ＡＰＩリスト

クッキーライブラリ

概要

クッキーに対するアクセス関数群

ソースファイル

imart/csjs/im_cookie.js

(URLの関係で呼び出し時のソースパスは変わります。スクリプト開発モデルの場合は、csjs/im_cookie.js でリンクできます。)

構造図

      getCookie()
      removeCookie()
      setCookie()

      使用例

使用例

プレゼンテーション・ページで
<SCRIPT src="csjs/im_cookie.js"></SCRIPT>

<SCRIPT language="JavaScript1.2">
// クッキーに "ABC" というキーで "XYZ" というデータを保存
setCookie("ABC", "XYZ");
// クッキーから "ABC" というキーに該当するデータを取得
var sABC = getCookie("ABC");
// クッキーから "ABC" というキーに該当するデータを削除
removeCookie("ABC");
</SCRIPT>

詳細

getCookie()

  • 型

    文字列型関数
    (String) getCookie((String) sName) ;

  • 概要

    クッキーの値を取得する関数

  • 入力値

    sName：参照名称(文字列)

  • 返却値

    参照名称に対応した値

  • 詳細

    指定参照名称に該当するクッキー内に保存された値を返却します。
    指定参照名称で値を取得できなかった場合には、null 値が返されます。

removeCookie()

  • 型

    void 型関数
    (void) removeCookie( (String) sName) ;

  • 概要

    クッキーの値を消去する関数

  • 入力値

    sName：参照名称(文字列)

  • 返却値

    なし

  • 詳細

    クッキー内に保存されているデータのうち、指定の参照名に該当するデータを消去します。
    実際には、クッキーの有効期限を過去に設定し直す事によって、その値自体を無効とし、表面上見えない状態にしているだけです。

setCookie()

  • 型

    void 型関数
    (void) setCookie((String)sName, (String)sValue, [(Date)dExpires[, (String)sDomain[, (String)sPath[, (boolean)bSecure]]]]) ;

  • 概要

    クッキーに値を保存するメソッド

  • 入力値

    sName : 参照名称(必須)
    sValue : 値(必須)
    dExpires: 利用期限(任意)
    sDomain : 有効ドメイン(任意)
    sPath : 設定可能階層(任意)
    bSecure : セキュリティの有無(任意)

  • 返却値

    なし

  • 詳細

    指定のデータをクッキーに保存します。


ＡＰＩリスト

DATE ライブラリ

概要

日付（時間）データ操作関数群

ソースファイル

imart/csjs/im_date.js

(URLの関係で呼び出し時のソースパスは変わります。スクリプト開発モデルの場合は、csjs/im_date.js でリンクできます。)

構造図

      isDateData()
      isLeapYear()

      使用例

使用例

プレゼンテーション・ページで
<SCRIPT src="csjs/im_window.js"></SCRIPT>

<!-- ボタンを押すと、2002年02年29日が日付として正しいかどうか判定します -->
<INPUT type="button" onClick="alert(isDateData(2002, 02, 02));">>

詳細

isDateData()

  • 型

    真偽値型関数
    (boolean) isDateData((Number) nYear, (Number)nMonth, (Number)nDay, (Number)nHour, (Number)nMinutes, (Number)nSecond) ;

  • 概要

    日付として正しいかどうか判定します。

  • 入力値

    (number) nYear : 年(必須) (number) nMonth : 月(必須) (number) nDay : 日(必須) (number) nHour : 時間(任意) (number) nMinutes: 分(任意) (number) nSecond : 秒(任意)

  • 返却値

    指定の数値データが日付として正しい場合 true、そうでない場合false。

  • 詳細

    与えられた数値の組合わせが日付（および時間）を表す情報として正しいかどうかを判定します。この関数は、閏年の判定も行っているので、２月２９日に関しても正しく判定することができます。

isLeapYear()

  • 型

    真偽値型関数
    (boolean) isLeapYear((Number) nYear) ;

  • 概要

    指定の年が閏年かどうか判定します。

  • 入力値

    (number) nYear : 年(必須)

  • 返却値

    指定の年が閏年の場合 true、そうでない場合false。

  • 詳細

    与えられた数値を西暦年として閏年計算をします。


ＡＰＩリスト

イベントライブラリ

概要

イベントに関する関数群

ソースファイル

imart/csjs/im_event.js

(URLの関係で呼び出し時のソースパスは変わります。スクリプト開発モデルの場合は、csjs/im_event.js でリンクできます。)

構造図

      isDoubleClick()

      使用例

使用例

プレゼンテーション・ページで
    <HTML>

        <HEAD>

            <SCRIPT src="csjs/im_window.js"></SCRIPT>

            <SCRIPT language="JavaScript1.2">

                function chkClick(){

                    if(isDoubleClick()){

                        window.alert("WARNING: Double-click !!");

                    }

                }

            </SCRIPT>

        </HEAD>

        <BODY>

            <FORM>

                <INPUT type="button" onClick="chkClick();">

            </FORM>

        </BODY>

    </HTML>

詳細

isDoubleClick()

  • 型

    真偽値型関数
    (boolean) isDoubleClick() ;

  • 概要

    ダブルクリックされたかどうか判定します。

  • 入力値

    なし

  • 返却値

    ダブルクリックされたと判断された場合 true、そうでない場合 false。

  • 詳細

    直前に関数実行されてから一定時間（1/2秒）以内に再び関数呼び出しされた場合、ダブルクリックされたと判断して真値を返します。

    この関数は、JavaScript のタイマー機能を利用しています。まだ一度も関数実行されていない状態で関数呼び出しされた場合、タイマーにより時間計測します。時間計測している間に関数呼び出しされた場合、その呼び出し回数に関係なく必ず true を返します。

    タイマーによる時間計測を開始してから十分な時間（およそ1/2秒）経過するとフラグが解除されます。
    フラグが解除された状態で関数呼び出しされると、再びタイマーにより時間計測を開始して true を返します。時間計測中に関数呼び出しされた場合、false を返します。時間計測を開始して十分な時間（およそ1/2秒）が経過するとフラグが解除されます。

    以降、上記プロセスが関数呼び出しのたびに繰り替えされます。


ＡＰＩリスト

実数計算ライブラリ

概要

小数演算を可能にするオブジェクト。

ソースファイル

imart/csjs/im_realnumber.js

(URLの関係で呼び出し時のソースパスは変わります。スクリプト開発モデルの場合は、csjs/im_realnumber.js でリンクできます。)

構造図

    RealNumber
      ├ getAdd()
      ├ getDiv()
      ├ getMlt()
      ├ getSub()
      ├ get()
      └ toString()

      使用例

使用例

プレゼンテーション・ページで
<SCRIPT src="csjs/im_realnumber.js"></SCRIPT>

<SCRIPT language="JavaScript1.2">
//変数 oRN を 2.1 で初期化
var oRN = new RealNumber( 2.1 );
//加算 oRN + 0.9 を実行し、その数字データ(String)を取得する。
var nAns = oRN.getAdd(0.9).toString();
</SCRIPT>

詳細

RealNumber(nTarget)

  • 型

    コンストラクター・メソッド
    (Object) RealNumber( (number) nTarget) ;

  • 概要

    指定の数値を表すインスタンスを生成

  • 入力値

    第1引数：数値

  • 詳細

    引数に指定した数値を表す実数オブジェクトのインスタンスを生成する。

getAdd(nTarget)

  • 型

    Object型メソッド
    (Object) getAdd( (number) nTarget) ;

  • 概要

    オブジェクトの持つ数値データと加法演算するメソッド

  • 入力値

    第1引数：演算数値

  • 返却値

    RealNumber

  • 詳細

    このオブジェクトのもつ数値と足し算をしする。
    返却値は新たなインスタンスを生成して返すので、もとの オブジェクト自体の値は変化しない。

getDiv(nTarget)

  • 型

    Object型メソッド
    (Object) getDiv( (number) nTarget) ;

  • 概要

    オブジェクトの持つ数値データと除法演算するメソッド

  • 入力値

    第1引数：演算数値

  • 返却値

    RealNumber

  • 詳細

    このオブジェクトのもつ数値と割り算する。
    返却値は新たなインスタンスを生成して返すので、もとの オブジェクト自体の値は変化しない。

getMlt(nTarget)

  • 型

    Object型メソッド
    (Object) getMlt(nTarget) ;

  • 概要

    オブジェクトの持つ数値データと乗法演算するメソッド

  • 入力値

    第1引数：演算数値

  • 返却値

    RealNumber

  • 詳細

    このオブジェクトのもつ数値と掛け算をしする。
    返却値は新たなインスタンスを生成して返すので、もとの オブジェクト自体の値は変化しない。

getSub(nTarget)

  • 型

    Object型メソッド
    (Object) getSub(nTarget) ;

  • 概要

    オブジェクトの持つ数値データと減法演算するメソッド

  • 入力値

    第1引数：演算数値

  • 返却値

    RealNumber

  • 詳細

    このオブジェクトのもつ数値と引き算をする。
    返却値は新たなインスタンスを生成して返すので、もとの オブジェクト自体の値は変化しない。

toString()

  • 型

    String型メソッド
    (String) toString() ;

  • 概要

    オブジェクトの持つ数値データを文字列として取得するメソッド

  • 入力値

    第1引数：なし

  • 返却値

    数値データ（文字列）

  • 詳細

    このオブジェクトのもつ数値情報を文字列で返す。

get()

  • 型

    Number型メソッド
    (Number) get() ;

  • 概要

    オブジェクトの持つ数値データを取得するメソッド

  • 入力値

    第1引数：なし

  • 返却値

    数値データ

  • 詳細

    このオブジェクトのもつ数値情報を返す。


ＡＰＩリスト

ウィンドウライブラリ

概要

ウィンドウ操作関数群

ソースファイル

imart/csjs/im_window.js

(URLの関係で呼び出し時のソースパスは変わります。スクリプト開発モデルの場合は、csjs/im_window.js でリンクできます。)

構造図

      openNewWindow()

      使用例

使用例

プレゼンテーション・ページで
<SCRIPT src="csjs/im_window.js"></SCRIPT>

<SCRIPT language="JavaScript1.2">
// 名称が "MY_WIN" というウィンドウを新規に立ちあげる
openNewWindow("MY_WIN", "status=yes,resizable=yes");
</SCRIPT>

詳細

openNewWindow()

  • 型

    オブジェクト型関数
    (Object) openNewWindow((String) name, (String) status) ;

  • 概要

    新しいウィンドウを開く関数

  • 入力値

    name：ウィンドウ参照名称(必須)
    status：ウィンドウ・ステータス(必須)

  • 返却値

    新規に開いたウィンドウのハンドル(Window オブジェクト)

  • 詳細

    指定された条件で新しいウィンドウを開きます。
    この関数は、window.open() と同等の振る舞いをします。引数 status には、window.open() ＡＰＩの第３引数に与える引数と同様の文字列データ(詳細は、JavaScript のリファレンスを参照して下さい)を渡して下さい。
    この関数は、JavaScript の window.open() と等しい値を返します。

    指定された参照名で、すでにウィンドウが開かれている場合、新規ウィンドウが開かれない場合があります。

    この関数を利用して開いたウィンドウには、『Please wait...』という画面が表示されます。


インタフェース jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity の使用 (javadoc_entire 6.1.14 API)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity の使用

MultipartFormData.Entity を使用しているパッケージ
jp.co.intra_mart.common.aid.javaee.http このパッケージには、ファイルをアップロードする際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.javaee.http での MultipartFormData.Entity の使用

MultipartFormData.Entity を返す jp.co.intra_mart.common.aid.javaee.http のメソッド
MultipartFormData.Entity | MultipartFormData.getEntity(int index) 指定のインデックスに該当するエンティティを取得します。
MultipartFormData.Entity | MultipartFormData.getEntity(String name) 指定の名前を持つエンティティを取得します。
MultipartFormData.Entity[] | MultipartFormData.getEntities(String name) 指定の名前を持つエンティティをすべて取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし
Copyright © 2000-2010 NTT DATA INTRAMART CO.,LTD.. All Rights Reserved.


クラス jp.co.intra_mart.common.aid.javaee.http.MultipartFormData の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.javaee.http.MultipartFormData の使用

jp.co.intra_mart.common.aid.javaee.http.MultipartFormData はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


MultipartFormData.Entity (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.javaee.http
インタフェース MultipartFormData.Entity

含まれているインタフェース:
MultipartFormData
public static interface MultipartFormData.Entity

フォームデータのエンティティです。

フォームから送信された情報を解析した結果の各エンティティは、 ヘッダ情報とデータで構成されます。

メソッドの概要
boolean | containsHeader(String name) 指定された文字列がヘッダの名称かどうかを判定します。
byte[] | getBytes() データ部をバイト配列として取得します。
String | getContent() データ部を文字列表現として取得します。
String | getContent(String enc) データ部を指定された文字コードで変換した結果を文字列表現として 取得します。
int | getContentLength() データ部をバイト長を取得します。
String | getFileName() アップロードされたファイルのファイル名を取得します。
String | getHeader(String name) ヘッダの取得。
String[] | getHeaderNames() ヘッダ名称一覧の取得。
InputStream | getInputStream() データ部を入力ストリームとして取得します。
String | getName() フォームのコントロール名称の取得。
Reader | getReader() 推奨されていません。 getReader(String) に置き換えられました。
Reader | getReader(String encoding) データ部を Reader として取得します。

メソッドの詳細

getName

public String getName()
フォームのコントロール名称の取得。

フォームから送信された情報のうち、このエンティティが表す情報の もととなったフォーム中に定義されたコントロールの名称を返します。

戻り値:
コントロール名称

getFileName

public String getFileName()
アップロードされたファイルのファイル名を取得します。

ファイルアップロードをしたリクエストではない場合は、null を返します。
Content-Disposition: form-data; name="ctrl_name"; filename="file_path"
ヘッダは、上記のような形式で受け取れる
ctrl_name: <INPUT type="file"> の name 属性
file_path: クライアントでのファイル名
ヘッダ情報は他にもあるが、上記の行のみを対象に解析を行う

戻り値:
String ファイル名

getHeaderNames

public String[] getHeaderNames()
ヘッダ名称一覧の取得。

このエンティティのもつヘッダ情報の名称一覧を返します。

戻り値:
ヘッダ名称の取得

getHeader

public String getHeader(String name)
ヘッダの取得。

返却値は、文字エンコーディングの変換が行われていない状態の文字列を返却します。 具体的には、javax.servlet.ServletRequest#getInputStream()を利用して リクエストの内容をバイト配列で取得し、それを「ISO-8859-1」で文字列化した内容が返却されます。

別のエンコーディングに変換する場合、以下のようなコードで変換する必要があります。

 byte[] rawData = entity.getHeader(headerName).getBytes("ISO-8859-1");
 String encodedValue = new String(rawData, request.getCharacterEncoding());

パラメータ:
name - ヘッダ名称
戻り値:
ヘッダ名称にマップされている値

containsHeader

public boolean containsHeader(String name)
指定された文字列がヘッダの名称かどうかを判定します。

パラメータ:
name - ヘッダ名称
戻り値:
ヘッダ名称が値にマップされている場合 true

getContentLength

public int getContentLength()
データ部をバイト長を取得します。

戻り値:
データのサイズ

getContent

public String getContent()
データ部を文字列表現として取得します。

入力されたバイトデータから文字列への変換には、Application Runtimeが稼動しているJavaVMの デフォルト文字エンコーディングを使います。

戻り値:
データ

getContent

public String getContent(String enc)
                  throws UnsupportedEncodingException
データ部を指定された文字コードで変換した結果を文字列表現として 取得します。

指定のエンコード名がサポートされていない場合 UnsupportedEncodingException がスローされます。

パラメータ:
enc - エンコード名
戻り値:
データ
例外:
UnsupportedEncodingException
関連項目:
UnsupportedEncodingException

getBytes

public byte[] getBytes()
データ部をバイト配列として取得します。

戻り値:
データ

getReader

public Reader getReader()
推奨されていません。 getReader(String) に置き換えられました。

データ部を Reader として取得します。

このReaderが文字に変換する際に使用する文字エンコーディングは、Application Runtimeが稼動している JavaVMのデフォルト文字エンコーディングです。

戻り値:
データ

getReader

public Reader getReader(String encoding)
データ部を Reader として取得します。

このReaderが文字に変換する際に使用する文字エンコーディングは、指定した文字エンコーディングです。

戻り値:
データ。エラーが発生した場合nullを返します。
導入されたバージョン:
6.1.12

getInputStream

public InputStream getInputStream()
データ部を入力ストリームとして取得します。

戻り値:
データ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MultipartFormData (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.javaee.http
クラス MultipartFormData

java.lang.Object
    拡張 java.util.AbstractCollection
        拡張 java.util.AbstractList
            拡張 java.util.ArrayList
                拡張 jp.co.intra_mart.common.aid.javaee.http.MultipartFormData
すべての実装インタフェース:
Cloneable, Collection, List, RandomAccess, Serializable
public class MultipartFormData
extends ArrayList

フォームから enctype が multipart/form-data で送信されてきた情報を 解析するオブジェクトです。

このオブジェクトは、ブラウザから multipart/form-data 形式でリクエストされた データを解析し、boundary で区切られた各情報(エンティティ)をMultipartFormData.Entity としてリストに保管します。

このクラスを利用する事により、ブラウザからサーバに対するファイルの アップロードなどが簡単に実装する事ができます。

留意点

intra-mart6.1.11から、アップロードされたファイルが指定した閾値を超えた場合、 メモリ上ではなく一時ファイルに書き出し、OutOfMemoryErrorの発生を抑えることが できるようになりました。内部では Apache Commons FileUpload を利用しています。

一時ファイルは、ガベージコレクタがMultiPartFormData.Entityを解放するタイミングで 削除されます。従いまして、MultiPartFormData.Entityが解放される前にintra-martが 停止すると一時ファイルは削除されません。

一時ファイルの格納先は、デフォルトではJavaのテンポラリフォルダ(java.io.tmpdir)です。 ファイル名は upload_ランダムな文字列.tmp です。

なお、アップロードされたファイルを常にメモリ上で扱う実装と一時ファイルに書き出す実装の切り替え、 一時ファイルの格納先、一時ファイルに書き出すかどうかの閾値を設定ファイルで指定することができます。 設定ファイルは、 %ApplicationRuntime%/doc/imart/WEB-INF/classes/jp/co/intra_mart/common/aid/javaee/http/MultipartFormData.properties です。

設定ファイルの内容はMultipartFormDataResourceBundleを参照してください。

関連項目:
直列化された形式

入れ子クラスの概要
static interface MultipartFormData.Entity
フォームデータのエンティティです。
フィールドの概要
クラス java.util.AbstractList から継承したフィールド
modCount
コンストラクタの概要
MultipartFormData(ServletRequest req)
リクエストされた情報を解析して、新しいオブジェクトを構築します。
MultipartFormData(ServletRequest req, IMFileItemFactory factory)
リクエストされた情報を解析して、新しいオブジェクトを構築します。
メソッドの概要
void | add(int index, Object element) リストの指定された位置に、指定された要素を挿入します。
boolean | add(Object o) リストの最後に、指定された要素を追加します。
boolean | addAll(Collection c) リストの末尾に、指定された Collection のすべての要素を追加します。
boolean | addAll(int index, Collection c) リスト内の指定された位置から、指定された Collection のすべての要素を挿入します。
void | clear() リストからすべての要素を削除します。
boolean | contains(Object elem) リストに指定の要素がある場合に true を返します。
boolean | containsAll(Collection c) このコレクション内に、指定されたコレクションのすべての要素がある場合に true を返します。
void | ensureCapacity(int minCapacity) 必要に応じて、この ArrayList のインスタンスのサイズを拡大し、少なくとも最小サイズ引数で指定された数の要素を格納できるようにします。
boolean | equals(Object o) 指定されたオブジェクトとリストが等しいかどうかを比較します。
Object | get(int index) リスト内の指定された位置にある要素を返します。
MultipartFormData.Entity[] | getEntities(String name) 指定の名前を持つエンティティをすべて取得します。
MultipartFormData.Entity | getEntity(int index) 指定のインデックスに該当するエンティティを取得します。
MultipartFormData.Entity | getEntity(String name) 指定の名前を持つエンティティを取得します。
int | hashCode() このリストのハッシュコード値を返します。
int | indexOf(Object elem) equals メソッドを使って等しいかどうかを判定しながら、指定された引数と同じ内容の要素を先頭から検索します。
boolean | isEmpty() リストに要素がないかどうかを判定します。
Iterator | iterator() このリスト内の要素を適切な順序で繰り返し処理する反復子を返します。
int | lastIndexOf(Object elem) 指定されたオブジェクトがリスト内で最後に現れるインデックスを返します。
ListIterator | listIterator() このリスト内の要素を適切な順序で繰り返し処理する反復子を返します。
ListIterator | listIterator(int index) リスト内の要素を適切な順序で繰り返し処理する、リスト内の指定された位置から開始する反復子を返します。
Object | remove(int index) リスト内の指定された位置から要素を削除します。
boolean | remove(Object o) 指定された要素のインスタンスがこのコレクションにあれば、そのインスタンスをコレクションから 1 つ削除します。
boolean | removeAll(Collection c) このコレクションから、指定されたコレクションに含まれる要素をすべて削除します。
boolean | retainAll(Collection c) このコレクションにおいて、指定されたコレクションに格納されている要素だけを保持します。
Object | set(int index, Object element) リストの指定された位置にある要素を、指定された要素で置き換えます。
int | size() リスト内にある要素の数を返します。
List | subList(int fromIndex, int toIndex) このリストの、fromIndex (これを含む) から toIndex (これを含まない) の範囲の部分のビューを返します。
Object[] | toArray() リスト内のすべての要素が正しい順序で格納されている配列を返します。
Object[] | toArray(Object[] a) リスト内のすべての要素が正しい順序で格納されている配列を返します。
void | trimToSize() この ArrayList のインスタンスのサイズをリストの現在のサイズに縮小します。
クラス java.util.ArrayList から継承したメソッド
clone, removeRange
クラス java.util.AbstractCollection から継承したメソッド
toString
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MultipartFormData

public MultipartFormData(ServletRequest req)
                  throws IOException,
                         IllegalArgumentException
リクエストされた情報を解析して、新しいオブジェクトを構築します。
multipart/form-data 形式のリクエストを解析します。

req が multipart/form-data で受信したリクエストではない場合、 IllegalArgumentException をスローします。

パラメータ:
req - サーブレットエンジンから渡されるリクエスト情報オブジェクト
例外:
IOException - リクエストデータ解析時の入出力エラー
IllegalArgumentException - 引数が不正の場合

MultipartFormData

public MultipartFormData(ServletRequest req,
                         IMFileItemFactory factory)
                  throws IOException,
                         IllegalArgumentException
リクエストされた情報を解析して、新しいオブジェクトを構築します。
multipart/form-data 形式のリクエストを解析します。

req が multipart/form-data で受信したリクエストではない場合、 IllegalArgumentException をスローします。

パラメータ:
req - サーブレットエンジンから渡されるリクエスト情報オブジェクト
factory - IMFileItemFactory のインスタンス
例外:
IOException - リクエストデータ解析時の入出力エラー
IllegalArgumentException - 引数が不正の場合
導入されたバージョン:
6.1.11
メソッドの詳細

getEntity

public MultipartFormData.Entity getEntity(int index)
指定のインデックスに該当するエンティティを取得します。

インデックスが範囲外の場合(インデックスが負または size() よりも大きい) IndexOutOfBoundsException をスローします。

パラメータ:
index - 返すエンティティのインデックス
戻り値:
リスト内の指定された位置にあるエンティティ

getEntity

public MultipartFormData.Entity getEntity(String name)
指定の名前を持つエンティティを取得します。

エンティティの名前とは、フォームのコントロール名称のことです。 指定の名前を持つエンティティが複数存在する場合、その中のいずれか一つが 返されます。 該当するエンティティが存在しない場合 null を返します。

戻り値:
指定の名前を持つエンティティ
関連項目:
MultipartFormData.Entity.getName()

getEntities

public MultipartFormData.Entity[] getEntities(String name)
指定の名前を持つエンティティをすべて取得します。

エンティティの名前とは、フォームのコントロール名称のことです。 該当するエンティティが存在しない場合、空の配列を返します。

戻り値:
指定の名前を持つエンティティ
関連項目:
MultipartFormData.Entity.getName()

add

public void add(int index,
                Object element)
リストの指定された位置に、指定された要素を挿入します。

add

public boolean add(Object o)
リストの最後に、指定された要素を追加します。

addAll

public boolean addAll(Collection c)
リストの末尾に、指定された Collection のすべての要素を追加します。

addAll

public boolean addAll(int index,
                      Collection c)
リスト内の指定された位置から、指定された Collection のすべての要素を挿入します。

clear

public void clear()
リストからすべての要素を削除します。

contains

public boolean contains(Object elem)
リストに指定の要素がある場合に true を返します。

containsAll

public boolean containsAll(Collection c)
このコレクション内に、指定されたコレクションのすべての要素がある場合に true を返します。

ensureCapacity

public void ensureCapacity(int minCapacity)
必要に応じて、この ArrayList のインスタンスのサイズを拡大し、少なくとも最小サイズ引数で指定された数の要素を格納できるようにします。

equals

public boolean equals(Object o)
指定されたオブジェクトとリストが等しいかどうかを比較します。

get

public Object get(int index)
リスト内の指定された位置にある要素を返します。

hashCode

public int hashCode()
このリストのハッシュコード値を返します。

indexOf

public int indexOf(Object elem)
equals メソッドを使って等しいかどうかを判定しながら、指定された引数と同じ内容の要素を先頭から検索します。

isEmpty

public boolean isEmpty()
リストに要素がないかどうかを判定します。

iterator

public Iterator iterator()
このリスト内の要素を適切な順序で繰り返し処理する反復子を返します。

lastIndexOf

public int lastIndexOf(Object elem)
指定されたオブジェクトがリスト内で最後に現れるインデックスを返します。

listIterator

public ListIterator listIterator()
このリスト内の要素を適切な順序で繰り返し処理する反復子を返します。

listIterator

public ListIterator listIterator(int index)
リスト内の要素を適切な順序で繰り返し処理する、リスト内の指定された位置から開始する反復子を返します。

remove

public Object remove(int index)
リスト内の指定された位置から要素を削除します。

remove

public boolean remove(Object o)
指定された要素のインスタンスがこのコレクションにあれば、そのインスタンスをコレクションから 1 つ削除します。

removeAll

public boolean removeAll(Collection c)
このコレクションから、指定されたコレクションに含まれる要素をすべて削除します。

retainAll

public boolean retainAll(Collection c)
このコレクションにおいて、指定されたコレクションに格納されている要素だけを保持します。

set

public Object set(int index,
                  Object element)
リストの指定された位置にある要素を、指定された要素で置き換えます。

size

public int size()
リスト内にある要素の数を返します。

subList

public List subList(int fromIndex,
                    int toIndex)
このリストの、fromIndex (これを含む) から toIndex (これを含まない) の範囲の部分のビューを返します。

toArray

public Object[] toArray()
リスト内のすべての要素が正しい順序で格納されている配列を返します。

toArray

public Object[] toArray(Object[] a)
リスト内のすべての要素が正しい順序で格納されている配列を返します。

trimToSize

public void trimToSize()
この ArrayList のインスタンスのサイズをリストの現在のサイズに縮小します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.javaee.http (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.common.aid.javaee.http
インタフェース
MultipartFormData.Entity
クラス
MultipartFormData
MultipartFormDataResourceBundle


jp.co.intra_mart.common.aid.javaee.http (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.javaee.http

このパッケージには、ファイルをアップロードする際に利用すると 便利な汎用クラスが含まれています。

参照:
説明

インタフェースの概要
MultipartFormData.Entity フォームデータのエンティティです。

クラスの概要
MultipartFormData | フォームから enctype が multipart/form-data で送信されてきた情報を 解析するオブジェクトです。
MultipartFormDataResourceBundle | MultipartFormDataの設定情報を扱うクラスです。

パッケージ jp.co.intra_mart.common.aid.javaee.http の説明

このパッケージには、ファイルをアップロードする際に利用すると 便利な汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.common.aid.javaee.http クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.javaee.http の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.util.AbstractCollection (implements java.util.Collection)
      • class java.util.AbstractList (implements java.util.List)
        • class java.util.ArrayList (implements java.lang.Cloneable, java.util.List, java.util.RandomAccess, java.io.Serializable)
          • class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData
    • class jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle

インタフェース階層

  • interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.common.aid.javaee.http の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.javaee.http の使用

jp.co.intra_mart.common.aid.javaee.http を使用しているパッケージ
jp.co.intra_mart.common.aid.javaee.http このパッケージには、ファイルをアップロードする際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.javaee.http により使用される jp.co.intra_mart.common.aid.javaee.http のクラス
MultipartFormData.Entity
フォームデータのエンティティです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream の使用

ExtendedInputStream を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での ExtendedInputStream の使用

ExtendedInputStream を返す jp.co.intra_mart.common.aid.jdk.java.net のメソッド
 ExtendedInputStream ExtendedSocket.getInputStream()
入力ストリームの取得。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream の使用

ExtendedOutputStream を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での ExtendedOutputStream の使用

ExtendedOutputStream を返す jp.co.intra_mart.common.aid.jdk.java.net のメソッド
 ExtendedOutputStream ExtendedSocket.getOutputStream()
出力ストリームの取得。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter の使用

jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader の使用

jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter の使用

jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.file.Directory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.file.Directory の使用

Directory を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.io.file | このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

jp.co.intra_mart.common.aid.jdk.java.io.file での Directory の使用

jp.co.intra_mart.common.aid.jdk.java.io.file での Directory のサブクラス
 class ExtendedDirectory
File インスタンスを作成するためのファクトリクラスです。

jp.co.intra_mart.foundation.service.provider での Directory の使用

jp.co.intra_mart.foundation.service.provider での Directory のサブクラス
 class HomeDirectory
このクラスは、サーバ実行システムのホームディレクトリに関する機能を 提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory の使用

ExtendedDirectory を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.io.file | このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

jp.co.intra_mart.common.aid.jdk.java.io.file での ExtendedDirectory の使用

ExtendedDirectory を返す jp.co.intra_mart.common.aid.jdk.java.io.file のメソッド
ExtendedDirectory | ExtendedDirectory.childDirectory(String path) このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
protected ExtendedDirectory | ExtendedDirectory.findDirectory(String path) このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。

jp.co.intra_mart.foundation.service.provider での ExtendedDirectory の使用

jp.co.intra_mart.foundation.service.provider での ExtendedDirectory のサブクラス
 class HomeDirectory
このクラスは、サーバ実行システムのホームディレクトリに関する機能を 提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile の使用

ExtendedFile を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.io.file このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.io.file での ExtendedFile の使用

ExtendedFile を返す jp.co.intra_mart.common.aid.jdk.java.io.file のメソッド
ExtendedFile | ExtendedDirectory.childFile(String path) このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
protected ExtendedFile | ExtendedDirectory.findFile(String path) このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Directory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io.file
クラス Directory

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory
すべての実装インタフェース:
Comparable, Serializable
直系の既知のサブクラス:
ExtendedDirectory
public class Directory
extends File

このクラスは、ディレクトリを扱う時に便利な機能を提供します。

このクラスは java.io.File クラスをベースに、オブジェクトが表す抽象パスが ディレクトリである場合に利用することができます。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
コンストラクタの概要
Directory(File parent, String child)
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
Directory(String pathname)
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
Directory(String parent, String child)
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
メソッドの概要
Collection | childDirectories() この抽象パス名が示すディレクトリにあるサブディレクトリの抽象パスを 繰り返し処理する反復子を作成します。
Collection | childFiles() この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
boolean | deleteAll() このディレクトリパスを削除します。
void | deleteChilds() このディレクトリが持つファイルまたはサブディレクトリをすべて削除します。
Collection | files(int depth) この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
Collection | paths(int depth) この抽象パス名が示すディレクトリにあるファイルおよびディレクトリの 抽象パスを繰り返し処理する反復子を作成します。
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Directory

public Directory(String pathname)
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。 指定された文字列が空の文字列の場合、結果は空の抽象パス名になります。

パラメータ:
pathname - パス名文字列
例外:
NullPointerException - pathname 引数が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合
関連項目:
File.File(File, String)

Directory

public Directory(File parent,
                 String child)
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。

parent が null の場合、新しい File のインスタンスは、 指定された child パス名文字列で単一引数の File コンストラクタを 呼び出したように生成されます。

そうでない場合、parent 抽象パス名はディレクトリを示し、 child パス名文字列はディレクトリまたはファイルを示します。 child パス名文字列が絶対の場合、 それはシステムに依存する方法で相対パス名に変換されます。 parent が空の抽象パス名の場合、新しい File のインスタンスは、 child を抽象パス名に変換し、その結果をシステムに依存する デフォルトディレクトリを基準に解決することで生成されます。 そうでない場合、各パス名文字列は抽象パス名に変換され、 子抽象パス名は親を基準に解決されます。

パラメータ:
parent - 親抽象パス名
child - 子パス名文字列
例外:
NullPointerException - child が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合
関連項目:
File.File(File, String)

Directory

public Directory(String parent,
                 String child)
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。

parent が null の場合、新しい File のインスタンスは、 指定された child パス名文字列で単一引数の File コンストラクタを 呼び出したように生成されます。 そうでない場合、parent パス名文字列はディレクトリを示し、 child パス名文字列はディレクトリまたはファイルを示します。 child パス名文字列が絶対の場合、 それはシステムに依存する方法で相対パス名に変換されます。 parent が空の文字列の場合、新しい File のインスタンスは、 child を抽象パス名に変換し、 その結果をシステムに依存するデフォルトディレクトリを基準に 解決することで生成されます。 そうでない場合、各パス名文字列は抽象パス名に変換され、 子抽象パス名は親を基準に解決されます。

パラメータ:
parent - 親パス名文字列
child - 子パス名文字列
例外:
NullPointerException - child が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合
関連項目:
File.File(File, String)
メソッドの詳細

childDirectories

public Collection childDirectories()
この抽象パス名が示すディレクトリにあるサブディレクトリの抽象パスを 繰り返し処理する反復子を作成します。 反復子が返す各要素は、ディレクトリを表す java.io.File クラスのインスタンスです。

戻り値:
ディレクトリパスを繰り返し処理する反復子

childFiles

public Collection childFiles()
この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。 反復子が返す各要素は、ファイルを表す java.io.File クラスのインスタンスです。

戻り値:
ファイルパスを繰り返し処理する反復子

deleteAll

public boolean deleteAll()
                  throws IOException
このディレクトリパスを削除します。 このディレクトリがファイルまたはサブディレクトリを持つ場合、 それらもすべて削除します。

このメソッドは複数のパスを削除しますが、すべてのパスを削除したか、 またはしないことを保証するものではありません。 このディレクトリパスの削除に失敗した場合でも、 このディレクトリに含まれるいくつかのパスが削除される場合があります。

戻り値:
このディレクトリパスの削除に成功した場合 true。それ以外の場合 false。
例外:
IOException - このディレクトリパスに含まれるいずれかのパスの削除に失敗した場合。

deleteChilds

public void deleteChilds()
                  throws IOException
このディレクトリが持つファイルまたはサブディレクトリをすべて削除します。 このサブディレクトリに含まれるファイルやサブディレクトリも 再帰的に検索し、すべて削除します。

このメソッドが false を返した場合でも、 いくつかのパスが削除される場合があります。

例外:
IOException - このディレクトリパスに含まれるいずれかのパスの削除に失敗した場合。

paths

public Collection paths(int depth)
この抽象パス名が示すディレクトリにあるファイルおよびディレクトリの 抽象パスを繰り返し処理する反復子を作成します。 反復子が返す各要素は、ファイルまたはディレクトリを表す java.io.File クラスのインスタンスです。

パラメータ:
depth - 検索をするサブディレクトリの深さ
戻り値:
ファイルパスを繰り返し処理する反復子
例外:
IllegalArgumentException - depth 引数が 1 よりも小さい場合

files

public Collection files(int depth)
この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。 反復子が返す各要素は、ファイルを表す java.io.File クラスのインスタンスです。

パラメータ:
depth - 検索をするサブディレクトリの深さ
戻り値:
ファイルパスを繰り返し処理する反復子
例外:
IllegalArgumentException - depth 引数が 1 よりも小さい場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedDirectory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io.file
クラス ExtendedDirectory

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory
すべての実装インタフェース:
Comparable, Serializable
直系の既知のサブクラス:
HomeDirectory
public class ExtendedDirectory
extends Directory

File インスタンスを作成するためのファクトリクラスです。

このクラスは、指定のディレクトリを親とすして、相対パスにより解決される 抽象パスを表す File インスタンスを生成する機能を提供します。 生成された File インスタンスは、オブジェクト内にプールされるため、 同じパスを繰り返し利用ようなプログラムで利用することにより、 メモリリソースを節約することができます。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
コンストラクタの概要
ExtendedDirectory(File parent, String path, int size)
File オブジェクトを作成するためのファクトリオブジェクトを作成します。
ExtendedDirectory(String pathname, int size)
File オブジェクトを作成するためのファクトリオブジェクトを作成します。
メソッドの概要
void | archive(File f) このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
void | archive(File f, FileFilter filter) このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
void | archive(OutputStream out) このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
void | archive(OutputStream out, FileFilter filter) このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
void | archive(ZipOutputStream out) このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
void | archive(ZipOutputStream out, FileFilter filter) このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
ExtendedDirectory | childDirectory(String path) このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
ExtendedFile | childFile(String path) このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
File | childPath(String path) このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
protected ExtendedDirectory | findDirectory(String path) このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
protected ExtendedFile | findFile(String path) このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
protected File | findPath(String path) このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
void | reset() キャッシュ領域をクリアします。
クラス jp.co.intra_mart.common.aid.jdk.java.io.file.Directory から継承したメソッド
childDirectories, childFiles, deleteAll, deleteChilds, files, paths
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtendedDirectory

public ExtendedDirectory(String pathname,
                         int size)
File オブジェクトを作成するためのファクトリオブジェクトを作成します。

このオブジェクトは、File インスタンスのプール機能を実装しています。 引数 size はプールのサイズを指定して下さい。プールは、最大で size 個のインスタンスをキャッシュするように動作します。

パラメータ:
pathname - ディレクトリパス
size - キャッシュサイズ
例外:
NullPointerException - 引数 parent が null の場合
IllegalArgumentException - 引数 size が 1 よりも小さい場合

ExtendedDirectory

public ExtendedDirectory(File parent,
                         String path,
                         int size)
File オブジェクトを作成するためのファクトリオブジェクトを作成します。

このオブジェクトは、File インスタンスのプール機能を実装しています。 このオブジェクトのパスは、parent を親ディレクトリとした 子抽象パス path により解決されます。
引数 size はプールのサイズを指定して下さい。プールは、最大で size 個のインスタンスをキャッシュするように動作します。

パラメータ:
parent - 親ディレクトリ
path - パス
size - キャッシュサイズ
例外:
NullPointerException - 引数 parent が null の場合
IllegalArgumentException - 引数 size が 1 よりも小さい場合
メソッドの詳細

childFile

public ExtendedFile childFile(String path)
このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合

findFile

protected ExtendedFile findFile(String path)
このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。

このメソッドは、childFile メソッドが要求されたファイルオブジェクトを プールしていなかった場合に、新しいファイルオブジェクトを作成するために 呼び出します。 サブクラスは、このメソッドをオーバーライドすることにより、 ファイルインスタンスを任意に作成することができます。

このメソッドは、単純にこのオブジェクトを親ディレクトリとして 引数 path を解決したファイルオブジェクトを作成して返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合

childDirectory

public ExtendedDirectory childDirectory(String path)
このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。 このメソッドは、このオブジェクトのプール許容値と等しい プール許容値を持つ ExtendedDirectory のインスタンスを返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合

findDirectory

protected ExtendedDirectory findDirectory(String path)
このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。

このメソッドは、childDirectory メソッドが要求されたファイルオブジェクトを プールしていなかった場合に、新しいファイルオブジェクトを作成するために 呼び出します。 サブクラスは、このメソッドをオーバーライドすることにより、 ファイルインスタンスを任意に作成することができます。

このメソッドは、単純にこのオブジェクトを親ディレクトリとして 引数 path を解決したファイルオブジェクトを作成して返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合

childPath

public File childPath(String path)
このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合

findPath

protected File findPath(String path)
このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。

このメソッドは、childPath メソッドが要求されたファイルオブジェクトを プールしていなかった場合に、新しいファイルオブジェクトを作成するために 呼び出します。 サブクラスは、このメソッドをオーバーライドすることにより、 ファイルインスタンスを任意に作成することができます。

このメソッドは、単純にこのオブジェクトを親ディレクトリとして 引数 path を解決したファイルオブジェクトを作成して返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合

reset

public void reset()
キャッシュ領域をクリアします。

archive

public void archive(File f)
             throws IOException
このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。 作成されるファイルは、ZIP ファイル形式となります。

パラメータ:
f - 出力ファイルパス
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(File f,
                    FileFilter filter)
             throws IOException
このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。 作成されるファイルは、ZIP ファイル形式となります。 ファイルに出力されるファイルは、フィルタの基準を満たす必要があります。 圧縮されるファイルは、 FileFilter.accept(java.io.File) メソッドが呼び出されたときに true が返される場合だけです。

パラメータ:
f - 出力ファイルパス
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(OutputStream out)
             throws IOException
このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。

パラメータ:
out - 出力ストリーム
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(OutputStream out,
                    FileFilter filter)
             throws IOException
このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。 ストリームに出力されるファイルは、フィルタの基準を満たす必要があります。 ストリームにファイルの内容が出力されるのは、 FileFilter.accept(java.io.File) メソッドが呼び出されたときに true が返される場合だけです。

パラメータ:
out - 出力ストリーム
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(ZipOutputStream out)
             throws IOException
このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。

パラメータ:
out - 出力ストリーム
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(ZipOutputStream out,
                    FileFilter filter)
             throws IOException
このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。 ストリームに出力されるファイルは、フィルタの基準を満たす必要があります。 ストリームにファイルの内容が出力されるのは、 FileFilter.accept(java.io.File) メソッドが呼び出されたときに true が返される場合だけです。

パラメータ:
out - 出力ストリーム
filter - ファイル名フィルタ
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedFile (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io.file
クラス ExtendedFile

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile
すべての実装インタフェース:
Comparable, Serializable
public class ExtendedFile
extends File

このクラスは、ファイルを扱う時に便利な機能を提供します。

このクラスは java.io.File クラスをベースに、オブジェクトが表す抽象パスが ファイルである場合に利用することができます。

導入されたバージョン:
version 5.0
関連項目:
File, ExtendedDirectory, 直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
コンストラクタの概要
ExtendedFile(File parent, String child)
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
ExtendedFile(String pathname)
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
ExtendedFile(String parent, String child)
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
メソッドの概要
void | append(byte[] b) 指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
void | append(String str) デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
void | append(String str, String enc) 指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
byte[] | getBytes() この抽象パスが表すファイルからデータを読み込みます。
Iterator | readLines() ファイルの行を繰り返し処理する反復子を作成します。
Iterator | readLines(String enc) ファイルの行を繰り返し処理する反復子を作成します。
String | readString() このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
String | readString(String enc) このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
void | write(byte[] b) 指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
void | write(String str) デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
void | write(String str, String enc) 指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtendedFile

public ExtendedFile(String pathname)
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。 指定された文字列が空の文字列の場合、結果は空の抽象パス名になります。

パラメータ:
pathname - パス名文字列
例外:
NullPointerException - pathname 引数が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合
関連項目:
File.File(File, String)

ExtendedFile

public ExtendedFile(File parent,
                    String child)
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。

parent が null の場合、新しい File のインスタンスは、 指定された child パス名文字列で単一引数の File コンストラクタを 呼び出したように生成されます。

そうでない場合、parent 抽象パス名はディレクトリを示し、 child パス名文字列はディレクトリまたはファイルを示します。 child パス名文字列が絶対の場合、 それはシステムに依存する方法で相対パス名に変換されます。 parent が空の抽象パス名の場合、新しい File のインスタンスは、 child を抽象パス名に変換し、その結果をシステムに依存する デフォルトディレクトリを基準に解決することで生成されます。 そうでない場合、各パス名文字列は抽象パス名に変換され、 子抽象パス名は親を基準に解決されます。

パラメータ:
parent - 親抽象パス名
child - 子パス名文字列
例外:
NullPointerException - child が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合
関連項目:
File.File(File, String)

ExtendedFile

public ExtendedFile(String parent,
                    String child)
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。

parent が null の場合、新しい File のインスタンスは、 指定された child パス名文字列で単一引数の File コンストラクタを 呼び出したように生成されます。 そうでない場合、parent パス名文字列はディレクトリを示し、 child パス名文字列はディレクトリまたはファイルを示します。 child パス名文字列が絶対の場合、 それはシステムに依存する方法で相対パス名に変換されます。 parent が空の文字列の場合、新しい File のインスタンスは、 child を抽象パス名に変換し、 その結果をシステムに依存するデフォルトディレクトリを基準に 解決することで生成されます。 そうでない場合、各パス名文字列は抽象パス名に変換され、 子抽象パス名は親を基準に解決されます。

パラメータ:
parent - 親パス名文字列
child - 子パス名文字列
例外:
NullPointerException - child が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合
関連項目:
File.File(File, String)
メソッドの詳細

getBytes

public byte[] getBytes()
                throws FileNotFoundException,
                       IOException
この抽象パスが表すファイルからデータを読み込みます。

戻り値:
ファイルの内容
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
IOException - 入出力エラーが発生した場合

readString

public String readString()
                  throws FileNotFoundException,
                         IOException
このオブジェクトの抽象パスが表すファイルからデータを読み込みます。

データはテキストとして扱い、デフォルトの文字エンコーディングから Unicode に変換して返します。

戻り値:
ファイルのデータ
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
IOException - 入出力エラーが発生した場合

readString

public String readString(String enc)
                  throws FileNotFoundException,
                         UnsupportedEncodingException,
                         IOException
このオブジェクトの抽象パスが表すファイルからデータを読み込みます。

データはテキストとして扱い、指定の文字エンコーディングから Unicode に変換して返します。

パラメータ:
enc - 文字エンコーディング名
戻り値:
ファイルのデータ
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
UnsupportedEncodingException - 指定の文字のエンコーディングがサポートされていない場合
IOException - 入出力エラーが発生した場合

readLines

public Iterator readLines()
                   throws FileNotFoundException,
                          IOException
ファイルの行を繰り返し処理する反復子を作成します。

データはテキストとして扱い、デフォルトの文字エンコーディングを使って Unicode に変換されます。 反復子が返す各要素は、ファイル内の 1 行のテキストです。 1 つの行は、改行 ('\n')、復帰 ('\r')、 または復帰とその直後に続く改行のどれかにより終了したと見なされます。

戻り値:
ファイルの行を繰り返し処理する反復子
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
IOException - 入出力エラーが発生した場合

readLines

public Iterator readLines(String enc)
                   throws FileNotFoundException,
                          UnsupportedEncodingException,
                          IOException
ファイルの行を繰り返し処理する反復子を作成します。

データはテキストとして扱い、指定の文字エンコーディングを使って Unicode に変換されます。 反復子が返す各要素は、ファイル内の 1 行のテキストです。 1 つの行は、改行 ('\n')、復帰 ('\r')、 または復帰とその直後に続く改行のどれかにより終了したと見なされます。

パラメータ:
enc - 文字エンコーディング名
戻り値:
ファイルの行を繰り返し処理する反復子
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
UnsupportedEncodingException - 指定の文字のエンコーディングがサポートされていない場合
IOException - 入出力エラーが発生した場合

write

public void write(String str)
           throws IOException
デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。

パラメータ:
str - 書き込む文字列
例外:
IOException - 入出力エラーが発生した場合

write

public void write(String str,
                  String enc)
           throws UnsupportedEncodingException,
                  IOException
指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。

パラメータ:
str - 書き込む文字列
enc - 使用するエンコーディングの名前
例外:
UnsupportedEncodingException - 指定の文字のエンコーディングがサポートされていない場合
IOException - 入出力エラーが発生した場合

append

public void append(String str)
            throws IOException
デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。

文字列は、ファイルの先頭ではなくファイルの最後に書き込まれます。 したがって、すでに存在するファイルに対して文字列を追記する場合に、 このメソッドを利用します。 このメソッドは、ファイルが存在しなかった場合、新しくファイルを 作成して文字列をファイルの先頭に書き込みます。

パラメータ:
str - 書き込む文字列
例外:
IOException - 入出力エラーが発生した場合

append

public void append(String str,
                   String enc)
            throws UnsupportedEncodingException,
                   IOException
指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。

文字列は、ファイルの先頭ではなくファイルの最後に書き込まれます。 したがって、すでに存在するファイルに対して文字列を追記する場合に、 このメソッドを利用します。 このメソッドは、ファイルが存在しなかった場合、新しくファイルを 作成して文字列をファイルの先頭に書き込みます。

パラメータ:
str - 書き込む文字列
enc - 使用するエンコーディングの名前
例外:
UnsupportedEncodingException - 指定の文字のエンコーディングがサポートされていない場合
IOException - 入出力エラーが発生した場合

append

public void append(byte[] b)
            throws IOException
指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。

バイトは、ファイルの先頭ではなくファイルの最後に書き込まれます。 したがって、すでに存在するファイルに対してバイトを追記する場合に、 このメソッドを利用します。 このメソッドは、ファイルが存在しなかった場合、新しくファイルを 作成してバイトをファイルの先頭に書き込みます。

パラメータ:
b - データ
例外:
IOException - 入出力エラーが発生した場合

write

public void write(byte[] b)
           throws IOException
指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。

パラメータ:
b - データ
例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.java.io.file (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.common.aid.jdk.java.io.file
クラス
Directory
ExtendedDirectory
ExtendedFile


jp.co.intra_mart.common.aid.jdk.java.io.file (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.io.file

このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

参照:
説明

クラスの概要
Directory | このクラスは、ディレクトリを扱う時に便利な機能を提供します。
ExtendedDirectory | File インスタンスを作成するためのファクトリクラスです。
ExtendedFile | このクラスは、ファイルを扱う時に便利な機能を提供します。

パッケージ jp.co.intra_mart.common.aid.jdk.java.io.file の説明

このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14


jp.co.intra_mart.common.aid.jdk.java.io.file クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.io.file の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.io.File (implements java.lang.Comparable, java.io.Serializable)
      • class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory
        • class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory
      • class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile


パッケージ jp.co.intra_mart.common.aid.jdk.java.io.file の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.java.io.file の使用

jp.co.intra_mart.common.aid.jdk.java.io.file を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.io.file | このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

jp.co.intra_mart.common.aid.jdk.java.io.file により使用される jp.co.intra_mart.common.aid.jdk.java.io.file のクラス
Directory
このクラスは、ディレクトリを扱う時に便利な機能を提供します。
ExtendedDirectory
File インスタンスを作成するためのファクトリクラスです。
ExtendedFile
このクラスは、ファイルを扱う時に便利な機能を提供します。

jp.co.intra_mart.foundation.service.provider により使用される jp.co.intra_mart.common.aid.jdk.java.io.file のクラス
Directory
このクラスは、ディレクトリを扱う時に便利な機能を提供します。
ExtendedDirectory
File インスタンスを作成するためのファクトリクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BASE64DecodeInputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス BASE64DecodeInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 java.io.FilterInputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream
public class BASE64DecodeInputStream
extends FilterInputStream

このクラスは、BASE64 エンコードされたデータを読み込むための ストリームフィルタを実装します。
入力ストリームより読み込まれたバイトは、BASE64 デコードされ read() メソッドにより返されます。

導入されたバージョン:
version 5.0
関連項目:
InputStream

フィールドの概要
クラス java.io.FilterInputStream から継承したフィールド
in
コンストラクタの概要
BASE64DecodeInputStream(InputStream in)
指定された InputStream から読み込む BASE64 デコード入力ストリームを作成します。
メソッドの概要
int | read() デコードデータのバイトを読み込みます。
int | read(byte[] b, int off, int len) 入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
クラス java.io.FilterInputStream から継承したメソッド
available, close, mark, markSupported, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BASE64DecodeInputStream

public BASE64DecodeInputStream(InputStream in)
指定された InputStream から読み込む BASE64 デコード入力ストリームを作成します。

パラメータ:
in - 入力ストリーム
メソッドの詳細

read

public int read()
         throws IOException
デコードデータのバイトを読み込みます。

このメソッドは、BASE64 のデコードに十分な入力が利用できるようになるまで ブロックします。

戻り値:
読み込まれたバイト。圧縮された入力の最後に達した場合は -1
例外:
IOException - 入出力エラーが発生した場合

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。 このメソッドは入力データが読み込み可能になるまでブロックします。

パラメータ:
b - データが読み込まれるバッファ
off - データの開始オフセット
len - 読み込むバイトの最大値
戻り値:
バッファに読み込まれたバイト数。ストリームの終わりに達して読み込むデータがない場合は -1
例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BASE64DecodeOutputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス BASE64DecodeOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream
public class BASE64DecodeOutputStream
extends FilterOutputStream

このクラスは、BASE64 デコードされたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、BASE64 デコードされ 基礎出力ストリームに書き込まれます。

導入されたバージョン:
version 5.0
関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
BASE64DecodeOutputStream(OutputStream out)
指定された OutputStream に書き込む BASE64デコーダーを作成します。
メソッドの概要
void | write(byte[] b, int off, int len) バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) バイトをデコードして出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
close, flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BASE64DecodeOutputStream

public BASE64DecodeOutputStream(OutputStream out)
指定された OutputStream に書き込む BASE64デコーダーを作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
バイトをデコードして出力ストリームに書き込みます。

このメソッドは、デコード結果が出力可能な 1 バイトのデータになるまで、 バッファに溜め込みます。 バッファに溜め込まれたデータは、flush メソッドや close メソッドを 実行しても基礎出力ストリームに書き出されることはありません。 バッファにデータが溜まった状態で、flush メソッドや close メソッドを 実行した場合、バッファ内のデータは破棄されます。

パラメータ:
b - 書き込まれるバイト
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が ASCII 文字の範囲に含まれない場合（ASCII のコントロールコードの場合も含む）や不正なコードが指定された場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。
このメソッドは、配列 b 内の off から len バイトについて、 int 型引数をひとつだけとる write メソッドを呼び出します。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BASE64EncodeOutputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス BASE64EncodeOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream
public class BASE64EncodeOutputStream
extends FilterOutputStream

このクラスは、BASE64 エンコードされたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、BASE64 エンコードされ 基礎出力ストリームに書き込まれます。

導入されたバージョン:
version 5.0
関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
BASE64EncodeOutputStream(OutputStream out)
指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。
BASE64EncodeOutputStream(OutputStream out, boolean isAppnendReturnCodePer76chars)
指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。
メソッドの概要
void | close() ストリームを閉じます。
void | finish() 出力ストリームへのエンコードデータの書き込みを終了します。
void | write(byte[] b, int off, int len) バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) バイトをエンコード出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BASE64EncodeOutputStream

public BASE64EncodeOutputStream(OutputStream out)
指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。

パラメータ:
out - 出力ストリーム

BASE64EncodeOutputStream

public BASE64EncodeOutputStream(OutputStream out,
                                boolean isAppnendReturnCodePer76chars)
指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。

パラメータ:
out - 出力ストリーム
isAppnendReturnCodePer76chars - 76文字ごとに改行コード(=LF)を追加する場合は true、 改行コードを追加しない場合は、 falseを指定してください。
メソッドの詳細

write

public void write(int b)
           throws IOException
バイトをエンコード出力ストリームに書き込みます。

このメソッドは、3 バイトのデータを受け取るとエンコードされたバイトを 出力ストリームに書き込みます。入力されたバイトが 3 バイトに満たない 場合は、入力されたバイトが合計で 3 バイトになるまでバッファに 溜め込みます。

パラメータ:
b - 書き込まれるバイト
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

finish

public void finish()
            throws IOException
出力ストリームへのエンコードデータの書き込みを終了します。

このときストリームは閉じられません。 複数のフィルタを同じ出力ストリームに連続して適用するときに このメソッドを使用します。

例外:
IOException - 入出力エラーが発生した場合

close

public void close()
           throws IOException
ストリームを閉じます。

ストリームを閉じ、これに関連するすべての システムリソースを解放します。 もし、このストリームがバッファ内に出力バイトを保持している場合、 それらを終端処理をして出力ストリームに強制的に書き込みます。
このメソッドは、finish メソッドを呼び出した後、 スーパークラス(java.io.FilterOutputStream)の close メソッドを呼び出します。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedInputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス ExtendedInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream
public class ExtendedInputStream
extends InputStream

このクラスは、標準の入力ストリームを拡張した機能を提供します。

このクラスは、jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream により 書き出されたストリームを読み込むための実装を提供します。
このクラスの各メソッドは、データをストリームから読み込むときに、 java.io.DataInputStream または java.io.ObjectInputStream の 適切なメソッドを使います。

データをストリームに書き出したときに使ったメソッドに対応した 適切なメソッドを利用することにより、データを読み込むことができます。

このクラスを jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream と対で使うことにより、 データをファイルに保存したり、ネットワークにより他のプロセスへ データを転送することができます。

jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream の writeObject メソッドにより 書き出されたオブジェクトは、readObject メソッドにより インスタンス化することができます。 この時、インスタンスに必要なクラスが存在している必要があります。

導入されたバージョン:
version 5.0

コンストラクタの概要
ExtendedInputStream(InputStream in)
入力ストリームを構築します。
ExtendedInputStream(InputStream in, ErrorEventListener listener)
入力ストリームを構築します。
メソッドの概要
void | close() 入出力ストリームおよびソケットを閉じます。
boolean | isClosed() この入出力ストリームが閉じられているかチェックします。
int | read() データ取得。
int | read(byte[] b, int off, int len) データ取得。
boolean | readBoolean() boolean 型データ取得。
int | readInt() int 型データ取得。
long | readLong() long 型データ取得。
Object | readObject() Object の取得。
String | readString() 文字列の取得。
クラス java.io.InputStream から継承したメソッド
available, mark, markSupported, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedInputStream

public ExtendedInputStream(InputStream in)
                    throws IOException
入力ストリームを構築します。

パラメータ:
in - 基礎入力ストリーム
例外:
IOException - 入出力ストリームの作成時エラー

ExtendedInputStream

public ExtendedInputStream(InputStream in,
                           ErrorEventListener listener)
                    throws IOException
入力ストリームを構築します。

パラメータ:
in - 基礎入力ストリーム
listener - エラーイベントのリスナーオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー
メソッドの詳細

read

public int read()
         throws IOException
データ取得。

入力ストリームから次のバイトのデータを取得します。

戻り値:
取得したバイトデータ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
InputStream.read(), ExtendedOutputStream.write(int)

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
データ取得。

入力ストリームから len バイトまでのデータをバイト配列に 読み込みます。

パラメータ:
b - バイト配列
off - データの開始オフセット
len - 読み込むバイト数
戻り値:
取得したバイト数
例外:
IOException - 入出力エラーが発生した場合
関連項目:
InputStream.read(byte[], int, int), ExtendedOutputStream.write(int)

readInt

public int readInt()
            throws IOException
int 型データ取得。

基本データ型の整数データを読み込みます。

戻り値:
int 型数値データ
例外:
EOFException - データ受信完了前にストリームの終わりに達した場合
IOException - 入出力エラーが発生した場合
関連項目:
DataInputStream.readInt(), ExtendedOutputStream.writeInt(int)

readLong

public long readLong()
              throws IOException
long 型データ取得。

基本データ型の長整数データを読み込みます。

戻り値:
long 型数値データ
例外:
EOFException - データ受信完了前にストリームの終わりに達した場合
IOException - 入出力エラーが発生した場合
関連項目:
DataInputStream.readLong(), ExtendedOutputStream.writeLong(long)

readBoolean

public boolean readBoolean()
                    throws IOException
boolean 型データ取得。

基本データ型の真偽値データを読み込みます。

戻り値:
long 型数値データ
例外:
EOFException - データ受信完了前にストリームの終わりに達した場合
IOException - 入出力エラーが発生した場合
関連項目:
DataInputStream.readBoolean(), ExtendedOutputStream.writeBoolean(boolean)

readObject

public Object readObject()
                  throws OptionalDataException,
                         ClassNotFoundException,
                         IOException
Object の取得。

戻り値:
入力して復元したオブジェクト
例外:
ClassNotFoundException - 直列化されたオブジェクトのクラスが見つからなかった場合
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
StreamCorruptedException - ストリームの制御情報に一貫性がない場合
OptionalDataException - プリミティブデータが、オブジェクトではなくストリームに見つかった場合
IOException - 通常の入出力関連の例外
関連項目:
ObjectInputStream.readObject(), ExtendedOutputStream.writeObject(Object)

readString

public String readString()
                  throws OptionalDataException,
                         ClassNotFoundException,
                         IOException
文字列の取得。

このメソッドは、jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream クラスの writeString メソッドを使って書き込んだデータを読み込むための メソッドです。他の方法で書き込んだデータを読み込むことはできません。

戻り値:
入力した文字列
例外:
ClassNotFoundException - 直列化されたオブジェクトのクラスが見つからなかった場合
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
StreamCorruptedException - ストリームの制御情報に一貫性がない場合
OptionalDataException - プリミティブデータが、オブジェクトではなくストリームに見つかった場合
IOException - 通常の入出力関連の例外
関連項目:
ExtendedOutputStream.writeString(String)

close

public void close()
           throws IOException
入出力ストリームおよびソケットを閉じます。
入出力ストリームを閉じる前にバッファに溜められているデータをすべて 出力ストリームに書き出します。

例外:
IOException - 入出力エラーが発生した場合

isClosed

public boolean isClosed()
この入出力ストリームが閉じられているかチェックします。

戻り値:
すでに閉じられている場合 true、そうでない場合 false。
関連項目:
close()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedOutputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス ExtendedOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream
public class ExtendedOutputStream
extends OutputStream

このクラスは、標準の出力ストリームを拡張した機能を提供します。

このクラスの各メソッドは、データをストリームに書き出すときに、 java.io.DataOutputStream または java.io.ObjectOutputStream の 適切なメソッドを使います。
writeObject メソッドを使ってオブジェクトをストリームに書き出す 場合、ストリームに書き込めるのは java.io.Serializable インタフェースを サポートするオブジェクトに限ります。それ以外のオブジェクトを ストリームに書き込もうとした場合、例外がスローされます。

この出力ストリームに書き込んだデータを入力する場合、 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream を利用する必要があります。 他の入力ストリームから読み込んだ場合例外がスローされることがあります。

導入されたバージョン:
version 5.0
関連項目:
ExtendedInputStream

コンストラクタの概要
ExtendedOutputStream(OutputStream out)
出力ストリームを構築します。
ExtendedOutputStream(OutputStream out, ErrorEventListener listener)
出力ストリームを構築します。
メソッドの概要
void | close() 入出力ストリームおよびソケットを閉じます。
void | flush() 書き出しストリーム内のデータをすべて出力。
boolean | isClosed() この入出力ストリームが閉じられているかチェックします。
void | write(byte[] b, int off, int len) オフセット off から始まる指定のバイト配列から この出力ストリームに len バイトを書き込みます。
void | write(int data) 指定されたバイトを書き込みます。
void | writeBoolean(boolean data) boolean 型データの送信。
void | writeInt(int data) int 型データの送信。
void | writeLong(long data) long 型データの送信。
void | writeObject(Object data) オブジェクトの送信。
void | writeString(String data) 文字列の送信。
クラス java.io.OutputStream から継承したメソッド
write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedOutputStream

public ExtendedOutputStream(OutputStream out)
                     throws IOException
出力ストリームを構築します。

パラメータ:
out - 基礎出力ストリーム
例外:
IOException - 入出力ストリームの作成時エラー

ExtendedOutputStream

public ExtendedOutputStream(OutputStream out,
                            ErrorEventListener listener)
                     throws IOException
出力ストリームを構築します。

パラメータ:
out - 基礎出力ストリーム
listener - エラーイベントのリスナーオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー
メソッドの詳細

write

public void write(int data)
           throws IOException
指定されたバイトを書き込みます。

パラメータ:
data - バイトデータ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
OutputStream.write(int), ExtendedInputStream.read()

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
オフセット off から始まる指定のバイト配列から この出力ストリームに len バイトを書き込みます。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラーが発生した場合
関連項目:
OutputStream.write(byte[],int,int), ExtendedInputStream.read()

writeInt

public void writeInt(int data)
              throws IOException
int 型データの送信。
基本データ型の整数データを基礎出力ストリームに書き込みます。

パラメータ:
data - データ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
DataOutputStream.writeInt(int), ExtendedInputStream.readInt()

writeLong

public void writeLong(long data)
               throws IOException
long 型データの送信。
基本データ型の長整数データを基礎出力ストリームに書き込みます。

パラメータ:
data - データ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
DataOutputStream.writeLong(long), ExtendedInputStream.readLong()

writeBoolean

public void writeBoolean(boolean data)
                  throws IOException
boolean 型データの送信。
基本データ型の真偽値データを基礎出力ストリームに書き込みます。

パラメータ:
data - データ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
DataOutputStream.writeBoolean(boolean), ExtendedInputStream.readBoolean()

writeObject

public void writeObject(Object data)
                 throws IOException
オブジェクトの送信。

java.io.Serializable インタフェースを実装している オブジェクトを基礎出力ストリームに書き込みます。
このメソッドはオブジェクトをストリームに書き込む際に、 java.io.ObjectOutputStream の writeObject メソッドを使います。

パラメータ:
data - オブジェクト
例外:
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
NotSerializableException - 直列化の対象が java.io.Serializable インタフェースを実装していない場合
IOException - 基礎の OutputStream に例外が発生した場合
関連項目:
ObjectOutputStream.writeObject(Object), Serializable, ExtendedInputStream.readObject()

writeString

public void writeString(String data)
                 throws IOException
文字列の送信。
このメソッドは、writeObject() メソッドを使い文字列をストリームに 書き込みます。 java.io.DataOutputStream や java.io.ObjectOutputStream の writeUTF メソッドとの違いは、ストリームに書き込める文字列の 長さに制約がないことです。

パラメータ:
data - ストリームに書き込む文字列
例外:
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
NotSerializableException - 直列化の対象が java.io.Serializable インタフェースを実装していない場合
IOException - 基礎の OutputStream に例外が発生した場合
関連項目:
DataOutputStream.writeUTF(String),
ObjectOutputStream.writeUTF(String),
ExtendedInputStream.readString()

flush

public void flush()
           throws IOException
書き出しストリーム内のデータをすべて出力。

例外:
IOException - 入出力エラーが発生した場合

close

public void close()
           throws IOException
入出力ストリームおよびソケットを閉じます。
入出力ストリームを閉じる前にバッファに溜められているデータをすべて 出力ストリームに書き出します。

例外:
IOException - 入出力エラーが発生した場合

isClosed

public boolean isClosed()
この入出力ストリームが閉じられているかチェックします。

戻り値:
すでに閉じられている場合 true、そうでない場合 false。
関連項目:
close()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HexInputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス HexInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream
public class HexInputStream
extends InputStream

このクラスは、16進数表現されたデータを読み込むための ストリームフィルタを実装します。
入力ストリームより読み込まれたバイトは、16進数表現からバイトに変換され read() メソッドにより返されます。

導入されたバージョン:
version 5.0
関連項目:
InputStream

フィールドの概要
protected  InputStream in
フィルタ処理される入力ストリームです。
コンストラクタの概要
HexInputStream(InputStream in)
指定された InputStream から読み込む HexInputStream を作成します。
メソッドの概要
void | close() ストリームを閉じます。
int | read() デコードデータのバイトを読み込みます。
クラス java.io.InputStream から継承したメソッド
available, mark, markSupported, read, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

in

protected InputStream in
フィルタ処理される入力ストリームです。

コンストラクタの詳細

HexInputStream

public HexInputStream(InputStream in)
指定された InputStream から読み込む HexInputStream を作成します。

パラメータ:
in - 入力ストリーム
メソッドの詳細

read

public int read()
         throws IOException,
                NumberFormatException
デコードデータのバイトを読み込みます。

２バイトの 16進数表現されたキャラクタデータを 読み込んで１バイトの数値として返します。 このメソッドは、２バイトの入力があるまでブロックします。

戻り値:
読み込まれたバイト。
例外:
IOException - 入出力エラーが発生した場合
NumberFormatException - 16進数として有効ではない文字を読み込んだ場合

close

public void close()
           throws IOException
ストリームを閉じます。

入力ストリームを閉じ、これに関連するすべての システムリソースを解放します。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HexOutputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス HexOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream
public class HexOutputStream
extends OutputStream

このクラスは、16進数表現されたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、16進数表現され 基礎出力ストリームに書き込まれます。
フィルタリングされた結果、基礎ストリームに書き込まれるデータは、 [0-9a-f] の範囲のキャラクタで構成されます。

導入されたバージョン:
version 5.0
関連項目:
OutputStream

フィールドの概要
protected  OutputStream out
フィルタ処理される基礎出力ストリームです。
コンストラクタの概要
HexOutputStream(OutputStream out)
指定された OutputStream に書き込む HexOutputStream を作成します。
メソッドの概要
void | close() ストリームを閉じます。
void | write(byte[] b, int off, int len) バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) バイトをエンコード出力ストリームに書き込みます。
クラス java.io.OutputStream から継承したメソッド
flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

out

protected OutputStream out
フィルタ処理される基礎出力ストリームです。

コンストラクタの詳細

HexOutputStream

public HexOutputStream(OutputStream out)
指定された OutputStream に書き込む HexOutputStream を作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
バイトをエンコード出力ストリームに書き込みます。

このメソッドは、バイトを上位４ビットと下位ビットに分け、 それぞれ16進数表現されたキャラクターコードに置き換えて、 計２バイトのデータを基礎ストリームに書き込みます。

パラメータ:
b - 書き込まれるバイト
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

close

public void close()
           throws IOException
ストリームを閉じます。

ストリームを閉じ、これに関連するすべての システムリソースを解放します。
もし、このストリームがバッファ内に出力バイトを保持している場合、 それらを終端処理をして出力ストリームに強制的に書き込みます。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MultipleOutputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス MultipleOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream
public class MultipleOutputStream
extends OutputStream

複数の出力ストリームにバイトを書き出すためのフィルタ実装です。

このフィルタを利用する事によって、 同じバイト情報を全く異なる複数の出力先へ、同時に書き出すことができます。

導入されたバージョン:
version 5.0

コンストラクタの概要
MultipleOutputStream()
唯一のコンストラクタ
メソッドの概要
void | addOutputStream(OutputStream output) メッセージの出力先を追加します。
void | close() このストリームを閉じます。
protected void | finalize() このオブジェクトをクリーンアップします。
void | flush() この出力ストリームをフラッシュします。
boolean | removeOutputStream(OutputStream output) メッセージの出力先を削除します。
void | write(byte[] b) 指定のバイトを 設定されている各出力先へ書き出します。
void | write(byte[] b, int off, int len) 指定のバイトを 設定されている各出力先へ書き出します。
void | write(int b) 指定のバイトを 設定されている各出力先へ書き出します。
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MultipleOutputStream

public MultipleOutputStream()
唯一のコンストラクタ

メソッドの詳細

addOutputStream

public void addOutputStream(OutputStream output)
メッセージの出力先を追加します。

パラメータ:
output - 出力ストリーム

removeOutputStream

public boolean removeOutputStream(OutputStream output)
メッセージの出力先を削除します。

パラメータ:
output - 出力ストリーム
戻り値:
削除に成功した場合は true。

write

public void write(int b)
           throws IOException
指定のバイトを 設定されている各出力先へ書き出します。

パラメータ:
b - バイト
例外:
IOException - 入出力エラー

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
指定のバイトを 設定されている各出力先へ書き出します。

パラメータ:
b - バイト
例外:
IOException - 入出力エラー

write

public void write(byte[] b)
           throws IOException
指定のバイトを 設定されている各出力先へ書き出します。

パラメータ:
b - バイト
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
この出力ストリームをフラッシュします。

まず、この出力ストリーム内のデータをフラッシュします。 その後、設定されている各出力先の OutputStream.flush() メソッドを 順に呼び出します。

例外:
IOException - 入出力エラー

close

public void close()
           throws IOException
このストリームを閉じます。

このメソッドは、自分をクローズ処理すると同時に基礎ストリームも閉じます。 設定されている各出力先の OutputStream.close() メソッドを 順に呼び出します。

例外:
IOException - 入出力エラー

finalize

protected void finalize()
                 throws Throwable
このオブジェクトをクリーンアップします。 このオブジェクトへの参照はもうないとガベージコレクションによって 判断されたときに、ガベージコレクタによって呼び出されます。

例外:
Throwable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.java.io (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.common.aid.jdk.java.io
クラス
BASE64DecodeInputStream
BASE64DecodeOutputStream
BASE64EncodeOutputStream
ExtendedInputStream
ExtendedOutputStream
HexInputStream
HexOutputStream
MultipleOutputStream
ReplaceWriter
TrimmedFilterReader
TrimmedFilterWriter
UnlimitedBufferedOutputStream
URLDecodeInputStream
URLDecodeOutputStream
URLEncodeOutputStream
XORInputStream
XOROutputStream


jp.co.intra_mart.common.aid.jdk.java.io (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.io

このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。

参照:
説明

クラスの概要
BASE64DecodeInputStream | このクラスは、BASE64 エンコードされたデータを読み込むための ストリームフィルタを実装します。
BASE64DecodeOutputStream | このクラスは、BASE64 デコードされたデータを書き込むための ストリームフィルタを実装します。
BASE64EncodeOutputStream | このクラスは、BASE64 エンコードされたデータを書き込むための ストリームフィルタを実装します。
ExtendedInputStream | このクラスは、標準の入力ストリームを拡張した機能を提供します。
ExtendedOutputStream | このクラスは、標準の出力ストリームを拡張した機能を提供します。
HexInputStream | このクラスは、16進数表現されたデータを読み込むための ストリームフィルタを実装します。
HexOutputStream | このクラスは、16進数表現されたデータを書き込むための ストリームフィルタを実装します。
MultipleOutputStream | 複数の出力ストリームにバイトを書き出すためのフィルタ実装です。
ReplaceWriter | このクラスは、部分文字列を別な部分文字列へ置換しながら ストリームに文字列を書き込むためのストリームフィルタを実装します。
TrimmedFilterReader | このクラスは、基礎となる java.io.Reader をフィルタリングした Writer 機能を提供します。
TrimmedFilterWriter | このクラスは、基礎となる java.io.Writer をフィルタリングした Writer 機能を提供します。
UnlimitedBufferedOutputStream | 出力データを一時的にバッファリングする出力ストリームの実装です。
URLDecodeInputStream | このクラスは、URL デコードされたデータを読み込むための ストリームフィルタを実装します。
URLDecodeOutputStream | このクラスは、URL デコードされたデータを書き込むための ストリームフィルタを実装します。
URLEncodeOutputStream | このクラスは、URL エンコードされたデータを書き込むための ストリームフィルタを実装します。
XORInputStream | このクラスは、指定されたバイトとの排他論理和計算された結果の データを読み込むためのストリームフィルタを実装します。
XOROutputStream | このクラスは、指定のバイトデータとの排他論理和を計算した結果の バイトデータを書き込むためのストリームフィルタを実装します。

パッケージ jp.co.intra_mart.common.aid.jdk.java.io の説明

このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
このパッケージには、java.io パッケージに含まれるクラスを拡張したものが多く含まれています。


jp.co.intra_mart.common.aid.jdk.java.io クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.io の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.io.InputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream
      • class java.io.FilterInputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream
    • class java.io.OutputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream
      • class java.io.FilterOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream
    • class java.io.Reader
      • class java.io.FilterReader
        • class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader
    • class java.io.Writer
      • class java.io.FilterWriter
        • class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter
      • class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter


パッケージ jp.co.intra_mart.common.aid.jdk.java.io の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.java.io の使用

jp.co.intra_mart.common.aid.jdk.java.io を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net により使用される jp.co.intra_mart.common.aid.jdk.java.io のクラス
ExtendedInputStream
このクラスは、標準の入力ストリームを拡張した機能を提供します。
ExtendedOutputStream
このクラスは、標準の出力ストリームを拡張した機能を提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ReplaceWriter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス ReplaceWriter

java.lang.Object
    拡張 java.io.Writer
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter
public class ReplaceWriter
extends Writer

このクラスは、部分文字列を別な部分文字列へ置換しながら ストリームに文字列を書き込むためのストリームフィルタを実装します。
置換対象となる部分文字列と置換する文字列の長さは同じ必要はありません。 置換対象となる文字データと異なる長さの文字データを置換後のデータとして 指定することも可能です。この場合、 このクラスによって基礎ストリームに書き込まれるデータ量は、 元のデータ量と変化します。

   java.io.StringWriter sw = new java.io.StringWriter();

   ReplaceWriter rw = new ReplaceWriter(sw, "abc", "xyz");

   rw.write("abc");
   String result = sw.toString();
文字データ "abc" は、"xyz" に変化します。この場合、以下のように 記述しても同様の結果が得られます。
   java.io.StringWriter sw = new java.io.StringWriter();

   ReplaceWriter rw = new ReplaceWriter(sw, "abc", "xyz");

   rw.write("a");
   rw.write("b");
   rw.write("c");
   String result = sw.toString();

導入されたバージョン:
version 5.0

フィールドの概要
クラス java.io.Writer から継承したフィールド
lock
コンストラクタの概要
ReplaceWriter(Writer out, char[] oldChars)
文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer out, char[] oldChars, char[] newChars)
文字列置換のためのストリームフィルタを作成します。
ReplaceWriter(Writer out, String oldString)
文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer out, String oldString, String newString)
文字列置換のためのストリームフィルタを作成します。
メソッドの概要
void | close() ストリームを閉じてフラッシュします。
void | finish() バッファに保存してあるデータを書き出します。
void | flush() ストリームをフラッシュします。
void | write(char[] cbuf, int off, int len) 文字列の一部を基礎ストリームに書き込みます。
void | write(int c) 単一文字を書き込みます。
クラス java.io.Writer から継承したメソッド
write, write, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ReplaceWriter

public ReplaceWriter(Writer out,
                     char[] oldChars)
文字列削除のためのストリームフィルタを作成します。
このインスタンスに書き込まれた文字データは部分文字列の削除を行いながら 基礎ストリームに書き込まれます。

パラメータ:
out - 基礎ストリーム
oldChars - 削除対象となる文字の配列

ReplaceWriter

public ReplaceWriter(Writer out,
                     String oldString)
文字列削除のためのストリームフィルタを作成します。
このインスタンスに書き込まれた文字データは部分文字列の削除を行いながら 基礎ストリームに書き込まれます。

パラメータ:
out - 基礎ストリーム
oldString - 削除対象となる文字列

ReplaceWriter

public ReplaceWriter(Writer out,
                     char[] oldChars,
                     char[] newChars)
文字列置換のためのストリームフィルタを作成します。
このインスタンスに書き込まれた文字データは適切な置換を行いながら 基礎ストリームに書き込まれます。

パラメータ:
out - 基礎ストリーム
oldChars - 置換対象となる文字の配列
newChars - 置換する文字の配列

ReplaceWriter

public ReplaceWriter(Writer out,
                     String oldString,
                     String newString)
文字列置換のためのストリームフィルタを作成します。

パラメータ:
out - 基礎ストリーム
oldString - 置換対象となる文字列
newString - 置換する文字列
メソッドの詳細

write

public void write(int c)
           throws IOException
単一文字を書き込みます。 書き込まれる文字は、指定された整数値の下位 16 ビットに格納されます。 上位 16 ビットは無視されます。

パラメータ:
c - 文字
例外:
IOException - 入出力エラーが発生した場合

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
文字列の一部を基礎ストリームに書き込みます。

パラメータ:
cbuf - 文字の配列
off - 文字の書き込み開始オフセット
len - 書き込む文字数
例外:
IOException - 入出力エラーが発生した場合

finish

public void finish()
            throws IOException
バッファに保存してあるデータを書き出します。

ストリームがさまざまな write() メソッドからの文字をバッファに 保存してある場合、これらの文字を基礎ストリームへただちに 書き込みます。
このメソッドは、このストリームの持つ置換対象データと比較中の 文字データを含むすべてのバッファを基礎ストリームに書き込みます。 このメソッドを呼び出し後は、write() メソッドによって与えられる データを改めて検索し直します。この機能のより、このストリームフィルタの 複数のストリームでの再利用が可能となります。

このときストリームは閉じられません。 複数のフィルタを同じ出力ストリームに連続して適用するときに このメソッドを使用します。

例外:
IOException - 入出力エラーが発生した場合

flush

public void flush()
           throws IOException
ストリームをフラッシュします。

現在バッファに保存されているデータが置換対象の文字データと 比較途中である場合、比較中のデータはフラッシュされません。 このストリームの持つすべてのバッファをフラッシュするためには、 finish() メソッドを呼び出したあとにこのメソッドを呼び出して下さい。
宛先が別の文字またはバイトストリームの場合は、 この宛先をフラッシュします。つまり 1 つの flush() の呼び出しで、 関連する Writer および OutputStream のすべてのバッファを フラッシュします。

例外:
IOException - 入出力エラーが発生した場合

close

public void close()
           throws IOException
ストリームを閉じてフラッシュします。
ストリームを一度閉じると、以降 write() または flush() を呼び出すと、 IOException がスローされます。 ただし、前に閉じたストリームを閉じても効果はありません。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TrimmedFilterReader (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス TrimmedFilterReader

java.lang.Object
    拡張 java.io.Reader
        拡張 java.io.FilterReader
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader
public class TrimmedFilterReader
extends FilterReader

このクラスは、基礎となる java.io.Reader をフィルタリングした Writer 機能を提供します。

フィルタ処理として、 文字入力ストリームから Java の基準に従った空白文字ではない文字を読み込みます。

導入されたバージョン:
Version 5.0

フィールドの概要
クラス java.io.FilterReader から継承したフィールド
in
クラス java.io.Reader から継承したフィールド
lock
コンストラクタの概要
TrimmedFilterReader(Reader in)
Reader をフィルタリングする新しい TrimmedFilterReader を作成します。
メソッドの概要
int | read() 単一の文字を読み込みます。
int | read(char[] cbuf, int off, int len) 配列の一部に文字を読み込みます。
クラス java.io.FilterReader から継承したメソッド
close, mark, markSupported, ready, reset, skip
クラス java.io.Reader から継承したメソッド
read
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

TrimmedFilterReader

public TrimmedFilterReader(Reader in)
Reader をフィルタリングする新しい TrimmedFilterReader を作成します。

パラメータ:
in - 基本となるストリームを提供する Reader オブジェクト
メソッドの詳細

read

public int read()
         throws IOException
単一の文字を読み込みます。

文字入力ストリームから読み込んだ文字が Java の基準に従った空白文字である場合に、 次の文字を読み込みを行います。

文字の値は 0 ～ 65535 (0x00-0xffff) の範囲の値をとる int として返されます。 ストリームの終わりに達して読み込むデータがない場合は -1 を返します。

このメソッドは、入力データが読み込めるようになるか、 ストリームの終わりが検出されるか、 または例外がスローされるまでブロックします。

戻り値:
0 ～ 65535 (0x00-0xffff) の範囲の整数としての、読み込まれた文字。ストリームの終わりに達した場合は -1
例外:
IOException - 入出力エラーが発生した場合
関連項目:
java.io.Reader#read()

read

public int read(char[] cbuf,
                int off,
                int len)
         throws IOException,
                NullPointerException
配列の一部に文字を読み込みます。

入力ストリームから len 文字数分の文字を指定された文字の配列に格納します。 実際に読み込まれた文字数は整数として返されます。

このメソッドは、入力データが読み込めるようになるか、 ファイルの終わりが検出されるか、 あるいは例外がスローされるまでブロックします。

文字の配列 cbuf が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 cbuf の長さより大きい場合は、 IndexOutOfBoundsException がスローされます。

len が 0 の場合は、文字が読み込まれず、0 が返されます。 そうでない場合は、Java の基準に従った空白文字でない 1 文字以上の読み込み処理が行われます。 ストリームがファイルの終わりに達しているために読み込む文字がない場合は、 値 -1 が返されます。 そうでない場合は、Java の基準に従った空白文字でない len 文字数分の文字が読み込まれ、 文字の配列 cbuf に格納されます。

すべての場合において、文字 cbuf[0] ～ cbuf[off] および文字 cbuf[off+len] ～ cbuf[b.length-1] は影響を受けません。

ファイルの終わりに達している以外の理由で最初のバイトが読み込めない場合は、 IOException がスローされます。 特に、入力ストリームが閉じている場合には IOException がスローされます。

このメソッドは、単純に read() メソッドを繰り返し呼び出します。 最初の呼び出しが IOException になる場合、 その例外は呼び出し側から read(cbuf, off, len) メソッドに返されます。 read() の以降の呼び出しが IOException になった場合、 その例外はファイルの終わりが検出された場合と同じようにキャッチおよび処理されます。 つまり、その時点までに読み込まれた文字は cbuf に格納され、 例外が発生するまでに読み込まれた文字数が返されます。

パラメータ:
cbuf - 転送先バッファ
off - 文字の格納開始オフセット
len - 読み込む文字の最大数
戻り値:
読み込まれた文字数。
例外:
IOException
NullPointerException
関連項目:
Reader.read(char[], int, int)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TrimmedFilterWriter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス TrimmedFilterWriter

java.lang.Object
    拡張 java.io.Writer
        拡張 java.io.FilterWriter
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter
public class TrimmedFilterWriter
extends FilterWriter

このクラスは、基礎となる java.io.Writer をフィルタリングした Writer 機能を提供します。

フィルタ処理として、 Java の基準に従った空白ではない文字を文字出力ストリームに書き込みます。

導入されたバージョン:
Version 5.0

フィールドの概要
クラス java.io.FilterWriter から継承したフィールド
out
クラス java.io.Writer から継承したフィールド
lock
コンストラクタの概要
TrimmedFilterWriter(Writer writer)
Writer をフィルタリングする新しい TrimmedFilterWriter を作成します。
メソッドの概要
void | write(char[] cbuf, int off, int len) 文字の配列の一部を書き込みます。
void | write(int c) 指定された文字が Java 空白文字でない場合に 単一文字を文字出力ストリームに書き込みます。
void | write(String str, int off, int len) 文字列の一部を書き込みます。
クラス java.io.FilterWriter から継承したメソッド
close, flush
クラス java.io.Writer から継承したメソッド
write, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

TrimmedFilterWriter

public TrimmedFilterWriter(Writer writer)
Writer をフィルタリングする新しい TrimmedFilterWriter を作成します。

パラメータ:
writer - 基本となる文字出力ストリームを提供する java.io.Writer オブジェクト
メソッドの詳細

write

public void write(String str,
                  int off,
                  int len)
           throws IOException
文字列の一部を書き込みます。 オフセット off から始まる指定の文字列 str から、 len 文字分を文字出力ストリームに書き込みます。
この処理は、

char[] strToCharArray = str.toCharArray(); 上の式のように文字列 str を新しい文字の配列 strToCharArray に変換して write(strToCharArray, off, len) を呼び出す場合とまったく同じです。

指定した文字の配列 str が null の場合は、NullPointerException がスローされます。

パラメータ:
str - 書き込まれる文字列
off - 文字の読み込み開始オフセット
len - 書き込む文字数
例外:
IOException - 入出力エラーが発生した場合

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
文字の配列の一部を書き込みます。

オフセット off から始まる指定の文字の配列 cbuf から、 len 文字分を文字出力ストリームに書き込みます。
この処理で最初に書き込まれる文字は要素 b[off] で、 最後に書き込まれる文字は要素 cbuf[off+len-1] です。

この処理では、書き込む文字ごとに write(int) のメソッドを呼び出します。 指定した文字の配列 cbuf が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 cbuf の長さより大きい場合は、 IndexOutOfBoundsException がスローされます。

パラメータ:
cbuf - 書き込む文字のバッファ
off - 文字の読み込み開始オフセット
len - 書き込む文字数
例外:
IOException - 入出力エラーが発生した場合

write

public void write(int c)
           throws IOException
指定された文字が Java 空白文字でない場合に 単一文字を文字出力ストリームに書き込みます。

書き込まれる文字は、指定された整数値の下位 16 ビットに格納されます。 上位 16 ビットは無視されます。

パラメータ:
c - 文字
例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UnlimitedBufferedOutputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス UnlimitedBufferedOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream
public class UnlimitedBufferedOutputStream
extends FilterOutputStream

出力データを一時的にバッファリングする出力ストリームの実装です。

このクラスは、 BufferedOutputStream と異なり、 flush() メソッドが呼び出されるまで、 すべてのバイトをメモリ中にバッファリングします。 したがって、明示的にフラッシュしなければ、データが出力される事は ありません。 逆に言うと、明示的にフラッシュするまですべてのデータをメモリ中に 保存する事になるため、大きなデータを扱う場合には十分な注意が必要です。

導入されたバージョン:
version 5.0

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
UnlimitedBufferedOutputStream(OutputStream out)
出力データをバッファリングするためのフィルター出力ストリームを 新しく作成します。
メソッドの概要
void | flush() この出力ストリームをフラッシュし、 バッファに入っている出力バイトをすべて強制的に書き込みます。
void | write(byte[] b) b.length バイトのデータを出力ストリームに書き込みます。
void | write(byte[] b, int off, int len) 指定された byte 配列の、オフセット位置 off から始まる len バイトを出力ストリームに書き込みます。
void | write(int b) 指定のバイトを出力します。
クラス java.io.FilterOutputStream から継承したメソッド
close
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UnlimitedBufferedOutputStream

public UnlimitedBufferedOutputStream(OutputStream out)
出力データをバッファリングするためのフィルター出力ストリームを 新しく作成します。

パラメータ:
out - 出力先ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
指定のバイトを出力します。

バイトは、flush()メソッドが呼び出されるまで、 オブジェクト内部のバッファに溜め込まれます。 バイトを基本となるストリームに書き込むためには、flush()メソッドを呼び出してください。

パラメータ:
b - バイト
例外:
IOException - 入出力エラー

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
指定された byte 配列の、オフセット位置 off から始まる len バイトを出力ストリームに書き込みます。

バイトは、flush()メソッドが呼び出されるまで、 オブジェクト内部のバッファに溜め込まれます。 バイトを基本となるストリームに書き込むためには、flush()メソッドを呼び出してください。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラー

write

public void write(byte[] b)
           throws IOException
b.length バイトのデータを出力ストリームに書き込みます。

バイトは、flush()メソッドが呼び出されるまで、 オブジェクト内部のバッファに溜め込まれます。 バイトを基本となるストリームに書き込むためには、flush()メソッドを呼び出してください。

パラメータ:
b - データ
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
この出力ストリームをフラッシュし、 バッファに入っている出力バイトをすべて強制的に書き込みます。

例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


URLDecodeInputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス URLDecodeInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 java.io.FilterInputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream
public class URLDecodeInputStream
extends FilterInputStream

このクラスは、URL デコードされたデータを読み込むための ストリームフィルタを実装します。
この入力ストリームに読み込まれたバイトは、URL デコードされ 基礎入力ストリームに読み込まれます。

導入されたバージョン:
version 5.0

フィールドの概要
クラス java.io.FilterInputStream から継承したフィールド
in
コンストラクタの概要
URLDecodeInputStream(InputStream in)
指定された InputStream から URL デコードしながらバイトを読み込む 入力ストリームを作成します。
メソッドの概要
int | read() デコードデータのバイトを読み込みます。
int | read(byte[] b, int off, int len) 入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
クラス java.io.FilterInputStream から継承したメソッド
available, close, mark, markSupported, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLDecodeInputStream

public URLDecodeInputStream(InputStream in)
指定された InputStream から URL デコードしながらバイトを読み込む 入力ストリームを作成します。

パラメータ:
in - 入力ストリーム
メソッドの詳細

read

public int read()
         throws IOException
デコードデータのバイトを読み込みます。

このメソッドは、BASE64 のデコードに十分な入力が利用できるようになるまで ブロックします。

戻り値:
読み込まれたバイト。圧縮された入力の最後に達した場合は -1
例外:
EOFException - デコード途中で入力が終了した場合
IOException - 入出力エラーが発生した場合

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。 このメソッドは入力データが読み込み可能になるまでブロックします。

パラメータ:
b - データが読み込まれるバッファ
off - データの開始オフセット
len - 読み込むバイトの最大値
戻り値:
バッファに読み込まれたバイト数。ストリームの終わりに達して読み込むデータがない場合は -1
例外:
EOFException - デコード途中で入力が終了した場合
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


URLDecodeOutputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス URLDecodeOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream
public class URLDecodeOutputStream
extends FilterOutputStream

このクラスは、URL デコードされたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、URL デコードされ 基礎出力ストリームに書き込まれます。

導入されたバージョン:
version 5.0
関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
URLDecodeOutputStream(OutputStream out)
指定された OutputStream に書き込む URLデコーダーを作成します。
メソッドの概要
void | write(byte[] b, int off, int len) バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) バイトをデコードして出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
close, flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLDecodeOutputStream

public URLDecodeOutputStream(OutputStream out)
指定された OutputStream に書き込む URLデコーダーを作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
バイトをデコードして出力ストリームに書き込みます。

このメソッドは、デコード結果が出力可能な 1 バイトのデータになるまで、 バッファに溜め込みます。 バッファに溜め込まれたデータは、flush メソッドや close メソッドを 実行しても基礎出力ストリームに書き出されることはありません。 バッファにデータが溜まった状態で、flush メソッドや close メソッドを 実行した場合、バッファ内のデータは破棄されます。

パラメータ:
b - 書き込まれるバイト
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。
このメソッドは、配列 b 内の off から len バイトについて、 int 型引数をひとつだけとる write メソッドを呼び出します。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


URLEncodeOutputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス URLEncodeOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream
public class URLEncodeOutputStream
extends FilterOutputStream

このクラスは、URL エンコードされたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、URL エンコードされ 基礎出力ストリームに書き込まれます。

導入されたバージョン:
version 5.0
関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
URLEncodeOutputStream(OutputStream out)
指定された OutputStream に書き込む BASE64デコーダーを作成します。
メソッドの概要
void | write(byte[] b, int off, int len) バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) バイトをデコードして出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
close, flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLEncodeOutputStream

public URLEncodeOutputStream(OutputStream out)
指定された OutputStream に書き込む BASE64デコーダーを作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
バイトをデコードして出力ストリームに書き込みます。

このメソッドは、デコード結果が出力可能な 1 バイトのデータになるまで、 バッファに溜め込みます。 バッファに溜め込まれたデータは、flush メソッドや close メソッドを 実行しても基礎出力ストリームに書き出されることはありません。 バッファにデータが溜まった状態で、flush メソッドや close メソッドを 実行した場合、バッファ内のデータは破棄されます。

パラメータ:
b - 書き込まれるバイト
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。
このメソッドは、配列 b 内の off から len バイトについて、 int 型引数をひとつだけとる write メソッドを呼び出します。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XORInputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス XORInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 java.io.FilterInputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream
public class XORInputStream
extends FilterInputStream

このクラスは、指定されたバイトとの排他論理和計算された結果の データを読み込むためのストリームフィルタを実装します。
入力ストリームより読み込まれたバイトは、 指定されたバイトデータとの排他論理和を計算した結果として read() メソッドにより返されます。

導入されたバージョン:
version 5.0
関連項目:
InputStream

フィールドの概要
クラス java.io.FilterInputStream から継承したフィールド
in
コンストラクタの概要
XORInputStream(InputStream in, int b)
指定された InputStream から指定されたバイトとの排他論理和を 取りながら読み込む XORInputStream を作成します。
メソッドの概要
int | read() デコードデータのバイトを読み込みます。
int | read(byte[] b, int off, int len) 入力ストリームからバイト配列へ最大 len バイトのデータを読み込みます。
クラス java.io.FilterInputStream から継承したメソッド
available, close, mark, markSupported, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

XORInputStream

public XORInputStream(InputStream in,
                      int b)
指定された InputStream から指定されたバイトとの排他論理和を 取りながら読み込む XORInputStream を作成します。

パラメータ:
in - 入力ストリーム
b - 排他論理和を取るためのバイト
メソッドの詳細

read

public int read()
         throws IOException,
                NumberFormatException
デコードデータのバイトを読み込みます。

２バイトの 16進数表現されたキャラクタデータを 読み込んで１バイトの数値として返します。 このメソッドは、２バイトの入力があるまでブロックします。

戻り値:
読み込まれたバイト。
例外:
IOException - 入出力エラーが発生した場合
NumberFormatException - 16進数として有効ではない文字を読み込んだ場合

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
入力ストリームからバイト配列へ最大 len バイトのデータを読み込みます。このメソッドは、入力が可能になるまでブロックします。

パラメータ:
b - データの読み込み先のバッファ
off - データの開始オフセット
len - 読み込まれる最大バイト数
戻り値:
バッファに読み込まれたバイトの合計数。ストリームの終わりに達してデータがない場合は -1
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XOROutputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス XOROutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream
public class XOROutputStream
extends FilterOutputStream

このクラスは、指定のバイトデータとの排他論理和を計算した結果の バイトデータを書き込むためのストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、指定のバイトデータとの 排他論理和を計算して、その結果のバイトデータが 基礎出力ストリームに書き込まれます。
フィルタリングされた結果、基礎ストリームに書き込まれるデータは、 同じバイトデータによって排他論理和を取ることにより、 もとのバイトデータに戻すことができます。

導入されたバージョン:
version 5.0
関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
XOROutputStream(OutputStream out, int b)
指定された OutputStream に対して b との排他論理和を取ったバイトデータを書き込む XOROutputStream を作成します。
メソッドの概要
void | write(byte[] b, int off, int len) バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) バイトをエンコード出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
close, flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

XOROutputStream

public XOROutputStream(OutputStream out,
                       int b)
指定された OutputStream に対して b との排他論理和を取ったバイトデータを書き込む XOROutputStream を作成します。

パラメータ:
out - 出力ストリーム
b - 排他論理和を取るためのバイト
メソッドの詳細

write

public void write(int b)
           throws IOException
バイトをエンコード出力ストリームに書き込みます。

パラメータ:
b - 書き込まれるバイト
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader の使用

ExtendedClassLoader を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.lang このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.lang での ExtendedClassLoader の使用

jp.co.intra_mart.common.aid.jdk.java.lang での ExtendedClassLoader のサブクラス
 class SearchableClassLoader
ユーティリティ的な実装を提供するクラスローダです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread の使用

jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader の使用

ResourceLoader を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.lang このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.lang での ResourceLoader の使用

jp.co.intra_mart.common.aid.jdk.java.lang での ResourceLoader のサブクラス
class | ExtendedClassLoader このクラスは、拡張されたクラスローダーです。
class | SearchableClassLoader ユーティリティ的な実装を提供するクラスローダです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.lang.SearchableClassLoader の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.lang.SearchableClassLoader の使用

jp.co.intra_mart.common.aid.jdk.java.lang.SearchableClassLoader はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の使用

jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownListener の使用

ShutdownListener を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.lang このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.lang での ShutdownListener の使用

ShutdownListener を返す jp.co.intra_mart.common.aid.jdk.java.lang のメソッド
static ShutdownListener[] ShutdownEventController.getShutdownListeners()
現在登録されているリスナを返します。

ShutdownListener 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.java.lang のメソッド
static void | ShutdownEventController.addListener(ShutdownListener listener) シャットダウンリスナーを登録します。
static boolean | ShutdownEventController.removeListener(ShutdownListener listener) シャットダウンリスナーを削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の使用

jp.co.intra_mart.common.aid.jdk.java.lang.StdErr はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の使用

jp.co.intra_mart.common.aid.jdk.java.lang.StdOut はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener の使用

ThreadStopListener を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.lang このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.lang での ThreadStopListener の使用

ThreadStopListener 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.java.lang のメソッド
 void ExtendedThread.addThreadStopListener(ThreadStopListener listener)
このスレッドが終了したときに呼び出されるイベントリスナーを登録します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.java.lang.ThrowablePrintListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.java.lang.ThrowablePrintListener の使用

ThrowablePrintListener を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.lang このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.lang での ThrowablePrintListener の使用

ThrowablePrintListener を返す jp.co.intra_mart.common.aid.jdk.java.lang のメソッド
static ThrowablePrintListener StdErr.getThrowablePrintListener()
現在の例外出力リスナを返します。

ThrowablePrintListener 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.java.lang のメソッド
static void StdErr.setThrowablePrintListener(ThrowablePrintListener listener)
指定の例外出力リスナを割り当て直します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ExtendedClassLoader (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
クラス ExtendedClassLoader

java.lang.Object
    拡張 java.lang.ClassLoader
        拡張 jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader
            拡張 jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader
直系の既知のサブクラス:
SearchableClassLoader
public class ExtendedClassLoader
extends ResourceLoader

このクラスは、拡張されたクラスローダーです。

このクラスローダーは、リソースを検索するパスを任意に追加することが できます。

導入されたバージョン:
version 5.0

コンストラクタの概要
ExtendedClassLoader()
このクラスをロードした ClassLoader を親クラスローダとして使用し、 新しいクラスローダを作成します。
ExtendedClassLoader(ClassLoader parent)
指定された親クラスローダを使って、 委譲のために新しいクラスローダを作成します。
メソッドの概要
void | addNativePath(File path) クラスパスを追加します。
protected Class | findClass(String name) 指定されたクラスを探します。
protected String | findLibrary(String libname) ネイティブライブラリの絶対パス名を返します。
File[] | getNativePaths() このクラスローダーに設定されているネイティブライブラリパスを返します。
クラス jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader から継承したメソッド
addClassArchive, addClassArchiveLibrary, addClassPath, findResource, findResources, getClassArchives, getClassPaths
クラス java.lang.ClassLoader から継承したメソッド
clearAssertionStatus, defineClass, defineClass, defineClass, definePackage, findLoadedClass, findSystemClass, getPackage, getPackages, getParent, getResource, getResourceAsStream, getResources, getSystemClassLoader, getSystemResource, getSystemResourceAsStream, getSystemResources, loadClass, loadClass, resolveClass, setClassAssertionStatus, setDefaultAssertionStatus, setPackageAssertionStatus, setSigners
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedClassLoader

public ExtendedClassLoader()
このクラスをロードした ClassLoader を親クラスローダとして使用し、 新しいクラスローダを作成します。

ExtendedClassLoader

public ExtendedClassLoader(ClassLoader parent)
指定された親クラスローダを使って、 委譲のために新しいクラスローダを作成します。

パラメータ:
parent - 親クラスローダー
メソッドの詳細

addNativePath

public void addNativePath(File path)
クラスパスを追加します。 ここで追加されるクラスパスは、このクラスローダー内でのみ有効です。
クラスローダーは、最も過去に追加されたパスから順に ネイティブリソースを検索していきます。 path が既に追加済みである場合、このメソッドは何も行いません。

パラメータ:
path - 追加するパス

getNativePaths

public File[] getNativePaths()
このクラスローダーに設定されているネイティブライブラリパスを返します。
このクラスローダーでは、このメソッドにより返されるパスと このクラスローダーの動作している環境からネイティブライブラリを検索しています。 このメソッドで返されるパスは、このクラスローダー固有に設定されている パスに限られます。

戻り値:
クラスパス
関連項目:
addNativePath(File), File

findLibrary

protected String findLibrary(String libname)
ネイティブライブラリの絶対パス名を返します。
VM はこのメソッドを呼び出して、このクラスローダでロードされたクラスに 属するネイティブライブラリを見つけます。 このメソッドが null を返す場合、VM は java.library.path プロパティで 指定されたパスにしたがってライブラリを検索します。

パラメータ:
libname - ライブラリ名
戻り値:
ネイティブライブラリの絶対パス

findClass

protected Class findClass(String name)
                   throws ClassNotFoundException
指定されたクラスを探します。
このメソッドは、クラスをロードするための新しい委譲モデルに準拠する クラスローダ実装によってオーバーライドされ、必要なクラスの 親クラスローダのチェック後に loadClass メソッドによって呼び出されます。 デフォルトの実装は ClassNotFoundException をスローします。

パラメータ:
name - クラス名
戻り値:
結果の Class オブジェクト
例外:
ClassNotFoundException - クラスが見つからなかった場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedThread (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
クラス ExtendedThread

java.lang.Object
    拡張 java.lang.Thread
        拡張 jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread
すべての実装インタフェース:
Runnable
public class ExtendedThread
extends Thread

To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates. To enable and disable the creation of type comments go to Window>Preferences>Java>Code Generation.

導入されたバージョン:
version 5.0

フィールドの概要
クラス java.lang.Thread から継承したフィールド
MAX_PRIORITY, MIN_PRIORITY, NORM_PRIORITY
コンストラクタの概要
ExtendedThread()
Constructor for ExtendedThread.
ExtendedThread(Runnable target)
Constructor for ExtendedThread.
ExtendedThread(Runnable target, String name)
Constructor for ExtendedThread.
ExtendedThread(String name)
Constructor for ExtendedThread.
ExtendedThread(ThreadGroup group, Runnable target)
Constructor for ExtendedThread.
ExtendedThread(ThreadGroup group, Runnable target, String name)
Constructor for ExtendedThread.
ExtendedThread(ThreadGroup group, String name)
Constructor for ExtendedThread.
メソッドの概要
void | addThreadStopListener(ThreadStopListener listener) このスレッドが終了したときに呼び出されるイベントリスナーを登録します。
void | fire() スレッド実行されるロジック。
void | run() このオブジェクトのスレッド実行ロジックです。
クラス java.lang.Thread から継承したメソッド
activeCount, checkAccess, countStackFrames, currentThread, destroy, dumpStack, enumerate, getContextClassLoader, getName, getPriority, getThreadGroup, holdsLock, interrupt, interrupted, isAlive, isDaemon, isInterrupted, join, join, join, resume, setContextClassLoader, setDaemon, setName, setPriority, sleep, sleep, start, stop, stop, suspend, toString, yield
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtendedThread

public ExtendedThread()
Constructor for ExtendedThread.

ExtendedThread

public ExtendedThread(Runnable target)
Constructor for ExtendedThread.

パラメータ:
target -

ExtendedThread

public ExtendedThread(ThreadGroup group,
                      Runnable target)
Constructor for ExtendedThread.

パラメータ:
group -
target -

ExtendedThread

public ExtendedThread(String name)
Constructor for ExtendedThread.

パラメータ:
name -

ExtendedThread

public ExtendedThread(ThreadGroup group,
                      String name)
Constructor for ExtendedThread.

パラメータ:
group -
name -

ExtendedThread

public ExtendedThread(Runnable target,
                      String name)
Constructor for ExtendedThread.

パラメータ:
target -
name -

ExtendedThread

public ExtendedThread(ThreadGroup group,
                      Runnable target,
                      String name)
Constructor for ExtendedThread.

パラメータ:
group -
target -
name -
メソッドの詳細

run

public final void run()
このオブジェクトのスレッド実行ロジックです。 このメソッドをサブクラスがオーバーライドすることはできません。 サブクラスがスレッド実行ロジックを定義するためには、fireメソッドを オーバーライドしてください。

fire

public void fire()
スレッド実行されるロジック。 Thread クラスを継承したサブクラスにおいて、通常 run メソッドに 記述する内容をこのメソッドに定義してください。

addThreadStopListener

public void addThreadStopListener(ThreadStopListener listener)
このスレッドが終了したときに呼び出されるイベントリスナーを登録します。

パラメータ:
listener - スレッド終了イベントリスナー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.java.lang (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.common.aid.jdk.java.lang
インタフェース
ShutdownListener
ThreadStopListener
ThrowablePrintListener
クラス
ExtendedClassLoader
ExtendedThread
ResourceLoader
SearchableClassLoader
ShutdownEventController
StdErr
StdOut


jp.co.intra_mart.common.aid.jdk.java.lang (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.lang

このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。

参照:
説明

インタフェースの概要
ShutdownListener | シャットダウンイベント時に実行する任意のロジックを実装するためのインターフェースです。
ThreadStopListener | To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates.
ThrowablePrintListener | このインタフェースは、例外情報を出力するためのものです。

クラスの概要
ExtendedClassLoader | このクラスは、拡張されたクラスローダーです。
ExtendedThread | To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates.
ResourceLoader | このクラスは、ローカルファイルシステムからリソースファイルを検索するクラスローダーの拡張実装です。
SearchableClassLoader | ユーティリティ的な実装を提供するクラスローダです。
ShutdownEventController | このクラスは、サーバプロセスの基礎ロジック。
StdErr | このクラスは、エラーメッセージ出力用です。
StdOut | このクラスは、システムメッセージ出力用です。

パッケージ jp.co.intra_mart.common.aid.jdk.java.lang の説明

このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。


jp.co.intra_mart.common.aid.jdk.java.lang クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.lang の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.ClassLoader
      • class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader
        • class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader
          • class jp.co.intra_mart.common.aid.jdk.java.lang.SearchableClassLoader
    • class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController
    • class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr
    • class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut
    • class java.lang.Thread (implements java.lang.Runnable)
      • class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread

インタフェース階層

  • interface jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownListener
  • interface jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener
  • interface jp.co.intra_mart.common.aid.jdk.java.lang.ThrowablePrintListener


パッケージ jp.co.intra_mart.common.aid.jdk.java.lang の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.java.lang の使用

jp.co.intra_mart.common.aid.jdk.java.lang を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.lang このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.lang により使用される jp.co.intra_mart.common.aid.jdk.java.lang のクラス
ExtendedClassLoader
このクラスは、拡張されたクラスローダーです。
ResourceLoader
このクラスは、ローカルファイルシステムからリソースファイルを検索するクラスローダーの拡張実装です。
ShutdownListener
シャットダウンイベント時に実行する任意のロジックを実装するためのインターフェースです。
ThreadStopListener
To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates.
ThrowablePrintListener
このインタフェースは、例外情報を出力するためのものです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ResourceLoader (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
クラス ResourceLoader

java.lang.Object
    拡張 java.lang.ClassLoader
        拡張 jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader
直系の既知のサブクラス:
ExtendedClassLoader
public class ResourceLoader
extends ClassLoader

このクラスは、ローカルファイルシステムからリソースファイルを検索するクラスローダーの拡張実装です。

このクラスローダーは、リソースを検索するパスを任意に追加することが できます。

導入されたバージョン:
version 5.0

コンストラクタの概要
ResourceLoader()
このクラスをロードした ClassLoader を親クラスローダとして使用し、 新しいクラスローダを作成します。
ResourceLoader(ClassLoader parent)
指定された親クラスローダを使って、 委譲のために新しいクラスローダを作成します。
メソッドの概要
void | addClassArchive(File path) クラスパスに指定のアーカイブファイルを追加します。
void | addClassArchiveLibrary(File path) クラスパスに指定のアーカイブファイル格納ディレクトリを追加します。
void | addClassPath(File path) クラスパスを追加します。
protected URL | findResource(String name) 指定された名前を持つリソースを探します。
protected Enumeration | findResources(String name) 指定された名前を持つすべてのリソースを表す URL の Enumeration を返します。
File[] | getClassArchives() このクラスローダーに設定されているクラスアーカイブパスを返します。
File[] | getClassPaths() このクラスローダーに設定されているクラスパスを返します。
クラス java.lang.ClassLoader から継承したメソッド
clearAssertionStatus, defineClass, defineClass, defineClass, definePackage, findClass, findLibrary, findLoadedClass, findSystemClass, getPackage, getPackages, getParent, getResource, getResourceAsStream, getResources, getSystemClassLoader, getSystemResource, getSystemResourceAsStream, getSystemResources, loadClass, loadClass, resolveClass, setClassAssertionStatus, setDefaultAssertionStatus, setPackageAssertionStatus, setSigners
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ResourceLoader

public ResourceLoader()
このクラスをロードした ClassLoader を親クラスローダとして使用し、 新しいクラスローダを作成します。

ResourceLoader

public ResourceLoader(ClassLoader parent)
指定された親クラスローダを使って、 委譲のために新しいクラスローダを作成します。

パラメータ:
parent - 親クラスローダー
メソッドの詳細

addClassPath

public void addClassPath(File path)
クラスパスを追加します。

ここで追加されるクラスパスは、このクラスローダー内でのみ有効です。
クラスローダーは、最も過去に追加されたパスから順に クラスを検索していきます。
path が既に追加済みである場合、このメソッドは何も行いません。

パラメータ:
path - 追加するパス

addClassArchive

public void addClassArchive(File path)
クラスパスに指定のアーカイブファイルを追加します。 ここで追加されるクラスパスは、このクラスローダー内でのみ有効です。
クラスローダーは、最も過去に追加されたパスから順に クラスを検索していきます。 path が既に追加済みである場合、このメソッドは何も行いません。

パラメータ:
path - 追加するパス

addClassArchiveLibrary

public void addClassArchiveLibrary(File path)
クラスパスに指定のアーカイブファイル格納ディレクトリを追加します。 ここで追加されるクラスパスは、このクラスローダー内でのみ有効です。
このメソッドは、path に含まれる jar または zip ファイルを検索し、 addClassArchive(File) を呼び出して このクラスローダの検索パスに追加します。

パラメータ:
path - 追加するパス

getClassPaths

public File[] getClassPaths()
このクラスローダーに設定されているクラスパスを返します。
このクラスローダーでは、このメソッドにより返されるパスと このクラスローダーの動作している環境からクラスを検索しています。 このメソッドで返されるパスは、このクラスローダー固有に設定されている パスに限られます。

戻り値:
クラスパス
関連項目:
addClassPath(File), File

getClassArchives

public File[] getClassArchives()
このクラスローダーに設定されているクラスアーカイブパスを返します。
このクラスローダーでは、このメソッドにより返されるパスと このクラスローダーの動作している環境からクラスを検索しています。 このメソッドで返されるパスは、このクラスローダー固有に設定されている パスに限られます。

戻り値:
クラスパス
関連項目:
addClassArchive(File), File

findResources

protected Enumeration findResources(String name)
                             throws IOException
指定された名前を持つすべてのリソースを表す URL の Enumeration を返します。

パラメータ:
name - リソース名
戻り値:
リソースの URL の Enumeration
例外:
IOException

findResource

protected URL findResource(String name)
指定された名前を持つリソースを探します。

パラメータ:
name - リソース名
戻り値:
リソースを読み込むための URL。リソースが見つからなかった場合は null
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SearchableClassLoader (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
クラス SearchableClassLoader

java.lang.Object
    拡張 java.lang.ClassLoader
        拡張 jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader
            拡張 jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader
                拡張 jp.co.intra_mart.common.aid.jdk.java.lang.SearchableClassLoader
public class SearchableClassLoader
extends ExtendedClassLoader

ユーティリティ的な実装を提供するクラスローダです。 通常のクラスローダとしても利用可能です。

コンストラクタの概要
SearchableClassLoader()
新しいクラスローダを生成します。
SearchableClassLoader(ClassLoader parent)
指定された親クラスローダを使って、委譲のために新しいクラスローダを作成します。
メソッドの概要
void | addSearchPath(File file) 指定されたパスがファイルを表している場合、jar または zip を指定されたと判断して、 ResourceLoader.addClassArchive(File)を呼び出します。
Class[] | getImplementedClasses(Class clazz) 指定されたクラスと代入互換のあるインスタンスを生成できるクラスを検索します。
クラス jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader から継承したメソッド
addNativePath, findClass, findLibrary, getNativePaths
クラス jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader から継承したメソッド
addClassArchive, addClassArchiveLibrary, addClassPath, findResource, findResources, getClassArchives, getClassPaths
クラス java.lang.ClassLoader から継承したメソッド
clearAssertionStatus, defineClass, defineClass, defineClass, definePackage, findLoadedClass, findSystemClass, getPackage, getPackages, getParent, getResource, getResourceAsStream, getResources, getSystemClassLoader, getSystemResource, getSystemResourceAsStream, getSystemResources, loadClass, loadClass, resolveClass, setClassAssertionStatus, setDefaultAssertionStatus, setPackageAssertionStatus, setSigners
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SearchableClassLoader

public SearchableClassLoader()
新しいクラスローダを生成します。 このコンストラクタは、スーパークラスのデフォルトコンストラクタを呼び出します。

例外:
SecurityException - セキュリティマネージャが存在し、その checkCreateClassLoader メソッドが新しいクラスローダの作成を許可しない場合

SearchableClassLoader

public SearchableClassLoader(ClassLoader parent)
指定された親クラスローダを使って、委譲のために新しいクラスローダを作成します。

パラメータ:
parent - 親のクラスローダ
例外:
SecurityException - セキュリティマネージャが存在し、その checkCreateClassLoader メソッドが新しいクラスローダの作成を許可しない場合
メソッドの詳細

addSearchPath

public void addSearchPath(File file)
指定されたパスがファイルを表している場合、jar または zip を指定されたと判断して、 ResourceLoader.addClassArchive(File)を呼び出します。 指定されたパスがディレクトリを表している場合、 ResourceLoader.addClassPath(File)および ResourceLoader.addClassArchiveLibrary(File)を呼び出します。

パラメータ:
file - クラスを検索するパス

getImplementedClasses

public Class[] getImplementedClasses(Class clazz)
                              throws ZipException,
                                     IOException,
                                     ClassNotFoundException
指定されたクラスと代入互換のあるインスタンスを生成できるクラスを検索します。 「代入互換がある」とは、以下のいずれかの条件をみたすクラスです。
  • 同一のクラスである
  • 継承している親クラスが指定したクラスと同一
  • 実装しているインタフェースが指定した（インタフェースを表す）クラスと同一

パラメータ:
clazz -
戻り値:
例外:
ZipException
IOException
ClassNotFoundException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ShutdownEventController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
クラス ShutdownEventController

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController
public class ShutdownEventController
extends Object

このクラスは、サーバプロセスの基礎ロジック。

導入されたバージョン:
version 4.0
関連項目:
ShutdownListener

メソッドの概要
static void | addListener(ShutdownListener listener) シャットダウンリスナーを登録します。
static ShutdownListener[] | getShutdownListeners() 現在登録されているリスナを返します。
static boolean | isShutdown() シャットダウン中（またはシャットダウン処理終了）かどうかを判定。
static boolean | removeListener(ShutdownListener listener) シャットダウンリスナーを削除します。
static void | shutdown() このプロセスを終了します。
static void | shutdown(int status) このプロセスを終了します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

addListener

public static void addListener(ShutdownListener listener)
シャットダウンリスナーを登録します。

パラメータ:
listener - イベントリスナーオブジェクト
例外:
IllegalStateException - すでにシャットダウン処理中
関連項目:
ShutdownListener

removeListener

public static boolean removeListener(ShutdownListener listener)
シャットダウンリスナーを削除します。

ただし、すでにシャットダウンフェーズに入ってしまっている場合は、 リスナーの削除に成功しても削除したリスナが実行されてしまう 可能性があります。

パラメータ:
listener - イベントリスナーオブジェクト
戻り値:
リストに、指定された要素が格納されている場合は true
関連項目:
ShutdownListener

getShutdownListeners

public static ShutdownListener[] getShutdownListeners()
現在登録されているリスナを返します。

戻り値:
登録されているリスナ

shutdown

public static void shutdown()
このプロセスを終了します。 このメソッドは、System.exit(0) と同様です。

導入されたバージョン:
version 4.0.1

shutdown

public static void shutdown(int status)
このプロセスを終了します。 引数はステータスコードとして作用します。 通例、ゼロ以外のステータスコードは異常終了を示します。 このメソッドは、正常に復帰することはありません。

パラメータ:
status - 終了のステータス
導入されたバージョン:
version 4.0.1

isShutdown

public static boolean isShutdown()
シャットダウン中（またはシャットダウン処理終了）かどうかを判定。

戻り値:
シャットダウン中（またはシャットダウン処理を終了したとみなされる）場合は、true。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ShutdownListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
インタフェース ShutdownListener

public interface ShutdownListener

シャットダウンイベント時に実行する任意のロジックを実装するためのインターフェースです。

このインターフェースを実装して ShutdownEventController クラスに登録する ことで、任意のロジックをシャットダウン直前に実行することができます。

導入されたバージョン:
version 5.0
関連項目:
ShutdownEventController

メソッドの概要
 void handleShutdown()
シャットダウンイベントが発生したときに実行されるメソッドです。

メソッドの詳細

handleShutdown

public void handleShutdown()
シャットダウンイベントが発生したときに実行されるメソッドです。 このメソッドを実装することで、 シャットダウン直前に任意のロジックを実行することができます。 このメソッドは、プロセスのシャットダウン直前に実行されるため、 必ずスレッドセーフであり、かつデッドロックしないように プログラムする必要があります。 このメソッド実行中の ShutdownEventController に対するリスナー登録は、 デッドロックの原因となるので、絶対にやってはいけません。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


StdErr (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
クラス StdErr

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.lang.StdErr
public class StdErr
extends Object

このクラスは、エラーメッセージ出力用です。

導入されたバージョン:
version 5.0

メソッドの概要
static void | addOutputStream(OutputStream out) メッセージの出力先を追加します。
static PrintStream | getDefaultPrintStream() このクラスがロードされた時点の、System.err を 返します。
static PrintStream | getPrintStream() メッセージを出力する出力ストリームを返します。
static ThrowablePrintListener | getThrowablePrintListener() 現在の例外出力リスナを返します。
static boolean | removeOutputStream(OutputStream out) メッセージの出力先を削除します。
static void | setThrowablePrintListener(ThrowablePrintListener listener) 指定の例外出力リスナを割り当て直します。
static void | write(String msg) 指定のメッセージを標準エラー出力および指定の出力先に書き出します。
static void | write(String msg, Throwable exception) 指定のメッセージを標準エラー出力および指定の出力先に書き出します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getDefaultPrintStream

public static PrintStream getDefaultPrintStream()
このクラスがロードされた時点の、System.err を 返します。

このメソッドのリターン値を引数にして、 removeOutputStream(OutputStream) を実行すると、 標準エラー出力（コンソール）にメッセージが表示されなくなります。

戻り値:
標準エラー出力にメッセージを書き出す出力ストリーム

getPrintStream

public static PrintStream getPrintStream()
メッセージを出力する出力ストリームを返します。

返された出力ストリームの PrintStream.close() メソッドを 実行してストリームを閉じてしまうと、以後メッセージを出力できなく なります。

戻り値:
出力ストリーム

addOutputStream

public static void addOutputStream(OutputStream out)
メッセージの出力先を追加します。

パラメータ:
out - 出力ストリーム

removeOutputStream

public static boolean removeOutputStream(OutputStream out)
メッセージの出力先を削除します。

パラメータ:
out - 出力ストリーム
戻り値:
削除に成功した場合は true。

setThrowablePrintListener

public static void setThrowablePrintListener(ThrowablePrintListener listener)
指定の例外出力リスナを割り当て直します。

パラメータ:
listener - 新しい例外出力リスナ

getThrowablePrintListener

public static ThrowablePrintListener getThrowablePrintListener()
現在の例外出力リスナを返します。

戻り値:
現在有効な例外出力リスナ

write

public static void write(String msg)
指定のメッセージを標準エラー出力および指定の出力先に書き出します。

パラメータ:
msg - メッセージ

write

public static void write(String msg,
                         Throwable exception)
指定のメッセージを標準エラー出力および指定の出力先に書き出します。

パラメータ:
msg - メッセージ
exception - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StdOut (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
クラス StdOut

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.lang.StdOut
public class StdOut
extends Object

このクラスは、システムメッセージ出力用です。

導入されたバージョン:
version 5.0

メソッドの概要
static void | addOutputStream(OutputStream out) メッセージの出力先を追加します。
static PrintStream | getDefaultPrintStream() このクラスがロードされた時点の、System.out を 返します。
static PrintStream | getPrintStream() メッセージを出力する出力ストリームを返します。
static boolean | removeOutputStream(OutputStream out) メッセージの出力先を削除します。
static void | write(String msg) 指定のメッセージを標準出力および指定の出力先に書き出します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getDefaultPrintStream

public static PrintStream getDefaultPrintStream()
このクラスがロードされた時点の、System.out を 返します。

このメソッドのリターン値を引数にして、 removeOutputStream(OutputStream) を実行すると、 標準出力（コンソール）にメッセージが表示されなくなります。

戻り値:
標準出力にメッセージを書き出す出力ストリーム

getPrintStream

public static PrintStream getPrintStream()
メッセージを出力する出力ストリームを返します。

返された出力ストリームの PrintStream.close() メソッドを 実行してストリームを閉じてしまうと、以後メッセージを出力できなく なります。

戻り値:
出力ストリーム

addOutputStream

public static void addOutputStream(OutputStream out)
メッセージの出力先を追加します。

パラメータ:
out - 出力ストリーム

removeOutputStream

public static boolean removeOutputStream(OutputStream out)
メッセージの出力先を削除します。

パラメータ:
out - 出力ストリーム
戻り値:
削除に成功した場合は true。

write

public static void write(String msg)
指定のメッセージを標準出力および指定の出力先に書き出します。

パラメータ:
msg - メッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ThreadStopListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
インタフェース ThreadStopListener

public interface ThreadStopListener

To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates. To enable and disable the creation of type comments go to Window>Preferences>Java>Code Generation.

導入されたバージョン:
version 5.0

メソッドの概要
 void handleThreadStop()
監視していたスレッドが終了したときに実行されるメソッドです。

メソッドの詳細

handleThreadStop

public void handleThreadStop()
監視していたスレッドが終了したときに実行されるメソッドです。 このメソッドをサブクラスが実行することで、特定のスレッド終了時に プログラムを実行することができます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ThrowablePrintListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
インタフェース ThrowablePrintListener

public interface ThrowablePrintListener

このインタフェースは、例外情報を出力するためのものです。

StdErr クラスと合わせて利用します。

導入されたバージョン:
version 5.0

メソッドの概要
void | printMessage(Throwable t) 例外のメッセージを出力します。
void | printStackTrace(Throwable t) 例外のスタックトレースを出力します。

メソッドの詳細

printMessage

public void printMessage(Throwable t)
例外のメッセージを出力します。

パラメータ:
t - 例外

printStackTrace

public void printStackTrace(Throwable t)
例外のスタックトレースを出力します。

パラメータ:
t - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor の使用

AbstractSocketConnectionDistributor を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での AbstractSocketConnectionDistributor の使用

jp.co.intra_mart.common.aid.jdk.java.net での AbstractSocketConnectionDistributor のサブクラス
 class SocketPool
このクラスは、通信ソケットをプールする機能を提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket の使用

ExtendedSocket を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での ExtendedSocket の使用

jp.co.intra_mart.common.aid.jdk.java.net での ExtendedSocket のサブクラス
 class SocketConnection
ソケットプール用のスケルトン実装を提供します。

ExtendedSocket 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.java.net のメソッド
 void SocketEventListener.handleSocketEvent(ExtendedSocket socket)
ソケットに関するイベント発生時に呼び出されるメソッド。

ExtendedSocket 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.java.net のコンストラクタ
SocketConnection(ExtendedSocket socket)
ソケット入出力インスタンスを構築します。
ExtendedSocket(ExtendedSocket socket)
ソケットを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.net.Localhost の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.net.Localhost の使用

Localhost を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での Localhost の使用

Localhost を返す jp.co.intra_mart.common.aid.jdk.java.net のメソッド
static Localhost Localhost.instance()
このクラスから生成される唯一のインスタンスを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection の使用

SocketConnection を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での SocketConnection の使用

SocketConnection を返す jp.co.intra_mart.common.aid.jdk.java.net のメソッド
SocketConnection | SocketPool.connection() コネクションの取得。
SocketConnection | SocketConnectionDistributor.connection() コネクションの取得。

SocketConnection 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.java.net のメソッド
 boolean SocketPool.eject(SocketConnection connection)
指定コネクションをこのプールの管理から切り離します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor の使用

SocketConnectionDistributor を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での SocketConnectionDistributor の使用

jp.co.intra_mart.common.aid.jdk.java.net での SocketConnectionDistributor のサブインタフェース
 interface SocketConnectionManager
通信ソケットをプールする機能のインターフェースです。

SocketConnectionDistributor を実装している jp.co.intra_mart.common.aid.jdk.java.net のクラス
class | AbstractSocketConnectionDistributor このクラスは、通信ソケットを作成する機能を提供します。
class | SocketPool このクラスは、通信ソケットをプールする機能を提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager の使用

SocketConnectionManager を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での SocketConnectionManager の使用

SocketConnectionManager を実装している jp.co.intra_mart.common.aid.jdk.java.net のクラス
 class SocketPool
このクラスは、通信ソケットをプールする機能を提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener の使用

SocketEventListener を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での SocketEventListener の使用

SocketEventListener 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.java.net のメソッド
void | SocketPool.addCreateSocketEventListener(SocketEventListener listener) ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。
void | SocketPool.addCloseSocketEventListener(SocketEventListener listener) ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
void | ExtendedSocket.addCloseSocketEventListener(SocketEventListener listener) ソケットをクローズしたイベントを通知するためのリスナーを 設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.net.SocketPool の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.net.SocketPool の使用

jp.co.intra_mart.common.aid.jdk.java.net.SocketPool はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException の使用

jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AbstractSocketConnectionDistributor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
クラス AbstractSocketConnectionDistributor

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor
すべての実装インタフェース:
SocketConnectionDistributor
直系の既知のサブクラス:
SocketPool
public abstract class AbstractSocketConnectionDistributor
extends Object
implements SocketConnectionDistributor

このクラスは、通信ソケットを作成する機能を提供します。

このクラスを継承してソケットプールを作成することができます。

導入されたバージョン:
version 5.0

コンストラクタの概要
protected AbstractSocketConnectionDistributor(String address, int port)
ソケット作成オブジェクトを構築します。
メソッドの概要
protected Socket | createSocket() 新しいソケットを作成します。
String | getAddress() アドレスを返します。
int | getPort() ポートを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor から継承したメソッド
clean, connection, destroy

コンストラクタの詳細

AbstractSocketConnectionDistributor

protected AbstractSocketConnectionDistributor(String address,
                                              int port)
ソケット作成オブジェクトを構築します。

パラメータ:
address - 接続するサーバのアドレス
port - 接続するサーバがサービスを提供しているポート
メソッドの詳細

createSocket

protected Socket createSocket()
                       throws UnknownHostException,
                              IOException
新しいソケットを作成します。

戻り値:
ソケット
例外:
UnknownHostException - ホストの IP アドレスを判定できなかった場合
IOException - ソケットの生成中に入出力エラーが発生した場合

getAddress

public String getAddress()
アドレスを返します。

戻り値:
このプールのネットワーク接続先サーバアドレス

getPort

public int getPort()
ポートを返します。

戻り値:
このプールのネットワーク接続先サーバポート
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedSocket (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
クラス ExtendedSocket

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket
直系の既知のサブクラス:
SocketConnection
public class ExtendedSocket
extends Object

このクラスは、ソケット通信用の入出力機能を提供します。

このクラスの提供している独自機能や、このクラスの持つメソッドから 取得したオブジェクトを使っている最中に例外がスローされた場合、 このクラスのインスタンスは発生した例外を保存します。 保存された例外は、lastError メソッドにより知ることができます。
ただし、このクラスが継承しているスーパークラスのメソッドの 呼び出し時にスローされた例外に関しては感知することはできません。

導入されたバージョン:
version 5.0

コンストラクタの概要
protected | ExtendedSocket(ExtendedSocket socket) ソケットを構築します。
 | ExtendedSocket(Socket socket) ソケットを構築します。
 | ExtendedSocket(String address, int port) ソケットを構築します。
メソッドの概要
void | addCloseSocketEventListener(SocketEventListener listener) ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
void | clearError() このインスタンスのメソッド実行中に発生した例外をすべて破棄します。
void | close() 入出力ストリームおよびソケットを閉じます。
Iterator | errorIterator() このインスタンスのメソッド実行中に発生した例外を返します。
Collection | getCloseSocketEventListeners() このソケットに登録されているクローズ・イベント・リスナーを返します。
ExtendedInputStream | getInputStream() 入力ストリームの取得。
ExtendedOutputStream | getOutputStream() 出力ストリームの取得。
Socket | getSocket() このオブジェクトの持つソケットオブジェクトを返します。
boolean | isClosed() このソケットが閉じられているかどうかをチェックします。
Throwable | lastError() このインスタンスのメソッド中で最後に発生した例外を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedSocket

public ExtendedSocket(String address,
                      int port)
               throws UnknownHostException,
                      IOException
ソケットを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
address - 接続先アドレス
port - 接続先ポート
例外:
UnknownHostException - ホストの IP アドレスが判定できなかった場合にスローされます。
IOException - 入出力ストリームの作成時エラー

ExtendedSocket

public ExtendedSocket(Socket socket)
               throws IOException
ソケットを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
socket - ソケットオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー

ExtendedSocket

protected ExtendedSocket(ExtendedSocket socket)
ソケットを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
socket - ソケットオブジェクト
メソッドの詳細

getSocket

public Socket getSocket()
このオブジェクトの持つソケットオブジェクトを返します。 このメソッドから取得したソケットオブジェクトの入出力ストリームと このオブジェクト自身から取得した入出力ストリームを 同時に利用した場合、データ送受信の整合性が失われてしまう可能性が あります。

戻り値:
ソケットオブジェクト

getInputStream

public ExtendedInputStream getInputStream()
入力ストリームの取得。

戻り値:
入力ストリーム

getOutputStream

public ExtendedOutputStream getOutputStream()
出力ストリームの取得。

戻り値:
出力ストリーム

addCloseSocketEventListener

public void addCloseSocketEventListener(SocketEventListener listener)
ソケットをクローズしたイベントを通知するためのリスナーを 設定します。 このメソッドで追加したリスナーには、このソケットが クローズされたときに、そのソケットをメソッド引数として handleSocketEventメソッドが実行されます。

パラメータ:
listener - ソケットイベントリスナー
導入されたバージョン:
version 4.2

getCloseSocketEventListeners

public Collection getCloseSocketEventListeners()
このソケットに登録されているクローズ・イベント・リスナーを返します。 このメソッドの戻り値となる Collection の各要素は SocketEventListener 型オブジェクトです。

戻り値:
SocketEventListener を要素とする Collection
導入されたバージョン:
version 4.2

lastError

public Throwable lastError()
このインスタンスのメソッド中で最後に発生した例外を返します。

戻り値:
最後に発生した例外

clearError

public void clearError()
このインスタンスのメソッド実行中に発生した例外をすべて破棄します。

このメソッドを実行すると、次に例外が発生するまで lastError()メソッドは null を返し、 errorIterator()メソッドは空の反復子を返します。

導入されたバージョン:
version 4.0

errorIterator

public Iterator errorIterator()
このインスタンスのメソッド実行中に発生した例外を返します。 このメソッドの返す反復子は発生時間順に例外オブジェクトを返します。 反復子の返すオブジェクトは、Throwable クラスと代入互換のある オブジェクトになります。

戻り値:
例外の反復子

close

public void close()
           throws IOException
入出力ストリームおよびソケットを閉じます。
入出力ストリームを閉じる前にバッファに溜められているデータをすべて 出力ストリームに書き出します。

例外:
IOException - 入出力エラーが発生した場合

isClosed

public boolean isClosed()
このソケットが閉じられているかどうかをチェックします。

戻り値:
ソケットが閉じられている場合は true
導入されたバージョン:
version4.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Localhost (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
クラス Localhost

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.net.Localhost
すべての実装インタフェース:
Serializable
public class Localhost
extends Object
implements Serializable

このクラスは、サーバプロセスの基礎情報を管理します。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

メソッドの概要
byte[] | getAddress() このコンピュータのＩＰアドレスを返します。
String | getHostAddress() このコンピュータのアドレスを返します。
String | getHostName() このコンピュータのホスト名を返します。
static Localhost | instance() このクラスから生成される唯一のインスタンスを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

instance

public static Localhost instance()
                          throws UnknownHostException
このクラスから生成される唯一のインスタンスを返します。 このメソッドが返すインスタンスは、常に一定で、 VM 内で共有されます。

戻り値:
このクラスのインスタンス
例外:
UnknownHostException - このコンピュータのＩＰアドレスが判定できなかった場合

getAddress

public byte[] getAddress()
このコンピュータのＩＰアドレスを返します。

戻り値:
IPアドレス

getHostAddress

public String getHostAddress()
このコンピュータのアドレスを返します。

戻り値:
アドレス

getHostName

public String getHostName()
このコンピュータのホスト名を返します。

戻り値:
ホスト名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.java.net (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.common.aid.jdk.java.net
インタフェース
SocketConnectionDistributor
SocketConnectionManager
SocketEventListener
クラス
AbstractSocketConnectionDistributor
ExtendedSocket
Localhost
SocketConnection
SocketPool
例外
UnsupportedNetworkConnectException


jp.co.intra_mart.common.aid.jdk.java.net (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.net

ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

参照:
説明

インタフェースの概要
SocketConnectionDistributor | このクラスは、通信ソケットをプールする機能を提供します。
SocketConnectionManager | 通信ソケットをプールする機能のインターフェースです。
SocketEventListener | 通信ソケットに関するイベント発生を受け取るためのスケルトン実装です。

クラスの概要
AbstractSocketConnectionDistributor | このクラスは、通信ソケットを作成する機能を提供します。
ExtendedSocket | このクラスは、ソケット通信用の入出力機能を提供します。
Localhost | このクラスは、サーバプロセスの基礎情報を管理します。
SocketConnection | ソケットプール用のスケルトン実装を提供します。
SocketPool | このクラスは、通信ソケットをプールする機能を提供します。

例外の概要
UnsupportedNetworkConnectException To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates.

パッケージ jp.co.intra_mart.common.aid.jdk.java.net の説明

ソケットによるネットワーク対応機能を実装するためのクラスを提供します。


jp.co.intra_mart.common.aid.jdk.java.net クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.net の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor (implements jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor)
      • class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool (implements jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager)
    • class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket
      • class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection
    • class jp.co.intra_mart.common.aid.jdk.java.net.Localhost (implements java.io.Serializable)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.io.IOException
          • class jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException

インタフェース階層

  • interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor
    • interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager
  • interface jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener


パッケージ jp.co.intra_mart.common.aid.jdk.java.net の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.java.net の使用

jp.co.intra_mart.common.aid.jdk.java.net を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net により使用される jp.co.intra_mart.common.aid.jdk.java.net のクラス
AbstractSocketConnectionDistributor
このクラスは、通信ソケットを作成する機能を提供します。
ExtendedSocket
このクラスは、ソケット通信用の入出力機能を提供します。
Localhost
このクラスは、サーバプロセスの基礎情報を管理します。
SocketConnection
ソケットプール用のスケルトン実装を提供します。
SocketConnectionDistributor
このクラスは、通信ソケットをプールする機能を提供します。
SocketConnectionManager
通信ソケットをプールする機能のインターフェースです。
SocketEventListener
通信ソケットに関するイベント発生を受け取るためのスケルトン実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SocketConnection (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
クラス SocketConnection

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket
        拡張 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection
public abstract class SocketConnection
extends ExtendedSocket

ソケットプール用のスケルトン実装を提供します。

導入されたバージョン:
version 5.0
関連項目:
SocketPool

コンストラクタの概要
protected | SocketConnection(ExtendedSocket socket) ソケット入出力インスタンスを構築します。
protected | SocketConnection(Socket socket) ソケット入出力インスタンスを構築します。
protected | SocketConnection(String address, int port) ソケット入出力インスタンスを構築します。
メソッドの概要
abstract  void release()
ソケットおよび入出力ストリームの利用を中止します。
クラス jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket から継承したメソッド
addCloseSocketEventListener, clearError, close, errorIterator, getCloseSocketEventListeners, getInputStream, getOutputStream, getSocket, isClosed, lastError
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SocketConnection

protected SocketConnection(String address,
                           int port)
                    throws IOException
ソケット入出力インスタンスを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
address - 接続先アドレス
port - 接続先ポート
例外:
IOException - 入出力ストリームの作成時エラー

SocketConnection

protected SocketConnection(Socket socket)
                    throws IOException
ソケット入出力インスタンスを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
socket - ソケットオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー

SocketConnection

protected SocketConnection(ExtendedSocket socket)
                    throws IOException
ソケット入出力インスタンスを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
socket - ソケットオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー
メソッドの詳細

release

public abstract void release()
                      throws IOException
ソケットおよび入出力ストリームの利用を中止します。

このインスタンスの利用が終了したら、必ず呼び出して下さい。
このメソッドを呼び出さないと、プール領域中のリソースが完全には 開放されません。
また、スーパークラス ExtendedSocket の close メソッドを呼び出した場合も プール中のリソースが完全に開放されない可能性があります。

リソースの開放は、プールオブジェクトが必要に応じて行います。

例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SocketConnectionDistributor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
インタフェース SocketConnectionDistributor

既知のサブインタフェースの一覧:
SocketConnectionManager
既知の実装クラスの一覧:
AbstractSocketConnectionDistributor, SocketPool
public interface SocketConnectionDistributor

このクラスは、通信ソケットをプールする機能を提供します。

プール機能を利用することにより少ないソケットを複数のプログラムから 利用できるようになります。
このプールは、１つのインスタンスに付き１つの専用スレッドを持ちます。 プールは専用のスレッドにより管理され、一定時間に１つのコネクションが 順に破棄されていきます。したがって、コネクションを全く使用しないまま 長い時間が経過すると、このプール中にプールされているソケット・コネクションは ０個になります。

導入されたバージョン:
version 5.0

メソッドの概要
void | clean() プール中のコネクションをすべて破棄します。
SocketConnection | connection() コネクションの取得。
void | destroy() このプールを破棄します。

メソッドの詳細

connection

public SocketConnection connection()
                            throws IOException
コネクションの取得。

プール中にコネクションが待機している場合にはプールの中から 待機中のコネクションを返却します。 プール中にコネクションが存在しない場合には、 新しいコネクションを生成して返します。

戻り値:
通信用インスタンス
例外:
IOException - ソケットの接続エラー
関連項目:
SocketConnection

destroy

public void destroy()
このプールを破棄します。

clean

public void clean()
プール中のコネクションをすべて破棄します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SocketConnectionManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
インタフェース SocketConnectionManager

すべてのスーパーインタフェース:
SocketConnectionDistributor
既知の実装クラスの一覧:
SocketPool
public interface SocketConnectionManager
extends SocketConnectionDistributor

通信ソケットをプールする機能のインターフェースです。

導入されたバージョン:
version 5.0

メソッドの概要
int | getCapacity() コネクション作成最大数の取得。
int | getSize() このプールが現在管理しているコネクション数です。
int | usableConnection() 現在待機中のコネクションをです。
インタフェース jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor から継承したメソッド
clean, connection, destroy

メソッドの詳細

getCapacity

public int getCapacity()
コネクション作成最大数の取得。

戻り値:
このプールにより作成されるコネクションの最大数

getSize

public int getSize()
このプールが現在管理しているコネクション数です。

この数は、最小が 0 で最大が getCapacity() メソッドにより得られる値の 間で変動します。

戻り値:
有効なコネクション数
導入されたバージョン:
version 4.2

usableConnection

public int usableConnection()
現在待機中のコネクションをです。

戻り値:
待機中のコネクション数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SocketEventListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
インタフェース SocketEventListener

public interface SocketEventListener

通信ソケットに関するイベント発生を受け取るためのスケルトン実装です。

ソケットに関するイベント通知側と組み合わせて利用することにより、 ソケットに関する特定のイベント発生時に独自の処理を実行することができます。

導入されたバージョン:
version 5.0

メソッドの概要
 void handleSocketEvent(ExtendedSocket socket)
ソケットに関するイベント発生時に呼び出されるメソッド。

メソッドの詳細

handleSocketEvent

public void handleSocketEvent(ExtendedSocket socket)
                       throws IOException
ソケットに関するイベント発生時に呼び出されるメソッド。 サブクラスは、このメソッドを実装することにより、特定のソケットに関する イベントの発生を知ることができます。

パラメータ:
socket - イベントの発生したソケット
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SocketPool (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
クラス SocketPool

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor
        拡張 jp.co.intra_mart.common.aid.jdk.java.net.SocketPool
すべての実装インタフェース:
SocketConnectionDistributor, SocketConnectionManager
public class SocketPool
extends AbstractSocketConnectionDistributor
implements SocketConnectionManager

このクラスは、通信ソケットをプールする機能を提供します。

プール機能を利用することにより少ないソケットを複数のプログラムから 利用できるようになります。
このプールは、１つのインスタンスに付き１つの専用スレッドを持ちます。 プールは専用のスレッドにより管理され、一定時間に１つのコネクションが 順に破棄されていきます。したがって、コネクションを全く使用しないまま 長い時間が経過すると、このプール中にプールされているソケット・コネクションは ０個になります。

導入されたバージョン:
version 5.0

コンストラクタの概要
SocketPool(String address, int port)
ソケットプールを構築します。
SocketPool(String address, int port, int capacity)
ソケットプールを構築します。
メソッドの概要
void | addCloseSocketEventListener(SocketEventListener listener) ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
void | addCreateSocketEventListener(SocketEventListener listener) ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。
void | clean() プール中のコネクションをすべて破棄します。
SocketConnection | connection() コネクションの取得。
void | destroy() このプールを破棄します。
boolean | eject(SocketConnection connection) 指定コネクションをこのプールの管理から切り離します。
protected void | finalize() このオブジェクトへの参照はもうないとガーベージコレクションによって 判断されたときに、ガーベージコレクタによって呼び出されます。
int | getCapacity() コネクション作成最大数の取得。
Collection | getCloseSocketEventListeners() このプールに登録されている ソケットをクローズしたイベントを通知するためのリスナーを 返します。
Collection | getCreateSocketEventListeners() このプールに登録されている ソケットを新規に作成したイベントを通知するためのリスナーを 返します。
int | getSize() このプールが現在管理しているコネクション数です。
int | usableConnection() 現在待機中のコネクションをです。
クラス jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor から継承したメソッド
createSocket, getAddress, getPort
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SocketPool

public SocketPool(String address,
                  int port)
ソケットプールを構築します。

このプールで管理できるソケットコネクションは 1 個になります。

パラメータ:
address - 接続するサーバのアドレス
port - 接続するサーバがサービスを提供しているポート

SocketPool

public SocketPool(String address,
                  int port,
                  int capacity)
ソケットプールを構築します。

コネクションは動的に生成されます。 capacity 個よりも多くのコネクション要求があった場合、 コネクションが開放されるまで待ち状態になります。
capacity にはプールの性質上、 1 以上の値を指定して下さい。 capacity に 1 より小さな値を指定した場合、プール数は 1 になります。

パラメータ:
address - 接続するサーバのアドレス
port - 接続するサーバがサービスを提供しているポート
capacity - 接続コネクションの最大数
メソッドの詳細

addCreateSocketEventListener

public void addCreateSocketEventListener(SocketEventListener listener)
ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。 このメソッドで追加したリスナーには、このプールで新規にソケットが 作成されたときに、そのソケットをメソッド引数として handleSocketEventメソッドが実行されます。

パラメータ:
listener - ソケットイベントリスナー

getCreateSocketEventListeners

public Collection getCreateSocketEventListeners()
このプールに登録されている ソケットを新規に作成したイベントを通知するためのリスナーを 返します。 このメソッドの戻り値となる Collection の各要素は SocketEventListener 型オブジェクトです。

戻り値:
SocketEventListener を要素とする Collection

addCloseSocketEventListener

public void addCloseSocketEventListener(SocketEventListener listener)
ソケットをクローズしたイベントを通知するためのリスナーを 設定します。 このメソッドで追加したリスナーには、このプールのソケットが クローズされたときに、そのソケットをメソッド引数として handleSocketEventメソッドが実行されます。

パラメータ:
listener - ソケットイベントリスナー

getCloseSocketEventListeners

public Collection getCloseSocketEventListeners()
このプールに登録されている ソケットをクローズしたイベントを通知するためのリスナーを 返します。 このメソッドの戻り値となる Collection の各要素は SocketEventListener 型オブジェクトです。

戻り値:
SocketEventListener を要素とする Collection

getCapacity

public int getCapacity()
コネクション作成最大数の取得。

定義:
インタフェース SocketConnectionManager 内の getCapacity
戻り値:
このプールにより作成されるコネクションの最大数

getSize

public int getSize()
このプールが現在管理しているコネクション数です。

この数は、最小が 0 で最大が getCapacity() メソッドにより得られる値の 間で変動します。

定義:
インタフェース SocketConnectionManager 内の getSize
戻り値:
有効なコネクション数
導入されたバージョン:
version 4.2

usableConnection

public int usableConnection()
現在待機中のコネクションをです。

定義:
インタフェース SocketConnectionManager 内の usableConnection
戻り値:
待機中のコネクション数

connection

public SocketConnection connection()
                            throws IOException
コネクションの取得。

プール中にコネクションが待機している場合にはプールの中から 待機中のコネクションを返却します。 プール中にコネクションが存在しない場合には、 新しいコネクションを生成して返します。

定義:
インタフェース SocketConnectionDistributor 内の connection
戻り値:
通信用インスタンス
例外:
IOException - ソケットの接続エラー
関連項目:
SocketConnection

eject

public boolean eject(SocketConnection connection)
指定コネクションをこのプールの管理から切り離します。

指定コネクションがこのプールに管理されていたものなら、 このメソッド実行後はこのプールの管理するコネクションが１つ減少するので、 新たにコネクションを作成することができるようになります。

指定のコネクションをこのプールが管理していて他のスレッドによって 使用（connection() メソッドにより取得）されていない場合 true を 返します。指定のコネクションがこのプールにより管理されているもの であった場合でも、他のスレッドにより使用中の場合は false を返します。

パラメータ:
connection - 管理から切り離すコネクション
戻り値:
コネクションの切り離しに成功した場合 true

destroy

public void destroy()
このプールを破棄します。

定義:
インタフェース SocketConnectionDistributor 内の destroy

clean

public void clean()
プール中のコネクションをすべて破棄します。

定義:
インタフェース SocketConnectionDistributor 内の clean

finalize

protected void finalize()
                 throws Throwable
このオブジェクトへの参照はもうないとガーベージコレクションによって 判断されたときに、ガーベージコレクタによって呼び出されます。 SocketPool クラスは、このメソッドによりオブジェクトの破棄前に リソースのクリーンアップをします。

例外:
Throwable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UnsupportedNetworkConnectException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
クラス UnsupportedNetworkConnectException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.io.IOException
                拡張 jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException
すべての実装インタフェース:
Serializable
public class UnsupportedNetworkConnectException
extends IOException

To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates. To enable and disable the creation of type comments go to Window>Preferences>Java>Code Generation.

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
UnsupportedNetworkConnectException()
Constructor for UnsupportedNetworkConnectException.
UnsupportedNetworkConnectException(String arg0)
Constructor for UnsupportedNetworkConnectException.
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UnsupportedNetworkConnectException

public UnsupportedNetworkConnectException()
Constructor for UnsupportedNetworkConnectException.

UnsupportedNetworkConnectException

public UnsupportedNetworkConnectException(String arg0)
Constructor for UnsupportedNetworkConnectException.

パラメータ:
arg0 -
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator の使用

AbstractDualComparator を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.util このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.util での AbstractDualComparator の使用

jp.co.intra_mart.common.aid.jdk.java.util での AbstractDualComparator のサブクラス
 class MultiComparator
複数のコンパレータを使用してソートを行うためにクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.java.util.DualComparator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.java.util.DualComparator の使用

DualComparator を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.util このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.util での DualComparator の使用

DualComparator を実装している jp.co.intra_mart.common.aid.jdk.java.util のクラス
class | AbstractDualComparator ２つのコンパレータを使用してソートを行うクラスです。
class | MultiComparator 複数のコンパレータを使用してソートを行うためにクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties の使用

ExtendedProperties を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.javax.xml | このパッケージには、ＸＭＬを利用するためのクラスが含まれています。
jp.co.intra_mart.common.aid.jdk.org.w3c.dom | このパッケージには、ＤＯＭを利用するためのクラスが含まれています。

jp.co.intra_mart.common.aid.jdk.javax.xml での ExtendedProperties の使用

jp.co.intra_mart.common.aid.jdk.javax.xml での ExtendedProperties のサブクラス
 class XMLProperties
XML をベースとした不変のプロパティセットを表します。

jp.co.intra_mart.common.aid.jdk.org.w3c.dom での ExtendedProperties の使用

jp.co.intra_mart.common.aid.jdk.org.w3c.dom での ExtendedProperties のサブクラス
 class ElementProperties
DOM をベースとした不変のプロパティセットを表します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator の使用

FilterComparator を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.util このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.util での FilterComparator の使用

jp.co.intra_mart.common.aid.jdk.java.util での FilterComparator のサブクラス
 class ReverseComparator
コンパレータのフィルタとして機能します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap の使用

jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator の使用

jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties の使用

jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator の使用

jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator の使用

jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AbstractDualComparator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス AbstractDualComparator

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator
すべての実装インタフェース:
Comparator, DualComparator, Serializable
直系の既知のサブクラス:
MultiComparator
public abstract class AbstractDualComparator
extends Object
implements DualComparator

２つのコンパレータを使用してソートを行うクラスです。
比較の順番は、指定された第１コンパレータ、第２コンパレータの順に行われます。まず、第１コンパレータで比較を行います。 もし、その比較の結果が０の時は第２コンパレータで比較を行いその結果を返します。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
AbstractDualComparator()
新しいオブジェクトを生成します。
メソッドの概要
 int compare(Object arg0, Object arg1)
順序付けのために ２ つの引数を比較するメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.common.aid.jdk.java.util.DualComparator から継承したメソッド
getPrimaryComparator, getSecondaryComparator
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

AbstractDualComparator

public AbstractDualComparator()
新しいオブジェクトを生成します。

メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
順序付けのために ２ つの引数を比較するメソッドです。
最初の引数が ２ 番目の引数より小さ い場合は負の整数、両方が等しい場合は ０、最初の引数が ２ 番目の引 数より大きい場合は正の整数を返します。
このメソッドは ２ つのコンパレータを使用して比較を行いその結果を返します。 比較の順番は、指定された第１コンパレータ、第２コンパレータの順に行われます。まず、第１コンパレータで比較を行います。 比較の結果が０でないときは、その比較した結果を返します。もし比較の結果が０の時は第２コンパレータで比較を行いその結果を返します。

定義:
インタフェース Comparator 内の compare
パラメータ:
arg0 - 引数１
arg1 - 引数２
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DualComparator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
インタフェース DualComparator

すべてのスーパーインタフェース:
Comparator, Serializable
既知の実装クラスの一覧:
AbstractDualComparator
public interface DualComparator
extends Serializable, Comparator

２つのコンパレータを使用してソートを行うためのインターフェースです。

導入されたバージョン:
version 5.0

メソッドの概要
Comparator | getPrimaryComparator() １番目コンパレータを取得します。
Comparator | getSecondaryComparator() ２番目コンパレータを取得します。
インタフェース java.util.Comparator から継承したメソッド
compare, equals

メソッドの詳細

getPrimaryComparator

public Comparator getPrimaryComparator()
１番目コンパレータを取得します。

戻り値:
１番目のコンパレータ

getSecondaryComparator

public Comparator getSecondaryComparator()
２番目コンパレータを取得します。

戻り値:
２番目のコンパレータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedProperties (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス ExtendedProperties

java.lang.Object
    拡張 java.util.Dictionary
        拡張 java.util.Hashtable
            拡張 java.util.Properties
                拡張 jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties
すべての実装インタフェース:
Cloneable, Map, Serializable
直系の既知のサブクラス:
ElementProperties
public class ExtendedProperties
extends Properties

java.util.Properties を、より便利に利用するためのインタフェースを提供します。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

フィールドの概要
クラス java.util.Properties から継承したフィールド
defaults
コンストラクタの概要
ExtendedProperties()
デフォルト値を持たない空のプロパティリストを作成します。
ExtendedProperties(Properties defaults)
指定されたデフォルト値を持つ空のプロパティリストを作成します。
メソッドの概要
double | doubleValue(String key) 指定されたキーによって示されるプロパティ値を 浮動小数点数(double)表現された数値として取得します。
double | doubleValue(String key, double defaultValue) 指定されたキーによって示されるプロパティ値を 浮動小数点数(double)表現された数値として取得します。
float | floatValue(String key) 指定されたキーによって示されるプロパティ値を 浮動小数点数(float)表現された数値として取得します。
float | floatValue(String key, float defaultValue) 指定されたキーによって示されるプロパティ値を 浮動小数点数(float)表現された数値として取得します。
int | intValue(String key) 指定されたキーによって示されるプロパティ値を 数値として取得します。
int | intValue(String key, int defaultValue) 指定されたキーによって示されるプロパティ値を 数値として取得します。
boolean | isFalse(String key) 指定されたキーによって示されるプロパティ値を真偽判定します。
boolean | isTrue(String key) 指定されたキーによって示されるプロパティ値を真偽判定します。
long | longValue(String key) 指定されたキーによって示されるプロパティ値を 長整数として取得します。
long | longValue(String key, long defaultValue) 指定されたキーによって示されるプロパティ値を 長整数として取得します。
int | parseInt(String key, int radix) 2 番目の引数に指定された基数を元にして、 指定されたキーによって示されるプロパティ値を 符号付き整数として解析します。
long | parseLong(String key, int radix) 2 番目の引数に指定された基数を元にして、 指定されたキーによって示されるプロパティ値を 符号付き長整数として解析します。
クラス java.util.Properties から継承したメソッド
getProperty, getProperty, list, list, load, propertyNames, save, setProperty, store
クラス java.util.Hashtable から継承したメソッド
clear, clone, contains, containsKey, containsValue, elements, entrySet, equals, get, hashCode, isEmpty, keys, keySet, put, putAll, rehash, remove, size, toString, values
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtendedProperties

public ExtendedProperties()
デフォルト値を持たない空のプロパティリストを作成します。

ExtendedProperties

public ExtendedProperties(Properties defaults)
指定されたデフォルト値を持つ空のプロパティリストを作成します。

パラメータ:
defaults - デフォルト値
メソッドの詳細

isTrue

public boolean isTrue(String key)
指定されたキーによって示されるプロパティ値を真偽判定します。

パラメータ:
key - プロパティの名前
戻り値:
プロパティの文字列値が "true" の場合(大文字と小文字は区別しない) true、そうでない場合 false。

isFalse

public boolean isFalse(String key)
指定されたキーによって示されるプロパティ値を真偽判定します。

パラメータ:
key - プロパティの名前
戻り値:
プロパティの文字列値が "false" の場合(大文字と小文字は区別しない) true、そうでない場合 false。

intValue

public int intValue(String key)
指定されたキーによって示されるプロパティ値を 数値として取得します。

パラメータ:
key - プロパティの名前
戻り値:
プロパティの文字列値を数値として表現した値。そのキーにプロパティがない場合(設定値が不適切なフォーマットも含む)は 0。

intValue

public int intValue(String key,
                    int defaultValue)
指定されたキーによって示されるプロパティ値を 数値として取得します。

パラメータ:
key - プロパティの名前
defaultValue - デフォルト値
戻り値:
プロパティの文字列値を数値として表現した値。そのキーにプロパティがない場合(設定値が不適切なフォーマットも含む)はデフォルト値。

parseInt

public int parseInt(String key,
                    int radix)
             throws NumberFormatException
2 番目の引数に指定された基数を元にして、 指定されたキーによって示されるプロパティ値を 符号付き整数として解析します。 このメソッドは、java.lang.Integer.parseInt(String s, int radix) メソッドの仕様に準じます。

パラメータ:
key - プロパティの名前
radix - 使用される基数
戻り値:
プロパティの文字列値を数値として表現した値。
例外:
NumberFormatException - 文字列が解析可能な整数を含まない場合

longValue

public long longValue(String key)
指定されたキーによって示されるプロパティ値を 長整数として取得します。

パラメータ:
key - プロパティの名前
戻り値:
プロパティの文字列値を数値として表現した値。そのキーにプロパティがない場合(設定値が不適切なフォーマットも含む)は 0。

longValue

public long longValue(String key,
                      long defaultValue)
指定されたキーによって示されるプロパティ値を 長整数として取得します。

パラメータ:
key - プロパティの名前
defaultValue - デフォルト値
戻り値:
プロパティの文字列値を数値として表現した値。そのキーにプロパティがない場合(設定値が不適切なフォーマットも含む)はデフォルト値。

parseLong

public long parseLong(String key,
                      int radix)
               throws NumberFormatException
2 番目の引数に指定された基数を元にして、 指定されたキーによって示されるプロパティ値を 符号付き長整数として解析します。 このメソッドは、java.lang.Long.parseLong(String s, int radix) メソッドの仕様に準じます。

パラメータ:
key - プロパティの名前
radix - 使用される基数
戻り値:
プロパティの文字列値を数値として表現した値。
例外:
NumberFormatException - 文字列が解析可能な整数を含まない場合

floatValue

public float floatValue(String key)
指定されたキーによって示されるプロパティ値を 浮動小数点数(float)表現された数値として取得します。

パラメータ:
key - プロパティの名前
戻り値:
プロパティの文字列値を数値として表現した値。そのキーにプロパティがない場合(設定値が不適切なフォーマットも含む)は float 型の非数 (NaN) 値。

floatValue

public float floatValue(String key,
                        float defaultValue)
指定されたキーによって示されるプロパティ値を 浮動小数点数(float)表現された数値として取得します。

パラメータ:
key - プロパティの名前
defaultValue - デフォルト値
戻り値:
プロパティの文字列値を数値として表現した値。そのキーにプロパティがない場合(設定値が不適切なフォーマットも含む)はデフォルト値。

doubleValue

public double doubleValue(String key)
指定されたキーによって示されるプロパティ値を 浮動小数点数(double)表現された数値として取得します。

パラメータ:
key - プロパティの名前
戻り値:
プロパティの文字列値を数値として表現した値。そのキーにプロパティがない場合(設定値が不適切なフォーマットも含む)は double 型の非数 (NaN) 値。

doubleValue

public double doubleValue(String key,
                          double defaultValue)
指定されたキーによって示されるプロパティ値を 浮動小数点数(double)表現された数値として取得します。

パラメータ:
key - プロパティの名前
defaultValue - デフォルト値
戻り値:
プロパティの文字列値を数値として表現した値。そのキーにプロパティがない場合(設定値が不適切なフォーマットも含む)はデフォルト値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FilterComparator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス FilterComparator

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator
すべての実装インタフェース:
Comparator, Serializable
直系の既知のサブクラス:
ReverseComparator
public abstract class FilterComparator
extends Object
implements Comparator, Serializable

コンパレータのフィルターとして機能する抽象クラスです。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
FilterComparator(Comparator comparator)
指定されれたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
メソッドの概要
int | compare(Object arg0, Object arg1) 順序付けのために 2 つの引数を比較するメソッドです。
Comparator | getParentComparator() フィルター対象のコンパレータを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

FilterComparator

public FilterComparator(Comparator comparator)
指定されれたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。

パラメータ:
comparator - フィルター対象のコンパレータ
メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
順序付けのために 2 つの引数を比較するメソッドです。
最初の引数が 2 番目の引数より小さ い場合は負の整数、両方が等しい場合は 0、最初の引数が 2 番目の引 数より大きい場合は正の整数を返します。

定義:
インタフェース Comparator 内の compare
パラメータ:
arg0 - 引数１
arg1 - 引数２
戻り値:
比較した結果

getParentComparator

public Comparator getParentComparator()
フィルター対象のコンパレータを返します。

戻り値:
フィルター対象のコンパレータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FixedSizeMap (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス FixedSizeMap

java.lang.Object
    拡張 java.util.AbstractMap
        拡張 jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap
すべての実装インタフェース:
Map
public class FixedSizeMap
extends AbstractMap

LRU(Least Recently Used) アルゴリズムによる Map インターフェースの実装を提供します。

このクラスのマップは、決められたサイズの領域持ちます。 キーはコンストラクタで指定された マップのサイズに等しい個数しか、このマップに関連付けることはできません。 すでにマップのサイズに等しい個数のキーが関連付けられている状態で、 別の新しいキーを関連付けようとした場合、LRU アルゴリズムに従い 最も古くに使われたキーが削除され、全体のキー数がマップのサイズに 等しくなるように調整されます。
このオブジェクトは、Thread safe となっています。
このマップは LRU アルゴリズムにより動作するため、 マッピングの追加や更新をしたり、キーにマッピングされている値の取得を した時に、キーのアクセス順をチェックします。 したがって、マップのサイズが大きさに比例して put() や get() メソッドの レスポンス時間が長くなります。 このハッシュテーブルは、適度な大きさで利用することを推奨します。

導入されたバージョン:
version 5.0
関連項目:
Hashtable

入れ子クラスの概要
クラス java.util.Map から継承した入れ子クラス
Map.Entry
コンストラクタの概要
FixedSizeMap(int size)
指定されたサイズの領域を持つマップを構築します。
メソッドの概要
int | capacity() このマップに対してマップできるキーの最大個数を返します。
void | clear() マップからマッピングをすべて削除します。
boolean | containsKey(Object key) 指定されたキーへのマッピングをこのマップが格納する場合に true を返します。
Set | entrySet() このマップに格納されているマッピングのセットビューを返します。
Object | get(Object key) マップが、指定されたキーにマッピングしている値を返します。
Object | put(Object key, Object value) 指定された値を、マップ内の指定されたキーに関連付けます 。
Object | remove(Object key) このキーにマッピングがある場合に、そのマッピングをマップから削除します。
クラス java.util.AbstractMap から継承したメソッド
clone, containsValue, equals, hashCode, isEmpty, keySet, putAll, size, toString, values
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

FixedSizeMap

public FixedSizeMap(int size)
             throws IllegalArgumentException
指定されたサイズの領域を持つマップを構築します。

パラメータ:
size - ハッシュテーブルの容量
例外:
IllegalArgumentException - 容量が 1 より小さい場合
メソッドの詳細

capacity

public int capacity()
このマップに対してマップできるキーの最大個数を返します。 このメソッドの返す値は、コンストラクタで指定されたハッシュテーブルの 容量値をそのまま返すものです。

戻り値:
このマップにエントリできるキーの最大個数

clear

public void clear()
マップからマッピングをすべて削除します。

containsKey

public boolean containsKey(Object key)
指定されたキーへのマッピングをこのマップが格納する場合に true を返します。

パラメータ:
key - このマップにあるかどうかを判定するキー
戻り値:
指定されたキーへのマッピングをこのマップが含む場合は true

entrySet

public Set entrySet()
このマップに格納されているマッピングのセットビューを返します。 このセットの各要素は Map.Entry です。セットはこのマップを 基にしているので、マップへの変更、およびセットへの変更は、 互いに反映されます。 セットでの繰り返し処理が進行中にマップが変更された場合、 反復の結果は保証されません。セットは要素の削除をサポートしており、 対応するエントリをマップから削除することができます。 削除には、Iterator.remove、Set.remove、removeAll、retainAll、 および clear オペレーションが使えます。 add または addAll オペレーションはサポートされません。

戻り値:
このマップに格納されているマッピングのセットビュー

get

public Object get(Object key)
マップが、指定されたキーにマッピングしている値を返します。 マップに、このキーに対するマッピングがない場合は null を返します。

パラメータ:
key - 関連付けられている値が返されるキー
戻り値:
マップが、指定されたキーにマッピングしている値。このキーに対するマッピングがマップにない場合は null
関連項目:
containsKey(Object)

put

public Object put(Object key,
                  Object value)
指定された値を、マップ内の指定されたキーに関連付けます 。 マップにすでにこのキーに対するマッピングがある場合、 古い値は置き換えられます。

パラメータ:
key - 指定された値が関連付けられるキー
value - 指定されたキーに関連付けられる値
戻り値:
指定されたキーに関連付けられていた以前の値。key にマッピングがなかった場合は null。
例外:
NullPointerException - キーまたは値が null の場合

remove

public Object remove(Object key)
このキーにマッピングがある場合に、そのマッピングをマップから削除します。

パラメータ:
key - マッピングがマップから削除されるキー
戻り値:
指定されたキーに関連付けられていた以前の値。key にマッピングがなかった場合は null。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MultiComparator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス MultiComparator

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator
        拡張 jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator
すべての実装インタフェース:
Comparator, DualComparator, Serializable
public class MultiComparator
extends AbstractDualComparator

複数のコンパレータを使用してソートを行うためにクラスです。
実行したコンパレータの compare() メソッドの戻り値が０でなくなるか、全てのコンパレータの実行が完了するまで下記の順番でコンパレータの実行が行われます。

・コンストラクタで指定された第１コンパレータ
・コンストラクタで指定された第２コンパレータ
・addComparator()で追加されたコンパレータ

このクラスは同じインスタンスのコンパレータを２つ以上持つことを想定されていません。 そのような操作を行うと、正しい結果が得られない可能性があります。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
MultiComparator(Comparator primaryComparator, Comparator secondaryComparator)
第１コンパレータ 、第２コンパレータを指定して、新しいオブジェクトを生成します。
メソッドの概要
void | addComparator(Comparator comparator) 指定されたコンパレータ comparator を追加します。
Collection | getComparators() 設定されている全てのコンパレータを取得します。
Comparator | getPrimaryComparator() 第１コンパレータを返します。
Comparator | getSecondaryComparator() 第２コンパレータを返します。
boolean | removeComparator(Comparator comparator) 指定されたコンパレータ comparatorを削除します。
クラス jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator から継承したメソッド
compare
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

MultiComparator

public MultiComparator(Comparator primaryComparator,
                       Comparator secondaryComparator)
                throws NullPointerException
第１コンパレータ 、第２コンパレータを指定して、新しいオブジェクトを生成します。
もし primaryComparator がnullで、 secondaryComparator がnullでない時は、secondaryComparator が第１コンパレータとして扱われます。
primaryComparator 、secondaryComparator がともにnullの時は例外を発生させます。

パラメータ:
primaryComparator - 第１コンパレータ
secondaryComparator - 第２コンパレータ
例外:
NullPointerException - primaryComparator 、 secondaryComparator がともにnullの時発生します。
メソッドの詳細

getPrimaryComparator

public Comparator getPrimaryComparator()
第１コンパレータを返します。

戻り値:
第１コンパレータ

getSecondaryComparator

public Comparator getSecondaryComparator()
第２コンパレータを返します。 このメソッドの戻り値は、設定された第２コンパレータをラップしたMultiComparatorのオブジェクトになります。 もし、第２コンパレータが設定されていないときはnullを返します。

戻り値:
第２コンパレータ

addComparator

public void addComparator(Comparator comparator)
                   throws NullPointerException
指定されたコンパレータ comparator を追加します。 指定されたコンパレータ comparatorがnullの時は例外を発生させます。

パラメータ:
comparator - コンパレータ
例外:
NullPointerException - 指定されたcomparatorがnullの時に発生します。

removeComparator

public boolean removeComparator(Comparator comparator)
                         throws IllegalArgumentException
指定されたコンパレータ comparatorを削除します。 指定されたコンパレータの削除に成功したときはtrue、失敗したときはfalseを返します。 このクラスのオブジェクトが持つ全てのコンパレータを削除しようとすると例外が発生します。

パラメータ:
comparator - 削除対象のコンパレータ
戻り値:
削除に成功したときはtrue、失敗したときはfalseを返す。
例外:
IllegalArgumentException - 全てのコンパレータを削除しようとした時に発生します。

getComparators

public Collection getComparators()
設定されている全てのコンパレータを取得します。

戻り値:
設定されている全てのコンパレータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.java.util (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.common.aid.jdk.java.util
インタフェース
DualComparator
クラス
AbstractDualComparator
ExtendedProperties
FilterComparator
FixedSizeMap
MultiComparator
ResourceBundleProperties
ReverseComparator
SequenceComparator


jp.co.intra_mart.common.aid.jdk.java.util (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.util

このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。

参照:
説明

インタフェースの概要
DualComparator ２つのコンパレータを使用してソートを行うためのインターフェースです。

クラスの概要
AbstractDualComparator | ２つのコンパレータを使用してソートを行うクラスです。
ExtendedProperties | java.util.Properties を、より便利に利用するためのインタフェースを提供します。
FilterComparator | コンパレータのフィルターとして機能する抽象クラスです。
FixedSizeMap | LRU(Least Recently Used) アルゴリズムによる Map インターフェースの実装を提供します。
MultiComparator | 複数のコンパレータを使用してソートを行うためにクラスです。
ResourceBundleProperties | このクラスは、java.util.Properties クラスのインターフェースを実装した、 プロパティ管理クラスです。
ReverseComparator | コンパレータのフィルタとして機能します。
SequenceComparator | 挿入順にソートするためのコンパレータです。

パッケージ jp.co.intra_mart.common.aid.jdk.java.util の説明

このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。


jp.co.intra_mart.common.aid.jdk.java.util クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator (implements jp.co.intra_mart.common.aid.jdk.java.util.DualComparator)
      • class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator
    • class java.util.AbstractMap (implements java.util.Map)
      • class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap
    • class java.util.Dictionary
      • class java.util.Hashtable (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class java.util.Properties
          • class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties
          • class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties
    • class jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator (implements java.util.Comparator, java.io.Serializable)
      • class jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator
    • class jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator (implements java.util.Comparator, java.io.Serializable)

インタフェース階層

  • interface java.util.Comparator
    • interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator (同様に extends java.io.Serializable)
  • interface java.io.Serializable
    • interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator (同様に extends java.util.Comparator)


パッケージ jp.co.intra_mart.common.aid.jdk.java.util の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.java.util の使用

jp.co.intra_mart.common.aid.jdk.java.util を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.util | このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.javax.xml | このパッケージには、ＸＭＬを利用するためのクラスが含まれています。
jp.co.intra_mart.common.aid.jdk.org.w3c.dom | このパッケージには、ＤＯＭを利用するためのクラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.util により使用される jp.co.intra_mart.common.aid.jdk.java.util のクラス
AbstractDualComparator
２つのコンパレータを使用してソートを行うクラスです。
DualComparator
２つのコンパレータを使用してソートを行うためのインターフェースです。
FilterComparator
コンパレータのフィルターとして機能する抽象クラスです。

jp.co.intra_mart.common.aid.jdk.javax.xml により使用される jp.co.intra_mart.common.aid.jdk.java.util のクラス
ExtendedProperties
java.util.Properties を、より便利に利用するためのインタフェースを提供します。

jp.co.intra_mart.common.aid.jdk.org.w3c.dom により使用される jp.co.intra_mart.common.aid.jdk.java.util のクラス
ExtendedProperties
java.util.Properties を、より便利に利用するためのインタフェースを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ResourceBundleProperties (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス ResourceBundleProperties

java.lang.Object
    拡張 java.util.Dictionary
        拡張 java.util.Hashtable
            拡張 java.util.Properties
                拡張 jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties
すべての実装インタフェース:
Cloneable, Map, Serializable
public class ResourceBundleProperties
extends Properties

このクラスは、java.util.Properties クラスのインターフェースを実装した、 プロパティ管理クラスです。プロパティデータは、java.util.ResourceBundle により取得されます。
ロードできるリソースに関しては、java.util.ResourceBundle の 説明を参照して下さい。
このクラスのコンストラクタが、java.util.ResourceBundle クラスの getBundle() メソッドと同様の機能を提供しています。 各コンストラクタは、引数の同じ getBundle() メソッドに対応しています。

導入されたバージョン:
version 5.0
関連項目:
Properties, ResourceBundle, 直列化された形式

フィールドの概要
クラス java.util.Properties から継承したフィールド
defaults
コンストラクタの概要
ResourceBundleProperties(String baseName)
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String baseName, Locale locale)
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String baseName, Locale locale, ClassLoader loader)
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
メソッドの概要
 Locale getLocale()
ResourceBundle の Locale を返します。
クラス java.util.Properties から継承したメソッド
getProperty, getProperty, list, list, load, propertyNames, save, setProperty, store
クラス java.util.Hashtable から継承したメソッド
clear, clone, contains, containsKey, containsValue, elements, entrySet, equals, get, hashCode, isEmpty, keys, keySet, put, putAll, rehash, remove, size, toString, values
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ResourceBundleProperties

public ResourceBundleProperties(String baseName)
                         throws MissingResourceException
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。

パラメータ:
baseName - 目的のオブジェクトを含むリソースバンドルのファミリ名
例外:
MissingResourceException - リソースの照合に失敗した場合

ResourceBundleProperties

public ResourceBundleProperties(String baseName,
                                Locale locale)
                         throws MissingResourceException
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。

パラメータ:
baseName - 目的のオブジェクトを含むリソースバンドルのファミリ名
locale - 目的のロケール
例外:
MissingResourceException - リソースの照合に失敗した場合

ResourceBundleProperties

public ResourceBundleProperties(String baseName,
                                Locale locale,
                                ClassLoader loader)
                         throws MissingResourceException
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。

パラメータ:
baseName - 目的のオブジェクトを含むリソースバンドルのファミリ名
locale - 目的のロケール
loader - リソースをロードする ClassLoader
例外:
MissingResourceException - リソースの照合に失敗した場合
メソッドの詳細

getLocale

public Locale getLocale()
ResourceBundle の Locale を返します。
この関数は、このオブジェクトが本当に要求されたロケールに対応しているか、 またはフォールバックであるかを判定するために、このオブジェクトが 構築されたあとで使用できます。

この関数は、java.util.ResourceBundle クラスの getLocale() と 同じであり、java.util.ResourceBundle クラスとインターフェースを 合わせるために提供されています。 java.util.ResourceBundle クラスの getLocale() の説明を参照して下さい。

戻り値:
ロケール
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReverseComparator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス ReverseComparator

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator
        拡張 jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator
すべての実装インタフェース:
Comparator, Serializable
public class ReverseComparator
extends FilterComparator

コンパレータのフィルタとして機能します。
フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
ReverseComparator(Comparator comparator)
指定されたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
メソッドの概要
 int compare(Object arg0, Object arg1)
フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。
クラス jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator から継承したメソッド
getParentComparator
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

ReverseComparator

public ReverseComparator(Comparator comparator)
指定されたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。

パラメータ:
comparator - フィルター対象のコンパレータ
メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。

定義:
インタフェース Comparator 内の compare
オーバーライド:
クラス FilterComparator 内の compare
パラメータ:
arg0 - 引数１
arg1 - 引数２
戻り値:
フィルタ対象のコンパレータの compare() メソッドの結果を反転させた値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SequenceComparator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス SequenceComparator

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator
すべての実装インタフェース:
Comparator, Serializable
public class SequenceComparator
extends Object
implements Comparator, Serializable

挿入順にソートするためのコンパレータです。
このコンパレータは挿入が早い物から遅い物の順に並べます。
このコンパレータは、挿入されたオブジェクトの順番をインスタンス変数として持っています。 そのため、複数のオブジェクトでこのコンパレータを共有使用すると正しく動作しない可能性があります。
またこのクラスは、java.lang.TreeSet、java.lang.TreeMapで使用されることを想定して作られています。 そのため、他のクラスのコンパレータとして使用すると正しく動作しない可能性があります。 クラスで管理できるオブジェクトの数は、２の３１乗-１までのみ管理できます。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
SequenceComparator()
新しいオブジェクトを生成します。
メソッドの概要
 int compare(Object arg0, Object arg1)
順序付けのために ２ つの引数を比較するメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

SequenceComparator

public SequenceComparator()
新しいオブジェクトを生成します。

メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
順序付けのために ２ つの引数を比較するメソッドです。
最初の引数が ２ 番目の引数より小さ い場合は負の整数、両方が等しい場合は 0、最初の引数が 2 番目の引 数より大きい場合は正の整数を返します。
このメソッドの目的は、挿入順にソートすることです。 引数１と引数２を比較したとき、引数１の方が挿入が遅いときは正の数、早い時は負の数を返します。
引数１と引数２が同じインスタンスの時は０を返します

定義:
インタフェース Comparator 内の compare
パラメータ:
arg0 - 引き数１
arg1 - 引き数２
戻り値:
比較した結果
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties の使用

jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.common.aid.jdk.javax.xml (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.common.aid.jdk.javax.xml
クラス
XMLProperties


jp.co.intra_mart.common.aid.jdk.javax.xml (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.javax.xml

このパッケージには、ＸＭＬを利用するためのクラスが含まれています。

参照:
説明

クラスの概要
XMLProperties XML をベースとした不変のプロパティセットを表します。

パッケージ jp.co.intra_mart.common.aid.jdk.javax.xml の説明

このパッケージには、ＸＭＬを利用するためのクラスが含まれています。


jp.co.intra_mart.common.aid.jdk.javax.xml クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.javax.xml の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.util.Dictionary
      • class java.util.Hashtable (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class java.util.Properties
          • class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties
            • class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties
              • class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties


パッケージ jp.co.intra_mart.common.aid.jdk.javax.xml の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.javax.xml の使用

jp.co.intra_mart.common.aid.jdk.javax.xml はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


XMLProperties (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.javax.xml
クラス XMLProperties

java.lang.Object
    拡張 java.util.Dictionary
        拡張 java.util.Hashtable
            拡張 java.util.Properties
                拡張 jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties
                    拡張 jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties
                        拡張 jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties
すべての実装インタフェース:
Cloneable, Map, Serializable
public class XMLProperties
extends ElementProperties

XML をベースとした不変のプロパティセットを表します。 このクラスは、XML を元データとして、Properties として 利用できるインタフェースを提供します。

読み込んだ XML ソースは、DocumentBuilderFactory が 返すパーサを利用して解析します。 XML で記述された各情報に対しては、XPath 形式の文字列をプロパティ名として Properties.getProperty(java.lang.String) により アクセスできます。

プロパティ名の例

  • /root/elm1 ・・・タグに挟まれた文字列情報
  • /root/elm1/@attr ・・・タグの属性
  • /root/elm1/text() ・・・タグに挟まれた文字列情報を連結したもの
  • /root/elm1/comment() ・・・コメントを連結したもの

上記以外の XPath 構文は、解釈できません。 また、.. や // 等を用いた相対指定もできません。

取得できる値は、テキストノードおよび属性(attribute)ノードの値のみです。 コメントノード等の値は取得できません。

バージョン:
Version 5.0
関連項目:
直列化された形式

フィールドの概要
クラス java.util.Properties から継承したフィールド
defaults
コンストラクタの概要
XMLProperties(File f)
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputSource in)
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputSource in, Properties parent)
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputStream in)
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputStream in, Properties parent)
指定データを持つ新しいプロパティセットを作成します。
メソッドの概要
 Document getDocument()
設定ファイルのドキュメントノードを返します。
クラス jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties から継承したメソッド
getElement, getProperties
クラス jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties から継承したメソッド
doubleValue, doubleValue, floatValue, floatValue, intValue, intValue, isFalse, isTrue, longValue, longValue, parseInt, parseLong
クラス java.util.Properties から継承したメソッド
getProperty, getProperty, list, list, load, propertyNames, save, setProperty, store
クラス java.util.Hashtable から継承したメソッド
clear, clone, contains, containsKey, containsValue, elements, entrySet, equals, get, hashCode, isEmpty, keys, keySet, put, putAll, rehash, remove, size, toString, values
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

XMLProperties

public XMLProperties(File f)
              throws FileNotFoundException,
                     ParserConfigurationException,
                     SAXException,
                     IOException
指定データを持つ新しいプロパティセットを作成します。

パラメータ:
f - 設定ファイル（xml）のパス
例外:
FileNotFoundException - ファイルがな場合。またはファイルにアクセスできない場合。
IOException - 入出力エラー
SAXException - XML の解析エラー
ParserConfigurationException - XML の解析エラー

XMLProperties

public XMLProperties(InputStream in)
              throws ParserConfigurationException,
                     SAXException,
                     IOException
指定データを持つ新しいプロパティセットを作成します。

パラメータ:
in - XML ソースを入力するストリーム
例外:
IOException - 入出力エラー
SAXException - XML の解析エラー
ParserConfigurationException - XML の解析エラー

XMLProperties

public XMLProperties(InputSource in)
              throws ParserConfigurationException,
                     SAXException,
                     IOException
指定データを持つ新しいプロパティセットを作成します。

パラメータ:
in - XML ソースを入力するストリーム
例外:
IOException - 入出力エラー
SAXException - XML の解析エラー
ParserConfigurationException - XML の解析エラー

XMLProperties

public XMLProperties(InputStream in,
                     Properties parent)
              throws ParserConfigurationException,
                     SAXException,
                     IOException
指定データを持つ新しいプロパティセットを作成します。

パラメータ:
in - XML ソースを入力するストリーム
parent - 基礎データ
例外:
IOException - 入出力エラー
SAXException - XML の解析エラー
ParserConfigurationException - XML の解析エラー

XMLProperties

public XMLProperties(InputSource in,
                     Properties parent)
              throws ParserConfigurationException,
                     SAXException,
                     IOException
指定データを持つ新しいプロパティセットを作成します。

パラメータ:
in - XML ソースを入力するストリーム
parent - 基礎データ
例外:
IOException - 入出力エラー
SAXException - XML の解析エラー
ParserConfigurationException - XML の解析エラー
メソッドの詳細

getDocument

public Document getDocument()
設定ファイルのドキュメントノードを返します。

戻り値:
ドキュメントノード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties の使用

ElementProperties を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.javax.xml このパッケージには、ＸＭＬを利用するためのクラスが含まれています。

jp.co.intra_mart.common.aid.jdk.javax.xml での ElementProperties の使用

jp.co.intra_mart.common.aid.jdk.javax.xml での ElementProperties のサブクラス
 class XMLProperties
XML をベースとした不変のプロパティセットを表します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ElementProperties (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.org.w3c.dom
クラス ElementProperties

java.lang.Object
    拡張 java.util.Dictionary
        拡張 java.util.Hashtable
            拡張 java.util.Properties
                拡張 jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties
                    拡張 jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties
すべての実装インタフェース:
Cloneable, Map, Serializable
直系の既知のサブクラス:
XMLProperties
public class ElementProperties
extends ExtendedProperties

DOM をベースとした不変のプロパティセットを表します。 このクラスは、DOM を元データとして、Properties として 利用できるインタフェースを提供します。

DOM の各情報に対しては、XPath 形式の文字列をプロパティ名として Properties.getProperty(java.lang.String) により アクセスできます。

プロパティ名の例

  • /root/elm1 ・・・タグに挟まれた文字列情報
  • /root/elm1/@attr ・・・タグの属性
  • /root/elm1/text() ・・・タグに挟まれた文字列情報を連結したもの
  • /root/elm1/comment() ・・・コメントを連結したもの

上記以外の XPath 構文は、解釈できません。 また、.. や // 等を用いた相対指定もできません。

取得できる値は、テキストノードおよび属性(attribute)ノードの値のみです。 コメントノード等の値は取得できません。

バージョン:
Version 5.0
関連項目:
直列化された形式

フィールドの概要
クラス java.util.Properties から継承したフィールド
defaults
コンストラクタの概要
ElementProperties(Element element)
指定のエレメントの情報をプロパティズ化します。
ElementProperties(Element element, Properties parent)
指定のエレメントの情報をプロパティズ化します。
メソッドの概要
Element | getElement() 現在のプロパティズの元となったエレメントノードを返します。
String[] | getProperties(String key) 指定のキーにマップされた値のリストを返します。
クラス jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties から継承したメソッド
doubleValue, doubleValue, floatValue, floatValue, intValue, intValue, isFalse, isTrue, longValue, longValue, parseInt, parseLong
クラス java.util.Properties から継承したメソッド
getProperty, getProperty, list, list, load, propertyNames, save, setProperty, store
クラス java.util.Hashtable から継承したメソッド
clear, clone, contains, containsKey, containsValue, elements, entrySet, equals, get, hashCode, isEmpty, keys, keySet, put, putAll, rehash, remove, size, toString, values
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ElementProperties

public ElementProperties(Element element)
指定のエレメントの情報をプロパティズ化します。

パラメータ:
element - プロパティズ化するエレメントノード

ElementProperties

public ElementProperties(Element element,
                         Properties parent)
指定のエレメントの情報をプロパティズ化します。

パラメータ:
element - プロパティズ化するエレメントノード
parent - 基礎データ
メソッドの詳細

getElement

public Element getElement()
現在のプロパティズの元となったエレメントノードを返します。

戻り値:
エレメントノード

getProperties

public String[] getProperties(String key)
指定のキーにマップされた値のリストを返します。
XML 中で同名のタグが連続している場合など、タグや属性から生成された キー名称が同一のもののすべてを返します。

パラメータ:
key - キー
戻り値:
キーにマップされた値の配列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.org.w3c.dom (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.common.aid.jdk.org.w3c.dom
クラス
ElementProperties


jp.co.intra_mart.common.aid.jdk.org.w3c.dom (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.org.w3c.dom

このパッケージには、ＤＯＭを利用するためのクラスが含まれています。

参照:
説明

クラスの概要
ElementProperties DOM をベースとした不変のプロパティセットを表します。

パッケージ jp.co.intra_mart.common.aid.jdk.org.w3c.dom の説明

このパッケージには、ＤＯＭを利用するためのクラスが含まれています。


jp.co.intra_mart.common.aid.jdk.org.w3c.dom クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.org.w3c.dom の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.util.Dictionary
      • class java.util.Hashtable (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class java.util.Properties
          • class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties
            • class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties


パッケージ jp.co.intra_mart.common.aid.jdk.org.w3c.dom の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.org.w3c.dom の使用

jp.co.intra_mart.common.aid.jdk.org.w3c.dom を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.javax.xml このパッケージには、ＸＭＬを利用するためのクラスが含まれています。

jp.co.intra_mart.common.aid.jdk.javax.xml により使用される jp.co.intra_mart.common.aid.jdk.org.w3c.dom のクラス
ElementProperties
DOM をベースとした不変のプロパティセットを表します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter の使用

AdvancedOutputStreamWriter を使用しているパッケージ
jp.co.intra_mart.foundation.utility.charset このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.charset での AdvancedOutputStreamWriter の使用

AdvancedOutputStreamWriter を返す jp.co.intra_mart.foundation.utility.charset のメソッド
static AdvancedOutputStreamWriter AdvancedOutputStreamWriter.createWriter(OutputStreamWriter writer)
推奨されていません。 AdvancedOutputStreamWriter のスーパークラス AdvancedOutputStreamWriter を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder の使用

jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager の使用

jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException の使用

ResourceFormatException を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.charset | このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.charset | このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.charset での ResourceFormatException の使用

ResourceFormatException をスローする jp.co.intra_mart.common.aid.jdk.util.charset のメソッド
protected  void CharacterEncoder.setCharacterEncoding(String enc)
このオブジェクトが対象とする文字エンコーディングを設定します。

ResourceFormatException をスローする jp.co.intra_mart.common.aid.jdk.util.charset のコンストラクタ
CharacterEncoder(String enc)
文字コード変換のためのエンコーダを作成します。
AdvancedOutputStreamWriter(OutputStream out, String charsetName)
指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out)
デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, Charset cs)
与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, CharsetEncoder enc)
与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter writer)
OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。

jp.co.intra_mart.foundation.utility.charset での ResourceFormatException の使用

jp.co.intra_mart.foundation.utility.charset での ResourceFormatException のサブクラス
 class ResourceFormatException
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException の使用

ResourceNotFoundException を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.charset | このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.charset | このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.charset での ResourceNotFoundException の使用

ResourceNotFoundException をスローする jp.co.intra_mart.common.aid.jdk.util.charset のメソッド
protected  void CharacterEncoder.setCharacterEncoding(String enc)
このオブジェクトが対象とする文字エンコーディングを設定します。

ResourceNotFoundException をスローする jp.co.intra_mart.common.aid.jdk.util.charset のコンストラクタ
CharacterEncoder(String enc)
文字コード変換のためのエンコーダを作成します。
AdvancedOutputStreamWriter(OutputStream out, String charsetName)
指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out)
デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, Charset cs)
与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, CharsetEncoder enc)
与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter writer)
OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。

jp.co.intra_mart.foundation.utility.charset での ResourceNotFoundException の使用

jp.co.intra_mart.foundation.utility.charset での ResourceNotFoundException のサブクラス
 class ResourceNotFoundException
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AdvancedOutputStreamWriter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.charset
クラス AdvancedOutputStreamWriter

java.lang.Object
    拡張 java.io.Writer
        拡張 java.io.FilterWriter
            拡張 jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter
public class AdvancedOutputStreamWriter
extends FilterWriter

このクラスは、基礎となる java.io.OutputStreamWriter をフィルタリングした Writer 機能を提供します。

通常、ASCII の範囲に含まれない文字は、java.io.OutputStreamWriter を 利用して相互に文字コード変換した場合、各文字エンコーディングの Unicode に対するマッピングの相違により、本来その文字エンコーディングにおいて 存在する文字であってもコード不明を意味する「?」に置き換えられてしまう ことがあります。 いわゆる、この文字化けに対して、文字コード変換前に、 対象となる文字エンコーディングに対する Unicode の正しい文字に 置換することで、いくつかの文字については正しく文字コード変換することが できます。
このクラスでは、この方式により文字化けを回避します。

文字化けに対する文字のマッピングおよび対応する文字エンコーディングに 関しては、jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder クラスの仕様に準じます。

導入されたバージョン:
version 5.0
関連項目:
jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder

フィールドの概要
クラス java.io.FilterWriter から継承したフィールド
out
クラス java.io.Writer から継承したフィールド
lock
コンストラクタの概要
AdvancedOutputStreamWriter(OutputStream out)
デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, Charset cs)
与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, CharsetEncoder enc)
与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, String charsetName)
指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter writer)
OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。
メソッドの概要
String | getCharacterEncoding() このオブジェクトが対象としている文字エンコーディング名を返します。
OutputStreamWriter | getOutputStreamWriter() このオブジェクトの基礎出力となっている java.io.OutputStreamWriter を返します。
void | write(char[] cbuf, int off, int len) 文字の配列の一部を書き込みます。
void | write(int c) 単一の文字を書き込みます。
void | write(String str, int off, int len) 文字列の一部を書き込みます。
クラス java.io.FilterWriter から継承したメソッド
close, flush
クラス java.io.Writer から継承したメソッド
write, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStream out,
                                  String charsetName)
                           throws UnsupportedEncodingException,
                                  ResourceNotFoundException,
                                  ResourceFormatException,
                                  IOException
指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。

パラメータ:
out - 基礎となる出力ストリーム
charsetName - サポートされる charset の名前
例外:
UnsupportedEncodingException - 指定された文字エンコーディングがサポートされていない場合
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
IOException - 設定の読み込みエラー
ResourceFormatException - 設定に不整合がある場合

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStream out)
                           throws ResourceFormatException,
                                  ResourceNotFoundException,
                                  IOException
デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。

パラメータ:
out - 基礎となる出力ストリーム
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
IOException - 設定の読み込みエラー
ResourceFormatException - 設定に不整合がある場合

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStream out,
                                  Charset cs)
                           throws IOException,
                                  ResourceFormatException,
                                  ResourceNotFoundException
与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。

パラメータ:
out - 基礎となる出力ストリーム
cs - サポートされる Charset
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
IOException - 入出力エラー
ResourceFormatException - 設定に不整合がある場合

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStream out,
                                  CharsetEncoder enc)
                           throws ResourceFormatException,
                                  IOException,
                                  ResourceNotFoundException
与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。

パラメータ:
out - 基礎となる出力ストリーム
enc - 文字エンコーディングエンコーダ
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
IOException - 設定の読み込みエラー
ResourceFormatException - 設定に不整合がある場合

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStreamWriter writer)
                           throws ResourceNotFoundException,
                                  IOException,
                                  ResourceFormatException
OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。

なお、このオブジェクトが対応する文字エンコーディングは、 java.io.OutputStreamWriter#getEncoding() の返す値によって 決定します。 java.io.OutputStreamWriter#getEncoding() が null を返す場合、 このコンストラクタは NUllPointerException をスローして オブジェクトの作成に失敗します。

パラメータ:
writer - 基本となるストリームを提供する java.io.OutputStreamWriter オブジェクト
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
ResourceFormatException - 設定に不整合がある場合
IOException - 設定の読み込みエラー
メソッドの詳細

getCharacterEncoding

public String getCharacterEncoding()
このオブジェクトが対象としている文字エンコーディング名を返します。

戻り値:
文字エンコーディング名

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
文字の配列の一部を書き込みます。

パラメータ:
cbuf - 書き込む文字のバッファ
off - 文字の読み込み開始オフセット
len - 書き込む文字数
例外:
IOException - 入出力エラーが発生した場合

write

public void write(int c)
           throws IOException
単一の文字を書き込みます。

パラメータ:
c - 書き込む文字を指定する int
例外:
IOException - 入出力エラーが発生した場合

write

public void write(String str,
                  int off,
                  int len)
           throws IOException
文字列の一部を書き込みます。

パラメータ:
str - 書き込まれる文字列
off - 文字の読み込み開始オフセット
len - 書き込む文字数
例外:
IOException - 入出力エラーが発生した場合

getOutputStreamWriter

public OutputStreamWriter getOutputStreamWriter()
このオブジェクトの基礎出力となっている java.io.OutputStreamWriter を返します。

戻り値:
基礎となっている java.io.OutputStreamWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CharacterEncoder (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.charset
クラス CharacterEncoder

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder
public class CharacterEncoder
extends Object

このクラスは、文字エンコードの機能を提供します。

このクラスは、Java runtime が提供する通常の文字コード変換において 文字のマッピング定義の相違に起因して文字化けしてしまう現象を解決するための 一つの方法となります。 実際には、定義ファイルに設定されている文字をネイティブコードへ変換する前に 他の文字へ変更する事により、文字化けを防ぎます。

例えば、EUC_JP における文字「～」は、 Unicode へ変換した際 0x301C(Wave Dash) にマッピングされます。 これに対して、SJIS では文字「～」は、 Unicode の 0xFF5E(Fullwidth Tilde) にマッピングされています。 このため、相互に文字コード変換をすると、 文字「?」に置き換わると言う現象(いわゆる文字化け)が発生します。
このクラスでは、Unicode から SJIS へ変換する際に Unicode の文字 0x301C(Wave Dash) を 0xFF5E(Fullwidth Tilde) へ変更してから 文字コード変換を行います。

定義ファイルは、クラスローダを利用して検索および読み込まれます。 したがって、定義ファイルはクラスパスに設定されているディレクトリまたは アーカイブファイル内に配置する必要があります。
各文字エンコーディングと文字の変換テーブルの関連については、 定義ファイル jp/co/intra_mart/resources/charset/encoding/mapping.xml に記載されています。

導入されたバージョン:
version 5.0

コンストラクタの概要
CharacterEncoder(String enc)
文字コード変換のためのエンコーダを作成します。
メソッドの概要
byte[] | encode(char c) 指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。
byte[] | encode(char[] c) 指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。
byte[] | encode(String str) 指定の文字列を getCharacterEncoding() で表される文字コードへ エンコードします。
String | getCharacterEncoding() このオブジェクトが対象としている文字エンコーディング名を返します。
String | newString(char[] c) getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
String | newString(String str) getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
protected void | setCharacterEncoding(String enc) このオブジェクトが対象とする文字エンコーディングを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CharacterEncoder

public CharacterEncoder(String enc)
                 throws ResourceNotFoundException,
                        ResourceFormatException,
                        IOException
文字コード変換のためのエンコーダを作成します。

パラメータ:
enc - エンコーディング名
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 設定が見つからなかった場合
ResourceFormatException - 設定情報が不適切だった場合
IOException - 入出力エラー
メソッドの詳細

getCharacterEncoding

public String getCharacterEncoding()
このオブジェクトが対象としている文字エンコーディング名を返します。

戻り値:
文字エンコーディング名

setCharacterEncoding

protected void setCharacterEncoding(String enc)
                             throws ResourceFormatException,
                                    ResourceNotFoundException,
                                    IOException
このオブジェクトが対象とする文字エンコーディングを設定します。

パラメータ:
enc - エンコーディング名
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 設定が見つからなかった場合
ResourceFormatException - 設定情報が不適切だった場合
IOException - 入出力エラー

encode

public byte[] encode(char c)
              throws UnsupportedEncodingException,
                     IOException
指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。

パラメータ:
c - 文字
戻り値:
エンコードされたバイト列
例外:
UnsupportedEncodingException
IOException

encode

public byte[] encode(char[] c)
              throws UnsupportedEncodingException,
                     IOException
指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。

パラメータ:
c - 文字配列
戻り値:
エンコードされたバイト列
例外:
UnsupportedEncodingException
IOException

encode

public byte[] encode(String str)
              throws UnsupportedEncodingException,
                     IOException
指定の文字列を getCharacterEncoding() で表される文字コードへ エンコードします。

パラメータ:
str - 文字列
戻り値:
エンコードされたバイト列
例外:
UnsupportedEncodingException
IOException

newString

public String newString(String str)
getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。

返される文字列は、引数 str のマッピングを修正した 新しい文字列です。

パラメータ:
str - 文字列
戻り値:
マッピングを修正された新しい文字列

newString

public String newString(char[] c)
getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。

返される文字列は、引数 c のマッピングを修正した 新しい文字列です。
引数の配列 c は変化しません。

パラメータ:
c - 文字配列
戻り値:
新しい文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CharacterSetManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.charset
クラス CharacterSetManager

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager
public class CharacterSetManager
extends Object

このクラスは J2SE,v1.4 でサポートされているエンコーディングセットと、 IANAに登録されているキャラクタセット名とのマッピング情報を管理するオブジェクトです。

J2SE,v1.4でサポートされているエンコーディングセット名から IANAに登録されているキャラクタセット名へのマッピングについては、 定義ファイル jp/co/intra_mart/common/aid/jdk/util/charset/jdk2iana.properties に記載されています。

IANAに登録されているキャラクタセット名と J2SE,v1.4 でサポートされているエンコーディングセット名へのマッピングについては、 定義ファイル jp/co/intra_mart/common/aid/jdk/util/charset/jdk2iana.properties に記載されています。

導入されたバージョン:
version 5.0

コンストラクタの概要
CharacterSetManager()
メソッドの概要
static String | toIANAName(String jdkEncodingSetName) 指定されたエンコーディングセット名に対応する IANAに登録されている キャラクタセット名 を返却します。
static String | toJDKName(String ianaCharacterSetName) 指定されたキャラクタセット名 に対応する J2SEでサポートされているエンコーディングセット名を返却します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CharacterSetManager

public CharacterSetManager()
メソッドの詳細

toJDKName

public static String toJDKName(String ianaCharacterSetName)
指定されたキャラクタセット名 に対応する J2SEでサポートされているエンコーディングセット名を返却します。
対応するエンコーディングセット名が見つからない場合には 指定されたキャラクタセット名をそのまま返却します。

パラメータ:
ianaCharacterSetName - IANAに登録されている キャラクタセット名
戻り値:
J2SEでサポートされているエンコーディングセット名

toIANAName

public static String toIANAName(String jdkEncodingSetName)
指定されたエンコーディングセット名に対応する IANAに登録されている キャラクタセット名 を返却します。
対応するキャラクタセット名が見つからない場合には 指定されたエンコーディングセット名をそのまま返却します。

パラメータ:
jdkEncodingSetName - J2SEでサポートされているエンコーディングセット名
戻り値:
IANAに登録されているキャラクタセット名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.util.charset (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.common.aid.jdk.util.charset
クラス
AdvancedOutputStreamWriter
CharacterEncoder
CharacterSetManager
例外
ResourceFormatException
ResourceNotFoundException


jp.co.intra_mart.common.aid.jdk.util.charset (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.util.charset

このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

参照:
説明

クラスの概要
AdvancedOutputStreamWriter | このクラスは、基礎となる java.io.OutputStreamWriter をフィルタリングした Writer 機能を提供します。
CharacterEncoder | このクラスは、文字エンコードの機能を提供します。
CharacterSetManager | このクラスは J2SE,v1.4 でサポートされているエンコーディングセットと、 IANAに登録されているキャラクタセット名とのマッピング情報を管理するオブジェクトです。

例外の概要
ResourceFormatException | リソースの内容が不適切であることを通知する例外です。
ResourceNotFoundException | リソースがないことを通知する例外です。

パッケージ jp.co.intra_mart.common.aid.jdk.util.charset の説明

このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。


jp.co.intra_mart.common.aid.jdk.util.charset クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.util.charset の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder
    • class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException
        • class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException
    • class java.io.Writer
      • class java.io.FilterWriter
        • class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter


パッケージ jp.co.intra_mart.common.aid.jdk.util.charset の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.util.charset の使用

jp.co.intra_mart.common.aid.jdk.util.charset を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.charset | このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.charset | このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.charset により使用される jp.co.intra_mart.common.aid.jdk.util.charset のクラス
ResourceFormatException
リソースの内容が不適切であることを通知する例外です。
ResourceNotFoundException
リソースがないことを通知する例外です。

jp.co.intra_mart.foundation.utility.charset により使用される jp.co.intra_mart.common.aid.jdk.util.charset のクラス
AdvancedOutputStreamWriter
このクラスは、基礎となる java.io.OutputStreamWriter をフィルタリングした Writer 機能を提供します。
ResourceFormatException
リソースの内容が不適切であることを通知する例外です。
ResourceNotFoundException
リソースがないことを通知する例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ResourceFormatException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.charset
クラス ResourceFormatException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ResourceFormatException
public class ResourceFormatException
extends Exception

リソースの内容が不適切であることを通知する例外です。

設定の内容に誤りがあるか、または定義の書式が正しくない場合にスローされます。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
ResourceFormatException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceFormatException(String msg, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ResourceFormatException

public ResourceFormatException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

ResourceFormatException

public ResourceFormatException(String msg,
                               Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ResourceNotFoundException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.charset
クラス ResourceNotFoundException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ResourceNotFoundException
public class ResourceNotFoundException
extends Exception

リソースがないことを通知する例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
ResourceNotFoundException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceNotFoundException(String msg, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ResourceNotFoundException

public ResourceNotFoundException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

ResourceNotFoundException

public ResourceNotFoundException(String msg,
                                 Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.aid.jdk.util.Counter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.Counter の使用

jp.co.intra_mart.common.aid.jdk.util.Counter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.ErrorEvent の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.ErrorEvent の使用

ErrorEvent を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util での ErrorEvent の使用

ErrorEvent 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.util のメソッド
 void ErrorEventListener.handleError(ErrorEvent err)
発生した例外を通知します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener の使用

ErrorEventListener を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.io このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.io での ErrorEventListener の使用

ErrorEventListener 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.java.io のコンストラクタ
ExtendedOutputStream(OutputStream out, ErrorEventListener listener)
出力ストリームを構築します。
ExtendedInputStream(InputStream in, ErrorEventListener listener)
入力ストリームを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.util.EventListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.util.EventListener の使用

EventListener を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util での EventListener の使用

EventListener 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.util のメソッド
 void EventQueueController.entry(EventListener listener)
イベントリスナーの登録。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.EventQueueController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.EventQueueController の使用

EventQueueController を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.report での EventQueueController の使用

EventQueueController 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.util.report のコンストラクタ
RepresentativeReporter(MessageReporter out, EventQueueController queue)
指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.LockMonitor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.LockMonitor の使用

jp.co.intra_mart.common.aid.jdk.util.LockMonitor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions の使用

jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter の使用

AbstractMessageReporter を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.report での AbstractMessageReporter の使用

jp.co.intra_mart.common.aid.jdk.util.report での AbstractMessageReporter のサブクラス
class | FileReporter メッセージのファイル出力機能を提供します。
class | MultiCastReporter メッセージを複数のストリームに出力するためのフィルタークラスです。
class | PrintStreamReporter メッセージ出力用クラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner の使用

jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.FileReporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.FileReporter の使用

jp.co.intra_mart.common.aid.jdk.util.report.FileReporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner の使用

jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter の使用

FilterMessageReporter を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.report での FilterMessageReporter の使用

jp.co.intra_mart.common.aid.jdk.util.report での FilterMessageReporter のサブクラス
class | LineReportFilter メッセージを行出力するためのフィルタークラスです。
class | ReportLevelFilter メッセージの出力制御を行うためのフィルタークラスです。
class | RepresentativeReporter メッセージ出力をイベント処理するためのフィルタークラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter の使用

jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter の使用

MessageReporter を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.report での MessageReporter の使用

MessageReporter を実装している jp.co.intra_mart.common.aid.jdk.util.report のクラス
class | AbstractMessageReporter メッセージ出力用のスケルトンクラスです。
class | FileReporter メッセージのファイル出力機能を提供します。
class | FilterMessageReporter メッセージ出力ストリームをフィルタ処理するクラスのスーパークラスです。
class | LineReportFilter メッセージを行出力するためのフィルタークラスです。
class | MultiCastReporter メッセージを複数のストリームに出力するためのフィルタークラスです。
class | PrintStreamReporter メッセージ出力用クラスです。
class | ReportLevelFilter メッセージの出力制御を行うためのフィルタークラスです。
class | RepresentativeReporter メッセージ出力をイベント処理するためのフィルタークラスです。

MessageReporter として宣言されている jp.co.intra_mart.common.aid.jdk.util.report のフィールド
protected  MessageReporter FilterMessageReporter.out
基礎出力ストリームです。

MessageReporter 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.util.report のメソッド
void | MultiCastReporter.addReporter(MessageReporter reporter) 指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。
boolean | MultiCastReporter.hasReporter(MessageReporter reporter) 指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。
boolean | MultiCastReporter.removeReporter(MessageReporter reporter) 指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。

MessageReporter 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.util.report のコンストラクタ
RepresentativeReporter(MessageReporter out, EventQueueController queue)
指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。
ReportLevelFilter(MessageReporter out, int level)
指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。
LineReportFilter(MessageReporter out)
指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。
FilterMessageReporter(MessageReporter out)
指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter の使用

jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner の使用

jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner の使用

jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter の使用

jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner の使用

ReportFileConditioner を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.report での ReportFileConditioner の使用

ReportFileConditioner を実装している jp.co.intra_mart.common.aid.jdk.util.report のクラス
class | EverydayConditioner このクラスは、時間によりリフレッシュイベントを 発生させるためのヘルパークラスです。
class | FileSizeConditioner このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
class | OutputSizeConditioner このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
class | PeriodicConditioner このクラスは、タイマーによりリフレッシュイベントを 発生させるためのヘルパークラスです。

ReportFileConditioner 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.util.report のメソッド
void | FileReporter.addConditioner(ReportFileConditioner conditioner) ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
boolean | FileReporter.removeConditioner(ReportFileConditioner conditioner) ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter の使用

ReportFileWriter を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.report での ReportFileWriter の使用

ReportFileWriter として宣言されている jp.co.intra_mart.common.aid.jdk.util.report のフィールド
protected  ReportFileWriter FileReporter.out
基礎出力ストリームです。

ReportFileWriter 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.util.report のメソッド
boolean | ReportFileConditioner.expiration(ReportFileWriter writer) メッセージファイルを再作成する必要があるかどうかを判定します。
boolean | PeriodicConditioner.expiration(ReportFileWriter writer) メッセージファイルを再作成する必要があるかどうかを判定します。
boolean | OutputSizeConditioner.expiration(ReportFileWriter writer) メッセージファイルを再作成する必要があるかどうかを判定します。
boolean | FileSizeConditioner.expiration(ReportFileWriter writer) メッセージファイルを再作成する必要があるかどうかを判定します。
boolean | EverydayConditioner.expiration(ReportFileWriter writer) メッセージファイルを再作成する必要があるかどうかを判定します。

ReportFileWriter 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.util.report のコンストラクタ
FileReporter(ReportFileWriter out)
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の使用

ReportLevel を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.report での ReportLevel の使用

ReportLevel を実装している jp.co.intra_mart.common.aid.jdk.util.report のクラス
 class ReportLevelFilter
メッセージの出力制御を行うためのフィルタークラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter の使用

jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter の使用

jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AbstractMessageReporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス AbstractMessageReporter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter
すべての実装インタフェース:
MessageReporter
直系の既知のサブクラス:
FileReporter, MultiCastReporter, PrintStreamReporter
public abstract class AbstractMessageReporter
extends Object
implements MessageReporter

メッセージ出力用のスケルトンクラスです。

サブクラスでは、report メソッドをオーバーライドして、 任意の出力先にメッセージを出力する機能を実装する必要があります。

導入されたバージョン:
version 5.0

コンストラクタの概要
protected AbstractMessageReporter()
唯一のコンストラクタ。
メソッドの概要
void | close() このオブジェクトを閉じます。
void | flush() このオブジェクトのバッファの情報をすべて出力します。
void | report(Object data) data をメッセージとして出力します。
abstract void | report(String message) メッセージを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractMessageReporter

protected AbstractMessageReporter()
唯一のコンストラクタ。

メソッドの詳細

report

public abstract void report(String message)
メッセージを出力します。

定義:
インタフェース MessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
data をメッセージとして出力します。
このメソッドは、以下の呼出と同じです。

report(String.valueOf(data))

定義:
インタフェース MessageReporter 内の report
パラメータ:
data - データ

close

public void close()
           throws IOException
このオブジェクトを閉じます。 オブジェクトが閉じられると、report メソッドは何もしなくなります。 必要に応じてサブクラスでオーバーライドしてください。

定義:
インタフェース MessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
このオブジェクトのバッファの情報をすべて出力します。 このメソッドは、何も行いません。 必要に応じてサブクラスでオーバーライドしてください。

定義:
インタフェース MessageReporter 内の flush
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EverydayConditioner (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス EverydayConditioner

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner
すべての実装インタフェース:
ReportFileConditioner
public class EverydayConditioner
extends Object
implements ReportFileConditioner

このクラスは、時間によりリフレッシュイベントを 発生させるためのヘルパークラスです。
このクラスは、FileReporter と組み合わせて利用します。 このクラスのオブジェクトを FileReporter オブジェクトにセットすることで、 指定時間になった(指定時間を経過した)ときに、 メッセージファイルのローテイト機能イベントを発生させることができます。 時間のチェックは時および分によるものなので、FileReporter の中で リフレッシュイベントは毎日発生することになります。

導入されたバージョン:
version 5.0
関連項目:
FileReporter, ReportFileWriter

コンストラクタの概要
EverydayConditioner(int hours, int minutes)
毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
EverydayConditioner(int hours, int minutes, TimeZone timeZone)
毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
メソッドの概要
 boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EverydayConditioner

public EverydayConditioner(int hours,
                           int minutes,
                           TimeZone timeZone)
                    throws IllegalArgumentException
毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
このオブジェクトは、毎日指定された時刻に なった場合にリフレッシュイベント発生を通知します。
時刻の計算は、指定されたタイムゾーンに基づきます。

パラメータ:
hours - 時間(0 ～ 23)
minutes - 分(0 ～ 59)
timeZone - タイムゾーン
例外:
IllegalArgumentException - 引数が有効範囲外の場合

EverydayConditioner

public EverydayConditioner(int hours,
                           int minutes)
                    throws IllegalArgumentException
毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
このオブジェクトは、毎日指定された時刻に なった場合にリフレッシュイベント発生を通知します。
時刻の計算は、デフォルトタイムゾーンに基づきます。

パラメータ:
hours - 時間(0 ～ 23)
minutes - 分(0 ～ 59)
例外:
IllegalArgumentException - 引数が有効範囲外の場合
メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
このオブジェクトの作成時に指定された時刻を経過して最初の呼び出し時 の場合 true を返します。

定義:
インタフェース ReportFileConditioner 内の expiration
パラメータ:
writer - 出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
関連項目:
FileReporter, ReportFileWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FileReporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス FileReporter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter
        拡張 jp.co.intra_mart.common.aid.jdk.util.report.FileReporter
すべての実装インタフェース:
MessageReporter
public class FileReporter
extends AbstractMessageReporter

メッセージのファイル出力機能を提供します。

このクラスは、report メソッドで渡されたメッセージを指定のファイルに 出力します。

導入されたバージョン:
version 5.0

フィールドの概要
protected  ReportFileWriter out
基礎出力ストリームです。
コンストラクタの概要
FileReporter(ReportFileWriter out)
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
メソッドの概要
void | addConditioner(ReportFileConditioner conditioner) ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
void | close() このオブジェクトを閉じます。
protected void | finalize() このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
void | flush() このオブジェクトのバッファの情報をすべて出力します。
boolean | removeConditioner(ReportFileConditioner conditioner) ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。
void | report(String message) メッセージを出力します。
クラス jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter から継承したメソッド
report
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

out

protected ReportFileWriter out
基礎出力ストリームです。

コンストラクタの詳細

FileReporter

public FileReporter(ReportFileWriter out)
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。

パラメータ:
out - 基礎出力ストリーム
メソッドの詳細

addConditioner

public void addConditioner(ReportFileConditioner conditioner)
ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
引数が null の場合は、何の効果もありません。 また、conditioner が既に登録済みのインスタンスである場合、 追加登録はされません。

パラメータ:
conditioner - 追加する ReportFileConditioner のインスタンス

removeConditioner

public boolean removeConditioner(ReportFileConditioner conditioner)
ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。
引数が null の場合は、何の効果もありません。

パラメータ:
conditioner - 削除する ReportFileConditioner のインスタンス
戻り値:
指定のオブジェクトを削除できた場合 true。

report

public void report(String message)
メッセージを出力します。 このオブジェクトが既に閉じられている場合、このメソッドは 何も行いません。

定義:
インタフェース MessageReporter 内の report
定義:
クラス AbstractMessageReporter 内の report
パラメータ:
message - メッセージ

close

public void close()
           throws IOException
このオブジェクトを閉じます。 このオブジェクトに関わる全てのリソースを開放します。 オブジェクトが閉じられると、report メソッドは何もしなくなります。

定義:
インタフェース MessageReporter 内の close
オーバーライド:
クラス AbstractMessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
このオブジェクトのバッファの情報をすべて出力します。 また、このメソッドは基礎ストリームも同時にフラッシュします。

定義:
インタフェース MessageReporter 内の flush
オーバーライド:
クラス AbstractMessageReporter 内の flush
例外:
IOException - 入出力エラー

finalize

protected void finalize()
                 throws Throwable
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
このオブジェクトの全てのリソースを破棄します。

例外:
Throwable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FileSizeConditioner (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス FileSizeConditioner

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner
すべての実装インタフェース:
ReportFileConditioner
public class FileSizeConditioner
extends Object
implements ReportFileConditioner

このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
このクラスは、FileReporter と組み合わせて利用します。 このクラスのオブジェクトを FileReporter オブジェクトにセットすることで、 メッセージファイルが一定サイズ以上になったときに、 メッセージファイルのローテイト機能イベントを発生させることができます。

導入されたバージョン:
version 5.0
関連項目:
FileReporter, ReportFileWriter

コンストラクタの概要
FileSizeConditioner(long max)
メッセージファイルのサイズによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
メソッドの概要
 boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FileSizeConditioner

public FileSizeConditioner(long max)
                    throws IllegalArgumentException
メッセージファイルのサイズによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
このオブジェクトは、メッセージファイルが指定の大きさ(max)以上に なった場合にリフレッシュイベント発生を通知します。

例外:
IllegalArgumentException - max がゼロ以下の場合
メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
ファイルサイズが、このオブジェクトの作成時に指定された 値以上の場合 true を返します。

定義:
インタフェース ReportFileConditioner 内の expiration
パラメータ:
writer - 出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
関連項目:
FileReporter, ReportFileWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FilterMessageReporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス FilterMessageReporter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter
すべての実装インタフェース:
MessageReporter
直系の既知のサブクラス:
LineReportFilter, ReportLevelFilter, RepresentativeReporter
public class FilterMessageReporter
extends Object
implements MessageReporter

メッセージ出力ストリームをフィルタ処理するクラスのスーパークラスです。

基礎出力ストリームにメッセージを出力する前にメッセージを加工したりする 追加機能を提供するクラスを作成するために利用することができます。

このクラスは、単に MessageReporter の全てのメソッドを オーバーライドし、各要求を基礎出力ストリームに渡す機能を提供しています。 サブクラスでは、メソッドを追加したり、必要に応じてメソッドをオーバーライド することがあります。

導入されたバージョン:
version 5.0

フィールドの概要
protected  MessageReporter out
基礎出力ストリームです。
コンストラクタの概要
FilterMessageReporter(MessageReporter out)
指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。
メソッドの概要
void | close() このオブジェクトを閉じます。
void | flush() このオブジェクトのバッファの情報をすべて出力します。
void | report(Object data) 基礎出力ストリームに対してメッセージを出力します。
void | report(String message) 基礎出力ストリームに対してメッセージを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

out

protected MessageReporter out
基礎出力ストリームです。

コンストラクタの詳細

FilterMessageReporter

public FilterMessageReporter(MessageReporter out)
指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。

パラメータ:
out - 基礎出力リポーター
メソッドの詳細

report

public void report(String message)
基礎出力ストリームに対してメッセージを出力します。
このメソッドは、単純に message を基礎出力ストリームに渡します。 サブクラスで、このメソッドをオーバーライドすることにより、 データの加工などのフィルタリング処理を追加することができます。

定義:
インタフェース MessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
基礎出力ストリームに対してメッセージを出力します。
このメソッドは、単純に data を基礎出力ストリームに渡します。 サブクラスで、このメソッドをオーバーライドすることにより、 データの加工などのフィルタリング処理を追加することができます。

定義:
インタフェース MessageReporter 内の report
パラメータ:
data - データ

close

public void close()
           throws IOException
このオブジェクトを閉じます。 オブジェクトが閉じられると、report メソッドは何もしなくなります。

定義:
インタフェース MessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
このオブジェクトのバッファの情報をすべて出力します。 このメソッドでは、基礎出力リポートオブジェクトも同時にフラッシュします。

定義:
インタフェース MessageReporter 内の flush
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LineReportFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス LineReportFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter
        拡張 jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter
すべての実装インタフェース:
MessageReporter
public class LineReportFilter
extends FilterMessageReporter

メッセージを行出力するためのフィルタークラスです。

このクラスを利用すると、report メソッドに渡されたメッセージ文字列に 改行コードを付加して、行出力することができます。
以下のようなプログラムにより、ログファイルをログファイルを作成することが できます。

FIle logFile = new File("test.log");
ReportFileWriter writer = new ReportFileWriter(logFile);
FileReporter writer = new FileReporter(writer);
MessageReporter reporter = new LineReportFilter(writer);
これで、変数 reporter の report メソッドを呼び出す毎に、 ファイル test.log に report メソッド指定したメッセージが １行として出力されます。

導入されたバージョン:
version 5.0
関連項目:
ReportLevel

フィールドの概要
クラス jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter から継承したフィールド
out
コンストラクタの概要
LineReportFilter(MessageReporter out)
指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。
メソッドの概要
void | report(Object data) 基礎出力ストリームに対してメッセージを出力します。
void | report(String message) メッセージを出力します。
クラス jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter から継承したメソッド
close, flush
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LineReportFilter

public LineReportFilter(MessageReporter out)
指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。

パラメータ:
out - 基礎出力ストリーム
メソッドの詳細

report

public void report(String message)
メッセージを出力します。
このメソッドは、基礎出力ストリームに対して、message に 改行コードを付加してメッセージを１行出力します。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
基礎出力ストリームに対してメッセージを出力します。
このメソッドは、単純に data を基礎出力ストリームに渡します。 サブクラスで、このメソッドをオーバーライドすることにより、 データの加工などのフィルタリング処理を追加することができます。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
data - データ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MessageReporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
インタフェース MessageReporter

既知の実装クラスの一覧:
AbstractMessageReporter, FilterMessageReporter
public interface MessageReporter

メッセージ出力のためのインターフェースです。

このインターフェースを実装したクラスでは、report メソッドで 指定されたメッセージを任意の出力先に対して出力する機能を提供します。

導入されたバージョン:
version 5.0

メソッドの概要
void | close() このオブジェクトを閉じます。
void | flush() このオブジェクトのバッファの情報をすべて出力します。
void | report(Object data) data をメッセージとして出力します。
void | report(String message) メッセージを出力します。

メソッドの詳細

report

public void report(String message)
メッセージを出力します。

パラメータ:
message - メッセージ

report

public void report(Object data)
data をメッセージとして出力します。

パラメータ:
data - データ

close

public void close()
           throws IOException
このオブジェクトを閉じます。 オブジェクトが閉じられると、report メソッドは何もしなくなります。 このメソッドは、任意のオペレーションです。

例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
このオブジェクトのバッファの情報をすべて出力します。 このメソッドは、任意のオペレーションです。

例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MultiCastReporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス MultiCastReporter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter
        拡張 jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter
すべての実装インタフェース:
MessageReporter
public class MultiCastReporter
extends AbstractMessageReporter

メッセージを複数のストリームに出力するためのフィルタークラスです。

このクラスは、MessageReporter インターフェースを実装したクラスに対する フィルタークラスとして働きます。 report メソッドに渡されたメッセージデータは、指定された複数の MessageReporter インターフェースすべてに渡されます。
このフィルタークラスを利用することにより、複数の MessageReporter に 対して同じメッセージを渡すことができるため、メッセージ出力プログラムを 効率的に記述することができます。

メッセージの出力先となる MessageReporter は、addReporter メソッドで 定義します。addReporter メソッドでの定義順と、実際の実行順は 保証されません。

導入されたバージョン:
version 5.0

コンストラクタの概要
MultiCastReporter()
唯一のコンストラクタ。
メソッドの概要
void | addReporter(MessageReporter reporter) 指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。
void | close() このオブジェクトを閉じます。
void | flush() このオブジェクトのバッファの情報をすべて出力します。
Iterator | getReporters() セット内の要素についての反復子を返します。
boolean | hasReporter(MessageReporter reporter) 指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。
boolean | removeReporter(MessageReporter reporter) 指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。
void | report(Object data) data をメッセージとして出力します。
void | report(String message) メッセージを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MultiCastReporter

public MultiCastReporter()
唯一のコンストラクタ。

メソッドの詳細

addReporter

public void addReporter(MessageReporter reporter)
指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。 すでに指定のオブジェクトを要素としてもっていた場合、 このメソッドは何も行いません。

パラメータ:
reporter - セットに追加される要素

hasReporter

public boolean hasReporter(MessageReporter reporter)
指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。

パラメータ:
reporter - セットに含まれているかチェックする要素
戻り値:
セット内に指定された要素がある場合は true

removeReporter

public boolean removeReporter(MessageReporter reporter)
指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。

パラメータ:
reporter - セットにあった場合に削除されるオブジェクト
戻り値:
指定された要素がセット内にあった場合は true

getReporters

public Iterator getReporters()
セット内の要素についての反復子を返します。 反復子から取得される各要素は、addReporter メソッドにより追加された リポーターオブジェクトになります。 各要素の取得順は保証されません。 このオブジェクトが閉じられている場合 null を返します。

戻り値:
セット内の要素についての反復子

report

public void report(String message)
メッセージを出力します。

定義:
インタフェース MessageReporter 内の report
定義:
クラス AbstractMessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
data をメッセージとして出力します。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス AbstractMessageReporter 内の report
パラメータ:
data - データ

close

public void close()
           throws IOException
このオブジェクトを閉じます。 オブジェクトが閉じられると、report メソッドは何もしなくなります。 このオブジェクトの持つすべての Reporter オブジェクトを閉じて、 リソースを開放します。

定義:
インタフェース MessageReporter 内の close
オーバーライド:
クラス AbstractMessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
このオブジェクトのバッファの情報をすべて出力します。 このメソッドは、何も行いません。 このオブジェクトの持つすべての Reporter オブジェクトをフラッシュします。

定義:
インタフェース MessageReporter 内の flush
オーバーライド:
クラス AbstractMessageReporter 内の flush
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


OutputSizeConditioner (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス OutputSizeConditioner

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner
すべての実装インタフェース:
ReportFileConditioner
public class OutputSizeConditioner
extends Object
implements ReportFileConditioner

このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
このクラスは、FileReporter と組み合わせて利用します。 このクラスのオブジェクトを FileReporter オブジェクトにセットすることで、 メッセージファイルが一定サイズ以上になったときに、 メッセージファイルのローテイト機能イベントを発生させることができます。

導入されたバージョン:
version 5.0
関連項目:
FileReporter, ReportFileWriter

コンストラクタの概要
OutputSizeConditioner(long max)
メッセージファイルへのデータ出力量によりリフレッシュイベントを 発生させるためのヘルパーオブジェクトを構築します。
メソッドの概要
 boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

OutputSizeConditioner

public OutputSizeConditioner(long max)
                      throws IllegalArgumentException
メッセージファイルへのデータ出力量によりリフレッシュイベントを 発生させるためのヘルパーオブジェクトを構築します。
このオブジェクトは、ログファイルへ書き出したメッセージの量が 一定(max)以上の大きさに なった場合にリフレッシュイベント発生を通知します。

例外:
IllegalArgumentException - max がゼロ以下の場合
メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
ファイルへの出力文字数が、このオブジェクトの作成時に指定された 値以上の場合 true を返します。

定義:
インタフェース ReportFileConditioner 内の expiration
パラメータ:
writer - 出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
関連項目:
FileReporter, ReportFileWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.util.report (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.common.aid.jdk.util.report
インタフェース
MessageReporter
ReportFileConditioner
ReportLevel
クラス
AbstractMessageReporter
EverydayConditioner
FileReporter
FileSizeConditioner
FilterMessageReporter
LineReportFilter
MultiCastReporter
OutputSizeConditioner
PeriodicConditioner
PrintStreamReporter
ReportFileWriter
ReportLevelFilter
RepresentativeReporter


jp.co.intra_mart.common.aid.jdk.util.report (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.util.report

このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

参照:
説明

インタフェースの概要
MessageReporter | メッセージ出力のためのインターフェースです。
ReportFileConditioner | このクラスは、ReportFileWriter の初期化チェックのインターフェースです。
ReportLevel | メッセージレベルのインターフェースです。

クラスの概要
AbstractMessageReporter | メッセージ出力用のスケルトンクラスです。
EverydayConditioner | このクラスは、時間によりリフレッシュイベントを 発生させるためのヘルパークラスです。
FileReporter | メッセージのファイル出力機能を提供します。
FileSizeConditioner | このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
FilterMessageReporter | メッセージ出力ストリームをフィルタ処理するクラスのスーパークラスです。
LineReportFilter | メッセージを行出力するためのフィルタークラスです。
MultiCastReporter | メッセージを複数のストリームに出力するためのフィルタークラスです。
OutputSizeConditioner | このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
PeriodicConditioner | このクラスは、タイマーによりリフレッシュイベントを 発生させるためのヘルパークラスです。
PrintStreamReporter | メッセージ出力用クラスです。
ReportFileWriter | メッセージをファイルに出力するストリームクラスです。
ReportLevelFilter | メッセージの出力制御を行うためのフィルタークラスです。
RepresentativeReporter | メッセージ出力をイベント処理するためのフィルタークラスです。

パッケージ jp.co.intra_mart.common.aid.jdk.util.report の説明

このパッケージには、ログ機能を実装するための汎用クラスが含まれています。


jp.co.intra_mart.common.aid.jdk.util.report クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.util.report の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter (implements jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter)
      • class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter
      • class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter
      • class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter
    • class jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter (implements jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter)
      • class jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter
      • class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel)
      • class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter
    • class jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class java.io.Writer
      • class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter

インタフェース階層

  • interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter
  • interface jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner
  • interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel


パッケージ jp.co.intra_mart.common.aid.jdk.util.report の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.util.report の使用

jp.co.intra_mart.common.aid.jdk.util.report を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.report により使用される jp.co.intra_mart.common.aid.jdk.util.report のクラス
AbstractMessageReporter
メッセージ出力用のスケルトンクラスです。
FilterMessageReporter
メッセージ出力ストリームをフィルタ処理するクラスのスーパークラスです。
MessageReporter
メッセージ出力のためのインターフェースです。
ReportFileConditioner
このクラスは、ReportFileWriter の初期化チェックのインターフェースです。
ReportFileWriter
メッセージをファイルに出力するストリームクラスです。
ReportLevel
メッセージレベルのインターフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PeriodicConditioner (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス PeriodicConditioner

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner
すべての実装インタフェース:
ReportFileConditioner
public class PeriodicConditioner
extends Object
implements ReportFileConditioner

このクラスは、タイマーによりリフレッシュイベントを 発生させるためのヘルパークラスです。
このクラスは、FileReporter と組み合わせて利用します。 このクラスのオブジェクトを FileReporter オブジェクトにセットすることで、 一定期間の経過に合わせてに、 メッセージファイルのローテイト機能イベントを発生させることができます。

導入されたバージョン:
version 5.0
関連項目:
FileReporter, ReportFileWriter

コンストラクタの概要
PeriodicConditioner(long millis)
タイマーによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
メソッドの概要
 boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PeriodicConditioner

public PeriodicConditioner(long millis)
                    throws IllegalArgumentException
タイマーによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
このオブジェクトは、指定の時間が経過した時に リフレッシュイベント発生を通知します。

例外:
IllegalArgumentException - millis がゼロ以下の場合
メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
引数 outputSize の値が、このオブジェクトの作成時に指定された 値以上の場合 true を返します。

定義:
インタフェース ReportFileConditioner 内の expiration
パラメータ:
writer - 出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
関連項目:
FileReporter, ReportFileWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PrintStreamReporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス PrintStreamReporter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter
        拡張 jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter
すべての実装インタフェース:
MessageReporter
public class PrintStreamReporter
extends AbstractMessageReporter

メッセージ出力用クラスです。

このクラスは、指定の PrintStream に対してメッセージを出力するための 機能を実装しています。 例えば、このクラスのコンストラクタの引数に java.lang.System.out を指定した 場合、標準出力に対してメッセージを出力することができます。
このクラスの特徴は、report メソッドに渡されたメッセージを PrintStream の println メソッドに渡します。 これにより、report メソッドの呼び出し毎にメッセージを改行付きで 指定の PrintStream に出力することができます（１行毎に出力）。

導入されたバージョン:
version 5.0

コンストラクタの概要
PrintStreamReporter(PrintStream out)
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
メソッドの概要
void | close() このオブジェクトを閉じます。
void | flush() このオブジェクトのバッファの情報をすべて出力します。
void | report(String message) メッセージを出力します。
クラス jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter から継承したメソッド
report
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PrintStreamReporter

public PrintStreamReporter(PrintStream out)
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。

パラメータ:
out - 基礎出力ストリーム
メソッドの詳細

report

public void report(String message)
メッセージを出力します。 このオブジェクトが既に閉じられている場合、このメソッドは 何も行いません。

定義:
インタフェース MessageReporter 内の report
定義:
クラス AbstractMessageReporter 内の report
パラメータ:
message - メッセージ

close

public void close()
           throws IOException
このオブジェクトを閉じます。 このオブジェクトに関わる全てのリソースを開放します。 オブジェクトが閉じられると、report メソッドは何もしなくなります。

定義:
インタフェース MessageReporter 内の close
オーバーライド:
クラス AbstractMessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
このオブジェクトのバッファの情報をすべて出力します。 また、このメソッドは基礎ストリームも同時にフラッシュします。

定義:
インタフェース MessageReporter 内の flush
オーバーライド:
クラス AbstractMessageReporter 内の flush
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReportFileConditioner (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
インタフェース ReportFileConditioner

既知の実装クラスの一覧:
EverydayConditioner, FileSizeConditioner, OutputSizeConditioner, PeriodicConditioner
public interface ReportFileConditioner

このクラスは、ReportFileWriter の初期化チェックのインターフェースです。

このクラスは FileReporter クラスにより ReportFileWriter へのメッセージ 書き出し前に呼び出されます。
このクラスは、FileReporter および ReportFileWriter オブジェクトと 組み合わせて使います。 これらのクラスと連携することにより、メッセージファイルの ローテイト機能などを実装することができます。

導入されたバージョン:
version 5.0

メソッドの概要
 boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。

メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
このメソッドは、FileReporter クラスにより呼び出されます。 真値(true)を返すと、ReportFileWriter は現在のログファイルに対して 初期化処理を行います。 メッセージファイルの初期化処理に関しては、 ReportFileWriter クラス(または、そのサブクラス)により行われます。

パラメータ:
writer - メッセージファイルへの出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReportFileWriter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス ReportFileWriter

java.lang.Object
    拡張 java.io.Writer
        拡張 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter
public class ReportFileWriter
extends Writer

メッセージをファイルに出力するストリームクラスです。

このクラスは、メッセージを指定のファイルに対して出力するための スケルトンです。 また、このクラスは reset メソッドをオーバーライドすることにより、 ファイルのローテイト機能などを実装することができます。

導入されたバージョン:
version 5.0

フィールドの概要
クラス java.io.Writer から継承したフィールド
lock
コンストラクタの概要
ReportFileWriter(File f)
ファイルへメッセージを書き出すためのライターオブジェクトを作成します。
メソッドの概要
void | close() ストリームを閉じてフラッシュします。
protected Writer | createWriter() メッセージをファイルへ書き出すための出力ストリームを作成します。
Writer | currentWriter() このオブジェクトが文字を書き出している基礎 Writer を返します。
protected void | finalize() このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
void | flush() ストリームをフラッシュします。
File | getFile() このオブジェクトが文字を書き出すファイルを取得します。
void | handleShutdown() シャットダウンイベントが発生したときに実行されるメソッドです。
long | length() このライターの出力文字数を取得します。
protected void | reconstruction() 現在使用中の Writer をリセットします。
protected Writer | reset(Writer writer) 文字の出力ストリームをリセットします。
void | write(char[] cbuf, int off, int len) 基礎ストリームに文字を出力します。
クラス java.io.Writer から継承したメソッド
write, write, write, write
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ReportFileWriter

public ReportFileWriter(File f)
                 throws IOException
ファイルへメッセージを書き出すためのライターオブジェクトを作成します。

パラメータ:
f - このライターで書き出すファイル
例外:
IOException - 入出力エラー
メソッドの詳細

getFile

public File getFile()
このオブジェクトが文字を書き出すファイルを取得します。
このメソッドは、このオブジェクトの作成時にコンストラクタの引数として 与えられた File オブジェクトへの参照を返します。

戻り値:
このライターで書き出すファイル

createWriter

protected Writer createWriter()
                       throws IOException
メッセージをファイルへ書き出すための出力ストリームを作成します。

このメソッドは、単に getFile メソッドが返すファイルに対して 文字を書き出すための出力ストリームを作成して返します。 このメソッドの返す出力ストリームを使うことで、 getFile メソッドの返す ファイルに対してメッセージを追記していくことができます。
メッセージを任意の文字コードに変換したり、出力バッファを備えた Writer オブジェクトを作成する必要がある場合には、サブクラスで このメソッドをオーバーライドして実装して下さい。

戻り値:
出力ストリーム
例外:
IOException

length

public long length()
このライターの出力文字数を取得します。
このメソッドで返される文字数は、このファイルに対して 現在までに出力した文字数です。 文字数カウンタは、reset メソッドを実行することにより 0 (ゼロ)にリセットされます。

戻り値:
出力文字数

currentWriter

public Writer currentWriter()
このオブジェクトが文字を書き出している基礎 Writer を返します。

戻り値:
基礎 Writer オブジェクト

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
基礎ストリームに文字を出力します。
このメソッドをサブクラスがオーバーライドすることにより、 バッファ機能などを実装することができます。 ただし、このメソッドをオーバーライドしたサブクラスは、 同時に length メソッドもオーバーライドする必要があります。

パラメータ:
cbuf - 文字の配列
off - 文字の書き込み開始オフセット
len - 書き込む文字数
例外:
IOException

reconstruction

protected void reconstruction()
                       throws IOException
現在使用中の Writer をリセットします。
このメソッドは、FileReporter クラスにより呼び出されます。 FileReporter オブジェクトでは、ReportFileConditioner オブジェクトが ファイルの初期化を必要と判断した場合に、このメソッドを呼び出して、 Writer の初期化を求めてきます。 これにより、リポートファイルのローテイト機能などを 実装することができます。

例外:
IOException

reset

protected Writer reset(Writer writer)
                throws IOException
文字の出力ストリームをリセットします。

このメソッドは reset メソッドに呼び出されます。
このメソッドは、単に引数のストリーム(writer)をそのまま リターンします。ファイルのローテイト機能などを実装する場合、 サブクラスでこのメソッドをオーバーライドして下さい。

パラメータ:
writer - 現在のストリーム
戻り値:
新しいストリーム
例外:
IOException

close

public void close()
           throws IOException
ストリームを閉じてフラッシュします。
ストリームを一度閉じると、以降 write() または flush() を呼び出すと、 IOException がスローされます。 ただし、前に閉じたストリームを閉じても効果はありません。

例外:
IOException - 入出力エラーが発生した場合

flush

public void flush()
           throws IOException
ストリームをフラッシュします。
ストリームがさまざまな write() メソッドからの文字をバッファに 保存してある場合、これらの文字の目的の宛先にただちに文字を書き込みます。 宛先が別の文字またはバイトストリームの場合は、 この宛先をフラッシュします。 つまり 1 つの flush() の呼び出しで、 関連する Writer および OutputStream の すべてのバッファをフラッシュします。

サブクラスで、文字のバッファリング機能を実装している場合、 このメソッドをオーバーライドしてバッファに保存している 文字をフラッシュするように実装しなければいけません。

例外:
IOException - 入出力エラーが発生した場合

finalize

protected void finalize()
                 throws Throwable
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
このオブジェクトの全てのリソースを破棄します。

例外:
Throwable

handleShutdown

public void handleShutdown()
シャットダウンイベントが発生したときに実行されるメソッドです。 このメソッドは、シャットダウンイベント発生時に、 バッファされているバイトをすべて出力するために flush() メソッドを呼び出します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReportLevel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
インタフェース ReportLevel

既知の実装クラスの一覧:
ReportLevelFilter
public interface ReportLevel

メッセージレベルのインターフェースです。

このインターフェースは、定数値化したメッセージレベルを示します。 すべてのメッセージに関して、必ずしもこのインターフェースで定義されている レベル値を使う必要はありませんが、このインターフェースを利用することにより プログラム全体でレベル値を統一することができます。

導入されたバージョン:
version 5.0

フィールドの概要
static int | MAX_VALUE レベル値として使用可能な最大値 この値は、java.lang.Integer.MAX_VALUE と同じです。
static int | MIN_VALUE レベル値として使用可能な最小値 この値は、java.lang.Integer.MIN_VALUE と同じです。
static int | TYPE_DEBUG デバッグレベル。
static int | TYPE_ERROR エラーレベル。
static int | TYPE_REPORT 通常の情報レベル。
static int | TYPE_WARNING 警告レベル。

フィールドの詳細

MIN_VALUE

public static final int MIN_VALUE
レベル値として使用可能な最小値 この値は、java.lang.Integer.MIN_VALUE と同じです。

関連項目:
定数フィールド値

MAX_VALUE

public static final int MAX_VALUE
レベル値として使用可能な最大値 この値は、java.lang.Integer.MAX_VALUE と同じです。

関連項目:
定数フィールド値

TYPE_DEBUG

public static final int TYPE_DEBUG
デバッグレベル。 デバッグ情報を出力する場合に利用します。

関連項目:
定数フィールド値

TYPE_REPORT

public static final int TYPE_REPORT
通常の情報レベル。
常に以下の関係が成り立ちます。

TYPE_DEBUG < TYPE_REPORT

関連項目:
定数フィールド値

TYPE_WARNING

public static final int TYPE_WARNING
警告レベル。 警告メッセージ出力時に利用します。
常に以下の関係が成り立ちます。

TYPE_REPORT < TYPE_WARNING

関連項目:
定数フィールド値

TYPE_ERROR

public static final int TYPE_ERROR
エラーレベル。 エラーメッセージ出力時に利用します。
常に以下の関係が成り立ちます。

TYPE_WARNING < TYPE_ERROR

関連項目:
定数フィールド値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ReportLevelFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス ReportLevelFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter
        拡張 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter
すべての実装インタフェース:
MessageReporter, ReportLevel
public class ReportLevelFilter
extends FilterMessageReporter
implements ReportLevel

メッセージの出力制御を行うためのフィルタークラスです。

このクラスを利用することにより、メッセージをメッセージレベルにより、 出力制御を行うことができます。

導入されたバージョン:
version 5.0
関連項目:
ReportLevel

フィールドの概要
protected  int datumpoint
このリポーターがフィルタリングする基準レベル値
クラス jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter から継承したフィールド
out
インタフェース jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel から継承したフィールド
MAX_VALUE, MIN_VALUE, TYPE_DEBUG, TYPE_ERROR, TYPE_REPORT, TYPE_WARNING
コンストラクタの概要
ReportLevelFilter(MessageReporter out, int level)
指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。
メソッドの概要
void | report(Object data) data をメッセージとして出力します。
void | report(Object data, int level) 指定のメッセージレベルが基準値以上のメッセージを出力します。
void | report(String message) メッセージを出力します。
void | report(String message, int level) 指定のメッセージレベルが基準値以上のメッセージを出力します。
クラス jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter から継承したメソッド
close, flush
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

datumpoint

protected int datumpoint
このリポーターがフィルタリングする基準レベル値

コンストラクタの詳細

ReportLevelFilter

public ReportLevelFilter(MessageReporter out,
                         int level)
指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。

パラメータ:
out - 基礎出力リポーター
メソッドの詳細

report

public void report(String message)
メッセージを出力します。
このメソッドは、以下の呼出と同じです。

report(message, ReportLevel.MAX_VALUE)

つまり、メッセージ message は必ず基礎出力リポーターに出力されます。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(String message,
                   int level)
指定のメッセージレベルが基準値以上のメッセージを出力します。
メッセージレベルは以下の式で判定されます。

this.datumpoint <= level

判定式が true の場合、基礎出力リポーターに対して メッセージが出力されます。逆に判定結果が false の場合、 このメソッドは何も行いません。

パラメータ:
message - メッセージ
level - メッセージレベル

report

public void report(Object data)
data をメッセージとして出力します。
このメソッドは、以下の呼出と同じです。

report(data, ReportLevel.MAX_VALUE)

つまり、メッセージデータ data は必ず基礎出力リポーターに出力されます。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
data - データ

report

public void report(Object data,
                   int level)
指定のメッセージレベルが基準値以上のメッセージを出力します。
メッセージレベルは以下の式で判定されます。

this.datumpoint <= level

判定式が true の場合、基礎出力リポーターに対して メッセージが出力されます。逆に判定結果が false の場合、 このメソッドは何も行いません。

パラメータ:
data - データ
level - メッセージレベル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RepresentativeReporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス RepresentativeReporter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter
        拡張 jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter
すべての実装インタフェース:
MessageReporter
public class RepresentativeReporter
extends FilterMessageReporter

メッセージ出力をイベント処理するためのフィルタークラスです。

このクラスを利用することにより、メッセージの MessageReporter における 処理を現在のスレッドと並列実行させることができます。 これにより、このクラスの report メソッドと、出力先となる MessageReporter の report メソッドの実行は非同期に処理されます。

このクラスを利用することのメリットは、メッセージの出力処理を 待たなくても、現在のスレッドの実行を継続できることにあります。 逆に、このクラスを利用することにより、メッセージ出力処理と現在のスレッド処理 がスレッドセーフであることが保証されなければなりません。
report メソッドで指定されたメッセージはキューに蓄積され、 現在のスレッドと異なるメッセージ処理専用のスレッドで 基礎出力ストリームに渡されます。 メッセージの出力処理は、現在のスレッドと非同期ですが、 report メソッドの実行順とメッセージの出力順は保証されます。

導入されたバージョン:
version 5.0

フィールドの概要
クラス jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter から継承したフィールド
out
コンストラクタの概要
RepresentativeReporter(MessageReporter out, EventQueueController queue)
指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。
メソッドの概要
boolean | canReport() このストリームが書き込み可能かどうかをチェックします。
void | close() ストリームを閉じます。
void | flush() ストリームをフラッシュします。
void | report(Object data) data をメッセージとして出力します。
void | report(String message) メッセージを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RepresentativeReporter

public RepresentativeReporter(MessageReporter out,
                              EventQueueController queue)
指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。

パラメータ:
out - 基礎出力リポーター
メソッドの詳細

canReport

public boolean canReport()
このストリームが書き込み可能かどうかをチェックします。

戻り値:
ストリームの書き込みが可能な場合 true、そうでない場合 false。

report

public void report(String message)
メッセージを出力します。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
data をメッセージとして出力します。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
data - データ

close

public void close()
           throws IOException
ストリームを閉じます。
このメソッドは、ストリームを閉じる前に flush メソッドを実行します。 オブジェクトが閉じられると、report メソッドは何もしなくなります。

定義:
インタフェース MessageReporter 内の close
オーバーライド:
クラス FilterMessageReporter 内の close
例外:
IOException - 入出力エラーが発生した場合

flush

public void flush()
           throws IOException
ストリームをフラッシュします。

ストリームに蓄積されているすべてのメッセージイベントを処理します。 このメソッドを実行した場合、現在のスレッドで メッセージが処理されます。また、このメソッドはすべてのメッセージ出力 処理が完了するまでブロックします。

定義:
インタフェース MessageReporter 内の flush
オーバーライド:
クラス FilterMessageReporter 内の flush
例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Counter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util
クラス Counter

java.lang.Object
    拡張 java.lang.Number
        拡張 jp.co.intra_mart.common.aid.jdk.util.Counter
すべての実装インタフェース:
Serializable
public class Counter
extends Number
implements Serializable

このクラスは、カウンター機能を提供します。

ある数値を基準として１ずつ増やしたり１ずつ減らしたりすることができます。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
Counter()
カウンターオブジェクトを作成します。
Counter(long initValue)
指定の初期値でカウンターオブジェクトを作成します。
メソッドの概要
long | decrement() カウンターの値を１だけ減少させます。
double | doubleValue() カウンターの現在の値を double 型として返します。
float | floatValue() カウンターの現在の値を float 型として返します。
long | increment() カウンターの値を１だけ増加させます。
int | intValue() カウンターの現在の値を int 型として返します。
long | longValue() カウンターの現在の値を long 型として返します。
クラス java.lang.Number から継承したメソッド
byteValue, shortValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Counter

public Counter()
カウンターオブジェクトを作成します。

初期値は０です。したがって、このコンストラクタの呼び出しは、 以下の呼び出しと同義です。
new Counter(0)

Counter

public Counter(long initValue)
指定の初期値でカウンターオブジェクトを作成します。

パラメータ:
initValue - カウンターの初期値
メソッドの詳細

increment

public long increment()
カウンターの値を１だけ増加させます。

戻り値:
変化後のカウンターの値

decrement

public long decrement()
カウンターの値を１だけ減少させます。

戻り値:
変化後のカウンターの値

intValue

public int intValue()
カウンターの現在の値を int 型として返します。 値を丸めたり切り捨てたりすることもあります。

戻り値:
このオブジェクトが表す数値を int 型に変換した値;

longValue

public long longValue()
カウンターの現在の値を long 型として返します。

戻り値:
このオブジェクトが表す数値を long 型に変換した値

floatValue

public float floatValue()
カウンターの現在の値を float 型として返します。 値を丸めることもあります。

戻り値:
このオブジェクトが表す数値を float 型に変換した値

doubleValue

public double doubleValue()
カウンターの現在の値を double 型として返します。 値を丸めることもあります。

戻り値:
このオブジェクトが表す数値を double 型に変換した値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ErrorEvent (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util
クラス ErrorEvent

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.ErrorEvent
public class ErrorEvent
extends Object

例外をイベントとして扱うためのプロトコルです。

イベントリスナー(インターフェース ErrorEventListener を実装したクラス) のオーナーオブジェクトは、例外の発生時にこのクラスのインスタンスを 生成して各リスナーに通知する義務があります。

導入されたバージョン:
version 5.0
関連項目:
ErrorEventListener

コンストラクタの概要
ErrorEvent(Throwable t, Object obj)
エラーを通知するためのイベントを構築します。
ErrorEvent(Throwable t, String msg, Object obj)
エラーを通知するためのイベントを構築します。
メソッドの概要
Throwable | getException() 通知されたエラーまたは例外を取得します。
String | getMessage() 通知されたエラーメッセージを取得します。
Object | getObject() 通知されたエラー発生オブジェクトを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ErrorEvent

public ErrorEvent(Throwable t,
                  Object obj)
エラーを通知するためのイベントを構築します。

obj パラメータはエラーの発生したクラスまたはインスタンスです。

パラメータ:
t - 発生した例外
obj - エラーの発生したオブジェクト

ErrorEvent

public ErrorEvent(Throwable t,
                  String msg,
                  Object obj)
エラーを通知するためのイベントを構築します。

obj パラメータはエラーの発生したクラスまたはインスタンスです。

パラメータ:
t - 発生した例外
msg - エラーメッセージ
obj - エラーの発生したオブジェクト
メソッドの詳細

getObject

public Object getObject()
通知されたエラー発生オブジェクトを取得します。

戻り値:
通知されたエラーオブジェクト

getMessage

public String getMessage()
通知されたエラーメッセージを取得します。 メッセージが通知されていない場合、通知されたエラーのメッセージを 返します。

戻り値:
通知されたエラーメッセージ
関連項目:
Throwable.getMessage()

getException

public Throwable getException()
通知されたエラーまたは例外を取得します。

戻り値:
通知されたエラーまたは例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ErrorEventListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util
インタフェース ErrorEventListener

public interface ErrorEventListener

例外をイベントとして扱うためのスケルトン実装を提供します。

このインターフェースを実装したクラスのインスタンスは例外の発生に伴い その例外をイベントとして受け取ることができます。 このインターフェースを実装しているクラスから生成されたインスタンスの オーナーオブジェクトは、 例外発生をイベントとしてインスタンスに対して通知する義務があります。

導入されたバージョン:
version 5.0

メソッドの概要
 void handleError(ErrorEvent err)
発生した例外を通知します。

メソッドの詳細

handleError

public void handleError(ErrorEvent err)
発生した例外を通知します。

パラメータ:
err - 発生したエラーイベント
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util
インタフェース EventListener

public interface EventListener

このクラスは、イベントリスナーのインターフェースです。

イベントコントローラと組み合わせて使うことにより、 様々なイベント機能を実装することができます。

導入されたバージョン:
version 5.0
関連項目:
EventQueueController

メソッドの概要
 void handleEvent()
イベントが発生した時にコントローラから呼び出されます。

メソッドの詳細

handleEvent

public void handleEvent()
イベントが発生した時にコントローラから呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventQueueController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util
クラス EventQueueController

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.EventQueueController
public class EventQueueController
extends Object

このクラスは、イベントリスナーを実行するイベント機能を実装します。

イベントコントローラは、指定された時間間隔に従ってリスナー登録状況を確認し、 リスナーの登録が１つ以上あった場合、これらを専用スレッドで実行します。 このとき、イベントリスナーの実行順と実行の直列化が保証されます。
これらの機能により、通常の関数実行や java.lang.Thread クラスを利用した 並列処理などと異なった機能を実装することができます。

このクラスを利用することにより、現在の処理とイベント処理を並列化することが できます。また、一つのコントローラは同時に一つのイベントリスナーしか 実行しないため、それぞれのリスナーの処理が並列処理されることはありません。 従って、リスナーはマルチスレッドを意識したプログラムにする必要がありますが、 リスナー間でマルチスレッドを意識する必要はありません。

導入されたバージョン:
version 5.0
関連項目:
EventListener

コンストラクタの概要
EventQueueController()
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
EventQueueController(long millis)
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
メソッドの概要
void | entry(EventListener listener) イベントリスナーの登録。
void | eventGenerating() キューに登録されているイベントリスナーを一つ実行します。
protected void | finalize() このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
void | flush() キューに溜まっているすべてのイベントリスナーを実行します。
void | setCapacity(int max) キューの容量を変更します。
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventQueueController

public EventQueueController()
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。 コントローラがリスナー登録状況を監視する時間間隔はデフォルト値(60秒)が 適用されます。

EventQueueController

public EventQueueController(long millis)
                     throws IllegalArgumentException
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。 millis は、リスナーの登録状況を監視する時間間隔です。 コントローラは、リスナーが一つも登録されていない状態になると、 millis ミリ秒間隔でリスナー登録の有無を確認します。

パラメータ:
millis - イベントの監視間隔(ミリ秒)
例外:
IllegalArgumentException - millis が 0 以下の場合
メソッドの詳細

setCapacity

public void setCapacity(int max)
                 throws IllegalStateException,
                        IllegalArgumentException
キューの容量を変更します。

パラメータ:
max - イベントをプールできる最大量
例外:
IllegalStateException - max 個以上のリスナーが登録されている場合
IllegalArgumentException - max が 0 以下の場合

entry

public void entry(EventListener listener)
           throws NullPointerException,
                  IndexOutOfBoundsException,
                  IllegalStateException
イベントリスナーの登録。
イベントリスナーは、一旦キューに溜められます。 キューに保管されたリスナーは、 このコントローラにより現在実行中のスレッドとは 別のスレッドで登録順に呼び出されます。

実行されたリスナーは、処理が終了すると破棄されます。

通常のスレッドクラスを利用した並列処理との違いは、 イベントリスナーが登録順に実行される点と、 イベントリスナーの実行が直列化される点にあります。

パラメータ:
listener - イベントリスナー
例外:
NullPointerException - listener が null の場合
IndexOutOfBoundsException - キューが飽和状態の場合
IllegalStateException - コントローラが破棄処理済の場合

flush

public void flush()
キューに溜まっているすべてのイベントリスナーを実行します。

このメソッドは、現在実行中のスレッドで すべてのイベント処理を行います。

eventGenerating

public void eventGenerating()
                     throws NoSuchElementException
キューに登録されているイベントリスナーを一つ実行します。 実行されるリスナーは、現在キューに保管されているリスナーの中で 最も過去に登録されたリスナーです。 このメソッドは、現在実行中のスレッドで 登録順で最も過去のイベントを１つ実行します。

例外:
NoSuchElementException - 登録リスナーがない場合

finalize

protected void finalize()
                 throws Throwable
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
このオブジェクトの全てのリソースを破棄します。

例外:
Throwable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LockMonitor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util
クラス LockMonitor

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.LockMonitor
public class LockMonitor
extends Object

このクラスはモニター機能を提供します。
このクラスでは、複数個のモニターを管理することができます。 アプリケーションでは、entry() メソッドによりモニターを取得し、 release() メソッドでモニターを開放します。

導入されたバージョン:
version 5.0

コンストラクタの概要
LockMonitor(int max)
モニターを構築します。
メソッドの概要
int | activeCount() 現在取得済みモニターの数を取得します。
void | entry() モニターの取得。
int | queue() モニターを取得するための待ち行列に入っているスレッドの数です。
void | release() モニターの開放。
int | size() このオブジェクトの管理するモニターの数を取得します。
int | total() モニターを利用中、または利用しようとしているスレッドの数です。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LockMonitor

public LockMonitor(int max)
モニターを構築します。

パラメータ:
max - 管理するモニターの個数
メソッドの詳細

entry

public void entry()
モニターの取得。

モニターを取得できるまでブロックします。 モニターの取得＝動作の権利を取得

size

public int size()
このオブジェクトの管理するモニターの数を取得します。

戻り値:
モニターの数

activeCount

public int activeCount()
現在取得済みモニターの数を取得します。

戻り値:
取得済みモニターの数

total

public int total()
モニターを利用中、または利用しようとしているスレッドの数です。

戻り値:
entry() メソッドを実行して release() メソッドを実行していないスレッドの数
導入されたバージョン:
version 4.2

queue

public int queue()
モニターを取得するための待ち行列に入っているスレッドの数です。

戻り値:
entry() メソッドを実行して、ブロック状態になっているスレッドの数
導入されたバージョン:
version 4.2

release

public void release()
モニターの開放。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MultipurposeInternetMailExtensions (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util
クラス MultipurposeInternetMailExtensions

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions
public class MultipurposeInternetMailExtensions
extends Object

MIME タイプを持つオブジェクトです。

導入されたバージョン:
version 5.0

コンストラクタの概要
MultipurposeInternetMailExtensions(File path)
MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(String filename)
MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(String mediaType, String subType)
指定のMIMEタイプを表すオブジェクトを構築します。
メソッドの概要
String | getMediaType() このオブジェクトが表す MIME タイプの Media Type を返します。
String | getSubType() このオブジェクトが表す MIME タイプの subtype を返します。
String | getType() このオブジェクトが表す MIME タイプを返します。
String | toString() このオブジェクトの文字列表現を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MultipurposeInternetMailExtensions

public MultipurposeInternetMailExtensions(String filename)
MIMEタイプを表すオブジェクトを構築します。

MIME タイプは引数 filename の拡張子により解決されます。
引数 filename に拡張子がない場合や、拡張子から MIME タイプを解決 出来なかった場合には、オブジェクトの表す MIME タイプは application/octet-stream となります。

パラメータ:
filename - ファイル名

MultipurposeInternetMailExtensions

public MultipurposeInternetMailExtensions(File path)
MIMEタイプを表すオブジェクトを構築します。

MIME タイプは引数 path の表すファイル名の拡張子により解決されます。
引数 path の表すファイル名に拡張子がない場合や、拡張子から MIME タイプを 解決出来なかった場合には、オブジェクトの表す MIME タイプは application/octet-stream となります。

パラメータ:
path - ファイル名を表す File クラスのインスタンス

MultipurposeInternetMailExtensions

public MultipurposeInternetMailExtensions(String mediaType,
                                          String subType)
指定のMIMEタイプを表すオブジェクトを構築します。

このコンストラクタにより構築されたオブジェクトの表す MIME タイプは、 mediaType "/" subType となります。

パラメータ:
mediaType - メディアタイプを表すキーワード
subType - サブタイプを表すキーワード
メソッドの詳細

getMediaType

public String getMediaType()
このオブジェクトが表す MIME タイプの Media Type を返します。

戻り値:
Media Type を表す文字列

getSubType

public String getSubType()
このオブジェクトが表す MIME タイプの subtype を返します。

戻り値:
subtype を表す文字列

getType

public String getType()
このオブジェクトが表す MIME タイプを返します。

戻り値:
MIME タイプを表す文字列

toString

public String toString()
このオブジェクトの文字列表現を返します。

戻り値:
MIME タイプを表す文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.util (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.common.aid.jdk.util
インタフェース
ErrorEventListener
EventListener
クラス
Counter
ErrorEvent
EventQueueController
LockMonitor
MultipurposeInternetMailExtensions


jp.co.intra_mart.common.aid.jdk.util (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.util

このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

参照:
説明

インタフェースの概要
ErrorEventListener | 例外をイベントとして扱うためのスケルトン実装を提供します。
EventListener | このクラスは、イベントリスナーのインターフェースです。

クラスの概要
Counter | このクラスは、カウンター機能を提供します。
ErrorEvent | 例外をイベントとして扱うためのプロトコルです。
EventQueueController | このクラスは、イベントリスナーを実行するイベント機能を実装します。
LockMonitor | このクラスはモニター機能を提供します。
MultipurposeInternetMailExtensions | MIME タイプを持つオブジェクトです。

パッケージ jp.co.intra_mart.common.aid.jdk.util の説明

このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。


jp.co.intra_mart.common.aid.jdk.util クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent
    • class jp.co.intra_mart.common.aid.jdk.util.EventQueueController
    • class jp.co.intra_mart.common.aid.jdk.util.LockMonitor
    • class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions
    • class java.lang.Number (implements java.io.Serializable)
      • class jp.co.intra_mart.common.aid.jdk.util.Counter (implements java.io.Serializable)

インタフェース階層

  • interface jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener
  • interface jp.co.intra_mart.common.aid.jdk.util.EventListener


パッケージ jp.co.intra_mart.common.aid.jdk.util の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.util の使用

jp.co.intra_mart.common.aid.jdk.util を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.io | このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util | このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util.report | このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.io により使用される jp.co.intra_mart.common.aid.jdk.util のクラス
ErrorEventListener
例外をイベントとして扱うためのスケルトン実装を提供します。

jp.co.intra_mart.common.aid.jdk.util により使用される jp.co.intra_mart.common.aid.jdk.util のクラス
ErrorEvent
例外をイベントとして扱うためのプロトコルです。
EventListener
このクラスは、イベントリスナーのインターフェースです。

jp.co.intra_mart.common.aid.jdk.util.report により使用される jp.co.intra_mart.common.aid.jdk.util のクラス
EventQueueController
このクラスは、イベントリスナーを実行するイベント機能を実装します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse の使用

ExtendedServletResponse を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter | このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http | このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での ExtendedServletResponse の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での ExtendedServletResponse のサブインタフェース
 interface HttpServletResponseEventController
レスポンスイベントコントローラのインタフェース。

ExtendedServletResponse を実装している jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のクラス
 class AbstractHttpServletResponseEventController
イベントを制御するレスポンスの抽象実装です。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http での ExtendedServletResponse の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http での ExtendedServletResponse のサブインタフェース
 interface ExtendedHttpServletResponse
このインタフェースは、HttpServletResponseを拡張したものです。

ExtendedServletResponse を実装している jp.co.intra_mart.common.aid.jsdk.javax.servlet.http のクラス
class | ExtendedHttpServletResponseWrapper レスポンスのサプクラス化による拡張を可能とする ExtendedHttpServletResponse インタフェースの簡潔な実装方法を提供します。
class | SearchableHttpServletResponseWrapper HttpServletResponseWrapperの拡張実装を提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException の使用

BadRequestException を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception での BadRequestException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception での BadRequestException のサブクラス
class | EmptyQueryException クエリがない場合にスローされる例外です。
class | ExcessiveQueryException クエリが Content-Length ヘッダで指定された量よりも過剰な場合に スローされる例外です。
class | LengthRequiredException Content-Length 指定がないためにリクエストを正常に処理できないことを 通知するための例外です。
class | UnripeQueryException クエリが Content-Lnegth ヘッダで指定された量に満たない場合に スローされる例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException の使用

ExtendedServletException を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception | このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter | このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception での ExtendedServletException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception での ExtendedServletException のサブクラス
class | BadRequestException 不正なリクエストを受け付けたことを通知するための例外です。
class | EmptyQueryException クエリがない場合にスローされる例外です。
class | ExcessiveQueryException クエリが Content-Length ヘッダで指定された量よりも過剰な場合に スローされる例外です。
class | ForbiddenException アクセス権限がないことを通知する例外です。
class | LengthRequiredException Content-Length 指定がないためにリクエストを正常に処理できないことを 通知するための例外です。
class | NotFoundException 指定されたコンテンツが見つからないことを通知するための例外です。
class | RequestEntityTooLargeException 処理可能量より大きいリクエストを受け付けたことを通知するための例外です。
class | ServiceUnavailableException サーバの都合により一時的にリクエストを処理できないことを 通知するための例外です。
class | UnauthorizedException リクエストを受け付けるためには認証が必要であることを通知するための例外です。
class | UnripeQueryException クエリが Content-Lnegth ヘッダで指定された量に満たない場合に スローされる例外です。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での ExtendedServletException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での ExtendedServletException のサブクラス
class | HttpServletResponseEventControllerException コントローラに関わる処理中にエラーが発生した事を通知する例外です。
class | HttpServletResponseEventException イベントに関わる処理中にエラーが発生した事を通知する例外です。
class | HttpServletResponseEventFilterException レスポンスイベントを定義するフィルタでエラーが発生した事を通知する例外です。
class | HttpServletResponseEventListenerException レスポンスリスナに関わる処理中にエラーが発生した事を通知する例外です。
class | HttpServletResponseEventValidatorException バリデータに関わる処理中にエラーが発生した事を通知する例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException の使用

UnripeQueryException を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception での UnripeQueryException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception での UnripeQueryException のサブクラス
 class EmptyQueryException
クエリがない場合にスローされる例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BadRequestException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス BadRequestException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ExcessiveQueryException, LengthRequiredException, UnripeQueryException
public class BadRequestException
extends ExtendedServletException

不正なリクエストを受け付けたことを通知するための例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
BadRequestException()
例外を作成します。
BadRequestException(String message)
指定のメッセージを持つ例外を作成します。
BadRequestException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BadRequestException

public BadRequestException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

BadRequestException

public BadRequestException(String message,
                           Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

BadRequestException

public BadRequestException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EmptyQueryException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス EmptyQueryException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException
                        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException
                            拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException
すべての実装インタフェース:
Serializable
public class EmptyQueryException
extends UnripeQueryException

クエリがない場合にスローされる例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
EmptyQueryException()
例外を作成します。
EmptyQueryException(String message)
指定のメッセージを持つ例外を作成します。
EmptyQueryException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EmptyQueryException

public EmptyQueryException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

EmptyQueryException

public EmptyQueryException(String message,
                           Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

EmptyQueryException

public EmptyQueryException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExcessiveQueryException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス ExcessiveQueryException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException
                        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException
すべての実装インタフェース:
Serializable
public class ExcessiveQueryException
extends BadRequestException

クエリが Content-Length ヘッダで指定された量よりも過剰な場合に スローされる例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
ExcessiveQueryException()
例外を作成します。
ExcessiveQueryException(String message)
指定のメッセージを持つ例外を作成します。
ExcessiveQueryException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExcessiveQueryException

public ExcessiveQueryException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

ExcessiveQueryException

public ExcessiveQueryException(String message,
                               Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

ExcessiveQueryException

public ExcessiveQueryException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedServletException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス ExtendedServletException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
BadRequestException, ForbiddenException, HttpServletResponseEventException, NotFoundException, RequestEntityTooLargeException, ServiceUnavailableException, UnauthorizedException
public class ExtendedServletException
extends ServletException

Servlet 例外の拡張モデルです。 JRE 1.4 から、Throwable に #getCause() が実装されました。 これと、ServletException が従来から持つ #getRootCause() が 同義となるようにしてあります。

導入されたバージョン:
version 5.0
関連項目:
ServletException, 直列化された形式

コンストラクタの概要
ExtendedServletException()
例外オブジェクトを作成します。
ExtendedServletException(String message)
指定されたメッセージを持つ例外を作成します。
ExtendedServletException(String message, Throwable rootCause)
指定されたメッセージと根本原因となった例外を持つ例外を作成します。
ExtendedServletException(Throwable rootCause)
根本原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtendedServletException

public ExtendedServletException()
例外オブジェクトを作成します。

ExtendedServletException

public ExtendedServletException(String message)
指定されたメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

ExtendedServletException

public ExtendedServletException(String message,
                                Throwable rootCause)
指定されたメッセージと根本原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

ExtendedServletException

public ExtendedServletException(Throwable rootCause)
根本原因となった例外を持つ例外を作成します。

パラメータ:
rootCause - 原因となった例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ForbiddenException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス ForbiddenException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException
すべての実装インタフェース:
Serializable
public class ForbiddenException
extends ExtendedServletException

アクセス権限がないことを通知する例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
ForbiddenException()
例外を作成します。
ForbiddenException(String message)
指定のメッセージを持つ例外を作成します。
ForbiddenException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ForbiddenException

public ForbiddenException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

ForbiddenException

public ForbiddenException(String message,
                          Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

ForbiddenException

public ForbiddenException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LengthRequiredException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス LengthRequiredException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException
                        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException
すべての実装インタフェース:
Serializable
public class LengthRequiredException
extends BadRequestException

Content-Length 指定がないためにリクエストを正常に処理できないことを 通知するための例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
LengthRequiredException()
例外を作成します。
LengthRequiredException(String message)
指定のメッセージを持つ例外を作成します。
LengthRequiredException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

LengthRequiredException

public LengthRequiredException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

LengthRequiredException

public LengthRequiredException(String message,
                               Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

LengthRequiredException

public LengthRequiredException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NotFoundException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス NotFoundException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException
すべての実装インタフェース:
Serializable
public class NotFoundException
extends ExtendedServletException

指定されたコンテンツが見つからないことを通知するための例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
NotFoundException()
例外を作成します。
NotFoundException(String message)
指定のメッセージを持つ例外を作成します。
NotFoundException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NotFoundException

public NotFoundException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

NotFoundException

public NotFoundException(String message,
                         Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

NotFoundException

public NotFoundException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
例外
BadRequestException
EmptyQueryException
ExcessiveQueryException
ExtendedServletException
ForbiddenException
LengthRequiredException
NotFoundException
RequestEntityTooLargeException
ServiceUnavailableException
UnauthorizedException
UnripeQueryException


jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception

このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。

参照:
説明

例外の概要
BadRequestException | 不正なリクエストを受け付けたことを通知するための例外です。
EmptyQueryException | クエリがない場合にスローされる例外です。
ExcessiveQueryException | クエリが Content-Length ヘッダで指定された量よりも過剰な場合に スローされる例外です。
ExtendedServletException | Servlet 例外の拡張モデルです。
ForbiddenException | アクセス権限がないことを通知する例外です。
LengthRequiredException | Content-Length 指定がないためにリクエストを正常に処理できないことを 通知するための例外です。
NotFoundException | 指定されたコンテンツが見つからないことを通知するための例外です。
RequestEntityTooLargeException | 処理可能量より大きいリクエストを受け付けたことを通知するための例外です。
ServiceUnavailableException | サーバの都合により一時的にリクエストを処理できないことを 通知するための例外です。
UnauthorizedException | リクエストを受け付けるためには認証が必要であることを通知するための例外です。
UnripeQueryException | クエリが Content-Lnegth ヘッダで指定された量に満たない場合に スローされる例外です。

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception の説明

このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。


jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.servlet.ServletException
          • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException
                • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException


パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception | このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter | このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception のクラス
BadRequestException
不正なリクエストを受け付けたことを通知するための例外です。
ExtendedServletException
Servlet 例外の拡張モデルです。
UnripeQueryException
クエリが Content-Lnegth ヘッダで指定された量に満たない場合に スローされる例外です。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception のクラス
ExtendedServletException
Servlet 例外の拡張モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


RequestEntityTooLargeException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス RequestEntityTooLargeException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException
すべての実装インタフェース:
Serializable
public class RequestEntityTooLargeException
extends ExtendedServletException

処理可能量より大きいリクエストを受け付けたことを通知するための例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
RequestEntityTooLargeException()
例外を作成します。
RequestEntityTooLargeException(String message)
指定のメッセージを持つ例外を作成します。
RequestEntityTooLargeException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

RequestEntityTooLargeException

public RequestEntityTooLargeException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

RequestEntityTooLargeException

public RequestEntityTooLargeException(String message,
                                      Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

RequestEntityTooLargeException

public RequestEntityTooLargeException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServiceUnavailableException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス ServiceUnavailableException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException
すべての実装インタフェース:
Serializable
public class ServiceUnavailableException
extends ExtendedServletException

サーバの都合により一時的にリクエストを処理できないことを 通知するための例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
ServiceUnavailableException()
例外を作成します。
ServiceUnavailableException(String message)
指定のメッセージを持つ例外を作成します。
ServiceUnavailableException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ServiceUnavailableException

public ServiceUnavailableException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

ServiceUnavailableException

public ServiceUnavailableException(String message,
                                   Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

ServiceUnavailableException

public ServiceUnavailableException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UnauthorizedException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス UnauthorizedException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException
すべての実装インタフェース:
Serializable
public class UnauthorizedException
extends ExtendedServletException

リクエストを受け付けるためには認証が必要であることを通知するための例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
UnauthorizedException()
例外を作成します。
UnauthorizedException(String message)
指定のメッセージを持つ例外を作成します。
UnauthorizedException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UnauthorizedException

public UnauthorizedException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

UnauthorizedException

public UnauthorizedException(String message,
                             Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

UnauthorizedException

public UnauthorizedException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UnripeQueryException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス UnripeQueryException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException
                        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
EmptyQueryException
public class UnripeQueryException
extends BadRequestException

クエリが Content-Lnegth ヘッダで指定された量に満たない場合に スローされる例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
UnripeQueryException()
例外を作成します。
UnripeQueryException(String message)
指定のメッセージを持つ例外を作成します。
UnripeQueryException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UnripeQueryException

public UnripeQueryException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

UnripeQueryException

public UnripeQueryException(String message,
                            Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

UnripeQueryException

public UnripeQueryException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter の使用

AbstractFilter を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter | このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session | このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.security.filter | アクセスセキュリティのフィルタに関連するクラスを提供します。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での AbstractFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での AbstractFilter のサブクラス
class | AbsoluteLinkFilter 絶対表現のＵＲＬをレスポンスするためのフィルタ。
class | ExceptionHandlingFilter サーブレットの実行例外をキャッチして、 指定のエラーページへフォワードするフィルタです。
class | HTTPContextHandlingFilter このフィルタを利用することにより、 HTTPContextManager経由で HTTPContextを取得できるようになります。
class | HttpServletResponseEventFilter サーブレットレスポンスの各メソッド呼び出しに対するリスナを設定するフィルタ。
class | LuxuryResponseWriterFilter
class | NoCacheFilter ブラウザのキャッシュを無効にするフィルタ。
class | RequestMessageBodyFilter リクエストをラップするフィルタです。
class | ResponseContentTypeManagementFilter レスポンスの Content-Type を自動解決するフィルタです。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session での AbstractFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session での AbstractFilter のサブクラス
 class HttpSessionMonitoringFilter
HttpSessionManagerFactory#instance() が返す、 HttpSessionManagerFactory および HttpSessionManager の 標準実装と連動するフィルタです。

jp.co.intra_mart.foundation.security.filter での AbstractFilter の使用

jp.co.intra_mart.foundation.security.filter での AbstractFilter のサブクラス
class | ActiveSessionFilter アクティブセッションフィルタ。
class | DuplicateLoginHandlingFilter 重複ログインハンドリングフィルタ。
class | InitialPageSessionHandlingFilter ログインしている状態にログイン画面を表示しようとした際に警告ページを表示するためのフィルタ。
class | RequestCharacterEncodingFilter リクエストに対するエンコードは SessionInfo.getEncoding()が 返す値をになります。
class | ResponseCharacterEncodingFilter レスポンスの文字エンコーディングを自動解決するフィルタです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventConfig の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventConfig の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventConfig はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener の使用

AbstractHttpServletResponseEventListener を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での AbstractHttpServletResponseEventListener の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での AbstractHttpServletResponseEventListener のサブクラス
 class SimpleHttpServletResponseEventListener
レスポンスの各メソッド呼び出しに対するイベントをフックするためのコンポーネント実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper の使用

HttpServletRequestMessageBodyWrapper を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での HttpServletRequestMessageBodyWrapper の使用

HttpServletRequestMessageBodyWrapper を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
static HttpServletRequestMessageBodyWrapper | RequestMessageBodyFilter.getCurrentRequest() 現在処理中のリクエストを返します。
HttpServletRequestMessageBodyWrapper | HttpServletRequestMessageBodyWrapperBuilder.buildExtendedHttpServletRequest(HttpServletRequest request, HttpServletResponse response) ExtendedHttpServletRequest を作成して返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventComponentBuilder の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventComponentBuilder の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventComponentBuilder はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventConfig の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventConfig の使用

HttpServletResponseEventConfig を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での HttpServletResponseEventConfig の使用

HttpServletResponseEventConfig を実装している jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のクラス
 class AbstractHttpServletResponseEventConfig
レスポンスの各メソッド呼び出しに対するイベントを 設定するためのオブジェクトの抽象実装です。

HttpServletResponseEventConfig を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
protected  HttpServletResponseEventConfig AbstractHttpServletResponseEventListener.getHttpServletResponseEventConfig()
このリスナに渡された設定オブジェクトを返します。

HttpServletResponseEventConfig 型のパラメータを持つ jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
void | HttpServletResponseEventValidator.init(HttpServletResponseEventConfig config) この Validator を初期化します。
void | HttpServletResponseEventListener.init(HttpServletResponseEventConfig config) このビルダを初期化します。
void | HttpServletResponseEventController.init(HttpServletResponseEventConfig config) このビルダを初期化します。
void | AbstractHttpServletResponseEventListener.init(HttpServletResponseEventConfig config) このビルダを初期化します。
void | AbstractHttpServletResponseEventController.init(HttpServletResponseEventConfig config) このビルダを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController の使用

HttpServletResponseEventController を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での HttpServletResponseEventController の使用

HttpServletResponseEventController を実装している jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のクラス
 class AbstractHttpServletResponseEventController
イベントを制御するレスポンスの抽象実装です。

HttpServletResponseEventController を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
HttpServletResponseEventController | StandardHttpServletResponseEventControllerBuilder.createController(HttpServletRequest request, ExtendedHttpServletResponse response, HttpServletResponseEventListener listener) コントローラを返します。
HttpServletResponseEventController | HttpServletResponseEventControllerBuilder.createController(HttpServletRequest request, ExtendedHttpServletResponse response, HttpServletResponseEventListener listener) コントローラを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerBuilder の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerBuilder の使用

HttpServletResponseEventControllerBuilder を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での HttpServletResponseEventControllerBuilder の使用

HttpServletResponseEventControllerBuilder を実装している jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のクラス
 class StandardHttpServletResponseEventControllerBuilder
標準的なコントローラを構築するビルダです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerException の使用

HttpServletResponseEventControllerException を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での HttpServletResponseEventControllerException の使用

HttpServletResponseEventControllerException をスローする jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
void | StandardHttpServletResponseEventControllerBuilder.init(String initParameterValue, ServletContext servletContext) ビルダを初期化します。
HttpServletResponseEventController | StandardHttpServletResponseEventControllerBuilder.createController(HttpServletRequest request, ExtendedHttpServletResponse response, HttpServletResponseEventListener listener) コントローラを返します。
void | HttpServletResponseEventControllerBuilder.init(String initParameterValue, ServletContext servletContext) ビルダを初期化します。
HttpServletResponseEventController | HttpServletResponseEventControllerBuilder.createController(HttpServletRequest request, ExtendedHttpServletResponse response, HttpServletResponseEventListener listener) コントローラを返します。
void | HttpServletResponseEventController.init(HttpServletResponseEventConfig config) このビルダを初期化します。
protected void | AbstractHttpServletResponseEventController.handleInit() このリスナを初期化します。
void | AbstractHttpServletResponseEventController.init(HttpServletResponseEventConfig config) このビルダを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException の使用

HttpServletResponseEventException を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での HttpServletResponseEventException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での HttpServletResponseEventException のサブクラス
class | HttpServletResponseEventControllerException コントローラに関わる処理中にエラーが発生した事を通知する例外です。
class | HttpServletResponseEventFilterException レスポンスイベントを定義するフィルタでエラーが発生した事を通知する例外です。
class | HttpServletResponseEventListenerException レスポンスリスナに関わる処理中にエラーが発生した事を通知する例外です。
class | HttpServletResponseEventValidatorException バリデータに関わる処理中にエラーが発生した事を通知する例外です。

HttpServletResponseEventException をスローする jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
 void HttpServletResponseEventComponentBuilder.init(String initParameterValue, ServletContext servletContext)
ビルダを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilterException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilterException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilterException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener の使用

HttpServletResponseEventListener を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での HttpServletResponseEventListener の使用

HttpServletResponseEventListener を実装している jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のクラス
class | AbstractHttpServletResponseEventListener レスポンスの各メソッド呼び出しに対するイベントをフックするための抽象実装です。
class | SimpleHttpServletResponseEventListener レスポンスの各メソッド呼び出しに対するイベントをフックするためのコンポーネント実装です。

HttpServletResponseEventListener を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
HttpServletResponseEventListener[] | HttpServletResponseEventComponentBuilder.getListeners() リスナの配列を返します。
protected abstract HttpServletResponseEventListener | AbstractHttpServletResponseEventController.getHttpServletResponseEventListener() リスナを返します。

HttpServletResponseEventListener 型のパラメータを持つ jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
HttpServletResponseEventController | StandardHttpServletResponseEventControllerBuilder.createController(HttpServletRequest request, ExtendedHttpServletResponse response, HttpServletResponseEventListener listener) コントローラを返します。
HttpServletResponseEventController | HttpServletResponseEventControllerBuilder.createController(HttpServletRequest request, ExtendedHttpServletResponse response, HttpServletResponseEventListener listener) コントローラを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListenerException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListenerException の使用

HttpServletResponseEventListenerException を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での HttpServletResponseEventListenerException の使用

HttpServletResponseEventListenerException をスローする jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
void | HttpServletResponseEventListener.init(HttpServletResponseEventConfig config) このビルダを初期化します。
HttpServletResponseEventListener[] | HttpServletResponseEventComponentBuilder.getListeners() リスナの配列を返します。
void | AbstractHttpServletResponseEventListener.init(HttpServletResponseEventConfig config) このビルダを初期化します。
protected void | AbstractHttpServletResponseEventListener.handleInit() このリスナを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidator の使用

HttpServletResponseEventValidator を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での HttpServletResponseEventValidator の使用

HttpServletResponseEventValidator を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
 HttpServletResponseEventValidator[] HttpServletResponseEventComponentBuilder.getValidators()
バリデータの配列を返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidatorException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidatorException の使用

HttpServletResponseEventValidatorException を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での HttpServletResponseEventValidatorException の使用

HttpServletResponseEventValidatorException をスローする jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
void | HttpServletResponseEventValidator.init(HttpServletResponseEventConfig config) この Validator を初期化します。
boolean | HttpServletResponseEventValidator.isValid(HttpServletRequest request, ExtendedHttpServletResponse response) イベントリスナを動作させるかどうかの意思決定をします。
HttpServletResponseEventValidator[] | HttpServletResponseEventComponentBuilder.getValidators() バリデータの配列を返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter の使用

RequestParameter を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での RequestParameter の使用

RequestParameter を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
static RequestParameter[] | RequestMessageBodyFilter.getRequestParameters() 現在のリクエストのパラメータを返します。
RequestParameter[] | HttpServletRequestMessageBodyWrapper.getRequestParameters() パラメータ情報を返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.StandardHttpServletResponseEventControllerBuilder の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.StandardHttpServletResponseEventControllerBuilder の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.StandardHttpServletResponseEventControllerBuilder はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AbsoluteLinkFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス AbsoluteLinkFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter
すべての実装インタフェース:
Filter
public class AbsoluteLinkFilter
extends AbstractFilter

絶対表現のＵＲＬをレスポンスするためのフィルタ。

このフィルタの目的は、ServletResponse#encodeURL() の実行結果として、 単にセッションＩＤ情報を付加するだけではなく、必ず絶対形式のＵＲＬを 作成することです。 したがって、このフィルタは、チェーンの次サーブレットまたはフィルタに対して、 ラップしたレスポンスを渡します。

このフィルタがレスポンスをラップするのは、事前に指定されたセッションに 関連したリクエストのみです。 #entry(ServletRequest) または entry(HttpSession) で 登録していないセッションに関するリクエストについては、 レスポンスをラップすることなくチェーンの次のサーブレットまたはフィルタを 実行します。

コンストラクタの概要
AbsoluteLinkFilter()
フィルタを新しく作成します。
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタ処理します。
static void | entry(HttpServletRequest request) このフィルタによってＵＲＬの制御を行うことを定義します。
static void | entry(HttpSession session) このフィルタによってＵＲＬの制御を行うことを定義します。
static void | leave(HttpServletRequest request) 指定のセッションに関する、このフィルタの処理を停止します。
static void | leave(HttpSession session) 指定のセッションに関する、このフィルタの処理を停止します。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, handleInit, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbsoluteLinkFilter

public AbsoluteLinkFilter()
フィルタを新しく作成します。

メソッドの詳細

entry

public static void entry(HttpServletRequest request)
このフィルタによってＵＲＬの制御を行うことを定義します。

この処理は、このリクエスト中のみでなく、 同じセッションのすべてのリクエストに対して有効となります。

パラメータ:
request - リクエスト
例外:
NullPointerException - 引数が null の場合
IllegalStateException - セッションを取得できなかった場合

entry

public static void entry(HttpSession session)
このフィルタによってＵＲＬの制御を行うことを定義します。

この処理は、このリクエスト中のみでなく、 同じセッションのすべてのリクエストに対して有効となります。

パラメータ:
session - セッション
例外:
NullPointerException - 引数が null の場合

leave

public static void leave(HttpServletRequest request)
指定のセッションに関する、このフィルタの処理を停止します。 この処理は、このリクエスト中のみでなく、 同じセッションのすべてのリクエストに対して有効となります。

既にセッションが有効でない場合、このメソッドは何も行いません。

パラメータ:
request - リクエスト
例外:
NullPointerException - 引数が null の場合

leave

public static void leave(HttpSession session)
指定のセッションに関する、このフィルタの処理を停止します。 この処理は、このリクエスト中のみでなく、 同じセッションのすべてのリクエストに対して有効となります。

パラメータ:
session - セッション
例外:
NullPointerException - 引数が null の場合

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタ処理します。

現在のリクエストに関連付けられているセッションが、 このクラスの entry(HttpSession) で定義済みのセッションの場合、 レスポンスをラップします。 ラップされたレスポンスは、javax.servlet.http.HttpServletResponse#encodeURL(java.lang.String) の 返り値として、必ず絶対形式のＵＲＬを返すようになります。

レスポンスをラップするかどうかに関わらず、 このメソッドは、フィルタチェーン内の次のチェーンを呼び出します。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - フィルタチェーンの次のビュー
例外:
IOException - 入出力エラー
ServletException - 実行時エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AbstractFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス AbstractFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
すべての実装インタフェース:
Filter
直系の既知のサブクラス:
AbsoluteLinkFilter, ActiveSessionFilter, DuplicateLoginHandlingFilter, ExceptionHandlingFilter, HTTPContextHandlingFilter, HttpServletResponseEventFilter, HttpSessionMonitoringFilter, InitialPageSessionHandlingFilter, LuxuryResponseWriterFilter, NoCacheFilter, RequestCharacterEncodingFilter, RequestMessageBodyFilter, ResponseCharacterEncodingFilter, ResponseContentTypeManagementFilter
public abstract class AbstractFilter
extends Object
implements Filter

フィルタを実装するための抽象クラスです。

導入されたバージョン:
version 5.0

コンストラクタの概要
protected AbstractFilter()
フィルタオブジェクトを作成します。
メソッドの概要
void | destroy() フィルタの終了処理。
abstract void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタとして動作するロジック。
FilterConfig | getFilterConfig() このフィルタの設定オブジェクトを返します。
ServletContext | getServletContext() この Filter を実行している ServletContext への参照を返します。
protected void | handleDestroy() フィルタの破棄処理。
protected void | handleInit() フィルタの初期化をします。
void | init(FilterConfig config) フィルタを初期化します。
protected void | log(String msg) Servlet ログファイルに指定されたメッセージを出力します。
protected void | log(String msg, Throwable throwable) 与えられた Throwable 例外の説明となるメッセージとスタックトレースを Servlet のログファイルに出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractFilter

protected AbstractFilter()
フィルタオブジェクトを作成します。

メソッドの詳細

init

public final void init(FilterConfig config)
                throws ServletException
フィルタを初期化します。

このメソッドは、この抽象クラスの初期化を実行後に、 handleInit() を実行します。 サブクラスが独自の初期化処理を必要とする場合は、 handleInit() をオーバーライドして初期化処理を実装してください。

定義:
インタフェース Filter 内の init
パラメータ:
config - フィルタ設定オブジェクト
例外:
ServletException - 初期化エラー
関連項目:
Filter.init(FilterConfig)

handleInit

protected void handleInit()
                   throws ServletException
フィルタの初期化をします。

このメソッドは、フィルタ初期化時に init(FilterConfig) に 呼び出されます。
このメソッドは何もしません。ただリターンするだけです。

サブクラスが初期化処理を必要とする場合は、 このメソッドをオーバーライドして初期化処理を実装してください。

例外:
ServletException - 初期化エラー
関連項目:
init(FilterConfig)

getFilterConfig

public FilterConfig getFilterConfig()
このフィルタの設定オブジェクトを返します。

このメソッドは、コンストラクタでは利用できません。

戻り値:
フィルタ設定オブジェクト。コンストラクタで呼び出した場合は null を返します。

getServletContext

public ServletContext getServletContext()
この Filter を実行している ServletContext への参照を返します。

このメソッドは、コンストラクタでは利用できません。

戻り値:
このフィルタが Servlet コンテナとの対話に使っている ServletContext オブジェクト
例外:
NullPointerException - コンストラクタで呼び出した場合

log

protected void log(String msg)
Servlet ログファイルに指定されたメッセージを出力します。
通常は event ログです。 Servlet ログファイルの名前やタイプは Servlet コンテナによって違います。

このメソッドの呼び出しは、下記と同等です。
this.getFilterConfig().getServletContext().log(msg);

このメソッドは、コンストラクタでは利用できません。

パラメータ:
msg - ログファイルに出力するメッセージ
例外:
NullPointerException - コンストラクタで呼び出した場合
関連項目:
ServletContext.log(String)

log

protected void log(String msg,
                   Throwable throwable)
与えられた Throwable 例外の説明となるメッセージとスタックトレースを Servlet のログファイルに出力します。
Servlet ログファイルは通常は event ログですが、 名前やタイプは Servlet コンテナによって違います。

このメソッドの呼び出しは、下記と同等です。
this.getFilterConfig().getServletContext().log(msg, throwable);

このメソッドは、コンストラクタでは利用できません。

パラメータ:
msg - ログファイルに出力するメッセージ
throwable - エラーや例外
例外:
NullPointerException - コンストラクタで呼び出した場合
関連項目:
ServletContext.log(String, Throwable)

doFilter

public abstract void doFilter(ServletRequest request,
                              ServletResponse response,
                              FilterChain chain)
                       throws ServletException,
                              IOException
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
ServletException - 実行時エラー
IOException - 入出力エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)

destroy

public final void destroy()
フィルタの終了処理。

このメソッドは、handleDestroy() を呼び出します。
handleDestroy() から正常に制御が返ってきた場合も、
また handleDestroy() が例外をスローした場合も、
このメソッドが終了する直前に、この抽象クラスの破棄処理が行われます。

サブクラスが独自の初期化処理を必要とする場合は、 handleDestroy() をオーバーライドして 初期化処理を実装してください。

定義:
インタフェース Filter 内の destroy
関連項目:
Filter.destroy()

handleDestroy

protected void handleDestroy()
フィルタの破棄処理。

このメソッドは、フィルタ破棄時に destroy() に 呼び出されます。
このメソッドは何もしません。ただリターンするだけです。

サブクラスが破棄処理を必要とする場合は、 このメソッドをオーバーライドして破棄処理を実装してください。

関連項目:
destroy()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AbstractHttpServletResponseEventConfig (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス AbstractHttpServletResponseEventConfig

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventConfig
すべての実装インタフェース:
HttpServletResponseEventConfig
public abstract class AbstractHttpServletResponseEventConfig
extends Object
implements HttpServletResponseEventConfig

レスポンスの各メソッド呼び出しに対するイベントを 設定するためのオブジェクトの抽象実装です。 リスナやコントローラの初期化の際に情報を渡すために使われます。

導入されたバージョン:
Version 6.0

コンストラクタの概要
AbstractHttpServletResponseEventConfig(ServletContext servletContext)
新しい設定オブジェクトを作成します。
メソッドの概要
abstract String | getInitParameter(String name) 指定した名前の初期化パラメータの値である String、 あるいはパラメータが存在しなければ null を返します。
abstract Enumeration | getInitParameterNames() 初期化パラメータの名前である String オブジェクトの Enumeration を返します。
ServletContext | getServletContext() 呼び出したコントローラを実行している ServletContext への参照を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractHttpServletResponseEventConfig

public AbstractHttpServletResponseEventConfig(ServletContext servletContext)
新しい設定オブジェクトを作成します。

パラメータ:
servletContext - サーブレットコンテキスト
メソッドの詳細

getInitParameter

public abstract String getInitParameter(String name)
指定した名前の初期化パラメータの値である String、 あるいはパラメータが存在しなければ null を返します。

定義:
インタフェース HttpServletResponseEventConfig 内の getInitParameter
パラメータ:
name - 初期化パラメータの名前を指定する String
戻り値:
初期化パラメータの値である Strin

getInitParameterNames

public abstract Enumeration getInitParameterNames()
初期化パラメータの名前である String オブジェクトの Enumeration を返します。 または、初期化パラメータが無ければ空の Enumeration を返します。

定義:
インタフェース HttpServletResponseEventConfig 内の getInitParameterNames
戻り値:
初期化パラメータの名前である String オブジェクトの Enumeration

getServletContext

public ServletContext getServletContext()
呼び出したコントローラを実行している ServletContext への参照を返します。

定義:
インタフェース HttpServletResponseEventConfig 内の getServletContext
戻り値:
呼び出したコントローラが Servlet コンテナとの対話に使っている ServletContext オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AbstractHttpServletResponseEventController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス AbstractHttpServletResponseEventController

java.lang.Object
    拡張 javax.servlet.ServletResponseWrapper
        拡張 javax.servlet.http.HttpServletResponseWrapper
            拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController
すべての実装インタフェース:
ExtendedHttpServletResponse, ExtendedServletResponse, HttpServletResponse, HttpServletResponseEventController, ServletResponse
public abstract class AbstractHttpServletResponseEventController
extends ExtendedHttpServletResponseWrapper
implements HttpServletResponseEventController

イベントを制御するレスポンスの抽象実装です。

HttpServletResponse が持つ 各メソッド（非推奨を除く）をオーバーライドして、 リスナに処理を委任するロジックを追加します。

導入されたバージョン:
Version 6.0

フィールドの概要
インタフェース javax.servlet.http.HttpServletResponse から継承したフィールド
SC_ACCEPTED, SC_BAD_GATEWAY, SC_BAD_REQUEST, SC_CONFLICT, SC_CONTINUE, SC_CREATED, SC_EXPECTATION_FAILED, SC_FORBIDDEN, SC_GATEWAY_TIMEOUT, SC_GONE, SC_HTTP_VERSION_NOT_SUPPORTED, SC_INTERNAL_SERVER_ERROR, SC_LENGTH_REQUIRED, SC_METHOD_NOT_ALLOWED, SC_MOVED_PERMANENTLY, SC_MOVED_TEMPORARILY, SC_MULTIPLE_CHOICES, SC_NO_CONTENT, SC_NON_AUTHORITATIVE_INFORMATION, SC_NOT_ACCEPTABLE, SC_NOT_FOUND, SC_NOT_IMPLEMENTED, SC_NOT_MODIFIED, SC_OK, SC_PARTIAL_CONTENT, SC_PAYMENT_REQUIRED, SC_PRECONDITION_FAILED, SC_PROXY_AUTHENTICATION_REQUIRED, SC_REQUEST_ENTITY_TOO_LARGE, SC_REQUEST_TIMEOUT, SC_REQUEST_URI_TOO_LONG, SC_REQUESTED_RANGE_NOT_SATISFIABLE, SC_RESET_CONTENT, SC_SEE_OTHER, SC_SERVICE_UNAVAILABLE, SC_SWITCHING_PROTOCOLS, SC_TEMPORARY_REDIRECT, SC_UNAUTHORIZED, SC_UNSUPPORTED_MEDIA_TYPE, SC_USE_PROXY
コンストラクタの概要
AbstractHttpServletResponseEventController(ExtendedHttpServletResponse response)
新しいインスタンスを生成します。
メソッドの概要
void | addCookie(Cookie cookie) 指定されたCookieをレスポンスに追加します。
void | addDateHeader(String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。
void | addHeader(String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを追加します。
void | addIntHeader(String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを追加します。
boolean | containsHeader(String name) 指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。
String | encodeRedirectURL(String url) sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。
String | encodeURL(String url) 指定されたURLがセッションIDを含むようにエンコードします。
void | flushBuffer() バッファリングされているコンテンツを強制的にクライアントに出力します。
int | getBufferSize() このレスポンスに設定されている実バッファサイズを返します。
String | getCharacterEncoding() このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。
protected abstract HttpServletRequest | getHttpServletRequest() リクエストを返します。
protected abstract HttpServletResponseEventListener | getHttpServletResponseEventListener() リスナを返します。
Locale | getLocale(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスに設定されているロケールを返します。
ServletOutputStream | getOutputStream() レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。
PrintWriter | getWriter() 文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。
protected void | handleInit() このリスナを初期化します。
void | init(HttpServletResponseEventConfig config) このビルダを初期化します。
boolean | isCommitted() レスポンスがすでにコミットされたかどうかを示す boolean を返します。
void | reset() バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。
void | resetBuffer() レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。
void | sendError(int sc) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
void | sendError(int sc, String msg) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
void | sendRedirect(String location) 指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。
void | setBufferSize(int size) 適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。
void | setContentLength(int len) レスポンスのメッセージボディ部分の長さをセットします。
void | setContentType(String type) クライアントに送り返されるレスポンスのコンテントタイプをセットします。
void | setDateHeader(String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。
void | setHeader(String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを設定します。
void | setIntHeader(String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを設定します。
void | setLocale(Locale loc) レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。
void | setStatus(int sc) このレスポンスのステータスコードを設定します。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper から継承したメソッド
getContentLength, getContentType, getCookies, getDateHeader, getDateHeaders, getExtendedHttpServletResponse, getHeader, getHeaders, getIntHeader, getIntHeaders, getStatus, getStringHeader, getStringHeaders, setContentType
クラス javax.servlet.http.HttpServletResponseWrapper から継承したメソッド
encodeRedirectUrl, encodeUrl, setStatus
クラス javax.servlet.ServletResponseWrapper から継承したメソッド
getLocale, getResponse, setResponse
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse から継承したメソッド
getCookies, getDateHeader, getDateHeaders, getHeader, getHeaders, getIntHeader, getIntHeaders, getStatus, getStringHeader, getStringHeaders
インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse から継承したメソッド
getContentLength, getContentType, setContentType
インタフェース javax.servlet.ServletResponse から継承したメソッド
getLocale
インタフェース javax.servlet.http.HttpServletResponse から継承したメソッド
encodeRedirectUrl, encodeUrl, setStatus

コンストラクタの詳細

AbstractHttpServletResponseEventController

public AbstractHttpServletResponseEventController(ExtendedHttpServletResponse response)
新しいインスタンスを生成します。

メソッドの詳細

handleInit

protected void handleInit()
                   throws HttpServletResponseEventControllerException
このリスナを初期化します。

このメソッドは、#init(HttpServletResponseEventListenerConfig) によって呼び出されます。 このメソッドは単にリターンするだけで、何もしません。
サブクラスが初期化処理を必要とする場合、 このメソッドをオーバーライドしてください。

例外:
HttpServletResponseEventControllerException - 初期化に失敗した場合

getHttpServletRequest

protected abstract HttpServletRequest getHttpServletRequest()
リクエストを返します。

戻り値:
現在のリクエスト

getHttpServletResponseEventListener

protected abstract HttpServletResponseEventListener getHttpServletResponseEventListener()
リスナを返します。

戻り値:
リスナ

init

public final void init(HttpServletResponseEventConfig config)
                throws HttpServletResponseEventControllerException
このビルダを初期化します。

定義:
インタフェース HttpServletResponseEventController 内の init
パラメータ:
config - 初期化パラメータ
例外:
HttpServletResponseEventControllerException - 初期化に失敗した場合

addCookie

public void addCookie(Cookie cookie)
指定されたCookieをレスポンスに追加します。

定義:
インタフェース HttpServletResponse 内の addCookie
パラメータ:
cookie - クライアントに返すCookie

containsHeader

public boolean containsHeader(String name)
指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。

定義:
インタフェース HttpServletResponse 内の containsHeader
パラメータ:
name - ヘッダ名
戻り値:
指定された名前のレスポンスヘッダが既にセットされていれば true、そうでなければfalse

encodeURL

public String encodeURL(String url)
指定されたURLがセッションIDを含むようにエンコードします。

定義:
インタフェース HttpServletResponse 内の encodeURL
パラメータ:
url - エンコードするURL
戻り値:
エンコードが必要である場合、エンコードされたURL。 そうでない場合は与えられたそのままのURL

encodeRedirectURL

public String encodeRedirectURL(String url)
sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。

定義:
インタフェース HttpServletResponse 内の encodeRedirectURL
パラメータ:
url - エンコードするURL
戻り値:
エンコードが必要である場合、エンコードされたURL。 そうでない場合は与えられたそのままのURL

sendError

public void sendError(int sc,
                      String msg)
               throws IOException
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。

定義:
インタフェース HttpServletResponse 内の sendError
パラメータ:
sc - エラーステータスコード
msg - 説明文
例外:
IOException - 入出力例外が発生した場合
IllegalStateException - レスポンスが既にコミットされている場合

sendError

public void sendError(int sc)
               throws IOException
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。

定義:
インタフェース HttpServletResponse 内の sendError
パラメータ:
sc - エラーステータスコード
例外:
IOException - 入出力例外が発生した場合
IllegalStateException - レスポンスが既にコミットされている場合

sendRedirect

public void sendRedirect(String location)
                  throws IOException
指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。

定義:
インタフェース HttpServletResponse 内の sendRedirect
パラメータ:
location - リダイレクト先のURL
例外:
IOException - 入出力例外が発生した場合
IllegalStateException - レスポンスが既にコミットされている場合

setDateHeader

public void setDateHeader(String name,
                          long date)
指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。

定義:
インタフェース HttpServletResponse 内の setDateHeader
パラメータ:
name - 設定するヘッダの名称
date - 設定するヘッダの値

addDateHeader

public void addDateHeader(String name,
                          long date)
指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。

定義:
インタフェース HttpServletResponse 内の addDateHeader
パラメータ:
name - 追加するヘッダの名称
date - 追加するヘッダの値

setHeader

public void setHeader(String name,
                      String value)
指定された名称で指定された値を持つレスポンスヘッダを設定します。

定義:
インタフェース HttpServletResponse 内の setHeader
パラメータ:
name - ヘッダの名称
value - ヘッダの値

addHeader

public void addHeader(String name,
                      String value)
指定された名称で指定された値を持つレスポンスヘッダを追加します。

定義:
インタフェース HttpServletResponse 内の addHeader
パラメータ:
name - ヘッダの名称
value - 追加するヘッダの値

setIntHeader

public void setIntHeader(String name,
                         int value)
指定された名称で指定された整数値を持つレスポンスヘッダを設定します。

定義:
インタフェース HttpServletResponse 内の setIntHeader
パラメータ:
name - ヘッダの名称
value - 割り当てられる整数値

addIntHeader

public void addIntHeader(String name,
                         int value)
指定された名称で指定された整数値を持つレスポンスヘッダを追加します。

定義:
インタフェース HttpServletResponse 内の addIntHeader
パラメータ:
name - ヘッダの名称
value - 割り当てられる整数値

setStatus

public void setStatus(int sc)
このレスポンスのステータスコードを設定します。

定義:
インタフェース HttpServletResponse 内の setStatus
パラメータ:
sc - ステータスコード

getCharacterEncoding

public String getCharacterEncoding()
このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。

定義:
インタフェース ServletResponse 内の getCharacterEncoding
戻り値:
文字エンコーディング名を意味する String。

getOutputStream

public ServletOutputStream getOutputStream()
                                    throws IOException
レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。

定義:
インタフェース ServletResponse 内の getOutputStream
戻り値:
バイナリデータ出力に使用する ServletOutputStream
例外:
IllegalStateException - このレスポンスですでに getWriter() メソッドが実行されていた場合
IOException - 入出力時に例外が発生した場合

getWriter

public PrintWriter getWriter()
                      throws IOException
文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。

定義:
インタフェース ServletResponse 内の getWriter
戻り値:
クライアントに文字データを送り返すことができる PrintWriter オブジェクト
例外:
UnsupportedEncodingException - setContentType メソッドで指定された文字エンコーディングがサポートされていない場合
IllegalStateException - このレスポンスですでに getOutputStream() メソッドが実行されていた場合
IOException - 入出力時に例外が発生した場合

setContentLength

public void setContentLength(int len)
レスポンスのメッセージボディ部分の長さをセットします。

定義:
インタフェース ServletResponse 内の setContentLength
パラメータ:
len - クライアントに送り返すメッセージボディの長さを指定する整数値。

setContentType

public void setContentType(String type)
クライアントに送り返されるレスポンスのコンテントタイプをセットします。

定義:
インタフェース ServletResponse 内の setContentType
パラメータ:
type - コンテントタイプを指定する String

setBufferSize

public void setBufferSize(int size)
適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。

定義:
インタフェース ServletResponse 内の setBufferSize
パラメータ:
size - 適当なバッファサイズを指定する整数値
例外:
IllegalStateException - すでにコンテンツが出力された後でこのメソッドが実行された場合

getBufferSize

public int getBufferSize()
このレスポンスに設定されている実バッファサイズを返します。

定義:
インタフェース ServletResponse 内の getBufferSize
戻り値:
実際に使われているバッファサイズ

flushBuffer

public void flushBuffer()
                 throws IOException
バッファリングされているコンテンツを強制的にクライアントに出力します。

定義:
インタフェース ServletResponse 内の flushBuffer
例外:
IOException - 入出力時に例外が発生した場合

resetBuffer

public void resetBuffer()
レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。

定義:
インタフェース ServletResponse 内の resetBuffer

isCommitted

public boolean isCommitted()
レスポンスがすでにコミットされたかどうかを示す boolean を返します。

定義:
インタフェース ServletResponse 内の isCommitted
戻り値:
レスポンスがすでにコミットされたかどうかを示す boolean

reset

public void reset()
バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。

定義:
インタフェース ServletResponse 内の reset

setLocale

public void setLocale(Locale loc)
レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。

定義:
インタフェース ServletResponse 内の setLocale
パラメータ:
loc - レスポンスのロケールを指定する Locale オブジェクト

getLocale

public Locale getLocale(HttpServletRequest request,
                        ExtendedHttpServletResponse response)
レスポンスに設定されているロケールを返します。

戻り値:
レスポンスに設定されているロケール
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AbstractHttpServletResponseEventListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス AbstractHttpServletResponseEventListener

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener
すべての実装インタフェース:
HttpServletResponseEventListener
直系の既知のサブクラス:
SimpleHttpServletResponseEventListener
public abstract class AbstractHttpServletResponseEventListener
extends Object
implements HttpServletResponseEventListener

レスポンスの各メソッド呼び出しに対するイベントをフックするための抽象実装です。

このクラスは、フックしたレスポンスの適当なメソッドを実行するだけの単純実装です。 アプリケーションは、このクラスを継承して、 任意のメソッドのみをオーバーライドする事により 必要なイベントフックのみを実装する事ができます。

導入されたバージョン:
Version 6.0

コンストラクタの概要
protected AbstractHttpServletResponseEventListener()
新しいリスナを作成します。
メソッドの概要
abstract void | addCookie(HttpServletRequest request, ExtendedHttpServletResponse response, Cookie cookie) 指定されたCookieをレスポンスに追加します。
abstract void | addDateHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。
abstract void | addHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを追加します。
abstract void | addIntHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを追加します。
abstract boolean | containsHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name) 指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。
abstract String | encodeRedirectURL(HttpServletRequest request, ExtendedHttpServletResponse response, String url) #sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。
abstract String | encodeURL(HttpServletRequest request, ExtendedHttpServletResponse response, String url) 指定されたURLがセッションIDを含むようにエンコードします。
abstract void | flushBuffer(HttpServletRequest request, ExtendedHttpServletResponse response) バッファリングされているコンテンツを強制的にクライアントに出力します。
abstract int | getBufferSize(HttpServletRequest request, ExtendedHttpServletResponse response) このレスポンスに設定されている実バッファサイズを返します。
abstract String | getCharacterEncoding(HttpServletRequest request, ExtendedHttpServletResponse response) このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。
protected HttpServletResponseEventConfig | getHttpServletResponseEventConfig() このリスナに渡された設定オブジェクトを返します。
abstract Locale | getLocale(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスに設定されているロケールを返します。
abstract ServletOutputStream | getOutputStream(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。
protected ServletContext | getServletContext() このリスナが実行されているサーブレットコンテキストを返します。
abstract PrintWriter | getWriter(HttpServletRequest request, ExtendedHttpServletResponse response) 文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。
protected void | handleInit() このリスナを初期化します。
void | init(HttpServletResponseEventConfig config) このビルダを初期化します。
abstract boolean | isCommitted(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスがすでにコミットされたかどうかを示す boolean を返します。
abstract void | reset(HttpServletRequest request, ExtendedHttpServletResponse response) バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。
abstract void | resetBuffer(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。
abstract void | sendError(HttpServletRequest request, ExtendedHttpServletResponse response, int sc) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
abstract void | sendError(HttpServletRequest request, ExtendedHttpServletResponse response, int sc, String msg) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
abstract void | sendRedirect(HttpServletRequest request, ExtendedHttpServletResponse response, String location) 指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。
abstract void | setBufferSize(HttpServletRequest request, ExtendedHttpServletResponse response, int size) 適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。
abstract void | setContentLength(HttpServletRequest request, ExtendedHttpServletResponse response, int len) レスポンスのメッセージボディ部分の長さをセットします。
abstract void | setContentType(HttpServletRequest request, ExtendedHttpServletResponse response, String type) クライアントに送り返されるレスポンスのコンテントタイプをセットします。
abstract void | setDateHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。
abstract void | setHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを設定します。
abstract void | setIntHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを設定します。
abstract void | setLocale(HttpServletRequest request, ExtendedHttpServletResponse response, Locale loc) レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。
abstract void | setStatus(HttpServletRequest request, ExtendedHttpServletResponse response, int sc) このレスポンスのステータスコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractHttpServletResponseEventListener

protected AbstractHttpServletResponseEventListener()
新しいリスナを作成します。

メソッドの詳細

init

public final void init(HttpServletResponseEventConfig config)
                throws HttpServletResponseEventListenerException
このビルダを初期化します。

定義:
インタフェース HttpServletResponseEventListener 内の init
パラメータ:
config - 初期化パラメータ
例外:
ServletException - 初期化に失敗した場合
HttpServletResponseEventListenerException - 初期化に失敗した場合

handleInit

protected void handleInit()
                   throws HttpServletResponseEventListenerException
このリスナを初期化します。

このメソッドは、#init(HttpServletResponseEventListenerConfig) によって呼び出されます。 このメソッドは単にリターンするだけで、何もしません。
サブクラスが初期化処理を必要とする場合、 このメソッドをオーバーライドしてください。

例外:
ServletException - 初期化に失敗した場合
HttpServletResponseEventListenerException

getHttpServletResponseEventConfig

protected HttpServletResponseEventConfig getHttpServletResponseEventConfig()
このリスナに渡された設定オブジェクトを返します。

戻り値:
設定オブジェクト

getServletContext

protected ServletContext getServletContext()
このリスナが実行されているサーブレットコンテキストを返します。

戻り値:
サーブレットコンテキスト

getCharacterEncoding

public abstract String getCharacterEncoding(HttpServletRequest request,
                                            ExtendedHttpServletResponse response)
このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。

このメソッドは、単純に以下を実行します。
return response.getCharacterEncoding();

定義:
インタフェース HttpServletResponseEventListener 内の getCharacterEncoding
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
文字エンコーディング名を意味する String。
関連項目:
ServletResponse.getCharacterEncoding()

getOutputStream

public abstract ServletOutputStream getOutputStream(HttpServletRequest request,
                                                    ExtendedHttpServletResponse response)
                                             throws IOException
レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。

このメソッドは、単純に以下を実行します。
return response.getOutputStream();

定義:
インタフェース HttpServletResponseEventListener 内の getOutputStream
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
バイナリデータ出力に使用する ServletOutputStream
例外:
IllegalStateException - このレスポンスですでに #getWriter() メソッドが実行されていた場合
IOException - 入出力時に例外が発生した場合
関連項目:
#getWriter(HTTPContext, ExtendedHttpServletResponse),
ServletResponse.getWriter(),
ServletResponse.getOutputStream()

getWriter

public abstract PrintWriter getWriter(HttpServletRequest request,
                                      ExtendedHttpServletResponse response)
                               throws IOException
文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。

このメソッドは、単純に以下を実行します。
return response.getWriter();

定義:
インタフェース HttpServletResponseEventListener 内の getWriter
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
クライアントに文字データを送り返すことができる PrintWriter オブジェクト
例外:
UnsupportedEncodingException - setContentType メソッドで指定された文字エンコーディングがサポートされていない場合
IllegalStateException - このレスポンスですでに #getOutputStream() メソッドが実行されていた場合
IOException - 入出力時に例外が発生した場合
関連項目:
#getOutputStream(HTTPContext, ExtendedHttpServletResponse),
ServletResponse.getOutputStream(),
ServletResponse.getWriter()

setContentLength

public abstract void setContentLength(HttpServletRequest request,
                                      ExtendedHttpServletResponse response,
                                      int len)
レスポンスのメッセージボディ部分の長さをセットします。

このメソッドは、単純に以下を実行します。
response.setContentLength(len);

定義:
インタフェース HttpServletResponseEventListener 内の setContentLength
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
len - クライアントに送り返すメッセージボディの長さを指定する整数値。
関連項目:
ServletResponse.setContentLength(int)

setContentType

public abstract void setContentType(HttpServletRequest request,
                                    ExtendedHttpServletResponse response,
                                    String type)
クライアントに送り返されるレスポンスのコンテントタイプをセットします。

このメソッドは、単純に以下を実行します。
response.setContentType(type);

定義:
インタフェース HttpServletResponseEventListener 内の setContentType
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
type - コンテントタイプを指定する String
関連項目:
ServletResponse.setContentType(String),
#getOutputStream(HTTPContext, ExtendedHttpServletResponse),
#getWriter(HTTPContext, ExtendedHttpServletResponse)

setBufferSize

public abstract void setBufferSize(HttpServletRequest request,
                                   ExtendedHttpServletResponse response,
                                   int size)
適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。

このメソッドは、単純に以下を実行します。
response.setBufferSize(size);

定義:
インタフェース HttpServletResponseEventListener 内の setBufferSize
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
size - 適当なバッファサイズを指定する整数値
例外:
IllegalStateException - すでにコンテンツが出力された後でこのメソッドが実行された場合
関連項目:
ServletResponse.setBufferSize(int),
#getBufferSize(HTTPContext, ExtendedHttpServletResponse),
#flushBuffer(HTTPContext, ExtendedHttpServletResponse),
#isCommitted(HTTPContext, ExtendedHttpServletResponse),
#reset(HTTPContext, ExtendedHttpServletResponse)

getBufferSize

public abstract int getBufferSize(HttpServletRequest request,
                                  ExtendedHttpServletResponse response)
このレスポンスに設定されている実バッファサイズを返します。

このメソッドは、単純に以下を実行します。
return response.getBufferSize();

定義:
インタフェース HttpServletResponseEventListener 内の getBufferSize
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
実際に使われているバッファサイズ
関連項目:
ServletResponse.getBufferSize(),
#setBufferSize(HTTPContext, ExtendedHttpServletResponse, int),
#flushBuffer(HTTPContext, ExtendedHttpServletResponse),
#isCommitted(HTTPContext, ExtendedHttpServletResponse),
#reset(HTTPContext, ExtendedHttpServletResponse)

flushBuffer

public abstract void flushBuffer(HttpServletRequest request,
                                 ExtendedHttpServletResponse response)
                          throws IOException
バッファリングされているコンテンツを強制的にクライアントに出力します。

このメソッドは、単純に以下を実行します。
response.flushBuffer();

定義:
インタフェース HttpServletResponseEventListener 内の flushBuffer
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
例外:
IOException - 入出力時に例外が発生した場合
関連項目:
ServletResponse.flushBuffer(),
#setBufferSize(HTTPContext, ExtendedHttpServletResponse, int),
#getBufferSize(HTTPContext, ExtendedHttpServletResponse),
#isCommitted(HTTPContext, ExtendedHttpServletResponse),
#reset(HTTPContext, ExtendedHttpServletResponse)

resetBuffer

public abstract void resetBuffer(HttpServletRequest request,
                                 ExtendedHttpServletResponse response)
レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。

このメソッドは、単純に以下を実行します。
response.resetBuffer();

定義:
インタフェース HttpServletResponseEventListener 内の resetBuffer
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
関連項目:
ServletResponse.resetBuffer(),
#setBufferSize(HTTPContext, ExtendedHttpServletResponse, int),
#getBufferSize(HTTPContext, ExtendedHttpServletResponse),
#isCommitted(HTTPContext, ExtendedHttpServletResponse),
#reset(HTTPContext, ExtendedHttpServletResponse)

isCommitted

public abstract boolean isCommitted(HttpServletRequest request,
                                    ExtendedHttpServletResponse response)
レスポンスがすでにコミットされたかどうかを示す boolean を返します。

このメソッドは、単純に以下を実行します。
return response.isCommitted();

定義:
インタフェース HttpServletResponseEventListener 内の isCommitted
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
レスポンスがすでにコミットされたかどうかを示す boolean
関連項目:
ServletResponse.isCommitted(),
#setBufferSize(HTTPContext, ExtendedHttpServletResponse, int),
#getBufferSize(HTTPContext, ExtendedHttpServletResponse),
#flushBuffer(HTTPContext, ExtendedHttpServletResponse),
#reset(HTTPContext, ExtendedHttpServletResponse)

reset

public abstract void reset(HttpServletRequest request,
                           ExtendedHttpServletResponse response)
バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。

このメソッドは、単純に以下を実行します。
response.reset();

定義:
インタフェース HttpServletResponseEventListener 内の reset
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
関連項目:
ServletResponse.reset(),
#setBufferSize(HTTPContext, ExtendedHttpServletResponse, int),
#getBufferSize(HTTPContext, ExtendedHttpServletResponse),
#flushBuffer(HTTPContext, ExtendedHttpServletResponse),
#isCommitted(HTTPContext, ExtendedHttpServletResponse)

setLocale

public abstract void setLocale(HttpServletRequest request,
                               ExtendedHttpServletResponse response,
                               Locale loc)
レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。

このメソッドは、単純に以下を実行します。
response.setLocale(loc);

定義:
インタフェース HttpServletResponseEventListener 内の setLocale
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
loc - レスポンスのロケールを指定する Locale オブジェクト
関連項目:
ServletResponse.setLocale(Locale), #getLocale(HTTPContext, ExtendedHttpServletResponse)

getLocale

public abstract Locale getLocale(HttpServletRequest request,
                                 ExtendedHttpServletResponse response)
レスポンスに設定されているロケールを返します。

このメソッドは、単純に以下を実行します。
return response.getLocale();

定義:
インタフェース HttpServletResponseEventListener 内の getLocale
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
レスポンスに設定されているロケール
関連項目:
ServletResponse.getLocale(), #setLocale(HTTPContext, ExtendedHttpServletResponse, java.util.Locale)

addCookie

public abstract void addCookie(HttpServletRequest request,
                               ExtendedHttpServletResponse response,
                               Cookie cookie)
指定されたCookieをレスポンスに追加します。

このメソッドは、単純に以下を実行します。
response.addCookie(cookie);

定義:
インタフェース HttpServletResponseEventListener 内の addCookie
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
cookie - クライアントに返すCookie
関連項目:
HttpServletResponse.addCookie(Cookie)

containsHeader

public abstract boolean containsHeader(HttpServletRequest request,
                                       ExtendedHttpServletResponse response,
                                       String name)
指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。

このメソッドは、単純に以下を実行します。
return response.containsHeader(name);

定義:
インタフェース HttpServletResponseEventListener 内の containsHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダ名
戻り値:
指定された名前のレスポンスヘッダが既にセットされていれば true、そうでなければfalse
関連項目:
HttpServletResponse.containsHeader(String)

encodeURL

public abstract String encodeURL(HttpServletRequest request,
                                 ExtendedHttpServletResponse response,
                                 String url)
指定されたURLがセッションIDを含むようにエンコードします。

このメソッドは、単純に以下を実行します。
return response.encodeURL(url);

定義:
インタフェース HttpServletResponseEventListener 内の encodeURL
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
url - エンコードするURL
戻り値:
エンコードが必要である場合、エンコードされたURL。 そうでない場合は与えられたそのままのURL
関連項目:
HttpServletResponse.encodeURL(String)

encodeRedirectURL

public abstract String encodeRedirectURL(HttpServletRequest request,
                                         ExtendedHttpServletResponse response,
                                         String url)
#sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。

このメソッドは、単純に以下を実行します。
return response.encodeRedirectURL(url);

定義:
インタフェース HttpServletResponseEventListener 内の encodeRedirectURL
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
url - エンコードするURL
戻り値:
エンコードが必要である場合、エンコードされたURL。 そうでない場合は与えられたそのままのURL
関連項目:
HttpServletResponse.encodeRedirectURL(String),
#sendRedirect(HTTPContext, ExtendedHttpServletResponse, String),
#encodeURL(HTTPContext, ExtendedHttpServletResponse, String)

sendError

public abstract void sendError(HttpServletRequest request,
                               ExtendedHttpServletResponse response,
                               int sc,
                               String msg)
                        throws IOException
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。

このメソッドは、単純に以下を実行します。
response.sendError(sc, msg);

定義:
インタフェース HttpServletResponseEventListener 内の sendError
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
sc - エラーステータスコード
msg - 説明文
例外:
IOException - 入出力例外が発生した場合
IllegalStateException - レスポンスが既にコミットされている場合
関連項目:
HttpServletResponse.sendError(int, String)

sendError

public abstract void sendError(HttpServletRequest request,
                               ExtendedHttpServletResponse response,
                               int sc)
                        throws IOException
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。

このメソッドは、単純に以下を実行します。
response.sendError(sc);

定義:
インタフェース HttpServletResponseEventListener 内の sendError
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
sc - エラーステータスコード
例外:
IOException - 入出力例外が発生した場合
IllegalStateException - レスポンスが既にコミットされている場合
関連項目:
HttpServletResponse.sendError(int)

sendRedirect

public abstract void sendRedirect(HttpServletRequest request,
                                  ExtendedHttpServletResponse response,
                                  String location)
                           throws IOException
指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。

このメソッドは、単純に以下を実行します。
response.sendRedirect(location);

定義:
インタフェース HttpServletResponseEventListener 内の sendRedirect
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
location - リダイレクト先のURL
例外:
IOException - 入出力例外が発生した場合
IllegalStateException - レスポンスが既にコミットされている場合
関連項目:
HttpServletResponse.sendRedirect(String)

setDateHeader

public abstract void setDateHeader(HttpServletRequest request,
                                   ExtendedHttpServletResponse response,
                                   String name,
                                   long date)
指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。

このメソッドは、単純に以下を実行します。
response.setDateHeader(name, date);

定義:
インタフェース HttpServletResponseEventListener 内の setDateHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - 設定するヘッダの名称
date - 設定するヘッダの値
関連項目:
HttpServletResponse.setDateHeader(String, long),
#containsHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String),
#addDateHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String, long)

addDateHeader

public abstract void addDateHeader(HttpServletRequest request,
                                   ExtendedHttpServletResponse response,
                                   String name,
                                   long date)
指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。

このメソッドは、単純に以下を実行します。
response.addDateHeader(name, date);

定義:
インタフェース HttpServletResponseEventListener 内の addDateHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - 追加するヘッダの名称
date - 追加するヘッダの値
関連項目:
HttpServletResponse.addDateHeader(String, long), #setDateHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String, long)

setHeader

public abstract void setHeader(HttpServletRequest request,
                               ExtendedHttpServletResponse response,
                               String name,
                               String value)
指定された名称で指定された値を持つレスポンスヘッダを設定します。

このメソッドは、単純に以下を実行します。
response.setHeader(name, value);

定義:
インタフェース HttpServletResponseEventListener 内の setHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダの名称
value - ヘッダの値
関連項目:
HttpServletResponse.setHeader(String, String),
#containsHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String),
#addHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String, java.lang.String)

addHeader

public abstract void addHeader(HttpServletRequest request,
                               ExtendedHttpServletResponse response,
                               String name,
                               String value)
指定された名称で指定された値を持つレスポンスヘッダを追加します。

このメソッドは、単純に以下を実行します。
response.addHeader(name, value);

定義:
インタフェース HttpServletResponseEventListener 内の addHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダの名称
value - 追加するヘッダの値
関連項目:
HttpServletResponse.addHeader(String, String), #setHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String, java.lang.String)

setIntHeader

public abstract void setIntHeader(HttpServletRequest request,
                                  ExtendedHttpServletResponse response,
                                  String name,
                                  int value)
指定された名称で指定された整数値を持つレスポンスヘッダを設定します。

このメソッドは、単純に以下を実行します。
response.setIntHeader(name, value);

定義:
インタフェース HttpServletResponseEventListener 内の setIntHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダの名称
value - 割り当てられる整数値
関連項目:
HttpServletResponse.setIntHeader(String, int),
#containsHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String),
#addIntHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String, int)

addIntHeader

public abstract void addIntHeader(HttpServletRequest request,
                                  ExtendedHttpServletResponse response,
                                  String name,
                                  int value)
指定された名称で指定された整数値を持つレスポンスヘッダを追加します。

このメソッドは、単純に以下を実行します。
response.addIntHeader(name, value);

定義:
インタフェース HttpServletResponseEventListener 内の addIntHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダの名称
value - 割り当てられる整数値
関連項目:
HttpServletResponse.addIntHeader(String, int), #setIntHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String, int)

setStatus

public abstract void setStatus(HttpServletRequest request,
                               ExtendedHttpServletResponse response,
                               int sc)
このレスポンスのステータスコードを設定します。

このメソッドは、単純に以下を実行します。
response.setStatus(sc);

定義:
インタフェース HttpServletResponseEventListener 内の setStatus
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
sc - ステータスコード
関連項目:
HttpServletResponse.setStatus(int), #sendError(HTTPContext, ExtendedHttpServletResponse, int, java.lang.String)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExceptionHandlingFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス ExceptionHandlingFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter
すべての実装インタフェース:
Filter
public class ExceptionHandlingFilter
extends AbstractFilter

サーブレットの実行例外をキャッチして、 指定のエラーページへフォワードするフィルタです。

このフィルタを利用すると、例外の種類によって表示するエラーページを 切り替える事ができます。また、フォワード先ＵＲＬを JSP や Servlet にすると、 エラーログを出力するなどの例外処理をすることもできます。

フィルタの設定値は、以下のとおりです。

id.attribute.exception | フォワード先へ、発生した例外を通知するためのキー名です。 この指定値をキー名として、発生した例外を ServletRequest に #setAttribute() してから、エラーページへフォワードします。
id.attribute.url | フォワード先へ、リクエストＵＲＬを通知するためのキー名です。 この指定値をキー名として、 現在の ServletRequest が #getRequestURL() の結果として返す値を ServletRequest に #setAttribute() してから、エラーページへフォワードします。
id.attribute.uri | フォワード先へ、リクエストＵＲＩを通知するためのキー名です。 この指定値をキー名として、 現在の ServletRequest が #getRequestURI() の結果として返す値を ServletRequest に #setAttribute() してから、エラーページへフォワードします。
id.attribute.servlet | フォワード先へ、サーブレットパスを通知するためのキー名です。 この指定値をキー名として、 現在の ServletRequest が #getServletPath() の結果として返す値を ServletRequest に #setAttribute() してから、エラーページへフォワードします。
path.mapping マッピングに関して定義した定義ファイルです。 定義ファイルはＸＭＬ形式で、以下のフォーマットになります。

   <error-page>
     <mapping>
      <exception-type logging="true|false (デフォルト: true)" >
         例外のクラス名
       </exception-type>
      <location>
         例外発生時にフォワードするパス
       </location>
      <location request-header="リクエストヘッダ名(小文字指定)">
         例外発生時にフォワードするパス
         （属性「request-header」と同名のリクエストヘッダーが付与されている場合）
       </location>
     </mapping>
   </error-page>
<mapping> は任意の個数だけ定義できます。

フィルタは、指定されたパスをクラスパスから検索します。 定義ファイルは、必ずクラスパスに設定されているディレクトリに 保存してください。

exception.cause.enable 例外がスローされた直接原因となった例外 （Throwable.getCause() が返す値） もチェック対象とするかどうかの設定です。

文字列 'true' を設定した場合、ネストされた例外もチェックします。 ただし、パフォーマンスが悪化する可能性があります。
文字列 'false' を設定した場合、スローされた例外のみをチェック対象とします。 パフォーマンス面では有利ですが、パターンによっては 適切なエラーページを表示できない恐れがあります。

コンストラクタの概要
ExceptionHandlingFilter()
新しくフィルタオブジェクトを作成します。
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタとして動作するロジック。
protected void | handleInit() フィルタの初期化をします。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExceptionHandlingFilter

public ExceptionHandlingFilter()
新しくフィルタオブジェクトを作成します。

メソッドの詳細

handleInit

protected void handleInit()
                   throws ServletException
フィルタの初期化をします。

オーバーライド:
クラス AbstractFilter 内の handleInit
例外:
ServletException - 初期化エラー
関連項目:
AbstractFilter.init(FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
IOException - 入出力エラー
ServletException - 実行時エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPContextHandlingFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス HTTPContextHandlingFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter
すべての実装インタフェース:
Filter
public class HTTPContextHandlingFilter
extends AbstractFilter

このフィルタを利用することにより、 HTTPContextManager経由で HTTPContextを取得できるようになります。

導入されたバージョン:
version 5.0

コンストラクタの概要
HTTPContextHandlingFilter()
デフォルト・コンストラクタ
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタとして動作するロジック。
protected void | handleDestroy() フィルタの破棄処理。
protected void | handleInit() フィルタの初期化をします。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPContextHandlingFilter

public HTTPContextHandlingFilter()
デフォルト・コンストラクタ

メソッドの詳細

handleInit

protected void handleInit()
                   throws ServletException
クラス AbstractFilter の記述:
フィルタの初期化をします。

このメソッドは、フィルタ初期化時に AbstractFilter.init(FilterConfig) に 呼び出されます。
このメソッドは何もしません。ただリターンするだけです。

サブクラスが初期化処理を必要とする場合は、 このメソッドをオーバーライドして初期化処理を実装してください。

オーバーライド:
クラス AbstractFilter 内の handleInit
例外:
ServletException - 初期化エラー
関連項目:
AbstractFilter.init(FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws IOException,
                     ServletException
クラス AbstractFilter の記述:
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
IOException - 入出力エラー
ServletException - 実行時エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)

handleDestroy

protected void handleDestroy()
クラス AbstractFilter の記述:
フィルタの破棄処理。

このメソッドは、フィルタ破棄時に AbstractFilter.destroy() に 呼び出されます。
このメソッドは何もしません。ただリターンするだけです。

サブクラスが破棄処理を必要とする場合は、 このメソッドをオーバーライドして破棄処理を実装してください。

オーバーライド:
クラス AbstractFilter 内の handleDestroy
関連項目:
AbstractFilter.destroy()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpServletRequestMessageBodyWrapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
インタフェース HttpServletRequestMessageBodyWrapper

すべてのスーパーインタフェース:
HttpServletRequest, ServletRequest
public interface HttpServletRequestMessageBodyWrapper
extends HttpServletRequest

HttpServletRequest を拡張したインタフェースです。

導入されたバージョン:
version 5.0

フィールドの概要
インタフェース javax.servlet.http.HttpServletRequest から継承したフィールド
BASIC_AUTH, CLIENT_CERT_AUTH, DIGEST_AUTH, FORM_AUTH
メソッドの概要
InputStream | getMessageBody() リクエストのメッセージボディを返します。
RequestParameter[] | getRequestParameters() パラメータ情報を返します。
インタフェース javax.servlet.http.HttpServletRequest から継承したメソッド
getAuthType, getContextPath, getCookies, getDateHeader, getHeader, getHeaderNames, getHeaders, getIntHeader, getMethod, getPathInfo, getPathTranslated, getQueryString, getRemoteUser, getRequestedSessionId, getRequestURI, getRequestURL, getServletPath, getSession, getSession, getUserPrincipal, isRequestedSessionIdFromCookie, isRequestedSessionIdFromUrl, isRequestedSessionIdFromURL, isRequestedSessionIdValid, isUserInRole
インタフェース javax.servlet.ServletRequest から継承したメソッド
getAttribute, getAttributeNames, getCharacterEncoding, getContentLength, getContentType, getInputStream, getLocale, getLocales, getParameter, getParameterMap, getParameterNames, getParameterValues, getProtocol, getReader, getRealPath, getRemoteAddr, getRemoteHost, getRequestDispatcher, getScheme, getServerName, getServerPort, isSecure, removeAttribute, setAttribute, setCharacterEncoding

メソッドの詳細

getMessageBody

public InputStream getMessageBody()
                           throws IOException
リクエストのメッセージボディを返します。

このメソッドは、ServletRequest.getInputStream() または ServletRequest.getReader() を 実行した後でも、メッセージボディを含む入力ストリームを返します。
また同様に、 ServletRequest.getParameter(String name) を実行した後でも、メッセージボディを含む入力ストリームを返します。

戻り値:
メッセージボディを含む入力ストリーム
例外:
IOException - 入出力の例外が発生した場合

getRequestParameters

public RequestParameter[] getRequestParameters()
                                        throws IOException
パラメータ情報を返します。

戻り値:
パラメータ
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HttpServletRequestMessageBodyWrapperBuilder (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
インタフェース HttpServletRequestMessageBodyWrapperBuilder

public interface HttpServletRequestMessageBodyWrapperBuilder

HttpServletRequest を拡張したインタフェースです。

導入されたバージョン:
version 5.0

メソッドの概要
HttpServletRequestMessageBodyWrapper | buildExtendedHttpServletRequest(HttpServletRequest request, HttpServletResponse response) ExtendedHttpServletRequest を作成して返します。
void | destroy() このオブジェクトの破棄処理をします。
void | init(FilterConfig config) このオブジェクトを初期化します。

メソッドの詳細

init

public void init(FilterConfig config)
このオブジェクトを初期化します。

buildExtendedHttpServletRequest

public HttpServletRequestMessageBodyWrapper buildExtendedHttpServletRequest(HttpServletRequest request,
                                                                            HttpServletResponse response)
                                                                     throws IOException,
                                                                            ServletException
ExtendedHttpServletRequest を作成して返します。

パラメータ:
request - リクエスト
response - レスポンス
例外:
IOException - 入出力エラー
ServletException - その他の実行時エラー

destroy

public void destroy()
このオブジェクトの破棄処理をします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpServletResponseEventComponentBuilder (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
インタフェース HttpServletResponseEventComponentBuilder

public interface HttpServletResponseEventComponentBuilder

レスポンスイベントに関わる各種コンポーネント（リスナやバリデータ）をを構築するビルダです。

導入されたバージョン:
Version 6.0

メソッドの概要
HttpServletResponseEventListener[] | getListeners() リスナの配列を返します。
HttpServletResponseEventValidator[] | getValidators() バリデータの配列を返します。
void | init(String initParameterValue, ServletContext servletContext) ビルダを初期化します。

メソッドの詳細

init

public void init(String initParameterValue,
                 ServletContext servletContext)
          throws HttpServletResponseEventException
ビルダを初期化します。

パラメータ:
initParameterValue - パラメータ
servletContext - サーブレットコンテキスト
例外:
HttpServletResponseEventException - エラーが発生した場合

getListeners

public HttpServletResponseEventListener[] getListeners()
                                                throws HttpServletResponseEventListenerException
リスナの配列を返します。

戻り値:
リスナの配列
例外:
HttpServletResponseEventListenerException - エラーが発生した場合

getValidators

public HttpServletResponseEventValidator[] getValidators()
                                                  throws HttpServletResponseEventValidatorException
バリデータの配列を返します。

戻り値:
バリデータの配列
例外:
HttpServletResponseEventValidatorException - エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpServletResponseEventConfig (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
インタフェース HttpServletResponseEventConfig

既知の実装クラスの一覧:
AbstractHttpServletResponseEventConfig
public interface HttpServletResponseEventConfig

レスポンスの各メソッド呼び出しに対するイベントを 設定するためのオブジェクトです。 リスナやコントローラの初期化の際に情報を渡すために使われます。

導入されたバージョン:
Version 6.0

メソッドの概要
String | getInitParameter(String name) 指定した名前の初期化パラメータの値である String、 あるいはパラメータが存在しなければ null を返します。
Enumeration | getInitParameterNames() 初期化パラメータの名前である String オブジェクトの Enumeration を返します。
ServletContext | getServletContext() 呼び出したコントローラを実行している ServletContext への参照を返します。

メソッドの詳細

getInitParameter

public String getInitParameter(String name)
指定した名前の初期化パラメータの値である String、 あるいはパラメータが存在しなければ null を返します。

パラメータ:
name - 初期化パラメータの名前を指定する String
戻り値:
初期化パラメータの値である Strin

getInitParameterNames

public Enumeration getInitParameterNames()
初期化パラメータの名前である String オブジェクトの Enumeration を返します。 または、初期化パラメータが無ければ空の Enumeration を返します。

戻り値:
初期化パラメータの名前である String オブジェクトの Enumeration

getServletContext

public ServletContext getServletContext()
呼び出したコントローラを実行している ServletContext への参照を返します。

戻り値:
呼び出したコントローラが Servlet コンテナとの対話に使っている ServletContext オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpServletResponseEventController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
インタフェース HttpServletResponseEventController

すべてのスーパーインタフェース:
ExtendedHttpServletResponse, ExtendedServletResponse, HttpServletResponse, ServletResponse
既知の実装クラスの一覧:
AbstractHttpServletResponseEventController
public interface HttpServletResponseEventController
extends ExtendedHttpServletResponse

レスポンスイベントコントローラのインタフェース。

バージョン:
6.0

フィールドの概要
インタフェース javax.servlet.http.HttpServletResponse から継承したフィールド
SC_ACCEPTED, SC_BAD_GATEWAY, SC_BAD_REQUEST, SC_CONFLICT, SC_CONTINUE, SC_CREATED, SC_EXPECTATION_FAILED, SC_FORBIDDEN, SC_GATEWAY_TIMEOUT, SC_GONE, SC_HTTP_VERSION_NOT_SUPPORTED, SC_INTERNAL_SERVER_ERROR, SC_LENGTH_REQUIRED, SC_METHOD_NOT_ALLOWED, SC_MOVED_PERMANENTLY, SC_MOVED_TEMPORARILY, SC_MULTIPLE_CHOICES, SC_NO_CONTENT, SC_NON_AUTHORITATIVE_INFORMATION, SC_NOT_ACCEPTABLE, SC_NOT_FOUND, SC_NOT_IMPLEMENTED, SC_NOT_MODIFIED, SC_OK, SC_PARTIAL_CONTENT, SC_PAYMENT_REQUIRED, SC_PRECONDITION_FAILED, SC_PROXY_AUTHENTICATION_REQUIRED, SC_REQUEST_ENTITY_TOO_LARGE, SC_REQUEST_TIMEOUT, SC_REQUEST_URI_TOO_LONG, SC_REQUESTED_RANGE_NOT_SATISFIABLE, SC_RESET_CONTENT, SC_SEE_OTHER, SC_SERVICE_UNAVAILABLE, SC_SWITCHING_PROTOCOLS, SC_TEMPORARY_REDIRECT, SC_UNAUTHORIZED, SC_UNSUPPORTED_MEDIA_TYPE, SC_USE_PROXY
メソッドの概要
 void init(HttpServletResponseEventConfig config)
このビルダを初期化します。
インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse から継承したメソッド
getCookies, getDateHeader, getDateHeaders, getHeader, getHeaders, getIntHeader, getIntHeaders, getStatus, getStringHeader, getStringHeaders
インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse から継承したメソッド
getContentLength, getContentType, setContentType
インタフェース javax.servlet.ServletResponse から継承したメソッド
flushBuffer, getBufferSize, getCharacterEncoding, getLocale, getOutputStream, getWriter, isCommitted, reset, resetBuffer, setBufferSize, setContentLength, setContentType, setLocale
インタフェース javax.servlet.http.HttpServletResponse から継承したメソッド
addCookie, addDateHeader, addHeader, addIntHeader, containsHeader, encodeRedirectUrl, encodeRedirectURL, encodeUrl, encodeURL, sendError, sendError, sendRedirect, setDateHeader, setHeader, setIntHeader, setStatus, setStatus

メソッドの詳細

init

public void init(HttpServletResponseEventConfig config)
          throws HttpServletResponseEventControllerException
このビルダを初期化します。

パラメータ:
config - 初期化パラメータ
例外:
HttpServletResponseEventControllerException - 初期化に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpServletResponseEventControllerBuilder (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
インタフェース HttpServletResponseEventControllerBuilder

既知の実装クラスの一覧:
StandardHttpServletResponseEventControllerBuilder
public interface HttpServletResponseEventControllerBuilder

コントローラを構築するビルダです。

導入されたバージョン:
Version 6.0

メソッドの概要
HttpServletResponseEventController | createController(HttpServletRequest request, ExtendedHttpServletResponse response, HttpServletResponseEventListener listener) コントローラを返します。
void | init(String initParameterValue, ServletContext servletContext) ビルダを初期化します。

メソッドの詳細

init

public void init(String initParameterValue,
                 ServletContext servletContext)
          throws HttpServletResponseEventControllerException
ビルダを初期化します。

パラメータ:
initParameterValue - パラメータ
servletContext - サーブレットコンテキスト
例外:
HttpServletResponseEventControllerException - エラーが発生した場合

createController

public HttpServletResponseEventController createController(HttpServletRequest request,
                                                           ExtendedHttpServletResponse response,
                                                           HttpServletResponseEventListener listener)
                                                    throws HttpServletResponseEventControllerException
コントローラを返します。

戻り値:
コントローラ
例外:
HttpServletResponseEventControllerException - エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpServletResponseEventControllerException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス HttpServletResponseEventControllerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException
                        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerException
すべての実装インタフェース:
Serializable
public class HttpServletResponseEventControllerException
extends HttpServletResponseEventException

コントローラに関わる処理中にエラーが発生した事を通知する例外です。

導入されたバージョン:
Version 6.0
関連項目:
直列化された形式

コンストラクタの概要
HttpServletResponseEventControllerException()
詳細メッセージを null にして、新規例外を構築します。
HttpServletResponseEventControllerException(String message)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventControllerException(String message, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventControllerException(Throwable cause)
指定された原因を使用して新規例外を構築します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HttpServletResponseEventControllerException

public HttpServletResponseEventControllerException()
詳細メッセージを null にして、新規例外を構築します。 このコンストラクタでは原因を初期化しません。

HttpServletResponseEventControllerException

public HttpServletResponseEventControllerException(String message)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。 このコンストラクタでは原因を初期化しません。

パラメータ:
message - 詳細メッセージ。詳細メッセージは Throwable.getMessage() メソッドによる取得用に保存される

HttpServletResponseEventControllerException

public HttpServletResponseEventControllerException(String message,
                                                   Throwable cause)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。

cause と関連付けられた詳細メッセージが、 この例外の詳細メッセージに自動的に統合されることはありません。

パラメータ:
message - 詳細メッセージ。詳細メッセージは Throwable.getMessage() メソッドによる取得用に保存される
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す

HttpServletResponseEventControllerException

public HttpServletResponseEventControllerException(Throwable cause)
指定された原因を使用して新規例外を構築します。

パラメータ:
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HttpServletResponseEventException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス HttpServletResponseEventException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
HttpServletResponseEventControllerException, HttpServletResponseEventFilterException, HttpServletResponseEventListenerException, HttpServletResponseEventValidatorException
public class HttpServletResponseEventException
extends ExtendedServletException

イベントに関わる処理中にエラーが発生した事を通知する例外です。

導入されたバージョン:
Version 6.0
関連項目:
直列化された形式

コンストラクタの概要
HttpServletResponseEventException()
詳細メッセージを null にして、新規例外を構築します。
HttpServletResponseEventException(String message)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventException(String message, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventException(Throwable cause)
指定された原因を使用して新規例外を構築します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HttpServletResponseEventException

public HttpServletResponseEventException()
詳細メッセージを null にして、新規例外を構築します。 このコンストラクタでは原因を初期化しません。

HttpServletResponseEventException

public HttpServletResponseEventException(String message)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。 このコンストラクタでは原因を初期化しません。

パラメータ:
message - 詳細メッセージ。詳細メッセージは Throwable.getMessage() メソッドによる取得用に保存される

HttpServletResponseEventException

public HttpServletResponseEventException(String message,
                                         Throwable cause)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。

cause と関連付けられた詳細メッセージが、 この例外の詳細メッセージに自動的に統合されることはありません。

パラメータ:
message - 詳細メッセージ。詳細メッセージは Throwable.getMessage() メソッドによる取得用に保存される
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す

HttpServletResponseEventException

public HttpServletResponseEventException(Throwable cause)
指定された原因を使用して新規例外を構築します。

パラメータ:
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpServletResponseEventFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス HttpServletResponseEventFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilter
すべての実装インタフェース:
Filter
public class HttpServletResponseEventFilter
extends AbstractFilter

サーブレットレスポンスの各メソッド呼び出しに対するリスナを設定するフィルタ。

このフィルタは、以下の設定値を持ちます。

component.builder.class | レスポンスリスナやバリデータのビルダ実装のクラス名（FQN）
component.builder.parameter | ビルダに対する初期化パラメータ
controller.builder.class | コントローラビルダ実装のクラス名（FQN）
controller.builder.parameter | コントローラビルダに対する初期化パラメータ

設定値 property.builder.class には、 HttpServletResponseEventComponentBuilder の実装クラス名を指定してください。 リスナクラスには、デフォルトコンストラクタが必要です。
property.builder.parameter に指定したパラメータ値は、 HttpServletResponseEventComponentBuilder.init(String, ServletContext) への引数に渡されます。

設定値 controller.builder.class には、 HttpServletResponseEventControllerBuilder の実装クラス名を指定してください。 リスナクラスには、デフォルトコンストラクタが必要です。
controller.builder.parameter に指定したパラメータ値は、 HttpServletResponseEventControllerBuilder.init(String, ServletContext) への引数に渡されます。

導入されたバージョン:
Version 6.0

コンストラクタの概要
HttpServletResponseEventFilter()
新しいフィルタを作成します。
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタとして動作するロジック。
protected void | handleInit() フィルタの初期化をします。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HttpServletResponseEventFilter

public HttpServletResponseEventFilter()
新しいフィルタを作成します。

メソッドの詳細

handleInit

protected void handleInit()
                   throws ServletException
フィルタの初期化をします。

オーバーライド:
クラス AbstractFilter 内の handleInit
例外:
ServletException - 初期化エラー
関連項目:
AbstractFilter.init(FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
ServletException - 実行時エラー
IOException - 入出力エラー
関連項目:
Filter.doFilter(javax.servlet.ServletRequest, javax.servlet.ServletResponse, javax.servlet.FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpServletResponseEventFilterException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス HttpServletResponseEventFilterException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException
                        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilterException
すべての実装インタフェース:
Serializable
public class HttpServletResponseEventFilterException
extends HttpServletResponseEventException

レスポンスイベントを定義するフィルタでエラーが発生した事を通知する例外です。

導入されたバージョン:
Version 6.0
関連項目:
直列化された形式

コンストラクタの概要
HttpServletResponseEventFilterException()
詳細メッセージを null にして、新規例外を構築します。
HttpServletResponseEventFilterException(String message)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventFilterException(String message, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventFilterException(Throwable cause)
指定された原因を使用して新規例外を構築します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HttpServletResponseEventFilterException

public HttpServletResponseEventFilterException()
詳細メッセージを null にして、新規例外を構築します。 このコンストラクタでは原因を初期化しません。

HttpServletResponseEventFilterException

public HttpServletResponseEventFilterException(String message)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。 このコンストラクタでは原因を初期化しません。

パラメータ:
message - 詳細メッセージ。詳細メッセージは Throwable.getMessage() メソッドによる取得用に保存される

HttpServletResponseEventFilterException

public HttpServletResponseEventFilterException(String message,
                                               Throwable cause)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。

cause と関連付けられた詳細メッセージが、 この例外の詳細メッセージに自動的に統合されることはありません。

パラメータ:
message - 詳細メッセージ。詳細メッセージは Throwable.getMessage() メソッドによる取得用に保存される
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す

HttpServletResponseEventFilterException

public HttpServletResponseEventFilterException(Throwable cause)
指定された原因を使用して新規例外を構築します。

パラメータ:
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpServletResponseEventListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
インタフェース HttpServletResponseEventListener

既知の実装クラスの一覧:
AbstractHttpServletResponseEventListener
public interface HttpServletResponseEventListener

レスポンスの各メソッド呼び出しに対するイベントをフックするためのインタフェースです。

導入されたバージョン:
Version 6.0

メソッドの概要
void | addCookie(HttpServletRequest request, ExtendedHttpServletResponse response, Cookie cookie) 指定されたCookieをレスポンスに追加します。
void | addDateHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。
void | addHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを追加します。
void | addIntHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを追加します。
boolean | containsHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name) 指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。
String | encodeRedirectURL(HttpServletRequest request, ExtendedHttpServletResponse response, String url) #sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。
String | encodeURL(HttpServletRequest request, ExtendedHttpServletResponse response, String url) 指定されたURLがセッションIDを含むようにエンコードします。
void | flushBuffer(HttpServletRequest request, ExtendedHttpServletResponse response) バッファリングされているコンテンツを強制的にクライアントに出力します。
int | getBufferSize(HttpServletRequest request, ExtendedHttpServletResponse response) このレスポンスに設定されている実バッファサイズを返します。
String | getCharacterEncoding(HttpServletRequest request, ExtendedHttpServletResponse response) このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。
Locale | getLocale(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスに設定されているロケールを返します。
ServletOutputStream | getOutputStream(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。
PrintWriter | getWriter(HttpServletRequest request, ExtendedHttpServletResponse response) 文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。
void | init(HttpServletResponseEventConfig config) このビルダを初期化します。
boolean | isCommitted(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスがすでにコミットされたかどうかを示す boolean を返します。
void | reset(HttpServletRequest request, ExtendedHttpServletResponse response) バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。
void | resetBuffer(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。
void | sendError(HttpServletRequest request, ExtendedHttpServletResponse response, int sc) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
void | sendError(HttpServletRequest request, ExtendedHttpServletResponse response, int sc, String msg) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
void | sendRedirect(HttpServletRequest request, ExtendedHttpServletResponse response, String location) 指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。
void | setBufferSize(HttpServletRequest request, ExtendedHttpServletResponse response, int size) 適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。
void | setContentLength(HttpServletRequest request, ExtendedHttpServletResponse response, int len) レスポンスのメッセージボディ部分の長さをセットします。
void | setContentType(HttpServletRequest request, ExtendedHttpServletResponse response, String type) クライアントに送り返されるレスポンスのコンテントタイプをセットします。
void | setDateHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。
void | setHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを設定します。
void | setIntHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを設定します。
void | setLocale(HttpServletRequest request, ExtendedHttpServletResponse response, Locale loc) レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。
void | setStatus(HttpServletRequest request, ExtendedHttpServletResponse response, int sc) このレスポンスのステータスコードを設定します。

メソッドの詳細

init

public void init(HttpServletResponseEventConfig config)
          throws HttpServletResponseEventListenerException
このビルダを初期化します。

パラメータ:
config - 初期化パラメータ
例外:
HttpServletResponseEventListenerException - 初期化に失敗した場合

getCharacterEncoding

public String getCharacterEncoding(HttpServletRequest request,
                                   ExtendedHttpServletResponse response)
このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。

このメソッドは、 ServletResponse.getCharacterEncoding() の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの ServletResponse.getCharacterEncoding() 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
文字エンコーディング名を意味する String。
関連項目:
ServletResponse.getCharacterEncoding()

getOutputStream

public ServletOutputStream getOutputStream(HttpServletRequest request,
                                           ExtendedHttpServletResponse response)
                                    throws IOException
レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。

このメソッドは、 ServletResponse.getOutputStream() の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの ServletResponse.getOutputStream() 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
バイナリデータ出力に使用する ServletOutputStream
例外:
IllegalStateException - このレスポンスですでに #getWriter() メソッドが実行されていた場合
IOException - 入出力時に例外が発生した場合
関連項目:
#getWriter(HTTPContext, ExtendedHttpServletResponse),
ServletResponse.getWriter(),
ServletResponse.getOutputStream()

getWriter

public PrintWriter getWriter(HttpServletRequest request,
                             ExtendedHttpServletResponse response)
                      throws IOException
文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。

このメソッドは、 ServletResponse.getWriter() の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの ServletResponse.getWriter() 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
クライアントに文字データを送り返すことができる PrintWriter オブジェクト
例外:
UnsupportedEncodingException - setContentType メソッドで指定された文字エンコーディングがサポートされていない場合
IllegalStateException - このレスポンスですでに #getOutputStream() メソッドが実行されていた場合
IOException - 入出力時に例外が発生した場合
関連項目:
#getOutputStream(HTTPContext, ExtendedHttpServletResponse),
ServletResponse.getOutputStream(),
ServletResponse.getWriter()

setContentLength

public void setContentLength(HttpServletRequest request,
                             ExtendedHttpServletResponse response,
                             int len)
レスポンスのメッセージボディ部分の長さをセットします。

このメソッドは、 ServletResponse.setContentLength(int) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの ServletResponse.setContentLength(int) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
len - クライアントに送り返すメッセージボディの長さを指定する整数値。
関連項目:
ServletResponse.setContentLength(int)

setContentType

public void setContentType(HttpServletRequest request,
                           ExtendedHttpServletResponse response,
                           String type)
クライアントに送り返されるレスポンスのコンテントタイプをセットします。

このメソッドは、 javax.servlet.ServletResponse#setContentLength(String) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの javax.servlet.ServletResponse#setContentLength(String) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
type - コンテントタイプを指定する String
関連項目:
ServletResponse.setContentType(String),
#getOutputStream(HTTPContext, ExtendedHttpServletResponse),
#getWriter(HTTPContext, ExtendedHttpServletResponse)

setBufferSize

public void setBufferSize(HttpServletRequest request,
                          ExtendedHttpServletResponse response,
                          int size)
適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。

このメソッドは、 ServletResponse.setBufferSize(int) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの ServletResponse.setBufferSize(int) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
size - 適当なバッファサイズを指定する整数値
例外:
IllegalStateException - すでにコンテンツが出力された後でこのメソッドが実行された場合
関連項目:
ServletResponse.setBufferSize(int),
#getBufferSize(HTTPContext, ExtendedHttpServletResponse),
#flushBuffer(HTTPContext, ExtendedHttpServletResponse),
#isCommitted(HTTPContext, ExtendedHttpServletResponse),
#reset(HTTPContext, ExtendedHttpServletResponse)

getBufferSize

public int getBufferSize(HttpServletRequest request,
                         ExtendedHttpServletResponse response)
このレスポンスに設定されている実バッファサイズを返します。

このメソッドは、 ServletResponse.getBufferSize() の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの ServletResponse.getBufferSize() 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
実際に使われているバッファサイズ
関連項目:
ServletResponse.getBufferSize(),
#setBufferSize(HTTPContext, ExtendedHttpServletResponse, int),
#flushBuffer(HTTPContext, ExtendedHttpServletResponse),
#isCommitted(HTTPContext, ExtendedHttpServletResponse),
#reset(HTTPContext, ExtendedHttpServletResponse)

flushBuffer

public void flushBuffer(HttpServletRequest request,
                        ExtendedHttpServletResponse response)
                 throws IOException
バッファリングされているコンテンツを強制的にクライアントに出力します。

このメソッドは、 ServletResponse.flushBuffer() の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの ServletResponse.flushBuffer() 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
例外:
IOException - 入出力時に例外が発生した場合
関連項目:
ServletResponse.flushBuffer(),
#setBufferSize(HTTPContext, ExtendedHttpServletResponse, int),
#getBufferSize(HTTPContext, ExtendedHttpServletResponse),
#isCommitted(HTTPContext, ExtendedHttpServletResponse),
#reset(HTTPContext, ExtendedHttpServletResponse)

resetBuffer

public void resetBuffer(HttpServletRequest request,
                        ExtendedHttpServletResponse response)
レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。

このメソッドは、 ServletResponse.resetBuffer() の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの ServletResponse.resetBuffer() 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
関連項目:
ServletResponse.resetBuffer(),
#setBufferSize(HTTPContext, ExtendedHttpServletResponse, int),
#getBufferSize(HTTPContext, ExtendedHttpServletResponse),
#isCommitted(HTTPContext, ExtendedHttpServletResponse),
#reset(HTTPContext, ExtendedHttpServletResponse)

isCommitted

public boolean isCommitted(HttpServletRequest request,
                           ExtendedHttpServletResponse response)
レスポンスがすでにコミットされたかどうかを示す boolean を返します。

このメソッドは、 ServletResponse.isCommitted() の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの ServletResponse.isCommitted() 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
レスポンスがすでにコミットされたかどうかを示す boolean
関連項目:
ServletResponse.isCommitted(),
#setBufferSize(HTTPContext, ExtendedHttpServletResponse, int),
#getBufferSize(HTTPContext, ExtendedHttpServletResponse),
#flushBuffer(HTTPContext, ExtendedHttpServletResponse),
#reset(HTTPContext, ExtendedHttpServletResponse)

reset

public void reset(HttpServletRequest request,
                  ExtendedHttpServletResponse response)
バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。

このメソッドは、 ServletResponse.reset() の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの ServletResponse.reset() 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
関連項目:
ServletResponse.reset(),
#setBufferSize(HTTPContext, ExtendedHttpServletResponse, int),
#getBufferSize(HTTPContext, ExtendedHttpServletResponse),
#flushBuffer(HTTPContext, ExtendedHttpServletResponse),
#isCommitted(HTTPContext, ExtendedHttpServletResponse)

setLocale

public void setLocale(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      Locale loc)
レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。

このメソッドは、 ServletResponse.setLocale(Locale) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの ServletResponse.setLocale(Locale) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
loc - レスポンスのロケールを指定する Locale オブジェクト
関連項目:
ServletResponse.setLocale(Locale), #getLocale(HTTPContext, ExtendedHttpServletResponse)

getLocale

public Locale getLocale(HttpServletRequest request,
                        ExtendedHttpServletResponse response)
レスポンスに設定されているロケールを返します。

このメソッドは、 ServletResponse.getLocale() の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの ServletResponse.getLocale() 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
レスポンスに設定されているロケール
関連項目:
ServletResponse.getLocale(), #setLocale(HTTPContext, ExtendedHttpServletResponse, java.util.Locale)

addCookie

public void addCookie(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      Cookie cookie)
指定されたCookieをレスポンスに追加します。

このメソッドは、 HttpServletResponse.addCookie(Cookie) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.addCookie(Cookie) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
cookie - クライアントに返すCookie
関連項目:
HttpServletResponse.addCookie(Cookie)

containsHeader

public boolean containsHeader(HttpServletRequest request,
                              ExtendedHttpServletResponse response,
                              String name)
指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。

このメソッドは、 HttpServletResponse.containsHeader(String) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.containsHeader(String) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダ名
戻り値:
指定された名前のレスポンスヘッダが既にセットされていれば true、そうでなければfalse
関連項目:
HttpServletResponse.containsHeader(String)

encodeURL

public String encodeURL(HttpServletRequest request,
                        ExtendedHttpServletResponse response,
                        String url)
指定されたURLがセッションIDを含むようにエンコードします。

このメソッドは、 HttpServletResponse.encodeURL(String) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.encodeURL(String) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
url - エンコードするURL
戻り値:
エンコードが必要である場合、エンコードされたURL。 そうでない場合は与えられたそのままのURL
関連項目:
HttpServletResponse.encodeURL(String)

encodeRedirectURL

public String encodeRedirectURL(HttpServletRequest request,
                                ExtendedHttpServletResponse response,
                                String url)
#sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。

このメソッドは、 HttpServletResponse.encodeRedirectURL(String) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.encodeRedirectURL(String) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
url - エンコードするURL
戻り値:
エンコードが必要である場合、エンコードされたURL。 そうでない場合は与えられたそのままのURL
関連項目:
HttpServletResponse.encodeRedirectURL(String),
#sendRedirect(HTTPContext, ExtendedHttpServletResponse, String),
#encodeURL(HTTPContext, ExtendedHttpServletResponse, String)

sendError

public void sendError(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      int sc,
                      String msg)
               throws IOException
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。

このメソッドは、 HttpServletResponse.sendError(int, String) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.sendError(int, String) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
sc - エラーステータスコード
msg - 説明文
例外:
IOException - 入出力例外が発生した場合
IllegalStateException - レスポンスが既にコミットされている場合
関連項目:
HttpServletResponse.sendError(int, String)

sendError

public void sendError(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      int sc)
               throws IOException
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。

このメソッドは、 HttpServletResponse.sendError(int) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.sendError(int) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
sc - エラーステータスコード
例外:
IOException - 入出力例外が発生した場合
IllegalStateException - レスポンスが既にコミットされている場合
関連項目:
HttpServletResponse.sendError(int)

sendRedirect

public void sendRedirect(HttpServletRequest request,
                         ExtendedHttpServletResponse response,
                         String location)
                  throws IOException
指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。

このメソッドは、 HttpServletResponse.sendRedirect(String) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.sendRedirect(String) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
location - リダイレクト先のURL
例外:
IOException - 入出力例外が発生した場合
IllegalStateException - レスポンスが既にコミットされている場合
関連項目:
HttpServletResponse.sendRedirect(String)

setDateHeader

public void setDateHeader(HttpServletRequest request,
                          ExtendedHttpServletResponse response,
                          String name,
                          long date)
指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。

このメソッドは、 HttpServletResponse.setDateHeader(String, long) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.setDateHeader(String, long) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - 設定するヘッダの名称
date - 設定するヘッダの値
関連項目:
HttpServletResponse.setDateHeader(String, long),
#containsHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String),
#addDateHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String, long)

addDateHeader

public void addDateHeader(HttpServletRequest request,
                          ExtendedHttpServletResponse response,
                          String name,
                          long date)
指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。

このメソッドは、 HttpServletResponse.addDateHeader(String, long) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.addDateHeader(String, long) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - 追加するヘッダの名称
date - 追加するヘッダの値
関連項目:
HttpServletResponse.addDateHeader(String, long), #setDateHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String, long)

setHeader

public void setHeader(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      String name,
                      String value)
指定された名称で指定された値を持つレスポンスヘッダを設定します。

このメソッドは、 HttpServletResponse.setHeader(String, String) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.setHeader(String, String) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダの名称
value - ヘッダの値
関連項目:
HttpServletResponse.setHeader(String, String),
#containsHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String),
#addHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String, java.lang.String)

addHeader

public void addHeader(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      String name,
                      String value)
指定された名称で指定された値を持つレスポンスヘッダを追加します。

このメソッドは、 HttpServletResponse.addHeader(String, String) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.addHeader(String, String) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダの名称
value - 追加するヘッダの値
関連項目:
HttpServletResponse.addHeader(String, String), #setHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String, java.lang.String)

setIntHeader

public void setIntHeader(HttpServletRequest request,
                         ExtendedHttpServletResponse response,
                         String name,
                         int value)
指定された名称で指定された整数値を持つレスポンスヘッダを設定します。

このメソッドは、 HttpServletResponse.setIntHeader(String, int) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.setIntHeader(String, int) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダの名称
value - 割り当てられる整数値
関連項目:
HttpServletResponse.setIntHeader(String, int),
#containsHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String),
#addIntHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String, int)

addIntHeader

public void addIntHeader(HttpServletRequest request,
                         ExtendedHttpServletResponse response,
                         String name,
                         int value)
指定された名称で指定された整数値を持つレスポンスヘッダを追加します。

このメソッドは、 HttpServletResponse.addIntHeader(String, int) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.addIntHeader(String, int) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダの名称
value - 割り当てられる整数値
関連項目:
HttpServletResponse.addIntHeader(String, int), #setIntHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String, int)

setStatus

public void setStatus(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      int sc)
このレスポンスのステータスコードを設定します。

このメソッドは、 HttpServletResponse.setStatus(int) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.setStatus(int) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
sc - ステータスコード
関連項目:
HttpServletResponse.setStatus(int), #sendError(HTTPContext, ExtendedHttpServletResponse, int, java.lang.String)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpServletResponseEventListenerException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス HttpServletResponseEventListenerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException
                        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListenerException
すべての実装インタフェース:
Serializable
public class HttpServletResponseEventListenerException
extends HttpServletResponseEventException

レスポンスリスナに関わる処理中にエラーが発生した事を通知する例外です。

導入されたバージョン:
Version 6.0
関連項目:
直列化された形式

コンストラクタの概要
HttpServletResponseEventListenerException()
詳細メッセージを null にして、新規例外を構築します。
HttpServletResponseEventListenerException(String message)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventListenerException(String message, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventListenerException(Throwable cause)
指定された原因を使用して新規例外を構築します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HttpServletResponseEventListenerException

public HttpServletResponseEventListenerException()
詳細メッセージを null にして、新規例外を構築します。 このコンストラクタでは原因を初期化しません。

HttpServletResponseEventListenerException

public HttpServletResponseEventListenerException(String message)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。 このコンストラクタでは原因を初期化しません。

パラメータ:
message - 詳細メッセージ。詳細メッセージは Throwable.getMessage() メソッドによる取得用に保存される

HttpServletResponseEventListenerException

public HttpServletResponseEventListenerException(String message,
                                                 Throwable cause)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。

cause と関連付けられた詳細メッセージが、 この例外の詳細メッセージに自動的に統合されることはありません。

パラメータ:
message - 詳細メッセージ。詳細メッセージは Throwable.getMessage() メソッドによる取得用に保存される
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す

HttpServletResponseEventListenerException

public HttpServletResponseEventListenerException(Throwable cause)
指定された原因を使用して新規例外を構築します。

パラメータ:
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpServletResponseEventValidator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
インタフェース HttpServletResponseEventValidator

public interface HttpServletResponseEventValidator

レスポンスイベントが有効か無効かを判定するバリデータ。 このバリデータが無効と判定した場合、イベントリスナは呼び出されません。

導入されたバージョン:
Version 6.0

メソッドの概要
void | init(HttpServletResponseEventConfig config) この Validator を初期化します。
boolean | isValid(HttpServletRequest request, ExtendedHttpServletResponse response) イベントリスナを動作させるかどうかの意思決定をします。

メソッドの詳細

init

public void init(HttpServletResponseEventConfig config)
          throws HttpServletResponseEventValidatorException
この Validator を初期化します。

パラメータ:
config - 初期化パラメータ
例外:
HttpServletResponseEventValidatorException - 初期化に失敗した場合

isValid

public boolean isValid(HttpServletRequest request,
                       ExtendedHttpServletResponse response)
                throws HttpServletResponseEventValidatorException
イベントリスナを動作させるかどうかの意思決定をします。

パラメータ:
request - リクエスト
戻り値:
イベントリスナを動作させる場合 true。そうでない場合 false。
例外:
HttpServletResponseEventValidatorException - エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpServletResponseEventValidatorException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス HttpServletResponseEventValidatorException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException
                        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidatorException
すべての実装インタフェース:
Serializable
public class HttpServletResponseEventValidatorException
extends HttpServletResponseEventException

バリデータに関わる処理中にエラーが発生した事を通知する例外です。

導入されたバージョン:
Version 6.0
関連項目:
直列化された形式

コンストラクタの概要
HttpServletResponseEventValidatorException()
詳細メッセージを null にして、新規例外を構築します。
HttpServletResponseEventValidatorException(String message)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventValidatorException(String message, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventValidatorException(Throwable cause)
指定された原因を使用して新規例外を構築します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HttpServletResponseEventValidatorException

public HttpServletResponseEventValidatorException()
詳細メッセージを null にして、新規例外を構築します。 このコンストラクタでは原因を初期化しません。

HttpServletResponseEventValidatorException

public HttpServletResponseEventValidatorException(String message)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。 このコンストラクタでは原因を初期化しません。

パラメータ:
message - 詳細メッセージ。詳細メッセージは Throwable.getMessage() メソッドによる取得用に保存される

HttpServletResponseEventValidatorException

public HttpServletResponseEventValidatorException(String message,
                                                  Throwable cause)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。

cause と関連付けられた詳細メッセージが、 この例外の詳細メッセージに自動的に統合されることはありません。

パラメータ:
message - 詳細メッセージ。詳細メッセージは Throwable.getMessage() メソッドによる取得用に保存される
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す

HttpServletResponseEventValidatorException

public HttpServletResponseEventValidatorException(Throwable cause)
指定された原因を使用して新規例外を構築します。

パラメータ:
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LuxuryResponseWriterFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス LuxuryResponseWriterFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter
すべての実装インタフェース:
Filter
public class LuxuryResponseWriterFilter
extends AbstractFilter

導入されたバージョン:
version5.0
関連項目:
AbstractFilter

コンストラクタの概要
LuxuryResponseWriterFilter()
デフォルトコンストラクタ
メソッドの概要
 void doFilter(ServletRequest request, ServletResponse response, FilterChain chain)
フィルタとして動作するロジック。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, handleInit, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LuxuryResponseWriterFilter

public LuxuryResponseWriterFilter()
デフォルトコンストラクタ

メソッドの詳細

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
クラス AbstractFilter の記述:
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
IOException - 入出力エラー
ServletException - 実行時エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NoCacheFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス NoCacheFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter
すべての実装インタフェース:
Filter
public class NoCacheFilter
extends AbstractFilter

ブラウザのキャッシュを無効にするフィルタ。

このフィルタは、レスポンスヘッダに以下を追加します。

 Pragma: no-cache
 Cache-Control: no-cache
 Expires: Tue, 22 Feb 2000 12:00:00 GMT

レスポンスヘッダ Expires の値については、 フィルタの初期化パラメータ expires で任意に設定する事もできます。

設定可能な初期化パラメータは以下のとおりです。

expires コンテンツの有効期限日時

導入されたバージョン:
version 5.0

コンストラクタの概要
NoCacheFilter()
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタとして動作するロジック。
protected void | handleInit() フィルタの初期化をします。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NoCacheFilter

public NoCacheFilter()
メソッドの詳細

handleInit

protected void handleInit()
                   throws ServletException
フィルタの初期化をします。

このメソッドは、フィルタ初期化時に AbstractFilter.init(FilterConfig) に 呼び出されます。

オーバーライド:
クラス AbstractFilter 内の handleInit
例外:
ServletException - 初期化エラー
関連項目:
AbstractFilter.init(FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
ServletException - 実行時エラー
IOException - 入出力エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
インタフェース
HttpServletRequestMessageBodyWrapper
HttpServletRequestMessageBodyWrapperBuilder
HttpServletResponseEventComponentBuilder
HttpServletResponseEventConfig
HttpServletResponseEventController
HttpServletResponseEventControllerBuilder
HttpServletResponseEventListener
HttpServletResponseEventValidator
RequestParameter
クラス
AbsoluteLinkFilter
AbstractFilter
AbstractHttpServletResponseEventConfig
AbstractHttpServletResponseEventController
AbstractHttpServletResponseEventListener
ExceptionHandlingFilter
HTTPContextHandlingFilter
HttpServletResponseEventFilter
LuxuryResponseWriterFilter
NoCacheFilter
RequestMessageBodyFilter
ResponseContentTypeManagementFilter
SimpleHttpServletResponseEventListener
StandardHttpServletResponseEventControllerBuilder
例外
HttpServletResponseEventControllerException
HttpServletResponseEventException
HttpServletResponseEventFilterException
HttpServletResponseEventListenerException
HttpServletResponseEventValidatorException


jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter

このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

参照:
説明

インタフェースの概要
HttpServletRequestMessageBodyWrapper | HttpServletRequest を拡張したインタフェースです。
HttpServletRequestMessageBodyWrapperBuilder | HttpServletRequest を拡張したインタフェースです。
HttpServletResponseEventComponentBuilder | レスポンスイベントに関わる各種コンポーネント（リスナやバリデータ）をを構築するビルダです。
HttpServletResponseEventConfig | レスポンスの各メソッド呼び出しに対するイベントを 設定するためのオブジェクトです。
HttpServletResponseEventController | レスポンスイベントコントローラのインタフェース。
HttpServletResponseEventControllerBuilder | コントローラを構築するビルダです。
HttpServletResponseEventListener | レスポンスの各メソッド呼び出しに対するイベントをフックするためのインタフェースです。
HttpServletResponseEventValidator | レスポンスイベントが有効か無効かを判定するバリデータ。
RequestParameter | １つのリクエストパラメータを保持するオブジェクトの共通インターフェース。

クラスの概要
AbsoluteLinkFilter | 絶対表現のＵＲＬをレスポンスするためのフィルタ。
AbstractFilter | フィルタを実装するための抽象クラスです。
AbstractHttpServletResponseEventConfig | レスポンスの各メソッド呼び出しに対するイベントを 設定するためのオブジェクトの抽象実装です。
AbstractHttpServletResponseEventController | イベントを制御するレスポンスの抽象実装です。
AbstractHttpServletResponseEventListener | レスポンスの各メソッド呼び出しに対するイベントをフックするための抽象実装です。
ExceptionHandlingFilter | サーブレットの実行例外をキャッチして、 指定のエラーページへフォワードするフィルタです。
HTTPContextHandlingFilter | このフィルタを利用することにより、 HTTPContextManager経由で HTTPContextを取得できるようになります。
HttpServletResponseEventFilter | サーブレットレスポンスの各メソッド呼び出しに対するリスナを設定するフィルタ。
LuxuryResponseWriterFilter |
NoCacheFilter | ブラウザのキャッシュを無効にするフィルタ。
RequestMessageBodyFilter | リクエストをラップするフィルタです。
ResponseContentTypeManagementFilter | レスポンスの Content-Type を自動解決するフィルタです。
SimpleHttpServletResponseEventListener | レスポンスの各メソッド呼び出しに対するイベントをフックするためのコンポーネント実装です。
StandardHttpServletResponseEventControllerBuilder | 標準的なコントローラを構築するビルダです。

例外の概要
HttpServletResponseEventControllerException | コントローラに関わる処理中にエラーが発生した事を通知する例外です。
HttpServletResponseEventException | イベントに関わる処理中にエラーが発生した事を通知する例外です。
HttpServletResponseEventFilterException | レスポンスイベントを定義するフィルタでエラーが発生した事を通知する例外です。
HttpServletResponseEventListenerException | レスポンスリスナに関わる処理中にエラーが発生した事を通知する例外です。
HttpServletResponseEventValidatorException | バリデータに関わる処理中にエラーが発生した事を通知する例外です。

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter の説明

このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。


jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter (implements javax.servlet.Filter)
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventConfig (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventConfig)
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener)
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener
    • class javax.servlet.ServletResponseWrapper (implements javax.servlet.ServletResponse)
      • class javax.servlet.http.HttpServletResponseWrapper (implements javax.servlet.http.HttpServletResponse)
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse)
          • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController)
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.StandardHttpServletResponseEventControllerBuilder (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerBuilder)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.servlet.ServletException
          • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilterException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListenerException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidatorException

インタフェース階層

  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventComponentBuilder
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventConfig
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerBuilder
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidator
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter
  • interface javax.servlet.ServletRequest
    • interface javax.servlet.http.HttpServletRequest
      • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper
  • interface javax.servlet.ServletResponse
    • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse
      • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse (同様に extends javax.servlet.http.HttpServletResponse)
        • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController
    • interface javax.servlet.http.HttpServletResponse
      • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse (同様に extends jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse)
        • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController


パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter | このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session | このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.security.filter | アクセスセキュリティのフィルタに関連するクラスを提供します。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のクラス
AbstractFilter
フィルタを実装するための抽象クラスです。
AbstractHttpServletResponseEventListener
レスポンスの各メソッド呼び出しに対するイベントをフックするための抽象実装です。
HttpServletRequestMessageBodyWrapper
HttpServletRequest を拡張したインタフェースです。
HttpServletResponseEventConfig
レスポンスの各メソッド呼び出しに対するイベントを 設定するためのオブジェクトです。
HttpServletResponseEventController
レスポンスイベントコントローラのインタフェース。
HttpServletResponseEventControllerBuilder
コントローラを構築するビルダです。
HttpServletResponseEventControllerException
コントローラに関わる処理中にエラーが発生した事を通知する例外です。
HttpServletResponseEventException
イベントに関わる処理中にエラーが発生した事を通知する例外です。
HttpServletResponseEventListener
レスポンスの各メソッド呼び出しに対するイベントをフックするためのインタフェースです。
HttpServletResponseEventListenerException
レスポンスリスナに関わる処理中にエラーが発生した事を通知する例外です。
HttpServletResponseEventValidator
レスポンスイベントが有効か無効かを判定するバリデータ。
HttpServletResponseEventValidatorException
バリデータに関わる処理中にエラーが発生した事を通知する例外です。
RequestParameter
１つのリクエストパラメータを保持するオブジェクトの共通インターフェース。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のクラス
AbstractFilter
フィルタを実装するための抽象クラスです。

jp.co.intra_mart.foundation.security.filter により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のクラス
AbstractFilter
フィルタを実装するための抽象クラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


RequestMessageBodyFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス RequestMessageBodyFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter
すべての実装インタフェース:
Filter
public class RequestMessageBodyFilter
extends AbstractFilter

リクエストをラップするフィルタです。 このフィルタを利用する事により、リクエストの情報を、 いつでも取得できるようになります。

このフィルタを利用する場合は、実装を指定する必要があります。 フィルタの初期化パラメータ名 config に、 MIME タイプと インタフェース HttpServletRequestMessageBodyWrapperBuilder の 実装クラス名を指定したプロパティズファイルのパスを設定してください。

導入されたバージョン:
version 5.0

コンストラクタの概要
RequestMessageBodyFilter()
フィルタを作成します。
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタとして動作するロジック。
static HttpServletRequestMessageBodyWrapper | getCurrentRequest() 現在処理中のリクエストを返します。
static InputStream | getInputStream() 現在のリクエストのメッセージボディを返します。
static RequestParameter[] | getRequestParameters() 現在のリクエストのパラメータを返します。
protected void | handleDestroy() フィルタの破棄処理。
protected void | handleInit() フィルタの初期化をします。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RequestMessageBodyFilter

public RequestMessageBodyFilter()
フィルタを作成します。

メソッドの詳細

getInputStream

public static InputStream getInputStream()
                                  throws IOException
現在のリクエストのメッセージボディを返します。

リクエストまたはメッセージボディが不明の場合は、null を返します。

戻り値:
メッセージボディを含む入力ストリーム
例外:
IOException - 入出力の例外が発生した場合

getRequestParameters

public static RequestParameter[] getRequestParameters()
                                               throws IOException
現在のリクエストのパラメータを返します。

リクエストが不明な場合は null を返します。

戻り値:
パラメータ情報オブジェクトの配列
例外:
IOException - 入出力の例外が発生した場合

getCurrentRequest

public static HttpServletRequestMessageBodyWrapper getCurrentRequest()
現在処理中のリクエストを返します。

リクエストが不明、 またはHttpServletRequestMessageBodyWrapperに ラップされていない場合は、null を返します。

戻り値:
リクエスト

handleInit

protected void handleInit()
                   throws ServletException
フィルタの初期化をします。

このメソッドは、フィルタ初期化時に AbstractFilter.init(FilterConfig) に 呼び出されます。

オーバーライド:
クラス AbstractFilter 内の handleInit
例外:
ServletException - 初期化エラー
関連項目:
AbstractFilter.init(FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
ServletException - 実行時エラー
IOException - 入出力エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)

handleDestroy

protected void handleDestroy()
フィルタの破棄処理。

このメソッドは、フィルタ破棄時に AbstractFilter.destroy() に 呼び出されます。

オーバーライド:
クラス AbstractFilter 内の handleDestroy
関連項目:
AbstractFilter.destroy()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RequestParameter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
インタフェース RequestParameter

public interface RequestParameter

１つのリクエストパラメータを保持するオブジェクトの共通インターフェース。

導入されたバージョン:
Version 5.0

メソッドの概要
String | getHeader(String name) 指定のヘッダの値を返します。
String[] | getHeaderNames() ヘッダ名称一覧を返します。
String | getName() パラメータ名を返します。
InputStream | getNameAsStream() パラメータの名称を返します。
String | getValue() データ部を文字列表現として返します。
Reader | getValueAsReader() 推奨されていません。 getValueAsReader(String) に置き換えられました。
Reader | getValueAsReader(String encoding) データ部を Reader として取得します。
InputStream | getValueAsStream() データ部を入力ストリームとして取得します。
long | getValueLength() データ部のバイト長を返します。
boolean | hasHeader(String name) 指定された文字列がヘッダの名称かどうかを判定します。
boolean | hasHeaders() このオブジェクトがヘッダ情報を持つかどうかを判定します。

メソッドの詳細

getName

public String getName()
パラメータ名を返します。

GET の場合、各パラメータのパラメータ名を返します。
POST の場合、 フォームから送信された情報のうち、このエンティティが表す情報の もととなったフォーム中に定義されたコントロールの名称を返します。

戻り値:
パラメータ名

getNameAsStream

public InputStream getNameAsStream()
                            throws IOException
パラメータの名称を返します。

戻り値:
パラメータ名を含む入力ストリーム
例外:
IOException - 入出力エラー

getValue

public String getValue()
データ部を文字列表現として返します。

入力されたバイトデータから文字列への変換には、 リクエストの文字エンコーディング(javax.servlet.ServletRequest#getCharacterEncoding())を使います。

戻り値:
データ

getValueAsReader

public Reader getValueAsReader()
                        throws UnsupportedEncodingException,
                               IOException
推奨されていません。 getValueAsReader(String) に置き換えられました。

データ部を Reader として取得します。

文字コード変換には、 リクエストの文字エンコーディング(javax.servlet.ServletRequest#getCharacterEncoding())を使います。

戻り値:
データ
例外:
UnsupportedEncodingException
IOException

getValueAsReader

public Reader getValueAsReader(String encoding)
                        throws UnsupportedEncodingException,
                               IOException
データ部を Reader として取得します。

文字コード変換には、指定された文字エンコーディングを使います。

戻り値:
データ
例外:
UnsupportedEncodingException
IOException
導入されたバージョン:
6.1.12

getValueAsStream

public InputStream getValueAsStream()
                             throws IOException
データ部を入力ストリームとして取得します。

戻り値:
データ
例外:
IOException

getValueLength

public long getValueLength()
データ部のバイト長を返します。

戻り値:
データのサイズ

hasHeaders

public boolean hasHeaders()
このオブジェクトがヘッダ情報を持つかどうかを判定します。

戻り値:
ヘッダ情報を持つ場合 true

getHeaderNames

public String[] getHeaderNames()
ヘッダ名称一覧を返します。

このエンティティのもつヘッダ情報の名称一覧を返します。
ヘッダ情報がない場合、このメソッドは null を返します。

戻り値:
ヘッダ名称

getHeader

public String getHeader(String name)
指定のヘッダの値を返します。

指定のヘッダ名がない場合や、ヘッダ自体がない場合は、 null を返します。

パラメータ:
name - ヘッダ名称
戻り値:
ヘッダ名称にマップされている値

hasHeader

public boolean hasHeader(String name)
指定された文字列がヘッダの名称かどうかを判定します。

パラメータ:
name - ヘッダ名称
戻り値:
ヘッダ名称が値にマップされている場合 true
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ResponseContentTypeManagementFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス ResponseContentTypeManagementFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter
すべての実装インタフェース:
Filter
public class ResponseContentTypeManagementFilter
extends AbstractFilter

レスポンスの Content-Type を自動解決するフィルタです。
このフィルタの次のチェーン以降でレスポンス(ServletResponse)に対して、 #setCopntentType() を呼び出さなかった場合、 #getWriter() または #getOutputStream() 呼び出し時に Content-Type を自動的に設定します。

設定する Content-Type は、このフィルタの初期化パラメータ Content-Type で 指定された値です。 初期化パラメータ Content-Type が未定義の場合、text/html が設定されます。

バージョン:
1.0

コンストラクタの概要
ResponseContentTypeManagementFilter()
新しくフィルタを作成します。
メソッドの概要
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) レスポンスソースの Content-Type を 自動解決する HttpServletResponse を作成して、 次のフィルタチェーンを実行します。
void | handleInit() このフィルタを初期化します。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ResponseContentTypeManagementFilter

public ResponseContentTypeManagementFilter()
新しくフィルタを作成します。

メソッドの詳細

handleInit

public void handleInit()
このフィルタを初期化します。

オーバーライド:
クラス AbstractFilter 内の handleInit
関連項目:
AbstractFilter.init(FilterConfig)

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws ServletException,
                     IOException
レスポンスソースの Content-Type を 自動解決する HttpServletResponse を作成して、 次のフィルタチェーンを実行します。

このメソッドが作る HttpServletResponse は、引数 response をラップし、 #getWriter() または #getOutputStream() メソッドが実行された時に #setContentType() を一度も呼び出されていない場合、 フィルタの初期化パラメータで設定されている Content-Type をセットしてから、 引数 response の #getWriter() または #getOutputStream() メソッドを 呼び出します。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SimpleHttpServletResponseEventListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス SimpleHttpServletResponseEventListener

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener
すべての実装インタフェース:
HttpServletResponseEventListener
public class SimpleHttpServletResponseEventListener
extends AbstractHttpServletResponseEventListener

レスポンスの各メソッド呼び出しに対するイベントをフックするためのコンポーネント実装です。

このクラスは、フックしたレスポンスの適当なメソッドを実行するだけの単純実装です。 アプリケーションは、このクラスを継承して、 任意のメソッドのみをオーバーライドする事により 必要なイベントフックのみを実装する事ができます。

導入されたバージョン:
Version 6.0

コンストラクタの概要
protected SimpleHttpServletResponseEventListener()
新しいリスナを作成します。
メソッドの概要
void | addCookie(HttpServletRequest request, ExtendedHttpServletResponse response, Cookie cookie) 指定されたCookieをレスポンスに追加します。
void | addDateHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。
void | addHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを追加します。
void | addIntHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを追加します。
boolean | containsHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name) 指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。
String | encodeRedirectURL(HttpServletRequest request, ExtendedHttpServletResponse response, String url) #sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。
String | encodeURL(HttpServletRequest request, ExtendedHttpServletResponse response, String url) 指定されたURLがセッションIDを含むようにエンコードします。
void | flushBuffer(HttpServletRequest request, ExtendedHttpServletResponse response) バッファリングされているコンテンツを強制的にクライアントに出力します。
int | getBufferSize(HttpServletRequest request, ExtendedHttpServletResponse response) このレスポンスに設定されている実バッファサイズを返します。
String | getCharacterEncoding(HttpServletRequest request, ExtendedHttpServletResponse response) このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。
Locale | getLocale(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスに設定されているロケールを返します。
ServletOutputStream | getOutputStream(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。
PrintWriter | getWriter(HttpServletRequest request, ExtendedHttpServletResponse response) 文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。
boolean | isCommitted(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスがすでにコミットされたかどうかを示す boolean を返します。
void | reset(HttpServletRequest request, ExtendedHttpServletResponse response) バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。
void | resetBuffer(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。
void | sendError(HttpServletRequest request, ExtendedHttpServletResponse response, int sc) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
void | sendError(HttpServletRequest request, ExtendedHttpServletResponse response, int sc, String msg) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
void | sendRedirect(HttpServletRequest request, ExtendedHttpServletResponse response, String location) 指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。
void | setBufferSize(HttpServletRequest request, ExtendedHttpServletResponse response, int size) 適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。
void | setContentLength(HttpServletRequest request, ExtendedHttpServletResponse response, int len) レスポンスのメッセージボディ部分の長さをセットします。
void | setContentType(HttpServletRequest request, ExtendedHttpServletResponse response, String type) クライアントに送り返されるレスポンスのコンテントタイプをセットします。
void | setDateHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。
void | setHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを設定します。
void | setIntHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを設定します。
void | setLocale(HttpServletRequest request, ExtendedHttpServletResponse response, Locale loc) レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。
void | setStatus(HttpServletRequest request, ExtendedHttpServletResponse response, int sc) このレスポンスのステータスコードを設定します。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener から継承したメソッド
getHttpServletResponseEventConfig, getServletContext, handleInit, init
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SimpleHttpServletResponseEventListener

protected SimpleHttpServletResponseEventListener()
新しいリスナを作成します。

メソッドの詳細

getCharacterEncoding

public String getCharacterEncoding(HttpServletRequest request,
                                   ExtendedHttpServletResponse response)
このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。

このメソッドは、単純に以下を実行します。
return response.getCharacterEncoding();

定義:
インタフェース HttpServletResponseEventListener 内の getCharacterEncoding
定義:
クラス AbstractHttpServletResponseEventListener 内の getCharacterEncoding
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
文字エンコーディング名を意味する String。

getOutputStream

public ServletOutputStream getOutputStream(HttpServletRequest request,
                                           ExtendedHttpServletResponse response)
                                    throws IOException
レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。

このメソッドは、単純に以下を実行します。
return response.getOutputStream();

定義:
インタフェース HttpServletResponseEventListener 内の getOutputStream
定義:
クラス AbstractHttpServletResponseEventListener 内の getOutputStream
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
バイナリデータ出力に使用する ServletOutputStream
例外:
IllegalStateException - このレスポンスですでに #getWriter() メソッドが実行されていた場合
IOException - 入出力時に例外が発生した場合

getWriter

public PrintWriter getWriter(HttpServletRequest request,
                             ExtendedHttpServletResponse response)
                      throws IOException
文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。

このメソッドは、単純に以下を実行します。
return response.getWriter();

定義:
インタフェース HttpServletResponseEventListener 内の getWriter
定義:
クラス AbstractHttpServletResponseEventListener 内の getWriter
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
クライアントに文字データを送り返すことができる PrintWriter オブジェクト
例外:
UnsupportedEncodingException - setContentType メソッドで指定された文字エンコーディングがサポートされていない場合
IllegalStateException - このレスポンスですでに #getOutputStream() メソッドが実行されていた場合
IOException - 入出力時に例外が発生した場合

setContentLength

public void setContentLength(HttpServletRequest request,
                             ExtendedHttpServletResponse response,
                             int len)
レスポンスのメッセージボディ部分の長さをセットします。

このメソッドは、単純に以下を実行します。
response.setContentLength(len);

定義:
インタフェース HttpServletResponseEventListener 内の setContentLength
定義:
クラス AbstractHttpServletResponseEventListener 内の setContentLength
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
len - クライアントに送り返すメッセージボディの長さを指定する整数値。

setContentType

public void setContentType(HttpServletRequest request,
                           ExtendedHttpServletResponse response,
                           String type)
クライアントに送り返されるレスポンスのコンテントタイプをセットします。

このメソッドは、単純に以下を実行します。
response.setContentType(type);

定義:
インタフェース HttpServletResponseEventListener 内の setContentType
定義:
クラス AbstractHttpServletResponseEventListener 内の setContentType
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
type - コンテントタイプを指定する String

setBufferSize

public void setBufferSize(HttpServletRequest request,
                          ExtendedHttpServletResponse response,
                          int size)
適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。

このメソッドは、単純に以下を実行します。
response.setBufferSize(size);

定義:
インタフェース HttpServletResponseEventListener 内の setBufferSize
定義:
クラス AbstractHttpServletResponseEventListener 内の setBufferSize
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
size - 適当なバッファサイズを指定する整数値
例外:
IllegalStateException - すでにコンテンツが出力された後でこのメソッドが実行された場合

getBufferSize

public int getBufferSize(HttpServletRequest request,
                         ExtendedHttpServletResponse response)
このレスポンスに設定されている実バッファサイズを返します。

このメソッドは、単純に以下を実行します。
return response.getBufferSize();

定義:
インタフェース HttpServletResponseEventListener 内の getBufferSize
定義:
クラス AbstractHttpServletResponseEventListener 内の getBufferSize
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
実際に使われているバッファサイズ

flushBuffer

public void flushBuffer(HttpServletRequest request,
                        ExtendedHttpServletResponse response)
                 throws IOException
バッファリングされているコンテンツを強制的にクライアントに出力します。

このメソッドは、単純に以下を実行します。
response.flushBuffer();

定義:
インタフェース HttpServletResponseEventListener 内の flushBuffer
定義:
クラス AbstractHttpServletResponseEventListener 内の flushBuffer
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
例外:
IOException - 入出力時に例外が発生した場合

resetBuffer

public void resetBuffer(HttpServletRequest request,
                        ExtendedHttpServletResponse response)
レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。

このメソッドは、単純に以下を実行します。
response.resetBuffer();

定義:
インタフェース HttpServletResponseEventListener 内の resetBuffer
定義:
クラス AbstractHttpServletResponseEventListener 内の resetBuffer
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス

isCommitted

public boolean isCommitted(HttpServletRequest request,
                           ExtendedHttpServletResponse response)
レスポンスがすでにコミットされたかどうかを示す boolean を返します。

このメソッドは、単純に以下を実行します。
return response.isCommitted();

定義:
インタフェース HttpServletResponseEventListener 内の isCommitted
定義:
クラス AbstractHttpServletResponseEventListener 内の isCommitted
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
レスポンスがすでにコミットされたかどうかを示す boolean

reset

public void reset(HttpServletRequest request,
                  ExtendedHttpServletResponse response)
バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。

このメソッドは、単純に以下を実行します。
response.reset();

定義:
インタフェース HttpServletResponseEventListener 内の reset
定義:
クラス AbstractHttpServletResponseEventListener 内の reset
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス

setLocale

public void setLocale(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      Locale loc)
レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。

このメソッドは、単純に以下を実行します。
response.setLocale(loc);

定義:
インタフェース HttpServletResponseEventListener 内の setLocale
定義:
クラス AbstractHttpServletResponseEventListener 内の setLocale
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
loc - レスポンスのロケールを指定する Locale オブジェクト

getLocale

public Locale getLocale(HttpServletRequest request,
                        ExtendedHttpServletResponse response)
レスポンスに設定されているロケールを返します。

このメソッドは、単純に以下を実行します。
return response.getLocale();

定義:
インタフェース HttpServletResponseEventListener 内の getLocale
定義:
クラス AbstractHttpServletResponseEventListener 内の getLocale
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
レスポンスに設定されているロケール

addCookie

public void addCookie(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      Cookie cookie)
指定されたCookieをレスポンスに追加します。

このメソッドは、単純に以下を実行します。
response.addCookie(cookie);

定義:
インタフェース HttpServletResponseEventListener 内の addCookie
定義:
クラス AbstractHttpServletResponseEventListener 内の addCookie
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
cookie - クライアントに返すCookie

containsHeader

public boolean containsHeader(HttpServletRequest request,
                              ExtendedHttpServletResponse response,
                              String name)
指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。

このメソッドは、単純に以下を実行します。
return response.containsHeader(name);

定義:
インタフェース HttpServletResponseEventListener 内の containsHeader
定義:
クラス AbstractHttpServletResponseEventListener 内の containsHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダ名
戻り値:
指定された名前のレスポンスヘッダが既にセットされていれば true、そうでなければfalse

encodeURL

public String encodeURL(HttpServletRequest request,
                        ExtendedHttpServletResponse response,
                        String url)
指定されたURLがセッションIDを含むようにエンコードします。

このメソッドは、単純に以下を実行します。
return response.encodeURL(url);

定義:
インタフェース HttpServletResponseEventListener 内の encodeURL
定義:
クラス AbstractHttpServletResponseEventListener 内の encodeURL
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
url - エンコードするURL
戻り値:
エンコードが必要である場合、エンコードされたURL。 そうでない場合は与えられたそのままのURL

encodeRedirectURL

public String encodeRedirectURL(HttpServletRequest request,
                                ExtendedHttpServletResponse response,
                                String url)
#sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。

このメソッドは、単純に以下を実行します。
return response.encodeRedirectURL(url);

定義:
インタフェース HttpServletResponseEventListener 内の encodeRedirectURL
定義:
クラス AbstractHttpServletResponseEventListener 内の encodeRedirectURL
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
url - エンコードするURL
戻り値:
エンコードが必要である場合、エンコードされたURL。 そうでない場合は与えられたそのままのURL

sendError

public void sendError(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      int sc,
                      String msg)
               throws IOException
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。

このメソッドは、単純に以下を実行します。
response.sendError(sc, msg);

定義:
インタフェース HttpServletResponseEventListener 内の sendError
定義:
クラス AbstractHttpServletResponseEventListener 内の sendError
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
sc - エラーステータスコード
msg - 説明文
例外:
IOException - 入出力例外が発生した場合
IllegalStateException - レスポンスが既にコミットされている場合

sendError

public void sendError(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      int sc)
               throws IOException
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。

このメソッドは、単純に以下を実行します。
response.sendError(sc);

定義:
インタフェース HttpServletResponseEventListener 内の sendError
定義:
クラス AbstractHttpServletResponseEventListener 内の sendError
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
sc - エラーステータスコード
例外:
IOException - 入出力例外が発生した場合
IllegalStateException - レスポンスが既にコミットされている場合

sendRedirect

public void sendRedirect(HttpServletRequest request,
                         ExtendedHttpServletResponse response,
                         String location)
                  throws IOException
指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。

このメソッドは、単純に以下を実行します。
response.sendRedirect(location);

定義:
インタフェース HttpServletResponseEventListener 内の sendRedirect
定義:
クラス AbstractHttpServletResponseEventListener 内の sendRedirect
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
location - リダイレクト先のURL
例外:
IOException - 入出力例外が発生した場合
IllegalStateException - レスポンスが既にコミットされている場合

setDateHeader

public void setDateHeader(HttpServletRequest request,
                          ExtendedHttpServletResponse response,
                          String name,
                          long date)
指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。

このメソッドは、単純に以下を実行します。
response.setDateHeader(name, date);

定義:
インタフェース HttpServletResponseEventListener 内の setDateHeader
定義:
クラス AbstractHttpServletResponseEventListener 内の setDateHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - 設定するヘッダの名称
date - 設定するヘッダの値

addDateHeader

public void addDateHeader(HttpServletRequest request,
                          ExtendedHttpServletResponse response,
                          String name,
                          long date)
指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。

このメソッドは、単純に以下を実行します。
response.addDateHeader(name, date);

定義:
インタフェース HttpServletResponseEventListener 内の addDateHeader
定義:
クラス AbstractHttpServletResponseEventListener 内の addDateHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - 追加するヘッダの名称
date - 追加するヘッダの値

setHeader

public void setHeader(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      String name,
                      String value)
指定された名称で指定された値を持つレスポンスヘッダを設定します。

このメソッドは、単純に以下を実行します。
response.setHeader(name, value);

定義:
インタフェース HttpServletResponseEventListener 内の setHeader
定義:
クラス AbstractHttpServletResponseEventListener 内の setHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダの名称
value - ヘッダの値

addHeader

public void addHeader(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      String name,
                      String value)
指定された名称で指定された値を持つレスポンスヘッダを追加します。

このメソッドは、単純に以下を実行します。
response.addHeader(name, value);

定義:
インタフェース HttpServletResponseEventListener 内の addHeader
定義:
クラス AbstractHttpServletResponseEventListener 内の addHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダの名称
value - 追加するヘッダの値

setIntHeader

public void setIntHeader(HttpServletRequest request,
                         ExtendedHttpServletResponse response,
                         String name,
                         int value)
指定された名称で指定された整数値を持つレスポンスヘッダを設定します。

このメソッドは、単純に以下を実行します。
response.setIntHeader(name, value);

定義:
インタフェース HttpServletResponseEventListener 内の setIntHeader
定義:
クラス AbstractHttpServletResponseEventListener 内の setIntHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダの名称
value - 割り当てられる整数値

addIntHeader

public void addIntHeader(HttpServletRequest request,
                         ExtendedHttpServletResponse response,
                         String name,
                         int value)
指定された名称で指定された整数値を持つレスポンスヘッダを追加します。

このメソッドは、単純に以下を実行します。
response.addIntHeader(name, value);

定義:
インタフェース HttpServletResponseEventListener 内の addIntHeader
定義:
クラス AbstractHttpServletResponseEventListener 内の addIntHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダの名称
value - 割り当てられる整数値

setStatus

public void setStatus(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      int sc)
このレスポンスのステータスコードを設定します。

このメソッドは、単純に以下を実行します。
response.setStatus(sc);

定義:
インタフェース HttpServletResponseEventListener 内の setStatus
定義:
クラス AbstractHttpServletResponseEventListener 内の setStatus
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
sc - ステータスコード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardHttpServletResponseEventControllerBuilder (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス StandardHttpServletResponseEventControllerBuilder

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.StandardHttpServletResponseEventControllerBuilder
すべての実装インタフェース:
HttpServletResponseEventControllerBuilder
public class StandardHttpServletResponseEventControllerBuilder
extends Object
implements HttpServletResponseEventControllerBuilder

標準的なコントローラを構築するビルダです。

導入されたバージョン:
Version 6.0

コンストラクタの概要
StandardHttpServletResponseEventControllerBuilder()
新しいビルダを構築します。
メソッドの概要
HttpServletResponseEventController | createController(HttpServletRequest request, ExtendedHttpServletResponse response, HttpServletResponseEventListener listener) コントローラを返します。
void | init(String initParameterValue, ServletContext servletContext) ビルダを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardHttpServletResponseEventControllerBuilder

public StandardHttpServletResponseEventControllerBuilder()
新しいビルダを構築します。

メソッドの詳細

init

public void init(String initParameterValue,
                 ServletContext servletContext)
          throws HttpServletResponseEventControllerException
ビルダを初期化します。

定義:
インタフェース HttpServletResponseEventControllerBuilder 内の init
パラメータ:
initParameterValue - パラメータ
servletContext - サーブレットコンテキスト
例外:
HttpServletResponseEventControllerException - エラーが発生した場合

createController

public HttpServletResponseEventController createController(HttpServletRequest request,
                                                           ExtendedHttpServletResponse response,
                                                           HttpServletResponseEventListener listener)
                                                    throws HttpServletResponseEventControllerException
コントローラを返します。

定義:
インタフェース HttpServletResponseEventControllerBuilder 内の createController
戻り値:
コントローラ
例外:
HttpServletResponseEventControllerException - エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse の使用

ExtendedHttpServletResponse を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter | このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http | このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での ExtendedHttpServletResponse の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での ExtendedHttpServletResponse のサブインタフェース
 interface HttpServletResponseEventController
レスポンスイベントコントローラのインタフェース。

ExtendedHttpServletResponse を実装している jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のクラス
 class AbstractHttpServletResponseEventController
イベントを制御するレスポンスの抽象実装です。

ExtendedHttpServletResponse 型のパラメータを持つ jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
HttpServletResponseEventController | StandardHttpServletResponseEventControllerBuilder.createController(HttpServletRequest request, ExtendedHttpServletResponse response, HttpServletResponseEventListener listener) コントローラを返します。
String | SimpleHttpServletResponseEventListener.getCharacterEncoding(HttpServletRequest request, ExtendedHttpServletResponse response) このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。
ServletOutputStream | SimpleHttpServletResponseEventListener.getOutputStream(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。
PrintWriter | SimpleHttpServletResponseEventListener.getWriter(HttpServletRequest request, ExtendedHttpServletResponse response) 文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。
void | SimpleHttpServletResponseEventListener.setContentLength(HttpServletRequest request, ExtendedHttpServletResponse response, int len) レスポンスのメッセージボディ部分の長さをセットします。
void | SimpleHttpServletResponseEventListener.setContentType(HttpServletRequest request, ExtendedHttpServletResponse response, String type) クライアントに送り返されるレスポンスのコンテントタイプをセットします。
void | SimpleHttpServletResponseEventListener.setBufferSize(HttpServletRequest request, ExtendedHttpServletResponse response, int size) 適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。
int | SimpleHttpServletResponseEventListener.getBufferSize(HttpServletRequest request, ExtendedHttpServletResponse response) このレスポンスに設定されている実バッファサイズを返します。
void | SimpleHttpServletResponseEventListener.flushBuffer(HttpServletRequest request, ExtendedHttpServletResponse response) バッファリングされているコンテンツを強制的にクライアントに出力します。
void | SimpleHttpServletResponseEventListener.resetBuffer(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。
boolean | SimpleHttpServletResponseEventListener.isCommitted(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスがすでにコミットされたかどうかを示す boolean を返します。
void | SimpleHttpServletResponseEventListener.reset(HttpServletRequest request, ExtendedHttpServletResponse response) バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。
void | SimpleHttpServletResponseEventListener.setLocale(HttpServletRequest request, ExtendedHttpServletResponse response, Locale loc) レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。
Locale | SimpleHttpServletResponseEventListener.getLocale(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスに設定されているロケールを返します。
void | SimpleHttpServletResponseEventListener.addCookie(HttpServletRequest request, ExtendedHttpServletResponse response, Cookie cookie) 指定されたCookieをレスポンスに追加します。
boolean | SimpleHttpServletResponseEventListener.containsHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name) 指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。
String | SimpleHttpServletResponseEventListener.encodeURL(HttpServletRequest request, ExtendedHttpServletResponse response, String url) 指定されたURLがセッションIDを含むようにエンコードします。
String | SimpleHttpServletResponseEventListener.encodeRedirectURL(HttpServletRequest request, ExtendedHttpServletResponse response, String url) #sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。
void | SimpleHttpServletResponseEventListener.sendError(HttpServletRequest request, ExtendedHttpServletResponse response, int sc, String msg) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
void | SimpleHttpServletResponseEventListener.sendError(HttpServletRequest request, ExtendedHttpServletResponse response, int sc) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
void | SimpleHttpServletResponseEventListener.sendRedirect(HttpServletRequest request, ExtendedHttpServletResponse response, String location) 指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。
void | SimpleHttpServletResponseEventListener.setDateHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。
void | SimpleHttpServletResponseEventListener.addDateHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。
void | SimpleHttpServletResponseEventListener.setHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを設定します。
void | SimpleHttpServletResponseEventListener.addHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを追加します。
void | SimpleHttpServletResponseEventListener.setIntHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを設定します。
void | SimpleHttpServletResponseEventListener.addIntHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを追加します。
void | SimpleHttpServletResponseEventListener.setStatus(HttpServletRequest request, ExtendedHttpServletResponse response, int sc) このレスポンスのステータスコードを設定します。
boolean | HttpServletResponseEventValidator.isValid(HttpServletRequest request, ExtendedHttpServletResponse response) イベントリスナを動作させるかどうかの意思決定をします。
String | HttpServletResponseEventListener.getCharacterEncoding(HttpServletRequest request, ExtendedHttpServletResponse response) このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。
ServletOutputStream | HttpServletResponseEventListener.getOutputStream(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。
PrintWriter | HttpServletResponseEventListener.getWriter(HttpServletRequest request, ExtendedHttpServletResponse response) 文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。
void | HttpServletResponseEventListener.setContentLength(HttpServletRequest request, ExtendedHttpServletResponse response, int len) レスポンスのメッセージボディ部分の長さをセットします。
void | HttpServletResponseEventListener.setContentType(HttpServletRequest request, ExtendedHttpServletResponse response, String type) クライアントに送り返されるレスポンスのコンテントタイプをセットします。
void | HttpServletResponseEventListener.setBufferSize(HttpServletRequest request, ExtendedHttpServletResponse response, int size) 適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。
int | HttpServletResponseEventListener.getBufferSize(HttpServletRequest request, ExtendedHttpServletResponse response) このレスポンスに設定されている実バッファサイズを返します。
void | HttpServletResponseEventListener.flushBuffer(HttpServletRequest request, ExtendedHttpServletResponse response) バッファリングされているコンテンツを強制的にクライアントに出力します。
void | HttpServletResponseEventListener.resetBuffer(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。
boolean | HttpServletResponseEventListener.isCommitted(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスがすでにコミットされたかどうかを示す boolean を返します。
void | HttpServletResponseEventListener.reset(HttpServletRequest request, ExtendedHttpServletResponse response) バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。
void | HttpServletResponseEventListener.setLocale(HttpServletRequest request, ExtendedHttpServletResponse response, Locale loc) レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。
Locale | HttpServletResponseEventListener.getLocale(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスに設定されているロケールを返します。
void | HttpServletResponseEventListener.addCookie(HttpServletRequest request, ExtendedHttpServletResponse response, Cookie cookie) 指定されたCookieをレスポンスに追加します。
boolean | HttpServletResponseEventListener.containsHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name) 指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。
String | HttpServletResponseEventListener.encodeURL(HttpServletRequest request, ExtendedHttpServletResponse response, String url) 指定されたURLがセッションIDを含むようにエンコードします。
String | HttpServletResponseEventListener.encodeRedirectURL(HttpServletRequest request, ExtendedHttpServletResponse response, String url) #sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。
void | HttpServletResponseEventListener.sendError(HttpServletRequest request, ExtendedHttpServletResponse response, int sc, String msg) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
void | HttpServletResponseEventListener.sendError(HttpServletRequest request, ExtendedHttpServletResponse response, int sc) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
void | HttpServletResponseEventListener.sendRedirect(HttpServletRequest request, ExtendedHttpServletResponse response, String location) 指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。
void | HttpServletResponseEventListener.setDateHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。
void | HttpServletResponseEventListener.addDateHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。
void | HttpServletResponseEventListener.setHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを設定します。
void | HttpServletResponseEventListener.addHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを追加します。
void | HttpServletResponseEventListener.setIntHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを設定します。
void | HttpServletResponseEventListener.addIntHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを追加します。
void | HttpServletResponseEventListener.setStatus(HttpServletRequest request, ExtendedHttpServletResponse response, int sc) このレスポンスのステータスコードを設定します。
HttpServletResponseEventController | HttpServletResponseEventControllerBuilder.createController(HttpServletRequest request, ExtendedHttpServletResponse response, HttpServletResponseEventListener listener) コントローラを返します。
abstract String | AbstractHttpServletResponseEventListener.getCharacterEncoding(HttpServletRequest request, ExtendedHttpServletResponse response) このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。
abstract ServletOutputStream | AbstractHttpServletResponseEventListener.getOutputStream(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。
abstract PrintWriter | AbstractHttpServletResponseEventListener.getWriter(HttpServletRequest request, ExtendedHttpServletResponse response) 文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。
abstract void | AbstractHttpServletResponseEventListener.setContentLength(HttpServletRequest request, ExtendedHttpServletResponse response, int len) レスポンスのメッセージボディ部分の長さをセットします。
abstract void | AbstractHttpServletResponseEventListener.setContentType(HttpServletRequest request, ExtendedHttpServletResponse response, String type) クライアントに送り返されるレスポンスのコンテントタイプをセットします。
abstract void | AbstractHttpServletResponseEventListener.setBufferSize(HttpServletRequest request, ExtendedHttpServletResponse response, int size) 適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。
abstract int | AbstractHttpServletResponseEventListener.getBufferSize(HttpServletRequest request, ExtendedHttpServletResponse response) このレスポンスに設定されている実バッファサイズを返します。
abstract void | AbstractHttpServletResponseEventListener.flushBuffer(HttpServletRequest request, ExtendedHttpServletResponse response) バッファリングされているコンテンツを強制的にクライアントに出力します。
abstract void | AbstractHttpServletResponseEventListener.resetBuffer(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。
abstract boolean | AbstractHttpServletResponseEventListener.isCommitted(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスがすでにコミットされたかどうかを示す boolean を返します。
abstract void | AbstractHttpServletResponseEventListener.reset(HttpServletRequest request, ExtendedHttpServletResponse response) バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。
abstract void | AbstractHttpServletResponseEventListener.setLocale(HttpServletRequest request, ExtendedHttpServletResponse response, Locale loc) レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。
abstract Locale | AbstractHttpServletResponseEventListener.getLocale(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスに設定されているロケールを返します。
abstract void | AbstractHttpServletResponseEventListener.addCookie(HttpServletRequest request, ExtendedHttpServletResponse response, Cookie cookie) 指定されたCookieをレスポンスに追加します。
abstract boolean | AbstractHttpServletResponseEventListener.containsHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name) 指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。
abstract String | AbstractHttpServletResponseEventListener.encodeURL(HttpServletRequest request, ExtendedHttpServletResponse response, String url) 指定されたURLがセッションIDを含むようにエンコードします。
abstract String | AbstractHttpServletResponseEventListener.encodeRedirectURL(HttpServletRequest request, ExtendedHttpServletResponse response, String url) #sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。
abstract void | AbstractHttpServletResponseEventListener.sendError(HttpServletRequest request, ExtendedHttpServletResponse response, int sc, String msg) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
abstract void | AbstractHttpServletResponseEventListener.sendError(HttpServletRequest request, ExtendedHttpServletResponse response, int sc) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
abstract void | AbstractHttpServletResponseEventListener.sendRedirect(HttpServletRequest request, ExtendedHttpServletResponse response, String location) 指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。
abstract void | AbstractHttpServletResponseEventListener.setDateHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。
abstract void | AbstractHttpServletResponseEventListener.addDateHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。
abstract void | AbstractHttpServletResponseEventListener.setHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを設定します。
abstract void | AbstractHttpServletResponseEventListener.addHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを追加します。
abstract void | AbstractHttpServletResponseEventListener.setIntHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを設定します。
abstract void | AbstractHttpServletResponseEventListener.addIntHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを追加します。
abstract void | AbstractHttpServletResponseEventListener.setStatus(HttpServletRequest request, ExtendedHttpServletResponse response, int sc) このレスポンスのステータスコードを設定します。
Locale | AbstractHttpServletResponseEventController.getLocale(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスに設定されているロケールを返します。

ExtendedHttpServletResponse 型のパラメータを持つ jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のコンストラクタ
AbstractHttpServletResponseEventController(ExtendedHttpServletResponse response)
新しいインスタンスを生成します。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http での ExtendedHttpServletResponse の使用

ExtendedHttpServletResponse を実装している jp.co.intra_mart.common.aid.jsdk.javax.servlet.http のクラス
class | ExtendedHttpServletResponseWrapper レスポンスのサプクラス化による拡張を可能とする ExtendedHttpServletResponse インタフェースの簡潔な実装方法を提供します。
class | SearchableHttpServletResponseWrapper HttpServletResponseWrapperの拡張実装を提供します。

ExtendedHttpServletResponse を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.http のメソッド
 ExtendedHttpServletResponse ExtendedHttpServletResponseWrapper.getExtendedHttpServletResponse()
このオブジェクトにラップされているレスポンスを返します。

ExtendedHttpServletResponse 型のパラメータを持つ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http のコンストラクタ
ExtendedHttpServletResponseWrapper(ExtendedHttpServletResponse response)
指定したレスポンスをラッピングしたレスポンス・アダプタを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper の使用

ExtendedHttpServletResponseWrapper を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での ExtendedHttpServletResponseWrapper の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での ExtendedHttpServletResponseWrapper のサブクラス
 class AbstractHttpServletResponseEventController
イベントを制御するレスポンスの抽象実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext の使用

HTTPContext を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http での HTTPContext の使用

HTTPContext を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.http のメソッド
abstract HTTPContext | HTTPContextManager.getCurrentContext() 現在のスレッドに関連付けられた HTTP コンテキストを返します。
abstract HTTPContext[] | HTTPContextManager.getAllContext() マネージャーが保持するすべての HTTP コンテキストを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager の使用

HTTPContextManager を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http での HTTPContextManager の使用

HTTPContextManager を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.http のメソッド
static HTTPContextManager HTTPContextManager.getInstance()
HTTP コンテキスト・マネージャのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager の使用

HttpSessionManager を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session での HttpSessionManager の使用

HttpSessionManager を実装している jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session のクラス
 class AbstractHttpSessionManager
インタフェース HttpSessionManager の抽象実装です。

HttpSessionManager を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session のメソッド
abstract  HttpSessionManager HttpSessionManagerFactory.getManager()
マネージャを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory の使用

HttpSessionManagerFactory を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session での HttpSessionManagerFactory の使用

HttpSessionManagerFactory を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session のメソッド
static HttpSessionManagerFactory HttpSessionManagerFactory.getInstance()
インスタンスを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException の使用

NoSuchSessionException を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session での NoSuchSessionException の使用

NoSuchSessionException をスローする jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session のメソッド
long | HttpSessionManager.getCreationTime(String id) 指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。
long | HttpSessionManager.getLastAccessedTime(String id) 指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。
int | HttpSessionManager.getMaxInactiveInterval(String id) 指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。
abstract long | AbstractHttpSessionManager.getCreationTime(String id) 指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。
abstract long | AbstractHttpSessionManager.getLastAccessedTime(String id) 指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。
abstract int | AbstractHttpSessionManager.getMaxInactiveInterval(String id) 指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AbstractHttpSessionManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
クラス AbstractHttpSessionManager

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager
すべての実装インタフェース:
HttpSessionManager
public abstract class AbstractHttpSessionManager
extends Object
implements HttpSessionManager

インタフェース HttpSessionManager の抽象実装です。 インタフェースを実装するクラスは、この抽象実装を継承すると便利です。

導入されたバージョン:
version 5.0

コンストラクタの概要
protected AbstractHttpSessionManager()
HttpSessionManager の抽象実装を構築します。
メソッドの概要
abstract String[] | getAllIds() 現在有効なすべての HttpSession のセッションＩＤを返します。
abstract long | getCreationTime(String id) 指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。
abstract long | getLastAccessedTime(String id) 指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。
int | getLength() 現在有効な HttpSession の数を返します。
abstract int | getMaxInactiveInterval(String id) 指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager から継承したメソッド
getCount

コンストラクタの詳細

AbstractHttpSessionManager

protected AbstractHttpSessionManager()
HttpSessionManager の抽象実装を構築します。

メソッドの詳細

getLength

public int getLength()
現在有効な HttpSession の数を返します。

戻り値:
有効な HttpSession の個数

getAllIds

public abstract String[] getAllIds()
現在有効なすべての HttpSession のセッションＩＤを返します。 セッションＩＤは、HttpSession.getId() が 返す値です。

定義:
インタフェース HttpSessionManager 内の getAllIds
戻り値:
セッションＩＤの配列

getCreationTime

public abstract long getCreationTime(String id)
                              throws NoSuchSessionException,
                                     UnsupportedOperationException
指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。（任意のオペレーション） このメソッドが返す値は、 HttpSession.getCreationTime() が返す値です。

指定のＩＤに関連付けられている有効なＨＴＴＰセッションがない場合、 NoSuchSessionException をスローします。

このインタフェースの実装が、このメソッドをサポートしない場合、 UnsupportedOperationException をスローします。

定義:
インタフェース HttpSessionManager 内の getCreationTime
パラメータ:
id - セッションＩＤ
戻り値:
セッションが作成された時刻
例外:
NoSuchSessionException - 指定のＩＤに関連付けられた有効なセッションを見つけられなかった場合
UnsupportedOperationException - このメソッドがサポートされない場合

getLastAccessedTime

public abstract long getLastAccessedTime(String id)
                                  throws NoSuchSessionException,
                                         UnsupportedOperationException
指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。（任意のオペレーション） このメソッドが返す値は、 HttpSession.getLastAccessedTime() が返す値です。

指定のＩＤに関連付けられている有効なＨＴＴＰセッションがない場合、 NoSuchSessionException をスローします。

このインタフェースの実装が、このメソッドをサポートしない場合、 UnsupportedOperationException をスローします。

定義:
インタフェース HttpSessionManager 内の getLastAccessedTime
パラメータ:
id - セッションＩＤ
戻り値:
セッションに対して最後にアクセスした時刻
例外:
NoSuchSessionException - 指定のＩＤに関連付けられた有効なセッションを見つけられなかった場合
UnsupportedOperationException - このメソッドがサポートされない場合

getMaxInactiveInterval

public abstract int getMaxInactiveInterval(String id)
                                    throws NoSuchSessionException,
                                           UnsupportedOperationException
指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。（任意のオペレーション） このメソッドが返す値は、 HttpSession.getMaxInactiveInterval() が返す値です。

指定のＩＤに関連付けられている有効なＨＴＴＰセッションがない場合、 NoSuchSessionException をスローします。

このインタフェースの実装が、このメソッドをサポートしない場合、 UnsupportedOperationException をスローします。

定義:
インタフェース HttpSessionManager 内の getMaxInactiveInterval
パラメータ:
id - セッションＩＤ
戻り値:
クライアントからのリクエストの間に何秒間セッションを持続するかを表す数値
例外:
NoSuchSessionException - 指定のＩＤに関連付けられた有効なセッションを見つけられなかった場合
UnsupportedOperationException - このメソッドがサポートされない場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HttpSessionManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
インタフェース HttpSessionManager

既知の実装クラスの一覧:
AbstractHttpSessionManager
public interface HttpSessionManager

HttpSession に関する情報を提供するクラスの共通インタフェース定義です。

導入されたバージョン:
version 5.0

メソッドの概要
String[] | getAllIds() 現在有効なすべての HttpSession のセッションＩＤを返します。
int | getCount() 現在有効な HttpSession の数を返します。
long | getCreationTime(String id) 指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。
long | getLastAccessedTime(String id) 指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。
int | getMaxInactiveInterval(String id) 指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。

メソッドの詳細

getCount

public int getCount()
現在有効な HttpSession の数を返します。

戻り値:
有効な HttpSession の個数

getAllIds

public String[] getAllIds()
現在有効なすべての HttpSession のセッションＩＤを返します。 セッションＩＤは、HttpSession.getId() が 返す値です。

戻り値:
セッションＩＤの配列

getCreationTime

public long getCreationTime(String id)
                     throws NoSuchSessionException,
                            UnsupportedOperationException
指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。（任意のオペレーション） このメソッドが返す値は、 HttpSession.getCreationTime() が返す値です。

指定のＩＤに関連付けられている有効なＨＴＴＰセッションがない場合、 NoSuchSessionException をスローします。

このインタフェースの実装が、このメソッドをサポートしない場合、 UnsupportedOperationException をスローします。

パラメータ:
id - セッションＩＤ
戻り値:
セッションが作成された時刻
例外:
NoSuchSessionException - 指定のＩＤに関連付けられた有効なセッションを見つけられなかった場合
UnsupportedOperationException - このメソッドがサポートされない場合

getLastAccessedTime

public long getLastAccessedTime(String id)
                         throws NoSuchSessionException,
                                UnsupportedOperationException
指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。（任意のオペレーション） このメソッドが返す値は、 HttpSession.getLastAccessedTime() が返す値です。

指定のＩＤに関連付けられている有効なＨＴＴＰセッションがない場合、 NoSuchSessionException をスローします。

このインタフェースの実装が、このメソッドをサポートしない場合、 UnsupportedOperationException をスローします。

パラメータ:
id - セッションＩＤ
戻り値:
セッションに対して最後にアクセスした時刻
例外:
NoSuchSessionException - 指定のＩＤに関連付けられた有効なセッションを見つけられなかった場合
UnsupportedOperationException - このメソッドがサポートされない場合

getMaxInactiveInterval

public int getMaxInactiveInterval(String id)
                           throws NoSuchSessionException,
                                  UnsupportedOperationException
指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。（任意のオペレーション） このメソッドが返す値は、 HttpSession.getMaxInactiveInterval() が返す値です。

指定のＩＤに関連付けられている有効なＨＴＴＰセッションがない場合、 NoSuchSessionException をスローします。

このインタフェースの実装が、このメソッドをサポートしない場合、 UnsupportedOperationException をスローします。

パラメータ:
id - セッションＩＤ
戻り値:
クライアントからのリクエストの間に何秒間セッションを持続するかを表す数値
例外:
NoSuchSessionException - 指定のＩＤに関連付けられた有効なセッションを見つけられなかった場合
UnsupportedOperationException - このメソッドがサポートされない場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HttpSessionManagerFactory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
クラス HttpSessionManagerFactory

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory
public abstract class HttpSessionManagerFactory
extends Object

HttpSessionManager を作成するファクトリクラスの抽象実装です。

導入されたバージョン:
version 5.0

コンストラクタの概要
protected HttpSessionManagerFactory()
新しい HttpSessionManagerFactory を構築します。
メソッドの概要
static HttpSessionManagerFactory | getInstance() インスタンスを返します。
abstract HttpSessionManager | getManager() マネージャを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HttpSessionManagerFactory

protected HttpSessionManagerFactory()
新しい HttpSessionManagerFactory を構築します。

メソッドの詳細

getInstance

public static HttpSessionManagerFactory getInstance()
インスタンスを返します。
このメソッドが返すファクトリは、システムに標準実装されているものです。 独自実装を利用する場合は、このクラスを継承して新しいサブクラスを 作成してください。

戻り値:
ファクトリオブジェクトを返します。

getManager

public abstract HttpSessionManager getManager()
マネージャを返します。

戻り値:
マネージャ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpSessionMonitoringFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
クラス HttpSessionMonitoringFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter
すべての実装インタフェース:
Filter
public class HttpSessionMonitoringFilter
extends AbstractFilter

HttpSessionManagerFactory#instance() が返す、 HttpSessionManagerFactory および HttpSessionManager の 標準実装と連動するフィルタです。 このフィルタを設定し動作させる事で、HttpSessionManager の標準実装が 正しい値を返します。

導入されたバージョン:
version 5.0

コンストラクタの概要
HttpSessionMonitoringFilter()
新しい HttpSessionMonitoringFilter を構築します。
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタとして動作するロジック。
protected void | handleDestroy() フィルタの破棄処理。
protected void | handleInit() フィルタの初期化をします。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HttpSessionMonitoringFilter

public HttpSessionMonitoringFilter()
新しい HttpSessionMonitoringFilter を構築します。

メソッドの詳細

handleInit

protected void handleInit()
                   throws ServletException
フィルタの初期化をします。

このメソッドは、フィルタ初期化時に AbstractFilter.init(FilterConfig) に 呼び出されます。
このメソッドは何もしません。ただリターンするだけです。

サブクラスが初期化処理を必要とする場合は、 このメソッドをオーバーライドして初期化処理を実装してください。

オーバーライド:
クラス AbstractFilter 内の handleInit
例外:
ServletException - 初期化エラー
関連項目:
AbstractFilter.init(FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
ServletException - 実行時エラー
IOException - 入出力エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)

handleDestroy

protected void handleDestroy()
フィルタの破棄処理。

このメソッドは、フィルタ破棄時に AbstractFilter.destroy() に 呼び出されます。
このメソッドは何もしません。ただリターンするだけです。

サブクラスが破棄処理を必要とする場合は、 このメソッドをオーバーライドして破棄処理を実装してください。

オーバーライド:
クラス AbstractFilter 内の handleDestroy
関連項目:
AbstractFilter.destroy()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpSessionMonitoringListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
クラス HttpSessionMonitoringListener

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener
すべての実装インタフェース:
EventListener, HttpSessionListener
public class HttpSessionMonitoringListener
extends Object
implements HttpSessionListener

HttpSessionManagerFactory#instance() が返す、 HttpSessionManagerFactory および HttpSessionManager の 標準実装と連動するセッションリスナです。 このリスナを設定し動作させる事で、HttpSessionManager の標準実装が 正しい値を返します。

導入されたバージョン:
version 5.0

コンストラクタの概要
HttpSessionMonitoringListener()
新しいセッションリスナを構築します。
メソッドの概要
void | sessionCreated(HttpSessionEvent se) セッションが作成されたことを通知します。
void | sessionDestroyed(HttpSessionEvent se) セッションが無効になったことを通知します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HttpSessionMonitoringListener

public HttpSessionMonitoringListener()
新しいセッションリスナを構築します。

メソッドの詳細

sessionCreated

public void sessionCreated(HttpSessionEvent se)
セッションが作成されたことを通知します。

定義:
インタフェース HttpSessionListener 内の sessionCreated
パラメータ:
se - 通知するイベント

sessionDestroyed

public void sessionDestroyed(HttpSessionEvent se)
セッションが無効になったことを通知します。

定義:
インタフェース HttpSessionListener 内の sessionDestroyed
パラメータ:
se - 通知するイベント
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


NoSuchSessionException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
クラス NoSuchSessionException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException
すべての実装インタフェース:
Serializable
public class NoSuchSessionException
extends Exception

特定のＨＴＴＰセッションが見つからない場合にスローされます。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
NoSuchSessionException()
詳細メッセージを持たない NoSuchSessionException を構築します。
NoSuchSessionException(String message)
詳細メッセージを持つ NoSuchSessionException を構築します。
NoSuchSessionException(String message, Throwable cause)
指定された詳細メッセージおよび原因を使用して新しい NoSuchSessionException を構築します。
NoSuchSessionException(Throwable cause)
指定された原因を使用して新しい NoSuchSessionException を構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NoSuchSessionException

public NoSuchSessionException()
詳細メッセージを持たない NoSuchSessionException を構築します。

NoSuchSessionException

public NoSuchSessionException(String message)
詳細メッセージを持つ NoSuchSessionException を構築します。

パラメータ:
message - 詳細メッセージ

NoSuchSessionException

public NoSuchSessionException(String message,
                              Throwable cause)
指定された詳細メッセージおよび原因を使用して新しい NoSuchSessionException を構築します。

パラメータ:
message - 詳細メッセージ
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す

NoSuchSessionException

public NoSuchSessionException(Throwable cause)
指定された原因を使用して新しい NoSuchSessionException を構築します。

パラメータ:
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
インタフェース
HttpSessionManager
クラス
AbstractHttpSessionManager
HttpSessionManagerFactory
HttpSessionMonitoringFilter
HttpSessionMonitoringListener
例外
NoSuchSessionException


jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session

このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。

参照:
説明

インタフェースの概要
HttpSessionManager HttpSession に関する情報を提供するクラスの共通インタフェース定義です。

クラスの概要
AbstractHttpSessionManager | インタフェース HttpSessionManager の抽象実装です。
HttpSessionManagerFactory | HttpSessionManager を作成するファクトリクラスの抽象実装です。
HttpSessionMonitoringFilter | HttpSessionManagerFactory#instance() が返す、 HttpSessionManagerFactory および HttpSessionManager の 標準実装と連動するフィルタです。
HttpSessionMonitoringListener | HttpSessionManagerFactory#instance() が返す、 HttpSessionManagerFactory および HttpSessionManager の 標準実装と連動するセッションリスナです。

例外の概要
NoSuchSessionException 特定のＨＴＴＰセッションが見つからない場合にスローされます。

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session の説明

このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。


jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter (implements javax.servlet.Filter)
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager)
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener (implements javax.servlet.http.HttpSessionListener)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException

インタフェース階層

  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager


パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session のクラス
HttpSessionManager
HttpSession に関する情報を提供するクラスの共通インタフェース定義です。
HttpSessionManagerFactory
HttpSessionManager を作成するファクトリクラスの抽象実装です。
NoSuchSessionException
特定のＨＴＴＰセッションが見つからない場合にスローされます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ExtendedHttpServletResponse (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http
インタフェース ExtendedHttpServletResponse

すべてのスーパーインタフェース:
ExtendedServletResponse, HttpServletResponse, ServletResponse
既知のサブインタフェースの一覧:
HttpServletResponseEventController
既知の実装クラスの一覧:
AbstractHttpServletResponseEventController, ExtendedHttpServletResponseWrapper, SearchableHttpServletResponseWrapper
public interface ExtendedHttpServletResponse
extends ExtendedServletResponse, HttpServletResponse

このインタフェースは、HttpServletResponseを拡張したものです。

導入されたバージョン:
version 6.0

フィールドの概要
インタフェース javax.servlet.http.HttpServletResponse から継承したフィールド
SC_ACCEPTED, SC_BAD_GATEWAY, SC_BAD_REQUEST, SC_CONFLICT, SC_CONTINUE, SC_CREATED, SC_EXPECTATION_FAILED, SC_FORBIDDEN, SC_GATEWAY_TIMEOUT, SC_GONE, SC_HTTP_VERSION_NOT_SUPPORTED, SC_INTERNAL_SERVER_ERROR, SC_LENGTH_REQUIRED, SC_METHOD_NOT_ALLOWED, SC_MOVED_PERMANENTLY, SC_MOVED_TEMPORARILY, SC_MULTIPLE_CHOICES, SC_NO_CONTENT, SC_NON_AUTHORITATIVE_INFORMATION, SC_NOT_ACCEPTABLE, SC_NOT_FOUND, SC_NOT_IMPLEMENTED, SC_NOT_MODIFIED, SC_OK, SC_PARTIAL_CONTENT, SC_PAYMENT_REQUIRED, SC_PRECONDITION_FAILED, SC_PROXY_AUTHENTICATION_REQUIRED, SC_REQUEST_ENTITY_TOO_LARGE, SC_REQUEST_TIMEOUT, SC_REQUEST_URI_TOO_LONG, SC_REQUESTED_RANGE_NOT_SATISFIABLE, SC_RESET_CONTENT, SC_SEE_OTHER, SC_SERVICE_UNAVAILABLE, SC_SWITCHING_PROTOCOLS, SC_TEMPORARY_REDIRECT, SC_UNAUTHORIZED, SC_UNSUPPORTED_MEDIA_TYPE, SC_USE_PROXY
メソッドの概要
Cookie[] | getCookies() このレスポンスにセットされたすべての Cookie を返します。
Long | getDateHeader(String name) 指定された名称でレスポンスヘッダに設定されている日付の値を返します。
long[] | getDateHeaders(String name) 指定された名称でレスポンスヘッダに設定されている全ての日付の値を返します。
Object | getHeader(String name) 指定された名称でレスポンスヘッダに設定されている値を返します。
Object[] | getHeaders(String name) 指定された名称でレスポンスヘッダに設定されている全ての値を返します。
Integer | getIntHeader(String name) 指定された名称でレスポンスヘッダに設定されている数値を返します。
int[] | getIntHeaders(String name) 指定された名称でレスポンスヘッダに設定されている全ての数値を返します。
Integer | getStatus() レスポンスにセットされている ステータスコードを返します。
String | getStringHeader(String name) 指定された名称でレスポンスヘッダに設定されている文字列の値を返します。
String[] | getStringHeaders(String name) 指定された名称でレスポンスヘッダに設定されている全ての文字列の値を返します。
インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse から継承したメソッド
getContentLength, getContentType, setContentType
インタフェース javax.servlet.ServletResponse から継承したメソッド
flushBuffer, getBufferSize, getCharacterEncoding, getLocale, getOutputStream, getWriter, isCommitted, reset, resetBuffer, setBufferSize, setContentLength, setContentType, setLocale
インタフェース javax.servlet.http.HttpServletResponse から継承したメソッド
addCookie, addDateHeader, addHeader, addIntHeader, containsHeader, encodeRedirectUrl, encodeRedirectURL, encodeUrl, encodeURL, sendError, sendError, sendRedirect, setDateHeader, setHeader, setIntHeader, setStatus, setStatus

メソッドの詳細

getStatus

public Integer getStatus()
レスポンスにセットされている ステータスコードを返します。
このメソッドは、 HttpServletResponse.sendRedirect(String location)、 HttpServletResponse.sendError(int sc)、 HttpServletResponse.sendError(int sc, String msg)、 HttpServletResponse.setStatus(int sc)、 またはHttpServletResponse.setStatus(int sc, String sm) によってセットされたステータスコードを返します。 値を未設定の場合、null を返します。

戻り値:
ステータスコード

getIntHeader

public Integer getIntHeader(String name)
指定された名称でレスポンスヘッダに設定されている数値を返します。 このヘッダに対して数値を未設定の場合、null を返します。

パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている整数値

getIntHeaders

public int[] getIntHeaders(String name)
指定された名称でレスポンスヘッダに設定されている全ての数値を返します。 このヘッダに対して値を未設定の場合、null を返します。 このヘッダに対して数値を未設定の場合、空の配列を返します。

パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている全ての整数値

getDateHeader

public Long getDateHeader(String name)
指定された名称でレスポンスヘッダに設定されている日付の値を返します。 このヘッダに対して日付の値を未設定の場合、null を返します。

パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている日付の値

getDateHeaders

public long[] getDateHeaders(String name)
指定された名称でレスポンスヘッダに設定されている全ての日付の値を返します。 このヘッダに対して値を未設定の場合、null を返します。 このヘッダに対して日付の値を未設定の場合、空の配列を返します。

パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている全ての日付の値

getStringHeader

public String getStringHeader(String name)
指定された名称でレスポンスヘッダに設定されている文字列の値を返します。 このヘッダに対して文字列の値を未設定の場合、null を返します。

パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている文字列の値

getStringHeaders

public String[] getStringHeaders(String name)
指定された名称でレスポンスヘッダに設定されている全ての文字列の値を返します。 このヘッダに対して値を未設定の場合、null を返します。 このヘッダに対して文字列の値を未設定の場合、空の配列を返します。

パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている全ての文字列の値

getHeader

public Object getHeader(String name)
指定された名称でレスポンスヘッダに設定されている値を返します。 ヘッダをセットするために利用したメソッドにより、 返り値の型が決定されます。
メソッド 返り値の型
HttpServletResponse.addDateHeader(String name, long date) Long
HttpServletResponse.setDateHeader(String name, long date) Long
HttpServletResponse.addIntHeader(String name, int value) Integer
HttpServletResponse.setIntHeader(String name, int value) Integer
HttpServletResponse.addHeader(String name, String value) String
HttpServletResponse.setHeader(String name, String value) String
このヘッダが未設定の場合、null を返します。

パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている値

getHeaders

public Object[] getHeaders(String name)
指定された名称でレスポンスヘッダに設定されている全ての値を返します。 配列の各要素の型は、getHeader(String)の返り値と同様です。 このヘッダが未設定の場合、null を返します。

パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている全ての値

getCookies

public Cookie[] getCookies()
このレスポンスにセットされたすべての Cookie を返します。 Cookie を未設定の場合、null を返します。

戻り値:
セットされている全ての Cookie
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedHttpServletResponseWrapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http
クラス ExtendedHttpServletResponseWrapper

java.lang.Object
    拡張 javax.servlet.ServletResponseWrapper
        拡張 javax.servlet.http.HttpServletResponseWrapper
            拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper
すべての実装インタフェース:
ExtendedHttpServletResponse, ExtendedServletResponse, HttpServletResponse, ServletResponse
直系の既知のサブクラス:
AbstractHttpServletResponseEventController
public class ExtendedHttpServletResponseWrapper
extends HttpServletResponseWrapper
implements ExtendedHttpServletResponse

レスポンスのサプクラス化による拡張を可能とする ExtendedHttpServletResponse インタフェースの簡潔な実装方法を提供します。
このクラスは、WrapperパターンもしくはDecoratorパターンに基づいて 実装されています。 各々のメソッドは、ラップされたレスポンスオブジェクトのメソッドを デフォルトで呼び出します。

導入されたバージョン:
version 6.0

フィールドの概要
インタフェース javax.servlet.http.HttpServletResponse から継承したフィールド
SC_ACCEPTED, SC_BAD_GATEWAY, SC_BAD_REQUEST, SC_CONFLICT, SC_CONTINUE, SC_CREATED, SC_EXPECTATION_FAILED, SC_FORBIDDEN, SC_GATEWAY_TIMEOUT, SC_GONE, SC_HTTP_VERSION_NOT_SUPPORTED, SC_INTERNAL_SERVER_ERROR, SC_LENGTH_REQUIRED, SC_METHOD_NOT_ALLOWED, SC_MOVED_PERMANENTLY, SC_MOVED_TEMPORARILY, SC_MULTIPLE_CHOICES, SC_NO_CONTENT, SC_NON_AUTHORITATIVE_INFORMATION, SC_NOT_ACCEPTABLE, SC_NOT_FOUND, SC_NOT_IMPLEMENTED, SC_NOT_MODIFIED, SC_OK, SC_PARTIAL_CONTENT, SC_PAYMENT_REQUIRED, SC_PRECONDITION_FAILED, SC_PROXY_AUTHENTICATION_REQUIRED, SC_REQUEST_ENTITY_TOO_LARGE, SC_REQUEST_TIMEOUT, SC_REQUEST_URI_TOO_LONG, SC_REQUESTED_RANGE_NOT_SATISFIABLE, SC_RESET_CONTENT, SC_SEE_OTHER, SC_SERVICE_UNAVAILABLE, SC_SWITCHING_PROTOCOLS, SC_TEMPORARY_REDIRECT, SC_UNAUTHORIZED, SC_UNSUPPORTED_MEDIA_TYPE, SC_USE_PROXY
コンストラクタの概要
protected ExtendedHttpServletResponseWrapper(ExtendedHttpServletResponse response)
指定したレスポンスをラッピングしたレスポンス・アダプタを構築します。
メソッドの概要
 Integer getContentLength()
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedServletResponse#getContentLength() メソッドをそのまま呼び出します。
 ContentType getContentType()
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedServletResponse#getContentType() メソッドをそのまま呼び出します。
 Cookie[] getCookies()
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getCookies() メソッドをそのまま呼び出します。
 Long getDateHeader(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getDateHeader(String) メソッドをそのまま呼び出します。
 long[] getDateHeaders(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getDateHeaders(String) メソッドをそのまま呼び出します。
 ExtendedHttpServletResponse getExtendedHttpServletResponse()
このオブジェクトにラップされているレスポンスを返します。
 Object getHeader(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getHeader(String) メソッドをそのまま呼び出します。
 Object[] getHeaders(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getHeaders(String) メソッドをそのまま呼び出します。
 Integer getIntHeader(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getIntHeader(String) メソッドをそのまま呼び出します。
 int[] getIntHeaders(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getIntHeaders(String) メソッドをそのまま呼び出します。
 Integer getStatus()
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse#getStatus(String) メソッドをそのまま呼び出します。
 String getStringHeader(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getStringHeader(String) メソッドをそのまま呼び出します。
 String[] getStringHeaders(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getStringHeaders(String) メソッドをそのまま呼び出します。
 void setContentType(ContentType type)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedServletResponse#setContentType(ContentType) メソッドをそのまま呼び出します。
クラス javax.servlet.http.HttpServletResponseWrapper から継承したメソッド
addCookie, addDateHeader, addHeader, addIntHeader, containsHeader, encodeRedirectUrl, encodeRedirectURL, encodeUrl, encodeURL, sendError, sendError, sendRedirect, setDateHeader, setHeader, setIntHeader, setStatus, setStatus
クラス javax.servlet.ServletResponseWrapper から継承したメソッド
flushBuffer, getBufferSize, getCharacterEncoding, getLocale, getOutputStream, getResponse, getWriter, isCommitted, reset, resetBuffer, setBufferSize, setContentLength, setContentType, setLocale, setResponse
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.ServletResponse から継承したメソッド
flushBuffer, getBufferSize, getCharacterEncoding, getLocale, getOutputStream, getWriter, isCommitted, reset, resetBuffer, setBufferSize, setContentLength, setContentType, setLocale
インタフェース javax.servlet.http.HttpServletResponse から継承したメソッド
addCookie, addDateHeader, addHeader, addIntHeader, containsHeader, encodeRedirectUrl, encodeRedirectURL, encodeUrl, encodeURL, sendError, sendError, sendRedirect, setDateHeader, setHeader, setIntHeader, setStatus, setStatus

コンストラクタの詳細

ExtendedHttpServletResponseWrapper

protected ExtendedHttpServletResponseWrapper(ExtendedHttpServletResponse response)
指定したレスポンスをラッピングしたレスポンス・アダプタを構築します。

パラメータ:
response - ラップ対象となるレスポンス
例外:
IllegalArgumentException - response が null である場合
メソッドの詳細

getStatus

public Integer getStatus()
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse#getStatus(String) メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedHttpServletResponse 内の getStatus
戻り値:
ステータスコード

getIntHeader

public Integer getIntHeader(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getIntHeader(String) メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedHttpServletResponse 内の getIntHeader
パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている整数値

getIntHeaders

public int[] getIntHeaders(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getIntHeaders(String) メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedHttpServletResponse 内の getIntHeaders
パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている全ての整数値

getDateHeader

public Long getDateHeader(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getDateHeader(String) メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedHttpServletResponse 内の getDateHeader
パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている日付の値

getDateHeaders

public long[] getDateHeaders(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getDateHeaders(String) メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedHttpServletResponse 内の getDateHeaders
パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている全ての日付の値

getStringHeader

public String getStringHeader(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getStringHeader(String) メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedHttpServletResponse 内の getStringHeader
パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている文字列の値

getStringHeaders

public String[] getStringHeaders(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getStringHeaders(String) メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedHttpServletResponse 内の getStringHeaders
パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている全ての文字列の値

getHeader

public Object getHeader(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getHeader(String) メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedHttpServletResponse 内の getHeader
パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている値

getHeaders

public Object[] getHeaders(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getHeaders(String) メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedHttpServletResponse 内の getHeaders
パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている全ての値

getCookies

public Cookie[] getCookies()
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getCookies() メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedHttpServletResponse 内の getCookies
戻り値:
セットされている全ての Cookie

getContentType

public ContentType getContentType()
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedServletResponse#getContentType() メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedServletResponse 内の getContentType
戻り値:
コンテントタイプを指定する ContentType

setContentType

public void setContentType(ContentType type)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedServletResponse#setContentType(ContentType) メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedServletResponse 内の setContentType
パラメータ:
type - コンテントタイプを指定する ContentType

getContentLength

public Integer getContentLength()
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedServletResponse#getContentLength() メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedServletResponse 内の getContentLength
戻り値:
クライアントに送り返すメッセージボディの長さを指定する整数値。 HTTP の Content-Length ヘッダフィールドの値

getExtendedHttpServletResponse

public ExtendedHttpServletResponse getExtendedHttpServletResponse()
このオブジェクトにラップされているレスポンスを返します。

戻り値:
ラップされているレスポンス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPContext (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http
インタフェース HTTPContext

public interface HTTPContext

リクエスト、レスポンス、および サーブレットコンテキストへのアクセスを提供します。

メソッドの概要
HttpSession | getCurrentSession() このリクエストに関連づけられている現在のセッションを返します。
HttpServletRequest | getRequest() リクエストを返します。
HttpServletResponse | getResponse() レスポンスを返します。
ServletContext | getServletContext() サーブレットコンテキストを返します。
HttpSession | getSession() このリクエストに関連づけられている現在のセッションを返します。
void | log(String message) Servlet ログファイルに指定されたメッセージを出力します。
void | log(String message, Throwable throwable) 与えられた Throwable 例外の説明となるメッセージとスタックトレースを Servlet のログファイルに出力します。

メソッドの詳細

getServletContext

public ServletContext getServletContext()
サーブレットコンテキストを返します。

戻り値:
サーブレットコンテキスト

getRequest

public HttpServletRequest getRequest()
リクエストを返します。

戻り値:
リクエスト

getResponse

public HttpServletResponse getResponse()
レスポンスを返します。

戻り値:
レスポンス

getSession

public HttpSession getSession()
このリクエストに関連づけられている現在のセッションを返します。 リクエストがセッションを持たない場合はセッションを生成します。

戻り値:
このリクエストに関連づけられているHttpSession

getCurrentSession

public HttpSession getCurrentSession()
このリクエストに関連づけられている現在のセッションを返します。 リクエストが有効なHttpSessionを持たない場合は nullを返します。

戻り値:
このリクエストに関連づけられているHttpSession。リクエストが有効なセッションを持っていなければ null。

log

public void log(String message)
Servlet ログファイルに指定されたメッセージを出力します。

このメソッドは、現在の ServletContext の #log(String) を呼び出します。

パラメータ:
message - ログファイルに出力するメッセージを指定する String
関連項目:
ServletContext.log(String msg)

log

public void log(String message,
                Throwable throwable)
与えられた Throwable 例外の説明となるメッセージとスタックトレースを Servlet のログファイルに出力します。

このメソッドは、現在の ServletContext の #log(String, Throwable) を呼び出します。

パラメータ:
message - エラーや例外を解説する String
throwable - Throwable エラーや例外
関連項目:
ServletContext.log(String message, Throwable throwable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HTTPContextManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http
クラス HTTPContextManager

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager
public abstract class HTTPContextManager
extends Object

HTTP コンテキスト・マネージャ

導入されたバージョン:
version 5.0

コンストラクタの概要
protected HTTPContextManager()
デフォルトコンストラクタ getInstance()を利用してください。
メソッドの概要
abstract HTTPContext[] | getAllContext() マネージャーが保持するすべての HTTP コンテキストを返します。
abstract HTTPContext | getCurrentContext() 現在のスレッドに関連付けられた HTTP コンテキストを返します。
static HTTPContextManager | getInstance() HTTP コンテキスト・マネージャのインスタンスを取得します。
abstract int | getLength() マネージャーが保持する HTTP コンテキストの数を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPContextManager

protected HTTPContextManager()
デフォルトコンストラクタ getInstance()を利用してください。

メソッドの詳細

getInstance

public static HTTPContextManager getInstance()
HTTP コンテキスト・マネージャのインスタンスを取得します。

戻り値:
HTTP コンテキスト・マネージャ

getCurrentContext

public abstract HTTPContext getCurrentContext()
現在のスレッドに関連付けられた HTTP コンテキストを返します。

戻り値:
現在のスレッドに関連付けられた HTTP コンテキスト

getAllContext

public abstract HTTPContext[] getAllContext()
                                     throws UnsupportedOperationException
マネージャーが保持するすべての HTTP コンテキストを返します。

戻り値:
マネージャーが保持するすべての HTTP コンテキストの配列
例外:
UnsupportedOperationException - サブクラスが本メソッドをサポートしていない場合

getLength

public abstract int getLength()
                       throws UnsupportedOperationException
マネージャーが保持する HTTP コンテキストの数を返します。

戻り値:
マネージャーが保持する HTTP コンテキストの数
例外:
UnsupportedOperationException - サブクラスが本メソッドをサポートしていない場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jsdk.javax.servlet.http (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http
インタフェース
ExtendedHttpServletResponse
HTTPContext
クラス
EmptyParameterHttpServletRequestWrapper
ExtendedHttpServletResponseWrapper
HTTPContextManager
SearchableHttpServletResponseWrapper


jp.co.intra_mart.common.aid.jsdk.javax.servlet.http (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http

このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。

参照:
説明

インタフェースの概要
ExtendedHttpServletResponse | このインタフェースは、HttpServletResponseを拡張したものです。
HTTPContext | リクエスト、レスポンス、および サーブレットコンテキストへのアクセスを提供します。

クラスの概要
EmptyParameterHttpServletRequestWrapper | エンプティーリクエストパラメータサーブレットリクエストラッパー。
ExtendedHttpServletResponseWrapper | レスポンスのサプクラス化による拡張を可能とする ExtendedHttpServletResponse インタフェースの簡潔な実装方法を提供します。
HTTPContextManager | HTTP コンテキスト・マネージャ
SearchableHttpServletResponseWrapper | HttpServletResponseWrapperの拡張実装を提供します。

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http の説明

このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。


jp.co.intra_mart.common.aid.jsdk.javax.servlet.http クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager
    • class javax.servlet.ServletRequestWrapper (implements javax.servlet.ServletRequest)
      • class javax.servlet.http.HttpServletRequestWrapper (implements javax.servlet.http.HttpServletRequest)
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.EmptyParameterHttpServletRequestWrapper
    • class javax.servlet.ServletResponseWrapper (implements javax.servlet.ServletResponse)
      • class javax.servlet.http.HttpServletResponseWrapper (implements javax.servlet.http.HttpServletResponse)
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse)
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse)

インタフェース階層

  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext
  • interface javax.servlet.ServletResponse
    • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse
      • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse (同様に extends javax.servlet.http.HttpServletResponse)
    • interface javax.servlet.http.HttpServletResponse
      • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse (同様に extends jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse)


パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter | このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http | このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet.http のクラス
ExtendedHttpServletResponse
このインタフェースは、HttpServletResponseを拡張したものです。
ExtendedHttpServletResponseWrapper
レスポンスのサプクラス化による拡張を可能とする ExtendedHttpServletResponse インタフェースの簡潔な実装方法を提供します。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet.http のクラス
ExtendedHttpServletResponse
このインタフェースは、HttpServletResponseを拡張したものです。
HTTPContext
リクエスト、レスポンス、および サーブレットコンテキストへのアクセスを提供します。
HTTPContextManager
HTTP コンテキスト・マネージャ

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SearchableHttpServletResponseWrapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http
クラス SearchableHttpServletResponseWrapper

java.lang.Object
    拡張 javax.servlet.ServletResponseWrapper
        拡張 javax.servlet.http.HttpServletResponseWrapper
            拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper
すべての実装インタフェース:
ExtendedHttpServletResponse, ExtendedServletResponse, HttpServletResponse, ServletResponse
public class SearchableHttpServletResponseWrapper
extends HttpServletResponseWrapper
implements ExtendedHttpServletResponse

HttpServletResponseWrapperの拡張実装を提供します。 このクラスを利用する事により、レスポンスにセットした値を取得可能になり、 アプリケーションプログラム内での情報操作の利便性が向上します。

導入されたバージョン:
version 6.0

フィールドの概要
インタフェース javax.servlet.http.HttpServletResponse から継承したフィールド
SC_ACCEPTED, SC_BAD_GATEWAY, SC_BAD_REQUEST, SC_CONFLICT, SC_CONTINUE, SC_CREATED, SC_EXPECTATION_FAILED, SC_FORBIDDEN, SC_GATEWAY_TIMEOUT, SC_GONE, SC_HTTP_VERSION_NOT_SUPPORTED, SC_INTERNAL_SERVER_ERROR, SC_LENGTH_REQUIRED, SC_METHOD_NOT_ALLOWED, SC_MOVED_PERMANENTLY, SC_MOVED_TEMPORARILY, SC_MULTIPLE_CHOICES, SC_NO_CONTENT, SC_NON_AUTHORITATIVE_INFORMATION, SC_NOT_ACCEPTABLE, SC_NOT_FOUND, SC_NOT_IMPLEMENTED, SC_NOT_MODIFIED, SC_OK, SC_PARTIAL_CONTENT, SC_PAYMENT_REQUIRED, SC_PRECONDITION_FAILED, SC_PROXY_AUTHENTICATION_REQUIRED, SC_REQUEST_ENTITY_TOO_LARGE, SC_REQUEST_TIMEOUT, SC_REQUEST_URI_TOO_LONG, SC_REQUESTED_RANGE_NOT_SATISFIABLE, SC_RESET_CONTENT, SC_SEE_OTHER, SC_SERVICE_UNAVAILABLE, SC_SWITCHING_PROTOCOLS, SC_TEMPORARY_REDIRECT, SC_UNAUTHORIZED, SC_UNSUPPORTED_MEDIA_TYPE, SC_USE_PROXY
コンストラクタの概要
SearchableHttpServletResponseWrapper(HttpServletResponse response)
指定したレスポンスをラッピングしたレスポンス・アダプタを構築します。
メソッドの概要
 void addCookie(Cookie cookie)
このメソッドは、スーパークラスにある HttpServletResponseWrapper.addCookie(Cookie cookie) メソッドをそのまま呼び出します。
 void addDateHeader(String name, long date)
このメソッドは、スーパークラスの HttpServletResponseWrapper.addDateHeader(java.lang.String name, long date) メソッドをそのまま呼び出します。
 void addHeader(String name, String value)
このメソッドは、スーパークラスの HttpServletResponseWrapper.addHeader(java.lang.String name, java.lang.String value) メソッドをそのまま呼び出します。
 void addIntHeader(String name, int value)
このメソッドは、スーパークラスの HttpServletResponseWrapper.addIntHeader(java.lang.String name, int value) メソッドをそのまま呼び出します。
 Integer getContentLength()
レスポンスにセットされている メッセージボディ部の長さを返します。
 ContentType getContentType()
レスポンスにセットされている クライアントに送り返されるレスポンスのコンテントタイプを 返します。
 Cookie[] getCookies()
このレスポンスにセットされたすべての Cookie を返します。
 Long getDateHeader(String name)
指定された名称でレスポンスヘッダに設定されている日付の値を返します。
 long[] getDateHeaders(String name)
指定された名称でレスポンスヘッダに設定されている全ての日付の値を返します。
 Object getHeader(String name)
指定された名称でレスポンスヘッダに設定されている値を返します。
 Object[] getHeaders(String name)
指定された名称でレスポンスヘッダに設定されている全ての値を返します。
 HttpServletResponse getHttpServletResponse()
このオブジェクトにラップされているレスポンスを返します。
 Integer getIntHeader(String name)
指定された名称でレスポンスヘッダに設定されている数値を返します。
 int[] getIntHeaders(String name)
指定された名称でレスポンスヘッダに設定されている全ての数値を返します。
 Integer getStatus()
レスポンスにセットされている ステータスコードを返します。
 String getStringHeader(String name)
指定された名称でレスポンスヘッダに設定されている文字列の値を返します。
 String[] getStringHeaders(String name)
指定された名称でレスポンスヘッダに設定されている全ての文字列の値を返します。
 void reset()
このメソッドは、スーパークラスの ServletResponseWrapper.reset() メソッドをそのまま呼び出します。
 void sendError(int sc)
このメソッドは、スーパークラスの HttpServletResponseWrapper.sendError(int) メソッドをそのまま呼び出します。
 void sendError(int sc, String msg)
このメソッドは、スーパークラスの HttpServletResponseWrapper.sendError(int, java.lang.String) メソッドをそのまま呼び出します。
 void sendRedirect(String location)
このメソッドは、スーパークラスの HttpServletResponseWrapper.sendRedirect(java.lang.String) メソッドをそのまま呼び出します。
 void setContentLength(int len)
レスポンスのメッセージボディ部分の長さをセットします。
 void setContentType(ContentType type)
このメソッドは、 type の ContentType.toString() が返す値を ラップしている ServletResponse にセットします。
 void setContentType(String type)
クライアントに送り返されるレスポンスのコンテントタイプをセットします。
 void setDateHeader(String name, long date)
このメソッドは、スーパークラスの HttpServletResponseWrapper.setDateHeader(java.lang.String name, long date) メソッドをそのまま呼び出します。
 void setHeader(String name, String value)
このメソッドは、スーパークラスの HttpServletResponseWrapper.setHeader(java.lang.String name, java.lang.String value) メソッドをそのまま呼び出します。
 void setIntHeader(String name, int value)
このメソッドは、スーパークラスの HttpServletResponseWrapper.setIntHeader(java.lang.String name, int value) メソッドをそのまま呼び出します。
 void setStatus(int sc)
このレスポンスのステータスコードを設定します。
 void setStatus(int sc, String sm)
推奨されていません。
クラス javax.servlet.http.HttpServletResponseWrapper から継承したメソッド
containsHeader, encodeRedirectUrl, encodeRedirectURL, encodeUrl, encodeURL
クラス javax.servlet.ServletResponseWrapper から継承したメソッド
flushBuffer, getBufferSize, getCharacterEncoding, getLocale, getOutputStream, getResponse, getWriter, isCommitted, resetBuffer, setBufferSize, setLocale, setResponse
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.ServletResponse から継承したメソッド
flushBuffer, getBufferSize, getCharacterEncoding, getLocale, getOutputStream, getWriter, isCommitted, resetBuffer, setBufferSize, setLocale
インタフェース javax.servlet.http.HttpServletResponse から継承したメソッド
containsHeader, encodeRedirectUrl, encodeRedirectURL, encodeUrl, encodeURL

コンストラクタの詳細

SearchableHttpServletResponseWrapper

public SearchableHttpServletResponseWrapper(HttpServletResponse response)
指定したレスポンスをラッピングしたレスポンス・アダプタを構築します。

パラメータ:
response - ラップされるレスポンス・オブジェクト
例外:
IllegalArgumentException - response が null である場合
メソッドの詳細

getHttpServletResponse

public HttpServletResponse getHttpServletResponse()
このオブジェクトにラップされているレスポンスを返します。

戻り値:
ラップされているレスポンス

addCookie

public void addCookie(Cookie cookie)
このメソッドは、スーパークラスにある HttpServletResponseWrapper.addCookie(Cookie cookie) メソッドをそのまま呼び出します。 その後、このオブジェクト内に引数 cookie を保持します。 保持したオブジェクト cookie は、 getCookies()メソッドによって アプリケーションに返されます。

定義:
インタフェース HttpServletResponse 内の addCookie
パラメータ:
cookie - クライアントに返すCookie

getCookies

public Cookie[] getCookies()
このレスポンスにセットされたすべての Cookie を返します。 Cookie を１つもセットしていない場合、null を返します。

定義:
インタフェース ExtendedHttpServletResponse 内の getCookies
戻り値:
セットされている全ての Cookie

addDateHeader

public void addDateHeader(String name,
                          long date)
このメソッドは、スーパークラスの HttpServletResponseWrapper.addDateHeader(java.lang.String name, long date) メソッドをそのまま呼び出します。 その後、このオブジェクト内に引数 name および date を保持します。 保持した情報は、以下のメソッドによってアプリケーションに返されます。
  • getDateHeader(java.lang.String)
  • getDateHeaders(java.lang.String)
  • getHeader(java.lang.String)
  • getHeaders(java.lang.String)

    定義:
    インタフェース HttpServletResponse 内の addDateHeader
    関連項目:
    HttpServletResponse.addDateHeader(java.lang.String, long), HttpServletResponseWrapper.addDateHeader(java.lang.String, long)

    • setDateHeader

    public void setDateHeader(String name,
                          long date)
    このメソッドは、スーパークラスの HttpServletResponseWrapper.setDateHeader(java.lang.String name, long date) メソッドをそのまま呼び出します。 その後、このオブジェクト内に引数 name および date を保持します。 保持した情報は、以下のメソッドによってアプリケーションに返されます。
  • getDateHeader(java.lang.String)
  • getDateHeaders(java.lang.String)
  • getHeader(java.lang.String)
  • getHeaders(java.lang.String)

    定義:
    インタフェース HttpServletResponse 内の setDateHeader
    関連項目:
    HttpServletResponse.setDateHeader(java.lang.String, long), HttpServletResponseWrapper.setDateHeader(java.lang.String, long)

    • getDateHeader

    public Long getDateHeader(String name)
    指定された名称でレスポンスヘッダに設定されている日付の値を返します。 このヘッダに対して日付の値を未設定の場合、null を返します。

    定義:
    インタフェース ExtendedHttpServletResponse 内の getDateHeader
    パラメータ:
    name - ヘッダの名称
    戻り値:
    割り当てられている日付の値

    getDateHeaders

    public long[] getDateHeaders(String name)
    指定された名称でレスポンスヘッダに設定されている全ての日付の値を返します。 このヘッダに対して値を未設定の場合、null を返します。 このヘッダに対して日付の値を未設定の場合、空の配列を返します。

    定義:
    インタフェース ExtendedHttpServletResponse 内の getDateHeaders
    パラメータ:
    name - ヘッダの名称
    戻り値:
    割り当てられている全ての日付の値

    addIntHeader

    public void addIntHeader(String name,
                         int value)
    このメソッドは、スーパークラスの HttpServletResponseWrapper.addIntHeader(java.lang.String name, int value) メソッドをそのまま呼び出します。 その後、このオブジェクト内に引数 name および value を保持します。 保持した情報は、以下のメソッドによってアプリケーションに返されます。
  • getIntHeader(java.lang.String)
  • getIntHeaders(java.lang.String)
  • getHeader(java.lang.String)
  • getHeaders(java.lang.String)

    定義:
    インタフェース HttpServletResponse 内の addIntHeader
    関連項目:
    HttpServletResponse.addIntHeader(java.lang.String, int), HttpServletResponseWrapper.addIntHeader(java.lang.String, int)

    • setIntHeader

    public void setIntHeader(String name,
                         int value)
    このメソッドは、スーパークラスの HttpServletResponseWrapper.setIntHeader(java.lang.String name, int value) メソッドをそのまま呼び出します。 その後、このオブジェクト内に引数 name および value を保持します。 保持した情報は、以下のメソッドによってアプリケーションに返されます。
  • getIntHeader(java.lang.String)
  • getIntHeaders(java.lang.String)
  • getHeader(java.lang.String)
  • getHeaders(java.lang.String)

    定義:
    インタフェース HttpServletResponse 内の setIntHeader
    関連項目:
    HttpServletResponse.setIntHeader(java.lang.String, int), HttpServletResponseWrapper.setIntHeader(java.lang.String, int)

    • getIntHeader

    public Integer getIntHeader(String name)
    指定された名称でレスポンスヘッダに設定されている数値を返します。 このヘッダに対して数値を未設定の場合、null を返します。

    定義:
    インタフェース ExtendedHttpServletResponse 内の getIntHeader
    パラメータ:
    name - ヘッダの名称
    戻り値:
    割り当てられている整数値

    getIntHeaders

    public int[] getIntHeaders(String name)
    指定された名称でレスポンスヘッダに設定されている全ての数値を返します。 このヘッダに対して値を未設定の場合、null を返します。 このヘッダに対して数値を未設定の場合、空の配列を返します。

    定義:
    インタフェース ExtendedHttpServletResponse 内の getIntHeaders
    パラメータ:
    name - ヘッダの名称
    戻り値:
    割り当てられている全ての整数値

    addHeader

    public void addHeader(String name,
                      String value)
    このメソッドは、スーパークラスの HttpServletResponseWrapper.addHeader(java.lang.String name, java.lang.String value) メソッドをそのまま呼び出します。 その後、このオブジェクト内に引数 name および value を保持します。 保持した情報は、以下のメソッドによってアプリケーションに返されます。
  • getStringHeader(java.lang.String)
  • getStringHeaders(java.lang.String)
  • getHeader(java.lang.String)
  • getHeaders(java.lang.String)

    定義:
    インタフェース HttpServletResponse 内の addHeader
    関連項目:
    HttpServletResponse.addHeader(java.lang.String, java.lang.String), HttpServletResponseWrapper.addHeader(java.lang.String, java.lang.String)

    • setHeader

    public void setHeader(String name,
                      String value)
    このメソッドは、スーパークラスの HttpServletResponseWrapper.setHeader(java.lang.String name, java.lang.String value) メソッドをそのまま呼び出します。 その後、このオブジェクト内に引数 name および value を保持します。 保持した情報は、以下のメソッドによってアプリケーションに返されます。
  • getStringHeader(java.lang.String)
  • getStringHeaders(java.lang.String)
  • getHeader(java.lang.String)
  • getHeaders(java.lang.String)

    定義:
    インタフェース HttpServletResponse 内の setHeader
    関連項目:
    HttpServletResponse.setHeader(java.lang.String, java.lang.String), HttpServletResponseWrapper.setHeader(java.lang.String, java.lang.String)

    • getStringHeader

    public String getStringHeader(String name)
    指定された名称でレスポンスヘッダに設定されている文字列の値を返します。 このヘッダに対して文字列の値を未設定の場合、null を返します。

    定義:
    インタフェース ExtendedHttpServletResponse 内の getStringHeader
    パラメータ:
    name - ヘッダの名称
    戻り値:
    割り当てられている文字列の値

    getStringHeaders

    public String[] getStringHeaders(String name)
    指定された名称でレスポンスヘッダに設定されている全ての文字列の値を返します。 このヘッダに対して値を未設定の場合、null を返します。 このヘッダに対して文字列の値を未設定の場合、空の配列を返します。

    定義:
    インタフェース ExtendedHttpServletResponse 内の getStringHeaders
    パラメータ:
    name - ヘッダの名称
    戻り値:
    割り当てられている全ての文字列の値

    getHeader

    public Object getHeader(String name)
    指定された名称でレスポンスヘッダに設定されている値を返します。 ヘッダをセットするために利用したメソッドにより、 返り値の型が決定されます。
    メソッド 返り値の型
    HttpServletResponse.addDateHeader(String name, long date) Long
    HttpServletResponse.setDateHeader(String name, long date) Long
    HttpServletResponse.addIntHeader(String name, int value) Integer
    HttpServletResponse.setIntHeader(String name, int value) Integer
    HttpServletResponse.addHeader(String name, String value) String
    HttpServletResponse.setHeader(String name, String value) String
    このヘッダが未設定の場合、null を返します。

    定義:
    インタフェース ExtendedHttpServletResponse 内の getHeader
    パラメータ:
    name - ヘッダの名称
    戻り値:
    割り当てられている値

    getHeaders

    public Object[] getHeaders(String name)
    指定された名称でレスポンスヘッダに設定されている全ての値を返します。 配列の各要素の型は、getHeader(String)の返り値と同様です。 このヘッダが未設定の場合、null を返します。

    定義:
    インタフェース ExtendedHttpServletResponse 内の getHeaders
    パラメータ:
    name - ヘッダの名称
    戻り値:
    割り当てられている全ての値

    setStatus

    public void setStatus(int sc,
                      String sm)
    推奨されていません。

    定義:
    インタフェース HttpServletResponse 内の setStatus
    パラメータ:
    sc - ステータスコード
    sm - ステータスメッセージ
    関連項目:
    HttpServletResponse.setStatus(int, java.lang.String)

    setStatus

    public void setStatus(int sc)
    このレスポンスのステータスコードを設定します。

    このメソッドは、スーパークラスの HttpServletResponseWrapper.setStatus(int) メソッドをそのまま呼び出します。 その後、このオブジェクト内に引数 sc を保持します。 保持した情報は、getStatus()によってアプリケーションに返されます。

    定義:
    インタフェース HttpServletResponse 内の setStatus
    パラメータ:
    sc - ステータスコード
    関連項目:
    HttpServletResponse.setStatus(int)

    sendError

    public void sendError(int sc,
                      String msg)
               throws IOException
    このメソッドは、スーパークラスの HttpServletResponseWrapper.sendError(int, java.lang.String) メソッドをそのまま呼び出します。 その後、このオブジェクト内に引数 sc を保持します。 保持した情報は、getStatus()によってアプリケーションに返されます。

    定義:
    インタフェース HttpServletResponse 内の sendError
    パラメータ:
    sc - ステータスコード
    msg - 説明文
    例外:
    IOException
    関連項目:
    HttpServletResponse.sendError(int, java.lang.String)

    sendError

    public void sendError(int sc)
               throws IOException
    このメソッドは、スーパークラスの HttpServletResponseWrapper.sendError(int) メソッドをそのまま呼び出します。 その後、このオブジェクト内に引数 sc を保持します。 保持した情報は、getStatus()によってアプリケーションに返されます。

    定義:
    インタフェース HttpServletResponse 内の sendError
    パラメータ:
    sc - ステータスコード
    例外:
    IOException
    関連項目:
    HttpServletResponse.sendError(int)

    sendRedirect

    public void sendRedirect(String location)
                  throws IOException
    このメソッドは、スーパークラスの HttpServletResponseWrapper.sendRedirect(java.lang.String) メソッドをそのまま呼び出します。 このメソッドでは、ステータスコード HttpServletResponse.SC_MOVED_TEMPORARILY が指定されたと判断し、このオブジェクト内に HttpServletResponse.SC_MOVED_TEMPORARILY を保持します。 保持した情報は、getStatus()によってアプリケーションに返されます。

    定義:
    インタフェース HttpServletResponse 内の sendRedirect
    パラメータ:
    location - リダイレクト先のURL
    例外:
    IOException
    関連項目:
    HttpServletResponse.sendRedirect(java.lang.String)

    getStatus

    public Integer getStatus()
    レスポンスにセットされている ステータスコードを返します。
    このメソッドは、 HttpServletResponse.sendRedirect(String location)、 HttpServletResponse.sendError(int sc)、 HttpServletResponse.sendError(int sc, String msg)、 HttpServletResponse.setStatus(int sc)、 またはHttpServletResponse.setStatus(int sc, String sm) によってセットされたステータスコードを返します。 値を未設定の場合、null を返します。

    定義:
    インタフェース ExtendedHttpServletResponse 内の getStatus
    戻り値:
    ステータスコード

    setContentLength

    public void setContentLength(int len)
    レスポンスのメッセージボディ部分の長さをセットします。

    このメソッドは、スーパークラスの ServletResponseWrapper.setContentLength(int) メソッドをそのまま呼び出します。 その後、このオブジェクト内に引数 len を保持します。 保持した情報は、getContentLength()によってアプリケーションに返されます。

    定義:
    インタフェース ServletResponse 内の setContentLength
    パラメータ:
    len - クライアントに送り返すメッセージボディの長さを指定する整数
    関連項目:
    ServletResponse.setContentLength(int)

    getContentLength

    public Integer getContentLength()
    レスポンスにセットされている メッセージボディ部の長さを返します。
    このメソッドは、ServletResponse.setContentLength(int len) によってセットされた長さを返します。 値を未設定の場合、null を返します。

    定義:
    インタフェース ExtendedServletResponse 内の getContentLength
    戻り値:
    クライアントに送り返すメッセージボディの長さを指定する整数値。 HTTP の Content-Length ヘッダフィールドの値

    setContentType

    public void setContentType(String type)
    クライアントに送り返されるレスポンスのコンテントタイプをセットします。

    このメソッドは、スーパークラスの ServletResponseWrapper.setContentType(java.lang.String) メソッドをそのまま呼び出します。 その後、このオブジェクト内に引数 type を保持します。 保持した情報は、getContentType()によってアプリケーションに返されます。

    定義:
    インタフェース ServletResponse 内の setContentType
    パラメータ:
    type - コンテントタイプを指定する String
    例外:
    IllegalArgumentException - type の構文解析に失敗した場合
    関連項目:
    ServletResponse.setContentType(java.lang.String)

    getContentType

    public ContentType getContentType()
    レスポンスにセットされている クライアントに送り返されるレスポンスのコンテントタイプを 返します。

    定義:
    インタフェース ExtendedServletResponse 内の getContentType
    戻り値:
    コンテントタイプを指定する ContentType
    関連項目:
    ServletResponse.setContentType(java.lang.String)

    setContentType

    public void setContentType(ContentType type)
    このメソッドは、 type の ContentType.toString() が返す値を ラップしている ServletResponse にセットします。

    定義:
    インタフェース ExtendedServletResponse 内の setContentType
    パラメータ:
    type - コンテントタイプを指定する ContentType
    関連項目:
    ServletResponse.setContentType(java.lang.String)

    reset

    public void reset()
    このメソッドは、スーパークラスの ServletResponseWrapper.reset() メソッドをそのまま呼び出します。 その後、このオブジェクト内に保持している各データをクリアし、初期状態に戻します。

    定義:
    インタフェース ServletResponse 内の reset
    例外:
    IllegalStateException - レスポンスがすでにコミットされている場合
    関連項目:
    ServletResponse.reset()
    概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
            intra-mart 6.1.14
    前のクラス 次のクラス | フレームあり フレームなし
    概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedServletResponse (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet
インタフェース ExtendedServletResponse

すべてのスーパーインタフェース:
ServletResponse
既知のサブインタフェースの一覧:
ExtendedHttpServletResponse, HttpServletResponseEventController
既知の実装クラスの一覧:
AbstractHttpServletResponseEventController, ExtendedHttpServletResponseWrapper, SearchableHttpServletResponseWrapper
public interface ExtendedServletResponse
extends ServletResponse

このインタフェースは、ServletResponseを拡張したものです。

導入されたバージョン:
version 6.0

メソッドの概要
Integer | getContentLength() レスポンスにセットされている メッセージボディ部の長さを返します。
ContentType | getContentType() レスポンスにセットされている クライアントに送り返されるレスポンスのコンテントタイプを 返します。
void | setContentType(ContentType type) レスポンスに Content-Type をセットします。
インタフェース javax.servlet.ServletResponse から継承したメソッド
flushBuffer, getBufferSize, getCharacterEncoding, getLocale, getOutputStream, getWriter, isCommitted, reset, resetBuffer, setBufferSize, setContentLength, setContentType, setLocale

メソッドの詳細

getContentType

public ContentType getContentType()
レスポンスにセットされている クライアントに送り返されるレスポンスのコンテントタイプを 返します。
このメソッドは、 ServletResponse.setContentType(String type) または setContentType(ContentType) によってセットされたコンテントタイプを返します。 コンテントタイプには、 例えば、 text/html; charset=ISO-8859-4 のように 文字エンコーディングのタイプが含まれることがあります。

戻り値:
コンテントタイプを指定する ContentType

setContentType

public void setContentType(ContentType type)
レスポンスに Content-Type をセットします。

このメソッドは、 ContentType での 引数指定を可能とするインタフェースを提供します。

パラメータ:
type - コンテントタイプを指定する ContentType

getContentLength

public Integer getContentLength()
レスポンスにセットされている メッセージボディ部の長さを返します。
このメソッドは、ServletResponse.setContentLength(int len) によってセットされた長さを返します。 値を未設定の場合、null を返します。

戻り値:
クライアントに送り返すメッセージボディの長さを指定する整数値。 HTTP の Content-Length ヘッダフィールドの値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


FilterServletInputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet
クラス FilterServletInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 javax.servlet.ServletInputStream
            拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream
public class FilterServletInputStream
extends ServletInputStream

InputStream を ServletInputStream に変換するためのラッパです。

このクラスは、基礎ストリームの対応するメソッドを呼び出すだけです。 各メソッドをオーバーライドして再定義することにより、 入力をフィルタリングする事ができます。

導入されたバージョン:
Version 5.0

コンストラクタの概要
FilterServletInputStream(InputStream in)
指定の入力を基礎入力とするサーブレット入力ストリームを作成します。
メソッドの概要
int | available() この入力ストリームのメソッドの次の呼び出し側からブロックされることなく、 この入力ストリームから読み込むことができる(またはスキップできる)バイト数 を返します。
void | close() 入力を閉じます。
protected InputStream | getInputStream() このオブジェクトがラップしている入力ストリームを返します。
void | mark(int readlimit) 入力ストリームの現在位置にマークを設定します。
boolean | markSupported() 入力ストリームが mark および reset メソッドをサポートしているかどうかを 判定します。
int | read() 基礎入力から１バイト読み込みます。
int | read(byte[] b) 基礎入力から指定のバイト配列にデータを読み込みます。
int | read(byte[] b, int off, int len) 基礎入力から指定のバイト配列にデータを読み込みます。
void | reset() このストリームの位置を、 入力ストリームで最後に mark メソッドが呼び出されたときのマーク位置に 再設定します。
long | skip(long n) 指定のバイト数だけ入力をスキップします。
クラス javax.servlet.ServletInputStream から継承したメソッド
readLine
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FilterServletInputStream

public FilterServletInputStream(InputStream in)
指定の入力を基礎入力とするサーブレット入力ストリームを作成します。

パラメータ:
in - 入力ストリーム
メソッドの詳細

getInputStream

protected InputStream getInputStream()
このオブジェクトがラップしている入力ストリームを返します。

戻り値:
入力ストリーム

read

public int read()
         throws IOException
基礎入力から１バイト読み込みます。

このメソッドは、以下と同じです。
getInputStream().read()

戻り値:
データの次のバイト。ストリームの終わりに達した場合は -1
例外:
IOException - 入出力エラーが発生した場合

read

public int read(byte[] b)
         throws IOException
基礎入力から指定のバイト配列にデータを読み込みます。

このメソッドは、以下と同じです。
getInputStream().read(b)

パラメータ:
b - データの読み込み先のバッファ
戻り値:
バッファに読み込まれたバイトの合計数。ストリームの終わりに達してデータがない場合は -1
例外:
IOException - 入出力エラーが発生した場合

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
基礎入力から指定のバイト配列にデータを読み込みます。

このメソッドは、以下と同じです。
getInputStream().read(b, off, len)

パラメータ:
b - データの読み込み先のバッファ
off - データが書き込まれる配列 b の開始オフセット
len - 読み込む最大バイト数
戻り値:
バッファに読み込まれたバイトの合計数。ストリームの終わりに達してデータがない場合は -1
例外:
IOException - 入出力エラーが発生した場合

skip

public long skip(long n)
          throws IOException
指定のバイト数だけ入力をスキップします。

このメソッドは、以下と同じです。
getInputStream().skip(n)

パラメータ:
n - スキップするバイト数
戻り値:
実際にスキップされたバイト数
例外:
IOException - 入出力エラーが発生した場合

available

public int available()
              throws IOException
この入力ストリームのメソッドの次の呼び出し側からブロックされることなく、 この入力ストリームから読み込むことができる(またはスキップできる)バイト数 を返します。

このメソッドは、以下と同じです。
getInputStream().available()

戻り値:
ブロックしないで入力ストリームから読み込むことができるバイト数
例外:
IOException - 入出力エラーが発生した場合

close

public void close()
           throws IOException
入力を閉じます。

このメソッドは、以下と同じです。
getInputStream().close()

例外:
IOException - 入出力エラーが発生した場合

mark

public void mark(int readlimit)
入力ストリームの現在位置にマークを設定します。

このメソッドは、以下と同じです。
getInputStream().mark(readlimit)

パラメータ:
readlimit - マーク位置が無効になる前に読み込み可能なバイトの最大リミット

reset

public void reset()
           throws IOException
このストリームの位置を、 入力ストリームで最後に mark メソッドが呼び出されたときのマーク位置に 再設定します。

このメソッドは、以下と同じです。
getInputStream().reset()

例外:
IOException - ストリームにマークが設定されていなかった場合、またはマークが無効になっていた場合

markSupported

public boolean markSupported()
入力ストリームが mark および reset メソッドをサポートしているかどうかを 判定します。

このメソッドは、以下と同じです。
getInputStream().markSupported()

戻り値:
このストリームインスタンスが mark および reset メソッドをサポートしている場合は true、サポートしていない場合は false
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jsdk.javax.servlet (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.common.aid.jsdk.javax.servlet
インタフェース
ExtendedServletResponse
クラス
FilterServletInputStream


jp.co.intra_mart.common.aid.jsdk.javax.servlet (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet

このパッケージには、サーブレットを利用する際に利用すると 便利な汎用クラスが含まれています。

参照:
説明

インタフェースの概要
ExtendedServletResponse このインタフェースは、ServletResponseを拡張したものです。

クラスの概要
FilterServletInputStream InputStream を ServletInputStream に変換するためのラッパです。

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet の説明

このパッケージには、サーブレットを利用する際に利用すると 便利な汎用クラスが含まれています。


jp.co.intra_mart.common.aid.jsdk.javax.servlet クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.io.InputStream
      • class javax.servlet.ServletInputStream
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream

インタフェース階層

  • interface javax.servlet.ServletResponse
    • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse


パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter | このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http | このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet のクラス
ExtendedServletResponse
このインタフェースは、ServletResponseを拡張したものです。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet のクラス
ExtendedServletResponse
このインタフェースは、ServletResponseを拡張したものです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.utility.BrowseString の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.utility.BrowseString の使用

jp.co.intra_mart.common.aid.jsdk.utility.BrowseString はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.utility.URLUtil の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.utility.URLUtil の使用

jp.co.intra_mart.common.aid.jsdk.utility.URLUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BrowseString (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.utility
クラス BrowseString

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.utility.BrowseString
public class BrowseString
extends Object

HTML表示用文字列変換ユーティリティクラス。

HTML表示用に文字列の変換を行うクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
static String convert(String string)
HTML表示可能な文字列に変換します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

convert

public static String convert(String string)
HTML表示可能な文字列に変換します。

「>」、「<」、「"」、「&」、「半角スペース」、「改行コード」をHTML表示可能な文字に変換します。
改行コードは「<BR>」に変換します。

パラメータ:
string - 変換元文字列
戻り値:
変換された文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jsdk.utility (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.common.aid.jsdk.utility
クラス
BrowseString
URLUtil


jp.co.intra_mart.common.aid.jsdk.utility (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.utility

このパッケージには、ＨＴＭＬの表示変換に 便利な汎用クラスが含まれています。

参照:
説明

クラスの概要
BrowseString | HTML表示用文字列変換ユーティリティクラス。
URLUtil | URL関連のユーティリティクラス。

パッケージ jp.co.intra_mart.common.aid.jsdk.utility の説明

このパッケージには、ＨＴＭＬの表示変換に 便利な汎用クラスが含まれています。


jp.co.intra_mart.common.aid.jsdk.utility クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.utility の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jsdk.utility.BrowseString
    • class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil


パッケージ jp.co.intra_mart.common.aid.jsdk.utility の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jsdk.utility の使用

jp.co.intra_mart.common.aid.jsdk.utility はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


URLUtil (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.utility
クラス URLUtil

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.utility.URLUtil
public class URLUtil
extends Object

URL関連のユーティリティクラス。

HttpServletRequestが保持している情報を元に、URLを生成するクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
URLUtil()
メソッドの概要
static String | encodeUrl(String src) 文字列をURLエンコードします。
static URL | getContextURL(HttpServletRequest request) 引数で与えられたリクエストのコンテキストを示すURLを生成します。
static URL | getContextURL(HttpServletRequest request, boolean appendSlash) 引数で与えられたリクエストのコンテキストを示すURLを生成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLUtil

public URLUtil()
メソッドの詳細

getContextURL

public static URL getContextURL(HttpServletRequest request)
                         throws MalformedURLException
引数で与えられたリクエストのコンテキストを示すURLを生成します。
このメソッドで生成されたURLの末尾は、常にスラッシュとなります。

パラメータ:
request - リクエスト
戻り値:
要求のコンテキストを示すURL
例外:
MalformedURLException - 引数で与えられたリクエストに使用されるスキーマが未知である場合

getContextURL

public static URL getContextURL(HttpServletRequest request,
                                boolean appendSlash)
                         throws MalformedURLException
引数で与えられたリクエストのコンテキストを示すURLを生成します。
このメソッドで生成されたURLの末尾は、引数 appendSlash によって変化します。

パラメータ:
request - リクエスト
appendSlash - このメソッドで生成されたURLの末尾にスラッシュを付加する場合は、true、　それ以外はfalse
戻り値:
要求のコンテキストを示すURL
例外:
MalformedURLException - 引数で与えられたリクエストに使用されるスキーマが未知である場合

encodeUrl

public static String encodeUrl(String src)
文字列をURLエンコードします。

パラメータ:
src - URLエンコード元文字列
戻り値:
URLエンコード後の文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.platform.util.DateUtil の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.platform.util.DateUtil の使用

jp.co.intra_mart.common.platform.util.DateUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DateUtil (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.platform.util
クラス DateUtil

java.lang.Object
    拡張 jp.co.intra_mart.common.platform.util.DateUtil
public class DateUtil
extends Object

日付操作ユーティリティクラスです。

日付に関する操作をするためのユーティリティクラスです。
このクラスのメソッドはすべてstaticメソッドとなっています。
このクラスのインスタンスを生成することはできません。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
static Date | convertOnlyDate(Date date) 日付のみのjava.util.Dateに変換します。
static Date | convertOnlyDate(long date) 日付のみのjava.util.Dateに変換します。
static Date | convertOnlyDateTime(Date date) 日付と時刻のみのjava.util.Dateに変換します。
static Date | convertOnlyDateTime(long date) 日付と時刻のみのjava.util.Dateに変換します。
static String | dateToString(Date date) データベース登録用文字列を取得します。
static Date | getMaxDate() システムで許可されている最大日時を取得します。
static Date | getMinDate() システムで許可されている最小日時を取得します。
static Date | stringToDate(String dateString) データベース登録用文字列からjava.util.Dateを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

dateToString

public static String dateToString(Date date)
データベース登録用文字列を取得します。

パラメータ:
date - 変換元のDateオブジェクト
戻り値:
データベース登録用文字列(YYYY/MM/DD|hh:mm:ss)

stringToDate

public static Date stringToDate(String dateString)
データベース登録用文字列からjava.util.Dateを取得します。

パラメータ:
dateString - 変換元のデータベース登録用文字列(YYYY/MM/DD|hh:mm:ss)
年月日のみ(YYYY/MM/DD形式)で指定した場合、YYYY/MM/DD|00:00:00として変換します。
戻り値:
Dateオブジェクト

convertOnlyDate

public static Date convertOnlyDate(long date)
日付のみのjava.util.Dateに変換します。

時刻は、00:00:00.000に設定されます。

パラメータ:
date - 1970 年 1 月 1 日 00:00:00 GMT からのミリ秒数
戻り値:
日付のみのjava.util.Date

convertOnlyDate

public static Date convertOnlyDate(Date date)
日付のみのjava.util.Dateに変換します。

時刻は、00:00:00.000に設定されます。

パラメータ:
date - 日付
戻り値:
日付のみのjava.util.Date

convertOnlyDateTime

public static Date convertOnlyDateTime(long date)
日付と時刻のみのjava.util.Dateに変換します。

ミリ秒の単位は 0 に設定されます。

パラメータ:
date - 1970 年 1 月 1 日 00:00:00 GMT からのミリ秒数
戻り値:
日付と時刻のみのjava.util.Date

convertOnlyDateTime

public static Date convertOnlyDateTime(Date date)
日付と時刻のみのjava.util.Dateに変換します。

ミリ秒の単位は 0 に設定されます。

パラメータ:
date - 日付
戻り値:
日付と時刻のみのjava.util.Date

getMinDate

public static Date getMinDate()
システムで許可されている最小日時を取得します。

戻り値:
システムで許可されている最小日時

getMaxDate

public static Date getMaxDate()
システムで許可されている最大日時を取得します。

戻り値:
システムで許可されている最大日時
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.platform.util (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.common.platform.util
クラス
DateUtil


jp.co.intra_mart.common.platform.util (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.platform.util

このパッケージには、プラットフォームを利用する際に 便利なユーティリティクラスが含まれています。

参照:
説明

クラスの概要
DateUtil 日付操作ユーティリティクラスです。

パッケージ jp.co.intra_mart.common.platform.util の説明

このパッケージには、プラットフォームを利用する際に 便利なユーティリティクラスが含まれています。


jp.co.intra_mart.common.platform.util クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.platform.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.platform.util.DateUtil


パッケージ jp.co.intra_mart.common.platform.util の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.platform.util の使用

jp.co.intra_mart.common.platform.util はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.platform.vm.CommandLineArgument の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.platform.vm.CommandLineArgument の使用

jp.co.intra_mart.common.platform.vm.CommandLineArgument はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CommandLineArgument (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.platform.vm
クラス CommandLineArgument

java.lang.Object
    拡張 jp.co.intra_mart.common.platform.vm.CommandLineArgument
public class CommandLineArgument
extends Object

このクラスはコマンド実引数を解釈するための共通実装です。

このクラスは、インスタンス生成時にコマンドライン引数を解析し、 オプションと引数に選別します。 コマンド [-オプション名 [値]] [引数] オプションは "-" から始まる名称文字列と値から成り立ちます。 最後尾のオプション指定以降のトークンを引数として解釈します。 オプションはオプション名("-" から始まるトークン)をキーとして 値がマッピングされます。

コンストラクタの概要
CommandLineArgument(String[] args)
Java-VM から最初に実行される public かつ static な void main(String[]) メソッドの引数を受け取り解析します。
メソッドの概要
String | getArgument(int index) 指定されたすべてのコマンドライン引数の引数を返します。
String[] | getArguments() 指定されたすべてのコマンドライン引数の引数を返します。
String | getOption(String name) オプションの値を返します。
String | getOption(String name, String def) オプションの値を返します。
Set | getOptionNames() 指定されたすべてのオプションの名前を返します。
String[] | getOptions(String name) オプションの値を返します。
String[] | getQuery() 引数情報を取得します。
boolean | hasArguments() コマンドライン引数があるかどうか判定します。
boolean | hasOption(String name) オプションが指定されているかどうか判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CommandLineArgument

public CommandLineArgument(String[] args)
Java-VM から最初に実行される public かつ static な void main(String[]) メソッドの引数を受け取り解析します。

実引数(command-line-arguments)の格納されている配列の構造は変化しません。
コマンド [-オプション名 [値]] [引数] オプションと引数を分割します。 オプションは、値のない単独指定も可能です。

パラメータ:
args - コマンド実行時のコマンドライン引数(main メソッドの引数)
例外:
IllegalArgumentException - 引数が null の場合
メソッドの詳細

getQuery

public String[] getQuery()
引数情報を取得します。 このメソッドは、このインスタンス生成時にコンストラクタに指定した 値を返します。

戻り値:
引数情報

hasOption

public boolean hasOption(String name)
オプションが指定されているかどうか判定します。

パラメータ:
name - オプション名
戻り値:
オプションが指定されている場合 true、そうでない場合 false。

getOption

public String getOption(String name)
                 throws IllegalArgumentException
オプションの値を返します。 オプション name が値を持たない単独指定の場合、null を返します。

パラメータ:
name - オプション名
戻り値:
オプションの値
例外:
IllegalArgumentException - 指定のオプション名が定義されていない場合

getOption

public String getOption(String name,
                        String def)
オプションの値を返します。 オプション name が値を持たない単独指定の場合、null を返します。 また、指定のオプション名が未定義だった場合、デフォルト値 def を 返します。

パラメータ:
name - オプション名
def - オプションが未指定だった場合のデフォルト値
戻り値:
オプションの値

getOptions

public String[] getOptions(String name)
                    throws IllegalArgumentException
オプションの値を返します。 オプション name が値を持たない単独指定の場合、null を返します。

パラメータ:
name - オプション名
戻り値:
オプションの値
例外:
IllegalArgumentException - 指定のオプション名が定義されていない場合

getOptionNames

public Set getOptionNames()
指定されたすべてのオプションの名前を返します。 返却値のセットの各要素は String インスタンスです。

戻り値:
オプション名一覧のセット

getArguments

public String[] getArguments()
指定されたすべてのコマンドライン引数の引数を返します。 ここで返される引数は、コマンドライン引数のうちの オプション指定ではない引数です。 返却値のセットの各要素は String インスタンスです。

戻り値:
引数のセット

getArgument

public String getArgument(int index)
                   throws ArrayIndexOutOfBoundsException
指定されたすべてのコマンドライン引数の引数を返します。 ここで返される引数は、コマンドライン引数のうちの オプション指定ではない引数です。 返却値のセットの各要素は String インスタンスです。

戻り値:
引数のセット
例外:
ArrayIndexOutOfBoundsException - インデックスが範囲外の場合（引数の個数以上、または負数）

hasArguments

public boolean hasArguments()
コマンドライン引数があるかどうか判定します。 ここでチェックされる引数は、コマンドライン引数のうちの オプション指定ではない引数です。

戻り値:
オプションではない引数がある場合 true、そうでない場合 false。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.platform.vm (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.common.platform.vm
クラス
CommandLineArgument


jp.co.intra_mart.common.platform.vm (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.platform.vm

このパッケージには、コマンド実引数を解釈するための共通クラスが含まれています。

参照:
説明

クラスの概要
CommandLineArgument このクラスはコマンド実引数を解釈するための共通実装です。

パッケージ jp.co.intra_mart.common.platform.vm の説明

このパッケージには、コマンド実引数を解釈するための共通クラスが含まれています。


jp.co.intra_mart.common.platform.vm クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.platform.vm の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.platform.vm.CommandLineArgument


パッケージ jp.co.intra_mart.common.platform.vm の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.platform.vm の使用

jp.co.intra_mart.common.platform.vm はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.extension.maskat.exception.MKRuntimeException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.extension.maskat.exception.MKRuntimeException の使用

MKRuntimeException を使用しているパッケージ
jp.co.intra_mart.extension.maskat.util

jp.co.intra_mart.extension.maskat.util での MKRuntimeException の使用

MKRuntimeException をスローする jp.co.intra_mart.extension.maskat.util のメソッド
static String | XMLUtil.getXMLString(Document doc) XML文字列を取得します。
static void | XMLUtil.writeXML(Document doc, OutputStream out) ドキュメントをストリームに出力します。
static Document | XMLUtil.readXML(InputStream in) ストリームからXMLを読み込み、ドキュメントを生成します。
Document | MKErrors.getDocument() エラー要素群のドキュメントを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.extension.maskat.exception.MKSystemException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.extension.maskat.exception.MKSystemException の使用

MKSystemException を使用しているパッケージ
jp.co.intra_mart.extension.maskat.service

jp.co.intra_mart.extension.maskat.service での MKSystemException の使用

MKSystemException をスローする jp.co.intra_mart.extension.maskat.service のメソッド
Document | MKServiceResult.getTelegram() クライアントへ送信する電文を取得します。
Document | MKErrorsResult.getTelegram() クライアントへ送信するエラー電文を取得します。

MKSystemException をスローする jp.co.intra_mart.extension.maskat.service のコンストラクタ
DefaultMKServiceResult(String xmlString)
XML文字列から新規に処理結果を生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


MKRuntimeException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.exception
クラス MKRuntimeException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.extension.maskat.exception.MKRuntimeException
すべての実装インタフェース:
Serializable
public class MKRuntimeException
extends RuntimeException

マスカットアプリケーション実行時に出力されるランタイム例外です。

関連項目:
直列化された形式

コンストラクタの概要
MKRuntimeException()
詳細メッセージを指定しないで MKRuntimeException を構築します。
MKRuntimeException(String msg)
指定された詳細メッセージを持つ MKRuntimeException を構築します。
MKRuntimeException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MKRuntimeException を構築します。
MKRuntimeException(Throwable throwable)
この例外の発生原因となる例外を持つ MKRuntimeException を構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MKRuntimeException

public MKRuntimeException()
詳細メッセージを指定しないで MKRuntimeException を構築します。

MKRuntimeException

public MKRuntimeException(String msg)
指定された詳細メッセージを持つ MKRuntimeException を構築します。

パラメータ:
msg - 詳細メッセージ

MKRuntimeException

public MKRuntimeException(Throwable throwable)
この例外の発生原因となる例外を持つ MKRuntimeException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外

MKRuntimeException

public MKRuntimeException(String msg,
                          Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MKRuntimeException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MKSystemException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.exception
クラス MKSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.extension.maskat.exception.MKSystemException
すべての実装インタフェース:
Serializable
public class MKSystemException
extends SystemException

マスカットアプリケーション実行時に出力される例外です。

関連項目:
直列化された形式

コンストラクタの概要
MKSystemException()
詳細メッセージを指定しないで MKSystemException を構築します。
MKSystemException(String msg)
指定された詳細メッセージを持つ MKSystemException を構築します。
MKSystemException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MKSystemException を構築します。
MKSystemException(Throwable throwable)
この例外の発生原因となる例外を持つ MKSystemException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MKSystemException

public MKSystemException()
詳細メッセージを指定しないで MKSystemException を構築します。

MKSystemException

public MKSystemException(String msg)
指定された詳細メッセージを持つ MKSystemException を構築します。

パラメータ:
msg - 詳細メッセージ

MKSystemException

public MKSystemException(Throwable throwable)
この例外の発生原因となる例外を持つ MKSystemException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外

MKSystemException

public MKSystemException(String msg,
                         Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MKSystemException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.extension.maskat.exception (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.extension.maskat.exception
例外
MKRuntimeException
MKSystemException


jp.co.intra_mart.extension.maskat.exception (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.extension.maskat.exception

例外の概要
MKRuntimeException | マスカットアプリケーション実行時に出力されるランタイム例外です。
MKSystemException | マスカットアプリケーション実行時に出力される例外です。


jp.co.intra_mart.extension.maskat.exception クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.extension.maskat.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.extension.maskat.exception.MKSystemException
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.extension.maskat.exception.MKRuntimeException


パッケージ jp.co.intra_mart.extension.maskat.exception の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.extension.maskat.exception の使用

jp.co.intra_mart.extension.maskat.exception を使用しているパッケージ
jp.co.intra_mart.extension.maskat.service
jp.co.intra_mart.extension.maskat.util

jp.co.intra_mart.extension.maskat.service により使用される jp.co.intra_mart.extension.maskat.exception のクラス
MKSystemException
マスカットアプリケーション実行時に出力される例外です。

jp.co.intra_mart.extension.maskat.util により使用される jp.co.intra_mart.extension.maskat.exception のクラス
MKRuntimeException
マスカットアプリケーション実行時に出力されるランタイム例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.extension.maskat.service.DefaultMKServiceResult の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.extension.maskat.service.DefaultMKServiceResult の使用

jp.co.intra_mart.extension.maskat.service.DefaultMKServiceResult はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.extension.maskat.service.MKErrorsResult の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.extension.maskat.service.MKErrorsResult の使用

jp.co.intra_mart.extension.maskat.service.MKErrorsResult はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.extension.maskat.service.MKServiceResult の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.extension.maskat.service.MKServiceResult の使用

MKServiceResult を使用しているパッケージ
jp.co.intra_mart.extension.maskat.service

jp.co.intra_mart.extension.maskat.service での MKServiceResult の使用

MKServiceResult を実装している jp.co.intra_mart.extension.maskat.service のクラス
class | DefaultMKServiceResult デフォルトのMKServiceResult実装です。
class | MKErrorsResult マスカットにエラーを返すサービス処理結果です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.extension.maskat.service.MKTransition の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.extension.maskat.service.MKTransition の使用

jp.co.intra_mart.extension.maskat.service.MKTransition はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter の使用

jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject の使用

jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter の使用

jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


MKControllerConverter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.service.controller
クラス MKControllerConverter

java.lang.Object
    拡張 jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter
すべての実装インタフェース:
ControllerConverter
public class MKControllerConverter
extends Object
implements ControllerConverter

マスカット連携時に使用する汎用的なコントローラコンバータです。 コントローラオブジェクトは、MKControllerObjectである。 もしくはMKControllerObjectを継承したクラスである必要があります。

導入されたバージョン:
6.1

フィールドの概要
static String OBJECT_PARAM_NAME
コントローラオブジェクトのクラス名を設定するパラメータ名
コンストラクタの概要
MKControllerConverter()
メソッドの概要
ControllerObject | convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
void | destroy() MKControllerConverterを破棄します。
void | init(ControllerConverterConfig config) MKControllerConverterを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

OBJECT_PARAM_NAME

public static final String OBJECT_PARAM_NAME
コントローラオブジェクトのクラス名を設定するパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

MKControllerConverter

public MKControllerConverter()
メソッドの詳細

init

public void init(ControllerConverterConfig config)
          throws ControllerConverterException
MKControllerConverterを初期化します。

定義:
インタフェース ControllerConverter 内の init
パラメータ:
config - 初期化情報
例外:
ControllerConverterException - 初期化時に例外が発生

destroy

public void destroy()
MKControllerConverterを破棄します。

定義:
インタフェース ControllerConverter 内の destroy

convert

public ControllerObject convert(RequestInfo info)
                         throws RequestFormatException,
                                ServletException,
                                IOException
リクエスト情報をもとに入力オブジェクトを生成します。

定義:
インタフェース ControllerConverter 内の convert
パラメータ:
info - リクエスト情報
戻り値:
リクエストの内容が含まれる入力オブジェクト
例外:
RequestFormatException - リクエストのフォーマットが不正
ServletException - 変換中にServletExceptionが発生
IOException - 変換中にIOExceptionが発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MKControllerObject (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.service.controller
クラス MKControllerObject

java.lang.Object
    拡張 jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject
すべての実装インタフェース:
ControllerObject, Serializable
public class MKControllerObject
extends Object
implements ControllerObject

マスカット連携時に使用する汎用的なコントローラオブジェクトです。

関連項目:
直列化された形式

コンストラクタの概要
MKControllerObject()
MKControllerObjectを新規に生成します。
メソッドの概要
String | getComponentId() コンポーネントIDを取得します。
String | getEventId() イベントIDを取得します。
String | getLayoutId() レイアウトIDを取得します。
Document | getTelegram() 電文を取得します。
void | setComponentId(String componentId) コンポーネントIDを設定します。
void | setEventId(String eventId) イベントIDを設定します。
void | setLayoutId(String layoutId) レイアウトIDを設定します。
void | setTelegram(Document document) 電文を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MKControllerObject

public MKControllerObject()
MKControllerObjectを新規に生成します。

メソッドの詳細

getTelegram

public Document getTelegram()
電文を取得します。

戻り値:

setTelegram

public void setTelegram(Document document)
電文を設定します。

パラメータ:
document -

getComponentId

public String getComponentId()
コンポーネントIDを取得します。

戻り値:
コンポーネント

setComponentId

public void setComponentId(String componentId)
コンポーネントIDを設定します。

パラメータ:
componentId - コンポーネント

getEventId

public String getEventId()
イベントIDを取得します。

戻り値:

setEventId

public void setEventId(String eventId)
イベントIDを設定します。

パラメータ:
eventId -

getLayoutId

public String getLayoutId()
レイアウトIDを取得します。

戻り値:

setLayoutId

public void setLayoutId(String layoutId)
レイアウトIDを設定します。

パラメータ:
layoutId -
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NodePathControllerConverter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.service.controller
クラス NodePathControllerConverter

java.lang.Object
    拡張 jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter
すべての実装インタフェース:
ControllerConverter
public class NodePathControllerConverter
extends Object
implements ControllerConverter

コントローラオブジェクトに「PATH_フィールド名」となる名前の静的フィールドを定義し、 代入されるノードのパスを指定することにより、ノードの値をコントローラオブジェクトに代入します。 フィールドの型はString、またはStringの配列です。 また、コントローラオブジェクトはMKControllerObject を継承している必要があります。 以下は受信電文に対応したコントローラオブジェクトの例です。

 <?xml version="1.0" encoding="UTF-8"?>
 <sampleParam>
   <arg1>value1</arg1>
   <arg2>value2</arg2>
 </sampleParam>

 public class MKControllerObjectImpl extends MKControllerObject {

   public static final String PATH_arg1 = "/sampleParam/arg1";
   public static final String PATH_arg2 = "/sampleParam/arg2";

   private String arg1 = null;
   private String arg2 = null;

   public String getArg1() {
     return arg1;
   }

   public void setArg1(String arg1) {
     this.arg1 = arg1;
   }

   public String getArg2() {
     return arg2;
   }

   public void setArg2(String arg2) {
     this.arg2 = arg2;
   }
 }

 ノードパスが複数列を対象とする場合フィールドの型は配列です。

 <?xml version="1.0" encoding="UTF-8"?>
 <sampleParam>
   <arg>value1</arg>
   <arg>value2</arg>
   <arg>value3</arg>
 </sampleParam>

 public class ControllerObjectImpl extends MKControllerObject {

   public static final String PATH_arg = "/sampleParam/arg";

   private String[] arg = null;

   public String[] getArg() {
     return arg;
   }

   public void setArg(String[] arg) {
     this.arg = arg;
   }
 }

導入されたバージョン:
6.1

フィールドの概要
static String | NODE_PATH_PREFIX Pathを記述するフィールドのプレフィックス
static String | OBJECT_PARAM_NAME コントローラオブジェクトのクラス名を設定するパラメータ名
コンストラクタの概要
NodePathControllerConverter()
メソッドの概要
ControllerObject | convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
void | destroy() NodePathControllerConverterを破棄します。
void | init(ControllerConverterConfig config) NodePathControllerConverterを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

OBJECT_PARAM_NAME

public static final String OBJECT_PARAM_NAME
コントローラオブジェクトのクラス名を設定するパラメータ名

関連項目:
定数フィールド値

NODE_PATH_PREFIX

public static final String NODE_PATH_PREFIX
Pathを記述するフィールドのプレフィックス

関連項目:
定数フィールド値
コンストラクタの詳細

NodePathControllerConverter

public NodePathControllerConverter()
メソッドの詳細

init

public void init(ControllerConverterConfig config)
          throws ControllerConverterException
NodePathControllerConverterを初期化します。

定義:
インタフェース ControllerConverter 内の init
パラメータ:
config - 初期化情報
例外:
ControllerConverterException - 初期化時に例外が発生

destroy

public void destroy()
NodePathControllerConverterを破棄します。

定義:
インタフェース ControllerConverter 内の destroy

convert

public ControllerObject convert(RequestInfo info)
                         throws RequestFormatException,
                                ServletException,
                                IOException
リクエスト情報をもとに入力オブジェクトを生成します。

定義:
インタフェース ControllerConverter 内の convert
パラメータ:
info - リクエスト情報
戻り値:
リクエストの内容が含まれる入力オブジェクト
例外:
RequestFormatException - リクエストのフォーマットが不正
ServletException - 変換中にServletExceptionが発生
IOException - 変換中にIOExceptionが発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.extension.maskat.service.controller (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.extension.maskat.service.controller
クラス
MKControllerConverter
MKControllerObject
NodePathControllerConverter


jp.co.intra_mart.extension.maskat.service.controller (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.extension.maskat.service.controller

クラスの概要
MKControllerConverter | マスカット連携時に使用する汎用的なコントローラコンバータです。
MKControllerObject | マスカット連携時に使用する汎用的なコントローラオブジェクトです。
NodePathControllerConverter | コントローラオブジェクトに「PATH_フィールド名」となる名前の静的フィールドを定義し、 代入されるノードのパスを指定することにより、ノードの値をコントローラオブジェクトに代入します。


jp.co.intra_mart.extension.maskat.service.controller クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.extension.maskat.service.controller の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter (implements jp.co.intra_mart.framework.base.service.controller.ControllerConverter)
    • class jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject (implements jp.co.intra_mart.framework.base.service.controller.ControllerObject)
    • class jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter (implements jp.co.intra_mart.framework.base.service.controller.ControllerConverter)


パッケージ jp.co.intra_mart.extension.maskat.service.controller の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.extension.maskat.service.controller の使用

jp.co.intra_mart.extension.maskat.service.controller はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DefaultMKServiceResult (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.service
クラス DefaultMKServiceResult

java.lang.Object
    拡張 jp.co.intra_mart.extension.maskat.service.DefaultMKServiceResult
すべての実装インタフェース:
MKServiceResult, ServiceResult
public class DefaultMKServiceResult
extends Object
implements MKServiceResult

デフォルトのMKServiceResult実装です。

コンストラクタの概要
DefaultMKServiceResult(Document doc)
ドキュメントから新規に処理結果を生成します。
DefaultMKServiceResult(String xmlString)
XML文字列から新規に処理結果を生成します。
メソッドの概要
 Document getTelegram()
クライアントへ送信する電文を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DefaultMKServiceResult

public DefaultMKServiceResult(Document doc)
ドキュメントから新規に処理結果を生成します。

パラメータ:
doc - ドキュメント

DefaultMKServiceResult

public DefaultMKServiceResult(String xmlString)
                       throws MKSystemException
XML文字列から新規に処理結果を生成します。

パラメータ:
xmlString - XML文字列
例外:
MKSystemException
メソッドの詳細

getTelegram

public Document getTelegram()
クライアントへ送信する電文を取得します。

定義:
インタフェース MKServiceResult 内の getTelegram
戻り値:
送信電文
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MKErrorsResult (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.service
クラス MKErrorsResult

java.lang.Object
    拡張 jp.co.intra_mart.extension.maskat.util.MKErrors
        拡張 jp.co.intra_mart.extension.maskat.service.MKErrorsResult
すべての実装インタフェース:
MKServiceResult, ServiceResult
public class MKErrorsResult
extends MKErrors
implements MKServiceResult

マスカットにエラーを返すサービス処理結果です。

導入されたバージョン:
6.1

フィールドの概要
クラス jp.co.intra_mart.extension.maskat.util.MKErrors から継承したフィールド
ERRORS_NODE
コンストラクタの概要
MKErrorsResult()
空のErrorsResultを新規に生成します。
MKErrorsResult(MKError error)
エラー要素を設定してErrorsResultを新規に生成します。
メソッドの概要
 Document getTelegram()
クライアントへ送信するエラー電文を取得します。
クラス jp.co.intra_mart.extension.maskat.util.MKErrors から継承したメソッド
addError, getDocument, size
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MKErrorsResult

public MKErrorsResult()
空のErrorsResultを新規に生成します。

MKErrorsResult

public MKErrorsResult(MKError error)
エラー要素を設定してErrorsResultを新規に生成します。

パラメータ:
error - エラー要素
メソッドの詳細

getTelegram

public Document getTelegram()
                     throws MKSystemException
クライアントへ送信するエラー電文を取得します。

定義:
インタフェース MKServiceResult 内の getTelegram
戻り値:
送信電文
例外:
MKSystemException - 電文取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MKServiceResult (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.service
インタフェース MKServiceResult

すべてのスーパーインタフェース:
ServiceResult
既知の実装クラスの一覧:
DefaultMKServiceResult, MKErrorsResult
public interface MKServiceResult
extends ServiceResult

マスカット連携を行う処理結果です。

導入されたバージョン:
6.1

メソッドの概要
 Document getTelegram()
クライアントへ送信する電文を取得します。

メソッドの詳細

getTelegram

public Document getTelegram()
                     throws MKSystemException
クライアントへ送信する電文を取得します。

戻り値:
送信電文
例外:
MKSystemException - 電文取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MKTransition (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.service
クラス MKTransition

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.Transition
        拡張 jp.co.intra_mart.framework.base.service.DefaultTransition
            拡張 jp.co.intra_mart.extension.maskat.service.MKTransition
public class MKTransition
extends DefaultTransition

マスカットに電文を送信するトランジションです。

導入されたバージョン:
6.1

コンストラクタの概要
MKTransition()
メソッドの概要
 void transfer()
サービス処理結果に格納されたドキュメントをレスポンスとして送信します。
クラス jp.co.intra_mart.framework.base.service.DefaultTransition から継承したメソッド
getInputErrorPage, getNextPage, getServiceErrorPage, getSystemErrorPage, setInformation
クラス jp.co.intra_mart.framework.base.service.Transition から継承したメソッド
getApplication, getEntity, getNextPagePath, getNextPagePath, getRequest, getResponse, getResult, getService, getServiceManager, getSessionObject, setRequest, setResponse, setResult, setServiceManager
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MKTransition

public MKTransition()
メソッドの詳細

transfer

public void transfer()
              throws SystemException
サービス処理結果に格納されたドキュメントをレスポンスとして送信します。 サービス処理結果はjp.co.intra_mart.extension.maskat.serviceMKServiceResultの実装クラスである必要があります。

オーバーライド:
クラス DefaultTransition 内の transfer
例外:
SystemException - システム例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.extension.maskat.service (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.extension.maskat.service
インタフェース
MKServiceResult
クラス
DefaultMKServiceResult
MKErrorsResult
MKTransition


jp.co.intra_mart.extension.maskat.service (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.extension.maskat.service

インタフェースの概要
MKServiceResult マスカット連携を行う処理結果です。

クラスの概要
DefaultMKServiceResult | デフォルトのMKServiceResult実装です。
MKErrorsResult | マスカットにエラーを返すサービス処理結果です。
MKTransition | マスカットに電文を送信するトランジションです。


jp.co.intra_mart.extension.maskat.service クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.extension.maskat.service の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.extension.maskat.service.DefaultMKServiceResult (implements jp.co.intra_mart.extension.maskat.service.MKServiceResult)
    • class jp.co.intra_mart.extension.maskat.util.MKErrors
      • class jp.co.intra_mart.extension.maskat.service.MKErrorsResult (implements jp.co.intra_mart.extension.maskat.service.MKServiceResult)
    • class jp.co.intra_mart.framework.base.service.Transition
      • class jp.co.intra_mart.framework.base.service.DefaultTransition
        • class jp.co.intra_mart.extension.maskat.service.MKTransition

インタフェース階層

  • interface jp.co.intra_mart.framework.base.service.ServiceResult
    • interface jp.co.intra_mart.extension.maskat.service.MKServiceResult


パッケージ jp.co.intra_mart.extension.maskat.service の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.extension.maskat.service の使用

jp.co.intra_mart.extension.maskat.service を使用しているパッケージ
jp.co.intra_mart.extension.maskat.service

jp.co.intra_mart.extension.maskat.service により使用される jp.co.intra_mart.extension.maskat.service のクラス
MKServiceResult
マスカット連携を行う処理結果です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.extension.maskat.util.MKConst の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.extension.maskat.util.MKConst の使用

jp.co.intra_mart.extension.maskat.util.MKConst はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.extension.maskat.util.MKError の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.extension.maskat.util.MKError の使用

MKError を使用しているパッケージ
jp.co.intra_mart.extension.maskat.service
jp.co.intra_mart.extension.maskat.util

jp.co.intra_mart.extension.maskat.service での MKError の使用

MKError 型のパラメータを持つ jp.co.intra_mart.extension.maskat.service のコンストラクタ
MKErrorsResult(MKError error)
エラー要素を設定してErrorsResultを新規に生成します。

jp.co.intra_mart.extension.maskat.util での MKError の使用

MKError 型のパラメータを持つ jp.co.intra_mart.extension.maskat.util のメソッド
 void MKErrors.addError(MKError error)
エラー要素を追加します。

MKError 型のパラメータを持つ jp.co.intra_mart.extension.maskat.util のコンストラクタ
MKErrors(MKError error)
エラー要素を設定してMKErrorsを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.extension.maskat.util.MKErrors の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.extension.maskat.util.MKErrors の使用

MKErrors を使用しているパッケージ
jp.co.intra_mart.extension.maskat.service

jp.co.intra_mart.extension.maskat.service での MKErrors の使用

jp.co.intra_mart.extension.maskat.service での MKErrors のサブクラス
 class MKErrorsResult
マスカットにエラーを返すサービス処理結果です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.extension.maskat.util.XMLUtil の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.extension.maskat.util.XMLUtil の使用

jp.co.intra_mart.extension.maskat.util.XMLUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


MKConst (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.util
クラス MKConst

java.lang.Object
    拡張 jp.co.intra_mart.extension.maskat.util.MKConst
public class MKConst
extends Object

マスカット連携に使用される定数値です。

導入されたバージョン:
6.1

フィールドの概要
static String | MASKAT_COMPONENT_ID_HEAD マスカット・コンポーネントIDのヘッダ属性
static String | MASKAT_DEFAULT_COMPONENT_ID デフォルトのコンポーネントID
static String | MASKAT_EVENT_ID_HEAD マスカット・イベントIDのヘッダ属性
static String | MASKAT_LAYOUT_ID_HEAD マスカット・レイアウトIDのヘッダ属性
コンストラクタの概要
MKConst()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

MASKAT_LAYOUT_ID_HEAD

public static final String MASKAT_LAYOUT_ID_HEAD
マスカット・レイアウトIDのヘッダ属性

関連項目:
定数フィールド値

MASKAT_COMPONENT_ID_HEAD

public static final String MASKAT_COMPONENT_ID_HEAD
マスカット・コンポーネントIDのヘッダ属性

関連項目:
定数フィールド値

MASKAT_EVENT_ID_HEAD

public static final String MASKAT_EVENT_ID_HEAD
マスカット・イベントIDのヘッダ属性

関連項目:
定数フィールド値

MASKAT_DEFAULT_COMPONENT_ID

public static final String MASKAT_DEFAULT_COMPONENT_ID
デフォルトのコンポーネントID

関連項目:
定数フィールド値
コンストラクタの詳細

MKConst

public MKConst()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MKError (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.util
クラス MKError

java.lang.Object
    拡張 jp.co.intra_mart.extension.maskat.util.MKError
public class MKError
extends Object

マスカットのエラー情報を保持します。

導入されたバージョン:
6.1

フィールドの概要
static String | ERROR_CODE_NODE errorCodeのノード名
static String | ERROR_NODE error要素のノード名
static String | INFO_NODE infoのノード名
static String | MESSAGE_CODE_NODE messageCodeのノード名
static String | MESSAGE_NODE messageのノード名
static String | SYSTEM_ERROR_MESSAGE_NODE systemErrorMessageのノード名
コンストラクタの概要
MKError()
MKErrorを新規に生成します。
メソッドの概要
String | getErrorCode() errorCodeを取得します。
String | getInfo() infoを取得します。
String | getMessage() messageを取得します。
String | getMessageCode() messageCodeを取得します。
String | getSystemErrorMessage() systemErrorMessageを取得します。
void | setErrorCode(String errorCode) errorCodeを設定します。
void | setInfo(String info) infoを設定します。
void | setMessage(String message) messageを設定します。
void | setMessageCode(String messageCode) messageCodeを設定します。
void | setSystemErrorMessage(String systemErrorMessage) systemErrorMessageを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ERROR_NODE

public static String ERROR_NODE
error要素のノード名

ERROR_CODE_NODE

public static String ERROR_CODE_NODE
errorCodeのノード名

MESSAGE_CODE_NODE

public static String MESSAGE_CODE_NODE
messageCodeのノード名

MESSAGE_NODE

public static String MESSAGE_NODE
messageのノード名

INFO_NODE

public static String INFO_NODE
infoのノード名

SYSTEM_ERROR_MESSAGE_NODE

public static String SYSTEM_ERROR_MESSAGE_NODE
systemErrorMessageのノード名

コンストラクタの詳細

MKError

public MKError()
MKErrorを新規に生成します。

メソッドの詳細

getErrorCode

public String getErrorCode()
errorCodeを取得します。

戻り値:
errorCode

setErrorCode

public void setErrorCode(String errorCode)
errorCodeを設定します。

パラメータ:
errorCode -

getInfo

public String getInfo()
infoを取得します。

戻り値:
info

setInfo

public void setInfo(String info)
infoを設定します。

パラメータ:
info -

getMessage

public String getMessage()
messageを取得します。

戻り値:
message

setMessage

public void setMessage(String message)
messageを設定します。

パラメータ:
message -

getMessageCode

public String getMessageCode()
messageCodeを取得します。

戻り値:
messageCode

setMessageCode

public void setMessageCode(String messageCode)
messageCodeを設定します。

パラメータ:
messageCode -

getSystemErrorMessage

public String getSystemErrorMessage()
systemErrorMessageを取得します。

戻り値:
systemErrorMessage

setSystemErrorMessage

public void setSystemErrorMessage(String systemErrorMessage)
systemErrorMessageを設定します。

パラメータ:
systemErrorMessage -
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MKErrors (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.util
クラス MKErrors

java.lang.Object
    拡張 jp.co.intra_mart.extension.maskat.util.MKErrors
直系の既知のサブクラス:
MKErrorsResult
public class MKErrors
extends Object

マスカットのエラー要素群を保持します。

フィールドの概要
static String ERRORS_NODE
errors要素のノード名
コンストラクタの概要
MKErrors()
空のMKErrorsを新規に生成します。
MKErrors(MKError error)
エラー要素を設定してMKErrorsを新規に生成します。
メソッドの概要
void | addError(MKError error) エラー要素を追加します。
Document | getDocument() エラー要素群のドキュメントを取得します。
int | size() errorの個数を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ERRORS_NODE

public static String ERRORS_NODE
errors要素のノード名

コンストラクタの詳細

MKErrors

public MKErrors()
空のMKErrorsを新規に生成します。

MKErrors

public MKErrors(MKError error)
エラー要素を設定してMKErrorsを新規に生成します。

パラメータ:
error - エラー要素
メソッドの詳細

addError

public void addError(MKError error)
エラー要素を追加します。

パラメータ:
error - エラー要素

getDocument

public Document getDocument()
                     throws MKRuntimeException
エラー要素群のドキュメントを取得します。

戻り値:
ドキュメント
例外:
MKRuntimeExceptionドキュメント取得時に例外が発生
MKRuntimeException

size

public int size()
errorの個数を取得します。

戻り値:
エラー要素の個数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.extension.maskat.util (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.extension.maskat.util
クラス
MKConst
MKError
MKErrors
XMLUtil


jp.co.intra_mart.extension.maskat.util (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.extension.maskat.util

クラスの概要
MKConst | マスカット連携に使用される定数値です。
MKError | マスカットのエラー情報を保持します。
MKErrors | マスカットのエラー要素群を保持します。
XMLUtil | XMLのユーティリティクラスです。


jp.co.intra_mart.extension.maskat.util クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.extension.maskat.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.extension.maskat.util.MKConst
    • class jp.co.intra_mart.extension.maskat.util.MKError
    • class jp.co.intra_mart.extension.maskat.util.MKErrors
    • class jp.co.intra_mart.extension.maskat.util.XMLUtil


パッケージ jp.co.intra_mart.extension.maskat.util の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.extension.maskat.util の使用

jp.co.intra_mart.extension.maskat.util を使用しているパッケージ
jp.co.intra_mart.extension.maskat.service
jp.co.intra_mart.extension.maskat.util

jp.co.intra_mart.extension.maskat.service により使用される jp.co.intra_mart.extension.maskat.util のクラス
MKError
マスカットのエラー情報を保持します。
MKErrors
マスカットのエラー要素群を保持します。

jp.co.intra_mart.extension.maskat.util により使用される jp.co.intra_mart.extension.maskat.util のクラス
MKError
マスカットのエラー情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


XMLUtil (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.util
クラス XMLUtil

java.lang.Object
    拡張 jp.co.intra_mart.extension.maskat.util.XMLUtil
public class XMLUtil
extends Object

XMLのユーティリティクラスです。

コンストラクタの概要
XMLUtil()
メソッドの概要
static String | getXMLString(Document doc) XML文字列を取得します。
static Document | readXML(InputStream in) ストリームからXMLを読み込み、ドキュメントを生成します。
static void | writeXML(Document doc, OutputStream out) ドキュメントをストリームに出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

XMLUtil

public XMLUtil()
メソッドの詳細

getXMLString

public static String getXMLString(Document doc)
                           throws MKRuntimeException
XML文字列を取得します。

戻り値:
XML文字列
例外:
MKRuntimeException - XML取得時に例外が発生

writeXML

public static void writeXML(Document doc,
                            OutputStream out)
                     throws MKRuntimeException
ドキュメントをストリームに出力します。

パラメータ:
doc - ドキュメント
out - 出力
例外:
MKRuntimeException - ストリーム出力時に例外が発生。

readXML

public static Document readXML(InputStream in)
                        throws MKRuntimeException
ストリームからXMLを読み込み、ドキュメントを生成します。

パラメータ:
in - 入力
戻り値:
doc ドキュメント
例外:
MKRuntimeException - ドキュメント生成時に例外が発生。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.acssecurity.AccountManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.acssecurity.AccountManager の使用

jp.co.intra_mart.foundation.acssecurity.AccountManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.acssecurity.AcsData の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.acssecurity.AcsData の使用

jp.co.intra_mart.foundation.acssecurity.AcsData はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.acssecurity.AcssecurityException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.acssecurity.AcssecurityException の使用

AcssecurityException を使用しているパッケージ
jp.co.intra_mart.foundation.acssecurity アクセスセキュリティモジュールを利用するためのクラスを提供します。

jp.co.intra_mart.foundation.acssecurity での AcssecurityException の使用

AcssecurityException をスローする jp.co.intra_mart.foundation.acssecurity のメソッド
 void RoleManager.setData(Map datas)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
 void RoleManager.setData(Map datas, boolean isTransaction)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
 boolean RoleManager.contains(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.contains(String)に置き換えられました。
 int RoleManager.count()
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.count()に置き換えられました。
 Vector RoleManager.getIDs()
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRoleIds()に置き換えられました。
 Map RoleManager.getData(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRole(String)に置き換えられました。
 void RoleManager.delData(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
 void RoleManager.delData(String roleId, boolean isTransaction)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
 String RoleManager.getIdByName(String roleName)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.searchRolesByName(String)に置き換えられました。
 String[] RoleManager.getListData(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getAllSubRoleIds(String)に置き換えられました。
 String[] RoleManager.getParentData(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getParentRoleIds(String)に置き換えられました。
 void AccountManager.setData(Map datas)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.addAcount(Account) およびupdateAccount(Account)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.registerAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.domain.user.UserManagerを利用して、更新してください。
 void AccountManager.setData(Map datas, boolean isTransaction)
推奨されていません。
 boolean AccountManager.contains(String userId)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.contains(String)に置き換えられました。
 int AccountManager.count()
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.count()に置き換えられました。
 Vector AccountManager.getIDs()
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getUserIds()に置き換えられました。
 Map AccountManager.getData(String userId)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getAccount(String)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.isRegisteredAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.model.user.UserMapperを利用して取得してください。
 void AccountManager.delData(String uid)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。
 void AccountManager.delData(String uid, boolean isTransaction)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.acssecurity.Logingp の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.acssecurity.Logingp の使用

jp.co.intra_mart.foundation.acssecurity.Logingp はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.acssecurity.RoleManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.acssecurity.RoleManager の使用

jp.co.intra_mart.foundation.acssecurity.RoleManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AccountManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.acssecurity
クラス AccountManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.acssecurity.AccountManager
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManagerに置き換えられました。

public class AccountManager
extends Object

ログインユーザ情報を操作します。

コンストラクタの概要
AccountManager(String login_grp)
推奨されていません。
メソッドの概要
 boolean contains(String userId)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.contains(String)に置き換えられました。
 int count()
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.count()に置き換えられました。
 void delData(String uid)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。
 void delData(String uid, boolean isTransaction)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。
 Map getData(String userId)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getAccount(String)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.isRegisteredAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.model.user.UserMapperを利用して取得してください。
 Vector getIDs()
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getUserIds()に置き換えられました。
 void setData(Map datas)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.addAcount(Account) およびupdateAccount(Account)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.registerAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.domain.user.UserManagerを利用して、更新してください。
 void setData(Map datas, boolean isTransaction)
推奨されていません。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AccountManager

public AccountManager(String login_grp)
推奨されていません。

コンストラクタ

パラメータ:
login_grp - ログイングループID
メソッドの詳細

setData

public void setData(Map datas)
             throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.addAcount(Account) およびupdateAccount(Account)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.registerAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.domain.user.UserManagerを利用して、更新してください。

ユーザデータを登録する

DBを使用する場合,このメソッドは内部でDBトランザクションを発行します。 このメソッドをDBトランザクション内で使用しないで下さい。

パラメータ:
datas - ユーザデータ

例外:
AcssecurityException -

引数 datas(Map)の内容
      (key == value)

         以下、IMISに登録されるデータ。
         DBを使用する場合,（＊）印のデータはIMISとDBの同期をとる。

         id      = ユーザID(String)[必須]（＊）
         pwd     = パスワード(String)
         mpwd    = モバイル用パスワード(String)
         name    = ユーザ名(String)[必須]（＊）
         madrs   = メールアドレス(String)（＊）
         mbladrs = モバイル用メールアドレス(String)（＊）
         explan  = 説明(String)
         vldDate = 有効期限(Double(ミリ秒))
         roles   = ロールIDの配列(String[])
         license = ライセンス(Boolean あり true/なし false)
         apps    = アプリケーションロール(String[]) （V4.0.0以上）

         以下、DBにのみ登録されるデータ。
                    (get()メソッドでは取得できない)
         kana    = ユーザ名カナ(String)
         eng     = ユーザ名英字(String)
         tel     = 電話番号(String)
         hndy    = 携帯電話番号(String)
         fax     = FAX番号(String)
         extens  = 内線電話番号(String)
         exFax   = 内線FAX(String)
         cntry_cd =  国コード(String)
         zip     = 郵便番号(String)
         adrs    = 住所(String)
         madrs2  = メールアドレス２(String)
         url     = URL(String)
         note    = 備考(String)
         mainGp  = 主所属グループCD(String)
         groups  = 所属グループCDの配列(String[])
         その他 各アプリに依存(String or Double or Boolean)

        引数に指定したユーザIDが既に存在していた場合、上書き(前のデータはなくなり、引数データを追加)する。

setData

public void setData(Map datas,
                    boolean isTransaction)
             throws AcssecurityException
推奨されていません。

ユーザデータを登録する

パラメータ:
datas - ユーザデータ

isTransaction - DBトランザクションフラグ（true このメソッドの中でDBトランザクションを張る。／false このメソッドの中でDBトランザクションを張らない。）

例外:
AcssecurityException -

     引数 datas(Map)の内容

      (key == value)

         以下、IMISに登録されるデータ。
         DBを使用する場合,（＊）印のデータはIMISとDBの同期をとる。

         id      = ユーザID(String)[必須]（＊）
         pwd     = パスワード(String)
         mpwd    = モバイル用パスワード(String)
         name    = ユーザ名(String)[必須]（＊）
         madrs   = メールアドレス(String)（＊）
         mbladrs = モバイル用メールアドレス(String)（＊）
         explan  = 説明(String)
         vldDate = 有効期限(Double(ミリ秒))
         roles   = ロールIDの配列(String[])
         license = ライセンス(Boolean あり true/なし false)
         apps    = アプリケーションロール(String[]) （V4.0.0以上）

         以下、DBにのみ登録されるデータ。
                    (get()メソッドでは取得できない)
         kana    = ユーザ名カナ(String)
         eng     = ユーザ名英字(String)
         tel     = 電話番号(String)
         hndy    = 携帯電話番号(String)
         fax     = FAX番号(String)
         extens  = 内線電話番号(String)
         exFax   = 内線FAX(String)
         cntry_cd =  国コード(String)
         zip     = 郵便番号(String)
         adrs    = 住所(String)
         madrs2  = メールアドレス２(String)
         url     = URL(String)
         note    = 備考(String)
         mainGp  = 主所属グループCD(String)
         groups  = 所属グループCDの配列(String[])
         その他 各アプリに依存(String or Double or Boolean)

        引数に指定したユーザIDが既に存在していた場合、上書きする。

contains

public boolean contains(String userId)
                 throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.contains(String)に置き換えられました。

ユーザデータの存在チェック

パラメータ:
userId - ユーザID
戻り値:
ある true / ない false
例外:
AcssecurityException

count

public int count()
          throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.count()に置き換えられました。

ユーザデータの登録数を取得

戻り値:
登録ユーザ数
例外:
AcssecurityException

getIDs

public Vector getIDs()
              throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getUserIds()に置き換えられました。

ユーザIDをすべて取得する

戻り値:
ユーザIDの配列(データがない場合は空の配列)
例外:
AcssecurityException

getData

public Map getData(String userId)
            throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getAccount(String)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.isRegisteredAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.model.user.UserMapperを利用して取得してください。

ユーザデータの取得

パラメータ:
userId - ユーザID
戻り値:
ユーザ情報（ユーザ情報がなければnull）

     戻り値 (Map)の内容

      (key == value)

         id      = ユーザID(String)
         pwd     = パスワード(String)
         mpwd    = モバイル用パスワード(String)
         name    = ユーザ名(String)[必須]
         madrs   = メールアドレス(String)
         mbladrs = モバイル用メールアドレス(String)
         explan  = 説明(String)
         vldDate = 有効期限(Double(ミリ秒))
         roles   = ロールIDの配列(String[])
         license = ライセンス(Boolean あり true/なし false)
         apps    = アプリケーションロール(String[]) （V4.0.0以上）
例外:
AcssecurityException

delData

public void delData(String uid)
             throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。

ユーザデータを削除する

DBを使用する場合,このメソッドは内部でDBトランザクションを発行します。 このメソッドをDBトランザクション内で使用しないで下さい。

例外:
AcssecurityException

delData

public void delData(String uid,
                    boolean isTransaction)
             throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。

ユーザデータを削除する

パラメータ:
isTransaction - DBトランザクションフラグ（true このメソッドの中でDBトランザクションを張る。／false このメソッドの中でDBトランザクションを張らない。）

例外:
AcssecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AcsData (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.acssecurity
クラス AcsData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.acssecurity.AcsData

public class AcsData
extends Object

ロール、メニュー、メッセージ、アカウント、バッチ、リンク データをインポート／エクスポートします。

※インポート／エクスポート のフォーマットは、system/config/data/format_readme.txtを参照して下さい。

コンストラクタの概要
AcsData()
推奨されていません。
メソッドの概要
static Number acntFromDBToIS(String login_grp)
推奨されていません。 代替えメソッドはありません。
static Number acntFromISToDB(String login_grp)
推奨されていません。 代替えメソッドはありません。
static Number dbConsistChk(String login_grp)
推奨されていません。 代替えメソッドはありません。
static Number delAllAccount(String login_grp)
推奨されていません。 AccountManager.deleteAccounts()に置き換えられました。
static Number delAllLink(String login_grp)
推奨されていません。 代替えメソッドはありません。
static Number delAllMenu(String login_grp)
推奨されていません。 MenuManager.deleteMenuItems()に置き換えられました。
static Number delAllMessage(String login_grp)
推奨されていません。 代替えメソッドはありません。
static Number delAllRole(String login_grp)
推奨されていません。 RoleManager.deleteRoles()に置き換えられました。
static Number delAllSchedule(String login_grp)
推奨されていません。 BatchManager.deleteBatches()に置き換えられました。
static Number getAccount(String login_grp, String path)
推奨されていません。 AccountManager.exportData(String category, OutputStream outputStream)に置き換えられました。
static Number getLink(String login_grp, String path)
推奨されていません。 代替えメソッドはありません。
static Number getMenu(String login_grp, String path)
推奨されていません。 MenuManager.exportData(String category, OutputStream outputStream)に置き換えられました。
static Number getMessage(String login_grp, String path)
推奨されていません。 代替えメソッドはありません。
static Number getRole(String login_grp, String path)
推奨されていません。 RoleManager.exportData(String category, OutputStream outputStream)に置き換えられました。
static Number getSchedule(String login_grp, String path)
推奨されていません。 BatchManager.exportData(String category, OutputStream outputStream)に置き換えられました。
static Number setAccount(String login_grp, String path)
推奨されていません。 AccountManager.importData(String category, InputStream inputStream)に置き換えられました。
static Number setLink(String login_grp, String path)
推奨されていません。 代替えメソッドはありません。
static Number setMenu(String login_grp, String path)
推奨されていません。 MenuManager.importData(String category, InputStream inputStream)に置き換えられました。
static Number setMessage(String login_grp, String path)
推奨されていません。 代替えメソッドはありません。
static Number setRole(String login_grp, String path)
推奨されていません。 RoleManager.importData(String category, InputStream inputStream)に置き換えられました。
static Number setSchedule(String login_grp, String path)
推奨されていません。 BatchManager.importData(String category, InputStream inputStream)に置き換えられました。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AcsData

public AcsData()
推奨されていません。
メソッドの詳細

setRole

public static Number setRole(String login_grp,
                             String path)
推奨されていません。 RoleManager.importData(String category, InputStream inputStream)に置き換えられました。

ロールデータをインポートする

このメソッドは同期をとりません。複数のリクエストから同時に 実行されるような場所には使用しないで下さい。 指定のファイル内のロールデータを Infomation Server へ登録します。 データは第1引数で指定したログイングループに登録されます。 ファイルは File Server 上にある必要があります。 第2引数のデータファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（imart_error.log）に出力されます。 (指定のフォーマットにそぐわないデータがある場合、処理が遅くなります。) 既に同一のロールIDがシステムに登録されている場合、上書きされます。

パラメータ:
login_grp - ログイングループID
path - データファイルパス
戻り値:
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正
3： システムエラー
6： パスがディレクトリである

setMenu

public static Number setMenu(String login_grp,
                             String path)
推奨されていません。 MenuManager.importData(String category, InputStream inputStream)に置き換えられました。

メニューデータをインポートする

このメソッドは同期をとりません。複数のリクエストから同時に 実行されるような場所には使用しないで下さい。 指定のファイル内のロールデータを Infomation Server へ登録します。 データは第1引数で指定したログイングループに登録されます。 ファイルは File Server 上にある必要があります。 第2引数のデータファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（imart_error.log）に出力されます。 (指定のフォーマットにそぐわないデータがある場合、処理が遅くなります。) 既に同一のロールIDがシステムに登録されている場合、上書きされます。

パラメータ:
login_grp - ログイングループID
path - データファイルパス
戻り値:
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正
3：システムエラー
6：パスがディレクトリである

setMessage

public static Number setMessage(String login_grp,
                                String path)
推奨されていません。 代替えメソッドはありません。

メッセージデータをインポートする

このメソッドは同期をとりません。複数のリクエストから同時に 実行されるような場所には使用しないで下さい。 指定のファイル内のロールデータを Infomation Server へ登録します。 データは第1引数で指定したログイングループに登録されます。 ファイルは File Server 上にある必要があります。 第2引数のデータファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（imart_error.log）に出力されます。 (指定のフォーマットにそぐわないデータがある場合、処理が遅くなります。) 既に同一のロールIDがシステムに登録されている場合、上書きされます。

パラメータ:
login_grp - ログイングループID
path - データファイルパス
戻り値:
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正

setAccount

public static Number setAccount(String login_grp,
                                String path)
推奨されていません。 AccountManager.importData(String category, InputStream inputStream)に置き換えられました。

アカウントデータをインポートする

このメソッドは同期をとりません。複数のリクエストから同時に 実行されるような場所には使用しないで下さい。 指定のファイル内のロールデータを Infomation Server へ登録します。 データは第1引数で指定したログイングループに登録されます。 ファイルは File Server 上にある必要があります。 第2引数のデータファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（imart_error.log）に出力されます。 (指定のフォーマットにそぐわないデータがある場合、処理が遅くなります。) 既に同一のロールIDがシステムに登録されている場合、上書きされます。

パラメータ:
login_grp - ログイングループID
path - データファイルパス
戻り値:
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正
3：システムエラー
6：パスがディレクトリである

setSchedule

public static Number setSchedule(String login_grp,
                                 String path)
推奨されていません。 BatchManager.importData(String category, InputStream inputStream)に置き換えられました。

バッチデータをインポートする

このメソッドは同期をとりません。複数のリクエストから同時に 実行されるような場所には使用しないで下さい。 指定のファイル内のロールデータを Infomation Server へ登録します。 データは第1引数で指定したログイングループに登録されます。 ファイルは File Server 上にある必要があります。 第2引数のデータファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（imart_error.log）に出力されます。 (指定のフォーマットにそぐわないデータがある場合、処理が遅くなります。) 既に同一のロールIDがシステムに登録されている場合、上書きされます。

パラメータ:
login_grp - ログイングループID
path - データファイルパス
戻り値:
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正
3：システムエラー
6：パスがディレクトリである

setLink

public static Number setLink(String login_grp,
                             String path)
推奨されていません。 代替えメソッドはありません。

リンクデータをインポートする

このメソッドは同期をとりません。複数のリクエストから同時に 実行されるような場所には使用しないで下さい。 指定のファイル内のロールデータを Infomation Server へ登録します。 データは第1引数で指定したログイングループに登録されます。 ファイルは File Server 上にある必要があります。 第2引数のデータファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（imart_error.log）に出力されます。 (指定のフォーマットにそぐわないデータがある場合、処理が遅くなります。) 既に同一のロールIDがシステムに登録されている場合、上書きされます。

パラメータ:
login_grp - ログイングループID
path - データファイルパス
戻り値:
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正

getRole

public static Number getRole(String login_grp,
                             String path)
推奨されていません。 RoleManager.exportData(String category, OutputStream outputStream)に置き換えられました。

ロール情報をエクスポートする

指定のログイングループ内のロールデータを ファイルへ出力します。 ファイルは File Server 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。

パラメータ:
login_grp - ログイングループID
path - 出力ファイルパス
戻り値:
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
3：エクスポートするデータがない
4：ファイルへの書き込みに失敗
5：引数が不正
6：パスがディレクトリである。

getMenu

public static Number getMenu(String login_grp,
                             String path)
推奨されていません。 MenuManager.exportData(String category, OutputStream outputStream)に置き換えられました。

メニュー情報をエクスポートする

指定のログイングループ内のロールデータを ファイルへ出力します。 ファイルは File Server 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。

パラメータ:
login_grp - ログイングループID
path - 出力ファイルパス
戻り値:
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
3：エクスポートするデータがない
4：ファイルへの書き込みに失敗
5：引数が不正
6：パスがディレクトリである。

getMessage

public static Number getMessage(String login_grp,
                                String path)
推奨されていません。 代替えメソッドはありません。

メッセージ情報をエクスポートする

指定のログイングループ内のロールデータを ファイルへ出力します。 ファイルは File Server 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。

パラメータ:
login_grp - ログイングループID
path - 出力ファイルパス
戻り値:
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
3：エクスポートするデータがない
4：ファイルへの書き込みに失敗
5：引数が不正
6：パスがディレクトリである。

getAccount

public static Number getAccount(String login_grp,
                                String path)
推奨されていません。 AccountManager.exportData(String category, OutputStream outputStream)に置き換えられました。

アカウント情報をエクスポートする

指定のログイングループ内のロールデータを ファイルへ出力します。 ファイルは File Server 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。

パラメータ:
login_grp - ログイングループID
path - 出力ファイルパス
戻り値:
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
3：エクスポートするデータがない
4：ファイルへの書き込みに失敗
5：引数が不正
6：パスがディレクトリである。

getSchedule

public static Number getSchedule(String login_grp,
                                 String path)
推奨されていません。 BatchManager.exportData(String category, OutputStream outputStream)に置き換えられました。

バッチ情報をエクスポートする

指定のログイングループ内のロールデータを ファイルへ出力します。 ファイルは File Server 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。

パラメータ:
login_grp - ログイングループID
path - 出力ファイルパス
戻り値:
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
3：エクスポートするデータがない
4：ファイルへの書き込みに失敗
5：引数が不正
6：パスがディレクトリである。

getLink

public static Number getLink(String login_grp,
                             String path)
推奨されていません。 代替えメソッドはありません。

リンク情報をエクスポートする

指定のログイングループ内のロールデータを ファイルへ出力します。 ファイルは File Server 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。

パラメータ:
login_grp - ログイングループID
path - 出力ファイルパス
戻り値:
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
3：エクスポートするデータがない
4：ファイルへの書き込みに失敗
5：引数が不正

delAllRole

public static Number delAllRole(String login_grp)
推奨されていません。 RoleManager.deleteRoles()に置き換えられました。

ロール情報を全て削除する

指定のログイングループ内のロールデータを 全て削除します。

パラメータ:
login_grp - ログイングループID
戻り値:
0：削除成功
2：引数が不正
3: システムエラー

delAllMenu

public static Number delAllMenu(String login_grp)
推奨されていません。 MenuManager.deleteMenuItems()に置き換えられました。

メニュー情報を全て削除する

指定のログイングループ内のロールデータを 全て削除します。

パラメータ:
login_grp - ログイングループID
戻り値:
0：削除成功
2：引数が不正
3: システムエラー

delAllMessage

public static Number delAllMessage(String login_grp)
推奨されていません。 代替えメソッドはありません。

メッセージ情報を全て削除する

指定のログイングループ内のロールデータを 全て削除します。

パラメータ:
login_grp - ログイングループID
戻り値:
0：削除成功
2：引数が不正

delAllAccount

public static Number delAllAccount(String login_grp)
推奨されていません。 AccountManager.deleteAccounts()に置き換えられました。

アカウント情報を全て削除する

指定のログイングループ内のロールデータを 全て削除します。

パラメータ:
login_grp - ログイングループID
戻り値:
0：削除成功
2：引数が不正

delAllSchedule

public static Number delAllSchedule(String login_grp)
推奨されていません。 BatchManager.deleteBatches()に置き換えられました。

バッチ情報を全て削除する

指定のログイングループ内のロールデータを 全て削除します。

パラメータ:
login_grp - ログイングループID
戻り値:
0：削除成功
2：引数が不正

delAllLink

public static Number delAllLink(String login_grp)
推奨されていません。 代替えメソッドはありません。

リンク情報を全て削除する

指定のログイングループ内のロールデータを 全て削除します。

パラメータ:
login_grp - ログイングループID
戻り値:
0：削除成功
2：引数が不正

dbConsistChk

public static Number dbConsistChk(String login_grp)
推奨されていません。 代替えメソッドはありません。

DBとInfomationサーバとのアカウント情報整合性チェック

DBとInfomationサーバのアカウントデータの数があっているかチェックします。

パラメータ:
login_grp - ログイングループID
戻り値:
0：不整合なし
1：ＤＢにデータが不足している
2：ＤＢのデータが多い
3：DBに接続できない。またはDBにテーブル(b_m_user)がない。
4：引数が不正

acntFromISToDB

public static Number acntFromISToDB(String login_grp)
推奨されていません。 代替えメソッドはありません。

Infomationサーバのアカウント情報をDBへ入れる

このメソッドは同期をとりません。複数のリクエストから同時に 実行されるような場所には使用しないで下さい。 このメソッドは内部でDBトランザクションを発行しています。このメソッドを トランザクション内で使用しないで下さい。 このメソッドは登録しているユーザ数に処理時間が依存します。サーバ環境にも よりますが、数分から数十分処理時間がかかる場合があります。 Infomationサーバのアカウント情報をDBのユーザ管理テーブルへ入れます。 既にDBに登録してあるユーザは処理しません。 （Infomationサーバに存在し、DBにないユーザだけをDBに 追加します。DBの既存データの更新は行いません。）

パラメータ:
login_grp - ログイングループID
戻り値:
0：登録成功
1：DBに接続できない。またはDBにテーブル(b_m_user)がない。
2：引数が不正

acntFromDBToIS

public static Number acntFromDBToIS(String login_grp)
推奨されていません。 代替えメソッドはありません。

DBのアカウント情報をInfomationサーバへ入れる

このメソッドは同期をとりません。複数のリクエストから同時に 実行されるような場所には使用しないで下さい。 このメソッドは登録しているユーザ数に処理時間が依存します。サーバ環境にも よりますが、数分から数十分処理時間がかかる場合があります。 DBのユーザ管理テーブルのアカウント情報をInfomationサーバへ入れます。 既にInfomationサーバに登録してあるユーザは処理しません。 （DBに存在し、InfomationサーバにないユーザだけをInfomationサーバに 追加します。Infomationサーバの既存データの更新は行いません。） ユーザIDをパスワードとして登録します。 そのとき、ユーザIDが14桁を越えている場合は15桁目以降をカットします。 i-modeパスワードは登録しません。 ライセンスなしで登録します。 有効期限は無期限で登録します。 ロール情報は登録しません。

パラメータ:
login_grp - ログイングループID
戻り値:
0：登録成功
1：DBに接続できない。またはDBにテーブル(b_m_user)がない。
2：引数が不正
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AcssecurityException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.acssecurity
クラス AcssecurityException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.acssecurity.AcssecurityException
すべての実装インタフェース:
Serializable
public class AcssecurityException
extends Exception

アクセスセキュリティ情報操作時にエラーが発生した場合にスローされます。

関連項目:
直列化された形式

メソッドの概要
int | getCode()
String | getMessage()
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

メソッドの詳細

getMessage

public String getMessage()

getCode

public int getCode()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Logingp (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.acssecurity
クラス Logingp

java.lang.Object
    拡張 jp.co.intra_mart.foundation.acssecurity.Logingp

public class Logingp
extends Object

ログイングループ情報を操作します。

コンストラクタの概要
Logingp(String login_grp)
推奨されていません。 LoginGroupManagerに置き換えられました。
メソッドの概要
static Number count()
推奨されていません。 LoginGroupManager.countLoginGroups()に置き換えられました。
 Boolean del(String key)
推奨されていません。 代替えメソッドはありません。
static List entries()
推奨されていません。 LoginGroupManager.getLoginGroupIds()に置き換えられました。
 Object get(String key)
推奨されていません。 代替えメソッドはありません。
static Boolean isGroup(String login_grp)
推奨されていません。 代替えメソッドはありません。
 Boolean set(String key, Number value)
推奨されていません。 代替えメソッドはありません。
 Boolean set(String key, String value)
推奨されていません。 代替えメソッドはありません。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Logingp

public Logingp(String login_grp)
推奨されていません。 LoginGroupManagerに置き換えられました。

コンストラクタ

パラメータ:
login_grp - ログイングループID
メソッドの詳細

count

public static Number count()
推奨されていません。 LoginGroupManager.countLoginGroups()に置き換えられました。

登録されているログイングループ数を返す

戻り値:
ログイングループ数

entries

public static List entries()
推奨されていません。 LoginGroupManager.getLoginGroupIds()に置き換えられました。

登録されているログイングループIDの配列を取得する。

戻り値:
ログイングループIDの配列
(データがないときnull)

isGroup

public static Boolean isGroup(String login_grp)
推奨されていません。 代替えメソッドはありません。

指定のログイングループの存在チェック

パラメータ:
login_grp - ログイングループID
戻り値:
ある true/ない false

del

public Boolean del(String key)
推奨されていません。 代替えメソッドはありません。

ログイングループ付随情報を削除する。

set()メソッドで登録した値を削除する。

パラメータ:
key - データのキー

戻り値:
成功 true/失敗 false

get

public Object get(String key)
推奨されていません。 代替えメソッドはありません。

ログイングループ付随情報を取得する。

set()メソッドで登録した値を取得する。

パラメータ:
key - データのキー

戻り値:
set()メソッドで登録した値(String、Number)

set

public Boolean set(String key,
                   Number value)
推奨されていません。 代替えメソッドはありません。

ログイングループ付随情報をセットする。

パラメータ:
key - データのキー
value - データ
戻り値:
成功 true/失敗 false

set

public Boolean set(String key,
                   String value)
推奨されていません。 代替えメソッドはありません。

ログイングループ付随情報をセットする。

パラメータ:
key - データのキー
value - データ
戻り値:
成功 true/失敗 false
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.acssecurity (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.acssecurity
クラス
AccountManager
AcsData
Logingp
RoleManager
例外
AcssecurityException


jp.co.intra_mart.foundation.acssecurity (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.acssecurity

アクセスセキュリティモジュールを利用するためのクラスを提供します。

参照:
説明

クラスの概要
AccountManager | 推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManagerに置き換えられました。
AcsData | 推奨されていません。
Logingp | 推奨されていません。
RoleManager | 推奨されていません。

例外の概要
AcssecurityException アクセスセキュリティ情報操作時にエラーが発生した場合にスローされます。

パッケージ jp.co.intra_mart.foundation.acssecurity の説明

アクセスセキュリティモジュールを利用するためのクラスを提供します。 このパッケージのクラスを利用することで、アクセスセキュリティ機能の持つ 以下の情報に対してアクセスすることができます。

  • アカウント
  • ログイングループ
  • ロール
  • メニュー
  • メッセージ
  • バッチ
  • リンク


jp.co.intra_mart.foundation.acssecurity クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.acssecurity の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.acssecurity.AccountManager
    • class jp.co.intra_mart.foundation.acssecurity.AcsData
    • class jp.co.intra_mart.foundation.acssecurity.Logingp
    • class jp.co.intra_mart.foundation.acssecurity.RoleManager
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.acssecurity.AcssecurityException


パッケージ jp.co.intra_mart.foundation.acssecurity の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.acssecurity の使用

jp.co.intra_mart.foundation.acssecurity を使用しているパッケージ
jp.co.intra_mart.foundation.acssecurity アクセスセキュリティモジュールを利用するためのクラスを提供します。

jp.co.intra_mart.foundation.acssecurity により使用される jp.co.intra_mart.foundation.acssecurity のクラス
AcssecurityException
アクセスセキュリティ情報操作時にエラーが発生した場合にスローされます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


RoleManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.acssecurity
クラス RoleManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.acssecurity.RoleManager

public class RoleManager
extends Object

ロール情報を操作します。

コンストラクタの概要
RoleManager(String login_grp)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManagerに置き換えられました。
メソッドの概要
 boolean contains(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.contains(String)に置き換えられました。
 int count()
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.count()に置き換えられました。
 void delData(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
 void delData(String roleId, boolean isTransaction)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
 Map getData(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRole(String)に置き換えられました。
 String getIdByName(String roleName)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.searchRolesByName(String)に置き換えられました。
 Vector getIDs()
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRoleIds()に置き換えられました。
 String[] getListData(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getAllSubRoleIds(String)に置き換えられました。
 String[] getParentData(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getParentRoleIds(String)に置き換えられました。
 void setData(Map datas)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
 void setData(Map datas, boolean isTransaction)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RoleManager

public RoleManager(String login_grp)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManagerに置き換えられました。

コンストラクタ

パラメータ:
login_grp - ログイングループID
メソッドの詳細

setData

public void setData(Map datas)
             throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。

ロールデータを登録する

DBを使用する場合,このメソッドは内部でDBトランザクションを発行します。 このメソッドをDBトランザクション内で使用しないで下さい。

パラメータ:
datas - ロールデータ

例外:
AcssecurityException -

引数 datas(Map)の内容
(key == value)
id      = ロールID(String)[必須]
         name    = ロール名(String)[必須]
         explan  = 説明(String)
         detail  = 詳細(String)
         roles   = ロールIDの配列(String[])
         search_key = 検索キー(String)

        引数に指定したロールIDが既に存在していた場合、上書きする。

setData

public void setData(Map datas,
                    boolean isTransaction)
             throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。

ロールデータを登録する

パラメータ:
datas - ロールデータ

isTransaction - DBトランザクションフラグ（true このメソッドの中でDBトランザクションを張る。／false このメソッドの中でDBトランザクションを張らない。）

例外:
AcssecurityException -

引数 datas(Map)の内容
(key == value)
id      = ロールID(String)[必須]
         name    = ロール名(String)[必須]
         explan  = 説明(String)
         detail  = 詳細(String)
         roles   = ロールIDの配列(String[])
         search_key = 検索キー(String)

        引数に指定したロールIDが既に存在していた場合、上書きする。

contains

public boolean contains(String roleId)
                 throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.contains(String)に置き換えられました。

ロールデータの存在チェック

パラメータ:
roleId - ロールID
戻り値:
ある true / ない false
例外:
AcssecurityException

count

public int count()
          throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.count()に置き換えられました。

ロールデータの登録数を取得

戻り値:
登録ロール数
例外:
AcssecurityException

getIDs

public Vector getIDs()
              throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRoleIds()に置き換えられました。

ロールIDをすべて取得する

戻り値:
ロールIDの配列(データがない場合は空の配列)
例外:
AcssecurityException

getData

public Map getData(String roleId)
            throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRole(String)に置き換えられました。

ロールデータの取得

パラメータ:
roleId - ロールID
戻り値:
ユーザ情報（ユーザ情報がなければnull）

戻り値 (Map)の内容
(key == value)
id      = ロールID(String)
         name    = ロール名(String)
         explan  = 説明(String)
         detail  = 詳細(String)
         roles   = ロールIDの配列(String[])
         search_key = 検索キー(String)
例外:
AcssecurityException

delData

public void delData(String roleId)
             throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。

ロールデータを削除する

DBを使用する場合,このメソッドは内部でDBトランザクションを発行します。 このメソッドをDBトランザクション内で使用しないで下さい。

パラメータ:
roleId - ロールID
例外:
AcssecurityException

delData

public void delData(String roleId,
                    boolean isTransaction)
             throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。

ロールデータを削除する

パラメータ:
roleId - ロールID
isTransaction - DBトランザクションフラグ（true このメソッドの中でDBトランザクションを張る。／false このメソッドの中でDBトランザクションを張らない。）

例外:
AcssecurityException

getIdByName

public String getIdByName(String roleName)
                   throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.searchRolesByName(String)に置き換えられました。

ロール名からロールIDを取得する

パラメータ:
roleName - ロール名
戻り値:
ロールID(データがない場合はnull)
２つ以上あった場合は先に見つかったほうを返す。
例外:
AcssecurityException

getListData

public String[] getListData(String roleId)
                     throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getAllSubRoleIds(String)に置き換えられました。

サブロールデータの取得(子ロールも含めたロールデータをすべて取得する)

パラメータ:
roleId - ロールID
戻り値:
ロールID配列
例外:
AcssecurityException

getParentData

public String[] getParentData(String roleId)
                       throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getParentRoleIds(String)に置き換えられました。

直接の親（一階層上）ロールIDを取得する

パラメータ:
roleId - ロールID
戻り値:
ロールID配列
例外:
AcssecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.commons.ParameterManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.commons.ParameterManager の使用

ParameterManager を使用しているパッケージ
jp.co.intra_mart.foundation.commons

jp.co.intra_mart.foundation.commons での ParameterManager の使用

ParameterManager を返す jp.co.intra_mart.foundation.commons のメソッド
static ParameterManager ParameterManager.getInstance()
インスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.commons.ParameterSourceProvider の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.commons.ParameterSourceProvider の使用

jp.co.intra_mart.foundation.commons.ParameterSourceProvider はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.commons.SourceProviderHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.commons.SourceProviderHandler の使用

SourceProviderHandler を使用しているパッケージ
jp.co.intra_mart.foundation.commons

jp.co.intra_mart.foundation.commons での SourceProviderHandler の使用

SourceProviderHandler を返す jp.co.intra_mart.foundation.commons のメソッド
static SourceProviderHandler SourceProviderHandler.getInstance()
インスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.commons.validation.InputCheck の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.commons.validation.InputCheck の使用

jp.co.intra_mart.foundation.commons.validation.InputCheck はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


InputCheck (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.commons.validation
クラス InputCheck

java.lang.Object
    拡張 jp.co.intra_mart.foundation.commons.validation.InputCheck
public class InputCheck
extends Object

入力チェック関数ライブラリ

導入されたバージョン:
4.2

コンストラクタの概要
InputCheck()
メソッドの概要
static int | checkDigitOfNumber(Number value, Integer integerDigit, Integer floatDigit) 数値の整数部、小数部の桁数チェック（引数がクラス版）。
static int | checkDigitOfNumber(Number value, int integerDigit, int floatDigit) 数値の整数部、小数部の桁数チェック。
static int | checkDigitOfNumberString(String value, Integer integerDigit, Integer floatDigit) 数値（文字型）の整数部、小数部の桁数チェック（引数がクラス版）
static int | checkDigitOfNumberString(String value, int integerDigit, int floatDigit) 数値（文字型）の整数部、小数部の桁数チェック ※数値かどうかのチェックも行う。
static boolean | isDateString(String dateString) 日付文字列が日付フォーマット（YYYYMMDD）にそっているかチェックする。
static boolean | isDateTimeString(String dateTimeString) 日時文字列がフォーマット（YYYY-MM-DD HH:MM:SS）にそっているかどうかをチェックする。
static boolean | isDateTimeString(String dateTimeString, SimpleDateFormat df) 日時文字列が指定フォーマットにそっているかどうかをチェックする。
static boolean | isEMailAddress(String str) 入力文字列がメールアドレスの形式をとっているかのチェック。
static boolean | isEmpty(Number value) 数値のNULLチェック。
static boolean | isEmpty(String str) 渡された文字列が、空文字列かまたはNULLかチェック。
static boolean | isExistString(String[] strAry, String str) 配列内に指定した文字列が含まれているかどうかをチェックする。
static boolean | isInput(Number column) カラムの空値チェック。
static boolean | isInput(String column) カラムの空値チェック。
static boolean | isKatakanaString(String str) 文字列が半角カナ文字列かチェックする。
static boolean | isKessaiDateString(String kessaiDateString) 決済年月日(YYYYMMDD)として有効かをチェックする。
static boolean | isLenEqual(Number column, int length) カラムの入力桁数チェック。
static boolean | isLenEqual(Number column, Integer length) カラムの入力桁数チェック（引数がクラス版）。
static boolean | isLenEqual(String column, int byteLength) カラムの入力バイト数チェック。
static boolean | isLenEqual(String column, Integer byteLength) カラムの入力バイト数チェック（引数がクラス版）。
static boolean | isLenLessThan(Number column, int length) カラムの桁数が指定桁数より小さいか(等号を含む)。
static boolean | isLenLessThan(Number column, Integer length) カラムの桁数が指定桁数より小さいか(等号を含む)（引数がクラス版）。
static boolean | isLenLessThan(String column, int byteLength) カラムのバイト数が指定バイト数より小さいか(等号を含む)。
static boolean | isLenLessThan(String column, Integer byteLength) カラムのバイト数が指定バイト数より小さいか(等号を含む)（引数がクラス版）。
static boolean | isLenMoreThan(Number column, int length) カラムの桁数が指定桁数より大きいか(等号を含まない)。
static boolean | isLenMoreThan(Number column, Integer length) カラムの桁数が指定桁数より大きいか(等号を含まない)（引数がクラス版）。
static boolean | isLenMoreThan(String column, int byteLength) カラムのバイト数が指定バイト数より大きいか(等号を含まない)。
static boolean | isLenMoreThan(String column, Integer byteLength) カラムのバイト数が指定バイト数より大きいか(等号を含まない)（引数がクラス版）。
static boolean | isNengetsuString(String nengetsuString) 年月指定文字列が年月フォーマット（YYYYMM）にそっているかチェックする。
static boolean | isNotNull(Object obj) not nullチェック not nullのとき true nullのとき false
static boolean | isNumberString(String value) 文字列が数値かどうかをチェックする。
static boolean | isNumeralRange(String column, Number min, Number max) 指定した数値カラムが指定した数値の範囲なのかチェック 範囲最大値、または最小値と同じ値は範囲内に含まれる。
static boolean | isShimebiString(String shimebiString) 締め日(YYYYMMDD)として有効かをチェックする。
static boolean | isValidDate(String year, String month, String day) 推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。
static boolean | isValueEqual(Number column1, Number column2) カラム１の値とカラム２の値が同一かのチェック。
static boolean | isValueEqual(String column1, String column2) カラム１の値とカラム２の値が同一かのチェック。
static boolean | isValueLessThan(Number column1, Number column2) カラム１の値がカラム２の値より小さいか(等号を含まず)のチェック。
static boolean | isValueLessThan(String column1, String column2) カラム１の値がカラム２の値より小さいか(等号を含まず)のチェック。
static boolean | isValueMoreThan(Number column1, Number column2) カラム１の値がカラム２の値より大きいか(等号を含まず)のチェック。
static boolean | isValueMoreThan(String column1, String column2) カラム１の値がカラム２の値より大きいか(等号を含まず)のチェック。
static boolean | isWeekDate(String dateColumn, int dateFlag) 推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。
static boolean | isWeekDate(String dateColumn, Integer dateFlag) 推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

InputCheck

public InputCheck()
メソッドの詳細

isInput

public static boolean isInput(String column)
カラムの空値チェック。

nullのとき空値
空文字列のときは空値
値が入っているときは空値ではありません
（参照）isEmpty(java.lang.String)

パラメータ:
column - カラム入力文字列
戻り値:
true:空値ではない false:空値

isInput

public static boolean isInput(Number column)
カラムの空値チェック。

nullのとき空値
0のときは空値ではない
NaN,無限大が入っているときは空値ではありません
値が入っているときは空値ではありません
（参照）isEmpty(java.lang.Number)

パラメータ:
column - カラム入力数値
戻り値:
true:空値ではない false:空値

isLenEqual

public static boolean isLenEqual(String column,
                                 int byteLength)
カラムの入力バイト数チェック。

カラムがnullまたは空文字列のときは常にFalseを返す
0バイト指定はFalseを返す

パラメータ:
column - カラム入力文字列
byteLength - カラムのバイト数
戻り値:
true:バイト数が一致 false:バイト数が一致しない

isLenEqual

public static boolean isLenEqual(String column,
                                 Integer byteLength)
カラムの入力バイト数チェック（引数がクラス版）。

パラメータ:
column - カラム入力文字列
byteLength - カラムのバイト数
戻り値:
true:バイト数が一致 false:バイト数が一致しない

isLenEqual

public static boolean isLenEqual(Number column,
                                 int length)
カラムの入力桁数チェック。

カラムがnullのときは常にFalseを返す
カラムに入力された数値を文字列に変換して桁数を比較する
NaN、無限大などの問題は考慮していません
0桁指定はfalseを返す

パラメータ:
column - カラム入力数値
length - 桁数
戻り値:
true:桁数が一致 false:桁数が一致しない

isLenEqual

public static boolean isLenEqual(Number column,
                                 Integer length)
カラムの入力桁数チェック（引数がクラス版）。

パラメータ:
column - カラム入力数値
length - 桁数
戻り値:
true:桁数が一致 false:桁数が一致しない

isLenLessThan

public static boolean isLenLessThan(String column,
                                    int byteLength)
カラムのバイト数が指定バイト数より小さいか(等号を含む)。

カラムがnullまたは空文字列のときは常にFalseを返す
0バイト指定はFalseを返す

パラメータ:
column - カラム入力文字列
byteLength - カラムのバイト数
戻り値:
true:バイト数が指定のものより短いか同じ false:バイト数が指定のものより長い

isLenLessThan

public static boolean isLenLessThan(String column,
                                    Integer byteLength)
カラムのバイト数が指定バイト数より小さいか(等号を含む)（引数がクラス版）。

パラメータ:
column - カラム入力文字列
byteLength - カラムのバイト数
戻り値:
true:バイト数が指定のものより短いか同じ false:バイト数が指定のものより長い

isLenLessThan

public static boolean isLenLessThan(Number column,
                                    int length)
カラムの桁数が指定桁数より小さいか(等号を含む)。

カラムがnullのときは常にFalseを返す
カラムに入力された数値を文字列に変換して桁数を比較する
NaN、無限大などの問題は考慮していません
0桁指定はfalseを返す

パラメータ:
column - カラム入力数値
length - 桁数
戻り値:
true:桁数が指定のものより短いか同じ false:桁数が指定のものより長い

isLenLessThan

public static boolean isLenLessThan(Number column,
                                    Integer length)
カラムの桁数が指定桁数より小さいか(等号を含む)（引数がクラス版）。

パラメータ:
column - カラム入力数値
length - 桁数
戻り値:
true:桁数が指定のものより短いか同じ false:桁数が指定のものより長い

isLenMoreThan

public static boolean isLenMoreThan(String column,
                                    int byteLength)
カラムのバイト数が指定バイト数より大きいか(等号を含まない)。

カラムがnullまたは空文字列のときは常にFalseを返す
0バイト指定はFalseを返す

パラメータ:
column - カラム入力文字列
byteLength - カラムのバイト数
戻り値:
true:バイト数が指定のものより長い false:バイト数が指定のものと同じか短い

isLenMoreThan

public static boolean isLenMoreThan(String column,
                                    Integer byteLength)
カラムのバイト数が指定バイト数より大きいか(等号を含まない)（引数がクラス版）。

パラメータ:
column - カラム入力文字列
byteLength - カラムのバイト数
戻り値:
true:バイト数が指定のものより長い false:バイト数が指定のものと同じか短い

isLenMoreThan

public static boolean isLenMoreThan(Number column,
                                    int length)
カラムの桁数が指定桁数より大きいか(等号を含まない)。

カラムがnullのときは常にFalseを返す
カラムに入力された数値を文字列に変換して桁数を比較する
NaN、無限大などの問題は考慮していません
0桁指定はfalseを返す

パラメータ:
column - カラム入力数値
length - 桁数
戻り値:
true:桁数が指定のものより長い false:桁数が指定のものと同じか短い

isLenMoreThan

public static boolean isLenMoreThan(Number column,
                                    Integer length)
カラムの桁数が指定桁数より大きいか(等号を含まない)（引数がクラス版）。

パラメータ:
column - カラム入力数値
length - 桁数
戻り値:
true:桁数が指定のものより長い false:桁数が指定のものと同じか短い

isValueEqual

public static boolean isValueEqual(String column1,
                                   String column2)
カラム１の値とカラム２の値が同一かのチェック。

大文字、小文字および半角、全角の違う文字は違う文字として扱う
両方null値、または空文字列の場合はtrueを返す
一方がnull値、または空文字列でもう一方が一般の文字列の場合はfalseを返す
nullと空値を比較した場合はtrueを返す

パラメータ:
column1 - 対象文字列１
column2 - 対象文字列２
戻り値:
true:同一文字列 false:異なる文字列

isValueEqual

public static boolean isValueEqual(Number column1,
                                   Number column2)
カラム１の値とカラム２の値が同一かのチェック。

型が違うものが渡された場合はfalseを返す
両方null値の場合はtrueを返す
一方がnull値の場合はfalseを返す

パラメータ:
column1 - 対象値１
column2 - 対象値２
戻り値:
true:同一値 false:異なる値

isValueLessThan

public static boolean isValueLessThan(String column1,
                                      String column2)
カラム１の値がカラム２の値より小さいか(等号を含まず)のチェック。

半角、全角などが混ざってもUnicode順で判断する
一方がnull値、または空文字列の場合は無条件でfalseを返す

パラメータ:
column1 - 対象文字列１
column2 - 対象文字列２
戻り値:
true:カラム１の値がカラム２の値よりも小さい
false:カラム１の値がカラム２の値よりも大きい、または同一値

isValueLessThan

public static boolean isValueLessThan(Number column1,
                                      Number column2)
カラム１の値がカラム２の値より小さいか(等号を含まず)のチェック。

型が違うものが渡された場合はfalseを返す
どちらか一方でもnull値だった場合はfalseを返す
(使用できる型を限定: Integer,Byte,Short,Long,Float,Double)

パラメータ:
column1 - 対象値１
column2 - 対象値２
戻り値:
true:カラム１の値がカラム２の値よりも小さい
false:カラム１の値がカラム２の値よりも大きい、または同一値

isValueMoreThan

public static boolean isValueMoreThan(String column1,
                                      String column2)
カラム１の値がカラム２の値より大きいか(等号を含まず)のチェック。

半角、全角などが混ざってもUnicode順で判断する
一方がnull値、または空文字列の場合は無条件でfalseを返す

パラメータ:
column1 - 対象文字列１
column2 - 対象文字列２
戻り値:
true:カラム１の値がカラム２の値よりも大きい
false:カラム１の値がカラム２の値より小さい、または同一値

isValueMoreThan

public static boolean isValueMoreThan(Number column1,
                                      Number column2)
カラム１の値がカラム２の値より大きいか(等号を含まず)のチェック。

型が違うものが渡された場合はfalseを返す
どちらか一方でもnull値だった場合はfalseを返す
(使用できる型を限定: Integer,Byte,Short,Long,Float,Double)

パラメータ:
column1 - 対象値１
column2 - 対象値２
戻り値:
true:カラム１の値がカラム２の値よりも大きい
false:カラム１の値がカラム２の値よりも小さい、または同一値

isValidDate

public static boolean isValidDate(String year,
                                  String month,
                                  String day)
推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。

日付カラムが有効な範囲なのかチェック

パラメータ:
year - 年
month - 月
day - 日
戻り値:
true:正当な日付 false:不正な日付

isWeekDate

public static boolean isWeekDate(String dateColumn,
                                 int dateFlag)
推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。

日付カラムが銀行営業日なのかチェック。

パラメータ:
dateColumn - 日付文字列
dateFlag - 判定する日付のタイプを示すフラグ 0:営業日判定 1:休日判定
戻り値:
判定条件を満たせばtrue,条件に合わなかったらfalse

isWeekDate

public static boolean isWeekDate(String dateColumn,
                                 Integer dateFlag)
推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。

日付カラムが銀行営業日なのかチェック（引数がクラス版）。

パラメータ:
dateColumn - 日付文字列
dateFlag - 判定する日付のタイプを示すフラグ 0:営業日判定 1:休日判定
戻り値:
判定条件を満たせばtrue,条件に合わなかったらfalse

isNumeralRange

public static boolean isNumeralRange(String column,
                                     Number min,
                                     Number max)
指定した数値カラムが指定した数値の範囲なのかチェック
範囲最大値、または最小値と同じ値は範囲内に含まれる。

数値カラムがnullまたは空文字列の場合はfalseを返す
範囲値の指定のどちらか一方がnullの場合はfalseを返す
範囲値の指定の型が異なる場合はfalseを返す
数値カラムの値を範囲指定のクラスの型に変更して判断を行う
(使用できる型を限定: Integer,Byte,Short,Long,Float,Double)

パラメータ:
column - 数値を示す文字列
min - 範囲最小値
max - 範囲最大値
戻り値:
true:範囲内 false:範囲外

checkDigitOfNumber

public static int checkDigitOfNumber(Number value,
                                     int integerDigit,
                                     int floatDigit)
数値の整数部、小数部の桁数チェック。

Double型の値は有効桁数１６桁
Float型の値は有効桁数７桁
(使用できる型を限定: Integer,Byte,Short,Long,Float,Double)
数値を文字列に変換してcheckDigitOfNumberStringを使用して判断する
（参照）checkDigitOfNumberString(java.lang.String, int, int)

パラメータ:
value - 数値
integerDigit - 整数部桁数
floatDigit - 小数部桁数
戻り値:
0:チェック成功 1:整数部桁数オーバー 2:小数部桁数オーバー 3:整数部、小数部ともに桁数オーバー -1:渡された数値が不正 -2:渡された桁数情報が不正 -3:有効桁数を超えて桁数判断を行おうとしている -4:この関数では扱えない型

checkDigitOfNumber

public static int checkDigitOfNumber(Number value,
                                     Integer integerDigit,
                                     Integer floatDigit)
数値の整数部、小数部の桁数チェック（引数がクラス版）。

パラメータ:
value - 数値
integerDigit - 整数部桁数
floatDigit - 小数部桁数
戻り値:
0:チェック成功 1:整数部桁数オーバー 2:小数部桁数オーバー 3:整数部、小数部ともに桁数オーバー -1:渡された数値が不正 -2:渡された桁数情報が不正 -3:有効桁数を超えて桁数判断を行おうとしている -4:この関数では扱えない型

checkDigitOfNumberString

public static int checkDigitOfNumberString(String value,
                                           int integerDigit,
                                           int floatDigit)
数値（文字型）の整数部、小数部の桁数チェック
※数値かどうかのチェックも行う。

扱える数値文字列は指数表現の入らないものだけとする
(例) 1234567890.0987654321は扱える
12345.67E89といった表現は扱えない
符号も１桁としてカウントする

パラメータ:
value - 数値文字列
integerDigit - 整数部桁数
floatDigit - 小数部桁数
戻り値:
0:チェック成功 1:整数部桁数オーバー 2:小数部桁数オーバー 3:整数部、小数部ともに桁数オーバー -1:渡された文字列が数値ではない -2:渡された桁数情報が不正

checkDigitOfNumberString

public static int checkDigitOfNumberString(String value,
                                           Integer integerDigit,
                                           Integer floatDigit)
数値（文字型）の整数部、小数部の桁数チェック（引数がクラス版）

パラメータ:
value - 数値文字列
integerDigit - 整数部桁数
floatDigit - 小数部桁数
戻り値:
0:チェック成功 1:整数部桁数オーバー 2:小数部桁数オーバー 3:整数部、小数部ともに桁数オーバー -1:渡された文字列が数値ではない -2:渡された桁数情報が不正

isEmpty

public static boolean isEmpty(String str)
渡された文字列が、空文字列かまたはNULLかチェック。

nullのときtrue
空文字列のときtrue
値が入っているときはfalse
（参照）isInput(java.lang.String)

パラメータ:
str - 文字列
戻り値:
true:空文字列またはNULL false:空値

isEmpty

public static boolean isEmpty(Number value)
数値のNULLチェック。

nullのときtrueを返す
0のときはfalseを返す
NaN,無限大が入っているときはfalseを返す
値が入っているときはfalseを返す
（参照）isInput(java.lang.Number)

パラメータ:
value - 数値
戻り値:
true:null false:nullではない

isNumberString

public static boolean isNumberString(String value)
文字列が数値かどうかをチェックする。

パラメータが数字文字列または"1.0f"などのfloat値、"1.0d"などのdouble値を表す場合にtrueが返されます。

パラメータ:
value - 数値文字列
戻り値:
true:数値文字列である false:数値文字列ではない

isDateString

public static boolean isDateString(String dateString)
日付文字列が日付フォーマット（YYYYMMDD）にそっているかチェックする。

パラメータ:
dateString - 日付文字列
戻り値:
true:フォーマットに従っている false:従っていない

isShimebiString

public static boolean isShimebiString(String shimebiString)
締め日(YYYYMMDD)として有効かをチェックする。

（日付として有効かどうかだけをチェックする）

パラメータ:
shimebiString - 日付文字列
戻り値:
true:フォーマットに従っている false:従っていない

isKessaiDateString

public static boolean isKessaiDateString(String kessaiDateString)
決済年月日(YYYYMMDD)として有効かをチェックする。

（営業日として有効かどうかだけをチェックする）

パラメータ:
kessaiDateString - 日付文字列
戻り値:
true:フォーマットに従っている false:従っていない

isNengetsuString

public static boolean isNengetsuString(String nengetsuString)
年月指定文字列が年月フォーマット（YYYYMM）にそっているかチェックする。

パラメータ:
nengetsuString - 年月指定文字列
戻り値:
true:フォーマットに従っている false:従っていない

isDateTimeString

public static boolean isDateTimeString(String dateTimeString)
日時文字列がフォーマット（YYYY-MM-DD HH:MM:SS）にそっているかどうかをチェックする。

パラメータ:
dateTimeString - 日時文字列
戻り値:
true:フォーマットに従っている false:従っていない

isDateTimeString

public static boolean isDateTimeString(String dateTimeString,
                                       SimpleDateFormat df)
日時文字列が指定フォーマットにそっているかどうかをチェックする。

パラメータ:
dateTimeString - 日時文字列
df - 指定フォーマット
戻り値:
true:フォーマットに従っている false:従っていない

isKatakanaString

public static boolean isKatakanaString(String str)
文字列が半角カナ文字列かチェックする。

半角カナ文字と半角スペースだけを許可する

パラメータ:
str - 半角カナ文字列
戻り値:
true:半角カナ文字だけで構成 false:違う種類の文字が含まれる

isExistString

public static boolean isExistString(String[] strAry,
                                    String str)
配列内に指定した文字列が含まれているかどうかをチェックする。

配列の要素のうち、どれか一つの要素が対象文字列を含むならばtrueを返す
対象文字列にnullか空文字列を指定された場合にはfalseを返す

パラメータ:
strAry - 文字列が含まれる配列
str - 対象文字列
戻り値:
true:対象文字列が含まれる false:対象文字列が含まれない

isEMailAddress

public static boolean isEMailAddress(String str)
入力文字列がメールアドレスの形式をとっているかのチェック。

（以下の形式の文字列をエラーとして判定します
☆@がない場合
☆.で始まるユーザ名・ドメイン名
☆.で終わるユーザ名・ドメイン名
☆ドメインに.が無い場合
☆ユーザ名の文字数が3文字未満の場合
☆ユーザ名に.が2文字以上含まれている場合
☆.を含んだドメイン名の文字数が4文字未満の場合
☆ユーザ名に含まれる文字に . _ - 以外の記号が入っている場合
☆ドメイン名に含まれる文字に . - 以外の記号が入っている場合
☆ドメインのピリオドが出現した後に続けてピリオドが出現する
☆最後の.の後、アルファベットが２文字未満しかない
（ＲＦＣ８２２で許可されている記号は!#$%&'*+-/=?^_`{|}~であるがより制限を厳しくする）

パラメータ:
str - メールアドレス
戻り値:
true:メールアドレス形式に合致 false:メールアドレス形式に適合しない

isNotNull

public static boolean isNotNull(Object obj)
not nullチェック not nullのとき true nullのとき false

パラメータ:
obj - チェック対象オブジェクト
戻り値:
true:null以外のとき false:nullのとき
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.commons.validation (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.commons.validation
クラス
InputCheck


jp.co.intra_mart.foundation.commons.validation (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.commons.validation

このパッケージは、入力チェック関数ライブラリを提供します。

参照:
説明

クラスの概要
InputCheck 入力チェック関数ライブラリ

パッケージ jp.co.intra_mart.foundation.commons.validation の説明

このパッケージは、入力チェック関数ライブラリを提供します。


jp.co.intra_mart.foundation.commons.validation クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.commons.validation の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.commons.validation.InputCheck


パッケージ jp.co.intra_mart.foundation.commons.validation の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.commons.validation の使用

jp.co.intra_mart.foundation.commons.validation はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.commons (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.commons
インタフェース
ParameterSourceProvider
クラス
ParameterManager
SourceProviderHandler


jp.co.intra_mart.foundation.commons (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.commons

インタフェースの概要
ParameterSourceProvider アプリケーション共通マスタのパラメータの管理するプロバイダーです。

クラスの概要
ParameterManager | システム共通パラメータ情報の取得を行うクラスです。
SourceProviderHandler |


jp.co.intra_mart.foundation.commons クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.commons の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.commons.ParameterManager
    • class jp.co.intra_mart.foundation.commons.SourceProviderHandler

インタフェース階層

  • interface jp.co.intra_mart.foundation.commons.ParameterSourceProvider


パッケージ jp.co.intra_mart.foundation.commons の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.commons の使用

jp.co.intra_mart.foundation.commons を使用しているパッケージ
jp.co.intra_mart.foundation.commons

jp.co.intra_mart.foundation.commons により使用される jp.co.intra_mart.foundation.commons のクラス
ParameterManager
システム共通パラメータ情報の取得を行うクラスです。
SourceProviderHandler

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParameterManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.commons
クラス ParameterManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.commons.ParameterManager
public class ParameterManager
extends Object

システム共通パラメータ情報の取得を行うクラスです。

導入されたバージョン:
5.1

メソッドの概要
static ParameterManager | getInstance() インスタンスを取得します。
String | getParameter(String paramName) パラメータの値を取得します。
String[] | getParameterNames() パラメータ名の一覧を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getInstance

public static ParameterManager getInstance()
インスタンスを取得します。

戻り値:
インスタンス

getParameter

public String getParameter(String paramName)
パラメータの値を取得します。
指定されたパラメータ名に一致するパラメータが存在しない場合は、null を返します。

パラメータ:
paramName - パラメータ名
戻り値:
パラメータの値

getParameterNames

public String[] getParameterNames()
パラメータ名の一覧を取得します。
パラメータが定義されていない場合は空の配列を返します。

戻り値:
パラメータ名の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ParameterSourceProvider (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.commons
インタフェース ParameterSourceProvider

public interface ParameterSourceProvider

アプリケーション共通マスタのパラメータの管理するプロバイダーです。

導入されたバージョン:
5.1

メソッドの概要
 Map getParameters()
パラメータの一覧を取得します。

メソッドの詳細

getParameters

public Map getParameters()
パラメータの一覧を取得します。

戻り値:
パラメータの一覧を取得します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SourceProviderHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.commons
クラス SourceProviderHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.commons.SourceProviderHandler
public class SourceProviderHandler
extends Object

導入されたバージョン:
5.1

コンストラクタの概要
protected SourceProviderHandler()
コンストラクタ。
メソッドの概要
Object | getClassInstance(String key) ソースプロバイダクラスのインスタンスを取得します。
String | getHandlerName(String key) ソースプロバイダクラス名を取得します。
static SourceProviderHandler | getInstance() インスタンスを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SourceProviderHandler

protected SourceProviderHandler()
コンストラクタ。

例外:
SAXException
IOException
メソッドの詳細

getInstance

public static SourceProviderHandler getInstance()
インスタンスを取得します。

戻り値:
インスタンス

getHandlerName

public String getHandlerName(String key)
ソースプロバイダクラス名を取得します。

識別キーの該当するソースプロバイダクラス名が存在しなかった場合は、空文字列を返却します。

パラメータ:
key - 識別キー
戻り値:
ソースプロバイダクラス名

getClassInstance

public Object getClassInstance(String key)
ソースプロバイダクラスのインスタンスを取得します。

識別キーの該当するソースプロバイダクラス名が存在しなかった場合は、nullを返却します。

パラメータ:
key - 識別キー
戻り値:
ソースプロバイダクラスのインスタンス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.database.ConInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.database.ConInfo の使用

ConInfo を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database での ConInfo の使用

ConInfo を返す jp.co.intra_mart.foundation.database のメソッド
ConInfo | DbsConnection.getConnectionInfo() 推奨されていません。 データベース設定情報を取得します。
ConInfo | DbManager.getConnectInfo() 推奨されていません。 代替えメソッドはありません。

ConInfo 型のパラメータを持つ jp.co.intra_mart.foundation.database のメソッド
static boolean | DbManager.contact(ConInfo dio) 推奨されていません。 代替えメソッドはありません。
Connection | DatabaseAccessor.getConnection(ConInfo conInfo) Connectionオブジェクトを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.database.DatabaseAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.database.DatabaseAccessor の使用

DatabaseAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database での DatabaseAccessor の使用

DatabaseAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.database のメソッド
static void DatabaseManager.setDatabaseAccessor(DatabaseAccessor databaseAccessor)
データベースアクセッサを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DatabaseColumn の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DatabaseColumn の使用

DatabaseColumn を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database での DatabaseColumn の使用

DatabaseColumn を返す jp.co.intra_mart.foundation.database のメソッド
 DatabaseColumn[] DatabaseExport.getColumnsInfo()
推奨されていません。

DatabaseColumn 型のパラメータを持つ jp.co.intra_mart.foundation.database のメソッド
 void DatabaseExport.setColumnsInfo(DatabaseColumn[] columns)
推奨されていません。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DatabaseExport の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DatabaseExport の使用

DatabaseExport を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database での DatabaseExport の使用

DatabaseExport を返す jp.co.intra_mart.foundation.database のメソッド
static DatabaseExport DatabaseExport.getInstance()
推奨されていません。 DatabaseExportインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DatabaseManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DatabaseManager の使用

DatabaseManager を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database での DatabaseManager の使用

DatabaseManager を返す jp.co.intra_mart.foundation.database のメソッド
static DatabaseManager DatabaseManager.getInstance()
データべースマネージャインスタンスを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.database.DataSourceProvider の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.database.DataSourceProvider の使用

DataSourceProvider を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database での DataSourceProvider の使用

DataSourceProvider 型のパラメータを持つ jp.co.intra_mart.foundation.database のメソッド
static void DatabaseManager.setSourceProvider(DataSourceProvider provider)
ソースプロバイダを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DbManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DbManager の使用

jp.co.intra_mart.foundation.database.DbManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.database.DbsConnection の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.database.DbsConnection の使用

DbsConnection を使用しているパッケージ
jp.co.intra_mart.foundation.database | データベースへアクセスするためのクラスを提供します。
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.foundation.database での DbsConnection の使用

DbsConnection を返す jp.co.intra_mart.foundation.database のメソッド
 DbsConnection DbManager.getConnection()
推奨されていません。 DatabaseManager.getLoginGroupConnection(String) および DatabaseManager.getSystemConnection(String)を使用してください。

jp.co.intra_mart.framework.base.data での DbsConnection の使用

DbsConnection を返す jp.co.intra_mart.framework.base.data のメソッド
DbsConnection | IntramartDBDAO.getConnection() 推奨されていません。 イントラマートで設定されているDBへのコネクションを取得します。
DbsConnection | IntramartDBConnector.getConnection(String connect) 推奨されていません。 データベースへのコネクションを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.exception.DatabaseExportException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.exception.DatabaseExportException の使用

DatabaseExportException を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database での DatabaseExportException の使用

DatabaseExportException をスローする jp.co.intra_mart.foundation.database のメソッド
void | DatabaseExport.downloadCSV(String sql, String fileName, int startIndex, int maxRow, String connectId, boolean isGroup, boolean isTitle) 推奨されていません。 CSVファイルをダウンロードします。
void | DatabaseExport.downloadCSV(PreparedStatement stmt, String fileName, boolean isTitle) 推奨されていません。 CSVファイルをダウンロードします。
void | DatabaseExport.downloadCSV(PreparedStatement stmt, String fileName, int startIndex, int maxRow, boolean isTitle) 推奨されていません。 CSVファイルをダウンロードします。
int | DatabaseExport.exportCSV(PreparedStatement stmt, OutputStream out, boolean isTitle) 推奨されていません。 CSV形式のデータをストリームに出力します。
int | DatabaseExport.exportCSV(PreparedStatement stmt, OutputStream out, int startIndex, int maxRow, boolean isTitle) 推奨されていません。 CSV形式のデータをストリームに出力します。
int | DatabaseExport.exportCSV(PreparedStatement stmt, NetworkFile file, boolean isTitle) 推奨されていません。 CSVファイルをストレージに出力します。
int | DatabaseExport.exportCSV(PreparedStatement stmt, NetworkFile file, int startIndex, int maxRow, boolean isTitle) 推奨されていません。 CSVファイルをストレージに出力します。
String[] | DatabaseExport.getCSVStrings(PreparedStatement stmt, boolean isTitle) 推奨されていません。 CSV形式のデータ取得します。
String[] | DatabaseExport.getCSVStrings(PreparedStatement stmt, int startIndex, int maxRow, boolean isTitle) 推奨されていません。 CSV形式のデータ取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.exception.DatabaseSQLException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.exception.DatabaseSQLException の使用

jp.co.intra_mart.foundation.database.exception.DatabaseSQLException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DatabaseExportException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database.exception
クラス DatabaseExportException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.database.exception.DatabaseExportException
すべての実装インタフェース:
Serializable
推奨されていません。 システム内部で利用しているクラスです。

public class DatabaseExportException
extends Exception

関連項目:
直列化された形式

フィールドの概要
static int | PROCESS_BUSY 推奨されていません。
static int | WRITE_TIMEOUT 推奨されていません。
コンストラクタの概要
DatabaseExportException(int type)
推奨されていません。
DatabaseExportException(String value, int type)
推奨されていません。
メソッドの概要
 int getErrorType()
推奨されていません。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

フィールドの詳細

PROCESS_BUSY

public static final int PROCESS_BUSY
推奨されていません。
関連項目:
定数フィールド値

WRITE_TIMEOUT

public static final int WRITE_TIMEOUT
推奨されていません。
関連項目:
定数フィールド値
コンストラクタの詳細

DatabaseExportException

public DatabaseExportException(int type)
推奨されていません。

DatabaseExportException

public DatabaseExportException(String value,
                               int type)
推奨されていません。
メソッドの詳細

getErrorType

public int getErrorType()
推奨されていません。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DatabaseSQLException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database.exception
クラス DatabaseSQLException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.sql.SQLException
                拡張 jp.co.intra_mart.foundation.database.exception.DatabaseSQLException
すべての実装インタフェース:
Serializable
public class DatabaseSQLException
extends SQLException

データベースSQL例外拡張クラス。

SQL例外に原因となる例外を渡せるようにした拡張版例外クラス。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DatabaseSQLException(String reason)
コンストラクタ。
DatabaseSQLException(String reason, String SQLState)
コンストラクタ。
DatabaseSQLException(String reason, String SQLState, int vendorCode)
コンストラクタ。
DatabaseSQLException(String reason, String SQLState, int vendorCode, Throwable cause)
コンストラクタ。
DatabaseSQLException(String reason, String SQLState, Throwable cause)
コンストラクタ。
DatabaseSQLException(String reason, Throwable cause)
コンストラクタ。
クラス java.sql.SQLException から継承したメソッド
getErrorCode, getNextException, getSQLState, setNextException
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DatabaseSQLException

public DatabaseSQLException(String reason)
コンストラクタ。

パラメータ:
reason - 理由

DatabaseSQLException

public DatabaseSQLException(String reason,
                            String SQLState)
コンストラクタ。

パラメータ:
reason - 理由
SQLState - SQLステータス

DatabaseSQLException

public DatabaseSQLException(String reason,
                            String SQLState,
                            int vendorCode)
コンストラクタ。

パラメータ:
reason - 理由
SQLState - SQLステータス
vendorCode - ベンダーコード

DatabaseSQLException

public DatabaseSQLException(String reason,
                            Throwable cause)
コンストラクタ。

パラメータ:
reason - 理由
cause - 原因となる例外

DatabaseSQLException

public DatabaseSQLException(String reason,
                            String SQLState,
                            Throwable cause)
コンストラクタ。

パラメータ:
reason - 理由
SQLState - SQLステータス
cause - 原因となる例外

DatabaseSQLException

public DatabaseSQLException(String reason,
                            String SQLState,
                            int vendorCode,
                            Throwable cause)
コンストラクタ。

パラメータ:
reason - 理由
SQLState - SQLステータス
vendorCode - ベンダーコード
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.database.exception (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.database.exception
例外
DatabaseExportException
DatabaseSQLException


jp.co.intra_mart.foundation.database.exception (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.database.exception

データベースＳＱＬ例外クラスを提供します。

参照:
説明

例外の概要
DatabaseExportException | 推奨されていません。 システム内部で利用しているクラスです。
DatabaseSQLException | データベースSQL例外拡張クラス。

パッケージ jp.co.intra_mart.foundation.database.exception の説明

データベースＳＱＬ例外クラスを提供します。


jp.co.intra_mart.foundation.database.exception クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.database.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.database.exception.DatabaseExportException
        • class java.sql.SQLException
          • class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException


パッケージ jp.co.intra_mart.foundation.database.exception の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.database.exception の使用

jp.co.intra_mart.foundation.database.exception を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database により使用される jp.co.intra_mart.foundation.database.exception のクラス
DatabaseExportException
推奨されていません。 システム内部で利用しているクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ConInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
インタフェース ConInfo

public interface ConInfo

フィールドの概要
static String | TYPE_DATA_SOURCE
static String | TYPE_GROUP
static String | TYPE_JDBC
static String | TYPE_SYSTEM
メソッドの概要
String | getConId() 接続参照名を取得します。
String | getConnectionType() 接続の種別を取得します。
String | getDataSourceRefName() DataSourceへの参照名を取得します。
String | getIdentifier() コネクションの識別子を取得します。
void | setDataSourceRefName(String dsRefName) DataSourceへの参照名を設定します。

フィールドの詳細

TYPE_SYSTEM

public static final String TYPE_SYSTEM
関連項目:
定数フィールド値

TYPE_GROUP

public static final String TYPE_GROUP
関連項目:
定数フィールド値

TYPE_DATA_SOURCE

public static final String TYPE_DATA_SOURCE
関連項目:
定数フィールド値

TYPE_JDBC

public static final String TYPE_JDBC
関連項目:
定数フィールド値
メソッドの詳細

setDataSourceRefName

public void setDataSourceRefName(String dsRefName)
DataSourceへの参照名を設定します。

パラメータ:
dsRefName - DataSourceへの参照名

getDataSourceRefName

public String getDataSourceRefName()
DataSourceへの参照名を取得します。

戻り値:
DataSourceへの参照名

getConId

public String getConId()
接続参照名を取得します。

戻り値:
接続参照名

getConnectionType

public String getConnectionType()
接続の種別を取得します。

戻り値:
接続の種別

getIdentifier

public String getIdentifier()
コネクションの識別子を取得します。

戻り値:
コネクションの識別子
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DatabaseAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
インタフェース DatabaseAccessor

public interface DatabaseAccessor

データベース接続オブジェクト取得インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
DatabaseAccessorImpl

メソッドの概要
void | beginTransaction() データベースアクセスのトランザクションを開始します。
void | commit() データベースのトランザクションをコミットします。
Connection | getConnection(ConInfo conInfo) Connectionオブジェクトを取得します。
boolean | isTransaction() データベースアクセスのトランザクション状態を取得します。
void | rollback() データベースのトランザクションをロールバックします。

メソッドの詳細

getConnection

public Connection getConnection(ConInfo conInfo)
                         throws SQLException,
                                NamingException
Connectionオブジェクトを取得します。

パラメータ:
conInfo - データベース接続情報
戻り値:
データベース接続オブジェクト
例外:
SQLException
NamingException

beginTransaction

public void beginTransaction()
                      throws NamingException,
                             NotSupportedException,
                             SystemException
データベースアクセスのトランザクションを開始します。

例外:
NamingException - Context および DirContext インタフェースでの操作によってスローされるすべての例外のスーパークラスです。
SystemException - SystemException は、トランザクションマネージャによってスローされ、トランザクションサービスの処理をこれ以上続行できないような予想外のエラー状態が検出されたことを示します。
NotSupportedException - NotSupportedException 例外は、操作がサポートされていない機能であるために、要求が実行できないことを示します。

isTransaction

public boolean isTransaction()
                      throws NamingException,
                             NotSupportedException,
                             SystemException
データベースアクセスのトランザクション状態を取得します。

戻り値:
true : トランザクション中 / false : トランザクション外
例外:
NamingException - Context および DirContext インタフェースでの操作によってスローされるすべての例外のスーパークラスです。
SystemException - SystemException は、トランザクションマネージャによってスローされ、トランザクションサービスの処理をこれ以上続行できないような予想外のエラー状態が検出されたことを示します。
NotSupportedException - NotSupportedException 例外は、操作がサポートされていない機能であるために、要求が実行できないことを示します。

commit

public void commit()
            throws NamingException,
                   IllegalStateException,
                   SecurityException,
                   RollbackException,
                   HeuristicMixedException,
                   HeuristicRollbackException,
                   SystemException
データベースのトランザクションをコミットします。

例外:
NamingException - Context および DirContext インタフェースでの操作によってスローされるすべての例外のスーパークラスです。
SystemException - SystemException は、トランザクションマネージャによってスローされ、トランザクションサービスの処理をこれ以上続行できないような予想外のエラー状態が検出されたことを示します。
HeuristicRollbackException - この例外は、コミット操作によってスローされ、ヒューリスティックな決定が行われて、それに関連するすべての更新がロールバックされたことを報告します。
HeuristicMixedException - この例外は、ヒューリスティックな決定が行われて、それに関連する一部の更新がコミットされ、残りの更新がロールバックされたことを報告するためにスローされます。
RollbackException - RollbackException 例外は、トランザクションがロールバック専用としてマークされたか、コミットの代わりにロールバックされた場合にスローされます。
SecurityException - セキュリティマネージャによってスローされ、セキュリティ違反を示します。
IllegalStateException - 不正または不適切なときにメソッドが呼び出されたことを示します。

rollback

public void rollback()
              throws NamingException,
                     IllegalStateException,
                     SecurityException,
                     SystemException
データベースのトランザクションをロールバックします。

例外:
NamingException - Context および DirContext インタフェースでの操作によってスローされるすべての例外のスーパークラスです。
SystemException - SystemException は、トランザクションマネージャによってスローされ、トランザクションサービスの処理をこれ以上続行できないような予想外のエラー状態が検出されたことを示します。
SecurityException - セキュリティマネージャによってスローされ、セキュリティ違反を示します。
IllegalStateException - 不正または不適切なときにメソッドが呼び出されたことを示します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DatabaseColumn (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DatabaseColumn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DatabaseColumn
public class DatabaseColumn
extends Object

フィールドの概要
static int | INDEX_UNDEFINED
static int | TYPE_DATE
static int | TYPE_NUMBER
static int | TYPE_STRING
static int | TYPE_UNDEFINED
コンストラクタの概要
DatabaseColumn()
DatabaseColumn(int columnType)
DatabaseColumn(int columnType, int index)
DatabaseColumn(String tableName, String columnName, String dataType, int index, boolean primaryKey)
メソッドの概要
String | getColumnName()
int | getColumnType()
String | getFormat()
int | getIndex()
boolean | isNumber()
boolean | isPrimaryKey()
void | setColumnName(String columnName)
void | setColumnType(int columnType)
void | setFormat(String format)
void | setIndex(int index)
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

INDEX_UNDEFINED

public static final int INDEX_UNDEFINED
関連項目:
定数フィールド値

TYPE_UNDEFINED

public static final int TYPE_UNDEFINED
関連項目:
定数フィールド値

TYPE_STRING

public static final int TYPE_STRING
関連項目:
定数フィールド値

TYPE_NUMBER

public static final int TYPE_NUMBER
関連項目:
定数フィールド値

TYPE_DATE

public static final int TYPE_DATE
関連項目:
定数フィールド値
コンストラクタの詳細

DatabaseColumn

public DatabaseColumn()

DatabaseColumn

public DatabaseColumn(int columnType)

DatabaseColumn

public DatabaseColumn(int columnType,
                      int index)

DatabaseColumn

public DatabaseColumn(String tableName,
                      String columnName,
                      String dataType,
                      int index,
                      boolean primaryKey)
メソッドの詳細

setColumnType

public void setColumnType(int columnType)

setFormat

public void setFormat(String format)

getColumnType

public int getColumnType()

getFormat

public String getFormat()

setIndex

public void setIndex(int index)

getIndex

public int getIndex()

isNumber

public boolean isNumber()

setColumnName

public void setColumnName(String columnName)

getColumnName

public String getColumnName()

isPrimaryKey

public boolean isPrimaryKey()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DatabaseExport (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DatabaseExport

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DatabaseExport
推奨されていません。 システム内部で利用しているクラスです。

public class DatabaseExport
extends Object

フィールドの概要
static int | DBTYPE_DB2 推奨されていません。
static int | DBTYPE_ORACLE 推奨されていません。
static int | DBTYPE_POSTGRESQL 推奨されていません。
static int | DBTYPE_SQLSERVER 推奨されていません。
メソッドの概要
void | addCSVHeaderText(String value) 推奨されていません。 出力するCSVのヘッダ部分をセットします。
static void | clearInstance() 推奨されていません。 DatabaseExportインスタンスを開放します。
static void | close(Connection con, PreparedStatement stmt) 推奨されていません。
void | discontinue() 推奨されていません。 現在実行中のエクスポート処理を中止します。
void | downloadCSV(PreparedStatement stmt, String fileName, boolean isTitle) 推奨されていません。 CSVファイルをダウンロードします。
void | downloadCSV(PreparedStatement stmt, String fileName, int startIndex, int maxRow, boolean isTitle) 推奨されていません。 CSVファイルをダウンロードします。
void | downloadCSV(String sql, String fileName, int startIndex, int maxRow, String connectId, boolean isGroup, boolean isTitle) 推奨されていません。 CSVファイルをダウンロードします。
int | exportCSV(PreparedStatement stmt, NetworkFile file, boolean isTitle) 推奨されていません。 CSVファイルをストレージに出力します。
int | exportCSV(PreparedStatement stmt, NetworkFile file, int startIndex, int maxRow, boolean isTitle) 推奨されていません。 CSVファイルをストレージに出力します。
int | exportCSV(PreparedStatement stmt, OutputStream out, boolean isTitle) 推奨されていません。 CSV形式のデータをストリームに出力します。
int | exportCSV(PreparedStatement stmt, OutputStream out, int startIndex, int maxRow, boolean isTitle) 推奨されていません。 CSV形式のデータをストリームに出力します。
DatabaseColumn[] | getColumnsInfo() 推奨されていません。
static Connection | getConnection(String connectId, boolean isGroup) 推奨されていません。 データベースコネクションを取得します。
String[] | getCSVStrings(PreparedStatement stmt, boolean isTitle) 推奨されていません。 CSV形式のデータ取得します。
String[] | getCSVStrings(PreparedStatement stmt, int startIndex, int maxRow, boolean isTitle) 推奨されていません。 CSV形式のデータ取得します。
static int | getDbType(Connection con) 推奨されていません。
int | getExecutingLineNumber() 推奨されていません。 現在エクスポート実行中の行番号を返します。
static DatabaseExport | getInstance() 推奨されていません。 DatabaseExportインスタンスを取得します。
static HttpServletRequest | getRequest() 推奨されていません。
static HttpServletResponse | getResponse() 推奨されていません。
void | setColumnsInfo(DatabaseColumn[] columns) 推奨されていません。
void | setDetectionTimeOut(Integer detectionTimeOutSecond) 推奨されていません。 書き込みタイムアウト時間を設定します。
void | setExportEncoding(String encoding) 推奨されていません。
void | setFieldNames(String[] fieldNames) 推奨されていません。
void | setNullValue(String nullValue) 推奨されていません。 データベースから取得されたデータがnullの場合の代替文字列を設定します。
void | setSleepInterval(int sleepRecordCount, int sleepTime) 推奨されていません。 指定された行数のレコードを書き出すごとに スレッドを一定時間スリープさせます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DBTYPE_ORACLE

public static final int DBTYPE_ORACLE
推奨されていません。
関連項目:
定数フィールド値

DBTYPE_DB2

public static final int DBTYPE_DB2
推奨されていません。
関連項目:
定数フィールド値

DBTYPE_POSTGRESQL

public static final int DBTYPE_POSTGRESQL
推奨されていません。
関連項目:
定数フィールド値

DBTYPE_SQLSERVER

public static final int DBTYPE_SQLSERVER
推奨されていません。
関連項目:
定数フィールド値
メソッドの詳細

setSleepInterval

public void setSleepInterval(int sleepRecordCount,
                             int sleepTime)
推奨されていません。
指定された行数のレコードを書き出すごとに
スレッドを一定時間スリープさせます。
0を設定された場合は、スリープを行いません。

パラメータ:
sleepRecordCount -
sleepTime -

setNullValue

public void setNullValue(String nullValue)
推奨されていません。
データベースから取得されたデータがnullの場合の代替文字列を設定します。

パラメータ:
nullValue - 代替文字列

setDetectionTimeOut

public void setDetectionTimeOut(Integer detectionTimeOutSecond)
推奨されていません。
書き込みタイムアウト時間を設定します。
0が設定された場合はタイムアウト監視を行いません。

パラメータ:
detectionTimeOutSecond -

setExportEncoding

public void setExportEncoding(String encoding)
推奨されていません。

getExecutingLineNumber

public int getExecutingLineNumber()
推奨されていません。
現在エクスポート実行中の行番号を返します。

戻り値:
行番号

discontinue

public void discontinue()
推奨されていません。
現在実行中のエクスポート処理を中止します。

getInstance

public static DatabaseExport getInstance()
推奨されていません。
DatabaseExportインスタンスを取得します。
１ユーザに１つインスタンスを割り当てます。

戻り値:

clearInstance

public static void clearInstance()
推奨されていません。
DatabaseExportインスタンスを開放します。

downloadCSV

public void downloadCSV(String sql,
                        String fileName,
                        int startIndex,
                        int maxRow,
                        String connectId,
                        boolean isGroup,
                        boolean isTitle)
                 throws IOException,
                        SQLException,
                        ServletException,
                        DatabaseExportException
推奨されていません。
CSVファイルをダウンロードします。

パラメータ:
sql -
fileName -
startIndex -
maxRow -
connectId -
isGroup -
例外:
NamingException
AccessSecurityException
NotExistException
ServletException
DatabaseExportException
IOException
SQLException

downloadCSV

public void downloadCSV(PreparedStatement stmt,
                        String fileName,
                        boolean isTitle)
                 throws IOException,
                        SQLException,
                        ServletException,
                        DatabaseExportException
推奨されていません。
CSVファイルをダウンロードします。

パラメータ:
stmt -
fileName -
例外:
ServletException
DatabaseExportException
IOException
SQLException

downloadCSV

public void downloadCSV(PreparedStatement stmt,
                        String fileName,
                        int startIndex,
                        int maxRow,
                        boolean isTitle)
                 throws IOException,
                        SQLException,
                        ServletException,
                        DatabaseExportException
推奨されていません。
CSVファイルをダウンロードします。

パラメータ:
stmt -
fileName -
startIndex -
maxRow -
例外:
ServletException
DatabaseExportException
IOException
SQLException

addCSVHeaderText

public void addCSVHeaderText(String value)
推奨されていません。
出力するCSVのヘッダ部分をセットします。

パラメータ:
value -

setFieldNames

public void setFieldNames(String[] fieldNames)
推奨されていません。

setColumnsInfo

public void setColumnsInfo(DatabaseColumn[] columns)
推奨されていません。

getColumnsInfo

public DatabaseColumn[] getColumnsInfo()
推奨されていません。

exportCSV

public int exportCSV(PreparedStatement stmt,
                     OutputStream out,
                     boolean isTitle)
              throws IOException,
                     SQLException,
                     DatabaseExportException
推奨されていません。
CSV形式のデータをストリームに出力します。

パラメータ:
stmt -
out -
例外:
DatabaseExportException
IOException
SQLException

exportCSV

public int exportCSV(PreparedStatement stmt,
                     OutputStream out,
                     int startIndex,
                     int maxRow,
                     boolean isTitle)
              throws IOException,
                     SQLException,
                     DatabaseExportException
推奨されていません。
CSV形式のデータをストリームに出力します。

パラメータ:
stmt -
out -
startIndex -
maxRow -
例外:
DatabaseExportException
IOException
SQLException

exportCSV

public int exportCSV(PreparedStatement stmt,
                     NetworkFile file,
                     boolean isTitle)
              throws IOException,
                     SQLException,
                     DatabaseExportException
推奨されていません。
CSVファイルをストレージに出力します。

パラメータ:
stmt -
file -
isTitle -
戻り値:
例外:
IOException
SQLException
DatabaseExportException

exportCSV

public int exportCSV(PreparedStatement stmt,
                     NetworkFile file,
                     int startIndex,
                     int maxRow,
                     boolean isTitle)
              throws IOException,
                     SQLException,
                     DatabaseExportException
推奨されていません。
CSVファイルをストレージに出力します。

パラメータ:
stmt -
file -
startIndex -
maxRow -
isTitle -
戻り値:
例外:
IOException
SQLException
DatabaseExportException

getCSVStrings

public String[] getCSVStrings(PreparedStatement stmt,
                              boolean isTitle)
                       throws IOException,
                              SQLException,
                              DatabaseExportException
推奨されていません。
CSV形式のデータ取得します。

パラメータ:
stmt - ステートメント
戻り値:
例外:
DatabaseExportException
IOException
SQLException

getCSVStrings

public String[] getCSVStrings(PreparedStatement stmt,
                              int startIndex,
                              int maxRow,
                              boolean isTitle)
                       throws IOException,
                              SQLException,
                              DatabaseExportException
推奨されていません。
CSV形式のデータ取得します。

パラメータ:
stmt - ステートメント
startIndex - 取得開始行番号
maxRow - 取得レコード件数
戻り値:
取得されたCSVデータ
例外:
DatabaseExportException
IOException
SQLException

getConnection

public static Connection getConnection(String connectId,
                                       boolean isGroup)
                                throws SQLException
推奨されていません。
データベースコネクションを取得します。

パラメータ:
connectId - 接続ID
isGroup - ログイングループかどうかを示します true/false
戻り値:
コネクションオブジェクト
例外:
SQLException

close

public static void close(Connection con,
                         PreparedStatement stmt)
推奨されていません。

getRequest

public static HttpServletRequest getRequest()
推奨されていません。

getResponse

public static HttpServletResponse getResponse()
推奨されていません。

getDbType

public static int getDbType(Connection con)
                     throws SQLException
推奨されていません。
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DatabaseManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DatabaseManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DatabaseManager
public class DatabaseManager
extends Object

データベースマネージャクラス。

コネクションオブジェクトを管理するマネージャです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | beginTransaction() データベースアクセスのトランザクションを開始します。
void | commit() データベースのトランザクションをコミットします。
String | dateToString(Date date) データベース登録用文字列を取得します。
String[] | getConnectIdsBySystem() システムに紐付くシステム接続名の一覧を取得します。
String | getDataSourceNameByLoginGroup(String groupId) ログイングループIDからデータソース参照名を取得します。
String | getDataSourceNameBySystem(String connectId) システム接続名からデータソース参照名を取得します。
DbTypes | getGroupDatabaseType(String groupId) ログイングループデータソースおけるデータベースの種類を取得する。
static DatabaseManager | getInstance() データべースマネージャインスタンスを生成します。
Connection | getJdbcConnection(String driver, String connectURL, String user, String password) JDBCからコネクションオブジェクトを取得します。
Connection | getLoginGroupConnection(String groupId) ログイングループIDからコネクションオブジェクトを取得します。
Connection | getResourceConnection(String resourceRef) リソース参照名からコネクションオブジェクト取得を取得します。
Connection | getSystemConnection(String connectId) システム接続名からコネクションオブジェクトを取得します。
DbTypes | getSystemDatabaseType(String connectId) システムデータソースにおけるデータベースの種類を取得する。
boolean | isTransaction() データベースアクセスのトランザクション状態を取得します。
void | rollback() データベースのトランザクションをロールバックします。
static void | setDatabaseAccessor(DatabaseAccessor databaseAccessor) データベースアクセッサを設定します。
static void | setSourceProvider(DataSourceProvider provider) ソースプロバイダを設定します。
Date | stringToDate(String dateString) データベース登録用文字列からjava.util.Dateを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getInstance

public static DatabaseManager getInstance()
データべースマネージャインスタンスを生成します。

戻り値:
データべースマネージャインスタンス

setDatabaseAccessor

public static void setDatabaseAccessor(DatabaseAccessor databaseAccessor)
データベースアクセッサを設定します。

実際にデータベースコネクションを取得するアクセッサを設定します。

通常、このメソッドを使用する必要はありません。

パラメータ:
databaseAccessor - データベースアクセッサ

setSourceProvider

public static void setSourceProvider(DataSourceProvider provider)
ソースプロバイダを設定します。

データソース設定ファイルを提供するプロバイダを設定します。

通常、このメソッドを使用する必要はありません。

パラメータ:
provider - ソースプロバイダ

getSystemDatabaseType

public DbTypes getSystemDatabaseType(String connectId)
システムデータソースにおけるデータベースの種類を取得する。 指定された接続参照名に一致する、データベースの種類を取得する。

パラメータ:
connectId - 接続参照名
戻り値:
データベースの種類
導入されたバージョン:
6.1.11

getGroupDatabaseType

public DbTypes getGroupDatabaseType(String groupId)
ログイングループデータソースおけるデータベースの種類を取得する。
指定されたログイングループIDに一致する、データベースの種類を取得する。

パラメータ:
groupId - ログイングループID
戻り値:
データベースの種類
導入されたバージョン:
6.1.11

beginTransaction

public void beginTransaction()
                      throws NamingException,
                             NotSupportedException,
                             SystemException
データベースアクセスのトランザクションを開始します。

例外:
NamingException - Context および DirContext インタフェースでの操作によってスローされるすべての例外のスーパークラスです。
SystemException - SystemException は、トランザクションマネージャによってスローされ、トランザクションサービスの処理をこれ以上続行できないような予想外のエラー状態が検出されたことを示します。
NotSupportedException - NotSupportedException 例外は、操作がサポートされていない機能であるために、要求が実行できないことを示します。

isTransaction

public boolean isTransaction()
                      throws NamingException,
                             NotSupportedException,
                             SystemException
データベースアクセスのトランザクション状態を取得します。

戻り値:
true : トランザクション中 / false : トランザクション外
例外:
NamingException - Context および DirContext インタフェースでの操作によってスローされるすべての例外のスーパークラスです。
SystemException - SystemException は、トランザクションマネージャによってスローされ、トランザクションサービスの処理をこれ以上続行できないような予想外のエラー状態が検出されたことを示します。
NotSupportedException - NotSupportedException 例外は、操作がサポートされていない機能であるために、要求が実行できないことを示します。

commit

public void commit()
            throws NamingException,
                   IllegalStateException,
                   SecurityException,
                   RollbackException,
                   HeuristicMixedException,
                   HeuristicRollbackException,
                   SystemException
データベースのトランザクションをコミットします。

例外:
NamingException - Context および DirContext インタフェースでの操作によってスローされるすべての例外のスーパークラスです。
SystemException - SystemException は、トランザクションマネージャによってスローされ、トランザクションサービスの処理をこれ以上続行できないような予想外のエラー状態が検出されたことを示します。
HeuristicRollbackException - この例外は、コミット操作によってスローされ、ヒューリスティックな決定が行われて、それに関連するすべての更新がロールバックされたことを報告します。
HeuristicMixedException - この例外は、ヒューリスティックな決定が行われて、それに関連する一部の更新がコミットされ、残りの更新がロールバックされたことを報告するためにスローされます。
RollbackException - RollbackException 例外は、トランザクションがロールバック専用としてマークされたか、コミットの代わりにロールバックされた場合にスローされます。
SecurityException - セキュリティマネージャによってスローされ、セキュリティ違反を示します。
IllegalStateException - 不正または不適切なときにメソッドが呼び出されたことを示します。

dateToString

public String dateToString(Date date)
データベース登録用文字列を取得します。

パラメータ:
date - 変換元のDateオブジェクト
戻り値:
データベース登録用文字列(yyyy/MM/dd|hh:mm:ss)

getConnectIdsBySystem

public String[] getConnectIdsBySystem()
システムに紐付くシステム接続名の一覧を取得します。

戻り値:
接続名の配列

getDataSourceNameByLoginGroup

public String getDataSourceNameByLoginGroup(String groupId)
ログイングループIDからデータソース参照名を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
データソース参照名

getDataSourceNameBySystem

public String getDataSourceNameBySystem(String connectId)
システム接続名からデータソース参照名を取得します。

パラメータ:
connectId - システム接続名
戻り値:
データソース参照名

getJdbcConnection

public Connection getJdbcConnection(String driver,
                                    String connectURL,
                                    String user,
                                    String password)
                             throws SQLException
JDBCからコネクションオブジェクトを取得します。

パラメータ:
driver - ドライバ名
connectURL - 接続URL
user - DBユーザ
password - DBパスワード
戻り値:
コネクションオブジェクト
例外:
SQLException - データベースの例外が発生した場合にスローされます。

getLoginGroupConnection

public Connection getLoginGroupConnection(String groupId)
                                   throws NamingException,
                                          SQLException,
                                          NotExistException,
                                          AccessSecurityException
ログイングループIDからコネクションオブジェクトを取得します。
ログイングループに紐付いたコネクションオブジェクトを取得します。

パラメータ:
groupId - ログイングループID
戻り値:
コネクションオブジェクト
例外:
NamingException - データベースリソース参照名が解決できなかった場合にスローされます。
SQLException - データベースの例外が発生した場合にスローされます。
NotFoundDataSourceException - システム接続名に対応するデータベース設定情報が存在しなかった場合にスローされます。
AccessSecurityException - データベース設定情報が取得できなかった場合にスローされます。
NotExistException

getResourceConnection

public Connection getResourceConnection(String resourceRef)
                                 throws NamingException,
                                        SQLException
リソース参照名からコネクションオブジェクト取得を取得します。

パラメータ:
resourceRef - リソース参照名
戻り値:
コネクションオブジェクト
例外:
NamingException - データベースリソース参照名が解決できなかった場合にスローされます。
SQLException - データベースの例外が発生した場合にスローされます。

getSystemConnection

public Connection getSystemConnection(String connectId)
                               throws NamingException,
                                      SQLException,
                                      NotExistException,
                                      AccessSecurityException
システム接続名からコネクションオブジェクトを取得します。
システムに紐付いたコネクションオブジェクトを取得します。

パラメータ:
connectId - システム接続名
戻り値:
コネクションオブジェクト
例外:
NamingException - データベースリソース参照名が解決できなかった場合にスローされます。
SQLException - データベースの例外が発生した場合にスローされます。
NotFoundDataSourceException - システム接続名に対応するデータベース設定情報が存在しなかった場合にスローされます。
AccessSecurityException - データベース設定情報が取得できなかった場合にスローされます。
NotExistException

rollback

public void rollback()
              throws NamingException,
                     IllegalStateException,
                     SecurityException,
                     SystemException
データベースのトランザクションをロールバックします。

例外:
NamingException - Context および DirContext インタフェースでの操作によってスローされるすべての例外のスーパークラスです。
SystemException - SystemException は、トランザクションマネージャによってスローされ、トランザクションサービスの処理をこれ以上続行できないような予想外のエラー状態が検出されたことを示します。
SecurityException - セキュリティマネージャによってスローされ、セキュリティ違反を示します。
IllegalStateException - 不正または不適切なときにメソッドが呼び出されたことを示します。

stringToDate

public Date stringToDate(String dateString)
データベース登録用文字列からjava.util.Dateを取得します。

パラメータ:
dateString - 変換元のデータベース登録用文字列(yyyy/MM/dd|hh:mm:ss)
戻り値:
Dateオブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataSourceProvider (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
インタフェース DataSourceProvider

public interface DataSourceProvider

データソース設定情報取得プロバイダインタフェース。

データソース設定情報を取得するためのプロバイダインタフェースです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
 InputStream getInputStream()
データソース設定ファイルのストリームを取得します。

メソッドの詳細

getInputStream

public InputStream getInputStream()
データソース設定ファイルのストリームを取得します。

戻り値:
データソース設定ファイルのストリーム
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DbManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DbManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DbManager
推奨されていません。 DatabaseManagerを使用してください。

public class DbManager
extends Object

データベース操作APIです。

データベース操作を行います。

導入されたバージョン:
3.0
バージョン:
2.0

コンストラクタの概要
DbManager(String connectID)
推奨されていません。 DatabaseManagerを使用してください。
メソッドの概要
 boolean contact()
推奨されていません。 代替えメソッドはありません。
static boolean contact(ConInfo dio)
推奨されていません。 代替えメソッドはありません。
static String dateToString(Date date)
推奨されていません。 DatabaseManager.dateToString(Date)を使用してください。
static String[] getConnectIDs()
推奨されていません。 DatabaseManager.getConnectIdsBySystem()を使用してください。
 ConInfo getConnectInfo()
推奨されていません。 代替えメソッドはありません。
 DbsConnection getConnection()
推奨されていません。 DatabaseManager.getLoginGroupConnection(String) および DatabaseManager.getSystemConnection(String)を使用してください。
static String[] getReference()
推奨されていません。 DatabaseManager.getConnectIdsBySystem()を使用してください。
 boolean isConnect()
推奨されていません。 代替えメソッドはありません。
static Date stringToDate(String dateString)
推奨されていません。 DatabaseManager.stringToDate(String)を使用してください。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DbManager

public DbManager(String connectID)
推奨されていません。 DatabaseManagerを使用してください。

コンストラクタ

パラメータ:
connectID - 接続参照名
メソッドの詳細

contact

public static boolean contact(ConInfo dio)
推奨されていません。 代替えメソッドはありません。

データベース接続を試みます。

パラメータ:
dio - データベース接続情報オブジェクト
戻り値:
成功 ture／失敗 false

dateToString

public static String dateToString(Date date)
推奨されていません。 DatabaseManager.dateToString(Date)を使用してください。

データベース登録用文字列を取得します。

パラメータ:
date - java.util.Date
戻り値:
データベース登録用文字列(YYYY/MM/DD|hh:mm:ss)
導入されたバージョン:
Version 4.0

getConnectIDs

public static String[] getConnectIDs()
推奨されていません。 DatabaseManager.getConnectIdsBySystem()を使用してください。

データベース接続参照名一覧を取得する。

戻り値:
データベース接続参照名配列

getReference

public static String[] getReference()
推奨されていません。 DatabaseManager.getConnectIdsBySystem()を使用してください。

データベース接続設定参照名を取得する。

戻り値:
データベース接続設定参照名配列

stringToDate

public static Date stringToDate(String dateString)
推奨されていません。 DatabaseManager.stringToDate(String)を使用してください。

データベース登録用文字列からjava.util.Date取得します。

パラメータ:
dateString - データベース登録用文字列(YYYY/MM/DD|hh:mm:ss)
戻り値:
java.util.Date
導入されたバージョン:
Version 4.0

contact

public boolean contact()
推奨されていません。 代替えメソッドはありません。

データベース接続を試みます。

戻り値:
成功 ture／失敗 false

getConnectInfo

public ConInfo getConnectInfo()
推奨されていません。 代替えメソッドはありません。

データベース接続情報を取得します。

指定の接続参照名のデータベース接続情報を取得します。

戻り値:
ConInfo データベース接続情報オブジェクト

getConnection

public DbsConnection getConnection()
                            throws SQLException
推奨されていません。 DatabaseManager.getLoginGroupConnection(String) および DatabaseManager.getSystemConnection(String)を使用してください。

データベースコネクションを取得します。

このメソッドで取得したコネクションを使用後は、そのコネクションの releaseメソッドを必ず 呼び出すこと。
releaseメソッドを呼び出さずにこのメソッドを実行した場合、 コネクションの取得に失敗し、nullが 返ります。

戻り値:
データベースコネクションオブジェクト
例外:
SQLException

isConnect

public boolean isConnect()
推奨されていません。 代替えメソッドはありません。

データベース接続の状態を確認します。

戻り値:
接続されている ture／接続されていない false
一度接続されると、途中、何らかの理由でデータベースとの接続が切断されてもtrueを返し続ける。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DbsConnection (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
インタフェース DbsConnection

すべてのスーパーインタフェース:
Connection
推奨されていません。 Connectionを利用してください。

public interface DbsConnection
extends Connection

特定のデータベースとの接続 (セッション) を表現します。
Connection のコンテキスト内で SQL 文が実行され結果が返されます。

このコネクションを使用後は必ずreleaseメソッドを呼び出し、解放して下さい。

フィールドの概要
インタフェース java.sql.Connection から継承したフィールド
TRANSACTION_NONE, TRANSACTION_READ_COMMITTED, TRANSACTION_READ_UNCOMMITTED, TRANSACTION_REPEATABLE_READ, TRANSACTION_SERIALIZABLE
メソッドの概要
void | clearWarnings() 推奨されていません。 この Connection オブジェクトに関して通知されたすべての警告をクリアします。
void | close() 推奨されていません。 releaseメソッドと同等です。
void | commit() 推奨されていません。 データベースアクセスの確定処理を行います。
Statement | createStatement() 推奨されていません。 SQL 文をデータベースに送るための Statement オブジェクトを生成します。
Statement | createStatement(int resultSetType, int resultSetConcurrency) 推奨されていません。 指定されたタイプと並行処理で ResultSet オブジェクトを生成する Statement オブジェクトを生成します。
Statement | createStatement(int resultSetType, int resultSetConcurrency, int resultSetHoldability) 推奨されていません。 指定された型、並行処理、および holdability で ResultSet オブジェクトを生成する Statement オブジェクトを生成します。
int | execute(String sql) 推奨されていません。 任意のＳＱＬ文をデータベースに対してリクエストする insert/update/delete文を実行する。
List | fetch(String sql, int startRow, int endRow) 推奨されていません。 SELECT文を発行してデータベースから指定範囲のデータを取得する
boolean | getAutoCommit() 推奨されていません。 現在の自動コミットの状態を取得します。
String | getCatalog() 推奨されていません。 Connection の現在のカタログ名を返します。
ConInfo | getConnectionInfo() 推奨されていません。 データベース設定情報を取得します。
int | getCount(String tablename, String where) 推奨されていません。 指定条件に該当する表内のデータ件数を取得する
String | getDbName() 推奨されていません。 このデータベース製品の名前を取得します。
String | getDbVersion() 推奨されていません。 このデータベース製品のバージョンを取得します。
String | getEscape() 推奨されていません。 ワイルドカード文字をエスケープするのに使用できる文字列を取得します。
int | getHoldability() 推奨されていません。 この Connection オブジェクトを使用して生成された ResultSet オブジェクトの現在の保持機能を取得します。
DatabaseMetaData | getMetaData() 推奨されていません。 この接続のデータベースに関するメタデータを取得します。
int | getTransactionIsolation() 推奨されていません。 この Connection の現在のトランザクション遮断レベルを取得します。
Map | getTypeMap() 推奨されていません。 この接続に関連した型マップオブジェクトを取得します。
SQLWarning | getWarnings() 推奨されていません。 この Connection に関する呼び出しによって通知された最初の警告を返します。
int | insert(String table, Map datas) 推奨されていません。 データベースにデータを追加挿入するメソッド データベースにインサート処理をする。
boolean | isClosed() 推奨されていません。 Connection がクローズされているかどうかを判定します。
boolean | isColumn(String clmnname, String tblname) 推奨されていません。 データベースの表内に指定カラムが存在するか調べる
boolean | isDataSource() 推奨されていません。 このコネクションがDataSourceかを返します。
boolean | isReadOnly() 推奨されていません。 Connection が読み込み専用モードかどうかを判定します。
String | nativeSQL(String sql) 推奨されていません。 指定された SQL 文をシステムの本来の SQL 文法に変換します。
CallableStatement | prepareCall(String sql) 推奨されていません。 データベースのストアドプロシージャを呼び出すための CallableStatement オブジェクトを生成します。
CallableStatement | prepareCall(String sql, int resultSetType, int resultSetConcurrency) 推奨されていません。 指定されたタイプと並行処理で ResultSet オブジェクトを生成する CallableStatement オブジェクトを生成します。
CallableStatement | prepareCall(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability) 推奨されていません。 指定された型と並行処理で ResultSet オブジェクトを生成する CallableStatement オブジェクトを生成します。
PreparedStatement | prepareStatement(String sql) 推奨されていません。 パラメータ付き SQL 文をデータベースに送るための PreparedStatement オブジェクトを作成します。
PreparedStatement | prepareStatement(String sql, int autoGeneratedKeys) 推奨されていません。 自動生成キーを取得する機能を持つデフォルトの PreparedStatement オブジェクトを生成します。
PreparedStatement | prepareStatement(String sql, int[] columnIndexes) 推奨されていません。 指定された配列によって指定された自動生成キーを返す機能を持つデフォルトの PreparedStatement オブジェクトを生成します。
PreparedStatement | prepareStatement(String sql, int resultSetType, int resultSetConcurrency) 推奨されていません。 指定されたタイプと並行処理で ResultSet オブジェクトを生成する PreparedStatementオブジェクトを生成します。
PreparedStatement | prepareStatement(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability) 推奨されていません。 指定された型、並行処理、および保持機能で ResultSet オブジェクトを生成する PreparedStatement オブジェクトを生成します。
PreparedStatement | prepareStatement(String sql, String[] columnNames) 推奨されていません。 指定された配列によって指定された自動生成キーを返す機能を持つデフォルトの PreparedStatement オブジェクトを生成します。
void | release() 推奨されていません。 データベースコネクションを解放します。
void | releaseSavepoint(Savepoint savepoint) 推奨されていません。 現在のトランザクションから指定された Savepoint オブジェクトを削除します。
int | remove(String table, String where) 推奨されていません。 データベースにデータを削除するメソッド データベースのデータを削除(デリート)する。
void | rollback() 推奨されていません。 データベースアクセスの取り消し処理をする トランザクションを終了(rollback)させる。
void | rollback(Savepoint savepoint) 推奨されていません。 指定された Savepoint オブジェクトが設定されたあとに行われたすべての変更を元に戻します。
List | select(String sql) 推奨されていません。 SELECT文を発行してデータベースからデータを取得する
void | setAutoCommit(boolean autoCommit) 推奨されていません。
void | setCatalog(String catalog) 推奨されていません。 この Connection のデータベースに作業のためのサブスペースを選択するために、カタログ名を設定します。
void | setHoldability(int holdability) 推奨されていません。 この Connection オブジェクトを使用して生成された ResultSet オブジェクトの保持機能を指定された保持機能へ変更します。
void | setReadOnly(boolean readOnly) 推奨されていません。 この Connection を読み込み専用モードに設定して、データベース最適化を実行するヒントとします。
Savepoint | setSavepoint() 推奨されていません。 現在のトランザクションで名前のないセーブポイントを作成し、それを表す新しい Savepoint オブジェクトを返します。
Savepoint | setSavepoint(String name) 推奨されていません。 現在のトランザクションで指定された名前のセーブポイントを作成し、それを表す新しい Savepoint オブジェクトを返します。
void | setTimer(boolean autoRelease) 推奨されていません。 トランザクション自動切断機能のタイマーをセットする（デフォルトtrue）
void | setTransactionIsolation(int level) 推奨されていません。 トランザクション遮断レベルを指定されたものに変更することを試みます。
void | setTypeMap(Map map) 推奨されていません。 この接続の型マップとして指定された型マップをインストールします。
void | transaction() 推奨されていません。 データベースアクセスのトランザクションを開始する トランザクションを開始させる。
int | update(String table, String where, Map datas) 推奨されていません。 データベースにデータを更新するメソッド データベースのデータを更新(アップデート)する。

メソッドの詳細

clearWarnings

public void clearWarnings()
                   throws SQLException
推奨されていません。
この Connection オブジェクトに関して通知されたすべての警告をクリアします。

このメソッドを呼び出したあと、Connection に対する新しい警告が通知されるまで、getWarnings は null を返します。

定義:
インタフェース Connection 内の clearWarnings
例外:
SQLException - データベースアクセスエラーが発生した場合

close

public void close()
           throws SQLException
推奨されていません。
releaseメソッドと同等です。

定義:
インタフェース Connection 内の close
例外:
SQLException - データベースアクセスエラーが発生した場合

commit

public void commit()
            throws SQLException
推奨されていません。
データベースアクセスの確定処理を行います。

トランザクションを終了(commit)させる。

定義:
インタフェース Connection 内の commit
例外:
SQLException - データベースアクセスエラーが発生した場合

createStatement

public Statement createStatement()
                          throws SQLException
推奨されていません。
SQL 文をデータベースに送るための Statement オブジェクトを生成します。

パラメータなしの SQL 文は通常、Statement オブジェクトを使用して実行されます。同じ SQL 文が多 数回実行される場合は、PreparedStatement オブジェクトを使用する方が効率的です。 返される Statement オブジェクトを使って作成された結果セットは、デフォルトでは、順方 向専用タイプで、読み取り専用の並行処理ができます。

定義:
インタフェース Connection 内の createStatement
戻り値:
新しい Statement オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合

createStatement

public Statement createStatement(int resultSetType,
                                 int resultSetConcurrency)
                          throws SQLException
推奨されていません。
指定されたタイプと並行処理で ResultSet オブジェクトを生成する Statement オブジェクトを生成します。

このメソッドは上記の createStatement メソッドと同じですが、デフォルト の結果セットのタイプおよび結果セットの並行処理の種類をオーバーライドできます。

定義:
インタフェース Connection 内の createStatement
パラメータ:
resultSetType - 結果セットのタイプ。ResultSet.TYPE_XXX を参照
resultSetConcurrency - 並行処理の種類。ResultSet.CONCUR_XXX を参照
戻り値:
新しい Statement オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合

createStatement

public Statement createStatement(int resultSetType,
                                 int resultSetConcurrency,
                                 int resultSetHoldability)
                          throws SQLException
推奨されていません。
指定された型、並行処理、および holdability で ResultSet オブジェクトを生成する Statement オブジェクトを生成します。 このメソッドは上記の createStatement メソッドと同じですが、デフォルトの結果セットの型、並行処理、および保持機能をオーバーライドできます。

定義:
インタフェース Connection 内の createStatement
パラメータ:
resultSetType - ResultSet 定数。ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE、または ResultSet.TYPE_SCROLL_SENSITIVE のうちの 1 つ
resultSetConcurrency - ResultSet 定数。ResultSet.CONCUR_READ_ONLY または ResultSet.CONCUR_UPDATABLE
resultSetHoldability - ResultSet 定数。ResultSet.HOLD_CURSORS_OVER_COMMIT または ResultSet.CLOSE_CURSORS_AT_COMMIT
戻り値:
指定された型、並行処理、および保持機能で ResultSet オブジェクトを生成する新しい Statement オブジェクト
例外:
データベースアクセスエラーが発生した場合、または指定されたパラメータが型、並行処理、および保持機能を示す - ResultSet 定数でない場合
SQLException

execute

public int execute(String sql)
            throws SQLException
推奨されていません。
任意のＳＱＬ文をデータベースに対してリクエストする

insert/update/delete文を実行する。

パラメータ:
sql - insert/update/delete文（引数のSQL文にはステートメント末判定文字(";"や"/"など)は付けない。）
戻り値:
処理行数
例外:
SQLException - データベースアクセスエラーが発生した場合

fetch

public List fetch(String sql,
                  int startRow,
                  int endRow)
           throws SQLException
推奨されていません。
SELECT文を発行してデータベースから指定範囲のデータを取得する

パラメータ:
sql - SQL文（SELECT文）
引数のSQL文にはステートメント末判定文字(";"や"/"など)は付けない。
startRow - 取得するデータの開始レコード位置 (1以上を指定)
endRow - 取得するデータの総件数 (1以上を指定)
戻り値:
Listの各要素はHashtable。カラム名(全て小文字に変換)＝値 で格納される。

取得できるデータはjp.co.intra_mart.foundation.database.DbsConnection.selectメソッドの戻り値と同様に変換されます。

例外:
SQLException - データベースアクセスエラーが発生した場合

getAutoCommit

public boolean getAutoCommit()
                      throws SQLException
推奨されていません。
現在の自動コミットの状態を取得します。

定義:
インタフェース Connection 内の getAutoCommit
戻り値:
現在の自動コミットモードの状態
例外:
SQLException - データベースアクセスエラーが発生した場合

getCatalog

public String getCatalog()
                  throws SQLException
推奨されていません。
Connection の現在のカタログ名を返します。

定義:
インタフェース Connection 内の getCatalog
戻り値:
現在のカタログ名または null
例外:
SQLException - データベースアクセスエラーが発生した場合

getConnectionInfo

public ConInfo getConnectionInfo()
推奨されていません。
データベース設定情報を取得します。

戻り値:
データベース設定情報

getCount

public int getCount(String tablename,
                    String where)
             throws SQLException
推奨されていません。
指定条件に該当する表内のデータ件数を取得する

パラメータ:
tablename - テーブル名
戻り値:
件数。
例外:
SQLException - データベースアクセスエラーが発生した場合

getDbName

public String getDbName()
                 throws SQLException
推奨されていません。
このデータベース製品の名前を取得します。

戻り値:
データベース製品の名前
例外:
SQLException - データベースアクセスエラーが発生した場合

getDbVersion

public String getDbVersion()
                    throws SQLException
推奨されていません。
このデータベース製品のバージョンを取得します。

戻り値:
データベースのバージョン
例外:
SQLException - データベースアクセスエラーが発生した場合

getEscape

public String getEscape()
                 throws SQLException
推奨されていません。
ワイルドカード文字をエスケープするのに使用できる文字列を取得します。

これは、文字列パターンスタイルカタログ検索パラメータで '_' や '%' をエスケープするのに使用できる 文字列です。 '_' 文字は任意の 1 文字を表します。 '%' 文字は 0 文字以上のシーケンスを表します。

戻り値:
ワイルドカード文字をエスケープするのに使用できる文字列
例外:
SQLException - データベースアクセスエラーが発生した場合

getHoldability

public int getHoldability()
                   throws SQLException
推奨されていません。
この Connection オブジェクトを使用して生成された ResultSet オブジェクトの現在の保持機能を取得します。

定義:
インタフェース Connection 内の getHoldability
戻り値:
保持機能。ResultSet.HOLD_CURSORS_OVER_COMMIT または ResultSet.CLOSE_CURSORS_AT_COMMIT
例外:
データベースアクセスエラーが発生した場合
SQLException

getMetaData

public DatabaseMetaData getMetaData()
                             throws SQLException
推奨されていません。
この接続のデータベースに関するメタデータを取得します。

Connection のデータベースは、テーブル、サポートしている SQL 文法、ストアドプロシージャ、 およびこの接続の能力などを記述する情報を提供します。この情報は、DatabaseMetaData オブジェクトから 取得します。

定義:
インタフェース Connection 内の getMetaData
戻り値:
この Connection に対する DatabaseMetaData オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合

getTransactionIsolation

public int getTransactionIsolation()
                            throws SQLException
推奨されていません。
この Connection の現在のトランザクション遮断レベルを取得します。

定義:
インタフェース Connection 内の getTransactionIsolation
戻り値:
現在の TRANSACTION_* モード値
例外:
SQLException - データベースアクセスエラーが発生した場合

getTypeMap

public Map getTypeMap()
               throws SQLException
推奨されていません。
この接続に関連した型マップオブジェクトを取得します。

アプリケーションが型マップにエントリを追加していない限り、空のマップが返されます。

定義:
インタフェース Connection 内の getTypeMap
戻り値:
この Connection オブジェクトに関連した java.util.Map オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合

getWarnings

public SQLWarning getWarnings()
                       throws SQLException
推奨されていません。
この Connection に関する呼び出しによって通知された最初の警告を返します。

注: 引き続く警告は、この SQLWarning にチェーンされます。

定義:
インタフェース Connection 内の getWarnings
戻り値:
最初の SQLWarning または null
例外:
SQLException - データベースアクセスエラーが発生した場合

insert

public int insert(String table,
                  Map datas)
           throws SQLException
推奨されていません。
データベースにデータを追加挿入するメソッド

データベースにインサート処理をする。 挿入データはオブジェクト(Map)形式のデータをセット。 なお、オブジェクトのプロパティ名称は、挿入したい データベースのカラム名称に等しく作成し、そのプロパティに 対して挿入したいデータをセットする。

パラメータ:
table - 処理対象のデータベース表名
datas - 挿入データ 引数 datas(Map)の内容
(key == value)
カラム名 = 値 ここでセットできるデータ型（値）は、String,Numberのみです。
戻り値:
処理行数
例外:
SQLException - データベースアクセスエラーが発生した場合

isClosed

public boolean isClosed()
                 throws SQLException
推奨されていません。
Connection がクローズされているかどうかを判定します。

定義:
インタフェース Connection 内の isClosed
戻り値:
Connection がクローズされている場合は true、まだオープンの状態の場合は false
例外:
SQLException - データベースアクセスエラーが発生した場合

isColumn

public boolean isColumn(String clmnname,
                        String tblname)
                 throws SQLException
推奨されていません。
データベースの表内に指定カラムが存在するか調べる

パラメータ:
clmnname - 存在の有無をチェックしたいカラム名称 （カラム名の大文字小文字は区別しない）
tblname - 定義情報をチェックしたい表名
戻り値:
指定のカラムは存在する ture／指定のカラムは存在しない false
例外:
SQLException - データベースアクセスエラーが発生した場合

isDataSource

public boolean isDataSource()
推奨されていません。
このコネクションがDataSourceかを返します。

戻り値:
DataSourceの場合 true／DataSourceではないの場合 false
例外:
SQLException - データベースアクセスエラーが発生した場合

isReadOnly

public boolean isReadOnly()
                   throws SQLException
推奨されていません。
Connection が読み込み専用モードかどうかを判定します。

定義:
インタフェース Connection 内の isReadOnly
戻り値:
Connection が読み込み専用モードの場合は true、そうでない場合は false
例外:
SQLException - データベースアクセスエラーが発生した場合

nativeSQL

public String nativeSQL(String sql)
                 throws SQLException
推奨されていません。
指定された SQL 文をシステムの本来の SQL 文法に変換します。

ドライバは、送信前にJDBC SQL 文法をシステムの本来の SQL 文法に変換できます。 このメソッドは、ドライバが送る文のシステム本来の形のフォームを返します。

定義:
インタフェース Connection 内の nativeSQL
パラメータ:
sql - 1 つ以上の '?' パラメータプレースホルダーを含めることができる SQL 文
戻り値:
この文の元のフォーム
例外:
SQLException - データベースアクセスエラーが発生した場合

prepareCall

public CallableStatement prepareCall(String sql)
                              throws SQLException
推奨されていません。
データベースのストアドプロシージャを呼び出すための CallableStatement オブジェクトを生成します。

CallableStatement オブジェクトは、その IN と OUT パラメータを設定するメ ソッドとストアドプロシージャの呼び出しを実行するメソッドを提供します。
注: このメソッドは、ストアドプロシージャ呼び出し文を処理するために最適化されていま す。ドライバによっては、prepareCall メソッドが実行されるときにデータベースに呼び出し 文を送るものがあります。その他のドライバは、CallableStatement オブジェクトが実行さ れるまで待ちます。これはユーザに直接的な影響はありませんが、どのメソッドが、どの SQLException をスローしたかに関して影響があります。 返される CallableStatement を 使って作成された結果セットは、デフォルトでは、順方向専用タイプで、読み取り専用の 並行処理ができます。

ストアドプロシジャーの実行例

 以下のようなストアドプロシジャーを実行する場合。
  // ストアドプロシジャー CREATE OR REPLACE PROCEDURE spTest ( retNo IN OUT
 NUMBER,errMsg IN OUT VARCHAR2 ) IS BEGIN retNo := retNo + 1; errMsg :=
 errMsg || 'A'; END; /

 public void execStoredProc(){ DbManager dbmgr = new DbManager("DEFAULT");
 DbsConnection dbsc = dbmgr.getConnection();

 String stmt = new String("{call spTest (?,?)}"); CallableStatement
 clblstmt = dbsc.prepareCall(stmt);
  // パラメータセット clblstmt.setInt(1,2);
 clblstmt.registerOutParameter(1,java.sql.Types.DECIMAL);
 clblstmt.setString(2,"TEST");
 clblstmt.registerOutParameter(2,java.sql.Types.VARCHAR);

 //実行 clblstmt.execute();

 System.out.println(clblstmt.getInt(1));
 System.out.println(clblstmt.getString(2));

 //終了処理 clblstmt.close(); dbsc.release(); }
  <<結果>>3 TESTA

 ストアドファンクションの実行例

 以下のようなストアドファンクションを実行する場合。
  // ストアドファンクション CREATE OR REPLACE FUNCTION fcTest ( retNo IN OUT
 NUMBER,errMsg IN OUT VARCHAR2 ) RETURN number IS retValue number(2);
 BEGIN retNo := retNo + 1; errMsg := errMsg || 'A';

 retValue := 19; return retValue; END; /

 public void execStoredFunc(){ DbManager dbmgr = new DbManager("DEFAULT");
 DbsConnection dbsc = dbmgr.getConnection();

 String stmt = new String("{? = call fcTest (?,?)}");
 CallableStatement clblstmt = dbsc.prepareCall(stmt);
  // 戻り値セット clblstmt.registerOutParameter(1,java.sql.Types.DECIMAL); //
 パラメータセット clblstmt.setInt(1,2);
 clblstmt.registerOutParameter(2,java.sql.Types.DECIMAL);
 clblstmt.setString(2,"TEST");
 clblstmt.registerOutParameter(3,java.sql.Types.VARCHAR);

 //実行 clblstmt.execute();

 System.out.println(clblstmt.getInt(1));
 System.out.println(clblstmt.getInt(2));
 System.out.println(clblstmt.getString(3));

 //終了処理 clblstmt.close(); dbsc.release(); }
  <<結果>>19 3 TESTA

 詳しくはjava.sql.CallableStatementの説明をご覧ください。

定義:
インタフェース Connection 内の prepareCall

パラメータ:
sql - 1 つ以上の '?' パラメータプレースホルダーを含めることができる SQL 文。通 常この文は、JBDC
            関数呼び出しのエスケープ文字列である

戻り値:
プリコンパイルされた SQL 文を含む新しい CallableStatement オブジェクト

例外:

SQLException - データベースアクセスエラーが発生した場合

prepareCall

public CallableStatement prepareCall(String sql,
                                     int resultSetType,
                                     int resultSetConcurrency)
                              throws SQLException
推奨されていません。
指定されたタイプと並行処理で ResultSet オブジェクトを生成する CallableStatement オブジェクトを生成します。

このメソッドは上記の prepareCall メソッドと同じ様ですが、デフ ォルトの結果セットのタイプおよび結果セットの並行処理の種類をオーバーライドできま す。

定義:
インタフェース Connection 内の prepareCall
パラメータ:
resultSetType - 結果セットのタイプ。ResultSet.TYPE_XXX を参照
resultSetConcurrency - 並行処理の種類。ResultSet.CONCUR_XXX を参照
戻り値:
プリコンパイルされた SQL 文を含む新しい CallableStatement オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合

prepareCall

public CallableStatement prepareCall(String sql,
                                     int resultSetType,
                                     int resultSetConcurrency,
                                     int resultSetHoldability)
                              throws SQLException
推奨されていません。
指定された型と並行処理で ResultSet オブジェクトを生成する CallableStatement オブジェクトを生成します。 このメソッドは上記の prepareCall メソッドと同じですが、デフォルトの結果セットの型、結果セットの並行処理の種類、および保持機能をオーバーライドできます。

定義:
インタフェース Connection 内の prepareCall
パラメータ:
sql - SQL 文がデータベースへ送られる String オブジェクト。1 つ以上の ? パラメータを含めることができる
resultSetType - ResultSet 定数。ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE、または ResultSet.TYPE_SCROLL_SENSITIVE のうちの 1 つ
resultSetConcurrency - ResultSet 定数。ResultSet.CONCUR_READ_ONLY または ResultSet.CONCUR_UPDATABLE
resultSetHoldability - ResultSet 定数。ResultSet.HOLD_CURSORS_OVER_COMMIT または ResultSet.CLOSE_CURSORS_AT_COMMIT
戻り値:
プリコンパイルされた SQL 文を含む新しい CallableStatement オブジェクト。指定された型、並行処理、および保持機能で ResultSet オブジェクトを生成する
例外:
データベースアクセスエラーが発生した場合、または指定されたパラメータが型、並行処理、および保持機能を示す - ResultSet 定数でない場合
SQLException

prepareStatement

public PreparedStatement prepareStatement(String sql)
                                   throws SQLException
推奨されていません。
パラメータ付き SQL 文をデータベースに送るための PreparedStatement オブジェクトを作成します。

IN パラメータ付きまたは IN パラメータなしの SQL 文は、プリコンパイルし て、PreparedStatement オブジェクトに格納できます。したがって、このオブジェクトは、こ の文を複数回、効率的に実行するのに使用できます。 注: このメソッドは、プリコンパイルが効果のある、パラメータ付き SQL 文を処理するた めに最適化されています。ドライバが、プリコンパイルをサポートしている場合、 prepareStatement メソッドは、その文をプリコンパイル用としてデータベースに送ります。 ドライバによっては、プリコンパイルをサポートしていないものがあります。この場合、 PreparedStatement が実行されるまで、文はデータベースに送られません。これはユー ザに直接的な影響はありませんが、どのメソッドが、どの SQLException をスローしたか に関して影響があります。 返される PreparedStatement を使って生成された結果セット は、デフォルトでは、順方向専用タイプで、読み取り専用の並行処理ができます。

定義:
インタフェース Connection 内の prepareStatement
パラメータ:
sql - 1 つ以上の '?' IN パラメータプレースホルダーを含めることができる SQL 文
戻り値:
プリコンパイルされた文を含む新しい PreparedStatement オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合

prepareStatement

public PreparedStatement prepareStatement(String sql,
                                          int autoGeneratedKeys)
                                   throws SQLException
推奨されていません。
自動生成キーを取得する機能を持つデフォルトの PreparedStatement オブジェクトを生成します。 指定された定数によって、ドライバが自動生成キーを取得可能にするかどうかが指定されます。 SQL 文が INSERT 文でない場合、このパラメータは無視されます。

注 : このメソッドは、プリコンパイルが効果のある、パラメータ付き SQL 文を処理するために最適化されています。 ドライバが、プリコンパイルをサポートしている場合、prepareStatement メソッドは、その文をプリコンパイル用としてデータベースに送ります。 ドライバによっては、プリコンパイルをサポートしていないものがあります。 この場合、PreparedStatement が実行されるまで、文はデータベースに送られません。 これはユーザに直接的な影響はありませんが、どのメソッドが、どの SQLException をスローしたかに関して影響があります。

返される PreparedStatement オブジェクトを使って作成された結果セットは、デフォルトでは、TYPE_FORWARD_ONLY の型で、CONCUR_READ_ONLY の並行処理レベルを持ちます。

定義:
インタフェース Connection 内の prepareStatement
パラメータ:
sql - 1 つ以上の '?' IN パラメータプレースホルダーを含めることができる SQL 文
autoGeneratedKeys - 自動生成キーを返すかどうかを示すフラグ。次の Statement 定数のうちの 1 つ
戻り値:
プリコンパイルされた SQL 文を含む新しい PreparedStatement オブジェクト。自動生成キーを返す機能を持つ
例外:
データベースアクセスエラーが発生した場合、または指定されたパラメータが自動生成キーを返すかどうかを示す - Statement 定数でない場合
SQLException

prepareStatement

public PreparedStatement prepareStatement(String sql,
                                          int resultSetType,
                                          int resultSetConcurrency)
                                   throws SQLException
推奨されていません。
指定されたタイプと並行処理で ResultSet オブジェクトを生成する PreparedStatementオブジェクトを生成します。

このメソッドは上記の prepareStatement メソッドと同じです が、デフォルトの結果セットのタイプおよび結果セットの並行処理の種類をオーバーライド できます。

定義:
インタフェース Connection 内の prepareStatement
パラメータ:
resultSetType - 結果セットのタイプ。ResultSet.TYPE_XXX を参照
resultSetConcurrency - 並行処理の種類。ResultSet.CONCUR_XXX を参照
戻り値:
プリコンパイルされた SQL 文を含む新しい PreparedStatement オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合

prepareStatement

public PreparedStatement prepareStatement(String sql,
                                          int resultSetType,
                                          int resultSetConcurrency,
                                          int resultSetHoldability)
                                   throws SQLException
推奨されていません。
指定された型、並行処理、および保持機能で ResultSet オブジェクトを生成する PreparedStatement オブジェクトを生成します。

このメソッドは上記の prepareStatement メソッドと同じですが、デフォルトの結果セットの型、並行処理、および保持機能をオーバーライドできます。

定義:
インタフェース Connection 内の prepareStatement
パラメータ:
sql - SQL 文がデータベースへ送られる String オブジェクト。1 つ以上の ? IN パラメータを含めることができる
resultSetType - ResultSet 定数。ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE、または ResultSet.TYPE_SCROLL_SENSITIVE のうちの 1 つ
resultSetConcurrency - ResultSet 定数。ResultSet.CONCUR_READ_ONLY または ResultSet.CONCUR_UPDATABLE
resultSetHoldability - ResultSet 定数。ResultSet.HOLD_CURSORS_OVER_COMMIT または ResultSet.CLOSE_CURSORS_AT_COMMIT
戻り値:
プリコンパイルされた SQL 文を含む新しい PreparedStatement オブジェクト。指定された型、並行処理、および保持機能で ResultSet オブジェクトを生成する
例外:
SQLException - データベースアクセスエラーが発生した場合、または指定されたパラメータが型、並行処理、および保持機能を示す ResultSet 定数でない場合

prepareStatement

public PreparedStatement prepareStatement(String sql,
                                          int[] columnIndexes)
                                   throws SQLException
推奨されていません。
指定された配列によって指定された自動生成キーを返す機能を持つデフォルトの PreparedStatement オブジェクトを生成します。この配列は、 使用可能にされる自動生成キーを含むターゲットテーブルの列のインデックスを含みます。 SQL 文が INSERT 文でない場合、この配列は無視されます。

IN パラメータ付きまたは IN パラメータなしの SQL 文は、プリコンパイルして、PreparedStatement オブジェクトに格納できます。 したがって、このオブジェクトは、この文を複数回、効率的に実行するのに使用できます。

注 : このメソッドは、プリコンパイルが効果のある、パラメータ付き SQL 文を処理するために最適化されています。 ドライバが、プリコンパイルをサポートしている場合、prepareStatement メソッドは、その文をプリコンパイル用としてデータベースに送ります。 ドライバによっては、プリコンパイルをサポートしていないものがあります。この場合、PreparedStatement が実行されるまで、文はデータベースに送られません。 これはユーザに直接的な影響はありませんが、どのメソッドが、どの SQLException をスローしたかに関して影響があります。

返される PreparedStatement オブジェクトを使って作成された結果セットは、デフォルトでは、TYPE_FORWARD_ONLY の型で、CONCUR_READ_ONLY の並行処理レベルを持ちます。

定義:
インタフェース Connection 内の prepareStatement
パラメータ:
sql - 1 つ以上の '?' IN パラメータプレースホルダーを含めることができる SQL 文
columnIndexes - 挿入された行から返される列を示す列インデックスの配列
戻り値:
プリコンパイルされた文を含む新しい PreparedStatement オブジェクト。指定された列インデックスの配列によって指定される自動生成キーを返す機能を持つ
例外:
データベースアクセスエラーが発生した場合
SQLException

prepareStatement

public PreparedStatement prepareStatement(String sql,
                                          String[] columnNames)
                                   throws SQLException
推奨されていません。
指定された配列によって指定された自動生成キーを返す機能を持つデフォルトの PreparedStatement オブジェクトを生成します。 この配列は、返される自動生成キーを含むターゲットテーブルの列の名前を含みます。 SQL 文が INSERT 文でない場合、この配列は無視されます。

IN パラメータ付きまたは IN パラメータなしの SQL 文は、プリコンパイルして、PreparedStatement オブジェクトに格納できます。 したがって、このオブジェクトは、この文を複数回、効率的に実行するのに使用できます。

注 : このメソッドは、プリコンパイルが効果のある、パラメータ付き SQL 文を処理するために最適化されています。 ドライバが、プリコンパイルをサポートしている場合、prepareStatement メソッドは、その文をプリコンパイル用としてデータベースに送ります。 ドライバによっては、プリコンパイルをサポートしていないものがあります。 この場合、PreparedStatement が実行されるまで、文はデータベースに送られません。 これはユーザに直接的な影響はありませんが、どのメソッドが、どの SQLException をスローしたかに関して影響があります。

返される PreparedStatement オブジェクトを使って作成された結果セットは、デフォルトでは、TYPE_FORWARD_ONLY の型で、CONCUR_READ_ONLY の並行処理レベルを持ちます。

定義:
インタフェース Connection 内の prepareStatement
パラメータ:
sql - 1 つ以上の '?' IN パラメータプレースホルダーを含めることができる SQL 文
columnNames - 挿入された行から返される列を示す列名の配列
戻り値:
プリコンパイルされた文を含む新しい PreparedStatement オブジェクト。指定された列名の配列によって指定される自動生成キーを返す機能を持つ
例外:
データベースアクセスエラーが発生した場合
SQLException

release

public void release()
             throws SQLException
推奨されていません。
データベースコネクションを解放します。

現在使用しているデータベースコネクションをシステムに返します。 このコネクションを使用後、必ず一回呼び出して下さい。

例外:
SQLException - データベースアクセスエラーが発生した場合

releaseSavepoint

public void releaseSavepoint(Savepoint savepoint)
                      throws SQLException
推奨されていません。
現在のトランザクションから指定された Savepoint オブジェクトを削除します。削除されたあとでセーブポイントを参照すると SQLException がスローされます。

定義:
インタフェース Connection 内の releaseSavepoint
パラメータ:
savepoint - 削除される Savepoint オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合、または指定された Savepoint オブジェクトが現在のトランザクションで有効なセーブポイントでない場合

remove

public int remove(String table,
                  String where)
           throws SQLException
推奨されていません。
データベースにデータを削除するメソッド

データベースのデータを削除(デリート)する。 条件を設定すると、条件に合致したすべてのレコードを削除する。

パラメータ:
table - 処理対象のデータベース表名
where - 更新部分検索条件(WHERE 句)
戻り値:
処理行数
例外:
SQLException - データベースアクセスエラーが発生した場合

rollback

public void rollback()
              throws SQLException
推奨されていません。
データベースアクセスの取り消し処理をする

トランザクションを終了(rollback)させる。

定義:
インタフェース Connection 内の rollback
例外:
SQLException - データベースアクセスエラーが発生した場合

rollback

public void rollback(Savepoint savepoint)
              throws SQLException
推奨されていません。
指定された Savepoint オブジェクトが設定されたあとに行われたすべての変更を元に戻します。

定義:
インタフェース Connection 内の rollback
パラメータ:
savepoint - ロールバックする Savepoint オブジェクト
例外:
データベースアクセスエラーが発生した場合、Savepoint - オブジェクトが有効でなくなった場合、または現在この Connection オブジェクトが自動コミットモードである場合
SQLException

select

public List select(String sql)
            throws SQLException
推奨されていません。
SELECT文を発行してデータベースからデータを取得する

パラメータ:
sql - SQL文（SELECT文）
引数のSQL文にはステートメント末判定文字(";"や"/"など)は付けない。
戻り値:
Listの各要素はHashtable。カラム名(全て小文字に変換)＝値 で格納される。 取得できるデータは以下のように変換されます。

JDBCドライバによっては以下の表の通りに取得できない場合もあります。
java.sql.Types.CHAR | java.lang.String
java.sql.Types.CLOB(※１)
java.sql.Types.LONGVARCHAR
java.sql.Types.VARCHAR
java.sql.Types.TIMESTAMP
java.sql.Types.OTHER(※１)
java.sql.Types.BIT | java.lang.Double
java.sql.Types.BIGINT
java.sql.Types.DECIMAL
java.sql.Types.DOUBLE
java.sql.Types.FLOAT
java.sql.Types.INTEGER
java.sql.Types.NUMERIC
java.sql.Types.REAL
java.sql.Types.SMALLINT
java.sql.Types.TINYINT
java.sql.Types.DATE | java.util.Date
java.sql.Types.TIME
java.sql.Types.BINARY(※１) | java.lang.String（エンコードしないString(バイナリ形式)）
java.sql.Types.LONGVARBINARY(※１)
java.sql.Types.VARBINARY(※１)
java.sql.Types.NULL | 取得しない
java.sql.Types.REF(※１) | java.lang.Object(java.sql.ResultSet.getObject()で取得した値)
java.sql.Types.JAVA_OBJECT(※１)
java.sql.Types.STRUCT(※１)
java.sql.Types.ARRAY(※１)
java.sql.Types.DISTINCT(※１)
(※１)推奨されません。動作未検証です。
例外:
SQLException - データベースアクセスエラーが発生した場合

setAutoCommit

public void setAutoCommit(boolean autoCommit)
                   throws SQLException
推奨されていません。

定義:
インタフェース Connection 内の setAutoCommit
例外:
SQLException

setCatalog

public void setCatalog(String catalog)
                throws SQLException
推奨されていません。
この Connection のデータベースに作業のためのサブスペースを選択するために、カタログ名を設定します。

ドライバがカタログをサポートしていない場合は、この要求を無視しま す。

定義:
インタフェース Connection 内の setCatalog
例外:
SQLException - データベースアクセスエラーが発生した場合

setHoldability

public void setHoldability(int holdability)
                    throws SQLException
推奨されていません。
この Connection オブジェクトを使用して生成された ResultSet オブジェクトの保持機能を指定された保持機能へ変更します。

定義:
インタフェース Connection 内の setHoldability
パラメータ:
holdability - ResultSet の保持機能定数。ResultSet.HOLD_CURSORS_OVER_COMMIT または ResultSet.CLOSE_CURSORS_AT_COMMIT
例外:
データベースアクセスエラーが発生した場合、指定されたパラメータが保持機能を示す - ResultSet 定数でない場合、または指定された保持機能がサポートされていない場合
SQLException

setReadOnly

public void setReadOnly(boolean readOnly)
                 throws SQLException
推奨されていません。
この Connection を読み込み専用モードに設定して、データベース最適化を実行するヒントとします。

注: トランザクションの途中では、このメソッドを呼び出すことはできません。

定義:
インタフェース Connection 内の setReadOnly
パラメータ:
readOnly - true の場合は読み込み専用モードが有効、false の場合は読み込み専用モードが無効
例外:
SQLException - データベースアクセスエラーが発生した場合

setSavepoint

public Savepoint setSavepoint()
                       throws SQLException
推奨されていません。
現在のトランザクションで名前のないセーブポイントを作成し、それを表す新しい Savepoint オブジェクトを返します。

定義:
インタフェース Connection 内の setSavepoint
戻り値:
新しい Savepoint オブジェクト
例外:
データベースアクセスエラーが発生した場合、または現在この - Connection オブジェクトが自動コミットモードである場合
SQLException

setSavepoint

public Savepoint setSavepoint(String name)
                       throws SQLException
推奨されていません。
現在のトランザクションで指定された名前のセーブポイントを作成し、それを表す新しい Savepoint オブジェクトを返します。

定義:
インタフェース Connection 内の setSavepoint
パラメータ:
name - セーブポイントの名前を格納する String
戻り値:
新しい Savepoint オブジェクト
例外:
データベースアクセスエラーが発生した場合、または現在この - Connection オブジェクトが自動コミットモードである場合
SQLException

setTimer

public void setTimer(boolean autoRelease)
              throws SQLException
推奨されていません。
トランザクション自動切断機能のタイマーをセットする（デフォルトtrue）

パラメータ:
autoRelease - タイマーストップ false ／スタート true
例外:
SQLException

setTransactionIsolation

public void setTransactionIsolation(int level)
                             throws SQLException
推奨されていません。
トランザクション遮断レベルを指定されたものに変更することを試みます。

指定できるトランザクション遮断レベルの定数は、Connection インタフェースで定義されています。
注: トランザクションの途中では、このメソッドを呼び出すことはできません。

定義:
インタフェース Connection 内の setTransactionIsolation
パラメータ:
level - TRANSACTION_NONE を除く TRANSACTION_* 遮断値の 1 つ。データベースによっては、ほかの値をサポートしないものがある
例外:
SQLException - データベースアクセスエラーが発生した場合

setTypeMap

public void setTypeMap(Map map)
                throws SQLException
推奨されていません。
この接続の型マップとして指定された型マップをインストールします。

型マップは、SQL 構造化型および個別の型のカスタムマッピングに使用されます。

定義:
インタフェース Connection 内の setTypeMap
パラメータ:
map - この Connection オブジェクトのデフォルトの型マップの代わりとしてインスト ールする java.util.Map オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合

transaction

public void transaction()
                 throws SQLException
推奨されていません。
データベースアクセスのトランザクションを開始する

トランザクションを開始させる。

例外:
SQLException - データベースアクセスエラーが発生した場合

update

public int update(String table,
                  String where,
                  Map datas)
           throws SQLException
推奨されていません。
データベースにデータを更新するメソッド

データベースのデータを更新(アップデート)する。 更新データはオブジェクト(Map)形式のデータをセット。 なお、オブジェクトのプロパティ名称は、更新したい データベースのカラム名称に等しく作成し、そのプロパティに 対して挿入したいデータをセットする。

パラメータ:
table - 処理対象のデータベース表名
where - 更新部分検索条件(WHERE 句)
datas - 更新データ 引数 datas(Map)の内容
(key == value)
カラム名 = 値 ここでセットできるデータ型（値）は、String,Numberのみです。
戻り値:
処理行数
例外:
SQLException - データベースアクセスエラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.database (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.database
インタフェース
ConInfo
DatabaseAccessor
DataSourceProvider
DBResultAdapter
DbsConnection
クラス
DatabaseColumn
DatabaseExport
DatabaseManager
DbManager
DBResultArrayAdapter
DBResultBigDecimalAdapter
DBResultBigIntAdapter
DBResultBinaryAdapter
DBResultBlobAdapter
DBResultBooleanAdapter
DBResultByteAdapter
DBResultClobAdapter
DBResultDateAdapter
DBResultDoubleAdapter
DBResultImTimestampAdapter
DBResultIntegerAdapter
DBResultNullAdapter
DBResultObjectAdapter
DBResultRealAdapter
DBResultRefAdapter
DBResultShortAdapter
DBResultStringAdapter
DBResultStructAdapter
DBResultTimeAdapter
DBResultTimestampAdapter
DbTypes


jp.co.intra_mart.foundation.database (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.database

データベースへアクセスするためのクラスを提供します。

参照:
説明

インタフェースの概要
ConInfo |
DatabaseAccessor | データベース接続オブジェクト取得インターフェースを定義します。
DataSourceProvider | データソース設定情報取得プロバイダインタフェース。
DBResultAdapter | スクリプト開発用データベースカラム取得アダプタインタフェース。
DbsConnection | 推奨されていません。 Connectionを利用してください。

クラスの概要
DatabaseColumn |
DatabaseExport | 推奨されていません。 システム内部で利用しているクラスです。
DatabaseManager | データベースマネージャクラス。
DbManager | 推奨されていません。 DatabaseManagerを使用してください。
DBResultArrayAdapter | スクリプト開発用データベースARRAY型カラム取得アダプタ。
DBResultBigDecimalAdapter | スクリプト開発用データベースDECIMAL,NUMERIC型カラム取得アダプタ。
DBResultBigIntAdapter | スクリプト開発用データベースBIGINT型カラム取得アダプタ。
DBResultBinaryAdapter | スクリプト開発用データベースBINARY,LONGVARBINARY,VARBINARY型カラム取得アダプタ。
DBResultBlobAdapter | スクリプト開発用データベースBLOB型カラム取得アダプタ。
DBResultBooleanAdapter | スクリプト開発用データベースBOOLEAN,BIT型カラム取得アダプタ。
DBResultByteAdapter | スクリプト開発用データベースBYTE型カラム取得アダプタ。
DBResultClobAdapter | スクリプト開発用データベースCLOB型カラム取得アダプタ。
DBResultDateAdapter | スクリプト開発用データベースDATE型カラム取得アダプタ。
DBResultDoubleAdapter | スクリプト開発用データベースDOUBLE,FLOAT型カラム取得アダプタ。
DBResultImTimestampAdapter | スクリプト開発用データベースTIMESTAMP型カラム取得intra-mart拡張アダプタ。
DBResultIntegerAdapter | スクリプト開発用データベースINTEGER型カラム取得アダプタ。
DBResultNullAdapter | スクリプト開発用データベースNULL型カラム取得アダプタ。
DBResultObjectAdapter | スクリプト開発用データベースカラムをObject型として取得するアダプタ。
DBResultRealAdapter | スクリプト開発用データベースREAL型カラム取得アダプタ。
DBResultRefAdapter | スクリプト開発用データベースREF型カラム取得アダプタ。
DBResultShortAdapter | スクリプト開発用データベースSMALLINT型カラム取得アダプタ。
DBResultStringAdapter | スクリプト開発用データベースカラムを文字列型として取得するアダプタ。
DBResultStructAdapter | スクリプト開発用データベースSTRUCT型カラム取得アダプタ。
DBResultTimeAdapter | スクリプト開発用データベースTIME型カラム取得アダプタ。
DBResultTimestampAdapter | スクリプト開発用データベースTIMESTAMP型カラム取得アダプター。
DbTypes |

パッケージ jp.co.intra_mart.foundation.database の説明

データベースへアクセスするためのクラスを提供します。


jp.co.intra_mart.foundation.database クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.database の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.database.DatabaseColumn
    • class jp.co.intra_mart.foundation.database.DatabaseExport
    • class jp.co.intra_mart.foundation.database.DatabaseManager
    • class jp.co.intra_mart.foundation.database.DbManager
    • class jp.co.intra_mart.foundation.database.DBResultArrayAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultBigDecimalAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultBigIntAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultBinaryAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultBlobAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultBooleanAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultByteAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultClobAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultDateAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultDoubleAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultImTimestampAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultIntegerAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultNullAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultObjectAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultRealAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultRefAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultShortAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultStringAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultStructAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultTimeAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultTimestampAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DbTypes

インタフェース階層

  • interface jp.co.intra_mart.foundation.database.ConInfo
  • interface java.sql.Connection
    • interface jp.co.intra_mart.foundation.database.DbsConnection
  • interface jp.co.intra_mart.foundation.database.DatabaseAccessor
  • interface jp.co.intra_mart.foundation.database.DataSourceProvider
  • interface jp.co.intra_mart.foundation.database.DBResultAdapter


パッケージ jp.co.intra_mart.foundation.database の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.database の使用

jp.co.intra_mart.foundation.database を使用しているパッケージ
jp.co.intra_mart.foundation.database | データベースへアクセスするためのクラスを提供します。
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.foundation.database により使用される jp.co.intra_mart.foundation.database のクラス
ConInfo
DatabaseAccessor
データベース接続オブジェクト取得インターフェースを定義します。
DatabaseColumn
DatabaseExport
推奨されていません。 システム内部で利用しているクラスです。
DatabaseManager
データベースマネージャクラス。
DataSourceProvider
データソース設定情報取得プロバイダインタフェース。
DBResultAdapter
スクリプト開発用データベースカラム取得アダプタインタフェース。
DbsConnection
推奨されていません。 Connectionを利用してください。
DbTypes

jp.co.intra_mart.framework.base.data により使用される jp.co.intra_mart.foundation.database のクラス
DbsConnection
推奨されていません。 Connectionを利用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass の使用

jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational の使用

CateogryClassInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class 分類区分情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.category.category_class での CateogryClassInternational の使用

CateogryClassInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.category.category_class のメソッド
 CateogryClassInternational CateogryClass.getCateogryClassInternational(Locale locale)
指定された言語に対する国際化情報を取得します。

CateogryClassInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.category.category_class のメソッド
 void CateogryClass.putInternational(Locale locale, CateogryClassInternational data)
指定された言語に対する国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CateogryClass (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.category.category_class
クラス CateogryClass

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass
すべての実装インタフェース:
Serializable
public class CateogryClass
extends Object
implements Serializable

分類区分の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CateogryClass()
分類区分に関連する情報を新規に生成します。
CateogryClass(Locale locale)
分類区分に関連する情報を新規に生成します。
メソッドの概要
String | getCategoryClassCode() 分類区分コードを取得します。
CateogryClassInternational | getCateogryClassInternational(Locale locale) 指定された言語に対する国際化情報を取得します。
Locale | getDefaultLocale() デフォルトのロケールを取得します。
Locale[] | getLocales() この分類区分で管理している言語（ロケール）をすべて取得します。
String | getName() 分類区分名を取得します。
String | getName(Locale locale) 分類区分名を取得します。
String | getNotes() 備考を取得します。
void | putInternational(Locale locale, CateogryClassInternational data) 指定された言語に対する国際化情報を設定します。
void | removeInternational(Locale locale) 指定された言語に対する国際化情報を削除します。
void | setCategoryClassCode(String categoryClassCode) 分類区分コードを設定します。
void | setDefaultLocale(Locale defaultLocale) デフォルトのロケールを設定します。
void | setNotes(String notes) 備考を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CateogryClass

public CateogryClass()
分類区分に関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値の言語だけのロケールが割り当てられます。

CateogryClass

public CateogryClass(Locale locale)
分類区分に関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられます。

パラメータ:
locale - デフォルトの言語
メソッドの詳細

getDefaultLocale

public Locale getDefaultLocale()
デフォルトのロケールを取得します。

戻り値:
デフォルトのロケール

setDefaultLocale

public void setDefaultLocale(Locale defaultLocale)
デフォルトのロケールを設定します。

パラメータ:
defaultLocale - デフォルトのロケール

getLocales

public Locale[] getLocales()
この分類区分で管理している言語（ロケール）をすべて取得します。

戻り値:
この分類区分で管理している言語（ロケール）

getCateogryClassInternational

public CateogryClassInternational getCateogryClassInternational(Locale locale)
指定された言語に対する国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
国際化情報

putInternational

public void putInternational(Locale locale,
                             CateogryClassInternational data)
指定された言語に対する国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 国際化情報

removeInternational

public void removeInternational(Locale locale)
指定された言語に対する国際化情報を削除します。

パラメータ:
locale - 言語（ロケール）

getCategoryClassCode

public String getCategoryClassCode()
分類区分コードを取得します。

戻り値:
分類区分コード

setCategoryClassCode

public void setCategoryClassCode(String categoryClassCode)
分類区分コードを設定します。

パラメータ:
categoryClassCode - 分類区分コード

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getName

public String getName()
分類区分名を取得します。

戻り値:
分類区分名

getName

public String getName(Locale locale)
分類区分名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
分類区分名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CateogryClassInternational (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.category.category_class
クラス CateogryClassInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational
すべての実装インタフェース:
Serializable
public class CateogryClassInternational
extends Object
implements Serializable

分類区分の国際化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CateogryClassInternational()
メソッドの概要
String | getName() 分類区分名を取得します。
void | setName(String name) 分類区分名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CateogryClassInternational

public CateogryClassInternational()
メソッドの詳細

getName

public String getName()
分類区分名を取得します。

戻り値:
分類区分名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
分類区分名を設定します。

パラメータ:
name - 分類区分名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.category.category_class (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.category.category_class
クラス
CateogryClass
CateogryClassInternational


jp.co.intra_mart.foundation.datastore.application.domain.category.category_class (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.category_class

分類区分情報を操作するクラスを提供します。

参照:
説明

クラスの概要
CateogryClass | 分類区分の基本属性のデータを取り扱います。
CateogryClassInternational | 分類区分の国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.category_class の説明

分類区分情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.category.category_class クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.category_class の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.category_class の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class の使用

jp.co.intra_mart.foundation.datastore.application.domain.category.category_class を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class 分類区分情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.category.category_class により使用される jp.co.intra_mart.foundation.datastore.application.domain.category.category_class のクラス
CateogryClassInternational
分類区分の国際化属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager の使用

CategoryManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category 分類情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.category での CategoryManager の使用

CategoryManager を返す jp.co.intra_mart.foundation.datastore.application.domain.category のメソッド
static CategoryManager CategoryManager.getCategoryManager(String user, String group)
CategoryManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail の使用

CategoryDetail を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category 分類情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.category での CategoryDetail の使用

CategoryDetail を返す jp.co.intra_mart.foundation.datastore.application.domain.category のメソッド
abstract CategoryDetail[] | CategoryManager.getCategoryDetails() 登録済みの分類区分詳細情報の一覧を取得します。
abstract CategoryDetail[] | CategoryManager.getCategoryDetails(String categoryClassCode) 登録済みの分類区分詳細情報の一覧を取得します。
abstract CategoryDetail | CategoryManager.getCategoryDetail(String categoryClassCode, String categoryCode) 登録済みの分類区分詳細情報を取得します。

CategoryDetail 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.category のメソッド
abstract void | CategoryManager.addCategoryDetail(CategoryDetail categoryDetail) 分類区分詳細を登録します。
abstract void | CategoryManager.updateCategoryDetail(CategoryDetail categoryDetail) 登録済の分類区分詳細を更新します。
abstract void | CategoryManager.deleteCategoryDetail(CategoryDetail categoryDetail) 登録済の分類区分詳細を削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational の使用

CategoryDetailInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category.detail 分類詳細情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.category.detail での CategoryDetailInternational の使用

CategoryDetailInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.category.detail のメソッド
 CategoryDetailInternational CategoryDetail.getCategoryDetailInternational(Locale locale)
指定された言語に対する国際化情報を取得します。

CategoryDetailInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.category.detail のメソッド
 void CategoryDetail.putInternational(Locale locale, CategoryDetailInternational data)
指定された言語に対する国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CategoryDetail (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.category.detail
クラス CategoryDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail
すべての実装インタフェース:
Serializable
public class CategoryDetail
extends Object
implements Serializable

分類区分詳細の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CategoryDetail()
分類区分詳細に関連する情報を新規に生成します。
CategoryDetail(Locale locale)
分類区分詳細に関連する情報を新規に生成します。
メソッドの概要
String | getCategoryClassCode() 分類区分コードを取得します。
String | getCategoryCode() 分類コードを取得します。
CategoryDetailInternational | getCategoryDetailInternational(Locale locale) 指定された言語に対する国際化情報を取得します。
Locale | getDefaultLocale() デフォルトのロケールを取得します。
Locale[] | getLocales() この分類区分詳細で管理している言語（ロケール）をすべて取得します。
String | getName() 分類名を取得します。
String | getName(Locale locale) 分類名を取得します。
String | getNotes() 備考を取得します。
void | putInternational(Locale locale, CategoryDetailInternational data) 指定された言語に対する国際化情報を設定します。
void | removeInternational(Locale locale) 指定された言語に対する国際化情報を削除します。
void | setCategoryClassCode(String categoryClassCode) 分類区分コードを設定します。
void | setCategoryCode(String categoryCode) 分類コードを設定します。
void | setDefaultLocale(Locale defaultLocale) デフォルトのロケールを設定します。
void | setNotes(String notes) 備考を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CategoryDetail

public CategoryDetail()
分類区分詳細に関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値の言語だけのロケールが割り当てられます。

CategoryDetail

public CategoryDetail(Locale locale)
分類区分詳細に関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられます。

パラメータ:
locale - デフォルトの言語
メソッドの詳細

getDefaultLocale

public Locale getDefaultLocale()
デフォルトのロケールを取得します。

戻り値:
デフォルトのロケール

setDefaultLocale

public void setDefaultLocale(Locale defaultLocale)
デフォルトのロケールを設定します。

パラメータ:
defaultLocale - デフォルトのロケール

getLocales

public Locale[] getLocales()
この分類区分詳細で管理している言語（ロケール）をすべて取得します。

戻り値:
この分類区分詳細で管理している言語（ロケール）

getCategoryDetailInternational

public CategoryDetailInternational getCategoryDetailInternational(Locale locale)
指定された言語に対する国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
国際化情報

putInternational

public void putInternational(Locale locale,
                             CategoryDetailInternational data)
指定された言語に対する国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 国際化情報

removeInternational

public void removeInternational(Locale locale)
指定された言語に対する国際化情報を削除します。

パラメータ:
locale - 言語（ロケール）

getCategoryClassCode

public String getCategoryClassCode()
分類区分コードを取得します。

戻り値:
分類区分コード

setCategoryClassCode

public void setCategoryClassCode(String categoryClassCode)
分類区分コードを設定します。

パラメータ:
categoryClassCode - 分類区分コード

getCategoryCode

public String getCategoryCode()
分類コードを取得します。

戻り値:
分類コード

setCategoryCode

public void setCategoryCode(String categoryCode)
分類コードを設定します。

パラメータ:
categoryCode - 分類コード

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getName

public String getName()
分類名を取得します。

戻り値:
分類名

getName

public String getName(Locale locale)
分類名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
分類名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CategoryDetailInternational (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.category.detail
クラス CategoryDetailInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational
すべての実装インタフェース:
Serializable
public class CategoryDetailInternational
extends Object
implements Serializable

分類区分詳細の国際化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CategoryDetailInternational()
メソッドの概要
String | getName() 分類名を取得します。
void | setName(String name) 分類名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CategoryDetailInternational

public CategoryDetailInternational()
メソッドの詳細

getName

public String getName()
分類名を取得します。

戻り値:
分類名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
分類名を設定します。

パラメータ:
name - 分類名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.category.detail (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.category.detail
クラス
CategoryDetail
CategoryDetailInternational


jp.co.intra_mart.foundation.datastore.application.domain.category.detail (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.detail

分類詳細情報を操作するクラスを提供します。

参照:
説明

クラスの概要
CategoryDetail | 分類区分詳細の基本属性のデータを取り扱います。
CategoryDetailInternational | 分類区分詳細の国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.detail の説明

分類詳細情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.category.detail クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.detail の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.detail の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category.detail の使用

jp.co.intra_mart.foundation.datastore.application.domain.category.detail を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category | 分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category.detail | 分類詳細情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.category により使用される jp.co.intra_mart.foundation.datastore.application.domain.category.detail のクラス
CategoryDetail
分類区分詳細の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.category.detail により使用される jp.co.intra_mart.foundation.datastore.application.domain.category.detail のクラス
CategoryDetailInternational
分類区分詳細の国際化属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CategoryManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.category
クラス CategoryManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager
public abstract class CategoryManager
extends Object

分類に関連する情報を管理します。 このクラスのインスタンスは必ず getCategoryManager(String,String) で取得してください。

導入されたバージョン:
5.0

コンストラクタの概要
CategoryManager()
メソッドの概要
abstract void | addCategoryDetail(CategoryDetail categoryDetail) 分類区分詳細を登録します。
abstract void | deleteCategoryDetail(CategoryDetail categoryDetail) 登録済の分類区分詳細を削除します。
abstract CategoryDetail | getCategoryDetail(String categoryClassCode, String categoryCode) 登録済みの分類区分詳細情報を取得します。
abstract CategoryDetail[] | getCategoryDetails() 登録済みの分類区分詳細情報の一覧を取得します。
abstract CategoryDetail[] | getCategoryDetails(String categoryClassCode) 登録済みの分類区分詳細情報の一覧を取得します。
static CategoryManager | getCategoryManager(String user, String group) CategoryManagerを取得します。
protected abstract void | init(String user, String group) CategoryManagerを初期化します。
abstract void | updateCategoryDetail(CategoryDetail categoryDetail) 登録済の分類区分詳細を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CategoryManager

public CategoryManager()
メソッドの詳細

getCategoryManager

public static CategoryManager getCategoryManager(String user,
                                                 String group)
                                          throws ManagerException
CategoryManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するCategoryManager
例外:
ManagerException - CategoryManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
CategoryManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - CategoryManagerの初期化に失敗

addCategoryDetail

public abstract void addCategoryDetail(CategoryDetail categoryDetail)
                                throws ManagerException
分類区分詳細を登録します。

パラメータ:
categoryDetail - 分類区分詳細情報
例外:
ManagerException - 分類区分詳細の登録に失敗

updateCategoryDetail

public abstract void updateCategoryDetail(CategoryDetail categoryDetail)
                                   throws ManagerException
登録済の分類区分詳細を更新します。

パラメータ:
categoryDetail - 分類区分詳細情報
例外:
ManagerException - 分類区分詳細の更新に失敗

deleteCategoryDetail

public abstract void deleteCategoryDetail(CategoryDetail categoryDetail)
                                   throws ManagerException
登録済の分類区分詳細を削除します。
指定された分類区分詳細の情報が存在しない場合は ManagerException がスローされます。

パラメータ:
categoryDetail - 分類区分詳細情報
例外:
ManagerException - 分類区分詳細の削除に失敗

getCategoryDetails

public abstract CategoryDetail[] getCategoryDetails()
                                             throws ManagerException
登録済みの分類区分詳細情報の一覧を取得します。
分類詳細情報が1件も存在しない場合は空の配列を返します。
取得される分類区分詳細情報の国際化情報には、ログインユーザのデフォルト言語の情報のみが設定されます。

戻り値:
分類区分詳細情報の一覧
例外:
ManagerException - 分類区分詳細情報の一覧の取得に失敗
導入されたバージョン:
6.1

getCategoryDetails

public abstract CategoryDetail[] getCategoryDetails(String categoryClassCode)
                                             throws ManagerException
登録済みの分類区分詳細情報の一覧を取得します。
指定された分類区分コードに対する詳細情報が存在しない場合は空の配列を返します。
取得される分類区分詳細情報の国際化情報には、ログインユーザのデフォルト言語の情報のみが設定されます。

パラメータ:
categoryClassCode - 分類区分コード
戻り値:
分類区分詳細情報の一覧
例外:
ManagerException - 分類区分詳細情報の一覧の取得に失敗
導入されたバージョン:
6.1

getCategoryDetail

public abstract CategoryDetail getCategoryDetail(String categoryClassCode,
                                                 String categoryCode)
                                          throws ManagerException
登録済みの分類区分詳細情報を取得します。
指定された分類区分コード、分類コードに対する詳細情報が存在しない場合は nullを返します。

パラメータ:
categoryClassCode - 分類区分コード
categoryCode - 分類コード
戻り値:
分類区分詳細情報
例外:
ManagerException - 分類区分詳細情報の取得に失敗
導入されたバージョン:
6.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.category (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.category
クラス
CategoryManager


jp.co.intra_mart.foundation.datastore.application.domain.category (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category

分類情報を操作するクラスを提供します。

参照:
説明

クラスの概要
CategoryManager 分類に関連する情報を管理します。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category の説明

分類情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.category クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category の使用

jp.co.intra_mart.foundation.datastore.application.domain.category を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category 分類情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.category により使用される jp.co.intra_mart.foundation.datastore.application.domain.category のクラス
CategoryManager
分類に関連する情報を管理します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach の使用

DepartmentAttach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での DepartmentAttach の使用

DepartmentAttach を返す jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract  DepartmentAttach CompanyManager.getDepartmentAttach(String user, String company, String department)
ユーザの組織への所属情報を取得します。

DepartmentAttach 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract void | CompanyManager.setMember(DepartmentAttach attach) 組織に人員を割り当てます。
abstract void | CompanyManager.deleteMember(DepartmentAttach attach) 組織から人員をはずします。
void | CompanyChangedListener.memberSet(String groupId, DepartmentAttach attach) 組織への人員の割当がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.memberDeleted(String groupId, DepartmentAttach attach) 組織からの人員の割当がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.access での DepartmentAttach の使用

DepartmentAttach 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | CompanyChangedControllerListener.memberSet(String groupId, DepartmentAttach attach) 組織への人員の割当がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.memberDeleted(String groupId, DepartmentAttach attach) 組織からの人員の割当がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での DepartmentAttach の使用

DepartmentAttach 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | CompanyChangedMenuListener.memberSet(String groupId, DepartmentAttach attach) 組織への人員の割当がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.memberDeleted(String groupId, DepartmentAttach attach) 組織からの人員の割当がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable の使用

DepartmentAttachTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.attach 組織所属情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.attach での DepartmentAttachTerminable の使用

DepartmentAttachTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.company.attach のメソッド
DepartmentAttachTerminable | DepartmentAttach.getDepartmentAttachTerminable(Term term) 指定された期間に対する期間化情報を取得します。
DepartmentAttachTerminable | DepartmentAttach.getDepartmentAttachTerminable(Date date) 指定された日時に対する期間化情報を取得します。

DepartmentAttachTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.attach のメソッド
 void DepartmentAttach.putDepartmentAttachTerminable(Term term, DepartmentAttachTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DepartmentAttach (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.attach
クラス DepartmentAttach

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach
すべての実装インタフェース:
Serializable
public class DepartmentAttach
extends Object
implements Serializable

組織所属の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DepartmentAttach()
組織所属に関連する情報を新規に生成します。
DepartmentAttach(Date date)
組織所属に関連する情報を新規に生成します。
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
Date | getDefaultDate() デフォルトの日時を取得します。
DepartmentAttachTerminable | getDepartmentAttachTerminable(Date date) 指定された日時に対する期間化情報を取得します。
DepartmentAttachTerminable | getDepartmentAttachTerminable(Term term) 指定された期間に対する期間化情報を取得します。
String | getDepartmentCode() 組織コードを取得します。
String | getPostCode() 役職CDを取得します。
String | getPostCode(Date date) 役職CDを取得します。
int | getSortKey() ソートキーを取得します。
Term[] | getTerms() この組織所属で管理している期間をすべて取得します。
String | getUserCode() ユーザコードを取得します。
void | putDepartmentAttachTerminable(Term term, DepartmentAttachTerminable data) 指定された期間に対する期間化情報を設定します。
void | removeDepartmentAttachTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setDepartmentCode(String departmentCode) 組織コードを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
void | setUserCode(String userCode) ユーザコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DepartmentAttach

public DepartmentAttach()
組織所属に関連する情報を新規に生成します。 デフォルトの日時には現在のシステム日時が割り当てられます。

DepartmentAttach

public DepartmentAttach(Date date)
組織所属に関連する情報を新規に生成します。 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時
メソッドの詳細

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
この組織所属で管理している期間をすべて取得します。

戻り値:
この組織所属で管理している期間

getDepartmentAttachTerminable

public DepartmentAttachTerminable getDepartmentAttachTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getDepartmentAttachTerminable

public DepartmentAttachTerminable getDepartmentAttachTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putDepartmentAttachTerminable

public void putDepartmentAttachTerminable(Term term,
                                          DepartmentAttachTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removeDepartmentAttachTerminable

public void removeDepartmentAttachTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getUserCode

public String getUserCode()
ユーザコードを取得します。

戻り値:
ユーザコード

setUserCode

public void setUserCode(String userCode)
ユーザコードを設定します。

パラメータ:
userCode - ユーザコード

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します。

パラメータ:
companyCode - 会社コード

getDepartmentCode

public String getDepartmentCode()
組織コードを取得します。

戻り値:
組織コード

setDepartmentCode

public void setDepartmentCode(String departmentCode)
組織コードを設定します。

パラメータ:
departmentCode - 組織コード

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー

getPostCode

public String getPostCode()
役職CDを取得します。

戻り値:
役職CD

getPostCode

public String getPostCode(Date date)
役職CDを取得します。

パラメータ:
date - 日時
戻り値:
役職CD
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DepartmentAttachTerminable (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.attach
クラス DepartmentAttachTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable
すべての実装インタフェース:
Serializable
public class DepartmentAttachTerminable
extends Object
implements Serializable

組織所属の期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DepartmentAttachTerminable()
メソッドの概要
String | getPostCode() 役職CDを取得します。
void | setPostCode(String postCode) 役職CDを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DepartmentAttachTerminable

public DepartmentAttachTerminable()
メソッドの詳細

getPostCode

public String getPostCode()
役職CDを取得します。

戻り値:
役職CD

setPostCode

public void setPostCode(String postCode)
役職CDを設定します。

パラメータ:
postCode - 役職CD
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.company.attach (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.company.attach
クラス
DepartmentAttach
DepartmentAttachTerminable


jp.co.intra_mart.foundation.datastore.application.domain.company.attach (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.attach

組織所属情報を操作するクラスを提供します。

参照:
説明

クラスの概要
DepartmentAttach | 組織所属の基本属性のデータを取り扱います。
DepartmentAttachTerminable | 組織所属の期間化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.attach の説明

組織所属情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.company.attach クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.attach の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.attach の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.attach の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.attach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.attach | 組織所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.attach のクラス
DepartmentAttach
組織所属の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.company.attach により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.attach のクラス
DepartmentAttachTerminable
組織所属の期間化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.attach のクラス
DepartmentAttach
組織所属の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.attach のクラス
DepartmentAttach
組織所属の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory の使用

CompanyCategory を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での CompanyCategory の使用

CompanyCategory 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract void | CompanyManager.setCategoryDetail(CompanyCategory category) 組織に対して指定された分類区分情報を設定します。
abstract void | CompanyManager.removeCategoryDetail(CompanyCategory category) 組織に対して指定された分類区分情報を削除します。
void | CompanyChangedListener.categoryDetailSet(String groupId, CompanyCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.categoryDetailRemoved(String groupId, CompanyCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.access での CompanyCategory の使用

CompanyCategory 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | CompanyChangedControllerListener.categoryDetailSet(String groupId, CompanyCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.categoryDetailRemoved(String groupId, CompanyCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での CompanyCategory の使用

CompanyCategory 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | CompanyChangedMenuListener.categoryDetailSet(String groupId, CompanyCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.categoryDetailRemoved(String groupId, CompanyCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable の使用

CompanyCategoryTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.category 会社分類情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.category での CompanyCategoryTerminable の使用

CompanyCategoryTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.company.category のメソッド
CompanyCategoryTerminable | CompanyCategory.getCompanyCategoryTerminable(Term term) 指定された期間に対する期間化情報を取得します。
CompanyCategoryTerminable | CompanyCategory.getCompanyCategoryTerminable(Date date) 指定された日時に対する期間化情報を取得します。

CompanyCategoryTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.category のメソッド
 void CompanyCategory.putCompanyCategoryTerminable(Term term, CompanyCategoryTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CompanyCategory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.category
クラス CompanyCategory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory
すべての実装インタフェース:
Serializable
public class CompanyCategory
extends Object
implements Serializable

会社組織分類の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CompanyCategory()
会社組織分類に関連する情報を新規に生成します。
CompanyCategory(Date date)
会社組織分類に関連する情報を新規に生成します。
メソッドの概要
String | getCategoryClassCode() 分類区分コードを取得します。
String | getCategoryCode() 分類コードを取得します。
CompanyCategoryTerminable | getCompanyCategoryTerminable(Date date) 指定された日時に対する期間化情報を取得します。
CompanyCategoryTerminable | getCompanyCategoryTerminable(Term term) 指定された期間に対する期間化情報を取得します。
String | getCompanyCode() 会社コードを取得します。
Date | getDefaultDate() デフォルトの日時を取得します。
String | getDepartmentCode() 組織コードを取得します。
Term[] | getTerms() この会社組織分類で管理している期間をすべて取得します。
void | putCompanyCategoryTerminable(Term term, CompanyCategoryTerminable data) 指定された期間に対する期間化情報を設定します。
void | removeCompanyCategoryTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setCategoryClassCode(String categoryClassCode) 分類区分コードを設定します。
void | setCategoryCode(String categoryCode) 分類コードを設定します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setDepartmentCode(String departmentCode) 組織コードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyCategory

public CompanyCategory()
会社組織分類に関連する情報を新規に生成します。 デフォルトの日時には現在のシステム日時が割り当てられます。

CompanyCategory

public CompanyCategory(Date date)
会社組織分類に関連する情報を新規に生成します。 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時
メソッドの詳細

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
この会社組織分類で管理している期間をすべて取得します。

戻り値:
この会社組織分類で管理している期間

getCompanyCategoryTerminable

public CompanyCategoryTerminable getCompanyCategoryTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getCompanyCategoryTerminable

public CompanyCategoryTerminable getCompanyCategoryTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putCompanyCategoryTerminable

public void putCompanyCategoryTerminable(Term term,
                                         CompanyCategoryTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removeCompanyCategoryTerminable

public void removeCompanyCategoryTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します。

パラメータ:
companyCode - 会社コード

getDepartmentCode

public String getDepartmentCode()
組織コードを取得します。

戻り値:
組織コード

setDepartmentCode

public void setDepartmentCode(String departmentCode)
組織コードを設定します。

パラメータ:
departmentCode - 組織コード

getCategoryClassCode

public String getCategoryClassCode()
分類区分コードを取得します。

戻り値:
分類区分コード

setCategoryClassCode

public void setCategoryClassCode(String categoryClassCode)
分類区分コードを設定します。

パラメータ:
categoryClassCode - 分類区分コード

getCategoryCode

public String getCategoryCode()
分類コードを取得します。

戻り値:
分類コード

setCategoryCode

public void setCategoryCode(String categoryCode)
分類コードを設定します。

パラメータ:
categoryCode - 分類コード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyCategoryTerminable (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.category
クラス CompanyCategoryTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable
すべての実装インタフェース:
Serializable
public class CompanyCategoryTerminable
extends Object
implements Serializable

会社組織分類の期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CompanyCategoryTerminable()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyCategoryTerminable

public CompanyCategoryTerminable()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.company.category (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.company.category
クラス
CompanyCategory
CompanyCategoryTerminable


jp.co.intra_mart.foundation.datastore.application.domain.company.category (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.category

会社分類情報を操作するクラスを提供します。

参照:
説明

クラスの概要
CompanyCategory | 会社組織分類の基本属性のデータを取り扱います。
CompanyCategoryTerminable | 会社組織分類の期間化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.category の説明

会社分類情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.company.category クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.category の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.category の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.category の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.category を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.category | 会社分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.category のクラス
CompanyCategory
会社組織分類の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.company.category により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.category のクラス
CompanyCategoryTerminable
会社組織分類の期間化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.category のクラス
CompanyCategory
会社組織分類の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.category のクラス
CompanyCategory
会社組織分類の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener の使用

CompanyChangedListener を使用しているパッケージ
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.access での CompanyChangedListener の使用

CompanyChangedListener を実装している jp.co.intra_mart.foundation.security.access のクラス
 class CompanyChangedControllerListener
会社・組織・役職が削除された場合にアクセスコントローラに紐付く会社・組織・役職を削除するリスナークラスです。

jp.co.intra_mart.foundation.security.menu での CompanyChangedListener の使用

CompanyChangedListener を実装している jp.co.intra_mart.foundation.security.menu のクラス
 class CompanyChangedMenuListener
会社・組織に関する情報の変更時のリスナーです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter の使用

CompanyImporter を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company 会社情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での CompanyImporter の使用

CompanyImporter を実装している jp.co.intra_mart.foundation.datastore.application.domain.company のクラス
 class StandardCompanyImporter
会社のインポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager の使用

CompanyManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company 会社情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での CompanyManager の使用

CompanyManager を返す jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
static CompanyManager CompanyManager.getCompanyManager(String user, String group)
CompanyManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter の使用

CompanyPostImporter を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company 会社情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での CompanyPostImporter の使用

CompanyPostImporter を実装している jp.co.intra_mart.foundation.datastore.application.domain.company のクラス
 class StandardCompanyPostImporter
役職のインポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct の使用

DepartmentStruct を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company 会社情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での DepartmentStruct の使用

DepartmentStruct を返す jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract  DepartmentStruct[] CompanyManager.getDepartmentStructs(String company, String department, Date date, Locale locale)
組織の階層構造を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company の使用

Company を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での Company の使用

Company 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract void | CompanyManager.addCompany(Company company) 会社を登録します。
abstract void | CompanyManager.deleteCompany(Company company) 登録済の会社を削除します。
void | CompanyChangedListener.companyAdded(String groupId, Company company) 会社情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.companyDeleted(String groupId, Company company) 会社情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.access での Company の使用

Company 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | CompanyChangedControllerListener.companyAdded(String groupId, Company company) 会社情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.companyDeleted(String groupId, Company company) 会社情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での Company の使用

Company 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | CompanyChangedMenuListener.companyAdded(String groupId, Company company) 会社情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.companyDeleted(String groupId, Company company) 会社情報がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable の使用

CompanyTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.company 会社情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.company での CompanyTerminable の使用

CompanyTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.company.company のメソッド
CompanyTerminable | Company.getCompanyTerminable(Term term) 指定された期間に対する期間化情報を取得します。
CompanyTerminable | Company.getCompanyTerminable(Date date) 指定された日時に対する期間化情報を取得します。

CompanyTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.company のメソッド
 void Company.putCompanyTerminable(Term term, CompanyTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational の使用

CompanyTerminableInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.company 会社情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.company での CompanyTerminableInternational の使用

CompanyTerminableInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.company.company のメソッド
 CompanyTerminableInternational CompanyTerminable.getCompanyTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。

CompanyTerminableInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.company のメソッド
 void CompanyTerminable.putCompanyTerminableInternational(Locale locale, CompanyTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Company (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.company
クラス Company

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company
すべての実装インタフェース:
Serializable
public class Company
extends Object
implements Serializable

会社の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
Company()
会社に関連する情報を新規に生成します。
Company(Date date)
会社に関連する情報を新規に生成します。
Company(Locale locale)
会社に関連する情報を新規に生成します。
Company(Locale locale, Date date)
会社に関連する情報を新規に生成します。
メソッドの概要
String | getAddress1() 住所1を取得します。
String | getAddress1(Date date) 住所1を取得します。
String | getAddress1(Date date, Locale locale) 住所1を取得します。
String | getAddress1(Locale locale) 住所1を取得します。
String | getAddress2() 住所2を取得します。
String | getAddress2(Date date) 住所2を取得します。
String | getAddress2(Date date, Locale locale) 住所2を取得します。
String | getAddress2(Locale locale) 住所2を取得します。
String | getCompanyCode() 会社コードを取得します。
CompanyTerminable | getCompanyTerminable(Date date) 指定された日時に対する期間化情報を取得します。
CompanyTerminable | getCompanyTerminable(Term term) 指定された期間に対する期間化情報を取得します。
String | getCountryCode() 国コードを取得します。
String | getCountryCode(Date date) 国コードを取得します。
Date | getDefaultDate() デフォルトの日時を取得します。
Locale | getDefaultLocale() デフォルトのロケールを取得します。
String | getEmailAddress1() メールアドレス1を取得します。
String | getEmailAddress1(Date date) メールアドレス1を取得します。
String | getEmailAddress2() メールアドレス2を取得します。
String | getEmailAddress2(Date date) メールアドレス2を取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionFaxNumber(Date date) 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getExtensionNumber(Date date) 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
String | getFaxNumber(Date date) FAX番号を取得します。
String | getName() 組織名を取得します。
String | getName(Date date) 組織名を取得します。
String | getName(Date date, Locale locale) 組織名を取得します。
String | getName(Locale locale) 組織名を取得します。
String | getNameEnglish() 組織名英字を取得します。
String | getNameEnglish(Date date) 組織名英字を取得します。
String | getNameEnglish(Date date, Locale locale) 組織名英字を取得します。
String | getNameEnglish(Locale locale) 組織名英字を取得します。
String | getNameSyllabary() 組織名カナを取得します。
String | getNameSyllabary(Date date) 組織名カナを取得します。
String | getNameSyllabary(Date date, Locale locale) 組織名カナを取得します。
String | getNameSyllabary(Locale locale) 組織名カナを取得します。
String | getNotes() 備考を取得します。
int | getSortKey() ソートキーを取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getTelephoneNumber(Date date) 電話番号を取得します。
Term[] | getTerms() この会社で管理している期間をすべて取得します。
String | getUrl() URLを取得します。
String | getUrl(Date date) URLを取得します。
String | getZipCode() 郵便番号を取得します。
String | getZipCode(Date date) 郵便番号を取得します。
void | putCompanyTerminable(Term term, CompanyTerminable data) 指定された期間に対する期間化情報を設定します。
void | removeCompanyTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setDefaultLocale(Locale defaultLocale) デフォルトのロケールを設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Company

public Company()
会社に関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

Company

public Company(Locale locale)
会社に関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

パラメータ:
locale - デフォルトの言語

Company

public Company(Date date)
会社に関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時

Company

public Company(Locale locale,
               Date date)
会社に関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
locale - デフォルトの言語
date - デフォルトの日時
メソッドの詳細

getDefaultLocale

public Locale getDefaultLocale()
デフォルトのロケールを取得します。

戻り値:
デフォルトのロケール

setDefaultLocale

public void setDefaultLocale(Locale defaultLocale)
デフォルトのロケールを設定します。

パラメータ:
defaultLocale - デフォルトのロケール

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
この会社で管理している期間をすべて取得します。

戻り値:
この会社で管理している期間

getCompanyTerminable

public CompanyTerminable getCompanyTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getCompanyTerminable

public CompanyTerminable getCompanyTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putCompanyTerminable

public void putCompanyTerminable(Term term,
                                 CompanyTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removeCompanyTerminable

public void removeCompanyTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します。

パラメータ:
companyCode - 会社コード

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー

getTelephoneNumber

public String getTelephoneNumber()
電話番号を取得します。

戻り値:
電話番号

getTelephoneNumber

public String getTelephoneNumber(Date date)
電話番号を取得します。

パラメータ:
date - 日時
戻り値:
電話番号

getFaxNumber

public String getFaxNumber()
FAX番号を取得します。

戻り値:
FAX番号

getFaxNumber

public String getFaxNumber(Date date)
FAX番号を取得します。

パラメータ:
date - 日時
戻り値:
FAX番号

getExtensionNumber

public String getExtensionNumber()
内線番号を取得します。

戻り値:
内線番号

getExtensionNumber

public String getExtensionNumber(Date date)
内線番号を取得します。

パラメータ:
date - 日時
戻り値:
内線番号

getExtensionFaxNumber

public String getExtensionFaxNumber()
内線FAX番号を取得します。

戻り値:
内線FAX番号

getExtensionFaxNumber

public String getExtensionFaxNumber(Date date)
内線FAX番号を取得します。

パラメータ:
date - 日時
戻り値:
内線FAX番号

getCountryCode

public String getCountryCode()
国コードを取得します。

戻り値:
国コード

getCountryCode

public String getCountryCode(Date date)
国コードを取得します。

パラメータ:
date - 日時
戻り値:
国コード

getZipCode

public String getZipCode()
郵便番号を取得します。

戻り値:
郵便番号

getZipCode

public String getZipCode(Date date)
郵便番号を取得します。

パラメータ:
date - 日時
戻り値:
郵便番号

getEmailAddress1

public String getEmailAddress1()
メールアドレス1を取得します。

戻り値:
メールアドレス1

getEmailAddress1

public String getEmailAddress1(Date date)
メールアドレス1を取得します。

パラメータ:
date - 日時
戻り値:
メールアドレス1

getEmailAddress2

public String getEmailAddress2()
メールアドレス2を取得します。

戻り値:
メールアドレス2

getEmailAddress2

public String getEmailAddress2(Date date)
メールアドレス2を取得します。

パラメータ:
date - 日時
戻り値:
メールアドレス2

getUrl

public String getUrl()
URLを取得します。

戻り値:
URL

getUrl

public String getUrl(Date date)
URLを取得します。

パラメータ:
date - 日時
戻り値:
URL

getName

public String getName()
組織名を取得します。

戻り値:
組織名

getName

public String getName(Date date)
組織名を取得します。

パラメータ:
date - 日時
戻り値:
組織名

getName

public String getName(Locale locale)
組織名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名

getName

public String getName(Date date,
                      Locale locale)
組織名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
組織名

getNameSyllabary

public String getNameSyllabary()
組織名カナを取得します。

戻り値:
組織名カナ

getNameSyllabary

public String getNameSyllabary(Date date)
組織名カナを取得します。

パラメータ:
date - 日時
戻り値:
組織名カナ

getNameSyllabary

public String getNameSyllabary(Locale locale)
組織名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名カナ

getNameSyllabary

public String getNameSyllabary(Date date,
                               Locale locale)
組織名カナを取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
組織名カナ

getNameEnglish

public String getNameEnglish()
組織名英字を取得します。

戻り値:
組織名英字

getNameEnglish

public String getNameEnglish(Date date)
組織名英字を取得します。

パラメータ:
date - 日時
戻り値:
組織名英字

getNameEnglish

public String getNameEnglish(Locale locale)
組織名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名英字

getNameEnglish

public String getNameEnglish(Date date,
                             Locale locale)
組織名英字を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
組織名英字

getAddress1

public String getAddress1()
住所1を取得します。

戻り値:
住所1

getAddress1

public String getAddress1(Date date)
住所1を取得します。

パラメータ:
date - 日時
戻り値:
住所1

getAddress1

public String getAddress1(Locale locale)
住所1を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所1

getAddress1

public String getAddress1(Date date,
                          Locale locale)
住所1を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
住所1

getAddress2

public String getAddress2()
住所2を取得します。

戻り値:
住所2

getAddress2

public String getAddress2(Date date)
住所2を取得します。

パラメータ:
date - 日時
戻り値:
住所2

getAddress2

public String getAddress2(Locale locale)
住所2を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所2

getAddress2

public String getAddress2(Date date,
                          Locale locale)
住所2を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
住所2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyTerminable (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.company
クラス CompanyTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable
すべての実装インタフェース:
Serializable
public class CompanyTerminable
extends Object
implements Serializable

会社の期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CompanyTerminable()
メソッドの概要
CompanyTerminableInternational | getCompanyTerminableInternational(Locale locale) 指定された言語に対する期間国際化情報を取得します。
String | getCountryCode() 国コードを取得します。
String | getEmailAddress1() メールアドレス1を取得します。
String | getEmailAddress2() メールアドレス2を取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
Locale[] | getLocales() この会社で管理している言語（ロケール）をすべて取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getUrl() URLを取得します。
String | getZipCode() 郵便番号を取得します。
void | putCompanyTerminableInternational(Locale locale, CompanyTerminableInternational data) 指定された言語に対する期間国際化情報を設定します。
void | setCountryCode(String countryCode) 国コードを設定します。
void | setEmailAddress1(String emailAddress1) メールアドレス1を設定します。
void | setEmailAddress2(String emailAddress2) メールアドレス2を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | setFaxNumber(String faxNumber) FAX番号を設定します。
void | setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | setUrl(String url) URLを設定します。
void | setZipCode(String zipCode) 郵便番号を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyTerminable

public CompanyTerminable()
メソッドの詳細

getLocales

public Locale[] getLocales()
この会社で管理している言語（ロケール）をすべて取得します。

戻り値:
この会社で管理している言語（ロケール）

getCompanyTerminableInternational

public CompanyTerminableInternational getCompanyTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
期間国際化情報

putCompanyTerminableInternational

public void putCompanyTerminableInternational(Locale locale,
                                              CompanyTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 期間国際化情報

getTelephoneNumber

public String getTelephoneNumber()
電話番号を取得します。

戻り値:
電話番号

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber)
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号

getFaxNumber

public String getFaxNumber()
FAX番号を取得します。

戻り値:
FAX番号

setFaxNumber

public void setFaxNumber(String faxNumber)
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号

getExtensionNumber

public String getExtensionNumber()
内線番号を取得します。

戻り値:
内線番号

setExtensionNumber

public void setExtensionNumber(String extensionNumber)
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号

getExtensionFaxNumber

public String getExtensionFaxNumber()
内線FAX番号を取得します。

戻り値:
内線FAX番号

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber)
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号

getCountryCode

public String getCountryCode()
国コードを取得します。

戻り値:
国コード

setCountryCode

public void setCountryCode(String countryCode)
国コードを設定します。

パラメータ:
countryCode - 国コード

getZipCode

public String getZipCode()
郵便番号を取得します。

戻り値:
郵便番号

setZipCode

public void setZipCode(String zipCode)
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号

getEmailAddress1

public String getEmailAddress1()
メールアドレス1を取得します。

戻り値:
メールアドレス1

setEmailAddress1

public void setEmailAddress1(String emailAddress1)
メールアドレス1を設定します。

パラメータ:
emailAddress1 - メールアドレス1

getEmailAddress2

public String getEmailAddress2()
メールアドレス2を取得します。

戻り値:
メールアドレス2

setEmailAddress2

public void setEmailAddress2(String emailAddress2)
メールアドレス2を設定します。

パラメータ:
emailAddress2 - メールアドレス2

getUrl

public String getUrl()
URLを取得します。

戻り値:
URL

setUrl

public void setUrl(String url)
URLを設定します。

パラメータ:
url - URL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyTerminableInternational (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.company
クラス CompanyTerminableInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational
すべての実装インタフェース:
Serializable
public class CompanyTerminableInternational
extends Object
implements Serializable

会社の期間国際化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CompanyTerminableInternational()
メソッドの概要
String | getAddress1() 住所1を取得します。
String | getAddress2() 住所2を取得します。
String | getName() 組織名を取得します。
String | getNameEnglish() 組織名英字を取得します。
String | getNameSyllabary() 組織名カナを取得します。
void | setAddress1(String address1) 住所1を設定します。
void | setAddress2(String address2) 住所2を設定します。
void | setName(String name) 組織名を設定します。
void | setNameEnglish(String nameEnglish) 組織名英字を設定します。
void | setNameSyllabary(String nameSyllabary) 組織名カナを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyTerminableInternational

public CompanyTerminableInternational()
メソッドの詳細

getName

public String getName()
組織名を取得します。

戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
組織名を設定します。

パラメータ:
name - 組織名

getNameSyllabary

public String getNameSyllabary()
組織名カナを取得します。

戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ

getNameEnglish

public String getNameEnglish()
組織名英字を取得します。

戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字

getAddress1

public String getAddress1()
住所1を取得します。

戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

setAddress1

public void setAddress1(String address1)
住所1を設定します。

パラメータ:
address1 - 住所1

getAddress2

public String getAddress2()
住所2を取得します。

戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

setAddress2

public void setAddress2(String address2)
住所2を設定します。

パラメータ:
address2 - 住所2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.company.company (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.company.company
クラス
Company
CompanyTerminable
CompanyTerminableInternational


jp.co.intra_mart.foundation.datastore.application.domain.company.company (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.company

会社情報を操作するクラスを提供します。

参照:
説明

クラスの概要
Company | 会社の基本属性のデータを取り扱います。
CompanyTerminable | 会社の期間化属性のデータを取り扱います。
CompanyTerminableInternational | 会社の期間国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.company の説明

会社情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.company.company クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.company の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.company の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.company の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.company を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.company のクラス
Company
会社の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.company.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.company のクラス
CompanyTerminable
会社の期間化属性のデータを取り扱います。
CompanyTerminableInternational
会社の期間国際化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.company のクラス
Company
会社の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.company のクラス
Company
会社の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department の使用

Department を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での Department の使用

Department を返す jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract Department | CompanyManager.getDepartment(String company, String department) 登録済の組織を取得します。
abstract Department[] | CompanyManager.getAttachedDepartments(String user) 現在、ユーザが所属している組織の一覧を取得します。
abstract Department[] | CompanyManager.getAttachedDepartments(String user, Date date) 指定された日付にユーザが所属している組織の一覧を取得します。

Department 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract void | CompanyManager.addDepartment(Department department) 組織を登録します。
abstract void | CompanyManager.updateDepartment(Department department) 登録済の組織情報を更新します。
abstract void | CompanyManager.deleteDepartment(Department department) 登録済の組織情報を削除します。
void | CompanyChangedListener.departmentAdded(String groupId, Department department) 組織情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.departmentUpdated(String groupId, Department department) 組織情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedListener.departmentDeleted(String groupId, Department department) 組織情報がデータストアに更新された後に呼び出されます。

jp.co.intra_mart.foundation.datastore.application.domain.deal での Department の使用

Department を返す jp.co.intra_mart.foundation.datastore.application.domain.deal のメソッド
abstract  Department[] DealPermissionManager.getDepartments(Deal deal)
取扱情報を保有するアクセス権をもつ組織を返します。

jp.co.intra_mart.foundation.security.access での Department の使用

Department 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | CompanyChangedControllerListener.departmentAdded(String groupId, Department department) 組織情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.departmentUpdated(String groupId, Department department) 組織情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedControllerListener.departmentDeleted(String groupId, Department department) 組織情報がデータストアに更新された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での Department の使用

Department 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | CompanyChangedMenuListener.departmentAdded(String groupId, Department department) 組織情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.departmentUpdated(String groupId, Department department) 組織情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedMenuListener.departmentDeleted(String groupId, Department department) 組織情報がデータストアに更新された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable の使用

DepartmentTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.department 組織情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.department での DepartmentTerminable の使用

DepartmentTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.company.department のメソッド
DepartmentTerminable | Department.getDepartmentTerminable(Term term) 指定された期間に対する期間化情報を取得します。
DepartmentTerminable | Department.getDepartmentTerminable(Date date) 指定された日時に対する期間化情報を取得します。

DepartmentTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.department のメソッド
 void Department.putDepartmentTerminable(Term term, DepartmentTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational の使用

DepartmentTerminableInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.department 組織情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.department での DepartmentTerminableInternational の使用

DepartmentTerminableInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.company.department のメソッド
 DepartmentTerminableInternational DepartmentTerminable.getDepartmentTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。

DepartmentTerminableInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.department のメソッド
 void DepartmentTerminable.putDepartmentTerminableInternational(Locale locale, DepartmentTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Department (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.department
クラス Department

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department
すべての実装インタフェース:
Serializable
public class Department
extends Object
implements Serializable

組織の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
Department()
組織に関連する情報を新規に生成します。
Department(Date date)
組織に関連する情報を新規に生成します。
Department(Locale locale)
組織に関連する情報を新規に生成します。
Department(Locale locale, Date date)
組織に関連する情報を新規に生成します。
メソッドの概要
String | getAddress1() 住所1を取得します。
String | getAddress1(Date date) 住所1を取得します。
String | getAddress1(Date date, Locale locale) 住所1を取得します。
String | getAddress1(Locale locale) 住所1を取得します。
String | getAddress2() 住所2を取得します。
String | getAddress2(Date date) 住所2を取得します。
String | getAddress2(Date date, Locale locale) 住所2を取得します。
String | getAddress2(Locale locale) 住所2を取得します。
String | getCompanyCode() 会社コードを取得します。
String | getCountryCode() 国コードを取得します。
String | getCountryCode(Date date) 国コードを取得します。
Date | getDefaultDate() デフォルトの日時を取得します。
Locale | getDefaultLocale() デフォルトのロケールを取得します。
String | getDepartmentCode() 組織コードを取得します。
DepartmentTerminable | getDepartmentTerminable(Date date) 指定された日時に対する期間化情報を取得します。
DepartmentTerminable | getDepartmentTerminable(Term term) 指定された期間に対する期間化情報を取得します。
String | getEmailAddress1() メールアドレス1を取得します。
String | getEmailAddress1(Date date) メールアドレス1を取得します。
String | getEmailAddress2() メールアドレス2を取得します。
String | getEmailAddress2(Date date) メールアドレス2を取得します。
Map | getExtendedDepartment(String name) 指定された拡張情報を取得します。
Map | getExtendedDepartments() この組織の基本情報に対する拡張情報をすべて取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionFaxNumber(Date date) 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getExtensionNumber(Date date) 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
String | getFaxNumber(Date date) FAX番号を取得します。
String | getName() 組織名を取得します。
String | getName(Date date) 組織名を取得します。
String | getName(Date date, Locale locale) 組織名を取得します。
String | getName(Locale locale) 組織名を取得します。
String | getNameEnglish() 組織名英字を取得します。
String | getNameEnglish(Date date) 組織名英字を取得します。
String | getNameEnglish(Date date, Locale locale) 組織名英字を取得します。
String | getNameEnglish(Locale locale) 組織名英字を取得します。
String | getNameSyllabary() 組織名カナを取得します。
String | getNameSyllabary(Date date) 組織名カナを取得します。
String | getNameSyllabary(Date date, Locale locale) 組織名カナを取得します。
String | getNameSyllabary(Locale locale) 組織名カナを取得します。
String | getNotes() 備考を取得します。
int | getSortKey() ソートキーを取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getTelephoneNumber(Date date) 電話番号を取得します。
Term[] | getTerms() この組織で管理している期間をすべて取得します。
String | getUrl() URLを取得します。
String | getUrl(Date date) URLを取得します。
String | getZipCode() 郵便番号を取得します。
String | getZipCode(Date date) 郵便番号を取得します。
void | putDepartmentTerminable(Term term, DepartmentTerminable data) 指定された期間に対する期間化情報を設定します。
void | putExtendedDepartment(String name, Map data) 指定された拡張情報を追加します。
void | removeDepartmentTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setDefaultLocale(Locale defaultLocale) デフォルトのロケールを設定します。
void | setDepartmentCode(String departmentCode) 組織コードを設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Department

public Department()
組織に関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

Department

public Department(Locale locale)
組織に関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

パラメータ:
locale - デフォルトの言語

Department

public Department(Date date)
組織に関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時

Department

public Department(Locale locale,
                  Date date)
組織に関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
locale - デフォルトの言語
date - デフォルトの日時
メソッドの詳細

getDefaultLocale

public Locale getDefaultLocale()
デフォルトのロケールを取得します。

戻り値:
デフォルトのロケール

setDefaultLocale

public void setDefaultLocale(Locale defaultLocale)
デフォルトのロケールを設定します。

パラメータ:
defaultLocale - デフォルトのロケール

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
この組織で管理している期間をすべて取得します。

戻り値:
この組織で管理している期間

getDepartmentTerminable

public DepartmentTerminable getDepartmentTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getDepartmentTerminable

public DepartmentTerminable getDepartmentTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putDepartmentTerminable

public void putDepartmentTerminable(Term term,
                                    DepartmentTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removeDepartmentTerminable

public void removeDepartmentTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getExtendedDepartments

public Map getExtendedDepartments()
この組織の基本情報に対する拡張情報をすべて取得します。 返される値は拡張名をキー、 拡張情報を値とした Mapです。

戻り値:
基本情報に対するすべての拡張情報
導入されたバージョン:
5.1.5

getExtendedDepartment

public Map getExtendedDepartment(String name)
指定された拡張情報を取得します。

パラメータ:
name - 拡張名
戻り値:
基本情報に対する拡張情報
導入されたバージョン:
5.1.5

putExtendedDepartment

public void putExtendedDepartment(String name,
                                  Map data)
指定された拡張情報を追加します。 返される値は属性名をキー、 属性値を値とした Mapです。

パラメータ:
name - 拡張名
data - 基本情報に対する拡張情報
導入されたバージョン:
5.1.5

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します。

パラメータ:
companyCode - 会社コード

getDepartmentCode

public String getDepartmentCode()
組織コードを取得します。

戻り値:
組織コード

setDepartmentCode

public void setDepartmentCode(String departmentCode)
組織コードを設定します。

パラメータ:
departmentCode - 組織コード

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー

getTelephoneNumber

public String getTelephoneNumber()
電話番号を取得します。

戻り値:
電話番号

getTelephoneNumber

public String getTelephoneNumber(Date date)
電話番号を取得します。

パラメータ:
date - 日時
戻り値:
電話番号

getFaxNumber

public String getFaxNumber()
FAX番号を取得します。

戻り値:
FAX番号

getFaxNumber

public String getFaxNumber(Date date)
FAX番号を取得します。

パラメータ:
date - 日時
戻り値:
FAX番号

getExtensionNumber

public String getExtensionNumber()
内線番号を取得します。

戻り値:
内線番号

getExtensionNumber

public String getExtensionNumber(Date date)
内線番号を取得します。

パラメータ:
date - 日時
戻り値:
内線番号

getExtensionFaxNumber

public String getExtensionFaxNumber()
内線FAX番号を取得します。

戻り値:
内線FAX番号

getExtensionFaxNumber

public String getExtensionFaxNumber(Date date)
内線FAX番号を取得します。

パラメータ:
date - 日時
戻り値:
内線FAX番号

getCountryCode

public String getCountryCode()
国コードを取得します。

戻り値:
国コード

getCountryCode

public String getCountryCode(Date date)
国コードを取得します。

パラメータ:
date - 日時
戻り値:
国コード

getZipCode

public String getZipCode()
郵便番号を取得します。

戻り値:
郵便番号

getZipCode

public String getZipCode(Date date)
郵便番号を取得します。

パラメータ:
date - 日時
戻り値:
郵便番号

getEmailAddress1

public String getEmailAddress1()
メールアドレス1を取得します。

戻り値:
メールアドレス1

getEmailAddress1

public String getEmailAddress1(Date date)
メールアドレス1を取得します。

パラメータ:
date - 日時
戻り値:
メールアドレス1

getEmailAddress2

public String getEmailAddress2()
メールアドレス2を取得します。

戻り値:
メールアドレス2

getEmailAddress2

public String getEmailAddress2(Date date)
メールアドレス2を取得します。

パラメータ:
date - 日時
戻り値:
メールアドレス2

getUrl

public String getUrl()
URLを取得します。

戻り値:
URL

getUrl

public String getUrl(Date date)
URLを取得します。

パラメータ:
date - 日時
戻り値:
URL

getName

public String getName()
組織名を取得します。

戻り値:
組織名

getName

public String getName(Date date)
組織名を取得します。

パラメータ:
date - 日時
戻り値:
組織名

getName

public String getName(Locale locale)
組織名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名

getName

public String getName(Date date,
                      Locale locale)
組織名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
組織名

getNameSyllabary

public String getNameSyllabary()
組織名カナを取得します。

戻り値:
組織名カナ

getNameSyllabary

public String getNameSyllabary(Date date)
組織名カナを取得します。

パラメータ:
date - 日時
戻り値:
組織名カナ

getNameSyllabary

public String getNameSyllabary(Locale locale)
組織名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名カナ

getNameSyllabary

public String getNameSyllabary(Date date,
                               Locale locale)
組織名カナを取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
組織名カナ

getNameEnglish

public String getNameEnglish()
組織名英字を取得します。

戻り値:
組織名英字

getNameEnglish

public String getNameEnglish(Date date)
組織名英字を取得します。

パラメータ:
date - 日時
戻り値:
組織名英字

getNameEnglish

public String getNameEnglish(Locale locale)
組織名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名英字

getNameEnglish

public String getNameEnglish(Date date,
                             Locale locale)
組織名英字を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
組織名英字

getAddress1

public String getAddress1()
住所1を取得します。

戻り値:
住所1

getAddress1

public String getAddress1(Date date)
住所1を取得します。

パラメータ:
date - 日時
戻り値:
住所1

getAddress1

public String getAddress1(Locale locale)
住所1を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所1

getAddress1

public String getAddress1(Date date,
                          Locale locale)
住所1を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
住所1

getAddress2

public String getAddress2()
住所2を取得します。

戻り値:
住所2

getAddress2

public String getAddress2(Date date)
住所2を取得します。

パラメータ:
date - 日時
戻り値:
住所2

getAddress2

public String getAddress2(Locale locale)
住所2を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所2

getAddress2

public String getAddress2(Date date,
                          Locale locale)
住所2を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
住所2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DepartmentTerminable (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.department
クラス DepartmentTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable
すべての実装インタフェース:
Serializable
public class DepartmentTerminable
extends Object
implements Serializable

組織の期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DepartmentTerminable()
メソッドの概要
String | getCountryCode() 国コードを取得します。
DepartmentTerminableInternational | getDepartmentTerminableInternational(Locale locale) 指定された言語に対する期間国際化情報を取得します。
String | getEmailAddress1() メールアドレス1を取得します。
String | getEmailAddress2() メールアドレス2を取得します。
Map | getExtendedDepartmentTerminable(String name) 指定された拡張情報を取得します。
Map | getExtendedDepartmentTerminables() この組織の期間化情報に対する拡張情報をすべて取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
Locale[] | getLocales() この組織で管理している言語（ロケール）をすべて取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getUrl() URLを取得します。
String | getZipCode() 郵便番号を取得します。
void | putDepartmentTerminableInternational(Locale locale, DepartmentTerminableInternational data) 指定された言語に対する期間国際化情報を設定します。
void | putExtendedDepartmentTerminable(String name, Map data) 指定された拡張情報を追加します。
void | setCountryCode(String countryCode) 国コードを設定します。
void | setEmailAddress1(String emailAddress1) メールアドレス1を設定します。
void | setEmailAddress2(String emailAddress2) メールアドレス2を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | setFaxNumber(String faxNumber) FAX番号を設定します。
void | setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | setUrl(String url) URLを設定します。
void | setZipCode(String zipCode) 郵便番号を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DepartmentTerminable

public DepartmentTerminable()
メソッドの詳細

getLocales

public Locale[] getLocales()
この組織で管理している言語（ロケール）をすべて取得します。

戻り値:
この組織で管理している言語（ロケール）

getDepartmentTerminableInternational

public DepartmentTerminableInternational getDepartmentTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
期間国際化情報

putDepartmentTerminableInternational

public void putDepartmentTerminableInternational(Locale locale,
                                                 DepartmentTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 期間国際化情報

getExtendedDepartmentTerminables

public Map getExtendedDepartmentTerminables()
この組織の期間化情報に対する拡張情報をすべて取得します。 返される値は拡張名をキー、 拡張情報を値とした Mapです。

戻り値:
期間化情報に対するすべての拡張情報
導入されたバージョン:
5.1.5

getExtendedDepartmentTerminable

public Map getExtendedDepartmentTerminable(String name)
指定された拡張情報を取得します。 返される値は属性名をキー、 属性値を値とした Mapです。

パラメータ:
name - 拡張名
戻り値:
期間化情報に対する拡張情報
導入されたバージョン:
5.1.5

putExtendedDepartmentTerminable

public void putExtendedDepartmentTerminable(String name,
                                            Map data)
指定された拡張情報を追加します。

パラメータ:
name - 拡張名
data - 期間化情報に対する拡張情報
導入されたバージョン:
5.1.5

getTelephoneNumber

public String getTelephoneNumber()
電話番号を取得します。

戻り値:
電話番号

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber)
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号

getFaxNumber

public String getFaxNumber()
FAX番号を取得します。

戻り値:
FAX番号

setFaxNumber

public void setFaxNumber(String faxNumber)
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号

getExtensionNumber

public String getExtensionNumber()
内線番号を取得します。

戻り値:
内線番号

setExtensionNumber

public void setExtensionNumber(String extensionNumber)
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号

getExtensionFaxNumber

public String getExtensionFaxNumber()
内線FAX番号を取得します。

戻り値:
内線FAX番号

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber)
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号

getCountryCode

public String getCountryCode()
国コードを取得します。

戻り値:
国コード

setCountryCode

public void setCountryCode(String countryCode)
国コードを設定します。

パラメータ:
countryCode - 国コード

getZipCode

public String getZipCode()
郵便番号を取得します。

戻り値:
郵便番号

setZipCode

public void setZipCode(String zipCode)
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号

getEmailAddress1

public String getEmailAddress1()
メールアドレス1を取得します。

戻り値:
メールアドレス1

setEmailAddress1

public void setEmailAddress1(String emailAddress1)
メールアドレス1を設定します。

パラメータ:
emailAddress1 - メールアドレス1

getEmailAddress2

public String getEmailAddress2()
メールアドレス2を取得します。

戻り値:
メールアドレス2

setEmailAddress2

public void setEmailAddress2(String emailAddress2)
メールアドレス2を設定します。

パラメータ:
emailAddress2 - メールアドレス2

getUrl

public String getUrl()
URLを取得します。

戻り値:
URL

setUrl

public void setUrl(String url)
URLを設定します。

パラメータ:
url - URL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DepartmentTerminableInternational (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.department
クラス DepartmentTerminableInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational
すべての実装インタフェース:
Serializable
public class DepartmentTerminableInternational
extends Object
implements Serializable

組織の期間国際化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DepartmentTerminableInternational()
メソッドの概要
String | getAddress1() 住所1を取得します。
String | getAddress2() 住所2を取得します。
Map | getExtendedDepartmentTerminableInternational(String name) 指定された拡張情報を取得します。
Map | getExtendedDepartmentTerminableInternationals() この組織の基本情報に対する拡張情報をすべて取得します。
String | getName() 組織名を取得します。
String | getNameEnglish() 組織名英字を取得します。
String | getNameSyllabary() 組織名カナを取得します。
void | putExtendedDepartmentTerminableInternational(String name, Map data) 指定された拡張情報を追加します。
void | setAddress1(String address1) 住所1を設定します。
void | setAddress2(String address2) 住所2を設定します。
void | setName(String name) 組織名を設定します。
void | setNameEnglish(String nameEnglish) 組織名英字を設定します。
void | setNameSyllabary(String nameSyllabary) 組織名カナを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DepartmentTerminableInternational

public DepartmentTerminableInternational()
メソッドの詳細

getExtendedDepartmentTerminableInternationals

public Map getExtendedDepartmentTerminableInternationals()
この組織の基本情報に対する拡張情報をすべて取得します。 返される値は拡張名をキー、 拡張情報を値とした Mapです。

戻り値:
期間国際化情報に対するすべての拡張情報
導入されたバージョン:
5.1.5

getExtendedDepartmentTerminableInternational

public Map getExtendedDepartmentTerminableInternational(String name)
指定された拡張情報を取得します。 返される値は属性名をキー、 属性値を値とした Mapです。

パラメータ:
name - 拡張名
戻り値:
期間国際化情報に対する拡張情報
導入されたバージョン:
5.1.5

putExtendedDepartmentTerminableInternational

public void putExtendedDepartmentTerminableInternational(String name,
                                                         Map data)
指定された拡張情報を追加します。

パラメータ:
name - 拡張名
data - 期間国際化情報に対する拡張情報
導入されたバージョン:
5.1.5

getName

public String getName()
組織名を取得します。

戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
組織名を設定します。

パラメータ:
name - 組織名

getNameSyllabary

public String getNameSyllabary()
組織名カナを取得します。

戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ

getNameEnglish

public String getNameEnglish()
組織名英字を取得します。

戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字

getAddress1

public String getAddress1()
住所1を取得します。

戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

setAddress1

public void setAddress1(String address1)
住所1を設定します。

パラメータ:
address1 - 住所1

getAddress2

public String getAddress2()
住所2を取得します。

戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

setAddress2

public void setAddress2(String address2)
住所2を設定します。

パラメータ:
address2 - 住所2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.company.department (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.company.department
クラス
Department
DepartmentTerminable
DepartmentTerminableInternational


jp.co.intra_mart.foundation.datastore.application.domain.company.department (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.department

組織情報を操作するクラスを提供します。

参照:
説明

クラスの概要
Department | 組織の基本属性のデータを取り扱います。
DepartmentTerminable | 組織の期間化属性のデータを取り扱います。
DepartmentTerminableInternational | 組織の期間国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.department の説明

組織情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.company.department クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.department の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.department の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.department の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.department を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.department | 組織情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.department のクラス
Department
組織の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.company.department により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.department のクラス
DepartmentTerminable
組織の期間化属性のデータを取り扱います。
DepartmentTerminableInternational
組織の期間国際化属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.deal により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.department のクラス
Department
組織の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.department のクラス
Department
組織の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.department のクラス
Department
組織の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain の使用

DepartmentMain を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での DepartmentMain の使用

DepartmentMain を返す jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract  DepartmentMain CompanyManager.getDepartmentMain(String user)
ユーザの主所属情報を取得します。

DepartmentMain 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract void | CompanyManager.setMain(DepartmentMain main) ユーザが主所属する組織を設定します。
abstract void | CompanyManager.removeMain(DepartmentMain main) 指定されたユーザの主所属を削除します。
void | CompanyChangedListener.mainSet(String groupId, DepartmentMain main) 主所属情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.mainRemoved(String groupId, DepartmentMain main) 主所属情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.access での DepartmentMain の使用

DepartmentMain 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | CompanyChangedControllerListener.mainSet(String groupId, DepartmentMain main) 主所属情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.mainRemoved(String groupId, DepartmentMain main) 主所属情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での DepartmentMain の使用

DepartmentMain 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | CompanyChangedMenuListener.mainSet(String groupId, DepartmentMain main) 主所属情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.mainRemoved(String groupId, DepartmentMain main) 主所属情報がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable の使用

DepartmentMainTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.main 主所属情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.main での DepartmentMainTerminable の使用

DepartmentMainTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.company.main のメソッド
DepartmentMainTerminable | DepartmentMain.getDepartmentMainTerminable(Term term) 指定された期間に対する期間化情報を取得します。
DepartmentMainTerminable | DepartmentMain.getDepartmentMainTerminable(Date date) 指定された日時に対する期間化情報を取得します。

DepartmentMainTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.main のメソッド
 void DepartmentMain.putDepartmentMainTerminable(Term term, DepartmentMainTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DepartmentMain (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.main
クラス DepartmentMain

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain
すべての実装インタフェース:
Serializable
public class DepartmentMain
extends Object
implements Serializable

主所属の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DepartmentMain()
主所属に関連する情報を新規に生成します。
DepartmentMain(Date date)
主所属に関連する情報を新規に生成します。
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getCompanyCode(Date date) 会社コードを取得します。
Date | getDefaultDate() デフォルトの日時を取得します。
String | getDepartmentCode() 組織コードを取得します。
String | getDepartmentCode(Date date) 組織コードを取得します。
DepartmentMainTerminable | getDepartmentMainTerminable(Date date) 指定された日時に対する期間化情報を取得します。
DepartmentMainTerminable | getDepartmentMainTerminable(Term term) 指定された期間に対する期間化情報を取得します。
Term[] | getTerms() この主所属で管理している期間をすべて取得します。
String | getUserCode() ユーザコードを取得します。
void | putDepartmentMainTerminable(Term term, DepartmentMainTerminable data) 指定された期間に対する期間化情報を設定します。
void | removeDepartmentMainTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setUserCode(String userCode) ユーザコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DepartmentMain

public DepartmentMain()
主所属に関連する情報を新規に生成します。 デフォルトの日時には現在のシステム日時が割り当てられます。

DepartmentMain

public DepartmentMain(Date date)
主所属に関連する情報を新規に生成します。 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時
メソッドの詳細

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
この主所属で管理している期間をすべて取得します。

戻り値:
この主所属で管理している期間

getDepartmentMainTerminable

public DepartmentMainTerminable getDepartmentMainTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getDepartmentMainTerminable

public DepartmentMainTerminable getDepartmentMainTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putDepartmentMainTerminable

public void putDepartmentMainTerminable(Term term,
                                        DepartmentMainTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removeDepartmentMainTerminable

public void removeDepartmentMainTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getUserCode

public String getUserCode()
ユーザコードを取得します。

戻り値:
ユーザコード

setUserCode

public void setUserCode(String userCode)
ユーザコードを設定します。

パラメータ:
userCode - ユーザコード

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

getCompanyCode

public String getCompanyCode(Date date)
会社コードを取得します。

パラメータ:
date - 日時
戻り値:
会社コード

getDepartmentCode

public String getDepartmentCode()
組織コードを取得します。

戻り値:
組織コード

getDepartmentCode

public String getDepartmentCode(Date date)
組織コードを取得します。

パラメータ:
date - 日時
戻り値:
組織コード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DepartmentMainTerminable (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.main
クラス DepartmentMainTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable
すべての実装インタフェース:
Serializable
public class DepartmentMainTerminable
extends Object
implements Serializable

主所属の期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DepartmentMainTerminable()
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setDepartmentCode(String departmentCode) 組織コードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DepartmentMainTerminable

public DepartmentMainTerminable()
メソッドの詳細

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します。

パラメータ:
companyCode - 会社コード

getDepartmentCode

public String getDepartmentCode()
組織コードを取得します。

戻り値:
組織コード

setDepartmentCode

public void setDepartmentCode(String departmentCode)
組織コードを設定します。

パラメータ:
departmentCode - 組織コード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.company.main (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.company.main
クラス
DepartmentMain
DepartmentMainTerminable


jp.co.intra_mart.foundation.datastore.application.domain.company.main (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.main

主所属情報を操作するクラスを提供します。

参照:
説明

クラスの概要
DepartmentMain | 主所属の基本属性のデータを取り扱います。
DepartmentMainTerminable | 主所属の期間化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.main の説明

主所属情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.company.main クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.main の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.main の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.main の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.main を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.main | 主所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.main のクラス
DepartmentMain
主所属の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.company.main により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.main のクラス
DepartmentMainTerminable
主所属の期間化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.main のクラス
DepartmentMain
主所属の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.main のクラス
DepartmentMain
主所属の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost の使用

CompanyPost を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での CompanyPost の使用

CompanyPost 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract void | CompanyManager.addPost(CompanyPost post) 役職を登録します。
abstract void | CompanyManager.updatePost(CompanyPost post) 登録済の役職情報を更新します。
abstract void | CompanyManager.deletePost(CompanyPost post) 登録済の役職情報を削除します。
void | CompanyChangedListener.postAdded(String groupId, CompanyPost post) 役職情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.postUpdated(String groupId, CompanyPost post) 役職情報がデータストアに更新された後に呼び出されます。
void | CompanyChangedListener.postDeleted(String groupId, CompanyPost post) 役職情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.access での CompanyPost の使用

CompanyPost 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | CompanyChangedControllerListener.postAdded(String groupId, CompanyPost post) 役職情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.postUpdated(String groupId, CompanyPost post) 役職情報がデータストアに更新された後に呼び出されます。
void | CompanyChangedControllerListener.postDeleted(String groupId, CompanyPost post) 役職情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での CompanyPost の使用

CompanyPost 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | CompanyChangedMenuListener.postAdded(String groupId, CompanyPost post) 役職情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.postUpdated(String groupId, CompanyPost post) 役職情報がデータストアに更新された後に呼び出されます。
void | CompanyChangedMenuListener.postDeleted(String groupId, CompanyPost post) 役職情報がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable の使用

CompanyPostTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.post 役職情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.post での CompanyPostTerminable の使用

CompanyPostTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.company.post のメソッド
CompanyPostTerminable | CompanyPost.getCompanyPostTerminable(Term term) 指定された期間に対する期間化情報を取得します。
CompanyPostTerminable | CompanyPost.getCompanyPostTerminable(Date date) 指定された日時に対する期間化情報を取得します。

CompanyPostTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.post のメソッド
 void CompanyPost.putCompanyPostTerminable(Term term, CompanyPostTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational の使用

CompanyPostTerminableInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.post 役職情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.post での CompanyPostTerminableInternational の使用

CompanyPostTerminableInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.company.post のメソッド
 CompanyPostTerminableInternational CompanyPostTerminable.getCompanyPostTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。

CompanyPostTerminableInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.post のメソッド
 void CompanyPostTerminable.putCompanyPostTerminableInternational(Locale locale, CompanyPostTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost の使用

PlainCompanyPost を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company 会社情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での PlainCompanyPost の使用

PlainCompanyPost を返す jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract PlainCompanyPost[] | CompanyManager.getPostsInCompany(String company) 会社に登録済の役職をすべて取得します。
abstract PlainCompanyPost[] | CompanyManager.getPostsInCompany(String company, Date date) 会社に登録済の役職をすべて取得します。
abstract PlainCompanyPost[] | CompanyManager.getPostsInCompany(String company, Locale locale) 会社に登録済の役職をすべて取得します。
abstract PlainCompanyPost[] | CompanyManager.getPostsInCompany(String company, Date date, Locale locale) 会社に登録済の役職をすべて取得します。
abstract PlainCompanyPost[] | CompanyManager.getPostsOfUser(String company, String user) ユーザに設定された役職をすべて取得します。
abstract PlainCompanyPost[] | CompanyManager.getPostsOfUser(String company, String user, Date date) ユーザに設定された役職をすべて取得します。
abstract PlainCompanyPost[] | CompanyManager.getPostsOfUser(String company, String user, Locale locale) ユーザに設定された役職をすべて取得します。
abstract PlainCompanyPost[] | CompanyManager.getPostsOfUser(String company, String user, Date date, Locale locale) ユーザに設定された役職をすべて取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CompanyPost (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.post
クラス CompanyPost

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost
すべての実装インタフェース:
Serializable
public class CompanyPost
extends Object
implements Serializable

役職の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CompanyPost()
役職に関連する情報を新規に生成します。
CompanyPost(Date date)
役職に関連する情報を新規に生成します。
CompanyPost(Locale locale)
役職に関連する情報を新規に生成します。
CompanyPost(Locale locale, Date date)
役職に関連する情報を新規に生成します。
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
CompanyPostTerminable | getCompanyPostTerminable(Date date) 指定された日時に対する期間化情報を取得します。
CompanyPostTerminable | getCompanyPostTerminable(Term term) 指定された期間に対する期間化情報を取得します。
Date | getDefaultDate() デフォルトの日時を取得します。
Locale | getDefaultLocale() デフォルトのロケールを取得します。
String | getName() 役職名を取得します。
String | getName(Date date) 役職名を取得します。
String | getName(Date date, Locale locale) 役職名を取得します。
String | getName(Locale locale) 役職名を取得します。
String | getNotes() 備考を取得します。
String | getPostCode() 役職コードを取得します。
int | getSortKey() ソートキーを取得します。
Term[] | getTerms() この役職で管理している期間をすべて取得します。
void | putCompanyPostTerminable(Term term, CompanyPostTerminable data) 指定された期間に対する期間化情報を設定します。
void | removeCompanyPostTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setDefaultLocale(Locale defaultLocale) デフォルトのロケールを設定します。
void | setNotes(String notes) 備考を設定します。
void | setPostCode(String postCode) 役職コードを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyPost

public CompanyPost()
役職に関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

CompanyPost

public CompanyPost(Locale locale)
役職に関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

パラメータ:
locale - デフォルトの言語

CompanyPost

public CompanyPost(Date date)
役職に関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時

CompanyPost

public CompanyPost(Locale locale,
                   Date date)
役職に関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
locale - デフォルトの言語
date - デフォルトの日時
メソッドの詳細

getDefaultLocale

public Locale getDefaultLocale()
デフォルトのロケールを取得します。

戻り値:
デフォルトのロケール

setDefaultLocale

public void setDefaultLocale(Locale defaultLocale)
デフォルトのロケールを設定します。

パラメータ:
defaultLocale - デフォルトのロケール

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
この役職で管理している期間をすべて取得します。

戻り値:
この役職で管理している期間

getCompanyPostTerminable

public CompanyPostTerminable getCompanyPostTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getCompanyPostTerminable

public CompanyPostTerminable getCompanyPostTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putCompanyPostTerminable

public void putCompanyPostTerminable(Term term,
                                     CompanyPostTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removeCompanyPostTerminable

public void removeCompanyPostTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します。

パラメータ:
companyCode - 会社コード

getPostCode

public String getPostCode()
役職コードを取得します。

戻り値:
役職コード

setPostCode

public void setPostCode(String postCode)
役職コードを設定します。

パラメータ:
postCode - 役職コード

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー

getName

public String getName()
役職名を取得します。

戻り値:
役職名

getName

public String getName(Date date)
役職名を取得します。

パラメータ:
date - 日時
戻り値:
役職名

getName

public String getName(Locale locale)
役職名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
役職名

getName

public String getName(Date date,
                      Locale locale)
役職名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
役職名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyPostTerminable (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.post
クラス CompanyPostTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable
すべての実装インタフェース:
Serializable
public class CompanyPostTerminable
extends Object
implements Serializable

役職の期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CompanyPostTerminable()
メソッドの概要
CompanyPostTerminableInternational | getCompanyPostTerminableInternational(Locale locale) 指定された言語に対する期間国際化情報を取得します。
Locale[] | getLocales() この役職で管理している言語（ロケール）をすべて取得します。
void | putCompanyPostTerminableInternational(Locale locale, CompanyPostTerminableInternational data) 指定された言語に対する期間国際化情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyPostTerminable

public CompanyPostTerminable()
メソッドの詳細

getLocales

public Locale[] getLocales()
この役職で管理している言語（ロケール）をすべて取得します。

戻り値:
この役職で管理している言語（ロケール）

getCompanyPostTerminableInternational

public CompanyPostTerminableInternational getCompanyPostTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
期間国際化情報

putCompanyPostTerminableInternational

public void putCompanyPostTerminableInternational(Locale locale,
                                                  CompanyPostTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 期間国際化情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyPostTerminableInternational (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.post
クラス CompanyPostTerminableInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational
すべての実装インタフェース:
Serializable
public class CompanyPostTerminableInternational
extends Object
implements Serializable

役職の期間国際化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CompanyPostTerminableInternational()
メソッドの概要
String | getName() 役職名を取得します。
void | setName(String name) 役職名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyPostTerminableInternational

public CompanyPostTerminableInternational()
メソッドの詳細

getName

public String getName()
役職名を取得します。

戻り値:
役職名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
役職名を設定します。

パラメータ:
name - 役職名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.company.post (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.company.post
インタフェース
PlainCompanyPost
クラス
CompanyPost
CompanyPostTerminable
CompanyPostTerminableInternational


jp.co.intra_mart.foundation.datastore.application.domain.company.post (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.post

役職情報を操作するクラスを提供します。

参照:
説明

インタフェースの概要
PlainCompanyPost 役職データを扱います。

クラスの概要
CompanyPost | 役職の基本属性のデータを取り扱います。
CompanyPostTerminable | 役職の期間化属性のデータを取り扱います。
CompanyPostTerminableInternational | 役職の期間国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.post の説明

役職情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.company.post クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.post の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational (implements java.io.Serializable)

インタフェース階層

  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.post の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.post の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.post を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.post | 役職情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.post のクラス
CompanyPost
役職の基本属性のデータを取り扱います。
PlainCompanyPost
役職データを扱います。

jp.co.intra_mart.foundation.datastore.application.domain.company.post により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.post のクラス
CompanyPostTerminable
役職の期間化属性のデータを取り扱います。
CompanyPostTerminableInternational
役職の期間国際化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.post のクラス
CompanyPost
役職の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.post のクラス
CompanyPost
役職の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PlainCompanyPost (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.post
インタフェース PlainCompanyPost

すべてのスーパーインタフェース:
Serializable
public interface PlainCompanyPost
extends Serializable

役職データを扱います。

導入されたバージョン:
5.0

メソッドの概要
Date | getActivationDate() 役職情報の有効開始日を取得します。
String | getCompanyCode() 会社コードを取得します。
Date | getExpirationDate() 役職情報の有効終了日を取得します。
Locale | getLocale() 役職名の言語を取得します。
String | getNotes() 備考を取得します。
String | getPostCode() 役職コードを取得します。
String | getPostName() 役職名を取得します。
int | getSortKey() ソートキーを取得します。

メソッドの詳細

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

getPostCode

public String getPostCode()
役職コードを取得します。

戻り値:
役職コード

getPostName

public String getPostName()
役職名を取得します。

戻り値:
役職名

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

getActivationDate

public Date getActivationDate()
役職情報の有効開始日を取得します。

戻り値:
有効開始日

getExpirationDate

public Date getExpirationDate()
役職情報の有効終了日を取得します。

戻り値:
有効終了日

getLocale

public Locale getLocale()
役職名の言語を取得します。

戻り値:
言語
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion の使用

CompanyVersion を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での CompanyVersion の使用

CompanyVersion を返す jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract CompanyVersion | CompanyManager.getVersion(String company) 現在の会社構成バージョン情報を取得します。
abstract CompanyVersion | CompanyManager.getVersion(String company, Date date) 指定された日付の会社構成バージョン情報を取得します。

CompanyVersion 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract void | CompanyManager.addVersion(CompanyVersion version) 会社構成バージョンを新規に登録します。
abstract void | CompanyManager.updateVersion(CompanyVersion version) 登録済の会社構成バージョンを更新します。
abstract void | CompanyManager.deleteVersion(CompanyVersion version) 登録済の会社構成バージョンを削除します。
void | CompanyChangedListener.versionAdded(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.versionUpdated(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに更新された後に呼び出されます。
void | CompanyChangedListener.versionDeleted(String groupId, CompanyVersion version) 会社構成バージョンがデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.access での CompanyVersion の使用

CompanyVersion 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | CompanyChangedControllerListener.versionAdded(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.versionUpdated(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに更新された後に呼び出されます。
void | CompanyChangedControllerListener.versionDeleted(String groupId, CompanyVersion version) 会社構成バージョンがデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での CompanyVersion の使用

CompanyVersion 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | CompanyChangedMenuListener.versionAdded(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.versionUpdated(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに更新された後に呼び出されます。
void | CompanyChangedMenuListener.versionDeleted(String groupId, CompanyVersion version) 会社構成バージョンがデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CompanyVersion (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.version
クラス CompanyVersion

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion
すべての実装インタフェース:
Serializable
public class CompanyVersion
extends Object
implements Serializable

会社構成バージョンの基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CompanyVersion()
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
Date | getEndDate() 終了日を取得します。
String | getNotes() 備考を取得します。
Date | getStartDate() 開始日を取得します。
String | getVersionCode() バージョンコードを取得します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setEndDate(Date endDate) 終了日を設定します。
void | setNotes(String notes) 備考を設定します。
void | setStartDate(Date startDate) 開始日を設定します。
void | setVersionCode(String versionCode) バージョンコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyVersion

public CompanyVersion()
メソッドの詳細

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します。

パラメータ:
companyCode - 会社コード

getVersionCode

public String getVersionCode()
バージョンコードを取得します。

戻り値:
バージョンコード

setVersionCode

public void setVersionCode(String versionCode)
バージョンコードを設定します。

パラメータ:
versionCode - バージョンコード

getStartDate

public Date getStartDate()
開始日を取得します。

戻り値:
開始日

setStartDate

public void setStartDate(Date startDate)
開始日を設定します。

パラメータ:
startDate - 開始日

getEndDate

public Date getEndDate()
終了日を取得します。

戻り値:
終了日

setEndDate

public void setEndDate(Date endDate)
終了日を設定します。

パラメータ:
endDate - 終了日

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.company.version (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.company.version
クラス
CompanyVersion


jp.co.intra_mart.foundation.datastore.application.domain.company.version (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.version

バーション情報を操作するクラスを提供します。

参照:
説明

クラスの概要
CompanyVersion 会社構成バージョンの基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.version の説明

バーション情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.company.version クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.version の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.version の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.version の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.version を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.version のクラス
CompanyVersion
会社構成バージョンの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.version のクラス
CompanyVersion
会社構成バージョンの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.version のクラス
CompanyVersion
会社構成バージョンの基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CompanyChangedListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company
インタフェース CompanyChangedListener

既知の実装クラスの一覧:
CompanyChangedControllerListener, CompanyChangedMenuListener
public interface CompanyChangedListener

会社・組織に関する情報の変更時のリスナーです。

導入されたバージョン:
5.0

メソッドの概要
void | categoryDetailRemoved(String groupId, CompanyCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | categoryDetailSet(String groupId, CompanyCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | companyAdded(String groupId, Company company) 会社情報がデータストアに登録された後に呼び出されます。
void | companyDeleted(String groupId, Company company) 会社情報がデータストアから削除された後に呼び出されます。
void | departmentAdded(String groupId, Department department) 組織情報がデータストアに登録された後に呼び出されます。
void | departmentDeleted(String groupId, Department department) 組織情報がデータストアに更新された後に呼び出されます。
void | departmentJoined(String groupId, String company, String parentDepartment, String department, String version) 組織構成がデータストアに登録された後に呼び出されます。
void | departmentLeft(String groupId, String company, String department, String version) 組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
void | departmentMoved(String groupId, String company, String parentDepartment, String department, String version) 組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
void | departmentUpdated(String groupId, Department department) 組織情報がデータストアから削除された後に呼び出されます。
void | init(Map params) 会社リスナーの初期化を行います。
void | mainRemoved(String groupId, DepartmentMain main) 主所属情報がデータストアから削除された後に呼び出されます。
void | mainSet(String groupId, DepartmentMain main) 主所属情報がデータストアに登録された後に呼び出されます。
void | memberDeleted(String groupId, DepartmentAttach attach) 組織からの人員の割当がデータストアから削除された後に呼び出されます。
void | memberSet(String groupId, DepartmentAttach attach) 組織への人員の割当がデータストアに登録された後に呼び出されます。
void | postAdded(String groupId, CompanyPost post) 役職情報がデータストアに登録された後に呼び出されます。
void | postDeleted(String groupId, CompanyPost post) 役職情報がデータストアから削除された後に呼び出されます。
void | postUpdated(String groupId, CompanyPost post) 役職情報がデータストアに更新された後に呼び出されます。
void | setUserId(String userId) ログインユーザIDを設定します。
void | versionAdded(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに登録された後に呼び出されます。
void | versionCopied(String groupId, String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
void | versionDeleted(String groupId, CompanyVersion version) 会社構成バージョンがデータストアから削除された後に呼び出されます。
void | versionUpdated(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに更新された後に呼び出されます。

メソッドの詳細

init

public void init(Map params)
会社リスナーの初期化を行います。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

パラメータ:
params - 初期化パラメータのマップ(Map)

setUserId

public void setUserId(String userId)
ログインユーザIDを設定します。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

パラメータ:
userId - ログインユーザID

companyAdded

public void companyAdded(String groupId,
                         Company company)
                  throws ChangedListenerException
会社情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
company - 会社情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

companyDeleted

public void companyDeleted(String groupId,
                           Company company)
                    throws ChangedListenerException
会社情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
company - 会社情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentAdded

public void departmentAdded(String groupId,
                            Department department)
                     throws ChangedListenerException
組織情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentUpdated

public void departmentUpdated(String groupId,
                              Department department)
                       throws ChangedListenerException
組織情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentDeleted

public void departmentDeleted(String groupId,
                              Department department)
                       throws ChangedListenerException
組織情報がデータストアに更新された後に呼び出されます。

パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentJoined

public void departmentJoined(String groupId,
                             String company,
                             String parentDepartment,
                             String department,
                             String version)
                      throws ChangedListenerException
組織構成がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
company - 会社コード
parentDepartment - 新規登録する組織の上位となる組織の組織コード（または会社の会社コード）
department - 組織情報（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentMoved

public void departmentMoved(String groupId,
                            String company,
                            String parentDepartment,
                            String department,
                            String version)
                     throws ChangedListenerException
組織構成からの組織の移動がデータストアに反映された後に呼び出されます。

パラメータ:
groupId - ログイングループID
company - 上位組織と移動対象の組織が所属する会社の会社コード
parentDepartment - 上位組織の組織コード（または会社の会社コード）
department - 移動する組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentLeft

public void departmentLeft(String groupId,
                           String company,
                           String department,
                           String version)
                    throws ChangedListenerException
組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。

パラメータ:
groupId - ログイングループID
company - 会社コード
department - 離脱させる組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailSet

public void categoryDetailSet(String groupId,
                              CompanyCategory category)
                       throws ChangedListenerException
分類区分情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
category - 登録された分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailRemoved

public void categoryDetailRemoved(String groupId,
                                  CompanyCategory category)
                           throws ChangedListenerException
分類区分情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
category - 削除された分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberSet

public void memberSet(String groupId,
                      DepartmentAttach attach)
               throws ChangedListenerException
組織への人員の割当がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
attach - 割当られた人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberDeleted

public void memberDeleted(String groupId,
                          DepartmentAttach attach)
                   throws ChangedListenerException
組織からの人員の割当がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
attach - 組織から外された人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

mainSet

public void mainSet(String groupId,
                    DepartmentMain main)
             throws ChangedListenerException
主所属情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
main - 主所属情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

mainRemoved

public void mainRemoved(String groupId,
                        DepartmentMain main)
                 throws ChangedListenerException
主所属情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
main - 主所属情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionAdded

public void versionAdded(String groupId,
                         CompanyVersion version)
                  throws ChangedListenerException
会社構成バージョンがデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionUpdated

public void versionUpdated(String groupId,
                           CompanyVersion version)
                    throws ChangedListenerException
会社構成バージョンがデータストアに更新された後に呼び出されます。

パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionDeleted

public void versionDeleted(String groupId,
                           CompanyVersion version)
                    throws ChangedListenerException
会社構成バージョンがデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionCopied

public void versionCopied(String groupId,
                          String company,
                          String srcVersion,
                          String destVersion,
                          Term term)
                   throws ChangedListenerException
登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
company - コピー元、コピー先の会社構成バージョンの会社コード
srcVersion - コピー元の会社構成バージョンのバージョンコード
destVersion - コピー先の会社構成バージョンのバージョンコード
term - コピー先の会社構成バージョンの期間
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

postAdded

public void postAdded(String groupId,
                      CompanyPost post)
               throws ChangedListenerException
役職情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

postUpdated

public void postUpdated(String groupId,
                        CompanyPost post)
                 throws ChangedListenerException
役職情報がデータストアに更新された後に呼び出されます。

パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

postDeleted

public void postDeleted(String groupId,
                        CompanyPost post)
                 throws ChangedListenerException
役職情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyImporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company
インタフェース CompanyImporter

既知の実装クラスの一覧:
StandardCompanyImporter
public interface CompanyImporter

会社のインポートのインターフェースです。

導入されたバージョン:
5.0

メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。

メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company
クラス CompanyManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager
public abstract class CompanyManager
extends Object

会社や組織に関連する情報を管理します。 このクラスのインスタンスは必ず getCompanyManager(String,String) で取得してください。

導入されたバージョン:
5.0

コンストラクタの概要
CompanyManager()
メソッドの概要
abstract void | addCompany(Company company) 会社を登録します。
abstract void | addDepartment(Department department) 組織を登録します。
abstract void | addPost(CompanyPost post) 役職を登録します。
abstract void | addVersion(CompanyVersion version) 会社構成バージョンを新規に登録します。
abstract void | copyVersion(String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンの内容をコピーします。
abstract void | deleteCompany(Company company) 登録済の会社を削除します。
abstract void | deleteDepartment(Department department) 登録済の組織情報を削除します。
abstract void | deleteMember(DepartmentAttach attach) 組織から人員をはずします。
abstract void | deletePost(CompanyPost post) 登録済の役職情報を削除します。
abstract void | deleteVersion(CompanyVersion version) 登録済の会社構成バージョンを削除します。
abstract Department[] | getAttachedDepartments(String user) 現在、ユーザが所属している組織の一覧を取得します。
abstract Department[] | getAttachedDepartments(String user, Date date) 指定された日付にユーザが所属している組織の一覧を取得します。
static CompanyManager | getCompanyManager(String user, String group) CompanyManagerを取得します。
abstract Department | getDepartment(String company, String department) 登録済の組織を取得します。
abstract DepartmentAttach | getDepartmentAttach(String user, String company, String department) ユーザの組織への所属情報を取得します。
abstract DepartmentMain | getDepartmentMain(String user) ユーザの主所属情報を取得します。
abstract DepartmentStruct[] | getDepartmentStructs(String company, String department, Date date, Locale locale) 組織の階層構造を取得します。
abstract User[] | getMember(String company, String department) 現在、組織に所属するる人員の一覧を取得します。
abstract User[] | getMember(String company, String department, Date date) 指定された日付に組織に所属する人員の一覧を取得します。
abstract PlainCompanyPost[] | getPostsInCompany(String company) 会社に登録済の役職をすべて取得します。
abstract PlainCompanyPost[] | getPostsInCompany(String company, Date date) 会社に登録済の役職をすべて取得します。
abstract PlainCompanyPost[] | getPostsInCompany(String company, Date date, Locale locale) 会社に登録済の役職をすべて取得します。
abstract PlainCompanyPost[] | getPostsInCompany(String company, Locale locale) 会社に登録済の役職をすべて取得します。
abstract PlainCompanyPost[] | getPostsOfUser(String company, String user) ユーザに設定された役職をすべて取得します。
abstract PlainCompanyPost[] | getPostsOfUser(String company, String user, Date date) ユーザに設定された役職をすべて取得します。
abstract PlainCompanyPost[] | getPostsOfUser(String company, String user, Date date, Locale locale) ユーザに設定された役職をすべて取得します。
abstract PlainCompanyPost[] | getPostsOfUser(String company, String user, Locale locale) ユーザに設定された役職をすべて取得します。
abstract CompanyVersion | getVersion(String company) 現在の会社構成バージョン情報を取得します。
abstract CompanyVersion | getVersion(String company, Date date) 指定された日付の会社構成バージョン情報を取得します。
protected abstract void | init(String user, String group) CompanyManagerを初期化します。
abstract void | joinDepartment(String company, String parentDepartment, String department, String version) 組織構成に組織を登録します。
abstract void | leaveDepartment(String company, String department, String version) 組織構成から組織情報を離脱させます。
abstract void | moveDepartment(String company, String parentDepartment, String department, String version) 組織構成に登録済の組織情報を移動します。
abstract void | removeCategoryDetail(CompanyCategory category) 組織に対して指定された分類区分情報を削除します。
abstract void | removeMain(DepartmentMain main) 指定されたユーザの主所属を削除します。
abstract void | setCategoryDetail(CompanyCategory category) 組織に対して指定された分類区分情報を設定します。
abstract void | setMain(DepartmentMain main) ユーザが主所属する組織を設定します。
abstract void | setMember(DepartmentAttach attach) 組織に人員を割り当てます。
abstract void | updateDepartment(Department department) 登録済の組織情報を更新します。
abstract void | updatePost(CompanyPost post) 登録済の役職情報を更新します。
abstract void | updateVersion(CompanyVersion version) 登録済の会社構成バージョンを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyManager

public CompanyManager()
メソッドの詳細

getCompanyManager

public static CompanyManager getCompanyManager(String user,
                                               String group)
                                        throws ManagerException
CompanyManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するCompanyManager
例外:
ManagerException - CompanyManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
CompanyManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - 初期化に失敗

getDepartment

public abstract Department getDepartment(String company,
                                         String department)
                                  throws ManagerException
登録済の組織を取得します。
会社コード、組織コードに一致する組織情報が存在しない場合は nullを返します。

パラメータ:
company - 会社コード
department - 組織コード
戻り値:
組織情報
例外:
ManagerException - 組織情報の取得に失敗
導入されたバージョン:
5.1

addCompany

public abstract void addCompany(Company company)
                         throws ManagerException
会社を登録します。 このメソッドを実行すると下記のような動作が行われます。
  1. 会社を新規登録する。
  2. 会社に対応する組織を新規登録する。

パラメータ:
company - 会社情報
例外:
ManagerException - 会社の新規登録に失敗

deleteCompany

public abstract void deleteCompany(Company company)
                            throws ManagerException
登録済の会社を削除します。 このメソッドを実行すると指定された会社に関連する全ての情報が削除されます。
指定された会社の情報が存在しない場合は ManagerException がスローされます。

パラメータ:
company - 会社
例外:
ManagerException - 会社の削除に失敗

addDepartment

public abstract void addDepartment(Department department)
                            throws ManagerException
組織を登録します。
このメソッドを実行しただけではまだ会社の組織構成には追加されていません。
組織構成に追加したい場合は joinDepartment(String, String, String, String) を使用してください。

パラメータ:
department - 組織情報
例外:
ManagerException - 組織の登録に失敗

updateDepartment

public abstract void updateDepartment(Department department)
                               throws ManagerException
登録済の組織情報を更新します。

パラメータ:
department - 組織情報
例外:
ManagerException - 組織情報の更新に失敗

deleteDepartment

public abstract void deleteDepartment(Department department)
                               throws ManagerException
登録済の組織情報を削除します。
指定された組織情報が存在しない場合は ManagerException がスローされます。

パラメータ:
department - 組織情報
例外:
ManagerException - 組織情報の削除に失敗

joinDepartment

public abstract void joinDepartment(String company,
                                    String parentDepartment,
                                    String department,
                                    String version)
                             throws ManagerException
組織構成に組織を登録します。
新しく親となる組織と登録対象の組織は同一の会社に所属している必要があります。
バージョンコードは登録済みのものを指定する必要があります。
選択された組織が対象のバージョンにおいて既に登録されているときはこのメソッドは使用できません。

パラメータ:
company - 会社コード
parentDepartment - 新規登録する組織の上位となる組織の組織コード（または会社の会社コード）
department - 新規登録する組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ManagerException - 組織構成に組織の登録の失敗

moveDepartment

public abstract void moveDepartment(String company,
                                    String parentDepartment,
                                    String department,
                                    String version)
                             throws ManagerException
組織構成に登録済の組織情報を移動します。
新しく上位となる組織と移動対象の組織は同一の会社に所属している必要があります。

また、組織構成が循環するような移動はできません。
バージョンコードは登録済みのものを指定する必要があります。

パラメータ:
company - 上位組織と移動対象の組織が所属する会社の会社コード
parentDepartment - 上位組織の組織コード（または会社の会社コード）
department - 移動する組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ManagerException - 組織の移動の失敗

leaveDepartment

public abstract void leaveDepartment(String company,
                                     String department,
                                     String version)
                              throws ManagerException
組織構成から組織情報を離脱させます。
このメソッドを実行すると、組織を対象バージョンから離脱させることができます。
指定された組織が子組織を持っていた場合、それらの組織も再帰的にこのバージョンから削除されます。
このメソッドを実行しても組織情報そのものは残ります。
指定された組織が組織構成に登録されていない場合は ManagerException がスローされます。

パラメータ:
company - 会社コード
department - 離脱させる組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ManagerException - 組織構成から組織情報の離脱の失敗

setCategoryDetail

public abstract void setCategoryDetail(CompanyCategory category)
                                throws ManagerException
組織に対して指定された分類区分情報を設定します。

パラメータ:
category - 設定する分類区分詳細詳細情報
例外:
ManagerException - 分類区分情報の設定に失敗

removeCategoryDetail

public abstract void removeCategoryDetail(CompanyCategory category)
                                   throws ManagerException
組織に対して指定された分類区分情報を削除します。
指定された分類区分情報が存在しない場合は ManagerException がスローされます。

パラメータ:
category - 削除する分類区分詳細詳細情報
例外:
ManagerException - 分類区分情報の削除に失敗

setMember

public abstract void setMember(DepartmentAttach attach)
                        throws ManagerException
組織に人員を割り当てます。
人員の割当情報はパラメータで渡された情報で完全に上書きされます。

パラメータ:
attach - 割当人員の情報
例外:
ManagerException - 人員の割当に失敗

deleteMember

public abstract void deleteMember(DepartmentAttach attach)
                           throws ManagerException
組織から人員をはずします。
指定された人員が組織に割り当てられていない場合は ManagerException がスローされます。

パラメータ:
attach - 組織から外す人員の情報
例外:
ManagerException - 人員の削除に失敗

getMember

public abstract User[] getMember(String company,
                                 String department)
                          throws ManagerException
現在、組織に所属するる人員の一覧を取得します。
指定された組織に人員が所属していない場合は空の配列を返します。

取得されるユーザの期間化情報には、システム日付を含む期間の情報のみが設定されます。
また期間国際化情報には、ログインユーザのデフォルト言語の情報のみが設定されます。

パラメータ:
company - 会社コード
department - 組織コード
戻り値:
ユーザ情報
例外:
ManagerException - 所属する人員の取得に失敗
導入されたバージョン:
5.1

getMember

public abstract User[] getMember(String company,
                                 String department,
                                 Date date)
                          throws ManagerException
指定された日付に組織に所属する人員の一覧を取得します。
指定された組織に人員が所属していない場合は空の配列を返します。

取得されるユーザの期間化情報には、指定された日付を含む期間の情報のみが設定されます。
また期間国際化情報には、ログインユーザのデフォルト言語の情報のみが設定されます。

パラメータ:
company - 会社コード
department - 組織コード
date - 日付
戻り値:
ユーザ情報
例外:
ManagerException - 所属する人員の取得に失敗
導入されたバージョン:
5.1

setMain

public abstract void setMain(DepartmentMain main)
                      throws ManagerException
ユーザが主所属する組織を設定します。
既存の主所属情報は新しい情報で上書きされます。

パラメータ:
main - 主所属情報
例外:
ManagerException - 主所属する組織の設定に失敗

removeMain

public abstract void removeMain(DepartmentMain main)
                         throws ManagerException
指定されたユーザの主所属を削除します。
指定されたユーザの主所属の情報が存在しない場合は ManagerException がスローされます。

パラメータ:
main - 主所属情報
例外:
ManagerException - 主所属の削除の失敗

addVersion

public abstract void addVersion(CompanyVersion version)
                         throws ManagerException
会社構成バージョンを新規に登録します。
追加された構成バージョンのトップレベルには、会社に該当する組織が追加されます。

パラメータ:
version - バージョン情報
例外:
ManagerException - 会社構成バージョンの新規登録に失敗

updateVersion

public abstract void updateVersion(CompanyVersion version)
                            throws ManagerException
登録済の会社構成バージョンを更新します。

パラメータ:
version - バージョン情報
例外:
ManagerException - 会社構成バージョンの更新に失敗

deleteVersion

public abstract void deleteVersion(CompanyVersion version)
                            throws ManagerException
登録済の会社構成バージョンを削除します。
指定された会社構成バージョンの情報が存在しない場合は ManagerException がスローされます。

パラメータ:
version - バージョン情報
例外:
ManagerException - 会社構成バージョンの削除に失敗

copyVersion

public abstract void copyVersion(String company,
                                 String srcVersion,
                                 String destVersion,
                                 Term term)
                          throws ManagerException
登録済の会社構成バージョンの内容をコピーします。
コピー元の会社構成バージョンに関連する、全ての組織内包がコピー先の会社構成バージョンに関連づくようにコピーされます。
コピー元のバージョンコードは登録済みのものを選択してください
コピー先のバージョンコードは登録されていないものを選択してください

パラメータ:
company - コピー元、コピー先の会社構成バージョンの会社コード
srcVersion - コピー元の会社構成バージョンのバージョンコード
destVersion - コピー先の会社構成バージョンのバージョンコード
term - コピー先の会社構成バージョンの期間
例外:
ManagerException - 会社構成バージョンのコピーに失敗

getDepartmentStructs

public abstract DepartmentStruct[] getDepartmentStructs(String company,
                                                        String department,
                                                        Date date,
                                                        Locale locale)
                                                 throws ManagerException
組織の階層構造を取得します。
指定された日付に該当する会社構成バージョンが存在しない場合は、ManagerException がスローされます。
また、会社構成バージョンは存在するが該当する組織情報が存在しない場合は空の配列を返します。

パラメータ:
company - 会社コード
department - 組織コード
date - 日付
locale - 言語(ロケール)
戻り値:
組織の階層構造
例外:
ManagerException - 組織の階層構造の取得に失敗

getAttachedDepartments

public abstract Department[] getAttachedDepartments(String user)
                                             throws ManagerException
現在、ユーザが所属している組織の一覧を取得します。
ユーザがどの組織にも所属していない場合は空の配列を返します。

取得される組織の期間化情報には、システム日付を含む期間の情報のみが設定されます。
また期間国際化情報には、ログインユーザのデフォルト言語の情報のみが設定されます。

パラメータ:
user - ユーザコード
例外:
ManagerException - 組織情報の取得に失敗
導入されたバージョン:
5.1

getAttachedDepartments

public abstract Department[] getAttachedDepartments(String user,
                                                    Date date)
                                             throws ManagerException
指定された日付にユーザが所属している組織の一覧を取得します。
ユーザがどの組織にも所属していない場合は空の配列を返します。

取得される組織の期間化情報には、指定された日付を含む期間の情報のみが設定されます。
また期間国際化情報には、ログインユーザのデフォルト言語の情報のみが設定されます。

パラメータ:
user - ユーザコード
date - 日付
例外:
ManagerException - 組織情報の取得に失敗
導入されたバージョン:
5.1

getDepartmentAttach

public abstract DepartmentAttach getDepartmentAttach(String user,
                                                     String company,
                                                     String department)
                                              throws ManagerException
ユーザの組織への所属情報を取得します。
該当する組織所属が存在しない場合は nullを返します。

パラメータ:
user - ユーザコード
company - 会社コード
department - 組織コード
戻り値:
組織所属情報
例外:
ManagerException - 組織所属情報の取得に失敗
導入されたバージョン:
5.1

getDepartmentMain

public abstract DepartmentMain getDepartmentMain(String user)
                                          throws ManagerException
ユーザの主所属情報を取得します。

パラメータ:
user - ユーザコード
戻り値:
主所属情報
例外:
ManagerException - 主所属情報の取得に失敗
導入されたバージョン:
5.1

getPostsInCompany

public abstract PlainCompanyPost[] getPostsInCompany(String company)
会社に登録済の役職をすべて取得します。
役職を特定するためにシステム日付、ログインユーザのデフォルト言語を使用します。

パラメータ:
company - 会社コード
戻り値:
会社に登録済の役職
例外:
ManagerException - 役職情報の取得に失敗

getPostsInCompany

public abstract PlainCompanyPost[] getPostsInCompany(String company,
                                                     Date date)
会社に登録済の役職をすべて取得します。
役職を特定するためにログインユーザのデフォルト言語を使用します。

パラメータ:
company - 会社コード
date - 役職情報を特定するための日付
戻り値:
会社に登録済の役職
例外:
ManagerException - 役職情報の取得に失敗

getPostsInCompany

public abstract PlainCompanyPost[] getPostsInCompany(String company,
                                                     Locale locale)
会社に登録済の役職をすべて取得します。
役職を特定するためにシステム日付を使用します。

パラメータ:
company - 会社コード
locale - 役職情報を特定するための言語
戻り値:
会社に登録済の役職
例外:
ManagerException - 役職情報の取得に失敗

getPostsInCompany

public abstract PlainCompanyPost[] getPostsInCompany(String company,
                                                     Date date,
                                                     Locale locale)
会社に登録済の役職をすべて取得します。

パラメータ:
company - 会社コード
date - 役職情報を特定するための日付
locale - 役職情報を特定するための言語
戻り値:
会社に登録済の役職
例外:
ManagerException - 役職情報の取得に失敗

getPostsOfUser

public abstract PlainCompanyPost[] getPostsOfUser(String company,
                                                  String user)
ユーザに設定された役職をすべて取得します。
役職を特定するためにシステム日付、ログインユーザのデフォルト言語を使用します。

パラメータ:
company - 会社コード
user - ユーザコード
戻り値:
会社に登録済の役職
例外:
ManagerException - 役職情報の取得に失敗

getPostsOfUser

public abstract PlainCompanyPost[] getPostsOfUser(String company,
                                                  String user,
                                                  Date date)
ユーザに設定された役職をすべて取得します。
役職を特定するためにログインユーザのデフォルト言語を使用します。

パラメータ:
company - 会社コード
user - ユーザコード
date - 役職情報を特定するための日付
戻り値:
会社に登録済の役職
例外:
ManagerException - 役職情報の取得に失敗

getPostsOfUser

public abstract PlainCompanyPost[] getPostsOfUser(String company,
                                                  String user,
                                                  Locale locale)
ユーザに設定された役職をすべて取得します。
役職を特定するためにシステム日付を使用します。

パラメータ:
company - 会社コード
user - ユーザコード
locale - 役職情報を特定するための言語
戻り値:
会社に登録済の役職
例外:
ManagerException - 役職情報の取得に失敗

getPostsOfUser

public abstract PlainCompanyPost[] getPostsOfUser(String company,
                                                  String user,
                                                  Date date,
                                                  Locale locale)
ユーザに設定された役職をすべて取得します。

パラメータ:
company - 会社コード
user - ユーザコード
date - 役職情報を特定するための日付
locale - 役職情報を特定するための言語
戻り値:
会社に登録済の役職
例外:
ManagerException - 役職情報の取得に失敗

addPost

public abstract void addPost(CompanyPost post)
                      throws ManagerException
役職を登録します。

パラメータ:
post - 役職情報
例外:
ManagerException - 役職の登録に失敗

updatePost

public abstract void updatePost(CompanyPost post)
                         throws ManagerException
登録済の役職情報を更新します。

パラメータ:
post - 役職情報
例外:
ManagerException - 役職の更新に失敗

deletePost

public abstract void deletePost(CompanyPost post)
                         throws ManagerException
登録済の役職情報を削除します。
指定された役職情報が存在しない場合は ManagerException がスローされます。

パラメータ:
post - 役職情報
例外:
ManagerException - 役職の削除に失敗

getVersion

public abstract CompanyVersion getVersion(String company)
                                   throws ManagerException
現在の会社構成バージョン情報を取得します。
該当する会社構成バージョン情報が存在しない場合は null を返します。

パラメータ:
company - 会社コード
戻り値:
会社構成バージョン情報
例外:
ManagerException
導入されたバージョン:
5.1

getVersion

public abstract CompanyVersion getVersion(String company,
                                          Date date)
                                   throws ManagerException
指定された日付の会社構成バージョン情報を取得します。
該当する会社構成バージョン情報が存在しない場合は null を返します。

パラメータ:
company - 会社コード
date - バージョンを特定する日付
戻り値:
会社構成バージョン情報
例外:
ManagerException
導入されたバージョン:
5.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyPostImporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company
インタフェース CompanyPostImporter

既知の実装クラスの一覧:
StandardCompanyPostImporter
public interface CompanyPostImporter

役職のインポートのインターフェースです。

導入されたバージョン:
5.0

メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。

メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException - インポート時に例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DepartmentStruct (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company
インタフェース DepartmentStruct

public interface DepartmentStruct

組織の階層です。

導入されたバージョン:
5.0

メソッドの概要
String | getCompanyCode() 会社コードを取得する。
String | getDepartmentCode() 組織コードを取得する。
String | getName() 会社名または組織名を取得する。

メソッドの詳細

getCompanyCode

public String getCompanyCode()
会社コードを取得する。

戻り値:
会社コード

getDepartmentCode

public String getDepartmentCode()
組織コードを取得する。

戻り値:
組織コード

getName

public String getName()
会社名または組織名を取得する。

戻り値:
会社名または組織名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.company (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.company
インタフェース
CompanyChangedListener
CompanyImporter
CompanyPostImporter
DepartmentStruct
クラス
CompanyManager
StandardCompanyImporter
StandardCompanyPostImporter


jp.co.intra_mart.foundation.datastore.application.domain.company (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company

会社情報を操作するクラスを提供します。

参照:
説明

インタフェースの概要
CompanyChangedListener | 会社・組織に関する情報の変更時のリスナーです。
CompanyImporter | 会社のインポートのインターフェースです。
CompanyPostImporter | 役職のインポートのインターフェースです。
DepartmentStruct | 組織の階層です。

クラスの概要
CompanyManager | 会社や組織に関連する情報を管理します。
StandardCompanyImporter | 会社のインポートを行います。
StandardCompanyPostImporter | 役職のインポートを行います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company の説明

会社情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.company クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener
  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company の使用

jp.co.intra_mart.foundation.datastore.application.domain.company を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company のクラス
CompanyImporter
会社のインポートのインターフェースです。
CompanyManager
会社や組織に関連する情報を管理します。
CompanyPostImporter
役職のインポートのインターフェースです。
DepartmentStruct
組織の階層です。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.company のクラス
CompanyChangedListener
会社・組織に関する情報の変更時のリスナーです。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.company のクラス
CompanyChangedListener
会社・組織に関する情報の変更時のリスナーです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardCompanyImporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company
クラス StandardCompanyImporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter
すべての実装インタフェース:
CompanyImporter
public class StandardCompanyImporter
extends Object
implements CompanyImporter

会社のインポートを行います。

導入されたバージョン:
5.0

コンストラクタの概要
StandardCompanyImporter()
メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardCompanyImporter

public StandardCompanyImporter()
メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

定義:
インタフェース CompanyImporter 内の doImport
パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardCompanyPostImporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company
クラス StandardCompanyPostImporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter
すべての実装インタフェース:
CompanyPostImporter
public class StandardCompanyPostImporter
extends Object
implements CompanyPostImporter

役職のインポートを行います。

導入されたバージョン:
5.0

コンストラクタの概要
StandardCompanyPostImporter()
メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardCompanyPostImporter

public StandardCompanyPostImporter()
メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

定義:
インタフェース CompanyPostImporter 内の doImport
パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager の使用

CurrencyManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.currency 通貨情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.currency での CurrencyManager の使用

CurrencyManager を返す jp.co.intra_mart.foundation.datastore.application.domain.currency のメソッド
static CurrencyManager CurrencyManager.getCurrencyManager(String user, String group)
CurrencyManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CurrencyManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.currency
クラス CurrencyManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager
public abstract class CurrencyManager
extends Object

通貨情報を取り扱います。

導入されたバージョン:
5.1

コンストラクタの概要
CurrencyManager()
メソッドの概要
abstract String[] | getCurrencyCodes() 通貨コードの一覧を返します。
static CurrencyManager | getCurrencyManager(String user, String group) CurrencyManagerを取得します。
abstract Map | getCurrencyName(String currencyCode) 指定された通貨コードに対する名称を返します。
abstract String | getCurrencyName(String currencyCode, Locale locale) 通貨コードに対する名称を指定された言語で返します。
abstract String | getSystemCurrencyCode() システム通貨コードを返します。
protected abstract void | init(String user, String group) CurrencyManagerを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CurrencyManager

public CurrencyManager()
メソッドの詳細

getCurrencyManager

public static CurrencyManager getCurrencyManager(String user,
                                                 String group)
                                          throws ManagerException
CurrencyManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するCurrencyManager
例外:
ManagerException - CurrencyManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
CurrencyManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - 初期化に失敗

getSystemCurrencyCode

public abstract String getSystemCurrencyCode()
                                      throws ManagerException
システム通貨コードを返します。

戻り値:
通貨コード
例外:
ManagerException

getCurrencyCodes

public abstract String[] getCurrencyCodes()
                                   throws ManagerException
通貨コードの一覧を返します。

戻り値:
通貨コードの一覧
例外:
ManagerException

getCurrencyName

public abstract String getCurrencyName(String currencyCode,
                                       Locale locale)
                                throws ManagerException
通貨コードに対する名称を指定された言語で返します。
通貨コードが存在しない場合は、ManagerExceptionを発生させます。

null を返します。

パラメータ:
currencyCode - 通貨コード
locale - 言語
戻り値:
通貨名
例外:
ManagerException

getCurrencyName

public abstract Map getCurrencyName(String currencyCode)
                             throws ManagerException
指定された通貨コードに対する名称を返します。

返却されるマップ Map のキーには言語 Locale、値には通貨名が設定されます。

通貨コードが存在しない場合は、システム例外を発生させます。

通貨コードに対する名称が存在しない場合は、空のMapを返します。

返されるマップMapは変更することができません。

パラメータ:
currencyCode - 通貨コード
戻り値:
通貨名
例外:
ManagerException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.currency (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.currency
クラス
CurrencyManager


jp.co.intra_mart.foundation.datastore.application.domain.currency (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.currency

通貨情報を操作するクラスを提供します。

参照:
説明

クラスの概要
CurrencyManager 通貨情報を取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.currency の説明

通貨情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.currency クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.currency の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.currency の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.currency の使用

jp.co.intra_mart.foundation.datastore.application.domain.currency を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.currency 通貨情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.currency により使用される jp.co.intra_mart.foundation.datastore.application.domain.currency のクラス
CurrencyManager
通貨情報を取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager の使用

DealManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal での DealManager の使用

DealManager を返す jp.co.intra_mart.foundation.datastore.application.domain.deal のメソッド
static DealManager DealManager.getDealManager(String user, String group)
DealManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager の使用

DealPermissionManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal での DealPermissionManager の使用

DealPermissionManager を返す jp.co.intra_mart.foundation.datastore.application.domain.deal のメソッド
static DealPermissionManager DealPermissionManager.getDealPermissionManager(String user, String group)
DealPermissionManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal の使用

Deal を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal での Deal の使用

Deal を返す jp.co.intra_mart.foundation.datastore.application.domain.deal のメソッド
abstract Deal | DealManager.getDeal(String customerCompanyCode, String customerDepartmentCode, String dealCode) 指定された取扱情報を返します。
abstract Deal[] | DealManager.getDeals() 現在、存在する取扱情報を返します。
abstract Deal[] | DealManager.getDeals(Date date) 指定された日付に存在する取扱情報を返します。
abstract Deal[] | DealManager.getDealsByKey(String itemCode, String companyCode, String departmentCode) 現在、存在する取扱情報の中で、商品と取引先から特定されるものを返します。
abstract Deal[] | DealManager.getDealsByKey(String itemCode, String companyCode, String departmentCode, Date date) 指定された日時に存在する取扱情報の中で、商品と取引先から特定されるものを返します。
abstract Deal[] | DealManager.getUsersDeals(String userCode) 現在、ユーザがアクセスできる取扱情報を返します。
abstract Deal[] | DealManager.getUsersDeals(String userCode, Date date) 指定された日付にユーザがアクセスできる取扱情報を返します。
abstract Deal[] | DealManager.getUsersDealsByKey(String userCode, String itemCode, String companyCode, String departmentCode) 現在、存在する取扱情報の中で、商品と取引先から特定されるものを返します。
abstract Deal[] | DealManager.getUsersDealsByKey(String userCode, String itemCode, String companyCode, String departmentCode, Date date) 指定された日時に存在する取扱情報の中で、商品と取引先から特定されるものを返します。

Deal 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.deal のメソッド
abstract Department[] | DealPermissionManager.getDepartments(Deal deal) 取扱情報を保有するアクセス権をもつ組織を返します。
abstract PublicGroup[] | DealPermissionManager.getPublicGroups(Deal deal) 取扱情報を保有するアクセス権をもつパブリックグループを返します。
abstract Role[] | DealPermissionManager.getRoles(Deal deal) 取扱情報を保有するアクセス権をもつロールを返します。
abstract void | DealManager.addDeal(Deal deal) 取扱情報を新規登録します。
abstract void | DealManager.updateDeal(Deal deal) 取扱情報を更新します。
abstract void | DealManager.deleteDeal(Deal deal) 取扱情報を削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable の使用

DealTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal.deal での DealTerminable の使用

DealTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.deal.deal のメソッド
DealTerminable | Deal.getDealTerminable(Term term) 指定された期間に対する期間化情報を取得します。
DealTerminable | Deal.getDealTerminable(Date date) 指定された日時に対する期間化情報を取得します。

DealTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.deal.deal のメソッド
 void Deal.putDealTerminable(Term term, DealTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Deal (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.deal.deal
クラス Deal

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal
すべての実装インタフェース:
Serializable
public class Deal
extends Object
implements Serializable

取扱の基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
Deal()
取扱に関連する情報を新規に生成します。
Deal(Date date)
取扱に関連する情報を新規に生成します。
メソッドの概要
String | getCurrencyCode() 通貨コードを取得します。
String | getCustomerCompanyCode() 取引先会社コードを取得します。
String | getCustomerDepartmentCode() 取引先組織コードを取得します。
String | getDealCode() 取扱コードを取得します。
String | getDealName() 取扱名を取得します。
DealTerminable | getDealTerminable(Date date) 指定された日時に対する期間化情報を取得します。
DealTerminable | getDealTerminable(Term term) 指定された期間に対する期間化情報を取得します。
int | getDealType() 取扱種別を取得します。
Date | getDefaultDate() デフォルトの日時を取得します。
String | getNotes() 備考を取得します。
Term[] | getTerms() この取扱で管理している期間をすべて取得します。
double | getUnitPrice() 単価を取得します。
double | getUnitPrice(Date date) 単価を取得します。
void | putDealTerminable(Term term, DealTerminable data) 指定された期間に対する期間化情報を設定します。
void | removeDealTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setCurrencyCode(String currencyCode) 通貨コードを設定します。
void | setCustomerCompanyCode(String customerCompanyCode) 取引先会社コードを設定します。
void | setCustomerDepartmentCode(String customerDepartmentCode) 取引先組織コードを設定します。
void | setDealCode(String dealCode) 取扱コードを設定します。
void | setDealName(String dealName) 取扱名を設定します。
void | setDealType(int dealType) 取扱種別を設定します。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setNotes(String notes) 備考を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Deal

public Deal()
取扱に関連する情報を新規に生成します。 デフォルトの日時には現在のシステム日時が割り当てられます。

Deal

public Deal(Date date)
取扱に関連する情報を新規に生成します。 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時
メソッドの詳細

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
この取扱で管理している期間をすべて取得します。

戻り値:
この取扱で管理している期間

getDealTerminable

public DealTerminable getDealTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getDealTerminable

public DealTerminable getDealTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putDealTerminable

public void putDealTerminable(Term term,
                              DealTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removeDealTerminable

public void removeDealTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getCustomerCompanyCode

public String getCustomerCompanyCode()
取引先会社コードを取得します。

戻り値:
取引先会社コード

setCustomerCompanyCode

public void setCustomerCompanyCode(String customerCompanyCode)
取引先会社コードを設定します。

パラメータ:
customerCompanyCode - 取引先会社コード

getCustomerDepartmentCode

public String getCustomerDepartmentCode()
取引先組織コードを取得します。

戻り値:
取引先組織コード

setCustomerDepartmentCode

public void setCustomerDepartmentCode(String customerDepartmentCode)
取引先組織コードを設定します。

パラメータ:
customerDepartmentCode - 取引先組織コード

getDealCode

public String getDealCode()
取扱コードを取得します。

戻り値:
取扱コード

setDealCode

public void setDealCode(String dealCode)
取扱コードを設定します。

パラメータ:
dealCode - 取扱コード

getDealName

public String getDealName()
取扱名を取得します。

戻り値:
取扱名

setDealName

public void setDealName(String dealName)
取扱名を設定します。

パラメータ:
dealName - 取扱名

getDealType

public int getDealType()
取扱種別を取得します。

戻り値:
取扱種別

setDealType

public void setDealType(int dealType)
取扱種別を設定します。

パラメータ:
dealType - 取扱種別

getCurrencyCode

public String getCurrencyCode()
通貨コードを取得します。

戻り値:
通貨コード

setCurrencyCode

public void setCurrencyCode(String currencyCode)
通貨コードを設定します。

パラメータ:
currencyCode - 通貨コード

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getUnitPrice

public double getUnitPrice()
単価を取得します。

戻り値:
単価

getUnitPrice

public double getUnitPrice(Date date)
単価を取得します。

パラメータ:
date - 日時
戻り値:
単価
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DealTerminable (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.deal.deal
クラス DealTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable
すべての実装インタフェース:
Serializable
public class DealTerminable
extends Object
implements Serializable

取扱の期間化属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
DealTerminable()
メソッドの概要
void | addDetail(DealDetail detail) 取扱詳細を追加します。
DealDetail[] | getDetails() 取扱詳細の一覧を取得します。
double | getUnitPrice() 単価を取得します。
void | removeDetail(String itemCode) 商品コードに一致する取扱詳細を削除します。
void | setUnitPrice(double unitPrice) 単価を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DealTerminable

public DealTerminable()
メソッドの詳細

getUnitPrice

public double getUnitPrice()
単価を取得します。

戻り値:
単価

setUnitPrice

public void setUnitPrice(double unitPrice)
単価を設定します。

パラメータ:
unitPrice - 単価

addDetail

public void addDetail(DealDetail detail)
取扱詳細を追加します。

同じ商品コードを持つものがすでに、存在するときは上書きされます。

パラメータ:
detail - 取扱詳細

removeDetail

public void removeDetail(String itemCode)
商品コードに一致する取扱詳細を削除します。

パラメータ:
itemCode - 商品コード

getDetails

public DealDetail[] getDetails()
取扱詳細の一覧を取得します。

戻り値:
取扱詳細の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.deal.deal (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.deal.deal
クラス
Deal
DealTerminable


jp.co.intra_mart.foundation.datastore.application.domain.deal.deal (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.deal

取扱情報を操作するクラスを提供します。

参照:
説明

クラスの概要
Deal | 取扱の基本属性のデータを取り扱います。
DealTerminable | 取扱の期間化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.deal の説明

取扱情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.deal.deal クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.deal の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.deal の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal.deal の使用

jp.co.intra_mart.foundation.datastore.application.domain.deal.deal を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.deal | 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal により使用される jp.co.intra_mart.foundation.datastore.application.domain.deal.deal のクラス
Deal
取扱の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.deal.deal により使用される jp.co.intra_mart.foundation.datastore.application.domain.deal.deal のクラス
DealTerminable
取扱の期間化属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment の使用

DealerDepartment を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal での DealerDepartment の使用

DealerDepartment 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.deal のメソッド
abstract void | DealPermissionManager.setPermissionToDepartment(DealerDepartment dealer) 組織に対してアクセス権を設定します。
abstract void | DealPermissionManager.removePermissionFromDepartment(DealerDepartment dealer) 組織からアクセス権を削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DealerDepartment (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.deal.department
クラス DealerDepartment

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment
すべての実装インタフェース:
Serializable
public class DealerDepartment
extends Object
implements Serializable

組織毎取扱パーミッションの基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
DealerDepartment()
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getCustomerCompanyCode() 取引先会社コードを取得します。
String | getCustomerDepartmentCode() 取引先組織コードを取得します。
String | getDealCode() 取扱コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setCustomerCompanyCode(String customerCompanyCode) 取引先会社コードを設定します。
void | setCustomerDepartmentCode(String customerDepartmentCode) 取引先組織コードを設定します。
void | setDealCode(String dealCode) 取扱コードを設定します。
void | setDepartmentCode(String departmentCode) 組織コードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DealerDepartment

public DealerDepartment()
メソッドの詳細

getCustomerCompanyCode

public String getCustomerCompanyCode()
取引先会社コードを取得します。

戻り値:
取引先会社コード

setCustomerCompanyCode

public void setCustomerCompanyCode(String customerCompanyCode)
取引先会社コードを設定します。

パラメータ:
customerCompanyCode - 取引先会社コード

getCustomerDepartmentCode

public String getCustomerDepartmentCode()
取引先組織コードを取得します。

戻り値:
取引先組織コード

setCustomerDepartmentCode

public void setCustomerDepartmentCode(String customerDepartmentCode)
取引先組織コードを設定します。

パラメータ:
customerDepartmentCode - 取引先組織コード

getDealCode

public String getDealCode()
取扱コードを取得します。

戻り値:
取扱コード

setDealCode

public void setDealCode(String dealCode)
取扱コードを設定します。

パラメータ:
dealCode - 取扱コード

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します。

パラメータ:
companyCode - 会社コード

getDepartmentCode

public String getDepartmentCode()
組織コードを取得します。

戻り値:
組織コード

setDepartmentCode

public void setDepartmentCode(String departmentCode)
組織コードを設定します。

パラメータ:
departmentCode - 組織コード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.deal.department (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.deal.department
クラス
DealerDepartment


jp.co.intra_mart.foundation.datastore.application.domain.deal.department (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.department

取扱組織権限情報を操作するクラスを提供します。

参照:
説明

クラスの概要
DealerDepartment 組織毎取扱パーミッションの基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.department の説明

取扱組織権限情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.deal.department クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.department の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.department の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal.department の使用

jp.co.intra_mart.foundation.datastore.application.domain.deal.department を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal により使用される jp.co.intra_mart.foundation.datastore.application.domain.deal.department のクラス
DealerDepartment
組織毎取扱パーミッションの基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail の使用

DealDetail を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal.deal での DealDetail の使用

DealDetail を返す jp.co.intra_mart.foundation.datastore.application.domain.deal.deal のメソッド
 DealDetail[] DealTerminable.getDetails()
取扱詳細の一覧を取得します。

DealDetail 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.deal.deal のメソッド
 void DealTerminable.addDetail(DealDetail detail)
取扱詳細を追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DealDetail (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.deal.detail
クラス DealDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail
すべての実装インタフェース:
Serializable
public class DealDetail
extends Object
implements Serializable

取扱詳細の基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
DealDetail()
メソッドの概要
int | getAmount() 数量を取得します。
String | getItemCode() 商品コードを取得します。
String | getUnitCode() 単位コードを取得します。
double | getUnitPrice() 単価を取得します。
void | setAmount(int amount) 数量を設定します。
void | setItemCode(String itemCode) 商品コードを設定します。
void | setUnitCode(String unitCode) 単位コードを設定します。
void | setUnitPrice(double unitPrice) 単価を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DealDetail

public DealDetail()
メソッドの詳細

getItemCode

public String getItemCode()
商品コードを取得します。

戻り値:
商品コード

setItemCode

public void setItemCode(String itemCode)
商品コードを設定します。

パラメータ:
itemCode - 商品コード

getUnitCode

public String getUnitCode()
単位コードを取得します。

戻り値:
単位コード

getAmount

public int getAmount()
数量を取得します。

戻り値:
数量

getUnitPrice

public double getUnitPrice()
単価を取得します。

戻り値:
単価

setAmount

public void setAmount(int amount)
数量を設定します。

パラメータ:
amount - 数量

setUnitCode

public void setUnitCode(String unitCode)
単位コードを設定します。

パラメータ:
unitCode - 単位コード

setUnitPrice

public void setUnitPrice(double unitPrice)
単価を設定します。

パラメータ:
unitPrice - 単価
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.deal.detail (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.deal.detail
クラス
DealDetail


jp.co.intra_mart.foundation.datastore.application.domain.deal.detail (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.detail

取扱詳細情報を操作するクラスを提供します。

参照:
説明

クラスの概要
DealDetail 取扱詳細の基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.detail の説明

取扱詳細情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.deal.detail クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.detail の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.detail の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal.detail の使用

jp.co.intra_mart.foundation.datastore.application.domain.deal.detail を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal.deal により使用される jp.co.intra_mart.foundation.datastore.application.domain.deal.detail のクラス
DealDetail
取扱詳細の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup の使用

DealerPublicGroup を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal での DealerPublicGroup の使用

DealerPublicGroup 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.deal のメソッド
abstract void | DealPermissionManager.setPermissionToPublicGroup(DealerPublicGroup dealer) パブリックグループに対してアクセス権を設定します。
abstract void | DealPermissionManager.removePermissionFromPublicGroup(DealerPublicGroup dealer) パブリックグループからアクセス権を削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DealerPublicGroup (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group
クラス DealerPublicGroup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup
すべての実装インタフェース:
Serializable
public class DealerPublicGroup
extends Object
implements Serializable

パブリックグループ毎取扱パーミッションの基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
DealerPublicGroup()
メソッドの概要
String | getCustomerCompanyCode() 取引先会社コードを取得します。
String | getCustomerDepartmentCode() 取引先組織コードを取得します。
String | getDealCode() 取扱コードを取得します。
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
void | setCustomerCompanyCode(String customerCompanyCode) 取引先会社コードを設定します。
void | setCustomerDepartmentCode(String customerDepartmentCode) 取引先組織コードを設定します。
void | setDealCode(String dealCode) 取扱コードを設定します。
void | setPublicGroupCode(String publicGroupCode) グループコードを設定します。
void | setPublicGroupSetCode(String publicGroupSetCode) グループセットコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DealerPublicGroup

public DealerPublicGroup()
メソッドの詳細

getCustomerCompanyCode

public String getCustomerCompanyCode()
取引先会社コードを取得します。

戻り値:
取引先会社コード

setCustomerCompanyCode

public void setCustomerCompanyCode(String customerCompanyCode)
取引先会社コードを設定します。

パラメータ:
customerCompanyCode - 取引先会社コード

getCustomerDepartmentCode

public String getCustomerDepartmentCode()
取引先組織コードを取得します。

戻り値:
取引先組織コード

setCustomerDepartmentCode

public void setCustomerDepartmentCode(String customerDepartmentCode)
取引先組織コードを設定します。

パラメータ:
customerDepartmentCode - 取引先組織コード

getDealCode

public String getDealCode()
取扱コードを取得します。

戻り値:
取扱コード

setDealCode

public void setDealCode(String dealCode)
取扱コードを設定します。

パラメータ:
dealCode - 取扱コード

getPublicGroupSetCode

public String getPublicGroupSetCode()
グループセットコードを取得します。

戻り値:
グループセットコード

setPublicGroupSetCode

public void setPublicGroupSetCode(String publicGroupSetCode)
グループセットコードを設定します。

パラメータ:
publicGroupSetCode - グループセットコード

getPublicGroupCode

public String getPublicGroupCode()
グループコードを取得します。

戻り値:
グループコード

setPublicGroupCode

public void setPublicGroupCode(String publicGroupCode)
グループコードを設定します。

パラメータ:
publicGroupCode - グループコード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group
クラス
DealerPublicGroup


jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group

取扱パブリックグループ権限情報を操作するクラスを提供します。

参照:
説明

クラスの概要
DealerPublicGroup パブリックグループ毎取扱パーミッションの基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group の説明

取扱パブリックグループ権限情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group の使用

jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal により使用される jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group のクラス
DealerPublicGroup
パブリックグループ毎取扱パーミッションの基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole の使用

DealerRole を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal での DealerRole の使用

DealerRole 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.deal のメソッド
abstract void | DealPermissionManager.setPermissionToRole(DealerRole dealer) ロールに対してアクセス権を設定します。
abstract void | DealPermissionManager.removePermissionFromRole(DealerRole dealer) ロールからアクセス権を削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DealerRole (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.deal.role
クラス DealerRole

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole
すべての実装インタフェース:
Serializable
public class DealerRole
extends Object
implements Serializable

ロール毎取扱パーミッションの基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
DealerRole()
メソッドの概要
String | getCustomerCompanyCode() 取引先会社コードを取得します。
String | getCustomerDepartmentCode() 取引先組織コードを取得します。
String | getDealCode() 取扱コードを取得します。
String | getRoleId() ロールIDを取得します。
void | setCustomerCompanyCode(String customerCompanyCode) 取引先会社コードを設定します。
void | setCustomerDepartmentCode(String customerDepartmentCode) 取引先組織コードを設定します。
void | setDealCode(String dealCode) 取扱コードを設定します。
void | setRoleId(String roleId) ロールIDを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DealerRole

public DealerRole()
メソッドの詳細

getCustomerCompanyCode

public String getCustomerCompanyCode()
取引先会社コードを取得します。

戻り値:
取引先会社コード

setCustomerCompanyCode

public void setCustomerCompanyCode(String customerCompanyCode)
取引先会社コードを設定します。

パラメータ:
customerCompanyCode - 取引先会社コード

getCustomerDepartmentCode

public String getCustomerDepartmentCode()
取引先組織コードを取得します。

戻り値:
取引先組織コード

setCustomerDepartmentCode

public void setCustomerDepartmentCode(String customerDepartmentCode)
取引先組織コードを設定します。

パラメータ:
customerDepartmentCode - 取引先組織コード

getDealCode

public String getDealCode()
取扱コードを取得します。

戻り値:
取扱コード

setDealCode

public void setDealCode(String dealCode)
取扱コードを設定します。

パラメータ:
dealCode - 取扱コード

getRoleId

public String getRoleId()
ロールIDを取得します。

戻り値:
ロールID

setRoleId

public void setRoleId(String roleId)
ロールIDを設定します。

パラメータ:
roleId - ロールID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.deal.role (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.deal.role
クラス
DealerRole


jp.co.intra_mart.foundation.datastore.application.domain.deal.role (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.role

取扱ロール権限情報を操作するクラスを提供します。

参照:
説明

クラスの概要
DealerRole ロール毎取扱パーミッションの基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.role の説明

取扱ロール権限情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.deal.role クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.role の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.role の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal.role の使用

jp.co.intra_mart.foundation.datastore.application.domain.deal.role を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal により使用される jp.co.intra_mart.foundation.datastore.application.domain.deal.role のクラス
DealerRole
ロール毎取扱パーミッションの基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DealManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.deal
クラス DealManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager
public abstract class DealManager
extends Object

取扱に関する情報を管理します。

導入されたバージョン:
5.1

コンストラクタの概要
DealManager()
メソッドの概要
abstract void | addDeal(Deal deal) 取扱情報を新規登録します。
abstract void | deleteDeal(Deal deal) 取扱情報を削除します。
abstract Deal | getDeal(String customerCompanyCode, String customerDepartmentCode, String dealCode) 指定された取扱情報を返します。
static DealManager | getDealManager(String user, String group) DealManagerを取得します。
abstract Deal[] | getDeals() 現在、存在する取扱情報を返します。
abstract Deal[] | getDeals(Date date) 指定された日付に存在する取扱情報を返します。
abstract Deal[] | getDealsByKey(String itemCode, String companyCode, String departmentCode) 現在、存在する取扱情報の中で、商品と取引先から特定されるものを返します。
abstract Deal[] | getDealsByKey(String itemCode, String companyCode, String departmentCode, Date date) 指定された日時に存在する取扱情報の中で、商品と取引先から特定されるものを返します。
abstract Deal[] | getUsersDeals(String userCode) 現在、ユーザがアクセスできる取扱情報を返します。
abstract Deal[] | getUsersDeals(String userCode, Date date) 指定された日付にユーザがアクセスできる取扱情報を返します。
abstract Deal[] | getUsersDealsByKey(String userCode, String itemCode, String companyCode, String departmentCode) 現在、存在する取扱情報の中で、商品と取引先から特定されるものを返します。
abstract Deal[] | getUsersDealsByKey(String userCode, String itemCode, String companyCode, String departmentCode, Date date) 指定された日時に存在する取扱情報の中で、商品と取引先から特定されるものを返します。
protected abstract void | init(String user, String group) DealManagerを初期化します。
abstract void | updateDeal(Deal deal) 取扱情報を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DealManager

public DealManager()
メソッドの詳細

getDealManager

public static DealManager getDealManager(String user,
                                         String group)
                                  throws ManagerException
DealManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するDealManager
例外:
ManagerException - DealManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
DealManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - 初期化に失敗

addDeal

public abstract void addDeal(Deal deal)
                      throws ManagerException
取扱情報を新規登録します。

パラメータ:
deal - 取扱情報
例外:
ManagerException - 取扱情報の登録に失敗した場合

updateDeal

public abstract void updateDeal(Deal deal)
                         throws ManagerException
取扱情報を更新します。

パラメータ:
deal - 取扱情報
例外:
ManagerException - 取扱情報の更新に失敗した場合

deleteDeal

public abstract void deleteDeal(Deal deal)
                         throws ManagerException
取扱情報を削除します。
指定された取扱情報が存在しない場合は ManagerException がスローされます。

パラメータ:
deal - 取扱情報
例外:
ManagerException - 取扱情報の削除に失敗した場合

getDeal

public abstract Deal getDeal(String customerCompanyCode,
                             String customerDepartmentCode,
                             String dealCode)
指定された取扱情報を返します。

戻り値:
取扱情報
例外:
ManagerException - 取扱情報の取得に失敗した場合

getDeals

public abstract Deal[] getDeals()
                         throws ManagerException
現在、存在する取扱情報を返します。

戻り値:
取扱情報
例外:
ManagerException - 取扱情報の取得に失敗した場合

getDeals

public abstract Deal[] getDeals(Date date)
                         throws ManagerException
指定された日付に存在する取扱情報を返します。

パラメータ:
date - 日付
戻り値:
取扱情報
例外:
ManagerException - 取扱情報の取得に失敗した場合

getDealsByKey

public abstract Deal[] getDealsByKey(String itemCode,
                                     String companyCode,
                                     String departmentCode)
                              throws ManagerException
現在、存在する取扱情報の中で、商品と取引先から特定されるものを返します。

パラメータ:
itemCode - 商品コード
companyCode - 会社コード
departmentCode - 組織コード
戻り値:
取扱情報
例外:
ManagerException - 取扱情報の取得に失敗した場合

getDealsByKey

public abstract Deal[] getDealsByKey(String itemCode,
                                     String companyCode,
                                     String departmentCode,
                                     Date date)
                              throws ManagerException
指定された日時に存在する取扱情報の中で、商品と取引先から特定されるものを返します。

パラメータ:
itemCode - 商品コード
companyCode - 会社コード
departmentCode - 組織コード
date - 日付
戻り値:
取扱情報
例外:
ManagerException - 取扱情報の取得に失敗した場合

getUsersDeals

public abstract Deal[] getUsersDeals(String userCode)
                              throws ManagerException
現在、ユーザがアクセスできる取扱情報を返します。

パラメータ:
userCode - ユーザコード
戻り値:
取扱情報
例外:
ManagerException - 取扱情報の取得に失敗した場合

getUsersDeals

public abstract Deal[] getUsersDeals(String userCode,
                                     Date date)
                              throws ManagerException
指定された日付にユーザがアクセスできる取扱情報を返します。

パラメータ:
userCode - ユーザコード
date - 日付
戻り値:
取扱情報
例外:
ManagerException - 取扱情報の取得に失敗した場合

getUsersDealsByKey

public abstract Deal[] getUsersDealsByKey(String userCode,
                                          String itemCode,
                                          String companyCode,
                                          String departmentCode)
                                   throws ManagerException
現在、存在する取扱情報の中で、商品と取引先から特定されるものを返します。

パラメータ:
userCode - ユーザコード
itemCode - 商品コード
companyCode - 会社コード
departmentCode - 組織コード
戻り値:
取扱情報
例外:
ManagerException - 取扱情報の取得に失敗した場合

getUsersDealsByKey

public abstract Deal[] getUsersDealsByKey(String userCode,
                                          String itemCode,
                                          String companyCode,
                                          String departmentCode,
                                          Date date)
                                   throws ManagerException
指定された日時に存在する取扱情報の中で、商品と取引先から特定されるものを返します。

パラメータ:
userCode - ユーザコード
itemCode - 商品コード
companyCode - 会社コード
departmentCode - 組織コード
date - 日付
戻り値:
取扱情報
例外:
ManagerException - 取扱情報の取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DealPermissionManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.deal
クラス DealPermissionManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager
public abstract class DealPermissionManager
extends Object

取扱情報に対するアクセス権を操作します。

導入されたバージョン:
5.1

コンストラクタの概要
DealPermissionManager()
メソッドの概要
static DealPermissionManager | getDealPermissionManager(String user, String group) DealPermissionManagerを取得します。
abstract Department[] | getDepartments(Deal deal) 取扱情報を保有するアクセス権をもつ組織を返します。
abstract PublicGroup[] | getPublicGroups(Deal deal) 取扱情報を保有するアクセス権をもつパブリックグループを返します。
abstract Role[] | getRoles(Deal deal) 取扱情報を保有するアクセス権をもつロールを返します。
protected abstract void | init(String user, String group) DealPermissionManagerを初期化します。
abstract void | removePermissionFromDepartment(DealerDepartment dealer) 組織からアクセス権を削除します。
abstract void | removePermissionFromPublicGroup(DealerPublicGroup dealer) パブリックグループからアクセス権を削除します。
abstract void | removePermissionFromRole(DealerRole dealer) ロールからアクセス権を削除します。
abstract void | setPermissionToDepartment(DealerDepartment dealer) 組織に対してアクセス権を設定します。
abstract void | setPermissionToPublicGroup(DealerPublicGroup dealer) パブリックグループに対してアクセス権を設定します。
abstract void | setPermissionToRole(DealerRole dealer) ロールに対してアクセス権を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DealPermissionManager

public DealPermissionManager()
メソッドの詳細

getDealPermissionManager

public static DealPermissionManager getDealPermissionManager(String user,
                                                             String group)
                                                      throws ManagerException
DealPermissionManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するDealPermissionManager
例外:
ManagerException - DealPermissionManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
DealPermissionManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - 初期化に失敗

setPermissionToDepartment

public abstract void setPermissionToDepartment(DealerDepartment dealer)
                                        throws ManagerException
組織に対してアクセス権を設定します。

パラメータ:
dealer - 組織アクセス権設定情報
例外:
ManagerException - アクセス権の設定に失敗した場合

setPermissionToPublicGroup

public abstract void setPermissionToPublicGroup(DealerPublicGroup dealer)
                                         throws ManagerException
パブリックグループに対してアクセス権を設定します。

パラメータ:
dealer - パブリックグループアクセス権設定情報
例外:
ManagerException - アクセス権の設定に失敗した場合

setPermissionToRole

public abstract void setPermissionToRole(DealerRole dealer)
                                  throws ManagerException
ロールに対してアクセス権を設定します。

パラメータ:
dealer - ロールアクセス権設定情報
例外:
ManagerException - アクセス権の設定に失敗した場合

removePermissionFromDepartment

public abstract void removePermissionFromDepartment(DealerDepartment dealer)
                                             throws ManagerException
組織からアクセス権を削除します。
指定されたアクセス権が存在しない場合は ManagerException がスローされます。

パラメータ:
dealer - 組織アクセス件設定情報
例外:
ManagerException - アクセス権の削除に失敗した場合

removePermissionFromPublicGroup

public abstract void removePermissionFromPublicGroup(DealerPublicGroup dealer)
                                              throws ManagerException
パブリックグループからアクセス権を削除します。
指定されたアクセス権が存在しない場合は ManagerException がスローされます。

パラメータ:
dealer - パブリックグループアクセス権設定情報
例外:
ManagerException - アクセス権の削除に失敗した場合

removePermissionFromRole

public abstract void removePermissionFromRole(DealerRole dealer)
                                       throws ManagerException
ロールからアクセス権を削除します。
指定されたアクセス権が存在しない場合は ManagerException がスローされます。

パラメータ:
dealer - ロールアクセス権設定情報
例外:
ManagerException - アクセス権の削除に失敗した場合

getDepartments

public abstract Department[] getDepartments(Deal deal)
                                     throws ManagerException
取扱情報を保有するアクセス権をもつ組織を返します。

パラメータ:
deal - 取扱情報
戻り値:
組織情報
例外:
ManagerException - 組織情報の取得に失敗した場合

getPublicGroups

public abstract PublicGroup[] getPublicGroups(Deal deal)
                                       throws ManagerException
取扱情報を保有するアクセス権をもつパブリックグループを返します。

パラメータ:
deal - 取扱情報
戻り値:
パブリックグループ情報
例外:
ManagerException - パブリックグループ情報の取得に失敗した場合

getRoles

public abstract Role[] getRoles(Deal deal)
                         throws ManagerException
取扱情報を保有するアクセス権をもつロールを返します。

パラメータ:
deal - 取扱情報
戻り値:
ロール情報
例外:
ManagerException - ロール情報の取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.deal (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.deal
クラス
DealManager
DealPermissionManager


jp.co.intra_mart.foundation.datastore.application.domain.deal (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal

取扱情報を操作するクラスを提供します。

参照:
説明

クラスの概要
DealManager | 取扱に関する情報を管理します。
DealPermissionManager | 取扱情報に対するアクセス権を操作します。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal の説明

取扱情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.deal クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal の使用

jp.co.intra_mart.foundation.datastore.application.domain.deal を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal により使用される jp.co.intra_mart.foundation.datastore.application.domain.deal のクラス
DealManager
取扱に関する情報を管理します。
DealPermissionManager
取扱情報に対するアクセス権を操作します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute の使用

ItemAttribute を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item 商品情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item での ItemAttribute の使用

ItemAttribute を返す jp.co.intra_mart.foundation.datastore.application.domain.item のメソッド
abstract  ItemAttribute[] ItemManager.getAttributes(String itemCode)
指定された商品の属性情報を取得します。

ItemAttribute 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item のメソッド
abstract void | ItemManager.setAttribute(ItemAttribute attribute) 商品属性情報を設定します。
abstract void | ItemManager.removeAttribute(ItemAttribute attribute) 指定された商品属性情報を削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttributeInternational の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttributeInternational の使用

ItemAttributeInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item.attribute 商品属性情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item.attribute での ItemAttributeInternational の使用

ItemAttributeInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.item.attribute のメソッド
 ItemAttributeInternational ItemAttribute.getItemAttributeInternational(Locale locale)
指定された言語に対する国際化情報を取得します。

ItemAttributeInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item.attribute のメソッド
 void ItemAttribute.putInternational(Locale locale, ItemAttributeInternational data)
指定された言語に対する国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemAttribute (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item.attribute
クラス ItemAttribute

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute
すべての実装インタフェース:
Serializable
public class ItemAttribute
extends Object
implements Serializable

商品属性の基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemAttribute()
商品属性に関連する情報を新規に生成します。
ItemAttribute(Locale locale)
商品属性に関連する情報を新規に生成します。
メソッドの概要
Locale | getDefaultLocale() デフォルトのロケールを取得します。
ItemAttributeInternational | getItemAttributeInternational(Locale locale) 指定された言語に対する国際化情報を取得します。
String | getItemCode() 商品コードを取得します。
Locale[] | getLocales() この商品属性で管理している言語（ロケール）をすべて取得します。
double | getNumberValue() 属性数値を取得します。
String | getStringValue() 属性文字列を取得します。
String | getStringValue(Locale locale) 属性文字列を取得します。
String | getTemplateCode() テンプレートコードを取得します。
String | getTemplateDetailCode() テンプレート明細コードを取得します。
void | putInternational(Locale locale, ItemAttributeInternational data) 指定された言語に対する国際化情報を設定します。
void | removeInternational(Locale locale) 指定された言語に対する国際化情報を削除します。
void | setDefaultLocale(Locale defaultLocale) デフォルトのロケールを設定します。
void | setItemCode(String itemCode) 商品コードを設定します。
void | setNumberValue(double numberValue) 属性数値を設定します。
void | setTemplateCode(String templateCode) テンプレートコードを設定します。
void | setTemplateDetailCode(String templateDetailCode) テンプレート明細コードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemAttribute

public ItemAttribute()
商品属性に関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値の言語だけのロケールが割り当てられます。

ItemAttribute

public ItemAttribute(Locale locale)
商品属性に関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられます。

パラメータ:
locale - デフォルトの言語
メソッドの詳細

getDefaultLocale

public Locale getDefaultLocale()
デフォルトのロケールを取得します。

戻り値:
デフォルトのロケール

setDefaultLocale

public void setDefaultLocale(Locale defaultLocale)
デフォルトのロケールを設定します。

パラメータ:
defaultLocale - デフォルトのロケール

getLocales

public Locale[] getLocales()
この商品属性で管理している言語（ロケール）をすべて取得します。

戻り値:
この商品属性で管理している言語（ロケール）

getItemAttributeInternational

public ItemAttributeInternational getItemAttributeInternational(Locale locale)
指定された言語に対する国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
国際化情報

putInternational

public void putInternational(Locale locale,
                             ItemAttributeInternational data)
指定された言語に対する国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 国際化情報

removeInternational

public void removeInternational(Locale locale)
指定された言語に対する国際化情報を削除します。

パラメータ:
locale - 言語（ロケール）

getItemCode

public String getItemCode()
商品コードを取得します。

戻り値:
商品コード

setItemCode

public void setItemCode(String itemCode)
商品コードを設定します。

パラメータ:
itemCode - 商品コード

getTemplateCode

public String getTemplateCode()
テンプレートコードを取得します。

戻り値:
テンプレートコード

setTemplateCode

public void setTemplateCode(String templateCode)
テンプレートコードを設定します。

パラメータ:
templateCode - テンプレートコード

getTemplateDetailCode

public String getTemplateDetailCode()
テンプレート明細コードを取得します。

戻り値:
テンプレート明細コード

setTemplateDetailCode

public void setTemplateDetailCode(String templateDetailCode)
テンプレート明細コードを設定します。

パラメータ:
templateDetailCode - テンプレート明細コード

getNumberValue

public double getNumberValue()
属性数値を取得します。

戻り値:
属性数値

setNumberValue

public void setNumberValue(double numberValue)
属性数値を設定します。

パラメータ:
numberValue - 属性数値

getStringValue

public String getStringValue()
属性文字列を取得します。

戻り値:
属性文字列

getStringValue

public String getStringValue(Locale locale)
属性文字列を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
属性文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemAttributeInternational (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item.attribute
クラス ItemAttributeInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttributeInternational
すべての実装インタフェース:
Serializable
public class ItemAttributeInternational
extends Object
implements Serializable

商品属性の国際化属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemAttributeInternational()
メソッドの概要
String | getStringValue() 属性文字列を取得します。
void | setStringValue(String stringValue) 属性文字列を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemAttributeInternational

public ItemAttributeInternational()
メソッドの詳細

getStringValue

public String getStringValue()
属性文字列を取得します。

戻り値:
属性文字列
例外:
AccessorException - データの取得に失敗した場合

setStringValue

public void setStringValue(String stringValue)
属性文字列を設定します。

パラメータ:
stringValue - 属性文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.item.attribute (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.item.attribute
クラス
ItemAttribute
ItemAttributeInternational


jp.co.intra_mart.foundation.datastore.application.domain.item.attribute (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.attribute

商品属性情報を操作するクラスを提供します。

参照:
説明

クラスの概要
ItemAttribute | 商品属性の基本属性のデータを取り扱います。
ItemAttributeInternational | 商品属性の国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.attribute の説明

商品属性情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.item.attribute クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.attribute の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttributeInternational (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.attribute の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item.attribute の使用

jp.co.intra_mart.foundation.datastore.application.domain.item.attribute を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item | 商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item.attribute | 商品属性情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item により使用される jp.co.intra_mart.foundation.datastore.application.domain.item.attribute のクラス
ItemAttribute
商品属性の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.item.attribute により使用される jp.co.intra_mart.foundation.datastore.application.domain.item.attribute のクラス
ItemAttributeInternational
商品属性の国際化属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue の使用

ItemCatalogue を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item 商品情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item での ItemCatalogue の使用

ItemCatalogue を返す jp.co.intra_mart.foundation.datastore.application.domain.item のメソッド
abstract ItemCatalogue | ItemManager.getCatalogue(String itemCode, String catalogueCode) 指定されたカタログ情報を返します。
abstract ItemCatalogue[] | ItemManager.getCatalogues(String itemCode) 指定された商品のカタログ情報を返します。

ItemCatalogue 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item のメソッド
abstract void | ItemManager.setCatalogue(ItemCatalogue catalogue) 商品カタログ情報を設定します。
abstract void | ItemManager.setCatalogue(ItemCatalogue catalogue, byte[] byteStream) 商品カタログ情報を設定します。
abstract void | ItemManager.deleteCatalogue(ItemCatalogue catalogue) 商品カタログ情報を削除します。
abstract String | ItemManager.getCatalogueMediaFileName(ItemCatalogue catalogue) 商品カタログの媒体が保存されてるファイルパスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemCatalogue (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue
クラス ItemCatalogue

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue
すべての実装インタフェース:
Serializable
public class ItemCatalogue
extends Object
implements Serializable

商品カタログの基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemCatalogue()
メソッドの概要
String | getItemCatalogueCode() 商品カタログコードを取得します。
String | getItemCode() 商品コードを取得します。
String | getMedia() 媒体を取得します。
int | getMediaCls() 媒体種類を取得します。
String | getNotes() 備考を取得します。
int | getSortKey() ソートキーを取得します。
void | setItemCatalogueCode(String itemCatalogueCode) 商品カタログコードを設定します。
void | setItemCode(String itemCode) 商品コードを設定します。
void | setMedia(String media) 媒体を設定します。
void | setMediaCls(int mediaCls) 媒体種類を設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemCatalogue

public ItemCatalogue()
メソッドの詳細

getItemCode

public String getItemCode()
商品コードを取得します。

戻り値:
商品コード

setItemCode

public void setItemCode(String itemCode)
商品コードを設定します。

パラメータ:
itemCode - 商品コード

getItemCatalogueCode

public String getItemCatalogueCode()
商品カタログコードを取得します。

戻り値:
商品カタログコード

setItemCatalogueCode

public void setItemCatalogueCode(String itemCatalogueCode)
商品カタログコードを設定します。

パラメータ:
itemCatalogueCode - 商品カタログコード

getMediaCls

public int getMediaCls()
媒体種類を取得します。

戻り値:
媒体種類

setMediaCls

public void setMediaCls(int mediaCls)
媒体種類を設定します。

パラメータ:
mediaCls - 媒体種類

getMedia

public String getMedia()
媒体を取得します。

戻り値:
媒体

setMedia

public void setMedia(String media)
媒体を設定します。

パラメータ:
media - 媒体

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue
クラス
ItemCatalogue


jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue

商品カタログ情報を操作するクラスを提供します。

参照:
説明

クラスの概要
ItemCatalogue 商品カタログの基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue の説明

商品カタログ情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue の使用

jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item 商品情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item により使用される jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue のクラス
ItemCatalogue
商品カタログの基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.item.ItemCatalogueMediaManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.item.ItemCatalogueMediaManager の使用

ItemCatalogueMediaManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item 商品情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item での ItemCatalogueMediaManager の使用

ItemCatalogueMediaManager 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item のメソッド
abstract  void ItemManager.setItemCatalogueMediaManager(ItemCatalogueMediaManager catalogueMediaManager)
商品カタログの媒体のマネジャーを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.item.ItemImporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.item.ItemImporter の使用

ItemImporter を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item 商品情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item での ItemImporter の使用

ItemImporter を実装している jp.co.intra_mart.foundation.datastore.application.domain.item のクラス
 class StandardItemImporter
商品のインポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager の使用

ItemManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item 商品情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item での ItemManager の使用

ItemManager を返す jp.co.intra_mart.foundation.datastore.application.domain.item のメソッド
static ItemManager ItemManager.getItemManager(String user, String group)
ItemManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item.StandardItemImporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item.StandardItemImporter の使用

jp.co.intra_mart.foundation.datastore.application.domain.item.StandardItemImporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item の使用

Item を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item | 商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category | 商品カテゴリ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item での Item の使用

Item を返す jp.co.intra_mart.foundation.datastore.application.domain.item のメソッド
abstract Item[] | ItemManager.getItems() 現在、存在する商品の情報を返します。
abstract Item[] | ItemManager.getItems(Date date) 指定された日付に存在する商品の情報を返します。
abstract Item | ItemManager.getItem(String itemCode) 指定された商品コードに対する商品の情報を返します。
abstract Item[] | ItemManager.getItemsByKey(String code, String name) 現在、条件に合致する商品の情報を返します。
abstract Item[] | ItemManager.getItemsByKey(String code, String name, Date date) 指定された日付に条件に合致する商品の情報を返します。

Item 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item のメソッド
abstract void | ItemManager.addItem(Item item) 商品情報を新規登録します。
abstract void | ItemManager.updateItem(Item item) 商品情報を更新します。
abstract void | ItemManager.deleteItem(Item item) 商品情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.item_category での Item の使用

Item を返す jp.co.intra_mart.foundation.datastore.application.domain.item_category のメソッド
abstract Item[] | ItemCategoryManager.getCategorizedItems(String categoryTypeCode, String categoryCode) 商品カテゴリに分類されている商品の情報を返します。
abstract Item[] | ItemCategoryManager.getAllCategorizedItems(String categoryTypeCode, String categoryCode) 商品カテゴリに分類されているすべての商品の情報を返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable の使用

ItemTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item.item 商品情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item.item での ItemTerminable の使用

ItemTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.item.item のメソッド
ItemTerminable | Item.getItemTerminable(Term term) 指定された期間に対する期間化情報を取得します。
ItemTerminable | Item.getItemTerminable(Date date) 指定された日時に対する期間化情報を取得します。

ItemTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item.item のメソッド
 void Item.putItemTerminable(Term term, ItemTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminableInternational の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminableInternational の使用

ItemTerminableInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item.item 商品情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item.item での ItemTerminableInternational の使用

ItemTerminableInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.item.item のメソッド
 ItemTerminableInternational ItemTerminable.getItemTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。

ItemTerminableInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item.item のメソッド
 void ItemTerminable.putItemTerminableInternational(Locale locale, ItemTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Item (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item.item
クラス Item

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item
すべての実装インタフェース:
Serializable
public class Item
extends Object
implements Serializable

商品の基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
Item()
商品に関連する情報を新規に生成します。
Item(Date date)
商品に関連する情報を新規に生成します。
Item(Locale locale)
商品に関連する情報を新規に生成します。
Item(Locale locale, Date date)
商品に関連する情報を新規に生成します。
メソッドの概要
Date | getDefaultDate() デフォルトの日時を取得します。
Locale | getDefaultLocale() デフォルトのロケールを取得します。
String | getItemCaption() 商品通称を取得します。
String | getItemCaption(Date date) 商品通称を取得します。
String | getItemCaption(Date date, Locale locale) 商品通称を取得します。
String | getItemCaption(Locale locale) 商品通称を取得します。
String | getItemCode() 商品コードを取得します。
String | getItemName() 商品名を取得します。
String | getItemName(Date date) 商品名を取得します。
String | getItemName(Date date, Locale locale) 商品名を取得します。
String | getItemName(Locale locale) 商品名を取得します。
ItemTerminable | getItemTerminable(Date date) 指定された日時に対する期間化情報を取得します。
ItemTerminable | getItemTerminable(Term term) 指定された期間に対する期間化情報を取得します。
String | getNotes() 備考を取得します。
String | getProductModelCode() 製品型番を取得します。
double | getPurchaseUnitPrice() 仕入単価を取得します。
double | getPurchaseUnitPrice(Date date) 仕入単価を取得します。
double | getSalesUnitPrice() 販売単価を取得します。
double | getSalesUnitPrice(Date date) 販売単価を取得します。
Term[] | getTerms() この商品で管理している期間をすべて取得します。
void | putItemTerminable(Term term, ItemTerminable data) 指定された期間に対する期間化情報を設定します。
void | removeItemTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setDefaultLocale(Locale defaultLocale) デフォルトのロケールを設定します。
void | setItemCode(String itemCode) 商品コードを設定します。
void | setNotes(String notes) 備考を設定します。
void | setProductModelCode(String productModelCode) 製品型番を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Item

public Item()
商品に関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

Item

public Item(Locale locale)
商品に関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

パラメータ:
locale - デフォルトの言語

Item

public Item(Date date)
商品に関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時

Item

public Item(Locale locale,
            Date date)
商品に関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
locale - デフォルトの言語
date - デフォルトの日時
メソッドの詳細

getDefaultLocale

public Locale getDefaultLocale()
デフォルトのロケールを取得します。

戻り値:
デフォルトのロケール

setDefaultLocale

public void setDefaultLocale(Locale defaultLocale)
デフォルトのロケールを設定します。

パラメータ:
defaultLocale - デフォルトのロケール

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
この商品で管理している期間をすべて取得します。

戻り値:
この商品で管理している期間

getItemTerminable

public ItemTerminable getItemTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getItemTerminable

public ItemTerminable getItemTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putItemTerminable

public void putItemTerminable(Term term,
                              ItemTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removeItemTerminable

public void removeItemTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getItemCode

public String getItemCode()
商品コードを取得します。

戻り値:
商品コード

setItemCode

public void setItemCode(String itemCode)
商品コードを設定します。

パラメータ:
itemCode - 商品コード

getProductModelCode

public String getProductModelCode()
製品型番を取得します。

戻り値:
製品型番

setProductModelCode

public void setProductModelCode(String productModelCode)
製品型番を設定します。

パラメータ:
productModelCode - 製品型番

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSalesUnitPrice

public double getSalesUnitPrice()
販売単価を取得します。

戻り値:
販売単価

getSalesUnitPrice

public double getSalesUnitPrice(Date date)
販売単価を取得します。

パラメータ:
date - 日時
戻り値:
販売単価

getPurchaseUnitPrice

public double getPurchaseUnitPrice()
仕入単価を取得します。

戻り値:
仕入単価

getPurchaseUnitPrice

public double getPurchaseUnitPrice(Date date)
仕入単価を取得します。

パラメータ:
date - 日時
戻り値:
仕入単価

getItemName

public String getItemName()
商品名を取得します。

戻り値:
商品名

getItemName

public String getItemName(Date date)
商品名を取得します。

パラメータ:
date - 日時
戻り値:
商品名

getItemName

public String getItemName(Locale locale)
商品名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
商品名

getItemName

public String getItemName(Date date,
                          Locale locale)
商品名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
商品名

getItemCaption

public String getItemCaption()
商品通称を取得します。

戻り値:
商品通称

getItemCaption

public String getItemCaption(Date date)
商品通称を取得します。

パラメータ:
date - 日時
戻り値:
商品通称

getItemCaption

public String getItemCaption(Locale locale)
商品通称を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
商品通称

getItemCaption

public String getItemCaption(Date date,
                             Locale locale)
商品通称を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
商品通称
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemTerminable (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item.item
クラス ItemTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable
すべての実装インタフェース:
Serializable
public class ItemTerminable
extends Object
implements Serializable

商品の期間化属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemTerminable()
メソッドの概要
ItemTerminableInternational | getItemTerminableInternational(Locale locale) 指定された言語に対する期間国際化情報を取得します。
Locale[] | getLocales() この商品で管理している言語（ロケール）をすべて取得します。
double | getPurchaseUnitPrice() 仕入単価を取得します。
double | getSalesUnitPrice() 販売単価を取得します。
void | putItemTerminableInternational(Locale locale, ItemTerminableInternational data) 指定された言語に対する期間国際化情報を設定します。
void | setPurchaseUnitPrice(double purchaseUnitPrice) 仕入単価を設定します。
void | setSalesUnitPrice(double salesUnitPrice) 販売単価を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemTerminable

public ItemTerminable()
メソッドの詳細

getLocales

public Locale[] getLocales()
この商品で管理している言語（ロケール）をすべて取得します。

戻り値:
この商品で管理している言語（ロケール）

getItemTerminableInternational

public ItemTerminableInternational getItemTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
期間国際化情報

putItemTerminableInternational

public void putItemTerminableInternational(Locale locale,
                                           ItemTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 期間国際化情報

getSalesUnitPrice

public double getSalesUnitPrice()
販売単価を取得します。

戻り値:
販売単価

setSalesUnitPrice

public void setSalesUnitPrice(double salesUnitPrice)
販売単価を設定します。

パラメータ:
salesUnitPrice - 販売単価

getPurchaseUnitPrice

public double getPurchaseUnitPrice()
仕入単価を取得します。

戻り値:
仕入単価

setPurchaseUnitPrice

public void setPurchaseUnitPrice(double purchaseUnitPrice)
仕入単価を設定します。

パラメータ:
purchaseUnitPrice - 仕入単価
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ItemTerminableInternational (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item.item
クラス ItemTerminableInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminableInternational
すべての実装インタフェース:
Serializable
public class ItemTerminableInternational
extends Object
implements Serializable

商品の期間国際化属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemTerminableInternational()
メソッドの概要
String | getItemCaption() 商品通称を取得します。
String | getItemName() 商品名を取得します。
void | setItemCaption(String itemCaption) 商品通称を設定します。
void | setItemName(String itemName) 商品名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemTerminableInternational

public ItemTerminableInternational()
メソッドの詳細

getItemName

public String getItemName()
商品名を取得します。

戻り値:
商品名
例外:
AccessorException - データの取得に失敗した場合

setItemName

public void setItemName(String itemName)
商品名を設定します。

パラメータ:
itemName - 商品名

getItemCaption

public String getItemCaption()
商品通称を取得します。

戻り値:
商品通称
例外:
AccessorException - データの取得に失敗した場合

setItemCaption

public void setItemCaption(String itemCaption)
商品通称を設定します。

パラメータ:
itemCaption - 商品通称
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.item.item (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.item.item
クラス
Item
ItemTerminable
ItemTerminableInternational


jp.co.intra_mart.foundation.datastore.application.domain.item.item (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.item

商品情報を操作するクラスを提供します。

参照:
説明

クラスの概要
Item | 商品の基本属性のデータを取り扱います。
ItemTerminable | 商品の期間化属性のデータを取り扱います。
ItemTerminableInternational | 商品の期間国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.item の説明

商品情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.item.item クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.item の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminableInternational (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.item の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item.item の使用

jp.co.intra_mart.foundation.datastore.application.domain.item.item を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item | 商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item.item | 商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category | 商品カテゴリ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item により使用される jp.co.intra_mart.foundation.datastore.application.domain.item.item のクラス
Item
商品の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.item.item により使用される jp.co.intra_mart.foundation.datastore.application.domain.item.item のクラス
ItemTerminable
商品の期間化属性のデータを取り扱います。
ItemTerminableInternational
商品の期間国際化属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.item_category により使用される jp.co.intra_mart.foundation.datastore.application.domain.item.item のクラス
Item
商品の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemCatalogueMediaManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item
インタフェース ItemCatalogueMediaManager

public interface ItemCatalogueMediaManager

商品カタログの媒体情報を管理するクラスです。

導入されたバージョン:
5.1

メソッドの概要
void | delete(String filePath) 商品カタログの媒体情報を削除します。
void | save(String filePath, byte[] byteString) 商品カタログの媒体情報を保存します。

メソッドの詳細

save

public void save(String filePath,
                 byte[] byteString)
          throws ManagerException
商品カタログの媒体情報を保存します。

パラメータ:
filePath - 媒体情報を保存するファイルパス
byteString - 媒体情報のバイト配列
例外:
ManagerException - 媒体情報の保存に失敗した場合

delete

public void delete(String filePath)
            throws ManagerException
商品カタログの媒体情報を削除します。

指定されたファイルが存在しないときは、何もしません。

パラメータ:
filePath - 削除する媒体のファイルのパス
例外:
ManagerException - 媒体情報の削除に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemImporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item
インタフェース ItemImporter

既知の実装クラスの一覧:
StandardItemImporter
public interface ItemImporter

商品のインポートのインターフェースです。

導入されたバージョン:
5.1

メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。

メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item
クラス ItemManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager
public abstract class ItemManager
extends Object

商品に関する情報を管理します。 このクラスのインスタンスは必ず getItemManager(String, String) で取得してください。

導入されたバージョン:
5.1

コンストラクタの概要
ItemManager()
メソッドの概要
abstract void | addItem(Item item) 商品情報を新規登録します。
abstract void | deleteCatalogue(ItemCatalogue catalogue) 商品カタログ情報を削除します。
abstract void | deleteItem(Item item) 商品情報を削除します。
abstract ItemAttribute[] | getAttributes(String itemCode) 指定された商品の属性情報を取得します。
abstract ItemCatalogue | getCatalogue(String itemCode, String catalogueCode) 指定されたカタログ情報を返します。
abstract String | getCatalogueMediaFileName(ItemCatalogue catalogue) 商品カタログの媒体が保存されてるファイルパスを取得します。
abstract ItemCatalogue[] | getCatalogues(String itemCode) 指定された商品のカタログ情報を返します。
abstract Item | getItem(String itemCode) 指定された商品コードに対する商品の情報を返します。
static ItemManager | getItemManager(String user, String group) ItemManagerを取得します。
abstract Item[] | getItems() 現在、存在する商品の情報を返します。
abstract Item[] | getItems(Date date) 指定された日付に存在する商品の情報を返します。
abstract Item[] | getItemsByKey(String code, String name) 現在、条件に合致する商品の情報を返します。
abstract Item[] | getItemsByKey(String code, String name, Date date) 指定された日付に条件に合致する商品の情報を返します。
protected abstract void | init(String user, String group) ItemManagerを初期化します。
abstract void | removeAttribute(ItemAttribute attribute) 指定された商品属性情報を削除します。
abstract void | setAttribute(ItemAttribute attribute) 商品属性情報を設定します。
abstract void | setCatalogue(ItemCatalogue catalogue) 商品カタログ情報を設定します。
abstract void | setCatalogue(ItemCatalogue catalogue, byte[] byteStream) 商品カタログ情報を設定します。
abstract void | setItemCatalogueMediaManager(ItemCatalogueMediaManager catalogueMediaManager) 商品カタログの媒体のマネジャーを設定します。
abstract void | updateItem(Item item) 商品情報を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemManager

public ItemManager()
メソッドの詳細

getItemManager

public static ItemManager getItemManager(String user,
                                         String group)
                                  throws ManagerException
ItemManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するItemManager
例外:
ManagerException - ItemManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
ItemManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - 初期化に失敗

addItem

public abstract void addItem(Item item)
                      throws ManagerException
商品情報を新規登録します。
商品情報には、期間情報と期間国際化情報を設定してください。
もし設定されてないものがある場合は、 ManagerException をスローします。

商品の期間は、途切れることができません。
期間に途切れがある場合は、 ManagerException をスローします。

パラメータ:
item - 商品情報
例外:
ManagerException - 商品情報の登録に失敗した場合

updateItem

public abstract void updateItem(Item item)
                         throws ManagerException
商品情報を更新します。
商品情報には、期間情報と期間国際化情報を設定してください。
もし設定されてないものがある場合は、 ManagerException をスローします。

商品の期間は、途切れることができません。
期間に途切れがある場合は、 ManagerException をスローします。

パラメータ:
item - 商品情報
例外:
ManagerException - 商品情報の更新に失敗した場合

deleteItem

public abstract void deleteItem(Item item)
                         throws ManagerException
商品情報を削除します。
指定された商品情報が存在しない場合は ManagerException がスローされます。

パラメータ:
item - 商品情報
例外:
ManagerException - 商品情報の削除に失敗した場合

setCatalogue

public abstract void setCatalogue(ItemCatalogue catalogue)
                           throws ManagerException
商品カタログ情報を設定します。

パラメータ:
catalogue - 商品カタログ情報
例外:
ManagerException - 商品カタログ情報の設定に失敗した場合

setCatalogue

public abstract void setCatalogue(ItemCatalogue catalogue,
                                  byte[] byteStream)
                           throws ManagerException
商品カタログ情報を設定します。 ItemCatalogue.getMediaCls() の値が "file" の時に、バイト配列を ItemCatalogue.getMedia() をファイルに出力します。
バイト配列がnullの時は空のファイルを作成します。
媒体種類がURLの時は、バイトを配列を無視します。
媒体種類がファイルからURLに変更される時は、ストレージ上にあるファイルは削除されます。

パラメータ:
catalogue - 商品カタログ情報
byteStream - 出力するバイト配列
例外:
ManagerException - 商品カタログ情報の設定に失敗した場合

deleteCatalogue

public abstract void deleteCatalogue(ItemCatalogue catalogue)
                              throws ManagerException
商品カタログ情報を削除します。
指定されたカタログ情報が存在しない場合は ManagerException がスローされます。

パラメータ:
catalogue - 商品カタログ情報
例外:
ManagerException - 商品カタログ情報の削除に失敗した場合

getCatalogueMediaFileName

public abstract String getCatalogueMediaFileName(ItemCatalogue catalogue)
                                          throws ManagerException
商品カタログの媒体が保存されてるファイルパスを取得します。

商品カタログの媒体種類がファイルの時のみ有効です。
ファイルパスの区切りは'/'です。
媒体種類がファイル以外の時はnullを返します。

パラメータ:
catalogue - 商品カタログ
戻り値:
商品カタログの媒体が保存されているファイルパス
例外:
ManagerException - ファイルパスの取得に失敗した場合

setItemCatalogueMediaManager

public abstract void setItemCatalogueMediaManager(ItemCatalogueMediaManager catalogueMediaManager)
                                           throws ManagerException
商品カタログの媒体のマネジャーを設定します。

パラメータ:
catalogueMediaManager - 商品カタログの媒体マネジャー
例外:
ManagerException - 媒体の設定に失敗した場合

getItems

public abstract Item[] getItems()
                         throws ManagerException
現在、存在する商品の情報を返します。

指定された商品の情報が存在しない場合は、空の配列を返します。

戻り値:
商品情報
例外:
商品情報の取得に失敗した場合
ManagerException

getItems

public abstract Item[] getItems(Date date)
                         throws ManagerException
指定された日付に存在する商品の情報を返します。

指定された商品の情報が存在しない場合は、空の配列を返します。

パラメータ:
date - 日付
戻り値:
商品情報
例外:
商品情報の取得に失敗した場合
ManagerException

getItem

public abstract Item getItem(String itemCode)
                      throws ManagerException
指定された商品コードに対する商品の情報を返します。

パラメータ:
itemCode - 商品コード
戻り値:
商品情報
例外:
商品情報の取得に失敗した場合
ManagerException

getItemsByKey

public abstract Item[] getItemsByKey(String code,
                                     String name)
                              throws ManagerException
現在、条件に合致する商品の情報を返します。

検索キーは、コードは商品コード、製品型番に対して使用されます。名称は商品名、商品略称に対して使用されます。
指定された商品の情報が存在しない場合は、空の配列を返します。

パラメータ:
code - コードの検索キー
name - 名称の検索キー
戻り値:
商品情報
例外:
商品情報の取得に失敗した場合
ManagerException

getItemsByKey

public abstract Item[] getItemsByKey(String code,
                                     String name,
                                     Date date)
                              throws ManagerException
指定された日付に条件に合致する商品の情報を返します。

検索キーは、コードは商品コード、製品型番に対して使用されます。名称は商品名、商品略称に対して使用されます。
指定された商品の情報が存在しない場合は、空の配列を返します。

パラメータ:
code - コードの検索キー
name - 名称の検索キー
戻り値:
商品情報
例外:
商品情報の取得に失敗した場合
ManagerException

getCatalogue

public abstract ItemCatalogue getCatalogue(String itemCode,
                                           String catalogueCode)
                                    throws ManagerException
指定されたカタログ情報を返します。
カタログ情報が存在しない場合はnullを返します。

パラメータ:
itemCode - 商品コード
catalogueCode - カタログコード
戻り値:
カタログ情報
例外:
商品カタログ情報の取得に失敗した場合
ManagerException

getCatalogues

public abstract ItemCatalogue[] getCatalogues(String itemCode)
                                       throws ManagerException
指定された商品のカタログ情報を返します。
カタログ情報が見つからない場合は空の配列を返します。

パラメータ:
itemCode - 商品コード
戻り値:
カタログ情報
例外:
商品カタログ情報の取得に失敗した場合
ManagerException

setAttribute

public abstract void setAttribute(ItemAttribute attribute)
                           throws ManagerException
商品属性情報を設定します。

指定された商品属性情報が存在しない場合は新規登録します。商品属性情報すでに存在する場合は更新を行います。

このメソッドでは、複数の商品属性テンプレートの属性情報を設定することはできません。 もし登録済みのものとは異なる商品属性テンプレートの属性情報が指定された場合は、 ManagerException をスローします。

パラメータ:
attribute - 商品属性情報
例外:
商品属性情報の設定に失敗した場合
ManagerException

removeAttribute

public abstract void removeAttribute(ItemAttribute attribute)
                              throws ManagerException
指定された商品属性情報を削除します。
指定された属性情報が存在しない場合は ManagerException がスローされます。

パラメータ:
attribute - 商品属性情報
例外:
商品属性情報の削除に失敗した場合
ManagerException

getAttributes

public abstract ItemAttribute[] getAttributes(String itemCode)
                                       throws ManagerException
指定された商品の属性情報を取得します。

パラメータ:
itemCode - 商品コード
戻り値:
商品属性情報の一覧
例外:
商品属性情報の取得に失敗した場合
ManagerException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.item (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.item
インタフェース
ItemCatalogueMediaManager
ItemImporter
クラス
ItemManager
StandardItemImporter


jp.co.intra_mart.foundation.datastore.application.domain.item (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item

商品情報を操作するクラスを提供します。

参照:
説明

インタフェースの概要
ItemCatalogueMediaManager | 商品カタログの媒体情報を管理するクラスです。
ItemImporter | 商品のインポートのインターフェースです。

クラスの概要
ItemManager | 商品に関する情報を管理します。
StandardItemImporter | 商品のインポートを行います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item の説明

商品情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.item クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.StandardItemImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.item.ItemImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.application.domain.item.ItemCatalogueMediaManager
  • interface jp.co.intra_mart.foundation.datastore.application.domain.item.ItemImporter


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item の使用

jp.co.intra_mart.foundation.datastore.application.domain.item を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item 商品情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item により使用される jp.co.intra_mart.foundation.datastore.application.domain.item のクラス
ItemCatalogueMediaManager
商品カタログの媒体情報を管理するクラスです。
ItemImporter
商品のインポートのインターフェースです。
ItemManager
商品に関する情報を管理します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardItemImporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item
クラス StandardItemImporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item.StandardItemImporter
すべての実装インタフェース:
ItemImporter
public class StandardItemImporter
extends Object
implements ItemImporter

商品のインポートを行います。

導入されたバージョン:
5.1

コンストラクタの概要
StandardItemImporter()
メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardItemImporter

public StandardItemImporter()
メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

定義:
インタフェース ItemImporter 内の doImport
パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach の使用

ItemAttach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category 商品カテゴリ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_category での ItemAttach の使用

ItemAttach 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item_category のメソッド
abstract void | ItemCategoryManager.setItem(ItemAttach attach) 商品カテゴリに商品を設定します。
abstract void | ItemCategoryManager.removeItem(ItemAttach attach) 商品カテゴリから商品を外します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemAttach (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach
クラス ItemAttach

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach
すべての実装インタフェース:
Serializable
public class ItemAttach
extends Object
implements Serializable

商品分類の基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemAttach()
メソッドの概要
String | getItemCategoryCode() 商品カテゴリコードを取得します。
String | getItemCategoryTypeCode() 商品カテゴリ種別コードを取得します。
String | getItemCode() 商品コードを取得します。
void | setItemCategoryCode(String itemCategoryCode) 商品カテゴリコードを設定します。
void | setItemCategoryTypeCode(String itemCategoryTypeCode) 商品カテゴリ種別コードを設定します。
void | setItemCode(String itemCode) 商品コードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemAttach

public ItemAttach()
メソッドの詳細

getItemCategoryTypeCode

public String getItemCategoryTypeCode()
商品カテゴリ種別コードを取得します。

戻り値:
商品カテゴリ種別コード

setItemCategoryTypeCode

public void setItemCategoryTypeCode(String itemCategoryTypeCode)
商品カテゴリ種別コードを設定します。

パラメータ:
itemCategoryTypeCode - 商品カテゴリ種別コード

getItemCategoryCode

public String getItemCategoryCode()
商品カテゴリコードを取得します。

戻り値:
商品カテゴリコード

setItemCategoryCode

public void setItemCategoryCode(String itemCategoryCode)
商品カテゴリコードを設定します。

パラメータ:
itemCategoryCode - 商品カテゴリコード

getItemCode

public String getItemCode()
商品コードを取得します。

戻り値:
商品コード

setItemCode

public void setItemCode(String itemCode)
商品コードを設定します。

パラメータ:
itemCode - 商品コード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach
クラス
ItemAttach


jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach

商品分類情報を操作するクラスを提供します。

参照:
説明

クラスの概要
ItemAttach 商品分類の基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach の説明

商品分類情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach の使用

jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category 商品カテゴリ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_category により使用される jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach のクラス
ItemAttach
商品分類の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory の使用

ItemCategory を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category 商品カテゴリ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_category での ItemCategory の使用

ItemCategory を返す jp.co.intra_mart.foundation.datastore.application.domain.item_category のメソッド
ItemCategory | ItemCategoryStruct.getItemCateogry() 商品カテゴリを取得します。
abstract ItemCategory[] | ItemCategoryManager.getCategoryTypes() 登録済の商品カテゴリ種別の一覧を返します。
abstract ItemCategory | ItemCategoryManager.getCategory(String categoryTypeCode, String categoryCode) 指定されたカテゴリコードに対する商品カテゴリの情報を返します。

ItemCategory 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item_category のメソッド
abstract void | ItemCategoryManager.addCategory(ItemCategory category) 商品カテゴリを新規登録します。
abstract void | ItemCategoryManager.updateCategory(ItemCategory category) 商品カテゴリを更新します。
abstract void | ItemCategoryManager.deleteCategory(ItemCategory category) 商品カテゴリを削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategoryInternational の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategoryInternational の使用

ItemCategoryInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category.category 商品カテゴリ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_category.category での ItemCategoryInternational の使用

ItemCategoryInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.item_category.category のメソッド
 ItemCategoryInternational ItemCategory.getItemCategoryInternational(Locale locale)
指定された言語に対する国際化情報を取得します。

ItemCategoryInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item_category.category のメソッド
 void ItemCategory.putInternational(Locale locale, ItemCategoryInternational data)
指定された言語に対する国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemCategory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_category.category
クラス ItemCategory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory
すべての実装インタフェース:
Serializable
public class ItemCategory
extends Object
implements Serializable

商品カテゴリの基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemCategory()
商品カテゴリに関連する情報を新規に生成します。
ItemCategory(Locale locale)
商品カテゴリに関連する情報を新規に生成します。
メソッドの概要
Locale | getDefaultLocale() デフォルトのロケールを取得します。
String | getItemCategoryCode() 商品カテゴリコードを取得します。
ItemCategoryInternational | getItemCategoryInternational(Locale locale) 指定された言語に対する国際化情報を取得します。
String | getItemCategoryName() 商品カテゴリ名を取得します。
String | getItemCategoryName(Locale locale) 商品カテゴリ名を取得します。
String | getItemCategoryTypeCode() 商品カテゴリ種別コードを取得します。
Locale[] | getLocales() この商品カテゴリで管理している言語（ロケール）をすべて取得します。
String | getNotes() 備考を取得します。
String | getParentItemCategoryCode() 親商品カテゴリコードを取得します。
int | getSortKey() ソートキーを取得します。
void | putInternational(Locale locale, ItemCategoryInternational data) 指定された言語に対する国際化情報を設定します。
void | removeInternational(Locale locale) 指定された言語に対する国際化情報を削除します。
void | setDefaultLocale(Locale defaultLocale) デフォルトのロケールを設定します。
void | setItemCategoryCode(String itemCategoryCode) 商品カテゴリコードを設定します。
void | setItemCategoryTypeCode(String itemCategoryTypeCode) 商品カテゴリ種別コードを設定します。
void | setNotes(String notes) 備考を設定します。
void | setParentItemCategoryCode(String parentItemCategoryCode) 親商品カテゴリコードを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemCategory

public ItemCategory()
商品カテゴリに関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値の言語だけのロケールが割り当てられます。

ItemCategory

public ItemCategory(Locale locale)
商品カテゴリに関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられます。

パラメータ:
locale - デフォルトの言語
メソッドの詳細

getDefaultLocale

public Locale getDefaultLocale()
デフォルトのロケールを取得します。

戻り値:
デフォルトのロケール

setDefaultLocale

public void setDefaultLocale(Locale defaultLocale)
デフォルトのロケールを設定します。

パラメータ:
defaultLocale - デフォルトのロケール

getLocales

public Locale[] getLocales()
この商品カテゴリで管理している言語（ロケール）をすべて取得します。

戻り値:
この商品カテゴリで管理している言語（ロケール）

getItemCategoryInternational

public ItemCategoryInternational getItemCategoryInternational(Locale locale)
指定された言語に対する国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
国際化情報

putInternational

public void putInternational(Locale locale,
                             ItemCategoryInternational data)
指定された言語に対する国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 国際化情報

removeInternational

public void removeInternational(Locale locale)
指定された言語に対する国際化情報を削除します。

パラメータ:
locale - 言語（ロケール）

getItemCategoryTypeCode

public String getItemCategoryTypeCode()
商品カテゴリ種別コードを取得します。

戻り値:
商品カテゴリ種別コード

setItemCategoryTypeCode

public void setItemCategoryTypeCode(String itemCategoryTypeCode)
商品カテゴリ種別コードを設定します。

パラメータ:
itemCategoryTypeCode - 商品カテゴリ種別コード

getItemCategoryCode

public String getItemCategoryCode()
商品カテゴリコードを取得します。

戻り値:
商品カテゴリコード

setItemCategoryCode

public void setItemCategoryCode(String itemCategoryCode)
商品カテゴリコードを設定します。

パラメータ:
itemCategoryCode - 商品カテゴリコード

getParentItemCategoryCode

public String getParentItemCategoryCode()
親商品カテゴリコードを取得します。

戻り値:
親商品カテゴリコード

setParentItemCategoryCode

public void setParentItemCategoryCode(String parentItemCategoryCode)
親商品カテゴリコードを設定します。

パラメータ:
parentItemCategoryCode - 親商品カテゴリコード

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー

getItemCategoryName

public String getItemCategoryName()
商品カテゴリ名を取得します。

戻り値:
商品カテゴリ名

getItemCategoryName

public String getItemCategoryName(Locale locale)
商品カテゴリ名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
商品カテゴリ名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemCategoryInternational (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_category.category
クラス ItemCategoryInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategoryInternational
すべての実装インタフェース:
Serializable
public class ItemCategoryInternational
extends Object
implements Serializable

商品カテゴリの国際化属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemCategoryInternational()
メソッドの概要
String | getItemCategoryName() 商品カテゴリ名を取得します。
void | setItemCategoryName(String itemCategoryName) 商品カテゴリ名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemCategoryInternational

public ItemCategoryInternational()
メソッドの詳細

getItemCategoryName

public String getItemCategoryName()
商品カテゴリ名を取得します。

戻り値:
商品カテゴリ名
例外:
AccessorException - データの取得に失敗した場合

setItemCategoryName

public void setItemCategoryName(String itemCategoryName)
商品カテゴリ名を設定します。

パラメータ:
itemCategoryName - 商品カテゴリ名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.item_category.category (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.item_category.category
クラス
ItemCategory
ItemCategoryInternational


jp.co.intra_mart.foundation.datastore.application.domain.item_category.category (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.category

商品カテゴリ情報を操作するクラスを提供します。

参照:
説明

クラスの概要
ItemCategory | 商品カテゴリの基本属性のデータを取り扱います。
ItemCategoryInternational | 商品カテゴリの国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.category の説明

商品カテゴリ情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.item_category.category クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.category の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategoryInternational (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.category の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category.category の使用

jp.co.intra_mart.foundation.datastore.application.domain.item_category.category を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category | 商品カテゴリ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category.category | 商品カテゴリ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_category により使用される jp.co.intra_mart.foundation.datastore.application.domain.item_category.category のクラス
ItemCategory
商品カテゴリの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.item_category.category により使用される jp.co.intra_mart.foundation.datastore.application.domain.item_category.category のクラス
ItemCategoryInternational
商品カテゴリの国際化属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemAttachImporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemAttachImporter の使用

ItemAttachImporter を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category 商品カテゴリ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_category での ItemAttachImporter の使用

ItemAttachImporter を実装している jp.co.intra_mart.foundation.datastore.application.domain.item_category のクラス
 class StandardItemAttachImporter
商品分類のインポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryImporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryImporter の使用

ItemCategoryImporter を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category 商品カテゴリ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_category での ItemCategoryImporter の使用

ItemCategoryImporter を実装している jp.co.intra_mart.foundation.datastore.application.domain.item_category のクラス
 class StandardItemCategoryImporter
商品カテゴリのインポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager の使用

ItemCategoryManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category 商品カテゴリ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_category での ItemCategoryManager の使用

ItemCategoryManager を返す jp.co.intra_mart.foundation.datastore.application.domain.item_category のメソッド
static ItemCategoryManager ItemCategoryManager.getItemCategoryManager(String user, String group)
ItemCategoryManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryStruct の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryStruct の使用

ItemCategoryStruct を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category 商品カテゴリ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_category での ItemCategoryStruct の使用

ItemCategoryStruct を返す jp.co.intra_mart.foundation.datastore.application.domain.item_category のメソッド
ItemCategoryStruct[] | ItemCategoryStruct.getChildren() このカテゴリ構成の子供の構成を取得します。
abstract ItemCategoryStruct | ItemCategoryManager.getCategoryStruct(String categoryTypeCode) 指定された商品カテゴリ種別のカテゴリ階層を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemAttachImporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemAttachImporter の使用

jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemAttachImporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemCategoryImporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemCategoryImporter の使用

jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemCategoryImporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_category.type.ItemCategoryType の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_category.type.ItemCategoryType の使用

jp.co.intra_mart.foundation.datastore.application.domain.item_category.type.ItemCategoryType はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemCategoryType (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_category.type
クラス ItemCategoryType

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_category.type.ItemCategoryType
すべての実装インタフェース:
Serializable
public class ItemCategoryType
extends Object
implements Serializable

商品カテゴリ種別の基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemCategoryType()
メソッドの概要
String | getItemCategoryTypeCode() 商品カテゴリ種別コードを取得します。
void | setItemCategoryTypeCode(String itemCategoryTypeCode) 商品カテゴリ種別コードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemCategoryType

public ItemCategoryType()
メソッドの詳細

getItemCategoryTypeCode

public String getItemCategoryTypeCode()
商品カテゴリ種別コードを取得します。

戻り値:
商品カテゴリ種別コード

setItemCategoryTypeCode

public void setItemCategoryTypeCode(String itemCategoryTypeCode)
商品カテゴリ種別コードを設定します。

パラメータ:
itemCategoryTypeCode - 商品カテゴリ種別コード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.item_category.type (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.item_category.type
クラス
ItemCategoryType


jp.co.intra_mart.foundation.datastore.application.domain.item_category.type (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.type

商品カテゴリ種別情報を操作するクラスを提供します。

参照:
説明

クラスの概要
ItemCategoryType 商品カテゴリ種別の基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.type の説明

商品カテゴリ種別情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.item_category.type クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.type の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.type.ItemCategoryType (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.type の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category.type の使用

jp.co.intra_mart.foundation.datastore.application.domain.item_category.type はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemAttachImporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_category
インタフェース ItemAttachImporter

既知の実装クラスの一覧:
StandardItemAttachImporter
public interface ItemAttachImporter

商品分類のインポートのインターフェースです。

導入されたバージョン:
5.1

メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。

メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemCategoryImporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_category
インタフェース ItemCategoryImporter

既知の実装クラスの一覧:
StandardItemCategoryImporter
public interface ItemCategoryImporter

商品カテゴリのインポートのインターフェースです。

導入されたバージョン:
5.1

メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。

メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ItemCategoryManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_category
クラス ItemCategoryManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager
public abstract class ItemCategoryManager
extends Object

商品カテゴリに関する情報を管理します。 このクラスのインスタンスは必ず getItemCategoryManager(String, String) で取得してください。

導入されたバージョン:
5.1

コンストラクタの概要
ItemCategoryManager()
メソッドの概要
abstract void | addCategory(ItemCategory category) 商品カテゴリを新規登録します。
abstract void | deleteCategory(ItemCategory category) 商品カテゴリを削除します。
abstract Item[] | getAllCategorizedItems(String categoryTypeCode, String categoryCode) 商品カテゴリに分類されているすべての商品の情報を返します。
abstract Item[] | getCategorizedItems(String categoryTypeCode, String categoryCode) 商品カテゴリに分類されている商品の情報を返します。
abstract ItemCategory | getCategory(String categoryTypeCode, String categoryCode) 指定されたカテゴリコードに対する商品カテゴリの情報を返します。
abstract ItemCategoryStruct | getCategoryStruct(String categoryTypeCode) 指定された商品カテゴリ種別のカテゴリ階層を取得します。
abstract ItemCategory[] | getCategoryTypes() 登録済の商品カテゴリ種別の一覧を返します。
static ItemCategoryManager | getItemCategoryManager(String user, String group) ItemCategoryManagerを取得します。
protected abstract void | init(String user, String group) ItemCategoryManagerを初期化します。
abstract boolean | isEndCategory(String categoryTypeCode, String categoryCode) 指定されたカテゴリコードに対する商品カテゴリが末端のカテゴリか調べます。
abstract void | removeItem(ItemAttach attach) 商品カテゴリから商品を外します。
abstract void | setItem(ItemAttach attach) 商品カテゴリに商品を設定します。
abstract void | updateCategory(ItemCategory category) 商品カテゴリを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemCategoryManager

public ItemCategoryManager()
メソッドの詳細

getItemCategoryManager

public static ItemCategoryManager getItemCategoryManager(String user,
                                                         String group)
                                                  throws ManagerException
ItemCategoryManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するItemCategoryManager
例外:
ManagerException - ItemCategoryManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
ItemCategoryManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - 初期化に失敗

addCategory

public abstract void addCategory(ItemCategory category)
                          throws ManagerException
商品カテゴリを新規登録します。

ルートとなる商品カテゴリを登録するときは、商品カテゴリ種別コードと商品カテゴリコードに同じ値を設定してください。
ルートとなる商品カテゴリが、商品種別となります。
また、ルートの商品カテゴリ登録時は、親商品カテゴリコードに必ずnullが設定されます。

ルートではない商品カテゴリを登録するときは、親商品カテゴリコードを必ず設定してください。
親カテゴリコードが設定されていないときは、ManagerExceptionを発生させます。

パラメータ:
category - 商品カテゴリ情報
例外:
ManagerException - 商品カテゴリ情報の新規登録に失敗した場合

updateCategory

public abstract void updateCategory(ItemCategory category)
                             throws ManagerException
商品カテゴリを更新します。

商品カテゴリの属性情報および商品カテゴリの階層構造を更新する場合に、このメソッドを使用します。 商品カテゴリの階層構造の更新時に、階層構造が循環するような設定が行われた場合は、ManagerException が投げられます。

パラメータ:
category - 商品カテゴリ情報
例外:
ManagerException - 商品カテゴリ情報の更新に失敗した場合

deleteCategory

public abstract void deleteCategory(ItemCategory category)
                             throws ManagerException
商品カテゴリを削除します。
指定された商品カテゴリが存在しない場合は ManagerException がスローされます。

パラメータ:
category - 商品カテゴリ情報
例外:
ManagerException - 商品カテゴリ情報の削除に失敗した場合

setItem

public abstract void setItem(ItemAttach attach)
                      throws ManagerException
商品カテゴリに商品を設定します。

商品が設定できるのは、商品カテゴリ階層の末端のカテゴリだけです。 それ以外の商品カテゴリに商品を設定した場合は、ManagerException が投げられます。

パラメータ:
attach - 商品設定情報
例外:
ManagerException - 商品カテゴリ設定情報の設定に失敗した場合

removeItem

public abstract void removeItem(ItemAttach attach)
                         throws ManagerException
商品カテゴリから商品を外します。
指定された商品設定情報が存在しない場合は ManagerException がスローされます。

パラメータ:
attach - 商品設定情報
例外:
ManagerException - 商品カテゴリ設定情報の削除に失敗した場合

getCategoryTypes

public abstract ItemCategory[] getCategoryTypes()
                                         throws ManagerException
登録済の商品カテゴリ種別の一覧を返します。

指定された商品カテゴリ種別の情報が存在しない場合は、空の配列を返します。

戻り値:
商品カテゴリ情報
例外:
ManagerException - 商品カテゴリ設定情報の取得に失敗した場合

getCategoryStruct

public abstract ItemCategoryStruct getCategoryStruct(String categoryTypeCode)
                                              throws ManagerException
指定された商品カテゴリ種別のカテゴリ階層を取得します。

パラメータ:
categoryTypeCode - 商品カテゴリ種別コード
戻り値:
カテゴリ階層
例外:
ManagerException - カテゴリ階層情報の取得に失敗した場合

getCategory

public abstract ItemCategory getCategory(String categoryTypeCode,
                                         String categoryCode)
                                  throws ManagerException
指定されたカテゴリコードに対する商品カテゴリの情報を返します。

パラメータ:
categoryTypeCode - 商品カテゴリ種別コード
categoryCode - 商品カテゴリコード
戻り値:
商品カテゴリ情報
例外:
ManagerException - 商品カテゴリ情報の取得に失敗した場合

getCategorizedItems

public abstract Item[] getCategorizedItems(String categoryTypeCode,
                                           String categoryCode)
                                    throws ManagerException
商品カテゴリに分類されている商品の情報を返します。返される商品情報は、現在存在するもののみです。

指定された商品カテゴリがカテゴリ階層の末端のカテゴリでない場合、指定されたカテゴリ以下のすべてのカテゴリに分類されている商品情報を返します。
指定された商品カテゴリがカテゴリ階層の末端のカテゴリに商品が分類されていない場合は、空の配列を返します。

パラメータ:
categoryTypeCode - 商品カテゴリ種別コード
categoryCode - 商品カテゴリコード
戻り値:
商品情報
例外:
ManagerException - 商品情報の取得に失敗した場合

getAllCategorizedItems

public abstract Item[] getAllCategorizedItems(String categoryTypeCode,
                                              String categoryCode)
                                       throws ManagerException
商品カテゴリに分類されているすべての商品の情報を返します。

指定された商品カテゴリがカテゴリ階層の末端のカテゴリでない場合、指定されたカテゴリ以下のすべてのカテゴリに分類されている商品情報を返します。
指定された商品カテゴリがカテゴリ階層の末端のカテゴリに商品が分類されていない場合は、空の配列を返します。

パラメータ:
categoryTypeCode - 商品カテゴリ種別コード
categoryCode - 商品カテゴリコード
戻り値:
商品情報
例外:
ManagerException - 商品情報の取得に失敗した場合

isEndCategory

public abstract boolean isEndCategory(String categoryTypeCode,
                                      String categoryCode)
                               throws ManagerException
指定されたカテゴリコードに対する商品カテゴリが末端のカテゴリか調べます。
末端のカテゴリの時はtrueを返します。

パラメータ:
categoryTypeCode - 商品カテゴリ種別コード
categoryCode - 商品カテゴリコード
戻り値:
末端のカテゴリの時はtrue、末端のカテゴリでないときはfalseを返す。
例外:
ManagerException - 判定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemCategoryStruct (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_category
インタフェース ItemCategoryStruct

public interface ItemCategoryStruct

商品カテゴリのツリー構造の構成を表すクラスです。

メソッドの概要
ItemCategoryStruct[] | getChildren() このカテゴリ構成の子供の構成を取得します。
ItemCategory | getItemCateogry() 商品カテゴリを取得します。

メソッドの詳細

getItemCateogry

public ItemCategory getItemCateogry()
商品カテゴリを取得します。

戻り値:
商品カテゴリ

getChildren

public ItemCategoryStruct[] getChildren()
このカテゴリ構成の子供の構成を取得します。

戻り値:
カテゴリ構成の子供の構成
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.item_category (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.item_category
インタフェース
ItemAttachImporter
ItemCategoryImporter
ItemCategoryStruct
クラス
ItemCategoryManager
StandardItemAttachImporter
StandardItemCategoryImporter


jp.co.intra_mart.foundation.datastore.application.domain.item_category (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category

商品カテゴリ情報を操作するクラスを提供します。

参照:
説明

インタフェースの概要
ItemAttachImporter | 商品分類のインポートのインターフェースです。
ItemCategoryImporter | 商品カテゴリのインポートのインターフェースです。
ItemCategoryStruct | 商品カテゴリのツリー構造の構成を表すクラスです。

クラスの概要
ItemCategoryManager | 商品カテゴリに関する情報を管理します。
StandardItemAttachImporter | 商品分類のインポートを行います。
StandardItemCategoryImporter | 商品カテゴリのインポートを行います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category の説明

商品カテゴリ情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.item_category クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemAttachImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemAttachImporter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemCategoryImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemAttachImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryStruct


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category の使用

jp.co.intra_mart.foundation.datastore.application.domain.item_category を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category 商品カテゴリ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_category により使用される jp.co.intra_mart.foundation.datastore.application.domain.item_category のクラス
ItemAttachImporter
商品分類のインポートのインターフェースです。
ItemCategoryImporter
商品カテゴリのインポートのインターフェースです。
ItemCategoryManager
商品カテゴリに関する情報を管理します。
ItemCategoryStruct
商品カテゴリのツリー構造の構成を表すクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardItemAttachImporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_category
クラス StandardItemAttachImporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemAttachImporter
すべての実装インタフェース:
ItemAttachImporter
public class StandardItemAttachImporter
extends Object
implements ItemAttachImporter

商品分類のインポートを行います。

導入されたバージョン:
5.1

コンストラクタの概要
StandardItemAttachImporter()
メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardItemAttachImporter

public StandardItemAttachImporter()
メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

定義:
インタフェース ItemAttachImporter 内の doImport
パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardItemCategoryImporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_category
クラス StandardItemCategoryImporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemCategoryImporter
すべての実装インタフェース:
ItemCategoryImporter
public class StandardItemCategoryImporter
extends Object
implements ItemCategoryImporter

商品カテゴリのインポートを行います。

導入されたバージョン:
5.1

コンストラクタの概要
StandardItemCategoryImporter()
メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardItemCategoryImporter

public StandardItemCategoryImporter()
メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

定義:
インタフェース ItemCategoryImporter 内の doImport
パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateImporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateImporter の使用

ItemTemplateImporter を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_template 商品テンプレート属性情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_template での ItemTemplateImporter の使用

ItemTemplateImporter を実装している jp.co.intra_mart.foundation.datastore.application.domain.item_template のクラス
 class StandardItemTemplateImporter
商品テンプレートのインポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager の使用

ItemTemplateManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_template 商品テンプレート属性情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_template での ItemTemplateManager の使用

ItemTemplateManager を返す jp.co.intra_mart.foundation.datastore.application.domain.item_template のメソッド
static ItemTemplateManager ItemTemplateManager.getItemTemplateManager(String user, String group)
ItemTemplateManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_template.StandardItemTemplateImporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_template.StandardItemTemplateImporter の使用

jp.co.intra_mart.foundation.datastore.application.domain.item_template.StandardItemTemplateImporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail の使用

ItemTemplateDetail を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_template 商品テンプレート属性情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_template での ItemTemplateDetail の使用

ItemTemplateDetail を返す jp.co.intra_mart.foundation.datastore.application.domain.item_template のメソッド
abstract  ItemTemplateDetail[] ItemTemplateManager.getTemplateDetail(String templateCode)
指定された商品属性テンプレートの明細情報を返します。

ItemTemplateDetail 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item_template のメソッド
abstract void | ItemTemplateManager.setTemplateDetail(ItemTemplateDetail detail) 商品属性テンプレート明細情報を設定します。
abstract void | ItemTemplateManager.deleteTemplateDetail(ItemTemplateDetail detail) 商品属性テンプレート明細情報を削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetailInternational の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetailInternational の使用

ItemTemplateDetailInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail 商品テンプレート属性詳細情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail での ItemTemplateDetailInternational の使用

ItemTemplateDetailInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail のメソッド
 ItemTemplateDetailInternational ItemTemplateDetail.getItemTemplateDetailInternational(Locale locale)
指定された言語に対する国際化情報を取得します。

ItemTemplateDetailInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail のメソッド
 void ItemTemplateDetail.putInternational(Locale locale, ItemTemplateDetailInternational data)
指定された言語に対する国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemTemplateDetail (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail
クラス ItemTemplateDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail
すべての実装インタフェース:
Serializable
public class ItemTemplateDetail
extends Object
implements Serializable

商品属性テンプレート明細の基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemTemplateDetail()
商品属性テンプレート明細に関連する情報を新規に生成します。
ItemTemplateDetail(Locale locale)
商品属性テンプレート明細に関連する情報を新規に生成します。
メソッドの概要
int | getDataType() データ型を取得します。
Locale | getDefaultLocale() デフォルトのロケールを取得します。
ItemTemplateDetailInternational | getItemTemplateDetailInternational(Locale locale) 指定された言語に対する国際化情報を取得します。
Locale[] | getLocales() この商品属性テンプレート明細で管理している言語（ロケール）をすべて取得します。
String | getNotes() 備考を取得します。
int | getSortKey() ソートキーを取得します。
String | getTemplateCode() テンプレートコードを取得します。
String | getTemplateDetailCode() テンプレート明細コードを取得します。
String | getTemplateDetailName() テンプレート明細名を取得します。
String | getTemplateDetailName(Locale locale) テンプレート明細名を取得します。
void | putInternational(Locale locale, ItemTemplateDetailInternational data) 指定された言語に対する国際化情報を設定します。
void | removeInternational(Locale locale) 指定された言語に対する国際化情報を削除します。
void | setDataType(int dataType) データ型を設定します。
void | setDefaultLocale(Locale defaultLocale) デフォルトのロケールを設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
void | setTemplateCode(String templateCode) テンプレートコードを設定します。
void | setTemplateDetailCode(String templateDetailCode) テンプレート明細コードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemTemplateDetail

public ItemTemplateDetail()
商品属性テンプレート明細に関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値の言語だけのロケールが割り当てられます。

ItemTemplateDetail

public ItemTemplateDetail(Locale locale)
商品属性テンプレート明細に関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられます。

パラメータ:
locale - デフォルトの言語
メソッドの詳細

getDefaultLocale

public Locale getDefaultLocale()
デフォルトのロケールを取得します。

戻り値:
デフォルトのロケール

setDefaultLocale

public void setDefaultLocale(Locale defaultLocale)
デフォルトのロケールを設定します。

パラメータ:
defaultLocale - デフォルトのロケール

getLocales

public Locale[] getLocales()
この商品属性テンプレート明細で管理している言語（ロケール）をすべて取得します。

戻り値:
この商品属性テンプレート明細で管理している言語（ロケール）

getItemTemplateDetailInternational

public ItemTemplateDetailInternational getItemTemplateDetailInternational(Locale locale)
指定された言語に対する国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
国際化情報

putInternational

public void putInternational(Locale locale,
                             ItemTemplateDetailInternational data)
指定された言語に対する国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 国際化情報

removeInternational

public void removeInternational(Locale locale)
指定された言語に対する国際化情報を削除します。

パラメータ:
locale - 言語（ロケール）

getTemplateCode

public String getTemplateCode()
テンプレートコードを取得します。

戻り値:
テンプレートコード

setTemplateCode

public void setTemplateCode(String templateCode)
テンプレートコードを設定します。

パラメータ:
templateCode - テンプレートコード

getTemplateDetailCode

public String getTemplateDetailCode()
テンプレート明細コードを取得します。

戻り値:
テンプレート明細コード

setTemplateDetailCode

public void setTemplateDetailCode(String templateDetailCode)
テンプレート明細コードを設定します。

パラメータ:
templateDetailCode - テンプレート明細コード

getDataType

public int getDataType()
データ型を取得します。

戻り値:
データ型

setDataType

public void setDataType(int dataType)
データ型を設定します。

パラメータ:
dataType - データ型

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getTemplateDetailName

public String getTemplateDetailName()
テンプレート明細名を取得します。

戻り値:
テンプレート明細名

getTemplateDetailName

public String getTemplateDetailName(Locale locale)
テンプレート明細名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
テンプレート明細名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemTemplateDetailInternational (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail
クラス ItemTemplateDetailInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetailInternational
すべての実装インタフェース:
Serializable
public class ItemTemplateDetailInternational
extends Object
implements Serializable

商品属性テンプレート明細の国際化属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemTemplateDetailInternational()
メソッドの概要
String | getTemplateDetailName() テンプレート明細名を取得します。
void | setTemplateDetailName(String templateDetailName) テンプレート明細名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemTemplateDetailInternational

public ItemTemplateDetailInternational()
メソッドの詳細

getTemplateDetailName

public String getTemplateDetailName()
テンプレート明細名を取得します。

戻り値:
テンプレート明細名
例外:
AccessorException - データの取得に失敗した場合

setTemplateDetailName

public void setTemplateDetailName(String templateDetailName)
テンプレート明細名を設定します。

パラメータ:
templateDetailName - テンプレート明細名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail
クラス
ItemTemplateDetail
ItemTemplateDetailInternational


jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail

商品テンプレート属性詳細情報を操作するクラスを提供します。

参照:
説明

クラスの概要
ItemTemplateDetail | 商品属性テンプレート明細の基本属性のデータを取り扱います。
ItemTemplateDetailInternational | 商品属性テンプレート明細の国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail の説明

商品テンプレート属性詳細情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetailInternational (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail の使用

jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_template | 商品テンプレート属性情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail | 商品テンプレート属性詳細情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_template により使用される jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail のクラス
ItemTemplateDetail
商品属性テンプレート明細の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail により使用される jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail のクラス
ItemTemplateDetailInternational
商品属性テンプレート明細の国際化属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate の使用

ItemTemplate を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_template 商品テンプレート属性情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_template での ItemTemplate の使用

ItemTemplate を返す jp.co.intra_mart.foundation.datastore.application.domain.item_template のメソッド
abstract ItemTemplate[] | ItemTemplateManager.getTemplates(String key) 指定された検索条件に該当する商品属性テンプレート情報を返します。
abstract ItemTemplate | ItemTemplateManager.getTemplate(String templateCode) 指定された商品属性テンプレート情報を返します。

ItemTemplate 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item_template のメソッド
abstract void | ItemTemplateManager.addTemplate(ItemTemplate template) 商品属性テンプレート情報を新規登録します。
abstract void | ItemTemplateManager.updateTemplate(ItemTemplate template) 商品属性テンプレート情報を更新します。
abstract void | ItemTemplateManager.deleteTemplate(ItemTemplate template) 商品属性テンプレート情報を削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplateInternational の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplateInternational の使用

jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplateInternational はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemTemplate (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_template.template
クラス ItemTemplate

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate
すべての実装インタフェース:
Serializable
public class ItemTemplate
extends Object
implements Serializable

商品属性テンプレートの基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemTemplate()
メソッドの概要
String | getNotes() 備考を取得します。
String | getTemplateCode() テンプレートコードを取得します。
String | getTemplateName() テンプレート名を取得します。
void | setNotes(String notes) 備考を設定します。
void | setTemplateCode(String templateCode) テンプレートコードを設定します。
void | setTemplateName(String templateName) テンプレート名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemTemplate

public ItemTemplate()
メソッドの詳細

getTemplateCode

public String getTemplateCode()
テンプレートコードを取得します。

戻り値:
テンプレートコード

setTemplateCode

public void setTemplateCode(String templateCode)
テンプレートコードを設定します。

パラメータ:
templateCode - テンプレートコード

getTemplateName

public String getTemplateName()
テンプレート名を取得します。

戻り値:
テンプレート名

setTemplateName

public void setTemplateName(String templateName)
テンプレート名を設定します。

パラメータ:
templateName - テンプレート名

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemTemplateInternational (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_template.template
クラス ItemTemplateInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplateInternational
すべての実装インタフェース:
Serializable
public class ItemTemplateInternational
extends Object
implements Serializable

商品属性テンプレートの国際化属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemTemplateInternational()
メソッドの概要
String | getTemplateName() テンプレート名を取得します。
void | setTemplateName(String templateName) テンプレート名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemTemplateInternational

public ItemTemplateInternational()
メソッドの詳細

getTemplateName

public String getTemplateName()
テンプレート名を取得します。

戻り値:
テンプレート名
例外:
AccessorException - データの取得に失敗した場合

setTemplateName

public void setTemplateName(String templateName)
テンプレート名を設定します。

パラメータ:
templateName - テンプレート名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.item_template.template (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.item_template.template
クラス
ItemTemplate
ItemTemplateInternational


jp.co.intra_mart.foundation.datastore.application.domain.item_template.template (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template.template

商品テンプレート属性情報を操作するクラスを提供します。

参照:
説明

クラスの概要
ItemTemplate | 商品属性テンプレートの基本属性のデータを取り扱います。
ItemTemplateInternational | 商品属性テンプレートの国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template.template の説明

商品テンプレート属性情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.item_template.template クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template.template の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplateInternational (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template.template の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_template.template の使用

jp.co.intra_mart.foundation.datastore.application.domain.item_template.template を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_template 商品テンプレート属性情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_template により使用される jp.co.intra_mart.foundation.datastore.application.domain.item_template.template のクラス
ItemTemplate
商品属性テンプレートの基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemTemplateImporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_template
インタフェース ItemTemplateImporter

既知の実装クラスの一覧:
StandardItemTemplateImporter
public interface ItemTemplateImporter

商品属性テンプレートのインポートのインターフェースです。

導入されたバージョン:
5.1

メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。

メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemTemplateManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_template
クラス ItemTemplateManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager
public abstract class ItemTemplateManager
extends Object

商品属性テンプレートの情報を管理します。

導入されたバージョン:
5.1

コンストラクタの概要
ItemTemplateManager()
メソッドの概要
abstract void | addTemplate(ItemTemplate template) 商品属性テンプレート情報を新規登録します。
abstract void | deleteTemplate(ItemTemplate template) 商品属性テンプレート情報を削除します。
abstract void | deleteTemplateDetail(ItemTemplateDetail detail) 商品属性テンプレート明細情報を削除します。
static ItemTemplateManager | getItemTemplateManager(String user, String group) ItemTemplateManagerを取得します。
abstract ItemTemplate | getTemplate(String templateCode) 指定された商品属性テンプレート情報を返します。
abstract ItemTemplateDetail[] | getTemplateDetail(String templateCode) 指定された商品属性テンプレートの明細情報を返します。
abstract ItemTemplate[] | getTemplates(String key) 指定された検索条件に該当する商品属性テンプレート情報を返します。
protected abstract void | init(String user, String group) ItemTemplateManagerを初期化します。
abstract void | setTemplateDetail(ItemTemplateDetail detail) 商品属性テンプレート明細情報を設定します。
abstract void | updateTemplate(ItemTemplate template) 商品属性テンプレート情報を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemTemplateManager

public ItemTemplateManager()
メソッドの詳細

getItemTemplateManager

public static ItemTemplateManager getItemTemplateManager(String user,
                                                         String group)
                                                  throws ManagerException
ItemTemplateManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するItemTemplateManager
例外:
ManagerException - ItemTemplateManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
ItemTemplateManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - 初期化に失敗

addTemplate

public abstract void addTemplate(ItemTemplate template)
                          throws ManagerException
商品属性テンプレート情報を新規登録します。

パラメータ:
template - 商品属性テンプレート情報
例外:
ManagerException - 商品テンプレート情報の新規登録に失敗した場合

updateTemplate

public abstract void updateTemplate(ItemTemplate template)
                             throws ManagerException
商品属性テンプレート情報を更新します。

パラメータ:
template - 商品属性テンプレート情報
例外:
ManagerException - 商品テンプレート情報の更新に失敗した場合

deleteTemplate

public abstract void deleteTemplate(ItemTemplate template)
                             throws ManagerException
商品属性テンプレート情報を削除します。
指定された商品属性テンプレート情報が存在しない場合は ManagerException がスローされます。

パラメータ:
template - 商品属性テンプレート情報
例外:
ManagerException - 商品テンプレート情報の削除に失敗した場合

setTemplateDetail

public abstract void setTemplateDetail(ItemTemplateDetail detail)
                                throws ManagerException
商品属性テンプレート明細情報を設定します。

指定された商品属性テンプレート情報が存在しない場合は新規登録します。 商品属性テンプレート情報がすでに存在する場合は更新を行います。

パラメータ:
detail - 商品属性テンプレート明細情報
例外:
ManagerException - 商品テンプレート情報の設定に失敗した場合

deleteTemplateDetail

public abstract void deleteTemplateDetail(ItemTemplateDetail detail)
                                   throws ManagerException
商品属性テンプレート明細情報を削除します。
指定された商品属性テンプレート明細情報が存在しない場合は ManagerException がスローされます。

パラメータ:
detail - 商品属性テンプレート明細情報
例外:
ManagerException - 商品テンプレート情報の削除に失敗した場合

getTemplates

public abstract ItemTemplate[] getTemplates(String key)
                                     throws ManagerException
指定された検索条件に該当する商品属性テンプレート情報を返します。

検索条件に前方および後方一致する商品属性テンプレート情報が返されます。

パラメータ:
key - 検索条件（商品属性テンプレートコードまたは商品属性テンプレート名）
戻り値:
商品属性テンプレート情報
例外:
ManagerException - 商品テンプレート情報の取得に失敗した場合

getTemplate

public abstract ItemTemplate getTemplate(String templateCode)
                                  throws ManagerException
指定された商品属性テンプレート情報を返します。

パラメータ:
templateCode - テンプレートコード
戻り値:
商品属性テンプレート情報
例外:
ManagerException - 商品テンプレート情報の取得に失敗した場合

getTemplateDetail

public abstract ItemTemplateDetail[] getTemplateDetail(String templateCode)
                                                throws ManagerException
指定された商品属性テンプレートの明細情報を返します。

パラメータ:
templateCode - テンプレートコード
戻り値:
商品属性テンプレート明細情報
例外:
ManagerException - 商品テンプレート情報の取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.item_template (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.item_template
インタフェース
ItemTemplateImporter
クラス
ItemTemplateManager
StandardItemTemplateImporter


jp.co.intra_mart.foundation.datastore.application.domain.item_template (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template

商品テンプレート属性情報を操作するクラスを提供します。

参照:
説明

インタフェースの概要
ItemTemplateImporter 商品属性テンプレートのインポートのインターフェースです。

クラスの概要
ItemTemplateManager | 商品属性テンプレートの情報を管理します。
StandardItemTemplateImporter | 商品テンプレートのインポートを行います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template の説明

商品テンプレート属性情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.item_template クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_template.StandardItemTemplateImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateImporter


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_template の使用

jp.co.intra_mart.foundation.datastore.application.domain.item_template を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_template 商品テンプレート属性情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_template により使用される jp.co.intra_mart.foundation.datastore.application.domain.item_template のクラス
ItemTemplateImporter
商品属性テンプレートのインポートのインターフェースです。
ItemTemplateManager
商品属性テンプレートの情報を管理します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardItemTemplateImporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_template
クラス StandardItemTemplateImporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_template.StandardItemTemplateImporter
すべての実装インタフェース:
ItemTemplateImporter
public class StandardItemTemplateImporter
extends Object
implements ItemTemplateImporter

商品テンプレートのインポートを行います。

導入されたバージョン:
5.1

コンストラクタの概要
StandardItemTemplateImporter()
メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardItemTemplateImporter

public StandardItemTemplateImporter()
メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

定義:
インタフェース ItemTemplateImporter 内の doImport
パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach の使用

PrivateGroupAttach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group プライベートグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.private_group での PrivateGroupAttach の使用

PrivateGroupAttach 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.private_group のメソッド
abstract void | PrivateGroupManager.setMember(PrivateGroupAttach member) プライベートグループに人員を割り当てます。
abstract void | PrivateGroupManager.deleteMember(PrivateGroupAttach member) プライベートグループから人員をはずします。
void | PrivateGroupChangedListener.memberSet(String groupId, PrivateGroupAttach member) プライベートグループ所属情報がデータストアに登録された後に呼び出されます。
void | PrivateGroupChangedListener.memberDeleted(String groupId, PrivateGroupAttach member) プライベートグループ所属情報がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach
クラス
PrivateGroupAttach


jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach

プライベートグループ所属情報を操作するクラスを提供します。

参照:
説明

クラスの概要
PrivateGroupAttach プライベートグループ所属の基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach の説明

プライベートグループ所属情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach の使用

jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group プライベートグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.private_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach のクラス
PrivateGroupAttach
プライベートグループ所属の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PrivateGroupAttach (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach
クラス PrivateGroupAttach

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach
すべての実装インタフェース:
Serializable
public class PrivateGroupAttach
extends Object
implements Serializable

プライベートグループ所属の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PrivateGroupAttach()
メソッドの概要
String | getOwnerCode() 所有者コードを取得します。
String | getPrivateGroupCode() グループコードを取得します。
int | getSortKey() ソートキーを取得します。
String | getUserCode() ユーザコードを取得します。
void | setOwnerCode(String ownerCode) 所有者コードを設定します。
void | setPrivateGroupCode(String privateGroupCode) グループコードを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
void | setUserCode(String userCode) ユーザコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PrivateGroupAttach

public PrivateGroupAttach()
メソッドの詳細

getOwnerCode

public String getOwnerCode()
所有者コードを取得します。

戻り値:
所有者コード

setOwnerCode

public void setOwnerCode(String ownerCode)
所有者コードを設定します。

パラメータ:
ownerCode - 所有者コード

getPrivateGroupCode

public String getPrivateGroupCode()
グループコードを取得します。

戻り値:
グループコード

setPrivateGroupCode

public void setPrivateGroupCode(String privateGroupCode)
グループコードを設定します。

パラメータ:
privateGroupCode - グループコード

getUserCode

public String getUserCode()
ユーザコードを取得します。

戻り値:
ユーザコード

setUserCode

public void setUserCode(String userCode)
ユーザコードを設定します。

パラメータ:
userCode - ユーザコード

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener の使用

jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager の使用

PrivateGroupManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group プライベートグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.private_group での PrivateGroupManager の使用

PrivateGroupManager を返す jp.co.intra_mart.foundation.datastore.application.domain.private_group のメソッド
static PrivateGroupManager PrivateGroupManager.getPrivateGroupManager(String user, String group)
PrivateGroupManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup の使用

PrivateGroup を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group プライベートグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.private_group での PrivateGroup の使用

PrivateGroup を返す jp.co.intra_mart.foundation.datastore.application.domain.private_group のメソッド
abstract PrivateGroup | PrivateGroupManager.getPrivateGroup(String owner, String group) 登録済のプライベートグループを取得します。
abstract PrivateGroup[] | PrivateGroupManager.getPrivateGroups(String owner) 指定されたユーザが持つプライベートグループをすべて取得します。

PrivateGroup 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.private_group のメソッド
abstract void | PrivateGroupManager.addPrivateGroup(PrivateGroup group) プライベートグループを登録します。
abstract void | PrivateGroupManager.updatePrivateGroup(PrivateGroup group) 登録済のプライベートグループ情報を更新します。
abstract void | PrivateGroupManager.deletePrivateGroup(PrivateGroup group) 登録済のプライベートグループ情報を削除します。
void | PrivateGroupChangedListener.privateGroupAdded(String groupId, PrivateGroup group) プライベートグループがデータストアに登録された後に呼び出されます。
void | PrivateGroupChangedListener.privateGroupUpdated(String groupId, PrivateGroup group) プライベートグループがデータストアに更新された後に呼び出されます。
void | PrivateGroupChangedListener.privateGroupDeleted(String groupId, PrivateGroup group) プライベートグループがデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.domain.private_group.group (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.private_group.group
クラス
PrivateGroup


jp.co.intra_mart.foundation.datastore.application.domain.private_group.group (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.group

プライベートグループ情報を操作するクラスを提供します。

参照:
説明

クラスの概要
PrivateGroup プライベートグループの基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.group の説明

プライベートグループ情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.private_group.group クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.group の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.group の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group.group の使用

jp.co.intra_mart.foundation.datastore.application.domain.private_group.group を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group プライベートグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.private_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.private_group.group のクラス
PrivateGroup
プライベートグループの基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PrivateGroup (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.private_group.group
クラス PrivateGroup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup
すべての実装インタフェース:
Serializable
public class PrivateGroup
extends Object
implements Serializable

プライベートグループの基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PrivateGroup()
メソッドの概要
String | getName() グループ名を取得します。
String | getNameEnglish() グループ名英字を取得します。
String | getNameSyllabary() グループ名カナを取得します。
String | getNotes() 備考を取得します。
String | getOwnerCode() 所有者コードを取得します。
String | getPrivateGroupCode() グループコードを取得します。
int | getSortKey() ソートキーを取得します。
void | setName(String name) グループ名を設定します。
void | setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
void | setNotes(String notes) 備考を設定します。
void | setOwnerCode(String ownerCode) 所有者コードを設定します。
void | setPrivateGroupCode(String privateGroupCode) グループコードを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PrivateGroup

public PrivateGroup()
メソッドの詳細

getOwnerCode

public String getOwnerCode()
所有者コードを取得します。

戻り値:
所有者コード

setOwnerCode

public void setOwnerCode(String ownerCode)
所有者コードを設定します。

パラメータ:
ownerCode - 所有者コード

getPrivateGroupCode

public String getPrivateGroupCode()
グループコードを取得します。

戻り値:
グループコード

setPrivateGroupCode

public void setPrivateGroupCode(String privateGroupCode)
グループコードを設定します。

パラメータ:
privateGroupCode - グループコード

getName

public String getName()
グループ名を取得します。

戻り値:
グループ名

setName

public void setName(String name)
グループ名を設定します。

パラメータ:
name - グループ名

getNameSyllabary

public String getNameSyllabary()
グループ名カナを取得します。

戻り値:
グループ名カナ

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ

getNameEnglish

public String getNameEnglish()
グループ名英字を取得します。

戻り値:
グループ名英字

setNameEnglish

public void setNameEnglish(String nameEnglish)
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.private_group (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.private_group
インタフェース
PrivateGroupChangedListener
クラス
PrivateGroupManager


jp.co.intra_mart.foundation.datastore.application.domain.private_group (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group

プライベートグループ情報を操作するクラスを提供します。

参照:
説明

インタフェースの概要
PrivateGroupChangedListener プライベートグループに関する情報の更新時のリスナーです。

クラスの概要
PrivateGroupManager プライベートグループに関連する情報を管理します。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group の説明

プライベートグループ情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.private_group クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group の使用

jp.co.intra_mart.foundation.datastore.application.domain.private_group を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group プライベートグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.private_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.private_group のクラス
PrivateGroupManager
プライベートグループに関連する情報を管理します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PrivateGroupChangedListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.private_group
インタフェース PrivateGroupChangedListener

public interface PrivateGroupChangedListener

プライベートグループに関する情報の更新時のリスナーです。

導入されたバージョン:
5.0

メソッドの概要
void | init(Map params) プライベートグループリスナーの初期化を行います。
void | memberDeleted(String groupId, PrivateGroupAttach member) プライベートグループ所属情報がデータストアから削除された後に呼び出されます。
void | memberSet(String groupId, PrivateGroupAttach member) プライベートグループ所属情報がデータストアに登録された後に呼び出されます。
void | privateGroupAdded(String groupId, PrivateGroup group) プライベートグループがデータストアに登録された後に呼び出されます。
void | privateGroupDeleted(String groupId, PrivateGroup group) プライベートグループがデータストアから削除された後に呼び出されます。
void | privateGroupUpdated(String groupId, PrivateGroup group) プライベートグループがデータストアに更新された後に呼び出されます。
void | setUesrId(String userid) ログインユーザIDを設定します。

メソッドの詳細

init

public void init(Map params)
プライベートグループリスナーの初期化を行います。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

パラメータ:
params - 初期化パラメータのマップ(Map)

setUesrId

public void setUesrId(String userid)
ログインユーザIDを設定します。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

パラメータ:
userid - ログインユーザID

privateGroupAdded

public void privateGroupAdded(String groupId,
                              PrivateGroup group)
                       throws ChangedListenerException
プライベートグループがデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
group - プライベートグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

privateGroupUpdated

public void privateGroupUpdated(String groupId,
                                PrivateGroup group)
                         throws ChangedListenerException
プライベートグループがデータストアに更新された後に呼び出されます。

パラメータ:
groupId - ログイングループID
group - プライベートグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

privateGroupDeleted

public void privateGroupDeleted(String groupId,
                                PrivateGroup group)
                         throws ChangedListenerException
プライベートグループがデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
group - プライベートグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberSet

public void memberSet(String groupId,
                      PrivateGroupAttach member)
               throws ChangedListenerException
プライベートグループ所属情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
member - プライベートグループ所属情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberDeleted

public void memberDeleted(String groupId,
                          PrivateGroupAttach member)
                   throws ChangedListenerException
プライベートグループ所属情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
member - プライベート所属情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PrivateGroupManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.private_group
クラス PrivateGroupManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager
public abstract class PrivateGroupManager
extends Object

プライベートグループに関連する情報を管理します。 このクラスのインスタンスは必ず getPrivateGroupManager(String, String) で取得してください。コンストラクタによる明示的な生成はできません。

導入されたバージョン:
5.0

コンストラクタの概要
PrivateGroupManager()
メソッドの概要
abstract void | addPrivateGroup(PrivateGroup group) プライベートグループを登録します。
abstract void | deleteMember(PrivateGroupAttach member) プライベートグループから人員をはずします。
abstract void | deletePrivateGroup(PrivateGroup group) 登録済のプライベートグループ情報を削除します。
abstract User[] | getMember(String owner, String group) ログインユーザが持つ指定されたプライベートグループに所属する人員を取得します。
abstract User[] | getMember(String owner, String group, Date date) 指定されたプライベートグループに所属する人員を取得します。
abstract PrivateGroup | getPrivateGroup(String owner, String group) 登録済のプライベートグループを取得します。
static PrivateGroupManager | getPrivateGroupManager(String user, String group) PrivateGroupManagerを取得します。
abstract PrivateGroup[] | getPrivateGroups(String owner) 指定されたユーザが持つプライベートグループをすべて取得します。
protected abstract void | init(String user, String group) PrivateGroupManagerを初期化します。
abstract void | setMember(PrivateGroupAttach member) プライベートグループに人員を割り当てます。
abstract void | updatePrivateGroup(PrivateGroup group) 登録済のプライベートグループ情報を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PrivateGroupManager

public PrivateGroupManager()
メソッドの詳細

getPrivateGroupManager

public static PrivateGroupManager getPrivateGroupManager(String user,
                                                         String group)
                                                  throws ManagerException
PrivateGroupManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するPrivateGroupManager
例外:
ManagerException - PrivateGroupManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
PrivateGroupManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - 初期化に失敗

getPrivateGroup

public abstract PrivateGroup getPrivateGroup(String owner,
                                             String group)
                                      throws ManagerException
登録済のプライベートグループを取得します。
該当するプライベートグループ情報が存在しない場合は nullを返します。

パラメータ:
owner - 所有者となるユーザのユーザコード
group - プライベートグループコード
戻り値:
プライベートグループ情報
例外:
ManagerException - プライベートグループの取得に失敗
導入されたバージョン:
6.1

getPrivateGroups

public abstract PrivateGroup[] getPrivateGroups(String owner)
                                         throws ManagerException
指定されたユーザが持つプライベートグループをすべて取得します。
該当するプライベートグループ情報が存在しない場合は空の配列を返します。

パラメータ:
owner - 所有者となるユーザのユーザコード
戻り値:
所有者が持つプライベートグループ情報の配列
例外:
ManagerException - プライベートグループの取得に失敗
導入されたバージョン:
6.1

addPrivateGroup

public abstract void addPrivateGroup(PrivateGroup group)
                              throws ManagerException
プライベートグループを登録します。

パラメータ:
group - プライベートグループ情報
例外:
ManagerException - プライベートグループの登録に失敗

updatePrivateGroup

public abstract void updatePrivateGroup(PrivateGroup group)
                                 throws ManagerException
登録済のプライベートグループ情報を更新します。

パラメータ:
group - プライベートグループ情報
例外:
ManagerException - プライベートグループの更新に失敗

deletePrivateGroup

public abstract void deletePrivateGroup(PrivateGroup group)
                                 throws ManagerException
登録済のプライベートグループ情報を削除します。
指定されたプライベートグループ情報が存在しない場合は ManagerException がスローされます。

パラメータ:
group - プライベートグループ情報
例外:
ManagerException - プライベートグループの削除に失敗

setMember

public abstract void setMember(PrivateGroupAttach member)
                        throws ManagerException
プライベートグループに人員を割り当てます。

パラメータ:
member - プライベートグループに割り当てる人員の情報
例外:
ManagerException - プライベートグループへの人員の割り当てに失敗

deleteMember

public abstract void deleteMember(PrivateGroupAttach member)
                           throws ManagerException
プライベートグループから人員をはずします。
指定された人員がプライベートグループに割り当てられていない場合は ManagerException がスローされます。

パラメータ:
member - プライベートグループから削除する人員の情報
例外:
ManagerException - プライベートグループからの人員の削除に失敗

getMember

public abstract User[] getMember(String owner,
                                 String group)
                          throws ManagerException
ログインユーザが持つ指定されたプライベートグループに所属する人員を取得します。
ユーザ情報はシステム日付で有効なユーザのみを取得します。
指定されたプライベートグループに有効な人員が所属していない場合は空の配列を返します。

パラメータ:
group - プライベートグループコード
戻り値:
ユーザ情報
例外:
ManagerException - プライベートグループに所属する人員の取得に失敗
導入されたバージョン:
6.1

getMember

public abstract User[] getMember(String owner,
                                 String group,
                                 Date date)
                          throws ManagerException
指定されたプライベートグループに所属する人員を取得します。
ユーザ情報は指定された日付で有効なユーザのみを取得します。
指定されたプライベートグループに有効な人員が所属していない場合は空の配列を返します。

パラメータ:
owner - 所有者となるユーザのユーザコード
group - プライベートグループコード
date - 日付
戻り値:
ユーザ情報
例外:
ManagerException - プライベートグループに所属する人員の取得に失敗
導入されたバージョン:
6.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach の使用

PublicGroupAttach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での PublicGroupAttach の使用

PublicGroupAttach を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract  PublicGroupAttach PublicGroupManager.getPublicGroupAttach(String user, String groupSet, String publicGroup)
ユーザのパブリックグループへの所属情報を取得します。

PublicGroupAttach 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract void | PublicGroupManager.setMember(PublicGroupAttach attach) パブリックグループに人員を割り当てます。
abstract void | PublicGroupManager.deleteMember(PublicGroupAttach attach) パブリックグループから人員をはずします。
void | PublicGroupChangedListener.memberSet(String groupId, PublicGroupAttach attach) パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.memberDeleted(String groupId, PublicGroupAttach attach) パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.access での PublicGroupAttach の使用

PublicGroupAttach 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | PublicGroupChangedControllerListener.memberSet(String groupId, PublicGroupAttach attach) パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedControllerListener.memberDeleted(String groupId, PublicGroupAttach attach) パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での PublicGroupAttach の使用

PublicGroupAttach 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | PublicGroupChangedMenuListener.memberSet(String groupId, PublicGroupAttach attach) パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.memberDeleted(String groupId, PublicGroupAttach attach) パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable の使用

PublicGroupAttachTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach パブリックグループ所属情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach での PublicGroupAttachTerminable の使用

PublicGroupAttachTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach のメソッド
PublicGroupAttachTerminable | PublicGroupAttach.getPublicGroupAttachTerminable(Term term) 指定された期間に対する期間化情報を取得します。
PublicGroupAttachTerminable | PublicGroupAttach.getPublicGroupAttachTerminable(Date date) 指定された日時に対する期間化情報を取得します。

PublicGroupAttachTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach のメソッド
 void PublicGroupAttach.putPublicGroupAttachTerminable(Term term, PublicGroupAttachTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach
クラス
PublicGroupAttach
PublicGroupAttachTerminable


jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach

パブリックグループ所属情報を操作するクラスを提供します。

参照:
説明

クラスの概要
PublicGroupAttach | パブリックグループ所属の基本属性のデータを取り扱います。
PublicGroupAttachTerminable | パブリックグループ所属の期間化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach の説明

パブリックグループ所属情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach の使用

jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach | パブリックグループ所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach のクラス
PublicGroupAttach
パブリックグループ所属の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach のクラス
PublicGroupAttachTerminable
パブリックグループ所属の期間化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach のクラス
PublicGroupAttach
パブリックグループ所属の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach のクラス
PublicGroupAttach
パブリックグループ所属の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupAttach (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach
クラス PublicGroupAttach

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach
すべての実装インタフェース:
Serializable
public class PublicGroupAttach
extends Object
implements Serializable

パブリックグループ所属の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupAttach()
パブリックグループ所属に関連する情報を新規に生成します。
PublicGroupAttach(Date date)
パブリックグループ所属に関連する情報を新規に生成します。
メソッドの概要
Date | getDefaultDate() デフォルトの日時を取得します。
PublicGroupAttachTerminable | getPublicGroupAttachTerminable(Date date) 指定された日時に対する期間化情報を取得します。
PublicGroupAttachTerminable | getPublicGroupAttachTerminable(Term term) 指定された期間に対する期間化情報を取得します。
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
int | getSortKey() ソートキーを取得します。
Term[] | getTerms() このパブリックグループ所属で管理している期間をすべて取得します。
String | getUserCode() ユーザコードを取得します。
void | putPublicGroupAttachTerminable(Term term, PublicGroupAttachTerminable data) 指定された期間に対する期間化情報を設定します。
void | removePublicGroupAttachTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setPublicGroupCode(String publicGroupCode) グループコードを設定します。
void | setPublicGroupSetCode(String publicGroupSetCode) グループセットコードを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
void | setUserCode(String userCode) ユーザコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupAttach

public PublicGroupAttach()
パブリックグループ所属に関連する情報を新規に生成します。 デフォルトの日時には現在のシステム日時が割り当てられます。

PublicGroupAttach

public PublicGroupAttach(Date date)
パブリックグループ所属に関連する情報を新規に生成します。 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時
メソッドの詳細

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
このパブリックグループ所属で管理している期間をすべて取得します。

戻り値:
このパブリックグループ所属で管理している期間

getPublicGroupAttachTerminable

public PublicGroupAttachTerminable getPublicGroupAttachTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getPublicGroupAttachTerminable

public PublicGroupAttachTerminable getPublicGroupAttachTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putPublicGroupAttachTerminable

public void putPublicGroupAttachTerminable(Term term,
                                           PublicGroupAttachTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removePublicGroupAttachTerminable

public void removePublicGroupAttachTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getUserCode

public String getUserCode()
ユーザコードを取得します。

戻り値:
ユーザコード

setUserCode

public void setUserCode(String userCode)
ユーザコードを設定します。

パラメータ:
userCode - ユーザコード

getPublicGroupSetCode

public String getPublicGroupSetCode()
グループセットコードを取得します。

戻り値:
グループセットコード

setPublicGroupSetCode

public void setPublicGroupSetCode(String publicGroupSetCode)
グループセットコードを設定します。

パラメータ:
publicGroupSetCode - グループセットコード

getPublicGroupCode

public String getPublicGroupCode()
グループコードを取得します。

戻り値:
グループコード

setPublicGroupCode

public void setPublicGroupCode(String publicGroupCode)
グループコードを設定します。

パラメータ:
publicGroupCode - グループコード

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupAttachTerminable (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach
クラス PublicGroupAttachTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable
すべての実装インタフェース:
Serializable
public class PublicGroupAttachTerminable
extends Object
implements Serializable

パブリックグループ所属の期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupAttachTerminable()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupAttachTerminable

public PublicGroupAttachTerminable()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory の使用

PublicGroupCategory を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での PublicGroupCategory の使用

PublicGroupCategory 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract void | PublicGroupManager.setCategoryDetail(PublicGroupCategory category) パブリックグループに対して指定された分類区分情報を設定します。
abstract void | PublicGroupManager.removeCategoryDetail(PublicGroupCategory category) パブリックグループに対して指定された分類区分情報を削除します。
void | PublicGroupChangedListener.categoryDetailSet(String groupId, PublicGroupCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.categoryDetailRemoved(String groupId, PublicGroupCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.access での PublicGroupCategory の使用

PublicGroupCategory 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | PublicGroupChangedControllerListener.categoryDetailSet(String groupId, PublicGroupCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedControllerListener.categoryDetailRemoved(String groupId, PublicGroupCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での PublicGroupCategory の使用

PublicGroupCategory 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | PublicGroupChangedMenuListener.categoryDetailSet(String groupId, PublicGroupCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.categoryDetailRemoved(String groupId, PublicGroupCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable の使用

PublicGroupCategoryTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category パブリックグループ分類情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.category での PublicGroupCategoryTerminable の使用

PublicGroupCategoryTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.category のメソッド
PublicGroupCategoryTerminable | PublicGroupCategory.getPublicGroupCategoryTerminable(Term term) 指定された期間に対する期間化情報を取得します。
PublicGroupCategoryTerminable | PublicGroupCategory.getPublicGroupCategoryTerminable(Date date) 指定された日時に対する期間化情報を取得します。

PublicGroupCategoryTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.category のメソッド
 void PublicGroupCategory.putPublicGroupCategoryTerminable(Term term, PublicGroupCategoryTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.domain.public_group.category (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.public_group.category
クラス
PublicGroupCategory
PublicGroupCategoryTerminable


jp.co.intra_mart.foundation.datastore.application.domain.public_group.category (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.category

パブリックグループ分類情報を操作するクラスを提供します。

参照:
説明

クラスの概要
PublicGroupCategory | パブリックグループ分類の基本属性のデータを取り扱います。
PublicGroupCategoryTerminable | パブリックグループ分類の期間化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.category の説明

パブリックグループ分類情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.public_group.category クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.category の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.category の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category の使用

jp.co.intra_mart.foundation.datastore.application.domain.public_group.category を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category | パブリックグループ分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.category のクラス
PublicGroupCategory
パブリックグループ分類の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.category により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.category のクラス
PublicGroupCategoryTerminable
パブリックグループ分類の期間化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.category のクラス
PublicGroupCategory
パブリックグループ分類の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.category のクラス
PublicGroupCategory
パブリックグループ分類の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupCategory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.category
クラス PublicGroupCategory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory
すべての実装インタフェース:
Serializable
public class PublicGroupCategory
extends Object
implements Serializable

パブリックグループ分類の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupCategory()
パブリックグループ分類に関連する情報を新規に生成します。
PublicGroupCategory(Date date)
パブリックグループ分類に関連する情報を新規に生成します。
メソッドの概要
String | getCategoryClassCode() 分類区分コードを取得します。
String | getCategoryCode() 分類コードを取得します。
Date | getDefaultDate() デフォルトの日時を取得します。
PublicGroupCategoryTerminable | getPublicGroupCategoryTerminable(Date date) 指定された日時に対する期間化情報を取得します。
PublicGroupCategoryTerminable | getPublicGroupCategoryTerminable(Term term) 指定された期間に対する期間化情報を取得します。
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
Term[] | getTerms() このパブリックグループ分類で管理している期間をすべて取得します。
void | putPublicGroupCategoryTerminable(Term term, PublicGroupCategoryTerminable data) 指定された期間に対する期間化情報を設定します。
void | removePublicGroupCategoryTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setCategoryClassCode(String categoryClassCode) 分類区分コードを設定します。
void | setCategoryCode(String categoryCode) 分類コードを設定します。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setPublicGroupCode(String publicGroupCode) グループコードを設定します。
void | setPublicGroupSetCode(String publicGroupSetCode) グループセットコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupCategory

public PublicGroupCategory()
パブリックグループ分類に関連する情報を新規に生成します。 デフォルトの日時には現在のシステム日時が割り当てられます。

PublicGroupCategory

public PublicGroupCategory(Date date)
パブリックグループ分類に関連する情報を新規に生成します。 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時
メソッドの詳細

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
このパブリックグループ分類で管理している期間をすべて取得します。

戻り値:
このパブリックグループ分類で管理している期間

getPublicGroupCategoryTerminable

public PublicGroupCategoryTerminable getPublicGroupCategoryTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getPublicGroupCategoryTerminable

public PublicGroupCategoryTerminable getPublicGroupCategoryTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putPublicGroupCategoryTerminable

public void putPublicGroupCategoryTerminable(Term term,
                                             PublicGroupCategoryTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removePublicGroupCategoryTerminable

public void removePublicGroupCategoryTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getPublicGroupSetCode

public String getPublicGroupSetCode()
グループセットコードを取得します。

戻り値:
グループセットコード

setPublicGroupSetCode

public void setPublicGroupSetCode(String publicGroupSetCode)
グループセットコードを設定します。

パラメータ:
publicGroupSetCode - グループセットコード

getPublicGroupCode

public String getPublicGroupCode()
グループコードを取得します。

戻り値:
グループコード

setPublicGroupCode

public void setPublicGroupCode(String publicGroupCode)
グループコードを設定します。

パラメータ:
publicGroupCode - グループコード

getCategoryClassCode

public String getCategoryClassCode()
分類区分コードを取得します。

戻り値:
分類区分コード

setCategoryClassCode

public void setCategoryClassCode(String categoryClassCode)
分類区分コードを設定します。

パラメータ:
categoryClassCode - 分類区分コード

getCategoryCode

public String getCategoryCode()
分類コードを取得します。

戻り値:
分類コード

setCategoryCode

public void setCategoryCode(String categoryCode)
分類コードを設定します。

パラメータ:
categoryCode - 分類コード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupCategoryTerminable (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.category
クラス PublicGroupCategoryTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable
すべての実装インタフェース:
Serializable
public class PublicGroupCategoryTerminable
extends Object
implements Serializable

パブリックグループ分類の期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupCategoryTerminable()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupCategoryTerminable

public PublicGroupCategoryTerminable()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener の使用

PublicGroupChangedListener を使用しているパッケージ
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.access での PublicGroupChangedListener の使用

PublicGroupChangedListener を実装している jp.co.intra_mart.foundation.security.access のクラス
 class PublicGroupChangedControllerListener
パブリックグループが削除された場合にアクセスコントローラに紐付くパブリックグループを削除するリスナークラスです。

jp.co.intra_mart.foundation.security.menu での PublicGroupChangedListener の使用

PublicGroupChangedListener を実装している jp.co.intra_mart.foundation.security.menu のクラス
 class PublicGroupChangedMenuListener
パブリックグループに関する情報の変更時のリスナーです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter の使用

PublicGroupImporter を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group パブリックグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での PublicGroupImporter の使用

PublicGroupImporter を実装している jp.co.intra_mart.foundation.datastore.application.domain.public_group のクラス
 class StandardPublicGroupImporter
パブリックグループのインポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager の使用

PublicGroupManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group パブリックグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での PublicGroupManager の使用

PublicGroupManager を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
static PublicGroupManager PublicGroupManager.getPublicGroupManager(String user, String group)
PublicGroupManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct の使用

PublicGroupStruct を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group パブリックグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での PublicGroupStruct の使用

PublicGroupStruct を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract  PublicGroupStruct[] PublicGroupManager.getPublicGroupStructs(String groupSet, String publicGroup, Date date, Locale locale)
パブリックグループの階層構造を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter の使用

jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup の使用

PublicGroup を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal での PublicGroup の使用

PublicGroup を返す jp.co.intra_mart.foundation.datastore.application.domain.deal のメソッド
abstract  PublicGroup[] DealPermissionManager.getPublicGroups(Deal deal)
取扱情報を保有するアクセス権をもつパブリックグループを返します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での PublicGroup の使用

PublicGroup を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract PublicGroup | PublicGroupManager.getPublicGroup(String groupSet, String publicGroup) 登録済のパブリックグループを取得します。
abstract PublicGroup[] | PublicGroupManager.getAttachedPublicGroups(String user) 現在、ユーザが所属しているパブリックグループの一覧を取得します。
abstract PublicGroup[] | PublicGroupManager.getAttachedPublicGroups(String user, Date date) 指定された日付にユーザが所属しているパブリックグループの一覧を取得します。

PublicGroup 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract void | PublicGroupManager.addPublicGroup(PublicGroup publicGroup) パブリックグループを登録します。
abstract void | PublicGroupManager.updatePublicGroup(PublicGroup publicGroup) 登録済のパブリックグループ情報を更新します。
abstract void | PublicGroupManager.deletePublicGroup(PublicGroup publicGroup) 登録済のパブリックグループ情報を削除します。
void | PublicGroupChangedListener.publicGroupAdded(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.publicGroupUpdated(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedListener.publicGroupDeleted(String groupId, PublicGroup publicGroup) パブリックグループがデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.access での PublicGroup の使用

PublicGroup 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | PublicGroupChangedControllerListener.publicGroupAdded(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedControllerListener.publicGroupUpdated(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedControllerListener.publicGroupDeleted(String groupId, PublicGroup publicGroup) パブリックグループがデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での PublicGroup の使用

PublicGroup 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | PublicGroupChangedMenuListener.publicGroupAdded(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.publicGroupUpdated(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedMenuListener.publicGroupDeleted(String groupId, PublicGroup publicGroup) パブリックグループがデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable の使用

PublicGroupTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group パブリックグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group での PublicGroupTerminable の使用

PublicGroupTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のメソッド
PublicGroupTerminable | PublicGroup.getPublicGroupTerminable(Term term) 指定された期間に対する期間化情報を取得します。
PublicGroupTerminable | PublicGroup.getPublicGroupTerminable(Date date) 指定された日時に対する期間化情報を取得します。

PublicGroupTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のメソッド
 void PublicGroup.putPublicGroupTerminable(Term term, PublicGroupTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational の使用

PublicGroupTerminableInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group パブリックグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group での PublicGroupTerminableInternational の使用

PublicGroupTerminableInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のメソッド
 PublicGroupTerminableInternational PublicGroupTerminable.getPublicGroupTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。

PublicGroupTerminableInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のメソッド
 void PublicGroupTerminable.putPublicGroupTerminableInternational(Locale locale, PublicGroupTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.domain.public_group.group (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.public_group.group
クラス
PublicGroup
PublicGroupTerminable
PublicGroupTerminableInternational


jp.co.intra_mart.foundation.datastore.application.domain.public_group.group (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.group

パブリックグループ情報を操作するクラスを提供します。

参照:
説明

クラスの概要
PublicGroup | パブリックグループの基本属性のデータを取り扱います。
PublicGroupTerminable | パブリックグループの期間化属性のデータを取り扱います。
PublicGroupTerminableInternational | パブリックグループの期間国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.group の説明

パブリックグループ情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.public_group.group クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.group の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.group の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group の使用

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のクラス
PublicGroup
パブリックグループの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のクラス
PublicGroup
パブリックグループの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のクラス
PublicGroupTerminable
パブリックグループの期間化属性のデータを取り扱います。
PublicGroupTerminableInternational
パブリックグループの期間国際化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のクラス
PublicGroup
パブリックグループの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のクラス
PublicGroup
パブリックグループの基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroup (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group
クラス PublicGroup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup
すべての実装インタフェース:
Serializable
public class PublicGroup
extends Object
implements Serializable

パブリックグループの基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroup()
パブリックグループに関連する情報を新規に生成します。
PublicGroup(Date date)
パブリックグループに関連する情報を新規に生成します。
PublicGroup(Locale locale)
パブリックグループに関連する情報を新規に生成します。
PublicGroup(Locale locale, Date date)
パブリックグループに関連する情報を新規に生成します。
メソッドの概要
Date | getDefaultDate() デフォルトの日時を取得します。
Locale | getDefaultLocale() デフォルトのロケールを取得します。
String | getName() グループ名を取得します。
String | getName(Date date) グループ名を取得します。
String | getName(Date date, Locale locale) グループ名を取得します。
String | getName(Locale locale) グループ名を取得します。
String | getNameEnglish() グループ名英字を取得します。
String | getNameEnglish(Date date) グループ名英字を取得します。
String | getNameEnglish(Date date, Locale locale) グループ名英字を取得します。
String | getNameEnglish(Locale locale) グループ名英字を取得します。
String | getNameSyllabary() グループ名カナを取得します。
String | getNameSyllabary(Date date) グループ名カナを取得します。
String | getNameSyllabary(Date date, Locale locale) グループ名カナを取得します。
String | getNameSyllabary(Locale locale) グループ名カナを取得します。
String | getNotes() 備考を取得します。
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
PublicGroupTerminable | getPublicGroupTerminable(Date date) 指定された日時に対する期間化情報を取得します。
PublicGroupTerminable | getPublicGroupTerminable(Term term) 指定された期間に対する期間化情報を取得します。
int | getSortKey() ソートキーを取得します。
Term[] | getTerms() このパブリックグループで管理している期間をすべて取得します。
void | putPublicGroupTerminable(Term term, PublicGroupTerminable data) 指定された期間に対する期間化情報を設定します。
void | removePublicGroupTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setDefaultLocale(Locale defaultLocale) デフォルトのロケールを設定します。
void | setNotes(String notes) 備考を設定します。
void | setPublicGroupCode(String publicGroupCode) グループコードを設定します。
void | setPublicGroupSetCode(String publicGroupSetCode) グループセットコードを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroup

public PublicGroup()
パブリックグループに関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

PublicGroup

public PublicGroup(Locale locale)
パブリックグループに関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

パラメータ:
locale - デフォルトの言語

PublicGroup

public PublicGroup(Date date)
パブリックグループに関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時

PublicGroup

public PublicGroup(Locale locale,
                   Date date)
パブリックグループに関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
locale - デフォルトの言語
date - デフォルトの日時
メソッドの詳細

getDefaultLocale

public Locale getDefaultLocale()
デフォルトのロケールを取得します。

戻り値:
デフォルトのロケール

setDefaultLocale

public void setDefaultLocale(Locale defaultLocale)
デフォルトのロケールを設定します。

パラメータ:
defaultLocale - デフォルトのロケール

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
このパブリックグループで管理している期間をすべて取得します。

戻り値:
このパブリックグループで管理している期間

getPublicGroupTerminable

public PublicGroupTerminable getPublicGroupTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getPublicGroupTerminable

public PublicGroupTerminable getPublicGroupTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putPublicGroupTerminable

public void putPublicGroupTerminable(Term term,
                                     PublicGroupTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removePublicGroupTerminable

public void removePublicGroupTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getPublicGroupSetCode

public String getPublicGroupSetCode()
グループセットコードを取得します。

戻り値:
グループセットコード

setPublicGroupSetCode

public void setPublicGroupSetCode(String publicGroupSetCode)
グループセットコードを設定します。

パラメータ:
publicGroupSetCode - グループセットコード

getPublicGroupCode

public String getPublicGroupCode()
グループコードを取得します。

戻り値:
グループコード

setPublicGroupCode

public void setPublicGroupCode(String publicGroupCode)
グループコードを設定します。

パラメータ:
publicGroupCode - グループコード

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー

getName

public String getName()
グループ名を取得します。

戻り値:
グループ名

getName

public String getName(Date date)
グループ名を取得します。

パラメータ:
date - 日時
戻り値:
グループ名

getName

public String getName(Locale locale)
グループ名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名

getName

public String getName(Date date,
                      Locale locale)
グループ名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
グループ名

getNameSyllabary

public String getNameSyllabary()
グループ名カナを取得します。

戻り値:
グループ名カナ

getNameSyllabary

public String getNameSyllabary(Date date)
グループ名カナを取得します。

パラメータ:
date - 日時
戻り値:
グループ名カナ

getNameSyllabary

public String getNameSyllabary(Locale locale)
グループ名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名カナ

getNameSyllabary

public String getNameSyllabary(Date date,
                               Locale locale)
グループ名カナを取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
グループ名カナ

getNameEnglish

public String getNameEnglish()
グループ名英字を取得します。

戻り値:
グループ名英字

getNameEnglish

public String getNameEnglish(Date date)
グループ名英字を取得します。

パラメータ:
date - 日時
戻り値:
グループ名英字

getNameEnglish

public String getNameEnglish(Locale locale)
グループ名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名英字

getNameEnglish

public String getNameEnglish(Date date,
                             Locale locale)
グループ名英字を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
グループ名英字
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupTerminable (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group
クラス PublicGroupTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable
すべての実装インタフェース:
Serializable
public class PublicGroupTerminable
extends Object
implements Serializable

パブリックグループの期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupTerminable()
メソッドの概要
Locale[] | getLocales() このパブリックグループで管理している言語（ロケール）をすべて取得します。
PublicGroupTerminableInternational | getPublicGroupTerminableInternational(Locale locale) 指定された言語に対する期間国際化情報を取得します。
void | putPublicGroupTerminableInternational(Locale locale, PublicGroupTerminableInternational data) 指定された言語に対する期間国際化情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupTerminable

public PublicGroupTerminable()
メソッドの詳細

getLocales

public Locale[] getLocales()
このパブリックグループで管理している言語（ロケール）をすべて取得します。

戻り値:
このパブリックグループで管理している言語（ロケール）

getPublicGroupTerminableInternational

public PublicGroupTerminableInternational getPublicGroupTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
期間国際化情報

putPublicGroupTerminableInternational

public void putPublicGroupTerminableInternational(Locale locale,
                                                  PublicGroupTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 期間国際化情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PublicGroupTerminableInternational (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group
クラス PublicGroupTerminableInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational
すべての実装インタフェース:
Serializable
public class PublicGroupTerminableInternational
extends Object
implements Serializable

パブリックグループの期間国際化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupTerminableInternational()
メソッドの概要
String | getName() グループ名を取得します。
String | getNameEnglish() グループ名英字を取得します。
String | getNameSyllabary() グループ名カナを取得します。
void | setName(String name) グループ名を設定します。
void | setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupTerminableInternational

public PublicGroupTerminableInternational()
メソッドの詳細

getName

public String getName()
グループ名を取得します。

戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
グループ名を設定します。

パラメータ:
name - グループ名

getNameSyllabary

public String getNameSyllabary()
グループ名カナを取得します。

戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ

getNameEnglish

public String getNameEnglish()
グループ名英字を取得します。

戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet の使用

PublicGroupSet を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での PublicGroupSet の使用

PublicGroupSet 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract void | PublicGroupManager.addGroupSet(PublicGroupSet groupSet) パブリックグループセットを登録します。
abstract void | PublicGroupManager.deleteGroupSet(PublicGroupSet groupSet) 登録済のパブリックグループセットを削除します。
void | PublicGroupChangedListener.groupSetAdded(String groupId, PublicGroupSet groupSet) グループセットがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.groupSetDeleted(String groupId, PublicGroupSet groupSet) グループセットがデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.access での PublicGroupSet の使用

PublicGroupSet 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | PublicGroupChangedControllerListener.groupSetAdded(String groupId, PublicGroupSet groupSet) グループセットがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedControllerListener.groupSetDeleted(String groupId, PublicGroupSet groupSet) グループセットがデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での PublicGroupSet の使用

PublicGroupSet 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | PublicGroupChangedMenuListener.groupSetAdded(String groupId, PublicGroupSet groupSet) グループセットがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.groupSetDeleted(String groupId, PublicGroupSet groupSet) グループセットがデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable の使用

PublicGroupSetTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set パブリックグループセット情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set での PublicGroupSetTerminable の使用

PublicGroupSetTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のメソッド
PublicGroupSetTerminable | PublicGroupSet.getPublicGroupSetTerminable(Term term) 指定された期間に対する期間化情報を取得します。
PublicGroupSetTerminable | PublicGroupSet.getPublicGroupSetTerminable(Date date) 指定された日時に対する期間化情報を取得します。

PublicGroupSetTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のメソッド
 void PublicGroupSet.putPublicGroupSetTerminable(Term term, PublicGroupSetTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational の使用

PublicGroupSetTerminableInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set パブリックグループセット情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set での PublicGroupSetTerminableInternational の使用

PublicGroupSetTerminableInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のメソッド
 PublicGroupSetTerminableInternational PublicGroupSetTerminable.getPublicGroupSetTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。

PublicGroupSetTerminableInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のメソッド
 void PublicGroupSetTerminable.putPublicGroupSetTerminableInternational(Locale locale, PublicGroupSetTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.domain.public_group.set (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.public_group.set
クラス
PublicGroupSet
PublicGroupSetTerminable
PublicGroupSetTerminableInternational


jp.co.intra_mart.foundation.datastore.application.domain.public_group.set (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.set

パブリックグループセット情報を操作するクラスを提供します。

参照:
説明

クラスの概要
PublicGroupSet | パブリックグループセットの基本属性のデータを取り扱います。
PublicGroupSetTerminable | パブリックグループセットの期間化属性のデータを取り扱います。
PublicGroupSetTerminableInternational | パブリックグループセットの期間国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.set の説明

パブリックグループセット情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.public_group.set クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.set の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.set の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set の使用

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set | パブリックグループセット情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のクラス
PublicGroupSet
パブリックグループセットの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のクラス
PublicGroupSetTerminable
パブリックグループセットの期間化属性のデータを取り扱います。
PublicGroupSetTerminableInternational
パブリックグループセットの期間国際化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のクラス
PublicGroupSet
パブリックグループセットの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のクラス
PublicGroupSet
パブリックグループセットの基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupSet (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set
クラス PublicGroupSet

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet
すべての実装インタフェース:
Serializable
public class PublicGroupSet
extends Object
implements Serializable

パブリックグループセットの基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupSet()
パブリックグループセットに関連する情報を新規に生成します。
PublicGroupSet(Date date)
パブリックグループセットに関連する情報を新規に生成します。
PublicGroupSet(Locale locale)
パブリックグループセットに関連する情報を新規に生成します。
PublicGroupSet(Locale locale, Date date)
パブリックグループセットに関連する情報を新規に生成します。
メソッドの概要
Date | getDefaultDate() デフォルトの日時を取得します。
Locale | getDefaultLocale() デフォルトのロケールを取得します。
String | getName() グループ名を取得します。
String | getName(Date date) グループ名を取得します。
String | getName(Date date, Locale locale) グループ名を取得します。
String | getName(Locale locale) グループ名を取得します。
String | getNameEnglish() グループ名英字を取得します。
String | getNameEnglish(Date date) グループ名英字を取得します。
String | getNameEnglish(Date date, Locale locale) グループ名英字を取得します。
String | getNameEnglish(Locale locale) グループ名英字を取得します。
String | getNameSyllabary() グループ名カナを取得します。
String | getNameSyllabary(Date date) グループ名カナを取得します。
String | getNameSyllabary(Date date, Locale locale) グループ名カナを取得します。
String | getNameSyllabary(Locale locale) グループ名カナを取得します。
String | getNotes() 備考を取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
PublicGroupSetTerminable | getPublicGroupSetTerminable(Date date) 指定された日時に対する期間化情報を取得します。
PublicGroupSetTerminable | getPublicGroupSetTerminable(Term term) 指定された期間に対する期間化情報を取得します。
int | getSortKey() ソートキーを取得します。
Term[] | getTerms() このパブリックグループセットで管理している期間をすべて取得します。
void | putPublicGroupSetTerminable(Term term, PublicGroupSetTerminable data) 指定された期間に対する期間化情報を設定します。
void | removePublicGroupSetTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setDefaultLocale(Locale defaultLocale) デフォルトのロケールを設定します。
void | setNotes(String notes) 備考を設定します。
void | setPublicGroupSetCode(String publicGroupSetCode) グループセットコードを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupSet

public PublicGroupSet()
パブリックグループセットに関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

PublicGroupSet

public PublicGroupSet(Locale locale)
パブリックグループセットに関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

パラメータ:
locale - デフォルトの言語

PublicGroupSet

public PublicGroupSet(Date date)
パブリックグループセットに関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時

PublicGroupSet

public PublicGroupSet(Locale locale,
                      Date date)
パブリックグループセットに関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
locale - デフォルトの言語
date - デフォルトの日時
メソッドの詳細

getDefaultLocale

public Locale getDefaultLocale()
デフォルトのロケールを取得します。

戻り値:
デフォルトのロケール

setDefaultLocale

public void setDefaultLocale(Locale defaultLocale)
デフォルトのロケールを設定します。

パラメータ:
defaultLocale - デフォルトのロケール

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
このパブリックグループセットで管理している期間をすべて取得します。

戻り値:
このパブリックグループセットで管理している期間

getPublicGroupSetTerminable

public PublicGroupSetTerminable getPublicGroupSetTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getPublicGroupSetTerminable

public PublicGroupSetTerminable getPublicGroupSetTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putPublicGroupSetTerminable

public void putPublicGroupSetTerminable(Term term,
                                        PublicGroupSetTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removePublicGroupSetTerminable

public void removePublicGroupSetTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getPublicGroupSetCode

public String getPublicGroupSetCode()
グループセットコードを取得します。

戻り値:
グループセットコード

setPublicGroupSetCode

public void setPublicGroupSetCode(String publicGroupSetCode)
グループセットコードを設定します。

パラメータ:
publicGroupSetCode - グループセットコード

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー

getName

public String getName()
グループ名を取得します。

戻り値:
グループ名

getName

public String getName(Date date)
グループ名を取得します。

パラメータ:
date - 日時
戻り値:
グループ名

getName

public String getName(Locale locale)
グループ名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名

getName

public String getName(Date date,
                      Locale locale)
グループ名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
グループ名

getNameSyllabary

public String getNameSyllabary()
グループ名カナを取得します。

戻り値:
グループ名カナ

getNameSyllabary

public String getNameSyllabary(Date date)
グループ名カナを取得します。

パラメータ:
date - 日時
戻り値:
グループ名カナ

getNameSyllabary

public String getNameSyllabary(Locale locale)
グループ名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名カナ

getNameSyllabary

public String getNameSyllabary(Date date,
                               Locale locale)
グループ名カナを取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
グループ名カナ

getNameEnglish

public String getNameEnglish()
グループ名英字を取得します。

戻り値:
グループ名英字

getNameEnglish

public String getNameEnglish(Date date)
グループ名英字を取得します。

パラメータ:
date - 日時
戻り値:
グループ名英字

getNameEnglish

public String getNameEnglish(Locale locale)
グループ名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名英字

getNameEnglish

public String getNameEnglish(Date date,
                             Locale locale)
グループ名英字を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
グループ名英字
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupSetTerminable (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set
クラス PublicGroupSetTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable
すべての実装インタフェース:
Serializable
public class PublicGroupSetTerminable
extends Object
implements Serializable

パブリックグループセットの期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupSetTerminable()
メソッドの概要
Locale[] | getLocales() このパブリックグループセットで管理している言語（ロケール）をすべて取得します。
PublicGroupSetTerminableInternational | getPublicGroupSetTerminableInternational(Locale locale) 指定された言語に対する期間国際化情報を取得します。
void | putPublicGroupSetTerminableInternational(Locale locale, PublicGroupSetTerminableInternational data) 指定された言語に対する期間国際化情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupSetTerminable

public PublicGroupSetTerminable()
メソッドの詳細

getLocales

public Locale[] getLocales()
このパブリックグループセットで管理している言語（ロケール）をすべて取得します。

戻り値:
このパブリックグループセットで管理している言語（ロケール）

getPublicGroupSetTerminableInternational

public PublicGroupSetTerminableInternational getPublicGroupSetTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
期間国際化情報

putPublicGroupSetTerminableInternational

public void putPublicGroupSetTerminableInternational(Locale locale,
                                                     PublicGroupSetTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 期間国際化情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PublicGroupSetTerminableInternational (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set
クラス PublicGroupSetTerminableInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational
すべての実装インタフェース:
Serializable
public class PublicGroupSetTerminableInternational
extends Object
implements Serializable

パブリックグループセットの期間国際化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupSetTerminableInternational()
メソッドの概要
String | getName() グループ名を取得します。
String | getNameEnglish() グループ名英字を取得します。
String | getNameSyllabary() グループ名カナを取得します。
void | setName(String name) グループ名を設定します。
void | setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupSetTerminableInternational

public PublicGroupSetTerminableInternational()
メソッドの詳細

getName

public String getName()
グループ名を取得します。

戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
グループ名を設定します。

パラメータ:
name - グループ名

getNameSyllabary

public String getNameSyllabary()
グループ名カナを取得します。

戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ

getNameEnglish

public String getNameEnglish()
グループ名英字を取得します。

戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion の使用

PublicGroupVersion を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での PublicGroupVersion の使用

PublicGroupVersion を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract PublicGroupVersion | PublicGroupManager.getVersion(String groupSet) 現在のパブリックグループセット構成バージョン情報を取得します。
abstract PublicGroupVersion | PublicGroupManager.getVersion(String groupSet, Date date) 指定された日付のパブリックグループセット構成バージョン情報を取得します。

PublicGroupVersion 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract void | PublicGroupManager.addVersion(PublicGroupVersion version) パブリックグループセット構成バージョンを新規に登録します。
abstract void | PublicGroupManager.updateVersion(PublicGroupVersion version) 登録済のパブリックグループセット構成バージョンを更新します。
abstract void | PublicGroupManager.deleteVersion(PublicGroupVersion version) 登録済のパブリックグループセット構成バージョンを削除します。
void | PublicGroupChangedListener.versionAdded(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.versionUpdated(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedListener.versionDeleted(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.access での PublicGroupVersion の使用

PublicGroupVersion 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | PublicGroupChangedControllerListener.versionAdded(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedControllerListener.versionUpdated(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedControllerListener.versionDeleted(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での PublicGroupVersion の使用

PublicGroupVersion 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | PublicGroupChangedMenuListener.versionAdded(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.versionUpdated(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedMenuListener.versionDeleted(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.domain.public_group.version (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.public_group.version
クラス
PublicGroupVersion


jp.co.intra_mart.foundation.datastore.application.domain.public_group.version (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.version

パブリックグループバージョン情報を操作するクラスを提供します。

参照:
説明

クラスの概要
PublicGroupVersion パブリックグループ構成バージョンの基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.version の説明

パブリックグループバージョン情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.public_group.version クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.version の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.version の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.version の使用

jp.co.intra_mart.foundation.datastore.application.domain.public_group.version を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.version のクラス
PublicGroupVersion
パブリックグループ構成バージョンの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.version のクラス
PublicGroupVersion
パブリックグループ構成バージョンの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.version のクラス
PublicGroupVersion
パブリックグループ構成バージョンの基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupVersion (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.version
クラス PublicGroupVersion

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion
すべての実装インタフェース:
Serializable
public class PublicGroupVersion
extends Object
implements Serializable

パブリックグループ構成バージョンの基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupVersion()
メソッドの概要
Date | getEndDate() 終了日を取得します。
String | getNotes() 備考を取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
Date | getStartDate() 開始日を取得します。
String | getVersionCode() バージョンコードを取得します。
void | setEndDate(Date endDate) 終了日を設定します。
void | setNotes(String notes) 備考を設定します。
void | setPublicGroupSetCode(String publicGroupSetCode) グループセットコードを設定します。
void | setStartDate(Date startDate) 開始日を設定します。
void | setVersionCode(String versionCode) バージョンコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupVersion

public PublicGroupVersion()
メソッドの詳細

getPublicGroupSetCode

public String getPublicGroupSetCode()
グループセットコードを取得します。

戻り値:
グループセットコード

setPublicGroupSetCode

public void setPublicGroupSetCode(String publicGroupSetCode)
グループセットコードを設定します。

パラメータ:
publicGroupSetCode - グループセットコード

getVersionCode

public String getVersionCode()
バージョンコードを取得します。

戻り値:
バージョンコード

setVersionCode

public void setVersionCode(String versionCode)
バージョンコードを設定します。

パラメータ:
versionCode - バージョンコード

getStartDate

public Date getStartDate()
開始日を取得します。

戻り値:
開始日

setStartDate

public void setStartDate(Date startDate)
開始日を設定します。

パラメータ:
startDate - 開始日

getEndDate

public Date getEndDate()
終了日を取得します。

戻り値:
終了日

setEndDate

public void setEndDate(Date endDate)
終了日を設定します。

パラメータ:
endDate - 終了日

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.public_group (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.public_group
インタフェース
PublicGroupChangedListener
PublicGroupImporter
PublicGroupStruct
クラス
PublicGroupManager
StandardPublicGroupImporter


jp.co.intra_mart.foundation.datastore.application.domain.public_group (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group

パブリックグループ情報を操作するクラスを提供します。

参照:
説明

インタフェースの概要
PublicGroupChangedListener | パブリックグループに関する情報の更新時のリスナーです。
PublicGroupImporter | パブリックグループのインポートのインターフェースです
PublicGroupStruct | 組織の階層です。

クラスの概要
PublicGroupManager | パブリックグループに関連する情報を管理します。
StandardPublicGroupImporter | パブリックグループのインポートを行います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group の説明

パブリックグループ情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.public_group クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener
  • interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group の使用

jp.co.intra_mart.foundation.datastore.application.domain.public_group を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group のクラス
PublicGroupImporter
パブリックグループのインポートのインターフェースです
PublicGroupManager
パブリックグループに関連する情報を管理します。
PublicGroupStruct
組織の階層です。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group のクラス
PublicGroupChangedListener
パブリックグループに関する情報の更新時のリスナーです。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group のクラス
PublicGroupChangedListener
パブリックグループに関する情報の更新時のリスナーです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupChangedListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group
インタフェース PublicGroupChangedListener

既知の実装クラスの一覧:
PublicGroupChangedControllerListener, PublicGroupChangedMenuListener
public interface PublicGroupChangedListener

パブリックグループに関する情報の更新時のリスナーです。

導入されたバージョン:
5.0

メソッドの概要
void | categoryDetailRemoved(String groupId, PublicGroupCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | categoryDetailSet(String groupId, PublicGroupCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | groupSetAdded(String groupId, PublicGroupSet groupSet) グループセットがデータストアに登録された後に呼び出されます。
void | groupSetDeleted(String groupId, PublicGroupSet groupSet) グループセットがデータストアから削除された後に呼び出されます。
void | init(Map params) アカウントリスナーの初期化を行います。
void | memberDeleted(String groupId, PublicGroupAttach attach) パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
void | memberSet(String groupId, PublicGroupAttach attach) パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
void | publicGroupAdded(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに登録された後に呼び出されます。
void | publicGroupDeleted(String groupId, PublicGroup publicGroup) パブリックグループがデータストアから削除された後に呼び出されます。
void | publicGroupJoined(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
void | publicGroupLeft(String groupId, String groupSet, String publicGroup, String version) パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
void | publicGroupMoved(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
void | publicGroupUpdated(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに更新された後に呼び出されます。
void | setUesrId(String userid) ログインユーザIDを設定します。
void | versionAdded(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
void | versionCopied(String groupId, String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
void | versionDeleted(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
void | versionUpdated(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。

メソッドの詳細

init

public void init(Map params)
アカウントリスナーの初期化を行います。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

パラメータ:
params - 初期化パラメータのマップ(Map)

setUesrId

public void setUesrId(String userid)
ログインユーザIDを設定します。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

パラメータ:
userid - ログインユーザID

groupSetAdded

public void groupSetAdded(String groupId,
                          PublicGroupSet groupSet)
                   throws ChangedListenerException
グループセットがデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
groupSet - グループセット
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

groupSetDeleted

public void groupSetDeleted(String groupId,
                            PublicGroupSet groupSet)
                     throws ChangedListenerException
グループセットがデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
groupSet - グループセット
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupAdded

public void publicGroupAdded(String groupId,
                             PublicGroup publicGroup)
                      throws ChangedListenerException
パブリックグループがデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupUpdated

public void publicGroupUpdated(String groupId,
                               PublicGroup publicGroup)
                        throws ChangedListenerException
パブリックグループがデータストアに更新された後に呼び出されます。

パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupDeleted

public void publicGroupDeleted(String groupId,
                               PublicGroup publicGroup)
                        throws ChangedListenerException
パブリックグループがデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupJoined

public void publicGroupJoined(String groupId,
                              String groupSet,
                              String parentGroup,
                              String publicGroup,
                              String version)
                       throws ChangedListenerException
パブリックグループ構成情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
groupSet - 上位パブリックグループと新規登録されるパブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup - 新規登録するパブリックグループの上位となるパブリックグループのグループコード（またはパブリックグループセットのグループセットコード）
publicGroup - パブリックグループ情報（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupMoved

public void publicGroupMoved(String groupId,
                             String groupSet,
                             String parentGroup,
                             String publicGroup,
                             String version)
                      throws ChangedListenerException
パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。

パラメータ:
groupId - ログイングループID
groupSet - 上位パブリックグループと移動対象のパブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup - 上位パブリックグループのグループコード（またはパブリックグループセットのグループセットコード）
publicGroup - 移動するパブリックグループのグループコード（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupLeft

public void publicGroupLeft(String groupId,
                            String groupSet,
                            String publicGroup,
                            String version)
                     throws ChangedListenerException
パブリックグループ構成情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
groupSet - グループセットコード
publicGroup - 離脱させるパブリックグループのグループコード（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailSet

public void categoryDetailSet(String groupId,
                              PublicGroupCategory category)
                       throws ChangedListenerException
分類区分情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
category - 分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailRemoved

public void categoryDetailRemoved(String groupId,
                                  PublicGroupCategory category)
                           throws ChangedListenerException
分類区分情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
category - 分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberSet

public void memberSet(String groupId,
                      PublicGroupAttach attach)
               throws ChangedListenerException
パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
attach - 割当られた人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberDeleted

public void memberDeleted(String groupId,
                          PublicGroupAttach attach)
                   throws ChangedListenerException
パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
attach - パブリックグループから外された人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionAdded

public void versionAdded(String groupId,
                         PublicGroupVersion version)
                  throws ChangedListenerException
パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
version - パブリックグループ構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionUpdated

public void versionUpdated(String groupId,
                           PublicGroupVersion version)
                    throws ChangedListenerException
パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。

パラメータ:
groupId - ログイングループID
version - パブリックグループセット構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionDeleted

public void versionDeleted(String groupId,
                           PublicGroupVersion version)
                    throws ChangedListenerException
パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
version - パブリックグループセット構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionCopied

public void versionCopied(String groupId,
                          String groupSet,
                          String srcVersion,
                          String destVersion,
                          Term term)
                   throws ChangedListenerException
登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
groupSet - コピー元、コピー先のパブリックグループセット構成バージョンのパブリックグループコード
srcVersion - コピー元のパブリックグループセット構成バージョンのバージョンコード
destVersion - コピー先のパブリックグループセット構成バージョンのバージョンコード
term - コピー先のパブリックグループセット構成バージョンの期間
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupImporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group
インタフェース PublicGroupImporter

既知の実装クラスの一覧:
StandardPublicGroupImporter
public interface PublicGroupImporter

パブリックグループのインポートのインターフェースです

導入されたバージョン:
5.0

メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。

メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PublicGroupManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group
クラス PublicGroupManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager
public abstract class PublicGroupManager
extends Object

パブリックグループに関連する情報を管理します。 このクラスのインスタンスは必ず getPublicGroupManager(String, String) で取得してください。

導入されたバージョン:
5.0

コンストラクタの概要
PublicGroupManager()
メソッドの概要
abstract void | addGroupSet(PublicGroupSet groupSet) パブリックグループセットを登録します。
abstract void | addPublicGroup(PublicGroup publicGroup) パブリックグループを登録します。
abstract void | addVersion(PublicGroupVersion version) パブリックグループセット構成バージョンを新規に登録します。
abstract void | copyVersion(String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーします。
abstract void | deleteGroupSet(PublicGroupSet groupSet) 登録済のパブリックグループセットを削除します。
abstract void | deleteMember(PublicGroupAttach attach) パブリックグループから人員をはずします。
abstract void | deletePublicGroup(PublicGroup publicGroup) 登録済のパブリックグループ情報を削除します。
abstract void | deleteVersion(PublicGroupVersion version) 登録済のパブリックグループセット構成バージョンを削除します。
abstract PublicGroup[] | getAttachedPublicGroups(String user) 現在、ユーザが所属しているパブリックグループの一覧を取得します。
abstract PublicGroup[] | getAttachedPublicGroups(String user, Date date) 指定された日付にユーザが所属しているパブリックグループの一覧を取得します。
abstract User[] | getMember(String groupSet, String publicGroup) 現在、パブリックグループに所属するる人員の一覧を取得します。
abstract User[] | getMember(String groupSet, String publicGroup, Date date) 指定された日付にパブリックグループに所属する人員の一覧を取得します。
abstract PublicGroup | getPublicGroup(String groupSet, String publicGroup) 登録済のパブリックグループを取得します。
abstract PublicGroupAttach | getPublicGroupAttach(String user, String groupSet, String publicGroup) ユーザのパブリックグループへの所属情報を取得します。
static PublicGroupManager | getPublicGroupManager(String user, String group) PublicGroupManagerを取得します。
abstract PublicGroupStruct[] | getPublicGroupStructs(String groupSet, String publicGroup, Date date, Locale locale) パブリックグループの階層構造を取得します。
abstract PublicGroupVersion | getVersion(String groupSet) 現在のパブリックグループセット構成バージョン情報を取得します。
abstract PublicGroupVersion | getVersion(String groupSet, Date date) 指定された日付のパブリックグループセット構成バージョン情報を取得します。
protected abstract void | init(String user, String group) PublicGroupManagerを初期化します。
abstract void | joinPublicGroup(String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成にパブリックグループを登録します。
abstract void | leavePublicGroup(String groupSet, String publicGroup, String version) パブリックグループ構成からパブリックグループ情報を離脱させます。
abstract void | movePublicGroup(String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成に登録済のパブリックグループ情報を移動します。
abstract void | removeCategoryDetail(PublicGroupCategory category) パブリックグループに対して指定された分類区分情報を削除します。
abstract void | setCategoryDetail(PublicGroupCategory category) パブリックグループに対して指定された分類区分情報を設定します。
abstract void | setMember(PublicGroupAttach attach) パブリックグループに人員を割り当てます。
abstract void | updatePublicGroup(PublicGroup publicGroup) 登録済のパブリックグループ情報を更新します。
abstract void | updateVersion(PublicGroupVersion version) 登録済のパブリックグループセット構成バージョンを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupManager

public PublicGroupManager()
メソッドの詳細

getPublicGroupManager

public static PublicGroupManager getPublicGroupManager(String user,
                                                       String group)
                                                throws ManagerException
PublicGroupManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するCompanyManager
例外:
ManagerException - PublicGroupManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
PublicGroupManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - 初期化に失敗

getPublicGroup

public abstract PublicGroup getPublicGroup(String groupSet,
                                           String publicGroup)
                                    throws ManagerException
登録済のパブリックグループを取得します。
グループセットコード、グループコードに一致するパブリックグループ情報が存在しない場合は nullを返します。

パラメータ:
groupSet - グループセットコード
publicGroup - グループコード
戻り値:
パブリックグループ情報
例外:
ManagerException - パブリックグループの取得に失敗
導入されたバージョン:
6.1

addGroupSet

public abstract void addGroupSet(PublicGroupSet groupSet)
                          throws ManagerException
パブリックグループセットを登録します。 このメソッドを実行すると下記のような動作が行われます。
  1. パブリックグループセットを新規登録する。
  2. パブリックグループセットに対応するパブリックグループを新規登録する。

パラメータ:
groupSet - パブリックグループセット情報
例外:
MapperException - パブリックグループセットの登録に失敗
ManagerException

deleteGroupSet

public abstract void deleteGroupSet(PublicGroupSet groupSet)
                             throws ManagerException
登録済のパブリックグループセットを削除します。 このメソッドを実行すると指定されたパブリックグループセットに関連する全ての情報が削除されます。
指定されたパブリックグループセットの情報が存在しない場合は ManagerException がスローされます。

パラメータ:
groupSet - パブリックグループセット情報
例外:
ManagerException - パブリックグループセットの削除に失敗

addPublicGroup

public abstract void addPublicGroup(PublicGroup publicGroup)
                             throws ManagerException
パブリックグループを登録します。 このメソッドを実行しただけではまだパブリックグループセットのパブリックグループ構成には追加されていません。 パブリックグループ構成に追加したい場合は joinPublicGroup(String, String, String, String)を使用してください。

パラメータ:
publicGroup - パブリックグループ情報
例外:
ManagerException - パブリックグループの登録に失敗

updatePublicGroup

public abstract void updatePublicGroup(PublicGroup publicGroup)
                                throws ManagerException
登録済のパブリックグループ情報を更新します。

パラメータ:
publicGroup - パブリックグループ情報
例外:
ManagerException - パブリックグループの更新に失敗

deletePublicGroup

public abstract void deletePublicGroup(PublicGroup publicGroup)
                                throws ManagerException
登録済のパブリックグループ情報を削除します。
指定されたパブリックグループの情報が存在しない場合は ManagerException がスローされます。

パラメータ:
publicGroup - パブリックグループ情報
例外:
ManagerException - パブリックグループの削除に失敗

joinPublicGroup

public abstract void joinPublicGroup(String groupSet,
                                     String parentGroup,
                                     String publicGroup,
                                     String version)
                              throws ManagerException
パブリックグループ構成にパブリックグループを登録します。 新しく親となるパブリックグループと登録対象のパブリックグループは同一のパブリックグループセットに所属している必要があります。
バージョンコードは登録済みのものを指定する必要があります。 親となるパブリックグループは、パブリックグループ内包に登録済みのものを指定する必要があります
指定されたパブリックグループが対象のバージョンにおいて既に登録されているときはこのメソッドは使用できません。

パラメータ:
groupSet - 上位パブリックグループと新規登録されるパブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup - 新規登録するパブリックグループの上位となるパブリックグループのグループコード（またはパブリックグループセットのグループセットコード）
publicGroup - パブリックグループ情報（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ManagerException - パブリックグループ構成にパブリックグループの登録に失敗

movePublicGroup

public abstract void movePublicGroup(String groupSet,
                                     String parentGroup,
                                     String publicGroup,
                                     String version)
                              throws ManagerException
パブリックグループ構成に登録済のパブリックグループ情報を移動します。 新しく上位となるパブリックグループと移動対象のパブリックグループは同一のパブリックグループセットに所属している必要があります。
また、パブリックグループ構成が循環するような移動はできません。 バージョンコードは登録済みのものを指定する必要があります

パラメータ:
groupSet - 上位パブリックグループと移動対象のパブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup - 上位パブリックグループのグループコード（またはパブリックグループセットのグループセットコード）
publicGroup - 移動するパブリックグループのグループコード（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ManagerException - パブリックグループの移動に失敗

leavePublicGroup

public abstract void leavePublicGroup(String groupSet,
                                      String publicGroup,
                                      String version)
                               throws ManagerException
パブリックグループ構成からパブリックグループ情報を離脱させます。 このメソッドを実行すると、指定されたパブリックグループを指定されたバージョンから削除します。 指定されたパブリックグループが子パブリックグループを持っていた場合、それらのパブリックグループも再帰的にこのバージョンから削除されます。 このメソッドを実行してもパブリックグループ情報そのものは残ります。
指定されたパブリックグループがグループ構成に登録されていない場合は ManagerException がスローされます。

パラメータ:
groupSet - グループセットコード
publicGroup - 離脱させるパブリックグループのグループコード（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ManagerException - パブリックグループ構成からパブリックグループの離脱の失敗

setCategoryDetail

public abstract void setCategoryDetail(PublicGroupCategory category)
                                throws ManagerException
パブリックグループに対して指定された分類区分情報を設定します。

パラメータ:
category - 設定する分類区分詳細情報
例外:
ManagerException - 分類区分情報の設定に失敗

removeCategoryDetail

public abstract void removeCategoryDetail(PublicGroupCategory category)
                                   throws ManagerException
パブリックグループに対して指定された分類区分情報を削除します。 指定された分類区分情報が存在しない場合は ManagerException がスローされます。

パラメータ:
category - 削除する分類区分詳細詳細情報
例外:
ManagerException - パブリックグループに対して指定された分類区分情報の削除に失敗

setMember

public abstract void setMember(PublicGroupAttach attach)
                        throws ManagerException
パブリックグループに人員を割り当てます。 人員の割当情報はパラメータで渡された情報で完全に上書きされます。

パラメータ:
attach - 割当人員の情報
例外:
ManagerException - 人員の割当に失敗

deleteMember

public abstract void deleteMember(PublicGroupAttach attach)
                           throws ManagerException
パブリックグループから人員をはずします。 削除対象となる期間は無限の過去から無限の未来となります。
指定された人員がパブリックグループに割り当てられていない場合は ManagerException がスローされます。

パラメータ:
attach - パブリックグループから外す人員の情報
例外:
ManagerException - パブリックグループから人員を外すことに失敗

getMember

public abstract User[] getMember(String groupSet,
                                 String publicGroup)
                          throws ManagerException
現在、パブリックグループに所属するる人員の一覧を取得します。
指定されたパブリックグループに人員が所属していない場合は空の配列を返します。

取得されるユーザの期間化情報には、システム日付を含む期間の情報のみが設定されます。
また期間国際化情報には、ログインユーザのデフォルト言語の情報のみが設定されます。

パラメータ:
groupSet - グループセットコード
publicGroup - グループコード
戻り値:
ユーザ情報
例外:
ManagerException - パブリックグループに所属する人員の取得に失敗
導入されたバージョン:
6.1

getMember

public abstract User[] getMember(String groupSet,
                                 String publicGroup,
                                 Date date)
                          throws ManagerException
指定された日付にパブリックグループに所属する人員の一覧を取得します。
指定されたパブリックグループに人員が所属していない場合は空の配列を返します。

取得されるユーザの期間化情報には、指定された日付を含む期間の情報のみが設定されます。
また期間国際化情報には、ログインユーザのデフォルト言語の情報のみが設定されます。

パラメータ:
groupSet - グループセットコード
publicGroup - グループコード
date - 日付
戻り値:
ユーザ情報
例外:
ManagerException - パブリックグループに所属する人員の取得に失敗
導入されたバージョン:
6.1

addVersion

public abstract void addVersion(PublicGroupVersion version)
                         throws ManagerException
パブリックグループセット構成バージョンを新規に登録します。 追加された構成バージョンのトップレベルには、パブリックグループセットが自動的に追加されます。

パラメータ:
version - バージョン情報
例外:
ManagerException - パブリックグループセット構成バージョンの登録に失敗

updateVersion

public abstract void updateVersion(PublicGroupVersion version)
                            throws ManagerException
登録済のパブリックグループセット構成バージョンを更新します。

パラメータ:
version - バージョン情報
例外:
ManagerException - パブリックグループセット構成バージョンの更新に失敗

deleteVersion

public abstract void deleteVersion(PublicGroupVersion version)
                            throws ManagerException
登録済のパブリックグループセット構成バージョンを削除します。
指定されたパブリックグループセット構成バージョンが存在しない場合は ManagerException がスローされます。

パラメータ:
version - バージョン情報
例外:
ManagerException - パブリックグループセット構成バージョンの削除に失敗

copyVersion

public abstract void copyVersion(String groupSet,
                                 String srcVersion,
                                 String destVersion,
                                 Term term)
                          throws ManagerException
登録済のパブリックグループセット構成バージョンの内容をコピーします。 コピー元のバージョンコードは登録済みのものを選択してください コピー先のバージョンコードは登録されていないものを選択してください

パラメータ:
groupSet - コピー元、コピー先のパブリックグループセット構成バージョンのグループセットコード
srcVersion - コピー元のパブリックグループセット構成バージョンのバージョンコード
destVersion - コピー先のパブリックグループセット構成バージョンのバージョンコード
term - コピー先のパブリックグループセット構成バージョンの期間
例外:
ManagerException - パブリックグループセット構成バージョンのコピーに失敗

getPublicGroupStructs

public abstract PublicGroupStruct[] getPublicGroupStructs(String groupSet,
                                                          String publicGroup,
                                                          Date date,
                                                          Locale locale)
                                                   throws ManagerException
パブリックグループの階層構造を取得します。 指定された日付に該当する、パブリックグループ構成バージョンがない時はエラーとなります。

パラメータ:
groupSet - グループセットコード
publicGroup - グループコード
date - 日付
locale - 言語(ロケール)
戻り値:
パブリックグループの階層構造
例外:
ManagerException - パブリックグループの階層構造の取得に失敗

getAttachedPublicGroups

public abstract PublicGroup[] getAttachedPublicGroups(String user)
                                               throws ManagerException
現在、ユーザが所属しているパブリックグループの一覧を取得します。
ユーザがどのパブリックグループにも所属していない場合は空の配列を返します。

取得されるパブリックグループの期間化情報には、システム日付を含む期間の情報のみが設定されます。
また期間国際化情報には、ログインユーザのデフォルト言語の情報のみが設定されます。

パラメータ:
user - ユーザコード
戻り値:
パブリックグループ情報
例外:
ManagerException - 指定されたユーザが所属しているパブリックグループの取得に失敗
導入されたバージョン:
6.1

getAttachedPublicGroups

public abstract PublicGroup[] getAttachedPublicGroups(String user,
                                                      Date date)
                                               throws ManagerException
指定された日付にユーザが所属しているパブリックグループの一覧を取得します。
ユーザがどのパブリックグループにも所属していない場合は空の配列を返します。

取得されるパブリックグループの期間化情報には、指定された日付を含む期間の情報のみが設定されます。
また期間国際化情報には、ログインユーザのデフォルト言語の情報のみが設定されます。

パラメータ:
user - ユーザコード
date - 日付
戻り値:
パブリックグループ情報
例外:
ManagerException - 指定されたユーザが所属しているパブリックグループの取得に失敗
導入されたバージョン:
6.1

getPublicGroupAttach

public abstract PublicGroupAttach getPublicGroupAttach(String user,
                                                       String groupSet,
                                                       String publicGroup)
                                                throws ManagerException
ユーザのパブリックグループへの所属情報を取得します。
該当するパブリックグループ所属が存在しない場合は nullを返します。

パラメータ:
user - ユーザコード
groupSet - パブリックグループセットコード
publicGroup - パブリックグループコード
戻り値:
パブリックグループ所属情報
例外:
ManagerException - パブリックグループ所属情報の取得に失敗
導入されたバージョン:
6.1

getVersion

public abstract PublicGroupVersion getVersion(String groupSet)
                                       throws ManagerException
現在のパブリックグループセット構成バージョン情報を取得します。
該当するパブリックグループセット構成バージョン情報が存在しない場合は null を返します。

パラメータ:
groupSet - パブリックグループセットコード
戻り値:
パブリックグループセット構成バージョン情報
例外:
ManagerException
導入されたバージョン:
6.1

getVersion

public abstract PublicGroupVersion getVersion(String groupSet,
                                              Date date)
                                       throws ManagerException
指定された日付のパブリックグループセット構成バージョン情報を取得します。
該当するパブリックグループセット構成バージョン情報が存在しない場合は null を返します。

パラメータ:
groupSet - パブリックグループセットコード
date - バージョンを特定する日付
戻り値:
パブリックグループセット構成バージョン情報
例外:
ManagerException
導入されたバージョン:
6.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupStruct (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group
インタフェース PublicGroupStruct

public interface PublicGroupStruct

組織の階層です。

導入されたバージョン:
5.0

メソッドの概要
String | getName() グループ名を取得します。
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。

メソッドの詳細

getPublicGroupSetCode

public String getPublicGroupSetCode()
グループセットコードを取得します。

戻り値:
グループセットコード

getPublicGroupCode

public String getPublicGroupCode()
グループコードを取得します。

戻り値:
グループコード

getName

public String getName()
グループ名を取得します。

戻り値:
グループ名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


StandardPublicGroupImporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group
クラス StandardPublicGroupImporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter
すべての実装インタフェース:
PublicGroupImporter
public class StandardPublicGroupImporter
extends Object
implements PublicGroupImporter

パブリックグループのインポートを行います。

導入されたバージョン:
5.0

コンストラクタの概要
StandardPublicGroupImporter()
メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardPublicGroupImporter

public StandardPublicGroupImporter()
メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

定義:
インタフェース PublicGroupImporter 内の doImport
パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager の使用

ItemUnitManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.unit 商品単位情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.unit での ItemUnitManager の使用

ItemUnitManager を返す jp.co.intra_mart.foundation.datastore.application.domain.unit のメソッド
static ItemUnitManager ItemUnitManager.getItemUnitManager(String user, String group)
ItemUnitManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemUnitManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.unit
クラス ItemUnitManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager
public abstract class ItemUnitManager
extends Object

商品の単位を取り扱います。

導入されたバージョン:
5.1

コンストラクタの概要
ItemUnitManager()
メソッドの概要
abstract boolean | addUnit(String unitCode, String unitName) 単位を追加します。
abstract void | deleteUnit(String unitCode) 単位を削除します。
static ItemUnitManager | getItemUnitManager(String user, String group) ItemUnitManagerを取得します。
abstract String | getUnitCode(String unitName) 単位名に対する単位コードを取得します。
abstract String | getUnitName(String unitCode) 単位コードに対する名称を返します。
abstract Map | getUnits() 単位の一覧を取得します。
protected abstract void | init(String user, String group) ItemUnitManagerを初期化します。
abstract boolean | updateUnit(String unitCode, String unitName) 単位を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemUnitManager

public ItemUnitManager()
メソッドの詳細

getItemUnitManager

public static ItemUnitManager getItemUnitManager(String user,
                                                 String group)
                                          throws ManagerException
ItemUnitManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するItemUnitManager
例外:
ManagerException - ItemUnitManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
ItemUnitManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - 初期化に失敗

getUnits

public abstract Map getUnits()
                      throws ManagerException
単位の一覧を取得します。 返却されるマップ Mapのキーには単位コード、値には単位名が設定されます。

戻り値:
単位コードの一覧
例外:
ManagerException - 単位の取得に失敗した場合

getUnitName

public abstract String getUnitName(String unitCode)
                            throws ManagerException
単位コードに対する名称を返します。 単位コードに対する名称が存在しない場合は、nullを返します。

パラメータ:
unitCode - 単位コード
戻り値:
単位名
例外:
ManagerException - 単位名の取得に失敗した場合

getUnitCode

public abstract String getUnitCode(String unitName)
                            throws ManagerException
単位名に対する単位コードを取得します。 単位名に対する単位コードが存在しない場合は、nullを返します。

パラメータ:
unitName - 単位名
戻り値:
単位コード
例外:
ManagerException - 単位コードの取得に失敗した場合

addUnit

public abstract boolean addUnit(String unitCode,
                                String unitName)
                         throws ManagerException
単位を追加します。

すでに同一の単位名のものが存在している場合は、登録を行いません。
その場合はfalseを返します。

パラメータ:
unitCode - 単位コード
unitName - 単位名
戻り値:
単位の登録を行った場合はtrue、行わなかった場合はfalse
例外:
ManagerException - 単位の追加に失敗した場合

updateUnit

public abstract boolean updateUnit(String unitCode,
                                   String unitName)
                            throws ManagerException
単位を更新します。 すでに同一の単位名のものが存在している場合は、更新を行いません。
その場合はfalseを返します。

パラメータ:
unitCode - 単位コード
unitName - 単位名
戻り値:
単位の更新を行った場合はtrue、行わなかった場合はfalse
例外:
ManagerException - 単位の更新に失敗した場合

deleteUnit

public abstract void deleteUnit(String unitCode)
                         throws ManagerException
単位を削除します。
指定された単位情報が存在しない場合は ManagerException がスローされます。

パラメータ:
unitCode - 単位コード
例外:
ManagerException - 単位の削除に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.unit (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.unit
クラス
ItemUnitManager


jp.co.intra_mart.foundation.datastore.application.domain.unit (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.unit

商品単位情報を操作するクラスを提供します。

参照:
説明

クラスの概要
ItemUnitManager 商品の単位を取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.unit の説明

商品単位情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.unit クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.unit の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.unit の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.unit の使用

jp.co.intra_mart.foundation.datastore.application.domain.unit を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.unit 商品単位情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.unit により使用される jp.co.intra_mart.foundation.datastore.application.domain.unit のクラス
ItemUnitManager
商品の単位を取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter の使用

jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.user.User の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.user.User の使用

User を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group | プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での User の使用

User を返す jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract User[] | CompanyManager.getMember(String company, String department) 現在、組織に所属するる人員の一覧を取得します。
abstract User[] | CompanyManager.getMember(String company, String department, Date date) 指定された日付に組織に所属する人員の一覧を取得します。

jp.co.intra_mart.foundation.datastore.application.domain.private_group での User の使用

User を返す jp.co.intra_mart.foundation.datastore.application.domain.private_group のメソッド
abstract User[] | PrivateGroupManager.getMember(String owner, String group) ログインユーザが持つ指定されたプライベートグループに所属する人員を取得します。
abstract User[] | PrivateGroupManager.getMember(String owner, String group, Date date) 指定されたプライベートグループに所属する人員を取得します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での User の使用

User を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract User[] | PublicGroupManager.getMember(String groupSet, String publicGroup) 現在、パブリックグループに所属するる人員の一覧を取得します。
abstract User[] | PublicGroupManager.getMember(String groupSet, String publicGroup, Date date) 指定された日付にパブリックグループに所属する人員の一覧を取得します。

jp.co.intra_mart.foundation.datastore.application.domain.user での User の使用

User を返す jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
abstract  User UserManager.getUser(String userCode)
登録済のユーザを取得します。

User 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
abstract void | UserManager.addUser(User user) ユーザを登録します。
abstract void | UserManager.updateUser(User user) 登録済のユーザを更新します。
abstract void | UserManager.deleteUser(User user) 登録済のユーザを削除します。
void | UserChangedListener.userAdded(String groupId, User user) ユーザ情報がデータストアに登録された後に呼び出されます。
void | UserChangedListener.userUpdated(String groupId, User user) ユーザ情報がデータストアに対して更新された後に呼び出されます。
void | UserChangedListener.userDeleted(String groupId, User user) ユーザ情報がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener の使用

jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter の使用

UserImporter を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.user ユーザ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.user での UserImporter の使用

UserImporter を実装している jp.co.intra_mart.foundation.datastore.application.domain.user のクラス
 class StandardUserImporter
ユーザプロファイルのインポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager の使用

UserManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.user ユーザ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.user での UserManager の使用

UserManager を返す jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
static UserManager UserManager.getUserManager(String user, String group)
UserManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable の使用

UserTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.user ユーザ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.user での UserTerminable の使用

UserTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
UserTerminable | User.getUserTerminable(Term term) 指定された期間に対する期間化情報を取得します。
UserTerminable | User.getUserTerminable(Date date) 指定された日時に対する期間化情報を取得します。

UserTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
 void User.putUserTerminable(Term term, UserTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational の使用

UserTerminableInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.user ユーザ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.user での UserTerminableInternational の使用

UserTerminableInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
 UserTerminableInternational UserTerminable.getUserTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。

UserTerminableInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
 void UserTerminable.putUserTerminableInternational(Locale locale, UserTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.domain.user (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.user
インタフェース
UserChangedListener
UserImporter
クラス
StandardUserImporter
User
UserManager
UserTerminable
UserTerminableInternational


jp.co.intra_mart.foundation.datastore.application.domain.user (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.user

ユーザ情報を操作するクラスを提供します。

参照:
説明

インタフェースの概要
UserChangedListener | ユーザに関する情報の変更時のリスナーです。
UserImporter | ユーザインポーターのインタフェースです。

クラスの概要
StandardUserImporter | ユーザプロファイルのインポートを行います。
User | ユーザの基本属性のデータを取り扱います。
UserManager | ユーザに関連する情報を管理します。
UserTerminable | ユーザの期間化属性のデータを取り扱います。
UserTerminableInternational | ユーザの期間国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.user の説明

ユーザ情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.user クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.user の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.User (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational (implements java.io.Serializable)

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener
  • interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.user の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.user の使用

jp.co.intra_mart.foundation.datastore.application.domain.user を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group | プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.user のクラス
User
ユーザの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.private_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.user のクラス
User
ユーザの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.user のクラス
User
ユーザの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.user により使用される jp.co.intra_mart.foundation.datastore.application.domain.user のクラス
User
ユーザの基本属性のデータを取り扱います。
UserImporter
ユーザインポーターのインタフェースです。
UserManager
ユーザに関連する情報を管理します。
UserTerminable
ユーザの期間化属性のデータを取り扱います。
UserTerminableInternational
ユーザの期間国際化属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardUserImporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.user
クラス StandardUserImporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter
すべての実装インタフェース:
UserImporter
public class StandardUserImporter
extends Object
implements UserImporter

ユーザプロファイルのインポートを行います。

導入されたバージョン:
5.0

コンストラクタの概要
StandardUserImporter()
メソッドの概要
 void doImport(InputStream inputStream, String user, String group)
インポートを行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardUserImporter

public StandardUserImporter()
メソッドの詳細

doImport

public void doImport(InputStream inputStream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

定義:
インタフェース UserImporter 内の doImport
パラメータ:
inputStream - 入力ストリーム
user - ログインユーザ
group - ログイングループ
例外:
ImportException - インポートに失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


User (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.user
クラス User

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.user.User
すべての実装インタフェース:
Serializable
public class User
extends Object
implements Serializable

ユーザの基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
User()
ユーザに関連する情報を新規に生成します。
User(Date date)
ユーザに関連する情報を新規に生成します。
User(Locale locale)
ユーザに関連する情報を新規に生成します。
User(Locale locale, Date date)
ユーザに関連する情報を新規に生成します。
メソッドの概要
String | getAccountFlag() アカウントフラグを取得します。
String | getAddress() 住所を取得します。
String | getAddress(Date date) 住所を取得します。
String | getAddress(Date date, Locale locale) 住所を取得します。
String | getAddress(Locale locale) 住所を取得します。
String | getCountryCode() 国コードを取得します。
String | getCountryCode(Date date) 国コードを取得します。
Date | getDefaultDate() デフォルトの日時を取得します。
Locale | getDefaultLocale() デフォルトのロケールを取得します。
String | getEmailAddress1() メールアドレス１を取得します。
String | getEmailAddress1(Date date) メールアドレス１を取得します。
String | getEmailAddress2() メールアドレス２を取得します。
String | getEmailAddress2(Date date) メールアドレス２を取得します。
Map | getExtendedUser(String name) 指定された拡張情報を取得します。
Map | getExtendedUsers() このユーザの基本情報に対する拡張情報をすべて取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionFaxNumber(Date date) 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getExtensionNumber(Date date) 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
String | getFaxNumber(Date date) FAX番号を取得します。
String | getMobileEmailAddress() 携帯用メールを取得します。
String | getMobileEmailAddress(Date date) 携帯用メールを取得します。
String | getMobileNumber() 携帯電話番号を取得します。
String | getMobileNumber(Date date) 携帯電話番号を取得します。
String | getName() ユーザ名を取得します。
String | getName(Date date) ユーザ名を取得します。
String | getName(Date date, Locale locale) ユーザ名を取得します。
String | getName(Locale locale) ユーザ名を取得します。
String | getNameEnglish() ユーザ名英字を取得します。
String | getNameEnglish(Date date) ユーザ名英字を取得します。
String | getNameEnglish(Date date, Locale locale) ユーザ名英字を取得します。
String | getNameEnglish(Locale locale) ユーザ名英字を取得します。
String | getNameSyllabary() ユーザ名カナを取得します。
String | getNameSyllabary(Date date) ユーザ名カナを取得します。
String | getNameSyllabary(Date date, Locale locale) ユーザ名カナを取得します。
String | getNameSyllabary(Locale locale) ユーザ名カナを取得します。
String | getNotes() 備考を取得します。
int | getSortKey() ソートキーを取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getTelephoneNumber(Date date) 電話番号を取得します。
Term[] | getTerms() このユーザで管理している期間をすべて取得します。
String | getUrl() URLを取得します。
String | getUrl(Date date) URLを取得します。
String | getUserCode() ユーザコードを取得します。
UserTerminable | getUserTerminable(Date date) 指定された日時に対する期間化情報を取得します。
UserTerminable | getUserTerminable(Term term) 指定された期間に対する期間化情報を取得します。
String | getZipCode() 郵便番号を取得します。
String | getZipCode(Date date) 郵便番号を取得します。
void | putExtendedUser(String name, Map data) 指定された拡張情報を追加します。
void | putUserTerminable(Term term, UserTerminable data) 指定された期間に対する期間化情報を設定します。
void | removeUserTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setAccountFlag(String accountFlag) このメソッドはシステム内で使用されます。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setDefaultLocale(Locale defaultLocale) デフォルトのロケールを設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
void | setUserCode(String userCode) ユーザコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

User

public User()
ユーザに関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

User

public User(Locale locale)
ユーザに関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

パラメータ:
locale - デフォルトの言語

User

public User(Date date)
ユーザに関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時

User

public User(Locale locale,
            Date date)
ユーザに関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
locale - デフォルトの言語
date - デフォルトの日時
メソッドの詳細

getDefaultLocale

public Locale getDefaultLocale()
デフォルトのロケールを取得します。

戻り値:
デフォルトのロケール

setDefaultLocale

public void setDefaultLocale(Locale defaultLocale)
デフォルトのロケールを設定します。

パラメータ:
defaultLocale - デフォルトのロケール

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
このユーザで管理している期間をすべて取得します。

戻り値:
このユーザで管理している期間

getUserTerminable

public UserTerminable getUserTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getUserTerminable

public UserTerminable getUserTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putUserTerminable

public void putUserTerminable(Term term,
                              UserTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removeUserTerminable

public void removeUserTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getExtendedUsers

public Map getExtendedUsers()
このユーザの基本情報に対する拡張情報をすべて取得します。 返される値は拡張名をキー、 拡張情報を値とした Mapです。

戻り値:
基本情報に対するすべての拡張情報
導入されたバージョン:
5.1.5

getExtendedUser

public Map getExtendedUser(String name)
指定された拡張情報を取得します。

パラメータ:
name - 拡張名
戻り値:
基本情報に対する拡張情報
導入されたバージョン:
5.1.5

putExtendedUser

public void putExtendedUser(String name,
                            Map data)
指定された拡張情報を追加します。 返される値は属性名をキー、 属性値を値とした Mapです。

パラメータ:
name - 拡張名
data - 基本情報に対する拡張情報
導入されたバージョン:
5.1.5

getUserCode

public String getUserCode()
ユーザコードを取得します。

戻り値:
ユーザコード

setUserCode

public void setUserCode(String userCode)
ユーザコードを設定します。

パラメータ:
userCode - ユーザコード

getAccountFlag

public String getAccountFlag()
アカウントフラグを取得します。

戻り値:
アカウントフラグ

setAccountFlag

public void setAccountFlag(String accountFlag)
このメソッドはシステム内で使用されます。明示的に使用しないでください。

パラメータ:
accountFlag - アカウントフラグ

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー

getTelephoneNumber

public String getTelephoneNumber()
電話番号を取得します。

戻り値:
電話番号

getTelephoneNumber

public String getTelephoneNumber(Date date)
電話番号を取得します。

パラメータ:
date - 日時
戻り値:
電話番号

getMobileNumber

public String getMobileNumber()
携帯電話番号を取得します。

戻り値:
携帯電話番号

getMobileNumber

public String getMobileNumber(Date date)
携帯電話番号を取得します。

パラメータ:
date - 日時
戻り値:
携帯電話番号

getFaxNumber

public String getFaxNumber()
FAX番号を取得します。

戻り値:
FAX番号

getFaxNumber

public String getFaxNumber(Date date)
FAX番号を取得します。

パラメータ:
date - 日時
戻り値:
FAX番号

getExtensionNumber

public String getExtensionNumber()
内線番号を取得します。

戻り値:
内線番号

getExtensionNumber

public String getExtensionNumber(Date date)
内線番号を取得します。

パラメータ:
date - 日時
戻り値:
内線番号

getExtensionFaxNumber

public String getExtensionFaxNumber()
内線FAX番号を取得します。

戻り値:
内線FAX番号

getExtensionFaxNumber

public String getExtensionFaxNumber(Date date)
内線FAX番号を取得します。

パラメータ:
date - 日時
戻り値:
内線FAX番号

getCountryCode

public String getCountryCode()
国コードを取得します。

戻り値:
国コード

getCountryCode

public String getCountryCode(Date date)
国コードを取得します。

パラメータ:
date - 日時
戻り値:
国コード

getZipCode

public String getZipCode()
郵便番号を取得します。

戻り値:
郵便番号

getZipCode

public String getZipCode(Date date)
郵便番号を取得します。

パラメータ:
date - 日時
戻り値:
郵便番号

getEmailAddress1

public String getEmailAddress1()
メールアドレス１を取得します。

戻り値:
メールアドレス１

getEmailAddress1

public String getEmailAddress1(Date date)
メールアドレス１を取得します。

パラメータ:
date - 日時
戻り値:
メールアドレス１

getEmailAddress2

public String getEmailAddress2()
メールアドレス２を取得します。

戻り値:
メールアドレス２

getEmailAddress2

public String getEmailAddress2(Date date)
メールアドレス２を取得します。

パラメータ:
date - 日時
戻り値:
メールアドレス２

getMobileEmailAddress

public String getMobileEmailAddress()
携帯用メールを取得します。

戻り値:
携帯用メール

getMobileEmailAddress

public String getMobileEmailAddress(Date date)
携帯用メールを取得します。

パラメータ:
date - 日時
戻り値:
携帯用メール

getUrl

public String getUrl()
URLを取得します。

戻り値:
URL

getUrl

public String getUrl(Date date)
URLを取得します。

パラメータ:
date - 日時
戻り値:
URL

getName

public String getName()
ユーザ名を取得します。

戻り値:
ユーザ名

getName

public String getName(Date date)
ユーザ名を取得します。

パラメータ:
date - 日時
戻り値:
ユーザ名

getName

public String getName(Locale locale)
ユーザ名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザ名

getName

public String getName(Date date,
                      Locale locale)
ユーザ名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
ユーザ名

getNameSyllabary

public String getNameSyllabary()
ユーザ名カナを取得します。

戻り値:
ユーザ名カナ

getNameSyllabary

public String getNameSyllabary(Date date)
ユーザ名カナを取得します。

パラメータ:
date - 日時
戻り値:
ユーザ名カナ

getNameSyllabary

public String getNameSyllabary(Locale locale)
ユーザ名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザ名カナ

getNameSyllabary

public String getNameSyllabary(Date date,
                               Locale locale)
ユーザ名カナを取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
ユーザ名カナ

getNameEnglish

public String getNameEnglish()
ユーザ名英字を取得します。

戻り値:
ユーザ名英字

getNameEnglish

public String getNameEnglish(Date date)
ユーザ名英字を取得します。

パラメータ:
date - 日時
戻り値:
ユーザ名英字

getNameEnglish

public String getNameEnglish(Locale locale)
ユーザ名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザ名英字

getNameEnglish

public String getNameEnglish(Date date,
                             Locale locale)
ユーザ名英字を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
ユーザ名英字

getAddress

public String getAddress()
住所を取得します。

戻り値:
住所

getAddress

public String getAddress(Date date)
住所を取得します。

パラメータ:
date - 日時
戻り値:
住所

getAddress

public String getAddress(Locale locale)
住所を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所

getAddress

public String getAddress(Date date,
                         Locale locale)
住所を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
住所
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserChangedListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.user
インタフェース UserChangedListener

public interface UserChangedListener

ユーザに関する情報の変更時のリスナーです。

導入されたバージョン:
5.0

メソッドの概要
void | init(Map params) ユーザリスナーの初期化を行います。
void | setUesrId(String userid) ログインユーザIDを設定します。
void | userAdded(String groupId, User user) ユーザ情報がデータストアに登録された後に呼び出されます。
void | userDeleted(String groupId, User user) ユーザ情報がデータストアから削除された後に呼び出されます。
void | userUpdated(String groupId, User user) ユーザ情報がデータストアに対して更新された後に呼び出されます。

メソッドの詳細

init

public void init(Map params)
ユーザリスナーの初期化を行います。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

パラメータ:
params - 初期化パラメータのマップ(Map)

setUesrId

public void setUesrId(String userid)
ログインユーザIDを設定します。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

パラメータ:
userid - ログインユーザID

userAdded

public void userAdded(String groupId,
                      User user)
               throws ChangedListenerException
ユーザ情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
user - ユーザ情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

userUpdated

public void userUpdated(String groupId,
                        User user)
                 throws ChangedListenerException
ユーザ情報がデータストアに対して更新された後に呼び出されます。

パラメータ:
groupId - ログイングループID
user - ユーザ情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

userDeleted

public void userDeleted(String groupId,
                        User user)
                 throws ChangedListenerException
ユーザ情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
user - ユーザ情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UserImporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.user
インタフェース UserImporter

既知の実装クラスの一覧:
StandardUserImporter
public interface UserImporter

ユーザインポーターのインタフェースです。

導入されたバージョン:
5.0

メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。

メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

パラメータ:
inputstream - 入力ストリーム
user - ログインユーザ
group - ログイングループ
例外:
ImportException - インポートに失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UserManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.user
クラス UserManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager
public abstract class UserManager
extends Object

ユーザに関連する情報を管理します。 このクラスのインスタンスは必ず getUserManager(String,String) で取得してください。

導入されたバージョン:
5.0

コンストラクタの概要
UserManager()
メソッドの概要
abstract void | addUser(User user) ユーザを登録します。
abstract void | deleteUser(User user) 登録済のユーザを削除します。
abstract User | getUser(String userCode) 登録済のユーザを取得します。
static UserManager | getUserManager(String user, String group) UserManagerを取得します。
protected abstract void | init(String user, String group) UserManagerを初期化します。
abstract void | updateUser(User user) 登録済のユーザを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserManager

public UserManager()
メソッドの詳細

getUserManager

public static UserManager getUserManager(String user,
                                         String group)
                                  throws ManagerException
UserManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するUserManager
例外:
ManagerException - UserManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
UserManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - UserManagerの初期化に失敗

getUser

public abstract User getUser(String userCode)
                      throws ManagerException
登録済のユーザを取得します。
指定されたユーザコードに一致するユーザ情報が存在しない場合は null を返します。

パラメータ:
userCode - ユーザコード
戻り値:
ユーザ情報
例外:
ManagerException - ユーザ情報の取得に失敗
導入されたバージョン:
5.1

addUser

public abstract void addUser(User user)
                      throws ManagerException
ユーザを登録します。

パラメータ:
user - ユーザ情報
例外:
ManagerException - UserManagerのユーザ情報の登録に失敗

updateUser

public abstract void updateUser(User user)
                         throws ManagerException
登録済のユーザを更新します。

パラメータ:
user - ユーザ情報
例外:
ManagerException - UserManagerのユーザ情報の更新に失敗

deleteUser

public abstract void deleteUser(User user)
                         throws ManagerException
登録済のユーザを削除します。
指定されたユーザの情報が存在しない場合は ManagerException がスローされます。

パラメータ:
user - ユーザ情報
例外:
ManagerException - UserManagerのユーザ情報の削除に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserTerminable (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.user
クラス UserTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable
すべての実装インタフェース:
Serializable
public class UserTerminable
extends Object
implements Serializable

ユーザの期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
UserTerminable()
メソッドの概要
String | getCountryCode() 国コードを取得します。
String | getEmailAddress1() メールアドレス１を取得します。
String | getEmailAddress2() メールアドレス２を取得します。
Map | getExtendedUserTerminable(String name) 指定された拡張情報を取得します。
Map | getExtendedUserTerminables() このユーザの期間化情報に対する拡張情報をすべて取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
Locale[] | getLocales() このユーザで管理している言語（ロケール）をすべて取得します。
String | getMobileEmailAddress() 携帯用メールを取得します。
String | getMobileNumber() 携帯電話番号を取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getUrl() URLを取得します。
UserTerminableInternational | getUserTerminableInternational(Locale locale) 指定された言語に対する期間国際化情報を取得します。
String | getZipCode() 郵便番号を取得します。
void | putExtendedUserTerminable(String name, Map data) 指定された拡張情報を追加します。
void | putUserTerminableInternational(Locale locale, UserTerminableInternational data) 指定された言語に対する期間国際化情報を設定します。
void | setCountryCode(String countryCode) 国コードを設定します。
void | setEmailAddress1(String emailAddress1) メールアドレス１を設定します。
void | setEmailAddress2(String emailAddress2) メールアドレス２を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | setFaxNumber(String faxNumber) FAX番号を設定します。
void | setMobileEmailAddress(String mobileEmailAddress) 携帯用メールを設定します。
void | setMobileNumber(String mobileNumber) 携帯電話番号を設定します。
void | setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | setUrl(String url) URLを設定します。
void | setZipCode(String zipCode) 郵便番号を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserTerminable

public UserTerminable()
メソッドの詳細

getLocales

public Locale[] getLocales()
このユーザで管理している言語（ロケール）をすべて取得します。

戻り値:
このユーザで管理している言語（ロケール）

getUserTerminableInternational

public UserTerminableInternational getUserTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
期間国際化情報

putUserTerminableInternational

public void putUserTerminableInternational(Locale locale,
                                           UserTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 期間国際化情報

getExtendedUserTerminables

public Map getExtendedUserTerminables()
このユーザの期間化情報に対する拡張情報をすべて取得します。 返される値は拡張名をキー、 拡張情報を値とした Mapです。

戻り値:
期間化情報に対するすべての拡張情報
導入されたバージョン:
5.1.5

getExtendedUserTerminable

public Map getExtendedUserTerminable(String name)
指定された拡張情報を取得します。 返される値は属性名をキー、 属性値を値とした Mapです。

パラメータ:
name - 拡張名
戻り値:
期間化情報に対する拡張情報
導入されたバージョン:
5.1.5

putExtendedUserTerminable

public void putExtendedUserTerminable(String name,
                                      Map data)
指定された拡張情報を追加します。

パラメータ:
name - 拡張名
data - 期間化情報に対する拡張情報
導入されたバージョン:
5.1.5

getTelephoneNumber

public String getTelephoneNumber()
電話番号を取得します。

戻り値:
電話番号

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber)
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号

getMobileNumber

public String getMobileNumber()
携帯電話番号を取得します。

戻り値:
携帯電話番号

setMobileNumber

public void setMobileNumber(String mobileNumber)
携帯電話番号を設定します。

パラメータ:
mobileNumber - 携帯電話番号

getFaxNumber

public String getFaxNumber()
FAX番号を取得します。

戻り値:
FAX番号

setFaxNumber

public void setFaxNumber(String faxNumber)
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号

getExtensionNumber

public String getExtensionNumber()
内線番号を取得します。

戻り値:
内線番号

setExtensionNumber

public void setExtensionNumber(String extensionNumber)
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号

getExtensionFaxNumber

public String getExtensionFaxNumber()
内線FAX番号を取得します。

戻り値:
内線FAX番号

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber)
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号

getCountryCode

public String getCountryCode()
国コードを取得します。

戻り値:
国コード

setCountryCode

public void setCountryCode(String countryCode)
国コードを設定します。

パラメータ:
countryCode - 国コード

getZipCode

public String getZipCode()
郵便番号を取得します。

戻り値:
郵便番号

setZipCode

public void setZipCode(String zipCode)
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号

getEmailAddress1

public String getEmailAddress1()
メールアドレス１を取得します。

戻り値:
メールアドレス１

setEmailAddress1

public void setEmailAddress1(String emailAddress1)
メールアドレス１を設定します。

パラメータ:
emailAddress1 - メールアドレス１

getEmailAddress2

public String getEmailAddress2()
メールアドレス２を取得します。

戻り値:
メールアドレス２

setEmailAddress2

public void setEmailAddress2(String emailAddress2)
メールアドレス２を設定します。

パラメータ:
emailAddress2 - メールアドレス２

getMobileEmailAddress

public String getMobileEmailAddress()
携帯用メールを取得します。

戻り値:
携帯用メール

setMobileEmailAddress

public void setMobileEmailAddress(String mobileEmailAddress)
携帯用メールを設定します。

パラメータ:
mobileEmailAddress - 携帯用メール

getUrl

public String getUrl()
URLを取得します。

戻り値:
URL

setUrl

public void setUrl(String url)
URLを設定します。

パラメータ:
url - URL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserTerminableInternational (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.user
クラス UserTerminableInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational
すべての実装インタフェース:
Serializable
public class UserTerminableInternational
extends Object
implements Serializable

ユーザの期間国際化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
UserTerminableInternational()
メソッドの概要
String | getAddress() 住所を取得します。
Map | getExtendedUserTerminableInternational(String name) 指定された拡張情報を取得します。
Map | getExtendedUserTerminableInternationals() このユーザの基本情報に対する拡張情報をすべて取得します。
String | getName() ユーザ名を取得します。
String | getNameEnglish() ユーザ名英字を取得します。
String | getNameSyllabary() ユーザ名カナを取得します。
void | putExtendedUserTerminableInternational(String name, Map data) 指定された拡張情報を追加します。
void | setAddress(String address) 住所を設定します。
void | setName(String name) ユーザ名を設定します。
void | setNameEnglish(String nameEnglish) ユーザ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) ユーザ名カナを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserTerminableInternational

public UserTerminableInternational()
メソッドの詳細

getExtendedUserTerminableInternationals

public Map getExtendedUserTerminableInternationals()
このユーザの基本情報に対する拡張情報をすべて取得します。 返される値は拡張名をキー、 拡張情報を値とした Mapです。

戻り値:
期間国際化情報に対するすべての拡張情報
導入されたバージョン:
5.1.5

getExtendedUserTerminableInternational

public Map getExtendedUserTerminableInternational(String name)
指定された拡張情報を取得します。 返される値は属性名をキー、 属性値を値とした Mapです。

パラメータ:
name - 拡張名
戻り値:
期間国際化情報に対する拡張情報
導入されたバージョン:
5.1.5

putExtendedUserTerminableInternational

public void putExtendedUserTerminableInternational(String name,
                                                   Map data)
指定された拡張情報を追加します。

パラメータ:
name - 拡張名
data - 期間国際化情報に対する拡張情報
導入されたバージョン:
5.1.5

getName

public String getName()
ユーザ名を取得します。

戻り値:
ユーザ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
ユーザ名を設定します。

パラメータ:
name - ユーザ名

getNameSyllabary

public String getNameSyllabary()
ユーザ名カナを取得します。

戻り値:
ユーザ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
ユーザ名カナを設定します。

パラメータ:
nameSyllabary - ユーザ名カナ

getNameEnglish

public String getNameEnglish()
ユーザ名英字を取得します。

戻り値:
ユーザ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
ユーザ名英字を設定します。

パラメータ:
nameEnglish - ユーザ名英字

getAddress

public String getAddress()
住所を取得します。

戻り値:
住所
例外:
AccessorException - データの取得に失敗した場合

setAddress

public void setAddress(String address)
住所を設定します。

パラメータ:
address - 住所
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の使用

CateogryClassBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class 分類区分情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での CateogryClassBaseModel の使用

CateogryClassBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.category.category_class のメソッド
CateogryClassBaseModel | CateogryClassMapper.create(String categoryClassCode) プライマリキーに該当する分類区分を生成します。
CateogryClassBaseModel | CateogryClassMapper.select(String categoryClassCode) プライマリーキーで特定される分類区分の基本モデルを取得します。

CateogryClassBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.category.category_class のメソッド
void | CateogryClassMapper.insert(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ挿入します。
void | CateogryClassMapper.update(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ更新します。
void | CateogryClassMapper.delete(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel の使用

CateogryClassInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class 分類区分情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での CateogryClassInternationalModel の使用

CateogryClassInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.category.category_class のメソッド
 CateogryClassInternationalModel CateogryClassBaseModel.selectCateogryClassInternationalModel(Locale locale)
指定された言語に該当する分類区分の国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CateogryClassBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.category.category_class
インタフェース CateogryClassBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface CateogryClassBaseModel
extends BaseModel

分類区分の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | CATEGORY_CLASS_CODE 分類区分コード
static String | NAME 分類区分名
static String | NOTES 備考
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getCategoryClassCode() 分類区分コードを取得します。
String | getName() 分類区分名を取得します。
String | getName(Locale locale) 分類区分名を取得します。
String | getNotes() 備考を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
CateogryClassInternationalModel | selectCateogryClassInternationalModel(Locale locale) 指定された言語に該当する分類区分の国際化モデルを取得します。
void | setName(String name) 分類区分名を設定します。
void | setName(String name, Locale locale) 分類区分名を設定します。
void | setNotes(String notes) 備考を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

CATEGORY_CLASS_CODE

public static final String CATEGORY_CLASS_CODE
分類区分コード

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

NAME

public static final String NAME
分類区分名

関連項目:
定数フィールド値
メソッドの詳細

getCategoryClassCode

public String getCategoryClassCode()
                            throws AccessorException
分類区分コードを取得します。

戻り値:
分類区分コード
例外:
AccessorException - データの取得に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName()
               throws AccessorException
分類区分名を取得します。

戻り値:
分類区分名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
分類区分名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
分類区分名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
分類区分名を設定します。

パラメータ:
name - 分類区分名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
分類区分名を設定します。

パラメータ:
name - 分類区分名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectCateogryClassInternationalModel

public CateogryClassInternationalModel selectCateogryClassInternationalModel(Locale locale)
                                                                      throws IllegalLocaleException
指定された言語に該当する分類区分の国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
分類区分の国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CateogryClassInternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.category.category_class
インタフェース CateogryClassInternationalModel

すべてのスーパーインタフェース:
InternationalModel, Serializable
public interface CateogryClassInternationalModel
extends InternationalModel

分類区分の国際化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getName() 分類区分名を取得します。
void | setName(String name) 分類区分名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModel から継承したメソッド
getExtendedInternationalModelMap, getLocale, init

メソッドの詳細

getName

public String getName()
               throws AccessorException
分類区分名を取得します。

戻り値:
分類区分名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
分類区分名を設定します。

パラメータ:
name - 分類区分名
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CateogryClassMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.category.category_class
インタフェース CateogryClassMapper

すべてのスーパーインタフェース:
Mapper
public interface CateogryClassMapper
extends Mapper

分類区分に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
CateogryClassBaseModel | create(String categoryClassCode) プライマリキーに該当する分類区分を生成します。
void | delete(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ削除します。
void | delete(Collection models) 分類区分の基本モデルを複数削除します。
void | insert(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ挿入します。
void | insert(Collection models) 分類区分の基本モデルを複数挿入します。
CateogryClassBaseModel | select(String categoryClassCode) プライマリーキーで特定される分類区分の基本モデルを取得します。
void | update(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ更新します。
void | update(Collection models) 分類区分の基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public CateogryClassBaseModel create(String categoryClassCode)
                              throws MapperException
プライマリキーに該当する分類区分を生成します。

パラメータ:
categoryClassCode - 分類区分コード
戻り値:
プライマリキーに該当する分類区分の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public CateogryClassBaseModel select(String categoryClassCode)
                              throws MapperException
プライマリーキーで特定される分類区分の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
categoryClassCode - 分類区分コード
戻り値:
分類区分の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(CateogryClassBaseModel model)
            throws MapperException
分類区分の基本モデルを1つだけ挿入します。 引数に指定する分類区分の基本モデルは同一の CateogryClassMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入する分類区分の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
分類区分の基本モデルを複数挿入します。 引数に指定するものは同一の CateogryClassMapperの create(String) で生成された分類区分の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する分類区分の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(CateogryClassBaseModel model)
            throws MapperException
分類区分の基本モデルを1つだけ更新します。 引数に指定する分類区分の基本モデルは同一の CateogryClassMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する分類区分の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
分類区分の基本モデルを複数更新します。 引数に指定するものは同一の CateogryClassMapperの select 系メソッド から取得されたものかで生成された分類区分の基本モデルの集合である必要があります。

パラメータ:
models - 更新する分類区分の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(CateogryClassBaseModel model)
            throws MapperException
分類区分の基本モデルを1つだけ削除します。 引数で指定された分類区分の基本モデルに該当するデータのすべての情報を削除します。引数に指定する分類区分の基本モデルは同一の CateogryClassMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する分類区分の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
分類区分の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する分類区分の基本モデルは同一の CateogryClassMapperの select 系メソッド から取得された分類区分の基本モデルの集合である必要があります。

パラメータ:
models - 削除する分類区分の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.category.category_class (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.category.category_class
インタフェース
CateogryClassBaseModel
CateogryClassInternationalModel
CateogryClassMapper


jp.co.intra_mart.foundation.datastore.application.model.category.category_class (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.category.category_class

分類区分情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
CateogryClassBaseModel | 分類区分の基本モデルです。
CateogryClassInternationalModel | 分類区分の国際化モデルです。
CateogryClassMapper | 分類区分に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.category.category_class の説明

分類区分情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.category.category_class クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.category.category_class の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.category.category_class の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class の使用

jp.co.intra_mart.foundation.datastore.application.model.category.category_class を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class 分類区分情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.category.category_class により使用される jp.co.intra_mart.foundation.datastore.application.model.category.category_class のクラス
CateogryClassBaseModel
分類区分の基本モデルです。
CateogryClassInternationalModel
分類区分の国際化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の使用

CategoryDetailBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.detail 分類詳細情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.category.detail での CategoryDetailBaseModel の使用

CategoryDetailBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.category.detail のメソッド
CategoryDetailBaseModel | CategoryDetailMapper.create(String categoryClassCode, String categoryCode) プライマリキーに該当する分類区分詳細を生成します。
CategoryDetailBaseModel | CategoryDetailMapper.select(String categoryClassCode, String categoryCode) プライマリーキーで特定される分類区分詳細の基本モデルを取得します。

CategoryDetailBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.category.detail のメソッド
void | CategoryDetailMapper.insert(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ挿入します。
void | CategoryDetailMapper.update(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ更新します。
void | CategoryDetailMapper.delete(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel の使用

CategoryDetailInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.detail 分類詳細情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.category.detail での CategoryDetailInternationalModel の使用

CategoryDetailInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.category.detail のメソッド
 CategoryDetailInternationalModel CategoryDetailBaseModel.selectCategoryDetailInternationalModel(Locale locale)
指定された言語に該当する分類区分詳細の国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CategoryDetailBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.category.detail
インタフェース CategoryDetailBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface CategoryDetailBaseModel
extends BaseModel

分類区分詳細の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | CATEGORY_CLASS_CODE 分類区分コード
static String | CATEGORY_CODE 分類コード
static String | NAME 分類名
static String | NOTES 備考
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getCategoryClassCode() 分類区分コードを取得します。
String | getCategoryCode() 分類コードを取得します。
String | getName() 分類名を取得します。
String | getName(Locale locale) 分類名を取得します。
String | getNotes() 備考を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
CategoryDetailInternationalModel | selectCategoryDetailInternationalModel(Locale locale) 指定された言語に該当する分類区分詳細の国際化モデルを取得します。
void | setName(String name) 分類名を設定します。
void | setName(String name, Locale locale) 分類名を設定します。
void | setNotes(String notes) 備考を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

CATEGORY_CLASS_CODE

public static final String CATEGORY_CLASS_CODE
分類区分コード

関連項目:
定数フィールド値

CATEGORY_CODE

public static final String CATEGORY_CODE
分類コード

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

NAME

public static final String NAME
分類名

関連項目:
定数フィールド値
メソッドの詳細

getCategoryClassCode

public String getCategoryClassCode()
                            throws AccessorException
分類区分コードを取得します。

戻り値:
分類区分コード
例外:
AccessorException - データの取得に失敗した場合

getCategoryCode

public String getCategoryCode()
                       throws AccessorException
分類コードを取得します。

戻り値:
分類コード
例外:
AccessorException - データの取得に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName()
               throws AccessorException
分類名を取得します。

戻り値:
分類名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
分類名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
分類名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
分類名を設定します。

パラメータ:
name - 分類名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
分類名を設定します。

パラメータ:
name - 分類名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectCategoryDetailInternationalModel

public CategoryDetailInternationalModel selectCategoryDetailInternationalModel(Locale locale)
                                                                        throws IllegalLocaleException
指定された言語に該当する分類区分詳細の国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
分類区分詳細の国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CategoryDetailInternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.category.detail
インタフェース CategoryDetailInternationalModel

すべてのスーパーインタフェース:
InternationalModel, Serializable
public interface CategoryDetailInternationalModel
extends InternationalModel

分類区分詳細の国際化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getName() 分類名を取得します。
void | setName(String name) 分類名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModel から継承したメソッド
getExtendedInternationalModelMap, getLocale, init

メソッドの詳細

getName

public String getName()
               throws AccessorException
分類名を取得します。

戻り値:
分類名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
分類名を設定します。

パラメータ:
name - 分類名
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CategoryDetailMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.category.detail
インタフェース CategoryDetailMapper

すべてのスーパーインタフェース:
Mapper
public interface CategoryDetailMapper
extends Mapper

分類区分詳細に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
CategoryDetailBaseModel | create(String categoryClassCode, String categoryCode) プライマリキーに該当する分類区分詳細を生成します。
void | delete(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ削除します。
void | delete(Collection models) 分類区分詳細の基本モデルを複数削除します。
void | insert(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ挿入します。
void | insert(Collection models) 分類区分詳細の基本モデルを複数挿入します。
CategoryDetailBaseModel | select(String categoryClassCode, String categoryCode) プライマリーキーで特定される分類区分詳細の基本モデルを取得します。
void | update(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ更新します。
void | update(Collection models) 分類区分詳細の基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public CategoryDetailBaseModel create(String categoryClassCode,
                                      String categoryCode)
                               throws MapperException
プライマリキーに該当する分類区分詳細を生成します。

パラメータ:
categoryClassCode - 分類区分コード
categoryCode - 分類コード
戻り値:
プライマリキーに該当する分類区分詳細の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public CategoryDetailBaseModel select(String categoryClassCode,
                                      String categoryCode)
                               throws MapperException
プライマリーキーで特定される分類区分詳細の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
categoryClassCode - 分類区分コード
categoryCode - 分類コード
戻り値:
分類区分詳細の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(CategoryDetailBaseModel model)
            throws MapperException
分類区分詳細の基本モデルを1つだけ挿入します。 引数に指定する分類区分詳細の基本モデルは同一の CategoryDetailMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する分類区分詳細の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
分類区分詳細の基本モデルを複数挿入します。 引数に指定するものは同一の CategoryDetailMapperの create(String,String) で生成された分類区分詳細の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する分類区分詳細の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(CategoryDetailBaseModel model)
            throws MapperException
分類区分詳細の基本モデルを1つだけ更新します。 引数に指定する分類区分詳細の基本モデルは同一の CategoryDetailMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する分類区分詳細の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
分類区分詳細の基本モデルを複数更新します。 引数に指定するものは同一の CategoryDetailMapperの select 系メソッド から取得されたものかで生成された分類区分詳細の基本モデルの集合である必要があります。

パラメータ:
models - 更新する分類区分詳細の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(CategoryDetailBaseModel model)
            throws MapperException
分類区分詳細の基本モデルを1つだけ削除します。 引数で指定された分類区分詳細の基本モデルに該当するデータのすべての情報を削除します。引数に指定する分類区分詳細の基本モデルは同一の CategoryDetailMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する分類区分詳細の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
分類区分詳細の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する分類区分詳細の基本モデルは同一の CategoryDetailMapperの select 系メソッド から取得された分類区分詳細の基本モデルの集合である必要があります。

パラメータ:
models - 削除する分類区分詳細の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.category.detail (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.category.detail
インタフェース
CategoryDetailBaseModel
CategoryDetailInternationalModel
CategoryDetailMapper


jp.co.intra_mart.foundation.datastore.application.model.category.detail (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.category.detail

分類詳細情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
CategoryDetailBaseModel | 分類区分詳細の基本モデルです。
CategoryDetailInternationalModel | 分類区分詳細の国際化モデルです。
CategoryDetailMapper | 分類区分詳細に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.category.detail の説明

分類詳細情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.category.detail クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.category.detail の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.category.detail の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.detail の使用

jp.co.intra_mart.foundation.datastore.application.model.category.detail を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.detail 分類詳細情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.category.detail により使用される jp.co.intra_mart.foundation.datastore.application.model.category.detail のクラス
CategoryDetailBaseModel
分類区分詳細の基本モデルです。
CategoryDetailInternationalModel
分類区分詳細の国際化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の使用

DepartmentAttachBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.attach 組織所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.attach での DepartmentAttachBaseModel の使用

DepartmentAttachBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.attach のメソッド
DepartmentAttachBaseModel | DepartmentAttachMapper.create(String userCode, String companyCode, String departmentCode) プライマリキーに該当する組織所属を生成します。
DepartmentAttachBaseModel | DepartmentAttachMapper.select(String userCode, String companyCode, String departmentCode) プライマリーキーで特定される組織所属の基本モデルを取得します。

DepartmentAttachBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.company.attach のメソッド
void | DepartmentAttachMapper.insert(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ挿入します。
void | DepartmentAttachMapper.update(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ更新します。
void | DepartmentAttachMapper.delete(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel の使用

DepartmentAttachTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.attach 組織所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.attach での DepartmentAttachTerminableModel の使用

DepartmentAttachTerminableModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.attach のメソッド
 DepartmentAttachTerminableModel DepartmentAttachBaseModel.selectDepartmentAttachTerminableModel(Date date)
指定された日付に該当する組織所属の期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DepartmentAttachBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.attach
インタフェース DepartmentAttachBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface DepartmentAttachBaseModel
extends BaseModel

組織所属の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | COMPANY_CODE 会社コード
static String | DEPARTMENT_CODE 組織コード
static String | POST_CODE 役職CD
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
static String | USER_CODE ユーザコード
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
String | getPostCode() 役職CDを取得します。
String | getPostCode(Date date) 役職CDを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
String | getUserCode() ユーザコードを取得します。
DepartmentAttachTerminableModel | selectDepartmentAttachTerminableModel(Date date) 指定された日付に該当する組織所属の期間化モデルを取得します。
void | setPostCode(String postCode) 役職CDを設定します。
void | setPostCode(String postCode, Date date) 役職CDを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

USER_CODE

public static final String USER_CODE
ユーザコード

関連項目:
定数フィールド値

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

DEPARTMENT_CODE

public static final String DEPARTMENT_CODE
組織コード

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

POST_CODE

public static final String POST_CODE
役職CD

関連項目:
定数フィールド値
メソッドの詳細

getUserCode

public String getUserCode()
                   throws AccessorException
ユーザコードを取得します。

戻り値:
ユーザコード
例外:
AccessorException - データの取得に失敗した場合

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getDepartmentCode

public String getDepartmentCode()
                         throws AccessorException
組織コードを取得します。

戻り値:
組織コード
例外:
AccessorException - データの取得に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getPostCode

public String getPostCode()
                   throws AccessorException
役職CDを取得します。

戻り値:
役職CD
例外:
AccessorException - データの取得に失敗した場合

getPostCode

public String getPostCode(Date date)
                   throws AccessorException
役職CDを取得します。

パラメータ:
date - 日時
戻り値:
役職CD
例外:
AccessorException - データの取得に失敗した場合

setPostCode

public void setPostCode(String postCode)
                 throws AccessorException
役職CDを設定します。

パラメータ:
postCode - 役職CD
例外:
AccessorException - データの設定に失敗した場合

setPostCode

public void setPostCode(String postCode,
                        Date date)
                 throws AccessorException
役職CDを設定します。

パラメータ:
postCode - 役職CD
date - 日時
例外:
AccessorException - データの設定に失敗した場合

selectDepartmentAttachTerminableModel

public DepartmentAttachTerminableModel selectDepartmentAttachTerminableModel(Date date)
                                                                      throws IllegalTermException
指定された日付に該当する組織所属の期間化モデルを取得します。

パラメータ:
date - 指定日付
戻り値:
組織所属の期間化モデル
例外:
IllegalTermException - 指定された日付に該当する期間が定義されていない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DepartmentAttachMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.attach
インタフェース DepartmentAttachMapper

すべてのスーパーインタフェース:
Mapper
public interface DepartmentAttachMapper
extends Mapper

組織所属に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
DepartmentAttachBaseModel | create(String userCode, String companyCode, String departmentCode) プライマリキーに該当する組織所属を生成します。
void | delete(Collection models) 組織所属の基本モデルを複数削除します。
void | delete(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ削除します。
void | insert(Collection models) 組織所属の基本モデルを複数挿入します。
void | insert(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ挿入します。
DepartmentAttachBaseModel | select(String userCode, String companyCode, String departmentCode) プライマリーキーで特定される組織所属の基本モデルを取得します。
void | update(Collection models) 組織所属の基本モデルを複数更新します。
void | update(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public DepartmentAttachBaseModel create(String userCode,
                                        String companyCode,
                                        String departmentCode)
                                 throws MapperException
プライマリキーに該当する組織所属を生成します。

パラメータ:
userCode - ユーザコード
companyCode - 会社コード
departmentCode - 組織コード
戻り値:
プライマリキーに該当する組織所属の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public DepartmentAttachBaseModel select(String userCode,
                                        String companyCode,
                                        String departmentCode)
                                 throws MapperException
プライマリーキーで特定される組織所属の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
userCode - ユーザコード
companyCode - 会社コード
departmentCode - 組織コード
戻り値:
組織所属の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(DepartmentAttachBaseModel model)
            throws MapperException
組織所属の基本モデルを1つだけ挿入します。 引数に指定する組織所属の基本モデルは同一の DepartmentAttachMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する組織所属の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
組織所属の基本モデルを複数挿入します。 引数に指定するものは同一の DepartmentAttachMapperの create(String,String,String) で生成された組織所属の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する組織所属の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(DepartmentAttachBaseModel model)
            throws MapperException
組織所属の基本モデルを1つだけ更新します。 引数に指定する組織所属の基本モデルは同一の DepartmentAttachMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する組織所属の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
組織所属の基本モデルを複数更新します。 引数に指定するものは同一の DepartmentAttachMapperの select 系メソッド から取得されたものかで生成された組織所属の基本モデルの集合である必要があります。

パラメータ:
models - 更新する組織所属の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(DepartmentAttachBaseModel model)
            throws MapperException
組織所属の基本モデルを1つだけ削除します。 引数で指定された組織所属の基本モデルに該当するデータのすべての情報を削除します。引数に指定する組織所属の基本モデルは同一の DepartmentAttachMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する組織所属の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
組織所属の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する組織所属の基本モデルは同一の DepartmentAttachMapperの select 系メソッド から取得された組織所属の基本モデルの集合である必要があります。

パラメータ:
models - 削除する組織所属の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DepartmentAttachTerminableModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.attach
インタフェース DepartmentAttachTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface DepartmentAttachTerminableModel
extends TerminableModel

組織所属の期間化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getPostCode() 役職CDを取得します。
void | setPostCode(String postCode) 役職CDを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

メソッドの詳細

getPostCode

public String getPostCode()
                   throws AccessorException
役職CDを取得します。

戻り値:
役職CD
例外:
AccessorException - データの取得に失敗した場合

setPostCode

public void setPostCode(String postCode)
                 throws AccessorException
役職CDを設定します。

パラメータ:
postCode - 役職CD
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.company.attach (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.company.attach
インタフェース
DepartmentAttachBaseModel
DepartmentAttachMapper
DepartmentAttachTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.company.attach (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.attach

組織所属情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
DepartmentAttachBaseModel | 組織所属の基本モデルです。
DepartmentAttachMapper | 組織所属に関連するマッパです。
DepartmentAttachTerminableModel | 組織所属の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.attach の説明

組織所属情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.company.attach クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.attach の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.attach の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.attach の使用

jp.co.intra_mart.foundation.datastore.application.model.company.attach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.attach 組織所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.attach により使用される jp.co.intra_mart.foundation.datastore.application.model.company.attach のクラス
DepartmentAttachBaseModel
組織所属の基本モデルです。
DepartmentAttachTerminableModel
組織所属の期間化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の使用

CompanyCategoryBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.category 会社分類情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.category での CompanyCategoryBaseModel の使用

CompanyCategoryBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.category のメソッド
CompanyCategoryBaseModel | CompanyCategoryMapper.create(String companyCode, String departmentCode, String categoryClassCode, String categoryCode) プライマリキーに該当する会社組織分類を生成します。
CompanyCategoryBaseModel | CompanyCategoryMapper.select(String companyCode, String departmentCode, String categoryClassCode, String categoryCode) プライマリーキーで特定される会社組織分類の基本モデルを取得します。

CompanyCategoryBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.company.category のメソッド
void | CompanyCategoryMapper.insert(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ挿入します。
void | CompanyCategoryMapper.update(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ更新します。
void | CompanyCategoryMapper.delete(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryTerminableModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryTerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryTerminableModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CompanyCategoryBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.category
インタフェース CompanyCategoryBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface CompanyCategoryBaseModel
extends BaseModel

会社組織分類の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | CATEGORY_CLASS_CODE 分類区分コード
static String | CATEGORY_CODE 分類コード
static String | COMPANY_CODE 会社コード
static String | DEPARTMENT_CODE 組織コード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getCategoryClassCode() 分類区分コードを取得します。
String | getCategoryCode() 分類コードを取得します。
String | getCompanyCode() 会社コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

DEPARTMENT_CODE

public static final String DEPARTMENT_CODE
組織コード

関連項目:
定数フィールド値

CATEGORY_CLASS_CODE

public static final String CATEGORY_CLASS_CODE
分類区分コード

関連項目:
定数フィールド値

CATEGORY_CODE

public static final String CATEGORY_CODE
分類コード

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getDepartmentCode

public String getDepartmentCode()
                         throws AccessorException
組織コードを取得します。

戻り値:
組織コード
例外:
AccessorException - データの取得に失敗した場合

getCategoryClassCode

public String getCategoryClassCode()
                            throws AccessorException
分類区分コードを取得します。

戻り値:
分類区分コード
例外:
AccessorException - データの取得に失敗した場合

getCategoryCode

public String getCategoryCode()
                       throws AccessorException
分類コードを取得します。

戻り値:
分類コード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyCategoryMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.category
インタフェース CompanyCategoryMapper

すべてのスーパーインタフェース:
Mapper
public interface CompanyCategoryMapper
extends Mapper

会社組織分類に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
CompanyCategoryBaseModel | create(String companyCode, String departmentCode, String categoryClassCode, String categoryCode) プライマリキーに該当する会社組織分類を生成します。
void | delete(Collection models) 会社組織分類の基本モデルを複数削除します。
void | delete(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ削除します。
void | insert(Collection models) 会社組織分類の基本モデルを複数挿入します。
void | insert(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ挿入します。
CompanyCategoryBaseModel | select(String companyCode, String departmentCode, String categoryClassCode, String categoryCode) プライマリーキーで特定される会社組織分類の基本モデルを取得します。
void | update(Collection models) 会社組織分類の基本モデルを複数更新します。
void | update(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public CompanyCategoryBaseModel create(String companyCode,
                                       String departmentCode,
                                       String categoryClassCode,
                                       String categoryCode)
                                throws MapperException
プライマリキーに該当する会社組織分類を生成します。

パラメータ:
companyCode - 会社コード
departmentCode - 組織コード
categoryClassCode - 分類区分コード
categoryCode - 分類コード
戻り値:
プライマリキーに該当する会社組織分類の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public CompanyCategoryBaseModel select(String companyCode,
                                       String departmentCode,
                                       String categoryClassCode,
                                       String categoryCode)
                                throws MapperException
プライマリーキーで特定される会社組織分類の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
companyCode - 会社コード
departmentCode - 組織コード
categoryClassCode - 分類区分コード
categoryCode - 分類コード
戻り値:
会社組織分類の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(CompanyCategoryBaseModel model)
            throws MapperException
会社組織分類の基本モデルを1つだけ挿入します。 引数に指定する会社組織分類の基本モデルは同一の CompanyCategoryMapperの create(String,String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する会社組織分類の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
会社組織分類の基本モデルを複数挿入します。 引数に指定するものは同一の CompanyCategoryMapperの create(String,String,String,String) で生成された会社組織分類の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する会社組織分類の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(CompanyCategoryBaseModel model)
            throws MapperException
会社組織分類の基本モデルを1つだけ更新します。 引数に指定する会社組織分類の基本モデルは同一の CompanyCategoryMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する会社組織分類の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
会社組織分類の基本モデルを複数更新します。 引数に指定するものは同一の CompanyCategoryMapperの select 系メソッド から取得されたものかで生成された会社組織分類の基本モデルの集合である必要があります。

パラメータ:
models - 更新する会社組織分類の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(CompanyCategoryBaseModel model)
            throws MapperException
会社組織分類の基本モデルを1つだけ削除します。 引数で指定された会社組織分類の基本モデルに該当するデータのすべての情報を削除します。引数に指定する会社組織分類の基本モデルは同一の CompanyCategoryMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する会社組織分類の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
会社組織分類の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する会社組織分類の基本モデルは同一の CompanyCategoryMapperの select 系メソッド から取得された会社組織分類の基本モデルの集合である必要があります。

パラメータ:
models - 削除する会社組織分類の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyCategoryTerminableModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.category
インタフェース CompanyCategoryTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface CompanyCategoryTerminableModel
extends TerminableModel

会社組織分類の期間化モデルです。

導入されたバージョン:
5.0

インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.company.category (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.company.category
インタフェース
CompanyCategoryBaseModel
CompanyCategoryMapper
CompanyCategoryTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.company.category (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.category

会社分類情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
CompanyCategoryBaseModel | 会社組織分類の基本モデルです。
CompanyCategoryMapper | 会社組織分類に関連するマッパです。
CompanyCategoryTerminableModel | 会社組織分類の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.category の説明

会社分類情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.company.category クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.category の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryTerminableModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.category の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.category の使用

jp.co.intra_mart.foundation.datastore.application.model.company.category を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.category 会社分類情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.category により使用される jp.co.intra_mart.foundation.datastore.application.model.company.category のクラス
CompanyCategoryBaseModel
会社組織分類の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel の使用

CompanyBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.company 会社情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.company での CompanyBaseModel の使用

CompanyBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.company のメソッド
CompanyBaseModel | CompanyMapper.create(String companyCode) プライマリキーに該当する会社を生成します。
CompanyBaseModel | CompanyMapper.select(String companyCode) プライマリーキーで特定される会社の基本モデルを取得します。

CompanyBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.company.company のメソッド
void | CompanyMapper.insert(CompanyBaseModel model) 会社の基本モデルを1つだけ挿入します。
void | CompanyMapper.update(CompanyBaseModel model) 会社の基本モデルを1つだけ更新します。
void | CompanyMapper.delete(CompanyBaseModel model) 会社の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CompanyBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.company
インタフェース CompanyBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface CompanyBaseModel
extends BaseModel

会社の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | COMPANY_CODE 会社コード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.company
インタフェース CompanyMapper

すべてのスーパーインタフェース:
Mapper
public interface CompanyMapper
extends Mapper

会社に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
CompanyBaseModel | create(String companyCode) プライマリキーに該当する会社を生成します。
void | delete(Collection models) 会社の基本モデルを複数削除します。
void | delete(CompanyBaseModel model) 会社の基本モデルを1つだけ削除します。
void | insert(Collection models) 会社の基本モデルを複数挿入します。
void | insert(CompanyBaseModel model) 会社の基本モデルを1つだけ挿入します。
CompanyBaseModel | select(String companyCode) プライマリーキーで特定される会社の基本モデルを取得します。
void | update(Collection models) 会社の基本モデルを複数更新します。
void | update(CompanyBaseModel model) 会社の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public CompanyBaseModel create(String companyCode)
                        throws MapperException
プライマリキーに該当する会社を生成します。

パラメータ:
companyCode - 会社コード
戻り値:
プライマリキーに該当する会社の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public CompanyBaseModel select(String companyCode)
                        throws MapperException
プライマリーキーで特定される会社の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
companyCode - 会社コード
戻り値:
会社の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(CompanyBaseModel model)
            throws MapperException
会社の基本モデルを1つだけ挿入します。 引数に指定する会社の基本モデルは同一の CompanyMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入する会社の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
会社の基本モデルを複数挿入します。 引数に指定するものは同一の CompanyMapperの create(String) で生成された会社の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する会社の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(CompanyBaseModel model)
            throws MapperException
会社の基本モデルを1つだけ更新します。 引数に指定する会社の基本モデルは同一の CompanyMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する会社の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
会社の基本モデルを複数更新します。 引数に指定するものは同一の CompanyMapperの select 系メソッド から取得されたものかで生成された会社の基本モデルの集合である必要があります。

パラメータ:
models - 更新する会社の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(CompanyBaseModel model)
            throws MapperException
会社の基本モデルを1つだけ削除します。 引数で指定された会社の基本モデルに該当するデータのすべての情報を削除します。引数に指定する会社の基本モデルは同一の CompanyMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する会社の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
会社の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する会社の基本モデルは同一の CompanyMapperの select 系メソッド から取得された会社の基本モデルの集合である必要があります。

パラメータ:
models - 削除する会社の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.company.company (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.company.company
インタフェース
CompanyBaseModel
CompanyMapper


jp.co.intra_mart.foundation.datastore.application.model.company.company (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.company

会社情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
CompanyBaseModel | 会社の基本モデルです。
CompanyMapper | 会社に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.company の説明

会社情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.company.company クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.company の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.company の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.company の使用

jp.co.intra_mart.foundation.datastore.application.model.company.company を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.company 会社情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.company により使用される jp.co.intra_mart.foundation.datastore.application.model.company.company のクラス
CompanyBaseModel
会社の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の使用

DepartmentBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.department 組織情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.department での DepartmentBaseModel の使用

DepartmentBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.department のメソッド
DepartmentBaseModel | DepartmentMapper.create(String companyCode, String departmentCode) プライマリキーに該当する組織を生成します。
DepartmentBaseModel | DepartmentMapper.select(String companyCode, String departmentCode) プライマリーキーで特定される組織の基本モデルを取得します。

DepartmentBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.company.department のメソッド
void | DepartmentMapper.insert(DepartmentBaseModel model) 組織の基本モデルを1つだけ挿入します。
void | DepartmentMapper.update(DepartmentBaseModel model) 組織の基本モデルを1つだけ更新します。
void | DepartmentMapper.delete(DepartmentBaseModel model) 組織の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel の使用

DepartmentTerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.department 組織情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.department での DepartmentTerminableInternationalModel の使用

DepartmentTerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.department のメソッド
 DepartmentTerminableInternationalModel DepartmentTerminableModel.selectDepartmentTerminableInternationalModel(Locale locale)
指定された言語に該当する組織の期間国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel の使用

DepartmentTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.department 組織情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.department での DepartmentTerminableModel の使用

DepartmentTerminableModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.department のメソッド
 DepartmentTerminableModel DepartmentBaseModel.selectDepartmentTerminableModel(Date date)
指定された日付に該当する組織の期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DepartmentBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.department
インタフェース DepartmentBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface DepartmentBaseModel
extends BaseModel

組織の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | ADDRESS1 住所1
static String | ADDRESS2 住所2
static String | COMPANY_CODE 会社コード
static String | COUNTRY_CODE 国コード
static String | DEPARTMENT_CODE 組織コード
static String | EMAIL_ADDRESS1 メールアドレス1
static String | EMAIL_ADDRESS2 メールアドレス2
static String | EXTENSION_FAX_NUMBER 内線FAX番号
static String | EXTENSION_NUMBER 内線番号
static String | FAX_NUMBER FAX番号
static String | NAME 組織名
static String | NAME_ENGLISH 組織名英字
static String | NAME_SYLLABARY 組織名カナ
static String | NOTES 備考
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
static String | TELEPHONE_NUMBER 電話番号
static String | URL URL
static String | ZIP_CODE 郵便番号
メソッドの概要
String | getAddress1() 住所1を取得します。
String | getAddress1(Date date) 住所1を取得します。
String | getAddress1(Date date, Locale locale) 住所1を取得します。
String | getAddress1(Locale locale) 住所1を取得します。
String | getAddress2() 住所2を取得します。
String | getAddress2(Date date) 住所2を取得します。
String | getAddress2(Date date, Locale locale) 住所2を取得します。
String | getAddress2(Locale locale) 住所2を取得します。
String | getCompanyCode() 会社コードを取得します。
String | getCountryCode() 国コードを取得します。
String | getCountryCode(Date date) 国コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
String | getEmailAddress1() メールアドレス1を取得します。
String | getEmailAddress1(Date date) メールアドレス1を取得します。
String | getEmailAddress2() メールアドレス2を取得します。
String | getEmailAddress2(Date date) メールアドレス2を取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionFaxNumber(Date date) 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getExtensionNumber(Date date) 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
String | getFaxNumber(Date date) FAX番号を取得します。
String | getName() 組織名を取得します。
String | getName(Date date) 組織名を取得します。
String | getName(Date date, Locale locale) 組織名を取得します。
String | getName(Locale locale) 組織名を取得します。
String | getNameEnglish() 組織名英字を取得します。
String | getNameEnglish(Date date) 組織名英字を取得します。
String | getNameEnglish(Date date, Locale locale) 組織名英字を取得します。
String | getNameEnglish(Locale locale) 組織名英字を取得します。
String | getNameSyllabary() 組織名カナを取得します。
String | getNameSyllabary(Date date) 組織名カナを取得します。
String | getNameSyllabary(Date date, Locale locale) 組織名カナを取得します。
String | getNameSyllabary(Locale locale) 組織名カナを取得します。
String | getNotes() 備考を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getTelephoneNumber(Date date) 電話番号を取得します。
String | getUrl() URLを取得します。
String | getUrl(Date date) URLを取得します。
String | getZipCode() 郵便番号を取得します。
String | getZipCode(Date date) 郵便番号を取得します。
DepartmentTerminableModel | selectDepartmentTerminableModel(Date date) 指定された日付に該当する組織の期間化モデルを取得します。
void | setAddress1(String address1) 住所1を設定します。
void | setAddress1(String address1, Date date) 住所1を設定します。
void | setAddress1(String address1, Date date, Locale locale) 住所1を設定します。
void | setAddress1(String address1, Locale locale) 住所1を設定します。
void | setAddress2(String address2) 住所2を設定します。
void | setAddress2(String address2, Date date) 住所2を設定します。
void | setAddress2(String address2, Date date, Locale locale) 住所2を設定します。
void | setAddress2(String address2, Locale locale) 住所2を設定します。
void | setCountryCode(String countryCode) 国コードを設定します。
void | setCountryCode(String countryCode, Date date) 国コードを設定します。
void | setEmailAddress1(String emailAddress1) メールアドレス1を設定します。
void | setEmailAddress1(String emailAddress1, Date date) メールアドレス1を設定します。
void | setEmailAddress2(String emailAddress2) メールアドレス2を設定します。
void | setEmailAddress2(String emailAddress2, Date date) メールアドレス2を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber, Date date) 内線FAX番号を設定します。
void | setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | setExtensionNumber(String extensionNumber, Date date) 内線番号を設定します。
void | setFaxNumber(String faxNumber) FAX番号を設定します。
void | setFaxNumber(String faxNumber, Date date) FAX番号を設定します。
void | setName(String name) 組織名を設定します。
void | setName(String name, Date date) 組織名を設定します。
void | setName(String name, Date date, Locale locale) 組織名を設定します。
void | setName(String name, Locale locale) 組織名を設定します。
void | setNameEnglish(String nameEnglish) 組織名英字を設定します。
void | setNameEnglish(String nameEnglish, Date date) 組織名英字を設定します。
void | setNameEnglish(String nameEnglish, Date date, Locale locale) 組織名英字を設定します。
void | setNameEnglish(String nameEnglish, Locale locale) 組織名英字を設定します。
void | setNameSyllabary(String nameSyllabary) 組織名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Date date) 組織名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Date date, Locale locale) 組織名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Locale locale) 組織名カナを設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
void | setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | setTelephoneNumber(String telephoneNumber, Date date) 電話番号を設定します。
void | setUrl(String url) URLを設定します。
void | setUrl(String url, Date date) URLを設定します。
void | setZipCode(String zipCode) 郵便番号を設定します。
void | setZipCode(String zipCode, Date date) 郵便番号を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

DEPARTMENT_CODE

public static final String DEPARTMENT_CODE
組織コード

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

TELEPHONE_NUMBER

public static final String TELEPHONE_NUMBER
電話番号

関連項目:
定数フィールド値

FAX_NUMBER

public static final String FAX_NUMBER
FAX番号

関連項目:
定数フィールド値

EXTENSION_NUMBER

public static final String EXTENSION_NUMBER
内線番号

関連項目:
定数フィールド値

EXTENSION_FAX_NUMBER

public static final String EXTENSION_FAX_NUMBER
内線FAX番号

関連項目:
定数フィールド値

COUNTRY_CODE

public static final String COUNTRY_CODE
国コード

関連項目:
定数フィールド値

ZIP_CODE

public static final String ZIP_CODE
郵便番号

関連項目:
定数フィールド値

EMAIL_ADDRESS1

public static final String EMAIL_ADDRESS1
メールアドレス1

関連項目:
定数フィールド値

EMAIL_ADDRESS2

public static final String EMAIL_ADDRESS2
メールアドレス2

関連項目:
定数フィールド値

URL

public static final String URL
URL

関連項目:
定数フィールド値

NAME

public static final String NAME
組織名

関連項目:
定数フィールド値

NAME_SYLLABARY

public static final String NAME_SYLLABARY
組織名カナ

関連項目:
定数フィールド値

NAME_ENGLISH

public static final String NAME_ENGLISH
組織名英字

関連項目:
定数フィールド値

ADDRESS1

public static final String ADDRESS1
住所1

関連項目:
定数フィールド値

ADDRESS2

public static final String ADDRESS2
住所2

関連項目:
定数フィールド値
メソッドの詳細

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getDepartmentCode

public String getDepartmentCode()
                         throws AccessorException
組織コードを取得します。

戻り値:
組織コード
例外:
AccessorException - データの取得に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getTelephoneNumber

public String getTelephoneNumber()
                          throws AccessorException
電話番号を取得します。

戻り値:
電話番号
例外:
AccessorException - データの取得に失敗した場合

getTelephoneNumber

public String getTelephoneNumber(Date date)
                          throws AccessorException
電話番号を取得します。

パラメータ:
date - 日時
戻り値:
電話番号
例外:
AccessorException - データの取得に失敗した場合

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber)
                        throws AccessorException
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号
例外:
AccessorException - データの設定に失敗した場合

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber,
                               Date date)
                        throws AccessorException
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getFaxNumber

public String getFaxNumber()
                    throws AccessorException
FAX番号を取得します。

戻り値:
FAX番号
例外:
AccessorException - データの取得に失敗した場合

getFaxNumber

public String getFaxNumber(Date date)
                    throws AccessorException
FAX番号を取得します。

パラメータ:
date - 日時
戻り値:
FAX番号
例外:
AccessorException - データの取得に失敗した場合

setFaxNumber

public void setFaxNumber(String faxNumber)
                  throws AccessorException
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号
例外:
AccessorException - データの設定に失敗した場合

setFaxNumber

public void setFaxNumber(String faxNumber,
                         Date date)
                  throws AccessorException
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getExtensionNumber

public String getExtensionNumber()
                          throws AccessorException
内線番号を取得します。

戻り値:
内線番号
例外:
AccessorException - データの取得に失敗した場合

getExtensionNumber

public String getExtensionNumber(Date date)
                          throws AccessorException
内線番号を取得します。

パラメータ:
date - 日時
戻り値:
内線番号
例外:
AccessorException - データの取得に失敗した場合

setExtensionNumber

public void setExtensionNumber(String extensionNumber)
                        throws AccessorException
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号
例外:
AccessorException - データの設定に失敗した場合

setExtensionNumber

public void setExtensionNumber(String extensionNumber,
                               Date date)
                        throws AccessorException
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getExtensionFaxNumber

public String getExtensionFaxNumber()
                             throws AccessorException
内線FAX番号を取得します。

戻り値:
内線FAX番号
例外:
AccessorException - データの取得に失敗した場合

getExtensionFaxNumber

public String getExtensionFaxNumber(Date date)
                             throws AccessorException
内線FAX番号を取得します。

パラメータ:
date - 日時
戻り値:
内線FAX番号
例外:
AccessorException - データの取得に失敗した場合

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber)
                           throws AccessorException
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号
例外:
AccessorException - データの設定に失敗した場合

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber,
                                  Date date)
                           throws AccessorException
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getCountryCode

public String getCountryCode()
                      throws AccessorException
国コードを取得します。

戻り値:
国コード
例外:
AccessorException - データの取得に失敗した場合

getCountryCode

public String getCountryCode(Date date)
                      throws AccessorException
国コードを取得します。

パラメータ:
date - 日時
戻り値:
国コード
例外:
AccessorException - データの取得に失敗した場合

setCountryCode

public void setCountryCode(String countryCode)
                    throws AccessorException
国コードを設定します。

パラメータ:
countryCode - 国コード
例外:
AccessorException - データの設定に失敗した場合

setCountryCode

public void setCountryCode(String countryCode,
                           Date date)
                    throws AccessorException
国コードを設定します。

パラメータ:
countryCode - 国コード
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getZipCode

public String getZipCode()
                  throws AccessorException
郵便番号を取得します。

戻り値:
郵便番号
例外:
AccessorException - データの取得に失敗した場合

getZipCode

public String getZipCode(Date date)
                  throws AccessorException
郵便番号を取得します。

パラメータ:
date - 日時
戻り値:
郵便番号
例外:
AccessorException - データの取得に失敗した場合

setZipCode

public void setZipCode(String zipCode)
                throws AccessorException
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号
例外:
AccessorException - データの設定に失敗した場合

setZipCode

public void setZipCode(String zipCode,
                       Date date)
                throws AccessorException
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getEmailAddress1

public String getEmailAddress1()
                        throws AccessorException
メールアドレス1を取得します。

戻り値:
メールアドレス1
例外:
AccessorException - データの取得に失敗した場合

getEmailAddress1

public String getEmailAddress1(Date date)
                        throws AccessorException
メールアドレス1を取得します。

パラメータ:
date - 日時
戻り値:
メールアドレス1
例外:
AccessorException - データの取得に失敗した場合

setEmailAddress1

public void setEmailAddress1(String emailAddress1)
                      throws AccessorException
メールアドレス1を設定します。

パラメータ:
emailAddress1 - メールアドレス1
例外:
AccessorException - データの設定に失敗した場合

setEmailAddress1

public void setEmailAddress1(String emailAddress1,
                             Date date)
                      throws AccessorException
メールアドレス1を設定します。

パラメータ:
emailAddress1 - メールアドレス1
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getEmailAddress2

public String getEmailAddress2()
                        throws AccessorException
メールアドレス2を取得します。

戻り値:
メールアドレス2
例外:
AccessorException - データの取得に失敗した場合

getEmailAddress2

public String getEmailAddress2(Date date)
                        throws AccessorException
メールアドレス2を取得します。

パラメータ:
date - 日時
戻り値:
メールアドレス2
例外:
AccessorException - データの取得に失敗した場合

setEmailAddress2

public void setEmailAddress2(String emailAddress2)
                      throws AccessorException
メールアドレス2を設定します。

パラメータ:
emailAddress2 - メールアドレス2
例外:
AccessorException - データの設定に失敗した場合

setEmailAddress2

public void setEmailAddress2(String emailAddress2,
                             Date date)
                      throws AccessorException
メールアドレス2を設定します。

パラメータ:
emailAddress2 - メールアドレス2
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getUrl

public String getUrl()
              throws AccessorException
URLを取得します。

戻り値:
URL
例外:
AccessorException - データの取得に失敗した場合

getUrl

public String getUrl(Date date)
              throws AccessorException
URLを取得します。

パラメータ:
date - 日時
戻り値:
URL
例外:
AccessorException - データの取得に失敗した場合

setUrl

public void setUrl(String url)
            throws AccessorException
URLを設定します。

パラメータ:
url - URL
例外:
AccessorException - データの設定に失敗した場合

setUrl

public void setUrl(String url,
                   Date date)
            throws AccessorException
URLを設定します。

パラメータ:
url - URL
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getName

public String getName()
               throws AccessorException
組織名を取得します。

戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Date date)
               throws AccessorException
組織名を取得します。

パラメータ:
date - 日時
戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
組織名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Date date,
                      Locale locale)
               throws AccessorException
組織名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
組織名を設定します。

パラメータ:
name - 組織名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Date date)
             throws AccessorException
組織名を設定します。

パラメータ:
name - 組織名
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
組織名を設定します。

パラメータ:
name - 組織名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Date date,
                    Locale locale)
             throws AccessorException
組織名を設定します。

パラメータ:
name - 組織名
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
組織名カナを取得します。

戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Date date)
                        throws AccessorException
組織名カナを取得します。

パラメータ:
date - 日時
戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Locale locale)
                        throws AccessorException
組織名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Date date,
                               Locale locale)
                        throws AccessorException
組織名カナを取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Date date)
                      throws AccessorException
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Locale locale)
                      throws AccessorException
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Date date,
                             Locale locale)
                      throws AccessorException
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
組織名英字を取得します。

戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Date date)
                      throws AccessorException
組織名英字を取得します。

パラメータ:
date - 日時
戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Locale locale)
                      throws AccessorException
組織名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Date date,
                             Locale locale)
                      throws AccessorException
組織名英字を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Date date)
                    throws AccessorException
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Locale locale)
                    throws AccessorException
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Date date,
                           Locale locale)
                    throws AccessorException
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getAddress1

public String getAddress1()
                   throws AccessorException
住所1を取得します。

戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

getAddress1

public String getAddress1(Date date)
                   throws AccessorException
住所1を取得します。

パラメータ:
date - 日時
戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

getAddress1

public String getAddress1(Locale locale)
                   throws AccessorException
住所1を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

getAddress1

public String getAddress1(Date date,
                          Locale locale)
                   throws AccessorException
住所1を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

setAddress1

public void setAddress1(String address1)
                 throws AccessorException
住所1を設定します。

パラメータ:
address1 - 住所1
例外:
AccessorException - データの設定に失敗した場合

setAddress1

public void setAddress1(String address1,
                        Date date)
                 throws AccessorException
住所1を設定します。

パラメータ:
address1 - 住所1
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setAddress1

public void setAddress1(String address1,
                        Locale locale)
                 throws AccessorException
住所1を設定します。

パラメータ:
address1 - 住所1
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setAddress1

public void setAddress1(String address1,
                        Date date,
                        Locale locale)
                 throws AccessorException
住所1を設定します。

パラメータ:
address1 - 住所1
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getAddress2

public String getAddress2()
                   throws AccessorException
住所2を取得します。

戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

getAddress2

public String getAddress2(Date date)
                   throws AccessorException
住所2を取得します。

パラメータ:
date - 日時
戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

getAddress2

public String getAddress2(Locale locale)
                   throws AccessorException
住所2を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

getAddress2

public String getAddress2(Date date,
                          Locale locale)
                   throws AccessorException
住所2を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

setAddress2

public void setAddress2(String address2)
                 throws AccessorException
住所2を設定します。

パラメータ:
address2 - 住所2
例外:
AccessorException - データの設定に失敗した場合

setAddress2

public void setAddress2(String address2,
                        Date date)
                 throws AccessorException
住所2を設定します。

パラメータ:
address2 - 住所2
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setAddress2

public void setAddress2(String address2,
                        Locale locale)
                 throws AccessorException
住所2を設定します。

パラメータ:
address2 - 住所2
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setAddress2

public void setAddress2(String address2,
                        Date date,
                        Locale locale)
                 throws AccessorException
住所2を設定します。

パラメータ:
address2 - 住所2
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectDepartmentTerminableModel

public DepartmentTerminableModel selectDepartmentTerminableModel(Date date)
                                                          throws IllegalTermException
指定された日付に該当する組織の期間化モデルを取得します。

パラメータ:
date - 指定日付
戻り値:
組織の期間化モデル
例外:
IllegalTermException - 指定された日付に該当する期間が定義されていない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DepartmentMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.department
インタフェース DepartmentMapper

すべてのスーパーインタフェース:
Mapper
public interface DepartmentMapper
extends Mapper

組織に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
DepartmentBaseModel | create(String companyCode, String departmentCode) プライマリキーに該当する組織を生成します。
void | delete(Collection models) 組織の基本モデルを複数削除します。
void | delete(DepartmentBaseModel model) 組織の基本モデルを1つだけ削除します。
void | insert(Collection models) 組織の基本モデルを複数挿入します。
void | insert(DepartmentBaseModel model) 組織の基本モデルを1つだけ挿入します。
DepartmentBaseModel | select(String companyCode, String departmentCode) プライマリーキーで特定される組織の基本モデルを取得します。
void | update(Collection models) 組織の基本モデルを複数更新します。
void | update(DepartmentBaseModel model) 組織の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public DepartmentBaseModel create(String companyCode,
                                  String departmentCode)
                           throws MapperException
プライマリキーに該当する組織を生成します。

パラメータ:
companyCode - 会社コード
departmentCode - 組織コード
戻り値:
プライマリキーに該当する組織の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public DepartmentBaseModel select(String companyCode,
                                  String departmentCode)
                           throws MapperException
プライマリーキーで特定される組織の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
companyCode - 会社コード
departmentCode - 組織コード
戻り値:
組織の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(DepartmentBaseModel model)
            throws MapperException
組織の基本モデルを1つだけ挿入します。 引数に指定する組織の基本モデルは同一の DepartmentMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する組織の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
組織の基本モデルを複数挿入します。 引数に指定するものは同一の DepartmentMapperの create(String,String) で生成された組織の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する組織の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(DepartmentBaseModel model)
            throws MapperException
組織の基本モデルを1つだけ更新します。 引数に指定する組織の基本モデルは同一の DepartmentMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する組織の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
組織の基本モデルを複数更新します。 引数に指定するものは同一の DepartmentMapperの select 系メソッド から取得されたものかで生成された組織の基本モデルの集合である必要があります。

パラメータ:
models - 更新する組織の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(DepartmentBaseModel model)
            throws MapperException
組織の基本モデルを1つだけ削除します。 引数で指定された組織の基本モデルに該当するデータのすべての情報を削除します。引数に指定する組織の基本モデルは同一の DepartmentMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する組織の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
組織の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する組織の基本モデルは同一の DepartmentMapperの select 系メソッド から取得された組織の基本モデルの集合である必要があります。

パラメータ:
models - 削除する組織の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DepartmentTerminableInternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.department
インタフェース DepartmentTerminableInternationalModel

すべてのスーパーインタフェース:
Serializable, TerminableInternationalModel
public interface DepartmentTerminableInternationalModel
extends TerminableInternationalModel

組織の期間国際化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getAddress1() 住所1を取得します。
String | getAddress2() 住所2を取得します。
String | getName() 組織名を取得します。
String | getNameEnglish() 組織名英字を取得します。
String | getNameSyllabary() 組織名カナを取得します。
void | setAddress1(String address1) 住所1を設定します。
void | setAddress2(String address2) 住所2を設定します。
void | setName(String name) 組織名を設定します。
void | setNameEnglish(String nameEnglish) 組織名英字を設定します。
void | setNameSyllabary(String nameSyllabary) 組織名カナを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel から継承したメソッド
getExtendedTerminableInternationalModelMap, getLocale, init

メソッドの詳細

getName

public String getName()
               throws AccessorException
組織名を取得します。

戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
組織名を設定します。

パラメータ:
name - 組織名
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
組織名カナを取得します。

戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
組織名英字を取得します。

戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字
例外:
AccessorException - データの設定に失敗した場合

getAddress1

public String getAddress1()
                   throws AccessorException
住所1を取得します。

戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

setAddress1

public void setAddress1(String address1)
                 throws AccessorException
住所1を設定します。

パラメータ:
address1 - 住所1
例外:
AccessorException - データの設定に失敗した場合

getAddress2

public String getAddress2()
                   throws AccessorException
住所2を取得します。

戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

setAddress2

public void setAddress2(String address2)
                 throws AccessorException
住所2を設定します。

パラメータ:
address2 - 住所2
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DepartmentTerminableModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.department
インタフェース DepartmentTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface DepartmentTerminableModel
extends TerminableModel

組織の期間化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getAddress1() 住所1を取得します。
String | getAddress1(Locale locale) 住所1を取得します。
String | getAddress2() 住所2を取得します。
String | getAddress2(Locale locale) 住所2を取得します。
String | getCountryCode() 国コードを取得します。
String | getEmailAddress1() メールアドレス1を取得します。
String | getEmailAddress2() メールアドレス2を取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
String | getName() 組織名を取得します。
String | getName(Locale locale) 組織名を取得します。
String | getNameEnglish() 組織名英字を取得します。
String | getNameEnglish(Locale locale) 組織名英字を取得します。
String | getNameSyllabary() 組織名カナを取得します。
String | getNameSyllabary(Locale locale) 組織名カナを取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getUrl() URLを取得します。
String | getZipCode() 郵便番号を取得します。
DepartmentTerminableInternationalModel | selectDepartmentTerminableInternationalModel(Locale locale) 指定された言語に該当する組織の期間国際化モデルを取得します。
void | setAddress1(String address1) 住所1を設定します。
void | setAddress1(String address1, Locale locale) 住所1を設定します。
void | setAddress2(String address2) 住所2を設定します。
void | setAddress2(String address2, Locale locale) 住所2を設定します。
void | setCountryCode(String countryCode) 国コードを設定します。
void | setEmailAddress1(String emailAddress1) メールアドレス1を設定します。
void | setEmailAddress2(String emailAddress2) メールアドレス2を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | setFaxNumber(String faxNumber) FAX番号を設定します。
void | setName(String name) 組織名を設定します。
void | setName(String name, Locale locale) 組織名を設定します。
void | setNameEnglish(String nameEnglish) 組織名英字を設定します。
void | setNameEnglish(String nameEnglish, Locale locale) 組織名英字を設定します。
void | setNameSyllabary(String nameSyllabary) 組織名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Locale locale) 組織名カナを設定します。
void | setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | setUrl(String url) URLを設定します。
void | setZipCode(String zipCode) 郵便番号を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

メソッドの詳細

getTelephoneNumber

public String getTelephoneNumber()
                          throws AccessorException
電話番号を取得します。

戻り値:
電話番号
例外:
AccessorException - データの取得に失敗した場合

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber)
                        throws AccessorException
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号
例外:
AccessorException - データの設定に失敗した場合

getFaxNumber

public String getFaxNumber()
                    throws AccessorException
FAX番号を取得します。

戻り値:
FAX番号
例外:
AccessorException - データの取得に失敗した場合

setFaxNumber

public void setFaxNumber(String faxNumber)
                  throws AccessorException
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号
例外:
AccessorException - データの設定に失敗した場合

getExtensionNumber

public String getExtensionNumber()
                          throws AccessorException
内線番号を取得します。

戻り値:
内線番号
例外:
AccessorException - データの取得に失敗した場合

setExtensionNumber

public void setExtensionNumber(String extensionNumber)
                        throws AccessorException
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号
例外:
AccessorException - データの設定に失敗した場合

getExtensionFaxNumber

public String getExtensionFaxNumber()
                             throws AccessorException
内線FAX番号を取得します。

戻り値:
内線FAX番号
例外:
AccessorException - データの取得に失敗した場合

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber)
                           throws AccessorException
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号
例外:
AccessorException - データの設定に失敗した場合

getCountryCode

public String getCountryCode()
                      throws AccessorException
国コードを取得します。

戻り値:
国コード
例外:
AccessorException - データの取得に失敗した場合

setCountryCode

public void setCountryCode(String countryCode)
                    throws AccessorException
国コードを設定します。

パラメータ:
countryCode - 国コード
例外:
AccessorException - データの設定に失敗した場合

getZipCode

public String getZipCode()
                  throws AccessorException
郵便番号を取得します。

戻り値:
郵便番号
例外:
AccessorException - データの取得に失敗した場合

setZipCode

public void setZipCode(String zipCode)
                throws AccessorException
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号
例外:
AccessorException - データの設定に失敗した場合

getEmailAddress1

public String getEmailAddress1()
                        throws AccessorException
メールアドレス1を取得します。

戻り値:
メールアドレス1
例外:
AccessorException - データの取得に失敗した場合

setEmailAddress1

public void setEmailAddress1(String emailAddress1)
                      throws AccessorException
メールアドレス1を設定します。

パラメータ:
emailAddress1 - メールアドレス1
例外:
AccessorException - データの設定に失敗した場合

getEmailAddress2

public String getEmailAddress2()
                        throws AccessorException
メールアドレス2を取得します。

戻り値:
メールアドレス2
例外:
AccessorException - データの取得に失敗した場合

setEmailAddress2

public void setEmailAddress2(String emailAddress2)
                      throws AccessorException
メールアドレス2を設定します。

パラメータ:
emailAddress2 - メールアドレス2
例外:
AccessorException - データの設定に失敗した場合

getUrl

public String getUrl()
              throws AccessorException
URLを取得します。

戻り値:
URL
例外:
AccessorException - データの取得に失敗した場合

setUrl

public void setUrl(String url)
            throws AccessorException
URLを設定します。

パラメータ:
url - URL
例外:
AccessorException - データの設定に失敗した場合

getName

public String getName()
               throws AccessorException
組織名を取得します。

戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
組織名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
組織名を設定します。

パラメータ:
name - 組織名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
組織名を設定します。

パラメータ:
name - 組織名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
組織名カナを取得します。

戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Locale locale)
                        throws AccessorException
組織名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Locale locale)
                      throws AccessorException
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
組織名英字を取得します。

戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Locale locale)
                      throws AccessorException
組織名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Locale locale)
                    throws AccessorException
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getAddress1

public String getAddress1()
                   throws AccessorException
住所1を取得します。

戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

getAddress1

public String getAddress1(Locale locale)
                   throws AccessorException
住所1を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

setAddress1

public void setAddress1(String address1)
                 throws AccessorException
住所1を設定します。

パラメータ:
address1 - 住所1
例外:
AccessorException - データの設定に失敗した場合

setAddress1

public void setAddress1(String address1,
                        Locale locale)
                 throws AccessorException
住所1を設定します。

パラメータ:
address1 - 住所1
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getAddress2

public String getAddress2()
                   throws AccessorException
住所2を取得します。

戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

getAddress2

public String getAddress2(Locale locale)
                   throws AccessorException
住所2を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

setAddress2

public void setAddress2(String address2)
                 throws AccessorException
住所2を設定します。

パラメータ:
address2 - 住所2
例外:
AccessorException - データの設定に失敗した場合

setAddress2

public void setAddress2(String address2,
                        Locale locale)
                 throws AccessorException
住所2を設定します。

パラメータ:
address2 - 住所2
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectDepartmentTerminableInternationalModel

public DepartmentTerminableInternationalModel selectDepartmentTerminableInternationalModel(Locale locale)
                                                                                throws IllegalLocaleException
指定された言語に該当する組織の期間国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織の期間国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.company.department (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.company.department
インタフェース
DepartmentBaseModel
DepartmentMapper
DepartmentTerminableInternationalModel
DepartmentTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.company.department (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.department

組織情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
DepartmentBaseModel | 組織の基本モデルです。
DepartmentMapper | 組織に関連するマッパです。
DepartmentTerminableInternationalModel | 組織の期間国際化モデルです。
DepartmentTerminableModel | 組織の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.department の説明

組織情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.company.department クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.department の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.department の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.department の使用

jp.co.intra_mart.foundation.datastore.application.model.company.department を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.department 組織情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.department により使用される jp.co.intra_mart.foundation.datastore.application.model.company.department のクラス
DepartmentBaseModel
組織の基本モデルです。
DepartmentTerminableInternationalModel
組織の期間国際化モデルです。
DepartmentTerminableModel
組織の期間化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の使用

DepartmentInclusionBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion 組織内包情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion での DepartmentInclusionBaseModel の使用

DepartmentInclusionBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.inclusion のメソッド
DepartmentInclusionBaseModel | DepartmentInclusionMapper.create(String companyCode, String versionCode, String parentDepartmentCode, String departmentCode) プライマリキーに該当する組織内包を生成します。
DepartmentInclusionBaseModel | DepartmentInclusionMapper.select(String companyCode, String versionCode, String parentDepartmentCode, String departmentCode) プライマリーキーで特定される組織内包の基本モデルを取得します。

DepartmentInclusionBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.company.inclusion のメソッド
void | DepartmentInclusionMapper.insert(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ挿入します。
void | DepartmentInclusionMapper.update(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ更新します。
void | DepartmentInclusionMapper.delete(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DepartmentInclusionBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion
インタフェース DepartmentInclusionBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface DepartmentInclusionBaseModel
extends BaseModel

組織内包の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | COMPANY_CODE 会社コード
static String | DEPARTMENT_CODE 組織コード
static String | DEPTH 階層レベル
static String | PARENT_DEPARTMENT_CODE 親組織コード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | VERSION_CODE バージョンコード
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
int | getDepth() 階層レベルを取得します。
String | getParentDepartmentCode() 親組織コードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getVersionCode() バージョンコードを取得します。
void | setDepth(int depth) 階層レベルを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

VERSION_CODE

public static final String VERSION_CODE
バージョンコード

関連項目:
定数フィールド値

PARENT_DEPARTMENT_CODE

public static final String PARENT_DEPARTMENT_CODE
親組織コード

関連項目:
定数フィールド値

DEPARTMENT_CODE

public static final String DEPARTMENT_CODE
組織コード

関連項目:
定数フィールド値

DEPTH

public static final String DEPTH
階層レベル

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getVersionCode

public String getVersionCode()
                      throws AccessorException
バージョンコードを取得します。

戻り値:
バージョンコード
例外:
AccessorException - データの取得に失敗した場合

getParentDepartmentCode

public String getParentDepartmentCode()
                               throws AccessorException
親組織コードを取得します。

戻り値:
親組織コード
例外:
AccessorException - データの取得に失敗した場合

getDepartmentCode

public String getDepartmentCode()
                         throws AccessorException
組織コードを取得します。

戻り値:
組織コード
例外:
AccessorException - データの取得に失敗した場合

getDepth

public int getDepth()
             throws AccessorException
階層レベルを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
階層レベル
例外:
AccessorException - データの取得に失敗した場合

setDepth

public void setDepth(int depth)
              throws AccessorException
階層レベルを設定します。

パラメータ:
depth - 階層レベル
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DepartmentInclusionMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion
インタフェース DepartmentInclusionMapper

すべてのスーパーインタフェース:
Mapper
public interface DepartmentInclusionMapper
extends Mapper

組織内包に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
DepartmentInclusionBaseModel | create(String companyCode, String versionCode, String parentDepartmentCode, String departmentCode) プライマリキーに該当する組織内包を生成します。
void | delete(Collection models) 組織内包の基本モデルを複数削除します。
void | delete(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ削除します。
void | insert(Collection models) 組織内包の基本モデルを複数挿入します。
void | insert(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ挿入します。
DepartmentInclusionBaseModel | select(String companyCode, String versionCode, String parentDepartmentCode, String departmentCode) プライマリーキーで特定される組織内包の基本モデルを取得します。
void | update(Collection models) 組織内包の基本モデルを複数更新します。
void | update(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public DepartmentInclusionBaseModel create(String companyCode,
                                           String versionCode,
                                           String parentDepartmentCode,
                                           String departmentCode)
                                    throws MapperException
プライマリキーに該当する組織内包を生成します。

パラメータ:
companyCode - 会社コード
versionCode - バージョンコード
parentDepartmentCode - 親組織コード
departmentCode - 組織コード
戻り値:
プライマリキーに該当する組織内包の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public DepartmentInclusionBaseModel select(String companyCode,
                                           String versionCode,
                                           String parentDepartmentCode,
                                           String departmentCode)
                                    throws MapperException
プライマリーキーで特定される組織内包の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
companyCode - 会社コード
versionCode - バージョンコード
parentDepartmentCode - 親組織コード
departmentCode - 組織コード
戻り値:
組織内包の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(DepartmentInclusionBaseModel model)
            throws MapperException
組織内包の基本モデルを1つだけ挿入します。 引数に指定する組織内包の基本モデルは同一の DepartmentInclusionMapperの create(String,String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する組織内包の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
組織内包の基本モデルを複数挿入します。 引数に指定するものは同一の DepartmentInclusionMapperの create(String,String,String,String) で生成された組織内包の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する組織内包の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(DepartmentInclusionBaseModel model)
            throws MapperException
組織内包の基本モデルを1つだけ更新します。 引数に指定する組織内包の基本モデルは同一の DepartmentInclusionMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する組織内包の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
組織内包の基本モデルを複数更新します。 引数に指定するものは同一の DepartmentInclusionMapperの select 系メソッド から取得されたものかで生成された組織内包の基本モデルの集合である必要があります。

パラメータ:
models - 更新する組織内包の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(DepartmentInclusionBaseModel model)
            throws MapperException
組織内包の基本モデルを1つだけ削除します。 引数で指定された組織内包の基本モデルに該当するデータのすべての情報を削除します。引数に指定する組織内包の基本モデルは同一の DepartmentInclusionMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する組織内包の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
組織内包の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する組織内包の基本モデルは同一の DepartmentInclusionMapperの select 系メソッド から取得された組織内包の基本モデルの集合である必要があります。

パラメータ:
models - 削除する組織内包の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.company.inclusion (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.company.inclusion
インタフェース
DepartmentInclusionBaseModel
DepartmentInclusionMapper


jp.co.intra_mart.foundation.datastore.application.model.company.inclusion (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.inclusion

組織内包情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
DepartmentInclusionBaseModel | 組織内包の基本モデルです。
DepartmentInclusionMapper | 組織内包に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.inclusion の説明

組織内包情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.company.inclusion クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.inclusion の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.inclusion の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion の使用

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion 組織内包情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion により使用される jp.co.intra_mart.foundation.datastore.application.model.company.inclusion のクラス
DepartmentInclusionBaseModel
組織内包の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の使用

DepartmentMainBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.main 組織主所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.main での DepartmentMainBaseModel の使用

DepartmentMainBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.main のメソッド
DepartmentMainBaseModel | DepartmentMainMapper.create(String userCode) プライマリキーに該当する主所属を生成します。
DepartmentMainBaseModel | DepartmentMainMapper.select(String userCode) プライマリーキーで特定される主所属の基本モデルを取得します。

DepartmentMainBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.company.main のメソッド
void | DepartmentMainMapper.insert(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ挿入します。
void | DepartmentMainMapper.update(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ更新します。
void | DepartmentMainMapper.delete(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel の使用

DepartmentMainTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.main 組織主所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.main での DepartmentMainTerminableModel の使用

DepartmentMainTerminableModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.main のメソッド
 DepartmentMainTerminableModel DepartmentMainBaseModel.selectDepartmentMainTerminableModel(Date date)
指定された日付に該当する主所属の期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DepartmentMainBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.main
インタフェース DepartmentMainBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface DepartmentMainBaseModel
extends BaseModel

主所属の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | COMPANY_CODE 会社コード
static String | DEPARTMENT_CODE 組織コード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | USER_CODE ユーザコード
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getCompanyCode(Date date) 会社コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
String | getDepartmentCode(Date date) 組織コードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getUserCode() ユーザコードを取得します。
DepartmentMainTerminableModel | selectDepartmentMainTerminableModel(Date date) 指定された日付に該当する主所属の期間化モデルを取得します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setCompanyCode(String companyCode, Date date) 会社コードを設定します。
void | setDepartmentCode(String departmentCode) 組織コードを設定します。
void | setDepartmentCode(String departmentCode, Date date) 組織コードを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

USER_CODE

public static final String USER_CODE
ユーザコード

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

DEPARTMENT_CODE

public static final String DEPARTMENT_CODE
組織コード

関連項目:
定数フィールド値
メソッドの詳細

getUserCode

public String getUserCode()
                   throws AccessorException
ユーザコードを取得します。

戻り値:
ユーザコード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getCompanyCode

public String getCompanyCode(Date date)
                      throws AccessorException
会社コードを取得します。

パラメータ:
date - 日時
戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

setCompanyCode

public void setCompanyCode(String companyCode)
                    throws AccessorException
会社コードを設定します。

パラメータ:
companyCode - 会社コード
例外:
AccessorException - データの設定に失敗した場合

setCompanyCode

public void setCompanyCode(String companyCode,
                           Date date)
                    throws AccessorException
会社コードを設定します。

パラメータ:
companyCode - 会社コード
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getDepartmentCode

public String getDepartmentCode()
                         throws AccessorException
組織コードを取得します。

戻り値:
組織コード
例外:
AccessorException - データの取得に失敗した場合

getDepartmentCode

public String getDepartmentCode(Date date)
                         throws AccessorException
組織コードを取得します。

パラメータ:
date - 日時
戻り値:
組織コード
例外:
AccessorException - データの取得に失敗した場合

setDepartmentCode

public void setDepartmentCode(String departmentCode)
                       throws AccessorException
組織コードを設定します。

パラメータ:
departmentCode - 組織コード
例外:
AccessorException - データの設定に失敗した場合

setDepartmentCode

public void setDepartmentCode(String departmentCode,
                              Date date)
                       throws AccessorException
組織コードを設定します。

パラメータ:
departmentCode - 組織コード
date - 日時
例外:
AccessorException - データの設定に失敗した場合

selectDepartmentMainTerminableModel

public DepartmentMainTerminableModel selectDepartmentMainTerminableModel(Date date)
                                                                  throws IllegalTermException
指定された日付に該当する主所属の期間化モデルを取得します。

パラメータ:
date - 指定日付
戻り値:
主所属の期間化モデル
例外:
IllegalTermException - 指定された日付に該当する期間が定義されていない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DepartmentMainMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.main
インタフェース DepartmentMainMapper

すべてのスーパーインタフェース:
Mapper
public interface DepartmentMainMapper
extends Mapper

主所属に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
DepartmentMainBaseModel | create(String userCode) プライマリキーに該当する主所属を生成します。
void | delete(Collection models) 主所属の基本モデルを複数削除します。
void | delete(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ削除します。
void | insert(Collection models) 主所属の基本モデルを複数挿入します。
void | insert(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ挿入します。
DepartmentMainBaseModel | select(String userCode) プライマリーキーで特定される主所属の基本モデルを取得します。
void | update(Collection models) 主所属の基本モデルを複数更新します。
void | update(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public DepartmentMainBaseModel create(String userCode)
                               throws MapperException
プライマリキーに該当する主所属を生成します。

パラメータ:
userCode - ユーザコード
戻り値:
プライマリキーに該当する主所属の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public DepartmentMainBaseModel select(String userCode)
                               throws MapperException
プライマリーキーで特定される主所属の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
userCode - ユーザコード
戻り値:
主所属の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(DepartmentMainBaseModel model)
            throws MapperException
主所属の基本モデルを1つだけ挿入します。 引数に指定する主所属の基本モデルは同一の DepartmentMainMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入する主所属の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
主所属の基本モデルを複数挿入します。 引数に指定するものは同一の DepartmentMainMapperの create(String) で生成された主所属の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する主所属の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(DepartmentMainBaseModel model)
            throws MapperException
主所属の基本モデルを1つだけ更新します。 引数に指定する主所属の基本モデルは同一の DepartmentMainMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する主所属の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
主所属の基本モデルを複数更新します。 引数に指定するものは同一の DepartmentMainMapperの select 系メソッド から取得されたものかで生成された主所属の基本モデルの集合である必要があります。

パラメータ:
models - 更新する主所属の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(DepartmentMainBaseModel model)
            throws MapperException
主所属の基本モデルを1つだけ削除します。 引数で指定された主所属の基本モデルに該当するデータのすべての情報を削除します。引数に指定する主所属の基本モデルは同一の DepartmentMainMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する主所属の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
主所属の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する主所属の基本モデルは同一の DepartmentMainMapperの select 系メソッド から取得された主所属の基本モデルの集合である必要があります。

パラメータ:
models - 削除する主所属の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DepartmentMainTerminableModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.main
インタフェース DepartmentMainTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface DepartmentMainTerminableModel
extends TerminableModel

主所属の期間化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setDepartmentCode(String departmentCode) 組織コードを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

メソッドの詳細

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

setCompanyCode

public void setCompanyCode(String companyCode)
                    throws AccessorException
会社コードを設定します。

パラメータ:
companyCode - 会社コード
例外:
AccessorException - データの設定に失敗した場合

getDepartmentCode

public String getDepartmentCode()
                         throws AccessorException
組織コードを取得します。

戻り値:
組織コード
例外:
AccessorException - データの取得に失敗した場合

setDepartmentCode

public void setDepartmentCode(String departmentCode)
                       throws AccessorException
組織コードを設定します。

パラメータ:
departmentCode - 組織コード
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.company.main (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.company.main
インタフェース
DepartmentMainBaseModel
DepartmentMainMapper
DepartmentMainTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.company.main (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.main

組織主所属情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
DepartmentMainBaseModel | 主所属の基本モデルです。
DepartmentMainMapper | 主所属に関連するマッパです。
DepartmentMainTerminableModel | 主所属の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.main の説明

組織主所属情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.company.main クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.main の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.main の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.main の使用

jp.co.intra_mart.foundation.datastore.application.model.company.main を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.main 組織主所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.main により使用される jp.co.intra_mart.foundation.datastore.application.model.company.main のクラス
DepartmentMainBaseModel
主所属の基本モデルです。
DepartmentMainTerminableModel
主所属の期間化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の使用

CompanyPostBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.post 会社役職情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.post での CompanyPostBaseModel の使用

CompanyPostBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.post のメソッド
CompanyPostBaseModel | CompanyPostMapper.create(String companyCode, String postCode) プライマリキーに該当する役職を生成します。
CompanyPostBaseModel | CompanyPostMapper.select(String companyCode, String postCode) プライマリーキーで特定される役職の基本モデルを取得します。

CompanyPostBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.company.post のメソッド
void | CompanyPostMapper.insert(CompanyPostBaseModel model) 役職の基本モデルを1つだけ挿入します。
void | CompanyPostMapper.update(CompanyPostBaseModel model) 役職の基本モデルを1つだけ更新します。
void | CompanyPostMapper.delete(CompanyPostBaseModel model) 役職の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel の使用

CompanyPostTerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.post 会社役職情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.post での CompanyPostTerminableInternationalModel の使用

CompanyPostTerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.post のメソッド
 CompanyPostTerminableInternationalModel CompanyPostTerminableModel.selectCompanyPostTerminableInternationalModel(Locale locale)
指定された言語に該当する役職の期間国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel の使用

CompanyPostTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.post 会社役職情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.post での CompanyPostTerminableModel の使用

CompanyPostTerminableModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.post のメソッド
 CompanyPostTerminableModel CompanyPostBaseModel.selectCompanyPostTerminableModel(Date date)
指定された日付に該当する役職の期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CompanyPostBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.post
インタフェース CompanyPostBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface CompanyPostBaseModel
extends BaseModel

役職の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | COMPANY_CODE 会社コード
static String | NAME 役職名
static String | NOTES 備考
static String | POST_CODE 役職コード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getName() 役職名を取得します。
String | getName(Date date) 役職名を取得します。
String | getName(Date date, Locale locale) 役職名を取得します。
String | getName(Locale locale) 役職名を取得します。
String | getNotes() 備考を取得します。
String | getPostCode() 役職コードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
CompanyPostTerminableModel | selectCompanyPostTerminableModel(Date date) 指定された日付に該当する役職の期間化モデルを取得します。
void | setName(String name) 役職名を設定します。
void | setName(String name, Date date) 役職名を設定します。
void | setName(String name, Date date, Locale locale) 役職名を設定します。
void | setName(String name, Locale locale) 役職名を設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

POST_CODE

public static final String POST_CODE
役職コード

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

NAME

public static final String NAME
役職名

関連項目:
定数フィールド値
メソッドの詳細

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getPostCode

public String getPostCode()
                   throws AccessorException
役職コードを取得します。

戻り値:
役職コード
例外:
AccessorException - データの取得に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName()
               throws AccessorException
役職名を取得します。

戻り値:
役職名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Date date)
               throws AccessorException
役職名を取得します。

パラメータ:
date - 日時
戻り値:
役職名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
役職名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
役職名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Date date,
                      Locale locale)
               throws AccessorException
役職名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
役職名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
役職名を設定します。

パラメータ:
name - 役職名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Date date)
             throws AccessorException
役職名を設定します。

パラメータ:
name - 役職名
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
役職名を設定します。

パラメータ:
name - 役職名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Date date,
                    Locale locale)
             throws AccessorException
役職名を設定します。

パラメータ:
name - 役職名
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectCompanyPostTerminableModel

public CompanyPostTerminableModel selectCompanyPostTerminableModel(Date date)
                                                            throws IllegalTermException
指定された日付に該当する役職の期間化モデルを取得します。

パラメータ:
date - 指定日付
戻り値:
役職の期間化モデル
例外:
IllegalTermException - 指定された日付に該当する期間が定義されていない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyPostMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.post
インタフェース CompanyPostMapper

すべてのスーパーインタフェース:
Mapper
public interface CompanyPostMapper
extends Mapper

役職に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
CompanyPostBaseModel | create(String companyCode, String postCode) プライマリキーに該当する役職を生成します。
void | delete(Collection models) 役職の基本モデルを複数削除します。
void | delete(CompanyPostBaseModel model) 役職の基本モデルを1つだけ削除します。
void | insert(Collection models) 役職の基本モデルを複数挿入します。
void | insert(CompanyPostBaseModel model) 役職の基本モデルを1つだけ挿入します。
CompanyPostBaseModel | select(String companyCode, String postCode) プライマリーキーで特定される役職の基本モデルを取得します。
void | update(Collection models) 役職の基本モデルを複数更新します。
void | update(CompanyPostBaseModel model) 役職の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public CompanyPostBaseModel create(String companyCode,
                                   String postCode)
                            throws MapperException
プライマリキーに該当する役職を生成します。

パラメータ:
companyCode - 会社コード
postCode - 役職コード
戻り値:
プライマリキーに該当する役職の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public CompanyPostBaseModel select(String companyCode,
                                   String postCode)
                            throws MapperException
プライマリーキーで特定される役職の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
companyCode - 会社コード
postCode - 役職コード
戻り値:
役職の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(CompanyPostBaseModel model)
            throws MapperException
役職の基本モデルを1つだけ挿入します。 引数に指定する役職の基本モデルは同一の CompanyPostMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する役職の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
役職の基本モデルを複数挿入します。 引数に指定するものは同一の CompanyPostMapperの create(String,String) で生成された役職の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する役職の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(CompanyPostBaseModel model)
            throws MapperException
役職の基本モデルを1つだけ更新します。 引数に指定する役職の基本モデルは同一の CompanyPostMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する役職の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
役職の基本モデルを複数更新します。 引数に指定するものは同一の CompanyPostMapperの select 系メソッド から取得されたものかで生成された役職の基本モデルの集合である必要があります。

パラメータ:
models - 更新する役職の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(CompanyPostBaseModel model)
            throws MapperException
役職の基本モデルを1つだけ削除します。 引数で指定された役職の基本モデルに該当するデータのすべての情報を削除します。引数に指定する役職の基本モデルは同一の CompanyPostMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する役職の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
役職の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する役職の基本モデルは同一の CompanyPostMapperの select 系メソッド から取得された役職の基本モデルの集合である必要があります。

パラメータ:
models - 削除する役職の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyPostTerminableInternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.post
インタフェース CompanyPostTerminableInternationalModel

すべてのスーパーインタフェース:
Serializable, TerminableInternationalModel
public interface CompanyPostTerminableInternationalModel
extends TerminableInternationalModel

役職の期間国際化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getName() 役職名を取得します。
void | setName(String name) 役職名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel から継承したメソッド
getExtendedTerminableInternationalModelMap, getLocale, init

メソッドの詳細

getName

public String getName()
               throws AccessorException
役職名を取得します。

戻り値:
役職名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
役職名を設定します。

パラメータ:
name - 役職名
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyPostTerminableModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.post
インタフェース CompanyPostTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface CompanyPostTerminableModel
extends TerminableModel

役職の期間化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getName() 役職名を取得します。
String | getName(Locale locale) 役職名を取得します。
CompanyPostTerminableInternationalModel | selectCompanyPostTerminableInternationalModel(Locale locale) 指定された言語に該当する役職の期間国際化モデルを取得します。
void | setName(String name) 役職名を設定します。
void | setName(String name, Locale locale) 役職名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

メソッドの詳細

getName

public String getName()
               throws AccessorException
役職名を取得します。

戻り値:
役職名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
役職名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
役職名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
役職名を設定します。

パラメータ:
name - 役職名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
役職名を設定します。

パラメータ:
name - 役職名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectCompanyPostTerminableInternationalModel

public CompanyPostTerminableInternationalModel selectCompanyPostTerminableInternationalModel(Locale locale)
                                                                                throws IllegalLocaleException
指定された言語に該当する役職の期間国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
役職の期間国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.company.post (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.company.post
インタフェース
CompanyPostBaseModel
CompanyPostMapper
CompanyPostTerminableInternationalModel
CompanyPostTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.company.post (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.post

会社役職情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
CompanyPostBaseModel | 役職の基本モデルです。
CompanyPostMapper | 役職に関連するマッパです。
CompanyPostTerminableInternationalModel | 役職の期間国際化モデルです。
CompanyPostTerminableModel | 役職の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.post の説明

会社役職情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.company.post クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.post の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.post の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.post の使用

jp.co.intra_mart.foundation.datastore.application.model.company.post を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.post 会社役職情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.post により使用される jp.co.intra_mart.foundation.datastore.application.model.company.post のクラス
CompanyPostBaseModel
役職の基本モデルです。
CompanyPostTerminableInternationalModel
役職の期間国際化モデルです。
CompanyPostTerminableModel
役職の期間化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の使用

CompanyVersionBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.version 会社バージョン情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.version での CompanyVersionBaseModel の使用

CompanyVersionBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.version のメソッド
CompanyVersionBaseModel | CompanyVersionMapper.create(String companyCode, String versionCode) プライマリキーに該当する会社構成バージョンを生成します。
CompanyVersionBaseModel | CompanyVersionMapper.select(String companyCode, String versionCode) プライマリーキーで特定される会社構成バージョンの基本モデルを取得します。

CompanyVersionBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.company.version のメソッド
void | CompanyVersionMapper.insert(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ挿入します。
void | CompanyVersionMapper.update(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ更新します。
void | CompanyVersionMapper.delete(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CompanyVersionBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.version
インタフェース CompanyVersionBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface CompanyVersionBaseModel
extends BaseModel

会社構成バージョンの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | COMPANY_CODE 会社コード
static String | END_DATE 終了日
static String | NOTES 備考
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | START_DATE 開始日
static String | VERSION_CODE バージョンコード
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
Date | getEndDate() 終了日を取得します。
String | getNotes() 備考を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
Date | getStartDate() 開始日を取得します。
String | getVersionCode() バージョンコードを取得します。
void | setEndDate(Date endDate) 終了日を設定します。
void | setNotes(String notes) 備考を設定します。
void | setStartDate(Date startDate) 開始日を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

VERSION_CODE

public static final String VERSION_CODE
バージョンコード

関連項目:
定数フィールド値

START_DATE

public static final String START_DATE
開始日

関連項目:
定数フィールド値

END_DATE

public static final String END_DATE
終了日

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getVersionCode

public String getVersionCode()
                      throws AccessorException
バージョンコードを取得します。

戻り値:
バージョンコード
例外:
AccessorException - データの取得に失敗した場合

getStartDate

public Date getStartDate()
                  throws AccessorException
開始日を取得します。

戻り値:
開始日
例外:
AccessorException - データの取得に失敗した場合

setStartDate

public void setStartDate(Date startDate)
                  throws AccessorException
開始日を設定します。

パラメータ:
startDate - 開始日
例外:
AccessorException - データの設定に失敗した場合

getEndDate

public Date getEndDate()
                throws AccessorException
終了日を取得します。

戻り値:
終了日
例外:
AccessorException - データの取得に失敗した場合

setEndDate

public void setEndDate(Date endDate)
                throws AccessorException
終了日を設定します。

パラメータ:
endDate - 終了日
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyVersionMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.version
インタフェース CompanyVersionMapper

すべてのスーパーインタフェース:
Mapper
public interface CompanyVersionMapper
extends Mapper

会社構成バージョンに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
CompanyVersionBaseModel | create(String companyCode, String versionCode) プライマリキーに該当する会社構成バージョンを生成します。
void | delete(Collection models) 会社構成バージョンの基本モデルを複数削除します。
void | delete(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ削除します。
void | insert(Collection models) 会社構成バージョンの基本モデルを複数挿入します。
void | insert(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ挿入します。
CompanyVersionBaseModel | select(String companyCode, String versionCode) プライマリーキーで特定される会社構成バージョンの基本モデルを取得します。
void | update(Collection models) 会社構成バージョンの基本モデルを複数更新します。
void | update(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public CompanyVersionBaseModel create(String companyCode,
                                      String versionCode)
                               throws MapperException
プライマリキーに該当する会社構成バージョンを生成します。

パラメータ:
companyCode - 会社コード
versionCode - バージョンコード
戻り値:
プライマリキーに該当する会社構成バージョンの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public CompanyVersionBaseModel select(String companyCode,
                                      String versionCode)
                               throws MapperException
プライマリーキーで特定される会社構成バージョンの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
companyCode - 会社コード
versionCode - バージョンコード
戻り値:
会社構成バージョンの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(CompanyVersionBaseModel model)
            throws MapperException
会社構成バージョンの基本モデルを1つだけ挿入します。 引数に指定する会社構成バージョンの基本モデルは同一の CompanyVersionMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する会社構成バージョンの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
会社構成バージョンの基本モデルを複数挿入します。 引数に指定するものは同一の CompanyVersionMapperの create(String,String) で生成された会社構成バージョンの基本モデルの集合である必要があります。

パラメータ:
models - 挿入する会社構成バージョンの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(CompanyVersionBaseModel model)
            throws MapperException
会社構成バージョンの基本モデルを1つだけ更新します。 引数に指定する会社構成バージョンの基本モデルは同一の CompanyVersionMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する会社構成バージョンの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
会社構成バージョンの基本モデルを複数更新します。 引数に指定するものは同一の CompanyVersionMapperの select 系メソッド から取得されたものかで生成された会社構成バージョンの基本モデルの集合である必要があります。

パラメータ:
models - 更新する会社構成バージョンの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(CompanyVersionBaseModel model)
            throws MapperException
会社構成バージョンの基本モデルを1つだけ削除します。 引数で指定された会社構成バージョンの基本モデルに該当するデータのすべての情報を削除します。引数に指定する会社構成バージョンの基本モデルは同一の CompanyVersionMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する会社構成バージョンの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
会社構成バージョンの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する会社構成バージョンの基本モデルは同一の CompanyVersionMapperの select 系メソッド から取得された会社構成バージョンの基本モデルの集合である必要があります。

パラメータ:
models - 削除する会社構成バージョンの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.company.version (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.company.version
インタフェース
CompanyVersionBaseModel
CompanyVersionMapper


jp.co.intra_mart.foundation.datastore.application.model.company.version (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.version

会社バージョン情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
CompanyVersionBaseModel | 会社構成バージョンの基本モデルです。
CompanyVersionMapper | 会社構成バージョンに関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.version の説明

会社バージョン情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.company.version クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.version の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.version の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.version の使用

jp.co.intra_mart.foundation.datastore.application.model.company.version を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.version 会社バージョン情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.version により使用される jp.co.intra_mart.foundation.datastore.application.model.company.version のクラス
CompanyVersionBaseModel
会社構成バージョンの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の使用

DealBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.deal 取扱情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.deal.deal での DealBaseModel の使用

DealBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.deal.deal のメソッド
DealBaseModel | DealMapper.create(String customerCompanyCode, String customerDepartmentCode, String dealCode) プライマリキーに該当する取扱を生成します。
DealBaseModel | DealMapper.select(String customerCompanyCode, String customerDepartmentCode, String dealCode) プライマリーキーで特定される取扱の基本モデルを取得します。

DealBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.deal.deal のメソッド
void | DealMapper.insert(DealBaseModel model) 取扱の基本モデルを1つだけ挿入します。
void | DealMapper.update(DealBaseModel model) 取扱の基本モデルを1つだけ更新します。
void | DealMapper.delete(DealBaseModel model) 取扱の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealTerminableModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealTerminableModel の使用

DealTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.deal 取扱情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.deal.deal での DealTerminableModel の使用

DealTerminableModel を返す jp.co.intra_mart.foundation.datastore.application.model.deal.deal のメソッド
 DealTerminableModel DealBaseModel.selectDealTerminableModel(Date date)
指定された日付に該当する取扱の期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DealBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.deal.deal
インタフェース DealBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface DealBaseModel
extends BaseModel

取扱の基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | CURRENCY_CODE 通貨コード
static String | CUSTOMER_COMPANY_CODE 取引先会社コード
static String | CUSTOMER_DEPARTMENT_CODE 取引先組織コード
static String | DEAL_CODE 取扱コード
static String | DEAL_NAME 取扱名
static String | DEAL_TYPE 取扱種別
static int | DEAL_TYPE_BUY 取引種別が仕入れを表す定数
static int | DEAL_TYPE_SELL 取引種別が売り上げを表す定数
static String | NOTES 備考
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | UNIT_PRICE 単価
メソッドの概要
String | getCurrencyCode() 通貨コードを取得します。
String | getCustomerCompanyCode() 取引先会社コードを取得します。
String | getCustomerDepartmentCode() 取引先組織コードを取得します。
String | getDealCode() 取扱コードを取得します。
String | getDealName() 取扱名を取得します。
int | getDealType() 取扱種別を取得します。
String | getNotes() 備考を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
double | getUnitPrice() 単価を取得します。
double | getUnitPrice(Date date) 単価を取得します。
DealTerminableModel | selectDealTerminableModel(Date date) 指定された日付に該当する取扱の期間化モデルを取得します。
void | setCurrencyCode(String currencyCode) 通貨コードを設定します。
void | setDealName(String dealName) 取扱名を設定します。
void | setDealType(int dealType) 取扱種別を設定します。
void | setNotes(String notes) 備考を設定します。
void | setUnitPrice(double unitPrice) 単価を設定します。
void | setUnitPrice(double unitPrice, Date date) 単価を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

CUSTOMER_COMPANY_CODE

public static final String CUSTOMER_COMPANY_CODE
取引先会社コード

関連項目:
定数フィールド値

CUSTOMER_DEPARTMENT_CODE

public static final String CUSTOMER_DEPARTMENT_CODE
取引先組織コード

関連項目:
定数フィールド値

DEAL_CODE

public static final String DEAL_CODE
取扱コード

関連項目:
定数フィールド値

DEAL_NAME

public static final String DEAL_NAME
取扱名

関連項目:
定数フィールド値

DEAL_TYPE

public static final String DEAL_TYPE
取扱種別

関連項目:
定数フィールド値

CURRENCY_CODE

public static final String CURRENCY_CODE
通貨コード

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

UNIT_PRICE

public static final String UNIT_PRICE
単価

関連項目:
定数フィールド値

DEAL_TYPE_BUY

public static final int DEAL_TYPE_BUY
取引種別が仕入れを表す定数

関連項目:
定数フィールド値

DEAL_TYPE_SELL

public static final int DEAL_TYPE_SELL
取引種別が売り上げを表す定数

関連項目:
定数フィールド値
メソッドの詳細

getCustomerCompanyCode

public String getCustomerCompanyCode()
                              throws AccessorException
取引先会社コードを取得します。

戻り値:
取引先会社コード
例外:
AccessorException - データの取得に失敗した場合

getCustomerDepartmentCode

public String getCustomerDepartmentCode()
                                 throws AccessorException
取引先組織コードを取得します。

戻り値:
取引先組織コード
例外:
AccessorException - データの取得に失敗した場合

getDealCode

public String getDealCode()
                   throws AccessorException
取扱コードを取得します。

戻り値:
取扱コード
例外:
AccessorException - データの取得に失敗した場合

getDealName

public String getDealName()
                   throws AccessorException
取扱名を取得します。

戻り値:
取扱名
例外:
AccessorException - データの取得に失敗した場合

setDealName

public void setDealName(String dealName)
                 throws AccessorException
取扱名を設定します。

パラメータ:
dealName - 取扱名
例外:
AccessorException - データの設定に失敗した場合

getDealType

public int getDealType()
                throws AccessorException
取扱種別を取得します。

戻り値:
取扱種別
例外:
AccessorException - データの取得に失敗した場合

setDealType

public void setDealType(int dealType)
                 throws AccessorException
取扱種別を設定します。

パラメータ:
dealType - 取扱種別
例外:
AccessorException - データの設定に失敗した場合

getCurrencyCode

public String getCurrencyCode()
                       throws AccessorException
通貨コードを取得します。

戻り値:
通貨コード
例外:
AccessorException - データの取得に失敗した場合

setCurrencyCode

public void setCurrencyCode(String currencyCode)
                     throws AccessorException
通貨コードを設定します。

パラメータ:
currencyCode - 通貨コード
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getUnitPrice

public double getUnitPrice()
                    throws AccessorException
単価を取得します。

戻り値:
単価
例外:
AccessorException - データの取得に失敗した場合

getUnitPrice

public double getUnitPrice(Date date)
                    throws AccessorException
単価を取得します。

パラメータ:
date - 日時
戻り値:
単価
例外:
AccessorException - データの取得に失敗した場合

setUnitPrice

public void setUnitPrice(double unitPrice)
                  throws AccessorException
単価を設定します。

パラメータ:
unitPrice - 単価
例外:
AccessorException - データの設定に失敗した場合

setUnitPrice

public void setUnitPrice(double unitPrice,
                         Date date)
                  throws AccessorException
単価を設定します。

パラメータ:
unitPrice - 単価
date - 日時
例外:
AccessorException - データの設定に失敗した場合

selectDealTerminableModel

public DealTerminableModel selectDealTerminableModel(Date date)
                                              throws IllegalTermException
指定された日付に該当する取扱の期間化モデルを取得します。

パラメータ:
date - 指定日付
戻り値:
取扱の期間化モデル
例外:
IllegalTermException - 指定された日付に該当する期間が定義されていない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DealMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.deal.deal
インタフェース DealMapper

すべてのスーパーインタフェース:
Mapper
public interface DealMapper
extends Mapper

取扱に関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
DealBaseModel | create(String customerCompanyCode, String customerDepartmentCode, String dealCode) プライマリキーに該当する取扱を生成します。
void | delete(Collection models) 取扱の基本モデルを複数削除します。
void | delete(DealBaseModel model) 取扱の基本モデルを1つだけ削除します。
void | insert(Collection models) 取扱の基本モデルを複数挿入します。
void | insert(DealBaseModel model) 取扱の基本モデルを1つだけ挿入します。
DealBaseModel | select(String customerCompanyCode, String customerDepartmentCode, String dealCode) プライマリーキーで特定される取扱の基本モデルを取得します。
void | update(Collection models) 取扱の基本モデルを複数更新します。
void | update(DealBaseModel model) 取扱の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public DealBaseModel create(String customerCompanyCode,
                            String customerDepartmentCode,
                            String dealCode)
                     throws MapperException
プライマリキーに該当する取扱を生成します。

パラメータ:
customerCompanyCode - 取引先会社コード
customerDepartmentCode - 取引先組織コード
dealCode - 取扱コード
戻り値:
プライマリキーに該当する取扱の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public DealBaseModel select(String customerCompanyCode,
                            String customerDepartmentCode,
                            String dealCode)
                     throws MapperException
プライマリーキーで特定される取扱の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
customerCompanyCode - 取引先会社コード
customerDepartmentCode - 取引先組織コード
dealCode - 取扱コード
戻り値:
取扱の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(DealBaseModel model)
            throws MapperException
取扱の基本モデルを1つだけ挿入します。 引数に指定する取扱の基本モデルは同一の DealMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する取扱の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
取扱の基本モデルを複数挿入します。 引数に指定するものは同一の DealMapperの create(String,String,String) で生成された取扱の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する取扱の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(DealBaseModel model)
            throws MapperException
取扱の基本モデルを1つだけ更新します。 引数に指定する取扱の基本モデルは同一の DealMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する取扱の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
取扱の基本モデルを複数更新します。 引数に指定するものは同一の DealMapperの select 系メソッド から取得されたものかで生成された取扱の基本モデルの集合である必要があります。

パラメータ:
models - 更新する取扱の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(DealBaseModel model)
            throws MapperException
取扱の基本モデルを1つだけ削除します。 引数で指定された取扱の基本モデルに該当するデータのすべての情報を削除します。引数に指定する取扱の基本モデルは同一の DealMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する取扱の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
取扱の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する取扱の基本モデルは同一の DealMapperの select 系メソッド から取得された取扱の基本モデルの集合である必要があります。

パラメータ:
models - 削除する取扱の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DealTerminableModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.deal.deal
インタフェース DealTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface DealTerminableModel
extends TerminableModel

取扱の期間化モデルです。

導入されたバージョン:
5.1

メソッドの概要
double | getUnitPrice() 単価を取得します。
void | setUnitPrice(double unitPrice) 単価を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

メソッドの詳細

getUnitPrice

public double getUnitPrice()
                    throws AccessorException
単価を取得します。

戻り値:
単価
例外:
AccessorException - データの取得に失敗した場合

setUnitPrice

public void setUnitPrice(double unitPrice)
                  throws AccessorException
単価を設定します。

パラメータ:
unitPrice - 単価
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.deal.deal (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.deal.deal
インタフェース
DealBaseModel
DealMapper
DealTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.deal.deal (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.deal

取扱情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
DealBaseModel | 取扱の基本モデルです。
DealMapper | 取扱に関連するマッパです。
DealTerminableModel | 取扱の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.deal の説明

取扱情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.deal.deal クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.deal の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealTerminableModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.deal の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.deal の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.deal を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.deal 取扱情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.deal.deal により使用される jp.co.intra_mart.foundation.datastore.application.model.deal.deal のクラス
DealBaseModel
取扱の基本モデルです。
DealTerminableModel
取扱の期間化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel の使用

DealerDepartmentBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.department 取扱組織権限情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.deal.department での DealerDepartmentBaseModel の使用

DealerDepartmentBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.deal.department のメソッド
DealerDepartmentBaseModel | DealerDepartmentMapper.create(String customerCompanyCode, String customerDepartmentCode, String dealCode, String companyCode, String departmentCode) プライマリキーに該当する組織毎取扱パーミッションを生成します。
DealerDepartmentBaseModel | DealerDepartmentMapper.select(String customerCompanyCode, String customerDepartmentCode, String dealCode, String companyCode, String departmentCode) プライマリーキーで特定される組織毎取扱パーミッションの基本モデルを取得します。

DealerDepartmentBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.deal.department のメソッド
void | DealerDepartmentMapper.insert(DealerDepartmentBaseModel model) 組織毎取扱パーミッションの基本モデルを1つだけ挿入します。
void | DealerDepartmentMapper.update(DealerDepartmentBaseModel model) 組織毎取扱パーミッションの基本モデルを1つだけ更新します。
void | DealerDepartmentMapper.delete(DealerDepartmentBaseModel model) 組織毎取扱パーミッションの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DealerDepartmentBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.deal.department
インタフェース DealerDepartmentBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface DealerDepartmentBaseModel
extends BaseModel

組織毎取扱パーミッションの基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | COMPANY_CODE 会社コード
static String | CUSTOMER_COMPANY_CODE 取引先会社コード
static String | CUSTOMER_DEPARTMENT_CODE 取引先組織コード
static String | DEAL_CODE 取扱コード
static String | DEPARTMENT_CODE 組織コード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getCustomerCompanyCode() 取引先会社コードを取得します。
String | getCustomerDepartmentCode() 取引先組織コードを取得します。
String | getDealCode() 取扱コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

CUSTOMER_COMPANY_CODE

public static final String CUSTOMER_COMPANY_CODE
取引先会社コード

関連項目:
定数フィールド値

CUSTOMER_DEPARTMENT_CODE

public static final String CUSTOMER_DEPARTMENT_CODE
取引先組織コード

関連項目:
定数フィールド値

DEAL_CODE

public static final String DEAL_CODE
取扱コード

関連項目:
定数フィールド値

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

DEPARTMENT_CODE

public static final String DEPARTMENT_CODE
組織コード

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getCustomerCompanyCode

public String getCustomerCompanyCode()
                              throws AccessorException
取引先会社コードを取得します。

戻り値:
取引先会社コード
例外:
AccessorException - データの取得に失敗した場合

getCustomerDepartmentCode

public String getCustomerDepartmentCode()
                                 throws AccessorException
取引先組織コードを取得します。

戻り値:
取引先組織コード
例外:
AccessorException - データの取得に失敗した場合

getDealCode

public String getDealCode()
                   throws AccessorException
取扱コードを取得します。

戻り値:
取扱コード
例外:
AccessorException - データの取得に失敗した場合

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getDepartmentCode

public String getDepartmentCode()
                         throws AccessorException
組織コードを取得します。

戻り値:
組織コード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DealerDepartmentMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.deal.department
インタフェース DealerDepartmentMapper

すべてのスーパーインタフェース:
Mapper
public interface DealerDepartmentMapper
extends Mapper

組織毎取扱パーミッションに関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
DealerDepartmentBaseModel | create(String customerCompanyCode, String customerDepartmentCode, String dealCode, String companyCode, String departmentCode) プライマリキーに該当する組織毎取扱パーミッションを生成します。
void | delete(Collection models) 組織毎取扱パーミッションの基本モデルを複数削除します。
void | delete(DealerDepartmentBaseModel model) 組織毎取扱パーミッションの基本モデルを1つだけ削除します。
void | insert(Collection models) 組織毎取扱パーミッションの基本モデルを複数挿入します。
void | insert(DealerDepartmentBaseModel model) 組織毎取扱パーミッションの基本モデルを1つだけ挿入します。
DealerDepartmentBaseModel | select(String customerCompanyCode, String customerDepartmentCode, String dealCode, String companyCode, String departmentCode) プライマリーキーで特定される組織毎取扱パーミッションの基本モデルを取得します。
void | update(Collection models) 組織毎取扱パーミッションの基本モデルを複数更新します。
void | update(DealerDepartmentBaseModel model) 組織毎取扱パーミッションの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public DealerDepartmentBaseModel create(String customerCompanyCode,
                                        String customerDepartmentCode,
                                        String dealCode,
                                        String companyCode,
                                        String departmentCode)
                                 throws MapperException
プライマリキーに該当する組織毎取扱パーミッションを生成します。

パラメータ:
customerCompanyCode - 取引先会社コード
customerDepartmentCode - 取引先組織コード
dealCode - 取扱コード
companyCode - 会社コード
departmentCode - 組織コード
戻り値:
プライマリキーに該当する組織毎取扱パーミッションの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public DealerDepartmentBaseModel select(String customerCompanyCode,
                                        String customerDepartmentCode,
                                        String dealCode,
                                        String companyCode,
                                        String departmentCode)
                                 throws MapperException
プライマリーキーで特定される組織毎取扱パーミッションの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
customerCompanyCode - 取引先会社コード
customerDepartmentCode - 取引先組織コード
dealCode - 取扱コード
companyCode - 会社コード
departmentCode - 組織コード
戻り値:
組織毎取扱パーミッションの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(DealerDepartmentBaseModel model)
            throws MapperException
組織毎取扱パーミッションの基本モデルを1つだけ挿入します。 引数に指定する組織毎取扱パーミッションの基本モデルは同一の DealerDepartmentMapperの create(String,String,String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する組織毎取扱パーミッションの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
組織毎取扱パーミッションの基本モデルを複数挿入します。 引数に指定するものは同一の DealerDepartmentMapperの create(String,String,String,String,String) で生成された組織毎取扱パーミッションの基本モデルの集合である必要があります。

パラメータ:
models - 挿入する組織毎取扱パーミッションの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(DealerDepartmentBaseModel model)
            throws MapperException
組織毎取扱パーミッションの基本モデルを1つだけ更新します。 引数に指定する組織毎取扱パーミッションの基本モデルは同一の DealerDepartmentMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する組織毎取扱パーミッションの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
組織毎取扱パーミッションの基本モデルを複数更新します。 引数に指定するものは同一の DealerDepartmentMapperの select 系メソッド から取得されたものかで生成された組織毎取扱パーミッションの基本モデルの集合である必要があります。

パラメータ:
models - 更新する組織毎取扱パーミッションの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(DealerDepartmentBaseModel model)
            throws MapperException
組織毎取扱パーミッションの基本モデルを1つだけ削除します。 引数で指定された組織毎取扱パーミッションの基本モデルに該当するデータのすべての情報を削除します。引数に指定する組織毎取扱パーミッションの基本モデルは同一の DealerDepartmentMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する組織毎取扱パーミッションの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
組織毎取扱パーミッションの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する組織毎取扱パーミッションの基本モデルは同一の DealerDepartmentMapperの select 系メソッド から取得された組織毎取扱パーミッションの基本モデルの集合である必要があります。

パラメータ:
models - 削除する組織毎取扱パーミッションの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.deal.department (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.deal.department
インタフェース
DealerDepartmentBaseModel
DealerDepartmentMapper


jp.co.intra_mart.foundation.datastore.application.model.deal.department (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.department

取扱組織権限情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
DealerDepartmentBaseModel | 組織毎取扱パーミッションの基本モデルです。
DealerDepartmentMapper | 組織毎取扱パーミッションに関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.department の説明

取扱組織権限情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.deal.department クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.department の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.department の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.department の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.department を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.department 取扱組織権限情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.deal.department により使用される jp.co.intra_mart.foundation.datastore.application.model.deal.department のクラス
DealerDepartmentBaseModel
組織毎取扱パーミッションの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel の使用

DealDetailBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.detail 取扱詳細情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.deal.detail での DealDetailBaseModel の使用

DealDetailBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.deal.detail のメソッド
DealDetailBaseModel | DealDetailMapper.create(String customerCompanyCode, String customerDepartmentCode, String dealCode, String itemCode) プライマリキーに該当する取扱詳細を生成します。
DealDetailBaseModel | DealDetailMapper.select(String customerCompanyCode, String customerDepartmentCode, String dealCode, String itemCode) プライマリーキーで特定される取扱詳細の基本モデルを取得します。

DealDetailBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.deal.detail のメソッド
void | DealDetailMapper.insert(DealDetailBaseModel model) 取扱詳細の基本モデルを1つだけ挿入します。
void | DealDetailMapper.update(DealDetailBaseModel model) 取扱詳細の基本モデルを1つだけ更新します。
void | DealDetailMapper.delete(DealDetailBaseModel model) 取扱詳細の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailTerminableModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailTerminableModel の使用

DealDetailTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.detail 取扱詳細情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.deal.detail での DealDetailTerminableModel の使用

DealDetailTerminableModel を返す jp.co.intra_mart.foundation.datastore.application.model.deal.detail のメソッド
 DealDetailTerminableModel DealDetailBaseModel.selectDealDetailTerminableModel(Date date)
指定された日付に該当する取扱詳細の期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DealDetailBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.deal.detail
インタフェース DealDetailBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface DealDetailBaseModel
extends BaseModel

取扱詳細の基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | AMOUNT 数量
static String | CUSTOMER_COMPANY_CODE 取引先会社コード
static String | CUSTOMER_DEPARTMENT_CODE 取引先組織コード
static String | DEAL_CODE 取扱コード
static String | ITEM_CODE 商品コード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | UNIT_CODE 単位コード
static String | UNIT_PRICE 単価
メソッドの概要
int | getAmount() 数量を取得します。
int | getAmount(Date date) 数量を取得します。
String | getCustomerCompanyCode() 取引先会社コードを取得します。
String | getCustomerDepartmentCode() 取引先組織コードを取得します。
String | getDealCode() 取扱コードを取得します。
String | getItemCode() 商品コードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getUnitCode() 単位コードを取得します。
String | getUnitCode(Date date) 単位コードを取得します。
double | getUnitPrice() 単価を取得します。
double | getUnitPrice(Date date) 単価を取得します。
DealDetailTerminableModel | selectDealDetailTerminableModel(Date date) 指定された日付に該当する取扱詳細の期間化モデルを取得します。
void | setAmount(int amount) 数量を設定します。
void | setAmount(int amount, Date date) 数量を設定します。
void | setUnitCode(String unitCode) 単位コードを設定します。
void | setUnitCode(String unitCode, Date date) 単位コードを設定します。
void | setUnitPrice(double unitPrice) 単価を設定します。
void | setUnitPrice(double unitPrice, Date date) 単価を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

CUSTOMER_COMPANY_CODE

public static final String CUSTOMER_COMPANY_CODE
取引先会社コード

関連項目:
定数フィールド値

CUSTOMER_DEPARTMENT_CODE

public static final String CUSTOMER_DEPARTMENT_CODE
取引先組織コード

関連項目:
定数フィールド値

DEAL_CODE

public static final String DEAL_CODE
取扱コード

関連項目:
定数フィールド値

ITEM_CODE

public static final String ITEM_CODE
商品コード

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

UNIT_CODE

public static final String UNIT_CODE
単位コード

関連項目:
定数フィールド値

AMOUNT

public static final String AMOUNT
数量

関連項目:
定数フィールド値

UNIT_PRICE

public static final String UNIT_PRICE
単価

関連項目:
定数フィールド値
メソッドの詳細

getCustomerCompanyCode

public String getCustomerCompanyCode()
                              throws AccessorException
取引先会社コードを取得します。

戻り値:
取引先会社コード
例外:
AccessorException - データの取得に失敗した場合

getCustomerDepartmentCode

public String getCustomerDepartmentCode()
                                 throws AccessorException
取引先組織コードを取得します。

戻り値:
取引先組織コード
例外:
AccessorException - データの取得に失敗した場合

getDealCode

public String getDealCode()
                   throws AccessorException
取扱コードを取得します。

戻り値:
取扱コード
例外:
AccessorException - データの取得に失敗した場合

getItemCode

public String getItemCode()
                   throws AccessorException
商品コードを取得します。

戻り値:
商品コード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getUnitCode

public String getUnitCode()
                   throws AccessorException
単位コードを取得します。

戻り値:
単位コード
例外:
AccessorException - データの取得に失敗した場合

getUnitCode

public String getUnitCode(Date date)
                   throws AccessorException
単位コードを取得します。

パラメータ:
date - 日時
戻り値:
単位コード
例外:
AccessorException - データの取得に失敗した場合

setUnitCode

public void setUnitCode(String unitCode)
                 throws AccessorException
単位コードを設定します。

パラメータ:
unitCode - 単位コード
例外:
AccessorException - データの設定に失敗した場合

setUnitCode

public void setUnitCode(String unitCode,
                        Date date)
                 throws AccessorException
単位コードを設定します。

パラメータ:
unitCode - 単位コード
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getAmount

public int getAmount()
              throws AccessorException
数量を取得します。

戻り値:
数量
例外:
AccessorException - データの取得に失敗した場合

getAmount

public int getAmount(Date date)
              throws AccessorException
数量を取得します。

パラメータ:
date - 日時
戻り値:
数量
例外:
AccessorException - データの取得に失敗した場合

setAmount

public void setAmount(int amount)
               throws AccessorException
数量を設定します。

パラメータ:
amount - 数量
例外:
AccessorException - データの設定に失敗した場合

setAmount

public void setAmount(int amount,
                      Date date)
               throws AccessorException
数量を設定します。

パラメータ:
amount - 数量
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getUnitPrice

public double getUnitPrice()
                    throws AccessorException
単価を取得します。

戻り値:
単価
例外:
AccessorException - データの取得に失敗した場合

getUnitPrice

public double getUnitPrice(Date date)
                    throws AccessorException
単価を取得します。

パラメータ:
date - 日時
戻り値:
単価
例外:
AccessorException - データの取得に失敗した場合

setUnitPrice

public void setUnitPrice(double unitPrice)
                  throws AccessorException
単価を設定します。

パラメータ:
unitPrice - 単価
例外:
AccessorException - データの設定に失敗した場合

setUnitPrice

public void setUnitPrice(double unitPrice,
                         Date date)
                  throws AccessorException
単価を設定します。

パラメータ:
unitPrice - 単価
date - 日時
例外:
AccessorException - データの設定に失敗した場合

selectDealDetailTerminableModel

public DealDetailTerminableModel selectDealDetailTerminableModel(Date date)
                                                          throws IllegalTermException
指定された日付に該当する取扱詳細の期間化モデルを取得します。

パラメータ:
date - 指定日付
戻り値:
取扱詳細の期間化モデル
例外:
IllegalTermException - 指定された日付に該当する期間が定義されていない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DealDetailMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.deal.detail
インタフェース DealDetailMapper

すべてのスーパーインタフェース:
Mapper
public interface DealDetailMapper
extends Mapper

取扱詳細に関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
DealDetailBaseModel | create(String customerCompanyCode, String customerDepartmentCode, String dealCode, String itemCode) プライマリキーに該当する取扱詳細を生成します。
void | delete(Collection models) 取扱詳細の基本モデルを複数削除します。
void | delete(DealDetailBaseModel model) 取扱詳細の基本モデルを1つだけ削除します。
void | insert(Collection models) 取扱詳細の基本モデルを複数挿入します。
void | insert(DealDetailBaseModel model) 取扱詳細の基本モデルを1つだけ挿入します。
DealDetailBaseModel | select(String customerCompanyCode, String customerDepartmentCode, String dealCode, String itemCode) プライマリーキーで特定される取扱詳細の基本モデルを取得します。
void | update(Collection models) 取扱詳細の基本モデルを複数更新します。
void | update(DealDetailBaseModel model) 取扱詳細の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public DealDetailBaseModel create(String customerCompanyCode,
                                  String customerDepartmentCode,
                                  String dealCode,
                                  String itemCode)
                           throws MapperException
プライマリキーに該当する取扱詳細を生成します。

パラメータ:
customerCompanyCode - 取引先会社コード
customerDepartmentCode - 取引先組織コード
dealCode - 取扱コード
itemCode - 商品コード
戻り値:
プライマリキーに該当する取扱詳細の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public DealDetailBaseModel select(String customerCompanyCode,
                                  String customerDepartmentCode,
                                  String dealCode,
                                  String itemCode)
                           throws MapperException
プライマリーキーで特定される取扱詳細の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
customerCompanyCode - 取引先会社コード
customerDepartmentCode - 取引先組織コード
dealCode - 取扱コード
itemCode - 商品コード
戻り値:
取扱詳細の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(DealDetailBaseModel model)
            throws MapperException
取扱詳細の基本モデルを1つだけ挿入します。 引数に指定する取扱詳細の基本モデルは同一の DealDetailMapperの create(String,String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する取扱詳細の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
取扱詳細の基本モデルを複数挿入します。 引数に指定するものは同一の DealDetailMapperの create(String,String,String,String) で生成された取扱詳細の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する取扱詳細の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(DealDetailBaseModel model)
            throws MapperException
取扱詳細の基本モデルを1つだけ更新します。 引数に指定する取扱詳細の基本モデルは同一の DealDetailMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する取扱詳細の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
取扱詳細の基本モデルを複数更新します。 引数に指定するものは同一の DealDetailMapperの select 系メソッド から取得されたものかで生成された取扱詳細の基本モデルの集合である必要があります。

パラメータ:
models - 更新する取扱詳細の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(DealDetailBaseModel model)
            throws MapperException
取扱詳細の基本モデルを1つだけ削除します。 引数で指定された取扱詳細の基本モデルに該当するデータのすべての情報を削除します。引数に指定する取扱詳細の基本モデルは同一の DealDetailMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する取扱詳細の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
取扱詳細の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する取扱詳細の基本モデルは同一の DealDetailMapperの select 系メソッド から取得された取扱詳細の基本モデルの集合である必要があります。

パラメータ:
models - 削除する取扱詳細の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DealDetailTerminableModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.deal.detail
インタフェース DealDetailTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface DealDetailTerminableModel
extends TerminableModel

取扱詳細の期間化モデルです。

導入されたバージョン:
5.1

メソッドの概要
int | getAmount() 数量を取得します。
String | getUnitCode() 単位コードを取得します。
double | getUnitPrice() 単価を取得します。
void | setAmount(int amount) 数量を設定します。
void | setUnitCode(String unitCode) 単位コードを設定します。
void | setUnitPrice(double unitPrice) 単価を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

メソッドの詳細

getUnitCode

public String getUnitCode()
                   throws AccessorException
単位コードを取得します。

戻り値:
単位コード
例外:
AccessorException - データの取得に失敗した場合

setUnitCode

public void setUnitCode(String unitCode)
                 throws AccessorException
単位コードを設定します。

パラメータ:
unitCode - 単位コード
例外:
AccessorException - データの設定に失敗した場合

getAmount

public int getAmount()
              throws AccessorException
数量を取得します。

戻り値:
数量
例外:
AccessorException - データの取得に失敗した場合

setAmount

public void setAmount(int amount)
               throws AccessorException
数量を設定します。

パラメータ:
amount - 数量
例外:
AccessorException - データの設定に失敗した場合

getUnitPrice

public double getUnitPrice()
                    throws AccessorException
単価を取得します。

戻り値:
単価
例外:
AccessorException - データの取得に失敗した場合

setUnitPrice

public void setUnitPrice(double unitPrice)
                  throws AccessorException
単価を設定します。

パラメータ:
unitPrice - 単価
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.deal.detail (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.deal.detail
インタフェース
DealDetailBaseModel
DealDetailMapper
DealDetailTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.deal.detail (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.detail

取扱詳細情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
DealDetailBaseModel | 取扱詳細の基本モデルです。
DealDetailMapper | 取扱詳細に関連するマッパです。
DealDetailTerminableModel | 取扱詳細の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.detail の説明

取扱詳細情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.deal.detail クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.detail の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailTerminableModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.detail の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.detail の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.detail を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.detail 取扱詳細情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.deal.detail により使用される jp.co.intra_mart.foundation.datastore.application.model.deal.detail のクラス
DealDetailBaseModel
取扱詳細の基本モデルです。
DealDetailTerminableModel
取扱詳細の期間化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel の使用

DealerPublicGroupBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group 取扱パブリックグループ権限情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group での DealerPublicGroupBaseModel の使用

DealerPublicGroupBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.deal.public_group のメソッド
DealerPublicGroupBaseModel | DealerPublicGroupMapper.create(String customerCompanyCode, String customerDepartmentCode, String dealCode, String publicGroupSetCode, String publicGroupCode) プライマリキーに該当するパブリックグループ毎取扱パーミッションを生成します。
DealerPublicGroupBaseModel | DealerPublicGroupMapper.select(String customerCompanyCode, String customerDepartmentCode, String dealCode, String publicGroupSetCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループ毎取扱パーミッションの基本モデルを取得します。

DealerPublicGroupBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.deal.public_group のメソッド
void | DealerPublicGroupMapper.insert(DealerPublicGroupBaseModel model) パブリックグループ毎取扱パーミッションの基本モデルを1つだけ挿入します。
void | DealerPublicGroupMapper.update(DealerPublicGroupBaseModel model) パブリックグループ毎取扱パーミッションの基本モデルを1つだけ更新します。
void | DealerPublicGroupMapper.delete(DealerPublicGroupBaseModel model) パブリックグループ毎取扱パーミッションの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DealerPublicGroupBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group
インタフェース DealerPublicGroupBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface DealerPublicGroupBaseModel
extends BaseModel

パブリックグループ毎取扱パーミッションの基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | CUSTOMER_COMPANY_CODE 取引先会社コード
static String | CUSTOMER_DEPARTMENT_CODE 取引先組織コード
static String | DEAL_CODE 取扱コード
static String | PUBLIC_GROUP_CODE グループコード
static String | PUBLIC_GROUP_SET_CODE グループセットコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getCustomerCompanyCode() 取引先会社コードを取得します。
String | getCustomerDepartmentCode() 取引先組織コードを取得します。
String | getDealCode() 取扱コードを取得します。
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

CUSTOMER_COMPANY_CODE

public static final String CUSTOMER_COMPANY_CODE
取引先会社コード

関連項目:
定数フィールド値

CUSTOMER_DEPARTMENT_CODE

public static final String CUSTOMER_DEPARTMENT_CODE
取引先組織コード

関連項目:
定数フィールド値

DEAL_CODE

public static final String DEAL_CODE
取扱コード

関連項目:
定数フィールド値

PUBLIC_GROUP_SET_CODE

public static final String PUBLIC_GROUP_SET_CODE
グループセットコード

関連項目:
定数フィールド値

PUBLIC_GROUP_CODE

public static final String PUBLIC_GROUP_CODE
グループコード

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getCustomerCompanyCode

public String getCustomerCompanyCode()
                              throws AccessorException
取引先会社コードを取得します。

戻り値:
取引先会社コード
例外:
AccessorException - データの取得に失敗した場合

getCustomerDepartmentCode

public String getCustomerDepartmentCode()
                                 throws AccessorException
取引先組織コードを取得します。

戻り値:
取引先組織コード
例外:
AccessorException - データの取得に失敗した場合

getDealCode

public String getDealCode()
                   throws AccessorException
取扱コードを取得します。

戻り値:
取扱コード
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupSetCode

public String getPublicGroupSetCode()
                             throws AccessorException
グループセットコードを取得します。

戻り値:
グループセットコード
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupCode

public String getPublicGroupCode()
                          throws AccessorException
グループコードを取得します。

戻り値:
グループコード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DealerPublicGroupMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group
インタフェース DealerPublicGroupMapper

すべてのスーパーインタフェース:
Mapper
public interface DealerPublicGroupMapper
extends Mapper

パブリックグループ毎取扱パーミッションに関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
DealerPublicGroupBaseModel | create(String customerCompanyCode, String customerDepartmentCode, String dealCode, String publicGroupSetCode, String publicGroupCode) プライマリキーに該当するパブリックグループ毎取扱パーミッションを生成します。
void | delete(Collection models) パブリックグループ毎取扱パーミッションの基本モデルを複数削除します。
void | delete(DealerPublicGroupBaseModel model) パブリックグループ毎取扱パーミッションの基本モデルを1つだけ削除します。
void | insert(Collection models) パブリックグループ毎取扱パーミッションの基本モデルを複数挿入します。
void | insert(DealerPublicGroupBaseModel model) パブリックグループ毎取扱パーミッションの基本モデルを1つだけ挿入します。
DealerPublicGroupBaseModel | select(String customerCompanyCode, String customerDepartmentCode, String dealCode, String publicGroupSetCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループ毎取扱パーミッションの基本モデルを取得します。
void | update(Collection models) パブリックグループ毎取扱パーミッションの基本モデルを複数更新します。
void | update(DealerPublicGroupBaseModel model) パブリックグループ毎取扱パーミッションの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public DealerPublicGroupBaseModel create(String customerCompanyCode,
                                         String customerDepartmentCode,
                                         String dealCode,
                                         String publicGroupSetCode,
                                         String publicGroupCode)
                                  throws MapperException
プライマリキーに該当するパブリックグループ毎取扱パーミッションを生成します。

パラメータ:
customerCompanyCode - 取引先会社コード
customerDepartmentCode - 取引先組織コード
dealCode - 取扱コード
publicGroupSetCode - グループセットコード
publicGroupCode - グループコード
戻り値:
プライマリキーに該当するパブリックグループ毎取扱パーミッションの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public DealerPublicGroupBaseModel select(String customerCompanyCode,
                                         String customerDepartmentCode,
                                         String dealCode,
                                         String publicGroupSetCode,
                                         String publicGroupCode)
                                  throws MapperException
プライマリーキーで特定されるパブリックグループ毎取扱パーミッションの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
customerCompanyCode - 取引先会社コード
customerDepartmentCode - 取引先組織コード
dealCode - 取扱コード
publicGroupSetCode - グループセットコード
publicGroupCode - グループコード
戻り値:
パブリックグループ毎取扱パーミッションの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(DealerPublicGroupBaseModel model)
            throws MapperException
パブリックグループ毎取扱パーミッションの基本モデルを1つだけ挿入します。 引数に指定するパブリックグループ毎取扱パーミッションの基本モデルは同一の DealerPublicGroupMapperの create(String,String,String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するパブリックグループ毎取扱パーミッションの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
パブリックグループ毎取扱パーミッションの基本モデルを複数挿入します。 引数に指定するものは同一の DealerPublicGroupMapperの create(String,String,String,String,String) で生成されたパブリックグループ毎取扱パーミッションの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するパブリックグループ毎取扱パーミッションの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(DealerPublicGroupBaseModel model)
            throws MapperException
パブリックグループ毎取扱パーミッションの基本モデルを1つだけ更新します。 引数に指定するパブリックグループ毎取扱パーミッションの基本モデルは同一の DealerPublicGroupMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するパブリックグループ毎取扱パーミッションの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
パブリックグループ毎取扱パーミッションの基本モデルを複数更新します。 引数に指定するものは同一の DealerPublicGroupMapperの select 系メソッド から取得されたものかで生成されたパブリックグループ毎取扱パーミッションの基本モデルの集合である必要があります。

パラメータ:
models - 更新するパブリックグループ毎取扱パーミッションの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(DealerPublicGroupBaseModel model)
            throws MapperException
パブリックグループ毎取扱パーミッションの基本モデルを1つだけ削除します。 引数で指定されたパブリックグループ毎取扱パーミッションの基本モデルに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ毎取扱パーミッションの基本モデルは同一の DealerPublicGroupMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するパブリックグループ毎取扱パーミッションの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
パブリックグループ毎取扱パーミッションの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ毎取扱パーミッションの基本モデルは同一の DealerPublicGroupMapperの select 系メソッド から取得されたパブリックグループ毎取扱パーミッションの基本モデルの集合である必要があります。

パラメータ:
models - 削除するパブリックグループ毎取扱パーミッションの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.deal.public_group (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.deal.public_group
インタフェース
DealerPublicGroupBaseModel
DealerPublicGroupMapper


jp.co.intra_mart.foundation.datastore.application.model.deal.public_group (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.public_group

取扱パブリックグループ権限情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
DealerPublicGroupBaseModel | パブリックグループ毎取扱パーミッションの基本モデルです。
DealerPublicGroupMapper | パブリックグループ毎取扱パーミッションに関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.public_group の説明

取扱パブリックグループ権限情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.deal.public_group クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.public_group の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.public_group の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group 取扱パブリックグループ権限情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group により使用される jp.co.intra_mart.foundation.datastore.application.model.deal.public_group のクラス
DealerPublicGroupBaseModel
パブリックグループ毎取扱パーミッションの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel の使用

DealerRoleBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.role 取扱ロール権限情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.deal.role での DealerRoleBaseModel の使用

DealerRoleBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.deal.role のメソッド
DealerRoleBaseModel | DealerRoleMapper.create(String customerCompanyCode, String customerDepartmentCode, String dealCode, String roleId) プライマリキーに該当するロール毎取扱パーミッションを生成します。
DealerRoleBaseModel | DealerRoleMapper.select(String customerCompanyCode, String customerDepartmentCode, String dealCode, String roleId) プライマリーキーで特定されるロール毎取扱パーミッションの基本モデルを取得します。

DealerRoleBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.deal.role のメソッド
void | DealerRoleMapper.insert(DealerRoleBaseModel model) ロール毎取扱パーミッションの基本モデルを1つだけ挿入します。
void | DealerRoleMapper.update(DealerRoleBaseModel model) ロール毎取扱パーミッションの基本モデルを1つだけ更新します。
void | DealerRoleMapper.delete(DealerRoleBaseModel model) ロール毎取扱パーミッションの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DealerRoleBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.deal.role
インタフェース DealerRoleBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface DealerRoleBaseModel
extends BaseModel

ロール毎取扱パーミッションの基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | CUSTOMER_COMPANY_CODE 取引先会社コード
static String | CUSTOMER_DEPARTMENT_CODE 取引先組織コード
static String | DEAL_CODE 取扱コード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | ROLE_ID ロールID
メソッドの概要
String | getCustomerCompanyCode() 取引先会社コードを取得します。
String | getCustomerDepartmentCode() 取引先組織コードを取得します。
String | getDealCode() 取扱コードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getRoleId() ロールIDを取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

CUSTOMER_COMPANY_CODE

public static final String CUSTOMER_COMPANY_CODE
取引先会社コード

関連項目:
定数フィールド値

CUSTOMER_DEPARTMENT_CODE

public static final String CUSTOMER_DEPARTMENT_CODE
取引先組織コード

関連項目:
定数フィールド値

DEAL_CODE

public static final String DEAL_CODE
取扱コード

関連項目:
定数フィールド値

ROLE_ID

public static final String ROLE_ID
ロールID

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getCustomerCompanyCode

public String getCustomerCompanyCode()
                              throws AccessorException
取引先会社コードを取得します。

戻り値:
取引先会社コード
例外:
AccessorException - データの取得に失敗した場合

getCustomerDepartmentCode

public String getCustomerDepartmentCode()
                                 throws AccessorException
取引先組織コードを取得します。

戻り値:
取引先組織コード
例外:
AccessorException - データの取得に失敗した場合

getDealCode

public String getDealCode()
                   throws AccessorException
取扱コードを取得します。

戻り値:
取扱コード
例外:
AccessorException - データの取得に失敗した場合

getRoleId

public String getRoleId()
                 throws AccessorException
ロールIDを取得します。

戻り値:
ロールID
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DealerRoleMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.deal.role
インタフェース DealerRoleMapper

すべてのスーパーインタフェース:
Mapper
public interface DealerRoleMapper
extends Mapper

ロール毎取扱パーミッションに関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
DealerRoleBaseModel | create(String customerCompanyCode, String customerDepartmentCode, String dealCode, String roleId) プライマリキーに該当するロール毎取扱パーミッションを生成します。
void | delete(Collection models) ロール毎取扱パーミッションの基本モデルを複数削除します。
void | delete(DealerRoleBaseModel model) ロール毎取扱パーミッションの基本モデルを1つだけ削除します。
void | insert(Collection models) ロール毎取扱パーミッションの基本モデルを複数挿入します。
void | insert(DealerRoleBaseModel model) ロール毎取扱パーミッションの基本モデルを1つだけ挿入します。
DealerRoleBaseModel | select(String customerCompanyCode, String customerDepartmentCode, String dealCode, String roleId) プライマリーキーで特定されるロール毎取扱パーミッションの基本モデルを取得します。
void | update(Collection models) ロール毎取扱パーミッションの基本モデルを複数更新します。
void | update(DealerRoleBaseModel model) ロール毎取扱パーミッションの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public DealerRoleBaseModel create(String customerCompanyCode,
                                  String customerDepartmentCode,
                                  String dealCode,
                                  String roleId)
                           throws MapperException
プライマリキーに該当するロール毎取扱パーミッションを生成します。

パラメータ:
customerCompanyCode - 取引先会社コード
customerDepartmentCode - 取引先組織コード
dealCode - 取扱コード
roleId - ロールID
戻り値:
プライマリキーに該当するロール毎取扱パーミッションの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public DealerRoleBaseModel select(String customerCompanyCode,
                                  String customerDepartmentCode,
                                  String dealCode,
                                  String roleId)
                           throws MapperException
プライマリーキーで特定されるロール毎取扱パーミッションの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
customerCompanyCode - 取引先会社コード
customerDepartmentCode - 取引先組織コード
dealCode - 取扱コード
roleId - ロールID
戻り値:
ロール毎取扱パーミッションの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(DealerRoleBaseModel model)
            throws MapperException
ロール毎取扱パーミッションの基本モデルを1つだけ挿入します。 引数に指定するロール毎取扱パーミッションの基本モデルは同一の DealerRoleMapperの create(String,String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するロール毎取扱パーミッションの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
ロール毎取扱パーミッションの基本モデルを複数挿入します。 引数に指定するものは同一の DealerRoleMapperの create(String,String,String,String) で生成されたロール毎取扱パーミッションの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するロール毎取扱パーミッションの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(DealerRoleBaseModel model)
            throws MapperException
ロール毎取扱パーミッションの基本モデルを1つだけ更新します。 引数に指定するロール毎取扱パーミッションの基本モデルは同一の DealerRoleMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するロール毎取扱パーミッションの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
ロール毎取扱パーミッションの基本モデルを複数更新します。 引数に指定するものは同一の DealerRoleMapperの select 系メソッド から取得されたものかで生成されたロール毎取扱パーミッションの基本モデルの集合である必要があります。

パラメータ:
models - 更新するロール毎取扱パーミッションの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(DealerRoleBaseModel model)
            throws MapperException
ロール毎取扱パーミッションの基本モデルを1つだけ削除します。 引数で指定されたロール毎取扱パーミッションの基本モデルに該当するデータのすべての情報を削除します。引数に指定するロール毎取扱パーミッションの基本モデルは同一の DealerRoleMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するロール毎取扱パーミッションの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
ロール毎取扱パーミッションの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するロール毎取扱パーミッションの基本モデルは同一の DealerRoleMapperの select 系メソッド から取得されたロール毎取扱パーミッションの基本モデルの集合である必要があります。

パラメータ:
models - 削除するロール毎取扱パーミッションの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.deal.role (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.deal.role
インタフェース
DealerRoleBaseModel
DealerRoleMapper


jp.co.intra_mart.foundation.datastore.application.model.deal.role (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.role

取扱ロール権限情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
DealerRoleBaseModel | ロール毎取扱パーミッションの基本モデルです。
DealerRoleMapper | ロール毎取扱パーミッションに関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.role の説明

取扱ロール権限情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.deal.role クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.role の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.role の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.role の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.role を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.role 取扱ロール権限情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.deal.role により使用される jp.co.intra_mart.foundation.datastore.application.model.deal.role のクラス
DealerRoleBaseModel
ロール毎取扱パーミッションの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel の使用

ItemAttributeBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item.attribute 商品属性情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item.attribute での ItemAttributeBaseModel の使用

ItemAttributeBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.item.attribute のメソッド
ItemAttributeBaseModel | ItemAttributeMapper.create(String itemCode, String templateCode, String templateDetailCode) プライマリキーに該当する商品属性を生成します。
ItemAttributeBaseModel | ItemAttributeMapper.select(String itemCode, String templateCode, String templateDetailCode) プライマリーキーで特定される商品属性の基本モデルを取得します。

ItemAttributeBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.item.attribute のメソッド
void | ItemAttributeMapper.insert(ItemAttributeBaseModel model) 商品属性の基本モデルを1つだけ挿入します。
void | ItemAttributeMapper.update(ItemAttributeBaseModel model) 商品属性の基本モデルを1つだけ更新します。
void | ItemAttributeMapper.delete(ItemAttributeBaseModel model) 商品属性の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeInternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeInternationalModel の使用

ItemAttributeInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item.attribute 商品属性情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item.attribute での ItemAttributeInternationalModel の使用

ItemAttributeInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.item.attribute のメソッド
 ItemAttributeInternationalModel ItemAttributeBaseModel.selectItemAttributeInternationalModel(Locale locale)
指定された言語に該当する商品属性の国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemAttributeBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item.attribute
インタフェース ItemAttributeBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface ItemAttributeBaseModel
extends BaseModel

商品属性の基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | ITEM_CODE 商品コード
static String | NUMBER_VALUE 属性数値
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | STRING_VALUE 属性文字列
static String | TEMPLATE_CODE テンプレートコード
static String | TEMPLATE_DETAIL_CODE テンプレート明細コード
メソッドの概要
String | getItemCode() 商品コードを取得します。
double | getNumberValue() 属性数値を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getStringValue() 属性文字列を取得します。
String | getStringValue(Locale locale) 属性文字列を取得します。
String | getTemplateCode() テンプレートコードを取得します。
String | getTemplateDetailCode() テンプレート明細コードを取得します。
ItemAttributeInternationalModel | selectItemAttributeInternationalModel(Locale locale) 指定された言語に該当する商品属性の国際化モデルを取得します。
void | setNumberValue(double numberValue) 属性数値を設定します。
void | setStringValue(String stringValue) 属性文字列を設定します。
void | setStringValue(String stringValue, Locale locale) 属性文字列を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ITEM_CODE

public static final String ITEM_CODE
商品コード

関連項目:
定数フィールド値

TEMPLATE_CODE

public static final String TEMPLATE_CODE
テンプレートコード

関連項目:
定数フィールド値

TEMPLATE_DETAIL_CODE

public static final String TEMPLATE_DETAIL_CODE
テンプレート明細コード

関連項目:
定数フィールド値

NUMBER_VALUE

public static final String NUMBER_VALUE
属性数値

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

STRING_VALUE

public static final String STRING_VALUE
属性文字列

関連項目:
定数フィールド値
メソッドの詳細

getItemCode

public String getItemCode()
                   throws AccessorException
商品コードを取得します。

戻り値:
商品コード
例外:
AccessorException - データの取得に失敗した場合

getTemplateCode

public String getTemplateCode()
                       throws AccessorException
テンプレートコードを取得します。

戻り値:
テンプレートコード
例外:
AccessorException - データの取得に失敗した場合

getTemplateDetailCode

public String getTemplateDetailCode()
                             throws AccessorException
テンプレート明細コードを取得します。

戻り値:
テンプレート明細コード
例外:
AccessorException - データの取得に失敗した場合

getNumberValue

public double getNumberValue()
                      throws AccessorException
属性数値を取得します。

戻り値:
属性数値
例外:
AccessorException - データの取得に失敗した場合

setNumberValue

public void setNumberValue(double numberValue)
                    throws AccessorException
属性数値を設定します。

パラメータ:
numberValue - 属性数値
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getStringValue

public String getStringValue()
                      throws AccessorException
属性文字列を取得します。

戻り値:
属性文字列
例外:
AccessorException - データの取得に失敗した場合

getStringValue

public String getStringValue(Locale locale)
                      throws AccessorException
属性文字列を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
属性文字列
例外:
AccessorException - データの取得に失敗した場合

setStringValue

public void setStringValue(String stringValue)
                    throws AccessorException
属性文字列を設定します。

パラメータ:
stringValue - 属性文字列
例外:
AccessorException - データの設定に失敗した場合

setStringValue

public void setStringValue(String stringValue,
                           Locale locale)
                    throws AccessorException
属性文字列を設定します。

パラメータ:
stringValue - 属性文字列
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectItemAttributeInternationalModel

public ItemAttributeInternationalModel selectItemAttributeInternationalModel(Locale locale)
                                                                      throws IllegalLocaleException
指定された言語に該当する商品属性の国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
商品属性の国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemAttributeInternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item.attribute
インタフェース ItemAttributeInternationalModel

すべてのスーパーインタフェース:
InternationalModel, Serializable
public interface ItemAttributeInternationalModel
extends InternationalModel

商品属性の国際化モデルです。

導入されたバージョン:
5.1

メソッドの概要
String | getStringValue() 属性文字列を取得します。
void | setStringValue(String stringValue) 属性文字列を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModel から継承したメソッド
getExtendedInternationalModelMap, getLocale, init

メソッドの詳細

getStringValue

public String getStringValue()
                      throws AccessorException
属性文字列を取得します。

戻り値:
属性文字列
例外:
AccessorException - データの取得に失敗した場合

setStringValue

public void setStringValue(String stringValue)
                    throws AccessorException
属性文字列を設定します。

パラメータ:
stringValue - 属性文字列
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ItemAttributeMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item.attribute
インタフェース ItemAttributeMapper

すべてのスーパーインタフェース:
Mapper
public interface ItemAttributeMapper
extends Mapper

商品属性に関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
ItemAttributeBaseModel | create(String itemCode, String templateCode, String templateDetailCode) プライマリキーに該当する商品属性を生成します。
void | delete(Collection models) 商品属性の基本モデルを複数削除します。
void | delete(ItemAttributeBaseModel model) 商品属性の基本モデルを1つだけ削除します。
void | insert(Collection models) 商品属性の基本モデルを複数挿入します。
void | insert(ItemAttributeBaseModel model) 商品属性の基本モデルを1つだけ挿入します。
ItemAttributeBaseModel | select(String itemCode, String templateCode, String templateDetailCode) プライマリーキーで特定される商品属性の基本モデルを取得します。
void | update(Collection models) 商品属性の基本モデルを複数更新します。
void | update(ItemAttributeBaseModel model) 商品属性の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public ItemAttributeBaseModel create(String itemCode,
                                     String templateCode,
                                     String templateDetailCode)
                              throws MapperException
プライマリキーに該当する商品属性を生成します。

パラメータ:
itemCode - 商品コード
templateCode - テンプレートコード
templateDetailCode - テンプレート明細コード
戻り値:
プライマリキーに該当する商品属性の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public ItemAttributeBaseModel select(String itemCode,
                                     String templateCode,
                                     String templateDetailCode)
                              throws MapperException
プライマリーキーで特定される商品属性の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
itemCode - 商品コード
templateCode - テンプレートコード
templateDetailCode - テンプレート明細コード
戻り値:
商品属性の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(ItemAttributeBaseModel model)
            throws MapperException
商品属性の基本モデルを1つだけ挿入します。 引数に指定する商品属性の基本モデルは同一の ItemAttributeMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する商品属性の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
商品属性の基本モデルを複数挿入します。 引数に指定するものは同一の ItemAttributeMapperの create(String,String,String) で生成された商品属性の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する商品属性の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(ItemAttributeBaseModel model)
            throws MapperException
商品属性の基本モデルを1つだけ更新します。 引数に指定する商品属性の基本モデルは同一の ItemAttributeMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する商品属性の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
商品属性の基本モデルを複数更新します。 引数に指定するものは同一の ItemAttributeMapperの select 系メソッド から取得されたものかで生成された商品属性の基本モデルの集合である必要があります。

パラメータ:
models - 更新する商品属性の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(ItemAttributeBaseModel model)
            throws MapperException
商品属性の基本モデルを1つだけ削除します。 引数で指定された商品属性の基本モデルに該当するデータのすべての情報を削除します。引数に指定する商品属性の基本モデルは同一の ItemAttributeMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する商品属性の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
商品属性の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する商品属性の基本モデルは同一の ItemAttributeMapperの select 系メソッド から取得された商品属性の基本モデルの集合である必要があります。

パラメータ:
models - 削除する商品属性の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.item.attribute (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.item.attribute
インタフェース
ItemAttributeBaseModel
ItemAttributeInternationalModel
ItemAttributeMapper


jp.co.intra_mart.foundation.datastore.application.model.item.attribute (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item.attribute

商品属性情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
ItemAttributeBaseModel | 商品属性の基本モデルです。
ItemAttributeInternationalModel | 商品属性の国際化モデルです。
ItemAttributeMapper | 商品属性に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item.attribute の説明

商品属性情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.item.attribute クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item.attribute の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeInternationalModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.item.attribute の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.item.attribute の使用

jp.co.intra_mart.foundation.datastore.application.model.item.attribute を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item.attribute 商品属性情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item.attribute により使用される jp.co.intra_mart.foundation.datastore.application.model.item.attribute のクラス
ItemAttributeBaseModel
商品属性の基本モデルです。
ItemAttributeInternationalModel
商品属性の国際化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel の使用

ItemCatalogueBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue 商品カタログ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue での ItemCatalogueBaseModel の使用

ItemCatalogueBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.item.catalogue のメソッド
ItemCatalogueBaseModel | ItemCatalogueMapper.create(String itemCode, String itemCatalogueCode) プライマリキーに該当する商品カタログを生成します。
ItemCatalogueBaseModel | ItemCatalogueMapper.select(String itemCode, String itemCatalogueCode) プライマリーキーで特定される商品カタログの基本モデルを取得します。

ItemCatalogueBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.item.catalogue のメソッド
void | ItemCatalogueMapper.insert(ItemCatalogueBaseModel model) 商品カタログの基本モデルを1つだけ挿入します。
void | ItemCatalogueMapper.update(ItemCatalogueBaseModel model) 商品カタログの基本モデルを1つだけ更新します。
void | ItemCatalogueMapper.delete(ItemCatalogueBaseModel model) 商品カタログの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemCatalogueBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue
インタフェース ItemCatalogueBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface ItemCatalogueBaseModel
extends BaseModel

商品カタログの基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | ITEM_CATALOGUE_CODE 商品カタログコード
static String | ITEM_CODE 商品コード
static String | MEDIA 媒体
static String | MEDIA_CLS 媒体種類
static int | MEDIA_CLS_FILE 媒体種類がFileを表す定数
static int | MEDIA_CLS_URL 媒体種類がURLを表す定数
static String | NOTES 備考
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
メソッドの概要
String | getItemCatalogueCode() 商品カタログコードを取得します。
String | getItemCode() 商品コードを取得します。
String | getMedia() 媒体を取得します。
int | getMediaCls() 媒体種類を取得します。
String | getNotes() 備考を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
void | setMedia(String media) 媒体を設定します。
void | setMediaCls(int mediaCls) 媒体種類を設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ITEM_CODE

public static final String ITEM_CODE
商品コード

関連項目:
定数フィールド値

ITEM_CATALOGUE_CODE

public static final String ITEM_CATALOGUE_CODE
商品カタログコード

関連項目:
定数フィールド値

MEDIA_CLS

public static final String MEDIA_CLS
媒体種類

関連項目:
定数フィールド値

MEDIA

public static final String MEDIA
媒体

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

MEDIA_CLS_FILE

public static final int MEDIA_CLS_FILE
媒体種類がFileを表す定数

関連項目:
定数フィールド値

MEDIA_CLS_URL

public static final int MEDIA_CLS_URL
媒体種類がURLを表す定数

関連項目:
定数フィールド値
メソッドの詳細

getItemCode

public String getItemCode()
                   throws AccessorException
商品コードを取得します。

戻り値:
商品コード
例外:
AccessorException - データの取得に失敗した場合

getItemCatalogueCode

public String getItemCatalogueCode()
                            throws AccessorException
商品カタログコードを取得します。

戻り値:
商品カタログコード
例外:
AccessorException - データの取得に失敗した場合

getMediaCls

public int getMediaCls()
                throws AccessorException
媒体種類を取得します。

戻り値:
媒体種類
例外:
AccessorException - データの取得に失敗した場合

setMediaCls

public void setMediaCls(int mediaCls)
                 throws AccessorException
媒体種類を設定します。

パラメータ:
mediaCls - 媒体種類
例外:
AccessorException - データの設定に失敗した場合

getMedia

public String getMedia()
                throws AccessorException
媒体を取得します。

戻り値:
媒体
例外:
AccessorException - データの取得に失敗した場合

setMedia

public void setMedia(String media)
              throws AccessorException
媒体を設定します。

パラメータ:
media - 媒体
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemCatalogueMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue
インタフェース ItemCatalogueMapper

すべてのスーパーインタフェース:
Mapper
public interface ItemCatalogueMapper
extends Mapper

商品カタログに関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
ItemCatalogueBaseModel | create(String itemCode, String itemCatalogueCode) プライマリキーに該当する商品カタログを生成します。
void | delete(Collection models) 商品カタログの基本モデルを複数削除します。
void | delete(ItemCatalogueBaseModel model) 商品カタログの基本モデルを1つだけ削除します。
void | insert(Collection models) 商品カタログの基本モデルを複数挿入します。
void | insert(ItemCatalogueBaseModel model) 商品カタログの基本モデルを1つだけ挿入します。
ItemCatalogueBaseModel | select(String itemCode, String itemCatalogueCode) プライマリーキーで特定される商品カタログの基本モデルを取得します。
void | update(Collection models) 商品カタログの基本モデルを複数更新します。
void | update(ItemCatalogueBaseModel model) 商品カタログの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public ItemCatalogueBaseModel create(String itemCode,
                                     String itemCatalogueCode)
                              throws MapperException
プライマリキーに該当する商品カタログを生成します。

パラメータ:
itemCode - 商品コード
itemCatalogueCode - 商品カタログコード
戻り値:
プライマリキーに該当する商品カタログの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public ItemCatalogueBaseModel select(String itemCode,
                                     String itemCatalogueCode)
                              throws MapperException
プライマリーキーで特定される商品カタログの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
itemCode - 商品コード
itemCatalogueCode - 商品カタログコード
戻り値:
商品カタログの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(ItemCatalogueBaseModel model)
            throws MapperException
商品カタログの基本モデルを1つだけ挿入します。 引数に指定する商品カタログの基本モデルは同一の ItemCatalogueMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する商品カタログの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
商品カタログの基本モデルを複数挿入します。 引数に指定するものは同一の ItemCatalogueMapperの create(String,String) で生成された商品カタログの基本モデルの集合である必要があります。

パラメータ:
models - 挿入する商品カタログの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(ItemCatalogueBaseModel model)
            throws MapperException
商品カタログの基本モデルを1つだけ更新します。 引数に指定する商品カタログの基本モデルは同一の ItemCatalogueMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する商品カタログの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
商品カタログの基本モデルを複数更新します。 引数に指定するものは同一の ItemCatalogueMapperの select 系メソッド から取得されたものかで生成された商品カタログの基本モデルの集合である必要があります。

パラメータ:
models - 更新する商品カタログの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(ItemCatalogueBaseModel model)
            throws MapperException
商品カタログの基本モデルを1つだけ削除します。 引数で指定された商品カタログの基本モデルに該当するデータのすべての情報を削除します。引数に指定する商品カタログの基本モデルは同一の ItemCatalogueMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する商品カタログの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
商品カタログの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する商品カタログの基本モデルは同一の ItemCatalogueMapperの select 系メソッド から取得された商品カタログの基本モデルの集合である必要があります。

パラメータ:
models - 削除する商品カタログの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.item.catalogue (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.item.catalogue
インタフェース
ItemCatalogueBaseModel
ItemCatalogueMapper


jp.co.intra_mart.foundation.datastore.application.model.item.catalogue (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item.catalogue

商品カタログ情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
ItemCatalogueBaseModel | 商品カタログの基本モデルです。
ItemCatalogueMapper | 商品カタログに関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item.catalogue の説明

商品カタログ情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.item.catalogue クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item.catalogue の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.item.catalogue の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue の使用

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue 商品カタログ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue により使用される jp.co.intra_mart.foundation.datastore.application.model.item.catalogue のクラス
ItemCatalogueBaseModel
商品カタログの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel の使用

ItemBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item.item 商品情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item.item での ItemBaseModel の使用

ItemBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.item.item のメソッド
ItemBaseModel | ItemMapper.create(String itemCode) プライマリキーに該当する商品を生成します。
ItemBaseModel | ItemMapper.select(String itemCode) プライマリーキーで特定される商品の基本モデルを取得します。

ItemBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.item.item のメソッド
void | ItemMapper.insert(ItemBaseModel model) 商品の基本モデルを1つだけ挿入します。
void | ItemMapper.update(ItemBaseModel model) 商品の基本モデルを1つだけ更新します。
void | ItemMapper.delete(ItemBaseModel model) 商品の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableInternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableInternationalModel の使用

ItemTerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item.item 商品情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item.item での ItemTerminableInternationalModel の使用

ItemTerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.item.item のメソッド
 ItemTerminableInternationalModel ItemTerminableModel.selectItemTerminableInternationalModel(Locale locale)
指定された言語に該当する商品の期間国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel の使用

ItemTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item.item 商品情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item.item での ItemTerminableModel の使用

ItemTerminableModel を返す jp.co.intra_mart.foundation.datastore.application.model.item.item のメソッド
 ItemTerminableModel ItemBaseModel.selectItemTerminableModel(Date date)
指定された日付に該当する商品の期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item.item
インタフェース ItemBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface ItemBaseModel
extends BaseModel

商品の基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | ITEM_CAPTION 商品通称
static String | ITEM_CODE 商品コード
static String | ITEM_NAME 商品名
static String | NOTES 備考
static String | PRODUCT_MODEL_CODE 製品型番
static String | PURCHASE_UNIT_PRICE 仕入単価
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SALES_UNIT_PRICE 販売単価
メソッドの概要
String | getItemCaption() 商品通称を取得します。
String | getItemCaption(Date date) 商品通称を取得します。
String | getItemCaption(Date date, Locale locale) 商品通称を取得します。
String | getItemCaption(Locale locale) 商品通称を取得します。
String | getItemCode() 商品コードを取得します。
String | getItemName() 商品名を取得します。
String | getItemName(Date date) 商品名を取得します。
String | getItemName(Date date, Locale locale) 商品名を取得します。
String | getItemName(Locale locale) 商品名を取得します。
String | getNotes() 備考を取得します。
String | getProductModelCode() 製品型番を取得します。
double | getPurchaseUnitPrice() 仕入単価を取得します。
double | getPurchaseUnitPrice(Date date) 仕入単価を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
double | getSalesUnitPrice() 販売単価を取得します。
double | getSalesUnitPrice(Date date) 販売単価を取得します。
ItemTerminableModel | selectItemTerminableModel(Date date) 指定された日付に該当する商品の期間化モデルを取得します。
void | setItemCaption(String itemCaption) 商品通称を設定します。
void | setItemCaption(String itemCaption, Date date) 商品通称を設定します。
void | setItemCaption(String itemCaption, Date date, Locale locale) 商品通称を設定します。
void | setItemCaption(String itemCaption, Locale locale) 商品通称を設定します。
void | setItemName(String itemName) 商品名を設定します。
void | setItemName(String itemName, Date date) 商品名を設定します。
void | setItemName(String itemName, Date date, Locale locale) 商品名を設定します。
void | setItemName(String itemName, Locale locale) 商品名を設定します。
void | setNotes(String notes) 備考を設定します。
void | setProductModelCode(String productModelCode) 製品型番を設定します。
void | setPurchaseUnitPrice(double purchaseUnitPrice) 仕入単価を設定します。
void | setPurchaseUnitPrice(double purchaseUnitPrice, Date date) 仕入単価を設定します。
void | setSalesUnitPrice(double salesUnitPrice) 販売単価を設定します。
void | setSalesUnitPrice(double salesUnitPrice, Date date) 販売単価を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ITEM_CODE

public static final String ITEM_CODE
商品コード

関連項目:
定数フィールド値

PRODUCT_MODEL_CODE

public static final String PRODUCT_MODEL_CODE
製品型番

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

SALES_UNIT_PRICE

public static final String SALES_UNIT_PRICE
販売単価

関連項目:
定数フィールド値

PURCHASE_UNIT_PRICE

public static final String PURCHASE_UNIT_PRICE
仕入単価

関連項目:
定数フィールド値

ITEM_NAME

public static final String ITEM_NAME
商品名

関連項目:
定数フィールド値

ITEM_CAPTION

public static final String ITEM_CAPTION
商品通称

関連項目:
定数フィールド値
メソッドの詳細

getItemCode

public String getItemCode()
                   throws AccessorException
商品コードを取得します。

戻り値:
商品コード
例外:
AccessorException - データの取得に失敗した場合

getProductModelCode

public String getProductModelCode()
                           throws AccessorException
製品型番を取得します。

戻り値:
製品型番
例外:
AccessorException - データの取得に失敗した場合

setProductModelCode

public void setProductModelCode(String productModelCode)
                         throws AccessorException
製品型番を設定します。

パラメータ:
productModelCode - 製品型番
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getSalesUnitPrice

public double getSalesUnitPrice()
                         throws AccessorException
販売単価を取得します。

戻り値:
販売単価
例外:
AccessorException - データの取得に失敗した場合

getSalesUnitPrice

public double getSalesUnitPrice(Date date)
                         throws AccessorException
販売単価を取得します。

パラメータ:
date - 日時
戻り値:
販売単価
例外:
AccessorException - データの取得に失敗した場合

setSalesUnitPrice

public void setSalesUnitPrice(double salesUnitPrice)
                       throws AccessorException
販売単価を設定します。

パラメータ:
salesUnitPrice - 販売単価
例外:
AccessorException - データの設定に失敗した場合

setSalesUnitPrice

public void setSalesUnitPrice(double salesUnitPrice,
                              Date date)
                       throws AccessorException
販売単価を設定します。

パラメータ:
salesUnitPrice - 販売単価
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getPurchaseUnitPrice

public double getPurchaseUnitPrice()
                            throws AccessorException
仕入単価を取得します。

戻り値:
仕入単価
例外:
AccessorException - データの取得に失敗した場合

getPurchaseUnitPrice

public double getPurchaseUnitPrice(Date date)
                            throws AccessorException
仕入単価を取得します。

パラメータ:
date - 日時
戻り値:
仕入単価
例外:
AccessorException - データの取得に失敗した場合

setPurchaseUnitPrice

public void setPurchaseUnitPrice(double purchaseUnitPrice)
                          throws AccessorException
仕入単価を設定します。

パラメータ:
purchaseUnitPrice - 仕入単価
例外:
AccessorException - データの設定に失敗した場合

setPurchaseUnitPrice

public void setPurchaseUnitPrice(double purchaseUnitPrice,
                                 Date date)
                          throws AccessorException
仕入単価を設定します。

パラメータ:
purchaseUnitPrice - 仕入単価
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getItemName

public String getItemName()
                   throws AccessorException
商品名を取得します。

戻り値:
商品名
例外:
AccessorException - データの取得に失敗した場合

getItemName

public String getItemName(Date date)
                   throws AccessorException
商品名を取得します。

パラメータ:
date - 日時
戻り値:
商品名
例外:
AccessorException - データの取得に失敗した場合

getItemName

public String getItemName(Locale locale)
                   throws AccessorException
商品名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
商品名
例外:
AccessorException - データの取得に失敗した場合

getItemName

public String getItemName(Date date,
                          Locale locale)
                   throws AccessorException
商品名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
商品名
例外:
AccessorException - データの取得に失敗した場合

setItemName

public void setItemName(String itemName)
                 throws AccessorException
商品名を設定します。

パラメータ:
itemName - 商品名
例外:
AccessorException - データの設定に失敗した場合

setItemName

public void setItemName(String itemName,
                        Date date)
                 throws AccessorException
商品名を設定します。

パラメータ:
itemName - 商品名
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setItemName

public void setItemName(String itemName,
                        Locale locale)
                 throws AccessorException
商品名を設定します。

パラメータ:
itemName - 商品名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setItemName

public void setItemName(String itemName,
                        Date date,
                        Locale locale)
                 throws AccessorException
商品名を設定します。

パラメータ:
itemName - 商品名
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getItemCaption

public String getItemCaption()
                      throws AccessorException
商品通称を取得します。

戻り値:
商品通称
例外:
AccessorException - データの取得に失敗した場合

getItemCaption

public String getItemCaption(Date date)
                      throws AccessorException
商品通称を取得します。

パラメータ:
date - 日時
戻り値:
商品通称
例外:
AccessorException - データの取得に失敗した場合

getItemCaption

public String getItemCaption(Locale locale)
                      throws AccessorException
商品通称を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
商品通称
例外:
AccessorException - データの取得に失敗した場合

getItemCaption

public String getItemCaption(Date date,
                             Locale locale)
                      throws AccessorException
商品通称を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
商品通称
例外:
AccessorException - データの取得に失敗した場合

setItemCaption

public void setItemCaption(String itemCaption)
                    throws AccessorException
商品通称を設定します。

パラメータ:
itemCaption - 商品通称
例外:
AccessorException - データの設定に失敗した場合

setItemCaption

public void setItemCaption(String itemCaption,
                           Date date)
                    throws AccessorException
商品通称を設定します。

パラメータ:
itemCaption - 商品通称
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setItemCaption

public void setItemCaption(String itemCaption,
                           Locale locale)
                    throws AccessorException
商品通称を設定します。

パラメータ:
itemCaption - 商品通称
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setItemCaption

public void setItemCaption(String itemCaption,
                           Date date,
                           Locale locale)
                    throws AccessorException
商品通称を設定します。

パラメータ:
itemCaption - 商品通称
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectItemTerminableModel

public ItemTerminableModel selectItemTerminableModel(Date date)
                                              throws IllegalTermException
指定された日付に該当する商品の期間化モデルを取得します。

パラメータ:
date - 指定日付
戻り値:
商品の期間化モデル
例外:
IllegalTermException - 指定された日付に該当する期間が定義されていない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item.item
インタフェース ItemMapper

すべてのスーパーインタフェース:
Mapper
public interface ItemMapper
extends Mapper

商品に関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
ItemBaseModel | create(String itemCode) プライマリキーに該当する商品を生成します。
void | delete(Collection models) 商品の基本モデルを複数削除します。
void | delete(ItemBaseModel model) 商品の基本モデルを1つだけ削除します。
void | insert(Collection models) 商品の基本モデルを複数挿入します。
void | insert(ItemBaseModel model) 商品の基本モデルを1つだけ挿入します。
ItemBaseModel | select(String itemCode) プライマリーキーで特定される商品の基本モデルを取得します。
void | update(Collection models) 商品の基本モデルを複数更新します。
void | update(ItemBaseModel model) 商品の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public ItemBaseModel create(String itemCode)
                     throws MapperException
プライマリキーに該当する商品を生成します。

パラメータ:
itemCode - 商品コード
戻り値:
プライマリキーに該当する商品の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public ItemBaseModel select(String itemCode)
                     throws MapperException
プライマリーキーで特定される商品の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
itemCode - 商品コード
戻り値:
商品の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(ItemBaseModel model)
            throws MapperException
商品の基本モデルを1つだけ挿入します。 引数に指定する商品の基本モデルは同一の ItemMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入する商品の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
商品の基本モデルを複数挿入します。 引数に指定するものは同一の ItemMapperの create(String) で生成された商品の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する商品の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(ItemBaseModel model)
            throws MapperException
商品の基本モデルを1つだけ更新します。 引数に指定する商品の基本モデルは同一の ItemMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する商品の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
商品の基本モデルを複数更新します。 引数に指定するものは同一の ItemMapperの select 系メソッド から取得されたものかで生成された商品の基本モデルの集合である必要があります。

パラメータ:
models - 更新する商品の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(ItemBaseModel model)
            throws MapperException
商品の基本モデルを1つだけ削除します。 引数で指定された商品の基本モデルに該当するデータのすべての情報を削除します。引数に指定する商品の基本モデルは同一の ItemMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する商品の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
商品の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する商品の基本モデルは同一の ItemMapperの select 系メソッド から取得された商品の基本モデルの集合である必要があります。

パラメータ:
models - 削除する商品の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ItemTerminableInternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item.item
インタフェース ItemTerminableInternationalModel

すべてのスーパーインタフェース:
Serializable, TerminableInternationalModel
public interface ItemTerminableInternationalModel
extends TerminableInternationalModel

商品の期間国際化モデルです。

導入されたバージョン:
5.1

メソッドの概要
String | getItemCaption() 商品通称を取得します。
String | getItemName() 商品名を取得します。
void | setItemCaption(String itemCaption) 商品通称を設定します。
void | setItemName(String itemName) 商品名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel から継承したメソッド
getExtendedTerminableInternationalModelMap, getLocale, init

メソッドの詳細

getItemName

public String getItemName()
                   throws AccessorException
商品名を取得します。

戻り値:
商品名
例外:
AccessorException - データの取得に失敗した場合

setItemName

public void setItemName(String itemName)
                 throws AccessorException
商品名を設定します。

パラメータ:
itemName - 商品名
例外:
AccessorException - データの設定に失敗した場合

getItemCaption

public String getItemCaption()
                      throws AccessorException
商品通称を取得します。

戻り値:
商品通称
例外:
AccessorException - データの取得に失敗した場合

setItemCaption

public void setItemCaption(String itemCaption)
                    throws AccessorException
商品通称を設定します。

パラメータ:
itemCaption - 商品通称
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ItemTerminableModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item.item
インタフェース ItemTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface ItemTerminableModel
extends TerminableModel

商品の期間化モデルです。

導入されたバージョン:
5.1

メソッドの概要
String | getItemCaption() 商品通称を取得します。
String | getItemCaption(Locale locale) 商品通称を取得します。
String | getItemName() 商品名を取得します。
String | getItemName(Locale locale) 商品名を取得します。
double | getPurchaseUnitPrice() 仕入単価を取得します。
double | getSalesUnitPrice() 販売単価を取得します。
ItemTerminableInternationalModel | selectItemTerminableInternationalModel(Locale locale) 指定された言語に該当する商品の期間国際化モデルを取得します。
void | setItemCaption(String itemCaption) 商品通称を設定します。
void | setItemCaption(String itemCaption, Locale locale) 商品通称を設定します。
void | setItemName(String itemName) 商品名を設定します。
void | setItemName(String itemName, Locale locale) 商品名を設定します。
void | setPurchaseUnitPrice(double purchaseUnitPrice) 仕入単価を設定します。
void | setSalesUnitPrice(double salesUnitPrice) 販売単価を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

メソッドの詳細

getSalesUnitPrice

public double getSalesUnitPrice()
                         throws AccessorException
販売単価を取得します。

戻り値:
販売単価
例外:
AccessorException - データの取得に失敗した場合

setSalesUnitPrice

public void setSalesUnitPrice(double salesUnitPrice)
                       throws AccessorException
販売単価を設定します。

パラメータ:
salesUnitPrice - 販売単価
例外:
AccessorException - データの設定に失敗した場合

getPurchaseUnitPrice

public double getPurchaseUnitPrice()
                            throws AccessorException
仕入単価を取得します。

戻り値:
仕入単価
例外:
AccessorException - データの取得に失敗した場合

setPurchaseUnitPrice

public void setPurchaseUnitPrice(double purchaseUnitPrice)
                          throws AccessorException
仕入単価を設定します。

パラメータ:
purchaseUnitPrice - 仕入単価
例外:
AccessorException - データの設定に失敗した場合

getItemName

public String getItemName()
                   throws AccessorException
商品名を取得します。

戻り値:
商品名
例外:
AccessorException - データの取得に失敗した場合

getItemName

public String getItemName(Locale locale)
                   throws AccessorException
商品名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
商品名
例外:
AccessorException - データの取得に失敗した場合

setItemName

public void setItemName(String itemName)
                 throws AccessorException
商品名を設定します。

パラメータ:
itemName - 商品名
例外:
AccessorException - データの設定に失敗した場合

setItemName

public void setItemName(String itemName,
                        Locale locale)
                 throws AccessorException
商品名を設定します。

パラメータ:
itemName - 商品名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getItemCaption

public String getItemCaption()
                      throws AccessorException
商品通称を取得します。

戻り値:
商品通称
例外:
AccessorException - データの取得に失敗した場合

getItemCaption

public String getItemCaption(Locale locale)
                      throws AccessorException
商品通称を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
商品通称
例外:
AccessorException - データの取得に失敗した場合

setItemCaption

public void setItemCaption(String itemCaption)
                    throws AccessorException
商品通称を設定します。

パラメータ:
itemCaption - 商品通称
例外:
AccessorException - データの設定に失敗した場合

setItemCaption

public void setItemCaption(String itemCaption,
                           Locale locale)
                    throws AccessorException
商品通称を設定します。

パラメータ:
itemCaption - 商品通称
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectItemTerminableInternationalModel

public ItemTerminableInternationalModel selectItemTerminableInternationalModel(Locale locale)
                                                                        throws IllegalLocaleException
指定された言語に該当する商品の期間国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
商品の期間国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.item.item (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.item.item
インタフェース
ItemBaseModel
ItemMapper
ItemTerminableInternationalModel
ItemTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.item.item (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item.item

商品情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
ItemBaseModel | 商品の基本モデルです。
ItemMapper | 商品に関連するマッパです。
ItemTerminableInternationalModel | 商品の期間国際化モデルです。
ItemTerminableModel | 商品の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item.item の説明

商品情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.item.item クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item.item の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.item.item の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.item.item の使用

jp.co.intra_mart.foundation.datastore.application.model.item.item を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item.item 商品情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item.item により使用される jp.co.intra_mart.foundation.datastore.application.model.item.item のクラス
ItemBaseModel
商品の基本モデルです。
ItemTerminableInternationalModel
商品の期間国際化モデルです。
ItemTerminableModel
商品の期間化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel の使用

ItemAttachBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach 商品分類情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach での ItemAttachBaseModel の使用

ItemAttachBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.item_category.attach のメソッド
ItemAttachBaseModel | ItemAttachMapper.create(String itemCategoryTypeCode, String itemCategoryCode, String itemCode) プライマリキーに該当する商品分類を生成します。
ItemAttachBaseModel | ItemAttachMapper.select(String itemCategoryTypeCode, String itemCategoryCode, String itemCode) プライマリーキーで特定される商品分類の基本モデルを取得します。

ItemAttachBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.item_category.attach のメソッド
void | ItemAttachMapper.insert(ItemAttachBaseModel model) 商品分類の基本モデルを1つだけ挿入します。
void | ItemAttachMapper.update(ItemAttachBaseModel model) 商品分類の基本モデルを1つだけ更新します。
void | ItemAttachMapper.delete(ItemAttachBaseModel model) 商品分類の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemAttachBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach
インタフェース ItemAttachBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface ItemAttachBaseModel
extends BaseModel

商品分類の基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | ITEM_CATEGORY_CODE 商品カテゴリコード
static String | ITEM_CATEGORY_TYPE_CODE 商品カテゴリ種別コード
static String | ITEM_CODE 商品コード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CD 最終更新者
メソッドの概要
String | getItemCategoryCode() 商品カテゴリコードを取得します。
String | getItemCategoryTypeCode() 商品カテゴリ種別コードを取得します。
String | getItemCode() 商品コードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCd() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ITEM_CATEGORY_TYPE_CODE

public static final String ITEM_CATEGORY_TYPE_CODE
商品カテゴリ種別コード

関連項目:
定数フィールド値

ITEM_CATEGORY_CODE

public static final String ITEM_CATEGORY_CODE
商品カテゴリコード

関連項目:
定数フィールド値

ITEM_CODE

public static final String ITEM_CODE
商品コード

関連項目:
定数フィールド値

RECORD_USER_CD

public static final String RECORD_USER_CD
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getItemCategoryTypeCode

public String getItemCategoryTypeCode()
                               throws AccessorException
商品カテゴリ種別コードを取得します。

戻り値:
商品カテゴリ種別コード
例外:
AccessorException - データの取得に失敗した場合

getItemCategoryCode

public String getItemCategoryCode()
                           throws AccessorException
商品カテゴリコードを取得します。

戻り値:
商品カテゴリコード
例外:
AccessorException - データの取得に失敗した場合

getItemCode

public String getItemCode()
                   throws AccessorException
商品コードを取得します。

戻り値:
商品コード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCd

public String getRecordUserCd()
                       throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemAttachMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach
インタフェース ItemAttachMapper

すべてのスーパーインタフェース:
Mapper
public interface ItemAttachMapper
extends Mapper

商品分類に関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
ItemAttachBaseModel | create(String itemCategoryTypeCode, String itemCategoryCode, String itemCode) プライマリキーに該当する商品分類を生成します。
void | delete(Collection models) 商品分類の基本モデルを複数削除します。
void | delete(ItemAttachBaseModel model) 商品分類の基本モデルを1つだけ削除します。
void | insert(Collection models) 商品分類の基本モデルを複数挿入します。
void | insert(ItemAttachBaseModel model) 商品分類の基本モデルを1つだけ挿入します。
ItemAttachBaseModel | select(String itemCategoryTypeCode, String itemCategoryCode, String itemCode) プライマリーキーで特定される商品分類の基本モデルを取得します。
void | update(Collection models) 商品分類の基本モデルを複数更新します。
void | update(ItemAttachBaseModel model) 商品分類の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public ItemAttachBaseModel create(String itemCategoryTypeCode,
                                  String itemCategoryCode,
                                  String itemCode)
                           throws MapperException
プライマリキーに該当する商品分類を生成します。

パラメータ:
itemCategoryTypeCode - 商品カテゴリ種別コード
itemCategoryCode - 商品カテゴリコード
itemCode - 商品コード
戻り値:
プライマリキーに該当する商品分類の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public ItemAttachBaseModel select(String itemCategoryTypeCode,
                                  String itemCategoryCode,
                                  String itemCode)
                           throws MapperException
プライマリーキーで特定される商品分類の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
itemCategoryTypeCode - 商品カテゴリ種別コード
itemCategoryCode - 商品カテゴリコード
itemCode - 商品コード
戻り値:
商品分類の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(ItemAttachBaseModel model)
            throws MapperException
商品分類の基本モデルを1つだけ挿入します。 引数に指定する商品分類の基本モデルは同一の ItemAttachMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する商品分類の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
商品分類の基本モデルを複数挿入します。 引数に指定するものは同一の ItemAttachMapperの create(String,String,String) で生成された商品分類の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する商品分類の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(ItemAttachBaseModel model)
            throws MapperException
商品分類の基本モデルを1つだけ更新します。 引数に指定する商品分類の基本モデルは同一の ItemAttachMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する商品分類の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
商品分類の基本モデルを複数更新します。 引数に指定するものは同一の ItemAttachMapperの select 系メソッド から取得されたものかで生成された商品分類の基本モデルの集合である必要があります。

パラメータ:
models - 更新する商品分類の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(ItemAttachBaseModel model)
            throws MapperException
商品分類の基本モデルを1つだけ削除します。 引数で指定された商品分類の基本モデルに該当するデータのすべての情報を削除します。引数に指定する商品分類の基本モデルは同一の ItemAttachMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する商品分類の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
商品分類の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する商品分類の基本モデルは同一の ItemAttachMapperの select 系メソッド から取得された商品分類の基本モデルの集合である必要があります。

パラメータ:
models - 削除する商品分類の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.item_category.attach (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.item_category.attach
インタフェース
ItemAttachBaseModel
ItemAttachMapper


jp.co.intra_mart.foundation.datastore.application.model.item_category.attach (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_category.attach

商品分類情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
ItemAttachBaseModel | 商品分類の基本モデルです。
ItemAttachMapper | 商品分類に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_category.attach の説明

商品分類情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.item_category.attach クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_category.attach の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_category.attach の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach 商品分類情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach により使用される jp.co.intra_mart.foundation.datastore.application.model.item_category.attach のクラス
ItemAttachBaseModel
商品分類の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel の使用

ItemCategoryBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_category.category 商品カテゴリ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.category での ItemCategoryBaseModel の使用

ItemCategoryBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.item_category.category のメソッド
ItemCategoryBaseModel | ItemCategoryMapper.create(String itemCategoryTypeCode, String itemCategoryCode) プライマリキーに該当する商品カテゴリを生成します。
ItemCategoryBaseModel | ItemCategoryMapper.select(String itemCategoryTypeCode, String itemCategoryCode) プライマリーキーで特定される商品カテゴリの基本モデルを取得します。

ItemCategoryBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.item_category.category のメソッド
void | ItemCategoryMapper.insert(ItemCategoryBaseModel model) 商品カテゴリの基本モデルを1つだけ挿入します。
void | ItemCategoryMapper.update(ItemCategoryBaseModel model) 商品カテゴリの基本モデルを1つだけ更新します。
void | ItemCategoryMapper.delete(ItemCategoryBaseModel model) 商品カテゴリの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryInternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryInternationalModel の使用

ItemCategoryInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_category.category 商品カテゴリ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.category での ItemCategoryInternationalModel の使用

ItemCategoryInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.item_category.category のメソッド
 ItemCategoryInternationalModel ItemCategoryBaseModel.selectItemCategoryInternationalModel(Locale locale)
指定された言語に該当する商品カテゴリの国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemCategoryBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_category.category
インタフェース ItemCategoryBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface ItemCategoryBaseModel
extends BaseModel

商品カテゴリの基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | ITEM_CATEGORY_CODE 商品カテゴリコード
static String | ITEM_CATEGORY_NAME 商品カテゴリ名
static String | ITEM_CATEGORY_TYPE_CODE 商品カテゴリ種別コード
static String | NOTES 備考
static String | PARENT_ITEM_CATEGORY_CODE 親商品カテゴリコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
メソッドの概要
String | getItemCategoryCode() 商品カテゴリコードを取得します。
String | getItemCategoryName() 商品カテゴリ名を取得します。
String | getItemCategoryName(Locale locale) 商品カテゴリ名を取得します。
String | getItemCategoryTypeCode() 商品カテゴリ種別コードを取得します。
String | getNotes() 備考を取得します。
String | getParentItemCategoryCode() 親商品カテゴリコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
ItemCategoryInternationalModel | selectItemCategoryInternationalModel(Locale locale) 指定された言語に該当する商品カテゴリの国際化モデルを取得します。
void | setItemCategoryName(String itemCategoryName) 商品カテゴリ名を設定します。
void | setItemCategoryName(String itemCategoryName, Locale locale) 商品カテゴリ名を設定します。
void | setNotes(String notes) 備考を設定します。
void | setParentItemCategoryCode(String parentItemCategoryCode) 親商品カテゴリコードを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ITEM_CATEGORY_TYPE_CODE

public static final String ITEM_CATEGORY_TYPE_CODE
商品カテゴリ種別コード

関連項目:
定数フィールド値

ITEM_CATEGORY_CODE

public static final String ITEM_CATEGORY_CODE
商品カテゴリコード

関連項目:
定数フィールド値

PARENT_ITEM_CATEGORY_CODE

public static final String PARENT_ITEM_CATEGORY_CODE
親商品カテゴリコード

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

ITEM_CATEGORY_NAME

public static final String ITEM_CATEGORY_NAME
商品カテゴリ名

関連項目:
定数フィールド値
メソッドの詳細

getItemCategoryTypeCode

public String getItemCategoryTypeCode()
                               throws AccessorException
商品カテゴリ種別コードを取得します。

戻り値:
商品カテゴリ種別コード
例外:
AccessorException - データの取得に失敗した場合

getItemCategoryCode

public String getItemCategoryCode()
                           throws AccessorException
商品カテゴリコードを取得します。

戻り値:
商品カテゴリコード
例外:
AccessorException - データの取得に失敗した場合

getParentItemCategoryCode

public String getParentItemCategoryCode()
                                 throws AccessorException
親商品カテゴリコードを取得します。

戻り値:
親商品カテゴリコード
例外:
AccessorException - データの取得に失敗した場合

setParentItemCategoryCode

public void setParentItemCategoryCode(String parentItemCategoryCode)
                               throws AccessorException
親商品カテゴリコードを設定します。

パラメータ:
parentItemCategoryCode - 親商品カテゴリコード
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getItemCategoryName

public String getItemCategoryName()
                           throws AccessorException
商品カテゴリ名を取得します。

戻り値:
商品カテゴリ名
例外:
AccessorException - データの取得に失敗した場合

getItemCategoryName

public String getItemCategoryName(Locale locale)
                           throws AccessorException
商品カテゴリ名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
商品カテゴリ名
例外:
AccessorException - データの取得に失敗した場合

setItemCategoryName

public void setItemCategoryName(String itemCategoryName)
                         throws AccessorException
商品カテゴリ名を設定します。

パラメータ:
itemCategoryName - 商品カテゴリ名
例外:
AccessorException - データの設定に失敗した場合

setItemCategoryName

public void setItemCategoryName(String itemCategoryName,
                                Locale locale)
                         throws AccessorException
商品カテゴリ名を設定します。

パラメータ:
itemCategoryName - 商品カテゴリ名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectItemCategoryInternationalModel

public ItemCategoryInternationalModel selectItemCategoryInternationalModel(Locale locale)
                                                                    throws IllegalLocaleException
指定された言語に該当する商品カテゴリの国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
商品カテゴリの国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemCategoryInternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_category.category
インタフェース ItemCategoryInternationalModel

すべてのスーパーインタフェース:
InternationalModel, Serializable
public interface ItemCategoryInternationalModel
extends InternationalModel

商品カテゴリの国際化モデルです。

導入されたバージョン:
5.1

メソッドの概要
String | getItemCategoryName() 商品カテゴリ名を取得します。
void | setItemCategoryName(String itemCategoryName) 商品カテゴリ名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModel から継承したメソッド
getExtendedInternationalModelMap, getLocale, init

メソッドの詳細

getItemCategoryName

public String getItemCategoryName()
                           throws AccessorException
商品カテゴリ名を取得します。

戻り値:
商品カテゴリ名
例外:
AccessorException - データの取得に失敗した場合

setItemCategoryName

public void setItemCategoryName(String itemCategoryName)
                         throws AccessorException
商品カテゴリ名を設定します。

パラメータ:
itemCategoryName - 商品カテゴリ名
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ItemCategoryMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_category.category
インタフェース ItemCategoryMapper

すべてのスーパーインタフェース:
Mapper
public interface ItemCategoryMapper
extends Mapper

商品カテゴリに関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
ItemCategoryBaseModel | create(String itemCategoryTypeCode, String itemCategoryCode) プライマリキーに該当する商品カテゴリを生成します。
void | delete(Collection models) 商品カテゴリの基本モデルを複数削除します。
void | delete(ItemCategoryBaseModel model) 商品カテゴリの基本モデルを1つだけ削除します。
void | insert(Collection models) 商品カテゴリの基本モデルを複数挿入します。
void | insert(ItemCategoryBaseModel model) 商品カテゴリの基本モデルを1つだけ挿入します。
ItemCategoryBaseModel | select(String itemCategoryTypeCode, String itemCategoryCode) プライマリーキーで特定される商品カテゴリの基本モデルを取得します。
void | update(Collection models) 商品カテゴリの基本モデルを複数更新します。
void | update(ItemCategoryBaseModel model) 商品カテゴリの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public ItemCategoryBaseModel create(String itemCategoryTypeCode,
                                    String itemCategoryCode)
                             throws MapperException
プライマリキーに該当する商品カテゴリを生成します。

パラメータ:
itemCategoryTypeCode - 商品カテゴリ種別コード
itemCategoryCode - 商品カテゴリコード
戻り値:
プライマリキーに該当する商品カテゴリの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public ItemCategoryBaseModel select(String itemCategoryTypeCode,
                                    String itemCategoryCode)
                             throws MapperException
プライマリーキーで特定される商品カテゴリの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
itemCategoryTypeCode - 商品カテゴリ種別コード
itemCategoryCode - 商品カテゴリコード
戻り値:
商品カテゴリの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(ItemCategoryBaseModel model)
            throws MapperException
商品カテゴリの基本モデルを1つだけ挿入します。 引数に指定する商品カテゴリの基本モデルは同一の ItemCategoryMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する商品カテゴリの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
商品カテゴリの基本モデルを複数挿入します。 引数に指定するものは同一の ItemCategoryMapperの create(String,String) で生成された商品カテゴリの基本モデルの集合である必要があります。

パラメータ:
models - 挿入する商品カテゴリの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(ItemCategoryBaseModel model)
            throws MapperException
商品カテゴリの基本モデルを1つだけ更新します。 引数に指定する商品カテゴリの基本モデルは同一の ItemCategoryMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する商品カテゴリの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
商品カテゴリの基本モデルを複数更新します。 引数に指定するものは同一の ItemCategoryMapperの select 系メソッド から取得されたものかで生成された商品カテゴリの基本モデルの集合である必要があります。

パラメータ:
models - 更新する商品カテゴリの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(ItemCategoryBaseModel model)
            throws MapperException
商品カテゴリの基本モデルを1つだけ削除します。 引数で指定された商品カテゴリの基本モデルに該当するデータのすべての情報を削除します。引数に指定する商品カテゴリの基本モデルは同一の ItemCategoryMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する商品カテゴリの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
商品カテゴリの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する商品カテゴリの基本モデルは同一の ItemCategoryMapperの select 系メソッド から取得された商品カテゴリの基本モデルの集合である必要があります。

パラメータ:
models - 削除する商品カテゴリの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.item_category.category (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.item_category.category
インタフェース
ItemCategoryBaseModel
ItemCategoryInternationalModel
ItemCategoryMapper


jp.co.intra_mart.foundation.datastore.application.model.item_category.category (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_category.category

商品カテゴリ情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
ItemCategoryBaseModel | 商品カテゴリの基本モデルです。
ItemCategoryInternationalModel | 商品カテゴリの国際化モデルです。
ItemCategoryMapper | 商品カテゴリに関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_category.category の説明

商品カテゴリ情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.item_category.category クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_category.category の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryInternationalModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_category.category の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_category.category の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.category を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_category.category 商品カテゴリ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.category により使用される jp.co.intra_mart.foundation.datastore.application.model.item_category.category のクラス
ItemCategoryBaseModel
商品カテゴリの基本モデルです。
ItemCategoryInternationalModel
商品カテゴリの国際化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel の使用

ItemCategoryTypeBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_category.type 商品カテゴリ種別情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.type での ItemCategoryTypeBaseModel の使用

ItemCategoryTypeBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.item_category.type のメソッド
ItemCategoryTypeBaseModel | ItemCategoryTypeMapper.create(String itemCategoryTypeCode) プライマリキーに該当する商品カテゴリ種別を生成します。
ItemCategoryTypeBaseModel | ItemCategoryTypeMapper.select(String itemCategoryTypeCode) プライマリーキーで特定される商品カテゴリ種別の基本モデルを取得します。

ItemCategoryTypeBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.item_category.type のメソッド
void | ItemCategoryTypeMapper.insert(ItemCategoryTypeBaseModel model) 商品カテゴリ種別の基本モデルを1つだけ挿入します。
void | ItemCategoryTypeMapper.update(ItemCategoryTypeBaseModel model) 商品カテゴリ種別の基本モデルを1つだけ更新します。
void | ItemCategoryTypeMapper.delete(ItemCategoryTypeBaseModel model) 商品カテゴリ種別の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemCategoryTypeBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_category.type
インタフェース ItemCategoryTypeBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface ItemCategoryTypeBaseModel
extends BaseModel

商品カテゴリ種別の基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | ITEM_CATEGORY_TYPE_CODE 商品カテゴリ種別コード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getItemCategoryTypeCode() 商品カテゴリ種別コードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ITEM_CATEGORY_TYPE_CODE

public static final String ITEM_CATEGORY_TYPE_CODE
商品カテゴリ種別コード

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getItemCategoryTypeCode

public String getItemCategoryTypeCode()
                               throws AccessorException
商品カテゴリ種別コードを取得します。

戻り値:
商品カテゴリ種別コード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemCategoryTypeMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_category.type
インタフェース ItemCategoryTypeMapper

すべてのスーパーインタフェース:
Mapper
public interface ItemCategoryTypeMapper
extends Mapper

商品カテゴリ種別に関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
ItemCategoryTypeBaseModel | create(String itemCategoryTypeCode) プライマリキーに該当する商品カテゴリ種別を生成します。
void | delete(Collection models) 商品カテゴリ種別の基本モデルを複数削除します。
void | delete(ItemCategoryTypeBaseModel model) 商品カテゴリ種別の基本モデルを1つだけ削除します。
void | insert(Collection models) 商品カテゴリ種別の基本モデルを複数挿入します。
void | insert(ItemCategoryTypeBaseModel model) 商品カテゴリ種別の基本モデルを1つだけ挿入します。
ItemCategoryTypeBaseModel | select(String itemCategoryTypeCode) プライマリーキーで特定される商品カテゴリ種別の基本モデルを取得します。
void | update(Collection models) 商品カテゴリ種別の基本モデルを複数更新します。
void | update(ItemCategoryTypeBaseModel model) 商品カテゴリ種別の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public ItemCategoryTypeBaseModel create(String itemCategoryTypeCode)
                                 throws MapperException
プライマリキーに該当する商品カテゴリ種別を生成します。

パラメータ:
itemCategoryTypeCode - 商品カテゴリ種別コード
戻り値:
プライマリキーに該当する商品カテゴリ種別の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public ItemCategoryTypeBaseModel select(String itemCategoryTypeCode)
                                 throws MapperException
プライマリーキーで特定される商品カテゴリ種別の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
itemCategoryTypeCode - 商品カテゴリ種別コード
戻り値:
商品カテゴリ種別の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(ItemCategoryTypeBaseModel model)
            throws MapperException
商品カテゴリ種別の基本モデルを1つだけ挿入します。 引数に指定する商品カテゴリ種別の基本モデルは同一の ItemCategoryTypeMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入する商品カテゴリ種別の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
商品カテゴリ種別の基本モデルを複数挿入します。 引数に指定するものは同一の ItemCategoryTypeMapperの create(String) で生成された商品カテゴリ種別の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する商品カテゴリ種別の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(ItemCategoryTypeBaseModel model)
            throws MapperException
商品カテゴリ種別の基本モデルを1つだけ更新します。 引数に指定する商品カテゴリ種別の基本モデルは同一の ItemCategoryTypeMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する商品カテゴリ種別の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
商品カテゴリ種別の基本モデルを複数更新します。 引数に指定するものは同一の ItemCategoryTypeMapperの select 系メソッド から取得されたものかで生成された商品カテゴリ種別の基本モデルの集合である必要があります。

パラメータ:
models - 更新する商品カテゴリ種別の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(ItemCategoryTypeBaseModel model)
            throws MapperException
商品カテゴリ種別の基本モデルを1つだけ削除します。 引数で指定された商品カテゴリ種別の基本モデルに該当するデータのすべての情報を削除します。引数に指定する商品カテゴリ種別の基本モデルは同一の ItemCategoryTypeMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する商品カテゴリ種別の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
商品カテゴリ種別の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する商品カテゴリ種別の基本モデルは同一の ItemCategoryTypeMapperの select 系メソッド から取得された商品カテゴリ種別の基本モデルの集合である必要があります。

パラメータ:
models - 削除する商品カテゴリ種別の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.item_category.type (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.item_category.type
インタフェース
ItemCategoryTypeBaseModel
ItemCategoryTypeMapper


jp.co.intra_mart.foundation.datastore.application.model.item_category.type (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_category.type

商品カテゴリ種別情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
ItemCategoryTypeBaseModel | 商品カテゴリ種別の基本モデルです。
ItemCategoryTypeMapper | 商品カテゴリ種別に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_category.type の説明

商品カテゴリ種別情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.item_category.type クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_category.type の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_category.type の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_category.type の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.type を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_category.type 商品カテゴリ種別情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.type により使用される jp.co.intra_mart.foundation.datastore.application.model.item_category.type のクラス
ItemCategoryTypeBaseModel
商品カテゴリ種別の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel の使用

ItemTemplateDetailBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail 商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail での ItemTemplateDetailBaseModel の使用

ItemTemplateDetailBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.item_template.detail のメソッド
ItemTemplateDetailBaseModel | ItemTemplateDetailMapper.create(String templateCode, String templateDetailCode) プライマリキーに該当する商品属性テンプレート明細を生成します。
ItemTemplateDetailBaseModel | ItemTemplateDetailMapper.select(String templateCode, String templateDetailCode) プライマリーキーで特定される商品属性テンプレート明細の基本モデルを取得します。

ItemTemplateDetailBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.item_template.detail のメソッド
void | ItemTemplateDetailMapper.insert(ItemTemplateDetailBaseModel model) 商品属性テンプレート明細の基本モデルを1つだけ挿入します。
void | ItemTemplateDetailMapper.update(ItemTemplateDetailBaseModel model) 商品属性テンプレート明細の基本モデルを1つだけ更新します。
void | ItemTemplateDetailMapper.delete(ItemTemplateDetailBaseModel model) 商品属性テンプレート明細の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailInternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailInternationalModel の使用

ItemTemplateDetailInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail 商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail での ItemTemplateDetailInternationalModel の使用

ItemTemplateDetailInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.item_template.detail のメソッド
 ItemTemplateDetailInternationalModel ItemTemplateDetailBaseModel.selectItemTemplateDetailInternationalModel(Locale locale)
指定された言語に該当する商品属性テンプレート明細の国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemTemplateDetailBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail
インタフェース ItemTemplateDetailBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface ItemTemplateDetailBaseModel
extends BaseModel

商品属性テンプレート明細の基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | DATA_TYPE データ型
static int | DATA_TYPE_NUMBER データ型が数値を表す定数
static int | DATA_TYPE_STRING データ型が文字列型を表す定数
static String | NOTES 備考
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CD 最終更新者
static String | SORT_KEY ソートキー
static String | TEMPLATE_CODE テンプレートコード
static String | TEMPLATE_DETAIL_CODE テンプレート明細コード
static String | TEMPLATE_DETAIL_NAME テンプレート明細名
メソッドの概要
int | getDataType() データ型を取得します。
String | getNotes() 備考を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCd() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
String | getTemplateCode() テンプレートコードを取得します。
String | getTemplateDetailCode() テンプレート明細コードを取得します。
String | getTemplateDetailName() テンプレート明細名を取得します。
String | getTemplateDetailName(Locale locale) テンプレート明細名を取得します。
ItemTemplateDetailInternationalModel | selectItemTemplateDetailInternationalModel(Locale locale) 指定された言語に該当する商品属性テンプレート明細の国際化モデルを取得します。
void | setDataType(int dataType) データ型を設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
void | setTemplateDetailName(String templateDetailName) テンプレート明細名を設定します。
void | setTemplateDetailName(String templateDetailName, Locale locale) テンプレート明細名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

TEMPLATE_CODE

public static final String TEMPLATE_CODE
テンプレートコード

関連項目:
定数フィールド値

TEMPLATE_DETAIL_CODE

public static final String TEMPLATE_DETAIL_CODE
テンプレート明細コード

関連項目:
定数フィールド値

DATA_TYPE

public static final String DATA_TYPE
データ型

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

RECORD_USER_CD

public static final String RECORD_USER_CD
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

TEMPLATE_DETAIL_NAME

public static final String TEMPLATE_DETAIL_NAME
テンプレート明細名

関連項目:
定数フィールド値

DATA_TYPE_NUMBER

public static final int DATA_TYPE_NUMBER
データ型が数値を表す定数

関連項目:
定数フィールド値

DATA_TYPE_STRING

public static final int DATA_TYPE_STRING
データ型が文字列型を表す定数

関連項目:
定数フィールド値
メソッドの詳細

getTemplateCode

public String getTemplateCode()
                       throws AccessorException
テンプレートコードを取得します。

戻り値:
テンプレートコード
例外:
AccessorException - データの取得に失敗した場合

getTemplateDetailCode

public String getTemplateDetailCode()
                             throws AccessorException
テンプレート明細コードを取得します。

戻り値:
テンプレート明細コード
例外:
AccessorException - データの取得に失敗した場合

getDataType

public int getDataType()
                throws AccessorException
データ型を取得します。

戻り値:
データ型
例外:
AccessorException - データの取得に失敗した場合

setDataType

public void setDataType(int dataType)
                 throws AccessorException
データ型を設定します。

パラメータ:
dataType - データ型
例外:
AccessorException - データの設定に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCd

public String getRecordUserCd()
                       throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getTemplateDetailName

public String getTemplateDetailName()
                             throws AccessorException
テンプレート明細名を取得します。

戻り値:
テンプレート明細名
例外:
AccessorException - データの取得に失敗した場合

getTemplateDetailName

public String getTemplateDetailName(Locale locale)
                             throws AccessorException
テンプレート明細名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
テンプレート明細名
例外:
AccessorException - データの取得に失敗した場合

setTemplateDetailName

public void setTemplateDetailName(String templateDetailName)
                           throws AccessorException
テンプレート明細名を設定します。

パラメータ:
templateDetailName - テンプレート明細名
例外:
AccessorException - データの設定に失敗した場合

setTemplateDetailName

public void setTemplateDetailName(String templateDetailName,
                                  Locale locale)
                           throws AccessorException
テンプレート明細名を設定します。

パラメータ:
templateDetailName - テンプレート明細名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectItemTemplateDetailInternationalModel

public ItemTemplateDetailInternationalModel selectItemTemplateDetailInternationalModel(Locale locale)
                                                                                throws IllegalLocaleException
指定された言語に該当する商品属性テンプレート明細の国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
商品属性テンプレート明細の国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemTemplateDetailInternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail
インタフェース ItemTemplateDetailInternationalModel

すべてのスーパーインタフェース:
InternationalModel, Serializable
public interface ItemTemplateDetailInternationalModel
extends InternationalModel

商品属性テンプレート明細の国際化モデルです。

導入されたバージョン:
5.1

メソッドの概要
String | getTemplateDetailName() テンプレート明細名を取得します。
void | setTemplateDetailName(String templateDetailName) テンプレート明細名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModel から継承したメソッド
getExtendedInternationalModelMap, getLocale, init

メソッドの詳細

getTemplateDetailName

public String getTemplateDetailName()
                             throws AccessorException
テンプレート明細名を取得します。

戻り値:
テンプレート明細名
例外:
AccessorException - データの取得に失敗した場合

setTemplateDetailName

public void setTemplateDetailName(String templateDetailName)
                           throws AccessorException
テンプレート明細名を設定します。

パラメータ:
templateDetailName - テンプレート明細名
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ItemTemplateDetailMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail
インタフェース ItemTemplateDetailMapper

すべてのスーパーインタフェース:
Mapper
public interface ItemTemplateDetailMapper
extends Mapper

商品属性テンプレート明細に関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
ItemTemplateDetailBaseModel | create(String templateCode, String templateDetailCode) プライマリキーに該当する商品属性テンプレート明細を生成します。
void | delete(Collection models) 商品属性テンプレート明細の基本モデルを複数削除します。
void | delete(ItemTemplateDetailBaseModel model) 商品属性テンプレート明細の基本モデルを1つだけ削除します。
void | insert(Collection models) 商品属性テンプレート明細の基本モデルを複数挿入します。
void | insert(ItemTemplateDetailBaseModel model) 商品属性テンプレート明細の基本モデルを1つだけ挿入します。
ItemTemplateDetailBaseModel | select(String templateCode, String templateDetailCode) プライマリーキーで特定される商品属性テンプレート明細の基本モデルを取得します。
void | update(Collection models) 商品属性テンプレート明細の基本モデルを複数更新します。
void | update(ItemTemplateDetailBaseModel model) 商品属性テンプレート明細の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public ItemTemplateDetailBaseModel create(String templateCode,
                                          String templateDetailCode)
                                   throws MapperException
プライマリキーに該当する商品属性テンプレート明細を生成します。

パラメータ:
templateCode - テンプレートコード
templateDetailCode - テンプレート明細コード
戻り値:
プライマリキーに該当する商品属性テンプレート明細の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public ItemTemplateDetailBaseModel select(String templateCode,
                                          String templateDetailCode)
                                   throws MapperException
プライマリーキーで特定される商品属性テンプレート明細の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
templateCode - テンプレートコード
templateDetailCode - テンプレート明細コード
戻り値:
商品属性テンプレート明細の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(ItemTemplateDetailBaseModel model)
            throws MapperException
商品属性テンプレート明細の基本モデルを1つだけ挿入します。 引数に指定する商品属性テンプレート明細の基本モデルは同一の ItemTemplateDetailMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する商品属性テンプレート明細の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
商品属性テンプレート明細の基本モデルを複数挿入します。 引数に指定するものは同一の ItemTemplateDetailMapperの create(String,String) で生成された商品属性テンプレート明細の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する商品属性テンプレート明細の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(ItemTemplateDetailBaseModel model)
            throws MapperException
商品属性テンプレート明細の基本モデルを1つだけ更新します。 引数に指定する商品属性テンプレート明細の基本モデルは同一の ItemTemplateDetailMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する商品属性テンプレート明細の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
商品属性テンプレート明細の基本モデルを複数更新します。 引数に指定するものは同一の ItemTemplateDetailMapperの select 系メソッド から取得されたものかで生成された商品属性テンプレート明細の基本モデルの集合である必要があります。

パラメータ:
models - 更新する商品属性テンプレート明細の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(ItemTemplateDetailBaseModel model)
            throws MapperException
商品属性テンプレート明細の基本モデルを1つだけ削除します。 引数で指定された商品属性テンプレート明細の基本モデルに該当するデータのすべての情報を削除します。引数に指定する商品属性テンプレート明細の基本モデルは同一の ItemTemplateDetailMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する商品属性テンプレート明細の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
商品属性テンプレート明細の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する商品属性テンプレート明細の基本モデルは同一の ItemTemplateDetailMapperの select 系メソッド から取得された商品属性テンプレート明細の基本モデルの集合である必要があります。

パラメータ:
models - 削除する商品属性テンプレート明細の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.item_template.detail (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.item_template.detail
インタフェース
ItemTemplateDetailBaseModel
ItemTemplateDetailInternationalModel
ItemTemplateDetailMapper


jp.co.intra_mart.foundation.datastore.application.model.item_template.detail (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_template.detail

商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
ItemTemplateDetailBaseModel | 商品属性テンプレート明細の基本モデルです。
ItemTemplateDetailInternationalModel | 商品属性テンプレート明細の国際化モデルです。
ItemTemplateDetailMapper | 商品属性テンプレート明細に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_template.detail の説明

商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.item_template.detail クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_template.detail の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailInternationalModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_template.detail の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail の使用

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail 商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail により使用される jp.co.intra_mart.foundation.datastore.application.model.item_template.detail のクラス
ItemTemplateDetailBaseModel
商品属性テンプレート明細の基本モデルです。
ItemTemplateDetailInternationalModel
商品属性テンプレート明細の国際化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel の使用

ItemTemplateBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_template.template 商品テンプレート情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item_template.template での ItemTemplateBaseModel の使用

ItemTemplateBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.item_template.template のメソッド
ItemTemplateBaseModel | ItemTemplateMapper.create(String templateCode) プライマリキーに該当する商品属性テンプレートを生成します。
ItemTemplateBaseModel | ItemTemplateMapper.select(String templateCode) プライマリーキーで特定される商品属性テンプレートの基本モデルを取得します。

ItemTemplateBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.item_template.template のメソッド
void | ItemTemplateMapper.insert(ItemTemplateBaseModel model) 商品属性テンプレートの基本モデルを1つだけ挿入します。
void | ItemTemplateMapper.update(ItemTemplateBaseModel model) 商品属性テンプレートの基本モデルを1つだけ更新します。
void | ItemTemplateMapper.delete(ItemTemplateBaseModel model) 商品属性テンプレートの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateInternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateInternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateInternationalModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemTemplateBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_template.template
インタフェース ItemTemplateBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface ItemTemplateBaseModel
extends BaseModel

商品属性テンプレートの基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | NOTES 備考
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CD 最終更新者
static String | TEMPLATE_CODE テンプレートコード
static String | TEMPLATE_NAME テンプレート名
メソッドの概要
String | getNotes() 備考を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCd() 最終更新者を取得します。
String | getTemplateCode() テンプレートコードを取得します。
String | getTemplateName() テンプレート名を取得します。
void | setNotes(String notes) 備考を設定します。
void | setTemplateName(String templateName) テンプレート名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

TEMPLATE_CODE

public static final String TEMPLATE_CODE
テンプレートコード

関連項目:
定数フィールド値

TEMPLATE_NAME

public static final String TEMPLATE_NAME
テンプレート名

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

RECORD_USER_CD

public static final String RECORD_USER_CD
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getTemplateCode

public String getTemplateCode()
                       throws AccessorException
テンプレートコードを取得します。

戻り値:
テンプレートコード
例外:
AccessorException - データの取得に失敗した場合

getTemplateName

public String getTemplateName()
                       throws AccessorException
テンプレート名を取得します。

戻り値:
テンプレート名
例外:
AccessorException - データの取得に失敗した場合

setTemplateName

public void setTemplateName(String templateName)
                     throws AccessorException
テンプレート名を設定します。

パラメータ:
templateName - テンプレート名
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCd

public String getRecordUserCd()
                       throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemTemplateInternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_template.template
インタフェース ItemTemplateInternationalModel

すべてのスーパーインタフェース:
InternationalModel, Serializable
public interface ItemTemplateInternationalModel
extends InternationalModel

商品属性テンプレートの国際化モデルです。

導入されたバージョン:
5.1

メソッドの概要
String | getTemplateName() テンプレート名を取得します。
void | setTemplateName(String templateName) テンプレート名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModel から継承したメソッド
getExtendedInternationalModelMap, getLocale, init

メソッドの詳細

getTemplateName

public String getTemplateName()
                       throws AccessorException
テンプレート名を取得します。

戻り値:
テンプレート名
例外:
AccessorException - データの取得に失敗した場合

setTemplateName

public void setTemplateName(String templateName)
                     throws AccessorException
テンプレート名を設定します。

パラメータ:
templateName - テンプレート名
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ItemTemplateMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_template.template
インタフェース ItemTemplateMapper

すべてのスーパーインタフェース:
Mapper
public interface ItemTemplateMapper
extends Mapper

商品属性テンプレートに関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
ItemTemplateBaseModel | create(String templateCode) プライマリキーに該当する商品属性テンプレートを生成します。
void | delete(Collection models) 商品属性テンプレートの基本モデルを複数削除します。
void | delete(ItemTemplateBaseModel model) 商品属性テンプレートの基本モデルを1つだけ削除します。
void | insert(Collection models) 商品属性テンプレートの基本モデルを複数挿入します。
void | insert(ItemTemplateBaseModel model) 商品属性テンプレートの基本モデルを1つだけ挿入します。
ItemTemplateBaseModel | select(String templateCode) プライマリーキーで特定される商品属性テンプレートの基本モデルを取得します。
void | update(Collection models) 商品属性テンプレートの基本モデルを複数更新します。
void | update(ItemTemplateBaseModel model) 商品属性テンプレートの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public ItemTemplateBaseModel create(String templateCode)
                             throws MapperException
プライマリキーに該当する商品属性テンプレートを生成します。

パラメータ:
templateCode - テンプレートコード
戻り値:
プライマリキーに該当する商品属性テンプレートの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public ItemTemplateBaseModel select(String templateCode)
                             throws MapperException
プライマリーキーで特定される商品属性テンプレートの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
templateCode - テンプレートコード
戻り値:
商品属性テンプレートの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(ItemTemplateBaseModel model)
            throws MapperException
商品属性テンプレートの基本モデルを1つだけ挿入します。 引数に指定する商品属性テンプレートの基本モデルは同一の ItemTemplateMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入する商品属性テンプレートの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
商品属性テンプレートの基本モデルを複数挿入します。 引数に指定するものは同一の ItemTemplateMapperの create(String) で生成された商品属性テンプレートの基本モデルの集合である必要があります。

パラメータ:
models - 挿入する商品属性テンプレートの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(ItemTemplateBaseModel model)
            throws MapperException
商品属性テンプレートの基本モデルを1つだけ更新します。 引数に指定する商品属性テンプレートの基本モデルは同一の ItemTemplateMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する商品属性テンプレートの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
商品属性テンプレートの基本モデルを複数更新します。 引数に指定するものは同一の ItemTemplateMapperの select 系メソッド から取得されたものかで生成された商品属性テンプレートの基本モデルの集合である必要があります。

パラメータ:
models - 更新する商品属性テンプレートの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(ItemTemplateBaseModel model)
            throws MapperException
商品属性テンプレートの基本モデルを1つだけ削除します。 引数で指定された商品属性テンプレートの基本モデルに該当するデータのすべての情報を削除します。引数に指定する商品属性テンプレートの基本モデルは同一の ItemTemplateMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する商品属性テンプレートの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
商品属性テンプレートの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する商品属性テンプレートの基本モデルは同一の ItemTemplateMapperの select 系メソッド から取得された商品属性テンプレートの基本モデルの集合である必要があります。

パラメータ:
models - 削除する商品属性テンプレートの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.item_template.template (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.item_template.template
インタフェース
ItemTemplateBaseModel
ItemTemplateInternationalModel
ItemTemplateMapper


jp.co.intra_mart.foundation.datastore.application.model.item_template.template (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_template.template

商品テンプレート情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
ItemTemplateBaseModel | 商品属性テンプレートの基本モデルです。
ItemTemplateInternationalModel | 商品属性テンプレートの国際化モデルです。
ItemTemplateMapper | 商品属性テンプレートに関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_template.template の説明

商品テンプレート情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.item_template.template クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_template.template の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateInternationalModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_template.template の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_template.template の使用

jp.co.intra_mart.foundation.datastore.application.model.item_template.template を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_template.template 商品テンプレート情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item_template.template により使用される jp.co.intra_mart.foundation.datastore.application.model.item_template.template のクラス
ItemTemplateBaseModel
商品属性テンプレートの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の使用

PrivateGroupAttachBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach プライベートグループ所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach での PrivateGroupAttachBaseModel の使用

PrivateGroupAttachBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.private_group.attach のメソッド
PrivateGroupAttachBaseModel | PrivateGroupAttachMapper.create(String ownerCode, String privateGroupCode, String userCode) プライマリキーに該当するプライベートグループ所属を生成します。
PrivateGroupAttachBaseModel | PrivateGroupAttachMapper.select(String ownerCode, String privateGroupCode, String userCode) プライマリーキーで特定されるプライベートグループ所属の基本モデルを取得します。

PrivateGroupAttachBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.private_group.attach のメソッド
void | PrivateGroupAttachMapper.insert(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ挿入します。
void | PrivateGroupAttachMapper.update(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ更新します。
void | PrivateGroupAttachMapper.delete(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.private_group.attach (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.private_group.attach
インタフェース
PrivateGroupAttachBaseModel
PrivateGroupAttachMapper


jp.co.intra_mart.foundation.datastore.application.model.private_group.attach (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.private_group.attach

プライベートグループ所属情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
PrivateGroupAttachBaseModel | プライベートグループ所属の基本モデルです。
PrivateGroupAttachMapper | プライベートグループ所属に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.private_group.attach の説明

プライベートグループ所属情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.private_group.attach クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.private_group.attach の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.private_group.attach の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach の使用

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach プライベートグループ所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach により使用される jp.co.intra_mart.foundation.datastore.application.model.private_group.attach のクラス
PrivateGroupAttachBaseModel
プライベートグループ所属の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PrivateGroupAttachBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach
インタフェース PrivateGroupAttachBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface PrivateGroupAttachBaseModel
extends BaseModel

プライベートグループ所属の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | OWNER_CODE 所有者コード
static String | PRIVATE_GROUP_CODE グループコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
static String | USER_CODE ユーザコード
メソッドの概要
String | getOwnerCode() 所有者コードを取得します。
String | getPrivateGroupCode() グループコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
String | getUserCode() ユーザコードを取得します。
void | setSortKey(int sortKey) ソートキーを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

OWNER_CODE

public static final String OWNER_CODE
所有者コード

関連項目:
定数フィールド値

PRIVATE_GROUP_CODE

public static final String PRIVATE_GROUP_CODE
グループコード

関連項目:
定数フィールド値

USER_CODE

public static final String USER_CODE
ユーザコード

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getOwnerCode

public String getOwnerCode()
                    throws AccessorException
所有者コードを取得します。

戻り値:
所有者コード
例外:
AccessorException - データの取得に失敗した場合

getPrivateGroupCode

public String getPrivateGroupCode()
                           throws AccessorException
グループコードを取得します。

戻り値:
グループコード
例外:
AccessorException - データの取得に失敗した場合

getUserCode

public String getUserCode()
                   throws AccessorException
ユーザコードを取得します。

戻り値:
ユーザコード
例外:
AccessorException - データの取得に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PrivateGroupAttachMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach
インタフェース PrivateGroupAttachMapper

すべてのスーパーインタフェース:
Mapper
public interface PrivateGroupAttachMapper
extends Mapper

プライベートグループ所属に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
PrivateGroupAttachBaseModel | create(String ownerCode, String privateGroupCode, String userCode) プライマリキーに該当するプライベートグループ所属を生成します。
void | delete(Collection models) プライベートグループ所属の基本モデルを複数削除します。
void | delete(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ削除します。
void | insert(Collection models) プライベートグループ所属の基本モデルを複数挿入します。
void | insert(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ挿入します。
PrivateGroupAttachBaseModel | select(String ownerCode, String privateGroupCode, String userCode) プライマリーキーで特定されるプライベートグループ所属の基本モデルを取得します。
void | update(Collection models) プライベートグループ所属の基本モデルを複数更新します。
void | update(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public PrivateGroupAttachBaseModel create(String ownerCode,
                                          String privateGroupCode,
                                          String userCode)
                                   throws MapperException
プライマリキーに該当するプライベートグループ所属を生成します。

パラメータ:
ownerCode - 所有者コード
privateGroupCode - グループコード
userCode - ユーザコード
戻り値:
プライマリキーに該当するプライベートグループ所属の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public PrivateGroupAttachBaseModel select(String ownerCode,
                                          String privateGroupCode,
                                          String userCode)
                                   throws MapperException
プライマリーキーで特定されるプライベートグループ所属の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
ownerCode - 所有者コード
privateGroupCode - グループコード
userCode - ユーザコード
戻り値:
プライベートグループ所属の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(PrivateGroupAttachBaseModel model)
            throws MapperException
プライベートグループ所属の基本モデルを1つだけ挿入します。 引数に指定するプライベートグループ所属の基本モデルは同一の PrivateGroupAttachMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するプライベートグループ所属の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
プライベートグループ所属の基本モデルを複数挿入します。 引数に指定するものは同一の PrivateGroupAttachMapperの create(String,String,String) で生成されたプライベートグループ所属の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するプライベートグループ所属の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(PrivateGroupAttachBaseModel model)
            throws MapperException
プライベートグループ所属の基本モデルを1つだけ更新します。 引数に指定するプライベートグループ所属の基本モデルは同一の PrivateGroupAttachMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するプライベートグループ所属の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
プライベートグループ所属の基本モデルを複数更新します。 引数に指定するものは同一の PrivateGroupAttachMapperの select 系メソッド から取得されたものかで生成されたプライベートグループ所属の基本モデルの集合である必要があります。

パラメータ:
models - 更新するプライベートグループ所属の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(PrivateGroupAttachBaseModel model)
            throws MapperException
プライベートグループ所属の基本モデルを1つだけ削除します。 引数で指定されたプライベートグループ所属の基本モデルに該当するデータのすべての情報を削除します。引数に指定するプライベートグループ所属の基本モデルは同一の PrivateGroupAttachMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するプライベートグループ所属の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
プライベートグループ所属の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するプライベートグループ所属の基本モデルは同一の PrivateGroupAttachMapperの select 系メソッド から取得されたプライベートグループ所属の基本モデルの集合である必要があります。

パラメータ:
models - 削除するプライベートグループ所属の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の使用

PrivateGroupBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.private_group.group プライベートグループ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.private_group.group での PrivateGroupBaseModel の使用

PrivateGroupBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.private_group.group のメソッド
PrivateGroupBaseModel | PrivateGroupMapper.create(String ownerCode, String privateGroupCode) プライマリキーに該当するプライベートグループを生成します。
PrivateGroupBaseModel | PrivateGroupMapper.select(String ownerCode, String privateGroupCode) プライマリーキーで特定されるプライベートグループの基本モデルを取得します。

PrivateGroupBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.private_group.group のメソッド
void | PrivateGroupMapper.insert(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ挿入します。
void | PrivateGroupMapper.update(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ更新します。
void | PrivateGroupMapper.delete(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.private_group.group (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.private_group.group
インタフェース
PrivateGroupBaseModel
PrivateGroupMapper


jp.co.intra_mart.foundation.datastore.application.model.private_group.group (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.private_group.group

プライベートグループ情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
PrivateGroupBaseModel | プライベートグループの基本モデルです。
PrivateGroupMapper | プライベートグループに関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.private_group.group の説明

プライベートグループ情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.private_group.group クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.private_group.group の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.private_group.group の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.private_group.group の使用

jp.co.intra_mart.foundation.datastore.application.model.private_group.group を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.private_group.group プライベートグループ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.private_group.group により使用される jp.co.intra_mart.foundation.datastore.application.model.private_group.group のクラス
PrivateGroupBaseModel
プライベートグループの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PrivateGroupBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.private_group.group
インタフェース PrivateGroupBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface PrivateGroupBaseModel
extends BaseModel

プライベートグループの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | NAME グループ名
static String | NAME_ENGLISH グループ名英字
static String | NAME_SYLLABARY グループ名カナ
static String | NOTES 備考
static String | OWNER_CODE 所有者コード
static String | PRIVATE_GROUP_CODE グループコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
メソッドの概要
String | getName() グループ名を取得します。
String | getNameEnglish() グループ名英字を取得します。
String | getNameSyllabary() グループ名カナを取得します。
String | getNotes() 備考を取得します。
String | getOwnerCode() 所有者コードを取得します。
String | getPrivateGroupCode() グループコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
void | setName(String name) グループ名を設定します。
void | setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

OWNER_CODE

public static final String OWNER_CODE
所有者コード

関連項目:
定数フィールド値

PRIVATE_GROUP_CODE

public static final String PRIVATE_GROUP_CODE
グループコード

関連項目:
定数フィールド値

NAME

public static final String NAME
グループ名

関連項目:
定数フィールド値

NAME_SYLLABARY

public static final String NAME_SYLLABARY
グループ名カナ

関連項目:
定数フィールド値

NAME_ENGLISH

public static final String NAME_ENGLISH
グループ名英字

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getOwnerCode

public String getOwnerCode()
                    throws AccessorException
所有者コードを取得します。

戻り値:
所有者コード
例外:
AccessorException - データの取得に失敗した場合

getPrivateGroupCode

public String getPrivateGroupCode()
                           throws AccessorException
グループコードを取得します。

戻り値:
グループコード
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName()
               throws AccessorException
グループ名を取得します。

戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
グループ名を設定します。

パラメータ:
name - グループ名
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
グループ名カナを取得します。

戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
グループ名英字を取得します。

戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PrivateGroupMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.private_group.group
インタフェース PrivateGroupMapper

すべてのスーパーインタフェース:
Mapper
public interface PrivateGroupMapper
extends Mapper

プライベートグループに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
PrivateGroupBaseModel | create(String ownerCode, String privateGroupCode) プライマリキーに該当するプライベートグループを生成します。
void | delete(Collection models) プライベートグループの基本モデルを複数削除します。
void | delete(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ削除します。
void | insert(Collection models) プライベートグループの基本モデルを複数挿入します。
void | insert(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ挿入します。
PrivateGroupBaseModel | select(String ownerCode, String privateGroupCode) プライマリーキーで特定されるプライベートグループの基本モデルを取得します。
void | update(Collection models) プライベートグループの基本モデルを複数更新します。
void | update(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public PrivateGroupBaseModel create(String ownerCode,
                                    String privateGroupCode)
                             throws MapperException
プライマリキーに該当するプライベートグループを生成します。

パラメータ:
ownerCode - 所有者コード
privateGroupCode - グループコード
戻り値:
プライマリキーに該当するプライベートグループの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public PrivateGroupBaseModel select(String ownerCode,
                                    String privateGroupCode)
                             throws MapperException
プライマリーキーで特定されるプライベートグループの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
ownerCode - 所有者コード
privateGroupCode - グループコード
戻り値:
プライベートグループの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(PrivateGroupBaseModel model)
            throws MapperException
プライベートグループの基本モデルを1つだけ挿入します。 引数に指定するプライベートグループの基本モデルは同一の PrivateGroupMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するプライベートグループの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
プライベートグループの基本モデルを複数挿入します。 引数に指定するものは同一の PrivateGroupMapperの create(String,String) で生成されたプライベートグループの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するプライベートグループの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(PrivateGroupBaseModel model)
            throws MapperException
プライベートグループの基本モデルを1つだけ更新します。 引数に指定するプライベートグループの基本モデルは同一の PrivateGroupMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するプライベートグループの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
プライベートグループの基本モデルを複数更新します。 引数に指定するものは同一の PrivateGroupMapperの select 系メソッド から取得されたものかで生成されたプライベートグループの基本モデルの集合である必要があります。

パラメータ:
models - 更新するプライベートグループの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(PrivateGroupBaseModel model)
            throws MapperException
プライベートグループの基本モデルを1つだけ削除します。 引数で指定されたプライベートグループの基本モデルに該当するデータのすべての情報を削除します。引数に指定するプライベートグループの基本モデルは同一の PrivateGroupMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するプライベートグループの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
プライベートグループの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するプライベートグループの基本モデルは同一の PrivateGroupMapperの select 系メソッド から取得されたプライベートグループの基本モデルの集合である必要があります。

パラメータ:
models - 削除するプライベートグループの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の使用

PublicGroupAttachBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach パブリックグループ所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での PublicGroupAttachBaseModel の使用

PublicGroupAttachBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.public_group.attach のメソッド
PublicGroupAttachBaseModel | PublicGroupAttachMapper.create(String userCode, String publicGroupSetCode, String publicGroupCode) プライマリキーに該当するパブリックグループ所属を生成します。
PublicGroupAttachBaseModel | PublicGroupAttachMapper.select(String userCode, String publicGroupSetCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループ所属の基本モデルを取得します。

PublicGroupAttachBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.public_group.attach のメソッド
void | PublicGroupAttachMapper.insert(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ挿入します。
void | PublicGroupAttachMapper.update(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ更新します。
void | PublicGroupAttachMapper.delete(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachTerminableModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachTerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachTerminableModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.public_group.attach (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.public_group.attach
インタフェース
PublicGroupAttachBaseModel
PublicGroupAttachMapper
PublicGroupAttachTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.public_group.attach (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.attach

パブリックグループ所属情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
PublicGroupAttachBaseModel | パブリックグループ所属の基本モデルです。
PublicGroupAttachMapper | パブリックグループ所属に関連するマッパです。
PublicGroupAttachTerminableModel | パブリックグループ所属の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.attach の説明

パブリックグループ所属情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.public_group.attach クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.attach の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachTerminableModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.attach の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach パブリックグループ所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach により使用される jp.co.intra_mart.foundation.datastore.application.model.public_group.attach のクラス
PublicGroupAttachBaseModel
パブリックグループ所属の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupAttachBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach
インタフェース PublicGroupAttachBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface PublicGroupAttachBaseModel
extends BaseModel

パブリックグループ所属の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | PUBLIC_GROUP_CODE グループコード
static String | PUBLIC_GROUP_SET_CODE グループセットコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
static String | USER_CODE ユーザコード
メソッドの概要
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
String | getUserCode() ユーザコードを取得します。
void | setSortKey(int sortKey) ソートキーを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

USER_CODE

public static final String USER_CODE
ユーザコード

関連項目:
定数フィールド値

PUBLIC_GROUP_SET_CODE

public static final String PUBLIC_GROUP_SET_CODE
グループセットコード

関連項目:
定数フィールド値

PUBLIC_GROUP_CODE

public static final String PUBLIC_GROUP_CODE
グループコード

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getUserCode

public String getUserCode()
                   throws AccessorException
ユーザコードを取得します。

戻り値:
ユーザコード
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupSetCode

public String getPublicGroupSetCode()
                             throws AccessorException
グループセットコードを取得します。

戻り値:
グループセットコード
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupCode

public String getPublicGroupCode()
                          throws AccessorException
グループコードを取得します。

戻り値:
グループコード
例外:
AccessorException - データの取得に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupAttachMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach
インタフェース PublicGroupAttachMapper

すべてのスーパーインタフェース:
Mapper
public interface PublicGroupAttachMapper
extends Mapper

パブリックグループ所属に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
PublicGroupAttachBaseModel | create(String userCode, String publicGroupSetCode, String publicGroupCode) プライマリキーに該当するパブリックグループ所属を生成します。
void | delete(Collection models) パブリックグループ所属の基本モデルを複数削除します。
void | delete(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ削除します。
void | insert(Collection models) パブリックグループ所属の基本モデルを複数挿入します。
void | insert(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ挿入します。
PublicGroupAttachBaseModel | select(String userCode, String publicGroupSetCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループ所属の基本モデルを取得します。
void | update(Collection models) パブリックグループ所属の基本モデルを複数更新します。
void | update(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public PublicGroupAttachBaseModel create(String userCode,
                                         String publicGroupSetCode,
                                         String publicGroupCode)
                                  throws MapperException
プライマリキーに該当するパブリックグループ所属を生成します。

パラメータ:
userCode - ユーザコード
publicGroupSetCode - グループセットコード
publicGroupCode - グループコード
戻り値:
プライマリキーに該当するパブリックグループ所属の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public PublicGroupAttachBaseModel select(String userCode,
                                         String publicGroupSetCode,
                                         String publicGroupCode)
                                  throws MapperException
プライマリーキーで特定されるパブリックグループ所属の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
userCode - ユーザコード
publicGroupSetCode - グループセットコード
publicGroupCode - グループコード
戻り値:
パブリックグループ所属の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(PublicGroupAttachBaseModel model)
            throws MapperException
パブリックグループ所属の基本モデルを1つだけ挿入します。 引数に指定するパブリックグループ所属の基本モデルは同一の PublicGroupAttachMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するパブリックグループ所属の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
パブリックグループ所属の基本モデルを複数挿入します。 引数に指定するものは同一の PublicGroupAttachMapperの create(String,String,String) で生成されたパブリックグループ所属の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するパブリックグループ所属の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(PublicGroupAttachBaseModel model)
            throws MapperException
パブリックグループ所属の基本モデルを1つだけ更新します。 引数に指定するパブリックグループ所属の基本モデルは同一の PublicGroupAttachMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するパブリックグループ所属の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
パブリックグループ所属の基本モデルを複数更新します。 引数に指定するものは同一の PublicGroupAttachMapperの select 系メソッド から取得されたものかで生成されたパブリックグループ所属の基本モデルの集合である必要があります。

パラメータ:
models - 更新するパブリックグループ所属の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(PublicGroupAttachBaseModel model)
            throws MapperException
パブリックグループ所属の基本モデルを1つだけ削除します。 引数で指定されたパブリックグループ所属の基本モデルに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ所属の基本モデルは同一の PublicGroupAttachMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するパブリックグループ所属の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
パブリックグループ所属の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ所属の基本モデルは同一の PublicGroupAttachMapperの select 系メソッド から取得されたパブリックグループ所属の基本モデルの集合である必要があります。

パラメータ:
models - 削除するパブリックグループ所属の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PublicGroupAttachTerminableModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach
インタフェース PublicGroupAttachTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface PublicGroupAttachTerminableModel
extends TerminableModel

パブリックグループ所属の期間化モデルです。

導入されたバージョン:
5.0

インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の使用

PublicGroupCategoryBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.category パブリックグループ分類情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での PublicGroupCategoryBaseModel の使用

PublicGroupCategoryBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.public_group.category のメソッド
PublicGroupCategoryBaseModel | PublicGroupCategoryMapper.create(String publicGroupSetCode, String publicGroupCode, String categoryClassCode, String categoryCode) プライマリキーに該当するパブリックグループ分類を生成します。
PublicGroupCategoryBaseModel | PublicGroupCategoryMapper.select(String publicGroupSetCode, String publicGroupCode, String categoryClassCode, String categoryCode) プライマリーキーで特定されるパブリックグループ分類の基本モデルを取得します。

PublicGroupCategoryBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.public_group.category のメソッド
void | PublicGroupCategoryMapper.insert(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ挿入します。
void | PublicGroupCategoryMapper.update(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ更新します。
void | PublicGroupCategoryMapper.delete(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryTerminableModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryTerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryTerminableModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.public_group.category (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.public_group.category
インタフェース
PublicGroupCategoryBaseModel
PublicGroupCategoryMapper
PublicGroupCategoryTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.public_group.category (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.category

パブリックグループ分類情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
PublicGroupCategoryBaseModel | パブリックグループ分類の基本モデルです。
PublicGroupCategoryMapper | パブリックグループ分類に関連するマッパです。
PublicGroupCategoryTerminableModel | パブリックグループ分類の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.category の説明

パブリックグループ分類情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.public_group.category クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.category の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryTerminableModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.category の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.category の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.category を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.category パブリックグループ分類情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category により使用される jp.co.intra_mart.foundation.datastore.application.model.public_group.category のクラス
PublicGroupCategoryBaseModel
パブリックグループ分類の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupCategoryBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.category
インタフェース PublicGroupCategoryBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface PublicGroupCategoryBaseModel
extends BaseModel

パブリックグループ分類の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | CATEGORY_CLASS_CODE 分類区分コード
static String | CATEGORY_CODE 分類コード
static String | PUBLIC_GROUP_CODE グループコード
static String | PUBLIC_GROUP_SET_CODE グループセットコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getCategoryClassCode() 分類区分コードを取得します。
String | getCategoryCode() 分類コードを取得します。
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

PUBLIC_GROUP_SET_CODE

public static final String PUBLIC_GROUP_SET_CODE
グループセットコード

関連項目:
定数フィールド値

PUBLIC_GROUP_CODE

public static final String PUBLIC_GROUP_CODE
グループコード

関連項目:
定数フィールド値

CATEGORY_CLASS_CODE

public static final String CATEGORY_CLASS_CODE
分類区分コード

関連項目:
定数フィールド値

CATEGORY_CODE

public static final String CATEGORY_CODE
分類コード

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getPublicGroupSetCode

public String getPublicGroupSetCode()
                             throws AccessorException
グループセットコードを取得します。

戻り値:
グループセットコード
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupCode

public String getPublicGroupCode()
                          throws AccessorException
グループコードを取得します。

戻り値:
グループコード
例外:
AccessorException - データの取得に失敗した場合

getCategoryClassCode

public String getCategoryClassCode()
                            throws AccessorException
分類区分コードを取得します。

戻り値:
分類区分コード
例外:
AccessorException - データの取得に失敗した場合

getCategoryCode

public String getCategoryCode()
                       throws AccessorException
分類コードを取得します。

戻り値:
分類コード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupCategoryMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.category
インタフェース PublicGroupCategoryMapper

すべてのスーパーインタフェース:
Mapper
public interface PublicGroupCategoryMapper
extends Mapper

パブリックグループ分類に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
PublicGroupCategoryBaseModel | create(String publicGroupSetCode, String publicGroupCode, String categoryClassCode, String categoryCode) プライマリキーに該当するパブリックグループ分類を生成します。
void | delete(Collection models) パブリックグループ分類の基本モデルを複数削除します。
void | delete(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ削除します。
void | insert(Collection models) パブリックグループ分類の基本モデルを複数挿入します。
void | insert(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ挿入します。
PublicGroupCategoryBaseModel | select(String publicGroupSetCode, String publicGroupCode, String categoryClassCode, String categoryCode) プライマリーキーで特定されるパブリックグループ分類の基本モデルを取得します。
void | update(Collection models) パブリックグループ分類の基本モデルを複数更新します。
void | update(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public PublicGroupCategoryBaseModel create(String publicGroupSetCode,
                                           String publicGroupCode,
                                           String categoryClassCode,
                                           String categoryCode)
                                    throws MapperException
プライマリキーに該当するパブリックグループ分類を生成します。

パラメータ:
publicGroupSetCode - グループセットコード
publicGroupCode - グループコード
categoryClassCode - 分類区分コード
categoryCode - 分類コード
戻り値:
プライマリキーに該当するパブリックグループ分類の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public PublicGroupCategoryBaseModel select(String publicGroupSetCode,
                                           String publicGroupCode,
                                           String categoryClassCode,
                                           String categoryCode)
                                    throws MapperException
プライマリーキーで特定されるパブリックグループ分類の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
publicGroupSetCode - グループセットコード
publicGroupCode - グループコード
categoryClassCode - 分類区分コード
categoryCode - 分類コード
戻り値:
パブリックグループ分類の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(PublicGroupCategoryBaseModel model)
            throws MapperException
パブリックグループ分類の基本モデルを1つだけ挿入します。 引数に指定するパブリックグループ分類の基本モデルは同一の PublicGroupCategoryMapperの create(String,String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するパブリックグループ分類の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
パブリックグループ分類の基本モデルを複数挿入します。 引数に指定するものは同一の PublicGroupCategoryMapperの create(String,String,String,String) で生成されたパブリックグループ分類の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するパブリックグループ分類の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(PublicGroupCategoryBaseModel model)
            throws MapperException
パブリックグループ分類の基本モデルを1つだけ更新します。 引数に指定するパブリックグループ分類の基本モデルは同一の PublicGroupCategoryMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するパブリックグループ分類の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
パブリックグループ分類の基本モデルを複数更新します。 引数に指定するものは同一の PublicGroupCategoryMapperの select 系メソッド から取得されたものかで生成されたパブリックグループ分類の基本モデルの集合である必要があります。

パラメータ:
models - 更新するパブリックグループ分類の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(PublicGroupCategoryBaseModel model)
            throws MapperException
パブリックグループ分類の基本モデルを1つだけ削除します。 引数で指定されたパブリックグループ分類の基本モデルに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ分類の基本モデルは同一の PublicGroupCategoryMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するパブリックグループ分類の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
パブリックグループ分類の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ分類の基本モデルは同一の PublicGroupCategoryMapperの select 系メソッド から取得されたパブリックグループ分類の基本モデルの集合である必要があります。

パラメータ:
models - 削除するパブリックグループ分類の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PublicGroupCategoryTerminableModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.category
インタフェース PublicGroupCategoryTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface PublicGroupCategoryTerminableModel
extends TerminableModel

パブリックグループ分類の期間化モデルです。

導入されたバージョン:
5.0

インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の使用

PublicGroupBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.group パブリックグループ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での PublicGroupBaseModel の使用

PublicGroupBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.public_group.group のメソッド
PublicGroupBaseModel | PublicGroupMapper.create(String publicGroupSetCode, String publicGroupCode) プライマリキーに該当するパブリックグループを生成します。
PublicGroupBaseModel | PublicGroupMapper.select(String publicGroupSetCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループの基本モデルを取得します。

PublicGroupBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.public_group.group のメソッド
void | PublicGroupMapper.insert(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ挿入します。
void | PublicGroupMapper.update(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ更新します。
void | PublicGroupMapper.delete(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel の使用

PublicGroupTerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.group パブリックグループ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での PublicGroupTerminableInternationalModel の使用

PublicGroupTerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.public_group.group のメソッド
 PublicGroupTerminableInternationalModel PublicGroupTerminableModel.selectPublicGroupTerminableInternationalModel(Locale locale)
指定された言語に該当するパブリックグループの期間国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel の使用

PublicGroupTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.group パブリックグループ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での PublicGroupTerminableModel の使用

PublicGroupTerminableModel を返す jp.co.intra_mart.foundation.datastore.application.model.public_group.group のメソッド
 PublicGroupTerminableModel PublicGroupBaseModel.selectPublicGroupTerminableModel(Date date)
指定された日付に該当するパブリックグループの期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.public_group.group (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.public_group.group
インタフェース
PublicGroupBaseModel
PublicGroupMapper
PublicGroupTerminableInternationalModel
PublicGroupTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.public_group.group (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.group

パブリックグループ情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
PublicGroupBaseModel | パブリックグループの基本モデルです。
PublicGroupMapper | パブリックグループに関連するマッパです。
PublicGroupTerminableInternationalModel | パブリックグループの期間国際化モデルです。
PublicGroupTerminableModel | パブリックグループの期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.group の説明

パブリックグループ情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.public_group.group クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.group の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.group の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.group の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.group を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.group パブリックグループ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group により使用される jp.co.intra_mart.foundation.datastore.application.model.public_group.group のクラス
PublicGroupBaseModel
パブリックグループの基本モデルです。
PublicGroupTerminableInternationalModel
パブリックグループの期間国際化モデルです。
PublicGroupTerminableModel
パブリックグループの期間化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.group
インタフェース PublicGroupBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface PublicGroupBaseModel
extends BaseModel

パブリックグループの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | NAME グループ名
static String | NAME_ENGLISH グループ名英字
static String | NAME_SYLLABARY グループ名カナ
static String | NOTES 備考
static String | PUBLIC_GROUP_CODE グループコード
static String | PUBLIC_GROUP_SET_CODE グループセットコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
メソッドの概要
String | getName() グループ名を取得します。
String | getName(Date date) グループ名を取得します。
String | getName(Date date, Locale locale) グループ名を取得します。
String | getName(Locale locale) グループ名を取得します。
String | getNameEnglish() グループ名英字を取得します。
String | getNameEnglish(Date date) グループ名英字を取得します。
String | getNameEnglish(Date date, Locale locale) グループ名英字を取得します。
String | getNameEnglish(Locale locale) グループ名英字を取得します。
String | getNameSyllabary() グループ名カナを取得します。
String | getNameSyllabary(Date date) グループ名カナを取得します。
String | getNameSyllabary(Date date, Locale locale) グループ名カナを取得します。
String | getNameSyllabary(Locale locale) グループ名カナを取得します。
String | getNotes() 備考を取得します。
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
PublicGroupTerminableModel | selectPublicGroupTerminableModel(Date date) 指定された日付に該当するパブリックグループの期間化モデルを取得します。
void | setName(String name) グループ名を設定します。
void | setName(String name, Date date) グループ名を設定します。
void | setName(String name, Date date, Locale locale) グループ名を設定します。
void | setName(String name, Locale locale) グループ名を設定します。
void | setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | setNameEnglish(String nameEnglish, Date date) グループ名英字を設定します。
void | setNameEnglish(String nameEnglish, Date date, Locale locale) グループ名英字を設定します。
void | setNameEnglish(String nameEnglish, Locale locale) グループ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Date date) グループ名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Date date, Locale locale) グループ名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Locale locale) グループ名カナを設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

PUBLIC_GROUP_SET_CODE

public static final String PUBLIC_GROUP_SET_CODE
グループセットコード

関連項目:
定数フィールド値

PUBLIC_GROUP_CODE

public static final String PUBLIC_GROUP_CODE
グループコード

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

NAME

public static final String NAME
グループ名

関連項目:
定数フィールド値

NAME_SYLLABARY

public static final String NAME_SYLLABARY
グループ名カナ

関連項目:
定数フィールド値

NAME_ENGLISH

public static final String NAME_ENGLISH
グループ名英字

関連項目:
定数フィールド値
メソッドの詳細

getPublicGroupSetCode

public String getPublicGroupSetCode()
                             throws AccessorException
グループセットコードを取得します。

戻り値:
グループセットコード
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupCode

public String getPublicGroupCode()
                          throws AccessorException
グループコードを取得します。

戻り値:
グループコード
例外:
AccessorException - データの取得に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName()
               throws AccessorException
グループ名を取得します。

戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Date date)
               throws AccessorException
グループ名を取得します。

パラメータ:
date - 日時
戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
グループ名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Date date,
                      Locale locale)
               throws AccessorException
グループ名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
グループ名を設定します。

パラメータ:
name - グループ名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Date date)
             throws AccessorException
グループ名を設定します。

パラメータ:
name - グループ名
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
グループ名を設定します。

パラメータ:
name - グループ名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Date date,
                    Locale locale)
             throws AccessorException
グループ名を設定します。

パラメータ:
name - グループ名
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
グループ名カナを取得します。

戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Date date)
                        throws AccessorException
グループ名カナを取得します。

パラメータ:
date - 日時
戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Locale locale)
                        throws AccessorException
グループ名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Date date,
                               Locale locale)
                        throws AccessorException
グループ名カナを取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Date date)
                      throws AccessorException
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Locale locale)
                      throws AccessorException
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Date date,
                             Locale locale)
                      throws AccessorException
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
グループ名英字を取得します。

戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Date date)
                      throws AccessorException
グループ名英字を取得します。

パラメータ:
date - 日時
戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Locale locale)
                      throws AccessorException
グループ名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Date date,
                             Locale locale)
                      throws AccessorException
グループ名英字を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Date date)
                    throws AccessorException
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Locale locale)
                    throws AccessorException
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Date date,
                           Locale locale)
                    throws AccessorException
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectPublicGroupTerminableModel

public PublicGroupTerminableModel selectPublicGroupTerminableModel(Date date)
                                                            throws IllegalTermException
指定された日付に該当するパブリックグループの期間化モデルを取得します。

パラメータ:
date - 指定日付
戻り値:
パブリックグループの期間化モデル
例外:
IllegalTermException - 指定された日付に該当する期間が定義されていない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.group
インタフェース PublicGroupMapper

すべてのスーパーインタフェース:
Mapper
public interface PublicGroupMapper
extends Mapper

パブリックグループに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
PublicGroupBaseModel | create(String publicGroupSetCode, String publicGroupCode) プライマリキーに該当するパブリックグループを生成します。
void | delete(Collection models) パブリックグループの基本モデルを複数削除します。
void | delete(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ削除します。
void | insert(Collection models) パブリックグループの基本モデルを複数挿入します。
void | insert(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ挿入します。
PublicGroupBaseModel | select(String publicGroupSetCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループの基本モデルを取得します。
void | update(Collection models) パブリックグループの基本モデルを複数更新します。
void | update(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public PublicGroupBaseModel create(String publicGroupSetCode,
                                   String publicGroupCode)
                            throws MapperException
プライマリキーに該当するパブリックグループを生成します。

パラメータ:
publicGroupSetCode - グループセットコード
publicGroupCode - グループコード
戻り値:
プライマリキーに該当するパブリックグループの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public PublicGroupBaseModel select(String publicGroupSetCode,
                                   String publicGroupCode)
                            throws MapperException
プライマリーキーで特定されるパブリックグループの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
publicGroupSetCode - グループセットコード
publicGroupCode - グループコード
戻り値:
パブリックグループの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(PublicGroupBaseModel model)
            throws MapperException
パブリックグループの基本モデルを1つだけ挿入します。 引数に指定するパブリックグループの基本モデルは同一の PublicGroupMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するパブリックグループの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
パブリックグループの基本モデルを複数挿入します。 引数に指定するものは同一の PublicGroupMapperの create(String,String) で生成されたパブリックグループの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するパブリックグループの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(PublicGroupBaseModel model)
            throws MapperException
パブリックグループの基本モデルを1つだけ更新します。 引数に指定するパブリックグループの基本モデルは同一の PublicGroupMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するパブリックグループの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
パブリックグループの基本モデルを複数更新します。 引数に指定するものは同一の PublicGroupMapperの select 系メソッド から取得されたものかで生成されたパブリックグループの基本モデルの集合である必要があります。

パラメータ:
models - 更新するパブリックグループの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(PublicGroupBaseModel model)
            throws MapperException
パブリックグループの基本モデルを1つだけ削除します。 引数で指定されたパブリックグループの基本モデルに該当するデータのすべての情報を削除します。引数に指定するパブリックグループの基本モデルは同一の PublicGroupMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するパブリックグループの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
パブリックグループの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するパブリックグループの基本モデルは同一の PublicGroupMapperの select 系メソッド から取得されたパブリックグループの基本モデルの集合である必要があります。

パラメータ:
models - 削除するパブリックグループの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PublicGroupTerminableInternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.group
インタフェース PublicGroupTerminableInternationalModel

すべてのスーパーインタフェース:
Serializable, TerminableInternationalModel
public interface PublicGroupTerminableInternationalModel
extends TerminableInternationalModel

パブリックグループの期間国際化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getName() グループ名を取得します。
String | getNameEnglish() グループ名英字を取得します。
String | getNameSyllabary() グループ名カナを取得します。
void | setName(String name) グループ名を設定します。
void | setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel から継承したメソッド
getExtendedTerminableInternationalModelMap, getLocale, init

メソッドの詳細

getName

public String getName()
               throws AccessorException
グループ名を取得します。

戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
グループ名を設定します。

パラメータ:
name - グループ名
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
グループ名カナを取得します。

戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
グループ名英字を取得します。

戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PublicGroupTerminableModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.group
インタフェース PublicGroupTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface PublicGroupTerminableModel
extends TerminableModel

パブリックグループの期間化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getName() グループ名を取得します。
String | getName(Locale locale) グループ名を取得します。
String | getNameEnglish() グループ名英字を取得します。
String | getNameEnglish(Locale locale) グループ名英字を取得します。
String | getNameSyllabary() グループ名カナを取得します。
String | getNameSyllabary(Locale locale) グループ名カナを取得します。
PublicGroupTerminableInternationalModel | selectPublicGroupTerminableInternationalModel(Locale locale) 指定された言語に該当するパブリックグループの期間国際化モデルを取得します。
void | setName(String name) グループ名を設定します。
void | setName(String name, Locale locale) グループ名を設定します。
void | setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | setNameEnglish(String nameEnglish, Locale locale) グループ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Locale locale) グループ名カナを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

メソッドの詳細

getName

public String getName()
               throws AccessorException
グループ名を取得します。

戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
グループ名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
グループ名を設定します。

パラメータ:
name - グループ名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
グループ名を設定します。

パラメータ:
name - グループ名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
グループ名カナを取得します。

戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Locale locale)
                        throws AccessorException
グループ名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Locale locale)
                      throws AccessorException
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
グループ名英字を取得します。

戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Locale locale)
                      throws AccessorException
グループ名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Locale locale)
                    throws AccessorException
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectPublicGroupTerminableInternationalModel

public PublicGroupTerminableInternationalModel selectPublicGroupTerminableInternationalModel(Locale locale)
                                                                                throws IllegalLocaleException
指定された言語に該当するパブリックグループの期間国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
パブリックグループの期間国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の使用

PublicGroupInclusionBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion パブリックグループ内包情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion での PublicGroupInclusionBaseModel の使用

PublicGroupInclusionBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion のメソッド
PublicGroupInclusionBaseModel | PublicGroupInclusionMapper.create(String publicGroupSetCode, String versionCode, String parentPublicGroupCode, String publicGroupCode) プライマリキーに該当するパブリックグループ内包を生成します。
PublicGroupInclusionBaseModel | PublicGroupInclusionMapper.select(String publicGroupSetCode, String versionCode, String parentPublicGroupCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループ内包の基本モデルを取得します。

PublicGroupInclusionBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion のメソッド
void | PublicGroupInclusionMapper.insert(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ挿入します。
void | PublicGroupInclusionMapper.update(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ更新します。
void | PublicGroupInclusionMapper.delete(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion
インタフェース
PublicGroupInclusionBaseModel
PublicGroupInclusionMapper


jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion

パブリックグループ内包情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
PublicGroupInclusionBaseModel | パブリックグループ内包の基本モデルです。
PublicGroupInclusionMapper | パブリックグループ内包に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion の説明

パブリックグループ内包情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion パブリックグループ内包情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion により使用される jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion のクラス
PublicGroupInclusionBaseModel
パブリックグループ内包の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupInclusionBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion
インタフェース PublicGroupInclusionBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface PublicGroupInclusionBaseModel
extends BaseModel

パブリックグループ内包の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | DEPTH 階層レベル
static String | PARENT_PUBLIC_GROUP_CODE 親グループコード
static String | PUBLIC_GROUP_CODE グループコード
static String | PUBLIC_GROUP_SET_CODE グループセットコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | VERSION_CODE バージョンコード
メソッドの概要
int | getDepth() 階層レベルを取得します。
String | getParentPublicGroupCode() 親グループコードを取得します。
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getVersionCode() バージョンコードを取得します。
void | setDepth(int depth) 階層レベルを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

PUBLIC_GROUP_SET_CODE

public static final String PUBLIC_GROUP_SET_CODE
グループセットコード

関連項目:
定数フィールド値

VERSION_CODE

public static final String VERSION_CODE
バージョンコード

関連項目:
定数フィールド値

PARENT_PUBLIC_GROUP_CODE

public static final String PARENT_PUBLIC_GROUP_CODE
親グループコード

関連項目:
定数フィールド値

PUBLIC_GROUP_CODE

public static final String PUBLIC_GROUP_CODE
グループコード

関連項目:
定数フィールド値

DEPTH

public static final String DEPTH
階層レベル

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getPublicGroupSetCode

public String getPublicGroupSetCode()
                             throws AccessorException
グループセットコードを取得します。

戻り値:
グループセットコード
例外:
AccessorException - データの取得に失敗した場合

getVersionCode

public String getVersionCode()
                      throws AccessorException
バージョンコードを取得します。

戻り値:
バージョンコード
例外:
AccessorException - データの取得に失敗した場合

getParentPublicGroupCode

public String getParentPublicGroupCode()
                                throws AccessorException
親グループコードを取得します。

戻り値:
親グループコード
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupCode

public String getPublicGroupCode()
                          throws AccessorException
グループコードを取得します。

戻り値:
グループコード
例外:
AccessorException - データの取得に失敗した場合

getDepth

public int getDepth()
             throws AccessorException
階層レベルを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
階層レベル
例外:
AccessorException - データの取得に失敗した場合

setDepth

public void setDepth(int depth)
              throws AccessorException
階層レベルを設定します。

パラメータ:
depth - 階層レベル
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupInclusionMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion
インタフェース PublicGroupInclusionMapper

すべてのスーパーインタフェース:
Mapper
public interface PublicGroupInclusionMapper
extends Mapper

パブリックグループ内包に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
PublicGroupInclusionBaseModel | create(String publicGroupSetCode, String versionCode, String parentPublicGroupCode, String publicGroupCode) プライマリキーに該当するパブリックグループ内包を生成します。
void | delete(Collection models) パブリックグループ内包の基本モデルを複数削除します。
void | delete(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ削除します。
void | insert(Collection models) パブリックグループ内包の基本モデルを複数挿入します。
void | insert(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ挿入します。
PublicGroupInclusionBaseModel | select(String publicGroupSetCode, String versionCode, String parentPublicGroupCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループ内包の基本モデルを取得します。
void | update(Collection models) パブリックグループ内包の基本モデルを複数更新します。
void | update(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public PublicGroupInclusionBaseModel create(String publicGroupSetCode,
                                            String versionCode,
                                            String parentPublicGroupCode,
                                            String publicGroupCode)
                                     throws MapperException
プライマリキーに該当するパブリックグループ内包を生成します。

パラメータ:
publicGroupSetCode - グループセットコード
versionCode - バージョンコード
parentPublicGroupCode - 親グループコード
publicGroupCode - グループコード
戻り値:
プライマリキーに該当するパブリックグループ内包の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public PublicGroupInclusionBaseModel select(String publicGroupSetCode,
                                            String versionCode,
                                            String parentPublicGroupCode,
                                            String publicGroupCode)
                                     throws MapperException
プライマリーキーで特定されるパブリックグループ内包の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
publicGroupSetCode - グループセットコード
versionCode - バージョンコード
parentPublicGroupCode - 親グループコード
publicGroupCode - グループコード
戻り値:
パブリックグループ内包の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(PublicGroupInclusionBaseModel model)
            throws MapperException
パブリックグループ内包の基本モデルを1つだけ挿入します。 引数に指定するパブリックグループ内包の基本モデルは同一の PublicGroupInclusionMapperの create(String,String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するパブリックグループ内包の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
パブリックグループ内包の基本モデルを複数挿入します。 引数に指定するものは同一の PublicGroupInclusionMapperの create(String,String,String,String) で生成されたパブリックグループ内包の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するパブリックグループ内包の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(PublicGroupInclusionBaseModel model)
            throws MapperException
パブリックグループ内包の基本モデルを1つだけ更新します。 引数に指定するパブリックグループ内包の基本モデルは同一の PublicGroupInclusionMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するパブリックグループ内包の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
パブリックグループ内包の基本モデルを複数更新します。 引数に指定するものは同一の PublicGroupInclusionMapperの select 系メソッド から取得されたものかで生成されたパブリックグループ内包の基本モデルの集合である必要があります。

パラメータ:
models - 更新するパブリックグループ内包の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(PublicGroupInclusionBaseModel model)
            throws MapperException
パブリックグループ内包の基本モデルを1つだけ削除します。 引数で指定されたパブリックグループ内包の基本モデルに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ内包の基本モデルは同一の PublicGroupInclusionMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するパブリックグループ内包の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
パブリックグループ内包の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ内包の基本モデルは同一の PublicGroupInclusionMapperの select 系メソッド から取得されたパブリックグループ内包の基本モデルの集合である必要があります。

パラメータ:
models - 削除するパブリックグループ内包の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel の使用

PublicGroupSetBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.set パブリックグループセット情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.set での PublicGroupSetBaseModel の使用

PublicGroupSetBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.public_group.set のメソッド
PublicGroupSetBaseModel | PublicGroupSetMapper.create(String publicGroupSetCode) プライマリキーに該当するパブリックグループセットを生成します。
PublicGroupSetBaseModel | PublicGroupSetMapper.select(String publicGroupSetCode) プライマリーキーで特定されるパブリックグループセットの基本モデルを取得します。

PublicGroupSetBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.public_group.set のメソッド
void | PublicGroupSetMapper.insert(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ挿入します。
void | PublicGroupSetMapper.update(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ更新します。
void | PublicGroupSetMapper.delete(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.public_group.set (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.public_group.set
インタフェース
PublicGroupSetBaseModel
PublicGroupSetMapper


jp.co.intra_mart.foundation.datastore.application.model.public_group.set (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.set

パブリックグループセット情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
PublicGroupSetBaseModel | パブリックグループセットの基本モデルです。
PublicGroupSetMapper | パブリックグループセットに関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.set の説明

パブリックグループセット情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.public_group.set クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.set の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.set の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.set の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.set を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.set パブリックグループセット情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.set により使用される jp.co.intra_mart.foundation.datastore.application.model.public_group.set のクラス
PublicGroupSetBaseModel
パブリックグループセットの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupSetBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.set
インタフェース PublicGroupSetBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface PublicGroupSetBaseModel
extends BaseModel

パブリックグループセットの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | PUBLIC_GROUP_SET_CODE グループセットコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getPublicGroupSetCode() グループセットコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

PUBLIC_GROUP_SET_CODE

public static final String PUBLIC_GROUP_SET_CODE
グループセットコード

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getPublicGroupSetCode

public String getPublicGroupSetCode()
                             throws AccessorException
グループセットコードを取得します。

戻り値:
グループセットコード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupSetMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.set
インタフェース PublicGroupSetMapper

すべてのスーパーインタフェース:
Mapper
public interface PublicGroupSetMapper
extends Mapper

パブリックグループセットに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
PublicGroupSetBaseModel | create(String publicGroupSetCode) プライマリキーに該当するパブリックグループセットを生成します。
void | delete(Collection models) パブリックグループセットの基本モデルを複数削除します。
void | delete(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ削除します。
void | insert(Collection models) パブリックグループセットの基本モデルを複数挿入します。
void | insert(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ挿入します。
PublicGroupSetBaseModel | select(String publicGroupSetCode) プライマリーキーで特定されるパブリックグループセットの基本モデルを取得します。
void | update(Collection models) パブリックグループセットの基本モデルを複数更新します。
void | update(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public PublicGroupSetBaseModel create(String publicGroupSetCode)
                               throws MapperException
プライマリキーに該当するパブリックグループセットを生成します。

パラメータ:
publicGroupSetCode - グループセットコード
戻り値:
プライマリキーに該当するパブリックグループセットの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public PublicGroupSetBaseModel select(String publicGroupSetCode)
                               throws MapperException
プライマリーキーで特定されるパブリックグループセットの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
publicGroupSetCode - グループセットコード
戻り値:
パブリックグループセットの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(PublicGroupSetBaseModel model)
            throws MapperException
パブリックグループセットの基本モデルを1つだけ挿入します。 引数に指定するパブリックグループセットの基本モデルは同一の PublicGroupSetMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入するパブリックグループセットの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
パブリックグループセットの基本モデルを複数挿入します。 引数に指定するものは同一の PublicGroupSetMapperの create(String) で生成されたパブリックグループセットの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するパブリックグループセットの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(PublicGroupSetBaseModel model)
            throws MapperException
パブリックグループセットの基本モデルを1つだけ更新します。 引数に指定するパブリックグループセットの基本モデルは同一の PublicGroupSetMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するパブリックグループセットの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
パブリックグループセットの基本モデルを複数更新します。 引数に指定するものは同一の PublicGroupSetMapperの select 系メソッド から取得されたものかで生成されたパブリックグループセットの基本モデルの集合である必要があります。

パラメータ:
models - 更新するパブリックグループセットの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(PublicGroupSetBaseModel model)
            throws MapperException
パブリックグループセットの基本モデルを1つだけ削除します。 引数で指定されたパブリックグループセットの基本モデルに該当するデータのすべての情報を削除します。引数に指定するパブリックグループセットの基本モデルは同一の PublicGroupSetMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するパブリックグループセットの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
パブリックグループセットの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するパブリックグループセットの基本モデルは同一の PublicGroupSetMapperの select 系メソッド から取得されたパブリックグループセットの基本モデルの集合である必要があります。

パラメータ:
models - 削除するパブリックグループセットの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の使用

PublicGroupVersionBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.version パブリックグループバーション情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.version での PublicGroupVersionBaseModel の使用

PublicGroupVersionBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.public_group.version のメソッド
PublicGroupVersionBaseModel | PublicGroupVersionMapper.create(String publicGroupSetCode, String versionCode) プライマリキーに該当するパブリックグループ構成バージョンを生成します。
PublicGroupVersionBaseModel | PublicGroupVersionMapper.select(String publicGroupSetCode, String versionCode) プライマリーキーで特定されるパブリックグループ構成バージョンの基本モデルを取得します。

PublicGroupVersionBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.public_group.version のメソッド
void | PublicGroupVersionMapper.insert(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ挿入します。
void | PublicGroupVersionMapper.update(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ更新します。
void | PublicGroupVersionMapper.delete(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.public_group.version (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.public_group.version
インタフェース
PublicGroupVersionBaseModel
PublicGroupVersionMapper


jp.co.intra_mart.foundation.datastore.application.model.public_group.version (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.version

パブリックグループバーション情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
PublicGroupVersionBaseModel | パブリックグループ構成バージョンの基本モデルです。
PublicGroupVersionMapper | パブリックグループ構成バージョンに関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.version の説明

パブリックグループバーション情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.public_group.version クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.version の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.version の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.version の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.version を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.version パブリックグループバーション情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.version により使用される jp.co.intra_mart.foundation.datastore.application.model.public_group.version のクラス
PublicGroupVersionBaseModel
パブリックグループ構成バージョンの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupVersionBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.version
インタフェース PublicGroupVersionBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface PublicGroupVersionBaseModel
extends BaseModel

パブリックグループ構成バージョンの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | END_DATE 終了日
static String | NOTES 備考
static String | PUBLIC_GROUP_SET_CODE グループセットコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | START_DATE 開始日
static String | VERSION_CODE バージョンコード
メソッドの概要
Date | getEndDate() 終了日を取得します。
String | getNotes() 備考を取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
Date | getStartDate() 開始日を取得します。
String | getVersionCode() バージョンコードを取得します。
void | setEndDate(Date endDate) 終了日を設定します。
void | setNotes(String notes) 備考を設定します。
void | setStartDate(Date startDate) 開始日を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

PUBLIC_GROUP_SET_CODE

public static final String PUBLIC_GROUP_SET_CODE
グループセットコード

関連項目:
定数フィールド値

VERSION_CODE

public static final String VERSION_CODE
バージョンコード

関連項目:
定数フィールド値

START_DATE

public static final String START_DATE
開始日

関連項目:
定数フィールド値

END_DATE

public static final String END_DATE
終了日

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getPublicGroupSetCode

public String getPublicGroupSetCode()
                             throws AccessorException
グループセットコードを取得します。

戻り値:
グループセットコード
例外:
AccessorException - データの取得に失敗した場合

getVersionCode

public String getVersionCode()
                      throws AccessorException
バージョンコードを取得します。

戻り値:
バージョンコード
例外:
AccessorException - データの取得に失敗した場合

getStartDate

public Date getStartDate()
                  throws AccessorException
開始日を取得します。

戻り値:
開始日
例外:
AccessorException - データの取得に失敗した場合

setStartDate

public void setStartDate(Date startDate)
                  throws AccessorException
開始日を設定します。

パラメータ:
startDate - 開始日
例外:
AccessorException - データの設定に失敗した場合

getEndDate

public Date getEndDate()
                throws AccessorException
終了日を取得します。

戻り値:
終了日
例外:
AccessorException - データの取得に失敗した場合

setEndDate

public void setEndDate(Date endDate)
                throws AccessorException
終了日を設定します。

パラメータ:
endDate - 終了日
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupVersionMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.version
インタフェース PublicGroupVersionMapper

すべてのスーパーインタフェース:
Mapper
public interface PublicGroupVersionMapper
extends Mapper

パブリックグループ構成バージョンに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
PublicGroupVersionBaseModel | create(String publicGroupSetCode, String versionCode) プライマリキーに該当するパブリックグループ構成バージョンを生成します。
void | delete(Collection models) パブリックグループ構成バージョンの基本モデルを複数削除します。
void | delete(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ削除します。
void | insert(Collection models) パブリックグループ構成バージョンの基本モデルを複数挿入します。
void | insert(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ挿入します。
PublicGroupVersionBaseModel | select(String publicGroupSetCode, String versionCode) プライマリーキーで特定されるパブリックグループ構成バージョンの基本モデルを取得します。
void | update(Collection models) パブリックグループ構成バージョンの基本モデルを複数更新します。
void | update(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public PublicGroupVersionBaseModel create(String publicGroupSetCode,
                                          String versionCode)
                                   throws MapperException
プライマリキーに該当するパブリックグループ構成バージョンを生成します。

パラメータ:
publicGroupSetCode - グループセットコード
versionCode - バージョンコード
戻り値:
プライマリキーに該当するパブリックグループ構成バージョンの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public PublicGroupVersionBaseModel select(String publicGroupSetCode,
                                          String versionCode)
                                   throws MapperException
プライマリーキーで特定されるパブリックグループ構成バージョンの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
publicGroupSetCode - グループセットコード
versionCode - バージョンコード
戻り値:
パブリックグループ構成バージョンの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(PublicGroupVersionBaseModel model)
            throws MapperException
パブリックグループ構成バージョンの基本モデルを1つだけ挿入します。 引数に指定するパブリックグループ構成バージョンの基本モデルは同一の PublicGroupVersionMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するパブリックグループ構成バージョンの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
パブリックグループ構成バージョンの基本モデルを複数挿入します。 引数に指定するものは同一の PublicGroupVersionMapperの create(String,String) で生成されたパブリックグループ構成バージョンの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するパブリックグループ構成バージョンの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(PublicGroupVersionBaseModel model)
            throws MapperException
パブリックグループ構成バージョンの基本モデルを1つだけ更新します。 引数に指定するパブリックグループ構成バージョンの基本モデルは同一の PublicGroupVersionMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するパブリックグループ構成バージョンの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
パブリックグループ構成バージョンの基本モデルを複数更新します。 引数に指定するものは同一の PublicGroupVersionMapperの select 系メソッド から取得されたものかで生成されたパブリックグループ構成バージョンの基本モデルの集合である必要があります。

パラメータ:
models - 更新するパブリックグループ構成バージョンの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(PublicGroupVersionBaseModel model)
            throws MapperException
パブリックグループ構成バージョンの基本モデルを1つだけ削除します。 引数で指定されたパブリックグループ構成バージョンの基本モデルに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ構成バージョンの基本モデルは同一の PublicGroupVersionMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するパブリックグループ構成バージョンの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
パブリックグループ構成バージョンの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ構成バージョンの基本モデルは同一の PublicGroupVersionMapperの select 系メソッド から取得されたパブリックグループ構成バージョンの基本モデルの集合である必要があります。

パラメータ:
models - 削除するパブリックグループ構成バージョンの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.unit.UnitBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.unit.UnitBaseModel の使用

UnitBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.unit 単位情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.unit での UnitBaseModel の使用

UnitBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.unit のメソッド
UnitBaseModel | UnitMapper.create(String unitCode) プライマリキーに該当する単位を生成します。
UnitBaseModel | UnitMapper.select(String unitCode) プライマリーキーで特定される単位の基本モデルを取得します。

UnitBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.unit のメソッド
void | UnitMapper.insert(UnitBaseModel model) 単位の基本モデルを1つだけ挿入します。
void | UnitMapper.update(UnitBaseModel model) 単位の基本モデルを1つだけ更新します。
void | UnitMapper.delete(UnitBaseModel model) 単位の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.unit (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.unit
インタフェース
UnitBaseModel
UnitMapper


jp.co.intra_mart.foundation.datastore.application.model.unit (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.unit

単位情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
UnitBaseModel | 単位の基本モデルです。
UnitMapper | 単位に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.unit の説明

単位情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.unit クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.unit の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.unit の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.unit の使用

jp.co.intra_mart.foundation.datastore.application.model.unit を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.unit 単位情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.unit により使用される jp.co.intra_mart.foundation.datastore.application.model.unit のクラス
UnitBaseModel
単位の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


UnitBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.unit
インタフェース UnitBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface UnitBaseModel
extends BaseModel

単位の基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | UNIT_CODE 単位コード
static String | UNIT_NAME 単位名
メソッドの概要
String | getUnitCode() 単位コードを取得します。
String | getUnitName() 単位名を取得します。
void | setUnitName(String unitName) 単位名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

UNIT_CODE

public static final String UNIT_CODE
単位コード

関連項目:
定数フィールド値

UNIT_NAME

public static final String UNIT_NAME
単位名

関連項目:
定数フィールド値
メソッドの詳細

getUnitCode

public String getUnitCode()
                   throws AccessorException
単位コードを取得します。

戻り値:
単位コード
例外:
AccessorException - データの取得に失敗した場合

getUnitName

public String getUnitName()
                   throws AccessorException
単位名を取得します。

戻り値:
単位名
例外:
AccessorException - データの取得に失敗した場合

setUnitName

public void setUnitName(String unitName)
                 throws AccessorException
単位名を設定します。

パラメータ:
unitName - 単位名
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UnitMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.unit
インタフェース UnitMapper

すべてのスーパーインタフェース:
Mapper
public interface UnitMapper
extends Mapper

単位に関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
UnitBaseModel | create(String unitCode) プライマリキーに該当する単位を生成します。
void | delete(Collection models) 単位の基本モデルを複数削除します。
void | delete(UnitBaseModel model) 単位の基本モデルを1つだけ削除します。
void | insert(Collection models) 単位の基本モデルを複数挿入します。
void | insert(UnitBaseModel model) 単位の基本モデルを1つだけ挿入します。
UnitBaseModel | select(String unitCode) プライマリーキーで特定される単位の基本モデルを取得します。
void | update(Collection models) 単位の基本モデルを複数更新します。
void | update(UnitBaseModel model) 単位の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public UnitBaseModel create(String unitCode)
                     throws MapperException
プライマリキーに該当する単位を生成します。

パラメータ:
unitCode - 単位コード
戻り値:
プライマリキーに該当する単位の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public UnitBaseModel select(String unitCode)
                     throws MapperException
プライマリーキーで特定される単位の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
unitCode - 単位コード
戻り値:
単位の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(UnitBaseModel model)
            throws MapperException
単位の基本モデルを1つだけ挿入します。 引数に指定する単位の基本モデルは同一の UnitMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入する単位の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
単位の基本モデルを複数挿入します。 引数に指定するものは同一の UnitMapperの create(String) で生成された単位の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する単位の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(UnitBaseModel model)
            throws MapperException
単位の基本モデルを1つだけ更新します。 引数に指定する単位の基本モデルは同一の UnitMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する単位の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
単位の基本モデルを複数更新します。 引数に指定するものは同一の UnitMapperの select 系メソッド から取得されたものかで生成された単位の基本モデルの集合である必要があります。

パラメータ:
models - 更新する単位の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(UnitBaseModel model)
            throws MapperException
単位の基本モデルを1つだけ削除します。 引数で指定された単位の基本モデルに該当するデータのすべての情報を削除します。引数に指定する単位の基本モデルは同一の UnitMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する単位の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
単位の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する単位の基本モデルは同一の UnitMapperの select 系メソッド から取得された単位の基本モデルの集合である必要があります。

パラメータ:
models - 削除する単位の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の使用

UserBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.user ユーザ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.user での UserBaseModel の使用

UserBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.user のメソッド
UserBaseModel | UserMapper.create(String userCode) プライマリキーに該当するユーザを生成します。
UserBaseModel | UserMapper.select(String userCode) プライマリーキーで特定されるユーザの基本モデルを取得します。

UserBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.user のメソッド
void | UserMapper.insert(UserBaseModel model) ユーザの基本モデルを1つだけ挿入します。
void | UserMapper.update(UserBaseModel model) ユーザの基本モデルを1つだけ更新します。
void | UserMapper.delete(UserBaseModel model) ユーザの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel の使用

UserTerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.user ユーザ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.user での UserTerminableInternationalModel の使用

UserTerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.user のメソッド
 UserTerminableInternationalModel UserTerminableModel.selectUserTerminableInternationalModel(Locale locale)
指定された言語に該当するユーザの期間国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel の使用

UserTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.user ユーザ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.user での UserTerminableModel の使用

UserTerminableModel を返す jp.co.intra_mart.foundation.datastore.application.model.user のメソッド
 UserTerminableModel UserBaseModel.selectUserTerminableModel(Date date)
指定された日付に該当するユーザの期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.user (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.user
インタフェース
UserBaseModel
UserMapper
UserTerminableInternationalModel
UserTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.user (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.user

ユーザ情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
UserBaseModel | ユーザの基本モデルです。
UserMapper | ユーザに関連するマッパです。
UserTerminableInternationalModel | ユーザの期間国際化モデルです。
UserTerminableModel | ユーザの期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.user の説明

ユーザ情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.user クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.user の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.user の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.user の使用

jp.co.intra_mart.foundation.datastore.application.model.user を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.user ユーザ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.user により使用される jp.co.intra_mart.foundation.datastore.application.model.user のクラス
UserBaseModel
ユーザの基本モデルです。
UserTerminableInternationalModel
ユーザの期間国際化モデルです。
UserTerminableModel
ユーザの期間化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


UserBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.user
インタフェース UserBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface UserBaseModel
extends BaseModel

ユーザの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | ACCOUNT_FLAG アカウントフラグ
static String | ADDRESS 住所
static String | AVALIABLE_LOGIN_USER ログインできるアカウントを表す定数
static String | COUNTRY_CODE 国コード
static String | EMAIL_ADDRESS1 メールアドレス１
static String | EMAIL_ADDRESS2 メールアドレス２
static String | EXTENSION_FAX_NUMBER 内線FAX番号
static String | EXTENSION_NUMBER 内線番号
static String | FAX_NUMBER FAX番号
static String | MOBILE_EMAIL_ADDRESS 携帯用メール
static String | MOBILE_NUMBER 携帯電話番号
static String | NAME ユーザ名
static String | NAME_ENGLISH ユーザ名英字
static String | NAME_SYLLABARY ユーザ名カナ
static String | NOTES 備考
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
static String | TELEPHONE_NUMBER 電話番号
static String | UNAVALIABLE_LOGIN_USER ログイン出来ないアカウントを表す定数
static String | URL URL
static String | USER_CODE ユーザコード
static String | ZIP_CODE 郵便番号
メソッドの概要
String | getAccountFlag() アカウントフラグを取得します。
String | getAddress() 住所を取得します。
String | getAddress(Date date) 住所を取得します。
String | getAddress(Date date, Locale locale) 住所を取得します。
String | getAddress(Locale locale) 住所を取得します。
String | getCountryCode() 国コードを取得します。
String | getCountryCode(Date date) 国コードを取得します。
String | getEmailAddress1() メールアドレス１を取得します。
String | getEmailAddress1(Date date) メールアドレス１を取得します。
String | getEmailAddress2() メールアドレス２を取得します。
String | getEmailAddress2(Date date) メールアドレス２を取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionFaxNumber(Date date) 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getExtensionNumber(Date date) 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
String | getFaxNumber(Date date) FAX番号を取得します。
String | getMobileEmailAddress() 携帯用メールを取得します。
String | getMobileEmailAddress(Date date) 携帯用メールを取得します。
String | getMobileNumber() 携帯電話番号を取得します。
String | getMobileNumber(Date date) 携帯電話番号を取得します。
String | getName() ユーザ名を取得します。
String | getName(Date date) ユーザ名を取得します。
String | getName(Date date, Locale locale) ユーザ名を取得します。
String | getName(Locale locale) ユーザ名を取得します。
String | getNameEnglish() ユーザ名英字を取得します。
String | getNameEnglish(Date date) ユーザ名英字を取得します。
String | getNameEnglish(Date date, Locale locale) ユーザ名英字を取得します。
String | getNameEnglish(Locale locale) ユーザ名英字を取得します。
String | getNameSyllabary() ユーザ名カナを取得します。
String | getNameSyllabary(Date date) ユーザ名カナを取得します。
String | getNameSyllabary(Date date, Locale locale) ユーザ名カナを取得します。
String | getNameSyllabary(Locale locale) ユーザ名カナを取得します。
String | getNotes() 備考を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getTelephoneNumber(Date date) 電話番号を取得します。
String | getUrl() URLを取得します。
String | getUrl(Date date) URLを取得します。
String | getUserCode() ユーザコードを取得します。
String | getZipCode() 郵便番号を取得します。
String | getZipCode(Date date) 郵便番号を取得します。
UserTerminableModel | selectUserTerminableModel(Date date) 指定された日付に該当するユーザの期間化モデルを取得します。
void | setAccountFlag(String accountFlag) アカウントフラグを設定します。
void | setAddress(String address) 住所を設定します。
void | setAddress(String address, Date date) 住所を設定します。
void | setAddress(String address, Date date, Locale locale) 住所を設定します。
void | setAddress(String address, Locale locale) 住所を設定します。
void | setCountryCode(String countryCode) 国コードを設定します。
void | setCountryCode(String countryCode, Date date) 国コードを設定します。
void | setEmailAddress1(String emailAddress1) メールアドレス１を設定します。
void | setEmailAddress1(String emailAddress1, Date date) メールアドレス１を設定します。
void | setEmailAddress2(String emailAddress2) メールアドレス２を設定します。
void | setEmailAddress2(String emailAddress2, Date date) メールアドレス２を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber, Date date) 内線FAX番号を設定します。
void | setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | setExtensionNumber(String extensionNumber, Date date) 内線番号を設定します。
void | setFaxNumber(String faxNumber) FAX番号を設定します。
void | setFaxNumber(String faxNumber, Date date) FAX番号を設定します。
void | setMobileEmailAddress(String mobileEmailAddress) 携帯用メールを設定します。
void | setMobileEmailAddress(String mobileEmailAddress, Date date) 携帯用メールを設定します。
void | setMobileNumber(String mobileNumber) 携帯電話番号を設定します。
void | setMobileNumber(String mobileNumber, Date date) 携帯電話番号を設定します。
void | setName(String name) ユーザ名を設定します。
void | setName(String name, Date date) ユーザ名を設定します。
void | setName(String name, Date date, Locale locale) ユーザ名を設定します。
void | setName(String name, Locale locale) ユーザ名を設定します。
void | setNameEnglish(String nameEnglish) ユーザ名英字を設定します。
void | setNameEnglish(String nameEnglish, Date date) ユーザ名英字を設定します。
void | setNameEnglish(String nameEnglish, Date date, Locale locale) ユーザ名英字を設定します。
void | setNameEnglish(String nameEnglish, Locale locale) ユーザ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) ユーザ名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Date date) ユーザ名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Date date, Locale locale) ユーザ名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Locale locale) ユーザ名カナを設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
void | setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | setTelephoneNumber(String telephoneNumber, Date date) 電話番号を設定します。
void | setUrl(String url) URLを設定します。
void | setUrl(String url, Date date) URLを設定します。
void | setZipCode(String zipCode) 郵便番号を設定します。
void | setZipCode(String zipCode, Date date) 郵便番号を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

USER_CODE

public static final String USER_CODE
ユーザコード

関連項目:
定数フィールド値

ACCOUNT_FLAG

public static final String ACCOUNT_FLAG
アカウントフラグ

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

TELEPHONE_NUMBER

public static final String TELEPHONE_NUMBER
電話番号

関連項目:
定数フィールド値

MOBILE_NUMBER

public static final String MOBILE_NUMBER
携帯電話番号

関連項目:
定数フィールド値

FAX_NUMBER

public static final String FAX_NUMBER
FAX番号

関連項目:
定数フィールド値

EXTENSION_NUMBER

public static final String EXTENSION_NUMBER
内線番号

関連項目:
定数フィールド値

EXTENSION_FAX_NUMBER

public static final String EXTENSION_FAX_NUMBER
内線FAX番号

関連項目:
定数フィールド値

COUNTRY_CODE

public static final String COUNTRY_CODE
国コード

関連項目:
定数フィールド値

ZIP_CODE

public static final String ZIP_CODE
郵便番号

関連項目:
定数フィールド値

EMAIL_ADDRESS1

public static final String EMAIL_ADDRESS1
メールアドレス１

関連項目:
定数フィールド値

EMAIL_ADDRESS2

public static final String EMAIL_ADDRESS2
メールアドレス２

関連項目:
定数フィールド値

MOBILE_EMAIL_ADDRESS

public static final String MOBILE_EMAIL_ADDRESS
携帯用メール

関連項目:
定数フィールド値

URL

public static final String URL
URL

関連項目:
定数フィールド値

NAME

public static final String NAME
ユーザ名

関連項目:
定数フィールド値

NAME_SYLLABARY

public static final String NAME_SYLLABARY
ユーザ名カナ

関連項目:
定数フィールド値

NAME_ENGLISH

public static final String NAME_ENGLISH
ユーザ名英字

関連項目:
定数フィールド値

ADDRESS

public static final String ADDRESS
住所

関連項目:
定数フィールド値

UNAVALIABLE_LOGIN_USER

public static final String UNAVALIABLE_LOGIN_USER
ログイン出来ないアカウントを表す定数

関連項目:
定数フィールド値

AVALIABLE_LOGIN_USER

public static final String AVALIABLE_LOGIN_USER
ログインできるアカウントを表す定数

関連項目:
定数フィールド値
メソッドの詳細

getUserCode

public String getUserCode()
                   throws AccessorException
ユーザコードを取得します。

戻り値:
ユーザコード
例外:
AccessorException - データの取得に失敗した場合

getAccountFlag

public String getAccountFlag()
                      throws AccessorException
アカウントフラグを取得します。

戻り値:
アカウントフラグ
例外:
AccessorException - データの取得に失敗した場合

setAccountFlag

public void setAccountFlag(String accountFlag)
                    throws AccessorException
アカウントフラグを設定します。

パラメータ:
accountFlag - アカウントフラグ
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getTelephoneNumber

public String getTelephoneNumber()
                          throws AccessorException
電話番号を取得します。

戻り値:
電話番号
例外:
AccessorException - データの取得に失敗した場合

getTelephoneNumber

public String getTelephoneNumber(Date date)
                          throws AccessorException
電話番号を取得します。

パラメータ:
date - 日時
戻り値:
電話番号
例外:
AccessorException - データの取得に失敗した場合

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber)
                        throws AccessorException
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号
例外:
AccessorException - データの設定に失敗した場合

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber,
                               Date date)
                        throws AccessorException
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getMobileNumber

public String getMobileNumber()
                       throws AccessorException
携帯電話番号を取得します。

戻り値:
携帯電話番号
例外:
AccessorException - データの取得に失敗した場合

getMobileNumber

public String getMobileNumber(Date date)
                       throws AccessorException
携帯電話番号を取得します。

パラメータ:
date - 日時
戻り値:
携帯電話番号
例外:
AccessorException - データの取得に失敗した場合

setMobileNumber

public void setMobileNumber(String mobileNumber)
                     throws AccessorException
携帯電話番号を設定します。

パラメータ:
mobileNumber - 携帯電話番号
例外:
AccessorException - データの設定に失敗した場合

setMobileNumber

public void setMobileNumber(String mobileNumber,
                            Date date)
                     throws AccessorException
携帯電話番号を設定します。

パラメータ:
mobileNumber - 携帯電話番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getFaxNumber

public String getFaxNumber()
                    throws AccessorException
FAX番号を取得します。

戻り値:
FAX番号
例外:
AccessorException - データの取得に失敗した場合

getFaxNumber

public String getFaxNumber(Date date)
                    throws AccessorException
FAX番号を取得します。

パラメータ:
date - 日時
戻り値:
FAX番号
例外:
AccessorException - データの取得に失敗した場合

setFaxNumber

public void setFaxNumber(String faxNumber)
                  throws AccessorException
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号
例外:
AccessorException - データの設定に失敗した場合

setFaxNumber

public void setFaxNumber(String faxNumber,
                         Date date)
                  throws AccessorException
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getExtensionNumber

public String getExtensionNumber()
                          throws AccessorException
内線番号を取得します。

戻り値:
内線番号
例外:
AccessorException - データの取得に失敗した場合

getExtensionNumber

public String getExtensionNumber(Date date)
                          throws AccessorException
内線番号を取得します。

パラメータ:
date - 日時
戻り値:
内線番号
例外:
AccessorException - データの取得に失敗した場合

setExtensionNumber

public void setExtensionNumber(String extensionNumber)
                        throws AccessorException
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号
例外:
AccessorException - データの設定に失敗した場合

setExtensionNumber

public void setExtensionNumber(String extensionNumber,
                               Date date)
                        throws AccessorException
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getExtensionFaxNumber

public String getExtensionFaxNumber()
                             throws AccessorException
内線FAX番号を取得します。

戻り値:
内線FAX番号
例外:
AccessorException - データの取得に失敗した場合

getExtensionFaxNumber

public String getExtensionFaxNumber(Date date)
                             throws AccessorException
内線FAX番号を取得します。

パラメータ:
date - 日時
戻り値:
内線FAX番号
例外:
AccessorException - データの取得に失敗した場合

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber)
                           throws AccessorException
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号
例外:
AccessorException - データの設定に失敗した場合

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber,
                                  Date date)
                           throws AccessorException
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getCountryCode

public String getCountryCode()
                      throws AccessorException
国コードを取得します。

戻り値:
国コード
例外:
AccessorException - データの取得に失敗した場合

getCountryCode

public String getCountryCode(Date date)
                      throws AccessorException
国コードを取得します。

パラメータ:
date - 日時
戻り値:
国コード
例外:
AccessorException - データの取得に失敗した場合

setCountryCode

public void setCountryCode(String countryCode)
                    throws AccessorException
国コードを設定します。

パラメータ:
countryCode - 国コード
例外:
AccessorException - データの設定に失敗した場合

setCountryCode

public void setCountryCode(String countryCode,
                           Date date)
                    throws AccessorException
国コードを設定します。

パラメータ:
countryCode - 国コード
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getZipCode

public String getZipCode()
                  throws AccessorException
郵便番号を取得します。

戻り値:
郵便番号
例外:
AccessorException - データの取得に失敗した場合

getZipCode

public String getZipCode(Date date)
                  throws AccessorException
郵便番号を取得します。

パラメータ:
date - 日時
戻り値:
郵便番号
例外:
AccessorException - データの取得に失敗した場合

setZipCode

public void setZipCode(String zipCode)
                throws AccessorException
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号
例外:
AccessorException - データの設定に失敗した場合

setZipCode

public void setZipCode(String zipCode,
                       Date date)
                throws AccessorException
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getEmailAddress1

public String getEmailAddress1()
                        throws AccessorException
メールアドレス１を取得します。

戻り値:
メールアドレス１
例外:
AccessorException - データの取得に失敗した場合

getEmailAddress1

public String getEmailAddress1(Date date)
                        throws AccessorException
メールアドレス１を取得します。

パラメータ:
date - 日時
戻り値:
メールアドレス１
例外:
AccessorException - データの取得に失敗した場合

setEmailAddress1

public void setEmailAddress1(String emailAddress1)
                      throws AccessorException
メールアドレス１を設定します。

パラメータ:
emailAddress1 - メールアドレス１
例外:
AccessorException - データの設定に失敗した場合

setEmailAddress1

public void setEmailAddress1(String emailAddress1,
                             Date date)
                      throws AccessorException
メールアドレス１を設定します。

パラメータ:
emailAddress1 - メールアドレス１
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getEmailAddress2

public String getEmailAddress2()
                        throws AccessorException
メールアドレス２を取得します。

戻り値:
メールアドレス２
例外:
AccessorException - データの取得に失敗した場合

getEmailAddress2

public String getEmailAddress2(Date date)
                        throws AccessorException
メールアドレス２を取得します。

パラメータ:
date - 日時
戻り値:
メールアドレス２
例外:
AccessorException - データの取得に失敗した場合

setEmailAddress2

public void setEmailAddress2(String emailAddress2)
                      throws AccessorException
メールアドレス２を設定します。

パラメータ:
emailAddress2 - メールアドレス２
例外:
AccessorException - データの設定に失敗した場合

setEmailAddress2

public void setEmailAddress2(String emailAddress2,
                             Date date)
                      throws AccessorException
メールアドレス２を設定します。

パラメータ:
emailAddress2 - メールアドレス２
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getMobileEmailAddress

public String getMobileEmailAddress()
                             throws AccessorException
携帯用メールを取得します。

戻り値:
携帯用メール
例外:
AccessorException - データの取得に失敗した場合

getMobileEmailAddress

public String getMobileEmailAddress(Date date)
                             throws AccessorException
携帯用メールを取得します。

パラメータ:
date - 日時
戻り値:
携帯用メール
例外:
AccessorException - データの取得に失敗した場合

setMobileEmailAddress

public void setMobileEmailAddress(String mobileEmailAddress)
                           throws AccessorException
携帯用メールを設定します。

パラメータ:
mobileEmailAddress - 携帯用メール
例外:
AccessorException - データの設定に失敗した場合

setMobileEmailAddress

public void setMobileEmailAddress(String mobileEmailAddress,
                                  Date date)
                           throws AccessorException
携帯用メールを設定します。

パラメータ:
mobileEmailAddress - 携帯用メール
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getUrl

public String getUrl()
              throws AccessorException
URLを取得します。

戻り値:
URL
例外:
AccessorException - データの取得に失敗した場合

getUrl

public String getUrl(Date date)
              throws AccessorException
URLを取得します。

パラメータ:
date - 日時
戻り値:
URL
例外:
AccessorException - データの取得に失敗した場合

setUrl

public void setUrl(String url)
            throws AccessorException
URLを設定します。

パラメータ:
url - URL
例外:
AccessorException - データの設定に失敗した場合

setUrl

public void setUrl(String url,
                   Date date)
            throws AccessorException
URLを設定します。

パラメータ:
url - URL
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getName

public String getName()
               throws AccessorException
ユーザ名を取得します。

戻り値:
ユーザ名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Date date)
               throws AccessorException
ユーザ名を取得します。

パラメータ:
date - 日時
戻り値:
ユーザ名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
ユーザ名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザ名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Date date,
                      Locale locale)
               throws AccessorException
ユーザ名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
ユーザ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
ユーザ名を設定します。

パラメータ:
name - ユーザ名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Date date)
             throws AccessorException
ユーザ名を設定します。

パラメータ:
name - ユーザ名
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
ユーザ名を設定します。

パラメータ:
name - ユーザ名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Date date,
                    Locale locale)
             throws AccessorException
ユーザ名を設定します。

パラメータ:
name - ユーザ名
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
ユーザ名カナを取得します。

戻り値:
ユーザ名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Date date)
                        throws AccessorException
ユーザ名カナを取得します。

パラメータ:
date - 日時
戻り値:
ユーザ名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Locale locale)
                        throws AccessorException
ユーザ名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザ名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Date date,
                               Locale locale)
                        throws AccessorException
ユーザ名カナを取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
ユーザ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
ユーザ名カナを設定します。

パラメータ:
nameSyllabary - ユーザ名カナ
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Date date)
                      throws AccessorException
ユーザ名カナを設定します。

パラメータ:
nameSyllabary - ユーザ名カナ
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Locale locale)
                      throws AccessorException
ユーザ名カナを設定します。

パラメータ:
nameSyllabary - ユーザ名カナ
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Date date,
                             Locale locale)
                      throws AccessorException
ユーザ名カナを設定します。

パラメータ:
nameSyllabary - ユーザ名カナ
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
ユーザ名英字を取得します。

戻り値:
ユーザ名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Date date)
                      throws AccessorException
ユーザ名英字を取得します。

パラメータ:
date - 日時
戻り値:
ユーザ名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Locale locale)
                      throws AccessorException
ユーザ名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザ名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Date date,
                             Locale locale)
                      throws AccessorException
ユーザ名英字を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
ユーザ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
ユーザ名英字を設定します。

パラメータ:
nameEnglish - ユーザ名英字
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Date date)
                    throws AccessorException
ユーザ名英字を設定します。

パラメータ:
nameEnglish - ユーザ名英字
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Locale locale)
                    throws AccessorException
ユーザ名英字を設定します。

パラメータ:
nameEnglish - ユーザ名英字
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Date date,
                           Locale locale)
                    throws AccessorException
ユーザ名英字を設定します。

パラメータ:
nameEnglish - ユーザ名英字
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getAddress

public String getAddress()
                  throws AccessorException
住所を取得します。

戻り値:
住所
例外:
AccessorException - データの取得に失敗した場合

getAddress

public String getAddress(Date date)
                  throws AccessorException
住所を取得します。

パラメータ:
date - 日時
戻り値:
住所
例外:
AccessorException - データの取得に失敗した場合

getAddress

public String getAddress(Locale locale)
                  throws AccessorException
住所を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所
例外:
AccessorException - データの取得に失敗した場合

getAddress

public String getAddress(Date date,
                         Locale locale)
                  throws AccessorException
住所を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
住所
例外:
AccessorException - データの取得に失敗した場合

setAddress

public void setAddress(String address)
                throws AccessorException
住所を設定します。

パラメータ:
address - 住所
例外:
AccessorException - データの設定に失敗した場合

setAddress

public void setAddress(String address,
                       Date date)
                throws AccessorException
住所を設定します。

パラメータ:
address - 住所
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setAddress

public void setAddress(String address,
                       Locale locale)
                throws AccessorException
住所を設定します。

パラメータ:
address - 住所
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setAddress

public void setAddress(String address,
                       Date date,
                       Locale locale)
                throws AccessorException
住所を設定します。

パラメータ:
address - 住所
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectUserTerminableModel

public UserTerminableModel selectUserTerminableModel(Date date)
                                              throws IllegalTermException
指定された日付に該当するユーザの期間化モデルを取得します。

パラメータ:
date - 指定日付
戻り値:
ユーザの期間化モデル
例外:
IllegalTermException - 指定された日付に該当する期間が定義されていない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UserMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.user
インタフェース UserMapper

すべてのスーパーインタフェース:
Mapper
public interface UserMapper
extends Mapper

ユーザに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
UserBaseModel | create(String userCode) プライマリキーに該当するユーザを生成します。
void | delete(Collection models) ユーザの基本モデルを複数削除します。
void | delete(UserBaseModel model) ユーザの基本モデルを1つだけ削除します。
void | insert(Collection models) ユーザの基本モデルを複数挿入します。
void | insert(UserBaseModel model) ユーザの基本モデルを1つだけ挿入します。
UserBaseModel | select(String userCode) プライマリーキーで特定されるユーザの基本モデルを取得します。
void | update(Collection models) ユーザの基本モデルを複数更新します。
void | update(UserBaseModel model) ユーザの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public UserBaseModel create(String userCode)
                     throws MapperException
プライマリキーに該当するユーザを生成します。

パラメータ:
userCode - ユーザコード
戻り値:
プライマリキーに該当するユーザの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public UserBaseModel select(String userCode)
                     throws MapperException
プライマリーキーで特定されるユーザの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
userCode - ユーザコード
戻り値:
ユーザの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(UserBaseModel model)
            throws MapperException
ユーザの基本モデルを1つだけ挿入します。 引数に指定するユーザの基本モデルは同一の UserMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入するユーザの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
ユーザの基本モデルを複数挿入します。 引数に指定するものは同一の UserMapperの create(String) で生成されたユーザの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するユーザの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(UserBaseModel model)
            throws MapperException
ユーザの基本モデルを1つだけ更新します。 引数に指定するユーザの基本モデルは同一の UserMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するユーザの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
ユーザの基本モデルを複数更新します。 引数に指定するものは同一の UserMapperの select 系メソッド から取得されたものかで生成されたユーザの基本モデルの集合である必要があります。

パラメータ:
models - 更新するユーザの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(UserBaseModel model)
            throws MapperException
ユーザの基本モデルを1つだけ削除します。 引数で指定されたユーザの基本モデルに該当するデータのすべての情報を削除します。引数に指定するユーザの基本モデルは同一の UserMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するユーザの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
ユーザの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するユーザの基本モデルは同一の UserMapperの select 系メソッド から取得されたユーザの基本モデルの集合である必要があります。

パラメータ:
models - 削除するユーザの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserTerminableInternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.user
インタフェース UserTerminableInternationalModel

すべてのスーパーインタフェース:
Serializable, TerminableInternationalModel
public interface UserTerminableInternationalModel
extends TerminableInternationalModel

ユーザの期間国際化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getAddress() 住所を取得します。
String | getName() ユーザ名を取得します。
String | getNameEnglish() ユーザ名英字を取得します。
String | getNameSyllabary() ユーザ名カナを取得します。
void | setAddress(String address) 住所を設定します。
void | setName(String name) ユーザ名を設定します。
void | setNameEnglish(String nameEnglish) ユーザ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) ユーザ名カナを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel から継承したメソッド
getExtendedTerminableInternationalModelMap, getLocale, init

メソッドの詳細

getName

public String getName()
               throws AccessorException
ユーザ名を取得します。

戻り値:
ユーザ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
ユーザ名を設定します。

パラメータ:
name - ユーザ名
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
ユーザ名カナを取得します。

戻り値:
ユーザ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
ユーザ名カナを設定します。

パラメータ:
nameSyllabary - ユーザ名カナ
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
ユーザ名英字を取得します。

戻り値:
ユーザ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
ユーザ名英字を設定します。

パラメータ:
nameEnglish - ユーザ名英字
例外:
AccessorException - データの設定に失敗した場合

getAddress

public String getAddress()
                  throws AccessorException
住所を取得します。

戻り値:
住所
例外:
AccessorException - データの取得に失敗した場合

setAddress

public void setAddress(String address)
                throws AccessorException
住所を設定します。

パラメータ:
address - 住所
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserTerminableModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.user
インタフェース UserTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface UserTerminableModel
extends TerminableModel

ユーザの期間化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getAddress() 住所を取得します。
String | getAddress(Locale locale) 住所を取得します。
String | getCountryCode() 国コードを取得します。
String | getEmailAddress1() メールアドレス１を取得します。
String | getEmailAddress2() メールアドレス２を取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
String | getMobileEmailAddress() 携帯用メールを取得します。
String | getMobileNumber() 携帯電話番号を取得します。
String | getName() ユーザ名を取得します。
String | getName(Locale locale) ユーザ名を取得します。
String | getNameEnglish() ユーザ名英字を取得します。
String | getNameEnglish(Locale locale) ユーザ名英字を取得します。
String | getNameSyllabary() ユーザ名カナを取得します。
String | getNameSyllabary(Locale locale) ユーザ名カナを取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getUrl() URLを取得します。
String | getZipCode() 郵便番号を取得します。
UserTerminableInternationalModel | selectUserTerminableInternationalModel(Locale locale) 指定された言語に該当するユーザの期間国際化モデルを取得します。
void | setAddress(String address) 住所を設定します。
void | setAddress(String address, Locale locale) 住所を設定します。
void | setCountryCode(String countryCode) 国コードを設定します。
void | setEmailAddress1(String emailAddress1) メールアドレス１を設定します。
void | setEmailAddress2(String emailAddress2) メールアドレス２を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | setFaxNumber(String faxNumber) FAX番号を設定します。
void | setMobileEmailAddress(String mobileEmailAddress) 携帯用メールを設定します。
void | setMobileNumber(String mobileNumber) 携帯電話番号を設定します。
void | setName(String name) ユーザ名を設定します。
void | setName(String name, Locale locale) ユーザ名を設定します。
void | setNameEnglish(String nameEnglish) ユーザ名英字を設定します。
void | setNameEnglish(String nameEnglish, Locale locale) ユーザ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) ユーザ名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Locale locale) ユーザ名カナを設定します。
void | setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | setUrl(String url) URLを設定します。
void | setZipCode(String zipCode) 郵便番号を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

メソッドの詳細

getTelephoneNumber

public String getTelephoneNumber()
                          throws AccessorException
電話番号を取得します。

戻り値:
電話番号
例外:
AccessorException - データの取得に失敗した場合

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber)
                        throws AccessorException
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号
例外:
AccessorException - データの設定に失敗した場合

getMobileNumber

public String getMobileNumber()
                       throws AccessorException
携帯電話番号を取得します。

戻り値:
携帯電話番号
例外:
AccessorException - データの取得に失敗した場合

setMobileNumber

public void setMobileNumber(String mobileNumber)
                     throws AccessorException
携帯電話番号を設定します。

パラメータ:
mobileNumber - 携帯電話番号
例外:
AccessorException - データの設定に失敗した場合

getFaxNumber

public String getFaxNumber()
                    throws AccessorException
FAX番号を取得します。

戻り値:
FAX番号
例外:
AccessorException - データの取得に失敗した場合

setFaxNumber

public void setFaxNumber(String faxNumber)
                  throws AccessorException
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号
例外:
AccessorException - データの設定に失敗した場合

getExtensionNumber

public String getExtensionNumber()
                          throws AccessorException
内線番号を取得します。

戻り値:
内線番号
例外:
AccessorException - データの取得に失敗した場合

setExtensionNumber

public void setExtensionNumber(String extensionNumber)
                        throws AccessorException
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号
例外:
AccessorException - データの設定に失敗した場合

getExtensionFaxNumber

public String getExtensionFaxNumber()
                             throws AccessorException
内線FAX番号を取得します。

戻り値:
内線FAX番号
例外:
AccessorException - データの取得に失敗した場合

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber)
                           throws AccessorException
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号
例外:
AccessorException - データの設定に失敗した場合

getCountryCode

public String getCountryCode()
                      throws AccessorException
国コードを取得します。

戻り値:
国コード
例外:
AccessorException - データの取得に失敗した場合

setCountryCode

public void setCountryCode(String countryCode)
                    throws AccessorException
国コードを設定します。

パラメータ:
countryCode - 国コード
例外:
AccessorException - データの設定に失敗した場合

getZipCode

public String getZipCode()
                  throws AccessorException
郵便番号を取得します。

戻り値:
郵便番号
例外:
AccessorException - データの取得に失敗した場合

setZipCode

public void setZipCode(String zipCode)
                throws AccessorException
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号
例外:
AccessorException - データの設定に失敗した場合

getEmailAddress1

public String getEmailAddress1()
                        throws AccessorException
メールアドレス１を取得します。

戻り値:
メールアドレス１
例外:
AccessorException - データの取得に失敗した場合

setEmailAddress1

public void setEmailAddress1(String emailAddress1)
                      throws AccessorException
メールアドレス１を設定します。

パラメータ:
emailAddress1 - メールアドレス１
例外:
AccessorException - データの設定に失敗した場合

getEmailAddress2

public String getEmailAddress2()
                        throws AccessorException
メールアドレス２を取得します。

戻り値:
メールアドレス２
例外:
AccessorException - データの取得に失敗した場合

setEmailAddress2

public void setEmailAddress2(String emailAddress2)
                      throws AccessorException
メールアドレス２を設定します。

パラメータ:
emailAddress2 - メールアドレス２
例外:
AccessorException - データの設定に失敗した場合

getMobileEmailAddress

public String getMobileEmailAddress()
                             throws AccessorException
携帯用メールを取得します。

戻り値:
携帯用メール
例外:
AccessorException - データの取得に失敗した場合

setMobileEmailAddress

public void setMobileEmailAddress(String mobileEmailAddress)
                           throws AccessorException
携帯用メールを設定します。

パラメータ:
mobileEmailAddress - 携帯用メール
例外:
AccessorException - データの設定に失敗した場合

getUrl

public String getUrl()
              throws AccessorException
URLを取得します。

戻り値:
URL
例外:
AccessorException - データの取得に失敗した場合

setUrl

public void setUrl(String url)
            throws AccessorException
URLを設定します。

パラメータ:
url - URL
例外:
AccessorException - データの設定に失敗した場合

getName

public String getName()
               throws AccessorException
ユーザ名を取得します。

戻り値:
ユーザ名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
ユーザ名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
ユーザ名を設定します。

パラメータ:
name - ユーザ名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
ユーザ名を設定します。

パラメータ:
name - ユーザ名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
ユーザ名カナを取得します。

戻り値:
ユーザ名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Locale locale)
                        throws AccessorException
ユーザ名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
ユーザ名カナを設定します。

パラメータ:
nameSyllabary - ユーザ名カナ
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Locale locale)
                      throws AccessorException
ユーザ名カナを設定します。

パラメータ:
nameSyllabary - ユーザ名カナ
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
ユーザ名英字を取得します。

戻り値:
ユーザ名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Locale locale)
                      throws AccessorException
ユーザ名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
ユーザ名英字を設定します。

パラメータ:
nameEnglish - ユーザ名英字
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Locale locale)
                    throws AccessorException
ユーザ名英字を設定します。

パラメータ:
nameEnglish - ユーザ名英字
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getAddress

public String getAddress()
                  throws AccessorException
住所を取得します。

戻り値:
住所
例外:
AccessorException - データの取得に失敗した場合

getAddress

public String getAddress(Locale locale)
                  throws AccessorException
住所を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所
例外:
AccessorException - データの取得に失敗した場合

setAddress

public void setAddress(String address)
                throws AccessorException
住所を設定します。

パラメータ:
address - 住所
例外:
AccessorException - データの設定に失敗した場合

setAddress

public void setAddress(String address,
                       Locale locale)
                throws AccessorException
住所を設定します。

パラメータ:
address - 住所
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectUserTerminableInternationalModel

public UserTerminableInternationalModel selectUserTerminableInternationalModel(Locale locale)
                                                                        throws IllegalLocaleException
指定された言語に該当するユーザの期間国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザの期間国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor の使用

BaseAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での BaseAccessor の使用

BaseAccessor を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
BaseAccessor | TerminableAccessor.getBaseAccessor() この期間化アクセサが所属する基本アクセサを取得します。
BaseAccessor | InternationalAccessor.getBaseAccessor() この国際化アクセサが所属する基本アクセサを取得します。
BaseAccessor | ExtendedBaseAccessor.getBaseAccessor() 拡張元となる基本エンティティの基本アクセサを取得します。

jp.co.intra_mart.foundation.datastore.common.model での BaseAccessor の使用

BaseAccessor を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
protected BaseAccessor | IntramartDBMapper.createBaseAccessor(Map primary) このマッパーに該当する基本アクセサを新規に生成します。
BaseAccessor | GenericBaseModel.getBaseAccessor() この基本モデルに割り当てられた基本アクセサを取得します。
BaseAccessor | BaseModelContext.getBaseAccessor() 基本アクセサを取得します。
BaseAccessor | BaseModel.getBaseAccessor() 基本アクセサ BaseAccessor を取得します。

BaseAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void BaseModelContext.setBaseAccessor(BaseAccessor accessor)
基本アクセサを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor の使用

ExtendedBaseAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での ExtendedBaseAccessor の使用

ExtendedBaseAccessor を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
ExtendedBaseAccessor | ExtendedBaseAccessorMap.createExtendedBaseAccessor(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を生成します。
ExtendedBaseAccessor | ExtendedBaseAccessorMap.findExtendedBaseAccessor(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を取得します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedBaseAccessor の使用

ExtendedBaseAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | ExtendedGenericBaseModel.init(ExtendedBaseAccessor accessor) 拡張基本モデルを初期化します。
void | ExtendedBaseModel.init(ExtendedBaseAccessor accessor) 拡張基本モデルを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap の使用

ExtendedBaseAccessorMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での ExtendedBaseAccessorMap の使用

ExtendedBaseAccessorMap を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 ExtendedBaseAccessorMap BaseAccessor.getExtendedBaseAccessorMap()
基本アクセサに関連する拡張基本アクセサのマップを取得します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedBaseAccessorMap の使用

ExtendedBaseAccessorMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void ExtendedGenericBaseModelMap.init(ExtendedBaseAccessorMap accessorMap)
初期化を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor の使用

ExtendedInternationalAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での ExtendedInternationalAccessor の使用

ExtendedInternationalAccessor を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
ExtendedInternationalAccessor | ExtendedInternationalAccessorMap.createExtendedInternationalAccessor(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を生成します。
ExtendedInternationalAccessor | ExtendedInternationalAccessorMap.findExtendedInternationalAccessor(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を取得します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedInternationalAccessor の使用

ExtendedInternationalAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | ExtendedInternationalModel.init(ExtendedInternationalAccessor accessor) 拡張国際化モデルを初期化します。
void | ExtendedGenericInternationalModel.init(ExtendedInternationalAccessor accessor) 拡張国際化モデルを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap の使用

ExtendedInternationalAccessorMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での ExtendedInternationalAccessorMap の使用

ExtendedInternationalAccessorMap を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 ExtendedInternationalAccessorMap InternationalAccessor.getExtendedInternationalAccessorMap()
この国際化アクセサに対する拡張国際化アクセサのマップを取得します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedInternationalAccessorMap の使用

ExtendedInternationalAccessorMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void ExtendedGenericInternationalModelMap.init(ExtendedInternationalAccessorMap accessorMap)
初期化を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor の使用

ExtendedTerminableAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での ExtendedTerminableAccessor の使用

ExtendedTerminableAccessor を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
ExtendedTerminableAccessor | ExtendedTerminableAccessorMap.createExtendedTerminableAccessor(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を生成します。
ExtendedTerminableAccessor | ExtendedTerminableAccessorMap.findExtendedTerminableAccessor(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を取得します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedTerminableAccessor の使用

ExtendedTerminableAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | ExtendedTerminableModel.init(ExtendedTerminableAccessor accessor) 拡張期間化モデルを初期化します。
void | ExtendedGenericTerminableModel.init(ExtendedTerminableAccessor accessor) 拡張期間化モデルを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap の使用

ExtendedTerminableAccessorMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での ExtendedTerminableAccessorMap の使用

ExtendedTerminableAccessorMap を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 ExtendedTerminableAccessorMap TerminableAccessor.getExtendedTerminableAccessorMap()
この期間化アクセサに対する拡張期間化アクセサのマップを取得します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedTerminableAccessorMap の使用

ExtendedTerminableAccessorMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void ExtendedGenericTerminableModelMap.init(ExtendedTerminableAccessorMap accessorMap)
初期化を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor の使用

ExtendedTerminableInternationalAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での ExtendedTerminableInternationalAccessor の使用

ExtendedTerminableInternationalAccessor を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
ExtendedTerminableInternationalAccessor | ExtendedTerminableInternationalAccessorMap.createExtendedTerminableInternationalAccessor(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を生成します。
ExtendedTerminableInternationalAccessor | ExtendedTerminableInternationalAccessorMap.findExtendedTerminableInternationalAccessor(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を取得します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedTerminableInternationalAccessor の使用

ExtendedTerminableInternationalAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | ExtendedTerminableInternationalModel.init(ExtendedTerminableInternationalAccessor accessor) 拡張期間国際化モデルを初期化します。
void | ExtendedGenericTerminableInternationalModel.init(ExtendedTerminableInternationalAccessor accessor) 拡張期間国際化モデルを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap の使用

ExtendedTerminableInternationalAccessorMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での ExtendedTerminableInternationalAccessorMap の使用

ExtendedTerminableInternationalAccessorMap を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 ExtendedTerminableInternationalAccessorMap TerminableInternationalAccessor.getExtendedTerminableInternationalAccessorMap()
この期間国際化アクセサの拡張期間国際化アクセサのマップを取得します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedTerminableInternationalAccessorMap の使用

ExtendedTerminableInternationalAccessorMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void ExtendedGenericTerminableInternationalModelMap.init(ExtendedTerminableInternationalAccessorMap accessorMap)
初期化を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor の使用

InternationalAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での InternationalAccessor の使用

InternationalAccessor を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
InternationalAccessor | InternationalAccessorMap.createInternationalAccessor(Locale locale) 国際化アクセサを生成します。
InternationalAccessor | InternationalAccessorMap.findInternationalAccessor(Locale locale) 指定された言語に該当する国際化アクセサを取得します。
InternationalAccessor | ExtendedInternationalAccessor.getInternationalAccessor() 拡張もととなる国際化アクセサを取得します。

jp.co.intra_mart.foundation.datastore.common.model での InternationalAccessor の使用

InternationalAccessor を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
InternationalAccessor | InternationalModelContext.getInternationalAccessor() 国際化アクセサを取得します。
protected InternationalAccessor | GenericInternationalModel.getInternationalAccessor() この国際化モデルに割り当てられた国際化アクセサを取得します。

InternationalAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void InternationalModelContext.setInternationalAccessor(InternationalAccessor accessor)
国際化アクセサを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap の使用

InternationalAccessorMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での InternationalAccessorMap の使用

InternationalAccessorMap を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 InternationalAccessorMap BaseAccessor.getInternationalAccessorMap()
基本アクセサに関連する国際化アクセサのマップを取得します。

jp.co.intra_mart.foundation.datastore.common.model での InternationalAccessorMap の使用

InternationalAccessorMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void GenericInternationalModelMap.init(String modelName, InternationalAccessorMap accessorMap)
初期化処理を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor の使用

TerminableAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での TerminableAccessor の使用

TerminableAccessor を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
TerminableAccessor | TerminableInternationalAccessor.getTerminableAccessor() この期間国際化アクセサが所属する期間化アクセサを取得します。
TerminableAccessor | TerminableAccessorMap.createTerminableAccessor(Term term) 指定した期間に期間化アクセサを生成します。
TerminableAccessor | TerminableAccessorMap.findTerminableAccessor(Date date) 指定された日付に該当する期間化アクセサを取得します。
TerminableAccessor | ExtendedTerminableAccessor.getTerminableAccessor() 拡張もととなる期間化アクセサを取得します。

jp.co.intra_mart.foundation.datastore.common.model での TerminableAccessor の使用

TerminableAccessor を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableAccessor | TerminableModelContext.getTerminableAccessor() 期間化アクセサを取得します。
protected TerminableAccessor | GenericTerminableModel.getTerminableAccessor() この期間化モデルに割り当てられた期間化アクセサを取得します。

TerminableAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void TerminableModelContext.setTerminableAccessor(TerminableAccessor accessor)
期間化アクセサを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap の使用

TerminableAccessorMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での TerminableAccessorMap の使用

TerminableAccessorMap を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 TerminableAccessorMap BaseAccessor.getTerminableAccessorMap()
基本アクセサに関連する期間化アクセサのマップを取得します。

jp.co.intra_mart.foundation.datastore.common.model での TerminableAccessorMap の使用

TerminableAccessorMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void GenericTerminableModelMap.init(String terminableName, String terminableInternationalName, TerminableAccessorMap accessorMap, Locale defaultLocale)
初期化処理を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor の使用

TerminableInternationalAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での TerminableInternationalAccessor の使用

TerminableInternationalAccessor を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
TerminableInternationalAccessor | TerminableInternationalAccessorMap.createTerminableInternationalAccessor(Locale locale) 期間国際化アクセサを生成します。
TerminableInternationalAccessor | TerminableInternationalAccessorMap.findTerminableInternationalAccessor(Locale locale) 指定された言語に該当する期間国際化アクセサを取得します。
TerminableInternationalAccessor | ExtendedTerminableInternationalAccessor.getTerminableInternationalAccessor() 拡張もととなる期間国際化アクセサを取得します。

jp.co.intra_mart.foundation.datastore.common.model での TerminableInternationalAccessor の使用

TerminableInternationalAccessor を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableInternationalAccessor | TerminableInternationalModelContext.getTerminableInternationalAccessor() 期間国際化アクセサを取得します。
protected TerminableInternationalAccessor | GenericTerminableInternationalModel.getTerminableInternationalAccessor() この期間国際化モデルに割り当てられた期間国際化アクセサを取得します。

TerminableInternationalAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void TerminableInternationalModelContext.setTerminableInternationalAccessor(TerminableInternationalAccessor accessor)
期間国際化アクセサを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap の使用

TerminableInternationalAccessorMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での TerminableInternationalAccessorMap の使用

TerminableInternationalAccessorMap を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 TerminableInternationalAccessorMap TerminableAccessor.getTerminableInternationalAccessorMap()
この期間化アクセサに対する期間国際化アクセサのマップを取得します。

jp.co.intra_mart.foundation.datastore.common.model での TerminableInternationalAccessorMap の使用

TerminableInternationalAccessorMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void GenericTerminableInternationalModelMap.init(String modelName, TerminableInternationalAccessorMap accessorMap)
初期化処理を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BaseAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース BaseAccessor

すべてのスーパーインタフェース:
Serializable
public interface BaseAccessor
extends Serializable

基本エンティティに対する情報操作用のインタフェースです。 このクラスを通じて実際の基本エンティティに反映されます。

クローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • setProperty(String, Object)

導入されたバージョン:
5.0

メソッドの概要
Entity | getEntity() アクセサの基となるエンティティを取得します。
ExtendedBaseAccessorMap | getExtendedBaseAccessorMap() 基本アクセサに関連する拡張基本アクセサのマップを取得します。
InternationalAccessorMap | getInternationalAccessorMap() 基本アクセサに関連する国際化アクセサのマップを取得します。
Object | getProperty(String prop) プロパティを取得します。
TerminableAccessorMap | getTerminableAccessorMap() 基本アクセサに関連する期間化アクセサのマップを取得します。
boolean | isClosed() このアクセサがクローズされた状態かどうかを確認します。
void | setClosed() このアクセサをクローズします。
void | setProperty(String prop, Object value) プロパティを設定します。

メソッドの詳細

getEntity

public Entity getEntity()
アクセサの基となるエンティティを取得します。

戻り値:
アクセサの基となるエンティティ

getInternationalAccessorMap

public InternationalAccessorMap getInternationalAccessorMap()
基本アクセサに関連する国際化アクセサのマップを取得します。

戻り値:
国際化アクセサのマップ

getTerminableAccessorMap

public TerminableAccessorMap getTerminableAccessorMap()
基本アクセサに関連する期間化アクセサのマップを取得します。

戻り値:
期間化アクセサのマップ

getExtendedBaseAccessorMap

public ExtendedBaseAccessorMap getExtendedBaseAccessorMap()
基本アクセサに関連する拡張基本アクセサのマップを取得します。

戻り値:
拡張基本アクセサのマップ

getProperty

public Object getProperty(String prop)
                   throws DataNotFoundException
プロパティを取得します。

パラメータ:
prop - プロパティ名
戻り値:
プロパティの値
例外:
DataNotFoundException - 検索時に取得していないプロパティが指定された場合

setProperty

public void setProperty(String prop,
                        Object value)
                 throws AccessorClosedException,
                        AccessorIllegalPropertyValueException
プロパティを設定します。

パラメータ:
prop - プロパティ名
value - プロパティの値
例外:
AccessorIllegalPropertyValueException - プロパティの値が不正な場合
AccessorClosedException - アクセサがすでにクローズされている場合

isClosed

public boolean isClosed()
このアクセサがクローズされた状態かどうかを確認します。 アクセサが一度クローズされている場合、以下のメソッドを使用してデータを設定することはできません。
  • setProperty(String, Object)

戻り値:
クローズされている場合 true 、そうでなければ false
関連項目:
setClosed()

setClosed

public void setClosed()
このアクセサをクローズします。

関連項目:
isClosed()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedBaseAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース ExtendedBaseAccessor

すべてのスーパーインタフェース:
Serializable
public interface ExtendedBaseAccessor
extends Serializable

拡張基本エンティティに対する情報操作用のインタフェースです。 このクラスを通じて実際の拡張基本エンティティに反映されます。

拡張元となる基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • setProperty(String, Object)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
BaseAccessor | getBaseAccessor() 拡張元となる基本エンティティの基本アクセサを取得します。
Object | getProperty(String prop) プロパティを取得します。
void | setProperty(String prop, Object value) プロパティを設定します。

メソッドの詳細

getBaseAccessor

public BaseAccessor getBaseAccessor()
拡張元となる基本エンティティの基本アクセサを取得します。

戻り値:
基本アクセサ

getProperty

public Object getProperty(String prop)
                   throws DataNotFoundException
プロパティを取得します。

パラメータ:
prop - プロパティ情報
戻り値:
プロパティの値
例外:
DataNotFoundException - 検索時に取得していないプロパティが指定された場合

setProperty

public void setProperty(String prop,
                        Object value)
                 throws AccessorClosedException,
                        AccessorIllegalPropertyValueException
プロパティを設定します。

パラメータ:
prop - プロパティ情報
value - プロパティの値
例外:
AccessorIllegalPropertyValueException - プロパティの値が不正な場合
AccessorClosedException - アクセサがすでにクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedBaseAccessorMap (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース ExtendedBaseAccessorMap

public interface ExtendedBaseAccessorMap

拡張基本アクセサのマッピング情報を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedBaseAccessor | createExtendedBaseAccessor(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を生成します。
ExtendedBaseAccessor | findExtendedBaseAccessor(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を取得します。
void | remove(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を削除します。

メソッドの詳細

createExtendedBaseAccessor

public ExtendedBaseAccessor createExtendedBaseAccessor(String name)
                                                throws IllegalExtensionException,
                                                       AccessorClosedException
拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を生成します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

パラメータ:
name - 拡張名
戻り値:
拡張基本アクセサ
例外:
IllegalExtensionException - 存在しない拡張名、または基本属性を持たない拡張名が指定された場合
AccessorClosedException - 基本アクセサがクローズされている場合

findExtendedBaseAccessor

public ExtendedBaseAccessor findExtendedBaseAccessor(String name)
                                              throws IllegalExtensionException
拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を取得します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張アクセサが生成されていない場合は null を返します。

パラメータ:
name - 拡張名
戻り値:
拡張基本アクセサ
例外:
IllegalExtensionException - 存在しない拡張名、または基本属性を持たない拡張名が指定された場合

remove

public void remove(String name)
            throws AccessorClosedException
拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を削除します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張アクセサが生成されていない場合は何もしません。

パラメータ:
name - 拡張名
例外:
AccessorClosedException - 基本アクセサがクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedInternationalAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース ExtendedInternationalAccessor

すべてのスーパーインタフェース:
Serializable
public interface ExtendedInternationalAccessor
extends Serializable

拡張国際化エンティティに対する情報操作用のインタフェースです。 このクラスを通じて実際の拡張国際化エンティティに反映されます。

拡張もととなる基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • setProperty(String, Object)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
InternationalAccessor | getInternationalAccessor() 拡張もととなる国際化アクセサを取得します。
Object | getProperty(String prop) プロパティを取得します。
void | setProperty(String prop, Object value) プロパティを設定します。

メソッドの詳細

getInternationalAccessor

public InternationalAccessor getInternationalAccessor()
拡張もととなる国際化アクセサを取得します。

戻り値:
国際化アクセサ

getProperty

public Object getProperty(String prop)
                   throws DataNotFoundException
プロパティを取得します。

パラメータ:
prop - プロパティ情報
戻り値:
プロパティの値
例外:
DataNotFoundException - 検索時に取得していないプロパティが指定された場合

setProperty

public void setProperty(String prop,
                        Object value)
                 throws AccessorClosedException,
                        AccessorIllegalPropertyValueException
プロパティを設定します。

パラメータ:
prop - プロパティ情報
value - プロパティの値
例外:
AccessorIllegalPropertyValueException - プロパティの値が不正な場合
AccessorClosedException - アクセサがすでにクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedInternationalAccessorMap (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース ExtendedInternationalAccessorMap

public interface ExtendedInternationalAccessorMap

拡張国際アクセサのマッピング情報を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedInternationalAccessor | createExtendedInternationalAccessor(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を生成します。
ExtendedInternationalAccessor | findExtendedInternationalAccessor(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を取得します。
void | remove(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を削除します。

メソッドの詳細

createExtendedInternationalAccessor

public ExtendedInternationalAccessor createExtendedInternationalAccessor(String name)
                                                                  throws IllegalExtensionException,
                                                                         AccessorClosedException
拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を生成します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

パラメータ:
name - 拡張名
戻り値:
拡張国際化アクセサ
例外:
IllegalExtensionException - 存在しない拡張名、国際化属性を持たない拡張名が指定された場合
AccessorClosedException - 基本アクセサがクローズされている場合

findExtendedInternationalAccessor

public ExtendedInternationalAccessor findExtendedInternationalAccessor(String name)
                                                                throws IllegalExtensionException
拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を取得します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張アクセサが生成されていない場合は null を返します。

パラメータ:
name - 拡張名
戻り値:
拡張国際化アクセサ
例外:
IllegalExtensionException - 存在しない拡張名、国際化属性を持たない拡張名が指定された場合

remove

public void remove(String name)
            throws AccessorClosedException
拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を削除します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張アクセサが生成されていない場合は何もしません。

パラメータ:
name - 拡張名
例外:
AccessorClosedException - 基本アクセサがクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース ExtendedTerminableAccessor

すべてのスーパーインタフェース:
Serializable
public interface ExtendedTerminableAccessor
extends Serializable

拡張期間化エンティティに対する情報操作用のインタフェースです。 このクラスを通じて実際の拡張期間化エンティティに反映されます。

拡張もととなる基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • setProperty(String, Object)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
Object | getProperty(String prop) プロパティを取得します。
TerminableAccessor | getTerminableAccessor() 拡張もととなる期間化アクセサを取得します。
void | setProperty(String prop, Object value) プロパティを設定します。

メソッドの詳細

getTerminableAccessor

public TerminableAccessor getTerminableAccessor()
拡張もととなる期間化アクセサを取得します。

戻り値:
期間化アクセサ

getProperty

public Object getProperty(String prop)
                   throws DataNotFoundException
プロパティを取得します。

パラメータ:
prop - プロパティ情報
戻り値:
プロパティの値
例外:
DataNotFoundException - 検索時に取得していないプロパティが指定された場合

setProperty

public void setProperty(String prop,
                        Object value)
                 throws AccessorClosedException,
                        AccessorIllegalPropertyValueException
プロパティを設定します。

パラメータ:
prop - プロパティ情報
value - プロパティの値
例外:
AccessorIllegalPropertyValueException - プロパティの値が不正な場合
AccessorClosedException - アクセサがすでにクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableAccessorMap (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース ExtendedTerminableAccessorMap

public interface ExtendedTerminableAccessorMap

拡張期間化アクセサのマッピング情報を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedTerminableAccessor | createExtendedTerminableAccessor(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を生成します。
ExtendedTerminableAccessor | findExtendedTerminableAccessor(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を取得します。
void | remove(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を削除します。

メソッドの詳細

createExtendedTerminableAccessor

public ExtendedTerminableAccessor createExtendedTerminableAccessor(String name)
                                                            throws IllegalExtensionException,
                                                                   AccessorClosedException
拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を生成します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

パラメータ:
name - 拡張名
戻り値:
拡張期間化アクセサ
例外:
IllegalExtensionException - 存在しない拡張名、または期間化属性を持たない拡張名が指定された場合
AccessorClosedException - 基本アクセサがクローズされている場合

findExtendedTerminableAccessor

public ExtendedTerminableAccessor findExtendedTerminableAccessor(String name)
                                                          throws IllegalExtensionException
拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を取得します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張アクセサが生成されていない場合は null を返します。

パラメータ:
name - 拡張名
戻り値:
拡張期間化アクセサ
例外:
IllegalExtensionException - 存在しない拡張名、または期間化属性を持たない拡張名が指定された場合

remove

public void remove(String name)
            throws AccessorClosedException
拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を削除します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張アクセサが生成されていない場合は何もしません。

パラメータ:
name - 拡張名
例外:
AccessorClosedException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableInternationalAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース ExtendedTerminableInternationalAccessor

public interface ExtendedTerminableInternationalAccessor

拡張期間国際化エンティティに対する情報操作用のインタフェースです。 このクラスを通じて実際の拡張期間国際化エンティティに反映されます。

拡張もととなる基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • setProperty(String, Object)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
Object | getProperty(String prop) プロパティを取得します。
TerminableInternationalAccessor | getTerminableInternationalAccessor() 拡張もととなる期間国際化アクセサを取得します。
void | setProperty(String prop, Object value) プロパティを設定します。

メソッドの詳細

getTerminableInternationalAccessor

public TerminableInternationalAccessor getTerminableInternationalAccessor()
拡張もととなる期間国際化アクセサを取得します。

戻り値:
期間国際化アクセサ

getProperty

public Object getProperty(String prop)
                   throws DataNotFoundException
プロパティを取得します。

パラメータ:
prop - プロパティ情報
戻り値:
プロパティの値
例外:
DataNotFoundException - 検索時に取得していないプロパティが指定された場合

setProperty

public void setProperty(String prop,
                        Object value)
                 throws AccessorClosedException,
                        AccessorIllegalPropertyValueException
プロパティを設定します。

パラメータ:
prop - プロパティ情報
value - プロパティの値
例外:
AccessorIllegalPropertyValueException - プロパティの値が不正な場合
AccessorClosedException - アクセサがすでにクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableInternationalAccessorMap (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース ExtendedTerminableInternationalAccessorMap

public interface ExtendedTerminableInternationalAccessorMap

拡張期間国際化アクセサのマッピング情報を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedTerminableInternationalAccessor | createExtendedTerminableInternationalAccessor(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を生成します。
ExtendedTerminableInternationalAccessor | findExtendedTerminableInternationalAccessor(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を取得します。
void | remove(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を削除します。

メソッドの詳細

createExtendedTerminableInternationalAccessor

public ExtendedTerminableInternationalAccessor createExtendedTerminableInternationalAccessor(String name)
                                                                                throws IllegalExtensionException,
                                                                                AccessorClosedException
拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を生成します。 拡張アクセサを指定するための拡張名には、「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

パラメータ:
name - 拡張名
戻り値:
拡張期間国際化アクセサ
例外:
IllegalExtensionException - 存在しない拡張名、期間国際化属性を持たない拡張名が指定された場合
AccessorClosedException - 基本アクセサがクローズされている場合

findExtendedTerminableInternationalAccessor

public ExtendedTerminableInternationalAccessor findExtendedTerminableInternationalAccessor(String name)
                                                                                throws IllegalExtensionException
拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を取得します。 拡張アクセサを指定するための拡張名には、「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張アクセサが生成されていない場合は null を返します。

パラメータ:
name - 拡張名
戻り値:
拡張期間国際化アクセサ
例外:
IllegalExtensionException - 存在しない拡張名、期間国際化属性を持たない拡張名が指定された場合

remove

public void remove(String name)
            throws AccessorClosedException
拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を削除します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張アクセサが生成されていない場合は何もしません。

パラメータ:
name - 拡張名
例外:
AccessorClosedException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース InternationalAccessor

すべてのスーパーインタフェース:
Serializable
public interface InternationalAccessor
extends Serializable

国際化エンティティに対する情報操作用のインタフェースです。 このクラスを通じて実際の国際化エンティティに反映されます。

基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • setProperty(String, Object)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
BaseAccessor | getBaseAccessor() この国際化アクセサが所属する基本アクセサを取得します。
ExtendedInternationalAccessorMap | getExtendedInternationalAccessorMap() この国際化アクセサに対する拡張国際化アクセサのマップを取得します。
Locale | getLocale() ロケールを取得します。
Object | getProperty(String prop) プロパティを取得します。
void | setProperty(String prop, Object value) プロパティを設定します。

メソッドの詳細

getBaseAccessor

public BaseAccessor getBaseAccessor()
この国際化アクセサが所属する基本アクセサを取得します。

戻り値:
基本アクセサ

getLocale

public Locale getLocale()
ロケールを取得します。

戻り値:
ロケール

getExtendedInternationalAccessorMap

public ExtendedInternationalAccessorMap getExtendedInternationalAccessorMap()
この国際化アクセサに対する拡張国際化アクセサのマップを取得します。

戻り値:
拡張国際化アクセサのマップ

getProperty

public Object getProperty(String prop)
                   throws DataNotFoundException
プロパティを取得します。

パラメータ:
prop - プロパティ名
戻り値:
プロパティの値
例外:
DataNotFoundException - 検索時に取得していないプロパティが指定された場合

setProperty

public void setProperty(String prop,
                        Object value)
                 throws AccessorClosedException,
                        AccessorIllegalPropertyValueException
プロパティを設定します。

パラメータ:
prop - プロパティ名
value - プロパティの値
例外:
AccessorIllegalPropertyValueException - プロパティの値が不正な場合
AccessorClosedException - アクセサがすでにクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalAccessorMap (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース InternationalAccessorMap

public interface InternationalAccessorMap

国際化アクセサのマッピング情報を持ちます。 システムで定義された言語に対応する情報のみを持ちます。 所属する基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • createInternationalAccessor(Locale)
  • remove(Locale)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
InternationalAccessor | createInternationalAccessor(Locale locale) 国際化アクセサを生成します。
InternationalAccessor | findInternationalAccessor(Locale locale) 指定された言語に該当する国際化アクセサを取得します。
Locale[] | getLocales() 現在管理している言語の一覧を取得します。
void | remove(Locale locale) 指定された言語に該当するデータを削除します。

メソッドの詳細

createInternationalAccessor

public InternationalAccessor createInternationalAccessor(Locale locale)
                                                  throws IllegalLocaleException,
                                                         AccessorClosedException
国際化アクセサを生成します。 引数で指定された言語に該当する既存の情報は新しい情報で上書きされます。 システムで取り扱う言語のみが対象となります。

パラメータ:
locale - 言語
戻り値:
国際化アクセサ
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
AccessorClosedException - 基本アクセサがクローズされている場合、例外を返す

findInternationalAccessor

public InternationalAccessor findInternationalAccessor(Locale locale)
                                                throws IllegalLocaleException
指定された言語に該当する国際化アクセサを取得します。 引数 locale で指定された言語に該当する InternationalAccessor を取得します。該当するものが存在しない場合、 null が返されます。

パラメータ:
locale - 対象となる言語
戻り値:
対象となる期間化アクセサ（存在しない場合は null）
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合

remove

public void remove(Locale locale)
            throws IllegalLocaleException,
                   AccessorClosedException
指定された言語に該当するデータを削除します。

パラメータ:
locale - 削除対象の言語
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
AccessorClosedException - 基本アクセサがクローズされている場合、例外を返す

getLocales

public Locale[] getLocales()
現在管理している言語の一覧を取得します。 もし、管理している言語がない時は空の配列を返します。

戻り値:
管理している言語の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.common.accessor (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース
BaseAccessor
ExtendedBaseAccessor
ExtendedBaseAccessorMap
ExtendedInternationalAccessor
ExtendedInternationalAccessorMap
ExtendedTerminableAccessor
ExtendedTerminableAccessorMap
ExtendedTerminableInternationalAccessor
ExtendedTerminableInternationalAccessorMap
InternationalAccessor
InternationalAccessorMap
TerminableAccessor
TerminableAccessorMap
TerminableInternationalAccessor
TerminableInternationalAccessorMap


jp.co.intra_mart.foundation.datastore.common.accessor (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.common.accessor

情報を扱うためのアクセサを提供します。

参照:
説明

インタフェースの概要
BaseAccessor | 基本エンティティに対する情報操作用のインタフェースです。
ExtendedBaseAccessor | 拡張基本エンティティに対する情報操作用のインタフェースです。
ExtendedBaseAccessorMap | 拡張基本アクセサのマッピング情報を持ちます。
ExtendedInternationalAccessor | 拡張国際化エンティティに対する情報操作用のインタフェースです。
ExtendedInternationalAccessorMap | 拡張国際アクセサのマッピング情報を持ちます。
ExtendedTerminableAccessor | 拡張期間化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableAccessorMap | 拡張期間化アクセサのマッピング情報を持ちます。
ExtendedTerminableInternationalAccessor | 拡張期間国際化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableInternationalAccessorMap | 拡張期間国際化アクセサのマッピング情報を持ちます。
InternationalAccessor | 国際化エンティティに対する情報操作用のインタフェースです。
InternationalAccessorMap | 国際化アクセサのマッピング情報を持ちます。
TerminableAccessor | 期間化エンティティに対する情報操作用のインタフェースです。
TerminableAccessorMap | 期間化アクセサのマッピング情報を持ちます。
TerminableInternationalAccessor | 期間国際化エンティティに対する情報操作用のインタフェースです。
TerminableInternationalAccessorMap | 期間国際化アクセサのマッピング情報を持ちます。

パッケージ jp.co.intra_mart.foundation.datastore.common.accessor の説明

情報を扱うためのアクセサを提供します。


jp.co.intra_mart.foundation.datastore.common.accessor クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.common.accessor の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap


パッケージ jp.co.intra_mart.foundation.datastore.common.accessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.common.accessor の使用

jp.co.intra_mart.foundation.datastore.common.accessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor により使用される jp.co.intra_mart.foundation.datastore.common.accessor のクラス
BaseAccessor
基本エンティティに対する情報操作用のインタフェースです。
ExtendedBaseAccessor
拡張基本エンティティに対する情報操作用のインタフェースです。
ExtendedBaseAccessorMap
拡張基本アクセサのマッピング情報を持ちます。
ExtendedInternationalAccessor
拡張国際化エンティティに対する情報操作用のインタフェースです。
ExtendedInternationalAccessorMap
拡張国際アクセサのマッピング情報を持ちます。
ExtendedTerminableAccessor
拡張期間化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableAccessorMap
拡張期間化アクセサのマッピング情報を持ちます。
ExtendedTerminableInternationalAccessor
拡張期間国際化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableInternationalAccessorMap
拡張期間国際化アクセサのマッピング情報を持ちます。
InternationalAccessor
国際化エンティティに対する情報操作用のインタフェースです。
InternationalAccessorMap
国際化アクセサのマッピング情報を持ちます。
TerminableAccessor
期間化エンティティに対する情報操作用のインタフェースです。
TerminableAccessorMap
期間化アクセサのマッピング情報を持ちます。
TerminableInternationalAccessor
期間国際化エンティティに対する情報操作用のインタフェースです。
TerminableInternationalAccessorMap
期間国際化アクセサのマッピング情報を持ちます。

jp.co.intra_mart.foundation.datastore.common.model により使用される jp.co.intra_mart.foundation.datastore.common.accessor のクラス
BaseAccessor
基本エンティティに対する情報操作用のインタフェースです。
ExtendedBaseAccessor
拡張基本エンティティに対する情報操作用のインタフェースです。
ExtendedBaseAccessorMap
拡張基本アクセサのマッピング情報を持ちます。
ExtendedInternationalAccessor
拡張国際化エンティティに対する情報操作用のインタフェースです。
ExtendedInternationalAccessorMap
拡張国際アクセサのマッピング情報を持ちます。
ExtendedTerminableAccessor
拡張期間化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableAccessorMap
拡張期間化アクセサのマッピング情報を持ちます。
ExtendedTerminableInternationalAccessor
拡張期間国際化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableInternationalAccessorMap
拡張期間国際化アクセサのマッピング情報を持ちます。
InternationalAccessor
国際化エンティティに対する情報操作用のインタフェースです。
InternationalAccessorMap
国際化アクセサのマッピング情報を持ちます。
TerminableAccessor
期間化エンティティに対する情報操作用のインタフェースです。
TerminableAccessorMap
期間化アクセサのマッピング情報を持ちます。
TerminableInternationalAccessor
期間国際化エンティティに対する情報操作用のインタフェースです。
TerminableInternationalAccessorMap
期間国際化アクセサのマッピング情報を持ちます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


TerminableAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース TerminableAccessor

すべてのスーパーインタフェース:
Serializable
public interface TerminableAccessor
extends Serializable

期間化エンティティに対する情報操作用のインタフェースです。 このクラスを通じて実際の期間化エンティティに反映されます。

基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • setProperty(String, Object)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
BaseAccessor | getBaseAccessor() この期間化アクセサが所属する基本アクセサを取得します。
ExtendedTerminableAccessorMap | getExtendedTerminableAccessorMap() この期間化アクセサに対する拡張期間化アクセサのマップを取得します。
Object | getProperty(String prop) プロパティを取得します。
Term | getTerm() 期間を取得します。
String | getTermCode() 期間CDを取得します。
TerminableInternationalAccessorMap | getTerminableInternationalAccessorMap() この期間化アクセサに対する期間国際化アクセサのマップを取得します。
void | setProperty(String prop, Object value) プロパティを設定します。

メソッドの詳細

getBaseAccessor

public BaseAccessor getBaseAccessor()
この期間化アクセサが所属する基本アクセサを取得します。

戻り値:
基本アクセサ

getTerm

public Term getTerm()
期間を取得します。

戻り値:
期間

getTermCode

public String getTermCode()
期間CDを取得します。

戻り値:
期間CD

getTerminableInternationalAccessorMap

public TerminableInternationalAccessorMap getTerminableInternationalAccessorMap()
この期間化アクセサに対する期間国際化アクセサのマップを取得します。

戻り値:
期間国際化アクセサのマップ

getExtendedTerminableAccessorMap

public ExtendedTerminableAccessorMap getExtendedTerminableAccessorMap()
この期間化アクセサに対する拡張期間化アクセサのマップを取得します。

戻り値:
拡張期間化アクセサのマップ

getProperty

public Object getProperty(String prop)
                   throws DataNotFoundException
プロパティを取得します。

パラメータ:
prop - プロパティ名
戻り値:
プロパティの値
例外:
DataNotFoundException - 検索時に取得していないプロパティが指定された場合

setProperty

public void setProperty(String prop,
                        Object value)
                 throws AccessorClosedException,
                        AccessorIllegalPropertyValueException
プロパティを設定します。

パラメータ:
prop - プロパティ名
value - プロパティの値
例外:
AccessorIllegalPropertyValueException - プロパティの値が不正な場合
AccessorClosedException - アクセサがすでにクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableAccessorMap (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース TerminableAccessorMap

public interface TerminableAccessorMap

期間化アクセサのマッピング情報を持ちます。 所属する基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • createTerminableAccessor(Term)
  • remove(Term)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
TerminableAccessor | createTerminableAccessor(Term term) 指定した期間に期間化アクセサを生成します。
TerminableAccessor | findTerminableAccessor(Date date) 指定された日付に該当する期間化アクセサを取得します。
Term[] | getTerms() 現在管理している期間の一覧を取得します。
Map | remove(Term term) 指定された期間に該当するデータを削除します。

メソッドの詳細

createTerminableAccessor

public TerminableAccessor createTerminableAccessor(Term term)
                                            throws IllegalTermException,
                                                   AccessorClosedException
指定した期間に期間化アクセサを生成します。 生成した期間化アクセサによって重複する期間が発生する場合、例外を返す

パラメータ:
term - 期間
戻り値:
期間アクセサ
例外:
IllegalTermException - 生成した期間化アクセサによって重複する期間が発生する場合、例外を返す
AccessorClosedException - 基本アクセサがクローズされている場合、例外を返す

findTerminableAccessor

public TerminableAccessor findTerminableAccessor(Date date)
指定された日付に該当する期間化アクセサを取得します。 引数 date で指定された日付を期間内に含む TerminableAccessor を取得します。該当するものが存在しない場合、 null が返されます。

パラメータ:
date - 対象となる日付
戻り値:
対象となる期間化アクセサ（存在しない場合は null）

remove

public Map remove(Term term)
           throws AccessorClosedException
指定された期間に該当するデータを削除します。 削除対象の期間に該当するデータがなくなるよう、既存のデータの有効開始日時や有効終了日時は調整されます。
削除対象の期間に該当するデータを持つ TerminableAccessorがキー、 削除に伴い新たに作成された期間に該当するデータを持つ TerminableAccessorの Collection が値のマップを返します。 （新規に作成された TerminableAccessorがない時は、値には 空の Collection）

パラメータ:
term - 削除対象の期間
戻り値:
map 削除された TerminableAccessorをキー、削除に伴って新規に作成された TerminableAccessorを値とするマップを返す
例外:
AccessorClosedException - 基本アクセサがクローズされている場合、例外を返す

getTerms

public Term[] getTerms()
現在管理している期間の一覧を取得します。 返される期間は期間の早い物から遅い物の順位並んでいる必要があります。 もし、管理している期間の管理がない時は空の配列を返します。

戻り値:
現在管理している期間の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableInternationalAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース TerminableInternationalAccessor

すべてのスーパーインタフェース:
Serializable
public interface TerminableInternationalAccessor
extends Serializable

期間国際化エンティティに対する情報操作用のインタフェースです。 このクラスを通じて実際の期間国際化エンティティに反映されます。

基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • setProperty(String, Object)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
ExtendedTerminableInternationalAccessorMap | getExtendedTerminableInternationalAccessorMap() この期間国際化アクセサの拡張期間国際化アクセサのマップを取得します。
Locale | getLocale() ロケールを取得します。
Object | getProperty(String prop) プロパティを取得します。
TerminableAccessor | getTerminableAccessor() この期間国際化アクセサが所属する期間化アクセサを取得します。
void | setProperty(String prop, Object value) プロパティを設定します。

メソッドの詳細

getLocale

public Locale getLocale()
ロケールを取得します。

戻り値:
ロケール

getTerminableAccessor

public TerminableAccessor getTerminableAccessor()
この期間国際化アクセサが所属する期間化アクセサを取得します。

戻り値:
期間化アクセサ

getExtendedTerminableInternationalAccessorMap

public ExtendedTerminableInternationalAccessorMap getExtendedTerminableInternationalAccessorMap()
この期間国際化アクセサの拡張期間国際化アクセサのマップを取得します。

戻り値:
拡張期間化アクセサのマップ

getProperty

public Object getProperty(String prop)
                   throws DataNotFoundException
プロパティを取得します。

パラメータ:
prop - プロパティ名
戻り値:
プロパティの値
例外:
DataNotFoundException - 検索時に取得していないプロパティが指定された場合

setProperty

public void setProperty(String prop,
                        Object value)
                 throws AccessorClosedException,
                        AccessorIllegalPropertyValueException
プロパティを設定します。

パラメータ:
prop - プロパティ名
value - プロパティの値
例外:
AccessorIllegalPropertyValueException - プロパティの値が不正な場合
AccessorClosedException - アクセサがすでにクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableInternationalAccessorMap (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース TerminableInternationalAccessorMap

public interface TerminableInternationalAccessorMap

期間国際化アクセサのマッピング情報を持ちます。 システムで定義された言語に対応する情報のみを持ちます。 所属する基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • createTerminableInternationalAccessor(Locale)
  • remove(Locale)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
TerminableInternationalAccessor | createTerminableInternationalAccessor(Locale locale) 期間国際化アクセサを生成します。
TerminableInternationalAccessor | findTerminableInternationalAccessor(Locale locale) 指定された言語に該当する期間国際化アクセサを取得します。
Locale[] | getLocales() 現在管理している言語の一覧を取得します。
void | remove(Locale locale) 指定された言語に該当するデータを削除します。

メソッドの詳細

createTerminableInternationalAccessor

public TerminableInternationalAccessor createTerminableInternationalAccessor(Locale locale)
                                                                      throws IllegalLocaleException,
                                                                             AccessorClosedException
期間国際化アクセサを生成します。 引数で指定された言語に該当する既存の情報は新しい情報で上書きされます。 システムで取り扱う言語のみが対象となります。

パラメータ:
locale - 言語
戻り値:
期間国際化アクセサ
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
AccessorClosedException - 基本アクセサがクローズされている場合、例外を返す

findTerminableInternationalAccessor

public TerminableInternationalAccessor findTerminableInternationalAccessor(Locale locale)
                                                                    throws IllegalLocaleException
指定された言語に該当する期間国際化アクセサを取得します。 引数 locale で指定された言語に該当する TerminableInternationalAccessorを取得します。該当するものが存在しない場合、 null が返されます。

パラメータ:
locale - 対象となる言語
戻り値:
対象となる期間国際化アクセサ（存在しない場合は null）
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合

remove

public void remove(Locale locale)
            throws IllegalLocaleException,
                   AccessorClosedException
指定された言語に該当するデータを削除します。

パラメータ:
locale - 削除対象の言語
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
AccessorClosedException - 基本アクセサがクローズされている場合、例外を返す

getLocales

public Locale[] getLocales()
現在管理している言語の一覧を取得します。 管理している言語がない時は、空の配列を返します。

戻り値:
現在管理している言語の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ActivationKey の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ActivationKey の使用

ActivationKey を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ActivationKey の使用

ActivationKey を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ActivationKey Relationship.getActivationKey()
ソースエンティティのライフタイム期間の有効開始日時を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Application の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Application の使用

Application を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での Application の使用

Application を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
Application | Table.getApplication() テーブルを定義しているアプリケーションを取得します。
Application | Relationship.getApplication() リレーションシップが定義されているアプリケーションを取得します。
Application | Model.getApplication() モデルを定義しているアプリケーションを取得します。
Application | ExtendedTable.getApplication() 拡張テーブルを定義しているアプリケーションを取得します。
Application | ExtendedModel.getApplication() 拡張モデルを定義しているアプリケーションを取得します。
Application | ExtendedEntity.getApplication() 拡張エンティティを定義しているアプリケーションを取得します。
Application | Entity.getApplication() エンティティを定義しているアプリケーションを取得します。
Application | Configuration.getApplication(String name) 指定された名前に該当するアプリケーションを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Attribute の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Attribute の使用

Attribute を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での Attribute の使用

Attribute を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
Attribute | UpdateInfo.getUpdateUser() エンティティの更新ユーザとなる属性を取得します。
Attribute | UpdateInfo.getUpdateTimestamp() エンティティの更新日付となる属性を取得します。
Attribute | TerminableKey.getAttribute() 期間化基準項目となる属性を取得します。
Attribute[] | Relationship.getForeignKeys() ソースエンティティの外部キーの集合を取得します。
Attribute | Property.getAttribute() プロパティに対応付ける属性を取得します。
Attribute | PrimaryKeyMapping.getAttribute() プライマリーキーとなる属性を取得します。
Attribute[] | Lifetime.getNullKeys() ターゲットエンティティの期間削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。
Attribute | InternationalKey.getAttribute() 国際化基準項目となる属性を取得します。
Attribute | ExpirationKey.getAttribute() ライフタイム期間の有効終了日時となる属性を取得します。
Attribute[] | Entity.getPrimaryKeys() エンティティのプライマリキーとなる属性をすべて取得します。
Attribute[] | Delete.getNullKeys() ターゲットエンティティのデータ削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。
Attribute | ColumnMapping.getAttribute() カラムに割り当てる属性を取得します。
Attribute | Column.getAttribute() カラムに対応付ける属性を取得します。
Attribute | ActivationKey.getAttribute() ライフタイム期間の有効開始日時となる属性を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.config.AttributeType の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.config.AttributeType の使用

AttributeType を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での AttributeType の使用

AttributeType として宣言されている jp.co.intra_mart.foundation.datastore.common.config のフィールド
static AttributeType | AttributeType.STRING 文字列型
static AttributeType | AttributeType.DECIMAL 整数型
static AttributeType | AttributeType.DATE 日時型
static AttributeType | AttributeType.FLOAT 浮動少数型
static AttributeType | AttributeType.LOCALE ロケール

AttributeType を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 AttributeType Attribute.getType()
属性の型を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.BaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.BaseModel の使用

BaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での BaseModel の使用

BaseModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 BaseModel Model.getBaseModel()
基本モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.BaseTable の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.BaseTable の使用

BaseTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での BaseTable の使用

BaseTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 BaseTable Table.getBaseTable()
基本テーブルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Column の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Column の使用

jp.co.intra_mart.foundation.datastore.common.config.Column はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping の使用

jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Configuration の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Configuration の使用

Configuration を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での Configuration の使用

Configuration を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
abstract  Configuration ConfigurationFactory.createConfiguration()
Configurationを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory の使用

ConfigurationFactory を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ConfigurationFactory の使用

ConfigurationFactory を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
static ConfigurationFactory ConfigurationFactory.getInstance()
ConfigurationFactoryのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Delete の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Delete の使用

Delete を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での Delete の使用

Delete を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 Delete Relationship.getDelete()
ターゲットエンティティのデータ削除時の整合性制約を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.config.DeleteType の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.config.DeleteType の使用

DeleteType を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での DeleteType の使用

DeleteType として宣言されている jp.co.intra_mart.foundation.datastore.common.config のフィールド
static DeleteType | DeleteType.CASCADE 削除 ターゲットエンティティのデータを参照しているソースエンティティのデータを削除します。
static DeleteType | DeleteType.NULL Null ターゲットエンティティのデータを参照しているソースエンティティの外部キーをnullにします。
static DeleteType | DeleteType.EXCEPTION 例外 例外を発生させます。

DeleteType を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 DeleteType Delete.getDeleteType()
ターゲットエンティティの削除時の整合性制約のタイプを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Entity の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Entity の使用

Entity を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.config | アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での Entity の使用

Entity を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 Entity BaseAccessor.getEntity()
アクセサの基となるエンティティを取得します。

jp.co.intra_mart.foundation.datastore.common.config での Entity の使用

Entity を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
Entity | TerminableKey.getSourceEntity() 期間化基準項目の基点となるソースエンティティの情報を取得します。
Entity | Table.getEntity() テーブル定義の基となるエンティティを取得します。
Entity | Relationship.getSourceEntity() ソースエンティティの情報を取得します。
Entity | Relationship.getTargetEntity() ターゲットエンティティの情報を取得します。
Entity | Model.getEntity() モデル定義の基となるエンティティを取得します。
Entity | InternationalKey.getSourceEntity() 国際化基準項目の基点となるソースエンティティの情報を取得します。
Entity | ExtendedEntity.getEntity() 拡張対象となるエンティティを取得します。
Entity | ExpirationKey.getSourceEntity() ライフタイム期間の有効終了日時の基点となるソースエンティティの情報を取得します。
Entity | Attribute.getEntity() 属性が定義されているエンティティを取得します。
Entity | ActivationKey.getSourceEntity() ライフタイム期間の有効開始日時の基点となるソースエンティティの情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey の使用

ExpirationKey を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExpirationKey の使用

ExpirationKey を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExpirationKey Relationship.getExpirationKey()
ソースエンティティのライフタイム期間の有効終了日時を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseModel の使用

ExtendedBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedBaseModel の使用

ExtendedBaseModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExtendedBaseModel ExtendedModel.getExtendedBaseModel()
拡張基本モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable の使用

ExtendedBaseTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedBaseTable の使用

ExtendedBaseTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExtendedBaseTable ExtendedTable.getExtendedBaseTable()
拡張基本テーブルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity の使用

ExtendedEntity を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedEntity の使用

ExtendedEntity を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
ExtendedEntity | ExtendedTable.getExtendedEntity() 拡張テーブル定義の基となる拡張エンティティを取得します。
ExtendedEntity | ExtendedModel.getExtendedEntity() 拡張モデル定義の基となる拡張エンティティを取得します。
ExtendedEntity | Attribute.getExtendedEntity() 属性が定義されている拡張エンティティを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalModel の使用

ExtendedInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedInternationalModel の使用

ExtendedInternationalModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExtendedInternationalModel ExtendedModel.getExtendedInternationalModel()
拡張国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable の使用

ExtendedInternationalTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedInternationalTable の使用

ExtendedInternationalTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExtendedInternationalTable ExtendedTable.getExtendedInternationalTable()
拡張国際化テーブルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel の使用

ExtendedModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedModel の使用

ExtendedModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
ExtendedModel | ExtendedTerminableModel.getExtendedModel() 拡張期間化モデルが定義されている拡張モデル定義を取得します。
ExtendedModel | ExtendedTerminableInternationalModel.getExtendedModel() 拡張期間国際化モデルが定義されている拡張モデル定義を取得します。
ExtendedModel | ExtendedInternationalModel.getExtendedModel() 拡張国際化モデルが定義されている拡張モデル定義を取得します。
ExtendedModel | ExtendedEntity.getExtendedModel() この拡張エンティティを参照している拡張モデルを取得します。
ExtendedModel | ExtendedBaseModel.getExtendedModel() 拡張基本モデルが定義されている拡張モデル定義を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable の使用

ExtendedTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedTable の使用

ExtendedTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
ExtendedTable | ExtendedTerminableTable.getExtendedTable() 拡張期間化テーブルが定義されている拡張テーブル定義を取得します。
ExtendedTable | ExtendedTerminableInternationalTable.getExtendedTable() 拡張期間国際化テーブルが定義されている拡張テーブル定義を取得します。
ExtendedTable | ExtendedInternationalTable.getExtendedTable() 拡張国際化テーブルが定義されている拡張テーブル定義を取得します。
ExtendedTable | ExtendedEntity.getExtendedTable() この拡張エンティティを参照している拡張テーブルを取得します。
ExtendedTable | ExtendedBaseTable.getExtendedTable() 拡張基本テーブルが定義されている拡張テーブル定義を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalModel の使用

ExtendedTerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedTerminableInternationalModel の使用

ExtendedTerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExtendedTerminableInternationalModel ExtendedModel.getExtendedTerminableInternationalModel()
拡張期間国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable の使用

ExtendedTerminableInternationalTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedTerminableInternationalTable の使用

ExtendedTerminableInternationalTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExtendedTerminableInternationalTable ExtendedTable.getExtendedTerminableInternationalTable()
拡張期間国際化テーブルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableModel の使用

ExtendedTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedTerminableModel の使用

ExtendedTerminableModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExtendedTerminableModel ExtendedModel.getExtendedTerminableModel()
拡張期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable の使用

ExtendedTerminableTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedTerminableTable の使用

ExtendedTerminableTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExtendedTerminableTable ExtendedTable.getExtendedTerminableTable()
拡張期間化テーブルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.InternationalKey の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.InternationalKey の使用

InternationalKey を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での InternationalKey の使用

InternationalKey を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 InternationalKey Relationship.getInternationalKey()
ソースエンティティの国際化基準項目を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.InternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.InternationalModel の使用

InternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での InternationalModel の使用

InternationalModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 InternationalModel Model.getInternationalModel()
国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.InternationalTable の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.InternationalTable の使用

InternationalTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での InternationalTable の使用

InternationalTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 InternationalTable Table.getInternationalTable()
国際化テーブルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Lifetime の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Lifetime の使用

Lifetime を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での Lifetime の使用

Lifetime を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 Lifetime Relationship.getLifetime()
ターゲットエンティティの期間削除時の整合性制約を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.config.LifetimeType の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.config.LifetimeType の使用

LifetimeType を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での LifetimeType の使用

LifetimeType として宣言されている jp.co.intra_mart.foundation.datastore.common.config のフィールド
static LifetimeType | LifetimeType.CASCADE 削除 ターゲットエンティティの期間を参照しているソースエンティティのデータを削除します。
static LifetimeType | LifetimeType.NULL Null ターゲットエンティティの期間を参照しているソースエンティティの外部キーをnullにします。
static LifetimeType | LifetimeType.EXCEPTION 例外 例外を発生させます。

LifetimeType を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 LifetimeType Lifetime.getLifetimeType()
ターゲットエンティティの期間削除時の整合性制約のタイプを取得します

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Model の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Model の使用

Model を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での Model の使用

Model を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
Model | TerminableModel.getModel() 期間化モデルが定義されているモデル定義を取得します。
Model | TerminableInternationalModel.getModel() 期間国際化モデルが定義されているモデル定義を取得します。
Model | InternationalModel.getModel() 国際化モデルが定義されているモデル定義を取得します。
Model | Entity.getModel() このエンティティを参照しているモデルを取得します。
Model | BaseModel.getModel() 基本モデルが定義されているモデル定義を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping の使用

jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Property の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Property の使用

jp.co.intra_mart.foundation.datastore.common.config.Property はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Relationship の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Relationship の使用

Relationship を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config | アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.config での Relationship の使用

Relationship を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
Relationship[] | TerminableKey.getRefereRelationships() ソースエンティティから期間化基準項目を持つエンティティまでのリレーションシップを取得します。
Relationship[] | InternationalKey.getRefereRelationships() ソースエンティティから国際化基準項目を持つエンティティまでのリレーションシップを取得します。
Relationship[] | ExpirationKey.getRefereRelationships() ソースエンティティから有効終了日時を持つエンティティまでのリレーションシップを取得します。
Relationship[] | ActivationKey.getRefereRelationships() ソースエンティティから有効開始日時を持つエンティティまでのリレーションシップを取得します。

jp.co.intra_mart.foundation.datastore.common.model での Relationship の使用

Relationship 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | Mapper.notifyUpdate(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
void | Mapper.notifyDelete(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
void | Mapper.checkByBaseProperty(Relationship[] relationships, BaseModel target, BaseModel base) 基準項目によるリレーションシップの整合性制約をチェックします。
protected Collection | IntramartDBMapper.select(Relationship relationship, Map keys) 外部キーで特定される基本モデルをすべて取得します。
void | IntramartDBMapper.notifyUpdate(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
void | IntramartDBMapper.notifyDelete(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
void | IntramartDBMapper.checkByBaseProperty(Relationship[] relationships, BaseModel target, BaseModel base) 基準項目によるリレーションシップの整合性制約をチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Table の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Table の使用

Table を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での Table の使用

Table を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
Table | TerminableTable.getTable() 期間化テーブルが定義されているテーブル定義を取得します。
Table | TerminableInternationalTable.getTable() 期間国際化テーブルが定義されているテーブル定義を取得します。
Table | InternationalTable.getTable() 国際化テーブルが定義されているテーブル定義を取得します。
Table | Entity.getTable() このエンティティを参照しているテーブルを取得します。
Table | BaseTable.getTable() 基本テーブルが定義されているテーブル定義を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalModel の使用

TerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での TerminableInternationalModel の使用

TerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 TerminableInternationalModel Model.getTerminableInternationalModel()
期間国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable の使用

TerminableInternationalTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での TerminableInternationalTable の使用

TerminableInternationalTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 TerminableInternationalTable Table.getTerminableInternationalTable()
期間国際化テーブルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.TerminableKey の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.TerminableKey の使用

TerminableKey を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での TerminableKey の使用

TerminableKey を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 TerminableKey Relationship.getTerminableKey()
ソースエンティティの期間化基準項目を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.TerminableModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.TerminableModel の使用

TerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での TerminableModel の使用

TerminableModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 TerminableModel Model.getTerminableModel()
期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.TerminableTable の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.TerminableTable の使用

TerminableTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での TerminableTable の使用

TerminableTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 TerminableTable Table.getTerminableTable()
期間化テーブルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.UpdateInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.UpdateInfo の使用

UpdateInfo を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での UpdateInfo の使用

UpdateInfo を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 UpdateInfo Entity.getUpdateInfo()
エンティティの更新情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ActivationKey (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ActivationKey

public interface ActivationKey

ライフタイム期間の有効開始日時を定義します。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getAttribute() ライフタイム期間の有効開始日時となる属性を取得します。
Relationship[] | getRefereRelationships() ソースエンティティから有効開始日時を持つエンティティまでのリレーションシップを取得します。
Entity | getSourceEntity() ライフタイム期間の有効開始日時の基点となるソースエンティティの情報を取得します。

メソッドの詳細

getSourceEntity

public Entity getSourceEntity()
ライフタイム期間の有効開始日時の基点となるソースエンティティの情報を取得します。

戻り値:
ソースエンティティの情報

getRefereRelationships

public Relationship[] getRefereRelationships()
ソースエンティティから有効開始日時を持つエンティティまでのリレーションシップを取得します。

戻り値:
ソースエンティティから有効開始日時を持つエンティティまでのリレーションシップ

getAttribute

public Attribute getAttribute()
ライフタイム期間の有効開始日時となる属性を取得します。

戻り値:
ライフタイム期間の有効開始日時となる属性
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Application (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Application

public interface Application

アプリケーションを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getEntities() アプリケーションで定義しているエンティティの一覧を取得します。
Map | getExtendedEntities() アプリケーションで定義している拡張エンティティの一覧を取得します。
Map | getExtendedModels() アプリケーションで定義している拡張モデル定義の一覧を取得します。
Map | getExtendedTables() アプリケーションで定義している拡張テーブル定義の一覧を取得します。
Map | getModels() アプリケーションで定義しているモデル定義の一覧を取得します。
String | getName() アプリケーション名を取得します。
Map | getRelationships() アプリケーションで定義しているリレーションシップの一覧を取得します。
Map | getTables() アプリケーションで定義しているテーブル定義の一覧を取得します。

メソッドの詳細

getName

public String getName()
アプリケーション名を取得します。

戻り値:
アプリケーション名

getEntities

public Map getEntities()
アプリケーションで定義しているエンティティの一覧を取得します。 エンティティ名をキー、 Entityを値としたマップを返します。

戻り値:
エンティティの一覧

getExtendedEntities

public Map getExtendedEntities()
アプリケーションで定義している拡張エンティティの一覧を取得します。 拡張名をキー、 ExtendedEntityを値としたマップを返します。

戻り値:
拡張エンティティの一覧

getRelationships

public Map getRelationships()
アプリケーションで定義しているリレーションシップの一覧を取得します。 リレーションシップ名をキー、 Relationshipを値としたマップを返します。

戻り値:
リレーションシップの一覧

getTables

public Map getTables()
アプリケーションで定義しているテーブル定義の一覧を取得します。 「テーブルの定義基となるエンティティが定義されているアプリケーション名　+ . + エンティティ名」 をキー、 Tableを値としたマップを返します。

例
エンティティが定義されているアプリケーション名：jp.co.intra_mart
エンティティ名：Entity
上記のようなときは「jp.co.intra_mart.Entity」がキーとなります。

戻り値:
テーブル定義の一覧

getExtendedTables

public Map getExtendedTables()
アプリケーションで定義している拡張テーブル定義の一覧を取得します。 「拡張テーブルの定義基となる拡張エンティティが定義されているアプリケーション名　+ . + 拡張名」 をキー、 ExtendedTableを値としたマップを返します。

例
拡張エンティティが定義されているアプリケーション名：jp.co.intra_mart
拡張名：ExtendedEntity
上記のようなときは「jp.co.intra_mart.ExtendedEntity」がキーとなります。

戻り値:
拡張テーブル定義の一覧

getModels

public Map getModels()
アプリケーションで定義しているモデル定義の一覧を取得します。 「モデルの定義基となるエンティティが定義されているアプリケーション名　+ . + エンティティ名」、 Modelを値としたマップを返します。

例
エンティティが定義されているアプリケーション名：jp.co.intra_mart
エンティティ名：Entity
上記のようなときは「jp.co.intra_mart.Entity」がキーとなります。

戻り値:
拡張テーブル定義の一覧

getExtendedModels

public Map getExtendedModels()
アプリケーションで定義している拡張モデル定義の一覧を取得します。 「拡張モデルの定義基となる拡張エンティティが定義されているアプリケーション名　+ . + 拡張名」 をキー、 ExtendedModelを値としたマップを返します。

例
拡張エンティティが定義されているアプリケーション名：jp.co.intra_mart
拡張名：ExtendedEntity
上記のようなときは「jp.co.intra_mart.ExtendedEntity」がキーとなります。

戻り値:
拡張モデル定義の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Attribute (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Attribute

public interface Attribute

属性を定義します。

導入されたバージョン:
5.0

メソッドの概要
Entity | getEntity() 属性が定義されているエンティティを取得します。
ExtendedEntity | getExtendedEntity() 属性が定義されている拡張エンティティを取得します。
String | getName() 属性名を取得します。
AttributeType | getType() 属性の型を取得します。
boolean | isInternational() 属性が国際化の対象であるかどうかを取得します。
boolean | isNullAcceptable() 属性にnullが設定可能であるかどうかを取得します。
boolean | isTerminable() 属性が期間化の対象であるかどうかを取得します。

メソッドの詳細

getName

public String getName()
属性名を取得します。

戻り値:
属性名

getType

public AttributeType getType()
属性の型を取得します。

戻り値:
属性の型

isTerminable

public boolean isTerminable()
属性が期間化の対象であるかどうかを取得します。

戻り値:
属性が期間化の対象である場合 true 、そうでない場合 false

isInternational

public boolean isInternational()
属性が国際化の対象であるかどうかを取得します。

戻り値:
属性が国際化の対象である場合 true 、そうでない場合 false

isNullAcceptable

public boolean isNullAcceptable()
属性にnullが設定可能であるかどうかを取得します。

戻り値:
属性にnullが設定が可能である場合 true 、そうでない場合 false

getEntity

public Entity getEntity()
属性が定義されているエンティティを取得します。

戻り値:
属性が定義されているエンティティ

getExtendedEntity

public ExtendedEntity getExtendedEntity()
属性が定義されている拡張エンティティを取得します。 属性が拡張エンティティに定義されていないとき null を返します。

戻り値:
属性が定義されている拡張エンティティ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AttributeType (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
クラス AttributeType

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.config.AttributeType
すべての実装インタフェース:
Serializable
public class AttributeType
extends Object
implements Serializable

属性で指定できる型です。

導入されたバージョン:
5.0
関連項目:
直列化された形式

フィールドの概要
static AttributeType | DATE 日時型
static AttributeType | DECIMAL 整数型
static AttributeType | FLOAT 浮動少数型
static AttributeType | LOCALE ロケール
static AttributeType | STRING 文字列型
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

STRING

public static final AttributeType STRING
文字列型

DECIMAL

public static final AttributeType DECIMAL
整数型

DATE

public static final AttributeType DATE
日時型

FLOAT

public static final AttributeType FLOAT
浮動少数型

LOCALE

public static final AttributeType LOCALE
ロケール

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース BaseModel

public interface BaseModel

基本モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
String | getClassName() 基本モデルのクラス名を取得します。
Model | getModel() 基本モデルが定義されているモデル定義を取得します。

メソッドの詳細

getModel

public Model getModel()
基本モデルが定義されているモデル定義を取得します。

戻り値:
基本モデルが定義されているモデル定義

getClassName

public String getClassName()
基本モデルのクラス名を取得します。

戻り値:
基本モデルのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BaseTable (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース BaseTable

public interface BaseTable

基本テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getColumnMappings() 基本テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
String | getName() 基本テーブルのテーブル名を取得します。
Table | getTable() 基本テーブルが定義されているテーブル定義を取得します。

メソッドの詳細

getTable

public Table getTable()
基本テーブルが定義されているテーブル定義を取得します。

戻り値:
基本テーブルが定義されているテーブル定義

getName

public String getName()
基本テーブルのテーブル名を取得します。

戻り値:
基本テーブルのテーブル名

getColumnMappings

public Map getColumnMappings()
基本テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。 属性名をキー、 ColumnMappingを値としたマップを返します。

戻り値:
基本テーブルに含まれるカラムマッピング
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Column (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Column

public interface Column

属性に対応するカラムの型を定義します。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getAttribute() カラムに対応付ける属性を取得します。
String | getType() カラムの型を取得します。

メソッドの詳細

getAttribute

public Attribute getAttribute()
カラムに対応付ける属性を取得します。

戻り値:
カラムに対応付ける属性

getType

public String getType()
カラムの型を取得します。

戻り値:
カラムの型
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ColumnMapping (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ColumnMapping

public interface ColumnMapping

分割されたテーブルに割り当てられるカラムを定義します。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getAttribute() カラムに割り当てる属性を取得します。
String | getName() カラム名を取得します。

メソッドの詳細

getAttribute

public Attribute getAttribute()
カラムに割り当てる属性を取得します。

戻り値:
カラムに割り当てる属性

getName

public String getName()
カラム名を取得します。

戻り値:
カラム名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Configuration (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Configuration

public interface Configuration

設定内容を取得します。

導入されたバージョン:
5.0

メソッドの概要
 Application getApplication(String name)
指定された名前に該当するアプリケーションを取得します。

メソッドの詳細

getApplication

public Application getApplication(String name)
指定された名前に該当するアプリケーションを取得します。

パラメータ:
name - アプリケーション名
戻り値:
指定された名前に該当するアプリケーション
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ConfigurationFactory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
クラス ConfigurationFactory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory
public abstract class ConfigurationFactory
extends Object

Configurationを生成します。

導入されたバージョン:
5.0

コンストラクタの概要
ConfigurationFactory()
メソッドの概要
abstract Configuration | createConfiguration() Configurationを生成します。
static ConfigurationFactory | getInstance() ConfigurationFactoryのインスタンスを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ConfigurationFactory

public ConfigurationFactory()
メソッドの詳細

getInstance

public static ConfigurationFactory getInstance()
ConfigurationFactoryのインスタンスを取得します。

戻り値:
ConfigurationFactory

createConfiguration

public abstract Configuration createConfiguration()
Configurationを生成します。

戻り値:
Configuration
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Delete (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Delete

public interface Delete

削除時の整合性制約です。 ターゲットエンティティの情報変更による整合性制約の内容です。

導入されたバージョン:
5.0

メソッドの概要
DeleteType | getDeleteType() ターゲットエンティティの削除時の整合性制約のタイプを取得します。
Attribute[] | getNullKeys() ターゲットエンティティのデータ削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。

メソッドの詳細

getDeleteType

public DeleteType getDeleteType()
ターゲットエンティティの削除時の整合性制約のタイプを取得します。

戻り値:
削除時の整合性制約のタイプ

getNullKeys

public Attribute[] getNullKeys()
ターゲットエンティティのデータ削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。

戻り値:
データ削除時の整合性制約の対象となる外部キー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DeleteType (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
クラス DeleteType

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.config.DeleteType
すべての実装インタフェース:
Serializable
public class DeleteType
extends Object
implements Serializable

削除時の整合性制約のタイプです。 ターゲットエンティティの情報変更による整合性制約のタイプです。

導入されたバージョン:
5.0
関連項目:
直列化された形式

フィールドの概要
static DeleteType | CASCADE 削除 ターゲットエンティティのデータを参照しているソースエンティティのデータを削除します。
static DeleteType | EXCEPTION 例外 例外を発生させます。
static DeleteType | NULL Null ターゲットエンティティのデータを参照しているソースエンティティの外部キーをnullにします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

CASCADE

public static final DeleteType CASCADE
削除 ターゲットエンティティのデータを参照しているソースエンティティのデータを削除します。

NULL

public static final DeleteType NULL
Null ターゲットエンティティのデータを参照しているソースエンティティの外部キーをnullにします。

EXCEPTION

public static final DeleteType EXCEPTION
例外 例外を発生させます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Entity (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Entity

public interface Entity

エンティティを定義します。

導入されたバージョン:
5.0

メソッドの概要
Application | getApplication() エンティティを定義しているアプリケーションを取得します。
Map | getAttributes() エンティティに含まれる属性をすべて取得します。
Map | getExtendedEntities() このエンティティを拡張している拡張エンティティをすべて取得します。
Model | getModel() このエンティティを参照しているモデルを取得します。
String | getName() エンティティ名を取得します。
Attribute[] | getPrimaryKeys() エンティティのプライマリキーとなる属性をすべて取得します。
Map | getReferedRelationships() このエンティティの属性を、国際化基準項目や期間化基準項目などを使用して参照している全てのリレーションシップを取得します。
Map | getSourceRelationships() このエンティティをソースとしているリレーションシップをすべて取得します。
Table | getTable() このエンティティを参照しているテーブルを取得します。
Map | getTargetRelationships() このエンティティをターゲットとしているリレーションシップをすべて取得します。
UpdateInfo | getUpdateInfo() エンティティの更新情報を取得します。
boolean | isInternational() エンティティが国際化の対象であるかどうかを取得します。
boolean | isTerminable() エンティティが期間化の対象であるかどうかを取得します。
boolean | isTerminableInternational() エンティティが期間国際化の対象であるかどうかを取得します。

メソッドの詳細

getApplication

public Application getApplication()
エンティティを定義しているアプリケーションを取得します。

戻り値:
エンティティを定義しているアプリケーション

getAttributes

public Map getAttributes()
エンティティに含まれる属性をすべて取得します。 属性名をキー、 Attributeを値としたマップを返します。

戻り値:
エンティティに含まれる属性

getName

public String getName()
エンティティ名を取得します。

戻り値:
エンティティ名

getPrimaryKeys

public Attribute[] getPrimaryKeys()
エンティティのプライマリキーとなる属性をすべて取得します。 ここで取得される属性は、 getAttributes()で取得される配列の部分集合になります。 また、配列の順番はプライマリキーとして定義された順番になります。

戻り値:
プライマリキーとなる属性

getUpdateInfo

public UpdateInfo getUpdateInfo()
エンティティの更新情報を取得します。 存在しない場合はnullを返します。

戻り値:
エンティティの更新情報

isTerminable

public boolean isTerminable()
エンティティが期間化の対象であるかどうかを取得します。

戻り値:
属性が期間化の対象である場合 true 、そうでない場合 false

isInternational

public boolean isInternational()
エンティティが国際化の対象であるかどうかを取得します。

戻り値:
属性が国際化の対象である場合 true 、そうでない場合 false

isTerminableInternational

public boolean isTerminableInternational()
エンティティが期間国際化の対象であるかどうかを取得します。

戻り値:
エンティティが期間国際化の対象である場合 true 、そうでない場合 false

getExtendedEntities

public Map getExtendedEntities()
このエンティティを拡張している拡張エンティティをすべて取得します。 「拡張エンティティが定義されているアプリケーション名 + . + 拡張名」 をキー、 ExtendedEntity を値としたマップを返します。

例
拡張エンティティが定義されているアプリケーション名：jp.co.intra_mart
拡張名：ExtendedEntity
上記のようなときは「jp.co.intra_mart.ExtendedEntity」がキーとなります。

戻り値:
拡張エンティティ一覧

getTable

public Table getTable()
このエンティティを参照しているテーブルを取得します。
このエンティティを参照しているテーブルが存在しないときは null を返します。

戻り値:
このエンティティを参照しているテーブル

getModel

public Model getModel()
このエンティティを参照しているモデルを取得します。

戻り値:
このエンティティを参照しているモデル

getSourceRelationships

public Map getSourceRelationships()
このエンティティをソースとしているリレーションシップをすべて取得します。 「リレーションシップが定義されているアプリケーション名 + . + リレーションシップ名」 をキー、 Relationship を値としたマップを返します。

例
リレーションシップが定義されているアプリケーション名：jp.co.intra_mart
リレーションシップ名：Relationship1
上記のようなときは「jp.co.intra_mart.Relationship1」がキーとなります。

戻り値:
このエンティティをソースとしているリレーションシップ

getTargetRelationships

public Map getTargetRelationships()
このエンティティをターゲットとしているリレーションシップをすべて取得します。 「リレーションシップが定義されているアプリケーション名 + . + リレーションシップ名」 をキー、 Relationship を値としたマップを返します。

例
リレーションシップが定義されているアプリケーション名：jp.co.intra_mart
リレーションシップ名：Relationship1
上記のようなときは「jp.co.intra_mart.Relationship1」がキーとなります。

戻り値:
このエンティティをターゲットとしているリレーションシップをすべて取得します。

getReferedRelationships

public Map getReferedRelationships()
このエンティティの属性を、国際化基準項目や期間化基準項目などを使用して参照している全てのリレーションシップを取得します。
ただし、このエンティティがソースとなるリレーションシップは取得対象となりません。 「リレーションシップが定義されているアプリケーション名 + . + リレーションシップ名」 をキー、 Relationship を値としたマップを返します。

例
リレーションシップが定義されているアプリケーション名：jp.co.intra_mart
リレーションシップ名：Relationship1
上記のようなときは「jp.co.intra_mart.Relationship1」がキーとなります。

戻り値:
このエンティティの属性を、国際化基準項目や期間化基準項目などを使用して参照している全てのリレーションシップを取得します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExpirationKey (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExpirationKey

public interface ExpirationKey

ライフタイム期間の有効終了日時を定義します。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getAttribute() ライフタイム期間の有効終了日時となる属性を取得します。
Relationship[] | getRefereRelationships() ソースエンティティから有効終了日時を持つエンティティまでのリレーションシップを取得します。
Entity | getSourceEntity() ライフタイム期間の有効終了日時の基点となるソースエンティティの情報を取得します。

メソッドの詳細

getSourceEntity

public Entity getSourceEntity()
ライフタイム期間の有効終了日時の基点となるソースエンティティの情報を取得します。

戻り値:
ソースエンティティの情報

getRefereRelationships

public Relationship[] getRefereRelationships()
ソースエンティティから有効終了日時を持つエンティティまでのリレーションシップを取得します。

戻り値:
ソースエンティティから有効終了日時を持つエンティティまでのリレーションシップ

getAttribute

public Attribute getAttribute()
ライフタイム期間の有効終了日時となる属性を取得します。

戻り値:
ライフタイム期間の有効終了日時となる属性
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedBaseModel

public interface ExtendedBaseModel

拡張基本モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
String | getClassName() 拡張基本モデルのクラス名を取得します。
ExtendedModel | getExtendedModel() 拡張基本モデルが定義されている拡張モデル定義を取得します。

メソッドの詳細

getExtendedModel

public ExtendedModel getExtendedModel()
拡張基本モデルが定義されている拡張モデル定義を取得します。

戻り値:
拡張基本モデルが定義されている拡張モデル定義

getClassName

public String getClassName()
拡張基本モデルのクラス名を取得します。

戻り値:
拡張基本モデルのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedBaseTable (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedBaseTable

public interface ExtendedBaseTable

拡張基本テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getColumnMappings() 拡張基本テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
ExtendedTable | getExtendedTable() 拡張基本テーブルが定義されている拡張テーブル定義を取得します。
String | getName() 拡張基本テーブルのテーブル名を取得します。
Map | getPrimaryKeyMappings() 拡張基本テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。

メソッドの詳細

getExtendedTable

public ExtendedTable getExtendedTable()
拡張基本テーブルが定義されている拡張テーブル定義を取得します。

戻り値:
拡張基本テーブルが定義されている拡張テーブル定義

getName

public String getName()
拡張基本テーブルのテーブル名を取得します。

戻り値:
拡張基本テーブルのテーブル名

getColumnMappings

public Map getColumnMappings()
拡張基本テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。 属性名をキー、 ColumnMappingを値としたマップを返します。

戻り値:
拡張基本テーブルに含まれるカラムマッピング

getPrimaryKeyMappings

public Map getPrimaryKeyMappings()
拡張基本テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。 属性名をキー、 PrimaryKeyMappingを値としたマップを返します。

戻り値:
拡張基本テーブルに含まれるプライマリキーマッピング
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedEntity (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedEntity

public interface ExtendedEntity

拡張エンティティを定義します。

導入されたバージョン:
5.0

メソッドの概要
Application | getApplication() 拡張エンティティを定義しているアプリケーションを取得します。
Map | getAttributes() 拡張エンティティに含まれる属性をすべて取得します。
Entity | getEntity() 拡張対象となるエンティティを取得します。
ExtendedModel | getExtendedModel() この拡張エンティティを参照している拡張モデルを取得します。
ExtendedTable | getExtendedTable() この拡張エンティティを参照している拡張テーブルを取得します。
String | getName() 拡張名を取得します。
boolean | hasBaseAttributes() 拡張エンティティが期間化も国際化もされていない従属属性を持つかどうか判定します。
boolean | hasInternationalAttributes() 拡張エンティティが国際化のみされている従属属性を持つかどうか判定します。
boolean | hasTerminableAttributes() 拡張エンティティが期間化のみされている従属属性を持つかどうか判定します。
boolean | hasTerminableInternationalAttributes() 拡張エンティティが期間国際化されている従属属性を持つかどうか判定します。

メソッドの詳細

getApplication

public Application getApplication()
拡張エンティティを定義しているアプリケーションを取得します。

戻り値:
拡張エンティティを定義しているアプリケーション

getAttributes

public Map getAttributes()
拡張エンティティに含まれる属性をすべて取得します。 属性名をキー、 Attributeを値としたマップを返します。

戻り値:
拡張エンティティに含まれる属性

getName

public String getName()
拡張名を取得します。

戻り値:
拡張名

getEntity

public Entity getEntity()
拡張対象となるエンティティを取得します。

戻り値:
拡張対象となるエンティティ

getExtendedTable

public ExtendedTable getExtendedTable()
この拡張エンティティを参照している拡張テーブルを取得します。
この拡張エンティティを参照している拡張テーブルが存在しないときは null を返します。

戻り値:
この拡張エンティティを参照している拡張テーブル

getExtendedModel

public ExtendedModel getExtendedModel()
この拡張エンティティを参照している拡張モデルを取得します。
この拡張エンティティを参照している拡張モデルが存在しないときは null を返します。

戻り値:
この拡張エンティティを参照している拡張モデル

hasBaseAttributes

public boolean hasBaseAttributes()
拡張エンティティが期間化も国際化もされていない従属属性を持つかどうか判定します。

戻り値:
期間化も国際化もされていない従属属性を持つときは、 true 、そうでない場合 false

hasTerminableAttributes

public boolean hasTerminableAttributes()
拡張エンティティが期間化のみされている従属属性を持つかどうか判定します。

戻り値:
期間化のみされている従属属性を持つ場合は true 、そうでない場合 false

hasInternationalAttributes

public boolean hasInternationalAttributes()
拡張エンティティが国際化のみされている従属属性を持つかどうか判定します。

戻り値:
国際化のみされている従属属性を持つ場合は true 、そうでない場合 false

hasTerminableInternationalAttributes

public boolean hasTerminableInternationalAttributes()
拡張エンティティが期間国際化されている従属属性を持つかどうか判定します。

戻り値:
期間国際化されている従属属性を持つ場合は true 、そうでない場合 false
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedInternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedInternationalModel

public interface ExtendedInternationalModel

拡張国際化モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
String | getClassName() 拡張国際化モデルのクラス名を取得します。
ExtendedModel | getExtendedModel() 拡張国際化モデルが定義されている拡張モデル定義を取得します。

メソッドの詳細

getExtendedModel

public ExtendedModel getExtendedModel()
拡張国際化モデルが定義されている拡張モデル定義を取得します。

戻り値:
拡張国際化モデルが定義されている拡張モデル定義

getClassName

public String getClassName()
拡張国際化モデルのクラス名を取得します。

戻り値:
拡張国際化モデルのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedInternationalTable (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedInternationalTable

public interface ExtendedInternationalTable

拡張国際化テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getColumnMappings() 拡張国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
ExtendedTable | getExtendedTable() 拡張国際化テーブルが定義されている拡張テーブル定義を取得します。
String | getLocaleColumnName() ロケールに該当するカラムのカラム名を取得します。
String | getName() 拡張国際化テーブルのテーブル名を取得します。
Map | getPrimaryKeyMappings() 拡張国際化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。

メソッドの詳細

getExtendedTable

public ExtendedTable getExtendedTable()
拡張国際化テーブルが定義されている拡張テーブル定義を取得します。

戻り値:
拡張国際化テーブルが定義されている拡張テーブル定義

getName

public String getName()
拡張国際化テーブルのテーブル名を取得します。

戻り値:
拡張国際化テーブルのテーブル名

getColumnMappings

public Map getColumnMappings()
拡張国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。 属性名をキー、 ColumnMappingを値としたマップを返します。

戻り値:
拡張国際化テーブルに含まれるカラムマッピング

getLocaleColumnName

public String getLocaleColumnName()
ロケールに該当するカラムのカラム名を取得します。

戻り値:
カラム名

getPrimaryKeyMappings

public Map getPrimaryKeyMappings()
拡張国際化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。 属性名をキー、 PrimaryKeyMappingを値としたマップを返します。

戻り値:
拡張国際化テーブルに含まれるプライマリキーマッピング
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedModel

public interface ExtendedModel

拡張モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Application | getApplication() 拡張モデルを定義しているアプリケーションを取得します。
ExtendedBaseModel | getExtendedBaseModel() 拡張基本モデルを取得します。
ExtendedEntity | getExtendedEntity() 拡張モデル定義の基となる拡張エンティティを取得します。
ExtendedInternationalModel | getExtendedInternationalModel() 拡張国際化モデルを取得します。
ExtendedTerminableInternationalModel | getExtendedTerminableInternationalModel() 拡張期間国際化モデルを取得します。
ExtendedTerminableModel | getExtendedTerminableModel() 拡張期間化モデルを取得します。
Map | getProperties() 拡張モデルに含まれるプロパティをすべて取得します。

メソッドの詳細

getApplication

public Application getApplication()
拡張モデルを定義しているアプリケーションを取得します。

戻り値:
拡張モデルを定義しているアプリケーション

getExtendedEntity

public ExtendedEntity getExtendedEntity()
拡張モデル定義の基となる拡張エンティティを取得します。

戻り値:
拡張モデル定義の基となる拡張エンティティ

getProperties

public Map getProperties()
拡張モデルに含まれるプロパティをすべて取得します。 属性名をキー、 Propertyを値としたマップを返します。

戻り値:
拡張モデルに含まれるプロパティ

getExtendedBaseModel

public ExtendedBaseModel getExtendedBaseModel()
拡張基本モデルを取得します。 拡張基本モデルが使用されない場合、 null が返されます。

戻り値:
拡張基本モデル

getExtendedInternationalModel

public ExtendedInternationalModel getExtendedInternationalModel()
拡張国際化モデルを取得します。 拡張国際化モデルが使用されない場合、 null が返されます。

戻り値:
拡張国際化モデル

getExtendedTerminableModel

public ExtendedTerminableModel getExtendedTerminableModel()
拡張期間化モデルを取得します。 拡張期間化モデルが使用されない場合、 null が返されます。

戻り値:
拡張期間化モデル

getExtendedTerminableInternationalModel

public ExtendedTerminableInternationalModel getExtendedTerminableInternationalModel()
拡張期間国際化モデルを取得します。 拡張期間国際化モデルが使用されない場合、 null が返されます。

戻り値:
拡張期間国際化モデル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTable (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedTable

public interface ExtendedTable

拡張テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Application | getApplication() 拡張テーブルを定義しているアプリケーションを取得します。
Map | getColumns() 拡張テーブルに含まれるカラムをすべて取得します。
ExtendedBaseTable | getExtendedBaseTable() 拡張基本テーブルを取得します。
ExtendedEntity | getExtendedEntity() 拡張テーブル定義の基となる拡張エンティティを取得します。
ExtendedInternationalTable | getExtendedInternationalTable() 拡張国際化テーブルを取得します。
ExtendedTerminableInternationalTable | getExtendedTerminableInternationalTable() 拡張期間国際化テーブルを取得します。
ExtendedTerminableTable | getExtendedTerminableTable() 拡張期間化テーブルを取得します。

メソッドの詳細

getApplication

public Application getApplication()
拡張テーブルを定義しているアプリケーションを取得します。

戻り値:
拡張テーブルを定義しているアプリケーション

getExtendedEntity

public ExtendedEntity getExtendedEntity()
拡張テーブル定義の基となる拡張エンティティを取得します。

戻り値:
拡張テーブル定義の基となる拡張エンティティ

getColumns

public Map getColumns()
拡張テーブルに含まれるカラムをすべて取得します。 属性名をキー、 Columnを値としたマップを返します。

戻り値:
拡張テーブルに含まれるカラム

getExtendedBaseTable

public ExtendedBaseTable getExtendedBaseTable()
拡張基本テーブルを取得します。 拡張基本テーブルが定義されていない場合、 null が返されます。

戻り値:
拡張基本テーブル

getExtendedInternationalTable

public ExtendedInternationalTable getExtendedInternationalTable()
拡張国際化テーブルを取得します。 拡張国際化テーブルが定義されていない場合、 null が返されます。

戻り値:
拡張国際化テーブル

getExtendedTerminableTable

public ExtendedTerminableTable getExtendedTerminableTable()
拡張期間化テーブルを取得します。 拡張期間化テーブルが定義されていない場合、 null が返されます。

戻り値:
拡張期間化テーブル

getExtendedTerminableInternationalTable

public ExtendedTerminableInternationalTable getExtendedTerminableInternationalTable()
拡張期間国際化テーブルを取得します。 拡張期間国際化テーブルが定義されていない場合、 null が返されます。

戻り値:
拡張期間国際化テーブル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableInternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedTerminableInternationalModel

public interface ExtendedTerminableInternationalModel

拡張期間国際化モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
String | getClassName() 拡張期間国際化モデルのクラス名を取得します。
ExtendedModel | getExtendedModel() 拡張期間国際化モデルが定義されている拡張モデル定義を取得します。

メソッドの詳細

getExtendedModel

public ExtendedModel getExtendedModel()
拡張期間国際化モデルが定義されている拡張モデル定義を取得します。

戻り値:
拡張期間国際化モデルが定義されている拡張モデル定義

getClassName

public String getClassName()
拡張期間国際化モデルのクラス名を取得します。

戻り値:
拡張期間国際化モデルのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableInternationalTable (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedTerminableInternationalTable

public interface ExtendedTerminableInternationalTable

拡張期間国際化テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getColumnMappings() 拡張期間国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
ExtendedTable | getExtendedTable() 拡張期間国際化テーブルが定義されている拡張テーブル定義を取得します。
String | getLocaleColumnName() ロケールに該当するカラムのカラム名を取得します。
String | getName() 拡張期間国際化テーブルのテーブル名を取得します。
Map | getPrimaryKeyMappings() 拡張期間国際化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。
String | getTermColumnName() 期間CDに該当するカラムのカラム名を取得します。

メソッドの詳細

getExtendedTable

public ExtendedTable getExtendedTable()
拡張期間国際化テーブルが定義されている拡張テーブル定義を取得します。

戻り値:
拡張期間国際化テーブルが定義されている拡張テーブル定義

getName

public String getName()
拡張期間国際化テーブルのテーブル名を取得します。

戻り値:
拡張期間国際化テーブルのテーブル名

getColumnMappings

public Map getColumnMappings()
拡張期間国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。 属性名をキー、 ColumnMappingを値としたマップを返します。

戻り値:
拡張期間国際化テーブルに含まれるカラムマッピング

getTermColumnName

public String getTermColumnName()
期間CDに該当するカラムのカラム名を取得します。

戻り値:
カラム名

getLocaleColumnName

public String getLocaleColumnName()
ロケールに該当するカラムのカラム名を取得します。

戻り値:
カラム名

getPrimaryKeyMappings

public Map getPrimaryKeyMappings()
拡張期間国際化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。 属性名をキー、 PrimaryKeyMappingを値としたマップを返します。

戻り値:
拡張期間国際化テーブルに含まれるプライマリキーマッピング
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedTerminableModel

public interface ExtendedTerminableModel

拡張期間化モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
String | getClassName() 拡張期間化モデルのクラス名を取得します。
ExtendedModel | getExtendedModel() 拡張期間化モデルが定義されている拡張モデル定義を取得します。

メソッドの詳細

getExtendedModel

public ExtendedModel getExtendedModel()
拡張期間化モデルが定義されている拡張モデル定義を取得します。

戻り値:
拡張期間化モデルが定義されている拡張モデル定義

getClassName

public String getClassName()
拡張期間化モデルのクラス名を取得します。

戻り値:
拡張期間化モデルのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableTable (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedTerminableTable

public interface ExtendedTerminableTable

拡張期間化テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getColumnMappings() 拡張期間化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
ExtendedTable | getExtendedTable() 拡張期間化テーブルが定義されている拡張テーブル定義を取得します。
String | getName() 拡張期間化テーブルのテーブル名を取得します。
Map | getPrimaryKeyMappings() 拡張期間化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。
String | getTermColumnName() 期間CDに該当するカラムのカラム名を取得します。

メソッドの詳細

getExtendedTable

public ExtendedTable getExtendedTable()
拡張期間化テーブルが定義されている拡張テーブル定義を取得します。

戻り値:
拡張期間化テーブルが定義されている拡張テーブル定義

getName

public String getName()
拡張期間化テーブルのテーブル名を取得します。

戻り値:
拡張期間化テーブルのテーブル名

getColumnMappings

public Map getColumnMappings()
拡張期間化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。 属性名をキー、 ColumnMappingを値としたマップを返します。

戻り値:
拡張期間化テーブルに含まれるカラムマッピング

getTermColumnName

public String getTermColumnName()
期間CDに該当するカラムのカラム名を取得します。

戻り値:
カラム名

getPrimaryKeyMappings

public Map getPrimaryKeyMappings()
拡張期間化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。 属性名をキー、 PrimaryKeyMappingを値としたマップを返します。

戻り値:
拡張期間化テーブルに含まれるプライマリキーマッピング
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalKey (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース InternationalKey

public interface InternationalKey

国際化基準項目を定義します。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getAttribute() 国際化基準項目となる属性を取得します。
Relationship[] | getRefereRelationships() ソースエンティティから国際化基準項目を持つエンティティまでのリレーションシップを取得します。
Entity | getSourceEntity() 国際化基準項目の基点となるソースエンティティの情報を取得します。

メソッドの詳細

getSourceEntity

public Entity getSourceEntity()
国際化基準項目の基点となるソースエンティティの情報を取得します。

戻り値:
ソースエンティティの情報

getRefereRelationships

public Relationship[] getRefereRelationships()
ソースエンティティから国際化基準項目を持つエンティティまでのリレーションシップを取得します。

戻り値:
ソースエンティティから国際化基準項目を持つエンティティまでのリレーションシップ

getAttribute

public Attribute getAttribute()
国際化基準項目となる属性を取得します。

戻り値:
国際化基準項目となる属性
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース InternationalModel

public interface InternationalModel

国際化モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
String | getClassName() 国際化モデルのクラス名を取得します。
Model | getModel() 国際化モデルが定義されているモデル定義を取得します。

メソッドの詳細

getModel

public Model getModel()
国際化モデルが定義されているモデル定義を取得します。

戻り値:
国際化モデルが定義されているモデル定義

getClassName

public String getClassName()
国際化モデルのクラス名を取得します。

戻り値:
国際化モデルのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalTable (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース InternationalTable

public interface InternationalTable

国際化テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getColumnMappings() 国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
String | getLocaleColumnName() ロケールに該当するカラムのカラム名を取得します。
String | getName() 国際化テーブルのテーブル名を取得します。
Table | getTable() 国際化テーブルが定義されているテーブル定義を取得します。

メソッドの詳細

getTable

public Table getTable()
国際化テーブルが定義されているテーブル定義を取得します。

戻り値:
国際化テーブルが定義されているテーブル定義

getName

public String getName()
国際化テーブルのテーブル名を取得します。

戻り値:
国際化テーブルのテーブル名

getColumnMappings

public Map getColumnMappings()
国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。 属性名をキー、 ColumnMappingを値としたマップを返します。

戻り値:
国際化テーブルに含まれるカラムマッピング

getLocaleColumnName

public String getLocaleColumnName()
ロケールに該当するカラムのカラム名を取得します。

戻り値:
カラム名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Lifetime (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Lifetime

public interface Lifetime

期間削除時の整合性制約です。 ターゲットエンティティの期間（またはその一部）が削除された場合の整合性制約です。

導入されたバージョン:
5.0

メソッドの概要
LifetimeType | getLifetimeType() ターゲットエンティティの期間削除時の整合性制約のタイプを取得します
Attribute[] | getNullKeys() ターゲットエンティティの期間削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。

メソッドの詳細

getLifetimeType

public LifetimeType getLifetimeType()
ターゲットエンティティの期間削除時の整合性制約のタイプを取得します

戻り値:
期間削除時の整合性制約のタイプ

getNullKeys

public Attribute[] getNullKeys()
ターゲットエンティティの期間削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。

戻り値:
期間削除時の整合性制約の対象となる外部キー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LifetimeType (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
クラス LifetimeType

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.config.LifetimeType
public class LifetimeType
extends Object

期間削除時の整合性制約のタイプです。 ターゲットエンティティの期間（またはその一部）が削除された場合の整合性制約のタイプです。

導入されたバージョン:
5.0

フィールドの概要
static LifetimeType | CASCADE 削除 ターゲットエンティティの期間を参照しているソースエンティティのデータを削除します。
static LifetimeType | EXCEPTION 例外 例外を発生させます。
static LifetimeType | NULL Null ターゲットエンティティの期間を参照しているソースエンティティの外部キーをnullにします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

CASCADE

public static final LifetimeType CASCADE
削除 ターゲットエンティティの期間を参照しているソースエンティティのデータを削除します。

NULL

public static final LifetimeType NULL
Null ターゲットエンティティの期間を参照しているソースエンティティの外部キーをnullにします。

EXCEPTION

public static final LifetimeType EXCEPTION
例外 例外を発生させます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Model (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Model

public interface Model

モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Application | getApplication() モデルを定義しているアプリケーションを取得します。
BaseModel | getBaseModel() 基本モデルを取得します。
Entity | getEntity() モデル定義の基となるエンティティを取得します。
InternationalModel | getInternationalModel() 国際化モデルを取得します。
String | getMapperClassName() マッパのクラス名を取得します。
Map | getProperties() モデルに含まれるプロパティをすべて取得します。
TerminableInternationalModel | getTerminableInternationalModel() 期間国際化モデルを取得します。
TerminableModel | getTerminableModel() 期間化モデルを取得します。

メソッドの詳細

getApplication

public Application getApplication()
モデルを定義しているアプリケーションを取得します。

戻り値:
モデルを定義しているアプリケーション

getEntity

public Entity getEntity()
モデル定義の基となるエンティティを取得します。

戻り値:
モデル定義の基となるエンティティ

getProperties

public Map getProperties()
モデルに含まれるプロパティをすべて取得します。 属性名をキー、 Propertyを値としたマップを返します。

戻り値:
モデルに含まれるプロパティ

getMapperClassName

public String getMapperClassName()
マッパのクラス名を取得します。

戻り値:
マッパのクラス名

getBaseModel

public BaseModel getBaseModel()
基本モデルを取得します。

戻り値:
基本モデル

getInternationalModel

public InternationalModel getInternationalModel()
国際化モデルを取得します。 国際化モデルが使用されない場合、 null が返されます。

戻り値:
国際化モデル

getTerminableModel

public TerminableModel getTerminableModel()
期間化モデルを取得します。 期間化モデルが使用されない場合、 null が返されます。

戻り値:
期間化モデル

getTerminableInternationalModel

public TerminableInternationalModel getTerminableInternationalModel()
期間国際化モデルを取得します。 期間国際化モデルが使用されない場合、 null が返されます。

戻り値:
期間国際化モデル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.common.config (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.common.config
インタフェース
ActivationKey
Application
Attribute
BaseModel
BaseTable
Column
ColumnMapping
Configuration
Delete
Entity
ExpirationKey
ExtendedBaseModel
ExtendedBaseTable
ExtendedEntity
ExtendedInternationalModel
ExtendedInternationalTable
ExtendedModel
ExtendedTable
ExtendedTerminableInternationalModel
ExtendedTerminableInternationalTable
ExtendedTerminableModel
ExtendedTerminableTable
InternationalKey
InternationalModel
InternationalTable
Lifetime
Model
PrimaryKeyMapping
Property
Relationship
Table
TerminableInternationalModel
TerminableInternationalTable
TerminableKey
TerminableModel
TerminableTable
UpdateInfo
クラス
AttributeType
ConfigurationFactory
DeleteType
LifetimeType


jp.co.intra_mart.foundation.datastore.common.config (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.common.config

アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

参照:
説明

インタフェースの概要
ActivationKey | ライフタイム期間の有効開始日時を定義します。
Application | アプリケーションを定義します。
Attribute | 属性を定義します。
BaseModel | 基本モデルを定義します。
BaseTable | 基本テーブルを定義します。
Column | 属性に対応するカラムの型を定義します。
ColumnMapping | 分割されたテーブルに割り当てられるカラムを定義します。
Configuration | 設定内容を取得します。
Delete | 削除時の整合性制約です。
Entity | エンティティを定義します。
ExpirationKey | ライフタイム期間の有効終了日時を定義します。
ExtendedBaseModel | 拡張基本モデルを定義します。
ExtendedBaseTable | 拡張基本テーブルを定義します。
ExtendedEntity | 拡張エンティティを定義します。
ExtendedInternationalModel | 拡張国際化モデルを定義します。
ExtendedInternationalTable | 拡張国際化テーブルを定義します。
ExtendedModel | 拡張モデルを定義します。
ExtendedTable | 拡張テーブルを定義します。
ExtendedTerminableInternationalModel | 拡張期間国際化モデルを定義します。
ExtendedTerminableInternationalTable | 拡張期間国際化テーブルを定義します。
ExtendedTerminableModel | 拡張期間化モデルを定義します。
ExtendedTerminableTable | 拡張期間化テーブルを定義します。
InternationalKey | 国際化基準項目を定義します。
InternationalModel | 国際化モデルを定義します。
InternationalTable | 国際化テーブルを定義します。
Lifetime | 期間削除時の整合性制約です。
Model | モデルを定義します。
PrimaryKeyMapping | 分割されたテーブルに割り当てられるプライマリーキーとなるカラムを定義します。
Property | プロパティを定義します。
Relationship | リレーションシップを定義します。
Table | テーブルを定義します。
TerminableInternationalModel | 期間国際化モデルを定義します。
TerminableInternationalTable | 期間国際化テーブルを定義します。
TerminableKey | 期間化基準項目を定義します。
TerminableModel | 期間化モデルを定義します。
TerminableTable | 期間化テーブルを定義します。
UpdateInfo | エンティティの更新情報です。

クラスの概要
AttributeType | 属性で指定できる型です。
ConfigurationFactory | Configurationを生成します。
DeleteType | 削除時の整合性制約のタイプです。
LifetimeType | 期間削除時の整合性制約のタイプです。

パッケージ jp.co.intra_mart.foundation.datastore.common.config の説明

アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。


jp.co.intra_mart.foundation.datastore.common.config クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.common.config の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.common.config.AttributeType (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory
    • class jp.co.intra_mart.foundation.datastore.common.config.DeleteType (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.common.config.LifetimeType

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.config.ActivationKey
  • interface jp.co.intra_mart.foundation.datastore.common.config.Application
  • interface jp.co.intra_mart.foundation.datastore.common.config.Attribute
  • interface jp.co.intra_mart.foundation.datastore.common.config.BaseModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.BaseTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.Column
  • interface jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping
  • interface jp.co.intra_mart.foundation.datastore.common.config.Configuration
  • interface jp.co.intra_mart.foundation.datastore.common.config.Delete
  • interface jp.co.intra_mart.foundation.datastore.common.config.Entity
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.InternationalKey
  • interface jp.co.intra_mart.foundation.datastore.common.config.InternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.Lifetime
  • interface jp.co.intra_mart.foundation.datastore.common.config.Model
  • interface jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping
  • interface jp.co.intra_mart.foundation.datastore.common.config.Property
  • interface jp.co.intra_mart.foundation.datastore.common.config.Relationship
  • interface jp.co.intra_mart.foundation.datastore.common.config.Table
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableKey
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.UpdateInfo


パッケージ jp.co.intra_mart.foundation.datastore.common.config の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.common.config の使用

jp.co.intra_mart.foundation.datastore.common.config を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.config | アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor により使用される jp.co.intra_mart.foundation.datastore.common.config のクラス
Entity
エンティティを定義します。

jp.co.intra_mart.foundation.datastore.common.config により使用される jp.co.intra_mart.foundation.datastore.common.config のクラス
ActivationKey
ライフタイム期間の有効開始日時を定義します。
Application
アプリケーションを定義します。
Attribute
属性を定義します。
AttributeType
属性で指定できる型です。
BaseModel
基本モデルを定義します。
BaseTable
基本テーブルを定義します。
Configuration
設定内容を取得します。
ConfigurationFactory
Configurationを生成します。
Delete
削除時の整合性制約です。
DeleteType
削除時の整合性制約のタイプです。
Entity
エンティティを定義します。
ExpirationKey
ライフタイム期間の有効終了日時を定義します。
ExtendedBaseModel
拡張基本モデルを定義します。
ExtendedBaseTable
拡張基本テーブルを定義します。
ExtendedEntity
拡張エンティティを定義します。
ExtendedInternationalModel
拡張国際化モデルを定義します。
ExtendedInternationalTable
拡張国際化テーブルを定義します。
ExtendedModel
拡張モデルを定義します。
ExtendedTable
拡張テーブルを定義します。
ExtendedTerminableInternationalModel
拡張期間国際化モデルを定義します。
ExtendedTerminableInternationalTable
拡張期間国際化テーブルを定義します。
ExtendedTerminableModel
拡張期間化モデルを定義します。
ExtendedTerminableTable
拡張期間化テーブルを定義します。
InternationalKey
国際化基準項目を定義します。
InternationalModel
国際化モデルを定義します。
InternationalTable
国際化テーブルを定義します。
Lifetime
期間削除時の整合性制約です。
LifetimeType
期間削除時の整合性制約のタイプです。
Model
モデルを定義します。
Relationship
リレーションシップを定義します。
Table
テーブルを定義します。
TerminableInternationalModel
期間国際化モデルを定義します。
TerminableInternationalTable
期間国際化テーブルを定義します。
TerminableKey
期間化基準項目を定義します。
TerminableModel
期間化モデルを定義します。
TerminableTable
期間化テーブルを定義します。
UpdateInfo
エンティティの更新情報です。

jp.co.intra_mart.foundation.datastore.common.model により使用される jp.co.intra_mart.foundation.datastore.common.config のクラス
Relationship
リレーションシップを定義します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PrimaryKeyMapping (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース PrimaryKeyMapping

public interface PrimaryKeyMapping

分割されたテーブルに割り当てられるプライマリーキーとなるカラムを定義します。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getAttribute() プライマリーキーとなる属性を取得します。
String | getName() プライマリーキーとなるカラム名を取得します。

メソッドの詳細

getAttribute

public Attribute getAttribute()
プライマリーキーとなる属性を取得します。

戻り値:
カラムに割り当てる属性

getName

public String getName()
プライマリーキーとなるカラム名を取得します。

戻り値:
カラム名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Property (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Property

public interface Property

プロパティを定義します。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getAttribute() プロパティに対応付ける属性を取得します。
String | getType() プロパティの型を取得します。

メソッドの詳細

getAttribute

public Attribute getAttribute()
プロパティに対応付ける属性を取得します。

戻り値:
プロパティに対応付ける属性

getType

public String getType()
プロパティの型を取得します。

戻り値:
プロパティの型
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Relationship (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Relationship

public interface Relationship

リレーションシップを定義します。

導入されたバージョン:
5.0

メソッドの概要
ActivationKey | getActivationKey() ソースエンティティのライフタイム期間の有効開始日時を取得します。
Application | getApplication() リレーションシップが定義されているアプリケーションを取得します。
Delete | getDelete() ターゲットエンティティのデータ削除時の整合性制約を取得します。
ExpirationKey | getExpirationKey() ソースエンティティのライフタイム期間の有効終了日時を取得します。
Attribute[] | getForeignKeys() ソースエンティティの外部キーの集合を取得します。
InternationalKey | getInternationalKey() ソースエンティティの国際化基準項目を取得します。
Lifetime | getLifetime() ターゲットエンティティの期間削除時の整合性制約を取得します。
String | getName() リレーションシップ名を取得します。
Entity | getSourceEntity() ソースエンティティの情報を取得します。
Entity | getTargetEntity() ターゲットエンティティの情報を取得します。
TerminableKey | getTerminableKey() ソースエンティティの期間化基準項目を取得します。

メソッドの詳細

getApplication

public Application getApplication()
リレーションシップが定義されているアプリケーションを取得します。

戻り値:
リレーションシップが定義されているアプリケーション

getName

public String getName()
リレーションシップ名を取得します。

戻り値:
リレーションシップ名

getSourceEntity

public Entity getSourceEntity()
ソースエンティティの情報を取得します。

戻り値:
ソースエンティティの情報

getTargetEntity

public Entity getTargetEntity()
ターゲットエンティティの情報を取得します。

戻り値:
ターゲットエンティティの情報

getForeignKeys

public Attribute[] getForeignKeys()
ソースエンティティの外部キーの集合を取得します。 ターゲットエンティティのプライマリキーの順番と一致している必要があります。

戻り値:
ソースエンティティの外部キーの集合

getTerminableKey

public TerminableKey getTerminableKey()
ソースエンティティの期間化基準項目を取得します。

戻り値:
期間化基準項目となる属性

getInternationalKey

public InternationalKey getInternationalKey()
ソースエンティティの国際化基準項目を取得します。

戻り値:
国際化基準項目となる属性

getActivationKey

public ActivationKey getActivationKey()
ソースエンティティのライフタイム期間の有効開始日時を取得します。

戻り値:
ライフタイム期間の有効開始日時となる属性

getExpirationKey

public ExpirationKey getExpirationKey()
ソースエンティティのライフタイム期間の有効終了日時を取得します。

戻り値:
ライフタイム期間の有効終了日時となる属性

getDelete

public Delete getDelete()
ターゲットエンティティのデータ削除時の整合性制約を取得します。

戻り値:
データ削除時の整合性制約

getLifetime

public Lifetime getLifetime()
ターゲットエンティティの期間削除時の整合性制約を取得します。

戻り値:
期間削除時の整合性制約
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Table (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Table

public interface Table

テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Application | getApplication() テーブルを定義しているアプリケーションを取得します。
BaseTable | getBaseTable() 基本テーブルを取得します。
Map | getColumns() テーブルに含まれるカラムをすべて取得します。
Entity | getEntity() テーブル定義の基となるエンティティを取得します。
InternationalTable | getInternationalTable() 国際化テーブルを取得します。
TerminableInternationalTable | getTerminableInternationalTable() 期間国際化テーブルを取得します。
TerminableTable | getTerminableTable() 期間化テーブルを取得します。

メソッドの詳細

getApplication

public Application getApplication()
テーブルを定義しているアプリケーションを取得します。

戻り値:
テーブルを定義しているアプリケーション

getEntity

public Entity getEntity()
テーブル定義の基となるエンティティを取得します。

戻り値:
テーブル定義の基となるエンティティ

getColumns

public Map getColumns()
テーブルに含まれるカラムをすべて取得します。 属性名をキー、 Columnを値としたマップを返します。

戻り値:
テーブルに含まれるカラム

getBaseTable

public BaseTable getBaseTable()
基本テーブルを取得します。

戻り値:
基本テーブル

getInternationalTable

public InternationalTable getInternationalTable()
国際化テーブルを取得します。 国際化テーブルが定義されていない場合、 null が返されます。

戻り値:
国際化テーブル

getTerminableTable

public TerminableTable getTerminableTable()
期間化テーブルを取得します。 期間化テーブルが定義されていない場合、 null が返されます。

戻り値:
期間化テーブル

getTerminableInternationalTable

public TerminableInternationalTable getTerminableInternationalTable()
期間国際化テーブルを取得します。 期間国際化テーブルが定義されていない場合、 null が返されます。

戻り値:
期間国際化テーブル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableInternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース TerminableInternationalModel

public interface TerminableInternationalModel

期間国際化モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
String | getClassName() 期間国際化モデルのクラス名を取得します。
Model | getModel() 期間国際化モデルが定義されているモデル定義を取得します。

メソッドの詳細

getModel

public Model getModel()
期間国際化モデルが定義されているモデル定義を取得します。

戻り値:
期間国際化モデルが定義されているモデル定義

getClassName

public String getClassName()
期間国際化モデルのクラス名を取得します。

戻り値:
期間国際化モデルのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableInternationalTable (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース TerminableInternationalTable

public interface TerminableInternationalTable

期間国際化テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getColumnMappings() 期間国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
String | getLocaleColumnName() ロケールに該当するカラムのカラム名を取得します。
String | getName() 期間国際化テーブルのテーブル名を取得します。
Table | getTable() 期間国際化テーブルが定義されているテーブル定義を取得します。
String | getTermColumnName() 期間CDに該当するカラムのカラム名を取得します。

メソッドの詳細

getTable

public Table getTable()
期間国際化テーブルが定義されているテーブル定義を取得します。

戻り値:
期間国際化テーブルが定義されているテーブル定義

getName

public String getName()
期間国際化テーブルのテーブル名を取得します。

戻り値:
期間国際化テーブルのテーブル名

getColumnMappings

public Map getColumnMappings()
期間国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。 属性名をキー、 ColumnMappingを値としたマップを返します。

戻り値:
期間国際化テーブルに含まれるカラムマッピング

getTermColumnName

public String getTermColumnName()
期間CDに該当するカラムのカラム名を取得します。

戻り値:
カラム名

getLocaleColumnName

public String getLocaleColumnName()
ロケールに該当するカラムのカラム名を取得します。

戻り値:
カラム名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableKey (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース TerminableKey

public interface TerminableKey

期間化基準項目を定義します。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getAttribute() 期間化基準項目となる属性を取得します。
Relationship[] | getRefereRelationships() ソースエンティティから期間化基準項目を持つエンティティまでのリレーションシップを取得します。
Entity | getSourceEntity() 期間化基準項目の基点となるソースエンティティの情報を取得します。

メソッドの詳細

getSourceEntity

public Entity getSourceEntity()
期間化基準項目の基点となるソースエンティティの情報を取得します。

戻り値:
ソースエンティティの情報

getRefereRelationships

public Relationship[] getRefereRelationships()
ソースエンティティから期間化基準項目を持つエンティティまでのリレーションシップを取得します。

戻り値:
ソースエンティティから期間化基準項目を持つエンティティまでのリレーションシップ

getAttribute

public Attribute getAttribute()
期間化基準項目となる属性を取得します。

戻り値:
期間化基準項目となる属性
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース TerminableModel

public interface TerminableModel

期間化モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
String | getClassName() 期間化モデルのクラス名を取得します。
Model | getModel() 期間化モデルが定義されているモデル定義を取得します。

メソッドの詳細

getModel

public Model getModel()
期間化モデルが定義されているモデル定義を取得します。

戻り値:
期間化モデルが定義されているモデル定義

getClassName

public String getClassName()
期間化モデルのクラス名を取得します。

戻り値:
期間化モデルのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableTable (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース TerminableTable

public interface TerminableTable

期間化テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getColumnMappings() 期間化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
String | getEndDateColumnName() 期間の日時に該当するカラムのカラム名を取得します。
String | getName() 期間化テーブルのテーブル名を取得します。
String | getStartDateColumnName() 期間の開始日時に該当するカラムのカラム名を取得します。
Table | getTable() 期間化テーブルが定義されているテーブル定義を取得します。
String | getTermColumnName() 期間CDに該当するカラムのカラム名を取得します。

メソッドの詳細

getTable

public Table getTable()
期間化テーブルが定義されているテーブル定義を取得します。

戻り値:
期間化テーブルが定義されているテーブル定義

getName

public String getName()
期間化テーブルのテーブル名を取得します。

戻り値:
期間化テーブルのテーブル名

getColumnMappings

public Map getColumnMappings()
期間化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。 属性名をキー、 ColumnMappingを値としたマップを返します。

戻り値:
期間化テーブルに含まれるカラムマッピング

getTermColumnName

public String getTermColumnName()
期間CDに該当するカラムのカラム名を取得します。

戻り値:
カラム名

getStartDateColumnName

public String getStartDateColumnName()
期間の開始日時に該当するカラムのカラム名を取得します。

戻り値:
カラム名

getEndDateColumnName

public String getEndDateColumnName()
期間の日時に該当するカラムのカラム名を取得します。

戻り値:
カラム名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UpdateInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース UpdateInfo

public interface UpdateInfo

エンティティの更新情報です。 エンティティの更新ユーザ、更新日時となる属性を持ちます。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getUpdateTimestamp() エンティティの更新日付となる属性を取得します。
Attribute | getUpdateUser() エンティティの更新ユーザとなる属性を取得します。

メソッドの詳細

getUpdateUser

public Attribute getUpdateUser()
エンティティの更新ユーザとなる属性を取得します。

戻り値:
エンティティの更新ユーザとなる属性

getUpdateTimestamp

public Attribute getUpdateTimestamp()
エンティティの更新日付となる属性を取得します。

戻り値:
エンティティの更新ユーザとなる属性
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.BaseModel の使用

BaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category | 会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company | 会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion | 組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version | 会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.deal | 取扱情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.department | 取扱組織権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.detail | 取扱詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group | 取扱パブリックグループ権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.role | 取扱ロール権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach | 商品分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.category | 商品カテゴリ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.type | 商品カテゴリ種別情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail | 商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.template | 商品テンプレート情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.attribute | 商品属性情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue | 商品カタログ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.item | 商品情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach | プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group | プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach | パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category | パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion | パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set | パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version | パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.unit | 単位情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.system.security.datastore.inf |

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での BaseModel のサブインタフェース
 interface CateogryClassBaseModel
分類区分の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.category.detail での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.category.detail での BaseModel のサブインタフェース
 interface CategoryDetailBaseModel
分類区分詳細の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.attach での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.attach での BaseModel のサブインタフェース
 interface DepartmentAttachBaseModel
組織所属の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.category での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.category での BaseModel のサブインタフェース
 interface CompanyCategoryBaseModel
会社組織分類の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.company での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.company での BaseModel のサブインタフェース
 interface CompanyBaseModel
会社の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.department での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.department での BaseModel のサブインタフェース
 interface DepartmentBaseModel
組織の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion での BaseModel のサブインタフェース
 interface DepartmentInclusionBaseModel
組織内包の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.main での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.main での BaseModel のサブインタフェース
 interface DepartmentMainBaseModel
主所属の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.post での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.post での BaseModel のサブインタフェース
 interface CompanyPostBaseModel
役職の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.version での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.version での BaseModel のサブインタフェース
 interface CompanyVersionBaseModel
会社構成バージョンの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.deal.deal での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.deal での BaseModel のサブインタフェース
 interface DealBaseModel
取扱の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.deal.department での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.department での BaseModel のサブインタフェース
 interface DealerDepartmentBaseModel
組織毎取扱パーミッションの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.deal.detail での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.detail での BaseModel のサブインタフェース
 interface DealDetailBaseModel
取扱詳細の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group での BaseModel のサブインタフェース
 interface DealerPublicGroupBaseModel
パブリックグループ毎取扱パーミッションの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.deal.role での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.role での BaseModel のサブインタフェース
 interface DealerRoleBaseModel
ロール毎取扱パーミッションの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach での BaseModel のサブインタフェース
 interface ItemAttachBaseModel
商品分類の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item_category.category での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.category での BaseModel のサブインタフェース
 interface ItemCategoryBaseModel
商品カテゴリの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item_category.type での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.type での BaseModel のサブインタフェース
 interface ItemCategoryTypeBaseModel
商品カテゴリ種別の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail での BaseModel のサブインタフェース
 interface ItemTemplateDetailBaseModel
商品属性テンプレート明細の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item_template.template での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item_template.template での BaseModel のサブインタフェース
 interface ItemTemplateBaseModel
商品属性テンプレートの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item.attribute での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item.attribute での BaseModel のサブインタフェース
 interface ItemAttributeBaseModel
商品属性の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue での BaseModel のサブインタフェース
 interface ItemCatalogueBaseModel
商品カタログの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item.item での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item.item での BaseModel のサブインタフェース
 interface ItemBaseModel
商品の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach での BaseModel のサブインタフェース
 interface PrivateGroupAttachBaseModel
プライベートグループ所属の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.private_group.group での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.private_group.group での BaseModel のサブインタフェース
 interface PrivateGroupBaseModel
プライベートグループの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での BaseModel のサブインタフェース
 interface PublicGroupAttachBaseModel
パブリックグループ所属の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での BaseModel のサブインタフェース
 interface PublicGroupCategoryBaseModel
パブリックグループ分類の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での BaseModel のサブインタフェース
 interface PublicGroupBaseModel
パブリックグループの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion での BaseModel のサブインタフェース
 interface PublicGroupInclusionBaseModel
パブリックグループ内包の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.set での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.set での BaseModel のサブインタフェース
 interface PublicGroupSetBaseModel
パブリックグループセットの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.version での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.version での BaseModel のサブインタフェース
 interface PublicGroupVersionBaseModel
パブリックグループ構成バージョンの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.unit での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.unit での BaseModel のサブインタフェース
 interface UnitBaseModel
単位の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.user での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.user での BaseModel のサブインタフェース
 interface UserBaseModel
ユーザの基本モデルです。

jp.co.intra_mart.foundation.datastore.common.model での BaseModel の使用

BaseModel を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class GenericBaseModel
基本モデルの汎用的な抽象クラスです。

BaseModel を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
BaseModel | Mapper.createBaseModel(Map keys) このマッパーに該当する基本モデルを新規に生成します。
BaseModel | Mapper.select(Map keys) プライマリーキーで特定される基本モデルを取得します。
BaseModel | IntramartDBMapper.createBaseModel(Map keys) このマッパーに該当する基本モデルを新規に生成します。
BaseModel | IntramartDBMapper.select(Map keys) プライマリーキーで特定される基本モデルを取得します。

BaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | Mapper.notifyUpdate(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
void | Mapper.notifyDelete(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
void | Mapper.checkByBaseProperty(Relationship[] relationships, BaseModel target, BaseModel base) 基準項目によるリレーションシップの整合性制約をチェックします。
protected void | IntramartDBMapper.insert(BaseModel model) 基本モデルを1つだけ挿入します。
protected void | IntramartDBMapper.update(BaseModel model) 基本モデルを1つだけ更新します。
protected void | IntramartDBMapper.delete(BaseModel model) 基本モデルを1つだけ削除します。
void | IntramartDBMapper.notifyUpdate(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
void | IntramartDBMapper.notifyDelete(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
void | IntramartDBMapper.checkByBaseProperty(Relationship[] relationships, BaseModel target, BaseModel base) 基準項目によるリレーションシップの整合性制約をチェックします。

jp.co.intra_mart.system.security.datastore.inf での BaseModel の使用

jp.co.intra_mart.system.security.datastore.inf での BaseModel のサブインタフェース
interface | AccessControllerBaseModel アクセスコントローラ情報の基本モデルです。
interface | AccessControllerDepartmentBaseModel アクセスコントローラの利用権限を保有する組織の基本モデルです。
interface | AccessControllerPostBaseModel アクセスコントローラの利用権限を保有する役職の基本モデルです。
interface | AccessControllerPublicGroupBaseModel アクセスコントローラの利用権限を保有するパブリックグループの基本モデルです。
interface | AccessControllerRoleBaseModel アクセスコントローラの利用権限を保有するロールの基本モデルです。
interface | AccountAttributeBaseModel アカウントが保有する属性の基本モデルです。
interface | AccountBaseModel アカウントの基本モデルです。
interface | AccountRoleBaseModel アカウントが保有するロールの基本モデルです。
interface | BatchBaseModel バッチ情報の基本モデルです。
interface | CalendarInfoBaseModel カレンダーが保有するデータの基本モデルです。
interface | FavoriteMenuBaseModel アカウントが保有するメニューの基本モデルです。
interface | MenuArgumentBaseModel メニューの保有する引数の基本モデルです。
interface | MenuBaseModel メニュー情報の基本モデルです。
interface | MenuDepartmentBaseModel メニューの利用権限を保有する組織の基本モデルです。
interface | MenuPostBaseModel メニューの利用権限を保有する役職の基本モデルです。
interface | MenuPublicGroupBaseModel メニューの利用権限を保有するパブリックグループの基本モデルです。
interface | MenuRoleBaseModel メニューの利用権限を保有するロールの基本モデルです。
interface | RoleBaseModel ロールの基本モデルです。
interface | RoleInclusionBaseModel ロール内包の基本モデルです。
interface | RoleSummaryBaseModel ロールサマリの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext の使用

BaseModelContext を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での BaseModelContext の使用

BaseModelContext 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | GenericBaseModel.init(BaseModelContext context) 基本モデルを初期化します。
void | BaseModel.init(BaseModelContext context) 基本モデルを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel の使用

ExtendedBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedBaseModel の使用

ExtendedBaseModel を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class ExtendedGenericBaseModel
拡張基本モデルの汎用的な抽象クラスです。

ExtendedBaseModel を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedBaseModel | ExtendedGenericBaseModelMap.createExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
ExtendedBaseModel | ExtendedGenericBaseModelMap.findExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。
ExtendedBaseModel | ExtendedGenericBaseModelMap.newExtendedBaseModel(String name) 初期化されていない拡張基本モデルのインスタンスを取得します。
ExtendedBaseModel | ExtendedBaseModelMap.createExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
ExtendedBaseModel | ExtendedBaseModelMap.findExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap の使用

ExtendedBaseModelMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedBaseModelMap の使用

ExtendedBaseModelMap を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class ExtendedGenericBaseModelMap
拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。

ExtendedBaseModelMap を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedBaseModelMap | GenericBaseModel.getExtendedBaseModelMap() 拡張基本モデルのマップを取得します。
ExtendedBaseModelMap | BaseModelContext.getExtendedBaseModelMap() 拡張基本モデルマップを取得します。
ExtendedBaseModelMap | BaseModel.getExtendedBaseModelMap() 拡張基本エンティティに対応する拡張基本モデルのマップを取得します。

ExtendedBaseModelMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void BaseModelContext.setExtendedBaseModelMap(ExtendedBaseModelMap extendedMap)
拡張基本モデルマップを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel の使用

jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap の使用

jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel の使用

jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap の使用

jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel の使用

jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap の使用

jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel の使用

jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap の使用

jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel の使用

ExtendedInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedInternationalModel の使用

ExtendedInternationalModel を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class ExtendedGenericInternationalModel
拡張国際化モデルの汎用的な抽象クラスです。

ExtendedInternationalModel を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedInternationalModel | ExtendedInternationalModelMap.createExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
ExtendedInternationalModel | ExtendedInternationalModelMap.findExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
ExtendedInternationalModel | ExtendedGenericInternationalModelMap.createExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
ExtendedInternationalModel | ExtendedGenericInternationalModelMap.findExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
ExtendedInternationalModel | ExtendedGenericInternationalModelMap.newExtendedInternationalModel(String name) 初期化されていない拡張国際化モデルのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap の使用

ExtendedInternationalModelMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedInternationalModelMap の使用

ExtendedInternationalModelMap を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class ExtendedGenericInternationalModelMap
拡張国際化モデルのマッピング情報を持つ汎用的な抽象クラスです。

ExtendedInternationalModelMap を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedInternationalModelMap | InternationalModelContext.getExtendedInternationalModelMap() 拡張国際化モデルマップを取得します。
ExtendedInternationalModelMap | InternationalModel.getExtendedInternationalModelMap() 拡張国際化エンティティに対応する拡張国際化モデルのマップを取得します。
ExtendedInternationalModelMap | GenericInternationalModel.getExtendedInternationalModelMap() 拡張国際化モデルのマップを取得します。

ExtendedInternationalModelMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void InternationalModelContext.setExtendedInternationalModelMap(ExtendedInternationalModelMap extendedMap)
拡張国際化モデルマップを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel の使用

ExtendedTerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedTerminableInternationalModel の使用

ExtendedTerminableInternationalModel を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class ExtendedGenericTerminableInternationalModel
拡張期間国際化モデルの汎用的な抽象クラスです。

ExtendedTerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedTerminableInternationalModel | ExtendedTerminableInternationalModelMap.createExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
ExtendedTerminableInternationalModel | ExtendedTerminableInternationalModelMap.findExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
ExtendedTerminableInternationalModel | ExtendedGenericTerminableInternationalModelMap.createExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
ExtendedTerminableInternationalModel | ExtendedGenericTerminableInternationalModelMap.findExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
ExtendedTerminableInternationalModel | ExtendedGenericTerminableInternationalModelMap.newExtendedTerminableInternationalModel(String name) 初期化されていない拡張期間国際化モデルのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap の使用

ExtendedTerminableInternationalModelMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedTerminableInternationalModelMap の使用

ExtendedTerminableInternationalModelMap を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class ExtendedGenericTerminableInternationalModelMap
拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。

ExtendedTerminableInternationalModelMap を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedTerminableInternationalModelMap | TerminableInternationalModelContext.getExtendedTerminableInternationalModelMap() 拡張期間国際化モデルマップを取得します。
ExtendedTerminableInternationalModelMap | TerminableInternationalModel.getExtendedTerminableInternationalModelMap() 拡張期間国際化エンティティに対応する拡張期間国際化モデルのマップを取得します。
ExtendedTerminableInternationalModelMap | GenericTerminableInternationalModel.getExtendedTerminableInternationalModelMap() 拡張期間国際化モデルのマップを取得します。

ExtendedTerminableInternationalModelMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void TerminableInternationalModelContext.setExtendedTerminableInternationalModelMap(ExtendedTerminableInternationalModelMap extendedMap)
拡張期間国際化モデルマップを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel の使用

ExtendedTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedTerminableModel の使用

ExtendedTerminableModel を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class ExtendedGenericTerminableModel
拡張期間化モデルの汎用的な抽象クラスです。

ExtendedTerminableModel を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedTerminableModel | ExtendedTerminableModelMap.createExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
ExtendedTerminableModel | ExtendedTerminableModelMap.findExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
ExtendedTerminableModel | ExtendedGenericTerminableModelMap.createExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
ExtendedTerminableModel | ExtendedGenericTerminableModelMap.findExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
ExtendedTerminableModel | ExtendedGenericTerminableModelMap.newExtendedTerminableModel(String name) 初期化されてていない拡張期間化モデルのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap の使用

ExtendedTerminableModelMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedTerminableModelMap の使用

ExtendedTerminableModelMap を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class ExtendedGenericTerminableModelMap
拡張期間化モデルのマッピング情報を持つ汎用的な抽象クラスです。

ExtendedTerminableModelMap を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedTerminableModelMap | TerminableModelContext.getExtendedTerminableModelMap() 拡張期間化モデルマップを取得します。
ExtendedTerminableModelMap | TerminableModel.getExtendedTerminableModelMap() 拡張期間化エンティティに対応する拡張期間化モデルのマップを取得します。
ExtendedTerminableModelMap | GenericTerminableModel.getExtendedTerminableModelMap() 拡張期間化モデルのマップを取得します。

ExtendedTerminableModelMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void TerminableModelContext.setExtendedTerminableModelMap(ExtendedTerminableModelMap extendedMap)
拡張期間化モデルマップを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel の使用

jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel の使用

jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap の使用

jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel の使用

jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap の使用

jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel の使用

jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap の使用

jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.InternationalModel の使用

InternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.category | 商品カテゴリ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail | 商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.template | 商品テンプレート情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.attribute | 商品属性情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.system.security.datastore.inf |

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での InternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での InternationalModel のサブインタフェース
 interface CateogryClassInternationalModel
分類区分の国際化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.category.detail での InternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.category.detail での InternationalModel のサブインタフェース
 interface CategoryDetailInternationalModel
分類区分詳細の国際化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item_category.category での InternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.category での InternationalModel のサブインタフェース
 interface ItemCategoryInternationalModel
商品カテゴリの国際化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail での InternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail での InternationalModel のサブインタフェース
 interface ItemTemplateDetailInternationalModel
商品属性テンプレート明細の国際化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item_template.template での InternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item_template.template での InternationalModel のサブインタフェース
 interface ItemTemplateInternationalModel
商品属性テンプレートの国際化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item.attribute での InternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item.attribute での InternationalModel のサブインタフェース
 interface ItemAttributeInternationalModel
商品属性の国際化モデルです。

jp.co.intra_mart.foundation.datastore.common.model での InternationalModel の使用

InternationalModel を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class GenericInternationalModel
国際化モデルの汎用的な抽象クラスです。

InternationalModel を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
InternationalModel | InternationalModelMap.createInternationalModel(Locale locale) 国際化モデルを生成します。
InternationalModel | InternationalModelMap.findInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。
InternationalModel | GenericInternationalModelMap.createInternationalModel(Locale locale) 国際化モデルを生成します。
InternationalModel | GenericInternationalModelMap.findInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。
InternationalModel | GenericInternationalModelMap.newInternationalModel(Locale locale) 初期化されていない国際化モデルのインスタンスを取得します。
protected InternationalModel | GenericBaseModel.selectInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。

jp.co.intra_mart.system.security.datastore.inf での InternationalModel の使用

jp.co.intra_mart.system.security.datastore.inf での InternationalModel のサブインタフェース
interface | CalendarInfoInternationalModel カレンダーが保有するデータの国際化モデルです。
interface | MenuInternationalModel メニュー情報の国際化モデルです。
interface | RoleInternationalModel ロールの国際化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext の使用

InternationalModelContext を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での InternationalModelContext の使用

InternationalModelContext 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | InternationalModel.init(InternationalModelContext context) 国際化モデルを初期化します。
void | GenericInternationalModel.init(InternationalModelContext context) 国際化モデルを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap の使用

InternationalModelMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での InternationalModelMap の使用

InternationalModelMap を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class GenericInternationalModelMap
国際化モデルマッピングの汎用的な抽象クラスです。

InternationalModelMap を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
InternationalModelMap | GenericBaseModel.getInternationalModelMap() 国際化モデルのマップを取得します。
InternationalModelMap | BaseModelContext.getInternationalModelMap() 国際化モデルマップを取得します。
InternationalModelMap | BaseModel.getInternationalModelMap() 国際化モデルのマップを取得します。

InternationalModelMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void BaseModelContext.setInternationalModelMap(InternationalModelMap internationalMap)
国際化モデルマップを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper の使用

jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.Mapper の使用

Mapper を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category | 会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company | 会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion | 組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version | 会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.deal | 取扱情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.department | 取扱組織権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.detail | 取扱詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group | 取扱パブリックグループ権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.role | 取扱ロール権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach | 商品分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.category | 商品カテゴリ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.type | 商品カテゴリ種別情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail | 商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.template | 商品テンプレート情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.attribute | 商品属性情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue | 商品カタログ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.item | 商品情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach | プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group | プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach | パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category | パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion | パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set | パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version | パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.unit | 単位情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.system.security.datastore.inf |

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での Mapper のサブインタフェース
 interface CateogryClassMapper
分類区分に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.category.detail での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.category.detail での Mapper のサブインタフェース
 interface CategoryDetailMapper
分類区分詳細に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.company.attach での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.attach での Mapper のサブインタフェース
 interface DepartmentAttachMapper
組織所属に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.company.category での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.category での Mapper のサブインタフェース
 interface CompanyCategoryMapper
会社組織分類に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.company.company での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.company での Mapper のサブインタフェース
 interface CompanyMapper
会社に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.company.department での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.department での Mapper のサブインタフェース
 interface DepartmentMapper
組織に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion での Mapper のサブインタフェース
 interface DepartmentInclusionMapper
組織内包に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.company.main での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.main での Mapper のサブインタフェース
 interface DepartmentMainMapper
主所属に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.company.post での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.post での Mapper のサブインタフェース
 interface CompanyPostMapper
役職に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.company.version での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.version での Mapper のサブインタフェース
 interface CompanyVersionMapper
会社構成バージョンに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.deal.deal での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.deal での Mapper のサブインタフェース
 interface DealMapper
取扱に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.deal.department での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.department での Mapper のサブインタフェース
 interface DealerDepartmentMapper
組織毎取扱パーミッションに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.deal.detail での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.detail での Mapper のサブインタフェース
 interface DealDetailMapper
取扱詳細に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group での Mapper のサブインタフェース
 interface DealerPublicGroupMapper
パブリックグループ毎取扱パーミッションに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.deal.role での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.role での Mapper のサブインタフェース
 interface DealerRoleMapper
ロール毎取扱パーミッションに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach での Mapper のサブインタフェース
 interface ItemAttachMapper
商品分類に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.item_category.category での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.category での Mapper のサブインタフェース
 interface ItemCategoryMapper
商品カテゴリに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.item_category.type での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.type での Mapper のサブインタフェース
 interface ItemCategoryTypeMapper
商品カテゴリ種別に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail での Mapper のサブインタフェース
 interface ItemTemplateDetailMapper
商品属性テンプレート明細に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.item_template.template での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item_template.template での Mapper のサブインタフェース
 interface ItemTemplateMapper
商品属性テンプレートに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.item.attribute での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item.attribute での Mapper のサブインタフェース
 interface ItemAttributeMapper
商品属性に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue での Mapper のサブインタフェース
 interface ItemCatalogueMapper
商品カタログに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.item.item での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item.item での Mapper のサブインタフェース
 interface ItemMapper
商品に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach での Mapper のサブインタフェース
 interface PrivateGroupAttachMapper
プライベートグループ所属に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.private_group.group での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.private_group.group での Mapper のサブインタフェース
 interface PrivateGroupMapper
プライベートグループに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での Mapper のサブインタフェース
 interface PublicGroupAttachMapper
パブリックグループ所属に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での Mapper のサブインタフェース
 interface PublicGroupCategoryMapper
パブリックグループ分類に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での Mapper のサブインタフェース
 interface PublicGroupMapper
パブリックグループに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion での Mapper のサブインタフェース
 interface PublicGroupInclusionMapper
パブリックグループ内包に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.set での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.set での Mapper のサブインタフェース
 interface PublicGroupSetMapper
パブリックグループセットに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.version での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.version での Mapper のサブインタフェース
 interface PublicGroupVersionMapper
パブリックグループ構成バージョンに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.unit での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.unit での Mapper のサブインタフェース
 interface UnitMapper
単位に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.user での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.user での Mapper のサブインタフェース
 interface UserMapper
ユーザに関連するマッパです。

jp.co.intra_mart.foundation.datastore.common.model での Mapper の使用

Mapper を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class IntramartDBMapper
intra-martで管理されるデータベースにアクセスするマッパーの汎用的な抽象クラスです。

Mapper を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
abstract  Mapper MapperFactory.createMapper(String application, String entity, String group, String user)
マッパーを生成します。

jp.co.intra_mart.system.security.datastore.inf での Mapper の使用

jp.co.intra_mart.system.security.datastore.inf での Mapper のサブインタフェース
interface | AccessControllerDepartmentMapper アクセスコントローラの利用権限を保有する組織に関連するマッパです。
interface | AccessControllerMapper アクセスコントローラ情報に関連するマッパです。
interface | AccessControllerPostMapper アクセスコントローラの利用権限を保有する役職に関連するマッパです。
interface | AccessControllerPublicGroupMapper アクセスコントローラの利用権限を保有するパブリックグループに関連するマッパです。
interface | AccessControllerRoleMapper アクセスコントローラの利用権限を保有するロールに関連するマッパです。
interface | AccountAttributeMapper アカウントが保有する属性に関連するマッパです。
interface | AccountMapper アカウントに関連するマッパです。
interface | AccountRoleMapper アカウントが保有するロールに関連するマッパです。
interface | BatchMapper バッチ情報に関連するマッパです。
interface | CalendarInfoMapper カレンダーが保有するデータに関連するマッパです。
interface | FavoriteMenuMapper アカウントが保有するメニューに関連するマッパです。
interface | MenuArgumentMapper メニューの保有する引数に関連するマッパです。
interface | MenuDepartmentMapper メニューの利用権限を保有する組織に関連するマッパです。
interface | MenuMapper メニュー情報に関連するマッパです。
interface | MenuPostMapper メニューの利用権限を保有する役職に関連するマッパです。
interface | MenuPublicGroupMapper メニューの利用権限を保有するパブリックグループに関連するマッパです。
interface | MenuRoleMapper メニューの利用権限を保有するロールに関連するマッパです。
interface | RoleInclusionMapper ロール内包に関連するマッパです。
interface | RoleMapper ロールに関連するマッパです。
interface | RoleSummaryMapper ロールサマリに関連するマッパです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.MapperFactory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.MapperFactory の使用

MapperFactory を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での MapperFactory の使用

MapperFactory を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
static MapperFactory MapperFactory.newInstance()
マッパーファクトリを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel の使用

TerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.item | 商品情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.department での TerminableInternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.department での TerminableInternationalModel のサブインタフェース
 interface DepartmentTerminableInternationalModel
組織の期間国際化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.post での TerminableInternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.post での TerminableInternationalModel のサブインタフェース
 interface CompanyPostTerminableInternationalModel
役職の期間国際化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item.item での TerminableInternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item.item での TerminableInternationalModel のサブインタフェース
 interface ItemTerminableInternationalModel
商品の期間国際化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での TerminableInternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での TerminableInternationalModel のサブインタフェース
 interface PublicGroupTerminableInternationalModel
パブリックグループの期間国際化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.user での TerminableInternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.user での TerminableInternationalModel のサブインタフェース
 interface UserTerminableInternationalModel
ユーザの期間国際化モデルです。

jp.co.intra_mart.foundation.datastore.common.model での TerminableInternationalModel の使用

TerminableInternationalModel を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class GenericTerminableInternationalModel
期間国際化モデルの汎用的な抽象クラスです。

TerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableInternationalModel | TerminableInternationalModelMap.createTerminableInternationalModel(Locale locale) 期間国際化モデルを生成します。
TerminableInternationalModel | TerminableInternationalModelMap.findTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
protected TerminableInternationalModel | GenericTerminableModel.selectTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
TerminableInternationalModel | GenericTerminableInternationalModelMap.createTerminableInternationalModel(Locale locale) 期間国際化モデルを生成します。
TerminableInternationalModel | GenericTerminableInternationalModelMap.findTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
TerminableInternationalModel | GenericTerminableInternationalModelMap.newTerminableInternationalModel(Locale locale) 初期化されていない期間国際化モデルのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext の使用

TerminableInternationalModelContext を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での TerminableInternationalModelContext の使用

TerminableInternationalModelContext 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | TerminableInternationalModel.init(TerminableInternationalModelContext context) 期間国際化モデルを初期化します。
void | GenericTerminableInternationalModel.init(TerminableInternationalModelContext context) 期間国際化モデルを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap の使用

TerminableInternationalModelMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での TerminableInternationalModelMap の使用

TerminableInternationalModelMap を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class GenericTerminableInternationalModelMap
期間国際化モデルマッピングの汎用的な抽象クラスです。

TerminableInternationalModelMap を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableInternationalModelMap | TerminableModelContext.getTerminableInternationalModelMap() 期間国際化モデルマップを取得します。
TerminableInternationalModelMap | TerminableModel.getTerminableInternationalModelMap() 期間国際化モデルを取得します。
TerminableInternationalModelMap | GenericTerminableModel.getTerminableInternationalModelMap() 期間国際化モデルのマップを取得します。

TerminableInternationalModelMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void TerminableModelContext.setTerminableInternationalModelMap(TerminableInternationalModelMap terminableInternationalMap)
期間国際化モデルマップを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.TerminableModel の使用

TerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category | 会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.deal | 取扱情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.detail | 取扱詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.item | 商品情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach | パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category | パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.attach での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.attach での TerminableModel のサブインタフェース
 interface DepartmentAttachTerminableModel
組織所属の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.category での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.category での TerminableModel のサブインタフェース
 interface CompanyCategoryTerminableModel
会社組織分類の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.department での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.department での TerminableModel のサブインタフェース
 interface DepartmentTerminableModel
組織の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.main での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.main での TerminableModel のサブインタフェース
 interface DepartmentMainTerminableModel
主所属の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.post での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.post での TerminableModel のサブインタフェース
 interface CompanyPostTerminableModel
役職の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.deal.deal での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.deal での TerminableModel のサブインタフェース
 interface DealTerminableModel
取扱の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.deal.detail での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.detail での TerminableModel のサブインタフェース
 interface DealDetailTerminableModel
取扱詳細の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item.item での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item.item での TerminableModel のサブインタフェース
 interface ItemTerminableModel
商品の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での TerminableModel のサブインタフェース
 interface PublicGroupAttachTerminableModel
パブリックグループ所属の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での TerminableModel のサブインタフェース
 interface PublicGroupCategoryTerminableModel
パブリックグループ分類の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での TerminableModel のサブインタフェース
 interface PublicGroupTerminableModel
パブリックグループの期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.user での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.user での TerminableModel のサブインタフェース
 interface UserTerminableModel
ユーザの期間化モデルです。

jp.co.intra_mart.foundation.datastore.common.model での TerminableModel の使用

TerminableModel を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class GenericTerminableModel
期間化モデルの汎用的な抽象クラスです。

TerminableModel を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableModel | TerminableModelMap.createTerminableModel(Term term) 指定した期間を満たす期間化モデルを生成します。
TerminableModel | TerminableModelMap.findTerminableModel(Date date) 指定された日付に該当する期間化モデルを取得します。
TerminableModel | GenericTerminableModelMap.createTerminableModel(Term term) 指定した期間を満たす期間化モデルを生成します。
TerminableModel | GenericTerminableModelMap.findTerminableModel(Date date) 指定された日時に該当する期間化モデルを取得します。
TerminableModel | GenericTerminableModelMap.newTerminableModel(Term term) 初期化されていない期間化モデルのインスタンスを取得します。
protected TerminableModel | GenericBaseModel.selectTerminableModel(Date date) 指定された日時に該当する期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext の使用

TerminableModelContext を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での TerminableModelContext の使用

TerminableModelContext 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | TerminableModel.init(TerminableModelContext context) 期間化モデルを初期化します。
void | GenericTerminableModel.init(TerminableModelContext context) 期間化モデルを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap の使用

TerminableModelMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での TerminableModelMap の使用

TerminableModelMap を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class GenericTerminableModelMap
期間化モデルマッピングの汎用的な抽象クラスです。

TerminableModelMap を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableModelMap | GenericBaseModel.getTerminableModelMap() 期間化モデルのマップを取得します。
TerminableModelMap | BaseModelContext.getTerminableModelMap() 期間化モデルマップを取得します。
TerminableModelMap | BaseModel.getTerminableModelMap() 期間化モデルのマップを取得します。

TerminableModelMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void BaseModelContext.setTerminableModelMap(TerminableModelMap terminableMap)
期間化モデルマップを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース BaseModel

すべてのスーパーインタフェース:
Serializable
既知のサブインタフェースの一覧:
AccessControllerBaseModel, AccessControllerDepartmentBaseModel, AccessControllerPostBaseModel, AccessControllerPublicGroupBaseModel, AccessControllerRoleBaseModel, AccountAttributeBaseModel, AccountBaseModel, AccountRoleBaseModel, BatchBaseModel, CalendarInfoBaseModel, CategoryDetailBaseModel, CateogryClassBaseModel, CompanyBaseModel, CompanyCategoryBaseModel, CompanyPostBaseModel, CompanyVersionBaseModel, DealBaseModel, DealDetailBaseModel, DealerDepartmentBaseModel, DealerPublicGroupBaseModel, DealerRoleBaseModel, DepartmentAttachBaseModel, DepartmentBaseModel, DepartmentInclusionBaseModel, DepartmentMainBaseModel, FavoriteMenuBaseModel, ItemAttachBaseModel, ItemAttributeBaseModel, ItemBaseModel, ItemCatalogueBaseModel, ItemCategoryBaseModel, ItemCategoryTypeBaseModel, ItemTemplateBaseModel, ItemTemplateDetailBaseModel, MenuArgumentBaseModel, MenuBaseModel, MenuDepartmentBaseModel, MenuPostBaseModel, MenuPublicGroupBaseModel, MenuRoleBaseModel, PrivateGroupAttachBaseModel, PrivateGroupBaseModel, PublicGroupAttachBaseModel, PublicGroupBaseModel, PublicGroupCategoryBaseModel, PublicGroupInclusionBaseModel, PublicGroupSetBaseModel, PublicGroupVersionBaseModel, RoleBaseModel, RoleInclusionBaseModel, RoleSummaryBaseModel, UnitBaseModel, UserBaseModel
既知の実装クラスの一覧:
GenericBaseModel
public interface BaseModel
extends Serializable

基本モデルの情報です。 基本エンティティの1データが基本モデルの1インスタンスに対応します。

導入されたバージョン:
5.0

メソッドの概要
BaseAccessor | getBaseAccessor() 基本アクセサ BaseAccessor を取得します。
ExtendedBaseModelMap | getExtendedBaseModelMap() 拡張基本エンティティに対応する拡張基本モデルのマップを取得します。
InternationalModelMap | getInternationalModelMap() 国際化モデルのマップを取得します。
TerminableModelMap | getTerminableModelMap() 期間化モデルのマップを取得します。
void | init(BaseModelContext context) 基本モデルを初期化します。

メソッドの詳細

init

public void init(BaseModelContext context)
基本モデルを初期化します。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

パラメータ:
context - 基本モデルコンテキスト

getInternationalModelMap

public InternationalModelMap getInternationalModelMap()
国際化モデルのマップを取得します。 この基本モデルに関連する国際化モデルのマップを取得します。

戻り値:
国際化モデルのマップ

getTerminableModelMap

public TerminableModelMap getTerminableModelMap()
期間化モデルのマップを取得します。 この基本モデルに関連する期間化モデルのマップを取得します。

戻り値:
期間化モデルのマップ

getExtendedBaseModelMap

public ExtendedBaseModelMap getExtendedBaseModelMap()
拡張基本エンティティに対応する拡張基本モデルのマップを取得します。

戻り値:
拡張基本モデルマップ

getBaseAccessor

public BaseAccessor getBaseAccessor()
基本アクセサ BaseAccessor を取得します。 このメソッドはシステム内で使用されます。明示的に使用しないでください。

戻り値:
基本アクセサ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BaseModelContext (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース BaseModelContext

public interface BaseModelContext

基本モデルの初期化に必要な設定を持ちます。

導入されたバージョン:
5.0

メソッドの概要
BaseAccessor | getBaseAccessor() 基本アクセサを取得します。
Date | getDefaultDate() デフォルト日時を取得します。
Locale | getDefaultLocale() デフォルト言語を取得します。
ExtendedBaseModelMap | getExtendedBaseModelMap() 拡張基本モデルマップを取得します。
InternationalModelMap | getInternationalModelMap() 国際化モデルマップを取得します。
TerminableModelMap | getTerminableModelMap() 期間化モデルマップを取得します。
void | setBaseAccessor(BaseAccessor accessor) 基本アクセサを設定します。
void | setDefaultDate(Date date) デフォルト日時を設定します。
void | setDefaultLocale(Locale locale) デフォルト言語を設定します。
void | setExtendedBaseModelMap(ExtendedBaseModelMap extendedMap) 拡張基本モデルマップを設定します。
void | setInternationalModelMap(InternationalModelMap internationalMap) 国際化モデルマップを設定します。
void | setTerminableModelMap(TerminableModelMap terminableMap) 期間化モデルマップを設定します。

メソッドの詳細

setBaseAccessor

public void setBaseAccessor(BaseAccessor accessor)
基本アクセサを設定します。

パラメータ:
accessor - 基本アクセサ

getBaseAccessor

public BaseAccessor getBaseAccessor()
基本アクセサを取得します。

戻り値:
基本アクセサ

setDefaultDate

public void setDefaultDate(Date date)
デフォルト日時を設定します。

パラメータ:
date - 日時

getDefaultDate

public Date getDefaultDate()
デフォルト日時を取得します。

戻り値:
日時

setDefaultLocale

public void setDefaultLocale(Locale locale)
デフォルト言語を設定します。

パラメータ:
locale - 言語

getDefaultLocale

public Locale getDefaultLocale()
デフォルト言語を取得します。

戻り値:
言語

setInternationalModelMap

public void setInternationalModelMap(InternationalModelMap internationalMap)
国際化モデルマップを設定します。

パラメータ:
internationalMap - 国際化モデルマップ

getInternationalModelMap

public InternationalModelMap getInternationalModelMap()
国際化モデルマップを取得します。

戻り値:
国際化モデルマップ

setTerminableModelMap

public void setTerminableModelMap(TerminableModelMap terminableMap)
期間化モデルマップを設定します。

パラメータ:
terminableMap - 期間化モデルマップ

getTerminableModelMap

public TerminableModelMap getTerminableModelMap()
期間化モデルマップを取得します。

戻り値:
期間化モデルマップ

setExtendedBaseModelMap

public void setExtendedBaseModelMap(ExtendedBaseModelMap extendedMap)
拡張基本モデルマップを設定します。

パラメータ:
extendedMap - 拡張基本モデルマップ

getExtendedBaseModelMap

public ExtendedBaseModelMap getExtendedBaseModelMap()
拡張基本モデルマップを取得します。

戻り値:
拡張基本モデルマップ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース ExtendedBaseModel

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
ExtendedGenericBaseModel
public interface ExtendedBaseModel
extends Serializable

拡張基本モデルの情報です。 基本エンティティの拡張部分に対応するモデル情報です。拡張基本エンティティの1データが拡張基本モデルの1インスタンスに対応します。

導入されたバージョン:
5.0

メソッドの概要
 void init(ExtendedBaseAccessor accessor)
拡張基本モデルを初期化します。

メソッドの詳細

init

public void init(ExtendedBaseAccessor accessor)
拡張基本モデルを初期化します。

パラメータ:
accessor - 拡張基本アクセサ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedBaseModelMap (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース ExtendedBaseModelMap

既知の実装クラスの一覧:
ExtendedGenericBaseModelMap
public interface ExtendedBaseModelMap

拡張基本モデルのマッピング情報を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedBaseModel | createExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
ExtendedBaseModel | findExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。
void | remove(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。

メソッドの詳細

createExtendedBaseModel

public ExtendedBaseModel createExtendedBaseModel(String name)
                                          throws AccessorException
拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

パラメータ:
name - 拡張名
戻り値:
拡張基本モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

findExtendedBaseModel

public ExtendedBaseModel findExtendedBaseModel(String name)
                                        throws AccessorException
拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は null を返します。

パラメータ:
name - 拡張名
戻り値:
拡張基本モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

remove

public void remove(String name)
            throws AccessorException
拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は何もしません。

パラメータ:
name - 拡張名
例外:
AccessorException - アクセサで例外が何らかの発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedGenericBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス ExtendedGenericBaseModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel
すべての実装インタフェース:
ExtendedBaseModel, Serializable
public abstract class ExtendedGenericBaseModel
extends Object
implements ExtendedBaseModel

拡張基本モデルの汎用的な抽象クラスです。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
ExtendedGenericBaseModel()
メソッドの概要
protected Object | get(String name) 指定の属性が保持する値を取得します。
void | init(ExtendedBaseAccessor accessor) 拡張基本モデルを初期化します。
protected void | set(String name, Object value) 指定の属性に値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedGenericBaseModel

public ExtendedGenericBaseModel()
メソッドの詳細

init

public void init(ExtendedBaseAccessor accessor)
拡張基本モデルを初期化します。

定義:
インタフェース ExtendedBaseModel 内の init
パラメータ:
accessor - 拡張基本アクセサ

get

protected Object get(String name)
              throws AccessorException
指定の属性が保持する値を取得します。

パラメータ:
name - 属性名
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
AccessorException - アクセサで例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedGenericBaseModelMap (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス ExtendedGenericBaseModelMap

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap
すべての実装インタフェース:
ExtendedBaseModelMap
public abstract class ExtendedGenericBaseModelMap
extends Object
implements ExtendedBaseModelMap

拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。

導入されたバージョン:
5.0

コンストラクタの概要
ExtendedGenericBaseModelMap()
メソッドの概要
ExtendedBaseModel | createExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
ExtendedBaseModel | findExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。
void | init(ExtendedBaseAccessorMap accessorMap) 初期化を行います。
ExtendedBaseModel | newExtendedBaseModel(String name) 初期化されていない拡張基本モデルのインスタンスを取得します。
void | remove(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedGenericBaseModelMap

public ExtendedGenericBaseModelMap()
メソッドの詳細

init

public void init(ExtendedBaseAccessorMap accessorMap)
初期化を行います。

パラメータ:
accessorMap - 拡張基本アクセサマップ

createExtendedBaseModel

public ExtendedBaseModel createExtendedBaseModel(String name)
                                          throws AccessorException
拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

定義:
インタフェース ExtendedBaseModelMap 内の createExtendedBaseModel
パラメータ:
name - 拡張名
戻り値:
拡張基本モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

findExtendedBaseModel

public ExtendedBaseModel findExtendedBaseModel(String name)
                                        throws AccessorException
拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は null を返します。

定義:
インタフェース ExtendedBaseModelMap 内の findExtendedBaseModel
パラメータ:
name - 拡張名
戻り値:
拡張基本モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

remove

public void remove(String name)
            throws AccessorException
拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は何もしません。

定義:
インタフェース ExtendedBaseModelMap 内の remove
パラメータ:
name - 拡張名
例外:
AccessorException - アクセサで例外が何らかの発生した場合

newExtendedBaseModel

public ExtendedBaseModel newExtendedBaseModel(String name)
                                       throws IllegalExtensionException
初期化されていない拡張基本モデルのインスタンスを取得します。 このメソッドはシステム内で使用されます。明示的に使用しないでください。

パラメータ:
name - 拡張名
戻り値:
拡張基本モデルのインスタンス
例外:
IllegalExtensionException - 存在しない拡張名、または基本属性を持たない拡張名が指定された場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedGenericInternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス ExtendedGenericInternationalModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel
すべての実装インタフェース:
ExtendedInternationalModel, Serializable
public abstract class ExtendedGenericInternationalModel
extends Object
implements ExtendedInternationalModel

拡張国際化モデルの汎用的な抽象クラスです。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
ExtendedGenericInternationalModel()
メソッドの概要
protected Object | get(String name) 指定の属性が保持する値を取得します。
void | init(ExtendedInternationalAccessor accessor) 拡張国際化モデルを初期化します。
protected void | set(String name, Object value) 指定の属性に値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedGenericInternationalModel

public ExtendedGenericInternationalModel()
メソッドの詳細

init

public void init(ExtendedInternationalAccessor accessor)
拡張国際化モデルを初期化します。

定義:
インタフェース ExtendedInternationalModel 内の init
パラメータ:
accessor - 拡張国際化アクセサ

get

protected Object get(String name)
              throws AccessorException
指定の属性が保持する値を取得します。

パラメータ:
name - 属性名
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
AccessorException - アクセサで例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedGenericInternationalModelMap (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス ExtendedGenericInternationalModelMap

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap
すべての実装インタフェース:
ExtendedInternationalModelMap
public abstract class ExtendedGenericInternationalModelMap
extends Object
implements ExtendedInternationalModelMap

拡張国際化モデルのマッピング情報を持つ汎用的な抽象クラスです。

導入されたバージョン:
5.0

コンストラクタの概要
ExtendedGenericInternationalModelMap()
メソッドの概要
ExtendedInternationalModel | createExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
ExtendedInternationalModel | findExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
void | init(ExtendedInternationalAccessorMap accessorMap) 初期化を行います。
ExtendedInternationalModel | newExtendedInternationalModel(String name) 初期化されていない拡張国際化モデルのインスタンスを取得します。
void | remove(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedGenericInternationalModelMap

public ExtendedGenericInternationalModelMap()
メソッドの詳細

init

public void init(ExtendedInternationalAccessorMap accessorMap)
初期化を行います。

パラメータ:
accessorMap - 拡張国際化アクセサマップ

createExtendedInternationalModel

public ExtendedInternationalModel createExtendedInternationalModel(String name)
                                                            throws AccessorException
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

定義:
インタフェース ExtendedInternationalModelMap 内の createExtendedInternationalModel
パラメータ:
name - 拡張名
戻り値:
拡張基本モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

findExtendedInternationalModel

public ExtendedInternationalModel findExtendedInternationalModel(String name)
                                                          throws AccessorException
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は null を返します。

定義:
インタフェース ExtendedInternationalModelMap 内の findExtendedInternationalModel
パラメータ:
name - 拡張名
戻り値:
拡張基本モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

remove

public void remove(String name)
            throws AccessorException
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は何もしません。

定義:
インタフェース ExtendedInternationalModelMap 内の remove
パラメータ:
name - 拡張名
例外:
AccessorException - アクセサで例外が何らかの発生した場合

newExtendedInternationalModel

public ExtendedInternationalModel newExtendedInternationalModel(String name)
初期化されていない拡張国際化モデルのインスタンスを取得します。 このメソッドはシステム内で使用されます。明示的に使用しないでください。

パラメータ:
name - 拡張名
戻り値:
拡張国際化モデルのインスタンス
例外:
ModelCreateException - 拡張モデルのインスタンスの生成に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedGenericTerminableInternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス ExtendedGenericTerminableInternationalModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel
すべての実装インタフェース:
ExtendedTerminableInternationalModel, Serializable
public abstract class ExtendedGenericTerminableInternationalModel
extends Object
implements ExtendedTerminableInternationalModel

拡張期間国際化モデルの汎用的な抽象クラスです。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
ExtendedGenericTerminableInternationalModel()
メソッドの概要
protected Object | get(String name) 指定の属性が保持する値を取得します。
void | init(ExtendedTerminableInternationalAccessor accessor) 拡張期間国際化モデルを初期化します。
protected void | set(String name, Object value) 指定の属性に値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedGenericTerminableInternationalModel

public ExtendedGenericTerminableInternationalModel()
メソッドの詳細

init

public void init(ExtendedTerminableInternationalAccessor accessor)
拡張期間国際化モデルを初期化します。

定義:
インタフェース ExtendedTerminableInternationalModel 内の init
パラメータ:
accessor - 拡張期間国際化アクセサ

get

protected Object get(String name)
              throws AccessorException
指定の属性が保持する値を取得します。

パラメータ:
name - 属性名
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
AccessorException - アクセサで例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedGenericTerminableInternationalModelMap (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス ExtendedGenericTerminableInternationalModelMap

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap
すべての実装インタフェース:
ExtendedTerminableInternationalModelMap
public abstract class ExtendedGenericTerminableInternationalModelMap
extends Object
implements ExtendedTerminableInternationalModelMap

拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。

導入されたバージョン:
5.0

コンストラクタの概要
ExtendedGenericTerminableInternationalModelMap()
メソッドの概要
ExtendedTerminableInternationalModel | createExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
ExtendedTerminableInternationalModel | findExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
void | init(ExtendedTerminableInternationalAccessorMap accessorMap) 初期化を行います。
ExtendedTerminableInternationalModel | newExtendedTerminableInternationalModel(String name) 初期化されていない拡張期間国際化モデルのインスタンスを取得します。
void | remove(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedGenericTerminableInternationalModelMap

public ExtendedGenericTerminableInternationalModelMap()
メソッドの詳細

init

public void init(ExtendedTerminableInternationalAccessorMap accessorMap)
初期化を行います。

パラメータ:
accessorMap - 拡張期間国際化アクセサマップ

createExtendedTerminableInternationalModel

public ExtendedTerminableInternationalModel createExtendedTerminableInternationalModel(String name)
                                                                                throws AccessorException
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

定義:
インタフェース ExtendedTerminableInternationalModelMap 内の createExtendedTerminableInternationalModel
パラメータ:
name - 拡張名
戻り値:
拡張期間国際化モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

findExtendedTerminableInternationalModel

public ExtendedTerminableInternationalModel findExtendedTerminableInternationalModel(String name)
                                                                              throws AccessorException
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は null を返します。

定義:
インタフェース ExtendedTerminableInternationalModelMap 内の findExtendedTerminableInternationalModel
パラメータ:
name - 拡張名
戻り値:
拡張期間国際化モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

remove

public void remove(String name)
            throws AccessorException
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は何もしません。

定義:
インタフェース ExtendedTerminableInternationalModelMap 内の remove
パラメータ:
name - 拡張名
例外:
AccessorException - アクセサで例外が何らかの発生した場合

newExtendedTerminableInternationalModel

public ExtendedTerminableInternationalModel newExtendedTerminableInternationalModel(String name)
                                                                             throws IllegalExtensionException
初期化されていない拡張期間国際化モデルのインスタンスを取得します。 このメソッドはシステム内で使用されます。明示的に使用しないでください。

パラメータ:
name - 拡張名
戻り値:
拡張期間国際化モデルのインスタンス
例外:
IllegalExtensionException - 存在しない拡張名、または期間国際化属性を持たない拡張名が指定された場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedGenericTerminableModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス ExtendedGenericTerminableModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel
すべての実装インタフェース:
ExtendedTerminableModel, Serializable
public abstract class ExtendedGenericTerminableModel
extends Object
implements ExtendedTerminableModel

拡張期間化モデルの汎用的な抽象クラスです。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
ExtendedGenericTerminableModel()
メソッドの概要
protected Object | get(String name) 指定の属性が保持する値を取得します。
void | init(ExtendedTerminableAccessor accessor) 拡張期間化モデルを初期化します。
protected void | set(String name, Object value) 指定の属性に値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedGenericTerminableModel

public ExtendedGenericTerminableModel()
メソッドの詳細

init

public void init(ExtendedTerminableAccessor accessor)
拡張期間化モデルを初期化します。

定義:
インタフェース ExtendedTerminableModel 内の init
パラメータ:
accessor - 拡張期間化アクセサ

get

protected Object get(String name)
              throws AccessorException
指定の属性が保持する値を取得します。

パラメータ:
name - 属性名
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
AccessorException - アクセサで例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedGenericTerminableModelMap (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス ExtendedGenericTerminableModelMap

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap
すべての実装インタフェース:
ExtendedTerminableModelMap
public abstract class ExtendedGenericTerminableModelMap
extends Object
implements ExtendedTerminableModelMap

拡張期間化モデルのマッピング情報を持つ汎用的な抽象クラスです。

導入されたバージョン:
5.0

コンストラクタの概要
ExtendedGenericTerminableModelMap()
メソッドの概要
ExtendedTerminableModel | createExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
ExtendedTerminableModel | findExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
void | init(ExtendedTerminableAccessorMap accessorMap) 初期化を行います。
ExtendedTerminableModel | newExtendedTerminableModel(String name) 初期化されてていない拡張期間化モデルのインスタンスを取得します。
void | remove(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedGenericTerminableModelMap

public ExtendedGenericTerminableModelMap()
メソッドの詳細

init

public void init(ExtendedTerminableAccessorMap accessorMap)
初期化を行います。

パラメータ:
accessorMap - 拡張期間化アクセサマップ

createExtendedTerminableModel

public ExtendedTerminableModel createExtendedTerminableModel(String name)
                                                      throws AccessorException
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

定義:
インタフェース ExtendedTerminableModelMap 内の createExtendedTerminableModel
パラメータ:
name - 拡張名
戻り値:
拡張期間化モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

findExtendedTerminableModel

public ExtendedTerminableModel findExtendedTerminableModel(String name)
                                                    throws AccessorException
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は null を返します。

定義:
インタフェース ExtendedTerminableModelMap 内の findExtendedTerminableModel
パラメータ:
name - 拡張名
戻り値:
拡張期間化モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

remove

public void remove(String name)
            throws AccessorException
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は何もしません。

定義:
インタフェース ExtendedTerminableModelMap 内の remove
パラメータ:
name - 拡張名
例外:
AccessorException - アクセサで例外が何らかの発生した場合

newExtendedTerminableModel

public ExtendedTerminableModel newExtendedTerminableModel(String name)
                                                   throws IllegalExtensionException
初期化されてていない拡張期間化モデルのインスタンスを取得します。 このメソッドはシステム内で使用されます。明示的に使用しないでください。

パラメータ:
name - 拡張名
戻り値:
拡張期間化モデルのインスタンス
例外:
IllegalExtensionException - 存在しない拡張名、または期間化属性を持たない拡張名が指定された場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedInternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース ExtendedInternationalModel

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
ExtendedGenericInternationalModel
public interface ExtendedInternationalModel
extends Serializable

拡張国際化モデルの情報です。 国際化エンティティの拡張部分に対応するモデル情報です。拡張国際化エンティティの1データが拡張国際化モデルの1インスタンスに対応します。

導入されたバージョン:
5.0

メソッドの概要
 void init(ExtendedInternationalAccessor accessor)
拡張国際化モデルを初期化します。

メソッドの詳細

init

public void init(ExtendedInternationalAccessor accessor)
拡張国際化モデルを初期化します。

パラメータ:
accessor - 拡張国際化アクセサ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedInternationalModelMap (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース ExtendedInternationalModelMap

既知の実装クラスの一覧:
ExtendedGenericInternationalModelMap
public interface ExtendedInternationalModelMap

拡張国際化モデルのマッピング情報を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedInternationalModel | createExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
ExtendedInternationalModel | findExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
void | remove(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。

メソッドの詳細

createExtendedInternationalModel

public ExtendedInternationalModel createExtendedInternationalModel(String name)
                                                            throws AccessorException
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

パラメータ:
name - 拡張名
戻り値:
拡張基本モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

findExtendedInternationalModel

public ExtendedInternationalModel findExtendedInternationalModel(String name)
                                                          throws AccessorException
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は null を返します。

パラメータ:
name - 拡張名
戻り値:
拡張基本モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

remove

public void remove(String name)
            throws AccessorException
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は何もしません。

パラメータ:
name - 拡張名
例外:
AccessorException - アクセサで例外が何らかの発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableInternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース ExtendedTerminableInternationalModel

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
ExtendedGenericTerminableInternationalModel
public interface ExtendedTerminableInternationalModel
extends Serializable

拡張期間国際化モデルの情報です。 期間国際化エンティティの拡張部分に対応するモデル情報です。拡張期間国際化エンティティの1データが拡張期間国際化モデルの1インスタンスに対応します。

導入されたバージョン:
5.0

メソッドの概要
 void init(ExtendedTerminableInternationalAccessor accessor)
拡張期間国際化モデルを初期化します。

メソッドの詳細

init

public void init(ExtendedTerminableInternationalAccessor accessor)
拡張期間国際化モデルを初期化します。

パラメータ:
accessor - 拡張期間国際化アクセサ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableInternationalModelMap (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース ExtendedTerminableInternationalModelMap

既知の実装クラスの一覧:
ExtendedGenericTerminableInternationalModelMap
public interface ExtendedTerminableInternationalModelMap

拡張期間国際化モデルのマッピング情報を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedTerminableInternationalModel | createExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
ExtendedTerminableInternationalModel | findExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
void | remove(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。

メソッドの詳細

createExtendedTerminableInternationalModel

public ExtendedTerminableInternationalModel createExtendedTerminableInternationalModel(String name)
                                                                                throws AccessorException
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

パラメータ:
name - 拡張名
戻り値:
拡張期間国際化モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

findExtendedTerminableInternationalModel

public ExtendedTerminableInternationalModel findExtendedTerminableInternationalModel(String name)
                                                                              throws AccessorException
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は null を返します。

パラメータ:
name - 拡張名
戻り値:
拡張期間国際化モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

remove

public void remove(String name)
            throws AccessorException
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は何もしません。

パラメータ:
name - 拡張名
例外:
AccessorException - アクセサで例外が何らかの発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース ExtendedTerminableModel

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
ExtendedGenericTerminableModel
public interface ExtendedTerminableModel
extends Serializable

拡張期間化モデルの情報です。 期間化エンティティの拡張部分に対応するモデル情報です。拡張期間化エンティティの1データが拡張期間化モデルの1インスタンスに対応します。

導入されたバージョン:
5.0

メソッドの概要
 void init(ExtendedTerminableAccessor accessor)
拡張期間化モデルを初期化します。

メソッドの詳細

init

public void init(ExtendedTerminableAccessor accessor)
拡張期間化モデルを初期化します。

パラメータ:
accessor - 拡張期間化アクセサ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableModelMap (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース ExtendedTerminableModelMap

既知の実装クラスの一覧:
ExtendedGenericTerminableModelMap
public interface ExtendedTerminableModelMap

拡張期間化モデルのマッピング情報を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedTerminableModel | createExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
ExtendedTerminableModel | findExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
void | remove(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。

メソッドの詳細

createExtendedTerminableModel

public ExtendedTerminableModel createExtendedTerminableModel(String name)
                                                      throws AccessorException
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

パラメータ:
name - 拡張名
戻り値:
拡張期間化モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

findExtendedTerminableModel

public ExtendedTerminableModel findExtendedTerminableModel(String name)
                                                    throws AccessorException
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は null を返します。

パラメータ:
name - 拡張名
戻り値:
拡張期間化モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

remove

public void remove(String name)
            throws AccessorException
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は何もしません。

パラメータ:
name - 拡張名
例外:
AccessorException - アクセサで例外が何らかの発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス GenericBaseModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel
すべての実装インタフェース:
BaseModel, Serializable
public abstract class GenericBaseModel
extends Object
implements BaseModel

基本モデルの汎用的な抽象クラスです。 このクラスでは、 init(BaseModelContext)で設定された基本アクセサを getBaseAccessor() で取得することができます。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
GenericBaseModel()
メソッドの概要
protected Object | get(String name) 指定の属性が保持する値を取得します。
protected Object | get(String name, Date date) 指定の属性が、指定の日時に保持している値を取得します。
protected Object | get(String name, Date date, Locale locale) 指定の属性が、指定の日時、言語で保持している値を取得します。
protected Object | get(String name, Locale locale) 指定の属性が、指定の言語で保持している値を取得します。
BaseAccessor | getBaseAccessor() この基本モデルに割り当てられた基本アクセサを取得します。
protected Date | getDefaultDate() モデル生成時に設定されたデフォルト日時を取得します。
protected Locale | getDefaultLocale() モデル生成時に設定されたデフォルト言語を取得します。
ExtendedBaseModelMap | getExtendedBaseModelMap() 拡張基本モデルのマップを取得します。
InternationalModelMap | getInternationalModelMap() 国際化モデルのマップを取得します。
TerminableModelMap | getTerminableModelMap() 期間化モデルのマップを取得します。
void | init(BaseModelContext context) 基本モデルを初期化します。
protected InternationalModel | selectInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。
protected TerminableModel | selectTerminableModel(Date date) 指定された日時に該当する期間化モデルを取得します。
protected void | set(String name, Object value) 指定の属性に値を設定します。
protected void | set(String name, Object value, Date date) 指定の属性に、指定の日時で値を設定します。
protected void | set(String name, Object value, Date date, Locale locale) 指定の属性に、指定の日時、言語で値を設定します。
protected void | set(String name, Object value, Locale locale) 指定の属性に、指定の言語で値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericBaseModel

public GenericBaseModel()
メソッドの詳細

init

public void init(BaseModelContext context)
基本モデルを初期化します。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

定義:
インタフェース BaseModel 内の init
パラメータ:
context - 基本モデルコンテキスト

getBaseAccessor

public BaseAccessor getBaseAccessor()
この基本モデルに割り当てられた基本アクセサを取得します。

定義:
インタフェース BaseModel 内の getBaseAccessor
戻り値:
基本アクセサ

getInternationalModelMap

public InternationalModelMap getInternationalModelMap()
国際化モデルのマップを取得します。 この基本モデルに関連する国際化モデルのマップを取得します。

定義:
インタフェース BaseModel 内の getInternationalModelMap
戻り値:
国際化モデルマップ

selectInternationalModel

protected InternationalModel selectInternationalModel(Locale locale)
                                               throws IllegalLocaleException
指定された言語に該当する国際化モデルを取得します。

パラメータ:
locale - 言語
戻り値:
国際化モデル
例外:
IllegalLocaleException - 言語に関する例外が発生した場合

getTerminableModelMap

public TerminableModelMap getTerminableModelMap()
期間化モデルのマップを取得します。 この基本モデルに関連する期間化モデルのマップを取得します。

定義:
インタフェース BaseModel 内の getTerminableModelMap
戻り値:
期間化モデルマップ

selectTerminableModel

protected TerminableModel selectTerminableModel(Date date)
                                         throws IllegalTermException
指定された日時に該当する期間化モデルを取得します。

パラメータ:
date - 日時
戻り値:
期間化モデル
例外:
IllegalTermException - 期間に関する例外が発生した場合

getExtendedBaseModelMap

public ExtendedBaseModelMap getExtendedBaseModelMap()
拡張基本モデルのマップを取得します。 この基本モデルに関連する拡張基本モデルのマップを取得します。

定義:
インタフェース BaseModel 内の getExtendedBaseModelMap
戻り値:
拡張基本モデルマップ

getDefaultDate

protected Date getDefaultDate()
モデル生成時に設定されたデフォルト日時を取得します。

戻り値:
デフォルト日時

getDefaultLocale

protected Locale getDefaultLocale()
モデル生成時に設定されたデフォルト言語を取得します。

戻り値:
デフォルト言語

get

protected Object get(String name)
              throws AccessorException
指定の属性が保持する値を取得します。

パラメータ:
name - 属性名
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

get

protected Object get(String name,
                     Date date)
              throws AccessorException
指定の属性が、指定の日時に保持している値を取得します。

パラメータ:
name - 属性名
date - 日時
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

get

protected Object get(String name,
                     Locale locale)
              throws AccessorException
指定の属性が、指定の言語で保持している値を取得します。

パラメータ:
name - 属性名
locale - 言語
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

get

protected Object get(String name,
                     Date date,
                     Locale locale)
              throws AccessorException
指定の属性が、指定の日時、言語で保持している値を取得します。

パラメータ:
name - 属性名
date - 日時
locale - 言語
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value,
                   Date date)
            throws AccessorException
指定の属性に、指定の日時で値を設定します。

パラメータ:
name - 属性名
value - 値
date - 日時
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value,
                   Locale locale)
            throws AccessorException
指定の属性に、指定の言語で値を設定します。

パラメータ:
name - 属性名
value - 値
locale - 言語
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value,
                   Date date,
                   Locale locale)
            throws AccessorException
指定の属性に、指定の日時、言語で値を設定します。

パラメータ:
name - 属性名
value - 値
date - 日時
locale - 言語
例外:
AccessorException - アクセサで例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericInternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス GenericInternationalModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel
すべての実装インタフェース:
InternationalModel, Serializable
public abstract class GenericInternationalModel
extends Object
implements InternationalModel

国際化モデルの汎用的な抽象クラスです。 このクラスでは、 init(InternationalModelContext)で設定された国際化アクセサを getInternationalAccessor()で取得することができます。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
GenericInternationalModel()
メソッドの概要
protected Object | get(String name) 指定の属性が保持する値を取得します。
ExtendedInternationalModelMap | getExtendedInternationalModelMap() 拡張国際化モデルのマップを取得します。
protected InternationalAccessor | getInternationalAccessor() この国際化モデルに割り当てられた国際化アクセサを取得します。
Locale | getLocale() 国際化モデルが保持する言語 Locale を取得します。
void | init(InternationalModelContext context) 国際化モデルを初期化します。
protected void | set(String name, Object value) 指定の属性に値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericInternationalModel

public GenericInternationalModel()
メソッドの詳細

init

public void init(InternationalModelContext context)
国際化モデルを初期化します。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

定義:
インタフェース InternationalModel 内の init
パラメータ:
context - 国際化モデルコンテキスト

getInternationalAccessor

protected InternationalAccessor getInternationalAccessor()
この国際化モデルに割り当てられた国際化アクセサを取得します。

戻り値:
国際化アクセサ

getExtendedInternationalModelMap

public ExtendedInternationalModelMap getExtendedInternationalModelMap()
拡張国際化モデルのマップを取得します。 この国際化モデルに関連する拡張国際化モデルのマップを取得します。

定義:
インタフェース InternationalModel 内の getExtendedInternationalModelMap
戻り値:
拡張国際化モデルマップ

get

protected Object get(String name)
              throws AccessorException
指定の属性が保持する値を取得します。

パラメータ:
name - 属性名
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
AccessorException - アクセサで例外が発生した場合

getLocale

public Locale getLocale()
国際化モデルが保持する言語 Locale を取得します。 このメソッドをオーバーライドすると言語を取得することが出来なくなります。

定義:
インタフェース InternationalModel 内の getLocale
戻り値:
言語
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericInternationalModelMap (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス GenericInternationalModelMap

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap
すべての実装インタフェース:
InternationalModelMap, Serializable
public abstract class GenericInternationalModelMap
extends Object
implements InternationalModelMap

国際化モデルマッピングの汎用的な抽象クラスです。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
GenericInternationalModelMap()
メソッドの概要
InternationalModel | createInternationalModel(Locale locale) 国際化モデルを生成します。
boolean | exists(Locale locale) 指定された言語に該当する国際化モデルが存在するどうか判定します。
InternationalModel | findInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。
Locale[] | getLocales() マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。
void | init(String modelName, InternationalAccessorMap accessorMap) 初期化処理を行います。
InternationalModel | newInternationalModel(Locale locale) 初期化されていない国際化モデルのインスタンスを取得します。
void | remove(Locale locale) 指定された言語に該当するデータを削除します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericInternationalModelMap

public GenericInternationalModelMap()
メソッドの詳細

init

public void init(String modelName,
                 InternationalAccessorMap accessorMap)
初期化処理を行います。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

パラメータ:
modelName - モデル名
accessorMap - 国際化アクセサマップ

createInternationalModel

public InternationalModel createInternationalModel(Locale locale)
                                            throws AccessorException
国際化モデルを生成します。 引数で指定された言語に該当する既存の情報は新しい情報で上書きされます。 システムで取り扱う言語のみが対象となります。

定義:
インタフェース InternationalModelMap 内の createInternationalModel
パラメータ:
locale - 言語
戻り値:
国際化モデル
例外:
AccessorException - システムで使用することができない言語が指定された場合

exists

public boolean exists(Locale locale)
指定された言語に該当する国際化モデルが存在するどうか判定します。

定義:
インタフェース InternationalModelMap 内の exists
パラメータ:
locale - 言語
戻り値:
指定された言語に該当する国際化モデルが存在する場合は true、それ以外は false

findInternationalModel

public InternationalModel findInternationalModel(Locale locale)
                                          throws IllegalLocaleException
指定された言語に該当する国際化モデルを取得します。 引数 locale で指定された言語に該当する　TerminableModel を取得します。該当するものが存在しない場合、 null が返されます。

定義:
インタフェース InternationalModelMap 内の findInternationalModel
パラメータ:
locale - 対象となる言語
戻り値:
対象となる国際化モデル（存在しない場合は null）
例外:
IllegalLocaleException - 対象のlocale が見つからない場合

remove

public void remove(Locale locale)
            throws AccessorException
指定された言語に該当するデータを削除します。

定義:
インタフェース InternationalModelMap 内の remove
パラメータ:
locale - 削除対象の言語
例外:
AccessorException - アクセサで例外が発生した場合

newInternationalModel

public InternationalModel newInternationalModel(Locale locale)
                                         throws IllegalLocaleException
初期化されていない国際化モデルのインスタンスを取得します。 このメソッドはシステム内で使用されます。明示的に使用しないでください。

パラメータ:
locale - 言語
戻り値:
国際化モデルのインスタンス
例外:
IllegalLocaleException - 言語に関する例外が発生した場合

getLocales

public Locale[] getLocales()
マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。

定義:
インタフェース InternationalModelMap 内の getLocales
戻り値:
言語の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericTerminableInternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス GenericTerminableInternationalModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel
すべての実装インタフェース:
Serializable, TerminableInternationalModel
public abstract class GenericTerminableInternationalModel
extends Object
implements TerminableInternationalModel

期間国際化モデルの汎用的な抽象クラスです。 このクラスでは、 init(TerminableInternationalModelContext)で設定された期間国際化アクセサを getTerminableInternationalAccessor()で取得することができます。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
GenericTerminableInternationalModel()
メソッドの概要
protected Object | get(String name) 指定の属性が保持する値を取得します。
ExtendedTerminableInternationalModelMap | getExtendedTerminableInternationalModelMap() 拡張期間国際化モデルのマップを取得します。
Locale | getLocale() 期間国際化モデルが保持する言語 Locale を取得します。
protected TerminableInternationalAccessor | getTerminableInternationalAccessor() この期間国際化モデルに割り当てられた期間国際化アクセサを取得します。
void | init(TerminableInternationalModelContext context) 期間国際化モデルを初期化します。
protected void | set(String name, Object value) 指定の属性に値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericTerminableInternationalModel

public GenericTerminableInternationalModel()
メソッドの詳細

init

public void init(TerminableInternationalModelContext context)
期間国際化モデルを初期化します。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

定義:
インタフェース TerminableInternationalModel 内の init
パラメータ:
context - 期間国際化モデルコンテキスト

getTerminableInternationalAccessor

protected TerminableInternationalAccessor getTerminableInternationalAccessor()
この期間国際化モデルに割り当てられた期間国際化アクセサを取得します。

戻り値:
期間国際化アクセサ

getExtendedTerminableInternationalModelMap

public ExtendedTerminableInternationalModelMap getExtendedTerminableInternationalModelMap()
拡張期間国際化モデルのマップを取得します。 この期間国際化モデルに関連する拡張期間国際化モデルのマップを取得します。

定義:
インタフェース TerminableInternationalModel 内の getExtendedTerminableInternationalModelMap
戻り値:
拡張期間国際化モデルマップ

get

protected Object get(String name)
              throws AccessorException
指定の属性が保持する値を取得します。

パラメータ:
name - 属性名
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
AccessorException - アクセサで例外が発生した場合

getLocale

public Locale getLocale()
期間国際化モデルが保持する言語 Locale を取得します。 このメソッドをオーバーライドすると言語を取得することが出来なくなります。

定義:
インタフェース TerminableInternationalModel 内の getLocale
戻り値:
言語
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericTerminableInternationalModelMap (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス GenericTerminableInternationalModelMap

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap
すべての実装インタフェース:
Serializable, TerminableInternationalModelMap
public abstract class GenericTerminableInternationalModelMap
extends Object
implements TerminableInternationalModelMap

期間国際化モデルマッピングの汎用的な抽象クラスです。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
GenericTerminableInternationalModelMap()
メソッドの概要
TerminableInternationalModel | createTerminableInternationalModel(Locale locale) 期間国際化モデルを生成します。
boolean | exists(Locale locale) 指定された言語に該当する期間国際化モデルが存在するかどうか判定します。
TerminableInternationalModel | findTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
Locale[] | getLocales() マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。
void | init(String modelName, TerminableInternationalAccessorMap accessorMap) 初期化処理を行います。
TerminableInternationalModel | newTerminableInternationalModel(Locale locale) 初期化されていない期間国際化モデルのインスタンスを取得します。
void | remove(Locale locale) 指定された言語に該当するデータを削除します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericTerminableInternationalModelMap

public GenericTerminableInternationalModelMap()
メソッドの詳細

init

public void init(String modelName,
                 TerminableInternationalAccessorMap accessorMap)
初期化処理を行います。

パラメータ:
modelName - 期間国際化モデルのクラス名
accessorMap - 期間国際化アクセサマップ

createTerminableInternationalModel

public TerminableInternationalModel createTerminableInternationalModel(Locale locale)
                                                                throws AccessorException
期間国際化モデルを生成します。 引数で指定された言語に該当する既存の情報は新しい情報で上書きされます。 システムで取り扱う言語のみが対象となります。

定義:
インタフェース TerminableInternationalModelMap 内の createTerminableInternationalModel
パラメータ:
locale - 言語
戻り値:
期間国際化モデル
例外:
AccessorException - システムで使用することができない言語が指定された場合

exists

public boolean exists(Locale locale)
指定された言語に該当する期間国際化モデルが存在するかどうか判定します。

定義:
インタフェース TerminableInternationalModelMap 内の exists
パラメータ:
locale - 言語
戻り値:
対象となる期間国際化モデルが存在する場合 true、それ以外は false

findTerminableInternationalModel

public TerminableInternationalModel findTerminableInternationalModel(Locale locale)
                                                              throws IllegalLocaleException
指定された言語に該当する期間国際化モデルを取得します。 引数 locale で指定された言語に該当する TerminableInternationalModelを取得します。該当するものが存在しない場合、 null が返されます。

定義:
インタフェース TerminableInternationalModelMap 内の findTerminableInternationalModel
パラメータ:
locale - 対象となる言語
戻り値:
対象となる期間国際化モデル（存在しない場合は null）
例外:
IllegalLocaleException - 対象の言語が見つからない場合

remove

public void remove(Locale locale)
            throws AccessorException
指定された言語に該当するデータを削除します。

定義:
インタフェース TerminableInternationalModelMap 内の remove
パラメータ:
locale - 削除対象の言語
例外:
AccessorException - アクセサで例外が発生した場合

newTerminableInternationalModel

public TerminableInternationalModel newTerminableInternationalModel(Locale locale)
                                                             throws IllegalLocaleException
初期化されていない期間国際化モデルのインスタンスを取得します。 このメソッドはシステム内で使用されます。明示的に使用しないでください。

パラメータ:
locale - 言語
戻り値:
期間国際化モデルのインスタンス
例外:
IllegalLocaleException - 言語に関する例外が発生した場合

getLocales

public Locale[] getLocales()
マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。

定義:
インタフェース TerminableInternationalModelMap 内の getLocales
戻り値:
言語の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericTerminableModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス GenericTerminableModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel
すべての実装インタフェース:
Serializable, TerminableModel
public abstract class GenericTerminableModel
extends Object
implements TerminableModel

期間化モデルの汎用的な抽象クラスです。 このクラスでは、 init(TerminableModelContext)で設定された期間化アクセサを getTerminableAccessor()で取得することができます。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
GenericTerminableModel()
メソッドの概要
protected Object | get(String name) 指定の属性が保持する値を取得します。
protected Object | get(String name, Locale locale) 指定の属性が指定の言語で保持する値を取得します。
protected Locale | getDefaultLocale() モデル生成時に指定された言語を取得します。
ExtendedTerminableModelMap | getExtendedTerminableModelMap() 拡張期間化モデルのマップを取得します。
Term | getTerm() 期間化モデルが保持する期間 Term を取得します。
protected TerminableAccessor | getTerminableAccessor() この期間化モデルに割り当てられた期間化アクセサを取得します。
TerminableInternationalModelMap | getTerminableInternationalModelMap() 期間国際化モデルのマップを取得します。
void | init(TerminableModelContext context) 期間化モデルを初期化します。
protected TerminableInternationalModel | selectTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
protected void | set(String name, Object value) 指定の属性に値を設定します。
protected void | set(String name, Object value, Locale locale) 指定の属性に値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericTerminableModel

public GenericTerminableModel()
メソッドの詳細

init

public void init(TerminableModelContext context)
期間化モデルを初期化します。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

定義:
インタフェース TerminableModel 内の init
パラメータ:
context - 期間化モデルコンテキスト

getTerminableAccessor

protected TerminableAccessor getTerminableAccessor()
この期間化モデルに割り当てられた期間化アクセサを取得します。

戻り値:
期間化アクセサ

getTerminableInternationalModelMap

public TerminableInternationalModelMap getTerminableInternationalModelMap()
期間国際化モデルのマップを取得します。 この期間化モデルに関連する期間国際化モデルのマップを取得します。

定義:
インタフェース TerminableModel 内の getTerminableInternationalModelMap
戻り値:
期間国際化モデルマップ

selectTerminableInternationalModel

protected TerminableInternationalModel selectTerminableInternationalModel(Locale locale)
                                                                   throws IllegalLocaleException
指定された言語に該当する期間国際化モデルを取得します。

パラメータ:
locale - 言語
戻り値:
期間国際化モデル
例外:
IllegalLocaleException - 言語に関する問題が発生した場合

getExtendedTerminableModelMap

public ExtendedTerminableModelMap getExtendedTerminableModelMap()
拡張期間化モデルのマップを取得します。 この期間化モデルに関連する拡張期間化モデルのマップを取得します。

定義:
インタフェース TerminableModel 内の getExtendedTerminableModelMap
戻り値:
拡張期間化モデルマップ

getDefaultLocale

protected Locale getDefaultLocale()
モデル生成時に指定された言語を取得します。

戻り値:
モデル生成時のlocale

get

protected Object get(String name)
              throws AccessorException
指定の属性が保持する値を取得します。

パラメータ:
name - 属性名
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

get

protected Object get(String name,
                     Locale locale)
              throws AccessorException
指定の属性が指定の言語で保持する値を取得します。

パラメータ:
name - 属性名
locale - 言語
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value,
                   Locale locale)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
IllegalLocaleException - 言語に関する例外が発生した場合
AccessorException - アクセサで例外が発生した場合

getTerm

public Term getTerm()
期間化モデルが保持する期間 Term を取得します。 このメソッドをオーバーライドすると期間を取得できなくなります。

定義:
インタフェース TerminableModel 内の getTerm
戻り値:
期間
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericTerminableModelMap (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス GenericTerminableModelMap

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap
すべての実装インタフェース:
Serializable, TerminableModelMap
public abstract class GenericTerminableModelMap
extends Object
implements TerminableModelMap

期間化モデルマッピングの汎用的な抽象クラスです。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
GenericTerminableModelMap()
メソッドの概要
TerminableModel | createTerminableModel(Term term) 指定した期間を満たす期間化モデルを生成します。
boolean | exists(Date date) 指定された日時を含む期間化モデルが存在するかどうか判定します。
TerminableModel | findTerminableModel(Date date) 指定された日時に該当する期間化モデルを取得します。
Term[] | getTerms() マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。
void | init(String terminableName, String terminableInternationalName, TerminableAccessorMap accessorMap, Locale defaultLocale) 初期化処理を行います。
TerminableModel | newTerminableModel(Term term) 初期化されていない期間化モデルのインスタンスを取得します。
void | remove(Term term) 指定された期間に該当するデータを削除します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericTerminableModelMap

public GenericTerminableModelMap()
メソッドの詳細

init

public void init(String terminableName,
                 String terminableInternationalName,
                 TerminableAccessorMap accessorMap,
                 Locale defaultLocale)
初期化処理を行います。

パラメータ:
terminableName - 期間化モデルのクラス名
terminableInternationalName - 期間国際化モデルのクラス名
accessorMap - 期間化アクセサマップ
defaultLocale - デフォルト言語

createTerminableModel

public TerminableModel createTerminableModel(Term term)
                                      throws AccessorException
指定した期間を満たす期間化モデルを生成します。 設定した期間化モデルによって重複する期間が発生する場合、例外が発生します。

定義:
インタフェース TerminableModelMap 内の createTerminableModel
パラメータ:
term - 期間 　　 *
戻り値:
期間化モデル
例外:
AccessorException - アクセサで何らかの例外が発生した場合

exists

public boolean exists(Date date)
指定された日時を含む期間化モデルが存在するかどうか判定します。

定義:
インタフェース TerminableModelMap 内の exists
パラメータ:
date - 日時
戻り値:
指定された日時を含む期間化モデルが存在する場合は true、それ以外は false

findTerminableModel

public TerminableModel findTerminableModel(Date date)
                                    throws IllegalTermException
指定された日時に該当する期間化モデルを取得します。 引数 date で指定された日時を期間内に含む TerminableModelを取得します。
指定された日時に該当する期間化モデルが存在しない場合は例外を返します。

定義:
インタフェース TerminableModelMap 内の findTerminableModel
パラメータ:
date - 対象となる日時
戻り値:
対象となる期間化モデル
例外:
IllegalTermException - 該当するものが存在しない場合

remove

public void remove(Term term)
            throws AccessorException
指定された期間に該当するデータを削除します。 削除対象の期間に該当するデータがなくなるよう、既存のデータの有効開始日時や有効終了日時は調整されます。

定義:
インタフェース TerminableModelMap 内の remove
パラメータ:
term - 削除対象の期間
例外:
AccessorException - アクセサで何らかの例外が発生した場合

newTerminableModel

public TerminableModel newTerminableModel(Term term)
                                   throws DataStoreSystemException
初期化されていない期間化モデルのインスタンスを取得します。 このメソッドはシステム内で使用されます。明示的に使用しないでください。

パラメータ:
term - 期間
戻り値:
期間化モデルのインスタンス
例外:
DataStoreSystemException

getTerms

public Term[] getTerms()
マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。 取得される期間は時系列でソートされています。

定義:
インタフェース TerminableModelMap 内の getTerms
戻り値:
期間の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース InternationalModel

すべてのスーパーインタフェース:
Serializable
既知のサブインタフェースの一覧:
CalendarInfoInternationalModel, CategoryDetailInternationalModel, CateogryClassInternationalModel, ItemAttributeInternationalModel, ItemCategoryInternationalModel, ItemTemplateDetailInternationalModel, ItemTemplateInternationalModel, MenuInternationalModel, RoleInternationalModel
既知の実装クラスの一覧:
GenericInternationalModel
public interface InternationalModel
extends Serializable

国際化モデルの情報です。 国際化エンティティの1データが国際化モデルの1インスタンスに対応します。

導入されたバージョン:
5.0

メソッドの概要
ExtendedInternationalModelMap | getExtendedInternationalModelMap() 拡張国際化エンティティに対応する拡張国際化モデルのマップを取得します。
Locale | getLocale() 国際化モデルが保持する言語 Locale を取得します。
void | init(InternationalModelContext context) 国際化モデルを初期化します。

メソッドの詳細

init

public void init(InternationalModelContext context)
国際化モデルを初期化します。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

パラメータ:
context - 国際化モデルコンテキスト

getExtendedInternationalModelMap

public ExtendedInternationalModelMap getExtendedInternationalModelMap()
拡張国際化エンティティに対応する拡張国際化モデルのマップを取得します。

戻り値:
拡張国際化モデルマップ

getLocale

public Locale getLocale()
国際化モデルが保持する言語 Locale を取得します。 このメソッドをオーバーライドすると言語を取得することが出来なくなります。

戻り値:
言語
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalModelContext (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース InternationalModelContext

public interface InternationalModelContext

国際化モデルの初期化に必要な設定を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedInternationalModelMap | getExtendedInternationalModelMap() 拡張国際化モデルマップを取得します。
InternationalAccessor | getInternationalAccessor() 国際化アクセサを取得します。
void | setExtendedInternationalModelMap(ExtendedInternationalModelMap extendedMap) 拡張国際化モデルマップを設定します。
void | setInternationalAccessor(InternationalAccessor accessor) 国際化アクセサを設定します。

メソッドの詳細

setInternationalAccessor

public void setInternationalAccessor(InternationalAccessor accessor)
国際化アクセサを設定します。

パラメータ:
accessor - 国際化アクセサ

getInternationalAccessor

public InternationalAccessor getInternationalAccessor()
国際化アクセサを取得します。

戻り値:
国際化アクセサ

setExtendedInternationalModelMap

public void setExtendedInternationalModelMap(ExtendedInternationalModelMap extendedMap)
拡張国際化モデルマップを設定します。

パラメータ:
extendedMap - 拡張国際化モデルマップ

getExtendedInternationalModelMap

public ExtendedInternationalModelMap getExtendedInternationalModelMap()
拡張国際化モデルマップを取得します。

戻り値:
拡張国際化モデルマップ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalModelMap (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース InternationalModelMap

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
GenericInternationalModelMap
public interface InternationalModelMap
extends Serializable

国際化モデルのマッピング情報を持ちます。 システムで定義された言語に対応する情報のみを持ちます。

導入されたバージョン:
5.0

メソッドの概要
InternationalModel | createInternationalModel(Locale locale) 国際化モデルを生成します。
boolean | exists(Locale locale) 指定された言語に該当する国際化モデルが存在するどうか判定します。
InternationalModel | findInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。
Locale[] | getLocales() マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。
void | remove(Locale locale) 指定された言語に該当するデータを削除します。

メソッドの詳細

createInternationalModel

public InternationalModel createInternationalModel(Locale locale)
                                            throws AccessorException
国際化モデルを生成します。 引数で指定された言語に該当する既存の情報は新しい情報で上書きされます。 システムで取り扱う言語のみが対象となります。

パラメータ:
locale - 言語
戻り値:
国際化モデル
例外:
AccessorException - システムで使用することができない言語が指定された場合

exists

public boolean exists(Locale locale)
指定された言語に該当する国際化モデルが存在するどうか判定します。

パラメータ:
locale - 言語
戻り値:
指定された言語に該当する国際化モデルが存在する場合は true、それ以外は false

findInternationalModel

public InternationalModel findInternationalModel(Locale locale)
                                          throws IllegalLocaleException
指定された言語に該当する国際化モデルを取得します。 引数 locale で指定された言語に該当する InternationalModel を取得します。該当するものが存在しない場合、 null が返されます。

パラメータ:
locale - 対象となる言語
戻り値:
対象となる期間化モデル（存在しない場合は null）
例外:
IllegalLocaleException - 言語に関する例外が発生した場合

getLocales

public Locale[] getLocales()
マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。

戻り値:
言語の一覧

remove

public void remove(Locale locale)
            throws AccessorException
指定された言語に該当するデータを削除します。

パラメータ:
locale - 削除対象の言語
例外:
AccessorException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartDBMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス IntramartDBMapper

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper
すべての実装インタフェース:
Mapper
public abstract class IntramartDBMapper
extends Object
implements Mapper

intra-martで管理されるデータベースにアクセスするマッパーの汎用的な抽象クラスです。

導入されたバージョン:
5.0

コンストラクタの概要
IntramartDBMapper()
メソッドの概要
void | checkByBaseProperty(Relationship[] relationships, BaseModel target, BaseModel base) 基準項目によるリレーションシップの整合性制約をチェックします。
void | close() マッパーをクローズします。
protected BaseAccessor | createBaseAccessor(Map primary) このマッパーに該当する基本アクセサを新規に生成します。
BaseModel | createBaseModel(Map keys) このマッパーに該当する基本モデルを新規に生成します。
protected void | delete(BaseModel model) 基本モデルを1つだけ削除します。
protected void | delete(Collection models) アクセサを複数削除します。
protected abstract String | getApplicationName() マッパーが定義されているアプリケーション名を取得します。
protected abstract String | getEntityName() マッパーがアクセスするエンティティ名を取得します。
void | init(String user, String group) マッパーを初期化します。
protected void | insert(BaseModel model) 基本モデルを1つだけ挿入します。
protected void | insert(Collection models) 基本モデルを複数挿入します。
boolean | isClosed() マッパーがクローズされているかどうか確認します。
void | notifyDelete(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
void | notifyUpdate(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
BaseModel | select(Map keys) プライマリーキーで特定される基本モデルを取得します。
protected Collection | select(Relationship relationship, Map keys) 外部キーで特定される基本モデルをすべて取得します。
protected void | update(BaseModel model) 基本モデルを1つだけ更新します。
protected void | update(Collection models) 基本モデルを複数更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartDBMapper

public IntramartDBMapper()
メソッドの詳細

init

public void init(String user,
                 String group)
          throws MapperException
マッパーを初期化します。 マッパーを生成する場合は、このメソッドを必ず呼び出して下さい。

定義:
インタフェース Mapper 内の init
パラメータ:
user - ログインユーザID
group - ログイングループID
例外:
MapperException - マッパーの初期化に失敗した場合

createBaseAccessor

protected BaseAccessor createBaseAccessor(Map primary)
                                   throws MapperException
このマッパーに該当する基本アクセサを新規に生成します。 アクセサはコンストラクタではなくこの新規生成系メソッドでのみ生成します。このメソッドで生成されたアクセサは次の状態です。
  • 指定された（または自動的に割り当てられた）プライマリキーが設定済
  • 国際化モデルが1つだけ存在
    • ロケールはデフォルトロケール
  • 期間化アクセサが1つだけ存在
    • 有効開始日は期間の最小日時 (1582/10/15|00:00:00)
    • 有効終了日は期間の最大日時 (9999/12/31|23:59:59)
  • 期間国際化アクセサが1つだけ存在
    • ロケールはデフォルトロケール
    • 有効開始日は期間の最小日時 (1582/10/15|00:00:00)
    • 有効終了日は期間の最大日時 (9999/12/31|23:59:59)

パラメータ:
primary - 基本アクセサのプライマリキー
戻り値:
基本アクセサ
例外:
MapperException

createBaseModel

public BaseModel createBaseModel(Map keys)
                          throws MapperException
このマッパーに該当する基本モデルを新規に生成します。 モデルを新規に生成することができるのはこのメソッドだけです。このメソッドで生成されたモデルは次の状態になります。
  • 指定されたプライマリキーが設定済
  • 該当するエンティティが国際化されている場合は、国際化モデルが1つだけ存在
    • ロケールはデフォルトロケール
  • 該当するエンティティが期間化されている場合は、期間化モデルが1つだけ存在
    • 有効開始日は期間の最小日時 (1582/10/15|00:00:00)
    • 有効終了日は期間の最大日時 (9999/12/31|23:59:59)
  • 該当するエンティティが期間国際化されている場合は、期間国際化モデルが1つだけ存在
    • ロケールはデフォルトロケール
    • 有効開始日は期間の最小日時 (1582/10/15|00:00:00)
    • 有効終了日は期間の最大日時 (9999/12/31|23:59:59)
    このメソッドで生成されたモデルはまだデータベースには反映されていません。データベースに反映するためには以下のデータ更新系のAPIを使用します。
    • insert(BaseModel)
    • insert(Collection)
    • update(BaseModel)
    • update(Collection)
    • delete(BaseModel)
    • delete(Collection)

    定義:
    インタフェース Mapper 内の createBaseModel
    パラメータ:
    keys - 項目名とその値を持つプライマリキーのマップ
    戻り値:
    プライマリキーが設定された基本モデル
    例外:
    MapperException - モデルの生成に失敗した場合

select

public BaseModel select(Map keys)
                 throws MapperException
プライマリーキーで特定される基本モデルを取得します。 取得される基本モデルには、国際化されている場合にはすべての言語情報、期間化されている場合にはすべての期間情報が設定されます。 また、基本モデル BaseModel、国際化モデル InternationalModel、期間化モデル TerminableModel、 期間国際化モデル TerminableInternationalModel にはすべてのプロパティが設定されます。
プライマリーキーに一致するデータが存在しない場合は、null を返します。

定義:
インタフェース Mapper 内の select
パラメータ:
keys - 項目名とその値を持つプライマリキーのマップ
戻り値:
基本モデル
例外:
MapperException - モデルの取得に失敗した場合

select

protected Collection select(Relationship relationship,
                            Map keys)
                     throws MapperException
外部キーで特定される基本モデルをすべて取得します。 外部キーによる検索条件に一致する基本モデル BaseModel のコレクション Collection が取得されます。
検索条件に一致するデータが存在しない場合は、空のコレクションを返します。

パラメータ:
relationship - 検索する基本モデルの外部キー項目を定義したリレーションシップ
keys - 検索条件
戻り値:
基本モデルのコレクション
例外:
MapperException - 基本モデルの取得に失敗した場合

insert

protected void insert(BaseModel model)
               throws MapperException
基本モデルを1つだけ挿入します。 引数に指定する基本モデルは同一の Mapperの createBaseAccessor(Map) で生成されたものである必要があります。

パラメータ:
model - 挿入するモデル
例外:
MapperException - 基本モデルの挿入に失敗した場合

insert

protected void insert(Collection models)
               throws MapperException
基本モデルを複数挿入します。 引数に指定するものは同一の Mapperの createBaseAccessor(Map) で生成されたアクセサの集合である必要があります。

パラメータ:
models - 挿入する基本モデルの集合
例外:
MapperException - 基本モデルの挿入に失敗した場合

update

protected void update(BaseModel model)
               throws MapperException
基本モデルを1つだけ更新します。 引数に指定するアクセサは同一の Mapperの select 系メソッドから取得されたものか createBaseAccessor(Map) で生成されたものである必要があります。期間が重複するデータが存在する場合、指定したアクセサが最優先されるように期間が調節された上で上書きします。

パラメータ:
model - 更新する基本モデル
例外:
MapperException - 基本モデルの更新に失敗した場合

update

protected void update(Collection models)
               throws MapperException
基本モデルを複数更新します。 引数に指定するものは同一の Mapperの select 系メソッドから取得されたものか createBaseAccessor(Map) で生成された基本モデルの集合である必要があります。

パラメータ:
models - 更新する基本モデルの集合
例外:
MapperException - 基本モデルの更新に失敗した場合

delete

protected void delete(BaseModel model)
               throws MapperException
基本モデルを1つだけ削除します。 引数で指定された基本モデルに該当するデータのすべての期間の情報を削除します。引数に指定する基本モデルは同一の Mapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するアクセサ
例外:
MapperException - 基本モデルの削除に失敗した場合

delete

protected void delete(Collection models)
               throws MapperException
アクセサを複数削除します。 引数で指定されたものに該当するデータのすべての期間の情報を削除します。引数に指定するアクセサは同一の Mapperの select 系メソッド から取得されたアクセサの集合である必要があります。

パラメータ:
models - 削除するアクセサ
例外:
MapperException - 基本モデルの削除に失敗した場合

notifyUpdate

public void notifyUpdate(Relationship relationship,
                         BaseModel model)
                  throws MapperException
リレーションシップで定義された参照先基本モデルが更新されたことを通知します。 引数で指定されたリレーションシップ Relationship の参照先基本モデル BaseModel が更新された場合に、このメソッドを呼び出してその内容を通知します。 マッパー Mapper は参照先モデルの更新内容と整合性をとるために、それを参照する基本モデルの内容を更新します。

定義:
インタフェース Mapper 内の notifyUpdate
パラメータ:
relationship - リレーションシップ
model - 参照先基本モデル
例外:
MapperException - 更新通知先で何らかの例外が発生した場合

notifyDelete

public void notifyDelete(Relationship relationship,
                         BaseModel model)
                  throws MapperException
リレーションシップで定義された参照先基本モデルが削除されたことを通知します。 引数で指定されたリレーションシップ Relationship の参照先基本モデル BaseModel が削除された場合にその内容を通知します。 マッパー Mapper は削除されたモデルを参照する基本モデルに対して、整合性を守るための更新を行います。

定義:
インタフェース Mapper 内の notifyDelete
パラメータ:
relationship - リレーションシップ
model - 参照先基本モデル
例外:
MapperException - 更新通知先で何らかの例外が発生した場合

checkByBaseProperty

public void checkByBaseProperty(Relationship[] relationships,
                                BaseModel target,
                                BaseModel base)
                         throws MapperException
基準項目によるリレーションシップの整合性制約をチェックします。 整合性制約違反が存在する場合は、MapperException をスローします。 リレーションシップ Relationship には、基準項目を参照するリレーションシップを参照元とするエンティティ Entity まで たどるためのリレーションシップの集合を設定します。

定義:
インタフェース Mapper 内の checkByBaseProperty
パラメータ:
relationships - リレーションシップの集合
target - 参照先基本モデル
base - 基準項目をもつ基本モデル
例外:
MapperException - 基準項目によるチェックで制約違反があった場合

close

public void close()
           throws MapperException
マッパーをクローズします。 このメソッドはトランザクションが終了される前に必ず呼び出される必要があります。 このメソッドが呼ばれると、マッパーは再利用できなくなります。 また、このマッパーから取得されたモデルの更新もできなくなります。

定義:
インタフェース Mapper 内の close
例外:
MapperException - マッパーがすでにクローズされている場合

getApplicationName

protected abstract String getApplicationName()
マッパーが定義されているアプリケーション名を取得します。

戻り値:
アプリケーション名

getEntityName

protected abstract String getEntityName()
マッパーがアクセスするエンティティ名を取得します。

戻り値:
エンティティ名

isClosed

public boolean isClosed()
マッパーがクローズされているかどうか確認します。

定義:
インタフェース Mapper 内の isClosed
戻り値:
クローズされている場合 true 、そうでなければ false
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Mapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース Mapper

既知のサブインタフェースの一覧:
AccessControllerDepartmentMapper, AccessControllerMapper, AccessControllerPostMapper, AccessControllerPublicGroupMapper, AccessControllerRoleMapper, AccountAttributeMapper, AccountMapper, AccountRoleMapper, BatchMapper, CalendarInfoMapper, CategoryDetailMapper, CateogryClassMapper, CompanyCategoryMapper, CompanyMapper, CompanyPostMapper, CompanyVersionMapper, DealDetailMapper, DealerDepartmentMapper, DealerPublicGroupMapper, DealerRoleMapper, DealMapper, DepartmentAttachMapper, DepartmentInclusionMapper, DepartmentMainMapper, DepartmentMapper, FavoriteMenuMapper, ItemAttachMapper, ItemAttributeMapper, ItemCatalogueMapper, ItemCategoryMapper, ItemCategoryTypeMapper, ItemMapper, ItemTemplateDetailMapper, ItemTemplateMapper, MenuArgumentMapper, MenuDepartmentMapper, MenuMapper, MenuPostMapper, MenuPublicGroupMapper, MenuRoleMapper, PrivateGroupAttachMapper, PrivateGroupMapper, PublicGroupAttachMapper, PublicGroupCategoryMapper, PublicGroupInclusionMapper, PublicGroupMapper, PublicGroupSetMapper, PublicGroupVersionMapper, RoleInclusionMapper, RoleMapper, RoleSummaryMapper, UnitMapper, UserMapper
既知の実装クラスの一覧:
IntramartDBMapper
public interface Mapper

エンティティの情報のマッパーです。 実際に永続化されるデータとJavaのクラスを対応付けます。 一度close()メソッドが呼ばれると、isClosed()以外のメソッドはすべて例外をthrowします。

導入されたバージョン:
5.0

メソッドの概要
void | checkByBaseProperty(Relationship[] relationships, BaseModel target, BaseModel base) 基準項目によるリレーションシップの整合性制約をチェックします。
void | close() マッパーをクローズします。
BaseModel | createBaseModel(Map keys) このマッパーに該当する基本モデルを新規に生成します。
void | init(String user, String group) マッパーを初期化します。
boolean | isClosed() マッパーがクローズされているかどうか確認します。
void | notifyDelete(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
void | notifyUpdate(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
BaseModel | select(Map keys) プライマリーキーで特定される基本モデルを取得します。

メソッドの詳細

init

public void init(String user,
                 String group)
          throws MapperException
マッパーを初期化します。 マッパーを生成する場合は、このメソッドを必ず呼び出して下さい。

パラメータ:
user - ログインユーザ
group - ログイングループ名
例外:
MapperException - マッパーの初期化に失敗した場合

createBaseModel

public BaseModel createBaseModel(Map keys)
                          throws MapperException
このマッパーに該当する基本モデルを新規に生成します。 モデルを新規に生成することができるのはこのメソッドだけです。このメソッドで生成されたモデルは次の状態になります。
  • 指定されたプライマリキーが設定済
  • 該当するエンティティが国際化されている場合は、国際化モデルが1つだけ存在
    • ロケールはデフォルトロケール
  • 該当するエンティティが期間化されている場合は、期間化モデルが1つだけ存在
    • 有効開始日は期間の最小日時 (1582/10/15)
    • 有効終了日は期間の最大日時 (9999/12/31)
  • 該当するエンティティが期間国際化されている場合は、期間国際化モデルが1つだけ存在
    • ロケールはデフォルトロケール
    • 有効開始日は期間の最小日時 (1582/10/15)
    • 有効終了日は期間の最大日時 (9999/12/31)

    パラメータ:
    keys - 項目名とその値を持つプライマリキーのマップ
    戻り値:
    プライマリキーが設定された基本モデル
    例外:
    MapperException - モデルの生成に失敗した場合

select

public BaseModel select(Map keys)
                 throws MapperException
プライマリーキーで特定される基本モデルを取得します。 取得される基本モデルには、国際化されている場合にはすべての言語情報、期間化されている場合にはすべての期間情報が設定されます。 また、基本モデル BaseModel、国際化モデル InternationalModel、期間化モデル TerminableModel、 期間国際化モデル TerminableInternationalModel にはすべてのプロパティが設定されます。

パラメータ:
keys - 項目名とその値を持つプライマリキーのマップ
戻り値:
基本モデル
例外:
MapperException - 検索で例外が発生した場合

notifyUpdate

public void notifyUpdate(Relationship relationship,
                         BaseModel model)
                  throws MapperException
リレーションシップで定義された参照先基本モデルが更新されたことを通知します。 引数で指定されたリレーションシップ Relationship の参照先基本モデル BaseModel が更新された場合に、このメソッドを呼び出してその内容を通知します。 マッパー Mapper は参照先モデルの更新内容と整合性をとるために、それを参照する基本モデルの内容を更新します。

パラメータ:
relationship - リレーションシップ
model - 参照先基本モデル
例外:
MapperException - 更新通知先で何らかの例外が発生した場合

notifyDelete

public void notifyDelete(Relationship relationship,
                         BaseModel model)
                  throws MapperException
リレーションシップで定義された参照先基本モデルが削除されたことを通知します。 引数で指定されたリレーションシップ Relationship の参照先基本モデル BaseModel が削除された場合にその内容を通知します。 マッパー Mapper は削除されたモデルを参照する基本モデルに対して、整合性を守るための更新を行います。

パラメータ:
relationship - リレーションシップ
model - 参照先基本モデル
例外:
MapperException - 更新通知先で何らかの例外が発生した場合

checkByBaseProperty

public void checkByBaseProperty(Relationship[] relationships,
                                BaseModel target,
                                BaseModel base)
                         throws MapperException
基準項目によるリレーションシップの整合性制約をチェックします。 リレーションシップ Relationship には、基準項目を参照するリレーションシップを参照元とするエンティティ Entity まで たどるためのリレーションシップの集合を設定します。 基本モデル BaseModel は、基準項目をプロパティにもつ基本モデルを設定します。

パラメータ:
relationships - リレーションシップの集合
target - 参照先基本モデル
base - 基準項目をもつ基本モデル
例外:
MapperException - 基準項目によるチェックで何らかの例外が発生した場合

close

public void close()
           throws MapperException
マッパーをクローズします。 このメソッドはトランザクションが終了される前に必ず呼び出される必要があります。 このメソッドが呼ばれると、マッパーは再利用できなくなります。 また、このマッパーから取得されたモデルの更新もできなくなります。

例外:
MapperException - マッパーがすでにクローズされている場合

isClosed

public boolean isClosed()
マッパーがクローズされているかどうか確認します。

戻り値:
クローズされている場合 true 、そうでなければ false
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MapperFactory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス MapperFactory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.MapperFactory
public abstract class MapperFactory
extends Object

マッパーを生成します。

導入されたバージョン:
5.0

コンストラクタの概要
MapperFactory()
メソッドの概要
abstract Mapper | createMapper(String application, String entity, String group, String user) マッパーを生成します。
static MapperFactory | newInstance() マッパーファクトリを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MapperFactory

public MapperFactory()
メソッドの詳細

newInstance

public static MapperFactory newInstance()
                                 throws MapperException
マッパーファクトリを取得します。

戻り値:
マッパーファクトリ
例外:
MapperException

createMapper

public abstract Mapper createMapper(String application,
                                    String entity,
                                    String group,
                                    String user)
                             throws MapperException
マッパーを生成します。

パラメータ:
application - マッパーを定義するアプリケーション名
entity - マッパーを定義するエンティティ名
group - ログイングループ名
user - ログインユーザコード
戻り値:
マッパー
例外:
MapperException - マッパーの生成に失敗した時
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.common.model (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.common.model
インタフェース
BaseModel
BaseModelContext
ExtendedBaseModel
ExtendedBaseModelMap
ExtendedInternationalModel
ExtendedInternationalModelMap
ExtendedTerminableInternationalModel
ExtendedTerminableInternationalModelMap
ExtendedTerminableModel
ExtendedTerminableModelMap
InternationalModel
InternationalModelContext
InternationalModelMap
Mapper
TerminableInternationalModel
TerminableInternationalModelContext
TerminableInternationalModelMap
TerminableModel
TerminableModelContext
TerminableModelMap
クラス
ExtendedGenericBaseModel
ExtendedGenericBaseModelMap
ExtendedGenericInternationalModel
ExtendedGenericInternationalModelMap
ExtendedGenericTerminableInternationalModel
ExtendedGenericTerminableInternationalModelMap
ExtendedGenericTerminableModel
ExtendedGenericTerminableModelMap
GenericBaseModel
GenericInternationalModel
GenericInternationalModelMap
GenericTerminableInternationalModel
GenericTerminableInternationalModelMap
GenericTerminableModel
GenericTerminableModelMap
IntramartDBMapper
MapperFactory


jp.co.intra_mart.foundation.datastore.common.model (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.common.model

情報を扱うための、モデルやマッパーを提供します。

参照:
説明

インタフェースの概要
BaseModel | 基本モデルの情報です。
BaseModelContext | 基本モデルの初期化に必要な設定を持ちます。
ExtendedBaseModel | 拡張基本モデルの情報です。
ExtendedBaseModelMap | 拡張基本モデルのマッピング情報を持ちます。
ExtendedInternationalModel | 拡張国際化モデルの情報です。
ExtendedInternationalModelMap | 拡張国際化モデルのマッピング情報を持ちます。
ExtendedTerminableInternationalModel | 拡張期間国際化モデルの情報です。
ExtendedTerminableInternationalModelMap | 拡張期間国際化モデルのマッピング情報を持ちます。
ExtendedTerminableModel | 拡張期間化モデルの情報です。
ExtendedTerminableModelMap | 拡張期間化モデルのマッピング情報を持ちます。
InternationalModel | 国際化モデルの情報です。
InternationalModelContext | 国際化モデルの初期化に必要な設定を持ちます。
InternationalModelMap | 国際化モデルのマッピング情報を持ちます。
Mapper | エンティティの情報のマッパーです。
TerminableInternationalModel | 期間国際化モデルの情報です。
TerminableInternationalModelContext | 期間国際化モデルの初期化に必要な設定を持ちます。
TerminableInternationalModelMap | 期間国際化モデルのマッピング情報を持ちます。
TerminableModel | 期間化モデルの情報です。
TerminableModelContext | 期間化化モデルの初期化に必要な設定を持ちます。
TerminableModelMap | 期間化モデルのマッピング情報を持ちます。

クラスの概要
ExtendedGenericBaseModel | 拡張基本モデルの汎用的な抽象クラスです。
ExtendedGenericBaseModelMap | 拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。
ExtendedGenericInternationalModel | 拡張国際化モデルの汎用的な抽象クラスです。
ExtendedGenericInternationalModelMap | 拡張国際化モデルのマッピング情報を持つ汎用的な抽象クラスです。
ExtendedGenericTerminableInternationalModel | 拡張期間国際化モデルの汎用的な抽象クラスです。
ExtendedGenericTerminableInternationalModelMap | 拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。
ExtendedGenericTerminableModel | 拡張期間化モデルの汎用的な抽象クラスです。
ExtendedGenericTerminableModelMap | 拡張期間化モデルのマッピング情報を持つ汎用的な抽象クラスです。
GenericBaseModel | 基本モデルの汎用的な抽象クラスです。
GenericInternationalModel | 国際化モデルの汎用的な抽象クラスです。
GenericInternationalModelMap | 国際化モデルマッピングの汎用的な抽象クラスです。
GenericTerminableInternationalModel | 期間国際化モデルの汎用的な抽象クラスです。
GenericTerminableInternationalModelMap | 期間国際化モデルマッピングの汎用的な抽象クラスです。
GenericTerminableModel | 期間化モデルの汎用的な抽象クラスです。
GenericTerminableModelMap | 期間化モデルマッピングの汎用的な抽象クラスです。
IntramartDBMapper | intra-martで管理されるデータベースにアクセスするマッパーの汎用的な抽象クラスです。
MapperFactory | マッパーを生成します。

パッケージ jp.co.intra_mart.foundation.datastore.common.model の説明

情報を扱うための、モデルやマッパーを提供します。


jp.co.intra_mart.foundation.datastore.common.model クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.common.model の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel (implements jp.co.intra_mart.foundation.datastore.common.model.BaseModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.InternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper (implements jp.co.intra_mart.foundation.datastore.common.model.Mapper)
    • class jp.co.intra_mart.foundation.datastore.common.model.MapperFactory

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext
  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext
  • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext


パッケージ jp.co.intra_mart.foundation.datastore.common.model の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.common.model の使用

jp.co.intra_mart.foundation.datastore.common.model を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category | 会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company | 会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion | 組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version | 会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.deal | 取扱情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.department | 取扱組織権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.detail | 取扱詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group | 取扱パブリックグループ権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.role | 取扱ロール権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.attribute | 商品属性情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue | 商品カタログ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.item | 商品情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach | 商品分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.category | 商品カテゴリ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.type | 商品カテゴリ種別情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail | 商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.template | 商品テンプレート情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach | プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group | プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach | パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category | パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion | パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set | パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version | パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.unit | 単位情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.system.security.datastore.inf |

jp.co.intra_mart.foundation.datastore.application.model.category.category_class により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
InternationalModel
国際化モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.category.detail により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
InternationalModel
国際化モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.company.attach により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.company.category により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.company.company により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.company.department により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableInternationalModel
期間国際化モデルの情報です。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.company.main により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.company.post により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableInternationalModel
期間国際化モデルの情報です。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.company.version により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.deal.deal により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.deal.department により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.deal.detail により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.deal.role により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.item.attribute により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
InternationalModel
国際化モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.item.item により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableInternationalModel
期間国際化モデルの情報です。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.item_category.category により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
InternationalModel
国際化モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.item_category.type により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
InternationalModel
国際化モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.item_template.template により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
InternationalModel
国際化モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.private_group.group により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableInternationalModel
期間国際化モデルの情報です。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.set により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.version により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.unit により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.user により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableInternationalModel
期間国際化モデルの情報です。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.common.model により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
BaseModelContext
基本モデルの初期化に必要な設定を持ちます。
ExtendedBaseModel
拡張基本モデルの情報です。
ExtendedBaseModelMap
拡張基本モデルのマッピング情報を持ちます。
ExtendedInternationalModel
拡張国際化モデルの情報です。
ExtendedInternationalModelMap
拡張国際化モデルのマッピング情報を持ちます。
ExtendedTerminableInternationalModel
拡張期間国際化モデルの情報です。
ExtendedTerminableInternationalModelMap
拡張期間国際化モデルのマッピング情報を持ちます。
ExtendedTerminableModel
拡張期間化モデルの情報です。
ExtendedTerminableModelMap
拡張期間化モデルのマッピング情報を持ちます。
InternationalModel
国際化モデルの情報です。
InternationalModelContext
国際化モデルの初期化に必要な設定を持ちます。
InternationalModelMap
国際化モデルのマッピング情報を持ちます。
Mapper
エンティティの情報のマッパーです。
MapperFactory
マッパーを生成します。
TerminableInternationalModel
期間国際化モデルの情報です。
TerminableInternationalModelContext
期間国際化モデルの初期化に必要な設定を持ちます。
TerminableInternationalModelMap
期間国際化モデルのマッピング情報を持ちます。
TerminableModel
期間化モデルの情報です。
TerminableModelContext
期間化化モデルの初期化に必要な設定を持ちます。
TerminableModelMap
期間化モデルのマッピング情報を持ちます。

jp.co.intra_mart.system.security.datastore.inf により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
InternationalModel
国際化モデルの情報です。
Mapper
エンティティの情報のマッパーです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


TerminableInternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース TerminableInternationalModel

すべてのスーパーインタフェース:
Serializable
既知のサブインタフェースの一覧:
CompanyPostTerminableInternationalModel, DepartmentTerminableInternationalModel, ItemTerminableInternationalModel, PublicGroupTerminableInternationalModel, UserTerminableInternationalModel
既知の実装クラスの一覧:
GenericTerminableInternationalModel
public interface TerminableInternationalModel
extends Serializable

期間国際化モデルの情報です。 期間国際化エンティティの1データが期間国際化モデルの1インスタンスに対応します。

導入されたバージョン:
5.0

メソッドの概要
ExtendedTerminableInternationalModelMap | getExtendedTerminableInternationalModelMap() 拡張期間国際化エンティティに対応する拡張期間国際化モデルのマップを取得します。
Locale | getLocale() 期間国際化モデルが保持する言語 Locale を取得します。
void | init(TerminableInternationalModelContext context) 期間国際化モデルを初期化します。

メソッドの詳細

init

public void init(TerminableInternationalModelContext context)
期間国際化モデルを初期化します。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

パラメータ:
context - 期間国際化モデルコンテキスト

getExtendedTerminableInternationalModelMap

public ExtendedTerminableInternationalModelMap getExtendedTerminableInternationalModelMap()
拡張期間国際化エンティティに対応する拡張期間国際化モデルのマップを取得します。

戻り値:
拡張期間国際化モデルマップ

getLocale

public Locale getLocale()
期間国際化モデルが保持する言語 Locale を取得します。 このメソッドをオーバーライドすると言語を取得することが出来なくなります。

戻り値:
言語
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableInternationalModelContext (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース TerminableInternationalModelContext

public interface TerminableInternationalModelContext

期間国際化モデルの初期化に必要な設定を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedTerminableInternationalModelMap | getExtendedTerminableInternationalModelMap() 拡張期間国際化モデルマップを取得します。
TerminableInternationalAccessor | getTerminableInternationalAccessor() 期間国際化アクセサを取得します。
void | setExtendedTerminableInternationalModelMap(ExtendedTerminableInternationalModelMap extendedMap) 拡張期間国際化モデルマップを設定します。
void | setTerminableInternationalAccessor(TerminableInternationalAccessor accessor) 期間国際化アクセサを設定します。

メソッドの詳細

setTerminableInternationalAccessor

public void setTerminableInternationalAccessor(TerminableInternationalAccessor accessor)
期間国際化アクセサを設定します。

パラメータ:
accessor - 期間国際化アクセサ

getTerminableInternationalAccessor

public TerminableInternationalAccessor getTerminableInternationalAccessor()
期間国際化アクセサを取得します。

戻り値:
期間国際化アクセサ

setExtendedTerminableInternationalModelMap

public void setExtendedTerminableInternationalModelMap(ExtendedTerminableInternationalModelMap extendedMap)
拡張期間国際化モデルマップを設定します。

パラメータ:
extendedMap - 拡張期間国際化モデルマップ

getExtendedTerminableInternationalModelMap

public ExtendedTerminableInternationalModelMap getExtendedTerminableInternationalModelMap()
拡張期間国際化モデルマップを取得します。

戻り値:
拡張期間国際化モデルマップ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableInternationalModelMap (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース TerminableInternationalModelMap

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
GenericTerminableInternationalModelMap
public interface TerminableInternationalModelMap
extends Serializable

期間国際化モデルのマッピング情報を持ちます。 システムで定義された言語に対応する情報のみを持ちます。

導入されたバージョン:
5.0

メソッドの概要
TerminableInternationalModel | createTerminableInternationalModel(Locale locale) 期間国際化モデルを生成します。
boolean | exists(Locale locale) 指定された言語に該当する期間国際化モデルが存在するかどうか判定します。
TerminableInternationalModel | findTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
Locale[] | getLocales() マッピングされている期間国際化モデル TerminableInternationalModel の言語 Locale の一覧を取得します。
void | remove(Locale locale) 指定された言語に該当するデータを削除します。

メソッドの詳細

createTerminableInternationalModel

public TerminableInternationalModel createTerminableInternationalModel(Locale locale)
                                                                throws AccessorException
期間国際化モデルを生成します。 引数で指定された言語に該当する既存の情報は新しい情報で上書きされます。 システムで取り扱う言語のみが対象となります。

パラメータ:
locale - 言語
戻り値:
期間国際化モデル
例外:
AccessorException - システムで使用することができない言語が指定された場合

exists

public boolean exists(Locale locale)
指定された言語に該当する期間国際化モデルが存在するかどうか判定します。

パラメータ:
locale - 言語
戻り値:
対象となる期間国際化モデルが存在する場合 true、それ以外は false

findTerminableInternationalModel

public TerminableInternationalModel findTerminableInternationalModel(Locale locale)
                                                              throws IllegalLocaleException
指定された言語に該当する期間国際化モデルを取得します。 引数 locale で指定された言語に該当する TerminableInternationalModelを取得します。該当するものが存在しない場合、 null が返されます。

パラメータ:
locale - 対象となる言語
戻り値:
対象となる期間国際化モデル（存在しない場合は null）
例外:
IllegalLocaleException - 言語に関する例外が発生した場合

getLocales

public Locale[] getLocales()
マッピングされている期間国際化モデル TerminableInternationalModel の言語 Locale の一覧を取得します。

戻り値:
言語の一覧

remove

public void remove(Locale locale)
            throws AccessorException
指定された言語に該当するデータを削除します。

パラメータ:
locale - 削除対象の言語
例外:
AccessorException - アクセサで何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース TerminableModel

すべてのスーパーインタフェース:
Serializable
既知のサブインタフェースの一覧:
CompanyCategoryTerminableModel, CompanyPostTerminableModel, DealDetailTerminableModel, DealTerminableModel, DepartmentAttachTerminableModel, DepartmentMainTerminableModel, DepartmentTerminableModel, ItemTerminableModel, PublicGroupAttachTerminableModel, PublicGroupCategoryTerminableModel, PublicGroupTerminableModel, UserTerminableModel
既知の実装クラスの一覧:
GenericTerminableModel
public interface TerminableModel
extends Serializable

期間化モデルの情報です。 期間化エンティティの1データが期間化モデルの1インスタンスに対応します。

導入されたバージョン:
5.0

メソッドの概要
ExtendedTerminableModelMap | getExtendedTerminableModelMap() 拡張期間化エンティティに対応する拡張期間化モデルのマップを取得します。
Term | getTerm() 期間化モデルが保持する期間 Term を取得します。
TerminableInternationalModelMap | getTerminableInternationalModelMap() 期間国際化モデルを取得します。
void | init(TerminableModelContext context) 期間化モデルを初期化します。

メソッドの詳細

init

public void init(TerminableModelContext context)
期間化モデルを初期化します。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

パラメータ:
context - 期間化モデルコンテキスト

getTerminableInternationalModelMap

public TerminableInternationalModelMap getTerminableInternationalModelMap()
期間国際化モデルを取得します。 この期間モデルに関連する期間国際化モデルの集合を取得します。

戻り値:
期間国際化モデルの集合

getExtendedTerminableModelMap

public ExtendedTerminableModelMap getExtendedTerminableModelMap()
拡張期間化エンティティに対応する拡張期間化モデルのマップを取得します。

戻り値:
拡張期間化モデルマップ

getTerm

public Term getTerm()
期間化モデルが保持する期間 Term を取得します。 このメソッドをオーバーライドすると期間を取得できなくなります。

戻り値:
期間
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableModelContext (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース TerminableModelContext

public interface TerminableModelContext

期間化化モデルの初期化に必要な設定を持ちます。

導入されたバージョン:
5.0

メソッドの概要
Locale | getDefaultLocale() デフォルト言語を取得します。
ExtendedTerminableModelMap | getExtendedTerminableModelMap() 拡張期間化モデルマップを取得します。
TerminableAccessor | getTerminableAccessor() 期間化アクセサを取得します。
TerminableInternationalModelMap | getTerminableInternationalModelMap() 期間国際化モデルマップを取得します。
void | setDefaultLocale(Locale locale) デフォルト言語を設定します。
void | setExtendedTerminableModelMap(ExtendedTerminableModelMap extendedMap) 拡張期間化モデルマップを設定します。
void | setTerminableAccessor(TerminableAccessor accessor) 期間化アクセサを設定します。
void | setTerminableInternationalModelMap(TerminableInternationalModelMap terminableInternationalMap) 期間国際化モデルマップを設定します。

メソッドの詳細

setTerminableAccessor

public void setTerminableAccessor(TerminableAccessor accessor)
期間化アクセサを設定します。

パラメータ:
accessor - 期間化アクセサ

getTerminableAccessor

public TerminableAccessor getTerminableAccessor()
期間化アクセサを取得します。

戻り値:
期間化アクセサ

setDefaultLocale

public void setDefaultLocale(Locale locale)
デフォルト言語を設定します。

パラメータ:
locale - 言語

getDefaultLocale

public Locale getDefaultLocale()
デフォルト言語を取得します。

戻り値:
言語

setTerminableInternationalModelMap

public void setTerminableInternationalModelMap(TerminableInternationalModelMap terminableInternationalMap)
期間国際化モデルマップを設定します。

パラメータ:
terminableInternationalMap - 期間国際化モデルマップ

getTerminableInternationalModelMap

public TerminableInternationalModelMap getTerminableInternationalModelMap()
期間国際化モデルマップを取得します。

戻り値:
期間国際化モデルマップ

setExtendedTerminableModelMap

public void setExtendedTerminableModelMap(ExtendedTerminableModelMap extendedMap)
拡張期間化モデルマップを設定します。

パラメータ:
extendedMap - 拡張期間化モデルマップ

getExtendedTerminableModelMap

public ExtendedTerminableModelMap getExtendedTerminableModelMap()
拡張期間化モデルマップを取得します。

戻り値:
拡張期間化モデルマップ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableModelMap (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース TerminableModelMap

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
GenericTerminableModelMap
public interface TerminableModelMap
extends Serializable

期間化モデルのマッピング情報を持ちます。 期間が変更された場合などは自動的に期間情報が重複しないように調整されます。

導入されたバージョン:
5.0

メソッドの概要
TerminableModel | createTerminableModel(Term term) 指定した期間を満たす期間化モデルを生成します。
boolean | exists(Date date) 指定された日付を含む期間化モデルが存在するかどうか判定します。
TerminableModel | findTerminableModel(Date date) 指定された日付に該当する期間化モデルを取得します。
Term[] | getTerms() マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。
void | remove(Term term) 指定された期間に該当するデータを削除します。

メソッドの詳細

createTerminableModel

public TerminableModel createTerminableModel(Term term)
                                      throws AccessorException
指定した期間を満たす期間化モデルを生成します。 指定した期間に期間化アクセサを生成します。 生成した期間化アクセサによって重複する期間が発生する場合、例外を返す

パラメータ:
term - 期間
戻り値:
期間化モデル
例外:
AccessorException - アクセサで何らかの例外が発生した場合

exists

public boolean exists(Date date)
指定された日付を含む期間化モデルが存在するかどうか判定します。

パラメータ:
date - 日付
戻り値:
指定された日付を含む期間化モデルが存在する場合は true、それ以外は false

findTerminableModel

public TerminableModel findTerminableModel(Date date)
                                    throws IllegalTermException
指定された日付に該当する期間化モデルを取得します。 引数 date で指定された日付を期間内に含む TerminableModel を取得します。該当するものが存在しない場合、例外を返します

パラメータ:
date - 対象となる日付
戻り値:
対象となる期間化モデル
例外:
IllegalTermException - 指定された日時に該当するモデルが存在しない場合

remove

public void remove(Term term)
            throws AccessorException
指定された期間に該当するデータを削除します。 削除対象の期間に該当するデータがなくなるよう、既存のデータの有効開始日時や有効終了日時は調整されます。

パラメータ:
term - 削除対象の期間
例外:
AccessorException - アクセサで何らかの例外が発生した場合

getTerms

public Term[] getTerms()
マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。 取得される期間は時系列でソートされています。

戻り値:
期間の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.common.structure.Term の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.structure.Term の使用

Term を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.attach | 組織所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.category | 会社分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.department | 組織情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.main | 主所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.post | 役職情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item.item | 商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach | パブリックグループ所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category | パブリックグループ分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set | パブリックグループセット情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.foundation.datastore.common.structure | 期間情報などを扱うクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での Term の使用

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract void | CompanyManager.copyVersion(String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンの内容をコピーします。
void | CompanyChangedListener.versionCopied(String groupId, String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。

jp.co.intra_mart.foundation.datastore.application.domain.company.attach での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.company.attach のメソッド
 Term[] DepartmentAttach.getTerms()
この組織所属で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.attach のメソッド
DepartmentAttachTerminable | DepartmentAttach.getDepartmentAttachTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | DepartmentAttach.putDepartmentAttachTerminable(Term term, DepartmentAttachTerminable data) 指定された期間に対する期間化情報を設定します。
void | DepartmentAttach.removeDepartmentAttachTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.company.category での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.company.category のメソッド
 Term[] CompanyCategory.getTerms()
この会社組織分類で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.category のメソッド
CompanyCategoryTerminable | CompanyCategory.getCompanyCategoryTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | CompanyCategory.putCompanyCategoryTerminable(Term term, CompanyCategoryTerminable data) 指定された期間に対する期間化情報を設定します。
void | CompanyCategory.removeCompanyCategoryTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.company.company での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.company.company のメソッド
 Term[] Company.getTerms()
この会社で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.company のメソッド
CompanyTerminable | Company.getCompanyTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | Company.putCompanyTerminable(Term term, CompanyTerminable data) 指定された期間に対する期間化情報を設定します。
void | Company.removeCompanyTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.company.department での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.company.department のメソッド
 Term[] Department.getTerms()
この組織で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.department のメソッド
DepartmentTerminable | Department.getDepartmentTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | Department.putDepartmentTerminable(Term term, DepartmentTerminable data) 指定された期間に対する期間化情報を設定します。
void | Department.removeDepartmentTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.company.main での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.company.main のメソッド
 Term[] DepartmentMain.getTerms()
この主所属で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.main のメソッド
DepartmentMainTerminable | DepartmentMain.getDepartmentMainTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | DepartmentMain.putDepartmentMainTerminable(Term term, DepartmentMainTerminable data) 指定された期間に対する期間化情報を設定します。
void | DepartmentMain.removeDepartmentMainTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.company.post での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.company.post のメソッド
 Term[] CompanyPost.getTerms()
この役職で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.post のメソッド
CompanyPostTerminable | CompanyPost.getCompanyPostTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | CompanyPost.putCompanyPostTerminable(Term term, CompanyPostTerminable data) 指定された期間に対する期間化情報を設定します。
void | CompanyPost.removeCompanyPostTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.deal.deal での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.deal.deal のメソッド
 Term[] Deal.getTerms()
この取扱で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.deal.deal のメソッド
DealTerminable | Deal.getDealTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | Deal.putDealTerminable(Term term, DealTerminable data) 指定された期間に対する期間化情報を設定します。
void | Deal.removeDealTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.item.item での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.item.item のメソッド
 Term[] Item.getTerms()
この商品で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item.item のメソッド
ItemTerminable | Item.getItemTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | Item.putItemTerminable(Term term, ItemTerminable data) 指定された期間に対する期間化情報を設定します。
void | Item.removeItemTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での Term の使用

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract void | PublicGroupManager.copyVersion(String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーします。
void | PublicGroupChangedListener.versionCopied(String groupId, String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach のメソッド
 Term[] PublicGroupAttach.getTerms()
このパブリックグループ所属で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach のメソッド
PublicGroupAttachTerminable | PublicGroupAttach.getPublicGroupAttachTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | PublicGroupAttach.putPublicGroupAttachTerminable(Term term, PublicGroupAttachTerminable data) 指定された期間に対する期間化情報を設定します。
void | PublicGroupAttach.removePublicGroupAttachTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.category での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.category のメソッド
 Term[] PublicGroupCategory.getTerms()
このパブリックグループ分類で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.category のメソッド
PublicGroupCategoryTerminable | PublicGroupCategory.getPublicGroupCategoryTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | PublicGroupCategory.putPublicGroupCategoryTerminable(Term term, PublicGroupCategoryTerminable data) 指定された期間に対する期間化情報を設定します。
void | PublicGroupCategory.removePublicGroupCategoryTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のメソッド
 Term[] PublicGroup.getTerms()
このパブリックグループで管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のメソッド
PublicGroupTerminable | PublicGroup.getPublicGroupTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | PublicGroup.putPublicGroupTerminable(Term term, PublicGroupTerminable data) 指定された期間に対する期間化情報を設定します。
void | PublicGroup.removePublicGroupTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のメソッド
 Term[] PublicGroupSet.getTerms()
このパブリックグループセットで管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のメソッド
PublicGroupSetTerminable | PublicGroupSet.getPublicGroupSetTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | PublicGroupSet.putPublicGroupSetTerminable(Term term, PublicGroupSetTerminable data) 指定された期間に対する期間化情報を設定します。
void | PublicGroupSet.removePublicGroupSetTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.user での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
 Term[] User.getTerms()
このユーザで管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
UserTerminable | User.getUserTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | User.putUserTerminable(Term term, UserTerminable data) 指定された期間に対する期間化情報を設定します。
void | User.removeUserTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.common.accessor での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
Term[] | TerminableAccessorMap.getTerms() 現在管理している期間の一覧を取得します。
Term | TerminableAccessor.getTerm() 期間を取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
TerminableAccessor | TerminableAccessorMap.createTerminableAccessor(Term term) 指定した期間に期間化アクセサを生成します。
Map | TerminableAccessorMap.remove(Term term) 指定された期間に該当するデータを削除します。

jp.co.intra_mart.foundation.datastore.common.model での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
Term[] | TerminableModelMap.getTerms() マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。
Term | TerminableModel.getTerm() 期間化モデルが保持する期間 Term を取得します。
Term[] | GenericTerminableModelMap.getTerms() マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。
Term | GenericTerminableModel.getTerm() 期間化モデルが保持する期間 Term を取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableModel | TerminableModelMap.createTerminableModel(Term term) 指定した期間を満たす期間化モデルを生成します。
void | TerminableModelMap.remove(Term term) 指定された期間に該当するデータを削除します。
TerminableModel | GenericTerminableModelMap.createTerminableModel(Term term) 指定した期間を満たす期間化モデルを生成します。
void | GenericTerminableModelMap.remove(Term term) 指定された期間に該当するデータを削除します。
TerminableModel | GenericTerminableModelMap.newTerminableModel(Term term) 初期化されていない期間化モデルのインスタンスを取得します。

jp.co.intra_mart.foundation.datastore.common.structure での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.common.structure のメソッド
static Term[] | TermManager.subtract(Term[] term1, Term[] term2) 期間配列 term1 から 期間配列 term2 を差し引いた期間を返します。
static Term[] | TermManager.getOverlap(Term[] term1, Term[] term2) 2つの期間配列 term1 と term2 で重なっている期間を返します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.structure のメソッド
static void | TermManager.validateTerms(Term[] terms) 指定された期間配列が有効かどうかを調べます。
static Term[] | TermManager.subtract(Term[] term1, Term[] term2) 期間配列 term1 から 期間配列 term2 を差し引いた期間を返します。
static Term[] | TermManager.getOverlap(Term[] term1, Term[] term2) 2つの期間配列 term1 と term2 で重なっている期間を返します。

jp.co.intra_mart.foundation.security.access での Term の使用

Term 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | PublicGroupChangedControllerListener.versionCopied(String groupId, String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.versionCopied(String groupId, String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での Term の使用

Term 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | PublicGroupChangedMenuListener.versionCopied(String groupId, String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.versionCopied(String groupId, String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.structure.TermManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.structure.TermManager の使用

jp.co.intra_mart.foundation.datastore.common.structure.TermManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.common.structure (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.common.structure
クラス
Term
TermManager


jp.co.intra_mart.foundation.datastore.common.structure (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.common.structure

期間情報などを扱うクラスを提供します。

参照:
説明

クラスの概要
Term | 有効期間を表します。
TermManager | 期間 Term を取り扱うマネージャクラスです。

パッケージ jp.co.intra_mart.foundation.datastore.common.structure の説明

期間情報などを扱うクラスを提供します。


jp.co.intra_mart.foundation.datastore.common.structure クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.common.structure の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.common.structure.Term (implements java.lang.Comparable, java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.common.structure.TermManager


パッケージ jp.co.intra_mart.foundation.datastore.common.structure の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.common.structure の使用

jp.co.intra_mart.foundation.datastore.common.structure を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.attach | 組織所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.category | 会社分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.department | 組織情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.main | 主所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.post | 役職情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item.item | 商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach | パブリックグループ所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category | パブリックグループ分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set | パブリックグループセット情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.foundation.datastore.common.structure | 期間情報などを扱うクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.company.attach により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.company.category により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.company.company により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.company.department により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.company.main により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.company.post により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.deal.deal により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.item.item により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.category により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.user により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.common.accessor により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.common.model により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.common.structure により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Term (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.structure
クラス Term

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.structure.Term
すべての実装インタフェース:
Comparable, Serializable
public class Term
extends Object
implements Comparable, Serializable

有効期間を表します。 有効期間は開始時間と終了時間から構成されます。次の式を満たす範囲が有効期間として認められます。

開始時間 ≤ 有効期間 < 終了時間

また、開始時間と終了時間は常に次の関係である必要があります。

開始時間 < 終了時間

設定された開始時間および終了時間の時刻は、00:00:00 に切り捨てられます。
ただし、終了時刻に有効最大日時 (9999/12/31|23:59:59) が設定された場合は切り捨ては行いません。

なお、システムで有効な最小日時は以下のAPIで取得することができます。
  • getMinDate()
  • DateUtil.getMinDate()
システムで有効な最大日時は以下のAPIで取得することができます。
  • getMaxDate()
  • DateUtil.getMaxDate()

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
Term()
開始時間、終了時間とも指定されていない有効期間を生成します。
Term(Date activation)
開始時間のみが指定された有効期間を生成します。
Term(Date activation, Date expiration)
開始時間と終了時間がともに指定された有効期間を生成します。
メソッドの概要
int | compareTo(Object o) この期間と指定された期間を比較します。
boolean | containsDate(Date date) 指定された日時が期間内に入っているかどうかを指定します。
boolean | equals(Object obj) この有効期間と他の有効期間が等しいかどうかを示します。
Date | getActivationDate() 開始時間を取得します。
Date | getExpirationDate() 終了時間を取得します。
static Date | getMaxDate() システムで設定できる期間の最大日時を取得します。
static Date | getMinDate() システムで設定できる期間の最小日時を取得します。
int | hashCode() 有効期間のハッシュコード値を返します。
String | toString() オブジェクトの文字列表現を返します。
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Term

public Term()
開始時間、終了時間とも指定されていない有効期間を生成します。 このコンストラクタで指定された有効期間は常に有効であることを意味します。

Term

public Term(Date activation)
開始時間のみが指定された有効期間を生成します。 終了時間が定義されていないため、終了日時には期間の最大日付が設定されます

パラメータ:
activation - 有効開始時間
例外:
IllegalArgumentException - 指定された開始時間が期間の最小日時、最大日時に含まれる日付でないとき発生する
NullPointerException - 有効開始時間が null

Term

public Term(Date activation,
            Date expiration)
     throws IllegalArgumentException
開始時間と終了時間がともに指定された有効期間を生成します。 開始時間と終了時間をともに設定する場合、以下の式を満たす必要があります。

開始時間 ≤ 終了時間

パラメータ:
activation - 有効期間の開始時間
expiration - 有効期間の終了時間
例外:
IllegalArgumentException - 開始時間が終了時間よりも後
NullPointerException - 有効開始時間または有効終了時間が null
メソッドの詳細

getActivationDate

public Date getActivationDate()
開始時間を取得します。

戻り値:
開始時間

getExpirationDate

public Date getExpirationDate()
終了時間を取得します。

戻り値:
終了時間

getMinDate

public static Date getMinDate()
システムで設定できる期間の最小日時を取得します。

戻り値:
期間の最小日時

getMaxDate

public static Date getMaxDate()
システムで設定できる期間の最大日時を取得します。

戻り値:
期間の最大日時

containsDate

public boolean containsDate(Date date)
                     throws NullPointerException,
                            IllegalArgumentException
指定された日時が期間内に入っているかどうかを指定します。

パラメータ:
date - 日時
戻り値:
指定された日時が期間内に入っている場合は true 、そうでなければ false
例外:
NullPointerException - 指定された日付が null
IllegalArgumentException - 不正な日付が設定された場合

compareTo

public int compareTo(Object o)
              throws ClassCastException,
                     IllegalArgumentException
この期間と指定された期間を比較します。 比較する期間どうしは完全に一致するか、少しも重なっていないかのいずれかである必要があります。期間の一部のみが重なっていたり、一方が他方の期間を包含している場合は例外が発生します。

定義:
インタフェース Comparable 内の compareTo
パラメータ:
o - 比較対照の期間（ Term）
戻り値:
この期間が引数で指定された期間より過去である場合は負の整数、等しい場合はゼロ、この期間が引数で指定された期間より未来である場合は正の整数
例外:
ClassCastException - 指定された期間が Termではない
IllegalArgumentException - 指定された期間の一部が重なっている、または一方が他方を包含している

equals

public boolean equals(Object obj)
この有効期間と他の有効期間が等しいかどうかを示します。 開始時間と終了時間がそれぞれの有効期間において完全に一致している場合、有効期間が等しいとみなされます。

パラメータ:
obj - 比較対象の有効期間
戻り値:
obj 引数に指定された有効期間とこの有効期間が等しい場合は true 、そうでない場合は false

hashCode

public int hashCode()
有効期間のハッシュコード値を返します。

戻り値:
有効期間のハッシュコード値

toString

public String toString()
オブジェクトの文字列表現を返します。
有効開始時間と有効終了時間をそれぞれ DateUtil.dateToString(Date) で変換した String を、半角ハイフン(-)で連結した文字列を返します。 つまり、このメソッドは次の値と等しい文字列を返します。

DateUtil.dateToString(getActivationDate()) + " - " + DateUtil.dateToString(getExpirationDate())

戻り値:
このオブジェクトの文字列表現
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


TermManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.structure
クラス TermManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.structure.TermManager
public class TermManager
extends Object

期間 Term を取り扱うマネージャクラスです。

導入されたバージョン:
5.0

メソッドの概要
static Date | getMaxDate() システムで設定できる期間の最大日時を取得します。
static Date | getMinDate() システムで設定できる期間の最小日時を取得します。
static Term[] | getOverlap(Term[] term1, Term[] term2) 2つの期間配列 term1 と term2 で重なっている期間を返します。
static Term[] | subtract(Term[] term1, Term[] term2) 期間配列 term1 から 期間配列 term2 を差し引いた期間を返します。
static void | validateTerm(Date activation, Date expiration) 指定された2つの日時が有効な期間を構成するかどうか調べます。
static void | validateTerms(Term[] terms) 指定された期間配列が有効かどうかを調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

validateTerm

public static void validateTerm(Date activation,
                                Date expiration)
                         throws TermManagerException
指定された2つの日時が有効な期間を構成するかどうか調べます。
指定された日時が有効な期間を構成しない場合は TermManagerException 例外をスローします。

パラメータ:
activation - 有効開始日時
expiration - 有効終了日時
例外:
TermManagerException - 指定された日時が有効な期間を構成しない場合

validateTerms

public static void validateTerms(Term[] terms)
                          throws TermManagerException
指定された期間配列が有効かどうかを調べます。
指定された期間配列が有効ではない場合はTermManagerException 例外をスローします。
期間配列は以下の場合に有効でないと判定されます。
  • 期間配列にnullの要素が含まれている場合
  • 期間が互いに重なる要素が含まれている場合

パラメータ:
terms - 期間の配列
例外:
TermManagerException - 指定された期間配列が有効でない場合

getMinDate

public static Date getMinDate()
システムで設定できる期間の最小日時を取得します。 取得される値は Term.getMinDate() で取得される値と同じです。

戻り値:
期間の最小日時

getMaxDate

public static Date getMaxDate()
システムで設定できる期間の最大日時を取得します。 取得される値は Term.getMaxDate() で取得される値と同じです。

戻り値:
期間の最大日時

subtract

public static Term[] subtract(Term[] term1,
                              Term[] term2)
                       throws TermManagerException
期間配列 term1 から 期間配列 term2 を差し引いた期間を返します。
差し引かれる期間が存在しない場合は空の配列を返します。
期間配列 term1 または term2 が null の場合も、空の配列を返します。

パラメータ:
term1 - 期間
term2 - 期間
戻り値:
term1 と term2 の差分となる期間
例外:
TermManagerException - 指定された期間配列内に期間に重複が存在する場合

getOverlap

public static Term[] getOverlap(Term[] term1,
                                Term[] term2)
                         throws TermManagerException
2つの期間配列 term1 と term2 で重なっている期間を返します。
期間に重なりが存在しない場合は空の配列を返します。
期間配列 term1 または term2 が null の場合も、空の配列を返します。

パラメータ:
term1 - 期間
term2 - 期間
戻り値:
互いに重なっている期間
例外:
TermManagerException - 指定された期間配列内に期間に重複が存在する場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException の使用

AccessorClosedException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor 情報を扱うためのアクセサを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での AccessorClosedException の使用

AccessorClosedException をスローする jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
TerminableInternationalAccessor | TerminableInternationalAccessorMap.createTerminableInternationalAccessor(Locale locale) 期間国際化アクセサを生成します。
void | TerminableInternationalAccessorMap.remove(Locale locale) 指定された言語に該当するデータを削除します。
void | TerminableInternationalAccessor.setProperty(String prop, Object value) プロパティを設定します。
TerminableAccessor | TerminableAccessorMap.createTerminableAccessor(Term term) 指定した期間に期間化アクセサを生成します。
Map | TerminableAccessorMap.remove(Term term) 指定された期間に該当するデータを削除します。
void | TerminableAccessor.setProperty(String prop, Object value) プロパティを設定します。
InternationalAccessor | InternationalAccessorMap.createInternationalAccessor(Locale locale) 国際化アクセサを生成します。
void | InternationalAccessorMap.remove(Locale locale) 指定された言語に該当するデータを削除します。
void | InternationalAccessor.setProperty(String prop, Object value) プロパティを設定します。
ExtendedTerminableInternationalAccessor | ExtendedTerminableInternationalAccessorMap.createExtendedTerminableInternationalAccessor(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を生成します。
void | ExtendedTerminableInternationalAccessorMap.remove(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を削除します。
void | ExtendedTerminableInternationalAccessor.setProperty(String prop, Object value) プロパティを設定します。
ExtendedTerminableAccessor | ExtendedTerminableAccessorMap.createExtendedTerminableAccessor(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を生成します。
void | ExtendedTerminableAccessorMap.remove(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を削除します。
void | ExtendedTerminableAccessor.setProperty(String prop, Object value) プロパティを設定します。
ExtendedInternationalAccessor | ExtendedInternationalAccessorMap.createExtendedInternationalAccessor(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を生成します。
void | ExtendedInternationalAccessorMap.remove(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を削除します。
void | ExtendedInternationalAccessor.setProperty(String prop, Object value) プロパティを設定します。
ExtendedBaseAccessor | ExtendedBaseAccessorMap.createExtendedBaseAccessor(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を生成します。
void | ExtendedBaseAccessorMap.remove(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を削除します。
void | ExtendedBaseAccessor.setProperty(String prop, Object value) プロパティを設定します。
void | BaseAccessor.setProperty(String prop, Object value) プロパティを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.AccessorException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.AccessorException の使用

AccessorException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category | 会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company | 会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion | 組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version | 会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.deal | 取扱情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.department | 取扱組織権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.detail | 取扱詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group | 取扱パブリックグループ権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.role | 取扱ロール権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach | 商品分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.category | 商品カテゴリ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.type | 商品カテゴリ種別情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail | 商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.template | 商品テンプレート情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.attribute | 商品属性情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue | 商品カタログ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.item | 商品情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach | プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group | プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach | パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category | パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion | パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set | パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version | パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.unit | 単位情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。
jp.co.intra_mart.system.security.datastore.inf |

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.category.category_class のメソッド
String | CateogryClassInternationalModel.getName() 分類区分名を取得します。
void | CateogryClassInternationalModel.setName(String name) 分類区分名を設定します。
String | CateogryClassBaseModel.getCategoryClassCode() 分類区分コードを取得します。
String | CateogryClassBaseModel.getNotes() 備考を取得します。
void | CateogryClassBaseModel.setNotes(String notes) 備考を設定します。
String | CateogryClassBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | CateogryClassBaseModel.getRecordDate() 最終更新日を取得します。
String | CateogryClassBaseModel.getName() 分類区分名を取得します。
String | CateogryClassBaseModel.getName(Locale locale) 分類区分名を取得します。
void | CateogryClassBaseModel.setName(String name) 分類区分名を設定します。
void | CateogryClassBaseModel.setName(String name, Locale locale) 分類区分名を設定します。

jp.co.intra_mart.foundation.datastore.application.model.category.detail での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.category.detail のメソッド
String | CategoryDetailInternationalModel.getName() 分類名を取得します。
void | CategoryDetailInternationalModel.setName(String name) 分類名を設定します。
String | CategoryDetailBaseModel.getCategoryClassCode() 分類区分コードを取得します。
String | CategoryDetailBaseModel.getCategoryCode() 分類コードを取得します。
String | CategoryDetailBaseModel.getNotes() 備考を取得します。
void | CategoryDetailBaseModel.setNotes(String notes) 備考を設定します。
String | CategoryDetailBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | CategoryDetailBaseModel.getRecordDate() 最終更新日を取得します。
String | CategoryDetailBaseModel.getName() 分類名を取得します。
String | CategoryDetailBaseModel.getName(Locale locale) 分類名を取得します。
void | CategoryDetailBaseModel.setName(String name) 分類名を設定します。
void | CategoryDetailBaseModel.setName(String name, Locale locale) 分類名を設定します。

jp.co.intra_mart.foundation.datastore.application.model.company.attach での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.attach のメソッド
String | DepartmentAttachTerminableModel.getPostCode() 役職CDを取得します。
void | DepartmentAttachTerminableModel.setPostCode(String postCode) 役職CDを設定します。
String | DepartmentAttachBaseModel.getUserCode() ユーザコードを取得します。
String | DepartmentAttachBaseModel.getCompanyCode() 会社コードを取得します。
String | DepartmentAttachBaseModel.getDepartmentCode() 組織コードを取得します。
int | DepartmentAttachBaseModel.getSortKey() ソートキーを取得します。
void | DepartmentAttachBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | DepartmentAttachBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | DepartmentAttachBaseModel.getRecordDate() 最終更新日を取得します。
String | DepartmentAttachBaseModel.getPostCode() 役職CDを取得します。
String | DepartmentAttachBaseModel.getPostCode(Date date) 役職CDを取得します。
void | DepartmentAttachBaseModel.setPostCode(String postCode) 役職CDを設定します。
void | DepartmentAttachBaseModel.setPostCode(String postCode, Date date) 役職CDを設定します。

jp.co.intra_mart.foundation.datastore.application.model.company.category での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.category のメソッド
String | CompanyCategoryBaseModel.getCompanyCode() 会社コードを取得します。
String | CompanyCategoryBaseModel.getDepartmentCode() 組織コードを取得します。
String | CompanyCategoryBaseModel.getCategoryClassCode() 分類区分コードを取得します。
String | CompanyCategoryBaseModel.getCategoryCode() 分類コードを取得します。
String | CompanyCategoryBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | CompanyCategoryBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.company.company での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.company のメソッド
String | CompanyBaseModel.getCompanyCode() 会社コードを取得します。
String | CompanyBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | CompanyBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.company.department での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.department のメソッド
String | DepartmentTerminableModel.getTelephoneNumber() 電話番号を取得します。
void | DepartmentTerminableModel.setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
String | DepartmentTerminableModel.getFaxNumber() FAX番号を取得します。
void | DepartmentTerminableModel.setFaxNumber(String faxNumber) FAX番号を設定します。
String | DepartmentTerminableModel.getExtensionNumber() 内線番号を取得します。
void | DepartmentTerminableModel.setExtensionNumber(String extensionNumber) 内線番号を設定します。
String | DepartmentTerminableModel.getExtensionFaxNumber() 内線FAX番号を取得します。
void | DepartmentTerminableModel.setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
String | DepartmentTerminableModel.getCountryCode() 国コードを取得します。
void | DepartmentTerminableModel.setCountryCode(String countryCode) 国コードを設定します。
String | DepartmentTerminableModel.getZipCode() 郵便番号を取得します。
void | DepartmentTerminableModel.setZipCode(String zipCode) 郵便番号を設定します。
String | DepartmentTerminableModel.getEmailAddress1() メールアドレス1を取得します。
void | DepartmentTerminableModel.setEmailAddress1(String emailAddress1) メールアドレス1を設定します。
String | DepartmentTerminableModel.getEmailAddress2() メールアドレス2を取得します。
void | DepartmentTerminableModel.setEmailAddress2(String emailAddress2) メールアドレス2を設定します。
String | DepartmentTerminableModel.getUrl() URLを取得します。
void | DepartmentTerminableModel.setUrl(String url) URLを設定します。
String | DepartmentTerminableModel.getName() 組織名を取得します。
String | DepartmentTerminableModel.getName(Locale locale) 組織名を取得します。
void | DepartmentTerminableModel.setName(String name) 組織名を設定します。
void | DepartmentTerminableModel.setName(String name, Locale locale) 組織名を設定します。
String | DepartmentTerminableModel.getNameSyllabary() 組織名カナを取得します。
String | DepartmentTerminableModel.getNameSyllabary(Locale locale) 組織名カナを取得します。
void | DepartmentTerminableModel.setNameSyllabary(String nameSyllabary) 組織名カナを設定します。
void | DepartmentTerminableModel.setNameSyllabary(String nameSyllabary, Locale locale) 組織名カナを設定します。
String | DepartmentTerminableModel.getNameEnglish() 組織名英字を取得します。
String | DepartmentTerminableModel.getNameEnglish(Locale locale) 組織名英字を取得します。
void | DepartmentTerminableModel.setNameEnglish(String nameEnglish) 組織名英字を設定します。
void | DepartmentTerminableModel.setNameEnglish(String nameEnglish, Locale locale) 組織名英字を設定します。
String | DepartmentTerminableModel.getAddress1() 住所1を取得します。
String | DepartmentTerminableModel.getAddress1(Locale locale) 住所1を取得します。
void | DepartmentTerminableModel.setAddress1(String address1) 住所1を設定します。
void | DepartmentTerminableModel.setAddress1(String address1, Locale locale) 住所1を設定します。
String | DepartmentTerminableModel.getAddress2() 住所2を取得します。
String | DepartmentTerminableModel.getAddress2(Locale locale) 住所2を取得します。
void | DepartmentTerminableModel.setAddress2(String address2) 住所2を設定します。
void | DepartmentTerminableModel.setAddress2(String address2, Locale locale) 住所2を設定します。
String | DepartmentTerminableInternationalModel.getName() 組織名を取得します。
void | DepartmentTerminableInternationalModel.setName(String name) 組織名を設定します。
String | DepartmentTerminableInternationalModel.getNameSyllabary() 組織名カナを取得します。
void | DepartmentTerminableInternationalModel.setNameSyllabary(String nameSyllabary) 組織名カナを設定します。
String | DepartmentTerminableInternationalModel.getNameEnglish() 組織名英字を取得します。
void | DepartmentTerminableInternationalModel.setNameEnglish(String nameEnglish) 組織名英字を設定します。
String | DepartmentTerminableInternationalModel.getAddress1() 住所1を取得します。
void | DepartmentTerminableInternationalModel.setAddress1(String address1) 住所1を設定します。
String | DepartmentTerminableInternationalModel.getAddress2() 住所2を取得します。
void | DepartmentTerminableInternationalModel.setAddress2(String address2) 住所2を設定します。
String | DepartmentBaseModel.getCompanyCode() 会社コードを取得します。
String | DepartmentBaseModel.getDepartmentCode() 組織コードを取得します。
String | DepartmentBaseModel.getNotes() 備考を取得します。
void | DepartmentBaseModel.setNotes(String notes) 備考を設定します。
int | DepartmentBaseModel.getSortKey() ソートキーを取得します。
void | DepartmentBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | DepartmentBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | DepartmentBaseModel.getRecordDate() 最終更新日を取得します。
String | DepartmentBaseModel.getTelephoneNumber() 電話番号を取得します。
String | DepartmentBaseModel.getTelephoneNumber(Date date) 電話番号を取得します。
void | DepartmentBaseModel.setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | DepartmentBaseModel.setTelephoneNumber(String telephoneNumber, Date date) 電話番号を設定します。
String | DepartmentBaseModel.getFaxNumber() FAX番号を取得します。
String | DepartmentBaseModel.getFaxNumber(Date date) FAX番号を取得します。
void | DepartmentBaseModel.setFaxNumber(String faxNumber) FAX番号を設定します。
void | DepartmentBaseModel.setFaxNumber(String faxNumber, Date date) FAX番号を設定します。
String | DepartmentBaseModel.getExtensionNumber() 内線番号を取得します。
String | DepartmentBaseModel.getExtensionNumber(Date date) 内線番号を取得します。
void | DepartmentBaseModel.setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | DepartmentBaseModel.setExtensionNumber(String extensionNumber, Date date) 内線番号を設定します。
String | DepartmentBaseModel.getExtensionFaxNumber() 内線FAX番号を取得します。
String | DepartmentBaseModel.getExtensionFaxNumber(Date date) 内線FAX番号を取得します。
void | DepartmentBaseModel.setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | DepartmentBaseModel.setExtensionFaxNumber(String extensionFaxNumber, Date date) 内線FAX番号を設定します。
String | DepartmentBaseModel.getCountryCode() 国コードを取得します。
String | DepartmentBaseModel.getCountryCode(Date date) 国コードを取得します。
void | DepartmentBaseModel.setCountryCode(String countryCode) 国コードを設定します。
void | DepartmentBaseModel.setCountryCode(String countryCode, Date date) 国コードを設定します。
String | DepartmentBaseModel.getZipCode() 郵便番号を取得します。
String | DepartmentBaseModel.getZipCode(Date date) 郵便番号を取得します。
void | DepartmentBaseModel.setZipCode(String zipCode) 郵便番号を設定します。
void | DepartmentBaseModel.setZipCode(String zipCode, Date date) 郵便番号を設定します。
String | DepartmentBaseModel.getEmailAddress1() メールアドレス1を取得します。
String | DepartmentBaseModel.getEmailAddress1(Date date) メールアドレス1を取得します。
void | DepartmentBaseModel.setEmailAddress1(String emailAddress1) メールアドレス1を設定します。
void | DepartmentBaseModel.setEmailAddress1(String emailAddress1, Date date) メールアドレス1を設定します。
String | DepartmentBaseModel.getEmailAddress2() メールアドレス2を取得します。
String | DepartmentBaseModel.getEmailAddress2(Date date) メールアドレス2を取得します。
void | DepartmentBaseModel.setEmailAddress2(String emailAddress2) メールアドレス2を設定します。
void | DepartmentBaseModel.setEmailAddress2(String emailAddress2, Date date) メールアドレス2を設定します。
String | DepartmentBaseModel.getUrl() URLを取得します。
String | DepartmentBaseModel.getUrl(Date date) URLを取得します。
void | DepartmentBaseModel.setUrl(String url) URLを設定します。
void | DepartmentBaseModel.setUrl(String url, Date date) URLを設定します。
String | DepartmentBaseModel.getName() 組織名を取得します。
String | DepartmentBaseModel.getName(Date date) 組織名を取得します。
String | DepartmentBaseModel.getName(Locale locale) 組織名を取得します。
String | DepartmentBaseModel.getName(Date date, Locale locale) 組織名を取得します。
void | DepartmentBaseModel.setName(String name) 組織名を設定します。
void | DepartmentBaseModel.setName(String name, Date date) 組織名を設定します。
void | DepartmentBaseModel.setName(String name, Locale locale) 組織名を設定します。
void | DepartmentBaseModel.setName(String name, Date date, Locale locale) 組織名を設定します。
String | DepartmentBaseModel.getNameSyllabary() 組織名カナを取得します。
String | DepartmentBaseModel.getNameSyllabary(Date date) 組織名カナを取得します。
String | DepartmentBaseModel.getNameSyllabary(Locale locale) 組織名カナを取得します。
String | DepartmentBaseModel.getNameSyllabary(Date date, Locale locale) 組織名カナを取得します。
void | DepartmentBaseModel.setNameSyllabary(String nameSyllabary) 組織名カナを設定します。
void | DepartmentBaseModel.setNameSyllabary(String nameSyllabary, Date date) 組織名カナを設定します。
void | DepartmentBaseModel.setNameSyllabary(String nameSyllabary, Locale locale) 組織名カナを設定します。
void | DepartmentBaseModel.setNameSyllabary(String nameSyllabary, Date date, Locale locale) 組織名カナを設定します。
String | DepartmentBaseModel.getNameEnglish() 組織名英字を取得します。
String | DepartmentBaseModel.getNameEnglish(Date date) 組織名英字を取得します。
String | DepartmentBaseModel.getNameEnglish(Locale locale) 組織名英字を取得します。
String | DepartmentBaseModel.getNameEnglish(Date date, Locale locale) 組織名英字を取得します。
void | DepartmentBaseModel.setNameEnglish(String nameEnglish) 組織名英字を設定します。
void | DepartmentBaseModel.setNameEnglish(String nameEnglish, Date date) 組織名英字を設定します。
void | DepartmentBaseModel.setNameEnglish(String nameEnglish, Locale locale) 組織名英字を設定します。
void | DepartmentBaseModel.setNameEnglish(String nameEnglish, Date date, Locale locale) 組織名英字を設定します。
String | DepartmentBaseModel.getAddress1() 住所1を取得します。
String | DepartmentBaseModel.getAddress1(Date date) 住所1を取得します。
String | DepartmentBaseModel.getAddress1(Locale locale) 住所1を取得します。
String | DepartmentBaseModel.getAddress1(Date date, Locale locale) 住所1を取得します。
void | DepartmentBaseModel.setAddress1(String address1) 住所1を設定します。
void | DepartmentBaseModel.setAddress1(String address1, Date date) 住所1を設定します。
void | DepartmentBaseModel.setAddress1(String address1, Locale locale) 住所1を設定します。
void | DepartmentBaseModel.setAddress1(String address1, Date date, Locale locale) 住所1を設定します。
String | DepartmentBaseModel.getAddress2() 住所2を取得します。
String | DepartmentBaseModel.getAddress2(Date date) 住所2を取得します。
String | DepartmentBaseModel.getAddress2(Locale locale) 住所2を取得します。
String | DepartmentBaseModel.getAddress2(Date date, Locale locale) 住所2を取得します。
void | DepartmentBaseModel.setAddress2(String address2) 住所2を設定します。
void | DepartmentBaseModel.setAddress2(String address2, Date date) 住所2を設定します。
void | DepartmentBaseModel.setAddress2(String address2, Locale locale) 住所2を設定します。
void | DepartmentBaseModel.setAddress2(String address2, Date date, Locale locale) 住所2を設定します。

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.inclusion のメソッド
String | DepartmentInclusionBaseModel.getCompanyCode() 会社コードを取得します。
String | DepartmentInclusionBaseModel.getVersionCode() バージョンコードを取得します。
String | DepartmentInclusionBaseModel.getParentDepartmentCode() 親組織コードを取得します。
String | DepartmentInclusionBaseModel.getDepartmentCode() 組織コードを取得します。
int | DepartmentInclusionBaseModel.getDepth() 階層レベルを取得します。
void | DepartmentInclusionBaseModel.setDepth(int depth) 階層レベルを設定します。
String | DepartmentInclusionBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | DepartmentInclusionBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.company.main での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.main のメソッド
String | DepartmentMainTerminableModel.getCompanyCode() 会社コードを取得します。
void | DepartmentMainTerminableModel.setCompanyCode(String companyCode) 会社コードを設定します。
String | DepartmentMainTerminableModel.getDepartmentCode() 組織コードを取得します。
void | DepartmentMainTerminableModel.setDepartmentCode(String departmentCode) 組織コードを設定します。
String | DepartmentMainBaseModel.getUserCode() ユーザコードを取得します。
String | DepartmentMainBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | DepartmentMainBaseModel.getRecordDate() 最終更新日を取得します。
String | DepartmentMainBaseModel.getCompanyCode() 会社コードを取得します。
String | DepartmentMainBaseModel.getCompanyCode(Date date) 会社コードを取得します。
void | DepartmentMainBaseModel.setCompanyCode(String companyCode) 会社コードを設定します。
void | DepartmentMainBaseModel.setCompanyCode(String companyCode, Date date) 会社コードを設定します。
String | DepartmentMainBaseModel.getDepartmentCode() 組織コードを取得します。
String | DepartmentMainBaseModel.getDepartmentCode(Date date) 組織コードを取得します。
void | DepartmentMainBaseModel.setDepartmentCode(String departmentCode) 組織コードを設定します。
void | DepartmentMainBaseModel.setDepartmentCode(String departmentCode, Date date) 組織コードを設定します。

jp.co.intra_mart.foundation.datastore.application.model.company.post での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.post のメソッド
String | CompanyPostTerminableModel.getName() 役職名を取得します。
String | CompanyPostTerminableModel.getName(Locale locale) 役職名を取得します。
void | CompanyPostTerminableModel.setName(String name) 役職名を設定します。
void | CompanyPostTerminableModel.setName(String name, Locale locale) 役職名を設定します。
String | CompanyPostTerminableInternationalModel.getName() 役職名を取得します。
void | CompanyPostTerminableInternationalModel.setName(String name) 役職名を設定します。
String | CompanyPostBaseModel.getCompanyCode() 会社コードを取得します。
String | CompanyPostBaseModel.getPostCode() 役職コードを取得します。
String | CompanyPostBaseModel.getNotes() 備考を取得します。
void | CompanyPostBaseModel.setNotes(String notes) 備考を設定します。
int | CompanyPostBaseModel.getSortKey() ソートキーを取得します。
void | CompanyPostBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | CompanyPostBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | CompanyPostBaseModel.getRecordDate() 最終更新日を取得します。
String | CompanyPostBaseModel.getName() 役職名を取得します。
String | CompanyPostBaseModel.getName(Date date) 役職名を取得します。
String | CompanyPostBaseModel.getName(Locale locale) 役職名を取得します。
String | CompanyPostBaseModel.getName(Date date, Locale locale) 役職名を取得します。
void | CompanyPostBaseModel.setName(String name) 役職名を設定します。
void | CompanyPostBaseModel.setName(String name, Date date) 役職名を設定します。
void | CompanyPostBaseModel.setName(String name, Locale locale) 役職名を設定します。
void | CompanyPostBaseModel.setName(String name, Date date, Locale locale) 役職名を設定します。

jp.co.intra_mart.foundation.datastore.application.model.company.version での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.version のメソッド
String | CompanyVersionBaseModel.getCompanyCode() 会社コードを取得します。
String | CompanyVersionBaseModel.getVersionCode() バージョンコードを取得します。
Date | CompanyVersionBaseModel.getStartDate() 開始日を取得します。
void | CompanyVersionBaseModel.setStartDate(Date startDate) 開始日を設定します。
Date | CompanyVersionBaseModel.getEndDate() 終了日を取得します。
void | CompanyVersionBaseModel.setEndDate(Date endDate) 終了日を設定します。
String | CompanyVersionBaseModel.getNotes() 備考を取得します。
void | CompanyVersionBaseModel.setNotes(String notes) 備考を設定します。
String | CompanyVersionBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | CompanyVersionBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.deal.deal での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.deal.deal のメソッド
double | DealTerminableModel.getUnitPrice() 単価を取得します。
void | DealTerminableModel.setUnitPrice(double unitPrice) 単価を設定します。
String | DealBaseModel.getCustomerCompanyCode() 取引先会社コードを取得します。
String | DealBaseModel.getCustomerDepartmentCode() 取引先組織コードを取得します。
String | DealBaseModel.getDealCode() 取扱コードを取得します。
String | DealBaseModel.getDealName() 取扱名を取得します。
void | DealBaseModel.setDealName(String dealName) 取扱名を設定します。
int | DealBaseModel.getDealType() 取扱種別を取得します。
void | DealBaseModel.setDealType(int dealType) 取扱種別を設定します。
String | DealBaseModel.getCurrencyCode() 通貨コードを取得します。
void | DealBaseModel.setCurrencyCode(String currencyCode) 通貨コードを設定します。
String | DealBaseModel.getNotes() 備考を取得します。
void | DealBaseModel.setNotes(String notes) 備考を設定します。
String | DealBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | DealBaseModel.getRecordDate() 最終更新日を取得します。
double | DealBaseModel.getUnitPrice() 単価を取得します。
double | DealBaseModel.getUnitPrice(Date date) 単価を取得します。
void | DealBaseModel.setUnitPrice(double unitPrice) 単価を設定します。
void | DealBaseModel.setUnitPrice(double unitPrice, Date date) 単価を設定します。

jp.co.intra_mart.foundation.datastore.application.model.deal.department での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.deal.department のメソッド
String | DealerDepartmentBaseModel.getCustomerCompanyCode() 取引先会社コードを取得します。
String | DealerDepartmentBaseModel.getCustomerDepartmentCode() 取引先組織コードを取得します。
String | DealerDepartmentBaseModel.getDealCode() 取扱コードを取得します。
String | DealerDepartmentBaseModel.getCompanyCode() 会社コードを取得します。
String | DealerDepartmentBaseModel.getDepartmentCode() 組織コードを取得します。
String | DealerDepartmentBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | DealerDepartmentBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.deal.detail での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.deal.detail のメソッド
String | DealDetailTerminableModel.getUnitCode() 単位コードを取得します。
void | DealDetailTerminableModel.setUnitCode(String unitCode) 単位コードを設定します。
int | DealDetailTerminableModel.getAmount() 数量を取得します。
void | DealDetailTerminableModel.setAmount(int amount) 数量を設定します。
double | DealDetailTerminableModel.getUnitPrice() 単価を取得します。
void | DealDetailTerminableModel.setUnitPrice(double unitPrice) 単価を設定します。
String | DealDetailBaseModel.getCustomerCompanyCode() 取引先会社コードを取得します。
String | DealDetailBaseModel.getCustomerDepartmentCode() 取引先組織コードを取得します。
String | DealDetailBaseModel.getDealCode() 取扱コードを取得します。
String | DealDetailBaseModel.getItemCode() 商品コードを取得します。
String | DealDetailBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | DealDetailBaseModel.getRecordDate() 最終更新日を取得します。
String | DealDetailBaseModel.getUnitCode() 単位コードを取得します。
String | DealDetailBaseModel.getUnitCode(Date date) 単位コードを取得します。
void | DealDetailBaseModel.setUnitCode(String unitCode) 単位コードを設定します。
void | DealDetailBaseModel.setUnitCode(String unitCode, Date date) 単位コードを設定します。
int | DealDetailBaseModel.getAmount() 数量を取得します。
int | DealDetailBaseModel.getAmount(Date date) 数量を取得します。
void | DealDetailBaseModel.setAmount(int amount) 数量を設定します。
void | DealDetailBaseModel.setAmount(int amount, Date date) 数量を設定します。
double | DealDetailBaseModel.getUnitPrice() 単価を取得します。
double | DealDetailBaseModel.getUnitPrice(Date date) 単価を取得します。
void | DealDetailBaseModel.setUnitPrice(double unitPrice) 単価を設定します。
void | DealDetailBaseModel.setUnitPrice(double unitPrice, Date date) 単価を設定します。

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.deal.public_group のメソッド
String | DealerPublicGroupBaseModel.getCustomerCompanyCode() 取引先会社コードを取得します。
String | DealerPublicGroupBaseModel.getCustomerDepartmentCode() 取引先組織コードを取得します。
String | DealerPublicGroupBaseModel.getDealCode() 取扱コードを取得します。
String | DealerPublicGroupBaseModel.getPublicGroupSetCode() グループセットコードを取得します。
String | DealerPublicGroupBaseModel.getPublicGroupCode() グループコードを取得します。
String | DealerPublicGroupBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | DealerPublicGroupBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.deal.role での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.deal.role のメソッド
String | DealerRoleBaseModel.getCustomerCompanyCode() 取引先会社コードを取得します。
String | DealerRoleBaseModel.getCustomerDepartmentCode() 取引先組織コードを取得します。
String | DealerRoleBaseModel.getDealCode() 取扱コードを取得します。
String | DealerRoleBaseModel.getRoleId() ロールIDを取得します。
String | DealerRoleBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | DealerRoleBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.item_category.attach のメソッド
String | ItemAttachBaseModel.getItemCategoryTypeCode() 商品カテゴリ種別コードを取得します。
String | ItemAttachBaseModel.getItemCategoryCode() 商品カテゴリコードを取得します。
String | ItemAttachBaseModel.getItemCode() 商品コードを取得します。
String | ItemAttachBaseModel.getRecordUserCd() 最終更新者を取得します。
Date | ItemAttachBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.category での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.item_category.category のメソッド
String | ItemCategoryInternationalModel.getItemCategoryName() 商品カテゴリ名を取得します。
void | ItemCategoryInternationalModel.setItemCategoryName(String itemCategoryName) 商品カテゴリ名を設定します。
String | ItemCategoryBaseModel.getItemCategoryTypeCode() 商品カテゴリ種別コードを取得します。
String | ItemCategoryBaseModel.getItemCategoryCode() 商品カテゴリコードを取得します。
String | ItemCategoryBaseModel.getParentItemCategoryCode() 親商品カテゴリコードを取得します。
void | ItemCategoryBaseModel.setParentItemCategoryCode(String parentItemCategoryCode) 親商品カテゴリコードを設定します。
String | ItemCategoryBaseModel.getNotes() 備考を取得します。
void | ItemCategoryBaseModel.setNotes(String notes) 備考を設定します。
int | ItemCategoryBaseModel.getSortKey() ソートキーを取得します。
void | ItemCategoryBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | ItemCategoryBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | ItemCategoryBaseModel.getRecordDate() 最終更新日を取得します。
String | ItemCategoryBaseModel.getItemCategoryName() 商品カテゴリ名を取得します。
String | ItemCategoryBaseModel.getItemCategoryName(Locale locale) 商品カテゴリ名を取得します。
void | ItemCategoryBaseModel.setItemCategoryName(String itemCategoryName) 商品カテゴリ名を設定します。
void | ItemCategoryBaseModel.setItemCategoryName(String itemCategoryName, Locale locale) 商品カテゴリ名を設定します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.type での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.item_category.type のメソッド
String | ItemCategoryTypeBaseModel.getItemCategoryTypeCode() 商品カテゴリ種別コードを取得します。
String | ItemCategoryTypeBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | ItemCategoryTypeBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.item_template.detail のメソッド
String | ItemTemplateDetailInternationalModel.getTemplateDetailName() テンプレート明細名を取得します。
void | ItemTemplateDetailInternationalModel.setTemplateDetailName(String templateDetailName) テンプレート明細名を設定します。
String | ItemTemplateDetailBaseModel.getTemplateCode() テンプレートコードを取得します。
String | ItemTemplateDetailBaseModel.getTemplateDetailCode() テンプレート明細コードを取得します。
int | ItemTemplateDetailBaseModel.getDataType() データ型を取得します。
void | ItemTemplateDetailBaseModel.setDataType(int dataType) データ型を設定します。
int | ItemTemplateDetailBaseModel.getSortKey() ソートキーを取得します。
void | ItemTemplateDetailBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | ItemTemplateDetailBaseModel.getNotes() 備考を取得します。
void | ItemTemplateDetailBaseModel.setNotes(String notes) 備考を設定します。
String | ItemTemplateDetailBaseModel.getRecordUserCd() 最終更新者を取得します。
Date | ItemTemplateDetailBaseModel.getRecordDate() 最終更新日を取得します。
String | ItemTemplateDetailBaseModel.getTemplateDetailName() テンプレート明細名を取得します。
String | ItemTemplateDetailBaseModel.getTemplateDetailName(Locale locale) テンプレート明細名を取得します。
void | ItemTemplateDetailBaseModel.setTemplateDetailName(String templateDetailName) テンプレート明細名を設定します。
void | ItemTemplateDetailBaseModel.setTemplateDetailName(String templateDetailName, Locale locale) テンプレート明細名を設定します。

jp.co.intra_mart.foundation.datastore.application.model.item_template.template での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.item_template.template のメソッド
String | ItemTemplateInternationalModel.getTemplateName() テンプレート名を取得します。
void | ItemTemplateInternationalModel.setTemplateName(String templateName) テンプレート名を設定します。
String | ItemTemplateBaseModel.getTemplateCode() テンプレートコードを取得します。
String | ItemTemplateBaseModel.getTemplateName() テンプレート名を取得します。
void | ItemTemplateBaseModel.setTemplateName(String templateName) テンプレート名を設定します。
String | ItemTemplateBaseModel.getNotes() 備考を取得します。
void | ItemTemplateBaseModel.setNotes(String notes) 備考を設定します。
String | ItemTemplateBaseModel.getRecordUserCd() 最終更新者を取得します。
Date | ItemTemplateBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.item.attribute での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.item.attribute のメソッド
String | ItemAttributeInternationalModel.getStringValue() 属性文字列を取得します。
void | ItemAttributeInternationalModel.setStringValue(String stringValue) 属性文字列を設定します。
String | ItemAttributeBaseModel.getItemCode() 商品コードを取得します。
String | ItemAttributeBaseModel.getTemplateCode() テンプレートコードを取得します。
String | ItemAttributeBaseModel.getTemplateDetailCode() テンプレート明細コードを取得します。
double | ItemAttributeBaseModel.getNumberValue() 属性数値を取得します。
void | ItemAttributeBaseModel.setNumberValue(double numberValue) 属性数値を設定します。
String | ItemAttributeBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | ItemAttributeBaseModel.getRecordDate() 最終更新日を取得します。
String | ItemAttributeBaseModel.getStringValue() 属性文字列を取得します。
String | ItemAttributeBaseModel.getStringValue(Locale locale) 属性文字列を取得します。
void | ItemAttributeBaseModel.setStringValue(String stringValue) 属性文字列を設定します。
void | ItemAttributeBaseModel.setStringValue(String stringValue, Locale locale) 属性文字列を設定します。

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.item.catalogue のメソッド
String | ItemCatalogueBaseModel.getItemCode() 商品コードを取得します。
String | ItemCatalogueBaseModel.getItemCatalogueCode() 商品カタログコードを取得します。
int | ItemCatalogueBaseModel.getMediaCls() 媒体種類を取得します。
void | ItemCatalogueBaseModel.setMediaCls(int mediaCls) 媒体種類を設定します。
String | ItemCatalogueBaseModel.getMedia() 媒体を取得します。
void | ItemCatalogueBaseModel.setMedia(String media) 媒体を設定します。
String | ItemCatalogueBaseModel.getNotes() 備考を取得します。
void | ItemCatalogueBaseModel.setNotes(String notes) 備考を設定します。
int | ItemCatalogueBaseModel.getSortKey() ソートキーを取得します。
void | ItemCatalogueBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | ItemCatalogueBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | ItemCatalogueBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.item.item での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.item.item のメソッド
double | ItemTerminableModel.getSalesUnitPrice() 販売単価を取得します。
void | ItemTerminableModel.setSalesUnitPrice(double salesUnitPrice) 販売単価を設定します。
double | ItemTerminableModel.getPurchaseUnitPrice() 仕入単価を取得します。
void | ItemTerminableModel.setPurchaseUnitPrice(double purchaseUnitPrice) 仕入単価を設定します。
String | ItemTerminableModel.getItemName() 商品名を取得します。
String | ItemTerminableModel.getItemName(Locale locale) 商品名を取得します。
void | ItemTerminableModel.setItemName(String itemName) 商品名を設定します。
void | ItemTerminableModel.setItemName(String itemName, Locale locale) 商品名を設定します。
String | ItemTerminableModel.getItemCaption() 商品通称を取得します。
String | ItemTerminableModel.getItemCaption(Locale locale) 商品通称を取得します。
void | ItemTerminableModel.setItemCaption(String itemCaption) 商品通称を設定します。
void | ItemTerminableModel.setItemCaption(String itemCaption, Locale locale) 商品通称を設定します。
String | ItemTerminableInternationalModel.getItemName() 商品名を取得します。
void | ItemTerminableInternationalModel.setItemName(String itemName) 商品名を設定します。
String | ItemTerminableInternationalModel.getItemCaption() 商品通称を取得します。
void | ItemTerminableInternationalModel.setItemCaption(String itemCaption) 商品通称を設定します。
String | ItemBaseModel.getItemCode() 商品コードを取得します。
String | ItemBaseModel.getProductModelCode() 製品型番を取得します。
void | ItemBaseModel.setProductModelCode(String productModelCode) 製品型番を設定します。
String | ItemBaseModel.getNotes() 備考を取得します。
void | ItemBaseModel.setNotes(String notes) 備考を設定します。
String | ItemBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | ItemBaseModel.getRecordDate() 最終更新日を取得します。
double | ItemBaseModel.getSalesUnitPrice() 販売単価を取得します。
double | ItemBaseModel.getSalesUnitPrice(Date date) 販売単価を取得します。
void | ItemBaseModel.setSalesUnitPrice(double salesUnitPrice) 販売単価を設定します。
void | ItemBaseModel.setSalesUnitPrice(double salesUnitPrice, Date date) 販売単価を設定します。
double | ItemBaseModel.getPurchaseUnitPrice() 仕入単価を取得します。
double | ItemBaseModel.getPurchaseUnitPrice(Date date) 仕入単価を取得します。
void | ItemBaseModel.setPurchaseUnitPrice(double purchaseUnitPrice) 仕入単価を設定します。
void | ItemBaseModel.setPurchaseUnitPrice(double purchaseUnitPrice, Date date) 仕入単価を設定します。
String | ItemBaseModel.getItemName() 商品名を取得します。
String | ItemBaseModel.getItemName(Date date) 商品名を取得します。
String | ItemBaseModel.getItemName(Locale locale) 商品名を取得します。
String | ItemBaseModel.getItemName(Date date, Locale locale) 商品名を取得します。
void | ItemBaseModel.setItemName(String itemName) 商品名を設定します。
void | ItemBaseModel.setItemName(String itemName, Date date) 商品名を設定します。
void | ItemBaseModel.setItemName(String itemName, Locale locale) 商品名を設定します。
void | ItemBaseModel.setItemName(String itemName, Date date, Locale locale) 商品名を設定します。
String | ItemBaseModel.getItemCaption() 商品通称を取得します。
String | ItemBaseModel.getItemCaption(Date date) 商品通称を取得します。
String | ItemBaseModel.getItemCaption(Locale locale) 商品通称を取得します。
String | ItemBaseModel.getItemCaption(Date date, Locale locale) 商品通称を取得します。
void | ItemBaseModel.setItemCaption(String itemCaption) 商品通称を設定します。
void | ItemBaseModel.setItemCaption(String itemCaption, Date date) 商品通称を設定します。
void | ItemBaseModel.setItemCaption(String itemCaption, Locale locale) 商品通称を設定します。
void | ItemBaseModel.setItemCaption(String itemCaption, Date date, Locale locale) 商品通称を設定します。

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.private_group.attach のメソッド
String | PrivateGroupAttachBaseModel.getOwnerCode() 所有者コードを取得します。
String | PrivateGroupAttachBaseModel.getPrivateGroupCode() グループコードを取得します。
String | PrivateGroupAttachBaseModel.getUserCode() ユーザコードを取得します。
int | PrivateGroupAttachBaseModel.getSortKey() ソートキーを取得します。
void | PrivateGroupAttachBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | PrivateGroupAttachBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | PrivateGroupAttachBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.private_group.group での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.private_group.group のメソッド
String | PrivateGroupBaseModel.getOwnerCode() 所有者コードを取得します。
String | PrivateGroupBaseModel.getPrivateGroupCode() グループコードを取得します。
String | PrivateGroupBaseModel.getName() グループ名を取得します。
void | PrivateGroupBaseModel.setName(String name) グループ名を設定します。
String | PrivateGroupBaseModel.getNameSyllabary() グループ名カナを取得します。
void | PrivateGroupBaseModel.setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
String | PrivateGroupBaseModel.getNameEnglish() グループ名英字を取得します。
void | PrivateGroupBaseModel.setNameEnglish(String nameEnglish) グループ名英字を設定します。
String | PrivateGroupBaseModel.getNotes() 備考を取得します。
void | PrivateGroupBaseModel.setNotes(String notes) 備考を設定します。
int | PrivateGroupBaseModel.getSortKey() ソートキーを取得します。
void | PrivateGroupBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | PrivateGroupBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | PrivateGroupBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.attach のメソッド
String | PublicGroupAttachBaseModel.getUserCode() ユーザコードを取得します。
String | PublicGroupAttachBaseModel.getPublicGroupSetCode() グループセットコードを取得します。
String | PublicGroupAttachBaseModel.getPublicGroupCode() グループコードを取得します。
int | PublicGroupAttachBaseModel.getSortKey() ソートキーを取得します。
void | PublicGroupAttachBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | PublicGroupAttachBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | PublicGroupAttachBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.category のメソッド
String | PublicGroupCategoryBaseModel.getPublicGroupSetCode() グループセットコードを取得します。
String | PublicGroupCategoryBaseModel.getPublicGroupCode() グループコードを取得します。
String | PublicGroupCategoryBaseModel.getCategoryClassCode() 分類区分コードを取得します。
String | PublicGroupCategoryBaseModel.getCategoryCode() 分類コードを取得します。
String | PublicGroupCategoryBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | PublicGroupCategoryBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.group のメソッド
String | PublicGroupTerminableModel.getName() グループ名を取得します。
String | PublicGroupTerminableModel.getName(Locale locale) グループ名を取得します。
void | PublicGroupTerminableModel.setName(String name) グループ名を設定します。
void | PublicGroupTerminableModel.setName(String name, Locale locale) グループ名を設定します。
String | PublicGroupTerminableModel.getNameSyllabary() グループ名カナを取得します。
String | PublicGroupTerminableModel.getNameSyllabary(Locale locale) グループ名カナを取得します。
void | PublicGroupTerminableModel.setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
void | PublicGroupTerminableModel.setNameSyllabary(String nameSyllabary, Locale locale) グループ名カナを設定します。
String | PublicGroupTerminableModel.getNameEnglish() グループ名英字を取得します。
String | PublicGroupTerminableModel.getNameEnglish(Locale locale) グループ名英字を取得します。
void | PublicGroupTerminableModel.setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | PublicGroupTerminableModel.setNameEnglish(String nameEnglish, Locale locale) グループ名英字を設定します。
String | PublicGroupTerminableInternationalModel.getName() グループ名を取得します。
void | PublicGroupTerminableInternationalModel.setName(String name) グループ名を設定します。
String | PublicGroupTerminableInternationalModel.getNameSyllabary() グループ名カナを取得します。
void | PublicGroupTerminableInternationalModel.setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
String | PublicGroupTerminableInternationalModel.getNameEnglish() グループ名英字を取得します。
void | PublicGroupTerminableInternationalModel.setNameEnglish(String nameEnglish) グループ名英字を設定します。
String | PublicGroupBaseModel.getPublicGroupSetCode() グループセットコードを取得します。
String | PublicGroupBaseModel.getPublicGroupCode() グループコードを取得します。
String | PublicGroupBaseModel.getNotes() 備考を取得します。
void | PublicGroupBaseModel.setNotes(String notes) 備考を設定します。
int | PublicGroupBaseModel.getSortKey() ソートキーを取得します。
void | PublicGroupBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | PublicGroupBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | PublicGroupBaseModel.getRecordDate() 最終更新日を取得します。
String | PublicGroupBaseModel.getName() グループ名を取得します。
String | PublicGroupBaseModel.getName(Date date) グループ名を取得します。
String | PublicGroupBaseModel.getName(Locale locale) グループ名を取得します。
String | PublicGroupBaseModel.getName(Date date, Locale locale) グループ名を取得します。
void | PublicGroupBaseModel.setName(String name) グループ名を設定します。
void | PublicGroupBaseModel.setName(String name, Date date) グループ名を設定します。
void | PublicGroupBaseModel.setName(String name, Locale locale) グループ名を設定します。
void | PublicGroupBaseModel.setName(String name, Date date, Locale locale) グループ名を設定します。
String | PublicGroupBaseModel.getNameSyllabary() グループ名カナを取得します。
String | PublicGroupBaseModel.getNameSyllabary(Date date) グループ名カナを取得します。
String | PublicGroupBaseModel.getNameSyllabary(Locale locale) グループ名カナを取得します。
String | PublicGroupBaseModel.getNameSyllabary(Date date, Locale locale) グループ名カナを取得します。
void | PublicGroupBaseModel.setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
void | PublicGroupBaseModel.setNameSyllabary(String nameSyllabary, Date date) グループ名カナを設定します。
void | PublicGroupBaseModel.setNameSyllabary(String nameSyllabary, Locale locale) グループ名カナを設定します。
void | PublicGroupBaseModel.setNameSyllabary(String nameSyllabary, Date date, Locale locale) グループ名カナを設定します。
String | PublicGroupBaseModel.getNameEnglish() グループ名英字を取得します。
String | PublicGroupBaseModel.getNameEnglish(Date date) グループ名英字を取得します。
String | PublicGroupBaseModel.getNameEnglish(Locale locale) グループ名英字を取得します。
String | PublicGroupBaseModel.getNameEnglish(Date date, Locale locale) グループ名英字を取得します。
void | PublicGroupBaseModel.setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | PublicGroupBaseModel.setNameEnglish(String nameEnglish, Date date) グループ名英字を設定します。
void | PublicGroupBaseModel.setNameEnglish(String nameEnglish, Locale locale) グループ名英字を設定します。
void | PublicGroupBaseModel.setNameEnglish(String nameEnglish, Date date, Locale locale) グループ名英字を設定します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion のメソッド
String | PublicGroupInclusionBaseModel.getPublicGroupSetCode() グループセットコードを取得します。
String | PublicGroupInclusionBaseModel.getVersionCode() バージョンコードを取得します。
String | PublicGroupInclusionBaseModel.getParentPublicGroupCode() 親グループコードを取得します。
String | PublicGroupInclusionBaseModel.getPublicGroupCode() グループコードを取得します。
int | PublicGroupInclusionBaseModel.getDepth() 階層レベルを取得します。
void | PublicGroupInclusionBaseModel.setDepth(int depth) 階層レベルを設定します。
String | PublicGroupInclusionBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | PublicGroupInclusionBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.set での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.set のメソッド
String | PublicGroupSetBaseModel.getPublicGroupSetCode() グループセットコードを取得します。
String | PublicGroupSetBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | PublicGroupSetBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.version での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.version のメソッド
String | PublicGroupVersionBaseModel.getPublicGroupSetCode() グループセットコードを取得します。
String | PublicGroupVersionBaseModel.getVersionCode() バージョンコードを取得します。
Date | PublicGroupVersionBaseModel.getStartDate() 開始日を取得します。
void | PublicGroupVersionBaseModel.setStartDate(Date startDate) 開始日を設定します。
Date | PublicGroupVersionBaseModel.getEndDate() 終了日を取得します。
void | PublicGroupVersionBaseModel.setEndDate(Date endDate) 終了日を設定します。
String | PublicGroupVersionBaseModel.getNotes() 備考を取得します。
void | PublicGroupVersionBaseModel.setNotes(String notes) 備考を設定します。
String | PublicGroupVersionBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | PublicGroupVersionBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.unit での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.unit のメソッド
String | UnitBaseModel.getUnitCode() 単位コードを取得します。
String | UnitBaseModel.getUnitName() 単位名を取得します。
void | UnitBaseModel.setUnitName(String unitName) 単位名を設定します。

jp.co.intra_mart.foundation.datastore.application.model.user での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.user のメソッド
String | UserTerminableModel.getTelephoneNumber() 電話番号を取得します。
void | UserTerminableModel.setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
String | UserTerminableModel.getMobileNumber() 携帯電話番号を取得します。
void | UserTerminableModel.setMobileNumber(String mobileNumber) 携帯電話番号を設定します。
String | UserTerminableModel.getFaxNumber() FAX番号を取得します。
void | UserTerminableModel.setFaxNumber(String faxNumber) FAX番号を設定します。
String | UserTerminableModel.getExtensionNumber() 内線番号を取得します。
void | UserTerminableModel.setExtensionNumber(String extensionNumber) 内線番号を設定します。
String | UserTerminableModel.getExtensionFaxNumber() 内線FAX番号を取得します。
void | UserTerminableModel.setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
String | UserTerminableModel.getCountryCode() 国コードを取得します。
void | UserTerminableModel.setCountryCode(String countryCode) 国コードを設定します。
String | UserTerminableModel.getZipCode() 郵便番号を取得します。
void | UserTerminableModel.setZipCode(String zipCode) 郵便番号を設定します。
String | UserTerminableModel.getEmailAddress1() メールアドレス１を取得します。
void | UserTerminableModel.setEmailAddress1(String emailAddress1) メールアドレス１を設定します。
String | UserTerminableModel.getEmailAddress2() メールアドレス２を取得します。
void | UserTerminableModel.setEmailAddress2(String emailAddress2) メールアドレス２を設定します。
String | UserTerminableModel.getMobileEmailAddress() 携帯用メールを取得します。
void | UserTerminableModel.setMobileEmailAddress(String mobileEmailAddress) 携帯用メールを設定します。
String | UserTerminableModel.getUrl() URLを取得します。
void | UserTerminableModel.setUrl(String url) URLを設定します。
String | UserTerminableModel.getName() ユーザ名を取得します。
String | UserTerminableModel.getName(Locale locale) ユーザ名を取得します。
void | UserTerminableModel.setName(String name) ユーザ名を設定します。
void | UserTerminableModel.setName(String name, Locale locale) ユーザ名を設定します。
String | UserTerminableModel.getNameSyllabary() ユーザ名カナを取得します。
String | UserTerminableModel.getNameSyllabary(Locale locale) ユーザ名カナを取得します。
void | UserTerminableModel.setNameSyllabary(String nameSyllabary) ユーザ名カナを設定します。
void | UserTerminableModel.setNameSyllabary(String nameSyllabary, Locale locale) ユーザ名カナを設定します。
String | UserTerminableModel.getNameEnglish() ユーザ名英字を取得します。
String | UserTerminableModel.getNameEnglish(Locale locale) ユーザ名英字を取得します。
void | UserTerminableModel.setNameEnglish(String nameEnglish) ユーザ名英字を設定します。
void | UserTerminableModel.setNameEnglish(String nameEnglish, Locale locale) ユーザ名英字を設定します。
String | UserTerminableModel.getAddress() 住所を取得します。
String | UserTerminableModel.getAddress(Locale locale) 住所を取得します。
void | UserTerminableModel.setAddress(String address) 住所を設定します。
void | UserTerminableModel.setAddress(String address, Locale locale) 住所を設定します。
String | UserTerminableInternationalModel.getName() ユーザ名を取得します。
void | UserTerminableInternationalModel.setName(String name) ユーザ名を設定します。
String | UserTerminableInternationalModel.getNameSyllabary() ユーザ名カナを取得します。
void | UserTerminableInternationalModel.setNameSyllabary(String nameSyllabary) ユーザ名カナを設定します。
String | UserTerminableInternationalModel.getNameEnglish() ユーザ名英字を取得します。
void | UserTerminableInternationalModel.setNameEnglish(String nameEnglish) ユーザ名英字を設定します。
String | UserTerminableInternationalModel.getAddress() 住所を取得します。
void | UserTerminableInternationalModel.setAddress(String address) 住所を設定します。
String | UserBaseModel.getUserCode() ユーザコードを取得します。
String | UserBaseModel.getAccountFlag() アカウントフラグを取得します。
void | UserBaseModel.setAccountFlag(String accountFlag) アカウントフラグを設定します。
String | UserBaseModel.getNotes() 備考を取得します。
void | UserBaseModel.setNotes(String notes) 備考を設定します。
int | UserBaseModel.getSortKey() ソートキーを取得します。
void | UserBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | UserBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | UserBaseModel.getRecordDate() 最終更新日を取得します。
String | UserBaseModel.getTelephoneNumber() 電話番号を取得します。
String | UserBaseModel.getTelephoneNumber(Date date) 電話番号を取得します。
void | UserBaseModel.setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | UserBaseModel.setTelephoneNumber(String telephoneNumber, Date date) 電話番号を設定します。
String | UserBaseModel.getMobileNumber() 携帯電話番号を取得します。
String | UserBaseModel.getMobileNumber(Date date) 携帯電話番号を取得します。
void | UserBaseModel.setMobileNumber(String mobileNumber) 携帯電話番号を設定します。
void | UserBaseModel.setMobileNumber(String mobileNumber, Date date) 携帯電話番号を設定します。
String | UserBaseModel.getFaxNumber() FAX番号を取得します。
String | UserBaseModel.getFaxNumber(Date date) FAX番号を取得します。
void | UserBaseModel.setFaxNumber(String faxNumber) FAX番号を設定します。
void | UserBaseModel.setFaxNumber(String faxNumber, Date date) FAX番号を設定します。
String | UserBaseModel.getExtensionNumber() 内線番号を取得します。
String | UserBaseModel.getExtensionNumber(Date date) 内線番号を取得します。
void | UserBaseModel.setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | UserBaseModel.setExtensionNumber(String extensionNumber, Date date) 内線番号を設定します。
String | UserBaseModel.getExtensionFaxNumber() 内線FAX番号を取得します。
String | UserBaseModel.getExtensionFaxNumber(Date date) 内線FAX番号を取得します。
void | UserBaseModel.setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | UserBaseModel.setExtensionFaxNumber(String extensionFaxNumber, Date date) 内線FAX番号を設定します。
String | UserBaseModel.getCountryCode() 国コードを取得します。
String | UserBaseModel.getCountryCode(Date date) 国コードを取得します。
void | UserBaseModel.setCountryCode(String countryCode) 国コードを設定します。
void | UserBaseModel.setCountryCode(String countryCode, Date date) 国コードを設定します。
String | UserBaseModel.getZipCode() 郵便番号を取得します。
String | UserBaseModel.getZipCode(Date date) 郵便番号を取得します。
void | UserBaseModel.setZipCode(String zipCode) 郵便番号を設定します。
void | UserBaseModel.setZipCode(String zipCode, Date date) 郵便番号を設定します。
String | UserBaseModel.getEmailAddress1() メールアドレス１を取得します。
String | UserBaseModel.getEmailAddress1(Date date) メールアドレス１を取得します。
void | UserBaseModel.setEmailAddress1(String emailAddress1) メールアドレス１を設定します。
void | UserBaseModel.setEmailAddress1(String emailAddress1, Date date) メールアドレス１を設定します。
String | UserBaseModel.getEmailAddress2() メールアドレス２を取得します。
String | UserBaseModel.getEmailAddress2(Date date) メールアドレス２を取得します。
void | UserBaseModel.setEmailAddress2(String emailAddress2) メールアドレス２を設定します。
void | UserBaseModel.setEmailAddress2(String emailAddress2, Date date) メールアドレス２を設定します。
String | UserBaseModel.getMobileEmailAddress() 携帯用メールを取得します。
String | UserBaseModel.getMobileEmailAddress(Date date) 携帯用メールを取得します。
void | UserBaseModel.setMobileEmailAddress(String mobileEmailAddress) 携帯用メールを設定します。
void | UserBaseModel.setMobileEmailAddress(String mobileEmailAddress, Date date) 携帯用メールを設定します。
String | UserBaseModel.getUrl() URLを取得します。
String | UserBaseModel.getUrl(Date date) URLを取得します。
void | UserBaseModel.setUrl(String url) URLを設定します。
void | UserBaseModel.setUrl(String url, Date date) URLを設定します。
String | UserBaseModel.getName() ユーザ名を取得します。
String | UserBaseModel.getName(Date date) ユーザ名を取得します。
String | UserBaseModel.getName(Locale locale) ユーザ名を取得します。
String | UserBaseModel.getName(Date date, Locale locale) ユーザ名を取得します。
void | UserBaseModel.setName(String name) ユーザ名を設定します。
void | UserBaseModel.setName(String name, Date date) ユーザ名を設定します。
void | UserBaseModel.setName(String name, Locale locale) ユーザ名を設定します。
void | UserBaseModel.setName(String name, Date date, Locale locale) ユーザ名を設定します。
String | UserBaseModel.getNameSyllabary() ユーザ名カナを取得します。
String | UserBaseModel.getNameSyllabary(Date date) ユーザ名カナを取得します。
String | UserBaseModel.getNameSyllabary(Locale locale) ユーザ名カナを取得します。
String | UserBaseModel.getNameSyllabary(Date date, Locale locale) ユーザ名カナを取得します。
void | UserBaseModel.setNameSyllabary(String nameSyllabary) ユーザ名カナを設定します。
void | UserBaseModel.setNameSyllabary(String nameSyllabary, Date date) ユーザ名カナを設定します。
void | UserBaseModel.setNameSyllabary(String nameSyllabary, Locale locale) ユーザ名カナを設定します。
void | UserBaseModel.setNameSyllabary(String nameSyllabary, Date date, Locale locale) ユーザ名カナを設定します。
String | UserBaseModel.getNameEnglish() ユーザ名英字を取得します。
String | UserBaseModel.getNameEnglish(Date date) ユーザ名英字を取得します。
String | UserBaseModel.getNameEnglish(Locale locale) ユーザ名英字を取得します。
String | UserBaseModel.getNameEnglish(Date date, Locale locale) ユーザ名英字を取得します。
void | UserBaseModel.setNameEnglish(String nameEnglish) ユーザ名英字を設定します。
void | UserBaseModel.setNameEnglish(String nameEnglish, Date date) ユーザ名英字を設定します。
void | UserBaseModel.setNameEnglish(String nameEnglish, Locale locale) ユーザ名英字を設定します。
void | UserBaseModel.setNameEnglish(String nameEnglish, Date date, Locale locale) ユーザ名英字を設定します。
String | UserBaseModel.getAddress() 住所を取得します。
String | UserBaseModel.getAddress(Date date) 住所を取得します。
String | UserBaseModel.getAddress(Locale locale) 住所を取得します。
String | UserBaseModel.getAddress(Date date, Locale locale) 住所を取得します。
void | UserBaseModel.setAddress(String address) 住所を設定します。
void | UserBaseModel.setAddress(String address, Date date) 住所を設定します。
void | UserBaseModel.setAddress(String address, Locale locale) 住所を設定します。
void | UserBaseModel.setAddress(String address, Date date, Locale locale) 住所を設定します。

jp.co.intra_mart.foundation.datastore.common.model での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableModel | TerminableModelMap.createTerminableModel(Term term) 指定した期間を満たす期間化モデルを生成します。
void | TerminableModelMap.remove(Term term) 指定された期間に該当するデータを削除します。
TerminableInternationalModel | TerminableInternationalModelMap.createTerminableInternationalModel(Locale locale) 期間国際化モデルを生成します。
void | TerminableInternationalModelMap.remove(Locale locale) 指定された言語に該当するデータを削除します。
InternationalModel | InternationalModelMap.createInternationalModel(Locale locale) 国際化モデルを生成します。
void | InternationalModelMap.remove(Locale locale) 指定された言語に該当するデータを削除します。
TerminableModel | GenericTerminableModelMap.createTerminableModel(Term term) 指定した期間を満たす期間化モデルを生成します。
void | GenericTerminableModelMap.remove(Term term) 指定された期間に該当するデータを削除します。
protected Object | GenericTerminableModel.get(String name) 指定の属性が保持する値を取得します。
protected Object | GenericTerminableModel.get(String name, Locale locale) 指定の属性が指定の言語で保持する値を取得します。
protected void | GenericTerminableModel.set(String name, Object value) 指定の属性に値を設定します。
protected void | GenericTerminableModel.set(String name, Object value, Locale locale) 指定の属性に値を設定します。
TerminableInternationalModel | GenericTerminableInternationalModelMap.createTerminableInternationalModel(Locale locale) 期間国際化モデルを生成します。
void | GenericTerminableInternationalModelMap.remove(Locale locale) 指定された言語に該当するデータを削除します。
protected Object | GenericTerminableInternationalModel.get(String name) 指定の属性が保持する値を取得します。
protected void | GenericTerminableInternationalModel.set(String name, Object value) 指定の属性に値を設定します。
InternationalModel | GenericInternationalModelMap.createInternationalModel(Locale locale) 国際化モデルを生成します。
void | GenericInternationalModelMap.remove(Locale locale) 指定された言語に該当するデータを削除します。
protected Object | GenericInternationalModel.get(String name) 指定の属性が保持する値を取得します。
protected void | GenericInternationalModel.set(String name, Object value) 指定の属性に値を設定します。
protected Object | GenericBaseModel.get(String name) 指定の属性が保持する値を取得します。
protected Object | GenericBaseModel.get(String name, Date date) 指定の属性が、指定の日時に保持している値を取得します。
protected Object | GenericBaseModel.get(String name, Locale locale) 指定の属性が、指定の言語で保持している値を取得します。
protected Object | GenericBaseModel.get(String name, Date date, Locale locale) 指定の属性が、指定の日時、言語で保持している値を取得します。
protected void | GenericBaseModel.set(String name, Object value) 指定の属性に値を設定します。
protected void | GenericBaseModel.set(String name, Object value, Date date) 指定の属性に、指定の日時で値を設定します。
protected void | GenericBaseModel.set(String name, Object value, Locale locale) 指定の属性に、指定の言語で値を設定します。
protected void | GenericBaseModel.set(String name, Object value, Date date, Locale locale) 指定の属性に、指定の日時、言語で値を設定します。
ExtendedTerminableModel | ExtendedTerminableModelMap.createExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
ExtendedTerminableModel | ExtendedTerminableModelMap.findExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
void | ExtendedTerminableModelMap.remove(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。
ExtendedTerminableInternationalModel | ExtendedTerminableInternationalModelMap.createExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
ExtendedTerminableInternationalModel | ExtendedTerminableInternationalModelMap.findExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
void | ExtendedTerminableInternationalModelMap.remove(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。
ExtendedInternationalModel | ExtendedInternationalModelMap.createExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
ExtendedInternationalModel | ExtendedInternationalModelMap.findExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
void | ExtendedInternationalModelMap.remove(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。
ExtendedTerminableModel | ExtendedGenericTerminableModelMap.createExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
ExtendedTerminableModel | ExtendedGenericTerminableModelMap.findExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
void | ExtendedGenericTerminableModelMap.remove(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。
protected Object | ExtendedGenericTerminableModel.get(String name) 指定の属性が保持する値を取得します。
protected void | ExtendedGenericTerminableModel.set(String name, Object value) 指定の属性に値を設定します。
ExtendedTerminableInternationalModel | ExtendedGenericTerminableInternationalModelMap.createExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
ExtendedTerminableInternationalModel | ExtendedGenericTerminableInternationalModelMap.findExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
void | ExtendedGenericTerminableInternationalModelMap.remove(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。
protected Object | ExtendedGenericTerminableInternationalModel.get(String name) 指定の属性が保持する値を取得します。
protected void | ExtendedGenericTerminableInternationalModel.set(String name, Object value) 指定の属性に値を設定します。
ExtendedInternationalModel | ExtendedGenericInternationalModelMap.createExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
ExtendedInternationalModel | ExtendedGenericInternationalModelMap.findExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
void | ExtendedGenericInternationalModelMap.remove(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。
protected Object | ExtendedGenericInternationalModel.get(String name) 指定の属性が保持する値を取得します。
protected void | ExtendedGenericInternationalModel.set(String name, Object value) 指定の属性に値を設定します。
ExtendedBaseModel | ExtendedGenericBaseModelMap.createExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
ExtendedBaseModel | ExtendedGenericBaseModelMap.findExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。
void | ExtendedGenericBaseModelMap.remove(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。
protected Object | ExtendedGenericBaseModel.get(String name) 指定の属性が保持する値を取得します。
protected void | ExtendedGenericBaseModel.set(String name, Object value) 指定の属性に値を設定します。
ExtendedBaseModel | ExtendedBaseModelMap.createExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
ExtendedBaseModel | ExtendedBaseModelMap.findExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。
void | ExtendedBaseModelMap.remove(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。

jp.co.intra_mart.foundation.datastore.exception での AccessorException の使用

jp.co.intra_mart.foundation.datastore.exception での AccessorException のサブクラス
class | AccessorClosedException アクセサのクローズ時に発生する例外クラス アクセサがクローズされている場合に、以下のメソッドを呼び出された時にスローする。
class | AccessorIllegalPropertyValueException アクセサのプロパティ設定に関する例外クラス アクセサに不正な値が設定された場合にスローする。
class | DataNotFoundException アクセサのプロパティ値の取得に関する例外クラス 指定されたプロパティに対する値が設定されていない場合にスローする。
class | IllegalExtensionException 拡張アクセサに関する例外クラス 拡張アクセサに対して不正な操作が行われた場合にスローする。
class | IllegalLocaleException アクセサが保持する言語に関する例外クラス アクセサが保持していない言語を要求された場合にスローする。
class | IllegalTermException アクセサが保持する期間に関する例外クラス アクセサが保持しない日時または期間が指定されたときにスローする。

jp.co.intra_mart.system.security.datastore.inf での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.system.security.datastore.inf のメソッド
String | RoleSummaryBaseModel.getRoleId() ロールIDを取得します。
String | RoleSummaryBaseModel.getSummaryRoleId() サマリロールIDを取得します。
String | RoleSummaryBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | RoleSummaryBaseModel.getRecordDate() 最終更新日を取得します。
String | RoleInternationalModel.getDisplayName() ロール表示名を取得します。
void | RoleInternationalModel.setDisplayName(String displayName) ロール表示名を設定します。
String | RoleInclusionBaseModel.getParentRoleId() 親ロールコードを取得します。
String | RoleInclusionBaseModel.getChildRoleId() 子ロールコードを取得します。
String | RoleInclusionBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | RoleInclusionBaseModel.getRecordDate() 最終更新日を取得します。
String | RoleBaseModel.getRoleId() ロールIDを取得します。
String | RoleBaseModel.getName() ロール名を取得します。
void | RoleBaseModel.setName(String name) ロール名を設定します。
String | RoleBaseModel.getCategory() カテゴリを取得します。
void | RoleBaseModel.setCategory(String category) カテゴリを設定します。
String | RoleBaseModel.getNotes() 備考を取得します。
void | RoleBaseModel.setNotes(String notes) 備考を設定します。
String | RoleBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | RoleBaseModel.getRecordDate() 最終更新日を取得します。
String | RoleBaseModel.getDisplayName() ロール表示名を取得します。
String | RoleBaseModel.getDisplayName(Locale locale) ロール表示名を取得します。
void | RoleBaseModel.setDisplayName(String displayName) ロール表示名を設定します。
void | RoleBaseModel.setDisplayName(String displayName, Locale locale) ロール表示名を設定します。
String | MenuRoleBaseModel.getMenuId() メニューIDを取得します。
String | MenuRoleBaseModel.getRoleId() ロールCDを取得します。
String | MenuRoleBaseModel.getRecordUserCode() 最終更新者を取得します。
String | MenuRoleBaseModel.getRecordDate() 最終更新日を取得します。
String | MenuPublicGroupBaseModel.getMenuId() メニューIDを取得します。
String | MenuPublicGroupBaseModel.getPublicGroupSetCd() グループセットCDを取得します。
String | MenuPublicGroupBaseModel.getPublicGroupCd() グルーピングCDを取得します。
String | MenuPublicGroupBaseModel.getRecordUserCode() 最終更新者を取得します。
String | MenuPublicGroupBaseModel.getRecordDate() 最終更新日を取得します。
String | MenuPostBaseModel.getMenuId() メニューIDを取得します。
String | MenuPostBaseModel.getCompanyCd() 会社CDを取得します。
String | MenuPostBaseModel.getPostCd() 役職CDを取得します。
String | MenuPostBaseModel.getRecordUserCode() 最終更新者を取得します。
String | MenuPostBaseModel.getRecordDate() 最終更新日を取得します。
String | MenuInternationalModel.getDisplayName() メニュー表示名を取得します。
void | MenuInternationalModel.setDisplayName(String displayName) メニュー表示名を設定します。
String | MenuDepartmentBaseModel.getMenuId() メニューIDを取得します。
String | MenuDepartmentBaseModel.getCompanyCd() 会社CDを取得します。
String | MenuDepartmentBaseModel.getDepartmentCd() 組織CDを取得します。
String | MenuDepartmentBaseModel.getRecordUserCode() 最終更新者を取得します。
String | MenuDepartmentBaseModel.getRecordDate() 最終更新日を取得します。
String | MenuBaseModel.getMenuId() メニューIDを取得します。
String | MenuBaseModel.getMenuType() メニュータイプを取得します。
void | MenuBaseModel.setMenuType(String menuType) メニュータイプを設定します。
String | MenuBaseModel.getNotes() 説明を取得します。
void | MenuBaseModel.setNotes(String notes) 説明を設定します。
int | MenuBaseModel.getSortNumber() ソート番号を取得します。
void | MenuBaseModel.setSortNumber(int sortNumber) ソート番号を設定します。
String | MenuBaseModel.getClientType() クライアントタイプを取得します。
void | MenuBaseModel.setClientType(String clientType) クライアントタイプを設定します。
String | MenuBaseModel.getContents() コンテンツの種類を取得します。
void | MenuBaseModel.setContents(String contents) コンテンツの種類を設定します。
String | MenuBaseModel.getUrl() URLを取得します。
void | MenuBaseModel.setUrl(String url) URLを設定します。
String | MenuBaseModel.getParentMenuId() 親メニューIDを取得します。
void | MenuBaseModel.setParentMenuId(String parentMenuId) 親メニューIDを設定します。
String | MenuBaseModel.getImagePath() イメージパスを取得します。
void | MenuBaseModel.setImagePath(String imagePath) イメージパスを設定します。
String | MenuBaseModel.getRecordUserCode() 最終更新者を取得します。
String | MenuBaseModel.getRecordDate() 最終更新日を取得します。
String | MenuBaseModel.getDisplayName() メニュー表示名を取得します。
String | MenuBaseModel.getDisplayName(Locale locale) メニュー表示名を取得します。
void | MenuBaseModel.setDisplayName(String displayName) メニュー表示名を設定します。
void | MenuBaseModel.setDisplayName(String displayName, Locale locale) メニュー表示名を設定します。
String | MenuArgumentBaseModel.getMenuId() メニューIDを取得します。
String | MenuArgumentBaseModel.getArgumentName() 引数名を取得します。
String | MenuArgumentBaseModel.getArgumentValue() 引数値を取得します。
void | MenuArgumentBaseModel.setArgumentValue(String argumentValue) 引数値を設定します。
String | MenuArgumentBaseModel.getRecordUserCode() 最終更新者を取得します。
String | MenuArgumentBaseModel.getRecordDate() 最終更新日を取得します。
String | FavoriteMenuBaseModel.getUserId() ユーザIDを取得します。
String | FavoriteMenuBaseModel.getMenuId() メニューIDを取得します。
String | FavoriteMenuBaseModel.getDisplayName() メニュー表示名を取得します。
void | FavoriteMenuBaseModel.setDisplayName(String displayName) メニュー表示名を設定します。
String | FavoriteMenuBaseModel.getImagePath() イメージパスを取得します。
void | FavoriteMenuBaseModel.setImagePath(String imagePath) イメージパスを設定します。
int | FavoriteMenuBaseModel.getSortNumber() ソート番号を取得します。
void | FavoriteMenuBaseModel.setSortNumber(int sortNumber) ソート番号を設定します。
String | FavoriteMenuBaseModel.getRecordUserCode() 最終更新者を取得します。
String | FavoriteMenuBaseModel.getRecordDate() 最終更新日を取得します。
String | CalendarInfoInternationalModel.getDisplayName() データ表示名を取得します。
void | CalendarInfoInternationalModel.setDisplayName(String displayName) データ表示名を設定します。
String | CalendarInfoBaseModel.getCalendarId() カレンダーIDを取得します。
String | CalendarInfoBaseModel.getDataId() データIDを取得します。
String | CalendarInfoBaseModel.getDataType() データタイプを取得します。
void | CalendarInfoBaseModel.setDataType(String dataType) データタイプを設定します。
String | CalendarInfoBaseModel.getDataName() データ名称を取得します。
void | CalendarInfoBaseModel.setDataName(String dataName) データ名称を設定します。
int | CalendarInfoBaseModel.getYear() 年を取得します。
void | CalendarInfoBaseModel.setYear(int year) 年を設定します。
int | CalendarInfoBaseModel.getMonth() 月を取得します。
void | CalendarInfoBaseModel.setMonth(int month) 月を設定します。
int | CalendarInfoBaseModel.getDay() 日を取得します。
void | CalendarInfoBaseModel.setDay(int day) 日を設定します。
int | CalendarInfoBaseModel.getWeek() 週を取得します。
void | CalendarInfoBaseModel.setWeek(int week) 週を設定します。
int | CalendarInfoBaseModel.getTimes() 次を取得します。
void | CalendarInfoBaseModel.setTimes(int times) 次を設定します。
int | CalendarInfoBaseModel.getDayWeek() 曜日を取得します。
void | CalendarInfoBaseModel.setDayWeek(int dayWeek) 曜日を設定します。
int | CalendarInfoBaseModel.getValidStartYear() 有効開始年を取得します。
void | CalendarInfoBaseModel.setValidStartYear(int validStartYear) 有効開始年を設定します。
int | CalendarInfoBaseModel.getValidEndYear() 有効終了年を取得します。
void | CalendarInfoBaseModel.setValidEndYear(int validEndYear) 有効終了年を設定します。
String | CalendarInfoBaseModel.getPluginMethod() プラグイン関数を取得します。
void | CalendarInfoBaseModel.setPluginMethod(String pluginMethod) プラグイン関数を設定します。
String | CalendarInfoBaseModel.getColor() 表示色を取得します。
void | CalendarInfoBaseModel.setColor(String color) 表示色を設定します。
String | CalendarInfoBaseModel.getRecordUserCode() 最終更新者を取得します。
String | CalendarInfoBaseModel.getRecordDate() 最終更新日を取得します。
String | CalendarInfoBaseModel.getDisplayName() データ表示名を取得します。
String | CalendarInfoBaseModel.getDisplayName(Locale locale) データ表示名を取得します。
void | CalendarInfoBaseModel.setDisplayName(String displayName) データ表示名を設定します。
void | CalendarInfoBaseModel.setDisplayName(String displayName, Locale locale) データ表示名を設定します。
String | BatchBaseModel.getBatchId() バッチIDを取得します。
String | BatchBaseModel.getBatchName() バッチ名を取得します。
void | BatchBaseModel.setBatchName(String batchName) バッチ名を設定します。
String | BatchBaseModel.getProgramLanguage() 実行プログラム言語を取得します。
void | BatchBaseModel.setProgramLanguage(String programLanguage) 実行プログラム言語を設定します。
String | BatchBaseModel.getProgramPath() 実行プログラムパスを取得します。
void | BatchBaseModel.setProgramPath(String programPath) 実行プログラムパスを設定します。
int | BatchBaseModel.getRunYear() 実行年を取得します。
void | BatchBaseModel.setRunYear(int runYear) 実行年を設定します。
int | BatchBaseModel.getRunMonth() 実行月を取得します。
void | BatchBaseModel.setRunMonth(int runMonth) 実行月を設定します。
int | BatchBaseModel.getRunDay() 実行日を取得します。
void | BatchBaseModel.setRunDay(int runDay) 実行日を設定します。
int | BatchBaseModel.getRunDayWeek() 実行曜日を取得します。
void | BatchBaseModel.setRunDayWeek(int runDayWeek) 実行曜日を設定します。
int | BatchBaseModel.getRunHour() 実行時を取得します。
void | BatchBaseModel.setRunHour(int runHour) 実行時を設定します。
int | BatchBaseModel.getRunMinute() 実行分を取得します。
void | BatchBaseModel.setRunMinute(int runMinute) 実行分を設定します。
int | BatchBaseModel.getRunSecond() 実行秒を取得します。
void | BatchBaseModel.setRunSecond(int runSecond) 実行秒を設定します。
String | BatchBaseModel.getValidFlg() 有効フラグを取得します。
void | BatchBaseModel.setValidFlg(String validFlg) 有効フラグを設定します。
String | BatchBaseModel.getRecordUserCode() 最終更新者を取得します。
String | BatchBaseModel.getRecordDate() 最終更新日を取得します。
String | AccountRoleBaseModel.getUserId() ユーザIDを取得します。
String | AccountRoleBaseModel.getRoleId() メニューIDを取得します。
String | AccountRoleBaseModel.getValidStartDate() 有効開始日を取得します。
void | AccountRoleBaseModel.setValidStartDate(String validStartDate) 有効開始日を設定します。
String | AccountRoleBaseModel.getValidEndDate() 有効終了日を取得します。
void | AccountRoleBaseModel.setValidEndDate(String validEndDate) 有効終了日を設定します。
String | AccountRoleBaseModel.getRecordUserCode() 最終更新者を取得します。
String | AccountRoleBaseModel.getRecordDate() 最終更新日を取得します。
String | AccountBaseModel.getUserId() ユーザIDを取得します。
String | AccountBaseModel.getLocale() ロケールを取得します。
void | AccountBaseModel.setLocale(String locale) ロケールを設定します。
String | AccountBaseModel.getEncoding() エンコーディングを取得します。
void | AccountBaseModel.setEncoding(String encoding) エンコーディングを設定します。
String | AccountBaseModel.getPassword() パスワードを取得します。
void | AccountBaseModel.setPassword(String password) パスワードを設定します。
String | AccountBaseModel.getMobilePassword() モバイル用パスワードを取得します。
void | AccountBaseModel.setMobilePassword(String mobilePassword) モバイル用パスワードを設定します。
String | AccountBaseModel.getNotes() 説明を取得します。
void | AccountBaseModel.setNotes(String notes) 説明を設定します。
String | AccountBaseModel.getValidStartDate() 有効開始日を取得します。
void | AccountBaseModel.setValidStartDate(String validStartDate) 有効開始日を設定します。
String | AccountBaseModel.getValidEndDate() 有効終了日を取得します。
void | AccountBaseModel.setValidEndDate(String validEndDate) 有効終了日を設定します。
String | AccountBaseModel.getGoOut() 外出フラグを取得します。
void | AccountBaseModel.setGoOut(String goOut) 外出フラグを設定します。
String | AccountBaseModel.getLockDate() アカウントロック日付を取得します。
void | AccountBaseModel.setLockDate(String lockDate) アカウントロック日付を設定します。
int | AccountBaseModel.getLoginFailureCount() ログイン失敗回数を取得します。
void | AccountBaseModel.setLoginFailureCount(int loginFailureCount) ログイン失敗回数を設定します。
String | AccountBaseModel.getPagePatternId() メインページパターンを取得します。
void | AccountBaseModel.setPagePatternId(String pagePatternId) メインページパターンを設定します。
String | AccountBaseModel.getColorPatternId() ページカラーパターンを取得します。
void | AccountBaseModel.setColorPatternId(String colorPatternId) ページカラーパターンを設定します。
String | AccountBaseModel.getRecordUserCode() 最終更新者を取得します。
String | AccountBaseModel.getRecordDate() 最終更新日を取得します。
String | AccountAttributeBaseModel.getUserId() ユーザIDを取得します。
String | AccountAttributeBaseModel.getAttributeName() 属性キーを取得します。
String | AccountAttributeBaseModel.getAttributeValue() 属性値を取得します。
void | AccountAttributeBaseModel.setAttributeValue(String attributeValue) 属性値を設定します。
String | AccountAttributeBaseModel.getRecordUserCode() 最終更新者を取得します。
String | AccountAttributeBaseModel.getRecordDate() 最終更新日を取得します。
String | AccessControllerRoleBaseModel.getAccessControllerId() アクセスコントローラIDを取得します。
String | AccessControllerRoleBaseModel.getRoleId() ロールCDを取得します。
String | AccessControllerRoleBaseModel.getRecordUserCode() 最終更新者を取得します。
String | AccessControllerRoleBaseModel.getRecordDate() 最終更新日を取得します。
String | AccessControllerPublicGroupBaseModel.getAccessControllerId() アクセスコントローラIDを取得します。
String | AccessControllerPublicGroupBaseModel.getPublicGroupSetCd() グループセットCDを取得します。
String | AccessControllerPublicGroupBaseModel.getPublicGroupCd() グルーピングCDを取得します。
String | AccessControllerPublicGroupBaseModel.getRecordUserCode() 最終更新者を取得します。
String | AccessControllerPublicGroupBaseModel.getRecordDate() 最終更新日を取得します。
String | AccessControllerPostBaseModel.getAccessControllerId() アクセスコントローラIDを取得します。
String | AccessControllerPostBaseModel.getCompanyCd() 会社CDを取得します。
String | AccessControllerPostBaseModel.getPostCd() 役職CDを取得します。
String | AccessControllerPostBaseModel.getRecordUserCode() 最終更新者を取得します。
String | AccessControllerPostBaseModel.getRecordDate() 最終更新日を取得します。
String | AccessControllerDepartmentBaseModel.getAccessControllerId() アクセスコントローラIDを取得します。
String | AccessControllerDepartmentBaseModel.getCompanyCd() 会社CDを取得します。
String | AccessControllerDepartmentBaseModel.getDepartmentCd() 組織CDを取得します。
String | AccessControllerDepartmentBaseModel.getRecordUserCode() 最終更新者を取得します。
String | AccessControllerDepartmentBaseModel.getRecordDate() 最終更新日を取得します。
String | AccessControllerBaseModel.getAccessControllerId() アクセスコントローラIDを取得します。
String | AccessControllerBaseModel.getAccessControllerName() アクセスコントローラ名を取得します。
void | AccessControllerBaseModel.setAccessControllerName(String accessControllerName) アクセスコントローラ名を設定します。
String | AccessControllerBaseModel.getNotes() 説明を取得します。
void | AccessControllerBaseModel.setNotes(String notes) 説明を設定します。
String | AccessControllerBaseModel.getRecordUserCode() 最終更新者を取得します。
String | AccessControllerBaseModel.getRecordDate() 最終更新日を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException の使用

AccessorIllegalPropertyValueException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor 情報を扱うためのアクセサを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での AccessorIllegalPropertyValueException の使用

AccessorIllegalPropertyValueException をスローする jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
void | TerminableInternationalAccessor.setProperty(String prop, Object value) プロパティを設定します。
void | TerminableAccessor.setProperty(String prop, Object value) プロパティを設定します。
void | InternationalAccessor.setProperty(String prop, Object value) プロパティを設定します。
void | ExtendedTerminableInternationalAccessor.setProperty(String prop, Object value) プロパティを設定します。
void | ExtendedTerminableAccessor.setProperty(String prop, Object value) プロパティを設定します。
void | ExtendedInternationalAccessor.setProperty(String prop, Object value) プロパティを設定します。
void | ExtendedBaseAccessor.setProperty(String prop, Object value) プロパティを設定します。
void | BaseAccessor.setProperty(String prop, Object value) プロパティを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException の使用

jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.BatchProcessException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.BatchProcessException の使用

BatchProcessException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exporter | アプリケーション共通マスタのエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.common.config | エクスポート設定の解釈を行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer | アプリケーション共通マスタのインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.common.config | インポート定義情報の解釈を行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.exporter での BatchProcessException の使用

jp.co.intra_mart.foundation.datastore.exporter での BatchProcessException のサブクラス
 class ExportInitializeException
エクスポートの初期化でエラーが発生したことを示すためにスローされます。

jp.co.intra_mart.foundation.datastore.exporter.common.config での BatchProcessException の使用

jp.co.intra_mart.foundation.datastore.exporter.common.config での BatchProcessException のサブクラス
 class ExportConfigurationReaderException
エクスポート設定の読み込みでエラーが発生したことを示すためにスローされます。

jp.co.intra_mart.foundation.datastore.importer での BatchProcessException の使用

jp.co.intra_mart.foundation.datastore.importer での BatchProcessException のサブクラス
 class ImportInitializeException
インポートの初期化で何らかのエラーが発生したことを示すためにスローされます。

jp.co.intra_mart.foundation.datastore.importer.common.config での BatchProcessException の使用

jp.co.intra_mart.foundation.datastore.importer.common.config での BatchProcessException のサブクラス
 class ImportConfigurationReaderException
インポート設定の読み込みでエラーが発生したことを示すためにスローされます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.BatchSystemException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.BatchSystemException の使用

jp.co.intra_mart.foundation.datastore.exception.BatchSystemException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException の使用

DataNotFoundException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での DataNotFoundException の使用

DataNotFoundException をスローする jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
Object | TerminableInternationalAccessor.getProperty(String prop) プロパティを取得します。
Object | TerminableAccessor.getProperty(String prop) プロパティを取得します。
Object | InternationalAccessor.getProperty(String prop) プロパティを取得します。
Object | ExtendedTerminableInternationalAccessor.getProperty(String prop) プロパティを取得します。
Object | ExtendedTerminableAccessor.getProperty(String prop) プロパティを取得します。
Object | ExtendedInternationalAccessor.getProperty(String prop) プロパティを取得します。
Object | ExtendedBaseAccessor.getProperty(String prop) プロパティを取得します。
Object | BaseAccessor.getProperty(String prop) プロパティを取得します。

jp.co.intra_mart.foundation.datastore.exception での DataNotFoundException の使用

jp.co.intra_mart.foundation.datastore.exception での DataNotFoundException のサブクラス
class | IllegalLocaleException アクセサが保持する言語に関する例外クラス アクセサが保持していない言語を要求された場合にスローする。
class | IllegalTermException アクセサが保持する期間に関する例外クラス アクセサが保持しない日時または期間が指定されたときにスローする。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException の使用

DataStoreApplicationException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。
jp.co.intra_mart.foundation.navigator |

jp.co.intra_mart.foundation.datastore.exception での DataStoreApplicationException の使用

jp.co.intra_mart.foundation.datastore.exception での DataStoreApplicationException のサブクラス
class | AccessorClosedException アクセサのクローズ時に発生する例外クラス アクセサがクローズされている場合に、以下のメソッドを呼び出された時にスローする。
class | AccessorException アクセサで発生する例外の基底クラス
class | AccessorIllegalPropertyValueException アクセサのプロパティ設定に関する例外クラス アクセサに不正な値が設定された場合にスローする。
class | DataNotFoundException アクセサのプロパティ値の取得に関する例外クラス 指定されたプロパティに対する値が設定されていない場合にスローする。
class | IllegalExtensionException 拡張アクセサに関する例外クラス 拡張アクセサに対して不正な操作が行われた場合にスローする。
class | IllegalLocaleException アクセサが保持する言語に関する例外クラス アクセサが保持していない言語を要求された場合にスローする。
class | IllegalRelationshipException リレーションシップに関する例外クラス リレーションシップの整合性が正しくない場合にスローする。
class | IllegalTermException アクセサが保持する期間に関する例外クラス アクセサが保持しない日時または期間が指定されたときにスローする。
class | ManagerException マネージャに関する例外クラス
class | MapperException マッパーに関する例外クラス マッパーの処理中に問題が発生した場合にスローする。
class | TermManagerException 期間に関する例外クラス

jp.co.intra_mart.foundation.navigator での DataStoreApplicationException の使用

jp.co.intra_mart.foundation.navigator での DataStoreApplicationException のサブクラス
 class EventNavigatorException
イベントナビゲータマネージャに関する例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException の使用

jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException の使用

DataStoreSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。

jp.co.intra_mart.foundation.datastore.common.model での DataStoreSystemException の使用

DataStoreSystemException をスローする jp.co.intra_mart.foundation.datastore.common.model のメソッド
 TerminableModel GenericTerminableModelMap.newTerminableModel(Term term)
初期化されていない期間化モデルのインスタンスを取得します。

jp.co.intra_mart.foundation.datastore.exception での DataStoreSystemException の使用

jp.co.intra_mart.foundation.datastore.exception での DataStoreSystemException のサブクラス
class | AccessorSystemException アクセサのプロパティに関する例外クラス 指定されたプロパティがアクセサに存在しない場合にスローする。
class | DataStoreConfigException アプリケーション共通マスタの設定に関する例外クラス アプリケーション共通マスタの設定に不整合がある場合にスローする。
class | MapperDAOException マッパーのデータベース接続に関する例外クラス マッパーがデータベース接続で問題が発生した場合にスローする。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException の使用

IllegalExtensionException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での IllegalExtensionException の使用

IllegalExtensionException をスローする jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
ExtendedTerminableInternationalAccessor | ExtendedTerminableInternationalAccessorMap.createExtendedTerminableInternationalAccessor(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を生成します。
ExtendedTerminableInternationalAccessor | ExtendedTerminableInternationalAccessorMap.findExtendedTerminableInternationalAccessor(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を取得します。
ExtendedTerminableAccessor | ExtendedTerminableAccessorMap.createExtendedTerminableAccessor(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を生成します。
ExtendedTerminableAccessor | ExtendedTerminableAccessorMap.findExtendedTerminableAccessor(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を取得します。
ExtendedInternationalAccessor | ExtendedInternationalAccessorMap.createExtendedInternationalAccessor(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を生成します。
ExtendedInternationalAccessor | ExtendedInternationalAccessorMap.findExtendedInternationalAccessor(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を取得します。
ExtendedBaseAccessor | ExtendedBaseAccessorMap.createExtendedBaseAccessor(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を生成します。
ExtendedBaseAccessor | ExtendedBaseAccessorMap.findExtendedBaseAccessor(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を取得します。

jp.co.intra_mart.foundation.datastore.common.model での IllegalExtensionException の使用

IllegalExtensionException をスローする jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedTerminableModel | ExtendedGenericTerminableModelMap.newExtendedTerminableModel(String name) 初期化されてていない拡張期間化モデルのインスタンスを取得します。
ExtendedTerminableInternationalModel | ExtendedGenericTerminableInternationalModelMap.newExtendedTerminableInternationalModel(String name) 初期化されていない拡張期間国際化モデルのインスタンスを取得します。
ExtendedBaseModel | ExtendedGenericBaseModelMap.newExtendedBaseModel(String name) 初期化されていない拡張基本モデルのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException の使用

IllegalLocaleException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.category | 商品カテゴリ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail | 商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.attribute | 商品属性情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.item | 商品情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.system.security.datastore.inf |

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.category.category_class のメソッド
 CateogryClassInternationalModel CateogryClassBaseModel.selectCateogryClassInternationalModel(Locale locale)
指定された言語に該当する分類区分の国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.category.detail での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.category.detail のメソッド
 CategoryDetailInternationalModel CategoryDetailBaseModel.selectCategoryDetailInternationalModel(Locale locale)
指定された言語に該当する分類区分詳細の国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.company.department での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.department のメソッド
 DepartmentTerminableInternationalModel DepartmentTerminableModel.selectDepartmentTerminableInternationalModel(Locale locale)
指定された言語に該当する組織の期間国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.company.post での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.post のメソッド
 CompanyPostTerminableInternationalModel CompanyPostTerminableModel.selectCompanyPostTerminableInternationalModel(Locale locale)
指定された言語に該当する役職の期間国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.category での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.item_category.category のメソッド
 ItemCategoryInternationalModel ItemCategoryBaseModel.selectItemCategoryInternationalModel(Locale locale)
指定された言語に該当する商品カテゴリの国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.item_template.detail のメソッド
 ItemTemplateDetailInternationalModel ItemTemplateDetailBaseModel.selectItemTemplateDetailInternationalModel(Locale locale)
指定された言語に該当する商品属性テンプレート明細の国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.item.attribute での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.item.attribute のメソッド
 ItemAttributeInternationalModel ItemAttributeBaseModel.selectItemAttributeInternationalModel(Locale locale)
指定された言語に該当する商品属性の国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.item.item での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.item.item のメソッド
 ItemTerminableInternationalModel ItemTerminableModel.selectItemTerminableInternationalModel(Locale locale)
指定された言語に該当する商品の期間国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.group のメソッド
 PublicGroupTerminableInternationalModel PublicGroupTerminableModel.selectPublicGroupTerminableInternationalModel(Locale locale)
指定された言語に該当するパブリックグループの期間国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.user での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.user のメソッド
 UserTerminableInternationalModel UserTerminableModel.selectUserTerminableInternationalModel(Locale locale)
指定された言語に該当するユーザの期間国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.common.accessor での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
TerminableInternationalAccessor | TerminableInternationalAccessorMap.createTerminableInternationalAccessor(Locale locale) 期間国際化アクセサを生成します。
TerminableInternationalAccessor | TerminableInternationalAccessorMap.findTerminableInternationalAccessor(Locale locale) 指定された言語に該当する期間国際化アクセサを取得します。
void | TerminableInternationalAccessorMap.remove(Locale locale) 指定された言語に該当するデータを削除します。
InternationalAccessor | InternationalAccessorMap.createInternationalAccessor(Locale locale) 国際化アクセサを生成します。
InternationalAccessor | InternationalAccessorMap.findInternationalAccessor(Locale locale) 指定された言語に該当する国際化アクセサを取得します。
void | InternationalAccessorMap.remove(Locale locale) 指定された言語に該当するデータを削除します。

jp.co.intra_mart.foundation.datastore.common.model での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableInternationalModel | TerminableInternationalModelMap.findTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
InternationalModel | InternationalModelMap.findInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。
protected TerminableInternationalModel | GenericTerminableModel.selectTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
TerminableInternationalModel | GenericTerminableInternationalModelMap.findTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
TerminableInternationalModel | GenericTerminableInternationalModelMap.newTerminableInternationalModel(Locale locale) 初期化されていない期間国際化モデルのインスタンスを取得します。
InternationalModel | GenericInternationalModelMap.findInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。
InternationalModel | GenericInternationalModelMap.newInternationalModel(Locale locale) 初期化されていない国際化モデルのインスタンスを取得します。
protected InternationalModel | GenericBaseModel.selectInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。

jp.co.intra_mart.system.security.datastore.inf での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.system.security.datastore.inf のメソッド
RoleInternationalModel | RoleBaseModel.selectRoleInternationalModel(Locale locale) 指定された言語に該当するロールの国際化モデルを取得します。
MenuInternationalModel | MenuBaseModel.selectMenuInternationalModel(Locale locale) 指定された言語に該当するメニュー情報の国際化モデルを取得します。
CalendarInfoInternationalModel | CalendarInfoBaseModel.selectCalendarInfoInternationalModel(Locale locale) 指定された言語に該当するカレンダーが保有するデータの国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException の使用

jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.IllegalTermException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.IllegalTermException の使用

IllegalTermException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.deal | 取扱情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.detail | 取扱詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.item | 商品情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.attach での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.attach のメソッド
 DepartmentAttachTerminableModel DepartmentAttachBaseModel.selectDepartmentAttachTerminableModel(Date date)
指定された日付に該当する組織所属の期間化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.company.department での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.department のメソッド
 DepartmentTerminableModel DepartmentBaseModel.selectDepartmentTerminableModel(Date date)
指定された日付に該当する組織の期間化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.company.main での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.main のメソッド
 DepartmentMainTerminableModel DepartmentMainBaseModel.selectDepartmentMainTerminableModel(Date date)
指定された日付に該当する主所属の期間化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.company.post での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.post のメソッド
 CompanyPostTerminableModel CompanyPostBaseModel.selectCompanyPostTerminableModel(Date date)
指定された日付に該当する役職の期間化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.deal.deal での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.application.model.deal.deal のメソッド
 DealTerminableModel DealBaseModel.selectDealTerminableModel(Date date)
指定された日付に該当する取扱の期間化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.deal.detail での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.application.model.deal.detail のメソッド
 DealDetailTerminableModel DealDetailBaseModel.selectDealDetailTerminableModel(Date date)
指定された日付に該当する取扱詳細の期間化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.item.item での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.application.model.item.item のメソッド
 ItemTerminableModel ItemBaseModel.selectItemTerminableModel(Date date)
指定された日付に該当する商品の期間化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.group のメソッド
 PublicGroupTerminableModel PublicGroupBaseModel.selectPublicGroupTerminableModel(Date date)
指定された日付に該当するパブリックグループの期間化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.user での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.application.model.user のメソッド
 UserTerminableModel UserBaseModel.selectUserTerminableModel(Date date)
指定された日付に該当するユーザの期間化モデルを取得します。

jp.co.intra_mart.foundation.datastore.common.accessor での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 TerminableAccessor TerminableAccessorMap.createTerminableAccessor(Term term)
指定した期間に期間化アクセサを生成します。

jp.co.intra_mart.foundation.datastore.common.model での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableModel | TerminableModelMap.findTerminableModel(Date date) 指定された日付に該当する期間化モデルを取得します。
TerminableModel | GenericTerminableModelMap.findTerminableModel(Date date) 指定された日時に該当する期間化モデルを取得します。
protected TerminableModel | GenericBaseModel.selectTerminableModel(Date date) 指定された日時に該当する期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.ImportException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.ImportException の使用

ImportException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item | 商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category | 商品カテゴリ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_template | 商品テンプレート属性情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での ImportException の使用

ImportException をスローする jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
void | StandardCompanyPostImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。
void | StandardCompanyImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。
void | CompanyPostImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。
void | CompanyImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。

jp.co.intra_mart.foundation.datastore.application.domain.item での ImportException の使用

ImportException をスローする jp.co.intra_mart.foundation.datastore.application.domain.item のメソッド
void | StandardItemImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。
void | ItemImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。

jp.co.intra_mart.foundation.datastore.application.domain.item_category での ImportException の使用

ImportException をスローする jp.co.intra_mart.foundation.datastore.application.domain.item_category のメソッド
void | StandardItemCategoryImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。
void | StandardItemAttachImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。
void | ItemCategoryImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。
void | ItemAttachImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。

jp.co.intra_mart.foundation.datastore.application.domain.item_template での ImportException の使用

ImportException をスローする jp.co.intra_mart.foundation.datastore.application.domain.item_template のメソッド
void | StandardItemTemplateImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。
void | ItemTemplateImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での ImportException の使用

ImportException をスローする jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
void | StandardPublicGroupImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。
void | PublicGroupImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。

jp.co.intra_mart.foundation.datastore.application.domain.user での ImportException の使用

ImportException をスローする jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
void | UserImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。
void | StandardUserImporter.doImport(InputStream inputStream, String user, String group) インポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.ManagerException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.ManagerException の使用

ManagerException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category | 分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.currency | 通貨情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item | 商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category | 商品カテゴリ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_template | 商品テンプレート属性情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group | プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.unit | 商品単位情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.category での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.category のメソッド
static CategoryManager | CategoryManager.getCategoryManager(String user, String group) CategoryManagerを取得します。
protected abstract void | CategoryManager.init(String user, String group) CategoryManagerを初期化します。
abstract void | CategoryManager.addCategoryDetail(CategoryDetail categoryDetail) 分類区分詳細を登録します。
abstract void | CategoryManager.updateCategoryDetail(CategoryDetail categoryDetail) 登録済の分類区分詳細を更新します。
abstract void | CategoryManager.deleteCategoryDetail(CategoryDetail categoryDetail) 登録済の分類区分詳細を削除します。
abstract CategoryDetail[] | CategoryManager.getCategoryDetails() 登録済みの分類区分詳細情報の一覧を取得します。
abstract CategoryDetail[] | CategoryManager.getCategoryDetails(String categoryClassCode) 登録済みの分類区分詳細情報の一覧を取得します。
abstract CategoryDetail | CategoryManager.getCategoryDetail(String categoryClassCode, String categoryCode) 登録済みの分類区分詳細情報を取得します。

jp.co.intra_mart.foundation.datastore.application.domain.company での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
static CompanyManager | CompanyManager.getCompanyManager(String user, String group) CompanyManagerを取得します。
protected abstract void | CompanyManager.init(String user, String group) CompanyManagerを初期化します。
abstract Department | CompanyManager.getDepartment(String company, String department) 登録済の組織を取得します。
abstract void | CompanyManager.addCompany(Company company) 会社を登録します。
abstract void | CompanyManager.deleteCompany(Company company) 登録済の会社を削除します。
abstract void | CompanyManager.addDepartment(Department department) 組織を登録します。
abstract void | CompanyManager.updateDepartment(Department department) 登録済の組織情報を更新します。
abstract void | CompanyManager.deleteDepartment(Department department) 登録済の組織情報を削除します。
abstract void | CompanyManager.joinDepartment(String company, String parentDepartment, String department, String version) 組織構成に組織を登録します。
abstract void | CompanyManager.moveDepartment(String company, String parentDepartment, String department, String version) 組織構成に登録済の組織情報を移動します。
abstract void | CompanyManager.leaveDepartment(String company, String department, String version) 組織構成から組織情報を離脱させます。
abstract void | CompanyManager.setCategoryDetail(CompanyCategory category) 組織に対して指定された分類区分情報を設定します。
abstract void | CompanyManager.removeCategoryDetail(CompanyCategory category) 組織に対して指定された分類区分情報を削除します。
abstract void | CompanyManager.setMember(DepartmentAttach attach) 組織に人員を割り当てます。
abstract void | CompanyManager.deleteMember(DepartmentAttach attach) 組織から人員をはずします。
abstract User[] | CompanyManager.getMember(String company, String department) 現在、組織に所属するる人員の一覧を取得します。
abstract User[] | CompanyManager.getMember(String company, String department, Date date) 指定された日付に組織に所属する人員の一覧を取得します。
abstract void | CompanyManager.setMain(DepartmentMain main) ユーザが主所属する組織を設定します。
abstract void | CompanyManager.removeMain(DepartmentMain main) 指定されたユーザの主所属を削除します。
abstract void | CompanyManager.addVersion(CompanyVersion version) 会社構成バージョンを新規に登録します。
abstract void | CompanyManager.updateVersion(CompanyVersion version) 登録済の会社構成バージョンを更新します。
abstract void | CompanyManager.deleteVersion(CompanyVersion version) 登録済の会社構成バージョンを削除します。
abstract void | CompanyManager.copyVersion(String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンの内容をコピーします。
abstract DepartmentStruct[] | CompanyManager.getDepartmentStructs(String company, String department, Date date, Locale locale) 組織の階層構造を取得します。
abstract Department[] | CompanyManager.getAttachedDepartments(String user) 現在、ユーザが所属している組織の一覧を取得します。
abstract Department[] | CompanyManager.getAttachedDepartments(String user, Date date) 指定された日付にユーザが所属している組織の一覧を取得します。
abstract DepartmentAttach | CompanyManager.getDepartmentAttach(String user, String company, String department) ユーザの組織への所属情報を取得します。
abstract DepartmentMain | CompanyManager.getDepartmentMain(String user) ユーザの主所属情報を取得します。
abstract void | CompanyManager.addPost(CompanyPost post) 役職を登録します。
abstract void | CompanyManager.updatePost(CompanyPost post) 登録済の役職情報を更新します。
abstract void | CompanyManager.deletePost(CompanyPost post) 登録済の役職情報を削除します。
abstract CompanyVersion | CompanyManager.getVersion(String company) 現在の会社構成バージョン情報を取得します。
abstract CompanyVersion | CompanyManager.getVersion(String company, Date date) 指定された日付の会社構成バージョン情報を取得します。

jp.co.intra_mart.foundation.datastore.application.domain.currency での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.currency のメソッド
static CurrencyManager | CurrencyManager.getCurrencyManager(String user, String group) CurrencyManagerを取得します。
protected abstract void | CurrencyManager.init(String user, String group) CurrencyManagerを初期化します。
abstract String | CurrencyManager.getSystemCurrencyCode() システム通貨コードを返します。
abstract String[] | CurrencyManager.getCurrencyCodes() 通貨コードの一覧を返します。
abstract String | CurrencyManager.getCurrencyName(String currencyCode, Locale locale) 通貨コードに対する名称を指定された言語で返します。
abstract Map | CurrencyManager.getCurrencyName(String currencyCode) 指定された通貨コードに対する名称を返します。

jp.co.intra_mart.foundation.datastore.application.domain.deal での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.deal のメソッド
static DealPermissionManager | DealPermissionManager.getDealPermissionManager(String user, String group) DealPermissionManagerを取得します。
protected abstract void | DealPermissionManager.init(String user, String group) DealPermissionManagerを初期化します。
abstract void | DealPermissionManager.setPermissionToDepartment(DealerDepartment dealer) 組織に対してアクセス権を設定します。
abstract void | DealPermissionManager.setPermissionToPublicGroup(DealerPublicGroup dealer) パブリックグループに対してアクセス権を設定します。
abstract void | DealPermissionManager.setPermissionToRole(DealerRole dealer) ロールに対してアクセス権を設定します。
abstract void | DealPermissionManager.removePermissionFromDepartment(DealerDepartment dealer) 組織からアクセス権を削除します。
abstract void | DealPermissionManager.removePermissionFromPublicGroup(DealerPublicGroup dealer) パブリックグループからアクセス権を削除します。
abstract void | DealPermissionManager.removePermissionFromRole(DealerRole dealer) ロールからアクセス権を削除します。
abstract Department[] | DealPermissionManager.getDepartments(Deal deal) 取扱情報を保有するアクセス権をもつ組織を返します。
abstract PublicGroup[] | DealPermissionManager.getPublicGroups(Deal deal) 取扱情報を保有するアクセス権をもつパブリックグループを返します。
abstract Role[] | DealPermissionManager.getRoles(Deal deal) 取扱情報を保有するアクセス権をもつロールを返します。
static DealManager | DealManager.getDealManager(String user, String group) DealManagerを取得します。
protected abstract void | DealManager.init(String user, String group) DealManagerを初期化します。
abstract void | DealManager.addDeal(Deal deal) 取扱情報を新規登録します。
abstract void | DealManager.updateDeal(Deal deal) 取扱情報を更新します。
abstract void | DealManager.deleteDeal(Deal deal) 取扱情報を削除します。
abstract Deal[] | DealManager.getDeals() 現在、存在する取扱情報を返します。
abstract Deal[] | DealManager.getDeals(Date date) 指定された日付に存在する取扱情報を返します。
abstract Deal[] | DealManager.getDealsByKey(String itemCode, String companyCode, String departmentCode) 現在、存在する取扱情報の中で、商品と取引先から特定されるものを返します。
abstract Deal[] | DealManager.getDealsByKey(String itemCode, String companyCode, String departmentCode, Date date) 指定された日時に存在する取扱情報の中で、商品と取引先から特定されるものを返します。
abstract Deal[] | DealManager.getUsersDeals(String userCode) 現在、ユーザがアクセスできる取扱情報を返します。
abstract Deal[] | DealManager.getUsersDeals(String userCode, Date date) 指定された日付にユーザがアクセスできる取扱情報を返します。
abstract Deal[] | DealManager.getUsersDealsByKey(String userCode, String itemCode, String companyCode, String departmentCode) 現在、存在する取扱情報の中で、商品と取引先から特定されるものを返します。
abstract Deal[] | DealManager.getUsersDealsByKey(String userCode, String itemCode, String companyCode, String departmentCode, Date date) 指定された日時に存在する取扱情報の中で、商品と取引先から特定されるものを返します。

jp.co.intra_mart.foundation.datastore.application.domain.item での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.item のメソッド
static ItemManager | ItemManager.getItemManager(String user, String group) ItemManagerを取得します。
protected abstract void | ItemManager.init(String user, String group) ItemManagerを初期化します。
abstract void | ItemManager.addItem(Item item) 商品情報を新規登録します。
abstract void | ItemManager.updateItem(Item item) 商品情報を更新します。
abstract void | ItemManager.deleteItem(Item item) 商品情報を削除します。
abstract void | ItemManager.setCatalogue(ItemCatalogue catalogue) 商品カタログ情報を設定します。
abstract void | ItemManager.setCatalogue(ItemCatalogue catalogue, byte[] byteStream) 商品カタログ情報を設定します。
abstract void | ItemManager.deleteCatalogue(ItemCatalogue catalogue) 商品カタログ情報を削除します。
abstract String | ItemManager.getCatalogueMediaFileName(ItemCatalogue catalogue) 商品カタログの媒体が保存されてるファイルパスを取得します。
abstract void | ItemManager.setItemCatalogueMediaManager(ItemCatalogueMediaManager catalogueMediaManager) 商品カタログの媒体のマネジャーを設定します。
abstract Item[] | ItemManager.getItems() 現在、存在する商品の情報を返します。
abstract Item[] | ItemManager.getItems(Date date) 指定された日付に存在する商品の情報を返します。
abstract Item | ItemManager.getItem(String itemCode) 指定された商品コードに対する商品の情報を返します。
abstract Item[] | ItemManager.getItemsByKey(String code, String name) 現在、条件に合致する商品の情報を返します。
abstract Item[] | ItemManager.getItemsByKey(String code, String name, Date date) 指定された日付に条件に合致する商品の情報を返します。
abstract ItemCatalogue | ItemManager.getCatalogue(String itemCode, String catalogueCode) 指定されたカタログ情報を返します。
abstract ItemCatalogue[] | ItemManager.getCatalogues(String itemCode) 指定された商品のカタログ情報を返します。
abstract void | ItemManager.setAttribute(ItemAttribute attribute) 商品属性情報を設定します。
abstract void | ItemManager.removeAttribute(ItemAttribute attribute) 指定された商品属性情報を削除します。
abstract ItemAttribute[] | ItemManager.getAttributes(String itemCode) 指定された商品の属性情報を取得します。
void | ItemCatalogueMediaManager.save(String filePath, byte[] byteString) 商品カタログの媒体情報を保存します。
void | ItemCatalogueMediaManager.delete(String filePath) 商品カタログの媒体情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.item_category での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.item_category のメソッド
static ItemCategoryManager | ItemCategoryManager.getItemCategoryManager(String user, String group) ItemCategoryManagerを取得します。
protected abstract void | ItemCategoryManager.init(String user, String group) ItemCategoryManagerを初期化します。
abstract void | ItemCategoryManager.addCategory(ItemCategory category) 商品カテゴリを新規登録します。
abstract void | ItemCategoryManager.updateCategory(ItemCategory category) 商品カテゴリを更新します。
abstract void | ItemCategoryManager.deleteCategory(ItemCategory category) 商品カテゴリを削除します。
abstract void | ItemCategoryManager.setItem(ItemAttach attach) 商品カテゴリに商品を設定します。
abstract void | ItemCategoryManager.removeItem(ItemAttach attach) 商品カテゴリから商品を外します。
abstract ItemCategory[] | ItemCategoryManager.getCategoryTypes() 登録済の商品カテゴリ種別の一覧を返します。
abstract ItemCategoryStruct | ItemCategoryManager.getCategoryStruct(String categoryTypeCode) 指定された商品カテゴリ種別のカテゴリ階層を取得します。
abstract ItemCategory | ItemCategoryManager.getCategory(String categoryTypeCode, String categoryCode) 指定されたカテゴリコードに対する商品カテゴリの情報を返します。
abstract Item[] | ItemCategoryManager.getCategorizedItems(String categoryTypeCode, String categoryCode) 商品カテゴリに分類されている商品の情報を返します。
abstract Item[] | ItemCategoryManager.getAllCategorizedItems(String categoryTypeCode, String categoryCode) 商品カテゴリに分類されているすべての商品の情報を返します。
abstract boolean | ItemCategoryManager.isEndCategory(String categoryTypeCode, String categoryCode) 指定されたカテゴリコードに対する商品カテゴリが末端のカテゴリか調べます。

jp.co.intra_mart.foundation.datastore.application.domain.item_template での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.item_template のメソッド
static ItemTemplateManager | ItemTemplateManager.getItemTemplateManager(String user, String group) ItemTemplateManagerを取得します。
protected abstract void | ItemTemplateManager.init(String user, String group) ItemTemplateManagerを初期化します。
abstract void | ItemTemplateManager.addTemplate(ItemTemplate template) 商品属性テンプレート情報を新規登録します。
abstract void | ItemTemplateManager.updateTemplate(ItemTemplate template) 商品属性テンプレート情報を更新します。
abstract void | ItemTemplateManager.deleteTemplate(ItemTemplate template) 商品属性テンプレート情報を削除します。
abstract void | ItemTemplateManager.setTemplateDetail(ItemTemplateDetail detail) 商品属性テンプレート明細情報を設定します。
abstract void | ItemTemplateManager.deleteTemplateDetail(ItemTemplateDetail detail) 商品属性テンプレート明細情報を削除します。
abstract ItemTemplate[] | ItemTemplateManager.getTemplates(String key) 指定された検索条件に該当する商品属性テンプレート情報を返します。
abstract ItemTemplate | ItemTemplateManager.getTemplate(String templateCode) 指定された商品属性テンプレート情報を返します。
abstract ItemTemplateDetail[] | ItemTemplateManager.getTemplateDetail(String templateCode) 指定された商品属性テンプレートの明細情報を返します。

jp.co.intra_mart.foundation.datastore.application.domain.private_group での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.private_group のメソッド
static PrivateGroupManager | PrivateGroupManager.getPrivateGroupManager(String user, String group) PrivateGroupManagerを取得します。
protected abstract void | PrivateGroupManager.init(String user, String group) PrivateGroupManagerを初期化します。
abstract PrivateGroup | PrivateGroupManager.getPrivateGroup(String owner, String group) 登録済のプライベートグループを取得します。
abstract PrivateGroup[] | PrivateGroupManager.getPrivateGroups(String owner) 指定されたユーザが持つプライベートグループをすべて取得します。
abstract void | PrivateGroupManager.addPrivateGroup(PrivateGroup group) プライベートグループを登録します。
abstract void | PrivateGroupManager.updatePrivateGroup(PrivateGroup group) 登録済のプライベートグループ情報を更新します。
abstract void | PrivateGroupManager.deletePrivateGroup(PrivateGroup group) 登録済のプライベートグループ情報を削除します。
abstract void | PrivateGroupManager.setMember(PrivateGroupAttach member) プライベートグループに人員を割り当てます。
abstract void | PrivateGroupManager.deleteMember(PrivateGroupAttach member) プライベートグループから人員をはずします。
abstract User[] | PrivateGroupManager.getMember(String owner, String group) ログインユーザが持つ指定されたプライベートグループに所属する人員を取得します。
abstract User[] | PrivateGroupManager.getMember(String owner, String group, Date date) 指定されたプライベートグループに所属する人員を取得します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
static PublicGroupManager | PublicGroupManager.getPublicGroupManager(String user, String group) PublicGroupManagerを取得します。
protected abstract void | PublicGroupManager.init(String user, String group) PublicGroupManagerを初期化します。
abstract PublicGroup | PublicGroupManager.getPublicGroup(String groupSet, String publicGroup) 登録済のパブリックグループを取得します。
abstract void | PublicGroupManager.addGroupSet(PublicGroupSet groupSet) パブリックグループセットを登録します。
abstract void | PublicGroupManager.deleteGroupSet(PublicGroupSet groupSet) 登録済のパブリックグループセットを削除します。
abstract void | PublicGroupManager.addPublicGroup(PublicGroup publicGroup) パブリックグループを登録します。
abstract void | PublicGroupManager.updatePublicGroup(PublicGroup publicGroup) 登録済のパブリックグループ情報を更新します。
abstract void | PublicGroupManager.deletePublicGroup(PublicGroup publicGroup) 登録済のパブリックグループ情報を削除します。
abstract void | PublicGroupManager.joinPublicGroup(String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成にパブリックグループを登録します。
abstract void | PublicGroupManager.movePublicGroup(String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成に登録済のパブリックグループ情報を移動します。
abstract void | PublicGroupManager.leavePublicGroup(String groupSet, String publicGroup, String version) パブリックグループ構成からパブリックグループ情報を離脱させます。
abstract void | PublicGroupManager.setCategoryDetail(PublicGroupCategory category) パブリックグループに対して指定された分類区分情報を設定します。
abstract void | PublicGroupManager.removeCategoryDetail(PublicGroupCategory category) パブリックグループに対して指定された分類区分情報を削除します。
abstract void | PublicGroupManager.setMember(PublicGroupAttach attach) パブリックグループに人員を割り当てます。
abstract void | PublicGroupManager.deleteMember(PublicGroupAttach attach) パブリックグループから人員をはずします。
abstract User[] | PublicGroupManager.getMember(String groupSet, String publicGroup) 現在、パブリックグループに所属するる人員の一覧を取得します。
abstract User[] | PublicGroupManager.getMember(String groupSet, String publicGroup, Date date) 指定された日付にパブリックグループに所属する人員の一覧を取得します。
abstract void | PublicGroupManager.addVersion(PublicGroupVersion version) パブリックグループセット構成バージョンを新規に登録します。
abstract void | PublicGroupManager.updateVersion(PublicGroupVersion version) 登録済のパブリックグループセット構成バージョンを更新します。
abstract void | PublicGroupManager.deleteVersion(PublicGroupVersion version) 登録済のパブリックグループセット構成バージョンを削除します。
abstract void | PublicGroupManager.copyVersion(String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーします。
abstract PublicGroupStruct[] | PublicGroupManager.getPublicGroupStructs(String groupSet, String publicGroup, Date date, Locale locale) パブリックグループの階層構造を取得します。
abstract PublicGroup[] | PublicGroupManager.getAttachedPublicGroups(String user) 現在、ユーザが所属しているパブリックグループの一覧を取得します。
abstract PublicGroup[] | PublicGroupManager.getAttachedPublicGroups(String user, Date date) 指定された日付にユーザが所属しているパブリックグループの一覧を取得します。
abstract PublicGroupAttach | PublicGroupManager.getPublicGroupAttach(String user, String groupSet, String publicGroup) ユーザのパブリックグループへの所属情報を取得します。
abstract PublicGroupVersion | PublicGroupManager.getVersion(String groupSet) 現在のパブリックグループセット構成バージョン情報を取得します。
abstract PublicGroupVersion | PublicGroupManager.getVersion(String groupSet, Date date) 指定された日付のパブリックグループセット構成バージョン情報を取得します。

jp.co.intra_mart.foundation.datastore.application.domain.unit での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.unit のメソッド
static ItemUnitManager | ItemUnitManager.getItemUnitManager(String user, String group) ItemUnitManagerを取得します。
protected abstract void | ItemUnitManager.init(String user, String group) ItemUnitManagerを初期化します。
abstract Map | ItemUnitManager.getUnits() 単位の一覧を取得します。
abstract String | ItemUnitManager.getUnitName(String unitCode) 単位コードに対する名称を返します。
abstract String | ItemUnitManager.getUnitCode(String unitName) 単位名に対する単位コードを取得します。
abstract boolean | ItemUnitManager.addUnit(String unitCode, String unitName) 単位を追加します。
abstract boolean | ItemUnitManager.updateUnit(String unitCode, String unitName) 単位を更新します。
abstract void | ItemUnitManager.deleteUnit(String unitCode) 単位を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.user での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
static UserManager | UserManager.getUserManager(String user, String group) UserManagerを取得します。
protected abstract void | UserManager.init(String user, String group) UserManagerを初期化します。
abstract User | UserManager.getUser(String userCode) 登録済のユーザを取得します。
abstract void | UserManager.addUser(User user) ユーザを登録します。
abstract void | UserManager.updateUser(User user) 登録済のユーザを更新します。
abstract void | UserManager.deleteUser(User user) 登録済のユーザを削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.MapperDAOException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.MapperDAOException の使用

jp.co.intra_mart.foundation.datastore.exception.MapperDAOException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.MapperException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.MapperException の使用

MapperException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category | 会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company | 会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion | 組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version | 会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.deal | 取扱情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.department | 取扱組織権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.detail | 取扱詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group | 取扱パブリックグループ権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.role | 取扱ロール権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach | 商品分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.category | 商品カテゴリ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.type | 商品カテゴリ種別情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail | 商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.template | 商品テンプレート情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.attribute | 商品属性情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue | 商品カタログ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.item | 商品情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach | プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group | プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach | パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category | パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion | パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set | パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version | パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.unit | 単位情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.system.security.datastore.inf |

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.category.category_class のメソッド
CateogryClassBaseModel | CateogryClassMapper.create(String categoryClassCode) プライマリキーに該当する分類区分を生成します。
CateogryClassBaseModel | CateogryClassMapper.select(String categoryClassCode) プライマリーキーで特定される分類区分の基本モデルを取得します。
void | CateogryClassMapper.insert(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ挿入します。
void | CateogryClassMapper.insert(Collection models) 分類区分の基本モデルを複数挿入します。
void | CateogryClassMapper.update(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ更新します。
void | CateogryClassMapper.update(Collection models) 分類区分の基本モデルを複数更新します。
void | CateogryClassMapper.delete(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ削除します。
void | CateogryClassMapper.delete(Collection models) 分類区分の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.category.detail での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.category.detail のメソッド
CategoryDetailBaseModel | CategoryDetailMapper.create(String categoryClassCode, String categoryCode) プライマリキーに該当する分類区分詳細を生成します。
CategoryDetailBaseModel | CategoryDetailMapper.select(String categoryClassCode, String categoryCode) プライマリーキーで特定される分類区分詳細の基本モデルを取得します。
void | CategoryDetailMapper.insert(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ挿入します。
void | CategoryDetailMapper.insert(Collection models) 分類区分詳細の基本モデルを複数挿入します。
void | CategoryDetailMapper.update(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ更新します。
void | CategoryDetailMapper.update(Collection models) 分類区分詳細の基本モデルを複数更新します。
void | CategoryDetailMapper.delete(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ削除します。
void | CategoryDetailMapper.delete(Collection models) 分類区分詳細の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.company.attach での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.attach のメソッド
DepartmentAttachBaseModel | DepartmentAttachMapper.create(String userCode, String companyCode, String departmentCode) プライマリキーに該当する組織所属を生成します。
DepartmentAttachBaseModel | DepartmentAttachMapper.select(String userCode, String companyCode, String departmentCode) プライマリーキーで特定される組織所属の基本モデルを取得します。
void | DepartmentAttachMapper.insert(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ挿入します。
void | DepartmentAttachMapper.insert(Collection models) 組織所属の基本モデルを複数挿入します。
void | DepartmentAttachMapper.update(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ更新します。
void | DepartmentAttachMapper.update(Collection models) 組織所属の基本モデルを複数更新します。
void | DepartmentAttachMapper.delete(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ削除します。
void | DepartmentAttachMapper.delete(Collection models) 組織所属の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.company.category での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.category のメソッド
CompanyCategoryBaseModel | CompanyCategoryMapper.create(String companyCode, String departmentCode, String categoryClassCode, String categoryCode) プライマリキーに該当する会社組織分類を生成します。
CompanyCategoryBaseModel | CompanyCategoryMapper.select(String companyCode, String departmentCode, String categoryClassCode, String categoryCode) プライマリーキーで特定される会社組織分類の基本モデルを取得します。
void | CompanyCategoryMapper.insert(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ挿入します。
void | CompanyCategoryMapper.insert(Collection models) 会社組織分類の基本モデルを複数挿入します。
void | CompanyCategoryMapper.update(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ更新します。
void | CompanyCategoryMapper.update(Collection models) 会社組織分類の基本モデルを複数更新します。
void | CompanyCategoryMapper.delete(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ削除します。
void | CompanyCategoryMapper.delete(Collection models) 会社組織分類の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.company.company での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.company のメソッド
CompanyBaseModel | CompanyMapper.create(String companyCode) プライマリキーに該当する会社を生成します。
CompanyBaseModel | CompanyMapper.select(String companyCode) プライマリーキーで特定される会社の基本モデルを取得します。
void | CompanyMapper.insert(CompanyBaseModel model) 会社の基本モデルを1つだけ挿入します。
void | CompanyMapper.insert(Collection models) 会社の基本モデルを複数挿入します。
void | CompanyMapper.update(CompanyBaseModel model) 会社の基本モデルを1つだけ更新します。
void | CompanyMapper.update(Collection models) 会社の基本モデルを複数更新します。
void | CompanyMapper.delete(CompanyBaseModel model) 会社の基本モデルを1つだけ削除します。
void | CompanyMapper.delete(Collection models) 会社の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.company.department での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.department のメソッド
DepartmentBaseModel | DepartmentMapper.create(String companyCode, String departmentCode) プライマリキーに該当する組織を生成します。
DepartmentBaseModel | DepartmentMapper.select(String companyCode, String departmentCode) プライマリーキーで特定される組織の基本モデルを取得します。
void | DepartmentMapper.insert(DepartmentBaseModel model) 組織の基本モデルを1つだけ挿入します。
void | DepartmentMapper.insert(Collection models) 組織の基本モデルを複数挿入します。
void | DepartmentMapper.update(DepartmentBaseModel model) 組織の基本モデルを1つだけ更新します。
void | DepartmentMapper.update(Collection models) 組織の基本モデルを複数更新します。
void | DepartmentMapper.delete(DepartmentBaseModel model) 組織の基本モデルを1つだけ削除します。
void | DepartmentMapper.delete(Collection models) 組織の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.inclusion のメソッド
DepartmentInclusionBaseModel | DepartmentInclusionMapper.create(String companyCode, String versionCode, String parentDepartmentCode, String departmentCode) プライマリキーに該当する組織内包を生成します。
DepartmentInclusionBaseModel | DepartmentInclusionMapper.select(String companyCode, String versionCode, String parentDepartmentCode, String departmentCode) プライマリーキーで特定される組織内包の基本モデルを取得します。
void | DepartmentInclusionMapper.insert(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ挿入します。
void | DepartmentInclusionMapper.insert(Collection models) 組織内包の基本モデルを複数挿入します。
void | DepartmentInclusionMapper.update(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ更新します。
void | DepartmentInclusionMapper.update(Collection models) 組織内包の基本モデルを複数更新します。
void | DepartmentInclusionMapper.delete(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ削除します。
void | DepartmentInclusionMapper.delete(Collection models) 組織内包の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.company.main での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.main のメソッド
DepartmentMainBaseModel | DepartmentMainMapper.create(String userCode) プライマリキーに該当する主所属を生成します。
DepartmentMainBaseModel | DepartmentMainMapper.select(String userCode) プライマリーキーで特定される主所属の基本モデルを取得します。
void | DepartmentMainMapper.insert(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ挿入します。
void | DepartmentMainMapper.insert(Collection models) 主所属の基本モデルを複数挿入します。
void | DepartmentMainMapper.update(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ更新します。
void | DepartmentMainMapper.update(Collection models) 主所属の基本モデルを複数更新します。
void | DepartmentMainMapper.delete(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ削除します。
void | DepartmentMainMapper.delete(Collection models) 主所属の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.company.post での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.post のメソッド
CompanyPostBaseModel | CompanyPostMapper.create(String companyCode, String postCode) プライマリキーに該当する役職を生成します。
CompanyPostBaseModel | CompanyPostMapper.select(String companyCode, String postCode) プライマリーキーで特定される役職の基本モデルを取得します。
void | CompanyPostMapper.insert(CompanyPostBaseModel model) 役職の基本モデルを1つだけ挿入します。
void | CompanyPostMapper.insert(Collection models) 役職の基本モデルを複数挿入します。
void | CompanyPostMapper.update(CompanyPostBaseModel model) 役職の基本モデルを1つだけ更新します。
void | CompanyPostMapper.update(Collection models) 役職の基本モデルを複数更新します。
void | CompanyPostMapper.delete(CompanyPostBaseModel model) 役職の基本モデルを1つだけ削除します。
void | CompanyPostMapper.delete(Collection models) 役職の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.company.version での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.version のメソッド
CompanyVersionBaseModel | CompanyVersionMapper.create(String companyCode, String versionCode) プライマリキーに該当する会社構成バージョンを生成します。
CompanyVersionBaseModel | CompanyVersionMapper.select(String companyCode, String versionCode) プライマリーキーで特定される会社構成バージョンの基本モデルを取得します。
void | CompanyVersionMapper.insert(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ挿入します。
void | CompanyVersionMapper.insert(Collection models) 会社構成バージョンの基本モデルを複数挿入します。
void | CompanyVersionMapper.update(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ更新します。
void | CompanyVersionMapper.update(Collection models) 会社構成バージョンの基本モデルを複数更新します。
void | CompanyVersionMapper.delete(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ削除します。
void | CompanyVersionMapper.delete(Collection models) 会社構成バージョンの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.deal.deal での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.deal.deal のメソッド
DealBaseModel | DealMapper.create(String customerCompanyCode, String customerDepartmentCode, String dealCode) プライマリキーに該当する取扱を生成します。
DealBaseModel | DealMapper.select(String customerCompanyCode, String customerDepartmentCode, String dealCode) プライマリーキーで特定される取扱の基本モデルを取得します。
void | DealMapper.insert(DealBaseModel model) 取扱の基本モデルを1つだけ挿入します。
void | DealMapper.insert(Collection models) 取扱の基本モデルを複数挿入します。
void | DealMapper.update(DealBaseModel model) 取扱の基本モデルを1つだけ更新します。
void | DealMapper.update(Collection models) 取扱の基本モデルを複数更新します。
void | DealMapper.delete(DealBaseModel model) 取扱の基本モデルを1つだけ削除します。
void | DealMapper.delete(Collection models) 取扱の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.deal.department での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.deal.department のメソッド
DealerDepartmentBaseModel | DealerDepartmentMapper.create(String customerCompanyCode, String customerDepartmentCode, String dealCode, String companyCode, String departmentCode) プライマリキーに該当する組織毎取扱パーミッションを生成します。
DealerDepartmentBaseModel | DealerDepartmentMapper.select(String customerCompanyCode, String customerDepartmentCode, String dealCode, String companyCode, String departmentCode) プライマリーキーで特定される組織毎取扱パーミッションの基本モデルを取得します。
void | DealerDepartmentMapper.insert(DealerDepartmentBaseModel model) 組織毎取扱パーミッションの基本モデルを1つだけ挿入します。
void | DealerDepartmentMapper.insert(Collection models) 組織毎取扱パーミッションの基本モデルを複数挿入します。
void | DealerDepartmentMapper.update(DealerDepartmentBaseModel model) 組織毎取扱パーミッションの基本モデルを1つだけ更新します。
void | DealerDepartmentMapper.update(Collection models) 組織毎取扱パーミッションの基本モデルを複数更新します。
void | DealerDepartmentMapper.delete(DealerDepartmentBaseModel model) 組織毎取扱パーミッションの基本モデルを1つだけ削除します。
void | DealerDepartmentMapper.delete(Collection models) 組織毎取扱パーミッションの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.deal.detail での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.deal.detail のメソッド
DealDetailBaseModel | DealDetailMapper.create(String customerCompanyCode, String customerDepartmentCode, String dealCode, String itemCode) プライマリキーに該当する取扱詳細を生成します。
DealDetailBaseModel | DealDetailMapper.select(String customerCompanyCode, String customerDepartmentCode, String dealCode, String itemCode) プライマリーキーで特定される取扱詳細の基本モデルを取得します。
void | DealDetailMapper.insert(DealDetailBaseModel model) 取扱詳細の基本モデルを1つだけ挿入します。
void | DealDetailMapper.insert(Collection models) 取扱詳細の基本モデルを複数挿入します。
void | DealDetailMapper.update(DealDetailBaseModel model) 取扱詳細の基本モデルを1つだけ更新します。
void | DealDetailMapper.update(Collection models) 取扱詳細の基本モデルを複数更新します。
void | DealDetailMapper.delete(DealDetailBaseModel model) 取扱詳細の基本モデルを1つだけ削除します。
void | DealDetailMapper.delete(Collection models) 取扱詳細の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.deal.public_group のメソッド
DealerPublicGroupBaseModel | DealerPublicGroupMapper.create(String customerCompanyCode, String customerDepartmentCode, String dealCode, String publicGroupSetCode, String publicGroupCode) プライマリキーに該当するパブリックグループ毎取扱パーミッションを生成します。
DealerPublicGroupBaseModel | DealerPublicGroupMapper.select(String customerCompanyCode, String customerDepartmentCode, String dealCode, String publicGroupSetCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループ毎取扱パーミッションの基本モデルを取得します。
void | DealerPublicGroupMapper.insert(DealerPublicGroupBaseModel model) パブリックグループ毎取扱パーミッションの基本モデルを1つだけ挿入します。
void | DealerPublicGroupMapper.insert(Collection models) パブリックグループ毎取扱パーミッションの基本モデルを複数挿入します。
void | DealerPublicGroupMapper.update(DealerPublicGroupBaseModel model) パブリックグループ毎取扱パーミッションの基本モデルを1つだけ更新します。
void | DealerPublicGroupMapper.update(Collection models) パブリックグループ毎取扱パーミッションの基本モデルを複数更新します。
void | DealerPublicGroupMapper.delete(DealerPublicGroupBaseModel model) パブリックグループ毎取扱パーミッションの基本モデルを1つだけ削除します。
void | DealerPublicGroupMapper.delete(Collection models) パブリックグループ毎取扱パーミッションの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.deal.role での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.deal.role のメソッド
DealerRoleBaseModel | DealerRoleMapper.create(String customerCompanyCode, String customerDepartmentCode, String dealCode, String roleId) プライマリキーに該当するロール毎取扱パーミッションを生成します。
DealerRoleBaseModel | DealerRoleMapper.select(String customerCompanyCode, String customerDepartmentCode, String dealCode, String roleId) プライマリーキーで特定されるロール毎取扱パーミッションの基本モデルを取得します。
void | DealerRoleMapper.insert(DealerRoleBaseModel model) ロール毎取扱パーミッションの基本モデルを1つだけ挿入します。
void | DealerRoleMapper.insert(Collection models) ロール毎取扱パーミッションの基本モデルを複数挿入します。
void | DealerRoleMapper.update(DealerRoleBaseModel model) ロール毎取扱パーミッションの基本モデルを1つだけ更新します。
void | DealerRoleMapper.update(Collection models) ロール毎取扱パーミッションの基本モデルを複数更新します。
void | DealerRoleMapper.delete(DealerRoleBaseModel model) ロール毎取扱パーミッションの基本モデルを1つだけ削除します。
void | DealerRoleMapper.delete(Collection models) ロール毎取扱パーミッションの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.item_category.attach のメソッド
ItemAttachBaseModel | ItemAttachMapper.create(String itemCategoryTypeCode, String itemCategoryCode, String itemCode) プライマリキーに該当する商品分類を生成します。
ItemAttachBaseModel | ItemAttachMapper.select(String itemCategoryTypeCode, String itemCategoryCode, String itemCode) プライマリーキーで特定される商品分類の基本モデルを取得します。
void | ItemAttachMapper.insert(ItemAttachBaseModel model) 商品分類の基本モデルを1つだけ挿入します。
void | ItemAttachMapper.insert(Collection models) 商品分類の基本モデルを複数挿入します。
void | ItemAttachMapper.update(ItemAttachBaseModel model) 商品分類の基本モデルを1つだけ更新します。
void | ItemAttachMapper.update(Collection models) 商品分類の基本モデルを複数更新します。
void | ItemAttachMapper.delete(ItemAttachBaseModel model) 商品分類の基本モデルを1つだけ削除します。
void | ItemAttachMapper.delete(Collection models) 商品分類の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.category での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.item_category.category のメソッド
ItemCategoryBaseModel | ItemCategoryMapper.create(String itemCategoryTypeCode, String itemCategoryCode) プライマリキーに該当する商品カテゴリを生成します。
ItemCategoryBaseModel | ItemCategoryMapper.select(String itemCategoryTypeCode, String itemCategoryCode) プライマリーキーで特定される商品カテゴリの基本モデルを取得します。
void | ItemCategoryMapper.insert(ItemCategoryBaseModel model) 商品カテゴリの基本モデルを1つだけ挿入します。
void | ItemCategoryMapper.insert(Collection models) 商品カテゴリの基本モデルを複数挿入します。
void | ItemCategoryMapper.update(ItemCategoryBaseModel model) 商品カテゴリの基本モデルを1つだけ更新します。
void | ItemCategoryMapper.update(Collection models) 商品カテゴリの基本モデルを複数更新します。
void | ItemCategoryMapper.delete(ItemCategoryBaseModel model) 商品カテゴリの基本モデルを1つだけ削除します。
void | ItemCategoryMapper.delete(Collection models) 商品カテゴリの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.type での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.item_category.type のメソッド
ItemCategoryTypeBaseModel | ItemCategoryTypeMapper.create(String itemCategoryTypeCode) プライマリキーに該当する商品カテゴリ種別を生成します。
ItemCategoryTypeBaseModel | ItemCategoryTypeMapper.select(String itemCategoryTypeCode) プライマリーキーで特定される商品カテゴリ種別の基本モデルを取得します。
void | ItemCategoryTypeMapper.insert(ItemCategoryTypeBaseModel model) 商品カテゴリ種別の基本モデルを1つだけ挿入します。
void | ItemCategoryTypeMapper.insert(Collection models) 商品カテゴリ種別の基本モデルを複数挿入します。
void | ItemCategoryTypeMapper.update(ItemCategoryTypeBaseModel model) 商品カテゴリ種別の基本モデルを1つだけ更新します。
void | ItemCategoryTypeMapper.update(Collection models) 商品カテゴリ種別の基本モデルを複数更新します。
void | ItemCategoryTypeMapper.delete(ItemCategoryTypeBaseModel model) 商品カテゴリ種別の基本モデルを1つだけ削除します。
void | ItemCategoryTypeMapper.delete(Collection models) 商品カテゴリ種別の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.item_template.detail のメソッド
ItemTemplateDetailBaseModel | ItemTemplateDetailMapper.create(String templateCode, String templateDetailCode) プライマリキーに該当する商品属性テンプレート明細を生成します。
ItemTemplateDetailBaseModel | ItemTemplateDetailMapper.select(String templateCode, String templateDetailCode) プライマリーキーで特定される商品属性テンプレート明細の基本モデルを取得します。
void | ItemTemplateDetailMapper.insert(ItemTemplateDetailBaseModel model) 商品属性テンプレート明細の基本モデルを1つだけ挿入します。
void | ItemTemplateDetailMapper.insert(Collection models) 商品属性テンプレート明細の基本モデルを複数挿入します。
void | ItemTemplateDetailMapper.update(ItemTemplateDetailBaseModel model) 商品属性テンプレート明細の基本モデルを1つだけ更新します。
void | ItemTemplateDetailMapper.update(Collection models) 商品属性テンプレート明細の基本モデルを複数更新します。
void | ItemTemplateDetailMapper.delete(ItemTemplateDetailBaseModel model) 商品属性テンプレート明細の基本モデルを1つだけ削除します。
void | ItemTemplateDetailMapper.delete(Collection models) 商品属性テンプレート明細の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.item_template.template での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.item_template.template のメソッド
ItemTemplateBaseModel | ItemTemplateMapper.create(String templateCode) プライマリキーに該当する商品属性テンプレートを生成します。
ItemTemplateBaseModel | ItemTemplateMapper.select(String templateCode) プライマリーキーで特定される商品属性テンプレートの基本モデルを取得します。
void | ItemTemplateMapper.insert(ItemTemplateBaseModel model) 商品属性テンプレートの基本モデルを1つだけ挿入します。
void | ItemTemplateMapper.insert(Collection models) 商品属性テンプレートの基本モデルを複数挿入します。
void | ItemTemplateMapper.update(ItemTemplateBaseModel model) 商品属性テンプレートの基本モデルを1つだけ更新します。
void | ItemTemplateMapper.update(Collection models) 商品属性テンプレートの基本モデルを複数更新します。
void | ItemTemplateMapper.delete(ItemTemplateBaseModel model) 商品属性テンプレートの基本モデルを1つだけ削除します。
void | ItemTemplateMapper.delete(Collection models) 商品属性テンプレートの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.item.attribute での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.item.attribute のメソッド
ItemAttributeBaseModel | ItemAttributeMapper.create(String itemCode, String templateCode, String templateDetailCode) プライマリキーに該当する商品属性を生成します。
ItemAttributeBaseModel | ItemAttributeMapper.select(String itemCode, String templateCode, String templateDetailCode) プライマリーキーで特定される商品属性の基本モデルを取得します。
void | ItemAttributeMapper.insert(ItemAttributeBaseModel model) 商品属性の基本モデルを1つだけ挿入します。
void | ItemAttributeMapper.insert(Collection models) 商品属性の基本モデルを複数挿入します。
void | ItemAttributeMapper.update(ItemAttributeBaseModel model) 商品属性の基本モデルを1つだけ更新します。
void | ItemAttributeMapper.update(Collection models) 商品属性の基本モデルを複数更新します。
void | ItemAttributeMapper.delete(ItemAttributeBaseModel model) 商品属性の基本モデルを1つだけ削除します。
void | ItemAttributeMapper.delete(Collection models) 商品属性の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.item.catalogue のメソッド
ItemCatalogueBaseModel | ItemCatalogueMapper.create(String itemCode, String itemCatalogueCode) プライマリキーに該当する商品カタログを生成します。
ItemCatalogueBaseModel | ItemCatalogueMapper.select(String itemCode, String itemCatalogueCode) プライマリーキーで特定される商品カタログの基本モデルを取得します。
void | ItemCatalogueMapper.insert(ItemCatalogueBaseModel model) 商品カタログの基本モデルを1つだけ挿入します。
void | ItemCatalogueMapper.insert(Collection models) 商品カタログの基本モデルを複数挿入します。
void | ItemCatalogueMapper.update(ItemCatalogueBaseModel model) 商品カタログの基本モデルを1つだけ更新します。
void | ItemCatalogueMapper.update(Collection models) 商品カタログの基本モデルを複数更新します。
void | ItemCatalogueMapper.delete(ItemCatalogueBaseModel model) 商品カタログの基本モデルを1つだけ削除します。
void | ItemCatalogueMapper.delete(Collection models) 商品カタログの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.item.item での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.item.item のメソッド
ItemBaseModel | ItemMapper.create(String itemCode) プライマリキーに該当する商品を生成します。
ItemBaseModel | ItemMapper.select(String itemCode) プライマリーキーで特定される商品の基本モデルを取得します。
void | ItemMapper.insert(ItemBaseModel model) 商品の基本モデルを1つだけ挿入します。
void | ItemMapper.insert(Collection models) 商品の基本モデルを複数挿入します。
void | ItemMapper.update(ItemBaseModel model) 商品の基本モデルを1つだけ更新します。
void | ItemMapper.update(Collection models) 商品の基本モデルを複数更新します。
void | ItemMapper.delete(ItemBaseModel model) 商品の基本モデルを1つだけ削除します。
void | ItemMapper.delete(Collection models) 商品の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.private_group.attach のメソッド
PrivateGroupAttachBaseModel | PrivateGroupAttachMapper.create(String ownerCode, String privateGroupCode, String userCode) プライマリキーに該当するプライベートグループ所属を生成します。
PrivateGroupAttachBaseModel | PrivateGroupAttachMapper.select(String ownerCode, String privateGroupCode, String userCode) プライマリーキーで特定されるプライベートグループ所属の基本モデルを取得します。
void | PrivateGroupAttachMapper.insert(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ挿入します。
void | PrivateGroupAttachMapper.insert(Collection models) プライベートグループ所属の基本モデルを複数挿入します。
void | PrivateGroupAttachMapper.update(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ更新します。
void | PrivateGroupAttachMapper.update(Collection models) プライベートグループ所属の基本モデルを複数更新します。
void | PrivateGroupAttachMapper.delete(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ削除します。
void | PrivateGroupAttachMapper.delete(Collection models) プライベートグループ所属の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.private_group.group での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.private_group.group のメソッド
PrivateGroupBaseModel | PrivateGroupMapper.create(String ownerCode, String privateGroupCode) プライマリキーに該当するプライベートグループを生成します。
PrivateGroupBaseModel | PrivateGroupMapper.select(String ownerCode, String privateGroupCode) プライマリーキーで特定されるプライベートグループの基本モデルを取得します。
void | PrivateGroupMapper.insert(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ挿入します。
void | PrivateGroupMapper.insert(Collection models) プライベートグループの基本モデルを複数挿入します。
void | PrivateGroupMapper.update(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ更新します。
void | PrivateGroupMapper.update(Collection models) プライベートグループの基本モデルを複数更新します。
void | PrivateGroupMapper.delete(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ削除します。
void | PrivateGroupMapper.delete(Collection models) プライベートグループの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.attach のメソッド
PublicGroupAttachBaseModel | PublicGroupAttachMapper.create(String userCode, String publicGroupSetCode, String publicGroupCode) プライマリキーに該当するパブリックグループ所属を生成します。
PublicGroupAttachBaseModel | PublicGroupAttachMapper.select(String userCode, String publicGroupSetCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループ所属の基本モデルを取得します。
void | PublicGroupAttachMapper.insert(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ挿入します。
void | PublicGroupAttachMapper.insert(Collection models) パブリックグループ所属の基本モデルを複数挿入します。
void | PublicGroupAttachMapper.update(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ更新します。
void | PublicGroupAttachMapper.update(Collection models) パブリックグループ所属の基本モデルを複数更新します。
void | PublicGroupAttachMapper.delete(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ削除します。
void | PublicGroupAttachMapper.delete(Collection models) パブリックグループ所属の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.category のメソッド
PublicGroupCategoryBaseModel | PublicGroupCategoryMapper.create(String publicGroupSetCode, String publicGroupCode, String categoryClassCode, String categoryCode) プライマリキーに該当するパブリックグループ分類を生成します。
PublicGroupCategoryBaseModel | PublicGroupCategoryMapper.select(String publicGroupSetCode, String publicGroupCode, String categoryClassCode, String categoryCode) プライマリーキーで特定されるパブリックグループ分類の基本モデルを取得します。
void | PublicGroupCategoryMapper.insert(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ挿入します。
void | PublicGroupCategoryMapper.insert(Collection models) パブリックグループ分類の基本モデルを複数挿入します。
void | PublicGroupCategoryMapper.update(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ更新します。
void | PublicGroupCategoryMapper.update(Collection models) パブリックグループ分類の基本モデルを複数更新します。
void | PublicGroupCategoryMapper.delete(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ削除します。
void | PublicGroupCategoryMapper.delete(Collection models) パブリックグループ分類の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.group のメソッド
PublicGroupBaseModel | PublicGroupMapper.create(String publicGroupSetCode, String publicGroupCode) プライマリキーに該当するパブリックグループを生成します。
PublicGroupBaseModel | PublicGroupMapper.select(String publicGroupSetCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループの基本モデルを取得します。
void | PublicGroupMapper.insert(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ挿入します。
void | PublicGroupMapper.insert(Collection models) パブリックグループの基本モデルを複数挿入します。
void | PublicGroupMapper.update(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ更新します。
void | PublicGroupMapper.update(Collection models) パブリックグループの基本モデルを複数更新します。
void | PublicGroupMapper.delete(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ削除します。
void | PublicGroupMapper.delete(Collection models) パブリックグループの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion のメソッド
PublicGroupInclusionBaseModel | PublicGroupInclusionMapper.create(String publicGroupSetCode, String versionCode, String parentPublicGroupCode, String publicGroupCode) プライマリキーに該当するパブリックグループ内包を生成します。
PublicGroupInclusionBaseModel | PublicGroupInclusionMapper.select(String publicGroupSetCode, String versionCode, String parentPublicGroupCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループ内包の基本モデルを取得します。
void | PublicGroupInclusionMapper.insert(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ挿入します。
void | PublicGroupInclusionMapper.insert(Collection models) パブリックグループ内包の基本モデルを複数挿入します。
void | PublicGroupInclusionMapper.update(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ更新します。
void | PublicGroupInclusionMapper.update(Collection models) パブリックグループ内包の基本モデルを複数更新します。
void | PublicGroupInclusionMapper.delete(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ削除します。
void | PublicGroupInclusionMapper.delete(Collection models) パブリックグループ内包の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.set での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.set のメソッド
PublicGroupSetBaseModel | PublicGroupSetMapper.create(String publicGroupSetCode) プライマリキーに該当するパブリックグループセットを生成します。
PublicGroupSetBaseModel | PublicGroupSetMapper.select(String publicGroupSetCode) プライマリーキーで特定されるパブリックグループセットの基本モデルを取得します。
void | PublicGroupSetMapper.insert(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ挿入します。
void | PublicGroupSetMapper.insert(Collection models) パブリックグループセットの基本モデルを複数挿入します。
void | PublicGroupSetMapper.update(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ更新します。
void | PublicGroupSetMapper.update(Collection models) パブリックグループセットの基本モデルを複数更新します。
void | PublicGroupSetMapper.delete(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ削除します。
void | PublicGroupSetMapper.delete(Collection models) パブリックグループセットの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.version での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.version のメソッド
PublicGroupVersionBaseModel | PublicGroupVersionMapper.create(String publicGroupSetCode, String versionCode) プライマリキーに該当するパブリックグループ構成バージョンを生成します。
PublicGroupVersionBaseModel | PublicGroupVersionMapper.select(String publicGroupSetCode, String versionCode) プライマリーキーで特定されるパブリックグループ構成バージョンの基本モデルを取得します。
void | PublicGroupVersionMapper.insert(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ挿入します。
void | PublicGroupVersionMapper.insert(Collection models) パブリックグループ構成バージョンの基本モデルを複数挿入します。
void | PublicGroupVersionMapper.update(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ更新します。
void | PublicGroupVersionMapper.update(Collection models) パブリックグループ構成バージョンの基本モデルを複数更新します。
void | PublicGroupVersionMapper.delete(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ削除します。
void | PublicGroupVersionMapper.delete(Collection models) パブリックグループ構成バージョンの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.unit での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.unit のメソッド
UnitBaseModel | UnitMapper.create(String unitCode) プライマリキーに該当する単位を生成します。
UnitBaseModel | UnitMapper.select(String unitCode) プライマリーキーで特定される単位の基本モデルを取得します。
void | UnitMapper.insert(UnitBaseModel model) 単位の基本モデルを1つだけ挿入します。
void | UnitMapper.insert(Collection models) 単位の基本モデルを複数挿入します。
void | UnitMapper.update(UnitBaseModel model) 単位の基本モデルを1つだけ更新します。
void | UnitMapper.update(Collection models) 単位の基本モデルを複数更新します。
void | UnitMapper.delete(UnitBaseModel model) 単位の基本モデルを1つだけ削除します。
void | UnitMapper.delete(Collection models) 単位の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.user での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.user のメソッド
UserBaseModel | UserMapper.create(String userCode) プライマリキーに該当するユーザを生成します。
UserBaseModel | UserMapper.select(String userCode) プライマリーキーで特定されるユーザの基本モデルを取得します。
void | UserMapper.insert(UserBaseModel model) ユーザの基本モデルを1つだけ挿入します。
void | UserMapper.insert(Collection models) ユーザの基本モデルを複数挿入します。
void | UserMapper.update(UserBaseModel model) ユーザの基本モデルを1つだけ更新します。
void | UserMapper.update(Collection models) ユーザの基本モデルを複数更新します。
void | UserMapper.delete(UserBaseModel model) ユーザの基本モデルを1つだけ削除します。
void | UserMapper.delete(Collection models) ユーザの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.common.model での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.common.model のメソッド
static MapperFactory | MapperFactory.newInstance() マッパーファクトリを取得します。
abstract Mapper | MapperFactory.createMapper(String application, String entity, String group, String user) マッパーを生成します。
void | Mapper.init(String user, String group) マッパーを初期化します。
BaseModel | Mapper.createBaseModel(Map keys) このマッパーに該当する基本モデルを新規に生成します。
BaseModel | Mapper.select(Map keys) プライマリーキーで特定される基本モデルを取得します。
void | Mapper.notifyUpdate(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
void | Mapper.notifyDelete(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
void | Mapper.checkByBaseProperty(Relationship[] relationships, BaseModel target, BaseModel base) 基準項目によるリレーションシップの整合性制約をチェックします。
void | Mapper.close() マッパーをクローズします。
void | IntramartDBMapper.init(String user, String group) マッパーを初期化します。
protected BaseAccessor | IntramartDBMapper.createBaseAccessor(Map primary) このマッパーに該当する基本アクセサを新規に生成します。
BaseModel | IntramartDBMapper.createBaseModel(Map keys) このマッパーに該当する基本モデルを新規に生成します。
BaseModel | IntramartDBMapper.select(Map keys) プライマリーキーで特定される基本モデルを取得します。
protected Collection | IntramartDBMapper.select(Relationship relationship, Map keys) 外部キーで特定される基本モデルをすべて取得します。
protected void | IntramartDBMapper.insert(BaseModel model) 基本モデルを1つだけ挿入します。
protected void | IntramartDBMapper.insert(Collection models) 基本モデルを複数挿入します。
protected void | IntramartDBMapper.update(BaseModel model) 基本モデルを1つだけ更新します。
protected void | IntramartDBMapper.update(Collection models) 基本モデルを複数更新します。
protected void | IntramartDBMapper.delete(BaseModel model) 基本モデルを1つだけ削除します。
protected void | IntramartDBMapper.delete(Collection models) アクセサを複数削除します。
void | IntramartDBMapper.notifyUpdate(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
void | IntramartDBMapper.notifyDelete(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
void | IntramartDBMapper.checkByBaseProperty(Relationship[] relationships, BaseModel target, BaseModel base) 基準項目によるリレーションシップの整合性制約をチェックします。
void | IntramartDBMapper.close() マッパーをクローズします。

jp.co.intra_mart.system.security.datastore.inf での MapperException の使用

MapperException をスローする jp.co.intra_mart.system.security.datastore.inf のメソッド
RoleSummaryBaseModel | RoleSummaryMapper.create(String roleId, String summaryRoleId) プライマリキーに該当するロールサマリを生成します。
RoleSummaryBaseModel | RoleSummaryMapper.select(String roleId, String summaryRoleId) プライマリーキーで特定されるロールサマリの基本モデルを取得します。
void | RoleSummaryMapper.insert(RoleSummaryBaseModel model) ロールサマリの基本モデルを1つだけ挿入します。
void | RoleSummaryMapper.insert(Collection models) ロールサマリの基本モデルを複数挿入します。
void | RoleSummaryMapper.update(RoleSummaryBaseModel model) ロールサマリの基本モデルを1つだけ更新します。
void | RoleSummaryMapper.update(Collection models) ロールサマリの基本モデルを複数更新します。
void | RoleSummaryMapper.delete(RoleSummaryBaseModel model) ロールサマリの基本モデルを1つだけ削除します。
void | RoleSummaryMapper.delete(Collection models) ロールサマリの基本モデルを複数削除します。
RoleBaseModel | RoleMapper.create(String roleId) プライマリキーに該当するロールを生成します。
RoleBaseModel | RoleMapper.select(String roleId) プライマリーキーで特定されるロールの基本モデルを取得します。
void | RoleMapper.insert(RoleBaseModel model) ロールの基本モデルを1つだけ挿入します。
void | RoleMapper.insert(Collection models) ロールの基本モデルを複数挿入します。
void | RoleMapper.update(RoleBaseModel model) ロールの基本モデルを1つだけ更新します。
void | RoleMapper.update(Collection models) ロールの基本モデルを複数更新します。
void | RoleMapper.delete(RoleBaseModel model) ロールの基本モデルを1つだけ削除します。
void | RoleMapper.delete(Collection models) ロールの基本モデルを複数削除します。
RoleInclusionBaseModel | RoleInclusionMapper.create(String parentRoleId, String childRoleId) プライマリキーに該当するロール内包を生成します。
RoleInclusionBaseModel | RoleInclusionMapper.select(String parentRoleId, String childRoleId) プライマリーキーで特定されるロール内包の基本モデルを取得します。
void | RoleInclusionMapper.insert(RoleInclusionBaseModel model) ロール内包の基本モデルを1つだけ挿入します。
void | RoleInclusionMapper.insert(Collection models) ロール内包の基本モデルを複数挿入します。
void | RoleInclusionMapper.update(RoleInclusionBaseModel model) ロール内包の基本モデルを1つだけ更新します。
void | RoleInclusionMapper.update(Collection models) ロール内包の基本モデルを複数更新します。
void | RoleInclusionMapper.delete(RoleInclusionBaseModel model) ロール内包の基本モデルを1つだけ削除します。
void | RoleInclusionMapper.delete(Collection models) ロール内包の基本モデルを複数削除します。
MenuRoleBaseModel | MenuRoleMapper.create(String menuId, String roleId) プライマリキーに該当するメニューの利用権限を保有するロールを生成します。
MenuRoleBaseModel | MenuRoleMapper.select(String menuId, String roleId) プライマリーキーで特定されるメニューの利用権限を保有するロールの基本モデルを取得します。
void | MenuRoleMapper.insert(MenuRoleBaseModel model) メニューの利用権限を保有するロールの基本モデルを1つだけ挿入します。
void | MenuRoleMapper.insert(Collection models) メニューの利用権限を保有するロールの基本モデルを複数挿入します。
void | MenuRoleMapper.update(MenuRoleBaseModel model) メニューの利用権限を保有するロールの基本モデルを1つだけ更新します。
void | MenuRoleMapper.update(Collection models) メニューの利用権限を保有するロールの基本モデルを複数更新します。
void | MenuRoleMapper.delete(MenuRoleBaseModel model) メニューの利用権限を保有するロールの基本モデルを1つだけ削除します。
void | MenuRoleMapper.delete(Collection models) メニューの利用権限を保有するロールの基本モデルを複数削除します。
MenuPublicGroupBaseModel | MenuPublicGroupMapper.create(String menuId, String publicGroupSetCd, String publicGroupCd) プライマリキーに該当するメニューの利用権限を保有するパブリックグループを生成します。
MenuPublicGroupBaseModel | MenuPublicGroupMapper.select(String menuId, String publicGroupSetCd, String publicGroupCd) プライマリーキーで特定されるメニューの利用権限を保有するパブリックグループの基本モデルを取得します。
void | MenuPublicGroupMapper.insert(MenuPublicGroupBaseModel model) メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ挿入します。
void | MenuPublicGroupMapper.insert(Collection models) メニューの利用権限を保有するパブリックグループの基本モデルを複数挿入します。
void | MenuPublicGroupMapper.update(MenuPublicGroupBaseModel model) メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ更新します。
void | MenuPublicGroupMapper.update(Collection models) メニューの利用権限を保有するパブリックグループの基本モデルを複数更新します。
void | MenuPublicGroupMapper.delete(MenuPublicGroupBaseModel model) メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ削除します。
void | MenuPublicGroupMapper.delete(Collection models) メニューの利用権限を保有するパブリックグループの基本モデルを複数削除します。
MenuPostBaseModel | MenuPostMapper.create(String menuId, String companyCd, String postCd) プライマリキーに該当するメニューの利用権限を保有する役職を生成します。
MenuPostBaseModel | MenuPostMapper.select(String menuId, String companyCd, String postCd) プライマリーキーで特定されるメニューの利用権限を保有する役職の基本モデルを取得します。
void | MenuPostMapper.insert(MenuPostBaseModel model) メニューの利用権限を保有する役職の基本モデルを1つだけ挿入します。
void | MenuPostMapper.insert(Collection models) メニューの利用権限を保有する役職の基本モデルを複数挿入します。
void | MenuPostMapper.update(MenuPostBaseModel model) メニューの利用権限を保有する役職の基本モデルを1つだけ更新します。
void | MenuPostMapper.update(Collection models) メニューの利用権限を保有する役職の基本モデルを複数更新します。
void | MenuPostMapper.delete(MenuPostBaseModel model) メニューの利用権限を保有する役職の基本モデルを1つだけ削除します。
void | MenuPostMapper.delete(Collection models) メニューの利用権限を保有する役職の基本モデルを複数削除します。
MenuBaseModel | MenuMapper.create(String menuId) プライマリキーに該当するメニュー情報を生成します。
MenuBaseModel | MenuMapper.select(String menuId) プライマリーキーで特定されるメニュー情報の基本モデルを取得します。
void | MenuMapper.insert(MenuBaseModel model) メニュー情報の基本モデルを1つだけ挿入します。
void | MenuMapper.insert(Collection models) メニュー情報の基本モデルを複数挿入します。
void | MenuMapper.update(MenuBaseModel model) メニュー情報の基本モデルを1つだけ更新します。
void | MenuMapper.update(Collection models) メニュー情報の基本モデルを複数更新します。
void | MenuMapper.delete(MenuBaseModel model) メニュー情報の基本モデルを1つだけ削除します。
void | MenuMapper.delete(Collection models) メニュー情報の基本モデルを複数削除します。
MenuDepartmentBaseModel | MenuDepartmentMapper.create(String menuId, String companyCd, String departmentCd) プライマリキーに該当するメニューの利用権限を保有する組織を生成します。
MenuDepartmentBaseModel | MenuDepartmentMapper.select(String menuId, String companyCd, String departmentCd) プライマリーキーで特定されるメニューの利用権限を保有する組織の基本モデルを取得します。
void | MenuDepartmentMapper.insert(MenuDepartmentBaseModel model) メニューの利用権限を保有する組織の基本モデルを1つだけ挿入します。
void | MenuDepartmentMapper.insert(Collection models) メニューの利用権限を保有する組織の基本モデルを複数挿入します。
void | MenuDepartmentMapper.update(MenuDepartmentBaseModel model) メニューの利用権限を保有する組織の基本モデルを1つだけ更新します。
void | MenuDepartmentMapper.update(Collection models) メニューの利用権限を保有する組織の基本モデルを複数更新します。
void | MenuDepartmentMapper.delete(MenuDepartmentBaseModel model) メニューの利用権限を保有する組織の基本モデルを1つだけ削除します。
void | MenuDepartmentMapper.delete(Collection models) メニューの利用権限を保有する組織の基本モデルを複数削除します。
MenuArgumentBaseModel | MenuArgumentMapper.create(String menuId, String argumentName) プライマリキーに該当するメニューの保有する引数を生成します。
MenuArgumentBaseModel | MenuArgumentMapper.select(String menuId, String argumentName) プライマリーキーで特定されるメニューの保有する引数の基本モデルを取得します。
void | MenuArgumentMapper.insert(MenuArgumentBaseModel model) メニューの保有する引数の基本モデルを1つだけ挿入します。
void | MenuArgumentMapper.insert(Collection models) メニューの保有する引数の基本モデルを複数挿入します。
void | MenuArgumentMapper.update(MenuArgumentBaseModel model) メニューの保有する引数の基本モデルを1つだけ更新します。
void | MenuArgumentMapper.update(Collection models) メニューの保有する引数の基本モデルを複数更新します。
void | MenuArgumentMapper.delete(MenuArgumentBaseModel model) メニューの保有する引数の基本モデルを1つだけ削除します。
void | MenuArgumentMapper.delete(Collection models) メニューの保有する引数の基本モデルを複数削除します。
FavoriteMenuBaseModel | FavoriteMenuMapper.create(String userId, String menuId) プライマリキーに該当するアカウントが保有するメニューを生成します。
FavoriteMenuBaseModel | FavoriteMenuMapper.select(String userId, String menuId) プライマリーキーで特定されるアカウントが保有するメニューの基本モデルを取得します。
void | FavoriteMenuMapper.insert(FavoriteMenuBaseModel model) アカウントが保有するメニューの基本モデルを1つだけ挿入します。
void | FavoriteMenuMapper.insert(Collection models) アカウントが保有するメニューの基本モデルを複数挿入します。
void | FavoriteMenuMapper.update(FavoriteMenuBaseModel model) アカウントが保有するメニューの基本モデルを1つだけ更新します。
void | FavoriteMenuMapper.update(Collection models) アカウントが保有するメニューの基本モデルを複数更新します。
void | FavoriteMenuMapper.delete(FavoriteMenuBaseModel model) アカウントが保有するメニューの基本モデルを1つだけ削除します。
void | FavoriteMenuMapper.delete(Collection models) アカウントが保有するメニューの基本モデルを複数削除します。
CalendarInfoBaseModel | CalendarInfoMapper.create(String calendarId, String dataId) プライマリキーに該当するカレンダーが保有するデータを生成します。
CalendarInfoBaseModel | CalendarInfoMapper.select(String calendarId, String dataId) プライマリーキーで特定されるカレンダーが保有するデータの基本モデルを取得します。
void | CalendarInfoMapper.insert(CalendarInfoBaseModel model) カレンダーが保有するデータの基本モデルを1つだけ挿入します。
void | CalendarInfoMapper.insert(Collection models) カレンダーが保有するデータの基本モデルを複数挿入します。
void | CalendarInfoMapper.update(CalendarInfoBaseModel model) カレンダーが保有するデータの基本モデルを1つだけ更新します。
void | CalendarInfoMapper.update(Collection models) カレンダーが保有するデータの基本モデルを複数更新します。
void | CalendarInfoMapper.delete(CalendarInfoBaseModel model) カレンダーが保有するデータの基本モデルを1つだけ削除します。
void | CalendarInfoMapper.delete(Collection models) カレンダーが保有するデータの基本モデルを複数削除します。
BatchBaseModel | BatchMapper.create(String batchId) プライマリキーに該当するバッチ情報を生成します。
BatchBaseModel | BatchMapper.select(String batchId) プライマリーキーで特定されるバッチ情報の基本モデルを取得します。
void | BatchMapper.insert(BatchBaseModel model) バッチ情報の基本モデルを1つだけ挿入します。
void | BatchMapper.insert(Collection models) バッチ情報の基本モデルを複数挿入します。
void | BatchMapper.update(BatchBaseModel model) バッチ情報の基本モデルを1つだけ更新します。
void | BatchMapper.update(Collection models) バッチ情報の基本モデルを複数更新します。
void | BatchMapper.delete(BatchBaseModel model) バッチ情報の基本モデルを1つだけ削除します。
void | BatchMapper.delete(Collection models) バッチ情報の基本モデルを複数削除します。
AccountRoleBaseModel | AccountRoleMapper.create(String userId, String roleId) プライマリキーに該当するアカウントが保有するロールを生成します。
AccountRoleBaseModel | AccountRoleMapper.select(String userId, String roleId) プライマリーキーで特定されるアカウントが保有するロールの基本モデルを取得します。
void | AccountRoleMapper.insert(AccountRoleBaseModel model) アカウントが保有するロールの基本モデルを1つだけ挿入します。
void | AccountRoleMapper.insert(Collection models) アカウントが保有するロールの基本モデルを複数挿入します。
void | AccountRoleMapper.update(AccountRoleBaseModel model) アカウントが保有するロールの基本モデルを1つだけ更新します。
void | AccountRoleMapper.update(Collection models) アカウントが保有するロールの基本モデルを複数更新します。
void | AccountRoleMapper.delete(AccountRoleBaseModel model) アカウントが保有するロールの基本モデルを1つだけ削除します。
void | AccountRoleMapper.delete(Collection models) アカウントが保有するロールの基本モデルを複数削除します。
AccountBaseModel | AccountMapper.create(String userId) プライマリキーに該当するアカウントを生成します。
AccountBaseModel | AccountMapper.select(String userId) プライマリーキーで特定されるアカウントの基本モデルを取得します。
void | AccountMapper.insert(AccountBaseModel model) アカウントの基本モデルを1つだけ挿入します。
void | AccountMapper.insert(Collection models) アカウントの基本モデルを複数挿入します。
void | AccountMapper.update(AccountBaseModel model) アカウントの基本モデルを1つだけ更新します。
void | AccountMapper.update(Collection models) アカウントの基本モデルを複数更新します。
void | AccountMapper.delete(AccountBaseModel model) アカウントの基本モデルを1つだけ削除します。
void | AccountMapper.delete(Collection models) アカウントの基本モデルを複数削除します。
AccountAttributeBaseModel | AccountAttributeMapper.create(String userId, String attributeName) プライマリキーに該当するアカウントが保有する属性を生成します。
AccountAttributeBaseModel | AccountAttributeMapper.select(String userId, String attributeName) プライマリーキーで特定されるアカウントが保有する属性の基本モデルを取得します。
void | AccountAttributeMapper.insert(AccountAttributeBaseModel model) アカウントが保有する属性の基本モデルを1つだけ挿入します。
void | AccountAttributeMapper.insert(Collection models) アカウントが保有する属性の基本モデルを複数挿入します。
void | AccountAttributeMapper.update(AccountAttributeBaseModel model) アカウントが保有する属性の基本モデルを1つだけ更新します。
void | AccountAttributeMapper.update(Collection models) アカウントが保有する属性の基本モデルを複数更新します。
void | AccountAttributeMapper.delete(AccountAttributeBaseModel model) アカウントが保有する属性の基本モデルを1つだけ削除します。
void | AccountAttributeMapper.delete(Collection models) アカウントが保有する属性の基本モデルを複数削除します。
AccessControllerRoleBaseModel | AccessControllerRoleMapper.create(String accessControllerId, String roleId) プライマリキーに該当するアクセスコントローラの利用権限を保有するロールを生成します。
AccessControllerRoleBaseModel | AccessControllerRoleMapper.select(String accessControllerId, String roleId) プライマリーキーで特定されるアクセスコントローラの利用権限を保有するロールの基本モデルを取得します。
void | AccessControllerRoleMapper.insert(AccessControllerRoleBaseModel model) アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ挿入します。
void | AccessControllerRoleMapper.insert(Collection models) アクセスコントローラの利用権限を保有するロールの基本モデルを複数挿入します。
void | AccessControllerRoleMapper.update(AccessControllerRoleBaseModel model) アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ更新します。
void | AccessControllerRoleMapper.update(Collection models) アクセスコントローラの利用権限を保有するロールの基本モデルを複数更新します。
void | AccessControllerRoleMapper.delete(AccessControllerRoleBaseModel model) アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ削除します。
void | AccessControllerRoleMapper.delete(Collection models) アクセスコントローラの利用権限を保有するロールの基本モデルを複数削除します。
AccessControllerPublicGroupBaseModel | AccessControllerPublicGroupMapper.create(String accessControllerId, String publicGroupSetCd, String publicGroupCd) プライマリキーに該当するアクセスコントローラの利用権限を保有するパブリックグループを生成します。
AccessControllerPublicGroupBaseModel | AccessControllerPublicGroupMapper.select(String accessControllerId, String publicGroupSetCd, String publicGroupCd) プライマリーキーで特定されるアクセスコントローラの利用権限を保有するパブリックグループの基本モデルを取得します。
void | AccessControllerPublicGroupMapper.insert(AccessControllerPublicGroupBaseModel model) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ挿入します。
void | AccessControllerPublicGroupMapper.insert(Collection models) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを複数挿入します。
void | AccessControllerPublicGroupMapper.update(AccessControllerPublicGroupBaseModel model) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ更新します。
void | AccessControllerPublicGroupMapper.update(Collection models) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを複数更新します。
void | AccessControllerPublicGroupMapper.delete(AccessControllerPublicGroupBaseModel model) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ削除します。
void | AccessControllerPublicGroupMapper.delete(Collection models) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを複数削除します。
AccessControllerPostBaseModel | AccessControllerPostMapper.create(String accessControllerId, String companyCd, String postCd) プライマリキーに該当するアクセスコントローラの利用権限を保有する役職を生成します。
AccessControllerPostBaseModel | AccessControllerPostMapper.select(String accessControllerId, String companyCd, String postCd) プライマリーキーで特定されるアクセスコントローラの利用権限を保有する役職の基本モデルを取得します。
void | AccessControllerPostMapper.insert(AccessControllerPostBaseModel model) アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ挿入します。
void | AccessControllerPostMapper.insert(Collection models) アクセスコントローラの利用権限を保有する役職の基本モデルを複数挿入します。
void | AccessControllerPostMapper.update(AccessControllerPostBaseModel model) アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ更新します。
void | AccessControllerPostMapper.update(Collection models) アクセスコントローラの利用権限を保有する役職の基本モデルを複数更新します。
void | AccessControllerPostMapper.delete(AccessControllerPostBaseModel model) アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ削除します。
void | AccessControllerPostMapper.delete(Collection models) アクセスコントローラの利用権限を保有する役職の基本モデルを複数削除します。
AccessControllerBaseModel | AccessControllerMapper.create(String accessControllerId) プライマリキーに該当するアクセスコントローラ情報を生成します。
AccessControllerBaseModel | AccessControllerMapper.select(String accessControllerId) プライマリーキーで特定されるアクセスコントローラ情報の基本モデルを取得します。
void | AccessControllerMapper.insert(AccessControllerBaseModel model) アクセスコントローラ情報の基本モデルを1つだけ挿入します。
void | AccessControllerMapper.insert(Collection models) アクセスコントローラ情報の基本モデルを複数挿入します。
void | AccessControllerMapper.update(AccessControllerBaseModel model) アクセスコントローラ情報の基本モデルを1つだけ更新します。
void | AccessControllerMapper.update(Collection models) アクセスコントローラ情報の基本モデルを複数更新します。
void | AccessControllerMapper.delete(AccessControllerBaseModel model) アクセスコントローラ情報の基本モデルを1つだけ削除します。
void | AccessControllerMapper.delete(Collection models) アクセスコントローラ情報の基本モデルを複数削除します。
AccessControllerDepartmentBaseModel | AccessControllerDepartmentMapper.create(String accessControllerId, String companyCd, String departmentCd) プライマリキーに該当するアクセスコントローラの利用権限を保有する組織を生成します。
AccessControllerDepartmentBaseModel | AccessControllerDepartmentMapper.select(String accessControllerId, String companyCd, String departmentCd) プライマリーキーで特定されるアクセスコントローラの利用権限を保有する組織の基本モデルを取得します。
void | AccessControllerDepartmentMapper.insert(AccessControllerDepartmentBaseModel model) アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ挿入します。
void | AccessControllerDepartmentMapper.insert(Collection models) アクセスコントローラの利用権限を保有する組織の基本モデルを複数挿入します。
void | AccessControllerDepartmentMapper.update(AccessControllerDepartmentBaseModel model) アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ更新します。
void | AccessControllerDepartmentMapper.update(Collection models) アクセスコントローラの利用権限を保有する組織の基本モデルを複数更新します。
void | AccessControllerDepartmentMapper.delete(AccessControllerDepartmentBaseModel model) アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ削除します。
void | AccessControllerDepartmentMapper.delete(Collection models) アクセスコントローラの利用権限を保有する組織の基本モデルを複数削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.TermManagerException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.TermManagerException の使用

TermManagerException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.structure 期間情報などを扱うクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.structure での TermManagerException の使用

TermManagerException をスローする jp.co.intra_mart.foundation.datastore.common.structure のメソッド
static void | TermManager.validateTerm(Date activation, Date expiration) 指定された2つの日時が有効な期間を構成するかどうか調べます。
static void | TermManager.validateTerms(Term[] terms) 指定された期間配列が有効かどうかを調べます。
static Term[] | TermManager.subtract(Term[] term1, Term[] term2) 期間配列 term1 から 期間配列 term2 を差し引いた期間を返します。
static Term[] | TermManager.getOverlap(Term[] term1, Term[] term2) 2つの期間配列 term1 と term2 で重なっている期間を返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AccessorClosedException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス AccessorClosedException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException
すべての実装インタフェース:
Serializable
public class AccessorClosedException
extends AccessorException

アクセサのクローズ時に発生する例外クラス

アクセサがクローズされている場合に、以下のメソッドを呼び出された時にスローする。

  • setProperty(String, Object)

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
AccessorClosedException()
コンストラクタ
AccessorClosedException(String message)
コンストラクタ
AccessorClosedException(String message, Throwable cause)
コンストラクタ
AccessorClosedException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessorClosedException

public AccessorClosedException()
コンストラクタ

AccessorClosedException

public AccessorClosedException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

AccessorClosedException

public AccessorClosedException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

AccessorClosedException

public AccessorClosedException(String message,
                               Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccessorException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス AccessorException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccessorClosedException, AccessorIllegalPropertyValueException, DataNotFoundException, IllegalExtensionException
public class AccessorException
extends DataStoreApplicationException

アクセサで発生する例外の基底クラス

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
AccessorException()
コンストラクタ
AccessorException(String message)
コンストラクタ
AccessorException(String message, Throwable cause)
コンストラクタ
AccessorException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessorException

public AccessorException()
コンストラクタ

AccessorException

public AccessorException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

AccessorException

public AccessorException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

AccessorException

public AccessorException(String message,
                         Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessorIllegalPropertyValueException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス AccessorIllegalPropertyValueException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException
すべての実装インタフェース:
Serializable
public class AccessorIllegalPropertyValueException
extends AccessorException

アクセサのプロパティ設定に関する例外クラス

アクセサに不正な値が設定された場合にスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
AccessorIllegalPropertyValueException()
コンストラクタ
AccessorIllegalPropertyValueException(String message)
コンストラクタ
AccessorIllegalPropertyValueException(String message, Throwable cause)
コンストラクタ
AccessorIllegalPropertyValueException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessorIllegalPropertyValueException

public AccessorIllegalPropertyValueException()
コンストラクタ

AccessorIllegalPropertyValueException

public AccessorIllegalPropertyValueException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

AccessorIllegalPropertyValueException

public AccessorIllegalPropertyValueException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

AccessorIllegalPropertyValueException

public AccessorIllegalPropertyValueException(String message,
                                             Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessorSystemException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス AccessorSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.exception.FoundationRuntimeException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException
すべての実装インタフェース:
Serializable
public class AccessorSystemException
extends DataStoreSystemException

アクセサのプロパティに関する例外クラス

指定されたプロパティがアクセサに存在しない場合にスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
AccessorSystemException()
コンストラクタ
AccessorSystemException(String message)
コンストラクタ
AccessorSystemException(String message, Throwable cause)
コンストラクタ
AccessorSystemException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessorSystemException

public AccessorSystemException()
コンストラクタ

AccessorSystemException

public AccessorSystemException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

AccessorSystemException

public AccessorSystemException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

AccessorSystemException

public AccessorSystemException(String message,
                               Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BatchProcessException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス BatchProcessException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.datastore.exception.BatchProcessException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ExportInitializeException, ImportInitializeException
public class BatchProcessException
extends RuntimeException

バッチ実行時に処理エラーが発生したことを示すためにスローされます。

導入されたバージョン:
6.1
関連項目:
直列化された形式

コンストラクタの概要
BatchProcessException()
コンストラクタ
BatchProcessException(String message)
コンストラクタ
BatchProcessException(String message, Throwable cause)
コンストラクタ
BatchProcessException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BatchProcessException

public BatchProcessException()
コンストラクタ

BatchProcessException

public BatchProcessException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

BatchProcessException

public BatchProcessException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

BatchProcessException

public BatchProcessException(String message,
                             Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BatchSystemException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス BatchSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.datastore.exception.BatchSystemException
すべての実装インタフェース:
Serializable
public class BatchSystemException
extends RuntimeException

バッチ実行時にシステムエラーが発生したことを示すためにスローされます。

導入されたバージョン:
6.1
関連項目:
直列化された形式

コンストラクタの概要
BatchSystemException()
コンストラクタ
BatchSystemException(String message)
コンストラクタ
BatchSystemException(String message, Throwable cause)
コンストラクタ
BatchSystemException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BatchSystemException

public BatchSystemException()
コンストラクタ

BatchSystemException

public BatchSystemException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

BatchSystemException

public BatchSystemException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

BatchSystemException

public BatchSystemException(String message,
                            Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataNotFoundException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス DataNotFoundException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
IllegalLocaleException, IllegalTermException
public class DataNotFoundException
extends AccessorException

アクセサのプロパティ値の取得に関する例外クラス

指定されたプロパティに対する値が設定されていない場合にスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DataNotFoundException()
コンストラクタ
DataNotFoundException(String message)
コンストラクタ
DataNotFoundException(String message, Throwable cause)
コンストラクタ
DataNotFoundException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataNotFoundException

public DataNotFoundException()
コンストラクタ

DataNotFoundException

public DataNotFoundException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

DataNotFoundException

public DataNotFoundException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

DataNotFoundException

public DataNotFoundException(String message,
                             Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataStoreApplicationException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス DataStoreApplicationException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccessorException, EventNavigatorException, IllegalRelationshipException, ManagerException, MapperException, TermManagerException
public class DataStoreApplicationException
extends FoundationException

アプリケーション共通マスタで発生するアプリケーション例外の基底クラス

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DataStoreApplicationException()
コンストラクタ
DataStoreApplicationException(String message)
コンストラクタ
DataStoreApplicationException(String message, Throwable cause)
コンストラクタ
DataStoreApplicationException(Throwable cause)
コンストラクタ
メソッドの概要
String | getKey() エラーメッセージを作成するための識別子を取得します。
String[] | getValues() エラーメッセージで使用する置換用の文字列を取得します。
void | setKey(String key) エラーメッセージを作成するためのキーを取得します。
void | setValues(String[] values) エラーメッセージで使用する置換用の文字列を設定します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataStoreApplicationException

public DataStoreApplicationException()
コンストラクタ

DataStoreApplicationException

public DataStoreApplicationException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

DataStoreApplicationException

public DataStoreApplicationException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

DataStoreApplicationException

public DataStoreApplicationException(String message,
                                     Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
メソッドの詳細

setKey

public void setKey(String key)
エラーメッセージを作成するためのキーを取得します。

パラメータ:
key - メッセージキー

setValues

public void setValues(String[] values)
エラーメッセージで使用する置換用の文字列を設定します。

パラメータ:
values - 置換用文字列

getKey

public String getKey()
エラーメッセージを作成するための識別子を取得します。

戻り値:
メッセージキー

getValues

public String[] getValues()
エラーメッセージで使用する置換用の文字列を取得します。

戻り値:
置換用文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataStoreConfigException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス DataStoreConfigException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.exception.FoundationRuntimeException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException
すべての実装インタフェース:
Serializable
public class DataStoreConfigException
extends DataStoreSystemException

アプリケーション共通マスタの設定に関する例外クラス

アプリケーション共通マスタの設定に不整合がある場合にスローする。

関連項目:
直列化された形式

コンストラクタの概要
DataStoreConfigException()
詳細メッセージを指定しないで DataStoreConfigException を構築します。
DataStoreConfigException(String msg)
指定された詳細メッセージを持つ DataStoreConfigException を構築します。
DataStoreConfigException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PresentationPropertyException を構築します。
DataStoreConfigException(Throwable throwable)
この例外の発生原因となる例外を持つ PresentationPropertyException を構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataStoreConfigException

public DataStoreConfigException()
詳細メッセージを指定しないで DataStoreConfigException を構築します。

DataStoreConfigException

public DataStoreConfigException(String msg)
指定された詳細メッセージを持つ DataStoreConfigException を構築します。

パラメータ:
msg - 詳細メッセージ

DataStoreConfigException

public DataStoreConfigException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PresentationPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外

DataStoreConfigException

public DataStoreConfigException(Throwable throwable)
この例外の発生原因となる例外を持つ PresentationPropertyException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataStoreSystemException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス DataStoreSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.exception.FoundationRuntimeException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccessorSystemException, DataStoreConfigException, MapperDAOException
public class DataStoreSystemException
extends FoundationRuntimeException

アプリケーション共通マスタで発生するシステム例外の基底クラス

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DataStoreSystemException()
コンストラクタ
DataStoreSystemException(String message)
コンストラクタ
DataStoreSystemException(String message, Throwable cause)
コンストラクタ
DataStoreSystemException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataStoreSystemException

public DataStoreSystemException()
コンストラクタ

DataStoreSystemException

public DataStoreSystemException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

DataStoreSystemException

public DataStoreSystemException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

DataStoreSystemException

public DataStoreSystemException(String message,
                                Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IllegalExtensionException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス IllegalExtensionException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException
すべての実装インタフェース:
Serializable
public class IllegalExtensionException
extends AccessorException

拡張アクセサに関する例外クラス

拡張アクセサに対して不正な操作が行われた場合にスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
IllegalExtensionException()
コンストラクタ
IllegalExtensionException(String message)
コンストラクタ
IllegalExtensionException(String message, Throwable cause)
コンストラクタ
IllegalExtensionException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalExtensionException

public IllegalExtensionException()
コンストラクタ

IllegalExtensionException

public IllegalExtensionException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

IllegalExtensionException

public IllegalExtensionException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

IllegalExtensionException

public IllegalExtensionException(String message,
                                 Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IllegalLocaleException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス IllegalLocaleException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException
                            拡張 jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException
すべての実装インタフェース:
Serializable
public class IllegalLocaleException
extends DataNotFoundException

アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
IllegalLocaleException()
コンストラクタ
IllegalLocaleException(String message)
コンストラクタ
IllegalLocaleException(String message, Throwable cause)
コンストラクタ
IllegalLocaleException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalLocaleException

public IllegalLocaleException()
コンストラクタ

IllegalLocaleException

public IllegalLocaleException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

IllegalLocaleException

public IllegalLocaleException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

IllegalLocaleException

public IllegalLocaleException(String message,
                              Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IllegalRelationshipException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス IllegalRelationshipException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException
すべての実装インタフェース:
Serializable
public class IllegalRelationshipException
extends DataStoreApplicationException

リレーションシップに関する例外クラス

リレーションシップの整合性が正しくない場合にスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
IllegalRelationshipException()
コンストラクタ
IllegalRelationshipException(String message)
コンストラクタ
IllegalRelationshipException(String message, Throwable cause)
コンストラクタ
IllegalRelationshipException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalRelationshipException

public IllegalRelationshipException()
コンストラクタ

IllegalRelationshipException

public IllegalRelationshipException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

IllegalRelationshipException

public IllegalRelationshipException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

IllegalRelationshipException

public IllegalRelationshipException(String message,
                                    Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IllegalTermException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス IllegalTermException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException
                            拡張 jp.co.intra_mart.foundation.datastore.exception.IllegalTermException
すべての実装インタフェース:
Serializable
public class IllegalTermException
extends DataNotFoundException

アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
IllegalTermException()
コンストラクタ
IllegalTermException(String message)
コンストラクタ
IllegalTermException(String message, Throwable cause)
コンストラクタ
IllegalTermException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalTermException

public IllegalTermException()
コンストラクタ

IllegalTermException

public IllegalTermException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

IllegalTermException

public IllegalTermException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

IllegalTermException

public IllegalTermException(String message,
                            Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ImportException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス ImportException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.datastore.exception.ImportException
すべての実装インタフェース:
Serializable
public class ImportException
extends Exception

アプリケーション共通マスタのインポートに関する例外クラス

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
ImportException()
コンストラクタ
ImportException(String message)
コンストラクタ
ImportException(String message, Throwable cause)
コンストラクタ
ImportException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ImportException

public ImportException()
コンストラクタ

ImportException

public ImportException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

ImportException

public ImportException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

ImportException

public ImportException(String message,
                       Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ManagerException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス ManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.ManagerException
すべての実装インタフェース:
Serializable
public class ManagerException
extends DataStoreApplicationException

マネージャに関する例外クラス

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
ManagerException()
コンストラクタ
ManagerException(String message)
コンストラクタ
ManagerException(String message, Throwable cause)
コンストラクタ
ManagerException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ManagerException

public ManagerException()
コンストラクタ

ManagerException

public ManagerException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

ManagerException

public ManagerException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

ManagerException

public ManagerException(String message,
                        Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MapperDAOException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス MapperDAOException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.exception.FoundationRuntimeException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.MapperDAOException
すべての実装インタフェース:
Serializable
public class MapperDAOException
extends DataStoreSystemException

マッパーのデータベース接続に関する例外クラス

マッパーがデータベース接続で問題が発生した場合にスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
MapperDAOException()
コンストラクタ
MapperDAOException(String message)
コンストラクタ
MapperDAOException(String message, Throwable cause)
コンストラクタ
MapperDAOException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MapperDAOException

public MapperDAOException()
コンストラクタ

MapperDAOException

public MapperDAOException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

MapperDAOException

public MapperDAOException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

MapperDAOException

public MapperDAOException(String message,
                          Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MapperException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス MapperException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.MapperException
すべての実装インタフェース:
Serializable
public class MapperException
extends DataStoreApplicationException

マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
MapperException()
コンストラクタ
MapperException(String message)
コンストラクタ
MapperException(String message, Throwable cause)
コンストラクタ
MapperException(Throwable cause)
コンストラクタ
メソッドの概要
protected String | getBaseName() メッセージを取得するためのリソースバンドルの基底名を返します。
static void | setBaseName(String baseName) リソースバンドルの基底名を設定します。
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MapperException

public MapperException()
コンストラクタ

MapperException

public MapperException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

MapperException

public MapperException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

MapperException

public MapperException(String message,
                       Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
メソッドの詳細

getBaseName

protected String getBaseName()
メッセージを取得するためのリソースバンドルの基底名を返します。

戻り値:
基底名

setBaseName

public static void setBaseName(String baseName)
リソースバンドルの基底名を設定します。

パラメータ:
baseName - 基底名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.exception (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.exception
例外
AccessorClosedException
AccessorException
AccessorIllegalPropertyValueException
AccessorSystemException
BatchProcessException
BatchSystemException
DataNotFoundException
DataStoreApplicationException
DataStoreConfigException
DataStoreSystemException
IllegalExtensionException
IllegalLocaleException
IllegalRelationshipException
IllegalTermException
ImportException
ManagerException
MapperDAOException
MapperException
TermManagerException


jp.co.intra_mart.foundation.datastore.exception (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exception

アプリケーション共通マスタで発生する例外クラスを提供します。

参照:
説明

例外の概要
AccessorClosedException | アクセサのクローズ時に発生する例外クラス アクセサがクローズされている場合に、以下のメソッドを呼び出された時にスローする。
AccessorException | アクセサで発生する例外の基底クラス
AccessorIllegalPropertyValueException | アクセサのプロパティ設定に関する例外クラス アクセサに不正な値が設定された場合にスローする。
AccessorSystemException | アクセサのプロパティに関する例外クラス 指定されたプロパティがアクセサに存在しない場合にスローする。
BatchProcessException | バッチ実行時に処理エラーが発生したことを示すためにスローされます。
BatchSystemException | バッチ実行時にシステムエラーが発生したことを示すためにスローされます。
DataNotFoundException | アクセサのプロパティ値の取得に関する例外クラス 指定されたプロパティに対する値が設定されていない場合にスローする。
DataStoreApplicationException | アプリケーション共通マスタで発生するアプリケーション例外の基底クラス
DataStoreConfigException | アプリケーション共通マスタの設定に関する例外クラス アプリケーション共通マスタの設定に不整合がある場合にスローする。
DataStoreSystemException | アプリケーション共通マスタで発生するシステム例外の基底クラス
IllegalExtensionException | 拡張アクセサに関する例外クラス 拡張アクセサに対して不正な操作が行われた場合にスローする。
IllegalLocaleException | アクセサが保持する言語に関する例外クラス アクセサが保持していない言語を要求された場合にスローする。
IllegalRelationshipException | リレーションシップに関する例外クラス リレーションシップの整合性が正しくない場合にスローする。
IllegalTermException | アクセサが保持する期間に関する例外クラス アクセサが保持しない日時または期間が指定されたときにスローする。
ImportException | アプリケーション共通マスタのインポートに関する例外クラス
ManagerException | マネージャに関する例外クラス
MapperDAOException | マッパーのデータベース接続に関する例外クラス マッパーがデータベース接続で問題が発生した場合にスローする。
MapperException | マッパーに関する例外クラス マッパーの処理中に問題が発生した場合にスローする。
TermManagerException | 期間に関する例外クラス

パッケージ jp.co.intra_mart.foundation.datastore.exception の説明

アプリケーション共通マスタで発生する例外クラスを提供します。


jp.co.intra_mart.foundation.datastore.exception クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.exception.FoundationException
          • class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
            • class jp.co.intra_mart.foundation.datastore.exception.AccessorException
              • class jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException
              • class jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException
              • class jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException
                • class jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException
                • class jp.co.intra_mart.foundation.datastore.exception.IllegalTermException
              • class jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException
            • class jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException
            • class jp.co.intra_mart.foundation.datastore.exception.ManagerException
            • class jp.co.intra_mart.foundation.datastore.exception.MapperException
            • class jp.co.intra_mart.foundation.datastore.exception.TermManagerException
        • class jp.co.intra_mart.foundation.datastore.exception.ImportException
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.datastore.exception.BatchProcessException
          • class jp.co.intra_mart.foundation.datastore.exception.BatchSystemException
          • class jp.co.intra_mart.foundation.exception.FoundationRuntimeException
            • class jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException
              • class jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException
              • class jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException
              • class jp.co.intra_mart.foundation.datastore.exception.MapperDAOException


パッケージ jp.co.intra_mart.foundation.datastore.exception の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.exception の使用

jp.co.intra_mart.foundation.datastore.exception を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category | 分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.currency | 通貨情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item | 商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category | 商品カテゴリ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_template | 商品テンプレート属性情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group | プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.unit | 商品単位情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category | 会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company | 会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion | 組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version | 会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.deal | 取扱情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.department | 取扱組織権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.detail | 取扱詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group | 取扱パブリックグループ権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.role | 取扱ロール権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.attribute | 商品属性情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue | 商品カタログ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.item | 商品情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach | 商品分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.category | 商品カテゴリ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.type | 商品カテゴリ種別情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail | 商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.template | 商品テンプレート情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach | プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group | プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach | パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category | パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion | パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set | パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version | パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.unit | 単位情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.foundation.datastore.common.structure | 期間情報などを扱うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter | アプリケーション共通マスタのエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.common.config | エクスポート設定の解釈を行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer | アプリケーション共通マスタのインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.common.config | インポート定義情報の解釈を行うクラスを提供します。
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.system.security.datastore.inf |

jp.co.intra_mart.foundation.datastore.application.domain.category により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ImportException
アプリケーション共通マスタのインポートに関する例外クラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.domain.currency により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.domain.deal により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.domain.item により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ImportException
アプリケーション共通マスタのインポートに関する例外クラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.domain.item_category により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ImportException
アプリケーション共通マスタのインポートに関する例外クラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.domain.item_template により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ImportException
アプリケーション共通マスタのインポートに関する例外クラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.domain.private_group により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ImportException
アプリケーション共通マスタのインポートに関する例外クラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.domain.unit により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.domain.user により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ImportException
アプリケーション共通マスタのインポートに関する例外クラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.model.category.category_class により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.category.detail により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.company.attach により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.company.category により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.company.company により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.company.department により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.company.main により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.company.post により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.company.version により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.deal.deal により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.deal.department により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.deal.detail により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.deal.role により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.item.attribute により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.item.item により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.item_category.category により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.item_category.type により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.item_template.template により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.private_group.group により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.public_group.set により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.public_group.version により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.unit により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.user により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.common.accessor により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorClosedException
アクセサのクローズ時に発生する例外クラス

アクセサがクローズされている場合に、以下のメソッドを呼び出された時にスローする。
AccessorIllegalPropertyValueException
アクセサのプロパティ設定に関する例外クラス

アクセサに不正な値が設定された場合にスローする。
DataNotFoundException
アクセサのプロパティ値の取得に関する例外クラス

指定されたプロパティに対する値が設定されていない場合にスローする。
IllegalExtensionException
拡張アクセサに関する例外クラス

拡張アクセサに対して不正な操作が行われた場合にスローする。
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。

jp.co.intra_mart.foundation.datastore.common.model により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
DataStoreSystemException
アプリケーション共通マスタで発生するシステム例外の基底クラス
IllegalExtensionException
拡張アクセサに関する例外クラス

拡張アクセサに対して不正な操作が行われた場合にスローする。
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.common.structure により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
TermManagerException
期間に関する例外クラス

jp.co.intra_mart.foundation.datastore.exception により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
DataNotFoundException
アクセサのプロパティ値の取得に関する例外クラス

指定されたプロパティに対する値が設定されていない場合にスローする。
DataStoreApplicationException
アプリケーション共通マスタで発生するアプリケーション例外の基底クラス
DataStoreSystemException
アプリケーション共通マスタで発生するシステム例外の基底クラス

jp.co.intra_mart.foundation.datastore.exporter により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
BatchProcessException
バッチ実行時に処理エラーが発生したことを示すためにスローされます。

jp.co.intra_mart.foundation.datastore.exporter.common.config により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
BatchProcessException
バッチ実行時に処理エラーが発生したことを示すためにスローされます。

jp.co.intra_mart.foundation.datastore.importer により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
BatchProcessException
バッチ実行時に処理エラーが発生したことを示すためにスローされます。

jp.co.intra_mart.foundation.datastore.importer.common.config により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
BatchProcessException
バッチ実行時に処理エラーが発生したことを示すためにスローされます。

jp.co.intra_mart.foundation.navigator により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
DataStoreApplicationException
アプリケーション共通マスタで発生するアプリケーション例外の基底クラス

jp.co.intra_mart.system.security.datastore.inf により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


TermManagerException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス TermManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.TermManagerException
すべての実装インタフェース:
Serializable
public class TermManagerException
extends DataStoreApplicationException

期間に関する例外クラス

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
TermManagerException()
コンストラクタ
TermManagerException(String message)
コンストラクタ
TermManagerException(String message, Throwable cause)
コンストラクタ
TermManagerException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

TermManagerException

public TermManagerException()
コンストラクタ

TermManagerException

public TermManagerException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

TermManagerException

public TermManagerException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

TermManagerException

public TermManagerException(String message,
                            Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient の使用

AbstractExportManagerClient を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exporter.company | 会社・組織関連の情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.public_group | パブリックグループ情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.user | ユーザ関連の情報のエクスポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.exporter.company での AbstractExportManagerClient の使用

jp.co.intra_mart.foundation.datastore.exporter.company での AbstractExportManagerClient のサブクラス
class | CompanyExportManagerClient 会社情報のエクスポートを行います。
class | CompanyPostExportManagerClient 会社役職情報のエクスポートを行います。

jp.co.intra_mart.foundation.datastore.exporter.public_group での AbstractExportManagerClient の使用

jp.co.intra_mart.foundation.datastore.exporter.public_group での AbstractExportManagerClient のサブクラス
 class PublicGroupExportManagerClient
パブリックグループ情報のエクスポートを行います。

jp.co.intra_mart.foundation.datastore.exporter.user での AbstractExportManagerClient の使用

jp.co.intra_mart.foundation.datastore.exporter.user での AbstractExportManagerClient のサブクラス
class | UserAttachExportManagerClient ユーザ所属情報のエクスポートを行います。
class | UserProfileExportManagerClient ユーザ情報のエクスポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.ExportInitializeException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.ExportInitializeException の使用

ExportInitializeException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exporter.common.config エクスポート設定の解釈を行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.exporter.common.config での ExportInitializeException の使用

jp.co.intra_mart.foundation.datastore.exporter.common.config での ExportInitializeException のサブクラス
 class ExportConfigurationReaderException
エクスポート設定の読み込みでエラーが発生したことを示すためにスローされます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.exporter.ExportManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.exporter.ExportManager の使用

ExportManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exporter | アプリケーション共通マスタのエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.company | 会社・組織関連の情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.public_group | パブリックグループ情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.user | ユーザ関連の情報のエクスポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.exporter での ExportManager の使用

ExportManager を実装している jp.co.intra_mart.foundation.datastore.exporter のクラス
 class ExportManagerImpl
エクスポートマネージャーの汎用的な実装です。

ExportManager を返す jp.co.intra_mart.foundation.datastore.exporter のメソッド
protected abstract  ExportManager AbstractExportManagerClient.getExportManager()
エクスポートマネージャーのインスタンスを取得します。

ExportManager 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.exporter のメソッド
protected void | AbstractExportManagerClient.setName(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義された処理名をマネージャーに設定します。
protected void | AbstractExportManagerClient.setFormat(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたエクスポートデータのフォーマットをマネージャーに設定します。
protected void | AbstractExportManagerClient.setDate(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義された日付をマネージャーに設定します。
protected void | AbstractExportManagerClient.setEncoding(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたエクスポートデータのエンコーディング情報をマネージャーに設定します。
protected void | AbstractExportManagerClient.setSize(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたエクスポート単位のデータ数をマネージャーに設定します。
protected void | AbstractExportManagerClient.setExecuteUser(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義された実行ユーザコードをマネージャーに設定します。
protected void | AbstractExportManagerClient.setFilter(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたフィルタの情報をマネージャーに設定します。
protected void | AbstractExportManagerClient.setParameters(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたパラメータ情報をマネージャーに設定します。

jp.co.intra_mart.foundation.datastore.exporter.company での ExportManager の使用

ExportManager を実装している jp.co.intra_mart.foundation.datastore.exporter.company のクラス
class | CompanyExportManager 会社情報のエクスポートを行います。
class | CompanyPostExportManager 会社役職情報のエクスポートを行います。

ExportManager を返す jp.co.intra_mart.foundation.datastore.exporter.company のメソッド
protected ExportManager | CompanyPostExportManagerClient.getExportManager()
protected ExportManager | CompanyExportManagerClient.getExportManager()

jp.co.intra_mart.foundation.datastore.exporter.public_group での ExportManager の使用

ExportManager を実装している jp.co.intra_mart.foundation.datastore.exporter.public_group のクラス
 class PublicGroupExportManager
パブリックグループ情報のエクスポートを行います。

ExportManager を返す jp.co.intra_mart.foundation.datastore.exporter.public_group のメソッド
protected  ExportManager PublicGroupExportManagerClient.getExportManager()

jp.co.intra_mart.foundation.datastore.exporter.user での ExportManager の使用

ExportManager を実装している jp.co.intra_mart.foundation.datastore.exporter.user のクラス
class | UserAttachExportManager ユーザ所属情報のエクスポートを行います。
class | UserProfileExportManager ユーザ情報のエクスポートを行います。

ExportManager を返す jp.co.intra_mart.foundation.datastore.exporter.user のメソッド
protected ExportManager | UserProfileExportManagerClient.getExportManager()
protected ExportManager | UserAttachExportManagerClient.getExportManager()

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient の使用

ExportManagerClient を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exporter | アプリケーション共通マスタのエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.company | 会社・組織関連の情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.public_group | パブリックグループ情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.user | ユーザ関連の情報のエクスポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.exporter での ExportManagerClient の使用

ExportManagerClient を実装している jp.co.intra_mart.foundation.datastore.exporter のクラス
 class AbstractExportManagerClient
エクスポートマネージャークライアントの汎用的な実装です。

jp.co.intra_mart.foundation.datastore.exporter.company での ExportManagerClient の使用

ExportManagerClient を実装している jp.co.intra_mart.foundation.datastore.exporter.company のクラス
class | CompanyExportManagerClient 会社情報のエクスポートを行います。
class | CompanyPostExportManagerClient 会社役職情報のエクスポートを行います。

jp.co.intra_mart.foundation.datastore.exporter.public_group での ExportManagerClient の使用

ExportManagerClient を実装している jp.co.intra_mart.foundation.datastore.exporter.public_group のクラス
 class PublicGroupExportManagerClient
パブリックグループ情報のエクスポートを行います。

jp.co.intra_mart.foundation.datastore.exporter.user での ExportManagerClient の使用

ExportManagerClient を実装している jp.co.intra_mart.foundation.datastore.exporter.user のクラス
class | UserAttachExportManagerClient ユーザ所属情報のエクスポートを行います。
class | UserProfileExportManagerClient ユーザ情報のエクスポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl の使用

jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.Filter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.Filter の使用

Filter を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exporter | アプリケーション共通マスタのエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.common.config | エクスポート設定の解釈を行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.company | 会社・組織関連の情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.public_group | パブリックグループ情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.user | ユーザ関連の情報のエクスポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.exporter での Filter の使用

Filter 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.exporter のメソッド
void | ExportManagerImpl.setFilter(Filter filter) エクスポートフィルタを設定します。
void | ExportManager.setFilter(Filter filter) エクスポート対象を絞り込むためのフィルタを設定します。

jp.co.intra_mart.foundation.datastore.exporter.common.config での Filter の使用

Filter を返す jp.co.intra_mart.foundation.datastore.exporter.common.config のメソッド
 Filter ExportConfigurationReader.getFilter()
エクスポートのフィルタ情報を取得します。

jp.co.intra_mart.foundation.datastore.exporter.company での Filter の使用

Filter 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.exporter.company のメソッド
void | CompanyPostExportManager.setFilter(Filter filter)
void | CompanyExportManager.setFilter(Filter filter)

jp.co.intra_mart.foundation.datastore.exporter.public_group での Filter の使用

Filter 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.exporter.public_group のメソッド
 void PublicGroupExportManager.setFilter(Filter filter)

jp.co.intra_mart.foundation.datastore.exporter.user での Filter の使用

Filter 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.exporter.user のメソッド
void | UserProfileExportManager.setFilter(Filter filter)
void | UserAttachExportManager.setFilter(Filter filter)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader の使用

ExportConfigurationReader を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exporter | アプリケーション共通マスタのエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.company | 会社・組織関連の情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.public_group | パブリックグループ情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.user | ユーザ関連の情報のエクスポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.exporter での ExportConfigurationReader の使用

ExportConfigurationReader を返す jp.co.intra_mart.foundation.datastore.exporter のメソッド
protected abstract  ExportConfigurationReader AbstractExportManagerClient.getConfigurationReader(InputStream inputStream)
入力ストリームからエクスポート設定情報を取得します。

ExportConfigurationReader 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.exporter のメソッド
protected void | AbstractExportManagerClient.setName(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義された処理名をマネージャーに設定します。
protected void | AbstractExportManagerClient.setFormat(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたエクスポートデータのフォーマットをマネージャーに設定します。
protected void | AbstractExportManagerClient.setDate(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義された日付をマネージャーに設定します。
protected void | AbstractExportManagerClient.setEncoding(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたエクスポートデータのエンコーディング情報をマネージャーに設定します。
protected void | AbstractExportManagerClient.setSize(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたエクスポート単位のデータ数をマネージャーに設定します。
protected void | AbstractExportManagerClient.setExecuteUser(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義された実行ユーザコードをマネージャーに設定します。
protected void | AbstractExportManagerClient.setFilter(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたフィルタの情報をマネージャーに設定します。
protected void | AbstractExportManagerClient.setParameters(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたパラメータ情報をマネージャーに設定します。

jp.co.intra_mart.foundation.datastore.exporter.company での ExportConfigurationReader の使用

ExportConfigurationReader を返す jp.co.intra_mart.foundation.datastore.exporter.company のメソッド
protected ExportConfigurationReader | CompanyPostExportManagerClient.getConfigurationReader(InputStream inputStream)
protected ExportConfigurationReader | CompanyExportManagerClient.getConfigurationReader(InputStream inputStream)

jp.co.intra_mart.foundation.datastore.exporter.public_group での ExportConfigurationReader の使用

ExportConfigurationReader を返す jp.co.intra_mart.foundation.datastore.exporter.public_group のメソッド
protected  ExportConfigurationReader PublicGroupExportManagerClient.getConfigurationReader(InputStream inputStream)

jp.co.intra_mart.foundation.datastore.exporter.user での ExportConfigurationReader の使用

ExportConfigurationReader を返す jp.co.intra_mart.foundation.datastore.exporter.user のメソッド
protected ExportConfigurationReader | UserProfileExportManagerClient.getConfigurationReader(InputStream inputStream)
protected ExportConfigurationReader | UserAttachExportManagerClient.getConfigurationReader(InputStream inputStream)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReaderException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReaderException の使用

jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReaderException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ExportConfigurationReader (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter.common.config
インタフェース ExportConfigurationReader

public interface ExportConfigurationReader

エクスポート設定情報の読込みを行います。

導入されたバージョン:
6.1

メソッドの概要
Date | getDate() 日付を取得します。
String | getEncoding() エクスポートデータのエンコーディング情報を取得します。
String | getExecuteUser() 実行ユーザコードを取得します。
String[] | getExtensionParameterNames() パラメータ名の一覧を取得します。
String | getExtensionParameterValue(String key) 指定されたキーに対するパラメータ値を取得します。
Filter | getFilter() エクスポートのフィルタ情報を取得します。
String | getFormat() エクスポートデータのフォーマットを取得します。
String | getName() エクスポート処理名を取得します。
String | getOutputPath() エクスポートデータを出力するファイルパスを取得します。
int | getSize() エクスポート単位のデータ数を取得します。
void | initialize(String rootName) 初期化を行います。

メソッドの詳細

initialize

public void initialize(String rootName)
初期化を行います。
指定された要素内に定義された設定情報を読込みます。

パラメータ:
rootName - 設定情報を定義するルート要素の名前

getName

public String getName()
エクスポート処理名を取得します。

戻り値:
エクスポート処理名
例外:
ExportConfigurationReaderException - 設定情報の定義が不正な場合

getFormat

public String getFormat()
エクスポートデータのフォーマットを取得します。

戻り値:
エクスポートデータのフォーマット
例外:
ExportConfigurationReaderException - 設定情報の定義が不正な場合

getDate

public Date getDate()
日付を取得します。

戻り値:
日付
例外:
ExportConfigurationReaderException - 設定情報の定義が不正な場合

getEncoding

public String getEncoding()
エクスポートデータのエンコーディング情報を取得します。

戻り値:
エクスポートデータのエンコーディング情報
例外:
ExportConfigurationReaderException - 設定情報の定義が不正な場合

getExecuteUser

public String getExecuteUser()
実行ユーザコードを取得します。

戻り値:
実行ユーザコード
例外:
ExportConfigurationReaderException - 設定情報の定義が不正な場合

getOutputPath

public String getOutputPath()
エクスポートデータを出力するファイルパスを取得します。

戻り値:
出力ファイルパス
例外:
ExportConfigurationReaderException - 設定情報の定義が不正な場合

getSize

public int getSize()
エクスポート単位のデータ数を取得します。

戻り値:
エクスポート単位となるデータ数
例外:
ExportConfigurationReaderException - 設定情報の定義が不正な場合

getFilter

public Filter getFilter()
エクスポートのフィルタ情報を取得します。

戻り値:
エクスポートのフィルタ
例外:
ExportConfigurationReaderException - 設定情報の定義が不正な場合

getExtensionParameterNames

public String[] getExtensionParameterNames()
パラメータ名の一覧を取得します。

戻り値:
パラメータ名の一覧

getExtensionParameterValue

public String getExtensionParameterValue(String key)
指定されたキーに対するパラメータ値を取得します。

パラメータ:
key - キー
戻り値:
パラメータ値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExportConfigurationReaderException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter.common.config
クラス ExportConfigurationReaderException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.datastore.exception.BatchProcessException
                    拡張 jp.co.intra_mart.foundation.datastore.exporter.ExportInitializeException
                        拡張 jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReaderException
すべての実装インタフェース:
Serializable
public class ExportConfigurationReaderException
extends ExportInitializeException

エクスポート設定の読み込みでエラーが発生したことを示すためにスローされます。

導入されたバージョン:
6.1
関連項目:
直列化された形式

コンストラクタの概要
ExportConfigurationReaderException(String message)
コンストラクタ
ExportConfigurationReaderException(String message, Throwable cause)
コンストラクタ
ExportConfigurationReaderException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExportConfigurationReaderException

public ExportConfigurationReaderException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

ExportConfigurationReaderException

public ExportConfigurationReaderException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

ExportConfigurationReaderException

public ExportConfigurationReaderException(String message,
                                          Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.exporter.common.config (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.exporter.common.config
インタフェース
ExportConfigurationReader
例外
ExportConfigurationReaderException


jp.co.intra_mart.foundation.datastore.exporter.common.config (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exporter.common.config

エクスポート設定の解釈を行うクラスを提供します。

参照:
説明

インタフェースの概要
ExportConfigurationReader エクスポート設定情報の読込みを行います。

例外の概要
ExportConfigurationReaderException エクスポート設定の読み込みでエラーが発生したことを示すためにスローされます。

パッケージ jp.co.intra_mart.foundation.datastore.exporter.common.config の説明

エクスポート設定の解釈を行うクラスを提供します。


jp.co.intra_mart.foundation.datastore.exporter.common.config クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exporter.common.config の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.datastore.exception.BatchProcessException
            • class jp.co.intra_mart.foundation.datastore.exporter.ExportInitializeException
              • class jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReaderException

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader


パッケージ jp.co.intra_mart.foundation.datastore.exporter.common.config の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.exporter.common.config の使用

jp.co.intra_mart.foundation.datastore.exporter.common.config を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exporter | アプリケーション共通マスタのエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.company | 会社・組織関連の情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.public_group | パブリックグループ情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.user | ユーザ関連の情報のエクスポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.exporter により使用される jp.co.intra_mart.foundation.datastore.exporter.common.config のクラス
ExportConfigurationReader
エクスポート設定情報の読込みを行います。

jp.co.intra_mart.foundation.datastore.exporter.company により使用される jp.co.intra_mart.foundation.datastore.exporter.common.config のクラス
ExportConfigurationReader
エクスポート設定情報の読込みを行います。

jp.co.intra_mart.foundation.datastore.exporter.public_group により使用される jp.co.intra_mart.foundation.datastore.exporter.common.config のクラス
ExportConfigurationReader
エクスポート設定情報の読込みを行います。

jp.co.intra_mart.foundation.datastore.exporter.user により使用される jp.co.intra_mart.foundation.datastore.exporter.common.config のクラス
ExportConfigurationReader
エクスポート設定情報の読込みを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager の使用

jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient の使用

jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager の使用

jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient の使用

jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CompanyExportManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter.company
クラス CompanyExportManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager
すべての実装インタフェース:
ExportManager
public class CompanyExportManager
extends Object
implements ExportManager

会社情報のエクスポートを行います。

導入されたバージョン:
6.1

コンストラクタの概要
CompanyExportManager()
コンストラクタ 会社情報エクスポートマネージャーのインスタンスを生成します。
メソッドの概要
void | execute(OutputStream outputStream) エクスポートを実行します。
void | execute(String path) エクスポートを実行します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) エクスポートデータのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザコードを設定します。
void | setFilter(Filter filter) エクスポート対象を絞り込むためのフィルタを設定します。
void | setFormat(String format) エクスポートデータのフォーマットを設定します。
void | setName(String name) エクスポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setSize(int size) エクスポート単位のデータ数を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyExportManager

public CompanyExportManager()
コンストラクタ 会社情報エクスポートマネージャーのインスタンスを生成します。

メソッドの詳細

execute

public void execute(String path)
インタフェース ExportManager の記述:
エクスポートを実行します。
指定されたパスにエクスポートした情報を出力します。

定義:
インタフェース ExportManager 内の execute
パラメータ:
path - 出力パス

execute

public void execute(OutputStream outputStream)
インタフェース ExportManager の記述:
エクスポートを実行します。
指定された出力ストリームにエクスポートした情報を出力します。

定義:
インタフェース ExportManager 内の execute
パラメータ:
outputStream - 出力ストリーム

setDate

public void setDate(Date date)
インタフェース ExportManager の記述:
日付を設定します。
設定可能な日付はシステムの有効期間内に限られます。

定義:
インタフェース ExportManager 内の setDate
パラメータ:
date - 日付
関連項目:
DateUtil#getMinDate(), DateUtil#getMaxDate()

setEncoding

public void setEncoding(String encoding)
インタフェース ExportManager の記述:
エクスポートデータのエンコーディングを設定します。

定義:
インタフェース ExportManager 内の setEncoding
パラメータ:
encoding - エンコーディング

setExecuteUser

public void setExecuteUser(String user)
インタフェース ExportManager の記述:
実行ユーザコードを設定します。

定義:
インタフェース ExportManager 内の setExecuteUser
パラメータ:
user - 実行ユーザ

setFilter

public void setFilter(Filter filter)
インタフェース ExportManager の記述:
エクスポート対象を絞り込むためのフィルタを設定します。

定義:
インタフェース ExportManager 内の setFilter
パラメータ:
filter - フィルタ

setFormat

public void setFormat(String format)
インタフェース ExportManager の記述:
エクスポートデータのフォーマットを設定します。

定義:
インタフェース ExportManager 内の setFormat
パラメータ:
format - エクスポートデータのフォーマット

setName

public void setName(String name)
インタフェース ExportManager の記述:
エクスポート処理名を設定します。
この処理名を使って、エクスポート処理の排他制御を行います。
(同じ処理名をもつエクスポート処理を同時に実行することはできません。)

定義:
インタフェース ExportManager 内の setName
パラメータ:
name - エクスポート処理名

setParameter

public void setParameter(String key,
                         Object value)
インタフェース ExportManager の記述:
パラメータを設定します。
エクスポート実行時に使用する任意のパラメータを設定します。

定義:
インタフェース ExportManager 内の setParameter
パラメータ:
key - キー
value - 値

setSize

public void setSize(int size)
インタフェース ExportManager の記述:
エクスポート単位のデータ数を設定します。

定義:
インタフェース ExportManager 内の setSize
パラメータ:
size - エクスポート単位のデータ数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyExportManagerClient (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter.company
クラス CompanyExportManagerClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient
        拡張 jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient
すべての実装インタフェース:
ExportManagerClient
public class CompanyExportManagerClient
extends AbstractExportManagerClient
implements ExportManagerClient

会社情報のエクスポートを行います。

このクラスは、CompanyExportManager クラスのクライアントになります。
executeメソッドに指定された設定情報を解釈した後、CompanyExportManager クラスに エクスポート処理を委譲します。

導入されたバージョン:
6.1

コンストラクタの概要
CompanyExportManagerClient()
メソッドの概要
boolean | execute(InputStream configuration) エクスポートマネージャーを呼び出します。
boolean | execute(String configurationPath) エクスポートマネージャーを呼び出します。
protected ExportConfigurationReader | getConfigurationReader(InputStream inputStream) 入力ストリームからエクスポート設定情報を取得します。
protected String | getDefaultPath() エクスポート情報の出力ファイルのデフォルトパス情報を取得します。
protected ExportManager | getExportManager() エクスポートマネージャーのインスタンスを取得します。
クラス jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient から継承したメソッド
setDate, setEncoding, setExecuteUser, setFilter, setFormat, setName, setParameters, setSize
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyExportManagerClient

public CompanyExportManagerClient()
メソッドの詳細

execute

public boolean execute(String configurationPath)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーを初期化して、エクスポートを実行します。

定義:
インタフェース ExportManagerClient 内の execute
オーバーライド:
クラス AbstractExportManagerClient 内の execute
パラメータ:
configurationPath - エクスポート設定ファイルパス
戻り値:
エクスポートに成功した場合 true、失敗した場合 false

execute

public boolean execute(InputStream configuration)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーを初期化して、エクスポートを実行します。

定義:
インタフェース ExportManagerClient 内の execute
オーバーライド:
クラス AbstractExportManagerClient 内の execute
パラメータ:
configuration - エクスポート設定情報
戻り値:
エクスポートに成功した場合 true、失敗した場合 false

getExportManager

protected ExportManager getExportManager()
クラス AbstractExportManagerClient の記述:
エクスポートマネージャーのインスタンスを取得します。

定義:
クラス AbstractExportManagerClient 内の getExportManager
戻り値:
エクスポートマネージャー

getConfigurationReader

protected ExportConfigurationReader getConfigurationReader(InputStream inputStream)
クラス AbstractExportManagerClient の記述:
入力ストリームからエクスポート設定情報を取得します。

定義:
クラス AbstractExportManagerClient 内の getConfigurationReader
パラメータ:
inputStream - 入力ストリーム
戻り値:
エクスポート設定リーダー

getDefaultPath

protected String getDefaultPath()
クラス AbstractExportManagerClient の記述:
エクスポート情報の出力ファイルのデフォルトパス情報を取得します。

定義:
クラス AbstractExportManagerClient 内の getDefaultPath
戻り値:
出力ファイルパス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyPostExportManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter.company
クラス CompanyPostExportManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager
すべての実装インタフェース:
ExportManager
public class CompanyPostExportManager
extends Object
implements ExportManager

会社役職情報のエクスポートを行います。

導入されたバージョン:
6.1

コンストラクタの概要
CompanyPostExportManager()
コンストラクタ 会社役職エクスポートマネージャーのインスタンスを生成します。
メソッドの概要
void | execute(OutputStream outputStream) エクスポートを実行します。
void | execute(String path) エクスポートを実行します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) エクスポートデータのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザコードを設定します。
void | setFilter(Filter filter) エクスポート対象を絞り込むためのフィルタを設定します。
void | setFormat(String format) エクスポートデータのフォーマットを設定します。
void | setName(String name) エクスポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setSize(int size) エクスポート単位のデータ数を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyPostExportManager

public CompanyPostExportManager()
コンストラクタ 会社役職エクスポートマネージャーのインスタンスを生成します。

メソッドの詳細

execute

public void execute(String path)
インタフェース ExportManager の記述:
エクスポートを実行します。
指定されたパスにエクスポートした情報を出力します。

定義:
インタフェース ExportManager 内の execute
パラメータ:
path - 出力パス

execute

public void execute(OutputStream outputStream)
インタフェース ExportManager の記述:
エクスポートを実行します。
指定された出力ストリームにエクスポートした情報を出力します。

定義:
インタフェース ExportManager 内の execute
パラメータ:
outputStream - 出力ストリーム

setDate

public void setDate(Date date)
インタフェース ExportManager の記述:
日付を設定します。
設定可能な日付はシステムの有効期間内に限られます。

定義:
インタフェース ExportManager 内の setDate
パラメータ:
date - 日付
関連項目:
DateUtil#getMinDate(), DateUtil#getMaxDate()

setEncoding

public void setEncoding(String encoding)
インタフェース ExportManager の記述:
エクスポートデータのエンコーディングを設定します。

定義:
インタフェース ExportManager 内の setEncoding
パラメータ:
encoding - エンコーディング

setExecuteUser

public void setExecuteUser(String user)
インタフェース ExportManager の記述:
実行ユーザコードを設定します。

定義:
インタフェース ExportManager 内の setExecuteUser
パラメータ:
user - 実行ユーザ

setFilter

public void setFilter(Filter filter)
インタフェース ExportManager の記述:
エクスポート対象を絞り込むためのフィルタを設定します。

定義:
インタフェース ExportManager 内の setFilter
パラメータ:
filter - フィルタ

setFormat

public void setFormat(String format)
インタフェース ExportManager の記述:
エクスポートデータのフォーマットを設定します。

定義:
インタフェース ExportManager 内の setFormat
パラメータ:
format - エクスポートデータのフォーマット

setName

public void setName(String name)
インタフェース ExportManager の記述:
エクスポート処理名を設定します。
この処理名を使って、エクスポート処理の排他制御を行います。
(同じ処理名をもつエクスポート処理を同時に実行することはできません。)

定義:
インタフェース ExportManager 内の setName
パラメータ:
name - エクスポート処理名

setParameter

public void setParameter(String key,
                         Object value)
インタフェース ExportManager の記述:
パラメータを設定します。
エクスポート実行時に使用する任意のパラメータを設定します。

定義:
インタフェース ExportManager 内の setParameter
パラメータ:
key - キー
value - 値

setSize

public void setSize(int size)
インタフェース ExportManager の記述:
エクスポート単位のデータ数を設定します。

定義:
インタフェース ExportManager 内の setSize
パラメータ:
size - エクスポート単位のデータ数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyPostExportManagerClient (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter.company
クラス CompanyPostExportManagerClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient
        拡張 jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient
すべての実装インタフェース:
ExportManagerClient
public class CompanyPostExportManagerClient
extends AbstractExportManagerClient
implements ExportManagerClient

会社役職情報のエクスポートを行います。

このクラスは、CompanyPostExportManager クラスのクライアントになります。
executeメソッドに指定された定義された情報を解釈した後、CompanyPostExportManager クラスに エクスポート処理を委譲します。

導入されたバージョン:
6.1

コンストラクタの概要
CompanyPostExportManagerClient()
メソッドの概要
boolean | execute(InputStream configuration) エクスポートマネージャーを呼び出します。
boolean | execute(String configurationPath) エクスポートマネージャーを呼び出します。
protected ExportConfigurationReader | getConfigurationReader(InputStream inputStream) 入力ストリームからエクスポート設定情報を取得します。
protected String | getDefaultPath() エクスポート情報の出力ファイルのデフォルトパス情報を取得します。
protected ExportManager | getExportManager() エクスポートマネージャーのインスタンスを取得します。
クラス jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient から継承したメソッド
setDate, setEncoding, setExecuteUser, setFilter, setFormat, setName, setParameters, setSize
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyPostExportManagerClient

public CompanyPostExportManagerClient()
メソッドの詳細

execute

public boolean execute(String configurationPath)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーを初期化して、エクスポートを実行します。

定義:
インタフェース ExportManagerClient 内の execute
オーバーライド:
クラス AbstractExportManagerClient 内の execute
パラメータ:
configurationPath - エクスポート設定ファイルパス
戻り値:
エクスポートに成功した場合 true、失敗した場合 false

execute

public boolean execute(InputStream configuration)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーを初期化して、エクスポートを実行します。

定義:
インタフェース ExportManagerClient 内の execute
オーバーライド:
クラス AbstractExportManagerClient 内の execute
パラメータ:
configuration - エクスポート設定情報
戻り値:
エクスポートに成功した場合 true、失敗した場合 false

getExportManager

protected ExportManager getExportManager()
クラス AbstractExportManagerClient の記述:
エクスポートマネージャーのインスタンスを取得します。

定義:
クラス AbstractExportManagerClient 内の getExportManager
戻り値:
エクスポートマネージャー

getConfigurationReader

protected ExportConfigurationReader getConfigurationReader(InputStream inputStream)
クラス AbstractExportManagerClient の記述:
入力ストリームからエクスポート設定情報を取得します。

定義:
クラス AbstractExportManagerClient 内の getConfigurationReader
パラメータ:
inputStream - 入力ストリーム
戻り値:
エクスポート設定リーダー

getDefaultPath

protected String getDefaultPath()
クラス AbstractExportManagerClient の記述:
エクスポート情報の出力ファイルのデフォルトパス情報を取得します。

定義:
クラス AbstractExportManagerClient 内の getDefaultPath
戻り値:
出力ファイルパス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.exporter.company (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.exporter.company
クラス
CompanyExportManager
CompanyExportManagerClient
CompanyPostExportManager
CompanyPostExportManagerClient


jp.co.intra_mart.foundation.datastore.exporter.company (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exporter.company

会社・組織関連の情報のエクスポートを行うクラスを提供します。

参照:
説明

クラスの概要
CompanyExportManager | 会社情報のエクスポートを行います。
CompanyExportManagerClient | 会社情報のエクスポートを行います。
CompanyPostExportManager | 会社役職情報のエクスポートを行います。
CompanyPostExportManagerClient | 会社役職情報のエクスポートを行います。

パッケージ jp.co.intra_mart.foundation.datastore.exporter.company の説明

会社・組織関連の情報のエクスポートを行うクラスを提供します。


jp.co.intra_mart.foundation.datastore.exporter.company クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exporter.company の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
    • class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManager)
    • class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManager)


パッケージ jp.co.intra_mart.foundation.datastore.exporter.company の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.exporter.company の使用

jp.co.intra_mart.foundation.datastore.exporter.company はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager の使用

jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient の使用

jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.exporter.public_group (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.exporter.public_group
クラス
PublicGroupExportManager
PublicGroupExportManagerClient


jp.co.intra_mart.foundation.datastore.exporter.public_group (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exporter.public_group

パブリックグループ情報のエクスポートを行うクラスを提供します。

参照:
説明

クラスの概要
PublicGroupExportManager | パブリックグループ情報のエクスポートを行います。
PublicGroupExportManagerClient | パブリックグループ情報のエクスポートを行います。

パッケージ jp.co.intra_mart.foundation.datastore.exporter.public_group の説明

パブリックグループ情報のエクスポートを行うクラスを提供します。


jp.co.intra_mart.foundation.datastore.exporter.public_group クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exporter.public_group の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
    • class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManager)


パッケージ jp.co.intra_mart.foundation.datastore.exporter.public_group の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.exporter.public_group の使用

jp.co.intra_mart.foundation.datastore.exporter.public_group はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupExportManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter.public_group
クラス PublicGroupExportManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager
すべての実装インタフェース:
ExportManager
public class PublicGroupExportManager
extends Object
implements ExportManager

パブリックグループ情報のエクスポートを行います。

導入されたバージョン:
6.1

コンストラクタの概要
PublicGroupExportManager()
コンストラクタ パブリックグループ情報エクスポートマネージャーのインスタンスを生成します。
メソッドの概要
void | execute(OutputStream outputStream) エクスポートを実行します。
void | execute(String path) エクスポートを実行します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) エクスポートデータのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザコードを設定します。
void | setFilter(Filter filter) エクスポート対象を絞り込むためのフィルタを設定します。
void | setFormat(String format) エクスポートデータのフォーマットを設定します。
void | setName(String name) エクスポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setSize(int size) エクスポート単位のデータ数を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupExportManager

public PublicGroupExportManager()
コンストラクタ パブリックグループ情報エクスポートマネージャーのインスタンスを生成します。

メソッドの詳細

execute

public void execute(String path)
インタフェース ExportManager の記述:
エクスポートを実行します。
指定されたパスにエクスポートした情報を出力します。

定義:
インタフェース ExportManager 内の execute
パラメータ:
path - 出力パス

execute

public void execute(OutputStream outputStream)
インタフェース ExportManager の記述:
エクスポートを実行します。
指定された出力ストリームにエクスポートした情報を出力します。

定義:
インタフェース ExportManager 内の execute
パラメータ:
outputStream - 出力ストリーム

setDate

public void setDate(Date date)
インタフェース ExportManager の記述:
日付を設定します。
設定可能な日付はシステムの有効期間内に限られます。

定義:
インタフェース ExportManager 内の setDate
パラメータ:
date - 日付
関連項目:
DateUtil#getMinDate(), DateUtil#getMaxDate()

setEncoding

public void setEncoding(String encoding)
インタフェース ExportManager の記述:
エクスポートデータのエンコーディングを設定します。

定義:
インタフェース ExportManager 内の setEncoding
パラメータ:
encoding - エンコーディング

setExecuteUser

public void setExecuteUser(String user)
インタフェース ExportManager の記述:
実行ユーザコードを設定します。

定義:
インタフェース ExportManager 内の setExecuteUser
パラメータ:
user - 実行ユーザ

setFilter

public void setFilter(Filter filter)
インタフェース ExportManager の記述:
エクスポート対象を絞り込むためのフィルタを設定します。

定義:
インタフェース ExportManager 内の setFilter
パラメータ:
filter - フィルタ

setFormat

public void setFormat(String format)
インタフェース ExportManager の記述:
エクスポートデータのフォーマットを設定します。

定義:
インタフェース ExportManager 内の setFormat
パラメータ:
format - エクスポートデータのフォーマット

setName

public void setName(String name)
インタフェース ExportManager の記述:
エクスポート処理名を設定します。
この処理名を使って、エクスポート処理の排他制御を行います。
(同じ処理名をもつエクスポート処理を同時に実行することはできません。)

定義:
インタフェース ExportManager 内の setName
パラメータ:
name - エクスポート処理名

setParameter

public void setParameter(String key,
                         Object value)
インタフェース ExportManager の記述:
パラメータを設定します。
エクスポート実行時に使用する任意のパラメータを設定します。

定義:
インタフェース ExportManager 内の setParameter
パラメータ:
key - キー
value - 値

setSize

public void setSize(int size)
インタフェース ExportManager の記述:
エクスポート単位のデータ数を設定します。

定義:
インタフェース ExportManager 内の setSize
パラメータ:
size - エクスポート単位のデータ数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupExportManagerClient (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter.public_group
クラス PublicGroupExportManagerClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient
        拡張 jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient
すべての実装インタフェース:
ExportManagerClient
public class PublicGroupExportManagerClient
extends AbstractExportManagerClient
implements ExportManagerClient

パブリックグループ情報のエクスポートを行います。

このクラスは、PublicGroupExportManager クラスのクライアントになります。
executeメソッドに指定された設定情報を解釈した後、PublicGroupExportManager クラスに エクスポート処理を委譲します。

導入されたバージョン:
6.1

コンストラクタの概要
PublicGroupExportManagerClient()
メソッドの概要
boolean | execute(InputStream configuration) エクスポートマネージャーを呼び出します。
boolean | execute(String configurationPath) エクスポートマネージャーを呼び出します。
protected ExportConfigurationReader | getConfigurationReader(InputStream inputStream) 入力ストリームからエクスポート設定情報を取得します。
protected String | getDefaultPath() エクスポート情報の出力ファイルのデフォルトパス情報を取得します。
protected ExportManager | getExportManager() エクスポートマネージャーのインスタンスを取得します。
クラス jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient から継承したメソッド
setDate, setEncoding, setExecuteUser, setFilter, setFormat, setName, setParameters, setSize
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupExportManagerClient

public PublicGroupExportManagerClient()
メソッドの詳細

execute

public boolean execute(String configurationPath)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーを初期化して、エクスポートを実行します。

定義:
インタフェース ExportManagerClient 内の execute
オーバーライド:
クラス AbstractExportManagerClient 内の execute
パラメータ:
configurationPath - エクスポート設定ファイルパス
戻り値:
エクスポートに成功した場合 true、失敗した場合 false

execute

public boolean execute(InputStream configuration)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーを初期化して、エクスポートを実行します。

定義:
インタフェース ExportManagerClient 内の execute
オーバーライド:
クラス AbstractExportManagerClient 内の execute
パラメータ:
configuration - エクスポート設定情報
戻り値:
エクスポートに成功した場合 true、失敗した場合 false

getExportManager

protected ExportManager getExportManager()
クラス AbstractExportManagerClient の記述:
エクスポートマネージャーのインスタンスを取得します。

定義:
クラス AbstractExportManagerClient 内の getExportManager
戻り値:
エクスポートマネージャー

getConfigurationReader

protected ExportConfigurationReader getConfigurationReader(InputStream inputStream)
クラス AbstractExportManagerClient の記述:
入力ストリームからエクスポート設定情報を取得します。

定義:
クラス AbstractExportManagerClient 内の getConfigurationReader
パラメータ:
inputStream - 入力ストリーム
戻り値:
エクスポート設定リーダー

getDefaultPath

protected String getDefaultPath()
クラス AbstractExportManagerClient の記述:
エクスポート情報の出力ファイルのデフォルトパス情報を取得します。

定義:
クラス AbstractExportManagerClient 内の getDefaultPath
戻り値:
出力ファイルパス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager の使用

jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient の使用

jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager の使用

jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient の使用

jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.exporter.user (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.exporter.user
クラス
UserAttachExportManager
UserAttachExportManagerClient
UserProfileExportManager
UserProfileExportManagerClient


jp.co.intra_mart.foundation.datastore.exporter.user (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exporter.user

ユーザ関連の情報のエクスポートを行うクラスを提供します。

参照:
説明

クラスの概要
UserAttachExportManager | ユーザ所属情報のエクスポートを行います。
UserAttachExportManagerClient | ユーザ所属情報のエクスポートを行います。
UserProfileExportManager | ユーザ情報のエクスポートを行います。
UserProfileExportManagerClient | ユーザ情報のエクスポートを行います。

パッケージ jp.co.intra_mart.foundation.datastore.exporter.user の説明

ユーザ関連の情報のエクスポートを行うクラスを提供します。


jp.co.intra_mart.foundation.datastore.exporter.user クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exporter.user の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
    • class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManager)
    • class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManager)


パッケージ jp.co.intra_mart.foundation.datastore.exporter.user の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.exporter.user の使用

jp.co.intra_mart.foundation.datastore.exporter.user はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


UserAttachExportManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter.user
クラス UserAttachExportManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager
すべての実装インタフェース:
ExportManager
public class UserAttachExportManager
extends Object
implements ExportManager

ユーザ所属情報のエクスポートを行います。

導入されたバージョン:
6.1

コンストラクタの概要
UserAttachExportManager()
コンストラクタ ユーザ所属情報エクスポートマネージャーのインスタンスを生成します。
メソッドの概要
void | execute(OutputStream outputStream) エクスポートを実行します。
void | execute(String path) エクスポートを実行します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) エクスポートデータのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザコードを設定します。
void | setFilter(Filter filter) エクスポート対象を絞り込むためのフィルタを設定します。
void | setFormat(String format) エクスポートデータのフォーマットを設定します。
void | setName(String name) エクスポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setSize(int size) エクスポート単位のデータ数を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserAttachExportManager

public UserAttachExportManager()
コンストラクタ ユーザ所属情報エクスポートマネージャーのインスタンスを生成します。

メソッドの詳細

execute

public void execute(String path)
インタフェース ExportManager の記述:
エクスポートを実行します。
指定されたパスにエクスポートした情報を出力します。

定義:
インタフェース ExportManager 内の execute
パラメータ:
path - 出力パス

execute

public void execute(OutputStream outputStream)
インタフェース ExportManager の記述:
エクスポートを実行します。
指定された出力ストリームにエクスポートした情報を出力します。

定義:
インタフェース ExportManager 内の execute
パラメータ:
outputStream - 出力ストリーム

setDate

public void setDate(Date date)
インタフェース ExportManager の記述:
日付を設定します。
設定可能な日付はシステムの有効期間内に限られます。

定義:
インタフェース ExportManager 内の setDate
パラメータ:
date - 日付
関連項目:
DateUtil#getMinDate(), DateUtil#getMaxDate()

setEncoding

public void setEncoding(String encoding)
インタフェース ExportManager の記述:
エクスポートデータのエンコーディングを設定します。

定義:
インタフェース ExportManager 内の setEncoding
パラメータ:
encoding - エンコーディング

setExecuteUser

public void setExecuteUser(String user)
インタフェース ExportManager の記述:
実行ユーザコードを設定します。

定義:
インタフェース ExportManager 内の setExecuteUser
パラメータ:
user - 実行ユーザ

setFilter

public void setFilter(Filter filter)
インタフェース ExportManager の記述:
エクスポート対象を絞り込むためのフィルタを設定します。

定義:
インタフェース ExportManager 内の setFilter
パラメータ:
filter - フィルタ

setFormat

public void setFormat(String format)
インタフェース ExportManager の記述:
エクスポートデータのフォーマットを設定します。

定義:
インタフェース ExportManager 内の setFormat
パラメータ:
format - エクスポートデータのフォーマット

setName

public void setName(String name)
インタフェース ExportManager の記述:
エクスポート処理名を設定します。
この処理名を使って、エクスポート処理の排他制御を行います。
(同じ処理名をもつエクスポート処理を同時に実行することはできません。)

定義:
インタフェース ExportManager 内の setName
パラメータ:
name - エクスポート処理名

setParameter

public void setParameter(String key,
                         Object value)
インタフェース ExportManager の記述:
パラメータを設定します。
エクスポート実行時に使用する任意のパラメータを設定します。

定義:
インタフェース ExportManager 内の setParameter
パラメータ:
key - キー
value - 値

setSize

public void setSize(int size)
インタフェース ExportManager の記述:
エクスポート単位のデータ数を設定します。

定義:
インタフェース ExportManager 内の setSize
パラメータ:
size - エクスポート単位のデータ数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UserAttachExportManagerClient (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter.user
クラス UserAttachExportManagerClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient
        拡張 jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient
すべての実装インタフェース:
ExportManagerClient
public class UserAttachExportManagerClient
extends AbstractExportManagerClient
implements ExportManagerClient

ユーザ所属情報のエクスポートを行います。

このクラスは、UserAttachExportManager クラスのクライアントになります。
executeメソッドに指定された設定情報を解釈した後、UserAttachExportManager クラスに エクスポート処理を委譲します。

導入されたバージョン:
6.1

コンストラクタの概要
UserAttachExportManagerClient()
メソッドの概要
boolean | execute(InputStream configuration) エクスポートマネージャーを呼び出します。
boolean | execute(String configurationPath) エクスポートマネージャーを呼び出します。
protected ExportConfigurationReader | getConfigurationReader(InputStream inputStream) 入力ストリームからエクスポート設定情報を取得します。
protected String | getDefaultPath() エクスポート情報の出力ファイルのデフォルトパス情報を取得します。
protected ExportManager | getExportManager() エクスポートマネージャーのインスタンスを取得します。
クラス jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient から継承したメソッド
setDate, setEncoding, setExecuteUser, setFilter, setFormat, setName, setParameters, setSize
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserAttachExportManagerClient

public UserAttachExportManagerClient()
メソッドの詳細

execute

public boolean execute(String configurationPath)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーを初期化して、エクスポートを実行します。

定義:
インタフェース ExportManagerClient 内の execute
オーバーライド:
クラス AbstractExportManagerClient 内の execute
パラメータ:
configurationPath - エクスポート設定ファイルパス
戻り値:
エクスポートに成功した場合 true、失敗した場合 false

execute

public boolean execute(InputStream configuration)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーを初期化して、エクスポートを実行します。

定義:
インタフェース ExportManagerClient 内の execute
オーバーライド:
クラス AbstractExportManagerClient 内の execute
パラメータ:
configuration - エクスポート設定情報
戻り値:
エクスポートに成功した場合 true、失敗した場合 false

getExportManager

protected ExportManager getExportManager()
クラス AbstractExportManagerClient の記述:
エクスポートマネージャーのインスタンスを取得します。

定義:
クラス AbstractExportManagerClient 内の getExportManager
戻り値:
エクスポートマネージャー

getConfigurationReader

protected ExportConfigurationReader getConfigurationReader(InputStream inputStream)
クラス AbstractExportManagerClient の記述:
入力ストリームからエクスポート設定情報を取得します。

定義:
クラス AbstractExportManagerClient 内の getConfigurationReader
パラメータ:
inputStream - 入力ストリーム
戻り値:
エクスポート設定リーダー

getDefaultPath

protected String getDefaultPath()
クラス AbstractExportManagerClient の記述:
エクスポート情報の出力ファイルのデフォルトパス情報を取得します。

定義:
クラス AbstractExportManagerClient 内の getDefaultPath
戻り値:
出力ファイルパス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserProfileExportManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter.user
クラス UserProfileExportManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager
すべての実装インタフェース:
ExportManager
public class UserProfileExportManager
extends Object
implements ExportManager

ユーザ情報のエクスポートを行います。

導入されたバージョン:
6.1

コンストラクタの概要
UserProfileExportManager()
コンストラクタ ユーザ情報エクスポートマネージャーのインスタンスを生成します。
メソッドの概要
void | execute(OutputStream outputStream) エクスポートを実行します。
void | execute(String path) エクスポートを実行します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) エクスポートデータのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザコードを設定します。
void | setFilter(Filter filter) エクスポート対象を絞り込むためのフィルタを設定します。
void | setFormat(String format) エクスポートデータのフォーマットを設定します。
void | setName(String name) エクスポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setSize(int size) エクスポート単位のデータ数を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserProfileExportManager

public UserProfileExportManager()
コンストラクタ ユーザ情報エクスポートマネージャーのインスタンスを生成します。

メソッドの詳細

execute

public void execute(String path)
インタフェース ExportManager の記述:
エクスポートを実行します。
指定されたパスにエクスポートした情報を出力します。

定義:
インタフェース ExportManager 内の execute
パラメータ:
path - 出力パス

execute

public void execute(OutputStream outputStream)
インタフェース ExportManager の記述:
エクスポートを実行します。
指定された出力ストリームにエクスポートした情報を出力します。

定義:
インタフェース ExportManager 内の execute
パラメータ:
outputStream - 出力ストリーム

setDate

public void setDate(Date date)
インタフェース ExportManager の記述:
日付を設定します。
設定可能な日付はシステムの有効期間内に限られます。

定義:
インタフェース ExportManager 内の setDate
パラメータ:
date - 日付
関連項目:
DateUtil#getMinDate(), DateUtil#getMaxDate()

setEncoding

public void setEncoding(String encoding)
インタフェース ExportManager の記述:
エクスポートデータのエンコーディングを設定します。

定義:
インタフェース ExportManager 内の setEncoding
パラメータ:
encoding - エンコーディング

setExecuteUser

public void setExecuteUser(String user)
インタフェース ExportManager の記述:
実行ユーザコードを設定します。

定義:
インタフェース ExportManager 内の setExecuteUser
パラメータ:
user - 実行ユーザ

setFilter

public void setFilter(Filter filter)
インタフェース ExportManager の記述:
エクスポート対象を絞り込むためのフィルタを設定します。

定義:
インタフェース ExportManager 内の setFilter
パラメータ:
filter - フィルタ

setFormat

public void setFormat(String format)
インタフェース ExportManager の記述:
エクスポートデータのフォーマットを設定します。

定義:
インタフェース ExportManager 内の setFormat
パラメータ:
format - エクスポートデータのフォーマット

setName

public void setName(String name)
インタフェース ExportManager の記述:
エクスポート処理名を設定します。
この処理名を使って、エクスポート処理の排他制御を行います。
(同じ処理名をもつエクスポート処理を同時に実行することはできません。)

定義:
インタフェース ExportManager 内の setName
パラメータ:
name - エクスポート処理名

setParameter

public void setParameter(String key,
                         Object value)
インタフェース ExportManager の記述:
パラメータを設定します。
エクスポート実行時に使用する任意のパラメータを設定します。

定義:
インタフェース ExportManager 内の setParameter
パラメータ:
key - キー
value - 値

setSize

public void setSize(int size)
インタフェース ExportManager の記述:
エクスポート単位のデータ数を設定します。

定義:
インタフェース ExportManager 内の setSize
パラメータ:
size - エクスポート単位のデータ数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserProfileExportManagerClient (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter.user
クラス UserProfileExportManagerClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient
        拡張 jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient
すべての実装インタフェース:
ExportManagerClient
public class UserProfileExportManagerClient
extends AbstractExportManagerClient
implements ExportManagerClient

ユーザ情報のエクスポートを行います。

エクスポートされるのは、ユーザプロファイル情報のみです。
ユーザ所属情報をエクスポートする場合は、UserAttachExportManagerClient、 または UserAttachExportManager を使用してください。

このクラスは、UserProfileExportManager クラスのクライアントになります。
executeメソッドに指定された設定情報を解釈した後、UserProfileExportManager クラスに エクスポート処理を委譲します。

導入されたバージョン:
6.1

コンストラクタの概要
UserProfileExportManagerClient()
メソッドの概要
boolean | execute(InputStream configuration) エクスポートマネージャーを呼び出します。
boolean | execute(String configurationPath) エクスポートマネージャーを呼び出します。
protected ExportConfigurationReader | getConfigurationReader(InputStream inputStream) 入力ストリームからエクスポート設定情報を取得します。
protected String | getDefaultPath() エクスポート情報の出力ファイルのデフォルトパス情報を取得します。
protected ExportManager | getExportManager() エクスポートマネージャーのインスタンスを取得します。
クラス jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient から継承したメソッド
setDate, setEncoding, setExecuteUser, setFilter, setFormat, setName, setParameters, setSize
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserProfileExportManagerClient

public UserProfileExportManagerClient()
メソッドの詳細

execute

public boolean execute(String configurationPath)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーを初期化して、エクスポートを実行します。

定義:
インタフェース ExportManagerClient 内の execute
オーバーライド:
クラス AbstractExportManagerClient 内の execute
パラメータ:
configurationPath - エクスポート設定ファイルパス
戻り値:
エクスポートに成功した場合 true、失敗した場合 false

execute

public boolean execute(InputStream configuration)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーを初期化して、エクスポートを実行します。

定義:
インタフェース ExportManagerClient 内の execute
オーバーライド:
クラス AbstractExportManagerClient 内の execute
パラメータ:
configuration - エクスポート設定情報
戻り値:
エクスポートに成功した場合 true、失敗した場合 false

getExportManager

protected ExportManager getExportManager()
クラス AbstractExportManagerClient の記述:
エクスポートマネージャーのインスタンスを取得します。

定義:
クラス AbstractExportManagerClient 内の getExportManager
戻り値:
エクスポートマネージャー

getConfigurationReader

protected ExportConfigurationReader getConfigurationReader(InputStream inputStream)
クラス AbstractExportManagerClient の記述:
入力ストリームからエクスポート設定情報を取得します。

定義:
クラス AbstractExportManagerClient 内の getConfigurationReader
パラメータ:
inputStream - 入力ストリーム
戻り値:
エクスポート設定リーダー

getDefaultPath

protected String getDefaultPath()
クラス AbstractExportManagerClient の記述:
エクスポート情報の出力ファイルのデフォルトパス情報を取得します。

定義:
クラス AbstractExportManagerClient 内の getDefaultPath
戻り値:
出力ファイルパス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AbstractExportManagerClient (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter
クラス AbstractExportManagerClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient
すべての実装インタフェース:
ExportManagerClient
直系の既知のサブクラス:
CompanyExportManagerClient, CompanyPostExportManagerClient, PublicGroupExportManagerClient, UserAttachExportManagerClient, UserProfileExportManagerClient
public abstract class AbstractExportManagerClient
extends Object
implements ExportManagerClient

エクスポートマネージャークライアントの汎用的な実装です。

導入されたバージョン:
6.1

コンストラクタの概要
AbstractExportManagerClient()
メソッドの概要
boolean | execute(InputStream configuration) エクスポートマネージャーを呼び出します。
boolean | execute(String configurationPath) エクスポートマネージャーを呼び出します。
protected abstract ExportConfigurationReader | getConfigurationReader(InputStream inputStream) 入力ストリームからエクスポート設定情報を取得します。
protected abstract String | getDefaultPath() エクスポート情報の出力ファイルのデフォルトパス情報を取得します。
protected abstract ExportManager | getExportManager() エクスポートマネージャーのインスタンスを取得します。
protected void | setDate(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義された日付をマネージャーに設定します。
protected void | setEncoding(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたエクスポートデータのエンコーディング情報をマネージャーに設定します。
protected void | setExecuteUser(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義された実行ユーザコードをマネージャーに設定します。
protected void | setFilter(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたフィルタの情報をマネージャーに設定します。
protected void | setFormat(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたエクスポートデータのフォーマットをマネージャーに設定します。
protected void | setName(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義された処理名をマネージャーに設定します。
protected void | setParameters(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたパラメータ情報をマネージャーに設定します。
protected void | setSize(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたエクスポート単位のデータ数をマネージャーに設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractExportManagerClient

public AbstractExportManagerClient()
メソッドの詳細

execute

public boolean execute(String configurationPath)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーの初期化を行い、エクスポートを実行します。

定義:
インタフェース ExportManagerClient 内の execute
パラメータ:
configurationPath - エクスポート設定ファイルパス
戻り値:
エクスポートに成功した場合 true
例外:
ExportInitializeException - エクスポートマネージャーの初期化でエラーが発生した場合
Error - エクスポート実行中に何らかのエラーが発生した場合

execute

public boolean execute(InputStream configuration)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーの初期化を行い、エクスポートを実行します。

定義:
インタフェース ExportManagerClient 内の execute
パラメータ:
configuration - エクスポート設定
戻り値:
エクスポートに成功した場合 true
例外:
ExportInitializeException - エクスポートマネージャーの初期化でエラーが発生した場合
Error - エクスポート実行中に何らかのエラーが発生した場合

getExportManager

protected abstract ExportManager getExportManager()
エクスポートマネージャーのインスタンスを取得します。

戻り値:
エクスポートマネージャー
例外:
ExportInitializeException - エクスポートマネージャーのインスタンスの生成に失敗した場合

getConfigurationReader

protected abstract ExportConfigurationReader getConfigurationReader(InputStream inputStream)
入力ストリームからエクスポート設定情報を取得します。

パラメータ:
inputStream - 入力ストリーム
戻り値:
エクスポート設定リーダー
例外:
ExportInitializeException - 入力ストリームの読み込みに失敗した場合

getDefaultPath

protected abstract String getDefaultPath()
エクスポート情報の出力ファイルのデフォルトパス情報を取得します。

戻り値:
出力ファイルパス

setName

protected void setName(ExportManager manager,
                       ExportConfigurationReader reader)
エクスポート設定に定義された処理名をマネージャーに設定します。

パラメータ:
manager - エクスポートマネージャー
reader - エクスポート設定リーダー

setFormat

protected void setFormat(ExportManager manager,
                         ExportConfigurationReader reader)
エクスポート設定に定義されたエクスポートデータのフォーマットをマネージャーに設定します。

パラメータ:
manager - エクスポートマネージャー
reader - エクスポート設定リーダー

setDate

protected void setDate(ExportManager manager,
                       ExportConfigurationReader reader)
エクスポート設定に定義された日付をマネージャーに設定します。

パラメータ:
manager - エクスポートマネージャー
reader - エクスポート設定リーダー

setEncoding

protected void setEncoding(ExportManager manager,
                           ExportConfigurationReader reader)
エクスポート設定に定義されたエクスポートデータのエンコーディング情報をマネージャーに設定します。

パラメータ:
manager - エクスポートマネージャー
reader - エクスポート設定リーダー

setSize

protected void setSize(ExportManager manager,
                       ExportConfigurationReader reader)
エクスポート設定に定義されたエクスポート単位のデータ数をマネージャーに設定します。

パラメータ:
manager - エクスポートマネージャー
reader - エクスポート設定リーダー

setExecuteUser

protected void setExecuteUser(ExportManager manager,
                              ExportConfigurationReader reader)
エクスポート設定に定義された実行ユーザコードをマネージャーに設定します。

パラメータ:
manager - エクスポートマネージャー
reader - エクスポート設定リーダー

setFilter

protected void setFilter(ExportManager manager,
                         ExportConfigurationReader reader)
エクスポート設定に定義されたフィルタの情報をマネージャーに設定します。

パラメータ:
manager - エクスポートマネージャー
reader - エクスポート設定リーダー

setParameters

protected void setParameters(ExportManager manager,
                             ExportConfigurationReader reader)
エクスポート設定に定義されたパラメータ情報をマネージャーに設定します。

パラメータ:
manager - エクスポートマネージャー
reader - エクスポート設定リーダー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExportInitializeException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter
クラス ExportInitializeException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.datastore.exception.BatchProcessException
                    拡張 jp.co.intra_mart.foundation.datastore.exporter.ExportInitializeException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ExportConfigurationReaderException
public class ExportInitializeException
extends BatchProcessException

エクスポートの初期化でエラーが発生したことを示すためにスローされます。

導入されたバージョン:
6.1
関連項目:
直列化された形式

コンストラクタの概要
ExportInitializeException(String message)
コンストラクタ
ExportInitializeException(String message, Throwable cause)
コンストラクタ
ExportInitializeException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExportInitializeException

public ExportInitializeException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

ExportInitializeException

public ExportInitializeException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

ExportInitializeException

public ExportInitializeException(String message,
                                 Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExportManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter
インタフェース ExportManager

既知の実装クラスの一覧:
CompanyExportManager, CompanyPostExportManager, ExportManagerImpl, PublicGroupExportManager, UserAttachExportManager, UserProfileExportManager
public interface ExportManager

エクスポートを行います。

導入されたバージョン:
6.1

メソッドの概要
void | execute(OutputStream outputStream) エクスポートを実行します。
void | execute(String path) エクスポートを実行します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) エクスポートデータのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザコードを設定します。
void | setFilter(Filter filter) エクスポート対象を絞り込むためのフィルタを設定します。
void | setFormat(String format) エクスポートデータのフォーマットを設定します。
void | setName(String name) エクスポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setSize(int size) エクスポート単位のデータ数を設定します。

メソッドの詳細

execute

public void execute(String path)
エクスポートを実行します。
指定されたパスにエクスポートした情報を出力します。

パラメータ:
path - 出力パス
例外:
ExportInitializeException - エクスポート処理の初期化でエラーが発生した場合
BatchProcessException - エクスポート処理中に何らかのエラーが発生した場合
BatchSystemException - エクスポート処理中にシステムエラーが発生した場合

execute

public void execute(OutputStream outputStream)
エクスポートを実行します。
指定された出力ストリームにエクスポートした情報を出力します。

パラメータ:
outputStream - 出力ストリーム
例外:
ExportInitializeException - エクスポート処理の初期化でエラーが発生した場合
BatchProcessException - エクスポート処理中に何らかのエラーが発生した場合
BatchSystemException - エクスポート処理中にシステムエラーが発生した場合

setName

public void setName(String name)
エクスポート処理名を設定します。
この処理名を使って、エクスポート処理の排他制御を行います。
(同じ処理名をもつエクスポート処理を同時に実行することはできません。)

パラメータ:
name - エクスポート処理名
例外:
ExportInitializeException - 処理名に null が設定された場合

setFormat

public void setFormat(String format)
エクスポートデータのフォーマットを設定します。

パラメータ:
format - エクスポートデータのフォーマット
例外:
ExportInitializeException - エクスポートデータのフォーマットに null が設定された場合

setDate

public void setDate(Date date)
日付を設定します。
設定可能な日付はシステムの有効期間内に限られます。

パラメータ:
date - 日付
例外:
ExportInitializeException - 日付に null、または有効期間外の日付が設定された場合
関連項目:
DateUtil#getMinDate(), DateUtil#getMaxDate()

setEncoding

public void setEncoding(String encoding)
エクスポートデータのエンコーディングを設定します。

パラメータ:
encoding - エンコーディング
例外:
ExportInitializeException - エンコーディングに null が設定された場合

setExecuteUser

public void setExecuteUser(String user)
実行ユーザコードを設定します。

パラメータ:
user - 実行ユーザ
例外:
ExportInitializeException - 実行ユーザに null が設定された場合

setSize

public void setSize(int size)
エクスポート単位のデータ数を設定します。

パラメータ:
size - エクスポート単位のデータ数
例外:
ExportInitializeException - データ数に 0 未満の数値が設定された場合

setFilter

public void setFilter(Filter filter)
エクスポート対象を絞り込むためのフィルタを設定します。

パラメータ:
filter - フィルタ

setParameter

public void setParameter(String key,
                         Object value)
パラメータを設定します。
エクスポート実行時に使用する任意のパラメータを設定します。

パラメータ:
key - キー
value - 値
例外:
ExportInitializeException - パラメータのキーに null が設定された場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExportManagerClient (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter
インタフェース ExportManagerClient

既知の実装クラスの一覧:
AbstractExportManagerClient, CompanyExportManagerClient, CompanyPostExportManagerClient, PublicGroupExportManagerClient, UserAttachExportManagerClient, UserProfileExportManagerClient
public interface ExportManagerClient

エクスポートマネージャーの呼び出しを行うクライアントです。

導入されたバージョン:
6.1

メソッドの概要
boolean | execute(InputStream configuration) エクスポートマネージャーを呼び出します。
boolean | execute(String configurationPath) エクスポートマネージャーを呼び出します。

メソッドの詳細

execute

public boolean execute(String configurationPath)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーを初期化して、エクスポートを実行します。

パラメータ:
configurationPath - エクスポート設定ファイルパス
戻り値:
エクスポートに成功した場合 true、失敗した場合 false

execute

public boolean execute(InputStream configuration)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーを初期化して、エクスポートを実行します。

パラメータ:
configuration - エクスポート設定情報
戻り値:
エクスポートに成功した場合 true、失敗した場合 false
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExportManagerImpl (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter
クラス ExportManagerImpl

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl
すべての実装インタフェース:
ExportManager
public class ExportManagerImpl
extends Object
implements ExportManager

エクスポートマネージャーの汎用的な実装です。

導入されたバージョン:
6.1

コンストラクタの概要
ExportManagerImpl(String id)
コンストラクタ
メソッドの概要
void | execute(OutputStream outputStream) エクスポートを実行します。
void | execute(String path) エクスポートを実行します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) エクスポートファイルのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザを設定します。
void | setFilter(Filter filter) エクスポートフィルタを設定します。
void | setFormat(String format) エクスポートファイルのフォーマットを設定します。
void | setName(String name) エクスポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setSize(int size) エクスポート単位のデータ数を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExportManagerImpl

public ExportManagerImpl(String id)
コンストラクタ

パラメータ:
id - エクスポート種別を特定するための識別子
メソッドの詳細

execute

public void execute(String path)
エクスポートを実行します。

定義:
インタフェース ExportManager 内の execute
パラメータ:
path - エクスポートファイルのパス
例外:
ExportInitializeException - エクスポート処理の初期化でエラーが発生した場合
BatchProcessException - エクスポート処理中に何らかのエラーが発生した場合
BatchSystemException - エクスポート処理中にシステムエラーが発生した場合

execute

public void execute(OutputStream outputStream)
エクスポートを実行します。

定義:
インタフェース ExportManager 内の execute
パラメータ:
outputStream - エクスポートデータ
例外:
ExportInitializeException - エクスポート処理の初期化でエラーが発生した場合
BatchProcessException - エクスポート処理中に何らかのエラーが発生した場合
BatchSystemException - エクスポート処理中にシステムエラーが発生した場合

setName

public void setName(String name)
エクスポート処理名を設定します。
この処理名を使って、エクスポート処理の排他制御を行います。
(同じ処理名をもつエクスポート処理を同時に実行することはできません。)

定義:
インタフェース ExportManager 内の setName
パラメータ:
name - エクスポート処理名
例外:
ExportInitializeException - 処理名に null が設定された場合

setEncoding

public void setEncoding(String encoding)
エクスポートファイルのエンコーディングを設定します。

定義:
インタフェース ExportManager 内の setEncoding
パラメータ:
encoding - エンコーディング
例外:
ExportInitializeException - エンコーディングに null が設定された場合

setDate

public void setDate(Date date)
日付を設定します。
設定可能な日付はシステムの有効期間内に限られます。

定義:
インタフェース ExportManager 内の setDate
パラメータ:
date - 日付
例外:
ExportInitializeException - 日付に null、または有効期間外の日付が設定された場合
関連項目:
Term.getMinDate(), Term.getMaxDate()

setFormat

public void setFormat(String format)
エクスポートファイルのフォーマットを設定します。

定義:
インタフェース ExportManager 内の setFormat
パラメータ:
format - エクスポートファイルのフォーマット
例外:
ExportInitializeException - フォーマットに null が設定された場合

setExecuteUser

public void setExecuteUser(String user)
実行ユーザを設定します。

定義:
インタフェース ExportManager 内の setExecuteUser
パラメータ:
user - 実行ユーザ
例外:
ExportInitializeException - 実行ユーザに null が設定された場合

setSize

public void setSize(int size)
エクスポート単位のデータ数を設定します。

定義:
インタフェース ExportManager 内の setSize
パラメータ:
size - エクスポート単位のデータ数
例外:
ExportInitializeException - データ数に 0 未満の数値が設定された場合

setFilter

public void setFilter(Filter filter)
エクスポートフィルタを設定します。

定義:
インタフェース ExportManager 内の setFilter
パラメータ:
filter - エクスポート条件を指定するためのフィルタ

setParameter

public void setParameter(String key,
                         Object value)
パラメータを設定します。
エクスポート実行時に使用する任意のパラメータを設定します。

定義:
インタフェース ExportManager 内の setParameter
パラメータ:
key - キー
value - 値
例外:
ExportInitializeException - パラメータのキーに null が設定された場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Filter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter
クラス Filter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.Filter
すべての実装インタフェース:
Serializable
public class Filter
extends Object
implements Serializable

エクスポート対象のデータを絞り込むための情報を保持します。

導入されたバージョン:
6.1
関連項目:
直列化された形式

コンストラクタの概要
Filter(String[] value)
コンストラクタ
設定された値以外を抽出するフィルタを構築します。
Filter(String[] value, boolean exclusive)
コンストラクタ
設定された値に対するフィルタを構築します。
メソッドの概要
String[] | getValue() フィルタリングされる値の配列を返します。
boolean | isExclusive() フィルタリング対象の値が除外されるかどうか
String | toString() フィルタの文字列表現を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Filter

public Filter(String[] value)
コンストラクタ
設定された値以外を抽出するフィルタを構築します。

パラメータ:
value - エクスポートから除外される値の配列

Filter

public Filter(String[] value,
              boolean exclusive)
コンストラクタ
設定された値に対するフィルタを構築します。
構築されたフィルタは、exclusive の値により動作が変わります。

exclusive に true が設定された場合は、value 配列に設定された値以外を抽出します。 false が設定された場合は、value 配列に設定された値のみを抽出します。

パラメータ:
value - フィルタリングされる値の配列
exclusive - フィルタリングされる値を除外するかどうかのフラグ
メソッドの詳細

isExclusive

public boolean isExclusive()
フィルタリング対象の値が除外されるかどうか

戻り値:
除外される場合 true、それ以外の場合 false

getValue

public String[] getValue()
フィルタリングされる値の配列を返します。

戻り値:
フィルタリングされる値の配列

toString

public String toString()
フィルタの文字列表現を返します。

戻り値:
フィルタの文字列表現
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.exporter (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.exporter
インタフェース
ExportManager
ExportManagerClient
クラス
AbstractExportManagerClient
ExportManagerImpl
Filter
例外
ExportInitializeException


jp.co.intra_mart.foundation.datastore.exporter (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exporter

アプリケーション共通マスタのエクスポートを行うクラスを提供します。

参照:
説明

インタフェースの概要
ExportManager | エクスポートを行います。
ExportManagerClient | エクスポートマネージャーの呼び出しを行うクライアントです。

クラスの概要
AbstractExportManagerClient | エクスポートマネージャークライアントの汎用的な実装です。
ExportManagerImpl | エクスポートマネージャーの汎用的な実装です。
Filter | エクスポート対象のデータを絞り込むための情報を保持します。

例外の概要
ExportInitializeException エクスポートの初期化でエラーが発生したことを示すためにスローされます。

パッケージ jp.co.intra_mart.foundation.datastore.exporter の説明

アプリケーション共通マスタのエクスポートを行うクラスを提供します。


jp.co.intra_mart.foundation.datastore.exporter クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exporter の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
    • class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManager)
    • class jp.co.intra_mart.foundation.datastore.exporter.Filter (implements java.io.Serializable)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.datastore.exception.BatchProcessException
            • class jp.co.intra_mart.foundation.datastore.exporter.ExportInitializeException

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager
  • interface jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient


パッケージ jp.co.intra_mart.foundation.datastore.exporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.exporter の使用

jp.co.intra_mart.foundation.datastore.exporter を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exporter | アプリケーション共通マスタのエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.common.config | エクスポート設定の解釈を行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.company | 会社・組織関連の情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.public_group | パブリックグループ情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.user | ユーザ関連の情報のエクスポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.exporter により使用される jp.co.intra_mart.foundation.datastore.exporter のクラス
ExportManager
エクスポートを行います。
ExportManagerClient
エクスポートマネージャーの呼び出しを行うクライアントです。
Filter
エクスポート対象のデータを絞り込むための情報を保持します。

jp.co.intra_mart.foundation.datastore.exporter.common.config により使用される jp.co.intra_mart.foundation.datastore.exporter のクラス
ExportInitializeException
エクスポートの初期化でエラーが発生したことを示すためにスローされます。
Filter
エクスポート対象のデータを絞り込むための情報を保持します。

jp.co.intra_mart.foundation.datastore.exporter.company により使用される jp.co.intra_mart.foundation.datastore.exporter のクラス
AbstractExportManagerClient
エクスポートマネージャークライアントの汎用的な実装です。
ExportManager
エクスポートを行います。
ExportManagerClient
エクスポートマネージャーの呼び出しを行うクライアントです。
Filter
エクスポート対象のデータを絞り込むための情報を保持します。

jp.co.intra_mart.foundation.datastore.exporter.public_group により使用される jp.co.intra_mart.foundation.datastore.exporter のクラス
AbstractExportManagerClient
エクスポートマネージャークライアントの汎用的な実装です。
ExportManager
エクスポートを行います。
ExportManagerClient
エクスポートマネージャーの呼び出しを行うクライアントです。
Filter
エクスポート対象のデータを絞り込むための情報を保持します。

jp.co.intra_mart.foundation.datastore.exporter.user により使用される jp.co.intra_mart.foundation.datastore.exporter のクラス
AbstractExportManagerClient
エクスポートマネージャークライアントの汎用的な実装です。
ExportManager
エクスポートを行います。
ExportManagerClient
エクスポートマネージャーの呼び出しを行うクライアントです。
Filter
エクスポート対象のデータを絞り込むための情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient の使用

AbstractImportManagerClient を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.importer.company | 会社・組織関連の情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.public_group | パブリックグループ情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.user | ユーザ関連の情報のインポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.importer.company での AbstractImportManagerClient の使用

jp.co.intra_mart.foundation.datastore.importer.company での AbstractImportManagerClient のサブクラス
class | CompanyImportManagerClient 会社情報のインポートを行います。
class | CompanyPostImportManagerClient 会社役職情報のインポートを行います。

jp.co.intra_mart.foundation.datastore.importer.public_group での AbstractImportManagerClient の使用

jp.co.intra_mart.foundation.datastore.importer.public_group での AbstractImportManagerClient のサブクラス
 class PublicGroupImportManagerClient
パブリックグループ情報のインポートを行います。

jp.co.intra_mart.foundation.datastore.importer.user での AbstractImportManagerClient の使用

jp.co.intra_mart.foundation.datastore.importer.user での AbstractImportManagerClient のサブクラス
class | UserAttachImportManagerClient ユーザ所属情報のインポートを行います。
class | UserProfileImportManagerClient ユーザ情報のインポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.ImportInitializeException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.ImportInitializeException の使用

ImportInitializeException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.importer.common.config インポート定義情報の解釈を行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.importer.common.config での ImportInitializeException の使用

jp.co.intra_mart.foundation.datastore.importer.common.config での ImportInitializeException のサブクラス
 class ImportConfigurationReaderException
インポート設定の読み込みでエラーが発生したことを示すためにスローされます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.importer.ImportManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.importer.ImportManager の使用

ImportManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.importer | アプリケーション共通マスタのインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.company | 会社・組織関連の情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.public_group | パブリックグループ情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.user | ユーザ関連の情報のインポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.importer での ImportManager の使用

ImportManager を実装している jp.co.intra_mart.foundation.datastore.importer のクラス
 class ImportManagerImpl
インポートマネージャーの実装です。

ImportManager を返す jp.co.intra_mart.foundation.datastore.importer のメソッド
protected abstract  ImportManager AbstractImportManagerClient.getImportManager()
インポートマネージャーのインスタンスを取得します。

ImportManager 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.importer のメソッド
protected void | AbstractImportManagerClient.setName(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義された処理名をマネージャーに設定します。
protected void | AbstractImportManagerClient.setFormat(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたインポートファイルのフォーマットをマネージャーに設定します。
protected void | AbstractImportManagerClient.setDate(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義された日付をマネージャーに設定します。
protected void | AbstractImportManagerClient.setEncoding(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたインポートファイルのエンコーディング情報をマネージャーに設定します。
protected void | AbstractImportManagerClient.setCommitCount(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたインポートデータのコミット間隔をマネージャーに設定します。
protected void | AbstractImportManagerClient.setExecuteUser(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義された実行ユーザをマネージャーに設定します。
protected void | AbstractImportManagerClient.setRetry(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたリトライステータスをマネージャーに設定します。
protected void | AbstractImportManagerClient.setValidate(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたバリデーションステータスをマネージャーに設定します。
protected void | AbstractImportManagerClient.setParameters(ImportManager manager, ImportConfigurationReader reader) エクスポート設定に定義されたパラメータ情報をマネージャーに設定します。

jp.co.intra_mart.foundation.datastore.importer.company での ImportManager の使用

ImportManager を実装している jp.co.intra_mart.foundation.datastore.importer.company のクラス
class | CompanyImportManager 会社情報のインポートを行います。
class | CompanyPostImportManager 会社役職情報のインポートを行います。

ImportManager を返す jp.co.intra_mart.foundation.datastore.importer.company のメソッド
protected ImportManager | CompanyPostImportManagerClient.getImportManager()
protected ImportManager | CompanyImportManagerClient.getImportManager()

jp.co.intra_mart.foundation.datastore.importer.public_group での ImportManager の使用

ImportManager を実装している jp.co.intra_mart.foundation.datastore.importer.public_group のクラス
 class PublicGroupImportManager
パブリックグループ情報のインポートを行います。

ImportManager を返す jp.co.intra_mart.foundation.datastore.importer.public_group のメソッド
protected  ImportManager PublicGroupImportManagerClient.getImportManager()

jp.co.intra_mart.foundation.datastore.importer.user での ImportManager の使用

ImportManager を実装している jp.co.intra_mart.foundation.datastore.importer.user のクラス
class | UserAttachImportManager ユーザ所属情報のインポートを行います。
class | UserProfileImportManager ユーザ情報のインポートを行います。

ImportManager を返す jp.co.intra_mart.foundation.datastore.importer.user のメソッド
protected ImportManager | UserProfileImportManagerClient.getImportManager()
protected ImportManager | UserAttachImportManagerClient.getImportManager()

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient の使用

ImportManagerClient を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.importer | アプリケーション共通マスタのインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.company | 会社・組織関連の情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.public_group | パブリックグループ情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.user | ユーザ関連の情報のインポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.importer での ImportManagerClient の使用

ImportManagerClient を実装している jp.co.intra_mart.foundation.datastore.importer のクラス
 class AbstractImportManagerClient
インポートマネージャークライアントの汎用的な実装です。

jp.co.intra_mart.foundation.datastore.importer.company での ImportManagerClient の使用

ImportManagerClient を実装している jp.co.intra_mart.foundation.datastore.importer.company のクラス
class | CompanyImportManagerClient 会社情報のインポートを行います。
class | CompanyPostImportManagerClient 会社役職情報のインポートを行います。

jp.co.intra_mart.foundation.datastore.importer.public_group での ImportManagerClient の使用

ImportManagerClient を実装している jp.co.intra_mart.foundation.datastore.importer.public_group のクラス
 class PublicGroupImportManagerClient
パブリックグループ情報のインポートを行います。

jp.co.intra_mart.foundation.datastore.importer.user での ImportManagerClient の使用

ImportManagerClient を実装している jp.co.intra_mart.foundation.datastore.importer.user のクラス
class | UserAttachImportManagerClient ユーザ所属情報のインポートを行います。
class | UserProfileImportManagerClient ユーザ情報のインポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl の使用

jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader の使用

ImportConfigurationReader を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.importer | アプリケーション共通マスタのインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.company | 会社・組織関連の情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.public_group | パブリックグループ情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.user | ユーザ関連の情報のインポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.importer での ImportConfigurationReader の使用

ImportConfigurationReader を返す jp.co.intra_mart.foundation.datastore.importer のメソッド
protected abstract  ImportConfigurationReader AbstractImportManagerClient.getConfigurationReader(InputStream inputStream)
入力ストリームからポート設定情報を取得します。

ImportConfigurationReader 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.importer のメソッド
protected void | AbstractImportManagerClient.setName(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義された処理名をマネージャーに設定します。
protected void | AbstractImportManagerClient.setFormat(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたインポートファイルのフォーマットをマネージャーに設定します。
protected void | AbstractImportManagerClient.setDate(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義された日付をマネージャーに設定します。
protected void | AbstractImportManagerClient.setEncoding(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたインポートファイルのエンコーディング情報をマネージャーに設定します。
protected void | AbstractImportManagerClient.setCommitCount(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたインポートデータのコミット間隔をマネージャーに設定します。
protected void | AbstractImportManagerClient.setExecuteUser(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義された実行ユーザをマネージャーに設定します。
protected void | AbstractImportManagerClient.setRetry(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたリトライステータスをマネージャーに設定します。
protected void | AbstractImportManagerClient.setValidate(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたバリデーションステータスをマネージャーに設定します。
protected void | AbstractImportManagerClient.setParameters(ImportManager manager, ImportConfigurationReader reader) エクスポート設定に定義されたパラメータ情報をマネージャーに設定します。

jp.co.intra_mart.foundation.datastore.importer.company での ImportConfigurationReader の使用

ImportConfigurationReader を返す jp.co.intra_mart.foundation.datastore.importer.company のメソッド
protected ImportConfigurationReader | CompanyPostImportManagerClient.getConfigurationReader(InputStream inputStream)
protected ImportConfigurationReader | CompanyImportManagerClient.getConfigurationReader(InputStream inputStream)

jp.co.intra_mart.foundation.datastore.importer.public_group での ImportConfigurationReader の使用

ImportConfigurationReader を返す jp.co.intra_mart.foundation.datastore.importer.public_group のメソッド
protected  ImportConfigurationReader PublicGroupImportManagerClient.getConfigurationReader(InputStream inputStream)

jp.co.intra_mart.foundation.datastore.importer.user での ImportConfigurationReader の使用

ImportConfigurationReader を返す jp.co.intra_mart.foundation.datastore.importer.user のメソッド
protected ImportConfigurationReader | UserProfileImportManagerClient.getConfigurationReader(InputStream inputStream)
protected ImportConfigurationReader | UserAttachImportManagerClient.getConfigurationReader(InputStream inputStream)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReaderException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReaderException の使用

jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReaderException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ImportConfigurationReader (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer.common.config
インタフェース ImportConfigurationReader

public interface ImportConfigurationReader

インポート設定情報の読込みを行います。

導入されたバージョン:
6.1

メソッドの概要
int | getCommitCount() コミット間隔を取得します。
Date | getDate() 日付を取得します。
String | getEncoding() インポートデータのエンコーディング情報を取得します。
String | getExecuteUser() 実行ユーザコードを取得します。
String[] | getExtensionParameterNames() パラメータ名の一覧を取得します。
String | getExtensionParameterValue(String key) 指定されたキーに対するパラメータ値を取得します。
String | getFormat() インポートデータのフォーマットを取得します。
String[] | getImportFileSet(String defaultPath) インポートデータのファイルパスの一覧を取得します。
String | getName() インポート処理名を取得します。
void | initialize(String rootName) 初期化を行います。
Boolean | isRetry() インポート異常終了後の再実行時に、リトライ処理として実行するかどうか。
Boolean | isValidate() インポートデータに対してバリデーションを行うかどうか。

メソッドの詳細

initialize

public void initialize(String rootName)
初期化を行います。
指定された要素内に定義された設定情報を読込みます。

パラメータ:
rootName - 設定情報を定義するルート要素の名前

getName

public String getName()
インポート処理名を取得します。

戻り値:
インスポート処理名
例外:
ImportConfigurationReaderException - 設定情報の定義が不正な場合

getFormat

public String getFormat()
インポートデータのフォーマットを取得します。

戻り値:
インポートデータのフォーマット
例外:
ImportConfigurationReaderException - 設定情報の定義が不正な場合

getDate

public Date getDate()
日付を取得します。

戻り値:
日付
例外:
ImportConfigurationReaderException - 設定情報の定義が不正な場合

getEncoding

public String getEncoding()
インポートデータのエンコーディング情報を取得します。

戻り値:
インポートデータのエンコーディング情報
例外:
ImportConfigurationReaderException - 設定情報の定義が不正な場合

getExecuteUser

public String getExecuteUser()
実行ユーザコードを取得します。

戻り値:
実行ユーザコード
例外:
ImportConfigurationReaderException - 設定情報の定義が不正な場合

getImportFileSet

public String[] getImportFileSet(String defaultPath)
インポートデータのファイルパスの一覧を取得します。
デフォルトファイルパス情報は、インポート設定にインポートファイルパスの情報が 設定されていない場合に使用されます。

パラメータ:
defaultPath - デフォルトのファイルパス情報
戻り値:
入力ファイルパスの配列
例外:
ImportConfigurationReaderException - 設定情報の定義が不正な場合

getCommitCount

public int getCommitCount()
コミット間隔を取得します。

戻り値:
コミット間隔

isRetry

public Boolean isRetry()
インポート異常終了後の再実行時に、リトライ処理として実行するかどうか。

戻り値:
リトライを行う場合 true、それ以外の場合は false

isValidate

public Boolean isValidate()
インポートデータに対してバリデーションを行うかどうか。

戻り値:
バリデーションを行う場合 true、それ以外の場合は false

getExtensionParameterNames

public String[] getExtensionParameterNames()
パラメータ名の一覧を取得します。

戻り値:
パラメータ名の一覧

getExtensionParameterValue

public String getExtensionParameterValue(String key)
指定されたキーに対するパラメータ値を取得します。

パラメータ:
key - キー
戻り値:
パラメータ値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ImportConfigurationReaderException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer.common.config
クラス ImportConfigurationReaderException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.datastore.exception.BatchProcessException
                    拡張 jp.co.intra_mart.foundation.datastore.importer.ImportInitializeException
                        拡張 jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReaderException
すべての実装インタフェース:
Serializable
public class ImportConfigurationReaderException
extends ImportInitializeException

インポート設定の読み込みでエラーが発生したことを示すためにスローされます。

導入されたバージョン:
6.1
関連項目:
直列化された形式

コンストラクタの概要
ImportConfigurationReaderException(String message)
コンストラクタ
ImportConfigurationReaderException(String message, Throwable cause)
コンストラクタ
ImportConfigurationReaderException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ImportConfigurationReaderException

public ImportConfigurationReaderException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

ImportConfigurationReaderException

public ImportConfigurationReaderException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

ImportConfigurationReaderException

public ImportConfigurationReaderException(String message,
                                          Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.importer.common.config (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.importer.common.config
インタフェース
ImportConfigurationReader
例外
ImportConfigurationReaderException


jp.co.intra_mart.foundation.datastore.importer.common.config (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.importer.common.config

インポート定義情報の解釈を行うクラスを提供します。

参照:
説明

インタフェースの概要
ImportConfigurationReader インポート設定情報の読込みを行います。

例外の概要
ImportConfigurationReaderException インポート設定の読み込みでエラーが発生したことを示すためにスローされます。

パッケージ jp.co.intra_mart.foundation.datastore.importer.common.config の説明

インポート定義情報の解釈を行うクラスを提供します。


jp.co.intra_mart.foundation.datastore.importer.common.config クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.importer.common.config の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.datastore.exception.BatchProcessException
            • class jp.co.intra_mart.foundation.datastore.importer.ImportInitializeException
              • class jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReaderException

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader


パッケージ jp.co.intra_mart.foundation.datastore.importer.common.config の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.importer.common.config の使用

jp.co.intra_mart.foundation.datastore.importer.common.config を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.importer | アプリケーション共通マスタのインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.company | 会社・組織関連の情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.public_group | パブリックグループ情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.user | ユーザ関連の情報のインポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.importer により使用される jp.co.intra_mart.foundation.datastore.importer.common.config のクラス
ImportConfigurationReader
インポート設定情報の読込みを行います。

jp.co.intra_mart.foundation.datastore.importer.company により使用される jp.co.intra_mart.foundation.datastore.importer.common.config のクラス
ImportConfigurationReader
インポート設定情報の読込みを行います。

jp.co.intra_mart.foundation.datastore.importer.public_group により使用される jp.co.intra_mart.foundation.datastore.importer.common.config のクラス
ImportConfigurationReader
インポート設定情報の読込みを行います。

jp.co.intra_mart.foundation.datastore.importer.user により使用される jp.co.intra_mart.foundation.datastore.importer.common.config のクラス
ImportConfigurationReader
インポート設定情報の読込みを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager の使用

jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient の使用

jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager の使用

jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient の使用

jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CompanyImportManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer.company
クラス CompanyImportManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager
すべての実装インタフェース:
ImportManager
public class CompanyImportManager
extends Object
implements ImportManager

会社情報のインポートを行います。

導入されたバージョン:
6.1

コンストラクタの概要
CompanyImportManager()
コンストラクタ 会社インポートマネージャーのインスタンスを生成します。
メソッドの概要
void | execute(InputStream inputStream) インポートを実行します。
void | execute(String[] path) インポートを実行します。
void | setCommitCount(int commitCount) コミット間隔を設定します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) インポートファイルのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザを設定します。
void | setFormat(String format) インポートファイルのフォーマットを設定します。
void | setName(String name) インポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setRetry(boolean retry) インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
void | setValidate(boolean validate) インポートデータに対してバリデーションを行うかどうか設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyImportManager

public CompanyImportManager()
コンストラクタ 会社インポートマネージャーのインスタンスを生成します。

メソッドの詳細

execute

public void execute(String[] path)
インタフェース ImportManager の記述:
インポートを実行します。

定義:
インタフェース ImportManager 内の execute
パラメータ:
path - インポートファイルのパス

execute

public void execute(InputStream inputStream)
インタフェース ImportManager の記述:
インポートを実行します。

定義:
インタフェース ImportManager 内の execute
パラメータ:
inputStream - インポートデータ

setFormat

public void setFormat(String format)
インタフェース ImportManager の記述:
インポートファイルのフォーマットを設定します。

定義:
インタフェース ImportManager 内の setFormat
パラメータ:
format - インポートファイルのフォーマット

setCommitCount

public void setCommitCount(int commitCount)
インタフェース ImportManager の記述:
コミット間隔を設定します。
ここで設定された件数分のデータの更新が行われたらコミットを実行します。

定義:
インタフェース ImportManager 内の setCommitCount
パラメータ:
commitCount - コミット間隔

setDate

public void setDate(Date date)
インタフェース ImportManager の記述:
日付を設定します。

定義:
インタフェース ImportManager 内の setDate
パラメータ:
date - 日付

setEncoding

public void setEncoding(String encoding)
インタフェース ImportManager の記述:
インポートファイルのエンコーディングを設定します。

定義:
インタフェース ImportManager 内の setEncoding
パラメータ:
encoding - エンコーディング

setExecuteUser

public void setExecuteUser(String user)
インタフェース ImportManager の記述:
実行ユーザを設定します。

定義:
インタフェース ImportManager 内の setExecuteUser
パラメータ:
user - 実行ユーザ

setName

public void setName(String name)
インタフェース ImportManager の記述:
インポート処理名を設定します。

定義:
インタフェース ImportManager 内の setName
パラメータ:
name - インポート処理名

setParameter

public void setParameter(String key,
                         Object value)
インタフェース ImportManager の記述:
パラメータを設定します。

定義:
インタフェース ImportManager 内の setParameter
パラメータ:
key - キー
value - 値

setRetry

public void setRetry(boolean retry)
インタフェース ImportManager の記述:
インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
リトライステータスが true に設定された場合、リトライとして再実行します。 この時、前回の処理でコミットしたデータの登録処理はスキップされます。
リトライステータスが false に設定された場合、最初からインポート処理をやり直します。

定義:
インタフェース ImportManager 内の setRetry
パラメータ:
retry - リトライとして実行するかどうか

setValidate

public void setValidate(boolean validate)
インタフェース ImportManager の記述:
インポートデータに対してバリデーションを行うかどうか設定します。
バリデーションステータスが true に設定された場合、バリデーションを実行します。 false に設定された場合は、バリデーションは実行しません。

定義:
インタフェース ImportManager 内の setValidate
パラメータ:
validate - バリデーションを行うかどうか
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyImportManagerClient (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer.company
クラス CompanyImportManagerClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient
        拡張 jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient
すべての実装インタフェース:
ImportManagerClient
public class CompanyImportManagerClient
extends AbstractImportManagerClient
implements ImportManagerClient

会社情報のインポートを行います。

このクラスは、CompanyImportManager クラスのクライアントになります。
executeメソッドに指定された設定情報を解釈した後、CompanyImportManager クラスに インポート処理を委譲します。

導入されたバージョン:
6.1

コンストラクタの概要
CompanyImportManagerClient()
メソッドの概要
boolean | execute(InputStream configuration) 指定された定義情報をもとにインポート処理を行います。
boolean | execute(String configurationPath) 指定された定義情報をもとにインポート処理を行います。
protected ImportConfigurationReader | getConfigurationReader(InputStream inputStream) 入力ストリームからポート設定情報を取得します。
protected String | getDefaultImportPath() インポートファイルのデフォルトパス情報を取得します。
protected ImportManager | getImportManager() インポートマネージャーのインスタンスを取得します。
クラス jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient から継承したメソッド
setCommitCount, setDate, setEncoding, setExecuteUser, setFormat, setName, setParameters, setRetry, setValidate
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyImportManagerClient

public CompanyImportManagerClient()
メソッドの詳細

execute

public boolean execute(String configurationPath)
指定された定義情報をもとにインポート処理を行います。

定義:
インタフェース ImportManagerClient 内の execute
オーバーライド:
クラス AbstractImportManagerClient 内の execute
パラメータ:
configurationPath - 定義ファイルパス
戻り値:
インポートに成功した場合 true、失敗した場合 false

execute

public boolean execute(InputStream configuration)
指定された定義情報をもとにインポート処理を行います。

定義:
インタフェース ImportManagerClient 内の execute
オーバーライド:
クラス AbstractImportManagerClient 内の execute
パラメータ:
configuration - 定義情報
戻り値:
インポートに成功した場合 true、失敗した場合 false

getImportManager

protected ImportManager getImportManager()
クラス AbstractImportManagerClient の記述:
インポートマネージャーのインスタンスを取得します。

定義:
クラス AbstractImportManagerClient 内の getImportManager
戻り値:
インポートマネージャー

getConfigurationReader

protected ImportConfigurationReader getConfigurationReader(InputStream inputStream)
クラス AbstractImportManagerClient の記述:
入力ストリームからポート設定情報を取得します。

定義:
クラス AbstractImportManagerClient 内の getConfigurationReader
パラメータ:
inputStream - 入力ストリーム
戻り値:
インポート設定リーダー

getDefaultImportPath

protected String getDefaultImportPath()
クラス AbstractImportManagerClient の記述:
インポートファイルのデフォルトパス情報を取得します。

定義:
クラス AbstractImportManagerClient 内の getDefaultImportPath
戻り値:
デフォルト定義パス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyPostImportManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer.company
クラス CompanyPostImportManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager
すべての実装インタフェース:
ImportManager
public class CompanyPostImportManager
extends Object
implements ImportManager

会社役職情報のインポートを行います。

導入されたバージョン:
6.1

コンストラクタの概要
CompanyPostImportManager()
コンストラクタ 会社役職インポートマネージャーのインスタンスを生成します。
メソッドの概要
void | execute(InputStream inputStream) インポートを実行します。
void | execute(String[] path) インポートを実行します。
void | setCommitCount(int commitCount) コミット間隔を設定します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) インポートファイルのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザを設定します。
void | setFormat(String format) インポートファイルのフォーマットを設定します。
void | setName(String name) インポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setRetry(boolean retry) インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
void | setValidate(boolean validate) インポートデータに対してバリデーションを行うかどうか設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyPostImportManager

public CompanyPostImportManager()
コンストラクタ 会社役職インポートマネージャーのインスタンスを生成します。

メソッドの詳細

execute

public void execute(String[] path)
インタフェース ImportManager の記述:
インポートを実行します。

定義:
インタフェース ImportManager 内の execute
パラメータ:
path - インポートファイルのパス

execute

public void execute(InputStream inputStream)
インタフェース ImportManager の記述:
インポートを実行します。

定義:
インタフェース ImportManager 内の execute
パラメータ:
inputStream - インポートデータ

setFormat

public void setFormat(String format)
インタフェース ImportManager の記述:
インポートファイルのフォーマットを設定します。

定義:
インタフェース ImportManager 内の setFormat
パラメータ:
format - インポートファイルのフォーマット

setCommitCount

public void setCommitCount(int commitCount)
インタフェース ImportManager の記述:
コミット間隔を設定します。
ここで設定された件数分のデータの更新が行われたらコミットを実行します。

定義:
インタフェース ImportManager 内の setCommitCount
パラメータ:
commitCount - コミット間隔

setDate

public void setDate(Date date)
インタフェース ImportManager の記述:
日付を設定します。

定義:
インタフェース ImportManager 内の setDate
パラメータ:
date - 日付

setEncoding

public void setEncoding(String encoding)
インタフェース ImportManager の記述:
インポートファイルのエンコーディングを設定します。

定義:
インタフェース ImportManager 内の setEncoding
パラメータ:
encoding - エンコーディング

setExecuteUser

public void setExecuteUser(String user)
インタフェース ImportManager の記述:
実行ユーザを設定します。

定義:
インタフェース ImportManager 内の setExecuteUser
パラメータ:
user - 実行ユーザ

setName

public void setName(String name)
インタフェース ImportManager の記述:
インポート処理名を設定します。

定義:
インタフェース ImportManager 内の setName
パラメータ:
name - インポート処理名

setParameter

public void setParameter(String key,
                         Object value)
インタフェース ImportManager の記述:
パラメータを設定します。

定義:
インタフェース ImportManager 内の setParameter
パラメータ:
key - キー
value - 値

setRetry

public void setRetry(boolean retry)
インタフェース ImportManager の記述:
インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
リトライステータスが true に設定された場合、リトライとして再実行します。 この時、前回の処理でコミットしたデータの登録処理はスキップされます。
リトライステータスが false に設定された場合、最初からインポート処理をやり直します。

定義:
インタフェース ImportManager 内の setRetry
パラメータ:
retry - リトライとして実行するかどうか

setValidate

public void setValidate(boolean validate)
インタフェース ImportManager の記述:
インポートデータに対してバリデーションを行うかどうか設定します。
バリデーションステータスが true に設定された場合、バリデーションを実行します。 false に設定された場合は、バリデーションは実行しません。

定義:
インタフェース ImportManager 内の setValidate
パラメータ:
validate - バリデーションを行うかどうか
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyPostImportManagerClient (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer.company
クラス CompanyPostImportManagerClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient
        拡張 jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient
すべての実装インタフェース:
ImportManagerClient
public class CompanyPostImportManagerClient
extends AbstractImportManagerClient
implements ImportManagerClient

会社役職情報のインポートを行います。

このクラスは、CompanyPostImportManager クラスのクライアントになります。
executeメソッドに指定された設定情報を解釈した後、CompanyPostImportManager クラスに インポート処理を委譲します。

導入されたバージョン:
6.1

コンストラクタの概要
CompanyPostImportManagerClient()
メソッドの概要
boolean | execute(InputStream configuration) 指定された定義情報をもとにインポート処理を行います。
boolean | execute(String configurationPath) 指定された定義情報をもとにインポート処理を行います。
protected ImportConfigurationReader | getConfigurationReader(InputStream inputStream) 入力ストリームからポート設定情報を取得します。
protected String | getDefaultImportPath() インポートファイルのデフォルトパス情報を取得します。
protected ImportManager | getImportManager() インポートマネージャーのインスタンスを取得します。
クラス jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient から継承したメソッド
setCommitCount, setDate, setEncoding, setExecuteUser, setFormat, setName, setParameters, setRetry, setValidate
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyPostImportManagerClient

public CompanyPostImportManagerClient()
メソッドの詳細

execute

public boolean execute(String configurationPath)
指定された定義情報をもとにインポート処理を行います。

定義:
インタフェース ImportManagerClient 内の execute
オーバーライド:
クラス AbstractImportManagerClient 内の execute
パラメータ:
configurationPath - 定義ファイルパス
戻り値:
インポートに成功した場合 true、失敗した場合 false

execute

public boolean execute(InputStream configuration)
指定された定義情報をもとにインポート処理を行います。

定義:
インタフェース ImportManagerClient 内の execute
オーバーライド:
クラス AbstractImportManagerClient 内の execute
パラメータ:
configuration - 定義情報
戻り値:
インポートに成功した場合 true、失敗した場合 false

getImportManager

protected ImportManager getImportManager()
クラス AbstractImportManagerClient の記述:
インポートマネージャーのインスタンスを取得します。

定義:
クラス AbstractImportManagerClient 内の getImportManager
戻り値:
インポートマネージャー

getConfigurationReader

protected ImportConfigurationReader getConfigurationReader(InputStream inputStream)
クラス AbstractImportManagerClient の記述:
入力ストリームからポート設定情報を取得します。

定義:
クラス AbstractImportManagerClient 内の getConfigurationReader
パラメータ:
inputStream - 入力ストリーム
戻り値:
インポート設定リーダー

getDefaultImportPath

protected String getDefaultImportPath()
クラス AbstractImportManagerClient の記述:
インポートファイルのデフォルトパス情報を取得します。

定義:
クラス AbstractImportManagerClient 内の getDefaultImportPath
戻り値:
デフォルト定義パス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.importer.company (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.importer.company
クラス
CompanyImportManager
CompanyImportManagerClient
CompanyPostImportManager
CompanyPostImportManagerClient


jp.co.intra_mart.foundation.datastore.importer.company (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.importer.company

会社・組織関連の情報のインポートを行うクラスを提供します。

参照:
説明

クラスの概要
CompanyImportManager | 会社情報のインポートを行います。
CompanyImportManagerClient | 会社情報のインポートを行います。
CompanyPostImportManager | 会社役職情報のインポートを行います。
CompanyPostImportManagerClient | 会社役職情報のインポートを行います。

パッケージ jp.co.intra_mart.foundation.datastore.importer.company の説明

会社・組織関連の情報のインポートを行うクラスを提供します。


jp.co.intra_mart.foundation.datastore.importer.company クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.importer.company の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
    • class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager (implements jp.co.intra_mart.foundation.datastore.importer.ImportManager)
    • class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager (implements jp.co.intra_mart.foundation.datastore.importer.ImportManager)


パッケージ jp.co.intra_mart.foundation.datastore.importer.company の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.importer.company の使用

jp.co.intra_mart.foundation.datastore.importer.company はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager の使用

jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient の使用

jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.importer.public_group (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.importer.public_group
クラス
PublicGroupImportManager
PublicGroupImportManagerClient


jp.co.intra_mart.foundation.datastore.importer.public_group (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.importer.public_group

パブリックグループ情報のインポートを行うクラスを提供します。

参照:
説明

クラスの概要
PublicGroupImportManager | パブリックグループ情報のインポートを行います。
PublicGroupImportManagerClient | パブリックグループ情報のインポートを行います。

パッケージ jp.co.intra_mart.foundation.datastore.importer.public_group の説明

パブリックグループ情報のインポートを行うクラスを提供します。


jp.co.intra_mart.foundation.datastore.importer.public_group クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.importer.public_group の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
    • class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager (implements jp.co.intra_mart.foundation.datastore.importer.ImportManager)


パッケージ jp.co.intra_mart.foundation.datastore.importer.public_group の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.importer.public_group の使用

jp.co.intra_mart.foundation.datastore.importer.public_group はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupImportManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer.public_group
クラス PublicGroupImportManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager
すべての実装インタフェース:
ImportManager
public class PublicGroupImportManager
extends Object
implements ImportManager

パブリックグループ情報のインポートを行います。

導入されたバージョン:
6.1

コンストラクタの概要
PublicGroupImportManager()
コンストラクタ パブリックグループインポートマネージャーのインスタンスを生成します。
メソッドの概要
void | execute(InputStream inputStream) インポートを実行します。
void | execute(String[] path) インポートを実行します。
void | setCommitCount(int commitCount) コミット間隔を設定します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) インポートファイルのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザを設定します。
void | setFormat(String format) インポートファイルのフォーマットを設定します。
void | setName(String name) インポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setRetry(boolean retry) インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
void | setValidate(boolean validate) インポートデータに対してバリデーションを行うかどうか設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupImportManager

public PublicGroupImportManager()
コンストラクタ パブリックグループインポートマネージャーのインスタンスを生成します。

メソッドの詳細

execute

public void execute(String[] path)
インタフェース ImportManager の記述:
インポートを実行します。

定義:
インタフェース ImportManager 内の execute
パラメータ:
path - インポートファイルのパス

execute

public void execute(InputStream inputStream)
インタフェース ImportManager の記述:
インポートを実行します。

定義:
インタフェース ImportManager 内の execute
パラメータ:
inputStream - インポートデータ

setFormat

public void setFormat(String format)
インタフェース ImportManager の記述:
インポートファイルのフォーマットを設定します。

定義:
インタフェース ImportManager 内の setFormat
パラメータ:
format - インポートファイルのフォーマット

setCommitCount

public void setCommitCount(int commitCount)
インタフェース ImportManager の記述:
コミット間隔を設定します。
ここで設定された件数分のデータの更新が行われたらコミットを実行します。

定義:
インタフェース ImportManager 内の setCommitCount
パラメータ:
commitCount - コミット間隔

setDate

public void setDate(Date date)
インタフェース ImportManager の記述:
日付を設定します。

定義:
インタフェース ImportManager 内の setDate
パラメータ:
date - 日付

setEncoding

public void setEncoding(String encoding)
インタフェース ImportManager の記述:
インポートファイルのエンコーディングを設定します。

定義:
インタフェース ImportManager 内の setEncoding
パラメータ:
encoding - エンコーディング

setExecuteUser

public void setExecuteUser(String user)
インタフェース ImportManager の記述:
実行ユーザを設定します。

定義:
インタフェース ImportManager 内の setExecuteUser
パラメータ:
user - 実行ユーザ

setName

public void setName(String name)
インタフェース ImportManager の記述:
インポート処理名を設定します。

定義:
インタフェース ImportManager 内の setName
パラメータ:
name - インポート処理名

setParameter

public void setParameter(String key,
                         Object value)
インタフェース ImportManager の記述:
パラメータを設定します。

定義:
インタフェース ImportManager 内の setParameter
パラメータ:
key - キー
value - 値

setRetry

public void setRetry(boolean retry)
インタフェース ImportManager の記述:
インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
リトライステータスが true に設定された場合、リトライとして再実行します。 この時、前回の処理でコミットしたデータの登録処理はスキップされます。
リトライステータスが false に設定された場合、最初からインポート処理をやり直します。

定義:
インタフェース ImportManager 内の setRetry
パラメータ:
retry - リトライとして実行するかどうか

setValidate

public void setValidate(boolean validate)
インタフェース ImportManager の記述:
インポートデータに対してバリデーションを行うかどうか設定します。
バリデーションステータスが true に設定された場合、バリデーションを実行します。 false に設定された場合は、バリデーションは実行しません。

定義:
インタフェース ImportManager 内の setValidate
パラメータ:
validate - バリデーションを行うかどうか
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupImportManagerClient (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer.public_group
クラス PublicGroupImportManagerClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient
        拡張 jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient
すべての実装インタフェース:
ImportManagerClient
public class PublicGroupImportManagerClient
extends AbstractImportManagerClient
implements ImportManagerClient

パブリックグループ情報のインポートを行います。

このクラスは、PublicGroupImportManager クラスのクライアントになります。
executeメソッドに指定された設定情報を解釈した後、PublicGroupImportManager クラスに インポート処理を委譲します。

導入されたバージョン:
6.1

コンストラクタの概要
PublicGroupImportManagerClient()
メソッドの概要
boolean | execute(InputStream configuration) 指定された定義情報をもとにインポート処理を行います。
boolean | execute(String configurationPath) 指定された定義情報をもとにインポート処理を行います。
protected ImportConfigurationReader | getConfigurationReader(InputStream inputStream) 入力ストリームからポート設定情報を取得します。
protected String | getDefaultImportPath() インポートファイルのデフォルトパス情報を取得します。
protected ImportManager | getImportManager() インポートマネージャーのインスタンスを取得します。
クラス jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient から継承したメソッド
setCommitCount, setDate, setEncoding, setExecuteUser, setFormat, setName, setParameters, setRetry, setValidate
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupImportManagerClient

public PublicGroupImportManagerClient()
メソッドの詳細

execute

public boolean execute(String configurationPath)
指定された定義情報をもとにインポート処理を行います。

定義:
インタフェース ImportManagerClient 内の execute
オーバーライド:
クラス AbstractImportManagerClient 内の execute
パラメータ:
configurationPath - 定義ファイルパス
戻り値:
インポートに成功した場合 true、失敗した場合 false

execute

public boolean execute(InputStream configuration)
指定された定義情報をもとにインポート処理を行います。

定義:
インタフェース ImportManagerClient 内の execute
オーバーライド:
クラス AbstractImportManagerClient 内の execute
パラメータ:
configuration - 定義情報
戻り値:
インポートに成功した場合 true、失敗した場合 false

getImportManager

protected ImportManager getImportManager()
クラス AbstractImportManagerClient の記述:
インポートマネージャーのインスタンスを取得します。

定義:
クラス AbstractImportManagerClient 内の getImportManager
戻り値:
インポートマネージャー

getConfigurationReader

protected ImportConfigurationReader getConfigurationReader(InputStream inputStream)
クラス AbstractImportManagerClient の記述:
入力ストリームからポート設定情報を取得します。

定義:
クラス AbstractImportManagerClient 内の getConfigurationReader
パラメータ:
inputStream - 入力ストリーム
戻り値:
インポート設定リーダー

getDefaultImportPath

protected String getDefaultImportPath()
クラス AbstractImportManagerClient の記述:
インポートファイルのデフォルトパス情報を取得します。

定義:
クラス AbstractImportManagerClient 内の getDefaultImportPath
戻り値:
デフォルト定義パス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager の使用

jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient の使用

jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager の使用

jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient の使用

jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.importer.user (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.importer.user
クラス
UserAttachImportManager
UserAttachImportManagerClient
UserProfileImportManager
UserProfileImportManagerClient


jp.co.intra_mart.foundation.datastore.importer.user (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.importer.user

ユーザ関連の情報のインポートを行うクラスを提供します。

参照:
説明

クラスの概要
UserAttachImportManager | ユーザ所属情報のインポートを行います。
UserAttachImportManagerClient | ユーザ所属情報のインポートを行います。
UserProfileImportManager | ユーザ情報のインポートを行います。
UserProfileImportManagerClient | ユーザ情報のインポートを行います。

パッケージ jp.co.intra_mart.foundation.datastore.importer.user の説明

ユーザ関連の情報のインポートを行うクラスを提供します。


jp.co.intra_mart.foundation.datastore.importer.user クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.importer.user の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
    • class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager (implements jp.co.intra_mart.foundation.datastore.importer.ImportManager)
    • class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager (implements jp.co.intra_mart.foundation.datastore.importer.ImportManager)


パッケージ jp.co.intra_mart.foundation.datastore.importer.user の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.importer.user の使用

jp.co.intra_mart.foundation.datastore.importer.user はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


UserAttachImportManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer.user
クラス UserAttachImportManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager
すべての実装インタフェース:
ImportManager
public class UserAttachImportManager
extends Object
implements ImportManager

ユーザ所属情報のインポートを行います。

導入されたバージョン:
6.1

コンストラクタの概要
UserAttachImportManager()
コンストラクタ ユーザ所属情報インポートマネージャーのインスタンスを生成します。
メソッドの概要
void | execute(InputStream inputStream) インポートを実行します。
void | execute(String[] path) インポートを実行します。
void | setCommitCount(int commitCount) コミット間隔を設定します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) インポートファイルのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザを設定します。
void | setFormat(String format) インポートファイルのフォーマットを設定します。
void | setName(String name) インポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setRetry(boolean retry) インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
void | setValidate(boolean validate) インポートデータに対してバリデーションを行うかどうか設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserAttachImportManager

public UserAttachImportManager()
コンストラクタ ユーザ所属情報インポートマネージャーのインスタンスを生成します。

メソッドの詳細

execute

public void execute(String[] path)
インタフェース ImportManager の記述:
インポートを実行します。

定義:
インタフェース ImportManager 内の execute
パラメータ:
path - インポートファイルのパス

execute

public void execute(InputStream inputStream)
インタフェース ImportManager の記述:
インポートを実行します。

定義:
インタフェース ImportManager 内の execute
パラメータ:
inputStream - インポートデータ

setFormat

public void setFormat(String format)
インタフェース ImportManager の記述:
インポートファイルのフォーマットを設定します。

定義:
インタフェース ImportManager 内の setFormat
パラメータ:
format - インポートファイルのフォーマット

setCommitCount

public void setCommitCount(int commitCount)
インタフェース ImportManager の記述:
コミット間隔を設定します。
ここで設定された件数分のデータの更新が行われたらコミットを実行します。

定義:
インタフェース ImportManager 内の setCommitCount
パラメータ:
commitCount - コミット間隔

setDate

public void setDate(Date date)
インタフェース ImportManager の記述:
日付を設定します。

定義:
インタフェース ImportManager 内の setDate
パラメータ:
date - 日付

setEncoding

public void setEncoding(String encoding)
インタフェース ImportManager の記述:
インポートファイルのエンコーディングを設定します。

定義:
インタフェース ImportManager 内の setEncoding
パラメータ:
encoding - エンコーディング

setExecuteUser

public void setExecuteUser(String user)
インタフェース ImportManager の記述:
実行ユーザを設定します。

定義:
インタフェース ImportManager 内の setExecuteUser
パラメータ:
user - 実行ユーザ

setName

public void setName(String name)
インタフェース ImportManager の記述:
インポート処理名を設定します。

定義:
インタフェース ImportManager 内の setName
パラメータ:
name - インポート処理名

setParameter

public void setParameter(String key,
                         Object value)
インタフェース ImportManager の記述:
パラメータを設定します。

定義:
インタフェース ImportManager 内の setParameter
パラメータ:
key - キー
value - 値

setRetry

public void setRetry(boolean retry)
インタフェース ImportManager の記述:
インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
リトライステータスが true に設定された場合、リトライとして再実行します。 この時、前回の処理でコミットしたデータの登録処理はスキップされます。
リトライステータスが false に設定された場合、最初からインポート処理をやり直します。

定義:
インタフェース ImportManager 内の setRetry
パラメータ:
retry - リトライとして実行するかどうか

setValidate

public void setValidate(boolean validate)
インタフェース ImportManager の記述:
インポートデータに対してバリデーションを行うかどうか設定します。
バリデーションステータスが true に設定された場合、バリデーションを実行します。 false に設定された場合は、バリデーションは実行しません。

定義:
インタフェース ImportManager 内の setValidate
パラメータ:
validate - バリデーションを行うかどうか
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UserAttachImportManagerClient (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer.user
クラス UserAttachImportManagerClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient
        拡張 jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient
すべての実装インタフェース:
ImportManagerClient
public class UserAttachImportManagerClient
extends AbstractImportManagerClient
implements ImportManagerClient

ユーザ所属情報のインポートを行います。

このクラスは、UserAttachImportManager クラスのクライアントになります。
executeメソッドに指定された設定情報を解釈した後、UserAttachImportManager クラスに インポート処理を委譲します。

導入されたバージョン:
6.1

コンストラクタの概要
UserAttachImportManagerClient()
メソッドの概要
boolean | execute(InputStream configuration) 指定された定義情報をもとにインポート処理を行います。
boolean | execute(String configurationPath) 指定された定義情報をもとにインポート処理を行います。
protected ImportConfigurationReader | getConfigurationReader(InputStream inputStream) 入力ストリームからポート設定情報を取得します。
protected String | getDefaultImportPath() インポートファイルのデフォルトパス情報を取得します。
protected ImportManager | getImportManager() インポートマネージャーのインスタンスを取得します。
クラス jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient から継承したメソッド
setCommitCount, setDate, setEncoding, setExecuteUser, setFormat, setName, setParameters, setRetry, setValidate
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserAttachImportManagerClient

public UserAttachImportManagerClient()
メソッドの詳細

execute

public boolean execute(String configurationPath)
指定された定義情報をもとにインポート処理を行います。

定義:
インタフェース ImportManagerClient 内の execute
オーバーライド:
クラス AbstractImportManagerClient 内の execute
パラメータ:
configurationPath - 定義ファイルパス
戻り値:
インポートに成功した場合 true、失敗した場合 false

execute

public boolean execute(InputStream configuration)
指定された定義情報をもとにインポート処理を行います。

定義:
インタフェース ImportManagerClient 内の execute
オーバーライド:
クラス AbstractImportManagerClient 内の execute
パラメータ:
configuration - 定義情報
戻り値:
インポートに成功した場合 true、失敗した場合 false

getImportManager

protected ImportManager getImportManager()
クラス AbstractImportManagerClient の記述:
インポートマネージャーのインスタンスを取得します。

定義:
クラス AbstractImportManagerClient 内の getImportManager
戻り値:
インポートマネージャー

getConfigurationReader

protected ImportConfigurationReader getConfigurationReader(InputStream inputStream)
クラス AbstractImportManagerClient の記述:
入力ストリームからポート設定情報を取得します。

定義:
クラス AbstractImportManagerClient 内の getConfigurationReader
パラメータ:
inputStream - 入力ストリーム
戻り値:
インポート設定リーダー

getDefaultImportPath

protected String getDefaultImportPath()
クラス AbstractImportManagerClient の記述:
インポートファイルのデフォルトパス情報を取得します。

定義:
クラス AbstractImportManagerClient 内の getDefaultImportPath
戻り値:
デフォルト定義パス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserProfileImportManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer.user
クラス UserProfileImportManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager
すべての実装インタフェース:
ImportManager
public class UserProfileImportManager
extends Object
implements ImportManager

ユーザ情報のインポートを行います。

導入されたバージョン:
6.1

コンストラクタの概要
UserProfileImportManager()
コンストラクタ ユーザ情報インポートマネージャーのインスタンスを生成します。
メソッドの概要
void | execute(InputStream inputStream) インポートを実行します。
void | execute(String[] path) インポートを実行します。
void | setCommitCount(int commitCount) コミット間隔を設定します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) インポートファイルのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザを設定します。
void | setFormat(String format) インポートファイルのフォーマットを設定します。
void | setName(String name) インポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setRetry(boolean retry) インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
void | setValidate(boolean validate) インポートデータに対してバリデーションを行うかどうか設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserProfileImportManager

public UserProfileImportManager()
コンストラクタ ユーザ情報インポートマネージャーのインスタンスを生成します。

メソッドの詳細

execute

public void execute(String[] path)
インタフェース ImportManager の記述:
インポートを実行します。

定義:
インタフェース ImportManager 内の execute
パラメータ:
path - インポートファイルのパス

execute

public void execute(InputStream inputStream)
インタフェース ImportManager の記述:
インポートを実行します。

定義:
インタフェース ImportManager 内の execute
パラメータ:
inputStream - インポートデータ

setFormat

public void setFormat(String format)
インタフェース ImportManager の記述:
インポートファイルのフォーマットを設定します。

定義:
インタフェース ImportManager 内の setFormat
パラメータ:
format - インポートファイルのフォーマット

setCommitCount

public void setCommitCount(int commitCount)
インタフェース ImportManager の記述:
コミット間隔を設定します。
ここで設定された件数分のデータの更新が行われたらコミットを実行します。

定義:
インタフェース ImportManager 内の setCommitCount
パラメータ:
commitCount - コミット間隔

setDate

public void setDate(Date date)
インタフェース ImportManager の記述:
日付を設定します。

定義:
インタフェース ImportManager 内の setDate
パラメータ:
date - 日付

setEncoding

public void setEncoding(String encoding)
インタフェース ImportManager の記述:
インポートファイルのエンコーディングを設定します。

定義:
インタフェース ImportManager 内の setEncoding
パラメータ:
encoding - エンコーディング

setExecuteUser

public void setExecuteUser(String user)
インタフェース ImportManager の記述:
実行ユーザを設定します。

定義:
インタフェース ImportManager 内の setExecuteUser
パラメータ:
user - 実行ユーザ

setName

public void setName(String name)
インタフェース ImportManager の記述:
インポート処理名を設定します。

定義:
インタフェース ImportManager 内の setName
パラメータ:
name - インポート処理名

setParameter

public void setParameter(String key,
                         Object value)
インタフェース ImportManager の記述:
パラメータを設定します。

定義:
インタフェース ImportManager 内の setParameter
パラメータ:
key - キー
value - 値

setRetry

public void setRetry(boolean retry)
インタフェース ImportManager の記述:
インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
リトライステータスが true に設定された場合、リトライとして再実行します。 この時、前回の処理でコミットしたデータの登録処理はスキップされます。
リトライステータスが false に設定された場合、最初からインポート処理をやり直します。

定義:
インタフェース ImportManager 内の setRetry
パラメータ:
retry - リトライとして実行するかどうか

setValidate

public void setValidate(boolean validate)
インタフェース ImportManager の記述:
インポートデータに対してバリデーションを行うかどうか設定します。
バリデーションステータスが true に設定された場合、バリデーションを実行します。 false に設定された場合は、バリデーションは実行しません。

定義:
インタフェース ImportManager 内の setValidate
パラメータ:
validate - バリデーションを行うかどうか
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserProfileImportManagerClient (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer.user
クラス UserProfileImportManagerClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient
        拡張 jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient
すべての実装インタフェース:
ImportManagerClient
public class UserProfileImportManagerClient
extends AbstractImportManagerClient
implements ImportManagerClient

ユーザ情報のインポートを行います。

インポートされるのは、ユーザプロファイル情報のみです。
ユーザ所属情報をインポートする場合は、UserAttachImportManagerClient、 UserAttachImportManager を使用してください。

このクラスは、UserProfileImportManager クラスのクライアントになります。
executeメソッドに指定された設定情報を解釈した後、UserProfileImportManager クラスに インポート処理を委譲します。

導入されたバージョン:
6.1

コンストラクタの概要
UserProfileImportManagerClient()
メソッドの概要
boolean | execute(InputStream configuration) 指定された定義情報をもとにインポート処理を行います。
boolean | execute(String configurationPath) 指定された定義情報をもとにインポート処理を行います。
protected ImportConfigurationReader | getConfigurationReader(InputStream inputStream) 入力ストリームからポート設定情報を取得します。
protected String | getDefaultImportPath() インポートファイルのデフォルトパス情報を取得します。
protected ImportManager | getImportManager() インポートマネージャーのインスタンスを取得します。
クラス jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient から継承したメソッド
setCommitCount, setDate, setEncoding, setExecuteUser, setFormat, setName, setParameters, setRetry, setValidate
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserProfileImportManagerClient

public UserProfileImportManagerClient()
メソッドの詳細

execute

public boolean execute(String configurationPath)
指定された定義情報をもとにインポート処理を行います。

定義:
インタフェース ImportManagerClient 内の execute
オーバーライド:
クラス AbstractImportManagerClient 内の execute
パラメータ:
configurationPath - 定義ファイルパス
戻り値:
インポートに成功した場合 true、失敗した場合 false

execute

public boolean execute(InputStream configuration)
指定された定義情報をもとにインポート処理を行います。

定義:
インタフェース ImportManagerClient 内の execute
オーバーライド:
クラス AbstractImportManagerClient 内の execute
パラメータ:
configuration - 定義情報
戻り値:
インポートに成功した場合 true、失敗した場合 false

getImportManager

protected ImportManager getImportManager()
クラス AbstractImportManagerClient の記述:
インポートマネージャーのインスタンスを取得します。

定義:
クラス AbstractImportManagerClient 内の getImportManager
戻り値:
インポートマネージャー

getConfigurationReader

protected ImportConfigurationReader getConfigurationReader(InputStream inputStream)
クラス AbstractImportManagerClient の記述:
入力ストリームからポート設定情報を取得します。

定義:
クラス AbstractImportManagerClient 内の getConfigurationReader
パラメータ:
inputStream - 入力ストリーム
戻り値:
インポート設定リーダー

getDefaultImportPath

protected String getDefaultImportPath()
クラス AbstractImportManagerClient の記述:
インポートファイルのデフォルトパス情報を取得します。

定義:
クラス AbstractImportManagerClient 内の getDefaultImportPath
戻り値:
デフォルト定義パス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AbstractImportManagerClient (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer
クラス AbstractImportManagerClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient
すべての実装インタフェース:
ImportManagerClient
直系の既知のサブクラス:
CompanyImportManagerClient, CompanyPostImportManagerClient, PublicGroupImportManagerClient, UserAttachImportManagerClient, UserProfileImportManagerClient
public abstract class AbstractImportManagerClient
extends Object
implements ImportManagerClient

インポートマネージャークライアントの汎用的な実装です。

導入されたバージョン:
6.1

コンストラクタの概要
AbstractImportManagerClient()
メソッドの概要
boolean | execute(InputStream configuration) インポートマネージャーを呼び出します。
boolean | execute(String configurationPath) インポートマネージャーを呼び出します。
protected abstract ImportConfigurationReader | getConfigurationReader(InputStream inputStream) 入力ストリームからポート設定情報を取得します。
protected abstract String | getDefaultImportPath() インポートファイルのデフォルトパス情報を取得します。
protected abstract ImportManager | getImportManager() インポートマネージャーのインスタンスを取得します。
protected void | setCommitCount(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたインポートデータのコミット間隔をマネージャーに設定します。
protected void | setDate(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義された日付をマネージャーに設定します。
protected void | setEncoding(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたインポートファイルのエンコーディング情報をマネージャーに設定します。
protected void | setExecuteUser(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義された実行ユーザをマネージャーに設定します。
protected void | setFormat(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたインポートファイルのフォーマットをマネージャーに設定します。
protected void | setName(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義された処理名をマネージャーに設定します。
protected void | setParameters(ImportManager manager, ImportConfigurationReader reader) エクスポート設定に定義されたパラメータ情報をマネージャーに設定します。
protected void | setRetry(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたリトライステータスをマネージャーに設定します。
protected void | setValidate(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたバリデーションステータスをマネージャーに設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractImportManagerClient

public AbstractImportManagerClient()
メソッドの詳細

execute

public boolean execute(String configurationPath)
インポートマネージャーを呼び出します。
設定ファイルに従ってインポートマネージャーの初期化を行い、インポートを実行します。

定義:
インタフェース ImportManagerClient 内の execute
パラメータ:
configurationPath - 定義ファイルパス
戻り値:
インポートに成功した場合 true
例外:
ImportInitializeException - インポートマネージャーの初期化でエラーが発生した場合
Error - インポート実行中に何らかのエラーが発生した場合

execute

public boolean execute(InputStream configuration)
インポートマネージャーを呼び出します。
設定ファイルに従ってインポートマネージャーの初期化を行い、インポートを実行します。

定義:
インタフェース ImportManagerClient 内の execute
パラメータ:
configuration - 定義情報
戻り値:
インポートに成功した場合 true
例外:
ImportInitializeException - インポートマネージャーの初期化でエラーが発生した場合
Error - インポート実行中に何らかのエラーが発生した場合

getImportManager

protected abstract ImportManager getImportManager()
インポートマネージャーのインスタンスを取得します。

戻り値:
インポートマネージャー
例外:
ImportInitializeException - インポートマネージャーのインスタンスの生成に失敗した場合

getConfigurationReader

protected abstract ImportConfigurationReader getConfigurationReader(InputStream inputStream)
入力ストリームからポート設定情報を取得します。

パラメータ:
inputStream - 入力ストリーム
戻り値:
インポート設定リーダー
例外:
ImportInitializeException - 入力ストリームの読み込みに失敗した場合

getDefaultImportPath

protected abstract String getDefaultImportPath()
インポートファイルのデフォルトパス情報を取得します。

戻り値:
デフォルト定義パス

setName

protected void setName(ImportManager manager,
                       ImportConfigurationReader reader)
インポート設定に定義された処理名をマネージャーに設定します。

パラメータ:
manager - インポートマネージャー
reader - インポート設定リーダー

setFormat

protected void setFormat(ImportManager manager,
                         ImportConfigurationReader reader)
インポート設定に定義されたインポートファイルのフォーマットをマネージャーに設定します。

パラメータ:
manager - インポートマネージャー
reader - インポート設定リーダー

setDate

protected void setDate(ImportManager manager,
                       ImportConfigurationReader reader)
インポート設定に定義された日付をマネージャーに設定します。

パラメータ:
manager - インポートマネージャー
reader - インポート設定リーダー

setEncoding

protected void setEncoding(ImportManager manager,
                           ImportConfigurationReader reader)
インポート設定に定義されたインポートファイルのエンコーディング情報をマネージャーに設定します。

パラメータ:
manager - インポートマネージャー
reader - インポート設定リーダー

setCommitCount

protected void setCommitCount(ImportManager manager,
                              ImportConfigurationReader reader)
インポート設定に定義されたインポートデータのコミット間隔をマネージャーに設定します。

パラメータ:
manager - インポートマネージャー
reader - インポート設定リーダー

setExecuteUser

protected void setExecuteUser(ImportManager manager,
                              ImportConfigurationReader reader)
インポート設定に定義された実行ユーザをマネージャーに設定します。

パラメータ:
manager - インポートマネージャー
reader - インポート設定リーダー

setRetry

protected void setRetry(ImportManager manager,
                        ImportConfigurationReader reader)
インポート設定に定義されたリトライステータスをマネージャーに設定します。
このステータスは、インポート異常終了後の再実行時に、リトライ処理として実行するかどうかの設定です。

パラメータ:
manager - インポートマネージャー
reader - インポート設定リーダー

setValidate

protected void setValidate(ImportManager manager,
                           ImportConfigurationReader reader)
インポート設定に定義されたバリデーションステータスをマネージャーに設定します。
このステータスは、インポートデータに対してバリデーションを行うかどうかの設定です。

パラメータ:
manager - インポートマネージャー
reader - インポート設定リーダー

setParameters

protected void setParameters(ImportManager manager,
                             ImportConfigurationReader reader)
エクスポート設定に定義されたパラメータ情報をマネージャーに設定します。

パラメータ:
manager - インポートマネージャー
reader - インポート設定リーダー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ImportInitializeException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer
クラス ImportInitializeException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.datastore.exception.BatchProcessException
                    拡張 jp.co.intra_mart.foundation.datastore.importer.ImportInitializeException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ImportConfigurationReaderException
public class ImportInitializeException
extends BatchProcessException

インポートの初期化で何らかのエラーが発生したことを示すためにスローされます。

導入されたバージョン:
6.1
関連項目:
直列化された形式

コンストラクタの概要
ImportInitializeException(String message)
コンストラクタ
ImportInitializeException(String message, Throwable cause)
コンストラクタ
ImportInitializeException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ImportInitializeException

public ImportInitializeException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

ImportInitializeException

public ImportInitializeException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

ImportInitializeException

public ImportInitializeException(String message,
                                 Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ImportManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer
インタフェース ImportManager

既知の実装クラスの一覧:
CompanyImportManager, CompanyPostImportManager, ImportManagerImpl, PublicGroupImportManager, UserAttachImportManager, UserProfileImportManager
public interface ImportManager

インポートを行います。

導入されたバージョン:
6.1

メソッドの概要
void | execute(InputStream inputStream) インポートを実行します。
void | execute(String[] path) インポートを実行します。
void | setCommitCount(int commitCount) コミット間隔を設定します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) インポートファイルのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザを設定します。
void | setFormat(String format) インポートファイルのフォーマットを設定します。
void | setName(String name) インポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setRetry(boolean retry) インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
void | setValidate(boolean validate) インポートデータに対してバリデーションを行うかどうか設定します。

メソッドの詳細

execute

public void execute(String[] path)
インポートを実行します。

パラメータ:
path - インポートファイルのパス

execute

public void execute(InputStream inputStream)
インポートを実行します。

パラメータ:
inputStream - インポートデータ

setName

public void setName(String name)
インポート処理名を設定します。

パラメータ:
name - インポート処理名

setDate

public void setDate(Date date)
日付を設定します。

パラメータ:
date - 日付

setEncoding

public void setEncoding(String encoding)
インポートファイルのエンコーディングを設定します。

パラメータ:
encoding - エンコーディング

setExecuteUser

public void setExecuteUser(String user)
実行ユーザを設定します。

パラメータ:
user - 実行ユーザ

setCommitCount

public void setCommitCount(int commitCount)
コミット間隔を設定します。
ここで設定された件数分のデータの更新が行われたらコミットを実行します。

パラメータ:
commitCount - コミット間隔

setFormat

public void setFormat(String format)
インポートファイルのフォーマットを設定します。

パラメータ:
format - インポートファイルのフォーマット

setRetry

public void setRetry(boolean retry)
インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
リトライステータスが true に設定された場合、リトライとして再実行します。 この時、前回の処理でコミットしたデータの登録処理はスキップされます。
リトライステータスが false に設定された場合、最初からインポート処理をやり直します。

パラメータ:
retry - リトライとして実行するかどうか

setValidate

public void setValidate(boolean validate)
インポートデータに対してバリデーションを行うかどうか設定します。
バリデーションステータスが true に設定された場合、バリデーションを実行します。 false に設定された場合は、バリデーションは実行しません。

パラメータ:
validate - バリデーションを行うかどうか

setParameter

public void setParameter(String key,
                         Object value)
パラメータを設定します。

パラメータ:
key - キー
value - 値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ImportManagerClient (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer
インタフェース ImportManagerClient

既知の実装クラスの一覧:
AbstractImportManagerClient, CompanyImportManagerClient, CompanyPostImportManagerClient, PublicGroupImportManagerClient, UserAttachImportManagerClient, UserProfileImportManagerClient
public interface ImportManagerClient

設定ファイルを読込んで、インポートマネージャーをセットアップ、実行します。

導入されたバージョン:
6.1

メソッドの概要
boolean | execute(InputStream configuration) 指定された定義情報をもとにインポート処理を行います。
boolean | execute(String configurationPath) 指定された定義情報をもとにインポート処理を行います。

メソッドの詳細

execute

public boolean execute(String configurationPath)
指定された定義情報をもとにインポート処理を行います。

パラメータ:
configurationPath - 定義ファイルパス
戻り値:
インポートに成功した場合 true、失敗した場合 false

execute

public boolean execute(InputStream configuration)
指定された定義情報をもとにインポート処理を行います。

パラメータ:
configuration - 定義情報
戻り値:
インポートに成功した場合 true、失敗した場合 false
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ImportManagerImpl (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer
クラス ImportManagerImpl

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl
すべての実装インタフェース:
ImportManager
public class ImportManagerImpl
extends Object
implements ImportManager

インポートマネージャーの実装です。

導入されたバージョン:
6.1

コンストラクタの概要
ImportManagerImpl(String id)
コンストラクタ
メソッドの概要
void | execute(InputStream inputStream) インポートを実行します。
void | execute(String[] path) インポートを実行します。
void | setCommitCount(int commitCount) コミット間隔を設定します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) インポートファイルのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザを設定します。
void | setFormat(String format) インポートファイルのフォーマットを設定します。
void | setName(String name) インポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setRetry(boolean retry) インポート異常終了後の再実行時に、リトライとして実行するかどうかを設定します。
void | setValidate(boolean validate) インポートデータに対してバリデーションを行うかどうか設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ImportManagerImpl

public ImportManagerImpl(String id)
コンストラクタ

パラメータ:
id - インポート種別を特定するための識別子
メソッドの詳細

execute

public void execute(String[] path)
インポートを実行します。

定義:
インタフェース ImportManager 内の execute
パラメータ:
path - インポートファイルのパス
例外:
ImportInitializeException - インポータの初期処理に失敗した場合
BatchProcessException - インポート処理に何らかの理由で失敗した場合
BatchSystemException - インポート処理中にシステムエラーが発生した場合

execute

public void execute(InputStream inputStream)
インポートを実行します。

定義:
インタフェース ImportManager 内の execute
パラメータ:
inputStream - インポートデータ
例外:
ImportInitializeException - インポータの初期処理に失敗した場合
BatchProcessException - インポート処理中に何らかの理由で失敗した場合
BatchSystemException - インポート処理中にシステムエラーが発生した場合

setName

public void setName(String name)
インポート処理名を設定します。

定義:
インタフェース ImportManager 内の setName
パラメータ:
name - インポート処理名
例外:
ImportInitializeException - 処理名に null が設定された場合

setEncoding

public void setEncoding(String encoding)
インポートファイルのエンコーディングを設定します。

定義:
インタフェース ImportManager 内の setEncoding
パラメータ:
encoding - エンコーディング
例外:
ImportInitializeException - エンコーディングに null が設定された場合

setDate

public void setDate(Date date)
日付を設定します。

定義:
インタフェース ImportManager 内の setDate
パラメータ:
date - 日付
例外:
ImportInitializeException - 有効期間にない日付が設定された場合

setFormat

public void setFormat(String format)
インポートファイルのフォーマットを設定します。

定義:
インタフェース ImportManager 内の setFormat
パラメータ:
format - インポートファイルのフォーマット
例外:
ImportInitializeException - フォーマットに null が設定された場合

setExecuteUser

public void setExecuteUser(String user)
実行ユーザを設定します。

定義:
インタフェース ImportManager 内の setExecuteUser
パラメータ:
user - 実行ユーザ
例外:
ImportInitializeException - 実行ユーザに null が設定された場合

setCommitCount

public void setCommitCount(int commitCount)
コミット間隔を設定します。

定義:
インタフェース ImportManager 内の setCommitCount
パラメータ:
commitCount - コミット間隔
例外:
ImportInitializeException - コミット間隔に 0 未満の数値が設定された場合

setRetry

public void setRetry(boolean retry)
インポート異常終了後の再実行時に、リトライとして実行するかどうかを設定します。
リトライステータスが true に設定された場合、リトライとして再実行します。 この時、前回の処理でコミットしたデータの登録処理はスキップされます。
リトライステータスが false に設定された場合、最初からインポート処理をやり直します。

定義:
インタフェース ImportManager 内の setRetry
パラメータ:
retry - リトライとして実行するかどうか

setValidate

public void setValidate(boolean validate)
インポートデータに対してバリデーションを行うかどうか設定します。
バリデーションステータスが true に設定された場合、バリデーションを実行します。 false に設定された場合は、バリデーションは実行しません。

定義:
インタフェース ImportManager 内の setValidate
パラメータ:
validate - バリデーションを行うかどうか

setParameter

public void setParameter(String key,
                         Object value)
パラメータを設定します。

定義:
インタフェース ImportManager 内の setParameter
パラメータ:
key - キー
value - 値
例外:
ImportInitializeException - パラメータのキーに null が設定された場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.importer (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.importer
インタフェース
ImportManager
ImportManagerClient
クラス
AbstractImportManagerClient
ImportManagerImpl
例外
ImportInitializeException


jp.co.intra_mart.foundation.datastore.importer (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.importer

アプリケーション共通マスタのインポートを行うクラスを提供します。

参照:
説明

インタフェースの概要
ImportManager | インポートを行います。
ImportManagerClient | 設定ファイルを読込んで、インポートマネージャーをセットアップ、実行します。

クラスの概要
AbstractImportManagerClient | インポートマネージャークライアントの汎用的な実装です。
ImportManagerImpl | インポートマネージャーの実装です。

例外の概要
ImportInitializeException インポートの初期化で何らかのエラーが発生したことを示すためにスローされます。

パッケージ jp.co.intra_mart.foundation.datastore.importer の説明

アプリケーション共通マスタのインポートを行うクラスを提供します。


jp.co.intra_mart.foundation.datastore.importer クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.importer の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
    • class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl (implements jp.co.intra_mart.foundation.datastore.importer.ImportManager)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.datastore.exception.BatchProcessException
            • class jp.co.intra_mart.foundation.datastore.importer.ImportInitializeException

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.importer.ImportManager
  • interface jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient


パッケージ jp.co.intra_mart.foundation.datastore.importer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.importer の使用

jp.co.intra_mart.foundation.datastore.importer を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.importer | アプリケーション共通マスタのインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.common.config | インポート定義情報の解釈を行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.company | 会社・組織関連の情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.public_group | パブリックグループ情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.user | ユーザ関連の情報のインポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.importer により使用される jp.co.intra_mart.foundation.datastore.importer のクラス
ImportManager
インポートを行います。
ImportManagerClient
設定ファイルを読込んで、インポートマネージャーをセットアップ、実行します。

jp.co.intra_mart.foundation.datastore.importer.common.config により使用される jp.co.intra_mart.foundation.datastore.importer のクラス
ImportInitializeException
インポートの初期化で何らかのエラーが発生したことを示すためにスローされます。

jp.co.intra_mart.foundation.datastore.importer.company により使用される jp.co.intra_mart.foundation.datastore.importer のクラス
AbstractImportManagerClient
インポートマネージャークライアントの汎用的な実装です。
ImportManager
インポートを行います。
ImportManagerClient
設定ファイルを読込んで、インポートマネージャーをセットアップ、実行します。

jp.co.intra_mart.foundation.datastore.importer.public_group により使用される jp.co.intra_mart.foundation.datastore.importer のクラス
AbstractImportManagerClient
インポートマネージャークライアントの汎用的な実装です。
ImportManager
インポートを行います。
ImportManagerClient
設定ファイルを読込んで、インポートマネージャーをセットアップ、実行します。

jp.co.intra_mart.foundation.datastore.importer.user により使用される jp.co.intra_mart.foundation.datastore.importer のクラス
AbstractImportManagerClient
インポートマネージャークライアントの汎用的な実装です。
ImportManager
インポートを行います。
ImportManagerClient
設定ファイルを読込んで、インポートマネージャーをセットアップ、実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.drawer.AbstractDrawer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.drawer.AbstractDrawer の使用

AbstractDrawer を使用しているパッケージ
jp.co.intra_mart.foundation.graph グラフ描画に関するクラスを提供します。

jp.co.intra_mart.foundation.graph での AbstractDrawer の使用

jp.co.intra_mart.foundation.graph での AbstractDrawer のサブクラス
class | BarGraphDrawer 棒グラフを描画します。
class | CircleGraphDrawer 円グラフを描画します。
class | LineGraphDrawer 折れ線グラフを描画します。
class | PortFolioDrawer ポートフォリオを描画します。
class | RadarChartDrawer レーダーチャートを描画します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AbstractDrawer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.drawer
クラス AbstractDrawer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.drawer.AbstractDrawer
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
BarGraphDrawer, CircleGraphDrawer, LineGraphDrawer, PortFolioDrawer, RadarChartDrawer
public abstract class AbstractDrawer
extends Object
implements Serializable

画像ファイル出力用のスケルトンクラスです。

サブクラスでは、createImage メソッドをオーバーライドして、 画像を描画する機能を実装する必要があります。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

コンストラクタの概要
protected AbstractDrawer()
唯一のコンストラクタ。
メソッドの概要
protected abstract void | createImage(Graphics g) 画像ファイルを描画します。
String | getContentType() 画像ファイルのフォーマットを返却します。
int | getHeight() 画像ファイルの高さを返却します。
int | getWidth() 画像ファイルの幅を返却します。
void | putImage(OutputStream out) 指定のストリームにファイルを出力します。
void | setContentType(String type) 画像ファイルのフォーマットを設定します。
void | setHeight(int height) 画像ファイルの高さを設定します。
void | setWidth(int width) 画像ファイルの幅を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractDrawer

protected AbstractDrawer()
唯一のコンストラクタ。

メソッドの詳細

createImage

protected abstract void createImage(Graphics g)
画像ファイルを描画します。
サブクラスでは、このメソッドをオーバーライドする必要があります。

パラメータ:
g - グラフィックコンテキスト

setContentType

public void setContentType(String type)
画像ファイルのフォーマットを設定します。

パラメータ:
type - コンテントタイプ
"png" または "jpeg" を指定。
初期のコンテントタイプはpngです。

setWidth

public void setWidth(int width)
画像ファイルの幅を設定します。

パラメータ:
width - 幅

setHeight

public void setHeight(int height)
画像ファイルの高さを設定します。

getContentType

public String getContentType()
画像ファイルのフォーマットを返却します。 初期のコンテントタイプはpngです。

戻り値:
コンテントタイプ

getWidth

public int getWidth()
画像ファイルの幅を返却します。

戻り値:
幅

getHeight

public int getHeight()
画像ファイルの高さを返却します。

戻り値:
高さ

putImage

public void putImage(OutputStream out)
              throws IOException
指定のストリームにファイルを出力します。
画像フォーマットは#setContentType()によって決定されます。

パラメータ:
out - 出力先ストリーム
例外:
IOException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.drawer (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.drawer
クラス
AbstractDrawer


jp.co.intra_mart.foundation.drawer (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.drawer

画像ファイル出力用クラスを提供します。

参照:
説明

クラスの概要
AbstractDrawer 画像ファイル出力用のスケルトンクラスです。

パッケージ jp.co.intra_mart.foundation.drawer の説明

画像ファイル出力用クラスを提供します。


jp.co.intra_mart.foundation.drawer クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.drawer の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.drawer.AbstractDrawer (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.drawer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.drawer の使用

jp.co.intra_mart.foundation.drawer を使用しているパッケージ
jp.co.intra_mart.foundation.graph グラフ描画に関するクラスを提供します。

jp.co.intra_mart.foundation.graph により使用される jp.co.intra_mart.foundation.drawer のクラス
AbstractDrawer
画像ファイル出力用のスケルトンクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.exception.ChangedListenerException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.exception.ChangedListenerException の使用

ChangedListenerException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group | プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.password |
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での ChangedListenerException の使用

ChangedListenerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
void | CompanyChangedListener.companyAdded(String groupId, Company company) 会社情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.companyDeleted(String groupId, Company company) 会社情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedListener.departmentAdded(String groupId, Department department) 組織情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.departmentUpdated(String groupId, Department department) 組織情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedListener.departmentDeleted(String groupId, Department department) 組織情報がデータストアに更新された後に呼び出されます。
void | CompanyChangedListener.departmentJoined(String groupId, String company, String parentDepartment, String department, String version) 組織構成がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.departmentMoved(String groupId, String company, String parentDepartment, String department, String version) 組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
void | CompanyChangedListener.departmentLeft(String groupId, String company, String department, String version) 組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
void | CompanyChangedListener.categoryDetailSet(String groupId, CompanyCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.categoryDetailRemoved(String groupId, CompanyCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedListener.memberSet(String groupId, DepartmentAttach attach) 組織への人員の割当がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.memberDeleted(String groupId, DepartmentAttach attach) 組織からの人員の割当がデータストアから削除された後に呼び出されます。
void | CompanyChangedListener.mainSet(String groupId, DepartmentMain main) 主所属情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.mainRemoved(String groupId, DepartmentMain main) 主所属情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedListener.versionAdded(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.versionUpdated(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに更新された後に呼び出されます。
void | CompanyChangedListener.versionDeleted(String groupId, CompanyVersion version) 会社構成バージョンがデータストアから削除された後に呼び出されます。
void | CompanyChangedListener.versionCopied(String groupId, String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.postAdded(String groupId, CompanyPost post) 役職情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.postUpdated(String groupId, CompanyPost post) 役職情報がデータストアに更新された後に呼び出されます。
void | CompanyChangedListener.postDeleted(String groupId, CompanyPost post) 役職情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.datastore.application.domain.private_group での ChangedListenerException の使用

ChangedListenerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.private_group のメソッド
void | PrivateGroupChangedListener.privateGroupAdded(String groupId, PrivateGroup group) プライベートグループがデータストアに登録された後に呼び出されます。
void | PrivateGroupChangedListener.privateGroupUpdated(String groupId, PrivateGroup group) プライベートグループがデータストアに更新された後に呼び出されます。
void | PrivateGroupChangedListener.privateGroupDeleted(String groupId, PrivateGroup group) プライベートグループがデータストアから削除された後に呼び出されます。
void | PrivateGroupChangedListener.memberSet(String groupId, PrivateGroupAttach member) プライベートグループ所属情報がデータストアに登録された後に呼び出されます。
void | PrivateGroupChangedListener.memberDeleted(String groupId, PrivateGroupAttach member) プライベートグループ所属情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での ChangedListenerException の使用

ChangedListenerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
void | PublicGroupChangedListener.groupSetAdded(String groupId, PublicGroupSet groupSet) グループセットがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.groupSetDeleted(String groupId, PublicGroupSet groupSet) グループセットがデータストアから削除された後に呼び出されます。
void | PublicGroupChangedListener.publicGroupAdded(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.publicGroupUpdated(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedListener.publicGroupDeleted(String groupId, PublicGroup publicGroup) パブリックグループがデータストアから削除された後に呼び出されます。
void | PublicGroupChangedListener.publicGroupJoined(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.publicGroupMoved(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
void | PublicGroupChangedListener.publicGroupLeft(String groupId, String groupSet, String publicGroup, String version) パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
void | PublicGroupChangedListener.categoryDetailSet(String groupId, PublicGroupCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.categoryDetailRemoved(String groupId, PublicGroupCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | PublicGroupChangedListener.memberSet(String groupId, PublicGroupAttach attach) パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.memberDeleted(String groupId, PublicGroupAttach attach) パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
void | PublicGroupChangedListener.versionAdded(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.versionUpdated(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedListener.versionDeleted(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
void | PublicGroupChangedListener.versionCopied(String groupId, String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。

jp.co.intra_mart.foundation.datastore.application.domain.user での ChangedListenerException の使用

ChangedListenerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
void | UserChangedListener.userAdded(String groupId, User user) ユーザ情報がデータストアに登録された後に呼び出されます。
void | UserChangedListener.userUpdated(String groupId, User user) ユーザ情報がデータストアに対して更新された後に呼び出されます。
void | UserChangedListener.userDeleted(String groupId, User user) ユーザ情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.access での ChangedListenerException の使用

ChangedListenerException をスローする jp.co.intra_mart.foundation.security.access のメソッド
void | RoleChangedControllerListener.roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RoleChangedControllerListener.roleDeleted(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | RoleChangedControllerListener.roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | RoleChangedControllerListener.subRoleAdded(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | RoleChangedControllerListener.subRoleDeleted(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。
void | PublicGroupChangedControllerListener.groupSetAdded(String groupId, PublicGroupSet groupSet) グループセットがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedControllerListener.groupSetDeleted(String groupId, PublicGroupSet groupSet) グループセットがデータストアから削除された後に呼び出されます。
void | PublicGroupChangedControllerListener.publicGroupAdded(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedControllerListener.publicGroupUpdated(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedControllerListener.publicGroupDeleted(String groupId, PublicGroup publicGroup) パブリックグループがデータストアから削除された後に呼び出されます。
void | PublicGroupChangedControllerListener.publicGroupJoined(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedControllerListener.publicGroupMoved(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
void | PublicGroupChangedControllerListener.publicGroupLeft(String groupId, String groupSet, String publicGroup, String version) パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
void | PublicGroupChangedControllerListener.categoryDetailSet(String groupId, PublicGroupCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedControllerListener.categoryDetailRemoved(String groupId, PublicGroupCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | PublicGroupChangedControllerListener.memberSet(String groupId, PublicGroupAttach attach) パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedControllerListener.memberDeleted(String groupId, PublicGroupAttach attach) パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
void | PublicGroupChangedControllerListener.versionAdded(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedControllerListener.versionUpdated(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedControllerListener.versionDeleted(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
void | PublicGroupChangedControllerListener.versionCopied(String groupId, String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.companyAdded(String groupId, Company company) 会社情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.companyDeleted(String groupId, Company company) 会社情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedControllerListener.departmentAdded(String groupId, Department department) 組織情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.departmentUpdated(String groupId, Department department) 組織情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedControllerListener.departmentDeleted(String groupId, Department department) 組織情報がデータストアに更新された後に呼び出されます。
void | CompanyChangedControllerListener.departmentJoined(String groupId, String company, String parentDepartment, String department, String version) 組織構成がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.departmentMoved(String groupId, String company, String parentDepartment, String department, String version) 組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
void | CompanyChangedControllerListener.departmentLeft(String groupId, String company, String department, String version) 組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
void | CompanyChangedControllerListener.categoryDetailSet(String groupId, CompanyCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.categoryDetailRemoved(String groupId, CompanyCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedControllerListener.memberSet(String groupId, DepartmentAttach attach) 組織への人員の割当がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.memberDeleted(String groupId, DepartmentAttach attach) 組織からの人員の割当がデータストアから削除された後に呼び出されます。
void | CompanyChangedControllerListener.mainSet(String groupId, DepartmentMain main) 主所属情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.mainRemoved(String groupId, DepartmentMain main) 主所属情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedControllerListener.versionAdded(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.versionUpdated(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに更新された後に呼び出されます。
void | CompanyChangedControllerListener.versionDeleted(String groupId, CompanyVersion version) 会社構成バージョンがデータストアから削除された後に呼び出されます。
void | CompanyChangedControllerListener.versionCopied(String groupId, String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.postAdded(String groupId, CompanyPost post) 役職情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.postUpdated(String groupId, CompanyPost post) 役職情報がデータストアに更新された後に呼び出されます。
void | CompanyChangedControllerListener.postDeleted(String groupId, CompanyPost post) 役職情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.account での ChangedListenerException の使用

ChangedListenerException をスローする jp.co.intra_mart.foundation.security.account のメソッド
void | RoleChangedAccountListener.roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RoleChangedAccountListener.roleDeleted(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | RoleChangedAccountListener.roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | RoleChangedAccountListener.subRoleAdded(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | RoleChangedAccountListener.subRoleDeleted(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。
void | AccountChangedListener.accountAdded(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | AccountChangedListener.accountDeleted(String groupId, String userId) アカウント情報をデータストアから削除した直後にコールされます。
void | AccountChangedListener.accountUpdated(String groupId, Account account) アカウント情報をデータストアに更新した直後にコールされます。
void | AccountChangedListener.accountRoleAdded(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | AccountChangedListener.accountRoleDeleted(String groupId, String userId, String roleId) アカウントロール情報をデータストアから削除した直後にコールされます。
void | AccountChangedListener.accountRoleUpdated(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.menu での ChangedListenerException の使用

ChangedListenerException をスローする jp.co.intra_mart.foundation.security.menu のメソッド
void | RoleChangedMenuListener.roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RoleChangedMenuListener.roleDeleted(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | RoleChangedMenuListener.roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | RoleChangedMenuListener.subRoleAdded(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | RoleChangedMenuListener.subRoleDeleted(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。
void | PublicGroupChangedMenuListener.groupSetAdded(String groupId, PublicGroupSet groupSet) グループセットがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.groupSetDeleted(String groupId, PublicGroupSet groupSet) グループセットがデータストアから削除された後に呼び出されます。
void | PublicGroupChangedMenuListener.publicGroupAdded(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.publicGroupUpdated(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedMenuListener.publicGroupDeleted(String groupId, PublicGroup publicGroup) パブリックグループがデータストアから削除された後に呼び出されます。
void | PublicGroupChangedMenuListener.publicGroupJoined(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.publicGroupMoved(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
void | PublicGroupChangedMenuListener.publicGroupLeft(String groupId, String groupSet, String publicGroup, String version) パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
void | PublicGroupChangedMenuListener.categoryDetailSet(String groupId, PublicGroupCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.categoryDetailRemoved(String groupId, PublicGroupCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | PublicGroupChangedMenuListener.memberSet(String groupId, PublicGroupAttach attach) パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.memberDeleted(String groupId, PublicGroupAttach attach) パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
void | PublicGroupChangedMenuListener.versionAdded(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.versionUpdated(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedMenuListener.versionDeleted(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
void | PublicGroupChangedMenuListener.versionCopied(String groupId, String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.companyAdded(String groupId, Company company) 会社情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.companyDeleted(String groupId, Company company) 会社情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedMenuListener.departmentAdded(String groupId, Department department) 組織情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.departmentUpdated(String groupId, Department department) 組織情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedMenuListener.departmentDeleted(String groupId, Department department) 組織情報がデータストアに更新された後に呼び出されます。
void | CompanyChangedMenuListener.departmentJoined(String groupId, String company, String parentDepartment, String department, String version) 組織構成がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.departmentMoved(String groupId, String company, String parentDepartment, String department, String version) 組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
void | CompanyChangedMenuListener.departmentLeft(String groupId, String company, String department, String version) 組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
void | CompanyChangedMenuListener.categoryDetailSet(String groupId, CompanyCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.categoryDetailRemoved(String groupId, CompanyCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedMenuListener.memberSet(String groupId, DepartmentAttach attach) 組織への人員の割当がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.memberDeleted(String groupId, DepartmentAttach attach) 組織からの人員の割当がデータストアから削除された後に呼び出されます。
void | CompanyChangedMenuListener.mainSet(String groupId, DepartmentMain main) 主所属情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.mainRemoved(String groupId, DepartmentMain main) 主所属情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedMenuListener.versionAdded(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.versionUpdated(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに更新された後に呼び出されます。
void | CompanyChangedMenuListener.versionDeleted(String groupId, CompanyVersion version) 会社構成バージョンがデータストアから削除された後に呼び出されます。
void | CompanyChangedMenuListener.versionCopied(String groupId, String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.postAdded(String groupId, CompanyPost post) 役職情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.postUpdated(String groupId, CompanyPost post) 役職情報がデータストアに更新された後に呼び出されます。
void | CompanyChangedMenuListener.postDeleted(String groupId, CompanyPost post) 役職情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.password での ChangedListenerException の使用

ChangedListenerException をスローする jp.co.intra_mart.foundation.security.password のメソッド
void | PasswordHistoryAccountChangedListener.accountAdded(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | PasswordHistoryAccountChangedListener.accountDeleted(String groupId, String userId) アカウント情報をデータストアから削除した直後にコールされます。

jp.co.intra_mart.foundation.security.role での ChangedListenerException の使用

ChangedListenerException をスローする jp.co.intra_mart.foundation.security.role のメソッド
void | RoleChangedListener.roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RoleChangedListener.roleDeleted(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | RoleChangedListener.roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | RoleChangedListener.subRoleAdded(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | RoleChangedListener.subRoleDeleted(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.exception.FoundationException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.exception.FoundationException の使用

FoundationException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。
jp.co.intra_mart.foundation.exception | システムでスローされる例外クラスを提供します。
jp.co.intra_mart.foundation.image |
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.password |
jp.co.intra_mart.foundation.update |

jp.co.intra_mart.foundation.datastore.exception での FoundationException の使用

jp.co.intra_mart.foundation.datastore.exception での FoundationException のサブクラス
class | AccessorClosedException アクセサのクローズ時に発生する例外クラス アクセサがクローズされている場合に、以下のメソッドを呼び出された時にスローする。
class | AccessorException アクセサで発生する例外の基底クラス
class | AccessorIllegalPropertyValueException アクセサのプロパティ設定に関する例外クラス アクセサに不正な値が設定された場合にスローする。
class | DataNotFoundException アクセサのプロパティ値の取得に関する例外クラス 指定されたプロパティに対する値が設定されていない場合にスローする。
class | DataStoreApplicationException アプリケーション共通マスタで発生するアプリケーション例外の基底クラス
class | IllegalExtensionException 拡張アクセサに関する例外クラス 拡張アクセサに対して不正な操作が行われた場合にスローする。
class | IllegalLocaleException アクセサが保持する言語に関する例外クラス アクセサが保持していない言語を要求された場合にスローする。
class | IllegalRelationshipException リレーションシップに関する例外クラス リレーションシップの整合性が正しくない場合にスローする。
class | IllegalTermException アクセサが保持する期間に関する例外クラス アクセサが保持しない日時または期間が指定されたときにスローする。
class | ManagerException マネージャに関する例外クラス
class | MapperException マッパーに関する例外クラス マッパーの処理中に問題が発生した場合にスローする。
class | TermManagerException 期間に関する例外クラス

jp.co.intra_mart.foundation.exception での FoundationException の使用

jp.co.intra_mart.foundation.exception での FoundationException のサブクラス
 class ChangedListenerException
更新リスナーの例外クラス。

jp.co.intra_mart.foundation.image での FoundationException の使用

jp.co.intra_mart.foundation.image での FoundationException のサブクラス
class | DuplicateImageIconCodeException 登録時重複例外クラス。
class | DuplicateImageIconSrcException 作成/更新時URLの重複例外クラス。
class | ImageIconException イメージアイコンの例外クラス。
class | NotExistImageIconException イメージアイコンが存在しなかった場合の例外クラス。

jp.co.intra_mart.foundation.navigator での FoundationException の使用

jp.co.intra_mart.foundation.navigator での FoundationException のサブクラス
 class EventNavigatorException
イベントナビゲータマネージャに関する例外クラス

jp.co.intra_mart.foundation.security.exception での FoundationException の使用

jp.co.intra_mart.foundation.security.exception での FoundationException のサブクラス
class | AccessSecurityCreateException アクセスセキュリティ情報作成例外クラス。
class | AccessSecurityDeleteException アクセスセキュリティ情報削除例外クラス。
class | AccessSecurityException アクセスセキュリティの基本となる例外クラス。
class | AccessSecurityExportException エクスポート時例外クラス。
class | AccessSecurityImportException インポート時例外クラス。
class | AccessSecurityListenerExcpetion アクセスセキュリティリスナーの例外クラス。
class | AccessSecurityReadException アクセスセキュリティ情報の取得例外クラス。
class | AccessSecurityUpdateException アクセスセキュリティ情報更新例外クラス。
class | AccessSecurityWriteException アクセスセキュリティ情報の更新例外クラス。
class | ActiveSessionException アクティブなセッション情報例外の基本となる例外クラス。
class | ActiveSessionInvalidatedByForceException アクティブなセッションが強制的に無効化されたことに関する例外クラス
class | ActiveSessionNotExistException アクティブなセッションが存在しない例外クラス。
class | DuplicateException 作成時重複例外クラス。
class | DuplicateLoginDetectedException 重複ログイン検出例外クラス
class | DuplicateLoginException 重複ログイン制御例外の基本となる例外クラス。
class | IllegalArgumentException 引数が不正の例外クラス。
class | NoFilterException HTTPリクエスト・レスポンス取得例外クラス。
class | NoSessionCookieException セッション情報クッキー取得例外クラス。
class | NoSessionException セッション取得例外クラス。
class | NotExistException アクセスセキュリティ情報が存在しなかった場合の例外クラス。
class | NotFoundDataSourceException データソースの参照名未解決例外クラス。
class | NotSupportMethodException アクセスセキュリティのマネージャでサポートされないメソッドがコールされた場合の例外クラス。

jp.co.intra_mart.foundation.security.password での FoundationException の使用

jp.co.intra_mart.foundation.security.password での FoundationException のサブクラス
 class PasswordHistoryException
イメージアイコンの例外クラス。

jp.co.intra_mart.foundation.update での FoundationException の使用

FoundationException をスローする jp.co.intra_mart.foundation.update のメソッド
String[] | UpdateManager.getKeys() 保存されている更新管理キーの一覧を取得します。
Date | UpdateManager.getLastModified(String key) 更新日付を取得します。
boolean | UpdateManager.isUpDate(String key, Date now) 更新管理キーの更新日付が検証日付より新しいか検証します。
Date | UpdateManager.modify(String key) 対象となる更新管理キーの更新日付を更新します。
void | UpdateManager.remove(String key) 更新管理キーを削除します。
void | UpdateManager.removeAll() すべての更新管理キーを削除します。
void | UpdateAccessor.delete(String groupId, String key) キーを削除します。
void | UpdateAccessor.deleteAll(String groupId) すべてのキーを削除します。
String[] | UpdateAccessor.getKeys(String groupId) 保存されているキーの一覧を取得します。
void | UpdateAccessor.insert(String groupId, String key, Date date) キーを取得します。
Date | UpdateAccessor.select(String groupId, String key) 更新日付を取得します。
void | UpdateAccessor.update(String groupId, String key, Date date) キーの更新日付を更新します。
void | StandardUpdateAccessor.delete(String groupId, String key) キーを削除します。
void | StandardUpdateAccessor.deleteAll(String groupId) すべてのキーを削除します。
String[] | StandardUpdateAccessor.getKeys(String groupId) 保存されているキーの一覧を取得します。
void | StandardUpdateAccessor.insert(String groupId, String key, Date date) キーを取得します。
Date | StandardUpdateAccessor.select(String groupId, String key) 更新日付を取得します。
void | StandardUpdateAccessor.update(String groupId, String key, Date date) キーの更新日付を更新します。

FoundationException をスローする jp.co.intra_mart.foundation.update のコンストラクタ
UpdateManager(String groupId)
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.exception.FoundationRuntimeException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.exception.FoundationRuntimeException の使用

FoundationRuntimeException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.exception での FoundationRuntimeException の使用

jp.co.intra_mart.foundation.datastore.exception での FoundationRuntimeException のサブクラス
class | AccessorSystemException アクセサのプロパティに関する例外クラス 指定されたプロパティがアクセサに存在しない場合にスローする。
class | DataStoreConfigException アプリケーション共通マスタの設定に関する例外クラス アプリケーション共通マスタの設定に不整合がある場合にスローする。
class | DataStoreSystemException アプリケーション共通マスタで発生するシステム例外の基底クラス
class | MapperDAOException マッパーのデータベース接続に関する例外クラス マッパーがデータベース接続で問題が発生した場合にスローする。

jp.co.intra_mart.foundation.security.exception での FoundationRuntimeException の使用

jp.co.intra_mart.foundation.security.exception での FoundationRuntimeException のサブクラス
class | AccessSecurityConfigException アクセスセキュリティ設定に関する例外クラス。
class | AccessSecurityRuntimeException アクセスセキュリティランタイム例外クラス。
class | SystemConfigException システム設定に関する例外クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ChangedListenerException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.exception
クラス ChangedListenerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.exception.ChangedListenerException
すべての実装インタフェース:
Serializable
public class ChangedListenerException
extends FoundationException

更新リスナーの例外クラス。

更新リスナー内で例外が発せした場合にスローされます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ChangedListenerException()
コンストラクタ。
ChangedListenerException(String message)
コンストラクタ。
ChangedListenerException(String message, Throwable cause)
コンストラクタ。
ChangedListenerException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ChangedListenerException

public ChangedListenerException()
コンストラクタ。

ChangedListenerException

public ChangedListenerException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

ChangedListenerException

public ChangedListenerException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

ChangedListenerException

public ChangedListenerException(String message,
                                Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


FoundationException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.exception
クラス FoundationException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccessSecurityException, ChangedListenerException, DataStoreApplicationException, ImageIconException, PasswordHistoryException
public class FoundationException
extends Exception

システム基盤共通例外クラス。

システムでスローされる例外のスーパークラスです。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
FoundationException()
コンストラクタ。
FoundationException(String message)
コンストラクタ。
FoundationException(String message, Throwable cause)
コンストラクタ。
FoundationException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

FoundationException

public FoundationException()
コンストラクタ。

FoundationException

public FoundationException(String message)
コンストラクタ。

パラメータ:
message - メッセージ

FoundationException

public FoundationException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

FoundationException

public FoundationException(String message,
                           Throwable cause)
コンストラクタ。

パラメータ:
message - メッセージ
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FoundationRuntimeException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.exception
クラス FoundationRuntimeException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.exception.FoundationRuntimeException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccessSecurityRuntimeException, DataStoreSystemException
public class FoundationRuntimeException
extends RuntimeException

システム基盤共通ランタイム例外クラス。

システムでスローされるランタイム例外のスーパークラスです。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
FoundationRuntimeException()
コンストラクタ。
FoundationRuntimeException(String message)
コンストラクタ。
FoundationRuntimeException(String message, Throwable cause)
コンストラクタ。
FoundationRuntimeException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

FoundationRuntimeException

public FoundationRuntimeException()
コンストラクタ。

FoundationRuntimeException

public FoundationRuntimeException(String message)
コンストラクタ。

パラメータ:
message - メッセージ

FoundationRuntimeException

public FoundationRuntimeException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

FoundationRuntimeException

public FoundationRuntimeException(String message,
                                  Throwable cause)
コンストラクタ。

パラメータ:
message - メッセージ
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.exception (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.exception
例外
ChangedListenerException
FoundationException
FoundationRuntimeException


jp.co.intra_mart.foundation.exception (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.exception

システムでスローされる例外クラスを提供します。

参照:
説明

例外の概要
ChangedListenerException | 更新リスナーの例外クラス。
FoundationException | システム基盤共通例外クラス。
FoundationRuntimeException | システム基盤共通ランタイム例外クラス。

パッケージ jp.co.intra_mart.foundation.exception の説明

システムでスローされる例外クラスを提供します。


jp.co.intra_mart.foundation.exception クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.exception.FoundationException
          • class jp.co.intra_mart.foundation.exception.ChangedListenerException
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.exception.FoundationRuntimeException


パッケージ jp.co.intra_mart.foundation.exception の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.exception の使用

jp.co.intra_mart.foundation.exception を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group | プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。
jp.co.intra_mart.foundation.exception | システムでスローされる例外クラスを提供します。
jp.co.intra_mart.foundation.image |
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.password |
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。
jp.co.intra_mart.foundation.update |

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.exception のクラス
ChangedListenerException
更新リスナーの例外クラス。

jp.co.intra_mart.foundation.datastore.application.domain.private_group により使用される jp.co.intra_mart.foundation.exception のクラス
ChangedListenerException
更新リスナーの例外クラス。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.exception のクラス
ChangedListenerException
更新リスナーの例外クラス。

jp.co.intra_mart.foundation.datastore.application.domain.user により使用される jp.co.intra_mart.foundation.exception のクラス
ChangedListenerException
更新リスナーの例外クラス。

jp.co.intra_mart.foundation.datastore.exception により使用される jp.co.intra_mart.foundation.exception のクラス
FoundationException
システム基盤共通例外クラス。
FoundationRuntimeException
システム基盤共通ランタイム例外クラス。

jp.co.intra_mart.foundation.exception により使用される jp.co.intra_mart.foundation.exception のクラス
FoundationException
システム基盤共通例外クラス。

jp.co.intra_mart.foundation.image により使用される jp.co.intra_mart.foundation.exception のクラス
FoundationException
システム基盤共通例外クラス。

jp.co.intra_mart.foundation.navigator により使用される jp.co.intra_mart.foundation.exception のクラス
FoundationException
システム基盤共通例外クラス。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.exception のクラス
ChangedListenerException
更新リスナーの例外クラス。

jp.co.intra_mart.foundation.security.account により使用される jp.co.intra_mart.foundation.exception のクラス
ChangedListenerException
更新リスナーの例外クラス。

jp.co.intra_mart.foundation.security.exception により使用される jp.co.intra_mart.foundation.exception のクラス
FoundationException
システム基盤共通例外クラス。
FoundationRuntimeException
システム基盤共通ランタイム例外クラス。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.exception のクラス
ChangedListenerException
更新リスナーの例外クラス。

jp.co.intra_mart.foundation.security.password により使用される jp.co.intra_mart.foundation.exception のクラス
ChangedListenerException
更新リスナーの例外クラス。
FoundationException
システム基盤共通例外クラス。

jp.co.intra_mart.foundation.security.role により使用される jp.co.intra_mart.foundation.exception のクラス
ChangedListenerException
更新リスナーの例外クラス。

jp.co.intra_mart.foundation.update により使用される jp.co.intra_mart.foundation.exception のクラス
FoundationException
システム基盤共通例外クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.BarGraphDrawer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.BarGraphDrawer の使用

jp.co.intra_mart.foundation.graph.BarGraphDrawer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.BarGraphObject の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.BarGraphObject の使用

BarGraphObject を使用しているパッケージ
jp.co.intra_mart.foundation.graph グラフ描画に関するクラスを提供します。

jp.co.intra_mart.foundation.graph での BarGraphObject の使用

BarGraphObject を返す jp.co.intra_mart.foundation.graph のメソッド
 BarGraphObject BarGraphDrawer.getData(int index)
リスト内の指定された位置にあるデータを返します。

BarGraphObject 型のパラメータを持つ jp.co.intra_mart.foundation.graph のメソッド
void | BarGraphDrawer.addData(BarGraphObject obj) 描画オブジェクトに新しいデータを追加します。
void | BarGraphDrawer.addData(int index, BarGraphObject obj) 指定された位置に、指定された描画オブジェクトを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.CircleGraphDrawer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.CircleGraphDrawer の使用

jp.co.intra_mart.foundation.graph.CircleGraphDrawer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.CircleGraphObject の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.CircleGraphObject の使用

CircleGraphObject を使用しているパッケージ
jp.co.intra_mart.foundation.graph グラフ描画に関するクラスを提供します。

jp.co.intra_mart.foundation.graph での CircleGraphObject の使用

CircleGraphObject を返す jp.co.intra_mart.foundation.graph のメソッド
 CircleGraphObject CircleGraphDrawer.getData(int index)
リスト内の指定された位置にあるデータを返します。

CircleGraphObject 型のパラメータを持つ jp.co.intra_mart.foundation.graph のメソッド
void | CircleGraphDrawer.addData(CircleGraphObject obj) 描画オブジェクトに新しいデータを追加します。
void | CircleGraphDrawer.addData(int index, CircleGraphObject obj) 指定された位置に、指定された描画オブジェクトを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.LineGraphDrawer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.LineGraphDrawer の使用

jp.co.intra_mart.foundation.graph.LineGraphDrawer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.LineGraphObject の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.LineGraphObject の使用

LineGraphObject を使用しているパッケージ
jp.co.intra_mart.foundation.graph グラフ描画に関するクラスを提供します。

jp.co.intra_mart.foundation.graph での LineGraphObject の使用

LineGraphObject を返す jp.co.intra_mart.foundation.graph のメソッド
 LineGraphObject LineGraphDrawer.getData(int index)
リスト内の指定された位置にあるデータを返します。

LineGraphObject 型のパラメータを持つ jp.co.intra_mart.foundation.graph のメソッド
void | LineGraphDrawer.addData(LineGraphObject obj) 描画オブジェクトに新しいデータを追加します。
void | LineGraphDrawer.addData(int index, LineGraphObject obj) 指定された位置に、指定された描画オブジェクトを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.PortFolioDrawer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.PortFolioDrawer の使用

jp.co.intra_mart.foundation.graph.PortFolioDrawer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.PortFolioObject の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.PortFolioObject の使用

PortFolioObject を使用しているパッケージ
jp.co.intra_mart.foundation.graph グラフ描画に関するクラスを提供します。

jp.co.intra_mart.foundation.graph での PortFolioObject の使用

PortFolioObject を返す jp.co.intra_mart.foundation.graph のメソッド
 PortFolioObject PortFolioDrawer.getData(int index)
リスト内の指定された位置にあるデータを返します。

PortFolioObject 型のパラメータを持つ jp.co.intra_mart.foundation.graph のメソッド
void | PortFolioDrawer.addData(PortFolioObject obj) 描画オブジェクトに新しいデータを追加します。
void | PortFolioDrawer.addData(int index, PortFolioObject obj) 指定された位置に、指定された描画オブジェクトを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.RadarChartDrawer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.RadarChartDrawer の使用

jp.co.intra_mart.foundation.graph.RadarChartDrawer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.RadarChartObject の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.RadarChartObject の使用

RadarChartObject を使用しているパッケージ
jp.co.intra_mart.foundation.graph グラフ描画に関するクラスを提供します。

jp.co.intra_mart.foundation.graph での RadarChartObject の使用

RadarChartObject を返す jp.co.intra_mart.foundation.graph のメソッド
 RadarChartObject RadarChartDrawer.getData(int index)
リスト内の指定された位置にあるデータを返します。

RadarChartObject 型のパラメータを持つ jp.co.intra_mart.foundation.graph のメソッド
void | RadarChartDrawer.addData(RadarChartObject obj) 描画オブジェクトに新しいデータを追加します。
void | RadarChartDrawer.addData(int index, RadarChartObject obj) 指定された位置に、指定された描画オブジェクトを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BarGraphDrawer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス BarGraphDrawer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.drawer.AbstractDrawer
        拡張 jp.co.intra_mart.foundation.graph.BarGraphDrawer
すべての実装インタフェース:
Serializable
public class BarGraphDrawer
extends AbstractDrawer

棒グラフを描画します。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

フィールドの概要
static int | DEFAULT_BOTTOM_MARGIN 標準のグラフ領域の下部マージン
static Color | DEFAULT_GRAPH_BACKGROUND_COLOR 標準のグラフ領域の背景色
static Color | DEFAULT_GRAPH_BORDER_COLOR 標準のグラフ領域のボーダー色
static Color | DEFAULT_IMAGE_BACKGROUND_COLOR 標準の画像ファイル背景色
static Color | DEFAULT_IMAGE_BORDER_COLOR 標準の画像ファイルのボーダ色
static int | DEFAULT_LEFT_MARGIN 標準のグラフ領域の左側マージン
static int | DEFAULT_RIGHT_MARGIN 標準のグラフ領域の右側マージン
static int | DEFAULT_TOP_MARGIN 標準のグラフ領域の上部マージン
コンストラクタの概要
BarGraphDrawer(double min, double max, double count)
ｙ軸の目盛値をdouble表現で棒グラフを作成します。
BarGraphDrawer(int min, int max, int count)
ｙ軸の目盛値をint表現で棒グラフを作成します。
メソッドの概要
void | addData(BarGraphObject obj) 描画オブジェクトに新しいデータを追加します。
void | addData(int index, BarGraphObject obj) 指定された位置に、指定された描画オブジェクトを追加します。
void | clear() すべてのデータを削除します。
protected void | createImage(Graphics g) 棒グラフを描画します。
String[] | getCaption() ｘ軸のキャプションを返します。
Color | getCaptionColor() キャプションの文字色を返します。
BarGraphObject | getData(int index) リスト内の指定された位置にあるデータを返します。
Color | getGraphBackgroundColor() グラフ領域の背景色を返します。
Color | getGraphBorderColor() グラフ領域のボーダーの色を返します。
Color | getImageBackgroundColor() 画像ファイルの背景色を返します。
Color | getImageBorderColor() 画像ファイルのボーダ色を返します。
Color | getImgaeBackgroundColor() 推奨されていません。
Color | getImgaeBorderColor() 推奨されていません。
double | getMax() ｙ軸の最大値を返します。
double | getMin() ｙ軸の最小値を返します。
double | getScaleCount() ｙ軸の目盛間隔を返します。
boolean | isDouble() ｙ軸の目盛値がdouble表現かどうかを判定します。
void | remove(int index) 指定された位置のデータを削除します。
void | setCaption(String[] caption) ｘ軸のキャプションを設定します。
void | setCaptionColor(Color color) キャプションの文字色を設定します。
void | setGraphBackgroundColor(Color color) グラフ領域の背景色を設定します。
void | setGraphBorderColor(Color color) グラフ領域のボーダーの色を設定します。
void | setImageBackgroundColor(Color color) 画像ファイルの背景色を設定します。
void | setImageBorderColor(Color color) 画像ファイルのボーダ色を設定します。
void | setImgaeBackgroundColor(Color color) 推奨されていません。
void | setImgaeBorderColor(Color color) 推奨されていません。
void | setMargin(int top, int right, int bottom, int left) グラフ領域のマージンを設定します。
int | size() データの数を返します。
クラス jp.co.intra_mart.foundation.drawer.AbstractDrawer から継承したメソッド
getContentType, getHeight, getWidth, putImage, setContentType, setHeight, setWidth
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_TOP_MARGIN

public static int DEFAULT_TOP_MARGIN
標準のグラフ領域の上部マージン

DEFAULT_RIGHT_MARGIN

public static int DEFAULT_RIGHT_MARGIN
標準のグラフ領域の右側マージン

DEFAULT_BOTTOM_MARGIN

public static int DEFAULT_BOTTOM_MARGIN
標準のグラフ領域の下部マージン

DEFAULT_LEFT_MARGIN

public static int DEFAULT_LEFT_MARGIN
標準のグラフ領域の左側マージン

DEFAULT_IMAGE_BACKGROUND_COLOR

public static Color DEFAULT_IMAGE_BACKGROUND_COLOR
標準の画像ファイル背景色

DEFAULT_IMAGE_BORDER_COLOR

public static Color DEFAULT_IMAGE_BORDER_COLOR
標準の画像ファイルのボーダ色

DEFAULT_GRAPH_BACKGROUND_COLOR

public static Color DEFAULT_GRAPH_BACKGROUND_COLOR
標準のグラフ領域の背景色

DEFAULT_GRAPH_BORDER_COLOR

public static Color DEFAULT_GRAPH_BORDER_COLOR
標準のグラフ領域のボーダー色

コンストラクタの詳細

BarGraphDrawer

public BarGraphDrawer(int min,
                      int max,
                      int count)
ｙ軸の目盛値をint表現で棒グラフを作成します。

パラメータ:
min - ｙ軸の最小値
max - ｙ軸の最大値
count - ｙ軸の目盛間隔
例外:
IllegalArgumentException - max <= min または count <= 0

BarGraphDrawer

public BarGraphDrawer(double min,
                      double max,
                      double count)
ｙ軸の目盛値をdouble表現で棒グラフを作成します。

パラメータ:
min - ｙ軸の最小値
max - ｙ軸の最大値
count - ｙ軸の目盛間隔
例外:
IllegalArgumentException - max <= min または count <= 0
メソッドの詳細

getMax

public double getMax()
ｙ軸の最大値を返します。

戻り値:
double ｙ軸の最大値

getMin

public double getMin()
ｙ軸の最小値を返します。

戻り値:
double ｙ軸の最小値

getScaleCount

public double getScaleCount()
ｙ軸の目盛間隔を返します。

戻り値:
double ｙ軸の目盛間隔

setCaption

public void setCaption(String[] caption)
ｘ軸のキャプションを設定します。

パラメータ:
caption - キャプション

getCaption

public String[] getCaption()
ｘ軸のキャプションを返します。

戻り値:
キャプション

addData

public void addData(BarGraphObject obj)
描画オブジェクトに新しいデータを追加します。

パラメータ:
obj - データ

setImageBackgroundColor

public void setImageBackgroundColor(Color color)
画像ファイルの背景色を設定します。

パラメータ:
color -

setImgaeBackgroundColor

public void setImgaeBackgroundColor(Color color)
推奨されていません。

画像ファイルの背景色を設定します。

パラメータ:
color -

getImageBackgroundColor

public Color getImageBackgroundColor()
画像ファイルの背景色を返します。

戻り値:
color

getImgaeBackgroundColor

public Color getImgaeBackgroundColor()
推奨されていません。

画像ファイルの背景色を返します。

戻り値:
color

setImageBorderColor

public void setImageBorderColor(Color color)
画像ファイルのボーダ色を設定します。

パラメータ:
color -

setImgaeBorderColor

public void setImgaeBorderColor(Color color)
推奨されていません。

画像ファイルのボーダ色を設定します。

パラメータ:
color -

getImageBorderColor

public Color getImageBorderColor()
画像ファイルのボーダ色を返します。

戻り値:
color

getImgaeBorderColor

public Color getImgaeBorderColor()
推奨されていません。

画像ファイルのボーダ色を返します。

戻り値:
color

getGraphBackgroundColor

public Color getGraphBackgroundColor()
グラフ領域の背景色を返します。

戻り値:
Color グラフ領域の背景色

setGraphBackgroundColor

public void setGraphBackgroundColor(Color color)
グラフ領域の背景色を設定します。

パラメータ:
color - グラフ領域の背景色

getGraphBorderColor

public Color getGraphBorderColor()
グラフ領域のボーダーの色を返します。

戻り値:
グラフ領域のボーダーの色

setGraphBorderColor

public void setGraphBorderColor(Color color)
グラフ領域のボーダーの色を設定します。

パラメータ:
color - グラフ領域のボーダーの色

getCaptionColor

public Color getCaptionColor()
キャプションの文字色を返します。

戻り値:
キャプションの文字色

setCaptionColor

public void setCaptionColor(Color color)
キャプションの文字色を設定します。

パラメータ:
color - キャプションの文字色

addData

public void addData(int index,
                    BarGraphObject obj)
指定された位置に、指定された描画オブジェクトを追加します。 現在その位置にあるデータはindex値に１追加されます。

パラメータ:
obj - データ
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index > size())

isDouble

public boolean isDouble()
ｙ軸の目盛値がdouble表現かどうかを判定します。

戻り値:
doubleで表現する場合はtrue

getData

public BarGraphObject getData(int index)
リスト内の指定された位置にあるデータを返します。

パラメータ:
index - インデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

remove

public void remove(int index)
指定された位置のデータを削除します。 削除後は後続の要素を左側に移動します。

パラメータ:
index - 削除されるデータ値のインデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

size

public int size()
データの数を返します。

戻り値:
int 値の数

clear

public void clear()
すべてのデータを削除します。

setMargin

public void setMargin(int top,
                      int right,
                      int bottom,
                      int left)
グラフ領域のマージンを設定します。

パラメータ:
top - 上部のマージン
right - 右側のマ－ジン
bottom - 下部のマージン
left - 左側のマージン

createImage

protected void createImage(Graphics g)
棒グラフを描画します。

定義:
クラス AbstractDrawer 内の createImage
パラメータ:
g - グラフィックコンテキスト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BarGraphObject (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス BarGraphObject

java.lang.Object
    拡張 jp.co.intra_mart.foundation.graph.BarGraphObject
すべての実装インタフェース:
Serializable
public class BarGraphObject
extends Object
implements Serializable

BarGraphDrawerクラスのデータを保存するオブジェクトです。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

コンストラクタの概要
BarGraphObject()
デフォルトのデータオブジェクトを作成します。
BarGraphObject(Color color)
線の色を指定して、データオブジェクトを作成します。
メソッドの概要
void | addData(double number) 値を追加します。
void | addData(int number) 値を追加します。
void | clear() すべての値を削除します。
Color | getColor() 棒の色を返します。
double | getData(int index) 指定された位置にある値を返します。
void | remove(int index) 指定された位置の値を削除します。
void | setColor(Color color) 棒の色を設定します。
int | size() 値の数を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BarGraphObject

public BarGraphObject()
デフォルトのデータオブジェクトを作成します。

BarGraphObject

public BarGraphObject(Color color)
線の色を指定して、データオブジェクトを作成します。

パラメータ:
color - 描画される線の色
メソッドの詳細

addData

public void addData(double number)
値を追加します。

パラメータ:
number - 値

addData

public void addData(int number)
値を追加します。 intを与えますが、値はdoubleで扱われます。

パラメータ:
number - 値

getData

public double getData(int index)
指定された位置にある値を返します。

パラメータ:
index - 返される値のインデックス
戻り値:
double 値
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

remove

public void remove(int index)
指定された位置の値を削除します。 削除後は後続の要素を左側に移動します。

パラメータ:
index - 削除されるデータ値のインデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

size

public int size()
値の数を返します。

戻り値:
int 値の数

clear

public void clear()
すべての値を削除します。

getColor

public Color getColor()
棒の色を返します。

戻り値:
color 描画される棒の色

setColor

public void setColor(Color color)
棒の色を設定します。

パラメータ:
color - 描画される棒の色
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CircleGraphDrawer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス CircleGraphDrawer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.drawer.AbstractDrawer
        拡張 jp.co.intra_mart.foundation.graph.CircleGraphDrawer
すべての実装インタフェース:
Serializable
public class CircleGraphDrawer
extends AbstractDrawer

円グラフを描画します。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

フィールドの概要
static int | DEFAULT_BOTTOM_MARGIN 標準のグラフ領域の下部マージン
static int | DEFAULT_CAPTION_MARGIN 標準のキャプション表示位置のマージン
static Color | DEFAULT_IMAGE_BACKGROUND_COLOR 標準の画像ファイル背景色
static Color | DEFAULT_IMAGE_BORDER_COLOR 標準の画像ファイルのボーダ色
static int | DEFAULT_LEFT_MARGIN 標準のグラフ領域の左側マージン
static int | DEFAULT_RIGHT_MARGIN 標準のグラフ領域の右側マージン
static int | DEFAULT_TOP_MARGIN 標準のグラフ領域の上部マージン
コンストラクタの概要
CircleGraphDrawer()
ｙ軸の目盛値をint表現で円グラフを作成します。
メソッドの概要
void | addData(CircleGraphObject obj) 描画オブジェクトに新しいデータを追加します。
void | addData(int index, CircleGraphObject obj) 指定された位置に、指定された描画オブジェクトを追加します。
void | clear() すべてのデータを削除します。
protected void | createImage(Graphics g) 円グラフを描画します。
int | getCaptionMargin() キャプション表示位置のマージンを返します。
CircleGraphObject | getData(int index) リスト内の指定された位置にあるデータを返します。
Color | getImageBackgroundColor() 画像ファイルの背景色を返します。
Color | getImageBorderColor() 画像ファイルのボーダ色を返します。
Color | getImgaeBackgroundColor() 推奨されていません。
Color | getImgaeBorderColor() 推奨されていません。
void | remove(int index) 指定された位置のデータを削除します。
void | setCaptionMargin(int margin) キャプション表示位置のマージンを設定します。
void | setImageBackgroundColor(Color color) 画像ファイルの背景色を設定します。
void | setImageBorderColor(Color color) 画像ファイルのボーダ色を設定します。
void | setImgaeBackgroundColor(Color color) 推奨されていません。
void | setImgaeBorderColor(Color color) 推奨されていません。
void | setMargin(int top, int right, int bottom, int left) グラフ領域のマージンを設定します。
int | size() データの数を返します。
クラス jp.co.intra_mart.foundation.drawer.AbstractDrawer から継承したメソッド
getContentType, getHeight, getWidth, putImage, setContentType, setHeight, setWidth
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_TOP_MARGIN

public static int DEFAULT_TOP_MARGIN
標準のグラフ領域の上部マージン

DEFAULT_RIGHT_MARGIN

public static int DEFAULT_RIGHT_MARGIN
標準のグラフ領域の右側マージン

DEFAULT_BOTTOM_MARGIN

public static int DEFAULT_BOTTOM_MARGIN
標準のグラフ領域の下部マージン

DEFAULT_LEFT_MARGIN

public static int DEFAULT_LEFT_MARGIN
標準のグラフ領域の左側マージン

DEFAULT_CAPTION_MARGIN

public static int DEFAULT_CAPTION_MARGIN
標準のキャプション表示位置のマージン

DEFAULT_IMAGE_BACKGROUND_COLOR

public static Color DEFAULT_IMAGE_BACKGROUND_COLOR
標準の画像ファイル背景色

DEFAULT_IMAGE_BORDER_COLOR

public static Color DEFAULT_IMAGE_BORDER_COLOR
標準の画像ファイルのボーダ色

コンストラクタの詳細

CircleGraphDrawer

public CircleGraphDrawer()
ｙ軸の目盛値をint表現で円グラフを作成します。

例外:
IllegalArgumentException - max <= min または count <= 0
メソッドの詳細

addData

public void addData(CircleGraphObject obj)
描画オブジェクトに新しいデータを追加します。

パラメータ:
obj - データ

setImageBackgroundColor

public void setImageBackgroundColor(Color color)
画像ファイルの背景色を設定します。

パラメータ:
color -

setImgaeBackgroundColor

public void setImgaeBackgroundColor(Color color)
推奨されていません。

画像ファイルの背景色を設定します。

パラメータ:
color -

getImageBackgroundColor

public Color getImageBackgroundColor()
画像ファイルの背景色を返します。

戻り値:
color

getImgaeBackgroundColor

public Color getImgaeBackgroundColor()
推奨されていません。

画像ファイルの背景色を返します。

戻り値:
color

setImageBorderColor

public void setImageBorderColor(Color color)
画像ファイルのボーダ色を設定します。

パラメータ:
color -

setImgaeBorderColor

public void setImgaeBorderColor(Color color)
推奨されていません。

画像ファイルのボーダ色を設定します。

パラメータ:
color -

getImageBorderColor

public Color getImageBorderColor()
画像ファイルのボーダ色を返します。

戻り値:
color

getImgaeBorderColor

public Color getImgaeBorderColor()
推奨されていません。

画像ファイルのボーダ色を返します。

戻り値:
color

addData

public void addData(int index,
                    CircleGraphObject obj)
指定された位置に、指定された描画オブジェクトを追加します。 現在その位置にあるデータはindex値に１追加されます。

パラメータ:
obj - データ
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index > size())

getData

public CircleGraphObject getData(int index)
リスト内の指定された位置にあるデータを返します。

パラメータ:
index - インデックス
戻り値:
jp.co.intra_mart.foundation.graph.RadarChartObject
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

remove

public void remove(int index)
指定された位置のデータを削除します。 削除後は後続の要素を左側に移動します。

パラメータ:
index - 削除されるデータ値のインデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

size

public int size()
データの数を返します。

戻り値:
int 値の数

clear

public void clear()
すべてのデータを削除します。

setMargin

public void setMargin(int top,
                      int right,
                      int bottom,
                      int left)
グラフ領域のマージンを設定します。

パラメータ:
top - 上部のマージン
right - 右側のマ－ジン
bottom - 下部のマージン
left - 左側のマージン

setCaptionMargin

public void setCaptionMargin(int margin)
キャプション表示位置のマージンを設定します。

パラメータ:
margin - キャプション表示位置のマージン

getCaptionMargin

public int getCaptionMargin()
キャプション表示位置のマージンを返します。

戻り値:
int キャプション表示位置のマージン

createImage

protected void createImage(Graphics g)
円グラフを描画します。

定義:
クラス AbstractDrawer 内の createImage
パラメータ:
g - グラフィックコンテキスト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CircleGraphObject (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス CircleGraphObject

java.lang.Object
    拡張 jp.co.intra_mart.foundation.graph.CircleGraphObject
すべての実装インタフェース:
Serializable
public class CircleGraphObject
extends Object
implements Serializable

CircleGraphDrawerクラスのデータを保存するオブジェクトです。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

コンストラクタの概要
CircleGraphObject(double number, Color color)
グラフ値と色を指定して、データオブジェクトを作成します。
CircleGraphObject(double number, Color color, String caption)
グラフ値と色とキャプションを指定して、データオブジェクトを作成します。
CircleGraphObject(int number, Color color)
グラフ値と色を指定して、データオブジェクトを作成します。
CircleGraphObject(int number, Color color, String caption)
グラフ値と色とキャプションを指定して、データオブジェクトを作成します。
メソッドの概要
String | getCaption() キャプション文字列を返します。
Color | getColor() グラフの色を返します。
double | getData() グラフ値を返します。
Color | getFontColor() キャプションの文字色を返します。
int | getFontSize() キャプションの文字サイズを返します。
boolean | isDouble() グラフ値がdouble表現かどうかを判定します。
void | setCaption(String caption) キャプション文字列を返します。
void | setFontColor(Color font_color) キャプションの文字色を設定します。
void | setFontSize(int font_size) キャプションの文字サイズを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CircleGraphObject

public CircleGraphObject(double number,
                         Color color)
グラフ値と色を指定して、データオブジェクトを作成します。 グラフ値は doubleです。

パラメータ:
number - グラフの値
color - 描画されるグラフの色

CircleGraphObject

public CircleGraphObject(int number,
                         Color color)
グラフ値と色を指定して、データオブジェクトを作成します。 グラフ値は intで与えますが、値はdoubleで扱われます。

パラメータ:
number - グラフの値
color - 描画されるグラフの色

CircleGraphObject

public CircleGraphObject(double number,
                         Color color,
                         String caption)
グラフ値と色とキャプションを指定して、データオブジェクトを作成します。 グラフ値は doubleです。

パラメータ:
number - グラフの値
color - 描画されるグラフの色
caption - キャプションの文字列

CircleGraphObject

public CircleGraphObject(int number,
                         Color color,
                         String caption)
グラフ値と色とキャプションを指定して、データオブジェクトを作成します。 グラフ値は intで与えますが、値はdoubleで扱われます。

パラメータ:
number - グラフの値
color - 描画されるグラフの色
caption - キャプションの文字列
メソッドの詳細

getData

public double getData()
グラフ値を返します。

戻り値:
double 値

getColor

public Color getColor()
グラフの色を返します。

戻り値:
color 描画されるグラフの色

getCaption

public String getCaption()
キャプション文字列を返します。

戻り値:
String キャプション文字列

setCaption

public void setCaption(String caption)
キャプション文字列を返します。

戻り値:
String キャプション文字列

getFontColor

public Color getFontColor()
キャプションの文字色を返します。

戻り値:
Color キャプションの文字色

setFontColor

public void setFontColor(Color font_color)
キャプションの文字色を設定します。

パラメータ:
font_color - キャプションの文字色

getFontSize

public int getFontSize()
キャプションの文字サイズを返します。

戻り値:
int キャプションの文字サイズ

setFontSize

public void setFontSize(int font_size)
キャプションの文字サイズを設定します。

パラメータ:
font_size - キャプションの文字サイズ

isDouble

public boolean isDouble()
グラフ値がdouble表現かどうかを判定します。

戻り値:
doubleで表現する場合はtrue
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LineGraphDrawer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス LineGraphDrawer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.drawer.AbstractDrawer
        拡張 jp.co.intra_mart.foundation.graph.LineGraphDrawer
すべての実装インタフェース:
Serializable
public class LineGraphDrawer
extends AbstractDrawer

折れ線グラフを描画します。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

フィールドの概要
static int | DEFAULT_BOTTOM_MARGIN 標準のグラフ領域の下部マージン
static Color | DEFAULT_GRAPH_BACKGROUND_COLOR 標準のグラフ領域の背景色
static Color | DEFAULT_GRAPH_BORDER_COLOR 標準のグラフ領域のボーダー色
static Color | DEFAULT_IMAGE_BACKGROUND_COLOR 標準の画像ファイル背景色
static Color | DEFAULT_IMAGE_BORDER_COLOR 標準の画像ファイルのボーダ色
static int | DEFAULT_LEFT_MARGIN 標準のグラフ領域の左側マージン
static int | DEFAULT_RIGHT_MARGIN 標準のグラフ領域の右側マージン
static int | DEFAULT_TOP_MARGIN 標準のグラフ領域の上部マージン
コンストラクタの概要
LineGraphDrawer(double min, double max, double count)
ｙ軸の目盛値をdouble表現で折れ線グラフを作成します。
LineGraphDrawer(int min, int max, int count)
ｙ軸の目盛値をint表現で折れ線グラフを作成します。
メソッドの概要
void | addData(int index, LineGraphObject obj) 指定された位置に、指定された描画オブジェクトを追加します。
void | addData(LineGraphObject obj) 描画オブジェクトに新しいデータを追加します。
void | clear() すべてのデータを削除します。
protected void | createImage(Graphics g) 折れ線グラフを描画します。
String[] | getCaption() ｘ軸のキャプションを返します。
Color | getCaptionColor() キャプションの文字色を返します。
LineGraphObject | getData(int index) リスト内の指定された位置にあるデータを返します。
Color | getGraphBackgroundColor() グラフ領域の背景色を返します。
Color | getGraphBorderColor() グラフ領域のボーダーの色を返します。
Color | getImageBackgroundColor() 画像ファイルの背景色を返します。
Color | getImageBorderColor() 画像ファイルのボーダ色を返します。
Color | getImgaeBackgroundColor() 推奨されていません。
Color | getImgaeBorderColor() 推奨されていません。
double | getMax() ｙ軸の最大値を返します。
double | getMin() ｙ軸の最小値を返します。
double | getScaleCount() ｙ軸の目盛間隔を返します。
boolean | isDouble() ｙ軸の目盛値がdouble表現かどうかを判定します。
void | remove(int index) 指定された位置のデータを削除します。
void | setCaption(String[] caption) ｘ軸のキャプションを設定します。
void | setCaptionColor(Color color) キャプションの文字色を設定します。
void | setGraphBackgroundColor(Color color) グラフ領域の背景色を設定します。
void | setGraphBorderColor(Color color) グラフ領域のボーダーの色を設定します。
void | setImageBackgroundColor(Color color) 画像ファイルの背景色を設定します。
void | setImageBorderColor(Color color) 画像ファイルのボーダ色を設定します。
void | setImgaeBackgroundColor(Color color) 推奨されていません。
void | setImgaeBorderColor(Color color) 推奨されていません。
void | setMargin(int top, int right, int bottom, int left) グラフ領域のマージンを設定します。
int | size() データの数を返します。
クラス jp.co.intra_mart.foundation.drawer.AbstractDrawer から継承したメソッド
getContentType, getHeight, getWidth, putImage, setContentType, setHeight, setWidth
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_TOP_MARGIN

public static int DEFAULT_TOP_MARGIN
標準のグラフ領域の上部マージン

DEFAULT_RIGHT_MARGIN

public static int DEFAULT_RIGHT_MARGIN
標準のグラフ領域の右側マージン

DEFAULT_BOTTOM_MARGIN

public static int DEFAULT_BOTTOM_MARGIN
標準のグラフ領域の下部マージン

DEFAULT_LEFT_MARGIN

public static int DEFAULT_LEFT_MARGIN
標準のグラフ領域の左側マージン

DEFAULT_IMAGE_BACKGROUND_COLOR

public static Color DEFAULT_IMAGE_BACKGROUND_COLOR
標準の画像ファイル背景色

DEFAULT_IMAGE_BORDER_COLOR

public static Color DEFAULT_IMAGE_BORDER_COLOR
標準の画像ファイルのボーダ色

DEFAULT_GRAPH_BACKGROUND_COLOR

public static Color DEFAULT_GRAPH_BACKGROUND_COLOR
標準のグラフ領域の背景色

DEFAULT_GRAPH_BORDER_COLOR

public static Color DEFAULT_GRAPH_BORDER_COLOR
標準のグラフ領域のボーダー色

コンストラクタの詳細

LineGraphDrawer

public LineGraphDrawer(int min,
                       int max,
                       int count)
ｙ軸の目盛値をint表現で折れ線グラフを作成します。

パラメータ:
min - ｙ軸の最小値
max - ｙ軸の最大値
count - ｙ軸の目盛間隔
例外:
IllegalArgumentException - max <= min または count <= 0

LineGraphDrawer

public LineGraphDrawer(double min,
                       double max,
                       double count)
ｙ軸の目盛値をdouble表現で折れ線グラフを作成します。

パラメータ:
min - ｙ軸の最小値
max - ｙ軸の最大値
count - ｙ軸の目盛間隔
例外:
IllegalArgumentException - max <= min または count <= 0
メソッドの詳細

getMax

public double getMax()
ｙ軸の最大値を返します。

戻り値:
double ｙ軸の最大値

getMin

public double getMin()
ｙ軸の最小値を返します。

戻り値:
double ｙ軸の最小値

getScaleCount

public double getScaleCount()
ｙ軸の目盛間隔を返します。

戻り値:
double ｙ軸の目盛間隔

setCaption

public void setCaption(String[] caption)
ｘ軸のキャプションを設定します。

パラメータ:
caption - キャプション

getCaption

public String[] getCaption()
ｘ軸のキャプションを返します。

戻り値:
キャプション

addData

public void addData(LineGraphObject obj)
描画オブジェクトに新しいデータを追加します。

パラメータ:
obj - データ

setImageBackgroundColor

public void setImageBackgroundColor(Color color)
画像ファイルの背景色を設定します。

パラメータ:
color -

setImgaeBackgroundColor

public void setImgaeBackgroundColor(Color color)
推奨されていません。

画像ファイルの背景色を設定します。

パラメータ:
color -

getImageBackgroundColor

public Color getImageBackgroundColor()
画像ファイルの背景色を返します。

戻り値:
color

getImgaeBackgroundColor

public Color getImgaeBackgroundColor()
推奨されていません。

画像ファイルの背景色を返します。

戻り値:
color

setImageBorderColor

public void setImageBorderColor(Color color)
画像ファイルのボーダ色を設定します。

パラメータ:
color -

setImgaeBorderColor

public void setImgaeBorderColor(Color color)
推奨されていません。

画像ファイルのボーダ色を設定します。

パラメータ:
color -

getImageBorderColor

public Color getImageBorderColor()
画像ファイルのボーダ色を返します。

戻り値:
color

getImgaeBorderColor

public Color getImgaeBorderColor()
推奨されていません。

画像ファイルのボーダ色を返します。

戻り値:
color

getGraphBackgroundColor

public Color getGraphBackgroundColor()
グラフ領域の背景色を返します。

戻り値:
Color グラフ領域の背景色

setGraphBackgroundColor

public void setGraphBackgroundColor(Color color)
グラフ領域の背景色を設定します。

パラメータ:
color - グラフ領域の背景色

getGraphBorderColor

public Color getGraphBorderColor()
グラフ領域のボーダーの色を返します。

戻り値:
グラフ領域のボーダーの色

setGraphBorderColor

public void setGraphBorderColor(Color color)
グラフ領域のボーダーの色を設定します。

パラメータ:
color - グラフ領域のボーダーの色

getCaptionColor

public Color getCaptionColor()
キャプションの文字色を返します。

戻り値:
キャプションの文字色

setCaptionColor

public void setCaptionColor(Color color)
キャプションの文字色を設定します。

パラメータ:
color - キャプションの文字色

addData

public void addData(int index,
                    LineGraphObject obj)
指定された位置に、指定された描画オブジェクトを追加します。 現在その位置にあるデータはindex値に１追加されます。

パラメータ:
obj - データ
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index > size())

isDouble

public boolean isDouble()
ｙ軸の目盛値がdouble表現かどうかを判定します。

戻り値:
doubleで表現する場合はtrue

getData

public LineGraphObject getData(int index)
リスト内の指定された位置にあるデータを返します。

パラメータ:
index - インデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

remove

public void remove(int index)
指定された位置のデータを削除します。 削除後は後続の要素を左側に移動します。

パラメータ:
index - 削除されるデータ値のインデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

size

public int size()
データの数を返します。

戻り値:
int 値の数

clear

public void clear()
すべてのデータを削除します。

setMargin

public void setMargin(int top,
                      int right,
                      int bottom,
                      int left)
グラフ領域のマージンを設定します。

パラメータ:
top - 上部のマージン
right - 右側のマ－ジン
bottom - 下部のマージン
left - 左側のマージン

createImage

protected void createImage(Graphics g)
折れ線グラフを描画します。

定義:
クラス AbstractDrawer 内の createImage
パラメータ:
g - グラフィックコンテキスト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LineGraphObject (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス LineGraphObject

java.lang.Object
    拡張 jp.co.intra_mart.foundation.graph.LineGraphObject
すべての実装インタフェース:
Serializable
public class LineGraphObject
extends Object
implements Serializable

LineGraphDrawerクラスのデータを保存するオブジェクトです。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

フィールドの概要
static Stroke DEFAULT_STROKE
コンストラクタの概要
LineGraphObject()
デフォルトのデータオブジェクトを作成します。
LineGraphObject(Color color)
線の色を指定して、データオブジェクトを作成します。
LineGraphObject(Color color, Stroke stroke)
線の色と描画属性を指定して、データオブジェクトを作成します。
LineGraphObject(Stroke stroke)
線の描画属性を指定して、データオブジェクトを作成します。
メソッドの概要
void | addData(double number) 値を追加します。
void | addData(int number) 値を追加します。
void | clear() すべての値を削除します。
Color | getColor() 線の色を返します。
double | getData(int index) 指定された位置にある値を返します。
Stroke | getStroke() 描画される線の描画属性を返します。
void | remove(int index) 指定された位置の値を削除します。
void | setColor(Color color) 線の色を設定します。
void | setStroke(Stroke stroke) 描画される線の描画属性を設定します。
int | size() 値の数を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_STROKE

public static Stroke DEFAULT_STROKE
コンストラクタの詳細

LineGraphObject

public LineGraphObject()
デフォルトのデータオブジェクトを作成します。

LineGraphObject

public LineGraphObject(Color color)
線の色を指定して、データオブジェクトを作成します。

パラメータ:
color - 描画される線の色

LineGraphObject

public LineGraphObject(Stroke stroke)
線の描画属性を指定して、データオブジェクトを作成します。

パラメータ:
stroke - 描画される線の描画属性

LineGraphObject

public LineGraphObject(Color color,
                       Stroke stroke)
線の色と描画属性を指定して、データオブジェクトを作成します。

パラメータ:
color - 描画される線の色
stroke - 描画される線の描画属性
メソッドの詳細

addData

public void addData(double number)
値を追加します。

パラメータ:
number - 値

addData

public void addData(int number)
値を追加します。 intを与えますが、値はdoubleで扱われます。

パラメータ:
number - 値

getData

public double getData(int index)
指定された位置にある値を返します。

パラメータ:
index - 返される値のインデックス
戻り値:
double 値
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

remove

public void remove(int index)
指定された位置の値を削除します。 削除後は後続の要素を左側に移動します。

パラメータ:
index - 削除されるデータ値のインデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

size

public int size()
値の数を返します。

戻り値:
int 値の数

clear

public void clear()
すべての値を削除します。

getColor

public Color getColor()
線の色を返します。

戻り値:
color 描画される線の色

getStroke

public Stroke getStroke()
描画される線の描画属性を返します。

戻り値:
描画される線の描画属性

setColor

public void setColor(Color color)
線の色を設定します。

パラメータ:
color - 描画される線の色

setStroke

public void setStroke(Stroke stroke)
描画される線の描画属性を設定します。

パラメータ:
stroke - 描画される線の描画属性
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.graph (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.graph
クラス
BarGraphDrawer
BarGraphObject
CircleGraphDrawer
CircleGraphObject
LineGraphDrawer
LineGraphObject
PortFolioDrawer
PortFolioObject
RadarChartDrawer
RadarChartObject


jp.co.intra_mart.foundation.graph (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.graph

グラフ描画に関するクラスを提供します。

参照:
説明

クラスの概要
BarGraphDrawer | 棒グラフを描画します。
BarGraphObject | BarGraphDrawerクラスのデータを保存するオブジェクトです。
CircleGraphDrawer | 円グラフを描画します。
CircleGraphObject | CircleGraphDrawerクラスのデータを保存するオブジェクトです。
LineGraphDrawer | 折れ線グラフを描画します。
LineGraphObject | LineGraphDrawerクラスのデータを保存するオブジェクトです。
PortFolioDrawer | ポートフォリオを描画します。
PortFolioObject | PortFolioDrawerクラスのデータを保存するオブジェクトです。
RadarChartDrawer | レーダーチャートを描画します。
RadarChartObject | RadarChartDrawerクラスのデータを保存するオブジェクトです。

パッケージ jp.co.intra_mart.foundation.graph の説明

グラフ描画に関するクラスを提供します。


jp.co.intra_mart.foundation.graph クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.graph の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.drawer.AbstractDrawer (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.graph.BarGraphDrawer
      • class jp.co.intra_mart.foundation.graph.CircleGraphDrawer
      • class jp.co.intra_mart.foundation.graph.LineGraphDrawer
      • class jp.co.intra_mart.foundation.graph.PortFolioDrawer
      • class jp.co.intra_mart.foundation.graph.RadarChartDrawer
    • class jp.co.intra_mart.foundation.graph.BarGraphObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.graph.CircleGraphObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.graph.LineGraphObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.graph.PortFolioObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.graph.RadarChartObject (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.graph の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.graph の使用

jp.co.intra_mart.foundation.graph を使用しているパッケージ
jp.co.intra_mart.foundation.graph グラフ描画に関するクラスを提供します。

jp.co.intra_mart.foundation.graph により使用される jp.co.intra_mart.foundation.graph のクラス
BarGraphObject
BarGraphDrawerクラスのデータを保存するオブジェクトです。
CircleGraphObject
CircleGraphDrawerクラスのデータを保存するオブジェクトです。
LineGraphObject
LineGraphDrawerクラスのデータを保存するオブジェクトです。
PortFolioObject
PortFolioDrawerクラスのデータを保存するオブジェクトです。
RadarChartObject
RadarChartDrawerクラスのデータを保存するオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PortFolioDrawer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス PortFolioDrawer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.drawer.AbstractDrawer
        拡張 jp.co.intra_mart.foundation.graph.PortFolioDrawer
すべての実装インタフェース:
Serializable
public class PortFolioDrawer
extends AbstractDrawer

ポートフォリオを描画します。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

フィールドの概要
static int | DEFAULT_BOTTOM_MARGIN 標準のグラフ領域の下部マージン
static Color | DEFAULT_GRAPH_BACKGROUND_COLOR 標準のグラフ領域の背景色
static Color | DEFAULT_GRAPH_BORDER_COLOR 標準のグラフ領域のボーダー色
static Color | DEFAULT_IMAGE_BACKGROUND_COLOR 標準の画像ファイル背景色
static Color | DEFAULT_IMAGE_BORDER_COLOR 標準の画像ファイルのボーダ色
static int | DEFAULT_LEFT_MARGIN 標準のグラフ領域の左側マージン
static int | DEFAULT_RIGHT_MARGIN 標準のグラフ領域の右側マージン
static int | DEFAULT_TOP_MARGIN 標準のグラフ領域の上部マージン
static String | SCALE_POSITION_CENTER ｘ軸、ｙ軸の目盛りの表示位置を「グラフの中心」に設定
static String | SCALE_POSITION_SIDE ｘ軸、ｙ軸の目盛りの表示位置を「グラフの枠」に設定
コンストラクタの概要
PortFolioDrawer(double x_center, double x_size, double x_count, double y_center, double y_size, double y_count)
ｘ軸、ｙ軸の目盛値をdouble表現でポートフォリオを作成します。
PortFolioDrawer(int x_center, int x_size, int x_count, int y_center, int y_size, int y_count)
ｘ軸、ｙ軸の目盛値をint表現でポートフォリオを作成します。
メソッドの概要
void | addData(int index, PortFolioObject obj) 指定された位置に、指定された描画オブジェクトを追加します。
void | addData(PortFolioObject obj) 描画オブジェクトに新しいデータを追加します。
void | clear() すべてのデータを削除します。
protected void | createImage(Graphics g) ポートフォリオを描画します。
Color | getCaptionColor() キャプションの文字色を返します。
double | getCenterPointX() ｘ軸の中心値を返します。
double | getCenterPointY() ｙ軸の中心値を返します。
PortFolioObject | getData(int index) リスト内の指定された位置にあるデータを返します。
double | getDataSizeX() ｘ軸の中心値からのデータサイズを返します。
double | getDataSizeY() ｙ軸の中心値からのデータサイズを返します。
Color | getGraphBackgroundColor() グラフ領域の背景色を返します。
Color | getGraphBorderColor() グラフ領域のボーダーの色を返します。
Color | getImageBackgroundColor() 画像ファイルの背景色を返します。
Color | getImageBorderColor() 画像ファイルのボーダ色を返します。
Color | getImgaeBackgroundColor() 推奨されていません。
Color | getImgaeBorderColor() 推奨されていません。
double | getScaleCountX() ｘ軸の目盛間隔を返します。
double | getScaleCountY() ｙ軸の目盛間隔を返します。
String | getScalePosition() ｘ軸、ｙ軸の目盛りの表示位置を返します。
boolean | isDouble() ｘ軸、ｙ軸の目盛値がdouble表現かどうかを判定します。
void | remove(int index) 指定された位置のデータを削除します。
void | setCaptionColor(Color color) キャプションの文字色を設定します。
void | setGraphBackgroundColor(Color color) グラフ領域の背景色を設定します。
void | setGraphBorderColor(Color color) グラフ領域のボーダーの色を設定します。
void | setImageBackgroundColor(Color color) 画像ファイルの背景色を設定します。
void | setImageBorderColor(Color color) 画像ファイルのボーダ色を設定します。
void | setImgaeBackgroundColor(Color color) 推奨されていません。
void | setImgaeBorderColor(Color color) 推奨されていません。
void | setMargin(int top, int right, int bottom, int left) グラフ領域のマージンを設定します。
void | setScalePosition(String scale_position) ｘ軸、ｙ軸の目盛りの表示位置を設定します。
int | size() データの数を返します。
クラス jp.co.intra_mart.foundation.drawer.AbstractDrawer から継承したメソッド
getContentType, getHeight, getWidth, putImage, setContentType, setHeight, setWidth
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_TOP_MARGIN

public static int DEFAULT_TOP_MARGIN
標準のグラフ領域の上部マージン

DEFAULT_RIGHT_MARGIN

public static int DEFAULT_RIGHT_MARGIN
標準のグラフ領域の右側マージン

DEFAULT_BOTTOM_MARGIN

public static int DEFAULT_BOTTOM_MARGIN
標準のグラフ領域の下部マージン

DEFAULT_LEFT_MARGIN

public static int DEFAULT_LEFT_MARGIN
標準のグラフ領域の左側マージン

DEFAULT_IMAGE_BACKGROUND_COLOR

public static Color DEFAULT_IMAGE_BACKGROUND_COLOR
標準の画像ファイル背景色

DEFAULT_IMAGE_BORDER_COLOR

public static Color DEFAULT_IMAGE_BORDER_COLOR
標準の画像ファイルのボーダ色

DEFAULT_GRAPH_BACKGROUND_COLOR

public static Color DEFAULT_GRAPH_BACKGROUND_COLOR
標準のグラフ領域の背景色

DEFAULT_GRAPH_BORDER_COLOR

public static Color DEFAULT_GRAPH_BORDER_COLOR
標準のグラフ領域のボーダー色

SCALE_POSITION_SIDE

public static String SCALE_POSITION_SIDE
ｘ軸、ｙ軸の目盛りの表示位置を「グラフの枠」に設定

SCALE_POSITION_CENTER

public static String SCALE_POSITION_CENTER
ｘ軸、ｙ軸の目盛りの表示位置を「グラフの中心」に設定

コンストラクタの詳細

PortFolioDrawer

public PortFolioDrawer(int x_center,
                       int x_size,
                       int x_count,
                       int y_center,
                       int y_size,
                       int y_count)
ｘ軸、ｙ軸の目盛値をint表現でポートフォリオを作成します。

パラメータ:
x_center - ｘ軸の中心値
x_size - ｘ軸の中心値からのデータサイズ
x_count - ｘ軸の目盛り間隔
y_center - ｙ軸の中心値
y_size - ｙ軸の中心値からのデータサイズ
y_count - ｙ軸の目盛り間隔
例外:
IllegalArgumentException - x_count <= 0 または y_count <= 0

PortFolioDrawer

public PortFolioDrawer(double x_center,
                       double x_size,
                       double x_count,
                       double y_center,
                       double y_size,
                       double y_count)
ｘ軸、ｙ軸の目盛値をdouble表現でポートフォリオを作成します。

パラメータ:
x_center - ｘ軸の中心値
x_size - ｘ軸の中心値からのデータサイズ
x_count - ｘ軸の目盛り間隔
y_center - ｙ軸の中心値
y_size - ｙ軸の中心値からのデータサイズ
y_count - ｙ軸の目盛り間隔
例外:
IllegalArgumentException - x_count <= 0 または y_count <= 0
メソッドの詳細

getCenterPointX

public double getCenterPointX()
ｘ軸の中心値を返します。

戻り値:
double ｘ軸の中心値

getDataSizeX

public double getDataSizeX()
ｘ軸の中心値からのデータサイズを返します。

戻り値:
double ｘ軸の中心値からのデータサイズ

getScaleCountX

public double getScaleCountX()
ｘ軸の目盛間隔を返します。

戻り値:
double ｘ軸の目盛り間隔

getCenterPointY

public double getCenterPointY()
ｙ軸の中心値を返します。

戻り値:
double ｙ軸の中心値

getDataSizeY

public double getDataSizeY()
ｙ軸の中心値からのデータサイズを返します。

戻り値:
double ｙ軸の中心値からのデータサイズ

getScaleCountY

public double getScaleCountY()
ｙ軸の目盛間隔を返します。

戻り値:
double ｙ軸の目盛り間隔

setScalePosition

public void setScalePosition(String scale_position)
ｘ軸、ｙ軸の目盛りの表示位置を設定します。 デフォルト値はSCALE_POSITION_CENTER（グラフの中心）になります

パラメータ:
scale_position - 目盛りの表示位置 SCALE_POSITION_CENTER：グラフの中心 SCALE_POSITION_SIDE：グラフの枠

getScalePosition

public String getScalePosition()
ｘ軸、ｙ軸の目盛りの表示位置を返します。

戻り値:
String 目盛りの表示位置 SCALE_POSITION_CENTER：グラフの中心 SCALE_POSITION_SIDE：グラフの枠

setImageBackgroundColor

public void setImageBackgroundColor(Color color)
画像ファイルの背景色を設定します。

パラメータ:
color -

setImgaeBackgroundColor

public void setImgaeBackgroundColor(Color color)
推奨されていません。

画像ファイルの背景色を設定します。

パラメータ:
color -

getImageBackgroundColor

public Color getImageBackgroundColor()
画像ファイルの背景色を返します。

戻り値:
color

getImgaeBackgroundColor

public Color getImgaeBackgroundColor()
推奨されていません。

画像ファイルの背景色を返します。

戻り値:
color

setImageBorderColor

public void setImageBorderColor(Color color)
画像ファイルのボーダ色を設定します。

パラメータ:
color -

setImgaeBorderColor

public void setImgaeBorderColor(Color color)
推奨されていません。

画像ファイルのボーダ色を設定します。

パラメータ:
color -

getImageBorderColor

public Color getImageBorderColor()
画像ファイルのボーダ色を返します。

戻り値:
color

getImgaeBorderColor

public Color getImgaeBorderColor()
推奨されていません。

画像ファイルのボーダ色を返します。

戻り値:
color

getGraphBackgroundColor

public Color getGraphBackgroundColor()
グラフ領域の背景色を返します。

戻り値:
Color グラフ領域の背景色

setGraphBackgroundColor

public void setGraphBackgroundColor(Color color)
グラフ領域の背景色を設定します。

パラメータ:
color - グラフ領域の背景色

getGraphBorderColor

public Color getGraphBorderColor()
グラフ領域のボーダーの色を返します。

戻り値:
グラフ領域のボーダーの色

setGraphBorderColor

public void setGraphBorderColor(Color color)
グラフ領域のボーダーの色を設定します。

パラメータ:
color - グラフ領域のボーダーの色

getCaptionColor

public Color getCaptionColor()
キャプションの文字色を返します。

戻り値:
キャプションの文字色

setCaptionColor

public void setCaptionColor(Color color)
キャプションの文字色を設定します。

パラメータ:
color - キャプションの文字色

addData

public void addData(PortFolioObject obj)
描画オブジェクトに新しいデータを追加します。

パラメータ:
obj - データ

addData

public void addData(int index,
                    PortFolioObject obj)
指定された位置に、指定された描画オブジェクトを追加します。 現在その位置にあるデータはindex値に１追加されます。

パラメータ:
obj - データ
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index > size())

isDouble

public boolean isDouble()
ｘ軸、ｙ軸の目盛値がdouble表現かどうかを判定します。

戻り値:
doubleで表現する場合はtrue

getData

public PortFolioObject getData(int index)
リスト内の指定された位置にあるデータを返します。

パラメータ:
index - インデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

remove

public void remove(int index)
指定された位置のデータを削除します。 削除後は後続の要素を左側に移動します。

パラメータ:
index - 削除されるデータ値のインデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

size

public int size()
データの数を返します。

戻り値:
int 値の数

clear

public void clear()
すべてのデータを削除します。

setMargin

public void setMargin(int top,
                      int right,
                      int bottom,
                      int left)
グラフ領域のマージンを設定します。

パラメータ:
top - 上部のマージン
right - 右側のマ－ジン
bottom - 下部のマージン
left - 左側のマージン

createImage

protected void createImage(Graphics g)
ポートフォリオを描画します。

定義:
クラス AbstractDrawer 内の createImage
パラメータ:
g - グラフィックコンテキスト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PortFolioObject (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス PortFolioObject

java.lang.Object
    拡張 jp.co.intra_mart.foundation.graph.PortFolioObject
すべての実装インタフェース:
Serializable
public class PortFolioObject
extends Object
implements Serializable

PortFolioDrawerクラスのデータを保存するオブジェクトです。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

コンストラクタの概要
PortFolioObject(double x_data, double y_data)
グラフのｘ値、ｙ値を指定して、データオブジェクトを作成します。
PortFolioObject(double x_data, double y_data, Color color, int size)
グラフのｘ値、ｙ値と描画する点の色とサイズを指定して、データオブジェクトを作成します。
PortFolioObject(int x_data, int y_data)
グラフのｘ値、ｙ値を指定して、データオブジェクトを作成します。
PortFolioObject(int x_data, int y_data, Color color, int size)
グラフのｘ値、ｙ値と描画する点の色とサイズを指定して、データオブジェクトを作成します。
メソッドの概要
Color | getColor() 描画する点の色を返します。
double | getDataX() グラフのｘ値を返します。
double | getDataY() グラフのｙ値を返します。
int | getSize() 描画する点のサイズを返します。
boolean | isDouble() グラフ値がdouble表現かどうかを判定します。
void | setColor(Color color) 描画する点の色を設定します。
void | setSize(int size) 描画する点のサイズを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PortFolioObject

public PortFolioObject(double x_data,
                       double y_data)
グラフのｘ値、ｙ値を指定して、データオブジェクトを作成します。 グラフ値は doubleです。

パラメータ:
x_data - グラフのｘ値
y_data - グラフのｙ値

PortFolioObject

public PortFolioObject(int x_data,
                       int y_data)
グラフのｘ値、ｙ値を指定して、データオブジェクトを作成します。 グラフ値は intで与えますが、値はdoubleで扱われます。

パラメータ:
x_data - グラフのｘ値
y_data - グラフのｙ値

PortFolioObject

public PortFolioObject(double x_data,
                       double y_data,
                       Color color,
                       int size)
グラフのｘ値、ｙ値と描画する点の色とサイズを指定して、データオブジェクトを作成します。 グラフ値は doubleです。

パラメータ:
x_data - グラフのｘ値
y_data - グラフのｙ値
color - 描画する点の色
size - 描画する点のサイズ

PortFolioObject

public PortFolioObject(int x_data,
                       int y_data,
                       Color color,
                       int size)
グラフのｘ値、ｙ値と描画する点の色とサイズを指定して、データオブジェクトを作成します。 グラフ値は intで与えますが、値はdoubleで扱われます。

パラメータ:
x_data - グラフのｘ値
y_data - グラフのｙ値
color - 描画する点の色
size - 描画する点のサイズ
メソッドの詳細

getDataX

public double getDataX()
グラフのｘ値を返します。

戻り値:
double ｘ値

getDataY

public double getDataY()
グラフのｙ値を返します。

戻り値:
double ｙ値

getColor

public Color getColor()
描画する点の色を返します。

戻り値:
color 描画する点の色

setColor

public void setColor(Color color)
描画する点の色を設定します。

パラメータ:
color - 描画する点の色

getSize

public int getSize()
描画する点のサイズを返します。

戻り値:
int 描画する点のサイズ

setSize

public void setSize(int size)
描画する点のサイズを設定します。

パラメータ:
size - 描画する点のサイズ

isDouble

public boolean isDouble()
グラフ値がdouble表現かどうかを判定します。

戻り値:
doubleで表現する場合はtrue
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RadarChartDrawer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス RadarChartDrawer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.drawer.AbstractDrawer
        拡張 jp.co.intra_mart.foundation.graph.RadarChartDrawer
すべての実装インタフェース:
Serializable
public class RadarChartDrawer
extends AbstractDrawer

レーダーチャートを描画します。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

フィールドの概要
static int | DEFAULT_BOTTOM_MARGIN 標準のグラフ領域の下部マージン
static int | DEFAULT_CAPTION_MARGIN 標準のキャプション表示位置のマージン
static Color | DEFAULT_GRAPH_FRAME_COLOR 標準のグラフ枠の線色
static Color | DEFAULT_IMAGE_BACKGROUND_COLOR 標準の画像ファイル背景色
static Color | DEFAULT_IMAGE_BORDER_COLOR 標準の画像ファイルのボーダ色
static int | DEFAULT_LEFT_MARGIN 標準のグラフ領域の左側マージン
static int | DEFAULT_RIGHT_MARGIN 標準のグラフ領域の右側マージン
static int | DEFAULT_TOP_MARGIN 標準のグラフ領域の上部マージン
コンストラクタの概要
RadarChartDrawer(double min, double max, double count)
ｙ軸の目盛値をdouble表現でレーダーチャートを作成します。
RadarChartDrawer(int min, int max, int count)
ｙ軸の目盛値をint表現でレーダーチャートを作成します。
メソッドの概要
void | addData(int index, RadarChartObject obj) 指定された位置に、指定された描画オブジェクトを追加します。
void | addData(RadarChartObject obj) 描画オブジェクトに新しいデータを追加します。
void | clear() すべてのデータを削除します。
protected void | createImage(Graphics g) レーダーチャートを描画します。
String[] | getCaption() ｘ軸のキャプションを返します。
Color | getCaptionColor() キャプションの文字色を返します。
int | getCaptionMargin() キャプション表示位置のマージンを返します。
RadarChartObject | getData(int index) リスト内の指定された位置にあるデータを返します。
Color | getGraphFrameColor() グラフ枠の線色を返します。
Color | getImageBackgroundColor() 画像ファイルの背景色を返します。
Color | getImageBorderColor() 画像ファイルのボーダ色を返します。
Color | getImgaeBackgroundColor() 推奨されていません。
Color | getImgaeBorderColor() 推奨されていません。
double | getMax() ｙ軸の最大値を返します。
double | getMin() ｙ軸の最小値を返します。
double | getScaleCount() ｙ軸の目盛間隔を返します。
boolean | isDouble() ｙ軸の目盛値がdouble表現かどうかを判定します。
void | remove(int index) 指定された位置のデータを削除します。
void | setCaption(String[] caption) ｘ軸のキャプションを設定します。
void | setCaptionColor(Color color) キャプションの文字色を設定します。
void | setCaptionMargin(int margin) キャプション表示位置のマージンを設定します。
void | setGraphFrameColor(Color color) グラフ枠の線色を設定します。
void | setImageBackgroundColor(Color color) 画像ファイルの背景色を設定します。
void | setImageBorderColor(Color color) 画像ファイルのボーダ色を設定します。
void | setImgaeBackgroundColor(Color color) 推奨されていません。
void | setImgaeBorderColor(Color color) 推奨されていません。
void | setMargin(int top, int right, int bottom, int left) グラフ領域のマージンを設定します。
int | size() データの数を返します。
クラス jp.co.intra_mart.foundation.drawer.AbstractDrawer から継承したメソッド
getContentType, getHeight, getWidth, putImage, setContentType, setHeight, setWidth
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_TOP_MARGIN

public static int DEFAULT_TOP_MARGIN
標準のグラフ領域の上部マージン

DEFAULT_RIGHT_MARGIN

public static int DEFAULT_RIGHT_MARGIN
標準のグラフ領域の右側マージン

DEFAULT_BOTTOM_MARGIN

public static int DEFAULT_BOTTOM_MARGIN
標準のグラフ領域の下部マージン

DEFAULT_LEFT_MARGIN

public static int DEFAULT_LEFT_MARGIN
標準のグラフ領域の左側マージン

DEFAULT_CAPTION_MARGIN

public static int DEFAULT_CAPTION_MARGIN
標準のキャプション表示位置のマージン

DEFAULT_IMAGE_BACKGROUND_COLOR

public static Color DEFAULT_IMAGE_BACKGROUND_COLOR
標準の画像ファイル背景色

DEFAULT_IMAGE_BORDER_COLOR

public static Color DEFAULT_IMAGE_BORDER_COLOR
標準の画像ファイルのボーダ色

DEFAULT_GRAPH_FRAME_COLOR

public static Color DEFAULT_GRAPH_FRAME_COLOR
標準のグラフ枠の線色

コンストラクタの詳細

RadarChartDrawer

public RadarChartDrawer(int min,
                        int max,
                        int count)
ｙ軸の目盛値をint表現でレーダーチャートを作成します。

パラメータ:
min - ｙ軸の最小値
max - ｙ軸の最大値
count - ｙ軸の目盛間隔
例外:
IllegalArgumentException - max <= min または count <= 0

RadarChartDrawer

public RadarChartDrawer(double min,
                        double max,
                        double count)
ｙ軸の目盛値をdouble表現でレーダーチャートを作成します。

パラメータ:
min - ｙ軸の最小値
max - ｙ軸の最大値
count - ｙ軸の目盛間隔
例外:
IllegalArgumentException - max <= min または count <= 0
メソッドの詳細

getMax

public double getMax()
ｙ軸の最大値を返します。

戻り値:
double ｙ軸の最大値

getMin

public double getMin()
ｙ軸の最小値を返します。

戻り値:
double ｙ軸の最小値

getScaleCount

public double getScaleCount()
ｙ軸の目盛間隔を返します。

戻り値:
double ｙ軸の目盛間隔

setCaption

public void setCaption(String[] caption)
ｘ軸のキャプションを設定します。

パラメータ:
caption - キャプション

getCaption

public String[] getCaption()
ｘ軸のキャプションを返します。

戻り値:
キャプション

addData

public void addData(RadarChartObject obj)
描画オブジェクトに新しいデータを追加します。

パラメータ:
obj - データ

setImageBackgroundColor

public void setImageBackgroundColor(Color color)
画像ファイルの背景色を設定します。

パラメータ:
color -

setImgaeBackgroundColor

public void setImgaeBackgroundColor(Color color)
推奨されていません。

画像ファイルの背景色を設定します。

パラメータ:
color -

getImageBackgroundColor

public Color getImageBackgroundColor()
画像ファイルの背景色を返します。

戻り値:
color

getImgaeBackgroundColor

public Color getImgaeBackgroundColor()
推奨されていません。

画像ファイルの背景色を返します。

戻り値:
color

setImageBorderColor

public void setImageBorderColor(Color color)
画像ファイルのボーダ色を設定します。

パラメータ:
color -

setImgaeBorderColor

public void setImgaeBorderColor(Color color)
推奨されていません。

画像ファイルのボーダ色を設定します。

パラメータ:
color -

getImageBorderColor

public Color getImageBorderColor()
画像ファイルのボーダ色を返します。

戻り値:
color

getImgaeBorderColor

public Color getImgaeBorderColor()
推奨されていません。

画像ファイルのボーダ色を返します。

戻り値:
color

getGraphFrameColor

public Color getGraphFrameColor()
グラフ枠の線色を返します。

戻り値:
Color グラフ枠の線色

setGraphFrameColor

public void setGraphFrameColor(Color color)
グラフ枠の線色を設定します。

パラメータ:
color - グラフ枠の線色

getCaptionColor

public Color getCaptionColor()
キャプションの文字色を返します。

戻り値:
キャプションの文字色

setCaptionColor

public void setCaptionColor(Color color)
キャプションの文字色を設定します。

パラメータ:
color - キャプションの文字色

addData

public void addData(int index,
                    RadarChartObject obj)
指定された位置に、指定された描画オブジェクトを追加します。 現在その位置にあるデータはindex値に１追加されます。

パラメータ:
obj - データ
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index > size())

isDouble

public boolean isDouble()
ｙ軸の目盛値がdouble表現かどうかを判定します。

戻り値:
doubleで表現する場合はtrue

getData

public RadarChartObject getData(int index)
リスト内の指定された位置にあるデータを返します。

パラメータ:
index - インデックス
戻り値:
jp.co.intra_mart.foundation.graph.RadarChartObject
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

remove

public void remove(int index)
指定された位置のデータを削除します。 削除後は後続の要素を左側に移動します。

パラメータ:
index - 削除されるデータ値のインデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

size

public int size()
データの数を返します。

戻り値:
int 値の数

clear

public void clear()
すべてのデータを削除します。

setMargin

public void setMargin(int top,
                      int right,
                      int bottom,
                      int left)
グラフ領域のマージンを設定します。

パラメータ:
top - 上部のマージン
right - 右側のマ－ジン
bottom - 下部のマージン
left - 左側のマージン

setCaptionMargin

public void setCaptionMargin(int margin)
キャプション表示位置のマージンを設定します。

パラメータ:
margin - キャプション表示位置のマージン

getCaptionMargin

public int getCaptionMargin()
キャプション表示位置のマージンを返します。

戻り値:
int キャプション表示位置のマージン

createImage

protected void createImage(Graphics g)
レーダーチャートを描画します。

定義:
クラス AbstractDrawer 内の createImage
パラメータ:
g - グラフィックコンテキスト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RadarChartObject (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス RadarChartObject

java.lang.Object
    拡張 jp.co.intra_mart.foundation.graph.RadarChartObject
すべての実装インタフェース:
Serializable
public class RadarChartObject
extends Object
implements Serializable

RadarChartDrawerクラスのデータを保存するオブジェクトです。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

コンストラクタの概要
RadarChartObject()
デフォルトのデータオブジェクトを作成します。
RadarChartObject(boolean fill)
塗りつぶしの可否を指定して、データオブジェクトを作成します。
RadarChartObject(Color color)
グラフ線の色を指定して、データオブジェクトを作成します。
RadarChartObject(Color color, boolean fill)
グラフの色と塗りつぶしの可否を指定して、データオブジェクトを作成します。
メソッドの概要
void | addData(double number) 値を追加します。
void | addData(int number) 値を追加します。
void | clear() すべての値を削除します。
Color | getColor() グラフ線の色を返します。
double | getData(int index) 指定された位置にある値を返します。
boolean | getFill() 描画されるグラフの塗りつぶし可否を返します。
void | remove(int index) 指定された位置の値を削除します。
void | setColor(Color color) グラフ線の色を設定します。
void | setFill(boolean fill) 描画されるグラフの塗りつぶし可否を設定します。
int | size() 値の数を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RadarChartObject

public RadarChartObject()
デフォルトのデータオブジェクトを作成します。

RadarChartObject

public RadarChartObject(Color color)
グラフ線の色を指定して、データオブジェクトを作成します。

パラメータ:
color - 描画されるグラフの色

RadarChartObject

public RadarChartObject(boolean fill)
塗りつぶしの可否を指定して、データオブジェクトを作成します。

パラメータ:
fill - 描画されるグラフの塗りつぶし可否（true：塗りつぶす／false：塗りつぶさない）

RadarChartObject

public RadarChartObject(Color color,
                        boolean fill)
グラフの色と塗りつぶしの可否を指定して、データオブジェクトを作成します。

パラメータ:
color - 描画される線の色
fill - 描画されるグラフの塗りつぶし可否（true：塗りつぶす／false：塗りつぶさない）
メソッドの詳細

addData

public void addData(double number)
値を追加します。

パラメータ:
number - 値

addData

public void addData(int number)
値を追加します。 intを与えますが、値はdoubleで扱われます。

パラメータ:
number - 値

getData

public double getData(int index)
指定された位置にある値を返します。

パラメータ:
index - 返される値のインデックス
戻り値:
double 値
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

remove

public void remove(int index)
指定された位置の値を削除します。 削除後は後続の要素を左側に移動します。

パラメータ:
index - 削除されるデータ値のインデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

size

public int size()
値の数を返します。

戻り値:
int 値の数

clear

public void clear()
すべての値を削除します。

getColor

public Color getColor()
グラフ線の色を返します。

戻り値:
color 描画されるグラフ線の色

getFill

public boolean getFill()
描画されるグラフの塗りつぶし可否を返します。

戻り値:
描画されるグラフの塗りつぶし可否（true：塗りつぶす／false：塗りつぶさない）

setColor

public void setColor(Color color)
グラフ線の色を設定します。

パラメータ:
color - 描画されるグラフ線の色

setFill

public void setFill(boolean fill)
描画されるグラフの塗りつぶし可否を設定します。

パラメータ:
fill - 描画されるグラフの塗りつぶし可否（true：塗りつぶす／false：塗りつぶさない）
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の使用

jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ImAjaxUtil (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.http.ajax
クラス ImAjaxUtil

java.lang.Object
    拡張 jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil
public class ImAjaxUtil
extends Object

CSJSライブラリ「ImAjax」で通信を行う際に有用なサーバサイドのユーティリティクラスです。

CSJSライブラリ「ImAjax」で通信を行う際、 レスポンスヘッダにエラーコードとエラーメッセージを設定することが可能です。
レスポンスヘッダのフォーマットは以下の通りです。

ヘッダー名 | ヘッダー値
x-jp-co-intra-mart-ajax-error-code | エラーコード
x-jp-co-intra-mart-ajax-error-message | エラーコードに紐づくエラーメッセージ

エラーメッセージは、JavaScript(＝EcmaScript) のencodeURIComponent()を利用して、 自動的にエンコードされます。
（エンコード処理は、ResponseCharacterEncodingFilter 内で実行されます）

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
static String | IM_AJAX_USER_AGENT_FIREFOX 「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Firefox
static String | IM_AJAX_USER_AGENT_IE 「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Internet Explorer
static String | IM_AJAX_USER_AGENT_NETSCAPE 「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Netscape
static String | IM_AJAX_USER_AGENT_OPERA 「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Opera
static String | IM_AJAX_USER_AGENT_SAFARI 「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Safari
static String | REQUEST_HEADER_NAME_IM_AJAX_REQUEST ImAjaxからの通信だということを判定可能にするためのリクエスト・ヘッダ名。
static String | REQUEST_HEADER_NAME_IM_AJAX_USER_AGENT ブラウザの種類を判定可能にするためのリクエスト・ヘッダ名。
static String | RESPONSE_HEADER_NAME_IM_AJAX_ERROR_CODE ImAjaxへエラーコードを通知するためのレスポンス・ヘッダ名。
static String | RESPONSE_HEADER_NAME_IM_AJAX_ERROR_MESSAGE ImAjaxへエラーメッセージを通知するためのレスポンス・ヘッダ名。
コンストラクタの概要
ImAjaxUtil()
メソッドの概要
static void | setErrorResponseHeaders(HttpServletResponse response, String errorCode) レスポンスヘッダにエラーコードとエラーメッセージを設定します。
static void | setErrorResponseHeaders(HttpServletResponse response, String errorCode, String arg) レスポンスヘッダにエラーコードとエラーメッセージを設定します。
static void | setErrorResponseHeaders(HttpServletResponse response, String errorCode, String[] args) レスポンスヘッダにエラーコードとエラーメッセージを設定します。
static void | setErrorResponseHeaders(HttpServletResponse response, String errorCode, String arg1, String arg2) レスポンスヘッダにエラーコードとエラーメッセージを設定します。
static void | setErrorResponseHeaders(HttpServletResponse response, String errorCode, String arg1, String arg2, String arg3) レスポンスヘッダにエラーコードとエラーメッセージを設定します。
static void | setErrorResponseHeaders(String errorCode) レスポンスヘッダにエラーコードとエラーメッセージを設定します。
static void | setErrorResponseHeaders(String errorCode, String arg) レスポンスヘッダにエラーコードとエラーメッセージを設定します。
static void | setErrorResponseHeaders(String errorCode, String[] args) レスポンスヘッダにエラーコードとエラーメッセージを設定します。
static void | setErrorResponseHeaders(String errorCode, String arg1, String arg2) レスポンスヘッダにエラーコードとエラーメッセージを設定します。
static void | setErrorResponseHeaders(String errorCode, String arg1, String arg2, String arg3) レスポンスヘッダにエラーコードとエラーメッセージを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

REQUEST_HEADER_NAME_IM_AJAX_REQUEST

public static final String REQUEST_HEADER_NAME_IM_AJAX_REQUEST
ImAjaxからの通信だということを判定可能にするためのリクエスト・ヘッダ名。

関連項目:
定数フィールド値

REQUEST_HEADER_NAME_IM_AJAX_USER_AGENT

public static final String REQUEST_HEADER_NAME_IM_AJAX_USER_AGENT
ブラウザの種類を判定可能にするためのリクエスト・ヘッダ名。

関連項目:
定数フィールド値

IM_AJAX_USER_AGENT_IE

public static final String IM_AJAX_USER_AGENT_IE
「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Internet Explorer

関連項目:
定数フィールド値

IM_AJAX_USER_AGENT_FIREFOX

public static final String IM_AJAX_USER_AGENT_FIREFOX
「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Firefox

関連項目:
定数フィールド値

IM_AJAX_USER_AGENT_NETSCAPE

public static final String IM_AJAX_USER_AGENT_NETSCAPE
「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Netscape

関連項目:
定数フィールド値

IM_AJAX_USER_AGENT_OPERA

public static final String IM_AJAX_USER_AGENT_OPERA
「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Opera

関連項目:
定数フィールド値

IM_AJAX_USER_AGENT_SAFARI

public static final String IM_AJAX_USER_AGENT_SAFARI
「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Safari

関連項目:
定数フィールド値

RESPONSE_HEADER_NAME_IM_AJAX_ERROR_CODE

public static final String RESPONSE_HEADER_NAME_IM_AJAX_ERROR_CODE
ImAjaxへエラーコードを通知するためのレスポンス・ヘッダ名。

関連項目:
定数フィールド値

RESPONSE_HEADER_NAME_IM_AJAX_ERROR_MESSAGE

public static final String RESPONSE_HEADER_NAME_IM_AJAX_ERROR_MESSAGE
ImAjaxへエラーメッセージを通知するためのレスポンス・ヘッダ名。

関連項目:
定数フィールド値
コンストラクタの詳細

ImAjaxUtil

public ImAjaxUtil()
メソッドの詳細

setErrorResponseHeaders

public static void setErrorResponseHeaders(String errorCode)
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
現在ログインしているユーザのロケールでメッセージを設定します。
ヘッダがすでに設定されていた場合は、新しい値が以前の値を上書きします。

レスポンスヘッダのフォーマットは、こちらを参照してください。

パラメータ:
errorCode - エラーコード
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。

setErrorResponseHeaders

public static void setErrorResponseHeaders(String errorCode,
                                           String arg)
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
現在ログインしているユーザのロケールでメッセージを設定します。
ヘッダがすでに設定されていた場合は、新しい値が以前の値を上書きします。

レスポンスヘッダのフォーマットは、こちらを参照してください。

パラメータ:
errorCode - エラーコード
arg - 置換文字列

setErrorResponseHeaders

public static void setErrorResponseHeaders(String errorCode,
                                           String arg1,
                                           String arg2)
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
現在ログインしているユーザのロケールでメッセージを設定します。
ヘッダがすでに設定されていた場合は、新しい値が以前の値を上書きします。

レスポンスヘッダのフォーマットは、こちらを参照してください。

パラメータ:
errorCode - エラーコード
arg1 - 置換文字列１
arg2 - 置換文字列２

setErrorResponseHeaders

public static void setErrorResponseHeaders(String errorCode,
                                           String arg1,
                                           String arg2,
                                           String arg3)
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
現在ログインしているユーザのロケールでメッセージを設定します。
ヘッダがすでに設定されていた場合は、新しい値が以前の値を上書きします。

レスポンスヘッダのフォーマットは、こちらを参照してください。

パラメータ:
errorCode - エラーコード
arg1 - 置換文字列１
arg2 - 置換文字列２
arg3 - 置換文字列３

setErrorResponseHeaders

public static void setErrorResponseHeaders(String errorCode,
                                           String[] args)
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
現在ログインしているユーザのロケールでメッセージを設定します。
ヘッダがすでに設定されていた場合は、新しい値が以前の値を上書きします。

レスポンスヘッダのフォーマットは、こちらを参照してください。

パラメータ:
errorCode - エラーコード
args - 置換文字列の配列

setErrorResponseHeaders

public static void setErrorResponseHeaders(HttpServletResponse response,
                                           String errorCode)
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
現在ログインしているユーザのロケールでメッセージを設定します。
ヘッダがすでに設定されていた場合は、新しい値が以前の値を上書きします。

レスポンスヘッダのフォーマットは、こちらを参照してください。

パラメータ:
response - レスポンス
errorCode - エラーコード

setErrorResponseHeaders

public static void setErrorResponseHeaders(HttpServletResponse response,
                                           String errorCode,
                                           String arg)
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
現在ログインしているユーザのロケールでメッセージを設定します。
ヘッダがすでに設定されていた場合は、新しい値が以前の値を上書きします。

レスポンスヘッダのフォーマットは、こちらを参照してください。

パラメータ:
response - レスポンス
errorCode - エラーコード
arg - 置換文字列

setErrorResponseHeaders

public static void setErrorResponseHeaders(HttpServletResponse response,
                                           String errorCode,
                                           String arg1,
                                           String arg2)
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
現在ログインしているユーザのロケールでメッセージを設定します。
ヘッダがすでに設定されていた場合は、新しい値が以前の値を上書きします。

レスポンスヘッダのフォーマットは、こちらを参照してください。

パラメータ:
response - レスポンス
errorCode - エラーコード
arg1 - 置換文字列１
arg2 - 置換文字列２

setErrorResponseHeaders

public static void setErrorResponseHeaders(HttpServletResponse response,
                                           String errorCode,
                                           String arg1,
                                           String arg2,
                                           String arg3)
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
現在ログインしているユーザのロケールでメッセージを設定します。
ヘッダがすでに設定されていた場合は、新しい値が以前の値を上書きします。

レスポンスヘッダのフォーマットは、こちらを参照してください。

パラメータ:
response - レスポンス
errorCode - エラーコード
arg1 - 置換文字列１
arg2 - 置換文字列２
arg3 - 置換文字列３

setErrorResponseHeaders

public static void setErrorResponseHeaders(HttpServletResponse response,
                                           String errorCode,
                                           String[] args)
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
現在ログインしているユーザのロケールでメッセージを設定します。
ヘッダがすでに設定されていた場合は、新しい値が以前の値を上書きします。

レスポンスヘッダのフォーマットは、こちらを参照してください。

パラメータ:
response - レスポンス
errorCode - エラーコード
args - 置換文字列の配列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.http.ajax (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.http.ajax
クラス
ImAjaxUtil


jp.co.intra_mart.foundation.http.ajax (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.http.ajax

クラスの概要
ImAjaxUtil CSJSライブラリ「ImAjax」で通信を行う際に有用なサーバサイドのユーティリティクラスです。


jp.co.intra_mart.foundation.http.ajax クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.http.ajax の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil


パッケージ jp.co.intra_mart.foundation.http.ajax の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.http.ajax の使用

jp.co.intra_mart.foundation.http.ajax はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.http.CGIEnvironment の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.http.CGIEnvironment の使用

jp.co.intra_mart.foundation.http.CGIEnvironment はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.http.FileSender の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.http.FileSender の使用

jp.co.intra_mart.foundation.http.FileSender はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.http.MultipartFormData.Entity の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.http.MultipartFormData.Entity の使用

MultipartFormData.Entity を使用しているパッケージ
jp.co.intra_mart.foundation.http | ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.foundation.http での MultipartFormData.Entity の使用

MultipartFormData.Entity を返す jp.co.intra_mart.foundation.http のメソッド
MultipartFormData.Entity | MultipartFormData.getEntity(int index) 推奨されていません。 指定のインデックスに該当するエンティティを取得します。
MultipartFormData.Entity | MultipartFormData.getEntity(String name) 推奨されていません。 指定の名前を持つエンティティを取得します。
MultipartFormData.Entity[] | MultipartFormData.getEntities(String name) 推奨されていません。 指定の名前を持つエンティティをすべて取得します。

jp.co.intra_mart.framework.base.service での MultipartFormData.Entity の使用

MultipartFormData.Entity を返す jp.co.intra_mart.framework.base.service のメソッド
MultipartFormData.Entity | Transition.getEntity(String name) リクエストから指定された名前に該当するエンティティを取得します。
MultipartFormData.Entity | ServiceControllerAdapter.getEntity(String name) リクエストから指定された名前に該当するエンティティを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.http.MultipartFormData の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.http.MultipartFormData の使用

jp.co.intra_mart.foundation.http.MultipartFormData はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.http.SessionQuery の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.http.SessionQuery の使用

jp.co.intra_mart.foundation.http.SessionQuery はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CGIEnvironment (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.http
クラス CGIEnvironment

java.lang.Object
    拡張 java.util.AbstractMap
        拡張 java.util.HashMap
            拡張 jp.co.intra_mart.foundation.http.CGIEnvironment
すべての実装インタフェース:
Cloneable, Map, Serializable
public class CGIEnvironment
extends HashMap

このクラスは、サーブレットクラス内で CGI 環境変数を扱えるように 各パラメータを CGI 環境変数で定義されているキーワードにマップします。
ユーザー・プログラムでは、このクラスを利用する事でサーブレット環境で CGI 環境変数インターフェースを実装する事が出来ます。

関連項目:
HttpServletRequest, HashMap, 直列化された形式

コンストラクタの概要
CGIEnvironment(HttpServletRequest httpRequest)
HTTP リクエストヘッダおよび Web サーバ情報から CGI 環境変数情報を構築します。
メソッドの概要
 String getenv(String key)
値の取得。
クラス java.util.HashMap から継承したメソッド
clear, clone, containsKey, containsValue, entrySet, get, isEmpty, keySet, put, putAll, remove, size, values
クラス java.util.AbstractMap から継承したメソッド
equals, hashCode, toString
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait
インタフェース java.util.Map から継承したメソッド
equals, hashCode

コンストラクタの詳細

CGIEnvironment

public CGIEnvironment(HttpServletRequest httpRequest)
HTTP リクエストヘッダおよび Web サーバ情報から CGI 環境変数情報を構築します。

パラメータ:
httpRequest - サーブレット実行時に受け取るリクエストオブジェクト
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getenv

public String getenv(String key)
値の取得。

キーにマップされている値を返します。
引数 key には、ＣＧＩ環境変数の変数名を指定して下さい。 引数に指定されたＣＧＩ環境変数にマップされている値がない場合 null を 返します。

パラメータ:
key - 値にマップされているキー
戻り値:
キーにマップされている値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


FileSender (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.http
クラス FileSender

java.lang.Object
    拡張 jp.co.intra_mart.foundation.http.FileSender
public class FileSender
extends Object

このクラスは、HTTP レスポンスに対して指定のバイトをストリームとして 出力します。

関連項目:
HttpServletResponse

コンストラクタの概要
FileSender(HttpServletResponse httpResponse)
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSender(HttpServletResponse httpResponse, MultipurposeInternetMailExtensions mimeType)
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSender(HttpServletResponse httpResponse, MultipurposeInternetMailExtensions mimeType, String filename)
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSender(HttpServletResponse httpResponse, String filename)
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
メソッドの概要
void | write(byte b) バイトの出力。
void | write(byte[] src) バイトの出力。
void | write(byte[] src, int off, int len) バイトの出力。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FileSender

public FileSender(HttpServletResponse httpResponse)
           throws IOException
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。

このコンストラクタでは、HTTP レスポンスヘッダの Content-Type および Content-Disposition の設定を自動的に行います。 その他のヘッダへの設定は httpResponse に対して 直接設定をしてください。
HTTP レスポンスヘッダの Content-Type には、MIME タイプとして application/octet-stream を指定します。
HTTP レスポンスヘッダの Content-Disposition は、以下のように定義します。
Content-Disposition: attachment

例外:
IOException - 入出力エラー

FileSender

public FileSender(HttpServletResponse httpResponse,
                  MultipurposeInternetMailExtensions mimeType)
           throws IOException
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。

このコンストラクタでは、HTTP レスポンスヘッダの Content-Type および Content-Disposition の設定を自動的に行います。 その他のヘッダへの設定は httpResponse に対して 直接設定をしてください。
HTTP レスポンスヘッダの Content-Type には、MIME タイプとして 引数 mimeType の表す MIME タイプを設定します。

パラメータ:
mimeType - MIME タイプ
例外:
IOException - 入出力エラー

FileSender

public FileSender(HttpServletResponse httpResponse,
                  String filename)
           throws IOException
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。

このコンストラクタでは、HTTP レスポンスヘッダの Content-Type および Content-Disposition の設定を自動的に行います。 その他のヘッダへの設定は httpResponse に対して 直接設定をしてください。
HTTP レスポンスヘッダの Content-Type には、MIME タイプとして 指定のファイル名にマップされている MIME を表す文字列か、または、 指定のファイル名にマップされている MIME タイプを解決できなかった 場合には application/octet-stream を指定します。
HTTP レスポンスヘッダの Content-Disposition は、以下のように定義します。
Content-Disposition: attachment; filename=ファイル名
“ファイル名”の部分には、引数 filename が設定されます。

パラメータ:
filename - ファイル名
例外:
IOException - 入出力エラー

FileSender

public FileSender(HttpServletResponse httpResponse,
                  MultipurposeInternetMailExtensions mimeType,
                  String filename)
           throws IOException
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。

このコンストラクタでは、HTTP レスポンスヘッダの Content-Type および Content-Disposition の設定を自動的に行います。 その他のヘッダへの設定は httpResponse に対して 直接設定をしてください。
HTTP レスポンスヘッダの Content-Type には、MIME タイプとして 引数 mimeType の表す MIME タイプを設定します。
HTTP レスポンスヘッダの Content-Disposition は、以下のように定義します。
Content-Disposition: attachment; filename=ファイル名
“ファイル名”の部分には、引数 filename が設定されます。

パラメータ:
mimeType - MIME タイプ
filename - ファイル名
例外:
IOException - 入出力エラー
メソッドの詳細

write

public void write(byte b)
           throws IOException
バイトの出力。

指定のバイトを HTTP レスポンスの出力ストリームに書き出します。

パラメータ:
b - ストリームに書き出すバイト
例外:
IOException - 入出力エラー

write

public void write(byte[] src)
           throws IOException
バイトの出力。

指定のバイトを HTTP レスポンスの出力ストリームに書き出します。

パラメータ:
src - ストリームに書き出すバイト列
例外:
IOException - 入出力エラー

write

public void write(byte[] src,
                  int off,
                  int len)
           throws IOException
バイトの出力。

オフセット off から始まる指定のバイト配列から HTTP レスポンスの 出力ストリームに len バイトを書き込みます。

パラメータ:
src - ストリームに書き出すバイト列
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MultipartFormData.Entity (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.http
インタフェース MultipartFormData.Entity

含まれているインタフェース:
MultipartFormData
推奨されていません。 jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity インタフェースを使用してください。

public static interface MultipartFormData.Entity

フォームデータのエンティティです。

フォームから送信された情報を解析した結果の各エンティティは、 ヘッダ情報とデータで構成されます。

メソッドの概要
boolean | containsHeader(String name) 推奨されていません。 指定された文字列がヘッダの名称かどうかを判定します。
byte[] | getBytes() 推奨されていません。 データ部をバイト配列として取得します。
String | getContent() 推奨されていません。 データ部を文字列表現として取得します。
String | getContent(String enc) 推奨されていません。 データ部を指定された文字コードで変換した結果を文字列表現として 取得します。
int | getContentLength() 推奨されていません。 データ部のバイト長を取得します。
String | getFileName() 推奨されていません。 アップロードされたファイルのファイル名を取得します。
String | getHeader(String name) 推奨されていません。 ヘッダの取得。
String[] | getHeaderNames() 推奨されていません。 ヘッダ名称一覧の取得。
InputStream | getInputStream() 推奨されていません。 データ部を入力ストリームとして取得します。
String | getName() 推奨されていません。 フォームのコントロール名称の取得。
Reader | getReader() 推奨されていません。 getReader(String) に置き換えられました。
Reader | getReader(String encoding) 推奨されていません。 データ部を Reader として取得します。

メソッドの詳細

getName

public String getName()
推奨されていません。
フォームのコントロール名称の取得。

フォームから送信された情報のうち、このエンティティが表す情報の もととなったフォーム中に定義されたコントロールの名称を返します。

戻り値:
コントロール名称

getFileName

public String getFileName()
推奨されていません。
アップロードされたファイルのファイル名を取得します。

ファイルアップロードをしたリクエストではない場合は、null を返します。
Content-Disposition: form-data; name="ctrl_name"; filename="file_path"
ヘッダは、上記のような形式で受け取れる
ctrl_name: <INPUT type="file"> の name 属性
file_path: クライアントでのファイル名
ヘッダ情報は他にもあるが、上記の行のみを対象に解析を行う

戻り値:
String ファイル名

getHeaderNames

public String[] getHeaderNames()
推奨されていません。
ヘッダ名称一覧の取得。

このエンティティのもつヘッダ情報の名称一覧を返します。

戻り値:
ヘッダ名称の取得

getHeader

public String getHeader(String name)
推奨されていません。
ヘッダの取得。

返却値は、文字エンコーディングの変換が行われていない状態の文字列を返却します。 具体的には、javax.servlet.ServletRequest#getInputStream()を利用して リクエストの内容をバイト配列で取得し、それを「ISO-8859-1」で文字列化した内容が返却されます。

別のエンコーディングに変換する場合、以下のようなコードで変換する必要があります。

 byte[] rawData = entity.getHeader(headerName).getBytes("ISO-8859-1");
 String encodedValue = new String(rawData, request.getCharacterEncoding());

パラメータ:
name - ヘッダ名称
戻り値:
ヘッダ名称にマップされている値

containsHeader

public boolean containsHeader(String name)
推奨されていません。
指定された文字列がヘッダの名称かどうかを判定します。

パラメータ:
name - ヘッダ名称
戻り値:
ヘッダ名称が値にマップされている場合 true

getContentLength

public int getContentLength()
推奨されていません。
データ部のバイト長を取得します。

戻り値:
データのサイズ

getContent

public String getContent()
推奨されていません。
データ部を文字列表現として取得します。

入力されたバイトデータから文字列への変換には、Application Runtimeが稼動しているJavaVMの デフォルト文字エンコーディングを使います。

戻り値:
データ

getContent

public String getContent(String enc)
                  throws UnsupportedEncodingException
推奨されていません。
データ部を指定された文字コードで変換した結果を文字列表現として 取得します。

指定のエンコード名がサポートされていない場合 UnsupportedEncodingException がスローされます。

パラメータ:
enc - エンコード名
戻り値:
データ
例外:
UnsupportedEncodingException
関連項目:
UnsupportedEncodingException

getBytes

public byte[] getBytes()
推奨されていません。
データ部をバイト配列として取得します。

戻り値:
データ

getReader

public Reader getReader()
推奨されていません。 getReader(String) に置き換えられました。

データ部を Reader として取得します。

Application Runtimeが稼動しているJavaVMのデフォルト文字エンコーディングを使うReaderを返します。

戻り値:
データ

getReader

public Reader getReader(String encoding)
推奨されていません。
データ部を Reader として取得します。

戻り値:
データ
導入されたバージョン:
6.1.12

getInputStream

public InputStream getInputStream()
推奨されていません。
データ部を入力ストリームとして取得します。

戻り値:
データ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MultipartFormData (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.http
クラス MultipartFormData

java.lang.Object
    拡張 java.util.AbstractCollection
        拡張 java.util.AbstractList
            拡張 java.util.ArrayList
                拡張 jp.co.intra_mart.foundation.http.MultipartFormData
すべての実装インタフェース:
Cloneable, Collection, List, RandomAccess, Serializable
推奨されていません。 jp.co.intra_mart.common.aid.javaee.http.MultipartFormData クラスを使用してください。

public class MultipartFormData
extends ArrayList

フォームから enctype が multipart/form-data で送信されてきた情報を 解析するオブジェクトです。

このオブジェクトは、ブラウザから multipart/form-data 形式でリクエストされた データを解析し、boundary で区切られた各情報(エンティティ)をとしてリストに 保管します。

このクラスを利用する事により、ブラウザからサーバに対するファイルの アップロードなどが簡単に実装する事ができます。

留意点

intra-mart6.1.11から、アップロードされたファイルが指定した閾値を超えた場合、 メモリ上ではなく一時ファイルに書き出し、OutOfMemoryErrorの発生を抑えることが できるようになりました。内部では Apache Commons FileUpload を利用しています。

一時ファイルは、ガベージコレクタがMultiPartFormData.Entityを解放するタイミングで 削除されます。従いまして、MultiPartFormData.Entityが解放される前にintra-martが 停止すると一時ファイルは削除されません。

一時ファイルの格納先は、デフォルトではJavaのテンポラリフォルダ(java.io.tmpdir)です。 ファイル名は upload_ランダムな文字列.tmp です。

なお、アップロードされたファイルを常にメモリ上で扱う実装と一時ファイルに書き出す実装の切り替え、 一時ファイルの格納先、一時ファイルに書き出すかどうかの閾値を設定ファイルで指定することができます。 設定ファイルは、 %ApplicationRuntime%/doc/imart/WEB-INF/classes/jp/co/intra_mart/common/aid/javaee/http/MultipartFormData.properties です。

設定ファイルの内容はMultipartFormDataResourceBundleを参照してください。

関連項目:
直列化された形式

入れ子クラスの概要
static interface MultipartFormData.Entity
推奨されていません。 jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity インタフェースを使用してください。
フィールドの概要
クラス java.util.AbstractList から継承したフィールド
modCount
コンストラクタの概要
MultipartFormData(ServletRequest req)
推奨されていません。 リクエストされた情報を解析して、新しいオブジェクトを構築します。
メソッドの概要
void | add(int index, Object element) 推奨されていません。 リストの指定された位置に、指定された要素を挿入します。
boolean | add(Object o) 推奨されていません。 リストの最後に、指定された要素を追加します。
boolean | addAll(Collection c) 推奨されていません。 リストの末尾に、指定された Collection のすべての要素を追加します。
boolean | addAll(int index, Collection c) 推奨されていません。 リスト内の指定された位置から、指定された Collection のすべての要素を挿入します。
void | clear() 推奨されていません。 リストからすべての要素を削除します。
boolean | contains(Object elem) 推奨されていません。 リストに指定の要素がある場合に true を返します。
boolean | containsAll(Collection c) 推奨されていません。 このコレクション内に、指定されたコレクションのすべての要素がある場合に true を返します。
void | ensureCapacity(int minCapacity) 推奨されていません。 必要に応じて、この ArrayList のインスタンスのサイズを拡大し、少なくとも最小サイズ引数で指定された数の要素を格納できるようにします。
boolean | equals(Object o) 推奨されていません。 指定されたオブジェクトとリストが等しいかどうかを比較します。
Object | get(int index) 推奨されていません。 リスト内の指定された位置にある要素を返します。
MultipartFormData.Entity[] | getEntities(String name) 推奨されていません。 指定の名前を持つエンティティをすべて取得します。
MultipartFormData.Entity | getEntity(int index) 推奨されていません。 指定のインデックスに該当するエンティティを取得します。
MultipartFormData.Entity | getEntity(String name) 推奨されていません。 指定の名前を持つエンティティを取得します。
int | hashCode() 推奨されていません。 このリストのハッシュコード値を返します。
int | indexOf(Object elem) 推奨されていません。 equals メソッドを使って等しいかどうかを判定しながら、指定された引数と同じ内容の要素を先頭から検索します。
boolean | isEmpty() 推奨されていません。 リストに要素がないかどうかを判定します。
Iterator | iterator() 推奨されていません。 このリスト内の要素を適切な順序で繰り返し処理する反復子を返します。
int | lastIndexOf(Object elem) 推奨されていません。 指定されたオブジェクトがリスト内で最後に現れるインデックスを返します。
ListIterator | listIterator() 推奨されていません。 このリスト内の要素を適切な順序で繰り返し処理する反復子を返します。
ListIterator | listIterator(int index) 推奨されていません。 リスト内の要素を適切な順序で繰り返し処理する、リスト内の指定された位置から開始する反復子を返します。
Object | remove(int index) 推奨されていません。 リスト内の指定された位置から要素を削除します。
boolean | remove(Object o) 推奨されていません。 指定された要素のインスタンスがこのコレクションにあれば、そのインスタンスをコレクションから 1 つ削除します。
boolean | removeAll(Collection c) 推奨されていません。 このコレクションから、指定されたコレクションに含まれる要素をすべて削除します。
boolean | retainAll(Collection c) 推奨されていません。 このコレクションにおいて、指定されたコレクションに格納されている要素だけを保持します。
Object | set(int index, Object element) 推奨されていません。 リストの指定された位置にある要素を、指定された要素で置き換えます。
int | size() 推奨されていません。 リスト内にある要素の数を返します。
List | subList(int fromIndex, int toIndex) 推奨されていません。 このリストの、fromIndex (これを含む) から toIndex (これを含まない) の範囲の部分のビューを返します。
Object[] | toArray() 推奨されていません。 リスト内のすべての要素が正しい順序で格納されている配列を返します。
Object[] | toArray(Object[] a) 推奨されていません。 リスト内のすべての要素が正しい順序で格納されている配列を返します。
void | trimToSize() 推奨されていません。 この ArrayList のインスタンスのサイズをリストの現在のサイズに縮小します。
クラス java.util.ArrayList から継承したメソッド
clone, removeRange
クラス java.util.AbstractCollection から継承したメソッド
toString
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MultipartFormData

public MultipartFormData(ServletRequest req)
                  throws IOException,
                         IllegalArgumentException
推奨されていません。
リクエストされた情報を解析して、新しいオブジェクトを構築します。
multipart/form-data 形式のリクエストを解析します。

req が multipart/form-data で受信したリクエストではない場合、 IllegalArgumentException をスローします。

パラメータ:
req - サーブレットエンジンから渡されるリクエスト情報オブジェクト
例外:
IOException - リクエストデータ解析時の入出力エラー
IllegalArgumentException - 引数が不正の場合
メソッドの詳細

getEntity

public MultipartFormData.Entity getEntity(int index)
推奨されていません。
指定のインデックスに該当するエンティティを取得します。

インデックスが範囲外の場合(インデックスが負または size() よりも大きい) IndexOutOfBoundsException をスローします。

パラメータ:
index - 返すエンティティのインデックス
戻り値:
リスト内の指定された位置にあるエンティティ

getEntity

public MultipartFormData.Entity getEntity(String name)
推奨されていません。
指定の名前を持つエンティティを取得します。

エンティティの名前とは、フォームのコントロール名称のことです。 指定の名前を持つエンティティが複数存在する場合、その中のいずれか一つが 返されます。 該当するエンティティが存在しない場合 null を返します。

戻り値:
指定の名前を持つエンティティ
関連項目:
MultipartFormData.Entity.getName()

getEntities

public MultipartFormData.Entity[] getEntities(String name)
推奨されていません。
指定の名前を持つエンティティをすべて取得します。

エンティティの名前とは、フォームのコントロール名称のことです。 該当するエンティティが存在しない場合、空の配列を返します。

戻り値:
指定の名前を持つエンティティ
関連項目:
MultipartFormData.Entity.getName()

add

public void add(int index,
                Object element)
推奨されていません。
リストの指定された位置に、指定された要素を挿入します。

add

public boolean add(Object o)
推奨されていません。
リストの最後に、指定された要素を追加します。

addAll

public boolean addAll(Collection c)
推奨されていません。
リストの末尾に、指定された Collection のすべての要素を追加します。

addAll

public boolean addAll(int index,
                      Collection c)
推奨されていません。
リスト内の指定された位置から、指定された Collection のすべての要素を挿入します。

clear

public void clear()
推奨されていません。
リストからすべての要素を削除します。

contains

public boolean contains(Object elem)
推奨されていません。
リストに指定の要素がある場合に true を返します。

containsAll

public boolean containsAll(Collection c)
推奨されていません。
このコレクション内に、指定されたコレクションのすべての要素がある場合に true を返します。

ensureCapacity

public void ensureCapacity(int minCapacity)
推奨されていません。
必要に応じて、この ArrayList のインスタンスのサイズを拡大し、少なくとも最小サイズ引数で指定された数の要素を格納できるようにします。

equals

public boolean equals(Object o)
推奨されていません。
指定されたオブジェクトとリストが等しいかどうかを比較します。

get

public Object get(int index)
推奨されていません。
リスト内の指定された位置にある要素を返します。

hashCode

public int hashCode()
推奨されていません。
このリストのハッシュコード値を返します。

indexOf

public int indexOf(Object elem)
推奨されていません。
equals メソッドを使って等しいかどうかを判定しながら、指定された引数と同じ内容の要素を先頭から検索します。

isEmpty

public boolean isEmpty()
推奨されていません。
リストに要素がないかどうかを判定します。

iterator

public Iterator iterator()
推奨されていません。
このリスト内の要素を適切な順序で繰り返し処理する反復子を返します。

lastIndexOf

public int lastIndexOf(Object elem)
推奨されていません。
指定されたオブジェクトがリスト内で最後に現れるインデックスを返します。

listIterator

public ListIterator listIterator()
推奨されていません。
このリスト内の要素を適切な順序で繰り返し処理する反復子を返します。

listIterator

public ListIterator listIterator(int index)
推奨されていません。
リスト内の要素を適切な順序で繰り返し処理する、リスト内の指定された位置から開始する反復子を返します。

remove

public Object remove(int index)
推奨されていません。
リスト内の指定された位置から要素を削除します。

remove

public boolean remove(Object o)
推奨されていません。
指定された要素のインスタンスがこのコレクションにあれば、そのインスタンスをコレクションから 1 つ削除します。

removeAll

public boolean removeAll(Collection c)
推奨されていません。
このコレクションから、指定されたコレクションに含まれる要素をすべて削除します。

retainAll

public boolean retainAll(Collection c)
推奨されていません。
このコレクションにおいて、指定されたコレクションに格納されている要素だけを保持します。

set

public Object set(int index,
                  Object element)
推奨されていません。
リストの指定された位置にある要素を、指定された要素で置き換えます。

size

public int size()
推奨されていません。
リスト内にある要素の数を返します。

subList

public List subList(int fromIndex,
                    int toIndex)
推奨されていません。
このリストの、fromIndex (これを含む) から toIndex (これを含まない) の範囲の部分のビューを返します。

toArray

public Object[] toArray()
推奨されていません。
リスト内のすべての要素が正しい順序で格納されている配列を返します。

toArray

public Object[] toArray(Object[] a)
推奨されていません。
リスト内のすべての要素が正しい順序で格納されている配列を返します。

trimToSize

public void trimToSize()
推奨されていません。
この ArrayList のインスタンスのサイズをリストの現在のサイズに縮小します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.http (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.http
インタフェース
MultipartFormData.Entity
クラス
CGIEnvironment
FileSender
MultipartFormData
SessionQuery


jp.co.intra_mart.foundation.http (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.http

ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

参照:
説明

インタフェースの概要
MultipartFormData.Entity 推奨されていません。 jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity インタフェースを使用してください。

クラスの概要
CGIEnvironment | このクラスは、サーブレットクラス内で CGI 環境変数を扱えるように 各パラメータを CGI 環境変数で定義されているキーワードにマップします。
FileSender | このクラスは、HTTP レスポンスに対して指定のバイトをストリームとして 出力します。
MultipartFormData | 推奨されていません。 jp.co.intra_mart.common.aid.javaee.http.MultipartFormData クラスを使用してください。
SessionQuery | 推奨されていません。 GenericURLBuilder および URLBuilder に置き替えられました。

パッケージ jp.co.intra_mart.foundation.http の説明

ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。


jp.co.intra_mart.foundation.http クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.http の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.util.AbstractCollection (implements java.util.Collection)
      • class java.util.AbstractList (implements java.util.List)
        • class java.util.ArrayList (implements java.lang.Cloneable, java.util.List, java.util.RandomAccess, java.io.Serializable)
          • class jp.co.intra_mart.foundation.http.MultipartFormData
    • class java.util.AbstractMap (implements java.util.Map)
      • class java.util.HashMap (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class jp.co.intra_mart.foundation.http.CGIEnvironment
    • class jp.co.intra_mart.foundation.http.FileSender
    • class jp.co.intra_mart.foundation.http.SessionQuery

インタフェース階層

  • interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity


パッケージ jp.co.intra_mart.foundation.http の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.http の使用

jp.co.intra_mart.foundation.http を使用しているパッケージ
jp.co.intra_mart.foundation.http | ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.foundation.http により使用される jp.co.intra_mart.foundation.http のクラス
MultipartFormData.Entity
推奨されていません。 jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity インタフェースを使用してください。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.foundation.http のクラス
MultipartFormData.Entity
推奨されていません。 jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity インタフェースを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SessionQuery (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.http
クラス SessionQuery

java.lang.Object
    拡張 jp.co.intra_mart.foundation.http.SessionQuery
推奨されていません。 GenericURLBuilder および URLBuilder に置き替えられました。

public class SessionQuery
extends Object

このクラスは、intra-mart のセッションを維持したまま プレゼンテーション・ページ＆ファンクション・コンテナを HTTP を利用して 呼び出すためのセッション引数を提供します。
このクラスを利用することにより、ＪＳＰおよびサーブレットにより作成された ページからスクリプト開発モデルのページに対してリンクすることができます。

なお、ＪＳＰおよびサーブレット間でのセッション維持には利用できません。

関連項目:
GenericURLBuilder, URLBuilder

コンストラクタの概要
SessionQuery(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 GenericURLBuilder および URLBuilder に置き替えられました。
メソッドの概要
 String addURL(String url)
推奨されていません。 GenericURLBuilder.createFilePath(String) および URLBuilder.createURLonSession(String)に置き替えられました。
protected  String getQuery()
推奨されていません。 代替えメソッドはありません。
 String getQueryName()
推奨されていません。 代替えメソッドはありません。
 String getQueryValue()
推奨されていません。 GenericURLBuilder.createFilePath(String) に置き替えられました。
 String setTo(String path)
推奨されていません。 代替えメソッドはありません。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SessionQuery

public SessionQuery(HttpServletRequest request,
                    HttpServletResponse response)
推奨されていません。 GenericURLBuilder および URLBuilder に置き替えられました。

セッションを維持するためのリクエスト引数を作成するインスタンスを 構築します。

指定のセッションＩＤにより遷移先のページで セッションを共有することができます。

例外:
NullPointerException - 引数が null
メソッドの詳細

setTo

public String setTo(String path)
推奨されていません。 代替えメソッドはありません。

遷移先ページの指定。

遷移先のプレゼンテーション・ページのパスを指定します。
パスは、InformationServer からの相対形式で拡張子(.html)を 省略したものを指定して下さい。

sample/tutorial/beginner/index.html へ遷移する場合、 sample/tutorial/beginner/index という文字列を引数 path に指定します。

パラメータ:
path - ファイル名
戻り値:
このメソッドで設定済みだった値
例外:
NullPointerException - 引数が null

getQueryName

public String getQueryName()
推奨されていません。 代替えメソッドはありません。

クエリー引数名称の取得。

クエリー引数の名称を返します。
このメソッドの値を <INPUT> の name 属性値として指定する事で、 セッションを維持したまま intra-mart のプレゼンテーション・ページへ 遷移するフォームを作成する事が出来ます。

戻り値:
クエリー引数名称

getQueryValue

public String getQueryValue()
推奨されていません。 GenericURLBuilder.createFilePath(String) に置き替えられました。

クエリー引数値の取得。

クエリー引数の値を返します。
このメソッドの値を <INPUT> の value 属性値として指定する事で、 セッションを維持したまま intra-mart のプレゼンテーション・ページへ 遷移するフォームを作成する事が出来ます。

戻り値:
クエリー引数値

getQuery

protected String getQuery()
推奨されていません。 代替えメソッドはありません。

クエリー引数の取得。

クエリー引数を返します。

戻り値:
クエリー引数

addURL

public String addURL(String url)
推奨されていません。 GenericURLBuilder.createFilePath(String) および URLBuilder.createURLonSession(String)に置き替えられました。

ＵＲＬへのクエリーの追加。

セッションを維持したまま intra-mart へアクセスするＵＲＬを返します。

パラメータ:
url - intra-mart にアクセスするためのＵＲＬ
戻り値:
セッション維持の為のクエリー引数を付加したＵＲＬ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.image.DuplicateImageIconCodeException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.image.DuplicateImageIconCodeException の使用

DuplicateImageIconCodeException を使用しているパッケージ
jp.co.intra_mart.foundation.image

jp.co.intra_mart.foundation.image での DuplicateImageIconCodeException の使用

DuplicateImageIconCodeException をスローする jp.co.intra_mart.foundation.image のメソッド
void | ImageIconManager.addGroupImageIcon(ImageIconInfo imageIconInfo) グループのイメージアイコン情報を新規登録します。
void | ImageIconManager.addUserImageIcon(ImageIconInfo imageIconInfo, String userCd) ユーザのイメージアイコン情報を新規登録します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.image.DuplicateImageIconSrcException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.image.DuplicateImageIconSrcException の使用

DuplicateImageIconSrcException を使用しているパッケージ
jp.co.intra_mart.foundation.image

jp.co.intra_mart.foundation.image での DuplicateImageIconSrcException の使用

DuplicateImageIconSrcException をスローする jp.co.intra_mart.foundation.image のメソッド
void | ImageIconManager.addGroupImageIcon(ImageIconInfo imageIconInfo) グループのイメージアイコン情報を新規登録します。
void | ImageIconManager.addUserImageIcon(ImageIconInfo imageIconInfo, String userCd) ユーザのイメージアイコン情報を新規登録します。
void | ImageIconManager.updateGroupImageIcon(ImageIconInfo imageIconInfo) グループのイメージアイコン情報を更新します。
void | ImageIconManager.updateUserImageIcon(ImageIconInfo imageIconInfo, String userCd) ユーザのイメージアイコン情報を更新します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.image.ImageIconException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.image.ImageIconException の使用

ImageIconException を使用しているパッケージ
jp.co.intra_mart.foundation.image

jp.co.intra_mart.foundation.image での ImageIconException の使用

jp.co.intra_mart.foundation.image での ImageIconException のサブクラス
class | DuplicateImageIconCodeException 登録時重複例外クラス。
class | DuplicateImageIconSrcException 作成/更新時URLの重複例外クラス。
class | NotExistImageIconException イメージアイコンが存在しなかった場合の例外クラス。

ImageIconException をスローする jp.co.intra_mart.foundation.image のメソッド
ImageIconInfo[] | ImageIconManager.getGroupImageIcons() すべてのグループイメージアイコンを取得します。
ImageIconInfo[] | ImageIconManager.getUserImageIcons(String userCd) すべてのユーザイメージアイコンを取得します。
ImageIconInfo | ImageIconManager.getImageIcon(String imageIconCd) イメージアイコン情報を取得します。
void | ImageIconManager.addGroupImageIcon(ImageIconInfo imageIconInfo) グループのイメージアイコン情報を新規登録します。
void | ImageIconManager.addUserImageIcon(ImageIconInfo imageIconInfo, String userCd) ユーザのイメージアイコン情報を新規登録します。
boolean | ImageIconManager.existImageIcon(String imageIconCd) イメージアイコンの存在チェックをします。
boolean | ImageIconManager.existGroupImageIconBySrc(String src) URLをもつグループイメージアイコンの存在チェックをします。
boolean | ImageIconManager.existUserImageIconBySrc(String userCd, String src) URLをもつユーザイメージアイコンの存在チェックをします。
void | ImageIconManager.deleteGroupImageIcons() グループのイメージアイコン情報をすべて削除します。
void | ImageIconManager.deleteUserImageIcons(String userCd) ユーザのイメージアイコン情報をすべて削除します。
void | ImageIconManager.deleteImageIcon(String imageIconCd) イメージアイコン情報を削除します。
boolean | ImageIconManager.existGroupImageIcons() グループイメージアイコンの存在チェックをします。
boolean | ImageIconManager.existUserImageIcons(String userCd) ユーザイメージアイコンの存在チェックをします。
void | ImageIconManager.updateGroupImageIcon(ImageIconInfo imageIconInfo) グループのイメージアイコン情報を更新します。
void | ImageIconManager.updateUserImageIcon(ImageIconInfo imageIconInfo, String userCd) ユーザのイメージアイコン情報を更新します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.image.ImageIconInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.image.ImageIconInfo の使用

ImageIconInfo を使用しているパッケージ
jp.co.intra_mart.foundation.image

jp.co.intra_mart.foundation.image での ImageIconInfo の使用

ImageIconInfo を返す jp.co.intra_mart.foundation.image のメソッド
ImageIconInfo[] | ImageIconManager.getGroupImageIcons() すべてのグループイメージアイコンを取得します。
ImageIconInfo[] | ImageIconManager.getUserImageIcons(String userCd) すべてのユーザイメージアイコンを取得します。
ImageIconInfo | ImageIconManager.getImageIcon(String imageIconCd) イメージアイコン情報を取得します。

ImageIconInfo 型のパラメータを持つ jp.co.intra_mart.foundation.image のメソッド
void | ImageIconManager.addGroupImageIcon(ImageIconInfo imageIconInfo) グループのイメージアイコン情報を新規登録します。
void | ImageIconManager.addUserImageIcon(ImageIconInfo imageIconInfo, String userCd) ユーザのイメージアイコン情報を新規登録します。
void | ImageIconManager.updateGroupImageIcon(ImageIconInfo imageIconInfo) グループのイメージアイコン情報を更新します。
void | ImageIconManager.updateUserImageIcon(ImageIconInfo imageIconInfo, String userCd) ユーザのイメージアイコン情報を更新します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.image.ImageIconManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.image.ImageIconManager の使用

jp.co.intra_mart.foundation.image.ImageIconManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.image.ImageIconMessageBundle の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.image.ImageIconMessageBundle の使用

jp.co.intra_mart.foundation.image.ImageIconMessageBundle はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.image.NotExistImageIconException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.image.NotExistImageIconException の使用

NotExistImageIconException を使用しているパッケージ
jp.co.intra_mart.foundation.image

jp.co.intra_mart.foundation.image での NotExistImageIconException の使用

NotExistImageIconException をスローする jp.co.intra_mart.foundation.image のメソッド
ImageIconInfo[] | ImageIconManager.getGroupImageIcons() すべてのグループイメージアイコンを取得します。
ImageIconInfo[] | ImageIconManager.getUserImageIcons(String userCd) すべてのユーザイメージアイコンを取得します。
void | ImageIconManager.deleteGroupImageIcons() グループのイメージアイコン情報をすべて削除します。
void | ImageIconManager.deleteUserImageIcons(String userCd) ユーザのイメージアイコン情報をすべて削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DuplicateImageIconCodeException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.image
クラス DuplicateImageIconCodeException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.image.ImageIconException
                    拡張 jp.co.intra_mart.foundation.image.DuplicateImageIconCodeException
すべての実装インタフェース:
Serializable
public class DuplicateImageIconCodeException
extends ImageIconException

登録時重複例外クラス。

イメージアイコンを新規登録時に、 イメージイメージアイコンコードが重複している場合にスローされます。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DuplicateImageIconCodeException()
コンストラクタ。
DuplicateImageIconCodeException(String imageIconCd, String loginType)
コンストラクタ。
DuplicateImageIconCodeException(String imageIconCd, String loginType, Throwable cause)
コンストラクタ。
DuplicateImageIconCodeException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DuplicateImageIconCodeException

public DuplicateImageIconCodeException()
コンストラクタ。

DuplicateImageIconCodeException

public DuplicateImageIconCodeException(String imageIconCd,
                                       String loginType)
コンストラクタ。

パラメータ:
imageIconCd - イメージアイコンコード
loginType - ログインタイプ

DuplicateImageIconCodeException

public DuplicateImageIconCodeException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

DuplicateImageIconCodeException

public DuplicateImageIconCodeException(String imageIconCd,
                                       String loginType,
                                       Throwable cause)
コンストラクタ。

パラメータ:
imageIconCd - イメージアイコンコード
loginType - ログインタイプ
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DuplicateImageIconSrcException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.image
クラス DuplicateImageIconSrcException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.image.ImageIconException
                    拡張 jp.co.intra_mart.foundation.image.DuplicateImageIconSrcException
すべての実装インタフェース:
Serializable
public class DuplicateImageIconSrcException
extends ImageIconException

作成/更新時URLの重複例外クラス。

イメージアイコンを新規作成または更新時に、 イメージアイコンのURLが重複している場合にスローされます。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DuplicateImageIconSrcException()
コンストラクタ。
DuplicateImageIconSrcException(String loginType, String src)
コンストラクタ。
DuplicateImageIconSrcException(String src, String loginType, Throwable cause)
コンストラクタ。
DuplicateImageIconSrcException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DuplicateImageIconSrcException

public DuplicateImageIconSrcException()
コンストラクタ。

DuplicateImageIconSrcException

public DuplicateImageIconSrcException(String loginType,
                                      String src)
コンストラクタ。

パラメータ:
loginType - ログインタイプ
src - イメージアイコンURL

DuplicateImageIconSrcException

public DuplicateImageIconSrcException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

DuplicateImageIconSrcException

public DuplicateImageIconSrcException(String src,
                                      String loginType,
                                      Throwable cause)
コンストラクタ。

パラメータ:
src - イメージアイコンURL
loginType - ログインタイプ
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ImageIconException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.image
クラス ImageIconException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.image.ImageIconException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
DuplicateImageIconCodeException, DuplicateImageIconSrcException, NotExistImageIconException
public class ImageIconException
extends FoundationException

イメージアイコンの例外クラス。

イメージアイコン内で例外が発生した場合にスローされます。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ImageIconException()
コンストラクタ。
ImageIconException(String message)
コンストラクタ。
ImageIconException(String message, Throwable cause)
コンストラクタ。
ImageIconException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ImageIconException

public ImageIconException()
コンストラクタ。

ImageIconException

public ImageIconException(String message)
コンストラクタ。

パラメータ:
message - メッセージ

ImageIconException

public ImageIconException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

ImageIconException

public ImageIconException(String message,
                          Throwable cause)
コンストラクタ。

パラメータ:
message - メッセージ
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ImageIconInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.image
クラス ImageIconInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.image.ImageIconInfo
public class ImageIconInfo
extends Object

イメージアイコン情報クラス。
イメージアイコンのイメージアイコンコード、URL、ソートキーを持ちます。

導入されたバージョン:
6.0
バージョン:
1.0

フィールドの概要
static int DEFAULT_SORT_KEY
デフォルトソートキー
コンストラクタの概要
ImageIconInfo(String src)
コンストラクタ。
ImageIconInfo(String src, int sortKey)
コンストラクタ。
ImageIconInfo(String imageIconCd, String src, int sortKey)
コンストラクタ。
メソッドの概要
String | getImageIconCd() イメージアイコンコードを取得する。
int | getSortKey() ソートキーを取得する。
String | getSrc() イメージアイコンURLを取得する。
void | setImageIconCd(String iconCd) イメージアイコンコードを設定する。
void | setSortKey(int sortKey) ソートキーを設定する。
void | setSrc(String src) イメージアイコンURLを設定する。
String | toString() この ImageIconInfo の値を表す String オブジェクトを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

フィールドの詳細

DEFAULT_SORT_KEY

public static final int DEFAULT_SORT_KEY
デフォルトソートキー

関連項目:
定数フィールド値
コンストラクタの詳細

ImageIconInfo

public ImageIconInfo(String src)
コンストラクタ。

引数にイメージアイコンのURL(src)を指定します。
イメージアイコンコードは自動的に生成されます。
ソートキーはデフォルト値(DEFAULT_SORT_KEY)が設定されます。

パラメータ:
src - イメージアイコンのURL

ImageIconInfo

public ImageIconInfo(String src,
                     int sortKey)
コンストラクタ。

引数にイメージアイコンのURL、ソートキーを指定します。
イメージアイコンコードは自動的に生成されます。

パラメータ:
src - イメージアイコンのURL
sortKey - ソートキー

ImageIconInfo

public ImageIconInfo(String imageIconCd,
                     String src,
                     int sortKey)
コンストラクタ。

引数にイメージアイコンコード、イメージアイコンのURL、ソートキーを指定します。

パラメータ:
imageIconCd - イメージアイコンコード
src - イメージアイコンのURL
sortKey - ソートキー
メソッドの詳細

getImageIconCd

public String getImageIconCd()
イメージアイコンコードを取得する。

ログイングループで一意に識別されるイメージアイコンコードを返却します。

戻り値:
イメージアイコンコード

setImageIconCd

public void setImageIconCd(String iconCd)
イメージアイコンコードを設定する。

ログイングループで一意に識別されるイメージアイコンコードを設定します。

パラメータ:
iconCd - イメージアイコンコード

getSortKey

public int getSortKey()
ソートキーを取得する。

イメージアイコンの並び順を表したソートキーを返却します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定する。

イメージアイコンの並び順を表したソートキーを設定します。

パラメータ:
sortKey - ソートキー

getSrc

public String getSrc()
イメージアイコンURLを取得する。

コンテキストルートからのパスとなるイメージアイコンのURLを取得します。

戻り値:
イメージアイコンURL

setSrc

public void setSrc(String src)
イメージアイコンURLを設定する。

コンテキストルートからのパスとなるイメージアイコンのURLを設定します。

パラメータ:
src - イメージアイコンURL

toString

public String toString()
この ImageIconInfo の値を表す String オブジェクトを返します。

この ImageIconInfo の値を表す String オブジェクトを返します。 形式は以下のようになります。
imageIconCd: imageIconCd, src: src, sortKey: sortKey

戻り値:
この ImageIconInfo の値を表す String オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ImageIconManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.image
クラス ImageIconManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.image.ImageIconManager
public class ImageIconManager
extends Object

アイコンマネージャクラス。
イメージアイコン情報の操作を行います。

導入されたバージョン:
6.0
バージョン:
1.0

コンストラクタの概要
ImageIconManager(String groupId)
メソッドの概要
void | addGroupImageIcon(ImageIconInfo imageIconInfo) グループのイメージアイコン情報を新規登録します。
void | addUserImageIcon(ImageIconInfo imageIconInfo, String userCd) ユーザのイメージアイコン情報を新規登録します。
void | deleteGroupImageIcons() グループのイメージアイコン情報をすべて削除します。
void | deleteImageIcon(String imageIconCd) イメージアイコン情報を削除します。
void | deleteUserImageIcons(String userCd) ユーザのイメージアイコン情報をすべて削除します。
boolean | existGroupImageIconBySrc(String src) URLをもつグループイメージアイコンの存在チェックをします。
boolean | existGroupImageIcons() グループイメージアイコンの存在チェックをします。
boolean | existImageIcon(String imageIconCd) イメージアイコンの存在チェックをします。
boolean | existUserImageIconBySrc(String userCd, String src) URLをもつユーザイメージアイコンの存在チェックをします。
boolean | existUserImageIcons(String userCd) ユーザイメージアイコンの存在チェックをします。
ImageIconInfo[] | getGroupImageIcons() すべてのグループイメージアイコンを取得します。
ImageIconInfo | getImageIcon(String imageIconCd) イメージアイコン情報を取得します。
ImageIconInfo[] | getUserImageIcons(String userCd) すべてのユーザイメージアイコンを取得します。
boolean | isDuplicateSrc() イメージアイコンのURLの重複チェックの有効/無効を取得します。
void | setDuplicateSrc(boolean duplicateSrc) イメージアイコンのURLの重複チェックの有効/無効を設定します。
void | updateGroupImageIcon(ImageIconInfo imageIconInfo) グループのイメージアイコン情報を更新します。
void | updateUserImageIcon(ImageIconInfo imageIconInfo, String userCd) ユーザのイメージアイコン情報を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ImageIconManager

public ImageIconManager(String groupId)
パラメータ:
groupId - グループID
メソッドの詳細

isDuplicateSrc

public boolean isDuplicateSrc()
イメージアイコンのURLの重複チェックの有効/無効を取得します。

  • true: 登録/更新時にイメージアイコンのURLがすでに登録済かどうかのチェックを行います。
  • false: 登録/更新時にイメージアイコンのURLがすでに登録済かどうかのチェックを行いません。
  • デフォルト: 無効(false)

      • 戻り値:
      イメージアイコンのURLの重複チェックの有効/無効

setDuplicateSrc

public void setDuplicateSrc(boolean duplicateSrc)
イメージアイコンのURLの重複チェックの有効/無効を設定します。

  • true: 登録/更新時にイメージアイコンのURLがすでに登録済かどうかのチェックを行います。
  • false: 登録/更新時にイメージアイコンのURLがすでに登録済かどうかのチェックを行いません。
  • デフォルト: 無効(false)

      • パラメータ:
      duplicateSrc - イメージアイコンのURLの重複チェックの有効/無効

getGroupImageIcons

public ImageIconInfo[] getGroupImageIcons()
                                   throws NotExistImageIconException,
                                          ImageIconException
すべてのグループイメージアイコンを取得します。

配列要素の順番はソートキーの昇順となります。

戻り値:
すべてのグループイメージアイコン情報
例外:
NotExistImageIconException - グループイメージアイコンが存在しない場合にスローされます。 ImageIconException イメージアイコン情報の取得に失敗した場合にスローされます。
ImageIconException

getUserImageIcons

public ImageIconInfo[] getUserImageIcons(String userCd)
                                  throws NotExistImageIconException,
                                         ImageIconException
すべてのユーザイメージアイコンを取得します。

配列要素の順番はソートキーの昇順となります。

戻り値:
すべてのユーザイメージアイコン情報
例外:
NotExistImageIconException - ユーザイメージアイコンが存在しない場合にスローされます。 ImageIconException イメージアイコン情報の取得に失敗した場合にスローされます。
ImageIconException

getImageIcon

public ImageIconInfo getImageIcon(String imageIconCd)
                           throws ImageIconException
イメージアイコン情報を取得します。

引数のイメージアイコンコードからイメージアイコンを取得します。

パラメータ:
imageIconCd - イメージアイコンコード
戻り値:
イメージアイコン情報またはnull
例外:
NotExistImageIconException - 引数のイメージアイコンが存在しない場合にスローされます。 ImageIconException イメージアイコン情報の取得に失敗した場合にスローされます。
ImageIconException

addGroupImageIcon

public void addGroupImageIcon(ImageIconInfo imageIconInfo)
                       throws DuplicateImageIconCodeException,
                              DuplicateImageIconSrcException,
                              ImageIconException
グループのイメージアイコン情報を新規登録します。

イメージアイコンURLの重複チェックが有効の場合、グループイメージアイコンにおいて重複していた場合にスローされます。

パラメータ:
imageIconInfo - イメージアイコン情報
例外:
DuplicateImageIconCodeException - イメージアイコンコードが重複している場合にスローされます。
DuplicateImageIconSrcException イメージアイコンURLの重複チェックが有効の場合、グループイメージアイコンにおいて重複していた場合にスローされます。
ImageIconException イメージアイコンの登録に失敗した場合にスローされます。
DuplicateImageIconSrcException
ImageIconException

addUserImageIcon

public void addUserImageIcon(ImageIconInfo imageIconInfo,
                             String userCd)
                      throws DuplicateImageIconCodeException,
                             DuplicateImageIconSrcException,
                             ImageIconException
ユーザのイメージアイコン情報を新規登録します。

イメージアイコンURLの重複チェックが有効の場合、ユーザイメージアイコンにおいて重複していた場合にスローされます。

パラメータ:
imageIconInfo - イメージアイコン情報
例外:
DuplicateImageIconCodeException - イメージアイコンコードが重複している場合にスローされます。
DuplicateImageIconSrcException イメージアイコンURLの重複チェックが有効の場合、引数のユーザのユーザイメージアイコンにおいて重複していた場合にスローされます。
ImageIconException イメージアイコンの登録に失敗した場合にスローされます。
DuplicateImageIconSrcException
ImageIconException

existImageIcon

public boolean existImageIcon(String imageIconCd)
                       throws ImageIconException
イメージアイコンの存在チェックをします。

  • true: イメージアイコンが存在している
  • false: イメージアイコンが存在していない

パラメータ:
imageIconCd - イメージアイコンコード
戻り値:
イメージアイコンが存在している(true)/存在していない(false)
例外:
ImageIconException - イメージアイコンの存在チェックに失敗した場合にスローされます。

existGroupImageIconBySrc

public boolean existGroupImageIconBySrc(String src)
                                 throws ImageIconException
URLをもつグループイメージアイコンの存在チェックをします。

引数のイメージアイコンURLからなるグループイメージアイコンの存在チェックをします。
  • true: イメージアイコンが存在している
  • false: イメージアイコンが存在していない

パラメータ:
src - イメージアイコンURL
戻り値:
グループイメージアイコンが存在している(true)/存在していない(false)かを返却します。
例外:
ImageIconException - イメージアイコンの存在チェックに失敗した場合にスローされます。

existUserImageIconBySrc

public boolean existUserImageIconBySrc(String userCd,
                                       String src)
                                throws ImageIconException
URLをもつユーザイメージアイコンの存在チェックをします。

引数のイメージアイコンURLからなるユーザイメージアイコンの存在チェックをします。
  • true: イメージアイコンが存在している
  • false: イメージアイコンが存在していない

パラメータ:
userCd - ユーザコード
src - イメージアイコンURL
戻り値:
ユーザイメージアイコンが存在している(true)/存在していない(false)かを返却します。
例外:
ImageIconException - イメージアイコンの存在チェックに失敗した場合にスローされます。

deleteGroupImageIcons

public void deleteGroupImageIcons()
                           throws NotExistImageIconException,
                                  ImageIconException
グループのイメージアイコン情報をすべて削除します。

例外:
NotExistImageIconException - 削除前にグループのイメージアイコン情報が存在しない場合にスローされます。
ImageIconException イメージアイコンの削除に失敗した場合にスローされます。
ImageIconException

deleteUserImageIcons

public void deleteUserImageIcons(String userCd)
                          throws NotExistImageIconException,
                                 ImageIconException
ユーザのイメージアイコン情報をすべて削除します。

パラメータ:
userCd - ユーザコード
例外:
NotExistImageIconException - 削除前にユーザのイメージアイコン情報が存在しない場合にスローされます。
ImageIconException イメージアイコンの削除に失敗した場合にスローされます。
ImageIconException

deleteImageIcon

public void deleteImageIcon(String imageIconCd)
                     throws ImageIconException
イメージアイコン情報を削除します。
引数で指定したイメージアイコン情報を削除します。

パラメータ:
imageIconCd - イメージアイコンコード
例外:
NotExistImageIconException - 削除前にイメージアイコン情報が存在しない場合にスローされます。
ImageIconException イメージアイコンの削除に失敗した場合にスローされます。
ImageIconException

existGroupImageIcons

public boolean existGroupImageIcons()
                             throws ImageIconException
グループイメージアイコンの存在チェックをします。

  • true: グループイメージアイコンが存在している
  • false: グループイメージアイコンが存在していない

戻り値:
グループイメージアイコンが存在している(true)/存在していない(false)かを返却します。
例外:
ImageIconException - グループイメージアイコンの存在チェックに失敗した場合にスローされます。

existUserImageIcons

public boolean existUserImageIcons(String userCd)
                            throws ImageIconException
ユーザイメージアイコンの存在チェックをします。

  • true: ユーザイメージアイコンが存在している
  • false: ユーザイメージアイコンが存在していない

パラメータ:
userCd - ユーザコード
戻り値:
ユーザイメージアイコンが存在している(true)/存在していない(false)かを返却します。
例外:
ImageIconException - ユーザイメージアイコンの存在チェックに失敗した場合にスローされます。

updateGroupImageIcon

public void updateGroupImageIcon(ImageIconInfo imageIconInfo)
                          throws DuplicateImageIconSrcException,
                                 ImageIconException
グループのイメージアイコン情報を更新します。
イメージアイコンURLの重複チェックが有効の場合、グループイメージアイコンにおいて重複していた場合にスローされます。

パラメータ:
imageIconInfo - イメージアイコン情報
例外:
DuplicateImageIconSrcException - イメージアイコンURLの重複チェックが有効の場合、グループイメージアイコンにおいて重複していた場合にスローされます。
ImageIconException イメージアイコンの更新に失敗した場合にスローされます。
ImageIconException

updateUserImageIcon

public void updateUserImageIcon(ImageIconInfo imageIconInfo,
                                String userCd)
                         throws DuplicateImageIconSrcException,
                                ImageIconException
ユーザのイメージアイコン情報を更新します。
イメージアイコンURLの重複チェックが有効の場合、ユーザイメージアイコンにおいて重複していた場合にスローされます。

パラメータ:
imageIconInfo - イメージアイコン情報
例外:
DuplicateImageIconSrcException - イメージアイコンURLの重複チェックが有効の場合、引数のユーザのユーザイメージアイコンにおいて重複していた場合にスローされます。
ImageIconException イメージアイコンの更新に失敗した場合にスローされます。
ImageIconException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ImageIconMessageBundle (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.image
クラス ImageIconMessageBundle

java.lang.Object
    拡張 jp.co.intra_mart.foundation.image.ImageIconMessageBundle
public class ImageIconMessageBundle
extends Object

コンストラクタの概要
ImageIconMessageBundle()
メソッドの概要
static String | getMessage(Locale locale, String key) イメージアイコンメッセージを取得します。
static String | getMessage(Locale locale, String key, String arg) 置換文字列を挿入したイメージアイコンメッセージを取得します。
static String | getMessage(Locale locale, String key, String[] args) 置換文字列を挿入したイメージアイコンメッセージを取得します。
static String | getMessage(Locale locale, String key, String arg1, String arg2) 置換文字列を挿入したイメージアイコンメッセージを取得します。
static String | getMessage(Locale locale, String key, String arg1, String arg2, String arg3) 置換文字列を挿入したイメージアイコンメッセージを取得します。
static String | getMessage(String key) イメージアイコンメッセージを取得します。
static String | getMessage(String key, String arg) 置換文字列を挿入したイメージアイコンメッセージを取得します。
static String | getMessage(String key, String[] args) 置換文字列を挿入したイメージアイコンメッセージを取得します。
static String | getMessage(String key, String arg1, String arg2) 置換文字列を挿入したイメージアイコンメッセージを取得します。
static String | getMessage(String key, String arg1, String arg2, String arg3) 置換文字列を挿入したイメージアイコンメッセージを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ImageIconMessageBundle

public ImageIconMessageBundle()
メソッドの詳細

getMessage

public static String getMessage(Locale locale,
                                String key)
イメージアイコンメッセージを取得します。

パラメータ:
locale - ロケール
key - メッセージID
戻り値:
イメージアイコンメッセージ

getMessage

public static String getMessage(Locale locale,
                                String key,
                                String arg)
置換文字列を挿入したイメージアイコンメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
locale - ロケール
key - メッセージID
arg - 置換文字列
戻り値:
置換文字列を挿入したイメージアイコンメッセージ

getMessage

public static String getMessage(Locale locale,
                                String key,
                                String arg1,
                                String arg2)
置換文字列を挿入したイメージアイコンメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
locale - ロケール
key - メッセージID
戻り値:
置換文字列を挿入したイメージアイコンメッセージ

getMessage

public static String getMessage(Locale locale,
                                String key,
                                String arg1,
                                String arg2,
                                String arg3)
置換文字列を挿入したイメージアイコンメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
locale - ロケール
key - メッセージID
戻り値:
置換文字列を挿入したイメージアイコンメッセージ

getMessage

public static String getMessage(Locale locale,
                                String key,
                                String[] args)
置換文字列を挿入したイメージアイコンメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
locale - ロケール
key - メッセージID
args - 置換文字列の配列
戻り値:
置換文字列を挿入したイメージアイコンメッセージ

getMessage

public static String getMessage(String key)
イメージアイコンメッセージを取得します。

パラメータ:
key - メッセージID
戻り値:
イメージアイコンメッセージ

getMessage

public static String getMessage(String key,
                                String arg)
置換文字列を挿入したイメージアイコンメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
key - メッセージID
arg - 置換文字列
戻り値:
置換文字列を挿入したイメージアイコンメッセージ

getMessage

public static String getMessage(String key,
                                String arg1,
                                String arg2)
置換文字列を挿入したイメージアイコンメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
key - メッセージID
戻り値:
置換文字列を挿入したイメージアイコンメッセージ

getMessage

public static String getMessage(String key,
                                String arg1,
                                String arg2,
                                String arg3)
置換文字列を挿入したイメージアイコンメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
key - メッセージID
戻り値:
置換文字列を挿入したイメージアイコンメッセージ

getMessage

public static String getMessage(String key,
                                String[] args)
置換文字列を挿入したイメージアイコンメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
key - メッセージID
args - 置換文字列の配列
戻り値:
置換文字列を挿入したイメージアイコンメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


NotExistImageIconException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.image
クラス NotExistImageIconException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.image.ImageIconException
                    拡張 jp.co.intra_mart.foundation.image.NotExistImageIconException
すべての実装インタフェース:
Serializable
public class NotExistImageIconException
extends ImageIconException

イメージアイコンが存在しなかった場合の例外クラス。

イメージアイコンがデータベースに存在しなかった場合にスローします。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
NotExistImageIconException()
コンストラクタ。
NotExistImageIconException(String imageIconCd, String loginType)
コンストラクタ。
NotExistImageIconException(String imageIconCd, String loginType, Throwable cause)
コンストラクタ。
NotExistImageIconException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NotExistImageIconException

public NotExistImageIconException()
コンストラクタ。

NotExistImageIconException

public NotExistImageIconException(String imageIconCd,
                                  String loginType)
コンストラクタ。

パラメータ:
imageIconCd - イメージアイコンコード
loginType - ログインタイプ

NotExistImageIconException

public NotExistImageIconException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

NotExistImageIconException

public NotExistImageIconException(String imageIconCd,
                                  String loginType,
                                  Throwable cause)
コンストラクタ。

パラメータ:
imageIconCd - イメージアイコンコード
loginType - ログインタイプ
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.image (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.image
クラス
ImageIconInfo
ImageIconManager
ImageIconMessageBundle
例外
DuplicateImageIconCodeException
DuplicateImageIconSrcException
ImageIconException
NotExistImageIconException


jp.co.intra_mart.foundation.image (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.image

クラスの概要
ImageIconInfo | イメージアイコン情報クラス。
ImageIconManager | アイコンマネージャクラス。
ImageIconMessageBundle |

例外の概要
DuplicateImageIconCodeException | 登録時重複例外クラス。
DuplicateImageIconSrcException | 作成/更新時URLの重複例外クラス。
ImageIconException | イメージアイコンの例外クラス。
NotExistImageIconException | イメージアイコンが存在しなかった場合の例外クラス。


jp.co.intra_mart.foundation.image クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.image の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.image.ImageIconInfo
    • class jp.co.intra_mart.foundation.image.ImageIconManager
    • class jp.co.intra_mart.foundation.image.ImageIconMessageBundle
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.exception.FoundationException
          • class jp.co.intra_mart.foundation.image.ImageIconException
            • class jp.co.intra_mart.foundation.image.DuplicateImageIconCodeException
            • class jp.co.intra_mart.foundation.image.DuplicateImageIconSrcException
            • class jp.co.intra_mart.foundation.image.NotExistImageIconException


パッケージ jp.co.intra_mart.foundation.image の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.image の使用

jp.co.intra_mart.foundation.image を使用しているパッケージ
jp.co.intra_mart.foundation.image

jp.co.intra_mart.foundation.image により使用される jp.co.intra_mart.foundation.image のクラス
DuplicateImageIconCodeException
登録時重複例外クラス。
DuplicateImageIconSrcException
作成/更新時URLの重複例外クラス。
ImageIconException
イメージアイコンの例外クラス。
ImageIconInfo
イメージアイコン情報クラス。
NotExistImageIconException
イメージアイコンが存在しなかった場合の例外クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.im_curl.CurlFieldBean の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.im_curl.CurlFieldBean の使用

CurlFieldBean を使用しているパッケージ
jp.co.intra_mart.foundation.im_curl intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。

jp.co.intra_mart.foundation.im_curl での CurlFieldBean の使用

CurlFieldBean 型のパラメータを持つ jp.co.intra_mart.foundation.im_curl のメソッド
 void CurlXMLComposer.addField(CurlFieldBean field)
フィールド一覧リストにフィールドを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.im_curl.CurlRecordBeanIF の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.im_curl.CurlRecordBeanIF の使用

CurlRecordBeanIF を使用しているパッケージ
jp.co.intra_mart.foundation.im_curl intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。

jp.co.intra_mart.foundation.im_curl での CurlRecordBeanIF の使用

CurlRecordBeanIF 型のパラメータを持つ jp.co.intra_mart.foundation.im_curl のメソッド
 void CurlXMLComposer.addRecord(CurlRecordBeanIF record)
レコード一覧リストにレコードを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.im_curl.CurlXMLComposer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.im_curl.CurlXMLComposer の使用

jp.co.intra_mart.foundation.im_curl.CurlXMLComposer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.im_curl.CurlXMLParser の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.im_curl.CurlXMLParser の使用

jp.co.intra_mart.foundation.im_curl.CurlXMLParser はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CurlFieldBean (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.im_curl
クラス CurlFieldBean

java.lang.Object
    拡張 jp.co.intra_mart.foundation.im_curl.CurlFieldBean
public class CurlFieldBean
extends Object

CurlフィールドBeanクラス
機能は以下の通り

  • CurlのRecordFieldクラスの属性情報を格納するBean

コンストラクタの概要
CurlFieldBean()
メソッドの概要
String | getCaption() キャプションを返します。
String | getDefault_value() デフォルト値を返します。
String | getDomain() ドメインを返します。
String | getIndex_type() インデックスタイプを返します。
String | getModifiable() 変更可能の可否を返します。
String | getName() 名前を返します。
String | getNullable() Null受付の可否を返します。
String | getRequired() フォーカスの要求の有無を返します。
void | setCaption(String string) キャプションを格納します。
void | setDefault_value(String string) デフォルト値を格納します。
void | setDomain(String string) ドメインを格納します。
void | setIndex_type(String string) インデックスタイプを格納します。
void | setModifiable(String string) 変更可能の可否を格納します。
void | setName(String string) 名前を格納します。
void | setNullable(String string) Null受付の可否を格納します。
void | setRequired(String string) フォーカスの要求の有無を格納します。
String | toString() オブジェクトを文字列に変換します。
String | toXMLNode() このインスタンスのXMLノードとしての文字列を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CurlFieldBean

public CurlFieldBean()
メソッドの詳細

getCaption

public String getCaption()
キャプションを返します。

戻り値:
キャプション

getDefault_value

public String getDefault_value()
デフォルト値を返します。

戻り値:
デフォルト値

getDomain

public String getDomain()
ドメインを返します。

戻り値:
ドメイン

getIndex_type

public String getIndex_type()
インデックスタイプを返します。

戻り値:
インデックスタイプ

getModifiable

public String getModifiable()
変更可能の可否を返します。

戻り値:
変更可能の可否

getName

public String getName()
名前を返します。

戻り値:
名前

getNullable

public String getNullable()
Null受付の可否を返します。

戻り値:
Null受付の可否

getRequired

public String getRequired()
フォーカスの要求の有無を返します。

戻り値:
フォーカスの要求の有無

setCaption

public void setCaption(String string)
キャプションを格納します。

パラメータ:
string - キャプション

setDefault_value

public void setDefault_value(String string)
デフォルト値を格納します。

パラメータ:
string - デフォルト値

setDomain

public void setDomain(String string)
ドメインを格納します。

パラメータ:
string - ドメイン

setIndex_type

public void setIndex_type(String string)
インデックスタイプを格納します。

パラメータ:
string - インデックスタイプ

setModifiable

public void setModifiable(String string)
変更可能の可否を格納します。

パラメータ:
string - 変更可能の可否

setName

public void setName(String string)
名前を格納します。

パラメータ:
string - 名前

setNullable

public void setNullable(String string)
Null受付の可否を格納します。

パラメータ:
string - Null受付の可否

setRequired

public void setRequired(String string)
フォーカスの要求の有無を格納します。

パラメータ:
string - フォーカスの要求の有無

toString

public String toString()
オブジェクトを文字列に変換します。

戻り値:
このオブジェクトの文字列表現

toXMLNode

public String toXMLNode()
このインスタンスのXMLノードとしての文字列を返します。

戻り値:
XMLノードへ変換した文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CurlRecordBeanIF (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.im_curl
インタフェース CurlRecordBeanIF

public interface CurlRecordBeanIF

CurlレコードBeanインタフェース
機能は以下の通り

  • CurlのRecordクラスの属性を格納するBean用のインタフェース

メソッドの概要
 String toXMLNode()
保持しているデータをXMLノードの文字列に変換します。

メソッドの詳細

toXMLNode

public String toXMLNode()
保持しているデータをXMLノードの文字列に変換します。

戻り値:
XMLノード文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CurlXMLComposer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.im_curl
クラス CurlXMLComposer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.im_curl.CurlXMLComposer
public class CurlXMLComposer
extends Object

CurlXML生成クラス
機能は以下の通り

  • Curlで入力可能なXML(elaborate-recordsetで入力可能)を生成します。

コンストラクタの概要
CurlXMLComposer()
メソッドの概要
void | addField(CurlFieldBean field) フィールド一覧リストにフィールドを追加します。
void | addRecord(CurlRecordBeanIF record) レコード一覧リストにレコードを追加します。
void | setFieldList(ArrayList fieldList) フィールド一覧リストをセットします。
void | setRecordList(ArrayList recordList) レコード一覧リストをセットします。
String | toXML() 指定されたフィールド定義、レコードからCurlで入力可能なXML(elaborate-xmlで 入力可能)を生成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CurlXMLComposer

public CurlXMLComposer()
メソッドの詳細

addField

public void addField(CurlFieldBean field)
フィールド一覧リストにフィールドを追加します。

パラメータ:
field - フィールド定義クラスのインスタンス

setFieldList

public void setFieldList(ArrayList fieldList)
フィールド一覧リストをセットします。

パラメータ:
fieldList - フィールド一覧リスト

addRecord

public void addRecord(CurlRecordBeanIF record)
レコード一覧リストにレコードを追加します。

パラメータ:
record - レコードクラスのインスタンス

setRecordList

public void setRecordList(ArrayList recordList)
レコード一覧リストをセットします。

パラメータ:
recordList - レコード一覧リスト

toXML

public String toXML()
             throws Exception
指定されたフィールド定義、レコードからCurlで入力可能なXML(elaborate-xmlで 入力可能)を生成します。

戻り値:
Curlで入力可能なXMLの文字列
例外:
Exception
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CurlXMLParser (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.im_curl
クラス CurlXMLParser

java.lang.Object
    拡張 org.xml.sax.helpers.DefaultHandler
        拡張 jp.co.intra_mart.foundation.im_curl.CurlXMLParser
すべての実装インタフェース:
ContentHandler, DTDHandler, EntityResolver, ErrorHandler
public class CurlXMLParser
extends DefaultHandler

CurlXMLパーサクラス
機能は以下の通り

  • Curlで出力されたXML(recordset-to-xmlでの出力)をパースします。

フィールドの概要
protected Object | field に対応するCurlFieldBean
protected ArrayList | fieldsList に対応するCurlFieldBeanクラスのインスタンス格納用リスト
protected Object | instance に対応するJavaBeans
protected ArrayList | recordList に対応するクラスのインスタンス格納用リスト
コンストラクタの概要
CurlXMLParser(InputStream stream, String beanClassName)
このクラス自身をハンドラとしたSAXパーサを作成し、指定されたInputStreamから取得したXMLを パースします。
CurlXMLParser(String path, String beanClassName)
このクラス自身をハンドラとしたSAXパーサを作成し、指定されたpathのXMLを パースします。
メソッドの概要
protected void | createField(Attributes atts) qNameがFieldの場合のパーサの動作を定義します。
protected void | createRecord(Attributes atts) qNameがRecordの場合のパーサの動作を定義します。
void | endElement(String uri, String localName, String qName) DefaultHandlerのabstractメソッドをオーバーライドします。
ArrayList | getFieldsList() パースした結果のフィールド一覧リストを返します。
ArrayList | getRecordList() パースした結果のレコード一覧リストを返します。
void | startElement(String uri, String localName, String qName, Attributes atts) DefaultHandlerのabstractメソッドをオーバーライドします。
クラス org.xml.sax.helpers.DefaultHandler から継承したメソッド
characters, endDocument, endPrefixMapping, error, fatalError, ignorableWhitespace, notationDecl, processingInstruction, resolveEntity, setDocumentLocator, skippedEntity, startDocument, startPrefixMapping, unparsedEntityDecl, warning
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

fieldsList

protected ArrayList fieldsList
に対応するCurlFieldBeanクラスのインスタンス格納用リスト

recordList

protected ArrayList recordList
に対応するクラスのインスタンス格納用リスト

field

protected Object field
に対応するCurlFieldBean

instance

protected Object instance
に対応するJavaBeans

コンストラクタの詳細

CurlXMLParser

public CurlXMLParser(String path,
                     String beanClassName)
              throws SAXException
このクラス自身をハンドラとしたSAXパーサを作成し、指定されたpathのXMLを パースします。

パラメータ:
path - パース対象のXMLファイルのパス
beanClassName - パース対象のXMLのRecordタグに対応するJavaBeansクラス名
例外:
SAXException

CurlXMLParser

public CurlXMLParser(InputStream stream,
                     String beanClassName)
              throws SAXException
このクラス自身をハンドラとしたSAXパーサを作成し、指定されたInputStreamから取得したXMLを パースします。

パラメータ:
stream - パース対象のXMLを読み込むストリーム
beanClassName - パース対象のXMLのRecordタグに対応するJavaBeansクラス名
例外:
SAXException
メソッドの詳細

getRecordList

public ArrayList getRecordList()
パースした結果のレコード一覧リストを返します。

戻り値:
レコード一覧

getFieldsList

public ArrayList getFieldsList()
パースした結果のフィールド一覧リストを返します。

戻り値:
フィールド一覧

startElement

public void startElement(String uri,
                         String localName,
                         String qName,
                         Attributes atts)
                  throws SAXException
DefaultHandlerのabstractメソッドをオーバーライドします。
Curlで出力されたXML(elaborate-recordsetでの出力)をパースし、 FieldタグをCurlFieldBeanクラスのリストに、Recordタグを指定したJavaBeans クラスのリストに変換します。処理の詳細は次の通りです。
  1. Fieldタグをパースし、フィールド一覧リストに格納する。
  2. Recordタグのパース
    1. 指定されたJavaBeansクラスのインスタンス生成
    2. Recordタグの属性名、属性値を取得
    3. フィールド一覧リスト内のフィールド名を取得
    4. 指定されたJavaBeansクラスのメソッド一覧を検索しRecordタグの 属性のセッターが存在すればセッターを呼び出し属性値をセットする。 存在の有無は"set"+属性値をすべて小文字に変換した文字列がJavaBeans クラスのメソッド一覧内に存在するかで判断する。

例外:
SAXException

createField

protected void createField(Attributes atts)
qNameがFieldの場合のパーサの動作を定義します。 RecordSetのフィールドを解析する部分になります。

パラメータ:
atts -

createRecord

protected void createRecord(Attributes atts)
                     throws SAXException
qNameがRecordの場合のパーサの動作を定義します。 RecordSetのレコードを解析する部分になります。

パラメータ:
atts -
例外:
SAXException

endElement

public void endElement(String uri,
                       String localName,
                       String qName)
                throws SAXException
DefaultHandlerのabstractメソッドをオーバーライドします。

例外:
SAXException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.im_curl (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.im_curl
インタフェース
CurlRecordBeanIF
クラス
CurlFieldBean
CurlXMLComposer
CurlXMLParser


jp.co.intra_mart.foundation.im_curl (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.im_curl

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。

参照:
説明

インタフェースの概要
CurlRecordBeanIF CurlレコードBeanインタフェース
機能は以下の通り
CurlのRecordクラスの属性を格納するBean用のインタフェース

クラスの概要
CurlFieldBean | CurlフィールドBeanクラス 機能は以下の通り CurlのRecordFieldクラスの属性情報を格納するBean
CurlXMLComposer | CurlXML生成クラス 機能は以下の通り Curlで入力可能なXML(elaborate-recordsetで入力可能)を生成します。
CurlXMLParser | CurlXMLパーサクラス 機能は以下の通り Curlで出力されたXML(recordset-to-xmlでの出力)をパースします。

パッケージ jp.co.intra_mart.foundation.im_curl の説明

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。


jp.co.intra_mart.foundation.im_curl クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.im_curl の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.im_curl.CurlFieldBean
    • class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer
    • class org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • class jp.co.intra_mart.foundation.im_curl.CurlXMLParser

インタフェース階層

  • interface jp.co.intra_mart.foundation.im_curl.CurlRecordBeanIF


パッケージ jp.co.intra_mart.foundation.im_curl の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.im_curl の使用

jp.co.intra_mart.foundation.im_curl を使用しているパッケージ
jp.co.intra_mart.foundation.im_curl intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。

jp.co.intra_mart.foundation.im_curl により使用される jp.co.intra_mart.foundation.im_curl のクラス
CurlFieldBean
CurlフィールドBeanクラス
機能は以下の通り
CurlのRecordFieldクラスの属性情報を格納するBean
CurlRecordBeanIF
CurlレコードBeanインタフェース
機能は以下の通り
CurlのRecordクラスの属性を格納するBean用のインタフェース

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.log.LogConstraint の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.log.LogConstraint の使用

jp.co.intra_mart.foundation.log.LogConstraint はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


LogConstraint (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.log
インタフェース LogConstraint

public interface LogConstraint

ログ定数インタフェース。ログで使用する定数値を定義したインターフェース。

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
static String RESPONSE_HEADER_NAME_NEXT_PAGE_TITLE
遷移先画面タイトルをレスポンスヘッダに登録するためのレスポンスヘッダ名。

フィールドの詳細

RESPONSE_HEADER_NAME_NEXT_PAGE_TITLE

public static final String RESPONSE_HEADER_NAME_NEXT_PAGE_TITLE
遷移先画面タイトルをレスポンスヘッダに登録するためのレスポンスヘッダ名。

関連項目:
定数フィールド値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.log (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.log
インタフェース
LogConstraint


jp.co.intra_mart.foundation.log (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.log

インタフェースの概要
LogConstraint ログ定数インタフェース。


jp.co.intra_mart.foundation.log クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.log の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.log.LogConstraint


パッケージ jp.co.intra_mart.foundation.log の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.log の使用

jp.co.intra_mart.foundation.log はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.mail.MailSender の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.mail.MailSender の使用

MailSender を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail メール送信クラスを提供します。

jp.co.intra_mart.foundation.mail.javamail での MailSender の使用

MailSender を実装している jp.co.intra_mart.foundation.mail.javamail のクラス
 class JavaMailSender
JavaMailをラップしたメール送信オブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.MailSenderException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.MailSenderException の使用

MailSenderException を使用しているパッケージ
jp.co.intra_mart.foundation.mail | メール送信に関するクラスを提供します。
jp.co.intra_mart.foundation.mail.javamail | メール送信クラスを提供します。
jp.co.intra_mart.foundation.mail.javamail.listener |
jp.co.intra_mart.foundation.mail.javamail.listener.impl |

jp.co.intra_mart.foundation.mail での MailSenderException の使用

MailSenderException をスローする jp.co.intra_mart.foundation.mail のメソッド
 void MailSender.send()
メールを送信します。

jp.co.intra_mart.foundation.mail.javamail での MailSenderException の使用

MailSenderException をスローする jp.co.intra_mart.foundation.mail.javamail のメソッド
protected void | StandardMail.init() StandardMailオブジェクトを初期化します。
protected Properties | StandardMail.getProperties() JavaMailのSMTPセッションに渡す属性を初期化します。
protected Session | StandardMail.createSession(Properties prop) SMTPセッションを構築します。
protected void | StandardMail.prepareSession(Session session) SMTPセッションに対して操作を行います。
protected void | StandardMail.prepareMimeMessage(MimeMessage message) MIMEメッセージに対して操作を行います。
void | JavaMailSender.send() メールを送信します。

jp.co.intra_mart.foundation.mail.javamail.listener での MailSenderException の使用

MailSenderException をスローする jp.co.intra_mart.foundation.mail.javamail.listener のメソッド
 int MailSendListener.onSendMail(MailSendEvent event)
メール送信が行われたことを通知します。

jp.co.intra_mart.foundation.mail.javamail.listener.impl での MailSenderException の使用

MailSenderException をスローする jp.co.intra_mart.foundation.mail.javamail.listener.impl のメソッド
 int HalfKanaTransrateListener.onSendMail(MailSendEvent event)
メール送信が行われたことを通知します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.javamail.JavaMailSender の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.javamail.JavaMailSender の使用

jp.co.intra_mart.foundation.mail.javamail.JavaMailSender はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.javamail.StandardMail の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.javamail.StandardMail の使用

StandardMail を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail | メール送信クラスを提供します。
jp.co.intra_mart.foundation.mail.javamail.listener |

jp.co.intra_mart.foundation.mail.javamail での StandardMail の使用

StandardMail 型のパラメータを持つ jp.co.intra_mart.foundation.mail.javamail のコンストラクタ
JavaMailSender(StandardMail mail)
JavaMailSenderを新規に作成します。

jp.co.intra_mart.foundation.mail.javamail.listener での StandardMail の使用

StandardMail を返す jp.co.intra_mart.foundation.mail.javamail.listener のメソッド
 StandardMail MailSendEvent.getMail()
メールの属性を取得します。

StandardMail 型のパラメータを持つ jp.co.intra_mart.foundation.mail.javamail.listener のメソッド
 void MailSendEvent.setMail(StandardMail mail)
メールの属性を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent の使用

MailSendEvent を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail.listener
jp.co.intra_mart.foundation.mail.javamail.listener.impl

jp.co.intra_mart.foundation.mail.javamail.listener での MailSendEvent の使用

MailSendEvent 型のパラメータを持つ jp.co.intra_mart.foundation.mail.javamail.listener のメソッド
 int MailSendListener.onSendMail(MailSendEvent event)
メール送信が行われたことを通知します。

jp.co.intra_mart.foundation.mail.javamail.listener.impl での MailSendEvent の使用

MailSendEvent 型のパラメータを持つ jp.co.intra_mart.foundation.mail.javamail.listener.impl のメソッド
 int HalfKanaTransrateListener.onSendMail(MailSendEvent event)
メール送信が行われたことを通知します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener の使用

MailSendListener を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail.listener.impl

jp.co.intra_mart.foundation.mail.javamail.listener.impl での MailSendListener の使用

MailSendListener を実装している jp.co.intra_mart.foundation.mail.javamail.listener.impl のクラス
 class HalfKanaTransrateListener
送信メールの件名と本文に含まれる半角カナ文字を、全角カナ文字に変換するリスナです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


MailSendEvent (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.listener
クラス MailSendEvent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent
public class MailSendEvent
extends Object

メール送信イベントです。

導入されたバージョン:
6.1.8

コンストラクタの概要
MailSendEvent()
SendMailEventを新規に生成します。
メソッドの概要
StandardMail | getMail() メールの属性を取得します。
Session | getSession() メール送信のセッションを取得します。
void | setMail(StandardMail mail) メールの属性を設定します。
void | setSession(Session session) メール送信のセッションを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MailSendEvent

public MailSendEvent()
SendMailEventを新規に生成します。

メソッドの詳細

getMail

public StandardMail getMail()
メールの属性を取得します。

戻り値:
メールの属性

setMail

public void setMail(StandardMail mail)
メールの属性を設定します。

パラメータ:
mail - メールの属性

getSession

public Session getSession()
メール送信のセッションを取得します。

戻り値:
セッション

setSession

public void setSession(Session session)
メール送信のセッションを設定します。

パラメータ:
session - セッション
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MailSendListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.listener
インタフェース MailSendListener

既知の実装クラスの一覧:
HalfKanaTransrateListener
public interface MailSendListener

メール送信イベントのListenerインタフェースです。

リスナを利用するには、MailSendListenerの実装クラスを作成し、 onSendMail(MailSendEvent)メソッドを実装してください。 そのクラス名をServerManager上の /conf/mail/mailSendListener.xmlに記述してください。以下はその記述例です。

 <listener-config>
   <listener>
     <listener-class>foo.TestListener1</listener-class>
   </listener>
   <listener>
     <listener-class>foo.TestListener2</listener-class>
   </listener>
 </listener-config>

リスナはメール送信時に、記述されている順に実行されます。 また、リスナのスキップや送信の中止も可能です。 通常onSendMail(MailSendEvent)メソッドの戻り値はCONTINUEです。 リスナ実行中に以降のリスナをスキップする場合はSKIP_LISTENERを返却してください。 メール送信を行わない場合はSTOP_MAILSENDを返却してください。

導入されたバージョン:
6.1.8

フィールドの概要
static int | CONTINUE リスナー処理を続行し、メール送信を行います。
static int | SKIP_LISTENER リスナー処理を中止し、メール送信を行います。
static int | STOP_MAILSEND リスナー処理を中止し、メール送信を中止します。
メソッドの概要
 int onSendMail(MailSendEvent event)
メール送信が行われたことを通知します。

フィールドの詳細

CONTINUE

public static final int CONTINUE
リスナー処理を続行し、メール送信を行います。

関連項目:
定数フィールド値

SKIP_LISTENER

public static final int SKIP_LISTENER
リスナー処理を中止し、メール送信を行います。

関連項目:
定数フィールド値

STOP_MAILSEND

public static final int STOP_MAILSEND
リスナー処理を中止し、メール送信を中止します。

関連項目:
定数フィールド値
メソッドの詳細

onSendMail

public int onSendMail(MailSendEvent event)
               throws MailSenderException
メール送信が行われたことを通知します。
メール送信イベントを受け取り、次のリスナーに処理を移します。

パラメータ:
event - メール送信イベント
例外:
MailSenderException - リスナーで例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.mail.javamail.listener (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.mail.javamail.listener
インタフェース
MailSendListener
クラス
MailSendEvent


jp.co.intra_mart.foundation.mail.javamail.listener (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.listener

インタフェースの概要
MailSendListener メール送信イベントのListenerインタフェースです。

クラスの概要
MailSendEvent メール送信イベントです。


jp.co.intra_mart.foundation.mail.javamail.listener クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.listener の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent

インタフェース階層

  • interface jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener


パッケージ jp.co.intra_mart.foundation.mail.javamail.listener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.mail.javamail.listener の使用

jp.co.intra_mart.foundation.mail.javamail.listener を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail.listener
jp.co.intra_mart.foundation.mail.javamail.listener.impl

jp.co.intra_mart.foundation.mail.javamail.listener により使用される jp.co.intra_mart.foundation.mail.javamail.listener のクラス
MailSendEvent
メール送信イベントです。

jp.co.intra_mart.foundation.mail.javamail.listener.impl により使用される jp.co.intra_mart.foundation.mail.javamail.listener のクラス
MailSendEvent
メール送信イベントです。
MailSendListener
メール送信イベントのListenerインタフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.mail.javamail.model.AttachmentFile の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.mail.javamail.model.AttachmentFile の使用

jp.co.intra_mart.foundation.mail.javamail.model.AttachmentFile はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.mail.javamail.model.MailAddress の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.mail.javamail.model.MailAddress の使用

MailAddress を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail メール送信クラスを提供します。

jp.co.intra_mart.foundation.mail.javamail での MailAddress の使用

MailAddress を返す jp.co.intra_mart.foundation.mail.javamail のメソッド
 MailAddress StandardMail.getFrom()
Fromを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AttachmentFile (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.model
インタフェース AttachmentFile

public interface AttachmentFile

添付ファイルのモデルです。

導入されたバージョン:
6.1.8

メソッドの概要
String | getFile() 添付ファイルを取得します。
String | getName() 添付ファイルのファイル名を取得します。

メソッドの詳細

getName

public String getName()
添付ファイルのファイル名を取得します。

戻り値:
ファイル名

getFile

public String getFile()
添付ファイルを取得します。

戻り値:
添付ファイル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MailAddress (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.model
インタフェース MailAddress

public interface MailAddress

メールアドレスのモデルです。

導入されたバージョン:
6.1.8

メソッドの概要
String | getAddress() メールアドレスを取得します。
String | getPersonal() 名前を取得します。

メソッドの詳細

getPersonal

public String getPersonal()
名前を取得します。

戻り値:
名前

getAddress

public String getAddress()
メールアドレスを取得します。

戻り値:
メールアドレス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.mail.javamail.model (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.mail.javamail.model
インタフェース
AttachmentFile
MailAddress


jp.co.intra_mart.foundation.mail.javamail.model (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.model

インタフェースの概要
AttachmentFile | 添付ファイルのモデルです。
MailAddress | メールアドレスのモデルです。


jp.co.intra_mart.foundation.mail.javamail.model クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.model の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.mail.javamail.model.AttachmentFile
  • interface jp.co.intra_mart.foundation.mail.javamail.model.MailAddress


パッケージ jp.co.intra_mart.foundation.mail.javamail.model の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.mail.javamail.model の使用

jp.co.intra_mart.foundation.mail.javamail.model を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail メール送信クラスを提供します。

jp.co.intra_mart.foundation.mail.javamail により使用される jp.co.intra_mart.foundation.mail.javamail.model のクラス
MailAddress
メールアドレスのモデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException の使用

JavaMailPropertyException を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail.property

jp.co.intra_mart.foundation.mail.javamail.property での JavaMailPropertyException の使用

JavaMailPropertyException をスローする jp.co.intra_mart.foundation.mail.javamail.property のメソッド
static JavaMailPropertyHandler JavaMailPropertyHandler.getInstance()
JavaMailPropertyHandlerのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler の使用

JavaMailPropertyHandler を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail.property

jp.co.intra_mart.foundation.mail.javamail.property での JavaMailPropertyHandler の使用

JavaMailPropertyHandler を返す jp.co.intra_mart.foundation.mail.javamail.property のメソッド
static JavaMailPropertyHandler JavaMailPropertyHandler.getInstance()
JavaMailPropertyHandlerのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl の使用

jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


JavaMailPropertyException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.property
クラス JavaMailPropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException
すべての実装インタフェース:
Serializable
public class JavaMailPropertyException
extends Exception

JavaMailSenderの設定に関する情報を提供する例外です。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
JavaMailPropertyException()
JavaMailPropertyExceptionを構築します。
JavaMailPropertyException(String message)
指定された詳細メッセージを使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyException(String message, Throwable cause)
指定された詳細メッセージおよび原因を使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyException(Throwable cause)
指定された原因を使用してJavaMailPropertyExceptionを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

JavaMailPropertyException

public JavaMailPropertyException()
JavaMailPropertyExceptionを構築します。

JavaMailPropertyException

public JavaMailPropertyException(String message)
指定された詳細メッセージを使用してJavaMailPropertyExceptionを構築します。

パラメータ:
message -

JavaMailPropertyException

public JavaMailPropertyException(String message,
                                 Throwable cause)
指定された詳細メッセージおよび原因を使用してJavaMailPropertyExceptionを構築します。

パラメータ:
message -
cause -

JavaMailPropertyException

public JavaMailPropertyException(Throwable cause)
指定された原因を使用してJavaMailPropertyExceptionを構築します。

パラメータ:
cause -
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


JavaMailPropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.property
クラス JavaMailPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler
public class JavaMailPropertyHandler
extends Object

JavaMailSenderの設定を保持します。

導入されたバージョン:
5.0.2

メソッドの概要
String | getCharset(Locale locale) キャラクターセットを取得します。
String | getContentTransferEncoding(Locale locale) Content-Transfer-Encodingを取得します。
String | getContentType(String ext) コンテントタイプを取得します。
boolean | getDebugOption() JavaMailに設定するデバック設定の有無を取得します。
static JavaMailPropertyHandler | getInstance() JavaMailPropertyHandlerのインスタンスを取得します。
Collection | getListeners() メール送信リスナを取得します。
String | getMimeEncoding(Locale locale) MIMEエンコードを取得します。
int | getSMTPConnectionTimeout() SMTPサーバへのコネクションタイムアウト時間を取得します。
String | getSMTPPassword() SMTP認証のパスワードを取得します
int | getSMTPTimeout() SMTPサーバとの入出力タイムアウト時間を取得します。
String | getSMTPUser() SMTP認証のユーザを取得します
String | getXMailerHeader() 送信メールに付加するX-Mailerヘッダを取得します。
boolean | isEnableSMTPAuth() SMTP認証の有効/無効を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getInstance

public static JavaMailPropertyHandler getInstance()
                                           throws JavaMailPropertyException
JavaMailPropertyHandlerのインスタンスを取得します。

戻り値:
JavaMailPropertyHandlerのインスタンス
例外:
JavaMailPropertyException

getContentType

public String getContentType(String ext)
コンテントタイプを取得します。

パラメータ:
ext - ドットを含む拡張子
戻り値:
コンテントタイプ

getXMailerHeader

public String getXMailerHeader()
送信メールに付加するX-Mailerヘッダを取得します。

戻り値:
X-Mailerヘッダ

getDebugOption

public boolean getDebugOption()
JavaMailに設定するデバック設定の有無を取得します。

戻り値:
デバック設定

getSMTPConnectionTimeout

public int getSMTPConnectionTimeout()
SMTPサーバへのコネクションタイムアウト時間を取得します。

戻り値:
タイムアウト時間

getSMTPTimeout

public int getSMTPTimeout()
SMTPサーバとの入出力タイムアウト時間を取得します。

戻り値:
タイムアウト時間

isEnableSMTPAuth

public boolean isEnableSMTPAuth()
SMTP認証の有効/無効を取得します。

戻り値:
SMTPの有効/無効
導入されたバージョン:
7.0.2

getSMTPUser

public String getSMTPUser()
SMTP認証のユーザを取得します

戻り値:
ユーザ
導入されたバージョン:
7.0.2

getSMTPPassword

public String getSMTPPassword()
SMTP認証のパスワードを取得します

戻り値:
パスワード
導入されたバージョン:
7.0.2

getCharset

public String getCharset(Locale locale)
キャラクターセットを取得します。

パラメータ:
locale - ロケール
戻り値:
キャラクターセット

getMimeEncoding

public String getMimeEncoding(Locale locale)
MIMEエンコードを取得します。

パラメータ:
locale - ロケール
戻り値:
エンコード

getContentTransferEncoding

public String getContentTransferEncoding(Locale locale)
Content-Transfer-Encodingを取得します。

パラメータ:
locale - ロケール
戻り値:
Content-Transfer-Encoding

getListeners

public Collection getListeners()
メール送信リスナを取得します。
コレクションの要素はMailSendListenerのインスタンスです。

戻り値:
メール送信リスナ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


JavaMailPropertyHandlerInitializerImpl (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.property
クラス JavaMailPropertyHandlerInitializerImpl

java.lang.Object
    拡張 jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl
すべての実装インタフェース:
jp.co.intra_mart.system.service.ApplicationInitializer
public class JavaMailPropertyHandlerInitializerImpl
extends Object
implements jp.co.intra_mart.system.service.ApplicationInitializer

JavaMailPropertyHandlerの初期化クラス。

JavaMailSenderの設定を保持するJavaMailPropertyHandlerの初期化を行います。 アプリケーションライタイム起動時に呼ばれます。

導入されたバージョン:
6.0.2

コンストラクタの概要
JavaMailPropertyHandlerInitializerImpl()
メソッドの概要
 void initialize()
初期化処理を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

JavaMailPropertyHandlerInitializerImpl

public JavaMailPropertyHandlerInitializerImpl()
メソッドの詳細

initialize

public void initialize()
初期化処理を行います。

定義:
インタフェース jp.co.intra_mart.system.service.ApplicationInitializer 内の initialize
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.mail.javamail.property (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.mail.javamail.property
クラス
JavaMailPropertyHandler
JavaMailPropertyHandlerInitializerImpl
例外
JavaMailPropertyException


jp.co.intra_mart.foundation.mail.javamail.property (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.property

クラスの概要
JavaMailPropertyHandler | JavaMailSenderの設定を保持します。
JavaMailPropertyHandlerInitializerImpl | JavaMailPropertyHandlerの初期化クラス。

例外の概要
JavaMailPropertyException JavaMailSenderの設定に関する情報を提供する例外です。


jp.co.intra_mart.foundation.mail.javamail.property クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.property の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler
    • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl (implements jp.co.intra_mart.system.service.ApplicationInitializer)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException


パッケージ jp.co.intra_mart.foundation.mail.javamail.property の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.mail.javamail.property の使用

jp.co.intra_mart.foundation.mail.javamail.property を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail.property

jp.co.intra_mart.foundation.mail.javamail.property により使用される jp.co.intra_mart.foundation.mail.javamail.property のクラス
JavaMailPropertyException
JavaMailSenderの設定に関する情報を提供する例外です。
JavaMailPropertyHandler
JavaMailSenderの設定を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


JavaMailSender (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail
クラス JavaMailSender

java.lang.Object
    拡張 jp.co.intra_mart.foundation.mail.javamail.JavaMailSender
すべての実装インタフェース:
MailSender
public class JavaMailSender
extends Object
implements MailSender

JavaMailをラップしたメール送信オブジェクトです。
メールの送信情報はStandardMailのインスタンスにより 決定されます。

JavaMailSenderはリスナを実装することで、メール送信前に任意の処理を実行することが可能です。
リスナでは送信メールの情報を参照したり、送信を中止することも可能です。 リスナの詳しい説明についてはMailSendListener を参照してください。

導入されたバージョン:
5.0
関連項目:
StandardMail

コンストラクタの概要
JavaMailSender(StandardMail mail)
JavaMailSenderを新規に作成します。
メソッドの概要
 void send()
メールを送信します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

JavaMailSender

public JavaMailSender(StandardMail mail)
JavaMailSenderを新規に作成します。

パラメータ:
mail - 送信メール
メソッドの詳細

send

public void send()
          throws MailSenderException
メールを送信します。

定義:
インタフェース MailSender 内の send
例外:
MailSenderException - メール送信時に例外が発生。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.mail.javamail (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.mail.javamail
クラス
JavaMailSender
StandardMail


jp.co.intra_mart.foundation.mail.javamail (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail

メール送信クラスを提供します。

参照:
説明

クラスの概要
JavaMailSender | JavaMailをラップしたメール送信オブジェクトです。
StandardMail | 送信するメールの属性を保管します。

パッケージ jp.co.intra_mart.foundation.mail.javamail の説明

メール送信クラスを提供します。


jp.co.intra_mart.foundation.mail.javamail クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender (implements jp.co.intra_mart.foundation.mail.MailSender)
    • class jp.co.intra_mart.foundation.mail.javamail.StandardMail


パッケージ jp.co.intra_mart.foundation.mail.javamail の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.mail.javamail の使用

jp.co.intra_mart.foundation.mail.javamail を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail | メール送信クラスを提供します。
jp.co.intra_mart.foundation.mail.javamail.listener |

jp.co.intra_mart.foundation.mail.javamail により使用される jp.co.intra_mart.foundation.mail.javamail のクラス
StandardMail
送信するメールの属性を保管します。

jp.co.intra_mart.foundation.mail.javamail.listener により使用される jp.co.intra_mart.foundation.mail.javamail のクラス
StandardMail
送信するメールの属性を保管します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardMail (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail
クラス StandardMail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.mail.javamail.StandardMail
public class StandardMail
extends Object

送信するメールの属性を保管します。

  • キャラクターセット、エンコード
    このオブジェクトが保持するメールのキャラクターセット、エンコディングの設定は ロケールに依存します。ロケール毎の設定は定義ファイルをにより決定されます。
    ServerManager上に /conf/mail/encode.properties として、定義ファイルを配置してください。

    指定可能なキーの一覧
    charset | キャラクターセット
    mimeEncoding | MIMEエンコード (B or Q)
    contentTransferEncoding | ボディのエンコード

  • SMTP Authentication
    StandardMail は SMTP Authentication に対応しています。有効にする場合は ServerManager 上の /conf/mail/smtpAuth.properties を編集してください。

    enable SMTP Authの有効
    (true or false)
    user | ユーザID
    password | パスワード

導入されたバージョン:
5.0
関連項目:
JavaMailSender

コンストラクタの概要
StandardMail()
システムのロケールからメール属性オブジェクトを新規に作成します。
StandardMail(Locale locale)
ロケールを指定してメール属性オブジェクトを新規に作成します。
メソッドの概要
void | addAttachment(String filename, String file) 添付ファイルを追加します。
void | addBcc(String address) Bccを追加します。
void | addBcc(String address, String personal) Bccを追加します。
void | addCc(String address) Ccを追加します。
void | addCc(String address, String personal) Ccを追加します。
void | addHeader(String name, String value) ヘッダーを追加します。
void | addReplyTo(String replyto) ReplyToを追加します。
void | addTo(String address) Toを追加します。
void | addTo(String address, String personal) Toを追加します。
protected Session | createSession(Properties prop) SMTPセッションを構築します。
Collection | getAttachment() 添付ファイルを取得します。
Collection | getBcc() Bccの一覧を取得します。
Collection | getCc() Ccの一覧を取得します。
MailAddress | getFrom() Fromを取得します。
Locale | getLocale() ロケールを取得します。
protected Properties | getProperties() JavaMailのSMTPセッションに渡す属性を初期化します。
String | getSubject() Subjectを取得します。
String | getText() 本文を取得します。
Collection | getTo() Toの一覧を取得します。
protected void | init() StandardMailオブジェクトを初期化します。
protected void | prepareMimeMessage(MimeMessage message) MIMEメッセージに対して操作を行います。
protected void | prepareSession(Session session) SMTPセッションに対して操作を行います。
void | setFrom(String address) Fromを設定します。
void | setFrom(String address, String personal) Fromを設定します。
void | setSubject(String subject) Subjectを設定します。
void | setText(String text) 本文を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardMail

public StandardMail()
システムのロケールからメール属性オブジェクトを新規に作成します。

StandardMail

public StandardMail(Locale locale)
ロケールを指定してメール属性オブジェクトを新規に作成します。

パラメータ:
locale - 送信先ロケール
メソッドの詳細

init

protected void init()
             throws MailSenderException
StandardMailオブジェクトを初期化します。 このメソッドはJavaMailSender.send()から呼ばれます。

例外:
MailSenderException - StandardMailオブジェクトを初期化時に例外が発生。

getLocale

public Locale getLocale()
ロケールを取得します。

戻り値:
ロケール

getProperties

protected Properties getProperties()
                            throws MailSenderException
JavaMailのSMTPセッションに渡す属性を初期化します。

ここではSMTPサーバのホスト及びポートを設定します。
このメソッドはJavaMailSender.send()から呼ばれます。

戻り値:
属性
例外:
MailSenderException - 属性設定時に例外が発生。

createSession

protected Session createSession(Properties prop)
                         throws MailSenderException
SMTPセッションを構築します。 SMTP認証が有効の場合は、認証情報が含まれたセッションを構築します。

パラメータ:
prop - 属性
戻り値:
SMTPセッション
例外:
MailSenderException - SMTPセッション構築時に例外が発生
導入されたバージョン:
7.0.2

prepareSession

protected void prepareSession(Session session)
                       throws MailSenderException
SMTPセッションに対して操作を行います。

ここでは、JavaMailにデバックオプションを設定します。 設定値は"conf/mail/javaMail.properties"の設定値が有効となります。
このメソッドはJavaMailSender.send()から呼ばれます。

パラメータ:
session - SMTPセッション
例外:
MailSenderException - セッション操作中に例外が発生。

prepareMimeMessage

protected void prepareMimeMessage(MimeMessage message)
                           throws MailSenderException
MIMEメッセージに対して操作を行います。 このメソッドはJavaMailSender.send()から呼ばれます。

パラメータ:
message - メッセージ
例外:
MailSenderException - メッセージ操作中に例外が発生。

addHeader

public void addHeader(String name,
                      String value)
ヘッダーを追加します。

パラメータ:
name - ヘッダーの名前
value - ヘッダーの値

addReplyTo

public void addReplyTo(String replyto)
ReplyToを追加します。

パラメータ:
replyto - ReplyToに追加するメールアドレス

setFrom

public void setFrom(String address)
Fromを設定します。

パラメータ:
address - メールアドレス

setFrom

public void setFrom(String address,
                    String personal)
Fromを設定します。

パラメータ:
address - メールアドレス
personal - 名前

setSubject

public void setSubject(String subject)
Subjectを設定します。

パラメータ:
subject - Subject

addTo

public void addTo(String address)
Toを追加します。

パラメータ:
address - メールアドレス

addTo

public void addTo(String address,
                  String personal)
Toを追加します。

パラメータ:
address - メールアドレス
personal - 名前

addCc

public void addCc(String address)
Ccを追加します。

パラメータ:
address - メールアドレス

addCc

public void addCc(String address,
                  String personal)
Ccを追加します。

パラメータ:
address - メールアドレス
personal - 名前

addBcc

public void addBcc(String address)
Bccを追加します。

パラメータ:
address - メールアドレス

addBcc

public void addBcc(String address,
                   String personal)
Bccを追加します。

パラメータ:
address - メールアドレス
personal - 名前

setText

public void setText(String text)
本文を設定します。

パラメータ:
text - 本文

addAttachment

public void addAttachment(String filename,
                          String file)
添付ファイルを追加します。

パラメータ:
filename - 添付ファイル名
file - ファイル

getAttachment

public Collection getAttachment()
添付ファイルを取得します。
コレクションの要素はAttachmentFileのインスタンスです。

戻り値:
添付ファイル

getSubject

public String getSubject()
Subjectを取得します。

戻り値:
Subject

getText

public String getText()
本文を取得します。

戻り値:
本文

getFrom

public MailAddress getFrom()
Fromを取得します。

戻り値:
from

getTo

public Collection getTo()
Toの一覧を取得します。
コレクションの要素はMailAddressのインスタンスです。

戻り値:

getCc

public Collection getCc()
Ccの一覧を取得します。
コレクションの要素はMailAddressのインスタンスです。

戻り値:

getBcc

public Collection getBcc()
Bccの一覧を取得します。
コレクションの要素はMailAddressのインスタンスです。

戻り値:
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MailSender (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail
インタフェース MailSender

既知の実装クラスの一覧:
JavaMailSender
public interface MailSender

メールを送信するためのインターフェースです。

導入されたバージョン:
5.0

メソッドの概要
 void send()
メールを送信します。

メソッドの詳細

send

public void send()
          throws MailSenderException
メールを送信します。

例外:
MailSenderException - メール送信時に例外が発生。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MailSenderException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail
クラス MailSenderException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.mail.MailSenderException
すべての実装インタフェース:
Serializable
public class MailSenderException
extends Exception

メール送信時またはその他の不正な処理に関する情報を提供する例外です。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
MailSenderException()
MailSenderExceptionを構築します。
MailSenderException(String message)
指定された詳細メッセージを使用してMailSenderExceptionを構築します。
MailSenderException(String message, Throwable cause)
指定された詳細メッセージおよび原因を使用してMailSenderExceptionを構築します。
MailSenderException(Throwable cause)
指定された原因を使用してMailSenderExceptionを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MailSenderException

public MailSenderException()
MailSenderExceptionを構築します。

MailSenderException

public MailSenderException(String message)
指定された詳細メッセージを使用してMailSenderExceptionを構築します。

パラメータ:
message -

MailSenderException

public MailSenderException(String message,
                           Throwable cause)
指定された詳細メッセージおよび原因を使用してMailSenderExceptionを構築します。

パラメータ:
message -
cause -

MailSenderException

public MailSenderException(Throwable cause)
指定された原因を使用してMailSenderExceptionを構築します。

パラメータ:
cause -
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.mail (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.mail
インタフェース
MailSender
例外
MailSenderException


jp.co.intra_mart.foundation.mail (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail

メール送信に関するクラスを提供します。

参照:
説明

インタフェースの概要
MailSender メールを送信するためのインターフェースです。

例外の概要
MailSenderException メール送信時またはその他の不正な処理に関する情報を提供する例外です。

パッケージ jp.co.intra_mart.foundation.mail の説明

メール送信に関するクラスを提供します。


jp.co.intra_mart.foundation.mail クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.mail.MailSenderException

インタフェース階層

  • interface jp.co.intra_mart.foundation.mail.MailSender


パッケージ jp.co.intra_mart.foundation.mail の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.mail の使用

jp.co.intra_mart.foundation.mail を使用しているパッケージ
jp.co.intra_mart.foundation.mail | メール送信に関するクラスを提供します。
jp.co.intra_mart.foundation.mail.javamail | メール送信クラスを提供します。
jp.co.intra_mart.foundation.mail.javamail.listener |
jp.co.intra_mart.foundation.mail.javamail.listener.impl |

jp.co.intra_mart.foundation.mail により使用される jp.co.intra_mart.foundation.mail のクラス
MailSenderException
メール送信時またはその他の不正な処理に関する情報を提供する例外です。

jp.co.intra_mart.foundation.mail.javamail により使用される jp.co.intra_mart.foundation.mail のクラス
MailSender
メールを送信するためのインターフェースです。
MailSenderException
メール送信時またはその他の不正な処理に関する情報を提供する例外です。

jp.co.intra_mart.foundation.mail.javamail.listener により使用される jp.co.intra_mart.foundation.mail のクラス
MailSenderException
メール送信時またはその他の不正な処理に関する情報を提供する例外です。

jp.co.intra_mart.foundation.mail.javamail.listener.impl により使用される jp.co.intra_mart.foundation.mail のクラス
MailSenderException
メール送信時またはその他の不正な処理に関する情報を提供する例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventAccessInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventAccessInfo の使用

EventAccessInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventAccessInfo の使用

EventAccessInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
 EventAccessInfo NavigatorAuthenticateItem.getAccessInfo()

EventAccessInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
 void NavigatorAuthenticateItem.setAccessInfo(EventAccessInfo accessInfo)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventFlow の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventFlow の使用

EventFlow を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventFlow の使用

EventFlow を返す jp.co.intra_mart.foundation.navigator のメソッド
EventFlow | StandardEventNavigatorAccessor.getEventFlow(EventNavigatorManager manager, String eventFlowId) イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
EventFlow | StandardEventNavigatorAccessor.copyEventFlow(EventNavigatorManager manager, String eventFlowId) イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
EventFlow[] | StandardEventNavigatorAccessor.getEventFlows(EventNavigatorManager manager) すべてのイベントフローを取得します。
EventFlow | EventNavigatorManager.getEventFlow(String eventFllowId) イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
EventFlow[] | EventNavigatorManager.getEventFlows() イベントフローの取得（全件） 全イベントフローを取得し、返却する。
EventFlow | EventNavigatorManager.copyEventFlow(String eventFllowId) イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
EventFlow | EventNavigatorAccessor.getEventFlow(EventNavigatorManager manager, String eventFllowId) イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
EventFlow[] | EventNavigatorAccessor.getEventFlows(EventNavigatorManager manager) すべてのイベントフローを取得します。
EventFlow | EventNavigatorAccessor.copyEventFlow(EventNavigatorManager manager, String eventFllowId) イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。

EventFlow 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | StandardEventNavigatorAccessor.updateEventFlow(EventNavigatorManager manager, EventFlow eventFlow) イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
void | StandardEventNavigatorAccessor.registEventFlow(EventNavigatorManager manager, EventFlow eventFlow) イベントフローを更新します。
void | EventNavigatorManager.registEventFlow(EventFlow eventFllow) イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
void | EventNavigatorManager.updateEventFlow(EventFlow eventFllow) イベントフローの更新 イベントフロー情報をDB更新する。
void | EventNavigatorAccessor.registEventFlow(EventNavigatorManager manager, EventFlow eventFllow) イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
void | EventNavigatorAccessor.updateEventFlow(EventNavigatorManager manager, EventFlow eventFllow) イベントフローの更新 イベントフロー情報をDB更新する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventFlowInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventFlowInfo の使用

EventFlowInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventFlowInfo の使用

EventFlowInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
EventFlowInfo[] | StandardEventNavigatorAccessor.getEventFlowInfos(EventNavigatorManager manager, String searchTitle, boolean permissionCheck, int currentPage) イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
EventFlowInfo[] | EventNavigatorManager.getEventFlowInfos(String searchTitle, boolean permissionCheck, int currentPage) イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
EventFlowInfo[] | EventNavigatorAccessor.getEventFlowInfos(EventNavigatorManager manager, String searchTitle, boolean permissionCheck, int currentPage) イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。

EventFlowInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | StandardEventNavigatorAccessor.setOrderSortNum(EventNavigatorManager manager, EventFlowInfo[] eventFlowInfos) 表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
void | EventNavigatorManager.setOrderSortNum(EventFlowInfo[] eventFlowInfos) 表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
void | EventNavigatorAccessor.setOrderSortNum(EventNavigatorManager manager, EventFlowInfo[] eventFlowInfos) 表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventHistoryInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventHistoryInfo の使用

EventHistoryInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventHistoryInfo の使用

EventHistoryInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
EventHistoryInfo[] | EventResultItemInfo.getEventHistory() イベント履歴情報リスト取得
EventHistoryInfo[] | EventItemInfo.getEventHistory() イベント履歴情報リスト取得

EventHistoryInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | EventResultItemInfo.setEventHistory(EventHistoryInfo[] eventHistory) イベント履歴情報リスト設定
void | EventItemInfo.setEventHistory(EventHistoryInfo[] eventHistory) イベント履歴情報リスト設定

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventItem の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventItem の使用

EventItem を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventItem の使用

EventItem を返す jp.co.intra_mart.foundation.navigator のメソッド
EventItem | SelectItem.getNextEventItem()
EventItem | EventFlow.getStartEventItem()

EventItem 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | SelectItem.setNextEventItem(EventItem nextEventItem)
void | EventFlow.setStartEventItem(EventItem startEventItem)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventItemInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventItemInfo の使用

EventItemInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventItemInfo の使用

EventItemInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
EventItemInfo | StandardEventNavigatorAccessor.getEventItemInfo(EventNavigatorManager manager, String eventFlowId, String eventItemId) イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
EventItemInfo | EventNavigatorManager.getEventItemInfo(String eventFllowId, String eventItemId) イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
EventItemInfo | EventNavigatorAccessor.getEventItemInfo(EventNavigatorManager manager, String eventFllowId, String eventItemId) イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor の使用

EventNavigatorAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventNavigatorAccessor の使用

EventNavigatorAccessor を実装している jp.co.intra_mart.foundation.navigator のクラス
 class StandardEventNavigatorAccessor
イベントナビゲーター管理アクセッサクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventNavigatorConst の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventNavigatorConst の使用

jp.co.intra_mart.foundation.navigator.EventNavigatorConst はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventNavigatorException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventNavigatorException の使用

EventNavigatorException を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventNavigatorException の使用

EventNavigatorException をスローする jp.co.intra_mart.foundation.navigator のメソッド
void | StandardEventNavigatorImporter.doImport(EventNavigatorManager manager, InputStream inputStream) インポートを行います。
boolean | StandardEventNavigatorImporter.checkStrLength(String str, int length) 文字列チェック（共通）
boolean | StandardEventNavigatorImporter.checkLocale(String keyLocale, String[] locales) ロケールチェック（共通）
void | StandardEventNavigatorImporter.checkTitleInfo(NavigatorItem item, String[] locales, String strURI) タイトル情報のロケールマッチング（共通）
void | StandardEventNavigatorExporter.doExport(EventNavigatorManager manager, OutputStream outputStream, boolean editFlag) エクスポートを行います。
EventFlowInfo[] | StandardEventNavigatorAccessor.getEventFlowInfos(EventNavigatorManager manager, String searchTitle, boolean permissionCheck, int currentPage) イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
void | StandardEventNavigatorAccessor.deleteEventFlow(EventNavigatorManager manager, String eventFlowId) イベントフローの削除 イベントフローIDから、イベントフローを削除する。
EventFlow | StandardEventNavigatorAccessor.getEventFlow(EventNavigatorManager manager, String eventFlowId) イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
void | StandardEventNavigatorAccessor.updateEventFlow(EventNavigatorManager manager, EventFlow eventFlow) イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
EventFlow | StandardEventNavigatorAccessor.copyEventFlow(EventNavigatorManager manager, String eventFlowId) イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
EventItemInfo | StandardEventNavigatorAccessor.getEventItemInfo(EventNavigatorManager manager, String eventFlowId, String eventItemId) イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
EventResultItemInfo | StandardEventNavigatorAccessor.getEventResultItemInfo(EventNavigatorManager manager, String eventFlowId, String resultItemId) ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
String | StandardEventNavigatorAccessor.addEventResultItemInfo(EventNavigatorManager manager, String userId, String eventFlowId, EventResultItemInfo resultItemInfo) 保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
void | StandardEventNavigatorAccessor.deleteSaveResultHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。
SaveEventResultItemInfo | StandardEventNavigatorAccessor.getSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
void | StandardEventNavigatorAccessor.updateEventResultItemInfo(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | StandardEventNavigatorAccessor.updateEventResultItemInfoTitle(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
SaveEventResultItemInfo[] | StandardEventNavigatorAccessor.getSaveEventResultItemInfos(EventNavigatorManager manager, String userId, String searchTitle, String sortKey, String oeder, int currentPage) 保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
void | StandardEventNavigatorAccessor.removeSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String saveResultItemId) 保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。
void | StandardEventNavigatorAccessor.addFavoriteSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String saveResultItemId) 保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。
SaveEventResultItemInfo[] | StandardEventNavigatorAccessor.getSaveEventResultItemInfosHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
void | StandardEventNavigatorAccessor.setOrderSortNum(EventNavigatorManager manager, EventFlowInfo[] eventFlowInfos) 表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
void | StandardEventNavigatorAccessor.setViewOpen(EventNavigatorManager manager, String eventFlowId, String open) 表示設定 イベントフロー情報に表示／非表示を設定する。
String[] | StandardEventNavigatorAccessor.getEventFlowIds(EventNavigatorManager manager) すべてのイベントフローIDを取得します。
EventFlow[] | StandardEventNavigatorAccessor.getEventFlows(EventNavigatorManager manager) すべてのイベントフローを取得します。
LinkPageInfo | StandardEventNavigatorAccessor.getLinkPageInfo(EventNavigatorManager manager, String eventFlowId, String eventResultId, String resultPageId) 結果ページ情報を取得します。
LinkPageInfo | StandardEventNavigatorAccessor.getSaveLinkPageInfo(EventNavigatorManager manager, String userId, String eventResultId, String resultPageId) 保存結果ページ情報を取得します。
void | StandardEventNavigatorAccessor.registEventFlow(EventNavigatorManager manager, EventFlow eventFlow) イベントフローを更新します。
EventFlowInfo[] | EventNavigatorManager.getEventFlowInfos(String searchTitle, boolean permissionCheck, int currentPage) イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
void | EventNavigatorManager.deleteEventFlow(String eventFlowId) イベントフローの削除 イベントフローIDから、イベントフローを削除する。
EventFlow | EventNavigatorManager.getEventFlow(String eventFllowId) イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
EventFlow[] | EventNavigatorManager.getEventFlows() イベントフローの取得（全件） 全イベントフローを取得し、返却する。
void | EventNavigatorManager.registEventFlow(EventFlow eventFllow) イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
EventFlow | EventNavigatorManager.copyEventFlow(String eventFllowId) イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
EventItemInfo | EventNavigatorManager.getEventItemInfo(String eventFllowId, String eventItemId) イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
EventResultItemInfo | EventNavigatorManager.getEventResultItemInfo(String eventFllowId, String resultItemId) ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
String | EventNavigatorManager.addEventResultItemInfo(String userId, String eventFlowId, EventResultItemInfo resultItemInfo) 保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
void | EventNavigatorManager.deleteSaveResultHistory(String userId) 保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。
SaveEventResultItemInfo | EventNavigatorManager.getSaveEventResultItemInfo(String userId, String resultItemId) 保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
void | EventNavigatorManager.updateEventResultItemInfo(String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | EventNavigatorManager.updateEventResultItemInfoTitle(String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
SaveEventResultItemInfo[] | EventNavigatorManager.getSaveEventResultItemInfos(String searchTitle, String userId, String sortKey, String oeder, int currentPage) 保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
void | EventNavigatorManager.removeSaveEventResultItemInfo(String userId, String resultItemId) 保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。
void | EventNavigatorManager.addFavoriteSaveEventResultItemInfo(String userId, String resultItemId) 保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。
SaveEventResultItemInfo[] | EventNavigatorManager.getSaveEventResultItemInfosHistory(String userId) 保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
void | EventNavigatorManager.updateEventFlow(EventFlow eventFllow) イベントフローの更新 イベントフロー情報をDB更新する。
void | EventNavigatorManager.setOrderSortNum(EventFlowInfo[] eventFlowInfos) 表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
void | EventNavigatorManager.setViewOpen(String eventFlowId, String open) 表示設定 イベントフロー情報に表示／非表示を設定する。
void | EventNavigatorManager.importData(InputStream inputStream) インポートを行います。
void | EventNavigatorManager.exportData(OutputStream outputStream, boolean editFlag) エクスポートを行います。
LinkPageInfo | EventNavigatorManager.getLinkPageInfo(String eventFlowId, String eventResultId, String resultPageId) 結果ページ情報を取得します。
LinkPageInfo | EventNavigatorManager.getSaveLinkPageInfo(String userId, String eventResultId, String resultPageId) 保存結果ページ情報を取得します。
String | EventNavigatorManager.getConfigPageCount(String userId) 履歴表示件数の取得。
void | EventNavigatorManager.setConfigPageCount(String userId, int iCount) 履歴表示件数の設定。
void | EventNavigatorImporter.doImport(EventNavigatorManager manager, InputStream inputStream) インポートを行います。
void | EventNavigatorExporter.doExport(EventNavigatorManager manager, OutputStream outputStream, boolean editFlag) エクスポートを行います。
EventFlowInfo[] | EventNavigatorAccessor.getEventFlowInfos(EventNavigatorManager manager, String searchTitle, boolean permissionCheck, int currentPage) イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
void | EventNavigatorAccessor.deleteEventFlow(EventNavigatorManager manager, String eventFllowId) イベントフローの削除 イベントフローIDから、イベントフローを削除する。
EventFlow | EventNavigatorAccessor.getEventFlow(EventNavigatorManager manager, String eventFllowId) イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
EventFlow[] | EventNavigatorAccessor.getEventFlows(EventNavigatorManager manager) すべてのイベントフローを取得します。
void | EventNavigatorAccessor.registEventFlow(EventNavigatorManager manager, EventFlow eventFllow) イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
EventFlow | EventNavigatorAccessor.copyEventFlow(EventNavigatorManager manager, String eventFllowId) イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
EventItemInfo | EventNavigatorAccessor.getEventItemInfo(EventNavigatorManager manager, String eventFllowId, String eventItemId) イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
EventResultItemInfo | EventNavigatorAccessor.getEventResultItemInfo(EventNavigatorManager manager, String eventFllowId, String resultItemId) ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
String | EventNavigatorAccessor.addEventResultItemInfo(EventNavigatorManager manager, String userId, String eventFlowId, EventResultItemInfo resultItemInfo) 保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
void | EventNavigatorAccessor.deleteSaveResultHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。
SaveEventResultItemInfo | EventNavigatorAccessor.getSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
void | EventNavigatorAccessor.updateEventResultItemInfo(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | EventNavigatorAccessor.updateEventResultItemInfoTitle(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
SaveEventResultItemInfo[] | EventNavigatorAccessor.getSaveEventResultItemInfos(EventNavigatorManager manager, String userId, String searchTitle, String sortKey, String oeder, int currentPage) 保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
void | EventNavigatorAccessor.removeSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。
void | EventNavigatorAccessor.addFavoriteSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。
SaveEventResultItemInfo[] | EventNavigatorAccessor.getSaveEventResultItemInfosHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
void | EventNavigatorAccessor.updateEventFlow(EventNavigatorManager manager, EventFlow eventFllow) イベントフローの更新 イベントフロー情報をDB更新する。
void | EventNavigatorAccessor.setOrderSortNum(EventNavigatorManager manager, EventFlowInfo[] eventFlowInfos) 表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
void | EventNavigatorAccessor.setViewOpen(EventNavigatorManager manager, String eventFlowId, String open) 表示設定 イベントフロー情報に表示／非表示を設定する。
String[] | EventNavigatorAccessor.getEventFlowIds(EventNavigatorManager manager) すべてのイベントフローIDを取得します。
LinkPageInfo | EventNavigatorAccessor.getLinkPageInfo(EventNavigatorManager manager, String eventFlowId, String eventResultId, String resultPageId) 結果ページ情報を取得します。
LinkPageInfo | EventNavigatorAccessor.getSaveLinkPageInfo(EventNavigatorManager manager, String userId, String eventResultId, String resultPageId) 保存結果ページ情報を取得します。

EventNavigatorException をスローする jp.co.intra_mart.foundation.navigator のコンストラクタ
EventNavigatorManager(String groupId, String locale)
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.navigator.EventNavigatorExporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.navigator.EventNavigatorExporter の使用

EventNavigatorExporter を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventNavigatorExporter の使用

EventNavigatorExporter を実装している jp.co.intra_mart.foundation.navigator のクラス
 class StandardEventNavigatorExporter

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventNavigatorHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventNavigatorHandler の使用

jp.co.intra_mart.foundation.navigator.EventNavigatorHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.navigator.EventNavigatorImporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.navigator.EventNavigatorImporter の使用

EventNavigatorImporter を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventNavigatorImporter の使用

EventNavigatorImporter を実装している jp.co.intra_mart.foundation.navigator のクラス
 class StandardEventNavigatorImporter
イベントナビゲーターのインポートクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventNavigatorManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventNavigatorManager の使用

EventNavigatorManager を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventNavigatorManager の使用

EventNavigatorManager 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | StandardEventNavigatorImporter.doImport(EventNavigatorManager manager, InputStream inputStream) インポートを行います。
void | StandardEventNavigatorExporter.doExport(EventNavigatorManager manager, OutputStream outputStream, boolean editFlag) エクスポートを行います。
EventFlowInfo[] | StandardEventNavigatorAccessor.getEventFlowInfos(EventNavigatorManager manager, String searchTitle, boolean permissionCheck, int currentPage) イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
void | StandardEventNavigatorAccessor.deleteEventFlow(EventNavigatorManager manager, String eventFlowId) イベントフローの削除 イベントフローIDから、イベントフローを削除する。
EventFlow | StandardEventNavigatorAccessor.getEventFlow(EventNavigatorManager manager, String eventFlowId) イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
void | StandardEventNavigatorAccessor.updateEventFlow(EventNavigatorManager manager, EventFlow eventFlow) イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
EventFlow | StandardEventNavigatorAccessor.copyEventFlow(EventNavigatorManager manager, String eventFlowId) イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
EventItemInfo | StandardEventNavigatorAccessor.getEventItemInfo(EventNavigatorManager manager, String eventFlowId, String eventItemId) イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
EventResultItemInfo | StandardEventNavigatorAccessor.getEventResultItemInfo(EventNavigatorManager manager, String eventFlowId, String resultItemId) ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
String | StandardEventNavigatorAccessor.addEventResultItemInfo(EventNavigatorManager manager, String userId, String eventFlowId, EventResultItemInfo resultItemInfo) 保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
void | StandardEventNavigatorAccessor.deleteSaveResultHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。
SaveEventResultItemInfo | StandardEventNavigatorAccessor.getSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
void | StandardEventNavigatorAccessor.updateEventResultItemInfo(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | StandardEventNavigatorAccessor.updateEventResultItemInfoTitle(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
SaveEventResultItemInfo[] | StandardEventNavigatorAccessor.getSaveEventResultItemInfos(EventNavigatorManager manager, String userId, String searchTitle, String sortKey, String oeder, int currentPage) 保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
void | StandardEventNavigatorAccessor.removeSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String saveResultItemId) 保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。
void | StandardEventNavigatorAccessor.addFavoriteSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String saveResultItemId) 保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。
SaveEventResultItemInfo[] | StandardEventNavigatorAccessor.getSaveEventResultItemInfosHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
void | StandardEventNavigatorAccessor.setOrderSortNum(EventNavigatorManager manager, EventFlowInfo[] eventFlowInfos) 表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
void | StandardEventNavigatorAccessor.setViewOpen(EventNavigatorManager manager, String eventFlowId, String open) 表示設定 イベントフロー情報に表示／非表示を設定する。
String[] | StandardEventNavigatorAccessor.getEventFlowIds(EventNavigatorManager manager) すべてのイベントフローIDを取得します。
EventFlow[] | StandardEventNavigatorAccessor.getEventFlows(EventNavigatorManager manager) すべてのイベントフローを取得します。
LinkPageInfo | StandardEventNavigatorAccessor.getLinkPageInfo(EventNavigatorManager manager, String eventFlowId, String eventResultId, String resultPageId) 結果ページ情報を取得します。
LinkPageInfo | StandardEventNavigatorAccessor.getSaveLinkPageInfo(EventNavigatorManager manager, String userId, String eventResultId, String resultPageId) 保存結果ページ情報を取得します。
void | StandardEventNavigatorAccessor.registEventFlow(EventNavigatorManager manager, EventFlow eventFlow) イベントフローを更新します。
Object | EventNavigatorReaderDecorator.doDecoration(EventNavigatorManager manager, Object obj) イベントナビゲータのオブジェクト情報をデータストアからの読み込み直後にコールされます。
void | EventNavigatorImporter.doImport(EventNavigatorManager manager, InputStream inputStream) インポートを行います。
void | EventNavigatorExporter.doExport(EventNavigatorManager manager, OutputStream outputStream, boolean editFlag) エクスポートを行います。
EventFlowInfo[] | EventNavigatorAccessor.getEventFlowInfos(EventNavigatorManager manager, String searchTitle, boolean permissionCheck, int currentPage) イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
void | EventNavigatorAccessor.deleteEventFlow(EventNavigatorManager manager, String eventFllowId) イベントフローの削除 イベントフローIDから、イベントフローを削除する。
EventFlow | EventNavigatorAccessor.getEventFlow(EventNavigatorManager manager, String eventFllowId) イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
EventFlow[] | EventNavigatorAccessor.getEventFlows(EventNavigatorManager manager) すべてのイベントフローを取得します。
void | EventNavigatorAccessor.registEventFlow(EventNavigatorManager manager, EventFlow eventFllow) イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
EventFlow | EventNavigatorAccessor.copyEventFlow(EventNavigatorManager manager, String eventFllowId) イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
EventItemInfo | EventNavigatorAccessor.getEventItemInfo(EventNavigatorManager manager, String eventFllowId, String eventItemId) イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
EventResultItemInfo | EventNavigatorAccessor.getEventResultItemInfo(EventNavigatorManager manager, String eventFllowId, String resultItemId) ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
String | EventNavigatorAccessor.addEventResultItemInfo(EventNavigatorManager manager, String userId, String eventFlowId, EventResultItemInfo resultItemInfo) 保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
void | EventNavigatorAccessor.deleteSaveResultHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。
SaveEventResultItemInfo | EventNavigatorAccessor.getSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
void | EventNavigatorAccessor.updateEventResultItemInfo(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | EventNavigatorAccessor.updateEventResultItemInfoTitle(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
SaveEventResultItemInfo[] | EventNavigatorAccessor.getSaveEventResultItemInfos(EventNavigatorManager manager, String userId, String searchTitle, String sortKey, String oeder, int currentPage) 保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
void | EventNavigatorAccessor.removeSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。
void | EventNavigatorAccessor.addFavoriteSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。
SaveEventResultItemInfo[] | EventNavigatorAccessor.getSaveEventResultItemInfosHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
void | EventNavigatorAccessor.updateEventFlow(EventNavigatorManager manager, EventFlow eventFllow) イベントフローの更新 イベントフロー情報をDB更新する。
void | EventNavigatorAccessor.setOrderSortNum(EventNavigatorManager manager, EventFlowInfo[] eventFlowInfos) 表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
void | EventNavigatorAccessor.setViewOpen(EventNavigatorManager manager, String eventFlowId, String open) 表示設定 イベントフロー情報に表示／非表示を設定する。
String[] | EventNavigatorAccessor.getEventFlowIds(EventNavigatorManager manager) すべてのイベントフローIDを取得します。
LinkPageInfo | EventNavigatorAccessor.getLinkPageInfo(EventNavigatorManager manager, String eventFlowId, String eventResultId, String resultPageId) 結果ページ情報を取得します。
LinkPageInfo | EventNavigatorAccessor.getSaveLinkPageInfo(EventNavigatorManager manager, String userId, String eventResultId, String resultPageId) 保存結果ページ情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventNavigatorPermissionSelector の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventNavigatorPermissionSelector の使用

jp.co.intra_mart.foundation.navigator.EventNavigatorPermissionSelector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.navigator.EventNavigatorReaderDecorator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.navigator.EventNavigatorReaderDecorator の使用

jp.co.intra_mart.foundation.navigator.EventNavigatorReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventResultItem の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventResultItem の使用

EventResultItem を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventResultItem の使用

EventResultItem を返す jp.co.intra_mart.foundation.navigator のメソッド
 EventResultItem SelectItem.getNextEventResultItem()

EventResultItem 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
 void SelectItem.setNextEventResultItem(EventResultItem nextEventResultItem)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventResultItemInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventResultItemInfo の使用

EventResultItemInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventResultItemInfo の使用

EventResultItemInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
EventResultItemInfo | StandardEventNavigatorAccessor.getEventResultItemInfo(EventNavigatorManager manager, String eventFlowId, String resultItemId) ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
EventResultItemInfo | EventNavigatorManager.getEventResultItemInfo(String eventFllowId, String resultItemId) ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
EventResultItemInfo | EventNavigatorAccessor.getEventResultItemInfo(EventNavigatorManager manager, String eventFllowId, String resultItemId) ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。

EventResultItemInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
String | StandardEventNavigatorAccessor.addEventResultItemInfo(EventNavigatorManager manager, String userId, String eventFlowId, EventResultItemInfo resultItemInfo) 保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
String | EventNavigatorManager.addEventResultItemInfo(String userId, String eventFlowId, EventResultItemInfo resultItemInfo) 保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
String | EventNavigatorAccessor.addEventResultItemInfo(EventNavigatorManager manager, String userId, String eventFlowId, EventResultItemInfo resultItemInfo) 保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.LinkPageInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.LinkPageInfo の使用

LinkPageInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での LinkPageInfo の使用

LinkPageInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
LinkPageInfo | StandardEventNavigatorAccessor.getLinkPageInfo(EventNavigatorManager manager, String eventFlowId, String eventResultId, String resultPageId) 結果ページ情報を取得します。
LinkPageInfo | StandardEventNavigatorAccessor.getSaveLinkPageInfo(EventNavigatorManager manager, String userId, String eventResultId, String resultPageId) 保存結果ページ情報を取得します。
LinkPageInfo | ResultPageItem.getLinkPageInfo()
LinkPageInfo | EventNavigatorManager.getLinkPageInfo(String eventFlowId, String eventResultId, String resultPageId) 結果ページ情報を取得します。
LinkPageInfo | EventNavigatorManager.getSaveLinkPageInfo(String userId, String eventResultId, String resultPageId) 保存結果ページ情報を取得します。
LinkPageInfo | EventNavigatorAccessor.getLinkPageInfo(EventNavigatorManager manager, String eventFlowId, String eventResultId, String resultPageId) 結果ページ情報を取得します。
LinkPageInfo | EventNavigatorAccessor.getSaveLinkPageInfo(EventNavigatorManager manager, String userId, String eventResultId, String resultPageId) 保存結果ページ情報を取得します。

LinkPageInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
 void ResultPageItem.setLinkPageInfo(LinkPageInfo linkPageInfo)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem の使用

NavigatorAuthenticateItem を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での NavigatorAuthenticateItem の使用

jp.co.intra_mart.foundation.navigator での NavigatorAuthenticateItem のサブクラス
class | EventFlow イベントフロークラス
class | ResultPageItem 結果ページクラス
class | SelectItem 選択アイテムクラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.NavigatorItem の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.NavigatorItem の使用

NavigatorItem を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での NavigatorItem の使用

jp.co.intra_mart.foundation.navigator での NavigatorItem のサブクラス
class | EventFlow イベントフロークラス
class | EventItem イベントアイテムクラス
class | EventResultItem ナビゲート結果クラス
class | NavigatorAuthenticateItem 選択アイテムクラス
class | ResultPageItem 結果ページクラス
class | SelectItem 選択アイテムクラス

NavigatorItem 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
 void StandardEventNavigatorImporter.checkTitleInfo(NavigatorItem item, String[] locales, String strURI)
タイトル情報のロケールマッチング（共通）

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.ResultPageItem の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.ResultPageItem の使用

ResultPageItem を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での ResultPageItem の使用

ResultPageItem を返す jp.co.intra_mart.foundation.navigator のメソッド
 ResultPageItem[] EventResultItem.getPageItem()

ResultPageItem 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | EventResultItem.setPageItem(ResultPageItem[] pageItem)
void | EventResultItem.addPage(ResultPageItem page) リンクページ情報追加

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.ResultPageItemInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.ResultPageItemInfo の使用

ResultPageItemInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での ResultPageItemInfo の使用

ResultPageItemInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
ResultPageItemInfo[] | SaveEventResultItemInfo.getResultPageItemInfos() 結果ページ情報リスト取得
ResultPageItemInfo[] | EventResultItemInfo.getResultPageItemInfos() 結果ページ情報リスト取得

ResultPageItemInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | SaveEventResultItemInfo.setResultPageItemInfos(ResultPageItemInfo[] resultPageItemInfos) 結果ページ情報リスト設定
void | EventResultItemInfo.setResultPageItemInfos(ResultPageItemInfo[] resultPageItemInfos) 結果ページ情報リスト設定

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.SaveEventHistoryInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.SaveEventHistoryInfo の使用

SaveEventHistoryInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での SaveEventHistoryInfo の使用

SaveEventHistoryInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
 SaveEventHistoryInfo[] SaveEventResultItemInfo.getEventHistory()
イベント履歴情報リスト取得

SaveEventHistoryInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
 void SaveEventResultItemInfo.setEventHistory(SaveEventHistoryInfo[] eventHistory)
イベント履歴情報リスト設定

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo の使用

SaveEventResultItemInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での SaveEventResultItemInfo の使用

SaveEventResultItemInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
SaveEventResultItemInfo | StandardEventNavigatorAccessor.getSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
SaveEventResultItemInfo[] | StandardEventNavigatorAccessor.getSaveEventResultItemInfos(EventNavigatorManager manager, String userId, String searchTitle, String sortKey, String oeder, int currentPage) 保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
SaveEventResultItemInfo[] | StandardEventNavigatorAccessor.getSaveEventResultItemInfosHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
SaveEventResultItemInfo | EventNavigatorManager.getSaveEventResultItemInfo(String userId, String resultItemId) 保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
SaveEventResultItemInfo[] | EventNavigatorManager.getSaveEventResultItemInfos(String searchTitle, String userId, String sortKey, String oeder, int currentPage) 保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
SaveEventResultItemInfo[] | EventNavigatorManager.getSaveEventResultItemInfosHistory(String userId) 保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
SaveEventResultItemInfo | EventNavigatorAccessor.getSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
SaveEventResultItemInfo[] | EventNavigatorAccessor.getSaveEventResultItemInfos(EventNavigatorManager manager, String userId, String searchTitle, String sortKey, String oeder, int currentPage) 保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
SaveEventResultItemInfo[] | EventNavigatorAccessor.getSaveEventResultItemInfosHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。

SaveEventResultItemInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | StandardEventNavigatorAccessor.updateEventResultItemInfo(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | StandardEventNavigatorAccessor.updateEventResultItemInfoTitle(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | EventNavigatorManager.updateEventResultItemInfo(String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | EventNavigatorManager.updateEventResultItemInfoTitle(String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | EventNavigatorAccessor.updateEventResultItemInfo(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | EventNavigatorAccessor.updateEventResultItemInfoTitle(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.SelectItem の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.SelectItem の使用

SelectItem を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での SelectItem の使用

SelectItem を返す jp.co.intra_mart.foundation.navigator のメソッド
SelectItem[] | EventItem.getSelectItem()
SelectItem | EventItem.getSelectItem(int index)

SelectItem 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | EventItem.setSelectItem(SelectItem[] selectItem)
void | EventItem.add(SelectItem node) イベントノード追加

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.SelectItemInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.SelectItemInfo の使用

SelectItemInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での SelectItemInfo の使用

SelectItemInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
 SelectItemInfo[] EventItemInfo.getSelectItemInfos()
選択アイテム情報リスト取得

SelectItemInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
 void EventItemInfo.setSelectItemInfos(SelectItemInfo[] selectItemInfos)
選択アイテム情報リスト設定

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor の使用

jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter の使用

jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter の使用

jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.TitleInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.TitleInfo の使用

TitleInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での TitleInfo の使用

jp.co.intra_mart.foundation.navigator での TitleInfo のサブクラス
class | EventFlowInfo イベントフロー情報
class | EventItemInfo イベントアイテム情報
class | EventResultItemInfo ナビゲート結果情報
class | LinkPageInfo リンク情報
class | ResultPageItemInfo 結果ページ情報
class | SaveEventResultItemInfo 保存ナビゲート結果情報
class | SelectItemInfo 選択アイテム情報

TitleInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
 TitleInfo NavigatorItem.getTitleInfo(Locale locale)

TitleInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
 void NavigatorItem.setTitleInfo(Locale locale, TitleInfo titleInfo)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


EventAccessInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventAccessInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.EventAccessInfo
すべての実装インタフェース:
Serializable
public class EventAccessInfo
extends Object
implements Serializable

アクセス権情報

関連項目:
直列化された形式

コンストラクタの概要
EventAccessInfo()
メソッドの概要
void | addDepartment(DepartmentInfo department)
void | addPost(PostInfo post)
void | addPublicGroup(PublicGroupInfo publicGroup)
void | addRole(Role role)
DepartmentInfo | getDepartment(int i)
DepartmentInfo[] | getDepartments()
PostInfo | getPost(int i)
PostInfo[] | getPosts()
PublicGroupInfo | getPublicGroup(int i)
PublicGroupInfo[] | getPublicGroups()
Role | getRole(int i)
Role[] | getRoles()
boolean | isRequiredCheck() 権限チェック要否
void | setDepartment(int i, DepartmentInfo department)
void | setDepartments(DepartmentInfo[] departments)
void | setPost(int i, PostInfo post)
void | setPosts(PostInfo[] posts)
void | setPublicGroup(int i, PublicGroupInfo publicGroup)
void | setPublicGroups(PublicGroupInfo[] publicGroups)
void | setRole(int i, Role role)
void | setRoles(Role[] roles)
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventAccessInfo

public EventAccessInfo()
メソッドの詳細

getDepartments

public DepartmentInfo[] getDepartments()
戻り値:
departments を戻します。

getDepartment

public DepartmentInfo getDepartment(int i)
パラメータ:
i - 取得するインデックス
戻り値:
department を戻します。

setDepartments

public void setDepartments(DepartmentInfo[] departments)
パラメータ:
departments - 設定する departments。

setDepartment

public void setDepartment(int i,
                          DepartmentInfo department)
パラメータ:
i - 設定するインデックス
department - 設定する department。

addDepartment

public void addDepartment(DepartmentInfo department)
パラメータ:
department - 設定する department。

getPosts

public PostInfo[] getPosts()
戻り値:
posts を戻します。

getPost

public PostInfo getPost(int i)
パラメータ:
i - 取得するインデックス
戻り値:
posts を戻します。

setPosts

public void setPosts(PostInfo[] posts)
パラメータ:
posts - 設定する posts。

setPost

public void setPost(int i,
                    PostInfo post)
パラメータ:
i - 設定するインデックス
post - 設定する post。

addPost

public void addPost(PostInfo post)
パラメータ:
post - 設定する post。

getPublicGroups

public PublicGroupInfo[] getPublicGroups()
戻り値:
publicGroups を戻します。

getPublicGroup

public PublicGroupInfo getPublicGroup(int i)
パラメータ:
i - 取得するインデックス
戻り値:
department を戻します。

setPublicGroups

public void setPublicGroups(PublicGroupInfo[] publicGroups)
パラメータ:
publicGroups - 設定する publicGroups。

setPublicGroup

public void setPublicGroup(int i,
                           PublicGroupInfo publicGroup)
パラメータ:
i - 設定するインデックス
publicGroup - 設定する publicGroup。

addPublicGroup

public void addPublicGroup(PublicGroupInfo publicGroup)
パラメータ:
publicGroup - 設定する publicGroup。

getRoles

public Role[] getRoles()
戻り値:
roles を戻します。

getRole

public Role getRole(int i)
パラメータ:
i - 取得するインデックス
戻り値:
roles を戻します。

setRoles

public void setRoles(Role[] roles)
パラメータ:
roles - 設定する roles。

setRole

public void setRole(int i,
                    Role role)
パラメータ:
i - 設定するインデックス
role - 設定する role。

addRole

public void addRole(Role role)
パラメータ:
role - 設定する role。

isRequiredCheck

public boolean isRequiredCheck()
権限チェック要否

戻り値:
boolean 権限チェック要否
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventFlow (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventFlow

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.NavigatorItem
        拡張 jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem
            拡張 jp.co.intra_mart.foundation.navigator.EventFlow
すべての実装インタフェース:
Serializable
public class EventFlow
extends NavigatorAuthenticateItem

イベントフロークラス

関連項目:
直列化された形式

コンストラクタの概要
EventFlow()
メソッドの概要
String | getId()
String | getOpen()
int | getSortNumber()
EventItem | getStartEventItem()
void | setId(String id)
void | setOpen(String open)
void | setSortNumber(int sortNumber)
void | setStartEventItem(EventItem startEventItem)
クラス jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem から継承したメソッド
getAccessInfo, setAccessInfo
クラス jp.co.intra_mart.foundation.navigator.NavigatorItem から継承したメソッド
getKeys, getTitleInfo, removeTitleInfo, setTitleInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventFlow

public EventFlow()
メソッドの詳細

getId

public String getId()
戻り値:
id を戻します。

setId

public void setId(String id)
パラメータ:
id - 設定する id。

getOpen

public String getOpen()
戻り値:
open を戻します。

setOpen

public void setOpen(String open)
パラメータ:
open - 設定する open。

getStartEventItem

public EventItem getStartEventItem()
戻り値:
startEventItem を戻します。

setStartEventItem

public void setStartEventItem(EventItem startEventItem)
パラメータ:
startEventItem - 設定する startEventItem。

getSortNumber

public int getSortNumber()
戻り値:
sortNumber を戻します。

setSortNumber

public void setSortNumber(int sortNumber)
パラメータ:
sortNumber - 設定する sortNumber。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventFlowInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventFlowInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.TitleInfo
        拡張 jp.co.intra_mart.foundation.navigator.EventFlowInfo
すべての実装インタフェース:
Serializable
public class EventFlowInfo
extends TitleInfo

イベントフロー情報

関連項目:
直列化された形式

コンストラクタの概要
EventFlowInfo()
メソッドの概要
String | getId() イベントフローID取得
String | getOpen() 公開フラグ取得
String | getStartEventId() スタートイベントアイテムID取得
boolean | isPermissionCheck() パーミッションチェックフラグ取得
void | setId(String id) イベントフローID設定
void | setOpen(String open) 公開フラグ設定
void | setPermissionCheck(boolean check) パーミッションチェックフラグ設定
void | setStartEventId(String startEventId) スタートイベントアイテムID設定
クラス jp.co.intra_mart.foundation.navigator.TitleInfo から継承したメソッド
getComment, getTitle, setComment, setTitle
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventFlowInfo

public EventFlowInfo()
メソッドの詳細

getId

public String getId()
イベントフローID取得

戻り値:
Returns the id.

setId

public void setId(String id)
イベントフローID設定

パラメータ:
id - The id to set.

getStartEventId

public String getStartEventId()
スタートイベントアイテムID取得

戻り値:
Returns the startEventId.

setStartEventId

public void setStartEventId(String startEventId)
スタートイベントアイテムID設定

パラメータ:
startEventId - The startEventId to set.

getOpen

public String getOpen()
公開フラグ取得

戻り値:
Returns the open.

setOpen

public void setOpen(String open)
公開フラグ設定

パラメータ:
open - The open to set.

isPermissionCheck

public boolean isPermissionCheck()
パーミッションチェックフラグ取得

戻り値:
Returns the permissionCheck.

setPermissionCheck

public void setPermissionCheck(boolean check)
パーミッションチェックフラグ設定

パラメータ:
check - The permissionCheck to set.
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventHistoryInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventHistoryInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.EventHistoryInfo
すべての実装インタフェース:
Serializable
public class EventHistoryInfo
extends Object
implements Serializable

イベント履歴情報

関連項目:
直列化された形式

コンストラクタの概要
EventHistoryInfo()
メソッドの概要
String | getAnswer() 質問取得
String | getId() イベントアイテムID取得
String | getQuestion() 回答取得
void | setAnswer(String answer) 質問設定
void | setId(String id) イベントアイテムID設定
void | setQuestion(String question) 回答設定
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventHistoryInfo

public EventHistoryInfo()
メソッドの詳細

getId

public String getId()
イベントアイテムID取得

戻り値:
Returns the id.

setId

public void setId(String id)
イベントアイテムID設定

パラメータ:
id - The id to set.

getAnswer

public String getAnswer()
質問取得

戻り値:
Returns the answer.

setAnswer

public void setAnswer(String answer)
質問設定

パラメータ:
answer - The answer to set.

getQuestion

public String getQuestion()
回答取得

戻り値:
Returns the question.

setQuestion

public void setQuestion(String question)
回答設定

パラメータ:
question - The question to set.
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventItem (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.NavigatorItem
        拡張 jp.co.intra_mart.foundation.navigator.EventItem
すべての実装インタフェース:
Serializable
public class EventItem
extends NavigatorItem

イベントアイテムクラス

関連項目:
直列化された形式

コンストラクタの概要
EventItem()
メソッドの概要
void | add(SelectItem node) イベントノード追加
SelectItem[] | getSelectItem()
SelectItem | getSelectItem(int index)
void | setSelectItem(SelectItem[] selectItem)
クラス jp.co.intra_mart.foundation.navigator.NavigatorItem から継承したメソッド
getKeys, getTitleInfo, removeTitleInfo, setTitleInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventItem

public EventItem()
メソッドの詳細

getSelectItem

public SelectItem[] getSelectItem()
戻り値:
selectItem を戻します。

getSelectItem

public SelectItem getSelectItem(int index)
パラメータ:
index - インデックス
戻り値:
selectItem を戻します。

setSelectItem

public void setSelectItem(SelectItem[] selectItem)
パラメータ:
selectItem - 設定する selectItem。

add

public void add(SelectItem node)
イベントノード追加

パラメータ:
node - 追加するノード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventItemInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventItemInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.TitleInfo
        拡張 jp.co.intra_mart.foundation.navigator.EventItemInfo
すべての実装インタフェース:
Serializable
public class EventItemInfo
extends TitleInfo

イベントアイテム情報

関連項目:
直列化された形式

コンストラクタの概要
EventItemInfo()
メソッドの概要
EventHistoryInfo[] | getEventHistory() イベント履歴情報リスト取得
String | getId() イベントアイテムID取得
SelectItemInfo[] | getSelectItemInfos() 選択アイテム情報リスト取得
void | setEventHistory(EventHistoryInfo[] eventHistory) イベント履歴情報リスト設定
void | setId(String id) イベントアイテムID設定
void | setSelectItemInfos(SelectItemInfo[] selectItemInfos) 選択アイテム情報リスト設定
クラス jp.co.intra_mart.foundation.navigator.TitleInfo から継承したメソッド
getComment, getTitle, setComment, setTitle
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventItemInfo

public EventItemInfo()
メソッドの詳細

getId

public String getId()
イベントアイテムID取得

戻り値:
Returns the id.

setId

public void setId(String id)
イベントアイテムID設定

パラメータ:
id - The id to set.

getSelectItemInfos

public SelectItemInfo[] getSelectItemInfos()
選択アイテム情報リスト取得

戻り値:
Returns the selectItemInfos.

setSelectItemInfos

public void setSelectItemInfos(SelectItemInfo[] selectItemInfos)
選択アイテム情報リスト設定

getEventHistory

public EventHistoryInfo[] getEventHistory()
イベント履歴情報リスト取得

戻り値:
Returns the eventHistory.

setEventHistory

public void setEventHistory(EventHistoryInfo[] eventHistory)
イベント履歴情報リスト設定

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventNavigatorAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
インタフェース EventNavigatorAccessor

既知の実装クラスの一覧:
StandardEventNavigatorAccessor
public interface EventNavigatorAccessor

イベントナビゲーター管理アクセッサインタフェース。

イベントナビゲーター情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
String | addEventResultItemInfo(EventNavigatorManager manager, String userId, String eventFlowId, EventResultItemInfo resultItemInfo) 保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
void | addFavoriteSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。
EventFlow | copyEventFlow(EventNavigatorManager manager, String eventFllowId) イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
void | deleteEventFlow(EventNavigatorManager manager, String eventFllowId) イベントフローの削除 イベントフローIDから、イベントフローを削除する。
void | deleteSaveResultHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。
EventFlow | getEventFlow(EventNavigatorManager manager, String eventFllowId) イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
String[] | getEventFlowIds(EventNavigatorManager manager) すべてのイベントフローIDを取得します。
EventFlowInfo[] | getEventFlowInfos(EventNavigatorManager manager, String searchTitle, boolean permissionCheck, int currentPage) イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
EventFlow[] | getEventFlows(EventNavigatorManager manager) すべてのイベントフローを取得します。
EventItemInfo | getEventItemInfo(EventNavigatorManager manager, String eventFllowId, String eventItemId) イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
EventResultItemInfo | getEventResultItemInfo(EventNavigatorManager manager, String eventFllowId, String resultItemId) ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
LinkPageInfo | getLinkPageInfo(EventNavigatorManager manager, String eventFlowId, String eventResultId, String resultPageId) 結果ページ情報を取得します。
SaveEventResultItemInfo | getSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
SaveEventResultItemInfo[] | getSaveEventResultItemInfos(EventNavigatorManager manager, String userId, String searchTitle, String sortKey, String oeder, int currentPage) 保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
SaveEventResultItemInfo[] | getSaveEventResultItemInfosHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
LinkPageInfo | getSaveLinkPageInfo(EventNavigatorManager manager, String userId, String eventResultId, String resultPageId) 保存結果ページ情報を取得します。
void | init(String[] args) イベントナビゲーター管理アクセッサの初期化。
void | registEventFlow(EventNavigatorManager manager, EventFlow eventFllow) イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
void | removeSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。
void | setOrderSortNum(EventNavigatorManager manager, EventFlowInfo[] eventFlowInfos) 表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
void | setViewOpen(EventNavigatorManager manager, String eventFlowId, String open) 表示設定 イベントフロー情報に表示／非表示を設定する。
void | updateEventFlow(EventNavigatorManager manager, EventFlow eventFllow) イベントフローの更新 イベントフロー情報をDB更新する。
void | updateEventResultItemInfo(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | updateEventResultItemInfoTitle(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。

メソッドの詳細

init

public void init(String[] args)
イベントナビゲーター管理アクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

getEventFlowInfos

public EventFlowInfo[] getEventFlowInfos(EventNavigatorManager manager,
                                         String searchTitle,
                                         boolean permissionCheck,
                                         int currentPage)
                                  throws EventNavigatorException
イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。

パラメータ:
manager - イベントナビゲータ管理オブジェクト
searchTitle - 検索タイトル
permissionCheck - 権限チェック要否
currentPage - 表示指定頁
戻り値:
イベントフロー情報一覧
例外:
EventNavigatorException - イベントフロー情報一覧取得処理に失敗した場合にスローされます。

deleteEventFlow

public void deleteEventFlow(EventNavigatorManager manager,
                            String eventFllowId)
                     throws EventNavigatorException
イベントフローの削除 イベントフローIDから、イベントフローを削除する。

パラメータ:
eventFllowId - イベントフローID
例外:
EventNavigatorException - イベントフロー削除処理に失敗した場合にスローされます。

getEventFlow

public EventFlow getEventFlow(EventNavigatorManager manager,
                              String eventFllowId)
                       throws EventNavigatorException
イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。

パラメータ:
eventFllowId - イベントフローID
戻り値:
イベントフロー
例外:
EventNavigatorException - イベントフロー取得処理に失敗した場合にスローされます。

getEventFlows

public EventFlow[] getEventFlows(EventNavigatorManager manager)
                          throws EventNavigatorException
すべてのイベントフローを取得します。

パラメータ:
manager -
戻り値:
イベントフローの配列
例外:
EventNavigatorException

registEventFlow

public void registEventFlow(EventNavigatorManager manager,
                            EventFlow eventFllow)
                     throws EventNavigatorException
イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。

パラメータ:
eventFllow - イベントフロー
例外:
EventNavigatorException - イベントフロー登録処理に失敗した場合にスローされます。

copyEventFlow

public EventFlow copyEventFlow(EventNavigatorManager manager,
                               String eventFllowId)
                        throws EventNavigatorException
イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。

パラメータ:
eventFllowId - コピー元イベントフローID
戻り値:
コピー先イベントフロー
例外:
EventNavigatorException - イベントフローコピー処理に失敗した場合にスローされます。

getEventItemInfo

public EventItemInfo getEventItemInfo(EventNavigatorManager manager,
                                      String eventFllowId,
                                      String eventItemId)
                               throws EventNavigatorException
イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。

パラメータ:
eventFllowId - イベントフローID
eventItemId - イベントアイテムID
戻り値:
イベントアイテム情報
例外:
EventNavigatorException - イベントアイテム情報取得処理に失敗した場合にスローされます。

getEventResultItemInfo

public EventResultItemInfo getEventResultItemInfo(EventNavigatorManager manager,
                                                  String eventFllowId,
                                                  String resultItemId)
                                           throws EventNavigatorException
ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。

パラメータ:
eventFllowId - イベントフローID
resultItemId - ナビゲート結果ID
戻り値:
ナビゲート結果情報
例外:
EventNavigatorException - ナビゲート結果情報取得処理に失敗した場合にスローされます。

addEventResultItemInfo

public String addEventResultItemInfo(EventNavigatorManager manager,
                                     String userId,
                                     String eventFlowId,
                                     EventResultItemInfo resultItemInfo)
                              throws EventNavigatorException
保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。

パラメータ:
userId - ユーザID
resultItemInfo - ナビゲート結果情報
戻り値:
保存ナビゲート結果ID
例外:
EventNavigatorException - 保存ナビゲート結果情報（履歴）登録処理に失敗した場合にスローされます。

deleteSaveResultHistory

public void deleteSaveResultHistory(EventNavigatorManager manager,
                                    String userId)
                             throws EventNavigatorException
保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。

パラメータ:
userId - ユーザID
例外:
EventNavigatorException - 保存ナビゲート結果情報（履歴）削除処理に失敗した場合にスローされます。

getSaveEventResultItemInfo

public SaveEventResultItemInfo getSaveEventResultItemInfo(EventNavigatorManager manager,
                                                          String userId,
                                                          String resultItemId)
                                                   throws EventNavigatorException
保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。

パラメータ:
userId - ユーザID
resultItemId - ナビゲート結果ID
戻り値:
保存ナビゲート結果情報
例外:
EventNavigatorException - 保存ナビゲート結果情報取得処理に失敗した場合にスローされます。

updateEventResultItemInfo

public void updateEventResultItemInfo(EventNavigatorManager manager,
                                      String userId,
                                      SaveEventResultItemInfo saveResultItemInfo)
                               throws EventNavigatorException
保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。

パラメータ:
userId - ユーザID
saveResultItemInfo - 保存ナビゲート結果情報
例外:
EventNavigatorException - 保存ナビゲート結果情報（ユーザ）更新処理に失敗した場合にスローされます。

updateEventResultItemInfoTitle

public void updateEventResultItemInfoTitle(EventNavigatorManager manager,
                                           String userId,
                                           SaveEventResultItemInfo saveResultItemInfo)
                                    throws EventNavigatorException
保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。

パラメータ:
userId - ユーザID
saveResultItemInfo - 保存ナビゲート結果情報
例外:
EventNavigatorException - 保存ナビゲート結果情報（ユーザ）更新処理に失敗した場合にスローされます。

getSaveEventResultItemInfos

public SaveEventResultItemInfo[] getSaveEventResultItemInfos(EventNavigatorManager manager,
                                                             String userId,
                                                             String searchTitle,
                                                             String sortKey,
                                                             String oeder,
                                                             int currentPage)
                                                      throws EventNavigatorException
保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。

パラメータ:
userId - ユーザID
searchTitle - 検索タイトル
sortKey - ソートキー
oeder - 昇降指定
currentPage - 表示指定頁
戻り値:
保存ナビゲート結果情報の配列（ユーザ）
例外:
EventNavigatorException - 保存ナビゲート結果情報一覧（ユーザ）取得処理に失敗した場合にスローされます。

removeSaveEventResultItemInfo

public void removeSaveEventResultItemInfo(EventNavigatorManager manager,
                                          String userId,
                                          String resultItemId)
                                   throws EventNavigatorException
保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。

パラメータ:
userId - ユーザID
resultItemId - 保存ナビゲート結果ID
例外:
EventNavigatorException - 保存ナビゲート結果情報削除処理に失敗した場合にスローされます。

addFavoriteSaveEventResultItemInfo

public void addFavoriteSaveEventResultItemInfo(EventNavigatorManager manager,
                                               String userId,
                                               String resultItemId)
                                        throws EventNavigatorException
保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。

パラメータ:
userId - ユーザID
resultItemId - 保存ナビゲート結果ID
例外:
EventNavigatorException - 保存ナビゲート結果情報お気に入りへ追加処理に失敗した場合にスローされます。

getSaveEventResultItemInfosHistory

public SaveEventResultItemInfo[] getSaveEventResultItemInfosHistory(EventNavigatorManager manager,
                                                                    String userId)
                                                             throws EventNavigatorException
保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。

パラメータ:
userId - ユーザID
戻り値:
保存ナビゲート結果情報の配列（履歴）
例外:
EventNavigatorException - 保存ナビゲート結果情報一覧（履歴）取得処理に失敗した場合にスローされます。

updateEventFlow

public void updateEventFlow(EventNavigatorManager manager,
                            EventFlow eventFllow)
                     throws EventNavigatorException
イベントフローの更新 イベントフロー情報をDB更新する。

パラメータ:
eventFllow - イベントフロー
例外:
EventNavigatorException - イベントフロー更新処理に失敗した場合にスローされます。

setOrderSortNum

public void setOrderSortNum(EventNavigatorManager manager,
                            EventFlowInfo[] eventFlowInfos)
                     throws EventNavigatorException
表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。

例外:
EventNavigatorException - 表示順設定処理に失敗した場合にスローされます。

setViewOpen

public void setViewOpen(EventNavigatorManager manager,
                        String eventFlowId,
                        String open)
                 throws EventNavigatorException
表示設定 イベントフロー情報に表示／非表示を設定する。

パラメータ:
eventFlowId - イベントフローID
open - 表示フラグ
例外:
EventNavigatorException - 表示順設定処理に失敗した場合にスローされます。

getEventFlowIds

public String[] getEventFlowIds(EventNavigatorManager manager)
                         throws EventNavigatorException
すべてのイベントフローIDを取得します。

戻り値:
イベントフローIDの配列
例外:
EventNavigatorException

getLinkPageInfo

public LinkPageInfo getLinkPageInfo(EventNavigatorManager manager,
                                    String eventFlowId,
                                    String eventResultId,
                                    String resultPageId)
                             throws EventNavigatorException
結果ページ情報を取得します。

パラメータ:
manager -
eventFlowId - イベントフローID
eventResultId - ナビゲート結果ID
resultPageId - 結果ページID
戻り値:
結果ページ情報
例外:
EventNavigatorException

getSaveLinkPageInfo

public LinkPageInfo getSaveLinkPageInfo(EventNavigatorManager manager,
                                        String userId,
                                        String eventResultId,
                                        String resultPageId)
                                 throws EventNavigatorException
保存結果ページ情報を取得します。

パラメータ:
manager -
userId - ユーザID
eventResultId - ナビゲート結果ID
resultPageId - 結果ページID
戻り値:
保存結果ページ情報
例外:
EventNavigatorException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventNavigatorConst (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventNavigatorConst

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.EventNavigatorConst
public class EventNavigatorConst
extends Object

イベントナビゲーターで使用する定数の一覧

フィールドの概要
static String | ATTRIBUTE_TYPE_HISTORY_COUNT 属性タイプ ：履歴表示件数
static String | COLUMN_NAVIGATOR_ACTION_TYPE
static String | COLUMN_NAVIGATOR_ANSWER
static String | COLUMN_NAVIGATOR_COMPANY_CD
static String | COLUMN_NAVIGATOR_DEPARTMENT_CD
static String | COLUMN_NAVIGATOR_DESCRIPTION
static String | COLUMN_NAVIGATOR_EVENT_FLOW_ID イベントフロー
static String | COLUMN_NAVIGATOR_EVENT_ITEM_ID イベントアイテム
static String | COLUMN_NAVIGATOR_EVENT_RESULT_ID ナビゲート結果
static String | COLUMN_NAVIGATOR_IDENTIFICATION_ID タイトル情報
static String | COLUMN_NAVIGATOR_LOCALE
static String | COLUMN_NAVIGATOR_MAX_SORT_NUM
static String | COLUMN_NAVIGATOR_NEXT_ITEM_ID
static String | COLUMN_NAVIGATOR_OPEN
static String | COLUMN_NAVIGATOR_PAGE_URL
static String | COLUMN_NAVIGATOR_PARAM_KEY ページパラメータ
static String | COLUMN_NAVIGATOR_PARAM_VALUE
static String | COLUMN_NAVIGATOR_PERMISSION_CHECK_FLAG
static String | COLUMN_NAVIGATOR_POST_CD
static String | COLUMN_NAVIGATOR_PUBLIC_GROUP_CD
static String | COLUMN_NAVIGATOR_PUBLIC_GROUP_SET_CD
static String | COLUMN_NAVIGATOR_QUESTION 保存イベント履歴
static String | COLUMN_NAVIGATOR_RECORD_DATE
static String | COLUMN_NAVIGATOR_RECORD_USER 共通
static String | COLUMN_NAVIGATOR_RESULT_PAGE_ID 結果ページ
static String | COLUMN_NAVIGATOR_ROLE_ID 権限情報
static String | COLUMN_NAVIGATOR_SELECT_ITEM_ID 選択アイテム
static String | COLUMN_NAVIGATOR_SORT_NUMBER
static String | COLUMN_NAVIGATOR_START_EVENT_ITEM_ID
static String | COLUMN_NAVIGATOR_TITLE
static String | COLUMN_NAVIGATOR_TYPE
static String | COLUMN_NAVIGATOR_USER_ID 保存ナビゲート結果
static String | CONFIG_FILE
static String | DB_DB2
static String | DB_ORACLE
static String | DB_POSTGRE
static String | DEFAULT_ACCESSOR
static String | DEFAULT_COMMENT
static String | DEFAULT_CONFIG_PAGE_COUNT 履歴表示件数 ：デフォルト件数
static String | DEFAULT_EXPORTER
static String | DEFAULT_IMPORTER
static String | DEFAULT_TITLE
static String | ESCAPE_LEFT_PARENTHESIS
static String | ESCAPE_PERCENTAGE
static String | ESCAPE_RIGHT_PARENTHESIS
static String | ESCAPE_STRING エスケープ文字
static String | ESCAPE_UNDER_SCORE
static String | EVENT_NAVIGATOR_PERMISSION_SELECTOR アクセス権限チェッククラス取得用キー
static String | ID_NAVIGATOR_ACCESS_INFO ACCESS INFO
static String | ID_NAVIGATOR_COMMENT
static String | ID_NAVIGATOR_COMPANY_ID
static String | ID_NAVIGATOR_DEPARTMENT
static String | ID_NAVIGATOR_DEPARTMENT_ID
static String | ID_NAVIGATOR_EVENT_FLOW EVENT FLOW
static String | ID_NAVIGATOR_EVENT_FLOW_ID
static String | ID_NAVIGATOR_EVENT_FLOW_OPEN
static String | ID_NAVIGATOR_EVENT_FLOW_SORT_NUMBER
static String | ID_NAVIGATOR_EVENT_ITEM EVENT ITEM
static String | ID_NAVIGATOR_EVENT_ITEM_ID
static String | ID_NAVIGATOR_EVENT_RESULT EVENT RESULT
static String | ID_NAVIGATOR_EVENT_RESULT_ID
static String | ID_NAVIGATOR_GROUP_ID
static String | ID_NAVIGATOR_GROUP_SET_ID
static String | ID_NAVIGATOR_ITEM_TYPE
static String | ID_NAVIGATOR_LINK_PAGE LINK PAGE
static String | ID_NAVIGATOR_LOCALE
static String | ID_NAVIGATOR_PARAM
static String | ID_NAVIGATOR_PARAM_KEY
static String | ID_NAVIGATOR_PARAM_VALUE
static String | ID_NAVIGATOR_POST
static String | ID_NAVIGATOR_POST_ID
static String | ID_NAVIGATOR_PUBLIC_GROUP
static String | ID_NAVIGATOR_RESULT_PAGE RESULT PAGE
static String | ID_NAVIGATOR_RESULT_PAGE_ID
static String | ID_NAVIGATOR_RESULT_PAGE_LIST
static String | ID_NAVIGATOR_ROLE
static String | ID_NAVIGATOR_ROLE_ID
static String | ID_NAVIGATOR_SELECT_ITEM SELECT ITEM
static String | ID_NAVIGATOR_SELECT_ITEM_ID
static String | ID_NAVIGATOR_SELECT_ITEM_LIST
static String | ID_NAVIGATOR_TITLE
static String | ID_NAVIGATOR_TITLE_INFO TITLE INFO
static String | ID_NAVIGATOR_URL
static String | ID_ROOT
static String | ID_ROOT_NAVIGATOR
static String | KIND_NAVIGATOR 種別 イベントナビゲーター
static String | OPEN_FLG_CLOSE 公開フラグ：非公開
static String | OPEN_FLG_EDIT 公開フラグ：編集中
static String | OPEN_FLG_OPEN 公開フラグ：公開
static String | ROOT_FOLDER
static String | SAVE_TYPE_FAVORITE ナビゲート結果保存タイプ：お気に入り
static String | SAVE_TYPE_HISTORY ナビゲート結果保存タイプ：履歴
static String | TABLE_B_M_EVENT_DEPARTMENT
static String | TABLE_B_M_EVENT_FLOW
static String | TABLE_B_M_EVENT_ITEM
static String | TABLE_B_M_EVENT_PAGE
static String | TABLE_B_M_EVENT_PAGE_PARAM
static String | TABLE_B_M_EVENT_POST
static String | TABLE_B_M_EVENT_PUBLIC_GROUP
static String | TABLE_B_M_EVENT_RESULT
static String | TABLE_B_M_EVENT_ROLE
static String | TABLE_B_M_EVENT_SAVE_RESULT
static String | TABLE_B_M_EVENT_SELECT
static String | TABLE_B_M_EVENT_TITLE_INFO
static String | TYPE_EVENT 遷移先タイプ：イベントアイテム
static String | TYPE_RESULT 遷移先タイプ：ナビゲート結果
コンストラクタの概要
EventNavigatorConst()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KIND_NAVIGATOR

public static final String KIND_NAVIGATOR
種別 イベントナビゲーター

関連項目:
定数フィールド値

TYPE_EVENT

public static final String TYPE_EVENT
遷移先タイプ：イベントアイテム

関連項目:
定数フィールド値

TYPE_RESULT

public static final String TYPE_RESULT
遷移先タイプ：ナビゲート結果

関連項目:
定数フィールド値

SAVE_TYPE_FAVORITE

public static final String SAVE_TYPE_FAVORITE
ナビゲート結果保存タイプ：お気に入り

関連項目:
定数フィールド値

SAVE_TYPE_HISTORY

public static final String SAVE_TYPE_HISTORY
ナビゲート結果保存タイプ：履歴

関連項目:
定数フィールド値

DEFAULT_CONFIG_PAGE_COUNT

public static final String DEFAULT_CONFIG_PAGE_COUNT
履歴表示件数 ：デフォルト件数

関連項目:
定数フィールド値

ATTRIBUTE_TYPE_HISTORY_COUNT

public static final String ATTRIBUTE_TYPE_HISTORY_COUNT
属性タイプ ：履歴表示件数

関連項目:
定数フィールド値

EVENT_NAVIGATOR_PERMISSION_SELECTOR

public static final String EVENT_NAVIGATOR_PERMISSION_SELECTOR
アクセス権限チェッククラス取得用キー

関連項目:
定数フィールド値

OPEN_FLG_OPEN

public static final String OPEN_FLG_OPEN
公開フラグ：公開

関連項目:
定数フィールド値

OPEN_FLG_CLOSE

public static final String OPEN_FLG_CLOSE
公開フラグ：非公開

関連項目:
定数フィールド値

OPEN_FLG_EDIT

public static final String OPEN_FLG_EDIT
公開フラグ：編集中

関連項目:
定数フィールド値

DEFAULT_ACCESSOR

public static final String DEFAULT_ACCESSOR
関連項目:
定数フィールド値

DEFAULT_IMPORTER

public static final String DEFAULT_IMPORTER
関連項目:
定数フィールド値

DEFAULT_EXPORTER

public static final String DEFAULT_EXPORTER
関連項目:
定数フィールド値

ROOT_FOLDER

public static final String ROOT_FOLDER
関連項目:
定数フィールド値

CONFIG_FILE

public static final String CONFIG_FILE
関連項目:
定数フィールド値

DEFAULT_TITLE

public static final String DEFAULT_TITLE
関連項目:
定数フィールド値

DEFAULT_COMMENT

public static final String DEFAULT_COMMENT
関連項目:
定数フィールド値

TABLE_B_M_EVENT_FLOW

public static final String TABLE_B_M_EVENT_FLOW
関連項目:
定数フィールド値

TABLE_B_M_EVENT_ITEM

public static final String TABLE_B_M_EVENT_ITEM
関連項目:
定数フィールド値

TABLE_B_M_EVENT_SELECT

public static final String TABLE_B_M_EVENT_SELECT
関連項目:
定数フィールド値

TABLE_B_M_EVENT_RESULT

public static final String TABLE_B_M_EVENT_RESULT
関連項目:
定数フィールド値

TABLE_B_M_EVENT_PAGE

public static final String TABLE_B_M_EVENT_PAGE
関連項目:
定数フィールド値

TABLE_B_M_EVENT_PAGE_PARAM

public static final String TABLE_B_M_EVENT_PAGE_PARAM
関連項目:
定数フィールド値

TABLE_B_M_EVENT_TITLE_INFO

public static final String TABLE_B_M_EVENT_TITLE_INFO
関連項目:
定数フィールド値

TABLE_B_M_EVENT_ROLE

public static final String TABLE_B_M_EVENT_ROLE
関連項目:
定数フィールド値

TABLE_B_M_EVENT_DEPARTMENT

public static final String TABLE_B_M_EVENT_DEPARTMENT
関連項目:
定数フィールド値

TABLE_B_M_EVENT_POST

public static final String TABLE_B_M_EVENT_POST
関連項目:
定数フィールド値

TABLE_B_M_EVENT_PUBLIC_GROUP

public static final String TABLE_B_M_EVENT_PUBLIC_GROUP
関連項目:
定数フィールド値

TABLE_B_M_EVENT_SAVE_RESULT

public static final String TABLE_B_M_EVENT_SAVE_RESULT
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_RECORD_USER

public static final String COLUMN_NAVIGATOR_RECORD_USER
共通

関連項目:
定数フィールド値

COLUMN_NAVIGATOR_RECORD_DATE

public static final String COLUMN_NAVIGATOR_RECORD_DATE
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_EVENT_FLOW_ID

public static final String COLUMN_NAVIGATOR_EVENT_FLOW_ID
イベントフロー

関連項目:
定数フィールド値

COLUMN_NAVIGATOR_START_EVENT_ITEM_ID

public static final String COLUMN_NAVIGATOR_START_EVENT_ITEM_ID
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_OPEN

public static final String COLUMN_NAVIGATOR_OPEN
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_SORT_NUMBER

public static final String COLUMN_NAVIGATOR_SORT_NUMBER
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_MAX_SORT_NUM

public static final String COLUMN_NAVIGATOR_MAX_SORT_NUM
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_PERMISSION_CHECK_FLAG

public static final String COLUMN_NAVIGATOR_PERMISSION_CHECK_FLAG
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_EVENT_ITEM_ID

public static final String COLUMN_NAVIGATOR_EVENT_ITEM_ID
イベントアイテム

関連項目:
定数フィールド値

COLUMN_NAVIGATOR_SELECT_ITEM_ID

public static final String COLUMN_NAVIGATOR_SELECT_ITEM_ID
選択アイテム

関連項目:
定数フィールド値

COLUMN_NAVIGATOR_ACTION_TYPE

public static final String COLUMN_NAVIGATOR_ACTION_TYPE
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_NEXT_ITEM_ID

public static final String COLUMN_NAVIGATOR_NEXT_ITEM_ID
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_EVENT_RESULT_ID

public static final String COLUMN_NAVIGATOR_EVENT_RESULT_ID
ナビゲート結果

関連項目:
定数フィールド値

COLUMN_NAVIGATOR_RESULT_PAGE_ID

public static final String COLUMN_NAVIGATOR_RESULT_PAGE_ID
結果ページ

関連項目:
定数フィールド値

COLUMN_NAVIGATOR_PAGE_URL

public static final String COLUMN_NAVIGATOR_PAGE_URL
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_PARAM_KEY

public static final String COLUMN_NAVIGATOR_PARAM_KEY
ページパラメータ

関連項目:
定数フィールド値

COLUMN_NAVIGATOR_PARAM_VALUE

public static final String COLUMN_NAVIGATOR_PARAM_VALUE
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_IDENTIFICATION_ID

public static final String COLUMN_NAVIGATOR_IDENTIFICATION_ID
タイトル情報

関連項目:
定数フィールド値

COLUMN_NAVIGATOR_LOCALE

public static final String COLUMN_NAVIGATOR_LOCALE
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_TITLE

public static final String COLUMN_NAVIGATOR_TITLE
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_DESCRIPTION

public static final String COLUMN_NAVIGATOR_DESCRIPTION
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_ROLE_ID

public static final String COLUMN_NAVIGATOR_ROLE_ID
権限情報

関連項目:
定数フィールド値

COLUMN_NAVIGATOR_COMPANY_CD

public static final String COLUMN_NAVIGATOR_COMPANY_CD
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_DEPARTMENT_CD

public static final String COLUMN_NAVIGATOR_DEPARTMENT_CD
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_POST_CD

public static final String COLUMN_NAVIGATOR_POST_CD
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_PUBLIC_GROUP_SET_CD

public static final String COLUMN_NAVIGATOR_PUBLIC_GROUP_SET_CD
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_PUBLIC_GROUP_CD

public static final String COLUMN_NAVIGATOR_PUBLIC_GROUP_CD
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_USER_ID

public static final String COLUMN_NAVIGATOR_USER_ID
保存ナビゲート結果

関連項目:
定数フィールド値

COLUMN_NAVIGATOR_TYPE

public static final String COLUMN_NAVIGATOR_TYPE
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_QUESTION

public static final String COLUMN_NAVIGATOR_QUESTION
保存イベント履歴

関連項目:
定数フィールド値

COLUMN_NAVIGATOR_ANSWER

public static final String COLUMN_NAVIGATOR_ANSWER
関連項目:
定数フィールド値

ESCAPE_STRING

public static final String ESCAPE_STRING
エスケープ文字

関連項目:
定数フィールド値

ESCAPE_UNDER_SCORE

public static final String ESCAPE_UNDER_SCORE
関連項目:
定数フィールド値

ESCAPE_PERCENTAGE

public static final String ESCAPE_PERCENTAGE
関連項目:
定数フィールド値

ESCAPE_LEFT_PARENTHESIS

public static final String ESCAPE_LEFT_PARENTHESIS
関連項目:
定数フィールド値

ESCAPE_RIGHT_PARENTHESIS

public static final String ESCAPE_RIGHT_PARENTHESIS
関連項目:
定数フィールド値

DB_ORACLE

public static final String DB_ORACLE
関連項目:
定数フィールド値

DB_DB2

public static final String DB_DB2
関連項目:
定数フィールド値

DB_POSTGRE

public static final String DB_POSTGRE
関連項目:
定数フィールド値

ID_ROOT

public static final String ID_ROOT
関連項目:
定数フィールド値

ID_ROOT_NAVIGATOR

public static final String ID_ROOT_NAVIGATOR
関連項目:
定数フィールド値

ID_NAVIGATOR_EVENT_FLOW

public static final String ID_NAVIGATOR_EVENT_FLOW
EVENT FLOW

関連項目:
定数フィールド値

ID_NAVIGATOR_EVENT_FLOW_ID

public static final String ID_NAVIGATOR_EVENT_FLOW_ID
関連項目:
定数フィールド値

ID_NAVIGATOR_EVENT_FLOW_OPEN

public static final String ID_NAVIGATOR_EVENT_FLOW_OPEN
関連項目:
定数フィールド値

ID_NAVIGATOR_EVENT_FLOW_SORT_NUMBER

public static final String ID_NAVIGATOR_EVENT_FLOW_SORT_NUMBER
関連項目:
定数フィールド値

ID_NAVIGATOR_EVENT_ITEM

public static final String ID_NAVIGATOR_EVENT_ITEM
EVENT ITEM

関連項目:
定数フィールド値

ID_NAVIGATOR_EVENT_ITEM_ID

public static final String ID_NAVIGATOR_EVENT_ITEM_ID
関連項目:
定数フィールド値

ID_NAVIGATOR_SELECT_ITEM_LIST

public static final String ID_NAVIGATOR_SELECT_ITEM_LIST
関連項目:
定数フィールド値

ID_NAVIGATOR_SELECT_ITEM

public static final String ID_NAVIGATOR_SELECT_ITEM
SELECT ITEM

関連項目:
定数フィールド値

ID_NAVIGATOR_SELECT_ITEM_ID

public static final String ID_NAVIGATOR_SELECT_ITEM_ID
関連項目:
定数フィールド値

ID_NAVIGATOR_ITEM_TYPE

public static final String ID_NAVIGATOR_ITEM_TYPE
関連項目:
定数フィールド値

ID_NAVIGATOR_EVENT_RESULT

public static final String ID_NAVIGATOR_EVENT_RESULT
EVENT RESULT

関連項目:
定数フィールド値

ID_NAVIGATOR_EVENT_RESULT_ID

public static final String ID_NAVIGATOR_EVENT_RESULT_ID
関連項目:
定数フィールド値

ID_NAVIGATOR_RESULT_PAGE_LIST

public static final String ID_NAVIGATOR_RESULT_PAGE_LIST
関連項目:
定数フィールド値

ID_NAVIGATOR_RESULT_PAGE

public static final String ID_NAVIGATOR_RESULT_PAGE
RESULT PAGE

関連項目:
定数フィールド値

ID_NAVIGATOR_RESULT_PAGE_ID

public static final String ID_NAVIGATOR_RESULT_PAGE_ID
関連項目:
定数フィールド値

ID_NAVIGATOR_LINK_PAGE

public static final String ID_NAVIGATOR_LINK_PAGE
LINK PAGE

関連項目:
定数フィールド値

ID_NAVIGATOR_URL

public static final String ID_NAVIGATOR_URL
関連項目:
定数フィールド値

ID_NAVIGATOR_PARAM

public static final String ID_NAVIGATOR_PARAM
関連項目:
定数フィールド値

ID_NAVIGATOR_PARAM_KEY

public static final String ID_NAVIGATOR_PARAM_KEY
関連項目:
定数フィールド値

ID_NAVIGATOR_PARAM_VALUE

public static final String ID_NAVIGATOR_PARAM_VALUE
関連項目:
定数フィールド値

ID_NAVIGATOR_TITLE_INFO

public static final String ID_NAVIGATOR_TITLE_INFO
TITLE INFO

関連項目:
定数フィールド値

ID_NAVIGATOR_LOCALE

public static final String ID_NAVIGATOR_LOCALE
関連項目:
定数フィールド値

ID_NAVIGATOR_TITLE

public static final String ID_NAVIGATOR_TITLE
関連項目:
定数フィールド値

ID_NAVIGATOR_COMMENT

public static final String ID_NAVIGATOR_COMMENT
関連項目:
定数フィールド値

ID_NAVIGATOR_ACCESS_INFO

public static final String ID_NAVIGATOR_ACCESS_INFO
ACCESS INFO

関連項目:
定数フィールド値

ID_NAVIGATOR_ROLE

public static final String ID_NAVIGATOR_ROLE
関連項目:
定数フィールド値

ID_NAVIGATOR_ROLE_ID

public static final String ID_NAVIGATOR_ROLE_ID
関連項目:
定数フィールド値

ID_NAVIGATOR_DEPARTMENT

public static final String ID_NAVIGATOR_DEPARTMENT
関連項目:
定数フィールド値

ID_NAVIGATOR_DEPARTMENT_ID

public static final String ID_NAVIGATOR_DEPARTMENT_ID
関連項目:
定数フィールド値

ID_NAVIGATOR_COMPANY_ID

public static final String ID_NAVIGATOR_COMPANY_ID
関連項目:
定数フィールド値

ID_NAVIGATOR_POST

public static final String ID_NAVIGATOR_POST
関連項目:
定数フィールド値

ID_NAVIGATOR_POST_ID

public static final String ID_NAVIGATOR_POST_ID
関連項目:
定数フィールド値

ID_NAVIGATOR_PUBLIC_GROUP

public static final String ID_NAVIGATOR_PUBLIC_GROUP
関連項目:
定数フィールド値

ID_NAVIGATOR_GROUP_ID

public static final String ID_NAVIGATOR_GROUP_ID
関連項目:
定数フィールド値

ID_NAVIGATOR_GROUP_SET_ID

public static final String ID_NAVIGATOR_GROUP_SET_ID
関連項目:
定数フィールド値
コンストラクタの詳細

EventNavigatorConst

public EventNavigatorConst()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventNavigatorException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventNavigatorException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.navigator.EventNavigatorException
すべての実装インタフェース:
Serializable
public class EventNavigatorException
extends DataStoreApplicationException

イベントナビゲータマネージャに関する例外クラス

導入されたバージョン:
6.1
関連項目:
直列化された形式

コンストラクタの概要
EventNavigatorException()
コンストラクタ
EventNavigatorException(String message)
コンストラクタ
EventNavigatorException(String message, Throwable cause)
コンストラクタ
EventNavigatorException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EventNavigatorException

public EventNavigatorException()
コンストラクタ

EventNavigatorException

public EventNavigatorException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

EventNavigatorException

public EventNavigatorException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

EventNavigatorException

public EventNavigatorException(String message,
                               Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventNavigatorExporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
インタフェース EventNavigatorExporter

既知の実装クラスの一覧:
StandardEventNavigatorExporter
public interface EventNavigatorExporter

イベントナビゲータバックアップインタフェースです。

バージョン:
1.0

メソッドの概要
void | doExport(EventNavigatorManager manager, OutputStream outputStream, boolean editFlag) エクスポートを行います。
void | init(String[] args) イベントナビゲータバックアップエクスポータの初期化。

メソッドの詳細

init

public void init(String[] args)
イベントナビゲータバックアップエクスポータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

doExport

public void doExport(EventNavigatorManager manager,
                     OutputStream outputStream,
                     boolean editFlag)
              throws EventNavigatorException
エクスポートを行います。

イベントナビゲータ情報をバックアップファイルに出力します。

パラメータ:
manager - イベントナビゲータマネージャ イベントナビゲータモデルクラスの配列
outputStream - 出力ストリーム
例外:
EventNavigatorException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventNavigatorHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventNavigatorHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.EventNavigatorHandler
public class EventNavigatorHandler
extends Object

コンストラクタの概要
EventNavigatorHandler()
メソッドの概要
static String getMessage(String key, String arg)
メッセージの取得。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventNavigatorHandler

public EventNavigatorHandler()
メソッドの詳細

getMessage

public static String getMessage(String key,
                                String arg)
メッセージの取得。

パラメータ:
key - メッセージのキー
arg - メッセージパラメータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventNavigatorImporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
インタフェース EventNavigatorImporter

既知の実装クラスの一覧:
StandardEventNavigatorImporter
public interface EventNavigatorImporter

イベントナビゲータバックアップインタフェースです。

バージョン:
1.0

メソッドの概要
void | doImport(EventNavigatorManager manager, InputStream inputStream) インポートを行います。
void | init(String[] args) イベントナビゲータバックアップインポータの初期化。

メソッドの詳細

init

public void init(String[] args)
イベントナビゲータバックアップインポータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

doImport

public void doImport(EventNavigatorManager manager,
                     InputStream inputStream)
              throws EventNavigatorException
インポートを行います。

ストリーム内の情報からイベントナビゲータ情報を取得し、生成します。

パラメータ:
manager - イベントナビゲータマネージャクラス
inputStream - 入力ストリーム
例外:
EventNavigatorException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventNavigatorManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventNavigatorManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.EventNavigatorManager
public class EventNavigatorManager
extends Object

イベントナビゲーター管理マネージャクラス。

イベントナビゲーター情報に関連する操作を行います。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
EventNavigatorManager(String groupId, String locale)
コンストラクタ。
メソッドの概要
String | addEventResultItemInfo(String userId, String eventFlowId, EventResultItemInfo resultItemInfo) 保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
void | addFavoriteSaveEventResultItemInfo(String userId, String resultItemId) 保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。
EventFlow | copyEventFlow(String eventFllowId) イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
void | deleteEventFlow(String eventFlowId) イベントフローの削除 イベントフローIDから、イベントフローを削除する。
void | deleteSaveResultHistory(String userId) 保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。
void | exportData(OutputStream outputStream, boolean editFlag) エクスポートを行います。
String | getConfigPageCount(String userId) 履歴表示件数の取得。
EventFlow | getEventFlow(String eventFllowId) イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
EventFlowInfo[] | getEventFlowInfos(String searchTitle, boolean permissionCheck, int currentPage) イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
EventFlow[] | getEventFlows() イベントフローの取得（全件） 全イベントフローを取得し、返却する。
EventItemInfo | getEventItemInfo(String eventFllowId, String eventItemId) イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
EventResultItemInfo | getEventResultItemInfo(String eventFllowId, String resultItemId) ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
LinkPageInfo | getLinkPageInfo(String eventFlowId, String eventResultId, String resultPageId) 結果ページ情報を取得します。
String | getLocale() ロケールを取得します。
String | getLoginGroupId() ログイングループIDを取得します。
SaveEventResultItemInfo | getSaveEventResultItemInfo(String userId, String resultItemId) 保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
SaveEventResultItemInfo[] | getSaveEventResultItemInfos(String searchTitle, String userId, String sortKey, String oeder, int currentPage) 保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
SaveEventResultItemInfo[] | getSaveEventResultItemInfosHistory(String userId) 保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
LinkPageInfo | getSaveLinkPageInfo(String userId, String eventResultId, String resultPageId) 保存結果ページ情報を取得します。
void | importData(InputStream inputStream) インポートを行います。
void | registEventFlow(EventFlow eventFllow) イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
void | removeSaveEventResultItemInfo(String userId, String resultItemId) 保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。
void | setConfigPageCount(String userId, int iCount) 履歴表示件数の設定。
void | setOrderSortNum(EventFlowInfo[] eventFlowInfos) 表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
void | setViewOpen(String eventFlowId, String open) 表示設定 イベントフロー情報に表示／非表示を設定する。
void | updateEventFlow(EventFlow eventFllow) イベントフローの更新 イベントフロー情報をDB更新する。
void | updateEventResultItemInfo(String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | updateEventResultItemInfoTitle(String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventNavigatorManager

public EventNavigatorManager(String groupId,
                             String locale)
                      throws EventNavigatorException
コンストラクタ。

パラメータ:
groupId - ログイングループID
locale - ロケール
メソッドの詳細

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

戻り値:
ログイングループID

getLocale

public String getLocale()
ロケールを取得します。

戻り値:
ロケール

getEventFlowInfos

public EventFlowInfo[] getEventFlowInfos(String searchTitle,
                                         boolean permissionCheck,
                                         int currentPage)
                                  throws EventNavigatorException
イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。

パラメータ:
searchTitle - 検索タイトル
permissionCheck - 権限チェック要否
currentPage - 表示指定頁
戻り値:
イベントフロー情報一覧
例外:
EventNavigatorException - イベントフロー情報一覧取得処理に失敗した場合にスローされます。

deleteEventFlow

public void deleteEventFlow(String eventFlowId)
                     throws EventNavigatorException
イベントフローの削除 イベントフローIDから、イベントフローを削除する。

例外:
EventNavigatorException - イベントフロー削除処理に失敗した場合にスローされます。

getEventFlow

public EventFlow getEventFlow(String eventFllowId)
                       throws EventNavigatorException
イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。

パラメータ:
eventFllowId - イベントフローID
戻り値:
イベントフロー
例外:
EventNavigatorException - イベントフロー取得処理に失敗した場合にスローされます。

getEventFlows

public EventFlow[] getEventFlows()
                          throws EventNavigatorException
イベントフローの取得（全件） 全イベントフローを取得し、返却する。

戻り値:
イベントフローの配列
例外:
EventNavigatorException - イベントフロー取得処理に失敗した場合にスローされます。

registEventFlow

public void registEventFlow(EventFlow eventFllow)
                     throws EventNavigatorException
イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。

パラメータ:
eventFllow - イベントフロー
例外:
EventNavigatorException - イベントフロー登録処理に失敗した場合にスローされます。

copyEventFlow

public EventFlow copyEventFlow(String eventFllowId)
                        throws EventNavigatorException
イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。

パラメータ:
eventFllowId - コピー元イベントフローID
戻り値:
コピー先イベントフロー
例外:
EventNavigatorException - イベントフローコピー処理に失敗した場合にスローされます。

getEventItemInfo

public EventItemInfo getEventItemInfo(String eventFllowId,
                                      String eventItemId)
                               throws EventNavigatorException
イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。

パラメータ:
eventFllowId - イベントフローID
eventItemId - イベントアイテムID
戻り値:
イベントアイテム情報
例外:
EventNavigatorException - イベントアイテム情報取得処理に失敗した場合にスローされます。

getEventResultItemInfo

public EventResultItemInfo getEventResultItemInfo(String eventFllowId,
                                                  String resultItemId)
                                           throws EventNavigatorException
ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。

パラメータ:
eventFllowId - イベントフローID
resultItemId - ナビゲート結果ID
戻り値:
ナビゲート結果情報
例外:
EventNavigatorException - ナビゲート結果情報取得処理に失敗した場合にスローされます。

addEventResultItemInfo

public String addEventResultItemInfo(String userId,
                                     String eventFlowId,
                                     EventResultItemInfo resultItemInfo)
                              throws EventNavigatorException
保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。

パラメータ:
userId - ユーザID
resultItemInfo - ナビゲート結果情報
戻り値:
保存ナビゲート結果ID
例外:
EventNavigatorException - 保存ナビゲート結果情報（履歴）登録処理に失敗した場合にスローされます。

deleteSaveResultHistory

public void deleteSaveResultHistory(String userId)
                             throws EventNavigatorException
保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。

パラメータ:
userId - ユーザID
例外:
EventNavigatorException - 保存ナビゲート結果情報（履歴）削除処理に失敗した場合にスローされます。

getSaveEventResultItemInfo

public SaveEventResultItemInfo getSaveEventResultItemInfo(String userId,
                                                          String resultItemId)
                                                   throws EventNavigatorException
保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。

パラメータ:
userId - ユーザID
resultItemId - ナビゲート結果ID
戻り値:
保存ナビゲート結果情報
例外:
EventNavigatorException - 保存ナビゲート結果情報取得処理に失敗した場合にスローされます。

updateEventResultItemInfo

public void updateEventResultItemInfo(String userId,
                                      SaveEventResultItemInfo saveResultItemInfo)
                               throws EventNavigatorException
保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。

パラメータ:
userId - ユーザID
saveResultItemInfo - 保存ナビゲート結果情報
例外:
EventNavigatorException - 保存ナビゲート結果情報更新（ユーザ）処理に失敗した場合にスローされます。

updateEventResultItemInfoTitle

public void updateEventResultItemInfoTitle(String userId,
                                           SaveEventResultItemInfo saveResultItemInfo)
                                    throws EventNavigatorException
保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。

パラメータ:
userId - ユーザID
saveResultItemInfo - 保存ナビゲート結果情報
例外:
EventNavigatorException - 保存ナビゲート結果情報更新（ユーザ）処理に失敗した場合にスローされます。

getSaveEventResultItemInfos

public SaveEventResultItemInfo[] getSaveEventResultItemInfos(String searchTitle,
                                                             String userId,
                                                             String sortKey,
                                                             String oeder,
                                                             int currentPage)
                                                      throws EventNavigatorException
保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。

パラメータ:
searchTitle - 検索タイトル
userId - ユーザID
sortKey - ソートキー
oeder - 昇降指定
currentPage - 表示指定頁
戻り値:
保存ナビゲート結果情報の配列（ユーザ）
例外:
EventNavigatorException - 保存ナビゲート結果情報一覧（ユーザ）取得処理に失敗した場合にスローされます。

removeSaveEventResultItemInfo

public void removeSaveEventResultItemInfo(String userId,
                                          String resultItemId)
                                   throws EventNavigatorException
保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。

パラメータ:
userId - ユーザID
resultItemId - 保存ナビゲート結果ID
例外:
EventNavigatorException - 保存ナビゲート結果情報削除処理に失敗した場合にスローされます。

addFavoriteSaveEventResultItemInfo

public void addFavoriteSaveEventResultItemInfo(String userId,
                                               String resultItemId)
                                        throws EventNavigatorException
保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。

パラメータ:
userId - ユーザID
resultItemId - 保存ナビゲート結果ID
例外:
EventNavigatorException - 保存ナビゲート結果情報お気に入りへ追加処理に失敗した場合にスローされます。

getSaveEventResultItemInfosHistory

public SaveEventResultItemInfo[] getSaveEventResultItemInfosHistory(String userId)
                                                             throws EventNavigatorException
保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。

パラメータ:
userId - ユーザID
戻り値:
保存ナビゲート結果情報の配列（履歴）
例外:
EventNavigatorException - 保存ナビゲート結果情報一覧（履歴）取得処理に失敗した場合にスローされます。

updateEventFlow

public void updateEventFlow(EventFlow eventFllow)
                     throws EventNavigatorException
イベントフローの更新 イベントフロー情報をDB更新する。

パラメータ:
eventFllow - イベントフロー
例外:
EventNavigatorException - イベントフロー更新処理に失敗した場合にスローされます。

setOrderSortNum

public void setOrderSortNum(EventFlowInfo[] eventFlowInfos)
                     throws EventNavigatorException
表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。

例外:
EventNavigatorException - 表示順設定処理に失敗した場合にスローされます。

setViewOpen

public void setViewOpen(String eventFlowId,
                        String open)
                 throws EventNavigatorException
表示設定 イベントフロー情報に表示／非表示を設定する。

パラメータ:
eventFlowId - イベントフローID
open - 表示フラグ
例外:
EventNavigatorException - 表示順設定処理に失敗した場合にスローされます。

importData

public void importData(InputStream inputStream)
                throws EventNavigatorException
インポートを行います。

パラメータ:
inputStream - 入力ストリーム
例外:
EventNavigatorException - インポートに失敗した場合、または引数が不正だった場合にスローされます。

exportData

public void exportData(OutputStream outputStream,
                       boolean editFlag)
                throws EventNavigatorException
エクスポートを行います。

パラメータ:
outputStream - 出力ストリーム
例外:
EventNavigatorException - エクスポートに失敗した場合、または引数が不正だった場合にスローされます。

getLinkPageInfo

public LinkPageInfo getLinkPageInfo(String eventFlowId,
                                    String eventResultId,
                                    String resultPageId)
                             throws EventNavigatorException
結果ページ情報を取得します。

パラメータ:
eventFlowId - イベントフローID
eventResultId - ナビゲート結果ID
resultPageId - 結果ページID
戻り値:
結果ページ情報
例外:
EventNavigatorException

getSaveLinkPageInfo

public LinkPageInfo getSaveLinkPageInfo(String userId,
                                        String eventResultId,
                                        String resultPageId)
                                 throws EventNavigatorException
保存結果ページ情報を取得します。

パラメータ:
userId - ユーザID
eventResultId - ナビゲート結果ID
resultPageId - 結果ページID
戻り値:
保存結果ページ情報
例外:
EventNavigatorException

getConfigPageCount

public String getConfigPageCount(String userId)
                          throws EventNavigatorException
履歴表示件数の取得。

パラメータ:
userId - ユーザID
例外:
EventNavigatorException - 履歴表示件数の取得に失敗した場合にスローされます。

setConfigPageCount

public void setConfigPageCount(String userId,
                               int iCount)
                        throws EventNavigatorException
履歴表示件数の設定。

パラメータ:
userId - ユーザID
iCount - 履歴表示件数
例外:
EventNavigatorException - 履歴表示件数の設定に失敗した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventNavigatorPermissionSelector (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventNavigatorPermissionSelector

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.EventNavigatorPermissionSelector
すべての実装インタフェース:
PermissionSelector
public class EventNavigatorPermissionSelector
extends Object
implements PermissionSelector

ユーザIDから有効なID一覧を取得するセレクタ。

選択条件としてのユーザIDからアクセス可能なイベントフロー、選択アイテム、結果ページの固有IDを選択します。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
EventNavigatorPermissionSelector()
コンストラクタ。
メソッドの概要
Collection | doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
void | init(Map param) インスタンスの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventNavigatorPermissionSelector

public EventNavigatorPermissionSelector()
コンストラクタ。

メソッドの詳細

doSelection

public Collection doSelection(String groupId,
                              String[] infos)
                       throws AccessSecurityException
選択用情報を利用して選別された情報のリストを返却します。
返却される情報のリストの各要素はJavaBeansの規格に準ずるオブジェクトでなければなりません。

定義:
インタフェース PermissionSelector 内の doSelection
パラメータ:
groupId - ログイングループID
infos - 選択用情報(配列)
この情報を利用して、選別された情報のリストを作成して返却します。
戻り値:
選別された情報のリスト
例外:
AccessSecurityException

init

public void init(Map param)
インスタンスの初期化を行います。
このインスタンスが生成された時に1度だけコールされます。

定義:
インタフェース PermissionSelector 内の init
パラメータ:
param - XMLで定義されたPermissionSelectorに関連付けられたパラメータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventNavigatorReaderDecorator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
インタフェース EventNavigatorReaderDecorator

public interface EventNavigatorReaderDecorator

メソッドの概要
Object | doDecoration(EventNavigatorManager manager, Object obj) イベントナビゲータのオブジェクト情報をデータストアからの読み込み直後にコールされます。
void | init(String[] args) イベントナビゲータデコレータの初期化。

メソッドの詳細

init

public void init(String[] args)
イベントナビゲータデコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

doDecoration

public Object doDecoration(EventNavigatorManager manager,
                           Object obj)
イベントナビゲータのオブジェクト情報をデータストアからの読み込み直後にコールされます。

パラメータ:
manager - イベントナビゲータ管理オブジェクト
obj - 読み込みが行われた イベントナビゲータのオブジェクト情報
戻り値:
拡張された イベントナビゲータのオブジェクト情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventResultItem (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventResultItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.NavigatorItem
        拡張 jp.co.intra_mart.foundation.navigator.EventResultItem
すべての実装インタフェース:
Serializable
public class EventResultItem
extends NavigatorItem

ナビゲート結果クラス

関連項目:
直列化された形式

コンストラクタの概要
EventResultItem()
メソッドの概要
void | addPage(ResultPageItem page) リンクページ情報追加
ResultPageItem[] | getPageItem()
void | setPageItem(ResultPageItem[] pageItem)
クラス jp.co.intra_mart.foundation.navigator.NavigatorItem から継承したメソッド
getKeys, getTitleInfo, removeTitleInfo, setTitleInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventResultItem

public EventResultItem()
メソッドの詳細

getPageItem

public ResultPageItem[] getPageItem()
戻り値:
pageItem を戻します。

setPageItem

public void setPageItem(ResultPageItem[] pageItem)
パラメータ:
pageItem - 設定する pageItem。

addPage

public void addPage(ResultPageItem page)
リンクページ情報追加

パラメータ:
page - 追加するリンクページ情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventResultItemInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventResultItemInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.TitleInfo
        拡張 jp.co.intra_mart.foundation.navigator.EventResultItemInfo
すべての実装インタフェース:
Serializable
public class EventResultItemInfo
extends TitleInfo

ナビゲート結果情報

関連項目:
直列化された形式

コンストラクタの概要
EventResultItemInfo()
メソッドの概要
EventHistoryInfo[] | getEventHistory() イベント履歴情報リスト取得
String | getId() ナビゲート結果ID取得
ResultPageItemInfo[] | getResultPageItemInfos() 結果ページ情報リスト取得
void | setEventHistory(EventHistoryInfo[] eventHistory) イベント履歴情報リスト設定
void | setId(String id) ナビゲート結果ID設定
void | setResultPageItemInfos(ResultPageItemInfo[] resultPageItemInfos) 結果ページ情報リスト設定
クラス jp.co.intra_mart.foundation.navigator.TitleInfo から継承したメソッド
getComment, getTitle, setComment, setTitle
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventResultItemInfo

public EventResultItemInfo()
メソッドの詳細

getId

public String getId()
ナビゲート結果ID取得

戻り値:
Returns the id.

setId

public void setId(String id)
ナビゲート結果ID設定

パラメータ:
id - The id to set.

getResultPageItemInfos

public ResultPageItemInfo[] getResultPageItemInfos()
結果ページ情報リスト取得

戻り値:
Returns the resultPageItemInfos.

setResultPageItemInfos

public void setResultPageItemInfos(ResultPageItemInfo[] resultPageItemInfos)
結果ページ情報リスト設定

パラメータ:
resultPageItemInfos - The resultPageItemInfos to set.

getEventHistory

public EventHistoryInfo[] getEventHistory()
イベント履歴情報リスト取得

戻り値:
Returns the eventHistory.

setEventHistory

public void setEventHistory(EventHistoryInfo[] eventHistory)
イベント履歴情報リスト設定

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LinkPageInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス LinkPageInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.TitleInfo
        拡張 jp.co.intra_mart.foundation.navigator.LinkPageInfo
すべての実装インタフェース:
Serializable
public class LinkPageInfo
extends TitleInfo

リンク情報

関連項目:
直列化された形式

コンストラクタの概要
LinkPageInfo()
メソッドの概要
String[] | getKeys() URLパラメータリストのキー配列取得
String | getParamValue(String key)
String | getUrl() URL取得
void | setParamValue(String key, String value)
void | setUrl(String url) URL設定
クラス jp.co.intra_mart.foundation.navigator.TitleInfo から継承したメソッド
getComment, getTitle, setComment, setTitle
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LinkPageInfo

public LinkPageInfo()
メソッドの詳細

getUrl

public String getUrl()
URL取得

戻り値:
Returns the url.

setUrl

public void setUrl(String url)
URL設定

パラメータ:
url - The url to set.

getParamValue

public String getParamValue(String key)
戻り値:
URLパラメータ取得。

setParamValue

public void setParamValue(String key,
                          String value)

getKeys

public String[] getKeys()
URLパラメータリストのキー配列取得

戻り値:
Returns the param.
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NavigatorAuthenticateItem (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス NavigatorAuthenticateItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.NavigatorItem
        拡張 jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
EventFlow, ResultPageItem, SelectItem
public abstract class NavigatorAuthenticateItem
extends NavigatorItem

選択アイテムクラス

関連項目:
直列化された形式

コンストラクタの概要
NavigatorAuthenticateItem()
メソッドの概要
EventAccessInfo | getAccessInfo()
void | setAccessInfo(EventAccessInfo accessInfo)
クラス jp.co.intra_mart.foundation.navigator.NavigatorItem から継承したメソッド
getKeys, getTitleInfo, removeTitleInfo, setTitleInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NavigatorAuthenticateItem

public NavigatorAuthenticateItem()
メソッドの詳細

getAccessInfo

public EventAccessInfo getAccessInfo()
戻り値:
accessInfo を戻します。

setAccessInfo

public void setAccessInfo(EventAccessInfo accessInfo)
パラメータ:
accessInfo - 設定する accessInfo。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NavigatorItem (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス NavigatorItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.NavigatorItem
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
EventItem, EventResultItem, NavigatorAuthenticateItem
public abstract class NavigatorItem
extends Object
implements Serializable

イベントナビゲータアイテムクラス

関連項目:
直列化された形式

コンストラクタの概要
NavigatorItem()
メソッドの概要
Locale[] | getKeys() タイトル情報リストのキー配列取得
TitleInfo | getTitleInfo(Locale locale)
void | removeTitleInfo(Locale locale)
void | setTitleInfo(Locale locale, TitleInfo titleInfo)
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NavigatorItem

public NavigatorItem()
メソッドの詳細

getTitleInfo

public TitleInfo getTitleInfo(Locale locale)
戻り値:
titleInfo を戻します。

setTitleInfo

public void setTitleInfo(Locale locale,
                         TitleInfo titleInfo)
パラメータ:
titleInfo - 設定する titleInfo。

removeTitleInfo

public void removeTitleInfo(Locale locale)

getKeys

public Locale[] getKeys()
タイトル情報リストのキー配列取得

戻り値:
Returns the param.
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.navigator (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.navigator
インタフェース
EventNavigatorAccessor
EventNavigatorExporter
EventNavigatorImporter
EventNavigatorReaderDecorator
クラス
EventAccessInfo
EventFlow
EventFlowInfo
EventHistoryInfo
EventItem
EventItemInfo
EventNavigatorConst
EventNavigatorHandler
EventNavigatorManager
EventNavigatorPermissionSelector
EventResultItem
EventResultItemInfo
LinkPageInfo
NavigatorAuthenticateItem
NavigatorItem
ResultPageItem
ResultPageItemInfo
SaveEventHistoryInfo
SaveEventResultItemInfo
SelectItem
SelectItemInfo
StandardEventNavigatorAccessor
StandardEventNavigatorExporter
StandardEventNavigatorImporter
TitleInfo
例外
EventNavigatorException


jp.co.intra_mart.foundation.navigator (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.navigator

インタフェースの概要
EventNavigatorAccessor | イベントナビゲーター管理アクセッサインタフェース。
EventNavigatorExporter | イベントナビゲータバックアップインタフェースです。
EventNavigatorImporter | イベントナビゲータバックアップインタフェースです。
EventNavigatorReaderDecorator |

クラスの概要
EventAccessInfo | アクセス権情報
EventFlow | イベントフロークラス
EventFlowInfo | イベントフロー情報
EventHistoryInfo | イベント履歴情報
EventItem | イベントアイテムクラス
EventItemInfo | イベントアイテム情報
EventNavigatorConst | イベントナビゲーターで使用する定数の一覧
EventNavigatorHandler |
EventNavigatorManager | イベントナビゲーター管理マネージャクラス。
EventNavigatorPermissionSelector | ユーザIDから有効なID一覧を取得するセレクタ。
EventResultItem | ナビゲート結果クラス
EventResultItemInfo | ナビゲート結果情報
LinkPageInfo | リンク情報
NavigatorAuthenticateItem | 選択アイテムクラス
NavigatorItem | イベントナビゲータアイテムクラス
ResultPageItem | 結果ページクラス
ResultPageItemInfo | 結果ページ情報
SaveEventHistoryInfo | 保存イベント履歴情報クラス
SaveEventResultItemInfo | 保存ナビゲート結果情報
SelectItem | 選択アイテムクラス
SelectItemInfo | 選択アイテム情報
StandardEventNavigatorAccessor | イベントナビゲーター管理アクセッサクラス。
StandardEventNavigatorExporter |
StandardEventNavigatorImporter | イベントナビゲーターのインポートクラス。
TitleInfo | タイトル情報

例外の概要
EventNavigatorException イベントナビゲータマネージャに関する例外クラス


jp.co.intra_mart.foundation.navigator クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.navigator の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.navigator.EventAccessInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.navigator.EventHistoryInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.navigator.EventNavigatorConst
    • class jp.co.intra_mart.foundation.navigator.EventNavigatorHandler
    • class jp.co.intra_mart.foundation.navigator.EventNavigatorManager
    • class jp.co.intra_mart.foundation.navigator.EventNavigatorPermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.foundation.navigator.NavigatorItem (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.navigator.EventItem
      • class jp.co.intra_mart.foundation.navigator.EventResultItem
      • class jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem
        • class jp.co.intra_mart.foundation.navigator.EventFlow
        • class jp.co.intra_mart.foundation.navigator.ResultPageItem
        • class jp.co.intra_mart.foundation.navigator.SelectItem
    • class jp.co.intra_mart.foundation.navigator.SaveEventHistoryInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor (implements jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor)
    • class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter (implements jp.co.intra_mart.foundation.navigator.EventNavigatorExporter)
    • class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter (implements jp.co.intra_mart.foundation.navigator.EventNavigatorImporter)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.exception.FoundationException
          • class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
            • class jp.co.intra_mart.foundation.navigator.EventNavigatorException
    • class jp.co.intra_mart.foundation.navigator.TitleInfo (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.navigator.EventFlowInfo
      • class jp.co.intra_mart.foundation.navigator.EventItemInfo
      • class jp.co.intra_mart.foundation.navigator.EventResultItemInfo
      • class jp.co.intra_mart.foundation.navigator.LinkPageInfo
      • class jp.co.intra_mart.foundation.navigator.ResultPageItemInfo
      • class jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo
      • class jp.co.intra_mart.foundation.navigator.SelectItemInfo

インタフェース階層

  • interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor
  • interface jp.co.intra_mart.foundation.navigator.EventNavigatorExporter
  • interface jp.co.intra_mart.foundation.navigator.EventNavigatorImporter
  • interface jp.co.intra_mart.foundation.navigator.EventNavigatorReaderDecorator


パッケージ jp.co.intra_mart.foundation.navigator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.navigator の使用

jp.co.intra_mart.foundation.navigator を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator により使用される jp.co.intra_mart.foundation.navigator のクラス
EventAccessInfo
アクセス権情報
EventFlow
イベントフロークラス
EventFlowInfo
イベントフロー情報
EventHistoryInfo
イベント履歴情報
EventItem
イベントアイテムクラス
EventItemInfo
イベントアイテム情報
EventNavigatorAccessor
イベントナビゲーター管理アクセッサインタフェース。
EventNavigatorException
イベントナビゲータマネージャに関する例外クラス
EventNavigatorExporter
イベントナビゲータバックアップインタフェースです。
EventNavigatorImporter
イベントナビゲータバックアップインタフェースです。
EventNavigatorManager
イベントナビゲーター管理マネージャクラス。
EventResultItem
ナビゲート結果クラス
EventResultItemInfo
ナビゲート結果情報
LinkPageInfo
リンク情報
NavigatorAuthenticateItem
選択アイテムクラス
NavigatorItem
イベントナビゲータアイテムクラス
ResultPageItem
結果ページクラス
ResultPageItemInfo
結果ページ情報
SaveEventHistoryInfo
保存イベント履歴情報クラス
SaveEventResultItemInfo
保存ナビゲート結果情報
SelectItem
選択アイテムクラス
SelectItemInfo
選択アイテム情報
TitleInfo
タイトル情報

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ResultPageItem (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス ResultPageItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.NavigatorItem
        拡張 jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem
            拡張 jp.co.intra_mart.foundation.navigator.ResultPageItem
すべての実装インタフェース:
Serializable
public class ResultPageItem
extends NavigatorAuthenticateItem

結果ページクラス

関連項目:
直列化された形式

コンストラクタの概要
ResultPageItem()
メソッドの概要
LinkPageInfo | getLinkPageInfo()
void | setLinkPageInfo(LinkPageInfo linkPageInfo)
クラス jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem から継承したメソッド
getAccessInfo, setAccessInfo
クラス jp.co.intra_mart.foundation.navigator.NavigatorItem から継承したメソッド
getKeys, getTitleInfo, removeTitleInfo, setTitleInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ResultPageItem

public ResultPageItem()
メソッドの詳細

getLinkPageInfo

public LinkPageInfo getLinkPageInfo()
戻り値:
linkPageInfo を戻します。

setLinkPageInfo

public void setLinkPageInfo(LinkPageInfo linkPageInfo)
パラメータ:
linkPageInfo - 設定する linkPageInfo。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ResultPageItemInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス ResultPageItemInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.TitleInfo
        拡張 jp.co.intra_mart.foundation.navigator.ResultPageItemInfo
すべての実装インタフェース:
Serializable
public class ResultPageItemInfo
extends TitleInfo

結果ページ情報

関連項目:
直列化された形式

コンストラクタの概要
ResultPageItemInfo()
メソッドの概要
String | getId() 保存結果ページID取得
boolean | isPermissionCheck() パーミッションチェックフラグ取得
void | setId(String id) 保存結果ページID設定
void | setPermissionCheck(boolean check) パーミッションチェックフラグ設定
クラス jp.co.intra_mart.foundation.navigator.TitleInfo から継承したメソッド
getComment, getTitle, setComment, setTitle
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ResultPageItemInfo

public ResultPageItemInfo()
メソッドの詳細

getId

public String getId()
保存結果ページID取得

戻り値:
Returns the id.

setId

public void setId(String id)
保存結果ページID設定

パラメータ:
id - The id to set.

isPermissionCheck

public boolean isPermissionCheck()
パーミッションチェックフラグ取得

戻り値:
Returns the permissionCheck.

setPermissionCheck

public void setPermissionCheck(boolean check)
パーミッションチェックフラグ設定

パラメータ:
check - The permissionCheck to set.
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SaveEventHistoryInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス SaveEventHistoryInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.SaveEventHistoryInfo
すべての実装インタフェース:
Serializable
public class SaveEventHistoryInfo
extends Object
implements Serializable

保存イベント履歴情報クラス

関連項目:
直列化された形式

コンストラクタの概要
SaveEventHistoryInfo()
メソッドの概要
String | getAnswer() 質問取得
String | getQuestion() 回答取得
void | setAnswer(String answer) 質問設定
void | setQuestion(String question) 回答設定
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SaveEventHistoryInfo

public SaveEventHistoryInfo()
メソッドの詳細

getAnswer

public String getAnswer()
質問取得

戻り値:
Returns the answer.

setAnswer

public void setAnswer(String answer)
質問設定

パラメータ:
answer - The answer to set.

getQuestion

public String getQuestion()
回答取得

戻り値:
Returns the question.

setQuestion

public void setQuestion(String question)
回答設定

パラメータ:
question - The question to set.
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SaveEventResultItemInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス SaveEventResultItemInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.TitleInfo
        拡張 jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo
すべての実装インタフェース:
Serializable
public class SaveEventResultItemInfo
extends TitleInfo

保存ナビゲート結果情報

関連項目:
直列化された形式

コンストラクタの概要
SaveEventResultItemInfo()
メソッドの概要
SaveEventHistoryInfo[] | getEventHistory() イベント履歴情報リスト取得
String | getId() 保存ナビゲート結果ID取得
ResultPageItemInfo[] | getResultPageItemInfos() 結果ページ情報リスト取得
Date | getSaveDate() 保存日時取得
void | setEventHistory(SaveEventHistoryInfo[] eventHistory) イベント履歴情報リスト設定
void | setId(String id) 保存ナビゲート結果ID設定
void | setResultPageItemInfos(ResultPageItemInfo[] resultPageItemInfos) 結果ページ情報リスト設定
void | setSaveDate(Date saveDate) 保存日時設定
クラス jp.co.intra_mart.foundation.navigator.TitleInfo から継承したメソッド
getComment, getTitle, setComment, setTitle
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SaveEventResultItemInfo

public SaveEventResultItemInfo()
メソッドの詳細

getId

public String getId()
保存ナビゲート結果ID取得

戻り値:
Returns the id.

setId

public void setId(String id)
保存ナビゲート結果ID設定

パラメータ:
id - The id to set.

getSaveDate

public Date getSaveDate()
保存日時取得

戻り値:
Returns the saveDate.

setSaveDate

public void setSaveDate(Date saveDate)
保存日時設定

パラメータ:
saveDate - The saveDate to set.

getResultPageItemInfos

public ResultPageItemInfo[] getResultPageItemInfos()
結果ページ情報リスト取得

戻り値:
Returns the resultPageItemInfos.

setResultPageItemInfos

public void setResultPageItemInfos(ResultPageItemInfo[] resultPageItemInfos)
結果ページ情報リスト設定

パラメータ:
resultPageItemInfos - The resultPageItemInfos to set.

getEventHistory

public SaveEventHistoryInfo[] getEventHistory()
イベント履歴情報リスト取得

戻り値:
Returns the eventHistory.

setEventHistory

public void setEventHistory(SaveEventHistoryInfo[] eventHistory)
イベント履歴情報リスト設定

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SelectItem (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス SelectItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.NavigatorItem
        拡張 jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem
            拡張 jp.co.intra_mart.foundation.navigator.SelectItem
すべての実装インタフェース:
Serializable
public class SelectItem
extends NavigatorAuthenticateItem

選択アイテムクラス

関連項目:
直列化された形式

コンストラクタの概要
SelectItem()
メソッドの概要
EventItem | getNextEventItem()
EventResultItem | getNextEventResultItem()
String | getNextType()
void | setNextEventItem(EventItem nextEventItem)
void | setNextEventResultItem(EventResultItem nextEventResultItem)
クラス jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem から継承したメソッド
getAccessInfo, setAccessInfo
クラス jp.co.intra_mart.foundation.navigator.NavigatorItem から継承したメソッド
getKeys, getTitleInfo, removeTitleInfo, setTitleInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SelectItem

public SelectItem()
メソッドの詳細

getNextEventItem

public EventItem getNextEventItem()
戻り値:
nextEventItem を戻します。

setNextEventItem

public void setNextEventItem(EventItem nextEventItem)
パラメータ:
nextEventItem - 設定する nextEventItem。

getNextEventResultItem

public EventResultItem getNextEventResultItem()
戻り値:
nextEventResultItem を戻します。

setNextEventResultItem

public void setNextEventResultItem(EventResultItem nextEventResultItem)
パラメータ:
nextEventResultItem - 設定する nextEventResultItem。

getNextType

public String getNextType()
戻り値:
nextType を戻します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SelectItemInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス SelectItemInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.TitleInfo
        拡張 jp.co.intra_mart.foundation.navigator.SelectItemInfo
すべての実装インタフェース:
Serializable
public class SelectItemInfo
extends TitleInfo

選択アイテム情報

関連項目:
直列化された形式

コンストラクタの概要
SelectItemInfo()
メソッドの概要
String | getId() 選択アイテムID取得
String | getNextItemId() 遷移先アイテムID取得
String | getNextType() 遷移先タイプ取得
boolean | isPermissionCheck() パーミッションチェックフラグ取得
void | setId(String id) 選択アイテムID設定
void | setNextItemId(String nextItemId) 遷移先アイテムID設定
void | setNextType(String nextType) 遷移先タイプ設定
void | setPermissionCheck(boolean check) パーミッションチェックフラグ設定
クラス jp.co.intra_mart.foundation.navigator.TitleInfo から継承したメソッド
getComment, getTitle, setComment, setTitle
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SelectItemInfo

public SelectItemInfo()
メソッドの詳細

getId

public String getId()
選択アイテムID取得

戻り値:
Returns the id.

setId

public void setId(String id)
選択アイテムID設定

パラメータ:
id - The id to set.

getNextItemId

public String getNextItemId()
遷移先アイテムID取得

戻り値:
Returns the nextItemId.

setNextItemId

public void setNextItemId(String nextItemId)
遷移先アイテムID設定

パラメータ:
nextItemId - The nextItemId to set.

getNextType

public String getNextType()
遷移先タイプ取得

戻り値:
Returns the nextType.

setNextType

public void setNextType(String nextType)
遷移先タイプ設定

パラメータ:
nextType - The nextType to set.

isPermissionCheck

public boolean isPermissionCheck()
パーミッションチェックフラグ取得

戻り値:
Returns the permissionCheck.

setPermissionCheck

public void setPermissionCheck(boolean check)
パーミッションチェックフラグ設定

パラメータ:
check - The permissionCheck to set.
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardEventNavigatorAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス StandardEventNavigatorAccessor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor
すべての実装インタフェース:
EventNavigatorAccessor
public class StandardEventNavigatorAccessor
extends Object
implements EventNavigatorAccessor

イベントナビゲーター管理アクセッサクラス。

イベントナビゲーター情報の読み込みおよび書き込みクラスです。

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
static String | DEFAULT_COMMENT コメント
static String | DEFAULT_FAVORITE 保存ナビゲート結果（お気に入）
static String | DEFAULT_HISTORY 保存ナビゲート結果（履歴）
static String | DEFAULT_TITLE タイトル
static String | KIND_NAVIGATOR 種別 ロール。
コンストラクタの概要
StandardEventNavigatorAccessor()
コンストラクタ
メソッドの概要
String | addEventResultItemInfo(EventNavigatorManager manager, String userId, String eventFlowId, EventResultItemInfo resultItemInfo) 保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
void | addFavoriteSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String saveResultItemId) 保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。
EventFlow | copyEventFlow(EventNavigatorManager manager, String eventFlowId) イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
void | deleteEventFlow(EventNavigatorManager manager, String eventFlowId) イベントフローの削除 イベントフローIDから、イベントフローを削除する。
void | deleteSaveResultHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。
EventFlow | getEventFlow(EventNavigatorManager manager, String eventFlowId) イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
String[] | getEventFlowIds(EventNavigatorManager manager) すべてのイベントフローIDを取得します。
EventFlowInfo[] | getEventFlowInfos(EventNavigatorManager manager, String searchTitle, boolean permissionCheck, int currentPage) イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
EventFlow[] | getEventFlows(EventNavigatorManager manager) すべてのイベントフローを取得します。
EventItemInfo | getEventItemInfo(EventNavigatorManager manager, String eventFlowId, String eventItemId) イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
EventResultItemInfo | getEventResultItemInfo(EventNavigatorManager manager, String eventFlowId, String resultItemId) ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
LinkPageInfo | getLinkPageInfo(EventNavigatorManager manager, String eventFlowId, String eventResultId, String resultPageId) 結果ページ情報を取得します。
protected String | getLoginUser() ログインユーザを取得します。
SaveEventResultItemInfo | getSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
SaveEventResultItemInfo[] | getSaveEventResultItemInfos(EventNavigatorManager manager, String userId, String searchTitle, String sortKey, String oeder, int currentPage) 保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
SaveEventResultItemInfo[] | getSaveEventResultItemInfosHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
LinkPageInfo | getSaveLinkPageInfo(EventNavigatorManager manager, String userId, String eventResultId, String resultPageId) 保存結果ページ情報を取得します。
void | init(String[] args) イベントナビゲーター管理アクセッサの初期化。
void | registEventFlow(EventNavigatorManager manager, EventFlow eventFlow) イベントフローを更新します。
void | removeSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String saveResultItemId) 保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。
void | setOrderSortNum(EventNavigatorManager manager, EventFlowInfo[] eventFlowInfos) 表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
void | setViewOpen(EventNavigatorManager manager, String eventFlowId, String open) 表示設定 イベントフロー情報に表示／非表示を設定する。
void | updateEventFlow(EventNavigatorManager manager, EventFlow eventFlow) イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
void | updateEventResultItemInfo(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | updateEventResultItemInfoTitle(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KIND_NAVIGATOR

public static final String KIND_NAVIGATOR
種別 ロール。

関連項目:
定数フィールド値

DEFAULT_TITLE

public static final String DEFAULT_TITLE
タイトル

関連項目:
定数フィールド値

DEFAULT_COMMENT

public static final String DEFAULT_COMMENT
コメント

関連項目:
定数フィールド値

DEFAULT_FAVORITE

public static final String DEFAULT_FAVORITE
保存ナビゲート結果（お気に入）

関連項目:
定数フィールド値

DEFAULT_HISTORY

public static final String DEFAULT_HISTORY
保存ナビゲート結果（履歴）

関連項目:
定数フィールド値
コンストラクタの詳細

StandardEventNavigatorAccessor

public StandardEventNavigatorAccessor()
コンストラクタ

メソッドの詳細

init

public void init(String[] args)
イベントナビゲーター管理アクセッサの初期化。

定義:
インタフェース EventNavigatorAccessor 内の init

getEventFlowInfos

public EventFlowInfo[] getEventFlowInfos(EventNavigatorManager manager,
                                         String searchTitle,
                                         boolean permissionCheck,
                                         int currentPage)
                                  throws EventNavigatorException
イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。

定義:
インタフェース EventNavigatorAccessor 内の getEventFlowInfos
パラメータ:
manager - イベントナビゲータ管理オブジェクト
searchTitle - 検索タイトル
permissionCheck - 権限チェック要否
currentPage - 表示指定頁
戻り値:
イベントフロー情報一覧
例外:
EventNavigatorException - イベントフロー情報一覧取得処理に失敗した場合にスローされます。

deleteEventFlow

public void deleteEventFlow(EventNavigatorManager manager,
                            String eventFlowId)
                     throws EventNavigatorException
イベントフローの削除 イベントフローIDから、イベントフローを削除する。

定義:
インタフェース EventNavigatorAccessor 内の deleteEventFlow
パラメータ:
eventFlowId - イベントフローID
例外:
EventNavigatorException - イベントフロー削除処理に失敗した場合にスローされます。

getEventFlow

public EventFlow getEventFlow(EventNavigatorManager manager,
                              String eventFlowId)
                       throws EventNavigatorException
イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。

定義:
インタフェース EventNavigatorAccessor 内の getEventFlow
パラメータ:
eventFlowId - イベントフローID
戻り値:
イベントフロー
例外:
EventNavigatorException - イベントフロー取得処理に失敗した場合にスローされます。

updateEventFlow

public void updateEventFlow(EventNavigatorManager manager,
                            EventFlow eventFlow)
                     throws EventNavigatorException
イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。

定義:
インタフェース EventNavigatorAccessor 内の updateEventFlow
パラメータ:
eventFlow - イベントフロー
例外:
EventNavigatorException - イベントフロー登録処理に失敗した場合にスローされます。

copyEventFlow

public EventFlow copyEventFlow(EventNavigatorManager manager,
                               String eventFlowId)
                        throws EventNavigatorException
イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。

定義:
インタフェース EventNavigatorAccessor 内の copyEventFlow
パラメータ:
eventFlowId - コピー元イベントフローID
戻り値:
コピー先イベントフロー
例外:
EventNavigatorException - イベントフローコピー処理に失敗した場合にスローされます。

getEventItemInfo

public EventItemInfo getEventItemInfo(EventNavigatorManager manager,
                                      String eventFlowId,
                                      String eventItemId)
                               throws EventNavigatorException
イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。

定義:
インタフェース EventNavigatorAccessor 内の getEventItemInfo
パラメータ:
eventFlowId - イベントフローID
eventItemId - イベントアイテムID
戻り値:
イベントアイテム情報
例外:
EventNavigatorException - イベントアイテム情報取得処理に失敗した場合にスローされます。

getEventResultItemInfo

public EventResultItemInfo getEventResultItemInfo(EventNavigatorManager manager,
                                                  String eventFlowId,
                                                  String resultItemId)
                                           throws EventNavigatorException
ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。

定義:
インタフェース EventNavigatorAccessor 内の getEventResultItemInfo
パラメータ:
eventFlowId - イベントフローID
resultItemId - ナビゲート結果ID
戻り値:
ナビゲート結果情報
例外:
EventNavigatorException - ナビゲート結果情報取得処理に失敗した場合にスローされます。

addEventResultItemInfo

public String addEventResultItemInfo(EventNavigatorManager manager,
                                     String userId,
                                     String eventFlowId,
                                     EventResultItemInfo resultItemInfo)
                              throws EventNavigatorException
保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。

定義:
インタフェース EventNavigatorAccessor 内の addEventResultItemInfo
パラメータ:
userId - ユーザID
eventFlowId - イベントフローID
resultItemInfo - ナビゲート結果情報
戻り値:
保存ナビゲート結果ID
例外:
EventNavigatorException - 保存ナビゲート結果情報（履歴）登録処理に失敗した場合にスローされます。

deleteSaveResultHistory

public void deleteSaveResultHistory(EventNavigatorManager manager,
                                    String userId)
                             throws EventNavigatorException
保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。

定義:
インタフェース EventNavigatorAccessor 内の deleteSaveResultHistory
パラメータ:
userId - ユーザID
例外:
EventNavigatorException - 保存ナビゲート結果情報（履歴）削除処理に失敗した場合にスローされます。

getSaveEventResultItemInfo

public SaveEventResultItemInfo getSaveEventResultItemInfo(EventNavigatorManager manager,
                                                          String userId,
                                                          String resultItemId)
                                                   throws EventNavigatorException
保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。

定義:
インタフェース EventNavigatorAccessor 内の getSaveEventResultItemInfo
パラメータ:
userId - ユーザID
resultItemId - ナビゲート結果ID
戻り値:
保存ナビゲート結果情報
例外:
EventNavigatorException - 保存ナビゲート結果情報取得処理に失敗した場合にスローされます。

updateEventResultItemInfo

public void updateEventResultItemInfo(EventNavigatorManager manager,
                                      String userId,
                                      SaveEventResultItemInfo saveResultItemInfo)
                               throws EventNavigatorException
保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。

定義:
インタフェース EventNavigatorAccessor 内の updateEventResultItemInfo
パラメータ:
userId - ユーザID
saveResultItemInfo - 保存ナビゲート結果情報
例外:
EventNavigatorException - 保存ナビゲート結果情報（ユーザ）更新処理に失敗した場合にスローされます。

updateEventResultItemInfoTitle

public void updateEventResultItemInfoTitle(EventNavigatorManager manager,
                                           String userId,
                                           SaveEventResultItemInfo saveResultItemInfo)
                                    throws EventNavigatorException
保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。

定義:
インタフェース EventNavigatorAccessor 内の updateEventResultItemInfoTitle
パラメータ:
manager - マネージャー
userId - ユーザID
saveResultItemInfo - 保存ナビゲート結果情報
例外:
EventNavigatorException - 保存ナビゲート結果情報（ユーザ）更新処理に失敗した場合にスローされます。

getSaveEventResultItemInfos

public SaveEventResultItemInfo[] getSaveEventResultItemInfos(EventNavigatorManager manager,
                                                             String userId,
                                                             String searchTitle,
                                                             String sortKey,
                                                             String oeder,
                                                             int currentPage)
                                                      throws EventNavigatorException
保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。

定義:
インタフェース EventNavigatorAccessor 内の getSaveEventResultItemInfos
パラメータ:
userId - ユーザID
searchTitle - 検索タイトル
sortKey - ソートキー
oeder - 昇降指定
currentPage - 表示指定頁
戻り値:
保存ナビゲート結果情報の配列（ユーザ）
例外:
EventNavigatorException - 保存ナビゲート結果情報一覧（ユーザ）取得処理に失敗した場合にスローされます。

removeSaveEventResultItemInfo

public void removeSaveEventResultItemInfo(EventNavigatorManager manager,
                                          String userId,
                                          String saveResultItemId)
                                   throws EventNavigatorException
保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。

定義:
インタフェース EventNavigatorAccessor 内の removeSaveEventResultItemInfo
パラメータ:
userId - ユーザID
saveResultItemId - 保存ナビゲート結果ID
例外:
EventNavigatorException - 保存ナビゲート結果情報削除処理に失敗した場合にスローされます。

addFavoriteSaveEventResultItemInfo

public void addFavoriteSaveEventResultItemInfo(EventNavigatorManager manager,
                                               String userId,
                                               String saveResultItemId)
                                        throws EventNavigatorException
保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。

定義:
インタフェース EventNavigatorAccessor 内の addFavoriteSaveEventResultItemInfo
パラメータ:
manager - マネージャー
userId - ユーザID
saveResultItemId - 保存ナビゲート結果ID
例外:
EventNavigatorException - 保存ナビゲート結果情報お気に入りへ追加処理に失敗した場合にスローされます。

getSaveEventResultItemInfosHistory

public SaveEventResultItemInfo[] getSaveEventResultItemInfosHistory(EventNavigatorManager manager,
                                                                    String userId)
                                                             throws EventNavigatorException
保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。

定義:
インタフェース EventNavigatorAccessor 内の getSaveEventResultItemInfosHistory
パラメータ:
userId - ユーザID
戻り値:
保存ナビゲート結果情報の配列（履歴）
例外:
EventNavigatorException - 保存ナビゲート結果情報一覧（履歴）取得処理に失敗した場合にスローされます。

setOrderSortNum

public void setOrderSortNum(EventNavigatorManager manager,
                            EventFlowInfo[] eventFlowInfos)
                     throws EventNavigatorException
表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。

定義:
インタフェース EventNavigatorAccessor 内の setOrderSortNum
パラメータ:
manager - イベントナビゲータ管理オブジェクト
eventFlowInfos - イベントフロー情報配列
例外:
EventNavigatorException - 表示順設定処理に失敗した場合にスローされます。

setViewOpen

public void setViewOpen(EventNavigatorManager manager,
                        String eventFlowId,
                        String open)
                 throws EventNavigatorException
表示設定 イベントフロー情報に表示／非表示を設定する。

定義:
インタフェース EventNavigatorAccessor 内の setViewOpen
パラメータ:
eventFlowId - イベントフローID
open - 表示フラグ
例外:
EventNavigatorException - 表示順設定処理に失敗した場合にスローされます。

getEventFlowIds

public String[] getEventFlowIds(EventNavigatorManager manager)
                         throws EventNavigatorException
すべてのイベントフローIDを取得します。

定義:
インタフェース EventNavigatorAccessor 内の getEventFlowIds
パラメータ:
manager -
戻り値:
イベントフローIDの配列
例外:
EventNavigatorException

getEventFlows

public EventFlow[] getEventFlows(EventNavigatorManager manager)
                          throws EventNavigatorException
すべてのイベントフローを取得します。

定義:
インタフェース EventNavigatorAccessor 内の getEventFlows
パラメータ:
manager -
戻り値:
イベントフローの配列
例外:
EventNavigatorException

getLinkPageInfo

public LinkPageInfo getLinkPageInfo(EventNavigatorManager manager,
                                    String eventFlowId,
                                    String eventResultId,
                                    String resultPageId)
                             throws EventNavigatorException
結果ページ情報を取得します。

定義:
インタフェース EventNavigatorAccessor 内の getLinkPageInfo
パラメータ:
manager -
eventFlowId - イベントフローID
eventResultId - ナビゲート結果ID
resultPageId - 結果ページID
戻り値:
結果ページ情報
例外:
EventNavigatorException

getSaveLinkPageInfo

public LinkPageInfo getSaveLinkPageInfo(EventNavigatorManager manager,
                                        String userId,
                                        String eventResultId,
                                        String resultPageId)
                                 throws EventNavigatorException
保存結果ページ情報を取得します。

定義:
インタフェース EventNavigatorAccessor 内の getSaveLinkPageInfo
パラメータ:
manager -
userId - ユーザID
eventResultId - ナビゲート結果ID
resultPageId - 結果ページID
戻り値:
保存結果ページ情報
例外:
EventNavigatorException

getLoginUser

protected String getLoginUser()
ログインユーザを取得します。
ログインユーザの取得に失敗した場合は空文字列を返却します。

戻り値:
ログインユーザID

registEventFlow

public void registEventFlow(EventNavigatorManager manager,
                            EventFlow eventFlow)
                     throws EventNavigatorException
イベントフローを更新します。

定義:
インタフェース EventNavigatorAccessor 内の registEventFlow
パラメータ:
eventFlow - イベントフロー
例外:
EventNavigatorException - イベントフローの更新に失敗した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardEventNavigatorExporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス StandardEventNavigatorExporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter
すべての実装インタフェース:
EventNavigatorExporter
public class StandardEventNavigatorExporter
extends Object
implements EventNavigatorExporter

コンストラクタの概要
StandardEventNavigatorExporter()
メソッドの概要
boolean | checkLocale(String keyLocale, String[] syslocales) ロケールチェック（共通）
void | doExport(EventNavigatorManager manager, OutputStream outputStream, boolean editFlag) エクスポートを行います。
void | init(String[] args) イベントナビゲータバックアップエクスポータの初期化。
Locale[] | matchSysLocales(Locale[] locales, String[] syslocales) ロケールマッチング（共通）
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardEventNavigatorExporter

public StandardEventNavigatorExporter()
メソッドの詳細

init

public void init(String[] args)
インタフェース EventNavigatorExporter の記述:
イベントナビゲータバックアップエクスポータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース EventNavigatorExporter 内の init

doExport

public void doExport(EventNavigatorManager manager,
                     OutputStream outputStream,
                     boolean editFlag)
              throws EventNavigatorException
エクスポートを行います。

イベントフロー情報からXMLを生成します。

定義:
インタフェース EventNavigatorExporter 内の doExport
パラメータ:
manager - イベントナビゲータマネージャクラス
outputStream - 出力ストリーム
例外:
EventNavigatorException

matchSysLocales

public Locale[] matchSysLocales(Locale[] locales,
                                String[] syslocales)
ロケールマッチング（共通）

パラメータ:
locales - タイトルのロケール
syslocales - システムのロケール

checkLocale

public boolean checkLocale(String keyLocale,
                           String[] syslocales)
ロケールチェック（共通）

パラメータ:
keyLocale - タイトル情報のロケール
syslocales - システムのロケール
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardEventNavigatorImporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス StandardEventNavigatorImporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter
すべての実装インタフェース:
EventNavigatorImporter
public class StandardEventNavigatorImporter
extends Object
implements EventNavigatorImporter

イベントナビゲーターのインポートクラス。

バージョン:
1.0

コンストラクタの概要
StandardEventNavigatorImporter()
メソッドの概要
boolean | checkLocale(String keyLocale, String[] locales) ロケールチェック（共通）
boolean | checkStrLength(String str, int length) 文字列チェック（共通）
void | checkTitleInfo(NavigatorItem item, String[] locales, String strURI) タイトル情報のロケールマッチング（共通）
void | doImport(EventNavigatorManager manager, InputStream inputStream) インポートを行います。
String | getPathXML(Node node, Node parent_node) このノードのフルパスを取得します。
void | init(String[] args) 初期化。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardEventNavigatorImporter

public StandardEventNavigatorImporter()
メソッドの詳細

init

public void init(String[] args)
初期化。

初期化します。

定義:
インタフェース EventNavigatorImporter 内の init

doImport

public void doImport(EventNavigatorManager manager,
                     InputStream inputStream)
              throws EventNavigatorException
インポートを行います。

ストリーム内の情報からメニュー情報を生成します。

定義:
インタフェース EventNavigatorImporter 内の doImport
パラメータ:
manager - メニューマネージャクラス
inputStream - 入力ストリーム
例外:
EventNavigatorException

checkStrLength

public boolean checkStrLength(String str,
                              int length)
                       throws EventNavigatorException
文字列チェック（共通）

パラメータ:
str - 対象文字列
length - レングス値
例外:
EventNavigatorException

checkLocale

public boolean checkLocale(String keyLocale,
                           String[] locales)
                    throws EventNavigatorException
ロケールチェック（共通）

パラメータ:
keyLocale - タイトル情報のロケール
locales - システムのロケール
例外:
EventNavigatorException

checkTitleInfo

public void checkTitleInfo(NavigatorItem item,
                           String[] locales,
                           String strURI)
                    throws EventNavigatorException
タイトル情報のロケールマッチング（共通）

パラメータ:
item - アイテム情報
locales - システムのロケール
例外:
EventNavigatorException

getPathXML

public String getPathXML(Node node,
                         Node parent_node)
このノードのフルパスを取得します。

このノードのフルパス '/'でつないだパスを取得します。

戻り値:
ノードのフルパス。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TitleInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス TitleInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.TitleInfo
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
EventFlowInfo, EventItemInfo, EventResultItemInfo, LinkPageInfo, ResultPageItemInfo, SaveEventResultItemInfo, SelectItemInfo
public class TitleInfo
extends Object
implements Serializable

タイトル情報

関連項目:
直列化された形式

コンストラクタの概要
TitleInfo()
メソッドの概要
String | getComment() コメント取得
String | getTitle() タイトル取得
void | setComment(String comment) コメント設定
void | setTitle(String title) タイトル設定
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

TitleInfo

public TitleInfo()
メソッドの詳細

getTitle

public String getTitle()
タイトル取得

戻り値:
Returns the strTitle.

setTitle

public void setTitle(String title)
タイトル設定

パラメータ:
title - The title to set.

getComment

public String getComment()
コメント取得

戻り値:
Returns the comment.

setComment

public void setComment(String comment)
コメント設定

パラメータ:
comment - The strComment to set.
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer の使用

AbstractTreeNodeContainer を使用しているパッケージ
jp.co.intra_mart.foundation.page ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.page での AbstractTreeNodeContainer の使用

jp.co.intra_mart.foundation.page での AbstractTreeNodeContainer のサブクラス
class | TreeBranch ツリービュー内の「フォルダ」をあらわすクラスです。
class | TreeRoot ツリービュー内の「ホーム」をあらわすクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.page.EventScript の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.page.EventScript の使用

jp.co.intra_mart.foundation.page.EventScript はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.page.NodeNameComparator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.page.NodeNameComparator の使用

jp.co.intra_mart.foundation.page.NodeNameComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.page.NodeTypeComparator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.page.NodeTypeComparator の使用

jp.co.intra_mart.foundation.page.NodeTypeComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.page.TreeBranch の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.page.TreeBranch の使用

TreeBranch を使用しているパッケージ
jp.co.intra_mart.foundation.page ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.page での TreeBranch の使用

TreeBranch 型のパラメータを持つ jp.co.intra_mart.foundation.page のメソッド
void | TreeBranch.setAll(TreeBranch branch) 指定された branch 内の表示名称、ポップアップ文字列、引数文字列をこのオブジェクトに設定します。
void | AbstractTreeNodeContainer.addChildBranch(TreeBranch branch) 指定されたブランチ branchを子ノードとして追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.page.TreeLeaf の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.page.TreeLeaf の使用

TreeLeaf を使用しているパッケージ
jp.co.intra_mart.foundation.page ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.page での TreeLeaf の使用

TreeLeaf 型のパラメータを持つ jp.co.intra_mart.foundation.page のメソッド
 void AbstractTreeNodeContainer.addChildLeaf(TreeLeaf leaf)
指定されたリーフ leafを子ノードとして追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.page.TreeNode の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.page.TreeNode の使用

TreeNode を使用しているパッケージ
jp.co.intra_mart.foundation.page ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.page での TreeNode の使用

TreeNode を実装している jp.co.intra_mart.foundation.page のクラス
class | TreeBranch ツリービュー内の「フォルダ」をあらわすクラスです。
class | TreeLeaf ツリービュー内の「ページ」をあらわすクラスです。

TreeNode 型のパラメータを持つ jp.co.intra_mart.foundation.page のメソッド
void | AbstractTreeNodeContainer.addChildNode(TreeNode node) 指定されたノード node を子ノードとして追加します。
boolean | AbstractTreeNodeContainer.hasChildNode(TreeNode node) 指定されたノード node を持っているか調べます。
boolean | AbstractTreeNodeContainer.removeChildNode(TreeNode node) 指定されたノード node をこのノードの子から削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.page.TreeNodeContainer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.page.TreeNodeContainer の使用

TreeNodeContainer を使用しているパッケージ
jp.co.intra_mart.foundation.page ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.page での TreeNodeContainer の使用

jp.co.intra_mart.foundation.page での TreeNodeContainer のサブインタフェース
 interface TreeNodeProvider
ツリービューの「ホーム」をあらわすインターフェースです。

TreeNodeContainer を実装している jp.co.intra_mart.foundation.page のクラス
class | AbstractTreeNodeContainer ツリービューの子ノードを扱うためのメソッドを提供する抽象クラスです。
class | TreeBranch ツリービュー内の「フォルダ」をあらわすクラスです。
class | TreeRoot ツリービュー内の「ホーム」をあらわすクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.page.TreeNodeProvider の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.page.TreeNodeProvider の使用

TreeNodeProvider を使用しているパッケージ
jp.co.intra_mart.foundation.page ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.page での TreeNodeProvider の使用

TreeNodeProvider を実装している jp.co.intra_mart.foundation.page のクラス
 class TreeRoot
ツリービュー内の「ホーム」をあらわすクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.page.TreeRoot の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.page.TreeRoot の使用

jp.co.intra_mart.foundation.page.TreeRoot はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AbstractTreeNodeContainer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
クラス AbstractTreeNodeContainer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer
すべての実装インタフェース:
TreeNodeContainer
直系の既知のサブクラス:
TreeBranch, TreeRoot
public abstract class AbstractTreeNodeContainer
extends Object
implements TreeNodeContainer

ツリービューの子ノードを扱うためのメソッドを提供する抽象クラスです。
この抽象クラスを使用して、ツリービューの「ホーム」と「フォルダ」は子ノードの追加、削除などの処理を行います。

導入されたバージョン:
version 4.3
バージョン:
1.0

コンストラクタの概要
AbstractTreeNodeContainer()
子ノードを追加順に並べる、新しいオブジェクトを生成します。
AbstractTreeNodeContainer(Comparator comparator)
指定されたコンパレータに従って子ノードを並べる、新しいオブジェクトを生成します。
メソッドの概要
void | addChildBranch(TreeBranch branch) 指定されたブランチ branchを子ノードとして追加します。
void | addChildLeaf(TreeLeaf leaf) 指定されたリーフ leafを子ノードとして追加します。
void | addChildNode(TreeNode node) 指定されたノード node を子ノードとして追加します。
Collection | getChildNodes() このノードの子ノードをすべて含む Collectionを返します。
boolean | hasChildNode(TreeNode node) 指定されたノード node を持っているか調べます。
boolean | hasChildNodes() このノードが子ノードを持っているかどうかを判断します。
boolean | isEmpty() このノードの下に子ノードがないか調べます。
boolean | removeChildNode(TreeNode node) 指定されたノード node をこのノードの子から削除します。
void | removeChildNodes() 子ノードを全て削除します。
int | size() このノードが持つ子ノードの数を返します。
void | sort(Comparator comparator) 指定されたコンパレータに従って、子ノードをソートします。
void | sortAll(Comparator comparator) このノードの下にある、全ての子ノードを指定されたコンパレータに従ってソートします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractTreeNodeContainer

public AbstractTreeNodeContainer()
子ノードを追加順に並べる、新しいオブジェクトを生成します。

AbstractTreeNodeContainer

public AbstractTreeNodeContainer(Comparator comparator)
指定されたコンパレータに従って子ノードを並べる、新しいオブジェクトを生成します。

パラメータ:
comparator - コンパレータ
メソッドの詳細

addChildNode

public void addChildNode(TreeNode node)
                  throws NullPointerException
指定されたノード node を子ノードとして追加します。

パラメータ:
node - ツリーノード
例外:
NullPoiterException - 引数がnullだった場合
NullPointerException

addChildBranch

public void addChildBranch(TreeBranch branch)
                    throws NullPointerException
指定されたブランチ branchを子ノードとして追加します。

パラメータ:
branch - ブランチ
例外:
NullPointerException - 引数がnullだった場合

addChildLeaf

public void addChildLeaf(TreeLeaf leaf)
指定されたリーフ leafを子ノードとして追加します。

パラメータ:
leaf - リーフ
例外:
NullPointerException - 引数がnullだった場合

hasChildNode

public boolean hasChildNode(TreeNode node)
指定されたノード node を持っているか調べます。 持っているときはtrueを返します。

パラメータ:
node - 子として持っているかどうか調べるノード
戻り値:
指定されたノードを持つときはtrue、持っていないときはfalseを返します。

removeChildNode

public boolean removeChildNode(TreeNode node)
指定されたノード　node をこのノードの子から削除します。

パラメータ:
node - 削除指定されたノード
戻り値:
削除に成功したときはtrue、削除に失敗したときはfalseを返します。

removeChildNodes

public void removeChildNodes()
子ノードを全て削除します。

sort

public void sort(Comparator comparator)
          throws NullPointerException
指定されたコンパレータに従って、子ノードをソートします。 このメソッド呼出後、子ノードの追加は指定されたコンパレータに従ってソートされます。

パラメータ:
comparator - コンパレータ
例外:
NullPoiterException - 引数がnullだったとき
NullPointerException

sortAll

public void sortAll(Comparator comparator)
             throws NullPointerException
このノードの下にある、全ての子ノードを指定されたコンパレータに従ってソートします。

パラメータ:
comparator - コンパレータ
例外:
NullPointerException - 引数がnullだったとき

getChildNodes

public Collection getChildNodes()
このノードの子ノードをすべて含む Collectionを返します。 もし、一つも子ノードがない時は空のCollectionが返されます。

定義:
インタフェース TreeNodeContainer 内の getChildNodes
戻り値:
子ノードを含むCollection

hasChildNodes

public boolean hasChildNodes()
このノードが子ノードを持っているかどうかを判断します。 持っているときは、trueを返します。

定義:
インタフェース TreeNodeContainer 内の hasChildNodes
戻り値:
持ってるときは、trueを返します。

isEmpty

public boolean isEmpty()
このノードの下に子ノードがないか調べます。 このノードが一つも子を持っていないときにtrueを返します。

定義:
インタフェース TreeNodeContainer 内の isEmpty
戻り値:
子を持っていないときにtrueを返します。

size

public int size()
このノードが持つ子ノードの数を返します。

定義:
インタフェース TreeNodeContainer 内の size
戻り値:
子ノードの数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventScript (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
クラス EventScript

java.lang.Object
    拡張 jp.co.intra_mart.foundation.page.EventScript
public class EventScript
extends Object

ブラウザでスクリプトの各変数に対する変更イベントを実装するための スクリプトコードを提供します。

このオブジェクトが作成するスクリプトは JavaScript 1.2 に準拠します。

このオブジェクトが作成するスクリプトの動作にはクッキーを利用しています。 クッキーの容量制限を越える量の値をやり取り(監視や受取)はできません。 また、クッキーを保存する際、クッキーの path 属性は 「/」で値を保存 していますので、この機能で扱うデータは、セキュリティ的に問題のない 範囲にとどめるか、またはセキュリティ的に問題となる場合には、 他の方法を利用するようにして下さい。

イベント同士でやり取りできる値の変数型は、クッキーの制約により 文字列型のみとなります。他の変数型の値に関しては、イベントでの入出力に おいて、データの整合性が保証されません。

このオブジェクトは、新しいインスタンスが構築されるたびに内部のシーケンサに より各々のインスタンスに対してＩＤが割り振られています。このＩＤは、 ブラウザでイベントが実行された時にイベントのスクリプトが誤動作をしない ように各変数や関数名称に利用されています。
従って、１つのインスタンスから複数回にわたりスクリプトを生成して １つのページで動作させた場合、それらのスクリプトは誤動作をします。
またＩＤは、0 から始まり 255 までカウントされ、256 に達した時点で 再び 0 からインクリメントされるように実装されています。つまり、初めて 構築されたインスタンスと 257 回目に構築されたインスタンスにより 生成されたイベントのためのスクリプトを同じページで実行した場合、 誤動作を起こします。

JSP でこのクラスを利用する場合の例

<% EventScript es = new EventScript("my_event"); %>
<% es.setOnChange("window.alert(\"Change!!\");"); %>
<SCRIPT> <%= es.getScript(); %> </SCRIPT>

フィールドの概要
protected static int counter
このクラスからインスタンスが生成された回数。
コンストラクタの概要
EventScript(String name)
イベントスクリプトを作成するためのインスタンスを構築します。
メソッドの概要
String | getLanguage() 言語名を返します。
String | getLanguageVersion() 言語のバージョンを返します。
String | getScript() 設定された情報からイベントのためのスクリプトを作成します。
void | setFocus(String valName) イベントとして監視する変数名を指定します。
void | setInitialize(String value) イベントの初期値を指定します。
void | setOnChange(String src) 監視している値に変更があった場合に実行するスクリプトを指定します。
void | setReceive(String valName) イベントから値を受け取る変数名を指定します。
int | setTimer(int millis) イベントの監視間隔を設定します。
String | toString() このオブジェクトの文字列表現を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

フィールドの詳細

counter

protected static volatile int counter
このクラスからインスタンスが生成された回数。

この値は、0 から 255 の範囲で加算されていき、256 に達した時 0 にリセットされて再び加算されていきます。

コンストラクタの詳細

EventScript

public EventScript(String name)
イベントスクリプトを作成するためのインスタンスを構築します。

引数 name は、このイベントのＩＤになります。 同じＩＤを持つ EventScript のインスタンスから生成されたイベントは ブラウザで実行された時に、それぞれ連携しあうことができます。

パラメータ:
name - このイベントのＩＤ
例外:
NullPointerException - 引数が null
メソッドの詳細

getLanguage

public String getLanguage()
言語名を返します。

このオブジェクトの生成するスクリプトは、このメソッドの返す言語に準拠 しています。 ブラウザが、この言語に対応していない場合、イベントのスクリプトは 正常に動作しません。

戻り値:
生成されるスクリプトの言語名

getLanguageVersion

public String getLanguageVersion()
言語のバージョンを返します。

このオブジェクトの生成するスクリプトは、メソッド getLanguage() の返す 言語のこのメソッドの返すバージョンに準拠しています。 ブラウザが、この言語のバージョンに対応していない場合、 イベントのスクリプトは正常に動作しません。

戻り値:
生成されるスクリプトの言語のバージョン
関連項目:
getLanguage()

setTimer

public int setTimer(int millis)
イベントの監視間隔を設定します。

指定のミリ秒間隔で変数を監視します。
インスタンス構築時の初期値は 250 ミリ秒に設定されています。この値を 小さくする事で EventScript 同士の連携のタイミングをよりリアルタイムに することができますが、クライアント・コンピュータに大きな負荷が かかってしまいます。
戻り値は、前に設定されていた値です。

パラメータ:
millis - 監視間隔（ミリ秒）
戻り値:
前に設定されていた値

setReceive

public void setReceive(String valName)
イベントから値を受け取る変数名を指定します。

ここでは、イベントから値を受け取るための変数名称を指定します。
変数は、ブラウザ上で動作するスクリプトで扱える変数に限ります。

パラメータ:
valName - 変数名称

setFocus

public void setFocus(String valName)
イベントとして監視する変数名を指定します。

ここでは、イベントで値を監視する変数名称を指定します。
変数は、ブラウザ上で動作するスクリプトで扱える変数に限ります。

パラメータ:
valName - 変数名称

setInitialize

public void setInitialize(String value)
イベントの初期値を指定します。

イベント内部の監視変数の初期値を設定します。
初期値を監視対象変数の現在値と同じ値に設定する事により イベント動作開始時の setOnChange() の誤動作を 未然に防ぐ事が出来ます。

パラメータ:
value - 初期値
関連項目:
setOnChange(java.lang.String)

setOnChange

public void setOnChange(String src)
監視している値に変更があった場合に実行するスクリプトを指定します。

スクリプトは、ブラウザ上で動作するスクリプトに限ります。

パラメータ:
src - 変更イベント発生時に実行するスクリプト

getScript

public String getScript()
設定された情報からイベントのためのスクリプトを作成します。

このメソッドの返すスクリプトがブラウザ上で実行された時 イベントとして動作します。

戻り値:
スクリプトのソース

toString

public String toString()
このオブジェクトの文字列表現を返します。

実際には、このメソッドの結果は getScript() と同じです。

戻り値:
このオブジェクトの文字列表現
関連項目:
getScript()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NodeNameComparator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
クラス NodeNameComparator

java.lang.Object
    拡張 jp.co.intra_mart.foundation.page.NodeNameComparator
すべての実装インタフェース:
Comparator, Serializable
public class NodeNameComparator
extends Object
implements Comparator, Serializable

ツリービューのノードを名前順にソートするためのコンパレータです。 並びは名前の昇順になります。

導入されたバージョン:
version 4.3
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
NodeNameComparator()
メソッドの概要
 int compare(Object arg0, Object arg1)
順序付けのために 2 つの引数を比較するメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

NodeNameComparator

public NodeNameComparator()
メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
順序付けのために 2 つの引数を比較するメソッドです。
最初の引数が 2 番目の引数より小さ い場合は負の整数、両方が等しい場合は 0、最初の引数が 2 番目の引 数より大きい場合は正の整数を返します。
このメソッドはツリービューのノードを名前で昇順にソートすることを目的としています。 もし、arg0とarg1が同じ名前でarg0.equals(arg1) == falseの時は正の整数を返します。arg0.equals(arg1)==trueの時は0を返します。

定義:
インタフェース Comparator 内の compare
パラメータ:
arg0 - 引数１
arg1 - 引数２
戻り値:
比較した結果
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NodeTypeComparator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
クラス NodeTypeComparator

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.AbstractDualComparator
        拡張 jp.co.intra_mart.foundation.page.NodeTypeComparator
すべての実装インタフェース:
Comparator, DualComparator, Serializable
public class NodeTypeComparator
extends AbstractDualComparator

ツリービューのノードを種類順にソートするためのコンパレータです。
並び順は「フォルダ」、「ページ」の順になります。 比較対象の２つノードの種類が同じときは、コンストラクタで与えられた、 第２コンパレータで比較を行い、その結果を返します。

導入されたバージョン:
version 4.3
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
NodeTypeComparator(Comparator secondaryComparator)
第２コンパレータ secondaryComparatorを指定して、新たなオブジェクトを生成します。
メソッドの概要
Comparator | getPrimaryComparator() 第１コンパレータを取得します。
Comparator | getSecondaryComparator() 第２コンパレータを取得します。
クラス jp.co.intra_mart.foundation.utility.AbstractDualComparator から継承したメソッド
compare
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

NodeTypeComparator

public NodeTypeComparator(Comparator secondaryComparator)
第２コンパレータ secondaryComparatorを指定して、新たなオブジェクトを生成します。

パラメータ:
secondaryComparator - 第２コンパレータ
メソッドの詳細

getPrimaryComparator

public Comparator getPrimaryComparator()
第１コンパレータを取得します。
このクラスの第１コンパレータは、ツリービューのノードを種類順にソートするコンパレータです。

戻り値:
第１コンパレータ

getSecondaryComparator

public Comparator getSecondaryComparator()
第２コンパレータを取得します。
このクラスの第２コンパレータは、コンストラクタで指定されたコンパレータです。

戻り値:
第２コンパレータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.page (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.page
インタフェース
TreeNode
TreeNodeContainer
TreeNodeProvider
クラス
AbstractTreeNodeContainer
EventScript
NodeNameComparator
NodeTypeComparator
TreeBranch
TreeLeaf
TreeRoot


jp.co.intra_mart.foundation.page (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.page

ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

参照:
説明

インタフェースの概要
TreeNode | ツリービュー内の単一のノードを表すインターフェースです。
TreeNodeContainer | 子ノードを参照するためのメソッドが定義されたインターフェースです。
TreeNodeProvider | ツリービューの「ホーム」をあらわすインターフェースです。

クラスの概要
AbstractTreeNodeContainer | ツリービューの子ノードを扱うためのメソッドを提供する抽象クラスです。
EventScript | ブラウザでスクリプトの各変数に対する変更イベントを実装するための スクリプトコードを提供します。
NodeNameComparator | ツリービューのノードを名前順にソートするためのコンパレータです。
NodeTypeComparator | ツリービューのノードを種類順にソートするためのコンパレータです。
TreeBranch | ツリービュー内の「フォルダ」をあらわすクラスです。
TreeLeaf | ツリービュー内の「ページ」をあらわすクラスです。
TreeRoot | ツリービュー内の「ホーム」をあらわすクラスです。

パッケージ jp.co.intra_mart.foundation.page の説明

ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。


jp.co.intra_mart.foundation.page クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.page の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.utility.AbstractDualComparator (implements jp.co.intra_mart.foundation.utility.DualComparator)
      • class jp.co.intra_mart.foundation.page.NodeTypeComparator
    • class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer (implements jp.co.intra_mart.foundation.page.TreeNodeContainer)
      • class jp.co.intra_mart.foundation.page.TreeBranch (implements jp.co.intra_mart.foundation.page.TreeNode)
      • class jp.co.intra_mart.foundation.page.TreeRoot (implements jp.co.intra_mart.foundation.page.TreeNodeProvider)
    • class jp.co.intra_mart.foundation.page.EventScript
    • class jp.co.intra_mart.foundation.page.NodeNameComparator (implements java.util.Comparator, java.io.Serializable)
    • class jp.co.intra_mart.foundation.page.TreeLeaf (implements jp.co.intra_mart.foundation.page.TreeNode)

インタフェース階層

  • interface jp.co.intra_mart.foundation.page.TreeNode
  • interface jp.co.intra_mart.foundation.page.TreeNodeContainer
    • interface jp.co.intra_mart.foundation.page.TreeNodeProvider


パッケージ jp.co.intra_mart.foundation.page の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.page の使用

jp.co.intra_mart.foundation.page を使用しているパッケージ
jp.co.intra_mart.foundation.page ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.page により使用される jp.co.intra_mart.foundation.page のクラス
AbstractTreeNodeContainer
ツリービューの子ノードを扱うためのメソッドを提供する抽象クラスです。
TreeBranch
ツリービュー内の「フォルダ」をあらわすクラスです。
TreeLeaf
ツリービュー内の「ページ」をあらわすクラスです。
TreeNode
ツリービュー内の単一のノードを表すインターフェースです。
TreeNodeContainer
子ノードを参照するためのメソッドが定義されたインターフェースです。
TreeNodeProvider
ツリービューの「ホーム」をあらわすインターフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


TreeBranch (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
クラス TreeBranch

java.lang.Object
    拡張 jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer
        拡張 jp.co.intra_mart.foundation.page.TreeBranch
すべての実装インタフェース:
TreeNode, TreeNodeContainer
public class TreeBranch
extends AbstractTreeNodeContainer
implements TreeNode

ツリービュー内の「フォルダ」をあらわすクラスです。
TreeNodeインターフェースの実装クラスのインスタンスを子ノードとして持つことが出来ます。

導入されたバージョン:
version 4.3
バージョン:
1.0

コンストラクタの概要
TreeBranch()
新しいTreeBranchオブジェクトを生成します。
TreeBranch(Comparator comparator)
指定されたコンパレータに従って子ノードをソートする、新しいTreeBranchオブジェクトを生成します。
メソッドの概要
String | getArgument() 引数文字列を取得します。
String | getName() 項目の表示名称のを取得します。
String | getNote() マウスポイント時に表示されるポップアップ文字列を取得します。
void | setAll(TreeBranch branch) 指定された branch 内の表示名称、ポップアップ文字列、引数文字列をこのオブジェクトに設定します。
void | setArgument(String argument) 引数文字列を設定します。
void | setName(String name) 項目の表示名称のを設定します。
void | setNote(String note) マウスポイント時に表示されるポップアップ文字列を設定します。
クラス jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer から継承したメソッド
addChildBranch, addChildLeaf, addChildNode, getChildNodes, hasChildNode, hasChildNodes, isEmpty, removeChildNode, removeChildNodes, size, sort, sortAll
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

TreeBranch

public TreeBranch()
新しいTreeBranchオブジェクトを生成します。

TreeBranch

public TreeBranch(Comparator comparator)
指定されたコンパレータに従って子ノードをソートする、新しいTreeBranchオブジェクトを生成します。

パラメータ:
comparator - コンパレータ
メソッドの詳細

getName

public String getName()
項目の表示名称のを取得します。

定義:
インタフェース TreeNode 内の getName
戻り値:
項目の表示名称

setName

public void setName(String name)
項目の表示名称のを設定します。

パラメータ:
name - 項目の表示名称

getNote

public String getNote()
マウスポイント時に表示されるポップアップ文字列を取得します。

定義:
インタフェース TreeNode 内の getNote
戻り値:
ポップアップ文字列

setNote

public void setNote(String note)
マウスポイント時に表示されるポップアップ文字列を設定します。

パラメータ:
note - ポップアップ文字列

getArgument

public String getArgument()
引数文字列を取得します。引数文字列はマウスクリックイベント発生時に実行される任意の Client Side JavaScript 関数に渡されます。

定義:
インタフェース TreeNode 内の getArgument
戻り値:
引数文字列

setArgument

public void setArgument(String argument)
引数文字列を設定します。引数文字列はマウスクリックイベント発生時に実行される任意の Client Side JavaScript 関数に渡されます。

パラメータ:
argument - 引数文字列

setAll

public void setAll(TreeBranch branch)
指定された branch 内の表示名称、ポップアップ文字列、引数文字列をこのオブジェクトに設定します。

パラメータ:
branch - 指定されたブランチ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TreeLeaf (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
クラス TreeLeaf

java.lang.Object
    拡張 jp.co.intra_mart.foundation.page.TreeLeaf
すべての実装インタフェース:
TreeNode
public class TreeLeaf
extends Object
implements TreeNode

ツリービュー内の「ページ」をあらわすクラスです。 このクラスは子ノードを持つことが出来ません。

導入されたバージョン:
version 4.3
バージョン:
1.0

コンストラクタの概要
TreeLeaf()
新しくTreeLeafオブジェクトを生成します。
TreeLeaf(String name)
新しくTreeLeafオブジェクトを生成し、表示名称を設定します。
TreeLeaf(String name, String note)
新しくTreeLeafオブジェクトを生成し、表示名称と、ポップアップ文字列を設定します。
メソッドの概要
String | getArgument() 引数文字列を取得します。
String | getName() 項目の表示名称のを取得します。
String | getNote() マウスポイント時に表示されるポップアップ文字列を取得します。
void | setArgument(String argument) マウスクリックイベント発生時に実行される任意の Client Side JavaScript 関数に渡される引数文字列を設定します。
void | setName(String name) 項目の表示名称を設定します。
void | setNote(String note) マウスポイント時に表示されるポップアップ文字列を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

TreeLeaf

public TreeLeaf()
新しくTreeLeafオブジェクトを生成します。

TreeLeaf

public TreeLeaf(String name)
新しくTreeLeafオブジェクトを生成し、表示名称を設定します。

パラメータ:
name - 表示名称

TreeLeaf

public TreeLeaf(String name,
                String note)
新しくTreeLeafオブジェクトを生成し、表示名称と、ポップアップ文字列を設定します。

パラメータ:
name - 表示名称
note - ポップアップ文字列
メソッドの詳細

getName

public String getName()
項目の表示名称のを取得します。

定義:
インタフェース TreeNode 内の getName
戻り値:
項目の表示名称

setName

public void setName(String name)
項目の表示名称を設定します。

パラメータ:
name - 項目の表示名称

getNote

public String getNote()
マウスポイント時に表示されるポップアップ文字列を取得します。

定義:
インタフェース TreeNode 内の getNote
戻り値:
note ポップアップ文字列

setNote

public void setNote(String note)
マウスポイント時に表示されるポップアップ文字列を設定します。

パラメータ:
note -

getArgument

public String getArgument()
引数文字列を取得します。引数文字列はマウスクリックイベント発生時に実行される任意の Client Side JavaScript 関数に渡されます。

定義:
インタフェース TreeNode 内の getArgument
戻り値:
JavaScript JavaScript関数に渡される引数文字列

setArgument

public void setArgument(String argument)
マウスクリックイベント発生時に実行される任意の Client Side JavaScript 関数に渡される引数文字列を設定します。

パラメータ:
argument - 引数文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TreeNode (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
インタフェース TreeNode

既知の実装クラスの一覧:
TreeBranch, TreeLeaf
public interface TreeNode

ツリービュー内の単一のノードを表すインターフェースです。 ツリービュー表示時の表示名称、ポップアップ文字列、JavaScript 関数に渡される引数文字列を取得するメソッドを持ちます。

導入されたバージョン:
version 4.3
バージョン:
1.0

メソッドの概要
String | getArgument() 引数文字列を取得します。
String | getName() 項目の表示名称のを取得します。
String | getNote() マウスポイント時に表示されるポップアップ文字列を取得します。

メソッドの詳細

getName

public String getName()
項目の表示名称のを取得します。

戻り値:
項目の表示名称

getNote

public String getNote()
マウスポイント時に表示されるポップアップ文字列を取得します。

戻り値:
ポップアップ文字列

getArgument

public String getArgument()
引数文字列を取得します。引数文字列はマウスクリックイベント発生時に実行される任意の Client Side JavaScript 関数に渡されます。

戻り値:
引数文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


TreeNodeContainer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
インタフェース TreeNodeContainer

既知のサブインタフェースの一覧:
TreeNodeProvider
既知の実装クラスの一覧:
AbstractTreeNodeContainer, TreeRoot
public interface TreeNodeContainer

子ノードを参照するためのメソッドが定義されたインターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
Collection | getChildNodes() このノードの子をすべて含む Collectionを返します。
boolean | hasChildNodes() このノードが子ノードを持っているかどうかを判断します。
boolean | isEmpty() このノードが一つも子を持っていないときにtrueを返します。
int | size() このノードが持つ子ノードの数を返します。

メソッドの詳細

getChildNodes

public Collection getChildNodes()
このノードの子をすべて含む Collectionを返します。 もし、一つも子ノードがない時は空のCollectionが返されます。

戻り値:
子ノードを含むCollection

hasChildNodes

public boolean hasChildNodes()
このノードが子ノードを持っているかどうかを判断します。 持っているときは、trueを返します。

戻り値:
持ってるときは、trueを返します。

isEmpty

public boolean isEmpty()
このノードが一つも子を持っていないときにtrueを返します。

戻り値:
子を持っていないときにtrueを返します。

size

public int size()
このノードが持つ子ノードの数を返します。

戻り値:
子ノードの数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TreeNodeProvider (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
インタフェース TreeNodeProvider

すべてのスーパーインタフェース:
TreeNodeContainer
既知の実装クラスの一覧:
TreeRoot
public interface TreeNodeProvider
extends TreeNodeContainer

ツリービューの「ホーム」をあらわすインターフェースです。 ツリービューの「ホーム」をあらわすクラスを作成するときは必ずこのインターフェースを実装する必要があります。

導入されたバージョン:
version 4.3
バージョン:
1.0

メソッドの概要
 Set getNodeSet()
ツリービュー内の「ホーム」以外の全てのノードが含まれるSetを返します。
インタフェース jp.co.intra_mart.foundation.page.TreeNodeContainer から継承したメソッド
getChildNodes, hasChildNodes, isEmpty, size

メソッドの詳細

getNodeSet

public Set getNodeSet()
ツリービュー内の「ホーム」以外の全てのノードが含まれるSetを返します。

戻り値:
ルート以外の全てのノードが含まれるSet
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


TreeRoot (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
クラス TreeRoot

java.lang.Object
    拡張 jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer
        拡張 jp.co.intra_mart.foundation.page.TreeRoot
すべての実装インタフェース:
TreeNodeContainer, TreeNodeProvider
public class TreeRoot
extends AbstractTreeNodeContainer
implements TreeNodeProvider

ツリービュー内の「ホーム」をあらわすクラスです。 子のクラスのオブジェクトは、ツリービュー内に一つだけ存在し、ツリーの原点となるノードです。

導入されたバージョン:
version 4.3
バージョン:
1.0

コンストラクタの概要
TreeRoot()
新しいTreeRootオブジェクトを生成します。
TreeRoot(Comparator comparator)
指定されたコンパレータに従って子ノードをソートする、新しいTreeRootオブジェクトを生成します。
メソッドの概要
 Set getNodeSet()
ツリービュー内の「ホーム」以外の全てのノードが含まれるSetを返します。
クラス jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer から継承したメソッド
addChildBranch, addChildLeaf, addChildNode, getChildNodes, hasChildNode, hasChildNodes, isEmpty, removeChildNode, removeChildNodes, size, sort, sortAll
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.foundation.page.TreeNodeContainer から継承したメソッド
getChildNodes, hasChildNodes, isEmpty, size

コンストラクタの詳細

TreeRoot

public TreeRoot()
新しいTreeRootオブジェクトを生成します。

TreeRoot

public TreeRoot(Comparator comparator)
指定されたコンパレータに従って子ノードをソートする、新しいTreeRootオブジェクトを生成します。

パラメータ:
comparator - 指定されたコンパレータ
メソッドの詳細

getNodeSet

public Set getNodeSet()
ツリービュー内の「ホーム」以外の全てのノードが含まれるSetを返します。

定義:
インタフェース TreeNodeProvider 内の getNodeSet
戻り値:
ルート以外の全てのノードが含まれるSet
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager の使用

jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived の使用

NewArrived を使用しているパッケージ
jp.co.intra_mart.foundation.portal.general_purpose_portlet
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider
jp.co.intra_mart.foundation.security.password

jp.co.intra_mart.foundation.portal.general_purpose_portlet での NewArrived の使用

NewArrived を返す jp.co.intra_mart.foundation.portal.general_purpose_portlet のメソッド
static NewArrived[] NewArrivedManager.getNewArrivedList(String config)
汎用新着情報の一覧を取得します。

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider での NewArrived の使用

NewArrived を返す jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider のメソッド
NewArrived[] | PageBaseCallProvider.getNewArrivedList(String user, String group) 汎用新着情報を取得
NewArrived[] | NewArrivedProvider.getNewArrivedList(String user, String group) 新着情報を一覧を取得します。

jp.co.intra_mart.foundation.security.password での NewArrived の使用

NewArrived を返す jp.co.intra_mart.foundation.security.password のメソッド
 NewArrived[] PasswordHistoryNewArrivedProvider.getNewArrivedList(String user, String group)
パスワード履歴管理の新着情報を一覧を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


NewArrived (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.general_purpose_portlet.model
クラス NewArrived

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived
すべての実装インタフェース:
Serializable
public class NewArrived
extends Object
implements Serializable

汎用新着情報を保持します。

導入されたバージョン:
5.1
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
NewArrived()
メソッドの概要
String | getCategory() 新着情報のカテゴリ名を取得します。
String | getContents() 新着情報の内容を取得します。
String | getDate() 日付を取得します。
String | getUrl() リンク先のURLを取得します。
boolean | isPopup() リンクへ参照時にポップアップを呼び出すかどうかを取得します。
void | setCategory(String category) 新着情報のカテゴリ名を設定します。
void | setContents(String contents) 新着情報の内容を設定します。
void | setDate(String date) 日付を設定します。
void | setPopup(boolean popup) リンクへ参照時にポップアップを呼び出すかどうかを設定します。
void | setUrl(String url) リンク先のURLを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NewArrived

public NewArrived()
メソッドの詳細

getCategory

public String getCategory()
新着情報のカテゴリ名を取得します。

戻り値:
新着カテゴリ名

setCategory

public void setCategory(String category)
新着情報のカテゴリ名を設定します。 カテゴリ名に null が設定された場合は、空文字に変換します。

パラメータ:
category - 新着カテゴリ名

getContents

public String getContents()
新着情報の内容を取得します。

戻り値:
新着情報の内容

setContents

public void setContents(String contents)
新着情報の内容を設定します。 内容に null が設定された場合は、空文字に変換します。

パラメータ:
contents - 新着情報の内容

getUrl

public String getUrl()
リンク先のURLを取得します。

戻り値:
リンク先のURL

setUrl

public void setUrl(String url)
リンク先のURLを設定します。 URLに null が設定された場合は、空文字に変換します。

パラメータ:
url - リンク先のURL

isPopup

public boolean isPopup()
リンクへ参照時にポップアップを呼び出すかどうかを取得します。

戻り値:
ポップアップを呼び出す場合は true、それ以外は falseを返します。

setPopup

public void setPopup(boolean popup)
リンクへ参照時にポップアップを呼び出すかどうかを設定します。

パラメータ:
popup - ポップアップするかどうか

getDate

public String getDate()
日付を取得します。

戻り値:
日付

setDate

public void setDate(String date)
日付を設定します。 日付に null が設定された場合は、空文字に変換します。

パラメータ:
date - 日付
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.portal.general_purpose_portlet.model (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.portal.general_purpose_portlet.model
クラス
NewArrived


jp.co.intra_mart.foundation.portal.general_purpose_portlet.model (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet.model

クラスの概要
NewArrived 汎用新着情報を保持します。


jp.co.intra_mart.foundation.portal.general_purpose_portlet.model クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet.model の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet.model の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.portal.general_purpose_portlet.model の使用

jp.co.intra_mart.foundation.portal.general_purpose_portlet.model を使用しているパッケージ
jp.co.intra_mart.foundation.portal.general_purpose_portlet
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider
jp.co.intra_mart.foundation.security.password

jp.co.intra_mart.foundation.portal.general_purpose_portlet により使用される jp.co.intra_mart.foundation.portal.general_purpose_portlet.model のクラス
NewArrived
汎用新着情報を保持します。

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider により使用される jp.co.intra_mart.foundation.portal.general_purpose_portlet.model のクラス
NewArrived
汎用新着情報を保持します。

jp.co.intra_mart.foundation.security.password により使用される jp.co.intra_mart.foundation.portal.general_purpose_portlet.model のクラス
NewArrived
汎用新着情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider の使用

NewArrivedProvider を使用しているパッケージ
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider
jp.co.intra_mart.foundation.security.password

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider での NewArrivedProvider の使用

NewArrivedProvider を実装している jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider のクラス
 class PageBaseCallProvider
NewArrivedProvider インターフェースの実装です。

jp.co.intra_mart.foundation.security.password での NewArrivedProvider の使用

NewArrivedProvider を実装している jp.co.intra_mart.foundation.security.password のクラス
 class PasswordHistoryNewArrivedProvider
パスワード履歴管理汎用新着情報のプロバイダ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider の使用

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


NewArrivedProvider (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider
インタフェース NewArrivedProvider

既知の実装クラスの一覧:
PageBaseCallProvider, PasswordHistoryNewArrivedProvider
public interface NewArrivedProvider

汎用新着情報のプロバイダのインターフェースです。

導入されたバージョン:
5.1
バージョン:
1.0

メソッドの概要
NewArrived[] | getNewArrivedList(String user, String group) 新着情報を一覧を取得します。
void | init(Properties properties) 初期化を行います。

メソッドの詳細

init

public void init(Properties properties)
初期化を行います。

パラメータ:
properties - 初期化パラメータ

getNewArrivedList

public NewArrived[] getNewArrivedList(String user,
                                      String group)
                               throws ApplicationException
新着情報を一覧を取得します。
新着情報が存在しない場合は、空の配列を返します。

パラメータ:
user - ログインユーザコード
group - ログイングループID
戻り値:
新着情報の一覧
例外:
ApplicationException - 新着情報の取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider
インタフェース
NewArrivedProvider
クラス
PageBaseCallProvider


jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider

インタフェースの概要
NewArrivedProvider 汎用新着情報のプロバイダのインターフェースです。

クラスの概要
PageBaseCallProvider NewArrivedProvider インターフェースの実装です。


jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider (implements jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider)

インタフェース階層

  • interface jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider


パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider の使用

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider を使用しているパッケージ
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider
jp.co.intra_mart.foundation.security.password

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider により使用される jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider のクラス
NewArrivedProvider
汎用新着情報のプロバイダのインターフェースです。

jp.co.intra_mart.foundation.security.password により使用される jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider のクラス
NewArrivedProvider
汎用新着情報のプロバイダのインターフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PageBaseCallProvider (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider
クラス PageBaseCallProvider

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider
すべての実装インタフェース:
NewArrivedProvider
public class PageBaseCallProvider
extends Object
implements NewArrivedProvider

NewArrivedProvider インターフェースの実装です。

このクラスは、initメソッドで設定される Properties オブジェクトから 定数 PAGE_PATH をキー名として特定されるページベースプログラムから、新着情報の一覧を取得します。
ページベースプログラムにパラメータを渡したい場合は、initメソッドで設定される Properties オブジェクトにページベースプログラムの情報に加えて、任意のキーでパラメータを設定して下さい。

このクラスから呼び出されるページベースプログラムは、返却値として配列を返す必要があります。 配列の要素は、以下のプロパティを格納したオブジェクトです。

新着情報オブジェクト
プロパティ名 | JavaScriptの型 | 設定内容
category | String | 新着情報のカテゴリ名
contents | String | 新着情報の内容
url | String | 新着情報の詳細情報へ遷移するURL
popup | Boolean | 詳細情報へ遷移する際にポップアップするかどうかのフラグ
date | String | 新着情報の配信日付

導入されたバージョン:
5.1
バージョン:
1.0

フィールドの概要
static String PAGE_PATH
ページベースプログラム名を特定するキー
コンストラクタの概要
PageBaseCallProvider()
メソッドの概要
NewArrived[] | getNewArrivedList(String user, String group) 汎用新着情報を取得
void | init(Properties properties) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PAGE_PATH

public static final String PAGE_PATH
ページベースプログラム名を特定するキー

関連項目:
定数フィールド値
コンストラクタの詳細

PageBaseCallProvider

public PageBaseCallProvider()
メソッドの詳細

getNewArrivedList

public NewArrived[] getNewArrivedList(String user,
                                      String group)
                               throws ApplicationException
汎用新着情報を取得

定義:
インタフェース NewArrivedProvider 内の getNewArrivedList
パラメータ:
user - ユーザコード
group - グループコード
戻り値:
汎用新着情報一覧
例外:
ApplicationException - 新着情報の取得に失敗した場合

init

public void init(Properties properties)
初期化を行います。

定義:
インタフェース NewArrivedProvider 内の init
パラメータ:
properties - 初期化パラメータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


NewArrivedManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.general_purpose_portlet
クラス NewArrivedManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager
public class NewArrivedManager
extends Object

汎用新着情報の取得処理を行うクラスです。
汎用新着情報の取得を行う際は、このクラスを利用します。

導入されたバージョン:
5.1
バージョン:
1.0

コンストラクタの概要
NewArrivedManager()
メソッドの概要
static NewArrived[] getNewArrivedList(String config)
汎用新着情報の一覧を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NewArrivedManager

public NewArrivedManager()
メソッドの詳細

getNewArrivedList

public static NewArrived[] getNewArrivedList(String config)
                                      throws ApplicationException
汎用新着情報の一覧を取得します。
引数の設定ファイルは、ストレージサービスからの相対パスで指定します。
新着情報が存在しなかった場合は、空の配列を返します。

パラメータ:
config - 設定ファイル
戻り値:
新着情報の一覧
例外:
ApplicationException - 新着情報の取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.portal.general_purpose_portlet (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.portal.general_purpose_portlet
クラス
NewArrivedManager


jp.co.intra_mart.foundation.portal.general_purpose_portlet (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet

クラスの概要
NewArrivedManager 汎用新着情報の取得処理を行うクラスです。


jp.co.intra_mart.foundation.portal.general_purpose_portlet クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager


パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.portal.general_purpose_portlet の使用

jp.co.intra_mart.foundation.portal.general_purpose_portlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.portlet.PortletManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.portlet.PortletManager の使用

jp.co.intra_mart.foundation.portal.portlet.PortletManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.portlet.PortletManagerException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.portlet.PortletManagerException の使用

PortletManagerException を使用しているパッケージ
jp.co.intra_mart.foundation.portal.portlet

jp.co.intra_mart.foundation.portal.portlet での PortletManagerException の使用

PortletManagerException をスローする jp.co.intra_mart.foundation.portal.portlet のメソッド
void | PortletManager.setPortlet(Portlet portlet) ポートレット情報を登録します。
void | PortletManager.deletePortlet(Portlet portlet) ポートレット情報を削除します。
Portlet | PortletManager.getPortlet(String portletCode, String pageKind) すでに登録済のポートレット情報を取得します。
Portlet[] | PortletManager.getPortlets() すでに登録されているポートレット情報の一覧を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.portlet.PortletMapping の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.portlet.PortletMapping の使用

PortletMapping を使用しているパッケージ
jp.co.intra_mart.foundation.portal.portlet

jp.co.intra_mart.foundation.portal.portlet での PortletMapping の使用

PortletMapping を返す jp.co.intra_mart.foundation.portal.portlet のメソッド
static PortletMapping PortletMapping.getInstance()
インスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet の使用

jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet の使用

J2eeFwPortlet を使用しているパッケージ
jp.co.intra_mart.foundation.portal.portlet.model

jp.co.intra_mart.foundation.portal.portlet.model での J2eeFwPortlet の使用

jp.co.intra_mart.foundation.portal.portlet.model での J2eeFwPortlet のサブクラス
class | MenuLinkSetPortlet ページ種別「メニューリンクセット」に対するポートレットのモデルです。
class | RssPortlet ページ種別「RSS」に対するポートレットのモデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet の使用

jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet の使用

jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.portlet.model.Portlet の使用

Portlet を使用しているパッケージ
jp.co.intra_mart.foundation.portal.portlet
jp.co.intra_mart.foundation.portal.portlet.model

jp.co.intra_mart.foundation.portal.portlet での Portlet の使用

Portlet を返す jp.co.intra_mart.foundation.portal.portlet のメソッド
Portlet | PortletMapping.getPortlet(String pageKind) 指定されたページ種別に対応するポートレットモデルのインスタンスを取得します。
Portlet | PortletManager.getPortlet(String portletCode, String pageKind) すでに登録済のポートレット情報を取得します。
Portlet[] | PortletManager.getPortlets() すでに登録されているポートレット情報の一覧を取得します。

Portlet 型のパラメータを持つ jp.co.intra_mart.foundation.portal.portlet のメソッド
void | PortletManager.setPortlet(Portlet portlet) ポートレット情報を登録します。
void | PortletManager.deletePortlet(Portlet portlet) ポートレット情報を削除します。

jp.co.intra_mart.foundation.portal.portlet.model での Portlet の使用

jp.co.intra_mart.foundation.portal.portlet.model での Portlet のサブクラス
class | InternetPortlet ページ種別「インターネット」に対するポートレットのモデルです。
class | J2eeFwPortlet ページ種別「J2EEフレームワーク」に対するポートレットのモデルです。
class | JspPortlet ページ種別「Servlet/JSP」に対するポートレットのモデルです。
class | MenuLinkSetPortlet ページ種別「メニューリンクセット」に対するポートレットのモデルです。
class | PresentationPagePortlet ページ種別「プレゼンテーションページ」に対するポートレットのモデルです。
class | RssPortlet ページ種別「RSS」に対するポートレットのモデルです。
class | StandardPortlet 標準ポートレットに対するモデルの抽象クラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet の使用

jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet の使用

jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet の使用

StandardPortlet を使用しているパッケージ
jp.co.intra_mart.foundation.portal.portlet.model

jp.co.intra_mart.foundation.portal.portlet.model での StandardPortlet の使用

jp.co.intra_mart.foundation.portal.portlet.model での StandardPortlet のサブクラス
class | InternetPortlet ページ種別「インターネット」に対するポートレットのモデルです。
class | JspPortlet ページ種別「Servlet/JSP」に対するポートレットのモデルです。
class | PresentationPagePortlet ページ種別「プレゼンテーションページ」に対するポートレットのモデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


InternetPortlet (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.portlet.model
クラス InternetPortlet

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.portlet.model.Portlet
        拡張 jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet
            拡張 jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet
すべての実装インタフェース:
Serializable
public class InternetPortlet
extends StandardPortlet

ページ種別「インターネット」に対するポートレットのモデルです。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
static String PAGE_KIND
ページ種別
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したフィールド
DISPLAY_NONE, DISPLAY_PERCENT, DISPLAY_PIXCEL
コンストラクタの概要
InternetPortlet()
メソッドの概要
boolean | equals(Object obj) このポートレットと別のオブジェクトとが等しいかどうかを比較します。
String | getPageKind() ページ種別を取得します。
クラス jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet から継承したメソッド
getArgument, getUrl, setArgument, setUrl
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したメソッド
getApplication, getCacheTime, getExplain, getHeight, getPortletCode, getPortletName, getRecordDate, getRecordUserCode, getUnit, getWidth, hashCode, isTitleBar, setApplication, setCacheConfig, setExplain, setHeight, setPortletCode, setPortletName, setRecordDate, setRecordUserCode, setTitleBar, setUnit, setWidth
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PAGE_KIND

public static final String PAGE_KIND
ページ種別

関連項目:
定数フィールド値
コンストラクタの詳細

InternetPortlet

public InternetPortlet()
メソッドの詳細

getPageKind

public String getPageKind()
ページ種別を取得します。

定義:
クラス Portlet 内の getPageKind
戻り値:
ページ種別

equals

public boolean equals(Object obj)
このポートレットと別のオブジェクトとが等しいかどうかを比較します。
2つのポートレットが等しいのは、同じポートレット種別、同じポートレットコードを持つ場合です。

戻り値:
オブジェクトが同じである場合はtrue、そうでない場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


J2eeFwPortlet (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.portlet.model
クラス J2eeFwPortlet

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.portlet.model.Portlet
        拡張 jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
MenuLinkSetPortlet, RssPortlet
public class J2eeFwPortlet
extends Portlet

ページ種別「J2EEフレームワーク」に対するポートレットのモデルです。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
static String PAGE_KIND
ページ種別
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したフィールド
DISPLAY_NONE, DISPLAY_PERCENT, DISPLAY_PIXCEL
コンストラクタの概要
J2eeFwPortlet()
メソッドの概要
boolean | equals(Object obj) このポートレットと別のオブジェクトとが等しいかどうかを比較します。
String | getApplicationId() アプリケーションIDを取得します。
String | getArgument() ページ引数を取得します。
String | getPageKind() ページ種別を取得します。
String | getServiceId() サービスIDを取得します。
void | setApplicationId(String applicationId) アプリケーションIDを設定します。
void | setArgument(String argument) ページ引数を設定します。
void | setServiceId(String serviceId) サービスIDを設定します。
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したメソッド
getApplication, getCacheTime, getExplain, getHeight, getPortletCode, getPortletName, getRecordDate, getRecordUserCode, getUnit, getWidth, hashCode, isTitleBar, setApplication, setCacheConfig, setExplain, setHeight, setPortletCode, setPortletName, setRecordDate, setRecordUserCode, setTitleBar, setUnit, setWidth
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PAGE_KIND

public static final String PAGE_KIND
ページ種別

関連項目:
定数フィールド値
コンストラクタの詳細

J2eeFwPortlet

public J2eeFwPortlet()
メソッドの詳細

getApplicationId

public String getApplicationId()
アプリケーションIDを取得します。

戻り値:
アプリケーションID
例外:
IllegalStateException - アプリケーションIDがnullである場合

setApplicationId

public void setApplicationId(String applicationId)
アプリケーションIDを設定します。(必須)
アプリケーションIDは必須項目です。必ずnull以外の値を設定して下さい。

パラメータ:
applicationId - アプリケーションID
例外:
IllegalArgumentException - アプリケーションIDにnullが設定された場合

getServiceId

public String getServiceId()
サービスIDを取得します。

戻り値:
サービスID
例外:
IllegalStateException - サービスIDがnullである場合

setServiceId

public void setServiceId(String serviceId)
サービスIDを設定します。(必須)
サービスIDは必須項目です。必ずnull以外の値を設定して下さい。

パラメータ:
serviceId - サービスID
例外:
IllegalArgumentException - サービスIDにnullが設定された場合

getArgument

public String getArgument()
ページ引数を取得します。

戻り値:
ページ引数

setArgument

public void setArgument(String argument)
ページ引数を設定します。

パラメータ:
argument - ページ引数

getPageKind

public String getPageKind()
ページ種別を取得します。

定義:
クラス Portlet 内の getPageKind
戻り値:
ページ種別

equals

public boolean equals(Object obj)
このポートレットと別のオブジェクトとが等しいかどうかを比較します。
2つのポートレットが等しいのは、同じポートレット種別、同じポートレットコードを持つ場合です。

戻り値:
オブジェクトが同じである場合はtrue、そうでない場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


JspPortlet (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.portlet.model
クラス JspPortlet

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.portlet.model.Portlet
        拡張 jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet
            拡張 jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet
すべての実装インタフェース:
Serializable
public class JspPortlet
extends StandardPortlet

ページ種別「Servlet/JSP」に対するポートレットのモデルです。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
static String PAGE_KIND
ページ種別
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したフィールド
DISPLAY_NONE, DISPLAY_PERCENT, DISPLAY_PIXCEL
コンストラクタの概要
JspPortlet()
メソッドの概要
boolean | equals(Object obj) このポートレットと別のオブジェクトとが等しいかどうかを比較します。
String | getPageKind() ページ種別を取得します。
クラス jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet から継承したメソッド
getArgument, getUrl, setArgument, setUrl
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したメソッド
getApplication, getCacheTime, getExplain, getHeight, getPortletCode, getPortletName, getRecordDate, getRecordUserCode, getUnit, getWidth, hashCode, isTitleBar, setApplication, setCacheConfig, setExplain, setHeight, setPortletCode, setPortletName, setRecordDate, setRecordUserCode, setTitleBar, setUnit, setWidth
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PAGE_KIND

public static final String PAGE_KIND
ページ種別

関連項目:
定数フィールド値
コンストラクタの詳細

JspPortlet

public JspPortlet()
メソッドの詳細

getPageKind

public String getPageKind()
ページ種別を取得します。

定義:
クラス Portlet 内の getPageKind
戻り値:
ページ種別

equals

public boolean equals(Object obj)
このポートレットと別のオブジェクトとが等しいかどうかを比較します。
2つのポートレットが等しいのは、同じポートレット種別、同じポートレットコードを持つ場合です。

戻り値:
オブジェクトが同じである場合はtrue、そうでない場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuLinkSetPortlet (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.portlet.model
クラス MenuLinkSetPortlet

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.portlet.model.Portlet
        拡張 jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet
            拡張 jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet
すべての実装インタフェース:
Serializable
public class MenuLinkSetPortlet
extends J2eeFwPortlet

ページ種別「メニューリンクセット」に対するポートレットのモデルです。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
static String PAGE_KIND
ページ種別
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したフィールド
DISPLAY_NONE, DISPLAY_PERCENT, DISPLAY_PIXCEL
コンストラクタの概要
MenuLinkSetPortlet()
コンストラクタ
メソッドの概要
boolean | equals(Object obj) このポートレットと別のオブジェクトとが等しいかどうかを比較します。
String | getMenuLinkSetCode() メニューリンクセットコードを取得します。
String | getPageKind() ページ種別を取得します。
void | setMenuLinkSetCode(String menuLinkSetCode) メニューリンクセットコードを設定します。
クラス jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet から継承したメソッド
getApplicationId, getArgument, getServiceId, setApplicationId, setArgument, setServiceId
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したメソッド
getApplication, getCacheTime, getExplain, getHeight, getPortletCode, getPortletName, getRecordDate, getRecordUserCode, getUnit, getWidth, hashCode, isTitleBar, setApplication, setCacheConfig, setExplain, setHeight, setPortletCode, setPortletName, setRecordDate, setRecordUserCode, setTitleBar, setUnit, setWidth
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PAGE_KIND

public static final String PAGE_KIND
ページ種別

関連項目:
定数フィールド値
コンストラクタの詳細

MenuLinkSetPortlet

public MenuLinkSetPortlet()
コンストラクタ

メソッドの詳細

getMenuLinkSetCode

public String getMenuLinkSetCode()
メニューリンクセットコードを取得します。

戻り値:
メニューリンクセットコード
例外:
IllegalStateException - メニューリンクセットコードがnullである場合

setMenuLinkSetCode

public void setMenuLinkSetCode(String menuLinkSetCode)
メニューリンクセットコードを設定します。(必須)
メニューリンクセットコードは必須項目です。必ずnull以外の値を設定して下さい。

パラメータ:
menuLinkSetCode - メニューリンクセットコード
例外:
IllegalArgumentException - メニューリンクセットコードにnullが設定された場合

getPageKind

public String getPageKind()
ページ種別を取得します。

オーバーライド:
クラス J2eeFwPortlet 内の getPageKind
戻り値:
ページ種別

equals

public boolean equals(Object obj)
このポートレットと別のオブジェクトとが等しいかどうかを比較します。
2つのポートレットが等しいのは、同じポートレット種別、同じポートレットコードを持つ場合です。

オーバーライド:
クラス J2eeFwPortlet 内の equals
戻り値:
オブジェクトが同じである場合はtrue、そうでない場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.portal.portlet.model (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.portal.portlet.model
クラス
InternetPortlet
J2eeFwPortlet
JspPortlet
MenuLinkSetPortlet
Portlet
PresentationPagePortlet
RssPortlet
StandardPortlet


jp.co.intra_mart.foundation.portal.portlet.model (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.portlet.model

クラスの概要
InternetPortlet | ページ種別「インターネット」に対するポートレットのモデルです。
J2eeFwPortlet | ページ種別「J2EEフレームワーク」に対するポートレットのモデルです。
JspPortlet | ページ種別「Servlet/JSP」に対するポートレットのモデルです。
MenuLinkSetPortlet | ページ種別「メニューリンクセット」に対するポートレットのモデルです。
Portlet | すべてのポートレットの基底となる抽象クラスです。
PresentationPagePortlet | ページ種別「プレゼンテーションページ」に対するポートレットのモデルです。
RssPortlet | ページ種別「RSS」に対するポートレットのモデルです。
StandardPortlet | 標準ポートレットに対するモデルの抽象クラスです。


jp.co.intra_mart.foundation.portal.portlet.model クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.portlet.model の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.portal.portlet.model.Portlet (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet
        • class jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet
        • class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet
      • class jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet
        • class jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet
        • class jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet
        • class jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet


パッケージ jp.co.intra_mart.foundation.portal.portlet.model の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.portal.portlet.model の使用

jp.co.intra_mart.foundation.portal.portlet.model を使用しているパッケージ
jp.co.intra_mart.foundation.portal.portlet
jp.co.intra_mart.foundation.portal.portlet.model

jp.co.intra_mart.foundation.portal.portlet により使用される jp.co.intra_mart.foundation.portal.portlet.model のクラス
Portlet
すべてのポートレットの基底となる抽象クラスです。

jp.co.intra_mart.foundation.portal.portlet.model により使用される jp.co.intra_mart.foundation.portal.portlet.model のクラス
J2eeFwPortlet
ページ種別「J2EEフレームワーク」に対するポートレットのモデルです。
Portlet
すべてのポートレットの基底となる抽象クラスです。
StandardPortlet
標準ポートレットに対するモデルの抽象クラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Portlet (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.portlet.model
クラス Portlet

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.portlet.model.Portlet
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
J2eeFwPortlet, StandardPortlet
public abstract class Portlet
extends Object
implements Serializable

すべてのポートレットの基底となる抽象クラスです。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
static String | DISPLAY_NONE 表示単位を指定しない状態
static String | DISPLAY_PERCENT 表示単位パーセント
static String | DISPLAY_PIXCEL 表示単位ピクセル
コンストラクタの概要
Portlet()
メソッドの概要
String | getApplication() アプリケーション名を取得します。
int | getCacheTime() キャッシュ時間を取得します。
String | getExplain() 説明を取得します。
int | getHeight() 表示単位に対する高さを取得します。
abstract String | getPageKind() ページ種別を取得します。
String | getPortletCode() ポートレットコードを取得します。
String | getPortletName() ポートレット名を取得します。
Date | getRecordDate() レコード更新日を取得します。
String | getRecordUserCode() レコード更新ユーザコードを取得します。
String | getUnit() 表示単位を取得します。
int | getWidth() 表示単位に対する幅を取得します。
int | hashCode() このオブジェクトに対するハッシュコード値を返します。
boolean | isTitleBar() タイトルバーを表示するかどうかのステータスを取得します。
void | setApplication(String application) アプリケーション名を設定します。
void | setCacheConfig(int cacheTime) キャッシュ時間を設定します。
void | setExplain(String explain) 説明を設定します。
void | setHeight(int height) 表示単位に対する高さを設定します。
void | setPortletCode(String portletCode) ポートレットコードを設定します。
void | setPortletName(String portletName) ポートレット名を設定します。
void | setRecordDate(Date recordDate) レコード更新日を設定します。
void | setRecordUserCode(String recordUserCode) レコード更新ユーザコードを設定します。
void | setTitleBar(boolean titleBar) タイトルバーを表示するかどうかのステータスを設定します。
void | setUnit(String unit) 表示単位を設定します。
void | setWidth(int width) 表示単位に対する幅設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DISPLAY_NONE

public static final String DISPLAY_NONE
表示単位を指定しない状態

DISPLAY_PERCENT

public static final String DISPLAY_PERCENT
表示単位パーセント

関連項目:
定数フィールド値

DISPLAY_PIXCEL

public static final String DISPLAY_PIXCEL
表示単位ピクセル

関連項目:
定数フィールド値
コンストラクタの詳細

Portlet

public Portlet()
メソッドの詳細

getApplication

public String getApplication()
アプリケーション名を取得します。

戻り値:
アプリケーション名

setApplication

public void setApplication(String application)
アプリケーション名を設定します。

パラメータ:
application - アプリケーション名

getCacheTime

public int getCacheTime()
キャッシュ時間を取得します。
初期値は 0 (キャッシュ設定なし)になります。

戻り値:
キャッシュ時間

setCacheConfig

public void setCacheConfig(int cacheTime)
キャッシュ時間を設定します。

パラメータ:
cacheTime - キャッシュ時間

getHeight

public int getHeight()
表示単位に対する高さを取得します。

戻り値:
表示高さ

setHeight

public void setHeight(int height)
表示単位に対する高さを設定します。

パラメータ:
height - 表示高

getUnit

public String getUnit()
表示単位を取得します。

戻り値:
表示単位

setUnit

public void setUnit(String unit)
表示単位を設定します。
表示単位には、以下のいずれのかの値を設定して下さい。
  • Portlet.DISPLAY_NONE (初期値)
  • Portlet.DISPLAY_PERCENT
  • Portlet.DISPLAY_PIXCEL
何れにも該当しない値が設定された場合は表示設定なしとします。

getWidth

public int getWidth()
表示単位に対する幅を取得します。

戻り値:
表示幅

setWidth

public void setWidth(int width)
表示単位に対する幅設定します。

パラメータ:
width - 表示幅

getExplain

public String getExplain()
説明を取得します。

戻り値:
説明

setExplain

public void setExplain(String explain)
説明を設定します。

パラメータ:
explain - 説明

getPortletCode

public String getPortletCode()
ポートレットコードを取得します。

戻り値:
ポートレットコード
例外:
IllegalStateException - ポートレットコードがnullである場合

setPortletCode

public void setPortletCode(String portletCode)
ポートレットコードを設定します。(必須)
ポートレットコードは必須項目です。必ずnull以外の値を設定して下さい。

パラメータ:
portletCode - ポートレットコード
例外:
IllegalArgumentException - ポートレットコードにnullが設定された場合

getPortletName

public String getPortletName()
ポートレット名を取得します。

戻り値:
ポートレット名
例外:
IllegalStateException - ポートレット名がnullである場合

setPortletName

public void setPortletName(String portletName)
ポートレット名を設定します。(必須)
ポートレット名は必須項目です。必ずnull以外の値を設定して下さい。

パラメータ:
portletName - ポートレット名
例外:
IllegalArgumentException - ポートレット名にnullが設定された場合

isTitleBar

public boolean isTitleBar()
タイトルバーを表示するかどうかのステータスを取得します。

戻り値:
タイトルバーを表示するかどうかのステータス

setTitleBar

public void setTitleBar(boolean titleBar)
タイトルバーを表示するかどうかのステータスを設定します。

パラメータ:
titleBar - タイトルバーを表示するかどうかのステータス

getPageKind

public abstract String getPageKind()
ページ種別を取得します。

戻り値:
ページ種別

getRecordUserCode

public String getRecordUserCode()
レコード更新ユーザコードを取得します。

戻り値:
レコード更新ユーザコード

setRecordUserCode

public void setRecordUserCode(String recordUserCode)
レコード更新ユーザコードを設定します。

パラメータ:
recordUserCode - レコード更新ユーザコード

getRecordDate

public Date getRecordDate()
レコード更新日を取得します。
初期値はモデル生成時のシステム時間になります。

戻り値:
レコード更新日

setRecordDate

public void setRecordDate(Date recordDate)
レコード更新日を設定します。

パラメータ:
recordDate - レコード更新日
例外:
IllegalArgumentException - レコード更新日にnullが設定された場合

hashCode

public int hashCode()
このオブジェクトに対するハッシュコード値を返します。

戻り値:
このオブジェクトのハッシュコード値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PresentationPagePortlet (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.portlet.model
クラス PresentationPagePortlet

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.portlet.model.Portlet
        拡張 jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet
            拡張 jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet
すべての実装インタフェース:
Serializable
public class PresentationPagePortlet
extends StandardPortlet

ページ種別「プレゼンテーションページ」に対するポートレットのモデルです。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
static String PAGE_KIND
ページ種別
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したフィールド
DISPLAY_NONE, DISPLAY_PERCENT, DISPLAY_PIXCEL
コンストラクタの概要
PresentationPagePortlet()
メソッドの概要
boolean | equals(Object obj) このポートレットと別のオブジェクトとが等しいかどうかを比較します。
String | getPageKind() ページ種別を取得します。
クラス jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet から継承したメソッド
getArgument, getUrl, setArgument, setUrl
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したメソッド
getApplication, getCacheTime, getExplain, getHeight, getPortletCode, getPortletName, getRecordDate, getRecordUserCode, getUnit, getWidth, hashCode, isTitleBar, setApplication, setCacheConfig, setExplain, setHeight, setPortletCode, setPortletName, setRecordDate, setRecordUserCode, setTitleBar, setUnit, setWidth
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PAGE_KIND

public static final String PAGE_KIND
ページ種別

関連項目:
定数フィールド値
コンストラクタの詳細

PresentationPagePortlet

public PresentationPagePortlet()
メソッドの詳細

getPageKind

public String getPageKind()
ページ種別を取得します。

定義:
クラス Portlet 内の getPageKind
戻り値:
ページ種別

equals

public boolean equals(Object obj)
このポートレットと別のオブジェクトとが等しいかどうかを比較します。
2つのポートレットが等しいのは、同じポートレット種別、同じポートレットコードを持つ場合です。

戻り値:
オブジェクトが同じである場合はtrue、そうでない場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RssPortlet (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.portlet.model
クラス RssPortlet

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.portlet.model.Portlet
        拡張 jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet
            拡張 jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet
すべての実装インタフェース:
Serializable
public class RssPortlet
extends J2eeFwPortlet

ページ種別「RSS」に対するポートレットのモデルです。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
static String PAGE_KIND
ページ種別
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したフィールド
DISPLAY_NONE, DISPLAY_PERCENT, DISPLAY_PIXCEL
コンストラクタの概要
RssPortlet()
コンストラクタ
メソッドの概要
boolean | equals(Object obj) このポートレットと別のオブジェクトとが等しいかどうかを比較します。
String | getPageKind() ページ種別を取得します。
String | getParserKey() RSS解析キーを取得します。
String | getProxyHost() プロキシホスト名を取得します。
int | getProxyPort() プロキシポート番号を取得します。
String | getRssUrl() URLを取得します。
void | setParserKey(String parserKey) RSS解析キーを設定します。
void | setProxyHost(String proxyHost) プロキシホスト名を設定します。
void | setProxyPort(int proxyPort) プロキシポート番号を設定します。
void | setRssUrl(String rssUrl) URLを設定します。
クラス jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet から継承したメソッド
getApplicationId, getArgument, getServiceId, setApplicationId, setArgument, setServiceId
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したメソッド
getApplication, getCacheTime, getExplain, getHeight, getPortletCode, getPortletName, getRecordDate, getRecordUserCode, getUnit, getWidth, hashCode, isTitleBar, setApplication, setCacheConfig, setExplain, setHeight, setPortletCode, setPortletName, setRecordDate, setRecordUserCode, setTitleBar, setUnit, setWidth
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PAGE_KIND

public static final String PAGE_KIND
ページ種別

関連項目:
定数フィールド値
コンストラクタの詳細

RssPortlet

public RssPortlet()
コンストラクタ

メソッドの詳細

getParserKey

public String getParserKey()
RSS解析キーを取得します。

戻り値:
RSS解析キー
例外:
IllegalStateException - RSS解析キーがnullである場合

setParserKey

public void setParserKey(String parserKey)
RSS解析キーを設定します。(必須)
RSS解析キーは必須項目です。必ずnull以外の値を設定して下さい。

パラメータ:
parserKey - RSS解析キー
例外:
IllegalArgumentException - RSS解析キーにnullが設定された場合

getProxyHost

public String getProxyHost()
プロキシホスト名を取得します。

戻り値:
プロキシホスト名

setProxyHost

public void setProxyHost(String proxyHost)
プロキシホスト名を設定します。

パラメータ:
proxyHost - プロキシホスト名

getProxyPort

public int getProxyPort()
プロキシポート番号を取得します。
ポート番号が設定されていない場合は、-1を返却します。

戻り値:
プロキシポート番号

setProxyPort

public void setProxyPort(int proxyPort)
プロキシポート番号を設定します。

パラメータ:
proxyPort - プロキシポート番号

getRssUrl

public String getRssUrl()
URLを取得します。

戻り値:
rssUrl
例外:
IllegalStateException - URLがnullである場合

setRssUrl

public void setRssUrl(String rssUrl)
URLを設定します。(必須)
URLは必須項目です。必ずnull以外の値を設定して下さい。

例外:
IllegalArgumentException - URLにnullが設定された場合

getPageKind

public String getPageKind()
ページ種別を取得します。

オーバーライド:
クラス J2eeFwPortlet 内の getPageKind
戻り値:
ページ種別

equals

public boolean equals(Object obj)
このポートレットと別のオブジェクトとが等しいかどうかを比較します。
2つのポートレットが等しいのは、同じポートレット種別、同じポートレットコードを持つ場合です。

オーバーライド:
クラス J2eeFwPortlet 内の equals
戻り値:
オブジェクトが同じである場合はtrue、そうでない場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardPortlet (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.portlet.model
クラス StandardPortlet

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.portlet.model.Portlet
        拡張 jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
InternetPortlet, JspPortlet, PresentationPagePortlet
public abstract class StandardPortlet
extends Portlet

標準ポートレットに対するモデルの抽象クラスです。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したフィールド
DISPLAY_NONE, DISPLAY_PERCENT, DISPLAY_PIXCEL
コンストラクタの概要
StandardPortlet()
メソッドの概要
String | getArgument() ページ引数を取得します。
String | getUrl() URLを取得します。
void | setArgument(String argument) ページ引数を設定します。
void | setUrl(String url) URLを設定します。
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したメソッド
getApplication, getCacheTime, getExplain, getHeight, getPageKind, getPortletCode, getPortletName, getRecordDate, getRecordUserCode, getUnit, getWidth, hashCode, isTitleBar, setApplication, setCacheConfig, setExplain, setHeight, setPortletCode, setPortletName, setRecordDate, setRecordUserCode, setTitleBar, setUnit, setWidth
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardPortlet

public StandardPortlet()
メソッドの詳細

getArgument

public String getArgument()
ページ引数を取得します。

戻り値:
ページ引数

setArgument

public void setArgument(String argument)
ページ引数を設定します。

パラメータ:
argument - ページ引数

getUrl

public String getUrl()
URLを取得します。

戻り値:
URL
例外:
IllegalStateException - URLがnullである場合

setUrl

public void setUrl(String url)
URLを設定します。(必須)
URLは必須項目です。必ずnull以外の値を設定して下さい。

パラメータ:
url - URL
例外:
IllegalArgumentException - URLにnullが設定された場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.portal.portlet (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.portal.portlet
クラス
PortletManager
PortletMapping
例外
PortletManagerException


jp.co.intra_mart.foundation.portal.portlet (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.portlet

クラスの概要
PortletManager | ポートレット情報の登録・参照を行うマネージャクラスです。
PortletMapping | ポートレットの種別とモデルのマッピングを管理します。

例外の概要
PortletManagerException ポートレットマネージャー操作時に発生するすべての例外のクラスです。


jp.co.intra_mart.foundation.portal.portlet クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.portlet の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.portal.portlet.PortletManager
    • class jp.co.intra_mart.foundation.portal.portlet.PortletMapping
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.portal.portlet.PortletManagerException


パッケージ jp.co.intra_mart.foundation.portal.portlet の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.portal.portlet の使用

jp.co.intra_mart.foundation.portal.portlet を使用しているパッケージ
jp.co.intra_mart.foundation.portal.portlet

jp.co.intra_mart.foundation.portal.portlet により使用される jp.co.intra_mart.foundation.portal.portlet のクラス
PortletManagerException
ポートレットマネージャー操作時に発生するすべての例外のクラスです。
PortletMapping
ポートレットの種別とモデルのマッピングを管理します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PortletManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.portlet
クラス PortletManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.portlet.PortletManager
public class PortletManager
extends Object

ポートレット情報の登録・参照を行うマネージャクラスです。

導入されたバージョン:
6.0
バージョン:
1.0

コンストラクタの概要
PortletManager(String groupId)
コンストラクタ
メソッドの概要
void | deletePortlet(Portlet portlet) ポートレット情報を削除します。
Portlet | getPortlet(String portletCode, String pageKind) すでに登録済のポートレット情報を取得します。
Portlet[] | getPortlets() すでに登録されているポートレット情報の一覧を取得します。
void | setPortlet(Portlet portlet) ポートレット情報を登録します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PortletManager

public PortletManager(String groupId)
コンストラクタ

パラメータ:
groupId - ログイングループID
メソッドの詳細

setPortlet

public void setPortlet(Portlet portlet)
                throws PortletManagerException
ポートレット情報を登録します。

指定されたポートレット情報が存在ない場合は新規登録します。
すでに存在する場合は更新を行います。

パラメータ:
portlet - ポートレット情報
例外:
PortletManagerException - ポートレットの登録に失敗した場合

deletePortlet

public void deletePortlet(Portlet portlet)
                   throws PortletManagerException
ポートレット情報を削除します。

パラメータ:
portlet - ポートレット情報
例外:
PortletManagerException - ポートレットの削除に失敗した場合

getPortlet

public Portlet getPortlet(String portletCode,
                          String pageKind)
                   throws PortletManagerException
すでに登録済のポートレット情報を取得します。
指定されたポートレット情報が存在しない場合は、nullを返します。

パラメータ:
portletCode - ポートレットコード
pageKind - ページ種別
戻り値:
ポートレット情報
例外:
PortletManagerException - ポートレット情報の取得に失敗した場合

getPortlets

public Portlet[] getPortlets()
                      throws PortletManagerException
すでに登録されているポートレット情報の一覧を取得します。

ポートレット情報を1件も取得できなかった場合は、空の配列を返します。

戻り値:
ポートレット情報の一覧
例外:
PortletManagerException - ポートレット一覧の取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PortletManagerException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.portlet
クラス PortletManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.portal.portlet.PortletManagerException
すべての実装インタフェース:
Serializable
public class PortletManagerException
extends RuntimeException

ポートレットマネージャー操作時に発生するすべての例外のクラスです。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
PortletManagerException()
コンストラクタ
PortletManagerException(String message)
コンストラクタ
PortletManagerException(String message, Throwable cause)
コンストラクタ
PortletManagerException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PortletManagerException

public PortletManagerException()
コンストラクタ

PortletManagerException

public PortletManagerException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

PortletManagerException

public PortletManagerException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

PortletManagerException

public PortletManagerException(String message,
                               Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PortletMapping (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.portlet
クラス PortletMapping

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.portlet.PortletMapping
public class PortletMapping
extends Object

ポートレットの種別とモデルのマッピングを管理します。

導入されたバージョン:
6.0
バージョン:
1.0

フィールドの概要
static String MAPPING_FILE_PATH
ポートレットマッピングの設定ファイルのパス情報
メソッドの概要
String[] | getAvailablePageKind() 利用可能なポートレット種別の一覧を取得します。
static PortletMapping | getInstance() インスタンスを取得します。
Portlet | getPortlet(String pageKind) 指定されたページ種別に対応するポートレットモデルのインスタンスを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

MAPPING_FILE_PATH

public static String MAPPING_FILE_PATH
ポートレットマッピングの設定ファイルのパス情報

メソッドの詳細

getInstance

public static PortletMapping getInstance()
インスタンスを取得します。

戻り値:
PortletMappingのインスタンス

getPortlet

public Portlet getPortlet(String pageKind)
指定されたページ種別に対応するポートレットモデルのインスタンスを取得します。

パラメータ:
pageKind - ページ種別
戻り値:
ポートレットモデルのインスタンス

getAvailablePageKind

public String[] getAvailablePageKind()
利用可能なポートレット種別の一覧を取得します。

戻り値:
ポートレットのページ種別の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.common.auth.SapAuthInfoBundle の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapAuthInfoBundle の使用

jp.co.intra_mart.foundation.sap.common.auth.SapAuthInfoBundle はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.SapClient の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapClient の使用

SapClient を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial | ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems |
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability |
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall |
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica |
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist |
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus |

jp.co.intra_mart.foundation.sap.common.auth での SapClient の使用

jp.co.intra_mart.foundation.sap.common.auth での SapClient のサブクラス
class | SapClientNoLoadBalancing SapClientNoLoadBalancingクラス。
class | SapClientPool SAPClientPoolクラス。
class | SapClientPoolNoLoadBalancing SAPClientPoolクラス。
class | SapClientPoolWithLoadBalancing SAPClientPoolクラス。
class | SapClientWithLoadBalancing SAPClientPoolクラス。

SapClient を返す jp.co.intra_mart.foundation.sap.common.auth のメソッド
static SapClient | SapClientManager.getSapClient() 接続情報初期値を保持したSAPクライアントオブジェクトの取得を行います。
static SapClient | SapClientManager.getSapClient(String serverType) 引数にて受け取ったサーバータイプに紐付く接続情報初期値を保持した SAPクライアントオブジェクトを取得します。

SapClient 型のパラメータを持つ jp.co.intra_mart.foundation.sap.common.auth のメソッド
static com.sap.mw.jco.JCO.Repository SapRepositoryManager.getJCORepository(SapClient sapClient)
Repository情報を生成もしくは、取得します。

jp.co.intra_mart.foundation.sap.common.general_purpose での SapClient の使用

SapClient 型のパラメータを持つ jp.co.intra_mart.foundation.sap.common.general_purpose のコンストラクタ
ConnectionManager(SapClient sapClient)
受け取ったサップクライアントに格納されている接続情報を 用いて、SAPへの接続を行います。
BapiController(String propertyName, SapClient sapClient)
サップクライアントのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。

jp.co.intra_mart.foundation.sap.module での SapClient の使用

SapClient として宣言されている jp.co.intra_mart.foundation.sap.module のフィールド
protected  SapClient AbstractController.sapClient
SAPクライアント

SapClient 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module のコンストラクタ
UpdateController(SapClient sapClient)
コンストラクタ。
ReferenceController(SapClient sapClient)
コンストラクタ。
AbstractController(SapClient sapClient)
コンストラクタ。

jp.co.intra_mart.foundation.sap.module.accounting での SapClient の使用

SapClient 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のコンストラクタ
ProfitCenterList(String controllingArea, String date, SapClient sapClient)
executeBapiを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, SapClient sapClient)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date, SapClient sapClient)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
GlAccList(String companyCode, SapClient sapClient)
executeBapiを呼び出し勘定項目一覧を作成します。
GlAccController(String companyCode, SapClient sapClient)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
CostCenterList(String controllingArea, String date, SapClient sapClient)
executeBapiを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date, SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
ControllingAreaList(SapClient sapClient)
executeBapiを呼び出し管理領域一覧を作成します。
ControllingAreaController(SapClient sapClient)
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
CompanyList(SapClient sapClient)
executeBapiを呼び出し会社一覧を作成します。
CompanyController(SapClient sapClient)
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
BusinessAreaList(SapClient sapClient)
executeBapiを呼び出し事業領域一覧を作成します。
BusinessAreaController(SapClient sapClient)
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BankList(SapClient sapClient)
executeBapiを呼び出し銀行一覧を作成します。
BankController(SapClient sapClient)
BankListのコンストラクタを呼び出し銀行一覧を作成します。
AccEmployeePayPostController(SapClient sapClient)
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバへデータを登録することが可能です。

jp.co.intra_mart.foundation.sap.module.financial での SapClient の使用

SapClient 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.financial のコンストラクタ
ProjectGetInfoController(SapClient sapClient)
ProjectGetInfoControllerのコンストラクタを生成します。
ProjectGetInfo(SapClient sapClient)
WBS情報を作成します。
ProfitCenterGrpGetDetailController(String controllingarea, String groupname, SapClient sapClient)
ProfitCenterGrpGetDetailController(SapClient sapClient)
ProfitCenterGrpGetDetailControllerのコンストラクタを生成します。
ProfitCenterGrpGetDetail(SapClient sapClient)
利益センタグループ情報を作成します。
ProfitCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
InternalOrderGetListController(SapClient sapClient)
InternalOrderGetListControllerのコンストラクタを生成します。
InternalOrderGetList(SapClient sapClient)
内部指図書（一覧）情報を作成します。
InternalOrderGetList(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
InternalOrderGetDetailController(String orderid, String language, SapClient sapClient)
InternalOrderGetDetailController(SapClient sapClient)
InternalOrderGetDetailControllerのコンストラクタを生成します。
InternalOrderGetDetail(SapClient sapClient)
内部指図書詳細情報を作成します。
InternalOrderGetDetail(String orderId, String language, SapClient sapClient)
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
ExchangeRateGetDetailController(SapClient sapClient)
ExchangeRateGetDetailControllerのコンストラクタを生成します。
ExchangeRateGetDetail(SapClient sapClient)
為替換算レート情報を作成
ExchangeRateGetDetail(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
DebtorGetDetailController(String debtorid, String companycode, SapClient sapClient)
DebtorGetDetailController(SapClient sapClient)
DebtorGetDetailControllerのコンストラクタを生成します。
DebtorGetDetail(SapClient sapClient)
得意先詳細情報を作成
DebtorGetDetail(String Debtorid, String Companycode, SapClient sapClient)
CreditorGetDetailController(String creditorid, String companycode, SapClient sapClient)
CreditorGetDetailController(SapClient sapClient)
DebtorGetDetailControllerのコンストラクタを生成します。
CreditorGetDetail(SapClient sapClient)
仕入先詳細情報を作成
CreditorGetDetail(String creditorid, String companycode, SapClient sapClient)
CostCenterGroupGetDetailController(String controllingarea, String groupname, SapClient sapClient)
CostCenterGroupGetDetailController(SapClient sapClient)
CostCenterGroupGetDetailControllerのコンストラクタを生成します。
CostCenterGroupGetDetail(SapClient sapClient)
原価センタグループ情報を作成
CostCenterGroupGetDetail(String controllingarea, String groupname, SapClient sapClient)
CommonCenterGrpGetDetail(SapClient sapClient)
センタグループ情報を作成
CommonCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)

jp.co.intra_mart.foundation.sap.module.purchase での SapClient の使用

SapClient 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase のコンストラクタ
SupplierGetDetailController(SapClient sapClient)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(String vendor, String compCode, SapClient sapClient)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierExistenceCheckController(SapClient sapClient)
コンストラクタ生成
SupplierExistenceCheckController(String vendor, String compCode, SapClient sapClient)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheck(SapClient sapClient)
仕入先詳細情報クラスを取得します
SupplierExistenceCheck(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先コード存在チェックを作成します。
SupplierDetail(SapClient sapClient)
仕入先詳細情報クラスを取得します
SupplierDetail(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先マスタ詳細を作成します。
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
PurchaseResetReleaseController(String purchaseorder, String poRelCode, String useExceptions, SapClient sapClient)
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。
PurchaseReleaseController(String purchaseorder, String poRelCode, String useExceptions, SapClient sapClient)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
PurchaseRelease(String purchaseorder, String poRelCode, String useExceptions, SapClient sapClient)
コンストラクタ生成。
PurchaseOrderPostChangeController(SapClient sapClient)
PurchaseOrderPostChangeControllerのコンストラクタを生成します。
PurchaseOrderPayPostController(SapClient sapClient)
PurchaseOrderPayPostControllerのコンストラクタを生成します。
PurchaseOrderPayPost(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
PurchaseGetItemSrelController(SapClient sapClient)
コンストラクタ生成
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrel(SapClient sapClient)
コンストラクタ生成
PurchaseGetItemSrel(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
承認対象一覧を作成します。
MaterialSaveReplicaController(SapClient sapClient)
コンストラクタ生成
MaterialGetListController(SapClient sapClient)
MaterialGetListのコンストラクタを生成します。
MaterialGetList(SapClient sapClient)
品目コードの選択オプション一覧、品目テキストの選択オプション一覧、 製造業者と製造者製品コード一覧、プラントの選択オプション一覧、 保管場所の選択オプション一覧、販売組織の選択オプション一覧、 流通チャネルの選択オプション一覧、品目コードと品目テキスト一覧を作成します｡
MaterialGetAllController(SapClient sapClient)
コンストラクタ生成
MaterialGetAllController(String material, String companyCode, String plant, String storageLocation, String salesOrganisation, String distributionChannel, SapClient sapClient)
MaterialGetallのコンストラクタを呼び出し品目マスタ照会情報を取得します。
MaterialAvailabilityController(SapClient sapClient)
コンストラクタ生成
GoodsMvtGetItemsController(SapClient sapClient)
コンストラクタ生成
GoodsMvtCreateController(SapClient sapClient)
GoodsMvtCreateControllerのコンストラクタを生成します。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での SapClient の使用

SapClient 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のコンストラクタ
GoodsMvtCreate(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems での SapClient の使用

SapClient 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems のコンストラクタ
GoodsMvtGetItems(SapClient sapClient)
出庫確認一覧照会情報を作成します。

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability での SapClient の使用

SapClient 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialavailability のコンストラクタ
MaterialAvailability(SapClient sapClient)
品目在庫確認情報を作成します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での SapClient の使用

SapClient 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のコンストラクタ
MaterialGetAll(SapClient sapClient)
品目マスタ照会情報を作成します。
MaterialGetAll(String material, String companyCode, String plant, String storageLocation, String salesOrganisation, String distributionChannel, SapClient sapClient)
品目マスタ照会情報を作成します。

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica での SapClient の使用

SapClient 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica のコンストラクタ
MaterialSaveReplica(SapClient sapClient)
品目マスタ更新情報を作成します。

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber での SapClient の使用

SapClient 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber のコンストラクタ
StdMaterialGetIntNumberList(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
executeBapiを呼び出し品目コード割当済一覧を作成します。

jp.co.intra_mart.foundation.sap.module.sales での SapClient の使用

SapClient 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales のコンストラクタ
SalesOrderGetStatusController(SapClient sapClient)
コンストラクタ生成
SalesOrderGetStatusController(String salesdocument, SapClient sapClient)
コンストラクタ生成
SalesOrderGetListController(SapClient sapClient)
コンストラクタ生成
SalesOrderGetListController(String customerNumber, String salesOrganisation, String material, String purchaseOrder, String transactionGroup, SapClient sapClient)
コンストラクタ生成
SalesOrderCreateFromDat2Controller(SapClient sapClient)
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。
QuotationCreateFromData2Controller(SapClient sapClient)
QuotationCreateFromData2Controllerのコンストラクタを生成します。
InquiryCreateFromData2Controller(SapClient sapClient)
InquiryCreateFromData2Controllerのコンストラクタを生成します。
BillingDocGetListController(SapClient sapClient)
コンストラクタ生成
BillingDocGetListController(String sign, String option, String refDocRow, String refDocHigh, SapClient sapClient)
コンストラクタ生成
BillingDocGetDetailController(String billingDocument, SapClient sapClient)
コンストラクタ生成
BillingDocCreateMultipleController(SapClient sapClient)
BillingDocCreateMultipleControllerのコンストラクタを生成します。

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple での SapClient の使用

SapClient 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple のコンストラクタ
BillingDocCreateMultiple(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での SapClient の使用

SapClient 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のコンストラクタ
BillingDocGetDetail(String billingdocument, SapClient sapClient)
請求伝票詳細照会情報を作成します。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist での SapClient の使用

SapClient 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist のコンストラクタ
BillingDocGetList(SapClient sapClient)
請求伝票一覧照会情報を作成します。
BillingDocGetList(String sign, String option, String refDocRow, String refDocHigh, SapClient sapClient)
請求伝票一覧照会情報を作成します。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での SapClient の使用

SapClient 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のコンストラクタ
InquiryCreateFromData2(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での SapClient の使用

SapClient 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のコンストラクタ
QuotationCreateFromData2(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での SapClient の使用

SapClient 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のコンストラクタ
SalesOrderCreateFromDat2(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist での SapClient の使用

SapClient 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist のコンストラクタ
SalesOrderGetList(SapClient sapClient)
販売伝票一覧照会情報を作成します。
SalesOrderGetList(String customerNumber, String salesOrganisation, String material, String purchaseOrder, String transactionGroup, SapClient sapClient)
販売伝票一覧照会情報を作成します。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus での SapClient の使用

SapClient 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus のコンストラクタ
SalesOrderGetStatus(SapClient sapClient)
販売伝票ステータス一覧照会情報を作成します。
SalesOrderGetStatus(String salesdocument, SapClient sapClient)
販売伝票ステータス一覧照会情報を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.SapClientManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapClientManager の使用

jp.co.intra_mart.foundation.sap.common.auth.SapClientManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing の使用

jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.SapClientPool の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapClientPool の使用

SapClientPool を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth ＳＡＰ連携に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.auth での SapClientPool の使用

jp.co.intra_mart.foundation.sap.common.auth での SapClientPool のサブクラス
class | SapClientPoolNoLoadBalancing SAPClientPoolクラス。
class | SapClientPoolWithLoadBalancing SAPClientPoolクラス。

SapClientPool 型のパラメータを持つ jp.co.intra_mart.foundation.sap.common.auth のメソッド
protected com.sap.mw.jco.JCO.Pool | SapClientPoolWithLoadBalancing.createPool(SapClientPool sapClientPool) コネクションプールを生成します。
protected com.sap.mw.jco.JCO.Pool | SapClientPoolNoLoadBalancing.createPool(SapClientPool sapClientPool) コネクションプールを生成します。
static void | SapClientPoolManager.createPool(SapClientPool sapClientPool) コネクションプール方式を用いて、JCOコネクションの取得を行います。
protected abstract com.sap.mw.jco.JCO.Pool | SapClientPool.createPool(SapClientPool sapClientPool) JCOコネクションプールを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolManager の使用

jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing の使用

jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing の使用

jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing の使用

jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.SapConnector の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapConnector の使用

jp.co.intra_mart.foundation.sap.common.auth.SapConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager の使用

jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException の使用

SAPAuthAppException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial | ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail |

jp.co.intra_mart.foundation.sap.common.auth での SAPAuthAppException の使用

SAPAuthAppException をスローする jp.co.intra_mart.foundation.sap.common.auth のコンストラクタ
SapConnector(String serverType)
推奨されていません。 プロパティファイルを読込み属性に値をセットします。

jp.co.intra_mart.foundation.sap.common.general_purpose での SAPAuthAppException の使用

SAPAuthAppException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のメソッド
 void BapiController.executeBapi()
BAPIを実行します。

jp.co.intra_mart.foundation.sap.module での SAPAuthAppException の使用

SAPAuthAppException をスローする jp.co.intra_mart.foundation.sap.module のメソッド
protected  void AbstractController.executeBapi(BapiController bapiController)
引数で指定された bapiController のexecuteBapiメソッドを実行します。

jp.co.intra_mart.foundation.sap.module.accounting での SAPAuthAppException の使用

SAPAuthAppException をスローする jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void AccEmployeePayPostController.executeBapi()
BapiControllerにより会計伝票を登録します。

SAPAuthAppException をスローする jp.co.intra_mart.foundation.sap.module.accounting のコンストラクタ
ProfitCenterList(String controllingArea, String date, SapClient sapClient)
executeBapiを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, SapClient sapClient)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date, SapClient sapClient)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
GlAccList(String companyCode, SapClient sapClient)
executeBapiを呼び出し勘定項目一覧を作成します。
GlAccController(String companyCode)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
GlAccController(String companyCode, SapClient sapClient)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
CostCenterList(String controllingArea, String date, SapClient sapClient)
executeBapiを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date, SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
ControllingAreaList(SapClient sapClient)
executeBapiを呼び出し管理領域一覧を作成します。
ControllingAreaController()
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
ControllingAreaController(SapClient sapClient)
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
CompanyList(SapClient sapClient)
executeBapiを呼び出し会社一覧を作成します。
CompanyController()
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
CompanyController(SapClient sapClient)
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
BusinessAreaList(SapClient sapClient)
executeBapiを呼び出し事業領域一覧を作成します。
BusinessAreaController()
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BusinessAreaController(SapClient sapClient)
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BankList(SapClient sapClient)
executeBapiを呼び出し銀行一覧を作成します。
BankController()
BankListのコンストラクタを呼び出し銀行一覧を作成します。
BankController(SapClient sapClient)
BankListのコンストラクタを呼び出し銀行一覧を作成します。

jp.co.intra_mart.foundation.sap.module.financial での SAPAuthAppException の使用

SAPAuthAppException をスローする jp.co.intra_mart.foundation.sap.module.financial のメソッド
 void ProjectGetInfoController.executeBapi()
ProjectGetInfoのexecuteBapi()を呼び出しWBSの詳細を取得します。
 void ProjectGetInfo.executeBapi()
BapiControllerによりWBSの詳細情報の検索します。
 void ProfitCenterGrpGetDetailController.executeBapi()
ProfitCenterGrpGetDetailのexecuteBapi()を呼び出し利益センタグループを取得します。
 void ProfitCenterGrpGetDetail.executeBapi()
BapiControllerにより利益センタグループ検索を検索します。
 void InternalOrderGetListController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し内部指図書一覧を取得します。
 void InternalOrderGetList.executeBapi()
BapiControllerにより内部指図書（一覧）情報を検索します。
 void InternalOrderGetDetailController.executeBapi()
InternalOrderGetDetailのexecuteBapi()を呼び出し内部指図書詳細を取得します。
 void InternalOrderGetDetail.executeBapi()
BapiControllerにより内部指図書詳細情報を検索します。
 void ExchangeRateGetDetailController.executeBapi()
ExchangeRateGetDetailのexecuteBapi()を呼び出し為替換算レートを取得します。
 void ExchangeRateGetDetail.executeBapi()
BapiControllerにより為替換算レート情報を検索します。
 void DebtorGetDetail.executeBapi()
BapiControllerにより得意先コードを検索します。
 void CreditorGetDetail.executeBapi()
BapiControllerにより仕入先コードを検索します。
 void CostCenterGroupGetDetailController.executeBapi()
CostCenterGroupGetDetailのexecuteBapi()を呼び出し原価センタグループを取得します。
 void CostCenterGroupGetDetail.executeBapi()
BapiControllerにより原価センタグループ検索を検索します。

SAPAuthAppException をスローする jp.co.intra_mart.foundation.sap.module.financial のコンストラクタ
ProfitCenterGrpGetDetailController(String controllingarea, String groupname)
ProfitCenterGrpGetDetailController(String controllingarea, String groupname, SapClient sapClient)
ProfitCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo)
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
InternalOrderGetList(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
InternalOrderGetDetailController(String orderid, String language)
InternalOrderGetDetailController(String orderid, String language, SapClient sapClient)
InternalOrderGetDetail(String orderId, String language, SapClient sapClient)
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date)
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
ExchangeRateGetDetail(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
DebtorGetDetailController(String debtorid, String companycode)
DebtorGetDetailController(String debtorid, String companycode, SapClient sapClient)
DebtorGetDetail(String Debtorid, String Companycode, SapClient sapClient)
CreditorGetDetailController(String creditorid, String companycode)
CreditorGetDetailController(String creditorid, String companycode, SapClient sapClient)
CreditorGetDetail(String creditorid, String companycode, SapClient sapClient)
CostCenterGroupGetDetailController(String controllingarea, String groupname)
CostCenterGroupGetDetailController(String controllingarea, String groupname, SapClient sapClient)
CostCenterGroupGetDetail(String controllingarea, String groupname, SapClient sapClient)
CommonCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)

jp.co.intra_mart.foundation.sap.module.purchase での SAPAuthAppException の使用

SAPAuthAppException をスローする jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 void SupplierGetDetailController.executeBapi()
SupplierDetailのexecuteBapi()を呼び出し仕入先マスタ詳細情報を作成します。
 void SupplierExistenceCheckController.executeBapi()
SupplierExistenceCheckのexecuteBapi()を呼び出し仕入先コード存在チェックを行います。
 void SupplierExistenceCheck.executeBapi()
BapiControllerにより仕入先コード存在チェックを作成します。
 void SupplierDetail.executeBapi()
BapiControllerにより仕入先マスタ詳細を作成します。
 void PurchaseResetReleaseController.executeBapi()
伝票承認取消処理を実行します。
 void PurchaseReleaseController.executeBapi()
伝票承認処理を実行します。
 void PurchaseRelease.executeBapi(BapiController bapiController)
伝票承認取消処理を実行します。
 void PurchaseOrderPostChangeController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を変更します。
 void PurchaseOrderPayPostController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を登録します。
 void PurchaseOrderPayPost.executeBapi(BapiController bapiController)
購買発注伝票の登録及び変更に共通で使用する項目に値をセットした後、 AbstractController#executeBapi()を実行します。
 void PurchaseGetItemSrelController.executeBapi()
PurchaseGetItemSrelのexecuteBapi()を呼び出し伝票承認対象一覧を取得します。
 void PurchaseGetItemSrel.executeBapi()
BapiControllerにより仕入先マスタ詳細を作成します。
 void MaterialSaveReplicaController.executeBapi()
BapiControllerにより品目マスタを更新します。
 void MaterialGetListController.executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し品目コードを検索します。
 void MaterialGetAllController.executeBapi()
BapiControllerにより品目マスタ照会を行います。
 void MaterialAvailabilityController.executeBapi()
MaterialAvailabilityのexecuteBapi()を呼び出し品目コードを検索します。
 void GoodsMvtGetItemsController.executeBapi()
GoodsMvtGetItemsのexecuteBapi()を呼び出し品目コードを検索します。
 void GoodsMvtCreateController.executeBapi()
GoodsMvtCreateのexecuteBapi()を呼び出し品目コードを検索します。

SAPAuthAppException をスローする jp.co.intra_mart.foundation.sap.module.purchase のコンストラクタ
SupplierGetDetailController(String vendor, String compCode)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(String vendor, String compCode, SapClient sapClient)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierExistenceCheckController(String vendor, String compCode)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheckController(String vendor, String compCode, SapClient sapClient)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheck(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先コード存在チェックを作成します。
SupplierDetail(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先マスタ詳細を作成します。
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrel(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
承認対象一覧を作成します。

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber での SAPAuthAppException の使用

SAPAuthAppException をスローする jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber のコンストラクタ
StdMaterialGetIntNumberList(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
executeBapiを呼び出し品目コード割当済一覧を作成します。

jp.co.intra_mart.foundation.sap.module.sales での SAPAuthAppException の使用

SAPAuthAppException をスローする jp.co.intra_mart.foundation.sap.module.sales のメソッド
 void SalesOrderGetStatusController.executeBapi()
SalesOrderGetStatusのexecuteBapi()を呼び出し販売伝票ステータス一覧を照会します。
 void SalesOrderGetListController.executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し販売伝票一覧を取得します。
 void SalesOrderCreateFromDat2Controller.executeBapi()
SalesOrderCreateFromDat2のexecuteBapi()を呼び出し販売伝票を登録します。
 void QuotationCreateFromData2Controller.executeBapi()
QuotationCreateFromData2のexecuteBapi()を呼び出し見積伝票を登録します。
 void InquiryCreateFromData2Controller.executeBapi()
InquiryCreateFromData2のexecuteBapi()を呼び出し引合伝票を登録します。
 void BillingDocGetListController.executeBapi()
BillingDocGetListのexecuteBapi()を呼び出し請求伝票一覧を検索します。
 void BillingDocCreateMultipleController.executeBapi()
BillingDocCreateMultipleのexecuteBapi()を呼び出し請求伝票を登録します。

SAPAuthAppException をスローする jp.co.intra_mart.foundation.sap.module.sales のコンストラクタ
BillingDocGetDetailController(String billingDocument)
コンストラクタ生成
BillingDocGetDetailController(String billingDocument, SapClient sapClient)
コンストラクタ生成

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での SAPAuthAppException の使用

SAPAuthAppException をスローする jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のメソッド
 void BillingDocGetDetail.executeBapi()
BillingDocGetDetailのexecuteBapi()を呼び出し請求伝票を検索します。

SAPAuthAppException をスローする jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のコンストラクタ
BillingDocGetDetail(String billingdocument, SapClient sapClient)
請求伝票詳細照会情報を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException の使用

SAPAuthSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.data | ＳＡＰ連携にて使用するデータ変換クラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.file | ＳＡＰ連携にて使用するプロパティを操作するクラスを提供します。
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial | ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail |

jp.co.intra_mart.foundation.sap.common.auth での SAPAuthSystemException の使用

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.common.auth のメソッド
static com.sap.mw.jco.JCO.Repository | SapRepositoryManager.getJCORepository(SapClient sapClient) Repository情報を生成もしくは、取得します。
com.sap.mw.jco.JCO.Client | SapConnector.useConnection() 推奨されていません。 コネクションを生成します。
static void | SapConnector.releaseConnection(com.sap.mw.jco.JCO.Client connection) 推奨されていません。 コネクションをリリースします。
static SapClient | SapClientManager.getSapClient() 接続情報初期値を保持したSAPクライアントオブジェクトの取得を行います。
static SapClient | SapClientManager.getSapClient(String serverType) 引数にて受け取ったサーバータイプに紐付く接続情報初期値を保持した SAPクライアントオブジェクトを取得します。
void | SapClient.release() JCOコネクションの開放を行います。
com.sap.mw.jco.JCO.Client | SapClient.getJCOClient() JCOコネクションの取得を行います。
static String | SapAuthInfoBundle.getProperty(String propertyName) 引数で指定されたプロパティの値を返却します。
static String | SapAuthInfoBundle.getProperty(String serverType, String propertyName) 引数で指定されたプロパティの値を返却します。

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.common.auth のコンストラクタ
SapConnector()
推奨されていません。 プロパティファイルを読込み属性に値をセットします。
SapConnector(String serverType)
推奨されていません。 プロパティファイルを読込み属性に値をセットします。

jp.co.intra_mart.foundation.sap.common.general_purpose での SAPAuthSystemException の使用

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のメソッド
 void BapiController.executeBapi()
BAPIを実行します。

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のコンストラクタ
BapiController(String propertyName)
プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡
BapiController(String propertyName, ConnectionManager connectionManager)
コネクションマネージャのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録・更新処理を実行することができます。
BapiController(String propertyName, SapClient sapClient)
サップクライアントのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。

jp.co.intra_mart.foundation.sap.common.util.data での SAPAuthSystemException の使用

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.common.util.data のメソッド
static String ExtendedParamConverter.changeToUpperParam(String param, String propertyName, String paramType)
入力された項目名をプロパティファイルの項目名に変換します。

jp.co.intra_mart.foundation.sap.common.util.file での SAPAuthSystemException の使用

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.common.util.file のコンストラクタ
PropertiesFile(String fileName)
ファイル名を指定してプロパティファイルを取得します。

jp.co.intra_mart.foundation.sap.module での SAPAuthSystemException の使用

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.module のメソッド
protected BapiController | UpdateController.createBapiController(String propertyFileName) 引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。
protected BapiController | AbstractController.createBapiController(String propertyFileName) 引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。
protected void | AbstractController.executeBapi(BapiController bapiController) 引数で指定された bapiController のexecuteBapiメソッドを実行します。

jp.co.intra_mart.foundation.sap.module.accounting での SAPAuthSystemException の使用

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void AccEmployeePayPostController.executeBapi()
BapiControllerにより会計伝票を登録します。

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.module.accounting のコンストラクタ
ProfitCenterList(String controllingArea, String date, SapClient sapClient)
executeBapiを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, SapClient sapClient)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date, SapClient sapClient)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
GlAccList(String companyCode, SapClient sapClient)
executeBapiを呼び出し勘定項目一覧を作成します。
GlAccController(String companyCode)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
GlAccController(String companyCode, SapClient sapClient)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
CostCenterList(String controllingArea, String date, SapClient sapClient)
executeBapiを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date, SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
ControllingAreaList(SapClient sapClient)
executeBapiを呼び出し管理領域一覧を作成します。
ControllingAreaController()
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
ControllingAreaController(SapClient sapClient)
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
CompanyList(SapClient sapClient)
executeBapiを呼び出し会社一覧を作成します。
CompanyController()
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
CompanyController(SapClient sapClient)
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
BusinessAreaList(SapClient sapClient)
executeBapiを呼び出し事業領域一覧を作成します。
BusinessAreaController()
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BusinessAreaController(SapClient sapClient)
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BankList(SapClient sapClient)
executeBapiを呼び出し銀行一覧を作成します。
BankController()
BankListのコンストラクタを呼び出し銀行一覧を作成します。
BankController(SapClient sapClient)
BankListのコンストラクタを呼び出し銀行一覧を作成します。

jp.co.intra_mart.foundation.sap.module.financial での SAPAuthSystemException の使用

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.module.financial のメソッド
 void ProjectGetInfoController.executeBapi()
ProjectGetInfoのexecuteBapi()を呼び出しWBSの詳細を取得します。
 void ProjectGetInfo.executeBapi()
BapiControllerによりWBSの詳細情報の検索します。
 void ProfitCenterGrpGetDetailController.executeBapi()
ProfitCenterGrpGetDetailのexecuteBapi()を呼び出し利益センタグループを取得します。
 void ProfitCenterGrpGetDetail.executeBapi()
BapiControllerにより利益センタグループ検索を検索します。
 void InternalOrderGetListController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し内部指図書一覧を取得します。
 void InternalOrderGetList.executeBapi()
BapiControllerにより内部指図書（一覧）情報を検索します。
 void InternalOrderGetDetailController.executeBapi()
InternalOrderGetDetailのexecuteBapi()を呼び出し内部指図書詳細を取得します。
 void InternalOrderGetDetail.executeBapi()
BapiControllerにより内部指図書詳細情報を検索します。
 void ExchangeRateGetDetailController.executeBapi()
ExchangeRateGetDetailのexecuteBapi()を呼び出し為替換算レートを取得します。
 void ExchangeRateGetDetail.executeBapi()
BapiControllerにより為替換算レート情報を検索します。
 void DebtorGetDetail.executeBapi()
BapiControllerにより得意先コードを検索します。
 void CreditorGetDetail.executeBapi()
BapiControllerにより仕入先コードを検索します。
 void CostCenterGroupGetDetailController.executeBapi()
CostCenterGroupGetDetailのexecuteBapi()を呼び出し原価センタグループを取得します。
 void CostCenterGroupGetDetail.executeBapi()
BapiControllerにより原価センタグループ検索を検索します。

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.module.financial のコンストラクタ
ProfitCenterGrpGetDetailController(String controllingarea, String groupname)
ProfitCenterGrpGetDetailController(String controllingarea, String groupname, SapClient sapClient)
ProfitCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo)
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
InternalOrderGetList(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
InternalOrderGetDetailController(String orderid, String language)
InternalOrderGetDetailController(String orderid, String language, SapClient sapClient)
InternalOrderGetDetail(String orderId, String language, SapClient sapClient)
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date)
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
ExchangeRateGetDetail(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
DebtorGetDetailController(String debtorid, String companycode)
DebtorGetDetailController(String debtorid, String companycode, SapClient sapClient)
DebtorGetDetail(String Debtorid, String Companycode, SapClient sapClient)
CreditorGetDetailController(String creditorid, String companycode)
CreditorGetDetailController(String creditorid, String companycode, SapClient sapClient)
CreditorGetDetail(String creditorid, String companycode, SapClient sapClient)
CostCenterGroupGetDetailController(String controllingarea, String groupname)
CostCenterGroupGetDetailController(String controllingarea, String groupname, SapClient sapClient)
CostCenterGroupGetDetail(String controllingarea, String groupname, SapClient sapClient)
CommonCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)

jp.co.intra_mart.foundation.sap.module.purchase での SAPAuthSystemException の使用

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 void SupplierGetDetailController.executeBapi()
SupplierDetailのexecuteBapi()を呼び出し仕入先マスタ詳細情報を作成します。
 void SupplierExistenceCheckController.executeBapi()
SupplierExistenceCheckのexecuteBapi()を呼び出し仕入先コード存在チェックを行います。
 void SupplierExistenceCheck.executeBapi()
BapiControllerにより仕入先コード存在チェックを作成します。
 void SupplierDetail.executeBapi()
BapiControllerにより仕入先マスタ詳細を作成します。
 void PurchaseResetReleaseController.executeBapi()
伝票承認取消処理を実行します。
 void PurchaseReleaseController.executeBapi()
伝票承認処理を実行します。
 void PurchaseRelease.executeBapi(BapiController bapiController)
伝票承認取消処理を実行します。
 void PurchaseOrderPostChangeController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を変更します。
 void PurchaseOrderPayPostController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を登録します。
 void PurchaseOrderPayPost.executeBapi(BapiController bapiController)
購買発注伝票の登録及び変更に共通で使用する項目に値をセットした後、 AbstractController#executeBapi()を実行します。
 void PurchaseGetItemSrelController.executeBapi()
PurchaseGetItemSrelのexecuteBapi()を呼び出し伝票承認対象一覧を取得します。
 void PurchaseGetItemSrel.executeBapi()
BapiControllerにより仕入先マスタ詳細を作成します。
 void MaterialSaveReplicaController.executeBapi()
BapiControllerにより品目マスタを更新します。
 void MaterialGetListController.executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し品目コードを検索します。
 void MaterialGetAllController.executeBapi()
BapiControllerにより品目マスタ照会を行います。
 void MaterialAvailabilityController.executeBapi()
MaterialAvailabilityのexecuteBapi()を呼び出し品目コードを検索します。
 void GoodsMvtGetItemsController.executeBapi()
GoodsMvtGetItemsのexecuteBapi()を呼び出し品目コードを検索します。
 void GoodsMvtCreateController.executeBapi()
GoodsMvtCreateのexecuteBapi()を呼び出し品目コードを検索します。

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.module.purchase のコンストラクタ
SupplierGetDetailController(String vendor, String compCode)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(String vendor, String compCode, SapClient sapClient)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierExistenceCheckController(String vendor, String compCode)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheckController(String vendor, String compCode, SapClient sapClient)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheck(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先コード存在チェックを作成します。
SupplierDetail(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先マスタ詳細を作成します。
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrel(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
承認対象一覧を作成します。

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber での SAPAuthSystemException の使用

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber のコンストラクタ
StdMaterialGetIntNumberList(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
executeBapiを呼び出し品目コード割当済一覧を作成します。

jp.co.intra_mart.foundation.sap.module.sales での SAPAuthSystemException の使用

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales のメソッド
 void SalesOrderGetStatusController.executeBapi()
SalesOrderGetStatusのexecuteBapi()を呼び出し販売伝票ステータス一覧を照会します。
 void SalesOrderGetListController.executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し販売伝票一覧を取得します。
 void SalesOrderCreateFromDat2Controller.executeBapi()
SalesOrderCreateFromDat2のexecuteBapi()を呼び出し販売伝票を登録します。
 void QuotationCreateFromData2Controller.executeBapi()
QuotationCreateFromData2のexecuteBapi()を呼び出し見積伝票を登録します。
 void InquiryCreateFromData2Controller.executeBapi()
InquiryCreateFromData2のexecuteBapi()を呼び出し引合伝票を登録します。
 void BillingDocGetListController.executeBapi()
BillingDocGetListのexecuteBapi()を呼び出し請求伝票一覧を検索します。
 void BillingDocCreateMultipleController.executeBapi()
BillingDocCreateMultipleのexecuteBapi()を呼び出し請求伝票を登録します。

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales のコンストラクタ
BillingDocGetDetailController(String billingDocument)
コンストラクタ生成
BillingDocGetDetailController(String billingDocument, SapClient sapClient)
コンストラクタ生成

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での SAPAuthSystemException の使用

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のメソッド
 void BillingDocGetDetail.executeBapi()
BillingDocGetDetailのexecuteBapi()を呼び出し請求伝票を検索します。

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のコンストラクタ
BillingDocGetDetail(String billingdocument, SapClient sapClient)
請求伝票詳細照会情報を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.common.auth.exception (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.common.auth.exception
例外
SAPAuthAppException
SAPAuthSystemException


jp.co.intra_mart.foundation.sap.common.auth.exception (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.auth.exception

ＳＡＰ連携に関する例外クラスを提供します。

参照:
説明

例外の概要
SAPAuthAppException | 認証系APIアプリケーション例外クラス
SAPAuthSystemException | 認証系APIシステム例外クラス

パッケージ jp.co.intra_mart.foundation.sap.common.auth.exception の説明

ＳＡＰ連携に関する例外クラスを提供します。


jp.co.intra_mart.foundation.sap.common.auth.exception クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.auth.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.common.exception.SAPException
          • class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException
          • class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException


パッケージ jp.co.intra_mart.foundation.sap.common.auth.exception の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.auth.exception の使用

jp.co.intra_mart.foundation.sap.common.auth.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.data | ＳＡＰ連携にて使用するデータ変換クラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.file | ＳＡＰ連携にて使用するプロパティを操作するクラスを提供します。
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial | ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail |

jp.co.intra_mart.foundation.sap.common.auth により使用される jp.co.intra_mart.foundation.sap.common.auth.exception のクラス
SAPAuthAppException
認証系APIアプリケーション例外クラス
SAPAuthSystemException
認証系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.common.general_purpose により使用される jp.co.intra_mart.foundation.sap.common.auth.exception のクラス
SAPAuthAppException
認証系APIアプリケーション例外クラス
SAPAuthSystemException
認証系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.common.util.data により使用される jp.co.intra_mart.foundation.sap.common.auth.exception のクラス
SAPAuthSystemException
認証系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.common.util.file により使用される jp.co.intra_mart.foundation.sap.common.auth.exception のクラス
SAPAuthSystemException
認証系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module により使用される jp.co.intra_mart.foundation.sap.common.auth.exception のクラス
SAPAuthAppException
認証系APIアプリケーション例外クラス
SAPAuthSystemException
認証系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.accounting により使用される jp.co.intra_mart.foundation.sap.common.auth.exception のクラス
SAPAuthAppException
認証系APIアプリケーション例外クラス
SAPAuthSystemException
認証系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.financial により使用される jp.co.intra_mart.foundation.sap.common.auth.exception のクラス
SAPAuthAppException
認証系APIアプリケーション例外クラス
SAPAuthSystemException
認証系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.common.auth.exception のクラス
SAPAuthAppException
認証系APIアプリケーション例外クラス
SAPAuthSystemException
認証系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber により使用される jp.co.intra_mart.foundation.sap.common.auth.exception のクラス
SAPAuthAppException
認証系APIアプリケーション例外クラス
SAPAuthSystemException
認証系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.common.auth.exception のクラス
SAPAuthAppException
認証系APIアプリケーション例外クラス
SAPAuthSystemException
認証系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail により使用される jp.co.intra_mart.foundation.sap.common.auth.exception のクラス
SAPAuthAppException
認証系APIアプリケーション例外クラス
SAPAuthSystemException
認証系APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SAPAuthAppException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth.exception
クラス SAPAuthAppException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException
すべての実装インタフェース:
Serializable
public class SAPAuthAppException
extends SAPException

認証系APIアプリケーション例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPAuthAppException(String message)
認証系APIアプリケーション例外
SAPAuthAppException(String message, Throwable ex)
認証系APIアプリケーション例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPAuthAppException

public SAPAuthAppException(String message,
                           Throwable ex)
認証系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPAuthAppException

public SAPAuthAppException(String message)
認証系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPAuthSystemException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth.exception
クラス SAPAuthSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException
すべての実装インタフェース:
Serializable
public class SAPAuthSystemException
extends SAPException

認証系APIシステム例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPAuthSystemException(String message)
認証系APIシステム例外
SAPAuthSystemException(String message, Throwable ex)
認証系APIシステム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPAuthSystemException

public SAPAuthSystemException(String message)
認証系APIシステム例外

パラメータ:
message - エラーメッセージ

SAPAuthSystemException

public SAPAuthSystemException(String message,
                              Throwable ex)
認証系APIシステム例外

パラメータ:
message - エラーメッセージ
ex - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.common.auth (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.common.auth
クラス
SapAuthInfoBundle
SapClient
SapClientManager
SapClientNoLoadBalancing
SapClientPool
SapClientPoolManager
SapClientPoolNoLoadBalancing
SapClientPoolWithLoadBalancing
SapClientWithLoadBalancing
SapConnector
SapRepositoryManager


jp.co.intra_mart.foundation.sap.common.auth (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.auth

ＳＡＰ連携に関するクラスを提供します。

参照:
説明

クラスの概要
SapAuthInfoBundle | 接続情報初期値取得クラス。
SapClient | SAPクライアント抽象クラス。
SapClientManager | SAPクライアントマネージャークラス。
SapClientNoLoadBalancing | SapClientNoLoadBalancingクラス。
SapClientPool | SAPClientPoolクラス。
SapClientPoolManager | SAPクライアントプールマネージャークラス。
SapClientPoolNoLoadBalancing | SAPClientPoolクラス。
SapClientPoolWithLoadBalancing | SAPClientPoolクラス。
SapClientWithLoadBalancing | SAPClientPoolクラス。
SapConnector | 推奨されていません。 本クラスは現在、標準では使用されておりません。
SapRepositoryManager | JCO.Repository を管理クラス。

パッケージ jp.co.intra_mart.foundation.sap.common.auth の説明

ＳＡＰ連携に関するクラスを提供します。


jp.co.intra_mart.foundation.sap.common.auth クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.auth の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.common.auth.SapAuthInfoBundle
    • class jp.co.intra_mart.foundation.sap.common.auth.SapClient
      • class jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing
      • class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool
        • class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing
        • class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing
      • class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing
    • class jp.co.intra_mart.foundation.sap.common.auth.SapClientManager
    • class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolManager
    • class jp.co.intra_mart.foundation.sap.common.auth.SapConnector (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager


パッケージ jp.co.intra_mart.foundation.sap.common.auth の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.auth の使用

jp.co.intra_mart.foundation.sap.common.auth を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial | ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems |
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability |
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall |
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica |
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist |
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus |

jp.co.intra_mart.foundation.sap.common.auth により使用される jp.co.intra_mart.foundation.sap.common.auth のクラス
SapClient
SAPクライアント抽象クラス。
SapClientPool
SAPClientPoolクラス。

jp.co.intra_mart.foundation.sap.common.general_purpose により使用される jp.co.intra_mart.foundation.sap.common.auth のクラス
SapClient
SAPクライアント抽象クラス。

jp.co.intra_mart.foundation.sap.module により使用される jp.co.intra_mart.foundation.sap.common.auth のクラス
SapClient
SAPクライアント抽象クラス。

jp.co.intra_mart.foundation.sap.module.accounting により使用される jp.co.intra_mart.foundation.sap.common.auth のクラス
SapClient
SAPクライアント抽象クラス。

jp.co.intra_mart.foundation.sap.module.financial により使用される jp.co.intra_mart.foundation.sap.common.auth のクラス
SapClient
SAPクライアント抽象クラス。

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.common.auth のクラス
SapClient
SAPクライアント抽象クラス。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate により使用される jp.co.intra_mart.foundation.sap.common.auth のクラス
SapClient
SAPクライアント抽象クラス。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems により使用される jp.co.intra_mart.foundation.sap.common.auth のクラス
SapClient
SAPクライアント抽象クラス。

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability により使用される jp.co.intra_mart.foundation.sap.common.auth のクラス
SapClient
SAPクライアント抽象クラス。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall により使用される jp.co.intra_mart.foundation.sap.common.auth のクラス
SapClient
SAPクライアント抽象クラス。

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica により使用される jp.co.intra_mart.foundation.sap.common.auth のクラス
SapClient
SAPクライアント抽象クラス。

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber により使用される jp.co.intra_mart.foundation.sap.common.auth のクラス
SapClient
SAPクライアント抽象クラス。

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.common.auth のクラス
SapClient
SAPクライアント抽象クラス。

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple により使用される jp.co.intra_mart.foundation.sap.common.auth のクラス
SapClient
SAPクライアント抽象クラス。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail により使用される jp.co.intra_mart.foundation.sap.common.auth のクラス
SapClient
SAPクライアント抽象クラス。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist により使用される jp.co.intra_mart.foundation.sap.common.auth のクラス
SapClient
SAPクライアント抽象クラス。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.common.auth のクラス
SapClient
SAPクライアント抽象クラス。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.common.auth のクラス
SapClient
SAPクライアント抽象クラス。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.common.auth のクラス
SapClient
SAPクライアント抽象クラス。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist により使用される jp.co.intra_mart.foundation.sap.common.auth のクラス
SapClient
SAPクライアント抽象クラス。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus により使用される jp.co.intra_mart.foundation.sap.common.auth のクラス
SapClient
SAPクライアント抽象クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SapAuthInfoBundle (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapAuthInfoBundle

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapAuthInfoBundle
public class SapAuthInfoBundle
extends Object

接続情報初期値取得クラス。
機能は以下の通り。

  • sap_auth_info.property内にて定義されている接続情報の取得を行います。
  • 取得の際は、プロパティ名及び、必要に応じてサーバータイプを用いて、
    指定された情報の取得を行います。

バージョン:
1.0

メソッドの概要
static String | getProperty(String propertyName) 引数で指定されたプロパティの値を返却します。
static String | getProperty(String serverType, String propertyName) 引数で指定されたプロパティの値を返却します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getProperty

public static String getProperty(String propertyName)
                          throws SAPAuthSystemException
引数で指定されたプロパティの値を返却します。

また、プロパティが存在しない場合、nullを返却します。

パラメータ:
propertyName - プロパティ名
戻り値:
プロパティ値またはnull
例外:
SAPAuthSystemException - 認証系システム例外処理

getProperty

public static String getProperty(String serverType,
                                 String propertyName)
                          throws SAPAuthSystemException
引数で指定されたプロパティの値を返却します。

プロパティが存在しない場合、nullを返却します。

パラメータ:
serverType - サーバタイプ
propertyName - プロパティ名
戻り値:
プロパティ値またはnull
例外:
SAPAuthSystemException - 認証系システム例外処理
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SapClient (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClient
直系の既知のサブクラス:
SapClientNoLoadBalancing, SapClientPool, SapClientWithLoadBalancing
public abstract class SapClient
extends Object

SAPクライアント抽象クラス。
機能は以下の通り。

  • SAP APサーバーへの接続情報を保持する為の抽象クラス。
  • JCOコネクションの取得に必要な抽象メソッドを用意しています。

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
protected  com.sap.mw.jco.JCO.Client connection
JCOコネクション
コンストラクタの概要
protected SapClient(String serverType, String client, String user, String passwd, String lang)
引数にて受け取った接続情報を属性にセットします。
メソッドの概要
protected abstract com.sap.mw.jco.JCO.Client | createClient() JCOコネクションの生成を行う為の抽象メソッドです。
String | getClient() クライアントを取得します。
abstract String | getHost() 接続先IPアドレスを取得する為の抽象メソッド
String | getIdentifier() コネクションの識別子を取得します。
com.sap.mw.jco.JCO.Client | getJCOClient() JCOコネクションの取得を行います。
String | getLang() 言語を取得します。
String | getPasswd() パスワードを取得します。
String | getServerType() 設定されているサーバータイプを取得します。
String | getUser() ユーザーを取得します。
void | release() JCOコネクションの開放を行います。
protected abstract void | releaseConnection() JCOコネクションの開放をを行う為の抽象メソッドです。
void | setClient(String client) クライアントを設定します。
void | setLang(String lang) 言語を設定します。
void | setPasswd(String passwd) パスワードを設定します。
void | setUser(String user) ユーザーを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

フィールドの詳細

connection

protected com.sap.mw.jco.JCO.Client connection
JCOコネクション

コンストラクタの詳細

SapClient

protected SapClient(String serverType,
                    String client,
                    String user,
                    String passwd,
                    String lang)
引数にて受け取った接続情報を属性にセットします。

パラメータ:
serverType - サーバータイプ
client - クライアント
user - ユーザー
passwd - パスワード
lang - 言語
メソッドの詳細

createClient

protected abstract com.sap.mw.jco.JCO.Client createClient()
                                                   throws com.sap.mw.jco.JCO.Exception
JCOコネクションの生成を行う為の抽象メソッドです。

戻り値:
JCOコネクション
例外:
JCO.Exception - JCO例外

releaseConnection

protected abstract void releaseConnection()
                                   throws com.sap.mw.jco.JCO.Exception
JCOコネクションの開放をを行う為の抽象メソッドです。

例外:
JCO.Exception - JCO例外

release

public void release()
             throws SAPAuthSystemException
JCOコネクションの開放を行います。

例外:
SAPAuthSystemException - 認証系システム例外

getJCOClient

public com.sap.mw.jco.JCO.Client getJCOClient()
                                       throws SAPAuthSystemException
JCOコネクションの取得を行います。

戻り値:
JCO.Client JCOコネクション
例外:
SAPAuthSystemException - 認証系システム例外

getLang

public String getLang()
言語を取得します。

戻り値:
lang 設定した言語

setLang

public void setLang(String lang)
言語を設定します。

パラメータ:
lang - 設定する言語

getPasswd

public String getPasswd()
パスワードを取得します。

戻り値:
passwd 設定したパスワード

setPasswd

public void setPasswd(String passwd)
パスワードを設定します。

パラメータ:
passwd - 設定するパスワード

getUser

public String getUser()
ユーザーを取得します。

戻り値:
user 設定したユーザー

setUser

public void setUser(String user)
ユーザーを設定します。

パラメータ:
user - 設定するユーザー

getClient

public String getClient()
クライアントを取得します。

戻り値:
client 設定したクライアント

setClient

public void setClient(String client)
クライアントを設定します。

パラメータ:
client - 設定するクライアント

getHost

public abstract String getHost()
接続先IPアドレスを取得する為の抽象メソッド

戻り値:
String 接続先IPアドレス

getIdentifier

public String getIdentifier()
コネクションの識別子を取得します。

戻り値:
identifier コネクションの識別子

getServerType

public String getServerType()
設定されているサーバータイプを取得します。

戻り値:
serverType サーバータイプ

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SapClientManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapClientManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClientManager
public class SapClientManager
extends Object

SAPクライアントマネージャークラス。

機能は以下の通り。

  • 接続情報初期値を保持したSAPクライアントオブジェクトを取得します。
接続情報設定ファイル sap_auth_info.properties で定義した サーバタイプ をキーに SAPクライアントオブジェクトSapClient を取得します。
以下、接続情報設定ファイル sap_auth_info.properties での定義方法を示します。

現在、以下の２つのコネクションに対応しています。
  • プールコネクション(Pool Connection)
  • ダイレクトコネクション(Direct Connection)
それぞれのコネクションにおいて、非負荷分散環境(No Load Balancing)と負荷分散環境(Load Balancing)への接続設定を行うプロパティは異なります。
以下その４パターンについて設定するプロパティを示します。

[備考]
※接続先が１接続の場合、.サーバタイプ を省略することができます。
※接続先が複数存在する場合は、.サーバタイプ を利用して、複数の接続先を定義することができます。
Pool Connection (No Load Balancing)
パラメータ名 | 説明
jco.client.client.サーバタイプ | SAPにログインする際に使用するクライアント
jco.client.user.サーバタイプ | SAPにログインする際に使用するユーザ
jco.client.passwd.サーバタイプ | SAPにログインする際に使用するパスワード
jco.client.lang.サーバタイプ | SAPにログインする際に使用する言語
jco.client.ashost.サーバタイプ | SAPにログインする際に使用する接続先サーバのIPアドレス（ホスト名）
jco.client.sysnr.サーバタイプ | SAPにログインする際に使用するシステム番号
jco.client.poolsize.サーバタイプ | SAPにログインする際に使用できる、指定したプール内のコネクション数
jco.client.poolname.サーバタイプ | SAPにログインする際に使用する任意のプール名称
jco.client.waittime.サーバタイプ | プール内のコネクションが全て使用中の際に、リリースされたコネクションを取得するために待機する時間(単位:ミリ秒)
jco.client.connectiontimeout.サーバタイプ | プール内で一定時間使用されていないコネクションを自動的にクローズする際の未使用時間(単位:ミリ秒)
jco.client.timeoutcheckperiod.サーバタイプ | プール内で一定時間使用されていないコネクションを自動的にクローズする際に、未使用時間をチェックする間隔(単位:ミリ秒)

Direct Connection (No Load Balancing)
パラメータ名 | 説明
jco.client.client.サーバタイプ | SAPにログインする際に使用するクライアント
jco.client.user.サーバタイプ | SAPにログインする際に使用するユーザ
jco.client.passwd.サーバタイプ | SAPにログインする際に使用するパスワード
jco.client.lang.サーバタイプ | SAPにログインする際に使用する言語
jco.client.ashost.サーバタイプ | SAPにログインする際に使用する接続先サーバのIPアドレス（ホスト名）
jco.client.sysnr.サーバタイプ | SAPにログインする際に使用するシステム番号

Pool Connection (Load Balancing)
パラメータ名 | 説明
jco.client.client.サーバタイプ | SAPにログインする際に使用するクライアント
jco.client.user.サーバタイプ | SAPにログインする際に使用するユーザ
jco.client.passwd.サーバタイプ | SAPにログインする際に使用するパスワード
jco.client.lang.サーバタイプ | SAPにログインする際に使用する言語
jco.client.mshost.サーバタイプ | SAPにログインする際に使用する接続先メッセージサーバIPアドレス（ホスト名）
jco.client.r3name.サーバタイプ | SAPにログインする際に使用するSAP名称
jco.client.group.サーバタイプ | SAPにログインする際に使用するグループID
jco.client.poolsize.サーバタイプ | SAPにログインする際に使用できる、指定したプール内のコネクション数
jco.client.poolname.サーバタイプ | SAPにログインする際に使用する任意のプール名称
jco.client.waittime.サーバタイプ | プール内のコネクションが全て使用中の際に、リリースされたコネクションを取得するために待機する時間(単位:ミリ秒)
jco.client.connectiontimeout.サーバタイプ | プール内で一定時間使用されていないコネクションを自動的にクローズする際の未使用時間(単位:ミリ秒)
jco.client.timeoutcheckperiod.サーバタイプ | プール内で一定時間使用されていないコネクションを自動的にクローズする際に、未使用時間をチェックする間隔(単位:ミリ秒)

Direct Connection (Load Balancing)
パラメータ名 | 説明
jco.client.client.サーバタイプ | SAPにログインする際に使用するクライアント
jco.client.user.サーバタイプ | SAPにログインする際に使用するユーザ
jco.client.passwd.サーバタイプ | SAPにログインする際に使用するパスワード
jco.client.lang.サーバタイプ | SAPにログインする際に使用する言語
jco.client.mshost.サーバタイプ | SAPにログインする際に使用する接続先メッセージサーバIPアドレス（ホスト名）
jco.client.r3name.サーバタイプ | SAPにログインする際に使用するSAP名称
jco.client.group.サーバタイプ | SAPにログインする際に使用するグループID

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
static SapClient | getSapClient() 接続情報初期値を保持したSAPクライアントオブジェクトの取得を行います。
static SapClient | getSapClient(String serverType) 引数にて受け取ったサーバータイプに紐付く接続情報初期値を保持した SAPクライアントオブジェクトを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getSapClient

public static SapClient getSapClient()
                              throws SAPAuthSystemException
接続情報初期値を保持したSAPクライアントオブジェクトの取得を行います。

戻り値:
SapClient SAPクライアントオブジェクト
例外:
SAPAuthSystemException - 認証系システム例外処理

getSapClient

public static SapClient getSapClient(String serverType)
                              throws SAPAuthSystemException
引数にて受け取ったサーバータイプに紐付く接続情報初期値を保持した SAPクライアントオブジェクトを取得します。
また引数にnull値もしくは、空文字("")を設定した場合、 serverTypeが指定されていない接続情報を保持したSAPクライアントオブジェクトを 取得します。

パラメータ:
serverType - サーバータイプ
戻り値:
SapClient SAPクライアントオブジェクト
例外:
SAPAuthSystemException - 認証系システム例外処理
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SapClientNoLoadBalancing (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapClientNoLoadBalancing

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClient
        拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing
public class SapClientNoLoadBalancing
extends SapClient

SapClientNoLoadBalancingクラス。
機能は以下の通り。

  • 非負荷分散環境にて構築されたSAP APサーバーと、 DirectConnection方式を用いた接続を行うクラスです。
  • JCOコネクションの取得に必要なメソッドを用意しています。
本クラスのインスタンスは、SapClientManagerから生成することができます。

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.common.auth.SapClient から継承したフィールド
connection
コンストラクタの概要
protected SapClientNoLoadBalancing(String serverType, String client, String user, String passwd, String lang, String ashost, String sysnr)
引数にて受け取った接続情報を属性にセットします。
メソッドの概要
protected com.sap.mw.jco.JCO.Client | createClient() JCOコネクションの生成を行います。
String | getAshost() 接続先アプリケーションサーバIPアドレスを取得します。
String | getHost() 接続先IPアドレスを取得します。
String | getSysnr() システム番号を取得します。
protected void | releaseConnection() 取得したJCOコネクションの開放を行います。
void | setAshost(String ashost) 接続先アプリケーションサーバIPアドレスを設定します。
void | setSysnr(String sysnr) システム番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.common.auth.SapClient から継承したメソッド
getClient, getIdentifier, getJCOClient, getLang, getPasswd, getServerType, getUser, release, setClient, setLang, setPasswd, setUser
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SapClientNoLoadBalancing

protected SapClientNoLoadBalancing(String serverType,
                                   String client,
                                   String user,
                                   String passwd,
                                   String lang,
                                   String ashost,
                                   String sysnr)
引数にて受け取った接続情報を属性にセットします。

パラメータ:
serverType - サーバータイプ
client - クライアント
user - ユーザー
passwd - パスワード
lang - 言語
ashost - 接続先アプリケーションサーバIPアドレス
sysnr - システム番号
メソッドの詳細

getAshost

public String getAshost()
接続先アプリケーションサーバIPアドレスを取得します。

戻り値:
ashost 設定した接続先アプリケーションサーバIPアドレス

setAshost

public void setAshost(String ashost)
接続先アプリケーションサーバIPアドレスを設定します。

パラメータ:
ashost - 設定する接続先アプリケーションサーバIPアドレス

createClient

protected com.sap.mw.jco.JCO.Client createClient()
                                          throws com.sap.mw.jco.JCO.Exception
JCOコネクションの生成を行います。

定義:
クラス SapClient 内の createClient
戻り値:
JCO.Client JCOコネクション
例外:
JCO.Exception - JCO例外

releaseConnection

protected void releaseConnection()
                          throws com.sap.mw.jco.JCO.Exception
取得したJCOコネクションの開放を行います。

定義:
クラス SapClient 内の releaseConnection
例外:
JCO.Exception - JCO例外

getHost

public String getHost()
接続先IPアドレスを取得します。

定義:
クラス SapClient 内の getHost
戻り値:
String 接続先IPアドレス

getSysnr

public String getSysnr()
システム番号を取得します。

戻り値:
sysnr 設定したシステム番号

setSysnr

public void setSysnr(String sysnr)
システム番号を設定します。

パラメータ:
sysnr - 設定するシステム番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス SapClient 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SapClientPool (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapClientPool

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClient
        拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClientPool
直系の既知のサブクラス:
SapClientPoolNoLoadBalancing, SapClientPoolWithLoadBalancing
public abstract class SapClientPool
extends SapClient

SAPClientPoolクラス。
機能は以下の通り。

  • SAP APサーバーへConnectionPool方式を用いた接続を行うクラスです。
  • JCOコネクションプールの生成に必要な抽象メソッドを用意しています。
  • JCOコネクションプールの接続先の設定は、プロパティファイルからのみ設定できます。
    メソッドで変更することはできません。

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.common.auth.SapClient から継承したフィールド
connection
コンストラクタの概要
protected SapClientPool(String serverType, String client, String user, String passwd, String lang, String poolName, int poolSize, long waitTime, long connectionTimeout, long timeoutCheckPeriod)
引数にて受け取った接続情報を属性にセットします。
メソッドの概要
protected com.sap.mw.jco.JCO.Client | createClient() JCOコネクションの生成を行います。
protected abstract com.sap.mw.jco.JCO.Pool | createPool(SapClientPool sapClientPool) JCOコネクションプールを生成します。
long | getConnectionTimeout() コネクションのタイムアウト時間を取得します。
String | getPoolName() プール名称を取得します。
int | getPoolSize() プール内のコネクション数を取得します。
long | getTimeoutCheckPeriod() コネクションのタイムアウトのチェック間隔を取得します。
long | getWaitTime() コネクション取得の待機時間を取得します。
protected void | releaseConnection() JCOコネクションの開放を行います。
void | setClient(String client) クライアントを設定します。
void | setLang(String lang) 言語を設定します。
void | setPasswd(String passwd) パスワードを設定します。
void | setUser(String user) ユーザーを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.common.auth.SapClient から継承したメソッド
getClient, getHost, getIdentifier, getJCOClient, getLang, getPasswd, getServerType, getUser, release
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SapClientPool

protected SapClientPool(String serverType,
                        String client,
                        String user,
                        String passwd,
                        String lang,
                        String poolName,
                        int poolSize,
                        long waitTime,
                        long connectionTimeout,
                        long timeoutCheckPeriod)
引数にて受け取った接続情報を属性にセットします。

パラメータ:
serverType - サーバータイプ
client - クライアント
user - ユーザー
passwd - パスワード
lang - 言語
poolName - プール名称
poolSize - プール内のコネクション数
waitTime - コネクション取得の待機時間
connectionTimeout - コネクションのタイムアウト
timeoutCheckPeriod - コネクションのタイムアウトのチェック間隔
メソッドの詳細

createClient

protected com.sap.mw.jco.JCO.Client createClient()
                                          throws com.sap.mw.jco.JCO.Exception
JCOコネクションの生成を行います。

定義:
クラス SapClient 内の createClient
戻り値:
JCO.Client JCOコネクション
例外:
JCO.Exception - JCO例外

releaseConnection

protected void releaseConnection()
                          throws com.sap.mw.jco.JCO.Exception
JCOコネクションの開放を行います。

定義:
クラス SapClient 内の releaseConnection
例外:
JCO.Exception - JCO例外

createPool

protected abstract com.sap.mw.jco.JCO.Pool createPool(SapClientPool sapClientPool)
                                               throws com.sap.mw.jco.JCO.Exception
JCOコネクションプールを生成します。

パラメータ:
sapClientPool - SapClientPoolオブジェクト
戻り値:
JCO.Pool JCO.Poolオブジェクト
例外:
JCO.Exception - JCO例外

getConnectionTimeout

public long getConnectionTimeout()
コネクションのタイムアウト時間を取得します。

戻り値:
connectionTimeout 取得したいコネクションのタイムアウト時間

getPoolName

public String getPoolName()
プール名称を取得します。

戻り値:
poolName 設定したプール名称

getPoolSize

public int getPoolSize()
プール内のコネクション数を取得します。

戻り値:
poolSize 設定したプール内のコネクション数

getTimeoutCheckPeriod

public long getTimeoutCheckPeriod()
コネクションのタイムアウトのチェック間隔を取得します。

戻り値:
timeoutCheckPeriod 設定したコネクションのタイムアウトのチェック間隔

getWaitTime

public long getWaitTime()
コネクション取得の待機時間を取得します。

戻り値:
waitTime 設定したコネクション取得の待機時間

setLang

public void setLang(String lang)
言語を設定します。

※本処理は無視されます。

オーバーライド:
クラス SapClient 内の setLang
パラメータ:
lang - 設定する言語

setPasswd

public void setPasswd(String passwd)
パスワードを設定します。

※本処理は無視されます。

オーバーライド:
クラス SapClient 内の setPasswd
パラメータ:
passwd - 設定するパスワード

setUser

public void setUser(String user)
ユーザーを設定します。

※本処理は無視されます。

オーバーライド:
クラス SapClient 内の setUser
パラメータ:
user - 設定するユーザー

setClient

public void setClient(String client)
クライアントを設定します。

※本処理は無視されます。

オーバーライド:
クラス SapClient 内の setClient
パラメータ:
client - 設定するクライアント

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス SapClient 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SapClientPoolManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapClientPoolManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolManager
public class SapClientPoolManager
extends Object

SAPクライアントプールマネージャークラス。
機能は以下の通り。

  • コネクションプール方式を用いて、JCOコネクションを取得します。
  • またコネクションの待機時間、タイムアウト時間、タイムアウトのチェック間隔の
    設定も行います。

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
static void | createPool(SapClientPool sapClientPool) コネクションプール方式を用いて、JCOコネクションの取得を行います。
static boolean | hasPool(String poolName) コネクションプール内に、引数にて渡されたJCOコネクション名が存在しているか判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

createPool

public static void createPool(SapClientPool sapClientPool)
                       throws com.sap.mw.jco.JCO.Exception
コネクションプール方式を用いて、JCOコネクションの取得を行います。

パラメータ:
sapClientPool - SAPクライアントオブジェクト
例外:
JCO.Exception - JCO例外

hasPool

public static boolean hasPool(String poolName)
コネクションプール内に、引数にて渡されたJCOコネクション名が存在しているか判定します。

パラメータ:
poolName - プールされるJCOコネクション名
戻り値:
boolean 判定結果
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SapClientPoolNoLoadBalancing (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapClientPoolNoLoadBalancing

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClient
        拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClientPool
            拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing
public class SapClientPoolNoLoadBalancing
extends SapClientPool

SAPClientPoolクラス。
機能は以下の通り。

  • 非負荷分散環境にて構築されたSAP APサーバーへ
    ConnectionPool方式を用いた接続を行うクラスです。
  • JCOコネクションプールの生成に必要なメソッドを用意しています。
  • JCOコネクションプールの接続先の設定は、プロパティファイルからのみ設定できます。
    メソッドで変更することはできません。
本クラスのインスタンスは、SapClientManagerから生成することができます。

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.common.auth.SapClient から継承したフィールド
connection
コンストラクタの概要
protected SapClientPoolNoLoadBalancing(String serverType, String client, String user, String passwd, String lang, String ashost, String sysnr, String poolName, int poolSize, long waitTime, long connectionTimeout, long timeoutCheckPeriod)
引数にて受け取った接続情報を属性にセットします。
メソッドの概要
protected com.sap.mw.jco.JCO.Pool | createPool(SapClientPool sapClientPool) コネクションプールを生成します。
String | getAshost() 接続先サーバIPアドレスを取得します。
String | getHost() 接続先IPアドレスを取得します。
String | getSysnr() システム番号を取得します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.common.auth.SapClientPool から継承したメソッド
createClient, getConnectionTimeout, getPoolName, getPoolSize, getTimeoutCheckPeriod, getWaitTime, releaseConnection, setClient, setLang, setPasswd, setUser
クラス jp.co.intra_mart.foundation.sap.common.auth.SapClient から継承したメソッド
getClient, getIdentifier, getJCOClient, getLang, getPasswd, getServerType, getUser, release
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SapClientPoolNoLoadBalancing

protected SapClientPoolNoLoadBalancing(String serverType,
                                       String client,
                                       String user,
                                       String passwd,
                                       String lang,
                                       String ashost,
                                       String sysnr,
                                       String poolName,
                                       int poolSize,
                                       long waitTime,
                                       long connectionTimeout,
                                       long timeoutCheckPeriod)
引数にて受け取った接続情報を属性にセットします。

パラメータ:
serverType - サーバータイプ
client - クライアント
user - ユーザー
passwd - パスワード
lang - 言語
ashost - 接続先サーバIPアドレス
sysnr - システム番号
poolName - プール名称
poolSize - プール内のコネクション数
waitTime - コネクション取得の待機時間
connectionTimeout - コネクションのタイムアウト
timeoutCheckPeriod - コネクションのタイムアウトのチェック間隔
メソッドの詳細

createPool

protected com.sap.mw.jco.JCO.Pool createPool(SapClientPool sapClientPool)
                                      throws com.sap.mw.jco.JCO.Exception
コネクションプールを生成します。

定義:
クラス SapClientPool 内の createPool
パラメータ:
sapClientPool - SapClientPoolオブジェクト
戻り値:
Pool Poolオブジェクト
例外:
JCO.Exception - JCO例外

getAshost

public String getAshost()
接続先サーバIPアドレスを取得します。

戻り値:
ashost 設定した接続先サーバIPアドレス

getHost

public String getHost()
接続先IPアドレスを取得します。

定義:
クラス SapClient 内の getHost
戻り値:
host 接続先IPアドレス

getSysnr

public String getSysnr()
システム番号を取得します。

戻り値:
sysnr 設定したシステム番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス SapClientPool 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SapClientPoolWithLoadBalancing (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapClientPoolWithLoadBalancing

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClient
        拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClientPool
            拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing
public class SapClientPoolWithLoadBalancing
extends SapClientPool

SAPClientPoolクラス。
機能は以下の通り。

  • 負荷分散環境にて構築されたSAP APサーバーへ
    ConnectionPool方式を用いた接続を行うクラスです。
  • JCOコネクションプールの生成に必要なメソッドを用意しています。
  • JCOコネクションプールの接続先の設定は、プロパティファイルからのみ設定できます。
    メソッドで変更することはできません。
本クラスのインスタンスは、SapClientManagerから生成することができます。

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.common.auth.SapClient から継承したフィールド
connection
コンストラクタの概要
protected SapClientPoolWithLoadBalancing(String serverType, String client, String user, String passwd, String lang, String mshost, String r3name, String group, String poolName, int poolSize, long waitTime, long connectionTimeout, long timeoutCheckPeriod)
引数にて受け取った接続情報を属性にセットします。
メソッドの概要
protected com.sap.mw.jco.JCO.Pool | createPool(SapClientPool sapClientPool) コネクションプールを生成します。
String | getGroup() グループIDを取得します。
String | getHost() 接続先IPアドレスを取得します。
String | getMshost() 接続先メッセージサーバIPアドレスを取得します。
String | getR3name() SAPシステム名称を取得します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.common.auth.SapClientPool から継承したメソッド
createClient, getConnectionTimeout, getPoolName, getPoolSize, getTimeoutCheckPeriod, getWaitTime, releaseConnection, setClient, setLang, setPasswd, setUser
クラス jp.co.intra_mart.foundation.sap.common.auth.SapClient から継承したメソッド
getClient, getIdentifier, getJCOClient, getLang, getPasswd, getServerType, getUser, release
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SapClientPoolWithLoadBalancing

protected SapClientPoolWithLoadBalancing(String serverType,
                                         String client,
                                         String user,
                                         String passwd,
                                         String lang,
                                         String mshost,
                                         String r3name,
                                         String group,
                                         String poolName,
                                         int poolSize,
                                         long waitTime,
                                         long connectionTimeout,
                                         long timeoutCheckPeriod)
引数にて受け取った接続情報を属性にセットします。

パラメータ:
serverType - サーバータイプ
client - クライアント
user - ユーザー
passwd - パスワード
lang - 言語
mshost - 接続先メッセージサーバIPアドレス
r3name - SAPシステム名称
group - グループID
poolName - プール名称
poolSize - プール内のコネクション数
waitTime - コネクション取得の待機時間
connectionTimeout - コネクションのタイムアウト
timeoutCheckPeriod - コネクションのタイムアウトのチェック間隔
メソッドの詳細

createPool

protected com.sap.mw.jco.JCO.Pool createPool(SapClientPool sapClientPool)
                                      throws com.sap.mw.jco.JCO.Exception
コネクションプールを生成します。

定義:
クラス SapClientPool 内の createPool
パラメータ:
sapClientPool - SapClientPoolオブジェクト
戻り値:
Pool Poolオブジェクト
例外:
JCO.Exception - JCO例外

getMshost

public String getMshost()
接続先メッセージサーバIPアドレスを取得します。

戻り値:
mshome 設定した接続先メッセージサーバIPアドレス

getR3name

public String getR3name()
SAPシステム名称を取得します。

戻り値:
r3name 設定したSAPシステム名称

getGroup

public String getGroup()
グループIDを取得します。

戻り値:
group 設定したグループID

getHost

public String getHost()
接続先IPアドレスを取得します。

定義:
クラス SapClient 内の getHost
戻り値:
接続先IPアドレス

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス SapClientPool 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SapClientWithLoadBalancing (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapClientWithLoadBalancing

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClient
        拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing
public class SapClientWithLoadBalancing
extends SapClient

SAPClientPoolクラス。
機能は以下の通り。

  • 負荷分散環境にて構築されたSAP APサーバーへ
    ConnectionPool方式を用いた接続を行うクラスです。
  • JCOコネクションプールの生成に必要なメソッドを用意しています。
本クラスのインスタンスは、SapClientManagerから生成することができます。

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.common.auth.SapClient から継承したフィールド
connection
コンストラクタの概要
protected SapClientWithLoadBalancing(String serverType, String client, String user, String passwd, String lang, String mshost, String r3name, String group)
引数にて受け取った接続情報を属性にセットします。
メソッドの概要
protected com.sap.mw.jco.JCO.Client | createClient() JCOコネクションの生成を行います。
String | getGroup() グループIDを取得します。
String | getHost() 接続先IPアドレスを取得します。
String | getMshost() 接続先メッセージサーバIPアドレスを取得します。
String | getR3name() SAPシステム名称を取得します。
protected void | releaseConnection() 取得したJCOコネクションの開放を行います。
void | setGroup(String group) グループIDを設定します。
void | setMshost(String mshost) 接続先メッセージサーバIPアドレスを設定します。
void | setR3name(String r3name) SAPシステム名称を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.common.auth.SapClient から継承したメソッド
getClient, getIdentifier, getJCOClient, getLang, getPasswd, getServerType, getUser, release, setClient, setLang, setPasswd, setUser
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SapClientWithLoadBalancing

protected SapClientWithLoadBalancing(String serverType,
                                     String client,
                                     String user,
                                     String passwd,
                                     String lang,
                                     String mshost,
                                     String r3name,
                                     String group)
引数にて受け取った接続情報を属性にセットします。

パラメータ:
serverType - サーバータイプ
client - クライアント
user - ユーザー
passwd - パスワード
lang - 言語
mshost - 接続先メッセージサーバIPアドレス
r3name - SAPシステム名称
group - グループID
メソッドの詳細

getMshost

public String getMshost()
接続先メッセージサーバIPアドレスを取得します。

戻り値:
mshome 設定した接続先メッセージサーバIPアドレス

setMshost

public void setMshost(String mshost)
接続先メッセージサーバIPアドレスを設定します。

パラメータ:
mshost - 設定する接続先メッセージサーバIPアドレス

getR3name

public String getR3name()
SAPシステム名称を取得します。

戻り値:
r3name 設定したSAPシステム名称

setR3name

public void setR3name(String r3name)
SAPシステム名称を設定します。

パラメータ:
r3name - 設定するSAPシステム名称

getGroup

public String getGroup()
グループIDを取得します。

戻り値:
group 設定したグループID

setGroup

public void setGroup(String group)
グループIDを設定します。

パラメータ:
group - 設定するグループID

createClient

protected com.sap.mw.jco.JCO.Client createClient()
                                          throws com.sap.mw.jco.JCO.Exception
JCOコネクションの生成を行います。

定義:
クラス SapClient 内の createClient
戻り値:
JCO.Client JCOコネクション
例外:
JCO.Exception - JCO例外

releaseConnection

protected void releaseConnection()
                          throws com.sap.mw.jco.JCO.Exception
取得したJCOコネクションの開放を行います。

定義:
クラス SapClient 内の releaseConnection
例外:
JCO.Exception - JCO例外

getHost

public String getHost()
接続先IPアドレスを取得します。

定義:
クラス SapClient 内の getHost
戻り値:
host 接続先IPアドレス

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス SapClient 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SapConnector (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapConnector

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapConnector
すべての実装インタフェース:
Serializable
推奨されていません。 本クラスは現在、標準では使用されておりません。
本機能はクラス SapClientManager に置き換えられました。

public class SapConnector
extends Object
implements Serializable

SAPコネクタークラス。
機能は以下の通り。

  • 単一ユーザIDで任意のコネクションプールを作成し、SAPにログインします。
  • 接続先のSAPサーバが複数存在する場合でも、任意のSAPサーバに接続可能です。

関連項目:
直列化された形式

コンストラクタの概要
SapConnector()
推奨されていません。 プロパティファイルを読込み属性に値をセットします。
SapConnector(String serverType)
推奨されていません。 プロパティファイルを読込み属性に値をセットします。
メソッドの概要
String | getAshost() 推奨されていません。 接続先サーバIPアドレスを取得します｡
String | getClient() 推奨されていません。 クライアントを取得します｡
long | getConnectionTimeout() 推奨されていません。 コネクションのタイムアウトを取得します｡
String | getLang() 推奨されていません。 言語を取得します｡
String | getPasswd() 推奨されていません。 パスワードを取得します｡
String | getPoolName() 推奨されていません。 プール名称を取得します｡
int | getPoolSize() 推奨されていません。 プール内のコネクション数を取得します｡
String | getServerType() 推奨されていません。 サーバタイプを取得します｡
String | getSysnr() 推奨されていません。 システム番号を取得します｡
long | getTimeoutCheckPeriod() 推奨されていません。 コネクションのタイムアウトのチェック間隔を取得します｡
String | getUser() 推奨されていません。 ユーザを取得します｡
long | getWaitTime() 推奨されていません。 コネクション取得の待機時間を取得します｡
static void | releaseConnection(com.sap.mw.jco.JCO.Client connection) 推奨されていません。 コネクションをリリースします。
void | setAshost(String ashost) 推奨されていません。 接続先サーバIPアドレスを設定します｡
void | setClient(String client) 推奨されていません。 クライアントを設定します｡
void | setConnectionTimeout(long connectionTimeout) 推奨されていません。 コネクションのタイムアウトを設定します｡
void | setLang(String lang) 推奨されていません。 言語を設定します｡
void | setPasswd(String passwd) 推奨されていません。 パスワードを設定します｡
void | setPoolName(String poolName) 推奨されていません。 プール名称を設定します｡
void | setPoolSize(int poolSize) 推奨されていません。 プール内のコネクション数を設定します｡
void | setServerType(String serverType) 推奨されていません。 サーバタイプを設定します｡
void | setSysnr(String sysnr) 推奨されていません。 システム番号を設定します｡
void | setTimeoutCheckPeriod(long timeoutCheckPeriod) 推奨されていません。 コネクションのタイムアウトのチェック間隔を設定します｡
void | setUser(String user) 推奨されていません。 ユーザを設定します｡
void | setWaitTime(long waitTime) 推奨されていません。 コネクション取得の待機時間を設定します｡
String | toString() 推奨されていません。 デバッグ用のメソッドです。
com.sap.mw.jco.JCO.Client | useConnection() 推奨されていません。 コネクションを生成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SapConnector

public SapConnector()
             throws SAPAuthSystemException
推奨されていません。
プロパティファイルを読込み属性に値をセットします。 接続先が１つの場合に使用します。

例外:
SAPAuthSystemException - 認証系システム例外

SapConnector

public SapConnector(String serverType)
             throws SAPAuthAppException,
                    SAPAuthSystemException
推奨されていません。
プロパティファイルを読込み属性に値をセットします。 接続先が複数の場合に使用します。

パラメータ:
serverType - サーバタイプ
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
メソッドの詳細

setServerType

public void setServerType(String serverType)
推奨されていません。
サーバタイプを設定します｡

パラメータ:
serverType - サーバタイプ

setClient

public void setClient(String client)
推奨されていません。
クライアントを設定します｡

パラメータ:
client - クライアント

setUser

public void setUser(String user)
推奨されていません。
ユーザを設定します｡

パラメータ:
user - ユーザ

setPasswd

public void setPasswd(String passwd)
推奨されていません。
パスワードを設定します｡

パラメータ:
passwd - パスワード

setLang

public void setLang(String lang)
推奨されていません。
言語を設定します｡

パラメータ:
lang - 言語

setSysnr

public void setSysnr(String sysnr)
推奨されていません。
システム番号を設定します｡

パラメータ:
sysnr - システム番号

setAshost

public void setAshost(String ashost)
推奨されていません。
接続先サーバIPアドレスを設定します｡

パラメータ:
ashost - 接続先サーバIPアドレス

setPoolName

public void setPoolName(String poolName)
推奨されていません。
プール名称を設定します｡

パラメータ:
poolName - プール名称

setPoolSize

public void setPoolSize(int poolSize)
推奨されていません。
プール内のコネクション数を設定します｡

パラメータ:
poolSize - プール内のコネクション数

setWaitTime

public void setWaitTime(long waitTime)
推奨されていません。
コネクション取得の待機時間を設定します｡

パラメータ:
waitTime - コネクション取得の待機時間

setConnectionTimeout

public void setConnectionTimeout(long connectionTimeout)
推奨されていません。
コネクションのタイムアウトを設定します｡

パラメータ:
connectionTimeout - コネクションのタイムアウト

setTimeoutCheckPeriod

public void setTimeoutCheckPeriod(long timeoutCheckPeriod)
推奨されていません。
コネクションのタイムアウトのチェック間隔を設定します｡

パラメータ:
timeoutCheckPeriod - コネクションのタイムアウトのチェック間隔

getServerType

public String getServerType()
推奨されていません。
サーバタイプを取得します｡

戻り値:
serverType

getClient

public String getClient()
推奨されていません。
クライアントを取得します｡

戻り値:
client

getUser

public String getUser()
推奨されていません。
ユーザを取得します｡

戻り値:
user

getPasswd

public String getPasswd()
推奨されていません。
パスワードを取得します｡

戻り値:
passwd

getLang

public String getLang()
推奨されていません。
言語を取得します｡

戻り値:
lang

getSysnr

public String getSysnr()
推奨されていません。
システム番号を取得します｡

戻り値:
sysnr

getAshost

public String getAshost()
推奨されていません。
接続先サーバIPアドレスを取得します｡

戻り値:
ashost

getPoolName

public String getPoolName()
推奨されていません。
プール名称を取得します｡

戻り値:
poolName

getPoolSize

public int getPoolSize()
推奨されていません。
プール内のコネクション数を取得します｡

戻り値:
poolSize

getWaitTime

public long getWaitTime()
推奨されていません。
コネクション取得の待機時間を取得します｡

戻り値:
waitTime

getConnectionTimeout

public long getConnectionTimeout()
推奨されていません。
コネクションのタイムアウトを取得します｡

戻り値:
connectionTimeout

getTimeoutCheckPeriod

public long getTimeoutCheckPeriod()
推奨されていません。
コネクションのタイムアウトのチェック間隔を取得します｡

戻り値:
timeoutCheckPeriod

useConnection

public com.sap.mw.jco.JCO.Client useConnection()
                                        throws SAPAuthSystemException
推奨されていません。
コネクションを生成します。

戻り値:
connection
例外:
SAPAuthSystemException - 認証系システム例外

releaseConnection

public static void releaseConnection(com.sap.mw.jco.JCO.Client connection)
                              throws SAPAuthSystemException
推奨されていません。
コネクションをリリースします。

パラメータ:
connection - コネクション
例外:
SAPAuthSystemException - 認証系システム例外

toString

public String toString()
推奨されていません。
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SapRepositoryManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapRepositoryManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager
public class SapRepositoryManager
extends Object

JCO.Repository を管理クラス。

SapClient インスタンスから JCO.Repository を返却するメソッド getJCORepository(SapClient)を提供します。
接続設定ファイルで設定されたPool用の各ServerTypeごとに JCO.Repository を管理します。
ただし、以下の場合は都度、新しい JCO.Repository インスタンスを生成し、本インスタンスは管理しません。

  • 引数がSapClientPool又は、SapClientPoolを継承した子クラスのインスタンスでない場合。

メソッドの概要
static com.sap.mw.jco.JCO.Repository getJCORepository(SapClient sapClient)
Repository情報を生成もしくは、取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getJCORepository

public static com.sap.mw.jco.JCO.Repository getJCORepository(SapClient sapClient)
                                                      throws SAPAuthSystemException
Repository情報を生成もしくは、取得します。
・ConnectionPool方式で且つ、プロパティファイル内に定義された接続情報を使用する場合
    キャッシュ内にRepository情報がある場合は、キャッシュよりRepository情報を取得します。
    キャッシュ内にRepository情報がない場合は、Repository情報を生成します。
・ConnectionPool方式で且つ、プロパティファイル内に定義された接続情報を変更した場合
又は、DirectConnection方式を用いたBapiの実行を行う場合
    Repository情報を生成します。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
戻り値:
JCO.Repository 生成及び、取得したRepository情報
例外:
SAPAuthSystemException - 認証系システム例外処理
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.common.exception.SAPException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.exception.SAPException の使用

SAPException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth.exception | ＳＡＰ連携に関する例外クラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose.exception | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting.exception | ＳＡＰ連携財務会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.exception |
jp.co.intra_mart.foundation.sap.module.financial.exception | ＳＡＰ連携管理会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.exception | ＳＡＰ連携経費購買系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.sales.exception |

jp.co.intra_mart.foundation.sap.common.auth.exception での SAPException の使用

jp.co.intra_mart.foundation.sap.common.auth.exception での SAPException のサブクラス
class | SAPAuthAppException 認証系APIアプリケーション例外クラス
class | SAPAuthSystemException 認証系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.common.general_purpose.exception での SAPException の使用

jp.co.intra_mart.foundation.sap.common.general_purpose.exception での SAPException のサブクラス
class | SAPGeneralAppException 共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
class | SAPGeneralSystemException 共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.accounting.exception での SAPException の使用

jp.co.intra_mart.foundation.sap.module.accounting.exception での SAPException のサブクラス
class | SAPAccountingAppException p 会計系APIアプリケーション例外クラス
class | SAPAccountingSystemException 会計系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.exception での SAPException の使用

jp.co.intra_mart.foundation.sap.module.exception での SAPException のサブクラス
class | SAPBapiReturnErrMessageExistException BAPI実行結果例外クラス
class | SAPModuleAppException モジュール用データ取得・追加・更新APIアプリケーション例外クラス
class | SAPModuleSystemException モジュール用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.financial.exception での SAPException の使用

jp.co.intra_mart.foundation.sap.module.financial.exception での SAPException のサブクラス
class | SAPFinancialAppException 会計系APIアプリケーション例外クラス
class | SAPFinancialSystemException 会計系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.purchase.exception での SAPException の使用

jp.co.intra_mart.foundation.sap.module.purchase.exception での SAPException のサブクラス
class | SAPPurchaseAppException 購買系APIアプリケーション例外クラス
class | SAPPurchaseSystemException 購買系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.sales.exception での SAPException の使用

jp.co.intra_mart.foundation.sap.module.sales.exception での SAPException のサブクラス
class | SAPSalesAppException 販売管理系APIアプリケーション例外クラス
class | SAPSalesSystemException 販売管理系APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.exception.SAPRuntimeException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.exception.SAPRuntimeException の使用

SAPRuntimeException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.exception

jp.co.intra_mart.foundation.sap.common.exception での SAPRuntimeException の使用

jp.co.intra_mart.foundation.sap.common.exception での SAPRuntimeException のサブクラス
 class UnsupportedProductEditionException
SAPリアルタイム連携APIがサポートされていないintra-mart製品で使用された場合にスローされる例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.exception.UnsupportedProductEditionException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.exception.UnsupportedProductEditionException の使用

jp.co.intra_mart.foundation.sap.common.exception.UnsupportedProductEditionException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.common.exception (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.common.exception
例外
SAPException
SAPRuntimeException
UnsupportedProductEditionException


jp.co.intra_mart.foundation.sap.common.exception (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.exception

例外の概要
SAPException | SAP連携モジュールの基本となる例外クラス。
SAPRuntimeException | SAP連携モジュールの基本となるランタイム例外クラス。
UnsupportedProductEditionException | SAPリアルタイム連携APIがサポートされていないintra-mart製品で使用された場合にスローされる例外クラス


jp.co.intra_mart.foundation.sap.common.exception クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.sap.common.exception.SAPRuntimeException
            • class jp.co.intra_mart.foundation.sap.common.exception.UnsupportedProductEditionException
        • class jp.co.intra_mart.foundation.sap.common.exception.SAPException


パッケージ jp.co.intra_mart.foundation.sap.common.exception の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.exception の使用

jp.co.intra_mart.foundation.sap.common.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth.exception | ＳＡＰ連携に関する例外クラスを提供します。
jp.co.intra_mart.foundation.sap.common.exception |
jp.co.intra_mart.foundation.sap.common.general_purpose.exception | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting.exception | ＳＡＰ連携財務会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.exception |
jp.co.intra_mart.foundation.sap.module.financial.exception | ＳＡＰ連携管理会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.exception | ＳＡＰ連携経費購買系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.sales.exception |

jp.co.intra_mart.foundation.sap.common.auth.exception により使用される jp.co.intra_mart.foundation.sap.common.exception のクラス
SAPException
SAP連携モジュールの基本となる例外クラス。

jp.co.intra_mart.foundation.sap.common.exception により使用される jp.co.intra_mart.foundation.sap.common.exception のクラス
SAPRuntimeException
SAP連携モジュールの基本となるランタイム例外クラス。

jp.co.intra_mart.foundation.sap.common.general_purpose.exception により使用される jp.co.intra_mart.foundation.sap.common.exception のクラス
SAPException
SAP連携モジュールの基本となる例外クラス。

jp.co.intra_mart.foundation.sap.module.accounting.exception により使用される jp.co.intra_mart.foundation.sap.common.exception のクラス
SAPException
SAP連携モジュールの基本となる例外クラス。

jp.co.intra_mart.foundation.sap.module.exception により使用される jp.co.intra_mart.foundation.sap.common.exception のクラス
SAPException
SAP連携モジュールの基本となる例外クラス。

jp.co.intra_mart.foundation.sap.module.financial.exception により使用される jp.co.intra_mart.foundation.sap.common.exception のクラス
SAPException
SAP連携モジュールの基本となる例外クラス。

jp.co.intra_mart.foundation.sap.module.purchase.exception により使用される jp.co.intra_mart.foundation.sap.common.exception のクラス
SAPException
SAP連携モジュールの基本となる例外クラス。

jp.co.intra_mart.foundation.sap.module.sales.exception により使用される jp.co.intra_mart.foundation.sap.common.exception のクラス
SAPException
SAP連携モジュールの基本となる例外クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SAPException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.exception
クラス SAPException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
SAPAuthAppException, SAPAuthSystemException, SAPBapiReturnErrMessageExistException, SAPGeneralAppException, SAPGeneralSystemException, SAPModuleAppException, SAPModuleSystemException
public class SAPException
extends Exception

SAP連携モジュールの基本となる例外クラス。

関連項目:
直列化された形式

コンストラクタの概要
SAPException()
SAP連携モジュール基本例外
SAPException(String message)
SAP連携モジュール基本例外
SAPException(String message, Throwable cause)
SAP連携モジュール基本例外
SAPException(Throwable cause)
SAP連携モジュール基本例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPException

public SAPException()
SAP連携モジュール基本例外

SAPException

public SAPException(String message)
SAP連携モジュール基本例外

パラメータ:
message - エラーメッセージ

SAPException

public SAPException(String message,
                    Throwable cause)
SAP連携モジュール基本例外

パラメータ:
message - エラーメッセージ
cause - 原因となる例外

SAPException

public SAPException(Throwable cause)
SAP連携モジュール基本例外

パラメータ:
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPRuntimeException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.exception
クラス SAPRuntimeException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPRuntimeException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
UnsupportedProductEditionException
public class SAPRuntimeException
extends RuntimeException

SAP連携モジュールの基本となるランタイム例外クラス。

関連項目:
直列化された形式

コンストラクタの概要
SAPRuntimeException()
SAP連携モジュール基本ランタイム例外
SAPRuntimeException(String message)
SAP連携モジュール基本ランタイム例外
SAPRuntimeException(String message, Throwable cause)
SAP連携モジュール基本ランタイム例外
SAPRuntimeException(Throwable cause)
SAP連携モジュール基本ランタイム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPRuntimeException

public SAPRuntimeException()
SAP連携モジュール基本ランタイム例外

SAPRuntimeException

public SAPRuntimeException(String message)
SAP連携モジュール基本ランタイム例外

パラメータ:
message - エラーメッセージ

SAPRuntimeException

public SAPRuntimeException(String message,
                           Throwable cause)
SAP連携モジュール基本ランタイム例外

パラメータ:
message - エラーメッセージ
cause - 原因となる例外

SAPRuntimeException

public SAPRuntimeException(Throwable cause)
SAP連携モジュール基本ランタイム例外

パラメータ:
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UnsupportedProductEditionException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.exception
クラス UnsupportedProductEditionException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPRuntimeException
                    拡張 jp.co.intra_mart.foundation.sap.common.exception.UnsupportedProductEditionException
すべての実装インタフェース:
Serializable
public class UnsupportedProductEditionException
extends SAPRuntimeException

SAPリアルタイム連携APIがサポートされていないintra-mart製品で使用された場合にスローされる例外クラス

関連項目:
直列化された形式

コンストラクタの概要
UnsupportedProductEditionException()
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UnsupportedProductEditionException

public UnsupportedProductEditionException()
コンストラクタ。

SAPリアルタイム連携APIがサポートされていないintra-mart製品で 使用された場合にスローされます。
SAPリアルタイム連携APIを利用できるのは、 intra-mart Enterprise版またはデバックサーバ版のみです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController の使用

BapiController を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.financial | ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.common.model |
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems |
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability |
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall |
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica |
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist |
jp.co.intra_mart.foundation.sap.module.sales.common.model |
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus |

jp.co.intra_mart.foundation.sap.module での BapiController の使用

BapiController を返す jp.co.intra_mart.foundation.sap.module のメソッド
protected BapiController | UpdateController.createBapiController(String propertyFileName) 引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。
protected BapiController | AbstractController.createBapiController(String propertyFileName) 引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。

BapiController 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module のメソッド
protected  void AbstractController.executeBapi(BapiController bapiController)
引数で指定された bapiController のexecuteBapiメソッドを実行します。

jp.co.intra_mart.foundation.sap.module.financial での BapiController の使用

BapiController 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.financial のメソッド
void | ProjectGetInfo.setImportParam(BapiController bapiController) WEBの詳細情報を検索する条件ををセットします。
void | ProjectGetInfo.setExportParam(BapiController bapiController) 登録された情報ををセットします。
void | InternalOrderGetList.setImportParam(BapiController bapiController) 内部指図書（一覧）情報を検索する条件ををセットします。
void | InternalOrderGetList.setExportParam(BapiController bapiController) 内部指図書（一覧）情報ををセットします。
void | InternalOrderGetDetail.setImportParam(BapiController bapiController) 内部指図書詳細情報を検索する条件ををセットします。
void | InternalOrderGetDetail.setExportParam(BapiController bapiController) 内部指図書詳細情報ををセットします。
void | ExchangeRateGetDetail.setImportParam(BapiController bapiController) 為替換算レート情報を検索する条件ををセットします。
void | ExchangeRateGetDetail.setExportParam(BapiController bapiController) 為替換算レート情報ををセットします。
void | DebtorGetDetail.setImportParam(BapiController bapiController) 得意先コードの詳細情報を検索する条件ををセットします。
void | DebtorGetDetail.setExportParam(BapiController bapiController) 得意先コードの詳細情報ををセットします。
void | CreditorGetDetail.setImportParam(BapiController bapiController) 仕入先コードの詳細情報を検索する条件ををセットします。
void | CreditorGetDetail.setExportParam(BapiController bapiController) 仕入先コードの詳細情報ををセットします。
void | CommonCenterGrpGetDetail.setImportParam(BapiController bapiController) センタグループを検索する条件ををセットします。
void | CommonCenterGrpGetDetail.setExportParam(BapiController bapiController) センタグループ情報ををセットします。

jp.co.intra_mart.foundation.sap.module.purchase での BapiController の使用

BapiController 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 void PurchaseRelease.executeBapi(BapiController bapiController)
伝票承認取消処理を実行します。
 void PurchaseRelease.setExportParam(BapiController bapiController)
実行結果を取得します。
 void PurchaseOrderPayPost.executeBapi(BapiController bapiController)
購買発注伝票の登録及び変更に共通で使用する項目に値をセットした後、 AbstractController#executeBapi()を実行します。
 void PurchaseOrderPayPost.setImportParam(BapiController bapiController)
伝票に登録する値ををセットします。
 void PurchaseOrderPayPost.setExportParam(BapiController bapiController)
伝票に登録された情報ををセットします。
static void ParamVersions.setImportParam(BapiController bapiController, Versions versions)
バージョン管理に値をセットします。
static void ParamPurchaseSchedule.setImportParam(BapiController bapiController, List purchaseScheduleList)
納入日程に値をセットします。
static void ParamPurchaseAccount.setImportParam(BapiController bapiController, List purchaseAccountList)
勘定設定に値をセットします。
static void ParamProfitSegment.setImportParam(BapiController bapiController, List profitSegmentList)
入出庫予定ヘッダに値をセットします。
static void ParamPartner.setImportParam(BapiController bapiController, List partnerList)
得意先に値をセットします。
static void ParamLimits.setImportParam(BapiController bapiController, List limitsList)
外注制限に値をセットします。
static void ParamItemText.setImportParam(BapiController bapiController, List itemTextList)
明細テキストに値をセットします。
static void ParamHeaderText.setImportParam(BapiController bapiController, List headerTextList)
ヘッダテキストに値をセットします。
static void ParamHeader.setImportParam(BapiController bapiController, PurchaseHeaderPost documentHeader)
伝票ヘッダに値をセットします。
static void ParamHeader.setExportParam(BapiController bapiController, PurchaseHeaderPost documentHeader)
伝票ヘッダに値をセットします。
static void ParamExtension.setImportParam(BapiController bapiController, List extensionList)
拡張得意先項目に値をセットします。
static void ParamExtension.setExportParam(BapiController bapiController, List extensionList)
拡張得意先項目に値をセットします。
static void ParamExportItem.setImportParam(BapiController bapiController, List exportItemList)
貿易管理明細に値をセットします。
static void ParamExportHeader.setImportParam(BapiController bapiController, ExportHeader exportHeader)
貿易管理ヘッダに値をセットします。
static void ParamExportHeader.setExportParam(BapiController bapiController, ExportHeader exportHeader)
貿易管理ヘッダに値をセットします。
static void ParamDeliveryAddress.setImportParam(BapiController bapiController, List deliveryAddressList)
入荷伝票アドレスヘッダに値をセットします。
static void ParamContractServiceText.setImportParam(BapiController bapiController, List contractServiceTextList)
外注サービステキストに値をセットします。
static void ParamContractServiceAccount.setImportParam(BapiController bapiController, List contractServiceAccountList)
外注サービス勘定設定に値をセットします。
static void ParamContractService.setImportParam(BapiController bapiController, List contractServiceList)
外注サービスに値をセットします。
static void ParamContractLimits.setImportParam(BapiController bapiController, List contractLimitsList)
外注基本契約制限に値をセットします。
static void ParamCondItem.setImportParam(BapiController bapiController, List condItemList)
条件明細に値をセットします。
static void ParamCondHeader.setImportParam(BapiController bapiController, List condHeaderList)
条件ヘッダに値をセットします。
static void ParamAllVersions.setExportParam(BapiController bapiController, List allVersionsList)
全バージョンに値をセットします。
 void MaterialGetList.setImportParam(BapiController bapiController)
品目コードを検索する条件ををセットします。
 void MaterialGetList.setExportParam(BapiController bapiController)
伝票に登録された情報ををセットします。

jp.co.intra_mart.foundation.sap.module.purchase.common.model での BapiController の使用

BapiController 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.common.model のメソッド
static void | ParamGoodsMvtItems.setImportParam(BapiController bapiController, List goodsMvtItemsList) リターン構造、入出庫伝票明細に値をセットします。
static void | ParamGoodsMvtItems.setExportParam(BapiController bapiController, List goodsMvtItemsList) table(Export)情報からリターン構造、入出庫伝票明細の値をセットします。
static void | ParamGoodsMvtHeaderList.setImportParam(BapiController bapiController, List goodsMvtHeaderList) リターン構造、入出庫伝票ヘッダに値をセットします。
static void | ParamGoodsMvtHeaderList.setExportParam(BapiController bapiController, List goodsMvtHeaderList) table(Export)情報から入出庫伝票ヘッダデータの値をセットします。
static void | ParamGoodsMvtHeader.setImportParam(BapiController bapiController, GoodsMvtHeader goodsMvtHeader) 入出庫伝票ヘッダデータに値をセットします。
static void | ParamGoodsMvtHeader.setExportParam(BapiController bapiController, List goodsMvtHeaderList) table(Export)情報から入出庫伝票ヘッダデータの値をセットします。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での BapiController の使用

BapiController 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のメソッド
static void | ParamGoodsMvtSerialNumber.setImportParam(BapiController bapiController, List goodsMvtSerialNumberList) シリアル番号の値をセットします。
static void | ParamGoodsMvtSerialNumber.setExportParam(BapiController bapiController, List goodsMvtSerialNumberList) table(Export)情報からシリアル番号の値をセットします。
static void | ParamGoodsMvtItem.setImportParam(BapiController bapiController, List goodsMvtItemList) リターン構造、入出庫伝票明細の値をセットします。
static void | ParamGoodsMvtItem.setExportParam(BapiController bapiController, List goodsMvtItemList) table(Export)情報から返却されたリターン構造、入出庫伝票明細の値をセットします。
static void | ParamGoodsMvtHeadret.setExportParam(BapiController bapiController, GoodsMvtHeadret goodsMvtHeadret) 入出庫伝票ヘッダデータの値をセットします。
static void | ParamGoodsMvtCode.setImportParam(BapiController bapiController, GoodsMvtCode goodsMvtCode) 在庫移動に対するコードのトランザクションへの割当の値をセットします。
void | GoodsMvtCreate.setImportParam(BapiController bapiController) 伝票に登録する値ををセットします。
void | GoodsMvtCreate.setExportParam(BapiController bapiController) 伝票に登録された情報ををセットします。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems での BapiController の使用

BapiController 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems のメソッド
static void | ParamVendorRa.setImportParam(BapiController bapiController, List vendorRaList) 仕入先の範囲の値をセットします。
static void | ParamVendorRa.setExportParam(BapiController bapiController, List vendorRaList) table(Export)情報から仕入先の範囲の値をセットします。
static void | ParamUserNameRa.setImportParam(BapiController bapiController, List userNameRaList) ユーザ名の範囲の値をセットします。
static void | ParamUserNameRa.setExportParam(BapiController bapiController, List userNameRaList) table(Export)情報からユーザ名の範囲の値をセットします。
static void | ParamTrEvTypeRa.setImportParam(BapiController bapiController, List trEvTypeRaList) ParamTrEvTypeRaの値をセットします。
static void | ParamTrEvTypeRa.setExportParam(BapiController bapiController, List trEvTypeRaList) table(Export)情報からトランザクション/イベントタイプの範囲の値をセットします。
static void | ParamStgeLocRa.setImportParam(BapiController bapiController, List stgeLocRaList) 保管場所の範囲の値をセットします。
static void | ParamStgeLocRa.setExportParam(BapiController bapiController, List stgeLocRaList) table(Export)情報から保管場所の範囲の値をセットします。
static void | ParamSpecStockRa.setImportParam(BapiController bapiController, List specStockRaList) 特殊在庫区分の範囲の値をセットします。
static void | ParamSpecStockRa.setExportParam(BapiController bapiController, List specStockRaList) table(Export)情報から特殊在庫区分の範囲の値をセットします。
static void | ParamPstngDateRa.setImportParam(BapiController bapiController, List pstngDateRaList) 登録日付の範囲の値をセットします。
static void | ParamPstngDateRa.setExportParam(BapiController bapiController, List pstngDateRaList) table(Export)情報から登録日付の範囲の値をセットします。
static void | ParamPlantRa.setImportParam(BapiController bapiController, List plantRaList) プラントの範囲の値をセットします。
static void | ParamPlantRa.setExportParam(BapiController bapiController, List plantRaList) table(Export)情報からプラントの範囲の値をセットします。
static void | ParamMoveTypeRa.setImportParam(BapiController bapiController, List moveTypeRaList) 移動タイプの範囲の値をセットします。
static void | ParamMoveTypeRa.setExportParam(BapiController bapiController, List moveTypeRaList) table(Export)情報から移動タイプの範囲の値をセットします。
static void | ParamMaterialRa.setImportParam(BapiController bapiController, List materialRaList) 品目コードの範囲の値をセットします。
static void | ParamMaterialRa.setExportParam(BapiController bapiController, List materialRaList) table(Export)情報から品目コードの範囲の値をセットします。
static void | ParamBatchRa.setImportParam(BapiController bapiController, List batchRaList) ロットの範囲の値をセットします。
static void | ParamBatchRa.setExportParam(BapiController bapiController, List batchRaList) table(Export)情報からロットの範囲の値をセットします。
void | GoodsMvtGetItems.setImportParam(BapiController bapiController) 入出庫伝票一覧照会する情報をセットします。
void | GoodsMvtGetItems.setExportParam(BapiController bapiController) 返却された入出庫伝票照会情報をセットします。

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability での BapiController の使用

BapiController 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialavailability のメソッド
static void | ParamWmdvsx.setImportParam(BapiController bapiController, List wmdvsxList) 入力テーブル (日付/数量)の値をセットします。
static void | ParamWmdvsx.setExportParam(BapiController bapiController, List wmdvsxList) table(Export)情報から入力テーブル (日付/数量)の値をセットします。
static void | ParamWmdvex.setImportParam(BapiController bapiController, List wmdvexList) 出力テーブル (日付および ATP 数量)の値をセットします。
static void | ParamWmdvex.setExportParam(BapiController bapiController, List wmdvexList) table(Export)情報から出力テーブル (日付および ATP 数量)の値をセットします。
void | MaterialAvailability.setImportParam(BapiController bapiController) 品目在庫確認情報を取得する為の条件をセットします。
void | MaterialAvailability.setExportParam(BapiController bapiController) 取得した品目在庫確認情報をセットします。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での BapiController の使用

BapiController 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
void | MaterialGetAll.setImportParam(BapiController bapiController) 品目マスタ照会条件ををセットします。
void | MaterialGetAll.setExportParam(BapiController bapiController) 返却された品目マスタ照会情報をセットします。
void | MaterialGetAll.setImpMaterialDescription(BapiController bapiController) 品目テキストからインポート情報を設定します。
void | MaterialGetAll.setImpUnitSofmeasure(BapiController bapiController) 数量単位からインポート情報を設定します。
void | MaterialGetAll.setImpInternationArticleNumbers(BapiController bapiController) EANからインポート情報を設定します。
void | MaterialGetAll.setImpMaterialText(BapiController bapiController) テキスト (長) からインポート情報を設定します。
void | MaterialGetAll.setImpTaxClassifications(BapiController bapiController) 制御データからインポート情報を設定します。
void | MaterialGetAll.setImpExtensionOut(BapiController bapiController) BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造からインポート情報を 設定します。
void | MaterialGetAll.setExpClientData(BapiController bapiController) structure(Export)情報から品目データ (クライアントレベル) を設定します。
void | MaterialGetAll.setExpPlantData(BapiController bapiController) structure(Export)情報から品目データ (プラントレベル) を設定します。
void | MaterialGetAll.setExpForecastParameters(BapiController bapiController) structure(Export)情報から予測データを設定します。
void | MaterialGetAll.setExpPlanningData(BapiController bapiController) structure(Export)情報から品目マスタ/製品グループの変更伝票構造を設定します。
void | MaterialGetAll.setExpStorageLocationData(BapiController bapiController) structure(Export)情報から品目データ (保管場所レベル)を設定します。
void | MaterialGetAll.setExpValuationData(BapiController bapiController) structure(Export)情報から評価データを設定します。
void | MaterialGetAll.setExpWarehouseNumberData(BapiController bapiController) structure(Export)情報から倉庫番号データを設定します。
void | MaterialGetAll.setExpSalesData(BapiController bapiController) structure(Export)情報から販売データを設定します。
void | MaterialGetAll.setExpStorageTypeData(BapiController bapiController) structure(Export)情報から保管域タイプデータを設定します。
void | MaterialGetAll.setExpProductionResourceToolData(BapiController bapiController) structure(Export)情報から品目マスタの生産資源/治工具 (PRT) 項目を設定します。
void | MaterialGetAll.setExpLifoValuationData(BapiController bapiController) structure(Export)情報からLIFO 関連品目データを設定します。
void | MaterialGetAll.setExpMaterialDescription(BapiController bapiController) table(Export)情報から品目テキストを設定します。
void | MaterialGetAll.setExpUnitSofmeasure(BapiController bapiController) table(Export)情報から数量単位を設定します。
void | MaterialGetAll.setExpInternationArticleNumbers(BapiController bapiController) table(Export)情報からEANを設定します。
void | MaterialGetAll.setExpMaterialText(BapiController bapiController) table(Export)情報からテキスト (長) を設定します。
void | MaterialGetAll.setExpTaxClassifications(BapiController bapiController) table(Export)情報から制御データを設定します。
void | MaterialGetAll.setExpExtensionOut(BapiController bapiController) table(Export)情報からBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造 を設定します。

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica での BapiController の使用

BapiController 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica のメソッド
static void | ParamWarehouseNumberDataList.setTableParam(BapiController bapiController, List warehouseNumberDataList) 倉庫番号データの値をセットします。
static void | ParamWarehouseNumberDataList.setExportParam(BapiController bapiController, List whseNoDataList) table(Export)情報から倉庫番号データを設定します。
static void | ParamValuationDataList.setTableParam(BapiController bapiController, List valuationDataList) 評価データの値をセットします。
static void | ParamValuationDataList.setExportParam(BapiController bapiController, List valuationDataList) table(Export)情報から評価データの値をセットします。
static void | ParamUnplndConsumption.setTableParam(BapiController bapiController, List unplndConsumptionList) 計画外消費のデータ転送の値をセットします。
static void | ParamUnplndConsumption.setExportParam(BapiController bapiController, List unplndConsumptionList) table(Export)情報から計画外消費のデータ転送の値をセットします。
static void | ParamUnitSofmeasure.setTableParam(BapiController bapiController, List unitSofmeasureList) 数量単位の値をセットします。
static void | ParamUnitSofmeasure.setExportParam(BapiController bapiController, List unitSofmeasureList) table(Export)情報から数量単位を設定します。
static void | ParamTotalConsumption.setTableParam(BapiController bapiController, List totalConsumptionList) 品目総消費量のデータ転送の値をセットします。
static void | ParamTotalConsumption.setExportParam(BapiController bapiController, List totalConsumptionList) table(Export)情報から品目総消費量のデータ転送の値をセットします。
static void | ParamTaxClassifications.setTableParam(BapiController bapiController, List taxClassificationsList) 制御デ－タの値をセットします。
static void | ParamTaxClassifications.setExportParam(BapiController bapiController, List taxClassificationsList) table(Export)情報から制御データを設定します。
static void | ParamStorageTypeDataList.setTableParam(BapiController bapiController, List storageTypeDataList) 保管域タイプデータの値をセットします。
static void | ParamStorageTypeDataList.setExportParam(BapiController bapiController, List stgeTypeDataList) table(Export)情報から保管域タイプデータの値をセットします。
static void | ParamStorageLocationDataList.setTableParam(BapiController bapiController, List storageLicationDataList) 品目データ (保管場所レベル)の値をセットします。
static void | ParamStorageLocationDataList.setExportParam(BapiController bapiController, List stgeLocDataList) table(Export)情報から品目データ (保管場所レベル)の値をセットします。
static void | ParamSalesDataList.setTableParam(BapiController bapiController, List salesDataList) 販売データの値をセットします。
static void | ParamSalesDataList.setExportParam(BapiController bapiController, List salesDataList) table(Export)情報から販売データの値をセットします。
static void | ParamReturnMessages.setExportParam(BapiController bapiController, List returnMessages) 品目マスタ更新結果をセットします。
static void | ParamPrtData.setTableParam(BapiController bapiController, List prtDataList) 品目マスタの生産資源/治工具 (PRT) 項目の値をセットします。
static void | ParamPrtData.setExportParam(BapiController bapiController, List prtDataList) table(Export)情報から品目マスタの生産資源/治工具 (PRT) 項目の値を セットします。
static void | ParamPlantDataList.setTableParam(BapiController bapiController, List plantDataList) 品目データ (プラントレベル)の値をセットします。
static void | ParamPlantDataList.setExportParam(BapiController bapiController, List plantDataList) table(Export)情報から品目データ (プラントレベル)の値をセットします。
static void | ParamPlanningDataList.setTableParam(BapiController bapiController, List planningDataList) 品目マスタ/製品グループの変更伝票構造の値をセットします。
static void | ParamPlanningDataList.setExportParam(BapiController bapiController, List planningDataList) table(Export)情報から品目マスタ/製品グループの変更伝票構造の値をセットします。
static void | ParamMaterialLongText.setTableParam(BapiController bapiController, List list) テキスト (長)の値をセットします。
static void | ParamMaterialLongText.setExportParam(BapiController bapiController, List materialLongTextList) table(Export)情報からテキスト (長)の値をセットします。
static void | ParamMaterialDescription.setTableParam(BapiController bapiController, List materialDescriptionList) 品目テキストの値をセットします。
static void | ParamMaterialDescription.setExportParam(BapiController bapiController, List materialDescriptionList) table(Export)情報から品目テキストを設定します。
static void | ParamInternationalArtnos.setTableParam(BapiController bapiController, List internationalArtnosList) 国際商品コード (EAN)の値をセットします。
static void | ParamInternationalArtnos.setExportParam(BapiController bapiController, List internationalArtnosList) table(Export)情報から国際商品コード (EAN)の値をセットします。
static void | ParamHeadData.setTableParam(BapiController bapiController, List headDataList) 管理情報設定ヘッダセグメントの値をセットします。
static void | ParamHeadData.setExportParam(BapiController bapiController, List headDataList) table(Export)情報から管理情報設定ヘッダセグメントの値をセットします。
static void | ParamForecastValues.setTableParam(BapiController bapiController, List forecastValuesList) 需要予測値のデータ転送の値をセットします。
static void | ParamForecastValues.setExportParam(BapiController bapiController, List forecastValuesList) table(Export)情報から需要予測値のデータ転送の値をセットします。
static void | ParamForecastParametersList.setTableParam(BapiController bapiController, List forecastParametersList) 需要予測パラメータの値をセットします。
static void | ParamForecastParametersList.setExportParam(BapiController bapiController, List forecastParametersList) table(Export)情報から需要予測パラメータの値をセットします。
static void | ParamExtensionInX.setTableParam(BapiController bapiController, List extensionInXList) 拡張イン/拡張アウトのチェックボックス構造の値をセットします。
static void | ParamExtensionInX.setExportParam(BapiController bapiController, List extensionInXList) 実行結果の拡張イン/拡張アウトのチェックボックス構造をセットします。
static void | ParamExtensionIn.setTableParam(BapiController bapiController, List extensionInList) BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の値をセットします。
static void | ParamExtensionIn.setExportParam(BapiController bapiController, List extensionInList) table(Export)情報からBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造 の値をセットします。
static void | ParamClientDataList.setTableParam(BapiController bapiController, List clientDataList) 品目データ (クライアントレベル)の値をセットします。
static void | ParamClientDataList.setExportParam(BapiController bapiController, List clientDataList) table(Export)情報から品目データ (クライアントレベル)の値をセットします。
void | MaterialSaveReplica.setImportParam(BapiController bapiController) 品目マスタに登録する値ををセットします。
void | MaterialSaveReplica.setExportParam(BapiController bapiController) 品目マスタに登録する値ををセットします。

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple での BapiController の使用

BapiController 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple のメソッド
static void | ParamTextDataIn.setImportParam(BapiController bapiController, List textDataInList) 請求インタフェースの通信構造テキストの値をセットします。
static void | ParamTextDataIn.setExportParam(BapiController bapiController, List textDataInList) table(Export)情報から請求インタフェースの通信構造テキストの値をセットします。
static void | ParamErrors.setImportParam(BapiController bapiController, List errorsList) 前明細の不正処理に関する情報の値をセットします。
static void | ParamErrors.setExportParam(BapiController bapiController, List errorsList) table(Export)情報から前明細の不正処理に関する情報の値をセットします。
static void | ParamCreatorDataIn.setImportParam(BapiController bapiController, CreatorDataIn creatorDataIn) 取り込まれる日付の順序の値をセットします。
static void | ParamConditionDataIn.setImportParam(BapiController bapiController, List conditionDataInList) 処理予定条件のテーブルの値をセットします。
static void | ParamConditionDataIn.setExportParam(BapiController bapiController, List conditionDataInList) table(Export)情報から処理予定条件のテーブルの値をセットします。
static void | ParamCCardDataIn.setImportParam(BapiController bapiController, List cCardDataInList) 処理予定支払方法のテーブルの値をセットします。
static void | ParamCCardDataIn.setExportParam(BapiController bapiController, List cCardDataInList) table(Export)情報から理予定支払方法のテーブルの値をセットします。
static void | ParamBillingDataIn.setImportParam(BapiController bapiController, List billingDataInList) 処理予定明細データのテーブルの値をセットします。
static void | ParamBillingDataIn.setExportParam(BapiController bapiController, List billingDataInList) table(Export)情報から処理予定明細データのテーブルの値をセットします。
void | BillingDocCreateMultiple.setImportParam(BapiController bapiController) 請求伝票に登録する値ををセットします。
void | BillingDocCreateMultiple.setExportParam(BapiController bapiController) 請求伝票に登録する値ををセットします。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での BapiController の使用

BapiController 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のメソッド
 void BillingDocGetDetail.setExportParam(BapiController bapiController)
返却された請求伝票詳細照会情報をセットします。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist での BapiController の使用

BapiController 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist のメソッド
static void | ParamRefDocRange.setImportParam(BapiController bapiController, RefDocRange refDocRange) 前伝票の範囲の値をセットします。
void | BillingDocGetList.setImportParam(BapiController bapiController) 請求伝票一覧照会情報を、取得する為に必要な情報をセットします。
void | BillingDocGetList.setExportParam(BapiController bapiController) 取得した請求伝票一覧照会情報をセットします。

jp.co.intra_mart.foundation.sap.module.sales.common.model での BapiController の使用

BapiController 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.common.model のメソッド
static void | ParamText.setImportParam(BapiController bapiController, List textList, String paramType) テキストに値をセットします。
static void | ParamText.setExportParam(BapiController bapiController, List textList, String paramType) table(Export)情報からテキストの値をセットします。
static void | ParamSuccess.setImportParam(BapiController bapiController, List successList) 後続請求伝票の明細テーブルに値をセットします。
static void | ParamSuccess.setExportParam(BapiController bapiController, List successList) table(Export)情報から後続請求伝票の明細テーブルの値をセットします。
static void | ParamSender.setImportParam(BapiController bapiController, Sender sender) 論理システム - 送信者に値をセットします。
static void | ParamSchedulesInX.setImportParam(BapiController bapiController, List schedulesInXList, String paramType) 納入日程行チェックボックスに値をセットします。
static void | ParamSchedulesInX.setExportParam(BapiController bapiController, List schedulesInXList, String paramType) table(Export)情報から納入日程行チェックボックスの値をセットします。
static void | ParamSchedulesIn.setImportParam(BapiController bapiController, List schedulesInList, String paramType) 納入日程行に値をセットします。
static void | ParamSchedulesIn.setExportParam(BapiController bapiController, List schedulesInList, String paramType) table(Export)情報から明細データの値をセットします。
static void | ParamPartners.setImportParam(BapiController bapiController, List partnersList, String paramType) 伝票取引先に値をセットします。
static void | ParamPartners.setExportParam(BapiController bapiController, List partnersList, String paramType) table(Export)情報から伝票取引先の値をセットします。
static void | ParamPartnerAddresses.setImportParam(BapiController bapiController, List partnerAddressesList) アドレス (組織/会社) 用 BAPI 参照構造に値をセットします。
static void | ParamPartnerAddresses.setExportParam(BapiController bapiController, List partnerAddressesList) table(Export)情報からアドレス (組織/会社) 用 BAPI 参照構造の値をセットします。
static void | ParamLogicSwitch.setImportParam(BapiController bapiController, LogicSwitch logicSwitch) 内部制御パラメータに値をセットします。
static void | ParamKeys.setImportParam(BapiController bapiController, List keysList, String paramType) 参照キーの出力テーブルに値をセットします。
static void | ParamKeys.setExportParam(BapiController bapiController, List keysList, String paramType) table(Export)情報から参照キーの出力テーブルの値をセットします。
static void | ParamItemsInX.setImportParam(BapiController bapiController, List itemsInXList, String paramType) 明細データに値をセットします。
static void | ParamItemsInX.setExportParam(BapiController bapiController, List itemsInXList, String paramType) table(Export)情報から明細データチェックボックスの値をセットします。
static void | ParamItemsIn.setImportParam(BapiController bapiController, List itemsInList, String paramType) 明細データに値をセットします。
static void | ParamItemsIn.setExportParam(BapiController bapiController, List itemsInList, String paramType) table(Export)情報から明細データの値をセットします。
static void | ParamHeaderInX.setImportParam(BapiController bapiController, HeaderInX headerInX, String paramType) ヘッダデータチェックボックスに値をセットします。
static void | ParamHeaderIn.setImportParam(BapiController bapiController, HeaderIn headerIn, String paramType) 販売伝票ヘッダデータに値をセットします。
static void | ParamExtensionIn.setImportParam(BapiController bapiController, List extensionInList) VBAK、VBAP、VBEP のカスタマ拡張に値をセットします。
static void | ParamExtensionIn.setExportParam(BapiController bapiController, List extensionInList) table(Export)情報からVBAK、VBAP、VBEP のカスタマ拡張の値をセットします。
static void | ParamConditionsInX.setImportParam(BapiController bapiController, List conditionsInXList, String paramType) 受注における条件更新の通信項目に値をセットします。
static void | ParamConditionsInX.setExportParam(BapiController bapiController, List conditionsInXList, String paramType) table(Export)情報から受注における条件更新の通信項目の値をセットします。
static void | ParamConditionsIn.setImportParam(BapiController bapiController, List conditionsInList, String paramType) 条件に値をセットします。
static void | ParamConditionsIn.setExportParam(BapiController bapiController, List conditionsInList, String paramType) table(Export)情報から条件の値をセットします。
static void | ParamCfgsVk.setImportParam(BapiController bapiController, List cfgsVkList, String paramType) 選定: バリアント条件キーに値をセットします。
static void | ParamCfgsVk.setExportParam(BapiController bapiController, List cfgsVkList, String paramType) table(Export)情報から明細データの値をセットします。
static void | ParamCfgsValue.setImportParam(BapiController bapiController, List cfgsValueList, String paramType) 選定: 特性値に値をセットします。
static void | ParamCfgsValue.setExportParam(BapiController bapiController, List cfgsValueList, String paramType) table(Export)情報から選定: 特性値の値をセットします。
static void | ParamCfgsRefInst.setImportParam(BapiController bapiController, List cfgsRefInstList, String paramType) 選定: 参照明細/インスタンスに値をセットします。
static void | ParamCfgsRefInst.setExportParam(BapiController bapiController, List cfgsRefInstList, String paramType) table(Export)情報から選定: 参照明細/インスタンスの値をセットします。
static void | ParamCfgsRef.setImportParam(BapiController bapiController, List cfgsRefList, String paramType) 選定: 参照データに値をセットします。
static void | ParamCfgsRef.setExportParam(BapiController bapiController, List cfgsRefList, String paramType) table(Export)情報から選定: 参照データの値をセットします。
static void | ParamCfgsPartOf.setImportParam(BapiController bapiController, List cfgsPartOfList, String paramType) 選定: 部分設定に値をセットします。
static void | ParamCfgsPartOf.setExportParam(BapiController bapiController, List cfgsPartOfList, String paramType) table(Export)情報から選定: 部分設定の値をセットします。
static void | ParamCfgsInst.setImportParam(BapiController bapiController, List cfgsInstList, String paramType) 選定: インスタンスに値をセットします。
static void | ParamCfgsInst.setExportParam(BapiController bapiController, List cfgsInstList, String paramType) table(Export)情報から選定: インスタンスの値をセットします。
static void | ParamCfgsBlob.setImportParam(BapiController bapiController, List cfgsBlobList, String paramType) 選定: BLOB 内部データ (SCE)に値をセットします。
static void | ParamCfgsBlob.setExportParam(BapiController bapiController, List cfgsBlobList, String paramType) table(Export)情報から選定: BLOB 内部データ (SCE)の値をセットします。
static void | ParamBillingDocumentDetailList.setImportParam(BapiController bapiController, List billingDocumentDetailListList) 請求伝票詳細に値をセットします。
static void | ParamBillingDocumentDetailList.setExportParam(BapiController bapiController, List billingDocumentDetailListList) table(Export)情報から請求伝票詳細の値をセットします。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での BapiController の使用

BapiController 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
void | InquiryCreateFromData2.setImportParam(BapiController bapiController) 引合伝票に登録する値ををセットします。
void | InquiryCreateFromData2.setExportParam(BapiController bapiController) 引合伝票に登録する値ををセットします。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での BapiController の使用

BapiController 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
void | QuotationCreateFromData2.setImportParam(BapiController bapiController) 見積伝票に登録する値ををセットします。
void | QuotationCreateFromData2.setExportParam(BapiController bapiController) 見積伝票に登録する値ををセットします。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での BapiController の使用

BapiController 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
void | SalesOrderCreateFromDat2.setImportParam(BapiController bapiController) 見積伝票に登録する値ををセットします。
void | SalesOrderCreateFromDat2.setExportParam(BapiController bapiController) 見積伝票に登録する値ををセットします。
static void | ParamOrderCcard.setImportParam(BapiController bapiController, List orderCcardList) クレジットカードデータに値をセットします。
static void | ParamOrderCcard.setExportParam(BapiController bapiController, List orderCcardList) table(Export)情報からクレジットカードデータの値をセットします。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist での BapiController の使用

BapiController 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist のメソッド
void | SalesOrderGetList.setImportParam(BapiController bapiController) 販売伝票一覧の検索条件をセットします。
void | SalesOrderGetList.setExportParam(BapiController bapiController) 返却された販売伝票一覧照会情報をセットします。
static void | ParamSalesOrders.setImportParam(BapiController bapiController, List salesOrdersList) 得意先受注テーブル情報の値をセットします。
static void | ParamSalesOrders.setExportParam(BapiController bapiController, List salesOrdersList) table(Export)情報から得意先受注テーブル情報の値をセットします。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus での BapiController の使用

BapiController 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus のメソッド
void | SalesOrderGetStatus.setImportParam(BapiController bapiController) 販売伝票ステータス一覧の検索条件をセットします。
void | SalesOrderGetStatus.setExportParam(BapiController bapiController) 返却された販売伝票ステータス一覧照会情報をセットします。
static void | ParamStatusInfo.setImportParam(BapiController bapiController, List statusInfoList) ステータス情報の値をセットします。
static void | ParamStatusInfo.setExportParam(BapiController bapiController, List statusInfoList) table(Export)情報からステータス情報の値をセットします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash の使用

jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn の使用

BapiReturn を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose ＳＡＰ連携に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.general_purpose での BapiReturn の使用

BapiReturn を返す jp.co.intra_mart.foundation.sap.common.general_purpose のメソッド
 BapiReturn BapiController.getReturn()
ＢＡＰＩ実行結果を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager の使用

ConnectionManager を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica |
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple |
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 |

jp.co.intra_mart.foundation.sap.common.general_purpose での ConnectionManager の使用

ConnectionManager 型のパラメータを持つ jp.co.intra_mart.foundation.sap.common.general_purpose のコンストラクタ
BapiController(String propertyName, ConnectionManager connectionManager)
コネクションマネージャのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録・更新処理を実行することができます。

jp.co.intra_mart.foundation.sap.module での ConnectionManager の使用

ConnectionManager として宣言されている jp.co.intra_mart.foundation.sap.module のフィールド
protected  ConnectionManager UpdateController.connectionManager
コネクション(トランザクション)オブジェクト

ConnectionManager 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module のコンストラクタ
UpdateController(ConnectionManager connectionManager)
コンストラクタ。

jp.co.intra_mart.foundation.sap.module.accounting での ConnectionManager の使用

ConnectionManager 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のコンストラクタ
AccEmployeePayPostController(ConnectionManager connetionManager)
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

ConnectionManagerを使用することで、ConnectionManagerから トランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。

jp.co.intra_mart.foundation.sap.module.purchase での ConnectionManager の使用

ConnectionManager 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase のコンストラクタ
PurchaseResetReleaseController(String purchaseorder, String poRelCode, String useExceptions, ConnectionManager connectionManager)
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。
PurchaseReleaseController(String purchaseorder, String poRelCode, String useExceptions, ConnectionManager connectionManager)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
PurchaseRelease(String purchaseorder, String poRelCode, String useExceptions, ConnectionManager connectionManager)
コンストラクタ生成。
PurchaseOrderPostChangeController(ConnectionManager connectionManager)
PurchaseOrderPostChangeControllerのコンストラクタを生成します。
PurchaseOrderPayPostController(ConnectionManager connectionManager)
PurchaseOrderPayPostControllerのコンストラクタを生成します。
PurchaseOrderPayPost(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。
MaterialSaveReplicaController(ConnectionManager connectionManager)
コンストラクタ生成
GoodsMvtCreateController(ConnectionManager connectionManager)
GoodsMvtCreateControllerのコンストラクタを生成します。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での ConnectionManager の使用

ConnectionManager 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のコンストラクタ
GoodsMvtCreate(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica での ConnectionManager の使用

ConnectionManager 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica のコンストラクタ
MaterialSaveReplica(ConnectionManager connectionManager)
品目マスタ更新情報を作成します。

jp.co.intra_mart.foundation.sap.module.sales での ConnectionManager の使用

ConnectionManager 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales のコンストラクタ
SalesOrderCreateFromDat2Controller(ConnectionManager connectionManager)
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。
QuotationCreateFromData2Controller(ConnectionManager connectionManager)
QuotationCreateFromData2Controllerのコンストラクタを生成します。
InquiryCreateFromData2Controller(ConnectionManager connectionManager)
InquiryCreateFromData2Controllerのコンストラクタを生成します。
BillingDocCreateMultipleController(ConnectionManager connectionManager)
BillingDocCreateMultipleControllerのコンストラクタを生成します。

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple での ConnectionManager の使用

ConnectionManager 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple のコンストラクタ
BillingDocCreateMultiple(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での ConnectionManager の使用

ConnectionManager 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のコンストラクタ
InquiryCreateFromData2(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での ConnectionManager の使用

ConnectionManager 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のコンストラクタ
QuotationCreateFromData2(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での ConnectionManager の使用

ConnectionManager 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のコンストラクタ
SalesOrderCreateFromDat2(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty の使用

jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException の使用

SAPGeneralAppException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.data | ＳＡＰ連携にて使用するデータ変換クラスを提供します。
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial | ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.common.model |
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems |
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability |
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall |
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica |
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist |
jp.co.intra_mart.foundation.sap.module.sales.common.model |
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus |

jp.co.intra_mart.foundation.sap.common.general_purpose での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のメソッド
String | LineProperty.getSeparateKey(int partIndex) 指定された添字に該当するプロパティファイルのキー情報（配列）の要素を 返します。
void | BapiController.putImportParam(String key, String val) 引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="import")を生成し､一覧に格納します｡
void | BapiController.putStructParam(String key, String val, String structName) 引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="structure",パラメタ名=第３引数)を生成し､一覧に格納します｡
void | BapiController.putTableParam(String key, String val, String tableName, int recordNo) 引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="table",パラメタ名=第３引数,レコード番号=第４引数)を生成し､ 一覧に格納します｡
void | BapiController.executeBapi() BAPIを実行します。

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のコンストラクタ
BapiController(String propertyName)
プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡
BapiController(String propertyName, ConnectionManager connectionManager)
コネクションマネージャのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録・更新処理を実行することができます。
BapiController(String propertyName, SapClient sapClient)
サップクライアントのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。

jp.co.intra_mart.foundation.sap.common.util.data での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.common.util.data のメソッド
static String ExtendedParamConverter.changeToUpperParam(String param, String propertyName, String paramType)
入力された項目名をプロパティファイルの項目名に変換します。

jp.co.intra_mart.foundation.sap.module での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module のメソッド
protected BapiController | UpdateController.createBapiController(String propertyFileName) 引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。
protected BapiController | AbstractController.createBapiController(String propertyFileName) 引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。
protected void | AbstractController.executeBapi(BapiController bapiController) 引数で指定された bapiController のexecuteBapiメソッドを実行します。

jp.co.intra_mart.foundation.sap.module.accounting での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void AccEmployeePayPostController.executeBapi()
BapiControllerにより会計伝票を登録します。

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.accounting のコンストラクタ
ProfitCenterList(String controllingArea, String date, SapClient sapClient)
executeBapiを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, SapClient sapClient)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date, SapClient sapClient)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
GlAccList(String companyCode, SapClient sapClient)
executeBapiを呼び出し勘定項目一覧を作成します。
GlAccController(String companyCode)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
GlAccController(String companyCode, SapClient sapClient)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
CostCenterList(String controllingArea, String date, SapClient sapClient)
executeBapiを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date, SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
ControllingAreaList(SapClient sapClient)
executeBapiを呼び出し管理領域一覧を作成します。
ControllingAreaController()
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
ControllingAreaController(SapClient sapClient)
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
CompanyList(SapClient sapClient)
executeBapiを呼び出し会社一覧を作成します。
CompanyController()
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
CompanyController(SapClient sapClient)
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
BusinessAreaList(SapClient sapClient)
executeBapiを呼び出し事業領域一覧を作成します。
BusinessAreaController()
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BusinessAreaController(SapClient sapClient)
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BankList(SapClient sapClient)
executeBapiを呼び出し銀行一覧を作成します。
BankController()
BankListのコンストラクタを呼び出し銀行一覧を作成します。
BankController(SapClient sapClient)
BankListのコンストラクタを呼び出し銀行一覧を作成します。

jp.co.intra_mart.foundation.sap.module.financial での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.financial のメソッド
 void ProjectGetInfoController.executeBapi()
ProjectGetInfoのexecuteBapi()を呼び出しWBSの詳細を取得します。
 void ProjectGetInfo.executeBapi()
BapiControllerによりWBSの詳細情報の検索します。
 void ProjectGetInfo.setImportParam(BapiController bapiController)
WEBの詳細情報を検索する条件ををセットします。
 void ProjectGetInfo.setExportParam(BapiController bapiController)
登録された情報ををセットします。
 void ProfitCenterGrpGetDetailController.executeBapi()
ProfitCenterGrpGetDetailのexecuteBapi()を呼び出し利益センタグループを取得します。
 void ProfitCenterGrpGetDetail.executeBapi()
BapiControllerにより利益センタグループ検索を検索します。
 void InternalOrderGetListController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し内部指図書一覧を取得します。
 void InternalOrderGetList.executeBapi()
BapiControllerにより内部指図書（一覧）情報を検索します。
 void InternalOrderGetList.setImportParam(BapiController bapiController)
内部指図書（一覧）情報を検索する条件ををセットします。
 void InternalOrderGetDetailController.executeBapi()
InternalOrderGetDetailのexecuteBapi()を呼び出し内部指図書詳細を取得します。
 void InternalOrderGetDetail.executeBapi()
BapiControllerにより内部指図書詳細情報を検索します。
 void InternalOrderGetDetail.setImportParam(BapiController bapiController)
内部指図書詳細情報を検索する条件ををセットします。
 void InternalOrderGetDetail.setExportParam(BapiController bapiController)
内部指図書詳細情報ををセットします。
 void ExchangeRateGetDetailController.executeBapi()
ExchangeRateGetDetailのexecuteBapi()を呼び出し為替換算レートを取得します。
 void ExchangeRateGetDetail.executeBapi()
BapiControllerにより為替換算レート情報を検索します。
 void ExchangeRateGetDetail.setImportParam(BapiController bapiController)
為替換算レート情報を検索する条件ををセットします。
 void DebtorGetDetail.executeBapi()
BapiControllerにより得意先コードを検索します。
 void DebtorGetDetail.setImportParam(BapiController bapiController)
得意先コードの詳細情報を検索する条件ををセットします。
 void CreditorGetDetail.executeBapi()
BapiControllerにより仕入先コードを検索します。
 void CreditorGetDetail.setImportParam(BapiController bapiController)
仕入先コードの詳細情報を検索する条件ををセットします。
 void CostCenterGroupGetDetailController.executeBapi()
CostCenterGroupGetDetailのexecuteBapi()を呼び出し原価センタグループを取得します。
 void CostCenterGroupGetDetail.executeBapi()
BapiControllerにより原価センタグループ検索を検索します。
 void CommonCenterGrpGetDetail.setImportParam(BapiController bapiController)
センタグループを検索する条件ををセットします。

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.financial のコンストラクタ
ProfitCenterGrpGetDetailController(String controllingarea, String groupname)
ProfitCenterGrpGetDetailController(String controllingarea, String groupname, SapClient sapClient)
ProfitCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo)
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
InternalOrderGetList(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
InternalOrderGetDetailController(String orderid, String language)
InternalOrderGetDetailController(String orderid, String language, SapClient sapClient)
InternalOrderGetDetail(String orderId, String language, SapClient sapClient)
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date)
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
ExchangeRateGetDetail(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
DebtorGetDetailController(String debtorid, String companycode)
DebtorGetDetailController(String debtorid, String companycode, SapClient sapClient)
DebtorGetDetail(String Debtorid, String Companycode, SapClient sapClient)
CreditorGetDetailController(String creditorid, String companycode)
CreditorGetDetailController(String creditorid, String companycode, SapClient sapClient)
CreditorGetDetail(String creditorid, String companycode, SapClient sapClient)
CostCenterGroupGetDetailController(String controllingarea, String groupname)
CostCenterGroupGetDetailController(String controllingarea, String groupname, SapClient sapClient)
CostCenterGroupGetDetail(String controllingarea, String groupname, SapClient sapClient)
CommonCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)

jp.co.intra_mart.foundation.sap.module.purchase での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 void SupplierGetDetailController.executeBapi()
SupplierDetailのexecuteBapi()を呼び出し仕入先マスタ詳細情報を作成します。
 void SupplierExistenceCheckController.executeBapi()
SupplierExistenceCheckのexecuteBapi()を呼び出し仕入先コード存在チェックを行います。
 void SupplierExistenceCheck.executeBapi()
BapiControllerにより仕入先コード存在チェックを作成します。
 void SupplierDetail.executeBapi()
BapiControllerにより仕入先マスタ詳細を作成します。
 void PurchaseResetReleaseController.executeBapi()
伝票承認取消処理を実行します。
 void PurchaseReleaseController.executeBapi()
伝票承認処理を実行します。
 void PurchaseRelease.executeBapi(BapiController bapiController)
伝票承認取消処理を実行します。
 void PurchaseRelease.setExportParam(BapiController bapiController)
実行結果を取得します。
 void PurchaseOrderPostChangeController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を変更します。
 void PurchaseOrderPayPostController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を登録します。
 void PurchaseOrderPayPost.executeBapi(BapiController bapiController)
購買発注伝票の登録及び変更に共通で使用する項目に値をセットした後、 AbstractController#executeBapi()を実行します。
 void PurchaseOrderPayPost.setImportParam(BapiController bapiController)
伝票に登録する値ををセットします。
 void PurchaseGetItemSrelController.executeBapi()
PurchaseGetItemSrelのexecuteBapi()を呼び出し伝票承認対象一覧を取得します。
 void PurchaseGetItemSrel.executeBapi()
BapiControllerにより仕入先マスタ詳細を作成します。
static void ParamVersions.setImportParam(BapiController bapiController, Versions versions)
バージョン管理に値をセットします。
static void ParamPurchaseSchedule.setImportParam(BapiController bapiController, List purchaseScheduleList)
納入日程に値をセットします。
static void ParamPurchaseAccount.setImportParam(BapiController bapiController, List purchaseAccountList)
勘定設定に値をセットします。
static void ParamProfitSegment.setImportParam(BapiController bapiController, List profitSegmentList)
入出庫予定ヘッダに値をセットします。
static void ParamPartner.setImportParam(BapiController bapiController, List partnerList)
得意先に値をセットします。
static void ParamLimits.setImportParam(BapiController bapiController, List limitsList)
外注制限に値をセットします。
static void ParamItemText.setImportParam(BapiController bapiController, List itemTextList)
明細テキストに値をセットします。
static void ParamHeaderText.setImportParam(BapiController bapiController, List headerTextList)
ヘッダテキストに値をセットします。
static void ParamHeader.setImportParam(BapiController bapiController, PurchaseHeaderPost documentHeader)
伝票ヘッダに値をセットします。
static void ParamExtension.setImportParam(BapiController bapiController, List extensionList)
拡張得意先項目に値をセットします。
static void ParamExportItem.setImportParam(BapiController bapiController, List exportItemList)
貿易管理明細に値をセットします。
static void ParamExportHeader.setImportParam(BapiController bapiController, ExportHeader exportHeader)
貿易管理ヘッダに値をセットします。
static void ParamDeliveryAddress.setImportParam(BapiController bapiController, List deliveryAddressList)
入荷伝票アドレスヘッダに値をセットします。
static void ParamContractServiceText.setImportParam(BapiController bapiController, List contractServiceTextList)
外注サービステキストに値をセットします。
static void ParamContractServiceAccount.setImportParam(BapiController bapiController, List contractServiceAccountList)
外注サービス勘定設定に値をセットします。
static void ParamContractService.setImportParam(BapiController bapiController, List contractServiceList)
外注サービスに値をセットします。
static void ParamContractLimits.setImportParam(BapiController bapiController, List contractLimitsList)
外注基本契約制限に値をセットします。
static void ParamCondItem.setImportParam(BapiController bapiController, List condItemList)
条件明細に値をセットします。
static void ParamCondHeader.setImportParam(BapiController bapiController, List condHeaderList)
条件ヘッダに値をセットします。
 void MaterialSaveReplicaController.executeBapi()
BapiControllerにより品目マスタを更新します。
 void MaterialGetListController.executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し品目コードを検索します。
 void MaterialGetList.setImportParam(BapiController bapiController)
品目コードを検索する条件ををセットします。
 void MaterialGetAllController.executeBapi()
BapiControllerにより品目マスタ照会を行います。
 void MaterialAvailabilityController.executeBapi()
MaterialAvailabilityのexecuteBapi()を呼び出し品目コードを検索します。
 void GoodsMvtGetItemsController.executeBapi()
GoodsMvtGetItemsのexecuteBapi()を呼び出し品目コードを検索します。
 void GoodsMvtCreateController.executeBapi()
GoodsMvtCreateのexecuteBapi()を呼び出し品目コードを検索します。

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.purchase のコンストラクタ
SupplierGetDetailController(String vendor, String compCode)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(String vendor, String compCode, SapClient sapClient)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierExistenceCheckController(String vendor, String compCode)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheckController(String vendor, String compCode, SapClient sapClient)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheck(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先コード存在チェックを作成します。
SupplierDetail(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先マスタ詳細を作成します。
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrel(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
承認対象一覧を作成します。

jp.co.intra_mart.foundation.sap.module.purchase.common.model での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.purchase.common.model のメソッド
static void | ParamGoodsMvtItems.setImportParam(BapiController bapiController, List goodsMvtItemsList) リターン構造、入出庫伝票明細に値をセットします。
static void | ParamGoodsMvtHeaderList.setImportParam(BapiController bapiController, List goodsMvtHeaderList) リターン構造、入出庫伝票ヘッダに値をセットします。
static void | ParamGoodsMvtHeader.setImportParam(BapiController bapiController, GoodsMvtHeader goodsMvtHeader) 入出庫伝票ヘッダデータに値をセットします。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のメソッド
static void | ParamGoodsMvtSerialNumber.setImportParam(BapiController bapiController, List goodsMvtSerialNumberList) シリアル番号の値をセットします。
static void | ParamGoodsMvtItem.setImportParam(BapiController bapiController, List goodsMvtItemList) リターン構造、入出庫伝票明細の値をセットします。
static void | ParamGoodsMvtCode.setImportParam(BapiController bapiController, GoodsMvtCode goodsMvtCode) 在庫移動に対するコードのトランザクションへの割当の値をセットします。
void | GoodsMvtCreate.setImportParam(BapiController bapiController) 伝票に登録する値ををセットします。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems のメソッド
static void | ParamVendorRa.setImportParam(BapiController bapiController, List vendorRaList) 仕入先の範囲の値をセットします。
static void | ParamUserNameRa.setImportParam(BapiController bapiController, List userNameRaList) ユーザ名の範囲の値をセットします。
static void | ParamTrEvTypeRa.setImportParam(BapiController bapiController, List trEvTypeRaList) ParamTrEvTypeRaの値をセットします。
static void | ParamStgeLocRa.setImportParam(BapiController bapiController, List stgeLocRaList) 保管場所の範囲の値をセットします。
static void | ParamSpecStockRa.setImportParam(BapiController bapiController, List specStockRaList) 特殊在庫区分の範囲の値をセットします。
static void | ParamPstngDateRa.setImportParam(BapiController bapiController, List pstngDateRaList) 登録日付の範囲の値をセットします。
static void | ParamPlantRa.setImportParam(BapiController bapiController, List plantRaList) プラントの範囲の値をセットします。
static void | ParamMoveTypeRa.setImportParam(BapiController bapiController, List moveTypeRaList) 移動タイプの範囲の値をセットします。
static void | ParamMaterialRa.setImportParam(BapiController bapiController, List materialRaList) 品目コードの範囲の値をセットします。
static void | ParamBatchRa.setImportParam(BapiController bapiController, List batchRaList) ロットの範囲の値をセットします。
void | GoodsMvtGetItems.setImportParam(BapiController bapiController) 入出庫伝票一覧照会する情報をセットします。

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.purchase.materialavailability のメソッド
static void | ParamWmdvsx.setImportParam(BapiController bapiController, List wmdvsxList) 入力テーブル (日付/数量)の値をセットします。
static void | ParamWmdvex.setImportParam(BapiController bapiController, List wmdvexList) 出力テーブル (日付および ATP 数量)の値をセットします。
void | MaterialAvailability.setImportParam(BapiController bapiController) 品目在庫確認情報を取得する為の条件をセットします。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
void | MaterialGetAll.setImportParam(BapiController bapiController) 品目マスタ照会条件ををセットします。
void | MaterialGetAll.setImpMaterialDescription(BapiController bapiController) 品目テキストからインポート情報を設定します。
void | MaterialGetAll.setImpUnitSofmeasure(BapiController bapiController) 数量単位からインポート情報を設定します。
void | MaterialGetAll.setImpInternationArticleNumbers(BapiController bapiController) EANからインポート情報を設定します。
void | MaterialGetAll.setImpMaterialText(BapiController bapiController) テキスト (長) からインポート情報を設定します。
void | MaterialGetAll.setImpTaxClassifications(BapiController bapiController) 制御データからインポート情報を設定します。
void | MaterialGetAll.setImpExtensionOut(BapiController bapiController) BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造からインポート情報を 設定します。

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica のメソッド
static void | ParamWarehouseNumberDataList.setTableParam(BapiController bapiController, List warehouseNumberDataList) 倉庫番号データの値をセットします。
static void | ParamValuationDataList.setTableParam(BapiController bapiController, List valuationDataList) 評価データの値をセットします。
static void | ParamUnplndConsumption.setTableParam(BapiController bapiController, List unplndConsumptionList) 計画外消費のデータ転送の値をセットします。
static void | ParamUnitSofmeasure.setTableParam(BapiController bapiController, List unitSofmeasureList) 数量単位の値をセットします。
static void | ParamTotalConsumption.setTableParam(BapiController bapiController, List totalConsumptionList) 品目総消費量のデータ転送の値をセットします。
static void | ParamTaxClassifications.setTableParam(BapiController bapiController, List taxClassificationsList) 制御デ－タの値をセットします。
static void | ParamStorageTypeDataList.setTableParam(BapiController bapiController, List storageTypeDataList) 保管域タイプデータの値をセットします。
static void | ParamStorageLocationDataList.setTableParam(BapiController bapiController, List storageLicationDataList) 品目データ (保管場所レベル)の値をセットします。
static void | ParamSalesDataList.setTableParam(BapiController bapiController, List salesDataList) 販売データの値をセットします。
static void | ParamPrtData.setTableParam(BapiController bapiController, List prtDataList) 品目マスタの生産資源/治工具 (PRT) 項目の値をセットします。
static void | ParamPlantDataList.setTableParam(BapiController bapiController, List plantDataList) 品目データ (プラントレベル)の値をセットします。
static void | ParamPlanningDataList.setTableParam(BapiController bapiController, List planningDataList) 品目マスタ/製品グループの変更伝票構造の値をセットします。
static void | ParamMaterialLongText.setTableParam(BapiController bapiController, List list) テキスト (長)の値をセットします。
static void | ParamMaterialDescription.setTableParam(BapiController bapiController, List materialDescriptionList) 品目テキストの値をセットします。
static void | ParamInternationalArtnos.setTableParam(BapiController bapiController, List internationalArtnosList) 国際商品コード (EAN)の値をセットします。
static void | ParamHeadData.setTableParam(BapiController bapiController, List headDataList) 管理情報設定ヘッダセグメントの値をセットします。
static void | ParamForecastValues.setTableParam(BapiController bapiController, List forecastValuesList) 需要予測値のデータ転送の値をセットします。
static void | ParamForecastParametersList.setTableParam(BapiController bapiController, List forecastParametersList) 需要予測パラメータの値をセットします。
static void | ParamExtensionInX.setTableParam(BapiController bapiController, List extensionInXList) 拡張イン/拡張アウトのチェックボックス構造の値をセットします。
static void | ParamExtensionIn.setTableParam(BapiController bapiController, List extensionInList) BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の値をセットします。
static void | ParamClientDataList.setTableParam(BapiController bapiController, List clientDataList) 品目データ (クライアントレベル)の値をセットします。
void | MaterialSaveReplica.setImportParam(BapiController bapiController) 品目マスタに登録する値ををセットします。

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber のコンストラクタ
StdMaterialGetIntNumberList(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
executeBapiを呼び出し品目コード割当済一覧を作成します。

jp.co.intra_mart.foundation.sap.module.sales での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.sales のメソッド
 void SalesOrderGetStatusController.executeBapi()
SalesOrderGetStatusのexecuteBapi()を呼び出し販売伝票ステータス一覧を照会します。
 void SalesOrderGetListController.executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し販売伝票一覧を取得します。
 void SalesOrderCreateFromDat2Controller.executeBapi()
SalesOrderCreateFromDat2のexecuteBapi()を呼び出し販売伝票を登録します。
 void QuotationCreateFromData2Controller.executeBapi()
QuotationCreateFromData2のexecuteBapi()を呼び出し見積伝票を登録します。
 void InquiryCreateFromData2Controller.executeBapi()
InquiryCreateFromData2のexecuteBapi()を呼び出し引合伝票を登録します。
 void BillingDocGetListController.executeBapi()
BillingDocGetListのexecuteBapi()を呼び出し請求伝票一覧を検索します。
 void BillingDocCreateMultipleController.executeBapi()
BillingDocCreateMultipleのexecuteBapi()を呼び出し請求伝票を登録します。

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.sales のコンストラクタ
BillingDocGetDetailController(String billingDocument)
コンストラクタ生成
BillingDocGetDetailController(String billingDocument, SapClient sapClient)
コンストラクタ生成

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple のメソッド
static void | ParamTextDataIn.setImportParam(BapiController bapiController, List textDataInList) 請求インタフェースの通信構造テキストの値をセットします。
static void | ParamErrors.setImportParam(BapiController bapiController, List errorsList) 前明細の不正処理に関する情報の値をセットします。
static void | ParamCreatorDataIn.setImportParam(BapiController bapiController, CreatorDataIn creatorDataIn) 取り込まれる日付の順序の値をセットします。
static void | ParamConditionDataIn.setImportParam(BapiController bapiController, List conditionDataInList) 処理予定条件のテーブルの値をセットします。
static void | ParamCCardDataIn.setImportParam(BapiController bapiController, List cCardDataInList) 処理予定支払方法のテーブルの値をセットします。
static void | ParamBillingDataIn.setImportParam(BapiController bapiController, List billingDataInList) 処理予定明細データのテーブルの値をセットします。
void | BillingDocCreateMultiple.setImportParam(BapiController bapiController) 請求伝票に登録する値ををセットします。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のメソッド
 void BillingDocGetDetail.executeBapi()
BillingDocGetDetailのexecuteBapi()を呼び出し請求伝票を検索します。

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のコンストラクタ
BillingDocGetDetail(String billingdocument, SapClient sapClient)
請求伝票詳細照会情報を作成します。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist のメソッド
static void | ParamRefDocRange.setImportParam(BapiController bapiController, RefDocRange refDocRange) 前伝票の範囲の値をセットします。
void | BillingDocGetList.setImportParam(BapiController bapiController) 請求伝票一覧照会情報を、取得する為に必要な情報をセットします。

jp.co.intra_mart.foundation.sap.module.sales.common.model での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.sales.common.model のメソッド
static void | ParamText.setImportParam(BapiController bapiController, List textList, String paramType) テキストに値をセットします。
static void | ParamSuccess.setImportParam(BapiController bapiController, List successList) 後続請求伝票の明細テーブルに値をセットします。
static void | ParamSender.setImportParam(BapiController bapiController, Sender sender) 論理システム - 送信者に値をセットします。
static void | ParamSchedulesInX.setImportParam(BapiController bapiController, List schedulesInXList, String paramType) 納入日程行チェックボックスに値をセットします。
static void | ParamSchedulesIn.setImportParam(BapiController bapiController, List schedulesInList, String paramType) 納入日程行に値をセットします。
static void | ParamPartners.setImportParam(BapiController bapiController, List partnersList, String paramType) 伝票取引先に値をセットします。
static void | ParamPartnerAddresses.setImportParam(BapiController bapiController, List partnerAddressesList) アドレス (組織/会社) 用 BAPI 参照構造に値をセットします。
static void | ParamLogicSwitch.setImportParam(BapiController bapiController, LogicSwitch logicSwitch) 内部制御パラメータに値をセットします。
static void | ParamKeys.setImportParam(BapiController bapiController, List keysList, String paramType) 参照キーの出力テーブルに値をセットします。
static void | ParamItemsInX.setImportParam(BapiController bapiController, List itemsInXList, String paramType) 明細データに値をセットします。
static void | ParamItemsIn.setImportParam(BapiController bapiController, List itemsInList, String paramType) 明細データに値をセットします。
static void | ParamHeaderInX.setImportParam(BapiController bapiController, HeaderInX headerInX, String paramType) ヘッダデータチェックボックスに値をセットします。
static void | ParamHeaderIn.setImportParam(BapiController bapiController, HeaderIn headerIn, String paramType) 販売伝票ヘッダデータに値をセットします。
static void | ParamExtensionIn.setImportParam(BapiController bapiController, List extensionInList) VBAK、VBAP、VBEP のカスタマ拡張に値をセットします。
static void | ParamConditionsInX.setImportParam(BapiController bapiController, List conditionsInXList, String paramType) 受注における条件更新の通信項目に値をセットします。
static void | ParamConditionsIn.setImportParam(BapiController bapiController, List conditionsInList, String paramType) 条件に値をセットします。
static void | ParamCfgsVk.setImportParam(BapiController bapiController, List cfgsVkList, String paramType) 選定: バリアント条件キーに値をセットします。
static void | ParamCfgsValue.setImportParam(BapiController bapiController, List cfgsValueList, String paramType) 選定: 特性値に値をセットします。
static void | ParamCfgsRefInst.setImportParam(BapiController bapiController, List cfgsRefInstList, String paramType) 選定: 参照明細/インスタンスに値をセットします。
static void | ParamCfgsRef.setImportParam(BapiController bapiController, List cfgsRefList, String paramType) 選定: 参照データに値をセットします。
static void | ParamCfgsPartOf.setImportParam(BapiController bapiController, List cfgsPartOfList, String paramType) 選定: 部分設定に値をセットします。
static void | ParamCfgsInst.setImportParam(BapiController bapiController, List cfgsInstList, String paramType) 選定: インスタンスに値をセットします。
static void | ParamCfgsBlob.setImportParam(BapiController bapiController, List cfgsBlobList, String paramType) 選定: BLOB 内部データ (SCE)に値をセットします。
static void | ParamBillingDocumentDetailList.setImportParam(BapiController bapiController, List billingDocumentDetailListList) 請求伝票詳細に値をセットします。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
 void InquiryCreateFromData2.setImportParam(BapiController bapiController)
引合伝票に登録する値ををセットします。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
 void QuotationCreateFromData2.setImportParam(BapiController bapiController)
見積伝票に登録する値ををセットします。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
void | SalesOrderCreateFromDat2.setImportParam(BapiController bapiController) 見積伝票に登録する値ををセットします。
static void | ParamOrderCcard.setImportParam(BapiController bapiController, List orderCcardList) クレジットカードデータに値をセットします。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist のメソッド
void | SalesOrderGetList.setImportParam(BapiController bapiController) 販売伝票一覧の検索条件をセットします。
static void | ParamSalesOrders.setImportParam(BapiController bapiController, List salesOrdersList) 得意先受注テーブル情報の値をセットします。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus のメソッド
void | SalesOrderGetStatus.setImportParam(BapiController bapiController) 販売伝票ステータス一覧の検索条件をセットします。
static void | ParamStatusInfo.setImportParam(BapiController bapiController, List statusInfoList) ステータス情報の値をセットします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException の使用

SAPGeneralSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.data | ＳＡＰ連携にて使用するデータ変換クラスを提供します。
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial | ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.common.model |
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems |
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability |
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall |
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica |
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist |
jp.co.intra_mart.foundation.sap.module.sales.common.model |
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus |

jp.co.intra_mart.foundation.sap.common.general_purpose での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のメソッド
 void ConnectionManager.commit()
ＢＡＰＩ実行結果のCOMMIT処理を行います｡

実行後にコネクションが開放されます。
 void ConnectionManager.rollback()
ＢＡＰＩ実行結果のROLLBACK処理を行います｡

実行後にコネクションが開放されます。
 void BapiController.putImportParam(String key, String val)
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="import")を生成し､一覧に格納します｡
 void BapiController.putStructParam(String key, String val, String structName)
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="structure",パラメタ名=第３引数)を生成し､一覧に格納します｡
 void BapiController.putTableParam(String key, String val, String tableName, int recordNo)
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="table",パラメタ名=第３引数,レコード番号=第４引数)を生成し､ 一覧に格納します｡
 void BapiController.executeBapi()
BAPIを実行します。
 boolean BapiController.isSuccess()
ＢＡＰＩ実行が正常に行われたか判定します｡

ＢＡＰＩ実行結果であるBapiReturndのType情報が 正常(デフォルト値: "S" / "")であった場合"true"をそれ以外は"false"を返します｡ 正常と判断させる条件はプロパティファイル、 またはBapiController.setIgnoreErrMsgReturnTypes(List)、 BapiController.addIgnoreErrMsgReturnType(String)でカスタマイズできます。
 String BapiController.getErrMessage()
ＢＡＰＩの実行結果のエラーメッセージを取得します。
 String BapiController.getMessage()
設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。
 String BapiController.getMessage(String type)
引数に一致したType情報のメッセージ情報全て取得します。
 String BapiController.getExportParam(String propKey)
export(Export)情報を返します。
 HashMap BapiController.getStructureParam(String paramName)
structure(Export)情報を返します。
 Iterator BapiController.getTableParam(String paramName)
table(Export)情報を返します。
 void BapiController.setAutoCommitConditions(List autoCommitConditions)
推奨されていません。 BapiController.setIgnoreErrMsgReturnTypes(java.util.List)に置き換えられました。
 void BapiController.setIgnoreErrMsgReturnTypes(List ignoreErrMsgReturnTypes)
エラーメッセージを無視するRETURN-TYPEを設定します。

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のコンストラクタ
LineProperty(String propertyKey, String propertyValue)
指定されたプロパティファイルのキー情報と値でLinePropertyオブジェクト を生成します。
BapiReturn(com.sap.mw.jco.JCO.Structure str)
指定されたJCO.Structure情報でBapiReturnを作成します。
BapiReturn(com.sap.mw.jco.JCO.Table tbl)
指定されたJCO.Table情報でBapiReturnを作成します。
BapiController(String propertyName)
プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡
BapiController(String propertyName, ConnectionManager connectionManager)
コネクションマネージャのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録・更新処理を実行することができます。
BapiController(String propertyName, SapClient sapClient)
サップクライアントのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。

jp.co.intra_mart.foundation.sap.common.util.data での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.common.util.data のメソッド
static String | ExtendedParamConverter.changeToUpperParam(String param, String propertyName, String paramType) 入力された項目名をプロパティファイルの項目名に変換します。
static String | Convertor.convJCOdata(int typ, int len, Object val) BAPIパラメータに設定する値でパラメータ属性が"JCO.TYPE_NUM"の場合は 0パディングした文字列を返します。

jp.co.intra_mart.foundation.sap.module での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module のメソッド
protected BapiController | UpdateController.createBapiController(String propertyFileName) 引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。
protected BapiController | AbstractController.createBapiController(String propertyFileName) 引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。
protected void | AbstractController.executeBapi(BapiController bapiController) 引数で指定された bapiController のexecuteBapiメソッドを実行します。

jp.co.intra_mart.foundation.sap.module.accounting での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void AccEmployeePayPostController.executeBapi()
BapiControllerにより会計伝票を登録します。

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.accounting のコンストラクタ
ProfitCenterList(String controllingArea, String date, SapClient sapClient)
executeBapiを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, SapClient sapClient)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date, SapClient sapClient)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
GlAccList(String companyCode, SapClient sapClient)
executeBapiを呼び出し勘定項目一覧を作成します。
GlAccController(String companyCode)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
GlAccController(String companyCode, SapClient sapClient)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
CostCenterList(String controllingArea, String date, SapClient sapClient)
executeBapiを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date, SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
ControllingAreaList(SapClient sapClient)
executeBapiを呼び出し管理領域一覧を作成します。
ControllingAreaController()
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
ControllingAreaController(SapClient sapClient)
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
CompanyList(SapClient sapClient)
executeBapiを呼び出し会社一覧を作成します。
CompanyController()
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
CompanyController(SapClient sapClient)
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
BusinessAreaList(SapClient sapClient)
executeBapiを呼び出し事業領域一覧を作成します。
BusinessAreaController()
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BusinessAreaController(SapClient sapClient)
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BankList(SapClient sapClient)
executeBapiを呼び出し銀行一覧を作成します。
BankController()
BankListのコンストラクタを呼び出し銀行一覧を作成します。
BankController(SapClient sapClient)
BankListのコンストラクタを呼び出し銀行一覧を作成します。

jp.co.intra_mart.foundation.sap.module.financial での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.financial のメソッド
 void ProjectGetInfoController.executeBapi()
ProjectGetInfoのexecuteBapi()を呼び出しWBSの詳細を取得します。
 void ProjectGetInfo.executeBapi()
BapiControllerによりWBSの詳細情報の検索します。
 void ProjectGetInfo.setImportParam(BapiController bapiController)
WEBの詳細情報を検索する条件ををセットします。
 void ProjectGetInfo.setExportParam(BapiController bapiController)
登録された情報ををセットします。
 void ProfitCenterGrpGetDetailController.executeBapi()
ProfitCenterGrpGetDetailのexecuteBapi()を呼び出し利益センタグループを取得します。
 void ProfitCenterGrpGetDetail.executeBapi()
BapiControllerにより利益センタグループ検索を検索します。
 void InternalOrderGetListController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し内部指図書一覧を取得します。
 void InternalOrderGetList.executeBapi()
BapiControllerにより内部指図書（一覧）情報を検索します。
 void InternalOrderGetList.setImportParam(BapiController bapiController)
内部指図書（一覧）情報を検索する条件ををセットします。
 void InternalOrderGetList.setExportParam(BapiController bapiController)
内部指図書（一覧）情報ををセットします。
 void InternalOrderGetDetailController.executeBapi()
InternalOrderGetDetailのexecuteBapi()を呼び出し内部指図書詳細を取得します。
 void InternalOrderGetDetail.executeBapi()
BapiControllerにより内部指図書詳細情報を検索します。
 void InternalOrderGetDetail.setImportParam(BapiController bapiController)
内部指図書詳細情報を検索する条件ををセットします。
 void InternalOrderGetDetail.setExportParam(BapiController bapiController)
内部指図書詳細情報ををセットします。
 void ExchangeRateGetDetailController.executeBapi()
ExchangeRateGetDetailのexecuteBapi()を呼び出し為替換算レートを取得します。
 void ExchangeRateGetDetail.executeBapi()
BapiControllerにより為替換算レート情報を検索します。
 void ExchangeRateGetDetail.setImportParam(BapiController bapiController)
為替換算レート情報を検索する条件ををセットします。
 void ExchangeRateGetDetail.setExportParam(BapiController bapiController)
為替換算レート情報ををセットします。
 void DebtorGetDetail.executeBapi()
BapiControllerにより得意先コードを検索します。
 void DebtorGetDetail.setImportParam(BapiController bapiController)
得意先コードの詳細情報を検索する条件ををセットします。
 void DebtorGetDetail.setExportParam(BapiController bapiController)
得意先コードの詳細情報ををセットします。
 void CreditorGetDetail.executeBapi()
BapiControllerにより仕入先コードを検索します。
 void CreditorGetDetail.setImportParam(BapiController bapiController)
仕入先コードの詳細情報を検索する条件ををセットします。
 void CreditorGetDetail.setExportParam(BapiController bapiController)
仕入先コードの詳細情報ををセットします。
 void CostCenterGroupGetDetailController.executeBapi()
CostCenterGroupGetDetailのexecuteBapi()を呼び出し原価センタグループを取得します。
 void CostCenterGroupGetDetail.executeBapi()
BapiControllerにより原価センタグループ検索を検索します。
 void CommonCenterGrpGetDetail.setImportParam(BapiController bapiController)
センタグループを検索する条件ををセットします。
 void CommonCenterGrpGetDetail.setExportParam(BapiController bapiController)
センタグループ情報ををセットします。

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.financial のコンストラクタ
ProfitCenterGrpGetDetailController(String controllingarea, String groupname)
ProfitCenterGrpGetDetailController(String controllingarea, String groupname, SapClient sapClient)
ProfitCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo)
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
InternalOrderGetList(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
InternalOrderGetDetailController(String orderid, String language)
InternalOrderGetDetailController(String orderid, String language, SapClient sapClient)
InternalOrderGetDetail(String orderId, String language, SapClient sapClient)
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date)
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
ExchangeRateGetDetail(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
DebtorGetDetailController(String debtorid, String companycode)
DebtorGetDetailController(String debtorid, String companycode, SapClient sapClient)
DebtorGetDetail(String Debtorid, String Companycode, SapClient sapClient)
CreditorGetDetailController(String creditorid, String companycode)
CreditorGetDetailController(String creditorid, String companycode, SapClient sapClient)
CreditorGetDetail(String creditorid, String companycode, SapClient sapClient)
CostCenterGroupGetDetailController(String controllingarea, String groupname)
CostCenterGroupGetDetailController(String controllingarea, String groupname, SapClient sapClient)
CostCenterGroupGetDetail(String controllingarea, String groupname, SapClient sapClient)
CommonCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)

jp.co.intra_mart.foundation.sap.module.purchase での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 void SupplierGetDetailController.executeBapi()
SupplierDetailのexecuteBapi()を呼び出し仕入先マスタ詳細情報を作成します。
 void SupplierExistenceCheckController.executeBapi()
SupplierExistenceCheckのexecuteBapi()を呼び出し仕入先コード存在チェックを行います。
 void SupplierExistenceCheck.executeBapi()
BapiControllerにより仕入先コード存在チェックを作成します。
 void SupplierDetail.executeBapi()
BapiControllerにより仕入先マスタ詳細を作成します。
 void PurchaseResetReleaseController.executeBapi()
伝票承認取消処理を実行します。
 void PurchaseReleaseController.executeBapi()
伝票承認処理を実行します。
 void PurchaseRelease.executeBapi(BapiController bapiController)
伝票承認取消処理を実行します。
 void PurchaseRelease.setExportParam(BapiController bapiController)
実行結果を取得します。
 void PurchaseOrderPostChangeController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を変更します。
 void PurchaseOrderPayPostController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を登録します。
 void PurchaseOrderPayPost.executeBapi(BapiController bapiController)
購買発注伝票の登録及び変更に共通で使用する項目に値をセットした後、 AbstractController#executeBapi()を実行します。
 void PurchaseOrderPayPost.setImportParam(BapiController bapiController)
伝票に登録する値ををセットします。
 void PurchaseOrderPayPost.setExportParam(BapiController bapiController)
伝票に登録された情報ををセットします。
 void PurchaseGetItemSrelController.executeBapi()
PurchaseGetItemSrelのexecuteBapi()を呼び出し伝票承認対象一覧を取得します。
 void PurchaseGetItemSrel.executeBapi()
BapiControllerにより仕入先マスタ詳細を作成します。
static void ParamVersions.setImportParam(BapiController bapiController, Versions versions)
バージョン管理に値をセットします。
static void ParamPurchaseSchedule.setImportParam(BapiController bapiController, List purchaseScheduleList)
納入日程に値をセットします。
static void ParamPurchaseAccount.setImportParam(BapiController bapiController, List purchaseAccountList)
勘定設定に値をセットします。
static void ParamProfitSegment.setImportParam(BapiController bapiController, List profitSegmentList)
入出庫予定ヘッダに値をセットします。
static void ParamPartner.setImportParam(BapiController bapiController, List partnerList)
得意先に値をセットします。
static void ParamLimits.setImportParam(BapiController bapiController, List limitsList)
外注制限に値をセットします。
static void ParamItemText.setImportParam(BapiController bapiController, List itemTextList)
明細テキストに値をセットします。
static void ParamHeaderText.setImportParam(BapiController bapiController, List headerTextList)
ヘッダテキストに値をセットします。
static void ParamHeader.setImportParam(BapiController bapiController, PurchaseHeaderPost documentHeader)
伝票ヘッダに値をセットします。
static void ParamHeader.setExportParam(BapiController bapiController, PurchaseHeaderPost documentHeader)
伝票ヘッダに値をセットします。
static void ParamExtension.setImportParam(BapiController bapiController, List extensionList)
拡張得意先項目に値をセットします。
static void ParamExtension.setExportParam(BapiController bapiController, List extensionList)
拡張得意先項目に値をセットします。
static void ParamExportItem.setImportParam(BapiController bapiController, List exportItemList)
貿易管理明細に値をセットします。
static void ParamExportHeader.setImportParam(BapiController bapiController, ExportHeader exportHeader)
貿易管理ヘッダに値をセットします。
static void ParamExportHeader.setExportParam(BapiController bapiController, ExportHeader exportHeader)
貿易管理ヘッダに値をセットします。
static void ParamDeliveryAddress.setImportParam(BapiController bapiController, List deliveryAddressList)
入荷伝票アドレスヘッダに値をセットします。
static void ParamContractServiceText.setImportParam(BapiController bapiController, List contractServiceTextList)
外注サービステキストに値をセットします。
static void ParamContractServiceAccount.setImportParam(BapiController bapiController, List contractServiceAccountList)
外注サービス勘定設定に値をセットします。
static void ParamContractService.setImportParam(BapiController bapiController, List contractServiceList)
外注サービスに値をセットします。
static void ParamContractLimits.setImportParam(BapiController bapiController, List contractLimitsList)
外注基本契約制限に値をセットします。
static void ParamCondItem.setImportParam(BapiController bapiController, List condItemList)
条件明細に値をセットします。
static void ParamCondHeader.setImportParam(BapiController bapiController, List condHeaderList)
条件ヘッダに値をセットします。
static void ParamAllVersions.setExportParam(BapiController bapiController, List allVersionsList)
全バージョンに値をセットします。
 void MaterialSaveReplicaController.executeBapi()
BapiControllerにより品目マスタを更新します。
 void MaterialGetListController.executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し品目コードを検索します。
 void MaterialGetList.setImportParam(BapiController bapiController)
品目コードを検索する条件ををセットします。
 void MaterialGetList.setExportParam(BapiController bapiController)
伝票に登録された情報ををセットします。
 void MaterialGetAllController.executeBapi()
BapiControllerにより品目マスタ照会を行います。
 void MaterialAvailabilityController.executeBapi()
MaterialAvailabilityのexecuteBapi()を呼び出し品目コードを検索します。
 void GoodsMvtGetItemsController.executeBapi()
GoodsMvtGetItemsのexecuteBapi()を呼び出し品目コードを検索します。
 void GoodsMvtCreateController.executeBapi()
GoodsMvtCreateのexecuteBapi()を呼び出し品目コードを検索します。

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.purchase のコンストラクタ
SupplierGetDetailController(String vendor, String compCode)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(String vendor, String compCode, SapClient sapClient)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierExistenceCheckController(String vendor, String compCode)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheckController(String vendor, String compCode, SapClient sapClient)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheck(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先コード存在チェックを作成します。
SupplierDetail(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先マスタ詳細を作成します。
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrel(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
承認対象一覧を作成します。

jp.co.intra_mart.foundation.sap.module.purchase.common.model での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.purchase.common.model のメソッド
static void | ParamGoodsMvtItems.setImportParam(BapiController bapiController, List goodsMvtItemsList) リターン構造、入出庫伝票明細に値をセットします。
static void | ParamGoodsMvtItems.setExportParam(BapiController bapiController, List goodsMvtItemsList) table(Export)情報からリターン構造、入出庫伝票明細の値をセットします。
static void | ParamGoodsMvtHeaderList.setImportParam(BapiController bapiController, List goodsMvtHeaderList) リターン構造、入出庫伝票ヘッダに値をセットします。
static void | ParamGoodsMvtHeaderList.setExportParam(BapiController bapiController, List goodsMvtHeaderList) table(Export)情報から入出庫伝票ヘッダデータの値をセットします。
static void | ParamGoodsMvtHeader.setImportParam(BapiController bapiController, GoodsMvtHeader goodsMvtHeader) 入出庫伝票ヘッダデータに値をセットします。
static void | ParamGoodsMvtHeader.setExportParam(BapiController bapiController, List goodsMvtHeaderList) table(Export)情報から入出庫伝票ヘッダデータの値をセットします。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のメソッド
static void | ParamGoodsMvtSerialNumber.setImportParam(BapiController bapiController, List goodsMvtSerialNumberList) シリアル番号の値をセットします。
static void | ParamGoodsMvtSerialNumber.setExportParam(BapiController bapiController, List goodsMvtSerialNumberList) table(Export)情報からシリアル番号の値をセットします。
static void | ParamGoodsMvtItem.setImportParam(BapiController bapiController, List goodsMvtItemList) リターン構造、入出庫伝票明細の値をセットします。
static void | ParamGoodsMvtItem.setExportParam(BapiController bapiController, List goodsMvtItemList) table(Export)情報から返却されたリターン構造、入出庫伝票明細の値をセットします。
static void | ParamGoodsMvtHeadret.setExportParam(BapiController bapiController, GoodsMvtHeadret goodsMvtHeadret) 入出庫伝票ヘッダデータの値をセットします。
static void | ParamGoodsMvtCode.setImportParam(BapiController bapiController, GoodsMvtCode goodsMvtCode) 在庫移動に対するコードのトランザクションへの割当の値をセットします。
void | GoodsMvtCreate.setImportParam(BapiController bapiController) 伝票に登録する値ををセットします。
void | GoodsMvtCreate.setExportParam(BapiController bapiController) 伝票に登録された情報ををセットします。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems のメソッド
static void | ParamVendorRa.setImportParam(BapiController bapiController, List vendorRaList) 仕入先の範囲の値をセットします。
static void | ParamVendorRa.setExportParam(BapiController bapiController, List vendorRaList) table(Export)情報から仕入先の範囲の値をセットします。
static void | ParamUserNameRa.setImportParam(BapiController bapiController, List userNameRaList) ユーザ名の範囲の値をセットします。
static void | ParamUserNameRa.setExportParam(BapiController bapiController, List userNameRaList) table(Export)情報からユーザ名の範囲の値をセットします。
static void | ParamTrEvTypeRa.setImportParam(BapiController bapiController, List trEvTypeRaList) ParamTrEvTypeRaの値をセットします。
static void | ParamTrEvTypeRa.setExportParam(BapiController bapiController, List trEvTypeRaList) table(Export)情報からトランザクション/イベントタイプの範囲の値をセットします。
static void | ParamStgeLocRa.setImportParam(BapiController bapiController, List stgeLocRaList) 保管場所の範囲の値をセットします。
static void | ParamStgeLocRa.setExportParam(BapiController bapiController, List stgeLocRaList) table(Export)情報から保管場所の範囲の値をセットします。
static void | ParamSpecStockRa.setImportParam(BapiController bapiController, List specStockRaList) 特殊在庫区分の範囲の値をセットします。
static void | ParamSpecStockRa.setExportParam(BapiController bapiController, List specStockRaList) table(Export)情報から特殊在庫区分の範囲の値をセットします。
static void | ParamPstngDateRa.setImportParam(BapiController bapiController, List pstngDateRaList) 登録日付の範囲の値をセットします。
static void | ParamPstngDateRa.setExportParam(BapiController bapiController, List pstngDateRaList) table(Export)情報から登録日付の範囲の値をセットします。
static void | ParamPlantRa.setImportParam(BapiController bapiController, List plantRaList) プラントの範囲の値をセットします。
static void | ParamPlantRa.setExportParam(BapiController bapiController, List plantRaList) table(Export)情報からプラントの範囲の値をセットします。
static void | ParamMoveTypeRa.setImportParam(BapiController bapiController, List moveTypeRaList) 移動タイプの範囲の値をセットします。
static void | ParamMoveTypeRa.setExportParam(BapiController bapiController, List moveTypeRaList) table(Export)情報から移動タイプの範囲の値をセットします。
static void | ParamMaterialRa.setImportParam(BapiController bapiController, List materialRaList) 品目コードの範囲の値をセットします。
static void | ParamMaterialRa.setExportParam(BapiController bapiController, List materialRaList) table(Export)情報から品目コードの範囲の値をセットします。
static void | ParamBatchRa.setImportParam(BapiController bapiController, List batchRaList) ロットの範囲の値をセットします。
static void | ParamBatchRa.setExportParam(BapiController bapiController, List batchRaList) table(Export)情報からロットの範囲の値をセットします。
void | GoodsMvtGetItems.setImportParam(BapiController bapiController) 入出庫伝票一覧照会する情報をセットします。
void | GoodsMvtGetItems.setExportParam(BapiController bapiController) 返却された入出庫伝票照会情報をセットします。

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.purchase.materialavailability のメソッド
static void | ParamWmdvsx.setImportParam(BapiController bapiController, List wmdvsxList) 入力テーブル (日付/数量)の値をセットします。
static void | ParamWmdvsx.setExportParam(BapiController bapiController, List wmdvsxList) table(Export)情報から入力テーブル (日付/数量)の値をセットします。
static void | ParamWmdvex.setImportParam(BapiController bapiController, List wmdvexList) 出力テーブル (日付および ATP 数量)の値をセットします。
static void | ParamWmdvex.setExportParam(BapiController bapiController, List wmdvexList) table(Export)情報から出力テーブル (日付および ATP 数量)の値をセットします。
void | MaterialAvailability.setImportParam(BapiController bapiController) 品目在庫確認情報を取得する為の条件をセットします。
void | MaterialAvailability.setExportParam(BapiController bapiController) 取得した品目在庫確認情報をセットします。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
void | MaterialGetAll.setImportParam(BapiController bapiController) 品目マスタ照会条件ををセットします。
void | MaterialGetAll.setExportParam(BapiController bapiController) 返却された品目マスタ照会情報をセットします。
void | MaterialGetAll.setImpMaterialDescription(BapiController bapiController) 品目テキストからインポート情報を設定します。
void | MaterialGetAll.setImpUnitSofmeasure(BapiController bapiController) 数量単位からインポート情報を設定します。
void | MaterialGetAll.setImpInternationArticleNumbers(BapiController bapiController) EANからインポート情報を設定します。
void | MaterialGetAll.setImpMaterialText(BapiController bapiController) テキスト (長) からインポート情報を設定します。
void | MaterialGetAll.setImpTaxClassifications(BapiController bapiController) 制御データからインポート情報を設定します。
void | MaterialGetAll.setImpExtensionOut(BapiController bapiController) BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造からインポート情報を 設定します。
void | MaterialGetAll.setExpClientData(BapiController bapiController) structure(Export)情報から品目データ (クライアントレベル) を設定します。
void | MaterialGetAll.setExpPlantData(BapiController bapiController) structure(Export)情報から品目データ (プラントレベル) を設定します。
void | MaterialGetAll.setExpForecastParameters(BapiController bapiController) structure(Export)情報から予測データを設定します。
void | MaterialGetAll.setExpPlanningData(BapiController bapiController) structure(Export)情報から品目マスタ/製品グループの変更伝票構造を設定します。
void | MaterialGetAll.setExpStorageLocationData(BapiController bapiController) structure(Export)情報から品目データ (保管場所レベル)を設定します。
void | MaterialGetAll.setExpValuationData(BapiController bapiController) structure(Export)情報から評価データを設定します。
void | MaterialGetAll.setExpWarehouseNumberData(BapiController bapiController) structure(Export)情報から倉庫番号データを設定します。
void | MaterialGetAll.setExpSalesData(BapiController bapiController) structure(Export)情報から販売データを設定します。
void | MaterialGetAll.setExpStorageTypeData(BapiController bapiController) structure(Export)情報から保管域タイプデータを設定します。
void | MaterialGetAll.setExpProductionResourceToolData(BapiController bapiController) structure(Export)情報から品目マスタの生産資源/治工具 (PRT) 項目を設定します。
void | MaterialGetAll.setExpLifoValuationData(BapiController bapiController) structure(Export)情報からLIFO 関連品目データを設定します。
void | MaterialGetAll.setExpMaterialDescription(BapiController bapiController) table(Export)情報から品目テキストを設定します。
void | MaterialGetAll.setExpUnitSofmeasure(BapiController bapiController) table(Export)情報から数量単位を設定します。
void | MaterialGetAll.setExpInternationArticleNumbers(BapiController bapiController) table(Export)情報からEANを設定します。
void | MaterialGetAll.setExpMaterialText(BapiController bapiController) table(Export)情報からテキスト (長) を設定します。
void | MaterialGetAll.setExpTaxClassifications(BapiController bapiController) table(Export)情報から制御データを設定します。
void | MaterialGetAll.setExpExtensionOut(BapiController bapiController) table(Export)情報からBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造 を設定します。

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica のメソッド
static void | ParamWarehouseNumberDataList.setTableParam(BapiController bapiController, List warehouseNumberDataList) 倉庫番号データの値をセットします。
static void | ParamWarehouseNumberDataList.setExportParam(BapiController bapiController, List whseNoDataList) table(Export)情報から倉庫番号データを設定します。
static void | ParamValuationDataList.setTableParam(BapiController bapiController, List valuationDataList) 評価データの値をセットします。
static void | ParamValuationDataList.setExportParam(BapiController bapiController, List valuationDataList) table(Export)情報から評価データの値をセットします。
static void | ParamUnplndConsumption.setTableParam(BapiController bapiController, List unplndConsumptionList) 計画外消費のデータ転送の値をセットします。
static void | ParamUnplndConsumption.setExportParam(BapiController bapiController, List unplndConsumptionList) table(Export)情報から計画外消費のデータ転送の値をセットします。
static void | ParamUnitSofmeasure.setTableParam(BapiController bapiController, List unitSofmeasureList) 数量単位の値をセットします。
static void | ParamUnitSofmeasure.setExportParam(BapiController bapiController, List unitSofmeasureList) table(Export)情報から数量単位を設定します。
static void | ParamTotalConsumption.setTableParam(BapiController bapiController, List totalConsumptionList) 品目総消費量のデータ転送の値をセットします。
static void | ParamTotalConsumption.setExportParam(BapiController bapiController, List totalConsumptionList) table(Export)情報から品目総消費量のデータ転送の値をセットします。
static void | ParamTaxClassifications.setTableParam(BapiController bapiController, List taxClassificationsList) 制御デ－タの値をセットします。
static void | ParamTaxClassifications.setExportParam(BapiController bapiController, List taxClassificationsList) table(Export)情報から制御データを設定します。
static void | ParamStorageTypeDataList.setTableParam(BapiController bapiController, List storageTypeDataList) 保管域タイプデータの値をセットします。
static void | ParamStorageTypeDataList.setExportParam(BapiController bapiController, List stgeTypeDataList) table(Export)情報から保管域タイプデータの値をセットします。
static void | ParamStorageLocationDataList.setTableParam(BapiController bapiController, List storageLicationDataList) 品目データ (保管場所レベル)の値をセットします。
static void | ParamStorageLocationDataList.setExportParam(BapiController bapiController, List stgeLocDataList) table(Export)情報から品目データ (保管場所レベル)の値をセットします。
static void | ParamSalesDataList.setTableParam(BapiController bapiController, List salesDataList) 販売データの値をセットします。
static void | ParamSalesDataList.setExportParam(BapiController bapiController, List salesDataList) table(Export)情報から販売データの値をセットします。
static void | ParamReturnMessages.setExportParam(BapiController bapiController, List returnMessages) 品目マスタ更新結果をセットします。
static void | ParamPrtData.setTableParam(BapiController bapiController, List prtDataList) 品目マスタの生産資源/治工具 (PRT) 項目の値をセットします。
static void | ParamPrtData.setExportParam(BapiController bapiController, List prtDataList) table(Export)情報から品目マスタの生産資源/治工具 (PRT) 項目の値を セットします。
static void | ParamPlantDataList.setTableParam(BapiController bapiController, List plantDataList) 品目データ (プラントレベル)の値をセットします。
static void | ParamPlantDataList.setExportParam(BapiController bapiController, List plantDataList) table(Export)情報から品目データ (プラントレベル)の値をセットします。
static void | ParamPlanningDataList.setTableParam(BapiController bapiController, List planningDataList) 品目マスタ/製品グループの変更伝票構造の値をセットします。
static void | ParamPlanningDataList.setExportParam(BapiController bapiController, List planningDataList) table(Export)情報から品目マスタ/製品グループの変更伝票構造の値をセットします。
static void | ParamMaterialLongText.setTableParam(BapiController bapiController, List list) テキスト (長)の値をセットします。
static void | ParamMaterialLongText.setExportParam(BapiController bapiController, List materialLongTextList) table(Export)情報からテキスト (長)の値をセットします。
static void | ParamMaterialDescription.setTableParam(BapiController bapiController, List materialDescriptionList) 品目テキストの値をセットします。
static void | ParamMaterialDescription.setExportParam(BapiController bapiController, List materialDescriptionList) table(Export)情報から品目テキストを設定します。
static void | ParamInternationalArtnos.setTableParam(BapiController bapiController, List internationalArtnosList) 国際商品コード (EAN)の値をセットします。
static void | ParamInternationalArtnos.setExportParam(BapiController bapiController, List internationalArtnosList) table(Export)情報から国際商品コード (EAN)の値をセットします。
static void | ParamHeadData.setTableParam(BapiController bapiController, List headDataList) 管理情報設定ヘッダセグメントの値をセットします。
static void | ParamHeadData.setExportParam(BapiController bapiController, List headDataList) table(Export)情報から管理情報設定ヘッダセグメントの値をセットします。
static void | ParamForecastValues.setTableParam(BapiController bapiController, List forecastValuesList) 需要予測値のデータ転送の値をセットします。
static void | ParamForecastValues.setExportParam(BapiController bapiController, List forecastValuesList) table(Export)情報から需要予測値のデータ転送の値をセットします。
static void | ParamForecastParametersList.setTableParam(BapiController bapiController, List forecastParametersList) 需要予測パラメータの値をセットします。
static void | ParamForecastParametersList.setExportParam(BapiController bapiController, List forecastParametersList) table(Export)情報から需要予測パラメータの値をセットします。
static void | ParamExtensionInX.setTableParam(BapiController bapiController, List extensionInXList) 拡張イン/拡張アウトのチェックボックス構造の値をセットします。
static void | ParamExtensionInX.setExportParam(BapiController bapiController, List extensionInXList) 実行結果の拡張イン/拡張アウトのチェックボックス構造をセットします。
static void | ParamExtensionIn.setTableParam(BapiController bapiController, List extensionInList) BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の値をセットします。
static void | ParamExtensionIn.setExportParam(BapiController bapiController, List extensionInList) table(Export)情報からBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造 の値をセットします。
static void | ParamClientDataList.setTableParam(BapiController bapiController, List clientDataList) 品目データ (クライアントレベル)の値をセットします。
static void | ParamClientDataList.setExportParam(BapiController bapiController, List clientDataList) table(Export)情報から品目データ (クライアントレベル)の値をセットします。
void | MaterialSaveReplica.setImportParam(BapiController bapiController) 品目マスタに登録する値ををセットします。
void | MaterialSaveReplica.setExportParam(BapiController bapiController) 品目マスタに登録する値ををセットします。

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber のコンストラクタ
StdMaterialGetIntNumberList(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
executeBapiを呼び出し品目コード割当済一覧を作成します。

jp.co.intra_mart.foundation.sap.module.sales での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales のメソッド
 void SalesOrderGetStatusController.executeBapi()
SalesOrderGetStatusのexecuteBapi()を呼び出し販売伝票ステータス一覧を照会します。
 void SalesOrderGetListController.executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し販売伝票一覧を取得します。
 void SalesOrderCreateFromDat2Controller.executeBapi()
SalesOrderCreateFromDat2のexecuteBapi()を呼び出し販売伝票を登録します。
 void QuotationCreateFromData2Controller.executeBapi()
QuotationCreateFromData2のexecuteBapi()を呼び出し見積伝票を登録します。
 void InquiryCreateFromData2Controller.executeBapi()
InquiryCreateFromData2のexecuteBapi()を呼び出し引合伝票を登録します。
 void BillingDocGetListController.executeBapi()
BillingDocGetListのexecuteBapi()を呼び出し請求伝票一覧を検索します。
 void BillingDocCreateMultipleController.executeBapi()
BillingDocCreateMultipleのexecuteBapi()を呼び出し請求伝票を登録します。

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales のコンストラクタ
BillingDocGetDetailController(String billingDocument)
コンストラクタ生成
BillingDocGetDetailController(String billingDocument, SapClient sapClient)
コンストラクタ生成

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple のメソッド
static void | ParamTextDataIn.setImportParam(BapiController bapiController, List textDataInList) 請求インタフェースの通信構造テキストの値をセットします。
static void | ParamTextDataIn.setExportParam(BapiController bapiController, List textDataInList) table(Export)情報から請求インタフェースの通信構造テキストの値をセットします。
static void | ParamErrors.setImportParam(BapiController bapiController, List errorsList) 前明細の不正処理に関する情報の値をセットします。
static void | ParamErrors.setExportParam(BapiController bapiController, List errorsList) table(Export)情報から前明細の不正処理に関する情報の値をセットします。
static void | ParamCreatorDataIn.setImportParam(BapiController bapiController, CreatorDataIn creatorDataIn) 取り込まれる日付の順序の値をセットします。
static void | ParamConditionDataIn.setImportParam(BapiController bapiController, List conditionDataInList) 処理予定条件のテーブルの値をセットします。
static void | ParamConditionDataIn.setExportParam(BapiController bapiController, List conditionDataInList) table(Export)情報から処理予定条件のテーブルの値をセットします。
static void | ParamCCardDataIn.setImportParam(BapiController bapiController, List cCardDataInList) 処理予定支払方法のテーブルの値をセットします。
static void | ParamCCardDataIn.setExportParam(BapiController bapiController, List cCardDataInList) table(Export)情報から理予定支払方法のテーブルの値をセットします。
static void | ParamBillingDataIn.setImportParam(BapiController bapiController, List billingDataInList) 処理予定明細データのテーブルの値をセットします。
static void | ParamBillingDataIn.setExportParam(BapiController bapiController, List billingDataInList) table(Export)情報から処理予定明細データのテーブルの値をセットします。
void | BillingDocCreateMultiple.setImportParam(BapiController bapiController) 請求伝票に登録する値ををセットします。
void | BillingDocCreateMultiple.setExportParam(BapiController bapiController) 請求伝票に登録する値ををセットします。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のメソッド
 void BillingDocGetDetail.executeBapi()
BillingDocGetDetailのexecuteBapi()を呼び出し請求伝票を検索します。
 void BillingDocGetDetail.setExportParam(BapiController bapiController)
返却された請求伝票詳細照会情報をセットします。

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のコンストラクタ
BillingDocGetDetail(String billingdocument, SapClient sapClient)
請求伝票詳細照会情報を作成します。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist のメソッド
static void | ParamRefDocRange.setImportParam(BapiController bapiController, RefDocRange refDocRange) 前伝票の範囲の値をセットします。
void | BillingDocGetList.setImportParam(BapiController bapiController) 請求伝票一覧照会情報を、取得する為に必要な情報をセットします。
void | BillingDocGetList.setExportParam(BapiController bapiController) 取得した請求伝票一覧照会情報をセットします。

jp.co.intra_mart.foundation.sap.module.sales.common.model での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales.common.model のメソッド
static void | ParamText.setImportParam(BapiController bapiController, List textList, String paramType) テキストに値をセットします。
static void | ParamText.setExportParam(BapiController bapiController, List textList, String paramType) table(Export)情報からテキストの値をセットします。
static void | ParamSuccess.setImportParam(BapiController bapiController, List successList) 後続請求伝票の明細テーブルに値をセットします。
static void | ParamSuccess.setExportParam(BapiController bapiController, List successList) table(Export)情報から後続請求伝票の明細テーブルの値をセットします。
static void | ParamSender.setImportParam(BapiController bapiController, Sender sender) 論理システム - 送信者に値をセットします。
static void | ParamSchedulesInX.setImportParam(BapiController bapiController, List schedulesInXList, String paramType) 納入日程行チェックボックスに値をセットします。
static void | ParamSchedulesInX.setExportParam(BapiController bapiController, List schedulesInXList, String paramType) table(Export)情報から納入日程行チェックボックスの値をセットします。
static void | ParamSchedulesIn.setImportParam(BapiController bapiController, List schedulesInList, String paramType) 納入日程行に値をセットします。
static void | ParamSchedulesIn.setExportParam(BapiController bapiController, List schedulesInList, String paramType) table(Export)情報から明細データの値をセットします。
static void | ParamPartners.setImportParam(BapiController bapiController, List partnersList, String paramType) 伝票取引先に値をセットします。
static void | ParamPartners.setExportParam(BapiController bapiController, List partnersList, String paramType) table(Export)情報から伝票取引先の値をセットします。
static void | ParamPartnerAddresses.setImportParam(BapiController bapiController, List partnerAddressesList) アドレス (組織/会社) 用 BAPI 参照構造に値をセットします。
static void | ParamPartnerAddresses.setExportParam(BapiController bapiController, List partnerAddressesList) table(Export)情報からアドレス (組織/会社) 用 BAPI 参照構造の値をセットします。
static void | ParamLogicSwitch.setImportParam(BapiController bapiController, LogicSwitch logicSwitch) 内部制御パラメータに値をセットします。
static void | ParamKeys.setImportParam(BapiController bapiController, List keysList, String paramType) 参照キーの出力テーブルに値をセットします。
static void | ParamKeys.setExportParam(BapiController bapiController, List keysList, String paramType) table(Export)情報から参照キーの出力テーブルの値をセットします。
static void | ParamItemsInX.setImportParam(BapiController bapiController, List itemsInXList, String paramType) 明細データに値をセットします。
static void | ParamItemsInX.setExportParam(BapiController bapiController, List itemsInXList, String paramType) table(Export)情報から明細データチェックボックスの値をセットします。
static void | ParamItemsIn.setImportParam(BapiController bapiController, List itemsInList, String paramType) 明細データに値をセットします。
static void | ParamItemsIn.setExportParam(BapiController bapiController, List itemsInList, String paramType) table(Export)情報から明細データの値をセットします。
static void | ParamHeaderInX.setImportParam(BapiController bapiController, HeaderInX headerInX, String paramType) ヘッダデータチェックボックスに値をセットします。
static void | ParamHeaderIn.setImportParam(BapiController bapiController, HeaderIn headerIn, String paramType) 販売伝票ヘッダデータに値をセットします。
static void | ParamExtensionIn.setImportParam(BapiController bapiController, List extensionInList) VBAK、VBAP、VBEP のカスタマ拡張に値をセットします。
static void | ParamExtensionIn.setExportParam(BapiController bapiController, List extensionInList) table(Export)情報からVBAK、VBAP、VBEP のカスタマ拡張の値をセットします。
static void | ParamConditionsInX.setImportParam(BapiController bapiController, List conditionsInXList, String paramType) 受注における条件更新の通信項目に値をセットします。
static void | ParamConditionsInX.setExportParam(BapiController bapiController, List conditionsInXList, String paramType) table(Export)情報から受注における条件更新の通信項目の値をセットします。
static void | ParamConditionsIn.setImportParam(BapiController bapiController, List conditionsInList, String paramType) 条件に値をセットします。
static void | ParamConditionsIn.setExportParam(BapiController bapiController, List conditionsInList, String paramType) table(Export)情報から条件の値をセットします。
static void | ParamCfgsVk.setImportParam(BapiController bapiController, List cfgsVkList, String paramType) 選定: バリアント条件キーに値をセットします。
static void | ParamCfgsVk.setExportParam(BapiController bapiController, List cfgsVkList, String paramType) table(Export)情報から明細データの値をセットします。
static void | ParamCfgsValue.setImportParam(BapiController bapiController, List cfgsValueList, String paramType) 選定: 特性値に値をセットします。
static void | ParamCfgsValue.setExportParam(BapiController bapiController, List cfgsValueList, String paramType) table(Export)情報から選定: 特性値の値をセットします。
static void | ParamCfgsRefInst.setImportParam(BapiController bapiController, List cfgsRefInstList, String paramType) 選定: 参照明細/インスタンスに値をセットします。
static void | ParamCfgsRefInst.setExportParam(BapiController bapiController, List cfgsRefInstList, String paramType) table(Export)情報から選定: 参照明細/インスタンスの値をセットします。
static void | ParamCfgsRef.setImportParam(BapiController bapiController, List cfgsRefList, String paramType) 選定: 参照データに値をセットします。
static void | ParamCfgsRef.setExportParam(BapiController bapiController, List cfgsRefList, String paramType) table(Export)情報から選定: 参照データの値をセットします。
static void | ParamCfgsPartOf.setImportParam(BapiController bapiController, List cfgsPartOfList, String paramType) 選定: 部分設定に値をセットします。
static void | ParamCfgsPartOf.setExportParam(BapiController bapiController, List cfgsPartOfList, String paramType) table(Export)情報から選定: 部分設定の値をセットします。
static void | ParamCfgsInst.setImportParam(BapiController bapiController, List cfgsInstList, String paramType) 選定: インスタンスに値をセットします。
static void | ParamCfgsInst.setExportParam(BapiController bapiController, List cfgsInstList, String paramType) table(Export)情報から選定: インスタンスの値をセットします。
static void | ParamCfgsBlob.setImportParam(BapiController bapiController, List cfgsBlobList, String paramType) 選定: BLOB 内部データ (SCE)に値をセットします。
static void | ParamCfgsBlob.setExportParam(BapiController bapiController, List cfgsBlobList, String paramType) table(Export)情報から選定: BLOB 内部データ (SCE)の値をセットします。
static void | ParamBillingDocumentDetailList.setImportParam(BapiController bapiController, List billingDocumentDetailListList) 請求伝票詳細に値をセットします。
static void | ParamBillingDocumentDetailList.setExportParam(BapiController bapiController, List billingDocumentDetailListList) table(Export)情報から請求伝票詳細の値をセットします。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
void | InquiryCreateFromData2.setImportParam(BapiController bapiController) 引合伝票に登録する値ををセットします。
void | InquiryCreateFromData2.setExportParam(BapiController bapiController) 引合伝票に登録する値ををセットします。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
void | QuotationCreateFromData2.setImportParam(BapiController bapiController) 見積伝票に登録する値ををセットします。
void | QuotationCreateFromData2.setExportParam(BapiController bapiController) 見積伝票に登録する値ををセットします。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
void | SalesOrderCreateFromDat2.setImportParam(BapiController bapiController) 見積伝票に登録する値ををセットします。
void | SalesOrderCreateFromDat2.setExportParam(BapiController bapiController) 見積伝票に登録する値ををセットします。
static void | ParamOrderCcard.setImportParam(BapiController bapiController, List orderCcardList) クレジットカードデータに値をセットします。
static void | ParamOrderCcard.setExportParam(BapiController bapiController, List orderCcardList) table(Export)情報からクレジットカードデータの値をセットします。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist のメソッド
void | SalesOrderGetList.setImportParam(BapiController bapiController) 販売伝票一覧の検索条件をセットします。
void | SalesOrderGetList.setExportParam(BapiController bapiController) 返却された販売伝票一覧照会情報をセットします。
static void | ParamSalesOrders.setImportParam(BapiController bapiController, List salesOrdersList) 得意先受注テーブル情報の値をセットします。
static void | ParamSalesOrders.setExportParam(BapiController bapiController, List salesOrdersList) table(Export)情報から得意先受注テーブル情報の値をセットします。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus のメソッド
void | SalesOrderGetStatus.setImportParam(BapiController bapiController) 販売伝票ステータス一覧の検索条件をセットします。
void | SalesOrderGetStatus.setExportParam(BapiController bapiController) 返却された販売伝票ステータス一覧照会情報をセットします。
static void | ParamStatusInfo.setImportParam(BapiController bapiController, List statusInfoList) ステータス情報の値をセットします。
static void | ParamStatusInfo.setExportParam(BapiController bapiController, List statusInfoList) table(Export)情報からステータス情報の値をセットします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.common.general_purpose.exception (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.common.general_purpose.exception
例外
SAPGeneralAppException
SAPGeneralSystemException


jp.co.intra_mart.foundation.sap.common.general_purpose.exception (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose.exception

ＳＡＰ連携に関するクラスを提供します。

参照:
説明

例外の概要
SAPGeneralAppException | 共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException | 共通API/汎用データ取得・追加・更新APIシステム例外クラス

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose.exception の説明

ＳＡＰ連携に関するクラスを提供します。


jp.co.intra_mart.foundation.sap.common.general_purpose.exception クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.common.exception.SAPException
          • class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException
          • class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException


パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose.exception の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose.exception の使用

jp.co.intra_mart.foundation.sap.common.general_purpose.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.data | ＳＡＰ連携にて使用するデータ変換クラスを提供します。
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial | ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.common.model |
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems |
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability |
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall |
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica |
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist |
jp.co.intra_mart.foundation.sap.module.sales.common.model |
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus |

jp.co.intra_mart.foundation.sap.common.general_purpose により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.common.util.data により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.accounting により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.financial により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.purchase.common.model により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.sales.common.model により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SAPGeneralAppException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose.exception
クラス SAPGeneralAppException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException
すべての実装インタフェース:
Serializable
public class SAPGeneralAppException
extends SAPException

共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPGeneralAppException(String message)
共通API/汎用データ取得・追加・更新APIアプリケーション例外
SAPGeneralAppException(String message, Throwable ex)
共通API/汎用データ取得・追加・更新APIアプリケーション例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPGeneralAppException

public SAPGeneralAppException(String message,
                              Throwable ex)
共通API/汎用データ取得・追加・更新APIアプリケーション例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPGeneralAppException

public SAPGeneralAppException(String message)
共通API/汎用データ取得・追加・更新APIアプリケーション例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPGeneralSystemException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose.exception
クラス SAPGeneralSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException
すべての実装インタフェース:
Serializable
public class SAPGeneralSystemException
extends SAPException

共通API/汎用データ取得・追加・更新APIシステム例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPGeneralSystemException(String message)
共通API/汎用データ取得・追加・更新APIシステム例外
SAPGeneralSystemException(String message, Throwable ex)
共通API/汎用データ取得・追加・更新APIシステム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPGeneralSystemException

public SAPGeneralSystemException(String message,
                                 Throwable ex)
共通API/汎用データ取得・追加・更新APIシステム例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPGeneralSystemException

public SAPGeneralSystemException(String message)
共通API/汎用データ取得・追加・更新APIシステム例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BapiController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose
クラス BapiController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController
すべての実装インタフェース:
Serializable
public class BapiController
extends Object
implements Serializable

BAPIコントローラクラス。
機能は以下の通り。

  • ソリューション特化型APIにて設定されたBAPI処理実行パラメータを保持し、 BAPI実行時はプロパティファイル設定の内容に従ってJCOパラメータに展開します｡
  • 展開後、BAPI処理を実行し、実行結果を保持する｡ソリューション特化型APIは、 実行結果を当クラスの公開メソッドを使用して取得します｡

バージョン:
1.2
関連項目:
直列化された形式

フィールドの概要
static String[] DEFAULT_IGNORE_ERR_MSG_RETURN_TYPES
エラーメッセージを無視するRETURN-TYPEの設定。
コンストラクタの概要
BapiController(String propertyName)
プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡
BapiController(String propertyName, ConnectionManager connectionManager)
コネクションマネージャのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録・更新処理を実行することができます。
BapiController(String propertyName, SapClient sapClient)
サップクライアントのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。
メソッドの概要
 void addAutoCommitCondition(String autoCommitConditon)
推奨されていません。 addIgnoreErrMsgReturnType(java.lang.String)に置き換えられました。
 void addIgnoreErrMsgReturnType(String ignoreErrMsgReturnType)
エラーメッセージを無視するRETURN-TYPEを追加します。
 void clear()
セットしたパラメータ、ストラクチャ、テーブル、BAPIの実行結果をクリアします。
 void executeBapi()
BAPIを実行します。
 List getAutoCommitConditions()
推奨されていません。 getIgnoreErrMsgReturnTypes()に置き換えられました。
 ArrayList getBapiHashList()
BapiHashの一覧を取得します。
 ArrayList getBapiReturnList()
BapiReturnの一覧を取得します｡
 String getErrMessage()
ＢＡＰＩの実行結果のエラーメッセージを取得します。
 ArrayList getExpExpList()
プロパティ情報(export(Export))の一覧を取得します｡
 String getExportParam(String propKey)
export(Export)情報を返します。
 ArrayList getExpStrList()
プロパティ情報(structure(Export))の一覧を取得します｡
 ArrayList getExpTblList()
プロパティ情報(table(Export))の一覧を取得します｡
 List getIgnoreErrMsgReturnTypes()
エラーメッセージを無視するRETURN-TYPEを取得します。
 ArrayList getImpImpList()
プロパティ情報(import(Import))の一覧を取得します。
 ArrayList getImpStrList()
プロパティ情報(structure(Import))一覧を取得します。
 ArrayList getImpTblList()
プロパティ情報(table(Import))の一覧を取得します｡
 String getMessage()
設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。
 String getMessage(String type)
引数に一致したType情報のメッセージ情報全て取得します。
 Properties getProperty()
プロパティファイル情報を取得します。
 String getPropertyName()
プロパティファイル名を取得します。
 BapiReturn getReturn()
ＢＡＰＩ実行結果を取得します。
 Iterator getReturnCodeTypes()
BapiReturn のType情報を取得します。
 Iterator getReturnList()
ＢＡＰＩ実行結果の一覧を取得します。
 HashMap getStructureParam(String paramName)
structure(Export)情報を返します。
 Iterator getTableParam(String paramName)
table(Export)情報を返します。
 boolean isSuccess()
ＢＡＰＩ実行が正常に行われたか判定します｡

ＢＡＰＩ実行結果であるBapiReturndのType情報が 正常(デフォルト値: "S" / "")であった場合"true"をそれ以外は"false"を返します｡ 正常と判断させる条件はプロパティファイル、 またはsetIgnoreErrMsgReturnTypes(List)、 addIgnoreErrMsgReturnType(String)でカスタマイズできます。
 void putImportParam(String key, String val)
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="import")を生成し､一覧に格納します｡
 void putStructParam(String key, String val, String structName)
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="structure",パラメタ名=第３引数)を生成し､一覧に格納します｡
 void putTableParam(String key, String val, String tableName, int recordNo)
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="table",パラメタ名=第３引数,レコード番号=第４引数)を生成し､ 一覧に格納します｡
 void setAutoCommitConditions(List autoCommitConditions)
推奨されていません。 setIgnoreErrMsgReturnTypes(java.util.List)に置き換えられました。
 void setBapiHashList(ArrayList bapiHashList)
BapiHashの一覧を設定します｡
 void setBapiReturnList(ArrayList bapiReturnList)
BapiReturnの一覧を設定します｡
 void setExpExpList(ArrayList expExpList)
プロパティ情報(export(Export))の一覧を設定します｡
 void setExpStrList(ArrayList expStrList)
プロパティ情報(structure(Export))の一覧を設定します｡
 void setExpTblList(ArrayList expTblList)
プロパティ情報(table(Export))の一覧を設定します｡
 void setIgnoreErrMsgReturnTypes(List ignoreErrMsgReturnTypes)
エラーメッセージを無視するRETURN-TYPEを設定します。
 void setImpImpList(ArrayList impImpList)
プロパティ情報(import(Import))の一覧を設定します｡
 void setImpStrList(ArrayList impStrList)
プロパティ情報(structure(Import))の一覧を設定します｡
 void setImpTblList(ArrayList impTblList)
プロパティ情報(table(Import))の一覧を設定します｡
 void setProperty(Properties property)
プロパティファイル情報を設定します｡
 void setPropertyName(String propertyName)
プロパティファイル名を設定します｡
 String toString()
デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

フィールドの詳細

DEFAULT_IGNORE_ERR_MSG_RETURN_TYPES

public static final String[] DEFAULT_IGNORE_ERR_MSG_RETURN_TYPES
エラーメッセージを無視するRETURN-TYPEの設定。

エラーメッセージを無視させる BapiReturn のType情報のデフォルト値を "S" または空文字 "" とします。

コンストラクタの詳細

BapiController

public BapiController(String propertyName)
               throws SAPGeneralSystemException,
                      SAPAuthSystemException,
                      SAPGeneralAppException
プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡

パラメータ:
propertyName - BAPIコントローラが使用するプロパティファイル名
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPAuthSystemException - 認証系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外

BapiController

public BapiController(String propertyName,
                      ConnectionManager connectionManager)
               throws SAPGeneralSystemException,
                      SAPAuthSystemException,
                      SAPGeneralAppException
コネクションマネージャのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録・更新処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

【注意】トランザクション処理が記述されているBAPIもあります。 その場合、executeBapi()実行後にここまでの コネクションマネージャーで実行したすべての処理がcommitまたは rollbackされます。
※ただし、コネクションはリリースされませんので、リリースされるようにConnectionManager.commit()または ConnectionManager.rollback()を実行してください。
この振る舞いを変更するには、BAPI自体をカスタマイズする必要があります。

パラメータ:
propertyName - BAPIコントローラが使用するプロパティファイル名
connectionManager - 生成したConnectionManagerオブジェクト
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPAuthSystemException - 認証系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外

BapiController

public BapiController(String propertyName,
                      SapClient sapClient)
               throws SAPGeneralSystemException,
                      SAPAuthSystemException,
                      SAPGeneralAppException
サップクライアントのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。

パラメータ:
propertyName - BAPIコントローラが使用するプロパティファイル名
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPAuthSystemException - 認証系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外
メソッドの詳細

putImportParam

public void putImportParam(String key,
                           String val)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="import")を生成し､一覧に格納します｡

パラメータ:
key - BapiHashに設定するHashMapのキー
val - BapiHashに設定するHashMapの値
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外処理

putStructParam

public void putStructParam(String key,
                           String val,
                           String structName)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="structure",パラメタ名=第３引数)を生成し､一覧に格納します｡

パラメータ:
key - BapiHashに設定するHashMapのキー
val - BapiHashに設定するHashMapの値
structName - BapiHashに設定するparamTypeの値
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外処理

putTableParam

public void putTableParam(String key,
                          String val,
                          String tableName,
                          int recordNo)
                   throws SAPGeneralSystemException,
                          SAPGeneralAppException
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="table",パラメタ名=第３引数,レコード番号=第４引数)を生成し､ 一覧に格納します｡

パラメータ:
key - BapiHashに設定するHashMapのキー
val - BapiHashに設定するHashMapの値
tableName - BapiHashに設定するparamTypeの値
recordNo - BapiHashに設定するrecordNoの値
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外処理

executeBapi

public void executeBapi()
                 throws SAPGeneralSystemException,
                        SAPGeneralAppException,
                        SAPAuthSystemException,
                        SAPAuthAppException
BAPIを実行します。

JCO.Connectionを生成し､JCO.Functionの生成、 BAPI引渡しパラメータの生成を行いBAPI実行を行います｡またBAPI実行結果から BapiHashオブジェクトの生成とBapiHashListへの追加、 BapiReturnオブジェクトの生成とBapiReturnListへの追加を行います｡
なお、このクラスのコンストラクタ呼び出し時にConnectionManagerを指定した場合、 トランザクション処理は自動的に実行されません。呼び出し側で明示的にConnectionManager.commit() またはConnectionManager.rollback()を実行する必要があります。また、SAPとのコネクションも 上記2メソッド内で行われますので、確実に呼び出すように実装しなくてはなりません。

【注意】ConnectionManagerを指定した場合の注意点

トランザクション処理が記述されているBAPIもあります。 その場合、本メソッド実行後にここまでのコネクションマネージャーで実行したすべての処理がcommitまたはrollbackされます。
※ただし、コネクションはリリースされませんので、リリースされるようにConnectionManager.commit()または ConnectionManager.rollback()を実行してください。
この振る舞いを変更するには、BAPI自体をカスタマイズする必要があります。

例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPAuthSystemException - 認証系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外処理
SAPAuthAppException - 認証系アプリケーション例外処理

isSuccess

public boolean isSuccess()
                  throws SAPGeneralSystemException
ＢＡＰＩ実行が正常に行われたか判定します｡

ＢＡＰＩ実行結果であるBapiReturndのType情報が 正常(デフォルト値: "S" / "")であった場合"true"をそれ以外は"false"を返します｡ 正常と判断させる条件はプロパティファイル、 またはsetIgnoreErrMsgReturnTypes(List)、 addIgnoreErrMsgReturnType(String)でカスタマイズできます。

戻り値:
bapiSuccess BAPI実行結果
例外:
SAPGeneralSystemException - 汎用系システム例外処理

getErrMessage

public String getErrMessage()
                     throws SAPGeneralSystemException
ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡ 正常と判断させる条件はプロパティファイル、 またはsetIgnoreErrMsgReturnTypes(List), addIgnoreErrMsgReturnType(String)でカスタマイズできます。

戻り値:
buffer BAPI実行結果エラーとなった全てのメッセージ情報
例外:
SAPGeneralSystemException - 汎用系システム例外処理

getMessage

public String getMessage()
                  throws SAPGeneralSystemException
設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡ 正常と判断させる条件はプロパティファイル、 またはsetIgnoreErrMsgReturnTypes(List), addIgnoreErrMsgReturnType(String)でカスタマイズできます。

戻り値:
buffer オートコミット条件に一致したType情報のメッセージ情報
例外:
SAPGeneralSystemException - 汎用系システム例外処理

getMessage

public String getMessage(String type)
                  throws SAPGeneralSystemException
引数に一致したType情報のメッセージ情報全て取得します。

ＢＡＰＩの実行結果において、引数に一致するType情報のメッセージ情報を全て返します。 メッセージは、以下のように、一致したType情報の各メッセージが MESSAGE1, MESSAGE2と改行文字で区切られた形式になります。

MESSAGE1 : メッセージ1
MESSAGE2 : メッセージ2
:
メッセージがない場合、nullが返却されます｡

引数に指定するType情報は、一般に以下のようになります。
  • S：正常終了
  • W：警告
  • I：情報
  • E：エラー
※上記のType情報は、BAPIに依存します。

パラメータ:
type - エラーコードタイプ
戻り値:
BAPI実行時の全てのメッセージ情報
例外:
SAPGeneralSystemException - 汎用系システム例外処理

getExportParam

public String getExportParam(String propKey)
                      throws SAPGeneralSystemException
export(Export)情報を返します。入力／出力区分、パラメータ属性、パラメータ名、 プロパティファイルのキー情報で一覧から該当するBapiHashオブジェクト を検索して、値を返します｡

パラメータ:
propKey - 検索条件となるPropertyKey
戻り値:
rtnVal 引数のキーに対応する値
例外:
SAPGeneralSystemException - 汎用系システム例外処理

getStructureParam

public HashMap getStructureParam(String paramName)
                          throws SAPGeneralSystemException
structure(Export)情報を返します。入力／出力区分、パラメータ属性、パラメータ名 で一覧から該当するBapiHashオブジェクトを検索して返します｡

パラメータ:
paramName - 検索条件となるParamName
戻り値:
retMap 検索結果となるBapiHash
例外:
SAPGeneralSystemException - 汎用系システム例外処理

getTableParam

public Iterator getTableParam(String paramName)
                       throws SAPGeneralSystemException
table(Export)情報を返します。入力／出力区分、パラメータ属性、パラメータ名 で一覧から該当するBapiHashオブジェクトを検索し、一覧に格納して返します｡

パラメータ:
paramName - 検索条件となるParamName
戻り値:
retMap 検索結果となるBapiHash
例外:
SAPGeneralSystemException - 汎用系システム例外処理

getReturnList

public Iterator getReturnList()
ＢＡＰＩ実行結果の一覧を取得します。(Table用)

戻り値:
bapiReturnList

getReturn

public BapiReturn getReturn()
ＢＡＰＩ実行結果を取得します。(Structure用)

戻り値:
bapiRet

getBapiHashList

public ArrayList getBapiHashList()
BapiHashの一覧を取得します。

戻り値:
bapiHashList

getProperty

public Properties getProperty()
プロパティファイル情報を取得します。

戻り値:
property

getPropertyName

public String getPropertyName()
プロパティファイル名を取得します。

戻り値:
propertyName

getImpImpList

public ArrayList getImpImpList()
プロパティ情報(import(Import))の一覧を取得します。

戻り値:
impImpList

getImpStrList

public ArrayList getImpStrList()
プロパティ情報(structure(Import))一覧を取得します。

戻り値:
impStrList

getImpTblList

public ArrayList getImpTblList()
プロパティ情報(table(Import))の一覧を取得します｡

戻り値:
impTblList

getExpExpList

public ArrayList getExpExpList()
プロパティ情報(export(Export))の一覧を取得します｡

戻り値:
expExpList

getExpStrList

public ArrayList getExpStrList()
プロパティ情報(structure(Export))の一覧を取得します｡

戻り値:
expStrList

getExpTblList

public ArrayList getExpTblList()
プロパティ情報(table(Export))の一覧を取得します｡

戻り値:
expTblList

getBapiReturnList

public ArrayList getBapiReturnList()
BapiReturnの一覧を取得します｡

戻り値:
bapiReturnList

setBapiHashList

public void setBapiHashList(ArrayList bapiHashList)
BapiHashの一覧を設定します｡

パラメータ:
bapiHashList - BapiHashList

setProperty

public void setProperty(Properties property)
プロパティファイル情報を設定します｡

パラメータ:
property - Property

setPropertyName

public void setPropertyName(String propertyName)
プロパティファイル名を設定します｡

パラメータ:
propertyName - propertyName

setImpImpList

public void setImpImpList(ArrayList impImpList)
プロパティ情報(import(Import))の一覧を設定します｡

パラメータ:
impImpList - impImpList

setImpStrList

public void setImpStrList(ArrayList impStrList)
プロパティ情報(structure(Import))の一覧を設定します｡

パラメータ:
impStrList - impStrList

setImpTblList

public void setImpTblList(ArrayList impTblList)
プロパティ情報(table(Import))の一覧を設定します｡

パラメータ:
impTblList - impTblList

setExpExpList

public void setExpExpList(ArrayList expExpList)
プロパティ情報(export(Export))の一覧を設定します｡

パラメータ:
expExpList - expExpList

setExpStrList

public void setExpStrList(ArrayList expStrList)
プロパティ情報(structure(Export))の一覧を設定します｡

パラメータ:
expStrList - expStrList

setExpTblList

public void setExpTblList(ArrayList expTblList)
プロパティ情報(table(Export))の一覧を設定します｡

パラメータ:
expTblList - expTblList

setBapiReturnList

public void setBapiReturnList(ArrayList bapiReturnList)
BapiReturnの一覧を設定します｡

パラメータ:
bapiReturnList - bapiReturnList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値

clear

public void clear()

セットしたパラメータ、ストラクチャ、テーブル、BAPIの実行結果をクリアします。

BapiControllerを複数回使用する場合、一度putImportParam()などを実行した後に 同じパラメータをセットする前に実行する必要があります。

実行例は次のようになります。

 BapiController bapiController = new BapiController(...);
 bapiController.putImportParam(...);
 bapiController.putStructParam(...);
 ...
 executeBapi();

 //クリア
 bapiController.clear();

 //BapiControllerを再利用する
 bapiController.putImportParam(...);
 bapiController.putStructParam(...);
 ...
 executeBapi();

getAutoCommitConditions

public List getAutoCommitConditions()
推奨されていません。 getIgnoreErrMsgReturnTypes()に置き換えられました。

オートコミットさせる条件を取得します。

BapiReturn のType情報に対して、オートコミットさせる文字列からなる条件を取得します。

戻り値:
オートコミットさせる条件(String型の要素からなるListオブジェクト)
導入されたバージョン:
5.1.5

addAutoCommitCondition

public void addAutoCommitCondition(String autoCommitConditon)
推奨されていません。 addIgnoreErrMsgReturnType(java.lang.String)に置き換えられました。

オートコミットさせる条件を追加します。

BapiReturn のType情報に対して、オートコミットさせる文字列の条件を設定します。

パラメータ:
autoCommitConditon - オートコミットさせる条件
導入されたバージョン:
5.1.5

setAutoCommitConditions

public void setAutoCommitConditions(List autoCommitConditions)
                             throws SAPGeneralSystemException
推奨されていません。 setIgnoreErrMsgReturnTypes(java.util.List)に置き換えられました。

オートコミットさせる条件を指定します。

BapiReturn のType情報に対して、オートコミットさせる文字列条件を設定します。 List の要素は文字列 String で登録します。

パラメータ:
autoCommitConditions - オートコミットさせる条件リスト
例外:
SAPGeneralSystemException - 引数にString型以外の要素が 含まれている場合にスローされます。
導入されたバージョン:
5.1.5

getIgnoreErrMsgReturnTypes

public List getIgnoreErrMsgReturnTypes()
エラーメッセージを無視するRETURN-TYPEを取得します。

BapiReturn のType情報に対して、エラーメッセージを無視するRETURN-TYPEを取得します。

戻り値:
エラーメッセージを無視するRETURN-TYPE値のリスト
導入されたバージョン:
6.0

addIgnoreErrMsgReturnType

public void addIgnoreErrMsgReturnType(String ignoreErrMsgReturnType)
エラーメッセージを無視するRETURN-TYPEを追加します。

BapiReturn のType情報に対して、エラーメッセージを無視するRETURN-TYPEを設定します。

パラメータ:
ignoreErrMsgReturnType - エラーメッセージを無視するRETURN-TYPE値
導入されたバージョン:
6.0

setIgnoreErrMsgReturnTypes

public void setIgnoreErrMsgReturnTypes(List ignoreErrMsgReturnTypes)
                                throws SAPGeneralSystemException
エラーメッセージを無視するRETURN-TYPEを設定します。

BapiReturn のType情報に対して、エラーメッセージを無視するRETURN-TYPEを設定します。 この設定を変更することで、たとえば警告時にもコミットさせることができます。 List の要素は文字列 String で登録します。

パラメータ:
ignoreErrMsgReturnTypes - エラーメッセージを無視するRETURN-TYPE値のリスト
例外:
SAPGeneralSystemException - 引数にString型以外の要素が 含まれている場合にスローされます。
導入されたバージョン:
6.0

getReturnCodeTypes

public Iterator getReturnCodeTypes()
BapiReturn のType情報を取得します。

BapiReturn のType情報をString型の要素からなる Iteratorオブジェクトを取得します。
BapiReturn のType情報は、一般的に以下となります。
  • S：正常終了
  • W：警告
  • I：情報
  • E：エラー
※上記のBapiReturn のType情報は、BAPIに依存します。

戻り値:
BapiReturn のType情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BapiHash (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose
クラス BapiHash

java.lang.Object
    拡張 java.util.AbstractMap
        拡張 java.util.HashMap
            拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash
すべての実装インタフェース:
Cloneable, Map, Serializable
public class BapiHash
extends HashMap
implements Serializable

BapiHashクラス
機能は以下の通り

  • 汎用モジュールAPIを呼び出すソリューション特化型APIが、BAPIを実行する為に 使用するパラメータ値を設定する｡
  • SAPのBAPI処理にて使用されるパラメータの値を保持します。
  • 上記のインスタンス変数の設定と取得のためにアクセサ・メソッドを提供します。

関連項目:
直列化された形式

コンストラクタの概要
BapiHash(String impExpType, String paramType)
指定された入力／出力区分、パラメータ属性でBapiHashオブジェクトを生成します｡ このコンストラクタはパラメタ属性が"import" / "export"の場合に使用します｡ パラメータ名は""が設定されます｡
BapiHash(String impExpType, String paramType, String paramName)
入力／出力区分、パラメータ属性、パラメータ名でBapiHashオブジェクトを生成します｡ このコンストラクタはパラメタ属性が"structure"の場合に使用します。
BapiHash(String impExpType, String paramType, String paramName, int recordNo)
入力／出力区分、パラメータ属性、パラメータ名、レコード番号でBapiHash オブジェクトを生成します｡このコンストラクタはパラメタ属性が"table"の場合 に使用します。
メソッドの概要
String | getImpExpType() 入力／出力区分を取得します｡
String | getParamName() パラメタ名を取得します｡
String | getParamType() パラメタ属性を取得します｡
int | getRecordNo() レコード番号を取得します｡
void | setImpExpType(String impExpType) 入力／出力区分を設定します｡
void | setParamName(String paramName) パラメタ名を設定します｡
void | setParamType(String paramType) パラメタ属性を設定します｡
void | setRecordNo(int recordNo) レコード番号を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.util.HashMap から継承したメソッド
clear, clone, containsKey, containsValue, entrySet, get, isEmpty, keySet, put, putAll, remove, size, values
クラス java.util.AbstractMap から継承したメソッド
equals, hashCode
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait
インタフェース java.util.Map から継承したメソッド
equals, hashCode

コンストラクタの詳細

BapiHash

public BapiHash(String impExpType,
                String paramType)
指定された入力／出力区分、パラメータ属性でBapiHashオブジェクトを生成します｡ このコンストラクタはパラメタ属性が"import" / "export"の場合に使用します｡ パラメータ名は""が設定されます｡

パラメータ:
impExpType - BapiHashの入力／出力区分
paramType - BapiHashのパラメタ属性

BapiHash

public BapiHash(String impExpType,
                String paramType,
                String paramName)
入力／出力区分、パラメータ属性、パラメータ名でBapiHashオブジェクトを生成します｡ このコンストラクタはパラメタ属性が"structure"の場合に使用します。

パラメータ:
impExpType - BapiHashの入力／出力区分
paramType - BapiHashのパラメタ属性
paramName - BapiHashのパラメタ名

BapiHash

public BapiHash(String impExpType,
                String paramType,
                String paramName,
                int recordNo)
入力／出力区分、パラメータ属性、パラメータ名、レコード番号でBapiHash オブジェクトを生成します｡このコンストラクタはパラメタ属性が"table"の場合 に使用します。

パラメータ:
impExpType - BapiHashの入力／出力区分
paramType - BapiHashのパラメタ属性
paramName - BapiHashのパラメタ名
recordNo - BapiHashのレコード番号
メソッドの詳細

getImpExpType

public String getImpExpType()
入力／出力区分を取得します｡

戻り値:
impExpType

getParamName

public String getParamName()
パラメタ名を取得します｡

戻り値:
paramName

getParamType

public String getParamType()
パラメタ属性を取得します｡

戻り値:
paramType

getRecordNo

public int getRecordNo()
レコード番号を取得します｡

戻り値:
recordNo

setImpExpType

public void setImpExpType(String impExpType)
入力／出力区分を設定します｡

パラメータ:
impExpType - BapiHashの入出力区分

setParamName

public void setParamName(String paramName)
パラメタ名を設定します｡

パラメータ:
paramName - Importのパラメタ名

setParamType

public void setParamType(String paramType)
パラメタ属性を設定します｡

パラメータ:
paramType - Importのパラメタ属性

setRecordNo

public void setRecordNo(int recordNo)
レコード番号を設定します｡

パラメータ:
recordNo - Importのレコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BapiReturn (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose
クラス BapiReturn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn
すべての実装インタフェース:
Serializable
public class BapiReturn
extends Object
implements Serializable

BapiReturnクラス
機能は以下の通り

  • SAPのBAPI処理の実行結果に関する値を保持します。
  • 上記のインスタンス変数の設定と取得のためにアクセサ・メソッドを提供します。

関連項目:
直列化された形式

コンストラクタの概要
BapiReturn(com.sap.mw.jco.JCO.Structure str)
指定されたJCO.Structure情報でBapiReturnを作成します。
BapiReturn(com.sap.mw.jco.JCO.Table tbl)
指定されたJCO.Table情報でBapiReturnを作成します。
メソッドの概要
String | getCode() コードを取得します｡
String | getField() フィールドを取得します｡
String | getId() ＩＤを取得します｡
String | getLogMsgNo() ログメッセージナンバーを取得します｡
String | getLogNo() ログナンバーを取得します｡
String | getMessage() メッセージを取得します｡
String | getMessageV1() メッセージＶ１を取得します｡
String | getMessageV2() メッセージＶ２を取得します｡
String | getMessageV3() メッセージＶ３を取得します｡
String | getMessageV4() メッセージＶ４を取得します｡
String | getNumber() ナンバーを取得します｡
String | getParameter() パラメーターを取得します｡
String | getRow() 行番号を取得します｡
String | getSystem() ＩＤを取得します｡
String | getType() タイプを取得します｡
void | setCode(String code) コードを設定します｡
void | setField(String field) フィールドを設定します｡
void | setId(String id) ＩＤを設定します｡
void | setLogMsgNo(String logMsgNo) ログメッセージナンバーを設定します｡
void | setLogNo(String logNo) ログナンバーを設定します｡
void | setMessage(String message) メッセージを設定します｡
void | setMessageV1(String messageV1) メッセージＶ１を設定します｡
void | setMessageV2(String messageV2) メッセージＶ２を設定します｡
void | setMessageV3(String messageV3) メッセージＶ３を設定します｡
void | setMessageV4(String messageV4) メッセージＶ４を設定します｡
void | setNumber(String number) ナンバーを設定します｡
void | setParameter(String parameter) パラメーターを設定します｡
void | setRow(String row) 行番号を設定します｡
void | setSystem(String system) システムを設定します｡
void | setType(String type) タイプを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BapiReturn

public BapiReturn(com.sap.mw.jco.JCO.Structure str)
           throws SAPGeneralSystemException
指定されたJCO.Structure情報でBapiReturnを作成します。 引数のBAPI RETURN(Structure)情報から属性に値をセットします｡

パラメータ:
str - JCO.Structure
例外:
SAPGeneralSystemException - システム例外処理

BapiReturn

public BapiReturn(com.sap.mw.jco.JCO.Table tbl)
           throws SAPGeneralSystemException
指定されたJCO.Table情報でBapiReturnを作成します。 引数のBAPI RETURN(Table)情報から属性に値をセットします｡

パラメータ:
tbl - JCO.Table
例外:
SAPGeneralSystemException - システム例外処理
メソッドの詳細

getField

public String getField()
フィールドを取得します｡

戻り値:
field

getId

public String getId()
ＩＤを取得します｡

戻り値:
id

getCode

public String getCode()
コードを取得します｡

戻り値:
code

getLogMsgNo

public String getLogMsgNo()
ログメッセージナンバーを取得します｡

戻り値:
logMsgNo

getLogNo

public String getLogNo()
ログナンバーを取得します｡

戻り値:
logNo

getMessage

public String getMessage()
メッセージを取得します｡

戻り値:
message

getMessageV1

public String getMessageV1()
メッセージＶ１を取得します｡

戻り値:
messageV1

getMessageV2

public String getMessageV2()
メッセージＶ２を取得します｡

戻り値:
messageV2

getMessageV3

public String getMessageV3()
メッセージＶ３を取得します｡

戻り値:
messageV3

getMessageV4

public String getMessageV4()
メッセージＶ４を取得します｡

戻り値:
messageV4

getNumber

public String getNumber()
ナンバーを取得します｡

戻り値:
number

getParameter

public String getParameter()
パラメーターを取得します｡

戻り値:
parameter

getRow

public String getRow()
行番号を取得します｡

戻り値:
row

getSystem

public String getSystem()
ＩＤを取得します｡

戻り値:
tableList

getType

public String getType()
タイプを取得します｡

戻り値:
type

setField

public void setField(String field)
フィールドを設定します｡

パラメータ:
field - BapiReturnのfieldの値

setId

public void setId(String id)
ＩＤを設定します｡

パラメータ:
id - BapiReturnのidの値

setLogMsgNo

public void setLogMsgNo(String logMsgNo)
ログメッセージナンバーを設定します｡

パラメータ:
logMsgNo - BapiReturnのlogMsgNoの値

setLogNo

public void setLogNo(String logNo)
ログナンバーを設定します｡

パラメータ:
logNo - BapiReturnのlogNoの値

setMessage

public void setMessage(String message)
メッセージを設定します｡

パラメータ:
message - BapiReturnのmessageの値

setMessageV1

public void setMessageV1(String messageV1)
メッセージＶ１を設定します｡

パラメータ:
messageV1 - BapiReturnのmessageV1の値

setMessageV2

public void setMessageV2(String messageV2)
メッセージＶ２を設定します｡

パラメータ:
messageV2 - BapiReturnのmessageV2の値

setMessageV3

public void setMessageV3(String messageV3)
メッセージＶ３を設定します｡

パラメータ:
messageV3 - BapiReturnのmessageV3の値

setMessageV4

public void setMessageV4(String messageV4)
メッセージＶ４を設定します｡

パラメータ:
messageV4 - BapiReturnのmessageV4の値

setNumber

public void setNumber(String number)
ナンバーを設定します｡

パラメータ:
number - BapiReturnのnumberの値

setParameter

public void setParameter(String parameter)
パラメーターを設定します｡

パラメータ:
parameter - BapiReturnのparameterの値

setRow

public void setRow(String row)
行番号を設定します｡

パラメータ:
row - BapiReturnのrowの値

setSystem

public void setSystem(String system)
システムを設定します｡

パラメータ:
system - BapiReturnのsystemの値

setType

public void setType(String type)
タイプを設定します｡

パラメータ:
type - BapiReturnのtypeの値

setCode

public void setCode(String code)
コードを設定します｡

パラメータ:
code - BapiReturnのcodeの値

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ConnectionManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose
クラス ConnectionManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager
すべての実装インタフェース:
Serializable
public class ConnectionManager
extends Object
implements Serializable

ConnectionManagerクラス。
機能は以下の通り。

SAPへのコネクション(トランザクション)を管理するクラスです。 commitとrollbackの2つのパブリックメソッドを持ち、業務ロジックの最後に実行することで SAPへの変更を確定/取り消しすることができます。
なお、SAPへのコネクションの開放も上記2メソッド内で実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

関連項目:
直列化された形式

コンストラクタの概要
ConnectionManager()
コンストラクタ。
ConnectionManager(SapClient sapClient)
受け取ったサップクライアントに格納されている接続情報を 用いて、SAPへの接続を行います。
メソッドの概要
void | commit() ＢＡＰＩ実行結果のCOMMIT処理を行います｡ 実行後にコネクションが開放されます。
void | rollback() ＢＡＰＩ実行結果のROLLBACK処理を行います｡ 実行後にコネクションが開放されます。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ConnectionManager

public ConnectionManager()
コンストラクタ。

ConnectionManager

public ConnectionManager(SapClient sapClient)
受け取ったサップクライアントに格納されている接続情報を 用いて、SAPへの接続を行います。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

commit

public void commit()
            throws SAPGeneralSystemException
ＢＡＰＩ実行結果のCOMMIT処理を行います｡

実行後にコネクションが開放されます。

例外:
SAPGeneralSystemException - 汎用系システム例外処理

rollback

public void rollback()
              throws SAPGeneralSystemException
ＢＡＰＩ実行結果のROLLBACK処理を行います｡

実行後にコネクションが開放されます。

例外:
SAPGeneralSystemException - 汎用系システム例外処理

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LineProperty (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose
クラス LineProperty

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty
すべての実装インタフェース:
Serializable
public class LineProperty
extends Object
implements Serializable

LinePropertyクラス
機能は以下の通り

  • Propertyファイル１行ごとの情報を保持します｡
  • 上記のインスタンス変数の設定と取得のためにアクセサ・メソッドを提供します。

関連項目:
直列化された形式

コンストラクタの概要
LineProperty(String propertyKey, String propertyValue)
指定されたプロパティファイルのキー情報と値でLinePropertyオブジェクト を生成します。
メソッドの概要
String[] | getPropertyKeyPart() プロパティのキーを取得します｡
String | getPropertyValue() プロパティの値を取得します｡
String | getSeparateKey(int partIndex) 指定された添字に該当するプロパティファイルのキー情報（配列）の要素を 返します。
void | setPropertyKeyPart(String[] propertyKeyPart) プロパティのキーを設定します｡
void | setPropertyValue(String propertyValue) プロパティの値を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

LineProperty

public LineProperty(String propertyKey,
                    String propertyValue)
             throws SAPGeneralSystemException
指定されたプロパティファイルのキー情報と値でLinePropertyオブジェクト を生成します。

パラメータ:
propertyKey - PropertyKey
propertyValue - PropertyValue
例外:
SAPGeneralSystemException - システム例外処理
メソッドの詳細

getSeparateKey

public String getSeparateKey(int partIndex)
                      throws SAPGeneralAppException
指定された添字に該当するプロパティファイルのキー情報（配列）の要素を 返します。
引数 = 0 の場合：入力／出力区分("import"/"export")
引数 = 1 の場合：パラメータ属性("import(export)"/"structure"/"table")
引数 = 2 の場合：パラメータ名
引数 = 3 の場合：コンポーネント名

パラメータ:
partIndex - propertyKeyPart（分割値の格納用配列）の要素を指定する添字
戻り値:
propertyKeyPart[]
例外:
SAPGeneralAppException - アプリケーション例外処理

getPropertyValue

public String getPropertyValue()
プロパティの値を取得します｡

戻り値:
propertyValue

getPropertyKeyPart

public String[] getPropertyKeyPart()
プロパティのキーを取得します｡

戻り値:
propertyKeyPart

setPropertyValue

public void setPropertyValue(String propertyValue)
プロパティの値を設定します｡

パラメータ:
propertyValue - PropertyValue

setPropertyKeyPart

public void setPropertyKeyPart(String[] propertyKeyPart)
プロパティのキーを設定します｡

パラメータ:
propertyKeyPart - propertyKeyPart

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.common.general_purpose (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.common.general_purpose
クラス
BapiController
BapiHash
BapiReturn
ConnectionManager
LineProperty


jp.co.intra_mart.foundation.sap.common.general_purpose (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose

ＳＡＰ連携に関するクラスを提供します。

参照:
説明

クラスの概要
BapiController | BAPIコントローラクラス。
BapiHash | BapiHashクラス 機能は以下の通り 汎用モジュールAPIを呼び出すソリューション特化型APIが、BAPIを実行する為に 使用するパラメータ値を設定する｡ SAPのBAPI処理にて使用されるパラメータの値を保持します。
BapiReturn | BapiReturnクラス 機能は以下の通り SAPのBAPI処理の実行結果に関する値を保持します。
ConnectionManager | ConnectionManagerクラス。
LineProperty | LinePropertyクラス 機能は以下の通り Propertyファイル１行ごとの情報を保持します｡ 上記のインスタンス変数の設定と取得のためにアクセサ・メソッドを提供します。

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose の説明

ＳＡＰ連携に関するクラスを提供します。


jp.co.intra_mart.foundation.sap.common.general_purpose クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.util.AbstractMap (implements java.util.Map)
      • class java.util.HashMap (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose の使用

jp.co.intra_mart.foundation.sap.common.general_purpose を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial | ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.common.model |
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems |
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability |
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall |
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica |
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist |
jp.co.intra_mart.foundation.sap.module.sales.common.model |
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus |

jp.co.intra_mart.foundation.sap.common.general_purpose により使用される jp.co.intra_mart.foundation.sap.common.general_purpose のクラス
BapiReturn
BapiReturnクラス
機能は以下の通り
SAPのBAPI処理の実行結果に関する値を保持します。
ConnectionManager
ConnectionManagerクラス。

jp.co.intra_mart.foundation.sap.module により使用される jp.co.intra_mart.foundation.sap.common.general_purpose のクラス
BapiController
BAPIコントローラクラス。
ConnectionManager
ConnectionManagerクラス。

jp.co.intra_mart.foundation.sap.module.accounting により使用される jp.co.intra_mart.foundation.sap.common.general_purpose のクラス
ConnectionManager
ConnectionManagerクラス。

jp.co.intra_mart.foundation.sap.module.financial により使用される jp.co.intra_mart.foundation.sap.common.general_purpose のクラス
BapiController
BAPIコントローラクラス。

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.common.general_purpose のクラス
BapiController
BAPIコントローラクラス。
ConnectionManager
ConnectionManagerクラス。

jp.co.intra_mart.foundation.sap.module.purchase.common.model により使用される jp.co.intra_mart.foundation.sap.common.general_purpose のクラス
BapiController
BAPIコントローラクラス。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate により使用される jp.co.intra_mart.foundation.sap.common.general_purpose のクラス
BapiController
BAPIコントローラクラス。
ConnectionManager
ConnectionManagerクラス。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems により使用される jp.co.intra_mart.foundation.sap.common.general_purpose のクラス
BapiController
BAPIコントローラクラス。

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability により使用される jp.co.intra_mart.foundation.sap.common.general_purpose のクラス
BapiController
BAPIコントローラクラス。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall により使用される jp.co.intra_mart.foundation.sap.common.general_purpose のクラス
BapiController
BAPIコントローラクラス。

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica により使用される jp.co.intra_mart.foundation.sap.common.general_purpose のクラス
BapiController
BAPIコントローラクラス。
ConnectionManager
ConnectionManagerクラス。

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.common.general_purpose のクラス
ConnectionManager
ConnectionManagerクラス。

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple により使用される jp.co.intra_mart.foundation.sap.common.general_purpose のクラス
BapiController
BAPIコントローラクラス。
ConnectionManager
ConnectionManagerクラス。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail により使用される jp.co.intra_mart.foundation.sap.common.general_purpose のクラス
BapiController
BAPIコントローラクラス。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist により使用される jp.co.intra_mart.foundation.sap.common.general_purpose のクラス
BapiController
BAPIコントローラクラス。

jp.co.intra_mart.foundation.sap.module.sales.common.model により使用される jp.co.intra_mart.foundation.sap.common.general_purpose のクラス
BapiController
BAPIコントローラクラス。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.common.general_purpose のクラス
BapiController
BAPIコントローラクラス。
ConnectionManager
ConnectionManagerクラス。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.common.general_purpose のクラス
BapiController
BAPIコントローラクラス。
ConnectionManager
ConnectionManagerクラス。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.common.general_purpose のクラス
BapiController
BAPIコントローラクラス。
ConnectionManager
ConnectionManagerクラス。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist により使用される jp.co.intra_mart.foundation.sap.common.general_purpose のクラス
BapiController
BAPIコントローラクラス。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus により使用される jp.co.intra_mart.foundation.sap.common.general_purpose のクラス
BapiController
BAPIコントローラクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.model.BankDataInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.model.BankDataInfo の使用

jp.co.intra_mart.foundation.sap.common.model.BankDataInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo の使用

CompanyDataInfo を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial | ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での CompanyDataInfo の使用

CompanyDataInfo を返す jp.co.intra_mart.foundation.sap.module.financial のメソッド
CompanyDataInfo | DebtorGetDetailController.getCompanyDataInfo() 会社コード依存データ情報を取得します｡
CompanyDataInfo | DebtorGetDetail.getCompanyDataInfo() 会社コード依存データ情報を取得します｡
CompanyDataInfo | CreditorGetDetailController.getCompanyDataInfo() 会社コード依存データ情報を取得します｡
CompanyDataInfo | CreditorGetDetail.getCompanyDataInfo() 会社コード依存データ情報を取得します｡

CompanyDataInfo 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.financial のメソッド
void | DebtorGetDetailController.setCompanyDataInfo(CompanyDataInfo companyDataInfo) 会社依存データ情報を設定します｡
void | DebtorGetDetail.setCompanyDataInfo(CompanyDataInfo companyDataInfo) 会社依存データ情報を設定します｡
void | CreditorGetDetailController.setCompanyDataInfo(CompanyDataInfo companyDataInfo) 会社依存データ情報を設定します｡
void | CreditorGetDetail.setCompanyDataInfo(CompanyDataInfo companyDataInfo) 会社依存データ情報を設定します｡

jp.co.intra_mart.foundation.sap.module.purchase での CompanyDataInfo の使用

CompanyDataInfo を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
CompanyDataInfo | SupplierGetDetailController.getCompanyDataInfo() 会社コード依存データ情報を取得します｡
CompanyDataInfo | SupplierDetail.getCompanyDataInfo() 会社コード依存データ情報を取得します｡

CompanyDataInfo 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase のメソッド
void | SupplierGetDetailController.setCompanyDataInfo(CompanyDataInfo companyDataInfo) 会社依存データ情報を設定します｡
void | SupplierDetail.setCompanyDataInfo(CompanyDataInfo companyDataInfo) 会社依存データ情報を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo の使用

GeneralDataInfo を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial | ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での GeneralDataInfo の使用

GeneralDataInfo を返す jp.co.intra_mart.foundation.sap.module.financial のメソッド
GeneralDataInfo | DebtorGetDetailController.getGeneralDataInfo() 一般データ情報を取得します｡
GeneralDataInfo | DebtorGetDetail.getGeneralDataInfo() 一般データ情報を取得します｡
GeneralDataInfo | CreditorGetDetailController.getGeneralDataInfo() 一般データ情報を取得します｡
GeneralDataInfo | CreditorGetDetail.getGeneralDataInfo() 一般データ情報を取得します｡

GeneralDataInfo 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.financial のメソッド
void | DebtorGetDetailController.setGeneralDataInfo(GeneralDataInfo generalDataInfo) 一般データ情報を設定します｡
void | DebtorGetDetail.setGeneralDataInfo(GeneralDataInfo generalDataInfo) 一般データ情報を設定します｡
void | CreditorGetDetailController.setGeneralDataInfo(GeneralDataInfo generalDataInfo) 一般データ情報を設定します｡
void | CreditorGetDetail.setGeneralDataInfo(GeneralDataInfo generalDataInfo) 一般データ情報を設定します｡

jp.co.intra_mart.foundation.sap.module.purchase での GeneralDataInfo の使用

jp.co.intra_mart.foundation.sap.module.purchase での GeneralDataInfo のサブクラス
 class VendorAddress
仕入先住所情報クラス
機能は以下の通り
仕入先住所を保持します。

GeneralDataInfo を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
GeneralDataInfo | SupplierGetDetailController.getGeneralDataInfo() 一般データ情報を取得します｡
GeneralDataInfo | SupplierDetail.getGeneralDataInfo() 一般データ情報を取得します｡

GeneralDataInfo 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase のメソッド
void | SupplierGetDetailController.setGeneralDataInfo(GeneralDataInfo generalDataInfo) 一般データ情報を設定します｡
void | SupplierDetail.setGeneralDataInfo(GeneralDataInfo generalDataInfo) 一般データ情報を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BankDataInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.model
クラス BankDataInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.model.BankDataInfo
すべての実装インタフェース:
Serializable
public class BankDataInfo
extends Object
implements Serializable

銀行データ情報クラス
機能は以下の通り

  • 銀行データの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
BankDataInfo()
銀行データ情報を作成します。
メソッドの概要
String | getBankAcct() 口座番号を取得します。
String | getBankCtry() 銀行国コードを取得します。
String | getBankKey() 銀行コードを取得します。
String | getBankRef() 銀行詳細の参照詳細を取得します。
String | getCollAuth() フラグ: 回収権限を取得します。
String | getCtrlKey() 預金種別を取得します。
String | getCustomer() 得意先コードを取得します
String | getPartnerBk() 取引先銀行タイプを取得します。
String | getVendor() 仕入先または債権者の勘定コードを取得します。
void | setBankAcct(String strBankAcct) 口座番号を設定します。
void | setBankCtry(String strBankCtry) 銀行国コードを設定します。
void | setBankKey(String strBankKey) 銀行コードを設定します。
void | setBankRef(String strBankRef) 銀行詳細の参照詳細を設定します。
void | setCollAuth(String strCollAuth) フラグ: 回収権限を設定します。
void | setCtrlKey(String strCtrlKey) 預金種別を設定します。
void | setCustomer(String string) 得意先コードを設定します
void | setPartnerBk(String strPartnerBk) 取引先銀行タイプを設定します。
void | setVendor(String strVendor) 仕入先または債権者の勘定コードを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BankDataInfo

public BankDataInfo()
銀行データ情報を作成します。

メソッドの詳細

getVendor

public String getVendor()
仕入先または債権者の勘定コードを取得します。

戻り値:
ｓｔｒVendor

getBankCtry

public String getBankCtry()
銀行国コードを取得します。

戻り値:
ｓｔｒBankCtry

getBankKey

public String getBankKey()
銀行コードを取得します。

戻り値:
ｓｔｒBankKey

getBankAcct

public String getBankAcct()
口座番号を取得します。

戻り値:
ｓｔｒBankAcct

getCtrlKey

public String getCtrlKey()
預金種別を取得します。

戻り値:
ｓｔｒCtrlKey

getPartnerBk

public String getPartnerBk()
取引先銀行タイプを取得します。

戻り値:
ｓｔｒPartnerBk

getCollAuth

public String getCollAuth()
フラグ: 回収権限を取得します。

戻り値:
ｓｔｒCollAuth

getBankRef

public String getBankRef()
銀行詳細の参照詳細を取得します。

戻り値:
ｓｔｒBankRef

setVendor

public void setVendor(String strVendor)
仕入先または債権者の勘定コードを設定します。

パラメータ:
strVendor - 仕入先または債権者の勘定コード

setBankCtry

public void setBankCtry(String strBankCtry)
銀行国コードを設定します。

パラメータ:
strBankCtry - 銀行国コード

setBankKey

public void setBankKey(String strBankKey)
銀行コードを設定します。

パラメータ:
strBankKey - 銀行コード

setBankAcct

public void setBankAcct(String strBankAcct)
口座番号を設定します。

パラメータ:
strBankAcct - 口座番号

setCtrlKey

public void setCtrlKey(String strCtrlKey)
預金種別を設定します。

パラメータ:
strCtrlKey - 預金種別

setPartnerBk

public void setPartnerBk(String strPartnerBk)
取引先銀行タイプを設定します。

パラメータ:
strPartnerBk - 取引先銀行タイプ

setCollAuth

public void setCollAuth(String strCollAuth)
フラグ: 回収権限を設定します。

パラメータ:
strCollAuth - フラグ: 回収権限

setBankRef

public void setBankRef(String strBankRef)
銀行詳細の参照詳細を設定します。

パラメータ:
strBankRef - 銀行詳細の参照詳細

getCustomer

public String getCustomer()
得意先コードを取得します

戻り値:
得意先コード

setCustomer

public void setCustomer(String string)
得意先コードを設定します

パラメータ:
string - 得意先コード

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyDataInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.model
クラス CompanyDataInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo
すべての実装インタフェース:
Serializable
public class CompanyDataInfo
extends Object
implements Serializable

会社コード依存データ情報クラス
機能は以下の通り

  • 会社コード依存データの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CompanyDataInfo()
会社コード依存データ情報を作成します。
メソッドの概要
String | getActAtCus() 得意先での自社勘定コードを取得します。
String | getActAtVen() 仕入先での自社勘定コードを取得します。
String | getAltPayee() 代理受取人勘定コードを取得します。
String | getAltPayer() 代理支払人の勘定コードを取得します。
String | getBuyingGrp() 購買グループの勘定コードを取得します。
String | getClerk() 記帳担当者を取得します。
String | getCompCode() 会社コードを取得します。
String | getCustomer() 得意先コードを取得します
String | getCustUser() 得意先担当者を取得します。
String | getCuvdClear() フラグ: 得意先と仕入先間の相殺決済を取得します。
String | getFax() 得意先/仕入先の経理担当者のファックス No.を取得します。
String | getHdOffice() 本店勘定コードを取得します。
String | getInternet() 関係会社担当者のインターネットアドレスを取得します。
String | getNextPayee() 次受取人を取得します。
String | getPaymentMethods() 考慮される支払方法一覧を取得します。
String | getPmnttrms() 支払条件キーを取得します。
String | getTel() 取引先での記帳担当者電話番号を取得します。
String | getVendor() 仕入先または債権者の勘定コードを取得します。
String | getVendUser() 仕入先担当者を取得します。
void | setActAtCus(String string) 得意先での自社勘定コードを設定します。
void | setActAtVen(String strActAtVen) 仕入先での自社勘定コードを設定します。
void | setAltPayee(String strAltPayee) 代理受取人勘定コードを設定します。
void | setAltPayer(String string) 代理支払人の勘定コードを設定します。
void | setBuyingGrp(String string) 購買グループの勘定コードを設定します。
void | setClerk(String strClerk) 記帳担当者を設定します。
void | setCompCode(String strCompCode) 会社コードを設定します。
void | setCustomer(String string) 得意先コードを設定します
void | setCustUser(String string) 得意先担当者を設定します。
void | setCuvdClear(String strCuvdClear) フラグ: 得意先と仕入先間の相殺決済を設定します。
void | setFax(String strFax) 得意先/仕入先の経理担当者のファックス No.を設定します。
void | setHdOffice(String strHdOffice) 本店勘定コードを設定します。
void | setInternet(String strInternet) 関係会社担当者のインターネットアドレスを設定します。
void | setNextPayee(String string) 次受取人を設定します。
void | setPaymentMethods(String strPaymentMethods) 考慮される支払方法一覧を設定します。
void | setPmnttrms(String strPmnttrms) 支払条件キーを設定します。
void | setTel(String strTel) 取引先での記帳担当者電話番号を設定します。
void | setVendor(String strVendor) 仕入先または債権者の勘定コードを設定します。
void | setVendUser(String strVendUser) 仕入先担当者を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CompanyDataInfo

public CompanyDataInfo()
会社コード依存データ情報を作成します。

メソッドの詳細

getVendor

public String getVendor()
仕入先または債権者の勘定コードを取得します。

戻り値:
strVendor

getCompCode

public String getCompCode()
会社コードを取得します。

戻り値:
strCompCode

getClerk

public String getClerk()
記帳担当者を取得します。

戻り値:
strClerk

getHdOffice

public String getHdOffice()
本店勘定コードを取得します。

戻り値:
strHdOffice

getAltPayee

public String getAltPayee()
代理受取人勘定コードを取得します。

戻り値:
strAltPayee

getCuvdClear

public String getCuvdClear()
フラグ: 得意先と仕入先間の相殺決済を取得します。

戻り値:
strCuvdClear

getPmnttrms

public String getPmnttrms()
支払条件キーを取得します。

戻り値:
strPmnttrms

getActAtVen

public String getActAtVen()
仕入先での自社勘定コードを取得します。

戻り値:
strActAtVen

getVendUser

public String getVendUser()
仕入先担当者を取得します。

戻り値:
strVendUser

getInternet

public String getInternet()
関係会社担当者のインターネットアドレスを取得します。

戻り値:
strInternet

getFax

public String getFax()
得意先/仕入先の経理担当者のファックス No.を取得します。

戻り値:
strFax

getPaymentMethods

public String getPaymentMethods()
考慮される支払方法一覧を取得します。

戻り値:
strPaymentMethods

getTel

public String getTel()
取引先での記帳担当者電話番号を取得します。

戻り値:
strTel

setVendor

public void setVendor(String strVendor)
仕入先または債権者の勘定コードを設定します。

パラメータ:
strVendor - 仕入先または債権者の勘定コード

setCompCode

public void setCompCode(String strCompCode)
会社コードを設定します。

パラメータ:
strCompCode - 会社コード

setClerk

public void setClerk(String strClerk)
記帳担当者を設定します。

パラメータ:
strClerk - 記帳担当者

setHdOffice

public void setHdOffice(String strHdOffice)
本店勘定コードを設定します。

パラメータ:
strHdOffice - 本店勘定コード

setAltPayee

public void setAltPayee(String strAltPayee)
代理受取人勘定コードを設定します。

パラメータ:
strAltPayee - 代理受取人勘定コード

setCuvdClear

public void setCuvdClear(String strCuvdClear)
フラグ: 得意先と仕入先間の相殺決済を設定します。

パラメータ:
strCuvdClear - フラグ: 得意先と仕入先間の相殺決済

setPmnttrms

public void setPmnttrms(String strPmnttrms)
支払条件キーを設定します。

パラメータ:
strPmnttrms - 支払条件キー

setActAtVen

public void setActAtVen(String strActAtVen)
仕入先での自社勘定コードを設定します。

パラメータ:
strActAtVen - 仕入先での自社勘定コード

setVendUser

public void setVendUser(String strVendUser)
仕入先担当者を設定します。

パラメータ:
strVendUser - 仕入先担当者

setInternet

public void setInternet(String strInternet)
関係会社担当者のインターネットアドレスを設定します。

パラメータ:
strInternet - 関係会社担当者のインターネットアドレス

setFax

public void setFax(String strFax)
得意先/仕入先の経理担当者のファックス No.を設定します。

パラメータ:
strFax - 得意先/仕入先の経理担当者のファックス No.

setPaymentMethods

public void setPaymentMethods(String strPaymentMethods)
考慮される支払方法一覧を設定します。

パラメータ:
strPaymentMethods - 考慮される支払方法一覧

setTel

public void setTel(String strTel)
取引先での記帳担当者電話番号を設定します。

パラメータ:
strTel - 取引先での記帳担当者電話番号

getCustomer

public String getCustomer()
得意先コードを取得します

戻り値:
得意先コード

setCustomer

public void setCustomer(String string)
得意先コードを設定します

パラメータ:
string - 得意先コード

getActAtCus

public String getActAtCus()
得意先での自社勘定コードを取得します。

戻り値:
得意先での自社勘定コード

getAltPayer

public String getAltPayer()
代理支払人の勘定コードを取得します。

戻り値:
代理支払人の勘定コード

getBuyingGrp

public String getBuyingGrp()
購買グループの勘定コードを取得します。

戻り値:
購買グループの勘定コード

getNextPayee

public String getNextPayee()
次受取人を取得します。

戻り値:
次受取人

setActAtCus

public void setActAtCus(String string)
得意先での自社勘定コードを設定します。

パラメータ:
string - 得意先での自社勘定コード

setAltPayer

public void setAltPayer(String string)
代理支払人の勘定コードを設定します。

パラメータ:
string - 代理支払人の勘定コード

setBuyingGrp

public void setBuyingGrp(String string)
購買グループの勘定コードを設定します。

パラメータ:
string - 購買グループの勘定コード

setNextPayee

public void setNextPayee(String string)
次受取人を設定します。

パラメータ:
string - 次受取人

getCustUser

public String getCustUser()
得意先担当者を取得します。

戻り値:
得意先担当者

setCustUser

public void setCustUser(String string)
得意先担当者を設定します。

パラメータ:
string - 得意先担当者

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GeneralDataInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.model
クラス GeneralDataInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
VendorAddress
public class GeneralDataInfo
extends Object
implements Serializable

一般データ情報クラス
機能は以下の通り

  • 一般データの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GeneralDataInfo()
一般データ情報を作成します。
メソッドの概要
String | getCity() 市区町村を取得します。
String | getCityCode() 市区町村コードを取得します
String | getCountry() 国コードを取得します。
String | getCountryiso() ISO 国コードを取得します。
String | getCountycode() 地域コードを取得します
String | getCustomer() 得意先コードを取得します
String | getDistrict() 所在地を取得します。
String | getFax1() FAX 1を取得します｡
String | getFormofaddr() 敬称を取得します。
String | getLangu() 言語キーを取得します。
String | getLanguIso() ISO 639 準拠の言語を取得します。
String | getName_2() 名称 2を取得します。
String | getName_3() 名称 3を取得します。
String | getName_4() 名称 4を取得します。
String | getName() 名称 1を取得します。
String | getPoBox() 私書箱を取得します。
String | getPobxCty() 私書箱住所を取得します。
String | getPobxPcd() 私書箱番号を取得します。
String | getPostlCode() 郵便番号を取得します。
String | getRegion() 地域 (都道府県)を取得します。
String | getStreet() 地名/番地-号を取得します。
String | getTelephone() 電話番号 1を取得します。
String | getTelephone2() 電話番号 2を取得します。
String | getVendor() 仕入先または債権者の勘定コードを取得します。
void | setCity(String strCity) 市区町村を設定します。
void | setCityCode(String string) 市区町村コードを設定します
void | setCountry(String strCountry) 国コードを設定します。
void | setCountryiso(String strCountryiso) ISO 国コードを設定します。
void | setCountycode(String string) 地域コードを設定します
void | setCustomer(String string) 得意先コードを設定します
void | setDistrict(String strDistrict) 所在地を設定します。
void | setFax1(String strFax1) FAX 1を設定します｡
void | setFormofaddr(String strFormofaddr) 敬称を設定します。
void | setLangu(String strLangu) 言語キーを設定します。
void | setLanguIso(String strLanguIso) ISO 639 準拠の言語を設定します。
void | setName_2(String strName2) 名称 2を設定します。
void | setName_3(String strName3) 名称 3を設定します。
void | setName_4(String strName4) 名称 4を設定します。
void | setName(String strName) 名称 1を設定します。
void | setPoBox(String strPoBox) 私書箱を設定します。
void | setPobxCty(String strPobxCty) 私書箱住所を設定します。
void | setPobxPcd(String strPobxPcd) 私書箱番号を設定します。
void | setPostlCode(String strPostlCode) 郵便番号を設定します。
void | setRegion(String strRegion) 地域 (都道府県)を設定します。
void | setStreet(String strStreet) 地名/番地-号を設定します。
void | setTelephone(String strTelephone) 電話番号 1を設定します。
void | setTelephone2(String strTelephone2) 電話番号 2を設定します。
void | setVendor(String strVendor) 仕入先または債権者の勘定コードを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GeneralDataInfo

public GeneralDataInfo()
一般データ情報を作成します。

メソッドの詳細

getVendor

public String getVendor()
仕入先または債権者の勘定コードを取得します。

戻り値:
ｓｔｒVendor

getName

public String getName()
名称 1を取得します。

戻り値:
ｓｔｒName

getName_2

public String getName_2()
名称 2を取得します。

戻り値:
ｓｔｒName2

getName_3

public String getName_3()
名称 3を取得します。

戻り値:
ｓｔｒName3

getName_4

public String getName_4()
名称 4を取得します。

戻り値:
ｓｔｒName4

getCity

public String getCity()
市区町村を取得します。

戻り値:
ｓｔｒCity

getDistrict

public String getDistrict()
所在地を取得します。

戻り値:
ｓｔｒDistrict

getPoBox

public String getPoBox()
私書箱を取得します。

戻り値:
ｓｔｒPoBox

getPobxPcd

public String getPobxPcd()
私書箱番号を取得します。

戻り値:
ｓｔｒPobxPcd

getPostlCode

public String getPostlCode()
郵便番号を取得します。

戻り値:
ｓｔｒPostlCode

getRegion

public String getRegion()
地域 (都道府県)を取得します。

戻り値:
ｓｔｒRegion

getStreet

public String getStreet()
地名/番地-号を取得します。

戻り値:
ｓｔｒStreet

getCountry

public String getCountry()
国コードを取得します。

戻り値:
ｓｔｒCountry

getCountryiso

public String getCountryiso()
ISO 国コードを取得します。

戻り値:
ｓｔｒCountryiso

getPobxCty

public String getPobxCty()
私書箱住所を取得します。

戻り値:
ｓｔｒPobxCty

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
ｓｔｒLangu

getLanguIso

public String getLanguIso()
ISO 639 準拠の言語を取得します。

戻り値:
ｓｔｒLanguIso

getTelephone

public String getTelephone()
電話番号 1を取得します。

戻り値:
ｓｔｒTelephone

getFormofaddr

public String getFormofaddr()
敬称を取得します。

戻り値:
ｓｔｒFormofaddr

getTelephone2

public String getTelephone2()
電話番号 2を取得します。

戻り値:
ｓｔｒTelephone2

getFax1

public String getFax1()
FAX 1を取得します｡

戻り値:
strFax1

setVendor

public void setVendor(String strVendor)
仕入先または債権者の勘定コードを設定します。

パラメータ:
strVendor - 仕入先または債権者の勘定コード

setName

public void setName(String strName)
名称 1を設定します。

パラメータ:
strName - 名称 1

setName_2

public void setName_2(String strName2)
名称 2を設定します。

パラメータ:
strName2 - 名称 2

setName_3

public void setName_3(String strName3)
名称 3を設定します。

パラメータ:
strName3 - 名称 3

setName_4

public void setName_4(String strName4)
名称 4を設定します。

パラメータ:
strName4 - 名称 4

setCity

public void setCity(String strCity)
市区町村を設定します。

パラメータ:
strCity - 市区町村

setDistrict

public void setDistrict(String strDistrict)
所在地を設定します。

パラメータ:
strDistrict - 所在地

setPoBox

public void setPoBox(String strPoBox)
私書箱を設定します。

パラメータ:
strPoBox - 私書箱

setPobxPcd

public void setPobxPcd(String strPobxPcd)
私書箱番号を設定します。

パラメータ:
strPobxPcd - 私書箱番号

setPostlCode

public void setPostlCode(String strPostlCode)
郵便番号を設定します。

パラメータ:
strPostlCode - 郵便番号

setRegion

public void setRegion(String strRegion)
地域 (都道府県)を設定します。

パラメータ:
strRegion - 地域 (都道府県)

setStreet

public void setStreet(String strStreet)
地名/番地-号を設定します。

パラメータ:
strStreet - 地名/番地-号

setCountry

public void setCountry(String strCountry)
国コードを設定します。

パラメータ:
strCountry - 国コード

setCountryiso

public void setCountryiso(String strCountryiso)
ISO 国コードを設定します。

パラメータ:
strCountryiso - SO 国コード

setPobxCty

public void setPobxCty(String strPobxCty)
私書箱住所を設定します。

パラメータ:
strPobxCty - 私書箱住所

setLangu

public void setLangu(String strLangu)
言語キーを設定します。

パラメータ:
strLangu - 言語キー

setLanguIso

public void setLanguIso(String strLanguIso)
ISO 639 準拠の言語を設定します。

パラメータ:
strLanguIso - ISO 639 準拠の言語

setTelephone

public void setTelephone(String strTelephone)
電話番号 1を設定します。

パラメータ:
strTelephone - 電話番号 1

setFormofaddr

public void setFormofaddr(String strFormofaddr)
敬称を設定します。

パラメータ:
strFormofaddr - 敬称

setTelephone2

public void setTelephone2(String strTelephone2)
電話番号 2を設定します。

パラメータ:
strTelephone2 - 電話番号 2

setFax1

public void setFax1(String strFax1)
FAX 1を設定します｡

パラメータ:
strFax1 - FAX 1

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値

getCityCode

public String getCityCode()
市区町村コードを取得します

戻り値:
市区町村コード

getCountycode

public String getCountycode()
地域コードを取得します

戻り値:
地域コード

getCustomer

public String getCustomer()
得意先コードを取得します

戻り値:
得意先コード

setCityCode

public void setCityCode(String string)
市区町村コードを設定します

パラメータ:
string - 市区町村コード

setCountycode

public void setCountycode(String string)
地域コードを設定します

パラメータ:
string - 地域コード

setCustomer

public void setCustomer(String string)
得意先コードを設定します

パラメータ:
string - 得意先コード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.common.model (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.common.model
クラス
BankDataInfo
CompanyDataInfo
GeneralDataInfo


jp.co.intra_mart.foundation.sap.common.model (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.model

クラスの概要
BankDataInfo | 銀行データ情報クラス 機能は以下の通り 銀行データの情報を保持します。
CompanyDataInfo | 会社コード依存データ情報クラス 機能は以下の通り 会社コード依存データの情報を保持します。
GeneralDataInfo | 一般データ情報クラス 機能は以下の通り 一般データの情報を保持します。


jp.co.intra_mart.foundation.sap.common.model クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.model の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.common.model の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.model の使用

jp.co.intra_mart.foundation.sap.common.model を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial | ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial により使用される jp.co.intra_mart.foundation.sap.common.model のクラス
CompanyDataInfo
会社コード依存データ情報クラス
機能は以下の通り
会社コード依存データの情報を保持します。
GeneralDataInfo
一般データ情報クラス
機能は以下の通り
一般データの情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.common.model のクラス
CompanyDataInfo
会社コード依存データ情報クラス
機能は以下の通り
会社コード依存データの情報を保持します。
GeneralDataInfo
一般データ情報クラス
機能は以下の通り
一般データの情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.util.PropertyDescriptorBox の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.util.PropertyDescriptorBox の使用

jp.co.intra_mart.foundation.sap.common.util.PropertyDescriptorBox はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.util.data.Convertor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.util.data.Convertor の使用

jp.co.intra_mart.foundation.sap.common.util.data.Convertor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.util.data.ExtendedParamConverter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.util.data.ExtendedParamConverter の使用

jp.co.intra_mart.foundation.sap.common.util.data.ExtendedParamConverter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter の使用

ParamConverter を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.util.data ＳＡＰ連携にて使用するデータ変換クラスを提供します。

jp.co.intra_mart.foundation.sap.common.util.data での ParamConverter の使用

jp.co.intra_mart.foundation.sap.common.util.data での ParamConverter のサブクラス
 class ExtendedParamConverter
共通APIのパラメータ変換クラス２。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Convertor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.util.data
クラス Convertor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.util.data.Convertor
すべての実装インタフェース:
Serializable
public final class Convertor
extends Object
implements Serializable

Converterクラス
機能は以下の通り

  • SAPリアルタイム連携APIにて使用するデータ変換機能を提供します。

関連項目:
直列化された形式

メソッドの概要
static String convJCOdata(int typ, int len, Object val)
BAPIパラメータに設定する値でパラメータ属性が"JCO.TYPE_NUM"の場合は 0パディングした文字列を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

convJCOdata

public static String convJCOdata(int typ,
                                 int len,
                                 Object val)
                          throws SAPGeneralSystemException
BAPIパラメータに設定する値でパラメータ属性が"JCO.TYPE_NUM"の場合は 0パディングした文字列を返します。それ以外のパラメータ属性の場合は無変換で 文字列を返します｡
ただし、valがnullの場合、nullを返却します。

パラメータ:
typ - 設定する項目の属性
len - 設定する項目の項目長
val - 変換対象オブジェクト
戻り値:
retVal 変換後文字列
例外:
SAPGeneralSystemException - システム例外処理
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedParamConverter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.util.data
クラス ExtendedParamConverter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter
        拡張 jp.co.intra_mart.foundation.sap.common.util.data.ExtendedParamConverter
すべての実装インタフェース:
Serializable
public final class ExtendedParamConverter
extends ParamConverter
implements Serializable

共通APIのパラメータ変換クラス２。
機能は以下の通り。

  • 共通APIのパラメータの項目、値を変換します。

関連項目:
直列化された形式

メソッドの概要
static String | changeParam(String param) 入力された項目名を変換します。
static String | changeToUpperParam(String param, String propertyName, String paramType) 入力された項目名をプロパティファイルの項目名に変換します。
static boolean | ioInvoke(Object obj, String paramName, String value, PropertyDescriptor[] props) パラメータ名からsetterメソッドを取得し、値をセットします。
クラス jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter から継承したメソッド
changeToUpperParam, checkFlg, checkNull
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

changeParam

public static String changeParam(String param)
入力された項目名を変換します。
例）COMP_CODE → compCode

ParamConverterのchangeParamとの相違点は以下の通り。

例）COMP_CODE2（Bapi項目名に数字が含まれている場合）。
ParamConverterの場合　 COMP_CODE2 → compCode_2
ParamConverter2の場合　COMP_CODE2 → compCode2

パラメータ:
param - 入力された項目名
戻り値:
string 変換された項目名

ioInvoke

public static boolean ioInvoke(Object obj,
                               String paramName,
                               String value,
                               PropertyDescriptor[] props)
パラメータ名からsetterメソッドを取得し、値をセットします。

ParamConverterのioInvokeとの相違点は以下の通り。

例）COMP_CODE2（Bapi項目名に数字が含まれている場合）
ParamConverterの場合　 COMP_CODE2 → setCompCode_2
ParamConverter2の場合　COMP_CODE2 → setCompCode2

パラメータ:
obj - 項目をセットするオブジェクト
paramName - 項目名
value - セットする値
props - プロパティ情報
戻り値:
boolean セット可否

changeToUpperParam

public static String changeToUpperParam(String param,
                                        String propertyName,
                                        String paramType)
                                 throws SAPAuthSystemException,
                                        SAPGeneralSystemException,
                                        SAPGeneralAppException
入力された項目名をプロパティファイルの項目名に変換します。

ParamConverterのchangeToUpperParamとの相違点は以下の通り。

ParamConverterの場合 文字操作による文字変換
ParamConverter2の場合 プロパティファイルの項目名へ文字変換

パラメータ:
param - String 変換する項目名
propertyName - String 検索するプロパティファイル名
paramType - String 検索するパラメータ属性(structure)
戻り値:
string 変換された項目名
例外:
SAPAuthSystemException
SAPAuthSystemException
SAPGeneralSystemException
SAPGeneralAppException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.common.util.data (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.common.util.data
クラス
Convertor
ExtendedParamConverter
ParamConverter


jp.co.intra_mart.foundation.sap.common.util.data (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.data

ＳＡＰ連携にて使用するデータ変換クラスを提供します。

参照:
説明

クラスの概要
Convertor | Converterクラス 機能は以下の通り SAPリアルタイム連携APIにて使用するデータ変換機能を提供します。
ExtendedParamConverter | 共通APIのパラメータ変換クラス２。
ParamConverter | パラメータ変換クラス 機能は以下の通り パラメータの項目、値を変換します。

パッケージ jp.co.intra_mart.foundation.sap.common.util.data の説明

ＳＡＰ連携にて使用するデータ変換クラスを提供します。


jp.co.intra_mart.foundation.sap.common.util.data クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.data の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.common.util.data.Convertor (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.common.util.data.ExtendedParamConverter (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.common.util.data の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.util.data の使用

jp.co.intra_mart.foundation.sap.common.util.data を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.util.data ＳＡＰ連携にて使用するデータ変換クラスを提供します。

jp.co.intra_mart.foundation.sap.common.util.data により使用される jp.co.intra_mart.foundation.sap.common.util.data のクラス
ParamConverter
パラメータ変換クラス
機能は以下の通り
パラメータの項目、値を変換します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamConverter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.util.data
クラス ParamConverter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ExtendedParamConverter
public class ParamConverter
extends Object
implements Serializable

パラメータ変換クラス
機能は以下の通り

  • パラメータの項目、値を変換します。

関連項目:
直列化された形式

コンストラクタの概要
protected ParamConverter()
ParamConvertorのコンストラクタを呼び出し
メソッドの概要
static String | changeParam(String param) 入力された項目名を変換します。
static String | changeToUpperParam(String param) 入力された項目名を変換します。
static String | checkFlg(String param) 項目に値が入っているかチェックします。
static String | checkNull(String string) 項目がnullかどうかチェックします。
static boolean | ioInvoke(Object obj, String paramName, String value, PropertyDescriptor[] props) パラメータ名からsetterメソッドを取得し、値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ParamConverter

protected ParamConverter()
ParamConvertorのコンストラクタを呼び出し

メソッドの詳細

checkNull

public static String checkNull(String string)
項目がnullかどうかチェックします。

パラメータ:
string - 項目の値
戻り値:
string 値有：X 値無：ブランク

checkFlg

public static String checkFlg(String param)
項目に値が入っているかチェックします。

パラメータ:
param - 項目の値
戻り値:
string 値有：X 値無：ブランク

changeParam

public static String changeParam(String param)
入力された項目名を変換します。 例）COMP_CODE → compCode

パラメータ:
param - 入力された項目名
戻り値:
string 変換された項目名

changeToUpperParam

public static String changeToUpperParam(String param)
入力された項目名を変換します。 例）compCode → COMP_CODE

パラメータ:
param - 入力された項目名
戻り値:
string 変換された項目名

ioInvoke

public static boolean ioInvoke(Object obj,
                               String paramName,
                               String value,
                               PropertyDescriptor[] props)
パラメータ名からsetterメソッドを取得し、値をセットします。

パラメータ:
obj - 項目をセットするオブジェクト
paramName - 項目名
value - セットする値
props - プロパティ情報
戻り値:
boolean セット可否
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.common.util.date.DateHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.util.date.DateHandler の使用

jp.co.intra_mart.foundation.sap.common.util.date.DateHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DateHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.util.date
クラス DateHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.util.date.DateHandler
すべての実装インタフェース:
Serializable
public final class DateHandler
extends Object
implements Serializable

DateHandlerクラス
機能は以下の通り

  • SAPリアルタイム連携APIにて使用する共通Date関連機能を提供します。

関連項目:
直列化された形式

メソッドの概要
static Date | getDateValue(String strValue) 日付書式[YYYYMMDD]の文字列をDate型に変換します。
static String | getStringDate(Date date) Date型オブジェクトを日付書式[YYYYMMDD]の文字列に変換して返します。
static String | getSysdate() システム日付を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getSysdate

public static String getSysdate()
システム日付を取得します。

戻り値:
nowDate システム日付[YYYYMMDD]

getStringDate

public static String getStringDate(Date date)
Date型オブジェクトを日付書式[YYYYMMDD]の文字列に変換して返します。

パラメータ:
date - 日付書式変換前Date型オブジェクト
戻り値:
date 日付書式変換後文字列[YYYYMMDD]

getDateValue

public static Date getDateValue(String strValue)
                         throws ParseException
日付書式[YYYYMMDD]の文字列をDate型に変換します。

パラメータ:
strValue - 日付書式[YYYYMMDD]の文字列
戻り値:
dateValue Date型に変換後の値
例外:
ParseException - 日付変換システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.common.util.date (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.common.util.date
クラス
DateHandler


jp.co.intra_mart.foundation.sap.common.util.date (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.date

ＳＡＰ連携にて使用する日付操作クラスを提供します。

参照:
説明

クラスの概要
DateHandler DateHandlerクラス
機能は以下の通り
SAPリアルタイム連携APIにて使用する共通Date関連機能を提供します。

パッケージ jp.co.intra_mart.foundation.sap.common.util.date の説明

ＳＡＰ連携にて使用する日付操作クラスを提供します。


jp.co.intra_mart.foundation.sap.common.util.date クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.date の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.common.util.date.DateHandler (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.common.util.date の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.util.date の使用

jp.co.intra_mart.foundation.sap.common.util.date はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile の使用

jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.common.util.file (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.common.util.file
クラス
PropertiesFile


jp.co.intra_mart.foundation.sap.common.util.file (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.file

ＳＡＰ連携にて使用するプロパティを操作するクラスを提供します。

参照:
説明

クラスの概要
PropertiesFile プロパティファイルクラス
機能は以下の通り
ファイル名を指定してプロパティファイルを呼び出します。

パッケージ jp.co.intra_mart.foundation.sap.common.util.file の説明

ＳＡＰ連携にて使用するプロパティを操作するクラスを提供します。


jp.co.intra_mart.foundation.sap.common.util.file クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.file の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.common.util.file の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.util.file の使用

jp.co.intra_mart.foundation.sap.common.util.file はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PropertiesFile (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.util.file
クラス PropertiesFile

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile
すべての実装インタフェース:
Serializable
public class PropertiesFile
extends Object
implements Serializable

プロパティファイルクラス
機能は以下の通り

  • ファイル名を指定してプロパティファイルを呼び出します。

関連項目:
直列化された形式

コンストラクタの概要
PropertiesFile(String fileName)
ファイル名を指定してプロパティファイルを取得します。
メソッドの概要
Properties | getProperties() プロパティを取得します｡
void | setPropeties(Properties properties) プロパティを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PropertiesFile

public PropertiesFile(String fileName)
               throws SAPAuthSystemException
ファイル名を指定してプロパティファイルを取得します。

パラメータ:
fileName - ファイル名
例外:
SAPAuthSystemException - 認証系システム例外
メソッドの詳細

setPropeties

public void setPropeties(Properties properties)
プロパティを設定します｡

パラメータ:
properties - プロパティ

getProperties

public Properties getProperties()
プロパティを取得します｡

戻り値:
properties

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle の使用

jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.common.util.message (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.common.util.message
クラス
SAPConnectorMessageBundle


jp.co.intra_mart.foundation.sap.common.util.message (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.message

クラスの概要
SAPConnectorMessageBundle SAPリアルタイム連携APIメッセージリソースクラス


jp.co.intra_mart.foundation.sap.common.util.message クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.message の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle


パッケージ jp.co.intra_mart.foundation.sap.common.util.message の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.util.message の使用

jp.co.intra_mart.foundation.sap.common.util.message はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SAPConnectorMessageBundle (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.util.message
クラス SAPConnectorMessageBundle

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle
public class SAPConnectorMessageBundle
extends Object

SAPリアルタイム連携APIメッセージリソースクラス

メソッドの概要
static String | getMessage(Locale locale, String key) SAPリアルタイム連携APIメッセージを取得します。
static String | getMessage(Locale locale, String key, String arg) 置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
static String | getMessage(Locale locale, String key, String[] args) 置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
static String | getMessage(Locale locale, String key, String arg1, String arg2) 置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
static String | getMessage(Locale locale, String key, String arg1, String arg2, String arg3) 置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
static String | getMessage(String key) SAPリアルタイム連携APIメッセージを取得します。
static String | getMessage(String key, String arg) 置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
static String | getMessage(String key, String[] args) 置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
static String | getMessage(String key, String arg1, String arg2) 置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
static String | getMessage(String key, String arg1, String arg2, String arg3) 置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getMessage

public static String getMessage(Locale locale,
                                String key)
SAPリアルタイム連携APIメッセージを取得します。

パラメータ:
locale - ロケール
key - メッセージID
戻り値:
SAPリアルタイム連携APIメッセージ

getMessage

public static String getMessage(Locale locale,
                                String key,
                                String arg)
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
locale - ロケール
key - メッセージID
arg - 置換文字列
戻り値:
置換文字列を挿入したSAPリアルタイム連携APIメッセージ

getMessage

public static String getMessage(Locale locale,
                                String key,
                                String arg1,
                                String arg2)
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
locale - ロケール
key - メッセージID
arg1 - 置換文字列1
arg2 - 置換文字列2
戻り値:
置換文字列を挿入したSAPリアルタイム連携APIメッセージ

getMessage

public static String getMessage(Locale locale,
                                String key,
                                String arg1,
                                String arg2,
                                String arg3)
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
locale - ロケール
key - メッセージID
arg1 - 置換文字列1
arg2 - 置換文字列2
arg3 - 置換文字列3
戻り値:
置換文字列を挿入したSAPリアルタイム連携APIメッセージ

getMessage

public static String getMessage(Locale locale,
                                String key,
                                String[] args)
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
locale - ロケール
key - メッセージID
args - 置換文字列の配列
戻り値:
置換文字列を挿入したSAPリアルタイム連携APIメッセージ

getMessage

public static String getMessage(String key)
SAPリアルタイム連携APIメッセージを取得します。

パラメータ:
key - メッセージID
戻り値:
SAPリアルタイム連携APIメッセージ

getMessage

public static String getMessage(String key,
                                String arg)
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
key - メッセージID
arg - 置換文字列
戻り値:
置換文字列を挿入したSAPリアルタイム連携APIメッセージ

getMessage

public static String getMessage(String key,
                                String arg1,
                                String arg2)
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
key - メッセージID
arg1 - 置換文字列1
arg2 - 置換文字列2
戻り値:
置換文字列を挿入したSAPリアルタイム連携APIメッセージ

getMessage

public static String getMessage(String key,
                                String arg1,
                                String arg2,
                                String arg3)
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
key - メッセージID
arg1 - 置換文字列1
arg2 - 置換文字列2
arg3 - 置換文字列3
戻り値:
置換文字列を挿入したSAPリアルタイム連携APIメッセージ

getMessage

public static String getMessage(String key,
                                String[] args)
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
key - メッセージID
args - 置換文字列の配列
戻り値:
置換文字列を挿入したSAPリアルタイム連携APIメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.common.util (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.common.util
クラス
PropertyDescriptorBox


jp.co.intra_mart.foundation.sap.common.util (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util

クラスの概要
PropertyDescriptorBox JavaBeansクラスから取得するPropertyDescriptorをキャッシュするためのクラスです。


jp.co.intra_mart.foundation.sap.common.util クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.common.util.PropertyDescriptorBox


パッケージ jp.co.intra_mart.foundation.sap.common.util の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.util の使用

jp.co.intra_mart.foundation.sap.common.util はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PropertyDescriptorBox (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.util
クラス PropertyDescriptorBox

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.util.PropertyDescriptorBox
public class PropertyDescriptorBox
extends Object

JavaBeansクラスから取得するPropertyDescriptorをキャッシュするためのクラスです。

メソッドの概要
static void | clear() キャッシュしたPropertyDescriptorをクリアします。
static PropertyDescriptor[] | getPropertyDescriptor(Object beanObject) 引数JavaBeansオブジェクトのPropertyDescriptor[]を取得します。
static PropertyDescriptor[] | getPropertyDescriptor(String beanClassPath) 引数JavaBeansクラス名からPropertyDescriptor[]を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getPropertyDescriptor

public static PropertyDescriptor[] getPropertyDescriptor(String beanClassPath)
                                                  throws IntrospectionException,
                                                         ClassNotFoundException
引数JavaBeansクラス名からPropertyDescriptor[]を取得します。

パラメータ:
beanClassPath - JavaBeansクラス名
戻り値:
引数beanClassPathで指定したJavaBeansクラス名のPropertyDescriptor[]
例外:
IntrospectionException - イントロスペクション中に例外が発生した場合にスローされます。
ClassNotFoundException - 引数で指定したクラスが見つからない場合にスローされます。

getPropertyDescriptor

public static PropertyDescriptor[] getPropertyDescriptor(Object beanObject)
                                                  throws IntrospectionException
引数JavaBeansオブジェクトのPropertyDescriptor[]を取得します。

パラメータ:
beanObject - PropertyDescriptor[]を取得したい BeanObject
戻り値:
引数JavaBeansオブジェクトのPropertyDescriptor[]
例外:
IntrospectionException - イントロスペクション中に例外が発生した場合にスローされます。

clear

public static void clear()
キャッシュしたPropertyDescriptorをクリアします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController の使用

jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountGl の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.AccountGl の使用

jp.co.intra_mart.foundation.sap.module.accounting.AccountGl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable の使用

jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountTax の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.AccountTax の使用

jp.co.intra_mart.foundation.sap.module.accounting.AccountTax はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.Bank の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.Bank の使用

jp.co.intra_mart.foundation.sap.module.accounting.Bank はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.BankController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.BankController の使用

jp.co.intra_mart.foundation.sap.module.accounting.BankController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.BankList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.BankList の使用

BankList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での BankList の使用

BankList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 BankList BankController.getBaList()
銀行一覧を取得します｡

BankList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void BankController.setBaList(BankList baList)
銀行一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea の使用

jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController の使用

jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList の使用

BusinessAreaList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での BusinessAreaList の使用

BusinessAreaList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 BusinessAreaList BusinessAreaController.getBusAreaList()
事業領域一覧を取得します｡

BusinessAreaList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void BusinessAreaController.setBusAreaList(BusinessAreaList busAreaList)
事業領域一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.Company の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.Company の使用

jp.co.intra_mart.foundation.sap.module.accounting.Company はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CompanyController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CompanyController の使用

jp.co.intra_mart.foundation.sap.module.accounting.CompanyController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CompanyList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CompanyList の使用

CompanyList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での CompanyList の使用

CompanyList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 CompanyList CompanyController.getCompList()
会社一覧を取得します｡

CompanyList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void CompanyController.setCompList(CompanyList compList)
会社一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea の使用

jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController の使用

jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList の使用

ControllingAreaList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での ControllingAreaList の使用

ControllingAreaList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 ControllingAreaList ControllingAreaController.getControllAreaList()
管理領域一覧を取得します｡

ControllingAreaList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void ControllingAreaController.setControllAreaList(ControllingAreaList controllAreaList)
管理領域一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CostCenter の使用

jp.co.intra_mart.foundation.sap.module.accounting.CostCenter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController の使用

jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList の使用

CostCenterList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での CostCenterList の使用

CostCenterList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 CostCenterList CostCenterController.getCostCentList()
原価センタ一覧を取得します｡

CostCenterList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void CostCenterController.setCostCentList(CostCenterList costCentList)
原価センタ一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount の使用

jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader の使用

DocumentHeader を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での DocumentHeader の使用

DocumentHeader を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 DocumentHeader AccEmployeePayPostController.getDocumentHeader()
伝票ヘッダを取得します｡

DocumentHeader 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void AccEmployeePayPostController.setDocumentHeader(DocumentHeader documentHeader)
伝票ヘッダを設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAcc の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.GlAcc の使用

jp.co.intra_mart.foundation.sap.module.accounting.GlAcc はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAccController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.GlAccController の使用

jp.co.intra_mart.foundation.sap.module.accounting.GlAccController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAccList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.GlAccList の使用

GlAccList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での GlAccList の使用

GlAccList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 GlAccList GlAccController.getGlList()
勘定科目一覧を取得します｡

GlAccList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void GlAccController.setGlList(GlAccList glList)
勘定科目一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter の使用

jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController の使用

jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList の使用

ProfitCenterList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での ProfitCenterList の使用

ProfitCenterList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 ProfitCenterList ProfitCenterController.getProfitCentList()
利益センタ一覧を取得します｡

ProfitCenterList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void ProfitCenterController.setProfitCentList(ProfitCenterList profitCentList)
利益センタ一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException の使用

SAPAccountingAppException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での SAPAccountingAppException の使用

SAPAccountingAppException をスローする jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void AccEmployeePayPostController.executeBapi()
BapiControllerにより会計伝票を登録します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException の使用

SAPAccountingSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での SAPAccountingSystemException の使用

SAPAccountingSystemException をスローする jp.co.intra_mart.foundation.sap.module.accounting のメソッド
String | ProfitCenterController.getValidTo(String profitCtr) 利益センタを指定して有効終了日を取得します。
String | ProfitCenterController.getPctrName(String profitCtr) 利益センタを指定して一般名称を取得します。
String | ProfitCenterController.getInCharge(String profitCtr) 利益センタを指定して利益センタ責任者を取得します。
String | GlAccController.getShortText(String glAccount) G/L勘定コードを指定してG/L勘定コードテキスト(短)を取得します。
String | GlAccController.getLongText(String glAccount) G/L勘定コードを指定して総勘定元帳勘定テキスト(長)を取得します。
String | CostCenterController.getName(String costCenter) 原価センタを指定して一般名称を取得します。
String | CostCenterController.getDescript(String costCenter) 原価センタを指定してテキストを取得します。
String | ControllingAreaController.getName(String coArea) 管理領域を指定して管理領域名を取得します。
String | CompanyController.getCompName(String compCode) 会社コードを指定して会社名を取得します。
String | BusinessAreaController.getBusArDes(String busArea) 事業領域を指定して事業領域名を取得します。
String | BankController.getBankName(String bankKey) 銀行コードを指定して銀行名を取得します。
String | BankController.getCity(String bankKey) 銀行コードを指定して市区町村名を取得します。
void | AccEmployeePayPostController.executeBapi() BapiControllerにより会計伝票を登録します。

SAPAccountingSystemException をスローする jp.co.intra_mart.foundation.sap.module.accounting のコンストラクタ
ProfitCenterList(String controllingArea, String date, SapClient sapClient)
executeBapiを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, SapClient sapClient)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date, SapClient sapClient)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
GlAccList(String companyCode, SapClient sapClient)
executeBapiを呼び出し勘定項目一覧を作成します。
GlAccController(String companyCode)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
GlAccController(String companyCode, SapClient sapClient)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
CostCenterList(String controllingArea, String date, SapClient sapClient)
executeBapiを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date, SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
ControllingAreaList(SapClient sapClient)
executeBapiを呼び出し管理領域一覧を作成します。
ControllingAreaController()
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
ControllingAreaController(SapClient sapClient)
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
CompanyList(SapClient sapClient)
executeBapiを呼び出し会社一覧を作成します。
CompanyController()
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
CompanyController(SapClient sapClient)
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
BusinessAreaList(SapClient sapClient)
executeBapiを呼び出し事業領域一覧を作成します。
BusinessAreaController()
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BusinessAreaController(SapClient sapClient)
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BankList(SapClient sapClient)
executeBapiを呼び出し銀行一覧を作成します。
BankController()
BankListのコンストラクタを呼び出し銀行一覧を作成します。
BankController(SapClient sapClient)
BankListのコンストラクタを呼び出し銀行一覧を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.accounting.exception (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.accounting.exception
例外
SAPAccountingAppException
SAPAccountingSystemException


jp.co.intra_mart.foundation.sap.module.accounting.exception (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.accounting.exception

ＳＡＰ連携財務会計系例外クラスを提供します。

参照:
説明

例外の概要
SAPAccountingAppException | p 会計系APIアプリケーション例外クラス
SAPAccountingSystemException | 会計系APIシステム例外クラス

パッケージ jp.co.intra_mart.foundation.sap.module.accounting.exception の説明

ＳＡＰ連携財務会計系例外クラスを提供します。


jp.co.intra_mart.foundation.sap.module.accounting.exception クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.accounting.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.common.exception.SAPException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
            • class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
            • class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException


パッケージ jp.co.intra_mart.foundation.sap.module.accounting.exception の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.accounting.exception の使用

jp.co.intra_mart.foundation.sap.module.accounting.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting により使用される jp.co.intra_mart.foundation.sap.module.accounting.exception のクラス
SAPAccountingAppException
p 会計系APIアプリケーション例外クラス
SAPAccountingSystemException
会計系APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SAPAccountingAppException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting.exception
クラス SAPAccountingAppException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
                    拡張 jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException
すべての実装インタフェース:
Serializable
public class SAPAccountingAppException
extends SAPModuleAppException

p 会計系APIアプリケーション例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPAccountingAppException(String message)
会計系APIアプリケーション例外
SAPAccountingAppException(String message, Throwable ex)
会計系APIアプリケーション例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPAccountingAppException

public SAPAccountingAppException(String message,
                                 Throwable ex)
会計系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPAccountingAppException

public SAPAccountingAppException(String message)
会計系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPAccountingSystemException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting.exception
クラス SAPAccountingSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
                    拡張 jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException
すべての実装インタフェース:
Serializable
public class SAPAccountingSystemException
extends SAPModuleSystemException

会計系APIシステム例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPAccountingSystemException(String message, Throwable ex)
会計系APIシステム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPAccountingSystemException

public SAPAccountingSystemException(String message,
                                    Throwable ex)
会計系APIシステム例外

パラメータ:
message - エラーメッセージ
ex - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccEmployeePayPostController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス AccEmployeePayPostController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController
すべての実装インタフェース:
Serializable
public class AccEmployeePayPostController
extends UpdateController
implements Serializable

伝票登録コントローラクラス
機能は以下の通り

  • 伝票を登録します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
AccEmployeePayPostController()
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、 明細通貨項目一覧を作成します｡
AccEmployeePayPostController(ConnectionManager connetionManager)
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

ConnectionManagerを使用することで、ConnectionManagerから トランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
AccEmployeePayPostController(SapClient sapClient)
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバへデータを登録することが可能です。
メソッドの概要
void | executeBapi() BapiControllerにより会計伝票を登録します。
ArrayList | getAccountGlList() G/L 勘定明細一覧を取得します｡
ArrayList | getAccountPayableList() 仕入先明細一覧を取得します｡
ArrayList | getAccountTaxList() 税明細一覧を取得します｡
ArrayList | getCurrencyAmountList() 明細通貨項目一覧を取得します｡
DocumentHeader | getDocumentHeader() 伝票ヘッダを取得します｡
void | setAccountGlList(ArrayList accountGlList) G/L 勘定明細一覧を設定します｡
void | setAccountPayableList(ArrayList accountPayableList) 仕入先明細一覧を設定します｡
void | setAccountTaxList(ArrayList accountTaxList) 税明細一覧を設定します｡
void | setCuAmtBase(String cuAmtBase, int index) 明細通貨項目の課税基準額に値を設定します。
void | setCuAmtDoccur(String cuAmtDoccur, int index) 明細通貨項目の伝票通貨額に値を設定します。
void | setCuCurrency(String cuCurrency, int index) 明細通貨項目の通貨コードに値を設定します。
void | setCuItemnoAcc(String cuItemnoAcc, int index) 明細通貨項目の会計伝票明細番号に値を設定します。
void | setCurrencyAmountList(ArrayList currencyAmountList) 明細通貨項目一覧を設定します｡
void | setDocAcDocNo(String docAcDocNo) 伝票ヘッダの会計伝票番号に値を設定します。
void | setDocCompCode(String docCompCode) 伝票ヘッダの会社コードに値を設定します。
void | setDocDocDate(String docDocDate) 伝票ヘッダの伝票の伝票日付に値を設定します。
void | setDocDocType(String docDocType) 伝票ヘッダの伝票タイプに値を設定します。
void | setDocFiscYear(String docFiscYear) 伝票ヘッダの会計年度に値を設定します。
void | setDocFisPeriod(String docFisPeriod) 伝票ヘッダの会計期間に値を設定します。
void | setDocHeaderTxt(String docHeaderTxt) 伝票ヘッダの伝票ヘッダテキストに値を設定します。
void | setDocObjKey(String docObjKey) 伝票ヘッダのオブジェクトキーに値を設定します。
void | setDocObjType(String docObjType) 伝票ヘッダの参照処理に値を設定します。
void | setDocPstngDate(String docPstngDate) 伝票ヘッダの伝票の転記日付に値を設定します。
void | setDocRefDocNo(String docRefDocNo) 伝票ヘッダの参照伝票番号に値を設定します。
void | setDocumentHeader(DocumentHeader documentHeader) 伝票ヘッダを設定します｡
void | setDocUsername(String docUsername) 伝票ヘッダのユーザ名に値を設定します。
void | setGlAllocNmbr(String glAllocNmbr, int index) G/L 勘定明細のソートキーに値を設定します。
void | setGlBusArea(String glBusArea, int index) G/L 勘定明細の事業領域に値を設定します。
void | setGlCompCode(String glCompCode, int index) G/L 勘定明細の会社コードに値を設定します。
void | setGlCostcenter(String glCostcenter, int index) G/L 勘定明細の原価センタに値を設定します。
void | setGlDocType(String glDocType, int index) G/L 勘定明細の伝票タイプに値を設定します。
void | setGlFiscYear(String glFiscYear, int index) G/L 勘定明細の会計年度に値を設定します。
void | setGlGlAccount(String glGlAccount, int index) G/L 勘定明細の総勘定元帳勘定に値を設定します。
void | setGlItemnoAcc(String glItemnoAcc, int index) G/L 勘定明細の会計伝票明細番号に値を設定します。
void | setGlItemText(String glItemText, int index) G/L 勘定明細の明細テキストに値を設定します。
void | setGlOrderid(String glOrderid, int index) G/L 勘定明細の指図番号に値を設定します。
void | setGlPstngDate(String glPstngDate, int index) G/L 勘定明細の伝票の転記日付に値を設定します。
void | setGlRefKey1(String glRefKey1, int index) G/L 勘定明細の取引先参照キーに値を設定します。
void | setGlTaxCode(String glTaxCode, int index) G/L 勘定明細の消費税コードに値を設定します。
void | setGlWbsElement(String glWbsElement, int index) G/L 勘定明細のWBS 要素に値を設定します。
void | setPaAllocNmbr(String paAllocNmbr, int index) 仕入先明細のソートキーに値を設定します。
void | setPaBlineDate(String paBlineDate, int index) 仕入先明細の期日計算の支払基準日に値を設定します。
void | setPaGlAccount(String paGlAccount, int index) 仕入先明細の総勘定元帳勘定に値を設定します。
void | setPaItemnoAcc(String paItemnoAcc, int index) 仕入先明細の会計伝票明細番号に値を設定します。
void | setPaItemText(String paItemText, int index) 仕入先明細の明細テキストに値を設定します。
void | setPaPymtMeth(String paPymtMeth, int index) 仕入先明細の支払方法に値を設定します。
void | setPaVendorNo(String paVendorNo, int index) 仕入先明細の仕入先または債権者の勘定コードに値を設定します。
void | setTaGlAccount(String taGlAccount, int index) 税明細の総勘定元帳勘定に値を設定します。
void | setTaItemnoAcc(String taItemnoAcc, int index) 税明細の会計伝票明細番号に値を設定します。
void | setTaTaxCode(String taTaxCode, int index) 税明細の消費税コードに値を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccEmployeePayPostController

public AccEmployeePayPostController()
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、 明細通貨項目一覧を作成します｡

AccEmployeePayPostController

public AccEmployeePayPostController(ConnectionManager connetionManager)
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

ConnectionManagerを使用することで、ConnectionManagerから トランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

パラメータ:
connetionManager - コネクションマネージャー

AccEmployeePayPostController

public AccEmployeePayPostController(SapClient sapClient)
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバへデータを登録することが可能です。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPAccountingAppException,
                        SAPAccountingSystemException
BapiControllerにより会計伝票を登録します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingAppException - 会計業務アプリケーション例外
SAPAccountingSystemException - 会計業務システム例外

setDocObjType

public void setDocObjType(String docObjType)
伝票ヘッダの参照処理に値を設定します。

パラメータ:
docObjType - 参照処理

setDocObjKey

public void setDocObjKey(String docObjKey)
伝票ヘッダのオブジェクトキーに値を設定します。

パラメータ:
docObjKey - オブジェクトキー

setDocUsername

public void setDocUsername(String docUsername)
伝票ヘッダのユーザ名に値を設定します。

パラメータ:
docUsername - ユーザ名

setDocHeaderTxt

public void setDocHeaderTxt(String docHeaderTxt)
伝票ヘッダの伝票ヘッダテキストに値を設定します。

パラメータ:
docHeaderTxt - 伝票ヘッダテキスト

setDocCompCode

public void setDocCompCode(String docCompCode)
伝票ヘッダの会社コードに値を設定します。

パラメータ:
docCompCode - 会社コード

setDocAcDocNo

public void setDocAcDocNo(String docAcDocNo)
伝票ヘッダの会計伝票番号に値を設定します。

パラメータ:
docAcDocNo - 会計伝票番号

setDocFiscYear

public void setDocFiscYear(String docFiscYear)
伝票ヘッダの会計年度に値を設定します。

パラメータ:
docFiscYear - 会計年度

setDocDocDate

public void setDocDocDate(String docDocDate)
伝票ヘッダの伝票の伝票日付に値を設定します。

パラメータ:
docDocDate - 伝票の伝票日付

setDocPstngDate

public void setDocPstngDate(String docPstngDate)
伝票ヘッダの伝票の転記日付に値を設定します。

パラメータ:
docPstngDate - 伝票の転記日付

setDocFisPeriod

public void setDocFisPeriod(String docFisPeriod)
伝票ヘッダの会計期間に値を設定します。

パラメータ:
docFisPeriod - 会計期間

setDocDocType

public void setDocDocType(String docDocType)
伝票ヘッダの伝票タイプに値を設定します。

パラメータ:
docDocType - 伝票タイプ

setDocRefDocNo

public void setDocRefDocNo(String docRefDocNo)
伝票ヘッダの参照伝票番号に値を設定します。

パラメータ:
docRefDocNo - 参照伝票番号

setPaItemnoAcc

public void setPaItemnoAcc(String paItemnoAcc,
                           int index)
仕入先明細の会計伝票明細番号に値を設定します。

パラメータ:
paItemnoAcc - 会計伝票明細番号
index - レコード番号

setPaVendorNo

public void setPaVendorNo(String paVendorNo,
                          int index)
仕入先明細の仕入先または債権者の勘定コードに値を設定します。

パラメータ:
paVendorNo - 仕入先または債権者の勘定コード
index - レコード番号

setPaGlAccount

public void setPaGlAccount(String paGlAccount,
                           int index)
仕入先明細の総勘定元帳勘定に値を設定します。

パラメータ:
paGlAccount - 総勘定元帳勘定
index - レコード番号

setPaBlineDate

public void setPaBlineDate(String paBlineDate,
                           int index)
仕入先明細の期日計算の支払基準日に値を設定します。

パラメータ:
paBlineDate - 期日計算の支払基準日
index - レコード番号

setPaPymtMeth

public void setPaPymtMeth(String paPymtMeth,
                          int index)
仕入先明細の支払方法に値を設定します。

パラメータ:
paPymtMeth - 支払方法
index - レコード番号

setPaAllocNmbr

public void setPaAllocNmbr(String paAllocNmbr,
                           int index)
仕入先明細のソートキーに値を設定します。

パラメータ:
paAllocNmbr - ソートキー
index - レコード番号

setPaItemText

public void setPaItemText(String paItemText,
                          int index)
仕入先明細の明細テキストに値を設定します。

パラメータ:
paItemText - 明細テキスト
index - レコード番号

setGlItemnoAcc

public void setGlItemnoAcc(String glItemnoAcc,
                           int index)
G/L 勘定明細の会計伝票明細番号に値を設定します。

パラメータ:
glItemnoAcc - 会計伝票明細番号
index - レコード番号

setGlGlAccount

public void setGlGlAccount(String glGlAccount,
                           int index)
G/L 勘定明細の総勘定元帳勘定に値を設定します。

パラメータ:
glGlAccount - 総勘定元帳勘定
index - レコード番号

setGlCompCode

public void setGlCompCode(String glCompCode,
                          int index)
G/L 勘定明細の会社コードに値を設定します。

パラメータ:
glCompCode - 会社コード
index - レコード番号

setGlPstngDate

public void setGlPstngDate(String glPstngDate,
                           int index)
G/L 勘定明細の伝票の転記日付に値を設定します。

パラメータ:
glPstngDate - 伝票の転記日付
index - レコード番号

setGlDocType

public void setGlDocType(String glDocType,
                         int index)
G/L 勘定明細の伝票タイプに値を設定します。

パラメータ:
glDocType - 伝票タイプ
index - レコード番号

setGlFiscYear

public void setGlFiscYear(String glFiscYear,
                          int index)
G/L 勘定明細の会計年度に値を設定します。

パラメータ:
glFiscYear - 会計年度
index - レコード番号

setGlRefKey1

public void setGlRefKey1(String glRefKey1,
                         int index)
G/L 勘定明細の取引先参照キーに値を設定します。

パラメータ:
glRefKey1 - 取引先参照キー
index - レコード番号

setGlItemText

public void setGlItemText(String glItemText,
                          int index)
G/L 勘定明細の明細テキストに値を設定します。

パラメータ:
glItemText - 明細テキスト
index - レコード番号

setGlTaxCode

public void setGlTaxCode(String glTaxCode,
                         int index)
G/L 勘定明細の消費税コードに値を設定します。

パラメータ:
glTaxCode - 消費税コード
index - レコード番号

setGlAllocNmbr

public void setGlAllocNmbr(String glAllocNmbr,
                           int index)
G/L 勘定明細のソートキーに値を設定します。

パラメータ:
glAllocNmbr - ソートキー
index - レコード番号

setGlBusArea

public void setGlBusArea(String glBusArea,
                         int index)
G/L 勘定明細の事業領域に値を設定します。

パラメータ:
glBusArea - 事業領域
index - レコード番号

setGlCostcenter

public void setGlCostcenter(String glCostcenter,
                            int index)
G/L 勘定明細の原価センタに値を設定します。

パラメータ:
glCostcenter - 原価センタ
index - レコード番号

setGlOrderid

public void setGlOrderid(String glOrderid,
                         int index)
G/L 勘定明細の指図番号に値を設定します。

パラメータ:
glOrderid - 指図番号
index - レコード番号

setGlWbsElement

public void setGlWbsElement(String glWbsElement,
                            int index)
G/L 勘定明細のWBS 要素に値を設定します。

パラメータ:
glWbsElement - WBS 要素
index - レコード番号

setTaItemnoAcc

public void setTaItemnoAcc(String taItemnoAcc,
                           int index)
税明細の会計伝票明細番号に値を設定します。

パラメータ:
taItemnoAcc - 会計伝票明細番号
index - レコード番号

setTaGlAccount

public void setTaGlAccount(String taGlAccount,
                           int index)
税明細の総勘定元帳勘定に値を設定します。

パラメータ:
taGlAccount - 総勘定元帳勘定
index - レコード番号

setTaTaxCode

public void setTaTaxCode(String taTaxCode,
                         int index)
税明細の消費税コードに値を設定します。

パラメータ:
taTaxCode - 消費税コード
index - レコード番号

setCuItemnoAcc

public void setCuItemnoAcc(String cuItemnoAcc,
                           int index)
明細通貨項目の会計伝票明細番号に値を設定します。

パラメータ:
cuItemnoAcc - 会計伝票明細番号
index - レコード番号

setCuCurrency

public void setCuCurrency(String cuCurrency,
                          int index)
明細通貨項目の通貨コードに値を設定します。

パラメータ:
cuCurrency - 通貨コード
index - レコード番号

setCuAmtDoccur

public void setCuAmtDoccur(String cuAmtDoccur,
                           int index)
明細通貨項目の伝票通貨額に値を設定します。

パラメータ:
cuAmtDoccur - 伝票通貨額
index - レコード番号

setCuAmtBase

public void setCuAmtBase(String cuAmtBase,
                         int index)
明細通貨項目の課税基準額に値を設定します。

パラメータ:
cuAmtBase - 課税基準額
index - レコード番号

setDocumentHeader

public void setDocumentHeader(DocumentHeader documentHeader)
伝票ヘッダを設定します｡

パラメータ:
documentHeader - 伝票ヘッダ

setAccountPayableList

public void setAccountPayableList(ArrayList accountPayableList)
仕入先明細一覧を設定します｡

パラメータ:
accountPayableList - 仕入先明細一覧

setAccountGlList

public void setAccountGlList(ArrayList accountGlList)
G/L 勘定明細一覧を設定します｡

パラメータ:
accountGlList - G/L 勘定明細一覧

setAccountTaxList

public void setAccountTaxList(ArrayList accountTaxList)
税明細一覧を設定します｡

パラメータ:
accountTaxList - 税明細一覧

setCurrencyAmountList

public void setCurrencyAmountList(ArrayList currencyAmountList)
明細通貨項目一覧を設定します｡

パラメータ:
currencyAmountList - 明細通貨項目一覧

getDocumentHeader

public DocumentHeader getDocumentHeader()
伝票ヘッダを取得します｡

戻り値:
documentHeader

getAccountPayableList

public ArrayList getAccountPayableList()
仕入先明細一覧を取得します｡

戻り値:
accountPayableList

getAccountGlList

public ArrayList getAccountGlList()
G/L 勘定明細一覧を取得します｡

戻り値:
accountGlList

getAccountTaxList

public ArrayList getAccountTaxList()
税明細一覧を取得します｡

戻り値:
accountTaxList

getCurrencyAmountList

public ArrayList getCurrencyAmountList()
明細通貨項目一覧を取得します｡

戻り値:
accountTaxList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccountGl (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス AccountGl

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.AccountGl
すべての実装インタフェース:
Serializable
public class AccountGl
extends Object
implements Serializable

G/L 勘定明細クラス
機能は以下の通り

  • G/L 勘定明細の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
AccountGl(int index)
G/L 勘定明細情報を作成します。
メソッドの概要
String | getGlAllocNmbr() ソートキーを取得します｡
String | getGlBusArea() 事業領域を取得します｡
String | getGlCompCode() 会社コードを取得します｡
String | getGlCostcenter() 原価センタを取得します｡
String | getGlDocType() 伝票タイプを取得します｡
String | getGlFiscYear() 会計年度を取得します｡
String | getGlGlAccount() 総勘定元帳勘定を取得します｡
int | getGlIndex() レコード番号を取得します｡
String | getGlItemnoAcc() 会計伝票明細番号を取得します｡
String | getGlItemText() 明細テキストを取得します｡
String | getGlOrderid() 指図番号を取得します｡
String | getGlPstngDate() 伝票の転記日付を取得します｡
String | getGlRefKey1() 取引先参照キーを取得します｡
String | getGlTaxCode() 消費税コードを取得します｡
String | getGlWbsElement() WBS 要素を取得します｡
void | setGlAllocNmbr(String glAllocNmbr) ソートキーコードを設定します｡
void | setGlBusArea(String glBusArea) 事業領域コードを設定します｡
void | setGlCompCode(String glCompCode) 会社コードコードを設定します｡
void | setGlCostcenter(String glCostcenter) 原価センタコードを設定します｡
void | setGlDocType(String glDocType) 伝票タイプコードを設定します｡
void | setGlFiscYear(String glFiscYear) 会計年度コードを設定します｡
void | setGlGlAccount(String glGlAccount) 総勘定元帳勘定コードを設定します｡
void | setGlIndex(int glIndex) レコード番号を設定します｡
void | setGlItemnoAcc(String glItemnoAcc) 会計伝票明細番号コードを設定します｡
void | setGlItemText(String glItemText) 明細テキストコードを設定します｡
void | setGlOrderid(String glOrderid) 指図番号コードを設定します｡
void | setGlPstngDate(String glPstngDate) 伝票の転記日付コードを設定します｡
void | setGlRefKey1(String glRefKey1) 取引先参照キーコードを設定します｡
void | setGlTaxCode(String glTaxCode) 消費税コードコードを設定します｡
void | setGlWbsElement(String glWbsElement) WBS 要素コードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccountGl

public AccountGl(int index)
G/L 勘定明細情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

setGlItemnoAcc

public void setGlItemnoAcc(String glItemnoAcc)
会計伝票明細番号コードを設定します｡

パラメータ:
glItemnoAcc - 会計伝票明細番号

setGlGlAccount

public void setGlGlAccount(String glGlAccount)
総勘定元帳勘定コードを設定します｡

パラメータ:
glGlAccount - 総勘定元帳勘定

setGlCompCode

public void setGlCompCode(String glCompCode)
会社コードコードを設定します｡

パラメータ:
glCompCode - 会社コード

setGlPstngDate

public void setGlPstngDate(String glPstngDate)
伝票の転記日付コードを設定します｡

パラメータ:
glPstngDate - 伝票の転記日付

setGlDocType

public void setGlDocType(String glDocType)
伝票タイプコードを設定します｡

パラメータ:
glDocType - 伝票タイプ

setGlFiscYear

public void setGlFiscYear(String glFiscYear)
会計年度コードを設定します｡

パラメータ:
glFiscYear - 会計年度

setGlRefKey1

public void setGlRefKey1(String glRefKey1)
取引先参照キーコードを設定します｡

パラメータ:
glRefKey1 - 取引先参照キー

setGlItemText

public void setGlItemText(String glItemText)
明細テキストコードを設定します｡

パラメータ:
glItemText - 明細テキスト

setGlTaxCode

public void setGlTaxCode(String glTaxCode)
消費税コードコードを設定します｡

パラメータ:
glTaxCode - 消費税コード

setGlAllocNmbr

public void setGlAllocNmbr(String glAllocNmbr)
ソートキーコードを設定します｡

パラメータ:
glAllocNmbr - ソートキー

setGlBusArea

public void setGlBusArea(String glBusArea)
事業領域コードを設定します｡

パラメータ:
glBusArea - 事業領域

setGlCostcenter

public void setGlCostcenter(String glCostcenter)
原価センタコードを設定します｡

パラメータ:
glCostcenter - 原価センタ

setGlOrderid

public void setGlOrderid(String glOrderid)
指図番号コードを設定します｡

パラメータ:
glOrderid - 指図番号

setGlWbsElement

public void setGlWbsElement(String glWbsElement)
WBS 要素コードを設定します｡

パラメータ:
glWbsElement - WBS 要素

setGlIndex

public void setGlIndex(int glIndex)
レコード番号を設定します｡

パラメータ:
glIndex - レコード番号

getGlItemnoAcc

public String getGlItemnoAcc()
会計伝票明細番号を取得します｡

戻り値:
glItemnoAcc

getGlGlAccount

public String getGlGlAccount()
総勘定元帳勘定を取得します｡

戻り値:
glGlAccount

getGlCompCode

public String getGlCompCode()
会社コードを取得します｡

戻り値:
glCompCode

getGlPstngDate

public String getGlPstngDate()
伝票の転記日付を取得します｡

戻り値:
glPstngDate

getGlDocType

public String getGlDocType()
伝票タイプを取得します｡

戻り値:
glDocType

getGlFiscYear

public String getGlFiscYear()
会計年度を取得します｡

戻り値:
glFiscYear

getGlRefKey1

public String getGlRefKey1()
取引先参照キーを取得します｡

戻り値:
glRefKey1

getGlItemText

public String getGlItemText()
明細テキストを取得します｡

戻り値:
glItemText

getGlTaxCode

public String getGlTaxCode()
消費税コードを取得します｡

戻り値:
glTaxCode

getGlAllocNmbr

public String getGlAllocNmbr()
ソートキーを取得します｡

戻り値:
glAllocNmbr

getGlBusArea

public String getGlBusArea()
事業領域を取得します｡

戻り値:
glBusArea

getGlCostcenter

public String getGlCostcenter()
原価センタを取得します｡

戻り値:
glCostcenter

getGlOrderid

public String getGlOrderid()
指図番号を取得します｡

戻り値:
glOrderid

getGlWbsElement

public String getGlWbsElement()
WBS 要素を取得します｡

戻り値:
glWbsElement

getGlIndex

public int getGlIndex()
レコード番号を取得します｡

戻り値:
giIndex

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountPayable (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス AccountPayable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable
すべての実装インタフェース:
Serializable
public class AccountPayable
extends Object
implements Serializable

仕入先明細クラス
機能は以下の通り

  • 仕入先明細の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
AccountPayable(int index)
仕入先明細情報を作成します。
メソッドの概要
String | getPaAllocNmbr() ソートキーを取得します｡
String | getPaBlineDate() 期日計算の支払基準日を取得します｡
String | getPaGlAccount() 総勘定元帳勘定を取得します｡
int | getPaIndex() レコード番号を取得します｡
String | getPaItemnoAcc() 会計伝票明細番号を取得します｡
String | getPaItemText() 明細テキストを取得します｡
String | getPaPymtMeth() 支払方法を取得します｡
String | getPaVendorNo() 仕入先または債権者の勘定コードを取得します｡
void | setPaAllocNmbr(String paAllocNmbr) ソートキーコードを設定します｡
void | setPaBlineDate(String paBlineDate) 期日計算の支払基準日コードを設定します｡
void | setPaGlAccount(String paGlAccount) 総勘定元帳勘定コードを設定します｡
void | setPaIndex(int paIndex) レコード番号を設定します｡
void | setPaItemnoAcc(String paItemnoAcc) 会計伝票明細番号コードを設定します｡
void | setPaItemText(String paItemText) 明細テキストコードを設定します｡
void | setPaPymtMeth(String paPymtMeth) 支払方法を設定します｡
void | setPaVendorNo(String paVendorNo) 仕入先または債権者の勘定コードコードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccountPayable

public AccountPayable(int index)
仕入先明細情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

setPaItemnoAcc

public void setPaItemnoAcc(String paItemnoAcc)
会計伝票明細番号コードを設定します｡

パラメータ:
paItemnoAcc - 会計伝票明細番号

setPaVendorNo

public void setPaVendorNo(String paVendorNo)
仕入先または債権者の勘定コードコードを設定します｡

パラメータ:
paVendorNo - 仕入先または債権者の勘定コード

setPaGlAccount

public void setPaGlAccount(String paGlAccount)
総勘定元帳勘定コードを設定します｡

パラメータ:
paGlAccount - 総勘定元帳勘定

setPaBlineDate

public void setPaBlineDate(String paBlineDate)
期日計算の支払基準日コードを設定します｡

パラメータ:
paBlineDate - 期日計算の支払基準日

setPaPymtMeth

public void setPaPymtMeth(String paPymtMeth)
支払方法を設定します｡

パラメータ:
paPymtMeth - 支払方法

setPaAllocNmbr

public void setPaAllocNmbr(String paAllocNmbr)
ソートキーコードを設定します｡

パラメータ:
paAllocNmbr - ソートキー

setPaItemText

public void setPaItemText(String paItemText)
明細テキストコードを設定します｡

パラメータ:
paItemText - 明細テキスト

setPaIndex

public void setPaIndex(int paIndex)
レコード番号を設定します｡

パラメータ:
paIndex - レコード番号

getPaItemnoAcc

public String getPaItemnoAcc()
会計伝票明細番号を取得します｡

戻り値:
paItemnoAcc

getPaVendorNo

public String getPaVendorNo()
仕入先または債権者の勘定コードを取得します｡

戻り値:
paVendorNo

getPaGlAccount

public String getPaGlAccount()
総勘定元帳勘定を取得します｡

戻り値:
paGlAccount

getPaBlineDate

public String getPaBlineDate()
期日計算の支払基準日を取得します｡

戻り値:
paBlineDate

getPaPymtMeth

public String getPaPymtMeth()
支払方法を取得します｡

戻り値:
paPymtMeth

getPaAllocNmbr

public String getPaAllocNmbr()
ソートキーを取得します｡

戻り値:
paAllocNmbr

getPaItemText

public String getPaItemText()
明細テキストを取得します｡

戻り値:
paItemText

getPaIndex

public int getPaIndex()
レコード番号を取得します｡

戻り値:
paIndex

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountTax (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス AccountTax

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.AccountTax
すべての実装インタフェース:
Serializable
public class AccountTax
extends Object
implements Serializable

税明細クラス
機能は以下の通り

  • 税明細の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
AccountTax(int index)
指定されたレコード番号でAccountTaxを作成します｡
メソッドの概要
String | getTaGlAccount() 総勘定元帳勘定を取得します｡
int | getTaIndex() レコード番号を取得します｡
String | getTaItemnoAcc() 会計伝票明細番号を取得します｡
String | getTaTaxCode() 消費税コードを取得します｡
void | setTaGlAccount(String taGlAccount) 総勘定元帳勘定コードを設定します｡
void | setTaIndex(int taIndex) レコード番号を設定します｡
void | setTaItemnoAcc(String taItemnoAcc) 会計伝票明細番号コードを設定します｡
void | setTaTaxCode(String taTaxCode) 消費税コードコードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccountTax

public AccountTax(int index)
指定されたレコード番号でAccountTaxを作成します｡

パラメータ:
index - レコード番号
メソッドの詳細

setTaItemnoAcc

public void setTaItemnoAcc(String taItemnoAcc)
会計伝票明細番号コードを設定します｡

パラメータ:
taItemnoAcc - 会計伝票明細番号

setTaGlAccount

public void setTaGlAccount(String taGlAccount)
総勘定元帳勘定コードを設定します｡

パラメータ:
taGlAccount - 総勘定元帳勘定

setTaTaxCode

public void setTaTaxCode(String taTaxCode)
消費税コードコードを設定します｡

パラメータ:
taTaxCode - 消費税コード

setTaIndex

public void setTaIndex(int taIndex)
レコード番号を設定します｡

パラメータ:
taIndex - レコード番号

getTaItemnoAcc

public String getTaItemnoAcc()
会計伝票明細番号を取得します｡

戻り値:
taItemnoAcc

getTaGlAccount

public String getTaGlAccount()
総勘定元帳勘定を取得します｡

戻り値:
taGlAccount

getTaTaxCode

public String getTaTaxCode()
消費税コードを取得します｡

戻り値:
taTaxCode

getTaIndex

public int getTaIndex()
レコード番号を取得します｡

戻り値:
tadex

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Bank (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス Bank

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.Bank
すべての実装インタフェース:
Serializable
public class Bank
extends Object
implements Serializable

銀行情報クラス
機能は以下の通り

  • 銀行の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Bank()
銀行情報を作成します。
メソッドの概要
String | getBankKey() 銀行コードを取得します｡
String | getBankName() 銀行名を取得します｡
String | getCity() 市区町村名を取得します｡
void | setBankKey(String bankKey) 銀行コードを設定します｡
void | setBankName(String bankName) 銀行名を設定します｡
void | setCity(String city) 市区町村名を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Bank

public Bank()
銀行情報を作成します。

メソッドの詳細

setBankKey

public void setBankKey(String bankKey)
銀行コードを設定します｡

パラメータ:
bankKey - 銀行コード

setBankName

public void setBankName(String bankName)
銀行名を設定します｡

パラメータ:
bankName - 銀行名

setCity

public void setCity(String city)
市区町村名を設定します｡

パラメータ:
city - 市区町村名

getBankKey

public String getBankKey()
銀行コードを取得します｡

戻り値:
bankKey

getBankName

public String getBankName()
銀行名を取得します｡

戻り値:
bankName

getCity

public String getCity()
市区町村名を取得します｡

戻り値:
city

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BankController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス BankController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.BankController
すべての実装インタフェース:
Serializable
public class BankController
extends Object
implements Serializable

銀行コントローラクラス
機能は以下の通り

  • 銀行の情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
BankController()
BankListのコンストラクタを呼び出し銀行一覧を作成します。
BankController(SapClient sapClient)
BankListのコンストラクタを呼び出し銀行一覧を作成します。
メソッドの概要
BankList | getBaList() 銀行一覧を取得します｡
ArrayList | getBankList() 銀行一覧を取得します。
String | getBankName(String bankKey) 銀行コードを指定して銀行名を取得します。
String | getCity(String bankKey) 銀行コードを指定して市区町村名を取得します。
void | setBaList(BankList baList) 銀行一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BankController

public BankController()
               throws SAPAuthAppException,
                      SAPAuthSystemException,
                      SAPGeneralAppException,
                      SAPGeneralSystemException,
                      SAPAccountingSystemException
BankListのコンストラクタを呼び出し銀行一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

BankController

public BankController(SapClient sapClient)
               throws SAPAuthAppException,
                      SAPAuthSystemException,
                      SAPGeneralAppException,
                      SAPGeneralSystemException,
                      SAPAccountingSystemException
BankListのコンストラクタを呼び出し銀行一覧を作成します。
SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバ接続が可能となります。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getBankList

public ArrayList getBankList()
銀行一覧を取得します。

戻り値:
bankList 銀行一覧

getBankName

public String getBankName(String bankKey)
                   throws SAPAccountingSystemException
銀行コードを指定して銀行名を取得します。

パラメータ:
bankKey - 銀行コード
戻り値:
bankName 銀行名
例外:
SAPAccountingSystemException - 会計業務システム例外

getCity

public String getCity(String bankKey)
               throws SAPAccountingSystemException
銀行コードを指定して市区町村名を取得します。

パラメータ:
bankKey - 銀行コード
戻り値:
city 市区町村名
例外:
SAPAccountingSystemException - 会計業務システム例外

setBaList

public void setBaList(BankList baList)
銀行一覧を設定します｡

パラメータ:
baList - 銀行一覧

getBaList

public BankList getBaList()
銀行一覧を取得します｡

戻り値:
baList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BankList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス BankList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.BankList
すべての実装インタフェース:
Serializable
public class BankList
extends ReferenceController
implements Serializable

銀行一覧クラス
機能は以下の通り

  • 銀行の情報を一覧形式で取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
BankList(SapClient sapClient)
executeBapiを呼び出し銀行一覧を作成します。
メソッドの概要
ArrayList | getBankList() 銀行一覧を取得します｡
void | setBankList(ArrayList bankList) 銀行一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BankList

public BankList(SapClient sapClient)
         throws SAPAuthAppException,
                SAPAuthSystemException,
                SAPGeneralAppException,
                SAPGeneralSystemException,
                SAPAccountingSystemException
executeBapiを呼び出し銀行一覧を作成します。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setBankList

public void setBankList(ArrayList bankList)
銀行一覧を設定します｡

パラメータ:
bankList - 銀行一覧

getBankList

public ArrayList getBankList()
銀行一覧を取得します｡

戻り値:
bankList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BusinessArea (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス BusinessArea

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea
すべての実装インタフェース:
Serializable
public class BusinessArea
extends Object
implements Serializable

事業領域情報クラス
機能は以下の通り

  • 事業領域の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
BusinessArea()
事業領域情報を作成します。
メソッドの概要
String | getBusArDes() 事業領域名を取得します｡
String | getBusArea() 事業領域を取得します｡
void | setBusArDes(String busArDes) 事業領域名を設定します｡
void | setBusArea(String busArea) 事業領域を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BusinessArea

public BusinessArea()
事業領域情報を作成します。

メソッドの詳細

setBusArea

public void setBusArea(String busArea)
事業領域を設定します｡

パラメータ:
busArea - 事業領域

setBusArDes

public void setBusArDes(String busArDes)
事業領域名を設定します｡

パラメータ:
busArDes - 事業領域名

getBusArea

public String getBusArea()
事業領域を取得します｡

戻り値:
businessAreaCode

getBusArDes

public String getBusArDes()
事業領域名を取得します｡

戻り値:
busArDes

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BusinessAreaController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス BusinessAreaController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController
すべての実装インタフェース:
Serializable
public class BusinessAreaController
extends Object
implements Serializable

事業領域コントローラクラス
機能は以下の通り

  • 事業領域の情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
BusinessAreaController()
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BusinessAreaController(SapClient sapClient)
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
メソッドの概要
String | getBusArDes(String busArea) 事業領域を指定して事業領域名を取得します。
BusinessAreaList | getBusAreaList() 事業領域一覧を取得します｡
ArrayList | getBusinessAreaList() 事業領域一覧を取得します。
void | setBusAreaList(BusinessAreaList busAreaList) 事業領域一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BusinessAreaController

public BusinessAreaController()
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

BusinessAreaController

public BusinessAreaController(SapClient sapClient)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバ接続が可能となります。

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getBusinessAreaList

public ArrayList getBusinessAreaList()
事業領域一覧を取得します。

戻り値:
businessAreaList 事業領域一覧

getBusArDes

public String getBusArDes(String busArea)
                   throws SAPAccountingSystemException
事業領域を指定して事業領域名を取得します。

パラメータ:
busArea - 事業領域
戻り値:
busArDes 事業領域名
例外:
SAPAccountingSystemException - 会計業務システム例外

setBusAreaList

public void setBusAreaList(BusinessAreaList busAreaList)
事業領域一覧を設定します｡

パラメータ:
busAreaList - 事業領域一覧

getBusAreaList

public BusinessAreaList getBusAreaList()
事業領域一覧を取得します｡

戻り値:
busAreaList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BusinessAreaList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス BusinessAreaList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList
すべての実装インタフェース:
Serializable
public class BusinessAreaList
extends ReferenceController
implements Serializable

事業領域一覧クラス
機能は以下の通り

  • 事業領域の情報を一覧形式で取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
BusinessAreaList(SapClient sapClient)
executeBapiを呼び出し事業領域一覧を作成します。
メソッドの概要
ArrayList | getBusinessAreaList() 事業領域一覧を取得します｡
void | setBusinessAreaList(ArrayList businessAreaList) 事業領域一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BusinessAreaList

public BusinessAreaList(SapClient sapClient)
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPAccountingSystemException
executeBapiを呼び出し事業領域一覧を作成します。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setBusinessAreaList

public void setBusinessAreaList(ArrayList businessAreaList)
事業領域一覧を設定します｡

パラメータ:
businessAreaList - 事業領域一覧

getBusinessAreaList

public ArrayList getBusinessAreaList()
事業領域一覧を取得します｡

戻り値:
businessAreaList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Company (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス Company

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.Company
すべての実装インタフェース:
Serializable
public class Company
extends Object
implements Serializable

会社情報クラス
機能は以下の通り

  • 会社の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Company()
会社情報を作成します。
メソッドの概要
String | getCompCode() 会社コードを取得します｡
String | getCompName() 会社名を取得します｡
void | setCompCode(String compCode) 会社コードを設定します｡
void | setCompName(String compName) 会社名を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Company

public Company()
会社情報を作成します。

メソッドの詳細

setCompCode

public void setCompCode(String compCode)
会社コードを設定します｡

パラメータ:
compCode - 会社コード

setCompName

public void setCompName(String compName)
会社名を設定します｡

パラメータ:
compName - 会社名

getCompCode

public String getCompCode()
会社コードを取得します｡

戻り値:
compCode

getCompName

public String getCompName()
会社名を取得します｡

戻り値:
compName

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CompanyController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.CompanyController
すべての実装インタフェース:
Serializable
public class CompanyController
extends Object
implements Serializable

会社コントローラクラス
機能は以下の通り

  • 会社の情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
CompanyController()
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
CompanyController(SapClient sapClient)
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
メソッドの概要
ArrayList | getCompanyList() 会社一覧を取得します。
CompanyList | getCompList() 会社一覧を取得します｡
String | getCompName(String compCode) 会社コードを指定して会社名を取得します。
void | setCompList(CompanyList compList) 会社一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CompanyController

public CompanyController()
                  throws SAPAuthAppException,
                         SAPAuthSystemException,
                         SAPGeneralAppException,
                         SAPGeneralSystemException,
                         SAPAccountingSystemException
CompanyListのコンストラクタを呼び出し会社一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

CompanyController

public CompanyController(SapClient sapClient)
                  throws SAPAuthAppException,
                         SAPAuthSystemException,
                         SAPGeneralAppException,
                         SAPGeneralSystemException,
                         SAPAccountingSystemException
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバ接続が可能となります。

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getCompanyList

public ArrayList getCompanyList()
会社一覧を取得します。

戻り値:
companyList 会社一覧

getCompName

public String getCompName(String compCode)
                   throws SAPAccountingSystemException
会社コードを指定して会社名を取得します。

パラメータ:
compCode - 会社コード
戻り値:
compName 会社名
例外:
SAPAccountingSystemException - 会計業務システム例外

setCompList

public void setCompList(CompanyList compList)
会社一覧を設定します｡

パラメータ:
compList - 会社一覧

getCompList

public CompanyList getCompList()
会社一覧を取得します｡

戻り値:
compList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CompanyList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.CompanyList
すべての実装インタフェース:
Serializable
public class CompanyList
extends ReferenceController
implements Serializable

会社一覧クラス
機能は以下の通り

  • 会社の情報を一覧形式で取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
CompanyList(SapClient sapClient)
executeBapiを呼び出し会社一覧を作成します。
メソッドの概要
ArrayList | getCompanyList() 会社一覧を取得します｡
void | setCompanyList(ArrayList companyList) 会社一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CompanyList

public CompanyList(SapClient sapClient)
            throws SAPAuthAppException,
                   SAPAuthSystemException,
                   SAPGeneralAppException,
                   SAPGeneralSystemException,
                   SAPAccountingSystemException
executeBapiを呼び出し会社一覧を作成します。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setCompanyList

public void setCompanyList(ArrayList companyList)
会社一覧を設定します｡

パラメータ:
companyList - 会社一覧

getCompanyList

public ArrayList getCompanyList()
会社一覧を取得します｡

戻り値:
companyList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ControllingArea (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ControllingArea

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea
すべての実装インタフェース:
Serializable
public class ControllingArea
extends Object
implements Serializable

管理領域情報クラス
機能は以下の通り

  • 管理領域の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ControllingArea()
管理領域情報を作成します。
メソッドの概要
String | getCoArea() 管理領域を取得します｡
String | getName() 管理領域名を取得します｡
void | setCoArea(String coArea) 管理領域を設定します｡
void | setName(String name) 管理領域名を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ControllingArea

public ControllingArea()
管理領域情報を作成します。

メソッドの詳細

setCoArea

public void setCoArea(String coArea)
管理領域を設定します｡

パラメータ:
coArea - 管理領域

setName

public void setName(String name)
管理領域名を設定します｡

パラメータ:
name - 管理領域名

getCoArea

public String getCoArea()
管理領域を取得します｡

戻り値:
coArea

getName

public String getName()
管理領域名を取得します｡

戻り値:
name

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ControllingAreaController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ControllingAreaController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController
すべての実装インタフェース:
Serializable
public class ControllingAreaController
extends Object
implements Serializable

管理領域コントローラクラス
機能は以下の通り

  • 管理領域の情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
ControllingAreaController()
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
ControllingAreaController(SapClient sapClient)
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
メソッドの概要
ControllingAreaList | getControllAreaList() 管理領域一覧を取得します｡
ArrayList | getControllingAreaList() 管理領域一覧を取得します。
String | getName(String coArea) 管理領域を指定して管理領域名を取得します。
void | setControllAreaList(ControllingAreaList controllAreaList) 管理領域一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ControllingAreaController

public ControllingAreaController()
                          throws SAPAuthAppException,
                                 SAPAuthSystemException,
                                 SAPGeneralAppException,
                                 SAPGeneralSystemException,
                                 SAPAccountingSystemException
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

ControllingAreaController

public ControllingAreaController(SapClient sapClient)
                          throws SAPAuthAppException,
                                 SAPAuthSystemException,
                                 SAPGeneralAppException,
                                 SAPGeneralSystemException,
                                 SAPAccountingSystemException
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバ接続が可能となります。

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getControllingAreaList

public ArrayList getControllingAreaList()
管理領域一覧を取得します。

戻り値:
controllingAreaList 管理領域一覧

getName

public String getName(String coArea)
               throws SAPAccountingSystemException
管理領域を指定して管理領域名を取得します。

パラメータ:
coArea - 管理領域
戻り値:
name 管理領域名
例外:
SAPAccountingSystemException - 会計業務システム例外

setControllAreaList

public void setControllAreaList(ControllingAreaList controllAreaList)
管理領域一覧を設定します｡

パラメータ:
controllAreaList - 管理領域一覧

getControllAreaList

public ControllingAreaList getControllAreaList()
管理領域一覧を取得します｡

戻り値:
controllAreaList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ControllingAreaList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ControllingAreaList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList
すべての実装インタフェース:
Serializable
public class ControllingAreaList
extends ReferenceController
implements Serializable

管理領域一覧クラス
機能は以下の通り

  • 管理領域の情報を一覧形式で取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
ControllingAreaList(SapClient sapClient)
executeBapiを呼び出し管理領域一覧を作成します。
メソッドの概要
ArrayList | getControllingAreaList() 管理領域一覧を取得します｡
void | setControllingAreaList(ArrayList controllingAreaList) 管理領域一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ControllingAreaList

public ControllingAreaList(SapClient sapClient)
                    throws SAPAuthAppException,
                           SAPAuthSystemException,
                           SAPGeneralAppException,
                           SAPGeneralSystemException,
                           SAPAccountingSystemException
executeBapiを呼び出し管理領域一覧を作成します。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setControllingAreaList

public void setControllingAreaList(ArrayList controllingAreaList)
管理領域一覧を設定します｡

パラメータ:
controllingAreaList - 管理領域一覧

getControllingAreaList

public ArrayList getControllingAreaList()
管理領域一覧を取得します｡

戻り値:
controllingAreaList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CostCenter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CostCenter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.CostCenter
すべての実装インタフェース:
Serializable
public class CostCenter
extends Object
implements Serializable

原価センタ情報クラス
機能は以下の通り

  • 原価センタの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CostCenter()
原価センタ情報を取得します。
メソッドの概要
String | getControllingArea() 管理領域を取得します｡
String | getCostCenter() 原価センタを取得します｡
String | getDescript() テキストを取得します｡
String | getName() 一般名称を取得します｡
void | setControllingArea(String controllingArea) 管理領域を設定します｡
void | setCostCenter(String costCenter) 原価センタを設定します｡
void | setDescript(String descript) テキストを設定します｡
void | setName(String name) 一般名称を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CostCenter

public CostCenter()
原価センタ情報を取得します。

メソッドの詳細

setControllingArea

public void setControllingArea(String controllingArea)
管理領域を設定します｡

パラメータ:
controllingArea - 管理領域

setCostCenter

public void setCostCenter(String costCenter)
原価センタを設定します｡

パラメータ:
costCenter - 原価センタ

setName

public void setName(String name)
一般名称を設定します｡

パラメータ:
name - 一般名称

setDescript

public void setDescript(String descript)
テキストを設定します｡

パラメータ:
descript - テキスト

getControllingArea

public String getControllingArea()
管理領域を取得します｡

戻り値:
controllingArea

getCostCenter

public String getCostCenter()
原価センタを取得します｡

戻り値:
costCenter

getName

public String getName()
一般名称を取得します｡

戻り値:
name

getDescript

public String getDescript()
テキストを取得します｡

戻り値:
descript

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CostCenterController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CostCenterController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController
すべての実装インタフェース:
Serializable
public class CostCenterController
extends Object
implements Serializable

原価センタコントローラクラス
機能は以下の通り

  • 原価センタの情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
CostCenterController(String controllingArea)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date, SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
メソッドの概要
ArrayList | getCostCenterList() 原価センタ一覧を取得します。
CostCenterList | getCostCentList() 原価センタ一覧を取得します｡
String | getDescript(String costCenter) 原価センタを指定してテキストを取得します。
String | getName(String costCenter) 原価センタを指定して一般名称を取得します。
void | setCostCentList(CostCenterList costCentList) 原価センタ一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CostCenterController

public CostCenterController(String controllingArea)
                     throws SAPAuthAppException,
                            SAPAuthSystemException,
                            SAPGeneralAppException,
                            SAPGeneralSystemException,
                            SAPAccountingSystemException
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。 「有効期間: 開始」をシステム日付より設定します。

パラメータ:
controllingArea - 管理領域
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

CostCenterController

public CostCenterController(String controllingArea,
                            Date date)
                     throws SAPAuthAppException,
                            SAPAuthSystemException,
                            SAPGeneralAppException,
                            SAPGeneralSystemException,
                            SAPAccountingSystemException
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。 「有効期間: 開始」を引数より設定します。

パラメータ:
controllingArea - 管理領域
date - 有効期間: 開始
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

CostCenterController

public CostCenterController(String controllingArea,
                            SapClient sapClient)
                     throws SAPAuthAppException,
                            SAPAuthSystemException,
                            SAPGeneralAppException,
                            SAPGeneralSystemException,
                            SAPAccountingSystemException
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。 「有効期間: 開始」を引数より設定します。

パラメータ:
controllingArea - 管理領域
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

CostCenterController

public CostCenterController(String controllingArea,
                            Date date,
                            SapClient sapClient)
                     throws SAPAuthAppException,
                            SAPAuthSystemException,
                            SAPGeneralAppException,
                            SAPGeneralSystemException,
                            SAPAccountingSystemException
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。 「有効期間: 開始」を引数より設定します。
SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバ接続が可能となります。

パラメータ:
controllingArea - 管理領域
date - 有効期間: 開始
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getCostCenterList

public ArrayList getCostCenterList()
原価センタ一覧を取得します。

戻り値:
costCenterList 原価センタ一覧

getName

public String getName(String costCenter)
               throws SAPAccountingSystemException
原価センタを指定して一般名称を取得します。

パラメータ:
costCenter - 原価センタ
戻り値:
name 一般名称
例外:
SAPAccountingSystemException - 会計業務システム例外

getDescript

public String getDescript(String costCenter)
                   throws SAPAccountingSystemException
原価センタを指定してテキストを取得します。

パラメータ:
costCenter - 原価センタ
戻り値:
descript テキスト
例外:
SAPAccountingSystemException - 会計業務システム例外

setCostCentList

public void setCostCentList(CostCenterList costCentList)
原価センタ一覧を設定します｡

パラメータ:
costCentList - 原価センタ一覧

getCostCentList

public CostCenterList getCostCentList()
原価センタ一覧を取得します｡

戻り値:
costCentList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CostCenterList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CostCenterList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList
すべての実装インタフェース:
Serializable
public class CostCenterList
extends ReferenceController
implements Serializable

原価センタ一覧クラス
機能は以下の通り

  • 原価センタの情報を一覧形式で取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
CostCenterList(String controllingArea, String date, SapClient sapClient)
executeBapiを呼び出し原価センタ一覧を作成します。
メソッドの概要
ArrayList | getCostCenterList() 原価センタ一覧を取得します｡
void | setCostCenterList(ArrayList costCenterList) 原価センタ一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CostCenterList

public CostCenterList(String controllingArea,
                      String date,
                      SapClient sapClient)
               throws SAPAuthAppException,
                      SAPAuthSystemException,
                      SAPGeneralAppException,
                      SAPGeneralSystemException,
                      SAPAccountingSystemException
executeBapiを呼び出し原価センタ一覧を作成します。

パラメータ:
controllingArea - 管理領域
date - 有効期間: 開始
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setCostCenterList

public void setCostCenterList(ArrayList costCenterList)
原価センタ一覧を設定します｡

パラメータ:
costCenterList - 原価センタ一覧

getCostCenterList

public ArrayList getCostCenterList()
原価センタ一覧を取得します｡

戻り値:
costCenterList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CurrencyAmount (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CurrencyAmount

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount
すべての実装インタフェース:
Serializable
public class CurrencyAmount
extends Object
implements Serializable

明細通貨項目クラス
機能は以下の通り

  • 明細通貨項目の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CurrencyAmount(int index)
指定されたレコード番号でCurrencyAmountを作成します。
メソッドの概要
String | getCuAmtBase() 課税基準額を取得します｡
String | getCuAmtDoccur() 伝票通貨額を取得します｡
String | getCuCurrency() 通貨コードを取得します｡
int | getCuIndex() レコード番号を取得します｡
String | getCuItemnoAcc() 会計伝票明細番号を取得します｡
void | setCuAmtBase(String cuAmtBase) 課税基準額を設定します｡
void | setCuAmtDoccur(String cuAmtDoccur) 伝票通貨額設定します｡
void | setCuCurrency(String cuCurrency) 通貨コードを設定します｡
void | setCuIndex(int cuIndex) レコード番号を設定します｡
void | setCuItemnoAcc(String cuItemnoAcc) 会計伝票明細番号コードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CurrencyAmount

public CurrencyAmount(int index)
指定されたレコード番号でCurrencyAmountを作成します。

パラメータ:
index - レコード番号
メソッドの詳細

setCuItemnoAcc

public void setCuItemnoAcc(String cuItemnoAcc)
会計伝票明細番号コードを設定します｡

パラメータ:
cuItemnoAcc - 会計伝票明細番号

setCuCurrency

public void setCuCurrency(String cuCurrency)
通貨コードを設定します｡

パラメータ:
cuCurrency - 通貨コード

setCuAmtDoccur

public void setCuAmtDoccur(String cuAmtDoccur)
伝票通貨額設定します｡

パラメータ:
cuAmtDoccur - 伝票通貨額

setCuAmtBase

public void setCuAmtBase(String cuAmtBase)
課税基準額を設定します｡

パラメータ:
cuAmtBase - 課税基準額

setCuIndex

public void setCuIndex(int cuIndex)
レコード番号を設定します｡

パラメータ:
cuIndex - レコード番号

getCuItemnoAcc

public String getCuItemnoAcc()
会計伝票明細番号を取得します｡

戻り値:
cuItemnoAcc

getCuCurrency

public String getCuCurrency()
通貨コードを取得します｡

戻り値:
cuCurrency

getCuAmtDoccur

public String getCuAmtDoccur()
伝票通貨額を取得します｡

戻り値:
cuAmtDoccur

getCuAmtBase

public String getCuAmtBase()
課税基準額を取得します｡

戻り値:
cuAmtBase

getCuIndex

public int getCuIndex()
レコード番号を取得します｡

戻り値:
cuindex

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DocumentHeader (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス DocumentHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader
すべての実装インタフェース:
Serializable
public class DocumentHeader
extends Object
implements Serializable

伝票ヘッダクラス
機能は以下の通り

  • 伝票ヘッダの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
DocumentHeader()
伝票ヘッダ情報を作成します。
メソッドの概要
String | getDocAcDocNo() 会計伝票番号を取得します｡
String | getDocCompCode() 会社コードを取得します｡
String | getDocDocDate() 伝票の伝票日付を取得します｡
String | getDocDocType() 伝票タイプを取得します｡
String | getDocFiscYear() 会計年度を取得します｡
String | getDocFisPeriod() 会計期間を取得します｡
String | getDocHeaderTxt() 伝票ヘッダテキストを取得します｡
String | getDocObjKey() オブジェクトキーを取得します｡
String | getDocObjType() 参照処理を取得します｡
String | getDocPstngDate() 伝票の転記日付を取得します｡
String | getDocRefDocNo() 参照伝票番号を取得します｡
String | getDocUsername() ユーザ名を取得します｡
void | setDocAcDocNo(String docAcDocNo) 会計伝票番号コードを設定します｡
void | setDocCompCode(String docCompCode) 会社コードコードを設定します｡
void | setDocDocDate(String docDocDate) 伝票の伝票日付コードを設定します｡
void | setDocDocType(String docDocType) 伝票タイプコードを設定します｡
void | setDocFiscYear(String docFiscYear) 会計年度コードを設定します｡
void | setDocFisPeriod(String docFisPeriod) 会計期間コードを設定します｡
void | setDocHeaderTxt(String docHeaderTxt) 伝票ヘッダテキストコードを設定します｡
void | setDocObjKey(String docObjKey) オブジェクトキーコードを設定します｡
void | setDocObjType(String docObjType) 参照処理コードを設定します｡
void | setDocPstngDate(String docPstngDate) 伝票の転記日付コードを設定します｡
void | setDocRefDocNo(String docRefDocNo) 参照伝票番号コードを設定します｡
void | setDocUsername(String docUsername) ユーザ名コードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DocumentHeader

public DocumentHeader()
伝票ヘッダ情報を作成します。

メソッドの詳細

setDocObjType

public void setDocObjType(String docObjType)
参照処理コードを設定します｡

パラメータ:
docObjType - 参照処理

setDocObjKey

public void setDocObjKey(String docObjKey)
オブジェクトキーコードを設定します｡

パラメータ:
docObjKey - オブジェクトキー

setDocUsername

public void setDocUsername(String docUsername)
ユーザ名コードを設定します｡

パラメータ:
docUsername - ユーザ名

setDocHeaderTxt

public void setDocHeaderTxt(String docHeaderTxt)
伝票ヘッダテキストコードを設定します｡

パラメータ:
docHeaderTxt - 伝票ヘッダテキスト

setDocCompCode

public void setDocCompCode(String docCompCode)
会社コードコードを設定します｡

パラメータ:
docCompCode - 会社コード

setDocAcDocNo

public void setDocAcDocNo(String docAcDocNo)
会計伝票番号コードを設定します｡

パラメータ:
docAcDocNo - 会計伝票番号

setDocFiscYear

public void setDocFiscYear(String docFiscYear)
会計年度コードを設定します｡

パラメータ:
docFiscYear - 会計年度

setDocDocDate

public void setDocDocDate(String docDocDate)
伝票の伝票日付コードを設定します｡

パラメータ:
docDocDate - 伝票の伝票日付

setDocPstngDate

public void setDocPstngDate(String docPstngDate)
伝票の転記日付コードを設定します｡

パラメータ:
docPstngDate - 伝票の転記日付

setDocFisPeriod

public void setDocFisPeriod(String docFisPeriod)
会計期間コードを設定します｡

パラメータ:
docFisPeriod - 会計期間

setDocDocType

public void setDocDocType(String docDocType)
伝票タイプコードを設定します｡

パラメータ:
docDocType - 伝票タイプ

setDocRefDocNo

public void setDocRefDocNo(String docRefDocNo)
参照伝票番号コードを設定します｡

パラメータ:
docRefDocNo - 参照伝票番号

getDocObjType

public String getDocObjType()
参照処理を取得します｡

戻り値:
docObjType

getDocObjKey

public String getDocObjKey()
オブジェクトキーを取得します｡

戻り値:
docObjKey

getDocUsername

public String getDocUsername()
ユーザ名を取得します｡

戻り値:
docUsername

getDocHeaderTxt

public String getDocHeaderTxt()
伝票ヘッダテキストを取得します｡

戻り値:
docHeaderTxt

getDocCompCode

public String getDocCompCode()
会社コードを取得します｡

戻り値:
docCompCode

getDocAcDocNo

public String getDocAcDocNo()
会計伝票番号を取得します｡

戻り値:
docAcDocNo

getDocFiscYear

public String getDocFiscYear()
会計年度を取得します｡

戻り値:
docFiscYear

getDocDocDate

public String getDocDocDate()
伝票の伝票日付を取得します｡

戻り値:
docDocDate

getDocPstngDate

public String getDocPstngDate()
伝票の転記日付を取得します｡

戻り値:
docPstngDate

getDocFisPeriod

public String getDocFisPeriod()
会計期間を取得します｡

戻り値:
docFisPeriod

getDocDocType

public String getDocDocType()
伝票タイプを取得します｡

戻り値:
docDocType

getDocRefDocNo

public String getDocRefDocNo()
参照伝票番号を取得します｡

戻り値:
docRefDocNo

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GlAcc (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス GlAcc

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.GlAcc
すべての実装インタフェース:
Serializable
public class GlAcc
extends Object
implements Serializable

勘定項目情報クラス
機能は以下の通り

  • 勘定項目の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GlAcc()
勘定項目情報を作成します。
メソッドの概要
String | getCompanyCode() 会社コードを取得します｡
String | getGlAccount() G/L勘定コードを取得します｡
String | getLongText() 総勘定元帳勘定テキスト(長)を取得します｡
String | getShortText() G/L勘定コードテキスト(短)を取得します｡
void | setCompanyCode(String companyCode) 会社コードを設定します｡
void | setGlAccount(String glAccount) G/L勘定コードを設定します｡
void | setLongText(String longText) 総勘定元帳勘定テキスト(長)を設定します｡
void | setShortText(String shortText) G/L勘定コードテキスト(短)を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GlAcc

public GlAcc()
勘定項目情報を作成します。

メソッドの詳細

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します｡

パラメータ:
companyCode - 会社コード

setGlAccount

public void setGlAccount(String glAccount)
G/L勘定コードを設定します｡

パラメータ:
glAccount - G/L勘定コード

setShortText

public void setShortText(String shortText)
G/L勘定コードテキスト(短)を設定します｡

パラメータ:
shortText - G/L勘定コードテキスト(短)

setLongText

public void setLongText(String longText)
総勘定元帳勘定テキスト(長)を設定します｡

パラメータ:
longText - 総勘定元帳勘定テキスト(長)

getCompanyCode

public String getCompanyCode()
会社コードを取得します｡

戻り値:
companyCode

getGlAccount

public String getGlAccount()
G/L勘定コードを取得します｡

戻り値:
glAccount

getShortText

public String getShortText()
G/L勘定コードテキスト(短)を取得します｡

戻り値:
shortText

getLongText

public String getLongText()
総勘定元帳勘定テキスト(長)を取得します｡

戻り値:
longText

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GlAccController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス GlAccController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.GlAccController
すべての実装インタフェース:
Serializable
public class GlAccController
extends Object
implements Serializable

勘定科目コントローラクラス
機能は以下の通り

  • 勘定科目の情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
GlAccController(String companyCode)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
GlAccController(String companyCode, SapClient sapClient)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
メソッドの概要
ArrayList | getGlAccList() 勘定項目情報一覧を取得します。
GlAccList | getGlList() 勘定科目一覧を取得します｡
String | getLongText(String glAccount) G/L勘定コードを指定して総勘定元帳勘定テキスト(長)を取得します。
String | getShortText(String glAccount) G/L勘定コードを指定してG/L勘定コードテキスト(短)を取得します。
void | setGlList(GlAccList glList) 勘定科目一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GlAccController

public GlAccController(String companyCode)
                throws SAPAuthAppException,
                       SAPAuthSystemException,
                       SAPGeneralAppException,
                       SAPGeneralSystemException,
                       SAPAccountingSystemException
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。

パラメータ:
companyCode - 会社コード
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

GlAccController

public GlAccController(String companyCode,
                       SapClient sapClient)
                throws SAPAuthAppException,
                       SAPAuthSystemException,
                       SAPGeneralAppException,
                       SAPGeneralSystemException,
                       SAPAccountingSystemException
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバ接続が可能となります。

パラメータ:
companyCode - 会社コード
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getGlAccList

public ArrayList getGlAccList()
勘定項目情報一覧を取得します。

戻り値:
glAccList 勘定項目情報一覧

getShortText

public String getShortText(String glAccount)
                    throws SAPAccountingSystemException
G/L勘定コードを指定してG/L勘定コードテキスト(短)を取得します。

パラメータ:
glAccount - G/L勘定コード
戻り値:
shortText G/L勘定コードテキスト(短)
例外:
SAPAccountingSystemException - 会計業務システム例外

getLongText

public String getLongText(String glAccount)
                   throws SAPAccountingSystemException
G/L勘定コードを指定して総勘定元帳勘定テキスト(長)を取得します。

パラメータ:
glAccount - G/L勘定コード
戻り値:
longText 総勘定元帳勘定テキスト(長)
例外:
SAPAccountingSystemException - 会計業務システム例外

setGlList

public void setGlList(GlAccList glList)
勘定科目一覧を設定します｡

パラメータ:
glList - 勘定科目一覧

getGlList

public GlAccList getGlList()
勘定科目一覧を取得します｡

戻り値:
glList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GlAccList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス GlAccList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.GlAccList
すべての実装インタフェース:
Serializable
public class GlAccList
extends ReferenceController
implements Serializable

勘定項目一覧クラス
機能は以下の通り

  • 勘定項目の情報を一覧形式で取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
GlAccList(String companyCode, SapClient sapClient)
executeBapiを呼び出し勘定項目一覧を作成します。
メソッドの概要
ArrayList | getGlAccList() 勘定項目情報一覧を取得します｡
void | setGlAccList(ArrayList glAccList) 勘定項目一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GlAccList

public GlAccList(String companyCode,
                 SapClient sapClient)
          throws SAPAuthAppException,
                 SAPAuthSystemException,
                 SAPGeneralAppException,
                 SAPGeneralSystemException,
                 SAPAccountingSystemException
executeBapiを呼び出し勘定項目一覧を作成します。

パラメータ:
companyCode - 会社コード
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setGlAccList

public void setGlAccList(ArrayList glAccList)
勘定項目一覧を設定します｡

パラメータ:
glAccList - 勘定項目一覧

getGlAccList

public ArrayList getGlAccList()
勘定項目情報一覧を取得します｡

戻り値:
glAccList 勘定項目情報一覧

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.accounting (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.accounting
クラス
AccEmployeePayPostController
AccountGl
AccountPayable
AccountTax
Bank
BankController
BankList
BusinessArea
BusinessAreaController
BusinessAreaList
Company
CompanyController
CompanyList
ControllingArea
ControllingAreaController
ControllingAreaList
CostCenter
CostCenterController
CostCenterList
CurrencyAmount
DocumentHeader
GlAcc
GlAccController
GlAccList
ProfitCenter
ProfitCenterController
ProfitCenterList


jp.co.intra_mart.foundation.sap.module.accounting (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.accounting

ＳＡＰ連携財務会計系に関するクラスを提供します。

参照:
説明

クラスの概要
AccEmployeePayPostController | 伝票登録コントローラクラス 機能は以下の通り 伝票を登録します。
AccountGl | G/L 勘定明細クラス 機能は以下の通り G/L 勘定明細の情報を保持します。
AccountPayable | 仕入先明細クラス 機能は以下の通り 仕入先明細の情報を保持します。
AccountTax | 税明細クラス 機能は以下の通り 税明細の情報を保持します。
Bank | 銀行情報クラス 機能は以下の通り 銀行の情報を保持します。
BankController | 銀行コントローラクラス 機能は以下の通り 銀行の情報を取得します。
BankList | 銀行一覧クラス 機能は以下の通り 銀行の情報を一覧形式で取得します。
BusinessArea | 事業領域情報クラス 機能は以下の通り 事業領域の情報を保持します。
BusinessAreaController | 事業領域コントローラクラス 機能は以下の通り 事業領域の情報を取得します。
BusinessAreaList | 事業領域一覧クラス 機能は以下の通り 事業領域の情報を一覧形式で取得します。
Company | 会社情報クラス 機能は以下の通り 会社の情報を保持します。
CompanyController | 会社コントローラクラス 機能は以下の通り 会社の情報を取得します。
CompanyList | 会社一覧クラス 機能は以下の通り 会社の情報を一覧形式で取得します。
ControllingArea | 管理領域情報クラス 機能は以下の通り 管理領域の情報を保持します。
ControllingAreaController | 管理領域コントローラクラス 機能は以下の通り 管理領域の情報を取得します。
ControllingAreaList | 管理領域一覧クラス 機能は以下の通り 管理領域の情報を一覧形式で取得します。
CostCenter | 原価センタ情報クラス 機能は以下の通り 原価センタの情報を保持します。
CostCenterController | 原価センタコントローラクラス 機能は以下の通り 原価センタの情報を取得します。
CostCenterList | 原価センタ一覧クラス 機能は以下の通り 原価センタの情報を一覧形式で取得します。
CurrencyAmount | 明細通貨項目クラス 機能は以下の通り 明細通貨項目の情報を保持します。
DocumentHeader | 伝票ヘッダクラス 機能は以下の通り 伝票ヘッダの情報を保持します。
GlAcc | 勘定項目情報クラス 機能は以下の通り 勘定項目の情報を保持します。
GlAccController | 勘定科目コントローラクラス 機能は以下の通り 勘定科目の情報を取得します。
GlAccList | 勘定項目一覧クラス 機能は以下の通り 勘定項目の情報を一覧形式で取得します。
ProfitCenter | 利益センタ情報クラス 機能は以下の通り 利益センタの情報を保持します。
ProfitCenterController | 利益センタコントローラクラス 機能は以下の通り 利益センタの情報を取得します。
ProfitCenterList | 利益センタ一覧クラス 機能は以下の通り 利益センタの情報を一覧形式で取得します。

パッケージ jp.co.intra_mart.foundation.sap.module.accounting の説明

ＳＡＰ連携財務会計系に関するクラスを提供します。


jp.co.intra_mart.foundation.sap.module.accounting クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.accounting の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.BankList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.Bank (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BankController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.Company (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.accounting の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.accounting の使用

jp.co.intra_mart.foundation.sap.module.accounting を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting により使用される jp.co.intra_mart.foundation.sap.module.accounting のクラス
BankList
銀行一覧クラス
機能は以下の通り
銀行の情報を一覧形式で取得します。
BusinessAreaList
事業領域一覧クラス
機能は以下の通り
事業領域の情報を一覧形式で取得します。
CompanyList
会社一覧クラス
機能は以下の通り
会社の情報を一覧形式で取得します。
ControllingAreaList
管理領域一覧クラス
機能は以下の通り
管理領域の情報を一覧形式で取得します。
CostCenterList
原価センタ一覧クラス
機能は以下の通り
原価センタの情報を一覧形式で取得します。
DocumentHeader
伝票ヘッダクラス
機能は以下の通り
伝票ヘッダの情報を保持します。
GlAccList
勘定項目一覧クラス
機能は以下の通り
勘定項目の情報を一覧形式で取得します。
ProfitCenterList
利益センタ一覧クラス

機能は以下の通り
利益センタの情報を一覧形式で取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ProfitCenter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ProfitCenter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter
すべての実装インタフェース:
Serializable
public class ProfitCenter
extends Object
implements Serializable

利益センタ情報クラス
機能は以下の通り

  • 利益センタの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ProfitCenter()
利益センタ情報を作成します。
メソッドの概要
String | getControllingArea() 管理領域コードを取得します｡
String | getInCharge() 利益センタ責任者を取得します｡
String | getPctrName() 一般名称を取得します｡
String | getProfitCtr() 利益センタを取得します｡
String | getValidTo() 有効終了日を取得します｡
void | setControllingArea(String controllingArea) 管理領域を設定します｡
void | setInCharge(String inCharge) 利益センタ責任者を設定します｡
void | setPctrName(String pctrName) 一般名称を設定します｡
void | setProfitCtr(String profitCtr) 利益センタを設定します｡
void | setValidTo(String validTo) 有効終了日を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProfitCenter

public ProfitCenter()
利益センタ情報を作成します。

メソッドの詳細

setControllingArea

public void setControllingArea(String controllingArea)
管理領域を設定します｡

パラメータ:
controllingArea - 管理領域

setProfitCtr

public void setProfitCtr(String profitCtr)
利益センタを設定します｡

パラメータ:
profitCtr - 利益センタ

setValidTo

public void setValidTo(String validTo)
有効終了日を設定します｡

パラメータ:
validTo - 有効終了日

setPctrName

public void setPctrName(String pctrName)
一般名称を設定します｡

パラメータ:
pctrName - 一般名称

setInCharge

public void setInCharge(String inCharge)
利益センタ責任者を設定します｡

パラメータ:
inCharge - 利益センタ責任者

getControllingArea

public String getControllingArea()
管理領域コードを取得します｡

戻り値:
controllingArea

getProfitCtr

public String getProfitCtr()
利益センタを取得します｡

戻り値:
profitCtr

getValidTo

public String getValidTo()
有効終了日を取得します｡

戻り値:
validTo

getPctrName

public String getPctrName()
一般名称を取得します｡

戻り値:
pctrName

getInCharge

public String getInCharge()
利益センタ責任者を取得します｡

戻り値:
inCharge

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProfitCenterController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ProfitCenterController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController
すべての実装インタフェース:
Serializable
public class ProfitCenterController
extends Object
implements Serializable

利益センタコントローラクラス
機能は以下の通り

  • 利益センタの情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
ProfitCenterController(String controllingArea)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date, SapClient sapClient)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, SapClient sapClient)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
メソッドの概要
String | getInCharge(String profitCtr) 利益センタを指定して利益センタ責任者を取得します。
String | getPctrName(String profitCtr) 利益センタを指定して一般名称を取得します。
ArrayList | getProfitCenterList() 利益センタ一覧を取得します。
ProfitCenterList | getProfitCentList() 利益センタ一覧を取得します｡
String | getValidTo(String profitCtr) 利益センタを指定して有効終了日を取得します。
void | setProfitCentList(ProfitCenterList profitCentList) 利益センタ一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProfitCenterController

public ProfitCenterController(String controllingArea)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。 「日付」をシステム日付より設定します。

パラメータ:
controllingArea - 管理領域
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

ProfitCenterController

public ProfitCenterController(String controllingArea,
                              Date date)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。 「日付」を引数より設定します。

パラメータ:
controllingArea - 管理領域
date - 日付
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

ProfitCenterController

public ProfitCenterController(String controllingArea,
                              SapClient sapClient)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。 「日付」を引数より設定します。

パラメータ:
controllingArea - 管理領域
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

ProfitCenterController

public ProfitCenterController(String controllingArea,
                              Date date,
                              SapClient sapClient)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。 「日付」を引数より設定します。

パラメータ:
controllingArea - 管理領域
date - 日付
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getProfitCenterList

public ArrayList getProfitCenterList()
利益センタ一覧を取得します。

戻り値:
profitCenterList 管理領域一覧

getValidTo

public String getValidTo(String profitCtr)
                  throws SAPAccountingSystemException
利益センタを指定して有効終了日を取得します。

パラメータ:
profitCtr - 利益センタ
戻り値:
validTo 有効終了日
例外:
SAPAccountingSystemException - 会計業務システム例外

getPctrName

public String getPctrName(String profitCtr)
                   throws SAPAccountingSystemException
利益センタを指定して一般名称を取得します。

パラメータ:
profitCtr - 利益センタ
戻り値:
pctrName 一般名称
例外:
SAPAccountingSystemException - 会計業務システム例外

getInCharge

public String getInCharge(String profitCtr)
                   throws SAPAccountingSystemException
利益センタを指定して利益センタ責任者を取得します。

パラメータ:
profitCtr - 利益センタ
戻り値:
inCharge 利益センタ責任者
例外:
SAPAccountingSystemException - 会計業務システム例外

setProfitCentList

public void setProfitCentList(ProfitCenterList profitCentList)
利益センタ一覧を設定します｡

パラメータ:
profitCentList - 利益センタ一覧

getProfitCentList

public ProfitCenterList getProfitCentList()
利益センタ一覧を取得します｡

戻り値:
profitCentList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProfitCenterList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ProfitCenterList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList
すべての実装インタフェース:
Serializable
public class ProfitCenterList
extends ReferenceController
implements Serializable

利益センタ一覧クラス

機能は以下の通り

  • 利益センタの情報を一覧形式で取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
ProfitCenterList(String controllingArea, String date, SapClient sapClient)
executeBapiを呼び出し利益センタ一覧を作成します。
メソッドの概要
ArrayList | getProfitCenterList() 利益センタ一覧を取得します｡
void | setProfitCenterList(ArrayList profitCenterList) 利益センタ一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProfitCenterList

public ProfitCenterList(String controllingArea,
                        String date,
                        SapClient sapClient)
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPAccountingSystemException
executeBapiを呼び出し利益センタ一覧を作成します。

パラメータ:
controllingArea - 管理領域
date - 日付
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setProfitCenterList

public void setProfitCenterList(ArrayList profitCenterList)
利益センタ一覧を設定します｡

パラメータ:
profitCenterList - 利益センタ一覧

getProfitCenterList

public ArrayList getProfitCenterList()
利益センタ一覧を取得します｡

戻り値:
profitCenterList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.AbstractController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.AbstractController の使用

AbstractController を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial | ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems |
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability |
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall |
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica |
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist |
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus |

jp.co.intra_mart.foundation.sap.module での AbstractController の使用

jp.co.intra_mart.foundation.sap.module での AbstractController のサブクラス
class | ReferenceController 参照系モジュール共通コントローラ親クラス。
class | UpdateController 登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.accounting での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.accounting での AbstractController のサブクラス
class | AccEmployeePayPostController 伝票登録コントローラクラス 機能は以下の通り 伝票を登録します。
class | BankList 銀行一覧クラス 機能は以下の通り 銀行の情報を一覧形式で取得します。
class | BusinessAreaList 事業領域一覧クラス 機能は以下の通り 事業領域の情報を一覧形式で取得します。
class | CompanyList 会社一覧クラス 機能は以下の通り 会社の情報を一覧形式で取得します。
class | ControllingAreaList 管理領域一覧クラス 機能は以下の通り 管理領域の情報を一覧形式で取得します。
class | CostCenterList 原価センタ一覧クラス 機能は以下の通り 原価センタの情報を一覧形式で取得します。
class | GlAccList 勘定項目一覧クラス 機能は以下の通り 勘定項目の情報を一覧形式で取得します。
class | ProfitCenterList 利益センタ一覧クラス 機能は以下の通り 利益センタの情報を一覧形式で取得します。

jp.co.intra_mart.foundation.sap.module.financial での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.financial での AbstractController のサブクラス
class | CommonCenterGrpGetDetail 原価・利益センタグループ情報取得共通クラス 機能は以下の通り 原価・利益センタグループ情報を取得します。
class | CostCenterGroupGetDetail 原価センタグループ情報取得クラス 機能は以下の通り 原価センタグループ情報を取得します。
class | CreditorGetDetail 仕入先詳細情報取得クラス 機能は以下の通り 仕入先詳細情報を取得します。
class | DebtorGetDetail 得意先詳細情報取得クラス 機能は以下の通り 得意先詳細情報を取得します。
class | ExchangeRateGetDetail 為替換算レート情報取得クラス 機能は以下の通り 為替換算レート情報を取得します。
class | InternalOrderGetDetail 内部指図書詳細情報取得クラス 機能は以下の通り 内部指図書詳細情報を取得します。
class | InternalOrderGetList 内部指図書（一覧）情報取得クラス 機能は以下の通り 内部指図書（一覧）情報を取得します。
class | ProfitCenterGrpGetDetail 利益センタグループ情報取得クラス 機能は以下の通り 利益センタグループ情報を取得します。
class | ProjectGetInfo WBS情報取得クラス 機能は以下の通り WBS情報を取得します。

jp.co.intra_mart.foundation.sap.module.purchase での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.purchase での AbstractController のサブクラス
class | GoodsMvtCreateController 入庫伝票登録コントローラクラス 機能は以下の通り 入庫伝票を登録します。
class | GoodsMvtGetItemsController 入出庫伝票一覧取得コントローラクラス 機能は以下の通り 入出庫伝票の一覧を取得します。
class | MaterialAvailabilityController 品目在庫確認コントローラクラス 機能は以下の通り 在庫情報を取得します。
class | MaterialGetAllController 品目マスタ照会コントローラクラス 機能は以下の通り 品目マスタの情報を取得します。
class | MaterialGetList 品目コード検索クラス 機能は以下の通り 品目コード、テキストを検索します。
class | MaterialGetListController 品目コード検索コントローラクラス 機能は以下の通り 品目コード、テキストを検索します。
class | MaterialSaveReplicaController 品目マスタ更新コントローラクラス 機能は以下の通り 品目マスタを更新します。
class | PurchaseGetItemSrel 伝票承認対象一覧情報クラス 機能は以下の通り 伝票承認対象一覧を取得します。
class | PurchaseOrderPayPost 伝票登録クラス 機能は以下の通り 伝票を登録します。
class | PurchaseOrderPayPostController 伝票登録コントローラクラス 機能は以下の通り 伝票を登録します。
class | PurchaseOrderPostChangeController 伝票登録変更コントローラクラス 機能は以下の通り 伝票を変更します。
class | PurchaseRelease 承認情報スーパークラス 機能は以下の通り 承認情報を保持します。
class | PurchaseReleaseController 伝票承認コントローラクラス 機能は以下の通り 伝票を承認します。
class | PurchaseResetReleaseController 伝票承認取消コントローラクラス 機能は以下の通り 伝票の承認取消します。
class | SupplierDetail 仕入先マスタ詳細情報クラス 機能は以下の通り 仕入先マスタの詳細情報を取得します。
class | SupplierExistenceCheck 仕入先コード存在チェッククラス 機能は以下の通り 仕入先コード存在チェック結果を取得します。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での AbstractController のサブクラス
 class GoodsMvtCreate
入出庫伝票登録情報クラス
機能は以下の通り
入出庫伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems での AbstractController のサブクラス
 class GoodsMvtGetItems
出庫確認一覧照会情報クラス
機能は以下の通り
出庫確認一覧照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability での AbstractController のサブクラス
 class MaterialAvailability
品目在庫確認情報クラス
機能は以下の通り
品目在庫確認情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での AbstractController のサブクラス
 class MaterialGetAll
品目マスタ照会情報クラス
機能は以下の通り
品目マスタ照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica での AbstractController のサブクラス
 class MaterialSaveReplica
品目マスタ更新情報クラス
機能は以下の通り
品目マスタ更新情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber での AbstractController のサブクラス
 class StdMaterialGetIntNumberList
品目コード割当済一覧クラス
機能は以下の通り
品目コード割当済の情報を一覧形式で取得します。

jp.co.intra_mart.foundation.sap.module.sales での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales での AbstractController のサブクラス
class | BillingDocCreateMultipleController 請求伝票登録コントローラクラス 機能は以下の通り 請求伝票を登録します。
class | BillingDocGetListController 請求伝票一覧照会情報コントローラクラス 機能は以下の通り 請求伝票一覧照会情報を保持します。
class | InquiryCreateFromData2Controller 引合伝票登録コントローラクラス 機能は以下の通り 引合伝票を登録します。
class | QuotationCreateFromData2Controller 見積伝票登録情報コントローラクラス 機能は以下の通り 見積伝票登録情報を保持します。
class | SalesOrderCreateFromDat2Controller 受注伝票登録コントローラクラス 機能は以下の通り 受注伝票を登録します。
class | SalesOrderGetListController 販売伝票一覧照会コントローラクラス 機能は以下の通り 販売伝票一覧の情報を取得します。
class | SalesOrderGetStatusController 販売伝票ステータス一覧照会コントローラクラス 機能は以下の通り 販売伝票ステータス一覧の情報を取得します。

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple での AbstractController のサブクラス
 class BillingDocCreateMultiple
請求伝票登録情報クラス
機能は以下の通り
請求伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での AbstractController のサブクラス
 class BillingDocGetDetail
請求伝票詳細照会情報クラス
機能は以下の通り
請求伝票詳細照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist での AbstractController のサブクラス
 class BillingDocGetList
請求伝票一覧照会情報クラス
機能は以下の通り
請求伝票一覧照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での AbstractController のサブクラス
 class InquiryCreateFromData2
引合伝票登録情報クラス
機能は以下の通り
引合伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での AbstractController のサブクラス
 class QuotationCreateFromData2
見積伝票登録情報クラス
機能は以下の通り
見積伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での AbstractController のサブクラス
 class SalesOrderCreateFromDat2
受注伝票登録情報クラス
機能は以下の通り
受注伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist での AbstractController のサブクラス
 class SalesOrderGetList
販売伝票一覧照会情報クラス
機能は以下の通り
販売伝票一覧照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus での AbstractController のサブクラス
 class SalesOrderGetStatus
販売伝票ステータス一覧照会情報クラス
機能は以下の通り
販売伝票ステータス一覧照会情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.ReferenceController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.ReferenceController の使用

ReferenceController を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial | ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems |
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability |
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall |
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus |

jp.co.intra_mart.foundation.sap.module.accounting での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.accounting での ReferenceController のサブクラス
class | BankList 銀行一覧クラス 機能は以下の通り 銀行の情報を一覧形式で取得します。
class | BusinessAreaList 事業領域一覧クラス 機能は以下の通り 事業領域の情報を一覧形式で取得します。
class | CompanyList 会社一覧クラス 機能は以下の通り 会社の情報を一覧形式で取得します。
class | ControllingAreaList 管理領域一覧クラス 機能は以下の通り 管理領域の情報を一覧形式で取得します。
class | CostCenterList 原価センタ一覧クラス 機能は以下の通り 原価センタの情報を一覧形式で取得します。
class | GlAccList 勘定項目一覧クラス 機能は以下の通り 勘定項目の情報を一覧形式で取得します。
class | ProfitCenterList 利益センタ一覧クラス 機能は以下の通り 利益センタの情報を一覧形式で取得します。

jp.co.intra_mart.foundation.sap.module.financial での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.financial での ReferenceController のサブクラス
class | CommonCenterGrpGetDetail 原価・利益センタグループ情報取得共通クラス 機能は以下の通り 原価・利益センタグループ情報を取得します。
class | CostCenterGroupGetDetail 原価センタグループ情報取得クラス 機能は以下の通り 原価センタグループ情報を取得します。
class | CreditorGetDetail 仕入先詳細情報取得クラス 機能は以下の通り 仕入先詳細情報を取得します。
class | DebtorGetDetail 得意先詳細情報取得クラス 機能は以下の通り 得意先詳細情報を取得します。
class | ExchangeRateGetDetail 為替換算レート情報取得クラス 機能は以下の通り 為替換算レート情報を取得します。
class | InternalOrderGetDetail 内部指図書詳細情報取得クラス 機能は以下の通り 内部指図書詳細情報を取得します。
class | InternalOrderGetList 内部指図書（一覧）情報取得クラス 機能は以下の通り 内部指図書（一覧）情報を取得します。
class | ProfitCenterGrpGetDetail 利益センタグループ情報取得クラス 機能は以下の通り 利益センタグループ情報を取得します。
class | ProjectGetInfo WBS情報取得クラス 機能は以下の通り WBS情報を取得します。

jp.co.intra_mart.foundation.sap.module.purchase での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.purchase での ReferenceController のサブクラス
class | GoodsMvtGetItemsController 入出庫伝票一覧取得コントローラクラス 機能は以下の通り 入出庫伝票の一覧を取得します。
class | MaterialAvailabilityController 品目在庫確認コントローラクラス 機能は以下の通り 在庫情報を取得します。
class | MaterialGetAllController 品目マスタ照会コントローラクラス 機能は以下の通り 品目マスタの情報を取得します。
class | MaterialGetList 品目コード検索クラス 機能は以下の通り 品目コード、テキストを検索します。
class | MaterialGetListController 品目コード検索コントローラクラス 機能は以下の通り 品目コード、テキストを検索します。
class | PurchaseGetItemSrel 伝票承認対象一覧情報クラス 機能は以下の通り 伝票承認対象一覧を取得します。
class | SupplierDetail 仕入先マスタ詳細情報クラス 機能は以下の通り 仕入先マスタの詳細情報を取得します。
class | SupplierExistenceCheck 仕入先コード存在チェッククラス 機能は以下の通り 仕入先コード存在チェック結果を取得します。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems での ReferenceController のサブクラス
 class GoodsMvtGetItems
出庫確認一覧照会情報クラス
機能は以下の通り
出庫確認一覧照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability での ReferenceController のサブクラス
 class MaterialAvailability
品目在庫確認情報クラス
機能は以下の通り
品目在庫確認情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での ReferenceController のサブクラス
 class MaterialGetAll
品目マスタ照会情報クラス
機能は以下の通り
品目マスタ照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber での ReferenceController のサブクラス
 class StdMaterialGetIntNumberList
品目コード割当済一覧クラス
機能は以下の通り
品目コード割当済の情報を一覧形式で取得します。

jp.co.intra_mart.foundation.sap.module.sales での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.sales での ReferenceController のサブクラス
class | BillingDocGetListController 請求伝票一覧照会情報コントローラクラス 機能は以下の通り 請求伝票一覧照会情報を保持します。
class | SalesOrderGetListController 販売伝票一覧照会コントローラクラス 機能は以下の通り 販売伝票一覧の情報を取得します。
class | SalesOrderGetStatusController 販売伝票ステータス一覧照会コントローラクラス 機能は以下の通り 販売伝票ステータス一覧の情報を取得します。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での ReferenceController のサブクラス
 class BillingDocGetDetail
請求伝票詳細照会情報クラス
機能は以下の通り
請求伝票詳細照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist での ReferenceController のサブクラス
 class BillingDocGetList
請求伝票一覧照会情報クラス
機能は以下の通り
請求伝票一覧照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist での ReferenceController のサブクラス
 class SalesOrderGetList
販売伝票一覧照会情報クラス
機能は以下の通り
販売伝票一覧照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus での ReferenceController のサブクラス
 class SalesOrderGetStatus
販売伝票ステータス一覧照会情報クラス
機能は以下の通り
販売伝票ステータス一覧照会情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.UpdateController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.UpdateController の使用

UpdateController を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica |
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple |
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 |

jp.co.intra_mart.foundation.sap.module.accounting での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.accounting での UpdateController のサブクラス
 class AccEmployeePayPostController
伝票登録コントローラクラス
機能は以下の通り
伝票を登録します。

jp.co.intra_mart.foundation.sap.module.purchase での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.purchase での UpdateController のサブクラス
class | GoodsMvtCreateController 入庫伝票登録コントローラクラス 機能は以下の通り 入庫伝票を登録します。
class | MaterialSaveReplicaController 品目マスタ更新コントローラクラス 機能は以下の通り 品目マスタを更新します。
class | PurchaseOrderPayPost 伝票登録クラス 機能は以下の通り 伝票を登録します。
class | PurchaseOrderPayPostController 伝票登録コントローラクラス 機能は以下の通り 伝票を登録します。
class | PurchaseOrderPostChangeController 伝票登録変更コントローラクラス 機能は以下の通り 伝票を変更します。
class | PurchaseRelease 承認情報スーパークラス 機能は以下の通り 承認情報を保持します。
class | PurchaseReleaseController 伝票承認コントローラクラス 機能は以下の通り 伝票を承認します。
class | PurchaseResetReleaseController 伝票承認取消コントローラクラス 機能は以下の通り 伝票の承認取消します。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での UpdateController のサブクラス
 class GoodsMvtCreate
入出庫伝票登録情報クラス
機能は以下の通り
入出庫伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica での UpdateController のサブクラス
 class MaterialSaveReplica
品目マスタ更新情報クラス
機能は以下の通り
品目マスタ更新情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.sales での UpdateController のサブクラス
class | BillingDocCreateMultipleController 請求伝票登録コントローラクラス 機能は以下の通り 請求伝票を登録します。
class | InquiryCreateFromData2Controller 引合伝票登録コントローラクラス 機能は以下の通り 引合伝票を登録します。
class | QuotationCreateFromData2Controller 見積伝票登録情報コントローラクラス 機能は以下の通り 見積伝票登録情報を保持します。
class | SalesOrderCreateFromDat2Controller 受注伝票登録コントローラクラス 機能は以下の通り 受注伝票を登録します。

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple での UpdateController のサブクラス
 class BillingDocCreateMultiple
請求伝票登録情報クラス
機能は以下の通り
請求伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での UpdateController のサブクラス
 class InquiryCreateFromData2
引合伝票登録情報クラス
機能は以下の通り
引合伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での UpdateController のサブクラス
 class QuotationCreateFromData2
見積伝票登録情報クラス
機能は以下の通り
見積伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での UpdateController のサブクラス
 class SalesOrderCreateFromDat2
受注伝票登録情報クラス
機能は以下の通り
受注伝票登録情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException の使用

SAPBapiReturnErrMessageExistException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module での SAPBapiReturnErrMessageExistException の使用

SAPBapiReturnErrMessageExistException をスローする jp.co.intra_mart.foundation.sap.module のメソッド
protected  void AbstractController.executeBapi(BapiController bapiController)
引数で指定された bapiController のexecuteBapiメソッドを実行します。

jp.co.intra_mart.foundation.sap.module.purchase での SAPBapiReturnErrMessageExistException の使用

SAPBapiReturnErrMessageExistException をスローする jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 void PurchaseRelease.executeBapi(BapiController bapiController)
伝票承認取消処理を実行します。
 void PurchaseOrderPayPost.executeBapi(BapiController bapiController)
購買発注伝票の登録及び変更に共通で使用する項目に値をセットした後、 AbstractController#executeBapi()を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException の使用

SAPModuleAppException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting.exception | ＳＡＰ連携財務会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial.exception | ＳＡＰ連携管理会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.exception | ＳＡＰ連携経費購買系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.sales.exception |

jp.co.intra_mart.foundation.sap.module.accounting.exception での SAPModuleAppException の使用

jp.co.intra_mart.foundation.sap.module.accounting.exception での SAPModuleAppException のサブクラス
 class SAPAccountingAppException
p 会計系APIアプリケーション例外クラス

jp.co.intra_mart.foundation.sap.module.financial.exception での SAPModuleAppException の使用

jp.co.intra_mart.foundation.sap.module.financial.exception での SAPModuleAppException のサブクラス
 class SAPFinancialAppException
会計系APIアプリケーション例外クラス

jp.co.intra_mart.foundation.sap.module.purchase.exception での SAPModuleAppException の使用

jp.co.intra_mart.foundation.sap.module.purchase.exception での SAPModuleAppException のサブクラス
 class SAPPurchaseAppException
購買系APIアプリケーション例外クラス

jp.co.intra_mart.foundation.sap.module.sales.exception での SAPModuleAppException の使用

jp.co.intra_mart.foundation.sap.module.sales.exception での SAPModuleAppException のサブクラス
 class SAPSalesAppException
販売管理系APIアプリケーション例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException の使用

SAPModuleSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting.exception | ＳＡＰ連携財務会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial.exception | ＳＡＰ連携管理会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.exception | ＳＡＰ連携経費購買系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.sales.exception |

jp.co.intra_mart.foundation.sap.module.accounting.exception での SAPModuleSystemException の使用

jp.co.intra_mart.foundation.sap.module.accounting.exception での SAPModuleSystemException のサブクラス
 class SAPAccountingSystemException
会計系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.financial.exception での SAPModuleSystemException の使用

jp.co.intra_mart.foundation.sap.module.financial.exception での SAPModuleSystemException のサブクラス
 class SAPFinancialSystemException
会計系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.purchase.exception での SAPModuleSystemException の使用

jp.co.intra_mart.foundation.sap.module.purchase.exception での SAPModuleSystemException のサブクラス
 class SAPPurchaseSystemException
購買系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.sales.exception での SAPModuleSystemException の使用

jp.co.intra_mart.foundation.sap.module.sales.exception での SAPModuleSystemException のサブクラス
 class SAPSalesSystemException
販売管理系APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.exception (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.exception
例外
SAPBapiReturnErrMessageExistException
SAPModuleAppException
SAPModuleSystemException


jp.co.intra_mart.foundation.sap.module.exception (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.exception

例外の概要
SAPBapiReturnErrMessageExistException | BAPI実行結果例外クラス
SAPModuleAppException | モジュール用データ取得・追加・更新APIアプリケーション例外クラス
SAPModuleSystemException | モジュール用データ取得・追加・更新APIシステム例外クラス


jp.co.intra_mart.foundation.sap.module.exception クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.common.exception.SAPException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException


パッケージ jp.co.intra_mart.foundation.sap.module.exception の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.exception の使用

jp.co.intra_mart.foundation.sap.module.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.accounting.exception | ＳＡＰ連携財務会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial.exception | ＳＡＰ連携管理会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.exception | ＳＡＰ連携経費購買系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.sales.exception |

jp.co.intra_mart.foundation.sap.module により使用される jp.co.intra_mart.foundation.sap.module.exception のクラス
SAPBapiReturnErrMessageExistException
BAPI実行結果例外クラス

jp.co.intra_mart.foundation.sap.module.accounting.exception により使用される jp.co.intra_mart.foundation.sap.module.exception のクラス
SAPModuleAppException
モジュール用データ取得・追加・更新APIアプリケーション例外クラス
SAPModuleSystemException
モジュール用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.financial.exception により使用される jp.co.intra_mart.foundation.sap.module.exception のクラス
SAPModuleAppException
モジュール用データ取得・追加・更新APIアプリケーション例外クラス
SAPModuleSystemException
モジュール用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.exception のクラス
SAPBapiReturnErrMessageExistException
BAPI実行結果例外クラス

jp.co.intra_mart.foundation.sap.module.purchase.exception により使用される jp.co.intra_mart.foundation.sap.module.exception のクラス
SAPModuleAppException
モジュール用データ取得・追加・更新APIアプリケーション例外クラス
SAPModuleSystemException
モジュール用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.sales.exception により使用される jp.co.intra_mart.foundation.sap.module.exception のクラス
SAPModuleAppException
モジュール用データ取得・追加・更新APIアプリケーション例外クラス
SAPModuleSystemException
モジュール用データ取得・追加・更新APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SAPBapiReturnErrMessageExistException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.exception
クラス SAPBapiReturnErrMessageExistException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException
すべての実装インタフェース:
Serializable
public class SAPBapiReturnErrMessageExistException
extends SAPException

BAPI実行結果例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPBapiReturnErrMessageExistException(String message)
BAPI実行結果例外
SAPBapiReturnErrMessageExistException(String message, Throwable ex)
BAPI実行結果例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPBapiReturnErrMessageExistException

public SAPBapiReturnErrMessageExistException(String message,
                                             Throwable ex)
BAPI実行結果例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPBapiReturnErrMessageExistException

public SAPBapiReturnErrMessageExistException(String message)
BAPI実行結果例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPModuleAppException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.exception
クラス SAPModuleAppException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
SAPAccountingAppException, SAPFinancialAppException, SAPPurchaseAppException, SAPSalesAppException
public class SAPModuleAppException
extends SAPException

モジュール用データ取得・追加・更新APIアプリケーション例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPModuleAppException(String message)
モジュール用データ取得・追加・更新APIアプリケーション例外
SAPModuleAppException(String message, Throwable ex)
モジュール用データ取得・追加・更新APIアプリケーション例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPModuleAppException

public SAPModuleAppException(String message,
                             Throwable ex)
モジュール用データ取得・追加・更新APIアプリケーション例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPModuleAppException

public SAPModuleAppException(String message)
モジュール用データ取得・追加・更新APIアプリケーション例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SAPModuleSystemException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.exception
クラス SAPModuleSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
SAPAccountingSystemException, SAPFinancialSystemException, SAPPurchaseSystemException, SAPSalesSystemException
public class SAPModuleSystemException
extends SAPException

モジュール用データ取得・追加・更新APIシステム例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPModuleSystemException(String message)
モジュール用データ取得・追加・更新APIシステム例外
SAPModuleSystemException(String message, Throwable ex)
モジュール用データ取得・追加・更新APIシステム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPModuleSystemException

public SAPModuleSystemException(String message,
                                Throwable ex)
モジュール用データ取得・追加・更新APIシステム例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPModuleSystemException

public SAPModuleSystemException(String message)
モジュール用データ取得・追加・更新APIシステム例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract の使用

jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail の使用

CommonCenterGrpGetDetail を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での CommonCenterGrpGetDetail の使用

jp.co.intra_mart.foundation.sap.module.financial での CommonCenterGrpGetDetail のサブクラス
class | CostCenterGroupGetDetail 原価センタグループ情報取得クラス 機能は以下の通り 原価センタグループ情報を取得します。
class | ProfitCenterGrpGetDetail 利益センタグループ情報取得クラス 機能は以下の通り 利益センタグループ情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail の使用

jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController の使用

jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail の使用

CreditorGetDetail を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での CreditorGetDetail の使用

CreditorGetDetail を返す jp.co.intra_mart.foundation.sap.module.financial のメソッド
 CreditorGetDetail CreditorGetDetailController.getCreditorGetDetail()
仕入先マスタ詳細情報を取得します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController の使用

jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail の使用

DebtorGetDetail を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での DebtorGetDetail の使用

DebtorGetDetail を返す jp.co.intra_mart.foundation.sap.module.financial のメソッド
 DebtorGetDetail DebtorGetDetailController.getDebtorGetDetail()
得意先マスタ詳細情報を取得します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController の使用

jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail の使用

jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController の使用

jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ExchRate の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ExchRate の使用

ExchRate を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での ExchRate の使用

ExchRate を返す jp.co.intra_mart.foundation.sap.module.financial のメソッド
ExchRate | ExchangeRateGetDetailController.getExchRate() 換算レート、係数 (通貨ペア)を取得します。
ExchRate | ExchangeRateGetDetail.getExchRate() 換算レート、係数 (通貨ペア)を取得します。

ExchRate 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.financial のメソッド
void | ExchangeRateGetDetailController.setExchRate(ExchRate exchRate) 換算レート、係数 (通貨ペア)を設定します。
void | ExchangeRateGetDetail.setExchRate(ExchRate exchRate) 換算レート、係数 (通貨ペア)を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ExpActivity の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ExpActivity の使用

jp.co.intra_mart.foundation.sap.module.financial.ExpActivity はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ExpMessage の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ExpMessage の使用

jp.co.intra_mart.foundation.sap.module.financial.ExpMessage はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement の使用

jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie の使用

jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone の使用

jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes の使用

jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues の使用

jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement の使用

jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail の使用

jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController の使用

jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList の使用

jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController の使用

jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.MasterData の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.MasterData の使用

MasterData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での MasterData の使用

MasterData を返す jp.co.intra_mart.foundation.sap.module.financial のメソッド
MasterData | InternalOrderGetDetailController.getMasterData() 指図のマスタデータ構造を取得します。
MasterData | InternalOrderGetDetail.getMasterData() 指図のマスタデータ構造を取得します。

MasterData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.financial のメソッド
void | InternalOrderGetDetailController.setMasterData(MasterData masterData) 指図のマスタデータ構造を設定します。
void | InternalOrderGetDetail.setMasterData(MasterData masterData) 指図のマスタデータ構造を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.OrderList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.OrderList の使用

jp.co.intra_mart.foundation.sap.module.financial.OrderList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail の使用

jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController の使用

jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition の使用

ProjectDefinition を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での ProjectDefinition の使用

ProjectDefinition を返す jp.co.intra_mart.foundation.sap.module.financial のメソッド
ProjectDefinition | ProjectGetInfoController.getProjectDefinitionInfo() プロジェクトについての詳細情報を取得します。
ProjectDefinition | ProjectGetInfo.getProjectDefinitionInfo() プロジェクトについての詳細情報を取得します。

ProjectDefinition 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.financial のメソッド
void | ProjectGetInfoController.setProjectDefinition(ProjectDefinition projectDefinition) プロジェクトについての詳細情報を設定します。
void | ProjectGetInfo.setProjectDefinition(ProjectDefinition projectDefinition) プロジェクトについての詳細情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo の使用

jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController の使用

jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.SystemStatus の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.SystemStatus の使用

jp.co.intra_mart.foundation.sap.module.financial.SystemStatus はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.UserStatus の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.UserStatus の使用

jp.co.intra_mart.foundation.sap.module.financial.UserStatus はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException の使用

SAPFinancialAppException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での SAPFinancialAppException の使用

SAPFinancialAppException をスローする jp.co.intra_mart.foundation.sap.module.financial のメソッド
 void ProjectGetInfoController.executeBapi()
ProjectGetInfoのexecuteBapi()を呼び出しWBSの詳細を取得します。
 void ProjectGetInfo.executeBapi()
BapiControllerによりWBSの詳細情報の検索します。
 void ProfitCenterGrpGetDetailController.executeBapi()
ProfitCenterGrpGetDetailのexecuteBapi()を呼び出し利益センタグループを取得します。
 void ProfitCenterGrpGetDetail.executeBapi()
BapiControllerにより利益センタグループ検索を検索します。
 void InternalOrderGetListController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し内部指図書一覧を取得します。
 void InternalOrderGetList.executeBapi()
BapiControllerにより内部指図書（一覧）情報を検索します。
 void InternalOrderGetDetailController.executeBapi()
InternalOrderGetDetailのexecuteBapi()を呼び出し内部指図書詳細を取得します。
 void InternalOrderGetDetail.executeBapi()
BapiControllerにより内部指図書詳細情報を検索します。
 void ExchangeRateGetDetailController.executeBapi()
ExchangeRateGetDetailのexecuteBapi()を呼び出し為替換算レートを取得します。
 void ExchangeRateGetDetail.executeBapi()
BapiControllerにより為替換算レート情報を検索します。
 void DebtorGetDetail.executeBapi()
BapiControllerにより得意先コードを検索します。
 void CreditorGetDetail.executeBapi()
BapiControllerにより仕入先コードを検索します。
 void CostCenterGroupGetDetailController.executeBapi()
CostCenterGroupGetDetailのexecuteBapi()を呼び出し原価センタグループを取得します。
 void CostCenterGroupGetDetail.executeBapi()
BapiControllerにより原価センタグループ検索を検索します。

SAPFinancialAppException をスローする jp.co.intra_mart.foundation.sap.module.financial のコンストラクタ
ProfitCenterGrpGetDetailController(String controllingarea, String groupname)
ProfitCenterGrpGetDetailController(String controllingarea, String groupname, SapClient sapClient)
ProfitCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo)
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
InternalOrderGetList(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
InternalOrderGetDetailController(String orderid, String language)
InternalOrderGetDetailController(String orderid, String language, SapClient sapClient)
InternalOrderGetDetail(String orderId, String language, SapClient sapClient)
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date)
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
ExchangeRateGetDetail(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
DebtorGetDetailController(String debtorid, String companycode)
DebtorGetDetailController(String debtorid, String companycode, SapClient sapClient)
DebtorGetDetail(String Debtorid, String Companycode, SapClient sapClient)
CreditorGetDetailController(String creditorid, String companycode)
CreditorGetDetailController(String creditorid, String companycode, SapClient sapClient)
CreditorGetDetail(String creditorid, String companycode, SapClient sapClient)
CostCenterGroupGetDetailController(String controllingarea, String groupname)
CostCenterGroupGetDetailController(String controllingarea, String groupname, SapClient sapClient)
CostCenterGroupGetDetail(String controllingarea, String groupname, SapClient sapClient)
CommonCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialSystemException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialSystemException の使用

SAPFinancialSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での SAPFinancialSystemException の使用

SAPFinancialSystemException をスローする jp.co.intra_mart.foundation.sap.module.financial のメソッド
 void ProjectGetInfoController.executeBapi()
ProjectGetInfoのexecuteBapi()を呼び出しWBSの詳細を取得します。
 void ProjectGetInfoController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 String ProjectGetInfoController.getProjectDefinition()
プロジェクト定義を識別するキーを取得します。
 String ProjectGetInfoController.getWithActivities()
従属活動を取得します。
 String ProjectGetInfoController.getWithMilestones()
従属 WBS マイルストーンを取得します。
 String ProjectGetInfoController.getWithSubtree()
サブプロジェクトを取得します。
 void ProjectGetInfo.executeBapi()
BapiControllerによりWBSの詳細情報の検索します。
 void ProjectGetInfo.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void ProjectGetInfo.setImportParam(BapiController bapiController)
WEBの詳細情報を検索する条件ををセットします。
 void ProfitCenterGrpGetDetailController.executeBapi()
ProfitCenterGrpGetDetailのexecuteBapi()を呼び出し利益センタグループを取得します。
 void ProfitCenterGrpGetDetail.executeBapi()
BapiControllerにより利益センタグループ検索を検索します。
 void InternalOrderGetListController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し内部指図書一覧を取得します。
 void InternalOrderGetList.executeBapi()
BapiControllerにより内部指図書（一覧）情報を検索します。
 void InternalOrderGetList.setImportParam(BapiController bapiController)
内部指図書（一覧）情報を検索する条件ををセットします。
 void InternalOrderGetDetailController.executeBapi()
InternalOrderGetDetailのexecuteBapi()を呼び出し内部指図書詳細を取得します。
 void InternalOrderGetDetail.executeBapi()
BapiControllerにより内部指図書詳細情報を検索します。
 void InternalOrderGetDetail.setImportParam(BapiController bapiController)
内部指図書詳細情報を検索する条件ををセットします。
 void ExchangeRateGetDetailController.executeBapi()
ExchangeRateGetDetailのexecuteBapi()を呼び出し為替換算レートを取得します。
 void ExchangeRateGetDetail.executeBapi()
BapiControllerにより為替換算レート情報を検索します。
 void ExchangeRateGetDetail.setImportParam(BapiController bapiController)
為替換算レート情報を検索する条件ををセットします。
 void DebtorGetDetail.executeBapi()
BapiControllerにより得意先コードを検索します。
 void DebtorGetDetail.setImportParam(BapiController bapiController)
得意先コードの詳細情報を検索する条件ををセットします。
 void CreditorGetDetail.executeBapi()
BapiControllerにより仕入先コードを検索します。
 void CreditorGetDetail.setImportParam(BapiController bapiController)
仕入先コードの詳細情報を検索する条件ををセットします。
 void CostCenterGroupGetDetailController.executeBapi()
CostCenterGroupGetDetailのexecuteBapi()を呼び出し原価センタグループを取得します。
 void CostCenterGroupGetDetail.executeBapi()
BapiControllerにより原価センタグループ検索を検索します。
 void CommonCenterGrpGetDetail.setImportParam(BapiController bapiController)
センタグループを検索する条件ををセットします。

SAPFinancialSystemException をスローする jp.co.intra_mart.foundation.sap.module.financial のコンストラクタ
ProfitCenterGrpGetDetailController(String controllingarea, String groupname)
ProfitCenterGrpGetDetailController(String controllingarea, String groupname, SapClient sapClient)
ProfitCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo)
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
InternalOrderGetList(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
InternalOrderGetDetailController(String orderid, String language)
InternalOrderGetDetailController(String orderid, String language, SapClient sapClient)
InternalOrderGetDetail(String orderId, String language, SapClient sapClient)
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date)
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
ExchangeRateGetDetail(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
DebtorGetDetailController(String debtorid, String companycode)
DebtorGetDetailController(String debtorid, String companycode, SapClient sapClient)
DebtorGetDetail(String Debtorid, String Companycode, SapClient sapClient)
CreditorGetDetailController(String creditorid, String companycode)
CreditorGetDetailController(String creditorid, String companycode, SapClient sapClient)
CreditorGetDetail(String creditorid, String companycode, SapClient sapClient)
CostCenterGroupGetDetailController(String controllingarea, String groupname)
CostCenterGroupGetDetailController(String controllingarea, String groupname, SapClient sapClient)
CostCenterGroupGetDetail(String controllingarea, String groupname, SapClient sapClient)
CommonCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.financial.exception (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.financial.exception
例外
SAPFinancialAppException
SAPFinancialSystemException


jp.co.intra_mart.foundation.sap.module.financial.exception (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.financial.exception

ＳＡＰ連携管理会計系例外クラスを提供します。

参照:
説明

例外の概要
SAPFinancialAppException | 会計系APIアプリケーション例外クラス
SAPFinancialSystemException | 会計系APIシステム例外クラス

パッケージ jp.co.intra_mart.foundation.sap.module.financial.exception の説明

ＳＡＰ連携管理会計系例外クラスを提供します。


jp.co.intra_mart.foundation.sap.module.financial.exception クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.financial.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.common.exception.SAPException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
            • class jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
            • class jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialSystemException


パッケージ jp.co.intra_mart.foundation.sap.module.financial.exception の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.financial.exception の使用

jp.co.intra_mart.foundation.sap.module.financial.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial により使用される jp.co.intra_mart.foundation.sap.module.financial.exception のクラス
SAPFinancialAppException
会計系APIアプリケーション例外クラス
SAPFinancialSystemException
会計系APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SAPFinancialAppException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial.exception
クラス SAPFinancialAppException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
                    拡張 jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException
すべての実装インタフェース:
Serializable
public class SAPFinancialAppException
extends SAPModuleAppException

会計系APIアプリケーション例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPFinancialAppException(String message)
会計系APIアプリケーション例外
SAPFinancialAppException(String message, Throwable ex)
会計系APIアプリケーション例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPFinancialAppException

public SAPFinancialAppException(String message,
                                Throwable ex)
会計系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPFinancialAppException

public SAPFinancialAppException(String message)
会計系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPFinancialSystemException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial.exception
クラス SAPFinancialSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
                    拡張 jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialSystemException
すべての実装インタフェース:
Serializable
public class SAPFinancialSystemException
extends SAPModuleSystemException

会計系APIシステム例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPFinancialSystemException(String message, Throwable ex)
会計系APIシステム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPFinancialSystemException

public SAPFinancialSystemException(String message,
                                   Throwable ex)
会計系APIシステム例外

パラメータ:
message - エラーメッセージ
ex - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AllowedBusTract (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス AllowedBusTract

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract
すべての実装インタフェース:
Serializable
public class AllowedBusTract
extends Object
implements Serializable

使用可能業務トランザクションのテーブル情報クラス 機能は以下の通り

  • 使用可能業務トランザクションのテーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
AllowedBusTract()
使用可能業務トランザクションのテーブルを作成します。
メソッドの概要
String | getDescript() テキスト (30 文字)を取得します。
String | getTrans() 取引を取得します。
void | setDescript(String strDescript) テキスト (30 文字)を設定します。
void | setTrans(String strTrans) 取引を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AllowedBusTract

public AllowedBusTract()
使用可能業務トランザクションのテーブルを作成します。

メソッドの詳細

getTrans

public String getTrans()
取引を取得します。

戻り値:
srtTrans 取引

getDescript

public String getDescript()
テキスト (30 文字)を取得します。

戻り値:
srtDescript テキスト (30 文字)

setTrans

public void setTrans(String strTrans)
取引を設定します。

パラメータ:
strTrans - 取引

setDescript

public void setDescript(String strDescript)
テキスト (30 文字)を設定します。

パラメータ:
strDescript - テキスト (30 文字)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CommonCenterGrpGetDetail (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス CommonCenterGrpGetDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
CostCenterGroupGetDetail, ProfitCenterGrpGetDetail
public class CommonCenterGrpGetDetail
extends ReferenceController
implements Serializable

原価・利益センタグループ情報取得共通クラス
機能は以下の通り

  • 原価・利益センタグループ情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
CommonCenterGrpGetDetail(SapClient sapClient)
センタグループ情報を作成
CommonCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)
メソッドの概要
String | getControllingarea() 管理領域を取得します。
String | getGroupname() グループ名を取得します。
ArrayList | getHierarchyNodesList() 階層ノード一覧を取得します。
ArrayList | getHierarchyValuesList() 階層値一覧を取得します。
void | setControllingarea(String strControllingarea) 管理領域を設定します。
void | setExportParam(BapiController bapiController) センタグループ情報ををセットします。
void | setGroupname(String strGroupname) グループ名を設定します。
void | setHierarchyNodesList(ArrayList hierarchyNodesList) 階層ノード一覧を設定します。
void | setHierarchyValuesList(ArrayList hierarchyValuesList) 階層値一覧を設定します。
void | setImportParam(BapiController bapiController) センタグループを検索する条件ををセットします。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CommonCenterGrpGetDetail

public CommonCenterGrpGetDetail(SapClient sapClient)
センタグループ情報を作成

パラメータ:
sapClient - SapClient SAPへの接続情報を格納しているオブジェクト

CommonCenterGrpGetDetail

public CommonCenterGrpGetDetail(String controllingarea,
                                String groupname,
                                SapClient sapClient)
                         throws SAPAuthAppException,
                                SAPAuthSystemException,
                                SAPGeneralAppException,
                                SAPGeneralSystemException,
                                SAPFinancialAppException,
                                SAPFinancialSystemException
パラメータ:
controllingarea - 管理領域
groupname - グループ名
sapClient - SapClient SAPへの接続情報を格納しているオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPFinancialSystemException
センタグループを検索する条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPFinancialSystemException - 会計系APIシステム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
センタグループ情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setControllingarea

public void setControllingarea(String strControllingarea)
管理領域を設定します。

パラメータ:
strControllingarea - 管理領域

setGroupname

public void setGroupname(String strGroupname)
グループ名を設定します。

パラメータ:
strGroupname - グループ名

getControllingarea

public String getControllingarea()
管理領域を取得します。

戻り値:
srtControllingarea 管理領域

getGroupname

public String getGroupname()
グループ名を取得します。

戻り値:
srtGroupname グループ名

setHierarchyNodesList

public void setHierarchyNodesList(ArrayList hierarchyNodesList)
階層ノード一覧を設定します。

パラメータ:
hierarchyNodesList - 階層ノード一覧

setHierarchyValuesList

public void setHierarchyValuesList(ArrayList hierarchyValuesList)
階層値一覧を設定します。

パラメータ:
hierarchyValuesList - 階層値一覧

getHierarchyNodesList

public ArrayList getHierarchyNodesList()
階層ノード一覧を取得します。

戻り値:
hierarchyNodesList 階層ノード一覧

getHierarchyValuesList

public ArrayList getHierarchyValuesList()
階層値一覧を取得します。

戻り値:
hierarchyValuesList 階層値一覧

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CostCenterGroupGetDetail (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス CostCenterGroupGetDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail
                拡張 jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail
すべての実装インタフェース:
Serializable
public class CostCenterGroupGetDetail
extends CommonCenterGrpGetDetail
implements Serializable

原価センタグループ情報取得クラス
機能は以下の通り

  • 原価センタグループ情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
CostCenterGroupGetDetail(SapClient sapClient)
原価センタグループ情報を作成
CostCenterGroupGetDetail(String controllingarea, String groupname, SapClient sapClient)
メソッドの概要
 void executeBapi()
BapiControllerにより原価センタグループ検索を検索します。
クラス jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail から継承したメソッド
getControllingarea, getGroupname, getHierarchyNodesList, getHierarchyValuesList, setControllingarea, setExportParam, setGroupname, setHierarchyNodesList, setHierarchyValuesList, setImportParam, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CostCenterGroupGetDetail

public CostCenterGroupGetDetail(SapClient sapClient)
原価センタグループ情報を作成

パラメータ:
sapClient - SapClient SAPへの接続情報を格納しているオブジェクト

CostCenterGroupGetDetail

public CostCenterGroupGetDetail(String controllingarea,
                                String groupname,
                                SapClient sapClient)
                         throws SAPAuthAppException,
                                SAPAuthSystemException,
                                SAPGeneralAppException,
                                SAPGeneralSystemException,
                                SAPFinancialAppException,
                                SAPFinancialSystemException
パラメータ:
controllingarea - 管理領域
groupname - グループ名
sapClient - SapClient SAPへの接続情報を格納しているオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
BapiControllerにより原価センタグループ検索を検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CostCenterGroupGetDetailController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス CostCenterGroupGetDetailController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController
すべての実装インタフェース:
Serializable
public class CostCenterGroupGetDetailController
extends Object
implements Serializable

原価センタグループコントローラクラス
機能は以下の通り

  • 原価センタグループを取得します。

関連項目:
直列化された形式

コンストラクタの概要
CostCenterGroupGetDetailController()
CostCenterGroupGetDetailControllerのコンストラクタを生成します。
CostCenterGroupGetDetailController(SapClient sapClient)
CostCenterGroupGetDetailControllerのコンストラクタを生成します。
CostCenterGroupGetDetailController(String controllingarea, String groupname)
CostCenterGroupGetDetailController(String controllingarea, String groupname, SapClient sapClient)
メソッドの概要
 void executeBapi()
CostCenterGroupGetDetailのexecuteBapi()を呼び出し原価センタグループを取得します。
 String getControllingarea()
管理領域を取得します。
 String getGroupname()
グループ名を取得します。
 ArrayList getHierarchyNodesList()
階層ノード一覧を取得します。
 ArrayList getHierarchyValuesList()
階層値一覧を取得します。
 void setControllingarea(String strControllingarea)
管理領域を設定します。
 void setGroupname(String strGroupname)
グループ名を設定します。
 void setHierarchyNodesList(ArrayList hierarchyNodesList)
階層ノード一覧を設定します。
 void setHierarchyValuesList(ArrayList hierarchyValuesList)
階層値一覧を設定します。
 String toString()
デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CostCenterGroupGetDetailController

public CostCenterGroupGetDetailController(String controllingarea,
                                          String groupname)
                                   throws SAPAuthAppException,
                                          SAPAuthSystemException,
                                          SAPGeneralAppException,
                                          SAPGeneralSystemException,
                                          SAPFinancialAppException,
                                          SAPFinancialSystemException
パラメータ:
controllingarea - 管理領域
groupname - グループ名
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

CostCenterGroupGetDetailController

public CostCenterGroupGetDetailController(String controllingarea,
                                          String groupname,
                                          SapClient sapClient)
                                   throws SAPAuthAppException,
                                          SAPAuthSystemException,
                                          SAPGeneralAppException,
                                          SAPGeneralSystemException,
                                          SAPFinancialAppException,
                                          SAPFinancialSystemException
パラメータ:
controllingarea - 管理領域
groupname - グループ名
sapClient - SapClient SAPへの接続情報を格納したオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

CostCenterGroupGetDetailController

public CostCenterGroupGetDetailController()
CostCenterGroupGetDetailControllerのコンストラクタを生成します。

CostCenterGroupGetDetailController

public CostCenterGroupGetDetailController(SapClient sapClient)
CostCenterGroupGetDetailControllerのコンストラクタを生成します。

パラメータ:
sapClient - SapClient SAPへの接続情報を格納したオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
CostCenterGroupGetDetailのexecuteBapi()を呼び出し原価センタグループを取得します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setControllingarea

public void setControllingarea(String strControllingarea)
管理領域を設定します。

パラメータ:
strControllingarea - 管理領域

setGroupname

public void setGroupname(String strGroupname)
グループ名を設定します。

パラメータ:
strGroupname - グループ名

getControllingarea

public String getControllingarea()
管理領域を取得します。

戻り値:
srtControllingarea 管理領域

getGroupname

public String getGroupname()
グループ名を取得します。

戻り値:
srtGroupname グループ名

setHierarchyNodesList

public void setHierarchyNodesList(ArrayList hierarchyNodesList)
階層ノード一覧を設定します。

パラメータ:
hierarchyNodesList - 階層ノード一覧

setHierarchyValuesList

public void setHierarchyValuesList(ArrayList hierarchyValuesList)
階層値一覧を設定します。

パラメータ:
hierarchyValuesList - 階層値一覧

getHierarchyNodesList

public ArrayList getHierarchyNodesList()
階層ノード一覧を取得します。

戻り値:
hierarchyNodesList 階層ノード一覧

getHierarchyValuesList

public ArrayList getHierarchyValuesList()
階層値一覧を取得します。

戻り値:
hierarchyValuesList 階層値一覧

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CreditorGetDetail (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス CreditorGetDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail
すべての実装インタフェース:
Serializable
public class CreditorGetDetail
extends ReferenceController
implements Serializable

仕入先詳細情報取得クラス
機能は以下の通り

  • 仕入先詳細情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
CreditorGetDetail(SapClient sapClient)
仕入先詳細情報を作成
CreditorGetDetail(String creditorid, String companycode, SapClient sapClient)
メソッドの概要
void | executeBapi() BapiControllerにより仕入先コードを検索します。
ArrayList | getBankDataInfoList() 銀行データ情報一覧を取得します｡
String | getCompanycode() 会社コードを取得します｡
CompanyDataInfo | getCompanyDataInfo() 会社コード依存データ情報を取得します｡
String | getCreditorid() 仕入先コードを取得します｡
GeneralDataInfo | getGeneralDataInfo() 一般データ情報を取得します｡
void | setBankDataInfoList(ArrayList bankDataInfoList) 銀行データ情報を設定します｡
void | setCompanycode(String strCompanycode) 会社コードを設定します｡
void | setCompanyDataInfo(CompanyDataInfo companyDataInfo) 会社依存データ情報を設定します｡
void | setCreditorid(String strCreditorid) 仕入先コードを設定します｡
void | setExportParam(BapiController bapiController) 仕入先コードの詳細情報ををセットします。
void | setGeneralDataInfo(GeneralDataInfo generalDataInfo) 一般データ情報を設定します｡
void | setImportParam(BapiController bapiController) 仕入先コードの詳細情報を検索する条件ををセットします。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CreditorGetDetail

public CreditorGetDetail(SapClient sapClient)
仕入先詳細情報を作成

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト

CreditorGetDetail

public CreditorGetDetail(String creditorid,
                         String companycode,
                         SapClient sapClient)
                  throws SAPAuthAppException,
                         SAPAuthSystemException,
                         SAPGeneralAppException,
                         SAPGeneralSystemException,
                         SAPFinancialAppException,
                         SAPFinancialSystemException
パラメータ:
creditorid - 仕入先コード
companycode - 会社コード
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
BapiControllerにより仕入先コードを検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計発注業務システム例外

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPFinancialSystemException
仕入先コードの詳細情報を検索する条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPFinancialSystemException - 会計発注業務システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
仕入先コードの詳細情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getCreditorid

public String getCreditorid()
仕入先コードを取得します｡

戻り値:
strCreditorid 仕入先コード

getCompanycode

public String getCompanycode()
会社コードを取得します｡

戻り値:
strCompanycode 会社コード

getGeneralDataInfo

public GeneralDataInfo getGeneralDataInfo()
一般データ情報を取得します｡

戻り値:
generalDataInfo

getCompanyDataInfo

public CompanyDataInfo getCompanyDataInfo()
会社コード依存データ情報を取得します｡

戻り値:
companyDataInfo

getBankDataInfoList

public ArrayList getBankDataInfoList()
銀行データ情報一覧を取得します｡

戻り値:
bankDataInfoList

setCreditorid

public void setCreditorid(String strCreditorid)
仕入先コードを設定します｡

パラメータ:
strCreditorid - 仕入先コード

setCompanycode

public void setCompanycode(String strCompanycode)
会社コードを設定します｡

パラメータ:
strCompanycode - 会社コード

setGeneralDataInfo

public void setGeneralDataInfo(GeneralDataInfo generalDataInfo)
一般データ情報を設定します｡

パラメータ:
generalDataInfo - 一般データ情報

setCompanyDataInfo

public void setCompanyDataInfo(CompanyDataInfo companyDataInfo)
会社依存データ情報を設定します｡

パラメータ:
companyDataInfo - 会社依存データ情報

setBankDataInfoList

public void setBankDataInfoList(ArrayList bankDataInfoList)
銀行データ情報を設定します｡

パラメータ:
bankDataInfoList - 銀行データ情報

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CreditorGetDetailController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス CreditorGetDetailController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController
すべての実装インタフェース:
Serializable
public class CreditorGetDetailController
extends Object
implements Serializable

仕入先詳細コントローラクラス
機能は以下の通り

  • 仕入先詳細を取得します。

関連項目:
直列化された形式

コンストラクタの概要
CreditorGetDetailController()
DebtorGetDetailControllerのコンストラクタを生成します。
CreditorGetDetailController(SapClient sapClient)
DebtorGetDetailControllerのコンストラクタを生成します。
CreditorGetDetailController(String creditorid, String companycode)
CreditorGetDetailController(String creditorid, String companycode, SapClient sapClient)
メソッドの概要
ArrayList | getBankDataList() 銀行データ情報を取得します。
String | getCompanycode() 会社コードを取得します｡
CompanyDataInfo | getCompanyDataInfo() 会社コード依存データ情報を取得します｡
CreditorGetDetail | getCreditorGetDetail() 仕入先マスタ詳細情報を取得します｡
String | getCreditorid() 仕入先コードを取得します｡
GeneralDataInfo | getGeneralDataInfo() 一般データ情報を取得します｡
void | setBankDataInfoList(ArrayList bankDataInfoList) 銀行データ情報を設定します｡
void | setCompanycode(String strCompanycode) 会社コードを設定します｡
void | setCompanyDataInfo(CompanyDataInfo companyDataInfo) 会社依存データ情報を設定します｡
void | setDebtorid(String strCreditorid) 仕入先コードを設定します｡
void | setGeneralDataInfo(GeneralDataInfo generalDataInfo) 一般データ情報を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CreditorGetDetailController

public CreditorGetDetailController(String creditorid,
                                   String companycode)
                            throws SAPAuthAppException,
                                   SAPAuthSystemException,
                                   SAPGeneralAppException,
                                   SAPGeneralSystemException,
                                   SAPFinancialAppException,
                                   SAPFinancialSystemException
パラメータ:
creditorid - 仕入先コード
companycode - 会社コード
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

CreditorGetDetailController

public CreditorGetDetailController(String creditorid,
                                   String companycode,
                                   SapClient sapClient)
                            throws SAPAuthAppException,
                                   SAPAuthSystemException,
                                   SAPGeneralAppException,
                                   SAPGeneralSystemException,
                                   SAPFinancialAppException,
                                   SAPFinancialSystemException
パラメータ:
creditorid - 仕入先コード
companycode - 会社コード
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

CreditorGetDetailController

public CreditorGetDetailController()
DebtorGetDetailControllerのコンストラクタを生成します。

CreditorGetDetailController

public CreditorGetDetailController(SapClient sapClient)
DebtorGetDetailControllerのコンストラクタを生成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

setDebtorid

public void setDebtorid(String strCreditorid)
仕入先コードを設定します｡

パラメータ:
strCreditorid - 仕入先コード

setCompanycode

public void setCompanycode(String strCompanycode)
会社コードを設定します｡

パラメータ:
strCompanycode - 会社コード

setGeneralDataInfo

public void setGeneralDataInfo(GeneralDataInfo generalDataInfo)
一般データ情報を設定します｡

パラメータ:
generalDataInfo - 一般データ情報

setCompanyDataInfo

public void setCompanyDataInfo(CompanyDataInfo companyDataInfo)
会社依存データ情報を設定します｡

パラメータ:
companyDataInfo - 会社依存データ情報

setBankDataInfoList

public void setBankDataInfoList(ArrayList bankDataInfoList)
銀行データ情報を設定します｡

パラメータ:
bankDataInfoList - 銀行データ情報

getCreditorGetDetail

public CreditorGetDetail getCreditorGetDetail()
仕入先マスタ詳細情報を取得します｡

戻り値:
DebtorGetDetail

getCreditorid

public String getCreditorid()
仕入先コードを取得します｡

戻り値:
strCreditorid 仕入先コード

getCompanycode

public String getCompanycode()
会社コードを取得します｡

戻り値:
strCompanycode 会社コード

getGeneralDataInfo

public GeneralDataInfo getGeneralDataInfo()
一般データ情報を取得します｡

戻り値:
GeneralDataInfo

getCompanyDataInfo

public CompanyDataInfo getCompanyDataInfo()
会社コード依存データ情報を取得します｡

戻り値:
CompanyDataInfo

getBankDataList

public ArrayList getBankDataList()
銀行データ情報を取得します。

戻り値:
String 銀行国コード(銀行データ情報)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DebtorGetDetail (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス DebtorGetDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail
すべての実装インタフェース:
Serializable
public class DebtorGetDetail
extends ReferenceController
implements Serializable

得意先詳細情報取得クラス
機能は以下の通り

  • 得意先詳細情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
DebtorGetDetail(SapClient sapClient)
得意先詳細情報を作成
DebtorGetDetail(String Debtorid, String Companycode, SapClient sapClient)
メソッドの概要
void | executeBapi() BapiControllerにより得意先コードを検索します。
ArrayList | getBankDataInfoList() 銀行データ情報一覧を取得します｡
String | getCompanycode() 会社コードを取得します｡
CompanyDataInfo | getCompanyDataInfo() 会社コード依存データ情報を取得します｡
String | getDebtorid() 得意先コードを取得します｡
GeneralDataInfo | getGeneralDataInfo() 一般データ情報を取得します｡
void | setBankDataInfoList(ArrayList bankDataInfoList) 銀行データ情報を設定します｡
void | setCompanycode(String strCompanycode) 会社コードを設定します｡
void | setCompanyDataInfo(CompanyDataInfo companyDataInfo) 会社依存データ情報を設定します｡
void | setDebtorid(String strDebtorid) 得意先コードを設定します｡
void | setExportParam(BapiController bapiController) 得意先コードの詳細情報ををセットします。
void | setGeneralDataInfo(GeneralDataInfo generalDataInfo) 一般データ情報を設定します｡
void | setImportParam(BapiController bapiController) 得意先コードの詳細情報を検索する条件ををセットします。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DebtorGetDetail

public DebtorGetDetail(SapClient sapClient)
得意先詳細情報を作成

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト

DebtorGetDetail

public DebtorGetDetail(String Debtorid,
                       String Companycode,
                       SapClient sapClient)
                throws SAPAuthAppException,
                       SAPAuthSystemException,
                       SAPGeneralAppException,
                       SAPGeneralSystemException,
                       SAPFinancialAppException,
                       SAPFinancialSystemException
パラメータ:
Debtorid - 得意先コード
Companycode - 会社コード
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
BapiControllerにより得意先コードを検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計発注業務システム例外

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPFinancialSystemException
得意先コードの詳細情報を検索する条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPFinancialSystemException - 会計発注業務システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
得意先コードの詳細情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getDebtorid

public String getDebtorid()
得意先コードを取得します｡

戻り値:
strDebtorid 仕入先コード

getCompanycode

public String getCompanycode()
会社コードを取得します｡

戻り値:
strCompanycode 会社コード

getGeneralDataInfo

public GeneralDataInfo getGeneralDataInfo()
一般データ情報を取得します｡

戻り値:
generalDataInfo

getCompanyDataInfo

public CompanyDataInfo getCompanyDataInfo()
会社コード依存データ情報を取得します｡

戻り値:
companyDataInfo

getBankDataInfoList

public ArrayList getBankDataInfoList()
銀行データ情報一覧を取得します｡

戻り値:
bankDataInfoList

setDebtorid

public void setDebtorid(String strDebtorid)
得意先コードを設定します｡

パラメータ:
strDebtorid - 仕入先コード

setCompanycode

public void setCompanycode(String strCompanycode)
会社コードを設定します｡

パラメータ:
strCompanycode - 会社コード

setGeneralDataInfo

public void setGeneralDataInfo(GeneralDataInfo generalDataInfo)
一般データ情報を設定します｡

パラメータ:
generalDataInfo - 一般データ情報

setCompanyDataInfo

public void setCompanyDataInfo(CompanyDataInfo companyDataInfo)
会社依存データ情報を設定します｡

パラメータ:
companyDataInfo - 会社依存データ情報

setBankDataInfoList

public void setBankDataInfoList(ArrayList bankDataInfoList)
銀行データ情報を設定します｡

パラメータ:
bankDataInfoList - 銀行データ情報

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DebtorGetDetailController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス DebtorGetDetailController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController
すべての実装インタフェース:
Serializable
public class DebtorGetDetailController
extends Object
implements Serializable

得意先詳細コントローラクラス
機能は以下の通り

  • 得意先詳細を取得します。

関連項目:
直列化された形式

コンストラクタの概要
DebtorGetDetailController()
DebtorGetDetailControllerのコンストラクタを生成します。
DebtorGetDetailController(SapClient sapClient)
DebtorGetDetailControllerのコンストラクタを生成します。
DebtorGetDetailController(String debtorid, String companycode)
DebtorGetDetailController(String debtorid, String companycode, SapClient sapClient)
メソッドの概要
ArrayList | getBankDataList() 銀行データ情報を取得します。
String | getCompanycode() 会社コードを取得します｡
CompanyDataInfo | getCompanyDataInfo() 会社コード依存データ情報を取得します｡
DebtorGetDetail | getDebtorGetDetail() 得意先マスタ詳細情報を取得します｡
String | getDebtorid() 得意先コードを取得します｡
GeneralDataInfo | getGeneralDataInfo() 一般データ情報を取得します｡
void | setBankDataInfoList(ArrayList bankDataInfoList) 銀行データ情報を設定します｡
void | setCompanycode(String strCompanycode) 会社コードを設定します｡
void | setCompanyDataInfo(CompanyDataInfo companyDataInfo) 会社依存データ情報を設定します｡
void | setDebtorid(String strDebtorid) 得意先コードを設定します｡
void | setGeneralDataInfo(GeneralDataInfo generalDataInfo) 一般データ情報を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DebtorGetDetailController

public DebtorGetDetailController(String debtorid,
                                 String companycode)
                          throws SAPAuthAppException,
                                 SAPAuthSystemException,
                                 SAPGeneralAppException,
                                 SAPGeneralSystemException,
                                 SAPFinancialAppException,
                                 SAPFinancialSystemException
パラメータ:
debtorid - 得意先コード
companycode - 会社コード
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

DebtorGetDetailController

public DebtorGetDetailController(String debtorid,
                                 String companycode,
                                 SapClient sapClient)
                          throws SAPAuthAppException,
                                 SAPAuthSystemException,
                                 SAPGeneralAppException,
                                 SAPGeneralSystemException,
                                 SAPFinancialAppException,
                                 SAPFinancialSystemException
パラメータ:
debtorid - 得意先コード
companycode - 会社コード
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

DebtorGetDetailController

public DebtorGetDetailController()
DebtorGetDetailControllerのコンストラクタを生成します。

DebtorGetDetailController

public DebtorGetDetailController(SapClient sapClient)
DebtorGetDetailControllerのコンストラクタを生成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

setDebtorid

public void setDebtorid(String strDebtorid)
得意先コードを設定します｡

パラメータ:
strDebtorid - 仕入先コード

setCompanycode

public void setCompanycode(String strCompanycode)
会社コードを設定します｡

パラメータ:
strCompanycode - 会社コード

setGeneralDataInfo

public void setGeneralDataInfo(GeneralDataInfo generalDataInfo)
一般データ情報を設定します｡

パラメータ:
generalDataInfo - 一般データ情報

setCompanyDataInfo

public void setCompanyDataInfo(CompanyDataInfo companyDataInfo)
会社依存データ情報を設定します｡

パラメータ:
companyDataInfo - 会社依存データ情報

setBankDataInfoList

public void setBankDataInfoList(ArrayList bankDataInfoList)
銀行データ情報を設定します｡

パラメータ:
bankDataInfoList - 銀行データ情報

getDebtorGetDetail

public DebtorGetDetail getDebtorGetDetail()
得意先マスタ詳細情報を取得します｡

戻り値:
DebtorGetDetail

getDebtorid

public String getDebtorid()
得意先コードを取得します｡

戻り値:
strDebtorid 得意先コード

getCompanycode

public String getCompanycode()
会社コードを取得します｡

戻り値:
strCompanycode 会社コード

getGeneralDataInfo

public GeneralDataInfo getGeneralDataInfo()
一般データ情報を取得します｡

戻り値:
GeneralDataInfo

getCompanyDataInfo

public CompanyDataInfo getCompanyDataInfo()
会社コード依存データ情報を取得します｡

戻り値:
CompanyDataInfo

getBankDataList

public ArrayList getBankDataList()
銀行データ情報を取得します。

戻り値:
String 銀行国コード(銀行データ情報)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExchangeRateGetDetail (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ExchangeRateGetDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail
すべての実装インタフェース:
Serializable
public class ExchangeRateGetDetail
extends ReferenceController
implements Serializable

為替換算レート情報取得クラス
機能は以下の通り

  • 為替換算レート情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
ExchangeRateGetDetail(SapClient sapClient)
為替換算レート情報を作成
ExchangeRateGetDetail(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
メソッドの概要
void | executeBapi() BapiControllerにより為替換算レート情報を検索します。
String | getDate() 起算日を取得します。
ExchRate | getExchRate() 換算レート、係数 (通貨ペア)を取得します。
String | getFromCurr() 換算前通貨を取得します。
String | getRateType() 換算レートタイプを取得します。
String | getToCurrncy() 換算後通貨を取得します。
void | setDate(String strDate) 起算日を設定します。
void | setExchRate(ExchRate exchRate) 換算レート、係数 (通貨ペア)を設定します。
void | setExportParam(BapiController bapiController) 為替換算レート情報ををセットします。
void | setFromCurr(String strFromCurr) 換算前通貨を設定します。
void | setImportParam(BapiController bapiController) 為替換算レート情報を検索する条件ををセットします。
void | setRateType(String strRateType) 換算レートタイプを設定します。
void | setToCurrncy(String strToCurrncy) 換算後通貨を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExchangeRateGetDetail

public ExchangeRateGetDetail(SapClient sapClient)
為替換算レート情報を作成

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト

ExchangeRateGetDetail

public ExchangeRateGetDetail(String rateType,
                             String fromCurr,
                             String toCurrncy,
                             String date,
                             SapClient sapClient)
                      throws SAPAuthAppException,
                             SAPAuthSystemException,
                             SAPGeneralAppException,
                             SAPGeneralSystemException,
                             SAPFinancialAppException,
                             SAPFinancialSystemException
パラメータ:
rateType - 換算レートタイプ
fromCurr - 換算前通貨
toCurrncy - 換算後通貨
date - 起算日
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
BapiControllerにより為替換算レート情報を検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPFinancialSystemException
為替換算レート情報を検索する条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPFinancialSystemException - 会計系APIシステム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
為替換算レート情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setRateType

public void setRateType(String strRateType)
換算レートタイプを設定します。

パラメータ:
strRateType - 換算レートタイプ

setFromCurr

public void setFromCurr(String strFromCurr)
換算前通貨を設定します。

パラメータ:
strFromCurr - 換算前通貨

setToCurrncy

public void setToCurrncy(String strToCurrncy)
換算後通貨を設定します。

パラメータ:
strToCurrncy - 換算後通貨

setDate

public void setDate(String strDate)
起算日を設定します。

パラメータ:
strDate - 起算日

getRateType

public String getRateType()
換算レートタイプを取得します。

戻り値:
srtRateType 換算レートタイプ

getFromCurr

public String getFromCurr()
換算前通貨を取得します。

戻り値:
srtFromCurr 換算前通貨

getToCurrncy

public String getToCurrncy()
換算後通貨を取得します。

戻り値:
srtTo_Currncy 換算後通貨

getDate

public String getDate()
起算日を取得します。

戻り値:
srtDate 起算日

setExchRate

public void setExchRate(ExchRate exchRate)
換算レート、係数 (通貨ペア)を設定します。

パラメータ:
exchRate - 換算レート、係数 (通貨ペア)

getExchRate

public ExchRate getExchRate()
換算レート、係数 (通貨ペア)を取得します。

戻り値:
exchRate 換算レート、係数 (通貨ペア)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExchangeRateGetDetailController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ExchangeRateGetDetailController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController
すべての実装インタフェース:
Serializable
public class ExchangeRateGetDetailController
extends Object
implements Serializable

為替換算レートコントローラクラス
機能は以下の通り

  • 為替換算レートを取得します。

関連項目:
直列化された形式

コンストラクタの概要
ExchangeRateGetDetailController()
ExchangeRateGetDetailControllerのコンストラクタを生成します。
ExchangeRateGetDetailController(SapClient sapClient)
ExchangeRateGetDetailControllerのコンストラクタを生成します。
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date)
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
メソッドの概要
 void executeBapi()
ExchangeRateGetDetailのexecuteBapi()を呼び出し為替換算レートを取得します。
 String getDate()
起算日を取得します。
 ExchRate getExchRate()
換算レート、係数 (通貨ペア)を取得します。
 String getFromCurr()
換算前通貨を取得します。
 String getRateType()
換算レートタイプを取得します。
 String getToCurrncy()
換算後通貨を取得します。
 void setDate(String strDate)
起算日を設定します。
 void setExchRate(ExchRate exchRate)
換算レート、係数 (通貨ペア)を設定します。
 void setFromCurr(String strFromCurr)
換算前通貨を設定します。
 void setRateType(String strRateType)
換算レートタイプを設定します。
 void setToCurrncy(String strToCurrncy)
換算後通貨を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExchangeRateGetDetailController

public ExchangeRateGetDetailController(String rateType,
                                       String fromCurr,
                                       String toCurrncy,
                                       String date)
                                throws SAPAuthAppException,
                                       SAPAuthSystemException,
                                       SAPGeneralAppException,
                                       SAPGeneralSystemException,
                                       SAPFinancialAppException,
                                       SAPFinancialSystemException
パラメータ:
rateType - 換算レートタイプ
fromCurr - 換算前通貨
toCurrncy - 換算後通貨
date - 起算日
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

ExchangeRateGetDetailController

public ExchangeRateGetDetailController(String rateType,
                                       String fromCurr,
                                       String toCurrncy,
                                       String date,
                                       SapClient sapClient)
                                throws SAPAuthAppException,
                                       SAPAuthSystemException,
                                       SAPGeneralAppException,
                                       SAPGeneralSystemException,
                                       SAPFinancialAppException,
                                       SAPFinancialSystemException
パラメータ:
rateType - 換算レートタイプ
fromCurr - 換算前通貨
toCurrncy - 換算後通貨
date - 起算日
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

ExchangeRateGetDetailController

public ExchangeRateGetDetailController()
ExchangeRateGetDetailControllerのコンストラクタを生成します。

ExchangeRateGetDetailController

public ExchangeRateGetDetailController(SapClient sapClient)
ExchangeRateGetDetailControllerのコンストラクタを生成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
ExchangeRateGetDetailのexecuteBapi()を呼び出し為替換算レートを取得します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setRateType

public void setRateType(String strRateType)
換算レートタイプを設定します。

パラメータ:
strRateType - 換算レートタイプ

setFromCurr

public void setFromCurr(String strFromCurr)
換算前通貨を設定します。

パラメータ:
strFromCurr - 換算前通貨

setToCurrncy

public void setToCurrncy(String strToCurrncy)
換算後通貨を設定します。

パラメータ:
strToCurrncy - 換算後通貨

setDate

public void setDate(String strDate)
起算日を設定します。

パラメータ:
strDate - 起算日

getRateType

public String getRateType()
換算レートタイプを取得します。

戻り値:
srtRateType 換算レートタイプ

getFromCurr

public String getFromCurr()
換算前通貨を取得します。

戻り値:
srtFromCurr 換算前通貨

getToCurrncy

public String getToCurrncy()
換算後通貨を取得します。

戻り値:
srtTo_Currncy 換算後通貨

getDate

public String getDate()
起算日を取得します。

戻り値:
srtDate 起算日

setExchRate

public void setExchRate(ExchRate exchRate)
換算レート、係数 (通貨ペア)を設定します。

パラメータ:
exchRate - 換算レート、係数 (通貨ペア)

getExchRate

public ExchRate getExchRate()
換算レート、係数 (通貨ペア)を取得します。

戻り値:
exchRate 換算レート、係数 (通貨ペア)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExchRate (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ExchRate

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ExchRate
すべての実装インタフェース:
Serializable
public class ExchRate
extends Object
implements Serializable

換算レート、係数 (通貨ペア)情報クラス 機能は以下の通り

  • 換算レート、係数 (通貨ペア)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExchRate()
換算レート、係数 (通貨ペア)を作成します。
メソッドの概要
String | getExchRate() 直接呼び値換算レートを取得します。
String | getExchRateV() 間接呼び値換算レートを取得します。
String | getFromCurr() 換算前通貨を取得します。
String | getFromFactor() 換算前 通貨単位の係数を取得します。
String | getFromFactorV() 換算前 通貨単位の係数を取得します。
String | getRateType() 換算レートタイプを取得します。
String | getToCurrncy() 換算後通貨を取得します。
String | getToFactor() 換算後 通貨単位の係数を取得します。
String | getToFactorV() 換算後 通貨単位の係数を取得します。
String | getValidFrom() エントリの有効開始日を取得します。
void | setExchRate(String strExchRate) 直接呼び値換算レートを設定します。
void | setExchRateV(String strExchRateV) 間接呼び値換算レートを設定します。
void | setFromCurr(String strFromCurr) 換算前通貨を設定します。
void | setFromFactor(String strFromFactor) 換算前 通貨単位の係数を設定します。
void | setFromFactorV(String strFromFactorV) 換算前 通貨単位の係数を設定します。
void | setRateType(String strRateType) 換算レートタイプを設定します。
void | setToCurrncy(String strToCurrncy) 換算後通貨を設定します。
void | setToFactor(String strToFactor) 換算後 通貨単位の係数を設定します。
void | setToFactorV(String strToFactorV) 換算後 通貨単位の係数を設定します。
void | setValidFrom(String strValidFrom) エントリの有効開始日を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExchRate

public ExchRate()
換算レート、係数 (通貨ペア)を作成します。

メソッドの詳細

getRateType

public String getRateType()
換算レートタイプを取得します。

戻り値:
srtRateType 換算レートタイプ

getFromCurr

public String getFromCurr()
換算前通貨を取得します。

戻り値:
srtFromCurr 換算前通貨

getToCurrncy

public String getToCurrncy()
換算後通貨を取得します。

戻り値:
srtToCurrncy 換算後通貨

getValidFrom

public String getValidFrom()
エントリの有効開始日を取得します。

戻り値:
srtValidFrom エントリの有効開始日

getExchRate

public String getExchRate()
直接呼び値換算レートを取得します。

戻り値:
srtExchRate 直接呼び値換算レート

getFromFactor

public String getFromFactor()
換算前 通貨単位の係数を取得します。

戻り値:
srtFromFactor 換算前 通貨単位の係数

getToFactor

public String getToFactor()
換算後 通貨単位の係数を取得します。

戻り値:
srtToFactor 換算後 通貨単位の係数

getExchRateV

public String getExchRateV()
間接呼び値換算レートを取得します。

戻り値:
srtExchRateV 間接呼び値換算レート

getFromFactorV

public String getFromFactorV()
換算前 通貨単位の係数を取得します。

戻り値:
srtFromFactorV 換算前 通貨単位の係数

getToFactorV

public String getToFactorV()
換算後 通貨単位の係数を取得します。

戻り値:
srtToFactorV 換算後 通貨単位の係数

setRateType

public void setRateType(String strRateType)
換算レートタイプを設定します。

パラメータ:
strRateType - 換算レートタイプ

setFromCurr

public void setFromCurr(String strFromCurr)
換算前通貨を設定します。

パラメータ:
strFromCurr - 換算前通貨

setToCurrncy

public void setToCurrncy(String strToCurrncy)
換算後通貨を設定します。

パラメータ:
strToCurrncy - 換算後通貨

setValidFrom

public void setValidFrom(String strValidFrom)
エントリの有効開始日を設定します。

パラメータ:
strValidFrom - エントリの有効開始日

setExchRate

public void setExchRate(String strExchRate)
直接呼び値換算レートを設定します。

パラメータ:
strExchRate - 直接呼び値換算レート

setFromFactor

public void setFromFactor(String strFromFactor)
換算前 通貨単位の係数を設定します。

パラメータ:
strFromFactor - 換算前 通貨単位の係数

setToFactor

public void setToFactor(String strToFactor)
換算後 通貨単位の係数を設定します。

パラメータ:
strToFactor - 換算後 通貨単位の係数

setExchRateV

public void setExchRateV(String strExchRateV)
間接呼び値換算レートを設定します。

パラメータ:
strExchRateV - 間接呼び値換算レート

setFromFactorV

public void setFromFactorV(String strFromFactorV)
換算前 通貨単位の係数を設定します。

パラメータ:
strFromFactorV - 換算前 通貨単位の係数

setToFactorV

public void setToFactorV(String strToFactorV)
換算後 通貨単位の係数を設定します。

パラメータ:
strToFactorV - 換算後 通貨単位の係数

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExpActivity (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ExpActivity

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ExpActivity
すべての実装インタフェース:
Serializable
public class ExpActivity
extends Object
implements Serializable

活動に関する詳細情報クラス 機能は以下の通り

  • 活動に関する詳細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExpActivity()
活動に関する詳細情報を作成します。
メソッドの概要
String | getActivity() ネットワーク/標準ネットワークの活動番号を取得します。
String | getActivityCosts() 活動の原価を取得します。
String | getActtype() 活動タイプを取得します。
String | getActualCost() 実際原価を取得します。
String | getActualFinishDate() 実績終了日: 実行 (日付)を取得します。
String | getActualStartDate() 実績開始日: 実行 (日付)を取得します。
String | getComplete() 最終確認の有効化を取得します。
String | getConstraintFinishDate() 活動の基準終了日に対する制約を取得します。
String | getConstraintFinishDateFc() 予測終了日付を取得します。
String | getConstraintFinishTime() 活動の基準終了時間を取得します。
String | getConstraintFinishTimeFc() 活動の予測終了時間を取得します。
String | getConstraintStartDate() 活動の基準開始日に対する制約を取得します。
String | getConstraintStartDateFc() 活動の予測開始日を取得します。
String | getConstraintStartTime() 活動の基準開始時間の制約を取得します。
String | getConstraintStartTimeFc() 活動の需要予測開始時間を取得します。
String | getConstraintTypeFinish() 活動の終了日に対する制約を取得します。
String | getConstraintTypeFinishFc() 活動終了の制約条件付き需要予測日付を取得します。
String | getConstraintTypeStart() 活動の基準開始日に対する制約を取得します。
String | getConstraintTypeStartFc() 活動開始の制約条件付き需要予測日付を取得します。
String | getControlKey() 管理キーを取得します。
String | getControllingAreaCurrency() 通貨コードを取得します。
String | getCostElem() 原価要素を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO 通貨コードを取得します。
String | getDeletionFlag() 削除フラグを取得します。
String | getDescription() 作業テキスト (短)を取得します。
String | getDistributingKey() 能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)を取得します。
String | getDurationConfirmFc() 確認の予測活動期間を取得します。
String | getDurationConfirmFcUnit() 確認の予測期間単位を取得します。
String | getDurationConfirmFcUnitIso() 単位の ISO コードを取得します。
String | getDurationMinimum() 最短活動期間を取得します。
String | getDurationMinimumFc() 活動の最小期間(需要予測より)を取得します。
String | getDurationMinimumFcUnit() 予測最短期間の単位を取得します。
String | getDurationMinimumFcUnitIso() 単位の ISO コードを取得します。
String | getDurationMinimumUnit() 最短期間の単位を取得します。
String | getDurationMinimumUnitIso() 単位の ISO コードを取得します。
String | getDurationNormal() 標準活動期間を取得します。
String | getDurationNormalFc() 標準活動期間 (予測)を取得します。
String | getDurationNormalFcUnit() 標準予測期間の単位を取得します。
String | getDurationNormalFcUnitIso() 単位の ISO コードを取得します。
String | getDurationNormalUnit() 標準期間/単位を取得します。
String | getDurationNormalUnitIso() 単位の ISO コードを取得します。
String | getDurationScheduled() 処理時間を取得します。
String | getDurationScheduledFc() 処理時間の長さ (予測値)を取得します。
String | getDurationScheduledUnit() 処理時間単位を取得します。
String | getDurationScheduledUnitIso() 単位の ISO コードを取得します。
String | getEarlyFinishDate() 最早計画終了: 実行 (日)を取得します。
String | getEarlyFinishDateFc() 最早計画終了日 (予測)を取得します。
String | getEarlyFinishTime() 最早計画終了: 実行 (時刻)を取得します。
String | getEarlyFinishTimeFc() 最早計画終了時間(需要予測)を取得します。
String | getEarlyStartDate() 最早計画開始: 実行 (日)を取得します。
String | getEarlyStartDateFc() 最早計画開始日付(需要予測)を取得します。
String | getEarlyStartTime() 最早計画開始: 作業実施(時間)を取得します。
String | getEarlyStartTimeFc() 最早計画開始時間(需要予測)を取得します。
String | getFactoryCalendar() 稼働日カレンダを取得します。
String | getFlexibleDuration() 区分: 可変期間を取得します。
String | getFloatFree() 自由余裕を取得します。
String | getFloatFreeFc() 自由余裕 (予測)を取得します。
String | getFloatTotal() 余裕合計を取得します。
String | getFloatTotalFc() 余裕合計 (予測)を取得します。
String | getForecastFinishDate() 予測終了日を取得します。
String | getFuncArea() 機能領域を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getInfoRec() 購買情報番号を取得します。
String | getLatestFinishDate() 計画最遅終了: 作業(日付)を取得します。
String | getLatestFinishDateFc() 最遅計画済終了日付(需要予測)を取得します。
String | getLatestFinishTime() 計画最遅終了: 作業(時間)を取得します。
String | getLatestFinishTimeFc() 最遅計画終了時間 (予測)を取得します。
String | getLatestStartDate() 計画最遅開始: 作業(日付)を取得します。
String | getLatestStartDateFc() 最遅計画済開始日付(需要予測)を取得します。
String | getLatestStartTime() 計画最遅開始: 作業(時間)を取得します。
String | getLatestStartTimeFc() 最遅計画済開始時間(需要予測)を取得します。
String | getMatlGroup() 品目グループを取得します。
String | getMilestone() 用途を取得します。
String | getNetwork() ネットワーク番号を取得します。
String | getNotMrpApplicable() 区分: MRP への入出庫予定の適用不可と購買依頼未登録を取得します。
String | getNumberOfCapacities() 所要能力数を取得します。
String | getObjectclass() オブジェクトクラス (言語非依存)を取得します。
String | getObjectclassExt() オブジェクトクラス、言語依存を取得します。
String | getOperationMeasureUnit() 活動単位を取得します。
String | getOperationMeasureUnitIso() 単位の ISO コードを取得します。
String | getPercentOfWork() 作業の比率 (%)を取得します。
String | getPlannedCost() 計画原価を取得します。
String | getPlant() プラントを取得します。
String | getPlndDelry() 予定納入時間 (単位: 日)を取得します。
String | getPrice() 価格を取得します。
String | getPriceUnit() 価格単位を取得します。
String | getPriority() 優先度を取得します。
String | getProfitCtr() 利益センタを取得します。
String | getProjectDefinition() プロジェクト定義を取得します。
String | getProjectSummarization() 区分: プロジェクト集計用に活動を考慮を取得します。
String | getPurchOrg() 購買組織を取得します。
String | getPurGroup() 購買グループを取得します。
String | getReferencePoint() BOM 転送の参照ポイントを取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getUnWork() 作業単位を取得します。
String | getUnWorkIso() 単位の ISO コードを取得します。
String | getUserFieldChar10_1() ユーザ定義項目 (10 文字)を取得します。
String | getUserFieldChar10_2() ユーザ定義項目 (10 文字)を取得します。
String | getUserFieldChar20_1() 20 文字のユーザ項目を取得します。
String | getUserFieldChar20_2() 20 文字のユーザ項目を取得します。
String | getUserFieldCuky1() ユーザ項目: 値項目の単位を取得します。
String | getUserFieldCuky1Iso() ISO 通貨コードを取得します。
String | getUserFieldCuky2() ユーザ項目: 値項目の単位を取得します。
String | getUserFieldCuky2Iso() ISO 通貨コードを取得します。
String | getUserFieldCurr1() 値のユーザ定義項目 (長さ 10,3)を取得します。
String | getUserFieldCurr2() 値のユーザ定義項目 (長さ 10,3)を取得します。
String | getUserFieldDate1() 日付のユーザ項目を取得します。
String | getUserFieldDate2() 日付のユーザ項目を取得します。
String | getUserFieldFlag1() ユーザ定義項目: レポート区分を取得します。
String | getUserFieldFlag2() ユーザ定義項目: レポート区分を取得します。
String | getUserFieldKey() ユーザ定義項目のキーワード IDを取得します。
String | getUserFieldQuan1() 数量のユーザ項目 (長さ 10,3)を取得します。
String | getUserFieldQuan2() 数量のユーザ項目 (長さ 10,3)を取得します。
String | getUserFieldUnit1() ユーザ項目: 数量項目の単位を取得します。
String | getUserFieldUnit1Iso() 単位の ISO コードを取得します。
String | getUserFieldUnit2() ユーザ項目: 数量項目の単位を取得します。
String | getUserFieldUnit2Iso() 単位の ISO コードを取得します。
String | getVendorNo() 仕入先または債権者の勘定コードを取得します。
String | getWbsElement() WBS 要素を取得します。
String | getWorkActivity() 活動に含まれる作業を取得します。
String | getWorkActual() 実績作業を取得します。
String | getWorkCntr() 作業区を取得します。
String | getWorkForecast() 予測作業 (実績 + 残存)を取得します。
void | setActivity(String strActivity) ネットワーク/標準ネットワークの活動番号を設定します。
void | setActivityCosts(String strActivityCosts) 活動の原価を設定します。
void | setActtype(String strActtype) 活動タイプを設定します。
void | setActualCost(String strActualCost) 実際原価を設定します。
void | setActualFinishDate(String strActualFinishDate) 実績終了日: 実行 (日付)を設定します。
void | setActualStartDate(String strActualStartDate) 実績開始日: 実行 (日付)を設定します。
void | setComplete(String strComplete) 最終確認の有効化を設定します。
void | setConstraintFinishDate(String strConstraintFinishDate) 活動の基準終了日に対する制約を設定します。
void | setConstraintFinishDateFc(String strConstraintFinishDateFc) 予測終了日付を設定します。
void | setConstraintFinishTime(String strConstraintFinishTime) 活動の基準終了時間を設定します。
void | setConstraintFinishTimeFc(String strConstraintFinishTimeFc) 活動の予測終了時間を設定します。
void | setConstraintStartDate(String strConstraintStartDate) 活動の基準開始日に対する制約を設定します。
void | setConstraintStartDateFc(String strConstraintStartDateFc) 活動の予測開始日を設定します。
void | setConstraintStartTime(String strConstraintStartTime) 活動の基準開始時間の制約を設定します。
void | setConstraintStartTimeFc(String strConstraintStartTimeFc) 活動の需要予測開始時間を設定します。
void | setConstraintTypeFinish(String strConstraintTypeFinish) 活動の終了日に対する制約を設定します。
void | setConstraintTypeFinishFc(String strConstraintTypeFinishFc) 活動終了の制約条件付き需要予測日付を設定します。
void | setConstraintTypeStart(String strConstraintTypeStart) 活動の基準開始日に対する制約を設定します。
void | setConstraintTypeStartFc(String strConstraintTypeStartFc) 活動開始の制約条件付き需要予測日付を設定します。
void | setControlKey(String strControlKey) 管理キーを設定します。
void | setControllingAreaCurrency(String strControllingAreaCurrency) 通貨コードを設定します。
void | setCostElem(String strCostElem) 原価要素を設定します。
void | setCurrency(String strCurrency) 通貨コードを設定します。
void | setCurrencyIso(String strCurrencyIso) ISO 通貨コードを設定します。
void | setDeletionFlag(String strDeletionFlag) 削除フラグを設定します。
void | setDescription(String strDescription) 作業テキスト (短)を設定します。
void | setDistributingKey(String strDistributingKey) 能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)を設定します。
void | setDurationConfirmFc(String strDurationConfirmFc) 確認の予測活動期間を設定します。
void | setDurationConfirmFcUnit(String strDurationConfirmFcUnit) 確認の予測期間単位を設定します。
void | setDurationConfirmFcUnitIso(String strDurationConfirmFcUnitIso) 単位の ISO コードを設定します。
void | setDurationMinimum(String strDurationMinimum) 最短活動期間を設定します。
void | setDurationMinimumFc(String strDurationMinimumFc) 活動の最小期間(需要予測より)を設定します。
void | setDurationMinimumFcUnit(String strDurationMinimumFcUnit) 予測最短期間の単位を設定します。
void | setDurationMinimumFcUnitIso(String strDurationMinimumFcUnitIso) 単位の ISO コードを設定します。
void | setDurationMinimumUnit(String strDurationMinimumUnit) 最短期間の単位を設定します。
void | setDurationMinimumUnitIso(String strDurationMinimumUnitIso) 単位の ISO コードを設定します。
void | setDurationNormal(String strDurationNormal) 標準活動期間を設定します。
void | setDurationNormalFc(String strDurationNormalFc) 標準活動期間 (予測)を設定します。
void | setDurationNormalFcUnit(String strDurationNormalFcUnit) 標準予測期間の単位を設定します。
void | setDurationNormalFcUnitIso(String strDurationNormalFcUnitIso) 単位の ISO コードを設定します。
void | setDurationNormalUnit(String strDurationNormalUnit) 標準期間/単位を設定します。
void | setDurationNormalUnitIso(String strDurationNormalUnitIso) 単位の ISO コードを設定します。
void | setDurationScheduled(String strDurationScheduled) 処理時間を設定します。
void | setDurationScheduledFc(String strDurationScheduledFc) 処理時間の長さ (予測値)を設定します。
void | setDurationScheduledUnit(String strDurationScheduledUnit) 処理時間単位を設定します。
void | setDurationScheduledUnitIso(String strDurationScheduledUnitIso) 単位の ISO コードを設定します。
void | setEarlyFinishDate(String strEarlyFinishDate) 最早計画終了: 実行 (日)を設定します。
void | setEarlyFinishDateFc(String strEarlyFinishDateFc) 最早計画終了日 (予測)を設定します。
void | setEarlyFinishTime(String strEarlyFinishTime) 最早計画終了: 実行 (時刻)を設定します。
void | setEarlyFinishTimeFc(String strEarlyFinishTimeFc) 最早計画終了時間(需要予測)を設定します。
void | setEarlyStartDate(String strEarlyStartDate) 最早計画開始: 実行 (日)を設定します。
void | setEarlyStartDateFc(String strEarlyStartDateFc) 最早計画開始日付(需要予測)を設定します。
void | setEarlyStartTime(String strEarlyStartTime) 最早計画開始: 作業実施(時間)を設定します。
void | setEarlyStartTimeFc(String strEarlyStartTimeFc) 最早計画開始時間(需要予測)を設定します。
void | setFactoryCalendar(String strFactoryCalendar) 稼働日カレンダを設定します。
void | setFlexibleDuration(String strFlexibleDuration) 区分: 可変期間を設定します。
void | setFloatFree(String strFloatFree) 自由余裕を設定します。
void | setFloatFreeFc(String strFloatFreeFc) 自由余裕 (予測)を設定します。
void | setFloatTotal(String strFloatTotal) 余裕合計を設定します。
void | setFloatTotalFc(String strFloatTotalFc) 余裕合計 (予測)を設定します。
void | setForecastFinishDate(String strForecastFinishDate) 予測終了日を設定します。
void | setFuncArea(String strFuncArea) 機能領域を設定します。
void | setFuncAreaLong(String strFuncAreaLong) 機能領域を設定します。
void | setInfoRec(String strInfoRec) 購買情報番号を設定します。
void | setLatestFinishDate(String strLatestFinishDate) 計画最遅終了: 作業(日付)を設定します。
void | setLatestFinishDateFc(String strLatestFinishDateFc) 最遅計画済終了日付(需要予測)を設定します。
void | setLatestFinishTime(String strLatestFinishTime) 計画最遅終了: 作業(時間)を設定します。
void | setLatestFinishTimeFc(String strLatestFinishTimeFc) 最遅計画終了時間 (予測)を設定します。
void | setLatestStartDate(String strLatestStartDate) 計画最遅開始: 作業(日付)を設定します。
void | setLatestStartDateFc(String strLatestStartDateFc) 最遅計画済開始日付(需要予測)を設定します。
void | setLatestStartTime(String strLatestStartTime) 計画最遅開始: 作業(時間)を設定します。
void | setLatestStartTimeFc(String strLatestStartTimeFc) 最遅計画済開始時間(需要予測)を設定します。
void | setMatlGroup(String strMatlGroup) 品目グループを設定します。
void | setMilestone(String strMilestone) 用途を設定します。
void | setNetwork(String strNetwork) ネットワーク番号を設定します。
void | setNotMrpApplicable(String strNotMrpApplicable) 区分: MRP への入出庫予定の適用不可と購買依頼未登録を設定します。
void | setNumberOfCapacities(String strNumberOfCapacities) 所要能力数を設定します。
void | setObjectclass(String strObjectclass) オブジェクトクラス (言語非依存)を設定します。
void | setObjectclassExt(String strObjectclassExt) オブジェクトクラス、言語依存を設定します。
void | setOperationMeasureUnit(String strOperationMeasureUnit) 活動単位を設定します。
void | setOperationMeasureUnitIso(String strOperationMeasureUnitIso) 単位の ISO コードを設定します。
void | setPercentOfWork(String strPercentOfWork) 作業の比率 (%)を設定します。
void | setPlannedCost(String strPlannedCost) 計画原価を設定します。
void | setPlant(String strPlant) プラントを設定します。
void | setPlndDelry(String strPlndDelry) 予定納入時間 (単位: 日)を設定します。
void | setPrice(String strPrice) 価格を設定します。
void | setPriceUnit(String strPriceUnit) 価格単位を設定します。
void | setPriority(String strPriority) 優先度を設定します。
void | setProfitCtr(String strProfitCtr) 利益センタを設定します。
void | setProjectDefinition(String strProjectDefinition) プロジェクト定義を設定します。
void | setProjectSummarization(String strProjectSummarization) 区分: プロジェクト集計用に活動を考慮を設定します。
void | setPurchOrg(String strPurchOrg) 購買組織を設定します。
void | setPurGroup(String strPurGroup) 購買グループを設定します。
void | setReferencePoint(String strReferencePoint) BOM 転送の参照ポイントを設定します。
void | setTaxjurcode(String strTaxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setUnWork(String strUnWork) 作業単位を設定します。
void | setUnWorkIso(String strUnWorkIso) 単位の ISO コードを設定します。
void | setUserFieldChar10_1(String strUserFieldChar101) ユーザ定義項目 (10 文字)を設定します。
void | setUserFieldChar10_2(String strUserFieldChar102) ユーザ定義項目 (10 文字)を設定します。
void | setUserFieldChar20_1(String strUserFieldChar201) 20 文字のユーザ項目を設定します。
void | setUserFieldChar20_2(String strUserFieldChar202) 20 文字のユーザ項目を設定します。
void | setUserFieldCuky1(String strUserFieldCuky1) ユーザ項目: 値項目の単位を設定します。
void | setUserFieldCuky1Iso(String strUserFieldCuky1Iso) ISO 通貨コードを設定します。
void | setUserFieldCuky2(String strUserFieldCuky2) ユーザ項目: 値項目の単位を設定します。
void | setUserFieldCuky2Iso(String strUserFieldCuky2Iso) ISO 通貨コードを設定します。
void | setUserFieldCurr1(String strUserFieldCurr1) 値のユーザ定義項目 (長さ 10,3)を設定します。
void | setUserFieldCurr2(String strUserFieldCurr2) 値のユーザ定義項目 (長さ 10,3)を設定します。
void | setUserFieldDate1(String strUserFieldDate1) 日付のユーザ項目を設定します。
void | setUserFieldDate2(String strUserFieldDate2) 日付のユーザ項目を設定します。
void | setUserFieldFlag1(String strUserFieldFlag1) ユーザ定義項目: レポート区分を設定します。
void | setUserFieldFlag2(String strUserFieldFlag2) ユーザ定義項目: レポート区分を設定します。
void | setUserFieldKey(String strUserFieldKey) ユーザ定義項目のキーワード IDを設定します。
void | setUserFieldQuan1(String strUserFieldQuan1) 数量のユーザ項目 (長さ 10,3)を設定します。
void | setUserFieldQuan2(String strUserFieldQuan2) 数量のユーザ項目 (長さ 10,3)を設定します。
void | setUserFieldUnit1(String strUserFieldUnit1) ユーザ項目: 数量項目の単位を設定します。
void | setUserFieldUnit1Iso(String strUserFieldUnit1Iso) 単位の ISO コードを設定します。
void | setUserFieldUnit2(String strUserFieldUnit2) ユーザ項目: 数量項目の単位を設定します。
void | setUserFieldUnit2Iso(String strUserFieldUnit2Iso) 単位の ISO コードを設定します。
void | setVendorNo(String strVendorNo) 仕入先または債権者の勘定コードを設定します。
void | setWbsElement(String strWbsElement) WBS 要素を設定します。
void | setWorkActivity(String strWorkActivity) 活動に含まれる作業を設定します。
void | setWorkActual(String strWorkActual) 実績作業を設定します。
void | setWorkCntr(String strWorkCntr) 作業区を設定します。
void | setWorkForecast(String strWorkForecast) 予測作業 (実績 + 残存)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExpActivity

public ExpActivity()
活動に関する詳細情報を作成します。

メソッドの詳細

getNetwork

public String getNetwork()
ネットワーク番号を取得します。

戻り値:
srtNetwork ネットワーク番号

getActivity

public String getActivity()
ネットワーク/標準ネットワークの活動番号を取得します。

戻り値:
srtActivity ネットワーク/標準ネットワークの活動番号

getControlKey

public String getControlKey()
管理キーを取得します。

戻り値:
srtControlKey 管理キー

getWorkCntr

public String getWorkCntr()
作業区を取得します。

戻り値:
srtWorkCntr 作業区

getPlant

public String getPlant()
プラントを取得します。

戻り値:
srtPlant プラント

getDescription

public String getDescription()
作業テキスト (短)を取得します。

戻り値:
srtDescription 作業テキスト (短)

getVendorNo

public String getVendorNo()
仕入先または債権者の勘定コードを取得します。

戻り値:
srtVendorNo 仕入先または債権者の勘定コード

getPrice

public String getPrice()
価格を取得します。

戻り値:
srtPrice 価格

getPriceUnit

public String getPriceUnit()
価格単位を取得します。

戻り値:
srtPriceUnit 価格単位

getCostElem

public String getCostElem()
原価要素を取得します。

戻り値:
srtCostElem 原価要素

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
srtCurrency 通貨コード

getCurrencyIso

public String getCurrencyIso()
ISO 通貨コードを取得します。

戻り値:
srtCurrencyIso ISO 通貨コード

getInfoRec

public String getInfoRec()
購買情報番号を取得します。

戻り値:
srtInfoRec 購買情報番号

getPurchOrg

public String getPurchOrg()
購買組織を取得します。

戻り値:
srtPurchOrg 購買組織

getPurGroup

public String getPurGroup()
購買グループを取得します。

戻り値:
srtPurGroup 購買グループ

getMatlGroup

public String getMatlGroup()
品目グループを取得します。

戻り値:
srtMatlGroup 品目グループ

getFlexibleDuration

public String getFlexibleDuration()
区分: 可変期間を取得します。

戻り値:
srtFlexibleDuration 区分: 可変期間

getNumberOfCapacities

public String getNumberOfCapacities()
所要能力数を取得します。

戻り値:
srtNumberOfCapacities 所要能力数

getPercentOfWork

public String getPercentOfWork()
作業の比率 (%)を取得します。

戻り値:
srtPercentOfWork 作業の比率 (%)

getMilestone

public String getMilestone()
用途を取得します。

戻り値:
srtMilestone 用途

getActtype

public String getActtype()
活動タイプを取得します。

戻り値:
srtActtype 活動タイプ

getActivityCosts

public String getActivityCosts()
活動の原価を取得します。

戻り値:
srtActivityCosts 活動の原価

getProjectDefinition

public String getProjectDefinition()
プロジェクト定義を取得します。

戻り値:
srtProjectDefinition プロジェクト定義

getWbsElement

public String getWbsElement()
WBS 要素を取得します。

戻り値:
srtWbsElement WBS 要素

getFactoryCalendar

public String getFactoryCalendar()
稼働日カレンダを取得します。

戻り値:
srtFactoryCalendar 稼働日カレンダ

getDistributingKey

public String getDistributingKey()
能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)を取得します。

戻り値:
srtDistributingKey 能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)

getPriority

public String getPriority()
優先度を取得します。

戻り値:
srtPriority 優先度

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
srtTaxjurcode 税計算管轄コード - 税管轄コード

getObjectclass

public String getObjectclass()
オブジェクトクラス (言語非依存)を取得します。

戻り値:
srtObjectclass オブジェクトクラス (言語非依存)

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
srtProfitCtr 利益センタ

getNotMrpApplicable

public String getNotMrpApplicable()
区分: MRP への入出庫予定の適用不可と購買依頼未登録を取得します。

戻り値:
srtNotMrpApplicable 区分: MRP への入出庫予定の適用不可と購買依頼未登録

getProjectSummarization

public String getProjectSummarization()
区分: プロジェクト集計用に活動を考慮を取得します。

戻り値:
srtProjectSummarization 区分: プロジェクト集計用に活動を考慮

getOperationMeasureUnit

public String getOperationMeasureUnit()
活動単位を取得します。

戻り値:
srtOperationMeasureUnit 活動単位

getOperationMeasureUnitIso

public String getOperationMeasureUnitIso()
単位の ISO コードを取得します。

戻り値:
srtOperationMeasureUnitIso 単位の ISO コード

getPlndDelry

public String getPlndDelry()
予定納入時間 (単位: 日)を取得します。

戻り値:
srtPlndDelry 予定納入時間 (単位: 日)

getDurationNormal

public String getDurationNormal()
標準活動期間を取得します。

戻り値:
srtDurationNormal 標準活動期間

getDurationNormalUnit

public String getDurationNormalUnit()
標準期間/単位を取得します。

戻り値:
srtDurationNormalUnit 標準期間/単位

getDurationNormalUnitIso

public String getDurationNormalUnitIso()
単位の ISO コードを取得します。

戻り値:
srtDurationNormalUnitIso 単位の ISO コード

getDurationMinimum

public String getDurationMinimum()
最短活動期間を取得します。

戻り値:
srtDurationMinimum 最短活動期間

getDurationMinimumUnit

public String getDurationMinimumUnit()
最短期間の単位を取得します。

戻り値:
srtDurationMinimumUnit 最短期間の単位

getDurationMinimumUnitIso

public String getDurationMinimumUnitIso()
単位の ISO コードを取得します。

戻り値:
srtDurationMinimumUnitIso 単位の ISO コード

getConstraintTypeStart

public String getConstraintTypeStart()
活動の基準開始日に対する制約を取得します。

戻り値:
srtConstraintTypeStart 活動の基準開始日に対する制約

getConstraintTypeFinish

public String getConstraintTypeFinish()
活動の終了日に対する制約を取得します。

戻り値:
srtConstraintTypeFinish 活動の終了日に対する制約

getWorkActivity

public String getWorkActivity()
活動に含まれる作業を取得します。

戻り値:
srtWorkActivity 活動に含まれる作業

getUnWork

public String getUnWork()
作業単位を取得します。

戻り値:
srtUnWork 作業単位

getUnWorkIso

public String getUnWorkIso()
単位の ISO コードを取得します。

戻り値:
srtUnWorkIso 単位の ISO コード

getEarlyStartDate

public String getEarlyStartDate()
最早計画開始: 実行 (日)を取得します。

戻り値:
srtEarlyStartDate 最早計画開始: 実行 (日)

getEarlyStartTime

public String getEarlyStartTime()
最早計画開始: 作業実施(時間)を取得します。

戻り値:
srtEarlyStartTime 最早計画開始: 作業実施(時間)

getEarlyFinishDate

public String getEarlyFinishDate()
最早計画終了: 実行 (日)を取得します。

戻り値:
srtEarlyFinishDate 最早計画終了: 実行 (日)

getEarlyFinishTime

public String getEarlyFinishTime()
最早計画終了: 実行 (時刻)を取得します。

戻り値:
srtEarlyFinishTime 最早計画終了: 実行 (時刻)

getLatestStartDate

public String getLatestStartDate()
計画最遅開始: 作業(日付)を取得します。

戻り値:
srtLatestStartDate 計画最遅開始: 作業(日付)

getLatestStartTime

public String getLatestStartTime()
計画最遅開始: 作業(時間)を取得します。

戻り値:
srtLatestStartTime 計画最遅開始: 作業(時間)

getLatestFinishDate

public String getLatestFinishDate()
計画最遅終了: 作業(日付)を取得します。

戻り値:
srtLatestFinishDate 計画最遅終了: 作業(日付)

getLatestFinishTime

public String getLatestFinishTime()
計画最遅終了: 作業(時間)を取得します。

戻り値:
srtLatestFinishTime 計画最遅終了: 作業(時間)

getFloatFree

public String getFloatFree()
自由余裕を取得します。

戻り値:
srtFloatFree 自由余裕

getFloatTotal

public String getFloatTotal()
余裕合計を取得します。

戻り値:
srtFloatTotal 余裕合計

getConstraintStartDate

public String getConstraintStartDate()
活動の基準開始日に対する制約を取得します。

戻り値:
srtConstraintStartDate 活動の基準開始日に対する制約

getConstraintStartTime

public String getConstraintStartTime()
活動の基準開始時間の制約を取得します。

戻り値:
srtConstraintStartTime 活動の基準開始時間の制約

getConstraintFinishDate

public String getConstraintFinishDate()
活動の基準終了日に対する制約を取得します。

戻り値:
srtConstraintFinishDate 活動の基準終了日に対する制約

getConstraintFinishTime

public String getConstraintFinishTime()
活動の基準終了時間を取得します。

戻り値:
srtConstraintFinishTime 活動の基準終了時間

getUserFieldKey

public String getUserFieldKey()
ユーザ定義項目のキーワード IDを取得します。

戻り値:
srtUserFieldKey ユーザ定義項目のキーワード ID

getUserFieldChar20_1

public String getUserFieldChar20_1()
20 文字のユーザ項目を取得します。

戻り値:
srtUserFieldChar201 20 文字のユーザ項目

getUserFieldChar20_2

public String getUserFieldChar20_2()
20 文字のユーザ項目を取得します。

戻り値:
srtUserFieldChar202 20 文字のユーザ項目

getUserFieldChar10_1

public String getUserFieldChar10_1()
ユーザ定義項目 (10 文字)を取得します。

戻り値:
srtUserFieldChar101 ユーザ定義項目 (10 文字)

getUserFieldChar10_2

public String getUserFieldChar10_2()
ユーザ定義項目 (10 文字)を取得します。

戻り値:
srtUserFieldChar102 ユーザ定義項目 (10 文字)

getUserFieldQuan1

public String getUserFieldQuan1()
数量のユーザ項目 (長さ 10,3)を取得します。

戻り値:
srtUserFieldQuan1 数量のユーザ項目 (長さ 10,3)

getUserFieldUnit1

public String getUserFieldUnit1()
ユーザ項目: 数量項目の単位を取得します。

戻り値:
srtUserFieldUnit1 ユーザ項目: 数量項目の単位

getUserFieldUnit1Iso

public String getUserFieldUnit1Iso()
単位の ISO コードを取得します。

戻り値:
srtUserFieldUnit1Iso 単位の ISO コード

getUserFieldQuan2

public String getUserFieldQuan2()
数量のユーザ項目 (長さ 10,3)を取得します。

戻り値:
srtUserFieldQuan2 数量のユーザ項目 (長さ 10,3)

getUserFieldUnit2

public String getUserFieldUnit2()
ユーザ項目: 数量項目の単位を取得します。

戻り値:
srtUserFieldUnit2 ユーザ項目: 数量項目の単位

getUserFieldUnit2Iso

public String getUserFieldUnit2Iso()
単位の ISO コードを取得します。

戻り値:
srtUserFieldUnit2Iso 単位の ISO コード

getUserFieldCurr1

public String getUserFieldCurr1()
値のユーザ定義項目 (長さ 10,3)を取得します。

戻り値:
srtUserFieldCurr1 値のユーザ定義項目 (長さ 10,3)

getUserFieldCuky1

public String getUserFieldCuky1()
ユーザ項目: 値項目の単位を取得します。

戻り値:
srtUserFieldCuky1 ユーザ項目: 値項目の単位

getUserFieldCuky1Iso

public String getUserFieldCuky1Iso()
ISO 通貨コードを取得します。

戻り値:
srtUserFieldCuky1Iso ISO 通貨コード

getUserFieldCurr2

public String getUserFieldCurr2()
値のユーザ定義項目 (長さ 10,3)を取得します。

戻り値:
srtUserFieldCurr2 値のユーザ定義項目 (長さ 10,3)

getUserFieldCuky2

public String getUserFieldCuky2()
ユーザ項目: 値項目の単位を取得します。

戻り値:
srtUserFieldCuky2 ユーザ項目: 値項目の単位

getUserFieldCuky2Iso

public String getUserFieldCuky2Iso()
ISO 通貨コードを取得します。

戻り値:
srtUserFieldCuky2Iso ISO 通貨コード

getUserFieldDate1

public String getUserFieldDate1()
日付のユーザ項目を取得します。

戻り値:
srtUserFieldDate1 日付のユーザ項目

getUserFieldDate2

public String getUserFieldDate2()
日付のユーザ項目を取得します。

戻り値:
srtUserFieldDate2 日付のユーザ項目

getUserFieldFlag1

public String getUserFieldFlag1()
ユーザ定義項目: レポート区分を取得します。

戻り値:
srtUserFieldFlag1 ユーザ定義項目: レポート区分

getUserFieldFlag2

public String getUserFieldFlag2()
ユーザ定義項目: レポート区分を取得します。

戻り値:
srtUserFieldFlag2 ユーザ定義項目: レポート区分

getDeletionFlag

public String getDeletionFlag()
削除フラグを取得します。

戻り値:
srtDeletionFlag 削除フラグ

getDurationNormalFc

public String getDurationNormalFc()
標準活動期間 (予測)を取得します。

戻り値:
srtDurationNormalFc 標準活動期間 (予測)

getDurationNormalFcUnit

public String getDurationNormalFcUnit()
標準予測期間の単位を取得します。

戻り値:
srtDurationNormalFcUnit 標準予測期間の単位

getDurationNormalFcUnitIso

public String getDurationNormalFcUnitIso()
単位の ISO コードを取得します。

戻り値:
srtDurationNormalFcUnitIso 単位の ISO コード

getDurationMinimumFc

public String getDurationMinimumFc()
活動の最小期間(需要予測より)を取得します。

戻り値:
srtDurationMinimumFc 活動の最小期間(需要予測より)

getDurationMinimumFcUnit

public String getDurationMinimumFcUnit()
予測最短期間の単位を取得します。

戻り値:
srtDurationMinimumFcUnit 予測最短期間の単位

getDurationMinimumFcUnitIso

public String getDurationMinimumFcUnitIso()
単位の ISO コードを取得します。

戻り値:
srtDurationMinimumFcUnitIso 単位の ISO コード

getConstraintTypeFinishFc

public String getConstraintTypeFinishFc()
活動終了の制約条件付き需要予測日付を取得します。

戻り値:
srtConstraintTypeFinishFc 活動終了の制約条件付き需要予測日付

getConstraintTypeStartFc

public String getConstraintTypeStartFc()
活動開始の制約条件付き需要予測日付を取得します。

戻り値:
srtConstraintTypeStartFc 活動開始の制約条件付き需要予測日付

getConstraintStartDateFc

public String getConstraintStartDateFc()
活動の予測開始日を取得します。

戻り値:
srtConstraintStartDateFc 活動の予測開始日

getConstraintStartTimeFc

public String getConstraintStartTimeFc()
活動の需要予測開始時間を取得します。

戻り値:
srtConstraintStartTimeFc 活動の需要予測開始時間

getConstraintFinishDateFc

public String getConstraintFinishDateFc()
予測終了日付を取得します。

戻り値:
srtConstraintFinishDateFc 予測終了日付

getConstraintFinishTimeFc

public String getConstraintFinishTimeFc()
活動の予測終了時間を取得します。

戻り値:
srtConstraintFinishTimeFc 活動の予測終了時間

getEarlyStartDateFc

public String getEarlyStartDateFc()
最早計画開始日付(需要予測)を取得します。

戻り値:
srtEarlyStartDateFc 最早計画開始日付(需要予測)

getEarlyStartTimeFc

public String getEarlyStartTimeFc()
最早計画開始時間(需要予測)を取得します。

戻り値:
srtEarlyStartTimeFc 最早計画開始時間(需要予測)

getEarlyFinishDateFc

public String getEarlyFinishDateFc()
最早計画終了日 (予測)を取得します。

戻り値:
srtEarlyFinishDateFc 最早計画終了日 (予測)

getEarlyFinishTimeFc

public String getEarlyFinishTimeFc()
最早計画終了時間(需要予測)を取得します。

戻り値:
srtEarlyFinishTimeFc 最早計画終了時間(需要予測)

getLatestStartDateFc

public String getLatestStartDateFc()
最遅計画済開始日付(需要予測)を取得します。

戻り値:
srtLatestStartDateFc 最遅計画済開始日付(需要予測)

getLatestStartTimeFc

public String getLatestStartTimeFc()
最遅計画済開始時間(需要予測)を取得します。

戻り値:
srtLatestStartTimeFc 最遅計画済開始時間(需要予測)

getLatestFinishDateFc

public String getLatestFinishDateFc()
最遅計画済終了日付(需要予測)を取得します。

戻り値:
srtLatestFinishDateFc 最遅計画済終了日付(需要予測)

getLatestFinishTimeFc

public String getLatestFinishTimeFc()
最遅計画終了時間 (予測)を取得します。

戻り値:
srtLatestFinishTimeFc 最遅計画終了時間 (予測)

getFloatFreeFc

public String getFloatFreeFc()
自由余裕 (予測)を取得します。

戻り値:
srtFloatFreeFc 自由余裕 (予測)

getFloatTotalFc

public String getFloatTotalFc()
余裕合計 (予測)を取得します。

戻り値:
srtFloatTotalFc 余裕合計 (予測)

getWorkForecast

public String getWorkForecast()
予測作業 (実績 + 残存)を取得します。

戻り値:
srtWorkForecast 予測作業 (実績 + 残存)

getWorkActual

public String getWorkActual()
実績作業を取得します。

戻り値:
srtWorkActual 実績作業

getDurationScheduled

public String getDurationScheduled()
処理時間を取得します。

戻り値:
srtDurationScheduled 処理時間

getDurationScheduledFc

public String getDurationScheduledFc()
処理時間の長さ (予測値)を取得します。

戻り値:
srtDurationScheduledFc 処理時間の長さ (予測値)

getDurationScheduledUnit

public String getDurationScheduledUnit()
処理時間単位を取得します。

戻り値:
srtDurationScheduledUnit 処理時間単位

getDurationScheduledUnitIso

public String getDurationScheduledUnitIso()
単位の ISO コードを取得します。

戻り値:
srtDurationScheduledUnitIso 単位の ISO コード

getDurationConfirmFc

public String getDurationConfirmFc()
確認の予測活動期間を取得します。

戻り値:
srtDurationConfirmFc 確認の予測活動期間

getDurationConfirmFcUnit

public String getDurationConfirmFcUnit()
確認の予測期間単位を取得します。

戻り値:
srtDurationConfirmFcUnit 確認の予測期間単位

getDurationConfirmFcUnitIso

public String getDurationConfirmFcUnitIso()
単位の ISO コードを取得します。

戻り値:
srtDurationConfirmFcUnitIso 単位の ISO コード

getObjectclassExt

public String getObjectclassExt()
オブジェクトクラス、言語依存を取得します。

戻り値:
srtObjectclassExt オブジェクトクラス、言語依存

getFuncArea

public String getFuncArea()
機能領域を取得します。

戻り値:
srtFuncArea 機能領域

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
srtFuncAreaLong 機能領域

getPlannedCost

public String getPlannedCost()
計画原価を取得します。

戻り値:
srtPlannedCost 計画原価

getActualCost

public String getActualCost()
実際原価を取得します。

戻り値:
srtActualCost 実際原価

getControllingAreaCurrency

public String getControllingAreaCurrency()
通貨コードを取得します。

戻り値:
srtControllingAreaCurrency 通貨コード

getActualStartDate

public String getActualStartDate()
実績開始日: 実行 (日付)を取得します。

戻り値:
srtActualStartDate 実績開始日: 実行 (日付)

getActualFinishDate

public String getActualFinishDate()
実績終了日: 実行 (日付)を取得します。

戻り値:
srtActualFinishDate 実績終了日: 実行 (日付)

getForecastFinishDate

public String getForecastFinishDate()
予測終了日を取得します。

戻り値:
srtForecastFinishDate 予測終了日

getComplete

public String getComplete()
最終確認の有効化を取得します。

戻り値:
srtComplete 最終確認の有効化

getReferencePoint

public String getReferencePoint()
BOM 転送の参照ポイントを取得します。

戻り値:
srtReferencePoint BOM 転送の参照ポイント

setNetwork

public void setNetwork(String strNetwork)
ネットワーク番号を設定します。

パラメータ:
strNetwork - ネットワーク番号

setActivity

public void setActivity(String strActivity)
ネットワーク/標準ネットワークの活動番号を設定します。

パラメータ:
strActivity - ネットワーク/標準ネットワークの活動番号

setControlKey

public void setControlKey(String strControlKey)
管理キーを設定します。

パラメータ:
strControlKey - 管理キー

setWorkCntr

public void setWorkCntr(String strWorkCntr)
作業区を設定します。

パラメータ:
strWorkCntr - 作業区

setPlant

public void setPlant(String strPlant)
プラントを設定します。

パラメータ:
strPlant - プラント

setDescription

public void setDescription(String strDescription)
作業テキスト (短)を設定します。

パラメータ:
strDescription - 作業テキスト (短)

setVendorNo

public void setVendorNo(String strVendorNo)
仕入先または債権者の勘定コードを設定します。

パラメータ:
strVendorNo - 仕入先または債権者の勘定コード

setPrice

public void setPrice(String strPrice)
価格を設定します。

パラメータ:
strPrice - 価格

setPriceUnit

public void setPriceUnit(String strPriceUnit)
価格単位を設定します。

パラメータ:
strPriceUnit - 価格単位

setCostElem

public void setCostElem(String strCostElem)
原価要素を設定します。

パラメータ:
strCostElem - 原価要素

setCurrency

public void setCurrency(String strCurrency)
通貨コードを設定します。

パラメータ:
strCurrency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String strCurrencyIso)
ISO 通貨コードを設定します。

パラメータ:
strCurrencyIso - ISO 通貨コード

setInfoRec

public void setInfoRec(String strInfoRec)
購買情報番号を設定します。

パラメータ:
strInfoRec - 購買情報番号

setPurchOrg

public void setPurchOrg(String strPurchOrg)
購買組織を設定します。

パラメータ:
strPurchOrg - 購買組織

setPurGroup

public void setPurGroup(String strPurGroup)
購買グループを設定します。

パラメータ:
strPurGroup - 購買グループ

setMatlGroup

public void setMatlGroup(String strMatlGroup)
品目グループを設定します。

パラメータ:
strMatlGroup - 品目グループ

setFlexibleDuration

public void setFlexibleDuration(String strFlexibleDuration)
区分: 可変期間を設定します。

パラメータ:
strFlexibleDuration - 区分: 可変期間

setNumberOfCapacities

public void setNumberOfCapacities(String strNumberOfCapacities)
所要能力数を設定します。

パラメータ:
strNumberOfCapacities - 所要能力数

setPercentOfWork

public void setPercentOfWork(String strPercentOfWork)
作業の比率 (%)を設定します。

パラメータ:
strPercentOfWork - 作業の比率 (%)

setMilestone

public void setMilestone(String strMilestone)
用途を設定します。

パラメータ:
strMilestone - 用途

setActtype

public void setActtype(String strActtype)
活動タイプを設定します。

パラメータ:
strActtype - 活動タイプ

setActivityCosts

public void setActivityCosts(String strActivityCosts)
活動の原価を設定します。

パラメータ:
strActivityCosts - 活動の原価

setProjectDefinition

public void setProjectDefinition(String strProjectDefinition)
プロジェクト定義を設定します。

パラメータ:
strProjectDefinition - プロジェクト定義

setWbsElement

public void setWbsElement(String strWbsElement)
WBS 要素を設定します。

パラメータ:
strWbsElement - WBS 要素

setFactoryCalendar

public void setFactoryCalendar(String strFactoryCalendar)
稼働日カレンダを設定します。

パラメータ:
strFactoryCalendar - 稼働日カレンダ

setDistributingKey

public void setDistributingKey(String strDistributingKey)
能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)を設定します。

パラメータ:
strDistributingKey - 能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)

setPriority

public void setPriority(String strPriority)
優先度を設定します。

パラメータ:
strPriority - 優先度

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税計算管轄コード - 税管轄コード

setObjectclass

public void setObjectclass(String strObjectclass)
オブジェクトクラス (言語非依存)を設定します。

パラメータ:
strObjectclass - オブジェクトクラス (言語非依存)

setProfitCtr

public void setProfitCtr(String strProfitCtr)
利益センタを設定します。

パラメータ:
strProfitCtr - 利益センタ

setNotMrpApplicable

public void setNotMrpApplicable(String strNotMrpApplicable)
区分: MRP への入出庫予定の適用不可と購買依頼未登録を設定します。

パラメータ:
strNotMrpApplicable - 区分: MRP への入出庫予定の適用不可と購買依頼未登録

setProjectSummarization

public void setProjectSummarization(String strProjectSummarization)
区分: プロジェクト集計用に活動を考慮を設定します。

パラメータ:
strProjectSummarization - 区分: プロジェクト集計用に活動を考慮

setOperationMeasureUnit

public void setOperationMeasureUnit(String strOperationMeasureUnit)
活動単位を設定します。

パラメータ:
strOperationMeasureUnit - 活動単位

setOperationMeasureUnitIso

public void setOperationMeasureUnitIso(String strOperationMeasureUnitIso)
単位の ISO コードを設定します。

パラメータ:
strOperationMeasureUnitIso - 単位の ISO コード

setPlndDelry

public void setPlndDelry(String strPlndDelry)
予定納入時間 (単位: 日)を設定します。

パラメータ:
strPlndDelry - 予定納入時間 (単位: 日)

setDurationNormal

public void setDurationNormal(String strDurationNormal)
標準活動期間を設定します。

パラメータ:
strDurationNormal - 標準活動期間

setDurationNormalUnit

public void setDurationNormalUnit(String strDurationNormalUnit)
標準期間/単位を設定します。

パラメータ:
strDurationNormalUnit - 標準期間/単位

setDurationNormalUnitIso

public void setDurationNormalUnitIso(String strDurationNormalUnitIso)
単位の ISO コードを設定します。

パラメータ:
strDurationNormalUnitIso - 単位の ISO コード

setDurationMinimum

public void setDurationMinimum(String strDurationMinimum)
最短活動期間を設定します。

パラメータ:
strDurationMinimum - 最短活動期間

setDurationMinimumUnit

public void setDurationMinimumUnit(String strDurationMinimumUnit)
最短期間の単位を設定します。

パラメータ:
strDurationMinimumUnit - 最短期間の単位

setDurationMinimumUnitIso

public void setDurationMinimumUnitIso(String strDurationMinimumUnitIso)
単位の ISO コードを設定します。

パラメータ:
strDurationMinimumUnitIso - 単位の ISO コード

setConstraintTypeStart

public void setConstraintTypeStart(String strConstraintTypeStart)
活動の基準開始日に対する制約を設定します。

パラメータ:
strConstraintTypeStart - 活動の基準開始日に対する制約

setConstraintTypeFinish

public void setConstraintTypeFinish(String strConstraintTypeFinish)
活動の終了日に対する制約を設定します。

パラメータ:
strConstraintTypeFinish - 活動の終了日に対する制約

setWorkActivity

public void setWorkActivity(String strWorkActivity)
活動に含まれる作業を設定します。

パラメータ:
strWorkActivity - 活動に含まれる作業

setUnWork

public void setUnWork(String strUnWork)
作業単位を設定します。

パラメータ:
strUnWork - 作業単位

setUnWorkIso

public void setUnWorkIso(String strUnWorkIso)
単位の ISO コードを設定します。

パラメータ:
strUnWorkIso - 単位の ISO コード

setEarlyStartDate

public void setEarlyStartDate(String strEarlyStartDate)
最早計画開始: 実行 (日)を設定します。

パラメータ:
strEarlyStartDate - 最早計画開始: 実行 (日)

setEarlyStartTime

public void setEarlyStartTime(String strEarlyStartTime)
最早計画開始: 作業実施(時間)を設定します。

パラメータ:
strEarlyStartTime - 最早計画開始: 作業実施(時間)

setEarlyFinishDate

public void setEarlyFinishDate(String strEarlyFinishDate)
最早計画終了: 実行 (日)を設定します。

パラメータ:
strEarlyFinishDate - 最早計画終了: 実行 (日)

setEarlyFinishTime

public void setEarlyFinishTime(String strEarlyFinishTime)
最早計画終了: 実行 (時刻)を設定します。

パラメータ:
strEarlyFinishTime - 最早計画終了: 実行 (時刻)

setLatestStartDate

public void setLatestStartDate(String strLatestStartDate)
計画最遅開始: 作業(日付)を設定します。

パラメータ:
strLatestStartDate - 計画最遅開始: 作業(日付)

setLatestStartTime

public void setLatestStartTime(String strLatestStartTime)
計画最遅開始: 作業(時間)を設定します。

パラメータ:
strLatestStartTime - 計画最遅開始: 作業(時間)

setLatestFinishDate

public void setLatestFinishDate(String strLatestFinishDate)
計画最遅終了: 作業(日付)を設定します。

パラメータ:
strLatestFinishDate - 計画最遅終了: 作業(日付)

setLatestFinishTime

public void setLatestFinishTime(String strLatestFinishTime)
計画最遅終了: 作業(時間)を設定します。

パラメータ:
strLatestFinishTime - 計画最遅終了: 作業(時間)

setFloatFree

public void setFloatFree(String strFloatFree)
自由余裕を設定します。

パラメータ:
strFloatFree - 自由余裕

setFloatTotal

public void setFloatTotal(String strFloatTotal)
余裕合計を設定します。

パラメータ:
strFloatTotal - 余裕合計

setConstraintStartDate

public void setConstraintStartDate(String strConstraintStartDate)
活動の基準開始日に対する制約を設定します。

パラメータ:
strConstraintStartDate - 活動の基準開始日に対する制約

setConstraintStartTime

public void setConstraintStartTime(String strConstraintStartTime)
活動の基準開始時間の制約を設定します。

パラメータ:
strConstraintStartTime - 活動の基準開始時間の制約

setConstraintFinishDate

public void setConstraintFinishDate(String strConstraintFinishDate)
活動の基準終了日に対する制約を設定します。

パラメータ:
strConstraintFinishDate - 活動の基準終了日に対する制約

setConstraintFinishTime

public void setConstraintFinishTime(String strConstraintFinishTime)
活動の基準終了時間を設定します。

パラメータ:
strConstraintFinishTime - 活動の基準終了時間

setUserFieldKey

public void setUserFieldKey(String strUserFieldKey)
ユーザ定義項目のキーワード IDを設定します。

パラメータ:
strUserFieldKey - ユーザ定義項目のキーワード ID

setUserFieldChar20_1

public void setUserFieldChar20_1(String strUserFieldChar201)
20 文字のユーザ項目を設定します。

パラメータ:
strUserFieldChar201 - 20 文字のユーザ項目

setUserFieldChar20_2

public void setUserFieldChar20_2(String strUserFieldChar202)
20 文字のユーザ項目を設定します。

パラメータ:
strUserFieldChar202 - 20 文字のユーザ項目

setUserFieldChar10_1

public void setUserFieldChar10_1(String strUserFieldChar101)
ユーザ定義項目 (10 文字)を設定します。

パラメータ:
strUserFieldChar101 - ユーザ定義項目 (10 文字)

setUserFieldChar10_2

public void setUserFieldChar10_2(String strUserFieldChar102)
ユーザ定義項目 (10 文字)を設定します。

パラメータ:
strUserFieldChar102 - ユーザ定義項目 (10 文字)

setUserFieldQuan1

public void setUserFieldQuan1(String strUserFieldQuan1)
数量のユーザ項目 (長さ 10,3)を設定します。

パラメータ:
strUserFieldQuan1 - 数量のユーザ項目 (長さ 10,3)

setUserFieldUnit1

public void setUserFieldUnit1(String strUserFieldUnit1)
ユーザ項目: 数量項目の単位を設定します。

パラメータ:
strUserFieldUnit1 - ユーザ項目: 数量項目の単位

setUserFieldUnit1Iso

public void setUserFieldUnit1Iso(String strUserFieldUnit1Iso)
単位の ISO コードを設定します。

パラメータ:
strUserFieldUnit1Iso - 単位の ISO コード

setUserFieldQuan2

public void setUserFieldQuan2(String strUserFieldQuan2)
数量のユーザ項目 (長さ 10,3)を設定します。

パラメータ:
strUserFieldQuan2 - 数量のユーザ項目 (長さ 10,3)

setUserFieldUnit2

public void setUserFieldUnit2(String strUserFieldUnit2)
ユーザ項目: 数量項目の単位を設定します。

パラメータ:
strUserFieldUnit2 - ユーザ項目: 数量項目の単位

setUserFieldUnit2Iso

public void setUserFieldUnit2Iso(String strUserFieldUnit2Iso)
単位の ISO コードを設定します。

パラメータ:
strUserFieldUnit2Iso - 単位の ISO コード

setUserFieldCurr1

public void setUserFieldCurr1(String strUserFieldCurr1)
値のユーザ定義項目 (長さ 10,3)を設定します。

パラメータ:
strUserFieldCurr1 - 値のユーザ定義項目 (長さ 10,3)

setUserFieldCuky1

public void setUserFieldCuky1(String strUserFieldCuky1)
ユーザ項目: 値項目の単位を設定します。

パラメータ:
strUserFieldCuky1 - ユーザ項目: 値項目の単位

setUserFieldCuky1Iso

public void setUserFieldCuky1Iso(String strUserFieldCuky1Iso)
ISO 通貨コードを設定します。

パラメータ:
strUserFieldCuky1Iso - ISO 通貨コード

setUserFieldCurr2

public void setUserFieldCurr2(String strUserFieldCurr2)
値のユーザ定義項目 (長さ 10,3)を設定します。

パラメータ:
strUserFieldCurr2 - 値のユーザ定義項目 (長さ 10,3)

setUserFieldCuky2

public void setUserFieldCuky2(String strUserFieldCuky2)
ユーザ項目: 値項目の単位を設定します。

パラメータ:
strUserFieldCuky2 - ユーザ項目: 値項目の単位

setUserFieldCuky2Iso

public void setUserFieldCuky2Iso(String strUserFieldCuky2Iso)
ISO 通貨コードを設定します。

パラメータ:
strUserFieldCuky2Iso - ISO 通貨コード

setUserFieldDate1

public void setUserFieldDate1(String strUserFieldDate1)
日付のユーザ項目を設定します。

パラメータ:
strUserFieldDate1 - 日付のユーザ項目

setUserFieldDate2

public void setUserFieldDate2(String strUserFieldDate2)
日付のユーザ項目を設定します。

パラメータ:
strUserFieldDate2 - 日付のユーザ項目

setUserFieldFlag1

public void setUserFieldFlag1(String strUserFieldFlag1)
ユーザ定義項目: レポート区分を設定します。

パラメータ:
strUserFieldFlag1 - ユーザ定義項目: レポート区分

setUserFieldFlag2

public void setUserFieldFlag2(String strUserFieldFlag2)
ユーザ定義項目: レポート区分を設定します。

パラメータ:
strUserFieldFlag2 - ユーザ定義項目: レポート区分

setDeletionFlag

public void setDeletionFlag(String strDeletionFlag)
削除フラグを設定します。

パラメータ:
strDeletionFlag - 削除フラグ

setDurationNormalFc

public void setDurationNormalFc(String strDurationNormalFc)
標準活動期間 (予測)を設定します。

パラメータ:
strDurationNormalFc - 標準活動期間 (予測)

setDurationNormalFcUnit

public void setDurationNormalFcUnit(String strDurationNormalFcUnit)
標準予測期間の単位を設定します。

パラメータ:
strDurationNormalFcUnit - 標準予測期間の単位

setDurationNormalFcUnitIso

public void setDurationNormalFcUnitIso(String strDurationNormalFcUnitIso)
単位の ISO コードを設定します。

パラメータ:
strDurationNormalFcUnitIso - 単位の ISO コード

setDurationMinimumFc

public void setDurationMinimumFc(String strDurationMinimumFc)
活動の最小期間(需要予測より)を設定します。

パラメータ:
strDurationMinimumFc - 活動の最小期間(需要予測より)

setDurationMinimumFcUnit

public void setDurationMinimumFcUnit(String strDurationMinimumFcUnit)
予測最短期間の単位を設定します。

パラメータ:
strDurationMinimumFcUnit - 予測最短期間の単位

setDurationMinimumFcUnitIso

public void setDurationMinimumFcUnitIso(String strDurationMinimumFcUnitIso)
単位の ISO コードを設定します。

パラメータ:
strDurationMinimumFcUnitIso - 単位の ISO コード

setConstraintTypeFinishFc

public void setConstraintTypeFinishFc(String strConstraintTypeFinishFc)
活動終了の制約条件付き需要予測日付を設定します。

パラメータ:
strConstraintTypeFinishFc - 活動終了の制約条件付き需要予測日付

setConstraintTypeStartFc

public void setConstraintTypeStartFc(String strConstraintTypeStartFc)
活動開始の制約条件付き需要予測日付を設定します。

パラメータ:
strConstraintTypeStartFc - 活動開始の制約条件付き需要予測日付

setConstraintStartDateFc

public void setConstraintStartDateFc(String strConstraintStartDateFc)
活動の予測開始日を設定します。

パラメータ:
strConstraintStartDateFc - 活動の予測開始日

setConstraintStartTimeFc

public void setConstraintStartTimeFc(String strConstraintStartTimeFc)
活動の需要予測開始時間を設定します。

パラメータ:
strConstraintStartTimeFc - 活動の需要予測開始時間

setConstraintFinishDateFc

public void setConstraintFinishDateFc(String strConstraintFinishDateFc)
予測終了日付を設定します。

パラメータ:
strConstraintFinishDateFc - 予測終了日付

setConstraintFinishTimeFc

public void setConstraintFinishTimeFc(String strConstraintFinishTimeFc)
活動の予測終了時間を設定します。

パラメータ:
strConstraintFinishTimeFc - 活動の予測終了時間

setEarlyStartDateFc

public void setEarlyStartDateFc(String strEarlyStartDateFc)
最早計画開始日付(需要予測)を設定します。

パラメータ:
strEarlyStartDateFc - 最早計画開始日付(需要予測)

setEarlyStartTimeFc

public void setEarlyStartTimeFc(String strEarlyStartTimeFc)
最早計画開始時間(需要予測)を設定します。

パラメータ:
strEarlyStartTimeFc - 最早計画開始時間(需要予測)

setEarlyFinishDateFc

public void setEarlyFinishDateFc(String strEarlyFinishDateFc)
最早計画終了日 (予測)を設定します。

パラメータ:
strEarlyFinishDateFc - 最早計画終了日 (予測)

setEarlyFinishTimeFc

public void setEarlyFinishTimeFc(String strEarlyFinishTimeFc)
最早計画終了時間(需要予測)を設定します。

パラメータ:
strEarlyFinishTimeFc - 最早計画終了時間(需要予測)

setLatestStartDateFc

public void setLatestStartDateFc(String strLatestStartDateFc)
最遅計画済開始日付(需要予測)を設定します。

パラメータ:
strLatestStartDateFc - 最遅計画済開始日付(需要予測)

setLatestStartTimeFc

public void setLatestStartTimeFc(String strLatestStartTimeFc)
最遅計画済開始時間(需要予測)を設定します。

パラメータ:
strLatestStartTimeFc - 最遅計画済開始時間(需要予測)

setLatestFinishDateFc

public void setLatestFinishDateFc(String strLatestFinishDateFc)
最遅計画済終了日付(需要予測)を設定します。

パラメータ:
strLatestFinishDateFc - 最遅計画済終了日付(需要予測)

setLatestFinishTimeFc

public void setLatestFinishTimeFc(String strLatestFinishTimeFc)
最遅計画終了時間 (予測)を設定します。

パラメータ:
strLatestFinishTimeFc - 最遅計画終了時間 (予測)

setFloatFreeFc

public void setFloatFreeFc(String strFloatFreeFc)
自由余裕 (予測)を設定します。

パラメータ:
strFloatFreeFc - 自由余裕 (予測)

setFloatTotalFc

public void setFloatTotalFc(String strFloatTotalFc)
余裕合計 (予測)を設定します。

パラメータ:
strFloatTotalFc - 余裕合計 (予測)

setWorkForecast

public void setWorkForecast(String strWorkForecast)
予測作業 (実績 + 残存)を設定します。

パラメータ:
strWorkForecast - 予測作業 (実績 + 残存)

setWorkActual

public void setWorkActual(String strWorkActual)
実績作業を設定します。

パラメータ:
strWorkActual - 実績作業

setDurationScheduled

public void setDurationScheduled(String strDurationScheduled)
処理時間を設定します。

パラメータ:
strDurationScheduled - 処理時間

setDurationScheduledFc

public void setDurationScheduledFc(String strDurationScheduledFc)
処理時間の長さ (予測値)を設定します。

パラメータ:
strDurationScheduledFc - 処理時間の長さ (予測値)

setDurationScheduledUnit

public void setDurationScheduledUnit(String strDurationScheduledUnit)
処理時間単位を設定します。

パラメータ:
strDurationScheduledUnit - 処理時間単位

setDurationScheduledUnitIso

public void setDurationScheduledUnitIso(String strDurationScheduledUnitIso)
単位の ISO コードを設定します。

パラメータ:
strDurationScheduledUnitIso - 単位の ISO コード

setDurationConfirmFc

public void setDurationConfirmFc(String strDurationConfirmFc)
確認の予測活動期間を設定します。

パラメータ:
strDurationConfirmFc - 確認の予測活動期間

setDurationConfirmFcUnit

public void setDurationConfirmFcUnit(String strDurationConfirmFcUnit)
確認の予測期間単位を設定します。

パラメータ:
strDurationConfirmFcUnit - 確認の予測期間単位

setDurationConfirmFcUnitIso

public void setDurationConfirmFcUnitIso(String strDurationConfirmFcUnitIso)
単位の ISO コードを設定します。

パラメータ:
strDurationConfirmFcUnitIso - 単位の ISO コード

setObjectclassExt

public void setObjectclassExt(String strObjectclassExt)
オブジェクトクラス、言語依存を設定します。

パラメータ:
strObjectclassExt - オブジェクトクラス、言語依存

setFuncArea

public void setFuncArea(String strFuncArea)
機能領域を設定します。

パラメータ:
strFuncArea - 機能領域

setFuncAreaLong

public void setFuncAreaLong(String strFuncAreaLong)
機能領域を設定します。

パラメータ:
strFuncAreaLong - 機能領域

setPlannedCost

public void setPlannedCost(String strPlannedCost)
計画原価を設定します。

パラメータ:
strPlannedCost - 計画原価

setActualCost

public void setActualCost(String strActualCost)
実際原価を設定します。

パラメータ:
strActualCost - 実際原価

setControllingAreaCurrency

public void setControllingAreaCurrency(String strControllingAreaCurrency)
通貨コードを設定します。

パラメータ:
strControllingAreaCurrency - 通貨コード

setActualStartDate

public void setActualStartDate(String strActualStartDate)
実績開始日: 実行 (日付)を設定します。

パラメータ:
strActualStartDate - 実績開始日: 実行 (日付)

setActualFinishDate

public void setActualFinishDate(String strActualFinishDate)
実績終了日: 実行 (日付)を設定します。

パラメータ:
strActualFinishDate - 実績終了日: 実行 (日付)

setForecastFinishDate

public void setForecastFinishDate(String strForecastFinishDate)
予測終了日を設定します。

パラメータ:
strForecastFinishDate - 予測終了日

setComplete

public void setComplete(String strComplete)
最終確認の有効化を設定します。

パラメータ:
strComplete - 最終確認の有効化

setReferencePoint

public void setReferencePoint(String strReferencePoint)
BOM 転送の参照ポイントを設定します。

パラメータ:
strReferencePoint - BOM 転送の参照ポイント

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExpMessage (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ExpMessage

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ExpMessage
すべての実装インタフェース:
Serializable
public class ExpMessage
extends Object
implements Serializable

詳細情報を読み込みエラー情報クラス 機能は以下の通り

  • 詳細情報を読み込みエラー情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExpMessage()
詳細情報を読み込みエラー情報を作成します。
メソッドの概要
String | getExternalObjectId() SAP 外部対象キーを取得します。
String | getInternalObjectId() SAP 内部対象キーを取得します。
String | getMessageId() メッセージ IDを取得します。
String | getMessageNumber() システムメッセージ番号を取得します。
String | getMessageText() メッセージのテキスト行を取得します。
String | getMessageType() メッセージタイプを取得します。
String | getMethod() メソッドを取得します。
String | getObjectType() オブジェクトタイプを取得します。
void | setExternalObjectId(String strExternalObjectId) SAP 外部対象キーを設定します。
void | setInternalObjectId(String strInternalObjectId) SAP 内部対象キーを設定します。
void | setMessageId(String strMessageId) メッセージ IDを設定します。
void | setMessageNumber(String strMessageNumber) システムメッセージ番号を設定します。
void | setMessageText(String strMessageText) メッセージのテキスト行を設定します。
void | setMessageType(String strMessageType) メッセージタイプを設定します。
void | setMethod(String strMethod) メソッドを設定します。
void | setObjectType(String strObjectType) オブジェクトタイプを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExpMessage

public ExpMessage()
詳細情報を読み込みエラー情報を作成します。

メソッドの詳細

getMethod

public String getMethod()
メソッドを取得します。

戻り値:
srtMethod メソッド

getObjectType

public String getObjectType()
オブジェクトタイプを取得します。

戻り値:
srtObjectType オブジェクトタイプ

getInternalObjectId

public String getInternalObjectId()
SAP 内部対象キーを取得します。

戻り値:
srtInternalObjectId SAP 内部対象キー

getExternalObjectId

public String getExternalObjectId()
SAP 外部対象キーを取得します。

戻り値:
srtExternalObjectId SAP 外部対象キー

getMessageId

public String getMessageId()
メッセージ IDを取得します。

戻り値:
srtMessageId メッセージ ID

getMessageNumber

public String getMessageNumber()
システムメッセージ番号を取得します。

戻り値:
srtMessageNumber システムメッセージ番号

getMessageType

public String getMessageType()
メッセージタイプを取得します。

戻り値:
srtMessageType メッセージタイプ

getMessageText

public String getMessageText()
メッセージのテキスト行を取得します。

戻り値:
srtMessageText メッセージのテキスト行

setMethod

public void setMethod(String strMethod)
メソッドを設定します。

パラメータ:
strMethod - メソッド

setObjectType

public void setObjectType(String strObjectType)
オブジェクトタイプを設定します。

パラメータ:
strObjectType - オブジェクトタイプ

setInternalObjectId

public void setInternalObjectId(String strInternalObjectId)
SAP 内部対象キーを設定します。

パラメータ:
strInternalObjectId - SAP 内部対象キー

setExternalObjectId

public void setExternalObjectId(String strExternalObjectId)
SAP 外部対象キーを設定します。

パラメータ:
strExternalObjectId - SAP 外部対象キー

setMessageId

public void setMessageId(String strMessageId)
メッセージ IDを設定します。

パラメータ:
strMessageId - メッセージ ID

setMessageNumber

public void setMessageNumber(String strMessageNumber)
システムメッセージ番号を設定します。

パラメータ:
strMessageNumber - システムメッセージ番号

setMessageType

public void setMessageType(String strMessageType)
メッセージタイプを設定します。

パラメータ:
strMessageType - メッセージタイプ

setMessageText

public void setMessageText(String strMessageText)
メッセージのテキスト行を設定します。

パラメータ:
strMessageText - メッセージのテキスト行

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExpWbsElement (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ExpWbsElement

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement
すべての実装インタフェース:
Serializable
public class ExpWbsElement
extends Object
implements Serializable

WBS 要素についての詳細情報クラス
機能は以下の通り

  • WBS 要素についての詳細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExpWbsElement()
WBS 要素についての詳細情報を作成します。
メソッドの概要
String | getApplicantNo() 申請者番号を取得します。
String | getBusArea() 事業領域を取得します。
String | getCalendar() 稼動日カレンダを取得します。
String | getChangeNo() 変更番号を取得します。
String | getCoArea() 管理領域を取得します。
String | getCompCode() 会社コードを取得します。
String | getCostingSheet() 原価計算表を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO 通貨コードを取得します。
String | getDeletionFlag() 削除フラグを取得します。
String | getDescription() PS: テキスト(短)(第一テキスト行)を取得します。
String | getEquipment() 設備番号を取得します。
String | getEquityType() 持分タイプを取得します。
String | getFuncArea() 機能領域を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getFunctionalLocation() 機能場所を取得します。
String | getIntProfile() プロジェクト/指図金利計算の金利プロファイルを取得します。
String | getInvestProfile() 設備投資案件プロファイルを取得します。
String | getJointVenture() ジョイントベンチャを取得します。
String | getJvJibClass() JIB/JIBE クラスを取得します。
String | getJvJibSubClassA() JIB/JIBE サブクラスAを取得します。
String | getJvObjectType() ジョイントベンチャ対象タイプを取得します。
String | getLocation() 場所を取得します。
String | getNetworkAssignment() ネットワーク割当を取得します。
String | getObjectclass() 対象クラスを取得します。
String | getObjectclassExt() オブジェクトクラス、言語依存を取得します。
String | getOverheadKey() 間接費キーを取得します。
String | getPlant() プラントを取得します。
String | getPriority() 優先度を取得します。
String | getProfitCtr() 利益センタを取得します。
String | getProjectDefinition() プロジェクト定義を取得します。
String | getProjType() プロジェクトタイプを取得します。
String | getRecoveryInd() リカバリフラグを取得します。
String | getRequestCctr() 申請原価センタを取得します。
String | getRequestCctrControllingArea() 依頼原価センタの管理領域を取得します。
String | getRequestCompCode() 会社コード要求を取得します。
String | getResAnalKey() 結果分析キーを取得します。
String | getResponsibleNo() 責任者番号 (プロジェクト責任者)を取得します。
String | getRespsblCctr() 責任原価センタを取得します。
String | getRespsblCctrControllingArea() 責任原価センタの管理領域を取得します。
String | getShortId() WBS 要素 ショート IDを取得します。
String | getStatistical() 統計 WBS 要素を取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getUserFieldChar10_1() 10 桁の第 3 ユーザ項目 - WBS 要素を取得します。
String | getUserFieldChar10_2() 10 桁の第 4 ユーザ項目 - WBS 要素を取得します。
String | getUserFieldChar20_1() 20 文字の第 1 ユーザ項目 - WBS 要素 -を取得します。
String | getUserFieldChar20_2() 20 桁の第 2 ユーザ項目 - WBS 要素を取得します。
String | getUserFieldCuky1() 値項目単位の第１ユーザ定義項目 - WBS 要素を取得します。
String | getUserFieldCuky1Iso() ISO 通貨コードを取得します。
String | getUserFieldCuky2() 値項目単位の第２ユーザ定義項目 - WBS 要素を取得します。
String | getUserFieldCuky2Iso() ISO 通貨コードを取得します。
String | getUserFieldCurr1() 値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。
String | getUserFieldCurr2() 値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。
String | getUserFieldDate1() 日付の第 1 ユーザ項目 - WBS 要素を取得します。
String | getUserFieldDate2() 日付の第 2 ユーザ項目 - WBS 要素を取得します。
String | getUserFieldFlag1() '評価区分' の第 1 ユーザ項目 - WBS 要素を取得します。
String | getUserFieldFlag2() '評価区分' の第 2 ユーザ項目 - WBS 要素を取得します。
String | getUserFieldKey() ユーザ定義項目のキーワード IDを取得します。
String | getUserFieldQuan1() 数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。
String | getUserFieldQuan2() 数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。
String | getUserFieldUnit1() 数量項目単位の第１ユーザ定義項目 - WBS 要素を取得します。
String | getUserFieldUnit1Iso() 単位の ISO コードを取得します。
String | getUserFieldUnit2() 数量項目単位の第２ユーザ定義項目 - WBS 要素を取得します。
String | getUserFieldUnit2Iso() 単位の ISO コードを取得します。
String | getWbsAccountAssignmentElement() 区分: 勘定設定要素を取得します。
String | getWbsActualDuration() WBS 要素の実績長(期間)を取得します。
String | getWbsActualDurUnit() 実績 WBS 要素日付の期間単位を取得します。
String | getWbsActualDurUnitIso() 単位の ISO コードを取得します。
String | getWbsActualFinishDate() WBS 要素の実績終了日を取得します。
String | getWbsActualStartDate() WBS 要素の実績開始日付を取得します。
String | getWbsBasicDuration() WBS 要素の基準日の長さ(期間)を取得します。
String | getWbsBasicDurUnit() 基準 WBS 要素日付の期間単位を取得します。
String | getWbsBasicDurUnitIso() 単位の ISO コードを取得します。
String | getWbsBasicFinishDate() WBS 要素: 基本終了日付を取得します。
String | getWbsBasicStartDate() WBS 要素: 基本開始日を取得します。
String | getWbsBillingElement() 区分: 請求要素を取得します。
String | getWbsCctrPostedActual() 原価が実際に転記される原価センタを取得します。
String | getWbsElement() WBS 要素を取得します。
String | getWbsForcastDurUnit() WBS 要素計画日付の単位を取得します。
String | getWbsForecastDuration() WBS 要素の予測期間を取得します。
String | getWbsForecastDurUnitIso() 単位の ISO コードを取得します。
String | getWbsForecastFinishDate() WBS 要素の予測済終了日付を取得します。
String | getWbsForecastStartDate() WBS 要素の予測開始日を取得します。
String | getWbsPlanningElement() 区分: 計画要素を取得します。
String | getWbsScdActualFinishDate() WBS 要素の仮実績終了日を取得します。
String | getWbsScdActualStartDate() WBS 要素の仮実績開始日を取得します。
String | getWbsScdBasicFinishDate() 最遅計画終了日 (基準)を取得します。
String | getWbsScdBasicStartDate() 最早計画開始日 (基準)を取得します。
String | getWbsScdForecastFinishDate() 最遅計画終了日 (予測)を取得します。
String | getWbsScdForecastStartDate() 計画開始日 (予測)を取得します。
void | setApplicantNo(String strApplicantNo) 申請者番号を設定します。
void | setBusArea(String strBusArea) 事業領域を設定します。
void | setCalendar(String strCalendar) 稼動日カレンダを設定します。
void | setChangeNo(String strChangeNo) 変更番号を設定します。
void | setCoArea(String strCoArea) 管理領域を設定します。
void | setCompCode(String strCompCode) 会社コードを設定します。
void | setCostingSheet(String strCostingSheet) 原価計算表を設定します。
void | setCurrency(String strCurrency) 通貨コードを設定します。
void | setCurrencyIso(String strCurrencyIso) ISO 通貨コードを設定します。
void | setDeletionFlag(String strDeletionFlag) 削除フラグを設定します。
void | setDescription(String strDescription) PS: テキスト(短)(第一テキスト行)を設定します。
void | setEquipment(String strEquipment) 設備番号を設定します。
void | setEquityType(String strEquityType) 持分タイプを設定します。
void | setFuncArea(String strFuncArea) 機能領域を設定します。
void | setFuncAreaLong(String strFuncAreaLong) 機能領域を設定します。
void | setFunctionalLocation(String strFunctionalLocation) 機能場所を設定します。
void | setIntProfile(String strIntProfile) プロジェクト/指図金利計算の金利プロファイルを設定します。
void | setInvestProfile(String strInvestProfile) 設備投資案件プロファイルを設定します。
void | setJointVenture(String strJointVenture) ジョイントベンチャを設定します。
void | setJvJibClass(String strJvJibClass) JIB/JIBE クラスを設定します。
void | setJvJibSubClassA(String strJvJibSubClassA) JIB/JIBE サブクラスAを設定します。
void | setJvObjectType(String strJvObjectType) ジョイントベンチャ対象タイプを設定します。
void | setLocation(String strLocation) 場所を設定します。
void | setNetworkAssignment(String strNetworkAssignment) ネットワーク割当を設定します。
void | setObjectclass(String strObjectclass) 対象クラスを設定します。
void | setObjectclassExt(String strObjectclassExt) オブジェクトクラス、言語依存を設定します。
void | setOverheadKey(String strOverheadKey) 間接費キーを設定します。
void | setPlant(String strPlant) プラントを設定します。
void | setPriority(String strPriority) 優先度を設定します。
void | setProfitCtr(String strProfitCtr) 利益センタを設定します。
void | setProjectDefinition(String strProjectDefinition) プロジェクト定義を設定します。
void | setProjType(String strProjType) プロジェクトタイプを設定します。
void | setRecoveryInd(String strRecoveryInd) リカバリフラグを設定します。
void | setRequestCctr(String strRequestCctr) 申請原価センタを設定します。
void | setRequestCctrControllingArea(String strRequestCctrControllingArea) 依頼原価センタの管理領域を設定します。
void | setRequestCompCode(String strRequestCompCode) 会社コード要求を設定します。
void | setResAnalKey(String strResAnalKey) 結果分析キーを設定します。
void | setResponsibleNo(String strResponsibleNo) 責任者番号 (プロジェクト責任者)を設定します。
void | setRespsblCctr(String strRespsblCctr) 責任原価センタを設定します。
void | setRespsblCctrControllingArea(String strRespsblCctrControllingArea) 責任原価センタの管理領域を設定します。
void | setShortId(String strShortId) WBS 要素 ショート IDを設定します。
void | setStatistical(String strStatistical) 統計 WBS 要素を設定します。
void | setTaxjurcode(String strTaxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setUserFieldChar10_1(String strUserFieldChar101) 10 桁の第 3 ユーザ項目 - WBS 要素を設定します。
void | setUserFieldChar10_2(String strUserFieldChar102) 10 桁の第 4 ユーザ項目 - WBS 要素を設定します。
void | setUserFieldChar20_1(String strUserFieldChar201) 20 文字の第 1 ユーザ項目 - WBS 要素 -を設定します。
void | setUserFieldChar20_2(String strUserFieldChar202) 20 桁の第 2 ユーザ項目 - WBS 要素を設定します。
void | setUserFieldCuky1(String strUserFieldCuky1) 値項目単位の第１ユーザ定義項目 - WBS 要素を設定します。
void | setUserFieldCuky1Iso(String strUserFieldCuky1Iso) ISO 通貨コードを設定します。
void | setUserFieldCuky2(String strUserFieldCuky2) 値項目単位の第２ユーザ定義項目 - WBS 要素を設定します。
void | setUserFieldCuky2Iso(String strUserFieldCuky2Iso) ISO 通貨コードを設定します。
void | setUserFieldCurr1(String strUserFieldCurr1) 値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。
void | setUserFieldCurr2(String strUserFieldCurr2) 値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。
void | setUserFieldDate1(String strUserFieldDate1) 日付の第 1 ユーザ項目 - WBS 要素を設定します。
void | setUserFieldDate2(String strUserFieldDate2) 日付の第 2 ユーザ項目 - WBS 要素を設定します。
void | setUserFieldFlag1(String strUserFieldFlag1) '評価区分' の第 1 ユーザ項目 - WBS 要素を設定します。
void | setUserFieldFlag2(String strUserFieldFlag2) '評価区分' の第 2 ユーザ項目 - WBS 要素を設定します。
void | setUserFieldKey(String strUserFieldKey) ユーザ定義項目のキーワード IDを設定します。
void | setUserFieldQuan1(String strUserFieldQuan1) 数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。
void | setUserFieldQuan2(String strUserFieldQuan2) 数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。
void | setUserFieldUnit1(String strUserFieldUnit1) 数量項目単位の第１ユーザ定義項目 - WBS 要素を設定します。
void | setUserFieldUnit1Iso(String strUserFieldUnit1Iso) 単位の ISO コードを設定します。
void | setUserFieldUnit2(String strUserFieldUnit2) 数量項目単位の第２ユーザ定義項目 - WBS 要素を設定します。
void | setUserFieldUnit2Iso(String strUserFieldUnit2Iso) 単位の ISO コードを設定します。
void | setWbsAccountAssignmentElement(String strWbsAccountAssignmentElement) 区分: 勘定設定要素を設定します。
void | setWbsActualDuration(String strWbsActualDuration) WBS 要素の実績長(期間)を設定します。
void | setWbsActualDurUnit(String strWbsActualDurUnit) 実績 WBS 要素日付の期間単位を設定します。
void | setWbsActualDurUnitIso(String strWbsActualDurUnitIso) 単位の ISO コードを設定します。
void | setWbsActualFinishDate(String strWbsActualFinishDate) WBS 要素の実績終了日を設定します。
void | setWbsActualStartDate(String strWbsActualStartDate) WBS 要素の実績開始日付を設定します。
void | setWbsBasicDuration(String strWbsBasicDuration) WBS 要素の基準日の長さ(期間)を設定します。
void | setWbsBasicDurUnit(String strWbsBasicDurUnit) 基準 WBS 要素日付の期間単位を設定します。
void | setWbsBasicDurUnitIso(String strWbsBasicDurUnitIso) 単位の ISO コードを設定します。
void | setWbsBasicFinishDate(String strWbsBasicFinishDate) WBS 要素: 基本終了日付を設定します。
void | setWbsBasicStartDate(String strWbsBasicStartDate) WBS 要素: 基本開始日を設定します。
void | setWbsBillingElement(String strWbsBillingElement) 区分: 請求要素を設定します。
void | setWbsCctrPostedActual(String strWbsCctrPostedActual) 原価が実際に転記される原価センタを設定します。
void | setWbsElement(String strWbsElement) WBS 要素を設定します。
void | setWbsForcastDurUnit(String strWbsForcastDurUnit) WBS 要素計画日付の単位を設定します。
void | setWbsForecastDuration(String strWbsForecastDuration) WBS 要素の予測期間を設定します。
void | setWbsForecastDurUnitIso(String strWbsForecastDurUnitIso) 単位の ISO コードを設定します。
void | setWbsForecastFinishDate(String strWbsForecastFinishDate) WBS 要素の予測済終了日付を設定します。
void | setWbsForecastStartDate(String strWbsForecastStartDate) WBS 要素の予測開始日を設定します。
void | setWbsPlanningElement(String strWbsPlanningElement) 区分: 計画要素を設定します。
void | setWbsScdActualFinishDate(String strWbsScdActualFinishDate) WBS 要素の仮実績終了日を設定します。
void | setWbsScdActualStartDate(String strWbsScdActualStartDate) WBS 要素の仮実績開始日を設定します。
void | setWbsScdBasicFinishDate(String strWbsScdBasicFinishDate) 最遅計画終了日 (基準)を設定します。
void | setWbsScdBasicStartDate(String strWbsScdBasicStartDate) 最早計画開始日 (基準)を設定します。
void | setWbsScdForecastFinishDate(String strWbsScdForecastFinishDate) 最遅計画終了日 (予測)を設定します。
void | setWbsScdForecastStartDate(String strWbsScdForecastStartDate) 計画開始日 (予測)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExpWbsElement

public ExpWbsElement()
WBS 要素についての詳細情報を作成します。

メソッドの詳細

getWbsElement

public String getWbsElement()
WBS 要素を取得します。

戻り値:
srtWbsElement WBS 要素

getProjectDefinition

public String getProjectDefinition()
プロジェクト定義を取得します。

戻り値:
srtProjectDefinition プロジェクト定義

getDescription

public String getDescription()
PS: テキスト(短)(第一テキスト行)を取得します。

戻り値:
srtDescription PS: テキスト(短)(第一テキスト行)

getShortId

public String getShortId()
WBS 要素 ショート IDを取得します。

戻り値:
srtShortId WBS 要素 ショート ID

getResponsibleNo

public String getResponsibleNo()
責任者番号 (プロジェクト責任者)を取得します。

戻り値:
srtResponsibleNo 責任者番号 (プロジェクト責任者)

getApplicantNo

public String getApplicantNo()
申請者番号を取得します。

戻り値:
srtApplicantNo 申請者番号

getCompCode

public String getCompCode()
会社コードを取得します。

戻り値:
srtCompCode 会社コード

getBusArea

public String getBusArea()
事業領域を取得します。

戻り値:
srtBusArea 事業領域

getCoArea

public String getCoArea()
管理領域を取得します。

戻り値:
srtCoArea 管理領域

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
srtProfitCtr 利益センタ

getProjType

public String getProjType()
プロジェクトタイプを取得します。

戻り値:
srtProjType プロジェクトタイプ

getNetworkAssignment

public String getNetworkAssignment()
ネットワーク割当を取得します。

戻り値:
srtNetworkAssignment ネットワーク割当

getCostingSheet

public String getCostingSheet()
原価計算表を取得します。

戻り値:
srtCostingSheet 原価計算表

getOverheadKey

public String getOverheadKey()
間接費キーを取得します。

戻り値:
srtOverheadKey 間接費キー

getCalendar

public String getCalendar()
稼動日カレンダを取得します。

戻り値:
srtCalendar 稼動日カレンダ

getPriority

public String getPriority()
優先度を取得します。

戻り値:
srtPriority 優先度

getEquipment

public String getEquipment()
設備番号を取得します。

戻り値:
srtEquipment 設備番号

getFunctionalLocation

public String getFunctionalLocation()
機能場所を取得します。

戻り値:
srtFunctionalLocation 機能場所

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
srtCurrency 通貨コード

getCurrencyIso

public String getCurrencyIso()
ISO 通貨コードを取得します。

戻り値:
srtCurrencyIso ISO 通貨コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
srtPlant プラント

getUserFieldKey

public String getUserFieldKey()
ユーザ定義項目のキーワード IDを取得します。

戻り値:
srtUserFieldKey ユーザ定義項目のキーワード ID

getUserFieldChar20_1

public String getUserFieldChar20_1()
20 文字の第 1 ユーザ項目 - WBS 要素 -を取得します。

戻り値:
srtUserFieldChar201 20 文字の第 1 ユーザ項目 - WBS 要素 -

getUserFieldChar20_2

public String getUserFieldChar20_2()
20 桁の第 2 ユーザ項目 - WBS 要素を取得します。

戻り値:
srtUserFieldChar202 20 桁の第 2 ユーザ項目 - WBS 要素

getUserFieldChar10_1

public String getUserFieldChar10_1()
10 桁の第 3 ユーザ項目 - WBS 要素を取得します。

戻り値:
srtUserFieldChar101 10 桁の第 3 ユーザ項目 - WBS 要素

getUserFieldChar10_2

public String getUserFieldChar10_2()
10 桁の第 4 ユーザ項目 - WBS 要素を取得します。

戻り値:
srtUserFieldChar102 10 桁の第 4 ユーザ項目 - WBS 要素

getUserFieldQuan1

public String getUserFieldQuan1()
数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。

戻り値:
srtUserFieldQuan1 数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素

getUserFieldUnit1

public String getUserFieldUnit1()
数量項目単位の第１ユーザ定義項目 - WBS 要素を取得します。

戻り値:
srtUserFieldUnit1 数量項目単位の第１ユーザ定義項目 - WBS 要素

getUserFieldUnit1Iso

public String getUserFieldUnit1Iso()
単位の ISO コードを取得します。

戻り値:
srtUserFieldUnit1Iso 単位の ISO コード

getUserFieldQuan2

public String getUserFieldQuan2()
数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。

戻り値:
srtUserFieldQuan2 数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素

getUserFieldUnit2

public String getUserFieldUnit2()
数量項目単位の第２ユーザ定義項目 - WBS 要素を取得します。

戻り値:
srtUserFieldUnit2 数量項目単位の第２ユーザ定義項目 - WBS 要素

getUserFieldUnit2Iso

public String getUserFieldUnit2Iso()
単位の ISO コードを取得します。

戻り値:
srtUserFieldUnit2Iso 単位の ISO コード

getUserFieldCurr1

public String getUserFieldCurr1()
値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。

戻り値:
srtUserFieldCurr1 値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素

getUserFieldCuky1

public String getUserFieldCuky1()
値項目単位の第１ユーザ定義項目 - WBS 要素を取得します。

戻り値:
srtUserFieldCuky1 値項目単位の第１ユーザ定義項目 - WBS 要素

getUserFieldCuky1Iso

public String getUserFieldCuky1Iso()
ISO 通貨コードを取得します。

戻り値:
srtUserFieldCuky1Iso ISO 通貨コード

getUserFieldCurr2

public String getUserFieldCurr2()
値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。

戻り値:
srtUserFieldCurr2 値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素

getUserFieldCuky2

public String getUserFieldCuky2()
値項目単位の第２ユーザ定義項目 - WBS 要素を取得します。

戻り値:
srtUserFieldCuky2 値項目単位の第２ユーザ定義項目 - WBS 要素

getUserFieldCuky2Iso

public String getUserFieldCuky2Iso()
ISO 通貨コードを取得します。

戻り値:
srtUserFieldCuky2Iso ISO 通貨コード

getUserFieldDate1

public String getUserFieldDate1()
日付の第 1 ユーザ項目 - WBS 要素を取得します。

戻り値:
srtUserFieldDate1 日付の第 1 ユーザ項目 - WBS 要素

getUserFieldDate2

public String getUserFieldDate2()
日付の第 2 ユーザ項目 - WBS 要素を取得します。

戻り値:
srtUserFieldDate2 日付の第 2 ユーザ項目 - WBS 要素

getUserFieldFlag1

public String getUserFieldFlag1()
'評価区分' の第 1 ユーザ項目 - WBS 要素を取得します。

戻り値:
srtUserFieldFlag1 '評価区分' の第 1 ユーザ項目 - WBS 要素

getUserFieldFlag2

public String getUserFieldFlag2()
'評価区分' の第 2 ユーザ項目 - WBS 要素を取得します。

戻り値:
srtUserFieldFlag2 '評価区分' の第 2 ユーザ項目 - WBS 要素

getObjectclass

public String getObjectclass()
対象クラスを取得します。

戻り値:
srtObjectclass 対象クラス

getStatistical

public String getStatistical()
統計 WBS 要素を取得します。

戻り値:
srtStatistical 統計 WBS 要素

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
srtTaxjurcode 税計算管轄コード - 税管轄コード

getIntProfile

public String getIntProfile()
プロジェクト/指図金利計算の金利プロファイルを取得します。

戻り値:
srtIntProfile プロジェクト/指図金利計算の金利プロファイル

getJointVenture

public String getJointVenture()
ジョイントベンチャを取得します。

戻り値:
srtJointVenture ジョイントベンチャ

getRecoveryInd

public String getRecoveryInd()
リカバリフラグを取得します。

戻り値:
srtRecoveryInd リカバリフラグ

getEquityType

public String getEquityType()
持分タイプを取得します。

戻り値:
srtEquityType 持分タイプ

getJvObjectType

public String getJvObjectType()
ジョイントベンチャ対象タイプを取得します。

戻り値:
srtJvObjectType ジョイントベンチャ対象タイプ

getJvJibClass

public String getJvJibClass()
JIB/JIBE クラスを取得します。

戻り値:
srtJvJibClass JIB/JIBE クラス

getJvJibSubClassA

public String getJvJibSubClassA()
JIB/JIBE サブクラスAを取得します。

戻り値:
srtJvJibSubClassA JIB/JIBE サブクラスA

getDeletionFlag

public String getDeletionFlag()
削除フラグを取得します。

戻り値:
srtDeletionFlag 削除フラグ

getObjectclassExt

public String getObjectclassExt()
オブジェクトクラス、言語依存を取得します。

戻り値:
srtObjectclassExt オブジェクトクラス、言語依存

getWbsPlanningElement

public String getWbsPlanningElement()
区分: 計画要素を取得します。

戻り値:
srtWbsPlanningElement 区分: 計画要素

getWbsAccountAssignmentElement

public String getWbsAccountAssignmentElement()
区分: 勘定設定要素を取得します。

戻り値:
srtWbsAccountAssignmentElement 区分: 勘定設定要素

getWbsBillingElement

public String getWbsBillingElement()
区分: 請求要素を取得します。

戻り値:
srtWbsBillingElement 区分: 請求要素

getRespsblCctr

public String getRespsblCctr()
責任原価センタを取得します。

戻り値:
srtRespsblCctr 責任原価センタ

getRespsblCctrControllingArea

public String getRespsblCctrControllingArea()
責任原価センタの管理領域を取得します。

戻り値:
srtRespsblCctrControllingArea 責任原価センタの管理領域

getRequestCctr

public String getRequestCctr()
申請原価センタを取得します。

戻り値:
srtRequestCctr 申請原価センタ

getRequestCompCode

public String getRequestCompCode()
会社コード要求を取得します。

戻り値:
srtRequestCompCode 会社コード要求

getRequestCctrControllingArea

public String getRequestCctrControllingArea()
依頼原価センタの管理領域を取得します。

戻り値:
srtRequestCctrControllingArea 依頼原価センタの管理領域

getLocation

public String getLocation()
場所を取得します。

戻り値:
srtLocation 場所

getChangeNo

public String getChangeNo()
変更番号を取得します。

戻り値:
srtChangeNo 変更番号

getInvestProfile

public String getInvestProfile()
設備投資案件プロファイルを取得します。

戻り値:
srtInvestProfile 設備投資案件プロファイル

getResAnalKey

public String getResAnalKey()
結果分析キーを取得します。

戻り値:
srtResAnalKey 結果分析キー

getWbsCctrPostedActual

public String getWbsCctrPostedActual()
原価が実際に転記される原価センタを取得します。

戻り値:
srtWbsCctrPostedActual 原価が実際に転記される原価センタ

getWbsBasicStartDate

public String getWbsBasicStartDate()
WBS 要素: 基本開始日を取得します。

戻り値:
srtWbsBasicStartDate WBS 要素: 基本開始日

getWbsBasicFinishDate

public String getWbsBasicFinishDate()
WBS 要素: 基本終了日付を取得します。

戻り値:
srtWbsBasicFinishDate WBS 要素: 基本終了日付

getWbsForecastStartDate

public String getWbsForecastStartDate()
WBS 要素の予測開始日を取得します。

戻り値:
srtWbsForecastStartDate WBS 要素の予測開始日

getWbsForecastFinishDate

public String getWbsForecastFinishDate()
WBS 要素の予測済終了日付を取得します。

戻り値:
srtWbsForecastFinishDate WBS 要素の予測済終了日付

getWbsActualStartDate

public String getWbsActualStartDate()
WBS 要素の実績開始日付を取得します。

戻り値:
srtWbsActualStartDate WBS 要素の実績開始日付

getWbsActualFinishDate

public String getWbsActualFinishDate()
WBS 要素の実績終了日を取得します。

戻り値:
srtWbsActualFinishDate WBS 要素の実績終了日

getWbsBasicDuration

public String getWbsBasicDuration()
WBS 要素の基準日の長さ(期間)を取得します。

戻り値:
srtWbsBasicDuration WBS 要素の基準日の長さ(期間)

getWbsBasicDurUnit

public String getWbsBasicDurUnit()
基準 WBS 要素日付の期間単位を取得します。

戻り値:
srtWbsBasicDurUnit 基準 WBS 要素日付の期間単位

getWbsBasicDurUnitIso

public String getWbsBasicDurUnitIso()
単位の ISO コードを取得します。

戻り値:
srtWbsBasicDurUnitIso 単位の ISO コード

getWbsForecastDuration

public String getWbsForecastDuration()
WBS 要素の予測期間を取得します。

戻り値:
srtWbsForecastDuration WBS 要素の予測期間

getWbsForcastDurUnit

public String getWbsForcastDurUnit()
WBS 要素計画日付の単位を取得します。

戻り値:
srtWbsForcastDurUnit WBS 要素計画日付の単位

getWbsForecastDurUnitIso

public String getWbsForecastDurUnitIso()
単位の ISO コードを取得します。

戻り値:
srtWbsForecastDurUnitIso 単位の ISO コード

getWbsActualDuration

public String getWbsActualDuration()
WBS 要素の実績長(期間)を取得します。

戻り値:
srtWbsActualDuration WBS 要素の実績長(期間)

getWbsActualDurUnit

public String getWbsActualDurUnit()
実績 WBS 要素日付の期間単位を取得します。

戻り値:
srtWbsActualDurUnit 実績 WBS 要素日付の期間単位

getWbsActualDurUnitIso

public String getWbsActualDurUnitIso()
単位の ISO コードを取得します。

戻り値:
srtWbsActualDurUnitIso 単位の ISO コード

getWbsScdBasicStartDate

public String getWbsScdBasicStartDate()
最早計画開始日 (基準)を取得します。

戻り値:
srtWbsScdBasicStartDate 最早計画開始日 (基準)

getWbsScdBasicFinishDate

public String getWbsScdBasicFinishDate()
最遅計画終了日 (基準)を取得します。

戻り値:
srtWbsScdBasicFinishDate 最遅計画終了日 (基準)

getWbsScdForecastStartDate

public String getWbsScdForecastStartDate()
計画開始日 (予測)を取得します。

戻り値:
srtWbsScdForecastStartDate 計画開始日 (予測)

getWbsScdForecastFinishDate

public String getWbsScdForecastFinishDate()
最遅計画終了日 (予測)を取得します。

戻り値:
srtWbsScdForecastFinishDate 最遅計画終了日 (予測)

getWbsScdActualStartDate

public String getWbsScdActualStartDate()
WBS 要素の仮実績開始日を取得します。

戻り値:
srtWbsScdActualStartDate WBS 要素の仮実績開始日

getWbsScdActualFinishDate

public String getWbsScdActualFinishDate()
WBS 要素の仮実績終了日を取得します。

戻り値:
srtWbsScdActualFinishDate WBS 要素の仮実績終了日

getFuncArea

public String getFuncArea()
機能領域を取得します。

戻り値:
srtFuncArea 機能領域

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
srtFuncAreaLong 機能領域

setWbsElement

public void setWbsElement(String strWbsElement)
WBS 要素を設定します。

パラメータ:
strWbsElement - WBS 要素

setProjectDefinition

public void setProjectDefinition(String strProjectDefinition)
プロジェクト定義を設定します。

パラメータ:
strProjectDefinition - プロジェクト定義

setDescription

public void setDescription(String strDescription)
PS: テキスト(短)(第一テキスト行)を設定します。

パラメータ:
strDescription - PS: テキスト(短)(第一テキスト行)

setShortId

public void setShortId(String strShortId)
WBS 要素 ショート IDを設定します。

パラメータ:
strShortId - WBS 要素 ショート ID

setResponsibleNo

public void setResponsibleNo(String strResponsibleNo)
責任者番号 (プロジェクト責任者)を設定します。

パラメータ:
strResponsibleNo - 責任者番号 (プロジェクト責任者)

setApplicantNo

public void setApplicantNo(String strApplicantNo)
申請者番号を設定します。

パラメータ:
strApplicantNo - 申請者番号

setCompCode

public void setCompCode(String strCompCode)
会社コードを設定します。

パラメータ:
strCompCode - 会社コード

setBusArea

public void setBusArea(String strBusArea)
事業領域を設定します。

パラメータ:
strBusArea - 事業領域

setCoArea

public void setCoArea(String strCoArea)
管理領域を設定します。

パラメータ:
strCoArea - 管理領域

setProfitCtr

public void setProfitCtr(String strProfitCtr)
利益センタを設定します。

パラメータ:
strProfitCtr - 利益センタ

setProjType

public void setProjType(String strProjType)
プロジェクトタイプを設定します。

パラメータ:
strProjType - プロジェクトタイプ

setNetworkAssignment

public void setNetworkAssignment(String strNetworkAssignment)
ネットワーク割当を設定します。

パラメータ:
strNetworkAssignment - ネットワーク割当

setCostingSheet

public void setCostingSheet(String strCostingSheet)
原価計算表を設定します。

パラメータ:
strCostingSheet - 原価計算表

setOverheadKey

public void setOverheadKey(String strOverheadKey)
間接費キーを設定します。

パラメータ:
strOverheadKey - 間接費キー

setCalendar

public void setCalendar(String strCalendar)
稼動日カレンダを設定します。

パラメータ:
strCalendar - 稼動日カレンダ

setPriority

public void setPriority(String strPriority)
優先度を設定します。

パラメータ:
strPriority - 優先度

setEquipment

public void setEquipment(String strEquipment)
設備番号を設定します。

パラメータ:
strEquipment - 設備番号

setFunctionalLocation

public void setFunctionalLocation(String strFunctionalLocation)
機能場所を設定します。

パラメータ:
strFunctionalLocation - 機能場所

setCurrency

public void setCurrency(String strCurrency)
通貨コードを設定します。

パラメータ:
strCurrency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String strCurrencyIso)
ISO 通貨コードを設定します。

パラメータ:
strCurrencyIso - ISO 通貨コード

setPlant

public void setPlant(String strPlant)
プラントを設定します。

パラメータ:
strPlant - プラント

setUserFieldKey

public void setUserFieldKey(String strUserFieldKey)
ユーザ定義項目のキーワード IDを設定します。

パラメータ:
strUserFieldKey - ユーザ定義項目のキーワード ID

setUserFieldChar20_1

public void setUserFieldChar20_1(String strUserFieldChar201)
20 文字の第 1 ユーザ項目 - WBS 要素 -を設定します。

パラメータ:
strUserFieldChar201 - 20 文字の第 1 ユーザ項目 - WBS 要素 -

setUserFieldChar20_2

public void setUserFieldChar20_2(String strUserFieldChar202)
20 桁の第 2 ユーザ項目 - WBS 要素を設定します。

パラメータ:
strUserFieldChar202 - 20 桁の第 2 ユーザ項目 - WBS 要素

setUserFieldChar10_1

public void setUserFieldChar10_1(String strUserFieldChar101)
10 桁の第 3 ユーザ項目 - WBS 要素を設定します。

パラメータ:
strUserFieldChar101 - 10 桁の第 3 ユーザ項目 - WBS 要素

setUserFieldChar10_2

public void setUserFieldChar10_2(String strUserFieldChar102)
10 桁の第 4 ユーザ項目 - WBS 要素を設定します。

パラメータ:
strUserFieldChar102 - 10 桁の第 4 ユーザ項目 - WBS 要素

setUserFieldQuan1

public void setUserFieldQuan1(String strUserFieldQuan1)
数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。

パラメータ:
strUserFieldQuan1 - 数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素

setUserFieldUnit1

public void setUserFieldUnit1(String strUserFieldUnit1)
数量項目単位の第１ユーザ定義項目 - WBS 要素を設定します。

パラメータ:
strUserFieldUnit1 - 数量項目単位の第１ユーザ定義項目 - WBS 要素

setUserFieldUnit1Iso

public void setUserFieldUnit1Iso(String strUserFieldUnit1Iso)
単位の ISO コードを設定します。

パラメータ:
strUserFieldUnit1Iso - 単位の ISO コード

setUserFieldQuan2

public void setUserFieldQuan2(String strUserFieldQuan2)
数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。

パラメータ:
strUserFieldQuan2 - 数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素

setUserFieldUnit2

public void setUserFieldUnit2(String strUserFieldUnit2)
数量項目単位の第２ユーザ定義項目 - WBS 要素を設定します。

パラメータ:
strUserFieldUnit2 - 数量項目単位の第２ユーザ定義項目 - WBS 要素

setUserFieldUnit2Iso

public void setUserFieldUnit2Iso(String strUserFieldUnit2Iso)
単位の ISO コードを設定します。

パラメータ:
strUserFieldUnit2Iso - 単位の ISO コード

setUserFieldCurr1

public void setUserFieldCurr1(String strUserFieldCurr1)
値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。

パラメータ:
strUserFieldCurr1 - 値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素

setUserFieldCuky1

public void setUserFieldCuky1(String strUserFieldCuky1)
値項目単位の第１ユーザ定義項目 - WBS 要素を設定します。

パラメータ:
strUserFieldCuky1 - 値項目単位の第１ユーザ定義項目 - WBS 要素

setUserFieldCuky1Iso

public void setUserFieldCuky1Iso(String strUserFieldCuky1Iso)
ISO 通貨コードを設定します。

パラメータ:
strUserFieldCuky1Iso - ISO 通貨コード

setUserFieldCurr2

public void setUserFieldCurr2(String strUserFieldCurr2)
値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。

パラメータ:
strUserFieldCurr2 - 値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素

setUserFieldCuky2

public void setUserFieldCuky2(String strUserFieldCuky2)
値項目単位の第２ユーザ定義項目 - WBS 要素を設定します。

パラメータ:
strUserFieldCuky2 - 値項目単位の第２ユーザ定義項目 - WBS 要素

setUserFieldCuky2Iso

public void setUserFieldCuky2Iso(String strUserFieldCuky2Iso)
ISO 通貨コードを設定します。

パラメータ:
strUserFieldCuky2Iso - ISO 通貨コード

setUserFieldDate1

public void setUserFieldDate1(String strUserFieldDate1)
日付の第 1 ユーザ項目 - WBS 要素を設定します。

パラメータ:
strUserFieldDate1 - 日付の第 1 ユーザ項目 - WBS 要素

setUserFieldDate2

public void setUserFieldDate2(String strUserFieldDate2)
日付の第 2 ユーザ項目 - WBS 要素を設定します。

パラメータ:
strUserFieldDate2 - 日付の第 2 ユーザ項目 - WBS 要素

setUserFieldFlag1

public void setUserFieldFlag1(String strUserFieldFlag1)
'評価区分' の第 1 ユーザ項目 - WBS 要素を設定します。

パラメータ:
strUserFieldFlag1 - '評価区分' の第 1 ユーザ項目 - WBS 要素

setUserFieldFlag2

public void setUserFieldFlag2(String strUserFieldFlag2)
'評価区分' の第 2 ユーザ項目 - WBS 要素を設定します。

パラメータ:
strUserFieldFlag2 - '評価区分' の第 2 ユーザ項目 - WBS 要素

setObjectclass

public void setObjectclass(String strObjectclass)
対象クラスを設定します。

パラメータ:
strObjectclass - 対象クラス

setStatistical

public void setStatistical(String strStatistical)
統計 WBS 要素を設定します。

パラメータ:
strStatistical - 統計 WBS 要素

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税計算管轄コード - 税管轄コード

setIntProfile

public void setIntProfile(String strIntProfile)
プロジェクト/指図金利計算の金利プロファイルを設定します。

パラメータ:
strIntProfile - プロジェクト/指図金利計算の金利プロファイル

setJointVenture

public void setJointVenture(String strJointVenture)
ジョイントベンチャを設定します。

パラメータ:
strJointVenture - ジョイントベンチャ

setRecoveryInd

public void setRecoveryInd(String strRecoveryInd)
リカバリフラグを設定します。

パラメータ:
strRecoveryInd - リカバリフラグ

setEquityType

public void setEquityType(String strEquityType)
持分タイプを設定します。

パラメータ:
strEquityType - 持分タイプ

setJvObjectType

public void setJvObjectType(String strJvObjectType)
ジョイントベンチャ対象タイプを設定します。

パラメータ:
strJvObjectType - ジョイントベンチャ対象タイプ

setJvJibClass

public void setJvJibClass(String strJvJibClass)
JIB/JIBE クラスを設定します。

パラメータ:
strJvJibClass - JIB/JIBE クラス

setJvJibSubClassA

public void setJvJibSubClassA(String strJvJibSubClassA)
JIB/JIBE サブクラスAを設定します。

パラメータ:
strJvJibSubClassA - JIB/JIBE サブクラスA

setDeletionFlag

public void setDeletionFlag(String strDeletionFlag)
削除フラグを設定します。

パラメータ:
strDeletionFlag - 削除フラグ

setObjectclassExt

public void setObjectclassExt(String strObjectclassExt)
オブジェクトクラス、言語依存を設定します。

パラメータ:
strObjectclassExt - オブジェクトクラス、言語依存

setWbsPlanningElement

public void setWbsPlanningElement(String strWbsPlanningElement)
区分: 計画要素を設定します。

パラメータ:
strWbsPlanningElement - 区分: 計画要素

setWbsAccountAssignmentElement

public void setWbsAccountAssignmentElement(String strWbsAccountAssignmentElement)
区分: 勘定設定要素を設定します。

パラメータ:
strWbsAccountAssignmentElement - 区分: 勘定設定要素

setWbsBillingElement

public void setWbsBillingElement(String strWbsBillingElement)
区分: 請求要素を設定します。

パラメータ:
strWbsBillingElement - 区分: 請求要素

setRespsblCctr

public void setRespsblCctr(String strRespsblCctr)
責任原価センタを設定します。

パラメータ:
strRespsblCctr - 責任原価センタ

setRespsblCctrControllingArea

public void setRespsblCctrControllingArea(String strRespsblCctrControllingArea)
責任原価センタの管理領域を設定します。

パラメータ:
strRespsblCctrControllingArea - 責任原価センタの管理領域

setRequestCctr

public void setRequestCctr(String strRequestCctr)
申請原価センタを設定します。

パラメータ:
strRequestCctr - 申請原価センタ

setRequestCompCode

public void setRequestCompCode(String strRequestCompCode)
会社コード要求を設定します。

パラメータ:
strRequestCompCode - 会社コード要求

setRequestCctrControllingArea

public void setRequestCctrControllingArea(String strRequestCctrControllingArea)
依頼原価センタの管理領域を設定します。

パラメータ:
strRequestCctrControllingArea - 依頼原価センタの管理領域

setLocation

public void setLocation(String strLocation)
場所を設定します。

パラメータ:
strLocation - 場所

setChangeNo

public void setChangeNo(String strChangeNo)
変更番号を設定します。

パラメータ:
strChangeNo - 変更番号

setInvestProfile

public void setInvestProfile(String strInvestProfile)
設備投資案件プロファイルを設定します。

パラメータ:
strInvestProfile - 設備投資案件プロファイル

setResAnalKey

public void setResAnalKey(String strResAnalKey)
結果分析キーを設定します。

パラメータ:
strResAnalKey - 結果分析キー

setWbsCctrPostedActual

public void setWbsCctrPostedActual(String strWbsCctrPostedActual)
原価が実際に転記される原価センタを設定します。

パラメータ:
strWbsCctrPostedActual - 原価が実際に転記される原価センタ

setWbsBasicStartDate

public void setWbsBasicStartDate(String strWbsBasicStartDate)
WBS 要素: 基本開始日を設定します。

パラメータ:
strWbsBasicStartDate - WBS 要素: 基本開始日

setWbsBasicFinishDate

public void setWbsBasicFinishDate(String strWbsBasicFinishDate)
WBS 要素: 基本終了日付を設定します。

パラメータ:
strWbsBasicFinishDate - WBS 要素: 基本終了日付

setWbsForecastStartDate

public void setWbsForecastStartDate(String strWbsForecastStartDate)
WBS 要素の予測開始日を設定します。

パラメータ:
strWbsForecastStartDate - WBS 要素の予測開始日

setWbsForecastFinishDate

public void setWbsForecastFinishDate(String strWbsForecastFinishDate)
WBS 要素の予測済終了日付を設定します。

パラメータ:
strWbsForecastFinishDate - WBS 要素の予測済終了日付

setWbsActualStartDate

public void setWbsActualStartDate(String strWbsActualStartDate)
WBS 要素の実績開始日付を設定します。

パラメータ:
strWbsActualStartDate - WBS 要素の実績開始日付

setWbsActualFinishDate

public void setWbsActualFinishDate(String strWbsActualFinishDate)
WBS 要素の実績終了日を設定します。

パラメータ:
strWbsActualFinishDate - WBS 要素の実績終了日

setWbsBasicDuration

public void setWbsBasicDuration(String strWbsBasicDuration)
WBS 要素の基準日の長さ(期間)を設定します。

パラメータ:
strWbsBasicDuration - WBS 要素の基準日の長さ(期間)

setWbsBasicDurUnit

public void setWbsBasicDurUnit(String strWbsBasicDurUnit)
基準 WBS 要素日付の期間単位を設定します。

パラメータ:
strWbsBasicDurUnit - 基準 WBS 要素日付の期間単位

setWbsBasicDurUnitIso

public void setWbsBasicDurUnitIso(String strWbsBasicDurUnitIso)
単位の ISO コードを設定します。

パラメータ:
strWbsBasicDurUnitIso - 単位の ISO コード

setWbsForecastDuration

public void setWbsForecastDuration(String strWbsForecastDuration)
WBS 要素の予測期間を設定します。

パラメータ:
strWbsForecastDuration - WBS 要素の予測期間

setWbsForcastDurUnit

public void setWbsForcastDurUnit(String strWbsForcastDurUnit)
WBS 要素計画日付の単位を設定します。

パラメータ:
strWbsForcastDurUnit - WBS 要素計画日付の単位

setWbsForecastDurUnitIso

public void setWbsForecastDurUnitIso(String strWbsForecastDurUnitIso)
単位の ISO コードを設定します。

パラメータ:
strWbsForecastDurUnitIso - 単位の ISO コード

setWbsActualDuration

public void setWbsActualDuration(String strWbsActualDuration)
WBS 要素の実績長(期間)を設定します。

パラメータ:
strWbsActualDuration - WBS 要素の実績長(期間)

setWbsActualDurUnit

public void setWbsActualDurUnit(String strWbsActualDurUnit)
実績 WBS 要素日付の期間単位を設定します。

パラメータ:
strWbsActualDurUnit - 実績 WBS 要素日付の期間単位

setWbsActualDurUnitIso

public void setWbsActualDurUnitIso(String strWbsActualDurUnitIso)
単位の ISO コードを設定します。

パラメータ:
strWbsActualDurUnitIso - 単位の ISO コード

setWbsScdBasicStartDate

public void setWbsScdBasicStartDate(String strWbsScdBasicStartDate)
最早計画開始日 (基準)を設定します。

パラメータ:
strWbsScdBasicStartDate - 最早計画開始日 (基準)

setWbsScdBasicFinishDate

public void setWbsScdBasicFinishDate(String strWbsScdBasicFinishDate)
最遅計画終了日 (基準)を設定します。

パラメータ:
strWbsScdBasicFinishDate - 最遅計画終了日 (基準)

setWbsScdForecastStartDate

public void setWbsScdForecastStartDate(String strWbsScdForecastStartDate)
計画開始日 (予測)を設定します。

パラメータ:
strWbsScdForecastStartDate - 計画開始日 (予測)

setWbsScdForecastFinishDate

public void setWbsScdForecastFinishDate(String strWbsScdForecastFinishDate)
最遅計画終了日 (予測)を設定します。

パラメータ:
strWbsScdForecastFinishDate - 最遅計画終了日 (予測)

setWbsScdActualStartDate

public void setWbsScdActualStartDate(String strWbsScdActualStartDate)
WBS 要素の仮実績開始日を設定します。

パラメータ:
strWbsScdActualStartDate - WBS 要素の仮実績開始日

setWbsScdActualFinishDate

public void setWbsScdActualFinishDate(String strWbsScdActualFinishDate)
WBS 要素の仮実績終了日を設定します。

パラメータ:
strWbsScdActualFinishDate - WBS 要素の仮実績終了日

setFuncArea

public void setFuncArea(String strFuncArea)
機能領域を設定します。

パラメータ:
strFuncArea - 機能領域

setFuncAreaLong

public void setFuncAreaLong(String strFuncAreaLong)
機能領域を設定します。

パラメータ:
strFuncAreaLong - 機能領域

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExpWbsHierarchie (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ExpWbsHierarchie

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie
すべての実装インタフェース:
Serializable
public class ExpWbsHierarchie
extends Object
implements Serializable

WBS 階層についての情報クラス 機能は以下の通り

  • WBS 階層についての情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExpWbsHierarchie()
WBS 階層についての情報を作成します。
メソッドの概要
String | getDown() WBS 要素を取得します。
String | getLeft() WBS 要素を取得します。
String | getProjectDefinition() プロジェクト定義を取得します。
String | getRight() WBS 要素を取得します。
String | getUp() WBS 要素を取得します。
String | getWbsElement() WBS 要素を取得します。
void | setDown(String strDown) WBS 要素を設定します。
void | setLeft(String strLeft) WBS 要素を設定します。
void | setProjectDefinition(String strProjectDefinition) プロジェクト定義を設定します。
void | setRight(String strRight) WBS 要素を設定します。
void | setUp(String strUp) WBS 要素を設定します。
void | setWbsElement(String strWbsElement) WBS 要素を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExpWbsHierarchie

public ExpWbsHierarchie()
WBS 階層についての情報を作成します。

メソッドの詳細

getWbsElement

public String getWbsElement()
WBS 要素を取得します。

戻り値:
srtWbsElement WBS 要素

getProjectDefinition

public String getProjectDefinition()
プロジェクト定義を取得します。

戻り値:
srtProjectDefinition プロジェクト定義

getUp

public String getUp()
WBS 要素を取得します。

戻り値:
srtUp WBS 要素

getDown

public String getDown()
WBS 要素を取得します。

戻り値:
srtDown WBS 要素

getLeft

public String getLeft()
WBS 要素を取得します。

戻り値:
srtLeft WBS 要素

getRight

public String getRight()
WBS 要素を取得します。

戻り値:
srtRight WBS 要素

setWbsElement

public void setWbsElement(String strWbsElement)
WBS 要素を設定します。

パラメータ:
strWbsElement - WBS 要素

setProjectDefinition

public void setProjectDefinition(String strProjectDefinition)
プロジェクト定義を設定します。

パラメータ:
strProjectDefinition - プロジェクト定義

setUp

public void setUp(String strUp)
WBS 要素を設定します。

パラメータ:
strUp - WBS 要素

setDown

public void setDown(String strDown)
WBS 要素を設定します。

パラメータ:
strDown - WBS 要素

setLeft

public void setLeft(String strLeft)
WBS 要素を設定します。

パラメータ:
strLeft - WBS 要素

setRight

public void setRight(String strRight)
WBS 要素を設定します。

パラメータ:
strRight - WBS 要素

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExpWbsMilestone (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ExpWbsMilestone

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone
すべての実装インタフェース:
Serializable
public class ExpWbsMilestone
extends Object
implements Serializable

WBS マイルストーンに関する詳細情報クラス 機能は以下の通り

  • WBS マイルストーンに関する詳細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExpWbsMilestone()
WBS マイルストーンに関する詳細情報を作成します。
メソッドの概要
String | getActualDate() 実績日付(マイルストーン通過)を取得します。
String | getActualTime() 実績日/時間(マイルストーン適合)を取得します。
String | getDeletionFlag() 削除フラグを取得します。
String | getDescription() テキストを取得します。
String | getEarnedValueIndicator() 進捗分析関連のマイルストーンを取得します。
String | getFixedMilestoneDateBasic() 固定マイルストーン日付(基準)を取得します。
String | getFixedMilestoneDateForecast() マイルストーン固定日付を取得します。
String | getFixedMilestoneTimeBasic() 固定マイルストーン時間(基準)を取得します。
String | getFixedMilestoneTimeForecast() マイルストーン固定時間 (F)を取得します。
String | getInvoicePercentage() 請求金額率 (%)を取得します。
String | getLatestDatesIndicator() 区分: 最遅日を取得します。
String | getMilestoneNumber() マイルストーン番号を取得します。
String | getMilestoneUsage() マイルストーン用途を取得します。
String | getOffsetMilestoneDate() マイルストーン日付のオフセットを取得します。
String | getOffsetMilestoneDateUnit() マイルストーンのオフセットのための時間単位を取得します。
String | getOffsetMilestoneDateUnitIso() 単位の ISO コードを取得します。
String | getOffsetPercentage() 活動日に対するマイルストーンの百分率によるオフセットを取得します。
String | getOffsetStartEndIndicator() 区分: オフセット用の参照（開始/終了活動日）を取得します。
String | getPercentageOfCompletion() 進捗度 (%)を取得します。
String | getSalesDocDateInidicator() 販売伝票の日付に関連するマイルストーンを取得します。
String | getSchedMilestoneDateBasic() マイルストーン計画日(基準)を取得します。
String | getSchedMilestoneDateForecast() マイルストーン計画日(予測)を取得します。
String | getSchedMilestoneTimeBasic() マイルストーン計画時間(基準)を取得します。
String | getSchedMilestoneTimeForecast() マイルストーン計画時間(予測)を取得します。
String | getTrendAnalysisIndicator() 傾向分析の関連マイルストーンを取得します。
String | getWbsElement() WBS 要素を取得します。
void | setActualDate(String strActualDate) 実績日付(マイルストーン通過)を設定します。
void | setActualTime(String strActualTime) 実績日/時間(マイルストーン適合)を設定します。
void | setDeletionFlag(String strDeletionFlag) 削除フラグを設定します。
void | setDescription(String strDescription) テキストを設定します。
void | setEarnedValueIndicator(String strEarnedValueIndicator) 進捗分析関連のマイルストーンを設定します。
void | setFixedMilestoneDateBasic(String strFixedMilestoneDateBasic) 固定マイルストーン日付(基準)を設定します。
void | setFixedMilestoneDateForecast(String strFixedMilestoneDateForecast) マイルストーン固定日付を設定します。
void | setFixedMilestoneTimeBasic(String strFixedMilestoneTimeBasic) 固定マイルストーン時間(基準)を設定します。
void | setFixedMilestoneTimeForecast(String strFixedMilestoneTimeForecast) マイルストーン固定時間 (F)を設定します。
void | setInvoicePercentage(String strInvoicePercentage) 請求金額率 (%)を設定します。
void | setLatestDatesIndicator(String strLatestDatesIndicator) 区分: 最遅日を設定します。
void | setMilestoneNumber(String strMilestoneNumber) マイルストーン番号を設定します。
void | setMilestoneUsage(String strMilestoneUsage) マイルストーン用途を設定します。
void | setOffsetMilestoneDate(String strOffsetMilestoneDate) マイルストーン日付のオフセットを設定します。
void | setOffsetMilestoneDateUnit(String strOffsetMilestoneDateUnit) マイルストーンのオフセットのための時間単位を設定します。
void | setOffsetMilestoneDateUnitIso(String strOffsetMilestoneDateUnitIso) 単位の ISO コードを設定します。
void | setOffsetPercentage(String strOffsetPercentage) 活動日に対するマイルストーンの百分率によるオフセットを設定します。
void | setOffsetStartEndIndicator(String strOffsetStartEndIndicator) 区分: オフセット用の参照（開始/終了活動日）を設定します。
void | setPercentageOfCompletion(String strPercentageOfCompletion) 進捗度 (%)を設定します。
void | setSalesDocDateInidicator(String strSalesDocDateInidicator) 販売伝票の日付に関連するマイルストーンを設定します。
void | setSchedMilestoneDateBasic(String strSchedMilestoneDateBasic) マイルストーン計画日(基準)を設定します。
void | setSchedMilestoneDateForecast(String strSchedMilestoneDateForecast) マイルストーン計画日(予測)を設定します。
void | setSchedMilestoneTimeBasic(String strSchedMilestoneTimeBasic) マイルストーン計画時間(基準)を設定します。
void | setSchedMilestoneTimeForecast(String strSchedMilestoneTimeForecast) マイルストーン計画時間(予測)を設定します。
void | setTrendAnalysisIndicator(String strTrendAnalysisIndicator) 傾向分析の関連マイルストーンを設定します。
void | setWbsElement(String strWbsElement) WBS 要素を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExpWbsMilestone

public ExpWbsMilestone()
WBS マイルストーンに関する詳細情報を作成します。

メソッドの詳細

getMilestoneNumber

public String getMilestoneNumber()
マイルストーン番号を取得します。

戻り値:
srtMilestoneNumber マイルストーン番号

getWbsElement

public String getWbsElement()
WBS 要素を取得します。

戻り値:
srtWbsElement WBS 要素

getMilestoneUsage

public String getMilestoneUsage()
マイルストーン用途を取得します。

戻り値:
srtMilestoneUsage マイルストーン用途

getDescription

public String getDescription()
テキストを取得します。

戻り値:
srtDescription テキスト

getSchedMilestoneDateBasic

public String getSchedMilestoneDateBasic()
マイルストーン計画日(基準)を取得します。

戻り値:
srtSchedMilestoneDateBasic マイルストーン計画日(基準)

getSchedMilestoneTimeBasic

public String getSchedMilestoneTimeBasic()
マイルストーン計画時間(基準)を取得します。

戻り値:
srtSchedMilestoneTimeBasic マイルストーン計画時間(基準)

getSchedMilestoneDateForecast

public String getSchedMilestoneDateForecast()
マイルストーン計画日(予測)を取得します。

戻り値:
srtSchedMilestoneDateForecast マイルストーン計画日(予測)

getSchedMilestoneTimeForecast

public String getSchedMilestoneTimeForecast()
マイルストーン計画時間(予測)を取得します。

戻り値:
srtSchedMilestoneTimeForecast マイルストーン計画時間(予測)

getFixedMilestoneDateBasic

public String getFixedMilestoneDateBasic()
固定マイルストーン日付(基準)を取得します。

戻り値:
srtFixedMilestoneDateBasic 固定マイルストーン日付(基準)

getFixedMilestoneTimeBasic

public String getFixedMilestoneTimeBasic()
固定マイルストーン時間(基準)を取得します。

戻り値:
srtFixedMilestoneTimeBasic 固定マイルストーン時間(基準)

getFixedMilestoneDateForecast

public String getFixedMilestoneDateForecast()
マイルストーン固定日付を取得します。

戻り値:
srtFixedMilestoneDateForecast マイルストーン固定日付

getFixedMilestoneTimeForecast

public String getFixedMilestoneTimeForecast()
マイルストーン固定時間 (F)を取得します。

戻り値:
srtFixedMilestoneTimeForecast マイルストーン固定時間 (F)

getActualDate

public String getActualDate()
実績日付(マイルストーン通過)を取得します。

戻り値:
srtActualDate 実績日付(マイルストーン通過)

getActualTime

public String getActualTime()
実績日/時間(マイルストーン適合)を取得します。

戻り値:
srtActualTime 実績日/時間(マイルストーン適合)

getLatestDatesIndicator

public String getLatestDatesIndicator()
区分: 最遅日を取得します。

戻り値:
srtLatestDatesIndicator 区分: 最遅日

getOffsetStartEndIndicator

public String getOffsetStartEndIndicator()
区分: オフセット用の参照（開始/終了活動日）を取得します。

戻り値:
srtOffsetStartEndIndicator 区分: オフセット用の参照（開始/終了活動日）

getOffsetMilestoneDate

public String getOffsetMilestoneDate()
マイルストーン日付のオフセットを取得します。

戻り値:
srtOffsetMilestoneDate マイルストーン日付のオフセット

getOffsetMilestoneDateUnit

public String getOffsetMilestoneDateUnit()
マイルストーンのオフセットのための時間単位を取得します。

戻り値:
srtOffsetMilestoneDateUnit マイルストーンのオフセットのための時間単位

getOffsetMilestoneDateUnitIso

public String getOffsetMilestoneDateUnitIso()
単位の ISO コードを取得します。

戻り値:
srtOffsetMilestoneDateUnitIso 単位の ISO コード

getOffsetPercentage

public String getOffsetPercentage()
活動日に対するマイルストーンの百分率によるオフセットを取得します。

戻り値:
srtOffsetPercentage 活動日に対するマイルストーンの百分率によるオフセット

getTrendAnalysisIndicator

public String getTrendAnalysisIndicator()
傾向分析の関連マイルストーンを取得します。

戻り値:
srtTrendAnalysisIndicator 傾向分析の関連マイルストーン

getEarnedValueIndicator

public String getEarnedValueIndicator()
進捗分析関連のマイルストーンを取得します。

戻り値:
srtEarnedValueIndicator 進捗分析関連のマイルストーン

getPercentageOfCompletion

public String getPercentageOfCompletion()
進捗度 (%)を取得します。

戻り値:
srtPercentageOfCompletion 進捗度 (%)

getSalesDocDateInidicator

public String getSalesDocDateInidicator()
販売伝票の日付に関連するマイルストーンを取得します。

戻り値:
srtSalesDocDateInidicator 販売伝票の日付に関連するマイルストーン

getInvoicePercentage

public String getInvoicePercentage()
請求金額率 (%)を取得します。

戻り値:
srtInvoicePercentage 請求金額率 (%)

getDeletionFlag

public String getDeletionFlag()
削除フラグを取得します。

戻り値:
srtDeletionFlag 削除フラグ

setMilestoneNumber

public void setMilestoneNumber(String strMilestoneNumber)
マイルストーン番号を設定します。

パラメータ:
strMilestoneNumber - マイルストーン番号

setWbsElement

public void setWbsElement(String strWbsElement)
WBS 要素を設定します。

パラメータ:
strWbsElement - WBS 要素

setMilestoneUsage

public void setMilestoneUsage(String strMilestoneUsage)
マイルストーン用途を設定します。

パラメータ:
strMilestoneUsage - マイルストーン用途

setDescription

public void setDescription(String strDescription)
テキストを設定します。

パラメータ:
strDescription - テキスト

setSchedMilestoneDateBasic

public void setSchedMilestoneDateBasic(String strSchedMilestoneDateBasic)
マイルストーン計画日(基準)を設定します。

パラメータ:
strSchedMilestoneDateBasic - マイルストーン計画日(基準)

setSchedMilestoneTimeBasic

public void setSchedMilestoneTimeBasic(String strSchedMilestoneTimeBasic)
マイルストーン計画時間(基準)を設定します。

パラメータ:
strSchedMilestoneTimeBasic - マイルストーン計画時間(基準)

setSchedMilestoneDateForecast

public void setSchedMilestoneDateForecast(String strSchedMilestoneDateForecast)
マイルストーン計画日(予測)を設定します。

パラメータ:
strSchedMilestoneDateForecast - マイルストーン計画日(予測)

setSchedMilestoneTimeForecast

public void setSchedMilestoneTimeForecast(String strSchedMilestoneTimeForecast)
マイルストーン計画時間(予測)を設定します。

パラメータ:
strSchedMilestoneTimeForecast - マイルストーン計画時間(予測)

setFixedMilestoneDateBasic

public void setFixedMilestoneDateBasic(String strFixedMilestoneDateBasic)
固定マイルストーン日付(基準)を設定します。

パラメータ:
strFixedMilestoneDateBasic - 固定マイルストーン日付(基準)

setFixedMilestoneTimeBasic

public void setFixedMilestoneTimeBasic(String strFixedMilestoneTimeBasic)
固定マイルストーン時間(基準)を設定します。

パラメータ:
strFixedMilestoneTimeBasic - 固定マイルストーン時間(基準)

setFixedMilestoneDateForecast

public void setFixedMilestoneDateForecast(String strFixedMilestoneDateForecast)
マイルストーン固定日付を設定します。

パラメータ:
strFixedMilestoneDateForecast - マイルストーン固定日付

setFixedMilestoneTimeForecast

public void setFixedMilestoneTimeForecast(String strFixedMilestoneTimeForecast)
マイルストーン固定時間 (F)を設定します。

パラメータ:
strFixedMilestoneTimeForecast - マイルストーン固定時間 (F)

setActualDate

public void setActualDate(String strActualDate)
実績日付(マイルストーン通過)を設定します。

パラメータ:
strActualDate - 実績日付(マイルストーン通過)

setActualTime

public void setActualTime(String strActualTime)
実績日/時間(マイルストーン適合)を設定します。

パラメータ:
strActualTime - 実績日/時間(マイルストーン適合)

setLatestDatesIndicator

public void setLatestDatesIndicator(String strLatestDatesIndicator)
区分: 最遅日を設定します。

パラメータ:
strLatestDatesIndicator - 区分: 最遅日

setOffsetStartEndIndicator

public void setOffsetStartEndIndicator(String strOffsetStartEndIndicator)
区分: オフセット用の参照（開始/終了活動日）を設定します。

パラメータ:
strOffsetStartEndIndicator - 区分: オフセット用の参照（開始/終了活動日）

setOffsetMilestoneDate

public void setOffsetMilestoneDate(String strOffsetMilestoneDate)
マイルストーン日付のオフセットを設定します。

パラメータ:
strOffsetMilestoneDate - マイルストーン日付のオフセット

setOffsetMilestoneDateUnit

public void setOffsetMilestoneDateUnit(String strOffsetMilestoneDateUnit)
マイルストーンのオフセットのための時間単位を設定します。

パラメータ:
strOffsetMilestoneDateUnit - マイルストーンのオフセットのための時間単位

setOffsetMilestoneDateUnitIso

public void setOffsetMilestoneDateUnitIso(String strOffsetMilestoneDateUnitIso)
単位の ISO コードを設定します。

パラメータ:
strOffsetMilestoneDateUnitIso - 単位の ISO コード

setOffsetPercentage

public void setOffsetPercentage(String strOffsetPercentage)
活動日に対するマイルストーンの百分率によるオフセットを設定します。

パラメータ:
strOffsetPercentage - 活動日に対するマイルストーンの百分率によるオフセット

setTrendAnalysisIndicator

public void setTrendAnalysisIndicator(String strTrendAnalysisIndicator)
傾向分析の関連マイルストーンを設定します。

パラメータ:
strTrendAnalysisIndicator - 傾向分析の関連マイルストーン

setEarnedValueIndicator

public void setEarnedValueIndicator(String strEarnedValueIndicator)
進捗分析関連のマイルストーンを設定します。

パラメータ:
strEarnedValueIndicator - 進捗分析関連のマイルストーン

setPercentageOfCompletion

public void setPercentageOfCompletion(String strPercentageOfCompletion)
進捗度 (%)を設定します。

パラメータ:
strPercentageOfCompletion - 進捗度 (%)

setSalesDocDateInidicator

public void setSalesDocDateInidicator(String strSalesDocDateInidicator)
販売伝票の日付に関連するマイルストーンを設定します。

パラメータ:
strSalesDocDateInidicator - 販売伝票の日付に関連するマイルストーン

setInvoicePercentage

public void setInvoicePercentage(String strInvoicePercentage)
請求金額率 (%)を設定します。

パラメータ:
strInvoicePercentage - 請求金額率 (%)

setDeletionFlag

public void setDeletionFlag(String strDeletionFlag)
削除フラグを設定します。

パラメータ:
strDeletionFlag - 削除フラグ

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HierarchyNodes (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス HierarchyNodes

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes
すべての実装インタフェース:
Serializable
public class HierarchyNodes
extends Object
implements Serializable

階層ノード情報クラス 機能は以下の通り

  • 階層ノード情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
HierarchyNodes()
階層ノードを作成します。
メソッドの概要
String | getDescript() グループテキスト (短)を取得します。
String | getGroupname() グループ名を取得します。
String | getHierlevel() 階層のエントリレベルを取得します。
String | getValcount() 階層ノード内の値の値数を取得します。
void | setDescript(String strDescript) グループテキスト (短)を設定します。
void | setGroupname(String strGroupname) グループ名を設定します。
void | setHierlevel(String strHierlevel) 階層のエントリレベルを設定します。
void | setValcount(String strValcount) 階層ノード内の値の値数を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HierarchyNodes

public HierarchyNodes()
階層ノードを作成します。

メソッドの詳細

getGroupname

public String getGroupname()
グループ名を取得します。

戻り値:
srtGroupname グループ名

getHierlevel

public String getHierlevel()
階層のエントリレベルを取得します。

戻り値:
srtHierlevel 階層のエントリレベル

getValcount

public String getValcount()
階層ノード内の値の値数を取得します。

戻り値:
srtValcount 階層ノード内の値の値数

getDescript

public String getDescript()
グループテキスト (短)を取得します。

戻り値:
srtDescript グループテキスト (短)

setGroupname

public void setGroupname(String strGroupname)
グループ名を設定します。

パラメータ:
strGroupname - グループ名

setHierlevel

public void setHierlevel(String strHierlevel)
階層のエントリレベルを設定します。

パラメータ:
strHierlevel - 階層のエントリレベル

setValcount

public void setValcount(String strValcount)
階層ノード内の値の値数を設定します。

パラメータ:
strValcount - 階層ノード内の値の値数

setDescript

public void setDescript(String strDescript)
グループテキスト (短)を設定します。

パラメータ:
strDescript - グループテキスト (短)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HierarchyValues (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス HierarchyValues

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues
すべての実装インタフェース:
Serializable
public class HierarchyValues
extends Object
implements Serializable

階層値情報クラス 機能は以下の通り

  • 階層値情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
HierarchyValues()
階層値を作成します。
メソッドの概要
String | getValfrom() 原価センタ/利益センタを取得します。
String | getValto() 原価センタ/利益センタを取得します。
void | setValfrom(String strValfrom) 原価センタ/利益センタを設定します。
void | setValto(String strValto) 原価センタ/利益センタを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HierarchyValues

public HierarchyValues()
階層値を作成します。

メソッドの詳細

getValfrom

public String getValfrom()
原価センタ/利益センタを取得します。

戻り値:
srtValfrom 原価センタ/利益センタ

getValto

public String getValto()
原価センタ/利益センタを取得します。

戻り値:
srtValto 原価センタ/利益センタ

setValfrom

public void setValfrom(String strValfrom)
原価センタ/利益センタを設定します。

パラメータ:
strValfrom - 原価センタ/利益センタ

setValto

public void setValto(String strValto)
原価センタ/利益センタを設定します。

パラメータ:
strValto - 原価センタ/利益センタ

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ImpWbsElement (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ImpWbsElement

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement
すべての実装インタフェース:
Serializable
public class ImpWbsElement
extends Object
implements Serializable

詳細情報を必要とする WBS 要素クラス 機能は以下の通り

  • 詳細情報を必要とする WBS 要素を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ImpWbsElement()
詳細情報を必要とする WBS 要素を作成します。
ImpWbsElement(int index)
詳細情報を必要とする WBS 要素を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
String | getWbsElement() WBS 要素を取得します。
void | setIndex(int index) レコード番号を設定します｡
void | setWbsElement(String strWbsElement) WBS 要素を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ImpWbsElement

public ImpWbsElement()
詳細情報を必要とする WBS 要素を作成します。

ImpWbsElement

public ImpWbsElement(int index)
詳細情報を必要とする WBS 要素を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

getWbsElement

public String getWbsElement()
WBS 要素を取得します。

戻り値:
srtWbsElement WBS 要素

setWbsElement

public void setWbsElement(String strWbsElement)
WBS 要素を設定します。

パラメータ:
strWbsElement - WBS 要素

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternalOrderGetDetail (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス InternalOrderGetDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail
すべての実装インタフェース:
Serializable
public class InternalOrderGetDetail
extends ReferenceController
implements Serializable

内部指図書詳細情報取得クラス
機能は以下の通り

  • 内部指図書詳細情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
InternalOrderGetDetail(SapClient sapClient)
内部指図書詳細情報を作成します。
InternalOrderGetDetail(String orderId, String language, SapClient sapClient)
メソッドの概要
void | executeBapi() BapiControllerにより内部指図書詳細情報を検索します。
ArrayList | getAllowedBusTractList() 使用可能業務トランザクションのテーブルを取得します。
String | getLanguage() ステータスおよび業務トランザクションテキストの言語を取得します。
MasterData | getMasterData() 指図のマスタデータ構造を取得します。
String | getOrderid() 指図番号を取得します。
ArrayList | getSystemStatusList() システムステータステーブルを取得します。
ArrayList | getUserStatusList() ユーザステータス/指図ステータステーブルを取得します。
void | setAllowedBusTractList(ArrayList allowedBusTractList) 使用可能業務トランザクションのテーブルを設定します。
void | setExportParam(BapiController bapiController) 内部指図書詳細情報ををセットします。
void | setImportParam(BapiController bapiController) 内部指図書詳細情報を検索する条件ををセットします。
void | setLanguage(String strLanguage) ステータスおよび業務トランザクションテキストの言語を設定します。
void | setMasterData(MasterData masterData) 指図のマスタデータ構造を設定します。
void | setOrderid(String strOrderid) 指図番号を設定します。
void | setSystemStatusList(ArrayList systemStatusList) システムステータステーブルを設定します。
void | setUserStatusList(ArrayList userStatusList) ユーザステータス/指図ステータステーブルを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

InternalOrderGetDetail

public InternalOrderGetDetail(SapClient sapClient)
内部指図書詳細情報を作成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト

InternalOrderGetDetail

public InternalOrderGetDetail(String orderId,
                              String language,
                              SapClient sapClient)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPFinancialAppException,
                              SAPFinancialSystemException
パラメータ:
orderId - 指図番号
language - ステータス及び業務トランザクションテキストの言語
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
BapiControllerにより内部指図書詳細情報を検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPFinancialSystemException
内部指図書詳細情報を検索する条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
内部指図書詳細情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setOrderid

public void setOrderid(String strOrderid)
指図番号を設定します。

パラメータ:
strOrderid - 指図番号

setLanguage

public void setLanguage(String strLanguage)
ステータスおよび業務トランザクションテキストの言語を設定します。

パラメータ:
strLanguage - ステータスおよび業務トランザクションテキストの言語

setMasterData

public void setMasterData(MasterData masterData)
指図のマスタデータ構造を設定します。

パラメータ:
masterData - 指図のマスタデータ構造

setSystemStatusList

public void setSystemStatusList(ArrayList systemStatusList)
システムステータステーブルを設定します。

パラメータ:
systemStatusList - システムステータステーブル

setUserStatusList

public void setUserStatusList(ArrayList userStatusList)
ユーザステータス/指図ステータステーブルを設定します。

パラメータ:
userStatusList - ユーザステータス/指図ステータステーブル

setAllowedBusTractList

public void setAllowedBusTractList(ArrayList allowedBusTractList)
使用可能業務トランザクションのテーブルを設定します。

パラメータ:
allowedBusTractList - 使用可能業務トランザクションのテーブル

getOrderid

public String getOrderid()
指図番号を取得します。

戻り値:
srtOrderid 指図番号

getLanguage

public String getLanguage()
ステータスおよび業務トランザクションテキストの言語を取得します。

戻り値:
srtLanguage ステータスおよび業務トランザクションテキストの言語

getMasterData

public MasterData getMasterData()
指図のマスタデータ構造を取得します。

戻り値:
masterData 指図のマスタデータ構造

getSystemStatusList

public ArrayList getSystemStatusList()
システムステータステーブルを取得します。

戻り値:
systemStatusList システムステータステーブル

getUserStatusList

public ArrayList getUserStatusList()
ユーザステータス/指図ステータステーブルを取得します。

戻り値:
userStatusList ユーザステータス/指図ステータステーブル

getAllowedBusTractList

public ArrayList getAllowedBusTractList()
使用可能業務トランザクションのテーブルを取得します。

戻り値:
allowedBusTractList 使用可能業務トランザクションのテーブル

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternalOrderGetDetailController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス InternalOrderGetDetailController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController
すべての実装インタフェース:
Serializable
public class InternalOrderGetDetailController
extends Object
implements Serializable

内部指図書詳細コントローラクラス
機能は以下の通り

  • 内部指図書詳細を取得します。

関連項目:
直列化された形式

コンストラクタの概要
InternalOrderGetDetailController()
InternalOrderGetDetailControllerのコンストラクタを生成します。
InternalOrderGetDetailController(SapClient sapClient)
InternalOrderGetDetailControllerのコンストラクタを生成します。
InternalOrderGetDetailController(String orderid, String language)
InternalOrderGetDetailController(String orderid, String language, SapClient sapClient)
メソッドの概要
 void executeBapi()
InternalOrderGetDetailのexecuteBapi()を呼び出し内部指図書詳細を取得します。
 ArrayList getAllowedBusTractList()
使用可能業務トランザクションのテーブルを取得します。
 String getLanguage()
ステータスおよび業務トランザクションテキストの言語を取得します。
 MasterData getMasterData()
指図のマスタデータ構造を取得します。
 String getOrderid()
指図番号を取得します。
 ArrayList getSystemStatusList()
システムステータステーブルを取得します。
 ArrayList getUserStatusList()
ユーザステータス/指図ステータステーブルを取得します。
 void setAllowedBusTractList(ArrayList allowedBusTractList)
使用可能業務トランザクションのテーブルを設定します。
 void setLanguage(String strLanguage)
ステータスおよび業務トランザクションテキストの言語を設定します。
 void setMasterData(MasterData masterData)
指図のマスタデータ構造を設定します。
 void setOrderid(String strOrderid)
指図番号を設定します。
 void setSystemStatusList(ArrayList systemStatusList)
システムステータステーブルを設定します。
 void setUserStatusList(ArrayList userStatusList)
ユーザステータス/指図ステータステーブルを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

InternalOrderGetDetailController

public InternalOrderGetDetailController(String orderid,
                                        String language)
                                 throws SAPAuthAppException,
                                        SAPAuthSystemException,
                                        SAPGeneralAppException,
                                        SAPGeneralSystemException,
                                        SAPFinancialAppException,
                                        SAPFinancialSystemException
パラメータ:
orderid - 指図番号
language - ステータスおよび業務トランザクションテキストの言語
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

InternalOrderGetDetailController

public InternalOrderGetDetailController(String orderid,
                                        String language,
                                        SapClient sapClient)
                                 throws SAPAuthAppException,
                                        SAPAuthSystemException,
                                        SAPGeneralAppException,
                                        SAPGeneralSystemException,
                                        SAPFinancialAppException,
                                        SAPFinancialSystemException
パラメータ:
orderid - 指図番号
language - ステータスおよび業務トランザクションテキストの言語
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

InternalOrderGetDetailController

public InternalOrderGetDetailController()
InternalOrderGetDetailControllerのコンストラクタを生成します。

InternalOrderGetDetailController

public InternalOrderGetDetailController(SapClient sapClient)
InternalOrderGetDetailControllerのコンストラクタを生成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
InternalOrderGetDetailのexecuteBapi()を呼び出し内部指図書詳細を取得します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setOrderid

public void setOrderid(String strOrderid)
指図番号を設定します。

パラメータ:
strOrderid - 指図番号

setLanguage

public void setLanguage(String strLanguage)
ステータスおよび業務トランザクションテキストの言語を設定します。

パラメータ:
strLanguage - ステータスおよび業務トランザクションテキストの言語

setMasterData

public void setMasterData(MasterData masterData)
指図のマスタデータ構造を設定します。

パラメータ:
masterData - 指図のマスタデータ構造

setSystemStatusList

public void setSystemStatusList(ArrayList systemStatusList)
システムステータステーブルを設定します。

パラメータ:
systemStatusList - システムステータステーブル

setUserStatusList

public void setUserStatusList(ArrayList userStatusList)
ユーザステータス/指図ステータステーブルを設定します。

パラメータ:
userStatusList - ユーザステータス/指図ステータステーブル

setAllowedBusTractList

public void setAllowedBusTractList(ArrayList allowedBusTractList)
使用可能業務トランザクションのテーブルを設定します。

パラメータ:
allowedBusTractList - 使用可能業務トランザクションのテーブル

getOrderid

public String getOrderid()
指図番号を取得します。

戻り値:
srtOrderid 指図番号

getLanguage

public String getLanguage()
ステータスおよび業務トランザクションテキストの言語を取得します。

戻り値:
srtLanguage ステータスおよび業務トランザクションテキストの言語

getMasterData

public MasterData getMasterData()
指図のマスタデータ構造を取得します。

戻り値:
masterData 指図のマスタデータ構造

getSystemStatusList

public ArrayList getSystemStatusList()
システムステータステーブルを取得します。

戻り値:
systemStatusList システムステータステーブル

getUserStatusList

public ArrayList getUserStatusList()
ユーザステータス/指図ステータステーブルを取得します。

戻り値:
userStatusList ユーザステータス/指図ステータステーブル

getAllowedBusTractList

public ArrayList getAllowedBusTractList()
使用可能業務トランザクションのテーブルを取得します。

戻り値:
allowedBusTractList 使用可能業務トランザクションのテーブル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternalOrderGetList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス InternalOrderGetList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList
すべての実装インタフェース:
Serializable
public class InternalOrderGetList
extends ReferenceController
implements Serializable

内部指図書（一覧）情報取得クラス
機能は以下の通り

  • 内部指図書（一覧）情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
InternalOrderGetList(SapClient sapClient)
内部指図書（一覧）情報を作成します。
InternalOrderGetList(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
メソッドの概要
void | executeBapi() BapiControllerにより内部指図書（一覧）情報を検索します。
String | getControllingArea() 管理領域を取得します。
String | getOrder() 指図番号 (個別値、または下限値)を取得します。
String | getOrderExternalNo() 外部指図番号 (個別値、または下限値)を取得します。
String | getOrderExternalNoTo() 外部指図番号 (上限値)を取得します。
ArrayList | getOrderListList() 選択指図一覧を取得します。
String | getOrderTo() 指図番号 (上限値)を取得します。
String | getOrderType() 指図タイプを取得します。
String | getRespCostCenter() 責任原価センタを取得します。
void | setControllingArea(String strControllingArea) 管理領域を設定します。
void | setExportParam(BapiController bapiController) 内部指図書（一覧）情報ををセットします。
void | setImportParam(BapiController bapiController) 内部指図書（一覧）情報を検索する条件ををセットします。
void | setOrder(String strOrder) 指図番号 (個別値、または下限値)を設定します。
void | setOrderExternalNo(String strOrderExternalNo) 外部指図番号 (個別値、または下限値)を設定します。
void | setOrderExternalNoTo(String strOrderExternalNoTo) 外部指図番号 (上限値)を設定します。
void | setOrderListList(ArrayList orderListList) 選択指図一覧を設定します。
void | setOrderTo(String strOrderTo) 指図番号 (上限値)を設定します。
void | setOrderType(String strOrderType) 指図タイプを設定します。
void | setRespCostCenter(String strRespCostCenter) 責任原価センタを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

InternalOrderGetList

public InternalOrderGetList(SapClient sapClient)
内部指図書（一覧）情報を作成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト

InternalOrderGetList

public InternalOrderGetList(String controllingArea,
                            String respCostCenter,
                            String orderType,
                            String order,
                            String orderTo,
                            String orderExternalNo,
                            String orderExternalNoTo,
                            SapClient sapClient)
                     throws SAPAuthAppException,
                            SAPAuthSystemException,
                            SAPGeneralAppException,
                            SAPGeneralSystemException,
                            SAPFinancialAppException,
                            SAPFinancialSystemException
パラメータ:
controllingArea - 管理領域
respCostCenter - 責任原価センタ
orderType - 指図タイプ
order - 指図番号 (個別値、または下限値)
orderTo - 指図番号 (上限値)
orderExternalNo - 外部指図番号 (個別値、または下限値)
orderExternalNoTo - 外部指図番号 (上限値)
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
BapiControllerにより内部指図書（一覧）情報を検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計発注業務システム例外

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPFinancialSystemException
内部指図書（一覧）情報を検索する条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPFinancialSystemException - 会計発注業務システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
内部指図書（一覧）情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setControllingArea

public void setControllingArea(String strControllingArea)
管理領域を設定します。

パラメータ:
strControllingArea - 管理領域

setRespCostCenter

public void setRespCostCenter(String strRespCostCenter)
責任原価センタを設定します。

パラメータ:
strRespCostCenter - 責任原価センタ

setOrderType

public void setOrderType(String strOrderType)
指図タイプを設定します。

パラメータ:
strOrderType - 指図タイプ

setOrder

public void setOrder(String strOrder)
指図番号 (個別値、または下限値)を設定します。

パラメータ:
strOrder - 指図番号 (個別値、または下限値)

setOrderTo

public void setOrderTo(String strOrderTo)
指図番号 (上限値)を設定します。

パラメータ:
strOrderTo - 指図番号 (上限値)

setOrderExternalNo

public void setOrderExternalNo(String strOrderExternalNo)
外部指図番号 (個別値、または下限値)を設定します。

パラメータ:
strOrderExternalNo - 外部指図番号 (個別値、または下限値)

setOrderExternalNoTo

public void setOrderExternalNoTo(String strOrderExternalNoTo)
外部指図番号 (上限値)を設定します。

パラメータ:
strOrderExternalNoTo - 外部指図番号 (上限値)

getControllingArea

public String getControllingArea()
管理領域を取得します。

戻り値:
srtControllingArea 管理領域

getRespCostCenter

public String getRespCostCenter()
責任原価センタを取得します。

戻り値:
srtRespCostCenter 責任原価センタ

getOrderType

public String getOrderType()
指図タイプを取得します。

戻り値:
srtOrderType 指図タイプ

getOrder

public String getOrder()
指図番号 (個別値、または下限値)を取得します。

戻り値:
srtOrder 指図番号 (個別値、または下限値)

getOrderTo

public String getOrderTo()
指図番号 (上限値)を取得します。

戻り値:
srtOrderTo 指図番号 (上限値)

getOrderExternalNo

public String getOrderExternalNo()
外部指図番号 (個別値、または下限値)を取得します。

戻り値:
srtOrderExternalNo 外部指図番号 (個別値、または下限値)

getOrderExternalNoTo

public String getOrderExternalNoTo()
外部指図番号 (上限値)を取得します。

戻り値:
srtOrderExternalNoTo 外部指図番号 (上限値)

setOrderListList

public void setOrderListList(ArrayList orderListList)
選択指図一覧を設定します。

パラメータ:
orderListList - 選択指図一覧

getOrderListList

public ArrayList getOrderListList()
選択指図一覧を取得します。

戻り値:
orderListList 選択指図一覧

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternalOrderGetListController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス InternalOrderGetListController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController
すべての実装インタフェース:
Serializable
public class InternalOrderGetListController
extends Object
implements Serializable

内部指図書一覧コントローラクラス
機能は以下の通り

  • 内部指図書一覧を取得します。

関連項目:
直列化された形式

コンストラクタの概要
InternalOrderGetListController()
InternalOrderGetListControllerのコンストラクタを生成します。
InternalOrderGetListController(SapClient sapClient)
InternalOrderGetListControllerのコンストラクタを生成します。
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo)
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
メソッドの概要
 void executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し内部指図書一覧を取得します。
 String getControllingArea()
管理領域を取得します。
 String getOrder()
指図番号 (個別値、または下限値)を取得します。
 String getOrderExternalNo()
外部指図番号 (個別値、または下限値)を取得します。
 String getOrderExternalNoTo()
外部指図番号 (上限値)を取得します。
 ArrayList getOrderListList()
選択指図一覧を取得します。
 String getOrderTo()
指図番号 (上限値)を取得します。
 String getOrderType()
指図タイプを取得します。
 String getRespCostCenter()
責任原価センタを取得します。
 void setControllingArea(String strControllingArea)
管理領域を設定します。
 void setOrder(String strOrder)
指図番号 (個別値、または下限値)を設定します。
 void setOrderExternalNo(String strOrderExternalNo)
外部指図番号 (個別値、または下限値)を設定します。
 void setOrderExternalNoTo(String strOrderExternalNoTo)
外部指図番号 (上限値)を設定します。
 void setOrderListList(ArrayList orderListList)
選択指図一覧を設定します。
 void setOrderTo(String strOrderTo)
指図番号 (上限値)を設定します。
 void setOrderType(String strOrderType)
指図タイプを設定します。
 void setRespCostCenter(String strRespCostCenter)
責任原価センタを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

InternalOrderGetListController

public InternalOrderGetListController(String controllingArea,
                                      String respCostCenter,
                                      String orderType,
                                      String order,
                                      String orderTo,
                                      String orderExternalNo,
                                      String orderExternalNoTo)
                               throws SAPAuthAppException,
                                      SAPAuthSystemException,
                                      SAPGeneralAppException,
                                      SAPGeneralSystemException,
                                      SAPFinancialAppException,
                                      SAPFinancialSystemException
パラメータ:
controllingArea - 管理領域
respCostCenter - 責任原価センタ
orderType - 指図タイプ
order - 指図番号 (個別値、または下限値)
orderTo - 指図番号 (上限値)
orderExternalNo - 外部指図番号 (個別値、または下限値)
orderExternalNoTo - 外部指図番号 (上限値)
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

InternalOrderGetListController

public InternalOrderGetListController(String controllingArea,
                                      String respCostCenter,
                                      String orderType,
                                      String order,
                                      String orderTo,
                                      String orderExternalNo,
                                      String orderExternalNoTo,
                                      SapClient sapClient)
                               throws SAPAuthAppException,
                                      SAPAuthSystemException,
                                      SAPGeneralAppException,
                                      SAPGeneralSystemException,
                                      SAPFinancialAppException,
                                      SAPFinancialSystemException
パラメータ:
controllingArea - 管理領域
respCostCenter - 責任原価センタ
orderType - 指図タイプ
order - 指図番号 (個別値、または下限値)
orderTo - 指図番号 (上限値)
orderExternalNo - 外部指図番号 (個別値、または下限値)
orderExternalNoTo - 外部指図番号 (上限値)
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

InternalOrderGetListController

public InternalOrderGetListController()
InternalOrderGetListControllerのコンストラクタを生成します。

InternalOrderGetListController

public InternalOrderGetListController(SapClient sapClient)
InternalOrderGetListControllerのコンストラクタを生成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
PurchaseOrderPayPostのexecuteBapi()を呼び出し内部指図書一覧を取得します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計系APIアプリケーション例外
SAPFinancialSystemException - 会計系APIシステム例外

setControllingArea

public void setControllingArea(String strControllingArea)
管理領域を設定します。

パラメータ:
strControllingArea - 管理領域

setRespCostCenter

public void setRespCostCenter(String strRespCostCenter)
責任原価センタを設定します。

パラメータ:
strRespCostCenter - 責任原価センタ

setOrderType

public void setOrderType(String strOrderType)
指図タイプを設定します。

パラメータ:
strOrderType - 指図タイプ

setOrder

public void setOrder(String strOrder)
指図番号 (個別値、または下限値)を設定します。

パラメータ:
strOrder - 指図番号 (個別値、または下限値)

setOrderTo

public void setOrderTo(String strOrderTo)
指図番号 (上限値)を設定します。

パラメータ:
strOrderTo - 指図番号 (上限値)

setOrderExternalNo

public void setOrderExternalNo(String strOrderExternalNo)
外部指図番号 (個別値、または下限値)を設定します。

パラメータ:
strOrderExternalNo - 外部指図番号 (個別値、または下限値)

setOrderExternalNoTo

public void setOrderExternalNoTo(String strOrderExternalNoTo)
外部指図番号 (上限値)を設定します。

パラメータ:
strOrderExternalNoTo - 外部指図番号 (上限値)

getControllingArea

public String getControllingArea()
管理領域を取得します。

戻り値:
srtControllingArea 管理領域

getRespCostCenter

public String getRespCostCenter()
責任原価センタを取得します。

戻り値:
srtRespCostCenter 責任原価センタ

getOrderType

public String getOrderType()
指図タイプを取得します。

戻り値:
srtOrderType 指図タイプ

getOrder

public String getOrder()
指図番号 (個別値、または下限値)を取得します。

戻り値:
srtOrder 指図番号 (個別値、または下限値)

getOrderTo

public String getOrderTo()
指図番号 (上限値)を取得します。

戻り値:
srtOrderTo 指図番号 (上限値)

getOrderExternalNo

public String getOrderExternalNo()
外部指図番号 (個別値、または下限値)を取得します。

戻り値:
srtOrderExternalNo 外部指図番号 (個別値、または下限値)

getOrderExternalNoTo

public String getOrderExternalNoTo()
外部指図番号 (上限値)を取得します。

戻り値:
srtOrderExternalNoTo 外部指図番号 (上限値)

setOrderListList

public void setOrderListList(ArrayList orderListList)
選択指図一覧を設定します。

パラメータ:
orderListList - 選択指図一覧

getOrderListList

public ArrayList getOrderListList()
選択指図一覧を取得します。

戻り値:
orderListList 選択指図一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MasterData (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス MasterData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.MasterData
すべての実装インタフェース:
Serializable
public class MasterData
extends Object
implements Serializable

指図のマスタデータ構造情報クラス 機能は以下の通り

  • 指図のマスタデータ構造情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MasterData()
指図のマスタデータ構造を作成します。
メソッドの概要
String | getApplicant() 申請者を取得します。
String | getApplicantPhone() 申請者の電話番号を取得します。
String | getApplicationDate() 申請日を取得します。
String | getBusArea() 事業領域を取得します。
String | getCctrPosted() 原価が実際に転記された原価センタを取得します。
String | getCoArea() 管理領域を取得します。
String | getCompCode() 会社コードを取得します。
String | getCstgSheet() 原価計算表を取得します。
String | getCurrency() 購買発注通貨を取得します。
String | getDateWorkBegins() 作業開始を取得します。
String | getDateWorkEnds() 作業終了を取得します。
String | getDepartment() 部署を取得します。
String | getEstimatedCosts() 指図の見積原価合計を取得します。
String | getExtOrdNo() 外部指図番号を取得します。
String | getFuncArea() 機能領域を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getInterestProf() プロジェクト/指図金利計算の金利プロファイルを取得します。
String | getObjectNo() 対象番号を取得します。
String | getOrder() 指図番号を取得します。
String | getOrderName() テキストを取得します。
String | getOrderType() 販売伝票タイプを取得します。
String | getOverheadKey() 間接費キーを取得します。
String | getPersonResp() 責任者を取得します。
String | getPersonRespPhone() 責任者の電話番号を取得します。
String | getPlant() プラントを取得します。
String | getPlnClose() 計画終了日付を取得します。
String | getPlnCompletion() 計画完了日を取得します。
String | getPlnRelease() 計画リリース日付を取得します。
String | getProcessingGroup() 処理グループを取得します。
String | getProfitCtr() 利益センタを取得します。
String | getRequCompCode() 会社コード要求を取得します。
String | getRequestCctr() 申請原価センタを取得します。
String | getRequestOrder() 申請指図を取得します。
String | getResAnalKey() 結果分析キーを取得します。
String | getRespcctr() 責任原価センタを取得します。
String | getSalesOrd() 受注伝票番号を取得します。
String | getSOrdItem() 受注明細番号を取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getWbsElem() 作業詳細項目要素 (WBS 要素)を取得します。
String | getWbsElementExt() WBS 要素を取得します。
String | getWorkPermit() 仕事許可済フラグを取得します。
void | setApplicant(String strApplicant) 申請者を設定します。
void | setApplicantPhone(String strApplicantPhone) 申請者の電話番号を設定します。
void | setApplicationDate(String strApplicationDate) 申請日を設定します。
void | setBusArea(String strBusArea) 事業領域を設定します。
void | setCctrPosted(String strCctrPosted) 原価が実際に転記された原価センタを設定します。
void | setCoArea(String strCoArea) 管理領域を設定します。
void | setCompCode(String strCompCode) 会社コードを設定します。
void | setCstgSheet(String strCstgSheet) 原価計算表を設定します。
void | setCurrency(String strCurrency) 購買発注通貨を設定します。
void | setDateWorkBegins(String strDateWorkBegins) 作業開始を設定します。
void | setDateWorkEnds(String strDateWorkEnds) 作業終了を設定します。
void | setDepartment(String strDepartment) 部署を設定します。
void | setEstimatedCosts(String strEstimatedCosts) 指図の見積原価合計を設定します。
void | setExtOrdNo(String strExtOrdNo) 外部指図番号を設定します。
void | setFuncArea(String strFuncArea) 機能領域を設定します。
void | setFuncAreaLong(String strFuncAreaLong) 機能領域を設定します。
void | setInterestProf(String strInterestProf) プロジェクト/指図金利計算の金利プロファイルを設定します。
void | setObjectNo(String strObjectNo) 対象番号を設定します。
void | setOrder(String strOrder) 指図番号を設定します。
void | setOrderName(String strOrderName) テキストを設定します。
void | setOrderType(String strOrderType) 販売伝票タイプを設定します。
void | setOverheadKey(String strOverheadKey) 間接費キーを設定します。
void | setPersonResp(String strPersonResp) 責任者を設定します。
void | setPersonRespPhone(String strPersonRespPhone) 責任者の電話番号を設定します。
void | setPlant(String strPlant) プラントを設定します。
void | setPlnClose(String strPlnClose) 計画終了日付を設定します。
void | setPlnCompletion(String strPlnCompletion) 計画完了日を設定します。
void | setPlnRelease(String strPlnRelease) 計画リリース日付を設定します。
void | setProcessingGroup(String strProcessingGroup) 処理グループを設定します。
void | setProfitCtr(String strProfitCtr) 利益センタを設定します。
void | setRequCompCode(String strRequCompCode) 会社コード要求を設定します。
void | setRequestCctr(String strRequestCctr) 申請原価センタを設定します。
void | setRequestOrder(String strRequestOrder) 申請指図を設定します。
void | setResAnalKey(String strResAnalKey) 結果分析キーを設定します。
void | setRespcctr(String strRespcctr) 責任原価センタを設定します。
void | setSalesOrd(String strSalesOrd) 受注伝票番号を設定します。
void | setSOrdItem(String strSOrdItem) 受注明細番号を設定します。
void | setTaxjurcode(String strTaxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setWbsElem(String strWbsElem) 作業詳細項目要素 (WBS 要素)を設定します。
void | setWbsElementExt(String strWbsElementExt) WBS 要素を設定します。
void | setWorkPermit(String strWorkPermit) 仕事許可済フラグを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MasterData

public MasterData()
指図のマスタデータ構造を作成します。

メソッドの詳細

getOrder

public String getOrder()
指図番号を取得します。

戻り値:
srtOrder 指図番号

getOrderType

public String getOrderType()
販売伝票タイプを取得します。

戻り値:
srtOrderType 販売伝票タイプ

getOrderName

public String getOrderName()
テキストを取得します。

戻り値:
srtOrderName テキスト

getExtOrdNo

public String getExtOrdNo()
外部指図番号を取得します。

戻り値:
srtExtOrdNo 外部指図番号

getObjectNo

public String getObjectNo()
対象番号を取得します。

戻り値:
srtObjectNo 対象番号

getCoArea

public String getCoArea()
管理領域を取得します。

戻り値:
srtCoArea 管理領域

getCompCode

public String getCompCode()
会社コードを取得します。

戻り値:
srtCompCode 会社コード

getBusArea

public String getBusArea()
事業領域を取得します。

戻り値:
srtBusArea 事業領域

getPlant

public String getPlant()
プラントを取得します。

戻り値:
srtPlant プラント

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
srtProfitCtr 利益センタ

getRespcctr

public String getRespcctr()
責任原価センタを取得します。

戻り値:
srtRespcctr 責任原価センタ

getWbsElem

public String getWbsElem()
作業詳細項目要素 (WBS 要素)を取得します。

戻り値:
srtWbsElem 作業詳細項目要素 (WBS 要素)

getWbsElementExt

public String getWbsElementExt()
WBS 要素を取得します。

戻り値:
srtWbsElementExt WBS 要素

getRequestCctr

public String getRequestCctr()
申請原価センタを取得します。

戻り値:
srtRequestCctr 申請原価センタ

getRequCompCode

public String getRequCompCode()
会社コード要求を取得します。

戻り値:
srtRequCompCode 会社コード要求

getSalesOrd

public String getSalesOrd()
受注伝票番号を取得します。

戻り値:
srtSalesOrd 受注伝票番号

getSOrdItem

public String getSOrdItem()
受注明細番号を取得します。

戻り値:
srtSOrdItem 受注明細番号

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
srtTaxjurcode 税計算管轄コード - 税管轄コード

getCctrPosted

public String getCctrPosted()
原価が実際に転記された原価センタを取得します。

戻り値:
srtCctrPosted 原価が実際に転記された原価センタ

getCurrency

public String getCurrency()
購買発注通貨を取得します。

戻り値:
srtCurrency 購買発注通貨

getCstgSheet

public String getCstgSheet()
原価計算表を取得します。

戻り値:
srtCstgSheet 原価計算表

getOverheadKey

public String getOverheadKey()
間接費キーを取得します。

戻り値:
srtOverheadKey 間接費キー

getResAnalKey

public String getResAnalKey()
結果分析キーを取得します。

戻り値:
srtResAnalKey 結果分析キー

getInterestProf

public String getInterestProf()
プロジェクト/指図金利計算の金利プロファイルを取得します。

戻り値:
srtInterestProf プロジェクト/指図金利計算の金利プロファイル

getApplicant

public String getApplicant()
申請者を取得します。

戻り値:
srtApplicant 申請者

getApplicantPhone

public String getApplicantPhone()
申請者の電話番号を取得します。

戻り値:
srtApplicantPhone 申請者の電話番号

getPersonResp

public String getPersonResp()
責任者を取得します。

戻り値:
srtPersonResp 責任者

getPersonRespPhone

public String getPersonRespPhone()
責任者の電話番号を取得します。

戻り値:
srtPersonRespPhone 責任者の電話番号

getEstimatedCosts

public String getEstimatedCosts()
指図の見積原価合計を取得します。

戻り値:
srtEstimatedCosts 指図の見積原価合計

getApplicationDate

public String getApplicationDate()
申請日を取得します。

戻り値:
srtApplicationDate 申請日

getDepartment

public String getDepartment()
部署を取得します。

戻り値:
srtDepartment 部署

getDateWorkBegins

public String getDateWorkBegins()
作業開始を取得します。

戻り値:
srtDateWorkBegins 作業開始

getDateWorkEnds

public String getDateWorkEnds()
作業終了を取得します。

戻り値:
srtDateWorkEnds 作業終了

getWorkPermit

public String getWorkPermit()
仕事許可済フラグを取得します。

戻り値:
srtWorkPermit 仕事許可済フラグ

getProcessingGroup

public String getProcessingGroup()
処理グループを取得します。

戻り値:
srtProcessingGroup 処理グループ

getPlnRelease

public String getPlnRelease()
計画リリース日付を取得します。

戻り値:
srtPlnRelease 計画リリース日付

getPlnCompletion

public String getPlnCompletion()
計画完了日を取得します。

戻り値:
srtPlnCompletion 計画完了日

getPlnClose

public String getPlnClose()
計画終了日付を取得します。

戻り値:
srtPlnClose 計画終了日付

getRequestOrder

public String getRequestOrder()
申請指図を取得します。

戻り値:
srtRequestOrder 申請指図

getFuncArea

public String getFuncArea()
機能領域を取得します。

戻り値:
srtFuncArea 機能領域

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
srtFuncAreaLong 機能領域

setOrder

public void setOrder(String strOrder)
指図番号を設定します。

パラメータ:
strOrder - 指図番号

setOrderType

public void setOrderType(String strOrderType)
販売伝票タイプを設定します。

パラメータ:
strOrderType - 販売伝票タイプ

setOrderName

public void setOrderName(String strOrderName)
テキストを設定します。

パラメータ:
strOrderName - テキスト

setExtOrdNo

public void setExtOrdNo(String strExtOrdNo)
外部指図番号を設定します。

パラメータ:
strExtOrdNo - 外部指図番号

setObjectNo

public void setObjectNo(String strObjectNo)
対象番号を設定します。

パラメータ:
strObjectNo - 対象番号

setCoArea

public void setCoArea(String strCoArea)
管理領域を設定します。

パラメータ:
strCoArea - 管理領域

setCompCode

public void setCompCode(String strCompCode)
会社コードを設定します。

パラメータ:
strCompCode - 会社コード

setBusArea

public void setBusArea(String strBusArea)
事業領域を設定します。

パラメータ:
strBusArea - 事業領域

setPlant

public void setPlant(String strPlant)
プラントを設定します。

パラメータ:
strPlant - プラント

setProfitCtr

public void setProfitCtr(String strProfitCtr)
利益センタを設定します。

パラメータ:
strProfitCtr - 利益センタ

setRespcctr

public void setRespcctr(String strRespcctr)
責任原価センタを設定します。

パラメータ:
strRespcctr - 責任原価センタ

setWbsElem

public void setWbsElem(String strWbsElem)
作業詳細項目要素 (WBS 要素)を設定します。

パラメータ:
strWbsElem - 作業詳細項目要素 (WBS 要素)

setWbsElementExt

public void setWbsElementExt(String strWbsElementExt)
WBS 要素を設定します。

パラメータ:
strWbsElementExt - WBS 要素

setRequestCctr

public void setRequestCctr(String strRequestCctr)
申請原価センタを設定します。

パラメータ:
strRequestCctr - 申請原価センタ

setRequCompCode

public void setRequCompCode(String strRequCompCode)
会社コード要求を設定します。

パラメータ:
strRequCompCode - 会社コード要求

setSalesOrd

public void setSalesOrd(String strSalesOrd)
受注伝票番号を設定します。

パラメータ:
strSalesOrd - 受注伝票番号

setSOrdItem

public void setSOrdItem(String strSOrdItem)
受注明細番号を設定します。

パラメータ:
strSOrdItem - 受注明細番号

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税計算管轄コード - 税管轄コード

setCctrPosted

public void setCctrPosted(String strCctrPosted)
原価が実際に転記された原価センタを設定します。

パラメータ:
strCctrPosted - 原価が実際に転記された原価センタ

setCurrency

public void setCurrency(String strCurrency)
購買発注通貨を設定します。

パラメータ:
strCurrency - 購買発注通貨

setCstgSheet

public void setCstgSheet(String strCstgSheet)
原価計算表を設定します。

パラメータ:
strCstgSheet - 原価計算表

setOverheadKey

public void setOverheadKey(String strOverheadKey)
間接費キーを設定します。

パラメータ:
strOverheadKey - 間接費キー

setResAnalKey

public void setResAnalKey(String strResAnalKey)
結果分析キーを設定します。

パラメータ:
strResAnalKey - 結果分析キー

setInterestProf

public void setInterestProf(String strInterestProf)
プロジェクト/指図金利計算の金利プロファイルを設定します。

パラメータ:
strInterestProf - プロジェクト/指図金利計算の金利プロファイル

setApplicant

public void setApplicant(String strApplicant)
申請者を設定します。

パラメータ:
strApplicant - 申請者

setApplicantPhone

public void setApplicantPhone(String strApplicantPhone)
申請者の電話番号を設定します。

パラメータ:
strApplicantPhone - 申請者の電話番号

setPersonResp

public void setPersonResp(String strPersonResp)
責任者を設定します。

パラメータ:
strPersonResp - 責任者

setPersonRespPhone

public void setPersonRespPhone(String strPersonRespPhone)
責任者の電話番号を設定します。

パラメータ:
strPersonRespPhone - 責任者の電話番号

setEstimatedCosts

public void setEstimatedCosts(String strEstimatedCosts)
指図の見積原価合計を設定します。

パラメータ:
strEstimatedCosts - 指図の見積原価合計

setApplicationDate

public void setApplicationDate(String strApplicationDate)
申請日を設定します。

パラメータ:
strApplicationDate - 申請日

setDepartment

public void setDepartment(String strDepartment)
部署を設定します。

パラメータ:
strDepartment - 部署

setDateWorkBegins

public void setDateWorkBegins(String strDateWorkBegins)
作業開始を設定します。

パラメータ:
strDateWorkBegins - 作業開始

setDateWorkEnds

public void setDateWorkEnds(String strDateWorkEnds)
作業終了を設定します。

パラメータ:
strDateWorkEnds - 作業終了

setWorkPermit

public void setWorkPermit(String strWorkPermit)
仕事許可済フラグを設定します。

パラメータ:
strWorkPermit - 仕事許可済フラグ

setProcessingGroup

public void setProcessingGroup(String strProcessingGroup)
処理グループを設定します。

パラメータ:
strProcessingGroup - 処理グループ

setPlnRelease

public void setPlnRelease(String strPlnRelease)
計画リリース日付を設定します。

パラメータ:
strPlnRelease - 計画リリース日付

setPlnCompletion

public void setPlnCompletion(String strPlnCompletion)
計画完了日を設定します。

パラメータ:
strPlnCompletion - 計画完了日

setPlnClose

public void setPlnClose(String strPlnClose)
計画終了日付を設定します。

パラメータ:
strPlnClose - 計画終了日付

setRequestOrder

public void setRequestOrder(String strRequestOrder)
申請指図を設定します。

パラメータ:
strRequestOrder - 申請指図

setFuncArea

public void setFuncArea(String strFuncArea)
機能領域を設定します。

パラメータ:
strFuncArea - 機能領域

setFuncAreaLong

public void setFuncAreaLong(String strFuncAreaLong)
機能領域を設定します。

パラメータ:
strFuncAreaLong - 機能領域

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


OrderList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス OrderList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.OrderList
すべての実装インタフェース:
Serializable
public class OrderList
extends Object
implements Serializable

選択指図一覧情報クラス 機能は以下の通り

  • 選択指図一覧情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
OrderList()
選択指図一覧を作成します。
メソッドの概要
String | getObjectNo() 対象番号を取得します。
String | getOrder() 指図番号を取得します。
String | getOrderName() テキストを取得します。
String | getOrderType() 販売伝票タイプを取得します。
void | setObjectNo(String strObjectNo) 対象番号を設定します。
void | setOrder(String strOrder) 指図番号を設定します。
void | setOrderName(String strOrderName) テキストを設定します。
void | setOrderType(String strOrderType) 販売伝票タイプを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

OrderList

public OrderList()
選択指図一覧を作成します。

メソッドの詳細

getOrder

public String getOrder()
指図番号を取得します。

戻り値:
srtOrder 指図番号

getObjectNo

public String getObjectNo()
対象番号を取得します。

戻り値:
srtObjectNo 対象番号

getOrderType

public String getOrderType()
販売伝票タイプを取得します。

戻り値:
srtOrderType 販売伝票タイプ

getOrderName

public String getOrderName()
テキストを取得します。

戻り値:
srtOrderName テキスト

setOrder

public void setOrder(String strOrder)
指図番号を設定します。

パラメータ:
strOrder - 指図番号

setObjectNo

public void setObjectNo(String strObjectNo)
対象番号を設定します。

パラメータ:
strObjectNo - 対象番号

setOrderType

public void setOrderType(String strOrderType)
販売伝票タイプを設定します。

パラメータ:
strOrderType - 販売伝票タイプ

setOrderName

public void setOrderName(String strOrderName)
テキストを設定します。

パラメータ:
strOrderName - テキスト

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.financial (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.financial
クラス
AllowedBusTract
CommonCenterGrpGetDetail
CostCenterGroupGetDetail
CostCenterGroupGetDetailController
CreditorGetDetail
CreditorGetDetailController
DebtorGetDetail
DebtorGetDetailController
ExchangeRateGetDetail
ExchangeRateGetDetailController
ExchRate
ExpActivity
ExpMessage
ExpWbsElement
ExpWbsHierarchie
ExpWbsMilestone
HierarchyNodes
HierarchyValues
ImpWbsElement
InternalOrderGetDetail
InternalOrderGetDetailController
InternalOrderGetList
InternalOrderGetListController
MasterData
OrderList
ProfitCenterGrpGetDetail
ProfitCenterGrpGetDetailController
ProjectDefinition
ProjectGetInfo
ProjectGetInfoController
SystemStatus
UserStatus


jp.co.intra_mart.foundation.sap.module.financial (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.financial

ＳＡＰ連携管理会計系に関するクラスを提供します。

参照:
説明

クラスの概要
AllowedBusTract | 使用可能業務トランザクションのテーブル情報クラス 機能は以下の通り 使用可能業務トランザクションのテーブル情報を保持します。
CommonCenterGrpGetDetail | 原価・利益センタグループ情報取得共通クラス 機能は以下の通り 原価・利益センタグループ情報を取得します。
CostCenterGroupGetDetail | 原価センタグループ情報取得クラス 機能は以下の通り 原価センタグループ情報を取得します。
CostCenterGroupGetDetailController | 原価センタグループコントローラクラス 機能は以下の通り 原価センタグループを取得します。
CreditorGetDetail | 仕入先詳細情報取得クラス 機能は以下の通り 仕入先詳細情報を取得します。
CreditorGetDetailController | 仕入先詳細コントローラクラス 機能は以下の通り 仕入先詳細を取得します。
DebtorGetDetail | 得意先詳細情報取得クラス 機能は以下の通り 得意先詳細情報を取得します。
DebtorGetDetailController | 得意先詳細コントローラクラス 機能は以下の通り 得意先詳細を取得します。
ExchangeRateGetDetail | 為替換算レート情報取得クラス 機能は以下の通り 為替換算レート情報を取得します。
ExchangeRateGetDetailController | 為替換算レートコントローラクラス 機能は以下の通り 為替換算レートを取得します。
ExchRate | 換算レート、係数 (通貨ペア)情報クラス 機能は以下の通り 換算レート、係数 (通貨ペア)情報を保持します。
ExpActivity | 活動に関する詳細情報クラス 機能は以下の通り 活動に関する詳細情報を保持します。
ExpMessage | 詳細情報を読み込みエラー情報クラス 機能は以下の通り 詳細情報を読み込みエラー情報を保持します。
ExpWbsElement | WBS 要素についての詳細情報クラス 機能は以下の通り WBS 要素についての詳細情報を保持します。
ExpWbsHierarchie | WBS 階層についての情報クラス 機能は以下の通り WBS 階層についての情報を保持します。
ExpWbsMilestone | WBS マイルストーンに関する詳細情報クラス 機能は以下の通り WBS マイルストーンに関する詳細情報を保持します。
HierarchyNodes | 階層ノード情報クラス 機能は以下の通り 階層ノード情報を保持します。
HierarchyValues | 階層値情報クラス 機能は以下の通り 階層値情報を保持します。
ImpWbsElement | 詳細情報を必要とする WBS 要素クラス 機能は以下の通り 詳細情報を必要とする WBS 要素を保持します。
InternalOrderGetDetail | 内部指図書詳細情報取得クラス 機能は以下の通り 内部指図書詳細情報を取得します。
InternalOrderGetDetailController | 内部指図書詳細コントローラクラス 機能は以下の通り 内部指図書詳細を取得します。
InternalOrderGetList | 内部指図書（一覧）情報取得クラス 機能は以下の通り 内部指図書（一覧）情報を取得します。
InternalOrderGetListController | 内部指図書一覧コントローラクラス 機能は以下の通り 内部指図書一覧を取得します。
MasterData | 指図のマスタデータ構造情報クラス 機能は以下の通り 指図のマスタデータ構造情報を保持します。
OrderList | 選択指図一覧情報クラス 機能は以下の通り 選択指図一覧情報を保持します。
ProfitCenterGrpGetDetail | 利益センタグループ情報取得クラス 機能は以下の通り 利益センタグループ情報を取得します。
ProfitCenterGrpGetDetailController | 利益センタグループコントローラクラス 機能は以下の通り 利益センタグループを取得します。
ProjectDefinition | プロジェクトについての詳細情報クラス 機能は以下の通り プロジェクトについての詳細情報を保持します。
ProjectGetInfo | WBS情報取得クラス 機能は以下の通り WBS情報を取得します。
ProjectGetInfoController | WBSの詳細コントローラクラス 機能は以下の通り WBSの詳細を取得します。
SystemStatus | システムステータステーブル情報クラス 機能は以下の通り システムステータステーブル情報を保持します。
UserStatus | ユーザステータス/指図ステータステーブル情報クラス 機能は以下の通り ユーザステータス/指図ステータステーブル情報を保持します。

パッケージ jp.co.intra_mart.foundation.sap.module.financial の説明

ＳＡＰ連携管理会計系に関するクラスを提供します。


jp.co.intra_mart.foundation.sap.module.financial クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.financial の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExchRate (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.MasterData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.OrderList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.UserStatus (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.financial の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.financial の使用

jp.co.intra_mart.foundation.sap.module.financial を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial により使用される jp.co.intra_mart.foundation.sap.module.financial のクラス
CommonCenterGrpGetDetail
原価・利益センタグループ情報取得共通クラス
機能は以下の通り
原価・利益センタグループ情報を取得します。
CreditorGetDetail
仕入先詳細情報取得クラス
機能は以下の通り
仕入先詳細情報を取得します。
DebtorGetDetail
得意先詳細情報取得クラス
機能は以下の通り
得意先詳細情報を取得します。
ExchRate
換算レート、係数 (通貨ペア)情報クラス 機能は以下の通り
換算レート、係数 (通貨ペア)情報を保持します。
MasterData
指図のマスタデータ構造情報クラス 機能は以下の通り
指図のマスタデータ構造情報を保持します。
ProjectDefinition
プロジェクトについての詳細情報クラス 機能は以下の通り
プロジェクトについての詳細情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ProfitCenterGrpGetDetail (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ProfitCenterGrpGetDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail
                拡張 jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail
すべての実装インタフェース:
Serializable
public class ProfitCenterGrpGetDetail
extends CommonCenterGrpGetDetail
implements Serializable

利益センタグループ情報取得クラス
機能は以下の通り

  • 利益センタグループ情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
ProfitCenterGrpGetDetail(SapClient sapClient)
利益センタグループ情報を作成します。
ProfitCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)
メソッドの概要
 void executeBapi()
BapiControllerにより利益センタグループ検索を検索します。
クラス jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail から継承したメソッド
getControllingarea, getGroupname, getHierarchyNodesList, getHierarchyValuesList, setControllingarea, setExportParam, setGroupname, setHierarchyNodesList, setHierarchyValuesList, setImportParam, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProfitCenterGrpGetDetail

public ProfitCenterGrpGetDetail(SapClient sapClient)
利益センタグループ情報を作成します。

パラメータ:
sapClient - SapClient SAPへの接続情報を格納したオブジェクト

ProfitCenterGrpGetDetail

public ProfitCenterGrpGetDetail(String controllingarea,
                                String groupname,
                                SapClient sapClient)
                         throws SAPAuthAppException,
                                SAPAuthSystemException,
                                SAPGeneralAppException,
                                SAPGeneralSystemException,
                                SAPFinancialAppException,
                                SAPFinancialSystemException
パラメータ:
controllingarea - 管理領域
groupname - グループ名
sapClient - SapClient SAPへの接続情報を格納したオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
BapiControllerにより利益センタグループ検索を検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProfitCenterGrpGetDetailController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ProfitCenterGrpGetDetailController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController
すべての実装インタフェース:
Serializable
public class ProfitCenterGrpGetDetailController
extends Object
implements Serializable

利益センタグループコントローラクラス
機能は以下の通り

  • 利益センタグループを取得します。

関連項目:
直列化された形式

コンストラクタの概要
ProfitCenterGrpGetDetailController()
ProfitCenterGrpGetDetailControllerのコンストラクタを生成します。
ProfitCenterGrpGetDetailController(SapClient sapClient)
ProfitCenterGrpGetDetailControllerのコンストラクタを生成します。
ProfitCenterGrpGetDetailController(String controllingarea, String groupname)
ProfitCenterGrpGetDetailController(String controllingarea, String groupname, SapClient sapClient)
メソッドの概要
 void executeBapi()
ProfitCenterGrpGetDetailのexecuteBapi()を呼び出し利益センタグループを取得します。
 String getControllingarea()
管理領域を取得します。
 String getGroupname()
グループ名を取得します。
 ArrayList getHierarchyNodesList()
階層ノード一覧を取得します。
 ArrayList getHierarchyValuesList()
階層値一覧を取得します。
 void setControllingarea(String strControllingarea)
管理領域を設定します。
 void setGroupname(String strGroupname)
グループ名を設定します。
 void setHierarchyNodesList(ArrayList hierarchyNodesList)
階層ノード一覧を設定します。
 void setHierarchyValuesList(ArrayList hierarchyValuesList)
階層値一覧を設定します。
 String toString()
デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProfitCenterGrpGetDetailController

public ProfitCenterGrpGetDetailController(String controllingarea,
                                          String groupname)
                                   throws SAPAuthAppException,
                                          SAPAuthSystemException,
                                          SAPGeneralAppException,
                                          SAPGeneralSystemException,
                                          SAPFinancialAppException,
                                          SAPFinancialSystemException
パラメータ:
controllingarea - 管理領域
groupname - グループ名
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

ProfitCenterGrpGetDetailController

public ProfitCenterGrpGetDetailController(String controllingarea,
                                          String groupname,
                                          SapClient sapClient)
                                   throws SAPAuthAppException,
                                          SAPAuthSystemException,
                                          SAPGeneralAppException,
                                          SAPGeneralSystemException,
                                          SAPFinancialAppException,
                                          SAPFinancialSystemException
パラメータ:
controllingarea - 管理領域
groupname - グループ名
sapClient - SapClient SAPへの接続情報を格納したオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

ProfitCenterGrpGetDetailController

public ProfitCenterGrpGetDetailController()
ProfitCenterGrpGetDetailControllerのコンストラクタを生成します。

ProfitCenterGrpGetDetailController

public ProfitCenterGrpGetDetailController(SapClient sapClient)
ProfitCenterGrpGetDetailControllerのコンストラクタを生成します。

パラメータ:
sapClient - SapClient SAPへの接続情報を格納したオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
ProfitCenterGrpGetDetailのexecuteBapi()を呼び出し利益センタグループを取得します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setControllingarea

public void setControllingarea(String strControllingarea)
管理領域を設定します。

パラメータ:
strControllingarea - 管理領域

setGroupname

public void setGroupname(String strGroupname)
グループ名を設定します。

パラメータ:
strGroupname - グループ名

getControllingarea

public String getControllingarea()
管理領域を取得します。

戻り値:
srtControllingarea 管理領域

getGroupname

public String getGroupname()
グループ名を取得します。

戻り値:
srtGroupname グループ名

setHierarchyNodesList

public void setHierarchyNodesList(ArrayList hierarchyNodesList)
階層ノード一覧を設定します。

パラメータ:
hierarchyNodesList - 階層ノード一覧

setHierarchyValuesList

public void setHierarchyValuesList(ArrayList hierarchyValuesList)
階層値一覧を設定します。

パラメータ:
hierarchyValuesList - 階層値一覧

getHierarchyNodesList

public ArrayList getHierarchyNodesList()
階層ノード一覧を取得します。

戻り値:
hierarchyNodesList 階層ノード一覧

getHierarchyValuesList

public ArrayList getHierarchyValuesList()
階層値一覧を取得します。

戻り値:
hierarchyValuesList 階層値一覧

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProjectDefinition (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ProjectDefinition

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition
すべての実装インタフェース:
Serializable
public class ProjectDefinition
extends Object
implements Serializable

プロジェクトについての詳細情報クラス 機能は以下の通り

  • プロジェクトについての詳細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ProjectDefinition()
プロジェクトについての詳細情報を作成します。
メソッドの概要
String | getApplicantNo() 申請者番号を取得します。
String | getBudgetProfile() 予算プロファイルを取得します。
String | getBusArea() 事業領域を取得します。
String | getCalendar() 稼動日カレンダを取得します。
String | getCompCode() 会社コードを取得します。
String | getControllingArea() 管理領域を取得します。
String | getCshBdgtProfile() 資金計画プロファイルを取得します。
String | getDeletionFlag() 削除フラグを取得します。
String | getDescription() PS: テキスト(短)(第一テキスト行)を取得します。
String | getEquityType() 持分タイプを取得します。
String | getFinish() プロジェクトの計画終了日を取得します。
String | getFuncArea() 機能領域を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getIntProfile() プロジェクト/指図金利計算の金利プロファイルを取得します。
String | getJointVenture() ジョイントベンチャを取得します。
String | getJvJibClass() JIB/JIBE クラスを取得します。
String | getJvJibSubClassA() JIB/JIBE サブクラスAを取得します。
String | getJvObjectType() ジョイントベンチャ対象タイプを取得します。
String | getMaskId() WBS 要素 ID(短)の選択マスクを取得します。
String | getNetworkAssignment() ネットワーク割当を取得します。
String | getNetworkProfile() ネットワークプロファイルを取得します。
String | getObjectclass() 対象クラスを取得します。
String | getObjectclassExt() オブジェクトクラス、言語依存を取得します。
String | getPlanBasic() プロジェクト基準日付計画方法を取得します。
String | getPlanFcst() プロジェクト予測日付の計画方法を取得します。
String | getPlanProfile() 計画プロファイルを取得します。
String | getPlant() プラントを取得します。
String | getProfitCtr() 利益センタを取得します。
String | getProjectCurrency() WBS 通貨(プロジェクト定義)を取得します。
String | getProjectCurrencyIso() ISO 通貨コードを取得します。
String | getProjectDefinition() プロジェクト定義を取得します。
String | getProjectProfile() プロジェクトプロファイルを取得します。
String | getProjectStock() プロジェクト在庫を取得します。
String | getRecoveryInd() リカバリフラグを取得します。
String | getResponsibleNo() 責任者番号 (プロジェクト責任者)を取得します。
String | getStart() プロジェクト計画開始日付を取得します。
String | getStatistical() 統計 WBS 要素を取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getTimeUnit() 時間計画単位を取得します。
String | getTimeUnitIso() 単位の ISO コードを取得します。
String | getWbsSchedProfile() WBS 日程計画のプロファイルを取得します。
void | setApplicantNo(String strApplicantNo) 申請者番号を設定します。
void | setBudgetProfile(String strBudgetProfile) 予算プロファイルを設定します。
void | setBusArea(String strBusArea) 事業領域を設定します。
void | setCalendar(String strCalendar) 稼動日カレンダを設定します。
void | setCompCode(String strCompCode) 会社コードを設定します。
void | setControllingArea(String strControllingArea) 管理領域を設定します。
void | setCshBdgtProfile(String strCshBdgtProfile) 資金計画プロファイルを設定します。
void | setDeletionFlag(String strDeletionFlag) 削除フラグを設定します。
void | setDescription(String strDescription) PS: テキスト(短)(第一テキスト行)を設定します。
void | setEquityType(String strEquityType) 持分タイプを設定します。
void | setFinish(String strFinish) プロジェクトの計画終了日を設定します。
void | setFuncArea(String strFuncArea) 機能領域を設定します。
void | setFuncAreaLong(String strFuncAreaLong) 機能領域を設定します。
void | setIntProfile(String strIntProfile) プロジェクト/指図金利計算の金利プロファイルを設定します。
void | setJointVenture(String strJointVenture) ジョイントベンチャを設定します。
void | setJvJibClass(String strJvJibClass) JIB/JIBE クラスを設定します。
void | setJvJibSubClassA(String strJvJibSubClassA) JIB/JIBE サブクラスAを設定します。
void | setJvObjectType(String strJvObjectType) ジョイントベンチャ対象タイプを設定します。
void | setMaskId(String strMaskId) WBS 要素 ID(短)の選択マスクを設定します。
void | setNetworkAssignment(String strNetworkAssignment) ネットワーク割当を設定します。
void | setNetworkProfile(String strNetworkProfile) ネットワークプロファイルを設定します。
void | setObjectclass(String strObjectclass) 対象クラスを設定します。
void | setObjectclassExt(String strObjectclassExt) オブジェクトクラス、言語依存を設定します。
void | setPlanBasic(String strPlanBasic) プロジェクト基準日付計画方法を設定します。
void | setPlanFcst(String strPlanFcst) プロジェクト予測日付の計画方法を設定します。
void | setPlanProfile(String strPlanProfile) 計画プロファイルを設定します。
void | setPlant(String strPlant) プラントを設定します。
void | setProfitCtr(String strProfitCtr) 利益センタを設定します。
void | setProjectCurrency(String strProjectCurrency) WBS 通貨(プロジェクト定義)を設定します。
void | setProjectCurrencyIso(String strProjectCurrencyIso) ISO 通貨コードを設定します。
void | setProjectDefinition(String strProjectDefinition) プロジェクト定義を設定します。
void | setProjectProfile(String strProjectProfile) プロジェクトプロファイルを設定します。
void | setProjectStock(String strProjectStock) プロジェクト在庫を設定します。
void | setRecoveryInd(String strRecoveryInd) リカバリフラグを設定します。
void | setResponsibleNo(String strResponsibleNo) 責任者番号 (プロジェクト責任者)を設定します。
void | setStart(String strStart) プロジェクト計画開始日付を設定します。
void | setStatistical(String strStatistical) 統計 WBS 要素を設定します。
void | setTaxjurcode(String strTaxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setTimeUnit(String strTimeUnit) 時間計画単位を設定します。
void | setTimeUnitIso(String strTimeUnitIso) 単位の ISO コードを設定します。
void | setWbsSchedProfile(String strWbsSchedProfile) WBS 日程計画のプロファイルを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProjectDefinition

public ProjectDefinition()
プロジェクトについての詳細情報を作成します。

メソッドの詳細

getProjectDefinition

public String getProjectDefinition()
プロジェクト定義を取得します。

戻り値:
srtProjectDefinition プロジェクト定義

getDescription

public String getDescription()
PS: テキスト(短)(第一テキスト行)を取得します。

戻り値:
srtDescription PS: テキスト(短)(第一テキスト行)

getMaskId

public String getMaskId()
WBS 要素 ID(短)の選択マスクを取得します。

戻り値:
srtMaskId WBS 要素 ID(短)の選択マスク

getResponsibleNo

public String getResponsibleNo()
責任者番号 (プロジェクト責任者)を取得します。

戻り値:
srtResponsibleNo 責任者番号 (プロジェクト責任者)

getApplicantNo

public String getApplicantNo()
申請者番号を取得します。

戻り値:
srtApplicantNo 申請者番号

getCompCode

public String getCompCode()
会社コードを取得します。

戻り値:
srtCompCode 会社コード

getBusArea

public String getBusArea()
事業領域を取得します。

戻り値:
srtBusArea 事業領域

getControllingArea

public String getControllingArea()
管理領域を取得します。

戻り値:
srtControllingArea 管理領域

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
srtProfitCtr 利益センタ

getProjectCurrency

public String getProjectCurrency()
WBS 通貨(プロジェクト定義)を取得します。

戻り値:
srtProjectCurrency WBS 通貨(プロジェクト定義)

getProjectCurrencyIso

public String getProjectCurrencyIso()
ISO 通貨コードを取得します。

戻り値:
srtProjectCurrencyIso ISO 通貨コード

getNetworkAssignment

public String getNetworkAssignment()
ネットワーク割当を取得します。

戻り値:
srtNetworkAssignment ネットワーク割当

getStart

public String getStart()
プロジェクト計画開始日付を取得します。

戻り値:
srtStart プロジェクト計画開始日付

getFinish

public String getFinish()
プロジェクトの計画終了日を取得します。

戻り値:
srtFinish プロジェクトの計画終了日

getPlant

public String getPlant()
プラントを取得します。

戻り値:
srtPlant プラント

getCalendar

public String getCalendar()
稼動日カレンダを取得します。

戻り値:
srtCalendar 稼動日カレンダ

getPlanBasic

public String getPlanBasic()
プロジェクト基準日付計画方法を取得します。

戻り値:
srtPlanBasic プロジェクト基準日付計画方法

getPlanFcst

public String getPlanFcst()
プロジェクト予測日付の計画方法を取得します。

戻り値:
srtPlanFcst プロジェクト予測日付の計画方法

getTimeUnit

public String getTimeUnit()
時間計画単位を取得します。

戻り値:
srtTimeUnit 時間計画単位

getTimeUnitIso

public String getTimeUnitIso()
単位の ISO コードを取得します。

戻り値:
srtTimeUnitIso 単位の ISO コード

getNetworkProfile

public String getNetworkProfile()
ネットワークプロファイルを取得します。

戻り値:
srtNetworkProfile ネットワークプロファイル

getProjectProfile

public String getProjectProfile()
プロジェクトプロファイルを取得します。

戻り値:
srtProjectProfile プロジェクトプロファイル

getBudgetProfile

public String getBudgetProfile()
予算プロファイルを取得します。

戻り値:
srtBudgetProfile 予算プロファイル

getProjectStock

public String getProjectStock()
プロジェクト在庫を取得します。

戻り値:
srtProjectStock プロジェクト在庫

getObjectclass

public String getObjectclass()
対象クラスを取得します。

戻り値:
srtObjectclass 対象クラス

getStatistical

public String getStatistical()
統計 WBS 要素を取得します。

戻り値:
srtStatistical 統計 WBS 要素

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
srtTaxjurcode 税計算管轄コード - 税管轄コード

getIntProfile

public String getIntProfile()
プロジェクト/指図金利計算の金利プロファイルを取得します。

戻り値:
srtIntProfile プロジェクト/指図金利計算の金利プロファイル

getWbsSchedProfile

public String getWbsSchedProfile()
WBS 日程計画のプロファイルを取得します。

戻り値:
srtWbsSchedProfile WBS 日程計画のプロファイル

getCshBdgtProfile

public String getCshBdgtProfile()
資金計画プロファイルを取得します。

戻り値:
srtCshBdgtProfile 資金計画プロファイル

getPlanProfile

public String getPlanProfile()
計画プロファイルを取得します。

戻り値:
srtPlanProfile 計画プロファイル

getJointVenture

public String getJointVenture()
ジョイントベンチャを取得します。

戻り値:
srtJointVenture ジョイントベンチャ

getRecoveryInd

public String getRecoveryInd()
リカバリフラグを取得します。

戻り値:
srtRecoveryInd リカバリフラグ

getEquityType

public String getEquityType()
持分タイプを取得します。

戻り値:
srtEquityType 持分タイプ

getJvObjectType

public String getJvObjectType()
ジョイントベンチャ対象タイプを取得します。

戻り値:
srtJvObjectType ジョイントベンチャ対象タイプ

getJvJibClass

public String getJvJibClass()
JIB/JIBE クラスを取得します。

戻り値:
srtJvJibClass JIB/JIBE クラス

getJvJibSubClassA

public String getJvJibSubClassA()
JIB/JIBE サブクラスAを取得します。

戻り値:
srtJvJibSubClassA JIB/JIBE サブクラスA

getDeletionFlag

public String getDeletionFlag()
削除フラグを取得します。

戻り値:
srtDeletionFlag 削除フラグ

getObjectclassExt

public String getObjectclassExt()
オブジェクトクラス、言語依存を取得します。

戻り値:
srtObjectclassExt オブジェクトクラス、言語依存

getFuncArea

public String getFuncArea()
機能領域を取得します。

戻り値:
srtFuncArea 機能領域

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
srtFuncAreaLong 機能領域

setProjectDefinition

public void setProjectDefinition(String strProjectDefinition)
プロジェクト定義を設定します。

パラメータ:
strProjectDefinition - プロジェクト定義

setDescription

public void setDescription(String strDescription)
PS: テキスト(短)(第一テキスト行)を設定します。

パラメータ:
strDescription - PS: テキスト(短)(第一テキスト行)

setMaskId

public void setMaskId(String strMaskId)
WBS 要素 ID(短)の選択マスクを設定します。

パラメータ:
strMaskId - WBS 要素 ID(短)の選択マスク

setResponsibleNo

public void setResponsibleNo(String strResponsibleNo)
責任者番号 (プロジェクト責任者)を設定します。

パラメータ:
strResponsibleNo - 責任者番号 (プロジェクト責任者)

setApplicantNo

public void setApplicantNo(String strApplicantNo)
申請者番号を設定します。

パラメータ:
strApplicantNo - 申請者番号

setCompCode

public void setCompCode(String strCompCode)
会社コードを設定します。

パラメータ:
strCompCode - 会社コード

setBusArea

public void setBusArea(String strBusArea)
事業領域を設定します。

パラメータ:
strBusArea - 事業領域

setControllingArea

public void setControllingArea(String strControllingArea)
管理領域を設定します。

パラメータ:
strControllingArea - 管理領域

setProfitCtr

public void setProfitCtr(String strProfitCtr)
利益センタを設定します。

パラメータ:
strProfitCtr - 利益センタ

setProjectCurrency

public void setProjectCurrency(String strProjectCurrency)
WBS 通貨(プロジェクト定義)を設定します。

パラメータ:
strProjectCurrency - WBS 通貨(プロジェクト定義)

setProjectCurrencyIso

public void setProjectCurrencyIso(String strProjectCurrencyIso)
ISO 通貨コードを設定します。

パラメータ:
strProjectCurrencyIso - ISO 通貨コード

setNetworkAssignment

public void setNetworkAssignment(String strNetworkAssignment)
ネットワーク割当を設定します。

パラメータ:
strNetworkAssignment - ネットワーク割当

setStart

public void setStart(String strStart)
プロジェクト計画開始日付を設定します。

パラメータ:
strStart - プロジェクト計画開始日付

setFinish

public void setFinish(String strFinish)
プロジェクトの計画終了日を設定します。

パラメータ:
strFinish - プロジェクトの計画終了日

setPlant

public void setPlant(String strPlant)
プラントを設定します。

パラメータ:
strPlant - プラント

setCalendar

public void setCalendar(String strCalendar)
稼動日カレンダを設定します。

パラメータ:
strCalendar - 稼動日カレンダ

setPlanBasic

public void setPlanBasic(String strPlanBasic)
プロジェクト基準日付計画方法を設定します。

パラメータ:
strPlanBasic - プロジェクト基準日付計画方法

setPlanFcst

public void setPlanFcst(String strPlanFcst)
プロジェクト予測日付の計画方法を設定します。

パラメータ:
strPlanFcst - プロジェクト予測日付の計画方法

setTimeUnit

public void setTimeUnit(String strTimeUnit)
時間計画単位を設定します。

パラメータ:
strTimeUnit - 時間計画単位

setTimeUnitIso

public void setTimeUnitIso(String strTimeUnitIso)
単位の ISO コードを設定します。

パラメータ:
strTimeUnitIso - 単位の ISO コード

setNetworkProfile

public void setNetworkProfile(String strNetworkProfile)
ネットワークプロファイルを設定します。

パラメータ:
strNetworkProfile - ネットワークプロファイル

setProjectProfile

public void setProjectProfile(String strProjectProfile)
プロジェクトプロファイルを設定します。

パラメータ:
strProjectProfile - プロジェクトプロファイル

setBudgetProfile

public void setBudgetProfile(String strBudgetProfile)
予算プロファイルを設定します。

パラメータ:
strBudgetProfile - 予算プロファイル

setProjectStock

public void setProjectStock(String strProjectStock)
プロジェクト在庫を設定します。

パラメータ:
strProjectStock - プロジェクト在庫

setObjectclass

public void setObjectclass(String strObjectclass)
対象クラスを設定します。

パラメータ:
strObjectclass - 対象クラス

setStatistical

public void setStatistical(String strStatistical)
統計 WBS 要素を設定します。

パラメータ:
strStatistical - 統計 WBS 要素

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税計算管轄コード - 税管轄コード

setIntProfile

public void setIntProfile(String strIntProfile)
プロジェクト/指図金利計算の金利プロファイルを設定します。

パラメータ:
strIntProfile - プロジェクト/指図金利計算の金利プロファイル

setWbsSchedProfile

public void setWbsSchedProfile(String strWbsSchedProfile)
WBS 日程計画のプロファイルを設定します。

パラメータ:
strWbsSchedProfile - WBS 日程計画のプロファイル

setCshBdgtProfile

public void setCshBdgtProfile(String strCshBdgtProfile)
資金計画プロファイルを設定します。

パラメータ:
strCshBdgtProfile - 資金計画プロファイル

setPlanProfile

public void setPlanProfile(String strPlanProfile)
計画プロファイルを設定します。

パラメータ:
strPlanProfile - 計画プロファイル

setJointVenture

public void setJointVenture(String strJointVenture)
ジョイントベンチャを設定します。

パラメータ:
strJointVenture - ジョイントベンチャ

setRecoveryInd

public void setRecoveryInd(String strRecoveryInd)
リカバリフラグを設定します。

パラメータ:
strRecoveryInd - リカバリフラグ

setEquityType

public void setEquityType(String strEquityType)
持分タイプを設定します。

パラメータ:
strEquityType - 持分タイプ

setJvObjectType

public void setJvObjectType(String strJvObjectType)
ジョイントベンチャ対象タイプを設定します。

パラメータ:
strJvObjectType - ジョイントベンチャ対象タイプ

setJvJibClass

public void setJvJibClass(String strJvJibClass)
JIB/JIBE クラスを設定します。

パラメータ:
strJvJibClass - JIB/JIBE クラス

setJvJibSubClassA

public void setJvJibSubClassA(String strJvJibSubClassA)
JIB/JIBE サブクラスAを設定します。

パラメータ:
strJvJibSubClassA - JIB/JIBE サブクラスA

setDeletionFlag

public void setDeletionFlag(String strDeletionFlag)
削除フラグを設定します。

パラメータ:
strDeletionFlag - 削除フラグ

setObjectclassExt

public void setObjectclassExt(String strObjectclassExt)
オブジェクトクラス、言語依存を設定します。

パラメータ:
strObjectclassExt - オブジェクトクラス、言語依存

setFuncArea

public void setFuncArea(String strFuncArea)
機能領域を設定します。

パラメータ:
strFuncArea - 機能領域

setFuncAreaLong

public void setFuncAreaLong(String strFuncAreaLong)
機能領域を設定します。

パラメータ:
strFuncAreaLong - 機能領域

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProjectGetInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ProjectGetInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo
すべての実装インタフェース:
Serializable
public class ProjectGetInfo
extends ReferenceController
implements Serializable

WBS情報取得クラス
機能は以下の通り

  • WBS情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
ProjectGetInfo(SapClient sapClient)
WBS情報を作成します。
メソッドの概要
void | executeBapi() BapiControllerによりWBSの詳細情報の検索します。
ArrayList | getExpActivityList() 活動に関する詳細情報を取得します。
ArrayList | getExpMessageList() 詳細情報を読み込みエラーを取得します。
ArrayList | getExpWbsElementList() WBS 要素についての詳細情報を取得します。
ArrayList | getExpWbsHierarchieList() WBS 階層についての情報を取得します。
ArrayList | getExpWbsMilestoneList() WBS マイルストーンに関する詳細情報を取得します。
ArrayList | getImpWbsElementList() 詳細情報を必要とする WBS 要素を取得します。
String | getProjectDefinition() プロジェクト定義を識別するキーを取得します。
ProjectDefinition | getProjectDefinitionInfo() プロジェクトについての詳細情報を取得します。
String | getWithActivities() 従属活動を取得します。
String | getWithMilestones() 従属 WBS マイルストーンを取得します。
String | getWithSubtree() サブプロジェクトを取得します。
void | setExpActivityList(ArrayList expActivityList) 活動に関する詳細情報を設定します。
void | setExpMessageList(ArrayList expMessageList) 詳細情報を読み込みエラーを設定します。
void | setExportParam(BapiController bapiController) 登録された情報ををセットします。
void | setExpWbsElementList(ArrayList expWbsElementList) WBS 要素についての詳細情報を設定します。
void | setExpWbsHierarchieList(ArrayList expWbsHierarchieList) WBS 階層についての情報を設定します。
void | setExpWbsMilestoneList(ArrayList expWbsMilestoneList) WBS マイルストーンに関する詳細情報を設定します。
void | setImportParam(BapiController bapiController) WEBの詳細情報を検索する条件ををセットします。
void | setImpWbsElementList(ArrayList impWbsElementList) 詳細情報を必要とする WBS 要素を設定します。
void | setProjectDefinition(ProjectDefinition projectDefinition) プロジェクトについての詳細情報を設定します。
void | setProjectDefinition(String strProjectDefinition) プロジェクト定義を識別するキーを設定します。
void | setTblParam(String paramTable, String paramName, String value, int index) テーブル型の項目に値をセットします。
void | setWithActivities(String strWithActivities) 従属活動を設定します。
void | setWithMilestones(String strWithMilestones) 従属 WBS マイルストーンを設定します。
void | setWithSubtree(String strWithSubtree) サブプロジェクトを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProjectGetInfo

public ProjectGetInfo(SapClient sapClient)
WBS情報を作成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
BapiControllerによりWBSの詳細情報の検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPFinancialSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPFinancialSystemException - 会計業務システム例外

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPFinancialSystemException
WEBの詳細情報を検索する条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
登録された情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setProjectDefinition

public void setProjectDefinition(String strProjectDefinition)
プロジェクト定義を識別するキーを設定します。

パラメータ:
strProjectDefinition - プロジェクト定義を識別するキー

setWithActivities

public void setWithActivities(String strWithActivities)
従属活動を設定します。

パラメータ:
strWithActivities - 従属活動がエクスポートされます

setWithMilestones

public void setWithMilestones(String strWithMilestones)
従属 WBS マイルストーンを設定します。

パラメータ:
strWithMilestones - 従属 WBS マイルストーンがエクスポートされます

setWithSubtree

public void setWithSubtree(String strWithSubtree)
サブプロジェクトを設定します。

パラメータ:
strWithSubtree - サブプロジェクトがエクスポートされます

getProjectDefinition

public String getProjectDefinition()
プロジェクト定義を識別するキーを取得します。

戻り値:
srtProjectDefinition プロジェクト定義を識別するキー

getWithActivities

public String getWithActivities()
従属活動を取得します。

戻り値:
srtWith_Activities 従属活動がエクスポートされます

getWithMilestones

public String getWithMilestones()
従属 WBS マイルストーンを取得します。

戻り値:
srtWithMilestones 従属 WBS マイルストーンがエクスポートされます

getWithSubtree

public String getWithSubtree()
サブプロジェクトを取得します。

戻り値:
srtWithSubtree サブプロジェクトがエクスポートされます

setProjectDefinition

public void setProjectDefinition(ProjectDefinition projectDefinition)
プロジェクトについての詳細情報を設定します。

パラメータ:
projectDefinition - プロジェクトについての詳細情報

setImpWbsElementList

public void setImpWbsElementList(ArrayList impWbsElementList)
詳細情報を必要とする WBS 要素を設定します。

パラメータ:
impWbsElementList - 詳細情報を必要とする WBS 要素

setExpWbsElementList

public void setExpWbsElementList(ArrayList expWbsElementList)
WBS 要素についての詳細情報を設定します。

パラメータ:
expWbsElementList - WBS 要素についての詳細情報

setExpWbsMilestoneList

public void setExpWbsMilestoneList(ArrayList expWbsMilestoneList)
WBS マイルストーンに関する詳細情報を設定します。

パラメータ:
expWbsMilestoneList - WBS マイルストーンに関する詳細情報

setExpWbsHierarchieList

public void setExpWbsHierarchieList(ArrayList expWbsHierarchieList)
WBS 階層についての情報を設定します。

パラメータ:
expWbsHierarchieList - WBS 階層についての情報

setExpActivityList

public void setExpActivityList(ArrayList expActivityList)
活動に関する詳細情報を設定します。

パラメータ:
expActivityList - 活動に関する詳細情報

setExpMessageList

public void setExpMessageList(ArrayList expMessageList)
詳細情報を読み込みエラーを設定します。

パラメータ:
expMessageList - 詳細情報を読み込みエラー

getProjectDefinitionInfo

public ProjectDefinition getProjectDefinitionInfo()
プロジェクトについての詳細情報を取得します。

戻り値:
projectDefinition プロジェクトについての詳細情報

getImpWbsElementList

public ArrayList getImpWbsElementList()
詳細情報を必要とする WBS 要素を取得します。

戻り値:
impWbsElementList 詳細情報を必要とする WBS 要素

getExpWbsElementList

public ArrayList getExpWbsElementList()
WBS 要素についての詳細情報を取得します。

戻り値:
expWbsElementList WBS 要素についての詳細情報

getExpWbsMilestoneList

public ArrayList getExpWbsMilestoneList()
WBS マイルストーンに関する詳細情報を取得します。

戻り値:
expWbsMilestoneList WBS マイルストーンに関する詳細情報

getExpWbsHierarchieList

public ArrayList getExpWbsHierarchieList()
WBS 階層についての情報を取得します。

戻り値:
expWbsHierarchieList WBS 階層についての情報

getExpActivityList

public ArrayList getExpActivityList()
活動に関する詳細情報を取得します。

戻り値:
expActivityList 活動に関する詳細情報

getExpMessageList

public ArrayList getExpMessageList()
詳細情報を読み込みエラーを取得します。

戻り値:
expMessageList 詳細情報を読み込みエラー

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProjectGetInfoController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ProjectGetInfoController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController
すべての実装インタフェース:
Serializable
public class ProjectGetInfoController
extends Object
implements Serializable

WBSの詳細コントローラクラス
機能は以下の通り

  • WBSの詳細を取得します。

関連項目:
直列化された形式

コンストラクタの概要
ProjectGetInfoController()
ProjectGetInfoControllerのコンストラクタを生成します。
ProjectGetInfoController(SapClient sapClient)
ProjectGetInfoControllerのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
ProjectGetInfoのexecuteBapi()を呼び出しWBSの詳細を取得します。
 ArrayList getExpActivityList()
活動に関する詳細情報を取得します。
 ArrayList getExpMessageList()
詳細情報を読み込みエラーを取得します。
 ArrayList getExpWbsElementList()
WBS 要素についての詳細情報を取得します。
 ArrayList getExpWbsHierarchieList()
WBS 階層についての情報を取得します。
 ArrayList getExpWbsMilestoneList()
WBS マイルストーンに関する詳細情報を取得します。
 ArrayList getImpWbsElementList()
詳細情報を必要とする WBS 要素を取得します。
 String getProjectDefinition()
プロジェクト定義を識別するキーを取得します。
 ProjectDefinition getProjectDefinitionInfo()
プロジェクトについての詳細情報を取得します。
 String getWithActivities()
従属活動を取得します。
 String getWithMilestones()
従属 WBS マイルストーンを取得します。
 String getWithSubtree()
サブプロジェクトを取得します。
 void setExpActivityList(ArrayList expActivityList)
活動に関する詳細情報を設定します。
 void setExpMessageList(ArrayList expMessageList)
詳細情報を読み込みエラーを設定します。
 void setExpWbsElementList(ArrayList expWbsElementList)
WBS 要素についての詳細情報を設定します。
 void setExpWbsHierarchieList(ArrayList expWbsHierarchieList)
WBS 階層についての情報を設定します。
 void setExpWbsMilestoneList(ArrayList expWbsMilestoneList)
WBS マイルストーンに関する詳細情報を設定します。
 void setImpWbsElementList(ArrayList impWbsElementList)
詳細情報を必要とする WBS 要素を設定します。
 void setProjectDefinition(ProjectDefinition projectDefinition)
プロジェクトについての詳細情報を設定します。
 void setProjectDefinition(String strProjectDefinition)
プロジェクト定義を識別するキーを設定します。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void setWithActivities(String strWithActivities)
従属活動を設定します。
 void setWithMilestones(String strWithMilestones)
従属 WBS マイルストーンを設定します。
 void setWithSubtree(String strWithSubtree)
サブプロジェクトを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ProjectGetInfoController

public ProjectGetInfoController()
ProjectGetInfoControllerのコンストラクタを生成します。

ProjectGetInfoController

public ProjectGetInfoController(SapClient sapClient)
ProjectGetInfoControllerのコンストラクタを生成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
ProjectGetInfoのexecuteBapi()を呼び出しWBSの詳細を取得します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPFinancialSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPFinancialSystemException - 会計業務システム例外

setProjectDefinition

public void setProjectDefinition(String strProjectDefinition)
プロジェクト定義を識別するキーを設定します。

パラメータ:
strProjectDefinition - プロジェクト定義を識別するキー

setWithActivities

public void setWithActivities(String strWithActivities)
従属活動を設定します。

パラメータ:
strWithActivities - 従属活動がエクスポートされます

setWithMilestones

public void setWithMilestones(String strWithMilestones)
従属 WBS マイルストーンを設定します。

パラメータ:
strWithMilestones - 従属 WBS マイルストーンがエクスポートされます

setWithSubtree

public void setWithSubtree(String strWithSubtree)
サブプロジェクトを設定します。

パラメータ:
strWithSubtree - サブプロジェクトがエクスポートされます

getProjectDefinition

public String getProjectDefinition()
                            throws SAPFinancialSystemException
プロジェクト定義を識別するキーを取得します。

戻り値:
srtProjectDefinition プロジェクト定義を識別するキー
例外:
SAPFinancialSystemException - 会計業務システム例外

getWithActivities

public String getWithActivities()
                         throws SAPFinancialSystemException
従属活動を取得します。

戻り値:
srtWith_Activities 従属活動がエクスポートされます
例外:
SAPFinancialSystemException - 会計業務システム例外

getWithMilestones

public String getWithMilestones()
                         throws SAPFinancialSystemException
従属 WBS マイルストーンを取得します。

戻り値:
srtWithMilestones 従属 WBS マイルストーンがエクスポートされます
例外:
SAPFinancialSystemException - 会計業務システム例外

getWithSubtree

public String getWithSubtree()
                      throws SAPFinancialSystemException
サブプロジェクトを取得します。

戻り値:
srtWithSubtree サブプロジェクトがエクスポートされます
例外:
SAPFinancialSystemException - 会計業務システム例外

setProjectDefinition

public void setProjectDefinition(ProjectDefinition projectDefinition)
プロジェクトについての詳細情報を設定します。

パラメータ:
projectDefinition - プロジェクトについての詳細情報

setImpWbsElementList

public void setImpWbsElementList(ArrayList impWbsElementList)
詳細情報を必要とする WBS 要素を設定します。

パラメータ:
impWbsElementList - 詳細情報を必要とする WBS 要素

setExpWbsElementList

public void setExpWbsElementList(ArrayList expWbsElementList)
WBS 要素についての詳細情報を設定します。

パラメータ:
expWbsElementList - WBS 要素についての詳細情報

setExpWbsMilestoneList

public void setExpWbsMilestoneList(ArrayList expWbsMilestoneList)
WBS マイルストーンに関する詳細情報を設定します。

パラメータ:
expWbsMilestoneList - WBS マイルストーンに関する詳細情報

setExpWbsHierarchieList

public void setExpWbsHierarchieList(ArrayList expWbsHierarchieList)
WBS 階層についての情報を設定します。

パラメータ:
expWbsHierarchieList - WBS 階層についての情報

setExpActivityList

public void setExpActivityList(ArrayList expActivityList)
活動に関する詳細情報を設定します。

パラメータ:
expActivityList - 活動に関する詳細情報

setExpMessageList

public void setExpMessageList(ArrayList expMessageList)
詳細情報を読み込みエラーを設定します。

パラメータ:
expMessageList - 詳細情報を読み込みエラー

getProjectDefinitionInfo

public ProjectDefinition getProjectDefinitionInfo()
プロジェクトについての詳細情報を取得します。

戻り値:
projectDefinition プロジェクトについての詳細情報

getImpWbsElementList

public ArrayList getImpWbsElementList()
詳細情報を必要とする WBS 要素を取得します。

戻り値:
impWbsElementList 詳細情報を必要とする WBS 要素

getExpWbsElementList

public ArrayList getExpWbsElementList()
WBS 要素についての詳細情報を取得します。

戻り値:
expWbsElementList WBS 要素についての詳細情報

getExpWbsMilestoneList

public ArrayList getExpWbsMilestoneList()
WBS マイルストーンに関する詳細情報を取得します。

戻り値:
expWbsMilestoneList WBS マイルストーンに関する詳細情報

getExpWbsHierarchieList

public ArrayList getExpWbsHierarchieList()
WBS 階層についての情報を取得します。

戻り値:
expWbsHierarchieList WBS 階層についての情報

getExpActivityList

public ArrayList getExpActivityList()
活動に関する詳細情報を取得します。

戻り値:
expActivityList 活動に関する詳細情報

getExpMessageList

public ArrayList getExpMessageList()
詳細情報を読み込みエラーを取得します。

戻り値:
expMessageList 詳細情報を読み込みエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SystemStatus (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス SystemStatus

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.SystemStatus
すべての実装インタフェース:
Serializable
public class SystemStatus
extends Object
implements Serializable

システムステータステーブル情報クラス 機能は以下の通り

  • システムステータステーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
SystemStatus()
システムステータステーブルを作成します。
メソッドの概要
String | getSysStatus() システムステータスを取得します。
String | getSyStDscr() オブジェクトステータスを取得します。
String | getSyStText() オブジェクトの個別ステータス (簡略形式)を取得します。
void | setSysStatus(String strSysStatus) システムステータスを設定します。
void | setSyStDscr(String strSyStDscr) オブジェクトステータスを設定します。
void | setSyStText(String strSyStText) オブジェクトの個別ステータス (簡略形式)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SystemStatus

public SystemStatus()
システムステータステーブルを作成します。

メソッドの詳細

getSysStatus

public String getSysStatus()
システムステータスを取得します。

戻り値:
srtSysStatus システムステータス

getSyStText

public String getSyStText()
オブジェクトの個別ステータス (簡略形式)を取得します。

戻り値:
srtSyStText オブジェクトの個別ステータス (簡略形式)

getSyStDscr

public String getSyStDscr()
オブジェクトステータスを取得します。

戻り値:
srtSyStDscr オブジェクトステータス

setSysStatus

public void setSysStatus(String strSysStatus)
システムステータスを設定します。

パラメータ:
strSysStatus - システムステータス

setSyStText

public void setSyStText(String strSyStText)
オブジェクトの個別ステータス (簡略形式)を設定します。

パラメータ:
strSyStText - オブジェクトの個別ステータス (簡略形式)

setSyStDscr

public void setSyStDscr(String strSyStDscr)
オブジェクトステータスを設定します。

パラメータ:
strSyStDscr - オブジェクトステータス

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserStatus (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス UserStatus

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.UserStatus
すべての実装インタフェース:
Serializable
public class UserStatus
extends Object
implements Serializable

ユーザステータス/指図ステータステーブル情報クラス 機能は以下の通り

  • ユーザステータス/指図ステータステーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
UserStatus()
ユーザステータス/指図ステータステーブルを作成します。
メソッドの概要
String | getStatProf() ステータスプロファイルを取得します。
String | getUsrStatus() ユーザステータスを取得します。
String | getUsStDscr() オブジェクトステータスを取得します。
String | getUsStNumb() ステータス番号を取得します。
String | getUsStText() オブジェクトの個別ステータス (簡略形式)を取得します。
void | setStatProf(String strStatProf) ステータスプロファイルを設定します。
void | setUsrStatus(String strUsrStatus) ユーザステータスを設定します。
void | setUsStDscr(String strUsStDscr) オブジェクトステータスを設定します。
void | setUsStNumb(String strUsStNumb) ステータス番号を設定します。
void | setUsStText(String strUsStText) オブジェクトの個別ステータス (簡略形式)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UserStatus

public UserStatus()
ユーザステータス/指図ステータステーブルを作成します。

メソッドの詳細

getStatProf

public String getStatProf()
ステータスプロファイルを取得します。

戻り値:
srtStatProf ステータスプロファイル

getUsrStatus

public String getUsrStatus()
ユーザステータスを取得します。

戻り値:
srtUsrStatus ユーザステータス

getUsStNumb

public String getUsStNumb()
ステータス番号を取得します。

戻り値:
srtUsStNumb ステータス番号

getUsStText

public String getUsStText()
オブジェクトの個別ステータス (簡略形式)を取得します。

戻り値:
srtUsStText オブジェクトの個別ステータス (簡略形式)

getUsStDscr

public String getUsStDscr()
オブジェクトステータスを取得します。

戻り値:
srtUsStDscr オブジェクトステータス

setStatProf

public void setStatProf(String strStatProf)
ステータスプロファイルを設定します。

パラメータ:
strStatProf - ステータスプロファイル

setUsrStatus

public void setUsrStatus(String strUsrStatus)
ユーザステータスを設定します。

パラメータ:
strUsrStatus - ユーザステータス

setUsStNumb

public void setUsStNumb(String strUsStNumb)
ステータス番号を設定します。

パラメータ:
strUsStNumb - ステータス番号

setUsStText

public void setUsStText(String strUsStText)
オブジェクトの個別ステータス (簡略形式)を設定します。

パラメータ:
strUsStText - オブジェクトの個別ステータス (簡略形式)

setUsStDscr

public void setUsStDscr(String strUsStDscr)
オブジェクトステータスを設定します。

パラメータ:
strUsStDscr - オブジェクトステータス

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.purchase.AllVersions の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.AllVersions の使用

jp.co.intra_mart.foundation.sap.module.purchase.AllVersions はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.Cond の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.Cond の使用

jp.co.intra_mart.foundation.sap.module.purchase.Cond はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits の使用

jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ContractService の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ContractService の使用

jp.co.intra_mart.foundation.sap.module.purchase.ContractService はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount の使用

jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText の使用

jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress の使用

jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection の使用

jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader の使用

ExportHeader を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での ExportHeader の使用

ExportHeader を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 ExportHeader PurchaseOrderPayPost.getExportHeader()
貿易管理ヘッダを取得します｡

ExportHeader 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase のメソッド
void | PurchaseOrderPayPost.setExportHeader(ExportHeader exportHeader) 貿易管理ヘッダを設定します｡
static void | ParamExportHeader.setImportParam(BapiController bapiController, ExportHeader exportHeader) 貿易管理ヘッダに値をセットします。
static void | ParamExportHeader.setExportParam(BapiController bapiController, ExportHeader exportHeader) 貿易管理ヘッダに値をセットします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ExportItem の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ExportItem の使用

jp.co.intra_mart.foundation.sap.module.purchase.ExportItem はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.Extension の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.Extension の使用

jp.co.intra_mart.foundation.sap.module.purchase.Extension はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController の使用

jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController の使用

jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.Limits の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.Limits の使用

jp.co.intra_mart.foundation.sap.module.purchase.Limits はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb の使用

jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController の使用

jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController の使用

jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList の使用

MaterialGetList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での MaterialGetList の使用

jp.co.intra_mart.foundation.sap.module.purchase での MaterialGetList のサブクラス
 class MaterialGetListController
品目コード検索コントローラクラス
機能は以下の通り
品目コード、テキストを検索します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController の使用

jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController の使用

jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel の使用

jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.MatnrList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.MatnrList の使用

jp.co.intra_mart.foundation.sap.module.purchase.MatnrList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection の使用

jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamItem の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamItem の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamItem はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamVendorAddress の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamVendorAddress の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamVendorAddress はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.Partner の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.Partner の使用

jp.co.intra_mart.foundation.sap.module.purchase.Partner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection の使用

jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment の使用

jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel の使用

PurchaseGetItemSrel を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseGetItemSrel の使用

PurchaseGetItemSrel を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 PurchaseGetItemSrel PurchaseGetItemSrelController.getPurchaseGetItemSrel()
承認対象一覧情報を取得します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader の使用

PurchaseHeader を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseHeader の使用

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseHeader のサブクラス
class | PurchaseHeaderPost 購買発注伝票ヘッダ情報クラス 機能は以下の通り 購買発注伝票ヘッダの情報を保持します。
class | PurchaseHeaders 伝票の承認対象一覧ヘッダ情報クラス 機能は以下の通り 伝票の承認対象一覧ヘッダの情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost の使用

PurchaseHeaderPost を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseHeaderPost の使用

PurchaseHeaderPost を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 PurchaseHeaderPost PurchaseOrderPayPost.getDocumentHeader()
伝票ヘッダを取得します｡

PurchaseHeaderPost 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase のメソッド
void | PurchaseOrderPayPost.setDocumentHeader(PurchaseHeaderPost documentHeader) 伝票ヘッダを設定します｡
static void | ParamHeader.setImportParam(BapiController bapiController, PurchaseHeaderPost documentHeader) 伝票ヘッダに値をセットします。
static void | ParamHeader.setExportParam(BapiController bapiController, PurchaseHeaderPost documentHeader) 伝票ヘッダに値をセットします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem の使用

PurchaseItem を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseItem の使用

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseItem のサブクラス
class | PurchaseItemPost 購買発注伝票明細情報クラス 機能は以下の通り 購買発注伝票明細情報を保持します。
class | PurchaseItems 伝票の承認対象明細情報クラス 機能は以下の通り 伝票の承認対象明細情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost の使用

PurchaseOrderPayPost を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseOrderPayPost の使用

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseOrderPayPost のサブクラス
class | PurchaseOrderPayPostController 伝票登録コントローラクラス 機能は以下の通り 伝票を登録します。
class | PurchaseOrderPostChangeController 伝票登録変更コントローラクラス 機能は以下の通り 伝票を変更します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease の使用

PurchaseRelease を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseRelease の使用

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseRelease のサブクラス
class | PurchaseReleaseController 伝票承認コントローラクラス 機能は以下の通り 伝票を承認します。
class | PurchaseResetReleaseController 伝票承認取消コントローラクラス 機能は以下の通り 伝票の承認取消します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText の使用

PurchaseText を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseText の使用

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseText のサブクラス
 class ContractServiceText
外注サービステキスト情報クラス
機能は以下の通り
外注サービステキスト情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection の使用

jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.Selection の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.Selection の使用

Selection を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での Selection の使用

jp.co.intra_mart.foundation.sap.module.purchase での Selection のサブクラス
class | DistributionChannelSelection 流通チャネルの選択オプションクラス 機能は以下の通り 流通チャネルの選択オプションの情報を保持します。
class | MaterialShortDescsel 品目テキストの選択オプションクラス 機能は以下の通り 品目テキストの選択オプションの情報を保持します。
class | MatnrSelection 品目コードの選択オプションクラス 機能は以下の通り 品目コードの選択オプションの情報を保持します。
class | PlantSelection プラントの選択オプションクラス 機能は以下の通り プラントの選択オプションの情報を保持します。
class | SalesOrganisationSelection 販売組織の選択オプションクラス 機能は以下の通り 販売組織の選択オプションの情報を保持します。
class | StorageLocationSelect 保管場所の選択オプションクラス 機能は以下の通り 保管場所の選択オプションの情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController の使用

jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect の使用

jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail の使用

SupplierDetail を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での SupplierDetail の使用

SupplierDetail を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 SupplierDetail SupplierGetDetailController.getSupplierDetail()
仕入先マスタ詳細情報を取得します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck の使用

SupplierExistenceCheck を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での SupplierExistenceCheck の使用

SupplierExistenceCheck を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 SupplierExistenceCheck SupplierExistenceCheckController.getSupplierExistenceCheck()
仕入先コードチェック情報を取得します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController の使用

jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController の使用

jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress の使用

VendorAddress を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での VendorAddress の使用

VendorAddress を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 VendorAddress PurchaseOrderPayPost.getSupplierInfo()
仕入先住所を取得します｡

VendorAddress 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 void PurchaseOrderPayPost.setSupplierInfo(VendorAddress supplierInfo)
仕入先住所を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.Versions の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.Versions の使用

Versions を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での Versions の使用

Versions を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 Versions PurchaseOrderPayPost.getVersions()
バージョン管理を取得します｡

Versions 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase のメソッド
void | PurchaseOrderPayPost.setVersions(Versions versions) バージョン管理ヘッダを設定します｡
static void | ParamVersions.setImportParam(BapiController bapiController, Versions versions) バージョン管理に値をセットします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData の使用

ClientData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での ClientData の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での ClientData のサブクラス
 class ClientDataList
品目データ (クライアントレベル)情報クラス
機能は以下の通り
品目データ (クライアントレベル)情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での ClientData の使用

ClientData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 ClientData MaterialGetAll.getClientData()
品目データ (クライアントレベル)を取得します。

ClientData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setClientData(ClientData clientData)
品目データ (クライアントレベル)を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList の使用

ClientDataList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での ClientDataList の使用

ClientDataList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 ClientDataList MaterialSaveReplicaController.getClientDataList(int index)
品目データ (クライアントレベル)が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters の使用

ForecastParameters を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での ForecastParameters の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での ForecastParameters のサブクラス
 class ForecastParametersList
需要予測パラメータ情報クラス
機能は以下の通り
需要予測パラメータ情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での ForecastParameters の使用

ForecastParameters を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 ForecastParameters MaterialGetAll.getForecastParameters()
予測パラメータを取得します。

ForecastParameters 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setForecastParameters(ForecastParameters forecastParameters)
予測パラメータを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList の使用

ForecastParametersList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での ForecastParametersList の使用

ForecastParametersList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 ForecastParametersList MaterialSaveReplicaController.getForecastParametersList(int index)
需要予測パラメータが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader の使用

GoodsMvtHeader を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate

jp.co.intra_mart.foundation.sap.module.purchase.common.model での GoodsMvtHeader の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での GoodsMvtHeader のサブクラス
 class GoodsMvtHeaderList
入出庫伝票明細情報クラス
機能は以下の通り
入出庫伝票明細情報を保持します。

GoodsMvtHeader 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.common.model のメソッド
static void ParamGoodsMvtHeader.setImportParam(BapiController bapiController, GoodsMvtHeader goodsMvtHeader)
入出庫伝票ヘッダデータに値をセットします。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での GoodsMvtHeader の使用

GoodsMvtHeader を返す jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のメソッド
 GoodsMvtHeader GoodsMvtCreate.getGoodsMvtHeader()
入出庫伝票ヘッダデータを取得します。

GoodsMvtHeader 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のメソッド
 void GoodsMvtCreate.setGoodsMvtHeader(GoodsMvtHeader goodsMvtHeader)
入出庫伝票ヘッダデータを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription の使用

MaterialDescription を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での MaterialDescription の使用

MaterialDescription を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
MaterialDescription | MaterialSaveReplicaController.getMaterialDescription(int index) 品目テキストが既に存在するかチェックします。
MaterialDescription | MaterialGetAllController.getMaterialDescription(int index) 品目テキストオブジェクトが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData の使用

PlanningData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での PlanningData の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での PlanningData のサブクラス
 class PlanningDataList
品目マスタ/製品グループの変更伝票構造情報クラス
機能は以下の通り
品目マスタ/製品グループの変更伝票構造情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での PlanningData の使用

PlanningData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 PlanningData MaterialGetAll.getPlanningData()
品目マスタ/製品グループの変更伝票構造を取得します。

PlanningData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setPlanningData(PlanningData planningData)
品目マスタ/製品グループの変更伝票構造を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList の使用

PlanningDataList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PlanningDataList の使用

PlanningDataList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 PlanningDataList MaterialSaveReplicaController.getPlanningDataList(int index)
品目マスタ/製品グループの変更伝票構造が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData の使用

PlantData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での PlantData の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での PlantData のサブクラス
 class PlantDataList
品目データ (プラントレベル)情報クラス
機能は以下の通り
品目データ (プラントレベル)情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での PlantData の使用

PlantData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 PlantData MaterialGetAll.getPlantData()
品目データ (プラントレベル)を取得します。

PlantData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setPlantData(PlantData plantData)
品目データ (プラントレベル)を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList の使用

PlantDataList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PlantDataList の使用

PlantDataList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 PlantDataList MaterialSaveReplicaController.getPlantDataList(int index)
品目データ (プラントレベル)が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData の使用

SalesData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での SalesData の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での SalesData のサブクラス
 class SalesDataList
販売データ情報クラス
機能は以下の通り
販売データ情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での SalesData の使用

SalesData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 SalesData MaterialGetAll.getSalesData()
販売データを取得します。

SalesData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setSalesData(SalesData salesData)
販売データを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList の使用

SalesDataList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での SalesDataList の使用

SalesDataList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 SalesDataList MaterialSaveReplicaController.getSalesDataList(int index)
販売データが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData の使用

StorageLocationData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での StorageLocationData の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での StorageLocationData のサブクラス
 class StorageLocationDataList
品目データ (保管場所レベル)情報クラス
機能は以下の通り
品目データ (保管場所レベル)情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での StorageLocationData の使用

StorageLocationData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 StorageLocationData MaterialGetAll.getStorageLocationData()
品目データ (保管場所レベル)を取得します。

StorageLocationData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setStorageLocationData(StorageLocationData storageLocationData)
品目データ (保管場所レベル)を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList の使用

StorageLocationDataList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での StorageLocationDataList の使用

StorageLocationDataList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 StorageLocationDataList MaterialSaveReplicaController.getStorageLocationDataList(int index)
品目データ (保管場所レベル)が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData の使用

StorageTypeData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での StorageTypeData の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での StorageTypeData のサブクラス
 class StorageTypeDataList
保管域タイプデータ情報クラス
機能は以下の通り
保管域タイプデータ情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での StorageTypeData の使用

StorageTypeData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 StorageTypeData MaterialGetAll.getStorageTypeData()
保管域タイプデータを取得します。

StorageTypeData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setStorageTypeData(StorageTypeData storageTypeData)
保管域タイプデータを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList の使用

StorageTypeDataList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での StorageTypeDataList の使用

StorageTypeDataList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 StorageTypeDataList MaterialSaveReplicaController.getStorageTypeDataList(int index)
保管域タイプデータが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications の使用

TaxClassifications を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での TaxClassifications の使用

TaxClassifications を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
TaxClassifications | MaterialSaveReplicaController.getTaxClassifications(int index) 制御デ－タが既に存在するかチェックします。
TaxClassifications | MaterialGetAllController.getTaxClassifications(int index) 制御デ－タオブジェクトが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure の使用

UnitSofmeasure を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での UnitSofmeasure の使用

UnitSofmeasure を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
UnitSofmeasure | MaterialSaveReplicaController.getUnitSofmeasure(int index) 数量単位が既に存在するかチェックします。
UnitSofmeasure | MaterialGetAllController.getUnitSofmeasure(int index) 数量単位オブジェクトが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData の使用

ValuationData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での ValuationData の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での ValuationData のサブクラス
 class ValuationDataList
評価データ情報クラス
機能は以下の通り
評価データ情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での ValuationData の使用

ValuationData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 ValuationData MaterialGetAll.getValuationData()
評価データを取得します。

ValuationData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setValuationData(ValuationData valuationData)
評価データを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList の使用

ValuationDataList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での ValuationDataList の使用

ValuationDataList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 ValuationDataList MaterialSaveReplicaController.getValuationDataList(int index)
評価データが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData の使用

WarehouseNumberData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での WarehouseNumberData の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での WarehouseNumberData のサブクラス
 class WarehouseNumberDataList
倉庫番号データ情報クラス
機能は以下の通り
倉庫番号データ情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での WarehouseNumberData の使用

WarehouseNumberData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 WarehouseNumberData MaterialGetAll.getWarehouseNumberData()
倉庫番号データを取得します。

WarehouseNumberData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setWarehouseNumberData(WarehouseNumberData warehouseNumberData)
倉庫番号データを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList の使用

WarehouseNumberDataList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での WarehouseNumberDataList の使用

WarehouseNumberDataList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 WarehouseNumberDataList MaterialSaveReplicaController.getWarehouseNumberDataList(int index)
倉庫番号データが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ClientData (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ClientData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ClientDataList
public class ClientData
extends Object
implements Serializable

品目データ (クライアントレベル)情報クラス
機能は以下の通り

  • 品目データ (クライアントレベル)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ClientData()
品目データ (クライアントレベル)情報を作成します。
メソッドの概要
String | getAllowedWt() 許容梱包重量を取得します。
String | getAllwdVol() 許容梱包容積を取得します。
String | getAppdBRec() 区分: バッチ製造記録の承認必須を取得します。
String | getAuthoritygroup() 権限グループを取得します。
String | getBaseUom() 基本数量単位を取得します。
String | getBaseUomIso() ISO コードでの基本数量単位を取得します。
String | getBasicMatl() 主構成物質を取得します。
String | getBatchMgmt() ロット管理所要量区分を取得します。
String | getCadId() CAD 区分を取得します。
String | getCatprofile() カタログプロファイルを取得します。
String | getChangedBy() オブジェクトの変更者名を取得します。
String | getClosedBox() 完了した梱包材を取得します。
String | getCmRelevanceFlag() 構成管理関連を取得します。
String | getCompetitor() 競合会社を取得します。
String | getConfigured() 選定可能品目を取得します。
String | getConfMatl() プラント共通選定可能品目を取得します。
String | getContainer() 容器条件を取得します。
String | getCoProduct() 区分: 連産品としても使用可能な品目を取得します。
String | getCreatedBy() オブジェクト登録者名を取得します。
String | getCreatedOn() 登録日付を取得します。
String | getDelFlag() クライアントレベルでの品目削除フラグを取得します。
String | getDivision() 製品部門を取得します。
String | getDocChgNo() 文書変更番号 (文書管理システム外)を取得します。
String | getDocFormat() 文書のページ書式 (文書管理システムによらない)を取得します。
String | getDocType() 文書タイプ (文書管理システムによらない)を取得します。
String | getDocument() 文書番号 (文書管理システムによらない)を取得します。
String | getDocVers() 文書バージョン (文書管理システムによらない)を取得します。
String | getDsnOffice() 研究室/設計室を取得します。
String | getEnvtRlvt() 区分: 環境関連を取得します。
String | getExtmatlgrp() 外部品目グループを取得します。
String | getFillLevel() 最大レベル (容積別)を取得します。
String | getFunction() BAPI 機能を取得します。
String | getGtinVariant() グローバルトレード明細番号バリアントを取得します。
String | getHazMatNo() 危険物コードを取得します。
String | getHazMatNoExternal() 項目 HAZ_MAT_NO の品目コード (長) (今後のリリースで開発)を取得します。
String | getHazMatNoGuid() 項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)を取得します。
String | getHazMatNoVersion() 項目 HAZ_MAT_NO のバージョン番号 (今後のリリースで開発)を取得します。
String | getHazmatprof() 危険物インジケータプロファイルを取得します。
String | getHighVisc() 区分: 高粘性を取得します。
String | getIndSector() 産業コードを取得します。
String | getInvMatNo() 会社固有 (内部) 在庫管理品目コードを取得します。
String | getInvMatNoExternal() 項目 INV_MAT_NO の品目コード (長) (今後のリリースで開発)を取得します。
String | getInvMatNoGuid() 項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)を取得します。
String | getInvMatNoVersion() 項目 INV_MAT_NO のバージョン番号 (今後のリリースで開発)を取得します。
String | getItemCat() 一般明細カテゴリグループを取得します。
String | getLabelForm() ラベル書式を取得します。
String | getLabelType() ラベルタイプを取得します。
String | getLastChnge() 最終変更日付を取得します。
String | getLooseorliq() 区分: バルク/液体を取得します。
String | getMaintStat() 更新ステータスを取得します。
String | getManufProf() 製造者製品プロファイルを取得します。
String | getManuMat() 製造者製品コードを取得します。
String | getMatcmpllvl() 品目完了レベルを取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialFixed() ロックされている品目を取得します。
String | getMatGrpSm() 品目グループ: 梱包材を取得します。
String | getMatlGroup() 品目グループを取得します。
String | getMatlType() 品目タイプを取得します。
String | getMatStatus() 品目更新完了ステータスを取得します。
String | getMfrNo() 製造者番号を取得します。
String | getMinremlife() 最低有効期間残を取得します。
String | getNetWeight() 正味重量を取得します。
String | getNoSheets() 文書枚数 (文書管理システムによらない)を取得します。
String | getOldMatNo() 旧品目コードを取得します。
String | getPackVoUn() 容積単位 (許容梱包容積)を取得します。
String | getPackVoUnIso() ISO コードでの容積単位 (許容梱包容積)を取得します。
String | getPackWtUn() 重量単位 (許容梱包重量)を取得します。
String | getPackWtUnIso() ISO コードでの重量単位 (許容梱包重量)を取得します。
String | getPageformat() 製造メモのページ書式を取得します。
String | getPageNo() 文書ページ番号 (文書管理システムによらない)を取得します。
String | getParEff() 有効性パラメータへの値割当/変更番号よりも優先を取得します。
String | getPeriodIndExpirationDate() 有効期間期限日の期間区分を取得します。
String | getPlRefMat() 梱包方法が同じ品目の参照品目を取得します。
String | getPoUnit() 発注単位を取得します。
String | getPoUnitIso() ISO コードによる発注単位を取得します。
String | getProcRule() 調達規則を取得します。
String | getProdAlloc() 製品割当決定手順を取得します。
String | getProdCompositionOnPackaging() 区分: 梱包材にプリントされた生産構造を取得します。
String | getProdHier() 品目階層を取得します。
String | getProdMemo() 製造/検査メモを取得します。
String | getPrRefMat() 価格設定参照品目を取得します。
String | getPurStatus() プラント共通品目ステータスを取得します。
String | getPurValkey() 購買許容値キーを取得します。
String | getPvalidfrom() プラント共通品目のステータス有効開始日付を取得します。
String | getQmProcmnt() 調達における品質管理有効を取得します。
String | getQtyGrGi() 数量: 印刷予定入出庫票数を取得します。
String | getQualDik() 無償納入による割引対象品目を取得します。
String | getRoundUpRuleExpirationDate() 有効期間期限日計算の丸め規則を取得します。
String | getSalStatus() 流通チェーン間品目ステータスを取得します。
String | getSeason() 季節カテゴリを取得します。
String | getSerializationLevel() シリアル番号の指定レベルを取得します。
String | getShelfLife() 総有効期間を取得します。
String | getShMatTyp() 梱包材タイプを取得します。
String | getSizeDim() サイズ/寸法を取得します。
String | getSledBbd() 有効期限を取得します。
String | getStackFact() 山積係数を取得します。
String | getStdDescr() 標準テキスト (ANSI、ISO など)を取得します。
String | getStorConds() 保管条件を取得します。
String | getStorPct() 残存有効期間割合 %を取得します。
String | getSupSource() 供給元を取得します。
String | getSvalidfrom() 流通チェーン間品目ステータスの有効開始日付を取得します。
String | getTempConds() 温度条件区分を取得します。
String | getTransGrp() 輸送グループを取得します。
String | getUnitOfWt() 重量単位を取得します。
String | getUnitOfWtIso() ISO コードでの重量単位を取得します。
String | getUomusage() 使用数量単位を取得します。
String | getVarOrdUn() 可変購買発注単位有効を取得します。
String | getVolTolLt() 荷役単位の容積超過許容量を取得します。
String | getWtTolLt() 荷役単位の重量超過許容量を取得します。
void | setAllowedWt(String allowedWt) 許容梱包重量を設定します。
void | setAllwdVol(String allwdVol) 許容梱包容積を設定します。
void | setAppdBRec(String appdBRec) 区分: バッチ製造記録の承認必須を設定します。
void | setAuthoritygroup(String authoritygroup) 権限グループを設定します。
void | setBaseUom(String baseUom) 基本数量単位を設定します。
void | setBaseUomIso(String baseUomIso) ISO コードでの基本数量単位を設定します。
void | setBasicMatl(String basicMatl) 主構成物質を設定します。
void | setBatchMgmt(String batchMgmt) ロット管理所要量区分を設定します。
void | setCadId(String cadId) CAD 区分を設定します。
void | setCatprofile(String catprofile) カタログプロファイルを設定します。
void | setChangedBy(String changedBy) オブジェクトの変更者名を設定します。
void | setClosedBox(String closedBox) 完了した梱包材を設定します。
void | setCmRelevanceFlag(String cmRelevanceFlag) 構成管理関連を設定します。
void | setCompetitor(String competitor) 競合会社を設定します。
void | setConfigured(String configured) 選定可能品目を設定します。
void | setConfMatl(String confMatl) プラント共通選定可能品目を設定します。
void | setContainer(String container) 容器条件を設定します。
void | setCoProduct(String coProduct) 区分: 連産品としても使用可能な品目を設定します。
void | setCreatedBy(String createdBy) オブジェクト登録者名を設定します。
void | setCreatedOn(String createdOn) 登録日付を設定します。
void | setDelFlag(String delFlag) クライアントレベルでの品目削除フラグを設定します。
void | setDivision(String division) 製品部門を設定します。
void | setDocChgNo(String docChgNo) 文書変更番号 (文書管理システム外)を設定します。
void | setDocFormat(String docFormat) 文書のページ書式 (文書管理システムによらない)を設定します。
void | setDocType(String docType) 文書タイプ (文書管理システムによらない)を設定します。
void | setDocument(String document) 文書番号 (文書管理システムによらない)を設定します。
void | setDocVers(String docVers) 文書バージョン (文書管理システムによらない)を設定します。
void | setDsnOffice(String dsnOffice) 研究室/設計室を設定します。
void | setEnvtRlvt(String envtRlvt) 区分: 環境関連を設定します。
void | setExtmatlgrp(String extmatlgrp) 外部品目グループを設定します。
void | setFillLevel(String fillLevel) 最大レベル (容積別)を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setGtinVariant(String gtinVariant) グローバルトレード明細番号バリアントを設定します。
void | setHazMatNo(String hazMatNo) 危険物コードを設定します。
void | setHazMatNoExternal(String hazMatNoExternal) 項目 HAZ_MAT_NO の品目コード (長) (今後のリリースで開発)を設定します。
void | setHazMatNoGuid(String hazMatNoGuid) 項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)を設定します。
void | setHazMatNoVersion(String hazMatNoVersion) 項目 HAZ_MAT_NO のバージョン番号 (今後のリリースで開発)を設定します。
void | setHazmatprof(String hazmatprof) 危険物インジケータプロファイルを設定します。
void | setHighVisc(String highVisc) 区分: 高粘性を設定します。
void | setIndSector(String indSector) 産業コードを設定します。
void | setInvMatNo(String invMatNo) 会社固有 (内部) 在庫管理品目コードを設定します。
void | setInvMatNoExternal(String invMatNoExternal) 項目 INV_MAT_NO の品目コード (長) (今後のリリースで開発)を設定します。
void | setInvMatNoGuid(String invMatNoGuid) 項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)を設定します。
void | setInvMatNoVersion(String invMatNoVersion) 項目 INV_MAT_NO のバージョン番号 (今後のリリースで開発)を設定します。
void | setItemCat(String itemCat) 一般明細カテゴリグループを設定します。
void | setLabelForm(String labelForm) ラベル書式を設定します。
void | setLabelType(String labelType) ラベルタイプを設定します。
void | setLastChnge(String lastChnge) 最終変更日付を設定します。
void | setLooseorliq(String looseorliq) 区分: バルク/液体を設定します。
void | setMaintStat(String maintStat) 更新ステータスを設定します。
void | setManufProf(String manufProf) 製造者製品プロファイルを設定します。
void | setManuMat(String manuMat) 製造者製品コードを設定します。
void | setMatcmpllvl(String matcmpllvl) 品目完了レベルを設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialFixed(String materialFixed) ロックされている品目を設定します。
void | setMatGrpSm(String matGrpSm) 品目グループ: 梱包材を設定します。
void | setMatlGroup(String matlGroup) 品目グループを設定します。
void | setMatlType(String matlType) 品目タイプを設定します。
void | setMatStatus(String matStatus) 品目更新完了ステータスを設定します。
void | setMfrNo(String mfrNo) 製造者番号を設定します。
void | setMinremlife(String minremlife) 最低有効期間残を設定します。
void | setNetWeight(String netWeight) 正味重量を設定します。
void | setNoSheets(String noSheets) 文書枚数 (文書管理システムによらない)を設定します。
void | setOldMatNo(String oldMatNo) 旧品目コードを設定します。
void | setPackVoUn(String packVoUn) 容積単位 (許容梱包容積)を設定します。
void | setPackVoUnIso(String packVoUnIso) ISO コードでの容積単位 (許容梱包容積)を設定します。
void | setPackWtUn(String packWtUn) 重量単位 (許容梱包重量)を設定します。
void | setPackWtUnIso(String packWtUnIso) ISO コードでの重量単位 (許容梱包重量)を設定します。
void | setPageformat(String pageformat) 製造メモのページ書式を設定します。
void | setPageNo(String pageNo) 文書ページ番号 (文書管理システムによらない)を設定します。
void | setParEff(String parEff) 有効性パラメータへの値割当/変更番号よりも優先を設定します。
void | setPeriodIndExpirationDate(String periodIndExpirationDate) 有効期間期限日の期間区分を設定します。
void | setPlRefMat(String plRefMat) 梱包方法が同じ品目の参照品目を設定します。
void | setPoUnit(String poUnit) 発注単位を設定します。
void | setPoUnitIso(String poUnitIso) ISO コードによる発注単位を設定します。
void | setProcRule(String procRule) 調達規則を設定します。
void | setProdAlloc(String prodAlloc) 製品割当決定手順を設定します。
void | setProdCompositionOnPackaging(String prodCompositionOnPackaging) 区分: 梱包材にプリントされた生産構造を設定します。
void | setProdHier(String prodHier) 品目階層を設定します。
void | setProdMemo(String prodMemo) 製造/検査メモを設定します。
void | setPrRefMat(String prRefMat) 価格設定参照品目を設定します。
void | setPurStatus(String purStatus) プラント共通品目ステータスを設定します。
void | setPurValkey(String purValkey) 購買許容値キーを設定します。
void | setPvalidfrom(String pvalidfrom) プラント共通品目のステータス有効開始日付を設定します。
void | setQmProcmnt(String qmProcmnt) 調達における品質管理有効を設定します。
void | setQtyGrGi(String qtyGrGi) 数量: 印刷予定入出庫票数を設定します。
void | setQualDik(String qualDik) 無償納入による割引対象品目を設定します。
void | setRoundUpRuleExpirationDate(String roundUpRuleExpirationDate) 有効期間期限日計算の丸め規則を設定します。
void | setSalStatus(String salStatus) 流通チェーン間品目ステータスを設定します。
void | setSeason(String season) 季節カテゴリを設定します。
void | setSerializationLevel(String serializationLevel) シリアル番号の指定レベルを設定します。
void | setShelfLife(String shelfLife) 総有効期間を設定します。
void | setShMatTyp(String shMatTyp) 梱包材タイプを設定します。
void | setSizeDim(String sizeDim) サイズ/寸法を設定します。
void | setSledBbd(String sledBbd) 有効期限を設定します。
void | setStackFact(String stackFact) 山積係数を設定します。
void | setStdDescr(String stdDescr) 標準テキスト (ANSI、ISO など)を設定します。
void | setStorConds(String storConds) 保管条件を設定します。
void | setStorPct(String storPct) 残存有効期間割合 %を設定します。
void | setSupSource(String supSource) 供給元を設定します。
void | setSvalidfrom(String svalidfrom) 流通チェーン間品目ステータスの有効開始日付を設定します。
void | setTempConds(String tempConds) 温度条件区分を設定します。
void | setTransGrp(String transGrp) 輸送グループを設定します。
void | setUnitOfWt(String unitOfWt) 重量単位を設定します。
void | setUnitOfWtIso(String unitOfWtIso) ISO コードでの重量単位を設定します。
void | setUomusage(String uomusage) 使用数量単位を設定します。
void | setVarOrdUn(String varOrdUn) 可変購買発注単位有効を設定します。
void | setVolTolLt(String volTolLt) 荷役単位の容積超過許容量を設定します。
void | setWtTolLt(String wtTolLt) 荷役単位の重量超過許容量を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ClientData

public ClientData()
品目データ (クライアントレベル)情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getIndSector

public String getIndSector()
産業コードを取得します。

戻り値:
indSector 産業コード

getMatlType

public String getMatlType()
品目タイプを取得します。

戻り値:
matlType 品目タイプ

getCreatedOn

public String getCreatedOn()
登録日付を取得します。

戻り値:
createdOn 登録日付

getCreatedBy

public String getCreatedBy()
オブジェクト登録者名を取得します。

戻り値:
createdBy オブジェクト登録者名

getLastChnge

public String getLastChnge()
最終変更日付を取得します。

戻り値:
lastChnge 最終変更日付

getChangedBy

public String getChangedBy()
オブジェクトの変更者名を取得します。

戻り値:
changedBy オブジェクトの変更者名

getMatStatus

public String getMatStatus()
品目更新完了ステータスを取得します。

戻り値:
matStatus 品目更新完了ステータス

getMaintStat

public String getMaintStat()
更新ステータスを取得します。

戻り値:
maintStat 更新ステータス

getDelFlag

public String getDelFlag()
クライアントレベルでの品目削除フラグを取得します。

戻り値:
delFlag クライアントレベルでの品目削除フラグ

getMatlGroup

public String getMatlGroup()
品目グループを取得します。

戻り値:
matlGroup 品目グループ

getOldMatNo

public String getOldMatNo()
旧品目コードを取得します。

戻り値:
oldMatNo 旧品目コード

getBaseUom

public String getBaseUom()
基本数量単位を取得します。

戻り値:
baseUom 基本数量単位

getBaseUomIso

public String getBaseUomIso()
ISO コードでの基本数量単位を取得します。

戻り値:
baseUomIso ISO コードでの基本数量単位

getPoUnit

public String getPoUnit()
発注単位を取得します。

戻り値:
poUnit 発注単位

getPoUnitIso

public String getPoUnitIso()
ISO コードによる発注単位を取得します。

戻り値:
poUnitIso ISO コードによる発注単位

getDocument

public String getDocument()
文書番号 (文書管理システムによらない)を取得します。

戻り値:
document 文書番号 (文書管理システムによらない)

getDocType

public String getDocType()
文書タイプ (文書管理システムによらない)を取得します。

戻り値:
docType 文書タイプ (文書管理システムによらない)

getDocVers

public String getDocVers()
文書バージョン (文書管理システムによらない)を取得します。

戻り値:
docVers 文書バージョン (文書管理システムによらない)

getDocFormat

public String getDocFormat()
文書のページ書式 (文書管理システムによらない)を取得します。

戻り値:
docFormat 文書のページ書式 (文書管理システムによらない)

getDocChgNo

public String getDocChgNo()
文書変更番号 (文書管理システム外)を取得します。

戻り値:
docChgNo 文書変更番号 (文書管理システム外)

getPageNo

public String getPageNo()
文書ページ番号 (文書管理システムによらない)を取得します。

戻り値:
pageNo 文書ページ番号 (文書管理システムによらない)

getNoSheets

public String getNoSheets()
文書枚数 (文書管理システムによらない)を取得します。

戻り値:
noSheets 文書枚数 (文書管理システムによらない)

getProdMemo

public String getProdMemo()
製造/検査メモを取得します。

戻り値:
prodMemo 製造/検査メモ

getPageformat

public String getPageformat()
製造メモのページ書式を取得します。

戻り値:
pageformat 製造メモのページ書式

getSizeDim

public String getSizeDim()
サイズ/寸法を取得します。

戻り値:
sizeDim サイズ/寸法

getBasicMatl

public String getBasicMatl()
主構成物質を取得します。

戻り値:
basicMatl 主構成物質

getStdDescr

public String getStdDescr()
標準テキスト (ANSI、ISO など)を取得します。

戻り値:
stdDescr 標準テキスト (ANSI、ISO など)

getDsnOffice

public String getDsnOffice()
研究室/設計室を取得します。

戻り値:
dsnOffice 研究室/設計室

getPurValkey

public String getPurValkey()
購買許容値キーを取得します。

戻り値:
purValkey 購買許容値キー

getNetWeight

public String getNetWeight()
正味重量を取得します。

戻り値:
netWeight 正味重量

getUnitOfWt

public String getUnitOfWt()
重量単位を取得します。

戻り値:
unitOfWt 重量単位

getUnitOfWtIso

public String getUnitOfWtIso()
ISO コードでの重量単位を取得します。

戻り値:
unitOfWtIso ISO コードでの重量単位

getContainer

public String getContainer()
容器条件を取得します。

戻り値:
container 容器条件

getStorConds

public String getStorConds()
保管条件を取得します。

戻り値:
storConds 保管条件

getTempConds

public String getTempConds()
温度条件区分を取得します。

戻り値:
tempConds 温度条件区分

getTransGrp

public String getTransGrp()
輸送グループを取得します。

戻り値:
transGrp 輸送グループ

getHazMatNo

public String getHazMatNo()
危険物コードを取得します。

戻り値:
hazMatNo 危険物コード

getDivision

public String getDivision()
製品部門を取得します。

戻り値:
division 製品部門

getCompetitor

public String getCompetitor()
競合会社を取得します。

戻り値:
competitor 競合会社

getQtyGrGi

public String getQtyGrGi()
数量: 印刷予定入出庫票数を取得します。

戻り値:
qtyGrGi 数量: 印刷予定入出庫票数

getProcRule

public String getProcRule()
調達規則を取得します。

戻り値:
procRule 調達規則

getSupSource

public String getSupSource()
供給元を取得します。

戻り値:
supSource 供給元

getSeason

public String getSeason()
季節カテゴリを取得します。

戻り値:
season 季節カテゴリ

getLabelType

public String getLabelType()
ラベルタイプを取得します。

戻り値:
labelType ラベルタイプ

getLabelForm

public String getLabelForm()
ラベル書式を取得します。

戻り値:
labelForm ラベル書式

getProdHier

public String getProdHier()
品目階層を取得します。

戻り値:
prodHier 品目階層

getCadId

public String getCadId()
CAD 区分を取得します。

戻り値:
cadId CAD 区分

getAllowedWt

public String getAllowedWt()
許容梱包重量を取得します。

戻り値:
allowedWt 許容梱包重量

getPackWtUn

public String getPackWtUn()
重量単位 (許容梱包重量)を取得します。

戻り値:
packWtUn 重量単位 (許容梱包重量)

getPackWtUnIso

public String getPackWtUnIso()
ISO コードでの重量単位 (許容梱包重量)を取得します。

戻り値:
packWtUnIso ISO コードでの重量単位 (許容梱包重量)

getAllwdVol

public String getAllwdVol()
許容梱包容積を取得します。

戻り値:
allwdVol 許容梱包容積

getPackVoUn

public String getPackVoUn()
容積単位 (許容梱包容積)を取得します。

戻り値:
packVoUn 容積単位 (許容梱包容積)

getPackVoUnIso

public String getPackVoUnIso()
ISO コードでの容積単位 (許容梱包容積)を取得します。

戻り値:
packVoUnIso ISO コードでの容積単位 (許容梱包容積)

getWtTolLt

public String getWtTolLt()
荷役単位の重量超過許容量を取得します。

戻り値:
wtTolLt 荷役単位の重量超過許容量

getVolTolLt

public String getVolTolLt()
荷役単位の容積超過許容量を取得します。

戻り値:
volTolLt 荷役単位の容積超過許容量

getVarOrdUn

public String getVarOrdUn()
可変購買発注単位有効を取得します。

戻り値:
varOrdUn 可変購買発注単位有効

getConfigured

public String getConfigured()
選定可能品目を取得します。

戻り値:
configured 選定可能品目

getBatchMgmt

public String getBatchMgmt()
ロット管理所要量区分を取得します。

戻り値:
batchMgmt ロット管理所要量区分

getShMatTyp

public String getShMatTyp()
梱包材タイプを取得します。

戻り値:
shMatTyp 梱包材タイプ

getFillLevel

public String getFillLevel()
最大レベル (容積別)を取得します。

戻り値:
fillLevel 最大レベル (容積別)

getStackFact

public String getStackFact()
山積係数を取得します。

戻り値:
stackFact 山積係数

getMatGrpSm

public String getMatGrpSm()
品目グループ: 梱包材を取得します。

戻り値:
matGrpSm 品目グループ: 梱包材

getAuthoritygroup

public String getAuthoritygroup()
権限グループを取得します。

戻り値:
authoritygroup 権限グループ

getQmProcmnt

public String getQmProcmnt()
調達における品質管理有効を取得します。

戻り値:
qmProcmnt 調達における品質管理有効

getCatprofile

public String getCatprofile()
カタログプロファイルを取得します。

戻り値:
catprofile カタログプロファイル

getMinremlife

public String getMinremlife()
最低有効期間残を取得します。

戻り値:
minremlife 最低有効期間残

getShelfLife

public String getShelfLife()
総有効期間を取得します。

戻り値:
shelfLife 総有効期間

getStorPct

public String getStorPct()
残存有効期間割合 %を取得します。

戻り値:
storPct 残存有効期間割合 %

getConfMatl

public String getConfMatl()
プラント共通選定可能品目を取得します。

戻り値:
confMatl プラント共通選定可能品目

getCoProduct

public String getCoProduct()
区分: 連産品としても使用可能な品目を取得します。

戻り値:
coProduct 区分: 連産品としても使用可能な品目

getPrRefMat

public String getPrRefMat()
価格設定参照品目を取得します。

戻り値:
prRefMat 価格設定参照品目

getPurStatus

public String getPurStatus()
プラント共通品目ステータスを取得します。

戻り値:
purStatus プラント共通品目ステータス

getSalStatus

public String getSalStatus()
流通チェーン間品目ステータスを取得します。

戻り値:
salStatus 流通チェーン間品目ステータス

getPvalidfrom

public String getPvalidfrom()
プラント共通品目のステータス有効開始日付を取得します。

戻り値:
pvalidfrom プラント共通品目のステータス有効開始日付

getSvalidfrom

public String getSvalidfrom()
流通チェーン間品目ステータスの有効開始日付を取得します。

戻り値:
svalidfrom 流通チェーン間品目ステータスの有効開始日付

getEnvtRlvt

public String getEnvtRlvt()
区分: 環境関連を取得します。

戻り値:
envtRlvt 区分: 環境関連

getProdAlloc

public String getProdAlloc()
製品割当決定手順を取得します。

戻り値:
prodAlloc 製品割当決定手順

getQualDik

public String getQualDik()
無償納入による割引対象品目を取得します。

戻り値:
qualDik 無償納入による割引対象品目

getManuMat

public String getManuMat()
製造者製品コードを取得します。

戻り値:
manuMat 製造者製品コード

getMfrNo

public String getMfrNo()
製造者番号を取得します。

戻り値:
mfrNo 製造者番号

getInvMatNo

public String getInvMatNo()
会社固有 (内部) 在庫管理品目コードを取得します。

戻り値:
invMatNo 会社固有 (内部) 在庫管理品目コード

getManufProf

public String getManufProf()
製造者製品プロファイルを取得します。

戻り値:
manufProf 製造者製品プロファイル

getHazmatprof

public String getHazmatprof()
危険物インジケータプロファイルを取得します。

戻り値:
hazmatprof 危険物インジケータプロファイル

getHighVisc

public String getHighVisc()
区分: 高粘性を取得します。

戻り値:
highVisc 区分: 高粘性

getLooseorliq

public String getLooseorliq()
区分: バルク/液体を取得します。

戻り値:
looseorliq 区分: バルク/液体

getClosedBox

public String getClosedBox()
完了した梱包材を取得します。

戻り値:
closedBox 完了した梱包材

getAppdBRec

public String getAppdBRec()
区分: バッチ製造記録の承認必須を取得します。

戻り値:
appdBRec 区分: バッチ製造記録の承認必須

getMatcmpllvl

public String getMatcmpllvl()
品目完了レベルを取得します。

戻り値:
matcmpllvl 品目完了レベル

getParEff

public String getParEff()
有効性パラメータへの値割当/変更番号よりも優先を取得します。

戻り値:
parEff 有効性パラメータへの値割当/変更番号よりも優先

getRoundUpRuleExpirationDate

public String getRoundUpRuleExpirationDate()
有効期間期限日計算の丸め規則を取得します。

戻り値:
roundUpRuleExpirationDate 有効期間期限日計算の丸め規則

getPeriodIndExpirationDate

public String getPeriodIndExpirationDate()
有効期間期限日の期間区分を取得します。

戻り値:
periodIndExpirationDate 有効期間期限日の期間区分

getProdCompositionOnPackaging

public String getProdCompositionOnPackaging()
区分: 梱包材にプリントされた生産構造を取得します。

戻り値:
prodCompositionOnPackaging 区分: 梱包材にプリントされた生産構造

getItemCat

public String getItemCat()
一般明細カテゴリグループを取得します。

戻り値:
itemCat 一般明細カテゴリグループ

getHazMatNoExternal

public String getHazMatNoExternal()
項目 HAZ_MAT_NO の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
hazMatNoExternal 項目 HAZ_MAT_NO の品目コード (長) (今後の リリースで開発)

getHazMatNoGuid

public String getHazMatNoGuid()
項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
hazMatNoGuid 項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)

getHazMatNoVersion

public String getHazMatNoVersion()
項目 HAZ_MAT_NO のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
hazMatNoVersion 項目 HAZ_MAT_NO のバージョン番号 (今後の リリースで開発)

getInvMatNoExternal

public String getInvMatNoExternal()
項目 INV_MAT_NO の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
invMatNoExternal 項目 INV_MAT_NO の品目コード (長) (今後の リリースで開発)

getInvMatNoGuid

public String getInvMatNoGuid()
項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
invMatNoGuid 項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)

getInvMatNoVersion

public String getInvMatNoVersion()
項目 INV_MAT_NO のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
invMatNoVersion 項目 INV_MAT_NO のバージョン番号 (今後の リリースで開発)

getMaterialFixed

public String getMaterialFixed()
ロックされている品目を取得します。

戻り値:
materialFixed ロックされている品目

getCmRelevanceFlag

public String getCmRelevanceFlag()
構成管理関連を取得します。

戻り値:
cmRelevanceFlag 構成管理関連

getSledBbd

public String getSledBbd()
有効期限を取得します。

戻り値:
sledBbd 有効期限

getGtinVariant

public String getGtinVariant()
グローバルトレード明細番号バリアントを取得します。

戻り値:
gtinVariant グローバルトレード明細番号バリアント

getSerializationLevel

public String getSerializationLevel()
シリアル番号の指定レベルを取得します。

戻り値:
serializationLevel シリアル番号の指定レベル

getPlRefMat

public String getPlRefMat()
梱包方法が同じ品目の参照品目を取得します。

戻り値:
plRefMat 梱包方法が同じ品目の参照品目

getExtmatlgrp

public String getExtmatlgrp()
外部品目グループを取得します。

戻り値:
extmatlgrp 外部品目グループ

getUomusage

public String getUomusage()
使用数量単位を取得します。

戻り値:
uomusage 使用数量単位

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setIndSector

public void setIndSector(String indSector)
産業コードを設定します。

パラメータ:
indSector - 産業コード

setMatlType

public void setMatlType(String matlType)
品目タイプを設定します。

パラメータ:
matlType - 品目タイプ

setCreatedOn

public void setCreatedOn(String createdOn)
登録日付を設定します。

パラメータ:
createdOn - 登録日付

setCreatedBy

public void setCreatedBy(String createdBy)
オブジェクト登録者名を設定します。

パラメータ:
createdBy - オブジェクト登録者名

setLastChnge

public void setLastChnge(String lastChnge)
最終変更日付を設定します。

パラメータ:
lastChnge - 最終変更日付

setChangedBy

public void setChangedBy(String changedBy)
オブジェクトの変更者名を設定します。

パラメータ:
changedBy - オブジェクトの変更者名

setMatStatus

public void setMatStatus(String matStatus)
品目更新完了ステータスを設定します。

パラメータ:
matStatus - 品目更新完了ステータス

setMaintStat

public void setMaintStat(String maintStat)
更新ステータスを設定します。

パラメータ:
maintStat - 更新ステータス

setDelFlag

public void setDelFlag(String delFlag)
クライアントレベルでの品目削除フラグを設定します。

パラメータ:
delFlag - クライアントレベルでの品目削除フラグ

setMatlGroup

public void setMatlGroup(String matlGroup)
品目グループを設定します。

パラメータ:
matlGroup - 品目グループ

setOldMatNo

public void setOldMatNo(String oldMatNo)
旧品目コードを設定します。

パラメータ:
oldMatNo - 旧品目コード

setBaseUom

public void setBaseUom(String baseUom)
基本数量単位を設定します。

パラメータ:
baseUom - 基本数量単位

setBaseUomIso

public void setBaseUomIso(String baseUomIso)
ISO コードでの基本数量単位を設定します。

パラメータ:
baseUomIso - ISO コードでの基本数量単位

setPoUnit

public void setPoUnit(String poUnit)
発注単位を設定します。

パラメータ:
poUnit - 発注単位

setPoUnitIso

public void setPoUnitIso(String poUnitIso)
ISO コードによる発注単位を設定します。

パラメータ:
poUnitIso - ISO コードによる発注単位

setDocument

public void setDocument(String document)
文書番号 (文書管理システムによらない)を設定します。

パラメータ:
document - 文書番号 (文書管理システムによらない)

setDocType

public void setDocType(String docType)
文書タイプ (文書管理システムによらない)を設定します。

パラメータ:
docType - 文書タイプ (文書管理システムによらない)

setDocVers

public void setDocVers(String docVers)
文書バージョン (文書管理システムによらない)を設定します。

パラメータ:
docVers - 文書バージョン (文書管理システムによらない)

setDocFormat

public void setDocFormat(String docFormat)
文書のページ書式 (文書管理システムによらない)を設定します。

パラメータ:
docFormat - 文書のページ書式 (文書管理システムによらない)

setDocChgNo

public void setDocChgNo(String docChgNo)
文書変更番号 (文書管理システム外)を設定します。

パラメータ:
docChgNo - 文書変更番号 (文書管理システム外)

setPageNo

public void setPageNo(String pageNo)
文書ページ番号 (文書管理システムによらない)を設定します。

パラメータ:
pageNo - 文書ページ番号 (文書管理システムによらない)

setNoSheets

public void setNoSheets(String noSheets)
文書枚数 (文書管理システムによらない)を設定します。

パラメータ:
noSheets - 文書枚数 (文書管理システムによらない)

setProdMemo

public void setProdMemo(String prodMemo)
製造/検査メモを設定します。

パラメータ:
prodMemo - 製造/検査メモ

setPageformat

public void setPageformat(String pageformat)
製造メモのページ書式を設定します。

パラメータ:
pageformat - 製造メモのページ書式

setSizeDim

public void setSizeDim(String sizeDim)
サイズ/寸法を設定します。

パラメータ:
sizeDim - サイズ/寸法

setBasicMatl

public void setBasicMatl(String basicMatl)
主構成物質を設定します。

パラメータ:
basicMatl - 主構成物質

setStdDescr

public void setStdDescr(String stdDescr)
標準テキスト (ANSI、ISO など)を設定します。

パラメータ:
stdDescr - 標準テキスト (ANSI、ISO など)

setDsnOffice

public void setDsnOffice(String dsnOffice)
研究室/設計室を設定します。

パラメータ:
dsnOffice - 研究室/設計室

setPurValkey

public void setPurValkey(String purValkey)
購買許容値キーを設定します。

パラメータ:
purValkey - 購買許容値キー

setNetWeight

public void setNetWeight(String netWeight)
正味重量を設定します。

パラメータ:
netWeight - 正味重量

setUnitOfWt

public void setUnitOfWt(String unitOfWt)
重量単位を設定します。

パラメータ:
unitOfWt - 重量単位

setUnitOfWtIso

public void setUnitOfWtIso(String unitOfWtIso)
ISO コードでの重量単位を設定します。

パラメータ:
unitOfWtIso - ISO コードでの重量単位

setContainer

public void setContainer(String container)
容器条件を設定します。

パラメータ:
container - 容器条件

setStorConds

public void setStorConds(String storConds)
保管条件を設定します。

パラメータ:
storConds - 保管条件

setTempConds

public void setTempConds(String tempConds)
温度条件区分を設定します。

パラメータ:
tempConds - 温度条件区分

setTransGrp

public void setTransGrp(String transGrp)
輸送グループを設定します。

パラメータ:
transGrp - 輸送グループ

setHazMatNo

public void setHazMatNo(String hazMatNo)
危険物コードを設定します。

パラメータ:
hazMatNo - 危険物コード

setDivision

public void setDivision(String division)
製品部門を設定します。

パラメータ:
division - 製品部門

setCompetitor

public void setCompetitor(String competitor)
競合会社を設定します。

パラメータ:
competitor - 競合会社

setQtyGrGi

public void setQtyGrGi(String qtyGrGi)
数量: 印刷予定入出庫票数を設定します。

パラメータ:
qtyGrGi - 数量: 印刷予定入出庫票数

setProcRule

public void setProcRule(String procRule)
調達規則を設定します。

パラメータ:
procRule - 調達規則

setSupSource

public void setSupSource(String supSource)
供給元を設定します。

パラメータ:
supSource - 供給元

setSeason

public void setSeason(String season)
季節カテゴリを設定します。

パラメータ:
season - 季節カテゴリ

setLabelType

public void setLabelType(String labelType)
ラベルタイプを設定します。

パラメータ:
labelType - ラベルタイプ

setLabelForm

public void setLabelForm(String labelForm)
ラベル書式を設定します。

パラメータ:
labelForm - ラベル書式

setProdHier

public void setProdHier(String prodHier)
品目階層を設定します。

パラメータ:
prodHier - 品目階層

setCadId

public void setCadId(String cadId)
CAD 区分を設定します。

パラメータ:
cadId - CAD 区分

setAllowedWt

public void setAllowedWt(String allowedWt)
許容梱包重量を設定します。

パラメータ:
allowedWt - 許容梱包重量

setPackWtUn

public void setPackWtUn(String packWtUn)
重量単位 (許容梱包重量)を設定します。

パラメータ:
packWtUn - 重量単位 (許容梱包重量)

setPackWtUnIso

public void setPackWtUnIso(String packWtUnIso)
ISO コードでの重量単位 (許容梱包重量)を設定します。

パラメータ:
packWtUnIso - ISO コードでの重量単位 (許容梱包重量)

setAllwdVol

public void setAllwdVol(String allwdVol)
許容梱包容積を設定します。

パラメータ:
allwdVol - 許容梱包容積

setPackVoUn

public void setPackVoUn(String packVoUn)
容積単位 (許容梱包容積)を設定します。

パラメータ:
packVoUn - 容積単位 (許容梱包容積)

setPackVoUnIso

public void setPackVoUnIso(String packVoUnIso)
ISO コードでの容積単位 (許容梱包容積)を設定します。

パラメータ:
packVoUnIso - ISO コードでの容積単位 (許容梱包容積)

setWtTolLt

public void setWtTolLt(String wtTolLt)
荷役単位の重量超過許容量を設定します。

パラメータ:
wtTolLt - 荷役単位の重量超過許容量

setVolTolLt

public void setVolTolLt(String volTolLt)
荷役単位の容積超過許容量を設定します。

パラメータ:
volTolLt - 荷役単位の容積超過許容量

setVarOrdUn

public void setVarOrdUn(String varOrdUn)
可変購買発注単位有効を設定します。

パラメータ:
varOrdUn - 可変購買発注単位有効

setConfigured

public void setConfigured(String configured)
選定可能品目を設定します。

パラメータ:
configured - 選定可能品目

setBatchMgmt

public void setBatchMgmt(String batchMgmt)
ロット管理所要量区分を設定します。

パラメータ:
batchMgmt - ロット管理所要量区分

setShMatTyp

public void setShMatTyp(String shMatTyp)
梱包材タイプを設定します。

パラメータ:
shMatTyp - 梱包材タイプ

setFillLevel

public void setFillLevel(String fillLevel)
最大レベル (容積別)を設定します。

パラメータ:
fillLevel - 最大レベル (容積別)

setStackFact

public void setStackFact(String stackFact)
山積係数を設定します。

パラメータ:
stackFact - 山積係数

setMatGrpSm

public void setMatGrpSm(String matGrpSm)
品目グループ: 梱包材を設定します。

パラメータ:
matGrpSm - 品目グループ: 梱包材

setAuthoritygroup

public void setAuthoritygroup(String authoritygroup)
権限グループを設定します。

パラメータ:
authoritygroup - 権限グループ

setQmProcmnt

public void setQmProcmnt(String qmProcmnt)
調達における品質管理有効を設定します。

パラメータ:
qmProcmnt - 調達における品質管理有効

setCatprofile

public void setCatprofile(String catprofile)
カタログプロファイルを設定します。

パラメータ:
catprofile - カタログプロファイル

setMinremlife

public void setMinremlife(String minremlife)
最低有効期間残を設定します。

パラメータ:
minremlife - 最低有効期間残

setShelfLife

public void setShelfLife(String shelfLife)
総有効期間を設定します。

パラメータ:
shelfLife - 総有効期間

setStorPct

public void setStorPct(String storPct)
残存有効期間割合 %を設定します。

パラメータ:
storPct - 残存有効期間割合 %

setConfMatl

public void setConfMatl(String confMatl)
プラント共通選定可能品目を設定します。

パラメータ:
confMatl - プラント共通選定可能品目

setCoProduct

public void setCoProduct(String coProduct)
区分: 連産品としても使用可能な品目を設定します。

パラメータ:
coProduct - 区分: 連産品としても使用可能な品目

setPrRefMat

public void setPrRefMat(String prRefMat)
価格設定参照品目を設定します。

パラメータ:
prRefMat - 価格設定参照品目

setPurStatus

public void setPurStatus(String purStatus)
プラント共通品目ステータスを設定します。

パラメータ:
purStatus - プラント共通品目ステータス

setSalStatus

public void setSalStatus(String salStatus)
流通チェーン間品目ステータスを設定します。

パラメータ:
salStatus - 流通チェーン間品目ステータス

setPvalidfrom

public void setPvalidfrom(String pvalidfrom)
プラント共通品目のステータス有効開始日付を設定します。

パラメータ:
pvalidfrom - プラント共通品目のステータス有効開始日付

setSvalidfrom

public void setSvalidfrom(String svalidfrom)
流通チェーン間品目ステータスの有効開始日付を設定します。

パラメータ:
svalidfrom - 流通チェーン間品目ステータスの有効開始日付

setEnvtRlvt

public void setEnvtRlvt(String envtRlvt)
区分: 環境関連を設定します。

パラメータ:
envtRlvt - 区分: 環境関連

setProdAlloc

public void setProdAlloc(String prodAlloc)
製品割当決定手順を設定します。

パラメータ:
prodAlloc - 製品割当決定手順

setQualDik

public void setQualDik(String qualDik)
無償納入による割引対象品目を設定します。

パラメータ:
qualDik - 無償納入による割引対象品目

setManuMat

public void setManuMat(String manuMat)
製造者製品コードを設定します。

パラメータ:
manuMat - 製造者製品コード

setMfrNo

public void setMfrNo(String mfrNo)
製造者番号を設定します。

パラメータ:
mfrNo - 製造者番号

setInvMatNo

public void setInvMatNo(String invMatNo)
会社固有 (内部) 在庫管理品目コードを設定します。

パラメータ:
invMatNo - 会社固有 (内部) 在庫管理品目コード

setManufProf

public void setManufProf(String manufProf)
製造者製品プロファイルを設定します。

パラメータ:
manufProf - 製造者製品プロファイル

setHazmatprof

public void setHazmatprof(String hazmatprof)
危険物インジケータプロファイルを設定します。

パラメータ:
hazmatprof - 危険物インジケータプロファイル

setHighVisc

public void setHighVisc(String highVisc)
区分: 高粘性を設定します。

パラメータ:
highVisc - 区分: 高粘性

setLooseorliq

public void setLooseorliq(String looseorliq)
区分: バルク/液体を設定します。

パラメータ:
looseorliq - 区分: バルク/液体

setClosedBox

public void setClosedBox(String closedBox)
完了した梱包材を設定します。

パラメータ:
closedBox - 完了した梱包材

setAppdBRec

public void setAppdBRec(String appdBRec)
区分: バッチ製造記録の承認必須を設定します。

パラメータ:
appdBRec - 区分: バッチ製造記録の承認必須

setMatcmpllvl

public void setMatcmpllvl(String matcmpllvl)
品目完了レベルを設定します。

パラメータ:
matcmpllvl - 品目完了レベル

setParEff

public void setParEff(String parEff)
有効性パラメータへの値割当/変更番号よりも優先を設定します。

パラメータ:
parEff - 有効性パラメータへの値割当/変更番号よりも優先

setRoundUpRuleExpirationDate

public void setRoundUpRuleExpirationDate(String roundUpRuleExpirationDate)
有効期間期限日計算の丸め規則を設定します。

パラメータ:
roundUpRuleExpirationDate - 有効期間期限日計算の丸め規則

setPeriodIndExpirationDate

public void setPeriodIndExpirationDate(String periodIndExpirationDate)
有効期間期限日の期間区分を設定します。

パラメータ:
periodIndExpirationDate - 有効期間期限日の期間区分

setProdCompositionOnPackaging

public void setProdCompositionOnPackaging(String prodCompositionOnPackaging)
区分: 梱包材にプリントされた生産構造を設定します。

パラメータ:
prodCompositionOnPackaging - 区分: 梱包材にプリントされた生産構造

setItemCat

public void setItemCat(String itemCat)
一般明細カテゴリグループを設定します。

パラメータ:
itemCat - 一般明細カテゴリグループ

setHazMatNoExternal

public void setHazMatNoExternal(String hazMatNoExternal)
項目 HAZ_MAT_NO の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
hazMatNoExternal - 項目 HAZ_MAT_NO の品目コード (長) (今後の リリースで開発)

setHazMatNoGuid

public void setHazMatNoGuid(String hazMatNoGuid)
項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
hazMatNoGuid - 項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)

setHazMatNoVersion

public void setHazMatNoVersion(String hazMatNoVersion)
項目 HAZ_MAT_NO のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
hazMatNoVersion - 項目 HAZ_MAT_NO のバージョン番号 (今後の リリースで開発)

setInvMatNoExternal

public void setInvMatNoExternal(String invMatNoExternal)
項目 INV_MAT_NO の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
invMatNoExternal - 項目 INV_MAT_NO の品目コード (長) (今後の リリースで開発)

setInvMatNoGuid

public void setInvMatNoGuid(String invMatNoGuid)
項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
invMatNoGuid - 項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)

setInvMatNoVersion

public void setInvMatNoVersion(String invMatNoVersion)
項目 INV_MAT_NO のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
invMatNoVersion - 項目 INV_MAT_NO のバージョン番号 (今後の リリースで開発)

setMaterialFixed

public void setMaterialFixed(String materialFixed)
ロックされている品目を設定します。

パラメータ:
materialFixed - ロックされている品目

setCmRelevanceFlag

public void setCmRelevanceFlag(String cmRelevanceFlag)
構成管理関連を設定します。

パラメータ:
cmRelevanceFlag - 構成管理関連

setSledBbd

public void setSledBbd(String sledBbd)
有効期限を設定します。

パラメータ:
sledBbd - 有効期限

setGtinVariant

public void setGtinVariant(String gtinVariant)
グローバルトレード明細番号バリアントを設定します。

パラメータ:
gtinVariant - グローバルトレード明細番号バリアント

setSerializationLevel

public void setSerializationLevel(String serializationLevel)
シリアル番号の指定レベルを設定します。

パラメータ:
serializationLevel - シリアル番号の指定レベル

setPlRefMat

public void setPlRefMat(String plRefMat)
梱包方法が同じ品目の参照品目を設定します。

パラメータ:
plRefMat - 梱包方法が同じ品目の参照品目

setExtmatlgrp

public void setExtmatlgrp(String extmatlgrp)
外部品目グループを設定します。

パラメータ:
extmatlgrp - 外部品目グループ

setUomusage

public void setUomusage(String uomusage)
使用数量単位を設定します。

パラメータ:
uomusage - 使用数量単位

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ClientDataList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ClientDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList
すべての実装インタフェース:
Serializable
public class ClientDataList
extends ClientData
implements Serializable

品目データ (クライアントレベル)情報クラス
機能は以下の通り

  • 品目データ (クライアントレベル)情報をテーブル型で保持します。

関連項目:
直列化された形式

コンストラクタの概要
ClientDataList()
品目データ (クライアントレベル)情報を作成します。
ClientDataList(int index)
品目データ (クライアントレベル)情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData から継承したメソッド
getAllowedWt, getAllwdVol, getAppdBRec, getAuthoritygroup, getBaseUom, getBaseUomIso, getBasicMatl, getBatchMgmt, getCadId, getCatprofile, getChangedBy, getClosedBox, getCmRelevanceFlag, getCompetitor, getConfigured, getConfMatl, getContainer, getCoProduct, getCreatedBy, getCreatedOn, getDelFlag, getDivision, getDocChgNo, getDocFormat, getDocType, getDocument, getDocVers, getDsnOffice, getEnvtRlvt, getExtmatlgrp, getFillLevel, getFunction, getGtinVariant, getHazMatNo, getHazMatNoExternal, getHazMatNoGuid, getHazMatNoVersion, getHazmatprof, getHighVisc, getIndSector, getInvMatNo, getInvMatNoExternal, getInvMatNoGuid, getInvMatNoVersion, getItemCat, getLabelForm, getLabelType, getLastChnge, getLooseorliq, getMaintStat, getManufProf, getManuMat, getMatcmpllvl, getMaterial, getMaterialFixed, getMatGrpSm, getMatlGroup, getMatlType, getMatStatus, getMfrNo, getMinremlife, getNetWeight, getNoSheets, getOldMatNo, getPackVoUn, getPackVoUnIso, getPackWtUn, getPackWtUnIso, getPageformat, getPageNo, getParEff, getPeriodIndExpirationDate, getPlRefMat, getPoUnit, getPoUnitIso, getProcRule, getProdAlloc, getProdCompositionOnPackaging, getProdHier, getProdMemo, getPrRefMat, getPurStatus, getPurValkey, getPvalidfrom, getQmProcmnt, getQtyGrGi, getQualDik, getRoundUpRuleExpirationDate, getSalStatus, getSeason, getSerializationLevel, getShelfLife, getShMatTyp, getSizeDim, getSledBbd, getStackFact, getStdDescr, getStorConds, getStorPct, getSupSource, getSvalidfrom, getTempConds, getTransGrp, getUnitOfWt, getUnitOfWtIso, getUomusage, getVarOrdUn, getVolTolLt, getWtTolLt, setAllowedWt, setAllwdVol, setAppdBRec, setAuthoritygroup, setBaseUom, setBaseUomIso, setBasicMatl, setBatchMgmt, setCadId, setCatprofile, setChangedBy, setClosedBox, setCmRelevanceFlag, setCompetitor, setConfigured, setConfMatl, setContainer, setCoProduct, setCreatedBy, setCreatedOn, setDelFlag, setDivision, setDocChgNo, setDocFormat, setDocType, setDocument, setDocVers, setDsnOffice, setEnvtRlvt, setExtmatlgrp, setFillLevel, setFunction, setGtinVariant, setHazMatNo, setHazMatNoExternal, setHazMatNoGuid, setHazMatNoVersion, setHazmatprof, setHighVisc, setIndSector, setInvMatNo, setInvMatNoExternal, setInvMatNoGuid, setInvMatNoVersion, setItemCat, setLabelForm, setLabelType, setLastChnge, setLooseorliq, setMaintStat, setManufProf, setManuMat, setMatcmpllvl, setMaterial, setMaterialFixed, setMatGrpSm, setMatlGroup, setMatlType, setMatStatus, setMfrNo, setMinremlife, setNetWeight, setNoSheets, setOldMatNo, setPackVoUn, setPackVoUnIso, setPackWtUn, setPackWtUnIso, setPageformat, setPageNo, setParEff, setPeriodIndExpirationDate, setPlRefMat, setPoUnit, setPoUnitIso, setProcRule, setProdAlloc, setProdCompositionOnPackaging, setProdHier, setProdMemo, setPrRefMat, setPurStatus, setPurValkey, setPvalidfrom, setQmProcmnt, setQtyGrGi, setQualDik, setRoundUpRuleExpirationDate, setSalStatus, setSeason, setSerializationLevel, setShelfLife, setShMatTyp, setSizeDim, setSledBbd, setStackFact, setStdDescr, setStorConds, setStorPct, setSupSource, setSvalidfrom, setTempConds, setTransGrp, setUnitOfWt, setUnitOfWtIso, setUomusage, setVarOrdUn, setVolTolLt, setWtTolLt, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ClientDataList

public ClientDataList()
品目データ (クライアントレベル)情報を作成します。

ClientDataList

public ClientDataList(int index)
品目データ (クライアントレベル)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ForecastParameters (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ForecastParameters

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ForecastParametersList
public class ForecastParameters
extends Object
implements Serializable

予測パラメータ情報クラス
機能は以下の通り

  • 予測パラメータ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ForecastParameters()
予測パラメータ情報を作成します。
メソッドの概要
String | getAlphaFact() アルファ係数使用による基本値の平滑化を取得します。
String | getBasicValue() 基準値を取得します。
String | getBasicValue1() 第二指図の基準値を取得します。
String | getBasicValue2() 第二指図の基準値を取得します。
String | getBasicValuePp() 前期間の基準値を取得します。
String | getBasicValuePp1() 前期間における第二指図の基準値を取得します。
String | getBasicValuePp2() 前期間における第二指図の基準値を取得します。
String | getBetaFact() ベータ係数による傾向値平準化を取得します。
String | getCoeffTheil() タイル係数を取得します。
String | getDeltaFact() デルタ係数使用による MAD (絶対平均偏差) 平準化を取得します。
String | getErrorTotal() エラー合計を取得します。
String | getErrorTotalPp() 前期間のエラー合計を取得します。
String | getExceptList() 例外メッセージバーを取得します。
String | getExpostPds() 事後的需要予測に含む履歴値の数を取得します。
String | getFixedPds() 固定期間を取得します。
String | getForecFlowCont() 予測フロー管理を取得します。
String | getForeDate() 最終需要予測日を取得します。
String | getForeModel() 予測モデルを取得します。
String | getForePds() 需要予測期間を取得します。
String | getForeProf() 需要予測プロファイルを取得します。
String | getFunction() BAPI 機能を取得します。
String | getFyVariant() 会計年度バリアントを取得します。
String | getGammaFact() ガンマ係数使用の平滑化のための季節指数を取得します。
String | getHistVals() 履歴値の数を取得します。
String | getInitialize() 初期化区分を取得します。
String | getInitPds() 初期化で使用する履歴値の数を取得します。
String | getMaterial() 品目コードを取得します。
String | getMeanAbsolDev() 絶対平均偏差 (MAD)を取得します。
String | getMeanAbsolDevPp() 前期間の平均絶対偏差を取得します。
String | getModelSi() モデル選択区分を取得します。
String | getModelSp() モデル選択方式を取得します。
String | getOptimLev() 最適化レベルを取得します。
String | getParamOpt() パラメータ最適化用の区分を取得します。
String | getPeriodInd() 期間区分を取得します。
String | getPlant() プラントを取得します。
String | getSeasonPds() 季節周期ごとの期間数を取得します。
String | getTracklimit() 警告限界を取得します。
String | getTrendValue() 傾向値を取得します。
String | getTrendValuePp() 前期間の傾向値を取得します。
String | getWtgGroup() 加重グループを取得します。
void | setAlphaFact(String alphaFact) アルファ係数使用による基本値の平滑化を設定します。
void | setBasicValue(String basicValue) 基準値を設定します。
void | setBasicValue1(String basicValue1) 第二指図の基準値を設定します。
void | setBasicValue2(String basicValue2) 第二指図の基準値を設定します。
void | setBasicValuePp(String basicValuePp) 前期間の基準値を設定します。
void | setBasicValuePp1(String basicValuePp1) 前期間における第二指図の基準値を設定します。
void | setBasicValuePp2(String basicValuePp2) 前期間における第二指図の基準値を設定します。
void | setBetaFact(String betaFact) ベータ係数による傾向値平準化を設定します。
void | setCoeffTheil(String coeffTheil) タイル係数を設定します。
void | setDeltaFact(String deltaFact) デルタ係数使用による MAD (絶対平均偏差) 平準化を設定します。
void | setErrorTotal(String errorTotal) エラー合計を設定します。
void | setErrorTotalPp(String errorTotalPp) 前期間のエラー合計を設定します。
void | setExceptList(String exceptList) 例外メッセージバーを設定します。
void | setExpostPds(String expostPds) 事後的需要予測に含む履歴値の数を設定します。
void | setFixedPds(String fixedPds) 固定期間を設定します。
void | setForecFlowCont(String forecFlowCont) 予測フロー管理を設定します。
void | setForeDate(String foreDate) 最終需要予測日を設定します。
void | setForeModel(String foreModel) 予測モデルを設定します。
void | setForePds(String forePds) 需要予測期間を設定します。
void | setForeProf(String foreProf) 需要予測プロファイルを設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setFyVariant(String fyVariant) 会計年度バリアントを設定します。
void | setGammaFact(String gammaFact) ガンマ係数使用の平滑化のための季節指数を設定します。
void | setHistVals(String histVals) 履歴値の数を設定します。
void | setInitialize(String initialize) 初期化区分を設定します。
void | setInitPds(String initPds) 初期化で使用する履歴値の数を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMeanAbsolDev(String meanAbsolDev) 絶対平均偏差 (MAD)を設定します。
void | setMeanAbsolDevPp(String meanAbsolDevPp) 前期間の平均絶対偏差を設定します。
void | setModelSi(String modelSi) モデル選択区分を設定します。
void | setModelSp(String modelSp) モデル選択方式を設定します。
void | setOptimLev(String optimLev) 最適化レベルを設定します。
void | setParamOpt(String paramOpt) パラメータ最適化用の区分を設定します。
void | setPeriodInd(String periodInd) 期間区分を設定します。
void | setPlant(String plant) プラントを設定します。
void | setSeasonPds(String seasonPds) 季節周期ごとの期間数を設定します。
void | setTracklimit(String tracklimit) 警告限界を設定します。
void | setTrendValue(String trendValue) 傾向値を設定します。
void | setTrendValuePp(String trendValuePp) 前期間の傾向値を設定します。
void | setWtgGroup(String wtgGroup) 加重グループを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ForecastParameters

public ForecastParameters()
予測パラメータ情報を作成します。 需要予測パラメータ情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getForeProf

public String getForeProf()
需要予測プロファイルを取得します。

戻り値:
foreProf 需要予測プロファイル

getModelSi

public String getModelSi()
モデル選択区分を取得します。

戻り値:
modelSi モデル選択区分

getModelSp

public String getModelSp()
モデル選択方式を取得します。

戻り値:
modelSp モデル選択方式

getParamOpt

public String getParamOpt()
パラメータ最適化用の区分を取得します。

戻り値:
paramOpt パラメータ最適化用の区分

getOptimLev

public String getOptimLev()
最適化レベルを取得します。

戻り値:
optimLev 最適化レベル

getInitialize

public String getInitialize()
初期化区分を取得します。

戻り値:
initialize 初期化区分

getForeModel

public String getForeModel()
予測モデルを取得します。

戻り値:
foreModel 予測モデル

getAlphaFact

public String getAlphaFact()
アルファ係数使用による基本値の平滑化を取得します。

戻り値:
alphaFact アルファ係数使用による基本値の平滑化

getBetaFact

public String getBetaFact()
ベータ係数による傾向値平準化を取得します。

戻り値:
betaFact ベータ係数による傾向値平準化

getGammaFact

public String getGammaFact()
ガンマ係数使用の平滑化のための季節指数を取得します。

戻り値:
gammaFact ガンマ係数使用の平滑化のための季節指数

getDeltaFact

public String getDeltaFact()
デルタ係数使用による MAD (絶対平均偏差) 平準化を取得します。

戻り値:
deltaFact デルタ係数使用による MAD (絶対平均偏差) 平準化

getTracklimit

public String getTracklimit()
警告限界を取得します。

戻り値:
tracklimit 警告限界

getForeDate

public String getForeDate()
最終需要予測日を取得します。

戻り値:
foreDate 最終需要予測日

getHistVals

public String getHistVals()
履歴値の数を取得します。

戻り値:
histVals 履歴値の数

getInitPds

public String getInitPds()
初期化で使用する履歴値の数を取得します。

戻り値:
initPds 初期化で使用する履歴値の数

getSeasonPds

public String getSeasonPds()
季節周期ごとの期間数を取得します。

戻り値:
seasonPds 季節周期ごとの期間数

getExpostPds

public String getExpostPds()
事後的需要予測に含む履歴値の数を取得します。

戻り値:
expostPds 事後的需要予測に含む履歴値の数

getForePds

public String getForePds()
需要予測期間を取得します。

戻り値:
forePds 需要予測期間

getFixedPds

public String getFixedPds()
固定期間を取得します。

戻り値:
fixedPds 固定期間

getBasicValue

public String getBasicValue()
基準値を取得します。

戻り値:
basicValue 基準値

getBasicValue1

public String getBasicValue1()
第二指図の基準値を取得します。

戻り値:
basicValue1 第二指図の基準値

getBasicValue2

public String getBasicValue2()
第二指図の基準値を取得します。

戻り値:
basicValue2 第二指図の基準値

getBasicValuePp

public String getBasicValuePp()
前期間の基準値を取得します。

戻り値:
basicValuePp 前期間の基準値

getBasicValuePp1

public String getBasicValuePp1()
前期間における第二指図の基準値を取得します。

戻り値:
basicValuePp1 前期間における第二指図の基準値

getBasicValuePp2

public String getBasicValuePp2()
前期間における第二指図の基準値を取得します。

戻り値:
basicValuePp2 前期間における第二指図の基準値

getTrendValue

public String getTrendValue()
傾向値を取得します。

戻り値:
trendValue 傾向値

getTrendValuePp

public String getTrendValuePp()
前期間の傾向値を取得します。

戻り値:
trendValuePp 前期間の傾向値

getMeanAbsolDev

public String getMeanAbsolDev()
絶対平均偏差 (MAD)を取得します。

戻り値:
meanAbsolDev 絶対平均偏差 (MAD)

getMeanAbsolDevPp

public String getMeanAbsolDevPp()
前期間の平均絶対偏差を取得します。

戻り値:
meanAbsolDevPp 前期間の平均絶対偏差

getErrorTotal

public String getErrorTotal()
エラー合計を取得します。

戻り値:
errorTotal エラー合計

getErrorTotalPp

public String getErrorTotalPp()
前期間のエラー合計を取得します。

戻り値:
errorTotalPp 前期間のエラー合計

getWtgGroup

public String getWtgGroup()
加重グループを取得します。

戻り値:
wtgGroup 加重グループ

getCoeffTheil

public String getCoeffTheil()
タイル係数を取得します。

戻り値:
coeffTheil タイル係数

getExceptList

public String getExceptList()
例外メッセージバーを取得します。

戻り値:
exceptList 例外メッセージバー

getForecFlowCont

public String getForecFlowCont()
予測フロー管理を取得します。

戻り値:
forecFlowCont 予測フロー管理

getPeriodInd

public String getPeriodInd()
期間区分を取得します。

戻り値:
periodInd 期間区分

getFyVariant

public String getFyVariant()
会計年度バリアントを取得します。

戻り値:
fyVariant 会計年度バリアント

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setForeProf

public void setForeProf(String foreProf)
需要予測プロファイルを設定します。

パラメータ:
foreProf - 需要予測プロファイル

setModelSi

public void setModelSi(String modelSi)
モデル選択区分を設定します。

パラメータ:
modelSi - モデル選択区分

setModelSp

public void setModelSp(String modelSp)
モデル選択方式を設定します。

パラメータ:
modelSp - モデル選択方式

setParamOpt

public void setParamOpt(String paramOpt)
パラメータ最適化用の区分を設定します。

パラメータ:
paramOpt - パラメータ最適化用の区分

setOptimLev

public void setOptimLev(String optimLev)
最適化レベルを設定します。

パラメータ:
optimLev - 最適化レベル

setInitialize

public void setInitialize(String initialize)
初期化区分を設定します。

パラメータ:
initialize - 初期化区分

setForeModel

public void setForeModel(String foreModel)
予測モデルを設定します。

パラメータ:
foreModel - 予測モデル

setAlphaFact

public void setAlphaFact(String alphaFact)
アルファ係数使用による基本値の平滑化を設定します。

パラメータ:
alphaFact - アルファ係数使用による基本値の平滑化

setBetaFact

public void setBetaFact(String betaFact)
ベータ係数による傾向値平準化を設定します。

パラメータ:
betaFact - ベータ係数による傾向値平準化

setGammaFact

public void setGammaFact(String gammaFact)
ガンマ係数使用の平滑化のための季節指数を設定します。

パラメータ:
gammaFact - ガンマ係数使用の平滑化のための季節指数

setDeltaFact

public void setDeltaFact(String deltaFact)
デルタ係数使用による MAD (絶対平均偏差) 平準化を設定します。

パラメータ:
deltaFact - デルタ係数使用による MAD (絶対平均偏差) 平準化

setTracklimit

public void setTracklimit(String tracklimit)
警告限界を設定します。

パラメータ:
tracklimit - 警告限界

setForeDate

public void setForeDate(String foreDate)
最終需要予測日を設定します。

パラメータ:
foreDate - 最終需要予測日

setHistVals

public void setHistVals(String histVals)
履歴値の数を設定します。

パラメータ:
histVals - 履歴値の数

setInitPds

public void setInitPds(String initPds)
初期化で使用する履歴値の数を設定します。

パラメータ:
initPds - 初期化で使用する履歴値の数

setSeasonPds

public void setSeasonPds(String seasonPds)
季節周期ごとの期間数を設定します。

パラメータ:
seasonPds - 季節周期ごとの期間数

setExpostPds

public void setExpostPds(String expostPds)
事後的需要予測に含む履歴値の数を設定します。

パラメータ:
expostPds - 事後的需要予測に含む履歴値の数

setForePds

public void setForePds(String forePds)
需要予測期間を設定します。

パラメータ:
forePds - 需要予測期間

setFixedPds

public void setFixedPds(String fixedPds)
固定期間を設定します。

パラメータ:
fixedPds - 固定期間

setBasicValue

public void setBasicValue(String basicValue)
基準値を設定します。

パラメータ:
basicValue - 基準値

setBasicValue1

public void setBasicValue1(String basicValue1)
第二指図の基準値を設定します。

パラメータ:
basicValue1 - 第二指図の基準値

setBasicValue2

public void setBasicValue2(String basicValue2)
第二指図の基準値を設定します。

パラメータ:
basicValue2 - 第二指図の基準値

setBasicValuePp

public void setBasicValuePp(String basicValuePp)
前期間の基準値を設定します。

パラメータ:
basicValuePp - 前期間の基準値

setBasicValuePp1

public void setBasicValuePp1(String basicValuePp1)
前期間における第二指図の基準値を設定します。

パラメータ:
basicValuePp1 - 前期間における第二指図の基準値

setBasicValuePp2

public void setBasicValuePp2(String basicValuePp2)
前期間における第二指図の基準値を設定します。

パラメータ:
basicValuePp2 - 前期間における第二指図の基準値

setTrendValue

public void setTrendValue(String trendValue)
傾向値を設定します。

パラメータ:
trendValue - 傾向値

setTrendValuePp

public void setTrendValuePp(String trendValuePp)
前期間の傾向値を設定します。

パラメータ:
trendValuePp - 前期間の傾向値

setMeanAbsolDev

public void setMeanAbsolDev(String meanAbsolDev)
絶対平均偏差 (MAD)を設定します。

パラメータ:
meanAbsolDev - 絶対平均偏差 (MAD)

setMeanAbsolDevPp

public void setMeanAbsolDevPp(String meanAbsolDevPp)
前期間の平均絶対偏差を設定します。

パラメータ:
meanAbsolDevPp - 前期間の平均絶対偏差

setErrorTotal

public void setErrorTotal(String errorTotal)
エラー合計を設定します。

パラメータ:
errorTotal - エラー合計

setErrorTotalPp

public void setErrorTotalPp(String errorTotalPp)
前期間のエラー合計を設定します。

パラメータ:
errorTotalPp - 前期間のエラー合計

setWtgGroup

public void setWtgGroup(String wtgGroup)
加重グループを設定します。

パラメータ:
wtgGroup - 加重グループ

setCoeffTheil

public void setCoeffTheil(String coeffTheil)
タイル係数を設定します。

パラメータ:
coeffTheil - タイル係数

setExceptList

public void setExceptList(String exceptList)
例外メッセージバーを設定します。

パラメータ:
exceptList - 例外メッセージバー

setForecFlowCont

public void setForecFlowCont(String forecFlowCont)
予測フロー管理を設定します。

パラメータ:
forecFlowCont - 予測フロー管理

setPeriodInd

public void setPeriodInd(String periodInd)
期間区分を設定します。

パラメータ:
periodInd - 期間区分

setFyVariant

public void setFyVariant(String fyVariant)
会計年度バリアントを設定します。

パラメータ:
fyVariant - 会計年度バリアント

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ForecastParametersList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ForecastParametersList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList
すべての実装インタフェース:
Serializable
public class ForecastParametersList
extends ForecastParameters
implements Serializable

需要予測パラメータ情報クラス
機能は以下の通り

  • 需要予測パラメータ情報をテーブル型で保持します。

関連項目:
直列化された形式

コンストラクタの概要
ForecastParametersList()
需要予測パラメータ情報を作成します。
ForecastParametersList(int index)
需要予測パラメータ情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters から継承したメソッド
getAlphaFact, getBasicValue, getBasicValue1, getBasicValue2, getBasicValuePp, getBasicValuePp1, getBasicValuePp2, getBetaFact, getCoeffTheil, getDeltaFact, getErrorTotal, getErrorTotalPp, getExceptList, getExpostPds, getFixedPds, getForecFlowCont, getForeDate, getForeModel, getForePds, getForeProf, getFunction, getFyVariant, getGammaFact, getHistVals, getInitialize, getInitPds, getMaterial, getMeanAbsolDev, getMeanAbsolDevPp, getModelSi, getModelSp, getOptimLev, getParamOpt, getPeriodInd, getPlant, getSeasonPds, getTracklimit, getTrendValue, getTrendValuePp, getWtgGroup, setAlphaFact, setBasicValue, setBasicValue1, setBasicValue2, setBasicValuePp, setBasicValuePp1, setBasicValuePp2, setBetaFact, setCoeffTheil, setDeltaFact, setErrorTotal, setErrorTotalPp, setExceptList, setExpostPds, setFixedPds, setForecFlowCont, setForeDate, setForeModel, setForePds, setForeProf, setFunction, setFyVariant, setGammaFact, setHistVals, setInitialize, setInitPds, setMaterial, setMeanAbsolDev, setMeanAbsolDevPp, setModelSi, setModelSp, setOptimLev, setParamOpt, setPeriodInd, setPlant, setSeasonPds, setTracklimit, setTrendValue, setTrendValuePp, setWtgGroup, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ForecastParametersList

public ForecastParametersList()
需要予測パラメータ情報を作成します。

ForecastParametersList

public ForecastParametersList(int index)
需要予測パラメータ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtHeader (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス GoodsMvtHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
GoodsMvtHeaderList
public class GoodsMvtHeader
extends Object
implements Serializable

入出庫伝票ヘッダデータ情報クラス
機能は以下の通り

  • 入出庫伝票ヘッダデータ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GoodsMvtHeader()
入出庫伝票ヘッダデータ情報を作成します。
メソッドの概要
String | getBarCode() バーコードエントリを取得します。
String | getBillOfLading() 入庫時に登録した B/L 番号を取得します。
String | getBillOfLadingLong() 入庫の船荷証券番号 (依存: テキスト (長) 参照)を取得します。
String | getDocDate() 伝票の伝票日付を取得します。
String | getDocYear() 入出庫伝票年度を取得します。
String | getEntryDate() 会計伝票登録日を取得します。
String | getEntryTime() 登録時刻を取得します。
String | getExpimpNo() 貿易データ番号: MM/SD 伝票を取得します。
String | getExtWms() 外部倉庫管理の転記の制御を取得します。
String | getGrGiSlipNo() 入出庫票番号を取得します。
String | getHeaderTxt() 伝票ヘッダテキストを取得します。
String | getMatDoc() 入出庫伝票番号を取得します。
String | getPrUname() ユーザ名を取得します。
String | getPstngDate() 伝票の転記日付を取得します。
String | getRefDocNo() 参照伝票番号を取得します。
String | getRefDocNoLong() 参照伝票番号 (依存性についてはテキスト長参照)を取得します。
String | getTrEvType() トランザクション/イベントタイプを取得します。
String | getUsername() ユーザ名を取得します。
String | getVerGrGiSlip() 入出庫票の印刷バ－ジョンを取得します。
String | getVerGrGiSlipx() 関連ユーザデータ項目の更新情報を取得します。
void | setBarCode(String barCode) バーコードエントリを設定します。
void | setBillOfLading(String billOfLading) 入庫時に登録した B/L 番号を設定します。
void | setBillOfLadingLong(String billOfLadingLong) 入庫の船荷証券番号 (依存: テキスト (長) 参照)を設定します。
void | setDocDate(String docDate) 伝票の伝票日付を設定します。
void | setDocYear(String docYear) 入出庫伝票年度を設定します。
void | setEntryDate(String entryDate) 会計伝票登録日を設定します。
void | setEntryTime(String entryTime) 登録時刻を設定します。
void | setExpimpNo(String expimpNo) 貿易データ番号: MM/SD 伝票を設定します。
void | setExtWms(String extWms) 外部倉庫管理の転記の制御を設定します。
void | setGrGiSlipNo(String grGiSlipNo) 入出庫票番号を設定します。
void | setHeaderTxt(String headerTxt) 伝票ヘッダテキストを設定します。
void | setMatDoc(String matDoc) 入出庫伝票番号を設定します。
void | setPrUname(String prUname) ユーザ名を設定します。
void | setPstngDate(String pstngDate) 伝票の転記日付を設定します。
void | setRefDocNo(String refDocNo) 参照伝票番号を設定します。
void | setRefDocNoLong(String refDocNoLong) 参照伝票番号 (依存性についてはテキスト長参照)を設定します。
void | setTrEvType(String trEvType) トランザクション/イベントタイプを設定します。
void | setUsername(String username) ユーザ名を設定します。
void | setVerGrGiSlip(String verGrGiSlip) 入出庫票の印刷バ－ジョンを設定します。
void | setVerGrGiSlipx(String verGrGiSlipx) 関連ユーザデータ項目の更新情報を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtHeader

public GoodsMvtHeader()
入出庫伝票ヘッダデータ情報を作成します。

メソッドの詳細

getDocDate

public String getDocDate()
伝票の伝票日付を取得します。

戻り値:
docDate 伝票の伝票日付

getHeaderTxt

public String getHeaderTxt()
伝票ヘッダテキストを取得します。

戻り値:
headerTxt 伝票ヘッダテキスト

getPstngDate

public String getPstngDate()
伝票の転記日付を取得します。

戻り値:
pstngDate 伝票の転記日付

getRefDocNo

public String getRefDocNo()
参照伝票番号を取得します。

戻り値:
refDocNo 参照伝票番号

getRefDocNoLong

public String getRefDocNoLong()
参照伝票番号 (依存性についてはテキスト長参照)を取得します。

戻り値:
refDocNoLong 参照伝票番号 (依存性についてはテキスト長参照)

getVerGrGiSlip

public String getVerGrGiSlip()
入出庫票の印刷バ－ジョンを取得します。

戻り値:
verGrGiSlip 入出庫票の印刷バ－ジョン

getBillOfLading

public String getBillOfLading()
入庫時に登録した B/L 番号を取得します。

戻り値:
billOfLading 入庫時に登録した B/L 番号

getGrGiSlipNo

public String getGrGiSlipNo()
入出庫票番号を取得します。

戻り値:
grGiSlipNo 入出庫票番号

getPrUname

public String getPrUname()
ユーザ名を取得します。

戻り値:
prUname ユーザ名

getVerGrGiSlipx

public String getVerGrGiSlipx()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
verGrGiSlipx 関連ユーザデータ項目の更新情報

getExtWms

public String getExtWms()
外部倉庫管理の転記の制御を取得します。

戻り値:
extWms 外部倉庫管理の転記の制御

getBillOfLadingLong

public String getBillOfLadingLong()
入庫の船荷証券番号 (依存: テキスト (長) 参照)を取得します。

戻り値:
billOfLadingLong 入庫の船荷証券番号 (依存: テキスト (長) 参照)

getBarCode

public String getBarCode()
バーコードエントリを取得します。

戻り値:
barCode バーコードエントリ

getMatDoc

public String getMatDoc()
入出庫伝票番号を取得します。

戻り値:
matDoc 入出庫伝票番号

getDocYear

public String getDocYear()
入出庫伝票年度を取得します。

戻り値:
docYear 入出庫伝票年度

getTrEvType

public String getTrEvType()
トランザクション/イベントタイプを取得します。

戻り値:
trEvType トランザクション/イベントタイプ

getEntryDate

public String getEntryDate()
会計伝票登録日を取得します。

戻り値:
entryDate 会計伝票登録日

getEntryTime

public String getEntryTime()
登録時刻を取得します。

戻り値:
entryTime 登録時刻

getUsername

public String getUsername()
ユーザ名を取得します。

戻り値:
username ユーザ名

getExpimpNo

public String getExpimpNo()
貿易データ番号: MM/SD 伝票を取得します。

戻り値:
expimpNo 貿易データ番号: MM/SD 伝票

setDocDate

public void setDocDate(String docDate)
伝票の伝票日付を設定します。

パラメータ:
docDate - 伝票の伝票日付

setHeaderTxt

public void setHeaderTxt(String headerTxt)
伝票ヘッダテキストを設定します。

パラメータ:
headerTxt - 伝票ヘッダテキスト

setPstngDate

public void setPstngDate(String pstngDate)
伝票の転記日付を設定します。

パラメータ:
pstngDate - 伝票の転記日付

setRefDocNo

public void setRefDocNo(String refDocNo)
参照伝票番号を設定します。

パラメータ:
refDocNo - 参照伝票番号

setRefDocNoLong

public void setRefDocNoLong(String refDocNoLong)
参照伝票番号 (依存性についてはテキスト長参照)を設定します。

パラメータ:
refDocNoLong - 参照伝票番号 (依存性についてはテキスト長参照)

setVerGrGiSlip

public void setVerGrGiSlip(String verGrGiSlip)
入出庫票の印刷バ－ジョンを設定します。

パラメータ:
verGrGiSlip - 入出庫票の印刷バ－ジョン

setBillOfLading

public void setBillOfLading(String billOfLading)
入庫時に登録した B/L 番号を設定します。

パラメータ:
billOfLading - 入庫時に登録した B/L 番号

setGrGiSlipNo

public void setGrGiSlipNo(String grGiSlipNo)
入出庫票番号を設定します。

パラメータ:
grGiSlipNo - 入出庫票番号

setPrUname

public void setPrUname(String prUname)
ユーザ名を設定します。

パラメータ:
prUname - ユーザ名

setVerGrGiSlipx

public void setVerGrGiSlipx(String verGrGiSlipx)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
verGrGiSlipx - 関連ユーザデータ項目の更新情報

setExtWms

public void setExtWms(String extWms)
外部倉庫管理の転記の制御を設定します。

パラメータ:
extWms - 外部倉庫管理の転記の制御

setBillOfLadingLong

public void setBillOfLadingLong(String billOfLadingLong)
入庫の船荷証券番号 (依存: テキスト (長) 参照)を設定します。

パラメータ:
billOfLadingLong - 入庫の船荷証券番号 (依存: テキスト (長) 参照)

setBarCode

public void setBarCode(String barCode)
バーコードエントリを設定します。

パラメータ:
barCode - バーコードエントリ

setMatDoc

public void setMatDoc(String matDoc)
入出庫伝票番号を設定します。

パラメータ:
matDoc - 入出庫伝票番号

setDocYear

public void setDocYear(String docYear)
入出庫伝票年度を設定します。

パラメータ:
docYear - 入出庫伝票年度

setTrEvType

public void setTrEvType(String trEvType)
トランザクション/イベントタイプを設定します。

パラメータ:
trEvType - トランザクション/イベントタイプ

setEntryDate

public void setEntryDate(String entryDate)
会計伝票登録日を設定します。

パラメータ:
entryDate - 会計伝票登録日

setEntryTime

public void setEntryTime(String entryTime)
登録時刻を設定します。

パラメータ:
entryTime - 登録時刻

setUsername

public void setUsername(String username)
ユーザ名を設定します。

パラメータ:
username - ユーザ名

setExpimpNo

public void setExpimpNo(String expimpNo)
貿易データ番号: MM/SD 伝票を設定します。

パラメータ:
expimpNo - 貿易データ番号: MM/SD 伝票

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtHeaderList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス GoodsMvtHeaderList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList
すべての実装インタフェース:
Serializable
public class GoodsMvtHeaderList
extends GoodsMvtHeader
implements Serializable

入出庫伝票明細情報クラス
機能は以下の通り

  • 入出庫伝票明細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GoodsMvtHeaderList()
入出庫伝票明細情報を作成します。
GoodsMvtHeaderList(int index)
入出庫伝票明細情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します。
void | setIndex(int index) レコード番号を設定します。
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader から継承したメソッド
getBarCode, getBillOfLading, getBillOfLadingLong, getDocDate, getDocYear, getEntryDate, getEntryTime, getExpimpNo, getExtWms, getGrGiSlipNo, getHeaderTxt, getMatDoc, getPrUname, getPstngDate, getRefDocNo, getRefDocNoLong, getTrEvType, getUsername, getVerGrGiSlip, getVerGrGiSlipx, setBarCode, setBillOfLading, setBillOfLadingLong, setDocDate, setDocYear, setEntryDate, setEntryTime, setExpimpNo, setExtWms, setGrGiSlipNo, setHeaderTxt, setMatDoc, setPrUname, setPstngDate, setRefDocNo, setRefDocNoLong, setTrEvType, setUsername, setVerGrGiSlip, setVerGrGiSlipx, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtHeaderList

public GoodsMvtHeaderList()
入出庫伝票明細情報を作成します。

GoodsMvtHeaderList

public GoodsMvtHeaderList(int index)
入出庫伝票明細情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtItems (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス GoodsMvtItems

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems
すべての実装インタフェース:
Serializable
public class GoodsMvtItems
extends Object
implements Serializable

入出庫伝票明細情報クラス
機能は以下の通り

  • 入出庫伝票明細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GoodsMvtItems()
入出庫伝票明細情報を作成します。
GoodsMvtItems(int index)
入出庫伝票明細情報を作成します。
メソッドの概要
String | getActivity() 作業番号を取得します。
String | getActtype() 活動タイプを取得します。
String | getAmountLc() マニュアル入力による転記金額 (国内通貨)を取得します。
String | getAmountSv() 外部入力による販売金額 (国内通貨)を取得します。
String | getAssetNo() 資産番号を取得します。
String | getBatch() ロット番号を取得します。
String | getCalcMotive() 計算区分を取得します。
String | getCmmtItem() 資金予算コードを取得します。
String | getCmmtItemLong() 資金予算コードを取得します。
String | getCoBusproc() 業務プロセスを取得します。
String | getCompShip() 出荷指示順守を取得します。
String | getCostcenter() 原価センタを取得します。
String | getCostObj() 原価対象を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO 通貨コードを取得します。
String | getCustomer() 得意先コードを取得します。
String | getDocYear() 入出庫伝票年度を取得します。
String | getEntryQnt() 入力単位での数量を取得します。
String | getEntryUom() 入力単位を取得します。
String | getEntryUomIso() 単位の ISO コードを取得します。
String | getExpirydate() 有効期間期限日を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getFund() 会計区分を取得します。
String | getFundsCtr() 予算センタを取得します。
String | getGrantNbr() 補助金を取得します。
String | getGrRcpt() 受領者を取得します。
int | getIndex() レコード番号を取得します｡
String | getItemText() 明細テキストを取得します。
String | getLineDepth() 伝票での明細行階層レベルを取得します。
String | getLineId() 伝票明細行の一意 IDを取得します。
String | getMatDoc() 入出庫伝票番号を取得します。
String | getMatdocItm() 入出庫伝票の明細を取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getMoveBatch() 入庫/出庫ロットを取得します。
String | getMoveMat() 入庫/出庫品目を取得します。
String | getMoveMatExternal() 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を取得します。
String | getMoveMatGuid() 項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を取得します。
String | getMoveMatVersion() 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を取得します。
String | getMovePlant() 入庫/出庫プラントを取得します。
String | getMoveReas() 移動理由を取得します。
String | getMoveStloc() 入庫/出庫保管場所を取得します。
String | getMoveType() 移動タイプ (在庫管理)を取得します。
String | getMoveValType() 転送ロットの評価タイプを取得します。
String | getMvtInd() 移動区分を取得します。
String | getNetwork() 勘定割当のネットワーク番号を取得します。
String | getNoMoreGr() 納入完了 区分を取得します。
String | getOrderid() 指図番号を取得します。
String | getOrderItno() 指図明細番号を取得します。
String | getOrderprUn() 購買発注価格単位 (購買管理)を取得します。
String | getOrderprUnIso() 単位の ISO コードを取得します。
String | getParentId() 1 レベル上位の行 IDを取得します。
String | getPartAcct() 取引先勘定コードを取得します。
String | getPlant() プラントを取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
String | getPoNumber() 購買発注番号を取得します。
String | getPoPrQnt() 数量 (購買発注価格単位)を取得します。
String | getProdDate() ロット製造日付を取得します。
String | getProfitCtr() 利益センタを取得します。
String | getProfitSegmNo() 収益性セグメント番号 (CO-PA)を取得します。
String | getRefDate() 決済の参照日付を取得します。
String | getRefDoc() 参照伝票の伝票番号を取得します。
String | getRefDocIt() 参照伝票の明細番号を取得します。
String | getRefDocYr() 参照伝票の会計年度を取得します。
String | getReservNo() 入出庫予定/従属所要量の番号を取得します。
String | getResItem() 入出庫予定/従属所要量の明細番号を取得します。
String | getResType() レコードタイプを取得します。
String | getRlEstKey() 不動産管理対象の内部キーを取得します。
String | getSalesOrd() 受注伝票番号を取得します。
String | getSchedLine() 受注納入日程を取得します。
String | getShipping() 出荷指示を取得します。
String | getSOrdItem() 受注明細番号を取得します。
String | getSpecStock() 特殊在庫区分を取得します。
String | getStckType() 在庫タイプを取得します。
String | getStgeLoc() 保管場所を取得します。
String | getSubNumber() 資産補助番号を取得します。
String | getSupplVend() 供給仕入先を取得します。
String | getUnloadPt() 荷渡ポイントを取得します。
String | getValSalesOrd() 評価受注在庫の受注番号を取得します。
String | getValSOrdItem() 評価受注在庫の受注明細を取得します。
String | getValType() 評価タイプを取得します。
String | getValWbsElem() WBS 要素を取得します。
String | getVendor() 仕入先勘定コードを取得します。
String | getWbsElem() WBS 要素を取得します。
String | getWithdrawn() 入出庫予定に対する出庫完了を取得します。
String | getXAutoCre() 自動登録済み明細を取得します。
void | setActivity(String activity) 作業番号を設定します。
void | setActtype(String acttype) 活動タイプを設定します。
void | setAmountLc(String amountLc) マニュアル入力による転記金額 (国内通貨)を設定します。
void | setAmountSv(String amountSv) 外部入力による販売金額 (国内通貨)を設定します。
void | setAssetNo(String assetNo) 資産番号を設定します。
void | setBatch(String batch) ロット番号を設定します。
void | setCalcMotive(String calcMotive) 計算区分を設定します。
void | setCmmtItem(String cmmtItem) 資金予算コードを設定します。
void | setCmmtItemLong(String cmmtItemLong) 資金予算コードを設定します。
void | setCoBusproc(String coBusproc) 業務プロセスを設定します。
void | setCompShip(String compShip) 出荷指示順守を設定します。
void | setCostcenter(String costcenter) 原価センタを設定します。
void | setCostObj(String costObj) 原価対象を設定します。
void | setCurrency(String currency) 通貨コードを設定します。
void | setCurrencyIso(String currencyIso) ISO 通貨コードを設定します。
void | setCustomer(String customer) 得意先コードを設定します。
void | setDocYear(String docYear) 入出庫伝票年度を設定します。
void | setEntryQnt(String entryQnt) 入力単位での数量を設定します。
void | setEntryUom(String entryUom) 入力単位を設定します。
void | setEntryUomIso(String entryUomIso) 単位の ISO コードを設定します。
void | setExpirydate(String expirydate) 有効期間期限日を設定します。
void | setFuncAreaLong(String funcAreaLong) 機能領域を設定します。
void | setFund(String fund) 会計区分を設定します。
void | setFundsCtr(String fundsCtr) 予算センタを設定します。
void | setGrantNbr(String grantNbr) 補助金を設定します。
void | setGrRcpt(String grRcpt) 受領者を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItemText(String itemText) 明細テキストを設定します。
void | setLineDepth(String lineDepth) 伝票での明細行階層レベルを設定します。
void | setLineId(String lineId) 伝票明細行の一意 IDを設定します。
void | setMatDoc(String matDoc) 入出庫伝票番号を設定します。
void | setMatdocItm(String matdocItm) 入出庫伝票の明細を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setMoveBatch(String moveBatch) 入庫/出庫ロットを設定します。
void | setMoveMat(String moveMat) 入庫/出庫品目を設定します。
void | setMoveMatExternal(String moveMatExternal) 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を設定します。
void | setMoveMatGuid(String moveMatGuid) 項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を設定します。
void | setMoveMatVersion(String moveMatVersion) 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を設定します。
void | setMovePlant(String movePlant) 入庫/出庫プラントを設定します。
void | setMoveReas(String moveReas) 移動理由を設定します。
void | setMoveStloc(String moveStloc) 入庫/出庫保管場所を設定します。
void | setMoveType(String moveType) 移動タイプ (在庫管理)を設定します。
void | setMoveValType(String moveValType) 転送ロットの評価タイプを設定します。
void | setMvtInd(String mvtInd) 移動区分を設定します。
void | setNetwork(String network) 勘定割当のネットワーク番号を設定します。
void | setNoMoreGr(String noMoreGr) 納入完了 区分を設定します。
void | setOrderid(String orderid) 指図番号を設定します。
void | setOrderItno(String orderItno) 指図明細番号を設定します。
void | setOrderprUn(String orderprUn) 購買発注価格単位 (購買管理)を設定します。
void | setOrderprUnIso(String orderprUnIso) 単位の ISO コードを設定します。
void | setParentId(String parentId) 1 レベル上位の行 IDを設定します。
void | setPartAcct(String partAcct) 取引先勘定コードを設定します。
void | setPlant(String plant) プラントを設定します。
void | setPoItem(String poItem) 購買伝票の明細番号を設定します。
void | setPoNumber(String poNumber) 購買発注番号を設定します。
void | setPoPrQnt(String poPrQnt) 数量 (購買発注価格単位)を設定します。
void | setProdDate(String prodDate) ロット製造日付を設定します。
void | setProfitCtr(String profitCtr) 利益センタを設定します。
void | setProfitSegmNo(String profitSegmNo) 収益性セグメント番号 (CO-PA)を設定します。
void | setRefDate(String refDate) 決済の参照日付を設定します。
void | setRefDoc(String refDoc) 参照伝票の伝票番号を設定します。
void | setRefDocIt(String refDocIt) 参照伝票の明細番号を設定します。
void | setRefDocYr(String refDocYr) 参照伝票の会計年度を設定します。
void | setReservNo(String reservNo) 入出庫予定/従属所要量の番号を設定します。
void | setResItem(String resItem) 入出庫予定/従属所要量の明細番号を設定します。
void | setResType(String resType) レコードタイプを設定します。
void | setRlEstKey(String rlEstKey) 不動産管理対象の内部キーを設定します。
void | setSalesOrd(String salesOrd) 受注伝票番号を設定します。
void | setSchedLine(String schedLine) 受注納入日程を設定します。
void | setShipping(String shipping) 出荷指示を設定します。
void | setSOrdItem(String sOrdItem) 受注明細番号を設定します。
void | setSpecStock(String specStock) 特殊在庫区分を設定します。
void | setStckType(String stckType) 在庫タイプを設定します。
void | setStgeLoc(String stgeLoc) 保管場所を設定します。
void | setSubNumber(String subNumber) 資産補助番号を設定します。
void | setSupplVend(String supplVend) 供給仕入先を設定します。
void | setUnloadPt(String unloadPt) 荷渡ポイントを設定します。
void | setValSalesOrd(String valSalesOrd) 評価受注在庫の受注番号を設定します。
void | setValSOrdItem(String valSOrdItem) 評価受注在庫の受注明細を設定します。
void | setValType(String valType) 評価タイプを設定します。
void | setValWbsElem(String valWbsElem) WBS 要素を設定します。
void | setVendor(String vendor) 仕入先勘定コードを設定します。
void | setWbsElem(String wbsElem) WBS 要素を設定します。
void | setWithdrawn(String withdrawn) 入出庫予定に対する出庫完了を設定します。
void | setXAutoCre(String xAutoCre) 自動登録済み明細を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtItems

public GoodsMvtItems()
入出庫伝票明細情報を作成します。

GoodsMvtItems

public GoodsMvtItems(int index)
入出庫伝票明細情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getActivity

public String getActivity()
作業番号を取得します。

戻り値:
activity 作業番号

getActtype

public String getActtype()
活動タイプを取得します。

戻り値:
acttype 活動タイプ

getAmountLc

public String getAmountLc()
マニュアル入力による転記金額 (国内通貨)を取得します。

戻り値:
amountLc マニュアル入力による転記金額 (国内通貨)

getAmountSv

public String getAmountSv()
外部入力による販売金額 (国内通貨)を取得します。

戻り値:
amountSv 外部入力による販売金額 (国内通貨)

getAssetNo

public String getAssetNo()
資産番号を取得します。

戻り値:
assetNo 資産番号

getBatch

public String getBatch()
ロット番号を取得します。

戻り値:
batch ロット番号

getCalcMotive

public String getCalcMotive()
計算区分を取得します。

戻り値:
calcMotive 計算区分

getCmmtItem

public String getCmmtItem()
資金予算コードを取得します。

戻り値:
cmmtItem 資金予算コード

getCmmtItemLong

public String getCmmtItemLong()
資金予算コードを取得します。

戻り値:
cmmtItemLong 資金予算コード

getCoBusproc

public String getCoBusproc()
業務プロセスを取得します。

戻り値:
coBusproc 業務プロセス

getCompShip

public String getCompShip()
出荷指示順守を取得します。

戻り値:
compShip 出荷指示順守

getCostObj

public String getCostObj()
原価対象を取得します。

戻り値:
costObj 原価対象

getCostcenter

public String getCostcenter()
原価センタを取得します。

戻り値:
costcenter 原価センタ

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
currency 通貨コード

getCurrencyIso

public String getCurrencyIso()
ISO 通貨コードを取得します。

戻り値:
currencyIso ISO 通貨コード

getCustomer

public String getCustomer()
得意先コードを取得します。

戻り値:
customer 得意先コード

getDocYear

public String getDocYear()
入出庫伝票年度を取得します。

戻り値:
docYear 入出庫伝票年度

getEntryQnt

public String getEntryQnt()
入力単位での数量を取得します。

戻り値:
entryQnt 入力単位での数量

getEntryUom

public String getEntryUom()
入力単位を取得します。

戻り値:
entryUom 入力単位

getEntryUomIso

public String getEntryUomIso()
単位の ISO コードを取得します。

戻り値:
entryUomIso 単位の ISO コード

getExpirydate

public String getExpirydate()
有効期間期限日を取得します。

戻り値:
expirydate 有効期間期限日

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
funcAreaLong 機能領域

getFund

public String getFund()
会計区分を取得します。

戻り値:
fund 会計区分

getFundsCtr

public String getFundsCtr()
予算センタを取得します。

戻り値:
fundsCtr 予算センタ

getGrRcpt

public String getGrRcpt()
受領者を取得します。

戻り値:
grRcpt 受領者

getGrantNbr

public String getGrantNbr()
補助金を取得します。

戻り値:
grantNbr 補助金

getItemText

public String getItemText()
明細テキストを取得します。

戻り値:
itemText 明細テキスト

getLineDepth

public String getLineDepth()
伝票での明細行階層レベルを取得します。

戻り値:
lineDepth 伝票での明細行階層レベル

getLineId

public String getLineId()
伝票明細行の一意 IDを取得します。

戻り値:
lineId 伝票明細行の一意 ID

getMatDoc

public String getMatDoc()
入出庫伝票番号を取得します。

戻り値:
matDoc 入出庫伝票番号

getMatdocItm

public String getMatdocItm()
入出庫伝票の明細を取得します。

戻り値:
matdocItm 入出庫伝票の明細

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getMoveBatch

public String getMoveBatch()
入庫/出庫ロットを取得します。

戻り値:
moveBatch 入庫/出庫ロット

getMoveMat

public String getMoveMat()
入庫/出庫品目を取得します。

戻り値:
moveMat 入庫/出庫品目

getMoveMatExternal

public String getMoveMatExternal()
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
moveMatExternal 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)

getMoveMatGuid

public String getMoveMatGuid()
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
moveMatGuid 項目 MOVE_MAT の外部 GUID (今後のリリースで開発)

getMoveMatVersion

public String getMoveMatVersion()
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
moveMatVersion 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)

getMovePlant

public String getMovePlant()
入庫/出庫プラントを取得します。

戻り値:
movePlant 入庫/出庫プラント

getMoveReas

public String getMoveReas()
移動理由を取得します。

戻り値:
moveReas 移動理由

getMoveStloc

public String getMoveStloc()
入庫/出庫保管場所を取得します。

戻り値:
moveStloc 入庫/出庫保管場所

getMoveType

public String getMoveType()
移動タイプ (在庫管理)を取得します。

戻り値:
moveType 移動タイプ (在庫管理)

getMoveValType

public String getMoveValType()
転送ロットの評価タイプを取得します。

戻り値:
moveValType 転送ロットの評価タイプ

getMvtInd

public String getMvtInd()
移動区分を取得します。

戻り値:
mvtInd 移動区分

getNetwork

public String getNetwork()
勘定割当のネットワーク番号を取得します。

戻り値:
network 勘定割当のネットワーク番号

getNoMoreGr

public String getNoMoreGr()
納入完了 区分を取得します。

戻り値:
noMoreGr 納入完了 区分

getOrderItno

public String getOrderItno()
指図明細番号を取得します。

戻り値:
orderItno 指図明細番号

getOrderid

public String getOrderid()
指図番号を取得します。

戻り値:
orderid 指図番号

getOrderprUn

public String getOrderprUn()
購買発注価格単位 (購買管理)を取得します。

戻り値:
orderprUn 購買発注価格単位 (購買管理)

getOrderprUnIso

public String getOrderprUnIso()
単位の ISO コードを取得します。

戻り値:
orderprUnIso 単位の ISO コード

getParentId

public String getParentId()
1 レベル上位の行 IDを取得します。

戻り値:
parentId 1 レベル上位の行 ID

getPartAcct

public String getPartAcct()
取引先勘定コードを取得します。

戻り値:
partAcct 取引先勘定コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
poItem 購買伝票の明細番号

getPoNumber

public String getPoNumber()
購買発注番号を取得します。

戻り値:
poNumber 購買発注番号

getPoPrQnt

public String getPoPrQnt()
数量 (購買発注価格単位)を取得します。

戻り値:
poPrQnt 数量 (購買発注価格単位)

getProdDate

public String getProdDate()
ロット製造日付を取得します。

戻り値:
prodDate ロット製造日付

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
profitCtr 利益センタ

getProfitSegmNo

public String getProfitSegmNo()
収益性セグメント番号 (CO-PA)を取得します。

戻り値:
profitSegmNo 収益性セグメント番号 (CO-PA)

getRefDate

public String getRefDate()
決済の参照日付を取得します。

戻り値:
refDate 決済の参照日付

getRefDoc

public String getRefDoc()
参照伝票の伝票番号を取得します。

戻り値:
refDoc 参照伝票の伝票番号

getRefDocIt

public String getRefDocIt()
参照伝票の明細番号を取得します。

戻り値:
refDocIt 参照伝票の明細番号

getRefDocYr

public String getRefDocYr()
参照伝票の会計年度を取得します。

戻り値:
refDocYr 参照伝票の会計年度

getResItem

public String getResItem()
入出庫予定/従属所要量の明細番号を取得します。

戻り値:
resItem 入出庫予定/従属所要量の明細番号

getResType

public String getResType()
レコードタイプを取得します。

戻り値:
resType レコードタイプ

getReservNo

public String getReservNo()
入出庫予定/従属所要量の番号を取得します。

戻り値:
reservNo 入出庫予定/従属所要量の番号

getRlEstKey

public String getRlEstKey()
不動産管理対象の内部キーを取得します。

戻り値:
rlEstKey 不動産管理対象の内部キー

getSOrdItem

public String getSOrdItem()
受注明細番号を取得します。

戻り値:
sOrdItem 受注明細番号

getSalesOrd

public String getSalesOrd()
受注伝票番号を取得します。

戻り値:
salesOrd 受注伝票番号

getSchedLine

public String getSchedLine()
受注納入日程を取得します。

戻り値:
schedLine 受注納入日程

getShipping

public String getShipping()
出荷指示を取得します。

戻り値:
shipping 出荷指示

getSpecStock

public String getSpecStock()
特殊在庫区分を取得します。

戻り値:
specStock 特殊在庫区分

getStckType

public String getStckType()
在庫タイプを取得します。

戻り値:
stckType 在庫タイプ

getStgeLoc

public String getStgeLoc()
保管場所を取得します。

戻り値:
stgeLoc 保管場所

getSubNumber

public String getSubNumber()
資産補助番号を取得します。

戻り値:
subNumber 資産補助番号

getSupplVend

public String getSupplVend()
供給仕入先を取得します。

戻り値:
supplVend 供給仕入先

getUnloadPt

public String getUnloadPt()
荷渡ポイントを取得します。

戻り値:
unloadPt 荷渡ポイント

getValSOrdItem

public String getValSOrdItem()
評価受注在庫の受注明細を取得します。

戻り値:
valSOrdItem 評価受注在庫の受注明細

getValSalesOrd

public String getValSalesOrd()
評価受注在庫の受注番号を取得します。

戻り値:
valSalesOrd 評価受注在庫の受注番号

getValType

public String getValType()
評価タイプを取得します。

戻り値:
valType 評価タイプ

getValWbsElem

public String getValWbsElem()
WBS 要素を取得します。

戻り値:
valWbsElem WBS 要素

getVendor

public String getVendor()
仕入先勘定コードを取得します。

戻り値:
vendor 仕入先勘定コード

getWbsElem

public String getWbsElem()
WBS 要素を取得します。

戻り値:
wbsElem WBS 要素

getWithdrawn

public String getWithdrawn()
入出庫予定に対する出庫完了を取得します。

戻り値:
withdrawn 入出庫予定に対する出庫完了

getXAutoCre

public String getXAutoCre()
自動登録済み明細を取得します。

戻り値:
xAutoCre 自動登録済み明細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setActivity

public void setActivity(String activity)
作業番号を設定します。

パラメータ:
activity - 作業番号

setActtype

public void setActtype(String acttype)
活動タイプを設定します。

パラメータ:
acttype - 活動タイプ

setAmountLc

public void setAmountLc(String amountLc)
マニュアル入力による転記金額 (国内通貨)を設定します。

パラメータ:
amountLc - マニュアル入力による転記金額 (国内通貨)

setAmountSv

public void setAmountSv(String amountSv)
外部入力による販売金額 (国内通貨)を設定します。

パラメータ:
amountSv - 外部入力による販売金額 (国内通貨)

setAssetNo

public void setAssetNo(String assetNo)
資産番号を設定します。

パラメータ:
assetNo - 資産番号

setBatch

public void setBatch(String batch)
ロット番号を設定します。

パラメータ:
batch - ロット番号

setCalcMotive

public void setCalcMotive(String calcMotive)
計算区分を設定します。

パラメータ:
calcMotive - 計算区分

setCmmtItem

public void setCmmtItem(String cmmtItem)
資金予算コードを設定します。

パラメータ:
cmmtItem - 資金予算コード

setCmmtItemLong

public void setCmmtItemLong(String cmmtItemLong)
資金予算コードを設定します。

パラメータ:
cmmtItemLong - 資金予算コード

setCoBusproc

public void setCoBusproc(String coBusproc)
業務プロセスを設定します。

パラメータ:
coBusproc - 業務プロセス

setCompShip

public void setCompShip(String compShip)
出荷指示順守を設定します。

パラメータ:
compShip - 出荷指示順守

setCostObj

public void setCostObj(String costObj)
原価対象を設定します。

パラメータ:
costObj - 原価対象

setCostcenter

public void setCostcenter(String costcenter)
原価センタを設定します。

パラメータ:
costcenter - 原価センタ

setCurrency

public void setCurrency(String currency)
通貨コードを設定します。

パラメータ:
currency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String currencyIso)
ISO 通貨コードを設定します。

パラメータ:
currencyIso - ISO 通貨コード

setCustomer

public void setCustomer(String customer)
得意先コードを設定します。

パラメータ:
customer - 得意先コード

setDocYear

public void setDocYear(String docYear)
入出庫伝票年度を設定します。

パラメータ:
docYear - 入出庫伝票年度

setEntryQnt

public void setEntryQnt(String entryQnt)
入力単位での数量を設定します。

パラメータ:
entryQnt - 入力単位での数量

setEntryUom

public void setEntryUom(String entryUom)
入力単位を設定します。

パラメータ:
entryUom - 入力単位

setEntryUomIso

public void setEntryUomIso(String entryUomIso)
単位の ISO コードを設定します。

パラメータ:
entryUomIso - 単位の ISO コード

setExpirydate

public void setExpirydate(String expirydate)
有効期間期限日を設定します。

パラメータ:
expirydate - 有効期間期限日

setFuncAreaLong

public void setFuncAreaLong(String funcAreaLong)
機能領域を設定します。

パラメータ:
funcAreaLong - 機能領域

setFund

public void setFund(String fund)
会計区分を設定します。

パラメータ:
fund - 会計区分

setFundsCtr

public void setFundsCtr(String fundsCtr)
予算センタを設定します。

パラメータ:
fundsCtr - 予算センタ

setGrRcpt

public void setGrRcpt(String grRcpt)
受領者を設定します。

パラメータ:
grRcpt - 受領者

setGrantNbr

public void setGrantNbr(String grantNbr)
補助金を設定します。

パラメータ:
grantNbr - 補助金

setItemText

public void setItemText(String itemText)
明細テキストを設定します。

パラメータ:
itemText - 明細テキスト

setLineDepth

public void setLineDepth(String lineDepth)
伝票での明細行階層レベルを設定します。

パラメータ:
lineDepth - 伝票での明細行階層レベル

setLineId

public void setLineId(String lineId)
伝票明細行の一意 IDを設定します。

パラメータ:
lineId - 伝票明細行の一意 ID

setMatDoc

public void setMatDoc(String matDoc)
入出庫伝票番号を設定します。

パラメータ:
matDoc - 入出庫伝票番号

setMatdocItm

public void setMatdocItm(String matdocItm)
入出庫伝票の明細を設定します。

パラメータ:
matdocItm - 入出庫伝票の明細

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setMoveBatch

public void setMoveBatch(String moveBatch)
入庫/出庫ロットを設定します。

パラメータ:
moveBatch - 入庫/出庫ロット

setMoveMat

public void setMoveMat(String moveMat)
入庫/出庫品目を設定します。

パラメータ:
moveMat - 入庫/出庫品目

setMoveMatExternal

public void setMoveMatExternal(String moveMatExternal)
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
moveMatExternal - 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)

setMoveMatGuid

public void setMoveMatGuid(String moveMatGuid)
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
moveMatGuid - 項目 MOVE_MAT の外部 GUID (今後のリリースで開発)

setMoveMatVersion

public void setMoveMatVersion(String moveMatVersion)
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
moveMatVersion - 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)

setMovePlant

public void setMovePlant(String movePlant)
入庫/出庫プラントを設定します。

パラメータ:
movePlant - 入庫/出庫プラント

setMoveReas

public void setMoveReas(String moveReas)
移動理由を設定します。

パラメータ:
moveReas - 移動理由

setMoveStloc

public void setMoveStloc(String moveStloc)
入庫/出庫保管場所を設定します。

パラメータ:
moveStloc - 入庫/出庫保管場所

setMoveType

public void setMoveType(String moveType)
移動タイプ (在庫管理)を設定します。

パラメータ:
moveType - 移動タイプ (在庫管理)

setMoveValType

public void setMoveValType(String moveValType)
転送ロットの評価タイプを設定します。

パラメータ:
moveValType - 転送ロットの評価タイプ

setMvtInd

public void setMvtInd(String mvtInd)
移動区分を設定します。

パラメータ:
mvtInd - 移動区分

setNetwork

public void setNetwork(String network)
勘定割当のネットワーク番号を設定します。

パラメータ:
network - 勘定割当のネットワーク番号

setNoMoreGr

public void setNoMoreGr(String noMoreGr)
納入完了 区分を設定します。

パラメータ:
noMoreGr - 納入完了 区分

setOrderItno

public void setOrderItno(String orderItno)
指図明細番号を設定します。

パラメータ:
orderItno - 指図明細番号

setOrderid

public void setOrderid(String orderid)
指図番号を設定します。

パラメータ:
orderid - 指図番号

setOrderprUn

public void setOrderprUn(String orderprUn)
購買発注価格単位 (購買管理)を設定します。

パラメータ:
orderprUn - 購買発注価格単位 (購買管理)

setOrderprUnIso

public void setOrderprUnIso(String orderprUnIso)
単位の ISO コードを設定します。

パラメータ:
orderprUnIso - 単位の ISO コード

setParentId

public void setParentId(String parentId)
1 レベル上位の行 IDを設定します。

パラメータ:
parentId - 1 レベル上位の行 ID

setPartAcct

public void setPartAcct(String partAcct)
取引先勘定コードを設定します。

パラメータ:
partAcct - 取引先勘定コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setPoItem

public void setPoItem(String poItem)
購買伝票の明細番号を設定します。

パラメータ:
poItem - 購買伝票の明細番号

setPoNumber

public void setPoNumber(String poNumber)
購買発注番号を設定します。

パラメータ:
poNumber - 購買発注番号

setPoPrQnt

public void setPoPrQnt(String poPrQnt)
数量 (購買発注価格単位)を設定します。

パラメータ:
poPrQnt - 数量 (購買発注価格単位)

setProdDate

public void setProdDate(String prodDate)
ロット製造日付を設定します。

パラメータ:
prodDate - ロット製造日付

setProfitCtr

public void setProfitCtr(String profitCtr)
利益センタを設定します。

パラメータ:
profitCtr - 利益センタ

setProfitSegmNo

public void setProfitSegmNo(String profitSegmNo)
収益性セグメント番号 (CO-PA)を設定します。

パラメータ:
profitSegmNo - 収益性セグメント番号 (CO-PA)

setRefDate

public void setRefDate(String refDate)
決済の参照日付を設定します。

パラメータ:
refDate - 決済の参照日付

setRefDoc

public void setRefDoc(String refDoc)
参照伝票の伝票番号を設定します。

パラメータ:
refDoc - 参照伝票の伝票番号

setRefDocIt

public void setRefDocIt(String refDocIt)
参照伝票の明細番号を設定します。

パラメータ:
refDocIt - 参照伝票の明細番号

setRefDocYr

public void setRefDocYr(String refDocYr)
参照伝票の会計年度を設定します。

パラメータ:
refDocYr - 参照伝票の会計年度

setResItem

public void setResItem(String resItem)
入出庫予定/従属所要量の明細番号を設定します。

パラメータ:
resItem - 入出庫予定/従属所要量の明細番号

setResType

public void setResType(String resType)
レコードタイプを設定します。

パラメータ:
resType - レコードタイプ

setReservNo

public void setReservNo(String reservNo)
入出庫予定/従属所要量の番号を設定します。

パラメータ:
reservNo - 入出庫予定/従属所要量の番号

setRlEstKey

public void setRlEstKey(String rlEstKey)
不動産管理対象の内部キーを設定します。

パラメータ:
rlEstKey - 不動産管理対象の内部キー

setSOrdItem

public void setSOrdItem(String sOrdItem)
受注明細番号を設定します。

パラメータ:
sOrdItem - 受注明細番号

setSalesOrd

public void setSalesOrd(String salesOrd)
受注伝票番号を設定します。

パラメータ:
salesOrd - 受注伝票番号

setSchedLine

public void setSchedLine(String schedLine)
受注納入日程を設定します。

パラメータ:
schedLine - 受注納入日程

setShipping

public void setShipping(String shipping)
出荷指示を設定します。

パラメータ:
shipping - 出荷指示

setSpecStock

public void setSpecStock(String specStock)
特殊在庫区分を設定します。

パラメータ:
specStock - 特殊在庫区分

setStckType

public void setStckType(String stckType)
在庫タイプを設定します。

パラメータ:
stckType - 在庫タイプ

setStgeLoc

public void setStgeLoc(String stgeLoc)
保管場所を設定します。

パラメータ:
stgeLoc - 保管場所

setSubNumber

public void setSubNumber(String subNumber)
資産補助番号を設定します。

パラメータ:
subNumber - 資産補助番号

setSupplVend

public void setSupplVend(String supplVend)
供給仕入先を設定します。

パラメータ:
supplVend - 供給仕入先

setUnloadPt

public void setUnloadPt(String unloadPt)
荷渡ポイントを設定します。

パラメータ:
unloadPt - 荷渡ポイント

setValSOrdItem

public void setValSOrdItem(String valSOrdItem)
評価受注在庫の受注明細を設定します。

パラメータ:
valSOrdItem - 評価受注在庫の受注明細

setValSalesOrd

public void setValSalesOrd(String valSalesOrd)
評価受注在庫の受注番号を設定します。

パラメータ:
valSalesOrd - 評価受注在庫の受注番号

setValType

public void setValType(String valType)
評価タイプを設定します。

パラメータ:
valType - 評価タイプ

setValWbsElem

public void setValWbsElem(String valWbsElem)
WBS 要素を設定します。

パラメータ:
valWbsElem - WBS 要素

setVendor

public void setVendor(String vendor)
仕入先勘定コードを設定します。

パラメータ:
vendor - 仕入先勘定コード

setWbsElem

public void setWbsElem(String wbsElem)
WBS 要素を設定します。

パラメータ:
wbsElem - WBS 要素

setWithdrawn

public void setWithdrawn(String withdrawn)
入出庫予定に対する出庫完了を設定します。

パラメータ:
withdrawn - 入出庫予定に対する出庫完了

setXAutoCre

public void setXAutoCre(String xAutoCre)
自動登録済み明細を設定します。

パラメータ:
xAutoCre - 自動登録済み明細

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialDescription (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス MaterialDescription

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription
すべての実装インタフェース:
Serializable
public class MaterialDescription
extends Object
implements Serializable

品目テキスト情報クラス
機能は以下の通り

  • 品目テキスト情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MaterialDescription()
品目テキスト情報を作成します。
MaterialDescription(int index)
品目テキスト情報を作成します。
メソッドの概要
String | getDelFlag() データレコード削除 (テーブル繰返し)を取得します。
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getLangu() 言語キーを取得します。
String | getLanguIso() ISO 639 準拠の言語を取得します。
String | getMaterial() 品目コードを取得します。
String | getMatlDesc() 品目テキストを取得します。
void | setDelFlag(String delFlag) データレコード削除 (テーブル繰返し)を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLangu(String langu) 言語キーを設定します。
void | setLanguIso(String languIso) ISO 639 準拠の言語を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMatlDesc(String matlDesc) 品目テキストを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialDescription

public MaterialDescription()
品目テキスト情報を作成します。

MaterialDescription

public MaterialDescription(int index)
品目テキスト情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
langu 言語キー

getLanguIso

public String getLanguIso()
ISO 639 準拠の言語を取得します。

戻り値:
languIso ISO 639 準拠の言語

getMatlDesc

public String getMatlDesc()
品目テキストを取得します。

戻り値:
matlDesc 品目テキスト

getDelFlag

public String getDelFlag()
データレコード削除 (テーブル繰返し)を取得します。

戻り値:
delFlag データレコード削除 (テーブル繰返し)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setLangu

public void setLangu(String langu)
言語キーを設定します。

パラメータ:
langu - 言語キー

setLanguIso

public void setLanguIso(String languIso)
ISO 639 準拠の言語を設定します。

パラメータ:
languIso - ISO 639 準拠の言語

setMatlDesc

public void setMatlDesc(String matlDesc)
品目テキストを設定します。

パラメータ:
matlDesc - 品目テキスト

setDelFlag

public void setDelFlag(String delFlag)
データレコード削除 (テーブル繰返し)を設定します。

パラメータ:
delFlag - データレコード削除 (テーブル繰返し)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.purchase.common.model (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス
ClientData
ClientDataList
ForecastParameters
ForecastParametersList
GoodsMvtHeader
GoodsMvtHeaderList
GoodsMvtItems
MaterialDescription
ParamGoodsMvtHeader
ParamGoodsMvtHeaderList
ParamGoodsMvtItems
PlanningData
PlanningDataList
PlantData
PlantDataList
SalesData
SalesDataList
StorageLocationData
StorageLocationDataList
StorageTypeData
StorageTypeDataList
TaxClassifications
UnitSofmeasure
ValuationData
ValuationDataList
WarehouseNumberData
WarehouseNumberDataList


jp.co.intra_mart.foundation.sap.module.purchase.common.model (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.common.model

クラスの概要
ClientData | 品目データ (クライアントレベル)情報クラス 機能は以下の通り 品目データ (クライアントレベル)情報を保持します。
ClientDataList | 品目データ (クライアントレベル)情報クラス 機能は以下の通り 品目データ (クライアントレベル)情報をテーブル型で保持します。
ForecastParameters | 予測パラメータ情報クラス 機能は以下の通り 予測パラメータ情報を保持します。
ForecastParametersList | 需要予測パラメータ情報クラス 機能は以下の通り 需要予測パラメータ情報をテーブル型で保持します。
GoodsMvtHeader | 入出庫伝票ヘッダデータ情報クラス 機能は以下の通り 入出庫伝票ヘッダデータ情報を保持します。
GoodsMvtHeaderList | 入出庫伝票明細情報クラス 機能は以下の通り 入出庫伝票明細情報を保持します。
GoodsMvtItems | 入出庫伝票明細情報クラス 機能は以下の通り 入出庫伝票明細情報を保持します。
MaterialDescription | 品目テキスト情報クラス 機能は以下の通り 品目テキスト情報を保持します。
ParamGoodsMvtHeader | 入出庫伝票ヘッダデータ設定クラス 機能は以下の通り 入出庫伝票ヘッダデータのパラメータを設定します。
ParamGoodsMvtHeaderList | リターン構造、入出庫伝票ヘッダパラメータ設定クラス 機能は以下の通り リターン構造、入出庫伝票ヘッダのパラメータを設定します。
ParamGoodsMvtItems | リターン構造、入出庫伝票明細パラメータ設定クラス 機能は以下の通り リターン構造、入出庫伝票明細のパラメータを設定します。
PlanningData | 品目マスタ/製品グループの変更伝票構造情報クラス 機能は以下の通り 品目マスタ/製品グループの変更伝票構造情報を保持します。
PlanningDataList | 品目マスタ/製品グループの変更伝票構造情報クラス 機能は以下の通り 品目マスタ/製品グループの変更伝票構造情報を保持します。
PlantData | 品目データ (プラントレベル)情報クラス 機能は以下の通り 品目データ (プラントレベル)情報を保持します。
PlantDataList | 品目データ (プラントレベル)情報クラス 機能は以下の通り 品目データ (プラントレベル)情報をテーブル型で保持します。
SalesData | 販売データ情報クラス 機能は以下の通り 販売データ情報を保持します。
SalesDataList | 販売データ情報クラス 機能は以下の通り 販売データ情報をテーブル型で保持します。
StorageLocationData | 品目データ (保管場所レベル)情報クラス 機能は以下の通り 品目データ (保管場所レベル)情報を保持します。
StorageLocationDataList | 品目データ (保管場所レベル)情報クラス 機能は以下の通り 品目データ (保管場所レベル)情報をテーブル型で保持します。
StorageTypeData | 保管域タイプデータ情報クラス 機能は以下の通り 保管域タイプデータ情報を保持します。
StorageTypeDataList | 保管域タイプデータ情報クラス 機能は以下の通り 保管域タイプデータ情報をテーブル型で保持します。
TaxClassifications | 制御デ－タ情報クラス 機能は以下の通り 制御デ－タ情報を保持します。
UnitSofmeasure | 数量単位情報クラス 機能は以下の通り 数量単位情報を保持します。
ValuationData | 評価データ情報クラス 機能は以下の通り 評価データ情報を保持します。
ValuationDataList | 評価データ情報クラス 機能は以下の通り 評価データ情報をテーブル型で保持します。
WarehouseNumberData | 倉庫番号データ情報クラス 機能は以下の通り 倉庫番号データ情報を保持します。
WarehouseNumberDataList | 倉庫番号データ情報クラス 機能は以下の通り 倉庫番号データ情報をテーブル型で保持します。


jp.co.intra_mart.foundation.sap.module.purchase.common.model クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.common.model の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.purchase.common.model の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.common.model |
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall |

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.purchase.common.model のクラス
ClientDataList
品目データ (クライアントレベル)情報クラス
機能は以下の通り
品目データ (クライアントレベル)情報をテーブル型で保持します。
ForecastParametersList
需要予測パラメータ情報クラス
機能は以下の通り
需要予測パラメータ情報をテーブル型で保持します。
MaterialDescription
品目テキスト情報クラス
機能は以下の通り
品目テキスト情報を保持します。
PlanningDataList
品目マスタ/製品グループの変更伝票構造情報クラス
機能は以下の通り
品目マスタ/製品グループの変更伝票構造情報を保持します。
PlantDataList
品目データ (プラントレベル)情報クラス
機能は以下の通り
品目データ (プラントレベル)情報をテーブル型で保持します。
SalesDataList
販売データ情報クラス
機能は以下の通り
販売データ情報をテーブル型で保持します。
StorageLocationDataList
品目データ (保管場所レベル)情報クラス
機能は以下の通り
品目データ (保管場所レベル)情報をテーブル型で保持します。
StorageTypeDataList
保管域タイプデータ情報クラス
機能は以下の通り
保管域タイプデータ情報をテーブル型で保持します。
TaxClassifications
制御デ－タ情報クラス
機能は以下の通り
制御デ－タ情報を保持します。
UnitSofmeasure
数量単位情報クラス
機能は以下の通り
数量単位情報を保持します。
ValuationDataList
評価データ情報クラス
機能は以下の通り
評価データ情報をテーブル型で保持します。
WarehouseNumberDataList
倉庫番号データ情報クラス
機能は以下の通り
倉庫番号データ情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.common.model により使用される jp.co.intra_mart.foundation.sap.module.purchase.common.model のクラス
ClientData
品目データ (クライアントレベル)情報クラス
機能は以下の通り
品目データ (クライアントレベル)情報を保持します。
ForecastParameters
予測パラメータ情報クラス
機能は以下の通り
予測パラメータ情報を保持します。
GoodsMvtHeader
入出庫伝票ヘッダデータ情報クラス
機能は以下の通り
入出庫伝票ヘッダデータ情報を保持します。
PlanningData
品目マスタ/製品グループの変更伝票構造情報クラス
機能は以下の通り
品目マスタ/製品グループの変更伝票構造情報を保持します。
PlantData
品目データ (プラントレベル)情報クラス
機能は以下の通り
品目データ (プラントレベル)情報を保持します。
SalesData
販売データ情報クラス
機能は以下の通り
販売データ情報を保持します。
StorageLocationData
品目データ (保管場所レベル)情報クラス
機能は以下の通り
品目データ (保管場所レベル)情報を保持します。
StorageTypeData
保管域タイプデータ情報クラス
機能は以下の通り
保管域タイプデータ情報を保持します。
ValuationData
評価データ情報クラス
機能は以下の通り
評価データ情報を保持します。
WarehouseNumberData
倉庫番号データ情報クラス
機能は以下の通り
倉庫番号データ情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate により使用される jp.co.intra_mart.foundation.sap.module.purchase.common.model のクラス
GoodsMvtHeader
入出庫伝票ヘッダデータ情報クラス
機能は以下の通り
入出庫伝票ヘッダデータ情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall により使用される jp.co.intra_mart.foundation.sap.module.purchase.common.model のクラス
ClientData
品目データ (クライアントレベル)情報クラス
機能は以下の通り
品目データ (クライアントレベル)情報を保持します。
ForecastParameters
予測パラメータ情報クラス
機能は以下の通り
予測パラメータ情報を保持します。
PlanningData
品目マスタ/製品グループの変更伝票構造情報クラス
機能は以下の通り
品目マスタ/製品グループの変更伝票構造情報を保持します。
PlantData
品目データ (プラントレベル)情報クラス
機能は以下の通り
品目データ (プラントレベル)情報を保持します。
SalesData
販売データ情報クラス
機能は以下の通り
販売データ情報を保持します。
StorageLocationData
品目データ (保管場所レベル)情報クラス
機能は以下の通り
品目データ (保管場所レベル)情報を保持します。
StorageTypeData
保管域タイプデータ情報クラス
機能は以下の通り
保管域タイプデータ情報を保持します。
ValuationData
評価データ情報クラス
機能は以下の通り
評価データ情報を保持します。
WarehouseNumberData
倉庫番号データ情報クラス
機能は以下の通り
倉庫番号データ情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamGoodsMvtHeader (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ParamGoodsMvtHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader
すべての実装インタフェース:
Serializable
public final class ParamGoodsMvtHeader
extends Object
implements Serializable

入出庫伝票ヘッダデータ設定クラス
機能は以下の通り

  • 入出庫伝票ヘッダデータのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List goodsMvtHeaderList) table(Export)情報から入出庫伝票ヘッダデータの値をセットします。
static void | setImportParam(BapiController bapiController, GoodsMvtHeader goodsMvtHeader) 入出庫伝票ヘッダデータに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  GoodsMvtHeader goodsMvtHeader)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
入出庫伝票ヘッダデータに値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtHeader - GoodsMvtHeadrer
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List goodsMvtHeaderList)
                           throws SAPGeneralSystemException
table(Export)情報から入出庫伝票ヘッダデータの値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtHeaderList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamGoodsMvtHeaderList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ParamGoodsMvtHeaderList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList
すべての実装インタフェース:
Serializable
public final class ParamGoodsMvtHeaderList
extends Object
implements Serializable

リターン構造、入出庫伝票ヘッダパラメータ設定クラス
機能は以下の通り

  • リターン構造、入出庫伝票ヘッダのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List goodsMvtHeaderList) table(Export)情報から入出庫伝票ヘッダデータの値をセットします。
static void | setImportParam(BapiController bapiController, List goodsMvtHeaderList) リターン構造、入出庫伝票ヘッダに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List goodsMvtHeaderList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
リターン構造、入出庫伝票ヘッダに値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtHeaderList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List goodsMvtHeaderList)
                           throws SAPGeneralSystemException
table(Export)情報から入出庫伝票ヘッダデータの値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtHeaderList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamGoodsMvtItems (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ParamGoodsMvtItems

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems
すべての実装インタフェース:
Serializable
public final class ParamGoodsMvtItems
extends Object
implements Serializable

リターン構造、入出庫伝票明細パラメータ設定クラス
機能は以下の通り

  • リターン構造、入出庫伝票明細のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List goodsMvtItemsList) table(Export)情報からリターン構造、入出庫伝票明細の値をセットします。
static void | setImportParam(BapiController bapiController, List goodsMvtItemsList) リターン構造、入出庫伝票明細に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List goodsMvtItemsList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
リターン構造、入出庫伝票明細に値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtItemsList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List goodsMvtItemsList)
                           throws SAPGeneralSystemException
table(Export)情報からリターン構造、入出庫伝票明細の値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtItemsList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PlanningData (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス PlanningData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
PlanningDataList
public class PlanningData
extends Object
implements Serializable

品目マスタ/製品グループの変更伝票構造情報クラス
機能は以下の通り

  • 品目マスタ/製品グループの変更伝票構造情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PlanningData()
品目マスタ/製品グループの変更伝票構造情報を作成します。
メソッドの概要
String | getConvfactor() 計画品目用変換係数を取得します。
String | getFunction() BAPI 機能を取得します。
String | getMaterial() 品目コードを取得します。
String | getPlant() プラントを取得します。
String | getPlngMatl() 計画品目を取得します。
String | getPlngMatlExternal() 項目 PLNG_MATL の品目コード (長) (今後のリリースで開発)を取得します。
String | getPlngMatlGuid() 項目 PLNG_MATL の外部 GUID (今後のリリースで開発)を取得します。
String | getPlngMatlVersion() 項目 PLNG_MATL のバージョン番号 (今後のリリースで開発)を取得します。
String | getPlngPlant() 計画プラントを取得します。
void | setConvfactor(String convfactor) 計画品目用変換係数を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setPlant(String plant) プラントを設定します。
void | setPlngMatl(String plngMatl) 計画品目を設定します。
void | setPlngMatlExternal(String plngMatlExternal) 項目 PLNG_MATL の品目コード (長) (今後のリリースで開発)を設定します。
void | setPlngMatlGuid(String plngMatlGuid) 項目 PLNG_MATL の外部 GUID (今後のリリースで開発)を設定します。
void | setPlngMatlVersion(String plngMatlVersion) 項目 PLNG_MATL のバージョン番号 (今後のリリースで開発)を設定します。
void | setPlngPlant(String plngPlant) 計画プラントを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PlanningData

public PlanningData()
品目マスタ/製品グループの変更伝票構造情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getPlngMatl

public String getPlngMatl()
計画品目を取得します。

戻り値:
plngMatl 計画品目

getPlngPlant

public String getPlngPlant()
計画プラントを取得します。

戻り値:
plngPlant 計画プラント

getConvfactor

public String getConvfactor()
計画品目用変換係数を取得します。

戻り値:
convfactor 計画品目用変換係数

getPlngMatlExternal

public String getPlngMatlExternal()
項目 PLNG_MATL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
plngMatlExternal 項目 PLNG_MATL の品目コード (長) (今後の リリースで開発)

getPlngMatlGuid

public String getPlngMatlGuid()
項目 PLNG_MATL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
plngMatlGuid 項目 PLNG_MATL の外部 GUID (今後のリリースで開発)

getPlngMatlVersion

public String getPlngMatlVersion()
項目 PLNG_MATL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
plngMatlVersion 項目 PLNG_MATL のバージョン番号 (今後の リリースで開発)

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setPlngMatl

public void setPlngMatl(String plngMatl)
計画品目を設定します。

パラメータ:
plngMatl - 計画品目

setPlngPlant

public void setPlngPlant(String plngPlant)
計画プラントを設定します。

パラメータ:
plngPlant - 計画プラント

setConvfactor

public void setConvfactor(String convfactor)
計画品目用変換係数を設定します。

パラメータ:
convfactor - 計画品目用変換係数

setPlngMatlExternal

public void setPlngMatlExternal(String plngMatlExternal)
項目 PLNG_MATL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
plngMatlExternal - 項目 PLNG_MATL の品目コード (長) (今後の リリースで開発)

setPlngMatlGuid

public void setPlngMatlGuid(String plngMatlGuid)
項目 PLNG_MATL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
plngMatlGuid - 項目 PLNG_MATL の外部 GUID (今後のリリースで開発)

setPlngMatlVersion

public void setPlngMatlVersion(String plngMatlVersion)
項目 PLNG_MATL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
plngMatlVersion - 項目 PLNG_MATL のバージョン番号 (今後の リリースで開発)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PlanningDataList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス PlanningDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList
すべての実装インタフェース:
Serializable
public class PlanningDataList
extends PlanningData
implements Serializable

品目マスタ/製品グループの変更伝票構造情報クラス
機能は以下の通り

  • 品目マスタ/製品グループの変更伝票構造情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PlanningDataList()
品目マスタ/製品グループの変更伝票構造情報を作成します。
PlanningDataList(int index)
品目マスタ/製品グループの変更伝票構造情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します。
void | setIndex(int index) レコード番号を設定します。
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData から継承したメソッド
getConvfactor, getFunction, getMaterial, getPlant, getPlngMatl, getPlngMatlExternal, getPlngMatlGuid, getPlngMatlVersion, getPlngPlant, setConvfactor, setFunction, setMaterial, setPlant, setPlngMatl, setPlngMatlExternal, setPlngMatlGuid, setPlngMatlVersion, setPlngPlant, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PlanningDataList

public PlanningDataList()
品目マスタ/製品グループの変更伝票構造情報を作成します。

PlanningDataList

public PlanningDataList(int index)
品目マスタ/製品グループの変更伝票構造情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PlantData (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス PlantData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
PlantDataList
public class PlantData
extends Object
implements Serializable

品目データ (プラントレベル)情報クラス
機能は以下の通り

  • 品目データ (プラントレベル)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PlantData()
品目データ (プラントレベル)情報を作成します。
メソッドの概要
String | getAbcId() ABC 区分を取得します。
String | getAccountView() 会計ビューを取得します。
String | getAltBomId() 代替 BOM 選択の方法を取得します。
String | getAlternativeBom() 代替 BOMを取得します。
String | getAssyScrap() 組立不良率を取得します。
String | getAutoPOrd() 区分: "購買発注自動生成"を取得します。
String | getAutoReset() 予測モデル自動リセットを取得します。
String | getAvailcheck() 利用可能在庫確認の確認グループを取得します。
String | getAvailCheckAllProjSegments() プロジェクト間品目区分を取得します。
String | getBackflush() 区分: バックフラッシュを取得します。
String | getBaseQty() 基本数量を取得します。
String | getBaseQtyPlan() 出荷の能力計画のための基本数量を取得します。
String | getBatchentry() 製造/プロセス指図でのロット入力設定を取得します。
String | getBatchMgmt() ロット管理所要量区分を取得します。
String | getBomUsage() BOM 用途を取得します。
String | getBulkMat() 区分: バルク品目を取得します。
String | getBwdCons() 消費期間: 後方を取得します。
String | getCasNo() CAS 番号： 薬事品目 - 貿易を取得します。
String | getCcFixed() 循環棚卸区分固定を取得します。
String | getCcPhInv() 循環棚卸の実地棚卸区分を取得します。
String | getCertType() 証明書タイプを取得します。
String | getCommCode() 貿易: 統計品目コード/輸入コード番号を取得します。
String | getCommCoUn() 物品コード (貿易) の数量単位を取得します。
String | getCommCoUnIso() ISO コードによる物品コード (貿易管理) の数量単位を取得します。
String | getCompScrap() 構成品目不良率を取得します。
String | getConsummode() 消費モードを取得します。
String | getCoProduct() 区分: 連産品としても使用可能な品目を取得します。
String | getCorrFact() 区分: 修正係数を需要予測値計算に使用を取得します。
String | getCostView() 原価計算ビューを取得します。
String | getCountryori() 品目の原産国を取得します。
String | getCountryoriIso() ISO コードでの品目原産国を取得します。
String | getCovprofile() 在庫日数プロファイルを取得します。
String | getCritPart() 区分: 重要品目を取得します。
String | getCtrlCode() 貿易: 消費税の管理コードを取得します。
String | getCtrlKey() 調達における品質管理の管理キーを取得します。
String | getCycleTime() タクトタイムを取得します。
String | getDeclStatFlag() 区分: 仕入先申告ありを取得します。
String | getDelFlag() プラントレベルでの品目削除フラグを取得します。
String | getDeployHoriz() 供給分配期間の日数を取得します。
String | getDepReqId() 個別所要量と包括所要量に対する従属所要量区分を取得します。
String | getDetermGrp() 在庫決定グループを取得します。
String | getDiscontinu() 打切区分を取得します。
String | getDistrProf() サイトの商品の物流プロファイルを取得します。
String | getDocReqd() 文書必須フラグを取得します。
String | getDToRefM() 消費データ参照の有効終了日を取得します。
String | getEffODay() 有効終了日を取得します。
String | getEuListNo() CAP: CAP 製品一覧番号を取得します。
String | getEuMatGrp() EEC 農産物政策: CAP 生産品グループ - 貿易を取得します。
String | getExCertDt() 非該当証明書発行日を取得します。
String | getExCertId() 法令管理: 認定書区分を取得します。
String | getExCertNoNew() 非該当証明書番号 - 法令管理を取得します。
String | getExpimpgrp() 輸出/輸入品目グループを取得します。
String | getFairShareRule() 均等配賦ルールを取得します。
String | getFixedLot() 固定ロットサイズを取得します。
String | getFixLotSize() 需要供給の一致に対する固定ロットサイズを取得します。
String | getFollowUp() フォローアップ品目を取得します。
String | getFollowUpExternal() 項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)を取得します。
String | getFollowUpGuid() 項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)を取得します。
String | getFollowUpVersion() 項目 FOLLOW_UP のバージョン番号 (今後のリリースで開発)を取得します。
String | getForecastView() 需要予測ビューを取得します。
String | getFunction() BAPI 機能を取得します。
String | getFwdCons() 消費期間: 前方を取得します。
String | getFxdPrice() 固定価格連産品を取得します。
String | getFyVariant() 会計年度バリアントを取得します。
String | getGrpReqmts() 区分: 所要量グループ化を取得します。
String | getGrPrTime() 入庫処理日数を取得します。
String | getHandlgGrp() ワークロード計算のロジスティクス処理グループを取得します。
String | getIndPostToInspStock() 品質検査中在庫への転記を取得します。
String | getInhseprodt() 内製日数を取得します。
String | getInspInt() 次回再検査までの間隔を取得します。
String | getInspSetupFlag() 品目/プラントに QM 検査データ設定を取得します。
String | getInterop() 移動時間を取得します。
String | getIssStLoc() 出庫保管場所を取得します。
String | getIssueUnit() 出庫単位を取得します。
String | getIssueUnitIso() ISO コードでの出庫単位を取得します。
String | getJitRelvt() 区分: JIT 納入日程の関連明細を取得します。
String | getLoadinggrp() 積載グループを取得します。
String | getLotIncrement() 需要と供給を一致させるためのロットサイズ増分を取得します。
String | getLotSize() 原価計算ロットサイズを取得します。
String | getLotsizekey() ロットサイズ (品目計画)を取得します。
String | getMaintStat() 更新ステータスを取得します。
String | getMatCfop() 品目 CFOP カテゴリを取得します。
String | getMaterial() 品目コードを取得します。
String | getMatfrgtgrp() 品目運賃グループを取得します。
String | getMatGrpTrans() 段取替えマトリクスに対する品目のグループを取得します。
String | getMaxlotsize() 最大ロットサイズを取得します。
String | getMaxLotSize() 需要と供給を一致させるための最大ロットサイズを取得します。
String | getMaxStock() 最大在庫レベルを取得します。
String | getMilitId() ID: 武器を取得します。
String | getMinlotsize() 最小ロットサイズを取得します。
String | getMinLotSize() 需要と供給を一致させるための最小ロットサイズを取得します。
String | getMinSafetyStk() 最小安全在庫を取得します。
String | getMixedMrp() 二重 MRP 区分を取得します。
String | getMrpAreaExists() 区分: MRP エリア登録済を取得します。
String | getMrpCtrler() MRP 管理者を取得します。
String | getMrpGroup() MRP グループを取得します。
String | getMrpprofile() 品目: MRP プロファイルを取得します。
String | getMrpRelevancyDepRequirements() 従属所要量と MRP の関連性を取得します。
String | getMrpType() MRP タイプを取得します。
String | getMrpView() 資材所要量計画 (MRP) ビューを取得します。
String | getMultRefM() 消費データ参照品目の乗数を取得します。
String | getNegStocks() プラントにおけるマイナス在庫許可を取得します。
String | getNoCosting() 原価計算なしを取得します。
String | getOrdCosts() 発注原価 (BAPI インタフェース)を取得します。
String | getOriginalBatchFlag() 元ロット管理区分を取得します。
String | getOriginalBatchRefMaterial() 元ロットの参照品目を取得します。
String | getOverallprf() 指図変更管理の全体プロファイルを取得します。
String | getOverTol() 過剰納入許容範囲リミットを取得します。
String | getPeriodInd() 期間区分を取得します。
String | getPeriodProfileSafetyTime() 安全時間の期間プロファイルを取得します。
String | getPlanlistcnt() グループカウンタを取得します。
String | getPlanlistgrp() タスクリストグループのキーを取得します。
String | getPlanStrgp() 計画方針グループを取得します。
String | getPlant() プラントを取得します。
String | getPlndDelry() 予定納入時間 (単位: 日)を取得します。
String | getPlngCycle() 計画サイクルを取得します。
String | getPlordCtrl() アクション管理: 計画手配処理を取得します。
String | getPlTiFnce() 計画タイムフェンスを取得します。
String | getPpcPlCal() PPC 計画カレンダを取得します。
String | getPrefStatFlag() 区分: 特恵関税 - 輸出/輸入を取得します。
String | getProcTime() 処理時間を取得します。
String | getProcType() 調達タイプを取得します。
String | getProdcomNo() 生産統計: 貿易における PRODCOM コードを取得します。
String | getProdConvType() 生産値の変換タイプを取得します。
String | getProdprof() 製造計画プロファイルを取得します。
String | getProductionScheduler() 製造計画担当を取得します。
String | getProdUnit() 製造単位を取得します。
String | getProdUnitIso() 製造単位 (ISO コード)を取得します。
String | getProdverscs() 原価計算を行う製造バージョンを取得します。
String | getProfitCtr() 利益センタを取得します。
String | getPrtView() 生産資源/治工具 (PRT) ビューを取得します。
String | getPsConfMat() 選定可能品目を取得します。
String | getPurchView() 購買管理ビューを取得します。
String | getPurGroup() 購買グループを取得します。
String | getPurStatus() プラント特有品目ステータスを取得します。
String | getPushDistrib() 区分: プッシュ配賦を取得します。
String | getPvalidfrom() プラント品目ステータス有効期間開始日を取得します。
String | getQmAuthgrp() QM における活動の品目権限グループを取得します。
String | getQmRgmts() 仕入先の必須 QM システムを取得します。
String | getQualityView() 品質管理ビューを取得します。
String | getQuotausage() 供給量割当の使用を取得します。
String | getRefmatcons() 消費参照品目を取得します。
String | getRefmatconsExternal() 項目 REFMATCONS の品目コード (長) (今後のリリースで開発)を取得します。
String | getRefmatconsGuid() 項目 REFMATCONS の外部 GUID (今後のリリースで開発)を取得します。
String | getRefmatconsVersion() 項目 REFMATCONS のバージョン番号 (今後のリリースで開発)を取得します。
String | getRefpltcons() 消費参照プラントを取得します。
String | getRegionorig() 品目の原産地 (非特恵対象地区の原産)を取得します。
String | getReorderPt() 発注点を取得します。
String | getReplacePt() 取替部品を取得します。
String | getReplentime() 補充リードタイム合計 (稼動日数)を取得します。
String | getRepmanprof() 繰返生産プロファイルを取得します。
String | getRepManuf() 区分: 繰返生産許可を取得します。
String | getRotationDate() 原価計算ビューを取得します。
String | getRoundProf() 丸めプロファイルを取得します。
String | getRoundVal() 購買発注数量の丸め数量を取得します。
String | getSafetyStk() 安全在庫を取得します。
String | getSafetytime() 安全時間 (稼動日数)を取得します。
String | getSaftyTId() 安全時間区分（安全リードタイムあり/なし)を取得します。
String | getSalesView() 販売ビューを取得します。
String | getSernoProf() シリアル番号プロファイルを取得します。
String | getServLevel() サービスレベルを取得します。
String | getSetuptime() 段取時間と片付け時間を取得します。
String | getSetupTime() 出荷準備時間を取得します。
String | getShipProcTime() 出荷処理時間を取得します。
String | getSlocExprc() 外部調達の初期保管場所を取得します。
String | getSmKey() 日程計画余裕キーを取得します。
String | getSourcelist() 区分: 供給元一覧必須を取得します。
String | getSpecprocty() 原価計算の特殊調達タイプを取得します。
String | getSplitInd() 分割区分を取得します。
String | getSpproctype() 特殊調達タイプを取得します。
String | getStgePdUn() 最長保管期間の単位を取得します。
String | getStgePdUnIso() ISO コードでの最長保管期間単位を取得します。
String | getStgeperiod() 最長保管期間を取得します。
String | getStorageView() 保管ビューを取得します。
String | getStorCosts() 保管経費区分を取得します。
String | getSupplyArea() 品目マスタレコードで提案される供給場所を取得します。
String | getSupSource() 供給元を取得します。
String | getTaskListType() タスクリストタイプを取得します。
String | getUnderTol() 不足納入許容範囲リミットを取得します。
String | getUnitGroup() 数量単位グループを取得します。
String | getUnlimited() 区分: 無制限過剰納入可能を取得します。
String | getVarianceKey() 差異キーを取得します。
String | getVersionFlag() バージョン区分を取得します。
String | getWarehouseView() 倉庫管理ビューを取得します。
String | getWorkSchedView() 作業計画ビューを取得します。
void | setAbcId(String abcId) ABC 区分を設定します。
void | setAccountView(String accountView) 会計ビューを設定します。
void | setAltBomId(String altBomId) 代替 BOM 選択の方法を設定します。
void | setAlternativeBom(String alternativeBom) 代替 BOMを設定します。
void | setAssyScrap(String assyScrap) 組立不良率を設定します。
void | setAutoPOrd(String autoPOrd) 区分: "購買発注自動生成"を設定します。
void | setAutoReset(String autoReset) 予測モデル自動リセットを設定します。
void | setAvailcheck(String availcheck) 利用可能在庫確認の確認グループを設定します。
void | setAvailCheckAllProjSegments(String availCheckAllProjSegments) プロジェクト間品目区分を設定します。
void | setBackflush(String backflush) 区分: バックフラッシュを設定します。
void | setBaseQty(String baseQty) 基本数量を設定します。
void | setBaseQtyPlan(String baseQtyPlan) 出荷の能力計画のための基本数量を設定します。
void | setBatchentry(String batchentry) 製造/プロセス指図でのロット入力設定を設定します。
void | setBatchMgmt(String batchMgmt) ロット管理所要量区分を設定します。
void | setBomUsage(String bomUsage) BOM 用途を設定します。
void | setBulkMat(String bulkMat) 区分: バルク品目を設定します。
void | setBwdCons(String bwdCons) 消費期間: 後方を設定します。
void | setCasNo(String casNo) CAS 番号： 薬事品目 - 貿易を設定します。
void | setCcFixed(String ccFixed) 循環棚卸区分固定を設定します。
void | setCcPhInv(String ccPhInv) 循環棚卸の実地棚卸区分を設定します。
void | setCertType(String certType) 証明書タイプを設定します。
void | setCommCode(String commCode) 貿易: 統計品目コード/輸入コード番号を設定します。
void | setCommCoUn(String commCoUn) 物品コード (貿易) の数量単位を設定します。
void | setCommCoUnIso(String commCoUnIso) ISO コードによる物品コード (貿易管理) の数量単位を設定します。
void | setCompScrap(String compScrap) 構成品目不良率を設定します。
void | setConsummode(String consummode) 消費モードを設定します。
void | setCoProduct(String coProduct) 区分: 連産品としても使用可能な品目を設定します。
void | setCorrFact(String corrFact) 区分: 修正係数を需要予測値計算に使用を設定します。
void | setCostView(String costView) 原価計算ビューを設定します。
void | setCountryori(String countryori) 品目の原産国を設定します。
void | setCountryoriIso(String countryoriIso) ISO コードでの品目原産国を設定します。
void | setCovprofile(String covprofile) 在庫日数プロファイルを設定します。
void | setCritPart(String critPart) 区分: 重要品目を設定します。
void | setCtrlCode(String ctrlCode) 貿易: 消費税の管理コードを設定します。
void | setCtrlKey(String ctrlKey) 調達における品質管理の管理キーを設定します。
void | setCycleTime(String cycleTime) タクトタイムを設定します。
void | setDeclStatFlag(String declStatFlag) 区分: 仕入先申告ありを設定します。
void | setDelFlag(String delFlag) プラントレベルでの品目削除フラグを設定します。
void | setDeployHoriz(String deployHoriz) 供給分配期間の日数を設定します。
void | setDepReqId(String depReqId) 個別所要量と包括所要量に対する従属所要量区分を設定します。
void | setDetermGrp(String determGrp) 在庫決定グループを設定します。
void | setDiscontinu(String discontinu) 打切区分を設定します。
void | setDistrProf(String distrProf) サイトの商品の物流プロファイルを設定します。
void | setDocReqd(String docReqd) 文書必須フラグを設定します。
void | setDToRefM(String dToRefM) 消費データ参照の有効終了日を設定します。
void | setEffODay(String effODay) 有効終了日を設定します。
void | setEuListNo(String euListNo) CAP: CAP 製品一覧番号を設定します。
void | setEuMatGrp(String euMatGrp) EEC 農産物政策: CAP 生産品グループ - 貿易を設定します。
void | setExCertDt(String exCertDt) 非該当証明書発行日を設定します。
void | setExCertId(String exCertId) 法令管理: 認定書区分を設定します。
void | setExCertNoNew(String exCertNoNew) 非該当証明書番号 - 法令管理を設定します。
void | setExpimpgrp(String expimpgrp) 輸出/輸入品目グループを設定します。
void | setFairShareRule(String fairShareRule) 均等配賦ルールを設定します。
void | setFixedLot(String fixedLot) 固定ロットサイズを設定します。
void | setFixLotSize(String fixLotSize) 需要供給の一致に対する固定ロットサイズを設定します。
void | setFollowUp(String followUp) フォローアップ品目を設定します。
void | setFollowUpExternal(String followUpExternal) 項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)を設定します。
void | setFollowUpGuid(String followUpGuid) 項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)を設定します。
void | setFollowUpVersion(String followUpVersion) 項目 FOLLOW_UP のバージョン番号 (今後のリリースで開発)を設定します。
void | setForecastView(String forecastView) 需要予測ビューを設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setFwdCons(String fwdCons) 消費期間: 前方を設定します。
void | setFxdPrice(String fxdPrice) 固定価格連産品を設定します。
void | setFyVariant(String fyVariant) 会計年度バリアントを設定します。
void | setGrpReqmts(String grpReqmts) 区分: 所要量グループ化を設定します。
void | setGrPrTime(String grPrTime) 入庫処理日数を設定します。
void | setHandlgGrp(String handlgGrp) ワークロード計算のロジスティクス処理グループを設定します。
void | setIndPostToInspStock(String indPostToInspStock) 品質検査中在庫への転記を設定します。
void | setInhseprodt(String inhseprodt) 内製日数を設定します。
void | setInspInt(String inspInt) 次回再検査までの間隔を設定します。
void | setInspSetupFlag(String inspSetupFlag) 品目/プラントに QM 検査データ設定を設定します。
void | setInterop(String interop) 移動時間を設定します。
void | setIssStLoc(String issStLoc) 出庫保管場所を設定します。
void | setIssueUnit(String issueUnit) 出庫単位を設定します。
void | setIssueUnitIso(String issueUnitIso) ISO コードでの出庫単位を設定します。
void | setJitRelvt(String jitRelvt) 区分: JIT 納入日程の関連明細を設定します。
void | setLoadinggrp(String loadinggrp) 積載グループを設定します。
void | setLotIncrement(String lotIncrement) 需要と供給を一致させるためのロットサイズ増分を設定します。
void | setLotSize(String lotSize) 原価計算ロットサイズを設定します。
void | setLotsizekey(String lotsizekey) ロットサイズ (品目計画)を設定します。
void | setMaintStat(String maintStat) 更新ステータスを設定します。
void | setMatCfop(String matCfop) 品目 CFOP カテゴリを設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMatfrgtgrp(String matfrgtgrp) 品目運賃グループを設定します。
void | setMatGrpTrans(String matGrpTrans) 段取替えマトリクスに対する品目のグループを設定します。
void | setMaxlotsize(String maxlotsize) 最大ロットサイズを設定します。
void | setMaxLotSize(String maxLotSize) 需要と供給を一致させるための最大ロットサイズを設定します。
void | setMaxStock(String maxStock) 最大在庫レベルを設定します。
void | setMilitId(String militId) ID: 武器を設定します。
void | setMinlotsize(String minlotsize) 最小ロットサイズを設定します。
void | setMinLotSize(String minLotSize) 需要と供給を一致させるための最小ロットサイズを設定します。
void | setMinSafetyStk(String minSafetyStk) 最小安全在庫を設定します。
void | setMixedMrp(String mixedMrp) 二重 MRP 区分を設定します。
void | setMrpAreaExists(String mrpAreaExists) 区分: MRP エリア登録済を設定します。
void | setMrpCtrler(String mrpCtrler) MRP 管理者を設定します。
void | setMrpGroup(String mrpGroup) MRP グループを設定します。
void | setMrpprofile(String mrpprofile) 品目: MRP プロファイルを設定します。
void | setMrpRelevancyDepRequirements(String mrpRelevancyDepRequirements) 従属所要量と MRP の関連性を設定します。
void | setMrpType(String mrpType) MRP タイプを設定します。
void | setMrpView(String mrpView) 資材所要量計画 (MRP) ビューを設定します。
void | setMultRefM(String multRefM) 消費データ参照品目の乗数を設定します。
void | setNegStocks(String negStocks) プラントにおけるマイナス在庫許可を設定します。
void | setNoCosting(String noCosting) 原価計算なしを設定します。
void | setOrdCosts(String ordCosts) 発注原価 (BAPI インタフェース)を設定します。
void | setOriginalBatchFlag(String originalBatchFlag) 元ロット管理区分を設定します。
void | setOriginalBatchRefMaterial(String originalBatchRefMaterial) 元ロットの参照品目を設定します。
void | setOverallprf(String overallprf) 指図変更管理の全体プロファイルを設定します。
void | setOverTol(String overTol) 過剰納入許容範囲リミットを設定します。
void | setPeriodInd(String periodInd) 期間区分を設定します。
void | setPeriodProfileSafetyTime(String periodProfileSafetyTime) 安全時間の期間プロファイルを設定します。
void | setPlanlistcnt(String planlistcnt) グループカウンタを設定します。
void | setPlanlistgrp(String planlistgrp) タスクリストグループのキーを設定します。
void | setPlanStrgp(String planStrgp) 計画方針グループを設定します。
void | setPlant(String plant) プラントを設定します。
void | setPlndDelry(String plndDelry) 予定納入時間 (単位: 日)を設定します。
void | setPlngCycle(String plngCycle) 計画サイクルを設定します。
void | setPlordCtrl(String plordCtrl) アクション管理: 計画手配処理を設定します。
void | setPlTiFnce(String plTiFnce) 計画タイムフェンスを設定します。
void | setPpcPlCal(String ppcPlCal) PPC 計画カレンダを設定します。
void | setPrefStatFlag(String prefStatFlag) 区分: 特恵関税 - 輸出/輸入を設定します。
void | setProcTime(String procTime) 処理時間を設定します。
void | setProcType(String procType) 調達タイプを設定します。
void | setProdcomNo(String prodcomNo) 生産統計: 貿易における PRODCOM コードを設定します。
void | setProdConvType(String prodConvType) 生産値の変換タイプを設定します。
void | setProdprof(String prodprof) 製造計画プロファイルを設定します。
void | setProductionScheduler(String productionScheduler) 製造計画担当を設定します。
void | setProdUnit(String prodUnit) 製造単位を設定します。
void | setProdUnitIso(String prodUnitIso) 製造単位 (ISO コード)を設定します。
void | setProdverscs(String prodverscs) 原価計算を行う製造バージョンを設定します。
void | setProfitCtr(String profitCtr) 利益センタを設定します。
void | setPrtView(String prtView) 生産資源/治工具 (PRT) ビューを設定します。
void | setPsConfMat(String psConfMat) 選定可能品目を設定します。
void | setPurchView(String purchView) 購買管理ビューを設定します。
void | setPurGroup(String purGroup) 購買グループを設定します。
void | setPurStatus(String purStatus) プラント特有品目ステータスを設定します。
void | setPushDistrib(String pushDistrib) 区分: プッシュ配賦を設定します。
void | setPvalidfrom(String pvalidfrom) プラント品目ステータス有効期間開始日を設定します。
void | setQmAuthgrp(String qmAuthgrp) QM における活動の品目権限グループを設定します。
void | setQmRgmts(String qmRgmts) 仕入先の必須 QM システムを設定します。
void | setQualityView(String qualityView) 品質管理ビューを設定します。
void | setQuotausage(String quotausage) 供給量割当の使用を設定します。
void | setRefmatcons(String refmatcons) 消費参照品目を設定します。
void | setRefmatconsExternal(String refmatconsExternal) 項目 REFMATCONS の品目コード (長) (今後のリリースで開発)を設定します。
void | setRefmatconsGuid(String refmatconsGuid) 項目 REFMATCONS の外部 GUID (今後のリリースで開発)を設定します。
void | setRefmatconsVersion(String refmatconsVersion) 項目 REFMATCONS のバージョン番号 (今後のリリースで開発)を設定します。
void | setRefpltcons(String refpltcons) 消費参照プラントを設定します。
void | setRegionorig(String regionorig) 品目の原産地 (非特恵対象地区の原産)を設定します。
void | setReorderPt(String reorderPt) 発注点を設定します。
void | setReplacePt(String replacePt) 取替部品を設定します。
void | setReplentime(String replentime) 補充リードタイム合計 (稼動日数)を設定します。
void | setRepmanprof(String repmanprof) 繰返生産プロファイルを設定します。
void | setRepManuf(String repManuf) 区分: 繰返生産許可を設定します。
void | setRotationDate(String rotationDate) 原価計算ビューを設定します。
void | setRoundProf(String roundProf) 丸めプロファイルを設定します。
void | setRoundVal(String roundVal) 購買発注数量の丸め数量を設定します。
void | setSafetyStk(String safetyStk) 安全在庫を設定します。
void | setSafetytime(String safetytime) 安全時間 (稼動日数)を設定します。
void | setSaftyTId(String saftyTId) 安全時間区分（安全リードタイムあり/なし)を設定します。
void | setSalesView(String salesView) 販売ビューを設定します。
void | setSernoProf(String sernoProf) シリアル番号プロファイルを設定します。
void | setServLevel(String servLevel) サービスレベルを設定します。
void | setSetuptime(String setuptime) 段取時間と片付け時間を設定します。
void | setSetupTime(String setupTime) 出荷準備時間を設定します。
void | setShipProcTime(String shipProcTime) 出荷処理時間を設定します。
void | setSlocExprc(String slocExprc) 外部調達の初期保管場所を設定します。
void | setSmKey(String smKey) 日程計画余裕キーを設定します。
void | setSourcelist(String sourcelist) 区分: 供給元一覧必須を設定します。
void | setSpecprocty(String specprocty) 原価計算の特殊調達タイプを設定します。
void | setSplitInd(String splitInd) 分割区分を設定します。
void | setSpproctype(String spproctype) 特殊調達タイプを設定します。
void | setStgePdUn(String stgePdUn) 最長保管期間の単位を設定します。
void | setStgePdUnIso(String stgePdUnIso) ISO コードでの最長保管期間単位を設定します。
void | setStgeperiod(String stgeperiod) 最長保管期間を設定します。
void | setStorageView(String storageView) 保管ビューを設定します。
void | setStorCosts(String storCosts) 保管経費区分を設定します。
void | setSupplyArea(String supplyArea) 品目マスタレコードで提案される供給場所を設定します。
void | setSupSource(String supSource) 供給元を設定します。
void | setTaskListType(String taskListType) タスクリストタイプを設定します。
void | setUnderTol(String underTol) 不足納入許容範囲リミットを設定します。
void | setUnitGroup(String unitGroup) 数量単位グループを設定します。
void | setUnlimited(String unlimited) 区分: 無制限過剰納入可能を設定します。
void | setVarianceKey(String varianceKey) 差異キーを設定します。
void | setVersionFlag(String versionFlag) バージョン区分を設定します。
void | setWarehouseView(String warehouseView) 倉庫管理ビューを設定します。
void | setWorkSchedView(String workSchedView) 作業計画ビューを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PlantData

public PlantData()
品目データ (プラントレベル)情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getMaintStat

public String getMaintStat()
更新ステータスを取得します。

戻り値:
maintStat 更新ステータス

getDelFlag

public String getDelFlag()
プラントレベルでの品目削除フラグを取得します。

戻り値:
delFlag プラントレベルでの品目削除フラグ

getAbcId

public String getAbcId()
ABC 区分を取得します。

戻り値:
abcId ABC 区分

getCritPart

public String getCritPart()
区分: 重要品目を取得します。

戻り値:
critPart 区分: 重要品目

getPurGroup

public String getPurGroup()
購買グループを取得します。

戻り値:
purGroup 購買グループ

getIssueUnit

public String getIssueUnit()
出庫単位を取得します。

戻り値:
issueUnit 出庫単位

getIssueUnitIso

public String getIssueUnitIso()
ISO コードでの出庫単位を取得します。

戻り値:
issueUnitIso ISO コードでの出庫単位

getMrpprofile

public String getMrpprofile()
品目: MRP プロファイルを取得します。

戻り値:
mrpprofile 品目: MRP プロファイル

getMrpType

public String getMrpType()
MRP タイプを取得します。

戻り値:
mrpType MRP タイプ

getMrpCtrler

public String getMrpCtrler()
MRP 管理者を取得します。

戻り値:
mrpCtrler MRP 管理者

getPlndDelry

public String getPlndDelry()
予定納入時間 (単位: 日)を取得します。

戻り値:
plndDelry 予定納入時間 (単位: 日)

getGrPrTime

public String getGrPrTime()
入庫処理日数を取得します。

戻り値:
grPrTime 入庫処理日数

getPeriodInd

public String getPeriodInd()
期間区分を取得します。

戻り値:
periodInd 期間区分

getAssyScrap

public String getAssyScrap()
組立不良率を取得します。

戻り値:
assyScrap 組立不良率

getLotsizekey

public String getLotsizekey()
ロットサイズ (品目計画)を取得します。

戻り値:
lotsizekey ロットサイズ (品目計画)

getProcType

public String getProcType()
調達タイプを取得します。

戻り値:
procType 調達タイプ

getSpproctype

public String getSpproctype()
特殊調達タイプを取得します。

戻り値:
spproctype 特殊調達タイプ

getReorderPt

public String getReorderPt()
発注点を取得します。

戻り値:
reorderPt 発注点

getSafetyStk

public String getSafetyStk()
安全在庫を取得します。

戻り値:
safetyStk 安全在庫

getMinlotsize

public String getMinlotsize()
最小ロットサイズを取得します。

戻り値:
minlotsize 最小ロットサイズ

getMaxlotsize

public String getMaxlotsize()
最大ロットサイズを取得します。

戻り値:
maxlotsize 最大ロットサイズ

getFixedLot

public String getFixedLot()
固定ロットサイズを取得します。

戻り値:
fixedLot 固定ロットサイズ

getRoundVal

public String getRoundVal()
購買発注数量の丸め数量を取得します。

戻り値:
roundVal 購買発注数量の丸め数量

getMaxStock

public String getMaxStock()
最大在庫レベルを取得します。

戻り値:
maxStock 最大在庫レベル

getOrdCosts

public String getOrdCosts()
発注原価 (BAPI インタフェース)を取得します。

戻り値:
ordCosts 発注原価 (BAPI インタフェース)

getDepReqId

public String getDepReqId()
個別所要量と包括所要量に対する従属所要量区分を取得します。

戻り値:
depReqId 個別所要量と包括所要量に対する従属所要量区分

getStorCosts

public String getStorCosts()
保管経費区分を取得します。

戻り値:
storCosts 保管経費区分

getAltBomId

public String getAltBomId()
代替 BOM 選択の方法を取得します。

戻り値:
altBomId 代替 BOM 選択の方法

getDiscontinu

public String getDiscontinu()
打切区分を取得します。

戻り値:
discontinu 打切区分

getEffODay

public String getEffODay()
有効終了日を取得します。

戻り値:
effODay 有効終了日

getFollowUp

public String getFollowUp()
フォローアップ品目を取得します。

戻り値:
followUp フォローアップ品目

getGrpReqmts

public String getGrpReqmts()
区分: 所要量グループ化を取得します。

戻り値:
grpReqmts 区分: 所要量グループ化

getMixedMrp

public String getMixedMrp()
二重 MRP 区分を取得します。

戻り値:
mixedMrp 二重 MRP 区分

getSmKey

public String getSmKey()
日程計画余裕キーを取得します。

戻り値:
smKey 日程計画余裕キー

getBackflush

public String getBackflush()
区分: バックフラッシュを取得します。

戻り値:
backflush 区分: バックフラッシュ

getProductionScheduler

public String getProductionScheduler()
製造計画担当を取得します。

戻り値:
productionScheduler 製造計画担当

getProcTime

public String getProcTime()
処理時間を取得します。

戻り値:
procTime 処理時間

getSetuptime

public String getSetuptime()
段取時間と片付け時間を取得します。

戻り値:
setuptime 段取時間と片付け時間

getInterop

public String getInterop()
移動時間を取得します。

戻り値:
interop 移動時間

getBaseQty

public String getBaseQty()
基本数量を取得します。

戻り値:
baseQty 基本数量

getInhseprodt

public String getInhseprodt()
内製日数を取得します。

戻り値:
inhseprodt 内製日数

getStgeperiod

public String getStgeperiod()
最長保管期間を取得します。

戻り値:
stgeperiod 最長保管期間

getStgePdUn

public String getStgePdUn()
最長保管期間の単位を取得します。

戻り値:
stgePdUn 最長保管期間の単位

getStgePdUnIso

public String getStgePdUnIso()
ISO コードでの最長保管期間単位を取得します。

戻り値:
stgePdUnIso ISO コードでの最長保管期間単位

getOverTol

public String getOverTol()
過剰納入許容範囲リミットを取得します。

戻り値:
overTol 過剰納入許容範囲リミット

getUnlimited

public String getUnlimited()
区分: 無制限過剰納入可能を取得します。

戻り値:
unlimited 区分: 無制限過剰納入可能

getUnderTol

public String getUnderTol()
不足納入許容範囲リミットを取得します。

戻り値:
underTol 不足納入許容範囲リミット

getReplentime

public String getReplentime()
補充リードタイム合計 (稼動日数)を取得します。

戻り値:
replentime 補充リードタイム合計 (稼動日数)

getReplacePt

public String getReplacePt()
取替部品を取得します。

戻り値:
replacePt 取替部品

getIndPostToInspStock

public String getIndPostToInspStock()
品質検査中在庫への転記を取得します。

戻り値:
indPostToInspStock 品質検査中在庫への転記

getCtrlKey

public String getCtrlKey()
調達における品質管理の管理キーを取得します。

戻り値:
ctrlKey 調達における品質管理の管理キー

getDocReqd

public String getDocReqd()
文書必須フラグを取得します。

戻り値:
docReqd 文書必須フラグ

getLoadinggrp

public String getLoadinggrp()
積載グループを取得します。

戻り値:
loadinggrp 積載グループ

getBatchMgmt

public String getBatchMgmt()
ロット管理所要量区分を取得します。

戻り値:
batchMgmt ロット管理所要量区分

getQuotausage

public String getQuotausage()
供給量割当の使用を取得します。

戻り値:
quotausage 供給量割当の使用

getServLevel

public String getServLevel()
サービスレベルを取得します。

戻り値:
servLevel サービスレベル

getSplitInd

public String getSplitInd()
分割区分を取得します。

戻り値:
splitInd 分割区分

getAvailcheck

public String getAvailcheck()
利用可能在庫確認の確認グループを取得します。

戻り値:
availcheck 利用可能在庫確認の確認グループ

getFyVariant

public String getFyVariant()
会計年度バリアントを取得します。

戻り値:
fyVariant 会計年度バリアント

getCorrFact

public String getCorrFact()
区分: 修正係数を需要予測値計算に使用を取得します。

戻り値:
corrFact 区分: 修正係数を需要予測値計算に使用

getSetupTime

public String getSetupTime()
出荷準備時間を取得します。

戻り値:
setupTime 出荷準備時間

getBaseQtyPlan

public String getBaseQtyPlan()
出荷の能力計画のための基本数量を取得します。

戻り値:
baseQtyPlan 出荷の能力計画のための基本数量

getShipProcTime

public String getShipProcTime()
出荷処理時間を取得します。

戻り値:
shipProcTime 出荷処理時間

getSupSource

public String getSupSource()
供給元を取得します。

戻り値:
supSource 供給元

getAutoPOrd

public String getAutoPOrd()
区分: "購買発注自動生成"を取得します。

戻り値:
autoPOrd 区分: "購買発注自動生成"

getSourcelist

public String getSourcelist()
区分: 供給元一覧必須を取得します。

戻り値:
sourcelist 区分: 供給元一覧必須

getCommCode

public String getCommCode()
貿易: 統計品目コード/輸入コード番号を取得します。

戻り値:
commCode 貿易: 統計品目コード/輸入コード番号

getCountryori

public String getCountryori()
品目の原産国を取得します。

戻り値:
countryori 品目の原産国

getCountryoriIso

public String getCountryoriIso()
ISO コードでの品目原産国を取得します。

戻り値:
countryoriIso ISO コードでの品目原産国

getRegionorig

public String getRegionorig()
品目の原産地 (非特恵対象地区の原産)を取得します。

戻り値:
regionorig 品目の原産地 (非特恵対象地区の原産)

getCommCoUn

public String getCommCoUn()
物品コード (貿易) の数量単位を取得します。

戻り値:
commCoUn 物品コード (貿易) の数量単位

getCommCoUnIso

public String getCommCoUnIso()
ISO コードによる物品コード (貿易管理) の数量単位を取得します。

戻り値:
commCoUnIso ISO コードによる物品コード (貿易管理) の数量単位

getExpimpgrp

public String getExpimpgrp()
輸出/輸入品目グループを取得します。

戻り値:
expimpgrp 輸出/輸入品目グループ

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
profitCtr 利益センタ

getPpcPlCal

public String getPpcPlCal()
PPC 計画カレンダを取得します。

戻り値:
ppcPlCal PPC 計画カレンダ

getRepManuf

public String getRepManuf()
区分: 繰返生産許可を取得します。

戻り値:
repManuf 区分: 繰返生産許可

getPlTiFnce

public String getPlTiFnce()
計画タイムフェンスを取得します。

戻り値:
plTiFnce 計画タイムフェンス

getConsummode

public String getConsummode()
消費モードを取得します。

戻り値:
consummode 消費モード

getBwdCons

public String getBwdCons()
消費期間: 後方を取得します。

戻り値:
bwdCons 消費期間: 後方

getFwdCons

public String getFwdCons()
消費期間: 前方を取得します。

戻り値:
fwdCons 消費期間: 前方

getVersionFlag

public String getVersionFlag()
バージョン区分を取得します。

戻り値:
versionFlag バージョン区分

getAlternativeBom

public String getAlternativeBom()
代替 BOMを取得します。

戻り値:
alternativeBom 代替 BOM

getBomUsage

public String getBomUsage()
BOM 用途を取得します。

戻り値:
bomUsage BOM 用途

getPlanlistgrp

public String getPlanlistgrp()
タスクリストグループのキーを取得します。

戻り値:
planlistgrp タスクリストグループのキー

getPlanlistcnt

public String getPlanlistcnt()
グループカウンタを取得します。

戻り値:
planlistcnt グループカウンタ

getLotSize

public String getLotSize()
原価計算ロットサイズを取得します。

戻り値:
lotSize 原価計算ロットサイズ

getSpecprocty

public String getSpecprocty()
原価計算の特殊調達タイプを取得します。

戻り値:
specprocty 原価計算の特殊調達タイプ

getProdUnit

public String getProdUnit()
製造単位を取得します。

戻り値:
prodUnit 製造単位

getProdUnitIso

public String getProdUnitIso()
製造単位 (ISO コード)を取得します。

戻り値:
prodUnitIso 製造単位 (ISO コード)

getIssStLoc

public String getIssStLoc()
出庫保管場所を取得します。

戻り値:
issStLoc 出庫保管場所

getMrpGroup

public String getMrpGroup()
MRP グループを取得します。

戻り値:
mrpGroup MRP グループ

getCompScrap

public String getCompScrap()
構成品目不良率を取得します。

戻り値:
compScrap 構成品目不良率

getCertType

public String getCertType()
証明書タイプを取得します。

戻り値:
certType 証明書タイプ

getCycleTime

public String getCycleTime()
タクトタイムを取得します。

戻り値:
cycleTime タクトタイム

getInspSetupFlag

public String getInspSetupFlag()
品目/プラントに QM 検査データ設定を取得します。

戻り値:
inspSetupFlag 品目/プラントに QM 検査データ設定

getCovprofile

public String getCovprofile()
在庫日数プロファイルを取得します。

戻り値:
covprofile 在庫日数プロファイル

getCcPhInv

public String getCcPhInv()
循環棚卸の実地棚卸区分を取得します。

戻り値:
ccPhInv 循環棚卸の実地棚卸区分

getVarianceKey

public String getVarianceKey()
差異キーを取得します。

戻り値:
varianceKey 差異キー

getSernoProf

public String getSernoProf()
シリアル番号プロファイルを取得します。

戻り値:
sernoProf シリアル番号プロファイル

getPsConfMat

public String getPsConfMat()
選定可能品目を取得します。

戻り値:
psConfMat 選定可能品目

getRepmanprof

public String getRepmanprof()
繰返生産プロファイルを取得します。

戻り値:
repmanprof 繰返生産プロファイル

getNegStocks

public String getNegStocks()
プラントにおけるマイナス在庫許可を取得します。

戻り値:
negStocks プラントにおけるマイナス在庫許可

getQmRgmts

public String getQmRgmts()
仕入先の必須 QM システムを取得します。

戻り値:
qmRgmts 仕入先の必須 QM システム

getPlngCycle

public String getPlngCycle()
計画サイクルを取得します。

戻り値:
plngCycle 計画サイクル

getRoundProf

public String getRoundProf()
丸めプロファイルを取得します。

戻り値:
roundProf 丸めプロファイル

getRefmatcons

public String getRefmatcons()
消費参照品目を取得します。

戻り値:
refmatcons 消費参照品目

getRefpltcons

public String getRefpltcons()
消費参照プラントを取得します。

戻り値:
refpltcons 消費参照プラント

getDToRefM

public String getDToRefM()
消費データ参照の有効終了日を取得します。

戻り値:
dToRefM 消費データ参照の有効終了日

getMultRefM

public String getMultRefM()
消費データ参照品目の乗数を取得します。

戻り値:
multRefM 消費データ参照品目の乗数

getAutoReset

public String getAutoReset()
予測モデル自動リセットを取得します。

戻り値:
autoReset 予測モデル自動リセット

getPrefStatFlag

public String getPrefStatFlag()
区分: 特恵関税 - 輸出/輸入を取得します。

戻り値:
prefStatFlag 区分: 特恵関税 - 輸出/輸入

getExCertId

public String getExCertId()
法令管理: 認定書区分を取得します。

戻り値:
exCertId 法令管理: 認定書区分

getExCertNoNew

public String getExCertNoNew()
非該当証明書番号 - 法令管理を取得します。

戻り値:
exCertNoNew 非該当証明書番号 - 法令管理

getExCertDt

public String getExCertDt()
非該当証明書発行日を取得します。

戻り値:
exCertDt 非該当証明書発行日

getDeclStatFlag

public String getDeclStatFlag()
区分: 仕入先申告ありを取得します。

戻り値:
declStatFlag 区分: 仕入先申告あり

getMilitId

public String getMilitId()
ID: 武器を取得します。

戻り値:
militId ID: 武器

getInspInt

public String getInspInt()
次回再検査までの間隔を取得します。

戻り値:
inspInt 次回再検査までの間隔

getCoProduct

public String getCoProduct()
区分: 連産品としても使用可能な品目を取得します。

戻り値:
coProduct 区分: 連産品としても使用可能な品目

getPlanStrgp

public String getPlanStrgp()
計画方針グループを取得します。

戻り値:
planStrgp 計画方針グループ

getSlocExprc

public String getSlocExprc()
外部調達の初期保管場所を取得します。

戻り値:
slocExprc 外部調達の初期保管場所

getBulkMat

public String getBulkMat()
区分: バルク品目を取得します。

戻り値:
bulkMat 区分: バルク品目

getCcFixed

public String getCcFixed()
循環棚卸区分固定を取得します。

戻り値:
ccFixed 循環棚卸区分固定

getDetermGrp

public String getDetermGrp()
在庫決定グループを取得します。

戻り値:
determGrp 在庫決定グループ

getQmAuthgrp

public String getQmAuthgrp()
QM における活動の品目権限グループを取得します。

戻り値:
qmAuthgrp QM における活動の品目権限グループ

getTaskListType

public String getTaskListType()
タスクリストタイプを取得します。

戻り値:
taskListType タスクリストタイプ

getPurStatus

public String getPurStatus()
プラント特有品目ステータスを取得します。

戻り値:
purStatus プラント特有品目ステータス

getProdprof

public String getProdprof()
製造計画プロファイルを取得します。

戻り値:
prodprof 製造計画プロファイル

getSaftyTId

public String getSaftyTId()
安全時間区分（安全リードタイムあり/なし)を取得します。

戻り値:
saftyTId 安全時間区分（安全リードタイムあり/なし)

getSafetytime

public String getSafetytime()
安全時間 (稼動日数)を取得します。

戻り値:
safetytime 安全時間 (稼動日数)

getPlordCtrl

public String getPlordCtrl()
アクション管理: 計画手配処理を取得します。

戻り値:
plordCtrl アクション管理: 計画手配処理

getBatchentry

public String getBatchentry()
製造/プロセス指図でのロット入力設定を取得します。

戻り値:
batchentry 製造/プロセス指図でのロット入力設定

getPvalidfrom

public String getPvalidfrom()
プラント品目ステータス有効期間開始日を取得します。

戻り値:
pvalidfrom プラント品目ステータス有効期間開始日

getMatfrgtgrp

public String getMatfrgtgrp()
品目運賃グループを取得します。

戻り値:
matfrgtgrp 品目運賃グループ

getProdverscs

public String getProdverscs()
原価計算を行う製造バージョンを取得します。

戻り値:
prodverscs 原価計算を行う製造バージョン

getMatCfop

public String getMatCfop()
品目 CFOP カテゴリを取得します。

戻り値:
matCfop 品目 CFOP カテゴリ

getEuListNo

public String getEuListNo()
CAP: CAP 製品一覧番号を取得します。

戻り値:
euListNo CAP: CAP 製品一覧番号

getEuMatGrp

public String getEuMatGrp()
EEC 農産物政策: CAP 生産品グループ - 貿易を取得します。

戻り値:
euMatGrp EEC 農産物政策: CAP 生産品グループ - 貿易

getCasNo

public String getCasNo()
CAS 番号： 薬事品目 - 貿易を取得します。

戻り値:
casNo CAS 番号： 薬事品目 - 貿易

getProdcomNo

public String getProdcomNo()
生産統計: 貿易における PRODCOM コードを取得します。

戻り値:
prodcomNo 生産統計: 貿易における PRODCOM コード

getCtrlCode

public String getCtrlCode()
貿易: 消費税の管理コードを取得します。

戻り値:
ctrlCode 貿易: 消費税の管理コード

getJitRelvt

public String getJitRelvt()
区分: JIT 納入日程の関連明細を取得します。

戻り値:
jitRelvt 区分: JIT 納入日程の関連明細

getMatGrpTrans

public String getMatGrpTrans()
段取替えマトリクスに対する品目のグループを取得します。

戻り値:
matGrpTrans 段取替えマトリクスに対する品目のグループ

getHandlgGrp

public String getHandlgGrp()
ワークロード計算のロジスティクス処理グループを取得します。

戻り値:
handlgGrp ワークロード計算のロジスティクス処理グループ

getSupplyArea

public String getSupplyArea()
品目マスタレコードで提案される供給場所を取得します。

戻り値:
supplyArea 品目マスタレコードで提案される供給場所

getFairShareRule

public String getFairShareRule()
均等配賦ルールを取得します。

戻り値:
fairShareRule 均等配賦ルール

getPushDistrib

public String getPushDistrib()
区分: プッシュ配賦を取得します。

戻り値:
pushDistrib 区分: プッシュ配賦

getDeployHoriz

public String getDeployHoriz()
供給分配期間の日数を取得します。

戻り値:
deployHoriz 供給分配期間の日数

getMinLotSize

public String getMinLotSize()
需要と供給を一致させるための最小ロットサイズを取得します。

戻り値:
minLotSize 需要と供給を一致させるための最小ロットサイズ

getMaxLotSize

public String getMaxLotSize()
需要と供給を一致させるための最大ロットサイズを取得します。

戻り値:
maxLotSize 需要と供給を一致させるための最大ロットサイズ

getFixLotSize

public String getFixLotSize()
需要供給の一致に対する固定ロットサイズを取得します。

戻り値:
fixLotSize 需要供給の一致に対する固定ロットサイズ

getLotIncrement

public String getLotIncrement()
需要と供給を一致させるためのロットサイズ増分を取得します。

戻り値:
lotIncrement 需要と供給を一致させるためのロットサイズ増分

getProdConvType

public String getProdConvType()
生産値の変換タイプを取得します。

戻り値:
prodConvType 生産値の変換タイプ

getDistrProf

public String getDistrProf()
サイトの商品の物流プロファイルを取得します。

戻り値:
distrProf サイトの商品の物流プロファイル

getPeriodProfileSafetyTime

public String getPeriodProfileSafetyTime()
安全時間の期間プロファイルを取得します。

戻り値:
periodProfileSafetyTime 安全時間の期間プロファイル

getFxdPrice

public String getFxdPrice()
固定価格連産品を取得します。

戻り値:
fxdPrice 固定価格連産品

getAvailCheckAllProjSegments

public String getAvailCheckAllProjSegments()
プロジェクト間品目区分を取得します。

戻り値:
availCheckAllProjSegments プロジェクト間品目区分

getOverallprf

public String getOverallprf()
指図変更管理の全体プロファイルを取得します。

戻り値:
overallprf 指図変更管理の全体プロファイル

getMrpRelevancyDepRequirements

public String getMrpRelevancyDepRequirements()
従属所要量と MRP の関連性を取得します。

戻り値:
mrpRelevancyDepRequirements 従属所要量と MRP の関連性

getMrpAreaExists

public String getMrpAreaExists()
区分: MRP エリア登録済を取得します。

戻り値:
mrpAreaExists 区分: MRP エリア登録済

getMinSafetyStk

public String getMinSafetyStk()
最小安全在庫を取得します。

戻り値:
minSafetyStk 最小安全在庫

getNoCosting

public String getNoCosting()
原価計算なしを取得します。

戻り値:
noCosting 原価計算なし

getUnitGroup

public String getUnitGroup()
数量単位グループを取得します。

戻り値:
unitGroup 数量単位グループ

getFollowUpExternal

public String getFollowUpExternal()
項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
followUpExternal 項目 FOLLOW_UP の品目コード (長) (今後の リリースで開発)

getFollowUpGuid

public String getFollowUpGuid()
項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
followUpGuid 項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)

getFollowUpVersion

public String getFollowUpVersion()
項目 FOLLOW_UP のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
followUpVersion 項目 FOLLOW_UP のバージョン番号 (今後の リリースで開発)

getRefmatconsExternal

public String getRefmatconsExternal()
項目 REFMATCONS の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
refmatconsExternal 項目 REFMATCONS の品目コード (長) (今後の リリースで開発)

getRefmatconsGuid

public String getRefmatconsGuid()
項目 REFMATCONS の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
refmatconsGuid 項目 REFMATCONS の外部 GUID (今後のリリースで開発)

getRefmatconsVersion

public String getRefmatconsVersion()
項目 REFMATCONS のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
refmatconsVersion 項目 REFMATCONS のバージョン番号 (今後の リリースで開発)

getSalesView

public String getSalesView()
販売ビューを取得します。

戻り値:
salesView 販売ビュー

getPurchView

public String getPurchView()
購買管理ビューを取得します。

戻り値:
purchView 購買管理ビュー

getMrpView

public String getMrpView()
資材所要量計画 (MRP) ビューを取得します。

戻り値:
mrpView 資材所要量計画 (MRP) ビュー

getForecastView

public String getForecastView()
需要予測ビューを取得します。

戻り値:
forecastView 需要予測ビュー

getWorkSchedView

public String getWorkSchedView()
作業計画ビューを取得します。

戻り値:
workSchedView 作業計画ビュー

getPrtView

public String getPrtView()
生産資源/治工具 (PRT) ビューを取得します。

戻り値:
prtView 生産資源/治工具 (PRT) ビュー

getStorageView

public String getStorageView()
保管ビューを取得します。

戻り値:
storageView 保管ビュー

getWarehouseView

public String getWarehouseView()
倉庫管理ビューを取得します。

戻り値:
warehouseView 倉庫管理ビュー

getQualityView

public String getQualityView()
品質管理ビューを取得します。

戻り値:
qualityView 品質管理ビュー

getAccountView

public String getAccountView()
会計ビューを取得します。

戻り値:
accountView 会計ビュー

getCostView

public String getCostView()
原価計算ビューを取得します。

戻り値:
costView 原価計算ビュー

getRotationDate

public String getRotationDate()
原価計算ビューを取得します。

戻り値:
rotationDate 原価計算ビュー

getOriginalBatchFlag

public String getOriginalBatchFlag()
元ロット管理区分を取得します。

戻り値:
originalBatchFlag 元ロット管理区分

getOriginalBatchRefMaterial

public String getOriginalBatchRefMaterial()
元ロットの参照品目を取得します。

戻り値:
originalBatchRefMaterial 元ロットの参照品目

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setMaintStat

public void setMaintStat(String maintStat)
更新ステータスを設定します。

パラメータ:
maintStat - 更新ステータス

setDelFlag

public void setDelFlag(String delFlag)
プラントレベルでの品目削除フラグを設定します。

パラメータ:
delFlag - プラントレベルでの品目削除フラグ

setAbcId

public void setAbcId(String abcId)
ABC 区分を設定します。

パラメータ:
abcId - ABC 区分

setCritPart

public void setCritPart(String critPart)
区分: 重要品目を設定します。

パラメータ:
critPart - 区分: 重要品目

setPurGroup

public void setPurGroup(String purGroup)
購買グループを設定します。

パラメータ:
purGroup - 購買グループ

setIssueUnit

public void setIssueUnit(String issueUnit)
出庫単位を設定します。

パラメータ:
issueUnit - 出庫単位

setIssueUnitIso

public void setIssueUnitIso(String issueUnitIso)
ISO コードでの出庫単位を設定します。

パラメータ:
issueUnitIso - ISO コードでの出庫単位

setMrpprofile

public void setMrpprofile(String mrpprofile)
品目: MRP プロファイルを設定します。

パラメータ:
mrpprofile - 品目: MRP プロファイル

setMrpType

public void setMrpType(String mrpType)
MRP タイプを設定します。

パラメータ:
mrpType - MRP タイプ

setMrpCtrler

public void setMrpCtrler(String mrpCtrler)
MRP 管理者を設定します。

パラメータ:
mrpCtrler - MRP 管理者

setPlndDelry

public void setPlndDelry(String plndDelry)
予定納入時間 (単位: 日)を設定します。

パラメータ:
plndDelry - 予定納入時間 (単位: 日)

setGrPrTime

public void setGrPrTime(String grPrTime)
入庫処理日数を設定します。

パラメータ:
grPrTime - 入庫処理日数

setPeriodInd

public void setPeriodInd(String periodInd)
期間区分を設定します。

パラメータ:
periodInd - 期間区分

setAssyScrap

public void setAssyScrap(String assyScrap)
組立不良率を設定します。

パラメータ:
assyScrap - 組立不良率

setLotsizekey

public void setLotsizekey(String lotsizekey)
ロットサイズ (品目計画)を設定します。

パラメータ:
lotsizekey - ロットサイズ (品目計画)

setProcType

public void setProcType(String procType)
調達タイプを設定します。

パラメータ:
procType - 調達タイプ

setSpproctype

public void setSpproctype(String spproctype)
特殊調達タイプを設定します。

パラメータ:
spproctype - 特殊調達タイプ

setReorderPt

public void setReorderPt(String reorderPt)
発注点を設定します。

パラメータ:
reorderPt - 発注点

setSafetyStk

public void setSafetyStk(String safetyStk)
安全在庫を設定します。

パラメータ:
safetyStk - 安全在庫

setMinlotsize

public void setMinlotsize(String minlotsize)
最小ロットサイズを設定します。

パラメータ:
minlotsize - 最小ロットサイズ

setMaxlotsize

public void setMaxlotsize(String maxlotsize)
最大ロットサイズを設定します。

パラメータ:
maxlotsize - 最大ロットサイズ

setFixedLot

public void setFixedLot(String fixedLot)
固定ロットサイズを設定します。

パラメータ:
fixedLot - 固定ロットサイズ

setRoundVal

public void setRoundVal(String roundVal)
購買発注数量の丸め数量を設定します。

パラメータ:
roundVal - 購買発注数量の丸め数量

setMaxStock

public void setMaxStock(String maxStock)
最大在庫レベルを設定します。

パラメータ:
maxStock - 最大在庫レベル

setOrdCosts

public void setOrdCosts(String ordCosts)
発注原価 (BAPI インタフェース)を設定します。

パラメータ:
ordCosts - 発注原価 (BAPI インタフェース)

setDepReqId

public void setDepReqId(String depReqId)
個別所要量と包括所要量に対する従属所要量区分を設定します。

パラメータ:
depReqId - 個別所要量と包括所要量に対する従属所要量区分

setStorCosts

public void setStorCosts(String storCosts)
保管経費区分を設定します。

パラメータ:
storCosts - 保管経費区分

setAltBomId

public void setAltBomId(String altBomId)
代替 BOM 選択の方法を設定します。

パラメータ:
altBomId - 代替 BOM 選択の方法

setDiscontinu

public void setDiscontinu(String discontinu)
打切区分を設定します。

パラメータ:
discontinu - 打切区分

setEffODay

public void setEffODay(String effODay)
有効終了日を設定します。

パラメータ:
effODay - 有効終了日

setFollowUp

public void setFollowUp(String followUp)
フォローアップ品目を設定します。

パラメータ:
followUp - フォローアップ品目

setGrpReqmts

public void setGrpReqmts(String grpReqmts)
区分: 所要量グループ化を設定します。

パラメータ:
grpReqmts - 区分: 所要量グループ化

setMixedMrp

public void setMixedMrp(String mixedMrp)
二重 MRP 区分を設定します。

パラメータ:
mixedMrp - 二重 MRP 区分

setSmKey

public void setSmKey(String smKey)
日程計画余裕キーを設定します。

パラメータ:
smKey - 日程計画余裕キー

setBackflush

public void setBackflush(String backflush)
区分: バックフラッシュを設定します。

パラメータ:
backflush - 区分: バックフラッシュ

setProductionScheduler

public void setProductionScheduler(String productionScheduler)
製造計画担当を設定します。

パラメータ:
productionScheduler - 製造計画担当

setProcTime

public void setProcTime(String procTime)
処理時間を設定します。

パラメータ:
procTime - 処理時間

setSetuptime

public void setSetuptime(String setuptime)
段取時間と片付け時間を設定します。

パラメータ:
setuptime - 段取時間と片付け時間

setInterop

public void setInterop(String interop)
移動時間を設定します。

パラメータ:
interop - 移動時間

setBaseQty

public void setBaseQty(String baseQty)
基本数量を設定します。

パラメータ:
baseQty - 基本数量

setInhseprodt

public void setInhseprodt(String inhseprodt)
内製日数を設定します。

パラメータ:
inhseprodt - 内製日数

setStgeperiod

public void setStgeperiod(String stgeperiod)
最長保管期間を設定します。

パラメータ:
stgeperiod - 最長保管期間

setStgePdUn

public void setStgePdUn(String stgePdUn)
最長保管期間の単位を設定します。

パラメータ:
stgePdUn - 最長保管期間の単位

setStgePdUnIso

public void setStgePdUnIso(String stgePdUnIso)
ISO コードでの最長保管期間単位を設定します。

パラメータ:
stgePdUnIso - ISO コードでの最長保管期間単位

setOverTol

public void setOverTol(String overTol)
過剰納入許容範囲リミットを設定します。

パラメータ:
overTol - 過剰納入許容範囲リミット

setUnlimited

public void setUnlimited(String unlimited)
区分: 無制限過剰納入可能を設定します。

パラメータ:
unlimited - 区分: 無制限過剰納入可能

setUnderTol

public void setUnderTol(String underTol)
不足納入許容範囲リミットを設定します。

パラメータ:
underTol - 不足納入許容範囲リミット

setReplentime

public void setReplentime(String replentime)
補充リードタイム合計 (稼動日数)を設定します。

パラメータ:
replentime - 補充リードタイム合計 (稼動日数)

setReplacePt

public void setReplacePt(String replacePt)
取替部品を設定します。

パラメータ:
replacePt - 取替部品

setIndPostToInspStock

public void setIndPostToInspStock(String indPostToInspStock)
品質検査中在庫への転記を設定します。

パラメータ:
indPostToInspStock - 品質検査中在庫への転記

setCtrlKey

public void setCtrlKey(String ctrlKey)
調達における品質管理の管理キーを設定します。

パラメータ:
ctrlKey - 調達における品質管理の管理キー

setDocReqd

public void setDocReqd(String docReqd)
文書必須フラグを設定します。

パラメータ:
docReqd - 文書必須フラグ

setLoadinggrp

public void setLoadinggrp(String loadinggrp)
積載グループを設定します。

パラメータ:
loadinggrp - 積載グループ

setBatchMgmt

public void setBatchMgmt(String batchMgmt)
ロット管理所要量区分を設定します。

パラメータ:
batchMgmt - ロット管理所要量区分

setQuotausage

public void setQuotausage(String quotausage)
供給量割当の使用を設定します。

パラメータ:
quotausage - 供給量割当の使用

setServLevel

public void setServLevel(String servLevel)
サービスレベルを設定します。

パラメータ:
servLevel - サービスレベル

setSplitInd

public void setSplitInd(String splitInd)
分割区分を設定します。

パラメータ:
splitInd - 分割区分

setAvailcheck

public void setAvailcheck(String availcheck)
利用可能在庫確認の確認グループを設定します。

パラメータ:
availcheck - 利用可能在庫確認の確認グループ

setFyVariant

public void setFyVariant(String fyVariant)
会計年度バリアントを設定します。

パラメータ:
fyVariant - 会計年度バリアント

setCorrFact

public void setCorrFact(String corrFact)
区分: 修正係数を需要予測値計算に使用を設定します。

パラメータ:
corrFact - 区分: 修正係数を需要予測値計算に使用

setSetupTime

public void setSetupTime(String setupTime)
出荷準備時間を設定します。

パラメータ:
setupTime - 出荷準備時間

setBaseQtyPlan

public void setBaseQtyPlan(String baseQtyPlan)
出荷の能力計画のための基本数量を設定します。

パラメータ:
baseQtyPlan - 出荷の能力計画のための基本数量

setShipProcTime

public void setShipProcTime(String shipProcTime)
出荷処理時間を設定します。

パラメータ:
shipProcTime - 出荷処理時間

setSupSource

public void setSupSource(String supSource)
供給元を設定します。

パラメータ:
supSource - 供給元

setAutoPOrd

public void setAutoPOrd(String autoPOrd)
区分: "購買発注自動生成"を設定します。

パラメータ:
autoPOrd - 区分: "購買発注自動生成"

setSourcelist

public void setSourcelist(String sourcelist)
区分: 供給元一覧必須を設定します。

パラメータ:
sourcelist - 区分: 供給元一覧必須

setCommCode

public void setCommCode(String commCode)
貿易: 統計品目コード/輸入コード番号を設定します。

パラメータ:
commCode - 貿易: 統計品目コード/輸入コード番号

setCountryori

public void setCountryori(String countryori)
品目の原産国を設定します。

パラメータ:
countryori - 品目の原産国

setCountryoriIso

public void setCountryoriIso(String countryoriIso)
ISO コードでの品目原産国を設定します。

パラメータ:
countryoriIso - ISO コードでの品目原産国

setRegionorig

public void setRegionorig(String regionorig)
品目の原産地 (非特恵対象地区の原産)を設定します。

パラメータ:
regionorig - 品目の原産地 (非特恵対象地区の原産)

setCommCoUn

public void setCommCoUn(String commCoUn)
物品コード (貿易) の数量単位を設定します。

パラメータ:
commCoUn - 物品コード (貿易) の数量単位

setCommCoUnIso

public void setCommCoUnIso(String commCoUnIso)
ISO コードによる物品コード (貿易管理) の数量単位を設定します。

パラメータ:
commCoUnIso - ISO コードによる物品コード (貿易管理) の数量単位

setExpimpgrp

public void setExpimpgrp(String expimpgrp)
輸出/輸入品目グループを設定します。

パラメータ:
expimpgrp - 輸出/輸入品目グループ

setProfitCtr

public void setProfitCtr(String profitCtr)
利益センタを設定します。

パラメータ:
profitCtr - 利益センタ

setPpcPlCal

public void setPpcPlCal(String ppcPlCal)
PPC 計画カレンダを設定します。

パラメータ:
ppcPlCal - PPC 計画カレンダ

setRepManuf

public void setRepManuf(String repManuf)
区分: 繰返生産許可を設定します。

パラメータ:
repManuf - 区分: 繰返生産許可

setPlTiFnce

public void setPlTiFnce(String plTiFnce)
計画タイムフェンスを設定します。

パラメータ:
plTiFnce - 計画タイムフェンス

setConsummode

public void setConsummode(String consummode)
消費モードを設定します。

パラメータ:
consummode - 消費モード

setBwdCons

public void setBwdCons(String bwdCons)
消費期間: 後方を設定します。

パラメータ:
bwdCons - 消費期間: 後方

setFwdCons

public void setFwdCons(String fwdCons)
消費期間: 前方を設定します。

パラメータ:
fwdCons - 消費期間: 前方

setVersionFlag

public void setVersionFlag(String versionFlag)
バージョン区分を設定します。

パラメータ:
versionFlag - バージョン区分

setAlternativeBom

public void setAlternativeBom(String alternativeBom)
代替 BOMを設定します。

パラメータ:
alternativeBom - 代替 BOM

setBomUsage

public void setBomUsage(String bomUsage)
BOM 用途を設定します。

パラメータ:
bomUsage - BOM 用途

setPlanlistgrp

public void setPlanlistgrp(String planlistgrp)
タスクリストグループのキーを設定します。

パラメータ:
planlistgrp - タスクリストグループのキー

setPlanlistcnt

public void setPlanlistcnt(String planlistcnt)
グループカウンタを設定します。

パラメータ:
planlistcnt - グループカウンタ

setLotSize

public void setLotSize(String lotSize)
原価計算ロットサイズを設定します。

パラメータ:
lotSize - 原価計算ロットサイズ

setSpecprocty

public void setSpecprocty(String specprocty)
原価計算の特殊調達タイプを設定します。

パラメータ:
specprocty - 原価計算の特殊調達タイプ

setProdUnit

public void setProdUnit(String prodUnit)
製造単位を設定します。

パラメータ:
prodUnit - 製造単位

setProdUnitIso

public void setProdUnitIso(String prodUnitIso)
製造単位 (ISO コード)を設定します。

パラメータ:
prodUnitIso - 製造単位 (ISO コード)

setIssStLoc

public void setIssStLoc(String issStLoc)
出庫保管場所を設定します。

パラメータ:
issStLoc - 出庫保管場所

setMrpGroup

public void setMrpGroup(String mrpGroup)
MRP グループを設定します。

パラメータ:
mrpGroup - MRP グループ

setCompScrap

public void setCompScrap(String compScrap)
構成品目不良率を設定します。

パラメータ:
compScrap - 構成品目不良率

setCertType

public void setCertType(String certType)
証明書タイプを設定します。

パラメータ:
certType - 証明書タイプ

setCycleTime

public void setCycleTime(String cycleTime)
タクトタイムを設定します。

パラメータ:
cycleTime - タクトタイム

setInspSetupFlag

public void setInspSetupFlag(String inspSetupFlag)
品目/プラントに QM 検査データ設定を設定します。

パラメータ:
inspSetupFlag - 品目/プラントに QM 検査データ設定

setCovprofile

public void setCovprofile(String covprofile)
在庫日数プロファイルを設定します。

パラメータ:
covprofile - 在庫日数プロファイル

setCcPhInv

public void setCcPhInv(String ccPhInv)
循環棚卸の実地棚卸区分を設定します。

パラメータ:
ccPhInv - 循環棚卸の実地棚卸区分

setVarianceKey

public void setVarianceKey(String varianceKey)
差異キーを設定します。

パラメータ:
varianceKey - 差異キー

setSernoProf

public void setSernoProf(String sernoProf)
シリアル番号プロファイルを設定します。

パラメータ:
sernoProf - シリアル番号プロファイル

setPsConfMat

public void setPsConfMat(String psConfMat)
選定可能品目を設定します。

パラメータ:
psConfMat - 選定可能品目

setRepmanprof

public void setRepmanprof(String repmanprof)
繰返生産プロファイルを設定します。

パラメータ:
repmanprof - 繰返生産プロファイル

setNegStocks

public void setNegStocks(String negStocks)
プラントにおけるマイナス在庫許可を設定します。

パラメータ:
negStocks - プラントにおけるマイナス在庫許可

setQmRgmts

public void setQmRgmts(String qmRgmts)
仕入先の必須 QM システムを設定します。

パラメータ:
qmRgmts - 仕入先の必須 QM システム

setPlngCycle

public void setPlngCycle(String plngCycle)
計画サイクルを設定します。

パラメータ:
plngCycle - 計画サイクル

setRoundProf

public void setRoundProf(String roundProf)
丸めプロファイルを設定します。

パラメータ:
roundProf - 丸めプロファイル

setRefmatcons

public void setRefmatcons(String refmatcons)
消費参照品目を設定します。

パラメータ:
refmatcons - 消費参照品目

setRefpltcons

public void setRefpltcons(String refpltcons)
消費参照プラントを設定します。

パラメータ:
refpltcons - 消費参照プラント

setDToRefM

public void setDToRefM(String dToRefM)
消費データ参照の有効終了日を設定します。

パラメータ:
dToRefM - 消費データ参照の有効終了日

setMultRefM

public void setMultRefM(String multRefM)
消費データ参照品目の乗数を設定します。

パラメータ:
multRefM - 消費データ参照品目の乗数

setAutoReset

public void setAutoReset(String autoReset)
予測モデル自動リセットを設定します。

パラメータ:
autoReset - 予測モデル自動リセット

setPrefStatFlag

public void setPrefStatFlag(String prefStatFlag)
区分: 特恵関税 - 輸出/輸入を設定します。

パラメータ:
prefStatFlag - 区分: 特恵関税 - 輸出/輸入

setExCertId

public void setExCertId(String exCertId)
法令管理: 認定書区分を設定します。

パラメータ:
exCertId - 法令管理: 認定書区分

setExCertNoNew

public void setExCertNoNew(String exCertNoNew)
非該当証明書番号 - 法令管理を設定します。

パラメータ:
exCertNoNew - 非該当証明書番号 - 法令管理

setExCertDt

public void setExCertDt(String exCertDt)
非該当証明書発行日を設定します。

パラメータ:
exCertDt - 非該当証明書発行日

setDeclStatFlag

public void setDeclStatFlag(String declStatFlag)
区分: 仕入先申告ありを設定します。

パラメータ:
declStatFlag - 区分: 仕入先申告あり

setMilitId

public void setMilitId(String militId)
ID: 武器を設定します。

パラメータ:
militId - ID: 武器

setInspInt

public void setInspInt(String inspInt)
次回再検査までの間隔を設定します。

パラメータ:
inspInt - 次回再検査までの間隔

setCoProduct

public void setCoProduct(String coProduct)
区分: 連産品としても使用可能な品目を設定します。

パラメータ:
coProduct - 区分: 連産品としても使用可能な品目

setPlanStrgp

public void setPlanStrgp(String planStrgp)
計画方針グループを設定します。

パラメータ:
planStrgp - 計画方針グループ

setSlocExprc

public void setSlocExprc(String slocExprc)
外部調達の初期保管場所を設定します。

パラメータ:
slocExprc - 外部調達の初期保管場所

setBulkMat

public void setBulkMat(String bulkMat)
区分: バルク品目を設定します。

パラメータ:
bulkMat - 区分: バルク品目

setCcFixed

public void setCcFixed(String ccFixed)
循環棚卸区分固定を設定します。

パラメータ:
ccFixed - 循環棚卸区分固定

setDetermGrp

public void setDetermGrp(String determGrp)
在庫決定グループを設定します。

パラメータ:
determGrp - 在庫決定グループ

setQmAuthgrp

public void setQmAuthgrp(String qmAuthgrp)
QM における活動の品目権限グループを設定します。

パラメータ:
qmAuthgrp - QM における活動の品目権限グループ

setTaskListType

public void setTaskListType(String taskListType)
タスクリストタイプを設定します。

パラメータ:
taskListType - タスクリストタイプ

setPurStatus

public void setPurStatus(String purStatus)
プラント特有品目ステータスを設定します。

パラメータ:
purStatus - プラント特有品目ステータス

setProdprof

public void setProdprof(String prodprof)
製造計画プロファイルを設定します。

パラメータ:
prodprof - 製造計画プロファイル

setSaftyTId

public void setSaftyTId(String saftyTId)
安全時間区分（安全リードタイムあり/なし)を設定します。

パラメータ:
saftyTId - 安全時間区分（安全リードタイムあり/なし)

setSafetytime

public void setSafetytime(String safetytime)
安全時間 (稼動日数)を設定します。

パラメータ:
safetytime - 安全時間 (稼動日数)

setPlordCtrl

public void setPlordCtrl(String plordCtrl)
アクション管理: 計画手配処理を設定します。

パラメータ:
plordCtrl - アクション管理: 計画手配処理

setBatchentry

public void setBatchentry(String batchentry)
製造/プロセス指図でのロット入力設定を設定します。

パラメータ:
batchentry - 製造/プロセス指図でのロット入力設定

setPvalidfrom

public void setPvalidfrom(String pvalidfrom)
プラント品目ステータス有効期間開始日を設定します。

パラメータ:
pvalidfrom - プラント品目ステータス有効期間開始日

setMatfrgtgrp

public void setMatfrgtgrp(String matfrgtgrp)
品目運賃グループを設定します。

パラメータ:
matfrgtgrp - 品目運賃グループ

setProdverscs

public void setProdverscs(String prodverscs)
原価計算を行う製造バージョンを設定します。

パラメータ:
prodverscs - 原価計算を行う製造バージョン

setMatCfop

public void setMatCfop(String matCfop)
品目 CFOP カテゴリを設定します。

パラメータ:
matCfop - 品目 CFOP カテゴリ

setEuListNo

public void setEuListNo(String euListNo)
CAP: CAP 製品一覧番号を設定します。

パラメータ:
euListNo - CAP: CAP 製品一覧番号

setEuMatGrp

public void setEuMatGrp(String euMatGrp)
EEC 農産物政策: CAP 生産品グループ - 貿易を設定します。

パラメータ:
euMatGrp - EEC 農産物政策: CAP 生産品グループ - 貿易

setCasNo

public void setCasNo(String casNo)
CAS 番号： 薬事品目 - 貿易を設定します。

パラメータ:
casNo - CAS 番号： 薬事品目 - 貿易

setProdcomNo

public void setProdcomNo(String prodcomNo)
生産統計: 貿易における PRODCOM コードを設定します。

パラメータ:
prodcomNo - 生産統計: 貿易における PRODCOM コード

setCtrlCode

public void setCtrlCode(String ctrlCode)
貿易: 消費税の管理コードを設定します。

パラメータ:
ctrlCode - 貿易: 消費税の管理コード

setJitRelvt

public void setJitRelvt(String jitRelvt)
区分: JIT 納入日程の関連明細を設定します。

パラメータ:
jitRelvt - 区分: JIT 納入日程の関連明細

setMatGrpTrans

public void setMatGrpTrans(String matGrpTrans)
段取替えマトリクスに対する品目のグループを設定します。

パラメータ:
matGrpTrans - 段取替えマトリクスに対する品目のグループ

setHandlgGrp

public void setHandlgGrp(String handlgGrp)
ワークロード計算のロジスティクス処理グループを設定します。

パラメータ:
handlgGrp - ワークロード計算のロジスティクス処理グループ

setSupplyArea

public void setSupplyArea(String supplyArea)
品目マスタレコードで提案される供給場所を設定します。

パラメータ:
supplyArea - 品目マスタレコードで提案される供給場所

setFairShareRule

public void setFairShareRule(String fairShareRule)
均等配賦ルールを設定します。

パラメータ:
fairShareRule - 均等配賦ルール

setPushDistrib

public void setPushDistrib(String pushDistrib)
区分: プッシュ配賦を設定します。

パラメータ:
pushDistrib - 区分: プッシュ配賦

setDeployHoriz

public void setDeployHoriz(String deployHoriz)
供給分配期間の日数を設定します。

パラメータ:
deployHoriz - 供給分配期間の日数

setMinLotSize

public void setMinLotSize(String minLotSize)
需要と供給を一致させるための最小ロットサイズを設定します。

パラメータ:
minLotSize - 需要と供給を一致させるための最小ロットサイズ

setMaxLotSize

public void setMaxLotSize(String maxLotSize)
需要と供給を一致させるための最大ロットサイズを設定します。

パラメータ:
maxLotSize - 需要と供給を一致させるための最大ロットサイズ

setFixLotSize

public void setFixLotSize(String fixLotSize)
需要供給の一致に対する固定ロットサイズを設定します。

パラメータ:
fixLotSize - 需要供給の一致に対する固定ロットサイズ

setLotIncrement

public void setLotIncrement(String lotIncrement)
需要と供給を一致させるためのロットサイズ増分を設定します。

パラメータ:
lotIncrement - 需要と供給を一致させるためのロットサイズ増分

setProdConvType

public void setProdConvType(String prodConvType)
生産値の変換タイプを設定します。

パラメータ:
prodConvType - 生産値の変換タイプ

setDistrProf

public void setDistrProf(String distrProf)
サイトの商品の物流プロファイルを設定します。

パラメータ:
distrProf - サイトの商品の物流プロファイル

setPeriodProfileSafetyTime

public void setPeriodProfileSafetyTime(String periodProfileSafetyTime)
安全時間の期間プロファイルを設定します。

パラメータ:
periodProfileSafetyTime - 安全時間の期間プロファイル

setFxdPrice

public void setFxdPrice(String fxdPrice)
固定価格連産品を設定します。

パラメータ:
fxdPrice - 固定価格連産品

setAvailCheckAllProjSegments

public void setAvailCheckAllProjSegments(String availCheckAllProjSegments)
プロジェクト間品目区分を設定します。

パラメータ:
availCheckAllProjSegments - プロジェクト間品目区分

setOverallprf

public void setOverallprf(String overallprf)
指図変更管理の全体プロファイルを設定します。

パラメータ:
overallprf - 指図変更管理の全体プロファイル

setMrpRelevancyDepRequirements

public void setMrpRelevancyDepRequirements(String mrpRelevancyDepRequirements)
従属所要量と MRP の関連性を設定します。

パラメータ:
mrpRelevancyDepRequirements - 従属所要量と MRP の関連性

setMrpAreaExists

public void setMrpAreaExists(String mrpAreaExists)
区分: MRP エリア登録済を設定します。

パラメータ:
mrpAreaExists - 区分: MRP エリア登録済

setMinSafetyStk

public void setMinSafetyStk(String minSafetyStk)
最小安全在庫を設定します。

パラメータ:
minSafetyStk - 最小安全在庫

setNoCosting

public void setNoCosting(String noCosting)
原価計算なしを設定します。

パラメータ:
noCosting - 原価計算なし

setUnitGroup

public void setUnitGroup(String unitGroup)
数量単位グループを設定します。

パラメータ:
unitGroup - 数量単位グループ

setFollowUpExternal

public void setFollowUpExternal(String followUpExternal)
項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
followUpExternal - 項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)

setFollowUpGuid

public void setFollowUpGuid(String followUpGuid)
項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
followUpGuid - 項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)

setFollowUpVersion

public void setFollowUpVersion(String followUpVersion)
項目 FOLLOW_UP のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
followUpVersion - 項目 FOLLOW_UP のバージョン番号 (今後の リリースで開発)

setRefmatconsExternal

public void setRefmatconsExternal(String refmatconsExternal)
項目 REFMATCONS の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
refmatconsExternal - 項目 REFMATCONS の品目コード (長) (今後の リリースで開発)

setRefmatconsGuid

public void setRefmatconsGuid(String refmatconsGuid)
項目 REFMATCONS の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
refmatconsGuid - 項目 REFMATCONS の外部 GUID (今後のリリースで開発)

setRefmatconsVersion

public void setRefmatconsVersion(String refmatconsVersion)
項目 REFMATCONS のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
refmatconsVersion - 項目 REFMATCONS のバージョン番号 (今後の リリースで開発)

setSalesView

public void setSalesView(String salesView)
販売ビューを設定します。

パラメータ:
salesView - 販売ビュー

setPurchView

public void setPurchView(String purchView)
購買管理ビューを設定します。

パラメータ:
purchView - 購買管理ビュー

setMrpView

public void setMrpView(String mrpView)
資材所要量計画 (MRP) ビューを設定します。

パラメータ:
mrpView - 資材所要量計画 (MRP) ビュー

setForecastView

public void setForecastView(String forecastView)
需要予測ビューを設定します。

パラメータ:
forecastView - 需要予測ビュー

setWorkSchedView

public void setWorkSchedView(String workSchedView)
作業計画ビューを設定します。

パラメータ:
workSchedView - 作業計画ビュー

setPrtView

public void setPrtView(String prtView)
生産資源/治工具 (PRT) ビューを設定します。

パラメータ:
prtView - 生産資源/治工具 (PRT) ビュー

setStorageView

public void setStorageView(String storageView)
保管ビューを設定します。

パラメータ:
storageView - 保管ビュー

setWarehouseView

public void setWarehouseView(String warehouseView)
倉庫管理ビューを設定します。

パラメータ:
warehouseView - 倉庫管理ビュー

setQualityView

public void setQualityView(String qualityView)
品質管理ビューを設定します。

パラメータ:
qualityView - 品質管理ビュー

setAccountView

public void setAccountView(String accountView)
会計ビューを設定します。

パラメータ:
accountView - 会計ビュー

setCostView

public void setCostView(String costView)
原価計算ビューを設定します。

パラメータ:
costView - 原価計算ビュー

setRotationDate

public void setRotationDate(String rotationDate)
原価計算ビューを設定します。

パラメータ:
rotationDate - 原価計算ビュー

setOriginalBatchFlag

public void setOriginalBatchFlag(String originalBatchFlag)
元ロット管理区分を設定します。

パラメータ:
originalBatchFlag - 元ロット管理区分

setOriginalBatchRefMaterial

public void setOriginalBatchRefMaterial(String originalBatchRefMaterial)
元ロットの参照品目を設定します。

パラメータ:
originalBatchRefMaterial - 元ロットの参照品目

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PlantDataList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス PlantDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList
すべての実装インタフェース:
Serializable
public class PlantDataList
extends PlantData
implements Serializable

品目データ (プラントレベル)情報クラス
機能は以下の通り

  • 品目データ (プラントレベル)情報をテーブル型で保持します。

関連項目:
直列化された形式

コンストラクタの概要
PlantDataList()
品目データ (プラントレベル)情報を作成します。
PlantDataList(int index)
品目データ (プラントレベル)情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData から継承したメソッド
getAbcId, getAccountView, getAltBomId, getAlternativeBom, getAssyScrap, getAutoPOrd, getAutoReset, getAvailcheck, getAvailCheckAllProjSegments, getBackflush, getBaseQty, getBaseQtyPlan, getBatchentry, getBatchMgmt, getBomUsage, getBulkMat, getBwdCons, getCasNo, getCcFixed, getCcPhInv, getCertType, getCommCode, getCommCoUn, getCommCoUnIso, getCompScrap, getConsummode, getCoProduct, getCorrFact, getCostView, getCountryori, getCountryoriIso, getCovprofile, getCritPart, getCtrlCode, getCtrlKey, getCycleTime, getDeclStatFlag, getDelFlag, getDeployHoriz, getDepReqId, getDetermGrp, getDiscontinu, getDistrProf, getDocReqd, getDToRefM, getEffODay, getEuListNo, getEuMatGrp, getExCertDt, getExCertId, getExCertNoNew, getExpimpgrp, getFairShareRule, getFixedLot, getFixLotSize, getFollowUp, getFollowUpExternal, getFollowUpGuid, getFollowUpVersion, getForecastView, getFunction, getFwdCons, getFxdPrice, getFyVariant, getGrpReqmts, getGrPrTime, getHandlgGrp, getIndPostToInspStock, getInhseprodt, getInspInt, getInspSetupFlag, getInterop, getIssStLoc, getIssueUnit, getIssueUnitIso, getJitRelvt, getLoadinggrp, getLotIncrement, getLotSize, getLotsizekey, getMaintStat, getMatCfop, getMaterial, getMatfrgtgrp, getMatGrpTrans, getMaxlotsize, getMaxLotSize, getMaxStock, getMilitId, getMinlotsize, getMinLotSize, getMinSafetyStk, getMixedMrp, getMrpAreaExists, getMrpCtrler, getMrpGroup, getMrpprofile, getMrpRelevancyDepRequirements, getMrpType, getMrpView, getMultRefM, getNegStocks, getNoCosting, getOrdCosts, getOriginalBatchFlag, getOriginalBatchRefMaterial, getOverallprf, getOverTol, getPeriodInd, getPeriodProfileSafetyTime, getPlanlistcnt, getPlanlistgrp, getPlanStrgp, getPlant, getPlndDelry, getPlngCycle, getPlordCtrl, getPlTiFnce, getPpcPlCal, getPrefStatFlag, getProcTime, getProcType, getProdcomNo, getProdConvType, getProdprof, getProductionScheduler, getProdUnit, getProdUnitIso, getProdverscs, getProfitCtr, getPrtView, getPsConfMat, getPurchView, getPurGroup, getPurStatus, getPushDistrib, getPvalidfrom, getQmAuthgrp, getQmRgmts, getQualityView, getQuotausage, getRefmatcons, getRefmatconsExternal, getRefmatconsGuid, getRefmatconsVersion, getRefpltcons, getRegionorig, getReorderPt, getReplacePt, getReplentime, getRepmanprof, getRepManuf, getRotationDate, getRoundProf, getRoundVal, getSafetyStk, getSafetytime, getSaftyTId, getSalesView, getSernoProf, getServLevel, getSetuptime, getSetupTime, getShipProcTime, getSlocExprc, getSmKey, getSourcelist, getSpecprocty, getSplitInd, getSpproctype, getStgePdUn, getStgePdUnIso, getStgeperiod, getStorageView, getStorCosts, getSupplyArea, getSupSource, getTaskListType, getUnderTol, getUnitGroup, getUnlimited, getVarianceKey, getVersionFlag, getWarehouseView, getWorkSchedView, setAbcId, setAccountView, setAltBomId, setAlternativeBom, setAssyScrap, setAutoPOrd, setAutoReset, setAvailcheck, setAvailCheckAllProjSegments, setBackflush, setBaseQty, setBaseQtyPlan, setBatchentry, setBatchMgmt, setBomUsage, setBulkMat, setBwdCons, setCasNo, setCcFixed, setCcPhInv, setCertType, setCommCode, setCommCoUn, setCommCoUnIso, setCompScrap, setConsummode, setCoProduct, setCorrFact, setCostView, setCountryori, setCountryoriIso, setCovprofile, setCritPart, setCtrlCode, setCtrlKey, setCycleTime, setDeclStatFlag, setDelFlag, setDeployHoriz, setDepReqId, setDetermGrp, setDiscontinu, setDistrProf, setDocReqd, setDToRefM, setEffODay, setEuListNo, setEuMatGrp, setExCertDt, setExCertId, setExCertNoNew, setExpimpgrp, setFairShareRule, setFixedLot, setFixLotSize, setFollowUp, setFollowUpExternal, setFollowUpGuid, setFollowUpVersion, setForecastView, setFunction, setFwdCons, setFxdPrice, setFyVariant, setGrpReqmts, setGrPrTime, setHandlgGrp, setIndPostToInspStock, setInhseprodt, setInspInt, setInspSetupFlag, setInterop, setIssStLoc, setIssueUnit, setIssueUnitIso, setJitRelvt, setLoadinggrp, setLotIncrement, setLotSize, setLotsizekey, setMaintStat, setMatCfop, setMaterial, setMatfrgtgrp, setMatGrpTrans, setMaxlotsize, setMaxLotSize, setMaxStock, setMilitId, setMinlotsize, setMinLotSize, setMinSafetyStk, setMixedMrp, setMrpAreaExists, setMrpCtrler, setMrpGroup, setMrpprofile, setMrpRelevancyDepRequirements, setMrpType, setMrpView, setMultRefM, setNegStocks, setNoCosting, setOrdCosts, setOriginalBatchFlag, setOriginalBatchRefMaterial, setOverallprf, setOverTol, setPeriodInd, setPeriodProfileSafetyTime, setPlanlistcnt, setPlanlistgrp, setPlanStrgp, setPlant, setPlndDelry, setPlngCycle, setPlordCtrl, setPlTiFnce, setPpcPlCal, setPrefStatFlag, setProcTime, setProcType, setProdcomNo, setProdConvType, setProdprof, setProductionScheduler, setProdUnit, setProdUnitIso, setProdverscs, setProfitCtr, setPrtView, setPsConfMat, setPurchView, setPurGroup, setPurStatus, setPushDistrib, setPvalidfrom, setQmAuthgrp, setQmRgmts, setQualityView, setQuotausage, setRefmatcons, setRefmatconsExternal, setRefmatconsGuid, setRefmatconsVersion, setRefpltcons, setRegionorig, setReorderPt, setReplacePt, setReplentime, setRepmanprof, setRepManuf, setRotationDate, setRoundProf, setRoundVal, setSafetyStk, setSafetytime, setSaftyTId, setSalesView, setSernoProf, setServLevel, setSetuptime, setSetupTime, setShipProcTime, setSlocExprc, setSmKey, setSourcelist, setSpecprocty, setSplitInd, setSpproctype, setStgePdUn, setStgePdUnIso, setStgeperiod, setStorageView, setStorCosts, setSupplyArea, setSupSource, setTaskListType, setUnderTol, setUnitGroup, setUnlimited, setVarianceKey, setVersionFlag, setWarehouseView, setWorkSchedView, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PlantDataList

public PlantDataList()
品目データ (プラントレベル)情報を作成します。

PlantDataList

public PlantDataList(int index)
品目データ (プラントレベル)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SalesData (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス SalesData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
SalesDataList
public class SalesData
extends Object
implements Serializable

販売データ情報クラス
機能は以下の通り

  • 販売データ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
SalesData()
販売データ情報を作成します。
メソッドの概要
String | getAcctAssgt() 品目の勘定設定グループを取得します。
String | getCashDisc() 現金値引区分を取得します。
String | getCommGroup() 手数料グループを取得します。
String | getDelFlag() 区分: 流通チャネルレベルでの品目削除フラグを取得します。
String | getDelygPlnt() 出荷プラントを取得します。
String | getDelyUnit() 出荷単位を取得します。
String | getDelyUom() 出荷数量単位を取得します。
String | getDelyUomIso() ISO コードでの出荷単位の数量単位を取得します。
String | getDistrChan() 流通チャネルを取得します。
String | getFunction() BAPI 機能を取得します。
String | getItemCat() 品目マスタの明細カテゴリグループを取得します。
String | getMaterial() 品目コードを取得します。
String | getMatlGrp1() 品目グループ 1を取得します。
String | getMatlGrp2() 品目グループ 2を取得します。
String | getMatlGrp3() 品目グループ 3を取得します。
String | getMatlGrp4() 品目グループ 4を取得します。
String | getMatlGrp5() 品目グループ 5を取得します。
String | getMatlStats() 品目統計グループを取得します。
String | getMatPrGrp() 品目価格設定グループを取得します。
String | getMinDely() 納品書処理時の最小納入数量を取得します。
String | getMinMto() 受注製造品最少受注数量を取得します。
String | getMinOrder() 基本数量単位での最小受注数量を取得します。
String | getProdAtt1() ID: 製品属性 1を取得します。
String | getProdAtt10() 品目属性 10 用 IDを取得します。
String | getProdAtt2() 品目属性 2 用 IDを取得します。
String | getProdAtt3() 品目属性 3 用 IDを取得します。
String | getProdAtt4() 品目属性 4 用 IDを取得します。
String | getProdAtt5() 品目属性 5 用 IDを取得します。
String | getProdAtt6() 品目属性 6 の IDを取得します。
String | getProdAtt7() 品目属性 7 用 IDを取得します。
String | getProdAtt8() 品目属性 8 用 IDを取得します。
String | getProdAtt9() 品目属性 9を取得します。
String | getProdHier() 品目階層を取得します。
String | getPrRefMat() 価格設定参照品目を取得します。
String | getPrRefMatExternal() 項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を取得します。
String | getPrRefMatGuid() 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を取得します。
String | getPrRefMatVersion() 項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を取得します。
String | getRebateGrp() 取引量リベートグループを取得します。
String | getRoundProf() 丸めプロファイルを取得します。
String | getSalesOrg() 販売組織を取得します。
String | getSalesUnit() 販売単位を取得します。
String | getSalesUnitIso() ISO コードによる販売単位を取得します。
String | getSalStatus() 販売ビューからの品目ステータスを取得します。
String | getUnitGroup() 数量単位グループを取得します。
String | getValidFrom() 流通チェーン別品目ステータスの有効期間開始日を取得します。
String | getVarSalesUn() 可変販売単位の使用不可を取得します。
void | setAcctAssgt(String acctAssgt) 品目の勘定設定グループを設定します。
void | setCashDisc(String cashDisc) 現金値引区分を設定します。
void | setCommGroup(String commGroup) 手数料グループを設定します。
void | setDelFlag(String delFlag) 区分: 流通チャネルレベルでの品目削除フラグを設定します。
void | setDelygPlnt(String delygPlnt) 出荷プラントを設定します。
void | setDelyUnit(String delyUnit) 出荷単位を設定します。
void | setDelyUom(String delyUom) 出荷数量単位を設定します。
void | setDelyUomIso(String delyUomIso) ISO コードでの出荷単位の数量単位を設定します。
void | setDistrChan(String distrChan) 流通チャネルを設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setItemCat(String itemCat) 品目マスタの明細カテゴリグループを設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMatlGrp1(String matlGrp1) 品目グループ 1を設定します。
void | setMatlGrp2(String matlGrp2) 品目グループ 2を設定します。
void | setMatlGrp3(String matlGrp3) 品目グループ 3を設定します。
void | setMatlGrp4(String matlGrp4) 品目グループ 4を設定します。
void | setMatlGrp5(String matlGrp5) 品目グループ 5を設定します。
void | setMatlStats(String matlStats) 品目統計グループを設定します。
void | setMatPrGrp(String matPrGrp) 品目価格設定グループを設定します。
void | setMinDely(String minDely) 納品書処理時の最小納入数量を設定します。
void | setMinMto(String minMto) 受注製造品最少受注数量を設定します。
void | setMinOrder(String minOrder) 基本数量単位での最小受注数量を設定します。
void | setProdAtt1(String prodAtt1) ID: 製品属性 1を設定します。
void | setProdAtt10(String prodAtt10) 品目属性 10 用 IDを設定します。
void | setProdAtt2(String prodAtt2) 品目属性 2 用 IDを設定します。
void | setProdAtt3(String prodAtt3) 品目属性 3 用 IDを設定します。
void | setProdAtt4(String prodAtt4) 品目属性 4 用 IDを設定します。
void | setProdAtt5(String prodAtt5) 品目属性 5 用 IDを設定します。
void | setProdAtt6(String prodAtt6) 品目属性 6 の IDを設定します。
void | setProdAtt7(String prodAtt7) 品目属性 7 用 IDを設定します。
void | setProdAtt8(String prodAtt8) 品目属性 8 用 IDを設定します。
void | setProdAtt9(String prodAtt9) 品目属性 9を設定します。
void | setProdHier(String prodHier) 品目階層を設定します。
void | setPrRefMat(String prRefMat) 価格設定参照品目を設定します。
void | setPrRefMatExternal(String prRefMatExternal) 項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を設定します。
void | setPrRefMatGuid(String prRefMatGuid) 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を設定します。
void | setPrRefMatVersion(String prRefMatVersion) 項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を設定します。
void | setRebateGrp(String rebateGrp) 取引量リベートグループを設定します。
void | setRoundProf(String roundProf) 丸めプロファイルを設定します。
void | setSalesOrg(String salesOrg) 販売組織を設定します。
void | setSalesUnit(String salesUnit) 販売単位を設定します。
void | setSalesUnitIso(String salesUnitIso) ISO コードによる販売単位を設定します。
void | setSalStatus(String salStatus) 販売ビューからの品目ステータスを設定します。
void | setUnitGroup(String unitGroup) 数量単位グループを設定します。
void | setValidFrom(String validFrom) 流通チェーン別品目ステータスの有効期間開始日を設定します。
void | setVarSalesUn(String varSalesUn) 可変販売単位の使用不可を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesData

public SalesData()
販売データ情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getSalesOrg

public String getSalesOrg()
販売組織を取得します。

戻り値:
salesOrg 販売組織

getDistrChan

public String getDistrChan()
流通チャネルを取得します。

戻り値:
distrChan 流通チャネル

getDelFlag

public String getDelFlag()
区分: 流通チャネルレベルでの品目削除フラグを取得します。

戻り値:
delFlag 区分: 流通チャネルレベルでの品目削除フラグ

getMatlStats

public String getMatlStats()
品目統計グループを取得します。

戻り値:
matlStats 品目統計グループ

getRebateGrp

public String getRebateGrp()
取引量リベートグループを取得します。

戻り値:
rebateGrp 取引量リベートグループ

getCommGroup

public String getCommGroup()
手数料グループを取得します。

戻り値:
commGroup 手数料グループ

getCashDisc

public String getCashDisc()
現金値引区分を取得します。

戻り値:
cashDisc 現金値引区分

getSalStatus

public String getSalStatus()
販売ビューからの品目ステータスを取得します。

戻り値:
salStatus 販売ビューからの品目ステータス

getValidFrom

public String getValidFrom()
流通チェーン別品目ステータスの有効期間開始日を取得します。

戻り値:
validFrom 流通チェーン別品目ステータスの有効期間開始日

getMinOrder

public String getMinOrder()
基本数量単位での最小受注数量を取得します。

戻り値:
minOrder 基本数量単位での最小受注数量

getMinDely

public String getMinDely()
納品書処理時の最小納入数量を取得します。

戻り値:
minDely 納品書処理時の最小納入数量

getMinMto

public String getMinMto()
受注製造品最少受注数量を取得します。

戻り値:
minMto 受注製造品最少受注数量

getDelyUnit

public String getDelyUnit()
出荷単位を取得します。

戻り値:
delyUnit 出荷単位

getDelyUom

public String getDelyUom()
出荷数量単位を取得します。

戻り値:
delyUom 出荷数量単位

getDelyUomIso

public String getDelyUomIso()
ISO コードでの出荷単位の数量単位を取得します。

戻り値:
delyUomIso ISO コードでの出荷単位の数量単位

getSalesUnit

public String getSalesUnit()
販売単位を取得します。

戻り値:
salesUnit 販売単位

getSalesUnitIso

public String getSalesUnitIso()
ISO コードによる販売単位を取得します。

戻り値:
salesUnitIso ISO コードによる販売単位

getItemCat

public String getItemCat()
品目マスタの明細カテゴリグループを取得します。

戻り値:
itemCat 品目マスタの明細カテゴリグループ

getDelygPlnt

public String getDelygPlnt()
出荷プラントを取得します。

戻り値:
delygPlnt 出荷プラント

getProdHier

public String getProdHier()
品目階層を取得します。

戻り値:
prodHier 品目階層

getPrRefMat

public String getPrRefMat()
価格設定参照品目を取得します。

戻り値:
prRefMat 価格設定参照品目

getMatPrGrp

public String getMatPrGrp()
品目価格設定グループを取得します。

戻り値:
matPrGrp 品目価格設定グループ

getAcctAssgt

public String getAcctAssgt()
品目の勘定設定グループを取得します。

戻り値:
acctAssgt 品目の勘定設定グループ

getMatlGrp1

public String getMatlGrp1()
品目グループ 1を取得します。

戻り値:
matlGrp1 品目グループ 1

getMatlGrp2

public String getMatlGrp2()
品目グループ 2を取得します。

戻り値:
matlGrp2 品目グループ 2

getMatlGrp3

public String getMatlGrp3()
品目グループ 3を取得します。

戻り値:
matlGrp3 品目グループ 3

getMatlGrp4

public String getMatlGrp4()
品目グループ 4を取得します。

戻り値:
matlGrp4 品目グループ 4

getMatlGrp5

public String getMatlGrp5()
品目グループ 5を取得します。

戻り値:
matlGrp5 品目グループ 5

getProdAtt1

public String getProdAtt1()
ID: 製品属性 1を取得します。

戻り値:
prodAtt1 ID: 製品属性 1

getProdAtt2

public String getProdAtt2()
品目属性 2 用 IDを取得します。

戻り値:
prodAtt2 品目属性 2 用 ID

getProdAtt3

public String getProdAtt3()
品目属性 3 用 IDを取得します。

戻り値:
prodAtt3 品目属性 3 用 ID

getProdAtt4

public String getProdAtt4()
品目属性 4 用 IDを取得します。

戻り値:
prodAtt4 品目属性 4 用 ID

getProdAtt5

public String getProdAtt5()
品目属性 5 用 IDを取得します。

戻り値:
prodAtt5 品目属性 5 用 ID

getProdAtt6

public String getProdAtt6()
品目属性 6 の IDを取得します。

戻り値:
prodAtt6 品目属性 6 の ID

getProdAtt7

public String getProdAtt7()
品目属性 7 用 IDを取得します。

戻り値:
prodAtt7 品目属性 7 用 ID

getProdAtt8

public String getProdAtt8()
品目属性 8 用 IDを取得します。

戻り値:
prodAtt8 品目属性 8 用 ID

getProdAtt9

public String getProdAtt9()
品目属性 9を取得します。

戻り値:
prodAtt9 品目属性 9

getProdAtt10

public String getProdAtt10()
品目属性 10 用 IDを取得します。

戻り値:
prodAtt10 品目属性 10 用 ID

getRoundProf

public String getRoundProf()
丸めプロファイルを取得します。

戻り値:
roundProf 丸めプロファイル

getVarSalesUn

public String getVarSalesUn()
可変販売単位の使用不可を取得します。

戻り値:
varSalesUn 可変販売単位の使用不可

getUnitGroup

public String getUnitGroup()
数量単位グループを取得します。

戻り値:
unitGroup 数量単位グループ

getPrRefMatExternal

public String getPrRefMatExternal()
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
prRefMatExternal 項目 PR_REF_MAT の品目コード (長) (今後の リリースで開発)

getPrRefMatGuid

public String getPrRefMatGuid()
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
prRefMatGuid 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)

getPrRefMatVersion

public String getPrRefMatVersion()
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
prRefMatVersion 項目 PR_REF_MAT のバージョン番号 (今後の リリースで開発)

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setSalesOrg

public void setSalesOrg(String salesOrg)
販売組織を設定します。

パラメータ:
salesOrg - 販売組織

setDistrChan

public void setDistrChan(String distrChan)
流通チャネルを設定します。

パラメータ:
distrChan - 流通チャネル

setDelFlag

public void setDelFlag(String delFlag)
区分: 流通チャネルレベルでの品目削除フラグを設定します。

パラメータ:
delFlag - 区分: 流通チャネルレベルでの品目削除フラグ

setMatlStats

public void setMatlStats(String matlStats)
品目統計グループを設定します。

パラメータ:
matlStats - 品目統計グループ

setRebateGrp

public void setRebateGrp(String rebateGrp)
取引量リベートグループを設定します。

パラメータ:
rebateGrp - 取引量リベートグループ

setCommGroup

public void setCommGroup(String commGroup)
手数料グループを設定します。

パラメータ:
commGroup - 手数料グループ

setCashDisc

public void setCashDisc(String cashDisc)
現金値引区分を設定します。

パラメータ:
cashDisc - 現金値引区分

setSalStatus

public void setSalStatus(String salStatus)
販売ビューからの品目ステータスを設定します。

パラメータ:
salStatus - 販売ビューからの品目ステータス

setValidFrom

public void setValidFrom(String validFrom)
流通チェーン別品目ステータスの有効期間開始日を設定します。

パラメータ:
validFrom - 流通チェーン別品目ステータスの有効期間開始日

setMinOrder

public void setMinOrder(String minOrder)
基本数量単位での最小受注数量を設定します。

パラメータ:
minOrder - 基本数量単位での最小受注数量

setMinDely

public void setMinDely(String minDely)
納品書処理時の最小納入数量を設定します。

パラメータ:
minDely - 納品書処理時の最小納入数量

setMinMto

public void setMinMto(String minMto)
受注製造品最少受注数量を設定します。

パラメータ:
minMto - 受注製造品最少受注数量

setDelyUnit

public void setDelyUnit(String delyUnit)
出荷単位を設定します。

パラメータ:
delyUnit - 出荷単位

setDelyUom

public void setDelyUom(String delyUom)
出荷数量単位を設定します。

パラメータ:
delyUom - 出荷数量単位

setDelyUomIso

public void setDelyUomIso(String delyUomIso)
ISO コードでの出荷単位の数量単位を設定します。

パラメータ:
delyUomIso - ISO コードでの出荷単位の数量単位

setSalesUnit

public void setSalesUnit(String salesUnit)
販売単位を設定します。

パラメータ:
salesUnit - 販売単位

setSalesUnitIso

public void setSalesUnitIso(String salesUnitIso)
ISO コードによる販売単位を設定します。

パラメータ:
salesUnitIso - ISO コードによる販売単位

setItemCat

public void setItemCat(String itemCat)
品目マスタの明細カテゴリグループを設定します。

パラメータ:
itemCat - 品目マスタの明細カテゴリグループ

setDelygPlnt

public void setDelygPlnt(String delygPlnt)
出荷プラントを設定します。

パラメータ:
delygPlnt - 出荷プラント

setProdHier

public void setProdHier(String prodHier)
品目階層を設定します。

パラメータ:
prodHier - 品目階層

setPrRefMat

public void setPrRefMat(String prRefMat)
価格設定参照品目を設定します。

パラメータ:
prRefMat - 価格設定参照品目

setMatPrGrp

public void setMatPrGrp(String matPrGrp)
品目価格設定グループを設定します。

パラメータ:
matPrGrp - 品目価格設定グループ

setAcctAssgt

public void setAcctAssgt(String acctAssgt)
品目の勘定設定グループを設定します。

パラメータ:
acctAssgt - 品目の勘定設定グループ

setMatlGrp1

public void setMatlGrp1(String matlGrp1)
品目グループ 1を設定します。

パラメータ:
matlGrp1 - 品目グループ 1

setMatlGrp2

public void setMatlGrp2(String matlGrp2)
品目グループ 2を設定します。

パラメータ:
matlGrp2 - 品目グループ 2

setMatlGrp3

public void setMatlGrp3(String matlGrp3)
品目グループ 3を設定します。

パラメータ:
matlGrp3 - 品目グループ 3

setMatlGrp4

public void setMatlGrp4(String matlGrp4)
品目グループ 4を設定します。

パラメータ:
matlGrp4 - 品目グループ 4

setMatlGrp5

public void setMatlGrp5(String matlGrp5)
品目グループ 5を設定します。

パラメータ:
matlGrp5 - 品目グループ 5

setProdAtt1

public void setProdAtt1(String prodAtt1)
ID: 製品属性 1を設定します。

パラメータ:
prodAtt1 - ID: 製品属性 1

setProdAtt2

public void setProdAtt2(String prodAtt2)
品目属性 2 用 IDを設定します。

パラメータ:
prodAtt2 - 品目属性 2 用 ID

setProdAtt3

public void setProdAtt3(String prodAtt3)
品目属性 3 用 IDを設定します。

パラメータ:
prodAtt3 - 品目属性 3 用 ID

setProdAtt4

public void setProdAtt4(String prodAtt4)
品目属性 4 用 IDを設定します。

パラメータ:
prodAtt4 - 品目属性 4 用 ID

setProdAtt5

public void setProdAtt5(String prodAtt5)
品目属性 5 用 IDを設定します。

パラメータ:
prodAtt5 - 品目属性 5 用 ID

setProdAtt6

public void setProdAtt6(String prodAtt6)
品目属性 6 の IDを設定します。

パラメータ:
prodAtt6 - 品目属性 6 の ID

setProdAtt7

public void setProdAtt7(String prodAtt7)
品目属性 7 用 IDを設定します。

パラメータ:
prodAtt7 - 品目属性 7 用 ID

setProdAtt8

public void setProdAtt8(String prodAtt8)
品目属性 8 用 IDを設定します。

パラメータ:
prodAtt8 - 品目属性 8 用 ID

setProdAtt9

public void setProdAtt9(String prodAtt9)
品目属性 9を設定します。

パラメータ:
prodAtt9 - 品目属性 9

setProdAtt10

public void setProdAtt10(String prodAtt10)
品目属性 10 用 IDを設定します。

パラメータ:
prodAtt10 - 品目属性 10 用 ID

setRoundProf

public void setRoundProf(String roundProf)
丸めプロファイルを設定します。

パラメータ:
roundProf - 丸めプロファイル

setVarSalesUn

public void setVarSalesUn(String varSalesUn)
可変販売単位の使用不可を設定します。

パラメータ:
varSalesUn - 可変販売単位の使用不可

setUnitGroup

public void setUnitGroup(String unitGroup)
数量単位グループを設定します。

パラメータ:
unitGroup - 数量単位グループ

setPrRefMatExternal

public void setPrRefMatExternal(String prRefMatExternal)
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
prRefMatExternal - 項目 PR_REF_MAT の品目コード (長) (今後の リリースで開発)

setPrRefMatGuid

public void setPrRefMatGuid(String prRefMatGuid)
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
prRefMatGuid - 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)

setPrRefMatVersion

public void setPrRefMatVersion(String prRefMatVersion)
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
prRefMatVersion - 項目 PR_REF_MAT のバージョン番号 (今後の リリースで開発)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SalesDataList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス SalesDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList
すべての実装インタフェース:
Serializable
public class SalesDataList
extends SalesData
implements Serializable

販売データ情報クラス
機能は以下の通り

  • 販売データ情報をテーブル型で保持します。

関連項目:
直列化された形式

コンストラクタの概要
SalesDataList()
販売データ情報を作成します。
SalesDataList(int index)
販売データ情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData から継承したメソッド
getAcctAssgt, getCashDisc, getCommGroup, getDelFlag, getDelygPlnt, getDelyUnit, getDelyUom, getDelyUomIso, getDistrChan, getFunction, getItemCat, getMaterial, getMatlGrp1, getMatlGrp2, getMatlGrp3, getMatlGrp4, getMatlGrp5, getMatlStats, getMatPrGrp, getMinDely, getMinMto, getMinOrder, getProdAtt1, getProdAtt10, getProdAtt2, getProdAtt3, getProdAtt4, getProdAtt5, getProdAtt6, getProdAtt7, getProdAtt8, getProdAtt9, getProdHier, getPrRefMat, getPrRefMatExternal, getPrRefMatGuid, getPrRefMatVersion, getRebateGrp, getRoundProf, getSalesOrg, getSalesUnit, getSalesUnitIso, getSalStatus, getUnitGroup, getValidFrom, getVarSalesUn, setAcctAssgt, setCashDisc, setCommGroup, setDelFlag, setDelygPlnt, setDelyUnit, setDelyUom, setDelyUomIso, setDistrChan, setFunction, setItemCat, setMaterial, setMatlGrp1, setMatlGrp2, setMatlGrp3, setMatlGrp4, setMatlGrp5, setMatlStats, setMatPrGrp, setMinDely, setMinMto, setMinOrder, setProdAtt1, setProdAtt10, setProdAtt2, setProdAtt3, setProdAtt4, setProdAtt5, setProdAtt6, setProdAtt7, setProdAtt8, setProdAtt9, setProdHier, setPrRefMat, setPrRefMatExternal, setPrRefMatGuid, setPrRefMatVersion, setRebateGrp, setRoundProf, setSalesOrg, setSalesUnit, setSalesUnitIso, setSalStatus, setUnitGroup, setValidFrom, setVarSalesUn, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesDataList

public SalesDataList()
販売データ情報を作成します。

SalesDataList

public SalesDataList(int index)
販売データ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StorageLocationData (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス StorageLocationData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
StorageLocationDataList
public class StorageLocationData
extends Object
implements Serializable

品目データ (保管場所レベル)情報クラス
機能は以下の通り

  • 品目データ (保管場所レベル)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
StorageLocationData()
品目データ (保管場所レベル)情報を作成します。
メソッドの概要
String | getCurrPeriod() 当期 (転記期間)を取得します。
String | getDelFlag() 保管場所レベルでの品目削除フラグを取得します。
String | getFiscYear() 当会計年度を取得します。
String | getFunction() BAPI 機能を取得します。
String | getInvCorrFac() 在庫修正係数を取得します。
String | getMaintStat() 更新ステータスを取得します。
String | getMaterial() 品目コードを取得します。
String | getMrpInd() 保管場所 MRP 区分を取得します。
String | getMrpView() 資材所要量計画 (MRP) ビューを取得します。
String | getPickgArea() 簡易倉庫管理のピッキングエリアを取得します。
String | getPlant() プラントを取得します。
String | getReorderPt() 保管場所 MRP に対する発注点を取得します。
String | getReplQty() 保管場所 MRP に対する補充数量を取得します。
String | getSpecProc() 保管場所レベルでの特殊調達タイプを取得します。
String | getStgeBin() 棚番を取得します。
String | getStgeLoc() 保管場所を取得します。
String | getStorageView() 保管ビューを取得します。
void | setCurrPeriod(String currPeriod) 当期 (転記期間)を設定します。
void | setDelFlag(String delFlag) 保管場所レベルでの品目削除フラグを設定します。
void | setFiscYear(String fiscYear) 当会計年度を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setInvCorrFac(String invCorrFac) 在庫修正係数を設定します。
void | setMaintStat(String maintStat) 更新ステータスを設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMrpInd(String mrpInd) 保管場所 MRP 区分を設定します。
void | setMrpView(String mrpView) 資材所要量計画 (MRP) ビューを設定します。
void | setPickgArea(String pickgArea) 簡易倉庫管理のピッキングエリアを設定します。
void | setPlant(String plant) プラントを設定します。
void | setReorderPt(String reorderPt) 保管場所 MRP に対する発注点を設定します。
void | setReplQty(String replQty) 保管場所 MRP に対する補充数量を設定します。
void | setSpecProc(String specProc) 保管場所レベルでの特殊調達タイプを設定します。
void | setStgeBin(String stgeBin) 棚番を設定します。
void | setStgeLoc(String stgeLoc) 保管場所を設定します。
void | setStorageView(String storageView) 保管ビューを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StorageLocationData

public StorageLocationData()
品目データ (保管場所レベル)情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getStgeLoc

public String getStgeLoc()
保管場所を取得します。

戻り値:
stgeLoc 保管場所

getMaintStat

public String getMaintStat()
更新ステータスを取得します。

戻り値:
maintStat 更新ステータス

getDelFlag

public String getDelFlag()
保管場所レベルでの品目削除フラグを取得します。

戻り値:
delFlag 保管場所レベルでの品目削除フラグ

getFiscYear

public String getFiscYear()
当会計年度を取得します。

戻り値:
fiscYear 当会計年度

getCurrPeriod

public String getCurrPeriod()
当期 (転記期間)を取得します。

戻り値:
currPeriod 当期 (転記期間)

getMrpInd

public String getMrpInd()
保管場所 MRP 区分を取得します。

戻り値:
mrpInd 保管場所 MRP 区分

getSpecProc

public String getSpecProc()
保管場所レベルでの特殊調達タイプを取得します。

戻り値:
specProc 保管場所レベルでの特殊調達タイプ

getReorderPt

public String getReorderPt()
保管場所 MRP に対する発注点を取得します。

戻り値:
reorderPt 保管場所 MRP に対する発注点

getReplQty

public String getReplQty()
保管場所 MRP に対する補充数量を取得します。

戻り値:
replQty 保管場所 MRP に対する補充数量

getStgeBin

public String getStgeBin()
棚番を取得します。

戻り値:
stgeBin 棚番

getPickgArea

public String getPickgArea()
簡易倉庫管理のピッキングエリアを取得します。

戻り値:
pickgArea 簡易倉庫管理のピッキングエリア

getInvCorrFac

public String getInvCorrFac()
在庫修正係数を取得します。

戻り値:
invCorrFac 在庫修正係数

getMrpView

public String getMrpView()
資材所要量計画 (MRP) ビューを取得します。

戻り値:
mrpView 資材所要量計画 (MRP) ビュー

getStorageView

public String getStorageView()
保管ビューを取得します。

戻り値:
storageView 保管ビュー

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setStgeLoc

public void setStgeLoc(String stgeLoc)
保管場所を設定します。

パラメータ:
stgeLoc - 保管場所

setMaintStat

public void setMaintStat(String maintStat)
更新ステータスを設定します。

パラメータ:
maintStat - 更新ステータス

setDelFlag

public void setDelFlag(String delFlag)
保管場所レベルでの品目削除フラグを設定します。

パラメータ:
delFlag - 保管場所レベルでの品目削除フラグ

setFiscYear

public void setFiscYear(String fiscYear)
当会計年度を設定します。

パラメータ:
fiscYear - 当会計年度

setCurrPeriod

public void setCurrPeriod(String currPeriod)
当期 (転記期間)を設定します。

パラメータ:
currPeriod - 当期 (転記期間)

setMrpInd

public void setMrpInd(String mrpInd)
保管場所 MRP 区分を設定します。

パラメータ:
mrpInd - 保管場所 MRP 区分

setSpecProc

public void setSpecProc(String specProc)
保管場所レベルでの特殊調達タイプを設定します。

パラメータ:
specProc - 保管場所レベルでの特殊調達タイプ

setReorderPt

public void setReorderPt(String reorderPt)
保管場所 MRP に対する発注点を設定します。

パラメータ:
reorderPt - 保管場所 MRP に対する発注点

setReplQty

public void setReplQty(String replQty)
保管場所 MRP に対する補充数量を設定します。

パラメータ:
replQty - 保管場所 MRP に対する補充数量

setStgeBin

public void setStgeBin(String stgeBin)
棚番を設定します。

パラメータ:
stgeBin - 棚番

setPickgArea

public void setPickgArea(String pickgArea)
簡易倉庫管理のピッキングエリアを設定します。

パラメータ:
pickgArea - 簡易倉庫管理のピッキングエリア

setInvCorrFac

public void setInvCorrFac(String invCorrFac)
在庫修正係数を設定します。

パラメータ:
invCorrFac - 在庫修正係数

setMrpView

public void setMrpView(String mrpView)
資材所要量計画 (MRP) ビューを設定します。

パラメータ:
mrpView - 資材所要量計画 (MRP) ビュー

setStorageView

public void setStorageView(String storageView)
保管ビューを設定します。

パラメータ:
storageView - 保管ビュー

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StorageLocationDataList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス StorageLocationDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList
すべての実装インタフェース:
Serializable
public class StorageLocationDataList
extends StorageLocationData
implements Serializable

品目データ (保管場所レベル)情報クラス
機能は以下の通り

  • 品目データ (保管場所レベル)情報をテーブル型で保持します。

関連項目:
直列化された形式

コンストラクタの概要
StorageLocationDataList()
品目データ (保管場所レベル)情報を作成します。
StorageLocationDataList(int index)
品目データ (保管場所レベル)情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData から継承したメソッド
getCurrPeriod, getDelFlag, getFiscYear, getFunction, getInvCorrFac, getMaintStat, getMaterial, getMrpInd, getMrpView, getPickgArea, getPlant, getReorderPt, getReplQty, getSpecProc, getStgeBin, getStgeLoc, getStorageView, setCurrPeriod, setDelFlag, setFiscYear, setFunction, setInvCorrFac, setMaintStat, setMaterial, setMrpInd, setMrpView, setPickgArea, setPlant, setReorderPt, setReplQty, setSpecProc, setStgeBin, setStgeLoc, setStorageView, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StorageLocationDataList

public StorageLocationDataList()
品目データ (保管場所レベル)情報を作成します。

StorageLocationDataList

public StorageLocationDataList(int index)
品目データ (保管場所レベル)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StorageTypeData (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス StorageTypeData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
StorageTypeDataList
public class StorageTypeData
extends Object
implements Serializable

保管域タイプデータ情報クラス
機能は以下の通り

  • 保管域タイプデータ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
StorageTypeData()
保管域タイプデータ情報を作成します。
メソッドの概要
String | getCtrlQty() 管理数量を取得します。
String | getDelFlag() 保管タイプに該当する全品目データ削除フラグを取得します。
String | getFunction() BAPI 機能を取得します。
String | getMaterial() 品目コードを取得します。
String | getMaxSbQty() 最大棚番在庫数量を取得します。
String | getMinSbQty() 最小棚番在庫数量を取得します。
String | getPickArea() ピッキングエリアを取得します。
String | getReplenQty() 補充数量を取得します。
String | getRoundQty() 丸め数量を取得します。
String | getStgeBin() 棚番を取得します。
String | getStgeType() 保管域タイプを取得します。
String | getWhseNo() 倉庫番号/複合倉庫を取得します。
void | setCtrlQty(String ctrlQty) 管理数量を設定します。
void | setDelFlag(String delFlag) 保管タイプに該当する全品目データ削除フラグを設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaxSbQty(String maxSbQty) 最大棚番在庫数量を設定します。
void | setMinSbQty(String minSbQty) 最小棚番在庫数量を設定します。
void | setPickArea(String pickArea) ピッキングエリアを設定します。
void | setReplenQty(String replenQty) 補充数量を設定します。
void | setRoundQty(String roundQty) 丸め数量を設定します。
void | setStgeBin(String stgeBin) 棚番を設定します。
void | setStgeType(String stgeType) 保管域タイプを設定します。
void | setWhseNo(String whseNo) 倉庫番号/複合倉庫を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StorageTypeData

public StorageTypeData()
保管域タイプデータ情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getWhseNo

public String getWhseNo()
倉庫番号/複合倉庫を取得します。

戻り値:
whseNo 倉庫番号/複合倉庫

getStgeType

public String getStgeType()
保管域タイプを取得します。

戻り値:
stgeType 保管域タイプ

getDelFlag

public String getDelFlag()
保管タイプに該当する全品目データ削除フラグを取得します。

戻り値:
delFlag 保管タイプに該当する全品目データ削除フラグ

getStgeBin

public String getStgeBin()
棚番を取得します。

戻り値:
stgeBin 棚番

getMaxSbQty

public String getMaxSbQty()
最大棚番在庫数量を取得します。

戻り値:
maxSbQty 最大棚番在庫数量

getMinSbQty

public String getMinSbQty()
最小棚番在庫数量を取得します。

戻り値:
minSbQty 最小棚番在庫数量

getCtrlQty

public String getCtrlQty()
管理数量を取得します。

戻り値:
ctrlQty 管理数量

getReplenQty

public String getReplenQty()
補充数量を取得します。

戻り値:
replenQty 補充数量

getPickArea

public String getPickArea()
ピッキングエリアを取得します。

戻り値:
pickArea ピッキングエリア

getRoundQty

public String getRoundQty()
丸め数量を取得します。

戻り値:
roundQty 丸め数量

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setWhseNo

public void setWhseNo(String whseNo)
倉庫番号/複合倉庫を設定します。

パラメータ:
whseNo - 倉庫番号/複合倉庫

setStgeType

public void setStgeType(String stgeType)
保管域タイプを設定します。

パラメータ:
stgeType - 保管域タイプ

setDelFlag

public void setDelFlag(String delFlag)
保管タイプに該当する全品目データ削除フラグを設定します。

パラメータ:
delFlag - 保管タイプに該当する全品目データ削除フラグ

setStgeBin

public void setStgeBin(String stgeBin)
棚番を設定します。

パラメータ:
stgeBin - 棚番

setMaxSbQty

public void setMaxSbQty(String maxSbQty)
最大棚番在庫数量を設定します。

パラメータ:
maxSbQty - 最大棚番在庫数量

setMinSbQty

public void setMinSbQty(String minSbQty)
最小棚番在庫数量を設定します。

パラメータ:
minSbQty - 最小棚番在庫数量

setCtrlQty

public void setCtrlQty(String ctrlQty)
管理数量を設定します。

パラメータ:
ctrlQty - 管理数量

setReplenQty

public void setReplenQty(String replenQty)
補充数量を設定します。

パラメータ:
replenQty - 補充数量

setPickArea

public void setPickArea(String pickArea)
ピッキングエリアを設定します。

パラメータ:
pickArea - ピッキングエリア

setRoundQty

public void setRoundQty(String roundQty)
丸め数量を設定します。

パラメータ:
roundQty - 丸め数量

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StorageTypeDataList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス StorageTypeDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList
すべての実装インタフェース:
Serializable
public class StorageTypeDataList
extends StorageTypeData
implements Serializable

保管域タイプデータ情報クラス
機能は以下の通り

  • 保管域タイプデータ情報をテーブル型で保持します。

関連項目:
直列化された形式

コンストラクタの概要
StorageTypeDataList()
保管域タイプデータ情報を作成します。
StorageTypeDataList(int index)
保管域タイプデータ情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData から継承したメソッド
getCtrlQty, getDelFlag, getFunction, getMaterial, getMaxSbQty, getMinSbQty, getPickArea, getReplenQty, getRoundQty, getStgeBin, getStgeType, getWhseNo, setCtrlQty, setDelFlag, setFunction, setMaterial, setMaxSbQty, setMinSbQty, setPickArea, setReplenQty, setRoundQty, setStgeBin, setStgeType, setWhseNo, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StorageTypeDataList

public StorageTypeDataList()
保管域タイプデータ情報を作成します。

StorageTypeDataList

public StorageTypeDataList(int index)
保管域タイプデータ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TaxClassifications (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス TaxClassifications

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications
すべての実装インタフェース:
Serializable
public class TaxClassifications
extends Object
implements Serializable

制御デ－タ情報クラス
機能は以下の通り

  • 制御デ－タ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
TaxClassifications()
制御デ－タ情報を作成します。
TaxClassifications(int index)
制御デ－タ情報を作成します。
メソッドの概要
String | getDepcountry() 出荷国 (商品発送国)を取得します。
String | getDepcountryIso() 出荷国の ISO コードを取得します。
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getMaterial() 品目コードを取得します。
String | getTaxclass1() 品目の税分類を取得します。
String | getTaxclass2() 品目の税分類を取得します。
String | getTaxclass3() 品目の税分類を取得します。
String | getTaxclass4() 品目の税分類を取得します。
String | getTaxclass5() 品目の税分類を取得します。
String | getTaxclass6() 品目の税分類を取得します。
String | getTaxclass7() 品目の税分類を取得します。
String | getTaxclass8() 品目の税分類を取得します。
String | getTaxclass9() 品目の税分類を取得します。
String | getTaxInd() 税区分: 品目 (購買管理)を取得します。
String | getTaxType1() 税カテゴリ (消費税等)を取得します。
String | getTaxType2() 税カテゴリ (消費税等)を取得します。
String | getTaxType3() 税カテゴリ (消費税等)を取得します。
String | getTaxType4() 税カテゴリ (消費税等)を取得します。
String | getTaxType5() 税カテゴリ (消費税等)を取得します。
String | getTaxType6() 税カテゴリ (消費税等)を取得します。
String | getTaxType7() 税カテゴリ (消費税等)を取得します。
String | getTaxType8() 税カテゴリ (消費税等)を取得します。
String | getTaxType9() 税カテゴリ (消費税等)を取得します。
void | setDepcountry(String depcountry) 出荷国 (商品発送国)を設定します。
void | setDepcountryIso(String depcountryIso) 出荷国の ISO コードを設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMaterial(String material) 品目コードを設定します。
void | setTaxclass1(String taxclass1) 品目の税分類を設定します。
void | setTaxclass2(String taxclass2) 品目の税分類を設定します。
void | setTaxclass3(String taxclass3) 品目の税分類を設定します。
void | setTaxclass4(String taxclass4) 品目の税分類を設定します。
void | setTaxclass5(String taxclass5) 品目の税分類を設定します。
void | setTaxclass6(String taxclass6) 品目の税分類を設定します。
void | setTaxclass7(String taxclass7) 品目の税分類を設定します。
void | setTaxclass8(String taxclass8) 品目の税分類を設定します。
void | setTaxclass9(String taxclass9) 品目の税分類を設定します。
void | setTaxInd(String taxInd) 税区分: 品目 (購買管理)を設定します。
void | setTaxType1(String taxType1) 税カテゴリ (消費税等)を設定します。
void | setTaxType2(String taxType2) 税カテゴリ (消費税等)を設定します。
void | setTaxType3(String taxType3) 税カテゴリ (消費税等)を設定します。
void | setTaxType4(String taxType4) 税カテゴリ (消費税等)を設定します。
void | setTaxType5(String taxType5) 税カテゴリ (消費税等)を設定します。
void | setTaxType6(String taxType6) 税カテゴリ (消費税等)を設定します。
void | setTaxType7(String taxType7) 税カテゴリ (消費税等)を設定します。
void | setTaxType8(String taxType8) 税カテゴリ (消費税等)を設定します。
void | setTaxType9(String taxType9) 税カテゴリ (消費税等)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

TaxClassifications

public TaxClassifications()
制御デ－タ情報を作成します。

TaxClassifications

public TaxClassifications(int index)
制御デ－タ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getDepcountry

public String getDepcountry()
出荷国 (商品発送国)を取得します。

戻り値:
depcountry 出荷国 (商品発送国)

getDepcountryIso

public String getDepcountryIso()
出荷国の ISO コードを取得します。

戻り値:
depcountryIso 出荷国の ISO コード

getTaxType1

public String getTaxType1()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType1 税カテゴリ (消費税等)

getTaxclass1

public String getTaxclass1()
品目の税分類を取得します。

戻り値:
taxclass1 品目の税分類

getTaxType2

public String getTaxType2()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType2 税カテゴリ (消費税等)

getTaxclass2

public String getTaxclass2()
品目の税分類を取得します。

戻り値:
taxclass2 品目の税分類

getTaxType3

public String getTaxType3()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType3 税カテゴリ (消費税等)

getTaxclass3

public String getTaxclass3()
品目の税分類を取得します。

戻り値:
taxclass3 品目の税分類

getTaxType4

public String getTaxType4()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType4 税カテゴリ (消費税等)

getTaxclass4

public String getTaxclass4()
品目の税分類を取得します。

戻り値:
taxclass4 品目の税分類

getTaxType5

public String getTaxType5()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType5 税カテゴリ (消費税等)

getTaxclass5

public String getTaxclass5()
品目の税分類を取得します。

戻り値:
taxclass5 品目の税分類

getTaxType6

public String getTaxType6()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType6 税カテゴリ (消費税等)

getTaxclass6

public String getTaxclass6()
品目の税分類を取得します。

戻り値:
taxclass6 品目の税分類

getTaxType7

public String getTaxType7()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType7 税カテゴリ (消費税等)

getTaxclass7

public String getTaxclass7()
品目の税分類を取得します。

戻り値:
taxclass7 品目の税分類

getTaxType8

public String getTaxType8()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType8 税カテゴリ (消費税等)

getTaxclass8

public String getTaxclass8()
品目の税分類を取得します。

戻り値:
taxclass8 品目の税分類

getTaxType9

public String getTaxType9()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType9 税カテゴリ (消費税等)

getTaxclass9

public String getTaxclass9()
品目の税分類を取得します。

戻り値:
taxclass9 品目の税分類

getTaxInd

public String getTaxInd()
税区分: 品目 (購買管理)を取得します。

戻り値:
taxInd 税区分: 品目 (購買管理)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setDepcountry

public void setDepcountry(String depcountry)
出荷国 (商品発送国)を設定します。

パラメータ:
depcountry - 出荷国 (商品発送国)

setDepcountryIso

public void setDepcountryIso(String depcountryIso)
出荷国の ISO コードを設定します。

パラメータ:
depcountryIso - 出荷国の ISO コード

setTaxType1

public void setTaxType1(String taxType1)
税カテゴリ (消費税等)を設定します。

setTaxclass1

public void setTaxclass1(String taxclass1)
品目の税分類を設定します。

setTaxType2

public void setTaxType2(String taxType2)
税カテゴリ (消費税等)を設定します。

パラメータ:
taxType2 - 税カテゴリ (消費税等)

setTaxclass2

public void setTaxclass2(String taxclass2)
品目の税分類を設定します。

パラメータ:
taxclass2 - 品目の税分類

setTaxType3

public void setTaxType3(String taxType3)
税カテゴリ (消費税等)を設定します。

パラメータ:
taxType3 - 税カテゴリ (消費税等)

setTaxclass3

public void setTaxclass3(String taxclass3)
品目の税分類を設定します。

パラメータ:
taxclass3 - 品目の税分類

setTaxType4

public void setTaxType4(String taxType4)
税カテゴリ (消費税等)を設定します。

パラメータ:
taxType4 - 税カテゴリ (消費税等)

setTaxclass4

public void setTaxclass4(String taxclass4)
品目の税分類を設定します。

パラメータ:
taxclass4 - 品目の税分類

setTaxType5

public void setTaxType5(String taxType5)
税カテゴリ (消費税等)を設定します。

パラメータ:
taxType5 - 税カテゴリ (消費税等)

setTaxclass5

public void setTaxclass5(String taxclass5)
品目の税分類を設定します。

パラメータ:
taxclass5 - 品目の税分類

setTaxType6

public void setTaxType6(String taxType6)
税カテゴリ (消費税等)を設定します。

パラメータ:
taxType6 - 税カテゴリ (消費税等)

setTaxclass6

public void setTaxclass6(String taxclass6)
品目の税分類を設定します。

パラメータ:
taxclass6 - 品目の税分類

setTaxType7

public void setTaxType7(String taxType7)
税カテゴリ (消費税等)を設定します。

パラメータ:
taxType7 - 税カテゴリ (消費税等)

setTaxclass7

public void setTaxclass7(String taxclass7)
品目の税分類を設定します。

パラメータ:
taxclass7 - 品目の税分類

setTaxType8

public void setTaxType8(String taxType8)
税カテゴリ (消費税等)を設定します。

パラメータ:
taxType8 - 税カテゴリ (消費税等)

setTaxclass8

public void setTaxclass8(String taxclass8)
品目の税分類を設定します。

パラメータ:
taxclass8 - 品目の税分類

setTaxType9

public void setTaxType9(String taxType9)
税カテゴリ (消費税等)を設定します。

パラメータ:
taxType9 - 税カテゴリ (消費税等)

setTaxclass9

public void setTaxclass9(String taxclass9)
品目の税分類を設定します。

パラメータ:
taxclass9 - 品目の税分類

setTaxInd

public void setTaxInd(String taxInd)
税区分: 品目 (購買管理)を設定します。

パラメータ:
taxInd - 税区分: 品目 (購買管理)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UnitSofmeasure (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス UnitSofmeasure

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure
すべての実装インタフェース:
Serializable
public class UnitSofmeasure
extends Object
implements Serializable

数量単位情報クラス
機能は以下の通り

  • 数量単位情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
UnitSofmeasure()
数量単位情報を作成します。
UnitSofmeasure(int index)
数量単位情報を作成します。
メソッドの概要
String | getAltUnit() 在庫保管単位の代替数量単位を取得します。
String | getAltUnitIso() ISO コードによる在庫単位の代替数量単位を取得します。
String | getCharUnit() 特性の数量単位を取得します。
String | getCharUnitIso() 下位レベル数量単位 (ISO コード)を取得します。
String | getDelFlag() データレコード削除 (テーブル繰返し)を取得します。
String | getDenominatr() 分母: 基本数量単位へ変換する場合を取得します。
String | getEanCat() 国際商品コード (EAN) のカテゴリを取得します。
String | getEanUpc() 国際商品コード (EAN/UPC)を取得します。
String | getFunction() BAPI 機能を取得します。
String | getGrossWt() 総重量を取得します。
String | getGtinVariant() グローバルトレード明細番号バリアントを取得します。
String | getHeight() 高さを取得します。
int | getIndex() レコード番号を取得します｡
String | getInternalChar() 内部特性を取得します。
String | getLeadinguom() 主要ロット特定数量単位を取得します。
String | getLength() 長さを取得します。
String | getMaterial() 品目コードを取得します。
String | getMeAnzSub() 下位レベル数量単位数を取得します。
String | getNetWeight() 正味重量を取得します。
String | getNumerator() 基本数量単位への換算分子を取得します。
String | getSubUom() 梱包階層の下位レベル数量単位を取得します。
String | getSubUomIso() 下位レベル数量単位 (ISO コード)を取得します。
String | getUnitDim() 寸法単位 (長さ/幅/高さ)を取得します。
String | getUnitDimIso() ISO コードでの長さ、幅、高さの単位を取得します。
String | getUnitOfWt() 重量単位を取得します。
String | getUnitOfWtIso() ISO コードでの重量単位を取得します。
String | getUomsortnumber() 数量単位ソート番号を取得します。
String | getValueduom() ロット特定数量単位での評価を取得します。
String | getVolume() 容積を取得します。
String | getVolumeunit() 容積単位を取得します。
String | getVolumeunitIso() ISO コードでの容積単位を取得します。
String | getWidth() 幅を取得します。
void | setAltUnit(String altUnit) 在庫保管単位の代替数量単位を設定します。
void | setAltUnitIso(String altUnitIso) ISO コードによる在庫単位の代替数量単位を設定します。
void | setCharUnit(String charUnit) 特性の数量単位を設定します。
void | setCharUnitIso(String charUnitIso) 下位レベル数量単位 (ISO コード)を設定します。
void | setDelFlag(String delFlag) データレコード削除 (テーブル繰返し)を設定します。
void | setDenominatr(String denominatr) 分母: 基本数量単位へ変換する場合を設定します。
void | setEanCat(String eanCat) 国際商品コード (EAN) のカテゴリを設定します。
void | setEanUpc(String eanUpc) 国際商品コード (EAN/UPC)を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setGrossWt(String grossWt) 総重量を設定します。
void | setGtinVariant(String gtinVariant) グローバルトレード明細番号バリアントを設定します。
void | setHeight(String height) 高さを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setInternalChar(String internalChar) 内部特性を設定します。
void | setLeadinguom(String leadinguom) 主要ロット特定数量単位を設定します。
void | setLength(String length) 長さを設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMeAnzSub(String meAnzSub) 下位レベル数量単位数を設定します。
void | setNetWeight(String netWeight) 正味重量を設定します。
void | setNumerator(String numerator) 基本数量単位への換算分子を設定します。
void | setSubUom(String subUom) 梱包階層の下位レベル数量単位を設定します。
void | setSubUomIso(String subUomIso) 下位レベル数量単位 (ISO コード)を設定します。
void | setUnitDim(String unitDim) 寸法単位 (長さ/幅/高さ)を設定します。
void | setUnitDimIso(String unitDimIso) ISO コードでの長さ、幅、高さの単位を設定します。
void | setUnitOfWt(String unitOfWt) 重量単位を設定します。
void | setUnitOfWtIso(String unitOfWtIso) ISO コードでの重量単位を設定します。
void | setUomsortnumber(String uomsortnumber) 数量単位ソート番号を設定します。
void | setValueduom(String valueduom) ロット特定数量単位での評価を設定します。
void | setVolume(String volume) 容積を設定します。
void | setVolumeunit(String volumeunit) 容積単位を設定します。
void | setVolumeunitIso(String volumeunitIso) ISO コードでの容積単位を設定します。
void | setWidth(String width) 幅を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UnitSofmeasure

public UnitSofmeasure()
数量単位情報を作成します。

UnitSofmeasure

public UnitSofmeasure(int index)
数量単位情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getAltUnit

public String getAltUnit()
在庫保管単位の代替数量単位を取得します。

戻り値:
altUnit 在庫保管単位の代替数量単位

getAltUnitIso

public String getAltUnitIso()
ISO コードによる在庫単位の代替数量単位を取得します。

戻り値:
altUnitIso ISO コードによる在庫単位の代替数量単位

getNumerator

public String getNumerator()
基本数量単位への換算分子を取得します。

戻り値:
numerator 基本数量単位への換算分子

getDenominatr

public String getDenominatr()
分母: 基本数量単位へ変換する場合を取得します。

戻り値:
denominatr 分母: 基本数量単位へ変換する場合

getEanUpc

public String getEanUpc()
国際商品コード (EAN/UPC)を取得します。

戻り値:
eanUpc 国際商品コード (EAN/UPC)

getEanCat

public String getEanCat()
国際商品コード (EAN) のカテゴリを取得します。

戻り値:
eanCat 国際商品コード (EAN) のカテゴリ

getLength

public String getLength()
長さを取得します。

戻り値:
length 長さ

getWidth

public String getWidth()
幅を取得します。

戻り値:
width 幅

getHeight

public String getHeight()
高さを取得します。

戻り値:
height 高さ

getUnitDim

public String getUnitDim()
寸法単位 (長さ/幅/高さ)を取得します。

戻り値:
unitDim 寸法単位 (長さ/幅/高さ)

getUnitDimIso

public String getUnitDimIso()
ISO コードでの長さ、幅、高さの単位を取得します。

戻り値:
unitDimIso ISO コードでの長さ、幅、高さの単位

getVolume

public String getVolume()
容積を取得します。

戻り値:
volume 容積

getVolumeunit

public String getVolumeunit()
容積単位を取得します。

戻り値:
volumeunit 容積単位

getVolumeunitIso

public String getVolumeunitIso()
ISO コードでの容積単位を取得します。

戻り値:
volumeunitIso ISO コードでの容積単位

getGrossWt

public String getGrossWt()
総重量を取得します。

戻り値:
grossWt 総重量

getUnitOfWt

public String getUnitOfWt()
重量単位を取得します。

戻り値:
unitOfWt 重量単位

getUnitOfWtIso

public String getUnitOfWtIso()
ISO コードでの重量単位を取得します。

戻り値:
unitOfWtIso ISO コードでの重量単位

getDelFlag

public String getDelFlag()
データレコード削除 (テーブル繰返し)を取得します。

戻り値:
delFlag データレコード削除 (テーブル繰返し)

getSubUom

public String getSubUom()
梱包階層の下位レベル数量単位を取得します。

戻り値:
subUom 梱包階層の下位レベル数量単位

getSubUomIso

public String getSubUomIso()
下位レベル数量単位 (ISO コード)を取得します。

戻り値:
subUomIso 下位レベル数量単位 (ISO コード)

getInternalChar

public String getInternalChar()
内部特性を取得します。

戻り値:
internalChar 内部特性

getUomsortnumber

public String getUomsortnumber()
数量単位ソート番号を取得します。

戻り値:
uomsortnumber 数量単位ソート番号

getLeadinguom

public String getLeadinguom()
主要ロット特定数量単位を取得します。

戻り値:
leadinguom 主要ロット特定数量単位

getValueduom

public String getValueduom()
ロット特定数量単位での評価を取得します。

戻り値:
valueduom ロット特定数量単位での評価

getCharUnit

public String getCharUnit()
特性の数量単位を取得します。

戻り値:
charUnit 特性の数量単位

getCharUnitIso

public String getCharUnitIso()
下位レベル数量単位 (ISO コード)を取得します。

戻り値:
charUnitIso 下位レベル数量単位 (ISO コード)

getGtinVariant

public String getGtinVariant()
グローバルトレード明細番号バリアントを取得します。

戻り値:
gtinVariant グローバルトレード明細番号バリアント

getNetWeight

public String getNetWeight()
正味重量を取得します。

戻り値:
netWeight 正味重量

getMeAnzSub

public String getMeAnzSub()
下位レベル数量単位数を取得します。

戻り値:
meAnzSub 下位レベル数量単位数

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setAltUnit

public void setAltUnit(String altUnit)
在庫保管単位の代替数量単位を設定します。

パラメータ:
altUnit - 在庫保管単位の代替数量単位

setAltUnitIso

public void setAltUnitIso(String altUnitIso)
ISO コードによる在庫単位の代替数量単位を設定します。

パラメータ:
altUnitIso - ISO コードによる在庫単位の代替数量単位

setNumerator

public void setNumerator(String numerator)
基本数量単位への換算分子を設定します。

パラメータ:
numerator - 基本数量単位への換算分子

setDenominatr

public void setDenominatr(String denominatr)
分母: 基本数量単位へ変換する場合を設定します。

パラメータ:
denominatr - 分母: 基本数量単位へ変換する場合

setEanUpc

public void setEanUpc(String eanUpc)
国際商品コード (EAN/UPC)を設定します。

パラメータ:
eanUpc - 国際商品コード (EAN/UPC)

setEanCat

public void setEanCat(String eanCat)
国際商品コード (EAN) のカテゴリを設定します。

パラメータ:
eanCat - 国際商品コード (EAN) のカテゴリ

setLength

public void setLength(String length)
長さを設定します。

パラメータ:
length - 長さ

setWidth

public void setWidth(String width)
幅を設定します。

パラメータ:
width - 幅

setHeight

public void setHeight(String height)
高さを設定します。

パラメータ:
height - 高さ

setUnitDim

public void setUnitDim(String unitDim)
寸法単位 (長さ/幅/高さ)を設定します。

パラメータ:
unitDim - 寸法単位 (長さ/幅/高さ)

setUnitDimIso

public void setUnitDimIso(String unitDimIso)
ISO コードでの長さ、幅、高さの単位を設定します。

パラメータ:
unitDimIso - ISO コードでの長さ、幅、高さの単位

setVolume

public void setVolume(String volume)
容積を設定します。

パラメータ:
volume - 容積

setVolumeunit

public void setVolumeunit(String volumeunit)
容積単位を設定します。

パラメータ:
volumeunit - 容積単位

setVolumeunitIso

public void setVolumeunitIso(String volumeunitIso)
ISO コードでの容積単位を設定します。

パラメータ:
volumeunitIso - ISO コードでの容積単位

setGrossWt

public void setGrossWt(String grossWt)
総重量を設定します。

パラメータ:
grossWt - 総重量

setUnitOfWt

public void setUnitOfWt(String unitOfWt)
重量単位を設定します。

パラメータ:
unitOfWt - 重量単位

setUnitOfWtIso

public void setUnitOfWtIso(String unitOfWtIso)
ISO コードでの重量単位を設定します。

パラメータ:
unitOfWtIso - ISO コードでの重量単位

setDelFlag

public void setDelFlag(String delFlag)
データレコード削除 (テーブル繰返し)を設定します。

パラメータ:
delFlag - データレコード削除 (テーブル繰返し)

setSubUom

public void setSubUom(String subUom)
梱包階層の下位レベル数量単位を設定します。

パラメータ:
subUom - 梱包階層の下位レベル数量単位

setSubUomIso

public void setSubUomIso(String subUomIso)
下位レベル数量単位 (ISO コード)を設定します。

パラメータ:
subUomIso - 下位レベル数量単位 (ISO コード)

setInternalChar

public void setInternalChar(String internalChar)
内部特性を設定します。

パラメータ:
internalChar - 内部特性

setUomsortnumber

public void setUomsortnumber(String uomsortnumber)
数量単位ソート番号を設定します。

パラメータ:
uomsortnumber - 数量単位ソート番号

setLeadinguom

public void setLeadinguom(String leadinguom)
主要ロット特定数量単位を設定します。

パラメータ:
leadinguom - 主要ロット特定数量単位

setValueduom

public void setValueduom(String valueduom)
ロット特定数量単位での評価を設定します。

パラメータ:
valueduom - ロット特定数量単位での評価

setCharUnit

public void setCharUnit(String charUnit)
特性の数量単位を設定します。

パラメータ:
charUnit - 特性の数量単位

setCharUnitIso

public void setCharUnitIso(String charUnitIso)
下位レベル数量単位 (ISO コード)を設定します。

パラメータ:
charUnitIso - 下位レベル数量単位 (ISO コード)

setGtinVariant

public void setGtinVariant(String gtinVariant)
グローバルトレード明細番号バリアントを設定します。

パラメータ:
gtinVariant - グローバルトレード明細番号バリアント

setNetWeight

public void setNetWeight(String netWeight)
正味重量を設定します。

パラメータ:
netWeight - 正味重量

setMeAnzSub

public void setMeAnzSub(String meAnzSub)
下位レベル数量単位数を設定します。

パラメータ:
meAnzSub - 下位レベル数量単位数

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ValuationData (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ValuationData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ValuationDataList
public class ValuationData
extends Object
implements Serializable

評価データ情報クラス
機能は以下の通り

  • 評価データ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ValuationData()
評価データ情報を作成します。
メソッドの概要
String | getAccountView() 会計ビューを取得します。
String | getCommprice1() 商法による評価額: レベル 1を取得します。
String | getCommprice2() 商法による評価額: レベル 2を取得します。
String | getCommprice3() 商法基準評価額: レベル 3を取得します。
String | getCostView() 原価計算ビューを取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO コード通貨を取得します。
String | getCurrPeriod() 当期 (転記期間)を取得します。
String | getCurrPlanPrice() 税法基準評価額: レベル 2を取得します。
String | getDelFlag() 評価タイプに該当する全品目データ削除フラグを取得します。
String | getDevalInd() 低価法: 評価減区分を取得します。
String | getFijCurCostEst() 当期標準原価見積の会計年度を取得します。
String | getFijFutCostEst() 将来標準原価見積の会計年度を取得します。
String | getFijPreCostEst() 前期標準原価見積の会計年度を取得します。
String | getFiscYear() 当会計年度を取得します。
String | getFunction() BAPI 機能を取得します。
String | getFuturePr() 次期標準原価を取得します。
String | getInHouse() 内部生産を取得します。
String | getLifoFifo() LIFO/FIFO 関連を取得します。
String | getMaintStat() 更新ステータスを取得します。
String | getMaterial() 品目コードを取得します。
String | getMatlUsage() 品目の用途を取得します。
String | getMatOrigin() 品目の原産地を取得します。
String | getMlActive() 品目レベルで有効な品目元帳を取得します。
String | getMlSettle() 品目元帳決済: 管理を取得します。
String | getMovingPr() 移動平均原価/期間単位価格を取得します。
String | getMovPrPp() 前期移動平均原価/期間平均原価を取得します。
String | getMovPrPy() 前年度の移動平均原価/期間単価を取得します。
String | getOrigGroup() 発生源グループ (原価要素の下位区分)を取得します。
String | getOrigMat() 品目発生源を取得します。
String | getOverheadGrp() 原価計算間接費グループを取得します。
String | getPerCurCostEst() 現行標準原価見積期間を取得します。
String | getPerFutCostEst() 将来標準原価見積期間を取得します。
String | getPerPreCostEst() 前標準原価見積期間を取得します。
String | getPlndprdate1() 予定原価 1 の有効開始日を取得します。
String | getPlndprdate2() 予定原価 2 の有効開始日を取得します。
String | getPlndprdate3() 予定原価 3 の有効開始日を取得します。
String | getPlndPrice() 予定計画原価を取得します。
String | getPlndprice1() 予定計画原価 1を取得します。
String | getPlndprice2() 予定計画原価 2を取得します。
String | getPlndprice3() 予定計画原価 3を取得します。
String | getPoolnumber() LIFO 評価でのプール番号を取得します。
String | getPrCtrlPp() 前期間の原価管理区分を取得します。
String | getPrCtrlPy() 前年度の原価管理区分を取得します。
String | getPrevPlanPrice() 税法基準評価額: レベル 2を取得します。
String | getPriceCtrl() 原価管理区分を取得します。
String | getPriceUnit() 価格単位を取得します。
String | getPrUnitPp() 前期価格単位を取得します。
String | getPrUnitPy() 前年度価格単位を取得します。
String | getQtyStruct() 数量構成により原価計算を行う品目を取得します。
String | getStdPrice() 標準原価を取得します。
String | getStdPrPp() 前期標準標準原価を取得します。
String | getStdPrPy() 前年度標準原価を取得します。
String | getTaxCmlUn() 税法/商法にもとづく評価額価格単位を取得します。
String | getTaxprice1() 税法による評価額: レベル 1を取得します。
String | getTaxprice2() 税法による評価額: レベル 2を取得します。
String | getTaxprice3() 税法基準評価額: レベル 3を取得します。
String | getValArea() 評価レベルを取得します。
String | getValCat() 評価カテゴリを取得します。
String | getValClass() 評価クラスを取得します。
String | getValidFrom() 原価有効開始日を取得します。
String | getValType() 評価タイプを取得します。
String | getVclassPp() 前期評価クラスを取得します。
String | getVclassPy() 前年度の評価クラスを取得します。
String | getVmPStock() プロジェクト在庫の評価クラスを取得します。
String | getVmSoStk() 受注在庫の評価クラスを取得します。
void | setAccountView(String accountView) 会計ビューを設定します。
void | setCommprice1(String commprice1) 商法による評価額: レベル 1を設定します。
void | setCommprice2(String commprice2) 商法による評価額: レベル 2を設定します。
void | setCommprice3(String commprice3) 商法基準評価額: レベル 3を設定します。
void | setCostView(String costView) 原価計算ビューを設定します。
void | setCurrency(String currency) 通貨コードを設定します。
void | setCurrencyIso(String currencyIso) ISO コード通貨を設定します。
void | setCurrPeriod(String currPeriod) 当期 (転記期間)を設定します。
void | setCurrPlanPrice(String currPlanPrice) 税法基準評価額: レベル 2を設定します。
void | setDelFlag(String delFlag) 評価タイプに該当する全品目データ削除フラグを設定します。
void | setDevalInd(String devalInd) 低価法: 評価減区分を設定します。
void | setFijCurCostEst(String fijCurCostEst) 当期標準原価見積の会計年度を設定します。
void | setFijFutCostEst(String fijFutCostEst) 将来標準原価見積の会計年度を設定します。
void | setFijPreCostEst(String fijPreCostEst) 前期標準原価見積の会計年度を設定します。
void | setFiscYear(String fiscYear) 当会計年度を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setFuturePr(String futurePr) 次期標準原価を設定します。
void | setInHouse(String inHouse) 内部生産を設定します。
void | setLifoFifo(String lifoFifo) LIFO/FIFO 関連を設定します。
void | setMaintStat(String maintStat) 更新ステータスを設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMatlUsage(String matlUsage) 品目の用途を設定します。
void | setMatOrigin(String matOrigin) 品目の原産地を設定します。
void | setMlActive(String mlActive) 品目レベルで有効な品目元帳を設定します。
void | setMlSettle(String mlSettle) 品目元帳決済: 管理を設定します。
void | setMovingPr(String movingPr) 移動平均原価/期間単位価格を設定します。
void | setMovPrPp(String movPrPp) 前期移動平均原価/期間平均原価を設定します。
void | setMovPrPy(String movPrPy) 前年度の移動平均原価/期間単価を設定します。
void | setOrigGroup(String origGroup) 発生源グループ (原価要素の下位区分)を設定します。
void | setOrigMat(String origMat) 品目発生源を設定します。
void | setOverheadGrp(String overheadGrp) 原価計算間接費グループを設定します。
void | setPerCurCostEst(String perCurCostEst) 現行標準原価見積期間を設定します。
void | setPerFutCostEst(String perFutCostEst) 将来標準原価見積期間を設定します。
void | setPerPreCostEst(String perPreCostEst) 前標準原価見積期間を設定します。
void | setPlndprdate1(String plndprdate1) 予定原価 1 の有効開始日を設定します。
void | setPlndprdate2(String plndprdate2) 予定原価 2 の有効開始日を設定します。
void | setPlndprdate3(String plndprdate3) 予定原価 3 の有効開始日を設定します。
void | setPlndPrice(String plndPrice) 予定計画原価を設定します。
void | setPlndprice1(String plndprice1) 予定計画原価 1を設定します。
void | setPlndprice2(String plndprice2) 予定計画原価 2を設定します。
void | setPlndprice3(String plndprice3) 予定計画原価 3を設定します。
void | setPoolnumber(String poolnumber) LIFO 評価でのプール番号を設定します。
void | setPrCtrlPp(String prCtrlPp) 前期間の原価管理区分を設定します。
void | setPrCtrlPy(String prCtrlPy) 前年度の原価管理区分を設定します。
void | setPrevPlanPrice(String prevPlanPrice) 税法基準評価額: レベル 2を設定します。
void | setPriceCtrl(String priceCtrl) 原価管理区分を設定します。
void | setPriceUnit(String priceUnit) 価格単位を設定します。
void | setPrUnitPp(String prUnitPp) 前期価格単位を設定します。
void | setPrUnitPy(String prUnitPy) 前年度価格単位を設定します。
void | setQtyStruct(String qtyStruct) 数量構成により原価計算を行う品目を設定します。
void | setStdPrice(String stdPrice) 標準原価を設定します。
void | setStdPrPp(String stdPrPp) 前期標準標準原価を設定します。
void | setStdPrPy(String stdPrPy) 前年度標準原価を設定します。
void | setTaxCmlUn(String taxCmlUn) 税法/商法にもとづく評価額価格単位を設定します。
void | setTaxprice1(String taxprice1) 税法による評価額: レベル 1を設定します。
void | setTaxprice2(String taxprice2) 税法による評価額: レベル 2を設定します。
void | setTaxprice3(String taxprice3) 税法基準評価額: レベル 3を設定します。
void | setValArea(String valArea) 評価レベルを設定します。
void | setValCat(String valCat) 評価カテゴリを設定します。
void | setValClass(String valClass) 評価クラスを設定します。
void | setValidFrom(String validFrom) 原価有効開始日を設定します。
void | setValType(String valType) 評価タイプを設定します。
void | setVclassPp(String vclassPp) 前期評価クラスを設定します。
void | setVclassPy(String vclassPy) 前年度の評価クラスを設定します。
void | setVmPStock(String vmPStock) プロジェクト在庫の評価クラスを設定します。
void | setVmSoStk(String vmSoStk) 受注在庫の評価クラスを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ValuationData

public ValuationData()
評価データ情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getValArea

public String getValArea()
評価レベルを取得します。

戻り値:
valArea 評価レベル

getValType

public String getValType()
評価タイプを取得します。

戻り値:
valType 評価タイプ

getMaintStat

public String getMaintStat()
更新ステータスを取得します。

戻り値:
maintStat 更新ステータス

getDelFlag

public String getDelFlag()
評価タイプに該当する全品目データ削除フラグを取得します。

戻り値:
delFlag 評価タイプに該当する全品目データ削除フラグ

getPriceCtrl

public String getPriceCtrl()
原価管理区分を取得します。

戻り値:
priceCtrl 原価管理区分

getMovingPr

public String getMovingPr()
移動平均原価/期間単位価格を取得します。

戻り値:
movingPr 移動平均原価/期間単位価格

getStdPrice

public String getStdPrice()
標準原価を取得します。

戻り値:
stdPrice 標準原価

getPriceUnit

public String getPriceUnit()
価格単位を取得します。

戻り値:
priceUnit 価格単位

getValClass

public String getValClass()
評価クラスを取得します。

戻り値:
valClass 評価クラス

getPrCtrlPp

public String getPrCtrlPp()
前期間の原価管理区分を取得します。

戻り値:
prCtrlPp 前期間の原価管理区分

getMovPrPp

public String getMovPrPp()
前期移動平均原価/期間平均原価を取得します。

戻り値:
movPrPp 前期移動平均原価/期間平均原価

getStdPrPp

public String getStdPrPp()
前期標準標準原価を取得します。

戻り値:
stdPrPp 前期標準標準原価

getPrUnitPp

public String getPrUnitPp()
前期価格単位を取得します。

戻り値:
prUnitPp 前期価格単位

getVclassPp

public String getVclassPp()
前期評価クラスを取得します。

戻り値:
vclassPp 前期評価クラス

getPrCtrlPy

public String getPrCtrlPy()
前年度の原価管理区分を取得します。

戻り値:
prCtrlPy 前年度の原価管理区分

getMovPrPy

public String getMovPrPy()
前年度の移動平均原価/期間単価を取得します。

戻り値:
movPrPy 前年度の移動平均原価/期間単価

getStdPrPy

public String getStdPrPy()
前年度標準原価を取得します。

戻り値:
stdPrPy 前年度標準原価

getVclassPy

public String getVclassPy()
前年度の評価クラスを取得します。

戻り値:
vclassPy 前年度の評価クラス

getPrUnitPy

public String getPrUnitPy()
前年度価格単位を取得します。

戻り値:
prUnitPy 前年度価格単位

getFiscYear

public String getFiscYear()
当会計年度を取得します。

戻り値:
fiscYear 当会計年度

getCurrPeriod

public String getCurrPeriod()
当期 (転記期間)を取得します。

戻り値:
currPeriod 当期 (転記期間)

getValCat

public String getValCat()
評価カテゴリを取得します。

戻り値:
valCat 評価カテゴリ

getFuturePr

public String getFuturePr()
次期標準原価を取得します。

戻り値:
futurePr 次期標準原価

getValidFrom

public String getValidFrom()
原価有効開始日を取得します。

戻り値:
validFrom 原価有効開始日

getTaxprice1

public String getTaxprice1()
税法による評価額: レベル 1を取得します。

戻り値:
taxprice1 税法による評価額: レベル 1

getCommprice1

public String getCommprice1()
商法による評価額: レベル 1を取得します。

戻り値:
commprice1 商法による評価額: レベル 1

getTaxprice3

public String getTaxprice3()
税法基準評価額: レベル 3を取得します。

戻り値:
taxprice3 税法基準評価額: レベル 3

getCommprice3

public String getCommprice3()
商法基準評価額: レベル 3を取得します。

戻り値:
commprice3 商法基準評価額: レベル 3

getPlndPrice

public String getPlndPrice()
予定計画原価を取得します。

戻り値:
plndPrice 予定計画原価

getPlndprice1

public String getPlndprice1()
予定計画原価 1を取得します。

戻り値:
plndprice1 予定計画原価 1

getPlndprice2

public String getPlndprice2()
予定計画原価 2を取得します。

戻り値:
plndprice2 予定計画原価 2

getPlndprice3

public String getPlndprice3()
予定計画原価 3を取得します。

戻り値:
plndprice3 予定計画原価 3

getPlndprdate1

public String getPlndprdate1()
予定原価 1 の有効開始日を取得します。

戻り値:
plndprdate1 予定原価 1 の有効開始日

getPlndprdate2

public String getPlndprdate2()
予定原価 2 の有効開始日を取得します。

戻り値:
plndprdate2 予定原価 2 の有効開始日

getPlndprdate3

public String getPlndprdate3()
予定原価 3 の有効開始日を取得します。

戻り値:
plndprdate3 予定原価 3 の有効開始日

getLifoFifo

public String getLifoFifo()
LIFO/FIFO 関連を取得します。

戻り値:
lifoFifo LIFO/FIFO 関連

getPoolnumber

public String getPoolnumber()
LIFO 評価でのプール番号を取得します。

戻り値:
poolnumber LIFO 評価でのプール番号

getTaxprice2

public String getTaxprice2()
税法による評価額: レベル 2を取得します。

戻り値:
taxprice2 税法による評価額: レベル 2

getCommprice2

public String getCommprice2()
商法による評価額: レベル 2を取得します。

戻り値:
commprice2 商法による評価額: レベル 2

getDevalInd

public String getDevalInd()
低価法: 評価減区分を取得します。

戻り値:
devalInd 低価法: 評価減区分

getOrigGroup

public String getOrigGroup()
発生源グループ (原価要素の下位区分)を取得します。

戻り値:
origGroup 発生源グループ (原価要素の下位区分)

getOverheadGrp

public String getOverheadGrp()
原価計算間接費グループを取得します。

戻り値:
overheadGrp 原価計算間接費グループ

getPerFutCostEst

public String getPerFutCostEst()
将来標準原価見積期間を取得します。

戻り値:
perFutCostEst 将来標準原価見積期間

getPerCurCostEst

public String getPerCurCostEst()
現行標準原価見積期間を取得します。

戻り値:
perCurCostEst 現行標準原価見積期間

getPerPreCostEst

public String getPerPreCostEst()
前標準原価見積期間を取得します。

戻り値:
perPreCostEst 前標準原価見積期間

getFijFutCostEst

public String getFijFutCostEst()
将来標準原価見積の会計年度を取得します。

戻り値:
fijFutCostEst 将来標準原価見積の会計年度

getFijCurCostEst

public String getFijCurCostEst()
当期標準原価見積の会計年度を取得します。

戻り値:
fijCurCostEst 当期標準原価見積の会計年度

getFijPreCostEst

public String getFijPreCostEst()
前期標準原価見積の会計年度を取得します。

戻り値:
fijPreCostEst 前期標準原価見積の会計年度

getQtyStruct

public String getQtyStruct()
数量構成により原価計算を行う品目を取得します。

戻り値:
qtyStruct 数量構成により原価計算を行う品目

getPrevPlanPrice

public String getPrevPlanPrice()
税法基準評価額: レベル 2を取得します。

戻り値:
prevPlanPrice 税法基準評価額: レベル 2

getMlActive

public String getMlActive()
品目レベルで有効な品目元帳を取得します。

戻り値:
mlActive 品目レベルで有効な品目元帳

getMlSettle

public String getMlSettle()
品目元帳決済: 管理を取得します。

戻り値:
mlSettle 品目元帳決済: 管理

getCurrPlanPrice

public String getCurrPlanPrice()
税法基準評価額: レベル 2を取得します。

戻り値:
currPlanPrice 税法基準評価額: レベル 2

getOrigMat

public String getOrigMat()
品目発生源を取得します。

戻り値:
origMat 品目発生源

getVmSoStk

public String getVmSoStk()
受注在庫の評価クラスを取得します。

戻り値:
vmSoStk 受注在庫の評価クラス

getVmPStock

public String getVmPStock()
プロジェクト在庫の評価クラスを取得します。

戻り値:
vmPStock プロジェクト在庫の評価クラス

getMatlUsage

public String getMatlUsage()
品目の用途を取得します。

戻り値:
matlUsage 品目の用途

getMatOrigin

public String getMatOrigin()
品目の原産地を取得します。

戻り値:
matOrigin 品目の原産地

getInHouse

public String getInHouse()
内部生産を取得します。

戻り値:
inHouse 内部生産

getTaxCmlUn

public String getTaxCmlUn()
税法/商法にもとづく評価額価格単位を取得します。

戻り値:
taxCmlUn 税法/商法にもとづく評価額価格単位

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
currency 通貨コード

getCurrencyIso

public String getCurrencyIso()
ISO コード通貨を取得します。

戻り値:
currencyIso ISO コード通貨

getAccountView

public String getAccountView()
会計ビューを取得します。

戻り値:
accountView 会計ビュー

getCostView

public String getCostView()
原価計算ビューを取得します。

戻り値:
costView 原価計算ビュー

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setValArea

public void setValArea(String valArea)
評価レベルを設定します。

パラメータ:
valArea - 評価レベル

setValType

public void setValType(String valType)
評価タイプを設定します。

パラメータ:
valType - 評価タイプ

setMaintStat

public void setMaintStat(String maintStat)
更新ステータスを設定します。

パラメータ:
maintStat - 更新ステータス

setDelFlag

public void setDelFlag(String delFlag)
評価タイプに該当する全品目データ削除フラグを設定します。

パラメータ:
delFlag - 評価タイプに該当する全品目データ削除フラグ

setPriceCtrl

public void setPriceCtrl(String priceCtrl)
原価管理区分を設定します。

パラメータ:
priceCtrl - 原価管理区分

setMovingPr

public void setMovingPr(String movingPr)
移動平均原価/期間単位価格を設定します。

パラメータ:
movingPr - 移動平均原価/期間単位価格

setStdPrice

public void setStdPrice(String stdPrice)
標準原価を設定します。

パラメータ:
stdPrice - 標準原価

setPriceUnit

public void setPriceUnit(String priceUnit)
価格単位を設定します。

パラメータ:
priceUnit - 価格単位

setValClass

public void setValClass(String valClass)
評価クラスを設定します。

パラメータ:
valClass - 評価クラス

setPrCtrlPp

public void setPrCtrlPp(String prCtrlPp)
前期間の原価管理区分を設定します。

パラメータ:
prCtrlPp - 前期間の原価管理区分

setMovPrPp

public void setMovPrPp(String movPrPp)
前期移動平均原価/期間平均原価を設定します。

パラメータ:
movPrPp - 前期移動平均原価/期間平均原価

setStdPrPp

public void setStdPrPp(String stdPrPp)
前期標準標準原価を設定します。

パラメータ:
stdPrPp - 前期標準標準原価

setPrUnitPp

public void setPrUnitPp(String prUnitPp)
前期価格単位を設定します。

パラメータ:
prUnitPp - 前期価格単位

setVclassPp

public void setVclassPp(String vclassPp)
前期評価クラスを設定します。

パラメータ:
vclassPp - 前期評価クラス

setPrCtrlPy

public void setPrCtrlPy(String prCtrlPy)
前年度の原価管理区分を設定します。

パラメータ:
prCtrlPy - 前年度の原価管理区分

setMovPrPy

public void setMovPrPy(String movPrPy)
前年度の移動平均原価/期間単価を設定します。

パラメータ:
movPrPy - 前年度の移動平均原価/期間単価

setStdPrPy

public void setStdPrPy(String stdPrPy)
前年度標準原価を設定します。

パラメータ:
stdPrPy - 前年度標準原価

setVclassPy

public void setVclassPy(String vclassPy)
前年度の評価クラスを設定します。

パラメータ:
vclassPy - 前年度の評価クラス

setPrUnitPy

public void setPrUnitPy(String prUnitPy)
前年度価格単位を設定します。

パラメータ:
prUnitPy - 前年度価格単位

setFiscYear

public void setFiscYear(String fiscYear)
当会計年度を設定します。

パラメータ:
fiscYear - 当会計年度

setCurrPeriod

public void setCurrPeriod(String currPeriod)
当期 (転記期間)を設定します。

パラメータ:
currPeriod - 当期 (転記期間)

setValCat

public void setValCat(String valCat)
評価カテゴリを設定します。

パラメータ:
valCat - 評価カテゴリ

setFuturePr

public void setFuturePr(String futurePr)
次期標準原価を設定します。

パラメータ:
futurePr - 次期標準原価

setValidFrom

public void setValidFrom(String validFrom)
原価有効開始日を設定します。

パラメータ:
validFrom - 原価有効開始日

setTaxprice1

public void setTaxprice1(String taxprice1)
税法による評価額: レベル 1を設定します。

パラメータ:
taxprice1 - 税法による評価額: レベル 1

setCommprice1

public void setCommprice1(String commprice1)
商法による評価額: レベル 1を設定します。

パラメータ:
commprice1 - 商法による評価額: レベル 1

setTaxprice3

public void setTaxprice3(String taxprice3)
税法基準評価額: レベル 3を設定します。

パラメータ:
taxprice3 - 税法基準評価額: レベル 3

setCommprice3

public void setCommprice3(String commprice3)
商法基準評価額: レベル 3を設定します。

パラメータ:
commprice3 - 商法基準評価額: レベル 3

setPlndPrice

public void setPlndPrice(String plndPrice)
予定計画原価を設定します。

パラメータ:
plndPrice - 予定計画原価

setPlndprice1

public void setPlndprice1(String plndprice1)
予定計画原価 1を設定します。

パラメータ:
plndprice1 - 予定計画原価 1

setPlndprice2

public void setPlndprice2(String plndprice2)
予定計画原価 2を設定します。

パラメータ:
plndprice2 - 予定計画原価 2

setPlndprice3

public void setPlndprice3(String plndprice3)
予定計画原価 3を設定します。

パラメータ:
plndprice3 - 予定計画原価 3

setPlndprdate1

public void setPlndprdate1(String plndprdate1)
予定原価 1 の有効開始日を設定します。

パラメータ:
plndprdate1 - 予定原価 1 の有効開始日

setPlndprdate2

public void setPlndprdate2(String plndprdate2)
予定原価 2 の有効開始日を設定します。

パラメータ:
plndprdate2 - 予定原価 2 の有効開始日

setPlndprdate3

public void setPlndprdate3(String plndprdate3)
予定原価 3 の有効開始日を設定します。

パラメータ:
plndprdate3 - 予定原価 3 の有効開始日

setLifoFifo

public void setLifoFifo(String lifoFifo)
LIFO/FIFO 関連を設定します。

パラメータ:
lifoFifo - LIFO/FIFO 関連

setPoolnumber

public void setPoolnumber(String poolnumber)
LIFO 評価でのプール番号を設定します。

パラメータ:
poolnumber - LIFO 評価でのプール番号

setTaxprice2

public void setTaxprice2(String taxprice2)
税法による評価額: レベル 2を設定します。

パラメータ:
taxprice2 - 税法による評価額: レベル 2

setCommprice2

public void setCommprice2(String commprice2)
商法による評価額: レベル 2を設定します。

パラメータ:
commprice2 - 商法による評価額: レベル 2

setDevalInd

public void setDevalInd(String devalInd)
低価法: 評価減区分を設定します。

パラメータ:
devalInd - 低価法: 評価減区分

setOrigGroup

public void setOrigGroup(String origGroup)
発生源グループ (原価要素の下位区分)を設定します。

パラメータ:
origGroup - 発生源グループ (原価要素の下位区分)

setOverheadGrp

public void setOverheadGrp(String overheadGrp)
原価計算間接費グループを設定します。

パラメータ:
overheadGrp - 原価計算間接費グループ

setPerFutCostEst

public void setPerFutCostEst(String perFutCostEst)
将来標準原価見積期間を設定します。

パラメータ:
perFutCostEst - 将来標準原価見積期間

setPerCurCostEst

public void setPerCurCostEst(String perCurCostEst)
現行標準原価見積期間を設定します。

パラメータ:
perCurCostEst - 現行標準原価見積期間

setPerPreCostEst

public void setPerPreCostEst(String perPreCostEst)
前標準原価見積期間を設定します。

パラメータ:
perPreCostEst - 前標準原価見積期間

setFijFutCostEst

public void setFijFutCostEst(String fijFutCostEst)
将来標準原価見積の会計年度を設定します。

パラメータ:
fijFutCostEst - 将来標準原価見積の会計年度

setFijCurCostEst

public void setFijCurCostEst(String fijCurCostEst)
当期標準原価見積の会計年度を設定します。

パラメータ:
fijCurCostEst - 当期標準原価見積の会計年度

setFijPreCostEst

public void setFijPreCostEst(String fijPreCostEst)
前期標準原価見積の会計年度を設定します。

パラメータ:
fijPreCostEst - 前期標準原価見積の会計年度

setQtyStruct

public void setQtyStruct(String qtyStruct)
数量構成により原価計算を行う品目を設定します。

パラメータ:
qtyStruct - 数量構成により原価計算を行う品目

setPrevPlanPrice

public void setPrevPlanPrice(String prevPlanPrice)
税法基準評価額: レベル 2を設定します。

パラメータ:
prevPlanPrice - 税法基準評価額: レベル 2

setMlActive

public void setMlActive(String mlActive)
品目レベルで有効な品目元帳を設定します。

パラメータ:
mlActive - 品目レベルで有効な品目元帳

setMlSettle

public void setMlSettle(String mlSettle)
品目元帳決済: 管理を設定します。

パラメータ:
mlSettle - 品目元帳決済: 管理

setCurrPlanPrice

public void setCurrPlanPrice(String currPlanPrice)
税法基準評価額: レベル 2を設定します。

パラメータ:
currPlanPrice - 税法基準評価額: レベル 2

setOrigMat

public void setOrigMat(String origMat)
品目発生源を設定します。

パラメータ:
origMat - 品目発生源

setVmSoStk

public void setVmSoStk(String vmSoStk)
受注在庫の評価クラスを設定します。

パラメータ:
vmSoStk - 受注在庫の評価クラス

setVmPStock

public void setVmPStock(String vmPStock)
プロジェクト在庫の評価クラスを設定します。

パラメータ:
vmPStock - プロジェクト在庫の評価クラス

setMatlUsage

public void setMatlUsage(String matlUsage)
品目の用途を設定します。

パラメータ:
matlUsage - 品目の用途

setMatOrigin

public void setMatOrigin(String matOrigin)
品目の原産地を設定します。

パラメータ:
matOrigin - 品目の原産地

setInHouse

public void setInHouse(String inHouse)
内部生産を設定します。

パラメータ:
inHouse - 内部生産

setTaxCmlUn

public void setTaxCmlUn(String taxCmlUn)
税法/商法にもとづく評価額価格単位を設定します。

パラメータ:
taxCmlUn - 税法/商法にもとづく評価額価格単位

setCurrency

public void setCurrency(String currency)
通貨コードを設定します。

パラメータ:
currency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String currencyIso)
ISO コード通貨を設定します。

パラメータ:
currencyIso - ISO コード通貨

setAccountView

public void setAccountView(String accountView)
会計ビューを設定します。

パラメータ:
accountView - 会計ビュー

setCostView

public void setCostView(String costView)
原価計算ビューを設定します。

パラメータ:
costView - 原価計算ビュー

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ValuationDataList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ValuationDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList
すべての実装インタフェース:
Serializable
public class ValuationDataList
extends ValuationData
implements Serializable

評価データ情報クラス
機能は以下の通り

  • 評価データ情報をテーブル型で保持します。

関連項目:
直列化された形式

コンストラクタの概要
ValuationDataList()
評価データ情報を作成します。
ValuationDataList(int index)
評価データ情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData から継承したメソッド
getAccountView, getCommprice1, getCommprice2, getCommprice3, getCostView, getCurrency, getCurrencyIso, getCurrPeriod, getCurrPlanPrice, getDelFlag, getDevalInd, getFijCurCostEst, getFijFutCostEst, getFijPreCostEst, getFiscYear, getFunction, getFuturePr, getInHouse, getLifoFifo, getMaintStat, getMaterial, getMatlUsage, getMatOrigin, getMlActive, getMlSettle, getMovingPr, getMovPrPp, getMovPrPy, getOrigGroup, getOrigMat, getOverheadGrp, getPerCurCostEst, getPerFutCostEst, getPerPreCostEst, getPlndprdate1, getPlndprdate2, getPlndprdate3, getPlndPrice, getPlndprice1, getPlndprice2, getPlndprice3, getPoolnumber, getPrCtrlPp, getPrCtrlPy, getPrevPlanPrice, getPriceCtrl, getPriceUnit, getPrUnitPp, getPrUnitPy, getQtyStruct, getStdPrice, getStdPrPp, getStdPrPy, getTaxCmlUn, getTaxprice1, getTaxprice2, getTaxprice3, getValArea, getValCat, getValClass, getValidFrom, getValType, getVclassPp, getVclassPy, getVmPStock, getVmSoStk, setAccountView, setCommprice1, setCommprice2, setCommprice3, setCostView, setCurrency, setCurrencyIso, setCurrPeriod, setCurrPlanPrice, setDelFlag, setDevalInd, setFijCurCostEst, setFijFutCostEst, setFijPreCostEst, setFiscYear, setFunction, setFuturePr, setInHouse, setLifoFifo, setMaintStat, setMaterial, setMatlUsage, setMatOrigin, setMlActive, setMlSettle, setMovingPr, setMovPrPp, setMovPrPy, setOrigGroup, setOrigMat, setOverheadGrp, setPerCurCostEst, setPerFutCostEst, setPerPreCostEst, setPlndprdate1, setPlndprdate2, setPlndprdate3, setPlndPrice, setPlndprice1, setPlndprice2, setPlndprice3, setPoolnumber, setPrCtrlPp, setPrCtrlPy, setPrevPlanPrice, setPriceCtrl, setPriceUnit, setPrUnitPp, setPrUnitPy, setQtyStruct, setStdPrice, setStdPrPp, setStdPrPy, setTaxCmlUn, setTaxprice1, setTaxprice2, setTaxprice3, setValArea, setValCat, setValClass, setValidFrom, setValType, setVclassPp, setVclassPy, setVmPStock, setVmSoStk, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ValuationDataList

public ValuationDataList()
評価データ情報を作成します。

ValuationDataList

public ValuationDataList(int index)
評価データ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


WarehouseNumberData (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス WarehouseNumberData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
WarehouseNumberDataList
public class WarehouseNumberData
extends Object
implements Serializable

倉庫番号データ情報クラス
機能は以下の通り

  • 倉庫番号データ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
WarehouseNumberData()
倉庫番号データ情報を作成します。
メソッドの概要
String | getAddToStk() 既存在庫への追加許可を取得します。
String | getBlockStge() 平置保管域区分を取得します。
String | getCapyUsage() 保管容量使用を取得します。
String | getDelFlag() WM 倉庫内の全品目データ削除フラグを取得します。
String | getFunction() BAPI 機能を取得します。
String | getLEquip1() 積載装置数量 1を取得します。
String | getLEquip2() 積載装置数量 2を取得します。
String | getLEquip3() 積載装置数量 3を取得します。
String | getLeqUnit1() 積載装置数量 1 の数量単位を取得します。
String | getLeqUnit1Iso() ISO コードによる積載装置数量 1 の数量単位を取得します。
String | getLeqUnit2() 積載装置数量 2 の数量単位を取得します。
String | getLeqUnit2Iso() ISO コードによる積載装置数量 2 の数量単位を取得します。
String | getLeqUnit3() 積載装置数量 3 の数量単位を取得します。
String | getLeqUnit3Iso() ISO コードによる積載装置数量 3 の数量単位を取得します。
String | getMaterial() 品目コードを取得します。
String | getMsgToIm() 区分: 在庫管理への出力を取得します。
String | getPlacement() 在庫受入に対する保管域タイプ検索区分を取得します。
String | getProcureUn() 保管容量消費の数量単位を取得します。
String | getProcureUnIso() ISO コードでの保管容量消費の数量単位を取得します。
String | getRefUnit() 品目マスタレコードの数量単位初期値を取得します。
String | getSpecMvmt() 倉庫管理の特殊移動区分を取得します。
String | getStgesector() 保管区画区分を取得します。
String | getStgeType() 概略計画および詳細計画のピッキング保管域タイプを取得します。
String | getTwoStepPick() ツーステップピッキング適用品目を取得します。
String | getUnittype1() 第１保管単位タイプを取得します。
String | getUnittype2() 第２保管単位タイプを取得します。
String | getUnittype3() 第３保管単位タイプを取得します。
String | getWhseNo() 倉庫番号/複合倉庫を取得します。
String | getWithdrawal() 在庫払出に対する保管域タイプ区分を取得します。
String | getWmUnit() 倉庫管理の数量単位を取得します。
String | getWmUnitIso() ISO コードでの倉庫管理単位を取得します。
void | setAddToStk(String addToStk) 既存在庫への追加許可を設定します。
void | setBlockStge(String blockStge) 平置保管域区分を設定します。
void | setCapyUsage(String capyUsage) 保管容量使用を設定します。
void | setDelFlag(String delFlag) WM 倉庫内の全品目データ削除フラグを設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setLEquip1(String lEquip1) 積載装置数量 1を設定します。
void | setLEquip2(String lEquip2) 積載装置数量 2を設定します。
void | setLEquip3(String lEquip3) 積載装置数量 3を設定します。
void | setLeqUnit1(String leqUnit1) 積載装置数量 1 の数量単位を設定します。
void | setLeqUnit1Iso(String leqUnit1Iso) ISO コードによる積載装置数量 1 の数量単位を設定します。
void | setLeqUnit2(String leqUnit2) 積載装置数量 2 の数量単位を設定します。
void | setLeqUnit2Iso(String leqUnit2Iso) ISO コードによる積載装置数量 2 の数量単位を設定します。
void | setLeqUnit3(String leqUnit3) 積載装置数量 3 の数量単位を設定します。
void | setLeqUnit3Iso(String leqUnit3Iso) ISO コードによる積載装置数量 3 の数量単位を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMsgToIm(String msgToIm) 区分: 在庫管理への出力を設定します。
void | setPlacement(String placement) 在庫受入に対する保管域タイプ検索区分を設定します。
void | setProcureUn(String procureUn) 保管容量消費の数量単位を設定します。
void | setProcureUnIso(String procureUnIso) ISO コードでの保管容量消費の数量単位を設定します。
void | setRefUnit(String refUnit) 品目マスタレコードの数量単位初期値を設定します。
void | setSpecMvmt(String specMvmt) 倉庫管理の特殊移動区分を設定します。
void | setStgesector(String stgesector) 保管区画区分を設定します。
void | setStgeType(String stgeType) 概略計画および詳細計画のピッキング保管域タイプを設定します。
void | setTwoStepPick(String twoStepPick) ツーステップピッキング適用品目を設定します。
void | setUnittype1(String unittype1) 第１保管単位タイプを設定します。
void | setUnittype2(String unittype2) 第２保管単位タイプを設定します。
void | setUnittype3(String unittype3) 第３保管単位タイプを設定します。
void | setWhseNo(String whseNo) 倉庫番号/複合倉庫を設定します。
void | setWithdrawal(String withdrawal) 在庫払出に対する保管域タイプ区分を設定します。
void | setWmUnit(String wmUnit) 倉庫管理の数量単位を設定します。
void | setWmUnitIso(String wmUnitIso) ISO コードでの倉庫管理単位を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

WarehouseNumberData

public WarehouseNumberData()
倉庫番号データ情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getWhseNo

public String getWhseNo()
倉庫番号/複合倉庫を取得します。

戻り値:
whseNo 倉庫番号/複合倉庫

getDelFlag

public String getDelFlag()
WM 倉庫内の全品目データ削除フラグを取得します。

戻り値:
delFlag WM 倉庫内の全品目データ削除フラグ

getStgesector

public String getStgesector()
保管区画区分を取得します。

戻り値:
stgesector 保管区画区分

getPlacement

public String getPlacement()
在庫受入に対する保管域タイプ検索区分を取得します。

戻り値:
placement 在庫受入に対する保管域タイプ検索区分

getWithdrawal

public String getWithdrawal()
在庫払出に対する保管域タイプ区分を取得します。

戻り値:
withdrawal 在庫払出に対する保管域タイプ区分

getLEquip1

public String getLEquip1()
積載装置数量 1を取得します。

戻り値:
lEquip1 積載装置数量 1

getLEquip2

public String getLEquip2()
積載装置数量 2を取得します。

戻り値:
lEquip2 積載装置数量 2

getLEquip3

public String getLEquip3()
積載装置数量 3を取得します。

戻り値:
lEquip3 積載装置数量 3

getLeqUnit1

public String getLeqUnit1()
積載装置数量 1 の数量単位を取得します。

戻り値:
leqUnit1 積載装置数量 1 の数量単位

getLeqUnit1Iso

public String getLeqUnit1Iso()
ISO コードによる積載装置数量 1 の数量単位を取得します。

戻り値:
leqUnit1Iso ISO コードによる積載装置数量 1 の数量単位

getLeqUnit2

public String getLeqUnit2()
積載装置数量 2 の数量単位を取得します。

戻り値:
leqUnit2 積載装置数量 2 の数量単位

getLeqUnit2Iso

public String getLeqUnit2Iso()
ISO コードによる積載装置数量 2 の数量単位を取得します。

戻り値:
leqUnit2Iso ISO コードによる積載装置数量 2 の数量単位

getLeqUnit3

public String getLeqUnit3()
積載装置数量 3 の数量単位を取得します。

戻り値:
leqUnit3 積載装置数量 3 の数量単位

getLeqUnit3Iso

public String getLeqUnit3Iso()
ISO コードによる積載装置数量 3 の数量単位を取得します。

戻り値:
leqUnit3Iso ISO コードによる積載装置数量 3 の数量単位

getUnittype1

public String getUnittype1()
第１保管単位タイプを取得します。

戻り値:
unittype1 第１保管単位タイプ

getUnittype2

public String getUnittype2()
第２保管単位タイプを取得します。

戻り値:
unittype2 第２保管単位タイプ

getUnittype3

public String getUnittype3()
第３保管単位タイプを取得します。

戻り値:
unittype3 第３保管単位タイプ

getWmUnit

public String getWmUnit()
倉庫管理の数量単位を取得します。

戻り値:
wmUnit 倉庫管理の数量単位

getWmUnitIso

public String getWmUnitIso()
ISO コードでの倉庫管理単位を取得します。

戻り値:
wmUnitIso ISO コードでの倉庫管理単位

getAddToStk

public String getAddToStk()
既存在庫への追加許可を取得します。

戻り値:
addToStk 既存在庫への追加許可

getBlockStge

public String getBlockStge()
平置保管域区分を取得します。

戻り値:
blockStge 平置保管域区分

getMsgToIm

public String getMsgToIm()
区分: 在庫管理への出力を取得します。

戻り値:
msgToIm 区分: 在庫管理への出力

getSpecMvmt

public String getSpecMvmt()
倉庫管理の特殊移動区分を取得します。

戻り値:
specMvmt 倉庫管理の特殊移動区分

getCapyUsage

public String getCapyUsage()
保管容量使用を取得します。

戻り値:
capyUsage 保管容量使用

getProcureUn

public String getProcureUn()
保管容量消費の数量単位を取得します。

戻り値:
procureUn 保管容量消費の数量単位

getProcureUnIso

public String getProcureUnIso()
ISO コードでの保管容量消費の数量単位を取得します。

戻り値:
procureUnIso ISO コードでの保管容量消費の数量単位

getStgeType

public String getStgeType()
概略計画および詳細計画のピッキング保管域タイプを取得します。

戻り値:
stgeType 概略計画および詳細計画のピッキング保管域タイプ

getRefUnit

public String getRefUnit()
品目マスタレコードの数量単位初期値を取得します。

戻り値:
refUnit 品目マスタレコードの数量単位初期値

getTwoStepPick

public String getTwoStepPick()
ツーステップピッキング適用品目を取得します。

戻り値:
twoStepPick ツーステップピッキング適用品目

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setWhseNo

public void setWhseNo(String whseNo)
倉庫番号/複合倉庫を設定します。

パラメータ:
whseNo - 倉庫番号/複合倉庫

setDelFlag

public void setDelFlag(String delFlag)
WM 倉庫内の全品目データ削除フラグを設定します。

パラメータ:
delFlag - WM 倉庫内の全品目データ削除フラグ

setStgesector

public void setStgesector(String stgesector)
保管区画区分を設定します。

パラメータ:
stgesector - 保管区画区分

setPlacement

public void setPlacement(String placement)
在庫受入に対する保管域タイプ検索区分を設定します。

パラメータ:
placement - 在庫受入に対する保管域タイプ検索区分

setWithdrawal

public void setWithdrawal(String withdrawal)
在庫払出に対する保管域タイプ区分を設定します。

パラメータ:
withdrawal - 在庫払出に対する保管域タイプ区分

setLEquip1

public void setLEquip1(String lEquip1)
積載装置数量 1を設定します。

パラメータ:
lEquip1 - 積載装置数量 1

setLEquip2

public void setLEquip2(String lEquip2)
積載装置数量 2を設定します。

パラメータ:
lEquip2 - 積載装置数量 2

setLEquip3

public void setLEquip3(String lEquip3)
積載装置数量 3を設定します。

パラメータ:
lEquip3 - 積載装置数量 3

setLeqUnit1

public void setLeqUnit1(String leqUnit1)
積載装置数量 1 の数量単位を設定します。

パラメータ:
leqUnit1 - 積載装置数量 1 の数量単位

setLeqUnit1Iso

public void setLeqUnit1Iso(String leqUnit1Iso)
ISO コードによる積載装置数量 1 の数量単位を設定します。

パラメータ:
leqUnit1Iso - ISO コードによる積載装置数量 1 の数量単位

setLeqUnit2

public void setLeqUnit2(String leqUnit2)
積載装置数量 2 の数量単位を設定します。

パラメータ:
leqUnit2 - 積載装置数量 2 の数量単位

setLeqUnit2Iso

public void setLeqUnit2Iso(String leqUnit2Iso)
ISO コードによる積載装置数量 2 の数量単位を設定します。

パラメータ:
leqUnit2Iso - ISO コードによる積載装置数量 2 の数量単位

setLeqUnit3

public void setLeqUnit3(String leqUnit3)
積載装置数量 3 の数量単位を設定します。

パラメータ:
leqUnit3 - 積載装置数量 3 の数量単位

setLeqUnit3Iso

public void setLeqUnit3Iso(String leqUnit3Iso)
ISO コードによる積載装置数量 3 の数量単位を設定します。

パラメータ:
leqUnit3Iso - ISO コードによる積載装置数量 3 の数量単位

setUnittype1

public void setUnittype1(String unittype1)
第１保管単位タイプを設定します。

パラメータ:
unittype1 - 第１保管単位タイプ

setUnittype2

public void setUnittype2(String unittype2)
第２保管単位タイプを設定します。

パラメータ:
unittype2 - 第２保管単位タイプ

setUnittype3

public void setUnittype3(String unittype3)
第３保管単位タイプを設定します。

パラメータ:
unittype3 - 第３保管単位タイプ

setWmUnit

public void setWmUnit(String wmUnit)
倉庫管理の数量単位を設定します。

パラメータ:
wmUnit - 倉庫管理の数量単位

setWmUnitIso

public void setWmUnitIso(String wmUnitIso)
ISO コードでの倉庫管理単位を設定します。

パラメータ:
wmUnitIso - ISO コードでの倉庫管理単位

setAddToStk

public void setAddToStk(String addToStk)
既存在庫への追加許可を設定します。

パラメータ:
addToStk - 既存在庫への追加許可

setBlockStge

public void setBlockStge(String blockStge)
平置保管域区分を設定します。

パラメータ:
blockStge - 平置保管域区分

setMsgToIm

public void setMsgToIm(String msgToIm)
区分: 在庫管理への出力を設定します。

パラメータ:
msgToIm - 区分: 在庫管理への出力

setSpecMvmt

public void setSpecMvmt(String specMvmt)
倉庫管理の特殊移動区分を設定します。

パラメータ:
specMvmt - 倉庫管理の特殊移動区分

setCapyUsage

public void setCapyUsage(String capyUsage)
保管容量使用を設定します。

パラメータ:
capyUsage - 保管容量使用

setProcureUn

public void setProcureUn(String procureUn)
保管容量消費の数量単位を設定します。

パラメータ:
procureUn - 保管容量消費の数量単位

setProcureUnIso

public void setProcureUnIso(String procureUnIso)
ISO コードでの保管容量消費の数量単位を設定します。

パラメータ:
procureUnIso - ISO コードでの保管容量消費の数量単位

setStgeType

public void setStgeType(String stgeType)
概略計画および詳細計画のピッキング保管域タイプを設定します。

パラメータ:
stgeType - 概略計画および詳細計画のピッキング保管域タイプ

setRefUnit

public void setRefUnit(String refUnit)
品目マスタレコードの数量単位初期値を設定します。

パラメータ:
refUnit - 品目マスタレコードの数量単位初期値

setTwoStepPick

public void setTwoStepPick(String twoStepPick)
ツーステップピッキング適用品目を設定します。

パラメータ:
twoStepPick - ツーステップピッキング適用品目

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


WarehouseNumberDataList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス WarehouseNumberDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList
すべての実装インタフェース:
Serializable
public class WarehouseNumberDataList
extends WarehouseNumberData
implements Serializable

倉庫番号データ情報クラス
機能は以下の通り

  • 倉庫番号データ情報をテーブル型で保持します。

関連項目:
直列化された形式

コンストラクタの概要
WarehouseNumberDataList()
倉庫番号データ情報を作成します。
WarehouseNumberDataList(int index)
倉庫番号データ情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData から継承したメソッド
getAddToStk, getBlockStge, getCapyUsage, getDelFlag, getFunction, getLEquip1, getLEquip2, getLEquip3, getLeqUnit1, getLeqUnit1Iso, getLeqUnit2, getLeqUnit2Iso, getLeqUnit3, getLeqUnit3Iso, getMaterial, getMsgToIm, getPlacement, getProcureUn, getProcureUnIso, getRefUnit, getSpecMvmt, getStgesector, getStgeType, getTwoStepPick, getUnittype1, getUnittype2, getUnittype3, getWhseNo, getWithdrawal, getWmUnit, getWmUnitIso, setAddToStk, setBlockStge, setCapyUsage, setDelFlag, setFunction, setLEquip1, setLEquip2, setLEquip3, setLeqUnit1, setLeqUnit1Iso, setLeqUnit2, setLeqUnit2Iso, setLeqUnit3, setLeqUnit3Iso, setMaterial, setMsgToIm, setPlacement, setProcureUn, setProcureUnIso, setRefUnit, setSpecMvmt, setStgesector, setStgeType, setTwoStepPick, setUnittype1, setUnittype2, setUnittype3, setWhseNo, setWithdrawal, setWmUnit, setWmUnitIso, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

WarehouseNumberDataList

public WarehouseNumberDataList()
倉庫番号データ情報を作成します。

WarehouseNumberDataList

public WarehouseNumberDataList(int index)
倉庫番号データ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException の使用

SAPPurchaseAppException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |

jp.co.intra_mart.foundation.sap.module.purchase での SAPPurchaseAppException の使用

SAPPurchaseAppException をスローする jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 void SupplierGetDetailController.executeBapi()
SupplierDetailのexecuteBapi()を呼び出し仕入先マスタ詳細情報を作成します。
 void SupplierExistenceCheckController.executeBapi()
SupplierExistenceCheckのexecuteBapi()を呼び出し仕入先コード存在チェックを行います。
 void SupplierExistenceCheck.executeBapi()
BapiControllerにより仕入先コード存在チェックを作成します。
 void SupplierDetail.executeBapi()
BapiControllerにより仕入先マスタ詳細を作成します。
 void PurchaseResetReleaseController.executeBapi()
伝票承認取消処理を実行します。
 void PurchaseReleaseController.executeBapi()
伝票承認処理を実行します。
 void PurchaseOrderPostChangeController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を変更します。
 void PurchaseOrderPayPostController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を登録します。
 void PurchaseGetItemSrelController.executeBapi()
PurchaseGetItemSrelのexecuteBapi()を呼び出し伝票承認対象一覧を取得します。
 void PurchaseGetItemSrel.executeBapi()
BapiControllerにより仕入先マスタ詳細を作成します。
 void MaterialSaveReplicaController.executeBapi()
BapiControllerにより品目マスタを更新します。
 void MaterialGetListController.executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し品目コードを検索します。
 void MaterialGetAllController.executeBapi()
BapiControllerにより品目マスタ照会を行います。
 void MaterialAvailabilityController.executeBapi()
MaterialAvailabilityのexecuteBapi()を呼び出し品目コードを検索します。
 void GoodsMvtGetItemsController.executeBapi()
GoodsMvtGetItemsのexecuteBapi()を呼び出し品目コードを検索します。
 void GoodsMvtCreateController.executeBapi()
GoodsMvtCreateのexecuteBapi()を呼び出し品目コードを検索します。

SAPPurchaseAppException をスローする jp.co.intra_mart.foundation.sap.module.purchase のコンストラクタ
SupplierGetDetailController(String vendor, String compCode)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(String vendor, String compCode, SapClient sapClient)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierExistenceCheckController(String vendor, String compCode)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheckController(String vendor, String compCode, SapClient sapClient)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheck(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先コード存在チェックを作成します。
SupplierDetail(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先マスタ詳細を作成します。
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrel(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
承認対象一覧を作成します。

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber での SAPPurchaseAppException の使用

SAPPurchaseAppException をスローする jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber のコンストラクタ
StdMaterialGetIntNumberList(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
executeBapiを呼び出し品目コード割当済一覧を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseSystemException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseSystemException の使用

SAPPurchaseSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |

jp.co.intra_mart.foundation.sap.module.purchase での SAPPurchaseSystemException の使用

SAPPurchaseSystemException をスローする jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 void SupplierGetDetailController.executeBapi()
SupplierDetailのexecuteBapi()を呼び出し仕入先マスタ詳細情報を作成します。
 void SupplierExistenceCheckController.executeBapi()
SupplierExistenceCheckのexecuteBapi()を呼び出し仕入先コード存在チェックを行います。
 void SupplierExistenceCheck.executeBapi()
BapiControllerにより仕入先コード存在チェックを作成します。
 void SupplierDetail.executeBapi()
BapiControllerにより仕入先マスタ詳細を作成します。
 void PurchaseResetReleaseController.executeBapi()
伝票承認取消処理を実行します。
 void PurchaseReleaseController.executeBapi()
伝票承認処理を実行します。
 String PurchaseReleaseController.getRetCode()
リターン値、ABAP 命令後のリターン値を取得します。
 void PurchaseOrderPostChangeController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を変更します。
 void PurchaseOrderPayPostController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を登録します。
 ArrayList PurchaseOrderPayPost.getItemTextList()
明細テキスト一覧を取得します｡
 void PurchaseOrderPayPost.setStrParam(String paramStr, String paramName, String value)
構造型の項目に値をセットします。
 void PurchaseOrderPayPost.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void PurchaseGetItemSrelController.executeBapi()
PurchaseGetItemSrelのexecuteBapi()を呼び出し伝票承認対象一覧を取得します。
 void PurchaseGetItemSrel.executeBapi()
BapiControllerにより仕入先マスタ詳細を作成します。
 void MaterialSaveReplicaController.executeBapi()
BapiControllerにより品目マスタを更新します。
 void MaterialSaveReplicaController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void MaterialGetListController.executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し品目コードを検索します。
 void MaterialGetList.setImportParam(BapiController bapiController)
品目コードを検索する条件ををセットします。
 void MaterialGetList.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void MaterialGetAllController.executeBapi()
BapiControllerにより品目マスタ照会を行います。
 void MaterialGetAllController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void MaterialAvailabilityController.executeBapi()
MaterialAvailabilityのexecuteBapi()を呼び出し品目コードを検索します。
 void MaterialAvailabilityController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void GoodsMvtGetItemsController.executeBapi()
GoodsMvtGetItemsのexecuteBapi()を呼び出し品目コードを検索します。
 void GoodsMvtGetItemsController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void GoodsMvtCreateController.executeBapi()
GoodsMvtCreateのexecuteBapi()を呼び出し品目コードを検索します。
 void GoodsMvtCreateController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void GoodsMvtCreateController.setStrParam(String paramStr, String paramName, String value)
構造型の項目に値をセットします。

SAPPurchaseSystemException をスローする jp.co.intra_mart.foundation.sap.module.purchase のコンストラクタ
SupplierGetDetailController(String vendor, String compCode)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(String vendor, String compCode, SapClient sapClient)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierExistenceCheckController(String vendor, String compCode)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheckController(String vendor, String compCode, SapClient sapClient)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheck(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先コード存在チェックを作成します。
SupplierDetail(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先マスタ詳細を作成します。
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrel(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
承認対象一覧を作成します。

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber での SAPPurchaseSystemException の使用

SAPPurchaseSystemException をスローする jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber のコンストラクタ
StdMaterialGetIntNumberList(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
executeBapiを呼び出し品目コード割当済一覧を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.purchase.exception (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase.exception
例外
SAPPurchaseAppException
SAPPurchaseSystemException


jp.co.intra_mart.foundation.sap.module.purchase.exception (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.exception

ＳＡＰ連携経費購買系例外クラスを提供します。

参照:
説明

例外の概要
SAPPurchaseAppException | 購買系APIアプリケーション例外クラス
SAPPurchaseSystemException | 購買系APIシステム例外クラス

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.exception の説明

ＳＡＰ連携経費購買系例外クラスを提供します。


jp.co.intra_mart.foundation.sap.module.purchase.exception クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.common.exception.SAPException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
            • class jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
            • class jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseSystemException


パッケージ jp.co.intra_mart.foundation.sap.module.purchase.exception の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase.exception の使用

jp.co.intra_mart.foundation.sap.module.purchase.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.purchase.exception のクラス
SAPPurchaseAppException
購買系APIアプリケーション例外クラス
SAPPurchaseSystemException
購買系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber により使用される jp.co.intra_mart.foundation.sap.module.purchase.exception のクラス
SAPPurchaseAppException
購買系APIアプリケーション例外クラス
SAPPurchaseSystemException
購買系APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SAPPurchaseAppException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.exception
クラス SAPPurchaseAppException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
                    拡張 jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException
すべての実装インタフェース:
Serializable
public class SAPPurchaseAppException
extends SAPModuleAppException

購買系APIアプリケーション例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPPurchaseAppException(String message)
購買系APIアプリケーション例外
SAPPurchaseAppException(String message, Throwable ex)
購買系APIアプリケーション例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPPurchaseAppException

public SAPPurchaseAppException(String message,
                               Throwable ex)
購買系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPPurchaseAppException

public SAPPurchaseAppException(String message)
購買系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPPurchaseSystemException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.exception
クラス SAPPurchaseSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
                    拡張 jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseSystemException
すべての実装インタフェース:
Serializable
public class SAPPurchaseSystemException
extends SAPModuleSystemException

購買系APIシステム例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPPurchaseSystemException(String message, Throwable ex)
購買系APIシステム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPPurchaseSystemException

public SAPPurchaseSystemException(String message,
                                  Throwable ex)
購買系APIシステム例外

パラメータ:
message - エラーメッセージ
ex - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode の使用

GoodsMvtCode を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での GoodsMvtCode の使用

GoodsMvtCode を返す jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のメソッド
 GoodsMvtCode GoodsMvtCreate.getGoodsMvtCode()
在庫移動に対するコードのトランザクションへの割当を取得します。

GoodsMvtCode 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のメソッド
static void | ParamGoodsMvtCode.setImportParam(BapiController bapiController, GoodsMvtCode goodsMvtCode) 在庫移動に対するコードのトランザクションへの割当の値をセットします。
void | GoodsMvtCreate.setGoodsMvtCode(GoodsMvtCode goodsMvtCode) 在庫移動に対するコードのトランザクションへの割当を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate の使用

GoodsMvtCreate を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での GoodsMvtCreate の使用

jp.co.intra_mart.foundation.sap.module.purchase での GoodsMvtCreate のサブクラス
 class GoodsMvtCreateController
入庫伝票登録コントローラクラス
機能は以下の通り
入庫伝票を登録します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret の使用

GoodsMvtHeadret を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での GoodsMvtHeadret の使用

GoodsMvtHeadret を返す jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のメソッド
 GoodsMvtHeadret GoodsMvtCreate.getGoodsMvtHeadret()
入出庫伝票番号/入出庫伝票会計年度を取得します。

GoodsMvtHeadret 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のメソッド
static void | ParamGoodsMvtHeadret.setExportParam(BapiController bapiController, GoodsMvtHeadret goodsMvtHeadret) 入出庫伝票ヘッダデータの値をセットします。
void | GoodsMvtCreate.setGoodsMvtHeadret(GoodsMvtHeadret goodsMvtHeadret) 入出庫伝票番号/入出庫伝票会計年度を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


GoodsMvtCode (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス GoodsMvtCode

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode
すべての実装インタフェース:
Serializable
public class GoodsMvtCode
extends Object
implements Serializable

在庫移動に対するコードのトランザクションへの割当情報クラス
機能は以下の通り

  • 在庫移動に対するコードのトランザクションへの割当情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GoodsMvtCode()
在庫移動に対するコードのトランザクションへの割当情報を作成します。
メソッドの概要
String | getGmCode() BAPI 在庫移動トランザクションのコード割当を取得します。
void | setGmCode(String gmCode) BAPI 在庫移動トランザクションのコード割当を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtCode

public GoodsMvtCode()
在庫移動に対するコードのトランザクションへの割当情報を作成します。

メソッドの詳細

getGmCode

public String getGmCode()
BAPI 在庫移動トランザクションのコード割当を取得します。

戻り値:
gmCode BAPI 在庫移動トランザクションのコード割当

setGmCode

public void setGmCode(String gmCode)
BAPI 在庫移動トランザクションのコード割当を設定します。

パラメータ:
gmCode - BAPI 在庫移動トランザクションのコード割当

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtCreate (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス GoodsMvtCreate

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
GoodsMvtCreateController
public class GoodsMvtCreate
extends UpdateController
implements Serializable

入出庫伝票登録情報クラス
機能は以下の通り

  • 入出庫伝票登録情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
GoodsMvtCreate()
コンストラクタ。
GoodsMvtCreate(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。
GoodsMvtCreate(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
メソッドの概要
GoodsMvtCode | getGoodsMvtCode() 在庫移動に対するコードのトランザクションへの割当を取得します。
GoodsMvtHeader | getGoodsMvtHeader() 入出庫伝票ヘッダデータを取得します。
GoodsMvtHeadret | getGoodsMvtHeadret() 入出庫伝票番号/入出庫伝票会計年度を取得します。
List | getGoodsMvtItemList() 入出庫伝票明細を取得します。
List | getGoodsMvtSerialNumberList() シリアル番号を取得します。
String | getMatdocumentyear() 入出庫伝票会計年度を取得します。
String | getMaterialdocument() 入出庫伝票番号を取得します。
String | getTestrun() 在庫移動シミュレーションを取得します。
void | setExportParam(BapiController bapiController) 伝票に登録された情報ををセットします。
void | setGoodsMvtCode(GoodsMvtCode goodsMvtCode) 在庫移動に対するコードのトランザクションへの割当を設定します。
void | setGoodsMvtHeader(GoodsMvtHeader goodsMvtHeader) 入出庫伝票ヘッダデータを設定します。
void | setGoodsMvtHeadret(GoodsMvtHeadret goodsMvtHeadret) 入出庫伝票番号/入出庫伝票会計年度を設定します。
void | setGoodsMvtItemList(List goodsMvtItemList) 入出庫伝票明細を設定します。
void | setGoodsMvtSerialNumberList(List goodsMvtSerialNumberList) シリアル番号を設定します。
void | setImportParam(BapiController bapiController) 伝票に登録する値ををセットします。
void | setMatdocumentyear(String matdocumentyear) 入出庫伝票会計年度を設定します。
void | setMaterialdocument(String materialdocument) 入出庫伝票番号を設定します。
void | setTestrun(String testrun) 在庫移動シミュレーションを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtCreate

public GoodsMvtCreate()
コンストラクタ。

GoodsMvtCreate

public GoodsMvtCreate(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。

パラメータ:
conectionManager - コネクションマネージャー

GoodsMvtCreate

public GoodsMvtCreate(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
伝票に登録された情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getTestrun

public String getTestrun()
在庫移動シミュレーションを取得します。

戻り値:
testrun 在庫移動シミュレーション

getMatdocumentyear

public String getMatdocumentyear()
入出庫伝票会計年度を取得します。

戻り値:
matdocumentyear 入出庫伝票会計年度

getMaterialdocument

public String getMaterialdocument()
入出庫伝票番号を取得します。

戻り値:
materialdocument 入出庫伝票番号

getGoodsMvtCode

public GoodsMvtCode getGoodsMvtCode()
在庫移動に対するコードのトランザクションへの割当を取得します。

戻り値:
goodsMvtCode 在庫移動に対するコードのトランザクションへの割当

getGoodsMvtHeader

public GoodsMvtHeader getGoodsMvtHeader()
入出庫伝票ヘッダデータを取得します。

戻り値:
goodsMvtHeader 入出庫伝票ヘッダデータ

getGoodsMvtHeadret

public GoodsMvtHeadret getGoodsMvtHeadret()
入出庫伝票番号/入出庫伝票会計年度を取得します。

戻り値:
goodsMvtHeadret 入出庫伝票番号/入出庫伝票会計年度

getGoodsMvtItemList

public List getGoodsMvtItemList()
入出庫伝票明細を取得します。

戻り値:
goodsMvtItemList 入出庫伝票明細

getGoodsMvtSerialNumberList

public List getGoodsMvtSerialNumberList()
シリアル番号を取得します。

戻り値:
goodsMvtSerialNumberList シリアル番号

setTestrun

public void setTestrun(String testrun)
在庫移動シミュレーションを設定します。

パラメータ:
testrun - 在庫移動シミュレーション

setMatdocumentyear

public void setMatdocumentyear(String matdocumentyear)
入出庫伝票会計年度を設定します。

パラメータ:
matdocumentyear - 入出庫伝票会計年度

setMaterialdocument

public void setMaterialdocument(String materialdocument)
入出庫伝票番号を設定します。

パラメータ:
materialdocument - 入出庫伝票番号

setGoodsMvtCode

public void setGoodsMvtCode(GoodsMvtCode goodsMvtCode)
在庫移動に対するコードのトランザクションへの割当を設定します。

パラメータ:
goodsMvtCode - 在庫移動に対するコードのトランザクションへの割当

setGoodsMvtHeader

public void setGoodsMvtHeader(GoodsMvtHeader goodsMvtHeader)
入出庫伝票ヘッダデータを設定します。

パラメータ:
goodsMvtHeader - 入出庫伝票ヘッダデータ

setGoodsMvtHeadret

public void setGoodsMvtHeadret(GoodsMvtHeadret goodsMvtHeadret)
入出庫伝票番号/入出庫伝票会計年度を設定します。

パラメータ:
goodsMvtHeadret - 入出庫伝票番号/入出庫伝票会計年度

setGoodsMvtItemList

public void setGoodsMvtItemList(List goodsMvtItemList)
入出庫伝票明細を設定します。

パラメータ:
goodsMvtItemList - 入出庫伝票明細

setGoodsMvtSerialNumberList

public void setGoodsMvtSerialNumberList(List goodsMvtSerialNumberList)
シリアル番号を設定します。

パラメータ:
goodsMvtSerialNumberList - シリアル番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtHeadret (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス GoodsMvtHeadret

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret
すべての実装インタフェース:
Serializable
public class GoodsMvtHeadret
extends Object
implements Serializable

入出庫伝票番号/入出庫伝票会計年度情報クラス
機能は以下の通り

  • 入出庫伝票番号/入出庫伝票会計年度情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GoodsMvtHeadret()
入出庫伝票番号/入出庫伝票会計年度情報を作成します。
メソッドの概要
String | getDocYear() 入出庫伝票年度を取得します。
String | getMatDoc() 入出庫伝票番号を取得します。
void | setDocYear(String docYear) 入出庫伝票年度を設定します。
void | setMatDoc(String matDoc) 入出庫伝票番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtHeadret

public GoodsMvtHeadret()
入出庫伝票番号/入出庫伝票会計年度情報を作成します。

メソッドの詳細

getMatDoc

public String getMatDoc()
入出庫伝票番号を取得します。

戻り値:
matDoc 入出庫伝票番号

getDocYear

public String getDocYear()
入出庫伝票年度を取得します。

戻り値:
docYear 入出庫伝票年度

setMatDoc

public void setMatDoc(String matDoc)
入出庫伝票番号を設定します。

パラメータ:
matDoc - 入出庫伝票番号

setDocYear

public void setDocYear(String docYear)
入出庫伝票年度を設定します。

パラメータ:
docYear - 入出庫伝票年度

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtItem (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス GoodsMvtItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem
すべての実装インタフェース:
Serializable
public class GoodsMvtItem
extends Object
implements Serializable

入出庫伝票明細情報クラス
機能は以下の通り

  • 入出庫伝票明細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GoodsMvtItem()
入出庫伝票明細情報を作成します。
GoodsMvtItem(int index)
入出庫伝票明細情報を作成します。
メソッドの概要
String | getActivity() 作業番号を取得します。
String | getActtype() 活動タイプを取得します。
String | getAmountLc() マニュアル入力による転記金額 (国内通貨)を取得します。
String | getAmountSv() 外部入力による販売金額 (国内通貨)を取得します。
String | getAssetNo() 資産番号を取得します。
String | getBaseUom() 基本数量単位を取得します。
String | getBatch() ロット番号を取得します。
String | getCalcMotive() 計算区分を取得します。
String | getCmmtItem() 資金予算コードを取得します。
String | getCmmtItemLong() 資金予算コードを取得します。
String | getCoBusproc() 業務プロセスを取得します。
String | getCompShip() 出荷指示順守を取得します。
String | getCostcenter() 原価センタを取得します。
String | getCostObj() 原価対象を取得します。
String | getCustomer() 得意先コードを取得します。
String | getDelivItem() 出荷明細を取得します。
String | getDelivItemToSearch() 出荷明細を取得します。
String | getDelivNumb() 出荷伝票を取得します。
String | getDelivNumbToSearch() 出荷伝票を取得します。
String | getEanUpc() 国際商品コード (EAN/UPC)を取得します。
String | getEntryQnt() 入力単位での数量を取得します。
String | getEntryUom() 入力単位を取得します。
String | getEntryUomIso() 単位の ISO コードを取得します。
String | getExpirydate() 有効期間期限日を取得します。
String | getFuncArea() 機能領域を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getFund() 会計区分を取得します。
String | getFundsCtr() 予算センタを取得します。
String | getGlAccount() G/L 勘定コードを取得します。
String | getGrantNbr() 補助金を取得します。
String | getGrNumber() 入庫番号を取得します。
String | getGrRcpt() 受領者を取得します。
String | getGrRcptx() 関連ユーザデータ項目の更新情報を取得します。
int | getIndex() レコード番号を取得します｡
String | getIndProposeQuanx() 提案数量 (初期数量)を取得します。
String | getItemText() 明細テキストを取得します。
String | getLineDepth() 伝票での明細行階層レベルを取得します。
String | getLineId() 伝票明細行の一意 IDを取得します。
String | getMatdocTrCancel() 取消予定の転送要求の入出庫伝票番号を取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getMatitemTrCancel() 取消予定の転送数量入出庫伝票明細を取得します。
String | getMatyearTrCancel() 取消予定の転送要求入出庫伝票年度を取得します。
String | getMoveBatch() 入庫/出庫ロットを取得します。
String | getMoveMat() 入庫/出庫品目を取得します。
String | getMoveMatExternal() 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を取得します。
String | getMoveMatGuid() 項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を取得します。
String | getMoveMatVersion() 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を取得します。
String | getMovePlant() 入庫/出庫プラントを取得します。
String | getMoveReas() 移動理由を取得します。
String | getMoveStloc() 入庫/出庫保管場所を取得します。
String | getMoveType() 移動タイプ (在庫管理)を取得します。
String | getMoveValType() 転送ロットの評価タイプを取得します。
String | getMvtInd() 移動区分を取得します。
String | getNbSlips() 入庫/出庫票の印刷部数を取得します。
String | getNbSlipsx() 関連ユーザデータ項目の更新情報を取得します。
String | getNetwork() 勘定割当のネットワーク番号を取得します。
String | getNoMoreGr() 納入完了 区分を取得します。
String | getNoPstChgnt() 区分: 振替要求通知登録禁止を取得します。
String | getNoTransferReq() 区分: 転送要求未登録を取得します。
String | getOrderid() 指図番号を取得します。
String | getOrderItno() 指図明細番号を取得します。
String | getOrderprUn() 購買発注価格単位 (購買管理)を取得します。
String | getOrderprUnIso() 単位の ISO コードを取得します。
String | getParCompco() 決済会社コードを取得します。
String | getParentId() 1 レベル上位の行 IDを取得します。
String | getPartAcct() 取引先勘定コードを取得します。
String | getPlant() プラントを取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
String | getPoNumber() 購買発注番号を取得します。
String | getPoPrQnt() 数量 (購買発注価格単位)を取得します。
String | getProdDate() ロット製造日付を取得します。
String | getProfitCtr() 利益センタを取得します。
String | getProfitSegmNo() 収益性セグメント番号 (CO-PA)を取得します。
String | getQuantity() 数量を取得します。
String | getRefDate() 決済の参照日付を取得します。
String | getRefDoc() 参照伝票の伝票番号を取得します。
String | getRefDocIt() 参照伝票の明細番号を取得します。
String | getRefDocYr() 参照伝票の会計年度を取得します。
String | getReservNo() 入出庫予定/従属所要量の番号を取得します。
String | getResItem() 入出庫予定/従属所要量の明細番号を取得します。
String | getResType() レコードタイプを取得します。
String | getRlEstKey() 不動産管理対象の内部キーを取得します。
String | getSalesOrd() 受注伝票番号を取得します。
String | getSchedLine() 受注納入日程を取得します。
String | getSerialnoAutoNumberassignment() シリアル番号の自動登録を取得します。
String | getShipping() 出荷指示を取得します。
String | getSOrdItem() 受注明細番号を取得します。
String | getSpecMvmt() 倉庫管理の特殊移動区分を取得します。
String | getSpecStock() 特殊在庫区分を取得します。
String | getStckType() 在庫タイプを取得します。
String | getStgeBin() 棚番を取得します。
String | getStgeBinPc() 在庫転送棚番を取得します。
String | getStgeBinSt() 在庫転送棚番を取得します。
String | getStgeLoc() 保管場所を取得します。
String | getStgeType() 保管域タイプを取得します。
String | getStgeTypePc() 在庫転送の保管域タイプを取得します。
String | getStgeTypeSt() 在庫転送の保管域タイプを取得します。
String | getStUnQtyy1() 代替数量単位での在庫受入予定保管単位別数量を取得します。
String | getStUnQtyy1Iso() 単位の ISO コードを取得します。
String | getStUnQtyy2() 代替数量単位での在庫受入予定保管単位別数量を取得します。
String | getStUnQtyy2Iso() 単位の ISO コードを取得します。
String | getSubNumber() 資産補助番号を取得します。
String | getSuPlStck1() 在庫受入予定の保管単位数を取得します。
String | getSuPlStck2() 在庫受入予定の保管単位数を取得します。
String | getSupplVend() 供給仕入先を取得します。
String | getTrPartBa() 取引会社事業領域を取得します。
String | getUnittype1() 保管単位タイプを取得します。
String | getUnittype2() 保管単位タイプを取得します。
String | getUnloadPt() 荷渡ポイントを取得します。
String | getUnloadPtx() 関連ユーザデータ項目の更新情報を取得します。
String | getValSalesOrd() 評価受注在庫の受注番号を取得します。
String | getValSOrdItem() 評価受注在庫の受注明細を取得します。
String | getValType() 評価タイプを取得します。
String | getValWbsElem() WBS 要素を取得します。
String | getVendor() 仕入先勘定コードを取得します。
String | getVendrbatch() 仕入先ロット番号を取得します。
String | getWbsElem() WBS 要素を取得します。
String | getWithdrawn() 入出庫予定に対する出庫完了を取得します。
String | getXstob() 取消移動タイプ区分の使用を取得します。
void | setActivity(String activity) 作業番号を設定します。
void | setActtype(String acttype) 活動タイプを設定します。
void | setAmountLc(String amountLc) マニュアル入力による転記金額 (国内通貨)を設定します。
void | setAmountSv(String amountSv) 外部入力による販売金額 (国内通貨)を設定します。
void | setAssetNo(String assetNo) 資産番号を設定します。
void | setBaseUom(String baseUom) 基本数量単位を設定します。
void | setBatch(String batch) ロット番号を設定します。
void | setCalcMotive(String calcMotive) 計算区分を設定します。
void | setCmmtItem(String cmmtItem) 資金予算コードを設定します。
void | setCmmtItemLong(String cmmtItemLong) 資金予算コードを設定します。
void | setCoBusproc(String coBusproc) 業務プロセスを設定します。
void | setCompShip(String compShip) 出荷指示順守を設定します。
void | setCostcenter(String costcenter) 原価センタを設定します。
void | setCostObj(String costObj) 原価対象を設定します。
void | setCustomer(String customer) 得意先コードを設定します。
void | setDelivItem(String delivItem) 出荷明細を設定します。
void | setDelivItemToSearch(String delivItemToSearch) 出荷明細を設定します。
void | setDelivNumb(String delivNumb) 出荷伝票を設定します。
void | setDelivNumbToSearch(String delivNumbToSearch) 出荷伝票を設定します。
void | setEanUpc(String eanUpc) 国際商品コード (EAN/UPC)を設定します。
void | setEntryQnt(String entryQnt) 入力単位での数量を設定します。
void | setEntryUom(String entryUom) 入力単位を設定します。
void | setEntryUomIso(String entryUomIso) 単位の ISO コードを設定します。
void | setExpirydate(String expirydate) 有効期間期限日を設定します。
void | setFuncArea(String funcArea) 機能領域を設定します。
void | setFuncAreaLong(String funcAreaLong) 機能領域を設定します。
void | setFund(String fund) 会計区分を設定します。
void | setFundsCtr(String fundsCtr) 予算センタを設定します。
void | setGlAccount(String glAccount) G/L 勘定コードを設定します。
void | setGrantNbr(String grantNbr) 補助金を設定します。
void | setGrNumber(String grNumber) 入庫番号を設定します。
void | setGrRcpt(String grRcpt) 受領者を設定します。
void | setGrRcptx(String grRcptx) 関連ユーザデータ項目の更新情報を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setIndProposeQuanx(String indProposeQuanx) 提案数量 (初期数量)を設定します。
void | setItemText(String itemText) 明細テキストを設定します。
void | setLineDepth(String lineDepth) 伝票での明細行階層レベルを設定します。
void | setLineId(String lineId) 伝票明細行の一意 IDを設定します。
void | setMatdocTrCancel(String matdocTrCancel) 取消予定の転送要求の入出庫伝票番号を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setMatitemTrCancel(String matitemTrCancel) 取消予定の転送数量入出庫伝票明細を設定します。
void | setMatyearTrCancel(String matyearTrCancel) 取消予定の転送要求入出庫伝票年度を設定します。
void | setMoveBatch(String moveBatch) 入庫/出庫ロットを設定します。
void | setMoveMat(String moveMat) 入庫/出庫品目を設定します。
void | setMoveMatExternal(String moveMatExternal) 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を設定します。
void | setMoveMatGuid(String moveMatGuid) 項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を設定します。
void | setMoveMatVersion(String moveMatVersion) 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を設定します。
void | setMovePlant(String movePlant) 入庫/出庫プラントを設定します。
void | setMoveReas(String moveReas) 移動理由を設定します。
void | setMoveStloc(String moveStloc) 入庫/出庫保管場所を設定します。
void | setMoveType(String moveType) 移動タイプ (在庫管理)を設定します。
void | setMoveValType(String moveValType) 転送ロットの評価タイプを設定します。
void | setMvtInd(String mvtInd) 移動区分を設定します。
void | setNbSlips(String nbSlips) 入庫/出庫票の印刷部数を設定します。
void | setNbSlipsx(String nbSlipsx) 関連ユーザデータ項目の更新情報を設定します。
void | setNetwork(String network) 勘定割当のネットワーク番号を設定します。
void | setNoMoreGr(String noMoreGr) 納入完了 区分を設定します。
void | setNoPstChgnt(String noPstChgnt) 区分: 振替要求通知登録禁止を設定します。
void | setNoTransferReq(String noTransferReq) 区分: 転送要求未登録を設定します。
void | setOrderid(String orderid) 指図番号を設定します。
void | setOrderItno(String orderItno) 指図明細番号を設定します。
void | setOrderprUn(String orderprUn) 購買発注価格単位 (購買管理)を設定します。
void | setOrderprUnIso(String orderprUnIso) 単位の ISO コードを設定します。
void | setParCompco(String parCompco) 決済会社コードを設定します。
void | setParentId(String parentId) 1 レベル上位の行 IDを設定します。
void | setPartAcct(String partAcct) 取引先勘定コードを設定します。
void | setPlant(String plant) プラントを設定します。
void | setPoItem(String poItem) 購買伝票の明細番号を設定します。
void | setPoNumber(String poNumber) 購買発注番号を設定します。
void | setPoPrQnt(String poPrQnt) 数量 (購買発注価格単位)を設定します。
void | setProdDate(String prodDate) ロット製造日付を設定します。
void | setProfitCtr(String profitCtr) 利益センタを設定します。
void | setProfitSegmNo(String profitSegmNo) 収益性セグメント番号 (CO-PA)を設定します。
void | setQuantity(String quantity) 数量を設定します。
void | setRefDate(String refDate) 決済の参照日付を設定します。
void | setRefDoc(String refDoc) 参照伝票の伝票番号を設定します。
void | setRefDocIt(String refDocIt) 参照伝票の明細番号を設定します。
void | setRefDocYr(String refDocYr) 参照伝票の会計年度を設定します。
void | setReservNo(String reservNo) 入出庫予定/従属所要量の番号を設定します。
void | setResItem(String resItem) 入出庫予定/従属所要量の明細番号を設定します。
void | setResType(String resType) レコードタイプを設定します。
void | setRlEstKey(String rlEstKey) 不動産管理対象の内部キーを設定します。
void | setSalesOrd(String salesOrd) 受注伝票番号を設定します。
void | setSchedLine(String schedLine) 受注納入日程を設定します。
void | setSerialnoAutoNumberassignment(String serialnoAutoNumberassignment) シリアル番号の自動登録を設定します。
void | setShipping(String shipping) 出荷指示を設定します。
void | setSOrdItem(String sOrdItem) 受注明細番号を設定します。
void | setSpecMvmt(String specMvmt) 倉庫管理の特殊移動区分を設定します。
void | setSpecStock(String specStock) 特殊在庫区分を設定します。
void | setStckType(String stckType) 在庫タイプを設定します。
void | setStgeBin(String stgeBin) 棚番を設定します。
void | setStgeBinPc(String stgeBinPc) 在庫転送棚番を設定します。
void | setStgeBinSt(String stgeBinSt) 在庫転送棚番を設定します。
void | setStgeLoc(String stgeLoc) 保管場所を設定します。
void | setStgeType(String stgeType) 保管域タイプを設定します。
void | setStgeTypePc(String stgeTypePc) 在庫転送の保管域タイプを設定します。
void | setStgeTypeSt(String stgeTypeSt) 在庫転送の保管域タイプを設定します。
void | setStUnQtyy1(String stUnQtyy1) 代替数量単位での在庫受入予定保管単位別数量を設定します。
void | setStUnQtyy1Iso(String stUnQtyy1Iso) 単位の ISO コードを設定します。
void | setStUnQtyy2(String stUnQtyy2) 代替数量単位での在庫受入予定保管単位別数量を設定します。
void | setStUnQtyy2Iso(String stUnQtyy2Iso) 単位の ISO コードを設定します。
void | setSubNumber(String subNumber) 資産補助番号を設定します。
void | setSuPlStck1(String suPlStck1) 在庫受入予定の保管単位数を設定します。
void | setSuPlStck2(String suPlStck2) 在庫受入予定の保管単位数を設定します。
void | setSupplVend(String supplVend) 供給仕入先を設定します。
void | setTrPartBa(String trPartBa) 取引会社事業領域を設定します。
void | setUnittype1(String unittype1) 保管単位タイプを設定します。
void | setUnittype2(String unittype2) 保管単位タイプを設定します。
void | setUnloadPt(String unloadPt) 荷渡ポイントを設定します。
void | setUnloadPtx(String unloadPtx) 関連ユーザデータ項目の更新情報を設定します。
void | setValSalesOrd(String valSalesOrd) 評価受注在庫の受注番号を設定します。
void | setValSOrdItem(String valSOrdItem) 評価受注在庫の受注明細を設定します。
void | setValType(String valType) 評価タイプを設定します。
void | setValWbsElem(String valWbsElem) WBS 要素を設定します。
void | setVendor(String vendor) 仕入先勘定コードを設定します。
void | setVendrbatch(String vendrbatch) 仕入先ロット番号を設定します。
void | setWbsElem(String wbsElem) WBS 要素を設定します。
void | setWithdrawn(String withdrawn) 入出庫予定に対する出庫完了を設定します。
void | setXstob(String xstob) 取消移動タイプ区分の使用を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtItem

public GoodsMvtItem()
入出庫伝票明細情報を作成します。

GoodsMvtItem

public GoodsMvtItem(int index)
入出庫伝票明細情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getStgeLoc

public String getStgeLoc()
保管場所を取得します。

戻り値:
stgeLoc 保管場所

getBatch

public String getBatch()
ロット番号を取得します。

戻り値:
batch ロット番号

getMoveType

public String getMoveType()
移動タイプ (在庫管理)を取得します。

戻り値:
moveType 移動タイプ (在庫管理)

getStckType

public String getStckType()
在庫タイプを取得します。

戻り値:
stckType 在庫タイプ

getSpecStock

public String getSpecStock()
特殊在庫区分を取得します。

戻り値:
specStock 特殊在庫区分

getVendor

public String getVendor()
仕入先勘定コードを取得します。

戻り値:
vendor 仕入先勘定コード

getCustomer

public String getCustomer()
得意先コードを取得します。

戻り値:
customer 得意先コード

getSalesOrd

public String getSalesOrd()
受注伝票番号を取得します。

戻り値:
salesOrd 受注伝票番号

getSOrdItem

public String getSOrdItem()
受注明細番号を取得します。

戻り値:
sOrdItem 受注明細番号

getSchedLine

public String getSchedLine()
受注納入日程を取得します。

戻り値:
schedLine 受注納入日程

getValType

public String getValType()
評価タイプを取得します。

戻り値:
valType 評価タイプ

getEntryQnt

public String getEntryQnt()
入力単位での数量を取得します。

戻り値:
entryQnt 入力単位での数量

getEntryUom

public String getEntryUom()
入力単位を取得します。

戻り値:
entryUom 入力単位

getEntryUomIso

public String getEntryUomIso()
単位の ISO コードを取得します。

戻り値:
entryUomIso 単位の ISO コード

getPoPrQnt

public String getPoPrQnt()
数量 (購買発注価格単位)を取得します。

戻り値:
poPrQnt 数量 (購買発注価格単位)

getOrderprUn

public String getOrderprUn()
購買発注価格単位 (購買管理)を取得します。

戻り値:
orderprUn 購買発注価格単位 (購買管理)

getOrderprUnIso

public String getOrderprUnIso()
単位の ISO コードを取得します。

戻り値:
orderprUnIso 単位の ISO コード

getPoNumber

public String getPoNumber()
購買発注番号を取得します。

戻り値:
poNumber 購買発注番号

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
poItem 購買伝票の明細番号

getShipping

public String getShipping()
出荷指示を取得します。

戻り値:
shipping 出荷指示

getCompShip

public String getCompShip()
出荷指示順守を取得します。

戻り値:
compShip 出荷指示順守

getNoMoreGr

public String getNoMoreGr()
納入完了 区分を取得します。

戻り値:
noMoreGr 納入完了 区分

getItemText

public String getItemText()
明細テキストを取得します。

戻り値:
itemText 明細テキスト

getGrRcpt

public String getGrRcpt()
受領者を取得します。

戻り値:
grRcpt 受領者

getUnloadPt

public String getUnloadPt()
荷渡ポイントを取得します。

戻り値:
unloadPt 荷渡ポイント

getCostcenter

public String getCostcenter()
原価センタを取得します。

戻り値:
costcenter 原価センタ

getOrderid

public String getOrderid()
指図番号を取得します。

戻り値:
orderid 指図番号

getOrderItno

public String getOrderItno()
指図明細番号を取得します。

戻り値:
orderItno 指図明細番号

getCalcMotive

public String getCalcMotive()
計算区分を取得します。

戻り値:
calcMotive 計算区分

getAssetNo

public String getAssetNo()
資産番号を取得します。

戻り値:
assetNo 資産番号

getSubNumber

public String getSubNumber()
資産補助番号を取得します。

戻り値:
subNumber 資産補助番号

getReservNo

public String getReservNo()
入出庫予定/従属所要量の番号を取得します。

戻り値:
reservNo 入出庫予定/従属所要量の番号

getResItem

public String getResItem()
入出庫予定/従属所要量の明細番号を取得します。

戻り値:
resItem 入出庫予定/従属所要量の明細番号

getResType

public String getResType()
レコードタイプを取得します。

戻り値:
resType レコードタイプ

getWithdrawn

public String getWithdrawn()
入出庫予定に対する出庫完了を取得します。

戻り値:
withdrawn 入出庫予定に対する出庫完了

getMoveMat

public String getMoveMat()
入庫/出庫品目を取得します。

戻り値:
moveMat 入庫/出庫品目

getMovePlant

public String getMovePlant()
入庫/出庫プラントを取得します。

戻り値:
movePlant 入庫/出庫プラント

getMoveStloc

public String getMoveStloc()
入庫/出庫保管場所を取得します。

戻り値:
moveStloc 入庫/出庫保管場所

getMoveBatch

public String getMoveBatch()
入庫/出庫ロットを取得します。

戻り値:
moveBatch 入庫/出庫ロット

getMoveValType

public String getMoveValType()
転送ロットの評価タイプを取得します。

戻り値:
moveValType 転送ロットの評価タイプ

getMvtInd

public String getMvtInd()
移動区分を取得します。

戻り値:
mvtInd 移動区分

getMoveReas

public String getMoveReas()
移動理由を取得します。

戻り値:
moveReas 移動理由

getRlEstKey

public String getRlEstKey()
不動産管理対象の内部キーを取得します。

戻り値:
rlEstKey 不動産管理対象の内部キー

getRefDate

public String getRefDate()
決済の参照日付を取得します。

戻り値:
refDate 決済の参照日付

getCostObj

public String getCostObj()
原価対象を取得します。

戻り値:
costObj 原価対象

getProfitSegmNo

public String getProfitSegmNo()
収益性セグメント番号 (CO-PA)を取得します。

戻り値:
profitSegmNo 収益性セグメント番号 (CO-PA)

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
profitCtr 利益センタ

getWbsElem

public String getWbsElem()
WBS 要素を取得します。

戻り値:
wbsElem WBS 要素

getNetwork

public String getNetwork()
勘定割当のネットワーク番号を取得します。

戻り値:
network 勘定割当のネットワーク番号

getActivity

public String getActivity()
作業番号を取得します。

戻り値:
activity 作業番号

getPartAcct

public String getPartAcct()
取引先勘定コードを取得します。

戻り値:
partAcct 取引先勘定コード

getAmountLc

public String getAmountLc()
マニュアル入力による転記金額 (国内通貨)を取得します。

戻り値:
amountLc マニュアル入力による転記金額 (国内通貨)

getAmountSv

public String getAmountSv()
外部入力による販売金額 (国内通貨)を取得します。

戻り値:
amountSv 外部入力による販売金額 (国内通貨)

getRefDocYr

public String getRefDocYr()
参照伝票の会計年度を取得します。

戻り値:
refDocYr 参照伝票の会計年度

getRefDoc

public String getRefDoc()
参照伝票の伝票番号を取得します。

戻り値:
refDoc 参照伝票の伝票番号

getRefDocIt

public String getRefDocIt()
参照伝票の明細番号を取得します。

戻り値:
refDocIt 参照伝票の明細番号

getExpirydate

public String getExpirydate()
有効期間期限日を取得します。

戻り値:
expirydate 有効期間期限日

getProdDate

public String getProdDate()
ロット製造日付を取得します。

戻り値:
prodDate ロット製造日付

getFund

public String getFund()
会計区分を取得します。

戻り値:
fund 会計区分

getFundsCtr

public String getFundsCtr()
予算センタを取得します。

戻り値:
fundsCtr 予算センタ

getCmmtItem

public String getCmmtItem()
資金予算コードを取得します。

戻り値:
cmmtItem 資金予算コード

getValSalesOrd

public String getValSalesOrd()
評価受注在庫の受注番号を取得します。

戻り値:
valSalesOrd 評価受注在庫の受注番号

getValSOrdItem

public String getValSOrdItem()
評価受注在庫の受注明細を取得します。

戻り値:
valSOrdItem 評価受注在庫の受注明細

getValWbsElem

public String getValWbsElem()
WBS 要素を取得します。

戻り値:
valWbsElem WBS 要素

getGlAccount

public String getGlAccount()
G/L 勘定コードを取得します。

戻り値:
glAccount G/L 勘定コード

getIndProposeQuanx

public String getIndProposeQuanx()
提案数量 (初期数量)を取得します。

戻り値:
indProposeQuanx 提案数量 (初期数量)

getXstob

public String getXstob()
取消移動タイプ区分の使用を取得します。

戻り値:
xstob 取消移動タイプ区分の使用

getEanUpc

public String getEanUpc()
国際商品コード (EAN/UPC)を取得します。

戻り値:
eanUpc 国際商品コード (EAN/UPC)

getDelivNumbToSearch

public String getDelivNumbToSearch()
出荷伝票を取得します。

戻り値:
delivNumbToSearch 出荷伝票

getDelivItemToSearch

public String getDelivItemToSearch()
出荷明細を取得します。

戻り値:
delivItemToSearch 出荷明細

getSerialnoAutoNumberassignment

public String getSerialnoAutoNumberassignment()
シリアル番号の自動登録を取得します。

戻り値:
serialnoAutoNumberassignment シリアル番号の自動登録

getVendrbatch

public String getVendrbatch()
仕入先ロット番号を取得します。

戻り値:
vendrbatch 仕入先ロット番号

getStgeType

public String getStgeType()
保管域タイプを取得します。

戻り値:
stgeType 保管域タイプ

getStgeBin

public String getStgeBin()
棚番を取得します。

戻り値:
stgeBin 棚番

getSuPlStck1

public String getSuPlStck1()
在庫受入予定の保管単位数を取得します。

戻り値:
suPlStck1 在庫受入予定の保管単位数

getStUnQtyy1

public String getStUnQtyy1()
代替数量単位での在庫受入予定保管単位別数量を取得します。

戻り値:
stUnQtyy1 代替数量単位での在庫受入予定保管単位別数量

getStUnQtyy1Iso

public String getStUnQtyy1Iso()
単位の ISO コードを取得します。

戻り値:
stUnQtyy1Iso 単位の ISO コード

getUnittype1

public String getUnittype1()
保管単位タイプを取得します。

戻り値:
unittype1 保管単位タイプ

getSuPlStck2

public String getSuPlStck2()
在庫受入予定の保管単位数を取得します。

戻り値:
suPlStck2 在庫受入予定の保管単位数

getStUnQtyy2

public String getStUnQtyy2()
代替数量単位での在庫受入予定保管単位別数量を取得します。

戻り値:
stUnQtyy2 代替数量単位での在庫受入予定保管単位別数量

getStUnQtyy2Iso

public String getStUnQtyy2Iso()
単位の ISO コードを取得します。

戻り値:
stUnQtyy2Iso 単位の ISO コード

getUnittype2

public String getUnittype2()
保管単位タイプを取得します。

戻り値:
unittype2 保管単位タイプ

getStgeTypePc

public String getStgeTypePc()
在庫転送の保管域タイプを取得します。

戻り値:
stgeTypePc 在庫転送の保管域タイプ

getStgeBinPc

public String getStgeBinPc()
在庫転送棚番を取得します。

戻り値:
stgeBinPc 在庫転送棚番

getNoPstChgnt

public String getNoPstChgnt()
区分: 振替要求通知登録禁止を取得します。

戻り値:
noPstChgnt 区分: 振替要求通知登録禁止

getGrNumber

public String getGrNumber()
入庫番号を取得します。

戻り値:
grNumber 入庫番号

getStgeTypeSt

public String getStgeTypeSt()
在庫転送の保管域タイプを取得します。

戻り値:
stgeTypeSt 在庫転送の保管域タイプ

getStgeBinSt

public String getStgeBinSt()
在庫転送棚番を取得します。

戻り値:
stgeBinSt 在庫転送棚番

getMatdocTrCancel

public String getMatdocTrCancel()
取消予定の転送要求の入出庫伝票番号を取得します。

戻り値:
matdocTrCancel 取消予定の転送要求の入出庫伝票番号

getMatitemTrCancel

public String getMatitemTrCancel()
取消予定の転送数量入出庫伝票明細を取得します。

戻り値:
matitemTrCancel 取消予定の転送数量入出庫伝票明細

getMatyearTrCancel

public String getMatyearTrCancel()
取消予定の転送要求入出庫伝票年度を取得します。

戻り値:
matyearTrCancel 取消予定の転送要求入出庫伝票年度

getNoTransferReq

public String getNoTransferReq()
区分: 転送要求未登録を取得します。

戻り値:
noTransferReq 区分: 転送要求未登録

getCoBusproc

public String getCoBusproc()
業務プロセスを取得します。

戻り値:
coBusproc 業務プロセス

getActtype

public String getActtype()
活動タイプを取得します。

戻り値:
acttype 活動タイプ

getSupplVend

public String getSupplVend()
供給仕入先を取得します。

戻り値:
supplVend 供給仕入先

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getMoveMatExternal

public String getMoveMatExternal()
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
moveMatExternal 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)

getMoveMatGuid

public String getMoveMatGuid()
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
moveMatGuid 項目 MOVE_MAT の外部 GUID (今後のリリースで開発)

getMoveMatVersion

public String getMoveMatVersion()
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
moveMatVersion 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)

getFuncArea

public String getFuncArea()
機能領域を取得します。

戻り値:
funcArea 機能領域

getTrPartBa

public String getTrPartBa()
取引会社事業領域を取得します。

戻り値:
trPartBa 取引会社事業領域

getParCompco

public String getParCompco()
決済会社コードを取得します。

戻り値:
parCompco 決済会社コード

getDelivNumb

public String getDelivNumb()
出荷伝票を取得します。

戻り値:
delivNumb 出荷伝票

getDelivItem

public String getDelivItem()
出荷明細を取得します。

戻り値:
delivItem 出荷明細

getNbSlips

public String getNbSlips()
入庫/出庫票の印刷部数を取得します。

戻り値:
nbSlips 入庫/出庫票の印刷部数

getNbSlipsx

public String getNbSlipsx()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
nbSlipsx 関連ユーザデータ項目の更新情報

getGrRcptx

public String getGrRcptx()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
grRcptx 関連ユーザデータ項目の更新情報

getUnloadPtx

public String getUnloadPtx()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
unloadPtx 関連ユーザデータ項目の更新情報

getSpecMvmt

public String getSpecMvmt()
倉庫管理の特殊移動区分を取得します。

戻り値:
specMvmt 倉庫管理の特殊移動区分

getGrantNbr

public String getGrantNbr()
補助金を取得します。

戻り値:
grantNbr 補助金

getCmmtItemLong

public String getCmmtItemLong()
資金予算コードを取得します。

戻り値:
cmmtItemLong 資金予算コード

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
funcAreaLong 機能領域

getLineId

public String getLineId()
伝票明細行の一意 IDを取得します。

戻り値:
lineId 伝票明細行の一意 ID

getParentId

public String getParentId()
1 レベル上位の行 IDを取得します。

戻り値:
parentId 1 レベル上位の行 ID

getLineDepth

public String getLineDepth()
伝票での明細行階層レベルを取得します。

戻り値:
lineDepth 伝票での明細行階層レベル

getQuantity

public String getQuantity()
数量を取得します。

戻り値:
quantity 数量

getBaseUom

public String getBaseUom()
基本数量単位を取得します。

戻り値:
baseUom 基本数量単位

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setStgeLoc

public void setStgeLoc(String stgeLoc)
保管場所を設定します。

パラメータ:
stgeLoc - 保管場所

setBatch

public void setBatch(String batch)
ロット番号を設定します。

パラメータ:
batch - ロット番号

setMoveType

public void setMoveType(String moveType)
移動タイプ (在庫管理)を設定します。

パラメータ:
moveType - 移動タイプ (在庫管理)

setStckType

public void setStckType(String stckType)
在庫タイプを設定します。

パラメータ:
stckType - 在庫タイプ

setSpecStock

public void setSpecStock(String specStock)
特殊在庫区分を設定します。

パラメータ:
specStock - 特殊在庫区分

setVendor

public void setVendor(String vendor)
仕入先勘定コードを設定します。

パラメータ:
vendor - 仕入先勘定コード

setCustomer

public void setCustomer(String customer)
得意先コードを設定します。

パラメータ:
customer - 得意先コード

setSalesOrd

public void setSalesOrd(String salesOrd)
受注伝票番号を設定します。

パラメータ:
salesOrd - 受注伝票番号

setSOrdItem

public void setSOrdItem(String sOrdItem)
受注明細番号を設定します。

パラメータ:
sOrdItem - 受注明細番号

setSchedLine

public void setSchedLine(String schedLine)
受注納入日程を設定します。

パラメータ:
schedLine - 受注納入日程

setValType

public void setValType(String valType)
評価タイプを設定します。

パラメータ:
valType - 評価タイプ

setEntryQnt

public void setEntryQnt(String entryQnt)
入力単位での数量を設定します。

パラメータ:
entryQnt - 入力単位での数量

setEntryUom

public void setEntryUom(String entryUom)
入力単位を設定します。

パラメータ:
entryUom - 入力単位

setEntryUomIso

public void setEntryUomIso(String entryUomIso)
単位の ISO コードを設定します。

パラメータ:
entryUomIso - 単位の ISO コード

setPoPrQnt

public void setPoPrQnt(String poPrQnt)
数量 (購買発注価格単位)を設定します。

パラメータ:
poPrQnt - 数量 (購買発注価格単位)

setOrderprUn

public void setOrderprUn(String orderprUn)
購買発注価格単位 (購買管理)を設定します。

パラメータ:
orderprUn - 購買発注価格単位 (購買管理)

setOrderprUnIso

public void setOrderprUnIso(String orderprUnIso)
単位の ISO コードを設定します。

パラメータ:
orderprUnIso - 単位の ISO コード

setPoNumber

public void setPoNumber(String poNumber)
購買発注番号を設定します。

パラメータ:
poNumber - 購買発注番号

setPoItem

public void setPoItem(String poItem)
購買伝票の明細番号を設定します。

パラメータ:
poItem - 購買伝票の明細番号

setShipping

public void setShipping(String shipping)
出荷指示を設定します。

パラメータ:
shipping - 出荷指示

setCompShip

public void setCompShip(String compShip)
出荷指示順守を設定します。

パラメータ:
compShip - 出荷指示順守

setNoMoreGr

public void setNoMoreGr(String noMoreGr)
納入完了 区分を設定します。

パラメータ:
noMoreGr - 納入完了 区分

setItemText

public void setItemText(String itemText)
明細テキストを設定します。

パラメータ:
itemText - 明細テキスト

setGrRcpt

public void setGrRcpt(String grRcpt)
受領者を設定します。

パラメータ:
grRcpt - 受領者

setUnloadPt

public void setUnloadPt(String unloadPt)
荷渡ポイントを設定します。

パラメータ:
unloadPt - 荷渡ポイント

setCostcenter

public void setCostcenter(String costcenter)
原価センタを設定します。

パラメータ:
costcenter - 原価センタ

setOrderid

public void setOrderid(String orderid)
指図番号を設定します。

パラメータ:
orderid - 指図番号

setOrderItno

public void setOrderItno(String orderItno)
指図明細番号を設定します。

パラメータ:
orderItno - 指図明細番号

setCalcMotive

public void setCalcMotive(String calcMotive)
計算区分を設定します。

パラメータ:
calcMotive - 計算区分

setAssetNo

public void setAssetNo(String assetNo)
資産番号を設定します。

パラメータ:
assetNo - 資産番号

setSubNumber

public void setSubNumber(String subNumber)
資産補助番号を設定します。

パラメータ:
subNumber - 資産補助番号

setReservNo

public void setReservNo(String reservNo)
入出庫予定/従属所要量の番号を設定します。

パラメータ:
reservNo - 入出庫予定/従属所要量の番号

setResItem

public void setResItem(String resItem)
入出庫予定/従属所要量の明細番号を設定します。

パラメータ:
resItem - 入出庫予定/従属所要量の明細番号

setResType

public void setResType(String resType)
レコードタイプを設定します。

パラメータ:
resType - レコードタイプ

setWithdrawn

public void setWithdrawn(String withdrawn)
入出庫予定に対する出庫完了を設定します。

パラメータ:
withdrawn - 入出庫予定に対する出庫完了

setMoveMat

public void setMoveMat(String moveMat)
入庫/出庫品目を設定します。

パラメータ:
moveMat - 入庫/出庫品目

setMovePlant

public void setMovePlant(String movePlant)
入庫/出庫プラントを設定します。

パラメータ:
movePlant - 入庫/出庫プラント

setMoveStloc

public void setMoveStloc(String moveStloc)
入庫/出庫保管場所を設定します。

パラメータ:
moveStloc - 入庫/出庫保管場所

setMoveBatch

public void setMoveBatch(String moveBatch)
入庫/出庫ロットを設定します。

パラメータ:
moveBatch - 入庫/出庫ロット

setMoveValType

public void setMoveValType(String moveValType)
転送ロットの評価タイプを設定します。

パラメータ:
moveValType - 転送ロットの評価タイプ

setMvtInd

public void setMvtInd(String mvtInd)
移動区分を設定します。

パラメータ:
mvtInd - 移動区分

setMoveReas

public void setMoveReas(String moveReas)
移動理由を設定します。

パラメータ:
moveReas - 移動理由

setRlEstKey

public void setRlEstKey(String rlEstKey)
不動産管理対象の内部キーを設定します。

パラメータ:
rlEstKey - 不動産管理対象の内部キー

setRefDate

public void setRefDate(String refDate)
決済の参照日付を設定します。

パラメータ:
refDate - 決済の参照日付

setCostObj

public void setCostObj(String costObj)
原価対象を設定します。

パラメータ:
costObj - 原価対象

setProfitSegmNo

public void setProfitSegmNo(String profitSegmNo)
収益性セグメント番号 (CO-PA)を設定します。

パラメータ:
profitSegmNo - 収益性セグメント番号 (CO-PA)

setProfitCtr

public void setProfitCtr(String profitCtr)
利益センタを設定します。

パラメータ:
profitCtr - 利益センタ

setWbsElem

public void setWbsElem(String wbsElem)
WBS 要素を設定します。

パラメータ:
wbsElem - WBS 要素

setNetwork

public void setNetwork(String network)
勘定割当のネットワーク番号を設定します。

パラメータ:
network - 勘定割当のネットワーク番号

setActivity

public void setActivity(String activity)
作業番号を設定します。

パラメータ:
activity - 作業番号

setPartAcct

public void setPartAcct(String partAcct)
取引先勘定コードを設定します。

パラメータ:
partAcct - 取引先勘定コード

setAmountLc

public void setAmountLc(String amountLc)
マニュアル入力による転記金額 (国内通貨)を設定します。

パラメータ:
amountLc - マニュアル入力による転記金額 (国内通貨)

setAmountSv

public void setAmountSv(String amountSv)
外部入力による販売金額 (国内通貨)を設定します。

パラメータ:
amountSv - 外部入力による販売金額 (国内通貨)

setRefDocYr

public void setRefDocYr(String refDocYr)
参照伝票の会計年度を設定します。

パラメータ:
refDocYr - 参照伝票の会計年度

setRefDoc

public void setRefDoc(String refDoc)
参照伝票の伝票番号を設定します。

パラメータ:
refDoc - 参照伝票の伝票番号

setRefDocIt

public void setRefDocIt(String refDocIt)
参照伝票の明細番号を設定します。

パラメータ:
refDocIt - 参照伝票の明細番号

setExpirydate

public void setExpirydate(String expirydate)
有効期間期限日を設定します。

パラメータ:
expirydate - 有効期間期限日

setProdDate

public void setProdDate(String prodDate)
ロット製造日付を設定します。

パラメータ:
prodDate - ロット製造日付

setFund

public void setFund(String fund)
会計区分を設定します。

パラメータ:
fund - 会計区分

setFundsCtr

public void setFundsCtr(String fundsCtr)
予算センタを設定します。

パラメータ:
fundsCtr - 予算センタ

setCmmtItem

public void setCmmtItem(String cmmtItem)
資金予算コードを設定します。

パラメータ:
cmmtItem - 資金予算コード

setValSalesOrd

public void setValSalesOrd(String valSalesOrd)
評価受注在庫の受注番号を設定します。

パラメータ:
valSalesOrd - 評価受注在庫の受注番号

setValSOrdItem

public void setValSOrdItem(String valSOrdItem)
評価受注在庫の受注明細を設定します。

パラメータ:
valSOrdItem - 評価受注在庫の受注明細

setValWbsElem

public void setValWbsElem(String valWbsElem)
WBS 要素を設定します。

パラメータ:
valWbsElem - WBS 要素

setGlAccount

public void setGlAccount(String glAccount)
G/L 勘定コードを設定します。

パラメータ:
glAccount - G/L 勘定コード

setIndProposeQuanx

public void setIndProposeQuanx(String indProposeQuanx)
提案数量 (初期数量)を設定します。

パラメータ:
indProposeQuanx - 提案数量 (初期数量)

setXstob

public void setXstob(String xstob)
取消移動タイプ区分の使用を設定します。

パラメータ:
xstob - 取消移動タイプ区分の使用

setEanUpc

public void setEanUpc(String eanUpc)
国際商品コード (EAN/UPC)を設定します。

パラメータ:
eanUpc - 国際商品コード (EAN/UPC)

setDelivNumbToSearch

public void setDelivNumbToSearch(String delivNumbToSearch)
出荷伝票を設定します。

パラメータ:
delivNumbToSearch - 出荷伝票

setDelivItemToSearch

public void setDelivItemToSearch(String delivItemToSearch)
出荷明細を設定します。

パラメータ:
delivItemToSearch - 出荷明細

setSerialnoAutoNumberassignment

public void setSerialnoAutoNumberassignment(String serialnoAutoNumberassignment)
シリアル番号の自動登録を設定します。

パラメータ:
serialnoAutoNumberassignment - シリアル番号の自動登録

setVendrbatch

public void setVendrbatch(String vendrbatch)
仕入先ロット番号を設定します。

パラメータ:
vendrbatch - 仕入先ロット番号

setStgeType

public void setStgeType(String stgeType)
保管域タイプを設定します。

パラメータ:
stgeType - 保管域タイプ

setStgeBin

public void setStgeBin(String stgeBin)
棚番を設定します。

パラメータ:
stgeBin - 棚番

setSuPlStck1

public void setSuPlStck1(String suPlStck1)
在庫受入予定の保管単位数を設定します。

パラメータ:
suPlStck1 - 在庫受入予定の保管単位数

setStUnQtyy1

public void setStUnQtyy1(String stUnQtyy1)
代替数量単位での在庫受入予定保管単位別数量を設定します。

パラメータ:
stUnQtyy1 - 代替数量単位での在庫受入予定保管単位別数量

setStUnQtyy1Iso

public void setStUnQtyy1Iso(String stUnQtyy1Iso)
単位の ISO コードを設定します。

パラメータ:
stUnQtyy1Iso - 単位の ISO コード

setUnittype1

public void setUnittype1(String unittype1)
保管単位タイプを設定します。

パラメータ:
unittype1 - 保管単位タイプ

setSuPlStck2

public void setSuPlStck2(String suPlStck2)
在庫受入予定の保管単位数を設定します。

パラメータ:
suPlStck2 - 在庫受入予定の保管単位数

setStUnQtyy2

public void setStUnQtyy2(String stUnQtyy2)
代替数量単位での在庫受入予定保管単位別数量を設定します。

パラメータ:
stUnQtyy2 - 代替数量単位での在庫受入予定保管単位別数量

setStUnQtyy2Iso

public void setStUnQtyy2Iso(String stUnQtyy2Iso)
単位の ISO コードを設定します。

パラメータ:
stUnQtyy2Iso - 単位の ISO コード

setUnittype2

public void setUnittype2(String unittype2)
保管単位タイプを設定します。

パラメータ:
unittype2 - 保管単位タイプ

setStgeTypePc

public void setStgeTypePc(String stgeTypePc)
在庫転送の保管域タイプを設定します。

パラメータ:
stgeTypePc - 在庫転送の保管域タイプ

setStgeBinPc

public void setStgeBinPc(String stgeBinPc)
在庫転送棚番を設定します。

パラメータ:
stgeBinPc - 在庫転送棚番

setNoPstChgnt

public void setNoPstChgnt(String noPstChgnt)
区分: 振替要求通知登録禁止を設定します。

パラメータ:
noPstChgnt - 区分: 振替要求通知登録禁止

setGrNumber

public void setGrNumber(String grNumber)
入庫番号を設定します。

パラメータ:
grNumber - 入庫番号

setStgeTypeSt

public void setStgeTypeSt(String stgeTypeSt)
在庫転送の保管域タイプを設定します。

パラメータ:
stgeTypeSt - 在庫転送の保管域タイプ

setStgeBinSt

public void setStgeBinSt(String stgeBinSt)
在庫転送棚番を設定します。

パラメータ:
stgeBinSt - 在庫転送棚番

setMatdocTrCancel

public void setMatdocTrCancel(String matdocTrCancel)
取消予定の転送要求の入出庫伝票番号を設定します。

パラメータ:
matdocTrCancel - 取消予定の転送要求の入出庫伝票番号

setMatitemTrCancel

public void setMatitemTrCancel(String matitemTrCancel)
取消予定の転送数量入出庫伝票明細を設定します。

パラメータ:
matitemTrCancel - 取消予定の転送数量入出庫伝票明細

setMatyearTrCancel

public void setMatyearTrCancel(String matyearTrCancel)
取消予定の転送要求入出庫伝票年度を設定します。

パラメータ:
matyearTrCancel - 取消予定の転送要求入出庫伝票年度

setNoTransferReq

public void setNoTransferReq(String noTransferReq)
区分: 転送要求未登録を設定します。

パラメータ:
noTransferReq - 区分: 転送要求未登録

setCoBusproc

public void setCoBusproc(String coBusproc)
業務プロセスを設定します。

パラメータ:
coBusproc - 業務プロセス

setActtype

public void setActtype(String acttype)
活動タイプを設定します。

パラメータ:
acttype - 活動タイプ

setSupplVend

public void setSupplVend(String supplVend)
供給仕入先を設定します。

パラメータ:
supplVend - 供給仕入先

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setMoveMatExternal

public void setMoveMatExternal(String moveMatExternal)
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
moveMatExternal - 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)

setMoveMatGuid

public void setMoveMatGuid(String moveMatGuid)
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
moveMatGuid - 項目 MOVE_MAT の外部 GUID (今後のリリースで開発)

setMoveMatVersion

public void setMoveMatVersion(String moveMatVersion)
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
moveMatVersion - 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)

setFuncArea

public void setFuncArea(String funcArea)
機能領域を設定します。

パラメータ:
funcArea - 機能領域

setTrPartBa

public void setTrPartBa(String trPartBa)
取引会社事業領域を設定します。

パラメータ:
trPartBa - 取引会社事業領域

setParCompco

public void setParCompco(String parCompco)
決済会社コードを設定します。

パラメータ:
parCompco - 決済会社コード

setDelivNumb

public void setDelivNumb(String delivNumb)
出荷伝票を設定します。

パラメータ:
delivNumb - 出荷伝票

setDelivItem

public void setDelivItem(String delivItem)
出荷明細を設定します。

パラメータ:
delivItem - 出荷明細

setNbSlips

public void setNbSlips(String nbSlips)
入庫/出庫票の印刷部数を設定します。

パラメータ:
nbSlips - 入庫/出庫票の印刷部数

setNbSlipsx

public void setNbSlipsx(String nbSlipsx)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
nbSlipsx - 関連ユーザデータ項目の更新情報

setGrRcptx

public void setGrRcptx(String grRcptx)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
grRcptx - 関連ユーザデータ項目の更新情報

setUnloadPtx

public void setUnloadPtx(String unloadPtx)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
unloadPtx - 関連ユーザデータ項目の更新情報

setSpecMvmt

public void setSpecMvmt(String specMvmt)
倉庫管理の特殊移動区分を設定します。

パラメータ:
specMvmt - 倉庫管理の特殊移動区分

setGrantNbr

public void setGrantNbr(String grantNbr)
補助金を設定します。

パラメータ:
grantNbr - 補助金

setCmmtItemLong

public void setCmmtItemLong(String cmmtItemLong)
資金予算コードを設定します。

パラメータ:
cmmtItemLong - 資金予算コード

setFuncAreaLong

public void setFuncAreaLong(String funcAreaLong)
機能領域を設定します。

パラメータ:
funcAreaLong - 機能領域

setLineId

public void setLineId(String lineId)
伝票明細行の一意 IDを設定します。

パラメータ:
lineId - 伝票明細行の一意 ID

setParentId

public void setParentId(String parentId)
1 レベル上位の行 IDを設定します。

パラメータ:
parentId - 1 レベル上位の行 ID

setLineDepth

public void setLineDepth(String lineDepth)
伝票での明細行階層レベルを設定します。

パラメータ:
lineDepth - 伝票での明細行階層レベル

setQuantity

public void setQuantity(String quantity)
数量を設定します。

パラメータ:
quantity - 数量

setBaseUom

public void setBaseUom(String baseUom)
基本数量単位を設定します。

パラメータ:
baseUom - 基本数量単位

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtSerialNumber (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス GoodsMvtSerialNumber

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber
すべての実装インタフェース:
Serializable
public class GoodsMvtSerialNumber
extends Object
implements Serializable

シリアル番号情報クラス
機能は以下の通り

  • シリアル番号情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GoodsMvtSerialNumber()
シリアル番号情報を作成します。
GoodsMvtSerialNumber(int index)
シリアル番号情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
String | getMatdocItm() 入出庫伝票の明細を取得します。
String | getSerialno() シリアル番号を取得します。
void | setIndex(int index) レコード番号を設定します｡
void | setMatdocItm(String matdocItm) 入出庫伝票の明細を設定します。
void | setSerialno(String serialno) シリアル番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtSerialNumber

public GoodsMvtSerialNumber()
シリアル番号情報を作成します。

GoodsMvtSerialNumber

public GoodsMvtSerialNumber(int index)
シリアル番号情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getMatdocItm

public String getMatdocItm()
入出庫伝票の明細を取得します。

戻り値:
matdocItm 入出庫伝票の明細

getSerialno

public String getSerialno()
シリアル番号を取得します。

戻り値:
serialno シリアル番号

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setMatdocItm

public void setMatdocItm(String matdocItm)
入出庫伝票の明細を設定します。

パラメータ:
matdocItm - 入出庫伝票の明細

setSerialno

public void setSerialno(String serialno)
シリアル番号を設定します。

パラメータ:
serialno - シリアル番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス
GoodsMvtCode
GoodsMvtCreate
GoodsMvtHeadret
GoodsMvtItem
GoodsMvtSerialNumber
ParamGoodsMvtCode
ParamGoodsMvtHeadret
ParamGoodsMvtItem
ParamGoodsMvtSerialNumber


jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate

クラスの概要
GoodsMvtCode | 在庫移動に対するコードのトランザクションへの割当情報クラス 機能は以下の通り 在庫移動に対するコードのトランザクションへの割当情報を保持します。
GoodsMvtCreate | 入出庫伝票登録情報クラス 機能は以下の通り 入出庫伝票登録情報を保持します。
GoodsMvtHeadret | 入出庫伝票番号/入出庫伝票会計年度情報クラス 機能は以下の通り 入出庫伝票番号/入出庫伝票会計年度情報を保持します。
GoodsMvtItem | 入出庫伝票明細情報クラス 機能は以下の通り 入出庫伝票明細情報を保持します。
GoodsMvtSerialNumber | シリアル番号情報クラス 機能は以下の通り シリアル番号情報を保持します。
ParamGoodsMvtCode | 在庫移動に対するコードのトランザクションへの割当パラメータ設定クラス 機能は以下の通り 在庫移動に対するコードのトランザクションへの割当のパラメータを設定します。
ParamGoodsMvtHeadret | 入出庫伝票ヘッダデータパラメータ設定クラス 機能は以下の通り 入出庫伝票ヘッダデータのパラメータを設定します。
ParamGoodsMvtItem | リターン構造、入出庫伝票明細パラメータ設定クラス 機能は以下の通り リターン構造、入出庫伝票明細のパラメータを設定します。
ParamGoodsMvtSerialNumber | シリアル番号パラメータ設定クラス 機能は以下の通り シリアル番号のパラメータを設定します。


jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のクラス
GoodsMvtCreate
入出庫伝票登録情報クラス
機能は以下の通り
入出庫伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate により使用される jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のクラス
GoodsMvtCode
在庫移動に対するコードのトランザクションへの割当情報クラス
機能は以下の通り
在庫移動に対するコードのトランザクションへの割当情報を保持します。
GoodsMvtHeadret
入出庫伝票番号/入出庫伝票会計年度情報クラス
機能は以下の通り
入出庫伝票番号/入出庫伝票会計年度情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamGoodsMvtCode (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス ParamGoodsMvtCode

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode
すべての実装インタフェース:
Serializable
public final class ParamGoodsMvtCode
extends Object
implements Serializable

在庫移動に対するコードのトランザクションへの割当パラメータ設定クラス
機能は以下の通り

  • 在庫移動に対するコードのトランザクションへの割当のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, GoodsMvtCode goodsMvtCode)
在庫移動に対するコードのトランザクションへの割当の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  GoodsMvtCode goodsMvtCode)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
在庫移動に対するコードのトランザクションへの割当の値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtCode - GoodsMvtCode
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamGoodsMvtHeadret (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス ParamGoodsMvtHeadret

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret
すべての実装インタフェース:
Serializable
public final class ParamGoodsMvtHeadret
extends Object
implements Serializable

入出庫伝票ヘッダデータパラメータ設定クラス
機能は以下の通り

    入出庫伝票ヘッダデータのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setExportParam(BapiController bapiController, GoodsMvtHeadret goodsMvtHeadret)
入出庫伝票ヘッダデータの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setExportParam

public static void setExportParam(BapiController bapiController,
                                  GoodsMvtHeadret goodsMvtHeadret)
                           throws SAPGeneralSystemException
入出庫伝票ヘッダデータの値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtHeadret - GoodsMvtHeadret
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamGoodsMvtItem (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス ParamGoodsMvtItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem
すべての実装インタフェース:
Serializable
public final class ParamGoodsMvtItem
extends Object
implements Serializable

リターン構造、入出庫伝票明細パラメータ設定クラス
機能は以下の通り

  • リターン構造、入出庫伝票明細のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List goodsMvtItemList) table(Export)情報から返却されたリターン構造、入出庫伝票明細の値をセットします。
static void | setImportParam(BapiController bapiController, List goodsMvtItemList) リターン構造、入出庫伝票明細の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List goodsMvtItemList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
リターン構造、入出庫伝票明細の値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtItemList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List goodsMvtItemList)
                           throws SAPGeneralSystemException
table(Export)情報から返却されたリターン構造、入出庫伝票明細の値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtItemList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamGoodsMvtSerialNumber (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス ParamGoodsMvtSerialNumber

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber
すべての実装インタフェース:
Serializable
public final class ParamGoodsMvtSerialNumber
extends Object
implements Serializable

シリアル番号パラメータ設定クラス
機能は以下の通り

  • シリアル番号のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List goodsMvtSerialNumberList) table(Export)情報からシリアル番号の値をセットします。
static void | setImportParam(BapiController bapiController, List goodsMvtSerialNumberList) シリアル番号の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List goodsMvtSerialNumberList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
シリアル番号の値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtSerialNumberList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List goodsMvtSerialNumberList)
                           throws SAPGeneralSystemException
table(Export)情報からシリアル番号の値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtSerialNumberList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems の使用

GoodsMvtGetItems を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での GoodsMvtGetItems の使用

jp.co.intra_mart.foundation.sap.module.purchase での GoodsMvtGetItems のサブクラス
 class GoodsMvtGetItemsController
入出庫伝票一覧取得コントローラクラス
機能は以下の通り
入出庫伝票の一覧を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BatchRa (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス BatchRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa
すべての実装インタフェース:
Serializable
public class BatchRa
extends Object
implements Serializable

ロットの範囲情報クラス
機能は以下の通り

  • ロットの範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
BatchRa()
ロットの範囲情報を作成します。
BatchRa(int index)
ロットの範囲情報を作成します。
メソッドの概要
String | getHigh() ロット番号を取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() ロット番号を取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) ロット番号を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) ロット番号を設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BatchRa

public BatchRa()
ロットの範囲情報を作成します。

BatchRa

public BatchRa(int index)
ロットの範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
ロット番号を取得します。

戻り値:
low ロット番号

getHigh

public String getHigh()
ロット番号を取得します。

戻り値:
high ロット番号

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
ロット番号を設定します。

パラメータ:
low - ロット番号

setHigh

public void setHigh(String high)
ロット番号を設定します。

パラメータ:
high - ロット番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtGetItems (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス GoodsMvtGetItems

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
GoodsMvtGetItemsController
public class GoodsMvtGetItems
extends ReferenceController
implements Serializable

出庫確認一覧照会情報クラス
機能は以下の通り

  • 出庫確認一覧照会情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
GoodsMvtGetItems(SapClient sapClient)
出庫確認一覧照会情報を作成します。
メソッドの概要
List | getBatchRaList() ロットの範囲を取得します。
List | getGoodsMvtHeaderList() リターン構造、入出庫伝票ヘッダを取得します。
List | getGoodsMvtItemsList() リターン構造、入出庫伝票明細を取得します。
List | getMaterialRaList() 品目コードの範囲を取得します。
List | getMoveTypeRaList() 移動タイプの範囲を取得します。
List | getPlantRaList() プラントの範囲を取得します。
List | getPstngDateRaList() 登録日付の範囲を取得します。
List | getSpecStockRaList() 特殊在庫区分の範囲を取得します。
List | getStgeLocRaList() 保管場所の範囲を取得します。
List | getTrEvTypeRaList() トランザクション/イベントタイプの範囲を取得します。
List | getUserNameRaList() ユーザ名の範囲を取得します。
List | getVendorRaList() 仕入先の範囲を取得します。
void | setBatchRaList(List batchRaList) ロットの範囲を設定します。
void | setExportParam(BapiController bapiController) 返却された入出庫伝票照会情報をセットします。
void | setGoodsMvtHeaderList(List goodsMvtHeaderList) リターン構造、入出庫伝票ヘッダを設定します。
void | setGoodsMvtItemsList(List goodsMvtItemsList) リターン構造、入出庫伝票明細を設定します。
void | setImportParam(BapiController bapiController) 入出庫伝票一覧照会する情報をセットします。
void | setMaterialRaList(List materialRaList) 品目コードの範囲を設定します。
void | setMoveTypeRaList(List moveTypeRaList) 移動タイプの範囲を設定します。
void | setPlantRaList(List plantRaList) プラントの範囲を設定します。
void | setPstngDateRaList(List pstngDateRaList) 登録日付の範囲を設定します。
void | setSpecStockRaList(List specStockRaList) 特殊在庫区分の範囲を設定します。
void | setStgeLocRaList(List stgeLocRaList) 保管場所の範囲を設定します。
void | setTrEvTypeRaList(List trEvTypeRaList) トランザクション/イベントタイプの範囲を設定します。
void | setUserNameRaList(List userNameRaList) ユーザ名の範囲を設定します。
void | setVendorRaList(List vendorRaList) 仕入先の範囲を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtGetItems

public GoodsMvtGetItems(SapClient sapClient)
出庫確認一覧照会情報を作成します。

パラメータ:
sapClient - SAPクライアント
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
入出庫伝票一覧照会する情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
返却された入出庫伝票照会情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getVendorRaList

public List getVendorRaList()
仕入先の範囲を取得します。

戻り値:
vendorRaList 仕入先の範囲

getUserNameRaList

public List getUserNameRaList()
ユーザ名の範囲を取得します。

戻り値:
userNameRaList ユーザ名の範囲

getTrEvTypeRaList

public List getTrEvTypeRaList()
トランザクション/イベントタイプの範囲を取得します。

戻り値:
trEvTypeRaList トランザクション/イベントタイプの範囲

getStgeLocRaList

public List getStgeLocRaList()
保管場所の範囲を取得します。

戻り値:
stgeLocRaList 保管場所の範囲

getSpecStockRaList

public List getSpecStockRaList()
特殊在庫区分の範囲を取得します。

戻り値:
specStockRaList 特殊在庫区分の範囲

getPstngDateRaList

public List getPstngDateRaList()
登録日付の範囲を取得します。

戻り値:
pstngDateRaList 登録日付の範囲

getPlantRaList

public List getPlantRaList()
プラントの範囲を取得します。

戻り値:
plantRaList プラントの範囲

getMoveTypeRaList

public List getMoveTypeRaList()
移動タイプの範囲を取得します。

戻り値:
moveTypeRaList 移動タイプの範囲

getMaterialRaList

public List getMaterialRaList()
品目コードの範囲を取得します。

戻り値:
materialRaList 品目コードの範囲

getGoodsMvtItemsList

public List getGoodsMvtItemsList()
リターン構造、入出庫伝票明細を取得します。

戻り値:
goodsMvtItemsList リターン構造、入出庫伝票明細

getGoodsMvtHeaderList

public List getGoodsMvtHeaderList()
リターン構造、入出庫伝票ヘッダを取得します。

戻り値:
goodsMvtHeaderList リターン構造、入出庫伝票ヘッダ

getBatchRaList

public List getBatchRaList()
ロットの範囲を取得します。

戻り値:
batchRaList ロットの範囲

setVendorRaList

public void setVendorRaList(List vendorRaList)
仕入先の範囲を設定します。

パラメータ:
vendorRaList - 仕入先の範囲

setUserNameRaList

public void setUserNameRaList(List userNameRaList)
ユーザ名の範囲を設定します。

パラメータ:
userNameRaList - ユーザ名の範囲

setTrEvTypeRaList

public void setTrEvTypeRaList(List trEvTypeRaList)
トランザクション/イベントタイプの範囲を設定します。

パラメータ:
trEvTypeRaList - トランザクション/イベントタイプの範囲

setStgeLocRaList

public void setStgeLocRaList(List stgeLocRaList)
保管場所の範囲を設定します。

パラメータ:
stgeLocRaList - 保管場所の範囲

setSpecStockRaList

public void setSpecStockRaList(List specStockRaList)
特殊在庫区分の範囲を設定します。

パラメータ:
specStockRaList - 特殊在庫区分の範囲

setPstngDateRaList

public void setPstngDateRaList(List pstngDateRaList)
登録日付の範囲を設定します。

パラメータ:
pstngDateRaList - 登録日付の範囲

setPlantRaList

public void setPlantRaList(List plantRaList)
プラントの範囲を設定します。

パラメータ:
plantRaList - プラントの範囲

setMoveTypeRaList

public void setMoveTypeRaList(List moveTypeRaList)
移動タイプの範囲を設定します。

パラメータ:
moveTypeRaList - 移動タイプの範囲

setMaterialRaList

public void setMaterialRaList(List materialRaList)
品目コードの範囲を設定します。

パラメータ:
materialRaList - 品目コードの範囲

setGoodsMvtItemsList

public void setGoodsMvtItemsList(List goodsMvtItemsList)
リターン構造、入出庫伝票明細を設定します。

パラメータ:
goodsMvtItemsList - リターン構造、入出庫伝票明細

setGoodsMvtHeaderList

public void setGoodsMvtHeaderList(List goodsMvtHeaderList)
リターン構造、入出庫伝票ヘッダを設定します。

パラメータ:
goodsMvtHeaderList - リターン構造、入出庫伝票ヘッダ

setBatchRaList

public void setBatchRaList(List batchRaList)
ロットの範囲を設定します。

パラメータ:
batchRaList - ロットの範囲

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialRa (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス MaterialRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa
すべての実装インタフェース:
Serializable
public class MaterialRa
extends Object
implements Serializable

品目コードの範囲情報クラス
機能は以下の通り

  • 品目コードの範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MaterialRa()
品目コードの範囲情報を作成します。
MaterialRa(int index)
品目コードの範囲情報を作成します。
メソッドの概要
String | getHigh() 品目コードを取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() 品目コードを取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) 品目コードを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) 品目コードを設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialRa

public MaterialRa()
品目コードの範囲情報を作成します。

MaterialRa

public MaterialRa(int index)
品目コードの範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
品目コードを取得します。

戻り値:
low 品目コード

getHigh

public String getHigh()
品目コードを取得します。

戻り値:
high 品目コード

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
品目コードを設定します。

パラメータ:
low - 品目コード

setHigh

public void setHigh(String high)
品目コードを設定します。

パラメータ:
high - 品目コード

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MoveTypeRa (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス MoveTypeRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa
すべての実装インタフェース:
Serializable
public class MoveTypeRa
extends Object
implements Serializable

移動タイプの範囲情報クラス
機能は以下の通り

  • 移動タイプの範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MoveTypeRa()
移動タイプの範囲情報を作成します。
MoveTypeRa(int index)
移動タイプの範囲情報を作成します。
メソッドの概要
String | getHigh() 移動タイプ (在庫管理)を取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() 移動タイプ (在庫管理)を取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) 移動タイプ (在庫管理)を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) 移動タイプ (在庫管理)を設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MoveTypeRa

public MoveTypeRa()
移動タイプの範囲情報を作成します。

MoveTypeRa

public MoveTypeRa(int index)
移動タイプの範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
移動タイプ (在庫管理)を取得します。

戻り値:
low 移動タイプ (在庫管理)

getHigh

public String getHigh()
移動タイプ (在庫管理)を取得します。

戻り値:
high 移動タイプ (在庫管理)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
移動タイプ (在庫管理)を設定します。

パラメータ:
low - 移動タイプ (在庫管理)

setHigh

public void setHigh(String high)
移動タイプ (在庫管理)を設定します。

パラメータ:
high - 移動タイプ (在庫管理)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス
BatchRa
GoodsMvtGetItems
MaterialRa
MoveTypeRa
ParamBatchRa
ParamMaterialRa
ParamMoveTypeRa
ParamPlantRa
ParamPstngDateRa
ParamSpecStockRa
ParamStgeLocRa
ParamTrEvTypeRa
ParamUserNameRa
ParamVendorRa
PlantRa
PstngDateRa
SpecStockRa
StgeLocRa
TrEvTypeRa
UserNameRa
VendorRa


jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems

クラスの概要
BatchRa | ロットの範囲情報クラス 機能は以下の通り ロットの範囲情報を保持します。
GoodsMvtGetItems | 出庫確認一覧照会情報クラス 機能は以下の通り 出庫確認一覧照会情報を保持します。
MaterialRa | 品目コードの範囲情報クラス 機能は以下の通り 品目コードの範囲情報を保持します。
MoveTypeRa | 移動タイプの範囲情報クラス 機能は以下の通り 移動タイプの範囲情報を保持します。
ParamBatchRa | ロットの範囲パラメータ設定クラス 機能は以下の通り ロットの範囲のパラメータを設定します。
ParamMaterialRa | 品目コードの範囲パラメータ設定クラス 機能は以下の通り 品目コードの範囲のパラメータを設定します。
ParamMoveTypeRa | 移動タイプの範囲パラメータ設定クラス 機能は以下の通り 移動タイプの範囲のパラメータを設定します。
ParamPlantRa | プラントの範囲パラメータ設定クラス 機能は以下の通り プラントの範囲のパラメータを設定します。
ParamPstngDateRa | 登録日付の範囲パラメータ設定クラス 機能は以下の通り 登録日付の範囲のパラメータを設定します。
ParamSpecStockRa | 特殊在庫区分の範囲パラメータ設定クラス 機能は以下の通り 特殊在庫区分の範囲のパラメータを設定します。
ParamStgeLocRa | 保管場所の範囲パラメータ設定クラス 機能は以下の通り 保管場所の範囲のパラメータを設定します。
ParamTrEvTypeRa | トランザクション/イベントタイプの範囲パラメータ設定クラス。
ParamUserNameRa | ユーザ名の範囲パラメータ設定クラス 機能は以下の通り ユーザ名の範囲のパラメータを設定します。
ParamVendorRa | 仕入先の範囲パラメータ設定クラス 機能は以下の通り 仕入先の範囲のパラメータを設定します。
PlantRa | プラントの範囲情報クラス 機能は以下の通り プラントの範囲情報を保持します。
PstngDateRa | 登録日付の範囲情報クラス 機能は以下の通り 登録日付の範囲情報を保持します。
SpecStockRa | 特殊在庫区分の範囲情報クラス 機能は以下の通り 特殊在庫区分の範囲情報を保持します。
StgeLocRa | 保管場所の範囲情報クラス 機能は以下の通り 保管場所の範囲情報を保持します。
TrEvTypeRa | トランザクション/イベントタイプの範囲情報クラス 機能は以下の通り トランザクション/イベントタイプの範囲情報を保持します。
UserNameRa | ユーザ名の範囲情報クラス 機能は以下の通り ユーザ名の範囲情報を保持します。
VendorRa | 仕入先の範囲情報クラス 機能は以下の通り 仕入先の範囲情報を保持します。


jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems のクラス
GoodsMvtGetItems
出庫確認一覧照会情報クラス
機能は以下の通り
出庫確認一覧照会情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamBatchRa (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamBatchRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa
すべての実装インタフェース:
Serializable
public final class ParamBatchRa
extends Object
implements Serializable

ロットの範囲パラメータ設定クラス
機能は以下の通り

  • ロットの範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List batchRaList) table(Export)情報からロットの範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List batchRaList) ロットの範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List batchRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
ロットの範囲の値をセットします。

パラメータ:
bapiController - BapiController
batchRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List batchRaList)
                           throws SAPGeneralSystemException
table(Export)情報からロットの範囲の値をセットします。

パラメータ:
bapiController - BapiController
batchRaList - BatchRa
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamMaterialRa (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamMaterialRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa
すべての実装インタフェース:
Serializable
public final class ParamMaterialRa
extends Object
implements Serializable

品目コードの範囲パラメータ設定クラス
機能は以下の通り

  • 品目コードの範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List materialRaList) table(Export)情報から品目コードの範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List materialRaList) 品目コードの範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List materialRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
品目コードの範囲の値をセットします。

パラメータ:
bapiController - BapiController
materialRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List materialRaList)
                           throws SAPGeneralSystemException
table(Export)情報から品目コードの範囲の値をセットします。

パラメータ:
bapiController - BapiController
materialRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamMoveTypeRa (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamMoveTypeRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa
すべての実装インタフェース:
Serializable
public final class ParamMoveTypeRa
extends Object
implements Serializable

移動タイプの範囲パラメータ設定クラス
機能は以下の通り

  • 移動タイプの範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List moveTypeRaList) table(Export)情報から移動タイプの範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List moveTypeRaList) 移動タイプの範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List moveTypeRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
移動タイプの範囲の値をセットします。

パラメータ:
bapiController - BapiController
moveTypeRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List moveTypeRaList)
                           throws SAPGeneralSystemException
table(Export)情報から移動タイプの範囲の値をセットします。

パラメータ:
bapiController - BapiController
moveTypeRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPlantRa (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamPlantRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa
すべての実装インタフェース:
Serializable
public final class ParamPlantRa
extends Object
implements Serializable

プラントの範囲パラメータ設定クラス
機能は以下の通り

  • プラントの範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List plantRaList) table(Export)情報からプラントの範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List plantRaList) プラントの範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List plantRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
プラントの範囲の値をセットします。

パラメータ:
bapiController - BapiController
plantRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List plantRaList)
                           throws SAPGeneralSystemException
table(Export)情報からプラントの範囲の値をセットします。

パラメータ:
bapiController - BapiController
plantRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPstngDateRa (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamPstngDateRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa
すべての実装インタフェース:
Serializable
public final class ParamPstngDateRa
extends Object
implements Serializable

登録日付の範囲パラメータ設定クラス
機能は以下の通り

  • 登録日付の範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List pstngDateRaList) table(Export)情報から登録日付の範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List pstngDateRaList) 登録日付の範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List pstngDateRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
登録日付の範囲の値をセットします。

パラメータ:
bapiController - BapiController
pstngDateRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List pstngDateRaList)
                           throws SAPGeneralSystemException
table(Export)情報から登録日付の範囲の値をセットします。

パラメータ:
bapiController - BapiController
pstngDateRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamSpecStockRa (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamSpecStockRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa
すべての実装インタフェース:
Serializable
public final class ParamSpecStockRa
extends Object
implements Serializable

特殊在庫区分の範囲パラメータ設定クラス
機能は以下の通り

  • 特殊在庫区分の範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List specStockRaList) table(Export)情報から特殊在庫区分の範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List specStockRaList) 特殊在庫区分の範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List specStockRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
特殊在庫区分の範囲の値をセットします。

パラメータ:
bapiController - BapiController
specStockRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List specStockRaList)
                           throws SAPGeneralSystemException
table(Export)情報から特殊在庫区分の範囲の値をセットします。

パラメータ:
bapiController - BapiController
specStockRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamStgeLocRa (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamStgeLocRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa
すべての実装インタフェース:
Serializable
public final class ParamStgeLocRa
extends Object
implements Serializable

保管場所の範囲パラメータ設定クラス
機能は以下の通り

  • 保管場所の範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List stgeLocRaList) table(Export)情報から保管場所の範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List stgeLocRaList) 保管場所の範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List stgeLocRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
保管場所の範囲の値をセットします。

パラメータ:
bapiController - BapiController
stgeLocRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List stgeLocRaList)
                           throws SAPGeneralSystemException
table(Export)情報から保管場所の範囲の値をセットします。

パラメータ:
bapiController - BapiController
stgeLocRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamTrEvTypeRa (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamTrEvTypeRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa
すべての実装インタフェース:
Serializable
public final class ParamTrEvTypeRa
extends Object
implements Serializable

トランザクション/イベントタイプの範囲パラメータ設定クラス。
機能は以下の通り。

  • トランザクション/イベントタイプの範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List trEvTypeRaList) table(Export)情報からトランザクション/イベントタイプの範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List trEvTypeRaList) ParamTrEvTypeRaの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List trEvTypeRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
ParamTrEvTypeRaの値をセットします。

パラメータ:
bapiController - BapiController
trEvTypeRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List trEvTypeRaList)
                           throws SAPGeneralSystemException
table(Export)情報からトランザクション/イベントタイプの範囲の値をセットします。

パラメータ:
bapiController - BapiController
trEvTypeRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamUserNameRa (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamUserNameRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa
すべての実装インタフェース:
Serializable
public final class ParamUserNameRa
extends Object
implements Serializable

ユーザ名の範囲パラメータ設定クラス
機能は以下の通り

  • ユーザ名の範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List userNameRaList) table(Export)情報からユーザ名の範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List userNameRaList) ユーザ名の範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List userNameRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
ユーザ名の範囲の値をセットします。

パラメータ:
bapiController - BapiController
userNameRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List userNameRaList)
                           throws SAPGeneralSystemException
table(Export)情報からユーザ名の範囲の値をセットします。

パラメータ:
bapiController - BapiController
userNameRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamVendorRa (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamVendorRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa
すべての実装インタフェース:
Serializable
public final class ParamVendorRa
extends Object
implements Serializable

仕入先の範囲パラメータ設定クラス
機能は以下の通り

  • 仕入先の範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List vendorRaList) table(Export)情報から仕入先の範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List vendorRaList) 仕入先の範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List vendorRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
仕入先の範囲の値をセットします。

パラメータ:
bapiController - BapiController
vendorRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List vendorRaList)
                           throws SAPGeneralSystemException
table(Export)情報から仕入先の範囲の値をセットします。

パラメータ:
bapiController - BapiController
vendorRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PlantRa (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス PlantRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa
すべての実装インタフェース:
Serializable
public class PlantRa
extends Object
implements Serializable

プラントの範囲情報クラス
機能は以下の通り

  • プラントの範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PlantRa()
プラントの範囲情報を作成します。
PlantRa(int index)
プラントの範囲情報を作成します。
メソッドの概要
String | getHigh() プラントを取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() プラントを取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) プラントを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) プラントを設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PlantRa

public PlantRa()
プラントの範囲情報を作成します。

PlantRa

public PlantRa(int index)
プラントの範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
プラントを取得します。

戻り値:
low プラント

getHigh

public String getHigh()
プラントを取得します。

戻り値:
high プラント

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
プラントを設定します。

パラメータ:
low - プラント

setHigh

public void setHigh(String high)
プラントを設定します。

パラメータ:
high - プラント

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PstngDateRa (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス PstngDateRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa
すべての実装インタフェース:
Serializable
public class PstngDateRa
extends Object
implements Serializable

登録日付の範囲情報クラス
機能は以下の通り

  • 登録日付の範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PstngDateRa()
登録日付の範囲情報を作成します。
PstngDateRa(int index)
登録日付の範囲情報を作成します。
メソッドの概要
String | getHigh() 伝票の転記日付を取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() 伝票の転記日付を取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) 伝票の転記日付を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) 伝票の転記日付を設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PstngDateRa

public PstngDateRa()
登録日付の範囲情報を作成します。

PstngDateRa

public PstngDateRa(int index)
登録日付の範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
伝票の転記日付を取得します。

戻り値:
low 伝票の転記日付

getHigh

public String getHigh()
伝票の転記日付を取得します。

戻り値:
high 伝票の転記日付

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
伝票の転記日付を設定します。

パラメータ:
low - 伝票の転記日付

setHigh

public void setHigh(String high)
伝票の転記日付を設定します。

パラメータ:
high - 伝票の転記日付

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SpecStockRa (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス SpecStockRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa
すべての実装インタフェース:
Serializable
public class SpecStockRa
extends Object
implements Serializable

特殊在庫区分の範囲情報クラス
機能は以下の通り

  • 特殊在庫区分の範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
SpecStockRa()
特殊在庫区分の範囲情報を作成します。
SpecStockRa(int index)
特殊在庫区分の範囲情報を作成します。
メソッドの概要
String | getHigh() 特殊在庫区分を取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() 特殊在庫区分を取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) 特殊在庫区分を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) 特殊在庫区分を設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SpecStockRa

public SpecStockRa()
特殊在庫区分の範囲情報を作成します。

SpecStockRa

public SpecStockRa(int index)
特殊在庫区分の範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
特殊在庫区分を取得します。

戻り値:
low 特殊在庫区分

getHigh

public String getHigh()
特殊在庫区分を取得します。

戻り値:
high 特殊在庫区分

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
特殊在庫区分を設定します。

パラメータ:
low - 特殊在庫区分

setHigh

public void setHigh(String high)
特殊在庫区分を設定します。

パラメータ:
high - 特殊在庫区分

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StgeLocRa (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス StgeLocRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa
すべての実装インタフェース:
Serializable
public class StgeLocRa
extends Object
implements Serializable

保管場所の範囲情報クラス
機能は以下の通り

  • 保管場所の範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
StgeLocRa()
保管場所の範囲情報を作成します。
StgeLocRa(int index)
保管場所の範囲情報を作成します。
メソッドの概要
String | getHigh() 保管場所を取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() 保管場所を取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) 保管場所を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) 保管場所を設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StgeLocRa

public StgeLocRa()
保管場所の範囲情報を作成します。

StgeLocRa

public StgeLocRa(int index)
保管場所の範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
保管場所を取得します。

戻り値:
low 保管場所

getHigh

public String getHigh()
保管場所を取得します。

戻り値:
high 保管場所

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
保管場所を設定します。

パラメータ:
low - 保管場所

setHigh

public void setHigh(String high)
保管場所を設定します。

パラメータ:
high - 保管場所

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TrEvTypeRa (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス TrEvTypeRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa
すべての実装インタフェース:
Serializable
public class TrEvTypeRa
extends Object
implements Serializable

トランザクション/イベントタイプの範囲情報クラス
機能は以下の通り

  • トランザクション/イベントタイプの範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
TrEvTypeRa()
トランザクション/イベントタイプの範囲情報を作成します。
TrEvTypeRa(int index)
トランザクション/イベントタイプの範囲情報を作成します。
メソッドの概要
String | getHigh() トランザクション/イベントタイプを取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() トランザクション/イベントタイプを取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) トランザクション/イベントタイプを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) トランザクション/イベントタイプを設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

TrEvTypeRa

public TrEvTypeRa()
トランザクション/イベントタイプの範囲情報を作成します。

TrEvTypeRa

public TrEvTypeRa(int index)
トランザクション/イベントタイプの範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
トランザクション/イベントタイプを取得します。

戻り値:
low トランザクション/イベントタイプ

getHigh

public String getHigh()
トランザクション/イベントタイプを取得します。

戻り値:
high トランザクション/イベントタイプ

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
トランザクション/イベントタイプを設定します。

パラメータ:
low - トランザクション/イベントタイプ

setHigh

public void setHigh(String high)
トランザクション/イベントタイプを設定します。

パラメータ:
high - トランザクション/イベントタイプ

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserNameRa (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス UserNameRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa
すべての実装インタフェース:
Serializable
public class UserNameRa
extends Object
implements Serializable

ユーザ名の範囲情報クラス
機能は以下の通り

  • ユーザ名の範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
UserNameRa()
ユーザ名の範囲情報を作成します。
UserNameRa(int index)
ユーザ名の範囲情報を作成します。
メソッドの概要
String | getHigh() ユーザ名を取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() ユーザ名を取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) ユーザ名を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) ユーザ名を設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UserNameRa

public UserNameRa()
ユーザ名の範囲情報を作成します。

UserNameRa

public UserNameRa(int index)
ユーザ名の範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
ユーザ名を取得します。

戻り値:
low ユーザ名

getHigh

public String getHigh()
ユーザ名を取得します。

戻り値:
high ユーザ名

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
ユーザ名を設定します。

パラメータ:
low - ユーザ名

setHigh

public void setHigh(String high)
ユーザ名を設定します。

パラメータ:
high - ユーザ名

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


VendorRa (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス VendorRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa
すべての実装インタフェース:
Serializable
public class VendorRa
extends Object
implements Serializable

仕入先の範囲情報クラス
機能は以下の通り

  • 仕入先の範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
VendorRa()
仕入先の範囲情報を作成します。
VendorRa(int index)
仕入先の範囲情報を作成します。
メソッドの概要
String | getHigh() 仕入先勘定コードを取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() 仕入先勘定コードを取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) 仕入先勘定コードを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) 仕入先勘定コードを設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

VendorRa

public VendorRa()
仕入先の範囲情報を作成します。

VendorRa

public VendorRa(int index)
仕入先の範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
仕入先勘定コードを取得します。

戻り値:
low 仕入先勘定コード

getHigh

public String getHigh()
仕入先勘定コードを取得します。

戻り値:
high 仕入先勘定コード

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
仕入先勘定コードを設定します。

パラメータ:
low - 仕入先勘定コード

setHigh

public void setHigh(String high)
仕入先勘定コードを設定します。

パラメータ:
high - 仕入先勘定コード

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability の使用

MaterialAvailability を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での MaterialAvailability の使用

jp.co.intra_mart.foundation.sap.module.purchase での MaterialAvailability のサブクラス
 class MaterialAvailabilityController
品目在庫確認コントローラクラス
機能は以下の通り
在庫情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


MaterialAvailability (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability
クラス MaterialAvailability

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
MaterialAvailabilityController
public class MaterialAvailability
extends ReferenceController
implements Serializable

品目在庫確認情報クラス
機能は以下の通り

  • 品目在庫確認情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
MaterialAvailability(SapClient sapClient)
品目在庫確認情報を作成します。
メソッドの概要
String | getAvQtyPlt() プラントレベル利用可能数量を取得します。
String | getBatch() ロットを取得します。
String | getCheckRule() 確認規則を取得します。
String | getCustomer() 得意先コードを取得します。
String | getDecForRounding() 小数点位置 (その位置まで丸める)を取得します。
String | getDecForRoundingX() 関連ユーザデータ項目の更新情報を取得します。
String | getDialogflag() 区分 (X = 利用不可 /N = 確認なし)を取得します。
String | getDocNumber() 伝票番号を取得します。
String | getEndleadtme() 補充リードタイムの終了日付を取得します。
String | getItmNumber() 明細番号を取得します。
String | getMaterial() 品目コードを取得します。
String | getPlant() プラントを取得します。
String | getStgeLoc() 保管場所を取得します。
String | getStockInd() 特殊在庫区分を取得します。
String | getUnit() 表示数量単位を取得します。
String | getWbsElem() WBS 要素を取得します。
List | getWmdvexList() 出力テーブル (日付および ATP 数量)を取得します。
List | getWmdvsxList() 入力テーブル (日付/数量)を取得します。
void | setAvQtyPlt(String avQtyPlt) プラントレベル利用可能数量を設定します。
void | setBatch(String batch) ロットを設定します。
void | setCheckRule(String checkRule) 確認規則を設定します。
void | setCustomer(String customer) 得意先コードを設定します。
void | setDecForRounding(String decForRounding) 小数点位置 (その位置まで丸める)を設定します。
void | setDecForRoundingX(String decForRoundingX) 関連ユーザデータ項目の更新情報を設定します。
void | setDialogflag(String dialogflag) 区分 (X = 利用不可 /N = 確認なし)を設定します。
void | setDocNumber(String docNumber) 伝票番号を設定します。
void | setEndleadtme(String endleadtme) 補充リードタイムの終了日付を設定します。
void | setExportParam(BapiController bapiController) 取得した品目在庫確認情報をセットします。
void | setImportParam(BapiController bapiController) 品目在庫確認情報を取得する為の条件をセットします。
void | setItmNumber(String itmNumber) 明細番号を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setPlant(String plant) プラントを設定します。
void | setStgeLoc(String stgeLoc) 保管場所を設定します。
void | setStockInd(String stockInd) 特殊在庫区分を設定します。
void | setUnit(String unit) 表示数量単位を設定します。
void | setWbsElem(String wbsElem) WBS 要素を設定します。
void | setWmdvexList(List wmdvexList) 出力テーブル (日付および ATP 数量)を設定します。
void | setWmdvsxList(List wmdvsxList) 入力テーブル (日付/数量)を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialAvailability

public MaterialAvailability(SapClient sapClient)
品目在庫確認情報を作成します。

パラメータ:
sapClient - SAPクライアント
メソッドの詳細

getWbsElem

public String getWbsElem()
WBS 要素を取得します。

戻り値:
wbsElem WBS 要素

getUnit

public String getUnit()
表示数量単位を取得します。

戻り値:
unit 表示数量単位

getStockInd

public String getStockInd()
特殊在庫区分を取得します。

戻り値:
stockInd 特殊在庫区分

getStgeLoc

public String getStgeLoc()
保管場所を取得します。

戻り値:
stgeLoc 保管場所

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getItmNumber

public String getItmNumber()
明細番号を取得します。

戻り値:
itmNumber 明細番号

getDocNumber

public String getDocNumber()
伝票番号を取得します。

戻り値:
docNumber 伝票番号

getDecForRoundingX

public String getDecForRoundingX()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
decForRoundingX 関連ユーザデータ項目の更新情報

getDecForRounding

public String getDecForRounding()
小数点位置 (その位置まで丸める)を取得します。

戻り値:
decForRounding 小数点位置 (その位置まで丸める)

getCustomer

public String getCustomer()
得意先コードを取得します。

戻り値:
customer 得意先コード

getCheckRule

public String getCheckRule()
確認規則を取得します。

戻り値:
checkRule 確認規則

getBatch

public String getBatch()
ロットを取得します。

戻り値:
batch ロット

getEndleadtme

public String getEndleadtme()
補充リードタイムの終了日付を取得します。

戻り値:
endleadtme 補充リードタイムの終了日付

getDialogflag

public String getDialogflag()
区分 (X = 利用不可 /N = 確認なし)を取得します。

戻り値:
dialogflag 区分 (X = 利用不可 /N = 確認なし)

getAvQtyPlt

public String getAvQtyPlt()
プラントレベル利用可能数量を取得します。

戻り値:
avQtyPlt プラントレベル利用可能数量

getWmdvexList

public List getWmdvexList()
出力テーブル (日付および ATP 数量)を取得します。

戻り値:
wmdvexList 出力テーブル (日付および ATP 数量)

getWmdvsxList

public List getWmdvsxList()
入力テーブル (日付/数量)を取得します。

戻り値:
wmdvsxList 入力テーブル (日付/数量)

setWbsElem

public void setWbsElem(String wbsElem)
WBS 要素を設定します。

パラメータ:
wbsElem - WBS 要素

setUnit

public void setUnit(String unit)
表示数量単位を設定します。

パラメータ:
unit - 表示数量単位

setStockInd

public void setStockInd(String stockInd)
特殊在庫区分を設定します。

パラメータ:
stockInd - 特殊在庫区分

setStgeLoc

public void setStgeLoc(String stgeLoc)
保管場所を設定します。

パラメータ:
stgeLoc - 保管場所

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setItmNumber

public void setItmNumber(String itmNumber)
明細番号を設定します。

パラメータ:
itmNumber - 明細番号

setDocNumber

public void setDocNumber(String docNumber)
伝票番号を設定します。

パラメータ:
docNumber - 伝票番号

setDecForRoundingX

public void setDecForRoundingX(String decForRoundingX)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
decForRoundingX - 関連ユーザデータ項目の更新情報

setDecForRounding

public void setDecForRounding(String decForRounding)
小数点位置 (その位置まで丸める)を設定します。

パラメータ:
decForRounding - 小数点位置 (その位置まで丸める)

setCustomer

public void setCustomer(String customer)
得意先コードを設定します。

パラメータ:
customer - 得意先コード

setCheckRule

public void setCheckRule(String checkRule)
確認規則を設定します。

パラメータ:
checkRule - 確認規則

setBatch

public void setBatch(String batch)
ロットを設定します。

パラメータ:
batch - ロット

setEndleadtme

public void setEndleadtme(String endleadtme)
補充リードタイムの終了日付を設定します。

パラメータ:
endleadtme - 補充リードタイムの終了日付

setDialogflag

public void setDialogflag(String dialogflag)
区分 (X = 利用不可 /N = 確認なし)を設定します。

パラメータ:
dialogflag - 区分 (X = 利用不可 /N = 確認なし)

setAvQtyPlt

public void setAvQtyPlt(String avQtyPlt)
プラントレベル利用可能数量を設定します。

パラメータ:
avQtyPlt - プラントレベル利用可能数量

setWmdvexList

public void setWmdvexList(List wmdvexList)
出力テーブル (日付および ATP 数量)を設定します。

パラメータ:
wmdvexList - 出力テーブル (日付および ATP 数量)

setWmdvsxList

public void setWmdvsxList(List wmdvsxList)
入力テーブル (日付/数量)を設定します。

パラメータ:
wmdvsxList - 入力テーブル (日付/数量)

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
品目在庫確認情報を取得する為の条件をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用アプリケーション例外
SAPGeneralAppException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
取得した品目在庫確認情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.purchase.materialavailability (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase.materialavailability
クラス
MaterialAvailability
ParamWmdvex
ParamWmdvsx
Wmdvex
Wmdvsx


jp.co.intra_mart.foundation.sap.module.purchase.materialavailability (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialavailability

クラスの概要
MaterialAvailability | 品目在庫確認情報クラス 機能は以下の通り 品目在庫確認情報を保持します。
ParamWmdvex | 出力テーブル (日付および ATP 数量)パラメータ設定クラス 機能は以下の通り 出力テーブル (日付および ATP 数量)のパラメータを設定します。
ParamWmdvsx | 入力テーブル (日付/数量)パラメータ設定クラス 機能は以下の通り 入力テーブル (日付/数量)のパラメータを設定します。
Wmdvex | 出力テーブル (日付および ATP 数量)情報クラス 機能は以下の通り 出力テーブル (日付および ATP 数量)情報を保持します。
Wmdvsx | 入力テーブル (日付/数量)情報クラス 機能は以下の通り 入力テーブル (日付/数量)情報を保持します。


jp.co.intra_mart.foundation.sap.module.purchase.materialavailability クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialavailability の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialavailability の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.purchase.materialavailability のクラス
MaterialAvailability
品目在庫確認情報クラス
機能は以下の通り
品目在庫確認情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamWmdvex (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability
クラス ParamWmdvex

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex
すべての実装インタフェース:
Serializable
public final class ParamWmdvex
extends Object
implements Serializable

出力テーブル (日付および ATP 数量)パラメータ設定クラス
機能は以下の通り

  • 出力テーブル (日付および ATP 数量)のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List wmdvexList) table(Export)情報から出力テーブル (日付および ATP 数量)の値をセットします。
static void | setImportParam(BapiController bapiController, List wmdvexList) 出力テーブル (日付および ATP 数量)の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List wmdvexList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
出力テーブル (日付および ATP 数量)の値をセットします。

パラメータ:
bapiController - BapiController
wmdvexList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List wmdvexList)
                           throws SAPGeneralSystemException
table(Export)情報から出力テーブル (日付および ATP 数量)の値をセットします。

パラメータ:
bapiController - BapiController
wmdvexList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamWmdvsx (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability
クラス ParamWmdvsx

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx
すべての実装インタフェース:
Serializable
public final class ParamWmdvsx
extends Object
implements Serializable

入力テーブル (日付/数量)パラメータ設定クラス
機能は以下の通り

  • 入力テーブル (日付/数量)のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List wmdvsxList) table(Export)情報から入力テーブル (日付/数量)の値をセットします。
static void | setImportParam(BapiController bapiController, List wmdvsxList) 入力テーブル (日付/数量)の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List wmdvsxList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
入力テーブル (日付/数量)の値をセットします。

パラメータ:
bapiController - BapiController
wmdvsxList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List wmdvsxList)
                           throws SAPGeneralSystemException
table(Export)情報から入力テーブル (日付/数量)の値をセットします。

パラメータ:
bapiController - BapiController
wmdvsxList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Wmdvex (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability
クラス Wmdvex

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex
すべての実装インタフェース:
Serializable
public class Wmdvex
extends Object
implements Serializable

出力テーブル (日付および ATP 数量)情報クラス
機能は以下の通り

  • 出力テーブル (日付および ATP 数量)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Wmdvex()
出力テーブル (日付および ATP 数量)情報を作成します。
Wmdvex(int index)
出力テーブル (日付および ATP 数量)情報を作成します。
メソッドの概要
String | getBdcnt() 5 文字数値 NUMCを取得します。
String | getComDate() 確認日を取得します。
String | getComQty() 確認数量を取得します。
int | getIndex() レコード番号を取得します｡
String | getReqDate() 所要日付を取得します。
String | getReqQty() 利用可能在庫確認の所要量を取得します。
void | setBdcnt(String bdcnt) 5 文字数値 NUMCを設定します。
void | setComDate(String comDate) 確認日を設定します。
void | setComQty(String comQty) 確認数量を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setReqDate(String reqDate) 所要日付を設定します。
void | setReqQty(String reqQty) 利用可能在庫確認の所要量を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Wmdvex

public Wmdvex()
出力テーブル (日付および ATP 数量)情報を作成します。

Wmdvex

public Wmdvex(int index)
出力テーブル (日付および ATP 数量)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getBdcnt

public String getBdcnt()
5 文字数値 NUMCを取得します。

戻り値:
bdcnt 5 文字数値 NUMC

getReqDate

public String getReqDate()
所要日付を取得します。

戻り値:
reqDate 所要日付

getReqQty

public String getReqQty()
利用可能在庫確認の所要量を取得します。

戻り値:
reqQty 利用可能在庫確認の所要量

getComDate

public String getComDate()
確認日を取得します。

戻り値:
comDate 確認日

getComQty

public String getComQty()
確認数量を取得します。

戻り値:
comQty 確認数量

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setBdcnt

public void setBdcnt(String bdcnt)
5 文字数値 NUMCを設定します。

パラメータ:
bdcnt - 5 文字数値 NUMC

setReqDate

public void setReqDate(String reqDate)
所要日付を設定します。

パラメータ:
reqDate - 所要日付

setReqQty

public void setReqQty(String reqQty)
利用可能在庫確認の所要量を設定します。

パラメータ:
reqQty - 利用可能在庫確認の所要量

setComDate

public void setComDate(String comDate)
確認日を設定します。

パラメータ:
comDate - 確認日

setComQty

public void setComQty(String comQty)
確認数量を設定します。

パラメータ:
comQty - 確認数量

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Wmdvsx (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability
クラス Wmdvsx

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx
すべての実装インタフェース:
Serializable
public class Wmdvsx
extends Object
implements Serializable

入力テーブル (日付/数量)情報クラス
機能は以下の通り

  • 入力テーブル (日付/数量)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Wmdvsx()
入力テーブル (日付/数量)情報を作成します。
Wmdvsx(int index)
入力テーブル (日付/数量)情報を作成します。
メソッドの概要
String | getDelkz() MRP 要素区分を取得します。
int | getIndex() レコード番号を取得します｡
String | getReqDate() 所要日付を取得します。
String | getReqQty() 所要量を取得します。
String | getYline() 内部テ－ブル処理の行索引を取得します。
void | setDelkz(String delkz) MRP 要素区分を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setReqDate(String reqDate) 所要日付を設定します。
void | setReqQty(String reqQty) 所要量を設定します。
void | setYline(String yline) 内部テ－ブル処理の行索引を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Wmdvsx

public Wmdvsx()
入力テーブル (日付/数量)情報を作成します。

Wmdvsx

public Wmdvsx(int index)
入力テーブル (日付/数量)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getReqDate

public String getReqDate()
所要日付を取得します。

戻り値:
reqDate 所要日付

getReqQty

public String getReqQty()
所要量を取得します。

戻り値:
reqQty 所要量

getDelkz

public String getDelkz()
MRP 要素区分を取得します。

戻り値:
delkz MRP 要素区分

getYline

public String getYline()
内部テ－ブル処理の行索引を取得します。

戻り値:
yline 内部テ－ブル処理の行索引

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setReqDate

public void setReqDate(String reqDate)
所要日付を設定します。

パラメータ:
reqDate - 所要日付

setReqQty

public void setReqQty(String reqQty)
所要量を設定します。

パラメータ:
reqQty - 所要量

setDelkz

public void setDelkz(String delkz)
MRP 要素区分を設定します。

パラメータ:
delkz - MRP 要素区分

setYline

public void setYline(String yline)
内部テ－ブル処理の行索引を設定します。

パラメータ:
yline - 内部テ－ブル処理の行索引

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut の使用

ExtensionOut を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での ExtensionOut の使用

ExtensionOut を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 ExtensionOut MaterialGetAllController.getExtensionOut(int index)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造オブジェクトが既に 存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers の使用

InternationArticleNumbers を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での InternationArticleNumbers の使用

InternationArticleNumbers を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 InternationArticleNumbers MaterialGetAllController.getInternationArticleNumbers(int index)
EANオブジェクトが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData の使用

LifoValuationData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での LifoValuationData の使用

LifoValuationData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 LifoValuationData MaterialGetAll.getLifoValuationData()
LIFO 関連品目データを取得します。

LifoValuationData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setLifoValuationData(LifoValuationData lifoValuationData)
LIFO 関連品目データを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll の使用

MaterialGetAll を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での MaterialGetAll の使用

jp.co.intra_mart.foundation.sap.module.purchase での MaterialGetAll のサブクラス
 class MaterialGetAllController
品目マスタ照会コントローラクラス
機能は以下の通り
品目マスタの情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText の使用

MaterialText を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での MaterialText の使用

MaterialText を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 MaterialText MaterialGetAllController.getMaterialText(int index)
テキスト (長)オブジェクトが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData の使用

ProductionResourceToolData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での ProductionResourceToolData の使用

ProductionResourceToolData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 ProductionResourceToolData MaterialGetAll.getProductionResourceToolData()
品目マスタの生産資源/治工具 (PRT) 項目を取得します。

ProductionResourceToolData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setProductionResourceToolData(ProductionResourceToolData productionResourceToolData)
品目マスタの生産資源/治工具 (PRT) 項目を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ExtensionOut (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall
クラス ExtensionOut

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut
すべての実装インタフェース:
Serializable
public class ExtensionOut
extends Object
implements Serializable

BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報クラス
機能は以下の通り

  • BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExtensionOut()
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。
ExtensionOut(int index)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
String | getStructure() BAPI テーブル拡張の構造名を取得します。
String | getValuepart1() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart2() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart3() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart4() BAPI 拡張パラメータのデータ部分を取得します。
void | setIndex(int index) レコード番号を設定します｡
void | setStructure(String structure) BAPI テーブル拡張の構造名を設定します。
void | setValuepart1(String valuepart1) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart2(String valuepart2) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart3(String valuepart3) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart4(String valuepart4) BAPI 拡張パラメータのデータ部分を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtensionOut

public ExtensionOut()
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。

ExtensionOut

public ExtensionOut(int index)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getStructure

public String getStructure()
BAPI テーブル拡張の構造名を取得します。

戻り値:
structure BAPI テーブル拡張の構造名

getValuepart1

public String getValuepart1()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart1 BAPI 拡張パラメータのデータ部分

getValuepart2

public String getValuepart2()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart2 BAPI 拡張パラメータのデータ部分

getValuepart3

public String getValuepart3()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart3 BAPI 拡張パラメータのデータ部分

getValuepart4

public String getValuepart4()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart4 BAPI 拡張パラメータのデータ部分

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setStructure

public void setStructure(String structure)
BAPI テーブル拡張の構造名を設定します。

パラメータ:
structure - BAPI テーブル拡張の構造名

setValuepart1

public void setValuepart1(String valuepart1)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart1 - BAPI 拡張パラメータのデータ部分

setValuepart2

public void setValuepart2(String valuepart2)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart2 - BAPI 拡張パラメータのデータ部分

setValuepart3

public void setValuepart3(String valuepart3)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart3 - BAPI 拡張パラメータのデータ部分

setValuepart4

public void setValuepart4(String valuepart4)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart4 - BAPI 拡張パラメータのデータ部分

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


InternationArticleNumbers (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall
クラス InternationArticleNumbers

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers
すべての実装インタフェース:
Serializable
public class InternationArticleNumbers
extends Object
implements Serializable

EAN情報クラス
機能は以下の通り

  • EAN情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
InternationArticleNumbers()
EAN情報を作成します。
InternationArticleNumbers(int index)
EAN情報を作成します。
メソッドの概要
String | getEanCat() 国際商品コード (EAN) のカテゴリを取得します。
String | getEanUpc() 国際商品コード (EAN/UPC)を取得します。
int | getIndex() レコード番号を取得します｡
String | getMainEan() 区分: 主要 EANを取得します。
String | getUnit() 表示数量単位を取得します。
String | getUnitIso() ISO コードでの表示数量単位を取得します。
void | setEanCat(String eanCat) 国際商品コード (EAN) のカテゴリを設定します。
void | setEanUpc(String eanUpc) 国際商品コード (EAN/UPC)を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMainEan(String mainEan) 区分: 主要 EANを設定します。
void | setUnit(String unit) 表示数量単位を設定します。
void | setUnitIso(String unitIso) ISO コードでの表示数量単位を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

InternationArticleNumbers

public InternationArticleNumbers()
EAN情報を作成します。

InternationArticleNumbers

public InternationArticleNumbers(int index)
EAN情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getUnit

public String getUnit()
表示数量単位を取得します。

戻り値:
unit 表示数量単位

getUnitIso

public String getUnitIso()
ISO コードでの表示数量単位を取得します。

戻り値:
unitIso ISO コードでの表示数量単位

getEanUpc

public String getEanUpc()
国際商品コード (EAN/UPC)を取得します。

戻り値:
eanUpc 国際商品コード (EAN/UPC)

getEanCat

public String getEanCat()
国際商品コード (EAN) のカテゴリを取得します。

戻り値:
eanCat 国際商品コード (EAN) のカテゴリ

getMainEan

public String getMainEan()
区分: 主要 EANを取得します。

戻り値:
mainEan 区分: 主要 EAN

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setUnit

public void setUnit(String unit)
表示数量単位を設定します。

パラメータ:
unit - 表示数量単位

setUnitIso

public void setUnitIso(String unitIso)
ISO コードでの表示数量単位を設定します。

パラメータ:
unitIso - ISO コードでの表示数量単位

setEanUpc

public void setEanUpc(String eanUpc)
国際商品コード (EAN/UPC)を設定します。

パラメータ:
eanUpc - 国際商品コード (EAN/UPC)

setEanCat

public void setEanCat(String eanCat)
国際商品コード (EAN) のカテゴリを設定します。

パラメータ:
eanCat - 国際商品コード (EAN) のカテゴリ

setMainEan

public void setMainEan(String mainEan)
区分: 主要 EANを設定します。

パラメータ:
mainEan - 区分: 主要 EAN

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LifoValuationData (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall
クラス LifoValuationData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData
すべての実装インタフェース:
Serializable
public class LifoValuationData
extends Object
implements Serializable

LIFO 関連品目データ情報クラス
機能は以下の通り

  • LIFO 関連品目データ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
LifoValuationData()
LIFO 関連品目データ情報を作成します。
メソッドの概要
String | getLifoValuationLevel() LIFO 評価レベルを取得します。
String | getPoolnumber() LIFO 評価でのプール番号を取得します。
void | setLifoValuationLevel(String lifoValuationLevel) LIFO 評価レベルを設定します。
void | setPoolnumber(String poolnumber) LIFO 評価でのプール番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

LifoValuationData

public LifoValuationData()
LIFO 関連品目データ情報を作成します。

メソッドの詳細

getLifoValuationLevel

public String getLifoValuationLevel()
LIFO 評価レベルを取得します。

戻り値:
lifoValuationLevel LIFO 評価レベル

getPoolnumber

public String getPoolnumber()
LIFO 評価でのプール番号を取得します。

戻り値:
poolnumber LIFO 評価でのプール番号

setLifoValuationLevel

public void setLifoValuationLevel(String lifoValuationLevel)
LIFO 評価レベルを設定します。

パラメータ:
lifoValuationLevel - LIFO 評価レベル

setPoolnumber

public void setPoolnumber(String poolnumber)
LIFO 評価でのプール番号を設定します。

パラメータ:
poolnumber - LIFO 評価でのプール番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialGetAll (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall
クラス MaterialGetAll

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
MaterialGetAllController
public class MaterialGetAll
extends ReferenceController
implements Serializable

品目マスタ照会情報クラス
機能は以下の通り

  • 品目マスタ照会情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
MaterialGetAll(SapClient sapClient)
品目マスタ照会情報を作成します。
MaterialGetAll(String material, String companyCode, String plant, String storageLocation, String salesOrganisation, String distributionChannel, SapClient sapClient)
品目マスタ照会情報を作成します。
メソッドの概要
ClientData | getClientData() 品目データ (クライアントレベル)を取得します。
String | getCompanycode() 会社コードを取得します。
String | getDistributionchannel() 流通チャネルを取得します。
List | getExtensionOutList() BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。
ForecastParameters | getForecastParameters() 予測パラメータを取得します。
List | getInternationArticleNumbersList() EANを取得します。
LifoValuationData | getLifoValuationData() LIFO 関連品目データを取得します。
String | getLifovaluationlevel() LIFO 評価レベルを取得します。
String | getMaterial() 品目コードを取得します。
List | getMaterialDescriptionList() 品目テキストを取得します。
List | getMaterialTextList() テキスト (長)を取得します。
PlanningData | getPlanningData() 品目マスタ/製品グループの変更伝票構造を取得します。
String | getPlant() プラントを取得します。
PlantData | getPlantData() 品目データ (プラントレベル)を取得します。
ProductionResourceToolData | getProductionResourceToolData() 品目マスタの生産資源/治工具 (PRT) 項目を取得します。
SalesData | getSalesData() 販売データを取得します。
String | getSalesorganisation() 販売組織を取得します。
String | getStoragelocation() 保管場所を取得します。
StorageLocationData | getStorageLocationData() 品目データ (保管場所レベル)を取得します。
String | getStoragetype() 保管域タイプを取得します。
StorageTypeData | getStorageTypeData() 保管域タイプデータを取得します。
List | getTaxClassificationsList() 制御デ－タを取得します。
List | getUnitSofmeasureList() 数量単位を取得します。
String | getValuationarea() 評価レベルを取得します。
ValuationData | getValuationData() 評価データを取得します。
String | getValuationtype() 評価タイプを取得します。
String | getWarehousenumber() 倉庫番号/複合倉庫を取得します。
WarehouseNumberData | getWarehouseNumberData() 倉庫番号データを取得します。
void | initMaterialGetAll() 品目マスタ照会情報を作成します。
void | setClientData(ClientData clientData) 品目データ (クライアントレベル)を設定します。
void | setCompanycode(String companycode) 会社コードを設定します。
void | setDistributionchannel(String distributionchannel) 流通チャネルを設定します。
void | setExpClientData(BapiController bapiController) structure(Export)情報から品目データ (クライアントレベル) を設定します。
void | setExpExtensionOut(BapiController bapiController) table(Export)情報からBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造 を設定します。
void | setExpForecastParameters(BapiController bapiController) structure(Export)情報から予測データを設定します。
void | setExpInternationArticleNumbers(BapiController bapiController) table(Export)情報からEANを設定します。
void | setExpLifoValuationData(BapiController bapiController) structure(Export)情報からLIFO 関連品目データを設定します。
void | setExpMaterialDescription(BapiController bapiController) table(Export)情報から品目テキストを設定します。
void | setExpMaterialText(BapiController bapiController) table(Export)情報からテキスト (長) を設定します。
void | setExportParam(BapiController bapiController) 返却された品目マスタ照会情報をセットします。
void | setExpPlanningData(BapiController bapiController) structure(Export)情報から品目マスタ/製品グループの変更伝票構造を設定します。
void | setExpPlantData(BapiController bapiController) structure(Export)情報から品目データ (プラントレベル) を設定します。
void | setExpProductionResourceToolData(BapiController bapiController) structure(Export)情報から品目マスタの生産資源/治工具 (PRT) 項目を設定します。
void | setExpSalesData(BapiController bapiController) structure(Export)情報から販売データを設定します。
void | setExpStorageLocationData(BapiController bapiController) structure(Export)情報から品目データ (保管場所レベル)を設定します。
void | setExpStorageTypeData(BapiController bapiController) structure(Export)情報から保管域タイプデータを設定します。
void | setExpTaxClassifications(BapiController bapiController) table(Export)情報から制御データを設定します。
void | setExpUnitSofmeasure(BapiController bapiController) table(Export)情報から数量単位を設定します。
void | setExpValuationData(BapiController bapiController) structure(Export)情報から評価データを設定します。
void | setExpWarehouseNumberData(BapiController bapiController) structure(Export)情報から倉庫番号データを設定します。
void | setExtensionOutList(List extensionOutList) BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を設定します。
void | setForecastParameters(ForecastParameters forecastParameters) 予測パラメータを設定します。
void | setImpExtensionOut(BapiController bapiController) BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造からインポート情報を 設定します。
void | setImpInternationArticleNumbers(BapiController bapiController) EANからインポート情報を設定します。
void | setImpMaterialDescription(BapiController bapiController) 品目テキストからインポート情報を設定します。
void | setImpMaterialText(BapiController bapiController) テキスト (長) からインポート情報を設定します。
void | setImportParam(BapiController bapiController) 品目マスタ照会条件ををセットします。
void | setImpTaxClassifications(BapiController bapiController) 制御データからインポート情報を設定します。
void | setImpUnitSofmeasure(BapiController bapiController) 数量単位からインポート情報を設定します。
void | setInternationArticleNumbersList(List internationArticleNumbersList) EANを設定します。
void | setLifoValuationData(LifoValuationData lifoValuationData) LIFO 関連品目データを設定します。
void | setLifovaluationlevel(String lifovaluationlevel) LIFO 評価レベルを設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialDescriptionList(List materialDescriptionList) 品目テキストを設定します。
void | setMaterialTextList(List materialTextList) テキスト (長)を設定します。
void | setPlanningData(PlanningData planningData) 品目マスタ/製品グループの変更伝票構造を設定します。
void | setPlant(String plant) プラントを設定します。
void | setPlantData(PlantData plantData) 品目データ (プラントレベル)を設定します。
void | setProductionResourceToolData(ProductionResourceToolData productionResourceToolData) 品目マスタの生産資源/治工具 (PRT) 項目を設定します。
void | setSalesData(SalesData salesData) 販売データを設定します。
void | setSalesorganisation(String salesorganisation) 販売組織を設定します。
void | setStoragelocation(String storagelocation) 保管場所を設定します。
void | setStorageLocationData(StorageLocationData storageLocationData) 品目データ (保管場所レベル)を設定します。
void | setStoragetype(String storagetype) 保管域タイプを設定します。
void | setStorageTypeData(StorageTypeData storageTypeData) 保管域タイプデータを設定します。
void | setTaxClassificationsList(List taxClassificationsList) 制御デ－タを設定します。
void | setUnitSofmeasureList(List unitSofmeasureList) 数量単位を設定します。
void | setValuationarea(String valuationarea) 評価レベルを設定します。
void | setValuationData(ValuationData valuationData) 評価データを設定します。
void | setValuationtype(String valuationtype) 評価タイプを設定します。
void | setWarehousenumber(String warehousenumber) 倉庫番号/複合倉庫を設定します。
void | setWarehouseNumberData(WarehouseNumberData warehouseNumberData) 倉庫番号データを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialGetAll

public MaterialGetAll(SapClient sapClient)
品目マスタ照会情報を作成します。

パラメータ:
sapClient - SAPクライアント

MaterialGetAll

public MaterialGetAll(String material,
                      String companyCode,
                      String plant,
                      String storageLocation,
                      String salesOrganisation,
                      String distributionChannel,
                      SapClient sapClient)
品目マスタ照会情報を作成します。

パラメータ:
material - 品目コード
companyCode - 会社コード
plant - プラント
storageLocation - 保管場所
salesOrganisation - 販売組織
distributionChannel - 流通チャネル
sapClient - SAPクライアント
メソッドの詳細

initMaterialGetAll

public void initMaterialGetAll()
品目マスタ照会情報を作成します。

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
品目マスタ照会条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
返却された品目マスタ照会情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setImpMaterialDescription

public void setImpMaterialDescription(BapiController bapiController)
                               throws SAPGeneralSystemException,
                                      SAPGeneralAppException
品目テキストからインポート情報を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setImpUnitSofmeasure

public void setImpUnitSofmeasure(BapiController bapiController)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
数量単位からインポート情報を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setImpInternationArticleNumbers

public void setImpInternationArticleNumbers(BapiController bapiController)
                                     throws SAPGeneralSystemException,
                                            SAPGeneralAppException
EANからインポート情報を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setImpMaterialText

public void setImpMaterialText(BapiController bapiController)
                        throws SAPGeneralSystemException,
                               SAPGeneralAppException
テキスト (長) からインポート情報を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setImpTaxClassifications

public void setImpTaxClassifications(BapiController bapiController)
                              throws SAPGeneralSystemException,
                                     SAPGeneralAppException
制御データからインポート情報を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setImpExtensionOut

public void setImpExtensionOut(BapiController bapiController)
                        throws SAPGeneralSystemException,
                               SAPGeneralAppException
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造からインポート情報を 設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setExpClientData

public void setExpClientData(BapiController bapiController)
                      throws SAPGeneralSystemException
structure(Export)情報から品目データ (クライアントレベル) を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpPlantData

public void setExpPlantData(BapiController bapiController)
                     throws SAPGeneralSystemException
structure(Export)情報から品目データ (プラントレベル) を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpForecastParameters

public void setExpForecastParameters(BapiController bapiController)
                              throws SAPGeneralSystemException
structure(Export)情報から予測データを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpPlanningData

public void setExpPlanningData(BapiController bapiController)
                        throws SAPGeneralSystemException
structure(Export)情報から品目マスタ/製品グループの変更伝票構造を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpStorageLocationData

public void setExpStorageLocationData(BapiController bapiController)
                               throws SAPGeneralSystemException
structure(Export)情報から品目データ (保管場所レベル)を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpValuationData

public void setExpValuationData(BapiController bapiController)
                         throws SAPGeneralSystemException
structure(Export)情報から評価データを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpWarehouseNumberData

public void setExpWarehouseNumberData(BapiController bapiController)
                               throws SAPGeneralSystemException
structure(Export)情報から倉庫番号データを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpSalesData

public void setExpSalesData(BapiController bapiController)
                     throws SAPGeneralSystemException
structure(Export)情報から販売データを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpStorageTypeData

public void setExpStorageTypeData(BapiController bapiController)
                           throws SAPGeneralSystemException
structure(Export)情報から保管域タイプデータを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpProductionResourceToolData

public void setExpProductionResourceToolData(BapiController bapiController)
                                      throws SAPGeneralSystemException
structure(Export)情報から品目マスタの生産資源/治工具 (PRT) 項目を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpLifoValuationData

public void setExpLifoValuationData(BapiController bapiController)
                             throws SAPGeneralSystemException
structure(Export)情報からLIFO 関連品目データを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpMaterialDescription

public void setExpMaterialDescription(BapiController bapiController)
                               throws SAPGeneralSystemException
table(Export)情報から品目テキストを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpUnitSofmeasure

public void setExpUnitSofmeasure(BapiController bapiController)
                          throws SAPGeneralSystemException
table(Export)情報から数量単位を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpInternationArticleNumbers

public void setExpInternationArticleNumbers(BapiController bapiController)
                                     throws SAPGeneralSystemException
table(Export)情報からEANを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpMaterialText

public void setExpMaterialText(BapiController bapiController)
                        throws SAPGeneralSystemException
table(Export)情報からテキスト (長) を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpTaxClassifications

public void setExpTaxClassifications(BapiController bapiController)
                              throws SAPGeneralSystemException
table(Export)情報から制御データを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpExtensionOut

public void setExpExtensionOut(BapiController bapiController)
                        throws SAPGeneralSystemException
table(Export)情報からBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造 を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getSalesorganisation

public String getSalesorganisation()
販売組織を取得します。

戻り値:
salesorganisation 販売組織

getStoragelocation

public String getStoragelocation()
保管場所を取得します。

戻り値:
storagelocation 保管場所

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getStoragetype

public String getStoragetype()
保管域タイプを取得します。

戻り値:
storagetype 保管域タイプ

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getLifovaluationlevel

public String getLifovaluationlevel()
LIFO 評価レベルを取得します。

戻り値:
lifovaluationlevel LIFO 評価レベル

getValuationarea

public String getValuationarea()
評価レベルを取得します。

戻り値:
valuationarea 評価レベル

getValuationtype

public String getValuationtype()
評価タイプを取得します。

戻り値:
valuationtype 評価タイプ

getWarehousenumber

public String getWarehousenumber()
倉庫番号/複合倉庫を取得します。

戻り値:
warehousenumber 倉庫番号/複合倉庫

getDistributionchannel

public String getDistributionchannel()
流通チャネルを取得します。

戻り値:
distributionchannel 流通チャネル

getCompanycode

public String getCompanycode()
会社コードを取得します。

戻り値:
companycode 会社コード

getValuationData

public ValuationData getValuationData()
評価データを取得します。

戻り値:
valuationData 評価データ

getStorageTypeData

public StorageTypeData getStorageTypeData()
保管域タイプデータを取得します。

戻り値:
storageTypeData 保管域タイプデータ

getStorageLocationData

public StorageLocationData getStorageLocationData()
品目データ (保管場所レベル)を取得します。

戻り値:
storageLocationData 品目データ (保管場所レベル)

getWarehouseNumberData

public WarehouseNumberData getWarehouseNumberData()
倉庫番号データを取得します。

戻り値:
warehouseNumberData 倉庫番号データ

getSalesData

public SalesData getSalesData()
販売データを取得します。

戻り値:
salesData 販売データ

getClientData

public ClientData getClientData()
品目データ (クライアントレベル)を取得します。

戻り値:
clientData 品目データ (クライアントレベル)

getProductionResourceToolData

public ProductionResourceToolData getProductionResourceToolData()
品目マスタの生産資源/治工具 (PRT) 項目を取得します。

戻り値:
productionResourceToolData 品目マスタの生産資源/治工具 (PRT) 項目

getPlantData

public PlantData getPlantData()
品目データ (プラントレベル)を取得します。

戻り値:
plantData 品目データ (プラントレベル)

getPlanningData

public PlanningData getPlanningData()
品目マスタ/製品グループの変更伝票構造を取得します。

戻り値:
planningData 品目マスタ/製品グループの変更伝票構造

getForecastParameters

public ForecastParameters getForecastParameters()
予測パラメータを取得します。

戻り値:
forecastParameters 予測パラメータ

getLifoValuationData

public LifoValuationData getLifoValuationData()
LIFO 関連品目データを取得します。

戻り値:
lifoValuationData LIFO 関連品目データ

getExtensionOutList

public List getExtensionOutList()
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。

戻り値:
extensionOutList BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の 参照構造

getInternationArticleNumbersList

public List getInternationArticleNumbersList()
EANを取得します。

戻り値:
internationArticleNumbersList EAN

getUnitSofmeasureList

public List getUnitSofmeasureList()
数量単位を取得します。

戻り値:
unitSofmeasureList 数量単位

getTaxClassificationsList

public List getTaxClassificationsList()
制御デ－タを取得します。

戻り値:
taxClassificationsList 制御デ－タ

getMaterialDescriptionList

public List getMaterialDescriptionList()
品目テキストを取得します。

戻り値:
materialDescriptionList 品目テキスト

getMaterialTextList

public List getMaterialTextList()
テキスト (長)を取得します。

戻り値:
materialTextList テキスト (長)

setSalesorganisation

public void setSalesorganisation(String salesorganisation)
販売組織を設定します。

パラメータ:
salesorganisation - 販売組織

setStoragelocation

public void setStoragelocation(String storagelocation)
保管場所を設定します。

パラメータ:
storagelocation - 保管場所

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setStoragetype

public void setStoragetype(String storagetype)
保管域タイプを設定します。

パラメータ:
storagetype - 保管域タイプ

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setLifovaluationlevel

public void setLifovaluationlevel(String lifovaluationlevel)
LIFO 評価レベルを設定します。

パラメータ:
lifovaluationlevel - LIFO 評価レベル

setValuationarea

public void setValuationarea(String valuationarea)
評価レベルを設定します。

パラメータ:
valuationarea - 評価レベル

setValuationtype

public void setValuationtype(String valuationtype)
評価タイプを設定します。

パラメータ:
valuationtype - 評価タイプ

setWarehousenumber

public void setWarehousenumber(String warehousenumber)
倉庫番号/複合倉庫を設定します。

パラメータ:
warehousenumber - 倉庫番号/複合倉庫

setDistributionchannel

public void setDistributionchannel(String distributionchannel)
流通チャネルを設定します。

パラメータ:
distributionchannel - 流通チャネル

setCompanycode

public void setCompanycode(String companycode)
会社コードを設定します。

パラメータ:
companycode - 会社コード

setValuationData

public void setValuationData(ValuationData valuationData)
評価データを設定します。

パラメータ:
valuationData - 評価データ

setStorageTypeData

public void setStorageTypeData(StorageTypeData storageTypeData)
保管域タイプデータを設定します。

パラメータ:
storageTypeData - 保管域タイプデータ

setStorageLocationData

public void setStorageLocationData(StorageLocationData storageLocationData)
品目データ (保管場所レベル)を設定します。

パラメータ:
storageLocationData - 品目データ (保管場所レベル)

setWarehouseNumberData

public void setWarehouseNumberData(WarehouseNumberData warehouseNumberData)
倉庫番号データを設定します。

パラメータ:
warehouseNumberData - 倉庫番号データ

setSalesData

public void setSalesData(SalesData salesData)
販売データを設定します。

パラメータ:
salesData - 販売データ

setClientData

public void setClientData(ClientData clientData)
品目データ (クライアントレベル)を設定します。

パラメータ:
clientData - 品目データ (クライアントレベル)

setProductionResourceToolData

public void setProductionResourceToolData(ProductionResourceToolData productionResourceToolData)
品目マスタの生産資源/治工具 (PRT) 項目を設定します。

パラメータ:
productionResourceToolData - 品目マスタの生産資源/治工具 (PRT) 項目

setPlantData

public void setPlantData(PlantData plantData)
品目データ (プラントレベル)を設定します。

パラメータ:
plantData - 品目データ (プラントレベル)

setPlanningData

public void setPlanningData(PlanningData planningData)
品目マスタ/製品グループの変更伝票構造を設定します。

パラメータ:
planningData - 品目マスタ/製品グループの変更伝票構造

setForecastParameters

public void setForecastParameters(ForecastParameters forecastParameters)
予測パラメータを設定します。

パラメータ:
forecastParameters - 予測パラメータ

setLifoValuationData

public void setLifoValuationData(LifoValuationData lifoValuationData)
LIFO 関連品目データを設定します。

パラメータ:
lifoValuationData - LIFO 関連品目データ

setExtensionOutList

public void setExtensionOutList(List extensionOutList)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を設定します。

パラメータ:
extensionOutList - BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の 参照構造

setInternationArticleNumbersList

public void setInternationArticleNumbersList(List internationArticleNumbersList)
EANを設定します。

パラメータ:
internationArticleNumbersList - EAN

setUnitSofmeasureList

public void setUnitSofmeasureList(List unitSofmeasureList)
数量単位を設定します。

パラメータ:
unitSofmeasureList - 数量単位

setTaxClassificationsList

public void setTaxClassificationsList(List taxClassificationsList)
制御デ－タを設定します。

パラメータ:
taxClassificationsList - 制御デ－タ

setMaterialDescriptionList

public void setMaterialDescriptionList(List materialDescriptionList)
品目テキストを設定します。

パラメータ:
materialDescriptionList - 品目テキスト

setMaterialTextList

public void setMaterialTextList(List materialTextList)
テキスト (長)を設定します。

パラメータ:
materialTextList - テキスト (長)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialText (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall
クラス MaterialText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText
すべての実装インタフェース:
Serializable
public class MaterialText
extends Object
implements Serializable

テキスト (長)情報クラス
機能は以下の通り

  • テキスト (長)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MaterialText()
テキスト (長)情報を作成します。
MaterialText(int index)
テキスト (長)情報を作成します。
メソッドの概要
String | getApplobject() テキスト: アプリケーションオブジェクトを取得します。
String | getFormatCol() タグ列を取得します。
int | getIndex() レコード番号を取得します｡
String | getLangu() 言語キーを取得します。
String | getLanguIso() ISO 639 準拠の言語を取得します。
String | getTextId() テキスト IDを取得します。
String | getTextLine() テキスト行を取得します。
String | getTextName() 名称を取得します。
void | setApplobject(String applobject) テキスト: アプリケーションオブジェクトを設定します。
void | setFormatCol(String formatCol) タグ列を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLangu(String langu) 言語キーを設定します。
void | setLanguIso(String languIso) ISO 639 準拠の言語を設定します。
void | setTextId(String textId) テキスト IDを設定します。
void | setTextLine(String textLine) テキスト行を設定します。
void | setTextName(String textName) 名称を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialText

public MaterialText()
テキスト (長)情報を作成します。

MaterialText

public MaterialText(int index)
テキスト (長)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getApplobject

public String getApplobject()
テキスト: アプリケーションオブジェクトを取得します。

戻り値:
applobject テキスト: アプリケーションオブジェクト

getTextName

public String getTextName()
名称を取得します。

戻り値:
textName 名称

getTextId

public String getTextId()
テキスト IDを取得します。

戻り値:
textId テキスト ID

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
langu 言語キー

getLanguIso

public String getLanguIso()
ISO 639 準拠の言語を取得します。

戻り値:
languIso ISO 639 準拠の言語

getFormatCol

public String getFormatCol()
タグ列を取得します。

戻り値:
formatCol タグ列

getTextLine

public String getTextLine()
テキスト行を取得します。

戻り値:
textLine テキスト行

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setApplobject

public void setApplobject(String applobject)
テキスト: アプリケーションオブジェクトを設定します。

パラメータ:
applobject - テキスト: アプリケーションオブジェクト

setTextName

public void setTextName(String textName)
名称を設定します。

パラメータ:
textName - 名称

setTextId

public void setTextId(String textId)
テキスト IDを設定します。

パラメータ:
textId - テキスト ID

setLangu

public void setLangu(String langu)
言語キーを設定します。

パラメータ:
langu - 言語キー

setLanguIso

public void setLanguIso(String languIso)
ISO 639 準拠の言語を設定します。

パラメータ:
languIso - ISO 639 準拠の言語

setFormatCol

public void setFormatCol(String formatCol)
タグ列を設定します。

パラメータ:
formatCol - タグ列

setTextLine

public void setTextLine(String textLine)
テキスト行を設定します。

パラメータ:
textLine - テキスト行

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.purchase.materialgetall (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase.materialgetall
クラス
ExtensionOut
InternationArticleNumbers
LifoValuationData
MaterialGetAll
MaterialText
ProductionResourceToolData


jp.co.intra_mart.foundation.sap.module.purchase.materialgetall (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

クラスの概要
ExtensionOut | BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報クラス 機能は以下の通り BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を保持します。
InternationArticleNumbers | EAN情報クラス 機能は以下の通り EAN情報を保持します。
LifoValuationData | LIFO 関連品目データ情報クラス 機能は以下の通り LIFO 関連品目データ情報を保持します。
MaterialGetAll | 品目マスタ照会情報クラス 機能は以下の通り 品目マスタ照会情報を保持します。
MaterialText | テキスト (長)情報クラス 機能は以下の通り テキスト (長)情報を保持します。
ProductionResourceToolData | 品目マスタの生産資源/治工具 (PRT) 項目情報クラス 機能は以下の通り 品目マスタの生産資源/治工具 (PRT) 項目情報を保持します。


jp.co.intra_mart.foundation.sap.module.purchase.materialgetall クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall |

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のクラス
ExtensionOut
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報クラス
機能は以下の通り
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を保持します。
InternationArticleNumbers
EAN情報クラス
機能は以下の通り
EAN情報を保持します。
MaterialGetAll
品目マスタ照会情報クラス
機能は以下の通り
品目マスタ照会情報を保持します。
MaterialText
テキスト (長)情報クラス
機能は以下の通り
テキスト (長)情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall により使用される jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のクラス
LifoValuationData
LIFO 関連品目データ情報クラス
機能は以下の通り
LIFO 関連品目データ情報を保持します。
ProductionResourceToolData
品目マスタの生産資源/治工具 (PRT) 項目情報クラス
機能は以下の通り
品目マスタの生産資源/治工具 (PRT) 項目情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ProductionResourceToolData (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall
クラス ProductionResourceToolData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData
すべての実装インタフェース:
Serializable
public class ProductionResourceToolData
extends Object
implements Serializable

品目マスタの生産資源/治工具 (PRT) 項目情報クラス
機能は以下の通り

  • 品目マスタの生産資源/治工具 (PRT) 項目情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ProductionResourceToolData()
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。
メソッドの概要
String | getCreateLoadRecs() 区分: 生産資源/治工具の負荷レコード登録を取得します。
String | getCtrlKey() 生産資源/治工具管理の管理キーを取得します。
String | getCtrlKeyNoChg() 管理キーは変更できませんを取得します。
String | getEndOffset() 生産資源/治工具用途の終了オフセットを取得します。
String | getEndOffsetNoChg() 終了オフセットは変更できませんを取得します。
String | getEndOffsetUnit() 生産資源/治工具使用終了オフセット単位を取得します。
String | getEndOffsetUnitIso() PRT 用途終了決定の間隔時間単位 (ISO)を取得します。
String | getEndRefDate() 生産資源/治工具使用終了日の参照日付を取得します。
String | getEndRefDateNoChg() 終了参照日付は変更できませんを取得します。
String | getFormulaTotQty() 生産資源/治工具の合計数量の計算式を取得します。
String | getFormulaTotQtyNoChg() 合計数量の計算式は変更できませんを取得します。
String | getFormulaTotUsage() 生産資源/治工具の総用途値の計算式を取得します。
String | getFormulaTotUsageNoChg() すべての用途値を計算する計算式は変更できませんを取得します。
String | getGrpKey1() 生産資源/治工具のグループキー 1を取得します。
String | getGrpKey2() 生産資源/治工具のグループキー 2を取得します。
String | getPlant() プラントを取得します。
String | getPrtUsage() 生産資源/治工具用途を取得します。
String | getRefKeyNoChg() 参照キーは変更できませんを取得します。
String | getStartOffset() 生産資源/治工具使用の開始オフセットを取得します。
String | getStartOffsetNoChg() 開始オフセットは変更できませんを取得します。
String | getStartOffsetUnit() 生産資源/治工具使用開始のオフセット単位を取得します。
String | getStartOffsetUnitIso() PRT 用途開始決定の間隔時間単位 (ISO)を取得します。
String | getStartRefDate() 生産資源/治工具使用開始の参照日付を取得します。
String | getStdTextKey() 生産資源/治工具の標準テキストキーを取得します。
String | getStRefDateNoChg() 開始参照日付は変更できませんを取得します。
void | setCreateLoadRecs(String createLoadRecs) 区分: 生産資源/治工具の負荷レコード登録を設定します。
void | setCtrlKey(String ctrlKey) 生産資源/治工具管理の管理キーを設定します。
void | setCtrlKeyNoChg(String ctrlKeyNoChg) 管理キーは変更できませんを設定します。
void | setEndOffset(String endOffset) 生産資源/治工具用途の終了オフセットを設定します。
void | setEndOffsetNoChg(String endOffsetNoChg) 終了オフセットは変更できませんを設定します。
void | setEndOffsetUnit(String endOffsetUnit) 生産資源/治工具使用終了オフセット単位を設定します。
void | setEndOffsetUnitIso(String endOffsetUnitIso) PRT 用途終了決定の間隔時間単位 (ISO)を設定します。
void | setEndRefDate(String endRefDate) 生産資源/治工具使用終了日の参照日付を設定します。
void | setEndRefDateNoChg(String endRefDateNoChg) 終了参照日付は変更できませんを設定します。
void | setFormulaTotQty(String formulaTotQty) 生産資源/治工具の合計数量の計算式を設定します。
void | setFormulaTotQtyNoChg(String formulaTotQtyNoChg) 合計数量の計算式は変更できませんを設定します。
void | setFormulaTotUsage(String formulaTotUsage) 生産資源/治工具の総用途値の計算式を設定します。
void | setFormulaTotUsageNoChg(String formulaTotUsageNoChg) すべての用途値を計算する計算式は変更できませんを設定します。
void | setGrpKey1(String grpKey1) 生産資源/治工具のグループキー 1を設定します。
void | setGrpKey2(String grpKey2) 生産資源/治工具のグループキー 2を設定します。
void | setPlant(String plant) プラントを設定します。
void | setPrtUsage(String prtUsage) 生産資源/治工具用途を設定します。
void | setRefKeyNoChg(String refKeyNoChg) 参照キーは変更できませんを設定します。
void | setStartOffset(String startOffset) 生産資源/治工具使用の開始オフセットを設定します。
void | setStartOffsetNoChg(String startOffsetNoChg) 開始オフセットは変更できませんを設定します。
void | setStartOffsetUnit(String startOffsetUnit) 生産資源/治工具使用開始のオフセット単位を設定します。
void | setStartOffsetUnitIso(String startOffsetUnitIso) PRT 用途開始決定の間隔時間単位 (ISO)を設定します。
void | setStartRefDate(String startRefDate) 生産資源/治工具使用開始の参照日付を設定します。
void | setStdTextKey(String stdTextKey) 生産資源/治工具の標準テキストキーを設定します。
void | setStRefDateNoChg(String stRefDateNoChg) 開始参照日付は変更できませんを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProductionResourceToolData

public ProductionResourceToolData()
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。

メソッドの詳細

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getCreateLoadRecs

public String getCreateLoadRecs()
区分: 生産資源/治工具の負荷レコード登録を取得します。

戻り値:
createLoadRecs 区分: 生産資源/治工具の負荷レコード登録

getCtrlKey

public String getCtrlKey()
生産資源/治工具管理の管理キーを取得します。

戻り値:
ctrlKey 生産資源/治工具管理の管理キー

getCtrlKeyNoChg

public String getCtrlKeyNoChg()
管理キーは変更できませんを取得します。

戻り値:
ctrlKeyNoChg 管理キーは変更できません

getGrpKey1

public String getGrpKey1()
生産資源/治工具のグループキー 1を取得します。

戻り値:
grpKey1 生産資源/治工具のグループキー 1

getGrpKey2

public String getGrpKey2()
生産資源/治工具のグループキー 2を取得します。

戻り値:
grpKey2 生産資源/治工具のグループキー 2

getPrtUsage

public String getPrtUsage()
生産資源/治工具用途を取得します。

戻り値:
prtUsage 生産資源/治工具用途

getStdTextKey

public String getStdTextKey()
生産資源/治工具の標準テキストキーを取得します。

戻り値:
stdTextKey 生産資源/治工具の標準テキストキー

getRefKeyNoChg

public String getRefKeyNoChg()
参照キーは変更できませんを取得します。

戻り値:
refKeyNoChg 参照キーは変更できません

getStartRefDate

public String getStartRefDate()
生産資源/治工具使用開始の参照日付を取得します。

戻り値:
startRefDate 生産資源/治工具使用開始の参照日付

getStRefDateNoChg

public String getStRefDateNoChg()
開始参照日付は変更できませんを取得します。

戻り値:
stRefDateNoChg 開始参照日付は変更できません

getStartOffset

public String getStartOffset()
生産資源/治工具使用の開始オフセットを取得します。

戻り値:
startOffset 生産資源/治工具使用の開始オフセット

getStartOffsetUnit

public String getStartOffsetUnit()
生産資源/治工具使用開始のオフセット単位を取得します。

戻り値:
startOffsetUnit 生産資源/治工具使用開始のオフセット単位

getStartOffsetUnitIso

public String getStartOffsetUnitIso()
PRT 用途開始決定の間隔時間単位 (ISO)を取得します。

戻り値:
startOffsetUnitIso PRT 用途開始決定の間隔時間単位 (ISO)

getStartOffsetNoChg

public String getStartOffsetNoChg()
開始オフセットは変更できませんを取得します。

戻り値:
startOffsetNoChg 開始オフセットは変更できません

getEndRefDate

public String getEndRefDate()
生産資源/治工具使用終了日の参照日付を取得します。

戻り値:
endRefDate 生産資源/治工具使用終了日の参照日付

getEndRefDateNoChg

public String getEndRefDateNoChg()
終了参照日付は変更できませんを取得します。

戻り値:
endRefDateNoChg 終了参照日付は変更できません

getEndOffset

public String getEndOffset()
生産資源/治工具用途の終了オフセットを取得します。

戻り値:
endOffset 生産資源/治工具用途の終了オフセット

getEndOffsetUnit

public String getEndOffsetUnit()
生産資源/治工具使用終了オフセット単位を取得します。

戻り値:
endOffsetUnit 生産資源/治工具使用終了オフセット単位

getEndOffsetUnitIso

public String getEndOffsetUnitIso()
PRT 用途終了決定の間隔時間単位 (ISO)を取得します。

戻り値:
endOffsetUnitIso PRT 用途終了決定の間隔時間単位 (ISO)

getEndOffsetNoChg

public String getEndOffsetNoChg()
終了オフセットは変更できませんを取得します。

戻り値:
endOffsetNoChg 終了オフセットは変更できません

getFormulaTotQty

public String getFormulaTotQty()
生産資源/治工具の合計数量の計算式を取得します。

戻り値:
formulaTotQty 生産資源/治工具の合計数量の計算式

getFormulaTotQtyNoChg

public String getFormulaTotQtyNoChg()
合計数量の計算式は変更できませんを取得します。

戻り値:
formulaTotQtyNoChg 合計数量の計算式は変更できません

getFormulaTotUsage

public String getFormulaTotUsage()
生産資源/治工具の総用途値の計算式を取得します。

戻り値:
formulaTotUsage 生産資源/治工具の総用途値の計算式

getFormulaTotUsageNoChg

public String getFormulaTotUsageNoChg()
すべての用途値を計算する計算式は変更できませんを取得します。

戻り値:
formulaTotUsageNoChg すべての用途値を計算する計算式は変更できません

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setCreateLoadRecs

public void setCreateLoadRecs(String createLoadRecs)
区分: 生産資源/治工具の負荷レコード登録を設定します。

パラメータ:
createLoadRecs - 区分: 生産資源/治工具の負荷レコード登録

setCtrlKey

public void setCtrlKey(String ctrlKey)
生産資源/治工具管理の管理キーを設定します。

パラメータ:
ctrlKey - 生産資源/治工具管理の管理キー

setCtrlKeyNoChg

public void setCtrlKeyNoChg(String ctrlKeyNoChg)
管理キーは変更できませんを設定します。

パラメータ:
ctrlKeyNoChg - 管理キーは変更できません

setGrpKey1

public void setGrpKey1(String grpKey1)
生産資源/治工具のグループキー 1を設定します。

パラメータ:
grpKey1 - 生産資源/治工具のグループキー 1

setGrpKey2

public void setGrpKey2(String grpKey2)
生産資源/治工具のグループキー 2を設定します。

パラメータ:
grpKey2 - 生産資源/治工具のグループキー 2

setPrtUsage

public void setPrtUsage(String prtUsage)
生産資源/治工具用途を設定します。

パラメータ:
prtUsage - 生産資源/治工具用途

setStdTextKey

public void setStdTextKey(String stdTextKey)
生産資源/治工具の標準テキストキーを設定します。

パラメータ:
stdTextKey - 生産資源/治工具の標準テキストキー

setRefKeyNoChg

public void setRefKeyNoChg(String refKeyNoChg)
参照キーは変更できませんを設定します。

パラメータ:
refKeyNoChg - 参照キーは変更できません

setStartRefDate

public void setStartRefDate(String startRefDate)
生産資源/治工具使用開始の参照日付を設定します。

パラメータ:
startRefDate - 生産資源/治工具使用開始の参照日付

setStRefDateNoChg

public void setStRefDateNoChg(String stRefDateNoChg)
開始参照日付は変更できませんを設定します。

パラメータ:
stRefDateNoChg - 開始参照日付は変更できません

setStartOffset

public void setStartOffset(String startOffset)
生産資源/治工具使用の開始オフセットを設定します。

パラメータ:
startOffset - 生産資源/治工具使用の開始オフセット

setStartOffsetUnit

public void setStartOffsetUnit(String startOffsetUnit)
生産資源/治工具使用開始のオフセット単位を設定します。

パラメータ:
startOffsetUnit - 生産資源/治工具使用開始のオフセット単位

setStartOffsetUnitIso

public void setStartOffsetUnitIso(String startOffsetUnitIso)
PRT 用途開始決定の間隔時間単位 (ISO)を設定します。

パラメータ:
startOffsetUnitIso - PRT 用途開始決定の間隔時間単位 (ISO)

setStartOffsetNoChg

public void setStartOffsetNoChg(String startOffsetNoChg)
開始オフセットは変更できませんを設定します。

パラメータ:
startOffsetNoChg - 開始オフセットは変更できません

setEndRefDate

public void setEndRefDate(String endRefDate)
生産資源/治工具使用終了日の参照日付を設定します。

パラメータ:
endRefDate - 生産資源/治工具使用終了日の参照日付

setEndRefDateNoChg

public void setEndRefDateNoChg(String endRefDateNoChg)
終了参照日付は変更できませんを設定します。

パラメータ:
endRefDateNoChg - 終了参照日付は変更できません

setEndOffset

public void setEndOffset(String endOffset)
生産資源/治工具用途の終了オフセットを設定します。

パラメータ:
endOffset - 生産資源/治工具用途の終了オフセット

setEndOffsetUnit

public void setEndOffsetUnit(String endOffsetUnit)
生産資源/治工具使用終了オフセット単位を設定します。

パラメータ:
endOffsetUnit - 生産資源/治工具使用終了オフセット単位

setEndOffsetUnitIso

public void setEndOffsetUnitIso(String endOffsetUnitIso)
PRT 用途終了決定の間隔時間単位 (ISO)を設定します。

パラメータ:
endOffsetUnitIso - PRT 用途終了決定の間隔時間単位 (ISO)

setEndOffsetNoChg

public void setEndOffsetNoChg(String endOffsetNoChg)
終了オフセットは変更できませんを設定します。

パラメータ:
endOffsetNoChg - 終了オフセットは変更できません

setFormulaTotQty

public void setFormulaTotQty(String formulaTotQty)
生産資源/治工具の合計数量の計算式を設定します。

パラメータ:
formulaTotQty - 生産資源/治工具の合計数量の計算式

setFormulaTotQtyNoChg

public void setFormulaTotQtyNoChg(String formulaTotQtyNoChg)
合計数量の計算式は変更できませんを設定します。

パラメータ:
formulaTotQtyNoChg - 合計数量の計算式は変更できません

setFormulaTotUsage

public void setFormulaTotUsage(String formulaTotUsage)
生産資源/治工具の総用途値の計算式を設定します。

パラメータ:
formulaTotUsage - 生産資源/治工具の総用途値の計算式

setFormulaTotUsageNoChg

public void setFormulaTotUsageNoChg(String formulaTotUsageNoChg)
すべての用途値を計算する計算式は変更できませんを設定します。

パラメータ:
formulaTotUsageNoChg - すべての用途値を計算する計算式は変更できません

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn の使用

ExtensionIn を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での ExtensionIn の使用

ExtensionIn を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 ExtensionIn MaterialSaveReplicaController.getExtensionIn(int index)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造が既に存在するか チェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX の使用

ExtensionInX を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での ExtensionInX の使用

ExtensionInX を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 ExtensionInX MaterialSaveReplicaController.getExtensionInX(int index)
拡張イン/拡張アウトのチェックボックス構造が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues の使用

ForecastValues を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での ForecastValues の使用

ForecastValues を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 ForecastValues MaterialSaveReplicaController.getForecastValues(int index)
需要予測値のデータ転送が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData の使用

HeadData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での HeadData の使用

HeadData を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 HeadData MaterialSaveReplicaController.getHeadData(int index)
管理情報設定ヘッダセグメントが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos の使用

InternationalArtnos を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での InternationalArtnos の使用

InternationalArtnos を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 InternationalArtnos MaterialSaveReplicaController.getInternationalArtnos(int index)
国際商品コード (EAN)が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText の使用

MaterialLongText を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での MaterialLongText の使用

MaterialLongText を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 MaterialLongText MaterialSaveReplicaController.getMaterialLongText(int index)
テキスト (長)が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica の使用

MaterialSaveReplica を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での MaterialSaveReplica の使用

jp.co.intra_mart.foundation.sap.module.purchase での MaterialSaveReplica のサブクラス
 class MaterialSaveReplicaController
品目マスタ更新コントローラクラス
機能は以下の通り
品目マスタを更新します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData の使用

PrtData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PrtData の使用

PrtData を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 PrtData MaterialSaveReplicaController.getPrtData(int index)
品目マスタの生産資源/治工具 (PRT) 項目が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption の使用

TotalConsumption を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での TotalConsumption の使用

TotalConsumption を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 TotalConsumption MaterialSaveReplicaController.getTotalConsumption(int index)
品目総消費量のデータ転送が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption の使用

UnplndConsumption を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での UnplndConsumption の使用

UnplndConsumption を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 UnplndConsumption MaterialSaveReplicaController.getUnplndConsumption(int index)
計画外消費のデータ転送が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ExtensionIn (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ExtensionIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn
すべての実装インタフェース:
Serializable
public class ExtensionIn
extends Object
implements Serializable

BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報クラス
機能は以下の通り

  • BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExtensionIn()
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。
ExtensionIn(int index)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。
メソッドの概要
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getMaterial() 品目コードを取得します。
String | getStructure() BAPI テーブル拡張の構造名を取得します。
String | getValuepart1() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart2() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart3() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart4() 長さ 229 の文字データのコンテナを取得します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMaterial(String material) 品目コードを設定します。
void | setStructure(String structure) BAPI テーブル拡張の構造名を設定します。
void | setValuepart1(String valuepart1) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart2(String valuepart2) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart3(String valuepart3) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart4(String valuepart4) 長さ 229 の文字データのコンテナを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtensionIn

public ExtensionIn()
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。

ExtensionIn

public ExtensionIn(int index)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getStructure

public String getStructure()
BAPI テーブル拡張の構造名を取得します。

戻り値:
structure BAPI テーブル拡張の構造名

getValuepart1

public String getValuepart1()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart1 BAPI 拡張パラメータのデータ部分

getValuepart2

public String getValuepart2()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart2 BAPI 拡張パラメータのデータ部分

getValuepart3

public String getValuepart3()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart3 BAPI 拡張パラメータのデータ部分

getValuepart4

public String getValuepart4()
長さ 229 の文字データのコンテナを取得します。

戻り値:
valuepart4 長さ 229 の文字データのコンテナ

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setStructure

public void setStructure(String structure)
BAPI テーブル拡張の構造名を設定します。

パラメータ:
structure - BAPI テーブル拡張の構造名

setValuepart1

public void setValuepart1(String valuepart1)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart1 - BAPI 拡張パラメータのデータ部分

setValuepart2

public void setValuepart2(String valuepart2)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart2 - BAPI 拡張パラメータのデータ部分

setValuepart3

public void setValuepart3(String valuepart3)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart3 - BAPI 拡張パラメータのデータ部分

setValuepart4

public void setValuepart4(String valuepart4)
長さ 229 の文字データのコンテナを設定します。

パラメータ:
valuepart4 - 長さ 229 の文字データのコンテナ

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtensionInX (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ExtensionInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX
すべての実装インタフェース:
Serializable
public class ExtensionInX
extends Object
implements Serializable

拡張イン/拡張アウトのチェックボックス構造情報クラス
機能は以下の通り

  • 拡張イン/拡張アウトのチェックボックス構造情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExtensionInX()
拡張イン/拡張アウトのチェックボックス構造情報を作成します。
ExtensionInX(int index)
拡張イン/拡張アウトのチェックボックス構造情報を作成します。
メソッドの概要
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getMaterial() 品目コードを取得します。
String | getStructure() BAPI テーブル拡張の構造名を取得します。
String | getValuepart1() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart2() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart3() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart4() 長さ 229 の文字データのコンテナを取得します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMaterial(String material) 品目コードを設定します。
void | setStructure(String structure) BAPI テーブル拡張の構造名を設定します。
void | setValuepart1(String valuepart1) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart2(String valuepart2) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart3(String valuepart3) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart4(String valuepart4) 長さ 229 の文字データのコンテナを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtensionInX

public ExtensionInX()
拡張イン/拡張アウトのチェックボックス構造情報を作成します。

ExtensionInX

public ExtensionInX(int index)
拡張イン/拡張アウトのチェックボックス構造情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getStructure

public String getStructure()
BAPI テーブル拡張の構造名を取得します。

戻り値:
structure BAPI テーブル拡張の構造名

getValuepart1

public String getValuepart1()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart1 BAPI 拡張パラメータのデータ部分

getValuepart2

public String getValuepart2()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart2 BAPI 拡張パラメータのデータ部分

getValuepart3

public String getValuepart3()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart3 BAPI 拡張パラメータのデータ部分

getValuepart4

public String getValuepart4()
長さ 229 の文字データのコンテナを取得します。

戻り値:
valuepart4 長さ 229 の文字データのコンテナ

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setStructure

public void setStructure(String structure)
BAPI テーブル拡張の構造名を設定します。

パラメータ:
structure - BAPI テーブル拡張の構造名

setValuepart1

public void setValuepart1(String valuepart1)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart1 - BAPI 拡張パラメータのデータ部分

setValuepart2

public void setValuepart2(String valuepart2)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart2 - BAPI 拡張パラメータのデータ部分

setValuepart3

public void setValuepart3(String valuepart3)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart3 - BAPI 拡張パラメータのデータ部分

setValuepart4

public void setValuepart4(String valuepart4)
長さ 229 の文字データのコンテナを設定します。

パラメータ:
valuepart4 - 長さ 229 の文字データのコンテナ

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ForecastValues (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ForecastValues

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues
すべての実装インタフェース:
Serializable
public class ForecastValues
extends Object
implements Serializable

需要予測値のデータ転送情報クラス
機能は以下の通り

  • 需要予測値のデータ転送情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ForecastValues()
需要予測値のデータ転送情報を作成します。
ForecastValues(int index)
需要予測値のデータ転送情報を作成します。
メソッドの概要
String | getCorrValue() 需要予測に対する修正値を取得します。
String | getCvalueFxd() 区分: 消費金額の確定を取得します。
String | getExpostVal() 事後的需要予測値を取得します。
String | getFirstDay() 値参照期間の第一日目を取得します。
String | getForeValue() 予測値を取得します。
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getPlant() プラントを取得します。
String | getSeasIndex() 季節指数を取得します。
String | getValRatio() 元値に対する修正値の比率 (修正値: 元値)を取得します。
void | setCorrValue(String corrValue) 需要予測に対する修正値を設定します。
void | setCvalueFxd(String cvalueFxd) 区分: 消費金額の確定を設定します。
void | setExpostVal(String expostVal) 事後的需要予測値を設定します。
void | setFirstDay(String firstDay) 値参照期間の第一日目を設定します。
void | setForeValue(String foreValue) 予測値を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setPlant(String plant) プラントを設定します。
void | setSeasIndex(String seasIndex) 季節指数を設定します。
void | setValRatio(String valRatio) 元値に対する修正値の比率 (修正値: 元値)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ForecastValues

public ForecastValues()
需要予測値のデータ転送情報を作成します。

ForecastValues

public ForecastValues(int index)
需要予測値のデータ転送情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getFirstDay

public String getFirstDay()
値参照期間の第一日目を取得します。

戻り値:
firstDay 値参照期間の第一日目

getForeValue

public String getForeValue()
予測値を取得します。

戻り値:
foreValue 予測値

getCorrValue

public String getCorrValue()
需要予測に対する修正値を取得します。

戻り値:
corrValue 需要予測に対する修正値

getSeasIndex

public String getSeasIndex()
季節指数を取得します。

戻り値:
seasIndex 季節指数

getCvalueFxd

public String getCvalueFxd()
区分: 消費金額の確定を取得します。

戻り値:
cvalueFxd 区分: 消費金額の確定

getExpostVal

public String getExpostVal()
事後的需要予測値を取得します。

戻り値:
expostVal 事後的需要予測値

getValRatio

public String getValRatio()
元値に対する修正値の比率 (修正値: 元値)を取得します。

戻り値:
valRatio 元値に対する修正値の比率 (修正値: 元値)

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setFirstDay

public void setFirstDay(String firstDay)
値参照期間の第一日目を設定します。

パラメータ:
firstDay - 値参照期間の第一日目

setForeValue

public void setForeValue(String foreValue)
予測値を設定します。

パラメータ:
foreValue - 予測値

setCorrValue

public void setCorrValue(String corrValue)
需要予測に対する修正値を設定します。

パラメータ:
corrValue - 需要予測に対する修正値

setSeasIndex

public void setSeasIndex(String seasIndex)
季節指数を設定します。

パラメータ:
seasIndex - 季節指数

setCvalueFxd

public void setCvalueFxd(String cvalueFxd)
区分: 消費金額の確定を設定します。

パラメータ:
cvalueFxd - 区分: 消費金額の確定

setExpostVal

public void setExpostVal(String expostVal)
事後的需要予測値を設定します。

パラメータ:
expostVal - 事後的需要予測値

setValRatio

public void setValRatio(String valRatio)
元値に対する修正値の比率 (修正値: 元値)を設定します。

パラメータ:
valRatio - 元値に対する修正値の比率 (修正値: 元値)

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HeadData (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス HeadData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData
すべての実装インタフェース:
Serializable
public class HeadData
extends Object
implements Serializable

管理情報設定ヘッダセグメント情報クラス
機能は以下の通り

  • 管理情報設定ヘッダセグメント情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
HeadData()
管理情報設定ヘッダセグメント情報を作成します。
HeadData(int index)
管理情報設定ヘッダセグメント情報を作成します。
メソッドの概要
String | getAccountView() 会計ビューを取得します。
String | getBasicView() 基本データビューを取得します。
String | getCostView() 原価計算ビューを取得します。
String | getForecastView() 需要予測ビューを取得します。
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getIndSector() 産業コードを取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getMatlType() 品目タイプを取得します。
String | getMrpView() 資材所要量計画 (MRP) ビューを取得します。
String | getPrtView() 生産資源/治工具 (PRT) ビューを取得します。
String | getPurchaseView() 購買管理ビューを取得します。
String | getQualityView() 品質管理ビューを取得します。
String | getSalesView() 販売ビューを取得します。
String | getStorageView() 保管ビューを取得します。
String | getWarehouseView() 倉庫管理ビューを取得します。
String | getWorkSchedView() 作業計画ビューを取得します。
void | setAccountView(String accountView) 会計ビューを設定します。
void | setBasicView(String basicView) 基本データビューを設定します。
void | setCostView(String costView) 原価計算ビューを設定します。
void | setForecastView(String forecastView) 需要予測ビューを設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setIndSector(String indSector) 産業コードを設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setMatlType(String matlType) 品目タイプを設定します。
void | setMrpView(String mrpView) 資材所要量計画 (MRP) ビューを設定します。
void | setPrtView(String prtView) 生産資源/治工具 (PRT) ビューを設定します。
void | setPurchaseView(String purchaseView) 購買管理ビューを設定します。
void | setQualityView(String qualityView) 品質管理ビューを設定します。
void | setSalesView(String salesView) 販売ビューを設定します。
void | setStorageView(String storageView) 保管ビューを設定します。
void | setWarehouseView(String warehouseView) 倉庫管理ビューを設定します。
void | setWorkSchedView(String workSchedView) 作業計画ビューを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HeadData

public HeadData()
管理情報設定ヘッダセグメント情報を作成します。

HeadData

public HeadData(int index)
管理情報設定ヘッダセグメント情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getIndSector

public String getIndSector()
産業コードを取得します。

戻り値:
indSector 産業コード

getMatlType

public String getMatlType()
品目タイプを取得します。

戻り値:
matlType 品目タイプ

getBasicView

public String getBasicView()
基本データビューを取得します。

戻り値:
basicView 基本データビュー

getSalesView

public String getSalesView()
販売ビューを取得します。

戻り値:
salesView 販売ビュー

getPurchaseView

public String getPurchaseView()
購買管理ビューを取得します。

戻り値:
purchaseView 購買管理ビュー

getMrpView

public String getMrpView()
資材所要量計画 (MRP) ビューを取得します。

戻り値:
mrpView 資材所要量計画 (MRP) ビュー

getForecastView

public String getForecastView()
需要予測ビューを取得します。

戻り値:
forecastView 需要予測ビュー

getWorkSchedView

public String getWorkSchedView()
作業計画ビューを取得します。

戻り値:
workSchedView 作業計画ビュー

getPrtView

public String getPrtView()
生産資源/治工具 (PRT) ビューを取得します。

戻り値:
prtView 生産資源/治工具 (PRT) ビュー

getStorageView

public String getStorageView()
保管ビューを取得します。

戻り値:
storageView 保管ビュー

getWarehouseView

public String getWarehouseView()
倉庫管理ビューを取得します。

戻り値:
warehouseView 倉庫管理ビュー

getQualityView

public String getQualityView()
品質管理ビューを取得します。

戻り値:
qualityView 品質管理ビュー

getAccountView

public String getAccountView()
会計ビューを取得します。

戻り値:
accountView 会計ビュー

getCostView

public String getCostView()
原価計算ビューを取得します。

戻り値:
costView 原価計算ビュー

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setIndSector

public void setIndSector(String indSector)
産業コードを設定します。

パラメータ:
indSector - 産業コード

setMatlType

public void setMatlType(String matlType)
品目タイプを設定します。

パラメータ:
matlType - 品目タイプ

setBasicView

public void setBasicView(String basicView)
基本データビューを設定します。

パラメータ:
basicView - 基本データビュー

setSalesView

public void setSalesView(String salesView)
販売ビューを設定します。

パラメータ:
salesView - 販売ビュー

setPurchaseView

public void setPurchaseView(String purchaseView)
購買管理ビューを設定します。

パラメータ:
purchaseView - 購買管理ビュー

setMrpView

public void setMrpView(String mrpView)
資材所要量計画 (MRP) ビューを設定します。

パラメータ:
mrpView - 資材所要量計画 (MRP) ビュー

setForecastView

public void setForecastView(String forecastView)
需要予測ビューを設定します。

パラメータ:
forecastView - 需要予測ビュー

setWorkSchedView

public void setWorkSchedView(String workSchedView)
作業計画ビューを設定します。

パラメータ:
workSchedView - 作業計画ビュー

setPrtView

public void setPrtView(String prtView)
生産資源/治工具 (PRT) ビューを設定します。

パラメータ:
prtView - 生産資源/治工具 (PRT) ビュー

setStorageView

public void setStorageView(String storageView)
保管ビューを設定します。

パラメータ:
storageView - 保管ビュー

setWarehouseView

public void setWarehouseView(String warehouseView)
倉庫管理ビューを設定します。

パラメータ:
warehouseView - 倉庫管理ビュー

setQualityView

public void setQualityView(String qualityView)
品質管理ビューを設定します。

パラメータ:
qualityView - 品質管理ビュー

setAccountView

public void setAccountView(String accountView)
会計ビューを設定します。

パラメータ:
accountView - 会計ビュー

setCostView

public void setCostView(String costView)
原価計算ビューを設定します。

パラメータ:
costView - 原価計算ビュー

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalArtnos (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス InternationalArtnos

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos
すべての実装インタフェース:
Serializable
public class InternationalArtnos
extends Object
implements Serializable

国際商品コード (EAN)情報クラス
機能は以下の通り

  • 国際商品コード (EAN)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
InternationalArtnos()
国際商品コード (EAN)情報を作成します。
InternationalArtnos(int index)
国際商品コード (EAN)情報を作成します。
メソッドの概要
String | getDelFlag() データレコード削除 (テーブル繰返し)を取得します。
String | getEanCat() 国際商品コード (EAN) のカテゴリを取得します。
String | getEanUpc() 国際商品コード (EAN/UPC)を取得します。
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getMaterial() 品目コードを取得します。
String | getUnit() 表示数量単位を取得します。
String | getUnitIso() ISO コードでの表示数量単位を取得します。
void | setDelFlag(String delFlag) データレコード削除 (テーブル繰返し)を設定します。
void | setEanCat(String eanCat) 国際商品コード (EAN) のカテゴリを設定します。
void | setEanUpc(String eanUpc) 国際商品コード (EAN/UPC)を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMaterial(String material) 品目コードを設定します。
void | setUnit(String unit) 表示数量単位を設定します。
void | setUnitIso(String unitIso) ISO コードでの表示数量単位を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

InternationalArtnos

public InternationalArtnos()
国際商品コード (EAN)情報を作成します。

InternationalArtnos

public InternationalArtnos(int index)
国際商品コード (EAN)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getUnit

public String getUnit()
表示数量単位を取得します。

戻り値:
unit 表示数量単位

getUnitIso

public String getUnitIso()
ISO コードでの表示数量単位を取得します。

戻り値:
unitIso ISO コードでの表示数量単位

getEanUpc

public String getEanUpc()
国際商品コード (EAN/UPC)を取得します。

戻り値:
eanUpc 国際商品コード (EAN/UPC)

getEanCat

public String getEanCat()
国際商品コード (EAN) のカテゴリを取得します。

戻り値:
eanCat 国際商品コード (EAN) のカテゴリ

getDelFlag

public String getDelFlag()
データレコード削除 (テーブル繰返し)を取得します。

戻り値:
delFlag データレコード削除 (テーブル繰返し)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setUnit

public void setUnit(String unit)
表示数量単位を設定します。

パラメータ:
unit - 表示数量単位

setUnitIso

public void setUnitIso(String unitIso)
ISO コードでの表示数量単位を設定します。

パラメータ:
unitIso - ISO コードでの表示数量単位

setEanUpc

public void setEanUpc(String eanUpc)
国際商品コード (EAN/UPC)を設定します。

パラメータ:
eanUpc - 国際商品コード (EAN/UPC)

setEanCat

public void setEanCat(String eanCat)
国際商品コード (EAN) のカテゴリを設定します。

パラメータ:
eanCat - 国際商品コード (EAN) のカテゴリ

setDelFlag

public void setDelFlag(String delFlag)
データレコード削除 (テーブル繰返し)を設定します。

パラメータ:
delFlag - データレコード削除 (テーブル繰返し)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialLongText (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス MaterialLongText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText
すべての実装インタフェース:
Serializable
public class MaterialLongText
extends Object
implements Serializable

テキスト (長)情報クラス
機能は以下の通り

  • テキスト (長)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MaterialLongText()
テキスト (長)情報を作成します。
MaterialLongText(int index)
テキスト (長)情報を作成します。
メソッドの概要
String | getApplobject() テキスト: アプリケーションオブジェクトを取得します。
String | getDelFlag() データレコード削除 (テーブル繰返し)を取得します。
String | getFormatCol() タグ列を取得します。
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getLangu() 言語キーを取得します。
String | getLanguIso() ISO 639 準拠の言語を取得します。
String | getMaterial() 品目コードを取得します。
String | getTextId() テキスト IDを取得します。
String | getTextLine() テキスト行を取得します。
String | getTextName() 名称を取得します。
void | setApplobject(String applobject) テキスト: アプリケーションオブジェクトを設定します。
void | setDelFlag(String delFlag) データレコード削除 (テーブル繰返し)を設定します。
void | setFormatCol(String formatCol) タグ列を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLangu(String langu) 言語キーを設定します。
void | setLanguIso(String languIso) ISO 639 準拠の言語を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setTextId(String textId) テキスト IDを設定します。
void | setTextLine(String textLine) テキスト行を設定します。
void | setTextName(String textName) 名称を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialLongText

public MaterialLongText()
テキスト (長)情報を作成します。

MaterialLongText

public MaterialLongText(int index)
テキスト (長)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getApplobject

public String getApplobject()
テキスト: アプリケーションオブジェクトを取得します。

戻り値:
applobject テキスト: アプリケーションオブジェクト

getTextName

public String getTextName()
名称を取得します。

戻り値:
textName 名称

getTextId

public String getTextId()
テキスト IDを取得します。

戻り値:
textId テキスト ID

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
langu 言語キー

getLanguIso

public String getLanguIso()
ISO 639 準拠の言語を取得します。

戻り値:
languIso ISO 639 準拠の言語

getFormatCol

public String getFormatCol()
タグ列を取得します。

戻り値:
formatCol タグ列

getTextLine

public String getTextLine()
テキスト行を取得します。

戻り値:
textLine テキスト行

getDelFlag

public String getDelFlag()
データレコード削除 (テーブル繰返し)を取得します。

戻り値:
delFlag データレコード削除 (テーブル繰返し)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setApplobject

public void setApplobject(String applobject)
テキスト: アプリケーションオブジェクトを設定します。

パラメータ:
applobject - テキスト: アプリケーションオブジェクト

setTextName

public void setTextName(String textName)
名称を設定します。

パラメータ:
textName - 名称

setTextId

public void setTextId(String textId)
テキスト IDを設定します。

パラメータ:
textId - テキスト ID

setLangu

public void setLangu(String langu)
言語キーを設定します。

パラメータ:
langu - 言語キー

setLanguIso

public void setLanguIso(String languIso)
ISO 639 準拠の言語を設定します。

パラメータ:
languIso - ISO 639 準拠の言語

setFormatCol

public void setFormatCol(String formatCol)
タグ列を設定します。

パラメータ:
formatCol - タグ列

setTextLine

public void setTextLine(String textLine)
テキスト行を設定します。

パラメータ:
textLine - テキスト行

setDelFlag

public void setDelFlag(String delFlag)
データレコード削除 (テーブル繰返し)を設定します。

パラメータ:
delFlag - データレコード削除 (テーブル繰返し)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialSaveReplica (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス MaterialSaveReplica

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
MaterialSaveReplicaController
public class MaterialSaveReplica
extends UpdateController
implements Serializable

品目マスタ更新情報クラス
機能は以下の通り

  • 品目マスタ更新情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
MaterialSaveReplica()
品目マスタ更新情報を作成します。
MaterialSaveReplica(ConnectionManager connectionManager)
品目マスタ更新情報を作成します。
MaterialSaveReplica(SapClient sapClient)
品目マスタ更新情報を作成します。
メソッドの概要
List | getClientDataList() 品目データ (クライアントレベル)を取得します。
List | getExtensionInList() BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。
List | getExtensionInXList() 拡張イン/拡張アウトのチェックボックス構造を取得します。
String | getFlagCadCall() CAD システムからコールを取得します。
List | getForecastParametersList() 需要予測パラメータを取得します。
List | getForecastValuesList() 需要予測値のデータ転送を取得します。
List | getHeadDataList() 管理情報設定ヘッダセグメントを取得します。
String | getInpfldcheck() 項目無効時の応答を取得します。
List | getInternationalArtnosList() 国際商品コード (EAN)を取得します。
List | getMaterialDescriptionList() 品目テキストを取得します。
List | getMaterialLongTextList() テキスト (長)を取得します。
String | getNoappllog() アプリケーションログ書込なしを取得します。
String | getNochangedoc() 変更伝票書込なしを取得します。
List | getPlanningDataList() 品目マスタ/製品グループの変更伝票構造を取得します。
List | getPlantDataList() 品目データ (プラントレベル)を取得します。
List | getPrtDataList() 品目マスタの生産資源/治工具 (PRT) 項目を取得します。
List | getReturnMessagesList() リターンパラメータ BAPIRET2 の代替構造を取得します。
List | getSalesDataList() 販売データを取得します。
List | getStorageLocationDataList() 品目データ (保管場所レベル)を取得します。
List | getStorageTypeDataList() 保管域タイプデータを取得します。
List | getTaxClassificationsList() 制御デ－タを取得します。
String | getTestrun() 書込 BAPI のシミュレーションセッションへの切替を取得します。
List | getTotalConsumptionList() 品目総消費量のデータ転送を取得します。
List | getUnitSofmeasureList() 数量単位を取得します。
List | getUnplndConsumptionList() 計画外消費のデータ転送を取得します。
List | getValuationDataList() 評価データを取得します。
List | getWarehouseNumberDataList() 倉庫番号データを取得します。
void | initMaterialSaveReplica() 品目マスタ更新情報の各種インスタンスを生成します。
void | setClientDataList(List clientDataList) 品目データ (クライアントレベル)を設定します。
void | setExportParam(BapiController bapiController) 品目マスタに登録する値ををセットします。
void | setExtensionInList(List extensionInList) BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を設定します。
void | setExtensionInXList(List extensionInXList) 拡張イン/拡張アウトのチェックボックス構造を設定します。
void | setFlagCadCall(String flagCadCall) CAD システムからコールを設定します。
void | setForecastParametersList(List forecastParametersList) 需要予測パラメータを設定します。
void | setForecastValuesList(List forecastValuesList) 需要予測値のデータ転送を設定します。
void | setHeadDataList(List headDataList) 管理情報設定ヘッダセグメントを設定します。
void | setImportParam(BapiController bapiController) 品目マスタに登録する値ををセットします。
void | setInpfldcheck(String inpFldCheck) 項目無効時の応答を設定します。
void | setInternationalArtnosList(List internationalArtnosList) 国際商品コード (EAN)を設定します。
void | setMaterialDescriptionList(List materialDescriptionList) 品目テキストを設定します。
void | setMaterialLongTextList(List materialLongTextList) テキスト (長)を設定します。
void | setNoappllog(String noApplLog) アプリケーションログ書込なしを設定します。
void | setNochangedoc(String noChangeDoc) 変更伝票書込なしを設定します。
void | setPlanningDataList(List planningDataList) 品目マスタ/製品グループの変更伝票構造を設定します。
void | setPlantDataList(List plantDataList) 品目データ (プラントレベル)を設定します。
void | setPrtDataList(List prtDataList) 品目マスタの生産資源/治工具 (PRT) 項目を設定します。
void | setReturnMessagesList(List returnMessagesList) リターンパラメータ BAPIRET2 の代替構造を設定します。
void | setSalesDataList(List salesDataList) 販売データを設定します。
void | setStorageLocationDataList(List storageLocationDataList) 品目データ (保管場所レベル)を設定します。
void | setStorageTypeDataList(List storageTypeDataList) 保管域タイプデータを設定します。
void | setTaxClassificationsList(List taxClassificationsList) 制御デ－タを設定します。
void | setTestrun(String testRun) 書込 BAPI のシミュレーションセッションへの切替を設定します。
void | setTotalConsumptionList(List totalConsumptionList) 品目総消費量のデータ転送を設定します。
void | setUnitSofmeasureList(List unitSofmeasureList) 数量単位を設定します。
void | setUnplndConsumptionList(List unplndConsumptionList) 計画外消費のデータ転送を設定します。
void | setValuationDataList(List valuationDataList) 評価データを設定します。
void | setWarehouseNumberDataList(List warehouseNumberDataList) 倉庫番号データを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialSaveReplica

public MaterialSaveReplica()
品目マスタ更新情報を作成します。

MaterialSaveReplica

public MaterialSaveReplica(ConnectionManager connectionManager)
品目マスタ更新情報を作成します。

パラメータ:
connectionManager - コネクションオブジェクト

MaterialSaveReplica

public MaterialSaveReplica(SapClient sapClient)
品目マスタ更新情報を作成します。

パラメータ:
sapClient - SAPクライアント
メソッドの詳細

initMaterialSaveReplica

public void initMaterialSaveReplica()
品目マスタ更新情報の各種インスタンスを生成します。

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
品目マスタに登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
品目マスタに登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getNochangedoc

public String getNochangedoc()
変更伝票書込なしを取得します。

戻り値:
nochangedoc 変更伝票書込なし

getNoappllog

public String getNoappllog()
アプリケーションログ書込なしを取得します。

戻り値:
noappllog アプリケーションログ書込なし

getTestrun

public String getTestrun()
書込 BAPI のシミュレーションセッションへの切替を取得します。

戻り値:
testrun 書込 BAPI のシミュレーションセッションへの切替

getInpfldcheck

public String getInpfldcheck()
項目無効時の応答を取得します。

戻り値:
inpfldcheck 項目無効時の応答

getFlagCadCall

public String getFlagCadCall()
CAD システムからコールを取得します。

戻り値:
flagCadCall CAD システムからコール

getHeadDataList

public List getHeadDataList()
管理情報設定ヘッダセグメントを取得します。

戻り値:
headDataList 管理情報設定ヘッダセグメント

getClientDataList

public List getClientDataList()
品目データ (クライアントレベル)を取得します。

戻り値:
clientDataList 品目データ (クライアントレベル)

getPlantDataList

public List getPlantDataList()
品目データ (プラントレベル)を取得します。

戻り値:
plantDataList 品目データ (プラントレベル)

getForecastParametersList

public List getForecastParametersList()
需要予測パラメータを取得します。

戻り値:
forecastParametersList 需要予測パラメータ

getPlanningDataList

public List getPlanningDataList()
品目マスタ/製品グループの変更伝票構造を取得します。

戻り値:
planningDataList 品目マスタ/製品グループの変更伝票構造

getStorageLocationDataList

public List getStorageLocationDataList()
品目データ (保管場所レベル)を取得します。

戻り値:
storageLocationDataList 品目データ (保管場所レベル)

getValuationDataList

public List getValuationDataList()
評価データを取得します。

戻り値:
valuationDataList 評価データ

getWarehouseNumberDataList

public List getWarehouseNumberDataList()
倉庫番号データを取得します。

戻り値:
warehouseNumberDataList 倉庫番号データ

getSalesDataList

public List getSalesDataList()
販売データを取得します。

戻り値:
salesDataList 販売データ

getStorageTypeDataList

public List getStorageTypeDataList()
保管域タイプデータを取得します。

戻り値:
storageTypeDataList 保管域タイプデータ

getMaterialDescriptionList

public List getMaterialDescriptionList()
品目テキストを取得します。

戻り値:
materialDescriptionList 品目テキスト

getUnitSofmeasureList

public List getUnitSofmeasureList()
数量単位を取得します。

戻り値:
unitSofmeasureList 数量単位

getInternationalArtnosList

public List getInternationalArtnosList()
国際商品コード (EAN)を取得します。

戻り値:
internationalArtnosList 国際商品コード (EAN)

getMaterialLongTextList

public List getMaterialLongTextList()
テキスト (長)を取得します。

戻り値:
materialLongTextList テキスト (長)

getTaxClassificationsList

public List getTaxClassificationsList()
制御デ－タを取得します。

戻り値:
taxClassificationsList 制御デ－タ

getPrtDataList

public List getPrtDataList()
品目マスタの生産資源/治工具 (PRT) 項目を取得します。

戻り値:
prtDataList 品目マスタの生産資源/治工具 (PRT) 項目

getExtensionInList

public List getExtensionInList()
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。

戻り値:
extensionInList BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の 参照構造

getExtensionInXList

public List getExtensionInXList()
拡張イン/拡張アウトのチェックボックス構造を取得します。

戻り値:
extensionInXList 拡張イン/拡張アウトのチェックボックス構造

getForecastValuesList

public List getForecastValuesList()
需要予測値のデータ転送を取得します。

戻り値:
forecastValuesList 需要予測値のデータ転送

getUnplndConsumptionList

public List getUnplndConsumptionList()
計画外消費のデータ転送を取得します。

戻り値:
unplndConsumptionList 計画外消費のデータ転送

getTotalConsumptionList

public List getTotalConsumptionList()
品目総消費量のデータ転送を取得します。

戻り値:
totalConsumptionList 品目総消費量のデータ転送

getReturnMessagesList

public List getReturnMessagesList()
リターンパラメータ BAPIRET2 の代替構造を取得します。

戻り値:
returnMessagesList リターンパラメータ BAPIRET2 の代替構造

setNochangedoc

public void setNochangedoc(String noChangeDoc)
変更伝票書込なしを設定します。

パラメータ:
noChangeDoc - 変更伝票書込なし

setNoappllog

public void setNoappllog(String noApplLog)
アプリケーションログ書込なしを設定します。

パラメータ:
noApplLog - アプリケーションログ書込なし

setTestrun

public void setTestrun(String testRun)
書込 BAPI のシミュレーションセッションへの切替を設定します。

パラメータ:
testRun - 書込 BAPI のシミュレーションセッションへの切替

setInpfldcheck

public void setInpfldcheck(String inpFldCheck)
項目無効時の応答を設定します。

パラメータ:
inpFldCheck - 項目無効時の応答

setFlagCadCall

public void setFlagCadCall(String flagCadCall)
CAD システムからコールを設定します。

パラメータ:
flagCadCall - CAD システムからコール

setHeadDataList

public void setHeadDataList(List headDataList)
管理情報設定ヘッダセグメントを設定します。

パラメータ:
headDataList - 管理情報設定ヘッダセグメント

setClientDataList

public void setClientDataList(List clientDataList)
品目データ (クライアントレベル)を設定します。

パラメータ:
clientDataList - 品目データ (クライアントレベル)

setPlantDataList

public void setPlantDataList(List plantDataList)
品目データ (プラントレベル)を設定します。

パラメータ:
plantDataList - 品目データ (プラントレベル)

setForecastParametersList

public void setForecastParametersList(List forecastParametersList)
需要予測パラメータを設定します。

パラメータ:
forecastParametersList - 需要予測パラメータ

setPlanningDataList

public void setPlanningDataList(List planningDataList)
品目マスタ/製品グループの変更伝票構造を設定します。

パラメータ:
planningDataList - 品目マスタ/製品グループの変更伝票構造

setStorageLocationDataList

public void setStorageLocationDataList(List storageLocationDataList)
品目データ (保管場所レベル)を設定します。

パラメータ:
storageLocationDataList - 品目データ (保管場所レベル)

setValuationDataList

public void setValuationDataList(List valuationDataList)
評価データを設定します。

パラメータ:
valuationDataList - 評価データ

setWarehouseNumberDataList

public void setWarehouseNumberDataList(List warehouseNumberDataList)
倉庫番号データを設定します。

パラメータ:
warehouseNumberDataList - 倉庫番号データ

setSalesDataList

public void setSalesDataList(List salesDataList)
販売データを設定します。

パラメータ:
salesDataList - 販売データ

setStorageTypeDataList

public void setStorageTypeDataList(List storageTypeDataList)
保管域タイプデータを設定します。

パラメータ:
storageTypeDataList - 保管域タイプデータ

setMaterialDescriptionList

public void setMaterialDescriptionList(List materialDescriptionList)
品目テキストを設定します。

パラメータ:
materialDescriptionList - 品目テキスト

setUnitSofmeasureList

public void setUnitSofmeasureList(List unitSofmeasureList)
数量単位を設定します。

パラメータ:
unitSofmeasureList - 数量単位

setInternationalArtnosList

public void setInternationalArtnosList(List internationalArtnosList)
国際商品コード (EAN)を設定します。

パラメータ:
internationalArtnosList - 国際商品コード (EAN)

setMaterialLongTextList

public void setMaterialLongTextList(List materialLongTextList)
テキスト (長)を設定します。

パラメータ:
materialLongTextList - テキスト (長)

setTaxClassificationsList

public void setTaxClassificationsList(List taxClassificationsList)
制御デ－タを設定します。

パラメータ:
taxClassificationsList - 制御デ－タ

setPrtDataList

public void setPrtDataList(List prtDataList)
品目マスタの生産資源/治工具 (PRT) 項目を設定します。

パラメータ:
prtDataList - 品目マスタの生産資源/治工具 (PRT) 項目

setExtensionInList

public void setExtensionInList(List extensionInList)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を設定します。

パラメータ:
extensionInList - BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の 参照構造

setExtensionInXList

public void setExtensionInXList(List extensionInXList)
拡張イン/拡張アウトのチェックボックス構造を設定します。

パラメータ:
extensionInXList - 拡張イン/拡張アウトのチェックボックス構造

setForecastValuesList

public void setForecastValuesList(List forecastValuesList)
需要予測値のデータ転送を設定します。

パラメータ:
forecastValuesList - 需要予測値のデータ転送

setUnplndConsumptionList

public void setUnplndConsumptionList(List unplndConsumptionList)
計画外消費のデータ転送を設定します。

パラメータ:
unplndConsumptionList - 計画外消費のデータ転送

setTotalConsumptionList

public void setTotalConsumptionList(List totalConsumptionList)
品目総消費量のデータ転送を設定します。

パラメータ:
totalConsumptionList - 品目総消費量のデータ転送

setReturnMessagesList

public void setReturnMessagesList(List returnMessagesList)
リターンパラメータ BAPIRET2 の代替構造を設定します。

パラメータ:
returnMessagesList - リターンパラメータ BAPIRET2 の代替構造

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス
ExtensionIn
ExtensionInX
ForecastValues
HeadData
InternationalArtnos
MaterialLongText
MaterialSaveReplica
ParamClientDataList
ParamExtensionIn
ParamExtensionInX
ParamForecastParametersList
ParamForecastValues
ParamHeadData
ParamInternationalArtnos
ParamMaterialDescription
ParamMaterialLongText
ParamPlanningDataList
ParamPlantDataList
ParamPrtData
ParamReturnMessages
ParamSalesDataList
ParamStorageLocationDataList
ParamStorageTypeDataList
ParamTaxClassifications
ParamTotalConsumption
ParamUnitSofmeasure
ParamUnplndConsumption
ParamValuationDataList
ParamWarehouseNumberDataList
PrtData
ReturnMessages
TotalConsumption
UnplndConsumption


jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica

クラスの概要
ExtensionIn | BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報クラス 機能は以下の通り BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を保持します。
ExtensionInX | 拡張イン/拡張アウトのチェックボックス構造情報クラス 機能は以下の通り 拡張イン/拡張アウトのチェックボックス構造情報を保持します。
ForecastValues | 需要予測値のデータ転送情報クラス 機能は以下の通り 需要予測値のデータ転送情報を保持します。
HeadData | 管理情報設定ヘッダセグメント情報クラス 機能は以下の通り 管理情報設定ヘッダセグメント情報を保持します。
InternationalArtnos | 国際商品コード (EAN)情報クラス 機能は以下の通り 国際商品コード (EAN)情報を保持します。
MaterialLongText | テキスト (長)情報クラス 機能は以下の通り テキスト (長)情報を保持します。
MaterialSaveReplica | 品目マスタ更新情報クラス 機能は以下の通り 品目マスタ更新情報を保持します。
ParamClientDataList | 品目データ (クライアントレベル)パラメータ設定クラス 機能は以下の通り 品目データ (クライアントレベル)パラメータを設定します。
ParamExtensionIn | BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造パラメータ設定クラス 機能は以下の通り BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造のパラメータを設定します。
ParamExtensionInX | 拡張イン/拡張アウトのチェックボックス構造パラメータ設定クラス 機能は以下の通り 拡張イン/拡張アウトのチェックボックス構造のパラメータを設定します。
ParamForecastParametersList | 需要予測パラメータ設定クラス 機能は以下の通り 需要予測パラメータのパラメータを設定します。
ParamForecastValues | 需要予測値のデータ転送パラメータ設定クラス 機能は以下の通り 需要予測値のデータ転送のパラメータを設定します。
ParamHeadData | 管理情報設定ヘッダセグメントパラメータ設定クラス 機能は以下の通り 管理情報設定ヘッダセグメントのパラメータを設定します。
ParamInternationalArtnos | 国際商品コード (EAN)パラメータ設定クラス 機能は以下の通り 国際商品コード (EAN)のパラメータを設定します。
ParamMaterialDescription | 品目テキストパラメータ設定クラス 機能は以下の通り 品目テキストのパラメータを設定します。
ParamMaterialLongText | テキスト (長)パラメータ設定クラス 機能は以下の通り テキスト (長)のパラメータを設定します。
ParamPlanningDataList | 品目マスタ/製品グループの変更伝票構造パラメータ設定クラス 機能は以下の通り 品目マスタ/製品グループの変更伝票構造のパラメータを設定します。
ParamPlantDataList | 品目データ (プラントレベル)パラメータ設定クラス 機能は以下の通り 品目データ (プラントレベル)のパラメータを設定します。
ParamPrtData | 品目マスタの生産資源/治工具 (PRT) 項目パラメータ設定クラス 機能は以下の通り 品目マスタの生産資源/治工具 (PRT) 項目のパラメータを設定します。
ParamReturnMessages | リターンパラメータ BAPIRET2 の代替構造項目パラメータ設定クラス 機能は以下の通り リターンパラメータ BAPIRET2 の代替構造項目のパラメータをセットします。
ParamSalesDataList | 倉庫番号データパラメータ設定クラス 機能は以下の通り 倉庫番号データのパラメータを設定します。
ParamStorageLocationDataList | 品目データ (保管場所レベル)パラメータ設定クラス 機能は以下の通り 品目データ (保管場所レベル)のパラメータを設定します。
ParamStorageTypeDataList | 品目データ (保管場所レベル)パラメータ設定クラス 機能は以下の通り 品目データ (保管場所レベル)のパラメータを設定します。
ParamTaxClassifications | 制御デ－タパラメータ設定クラス 機能は以下の通り 制御デ－タのパラメータを設定します。
ParamTotalConsumption | 品目総消費量のデータ転送パラメータ設定クラス 機能は以下の通り 品目総消費量のデータ転送のパラメータを設定します。
ParamUnitSofmeasure | 数量単位パラメータ設定クラス 機能は以下の通り 数量単位のパラメータを設定します。
ParamUnplndConsumption | 計画外消費のデータ転送パラメータ設定クラス 機能は以下の通り 計画外消費のデータ転送のパラメータを設定します。
ParamValuationDataList | 評価データパラメータ設定クラス 機能は以下の通り 評価データのパラメータを設定します。
ParamWarehouseNumberDataList | 倉庫番号データパラメータ設定クラス 機能は以下の通り 倉庫番号データのパラメータを設定します。
PrtData | 品目マスタの生産資源/治工具 (PRT) 項目情報クラス 機能は以下の通り 品目マスタの生産資源/治工具 (PRT) 項目情報を保持します。
ReturnMessages | リターンパラメータ BAPIRET2 の代替構造情報クラス 機能は以下の通り リターンパラメータ BAPIRET2 の代替構造情報を保持します。
TotalConsumption | 品目総消費量のデータ転送情報クラス 機能は以下の通り 品目総消費量のデータ転送情報を保持します。
UnplndConsumption | 計画外消費のデータ転送情報クラス 機能は以下の通り 計画外消費のデータ転送情報を保持します。


jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica のクラス
ExtensionIn
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報クラス
機能は以下の通り
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を保持します。
ExtensionInX
拡張イン/拡張アウトのチェックボックス構造情報クラス
機能は以下の通り
拡張イン/拡張アウトのチェックボックス構造情報を保持します。
ForecastValues
需要予測値のデータ転送情報クラス
機能は以下の通り
需要予測値のデータ転送情報を保持します。
HeadData
管理情報設定ヘッダセグメント情報クラス
機能は以下の通り
管理情報設定ヘッダセグメント情報を保持します。
InternationalArtnos
国際商品コード (EAN)情報クラス
機能は以下の通り
国際商品コード (EAN)情報を保持します。
MaterialLongText
テキスト (長)情報クラス
機能は以下の通り
テキスト (長)情報を保持します。
MaterialSaveReplica
品目マスタ更新情報クラス
機能は以下の通り
品目マスタ更新情報を保持します。
PrtData
品目マスタの生産資源/治工具 (PRT) 項目情報クラス
機能は以下の通り
品目マスタの生産資源/治工具 (PRT) 項目情報を保持します。
TotalConsumption
品目総消費量のデータ転送情報クラス
機能は以下の通り
品目総消費量のデータ転送情報を保持します。
UnplndConsumption
計画外消費のデータ転送情報クラス
機能は以下の通り
計画外消費のデータ転送情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamClientDataList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamClientDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList
すべての実装インタフェース:
Serializable
public final class ParamClientDataList
extends Object
implements Serializable

品目データ (クライアントレベル)パラメータ設定クラス
機能は以下の通り

  • 品目データ (クライアントレベル)パラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List clientDataList) table(Export)情報から品目データ (クライアントレベル)の値をセットします。
static void | setTableParam(BapiController bapiController, List clientDataList) 品目データ (クライアントレベル)の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List clientDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
品目データ (クライアントレベル)の値をセットします。 CLIENTDATA の情報の更新の値をセットします。

パラメータ:
bapiController - BapiController
clientDataList - 品目データ (クライアントレベル)配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List clientDataList)
                           throws SAPGeneralSystemException
table(Export)情報から品目データ (クライアントレベル)の値をセットします。

パラメータ:
bapiController - BapiController
clientDataList - 品目データ (クライアントレベル)配列
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamExtensionIn (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamExtensionIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn
すべての実装インタフェース:
Serializable
public final class ParamExtensionIn
extends Object
implements Serializable

BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造パラメータ設定クラス
機能は以下の通り

  • BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List extensionInList) table(Export)情報からBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造 の値をセットします。
static void | setTableParam(BapiController bapiController, List extensionInList) BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List extensionInList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の値をセットします。

パラメータ:
bapiController - BapiController
extensionInList - BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List extensionInList)
                           throws SAPGeneralSystemException
table(Export)情報からBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造 の値をセットします。

パラメータ:
bapiController - BapiController
extensionInList - EXTENSIONIN/EXTENSIONOUT の参照構造配列
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamExtensionInX (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamExtensionInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX
すべての実装インタフェース:
Serializable
public final class ParamExtensionInX
extends Object
implements Serializable

拡張イン/拡張アウトのチェックボックス構造パラメータ設定クラス
機能は以下の通り

  • 拡張イン/拡張アウトのチェックボックス構造のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List extensionInXList) 実行結果の拡張イン/拡張アウトのチェックボックス構造をセットします。
static void | setTableParam(BapiController bapiController, List extensionInXList) 拡張イン/拡張アウトのチェックボックス構造の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List extensionInXList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
拡張イン/拡張アウトのチェックボックス構造の値をセットします。

パラメータ:
bapiController - BapiController
extensionInXList - 拡張イン/拡張アウトのチェックボックス構造配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List extensionInXList)
                           throws SAPGeneralSystemException
実行結果の拡張イン/拡張アウトのチェックボックス構造をセットします。

パラメータ:
bapiController - BapiController
extensionInXList - 拡張イン/拡張アウトのチェックボックス構造配列
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamForecastParametersList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamForecastParametersList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList
すべての実装インタフェース:
Serializable
public final class ParamForecastParametersList
extends Object
implements Serializable

需要予測パラメータ設定クラス
機能は以下の通り

  • 需要予測パラメータのパラメータを設定します。
  • FORECASTDATA の情報の更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List forecastParametersList) table(Export)情報から需要予測パラメータの値をセットします。
static void | setTableParam(BapiController bapiController, List forecastParametersList) 需要予測パラメータの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List forecastParametersList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
需要予測パラメータの値をセットします。 FORECASTDATA の情報の更新の値をセットします。

パラメータ:
bapiController - BapiController
forecastParametersList - 需要予測パラメータ配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List forecastParametersList)
                           throws SAPGeneralSystemException
table(Export)情報から需要予測パラメータの値をセットします。

パラメータ:
bapiController - BapiController
forecastParametersList - 需要予測パラメータ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamForecastValues (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamForecastValues

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues
すべての実装インタフェース:
Serializable
public final class ParamForecastValues
extends Object
implements Serializable

需要予測値のデータ転送パラメータ設定クラス
機能は以下の通り

  • 需要予測値のデータ転送のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List forecastValuesList) table(Export)情報から需要予測値のデータ転送の値をセットします。
static void | setTableParam(BapiController bapiController, List forecastValuesList) 需要予測値のデータ転送の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List forecastValuesList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
需要予測値のデータ転送の値をセットします。

パラメータ:
bapiController - BapiController
forecastValuesList - 需要予測値のデータ転送配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List forecastValuesList)
                           throws SAPGeneralSystemException
table(Export)情報から需要予測値のデータ転送の値をセットします。

パラメータ:
bapiController - BapiController
forecastValuesList - 需要予測値のデータ転送配列
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamHeadData (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamHeadData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData
すべての実装インタフェース:
Serializable
public final class ParamHeadData
extends Object
implements Serializable

管理情報設定ヘッダセグメントパラメータ設定クラス
機能は以下の通り

  • 管理情報設定ヘッダセグメントのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List headDataList) table(Export)情報から管理情報設定ヘッダセグメントの値をセットします。
static void | setTableParam(BapiController bapiController, List headDataList) 管理情報設定ヘッダセグメントの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List headDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
管理情報設定ヘッダセグメントの値をセットします。

パラメータ:
bapiController - BapiController
headDataList - 管理情報設定ヘッダセグメント配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List headDataList)
                           throws SAPGeneralSystemException
table(Export)情報から管理情報設定ヘッダセグメントの値をセットします。

パラメータ:
bapiController - BapiController
headDataList - 管理情報設定ヘッダセグメント
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamInternationalArtnos (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamInternationalArtnos

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos
すべての実装インタフェース:
Serializable
public final class ParamInternationalArtnos
extends Object
implements Serializable

国際商品コード (EAN)パラメータ設定クラス
機能は以下の通り

  • 国際商品コード (EAN)のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List internationalArtnosList) table(Export)情報から国際商品コード (EAN)の値をセットします。
static void | setTableParam(BapiController bapiController, List internationalArtnosList) 国際商品コード (EAN)の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List internationalArtnosList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
国際商品コード (EAN)の値をセットします。

パラメータ:
bapiController - BapiController
internationalArtnosList - 国際商品コード (EAN)配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List internationalArtnosList)
                           throws SAPGeneralSystemException
table(Export)情報から国際商品コード (EAN)の値をセットします。

パラメータ:
bapiController - BapiController
internationalArtnosList - 国際商品コード (EAN)
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamMaterialDescription (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamMaterialDescription

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription
すべての実装インタフェース:
Serializable
public final class ParamMaterialDescription
extends Object
implements Serializable

品目テキストパラメータ設定クラス
機能は以下の通り

  • 品目テキストのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List materialDescriptionList) table(Export)情報から品目テキストを設定します。
static void | setTableParam(BapiController bapiController, List materialDescriptionList) 品目テキストの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List materialDescriptionList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
品目テキストの値をセットします。

パラメータ:
bapiController - BapiController
materialDescriptionList - 品目テキスト配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List materialDescriptionList)
                           throws SAPGeneralSystemException
table(Export)情報から品目テキストを設定します。

パラメータ:
bapiController - BapiController
materialDescriptionList - 品目テキスト配列
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamMaterialLongText (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamMaterialLongText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText
すべての実装インタフェース:
Serializable
public final class ParamMaterialLongText
extends Object
implements Serializable

テキスト (長)パラメータ設定クラス
機能は以下の通り

  • テキスト (長)のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List materialLongTextList) table(Export)情報からテキスト (長)の値をセットします。
static void | setTableParam(BapiController bapiController, List list) テキスト (長)の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List list)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
テキスト (長)の値をセットします。

パラメータ:
bapiController - BapiController
list - テキスト (長)配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List materialLongTextList)
                           throws SAPGeneralSystemException
table(Export)情報からテキスト (長)の値をセットします。

パラメータ:
bapiController - BapiController
materialLongTextList - テキスト (長)
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPlanningDataList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamPlanningDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList
すべての実装インタフェース:
Serializable
public final class ParamPlanningDataList
extends Object
implements Serializable

品目マスタ/製品グループの変更伝票構造パラメータ設定クラス
機能は以下の通り

  • 品目マスタ/製品グループの変更伝票構造のパラメータを設定します。
  • PLANNINGDATA の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List planningDataList) table(Export)情報から品目マスタ/製品グループの変更伝票構造の値をセットします。
static void | setTableParam(BapiController bapiController, List planningDataList) 品目マスタ/製品グループの変更伝票構造の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List planningDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
品目マスタ/製品グループの変更伝票構造の値をセットします。 PLANNINGDATA の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
planningDataList - 品目マスタ/製品グループの変更伝票構造配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List planningDataList)
                           throws SAPGeneralSystemException
table(Export)情報から品目マスタ/製品グループの変更伝票構造の値をセットします。

パラメータ:
bapiController - BapiController
planningDataList - 品目マスタ/製品グループの変更伝票構造
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPlantDataList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamPlantDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList
すべての実装インタフェース:
Serializable
public final class ParamPlantDataList
extends Object
implements Serializable

品目データ (プラントレベル)パラメータ設定クラス
機能は以下の通り

  • 品目データ (プラントレベル)のパラメータを設定します。
  • PLANTDATA の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List plantDataList) table(Export)情報から品目データ (プラントレベル)の値をセットします。
static void | setTableParam(BapiController bapiController, List plantDataList) 品目データ (プラントレベル)の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List plantDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
品目データ (プラントレベル)の値をセットします。 PLANTDATA の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
plantDataList - 品目データ (プラントレベル)配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List plantDataList)
                           throws SAPGeneralSystemException
table(Export)情報から品目データ (プラントレベル)の値をセットします。

パラメータ:
bapiController - BapiController
plantDataList - 品目データ (プラントレベル)
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPrtData (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamPrtData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData
すべての実装インタフェース:
Serializable
public final class ParamPrtData
extends Object
implements Serializable

品目マスタの生産資源/治工具 (PRT) 項目パラメータ設定クラス
機能は以下の通り

  • 品目マスタの生産資源/治工具 (PRT) 項目のパラメータを設定します。
  • PRTDATA の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List prtDataList) table(Export)情報から品目マスタの生産資源/治工具 (PRT) 項目の値を セットします。
static void | setTableParam(BapiController bapiController, List prtDataList) 品目マスタの生産資源/治工具 (PRT) 項目の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List prtDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
品目マスタの生産資源/治工具 (PRT) 項目の値をセットします。 PRTDATA の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
prtDataList - 品目マスタの生産資源/治工具 (PRT) 項目配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List prtDataList)
                           throws SAPGeneralSystemException
table(Export)情報から品目マスタの生産資源/治工具 (PRT) 項目の値を セットします。

パラメータ:
bapiController - BapiController
prtDataList - 品目マスタの生産資源/治工具 (PRT) 項目
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamReturnMessages (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamReturnMessages

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages
すべての実装インタフェース:
Serializable
public final class ParamReturnMessages
extends Object
implements Serializable

リターンパラメータ BAPIRET2 の代替構造項目パラメータ設定クラス
機能は以下の通り

  • リターンパラメータ BAPIRET2 の代替構造項目のパラメータをセットします。

関連項目:
直列化された形式

メソッドの概要
static void setExportParam(BapiController bapiController, List returnMessages)
品目マスタ更新結果をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List returnMessages)
                           throws SAPGeneralSystemException
品目マスタ更新結果をセットします。

パラメータ:
bapiController - BapiController
returnMessages - リターンパラメータ BAPIRET2 の代替構造
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamSalesDataList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamSalesDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList
すべての実装インタフェース:
Serializable
public final class ParamSalesDataList
extends Object
implements Serializable

倉庫番号データパラメータ設定クラス
機能は以下の通り

  • 倉庫番号データのパラメータを設定します。
  • WAREHOUSEDATA の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List salesDataList) table(Export)情報から販売データの値をセットします。
static void | setTableParam(BapiController bapiController, List salesDataList) 販売データの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List salesDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
販売データの値をセットします。 SALESDATA の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
salesDataList - 販売データ配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List salesDataList)
                           throws SAPGeneralSystemException
table(Export)情報から販売データの値をセットします。

パラメータ:
bapiController - BapiController
salesDataList - 販売データ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamStorageLocationDataList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamStorageLocationDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList
すべての実装インタフェース:
Serializable
public final class ParamStorageLocationDataList
extends Object
implements Serializable

品目データ (保管場所レベル)パラメータ設定クラス
機能は以下の通り

  • 品目データ (保管場所レベル)のパラメータを設定します。
  • STORAGELOCATIONDATA の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List stgeLocDataList) table(Export)情報から品目データ (保管場所レベル)の値をセットします。
static void | setTableParam(BapiController bapiController, List storageLicationDataList) 品目データ (保管場所レベル)の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List storageLicationDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
品目データ (保管場所レベル)の値をセットします。 STORAGELOCATIONDATA の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
storageLicationDataList - 品目データ (保管場所レベル)配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List stgeLocDataList)
                           throws SAPGeneralSystemException
table(Export)情報から品目データ (保管場所レベル)の値をセットします。

パラメータ:
bapiController - BapiController
stgeLocDataList - 品目データ (保管場所レベル)
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamStorageTypeDataList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamStorageTypeDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList
すべての実装インタフェース:
Serializable
public final class ParamStorageTypeDataList
extends Object
implements Serializable

品目データ (保管場所レベル)パラメータ設定クラス
機能は以下の通り

  • 品目データ (保管場所レベル)のパラメータを設定します。
  • STORAGELOCATIONDATA の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List stgeTypeDataList) table(Export)情報から保管域タイプデータの値をセットします。
static void | setTableParam(BapiController bapiController, List storageTypeDataList) 保管域タイプデータの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List storageTypeDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
保管域タイプデータの値をセットします。 STORAGETYPEDATA の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
storageTypeDataList - 保管域タイプデータ配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List stgeTypeDataList)
                           throws SAPGeneralSystemException
table(Export)情報から保管域タイプデータの値をセットします。

パラメータ:
bapiController - BapiController
stgeTypeDataList - 保管域タイプデータ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamTaxClassifications (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamTaxClassifications

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications
すべての実装インタフェース:
Serializable
public final class ParamTaxClassifications
extends Object
implements Serializable

制御デ－タパラメータ設定クラス
機能は以下の通り

  • 制御デ－タのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List taxClassificationsList) table(Export)情報から制御データを設定します。
static void | setTableParam(BapiController bapiController, List taxClassificationsList) 制御デ－タの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List taxClassificationsList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
制御デ－タの値をセットします。

パラメータ:
bapiController - BapiController
taxClassificationsList - 制御デ－タ配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List taxClassificationsList)
                           throws SAPGeneralSystemException
table(Export)情報から制御データを設定します。

パラメータ:
bapiController - BapiController
taxClassificationsList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamTotalConsumption (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamTotalConsumption

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption
すべての実装インタフェース:
Serializable
public final class ParamTotalConsumption
extends Object
implements Serializable

品目総消費量のデータ転送パラメータ設定クラス
機能は以下の通り

  • 品目総消費量のデータ転送のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List totalConsumptionList) table(Export)情報から品目総消費量のデータ転送の値をセットします。
static void | setTableParam(BapiController bapiController, List totalConsumptionList) 品目総消費量のデータ転送の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List totalConsumptionList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
品目総消費量のデータ転送の値をセットします。

パラメータ:
bapiController - BapiController
totalConsumptionList - 品目総消費量のデータ転送配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List totalConsumptionList)
                           throws SAPGeneralSystemException
table(Export)情報から品目総消費量のデータ転送の値をセットします。

パラメータ:
bapiController - BapiController
totalConsumptionList - 品目総消費量のデータ転送
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamUnitSofmeasure (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamUnitSofmeasure

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure
すべての実装インタフェース:
Serializable
public final class ParamUnitSofmeasure
extends Object
implements Serializable

数量単位パラメータ設定クラス
機能は以下の通り

  • 数量単位のパラメータを設定します。
  • UNITSOFMEASURE の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List unitSofmeasureList) table(Export)情報から数量単位を設定します。
static void | setTableParam(BapiController bapiController, List unitSofmeasureList) 数量単位の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List unitSofmeasureList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
数量単位の値をセットします。 UNITSOFMEASURE の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
unitSofmeasureList - 数量単位配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List unitSofmeasureList)
                           throws SAPGeneralSystemException
table(Export)情報から数量単位を設定します。

パラメータ:
bapiController - BapiController
unitSofmeasureList - 数量単位配列
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamUnplndConsumption (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamUnplndConsumption

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption
すべての実装インタフェース:
Serializable
public final class ParamUnplndConsumption
extends Object
implements Serializable

計画外消費のデータ転送パラメータ設定クラス
機能は以下の通り

  • 計画外消費のデータ転送のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List unplndConsumptionList) table(Export)情報から計画外消費のデータ転送の値をセットします。
static void | setTableParam(BapiController bapiController, List unplndConsumptionList) 計画外消費のデータ転送の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List unplndConsumptionList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
計画外消費のデータ転送の値をセットします。

パラメータ:
bapiController - BapiController
unplndConsumptionList - 計画外消費のデータ転送配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List unplndConsumptionList)
                           throws SAPGeneralSystemException
table(Export)情報から計画外消費のデータ転送の値をセットします。

パラメータ:
bapiController - BapiController
unplndConsumptionList - 計画外消費のデータ転送
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamValuationDataList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamValuationDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList
すべての実装インタフェース:
Serializable
public final class ParamValuationDataList
extends Object
implements Serializable

評価データパラメータ設定クラス
機能は以下の通り

  • 評価データのパラメータを設定します。
  • VALUATIONDATA の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List valuationDataList) table(Export)情報から評価データの値をセットします。
static void | setTableParam(BapiController bapiController, List valuationDataList) 評価データの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List valuationDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
評価データの値をセットします。 VALUATIONDATA の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
valuationDataList - 評価データ配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List valuationDataList)
                           throws SAPGeneralSystemException
table(Export)情報から評価データの値をセットします。

パラメータ:
bapiController - BapiController
valuationDataList - 評価データ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamWarehouseNumberDataList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamWarehouseNumberDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList
すべての実装インタフェース:
Serializable
public final class ParamWarehouseNumberDataList
extends Object
implements Serializable

倉庫番号データパラメータ設定クラス
機能は以下の通り

  • 倉庫番号データのパラメータを設定します。
  • WAREHOUSEDATA の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List whseNoDataList) table(Export)情報から倉庫番号データを設定します。
static void | setTableParam(BapiController bapiController, List warehouseNumberDataList) 倉庫番号データの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List warehouseNumberDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
倉庫番号データの値をセットします。 WAREHOUSEDATA の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
warehouseNumberDataList - 倉庫番号データ配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List whseNoDataList)
                           throws SAPGeneralSystemException
table(Export)情報から倉庫番号データを設定します。

パラメータ:
bapiController - BapiController
whseNoDataList - 倉庫番号データ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PrtData (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス PrtData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData
すべての実装インタフェース:
Serializable
public class PrtData
extends Object
implements Serializable

品目マスタの生産資源/治工具 (PRT) 項目情報クラス
機能は以下の通り

  • 品目マスタの生産資源/治工具 (PRT) 項目情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PrtData()
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。
PrtData(int index)
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。
メソッドの概要
String | getCreateLoadRecs() 区分: 生産資源/治工具の負荷レコード登録を取得します。
String | getCtrlKey() 生産資源/治工具管理の管理キーを取得します。
String | getCtrlKeyNoChg() 管理キーは変更できませんを取得します。
String | getEndOffset() 生産資源/治工具用途の終了オフセットを取得します。
String | getEndOffsetNoChg() 終了オフセットは変更できませんを取得します。
String | getEndOffsetUnit() 生産資源/治工具使用終了オフセット単位を取得します。
String | getEndOffsetUnitIso() PRT 用途終了決定の間隔時間単位 (ISO)を取得します。
String | getEndRefDate() 生産資源/治工具使用終了日の参照日付を取得します。
String | getEndRefDateNoChg() 終了参照日付は変更できませんを取得します。
String | getFormulaTotQty() 生産資源/治工具の合計数量の計算式を取得します。
String | getFormulaTotQtyNoChg() 合計数量の計算式は変更できませんを取得します。
String | getFormulaTotUsage() 生産資源/治工具の総用途値の計算式を取得します。
String | getFormulaTotUsageNoChg() すべての用途値を計算する計算式は変更できませんを取得します。
String | getFunction() BAPI 機能を取得します。
String | getGrpKey1() 生産資源/治工具のグループキー 1を取得します。
String | getGrpKey2() 生産資源/治工具のグループキー 2を取得します。
int | getIndex() レコード番号を取得します｡
String | getMaterial() 品目コードを取得します。
String | getPlant() プラントを取得します。
String | getPrtUsage() 生産資源/治工具用途を取得します。
String | getRefKeyNoChg() 参照キーは変更できませんを取得します。
String | getStartOffset() 生産資源/治工具使用の開始オフセットを取得します。
String | getStartOffsetNoChg() 開始オフセットは変更できませんを取得します。
String | getStartOffsetUnit() 生産資源/治工具使用開始のオフセット単位を取得します。
String | getStartOffsetUnitIso() PRT 用途開始決定の間隔時間単位 (ISO)を取得します。
String | getStartRefDate() 生産資源/治工具使用開始の参照日付を取得します。
String | getStdTextKey() 生産資源/治工具の標準テキストキーを取得します。
String | getStRefDateNoChg() 開始参照日付は変更できませんを取得します。
void | setCreateLoadRecs(String createLoadRecs) 区分: 生産資源/治工具の負荷レコード登録を設定します。
void | setCtrlKey(String ctrlKey) 生産資源/治工具管理の管理キーを設定します。
void | setCtrlKeyNoChg(String ctrlKeyNoChg) 管理キーは変更できませんを設定します。
void | setEndOffset(String endOffset) 生産資源/治工具用途の終了オフセットを設定します。
void | setEndOffsetNoChg(String endOffsetNoChg) 終了オフセットは変更できませんを設定します。
void | setEndOffsetUnit(String endOffsetUnit) 生産資源/治工具使用終了オフセット単位を設定します。
void | setEndOffsetUnitIso(String endOffsetUnitIso) PRT 用途終了決定の間隔時間単位 (ISO)を設定します。
void | setEndRefDate(String endRefDate) 生産資源/治工具使用終了日の参照日付を設定します。
void | setEndRefDateNoChg(String endRefDateNoChg) 終了参照日付は変更できませんを設定します。
void | setFormulaTotQty(String formulaTotQty) 生産資源/治工具の合計数量の計算式を設定します。
void | setFormulaTotQtyNoChg(String formulaTotQtyNoChg) 合計数量の計算式は変更できませんを設定します。
void | setFormulaTotUsage(String formulaTotUsage) 生産資源/治工具の総用途値の計算式を設定します。
void | setFormulaTotUsageNoChg(String formulaTotUsageNoChg) すべての用途値を計算する計算式は変更できませんを設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setGrpKey1(String grpKey1) 生産資源/治工具のグループキー 1を設定します。
void | setGrpKey2(String grpKey2) 生産資源/治工具のグループキー 2を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMaterial(String material) 品目コードを設定します。
void | setPlant(String plant) プラントを設定します。
void | setPrtUsage(String prtUsage) 生産資源/治工具用途を設定します。
void | setRefKeyNoChg(String refKeyNoChg) 参照キーは変更できませんを設定します。
void | setStartOffset(String startOffset) 生産資源/治工具使用の開始オフセットを設定します。
void | setStartOffsetNoChg(String startOffsetNoChg) 開始オフセットは変更できませんを設定します。
void | setStartOffsetUnit(String startOffsetUnit) 生産資源/治工具使用開始のオフセット単位を設定します。
void | setStartOffsetUnitIso(String startOffsetUnitIso) PRT 用途開始決定の間隔時間単位 (ISO)を設定します。
void | setStartRefDate(String startRefDate) 生産資源/治工具使用開始の参照日付を設定します。
void | setStdTextKey(String stdTextKey) 生産資源/治工具の標準テキストキーを設定します。
void | setStRefDateNoChg(String stRefDateNoChg) 開始参照日付は変更できませんを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PrtData

public PrtData()
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。

PrtData

public PrtData(int index)
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getCreateLoadRecs

public String getCreateLoadRecs()
区分: 生産資源/治工具の負荷レコード登録を取得します。

戻り値:
createLoadRecs 区分: 生産資源/治工具の負荷レコード登録

getCtrlKey

public String getCtrlKey()
生産資源/治工具管理の管理キーを取得します。

戻り値:
ctrlKey 生産資源/治工具管理の管理キー

getCtrlKeyNoChg

public String getCtrlKeyNoChg()
管理キーは変更できませんを取得します。

戻り値:
ctrlKeyNoChg 管理キーは変更できません

getGrpKey1

public String getGrpKey1()
生産資源/治工具のグループキー 1を取得します。

戻り値:
grpKey_1 生産資源/治工具のグループキー 1

getGrpKey2

public String getGrpKey2()
生産資源/治工具のグループキー 2を取得します。

戻り値:
grpKey_2 生産資源/治工具のグループキー 2

getPrtUsage

public String getPrtUsage()
生産資源/治工具用途を取得します。

戻り値:
prtUsage 生産資源/治工具用途

getStdTextKey

public String getStdTextKey()
生産資源/治工具の標準テキストキーを取得します。

戻り値:
stdTextKey 生産資源/治工具の標準テキストキー

getRefKeyNoChg

public String getRefKeyNoChg()
参照キーは変更できませんを取得します。

戻り値:
refKeyNoChg 参照キーは変更できません

getStartRefDate

public String getStartRefDate()
生産資源/治工具使用開始の参照日付を取得します。

戻り値:
startRefDate 生産資源/治工具使用開始の参照日付

getStRefDateNoChg

public String getStRefDateNoChg()
開始参照日付は変更できませんを取得します。

戻り値:
stRefDateNoChg 開始参照日付は変更できません

getStartOffset

public String getStartOffset()
生産資源/治工具使用の開始オフセットを取得します。

戻り値:
startOffset 生産資源/治工具使用の開始オフセット

getStartOffsetUnit

public String getStartOffsetUnit()
生産資源/治工具使用開始のオフセット単位を取得します。

戻り値:
startOffsetUnit 生産資源/治工具使用開始のオフセット単位

getStartOffsetUnitIso

public String getStartOffsetUnitIso()
PRT 用途開始決定の間隔時間単位 (ISO)を取得します。

戻り値:
startOffsetUnitIso PRT 用途開始決定の間隔時間単位 (ISO)

getStartOffsetNoChg

public String getStartOffsetNoChg()
開始オフセットは変更できませんを取得します。

戻り値:
startOffsetNoChg 開始オフセットは変更できません

getEndRefDate

public String getEndRefDate()
生産資源/治工具使用終了日の参照日付を取得します。

戻り値:
endRefDate 生産資源/治工具使用終了日の参照日付

getEndRefDateNoChg

public String getEndRefDateNoChg()
終了参照日付は変更できませんを取得します。

戻り値:
endRefDateNoChg 終了参照日付は変更できません

getEndOffset

public String getEndOffset()
生産資源/治工具用途の終了オフセットを取得します。

戻り値:
endOffset 生産資源/治工具用途の終了オフセット

getEndOffsetUnit

public String getEndOffsetUnit()
生産資源/治工具使用終了オフセット単位を取得します。

戻り値:
endOffsetUnit 生産資源/治工具使用終了オフセット単位

getEndOffsetUnitIso

public String getEndOffsetUnitIso()
PRT 用途終了決定の間隔時間単位 (ISO)を取得します。

戻り値:
endOffsetUnitIso PRT 用途終了決定の間隔時間単位 (ISO)

getEndOffsetNoChg

public String getEndOffsetNoChg()
終了オフセットは変更できませんを取得します。

戻り値:
endOffsetNoChg 終了オフセットは変更できません

getFormulaTotQty

public String getFormulaTotQty()
生産資源/治工具の合計数量の計算式を取得します。

戻り値:
formulaTotQty 生産資源/治工具の合計数量の計算式

getFormulaTotQtyNoChg

public String getFormulaTotQtyNoChg()
合計数量の計算式は変更できませんを取得します。

戻り値:
formulaTotQtyNoChg 合計数量の計算式は変更できません

getFormulaTotUsage

public String getFormulaTotUsage()
生産資源/治工具の総用途値の計算式を取得します。

戻り値:
formulaTotUsage 生産資源/治工具の総用途値の計算式

getFormulaTotUsageNoChg

public String getFormulaTotUsageNoChg()
すべての用途値を計算する計算式は変更できませんを取得します。

戻り値:
formulaTotUsageNoChg すべての用途値を計算する計算式は変更できません

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setCreateLoadRecs

public void setCreateLoadRecs(String createLoadRecs)
区分: 生産資源/治工具の負荷レコード登録を設定します。

パラメータ:
createLoadRecs - 区分: 生産資源/治工具の負荷レコード登録

setCtrlKey

public void setCtrlKey(String ctrlKey)
生産資源/治工具管理の管理キーを設定します。

パラメータ:
ctrlKey - 生産資源/治工具管理の管理キー

setCtrlKeyNoChg

public void setCtrlKeyNoChg(String ctrlKeyNoChg)
管理キーは変更できませんを設定します。

パラメータ:
ctrlKeyNoChg - 管理キーは変更できません

setGrpKey1

public void setGrpKey1(String grpKey1)
生産資源/治工具のグループキー 1を設定します。

パラメータ:
grpKey1 - 生産資源/治工具のグループキー 1

setGrpKey2

public void setGrpKey2(String grpKey2)
生産資源/治工具のグループキー 2を設定します。

パラメータ:
grpKey2 - 生産資源/治工具のグループキー 2

setPrtUsage

public void setPrtUsage(String prtUsage)
生産資源/治工具用途を設定します。

パラメータ:
prtUsage - 生産資源/治工具用途

setStdTextKey

public void setStdTextKey(String stdTextKey)
生産資源/治工具の標準テキストキーを設定します。

パラメータ:
stdTextKey - 生産資源/治工具の標準テキストキー

setRefKeyNoChg

public void setRefKeyNoChg(String refKeyNoChg)
参照キーは変更できませんを設定します。

パラメータ:
refKeyNoChg - 参照キーは変更できません

setStartRefDate

public void setStartRefDate(String startRefDate)
生産資源/治工具使用開始の参照日付を設定します。

パラメータ:
startRefDate - 生産資源/治工具使用開始の参照日付

setStRefDateNoChg

public void setStRefDateNoChg(String stRefDateNoChg)
開始参照日付は変更できませんを設定します。

パラメータ:
stRefDateNoChg - 開始参照日付は変更できません

setStartOffset

public void setStartOffset(String startOffset)
生産資源/治工具使用の開始オフセットを設定します。

パラメータ:
startOffset - 生産資源/治工具使用の開始オフセット

setStartOffsetUnit

public void setStartOffsetUnit(String startOffsetUnit)
生産資源/治工具使用開始のオフセット単位を設定します。

パラメータ:
startOffsetUnit - 生産資源/治工具使用開始のオフセット単位

setStartOffsetUnitIso

public void setStartOffsetUnitIso(String startOffsetUnitIso)
PRT 用途開始決定の間隔時間単位 (ISO)を設定します。

パラメータ:
startOffsetUnitIso - PRT 用途開始決定の間隔時間単位 (ISO)

setStartOffsetNoChg

public void setStartOffsetNoChg(String startOffsetNoChg)
開始オフセットは変更できませんを設定します。

パラメータ:
startOffsetNoChg - 開始オフセットは変更できません

setEndRefDate

public void setEndRefDate(String endRefDate)
生産資源/治工具使用終了日の参照日付を設定します。

パラメータ:
endRefDate - 生産資源/治工具使用終了日の参照日付

setEndRefDateNoChg

public void setEndRefDateNoChg(String endRefDateNoChg)
終了参照日付は変更できませんを設定します。

パラメータ:
endRefDateNoChg - 終了参照日付は変更できません

setEndOffset

public void setEndOffset(String endOffset)
生産資源/治工具用途の終了オフセットを設定します。

パラメータ:
endOffset - 生産資源/治工具用途の終了オフセット

setEndOffsetUnit

public void setEndOffsetUnit(String endOffsetUnit)
生産資源/治工具使用終了オフセット単位を設定します。

パラメータ:
endOffsetUnit - 生産資源/治工具使用終了オフセット単位

setEndOffsetUnitIso

public void setEndOffsetUnitIso(String endOffsetUnitIso)
PRT 用途終了決定の間隔時間単位 (ISO)を設定します。

パラメータ:
endOffsetUnitIso - PRT 用途終了決定の間隔時間単位 (ISO)

setEndOffsetNoChg

public void setEndOffsetNoChg(String endOffsetNoChg)
終了オフセットは変更できませんを設定します。

パラメータ:
endOffsetNoChg - 終了オフセットは変更できません

setFormulaTotQty

public void setFormulaTotQty(String formulaTotQty)
生産資源/治工具の合計数量の計算式を設定します。

パラメータ:
formulaTotQty - 生産資源/治工具の合計数量の計算式

setFormulaTotQtyNoChg

public void setFormulaTotQtyNoChg(String formulaTotQtyNoChg)
合計数量の計算式は変更できませんを設定します。

パラメータ:
formulaTotQtyNoChg - 合計数量の計算式は変更できません

setFormulaTotUsage

public void setFormulaTotUsage(String formulaTotUsage)
生産資源/治工具の総用途値の計算式を設定します。

パラメータ:
formulaTotUsage - 生産資源/治工具の総用途値の計算式

setFormulaTotUsageNoChg

public void setFormulaTotUsageNoChg(String formulaTotUsageNoChg)
すべての用途値を計算する計算式は変更できませんを設定します。

パラメータ:
formulaTotUsageNoChg - すべての用途値を計算する計算式は変更できません

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReturnMessages (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ReturnMessages

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages
すべての実装インタフェース:
Serializable
public class ReturnMessages
extends Object
implements Serializable

リターンパラメータ BAPIRET2 の代替構造情報クラス
機能は以下の通り

  • リターンパラメータ BAPIRET2 の代替構造情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ReturnMessages()
リターンパラメータ BAPIRET2 の代替構造情報を作成します。
ReturnMessages(int index)
リターンパラメータ BAPIRET2 の代替構造情報を作成します。
メソッドの概要
String | getField() パラメータの項目を取得します。
String | getId() メッセージ、メッセージクラスを取得します。
int | getIndex() レコード番号を取得します｡
String | getLogMsgNo() アプリケーションログ: メッセージシリアル番号を取得します。
String | getLogNo() アプリケーションログ: ログ番号を取得します。
String | getMessage() メッセージテキストを取得します。
String | getMessageV1() メッセージ、メッセージ変数を取得します。
String | getMessageV2() メッセージ、メッセージ変数を取得します。
String | getMessageV3() メッセージ、メッセージ変数を取得します。
String | getMessageV4() メッセージ、メッセージ変数を取得します。
String | getNumber() メッセージ、メッセージ番号を取得します。
String | getParameter() パラメータ名を取得します。
String | getRow() パラメータの行を取得します。
String | getSystem() メッセージが発行された論理システムを取得します。
String | getType() メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を取得します。
void | setField(String field) パラメータの項目を設定します。
void | setId(String id) メッセージ、メッセージクラスを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLogMsgNo(String logMsgNo) アプリケーションログ: メッセージシリアル番号を設定します。
void | setLogNo(String logNo) アプリケーションログ: ログ番号を設定します。
void | setMessage(String message) メッセージテキストを設定します。
void | setMessageV1(String messageV1) メッセージ、メッセージ変数を設定します。
void | setMessageV2(String messageV2) メッセージ、メッセージ変数を設定します。
void | setMessageV3(String messageV3) メッセージ、メッセージ変数を設定します。
void | setMessageV4(String messageV4) メッセージ、メッセージ変数を設定します。
void | setNumber(String number) メッセージ、メッセージ番号を設定します。
void | setParameter(String parameter) パラメータ名を設定します。
void | setRow(String row) パラメータの行を設定します。
void | setSystem(String system) メッセージが発行された論理システムを設定します。
void | setType(String type) メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ReturnMessages

public ReturnMessages()
リターンパラメータ BAPIRET2 の代替構造情報を作成します。

ReturnMessages

public ReturnMessages(int index)
リターンパラメータ BAPIRET2 の代替構造情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getType

public String getType()
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を取得します。

戻り値:
type メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了

getId

public String getId()
メッセージ、メッセージクラスを取得します。

戻り値:
id メッセージ、メッセージクラス

getNumber

public String getNumber()
メッセージ、メッセージ番号を取得します。

戻り値:
number メッセージ、メッセージ番号

getMessage

public String getMessage()
メッセージテキストを取得します。

戻り値:
message メッセージテキスト

getLogNo

public String getLogNo()
アプリケーションログ: ログ番号を取得します。

戻り値:
logNo アプリケーションログ: ログ番号

getLogMsgNo

public String getLogMsgNo()
アプリケーションログ: メッセージシリアル番号を取得します。

戻り値:
logMsgNo アプリケーションログ: メッセージシリアル番号

getMessageV1

public String getMessageV1()
メッセージ、メッセージ変数を取得します。

戻り値:
messageV1 メッセージ、メッセージ変数

getMessageV2

public String getMessageV2()
メッセージ、メッセージ変数を取得します。

戻り値:
messageV2 メッセージ、メッセージ変数

getMessageV3

public String getMessageV3()
メッセージ、メッセージ変数を取得します。

戻り値:
messageV3 メッセージ、メッセージ変数

getMessageV4

public String getMessageV4()
メッセージ、メッセージ変数を取得します。

戻り値:
messageV4 メッセージ、メッセージ変数

getParameter

public String getParameter()
パラメータ名を取得します。

戻り値:
parameter パラメータ名

getRow

public String getRow()
パラメータの行を取得します。

戻り値:
row パラメータの行

getField

public String getField()
パラメータの項目を取得します。

戻り値:
field パラメータの項目

getSystem

public String getSystem()
メッセージが発行された論理システムを取得します。

戻り値:
system メッセージが発行された論理システム

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setType

public void setType(String type)
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を設定します。

パラメータ:
type - メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了

setId

public void setId(String id)
メッセージ、メッセージクラスを設定します。

パラメータ:
id - メッセージ、メッセージクラス

setNumber

public void setNumber(String number)
メッセージ、メッセージ番号を設定します。

パラメータ:
number - メッセージ、メッセージ番号

setMessage

public void setMessage(String message)
メッセージテキストを設定します。

パラメータ:
message - メッセージテキスト

setLogNo

public void setLogNo(String logNo)
アプリケーションログ: ログ番号を設定します。

パラメータ:
logNo - アプリケーションログ: ログ番号

setLogMsgNo

public void setLogMsgNo(String logMsgNo)
アプリケーションログ: メッセージシリアル番号を設定します。

パラメータ:
logMsgNo - アプリケーションログ: メッセージシリアル番号

setMessageV1

public void setMessageV1(String messageV1)
メッセージ、メッセージ変数を設定します。

パラメータ:
messageV1 - メッセージ、メッセージ変数

setMessageV2

public void setMessageV2(String messageV2)
メッセージ、メッセージ変数を設定します。

パラメータ:
messageV2 - メッセージ、メッセージ変数

setMessageV3

public void setMessageV3(String messageV3)
メッセージ、メッセージ変数を設定します。

パラメータ:
messageV3 - メッセージ、メッセージ変数

setMessageV4

public void setMessageV4(String messageV4)
メッセージ、メッセージ変数を設定します。

パラメータ:
messageV4 - メッセージ、メッセージ変数

setParameter

public void setParameter(String parameter)
パラメータ名を設定します。

パラメータ:
parameter - パラメータ名

setRow

public void setRow(String row)
パラメータの行を設定します。

パラメータ:
row - パラメータの行

setField

public void setField(String field)
パラメータの項目を設定します。

パラメータ:
field - パラメータの項目

setSystem

public void setSystem(String system)
メッセージが発行された論理システムを設定します。

パラメータ:
system - メッセージが発行された論理システム

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TotalConsumption (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス TotalConsumption

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption
すべての実装インタフェース:
Serializable
public class TotalConsumption
extends Object
implements Serializable

品目総消費量のデータ転送情報クラス
機能は以下の通り

  • 品目総消費量のデータ転送情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
TotalConsumption()
品目総消費量のデータ転送情報を作成します。
TotalConsumption(int index)
品目総消費量のデータ転送情報を作成します。
メソッドの概要
String | getConsValue() 消費量を取得します。
String | getCorrValue() 修正消費量を取得します。
String | getFirstDay() 値参照期間の第一日目を取得します。
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getPlant() プラントを取得します。
String | getValRatio() 元値に対する修正値の比率 (修正値: 元値)を取得します。
void | setConsValue(String consValue) 消費量を設定します。
void | setCorrValue(String corrValue) 修正消費量を設定します。
void | setFirstDay(String firstDay) 値参照期間の第一日目を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setPlant(String plant) プラントを設定します。
void | setValRatio(String valRatio) 元値に対する修正値の比率 (修正値: 元値)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

TotalConsumption

public TotalConsumption()
品目総消費量のデータ転送情報を作成します。

TotalConsumption

public TotalConsumption(int index)
品目総消費量のデータ転送情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getFirstDay

public String getFirstDay()
値参照期間の第一日目を取得します。

戻り値:
firstDay 値参照期間の第一日目

getConsValue

public String getConsValue()
消費量を取得します。

戻り値:
consValue 消費量

getCorrValue

public String getCorrValue()
修正消費量を取得します。

戻り値:
corrValue 修正消費量

getValRatio

public String getValRatio()
元値に対する修正値の比率 (修正値: 元値)を取得します。

戻り値:
valRatio 元値に対する修正値の比率 (修正値: 元値)

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setFirstDay

public void setFirstDay(String firstDay)
値参照期間の第一日目を設定します。

パラメータ:
firstDay - 値参照期間の第一日目

setConsValue

public void setConsValue(String consValue)
消費量を設定します。

パラメータ:
consValue - 消費量

setCorrValue

public void setCorrValue(String corrValue)
修正消費量を設定します。

パラメータ:
corrValue - 修正消費量

setValRatio

public void setValRatio(String valRatio)
元値に対する修正値の比率 (修正値: 元値)を設定します。

パラメータ:
valRatio - 元値に対する修正値の比率 (修正値: 元値)

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UnplndConsumption (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス UnplndConsumption

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption
すべての実装インタフェース:
Serializable
public class UnplndConsumption
extends Object
implements Serializable

計画外消費のデータ転送情報クラス
機能は以下の通り

  • 計画外消費のデータ転送情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
UnplndConsumption()
計画外消費のデータ転送情報を作成します。
UnplndConsumption(int index)
計画外消費のデータ転送情報を作成します。
メソッドの概要
String | getConsValue() 消費量を取得します。
String | getCorrValue() 修正消費量を取得します。
String | getFirstDay() 値参照期間の第一日目を取得します。
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getPlant() プラントを取得します。
String | getValRatio() 元値に対する修正値の比率 (修正値: 元値)を取得します。
void | setConsValue(String consValue) 消費量を設定します。
void | setCorrValue(String corrValue) 修正消費量を設定します。
void | setFirstDay(String firstDay) 値参照期間の第一日目を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setPlant(String plant) プラントを設定します。
void | setValRatio(String valRatio) 元値に対する修正値の比率 (修正値: 元値)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UnplndConsumption

public UnplndConsumption()
計画外消費のデータ転送情報を作成します。

UnplndConsumption

public UnplndConsumption(int index)
計画外消費のデータ転送情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getFirstDay

public String getFirstDay()
値参照期間の第一日目を取得します。

戻り値:
firstDay 値参照期間の第一日目

getConsValue

public String getConsValue()
消費量を取得します。

戻り値:
consValue 消費量

getCorrValue

public String getCorrValue()
修正消費量を取得します。

戻り値:
corrValue 修正消費量

getValRatio

public String getValRatio()
元値に対する修正値の比率 (修正値: 元値)を取得します。

戻り値:
valRatio 元値に対する修正値の比率 (修正値: 元値)

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setFirstDay

public void setFirstDay(String firstDay)
値参照期間の第一日目を設定します。

パラメータ:
firstDay - 値参照期間の第一日目

setConsValue

public void setConsValue(String consValue)
消費量を設定します。

パラメータ:
consValue - 消費量

setCorrValue

public void setCorrValue(String corrValue)
修正消費量を設定します。

パラメータ:
corrValue - 修正消費量

setValRatio

public void setValRatio(String valRatio)
元値に対する修正値の比率 (修正値: 元値)を設定します。

パラメータ:
valRatio - 元値に対する修正値の比率 (修正値: 元値)

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber の使用

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList の使用

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber
クラス
StdMaterialGetIntNumber
StdMaterialGetIntNumberList


jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber

クラスの概要
StdMaterialGetIntNumber | 品目コード割当済情報クラス 機能は以下の通り 品目コード割当済の情報を保持します。
StdMaterialGetIntNumberList | 品目コード割当済一覧クラス 機能は以下の通り 品目コード割当済の情報を一覧形式で取得します。


jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber の使用

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StdMaterialGetIntNumber (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber
クラス StdMaterialGetIntNumber

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber
すべての実装インタフェース:
Serializable
public class StdMaterialGetIntNumber
extends Object
implements Serializable

品目コード割当済情報クラス
機能は以下の通り

  • 品目コード割当済の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
StdMaterialGetIntNumber()
品目コード割当済情報を作成します。
メソッドの概要
String | getMaterial() 品目コードを取得します｡
String | getMaterialExternal() 項目 MATERIAL の品目コード (長)を取得します｡
String | getMaterialGuid() 項目 MATERIAL の外部 GUIDを取得します｡
String | getMaterialVersion() 項目 MATERIAL のバージョン番号を取得します｡
void | setMaterial(String material) 品目コードを設定します｡
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長)を設定します｡
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUIDを設定します｡
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StdMaterialGetIntNumber

public StdMaterialGetIntNumber()
品目コード割当済情報を作成します。

メソッドの詳細

setMaterial

public void setMaterial(String material)
品目コードを設定します｡

パラメータ:
material - 品目コード

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長)を設定します｡

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUIDを設定します｡

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号を設定します｡

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号

getMaterial

public String getMaterial()
品目コードを取得します｡

戻り値:
material

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長)を取得します｡

戻り値:
materialExternal

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUIDを取得します｡

戻り値:
materialGuid

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号を取得します｡

戻り値:
materialVersion

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


StdMaterialGetIntNumberList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber
クラス StdMaterialGetIntNumberList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList
すべての実装インタフェース:
Serializable
public class StdMaterialGetIntNumberList
extends ReferenceController
implements Serializable

品目コード割当済一覧クラス
機能は以下の通り

  • 品目コード割当済の情報を一覧形式で取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
StdMaterialGetIntNumberList(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
executeBapiを呼び出し品目コード割当済一覧を作成します。
メソッドの概要
List | getStdMaterialGetIntNumberList() 品目コード割当済一覧を取得します｡
void | setStdMaterialGetIntNumberList(List stdMaterialGetIntNumberList) 品目コード割当済一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StdMaterialGetIntNumberList

public StdMaterialGetIntNumberList(String materialType,
                                   String industrySector,
                                   String requiredNumbers,
                                   SapClient sapClient)
                            throws SAPAuthAppException,
                                   SAPAuthSystemException,
                                   SAPGeneralAppException,
                                   SAPGeneralSystemException,
                                   SAPPurchaseSystemException,
                                   SAPPurchaseAppException
executeBapiを呼び出し品目コード割当済一覧を作成します。

パラメータ:
materialType - 品目タイプ
industrySector - 産業コード
requiredNumbers - 必須品目コードの設定
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseSystemException - 購買系業務システム例外
SAPPurchaseAppException - 購買系業務アプリケーション例外
メソッドの詳細

setStdMaterialGetIntNumberList

public void setStdMaterialGetIntNumberList(List stdMaterialGetIntNumberList)
品目コード割当済一覧を設定します｡

パラメータ:
stdMaterialGetIntNumberList - 品目コード割当済一覧

getStdMaterialGetIntNumberList

public List getStdMaterialGetIntNumberList()
品目コード割当済一覧を取得します｡

戻り値:
stdMaterialGetIntNumberList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AllVersions (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス AllVersions

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.AllVersions
すべての実装インタフェース:
Serializable
public class AllVersions
extends Object
implements Serializable

全バージョン管理情報クラス
機能は以下の通り

  • 全バージョン管理情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
AllVersions()
バージョン管理を作成します。
メソッドの概要
String | getCompleted() ステータス "バージョン完了済"を取得します。
String | getCreatedBy() オブジェクト登録者名を取得します。
String | getCrOn() レコード登録日を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO コード通貨を取得します。
String | getDeleteInd() 購買伝票の削除フラグを取得します。
String | getDescription() バージョンテキスト（長）を取得します。
String | getDocNumber() 購買管理におけるオブジェクト番号を取得します。
String | getDocType() 購買伝票カテゴリを取得します。
String | getItemNumber() 購買管理オブジェクト: 明細を取得します。
String | getNetValue() 購買発注通貨による正味発注額を取得します。
String | getPostDate() バージョンの転記日付を取得します。
String | getReason() 変更理由を取得します。
String | getRecTime() 登録時刻を取得します。
String | getReleasebyPur() 承認購買担当者名を取得します。
String | getReleaseDate() 承認日を取得します。
String | getReleasedatePur() 購買担当者承認日付を取得します。
String | getReleasedBy() 承認者名を取得します。
String | getReleaseTime() 承認時刻を取得します。
String | getReleasetimePur() 購買担当者承認時刻を取得します。
String | getReqBy() 変更を依頼した従業員を取得します。
String | getReqByExt() バージョンの外部変更番号を取得します。
String | getStatus() バージョンステータスを取得します。
String | getStatusDocOld() このバージョンの前の旧処理状況 (購買伝票内)を取得します。
String | getValueChanged() バージョンによる金額変更を取得します。
String | getVersion() 購買管理におけるバージョン番号を取得します。
void | setCompleted(String strCompleted) ステータス "バージョン完了済"を設定します。
void | setCreatedBy(String strCreatedBy) オブジェクト登録者名を設定します。
void | setCrOn(String strCrOn) レコード登録日を設定します。
void | setCurrency(String strCurrency) 通貨コードを設定します。
void | setCurrencyIso(String strCurrencyIso) ISO コード通貨を設定します。
void | setDeleteInd(String strDeleteInd) 購買伝票の削除フラグを設定します。
void | setDescription(String strDescription) バージョンテキスト（長）を設定します。
void | setDocNumber(String strDocNumber) 購買管理におけるオブジェクト番号を設定します。
void | setDocType(String strDocType) 購買伝票カテゴリを設定します。
void | setItemNumber(String strItemNumber) 購買管理オブジェクト: 明細を設定します。
void | setNetValue(String strNetValue) 購買発注通貨による正味発注額を設定します。
void | setPostDate(String strPostDate) バージョンの転記日付を設定します。
void | setReason(String strReason) 変更理由を設定します。
void | setRecTime(String strRecTime) 登録時刻を設定します。
void | setReleasebyPur(String strReleasebyPur) 承認購買担当者名を設定します。
void | setReleaseDate(String strReleaseDate) 承認日を設定します。
void | setReleasedatePur(String strReleasedatePur) 購買担当者承認日付を設定します。
void | setReleasedBy(String strReleasedBy) 承認者名を設定します。
void | setReleaseTime(String strReleaseTime) 承認時刻を設定します。
void | setReleasetimePur(String strReleasetimePur) 購買担当者承認時刻を設定します。
void | setReqBy(String strReqBy) 変更を依頼した従業員を設定します。
void | setReqByExt(String strReqByExt) バージョンの外部変更番号を設定します。
void | setStatus(String strStatus) バージョンステータスを設定します。
void | setStatusDocOld(String strStatusDocOld) このバージョンの前の旧処理状況 (購買伝票内)を設定します。
void | setValueChanged(String strValueChanged) バージョンによる金額変更を設定します。
void | setVersion(String strVersion) 購買管理におけるバージョン番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AllVersions

public AllVersions()
バージョン管理を作成します。

メソッドの詳細

getDocType

public String getDocType()
購買伝票カテゴリを取得します。

戻り値:
srtDocType 購買伝票カテゴリ

getDocNumber

public String getDocNumber()
購買管理におけるオブジェクト番号を取得します。

戻り値:
srtDocNumber 購買管理におけるオブジェクト番号

getItemNumber

public String getItemNumber()
購買管理オブジェクト: 明細を取得します。

戻り値:
srtItemNumber 購買管理オブジェクト: 明細

getVersion

public String getVersion()
購買管理におけるバージョン番号を取得します。

戻り値:
srtVersion 購買管理におけるバージョン番号

getCreatedBy

public String getCreatedBy()
オブジェクト登録者名を取得します。

戻り値:
srtCreatedBy オブジェクト登録者名

getCrOn

public String getCrOn()
レコード登録日を取得します。

戻り値:
srtCrOn レコード登録日

getRecTime

public String getRecTime()
登録時刻を取得します。

戻り値:
srtRecTime 登録時刻

getReleasedBy

public String getReleasedBy()
承認者名を取得します。

戻り値:
srtReleasedBy 承認者名

getReleaseDate

public String getReleaseDate()
承認日を取得します。

戻り値:
srtReleaseDate 承認日

getReleaseTime

public String getReleaseTime()
承認時刻を取得します。

戻り値:
srtReleaseTime 承認時刻

getReleasebyPur

public String getReleasebyPur()
承認購買担当者名を取得します。

戻り値:
srtReleasebyPur 承認購買担当者名

getReleasedatePur

public String getReleasedatePur()
購買担当者承認日付を取得します。

戻り値:
srtReleasedatePur 購買担当者承認日付

getReleasetimePur

public String getReleasetimePur()
購買担当者承認時刻を取得します。

戻り値:
srtReleasetimePur 購買担当者承認時刻

getReason

public String getReason()
変更理由を取得します。

戻り値:
srtReason 変更理由

getDescription

public String getDescription()
バージョンテキスト（長）を取得します。

戻り値:
srtDescription バージョンテキスト（長）

getReqByExt

public String getReqByExt()
バージョンの外部変更番号を取得します。

戻り値:
srtReqByExt バージョンの外部変更番号

getReqBy

public String getReqBy()
変更を依頼した従業員を取得します。

戻り値:
srtReqBy 変更を依頼した従業員

getNetValue

public String getNetValue()
購買発注通貨による正味発注額を取得します。

戻り値:
srtNetValue 購買発注通貨による正味発注額

getValueChanged

public String getValueChanged()
バージョンによる金額変更を取得します。

戻り値:
srtValueChanged バージョンによる金額変更

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
srtCurrency 通貨コード

getCurrencyIso

public String getCurrencyIso()
ISO コード通貨を取得します。

戻り値:
srtCurrencyIso ISO コード通貨

getPostDate

public String getPostDate()
バージョンの転記日付を取得します。

戻り値:
srtPostDate バージョンの転記日付

getCompleted

public String getCompleted()
ステータス "バージョン完了済"を取得します。

戻り値:
srtCompleted ステータス "バージョン完了済"

getStatus

public String getStatus()
バージョンステータスを取得します。

戻り値:
srtStatus バージョンステータス

getDeleteInd

public String getDeleteInd()
購買伝票の削除フラグを取得します。

戻り値:
srtDeleteInd 購買伝票の削除フラグ

getStatusDocOld

public String getStatusDocOld()
このバージョンの前の旧処理状況 (購買伝票内)を取得します。

戻り値:
srtStatusDocOld このバージョンの前の旧処理状況 (購買伝票内)

setDocType

public void setDocType(String strDocType)
購買伝票カテゴリを設定します。

パラメータ:
strDocType - 購買伝票カテゴリ

setDocNumber

public void setDocNumber(String strDocNumber)
購買管理におけるオブジェクト番号を設定します。

パラメータ:
strDocNumber - 購買管理におけるオブジェクト番号

setItemNumber

public void setItemNumber(String strItemNumber)
購買管理オブジェクト: 明細を設定します。

パラメータ:
strItemNumber - 購買管理オブジェクト: 明細

setVersion

public void setVersion(String strVersion)
購買管理におけるバージョン番号を設定します。

パラメータ:
strVersion - 購買管理におけるバージョン番号

setCreatedBy

public void setCreatedBy(String strCreatedBy)
オブジェクト登録者名を設定します。

パラメータ:
strCreatedBy - オブジェクト登録者名

setCrOn

public void setCrOn(String strCrOn)
レコード登録日を設定します。

パラメータ:
strCrOn - レコード登録日

setRecTime

public void setRecTime(String strRecTime)
登録時刻を設定します。

パラメータ:
strRecTime - 登録時刻

setReleasedBy

public void setReleasedBy(String strReleasedBy)
承認者名を設定します。

パラメータ:
strReleasedBy - 承認者名

setReleaseDate

public void setReleaseDate(String strReleaseDate)
承認日を設定します。

パラメータ:
strReleaseDate - 承認日

setReleaseTime

public void setReleaseTime(String strReleaseTime)
承認時刻を設定します。

パラメータ:
strReleaseTime - 承認時刻

setReleasebyPur

public void setReleasebyPur(String strReleasebyPur)
承認購買担当者名を設定します。

パラメータ:
strReleasebyPur - 承認購買担当者名

setReleasedatePur

public void setReleasedatePur(String strReleasedatePur)
購買担当者承認日付を設定します。

パラメータ:
strReleasedatePur - 購買担当者承認日付

setReleasetimePur

public void setReleasetimePur(String strReleasetimePur)
購買担当者承認時刻を設定します。

パラメータ:
strReleasetimePur - 購買担当者承認時刻

setReason

public void setReason(String strReason)
変更理由を設定します。

パラメータ:
strReason - 変更理由

setDescription

public void setDescription(String strDescription)
バージョンテキスト（長）を設定します。

パラメータ:
strDescription - バージョンテキスト（長）

setReqByExt

public void setReqByExt(String strReqByExt)
バージョンの外部変更番号を設定します。

パラメータ:
strReqByExt - バージョンの外部変更番号

setReqBy

public void setReqBy(String strReqBy)
変更を依頼した従業員を設定します。

パラメータ:
strReqBy - 変更を依頼した従業員

setNetValue

public void setNetValue(String strNetValue)
購買発注通貨による正味発注額を設定します。

パラメータ:
strNetValue - 購買発注通貨による正味発注額

setValueChanged

public void setValueChanged(String strValueChanged)
バージョンによる金額変更を設定します。

パラメータ:
strValueChanged - バージョンによる金額変更

setCurrency

public void setCurrency(String strCurrency)
通貨コードを設定します。

パラメータ:
strCurrency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String strCurrencyIso)
ISO コード通貨を設定します。

パラメータ:
strCurrencyIso - ISO コード通貨

setPostDate

public void setPostDate(String strPostDate)
バージョンの転記日付を設定します。

パラメータ:
strPostDate - バージョンの転記日付

setCompleted

public void setCompleted(String strCompleted)
ステータス "バージョン完了済"を設定します。

パラメータ:
strCompleted - ステータス "バージョン完了済"

setStatus

public void setStatus(String strStatus)
バージョンステータスを設定します。

パラメータ:
strStatus - バージョンステータス

setDeleteInd

public void setDeleteInd(String strDeleteInd)
購買伝票の削除フラグを設定します。

パラメータ:
strDeleteInd - 購買伝票の削除フラグ

setStatusDocOld

public void setStatusDocOld(String strStatusDocOld)
このバージョンの前の旧処理状況 (購買伝票内)を設定します。

パラメータ:
strStatusDocOld - このバージョンの前の旧処理状況 (購買伝票内)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Cond (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス Cond

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Cond
すべての実装インタフェース:
Serializable
public class Cond
extends Object
implements Serializable

条件情報クラス
機能は以下の通り

  • 条件情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Cond()
条件を作成します。
Cond(int index)
条件を作成します。
メソッドの概要
String | getAccessSeq() 検索順序 - 検索番号を取得します。
String | getAccruals() 見越額関連条件 (運賃など)を取得します。
String | getApplicatio() アプリケーションを取得します。
String | getCalctypcon() 条件計算タイプを取得します。
String | getChangeId() 変更タイプ(U、I、E、D)を取得します。
int | getCoIndex() レコード番号を取得します｡
String | getConbaseval() 条件基礎値を取得します。
String | getCondchaman() 条件 (マニュアル変更済)を取得します。
String | getCondclass() 条件クラスを取得します。
String | getCondcntrl() 条件管理を取得します。
String | getCondconfig() システム設定の条件を取得します。
String | getCondcount() 条件連続番号を取得します。
String | getCondCount() 条件カウンタを取得します。
String | getCondincomp() 会社間請求の条件を取得します。
String | getCondisacti() 無効条件を取得します。
String | getConditionNo() 伝票条件番号を取得します。
String | getCondNo() 条件レコード番号を取得します。
String | getCondorigin() 条件生成区分を取得します。
String | getCondPUnt() 価格条件単位を取得します。
String | getCondStNo() ステップ番号を取得します。
String | getCondtype() 条件カテゴリ (例: 税、運賃、価格、原価)を取得します。
String | getCondType() 条件タイプを取得します。
String | getCondUnit() 条件単位を取得します。
String | getCondUnitIso() 条件数量単位 (ISO コード)を取得します。
String | getCondUpdat() 条件更新を取得します。
String | getCondValue() 条件レートを取得します。
String | getConexchrat() 現地通貨への換算レートに対する条件を取得します。
String | getConinvolst() 請求書一覧条件を取得します。
String | getConpricdat() 条件価格設定日付を取得します。
String | getCurrenckey() スケール通貨を取得します。
String | getCurrenckeyIso() ISO コード通貨を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO コード通貨を取得します。
String | getDenominato() 条件単位を基本単位へ変換する分母を取得します。
String | getFactbasval() 条件基礎値に対する要因を取得します。
String | getGroupcond() グループ条件区分を取得します。
String | getItmNumber() 条件明細番号を取得します。
String | getNumconvert() 条件単位を基本単位へ変換する分子を取得します。
String | getScalbasval() 条件のスケール基準値を取得します。
String | getScalebasin() スケール基準区分を取得します。
String | getScaletype() スケールタイプを取得します。
String | getStatCon() 統計に適用する条件を取得します。
String | getUnitmeasur() 条件スケール単位を取得します。
String | getUnitmeasurIso() 単位の ISO コードを取得します。
void | setAccessSeq(String strAccessSeq) 検索順序 - 検索番号を設定します。
void | setAccruals(String strAccruals) 見越額関連条件 (運賃など)を設定します。
void | setApplicatio(String strApplicatio) アプリケーションを設定します。
void | setCalctypcon(String strCalctypcon) 条件計算タイプを設定します。
void | setChangeId(String strChangeId) 変更タイプ(U、I、E、D)を設定します。
void | setCoIndex(int coIndex) レコード番号を設定します｡
void | setConbaseval(String strConbaseval) 条件基礎値を設定します。
void | setCondchaman(String strCondchaman) 条件 (マニュアル変更済)を設定します。
void | setCondclass(String strCondclass) 条件クラスを設定します。
void | setCondcntrl(String strCondcntrl) 条件管理を設定します。
void | setCondconfig(String strCondconfig) システム設定の条件を設定します。
void | setCondcount(String strCondcount) 条件連続番号を設定します。
void | setCondCount(String strCondCount) 条件カウンタを設定します。
void | setCondincomp(String strCondincomp) 会社間請求の条件を設定します。
void | setCondisacti(String strCondisacti) 無効条件を設定します。
void | setConditionNo(String strConditionNo) 伝票条件番号を設定します。
void | setCondNo(String strCondNo) 条件レコード番号を設定します。
void | setCondorigin(String strCondorigin) 条件生成区分を設定します。
void | setCondPUnt(String strCondPUnt) 価格条件単位を設定します。
void | setCondStNo(String strCondStNo) ステップ番号を設定します。
void | setCondtype(String strCondtype) 条件カテゴリ (例: 税、運賃、価格、原価)を設定します。
void | setCondType(String strCondType) 条件タイプを設定します。
void | setCondUnit(String strCondUnit) 条件単位を設定します。
void | setCondUnitIso(String strCondUnitIso) 条件数量単位 (ISO コード)を設定します。
void | setCondUpdat(String strCondUpdat) 条件更新を設定します。
void | setCondValue(String strCondValue) 条件レートを設定します。
void | setConexchrat(String strConexchrat) 現地通貨への換算レートに対する条件を設定します。
void | setConinvolst(String strConinvolst) 請求書一覧条件を設定します。
void | setConpricdat(String strConpricdat) 条件価格設定日付を設定します。
void | setCurrenckey(String strCurrenckey) スケール通貨を設定します。
void | setCurrenckeyIso(String strCurrenckeyIso) ISO コード通貨を設定します。
void | setCurrency(String strCurrency) 通貨コードを設定します。
void | setCurrencyIso(String strCurrencyIso) ISO コード通貨を設定します。
void | setDenominato(String strDenominato) 条件単位を基本単位へ変換する分母を設定します。
void | setFactbasval(String strFactbasval) 条件基礎値に対する要因を設定します。
void | setGroupcond(String strGroupcond) グループ条件区分を設定します。
void | setItmNumber(String strItmNumber) 条件明細番号を設定します。
void | setNumconvert(String strNumconvert) 条件単位を基本単位へ変換する分子を設定します。
void | setScalbasval(String strScalbasval) 条件のスケール基準値を設定します。
void | setScalebasin(String strScalebasin) スケール基準区分を設定します。
void | setScaletype(String strScaletype) スケールタイプを設定します。
void | setStatCon(String strStatCon) 統計に適用する条件を設定します。
void | setUnitmeasur(String strUnitmeasur) 条件スケール単位を設定します。
void | setUnitmeasurIso(String strUnitmeasurIso) 単位の ISO コードを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Cond

public Cond()
条件を作成します。

Cond

public Cond(int index)
条件を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getConditionNo

public String getConditionNo()
伝票条件番号を取得します。

戻り値:
srtConditionNo 伝票条件番号

getItmNumber

public String getItmNumber()
条件明細番号を取得します。

戻り値:
srtItmNumber 条件明細番号

getCondStNo

public String getCondStNo()
ステップ番号を取得します。

戻り値:
srtCondStNo ステップ番号

getCondCount

public String getCondCount()
条件カウンタを取得します。

戻り値:
srtCondCount 条件カウンタ

getCondType

public String getCondType()
条件タイプを取得します。

戻り値:
srtCondType 条件タイプ

getCondValue

public String getCondValue()
条件レートを取得します。

戻り値:
srtCondValue 条件レート

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
srtCurrency 通貨コード

getCurrencyIso

public String getCurrencyIso()
ISO コード通貨を取得します。

戻り値:
srtCurrencyIso ISO コード通貨

getCondUnit

public String getCondUnit()
条件単位を取得します。

戻り値:
srtCondUnit 条件単位

getCondUnitIso

public String getCondUnitIso()
条件数量単位 (ISO コード)を取得します。

戻り値:
srtCondUnitIso 条件数量単位 (ISO コード)

getCondPUnt

public String getCondPUnt()
価格条件単位を取得します。

戻り値:
srtCondPUnt 価格条件単位

getApplicatio

public String getApplicatio()
アプリケーションを取得します。

戻り値:
srtApplicatio アプリケーション

getConpricdat

public String getConpricdat()
条件価格設定日付を取得します。

戻り値:
srtConpricdat 条件価格設定日付

getCalctypcon

public String getCalctypcon()
条件計算タイプを取得します。

戻り値:
srtCalctypcon 条件計算タイプ

getConbaseval

public String getConbaseval()
条件基礎値を取得します。

戻り値:
srtConbaseval 条件基礎値

getConexchrat

public String getConexchrat()
現地通貨への換算レートに対する条件を取得します。

戻り値:
srtConexchrat 現地通貨への換算レートに対する条件

getNumconvert

public String getNumconvert()
条件単位を基本単位へ変換する分子を取得します。

戻り値:
srtNumconvert 条件単位を基本単位へ変換する分子

getDenominato

public String getDenominato()
条件単位を基本単位へ変換する分母を取得します。

戻り値:
srtDenominato 条件単位を基本単位へ変換する分母

getCondtype

public String getCondtype()
条件カテゴリ (例: 税、運賃、価格、原価)を取得します。

戻り値:
srtCondtype 条件カテゴリ (例: 税、運賃、価格、原価)

getStatCon

public String getStatCon()
統計に適用する条件を取得します。

戻り値:
srtStatCon 統計に適用する条件

getScaletype

public String getScaletype()
スケールタイプを取得します。

戻り値:
srtScaletype スケールタイプ

getAccruals

public String getAccruals()
見越額関連条件 (運賃など)を取得します。

戻り値:
srtAccruals 見越額関連条件 (運賃など)

getConinvolst

public String getConinvolst()
請求書一覧条件を取得します。

戻り値:
srtConinvolst 請求書一覧条件

getCondorigin

public String getCondorigin()
条件生成区分を取得します。

戻り値:
srtCondorigin 条件生成区分

getGroupcond

public String getGroupcond()
グループ条件区分を取得します。

戻り値:
srtGroupcond グループ条件区分

getCondUpdat

public String getCondUpdat()
条件更新を取得します。

戻り値:
srtCondUpdat 条件更新

getAccessSeq

public String getAccessSeq()
検索順序 - 検索番号を取得します。

戻り値:
srtAccessSeq 検索順序 - 検索番号

getCondcount

public String getCondcount()
条件連続番号を取得します。

戻り値:
srtCondcount 条件連続番号

getCondcntrl

public String getCondcntrl()
条件管理を取得します。

戻り値:
srtCondcntrl 条件管理

getCondisacti

public String getCondisacti()
無効条件を取得します。

戻り値:
srtCondisacti 無効条件

getCondclass

public String getCondclass()
条件クラスを取得します。

戻り値:
srtCondclass 条件クラス

getFactbasval

public String getFactbasval()
条件基礎値に対する要因を取得します。

戻り値:
srtFactbasval 条件基礎値に対する要因

getScalebasin

public String getScalebasin()
スケール基準区分を取得します。

戻り値:
srtScalebasin スケール基準区分

getScalbasval

public String getScalbasval()
条件のスケール基準値を取得します。

戻り値:
srtScalbasval 条件のスケール基準値

getUnitmeasur

public String getUnitmeasur()
条件スケール単位を取得します。

戻り値:
srtUnitmeasur 条件スケール単位

getUnitmeasurIso

public String getUnitmeasurIso()
単位の ISO コードを取得します。

戻り値:
srtUnitmeasurIso 単位の ISO コード

getCurrenckey

public String getCurrenckey()
スケール通貨を取得します。

戻り値:
srtCurrenckey スケール通貨

getCurrenckeyIso

public String getCurrenckeyIso()
ISO コード通貨を取得します。

戻り値:
srtCurrenckeyIso ISO コード通貨

getCondincomp

public String getCondincomp()
会社間請求の条件を取得します。

戻り値:
srtCondincomp 会社間請求の条件

getCondconfig

public String getCondconfig()
システム設定の条件を取得します。

戻り値:
srtCondconfig システム設定の条件

getCondchaman

public String getCondchaman()
条件 (マニュアル変更済)を取得します。

戻り値:
srtCondchaman 条件 (マニュアル変更済)

getCondNo

public String getCondNo()
条件レコード番号を取得します。

戻り値:
srtCondNo 条件レコード番号

getChangeId

public String getChangeId()
変更タイプ(U、I、E、D)を取得します。

戻り値:
srtChangeId 変更タイプ(U、I、E、D)

getCoIndex

public int getCoIndex()
レコード番号を取得します｡

戻り値:
deIndex レコード番号

setConditionNo

public void setConditionNo(String strConditionNo)
伝票条件番号を設定します。

パラメータ:
strConditionNo - 伝票条件番号

setItmNumber

public void setItmNumber(String strItmNumber)
条件明細番号を設定します。

パラメータ:
strItmNumber - 条件明細番号

setCondStNo

public void setCondStNo(String strCondStNo)
ステップ番号を設定します。

パラメータ:
strCondStNo - ステップ番号

setCondCount

public void setCondCount(String strCondCount)
条件カウンタを設定します。

パラメータ:
strCondCount - 条件カウンタ

setCondType

public void setCondType(String strCondType)
条件タイプを設定します。

パラメータ:
strCondType - 条件タイプ

setCondValue

public void setCondValue(String strCondValue)
条件レートを設定します。

パラメータ:
strCondValue - 条件レート

setCurrency

public void setCurrency(String strCurrency)
通貨コードを設定します。

パラメータ:
strCurrency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String strCurrencyIso)
ISO コード通貨を設定します。

パラメータ:
strCurrencyIso - ISO コード通貨

setCondUnit

public void setCondUnit(String strCondUnit)
条件単位を設定します。

パラメータ:
strCondUnit - 条件単位

setCondUnitIso

public void setCondUnitIso(String strCondUnitIso)
条件数量単位 (ISO コード)を設定します。

パラメータ:
strCondUnitIso - 条件数量単位 (ISO コード)

setCondPUnt

public void setCondPUnt(String strCondPUnt)
価格条件単位を設定します。

パラメータ:
strCondPUnt - 価格条件単位

setApplicatio

public void setApplicatio(String strApplicatio)
アプリケーションを設定します。

パラメータ:
strApplicatio - アプリケーション

setConpricdat

public void setConpricdat(String strConpricdat)
条件価格設定日付を設定します。

パラメータ:
strConpricdat - 条件価格設定日付

setCalctypcon

public void setCalctypcon(String strCalctypcon)
条件計算タイプを設定します。

パラメータ:
strCalctypcon - 条件計算タイプ

setConbaseval

public void setConbaseval(String strConbaseval)
条件基礎値を設定します。

パラメータ:
strConbaseval - 条件基礎値

setConexchrat

public void setConexchrat(String strConexchrat)
現地通貨への換算レートに対する条件を設定します。

パラメータ:
strConexchrat - 現地通貨への換算レートに対する条件

setNumconvert

public void setNumconvert(String strNumconvert)
条件単位を基本単位へ変換する分子を設定します。

パラメータ:
strNumconvert - 条件単位を基本単位へ変換する分子

setDenominato

public void setDenominato(String strDenominato)
条件単位を基本単位へ変換する分母を設定します。

パラメータ:
strDenominato - 条件単位を基本単位へ変換する分母

setCondtype

public void setCondtype(String strCondtype)
条件カテゴリ (例: 税、運賃、価格、原価)を設定します。

パラメータ:
strCondtype - 条件カテゴリ (例: 税、運賃、価格、原価)

setStatCon

public void setStatCon(String strStatCon)
統計に適用する条件を設定します。

パラメータ:
strStatCon - 統計に適用する条件

setScaletype

public void setScaletype(String strScaletype)
スケールタイプを設定します。

パラメータ:
strScaletype - スケールタイプ

setAccruals

public void setAccruals(String strAccruals)
見越額関連条件 (運賃など)を設定します。

パラメータ:
strAccruals - 見越額関連条件 (運賃など)

setConinvolst

public void setConinvolst(String strConinvolst)
請求書一覧条件を設定します。

パラメータ:
strConinvolst - 請求書一覧条件

setCondorigin

public void setCondorigin(String strCondorigin)
条件生成区分を設定します。

パラメータ:
strCondorigin - 条件生成区分

setGroupcond

public void setGroupcond(String strGroupcond)
グループ条件区分を設定します。

パラメータ:
strGroupcond - グループ条件区分

setCondUpdat

public void setCondUpdat(String strCondUpdat)
条件更新を設定します。

パラメータ:
strCondUpdat - 条件更新

setAccessSeq

public void setAccessSeq(String strAccessSeq)
検索順序 - 検索番号を設定します。

パラメータ:
strAccessSeq - 検索順序 - 検索番号

setCondcount

public void setCondcount(String strCondcount)
条件連続番号を設定します。

パラメータ:
strCondcount - 条件連続番号

setCondcntrl

public void setCondcntrl(String strCondcntrl)
条件管理を設定します。

パラメータ:
strCondcntrl - 条件管理

setCondisacti

public void setCondisacti(String strCondisacti)
無効条件を設定します。

パラメータ:
strCondisacti - 無効条件

setCondclass

public void setCondclass(String strCondclass)
条件クラスを設定します。

パラメータ:
strCondclass - 条件クラス

setFactbasval

public void setFactbasval(String strFactbasval)
条件基礎値に対する要因を設定します。

パラメータ:
strFactbasval - 条件基礎値に対する要因

setScalebasin

public void setScalebasin(String strScalebasin)
スケール基準区分を設定します。

パラメータ:
strScalebasin - スケール基準区分

setScalbasval

public void setScalbasval(String strScalbasval)
条件のスケール基準値を設定します。

パラメータ:
strScalbasval - 条件のスケール基準値

setUnitmeasur

public void setUnitmeasur(String strUnitmeasur)
条件スケール単位を設定します。

パラメータ:
strUnitmeasur - 条件スケール単位

setUnitmeasurIso

public void setUnitmeasurIso(String strUnitmeasurIso)
単位の ISO コードを設定します。

パラメータ:
strUnitmeasurIso - 単位の ISO コード

setCurrenckey

public void setCurrenckey(String strCurrenckey)
スケール通貨を設定します。

パラメータ:
strCurrenckey - スケール通貨

setCurrenckeyIso

public void setCurrenckeyIso(String strCurrenckeyIso)
ISO コード通貨を設定します。

パラメータ:
strCurrenckeyIso - ISO コード通貨

setCondincomp

public void setCondincomp(String strCondincomp)
会社間請求の条件を設定します。

パラメータ:
strCondincomp - 会社間請求の条件

setCondconfig

public void setCondconfig(String strCondconfig)
システム設定の条件を設定します。

パラメータ:
strCondconfig - システム設定の条件

setCondchaman

public void setCondchaman(String strCondchaman)
条件 (マニュアル変更済)を設定します。

パラメータ:
strCondchaman - 条件 (マニュアル変更済)

setCondNo

public void setCondNo(String strCondNo)
条件レコード番号を設定します。

パラメータ:
strCondNo - 条件レコード番号

setChangeId

public void setChangeId(String strChangeId)
変更タイプ(U、I、E、D)を設定します。

パラメータ:
strChangeId - 変更タイプ(U、I、E、D)

setCoIndex

public void setCoIndex(int coIndex)
レコード番号を設定します｡

パラメータ:
coIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ContractLimits (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ContractLimits

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits
すべての実装インタフェース:
Serializable
public class ContractLimits
extends Object
implements Serializable

外注基本契約制限情報クラス
機能は以下の通り

  • 外注基本契約情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ContractLimits()
外注基本契約を作成します。
ContractLimits(int index)
外注基本契約を作成します。
メソッドの概要
int | getClIndex() レコード番号を取得します｡
String | getConItem() 明細番号、契約を取得します。
String | getConNumber() 基本契約番号を取得します。
String | getDeleteInd() 削除フラグを取得します。
String | getLimit() 全体制限を取得します。
String | getLineNo() 制限の内部明細番号を取得します。
String | getNoLimit() 制限なしを取得します。
String | getPckgNo() パッケージ番号を取得します。
String | getPriceChg() 入力シートの価格変更を取得します。
String | getShortText() テキスト 1 (短)を取得します。
void | setClIndex(int clIndex) レコード番号を設定します｡
void | setConItem(String strConItem) 明細番号、契約を設定します。
void | setConNumber(String strConNumber) 基本契約番号を設定します。
void | setDeleteInd(String strDeleteInd) 削除フラグを設定します。
void | setLimit(String strLimit) 全体制限を設定します。
void | setLineNo(String strLineNo) 制限の内部明細番号を設定します。
void | setNoLimit(String strNoLimit) 制限なしを設定します。
void | setPckgNo(String strPckgNo) パッケージ番号を設定します。
void | setPriceChg(String strPriceChg) 入力シートの価格変更を設定します。
void | setShortText(String strShortText) テキスト 1 (短)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ContractLimits

public ContractLimits()
外注基本契約を作成します。

ContractLimits

public ContractLimits(int index)
外注基本契約を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPckgNo

public String getPckgNo()
パッケージ番号を取得します。

戻り値:
srtPckgNo パッケージ番号

getLineNo

public String getLineNo()
制限の内部明細番号を取得します。

戻り値:
srtLineNo 制限の内部明細番号

getConNumber

public String getConNumber()
基本契約番号を取得します。

戻り値:
srtConNumber 基本契約番号

getConItem

public String getConItem()
明細番号、契約を取得します。

戻り値:
srtConItem 明細番号、契約

getLimit

public String getLimit()
全体制限を取得します。

戻り値:
srtLimit 全体制限

getNoLimit

public String getNoLimit()
制限なしを取得します。

戻り値:
srtNoLimit 制限なし

getPriceChg

public String getPriceChg()
入力シートの価格変更を取得します。

戻り値:
srtPriceChg 入力シートの価格変更

getShortText

public String getShortText()
テキスト 1 (短)を取得します。

戻り値:
srtShortText テキスト 1 (短)

getDeleteInd

public String getDeleteInd()
削除フラグを取得します。

戻り値:
srtDeleteInd 削除フラグ

getClIndex

public int getClIndex()
レコード番号を取得します｡

戻り値:
clIndex レコード番号

setPckgNo

public void setPckgNo(String strPckgNo)
パッケージ番号を設定します。

パラメータ:
strPckgNo - パッケージ番号

setLineNo

public void setLineNo(String strLineNo)
制限の内部明細番号を設定します。

パラメータ:
strLineNo - 制限の内部明細番号

setConNumber

public void setConNumber(String strConNumber)
基本契約番号を設定します。

パラメータ:
strConNumber - 基本契約番号

setConItem

public void setConItem(String strConItem)
明細番号、契約を設定します。

パラメータ:
strConItem - 明細番号、契約

setLimit

public void setLimit(String strLimit)
全体制限を設定します。

パラメータ:
strLimit - 全体制限

setNoLimit

public void setNoLimit(String strNoLimit)
制限なしを設定します。

パラメータ:
strNoLimit - 制限なし

setPriceChg

public void setPriceChg(String strPriceChg)
入力シートの価格変更を設定します。

パラメータ:
strPriceChg - 入力シートの価格変更

setShortText

public void setShortText(String strShortText)
テキスト 1 (短)を設定します。

パラメータ:
strShortText - テキスト 1 (短)

setDeleteInd

public void setDeleteInd(String strDeleteInd)
削除フラグを設定します。

パラメータ:
strDeleteInd - 削除フラグ

setClIndex

public void setClIndex(int clIndex)
レコード番号を設定します｡

パラメータ:
clIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ContractService (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ContractService

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ContractService
すべての実装インタフェース:
Serializable
public class ContractService
extends Object
implements Serializable

外注サービス情報クラス
機能は以下の通り

  • 外注サービス情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ContractService()
外注サービスを作成します。
ContractService(int index)
外注サービスを作成します。
メソッドの概要
String | getAlternat() 代替明細を取得します。
String | getBaseUom() 基本数量単位を取得します。
String | getBasicLine() 基本明細を取得します。
String | getBaslineNo() 代替: 基本明細参照を取得します。
String | getBegintime() 開始時刻を取得します。
String | getBidder() 入札者の明細を取得します。
String | getBlanket() 包括明細を取得します。
String | getConLine() 入力: 基本契約の計画外を取得します。
String | getConPckg() 入力: 基本契約の計画外を取得します。
int | getCsIndex() レコード番号を取得します｡
String | getDate() 日付を取得します。
String | getDeleteInd() 削除フラグを取得します。
String | getDistrib() 複数勘定設定の配賦区分を取得します。
String | getEdition() サービスタイプのバージョンを取得します。
String | getEndtime() 終了時刻を取得します。
String | getEventual() 偶発的明細を取得します。
String | getExtLine() 明細番号を取得します。
String | getExtpersNo() 外部従業員番号を取得します。
String | getExtrefkey() サービスの外部参照キーを取得します。
String | getExtServ() 仕入先のサービス番号を取得します。
String | getFormula() 計算式番号を取得します。
String | getFormVal1() 計算式値を取得します。
String | getFormVal2() 計算式値を取得します。
String | getFormVal3() 計算式値を取得します。
String | getFormVal4() 計算式値を取得します。
String | getFormVal5() 計算式値を取得します。
String | getFromLine() 下限を取得します。
String | getGrPrice() 基準額を取得します。
String | getHiLineNo() 上位階層明細番号を取得します。
String | getInform() 情報行を取得します。
String | getLimitLine() 入力: 計画外、明細制限を取得します。
String | getLineNo() 内部明細番号を取得します。
String | getMatlGroup() 品目グループを取得します。
String | getOpenQty() 未処理数量のある明細を取得します。
String | getOutlInd() 区分: 出力行を取得します。
String | getOutlLevel() グループの階層レベルを取得します。
String | getOutlNo() アウトラインレベルを取得します。
String | getOvfTol() 超過許容値を取得します。
String | getOvfUnlim() 契約外サービス制限なしを取得します。
String | getPckgNo() パッケージ番号を取得します。
String | getPersNo() 従業員番号を取得します。
String | getPlnLine() 入力: 計画梱包明細行を取得します。
String | getPlnPckg() パッケージ番号供給元一覧を取得します。
String | getPriceChg() 入力シートの価格変更を取得します。
String | getPriceUnit() 価格単位を取得します。
String | getQuantity() +/- 記号あり/なし数量を取得します。
String | getService() 活動番号を取得します。
String | getServType() サービスタイプのテキスト (短)を取得します。
String | getShortText() テキスト(短)を取得します。
String | getSscItem() 標準サービスカタログ: 明細を取得します。
String | getSscLim() 標準サービスカタログ制限参照のサービス行を取得します。
String | getSubpckgNo() サブパッケージ番号を取得します。
String | getSuppLine() 補足明細を取得します。
String | getTargetVal() 目標値を取得します。
String | getTaxCode() 消費税コードを取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getTmpLine() 入力: モデル仕様からの計画外サービスを取得します。
String | getTmpPckg() 入力: モデル仕様からの計画外サービスを取得します。
String | getToLine() 上限を取得します。
String | getUomIso() 単位の ISO コードを取得します。
String | getUserf1Num() ユーザ定義項目を取得します。
String | getUserf1Txt() ユーザ定義項目を取得します。
String | getUserf2Num() ユーザ定義項目を取得します。
String | getUserf2Txt() ユーザ定義項目を取得します。
String | getWagetype() ウェイジタイプを取得します。
void | setAlternat(String strAlternat) 代替明細を設定します。
void | setBaseUom(String strBaseUom) 基本数量単位を設定します。
void | setBasicLine(String strBasicLine) 基本明細を設定します。
void | setBaslineNo(String strBaslineNo) 代替: 基本明細参照を設定します。
void | setBegintime(String strBegintime) 開始時刻を設定します。
void | setBidder(String strBidder) 入札者の明細を設定します。
void | setBlanket(String strBlanket) 包括明細を設定します。
void | setConLine(String strConLine) 入力: 基本契約の計画外を設定します。
void | setConPckg(String strConPckg) 入力: 基本契約の計画外を設定します。
void | setCsIndex(int csIndex) レコード番号を設定します｡
void | setDate(String strDate) 日付を設定します。
void | setDeleteInd(String strDeleteInd) 削除フラグを設定します。
void | setDistrib(String strDistrib) 複数勘定設定の配賦区分を設定します。
void | setEdition(String strEdition) サービスタイプのバージョンを設定します。
void | setEndtime(String strEndtime) 終了時刻を設定します。
void | setEventual(String strEventual) 偶発的明細を設定します。
void | setExtLine(String strExtLine) 明細番号を設定します。
void | setExtpersNo(String strExtpersNo) 外部従業員番号を設定します。
void | setExtrefkey(String strExtrefkey) サービスの外部参照キーを設定します。
void | setExtServ(String strExtServ) 仕入先のサービス番号を設定します。
void | setFormula(String strFormula) 計算式番号を設定します。
void | setFormVal1(String strFormVal1) 計算式値を設定します。
void | setFormVal2(String strFormVal2) 計算式値を設定します。
void | setFormVal3(String strFormVal3) 計算式値を設定します。
void | setFormVal4(String strFormVal4) 計算式値を設定します。
void | setFormVal5(String strFormVal5) 計算式値を設定します。
void | setFromLine(String strFromLine) 下限を設定します。
void | setGrPrice(String strGrPrice) 基準額を設定します。
void | setHiLineNo(String strHiLineNo) 上位階層明細番号を設定します。
void | setInform(String strInform) 情報行を設定します。
void | setLimitLine(String strLimitLine) 入力: 計画外、明細制限を設定します。
void | setLineNo(String strLineNo) 内部明細番号を設定します。
void | setMatlGroup(String strMatlGroup) 品目グループを設定します。
void | setOpenQty(String strOpenQty) 未処理数量のある明細を設定します。
void | setOutlInd(String strOutlInd) 区分: 出力行を設定します。
void | setOutlLevel(String strOutlLevel) グループの階層レベルを設定します。
void | setOutlNo(String strOutlNo) アウトラインレベルを設定します。
void | setOvfTol(String strOvfTol) 超過許容値を設定します。
void | setOvfUnlim(String strOvfUnlim) 契約外サービス制限なしを設定します。
void | setPckgNo(String strPckgNo) パッケージ番号を設定します。
void | setPersNo(String strPersNo) 従業員番号を設定します。
void | setPlnLine(String strPlnLine) 入力: 計画梱包明細行を設定します。
void | setPlnPckg(String strPlnPckg) パッケージ番号供給元一覧を設定します。
void | setPriceChg(String strPriceChg) 入力シートの価格変更を設定します。
void | setPriceUnit(String strPriceUnit) 価格単位を設定します。
void | setQuantity(String strQuantity) +/- 記号あり/なし数量を設定します。
void | setService(String strService) 活動番号を設定します。
void | setServType(String strServType) サービスタイプのテキスト (短)を設定します。
void | setShortText(String strShortText) テキスト(短)を設定します。
void | setSscItem(String strSscItem) 標準サービスカタログ: 明細を設定します。
void | setSscLim(String strSscLim) 標準サービスカタログ制限参照のサービス行を設定します。
void | setSubpckgNo(String strSubpckgNo) サブパッケージ番号を設定します。
void | setSuppLine(String strSuppLine) 補足明細を設定します。
void | setTargetVal(String strTargetVal) 目標値を設定します。
void | setTaxCode(String strTaxCode) 消費税コードを設定します。
void | setTaxjurcode(String strTaxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setTmpLine(String strTmpLine) 入力: モデル仕様からの計画外サービスを設定します。
void | setTmpPckg(String strTmpPckg) 入力: モデル仕様からの計画外サービスを設定します。
void | setToLine(String strToLine) 上限を設定します。
void | setUomIso(String strUomIso) 単位の ISO コードを設定します。
void | setUserf1Num(String strUserf1Num) ユーザ定義項目を設定します。
void | setUserf1Txt(String strUserf1Txt) ユーザ定義項目を設定します。
void | setUserf2Num(String strUserf2Num) ユーザ定義項目を設定します。
void | setUserf2Txt(String strUserf2Txt) ユーザ定義項目を設定します。
void | setWagetype(String strWagetype) ウェイジタイプを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ContractService

public ContractService()
外注サービスを作成します。

ContractService

public ContractService(int index)
外注サービスを作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPckgNo

public String getPckgNo()
パッケージ番号を取得します。

戻り値:
srtPckgNo パッケージ番号

getLineNo

public String getLineNo()
内部明細番号を取得します。

戻り値:
srtLineNo 内部明細番号

getExtLine

public String getExtLine()
明細番号を取得します。

戻り値:
srtExtLine 明細番号

getOutlLevel

public String getOutlLevel()
グループの階層レベルを取得します。

戻り値:
srtOutlLevel グループの階層レベル

getOutlNo

public String getOutlNo()
アウトラインレベルを取得します。

戻り値:
srtOutlNo アウトラインレベル

getOutlInd

public String getOutlInd()
区分: 出力行を取得します。

戻り値:
srtOutlInd 区分: 出力行

getSubpckgNo

public String getSubpckgNo()
サブパッケージ番号を取得します。

戻り値:
srtSubpckgNo サブパッケージ番号

getService

public String getService()
活動番号を取得します。

戻り値:
srtService 活動番号

getServType

public String getServType()
サービスタイプのテキスト (短)を取得します。

戻り値:
srtServType サービスタイプのテキスト (短)

getEdition

public String getEdition()
サービスタイプのバージョンを取得します。

戻り値:
srtEdition サービスタイプのバージョン

getSscItem

public String getSscItem()
標準サービスカタログ: 明細を取得します。

戻り値:
srtSscItem 標準サービスカタログ: 明細

getExtServ

public String getExtServ()
仕入先のサービス番号を取得します。

戻り値:
srtExtServ 仕入先のサービス番号

getQuantity

public String getQuantity()
+/- 記号あり/なし数量を取得します。

戻り値:
srtQuantity +/- 記号あり/なし数量

getBaseUom

public String getBaseUom()
基本数量単位を取得します。

戻り値:
srtBaseUom 基本数量単位

getUomIso

public String getUomIso()
単位の ISO コードを取得します。

戻り値:
srtUomIso 単位の ISO コード

getOvfTol

public String getOvfTol()
超過許容値を取得します。

戻り値:
srtOvfTol 超過許容値

getOvfUnlim

public String getOvfUnlim()
契約外サービス制限なしを取得します。

戻り値:
srtOvfUnlim 契約外サービス制限なし

getPriceUnit

public String getPriceUnit()
価格単位を取得します。

戻り値:
srtPriceUnit 価格単位

getGrPrice

public String getGrPrice()
基準額を取得します。

戻り値:
srtGrPrice 基準額

getFromLine

public String getFromLine()
下限を取得します。

戻り値:
srtFromLine 下限

getToLine

public String getToLine()
上限を取得します。

戻り値:
srtToLine 上限

getShortText

public String getShortText()
テキスト(短)を取得します。

戻り値:
srtShortText テキスト(短)

getDistrib

public String getDistrib()
複数勘定設定の配賦区分を取得します。

戻り値:
srtDistrib 複数勘定設定の配賦区分

getPersNo

public String getPersNo()
従業員番号を取得します。

戻り値:
srtPersNo 従業員番号

getWagetype

public String getWagetype()
ウェイジタイプを取得します。

戻り値:
srtWagetype ウェイジタイプ

getPlnPckg

public String getPlnPckg()
パッケージ番号供給元一覧を取得します。

戻り値:
srtPlnPckg パッケージ番号供給元一覧

getPlnLine

public String getPlnLine()
入力: 計画梱包明細行を取得します。

戻り値:
srtPlnLine 入力: 計画梱包明細行

getConPckg

public String getConPckg()
入力: 基本契約の計画外を取得します。

戻り値:
srtConPckg 入力: 基本契約の計画外

getConLine

public String getConLine()
入力: 基本契約の計画外を取得します。

戻り値:
srtConLine 入力: 基本契約の計画外

getTmpPckg

public String getTmpPckg()
入力: モデル仕様からの計画外サービスを取得します。

戻り値:
srtTmpPckg 入力: モデル仕様からの計画外サービス

getTmpLine

public String getTmpLine()
入力: モデル仕様からの計画外サービスを取得します。

戻り値:
srtTmpLine 入力: モデル仕様からの計画外サービス

getSscLim

public String getSscLim()
標準サービスカタログ制限参照のサービス行を取得します。

戻り値:
srtSscLim 標準サービスカタログ制限参照のサービス行

getLimitLine

public String getLimitLine()
入力: 計画外、明細制限を取得します。

戻り値:
srtLimitLine 入力: 計画外、明細制限

getTargetVal

public String getTargetVal()
目標値を取得します。

戻り値:
srtTargetVal 目標値

getBaslineNo

public String getBaslineNo()
代替: 基本明細参照を取得します。

戻り値:
srtBaslineNo 代替: 基本明細参照

getBasicLine

public String getBasicLine()
基本明細を取得します。

戻り値:
srtBasicLine 基本明細

getAlternat

public String getAlternat()
代替明細を取得します。

戻り値:
srtAlternat 代替明細

getBidder

public String getBidder()
入札者の明細を取得します。

戻り値:
srtBidder 入札者の明細

getSuppLine

public String getSuppLine()
補足明細を取得します。

戻り値:
srtSuppLine 補足明細

getOpenQty

public String getOpenQty()
未処理数量のある明細を取得します。

戻り値:
srtOpenQty 未処理数量のある明細

getInform

public String getInform()
情報行を取得します。

戻り値:
srtInform 情報行

getBlanket

public String getBlanket()
包括明細を取得します。

戻り値:
srtBlanket 包括明細

getEventual

public String getEventual()
偶発的明細を取得します。

戻り値:
srtEventual 偶発的明細

getTaxCode

public String getTaxCode()
消費税コードを取得します。

戻り値:
srtTaxCode 消費税コード

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
srtTaxjurcode 税計算管轄コード - 税管轄コード

getPriceChg

public String getPriceChg()
入力シートの価格変更を取得します。

戻り値:
srtPriceChg 入力シートの価格変更

getMatlGroup

public String getMatlGroup()
品目グループを取得します。

戻り値:
srtMatlGroup 品目グループ

getDate

public String getDate()
日付を取得します。

戻り値:
srtDate 日付

getBegintime

public String getBegintime()
開始時刻を取得します。

戻り値:
srtBegintime 開始時刻

getEndtime

public String getEndtime()
終了時刻を取得します。

戻り値:
srtEndtime 終了時刻

getExtpersNo

public String getExtpersNo()
外部従業員番号を取得します。

戻り値:
srtExtpersNo 外部従業員番号

getFormula

public String getFormula()
計算式番号を取得します。

戻り値:
srtFormula 計算式番号

getFormVal1

public String getFormVal1()
計算式値を取得します。

戻り値:
srtFormVal1 計算式値

getFormVal2

public String getFormVal2()
計算式値を取得します。

戻り値:
srtFormVal2 計算式値

getFormVal3

public String getFormVal3()
計算式値を取得します。

戻り値:
srtFormVal3 計算式値

getFormVal4

public String getFormVal4()
計算式値を取得します。

戻り値:
srtFormVal4 計算式値

getFormVal5

public String getFormVal5()
計算式値を取得します。

戻り値:
srtFormVal5 計算式値

getUserf1Num

public String getUserf1Num()
ユーザ定義項目を取得します。

戻り値:
srtUserf1Num ユーザ定義項目

getUserf2Num

public String getUserf2Num()
ユーザ定義項目を取得します。

戻り値:
srtUserf2Num ユーザ定義項目

getUserf1Txt

public String getUserf1Txt()
ユーザ定義項目を取得します。

戻り値:
srtUserf1Txt ユーザ定義項目

getUserf2Txt

public String getUserf2Txt()
ユーザ定義項目を取得します。

戻り値:
srtUserf2Txt ユーザ定義項目

getHiLineNo

public String getHiLineNo()
上位階層明細番号を取得します。

戻り値:
srtHiLineNo 上位階層明細番号

getExtrefkey

public String getExtrefkey()
サービスの外部参照キーを取得します。

戻り値:
srtExtrefkey サービスの外部参照キー

getDeleteInd

public String getDeleteInd()
削除フラグを取得します。

戻り値:
srtDeleteInd 削除フラグ

getCsIndex

public int getCsIndex()
レコード番号を取得します｡

戻り値:
csIndex レコード番号

setPckgNo

public void setPckgNo(String strPckgNo)
パッケージ番号を設定します。

パラメータ:
strPckgNo - パッケージ番号

setLineNo

public void setLineNo(String strLineNo)
内部明細番号を設定します。

パラメータ:
strLineNo - 内部明細番号

setExtLine

public void setExtLine(String strExtLine)
明細番号を設定します。

パラメータ:
strExtLine - 明細番号

setOutlLevel

public void setOutlLevel(String strOutlLevel)
グループの階層レベルを設定します。

パラメータ:
strOutlLevel - グループの階層レベル

setOutlNo

public void setOutlNo(String strOutlNo)
アウトラインレベルを設定します。

パラメータ:
strOutlNo - アウトラインレベル

setOutlInd

public void setOutlInd(String strOutlInd)
区分: 出力行を設定します。

パラメータ:
strOutlInd - 区分: 出力行

setSubpckgNo

public void setSubpckgNo(String strSubpckgNo)
サブパッケージ番号を設定します。

パラメータ:
strSubpckgNo - サブパッケージ番号

setService

public void setService(String strService)
活動番号を設定します。

パラメータ:
strService - 活動番号

setServType

public void setServType(String strServType)
サービスタイプのテキスト (短)を設定します。

パラメータ:
strServType - サービスタイプのテキスト (短)

setEdition

public void setEdition(String strEdition)
サービスタイプのバージョンを設定します。

パラメータ:
strEdition - サービスタイプのバージョン

setSscItem

public void setSscItem(String strSscItem)
標準サービスカタログ: 明細を設定します。

パラメータ:
strSscItem - 標準サービスカタログ: 明細

setExtServ

public void setExtServ(String strExtServ)
仕入先のサービス番号を設定します。

パラメータ:
strExtServ - 仕入先のサービス番号

setQuantity

public void setQuantity(String strQuantity)
+/- 記号あり/なし数量を設定します。

パラメータ:
strQuantity - +/- 記号あり/なし数量

setBaseUom

public void setBaseUom(String strBaseUom)
基本数量単位を設定します。

パラメータ:
strBaseUom - 基本数量単位

setUomIso

public void setUomIso(String strUomIso)
単位の ISO コードを設定します。

パラメータ:
strUomIso - 単位の ISO コード

setOvfTol

public void setOvfTol(String strOvfTol)
超過許容値を設定します。

パラメータ:
strOvfTol - 超過許容値

setOvfUnlim

public void setOvfUnlim(String strOvfUnlim)
契約外サービス制限なしを設定します。

パラメータ:
strOvfUnlim - 契約外サービス制限なし

setPriceUnit

public void setPriceUnit(String strPriceUnit)
価格単位を設定します。

パラメータ:
strPriceUnit - 価格単位

setGrPrice

public void setGrPrice(String strGrPrice)
基準額を設定します。

パラメータ:
strGrPrice - 基準額

setFromLine

public void setFromLine(String strFromLine)
下限を設定します。

パラメータ:
strFromLine - 下限

setToLine

public void setToLine(String strToLine)
上限を設定します。

パラメータ:
strToLine - 上限

setShortText

public void setShortText(String strShortText)
テキスト(短)を設定します。

パラメータ:
strShortText - テキスト(短)

setDistrib

public void setDistrib(String strDistrib)
複数勘定設定の配賦区分を設定します。

パラメータ:
strDistrib - 複数勘定設定の配賦区分

setPersNo

public void setPersNo(String strPersNo)
従業員番号を設定します。

パラメータ:
strPersNo - 従業員番号

setWagetype

public void setWagetype(String strWagetype)
ウェイジタイプを設定します。

パラメータ:
strWagetype - ウェイジタイプ

setPlnPckg

public void setPlnPckg(String strPlnPckg)
パッケージ番号供給元一覧を設定します。

パラメータ:
strPlnPckg - パッケージ番号供給元一覧

setPlnLine

public void setPlnLine(String strPlnLine)
入力: 計画梱包明細行を設定します。

パラメータ:
strPlnLine - 入力: 計画梱包明細行

setConPckg

public void setConPckg(String strConPckg)
入力: 基本契約の計画外を設定します。

パラメータ:
strConPckg - 入力: 基本契約の計画外

setConLine

public void setConLine(String strConLine)
入力: 基本契約の計画外を設定します。

パラメータ:
strConLine - 入力: 基本契約の計画外

setTmpPckg

public void setTmpPckg(String strTmpPckg)
入力: モデル仕様からの計画外サービスを設定します。

パラメータ:
strTmpPckg - 入力: モデル仕様からの計画外サービス

setTmpLine

public void setTmpLine(String strTmpLine)
入力: モデル仕様からの計画外サービスを設定します。

パラメータ:
strTmpLine - 入力: モデル仕様からの計画外サービス

setSscLim

public void setSscLim(String strSscLim)
標準サービスカタログ制限参照のサービス行を設定します。

パラメータ:
strSscLim - 標準サービスカタログ制限参照のサービス行

setLimitLine

public void setLimitLine(String strLimitLine)
入力: 計画外、明細制限を設定します。

パラメータ:
strLimitLine - 入力: 計画外、明細制限

setTargetVal

public void setTargetVal(String strTargetVal)
目標値を設定します。

パラメータ:
strTargetVal - 目標値

setBaslineNo

public void setBaslineNo(String strBaslineNo)
代替: 基本明細参照を設定します。

パラメータ:
strBaslineNo - 代替: 基本明細参照

setBasicLine

public void setBasicLine(String strBasicLine)
基本明細を設定します。

パラメータ:
strBasicLine - 基本明細

setAlternat

public void setAlternat(String strAlternat)
代替明細を設定します。

パラメータ:
strAlternat - 代替明細

setBidder

public void setBidder(String strBidder)
入札者の明細を設定します。

パラメータ:
strBidder - 入札者の明細

setSuppLine

public void setSuppLine(String strSuppLine)
補足明細を設定します。

パラメータ:
strSuppLine - 補足明細

setOpenQty

public void setOpenQty(String strOpenQty)
未処理数量のある明細を設定します。

パラメータ:
strOpenQty - 未処理数量のある明細

setInform

public void setInform(String strInform)
情報行を設定します。

パラメータ:
strInform - 情報行

setBlanket

public void setBlanket(String strBlanket)
包括明細を設定します。

パラメータ:
strBlanket - 包括明細

setEventual

public void setEventual(String strEventual)
偶発的明細を設定します。

パラメータ:
strEventual - 偶発的明細

setTaxCode

public void setTaxCode(String strTaxCode)
消費税コードを設定します。

パラメータ:
strTaxCode - 消費税コード

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税計算管轄コード - 税管轄コード

setPriceChg

public void setPriceChg(String strPriceChg)
入力シートの価格変更を設定します。

パラメータ:
strPriceChg - 入力シートの価格変更

setMatlGroup

public void setMatlGroup(String strMatlGroup)
品目グループを設定します。

パラメータ:
strMatlGroup - 品目グループ

setDate

public void setDate(String strDate)
日付を設定します。

パラメータ:
strDate - 日付

setBegintime

public void setBegintime(String strBegintime)
開始時刻を設定します。

パラメータ:
strBegintime - 開始時刻

setEndtime

public void setEndtime(String strEndtime)
終了時刻を設定します。

パラメータ:
strEndtime - 終了時刻

setExtpersNo

public void setExtpersNo(String strExtpersNo)
外部従業員番号を設定します。

パラメータ:
strExtpersNo - 外部従業員番号

setFormula

public void setFormula(String strFormula)
計算式番号を設定します。

パラメータ:
strFormula - 計算式番号

setFormVal1

public void setFormVal1(String strFormVal1)
計算式値を設定します。

パラメータ:
strFormVal1 - 計算式値

setFormVal2

public void setFormVal2(String strFormVal2)
計算式値を設定します。

パラメータ:
strFormVal2 - 計算式値

setFormVal3

public void setFormVal3(String strFormVal3)
計算式値を設定します。

パラメータ:
strFormVal3 - 計算式値

setFormVal4

public void setFormVal4(String strFormVal4)
計算式値を設定します。

パラメータ:
strFormVal4 - 計算式値

setFormVal5

public void setFormVal5(String strFormVal5)
計算式値を設定します。

パラメータ:
strFormVal5 - 計算式値

setUserf1Num

public void setUserf1Num(String strUserf1Num)
ユーザ定義項目を設定します。

パラメータ:
strUserf1Num - ユーザ定義項目

setUserf2Num

public void setUserf2Num(String strUserf2Num)
ユーザ定義項目を設定します。

パラメータ:
strUserf2Num - ユーザ定義項目

setUserf1Txt

public void setUserf1Txt(String strUserf1Txt)
ユーザ定義項目を設定します。

パラメータ:
strUserf1Txt - ユーザ定義項目

setUserf2Txt

public void setUserf2Txt(String strUserf2Txt)
ユーザ定義項目を設定します。

パラメータ:
strUserf2Txt - ユーザ定義項目

setHiLineNo

public void setHiLineNo(String strHiLineNo)
上位階層明細番号を設定します。

パラメータ:
strHiLineNo - 上位階層明細番号

setExtrefkey

public void setExtrefkey(String strExtrefkey)
サービスの外部参照キーを設定します。

パラメータ:
strExtrefkey - サービスの外部参照キー

setDeleteInd

public void setDeleteInd(String strDeleteInd)
削除フラグを設定します。

パラメータ:
strDeleteInd - 削除フラグ

setCsIndex

public void setCsIndex(int csIndex)
レコード番号を設定します｡

パラメータ:
csIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ContractServiceAccount (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ContractServiceAccount

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount
すべての実装インタフェース:
Serializable
public class ContractServiceAccount
extends Object
implements Serializable

外注サービス勘定設定情報クラス
機能は以下の通り

  • 外注サービス勘定設定情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ContractServiceAccount()
外注サービス勘定設定を作成します。
ContractServiceAccount(int index)
外注サービス勘定設定を作成します。
メソッドの概要
String | getLineNo() 明細行番号を取得します。
String | getNetValue() 明細の正味額を取得します。
String | getPckgNo() パッケージ番号を取得します。
String | getPercentage() 勘定設定金額配賦のパーセントを取得します。
String | getQuantity() +/- 記号あり/なし数量を取得します。
int | getSaIndex() レコード番号を取得します｡
String | getSerialNo() 勘定設定の連続番号を取得します。
String | getSernoLine() 勘定コード設定のシリアル番号、サービス明細を取得します。
void | setLineNo(String strLineNo) 明細行番号を設定します。
void | setNetValue(String strNetValue) 明細の正味額を設定します。
void | setPckgNo(String strPckgNo) パッケージ番号を設定します。
void | setPercentage(String strPercentage) 勘定設定金額配賦のパーセントを設定します。
void | setQuantity(String strQuantity) +/- 記号あり/なし数量を設定します。
void | setSaIndex(int saIndex) レコード番号を設定します｡
void | setSerialNo(String strSerialNo) 勘定設定の連続番号を設定します。
void | setSernoLine(String strSernoLine) 勘定コード設定のシリアル番号、サービス明細を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ContractServiceAccount

public ContractServiceAccount()
外注サービス勘定設定を作成します。

ContractServiceAccount

public ContractServiceAccount(int index)
外注サービス勘定設定を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPckgNo

public String getPckgNo()
パッケージ番号を取得します。

戻り値:
srtPckgNo パッケージ番号

getLineNo

public String getLineNo()
明細行番号を取得します。

戻り値:
srtLineNo 明細行番号

getSernoLine

public String getSernoLine()
勘定コード設定のシリアル番号、サービス明細を取得します。

戻り値:
srtSernoLine 勘定コード設定のシリアル番号、サービス明細

getPercentage

public String getPercentage()
勘定設定金額配賦のパーセントを取得します。

戻り値:
srtPercentage 勘定設定金額配賦のパーセント

getSerialNo

public String getSerialNo()
勘定設定の連続番号を取得します。

戻り値:
srtSerialNo 勘定設定の連続番号

getQuantity

public String getQuantity()
+/- 記号あり/なし数量を取得します。

戻り値:
srtQuantity +/- 記号あり/なし数量

getNetValue

public String getNetValue()
明細の正味額を取得します。

戻り値:
srtNetValue 明細の正味額

getSaIndex

public int getSaIndex()
レコード番号を取得します｡

戻り値:
saIndex レコード番号

setPckgNo

public void setPckgNo(String strPckgNo)
パッケージ番号を設定します。

パラメータ:
strPckgNo - パッケージ番号

setLineNo

public void setLineNo(String strLineNo)
明細行番号を設定します。

パラメータ:
strLineNo - 明細行番号

setSernoLine

public void setSernoLine(String strSernoLine)
勘定コード設定のシリアル番号、サービス明細を設定します。

パラメータ:
strSernoLine - 勘定コード設定のシリアル番号、サービス明細

setPercentage

public void setPercentage(String strPercentage)
勘定設定金額配賦のパーセントを設定します。

パラメータ:
strPercentage - 勘定設定金額配賦のパーセント

setSerialNo

public void setSerialNo(String strSerialNo)
勘定設定の連続番号を設定します。

パラメータ:
strSerialNo - 勘定設定の連続番号

setQuantity

public void setQuantity(String strQuantity)
+/- 記号あり/なし数量を設定します。

パラメータ:
strQuantity - +/- 記号あり/なし数量

setNetValue

public void setNetValue(String strNetValue)
明細の正味額を設定します。

パラメータ:
strNetValue - 明細の正味額

setSaIndex

public void setSaIndex(int saIndex)
レコード番号を設定します｡

パラメータ:
saIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ContractServiceText (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ContractServiceText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText
すべての実装インタフェース:
Serializable
public class ContractServiceText
extends PurchaseText

外注サービステキスト情報クラス
機能は以下の通り

  • 外注サービステキスト情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ContractServiceText()
外注サービステキストを作成します。
ContractServiceText(int index)
外注サービステキストを作成します。
メソッドの概要
String | getFormatCol() タグ列を取得します。
String | getLineNo() 内部明細番号を取得します。
String | getPckgNo() パッケージ番号を取得します。
void | setFormatCol(String strFormatCol) タグ列を設定します。
void | setLineNo(String strLineNo) 内部明細番号を設定します。
void | setPckgNo(String strPckgNo) パッケージ番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText から継承したメソッド
getPoItem, getPoNumber, getTeIndex, getTextForm, getTextId, getTextLine, setPoItem, setPoNumber, setTeIndex, setTextForm, setTextId, setTextLine
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ContractServiceText

public ContractServiceText()
外注サービステキストを作成します。

ContractServiceText

public ContractServiceText(int index)
外注サービステキストを作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPckgNo

public String getPckgNo()
パッケージ番号を取得します。

戻り値:
srtPckgNo パッケージ番号

getLineNo

public String getLineNo()
内部明細番号を取得します。

戻り値:
srtLineNo 内部明細番号

getFormatCol

public String getFormatCol()
タグ列を取得します。

戻り値:
srtFormatCol タグ列

setPckgNo

public void setPckgNo(String strPckgNo)
パッケージ番号を設定します。

パラメータ:
strPckgNo - パッケージ番号

setLineNo

public void setLineNo(String strLineNo)
内部明細番号を設定します。

パラメータ:
strLineNo - 内部明細番号

setFormatCol

public void setFormatCol(String strFormatCol)
タグ列を設定します。

パラメータ:
strFormatCol - タグ列

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス PurchaseText 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DeliveryAddress (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス DeliveryAddress

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress
すべての実装インタフェース:
Serializable
public class DeliveryAddress
extends Object
implements Serializable

入荷伝票アドレス情報クラス
機能は以下の通り

  • 入荷伝票アドレス情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
DeliveryAddress()
入荷伝票アドレスを作成します。
DeliveryAddress(int index)
入荷伝票アドレスを作成します。
メソッドの概要
String | getAddrNo() アドレス番号を取得します。
String | getAdrNotes() 住所注記を取得します。
String | getBuilding() 旧: 建物 (番号または略称)を取得します。
String | getBuildLong() 建物 (番号またはコード)を取得します。
String | getChckstatus() 市区町村ファイルテストステータスを取得します。
String | getCity() 市区町村を取得します。
String | getCityNo() 市区町村/地名ファイルの市区町村コードを取得します。
String | getCommType() 通信方法 (キー) (アドレス管理)を取得します。
String | getCOName() 気付を取得します。
String | getCountry() 国コードを取得します。
String | getCountryiso() ISO 国コードを取得します。
int | getDeIndex() レコード番号を取得します｡
String | getDelivDis() 郵便配達地域を取得します。
String | getDistrctNo() 市区町村/地名ファイルの所在地コードを取得します。
String | getDistrict() 所在地を取得します。
String | getEMail() 電子メールアドレスを取得します。
String | getFaxExtens() 第一 FAX 番号: 内線を取得します。
String | getFaxNumber() 第一 FAX 番号: ダイヤルコード + 番号を取得します。
String | getFloor() 建物の階を取得します。
String | getFormofaddr() 敬称テキストを取得します。
String | getHouseNo() 番地-号を取得します。
String | getHouseNo2() 番地補足を取得します。
String | getLangu() 言語キーを取得します。
String | getLanguIso() ISO 639 準拠の言語を取得します。
String | getLocation() 地名 5を取得します。
String | getName_2() 名称 2を取得します。
String | getName_3() 名称 3を取得します。
String | getName_4() 名称 4を取得します。
String | getName() 名称 1を取得します。
String | getPboxcitNo() 市区町村私書箱コード (市ファイル)を取得します。
String | getPoBox() 私書箱を取得します。
String | getPoBoxCit() 私書箱住所を取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
String | getPostlCod1() 市区町村の郵便番号を取得します。
String | getPostlCod2() 私書箱郵便番号を取得します。
String | getPostlCod3() 会社郵便番号 (大規模なユーザ用)を取得します。
String | getRegiogroup() 地域構造グループ化を取得します。
String | getRegion() 地域 (都道府県)を取得します。
String | getRoomNo() 部屋/アパート番号を取得します。
String | getSort1() 検索条件 1を取得します。
String | getSort2() 検索条件 2を取得します。
String | getStrAbbr() 地名の略称 (例: スペイン)を取得します。
String | getStreet() 地名を取得します。
String | getStreetLng() 地名を取得します。
String | getStreetNo() 市区町村/地名ファイルの地名コードを取得します。
String | getStrSuppl1() 地名 2を取得します。
String | getStrSuppl2() 地名 3を取得します。
String | getStrSuppl3() 地名 4を取得します。
String | getTaxjurcode() 税管轄コードを取得します。
String | getTel1Ext() 第 1 電話番号: 内線を取得します。
String | getTel1Numbr() 第一電話番号: ダイヤルコード + 番号を取得します。
String | getTimeZone() アドレスタイムゾーンを取得します。
String | getTitle() タイトル (敬称)を取得します。
String | getTranspzone() 商品の納入区域を取得します。
void | setAddrNo(String strAddrNo) アドレス番号を設定します。
void | setAdrNotes(String strAdrNotes) 住所注記を設定します。
void | setBuilding(String strBuilding) 旧: 建物 (番号または略称)を設定します。
void | setBuildLong(String strBuildLong) 建物 (番号またはコード)を設定します。
void | setChckstatus(String strChckstatus) 市区町村ファイルテストステータスを設定します。
void | setCity(String strCity) 市区町村を設定します。
void | setCityNo(String strCityNo) 市区町村/地名ファイルの市区町村コードを設定します。
void | setCommType(String strCommType) 通信方法 (キー) (アドレス管理)を設定します。
void | setCOName(String strCOName) 気付を設定します。
void | setCountry(String strCountry) 国コードを設定します。
void | setCountryiso(String strCountryiso) ISO 国コードを設定します。
void | setDeIndex(int deIndex) レコード番号を設定します｡
void | setDelivDis(String strDelivDis) 郵便配達地域を設定します。
void | setDistrctNo(String strDistrctNo) 市区町村/地名ファイルの所在地コードを設定します。
void | setDistrict(String strDistrict) 所在地を設定します。
void | setEMail(String strEMail) 電子メールアドレスを設定します。
void | setFaxExtens(String strFaxExtens) 第一 FAX 番号: 内線を設定します。
void | setFaxNumber(String strFaxNumber) 第一 FAX 番号: ダイヤルコード + 番号を設定します。
void | setFloor(String strFloor) 建物の階を設定します。
void | setFormofaddr(String strFormofaddr) 敬称テキストを設定します。
void | setHouseNo(String strHouseNo) 番地-号を設定します。
void | setHouseNo2(String strHouseNo2) 番地補足を設定します。
void | setLangu(String strLangu) 言語キーを設定します。
void | setLanguIso(String strLanguIso) ISO 639 準拠の言語を設定します。
void | setLocation(String strLocation) 地名 5を設定します。
void | setName_2(String strName2) 名称 2を設定します。
void | setName_3(String strName3) 名称 3を設定します。
void | setName_4(String strName4) 名称 4を設定します。
void | setName(String strName) 名称 1を設定します。
void | setPboxcitNo(String strPboxcitNo) 市区町村私書箱コード (市ファイル)を設定します。
void | setPoBox(String strPoBox) 私書箱を設定します。
void | setPoBoxCit(String strPoBoxCit) 私書箱住所を設定します。
void | setPoItem(String strPoItem) 購買伝票の明細番号を設定します。
void | setPostlCod1(String strPostlCod1) 市区町村の郵便番号を設定します。
void | setPostlCod2(String strPostlCod2) 私書箱郵便番号を設定します。
void | setPostlCod3(String strPostlCod3) 会社郵便番号 (大規模なユーザ用)を設定します。
void | setRegiogroup(String strRegiogroup) 地域構造グループ化を設定します。
void | setRegion(String strRegion) 地域 (都道府県)を設定します。
void | setRoomNo(String strRoomNo) 部屋/アパート番号を設定します。
void | setSort1(String strSort1) 検索条件 1を設定します。
void | setSort2(String strSort2) 検索条件 2を設定します。
void | setStrAbbr(String strStrAbbr) 地名の略称 (例: スペイン)を設定します。
void | setStreet(String strStreet) 地名を設定します。
void | setStreetLng(String strStreetLng) 地名を設定します。
void | setStreetNo(String strStreetNo) 市区町村/地名ファイルの地名コードを設定します。
void | setStrSuppl1(String strStrSuppl1) 地名 2を設定します。
void | setStrSuppl2(String strStrSuppl2) 地名 3を設定します。
void | setStrSuppl3(String strStrSuppl3) 地名 4を設定します。
void | setTaxjurcode(String strTaxjurcode) 税管轄コードを設定します。
void | setTel1Ext(String strTel1Ext) 第 1 電話番号: 内線を設定します。
void | setTel1Numbr(String strTel1Numbr) 第一電話番号: ダイヤルコード + 番号を設定します。
void | setTimeZone(String strTimeZone) アドレスタイムゾーンを設定します。
void | setTitle(String strTitle) タイトル (敬称)を設定します。
void | setTranspzone(String strTranspzone) 商品の納入区域を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DeliveryAddress

public DeliveryAddress()
入荷伝票アドレスを作成します。

DeliveryAddress

public DeliveryAddress(int index)
入荷伝票アドレスを作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
srtPoItem 購買伝票の明細番号

getAddrNo

public String getAddrNo()
アドレス番号を取得します。

戻り値:
srtAddrNo アドレス番号

getFormofaddr

public String getFormofaddr()
敬称テキストを取得します。

戻り値:
srtFormofaddr 敬称テキスト

getName

public String getName()
名称 1を取得します。

戻り値:
srtName 名称 1

getName_2

public String getName_2()
名称 2を取得します。

戻り値:
srtName2 名称 2

getName_3

public String getName_3()
名称 3を取得します。

戻り値:
srtName3 名称 3

getName_4

public String getName_4()
名称 4を取得します。

戻り値:
srtName4 名称 4

getCOName

public String getCOName()
気付を取得します。

戻り値:
srtCOName 気付

getCity

public String getCity()
市区町村を取得します。

戻り値:
srtCity 市区町村

getDistrict

public String getDistrict()
所在地を取得します。

戻り値:
srtDistrict 所在地

getCityNo

public String getCityNo()
市区町村/地名ファイルの市区町村コードを取得します。

戻り値:
srtCityNo 市区町村/地名ファイルの市区町村コード

getPostlCod1

public String getPostlCod1()
市区町村の郵便番号を取得します。

戻り値:
srtPostlCod1 市区町村の郵便番号

getPostlCod2

public String getPostlCod2()
私書箱郵便番号を取得します。

戻り値:
srtPostlCod2 私書箱郵便番号

getPostlCod3

public String getPostlCod3()
会社郵便番号 (大規模なユーザ用)を取得します。

戻り値:
srtPostlCod3 会社郵便番号 (大規模なユーザ用)

getPoBox

public String getPoBox()
私書箱を取得します。

戻り値:
srtPoBox 私書箱

getPoBoxCit

public String getPoBoxCit()
私書箱住所を取得します。

戻り値:
srtPoBoxCit 私書箱住所

getDelivDis

public String getDelivDis()
郵便配達地域を取得します。

戻り値:
srtDelivDis 郵便配達地域

getStreet

public String getStreet()
地名を取得します。

戻り値:
srtStreet 地名

getStreetNo

public String getStreetNo()
市区町村/地名ファイルの地名コードを取得します。

戻り値:
srtStreetNo 市区町村/地名ファイルの地名コード

getStrAbbr

public String getStrAbbr()
地名の略称 (例: スペイン)を取得します。

戻り値:
srtStrAbbr 地名の略称 (例: スペイン)

getHouseNo

public String getHouseNo()
番地-号を取得します。

戻り値:
srtHouseNo 番地-号

getStrSuppl1

public String getStrSuppl1()
地名 2を取得します。

戻り値:
srtStrSuppl1 地名 2

getStrSuppl2

public String getStrSuppl2()
地名 3を取得します。

戻り値:
srtStrSuppl2 地名 3

getLocation

public String getLocation()
地名 5を取得します。

戻り値:
srtLocation 地名 5

getBuilding

public String getBuilding()
旧: 建物 (番号または略称)を取得します。

戻り値:
srtBuilding 旧: 建物 (番号または略称)

getFloor

public String getFloor()
建物の階を取得します。

戻り値:
srtFloor 建物の階

getRoomNo

public String getRoomNo()
部屋/アパート番号を取得します。

戻り値:
srtRoomNo 部屋/アパート番号

getCountry

public String getCountry()
国コードを取得します。

戻り値:
srtCountry 国コード

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
srtLangu 言語キー

getRegion

public String getRegion()
地域 (都道府県)を取得します。

戻り値:
srtRegion 地域 (都道府県)

getSort1

public String getSort1()
検索条件 1を取得します。

戻り値:
srtSort1 検索条件 1

getSort2

public String getSort2()
検索条件 2を取得します。

戻り値:
srtSort2 検索条件 2

getTimeZone

public String getTimeZone()
アドレスタイムゾーンを取得します。

戻り値:
srtTimeZone アドレスタイムゾーン

getTaxjurcode

public String getTaxjurcode()
税管轄コードを取得します。

戻り値:
srtTaxjurcode 税管轄コード

getAdrNotes

public String getAdrNotes()
住所注記を取得します。

戻り値:
srtAdrNotes 住所注記

getCommType

public String getCommType()
通信方法 (キー) (アドレス管理)を取得します。

戻り値:
srtCommType 通信方法 (キー) (アドレス管理)

getTel1Numbr

public String getTel1Numbr()
第一電話番号: ダイヤルコード + 番号を取得します。

戻り値:
srtTel1Numbr 第一電話番号: ダイヤルコード + 番号

getTel1Ext

public String getTel1Ext()
第 1 電話番号: 内線を取得します。

戻り値:
srtTel1Ext 第 1 電話番号: 内線

getFaxNumber

public String getFaxNumber()
第一 FAX 番号: ダイヤルコード + 番号を取得します。

戻り値:
srtFaxNumber 第一 FAX 番号: ダイヤルコード + 番号

getFaxExtens

public String getFaxExtens()
第一 FAX 番号: 内線を取得します。

戻り値:
srtFaxExtens 第一 FAX 番号: 内線

getStreetLng

public String getStreetLng()
地名を取得します。

戻り値:
srtStreetLng 地名

getDistrctNo

public String getDistrctNo()
市区町村/地名ファイルの所在地コードを取得します。

戻り値:
srtDistrctNo 市区町村/地名ファイルの所在地コード

getChckstatus

public String getChckstatus()
市区町村ファイルテストステータスを取得します。

戻り値:
srtChckstatus 市区町村ファイルテストステータス

getPboxcitNo

public String getPboxcitNo()
市区町村私書箱コード (市ファイル)を取得します。

戻り値:
srtPboxcitNo 市区町村私書箱コード (市ファイル)

getTranspzone

public String getTranspzone()
商品の納入区域を取得します。

戻り値:
srtTranspzone 商品の納入区域

getHouseNo2

public String getHouseNo2()
番地補足を取得します。

戻り値:
srtHouseNo2 番地補足

getEMail

public String getEMail()
電子メールアドレスを取得します。

戻り値:
srtEMail 電子メールアドレス

getStrSuppl3

public String getStrSuppl3()
地名 4を取得します。

戻り値:
srtStrSuppl3 地名 4

getTitle

public String getTitle()
タイトル (敬称)を取得します。

戻り値:
srtTitle タイトル (敬称)

getCountryiso

public String getCountryiso()
ISO 国コードを取得します。

戻り値:
srtCountryiso ISO 国コード

getLanguIso

public String getLanguIso()
ISO 639 準拠の言語を取得します。

戻り値:
srtLanguIso ISO 639 準拠の言語

getBuildLong

public String getBuildLong()
建物 (番号またはコード)を取得します。

戻り値:
srtBuildLong 建物 (番号またはコード)

getRegiogroup

public String getRegiogroup()
地域構造グループ化を取得します。

戻り値:
srtRegiogroup 地域構造グループ化

getDeIndex

public int getDeIndex()
レコード番号を取得します｡

戻り値:
deIndex レコード番号

setPoItem

public void setPoItem(String strPoItem)
購買伝票の明細番号を設定します。

パラメータ:
strPoItem - 購買伝票の明細番号

setAddrNo

public void setAddrNo(String strAddrNo)
アドレス番号を設定します。

パラメータ:
strAddrNo - アドレス番号

setFormofaddr

public void setFormofaddr(String strFormofaddr)
敬称テキストを設定します。

パラメータ:
strFormofaddr - 敬称テキスト

setName

public void setName(String strName)
名称 1を設定します。

パラメータ:
strName - 名称 1

setName_2

public void setName_2(String strName2)
名称 2を設定します。

パラメータ:
strName2 - 名称 2

setName_3

public void setName_3(String strName3)
名称 3を設定します。

パラメータ:
strName3 - 名称 3

setName_4

public void setName_4(String strName4)
名称 4を設定します。

パラメータ:
strName4 - 名称 4

setCOName

public void setCOName(String strCOName)
気付を設定します。

パラメータ:
strCOName - 気付

setCity

public void setCity(String strCity)
市区町村を設定します。

パラメータ:
strCity - 市区町村

setDistrict

public void setDistrict(String strDistrict)
所在地を設定します。

パラメータ:
strDistrict - 所在地

setCityNo

public void setCityNo(String strCityNo)
市区町村/地名ファイルの市区町村コードを設定します。

パラメータ:
strCityNo - 市区町村/地名ファイルの市区町村コード

setPostlCod1

public void setPostlCod1(String strPostlCod1)
市区町村の郵便番号を設定します。

パラメータ:
strPostlCod1 - 市区町村の郵便番号

setPostlCod2

public void setPostlCod2(String strPostlCod2)
私書箱郵便番号を設定します。

パラメータ:
strPostlCod2 - 私書箱郵便番号

setPostlCod3

public void setPostlCod3(String strPostlCod3)
会社郵便番号 (大規模なユーザ用)を設定します。

パラメータ:
strPostlCod3 - 会社郵便番号 (大規模なユーザ用)

setPoBox

public void setPoBox(String strPoBox)
私書箱を設定します。

パラメータ:
strPoBox - 私書箱

setPoBoxCit

public void setPoBoxCit(String strPoBoxCit)
私書箱住所を設定します。

パラメータ:
strPoBoxCit - 私書箱住所

setDelivDis

public void setDelivDis(String strDelivDis)
郵便配達地域を設定します。

パラメータ:
strDelivDis - 郵便配達地域

setStreet

public void setStreet(String strStreet)
地名を設定します。

パラメータ:
strStreet - 地名

setStreetNo

public void setStreetNo(String strStreetNo)
市区町村/地名ファイルの地名コードを設定します。

パラメータ:
strStreetNo - 市区町村/地名ファイルの地名コード

setStrAbbr

public void setStrAbbr(String strStrAbbr)
地名の略称 (例: スペイン)を設定します。

パラメータ:
strStrAbbr - 地名の略称 (例: スペイン)

setHouseNo

public void setHouseNo(String strHouseNo)
番地-号を設定します。

パラメータ:
strHouseNo - 番地-号

setStrSuppl1

public void setStrSuppl1(String strStrSuppl1)
地名 2を設定します。

パラメータ:
strStrSuppl1 - 地名 2

setStrSuppl2

public void setStrSuppl2(String strStrSuppl2)
地名 3を設定します。

パラメータ:
strStrSuppl2 - 地名 3

setLocation

public void setLocation(String strLocation)
地名 5を設定します。

パラメータ:
strLocation - 地名 5

setBuilding

public void setBuilding(String strBuilding)
旧: 建物 (番号または略称)を設定します。

パラメータ:
strBuilding - 旧: 建物 (番号または略称)

setFloor

public void setFloor(String strFloor)
建物の階を設定します。

パラメータ:
strFloor - 建物の階

setRoomNo

public void setRoomNo(String strRoomNo)
部屋/アパート番号を設定します。

パラメータ:
strRoomNo - 部屋/アパート番号

setCountry

public void setCountry(String strCountry)
国コードを設定します。

パラメータ:
strCountry - 国コード

setLangu

public void setLangu(String strLangu)
言語キーを設定します。

パラメータ:
strLangu - 言語キー

setRegion

public void setRegion(String strRegion)
地域 (都道府県)を設定します。

パラメータ:
strRegion - 地域 (都道府県)

setSort1

public void setSort1(String strSort1)
検索条件 1を設定します。

パラメータ:
strSort1 - 検索条件 1

setSort2

public void setSort2(String strSort2)
検索条件 2を設定します。

パラメータ:
strSort2 - 検索条件 2

setTimeZone

public void setTimeZone(String strTimeZone)
アドレスタイムゾーンを設定します。

パラメータ:
strTimeZone - アドレスタイムゾーン

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税管轄コード

setAdrNotes

public void setAdrNotes(String strAdrNotes)
住所注記を設定します。

パラメータ:
strAdrNotes - 住所注記

setCommType

public void setCommType(String strCommType)
通信方法 (キー) (アドレス管理)を設定します。

パラメータ:
strCommType - 通信方法 (キー) (アドレス管理)

setTel1Numbr

public void setTel1Numbr(String strTel1Numbr)
第一電話番号: ダイヤルコード + 番号を設定します。

パラメータ:
strTel1Numbr - 第一電話番号: ダイヤルコード + 番号

setTel1Ext

public void setTel1Ext(String strTel1Ext)
第 1 電話番号: 内線を設定します。

パラメータ:
strTel1Ext - 第 1 電話番号: 内線

setFaxNumber

public void setFaxNumber(String strFaxNumber)
第一 FAX 番号: ダイヤルコード + 番号を設定します。

パラメータ:
strFaxNumber - 第一 FAX 番号: ダイヤルコード + 番号

setFaxExtens

public void setFaxExtens(String strFaxExtens)
第一 FAX 番号: 内線を設定します。

パラメータ:
strFaxExtens - 第一 FAX 番号: 内線

setStreetLng

public void setStreetLng(String strStreetLng)
地名を設定します。

パラメータ:
strStreetLng - 地名

setDistrctNo

public void setDistrctNo(String strDistrctNo)
市区町村/地名ファイルの所在地コードを設定します。

パラメータ:
strDistrctNo - 市区町村/地名ファイルの所在地コード

setChckstatus

public void setChckstatus(String strChckstatus)
市区町村ファイルテストステータスを設定します。

パラメータ:
strChckstatus - 市区町村ファイルテストステータス

setPboxcitNo

public void setPboxcitNo(String strPboxcitNo)
市区町村私書箱コード (市ファイル)を設定します。

パラメータ:
strPboxcitNo - 市区町村私書箱コード (市ファイル)

setTranspzone

public void setTranspzone(String strTranspzone)
商品の納入区域を設定します。

パラメータ:
strTranspzone - 商品の納入区域

setHouseNo2

public void setHouseNo2(String strHouseNo2)
番地補足を設定します。

パラメータ:
strHouseNo2 - 番地補足

setEMail

public void setEMail(String strEMail)
電子メールアドレスを設定します。

パラメータ:
strEMail - 電子メールアドレス

setStrSuppl3

public void setStrSuppl3(String strStrSuppl3)
地名 4を設定します。

パラメータ:
strStrSuppl3 - 地名 4

setTitle

public void setTitle(String strTitle)
タイトル (敬称)を設定します。

パラメータ:
strTitle - タイトル (敬称)

setCountryiso

public void setCountryiso(String strCountryiso)
ISO 国コードを設定します。

パラメータ:
strCountryiso - ISO 国コード

setLanguIso

public void setLanguIso(String strLanguIso)
ISO 639 準拠の言語を設定します。

パラメータ:
strLanguIso - ISO 639 準拠の言語

setBuildLong

public void setBuildLong(String strBuildLong)
建物 (番号またはコード)を設定します。

パラメータ:
strBuildLong - 建物 (番号またはコード)

setRegiogroup

public void setRegiogroup(String strRegiogroup)
地域構造グループ化を設定します。

パラメータ:
strRegiogroup - 地域構造グループ化

setDeIndex

public void setDeIndex(int deIndex)
レコード番号を設定します｡

パラメータ:
deIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DistributionChannelSelection (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス DistributionChannelSelection

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Selection
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection
すべての実装インタフェース:
Serializable
public class DistributionChannelSelection
extends Selection
implements Serializable

流通チャネルの選択オプションクラス
機能は以下の通り

  • 流通チャネルの選択オプションの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
DistributionChannelSelection()
流通チャネルの選択オプション情報を作成します。
DistributionChannelSelection(int index)
流通チャネルの選択オプション情報を作成します。
メソッドの概要
String | getDistrChanHigh() 流通チャネルの範囲終了を取得します。
String | getDistrChanLow() 流通チャネルの範囲開始を取得します。
int | getIndex() レコード番号を取得します。
void | setDistrChanHigh(String strDistrChanHigh) 流通チャネルの範囲終了を設定します。
void | setDistrChanLow(String strDistrChanLow) 流通チャネルの範囲開始を設定します。
void | setIndex(int index) レコード番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.Selection から継承したメソッド
getOption, getSign, setOption, setSign
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DistributionChannelSelection

public DistributionChannelSelection()
流通チャネルの選択オプション情報を作成します。

DistributionChannelSelection

public DistributionChannelSelection(int index)
流通チャネルの選択オプション情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getDistrChanLow

public String getDistrChanLow()
流通チャネルの範囲開始を取得します。

戻り値:
srtDistrChanLow

getDistrChanHigh

public String getDistrChanHigh()
流通チャネルの範囲終了を取得します。

戻り値:
srtDistrChanHigh

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index

setDistrChanLow

public void setDistrChanLow(String strDistrChanLow)
流通チャネルの範囲開始を設定します。

パラメータ:
strDistrChanLow - 流通チャネルの範囲開始

setDistrChanHigh

public void setDistrChanHigh(String strDistrChanHigh)
流通チャネルの範囲終了を設定します。

パラメータ:
strDistrChanHigh - 流通チャネルの範囲終了

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス Selection 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExportHeader (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ExportHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader
すべての実装インタフェース:
Serializable
public class ExportHeader
extends Object
implements Serializable

貿易管理ヘッダ情報クラス
機能は以下の通り

  • 貿易管理ヘッダ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExportHeader()
貿易管理明細を作成します。
メソッドの概要
String | getCustoms() 税関: 税関 (出国時)を取得します。
String | getTransportMode() 貿易管理の輸送モードを取得します。
void | setCustoms(String strCustoms) 税関: 税関 (出国時)を設定します。
void | setTransportMode(String strTransportMode) 貿易管理の輸送モードを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExportHeader

public ExportHeader()
貿易管理明細を作成します。

メソッドの詳細

getTransportMode

public String getTransportMode()
貿易管理の輸送モードを取得します。

戻り値:
srtTransportMode 貿易管理の輸送モード

getCustoms

public String getCustoms()
税関: 税関 (出国時)を取得します。

戻り値:
srtCustoms 税関: 税関 (出国時)

setTransportMode

public void setTransportMode(String strTransportMode)
貿易管理の輸送モードを設定します。

パラメータ:
strTransportMode - 貿易管理の輸送モード

setCustoms

public void setCustoms(String strCustoms)
税関: 税関 (出国時)を設定します。

パラメータ:
strCustoms - 税関: 税関 (出国時)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExportItem (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ExportItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ExportItem
すべての実装インタフェース:
Serializable
public class ExportItem
extends Object
implements Serializable

貿易管理明細情報クラス
機能は以下の通り

  • 貿易管理明細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExportItem()
貿易管理明細を作成します。
ExportItem(int index)
貿易管理明細を作成します。
メソッドの概要
String | getBusinessTransactionType() 貿易管理の取引タイプを取得します。
String | getCommCode() 貿易: 統計品目コード/輸入コード番号を取得します。
String | getCountryori() 品目の原産国を取得します。
String | getCountryoriIso() ISO 国コードを取得します。
int | getEiIndex() レコード番号を取得します｡
String | getExportImportProcedure() 貿易の輸出入手続を取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
String | getRegionorig() 品目の原産地 (非特恵対象地区の原産)を取得します。
String | getShippingCountry() 貿易: 出荷国を取得します。
String | getShippingCountryIso() ISO 国コードを取得します。
void | setBusinessTransactionType(String strBusinessTransactionType) 貿易管理の取引タイプを設定します。
void | setCommCode(String strCommCode) 貿易: 統計品目コード/輸入コード番号を設定します。
void | setCountryori(String strCountryori) 品目の原産国を設定します。
void | setCountryoriIso(String strCountryoriIso) ISO 国コードを設定します。
void | setEiIndex(int eiIndex) レコード番号を設定します｡
void | setExportImportProcedure(String strExportImportProcedure) 貿易の輸出入手続を設定します。
void | setPoItem(String strPoItem) 購買伝票の明細番号を設定します。
void | setRegionorig(String strRegionorig) 品目の原産地 (非特恵対象地区の原産)を設定します。
void | setShippingCountry(String strShippingCountry) 貿易: 出荷国を設定します。
void | setShippingCountryIso(String strShippingCountryIso) ISO 国コードを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExportItem

public ExportItem()
貿易管理明細を作成します。

ExportItem

public ExportItem(int index)
貿易管理明細を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
srtPoItem 購買伝票の明細番号

getBusinessTransactionType

public String getBusinessTransactionType()
貿易管理の取引タイプを取得します。

戻り値:
srtBusinessTransactionType 貿易管理の取引タイプ

getExportImportProcedure

public String getExportImportProcedure()
貿易の輸出入手続を取得します。

戻り値:
srtExportImportProcedure 貿易の輸出入手続

getCountryori

public String getCountryori()
品目の原産国を取得します。

戻り値:
srtCountryori 品目の原産国

getCountryoriIso

public String getCountryoriIso()
ISO 国コードを取得します。

戻り値:
srtCountryoriIso ISO 国コード

getRegionorig

public String getRegionorig()
品目の原産地 (非特恵対象地区の原産)を取得します。

戻り値:
srtRegionorig 品目の原産地 (非特恵対象地区の原産)

getCommCode

public String getCommCode()
貿易: 統計品目コード/輸入コード番号を取得します。

戻り値:
srtCommCode 貿易: 統計品目コード/輸入コード番号

getShippingCountry

public String getShippingCountry()
貿易: 出荷国を取得します。

戻り値:
srtShippingCountry 貿易: 出荷国

getShippingCountryIso

public String getShippingCountryIso()
ISO 国コードを取得します。

戻り値:
srtShippingCountryIso ISO 国コード

getEiIndex

public int getEiIndex()
レコード番号を取得します｡

戻り値:
eiIndex レコード番号

setPoItem

public void setPoItem(String strPoItem)
購買伝票の明細番号を設定します。

パラメータ:
strPoItem - 購買伝票の明細番号

setBusinessTransactionType

public void setBusinessTransactionType(String strBusinessTransactionType)
貿易管理の取引タイプを設定します。

パラメータ:
strBusinessTransactionType - 貿易管理の取引タイプ

setExportImportProcedure

public void setExportImportProcedure(String strExportImportProcedure)
貿易の輸出入手続を設定します。

パラメータ:
strExportImportProcedure - 貿易の輸出入手続

setCountryori

public void setCountryori(String strCountryori)
品目の原産国を設定します。

パラメータ:
strCountryori - 品目の原産国

setCountryoriIso

public void setCountryoriIso(String strCountryoriIso)
ISO 国コードを設定します。

パラメータ:
strCountryoriIso - ISO 国コード

setRegionorig

public void setRegionorig(String strRegionorig)
品目の原産地 (非特恵対象地区の原産)を設定します。

パラメータ:
strRegionorig - 品目の原産地 (非特恵対象地区の原産)

setCommCode

public void setCommCode(String strCommCode)
貿易: 統計品目コード/輸入コード番号を設定します。

パラメータ:
strCommCode - 貿易: 統計品目コード/輸入コード番号

setShippingCountry

public void setShippingCountry(String strShippingCountry)
貿易: 出荷国を設定します。

パラメータ:
strShippingCountry - 貿易: 出荷国

setShippingCountryIso

public void setShippingCountryIso(String strShippingCountryIso)
ISO 国コードを設定します。

パラメータ:
strShippingCountryIso - ISO 国コード

setEiIndex

public void setEiIndex(int eiIndex)
レコード番号を設定します｡

パラメータ:
eiIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Extension (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス Extension

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Extension
すべての実装インタフェース:
Serializable
public class Extension
extends Object
implements Serializable

拡張得意先項目情報クラス
機能は以下の通り

  • 拡張得意先項目情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Extension()
拡張得意先項目を作成します。
Extension(int index)
拡張得意先項目アドレスを作成します。
メソッドの概要
int | getExIndex() レコード番号を取得します｡
String | getStructure() BAPI テーブル拡張の構造名を取得します。
String | getValuepart1() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart2() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart3() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart4() BAPI 拡張パラメータのデータ部分を取得します。
void | setExIndex(int exIndex) レコード番号を設定します｡
void | setStructure(String strStructure) BAPI テーブル拡張の構造名を設定します。
void | setValuepart1(String strValuepart1) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart2(String strValuepart2) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart3(String strValuepart3) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart4(String strValuepart4) BAPI 拡張パラメータのデータ部分を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Extension

public Extension()
拡張得意先項目を作成します。

Extension

public Extension(int index)
拡張得意先項目アドレスを作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getStructure

public String getStructure()
BAPI テーブル拡張の構造名を取得します。

戻り値:
srtStructure BAPI テーブル拡張の構造名

getValuepart1

public String getValuepart1()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
srtValuepart1 BAPI 拡張パラメータのデータ部分

getValuepart2

public String getValuepart2()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
srtValuepart2 BAPI 拡張パラメータのデータ部分

getValuepart3

public String getValuepart3()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
srtValuepart3 BAPI 拡張パラメータのデータ部分

getValuepart4

public String getValuepart4()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
srtValuepart4 BAPI 拡張パラメータのデータ部分

getExIndex

public int getExIndex()
レコード番号を取得します｡

戻り値:
exIndex レコード番号

setStructure

public void setStructure(String strStructure)
BAPI テーブル拡張の構造名を設定します。

パラメータ:
strStructure - BAPI テーブル拡張の構造名

setValuepart1

public void setValuepart1(String strValuepart1)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
strValuepart1 - BAPI 拡張パラメータのデータ部分

setValuepart2

public void setValuepart2(String strValuepart2)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
strValuepart2 - BAPI 拡張パラメータのデータ部分

setValuepart3

public void setValuepart3(String strValuepart3)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
strValuepart3 - BAPI 拡張パラメータのデータ部分

setValuepart4

public void setValuepart4(String strValuepart4)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
strValuepart4 - BAPI 拡張パラメータのデータ部分

setExIndex

public void setExIndex(int exIndex)
レコード番号を設定します｡

パラメータ:
exIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtCreateController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス GoodsMvtCreateController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController
すべての実装インタフェース:
Serializable
public class GoodsMvtCreateController
extends GoodsMvtCreate
implements Serializable

入庫伝票登録コントローラクラス
機能は以下の通り

  • 入庫伝票を登録します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
GoodsMvtCreateController()
GoodsMvtCreateControllerのコンストラクタを生成します。
GoodsMvtCreateController(ConnectionManager connectionManager)
GoodsMvtCreateControllerのコンストラクタを生成します。
GoodsMvtCreateController(SapClient sapClient)
GoodsMvtCreateControllerのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
GoodsMvtCreateのexecuteBapi()を呼び出し品目コードを検索します。
 void setStrParam(String paramStr, String paramName, String value)
構造型の項目に値をセットします。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate から継承したメソッド
getGoodsMvtCode, getGoodsMvtHeader, getGoodsMvtHeadret, getGoodsMvtItemList, getGoodsMvtSerialNumberList, getMatdocumentyear, getMaterialdocument, getTestrun, setExportParam, setGoodsMvtCode, setGoodsMvtHeader, setGoodsMvtHeadret, setGoodsMvtItemList, setGoodsMvtSerialNumberList, setImportParam, setMatdocumentyear, setMaterialdocument, setTestrun, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtCreateController

public GoodsMvtCreateController()
GoodsMvtCreateControllerのコンストラクタを生成します。

GoodsMvtCreateController

public GoodsMvtCreateController(ConnectionManager connectionManager)
GoodsMvtCreateControllerのコンストラクタを生成します。

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

パラメータ:
connectionManager - コネクションマネージャー

GoodsMvtCreateController

public GoodsMvtCreateController(SapClient sapClient)
GoodsMvtCreateControllerのコンストラクタを生成します。

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバへデータを登録することが可能です。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
GoodsMvtCreateのexecuteBapi()を呼び出し品目コードを検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPPurchaseSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPPurchaseSystemException - 購買発注業務システム例外

setStrParam

public void setStrParam(String paramStr,
                        String paramName,
                        String value)
                 throws SAPPurchaseSystemException
構造型の項目に値をセットします。

パラメータ:
paramStr - 構造名
paramName - 項目名
value - セットする値
例外:
SAPPurchaseSystemException - 購買発注業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtGetItemsController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス GoodsMvtGetItemsController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController
すべての実装インタフェース:
Serializable
public class GoodsMvtGetItemsController
extends GoodsMvtGetItems
implements Serializable

入出庫伝票一覧取得コントローラクラス
機能は以下の通り

  • 入出庫伝票の一覧を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
GoodsMvtGetItemsController()
コンストラクタ生成
GoodsMvtGetItemsController(SapClient sapClient)
コンストラクタ生成
メソッドの概要
 void executeBapi()
GoodsMvtGetItemsのexecuteBapi()を呼び出し品目コードを検索します。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems から継承したメソッド
getBatchRaList, getGoodsMvtHeaderList, getGoodsMvtItemsList, getMaterialRaList, getMoveTypeRaList, getPlantRaList, getPstngDateRaList, getSpecStockRaList, getStgeLocRaList, getTrEvTypeRaList, getUserNameRaList, getVendorRaList, setBatchRaList, setExportParam, setGoodsMvtHeaderList, setGoodsMvtItemsList, setImportParam, setMaterialRaList, setMoveTypeRaList, setPlantRaList, setPstngDateRaList, setSpecStockRaList, setStgeLocRaList, setTrEvTypeRaList, setUserNameRaList, setVendorRaList, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtGetItemsController

public GoodsMvtGetItemsController()
コンストラクタ生成

GoodsMvtGetItemsController

public GoodsMvtGetItemsController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - SAPクライアント
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
GoodsMvtGetItemsのexecuteBapi()を呼び出し品目コードを検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPPurchaseSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPPurchaseSystemException - 購買発注業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Limits (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス Limits

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Limits
すべての実装インタフェース:
Serializable
public class Limits
extends Object
implements Serializable

外注制限情報クラス
機能は以下の通り

  • 外注制限情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Limits()
外注制限を作成します。
Limits(int index)
外注制限を作成します。
メソッドの概要
String | getConExist() 基本契約明細の制限を取得します。
String | getContPerc() 価格決定率を取得します。
String | getEdition() サービスタイプのバージョンを取得します。
String | getExpValue() 見込金額を取得します。
String | getFreeLimit() 自由制限を取得します。
int | getLiIndex() レコード番号を取得します｡
String | getLimit() 全体制限を取得します。
String | getNoFrlimit() 制限なしを取得します。
String | getNoLimit() 制限なしを取得します。
String | getPckgNo() パッケージ番号を取得します。
String | getPriceChg() 入力シートの価格変更を取得します。
String | getServType() サービスタイプのテキスト (短)を取得します。
String | getSscExist() サービスタイプの制限を取得します。
String | getSscLimit() サービスタイプの金額制限を取得します。
String | getSscNolim() 標準サービスタイプの制限なしを取得します。
String | getSscPerc() 価格決定率を取得します。
String | getSscPrschg() 入力シートの価格変更を取得します。
String | getTmpExist() サービスパッケージの制限を取得します。
String | getTmpLimit() モデルサービス明細制限を取得します。
String | getTmpNolim() モデル仕様の制限なしを取得します。
String | getTmpNumber() モデルサービス明細セット番号を取得します。
String | getTmpPerc() 価格決定率を取得します。
String | getTmpPrschg() 入力シートの価格変更を取得します。
void | setConExist(String strConExist) 基本契約明細の制限を設定します。
void | setContPerc(String strContPerc) 価格決定率を設定します。
void | setEdition(String strEdition) サービスタイプのバージョンを設定します。
void | setExpValue(String strExpValue) 見込金額を設定します。
void | setFreeLimit(String strFreeLimit) 自由制限を設定します。
void | setLiIndex(int liIndex) レコード番号を設定します｡
void | setLimit(String strLimit) 全体制限を設定します。
void | setNoFrlimit(String strNoFrlimit) 制限なしを設定します。
void | setNoLimit(String strNoLimit) 制限なしを設定します。
void | setPckgNo(String strPckgNo) パッケージ番号を設定します。
void | setPriceChg(String strPriceChg) 入力シートの価格変更を設定します。
void | setServType(String strServType) サービスタイプのテキスト (短)を設定します。
void | setSscExist(String strSscExist) サービスタイプの制限を設定します。
void | setSscLimit(String strSscLimit) サービスタイプの金額制限を設定します。
void | setSscNolim(String strSscNolim) 標準サービスタイプの制限なしを設定します。
void | setSscPerc(String strSscPerc) 価格決定率を設定します。
void | setSscPrschg(String strSscPrschg) 入力シートの価格変更を設定します。
void | setTmpExist(String strTmpExist) サービスパッケージの制限を設定します。
void | setTmpLimit(String strTmpLimit) モデルサービス明細制限を設定します。
void | setTmpNolim(String strTmpNolim) モデル仕様の制限なしを設定します。
void | setTmpNumber(String strTmpNumber) モデルサービス明細セット番号を設定します。
void | setTmpPerc(String strTmpPerc) 価格決定率を設定します。
void | setTmpPrschg(String strTmpPrschg) 入力シートの価格変更を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Limits

public Limits()
外注制限を作成します。

Limits

public Limits(int index)
外注制限を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPckgNo

public String getPckgNo()
パッケージ番号を取得します。

戻り値:
srtPckgNo パッケージ番号

getLimit

public String getLimit()
全体制限を取得します。

戻り値:
srtLimit 全体制限

getNoLimit

public String getNoLimit()
制限なしを取得します。

戻り値:
srtNoLimit 制限なし

getExpValue

public String getExpValue()
見込金額を取得します。

戻り値:
srtExpValue 見込金額

getSscExist

public String getSscExist()
サービスタイプの制限を取得します。

戻り値:
srtSscExist サービスタイプの制限

getConExist

public String getConExist()
基本契約明細の制限を取得します。

戻り値:
srtConExist 基本契約明細の制限

getTmpExist

public String getTmpExist()
サービスパッケージの制限を取得します。

戻り値:
srtTmpExist サービスパッケージの制限

getPriceChg

public String getPriceChg()
入力シートの価格変更を取得します。

戻り値:
srtPriceChg 入力シートの価格変更

getFreeLimit

public String getFreeLimit()
自由制限を取得します。

戻り値:
srtFreeLimit 自由制限

getNoFrlimit

public String getNoFrlimit()
制限なしを取得します。

戻り値:
srtNoFrlimit 制限なし

getServType

public String getServType()
サービスタイプのテキスト (短)を取得します。

戻り値:
srtServType サービスタイプのテキスト (短)

getEdition

public String getEdition()
サービスタイプのバージョンを取得します。

戻り値:
srtEdition サービスタイプのバージョン

getSscLimit

public String getSscLimit()
サービスタイプの金額制限を取得します。

戻り値:
srtSscLimit サービスタイプの金額制限

getSscNolim

public String getSscNolim()
標準サービスタイプの制限なしを取得します。

戻り値:
srtSscNolim 標準サービスタイプの制限なし

getSscPrschg

public String getSscPrschg()
入力シートの価格変更を取得します。

戻り値:
srtSscPrschg 入力シートの価格変更

getSscPerc

public String getSscPerc()
価格決定率を取得します。

戻り値:
srtSscPerc 価格決定率

getTmpNumber

public String getTmpNumber()
モデルサービス明細セット番号を取得します。

戻り値:
srtTmpNumber モデルサービス明細セット番号

getTmpLimit

public String getTmpLimit()
モデルサービス明細制限を取得します。

戻り値:
srtTmpLimit モデルサービス明細制限

getTmpNolim

public String getTmpNolim()
モデル仕様の制限なしを取得します。

戻り値:
srtTmpNolim モデル仕様の制限なし

getTmpPrschg

public String getTmpPrschg()
入力シートの価格変更を取得します。

戻り値:
srtTmpPrschg 入力シートの価格変更

getTmpPerc

public String getTmpPerc()
価格決定率を取得します。

戻り値:
srtTmpPerc 価格決定率

getContPerc

public String getContPerc()
価格決定率を取得します。

戻り値:
srtContPerc 価格決定率

getLiIndex

public int getLiIndex()
レコード番号を取得します｡

戻り値:
liIndex レコード番号

setPckgNo

public void setPckgNo(String strPckgNo)
パッケージ番号を設定します。

パラメータ:
strPckgNo - パッケージ番号

setLimit

public void setLimit(String strLimit)
全体制限を設定します。

パラメータ:
strLimit - 全体制限

setNoLimit

public void setNoLimit(String strNoLimit)
制限なしを設定します。

パラメータ:
strNoLimit - 制限なし

setExpValue

public void setExpValue(String strExpValue)
見込金額を設定します。

パラメータ:
strExpValue - 見込金額

setSscExist

public void setSscExist(String strSscExist)
サービスタイプの制限を設定します。

パラメータ:
strSscExist - サービスタイプの制限

setConExist

public void setConExist(String strConExist)
基本契約明細の制限を設定します。

パラメータ:
strConExist - 基本契約明細の制限

setTmpExist

public void setTmpExist(String strTmpExist)
サービスパッケージの制限を設定します。

パラメータ:
strTmpExist - サービスパッケージの制限

setPriceChg

public void setPriceChg(String strPriceChg)
入力シートの価格変更を設定します。

パラメータ:
strPriceChg - 入力シートの価格変更

setFreeLimit

public void setFreeLimit(String strFreeLimit)
自由制限を設定します。

パラメータ:
strFreeLimit - 自由制限

setNoFrlimit

public void setNoFrlimit(String strNoFrlimit)
制限なしを設定します。

パラメータ:
strNoFrlimit - 制限なし

setServType

public void setServType(String strServType)
サービスタイプのテキスト (短)を設定します。

パラメータ:
strServType - サービスタイプのテキスト (短)

setEdition

public void setEdition(String strEdition)
サービスタイプのバージョンを設定します。

パラメータ:
strEdition - サービスタイプのバージョン

setSscLimit

public void setSscLimit(String strSscLimit)
サービスタイプの金額制限を設定します。

パラメータ:
strSscLimit - サービスタイプの金額制限

setSscNolim

public void setSscNolim(String strSscNolim)
標準サービスタイプの制限なしを設定します。

パラメータ:
strSscNolim - 標準サービスタイプの制限なし

setSscPrschg

public void setSscPrschg(String strSscPrschg)
入力シートの価格変更を設定します。

パラメータ:
strSscPrschg - 入力シートの価格変更

setSscPerc

public void setSscPerc(String strSscPerc)
価格決定率を設定します。

パラメータ:
strSscPerc - 価格決定率

setTmpNumber

public void setTmpNumber(String strTmpNumber)
モデルサービス明細セット番号を設定します。

パラメータ:
strTmpNumber - モデルサービス明細セット番号

setTmpLimit

public void setTmpLimit(String strTmpLimit)
モデルサービス明細制限を設定します。

パラメータ:
strTmpLimit - モデルサービス明細制限

setTmpNolim

public void setTmpNolim(String strTmpNolim)
モデル仕様の制限なしを設定します。

パラメータ:
strTmpNolim - モデル仕様の制限なし

setTmpPrschg

public void setTmpPrschg(String strTmpPrschg)
入力シートの価格変更を設定します。

パラメータ:
strTmpPrschg - 入力シートの価格変更

setTmpPerc

public void setTmpPerc(String strTmpPerc)
価格決定率を設定します。

パラメータ:
strTmpPerc - 価格決定率

setContPerc

public void setContPerc(String strContPerc)
価格決定率を設定します。

パラメータ:
strContPerc - 価格決定率

setLiIndex

public void setLiIndex(int liIndex)
レコード番号を設定します｡

パラメータ:
liIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ManufacturerPartNumb (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ManufacturerPartNumb

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb
すべての実装インタフェース:
Serializable
public class ManufacturerPartNumb
extends Object
implements Serializable

製造業者と製造者製品コードクラス
機能は以下の通り

  • 製造業者と製造者製品コードの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ManufacturerPartNumb()
製造業者と製造者製品コード情報を作成します。
ManufacturerPartNumb(int index)
製造業者と製造者製品コード情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します。
String | getManuMat() 製造者製品コードを取得します。
String | getMfrNo() 製造者番号を取得します。
void | setIndex(int index) レコード番号を設定します。
void | setManuMat(String strManuMat) 製造者製品コードを設定します。
void | setMfrNo(String strMfrNo) 製造者番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ManufacturerPartNumb

public ManufacturerPartNumb()
製造業者と製造者製品コード情報を作成します。

ManufacturerPartNumb

public ManufacturerPartNumb(int index)
製造業者と製造者製品コード情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getManuMat

public String getManuMat()
製造者製品コードを取得します。

戻り値:
srtManuMat 製造者製品コード

getMfrNo

public String getMfrNo()
製造者番号を取得します。

戻り値:
srtMfrNo 製造者番号

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index レコード番号

setManuMat

public void setManuMat(String strManuMat)
製造者製品コードを設定します。

パラメータ:
strManuMat - 製造者製品コード

setMfrNo

public void setMfrNo(String strMfrNo)
製造者番号を設定します。

パラメータ:
strMfrNo - 製造者番号

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialAvailabilityController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス MaterialAvailabilityController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController
すべての実装インタフェース:
Serializable
public class MaterialAvailabilityController
extends MaterialAvailability
implements Serializable

品目在庫確認コントローラクラス
機能は以下の通り

  • 在庫情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
MaterialAvailabilityController()
コンストラクタ生成
MaterialAvailabilityController(SapClient sapClient)
コンストラクタ生成
メソッドの概要
 void executeBapi()
MaterialAvailabilityのexecuteBapi()を呼び出し品目コードを検索します。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability から継承したメソッド
getAvQtyPlt, getBatch, getCheckRule, getCustomer, getDecForRounding, getDecForRoundingX, getDialogflag, getDocNumber, getEndleadtme, getItmNumber, getMaterial, getPlant, getStgeLoc, getStockInd, getUnit, getWbsElem, getWmdvexList, getWmdvsxList, setAvQtyPlt, setBatch, setCheckRule, setCustomer, setDecForRounding, setDecForRoundingX, setDialogflag, setDocNumber, setEndleadtme, setExportParam, setImportParam, setItmNumber, setMaterial, setPlant, setStgeLoc, setStockInd, setUnit, setWbsElem, setWmdvexList, setWmdvsxList, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialAvailabilityController

public MaterialAvailabilityController()
コンストラクタ生成

MaterialAvailabilityController

public MaterialAvailabilityController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - SAPクライアント
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
MaterialAvailabilityのexecuteBapi()を呼び出し品目コードを検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPPurchaseSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPPurchaseSystemException - 購買発注業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialGetAllController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス MaterialGetAllController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController
すべての実装インタフェース:
Serializable
public class MaterialGetAllController
extends MaterialGetAll
implements Serializable

品目マスタ照会コントローラクラス
機能は以下の通り

  • 品目マスタの情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
MaterialGetAllController()
コンストラクタ生成
MaterialGetAllController(SapClient sapClient)
コンストラクタ生成
MaterialGetAllController(String material, String companyCode, String plant, String storageLocation, String salesOrganisation, String distributionChannel)
MaterialGetallのコンストラクタを呼び出し品目マスタ照会情報を取得します。
MaterialGetAllController(String material, String companyCode, String plant, String storageLocation, String salesOrganisation, String distributionChannel, SapClient sapClient)
MaterialGetallのコンストラクタを呼び出し品目マスタ照会情報を取得します。
メソッドの概要
void | executeBapi() BapiControllerにより品目マスタ照会を行います。
ExtensionOut | getExtensionOut(int index) BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造オブジェクトが既に 存在するかチェックします。
InternationArticleNumbers | getInternationArticleNumbers(int index) EANオブジェクトが既に存在するかチェックします。
MaterialDescription | getMaterialDescription(int index) 品目テキストオブジェクトが既に存在するかチェックします。
MaterialText | getMaterialText(int index) テキスト (長)オブジェクトが既に存在するかチェックします。
TaxClassifications | getTaxClassifications(int index) 制御デ－タオブジェクトが既に存在するかチェックします。
UnitSofmeasure | getUnitSofmeasure(int index) 数量単位オブジェクトが既に存在するかチェックします。
void | setTblParam(String paramTable, String paramName, String value, int index) テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll から継承したメソッド
getClientData, getCompanycode, getDistributionchannel, getExtensionOutList, getForecastParameters, getInternationArticleNumbersList, getLifoValuationData, getLifovaluationlevel, getMaterial, getMaterialDescriptionList, getMaterialTextList, getPlanningData, getPlant, getPlantData, getProductionResourceToolData, getSalesData, getSalesorganisation, getStoragelocation, getStorageLocationData, getStoragetype, getStorageTypeData, getTaxClassificationsList, getUnitSofmeasureList, getValuationarea, getValuationData, getValuationtype, getWarehousenumber, getWarehouseNumberData, initMaterialGetAll, setClientData, setCompanycode, setDistributionchannel, setExpClientData, setExpExtensionOut, setExpForecastParameters, setExpInternationArticleNumbers, setExpLifoValuationData, setExpMaterialDescription, setExpMaterialText, setExportParam, setExpPlanningData, setExpPlantData, setExpProductionResourceToolData, setExpSalesData, setExpStorageLocationData, setExpStorageTypeData, setExpTaxClassifications, setExpUnitSofmeasure, setExpValuationData, setExpWarehouseNumberData, setExtensionOutList, setForecastParameters, setImpExtensionOut, setImpInternationArticleNumbers, setImpMaterialDescription, setImpMaterialText, setImportParam, setImpTaxClassifications, setImpUnitSofmeasure, setInternationArticleNumbersList, setLifoValuationData, setLifovaluationlevel, setMaterial, setMaterialDescriptionList, setMaterialTextList, setPlanningData, setPlant, setPlantData, setProductionResourceToolData, setSalesData, setSalesorganisation, setStoragelocation, setStorageLocationData, setStoragetype, setStorageTypeData, setTaxClassificationsList, setUnitSofmeasureList, setValuationarea, setValuationData, setValuationtype, setWarehousenumber, setWarehouseNumberData, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialGetAllController

public MaterialGetAllController()
コンストラクタ生成

MaterialGetAllController

public MaterialGetAllController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - SAPクライアント

MaterialGetAllController

public MaterialGetAllController(String material,
                                String companyCode,
                                String plant,
                                String storageLocation,
                                String salesOrganisation,
                                String distributionChannel)
MaterialGetallのコンストラクタを呼び出し品目マスタ照会情報を取得します。

パラメータ:
material - 品目コード
companyCode - 会社コード
plant - プラント
storageLocation - 保管場所
salesOrganisation - 販売組織
distributionChannel - 流通チャネル

MaterialGetAllController

public MaterialGetAllController(String material,
                                String companyCode,
                                String plant,
                                String storageLocation,
                                String salesOrganisation,
                                String distributionChannel,
                                SapClient sapClient)
MaterialGetallのコンストラクタを呼び出し品目マスタ照会情報を取得します。

パラメータ:
material - 品目コード
companyCode - 会社コード
plant - プラント
storageLocation - 保管場所
salesOrganisation - 販売組織
distributionChannel - 流通チャネル
sapClient - SAPクライアント
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
BapiControllerにより品目マスタ照会を行います。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPPurchaseSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - パラメータ名
value - セットする値
index - レコード番号
例外:
SAPPurchaseSystemException - 購買発注業務システム例外

getMaterialDescription

public MaterialDescription getMaterialDescription(int index)
品目テキストオブジェクトが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
materialDescription 品目テキストオブジェクト

getUnitSofmeasure

public UnitSofmeasure getUnitSofmeasure(int index)
数量単位オブジェクトが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
unitSofmeasure 数量単位オブジェクト

getInternationArticleNumbers

public InternationArticleNumbers getInternationArticleNumbers(int index)
EANオブジェクトが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
internationArticleNumbers EANオブジェクト

getMaterialText

public MaterialText getMaterialText(int index)
テキスト (長)オブジェクトが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
materialText テキスト (長)オブジェクト

getTaxClassifications

public TaxClassifications getTaxClassifications(int index)
制御デ－タオブジェクトが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
taxClassifications 制御デ－タオブジェクト

getExtensionOut

public ExtensionOut getExtensionOut(int index)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造オブジェクトが既に 存在するかチェックします。存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
extensionOut EXTENSIONIN/EXTENSIONOUT の参照構造オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialGetList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス MaterialGetList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
MaterialGetListController
public class MaterialGetList
extends ReferenceController
implements Serializable

品目コード検索クラス
機能は以下の通り

  • 品目コード、テキストを検索します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
MaterialGetList(SapClient sapClient)
品目コードの選択オプション一覧、品目テキストの選択オプション一覧、 製造業者と製造者製品コード一覧、プラントの選択オプション一覧、 保管場所の選択オプション一覧、販売組織の選択オプション一覧、 流通チャネルの選択オプション一覧、品目コードと品目テキスト一覧を作成します｡
メソッドの概要
ArrayList | getDistributionChannelSelectionList() 流通チャネルの選択オプション一覧を取得します｡
ArrayList | getManufacturerPartNumbList() 製造業者と製造者製品コード一覧を取得します｡
ArrayList | getMaterialShortDescselList() 品目テキストの選択オプション一覧を取得します｡
ArrayList | getMatnrListList() 品目コードと品目テキストの一覧を取得します｡
ArrayList | getMatnrSelectionList() 品目コードの選択オプション一覧を取得します｡
String | getMaxRows() 選択予定品目の最大数を取得します｡
ArrayList | getPlantSelectionList() プラントの選択オプション一覧を取得します｡
ArrayList | getSalesOrganisationSelectionList() 販売組織の選択オプション一覧を取得します｡
ArrayList | getStorageLocationselectList() 保管場所の選択オプション一覧を取得します｡
void | setDistributionChannelSelectionList(ArrayList distributionChannelSelectionList) 流通チャネルの選択オプション一覧を設定します｡
void | setExportParam(BapiController bapiController) 伝票に登録された情報ををセットします。
void | setImportParam(BapiController bapiController) 品目コードを検索する条件ををセットします。
void | setManufacturerPartNumbList(ArrayList manufacturerPartNumbList) 製造業者と製造者製品コード一覧を設定します｡
void | setMaterialShortDescselList(ArrayList materialShortDescselList) 品目テキストの選択オプション一覧を設定します。
void | setMatnrListList(ArrayList matnrListList) 品目コードと品目テキスト一覧を設定します｡
void | setMatnrSelectionList(ArrayList matnrSelectionList) 品目コードの選択オプション一覧を設定します。
void | setMaxRows(String strMaxRows) 選択予定品目の最大数を設定します。
void | setPlantSelectionList(ArrayList plantSelectionList) プラントの選択オプション一覧を設定します｡
void | setSalesOrganisationSelectionList(ArrayList salesOrganisationSelectionList) 販売組織の選択オプション一覧を設定します｡
void | setStoragelocationselectList(ArrayList storageLocationselectList) 保管場所の選択オプション一覧を設定します｡
void | setTblParam(String paramTable, String paramName, String value, int index) テーブル型の項目に値をセットします。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialGetList

public MaterialGetList(SapClient sapClient)
品目コードの選択オプション一覧、品目テキストの選択オプション一覧、 製造業者と製造者製品コード一覧、プラントの選択オプション一覧、 保管場所の選択オプション一覧、販売組織の選択オプション一覧、 流通チャネルの選択オプション一覧、品目コードと品目テキスト一覧を作成します｡

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPPurchaseSystemException
品目コードを検索する条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
伝票に登録された情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPPurchaseSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPPurchaseSystemException - 購買発注業務システム例外

setMaxRows

public void setMaxRows(String strMaxRows)
選択予定品目の最大数を設定します。

パラメータ:
strMaxRows - 選択予定品目の最大数

setMatnrSelectionList

public void setMatnrSelectionList(ArrayList matnrSelectionList)
品目コードの選択オプション一覧を設定します。

パラメータ:
matnrSelectionList - 品目コードの選択オプション一覧

setMaterialShortDescselList

public void setMaterialShortDescselList(ArrayList materialShortDescselList)
品目テキストの選択オプション一覧を設定します。

パラメータ:
materialShortDescselList - 品目テキストの選択オプション一覧

setManufacturerPartNumbList

public void setManufacturerPartNumbList(ArrayList manufacturerPartNumbList)
製造業者と製造者製品コード一覧を設定します｡

パラメータ:
manufacturerPartNumbList - 製造業者と製造者製品コード一覧

setPlantSelectionList

public void setPlantSelectionList(ArrayList plantSelectionList)
プラントの選択オプション一覧を設定します｡

パラメータ:
plantSelectionList - プラントの選択オプション一覧

setStoragelocationselectList

public void setStoragelocationselectList(ArrayList storageLocationselectList)
保管場所の選択オプション一覧を設定します｡

パラメータ:
storageLocationselectList - 保管場所の選択オプション一覧

setSalesOrganisationSelectionList

public void setSalesOrganisationSelectionList(ArrayList salesOrganisationSelectionList)
販売組織の選択オプション一覧を設定します｡

パラメータ:
salesOrganisationSelectionList - 販売組織の選択オプション一覧

setDistributionChannelSelectionList

public void setDistributionChannelSelectionList(ArrayList distributionChannelSelectionList)
流通チャネルの選択オプション一覧を設定します｡

パラメータ:
distributionChannelSelectionList - 流通チャネルの選択オプション一覧

setMatnrListList

public void setMatnrListList(ArrayList matnrListList)
品目コードと品目テキスト一覧を設定します｡

パラメータ:
matnrListList - 品目コードと品目テキスト一覧

getMaxRows

public String getMaxRows()
選択予定品目の最大数を取得します｡

戻り値:
strMaxRows 選択予定品目の最大数

getMatnrSelectionList

public ArrayList getMatnrSelectionList()
品目コードの選択オプション一覧を取得します｡

戻り値:
matnrSelectionList 品目コードの選択オプション一覧

getMaterialShortDescselList

public ArrayList getMaterialShortDescselList()
品目テキストの選択オプション一覧を取得します｡

戻り値:
materialShortDescselList 品目テキストの選択オプション一覧

getManufacturerPartNumbList

public ArrayList getManufacturerPartNumbList()
製造業者と製造者製品コード一覧を取得します｡

戻り値:
manufacturerPartNoList 製造業者と製造者製品コード一覧

getPlantSelectionList

public ArrayList getPlantSelectionList()
プラントの選択オプション一覧を取得します｡

戻り値:
plantSelectionList プラントの選択オプション一覧

getStorageLocationselectList

public ArrayList getStorageLocationselectList()
保管場所の選択オプション一覧を取得します｡

戻り値:
storagelocationselectList 保管場所の選択オプション一覧

getSalesOrganisationSelectionList

public ArrayList getSalesOrganisationSelectionList()
販売組織の選択オプション一覧を取得します｡

戻り値:
salesOrganisationSelectionList 販売組織の選択オプション一覧

getDistributionChannelSelectionList

public ArrayList getDistributionChannelSelectionList()
流通チャネルの選択オプション一覧を取得します｡

戻り値:
distributionChannelSelectionList 流通チャネルの選択オプション一覧

getMatnrListList

public ArrayList getMatnrListList()
品目コードと品目テキストの一覧を取得します｡

戻り値:
matnrListList 品目コードと品目テキストの一覧

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialGetListController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス MaterialGetListController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController
すべての実装インタフェース:
Serializable
public class MaterialGetListController
extends MaterialGetList
implements Serializable

品目コード検索コントローラクラス
機能は以下の通り

  • 品目コード、テキストを検索します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
MaterialGetListController()
MaterialGetListのコンストラクタを生成します。
MaterialGetListController(SapClient sapClient)
MaterialGetListのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し品目コードを検索します。
クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList から継承したメソッド
getDistributionChannelSelectionList, getManufacturerPartNumbList, getMaterialShortDescselList, getMatnrListList, getMatnrSelectionList, getMaxRows, getPlantSelectionList, getSalesOrganisationSelectionList, getStorageLocationselectList, setDistributionChannelSelectionList, setExportParam, setImportParam, setManufacturerPartNumbList, setMaterialShortDescselList, setMatnrListList, setMatnrSelectionList, setMaxRows, setPlantSelectionList, setSalesOrganisationSelectionList, setStoragelocationselectList, setTblParam, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialGetListController

public MaterialGetListController()
MaterialGetListのコンストラクタを生成します。

MaterialGetListController

public MaterialGetListController(SapClient sapClient)
MaterialGetListのコンストラクタを生成します。

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
ReferenceControllerのexecuteBapi()を呼び出し品目コードを検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialSaveReplicaController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス MaterialSaveReplicaController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController
すべての実装インタフェース:
Serializable
public class MaterialSaveReplicaController
extends MaterialSaveReplica
implements Serializable

品目マスタ更新コントローラクラス
機能は以下の通り

  • 品目マスタを更新します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
MaterialSaveReplicaController()
コンストラクタ生成
MaterialSaveReplicaController(ConnectionManager connectionManager)
コンストラクタ生成
MaterialSaveReplicaController(SapClient sapClient)
コンストラクタ生成
メソッドの概要
void | executeBapi() BapiControllerにより品目マスタを更新します。
ClientDataList | getClientDataList(int index) 品目データ (クライアントレベル)が既に存在するかチェックします。
ExtensionIn | getExtensionIn(int index) BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造が既に存在するか チェックします。
ExtensionInX | getExtensionInX(int index) 拡張イン/拡張アウトのチェックボックス構造が既に存在するかチェックします。
ForecastParametersList | getForecastParametersList(int index) 需要予測パラメータが既に存在するかチェックします。
ForecastValues | getForecastValues(int index) 需要予測値のデータ転送が既に存在するかチェックします。
HeadData | getHeadData(int index) 管理情報設定ヘッダセグメントが既に存在するかチェックします。
InternationalArtnos | getInternationalArtnos(int index) 国際商品コード (EAN)が既に存在するかチェックします。
MaterialDescription | getMaterialDescription(int index) 品目テキストが既に存在するかチェックします。
MaterialLongText | getMaterialLongText(int index) テキスト (長)が既に存在するかチェックします。
PlanningDataList | getPlanningDataList(int index) 品目マスタ/製品グループの変更伝票構造が既に存在するかチェックします。
PlantDataList | getPlantDataList(int index) 品目データ (プラントレベル)が既に存在するかチェックします。
PrtData | getPrtData(int index) 品目マスタの生産資源/治工具 (PRT) 項目が既に存在するかチェックします。
SalesDataList | getSalesDataList(int index) 販売データが既に存在するかチェックします。
StorageLocationDataList | getStorageLocationDataList(int index) 品目データ (保管場所レベル)が既に存在するかチェックします。
StorageTypeDataList | getStorageTypeDataList(int index) 保管域タイプデータが既に存在するかチェックします。
TaxClassifications | getTaxClassifications(int index) 制御デ－タが既に存在するかチェックします。
TotalConsumption | getTotalConsumption(int index) 品目総消費量のデータ転送が既に存在するかチェックします。
UnitSofmeasure | getUnitSofmeasure(int index) 数量単位が既に存在するかチェックします。
UnplndConsumption | getUnplndConsumption(int index) 計画外消費のデータ転送が既に存在するかチェックします。
ValuationDataList | getValuationDataList(int index) 評価データが既に存在するかチェックします。
WarehouseNumberDataList | getWarehouseNumberDataList(int index) 倉庫番号データが既に存在するかチェックします。
void | setTblParam(String paramTable, String paramName, String value, int index) テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica から継承したメソッド
getClientDataList, getExtensionInList, getExtensionInXList, getFlagCadCall, getForecastParametersList, getForecastValuesList, getHeadDataList, getInpfldcheck, getInternationalArtnosList, getMaterialDescriptionList, getMaterialLongTextList, getNoappllog, getNochangedoc, getPlanningDataList, getPlantDataList, getPrtDataList, getReturnMessagesList, getSalesDataList, getStorageLocationDataList, getStorageTypeDataList, getTaxClassificationsList, getTestrun, getTotalConsumptionList, getUnitSofmeasureList, getUnplndConsumptionList, getValuationDataList, getWarehouseNumberDataList, initMaterialSaveReplica, setClientDataList, setExportParam, setExtensionInList, setExtensionInXList, setFlagCadCall, setForecastParametersList, setForecastValuesList, setHeadDataList, setImportParam, setInpfldcheck, setInternationalArtnosList, setMaterialDescriptionList, setMaterialLongTextList, setNoappllog, setNochangedoc, setPlanningDataList, setPlantDataList, setPrtDataList, setReturnMessagesList, setSalesDataList, setStorageLocationDataList, setStorageTypeDataList, setTaxClassificationsList, setTestrun, setTotalConsumptionList, setUnitSofmeasureList, setUnplndConsumptionList, setValuationDataList, setWarehouseNumberDataList, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialSaveReplicaController

public MaterialSaveReplicaController()
コンストラクタ生成

MaterialSaveReplicaController

public MaterialSaveReplicaController(ConnectionManager connectionManager)
コンストラクタ生成

パラメータ:
connectionManager - コネクションオブジェクト

MaterialSaveReplicaController

public MaterialSaveReplicaController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - SAPクライアント
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
BapiControllerにより品目マスタを更新します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPPurchaseSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - パラメータ名
value - セットする値
index - レコード番号
例外:
SAPPurchaseSystemException - 購買発注業務システム例外

getHeadData

public HeadData getHeadData(int index)
管理情報設定ヘッダセグメントが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 管理情報設定ヘッダセグメントオブジェクト

getClientDataList

public ClientDataList getClientDataList(int index)
品目データ (クライアントレベル)が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 品目データ (クライアントレベル) オブジェクト

getPlantDataList

public PlantDataList getPlantDataList(int index)
品目データ (プラントレベル)が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 品目データ (プラントレベル) オブジェクト

getForecastParametersList

public ForecastParametersList getForecastParametersList(int index)
需要予測パラメータが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 需要予測パラメータオブジェクト

getPlanningDataList

public PlanningDataList getPlanningDataList(int index)
品目マスタ/製品グループの変更伝票構造が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 品目マスタ/製品グループの変更伝票構造オブジェクト

getStorageLocationDataList

public StorageLocationDataList getStorageLocationDataList(int index)
品目データ (保管場所レベル)が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 品目データ (保管場所レベル) オブジェクト

getValuationDataList

public ValuationDataList getValuationDataList(int index)
評価データが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 評価データオブジェクト

getWarehouseNumberDataList

public WarehouseNumberDataList getWarehouseNumberDataList(int index)
倉庫番号データが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 倉庫番号データオブジェクト

getSalesDataList

public SalesDataList getSalesDataList(int index)
販売データが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 販売データオブジェクト

getStorageTypeDataList

public StorageTypeDataList getStorageTypeDataList(int index)
保管域タイプデータが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 保管域タイプデータオブジェクト

getMaterialDescription

public MaterialDescription getMaterialDescription(int index)
品目テキストが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 品目テキストオブジェクト

getUnitSofmeasure

public UnitSofmeasure getUnitSofmeasure(int index)
数量単位が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 数量単位オブジェクト

getInternationalArtnos

public InternationalArtnos getInternationalArtnos(int index)
国際商品コード (EAN)が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 国際商品コード (EAN)オブジェクト

getMaterialLongText

public MaterialLongText getMaterialLongText(int index)
テキスト (長)が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj テキスト (長)オブジェクト

getTaxClassifications

public TaxClassifications getTaxClassifications(int index)
制御デ－タが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 制御デ－タオブジェクト

getPrtData

public PrtData getPrtData(int index)
品目マスタの生産資源/治工具 (PRT) 項目が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 品目マスタの生産資源/治工具 (PRT) 項目オブジェクト

getExtensionIn

public ExtensionIn getExtensionIn(int index)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造が既に存在するか チェックします。存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造 オブジェクト

getExtensionInX

public ExtensionInX getExtensionInX(int index)
拡張イン/拡張アウトのチェックボックス構造が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 拡張イン/拡張アウトのチェックボックス構造オブジェクト

getForecastValues

public ForecastValues getForecastValues(int index)
需要予測値のデータ転送が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 需要予測値のデータ転送オブジェクト

getUnplndConsumption

public UnplndConsumption getUnplndConsumption(int index)
計画外消費のデータ転送が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 計画外消費のデータ転送オブジェクト

getTotalConsumption

public TotalConsumption getTotalConsumption(int index)
品目総消費量のデータ転送が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 品目総消費量のデータ転送オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialShortDescsel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス MaterialShortDescsel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Selection
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel
すべての実装インタフェース:
Serializable
public class MaterialShortDescsel
extends Selection
implements Serializable

品目テキストの選択オプションクラス
機能は以下の通り

  • 品目テキストの選択オプションの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MaterialShortDescsel()
品目テキストの選択オプション情報を作成します。
MaterialShortDescsel(int index)
品目テキストの選択オプション情報を作成します。
メソッドの概要
String | getDescrHigh() 終了品目テキストを取得します。
String | getDescrLow() 開始品目テキストを取得します。
int | getIndex() レコード番号を取得します。
void | setDescrHigh(String strDescrHigh) 終了品目テキストを設定します。
void | setDescrLow(String strDescrLow) 開始品目テキストを設定します。
void | setIndex(int index) レコード番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.Selection から継承したメソッド
getOption, getSign, setOption, setSign
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialShortDescsel

public MaterialShortDescsel()
品目テキストの選択オプション情報を作成します。

MaterialShortDescsel

public MaterialShortDescsel(int index)
品目テキストの選択オプション情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getDescrLow

public String getDescrLow()
開始品目テキストを取得します。

戻り値:
srtDescrLow 開始品目テキスト

getDescrHigh

public String getDescrHigh()
終了品目テキストを取得します。

戻り値:
srtDescrHigh 品目テキスト

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index レコード番号

setDescrLow

public void setDescrLow(String strDescrLow)
開始品目テキストを設定します。

パラメータ:
strDescrLow - 開始品目テキスト

setDescrHigh

public void setDescrHigh(String strDescrHigh)
終了品目テキストを設定します。

パラメータ:
strDescrHigh - 品目テキスト

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス Selection 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MatnrList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス MatnrList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.MatnrList
すべての実装インタフェース:
Serializable
public class MatnrList
extends Object
implements Serializable

品目コードと品目テキストの一覧クラス
機能は以下の通り

  • 品目コードと品目テキストの一覧の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MatnrList()
品目コードと品目テキストの一覧情報を作成します。
メソッドの概要
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getMatlDesc() 品目テキストを取得します。
void | setMaterial(String strMaterial) 品目コードを設定します。
void | setMaterialExternal(String strMaterialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String strMaterialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String strMaterialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setMatlDesc(String strMatlDesc) 品目テキストを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MatnrList

public MatnrList()
品目コードと品目テキストの一覧情報を作成します。

メソッドの詳細

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
srtMaterial

getMatlDesc

public String getMatlDesc()
品目テキストを取得します。

戻り値:
srtMatlDesc

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
srtMaterialExternal

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
srtMaterialGuid

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
srtMaterialVersion

setMaterial

public void setMaterial(String strMaterial)
品目コードを設定します。

パラメータ:
strMaterial - 品目コード

setMatlDesc

public void setMatlDesc(String strMatlDesc)
品目テキストを設定します。

パラメータ:
strMatlDesc - 品目テキスト

setMaterialExternal

public void setMaterialExternal(String strMaterialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
strMaterialExternal - 項目 MATERIAL の品目コード (長)

setMaterialGuid

public void setMaterialGuid(String strMaterialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
strMaterialGuid - 項目 MATERIAL の外部 GUID

setMaterialVersion

public void setMaterialVersion(String strMaterialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
strMaterialVersion - 項目 MATERIAL のバージョン番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MatnrSelection (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス MatnrSelection

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Selection
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection
すべての実装インタフェース:
Serializable
public class MatnrSelection
extends Selection
implements Serializable

品目コードの選択オプションクラス
機能は以下の通り

  • 品目コードの選択オプションの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MatnrSelection()
品目コードの選択オプション情報を作成します。
MatnrSelection(int index)
品目コードの選択オプション情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します。
String | getMatnrHigh() 終了品目コードを取得します。
String | getMatnrLow() 開始品目コードを取得します。
void | setIndex(int index) レコード番号を設定します。
void | setMatnrHigh(String strMatnrHigh) 終了品目コードを設定します。
void | setMatnrLow(String strMatnrLow) 開始品目コードを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.Selection から継承したメソッド
getOption, getSign, setOption, setSign
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MatnrSelection

public MatnrSelection()
品目コードの選択オプション情報を作成します。

MatnrSelection

public MatnrSelection(int index)
品目コードの選択オプション情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getMatnrLow

public String getMatnrLow()
開始品目コードを取得します。

戻り値:
srtMatnrLow 開始品目コード

getMatnrHigh

public String getMatnrHigh()
終了品目コードを取得します。

戻り値:
srtMatnrHigh 終了品目コード

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index レコード番号

setMatnrLow

public void setMatnrLow(String strMatnrLow)
開始品目コードを設定します。

パラメータ:
strMatnrLow - 開始品目コード

setMatnrHigh

public void setMatnrHigh(String strMatnrHigh)
終了品目コードを設定します。

パラメータ:
strMatnrHigh - 終了品目コード

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス Selection 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.purchase (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase
クラス
AllVersions
Cond
ContractLimits
ContractService
ContractServiceAccount
ContractServiceText
DeliveryAddress
DistributionChannelSelection
ExportHeader
ExportItem
Extension
GoodsMvtCreateController
GoodsMvtGetItemsController
Limits
ManufacturerPartNumb
MaterialAvailabilityController
MaterialGetAllController
MaterialGetList
MaterialGetListController
MaterialSaveReplicaController
MaterialShortDescsel
MatnrList
MatnrSelection
ParamAllVersions
ParamCondHeader
ParamCondItem
ParamContractLimits
ParamContractService
ParamContractServiceAccount
ParamContractServiceText
ParamDeliveryAddress
ParamExportHeader
ParamExportItem
ParamExtension
ParamHeader
ParamHeaderText
ParamItem
ParamItemText
ParamLimits
ParamPartner
ParamProfitSegment
ParamPurchaseAccount
ParamPurchaseSchedule
ParamVendorAddress
ParamVersions
Partner
PlantSelection
ProfitSegment
PurchaseAccount
PurchaseGetItemSrel
PurchaseGetItemSrelController
PurchaseHeader
PurchaseHeaderPost
PurchaseHeaders
PurchaseItem
PurchaseItemPost
PurchaseItems
PurchaseOrderPayPost
PurchaseOrderPayPostController
PurchaseOrderPostChangeController
PurchaseRelease
PurchaseReleaseController
PurchaseResetReleaseController
PurchaseSchedule
PurchaseText
SalesOrganisationSelection
Selection
StdMaterialGetIntNumberController
StorageLocationSelect
SupplierDetail
SupplierExistenceCheck
SupplierExistenceCheckController
SupplierGetDetailController
VendorAddress
Versions


jp.co.intra_mart.foundation.sap.module.purchase (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase

ＳＡＰ連携経費購買系に関するクラスを提供します。

参照:
説明

クラスの概要
AllVersions | 全バージョン管理情報クラス 機能は以下の通り 全バージョン管理情報を保持します。
Cond | 条件情報クラス 機能は以下の通り 条件情報を保持します。
ContractLimits | 外注基本契約制限情報クラス 機能は以下の通り 外注基本契約情報を保持します。
ContractService | 外注サービス情報クラス 機能は以下の通り 外注サービス情報を保持します。
ContractServiceAccount | 外注サービス勘定設定情報クラス 機能は以下の通り 外注サービス勘定設定情報を保持します。
ContractServiceText | 外注サービステキスト情報クラス 機能は以下の通り 外注サービステキスト情報を保持します。
DeliveryAddress | 入荷伝票アドレス情報クラス 機能は以下の通り 入荷伝票アドレス情報を保持します。
DistributionChannelSelection | 流通チャネルの選択オプションクラス 機能は以下の通り 流通チャネルの選択オプションの情報を保持します。
ExportHeader | 貿易管理ヘッダ情報クラス 機能は以下の通り 貿易管理ヘッダ情報を保持します。
ExportItem | 貿易管理明細情報クラス 機能は以下の通り 貿易管理明細情報を保持します。
Extension | 拡張得意先項目情報クラス 機能は以下の通り 拡張得意先項目情報を保持します。
GoodsMvtCreateController | 入庫伝票登録コントローラクラス 機能は以下の通り 入庫伝票を登録します。
GoodsMvtGetItemsController | 入出庫伝票一覧取得コントローラクラス 機能は以下の通り 入出庫伝票の一覧を取得します。
Limits | 外注制限情報クラス 機能は以下の通り 外注制限情報を保持します。
ManufacturerPartNumb | 製造業者と製造者製品コードクラス 機能は以下の通り 製造業者と製造者製品コードの情報を保持します。
MaterialAvailabilityController | 品目在庫確認コントローラクラス 機能は以下の通り 在庫情報を取得します。
MaterialGetAllController | 品目マスタ照会コントローラクラス 機能は以下の通り 品目マスタの情報を取得します。
MaterialGetList | 品目コード検索クラス 機能は以下の通り 品目コード、テキストを検索します。
MaterialGetListController | 品目コード検索コントローラクラス 機能は以下の通り 品目コード、テキストを検索します。
MaterialSaveReplicaController | 品目マスタ更新コントローラクラス 機能は以下の通り 品目マスタを更新します。
MaterialShortDescsel | 品目テキストの選択オプションクラス 機能は以下の通り 品目テキストの選択オプションの情報を保持します。
MatnrList | 品目コードと品目テキストの一覧クラス 機能は以下の通り 品目コードと品目テキストの一覧の情報を保持します。
MatnrSelection | 品目コードの選択オプションクラス 機能は以下の通り 品目コードの選択オプションの情報を保持します。
ParamAllVersions | 全バージョンパラメータ設定クラス 機能は以下の通り 全バージョンのパラメータを設定します。
ParamCondHeader | 条件ヘッダパラメータ設定クラス 機能は以下の通り 条件ヘッダのパラメータを設定します。
ParamCondItem | 条件明細パラメータ設定ラクラス 機能は以下の通り 条件明細のパラメータを設定します。
ParamContractLimits | 外注基本契約制限パラメータ設定クラス 機能は以下の通り 外注基本契約制限のパラメータを設定します。
ParamContractService | 外注サービスパラメータ設定クラス 機能は以下の通り 外注サービスのパラメータを設定します。
ParamContractServiceAccount | 外注サービス勘定設定パラメータ設定クラス 機能は以下の通り 外注サービス勘定設定のパラメータを設定します。
ParamContractServiceText | 外注サービステキストパラメータ設定クラス 機能は以下の通り 外注サービステキストのパラメータを設定します。
ParamDeliveryAddress | 入荷伝票アドレスパラメータ設定ラクラス 機能は以下の通り 入荷伝票アドレスのパラメータを設定します。
ParamExportHeader | 貿易管理ヘッダパラメータ設定ラクラス 機能は以下の通り 貿易管理ヘッダのパラメータを設定します。
ParamExportItem | 貿易管理明細インポートパラメータ設定クラス 機能は以下の通り 貿易管理明細のパラメータを設定します。
ParamExtension | 拡張得意先項目パラメータ設定クラス 機能は以下の通り 拡張得意先項目のパラメータを設定します。
ParamHeader | 伝票ヘッダパラメータ設定クラス 機能は以下の通り 伝票ヘッダのインポートパラメータを設定します。
ParamHeaderText | ヘッダテキストパラメータ設定クラス 機能は以下の通り ヘッダテキストのパラメータを設定します。
ParamItem | 明細パラメータ設定クラス 機能は以下の通り 明細のパラメータを設定します。
ParamItemText | 明細テキストパラメータ設定クラス 機能は以下の通り 明細テキストのパラメータを設定します。
ParamLimits | 外注制限パラメータ設定クラス 機能は以下の通り 外注制限のパラメータを設定します。
ParamPartner | 得意先インポートパラメータ設定クラス 機能は以下の通り 得意先のパラメータを設定します。
ParamProfitSegment | 入出庫予定パラメータ設定クラス 機能は以下の通り 入出庫予定のパラメータを設定します。
ParamPurchaseAccount | 勘定設定パラメータ設定クラス 機能は以下の通り 勘定設定のパラメータを設定します。
ParamPurchaseSchedule | 納入日程パラメータ設定クラス 機能は以下の通り 納入日程のパラメータを設定します。
ParamVendorAddress | 仕入先住所パラメータ設定クラス 機能は以下の通り 仕入先住所のパラメータを設定します。
ParamVersions | バージョン管理パラメータ設定ラクラス 機能は以下の通り バージョン管理のパラメータを設定します。
Partner | 取引先情報クラス 機能は以下の通り 取引先情報を保持します。
PlantSelection | プラントの選択オプションクラス 機能は以下の通り プラントの選択オプションの情報を保持します。
ProfitSegment | 入出庫予定情報クラス 機能は以下の通り 入出庫予定情報を保持します。
PurchaseAccount | 購買発注伝票勘定情報クラス 機能は以下の通り 購買発注伝票勘定情報を保持します。
PurchaseGetItemSrel | 伝票承認対象一覧情報クラス 機能は以下の通り 伝票承認対象一覧を取得します。
PurchaseGetItemSrelController | 伝票の承認対象一覧取得コントローラクラス 機能は以下の通り 伝票の承認対象一覧を取得します。
PurchaseHeader | 購買発注ヘッダ情報スーパークラス 機能は以下の通り 購買発注のヘッダ情報を保持します。
PurchaseHeaderPost | 購買発注伝票ヘッダ情報クラス 機能は以下の通り 購買発注伝票ヘッダの情報を保持します。
PurchaseHeaders | 伝票の承認対象一覧ヘッダ情報クラス 機能は以下の通り 伝票の承認対象一覧ヘッダの情報を保持します。
PurchaseItem | 購買発注明細情報スーパークラス 機能は以下の通り 購買発注の明細情報を保持します。
PurchaseItemPost | 購買発注伝票明細情報クラス 機能は以下の通り 購買発注伝票明細情報を保持します。
PurchaseItems | 伝票の承認対象明細情報クラス 機能は以下の通り 伝票の承認対象明細情報を保持します。
PurchaseOrderPayPost | 伝票登録クラス 機能は以下の通り 伝票を登録します。
PurchaseOrderPayPostController | 伝票登録コントローラクラス 機能は以下の通り 伝票を登録します。
PurchaseOrderPostChangeController | 伝票登録変更コントローラクラス 機能は以下の通り 伝票を変更します。
PurchaseRelease | 承認情報スーパークラス 機能は以下の通り 承認情報を保持します。
PurchaseReleaseController | 伝票承認コントローラクラス 機能は以下の通り 伝票を承認します。
PurchaseResetReleaseController | 伝票承認取消コントローラクラス 機能は以下の通り 伝票の承認取消します。
PurchaseSchedule | 購買発注伝票納入日程情報クラス 機能は以下の通り 購買発注伝票納入日程情報を保持します。
PurchaseText | 購買発注伝票テキストクラス 機能は以下の通り 購買発注伝テキストを保持します。
SalesOrganisationSelection | 販売組織の選択オプションクラス 機能は以下の通り 販売組織の選択オプションの情報を保持します。
Selection | 選択オプションクラス 機能は以下の通り 選択オプションの情報を保持します。
StdMaterialGetIntNumberController | 品目コード割当済照会コントローラクラス。
StorageLocationSelect | 保管場所の選択オプションクラス 機能は以下の通り 保管場所の選択オプションの情報を保持します。
SupplierDetail | 仕入先マスタ詳細情報クラス 機能は以下の通り 仕入先マスタの詳細情報を取得します。
SupplierExistenceCheck | 仕入先コード存在チェッククラス 機能は以下の通り 仕入先コード存在チェック結果を取得します。
SupplierExistenceCheckController | 仕入先コード存在チェックコントローラ 機能は以下の通り 仕入先コード存在チェックを行います。
SupplierGetDetailController | 仕入先マスタの詳細情報取得コントローラ 機能は以下の通り 仕入先マスタの詳細情報を取得します。
VendorAddress | 仕入先住所情報クラス 機能は以下の通り 仕入先住所を保持します。
Versions | バージョン管理情報クラス 機能は以下の通り バージョン管理情報を保持します。

パッケージ jp.co.intra_mart.foundation.sap.module.purchase の説明

ＳＡＰ連携経費購買系に関するクラスを提供します。


jp.co.intra_mart.foundation.sap.module.purchase クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Cond (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ContractService (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Extension (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress
    • class jp.co.intra_mart.foundation.sap.module.purchase.Limits (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamVendorAddress (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Partner (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText
    • class jp.co.intra_mart.foundation.sap.module.purchase.Selection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Versions (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.purchase の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase の使用

jp.co.intra_mart.foundation.sap.module.purchase を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.purchase のクラス
ExportHeader
貿易管理ヘッダ情報クラス
機能は以下の通り
貿易管理ヘッダ情報を保持します。
MaterialGetList
品目コード検索クラス
機能は以下の通り
品目コード、テキストを検索します。
PurchaseGetItemSrel
伝票承認対象一覧情報クラス
機能は以下の通り
伝票承認対象一覧を取得します。
PurchaseHeader
購買発注ヘッダ情報スーパークラス
機能は以下の通り
購買発注のヘッダ情報を保持します。
PurchaseHeaderPost
購買発注伝票ヘッダ情報クラス
機能は以下の通り
購買発注伝票ヘッダの情報を保持します。
PurchaseItem
購買発注明細情報スーパークラス
機能は以下の通り
購買発注の明細情報を保持します。
PurchaseOrderPayPost
伝票登録クラス
機能は以下の通り
伝票を登録します。
PurchaseRelease
承認情報スーパークラス
機能は以下の通り
承認情報を保持します。
PurchaseText
購買発注伝票テキストクラス
機能は以下の通り
購買発注伝テキストを保持します。
Selection
選択オプションクラス
機能は以下の通り
選択オプションの情報を保持します。
SupplierDetail
仕入先マスタ詳細情報クラス
機能は以下の通り
仕入先マスタの詳細情報を取得します。
SupplierExistenceCheck
仕入先コード存在チェッククラス
機能は以下の通り
仕入先コード存在チェック結果を取得します。
VendorAddress
仕入先住所情報クラス
機能は以下の通り
仕入先住所を保持します。
Versions
バージョン管理情報クラス
機能は以下の通り
バージョン管理情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamAllVersions (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamAllVersions

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions
すべての実装インタフェース:
Serializable
public final class ParamAllVersions
extends Object
implements Serializable

全バージョンパラメータ設定クラス
機能は以下の通り

  • 全バージョンのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setExportParam(BapiController bapiController, List allVersionsList)
全バージョンに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List allVersionsList)
                           throws SAPGeneralSystemException
全バージョンに値をセットします。

パラメータ:
bapiController - BapiController
allVersionsList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCondHeader (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamCondHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader
すべての実装インタフェース:
Serializable
public final class ParamCondHeader
extends Object
implements Serializable

条件ヘッダパラメータ設定クラス
機能は以下の通り

  • 条件ヘッダのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List condHeaderList)
条件ヘッダに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List condHeaderList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
条件ヘッダに値をセットします。

パラメータ:
bapiController - BapiController
condHeaderList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCondItem (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamCondItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem
すべての実装インタフェース:
Serializable
public final class ParamCondItem
extends Object
implements Serializable

条件明細パラメータ設定ラクラス
機能は以下の通り

  • 条件明細のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List condItemList)
条件明細に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List condItemList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
条件明細に値をセットします。

パラメータ:
bapiController - BapiController
condItemList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamContractLimits (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamContractLimits

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits
すべての実装インタフェース:
Serializable
public final class ParamContractLimits
extends Object
implements Serializable

外注基本契約制限パラメータ設定クラス
機能は以下の通り

  • 外注基本契約制限のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List contractLimitsList)
外注基本契約制限に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List contractLimitsList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
外注基本契約制限に値をセットします。

パラメータ:
bapiController - BapiController
contractLimitsList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamContractService (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamContractService

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService
すべての実装インタフェース:
Serializable
public final class ParamContractService
extends Object
implements Serializable

外注サービスパラメータ設定クラス
機能は以下の通り

  • 外注サービスのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List contractServiceList)
外注サービスに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List contractServiceList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
外注サービスに値をセットします。

パラメータ:
bapiController - BapiController
contractServiceList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamContractServiceAccount (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamContractServiceAccount

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount
すべての実装インタフェース:
Serializable
public final class ParamContractServiceAccount
extends Object
implements Serializable

外注サービス勘定設定パラメータ設定クラス
機能は以下の通り

  • 外注サービス勘定設定のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List contractServiceAccountList)
外注サービス勘定設定に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List contractServiceAccountList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
外注サービス勘定設定に値をセットします。

パラメータ:
bapiController - BapiController
contractServiceAccountList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamContractServiceText (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamContractServiceText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText
すべての実装インタフェース:
Serializable
public final class ParamContractServiceText
extends Object
implements Serializable

外注サービステキストパラメータ設定クラス
機能は以下の通り

  • 外注サービステキストのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List contractServiceTextList)
外注サービステキストに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List contractServiceTextList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
外注サービステキストに値をセットします。

パラメータ:
bapiController - BapiController
contractServiceTextList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamDeliveryAddress (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamDeliveryAddress

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress
すべての実装インタフェース:
Serializable
public final class ParamDeliveryAddress
extends Object
implements Serializable

入荷伝票アドレスパラメータ設定ラクラス
機能は以下の通り

  • 入荷伝票アドレスのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List deliveryAddressList)
入荷伝票アドレスヘッダに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List deliveryAddressList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
入荷伝票アドレスヘッダに値をセットします。

パラメータ:
bapiController - BapiController
deliveryAddressList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamExportHeader (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamExportHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader
すべての実装インタフェース:
Serializable
public final class ParamExportHeader
extends Object
implements Serializable

貿易管理ヘッダパラメータ設定ラクラス
機能は以下の通り

  • 貿易管理ヘッダのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, ExportHeader exportHeader) 貿易管理ヘッダに値をセットします。
static void | setImportParam(BapiController bapiController, ExportHeader exportHeader) 貿易管理ヘッダに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  ExportHeader exportHeader)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
貿易管理ヘッダに値をセットします。

パラメータ:
bapiController - BapiController
exportHeader - ExportHeader
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  ExportHeader exportHeader)
                           throws SAPGeneralSystemException
貿易管理ヘッダに値をセットします。

パラメータ:
bapiController - BapiController
exportHeader - ExportHeader
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamExportItem (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamExportItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem
すべての実装インタフェース:
Serializable
public final class ParamExportItem
extends Object
implements Serializable

貿易管理明細インポートパラメータ設定クラス
機能は以下の通り

  • 貿易管理明細のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List exportItemList)
貿易管理明細に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List exportItemList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
貿易管理明細に値をセットします。

パラメータ:
bapiController - BapiController
exportItemList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamExtension (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamExtension

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension
すべての実装インタフェース:
Serializable
public final class ParamExtension
extends Object
implements Serializable

拡張得意先項目パラメータ設定クラス
機能は以下の通り

  • 拡張得意先項目のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List extensionList) 拡張得意先項目に値をセットします。
static void | setImportParam(BapiController bapiController, List extensionList) 拡張得意先項目に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List extensionList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
拡張得意先項目に値をセットします。

パラメータ:
bapiController - BapiController
extensionList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List extensionList)
                           throws SAPGeneralSystemException
拡張得意先項目に値をセットします。

パラメータ:
bapiController - BapiController
extensionList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamHeader (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader
すべての実装インタフェース:
Serializable
public final class ParamHeader
extends Object
implements Serializable

伝票ヘッダパラメータ設定クラス
機能は以下の通り

  • 伝票ヘッダのインポートパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, PurchaseHeaderPost documentHeader) 伝票ヘッダに値をセットします。
static void | setImportParam(BapiController bapiController, PurchaseHeaderPost documentHeader) 伝票ヘッダに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  PurchaseHeaderPost documentHeader)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
伝票ヘッダに値をセットします。

パラメータ:
bapiController - BapiController
documentHeader - PurchaseHeaderPost
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  PurchaseHeaderPost documentHeader)
                           throws SAPGeneralSystemException
伝票ヘッダに値をセットします。

パラメータ:
bapiController - BapiController
documentHeader - PurchaseHeaderPost
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamHeaderText (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamHeaderText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText
すべての実装インタフェース:
Serializable
public final class ParamHeaderText
extends Object
implements Serializable

ヘッダテキストパラメータ設定クラス
機能は以下の通り

  • ヘッダテキストのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List headerTextList)
ヘッダテキストに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List headerTextList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
ヘッダテキストに値をセットします。

パラメータ:
bapiController - BapiController
headerTextList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamItem (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamItem
すべての実装インタフェース:
Serializable
public final class ParamItem
extends Object
implements Serializable

明細パラメータ設定クラス
機能は以下の通り

  • 明細のパラメータを設定します。

関連項目:
直列化された形式

クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamItemText (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamItemText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText
すべての実装インタフェース:
Serializable
public final class ParamItemText
extends Object
implements Serializable

明細テキストパラメータ設定クラス
機能は以下の通り

  • 明細テキストのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List itemTextList)
明細テキストに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List itemTextList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
明細テキストに値をセットします。

パラメータ:
bapiController - BapiController
itemTextList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamLimits (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamLimits

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits
すべての実装インタフェース:
Serializable
public final class ParamLimits
extends Object
implements Serializable

外注制限パラメータ設定クラス
機能は以下の通り

  • 外注制限のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List limitsList)
外注制限に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List limitsList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
外注制限に値をセットします。

パラメータ:
bapiController - BapiController
limitsList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPartner (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamPartner

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner
すべての実装インタフェース:
Serializable
public final class ParamPartner
extends Object
implements Serializable

得意先インポートパラメータ設定クラス
機能は以下の通り

  • 得意先のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List partnerList)
得意先に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List partnerList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
得意先に値をセットします。

パラメータ:
bapiController - BapiController
partnerList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamProfitSegment (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamProfitSegment

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment
すべての実装インタフェース:
Serializable
public final class ParamProfitSegment
extends Object
implements Serializable

入出庫予定パラメータ設定クラス
機能は以下の通り

  • 入出庫予定のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List profitSegmentList)
入出庫予定ヘッダに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List profitSegmentList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
入出庫予定ヘッダに値をセットします。

パラメータ:
bapiController - BapiController
profitSegmentList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPurchaseAccount (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamPurchaseAccount

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount
すべての実装インタフェース:
Serializable
public final class ParamPurchaseAccount
extends Object
implements Serializable

勘定設定パラメータ設定クラス
機能は以下の通り

  • 勘定設定のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List purchaseAccountList)
勘定設定に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List purchaseAccountList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
勘定設定に値をセットします。

パラメータ:
bapiController - BapiController
purchaseAccountList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPurchaseSchedule (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamPurchaseSchedule

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule
すべての実装インタフェース:
Serializable
public final class ParamPurchaseSchedule
extends Object
implements Serializable

納入日程パラメータ設定クラス
機能は以下の通り

  • 納入日程のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List purchaseScheduleList)
納入日程に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List purchaseScheduleList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
納入日程に値をセットします。

パラメータ:
bapiController - BapiController
purchaseScheduleList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamVendorAddress (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamVendorAddress

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamVendorAddress
すべての実装インタフェース:
Serializable
public final class ParamVendorAddress
extends Object
implements Serializable

仕入先住所パラメータ設定クラス
機能は以下の通り

  • 仕入先住所のパラメータを設定します。

関連項目:
直列化された形式

クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamVersions (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamVersions

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions
すべての実装インタフェース:
Serializable
public final class ParamVersions
extends Object
implements Serializable

バージョン管理パラメータ設定ラクラス
機能は以下の通り

  • バージョン管理のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, Versions versions)
バージョン管理に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  Versions versions)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
バージョン管理に値をセットします。

パラメータ:
bapiController - BapiController
versions - Versions
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Partner (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス Partner

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Partner
すべての実装インタフェース:
Serializable
public class Partner
extends Object
implements Serializable

取引先情報クラス
機能は以下の通り

  • 取引先情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Partner()
取引先を作成します。
Partner(int index)
取引先を作成します。
メソッドの概要
String | getBuspartno() 取引先の仕入先マスタコードを取得します。
String | getLangu() 言語キーを取得します。
int | getPaIndex() レコード番号を取得します｡
String | getPartnerdesc() 言語別取引先機能テキストを取得します。
void | setBuspartno(String strBuspartno) 取引先の仕入先マスタコードを設定します。
void | setLangu(String strLangu) 言語キーを設定します。
void | setPaIndex(int paIndex) レコード番号を設定します｡
void | setPartnerdesc(String strPartnerdesc) 言語別取引先機能テキストを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Partner

public Partner()
取引先を作成します。

Partner

public Partner(int index)
取引先を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPartnerdesc

public String getPartnerdesc()
言語別取引先機能テキストを取得します。

戻り値:
srtPartnerdesc 言語別取引先機能テキスト

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
srtLangu 言語キー

getBuspartno

public String getBuspartno()
取引先の仕入先マスタコードを取得します。

戻り値:
srtBuspartno 取引先の仕入先マスタコード

getPaIndex

public int getPaIndex()
レコード番号を取得します｡

戻り値:
paIndex レコード番号

setPartnerdesc

public void setPartnerdesc(String strPartnerdesc)
言語別取引先機能テキストを設定します。

パラメータ:
strPartnerdesc - 言語別取引先機能テキスト

setLangu

public void setLangu(String strLangu)
言語キーを設定します。

パラメータ:
strLangu - 言語キー

setBuspartno

public void setBuspartno(String strBuspartno)
取引先の仕入先マスタコードを設定します。

パラメータ:
strBuspartno - 取引先の仕入先マスタコード

setPaIndex

public void setPaIndex(int paIndex)
レコード番号を設定します｡

パラメータ:
paIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PlantSelection (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PlantSelection

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Selection
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection
すべての実装インタフェース:
Serializable
public class PlantSelection
extends Selection
implements Serializable

プラントの選択オプションクラス
機能は以下の通り

  • プラントの選択オプションの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PlantSelection()
プラントの選択オプション情報を作成します。
PlantSelection(int index)
Sプラントの選択オプション情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します。
String | getPlantHigh() 対象プラント 終了を取得します。
String | getPlantLow() 対象プラント 開始を取得します。
void | setIndex(int index) レコード番号を設定します。
void | setPlantHigh(String strPlantHigh) 対象プラント 終了を設定します。
void | setPlantLow(String strPlantLow) 対象プラント 開始を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.Selection から継承したメソッド
getOption, getSign, setOption, setSign
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PlantSelection

public PlantSelection()
プラントの選択オプション情報を作成します。

PlantSelection

public PlantSelection(int index)
Sプラントの選択オプション情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPlantLow

public String getPlantLow()
対象プラント 開始を取得します。

戻り値:
srtPlantLow 対象プラント 開始

getPlantHigh

public String getPlantHigh()
対象プラント 終了を取得します。

戻り値:
srtPlantHigh 対象プラント 終了

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index レコード番号

setPlantLow

public void setPlantLow(String strPlantLow)
対象プラント 開始を設定します。

パラメータ:
strPlantLow - 対象プラント 開始

setPlantHigh

public void setPlantHigh(String strPlantHigh)
対象プラント 終了を設定します。

パラメータ:
strPlantHigh - 対象プラント 終了

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス Selection 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProfitSegment (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ProfitSegment

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment
すべての実装インタフェース:
Serializable
public class ProfitSegment
extends Object
implements Serializable

入出庫予定情報クラス
機能は以下の通り

  • 入出庫予定情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ProfitSegment()
入出庫予定を作成します。
ProfitSegment(int index)
入出庫予定を作成します。
メソッドの概要
String | getFieldname() 項目名を取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
int | getPrIndex() レコード番号を取得します｡
String | getSerialNo() 勘定設定の連続番号を取得します。
String | getValue() CO-PA 特性値を取得します。
void | setFieldname(String strFieldname) 項目名を設定します。
void | setPoItem(String strPoItem) 購買伝票の明細番号を設定します。
void | setPrIndex(int prIndex) レコード番号を設定します｡
void | setSerialNo(String strSerialNo) 勘定設定の連続番号を設定します。
void | setValue(String strValue) CO-PA 特性値を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProfitSegment

public ProfitSegment()
入出庫予定を作成します。

ProfitSegment

public ProfitSegment(int index)
入出庫予定を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
srtPoItem 購買伝票の明細番号

getSerialNo

public String getSerialNo()
勘定設定の連続番号を取得します。

戻り値:
srtSerialNo 勘定設定の連続番号

getFieldname

public String getFieldname()
項目名を取得します。

戻り値:
srtFieldname 項目名

getValue

public String getValue()
CO-PA 特性値を取得します。

戻り値:
srtValue CO-PA 特性値

getPrIndex

public int getPrIndex()
レコード番号を取得します｡

戻り値:
prIndex レコード番号

setPoItem

public void setPoItem(String strPoItem)
購買伝票の明細番号を設定します。

パラメータ:
strPoItem - 購買伝票の明細番号

setSerialNo

public void setSerialNo(String strSerialNo)
勘定設定の連続番号を設定します。

パラメータ:
strSerialNo - 勘定設定の連続番号

setFieldname

public void setFieldname(String strFieldname)
項目名を設定します。

パラメータ:
strFieldname - 項目名

setValue

public void setValue(String strValue)
CO-PA 特性値を設定します。

パラメータ:
strValue - CO-PA 特性値

setPrIndex

public void setPrIndex(int prIndex)
レコード番号を設定します｡

パラメータ:
prIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseAccount (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseAccount

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount
すべての実装インタフェース:
Serializable
public class PurchaseAccount
extends Object
implements Serializable

購買発注伝票勘定情報クラス
機能は以下の通り

  • 購買発注伝票勘定情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseAccount()
購買発注伝票明細を作成します。
PurchaseAccount(int index)
購買発注伝票明細を作成します。
メソッドの概要
int | getAcIndex() レコード番号を取得します｡
String | getActivity() 作業番号を取得します。
String | getActtype() 活動タイプを取得します。
String | getAssetNo() 資産番号を取得します。
String | getBusArea() 事業領域を取得します。
String | getCmmtItem() 資金予算コードを取得します。
String | getCmmtItemLong() 資金予算コードを取得します。
String | getCoArea() 管理領域を取得します。
String | getCoBusproc() 業務プロセスを取得します。
String | getCostcenter() 原価センタを取得します。
String | getCostobject() 原価対象を取得します。
String | getCreatDate() レコード登録日を取得します。
String | getDeleteInd() 削除フラグ: 購買伝票勘定設定を取得します。
String | getDistrPerc() 配賦率 % (複数勘定設定)を取得します。
String | getFuncArea() 機能領域を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getFund() 会計区分を取得します。
String | getFundsCtr() 予算センタを取得します。
String | getGlAccount() G/L 勘定コードを取得します。
String | getGrantNbr() 補助金を取得します。
String | getGrRcpt() 受領者を取得します。
String | getItmNumber() 販売伝票明細を取得します。
String | getNetValue() BAPI の通貨額 (小数点以下９桁)を取得します。
String | getNetwork() 勘定割当のネットワーク番号を取得します。
String | getNondItax() BAPI の通貨額 (小数点以下９桁)を取得します。
String | getOrderid() 指図番号を取得します。
String | getPartAcct() 取引先勘定コードを取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
String | getProfitCtr() 利益センタを取得します。
String | getQuantity() 数量を取得します。
String | getRecInd() リカバリフラグを取得します。
String | getRefDate() 決済の参照日付を取得します。
String | getResDoc() 用途指定予算の伝票番号を取得します。
String | getResItem() 用途指定予算: 伝票明細を取得します。
String | getRlEstKey() 不動産管理対象の内部キーを取得します。
String | getSchedLine() 納入日程行を取得します。
String | getSdDoc() 販売管理伝票番号を取得します。
String | getSerialNo() 勘定設定の連続番号を取得します。
String | getSubNumber() 資産補助番号を取得します。
String | getTaxCode() 消費税コードを取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getUnloadPt() 荷渡ポイントを取得します。
String | getWbsElement() WBS 要素を取得します。
void | setAcIndex(int acIndex) レコード番号を設定します｡
void | setActivity(String strActivity) 作業番号を設定します。
void | setActtype(String strActtype) 活動タイプを設定します。
void | setAssetNo(String strAssetNo) 資産番号を設定します。
void | setBusArea(String strBusArea) 事業領域を設定します。
void | setCmmtItem(String strCmmtItem) 資金予算コードを設定します。
void | setCmmtItemLong(String strCmmtItemLong) 資金予算コードを設定します。
void | setCoArea(String strCoArea) 管理領域を設定します。
void | setCoBusproc(String strCoBusproc) 業務プロセスを設定します。
void | setCostcenter(String strCostcenter) 原価センタを設定します。
void | setCostobject(String strCostobject) 原価対象を設定します。
void | setCreatDate(String strCreatDate) レコード登録日を設定します。
void | setDeleteInd(String strDeleteInd) 削除フラグ: 購買伝票勘定設定を設定します。
void | setDistrPerc(String strDistrPerc) 配賦率 % (複数勘定設定)を設定します。
void | setFuncArea(String strFuncArea) 機能領域を設定します。
void | setFuncAreaLong(String strFuncAreaLong) 機能領域を設定します。
void | setFund(String strFund) 会計区分を設定します。
void | setFundsCtr(String strFundsCtr) 予算センタを設定します。
void | setGlAccount(String strGlAccount) G/L 勘定コードを設定します。
void | setGrantNbr(String strGrantNbr) 補助金を設定します。
void | setGrRcpt(String strGrRcpt) 受領者を設定します。
void | setItmNumber(String strItmNumber) 販売伝票明細を設定します。
void | setNetValue(String strNetValue) BAPI の通貨額 (小数点以下９桁)を設定します。
void | setNetwork(String strNetwork) 勘定割当のネットワーク番号を設定します。
void | setNondItax(String strNondItax) BAPI の通貨額 (小数点以下９桁)を設定します。
void | setOrderid(String strOrderid) 指図番号を設定します。
void | setPartAcct(String strPartAcct) 取引先勘定コードを設定します。
void | setPoItem(String strPoItem) 購買伝票の明細番号を設定します。
void | setProfitCtr(String strProfitCtr) 利益センタを設定します。
void | setQuantity(String strQuantity) 数量を設定します。
void | setRecInd(String strRecInd) リカバリフラグを設定します。
void | setRefDate(String strRefDate) 決済の参照日付を設定します。
void | setResDoc(String strResDoc) 用途指定予算の伝票番号を設定します。
void | setResItem(String strResItem) 用途指定予算: 伝票明細を設定します。
void | setRlEstKey(String strRlEstKey) 不動産管理対象の内部キーを設定します。
void | setSchedLine(String strSchedLine) 納入日程行を設定します。
void | setSdDoc(String strSdDoc) 販売管理伝票番号を設定します。
void | setSerialNo(String strSerialNo) 勘定設定の連続番号を設定します。
void | setSubNumber(String strSubNumber) 資産補助番号を設定します。
void | setTaxCode(String strTaxCode) 消費税コードを設定します。
void | setTaxjurcode(String strTaxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setUnloadPt(String strUnloadPt) 荷渡ポイントを設定します。
void | setWbsElement(String strWbsElement) WBS 要素を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseAccount

public PurchaseAccount()
購買発注伝票明細を作成します。

PurchaseAccount

public PurchaseAccount(int index)
購買発注伝票明細を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
srtPoItem 購買伝票の明細番号

getSerialNo

public String getSerialNo()
勘定設定の連続番号を取得します。

戻り値:
srtSerialNo 勘定設定の連続番号

getDeleteInd

public String getDeleteInd()
削除フラグ: 購買伝票勘定設定を取得します。

戻り値:
srtDeleteInd 削除フラグ: 購買伝票勘定設定

getCreatDate

public String getCreatDate()
レコード登録日を取得します。

戻り値:
srtCreatDate レコード登録日

getQuantity

public String getQuantity()
数量を取得します。

戻り値:
srtQuantity 数量

getDistrPerc

public String getDistrPerc()
配賦率 % (複数勘定設定)を取得します。

戻り値:
srtDistrPerc 配賦率 % (複数勘定設定)

getNetValue

public String getNetValue()
BAPI の通貨額 (小数点以下９桁)を取得します。

戻り値:
srtNetValue BAPI の通貨額 (小数点以下９桁)

getGlAccount

public String getGlAccount()
G/L 勘定コードを取得します。

戻り値:
srtGlAccount G/L 勘定コード

getBusArea

public String getBusArea()
事業領域を取得します。

戻り値:
srtBusArea 事業領域

getCostcenter

public String getCostcenter()
原価センタを取得します。

戻り値:
srtCostcenter 原価センタ

getSdDoc

public String getSdDoc()
販売管理伝票番号を取得します。

戻り値:
srtSdDoc 販売管理伝票番号

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
srtItmNumber 販売伝票明細

getSchedLine

public String getSchedLine()
納入日程行を取得します。

戻り値:
srtSchedLine 納入日程行

getAssetNo

public String getAssetNo()
資産番号を取得します。

戻り値:
srtAssetNo 資産番号

getSubNumber

public String getSubNumber()
資産補助番号を取得します。

戻り値:
srtSubNumber 資産補助番号

getOrderid

public String getOrderid()
指図番号を取得します。

戻り値:
srtOrderid 指図番号

getGrRcpt

public String getGrRcpt()
受領者を取得します。

戻り値:
srtGrRcpt 受領者

getUnloadPt

public String getUnloadPt()
荷渡ポイントを取得します。

戻り値:
srtUnloadPt 荷渡ポイント

getCoArea

public String getCoArea()
管理領域を取得します。

戻り値:
srtCoArea 管理領域

getCostobject

public String getCostobject()
原価対象を取得します。

戻り値:
srtCostobject 原価対象

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
srtProfitCtr 利益センタ

getWbsElement

public String getWbsElement()
WBS 要素を取得します。

戻り値:
srtWbsElement WBS 要素

getNetwork

public String getNetwork()
勘定割当のネットワーク番号を取得します。

戻り値:
srtNetwork 勘定割当のネットワーク番号

getRlEstKey

public String getRlEstKey()
不動産管理対象の内部キーを取得します。

戻り値:
srtRlEstKey 不動産管理対象の内部キー

getPartAcct

public String getPartAcct()
取引先勘定コードを取得します。

戻り値:
srtPartAcct 取引先勘定コード

getCmmtItem

public String getCmmtItem()
資金予算コードを取得します。

戻り値:
srtCmmtItem 資金予算コード

getRecInd

public String getRecInd()
リカバリフラグを取得します。

戻り値:
srtRecInd リカバリフラグ

getFundsCtr

public String getFundsCtr()
予算センタを取得します。

戻り値:
srtFundsCtr 予算センタ

getFund

public String getFund()
会計区分を取得します。

戻り値:
srtFund 会計区分

getFuncArea

public String getFuncArea()
機能領域を取得します。

戻り値:
srtFuncArea 機能領域

getRefDate

public String getRefDate()
決済の参照日付を取得します。

戻り値:
srtRefDate 決済の参照日付

getTaxCode

public String getTaxCode()
消費税コードを取得します。

戻り値:
srtTaxCode 消費税コード

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
srtTaxjurcode 税計算管轄コード - 税管轄コード

getNondItax

public String getNondItax()
BAPI の通貨額 (小数点以下９桁)を取得します。

戻り値:
srtNondItax BAPI の通貨額 (小数点以下９桁)

getActtype

public String getActtype()
活動タイプを取得します。

戻り値:
srtActtype 活動タイプ

getCoBusproc

public String getCoBusproc()
業務プロセスを取得します。

戻り値:
srtCoBusproc 業務プロセス

getResDoc

public String getResDoc()
用途指定予算の伝票番号を取得します。

戻り値:
srtResDoc 用途指定予算の伝票番号

getResItem

public String getResItem()
用途指定予算: 伝票明細を取得します。

戻り値:
srtResItem 用途指定予算: 伝票明細

getActivity

public String getActivity()
作業番号を取得します。

戻り値:
srtActivity 作業番号

getGrantNbr

public String getGrantNbr()
補助金を取得します。

戻り値:
srtGrantNbr 補助金

getCmmtItemLong

public String getCmmtItemLong()
資金予算コードを取得します。

戻り値:
srtCmmtItemLong 資金予算コード

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
srtFuncAreaLong 機能領域

getAcIndex

public int getAcIndex()
レコード番号を取得します｡

戻り値:
acIndex レコード番号

setPoItem

public void setPoItem(String strPoItem)
購買伝票の明細番号を設定します。

パラメータ:
strPoItem - 購買伝票の明細番号

setSerialNo

public void setSerialNo(String strSerialNo)
勘定設定の連続番号を設定します。

パラメータ:
strSerialNo - 勘定設定の連続番号

setDeleteInd

public void setDeleteInd(String strDeleteInd)
削除フラグ: 購買伝票勘定設定を設定します。

パラメータ:
strDeleteInd - 削除フラグ: 購買伝票勘定設定

setCreatDate

public void setCreatDate(String strCreatDate)
レコード登録日を設定します。

パラメータ:
strCreatDate - レコード登録日

setQuantity

public void setQuantity(String strQuantity)
数量を設定します。

パラメータ:
strQuantity - 数量

setDistrPerc

public void setDistrPerc(String strDistrPerc)
配賦率 % (複数勘定設定)を設定します。

パラメータ:
strDistrPerc - 配賦率 % (複数勘定設定)

setNetValue

public void setNetValue(String strNetValue)
BAPI の通貨額 (小数点以下９桁)を設定します。

パラメータ:
strNetValue - BAPI の通貨額 (小数点以下９桁)

setGlAccount

public void setGlAccount(String strGlAccount)
G/L 勘定コードを設定します。

パラメータ:
strGlAccount - G/L 勘定コード

setBusArea

public void setBusArea(String strBusArea)
事業領域を設定します。

パラメータ:
strBusArea - 事業領域

setCostcenter

public void setCostcenter(String strCostcenter)
原価センタを設定します。

パラメータ:
strCostcenter - 原価センタ

setSdDoc

public void setSdDoc(String strSdDoc)
販売管理伝票番号を設定します。

パラメータ:
strSdDoc - 販売管理伝票番号

setItmNumber

public void setItmNumber(String strItmNumber)
販売伝票明細を設定します。

パラメータ:
strItmNumber - 販売伝票明細

setSchedLine

public void setSchedLine(String strSchedLine)
納入日程行を設定します。

パラメータ:
strSchedLine - 納入日程行

setAssetNo

public void setAssetNo(String strAssetNo)
資産番号を設定します。

パラメータ:
strAssetNo - 資産番号

setSubNumber

public void setSubNumber(String strSubNumber)
資産補助番号を設定します。

パラメータ:
strSubNumber - 資産補助番号

setOrderid

public void setOrderid(String strOrderid)
指図番号を設定します。

パラメータ:
strOrderid - 指図番号

setGrRcpt

public void setGrRcpt(String strGrRcpt)
受領者を設定します。

パラメータ:
strGrRcpt - 受領者

setUnloadPt

public void setUnloadPt(String strUnloadPt)
荷渡ポイントを設定します。

パラメータ:
strUnloadPt - 荷渡ポイント

setCoArea

public void setCoArea(String strCoArea)
管理領域を設定します。

パラメータ:
strCoArea - 管理領域

setCostobject

public void setCostobject(String strCostobject)
原価対象を設定します。

パラメータ:
strCostobject - 原価対象

setProfitCtr

public void setProfitCtr(String strProfitCtr)
利益センタを設定します。

パラメータ:
strProfitCtr - 利益センタ

setWbsElement

public void setWbsElement(String strWbsElement)
WBS 要素を設定します。

パラメータ:
strWbsElement - WBS 要素

setNetwork

public void setNetwork(String strNetwork)
勘定割当のネットワーク番号を設定します。

パラメータ:
strNetwork - 勘定割当のネットワーク番号

setRlEstKey

public void setRlEstKey(String strRlEstKey)
不動産管理対象の内部キーを設定します。

パラメータ:
strRlEstKey - 不動産管理対象の内部キー

setPartAcct

public void setPartAcct(String strPartAcct)
取引先勘定コードを設定します。

パラメータ:
strPartAcct - 取引先勘定コード

setCmmtItem

public void setCmmtItem(String strCmmtItem)
資金予算コードを設定します。

パラメータ:
strCmmtItem - 資金予算コード

setRecInd

public void setRecInd(String strRecInd)
リカバリフラグを設定します。

パラメータ:
strRecInd - リカバリフラグ

setFundsCtr

public void setFundsCtr(String strFundsCtr)
予算センタを設定します。

パラメータ:
strFundsCtr - 予算センタ

setFund

public void setFund(String strFund)
会計区分を設定します。

パラメータ:
strFund - 会計区分

setFuncArea

public void setFuncArea(String strFuncArea)
機能領域を設定します。

パラメータ:
strFuncArea - 機能領域

setRefDate

public void setRefDate(String strRefDate)
決済の参照日付を設定します。

パラメータ:
strRefDate - 決済の参照日付

setTaxCode

public void setTaxCode(String strTaxCode)
消費税コードを設定します。

パラメータ:
strTaxCode - 消費税コード

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税計算管轄コード - 税管轄コード

setNondItax

public void setNondItax(String strNondItax)
BAPI の通貨額 (小数点以下９桁)を設定します。

パラメータ:
strNondItax - BAPI の通貨額 (小数点以下９桁)

setActtype

public void setActtype(String strActtype)
活動タイプを設定します。

パラメータ:
strActtype - 活動タイプ

setCoBusproc

public void setCoBusproc(String strCoBusproc)
業務プロセスを設定します。

パラメータ:
strCoBusproc - 業務プロセス

setResDoc

public void setResDoc(String strResDoc)
用途指定予算の伝票番号を設定します。

パラメータ:
strResDoc - 用途指定予算の伝票番号

setResItem

public void setResItem(String strResItem)
用途指定予算: 伝票明細を設定します。

パラメータ:
strResItem - 用途指定予算: 伝票明細

setActivity

public void setActivity(String strActivity)
作業番号を設定します。

パラメータ:
strActivity - 作業番号

setGrantNbr

public void setGrantNbr(String strGrantNbr)
補助金を設定します。

パラメータ:
strGrantNbr - 補助金

setCmmtItemLong

public void setCmmtItemLong(String strCmmtItemLong)
資金予算コードを設定します。

パラメータ:
strCmmtItemLong - 資金予算コード

setFuncAreaLong

public void setFuncAreaLong(String strFuncAreaLong)
機能領域を設定します。

パラメータ:
strFuncAreaLong - 機能領域

setAcIndex

public void setAcIndex(int acIndex)
レコード番号を設定します｡

パラメータ:
acIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseGetItemSrel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseGetItemSrel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel
すべての実装インタフェース:
Serializable
public class PurchaseGetItemSrel
extends ReferenceController
implements Serializable

伝票承認対象一覧情報クラス
機能は以下の通り

  • 伝票承認対象一覧を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
PurchaseGetItemSrel(SapClient sapClient)
コンストラクタ生成
PurchaseGetItemSrel(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
承認対象一覧を作成します。
メソッドの概要
void | executeBapi() BapiControllerにより仕入先マスタ詳細を作成します。
String | getItemsForRelease() 区分: 承認待ち購買発注のみ照会を取得します。
ArrayList | getPurchaseHeadersList() 伝票ヘッダ一覧を取得します｡
ArrayList | getPurchaseItemsList() 伝票明細一覧を取得します｡
String | getRelCode() 承認コードを取得します。
String | getRelGroup() 承認グループを取得します。
void | setItemsForRelease(String strItemsForRelease) 区分: 承認待ち購買発注のみ照会を設定します。
void | setPurchaseHeadersList(ArrayList purchaseHeadersList) 伝票ヘッダ一覧を取得します｡を設定します。
void | setPurchaseItemsList(ArrayList purchaseItemsList) 伝票明細一覧を取得します｡を設定します。
void | setRelCode(String strRelCode) 承認コードを設定します。
void | setRelGroup(String strRelGroup) 承認グループを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseGetItemSrel

public PurchaseGetItemSrel(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト

PurchaseGetItemSrel

public PurchaseGetItemSrel(String relGroup,
                           String relCode,
                           String itemsForRelease,
                           SapClient sapClient)
                    throws SAPAuthAppException,
                           SAPAuthSystemException,
                           SAPGeneralAppException,
                           SAPGeneralSystemException,
                           SAPPurchaseAppException,
                           SAPPurchaseSystemException
承認対象一覧を作成します。

パラメータ:
relGroup - 承認グループ
relCode - 承認コード
itemsForRelease - 照会区分
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
BapiControllerにより仕入先マスタ詳細を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 会計業務システム例外

setRelGroup

public void setRelGroup(String strRelGroup)
承認グループを設定します。

パラメータ:
strRelGroup - 承認グループ

setRelCode

public void setRelCode(String strRelCode)
承認コードを設定します。

パラメータ:
strRelCode - 承認コード

setItemsForRelease

public void setItemsForRelease(String strItemsForRelease)
区分: 承認待ち購買発注のみ照会を設定します。

パラメータ:
strItemsForRelease - 区分: 承認待ち購買発注のみ照会

setPurchaseHeadersList

public void setPurchaseHeadersList(ArrayList purchaseHeadersList)
伝票ヘッダ一覧を取得します｡を設定します。

パラメータ:
purchaseHeadersList - 伝票ヘッダ一覧を取得します｡

setPurchaseItemsList

public void setPurchaseItemsList(ArrayList purchaseItemsList)
伝票明細一覧を取得します｡を設定します。

パラメータ:
purchaseItemsList - 伝票明細一覧を取得します｡

getRelGroup

public String getRelGroup()
承認グループを取得します。

戻り値:
srtRelGroup 承認グループ

getRelCode

public String getRelCode()
承認コードを取得します。

戻り値:
srtRelCode 承認コード

getItemsForRelease

public String getItemsForRelease()
区分: 承認待ち購買発注のみ照会を取得します。

戻り値:
srtItemsForRelease 区分: 承認待ち購買発注のみ照会

getPurchaseHeadersList

public ArrayList getPurchaseHeadersList()
伝票ヘッダ一覧を取得します｡

戻り値:
deliveryAddressList 出荷伝票アドレス一覧

getPurchaseItemsList

public ArrayList getPurchaseItemsList()
伝票明細一覧を取得します｡

戻り値:
deliveryAddressList 出荷伝票アドレス一覧

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseGetItemSrelController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseGetItemSrelController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController
すべての実装インタフェース:
Serializable
public class PurchaseGetItemSrelController
extends Object
implements Serializable

伝票の承認対象一覧取得コントローラクラス
機能は以下の通り

  • 伝票の承認対象一覧を取得します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseGetItemSrelController()
コンストラクタ生成
PurchaseGetItemSrelController(SapClient sapClient)
コンストラクタ生成
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
メソッドの概要
 void executeBapi()
PurchaseGetItemSrelのexecuteBapi()を呼び出し伝票承認対象一覧を取得します。
 String getItemsForRelease()
区分: 承認待ち購買発注のみ照会を取得します。
 PurchaseGetItemSrel getPurchaseGetItemSrel()
承認対象一覧情報を取得します｡
 ArrayList getPurchaseHeadersList()
伝票ヘッダ一覧を取得します。
 ArrayList getPurchaseItemsList()
伝票明細一覧を取得します。
 String getRelCode()
承認コードを取得します。
 String getRelGroup()
承認グループを取得します。
 void setItemsForRelease(String strItemsForRelease)
区分: 承認待ち購買発注のみ照会を設定します。
 void setPurchaseHeadersList(ArrayList purchaseHeadersList)
伝票ヘッダ一覧を設定します。
 void setPurchaseItemsList(ArrayList purchaseItemsList)
伝票明細一覧を設定します。
 void setRelCode(String strRelCode)
承認コードを設定します。
 void setRelGroup(String strRelGroup)
承認グループを設定します。
 String toString()
デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseGetItemSrelController

public PurchaseGetItemSrelController()
コンストラクタ生成

PurchaseGetItemSrelController

public PurchaseGetItemSrelController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト

PurchaseGetItemSrelController

public PurchaseGetItemSrelController(String relGroup,
                                     String relCode,
                                     String itemsForRelease)
                              throws SAPAuthAppException,
                                     SAPAuthSystemException,
                                     SAPGeneralAppException,
                                     SAPGeneralSystemException,
                                     SAPPurchaseAppException,
                                     SAPPurchaseSystemException
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。

パラメータ:
relGroup - 承認グループ
relCode - 承認コード
itemsForRelease - 照会区分 「X」：承認可能な購買発注のみ照会 「ブランク」：すでに承認された購買発注のみ照会
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 会計業務システム例外

PurchaseGetItemSrelController

public PurchaseGetItemSrelController(String relGroup,
                                     String relCode,
                                     String itemsForRelease,
                                     SapClient sapClient)
                              throws SAPAuthAppException,
                                     SAPAuthSystemException,
                                     SAPGeneralAppException,
                                     SAPGeneralSystemException,
                                     SAPPurchaseAppException,
                                     SAPPurchaseSystemException
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。

パラメータ:
relGroup - 承認グループ
relCode - 承認コード
itemsForRelease - 照会区分
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト 「X」：承認可能な購買発注のみ照会 「ブランク」：すでに承認された購買発注のみ照会
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
PurchaseGetItemSrelのexecuteBapi()を呼び出し伝票承認対象一覧を取得します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

setRelGroup

public void setRelGroup(String strRelGroup)
承認グループを設定します。

パラメータ:
strRelGroup - 承認グループ

setRelCode

public void setRelCode(String strRelCode)
承認コードを設定します。

パラメータ:
strRelCode - 承認コード

setItemsForRelease

public void setItemsForRelease(String strItemsForRelease)
区分: 承認待ち購買発注のみ照会を設定します。

パラメータ:
strItemsForRelease - 区分: 承認待ち購買発注のみ照会

setPurchaseHeadersList

public void setPurchaseHeadersList(ArrayList purchaseHeadersList)
伝票ヘッダ一覧を設定します。

パラメータ:
purchaseHeadersList - 伝票ヘッダ一覧

setPurchaseItemsList

public void setPurchaseItemsList(ArrayList purchaseItemsList)
伝票明細一覧を設定します。

パラメータ:
purchaseItemsList - 伝票明細一覧

getPurchaseGetItemSrel

public PurchaseGetItemSrel getPurchaseGetItemSrel()
承認対象一覧情報を取得します｡

戻り値:
SupplierDetail

getRelGroup

public String getRelGroup()
承認グループを取得します。

戻り値:
srtRelGroup 承認グループ

getRelCode

public String getRelCode()
承認コードを取得します。

戻り値:
srtRelCode 承認コード

getItemsForRelease

public String getItemsForRelease()
区分: 承認待ち購買発注のみ照会を取得します。

戻り値:
srtItemsForRelease 区分: 承認待ち購買発注のみ照会

getPurchaseHeadersList

public ArrayList getPurchaseHeadersList()
伝票ヘッダ一覧を取得します。

戻り値:
ArrayList 伝票ヘッダ一覧

getPurchaseItemsList

public ArrayList getPurchaseItemsList()
伝票明細一覧を取得します。

戻り値:
ArrayList 伝票明細一覧

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseHeader (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
PurchaseHeaderPost, PurchaseHeaders
public class PurchaseHeader
extends Object
implements Serializable

購買発注ヘッダ情報スーパークラス
機能は以下の通り

  • 購買発注のヘッダ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseHeader()
購買発注伝票ヘッダを作成します。
メソッドの概要
String | getAgreement() 購買契約番号を取得します｡
String | getCreatedBy() 登録者名を取得します｡
String | getCurrency() 通貨コードを取得します｡
String | getCurrencyIso() ISO通貨コードを取得します｡
String | getCustomer() 得意先コード1を取得します｡
String | getDeleteInd() 削除フラグを取得します｡
String | getDiffInv() 仕入先と請求元が異なる場合の供給元のコードを取得します｡
String | getDocDate() 購買伝票日付を取得します｡
String | getDocType() 伝票タイプを取得します｡
String | getDscnt1To() 現金割引日数1を取得します｡
String | getDscnt2To() 現金割引日数2を取得します｡
String | getDscnt3To() 現金割引日数3を取得します｡
String | getExchRate() 換算レートを取得します｡
String | getExRateFx() 換算レート固定区分を取得します｡
String | getGrMessage() 入庫メッセージ区分を取得します｡
String | getIncoterms1() インコタームズ1を取得します｡
String | getIncoterms2() インコタームズ2を取得します｡
String | getItemIntvl() 明細番号間隔を取得します｡
String | getLogsystem() 論理システムを取得します｡
String | getOurRef() 社内参照番号を取得します｡
String | getPmnttrms() 支払条件キーを取得します｡
String | getPoNumber() 購買伝票を取得します｡
String | getPurchOrg() 購買組織を取得します｡
String | getPurGroup() 購買グループを取得します｡
String | getQuotation() 見積番号を取得します｡
String | getQuotDate() 見積提出日を取得します｡
String | getRef_1() 得意先/仕入先の内部参照コードを取得します｡
String | getRelStatus() 承認状況を取得します｡
String | getSalesPers() 仕入先営業担当者を取得します｡
String | getStatus() 伝票ステータスを取得します｡
String | getSubitemint() 副明細の明細間隔を取得します｡
String | getSupplPlnt() 在庫転送オーダーにおける供給(出庫)プラントを取得します｡
String | getSupplVend() 供給仕入先を取得します｡
String | getTelephone() 仕入先電話番号を取得します｡
String | getVendor() 仕入先勘定コードを取得します｡
String | getVperEnd() 有効期間終了日を取得します｡
String | getVperStart() 有効期間開始日を取得します｡
String | getWarranty() 保証日を取得します｡
void | setAgreement(String strAgreement) 購買契約番号を設定します｡
void | setCreatedBy(String strCreatedBy) 登録者名を設定します｡
void | setCurrency(String strCurrency) 通貨コードを設定します｡
void | setCurrencyIso(String strCurrencyIso) ISO通貨コードを設定します｡
void | setCustomer(String strCustomer) 得意先コード1を設定します｡
void | setDeleteInd(String strDeleteInd) 削除フラグを設定します｡
void | setDiffInv(String strDiffInv) 仕入先と請求元が異なる場合の請求元コードを設定します｡
void | setDocDate(String strDocDate) 購買伝票日付を設定します｡
void | setDocType(String strDocType) 伝票タイプを設定します｡
void | setDscnt1To(String strDscnt1To) 現金割引日数1を設定します｡
void | setDscnt2To(String strDscnt2To) 現金割引日数2を設定します｡
void | setDscnt3To(String strDscnt3To) 現金割引日数3を設定します｡
void | setExchRate(String strExchRate) 換算レートを設定します｡
void | setExRateFx(String strExRateFx) 換算レート固定区分を設定します｡
void | setGrMessage(String strGrMessage) 入庫メッセージ区分を設定します｡
void | setIncoterms1(String strIncoterms1) インコタームズ1を設定します｡
void | setIncoterms2(String strIncoterms2) インコタームズ2を設定します｡
void | setItemIntvl(String strItemIntvl) 明細番号間隔を設定します｡
void | setLogsystem(String strLogsystem) 論理システムを設定します｡
void | setOurRef(String strOurRef) 社内参照番号を設定します｡
void | setPmnttrms(String strPmnttrms) 支払条件キーを設定します｡
void | setPoNumber(String strPonNmber) 購買伝票番号を設定します｡
void | setPurchOrg(String strPurchOrg) 購買組織を設定します｡
void | setPurGroup(String strPurGroup) 購買グループを設定します｡
void | setQuotation(String strQuotation) 見積番号を設定します｡
void | setQuotDate(String strQuotDate) 見積提出日を設定します｡
void | setRef_1(String strRef1) 得意先/仕入先の内部参照コードを設定します｡
void | setRelStatus(String strRelStatus) 承認状況を設定します｡
void | setSalesPers(String strSalesPers) 仕入先営業担当者を設定します｡
void | setStatus(String strStatus) ステータスを設定します｡
void | setSubitemint(String strSubitemint) 副明細の明細間隔を設定します｡
void | setSupplPlnt(String strSupplPlnt) 在庫転送オーダーにおける供給(出庫)プラントを設定します｡
void | setSupplVend(String strSupplVend) 供給仕入先を設定します｡
void | setTelephone(String strTelephone) 仕入先電話番号を設定します｡
void | setVendor(String strVendor) 仕入先勘定コードを設定します｡
void | setVperEnd(String strVperEnd) 有効期間終了日を設定します｡
void | setVperStart(String strVperStart) 有効期間開始日を設定します｡
void | setWarranty(String strWarranty) 保証日を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseHeader

public PurchaseHeader()
購買発注伝票ヘッダを作成します。

メソッドの詳細

getPoNumber

public String getPoNumber()
購買伝票を取得します｡

戻り値:
strPoNumber

getDocType

public String getDocType()
伝票タイプを取得します｡

戻り値:
strDocType

getDeleteInd

public String getDeleteInd()
削除フラグを取得します｡

戻り値:
strDeleteInd

getStatus

public String getStatus()
伝票ステータスを取得します｡

戻り値:
strStatus

getCreatedBy

public String getCreatedBy()
登録者名を取得します｡

戻り値:
strCreatedBy

getItemIntvl

public String getItemIntvl()
明細番号間隔を取得します｡

戻り値:
strItemIntvl

getVendor

public String getVendor()
仕入先勘定コードを取得します｡

戻り値:
strVendor

getPmnttrms

public String getPmnttrms()
支払条件キーを取得します｡

戻り値:
strPmnttrms

getDscnt1To

public String getDscnt1To()
現金割引日数1を取得します｡

戻り値:
strDscnt1To

getDscnt2To

public String getDscnt2To()
現金割引日数2を取得します｡

戻り値:
strDscnt2to

getDscnt3To

public String getDscnt3To()
現金割引日数3を取得します｡

戻り値:
strDscnt3To

getPurchOrg

public String getPurchOrg()
購買組織を取得します｡

戻り値:
strPutchOrg

getPurGroup

public String getPurGroup()
購買グループを取得します｡

戻り値:
strPurGroup

getCurrency

public String getCurrency()
通貨コードを取得します｡

戻り値:
strCurrency

getCurrencyIso

public String getCurrencyIso()
ISO通貨コードを取得します｡

戻り値:
strCurrencyIso

getExchRate

public String getExchRate()
換算レートを取得します｡

戻り値:
strExchRate

getExRateFx

public String getExRateFx()
換算レート固定区分を取得します｡

戻り値:
strExRateFx

getDocDate

public String getDocDate()
購買伝票日付を取得します｡

戻り値:
strDocDate

getVperStart

public String getVperStart()
有効期間開始日を取得します｡

戻り値:
strVperStart

getVperEnd

public String getVperEnd()
有効期間終了日を取得します｡

戻り値:
strVperEnd

getWarranty

public String getWarranty()
保証日を取得します｡

戻り値:
strWarranty

getQuotation

public String getQuotation()
見積番号を取得します｡

戻り値:
strQuotation

getQuotDate

public String getQuotDate()
見積提出日を取得します｡

戻り値:
strQuotDate

getRef_1

public String getRef_1()
得意先/仕入先の内部参照コードを取得します｡

戻り値:
strRef1

getSalesPers

public String getSalesPers()
仕入先営業担当者を取得します｡

戻り値:
strSalesPers

getTelephone

public String getTelephone()
仕入先電話番号を取得します｡

戻り値:
strTelephone

getSupplVend

public String getSupplVend()
供給仕入先を取得します｡

戻り値:
strSupplVend

getCustomer

public String getCustomer()
得意先コード1を取得します｡

戻り値:
strCustomer

getAgreement

public String getAgreement()
購買契約番号を取得します｡

戻り値:
strAgreement

getGrMessage

public String getGrMessage()
入庫メッセージ区分を取得します｡

戻り値:
strGrMessage

getSupplPlnt

public String getSupplPlnt()
在庫転送オーダーにおける供給(出庫)プラントを取得します｡

戻り値:
strSupplPlnt

getIncoterms1

public String getIncoterms1()
インコタームズ1を取得します｡

戻り値:
strIncoterms1

getIncoterms2

public String getIncoterms2()
インコタームズ2を取得します｡

戻り値:
strIncoterms2

getDiffInv

public String getDiffInv()
仕入先と請求元が異なる場合の供給元のコードを取得します｡

戻り値:
strDiffInv

getOurRef

public String getOurRef()
社内参照番号を取得します｡

戻り値:
strOurRef

getLogsystem

public String getLogsystem()
論理システムを取得します｡

戻り値:
strLogsystem

getSubitemint

public String getSubitemint()
副明細の明細間隔を取得します｡

戻り値:
strSubitemint

getRelStatus

public String getRelStatus()
承認状況を取得します｡

戻り値:
strRelStatus

setPoNumber

public void setPoNumber(String strPonNmber)
購買伝票番号を設定します｡

パラメータ:
strPonNmber - 購買伝票番号

setDocType

public void setDocType(String strDocType)
伝票タイプを設定します｡

パラメータ:
strDocType - 伝票タイプ

setDeleteInd

public void setDeleteInd(String strDeleteInd)
削除フラグを設定します｡

パラメータ:
strDeleteInd - 削除フラグ

setStatus

public void setStatus(String strStatus)
ステータスを設定します｡

パラメータ:
strStatus - ステータス

setCreatedBy

public void setCreatedBy(String strCreatedBy)
登録者名を設定します｡

パラメータ:
strCreatedBy - 登録者名

setItemIntvl

public void setItemIntvl(String strItemIntvl)
明細番号間隔を設定します｡

パラメータ:
strItemIntvl - 明細番号間隔

setVendor

public void setVendor(String strVendor)
仕入先勘定コードを設定します｡

パラメータ:
strVendor - 仕入先勘定コード

setPmnttrms

public void setPmnttrms(String strPmnttrms)
支払条件キーを設定します｡

パラメータ:
strPmnttrms - 支払条件キー

setDscnt1To

public void setDscnt1To(String strDscnt1To)
現金割引日数1を設定します｡

パラメータ:
strDscnt1To - 現金割引日数1

setDscnt2To

public void setDscnt2To(String strDscnt2To)
現金割引日数2を設定します｡

パラメータ:
strDscnt2To - 現金割引日数2

setDscnt3To

public void setDscnt3To(String strDscnt3To)
現金割引日数3を設定します｡

パラメータ:
strDscnt3To - 現金割引日数3

setPurchOrg

public void setPurchOrg(String strPurchOrg)
購買組織を設定します｡

パラメータ:
strPurchOrg - 購買組織

setPurGroup

public void setPurGroup(String strPurGroup)
購買グループを設定します｡

パラメータ:
strPurGroup - 購買グループ

setCurrency

public void setCurrency(String strCurrency)
通貨コードを設定します｡

パラメータ:
strCurrency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String strCurrencyIso)
ISO通貨コードを設定します｡

パラメータ:
strCurrencyIso - ISO通貨コード

setExchRate

public void setExchRate(String strExchRate)
換算レートを設定します｡

パラメータ:
strExchRate - 換算レート

setExRateFx

public void setExRateFx(String strExRateFx)
換算レート固定区分を設定します｡

パラメータ:
strExRateFx - 換算レート固定区分

setDocDate

public void setDocDate(String strDocDate)
購買伝票日付を設定します｡

パラメータ:
strDocDate - 購買伝票日付

setVperStart

public void setVperStart(String strVperStart)
有効期間開始日を設定します｡

パラメータ:
strVperStart - 有効期間開始日

setVperEnd

public void setVperEnd(String strVperEnd)
有効期間終了日を設定します｡

パラメータ:
strVperEnd - 有効期間終了日

setWarranty

public void setWarranty(String strWarranty)
保証日を設定します｡

パラメータ:
strWarranty - 保証日

setQuotation

public void setQuotation(String strQuotation)
見積番号を設定します｡

パラメータ:
strQuotation - 見積番号

setQuotDate

public void setQuotDate(String strQuotDate)
見積提出日を設定します｡

パラメータ:
strQuotDate - 見積提出日

setRef_1

public void setRef_1(String strRef1)
得意先/仕入先の内部参照コードを設定します｡

パラメータ:
strRef1 - 得意先/仕入先の内部参照コード

setSalesPers

public void setSalesPers(String strSalesPers)
仕入先営業担当者を設定します｡

パラメータ:
strSalesPers - 仕入先営業担当者

setTelephone

public void setTelephone(String strTelephone)
仕入先電話番号を設定します｡

パラメータ:
strTelephone - 仕入先電話番号

setSupplVend

public void setSupplVend(String strSupplVend)
供給仕入先を設定します｡

パラメータ:
strSupplVend - 供給仕入先

setCustomer

public void setCustomer(String strCustomer)
得意先コード1を設定します｡

パラメータ:
strCustomer - 得意先コード1

setAgreement

public void setAgreement(String strAgreement)
購買契約番号を設定します｡

パラメータ:
strAgreement - 購買契約番号

setGrMessage

public void setGrMessage(String strGrMessage)
入庫メッセージ区分を設定します｡

パラメータ:
strGrMessage - 入庫メッセージ区分

setSupplPlnt

public void setSupplPlnt(String strSupplPlnt)
在庫転送オーダーにおける供給(出庫)プラントを設定します｡

パラメータ:
strSupplPlnt - 在庫転送オーダーにおける供給(出庫)プラント

setIncoterms1

public void setIncoterms1(String strIncoterms1)
インコタームズ1を設定します｡

パラメータ:
strIncoterms1 - インコタームズ1

setIncoterms2

public void setIncoterms2(String strIncoterms2)
インコタームズ2を設定します｡

パラメータ:
strIncoterms2 - インコタームズ2

setDiffInv

public void setDiffInv(String strDiffInv)
仕入先と請求元が異なる場合の請求元コードを設定します｡

パラメータ:
strDiffInv - 仕入先と請求元が異なる場合の請求元コード

setOurRef

public void setOurRef(String strOurRef)
社内参照番号を設定します｡

パラメータ:
strOurRef - 社内参照番号

setLogsystem

public void setLogsystem(String strLogsystem)
論理システムを設定します｡

パラメータ:
strLogsystem - 論理システム

setSubitemint

public void setSubitemint(String strSubitemint)
副明細の明細間隔を設定します｡

パラメータ:
strSubitemint - 副明細の明細間隔

setRelStatus

public void setRelStatus(String strRelStatus)
承認状況を設定します｡

パラメータ:
strRelStatus - 承認状況

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseHeaderPost (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseHeaderPost

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost
すべての実装インタフェース:
Serializable
public class PurchaseHeaderPost
extends PurchaseHeader
implements Serializable

購買発注伝票ヘッダ情報クラス
機能は以下の通り

  • 購買発注伝票ヘッダの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseHeaderPost()
購買発注伝票ヘッダを作成します。
メソッドの概要
String | getCollectNo() 一括番号を取得します。
String | getCompCode() 会社コードを取得します｡
String | getCreatDate() レコード登録日を取得します。
String | getDsctPct1() 割引率 1を取得します。
String | getDsctPct2() 割引率 2を取得します。
String | getLangu() 言語キーを取得します。
String | getLanguIso() 言語キーの ISO コードを取得します。
String | getPoRelInd() 承認区分: 購買伝票を取得します。
String | getReasonCancel() 取消理由を取得します。
String | getVatCntry() 売上税 ID 番号国を取得します。
String | getVatCntryIso() 消費税登録番号の ISO 国コードを取得します。
void | setCollectNo(String strCollectNo) 一括番号を設定します。
void | setCompCode(String strCompCode) 会社コードを設定します｡
void | setCreatDate(String strCreatDate) レコード登録日を設定します。
void | setDsctPct1(String strDsctPct1) 割引率 1を設定します。
void | setDsctPct2(String strDsctPct2) 割引率 2を設定します。
void | setLangu(String strLangu) 言語キーを設定します。
void | setLanguIso(String strLanguIso) 言語キーの ISO コードを設定します。
void | setPoRelInd(String strPoRelInd) 承認区分: 購買伝票を設定します。
void | setReasonCancel(String strReasonCancel) 取消理由を設定します。
void | setVatCntry(String strVatCntry) 売上税 ID 番号国を設定します。
void | setVatCntryIso(String strVatCntryIso) 消費税登録番号の ISO 国コードを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader から継承したメソッド
getAgreement, getCreatedBy, getCurrency, getCurrencyIso, getCustomer, getDeleteInd, getDiffInv, getDocDate, getDocType, getDscnt1To, getDscnt2To, getDscnt3To, getExchRate, getExRateFx, getGrMessage, getIncoterms1, getIncoterms2, getItemIntvl, getLogsystem, getOurRef, getPmnttrms, getPoNumber, getPurchOrg, getPurGroup, getQuotation, getQuotDate, getRef_1, getRelStatus, getSalesPers, getStatus, getSubitemint, getSupplPlnt, getSupplVend, getTelephone, getVendor, getVperEnd, getVperStart, getWarranty, setAgreement, setCreatedBy, setCurrency, setCurrencyIso, setCustomer, setDeleteInd, setDiffInv, setDocDate, setDocType, setDscnt1To, setDscnt2To, setDscnt3To, setExchRate, setExRateFx, setGrMessage, setIncoterms1, setIncoterms2, setItemIntvl, setLogsystem, setOurRef, setPmnttrms, setPoNumber, setPurchOrg, setPurGroup, setQuotation, setQuotDate, setRef_1, setRelStatus, setSalesPers, setStatus, setSubitemint, setSupplPlnt, setSupplVend, setTelephone, setVendor, setVperEnd, setVperStart, setWarranty
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseHeaderPost

public PurchaseHeaderPost()
購買発注伝票ヘッダを作成します。

メソッドの詳細

getCompCode

public String getCompCode()
会社コードを取得します｡

戻り値:
strCompCode

getCreatDate

public String getCreatDate()
レコード登録日を取得します。

戻り値:
srtCreatDate レコード登録日

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
srtLangu 言語キー

getLanguIso

public String getLanguIso()
言語キーの ISO コードを取得します。

戻り値:
srtLanguIso 言語キーの ISO コード

getDsctPct1

public String getDsctPct1()
割引率 1を取得します。

戻り値:
srtDsctPct1 割引率 1

getDsctPct2

public String getDsctPct2()
割引率 2を取得します。

戻り値:
srtDsctPct2 割引率 2

getCollectNo

public String getCollectNo()
一括番号を取得します。

戻り値:
srtCollectNo 一括番号

getPoRelInd

public String getPoRelInd()
承認区分: 購買伝票を取得します。

戻り値:
srtPoRelInd 承認区分: 購買伝票

getVatCntry

public String getVatCntry()
売上税 ID 番号国を取得します。

戻り値:
srtVatCntry 売上税 ID 番号国

getVatCntryIso

public String getVatCntryIso()
消費税登録番号の ISO 国コードを取得します。

戻り値:
srtVatCntryIso 消費税登録番号の ISO 国コード

getReasonCancel

public String getReasonCancel()
取消理由を取得します。

戻り値:
srtReasonCancel 取消理由

setCompCode

public void setCompCode(String strCompCode)
会社コードを設定します｡

パラメータ:
strCompCode - 会社コード

setCreatDate

public void setCreatDate(String strCreatDate)
レコード登録日を設定します。

パラメータ:
strCreatDate - レコード登録日

setLangu

public void setLangu(String strLangu)
言語キーを設定します。

パラメータ:
strLangu - 言語キー

setLanguIso

public void setLanguIso(String strLanguIso)
言語キーの ISO コードを設定します。

パラメータ:
strLanguIso - 言語キーの ISO コード

setDsctPct1

public void setDsctPct1(String strDsctPct1)
割引率 1を設定します。

パラメータ:
strDsctPct1 - 割引率 1

setDsctPct2

public void setDsctPct2(String strDsctPct2)
割引率 2を設定します。

パラメータ:
strDsctPct2 - 割引率 2

setCollectNo

public void setCollectNo(String strCollectNo)
一括番号を設定します。

パラメータ:
strCollectNo - 一括番号

setPoRelInd

public void setPoRelInd(String strPoRelInd)
承認区分: 購買伝票を設定します。

パラメータ:
strPoRelInd - 承認区分: 購買伝票

setVatCntry

public void setVatCntry(String strVatCntry)
売上税 ID 番号国を設定します。

パラメータ:
strVatCntry - 売上税 ID 番号国

setVatCntryIso

public void setVatCntryIso(String strVatCntryIso)
消費税登録番号の ISO 国コードを設定します。

パラメータ:
strVatCntryIso - 消費税登録番号の ISO 国コード

setReasonCancel

public void setReasonCancel(String strReasonCancel)
取消理由を設定します。

パラメータ:
strReasonCancel - 取消理由

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス PurchaseHeader 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseHeaders (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseHeaders

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders
すべての実装インタフェース:
Serializable
public class PurchaseHeaders
extends PurchaseHeader
implements Serializable

伝票の承認対象一覧ヘッダ情報クラス
機能は以下の通り

  • 伝票の承認対象一覧ヘッダの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseHeaders()
伝票の承認対象一覧ヘッダを作成します。
メソッドの概要
String | getApplicBy() 見積提出期限を取得します。
String | getBidinvNo() 見積管理番号を取得します。
String | getBindgPer() 見積有効期間を取得します。
String | getCashDisc1() 割引率 1を取得します。
String | getCashDisc2() 割引率 2を取得します。
String | getCntrlInd() 購買伝票タイプに対する管理区分を取得します。
String | getCoCode() 会社コードを取得します。
String | getCollNo() 一括番号を取得します。
String | getComplDlv() 全購買発注に対する一括納入指定を取得します。
String | getCreatedOn() レコード登録日を取得します。
String | getDocCat() 購買伝票カテゴリを取得します。
String | getDocCond() 伝票条件番号を取得します。
String | getExchRateCm() 間接呼び値換算レートを取得します。
String | getExportNo() 貿易データ番号: MM/SD 伝票を取得します。
String | getHold() 購買発注の不完全を取得します。
String | getLanguage() 言語キーを取得します。
String | getLastItem() 最終明細番号を取得します。
String | getMastCond() 期間依存条件伝票を取得します。
String | getProcedure() 決定表 (価格設定/出力管理/勘定設定/原価計算など)を取得します。
String | getQuotDead() 見積提出期限を取得します。
String | getRcvgVend() 未使用項目を取得します。
String | getRejReason() 見積および受注の拒否理由を取得します。
String | getRelGroup() 承認グループを取得します。
String | getRelInd() 承認区分: 購買伝票を取得します。
String | getRelStrat() 承認方針を取得します。
String | getSchedInd() 分納契約のリリース伝票区分を取得します。
String | getSubjToR() 承認未完了を取得します。
String | getTargetVal() 累積計画金額を取得します。
String | getTaxrCntry() 納税申告書の国を取得します。
String | getUpdateGrp() 統計更新の更新グループを取得します。
String | getVendName() 名称 1を取得します。
void | setApplicBy(String strApplicBy) 見積提出期限を設定します。
void | setBidinvNo(String strBidinvNo) 見積管理番号を設定します。
void | setBindgPer(String strBindgPer) 見積有効期間を設定します。
void | setCashDisc1(String strCashDisc1) 割引率 1を設定します。
void | setCashDisc2(String strCashDisc2) 割引率 2を設定します。
void | setCntrlInd(String strCntrlInd) 購買伝票タイプに対する管理区分を設定します。
void | setCoCode(String strCoCode) 会社コードを設定します。
void | setCollNo(String strCollNo) 一括番号を設定します。
void | setComplDlv(String strComplDlv) 全購買発注に対する一括納入指定を設定します。
void | setCreatedOn(String strCreatedOn) レコード登録日を設定します。
void | setDocCat(String strDocCat) 購買伝票カテゴリを設定します。
void | setDocCond(String strDocCond) 伝票条件番号を設定します。
void | setExchRateCm(String strExchRateCm) 間接呼び値換算レートを設定します。
void | setExportNo(String strExportNo) 貿易データ番号: MM/SD 伝票を設定します。
void | setHold(String strHold) 購買発注の不完全を設定します。
void | setLanguage(String strLanguage) 言語キーを設定します。
void | setLastItem(String strLastItem) 最終明細番号を設定します。
void | setMastCond(String strMastCond) 期間依存条件伝票を設定します。
void | setProcedure(String strProcedure) 決定表 (価格設定/出力管理/勘定設定/原価計算など)を設定します。
void | setQuotDead(String strQuotDead) 見積提出期限を設定します。
void | setRcvgVend(String strRcvgVend) 未使用項目を設定します。
void | setRejReason(String strRejReason) 見積および受注の拒否理由を設定します。
void | setRelGroup(String strRelGroup) 承認グループを設定します。
void | setRelInd(String strRelInd) 承認区分: 購買伝票を設定します。
void | setRelStrat(String strRelStrat) 承認方針を設定します。
void | setSchedInd(String strSchedInd) 分納契約のリリース伝票区分を設定します。
void | setSubjToR(String strSubjToR) 承認未完了を設定します。
void | setTargetVal(String strTargetVal) 累積計画金額を設定します。
void | setTaxrCntry(String strTaxrCntry) 納税申告書の国を設定します。
void | setUpdateGrp(String strUpdateGrp) 統計更新の更新グループを設定します。
void | setVendName(String strVendName) 名称 1を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader から継承したメソッド
getAgreement, getCreatedBy, getCurrency, getCurrencyIso, getCustomer, getDeleteInd, getDiffInv, getDocDate, getDocType, getDscnt1To, getDscnt2To, getDscnt3To, getExchRate, getExRateFx, getGrMessage, getIncoterms1, getIncoterms2, getItemIntvl, getLogsystem, getOurRef, getPmnttrms, getPoNumber, getPurchOrg, getPurGroup, getQuotation, getQuotDate, getRef_1, getRelStatus, getSalesPers, getStatus, getSubitemint, getSupplPlnt, getSupplVend, getTelephone, getVendor, getVperEnd, getVperStart, getWarranty, setAgreement, setCreatedBy, setCurrency, setCurrencyIso, setCustomer, setDeleteInd, setDiffInv, setDocDate, setDocType, setDscnt1To, setDscnt2To, setDscnt3To, setExchRate, setExRateFx, setGrMessage, setIncoterms1, setIncoterms2, setItemIntvl, setLogsystem, setOurRef, setPmnttrms, setPoNumber, setPurchOrg, setPurGroup, setQuotation, setQuotDate, setRef_1, setRelStatus, setSalesPers, setStatus, setSubitemint, setSupplPlnt, setSupplVend, setTelephone, setVendor, setVperEnd, setVperStart, setWarranty
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseHeaders

public PurchaseHeaders()
伝票の承認対象一覧ヘッダを作成します。

メソッドの詳細

getCoCode

public String getCoCode()
会社コードを取得します。

戻り値:
srtCoCode

getDocCat

public String getDocCat()
購買伝票カテゴリを取得します。

戻り値:
srtDocCat

getCntrlInd

public String getCntrlInd()
購買伝票タイプに対する管理区分を取得します。

戻り値:
srtCntrlInd

getCreatedOn

public String getCreatedOn()
レコード登録日を取得します。

戻り値:
srtCreatedOn

getLastItem

public String getLastItem()
最終明細番号を取得します。

戻り値:
srtLastItem

getLanguage

public String getLanguage()
言語キーを取得します。

戻り値:
srtLanguage

getCashDisc1

public String getCashDisc1()
割引率 1を取得します。

戻り値:
srtCashDisc1

getCashDisc2

public String getCashDisc2()
割引率 2を取得します。

戻り値:
srtCashDisc2

getApplicBy

public String getApplicBy()
見積提出期限を取得します。

戻り値:
srtApplicBy

getQuotDead

public String getQuotDead()
見積提出期限を取得します。

戻り値:
srtQuotDead

getBindgPer

public String getBindgPer()
見積有効期間を取得します。

戻り値:
srtBindgPer

getBidinvNo

public String getBidinvNo()
見積管理番号を取得します。

戻り値:
srtBidinvNo

getRejReason

public String getRejReason()
見積および受注の拒否理由を取得します。

戻り値:
srtRejReason

getComplDlv

public String getComplDlv()
全購買発注に対する一括納入指定を取得します。

戻り値:
srtComplDlv

getRcvgVend

public String getRcvgVend()
未使用項目を取得します。

戻り値:
srtRcvgVend

getTargetVal

public String getTargetVal()
累積計画金額を取得します。

戻り値:
srtTargetVal

getCollNo

public String getCollNo()
一括番号を取得します。

戻り値:
srtCollNo

getDocCond

public String getDocCond()
伝票条件番号を取得します。

戻り値:
srtDocCond

getProcedure

public String getProcedure()
決定表 (価格設定/出力管理/勘定設定/原価計算など)を取得します。

戻り値:
srtProcedure

getUpdateGrp

public String getUpdateGrp()
統計更新の更新グループを取得します。

戻り値:
srtUpdateGrp

getExportNo

public String getExportNo()
貿易データ番号: MM/SD 伝票を取得します。

戻り値:
srtExportNo

getMastCond

public String getMastCond()
期間依存条件伝票を取得します。

戻り値:
srtMastCond

getRelGroup

public String getRelGroup()
承認グループを取得します。

戻り値:
srtRelGroup

getRelStrat

public String getRelStrat()
承認方針を取得します。

戻り値:
srtRelStrat

getRelInd

public String getRelInd()
承認区分: 購買伝票を取得します。

戻り値:
srtRelInd

getSubjToR

public String getSubjToR()
承認未完了を取得します。

戻り値:
srtSubjToR

getTaxrCntry

public String getTaxrCntry()
納税申告書の国を取得します。

戻り値:
srtTaxrCntry

getSchedInd

public String getSchedInd()
分納契約のリリース伝票区分を取得します。

戻り値:
srtSchedInd

getVendName

public String getVendName()
名称 1を取得します。

戻り値:
srtVendName

getExchRateCm

public String getExchRateCm()
間接呼び値換算レートを取得します。

戻り値:
srtExchRateCm

getHold

public String getHold()
購買発注の不完全を取得します。

戻り値:
srtHold

setCoCode

public void setCoCode(String strCoCode)
会社コードを設定します。

パラメータ:
strCoCode - 会社コード

setDocCat

public void setDocCat(String strDocCat)
購買伝票カテゴリを設定します。

パラメータ:
strDocCat - 購買伝票カテゴリ

setCntrlInd

public void setCntrlInd(String strCntrlInd)
購買伝票タイプに対する管理区分を設定します。

パラメータ:
strCntrlInd - 購買伝票タイプに対する管理区分

setCreatedOn

public void setCreatedOn(String strCreatedOn)
レコード登録日を設定します。

パラメータ:
strCreatedOn - レコード登録日

setLastItem

public void setLastItem(String strLastItem)
最終明細番号を設定します。

パラメータ:
strLastItem - 最終明細番号

setLanguage

public void setLanguage(String strLanguage)
言語キーを設定します。

パラメータ:
strLanguage - 言語キー

setCashDisc1

public void setCashDisc1(String strCashDisc1)
割引率 1を設定します。

パラメータ:
strCashDisc1 - 割引率 1

setCashDisc2

public void setCashDisc2(String strCashDisc2)
割引率 2を設定します。

パラメータ:
strCashDisc2 - 割引率 2

setApplicBy

public void setApplicBy(String strApplicBy)
見積提出期限を設定します。

パラメータ:
strApplicBy - 見積提出期限

setQuotDead

public void setQuotDead(String strQuotDead)
見積提出期限を設定します。

パラメータ:
strQuotDead - 見積提出期限

setBindgPer

public void setBindgPer(String strBindgPer)
見積有効期間を設定します。

パラメータ:
strBindgPer - 見積有効期間

setBidinvNo

public void setBidinvNo(String strBidinvNo)
見積管理番号を設定します。

パラメータ:
strBidinvNo - 見積管理番号

setRejReason

public void setRejReason(String strRejReason)
見積および受注の拒否理由を設定します。

パラメータ:
strRejReason - 見積および受注の拒否理由

setComplDlv

public void setComplDlv(String strComplDlv)
全購買発注に対する一括納入指定を設定します。

パラメータ:
strComplDlv - 全購買発注に対する一括納入指定

setRcvgVend

public void setRcvgVend(String strRcvgVend)
未使用項目を設定します。

パラメータ:
strRcvgVend - 未使用項目

setTargetVal

public void setTargetVal(String strTargetVal)
累積計画金額を設定します。

パラメータ:
strTargetVal - 累積計画金額

setCollNo

public void setCollNo(String strCollNo)
一括番号を設定します。

パラメータ:
strCollNo - 一括番号

setDocCond

public void setDocCond(String strDocCond)
伝票条件番号を設定します。

パラメータ:
strDocCond - 伝票条件番号

setProcedure

public void setProcedure(String strProcedure)
決定表 (価格設定/出力管理/勘定設定/原価計算など)を設定します。

パラメータ:
strProcedure - 決定表 (価格設定/出力管理/勘定設定/原価計算など)

setUpdateGrp

public void setUpdateGrp(String strUpdateGrp)
統計更新の更新グループを設定します。

パラメータ:
strUpdateGrp - 統計更新の更新グループ

setExportNo

public void setExportNo(String strExportNo)
貿易データ番号: MM/SD 伝票を設定します。

パラメータ:
strExportNo - 貿易データ番号: MM/SD 伝票

setMastCond

public void setMastCond(String strMastCond)
期間依存条件伝票を設定します。

パラメータ:
strMastCond - 期間依存条件伝票

setRelGroup

public void setRelGroup(String strRelGroup)
承認グループを設定します。

パラメータ:
strRelGroup - 承認グループ

setRelStrat

public void setRelStrat(String strRelStrat)
承認方針を設定します。

パラメータ:
strRelStrat - 承認方針

setRelInd

public void setRelInd(String strRelInd)
承認区分: 購買伝票を設定します。

パラメータ:
strRelInd - 承認区分: 購買伝票

setSubjToR

public void setSubjToR(String strSubjToR)
承認未完了を設定します。

パラメータ:
strSubjToR - 承認未完了

setTaxrCntry

public void setTaxrCntry(String strTaxrCntry)
納税申告書の国を設定します。

パラメータ:
strTaxrCntry - 納税申告書の国

setSchedInd

public void setSchedInd(String strSchedInd)
分納契約のリリース伝票区分を設定します。

パラメータ:
strSchedInd - 分納契約のリリース伝票区分

setVendName

public void setVendName(String strVendName)
名称 1を設定します。

パラメータ:
strVendName - 名称 1

setExchRateCm

public void setExchRateCm(String strExchRateCm)
間接呼び値換算レートを設定します。

パラメータ:
strExchRateCm - 間接呼び値換算レート

setHold

public void setHold(String strHold)
購買発注の不完全を設定します。

パラメータ:
strHold - 購買発注の不完全

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス PurchaseHeader 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseItem (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
PurchaseItemPost, PurchaseItems
public class PurchaseItem
extends Object
implements Serializable

購買発注明細情報スーパークラス
機能は以下の通り

  • 購買発注の明細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseItem()
購買発注伝票明細を作成します。
メソッドの概要
String | getAcctasscat() 勘定設定カテゴリを取得します。
String | getAcknReqd() 購買発注請求書依頼を取得します。
String | getAgmtItem() 購買契約の明細番号を取得します。
String | getAgreement() 購買契約番号を取得します。
String | getAtRelev() 適当テーブル関連を取得します。
String | getConvDen1() 購買価格単位から購買発注単位への変換分母を取得します。
String | getConvNum1() 購買価格単位から購買発注単位への変換分子を取得します。
String | getDeleteInd() 購買伝票の削除フラグを取得します。
String | getDistrib() 複数勘定設定の配賦区分を取得します。
String | getInfoRec() 購買情報番号を取得します。
String | getItemCat() 購買伝票の明細カテゴリを取得します。
String | getKanbanInd() かんばん区分を取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 品目コード（長）を取得します。
String | getMaterialGuid() 品目コードの外部GUIDを取得します。
String | getMaterialVersion() 品目コードのバージョン番号を取得します。
String | getNetPrice() 通貨額を取得します。
String | getNoMoreGr() 納入完了区分を取得します。
String | getNoRounding() 購買発注明細での非表示丸めを取得します。
String | getOrderprUn() 購買発注価格単位を取得します。
String | getOrderprUnIso() 購買発注価格のISOコードを取得します。
String | getPartInv() 一部請求区分を取得します。
String | getPckgNo() パッケージ番号を取得します。
String | getPlanDel() 予定納入日数を取得します。
String | getPlant() プラントを取得します。
String | getPoItem() 明細番号を取得します。
String | getPoPrice() 価格採用区分を取得します。
String | getPoUnitIso() ISOコードによる発注単位を取得します。
String | getPreqName() 購買依頼者名/要求者名を取得します。
String | getPriceUnit() 価格単位を取得します。
String | getQualInsp() 在庫タイプを取得します。
String | getRetItem() 返品明細を取得します。
String | getShipping() 出荷指示を取得します。
String | getShortText() 品目コードテキスト（短）を取得します。
String | getTaxCode() 消費税コードを取得します。
String | getTrackingno() 購買依頼追跡番号を取得します。
String | getValType() 評価タイプを取得します。
String | getVendMat() 仕入先が使用している品目コードを取得します。
void | setAcctasscat(String strAcctasscat) 勘定設定カテゴリを設定します。
void | setAcknReqd(String strAcknReqd) 購買発注請求書依頼を設定します。
void | setAgmtItem(String strAgmtItem) 購買契約の明細番号を設定します。
void | setAgreement(String strAgreement) 購買契約番号を設定します。
void | setAtRelev(String strAtRelev) 適当テーブル関連を設定します。
void | setConvDen1(String strConvDen1) 購買価格単位から購買発注単位への変換分母を設定します。
void | setConvNum1(String strConvNum1) 購買価格単位から購買発注単位への変換分子を設定します。
void | setDeleteInd(String strDeleteInd) 購買伝票の削除フラグを設定します。
void | setDistrib(String strDistrib) 複数勘定設定の配賦区分を設定します。
void | setInfoRec(String strInfoRec) 購買情報番号を設定します。
void | setItemCat(String strItemCat) 購買伝票の明細カテゴリを設定します。
void | setKanbanInd(String strKanbanInd) かんばん区分を設定します。
void | setMaterial(String strMaterial) 品目コードを設定します。
void | setMaterialExternal(String strMaterialExternal) 品目コード（長）を設定します。
void | setMaterialGuid(String strMaterialGuid) 品目コードの外部GUIDを設定します。
void | setMaterialVersion(String strMaterialVersion) 品目コードのバージョン番号を設定します。
void | setNetPrice(String strNetPrice) 通貨額を設定します。
void | setNoMoreGr(String strNoMoreGr) 納入完了区分を設定します。
void | setNoRounding(String strNoRounding) 購買発注明細での非表示丸めを設定します。
void | setOrderprUn(String strOrderprUn) 購買発注価格単位を設定します。
void | setOrderprUnIso(String strOrderprUnIso) 購買発注価格のISOコードを設定します。
void | setPartInv(String strPartInv) 一部請求区分を設定します。
void | setPckgNo(String strPckgNo) パッケージ番号を設定します。
void | setPlanDel(String strPlanDel) 予定納入日数を設定します。
void | setPlant(String strPlant) プラントを設定します。
void | setPoItem(String strPoItem) 明細番号を設定します。
void | setPoPrice(String strPoPrice) 価格採用区分を設定します。
void | setPoUnitIso(String strPoUnitIso) ISOコードによる発注単位を設定します。
void | setPreqName(String strPreqName) 購買依頼者名/要求者名を設定します。
void | setPriceUnit(String strPriceUnit) 価格単位を設定します。
void | setQualInsp(String strQualInsp) 在庫タイプを設定します。
void | setRetItem(String strRetItem) 返品明細を設定します。
void | setShipping(String strShipping) 出荷指示を設定します。
void | setShortText(String strShortText) 品目コードテキスト（短）を設定します。
void | setTaxCode(String strTaxCode) 消費税コードを設定します。
void | setTrackingno(String strTrackingno) 購買依頼追跡番号を設定します。
void | setValType(String strValType) 評価タイプを設定します。
void | setVendMat(String strVendMat) 仕入先が使用している品目コードを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseItem

public PurchaseItem()
購買発注伝票明細を作成します。

メソッドの詳細

getPoItem

public String getPoItem()
明細番号を取得します。

戻り値:
strPoItem

getDeleteInd

public String getDeleteInd()
購買伝票の削除フラグを取得します。

戻り値:
strDeleteInd

getShortText

public String getShortText()
品目コードテキスト（短）を取得します。

戻り値:
strShortText

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
strMaterial

getMaterialExternal

public String getMaterialExternal()
品目コード（長）を取得します。

戻り値:
strMaterialExternal

getMaterialGuid

public String getMaterialGuid()
品目コードの外部GUIDを取得します。

戻り値:
strMaterialGuid

getMaterialVersion

public String getMaterialVersion()
品目コードのバージョン番号を取得します。

戻り値:
strMaterialVersion

getPlant

public String getPlant()
プラントを取得します。

戻り値:
strPlant

getTrackingno

public String getTrackingno()
購買依頼追跡番号を取得します。

戻り値:
strTrackingno

getInfoRec

public String getInfoRec()
購買情報番号を取得します。

戻り値:
strInfoRec

getVendMat

public String getVendMat()
仕入先が使用している品目コードを取得します。

戻り値:
strVendMat

getPoUnitIso

public String getPoUnitIso()
ISOコードによる発注単位を取得します。

戻り値:
strPoUnitIso

getOrderprUn

public String getOrderprUn()
購買発注価格単位を取得します。

戻り値:
strOrderprUn

getOrderprUnIso

public String getOrderprUnIso()
購買発注価格のISOコードを取得します。

戻り値:
strOrderprUnIso

getConvNum1

public String getConvNum1()
購買価格単位から購買発注単位への変換分子を取得します。

戻り値:
strConvNum1

getConvDen1

public String getConvDen1()
購買価格単位から購買発注単位への変換分母を取得します。

戻り値:
strConvDen1

getNetPrice

public String getNetPrice()
通貨額を取得します。

戻り値:
strNetPrice

getPriceUnit

public String getPriceUnit()
価格単位を取得します。

戻り値:
strPriceUnit

getTaxCode

public String getTaxCode()
消費税コードを取得します。

戻り値:
strTaxCode

getQualInsp

public String getQualInsp()
在庫タイプを取得します。

戻り値:
strQualInsp

getValType

public String getValType()
評価タイプを取得します。

戻り値:
strValType

getNoMoreGr

public String getNoMoreGr()
納入完了区分を取得します。

戻り値:
strNoMoreGr

getItemCat

public String getItemCat()
購買伝票の明細カテゴリを取得します。

戻り値:
strItemCat

getAcctasscat

public String getAcctasscat()
勘定設定カテゴリを取得します。

戻り値:
strAcctasscat

getDistrib

public String getDistrib()
複数勘定設定の配賦区分を取得します。

戻り値:
strDistrib

getPartInv

public String getPartInv()
一部請求区分を取得します。

戻り値:
strPartInv

getAcknReqd

public String getAcknReqd()
購買発注請求書依頼を取得します。

戻り値:
strAcknReqd

getAgreement

public String getAgreement()
購買契約番号を取得します。

戻り値:
strAgreement

getAgmtItem

public String getAgmtItem()
購買契約の明細番号を取得します。

戻り値:
strAgmtItem

getShipping

public String getShipping()
出荷指示を取得します。

戻り値:
strShipping

getPlanDel

public String getPlanDel()
予定納入日数を取得します。

戻り値:
strPlanDel

getKanbanInd

public String getKanbanInd()
かんばん区分を取得します。

戻り値:
strKanbanInd

getRetItem

public String getRetItem()
返品明細を取得します。

戻り値:
strRetItem

getAtRelev

public String getAtRelev()
適当テーブル関連を取得します。

戻り値:
strAtRelev

getPreqName

public String getPreqName()
購買依頼者名/要求者名を取得します。

戻り値:
strPreqName

getPckgNo

public String getPckgNo()
パッケージ番号を取得します。

戻り値:
strPckgNo

getNoRounding

public String getNoRounding()
購買発注明細での非表示丸めを取得します。

戻り値:
strNoRounding

getPoPrice

public String getPoPrice()
価格採用区分を取得します。

戻り値:
strPoPrice

setPoItem

public void setPoItem(String strPoItem)
明細番号を設定します。

パラメータ:
strPoItem - 明細番号

setDeleteInd

public void setDeleteInd(String strDeleteInd)
購買伝票の削除フラグを設定します。

パラメータ:
strDeleteInd - 購買伝票の削除フラグ

setShortText

public void setShortText(String strShortText)
品目コードテキスト（短）を設定します。

パラメータ:
strShortText - 品目コードテキスト（短）

setMaterial

public void setMaterial(String strMaterial)
品目コードを設定します。

パラメータ:
strMaterial - 品目コード

setMaterialExternal

public void setMaterialExternal(String strMaterialExternal)
品目コード（長）を設定します。

パラメータ:
strMaterialExternal - 品目コード（長）

setMaterialGuid

public void setMaterialGuid(String strMaterialGuid)
品目コードの外部GUIDを設定します。

パラメータ:
strMaterialGuid - 品目コードの外部GUID

setMaterialVersion

public void setMaterialVersion(String strMaterialVersion)
品目コードのバージョン番号を設定します。

パラメータ:
strMaterialVersion - 品目コードのバージョン番号

setPlant

public void setPlant(String strPlant)
プラントを設定します。

パラメータ:
strPlant - プラント

setTrackingno

public void setTrackingno(String strTrackingno)
購買依頼追跡番号を設定します。

パラメータ:
strTrackingno - 購買依頼追跡番号

setInfoRec

public void setInfoRec(String strInfoRec)
購買情報番号を設定します。

パラメータ:
strInfoRec - 購買情報番号

setVendMat

public void setVendMat(String strVendMat)
仕入先が使用している品目コードを設定します。

パラメータ:
strVendMat - 仕入先が使用している品目コード

setPoUnitIso

public void setPoUnitIso(String strPoUnitIso)
ISOコードによる発注単位を設定します。

パラメータ:
strPoUnitIso - ISOコードによる発注単位

setOrderprUn

public void setOrderprUn(String strOrderprUn)
購買発注価格単位を設定します。

パラメータ:
strOrderprUn - 購買発注価格単位

setOrderprUnIso

public void setOrderprUnIso(String strOrderprUnIso)
購買発注価格のISOコードを設定します。

パラメータ:
strOrderprUnIso - 購買発注価格のISOコード

setConvNum1

public void setConvNum1(String strConvNum1)
購買価格単位から購買発注単位への変換分子を設定します。

パラメータ:
strConvNum1 - 購買価格単位から購買発注単位への変換分子

setConvDen1

public void setConvDen1(String strConvDen1)
購買価格単位から購買発注単位への変換分母を設定します。

パラメータ:
strConvDen1 - 購買価格単位から購買発注単位への変換分母

setNetPrice

public void setNetPrice(String strNetPrice)
通貨額を設定します。

パラメータ:
strNetPrice - 通貨額

setPriceUnit

public void setPriceUnit(String strPriceUnit)
価格単位を設定します。

パラメータ:
strPriceUnit - 価格単位

setTaxCode

public void setTaxCode(String strTaxCode)
消費税コードを設定します。

パラメータ:
strTaxCode - 消費税コード

setQualInsp

public void setQualInsp(String strQualInsp)
在庫タイプを設定します。

パラメータ:
strQualInsp - 在庫タイプ

setValType

public void setValType(String strValType)
評価タイプを設定します。

パラメータ:
strValType - 評価タイプ

setNoMoreGr

public void setNoMoreGr(String strNoMoreGr)
納入完了区分を設定します。

パラメータ:
strNoMoreGr - 納入完了区分

setItemCat

public void setItemCat(String strItemCat)
購買伝票の明細カテゴリを設定します。

パラメータ:
strItemCat - 購買伝票の明細カテゴリ

setAcctasscat

public void setAcctasscat(String strAcctasscat)
勘定設定カテゴリを設定します。

パラメータ:
strAcctasscat - 勘定設定カテゴリ

setDistrib

public void setDistrib(String strDistrib)
複数勘定設定の配賦区分を設定します。

パラメータ:
strDistrib - 複数勘定設定の配賦区分

setPartInv

public void setPartInv(String strPartInv)
一部請求区分を設定します。

パラメータ:
strPartInv - 一部請求区分

setAcknReqd

public void setAcknReqd(String strAcknReqd)
購買発注請求書依頼を設定します。

パラメータ:
strAcknReqd - 購買発注請求書依頼

setAgreement

public void setAgreement(String strAgreement)
購買契約番号を設定します。

パラメータ:
strAgreement - 購買契約番号

setAgmtItem

public void setAgmtItem(String strAgmtItem)
購買契約の明細番号を設定します。

パラメータ:
strAgmtItem - 購買契約の明細番号

setShipping

public void setShipping(String strShipping)
出荷指示を設定します。

パラメータ:
strShipping - 出荷指示

setPlanDel

public void setPlanDel(String strPlanDel)
予定納入日数を設定します。

パラメータ:
strPlanDel - 予定納入日数

setKanbanInd

public void setKanbanInd(String strKanbanInd)
かんばん区分を設定します。

パラメータ:
strKanbanInd - かんばん区分

setRetItem

public void setRetItem(String strRetItem)
返品明細を設定します。

パラメータ:
strRetItem - 返品明細

setAtRelev

public void setAtRelev(String strAtRelev)
適当テーブル関連を設定します。

パラメータ:
strAtRelev - 適当テーブル関連

setPreqName

public void setPreqName(String strPreqName)
購買依頼者名/要求者名を設定します。

パラメータ:
strPreqName - 購買依頼者名/要求者名

setPckgNo

public void setPckgNo(String strPckgNo)
パッケージ番号を設定します。

パラメータ:
strPckgNo - パッケージ番号

setNoRounding

public void setNoRounding(String strNoRounding)
購買発注明細での非表示丸めを設定します。

パラメータ:
strNoRounding - 購買発注明細での非表示丸め

setPoPrice

public void setPoPrice(String strPoPrice)
価格採用区分を設定します。

パラメータ:
strPoPrice - 価格採用区分

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseItemPost (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseItemPost

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost
すべての実装インタフェース:
Serializable
public class PurchaseItemPost
extends PurchaseItem
implements Serializable

購買発注伝票明細情報クラス
機能は以下の通り

  • 購買発注伝票明細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseItemPost()
購買発注伝票明細を作成します。
PurchaseItemPost(int index)
購買発注伝票明細を作成します。
メソッドの概要
String | getAcknowlNo() 購買発注請書番号を取得します。
String | getBatch() ロット番号を取得します。
String | getBonGrp1() 決済グループ1を取得します。
String | getBonGrp2() 決済グループ 2 (リベート決済、購買)を取得します。
String | getBonGrp3() 決済グループ 3 (リベート決済、購買)を取得します。
String | getBrasNbm() Brazilian NCM Codeを取得します。
String | getCalctype() 価格設定タイプを取得します。
String | getCmmtItem() 資金予算コードを取得します。
String | getCmmtItemLong() 資金予算コードを取得します。
String | getCondGroup() 仕入先条件グループを取得します。
String | getConfCtrl() 確認管理キーを取得します。
String | getCtrlKey() 調達における品質管理の管理キーを取得します。
String | getCustomer() 得意先コードを取得します。
String | getDelivCompl() 出荷完了 区分を取得します。
String | getEmaterial() 品目コードを取得します。
String | getEmaterialExternal() 品目コード（長）を取得します。
String | getEmaterialGuid() 品目コードの外部GUIDを取得します。
String | getEmaterialVersion() 品目コードのバージョン番号を取得します。
String | getErs() ERS（入庫/請求自動決済）を取得します。
String | getEstPrice() 概算価格区分を取得します。
String | getFinalInv() 請求書処理完了区分を取得します。
String | getFreeItem() 無償明細を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getFund() 会計区分を取得します。
String | getFundsCtr() 予算センタを取得します。
int | getGlIndex() レコード番号を設定します｡
String | getGrantNbr() 補助金を取得します。
String | getGrBasediv() 入庫基準の請求書照合区分を取得します。
String | getGrInd() 入庫区分を取得します。
String | getGrNonVal() 非評価入庫を取得します。
String | getGrossWt() 総重量を取得します。
String | getGrPrTime() 入庫処理日数を取得します。
String | getGrToDate() 納入最終期限を取得します。
String | getHlItem() 購買伝票中の上位明細を取得します。
String | getIncoterms1() インコタームズ (1)を取得します。
String | getIncoterms2() インコタームズ 2を取得します。
String | getIndus3() 品目 CFOP カテゴリを取得します。
String | getInfIndex() インフレーション指数を取得します。
String | getInfoUpd() 購買情報更新区分を取得します。
String | getInHouse() 内部生産を取得します。
String | getIntObjNo() 選定 (内部オブジェクト番号)を取得します。
String | getIrInd() 請求書受領区分を取得します。
String | getMatlGroup() 品目グループを取得します。
String | getMatlUsage() 品目の用途を取得します。
String | getMatOrigin() 品目の原産地を取得します。
String | getMinremlife() 最低有効期間残を取得します。
String | getNetWeight() 正味重量を取得します。
String | getNoDisct() 現金値引対象外明細を取得します。
String | getOrderReason() 発注理由を取得します。
String | getOverDlvTol() 過剰納入許容範囲を取得します。
String | getPartDeliv() 明細レベルでの分割納入 (在庫転送)を取得します。
String | getPeriodIndExpirationDate() 有効期間期限日の期間区分を取得します。
String | getPoints() リベートポイント数を取得します。
String | getPointUnit() ポイント単位を取得します。
String | getPointUnitIso() ポイント単位の ISO コードを取得します。
String | getPoUnit() 発注単位を取得します。
String | getPreqItem() 購買依頼の明細番号を取得します。
String | getPreqNo() 購買依頼番号を取得します。
String | getPreVendor() 製造元/販売元を取得します。
String | getPricedate() 価格設定日カテゴリ (価格設定日管理)を取得します。
String | getPriceDate() 価格設定日を取得します。
String | getPrntPrice() 価格印刷を取得します。
String | getQuantity() 購買発注数量を取得します。
String | getRefDoc() 参照伝票番号を取得します。
String | getRefItem() 参照伝票の明細を取得します。
String | getReminder1() 第一回催促状/督促状の日数を取得します。
String | getReminder2() 第二回催促状/督促状の日数を取得します。
String | getReminder3() 第三回催促状/督促状の日数を取得します。
String | getRevLev() 改訂レベルを取得します。
String | getRfqItem() 見積依頼明細番号を取得します。
String | getRfqNo() 見積依頼番号を取得します。
String | getRPromo() プロモーションを取得します。
String | getScVendor() 外注仕入先を取得します。
String | getSeason() 季節カテゴリを取得します。
String | getSeasonYr() シーズン年度を取得します。
String | getSettItem() リベート (期末) 決済対象の明細を取得します。
String | getShipBlocked() SD 出荷伝票の明細ブロックを取得します。
String | getSiCat() 補助明細カテゴリ、購買伝票を取得します。
String | getStgeLoc() 保管場所を取得します。
String | getSupplStloc() 出庫保管場所: 在庫転送オーダーを取得します。
String | getSuppVendor() 供給仕入先/仕入入庫を取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getUnderDlvTol() 不足納入許容範囲リミットを取得します。
String | getUnlimitedDlv() 区分: 無制限過剰納入可能を取得します。
String | getUntilDate() インフレーション指数日付を取得します。
String | getVendPart() 仕入先部門を取得します。
String | getVendrbatch() 仕入先ロット番号を取得します。
String | getVolume() 容積を取得します。
String | getVolumeunit() 容積単位を取得します。
String | getVolumeunitIso() ISO コードでの容積単位を取得します。
String | getWeightunit() 重量単位を取得します。
String | getWeightunitIso() 重量単位のISOコードを取得します。
void | setAcknowlNo(String strAcknowlNo) 購買発注請書番号を設定します。
void | setBatch(String strBatch) ロット番号を設定します。
void | setBonGrp1(String strBonGrp1) 決済グループ1を設定します。
void | setBonGrp2(String strBonGrp2) 決済グループ 2 (リベート決済、購買)を設定します。
void | setBonGrp3(String strBonGrp3) 決済グループ 3 (リベート決済、購買)を設定します。
void | setBrasNbm(String strBrasNbm) Brazilian NCM Codeを設定します。
void | setCalctype(String strCalctype) 価格設定タイプを設定します。
void | setCmmtItem(String strCmmtItem) 資金予算コードを設定します。
void | setCmmtItemLong(String strCmmtItemLong) 資金予算コードを設定します。
void | setCondGroup(String strCondGroup) 仕入先条件グループを設定します。
void | setConfCtrl(String strConfCtrl) 確認管理キーを設定します。
void | setCtrlKey(String strCtrlKey) 調達における品質管理の管理キーを設定します。
void | setCustomer(String strCustomer) 得意先コードを設定します。
void | setDelivCompl(String strDelivCompl) 出荷完了 区分を設定します。
void | setEmaterial(String strEmaterial) 品目コードを設定します。
void | setEmaterialExternal(String strEmaterialExternal) 品目コード（長）を設定します。
void | setEmaterialGuid(String strEmaterialGuid) 品目コードの外部GUIDを設定します。
void | setEmaterialVersion(String strEmaterialVersion) 品目コードのバージョン番号を設定します。
void | setErs(String strErs) ERS（入庫/請求自動決済）を設定します。
void | setEstPrice(String strEstPrice) 概算価格区分を設定します。
void | setFinalInv(String strFinalInv) 請求書処理完了区分を設定します。
void | setFreeItem(String strFreeItem) 無償明細を設定します。
void | setFuncAreaLong(String strFuncAreaLong) 機能領域を設定します。
void | setFund(String strFund) 会計区分を設定します。
void | setFundsCtr(String strFundsCtr) 予算センタを設定します。
void | setGlIndex(int glIndex) レコード番号を設定します｡
void | setGrantNbr(String strGrantNbr) 補助金を設定します。
void | setGrBasediv(String strGrBasediv) 入庫基準の請求書照合区分を設定します。
void | setGrInd(String strGrInd) 入庫区分を設定します。
void | setGrNonVal(String strGrNonVal) 非評価入庫を設定します。
void | setGrossWt(String strGrossWt) 総重量を設定します。
void | setGrPrTime(String strGrPrTime) 入庫処理日数を設定します。
void | setGrToDate(String strGrToDate) 納入最終期限を設定します。
void | setHlItem(String strHlItem) 購買伝票中の上位明細を設定します。
void | setIncoterms1(String strIncoterms1) インコタームズ (1)を設定します。
void | setIncoterms2(String strIncoterms2) インコタームズ 2を設定します。
void | setIndus3(String strIndus3) 品目 CFOP カテゴリを設定します。
void | setInfIndex(String strInfIndex) インフレーション指数を設定します。
void | setInfoUpd(String strInfoUpd) 購買情報更新区分を設定します。
void | setInHouse(String strInHouse) 内部生産を設定します。
void | setIntObjNo(String strIntObjNo) 選定 (内部オブジェクト番号)を設定します。
void | setIrInd(String strIrInd) 請求書受領区分を設定します。
void | setMatlGroup(String strMatlGroup) 品目グループを設定します。
void | setMatlUsage(String strMatlUsage) 品目の用途を設定します。
void | setMatOrigin(String strMatOrigin) 品目の原産地を設定します。
void | setMinremlife(String strMinremlife) 最低有効期間残を設定します。
void | setNetWeight(String strNetWeight) 正味重量を設定します。
void | setNoDisct(String strNoDisct) 現金値引対象外明細を設定します。
void | setOrderReason(String strOrderReason) 発注理由を設定します。
void | setOverDlvTol(String strOverDlvTol) 過剰納入許容範囲を設定します。
void | setPartDeliv(String strPartDeliv) 明細レベルでの分割納入 (在庫転送)を設定します。
void | setPeriodIndExpirationDate(String strPeriodIndExpirationDate) 有効期間期限日の期間区分を設定します。
void | setPoints(String strPoints) リベートポイント数を設定します。
void | setPointUnit(String strPointUnit) ポイント単位を設定します。
void | setPointUnitIso(String strPointUnitIso) ポイント単位の ISO コードを設定します。
void | setPoUnit(String strPoUnit) 発注単位を設定します。
void | setPreqItem(String strPreqItem) 購買依頼の明細番号を設定します。
void | setPreqNo(String strPreqNo) 購買依頼番号を設定します。
void | setPreVendor(String strPreVendor) 製造元/販売元を設定します。
void | setPricedate(String strPricedate) 価格設定日カテゴリ (価格設定日管理)を設定します。
void | setPriceDate(String strPriceDate) 価格設定日を設定します。
void | setPrntPrice(String strPrntPrice) 価格印刷を設定します。
void | setQuantity(String strQuantity) 購買発注数量を設定します。
void | setRefDoc(String strRefDoc) 参照伝票番号を設定します。
void | setRefItem(String strRefItem) 参照伝票の明細を設定します。
void | setReminder1(String strReminder1) 第一回催促状/督促状の日数を設定します。
void | setReminder2(String strReminder2) 第二回催促状/督促状の日数を設定します。
void | setReminder3(String strReminder3) 第三回催促状/督促状の日数を設定します。
void | setRevLev(String strRevLev) 改訂レベルを設定します。
void | setRfqItem(String strRfqItem) 見積依頼明細番号を設定します。
void | setRfqNo(String strRfqNo) 見積依頼番号を設定します。
void | setRPromo(String strRPromo) プロモーションを設定します。
void | setScVendor(String strScVendor) 外注仕入先を設定します。
void | setSeason(String strSeason) 季節カテゴリを設定します。
void | setSeasonYr(String strSeasonYr) シーズン年度を設定します。
void | setSettItem(String strSettItem) リベート (期末) 決済対象の明細を設定します。
void | setShipBlocked(String strShipBlocked) SD 出荷伝票の明細ブロックを設定します。
void | setSiCat(String strSiCat) 補助明細カテゴリ、購買伝票を設定します。
void | setStgeLoc(String strStgeLoc) 保管場所を設定します。
void | setSupplStloc(String strSupplStloc) 出庫保管場所: 在庫転送オーダーを設定します。
void | setSuppVendor(String strSuppVendor) 供給仕入先/仕入入庫を設定します。
void | setTaxjurcode(String strTaxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setUnderDlvTol(String strUnderDlvTol) 不足納入許容範囲リミットを設定します。
void | setUnlimitedDlv(String strUnlimitedDlv) 区分: 無制限過剰納入可能を設定します。
void | setUntilDate(String strUntilDate) インフレーション指数日付を設定します。
void | setVendPart(String strVendPart) 仕入先部門を設定します。
void | setVendrbatch(String strVendrbatch) 仕入先ロット番号を設定します。
void | setVolume(String strVolume) 容積を設定します。
void | setVolumeunit(String strVolumeunit) 容積単位を設定します。
void | setVolumeunitIso(String strVolumeunitIso) ISO コードでの容積単位を設定します。
void | setWeightunit(String strWeightunit) 重量単位を設定します。
void | setWeightunitIso(String strWeightunitIso) 重量単位のISOコードを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem から継承したメソッド
getAcctasscat, getAcknReqd, getAgmtItem, getAgreement, getAtRelev, getConvDen1, getConvNum1, getDeleteInd, getDistrib, getInfoRec, getItemCat, getKanbanInd, getMaterial, getMaterialExternal, getMaterialGuid, getMaterialVersion, getNetPrice, getNoMoreGr, getNoRounding, getOrderprUn, getOrderprUnIso, getPartInv, getPckgNo, getPlanDel, getPlant, getPoItem, getPoPrice, getPoUnitIso, getPreqName, getPriceUnit, getQualInsp, getRetItem, getShipping, getShortText, getTaxCode, getTrackingno, getValType, getVendMat, setAcctasscat, setAcknReqd, setAgmtItem, setAgreement, setAtRelev, setConvDen1, setConvNum1, setDeleteInd, setDistrib, setInfoRec, setItemCat, setKanbanInd, setMaterial, setMaterialExternal, setMaterialGuid, setMaterialVersion, setNetPrice, setNoMoreGr, setNoRounding, setOrderprUn, setOrderprUnIso, setPartInv, setPckgNo, setPlanDel, setPlant, setPoItem, setPoPrice, setPoUnitIso, setPreqName, setPriceUnit, setQualInsp, setRetItem, setShipping, setShortText, setTaxCode, setTrackingno, setValType, setVendMat
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseItemPost

public PurchaseItemPost()
購買発注伝票明細を作成します。

PurchaseItemPost

public PurchaseItemPost(int index)
購買発注伝票明細を作成します。

パラメータ:
index - レコード件数
メソッドの詳細

getEmaterial

public String getEmaterial()
品目コードを取得します。

戻り値:
srtEmaterial 品目コード

getEmaterialExternal

public String getEmaterialExternal()
品目コード（長）を取得します。

戻り値:
srtEmaterialExternal 品目コード（長）

getEmaterialGuid

public String getEmaterialGuid()
品目コードの外部GUIDを取得します。

戻り値:
srtEmaterialGuid 品目コードの外部GUID

getEmaterialVersion

public String getEmaterialVersion()
品目コードのバージョン番号を取得します。

戻り値:
srtEmaterialVersion 品目コードのバージョン番号

getStgeLoc

public String getStgeLoc()
保管場所を取得します。

戻り値:
srtStgeLoc 保管場所

getMatlGroup

public String getMatlGroup()
品目グループを取得します。

戻り値:
srtMatlGroup 品目グループ

getQuantity

public String getQuantity()
購買発注数量を取得します。

戻り値:
srtQuantity 購買発注数量

getPoUnit

public String getPoUnit()
発注単位を取得します。

戻り値:
srtPoUnit 発注単位

getGrPrTime

public String getGrPrTime()
入庫処理日数を取得します。

戻り値:
srtGrPrTime 入庫処理日数

getBonGrp1

public String getBonGrp1()
決済グループ1を取得します。

戻り値:
srtBonGrp1 決済グループ1

getInfoUpd

public String getInfoUpd()
購買情報更新区分を取得します。

戻り値:
srtInfoUpd 購買情報更新区分

getPrntPrice

public String getPrntPrice()
価格印刷を取得します。

戻り値:
srtPrntPrice 価格印刷

getEstPrice

public String getEstPrice()
概算価格区分を取得します。

戻り値:
srtEstPrice 概算価格区分

getReminder1

public String getReminder1()
第一回催促状/督促状の日数を取得します。

戻り値:
srtReminder1 第一回催促状/督促状の日数

getReminder2

public String getReminder2()
第二回催促状/督促状の日数を取得します。

戻り値:
srtReminder2 第二回催促状/督促状の日数

getReminder3

public String getReminder3()
第三回催促状/督促状の日数を取得します。

戻り値:
srtReminder3 第三回催促状/督促状の日数

getOverDlvTol

public String getOverDlvTol()
過剰納入許容範囲を取得します。

戻り値:
srtOverDlvTol 過剰納入許容範囲

getUnlimitedDlv

public String getUnlimitedDlv()
区分: 無制限過剰納入可能を取得します。

戻り値:
srtUnlimitedDlv 区分: 無制限過剰納入可能

getUnderDlvTol

public String getUnderDlvTol()
不足納入許容範囲リミットを取得します。

戻り値:
srtUnderDlvTol 不足納入許容範囲リミット

getFinalInv

public String getFinalInv()
請求書処理完了区分を取得します。

戻り値:
srtFinalInv 請求書処理完了区分

getGrInd

public String getGrInd()
入庫区分を取得します。

戻り値:
srtGrInd 入庫区分

getGrNonVal

public String getGrNonVal()
非評価入庫を取得します。

戻り値:
srtGrNonVal 非評価入庫

getIrInd

public String getIrInd()
請求書受領区分を取得します。

戻り値:
srtIrInd 請求書受領区分

getFreeItem

public String getFreeItem()
無償明細を取得します。

戻り値:
srtFreeItem 無償明細

getGrBasediv

public String getGrBasediv()
入庫基準の請求書照合区分を取得します。

戻り値:
srtGrBasediv 入庫基準の請求書照合区分

getAcknowlNo

public String getAcknowlNo()
購買発注請書番号を取得します。

戻り値:
srtAcknowlNo 購買発注請書番号

getCustomer

public String getCustomer()
得意先コードを取得します。

戻り値:
srtCustomer 得意先コード

getCondGroup

public String getCondGroup()
仕入先条件グループを取得します。

戻り値:
srtCondGroup 仕入先条件グループ

getNoDisct

public String getNoDisct()
現金値引対象外明細を取得します。

戻り値:
srtNoDisct 現金値引対象外明細

getNetWeight

public String getNetWeight()
正味重量を取得します。

戻り値:
srtNetWeight 正味重量

getWeightunit

public String getWeightunit()
重量単位を取得します。

戻り値:
srtWeightunit 重量単位

getWeightunitIso

public String getWeightunitIso()
重量単位のISOコードを取得します。

戻り値:
srtWeightunitIso 重量単位のISOコード

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
srtTaxjurcode 税計算管轄コード - 税管轄コード

getCtrlKey

public String getCtrlKey()
調達における品質管理の管理キーを取得します。

戻り値:
srtCtrlKey 調達における品質管理の管理キー

getConfCtrl

public String getConfCtrl()
確認管理キーを取得します。

戻り値:
srtConfCtrl 確認管理キー

getRevLev

public String getRevLev()
改訂レベルを取得します。

戻り値:
srtRevLev 改訂レベル

getFund

public String getFund()
会計区分を取得します。

戻り値:
srtFund 会計区分

getFundsCtr

public String getFundsCtr()
予算センタを取得します。

戻り値:
srtFundsCtr 予算センタ

getCmmtItem

public String getCmmtItem()
資金予算コードを取得します。

戻り値:
srtCmmtItem 資金予算コード

getPricedate

public String getPricedate()
価格設定日カテゴリ (価格設定日管理)を取得します。

戻り値:
srtPricedate 価格設定日カテゴリ (価格設定日管理)

getPriceDate

public String getPriceDate()
価格設定日を取得します。

戻り値:
srtPriceDate 価格設定日

getGrossWt

public String getGrossWt()
総重量を取得します。

戻り値:
srtGrossWt 総重量

getVolume

public String getVolume()
容積を取得します。

戻り値:
srtVolume 容積

getVolumeunit

public String getVolumeunit()
容積単位を取得します。

戻り値:
srtVolumeunit 容積単位

getVolumeunitIso

public String getVolumeunitIso()
ISO コードでの容積単位を取得します。

戻り値:
srtVolumeunitIso ISO コードでの容積単位

getIncoterms1

public String getIncoterms1()
インコタームズ (1)を取得します。

戻り値:
srtIncoterms1 インコタームズ (1)

getIncoterms2

public String getIncoterms2()
インコタームズ 2を取得します。

戻り値:
srtIncoterms2 インコタームズ 2

getPreVendor

public String getPreVendor()
製造元/販売元を取得します。

戻り値:
srtPreVendor 製造元/販売元

getVendPart

public String getVendPart()
仕入先部門を取得します。

戻り値:
srtVendPart 仕入先部門

getHlItem

public String getHlItem()
購買伝票中の上位明細を取得します。

戻り値:
srtHlItem 購買伝票中の上位明細

getGrToDate

public String getGrToDate()
納入最終期限を取得します。

戻り値:
srtGrToDate 納入最終期限

getSuppVendor

public String getSuppVendor()
供給仕入先/仕入入庫を取得します。

戻り値:
srtSuppVendor 供給仕入先/仕入入庫

getScVendor

public String getScVendor()
外注仕入先を取得します。

戻り値:
srtScVendor 外注仕入先

getErs

public String getErs()
ERS（入庫/請求自動決済）を取得します。

戻り値:
srtErs ERS（入庫/請求自動決済）

getRPromo

public String getRPromo()
プロモーションを取得します。

戻り値:
srtRPromo プロモーション

getPoints

public String getPoints()
リベートポイント数を取得します。

戻り値:
srtPoints リベートポイント数

getPointUnit

public String getPointUnit()
ポイント単位を取得します。

戻り値:
srtPointUnit ポイント単位

getPointUnitIso

public String getPointUnitIso()
ポイント単位の ISO コードを取得します。

戻り値:
srtPointUnitIso ポイント単位の ISO コード

getSeason

public String getSeason()
季節カテゴリを取得します。

戻り値:
srtSeason 季節カテゴリ

getSeasonYr

public String getSeasonYr()
シーズン年度を取得します。

戻り値:
srtSeasonYr シーズン年度

getBonGrp2

public String getBonGrp2()
決済グループ 2 (リベート決済、購買)を取得します。

戻り値:
srtBonGrp2 決済グループ 2 (リベート決済、購買)

getBonGrp3

public String getBonGrp3()
決済グループ 3 (リベート決済、購買)を取得します。

戻り値:
srtBonGrp3 決済グループ 3 (リベート決済、購買)

getSettItem

public String getSettItem()
リベート (期末) 決済対象の明細を取得します。

戻り値:
srtSettItem リベート (期末) 決済対象の明細

getMinremlife

public String getMinremlife()
最低有効期間残を取得します。

戻り値:
srtMinremlife 最低有効期間残

getRfqNo

public String getRfqNo()
見積依頼番号を取得します。

戻り値:
srtRfqNo 見積依頼番号

getRfqItem

public String getRfqItem()
見積依頼明細番号を取得します。

戻り値:
srtRfqItem 見積依頼明細番号

getPreqNo

public String getPreqNo()
購買依頼番号を取得します。

戻り値:
srtPreqNo 購買依頼番号

getPreqItem

public String getPreqItem()
購買依頼の明細番号を取得します。

戻り値:
srtPreqItem 購買依頼の明細番号

getRefDoc

public String getRefDoc()
参照伝票番号を取得します。

戻り値:
srtRefDoc 参照伝票番号

getRefItem

public String getRefItem()
参照伝票の明細を取得します。

戻り値:
srtRefItem 参照伝票の明細

getSiCat

public String getSiCat()
補助明細カテゴリ、購買伝票を取得します。

戻り値:
srtSiCat 補助明細カテゴリ、購買伝票

getOrderReason

public String getOrderReason()
発注理由を取得します。

戻り値:
srtOrderReason 発注理由

getBrasNbm

public String getBrasNbm()
Brazilian NCM Codeを取得します。

戻り値:
srtBrasNbm Brazilian NCM Code

getMatlUsage

public String getMatlUsage()
品目の用途を取得します。

戻り値:
srtMatlUsage 品目の用途

getMatOrigin

public String getMatOrigin()
品目の原産地を取得します。

戻り値:
srtMatOrigin 品目の原産地

getInHouse

public String getInHouse()
内部生産を取得します。

戻り値:
srtInHouse 内部生産

getIndus3

public String getIndus3()
品目 CFOP カテゴリを取得します。

戻り値:
srtIndus3 品目 CFOP カテゴリ

getInfIndex

public String getInfIndex()
インフレーション指数を取得します。

戻り値:
srtInfIndex インフレーション指数

getUntilDate

public String getUntilDate()
インフレーション指数日付を取得します。

戻り値:
srtUntilDate インフレーション指数日付

getDelivCompl

public String getDelivCompl()
出荷完了 区分を取得します。

戻り値:
srtDelivCompl 出荷完了 区分

getPartDeliv

public String getPartDeliv()
明細レベルでの分割納入 (在庫転送)を取得します。

戻り値:
srtPartDeliv 明細レベルでの分割納入 (在庫転送)

getShipBlocked

public String getShipBlocked()
SD 出荷伝票の明細ブロックを取得します。

戻り値:
srtShipBlocked SD 出荷伝票の明細ブロック

getPeriodIndExpirationDate

public String getPeriodIndExpirationDate()
有効期間期限日の期間区分を取得します。

戻り値:
srtPeriodIndExpirationDate 有効期間期限日の期間区分

getIntObjNo

public String getIntObjNo()
選定 (内部オブジェクト番号)を取得します。

戻り値:
srtIntObjNo 選定 (内部オブジェクト番号)

getBatch

public String getBatch()
ロット番号を取得します。

戻り値:
srtBatch ロット番号

getVendrbatch

public String getVendrbatch()
仕入先ロット番号を取得します。

戻り値:
srtVendrbatch 仕入先ロット番号

getCalctype

public String getCalctype()
価格設定タイプを取得します。

戻り値:
srtCalctype 価格設定タイプ

getGrantNbr

public String getGrantNbr()
補助金を取得します。

戻り値:
srtGrantNbr 補助金

getCmmtItemLong

public String getCmmtItemLong()
資金予算コードを取得します。

戻り値:
srtCmmtItemLong 資金予算コード

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
srtFuncAreaLong 機能領域

getSupplStloc

public String getSupplStloc()
出庫保管場所: 在庫転送オーダーを取得します。

戻り値:
srtSupplStloc 出庫保管場所: 在庫転送オーダー

getGlIndex

public int getGlIndex()
レコード番号を設定します｡

戻り値:
glIndex レコード番号

setEmaterial

public void setEmaterial(String strEmaterial)
品目コードを設定します。

パラメータ:
strEmaterial - 品目コード

setEmaterialExternal

public void setEmaterialExternal(String strEmaterialExternal)
品目コード（長）を設定します。

パラメータ:
strEmaterialExternal - 品目コード（長）

setEmaterialGuid

public void setEmaterialGuid(String strEmaterialGuid)
品目コードの外部GUIDを設定します。

パラメータ:
strEmaterialGuid - 品目コードの外部GUID

setEmaterialVersion

public void setEmaterialVersion(String strEmaterialVersion)
品目コードのバージョン番号を設定します。

パラメータ:
strEmaterialVersion - 品目コードのバージョン番号

setStgeLoc

public void setStgeLoc(String strStgeLoc)
保管場所を設定します。

パラメータ:
strStgeLoc - 保管場所

setMatlGroup

public void setMatlGroup(String strMatlGroup)
品目グループを設定します。

パラメータ:
strMatlGroup - 品目グループ

setQuantity

public void setQuantity(String strQuantity)
購買発注数量を設定します。

パラメータ:
strQuantity - 購買発注数量

setPoUnit

public void setPoUnit(String strPoUnit)
発注単位を設定します。

パラメータ:
strPoUnit - 発注単位

setGrPrTime

public void setGrPrTime(String strGrPrTime)
入庫処理日数を設定します。

パラメータ:
strGrPrTime - 入庫処理日数

setBonGrp1

public void setBonGrp1(String strBonGrp1)
決済グループ1を設定します。

パラメータ:
strBonGrp1 - 決済グループ1

setInfoUpd

public void setInfoUpd(String strInfoUpd)
購買情報更新区分を設定します。

パラメータ:
strInfoUpd - 購買情報更新区分

setPrntPrice

public void setPrntPrice(String strPrntPrice)
価格印刷を設定します。

パラメータ:
strPrntPrice - 価格印刷

setEstPrice

public void setEstPrice(String strEstPrice)
概算価格区分を設定します。

パラメータ:
strEstPrice - 概算価格区分

setReminder1

public void setReminder1(String strReminder1)
第一回催促状/督促状の日数を設定します。

パラメータ:
strReminder1 - 第一回催促状/督促状の日数

setReminder2

public void setReminder2(String strReminder2)
第二回催促状/督促状の日数を設定します。

パラメータ:
strReminder2 - 第二回催促状/督促状の日数

setReminder3

public void setReminder3(String strReminder3)
第三回催促状/督促状の日数を設定します。

パラメータ:
strReminder3 - 第三回催促状/督促状の日数

setOverDlvTol

public void setOverDlvTol(String strOverDlvTol)
過剰納入許容範囲を設定します。

パラメータ:
strOverDlvTol - 過剰納入許容範囲

setUnlimitedDlv

public void setUnlimitedDlv(String strUnlimitedDlv)
区分: 無制限過剰納入可能を設定します。

パラメータ:
strUnlimitedDlv - 区分: 無制限過剰納入可能

setUnderDlvTol

public void setUnderDlvTol(String strUnderDlvTol)
不足納入許容範囲リミットを設定します。

パラメータ:
strUnderDlvTol - 不足納入許容範囲リミット

setFinalInv

public void setFinalInv(String strFinalInv)
請求書処理完了区分を設定します。

パラメータ:
strFinalInv - 請求書処理完了区分

setGrInd

public void setGrInd(String strGrInd)
入庫区分を設定します。

パラメータ:
strGrInd - 入庫区分

setGrNonVal

public void setGrNonVal(String strGrNonVal)
非評価入庫を設定します。

パラメータ:
strGrNonVal - 非評価入庫

setIrInd

public void setIrInd(String strIrInd)
請求書受領区分を設定します。

パラメータ:
strIrInd - 請求書受領区分

setFreeItem

public void setFreeItem(String strFreeItem)
無償明細を設定します。

パラメータ:
strFreeItem - 無償明細

setGrBasediv

public void setGrBasediv(String strGrBasediv)
入庫基準の請求書照合区分を設定します。

パラメータ:
strGrBasediv - 入庫基準の請求書照合区分

setAcknowlNo

public void setAcknowlNo(String strAcknowlNo)
購買発注請書番号を設定します。

パラメータ:
strAcknowlNo - 購買発注請書番号

setCustomer

public void setCustomer(String strCustomer)
得意先コードを設定します。

パラメータ:
strCustomer - 得意先コード

setCondGroup

public void setCondGroup(String strCondGroup)
仕入先条件グループを設定します。

パラメータ:
strCondGroup - 仕入先条件グループ

setNoDisct

public void setNoDisct(String strNoDisct)
現金値引対象外明細を設定します。

パラメータ:
strNoDisct - 現金値引対象外明細

setNetWeight

public void setNetWeight(String strNetWeight)
正味重量を設定します。

パラメータ:
strNetWeight - 正味重量

setWeightunit

public void setWeightunit(String strWeightunit)
重量単位を設定します。

パラメータ:
strWeightunit - 重量単位

setWeightunitIso

public void setWeightunitIso(String strWeightunitIso)
重量単位のISOコードを設定します。

パラメータ:
strWeightunitIso - 重量単位のISOコード

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税計算管轄コード - 税管轄コード

setCtrlKey

public void setCtrlKey(String strCtrlKey)
調達における品質管理の管理キーを設定します。

パラメータ:
strCtrlKey - 調達における品質管理の管理キー

setConfCtrl

public void setConfCtrl(String strConfCtrl)
確認管理キーを設定します。

パラメータ:
strConfCtrl - 確認管理キー

setRevLev

public void setRevLev(String strRevLev)
改訂レベルを設定します。

パラメータ:
strRevLev - 改訂レベル

setFund

public void setFund(String strFund)
会計区分を設定します。

パラメータ:
strFund - 会計区分

setFundsCtr

public void setFundsCtr(String strFundsCtr)
予算センタを設定します。

パラメータ:
strFundsCtr - 予算センタ

setCmmtItem

public void setCmmtItem(String strCmmtItem)
資金予算コードを設定します。

パラメータ:
strCmmtItem - 資金予算コード

setPricedate

public void setPricedate(String strPricedate)
価格設定日カテゴリ (価格設定日管理)を設定します。

パラメータ:
strPricedate - 価格設定日カテゴリ (価格設定日管理)

setPriceDate

public void setPriceDate(String strPriceDate)
価格設定日を設定します。

パラメータ:
strPriceDate - 価格設定日

setGrossWt

public void setGrossWt(String strGrossWt)
総重量を設定します。

パラメータ:
strGrossWt - 総重量

setVolume

public void setVolume(String strVolume)
容積を設定します。

パラメータ:
strVolume - 容積

setVolumeunit

public void setVolumeunit(String strVolumeunit)
容積単位を設定します。

パラメータ:
strVolumeunit - 容積単位

setVolumeunitIso

public void setVolumeunitIso(String strVolumeunitIso)
ISO コードでの容積単位を設定します。

パラメータ:
strVolumeunitIso - ISO コードでの容積単位

setIncoterms1

public void setIncoterms1(String strIncoterms1)
インコタームズ (1)を設定します。

パラメータ:
strIncoterms1 - インコタームズ (1)

setIncoterms2

public void setIncoterms2(String strIncoterms2)
インコタームズ 2を設定します。

パラメータ:
strIncoterms2 - インコタームズ 2

setPreVendor

public void setPreVendor(String strPreVendor)
製造元/販売元を設定します。

パラメータ:
strPreVendor - 製造元/販売元

setVendPart

public void setVendPart(String strVendPart)
仕入先部門を設定します。

パラメータ:
strVendPart - 仕入先部門

setHlItem

public void setHlItem(String strHlItem)
購買伝票中の上位明細を設定します。

パラメータ:
strHlItem - 購買伝票中の上位明細

setGrToDate

public void setGrToDate(String strGrToDate)
納入最終期限を設定します。

パラメータ:
strGrToDate - 納入最終期限

setSuppVendor

public void setSuppVendor(String strSuppVendor)
供給仕入先/仕入入庫を設定します。

パラメータ:
strSuppVendor - 供給仕入先/仕入入庫

setScVendor

public void setScVendor(String strScVendor)
外注仕入先を設定します。

パラメータ:
strScVendor - 外注仕入先

setErs

public void setErs(String strErs)
ERS（入庫/請求自動決済）を設定します。

パラメータ:
strErs - ERS（入庫/請求自動決済）

setRPromo

public void setRPromo(String strRPromo)
プロモーションを設定します。

パラメータ:
strRPromo - プロモーション

setPoints

public void setPoints(String strPoints)
リベートポイント数を設定します。

パラメータ:
strPoints - リベートポイント数

setPointUnit

public void setPointUnit(String strPointUnit)
ポイント単位を設定します。

パラメータ:
strPointUnit - ポイント単位

setPointUnitIso

public void setPointUnitIso(String strPointUnitIso)
ポイント単位の ISO コードを設定します。

パラメータ:
strPointUnitIso - ポイント単位の ISO コード

setSeason

public void setSeason(String strSeason)
季節カテゴリを設定します。

パラメータ:
strSeason - 季節カテゴリ

setSeasonYr

public void setSeasonYr(String strSeasonYr)
シーズン年度を設定します。

パラメータ:
strSeasonYr - シーズン年度

setBonGrp2

public void setBonGrp2(String strBonGrp2)
決済グループ 2 (リベート決済、購買)を設定します。

パラメータ:
strBonGrp2 - 決済グループ 2 (リベート決済、購買)

setBonGrp3

public void setBonGrp3(String strBonGrp3)
決済グループ 3 (リベート決済、購買)を設定します。

パラメータ:
strBonGrp3 - 決済グループ 3 (リベート決済、購買)

setSettItem

public void setSettItem(String strSettItem)
リベート (期末) 決済対象の明細を設定します。

パラメータ:
strSettItem - リベート (期末) 決済対象の明細

setMinremlife

public void setMinremlife(String strMinremlife)
最低有効期間残を設定します。

パラメータ:
strMinremlife - 最低有効期間残

setRfqNo

public void setRfqNo(String strRfqNo)
見積依頼番号を設定します。

パラメータ:
strRfqNo - 見積依頼番号

setRfqItem

public void setRfqItem(String strRfqItem)
見積依頼明細番号を設定します。

パラメータ:
strRfqItem - 見積依頼明細番号

setPreqNo

public void setPreqNo(String strPreqNo)
購買依頼番号を設定します。

パラメータ:
strPreqNo - 購買依頼番号

setPreqItem

public void setPreqItem(String strPreqItem)
購買依頼の明細番号を設定します。

パラメータ:
strPreqItem - 購買依頼の明細番号

setRefDoc

public void setRefDoc(String strRefDoc)
参照伝票番号を設定します。

パラメータ:
strRefDoc - 参照伝票番号

setRefItem

public void setRefItem(String strRefItem)
参照伝票の明細を設定します。

パラメータ:
strRefItem - 参照伝票の明細

setSiCat

public void setSiCat(String strSiCat)
補助明細カテゴリ、購買伝票を設定します。

パラメータ:
strSiCat - 補助明細カテゴリ、購買伝票

setOrderReason

public void setOrderReason(String strOrderReason)
発注理由を設定します。

パラメータ:
strOrderReason - 発注理由

setBrasNbm

public void setBrasNbm(String strBrasNbm)
Brazilian NCM Codeを設定します。

パラメータ:
strBrasNbm - Brazilian NCM Code

setMatlUsage

public void setMatlUsage(String strMatlUsage)
品目の用途を設定します。

パラメータ:
strMatlUsage - 品目の用途

setMatOrigin

public void setMatOrigin(String strMatOrigin)
品目の原産地を設定します。

パラメータ:
strMatOrigin - 品目の原産地

setInHouse

public void setInHouse(String strInHouse)
内部生産を設定します。

パラメータ:
strInHouse - 内部生産

setIndus3

public void setIndus3(String strIndus3)
品目 CFOP カテゴリを設定します。

パラメータ:
strIndus3 - 品目 CFOP カテゴリ

setInfIndex

public void setInfIndex(String strInfIndex)
インフレーション指数を設定します。

パラメータ:
strInfIndex - インフレーション指数

setUntilDate

public void setUntilDate(String strUntilDate)
インフレーション指数日付を設定します。

パラメータ:
strUntilDate - インフレーション指数日付

setDelivCompl

public void setDelivCompl(String strDelivCompl)
出荷完了 区分を設定します。

パラメータ:
strDelivCompl - 出荷完了 区分

setPartDeliv

public void setPartDeliv(String strPartDeliv)
明細レベルでの分割納入 (在庫転送)を設定します。

パラメータ:
strPartDeliv - 明細レベルでの分割納入 (在庫転送)

setShipBlocked

public void setShipBlocked(String strShipBlocked)
SD 出荷伝票の明細ブロックを設定します。

パラメータ:
strShipBlocked - SD 出荷伝票の明細ブロック

setPeriodIndExpirationDate

public void setPeriodIndExpirationDate(String strPeriodIndExpirationDate)
有効期間期限日の期間区分を設定します。

パラメータ:
strPeriodIndExpirationDate - 有効期間期限日の期間区分

setIntObjNo

public void setIntObjNo(String strIntObjNo)
選定 (内部オブジェクト番号)を設定します。

パラメータ:
strIntObjNo - 選定 (内部オブジェクト番号)

setBatch

public void setBatch(String strBatch)
ロット番号を設定します。

パラメータ:
strBatch - ロット番号

setVendrbatch

public void setVendrbatch(String strVendrbatch)
仕入先ロット番号を設定します。

パラメータ:
strVendrbatch - 仕入先ロット番号

setCalctype

public void setCalctype(String strCalctype)
価格設定タイプを設定します。

パラメータ:
strCalctype - 価格設定タイプ

setGrantNbr

public void setGrantNbr(String strGrantNbr)
補助金を設定します。

パラメータ:
strGrantNbr - 補助金

setCmmtItemLong

public void setCmmtItemLong(String strCmmtItemLong)
資金予算コードを設定します。

パラメータ:
strCmmtItemLong - 資金予算コード

setFuncAreaLong

public void setFuncAreaLong(String strFuncAreaLong)
機能領域を設定します。

パラメータ:
strFuncAreaLong - 機能領域

setSupplStloc

public void setSupplStloc(String strSupplStloc)
出庫保管場所: 在庫転送オーダーを設定します。

パラメータ:
strSupplStloc - 出庫保管場所: 在庫転送オーダー

setGlIndex

public void setGlIndex(int glIndex)
レコード番号を設定します｡

パラメータ:
glIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス PurchaseItem 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseItems (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseItems

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems
すべての実装インタフェース:
Serializable
public class PurchaseItems
extends PurchaseItem
implements Serializable

伝票の承認対象明細情報クラス
機能は以下の通り

  • 伝票の承認対象明細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseItems()
伝票の承認対象明細を作成します。
メソッドの概要
String | getAddress() 住所を取得します。
String | getAllocTbl() 商品配分表番号を取得します。
String | getAtItem() 割当テーブルの明細番号を取得します。
String | getDispQuan() 購買発注数量: 表示目的全納入日程合計を取得します。
String | getItemCatExt() 購買伝票の明細カテゴリを取得します。
String | getManufProf() 製造者製品プロファイルを取得します。
String | getManuMat() 製造者製品コードを取得します。
String | getMatGrp() 品目グループを取得します。
String | getMfrNo() 製造者番号を取得します。
String | getMfrNoExt() 外部製造者コード名または番号を取得します。
String | getPoNumber() 購買伝票番号を取得します。
String | getPrClosed() 購買依頼処理済を取得します。
String | getPromotion() プロモーションを取得します。
String | getPurMat() 品目コードを取得します。
String | getPurMatExternal() 項目 PURMAT の品目コード (長) (今後のリリースで開発)を取得します。
String | getPurMatGuid() 項目 PURMAT の外部 GUID (今後のリリースで開発)を取得します。
String | getPurMatVersion() 項目 PURMAT のバージョン番号 (今後のリリースで開発)を取得します。
String | getStoreLoc() 保管場所を取得します。
String | getUnit() 発注単位を取得します。
void | setAddress(String strAddress) 住所を設定します。
void | setAllocTbl(String strAllocTbl) 商品配分表番号を設定します。
void | setAtItem(String strAtItem) 割当テーブルの明細番号を設定します。
void | setDispQuan(String strDispQuan) 購買発注数量: 表示目的全納入日程合計を設定します。
void | setItemCatExt(String strItemCatExt) 購買伝票の明細カテゴリを設定します。
void | setManufProf(String strManufProf) 製造者製品プロファイルを設定します。
void | setManuMat(String strManuMat) 製造者製品コードを設定します。
void | setMatGrp(String strMatGrp) 品目グループを設定します。
void | setMfrNo(String strMfrNo) 製造者番号を設定します。
void | setMfrNoExt(String strMfrNoExt) 外部製造者コード名または番号を設定します。
void | setPoNumber(String strPoNumber) 購買伝票番号を設定します。
void | setPrClosed(String strPrClosed) 購買依頼処理済を設定します。
void | setPromotion(String strPromotion) プロモーションを設定します。
void | setPurMat(String strPurMat) 品目コードを設定します。
void | setPurMatExternal(String strPurMatExternal) 項目 PURMAT の品目コード (長) (今後のリリースで開発)を設定します。
void | setPurMatGuid(String strPurMatGuid) 項目 PURMAT の外部 GUID (今後のリリースで開発)を設定します。
void | setPurMatVersion(String strPurMatVersion) 項目 PURMAT のバージョン番号 (今後のリリースで開発)を設定します。
void | setStoreLoc(String strStoreLoc) 保管場所を設定します。
void | setUnit(String strUnit) 発注単位を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem から継承したメソッド
getAcctasscat, getAcknReqd, getAgmtItem, getAgreement, getAtRelev, getConvDen1, getConvNum1, getDeleteInd, getDistrib, getInfoRec, getItemCat, getKanbanInd, getMaterial, getMaterialExternal, getMaterialGuid, getMaterialVersion, getNetPrice, getNoMoreGr, getNoRounding, getOrderprUn, getOrderprUnIso, getPartInv, getPckgNo, getPlanDel, getPlant, getPoItem, getPoPrice, getPoUnitIso, getPreqName, getPriceUnit, getQualInsp, getRetItem, getShipping, getShortText, getTaxCode, getTrackingno, getValType, getVendMat, setAcctasscat, setAcknReqd, setAgmtItem, setAgreement, setAtRelev, setConvDen1, setConvNum1, setDeleteInd, setDistrib, setInfoRec, setItemCat, setKanbanInd, setMaterial, setMaterialExternal, setMaterialGuid, setMaterialVersion, setNetPrice, setNoMoreGr, setNoRounding, setOrderprUn, setOrderprUnIso, setPartInv, setPckgNo, setPlanDel, setPlant, setPoItem, setPoPrice, setPoUnitIso, setPreqName, setPriceUnit, setQualInsp, setRetItem, setShipping, setShortText, setTaxCode, setTrackingno, setValType, setVendMat
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseItems

public PurchaseItems()
伝票の承認対象明細を作成します。

メソッドの詳細

getPoNumber

public String getPoNumber()
購買伝票番号を取得します。

戻り値:
srtPoNumber

getAddress

public String getAddress()
住所を取得します。

戻り値:
srtAddress

getPurMat

public String getPurMat()
品目コードを取得します。

戻り値:
srtPurMat

getStoreLoc

public String getStoreLoc()
保管場所を取得します。

戻り値:
srtStoreLoc

getMatGrp

public String getMatGrp()
品目グループを取得します。

戻り値:
srtMatGrp

getAllocTbl

public String getAllocTbl()
商品配分表番号を取得します。

戻り値:
srtAllocTbl

getAtItem

public String getAtItem()
割当テーブルの明細番号を取得します。

戻り値:
srtAtItem

getUnit

public String getUnit()
発注単位を取得します。

戻り値:
srtUnit

getPromotion

public String getPromotion()
プロモーションを取得します。

戻り値:
srtPromotion

getManufProf

public String getManufProf()
製造者製品プロファイルを取得します。

戻り値:
srtManufProf

getManuMat

public String getManuMat()
製造者製品コードを取得します。

戻り値:
srtManuMat

getMfrNo

public String getMfrNo()
製造者番号を取得します。

戻り値:
srtMfrNo

getMfrNoExt

public String getMfrNoExt()
外部製造者コード名または番号を取得します。

戻り値:
srtMfrNoExt

getItemCatExt

public String getItemCatExt()
購買伝票の明細カテゴリを取得します。

戻り値:
srtItemCatExt

getDispQuan

public String getDispQuan()
購買発注数量: 表示目的全納入日程合計を取得します。

戻り値:
srtDispQuan

getPurMatExternal

public String getPurMatExternal()
項目 PURMAT の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
srtPurMatExternal

getPurMatGuid

public String getPurMatGuid()
項目 PURMAT の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
srtPurMatGuid

getPurMatVersion

public String getPurMatVersion()
項目 PURMAT のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
srtPurMatVersion

getPrClosed

public String getPrClosed()
購買依頼処理済を取得します。

戻り値:
srtPrClosed

setPoNumber

public void setPoNumber(String strPoNumber)
購買伝票番号を設定します。

パラメータ:
strPoNumber - 購買伝票番号

setAddress

public void setAddress(String strAddress)
住所を設定します。

パラメータ:
strAddress - 住所

setPurMat

public void setPurMat(String strPurMat)
品目コードを設定します。

パラメータ:
strPurMat - 品目コード

setStoreLoc

public void setStoreLoc(String strStoreLoc)
保管場所を設定します。

パラメータ:
strStoreLoc - 保管場所

setMatGrp

public void setMatGrp(String strMatGrp)
品目グループを設定します。

パラメータ:
strMatGrp - 品目グループ

setAllocTbl

public void setAllocTbl(String strAllocTbl)
商品配分表番号を設定します。

パラメータ:
strAllocTbl - 商品配分表番号

setAtItem

public void setAtItem(String strAtItem)
割当テーブルの明細番号を設定します。

パラメータ:
strAtItem - 割当テーブルの明細番号

setUnit

public void setUnit(String strUnit)
発注単位を設定します。

パラメータ:
strUnit - 発注単位

setPromotion

public void setPromotion(String strPromotion)
プロモーションを設定します。

パラメータ:
strPromotion - プロモーション

setManufProf

public void setManufProf(String strManufProf)
製造者製品プロファイルを設定します。

パラメータ:
strManufProf - 製造者製品プロファイル

setManuMat

public void setManuMat(String strManuMat)
製造者製品コードを設定します。

パラメータ:
strManuMat - 製造者製品コード

setMfrNo

public void setMfrNo(String strMfrNo)
製造者番号を設定します。

パラメータ:
strMfrNo - 製造者番号

setMfrNoExt

public void setMfrNoExt(String strMfrNoExt)
外部製造者コード名または番号を設定します。

パラメータ:
strMfrNoExt - 外部製造者コード名または番号

setItemCatExt

public void setItemCatExt(String strItemCatExt)
購買伝票の明細カテゴリを設定します。

パラメータ:
strItemCatExt - 購買伝票の明細カテゴリ

setDispQuan

public void setDispQuan(String strDispQuan)
購買発注数量: 表示目的全納入日程合計を設定します。

パラメータ:
strDispQuan - 購買発注数量: 表示目的全納入日程合計

setPurMatExternal

public void setPurMatExternal(String strPurMatExternal)
項目 PURMAT の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
strPurMatExternal - 項目 PURMAT の品目コード (長)

setPurMatGuid

public void setPurMatGuid(String strPurMatGuid)
項目 PURMAT の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
strPurMatGuid - 項目 PURMAT の外部 GUID

setPurMatVersion

public void setPurMatVersion(String strPurMatVersion)
項目 PURMAT のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
strPurMatVersion - 項目 PURMAT のバージョン番号

setPrClosed

public void setPrClosed(String strPrClosed)
購買依頼処理済を設定します。

パラメータ:
strPrClosed - 購買依頼処理済

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス PurchaseItem 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseOrderPayPost (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseOrderPayPost

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
PurchaseOrderPayPostController, PurchaseOrderPostChangeController
public class PurchaseOrderPayPost
extends UpdateController
implements Serializable

伝票登録クラス
機能は以下の通り

  • 伝票を登録します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
PurchaseOrderPayPost()
コンストラクタ。
PurchaseOrderPayPost(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。
PurchaseOrderPayPost(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
メソッドの概要
void | executeBapi(BapiController bapiController) 購買発注伝票の登録及び変更に共通で使用する項目に値をセットした後、 AbstractController#executeBapi()を実行します。
ArrayList | getAllVersionsList() 全バージョン一覧を取得します｡
ArrayList | getCondHeaderList() 条件ヘッダ一覧を取得します｡
ArrayList | getCondItemList() 条件明細一覧を取得します｡
ArrayList | getContractLimitsList() 外注基本契約制限一覧を取得します｡
ArrayList | getContractServiceAccountList() 外注サービス勘定設定一覧を取得します｡
ArrayList | getContractServiceList() 外注サービス一覧を取得します｡
ArrayList | getContractServiceTextList() 外注サービステキスト一覧を取得します｡
ArrayList | getDeliverryAddressList() 出荷伝票アドレス一覧を取得します｡
PurchaseHeaderPost | getDocumentHeader() 伝票ヘッダを取得します｡
ExportHeader | getExportHeader() 貿易管理ヘッダを取得します｡
ArrayList | getExportItemList() 貿易管理明細一覧を取得します｡
ArrayList | getExtensionList() 拡張得意先項目一覧を取得します｡
ArrayList | getHeaderTextList() ヘッダテキスト一覧を取得します｡
ArrayList | getItemTextList() 明細テキスト一覧を取得します｡
ArrayList | getLimitsList() 外注制限一覧を取得します｡
String | getMemoryComplete() エラーがない場合に購買発注を保留にする区分を取得します｡
String | getMemoryUnComplete() エラーがある場合に購買発注を保留にする区分を取得します｡
String | getNoAuthority() 権限チェックなし区分を取得します｡
String | getNoMessageReq() メッセージ不要区分を取得します｡
String | getNoMessaging() 出力決定なし区分を取得します｡
String | getNoPriceFromPo() 最終伝票からの価格転送なし区分を取得します｡
ArrayList | getPartnerList() 得意先一覧を取得します｡
String | getPoNumber() 購買伝票番号を取得します｡
ArrayList | getProfitSegmentList() 入出庫予定一覧を取得します｡
ArrayList | getPurchaseAccountList() 勘定設定一覧を取得します｡
ArrayList | getPurchaseItemPostList() 明細一覧を取得します｡
ArrayList | getPurchaseScheduleList() 納入日程一覧を取得します｡
VendorAddress | getSupplierInfo() 仕入先住所を取得します｡
String | getTestRun() テスト区分を取得します｡
Versions | getVersions() バージョン管理を取得します｡
void | setAllVersionsList(ArrayList allVersionsList) 全バージョン一覧を設定します｡
void | setCondHeaderList(ArrayList condHeaderList) 条件ヘッダ一覧を設定します｡
void | setCondItemList(ArrayList condItemList) 条件明細一覧を設定します｡
void | setContractLimitsList(ArrayList contractLimitsList) 外注基本契約制限一覧を設定します｡
void | setContractServiceAccountList(ArrayList contractServiceAccountList) 外注サービス勘定設定一覧を設定します｡
void | setContractServiceList(ArrayList contractServiceList) 外注サービス一覧を設定します｡
void | setContractServiceTextList(ArrayList contractServiceTextList) 外注サービステキスト一覧を設定します｡
void | setDeliveryAddressList(ArrayList deliveryAddressList) 入荷伝票アドレス一覧を設定します｡
void | setDocumentHeader(PurchaseHeaderPost documentHeader) 伝票ヘッダを設定します｡
void | setExportHeader(ExportHeader exportHeader) 貿易管理ヘッダを設定します｡
void | setExportItemList(ArrayList exportItemList) 貿易管理明細を設定します｡
void | setExportParam(BapiController bapiController) 伝票に登録された情報ををセットします。
void | setExtensionList(ArrayList extensionList) 拡張得意先項目を設定します｡
void | setHeaderTextList(ArrayList headerTextList) ヘッダテキスト一覧を設定します｡
void | setImportParam(BapiController bapiController) 伝票に登録する値ををセットします。
void | setItemTextList(ArrayList itemTextList) 明細テキスト一覧を設定します｡
void | setLimitsList(ArrayList limitsList) 外注制限一覧を設定します｡
void | setMemoryComplete(String memoryComplete) エラーがない場合に購買発注を保留する区分を設定します｡
void | setMemoryUnComplete(String memoryUnComplete) エラーがある場合に購買発注を保留する区分を設定します｡
void | setNoAuthority(String noAuthority) 権限チェックなし区分に購買発注を保留する区分を設定します｡
void | setNoMessage(String noMessaging) 出力決定なし区分に購買発注を保留する区分を設定します｡
void | setNoMessageReq(String noMessageReq) メッセージ不要区分を設定します｡
void | setNoPriceFromPo(String noPriceFromPo) 最終伝票からの価格転送なし区分を設定します｡
void | setPartnerList(ArrayList partnerList) 取引先一覧を設定します｡
void | setPoNumber(String poNumber) 購買伝票番号に値を設定します。
void | setProfitSegmentList(ArrayList profitSegmentList) 入出庫予定一覧を設定します｡
void | setPurchaseAccountList(ArrayList purchaseAccountList) 勘定設定一覧を設定します｡
void | setPurchaseItemPostList(ArrayList purchaseItemPostList) 明細一覧を設定します｡
void | setPurchaseScheduleList(ArrayList purchaseScheduleList) 納入日程一覧を設定します｡
void | setStrParam(String paramStr, String paramName, String value) 構造型の項目に値をセットします。
void | setSupplierInfo(VendorAddress supplierInfo) 仕入先住所を設定します｡
void | setTblParam(String paramTable, String paramName, String value, int index) テーブル型の項目に値をセットします。
void | setTestRun(String testRun) テスト区分を設定します｡
void | setVersions(Versions versions) バージョン管理ヘッダを設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseOrderPayPost

public PurchaseOrderPayPost()
コンストラクタ。

PurchaseOrderPayPost

public PurchaseOrderPayPost(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。

パラメータ:
conectionManager - コネクションマネージャー

PurchaseOrderPayPost

public PurchaseOrderPayPost(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi(BapiController bapiController)
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPBapiReturnErrMessageExistException
購買発注伝票の登録及び変更に共通で使用する項目に値をセットした後、 AbstractController#executeBapi()を実行します。

オーバーライド:
クラス AbstractController 内の executeBapi
パラメータ:
bapiController - BapiControllerインスタンス
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPBapiReturnErrMessageExistException - BAPI実行結果例外

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
伝票に登録された情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setPoNumber

public void setPoNumber(String poNumber)
購買伝票番号に値を設定します。

パラメータ:
poNumber - 購買伝票番号

setTestRun

public void setTestRun(String testRun)
テスト区分を設定します｡

パラメータ:
testRun - テスト区分

setMemoryUnComplete

public void setMemoryUnComplete(String memoryUnComplete)
エラーがある場合に購買発注を保留する区分を設定します｡

パラメータ:
memoryUnComplete - エラーがある場合に購買発注を保留する区分

setMemoryComplete

public void setMemoryComplete(String memoryComplete)
エラーがない場合に購買発注を保留する区分を設定します｡

パラメータ:
memoryComplete - エラーがない場合に購買発注を保留する区分

setNoMessage

public void setNoMessage(String noMessaging)
出力決定なし区分に購買発注を保留する区分を設定します｡

パラメータ:
noMessaging - 出力決定なし区分

setNoMessageReq

public void setNoMessageReq(String noMessageReq)
メッセージ不要区分を設定します｡

パラメータ:
noMessageReq - メッセージ不要区分

setNoAuthority

public void setNoAuthority(String noAuthority)
権限チェックなし区分に購買発注を保留する区分を設定します｡

パラメータ:
noAuthority - 権限チェックなし区分

setNoPriceFromPo

public void setNoPriceFromPo(String noPriceFromPo)
最終伝票からの価格転送なし区分を設定します｡

パラメータ:
noPriceFromPo - 最終伝票からの価格転送なし区分

setDocumentHeader

public void setDocumentHeader(PurchaseHeaderPost documentHeader)
伝票ヘッダを設定します｡

パラメータ:
documentHeader - 伝票ヘッダ

setSupplierInfo

public void setSupplierInfo(VendorAddress supplierInfo)
仕入先住所を設定します｡

パラメータ:
supplierInfo - 仕入先住所

setExportHeader

public void setExportHeader(ExportHeader exportHeader)
貿易管理ヘッダを設定します｡

パラメータ:
exportHeader - 貿易管理ヘッダ

setVersions

public void setVersions(Versions versions)
バージョン管理ヘッダを設定します｡

パラメータ:
versions - バージョン管理ヘッダ

setPurchaseItemPostList

public void setPurchaseItemPostList(ArrayList purchaseItemPostList)
明細一覧を設定します｡

パラメータ:
purchaseItemPostList - 明細一覧

setDeliveryAddressList

public void setDeliveryAddressList(ArrayList deliveryAddressList)
入荷伝票アドレス一覧を設定します｡

パラメータ:
deliveryAddressList - 入荷伝票アドレス一覧

setPurchaseScheduleList

public void setPurchaseScheduleList(ArrayList purchaseScheduleList)
納入日程一覧を設定します｡

パラメータ:
purchaseScheduleList - 納入日程一覧

setProfitSegmentList

public void setProfitSegmentList(ArrayList profitSegmentList)
入出庫予定一覧を設定します｡

パラメータ:
profitSegmentList - 入出庫予定一覧

setPurchaseAccountList

public void setPurchaseAccountList(ArrayList purchaseAccountList)
勘定設定一覧を設定します｡

パラメータ:
purchaseAccountList - 勘定設定一覧

setCondHeaderList

public void setCondHeaderList(ArrayList condHeaderList)
条件ヘッダ一覧を設定します｡

パラメータ:
condHeaderList - 条件ヘッダ一覧

setCondItemList

public void setCondItemList(ArrayList condItemList)
条件明細一覧を設定します｡

パラメータ:
condItemList - 条件明細一覧

setLimitsList

public void setLimitsList(ArrayList limitsList)
外注制限一覧を設定します｡

パラメータ:
limitsList - 外注制限一覧

setContractLimitsList

public void setContractLimitsList(ArrayList contractLimitsList)
外注基本契約制限一覧を設定します｡

パラメータ:
contractLimitsList - 外注基本契約制限一覧

setContractServiceList

public void setContractServiceList(ArrayList contractServiceList)
外注サービス一覧を設定します｡

パラメータ:
contractServiceList - 外注サービス一覧

setContractServiceAccountList

public void setContractServiceAccountList(ArrayList contractServiceAccountList)
外注サービス勘定設定一覧を設定します｡

パラメータ:
contractServiceAccountList - 外注サービス勘定設定一覧

setContractServiceTextList

public void setContractServiceTextList(ArrayList contractServiceTextList)
外注サービステキスト一覧を設定します｡

パラメータ:
contractServiceTextList - 外注サービステキスト一覧

setExtensionList

public void setExtensionList(ArrayList extensionList)
拡張得意先項目を設定します｡

パラメータ:
extensionList - 拡張得意先項目

setExportItemList

public void setExportItemList(ArrayList exportItemList)
貿易管理明細を設定します｡

パラメータ:
exportItemList - 貿易管理明細

setHeaderTextList

public void setHeaderTextList(ArrayList headerTextList)
ヘッダテキスト一覧を設定します｡

パラメータ:
headerTextList - ヘッダテキスト一覧

setItemTextList

public void setItemTextList(ArrayList itemTextList)
明細テキスト一覧を設定します｡

パラメータ:
itemTextList - 明細テキスト一覧

setPartnerList

public void setPartnerList(ArrayList partnerList)
取引先一覧を設定します｡

パラメータ:
partnerList - 取引先一覧

setAllVersionsList

public void setAllVersionsList(ArrayList allVersionsList)
全バージョン一覧を設定します｡

パラメータ:
allVersionsList - 全バージョン一覧

getPoNumber

public String getPoNumber()
購買伝票番号を取得します｡

戻り値:
poNumber 購買伝票番号

getTestRun

public String getTestRun()
テスト区分を取得します｡

戻り値:
testRun テスト区分

getMemoryUnComplete

public String getMemoryUnComplete()
エラーがある場合に購買発注を保留にする区分を取得します｡

戻り値:
memoryUnComplete エラーがある場合に購買発注を保留にする区分

getMemoryComplete

public String getMemoryComplete()
エラーがない場合に購買発注を保留にする区分を取得します｡

戻り値:
memoryComplete エラーがない場合に購買発注を保留にする区分

getNoMessageReq

public String getNoMessageReq()
メッセージ不要区分を取得します｡

戻り値:
noMessageReq メッセージ不要区分

getNoAuthority

public String getNoAuthority()
権限チェックなし区分を取得します｡

戻り値:
noAuthority 権限チェックなし区分

getNoMessaging

public String getNoMessaging()
出力決定なし区分を取得します｡

戻り値:
noMessaging 出力決定なし区分

getNoPriceFromPo

public String getNoPriceFromPo()
最終伝票からの価格転送なし区分を取得します｡

戻り値:
noPriceFromPo 最終伝票からの価格転送なし区分

getDocumentHeader

public PurchaseHeaderPost getDocumentHeader()
伝票ヘッダを取得します｡

戻り値:
documentHeader 伝票ヘッダ

getSupplierInfo

public VendorAddress getSupplierInfo()
仕入先住所を取得します｡

戻り値:
VendorAddress 仕入先住所

getExportHeader

public ExportHeader getExportHeader()
貿易管理ヘッダを取得します｡

戻り値:
exportHeader 貿易管理ヘッダ

getVersions

public Versions getVersions()
バージョン管理を取得します｡

戻り値:
versions バージョン管理

getPurchaseItemPostList

public ArrayList getPurchaseItemPostList()
明細一覧を取得します｡

戻り値:
purchaseItemPostList 明細一覧

getDeliverryAddressList

public ArrayList getDeliverryAddressList()
出荷伝票アドレス一覧を取得します｡

戻り値:
deliveryAddressList 出荷伝票アドレス一覧

getPurchaseScheduleList

public ArrayList getPurchaseScheduleList()
納入日程一覧を取得します｡

戻り値:
purchaseScheduleList 納入日程一覧

getPurchaseAccountList

public ArrayList getPurchaseAccountList()
勘定設定一覧を取得します｡

戻り値:
purchaseAccountList 勘定設定一覧

getProfitSegmentList

public ArrayList getProfitSegmentList()
入出庫予定一覧を取得します｡

戻り値:
profitSegmentList 入出庫予定一覧

getCondHeaderList

public ArrayList getCondHeaderList()
条件ヘッダ一覧を取得します｡

戻り値:
condHeaderList 条件ヘッダ一覧

getCondItemList

public ArrayList getCondItemList()
条件明細一覧を取得します｡

戻り値:
condItemList 条件明細一覧

getLimitsList

public ArrayList getLimitsList()
外注制限一覧を取得します｡

戻り値:
limitsList 外注制限一覧

getContractLimitsList

public ArrayList getContractLimitsList()
外注基本契約制限一覧を取得します｡

戻り値:
contractLimitsList 外注基本契約制限一覧

getContractServiceList

public ArrayList getContractServiceList()
外注サービス一覧を取得します｡

戻り値:
contractServiceList 外注サービス一覧

getContractServiceAccountList

public ArrayList getContractServiceAccountList()
外注サービス勘定設定一覧を取得します｡

戻り値:
contractServiceAccountList 外注サービス勘定設定一覧

getContractServiceTextList

public ArrayList getContractServiceTextList()
外注サービステキスト一覧を取得します｡

戻り値:
contractServiceTextList 外注サービステキスト一覧

getExtensionList

public ArrayList getExtensionList()
拡張得意先項目一覧を取得します｡

戻り値:
extensionList 拡張得意先項目一覧

getExportItemList

public ArrayList getExportItemList()
貿易管理明細一覧を取得します｡

戻り値:
exportItemList 貿易管理明細一覧

getHeaderTextList

public ArrayList getHeaderTextList()
ヘッダテキスト一覧を取得します｡

戻り値:
headerTextList ヘッダテキスト一覧

getItemTextList

public ArrayList getItemTextList()
                          throws SAPPurchaseSystemException
明細テキスト一覧を取得します｡

戻り値:
itemTextList 明細テキスト一覧
例外:
SAPPurchaseSystemException - 購買発注業務システム例外

getPartnerList

public ArrayList getPartnerList()
得意先一覧を取得します｡

戻り値:
partnerList 得意先一覧

getAllVersionsList

public ArrayList getAllVersionsList()
全バージョン一覧を取得します｡

戻り値:
allVersionsList 全バージョン一覧

setStrParam

public void setStrParam(String paramStr,
                        String paramName,
                        String value)
                 throws SAPPurchaseSystemException
構造型の項目に値をセットします。

パラメータ:
paramStr - 構造名
paramName - 項目名
value - セットする値
例外:
SAPPurchaseSystemException - 購買発注業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPPurchaseSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPPurchaseSystemException - 購買発注業務システム例外

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseOrderPayPostController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseOrderPayPostController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController
すべての実装インタフェース:
Serializable
public class PurchaseOrderPayPostController
extends PurchaseOrderPayPost
implements Serializable

伝票登録コントローラクラス
機能は以下の通り

  • 伝票を登録します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
PurchaseOrderPayPostController()
PurchaseOrderPayPostControllerのコンストラクタを生成します。
PurchaseOrderPayPostController(ConnectionManager connectionManager)
PurchaseOrderPayPostControllerのコンストラクタを生成します。
PurchaseOrderPayPostController(SapClient sapClient)
PurchaseOrderPayPostControllerのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を登録します。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost から継承したメソッド
executeBapi, getAllVersionsList, getCondHeaderList, getCondItemList, getContractLimitsList, getContractServiceAccountList, getContractServiceList, getContractServiceTextList, getDeliverryAddressList, getDocumentHeader, getExportHeader, getExportItemList, getExtensionList, getHeaderTextList, getItemTextList, getLimitsList, getMemoryComplete, getMemoryUnComplete, getNoAuthority, getNoMessageReq, getNoMessaging, getNoPriceFromPo, getPartnerList, getPoNumber, getProfitSegmentList, getPurchaseAccountList, getPurchaseItemPostList, getPurchaseScheduleList, getSupplierInfo, getTestRun, getVersions, setAllVersionsList, setCondHeaderList, setCondItemList, setContractLimitsList, setContractServiceAccountList, setContractServiceList, setContractServiceTextList, setDeliveryAddressList, setDocumentHeader, setExportHeader, setExportItemList, setExportParam, setExtensionList, setHeaderTextList, setImportParam, setItemTextList, setLimitsList, setMemoryComplete, setMemoryUnComplete, setNoAuthority, setNoMessage, setNoMessageReq, setNoPriceFromPo, setPartnerList, setPoNumber, setProfitSegmentList, setPurchaseAccountList, setPurchaseItemPostList, setPurchaseScheduleList, setStrParam, setSupplierInfo, setTblParam, setTestRun, setVersions, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseOrderPayPostController

public PurchaseOrderPayPostController()
PurchaseOrderPayPostControllerのコンストラクタを生成します。

PurchaseOrderPayPostController

public PurchaseOrderPayPostController(ConnectionManager connectionManager)
PurchaseOrderPayPostControllerのコンストラクタを生成します。

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

パラメータ:
connectionManager - コネクションマネージャー

PurchaseOrderPayPostController

public PurchaseOrderPayPostController(SapClient sapClient)
PurchaseOrderPayPostControllerのコンストラクタを生成します。

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバへデータを登録することが可能です。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を登録します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseOrderPostChangeController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseOrderPostChangeController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController
すべての実装インタフェース:
Serializable
public class PurchaseOrderPostChangeController
extends PurchaseOrderPayPost
implements Serializable

伝票登録変更コントローラクラス
機能は以下の通り

  • 伝票を変更します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
PurchaseOrderPostChangeController()
PurchaseOrderPostChangeControllerのコンストラクタを生成します。
PurchaseOrderPostChangeController(ConnectionManager connectionManager)
PurchaseOrderPostChangeControllerのコンストラクタを生成します。
PurchaseOrderPostChangeController(SapClient sapClient)
PurchaseOrderPostChangeControllerのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を変更します。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost から継承したメソッド
executeBapi, getAllVersionsList, getCondHeaderList, getCondItemList, getContractLimitsList, getContractServiceAccountList, getContractServiceList, getContractServiceTextList, getDeliverryAddressList, getDocumentHeader, getExportHeader, getExportItemList, getExtensionList, getHeaderTextList, getItemTextList, getLimitsList, getMemoryComplete, getMemoryUnComplete, getNoAuthority, getNoMessageReq, getNoMessaging, getNoPriceFromPo, getPartnerList, getPoNumber, getProfitSegmentList, getPurchaseAccountList, getPurchaseItemPostList, getPurchaseScheduleList, getSupplierInfo, getTestRun, getVersions, setAllVersionsList, setCondHeaderList, setCondItemList, setContractLimitsList, setContractServiceAccountList, setContractServiceList, setContractServiceTextList, setDeliveryAddressList, setDocumentHeader, setExportHeader, setExportItemList, setExportParam, setExtensionList, setHeaderTextList, setImportParam, setItemTextList, setLimitsList, setMemoryComplete, setMemoryUnComplete, setNoAuthority, setNoMessage, setNoMessageReq, setNoPriceFromPo, setPartnerList, setPoNumber, setProfitSegmentList, setPurchaseAccountList, setPurchaseItemPostList, setPurchaseScheduleList, setStrParam, setSupplierInfo, setTblParam, setTestRun, setVersions, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseOrderPostChangeController

public PurchaseOrderPostChangeController()
PurchaseOrderPostChangeControllerのコンストラクタを生成します。

PurchaseOrderPostChangeController

public PurchaseOrderPostChangeController(ConnectionManager connectionManager)
PurchaseOrderPostChangeControllerのコンストラクタを生成します。

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の更新処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

パラメータ:
connectionManager - コネクションマネージャー

PurchaseOrderPostChangeController

public PurchaseOrderPostChangeController(SapClient sapClient)
PurchaseOrderPostChangeControllerのコンストラクタを生成します。

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバへデータを登録することが可能です。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を変更します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseRelease (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseRelease

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
PurchaseReleaseController, PurchaseResetReleaseController
public class PurchaseRelease
extends UpdateController
implements Serializable

承認情報スーパークラス
機能は以下の通り

  • 承認情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
PurchaseRelease()
伝票承認を作成します。
PurchaseRelease(String purchaseorder, String poRelCode, String useExceptions)
コンストラクタ生成。
PurchaseRelease(String purchaseorder, String poRelCode, String useExceptions, ConnectionManager connectionManager)
コンストラクタ生成。
PurchaseRelease(String purchaseorder, String poRelCode, String useExceptions, SapClient sapClient)
コンストラクタ生成。
メソッドの概要
void | executeBapi(BapiController bapiController) 伝票承認取消処理を実行します。
String | getPoRelCode() 承認コードを取得します。
String | getPurchaseorder() 購買発注番号を取得します。
String | getRelIndicatorNew() 返却規承認区分を取得します。
String | getRelStatusNew() 返却承認状況を取得します。
String | getUseExceptions() 例外メッセージ設定とエラーメッセージ出力を取得します。
void | setExportParam(BapiController bapiController) 実行結果を取得します。
void | setPoRelCode(String strPoRelCode) 承認コードを設定します。
void | setPurchaseorder(String strPurchaseorder) 購買発注番号を設定します。
void | setRelIndicatorNew(String strRelIndicatorNew) 返却承認区分を設定します。
void | setRelStatusNew(String strRelStatusNew) 返却承認状況を設定します。
void | setUseExceptions(String strUseExceptions) 例外メッセージ設定とエラーメッセージ出力を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseRelease

public PurchaseRelease()
伝票承認を作成します。

PurchaseRelease

public PurchaseRelease(String purchaseorder,
                       String poRelCode,
                       String useExceptions)
コンストラクタ生成。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ出力区分

PurchaseRelease

public PurchaseRelease(String purchaseorder,
                       String poRelCode,
                       String useExceptions,
                       ConnectionManager connectionManager)
コンストラクタ生成。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ出力区分
connectionManager - コネクションマネージャー

PurchaseRelease

public PurchaseRelease(String purchaseorder,
                       String poRelCode,
                       String useExceptions,
                       SapClient sapClient)
コンストラクタ生成。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ出力区分
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi(BapiController bapiController)
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPBapiReturnErrMessageExistException
伝票承認取消処理を実行します。

オーバーライド:
クラス AbstractController 内の executeBapi
パラメータ:
bapiController - BapiControllerインスタンス
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPBapiReturnErrMessageExistException - BAPI実行結果例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
実行結果を取得します。

パラメータ:
bapiController - BAPIコントローラー
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

getPurchaseorder

public String getPurchaseorder()
購買発注番号を取得します。

戻り値:
srtPurchaseorder

getPoRelCode

public String getPoRelCode()
承認コードを取得します。

戻り値:
srtPoRelCode

getUseExceptions

public String getUseExceptions()
例外メッセージ設定とエラーメッセージ出力を取得します。

戻り値:
srtUseExceptions

getRelStatusNew

public String getRelStatusNew()
返却承認状況を取得します。

戻り値:
srtRelStatusNew

getRelIndicatorNew

public String getRelIndicatorNew()
返却規承認区分を取得します。

戻り値:
srtRelIndicatorNew

setPurchaseorder

public void setPurchaseorder(String strPurchaseorder)
購買発注番号を設定します。

パラメータ:
strPurchaseorder - 購買発注番号

setPoRelCode

public void setPoRelCode(String strPoRelCode)
承認コードを設定します。

パラメータ:
strPoRelCode - 承認コード

setUseExceptions

public void setUseExceptions(String strUseExceptions)
例外メッセージ設定とエラーメッセージ出力を設定します。

パラメータ:
strUseExceptions - 例外メッセージ設定とエラーメッセージ出力

setRelStatusNew

public void setRelStatusNew(String strRelStatusNew)
返却承認状況を設定します。

パラメータ:
strRelStatusNew - 返却承認状況

setRelIndicatorNew

public void setRelIndicatorNew(String strRelIndicatorNew)
返却承認区分を設定します。

パラメータ:
strRelIndicatorNew - 返却規承認区分

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseReleaseController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseReleaseController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController
すべての実装インタフェース:
Serializable
public class PurchaseReleaseController
extends PurchaseRelease
implements Serializable

伝票承認コントローラクラス
機能は以下の通り

  • 伝票を承認します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
PurchaseReleaseController(String purchaseorder, String poRelCode, String useExceptions)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
PurchaseReleaseController(String purchaseorder, String poRelCode, String useExceptions, ConnectionManager connectionManager)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
PurchaseReleaseController(String purchaseorder, String poRelCode, String useExceptions, SapClient sapClient)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
メソッドの概要
void | executeBapi() 伝票承認処理を実行します。
String | getRetCode() リターン値、ABAP 命令後のリターン値を取得します。
void | setRetCode(String strRetCode) リターン値、ABAP 命令後のリターン値を設定します。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease から継承したメソッド
executeBapi, getPoRelCode, getPurchaseorder, getRelIndicatorNew, getRelStatusNew, getUseExceptions, setExportParam, setPoRelCode, setPurchaseorder, setRelIndicatorNew, setRelStatusNew, setUseExceptions, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseReleaseController

public PurchaseReleaseController(String purchaseorder,
                                 String poRelCode,
                                 String useExceptions)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ設定とエラーメッセージ出力

PurchaseReleaseController

public PurchaseReleaseController(String purchaseorder,
                                 String poRelCode,
                                 String useExceptions,
                                 ConnectionManager connectionManager)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の更新処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

【注意】このAPIが使用する標準のBAPI(BAPI_PO_RELEASE)では、BAPI実行時にコミット処理が実行されます。 つまり、executeBapi()実行後にここまでのコネクションマネージャーで実行したすべての処理がコミットされます。
※ただし、コネクションはリリースされませんので、リリースされるようにConnectionManager.commit()または ConnectionManager.rollback()を実行してください。
この振る舞いを変更するには、BAPI自体をカスタマイズする必要があります。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ設定とエラーメッセージ出力
connectionManager - コネクションマネージャー

PurchaseReleaseController

public PurchaseReleaseController(String purchaseorder,
                                 String poRelCode,
                                 String useExceptions,
                                 SapClient sapClient)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバへデータを登録することが可能です。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ設定とエラーメッセージ出力
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
伝票承認処理を実行します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

getRetCode

public String getRetCode()
                  throws SAPPurchaseSystemException
リターン値、ABAP 命令後のリターン値を取得します。

戻り値:
srtRetCode
例外:
SAPPurchaseSystemException - 購買発注業務システム例外

setRetCode

public void setRetCode(String strRetCode)
リターン値、ABAP 命令後のリターン値を設定します。

パラメータ:
strRetCode - リターン値、ABAP 命令後のリターン値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseResetReleaseController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseResetReleaseController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController
すべての実装インタフェース:
Serializable
public class PurchaseResetReleaseController
extends PurchaseRelease
implements Serializable

伝票承認取消コントローラクラス
機能は以下の通り

  • 伝票の承認取消します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
PurchaseResetReleaseController(String purchaseorder, String poRelCode, String useExceptions)
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。
PurchaseResetReleaseController(String purchaseorder, String poRelCode, String useExceptions, ConnectionManager connectionManager)
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。
PurchaseResetReleaseController(String purchaseorder, String poRelCode, String useExceptions, SapClient sapClient)
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。
メソッドの概要
 void executeBapi()
伝票承認取消処理を実行します。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease から継承したメソッド
executeBapi, getPoRelCode, getPurchaseorder, getRelIndicatorNew, getRelStatusNew, getUseExceptions, setExportParam, setPoRelCode, setPurchaseorder, setRelIndicatorNew, setRelStatusNew, setUseExceptions, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseResetReleaseController

public PurchaseResetReleaseController(String purchaseorder,
                                      String poRelCode,
                                      String useExceptions)
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。

【重要】標準BAPIでは、BAPI内部でコミット処理が実行されます。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ設定とエラーメッセージ出力

PurchaseResetReleaseController

public PurchaseResetReleaseController(String purchaseorder,
                                      String poRelCode,
                                      String useExceptions,
                                      ConnectionManager connectionManager)
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。

ConnectionManagerを使用することで、ConnectionManagerから トランザクションを制御でき、 たとえば同一トランザクション内で複数の更新処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

【注意】このAPIが使用する標準のBAPI(BAPI_PO_RESET_RELEASE)では、BAPI実行時にコミット処理が実行されます。 つまり、executeBapi()実行後にここまでのコネクションマネージャーで実行したすべての処理がコミットされます。
※ただし、コネクションはリリースされませんので、リリースされるようにConnectionManager.commit()または ConnectionManager.rollback()を実行してください。
この振る舞いを変更するには、BAPI自体をカスタマイズする必要があります。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ設定とエラーメッセージ出力
connectionManager - コネクションマネージャー

PurchaseResetReleaseController

public PurchaseResetReleaseController(String purchaseorder,
                                      String poRelCode,
                                      String useExceptions,
                                      SapClient sapClient)
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。

ConnectionManagerを使用することで、ConnectionManagerから トランザクションを制御でき、 たとえば同一トランザクション内で複数の更新処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

【注意】このAPIが使用する標準のBAPI(BAPI_PO_RESET_RELEASE)では、BAPI実行時にコミット処理が実行されます。 つまり、executeBapi()実行後にここまでのコネクションマネージャーで実行したすべての処理がコミットされます。
※ただし、コネクションはリリースされませんので、リリースされるようにConnectionManager.commit()または ConnectionManager.rollback()を実行してください。
この振る舞いを変更するには、BAPI自体をカスタマイズする必要があります。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ設定とエラーメッセージ出力
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
伝票承認取消処理を実行します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseSchedule (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseSchedule

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule
すべての実装インタフェース:
Serializable
public class PurchaseSchedule
extends Object
implements Serializable

購買発注伝票納入日程情報クラス
機能は以下の通り

  • 購買発注伝票納入日程情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseSchedule()
購買発注伝票納入日程を作成します。
PurchaseSchedule(int index)
購買発注伝票納入日程を作成します。
メソッドの概要
String | getDelDatcatExt() 納入期日カテゴリを取得します。
String | getDeleteInd() 購買伝票の削除フラグを取得します。
String | getDeliveryDate() 納入期日を取得します。
String | getDelivTime() 納入期日における指定時間を取得します。
String | getGiDate() 出庫日付を取得します。
String | getGiTime() 出庫時刻 (現地時間 - プラント参照)を取得します。
String | getLoadDate() 積載日付を取得します。
String | getLoadTime() 積載時刻 (現地時間: 出荷ポイント)を取得します。
String | getMsDate() 品目利用可能日を取得します。
String | getMsTime() 品目供給ステージ (現地時刻: プラント参照)を取得します。
String | getPoDate() 納入日程の購買発注日付を取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
String | getPreqItem() 購買依頼の明細番号を取得します。
String | getPreqNo() 購買依頼番号を取得します。
String | getQuantity() 計画数量を取得します。
String | getRoutesched() 輸送経路計画を取得します。
String | getSchedLine() 納入日程行を取得します。
int | getScIndex() レコード番号を取得します｡
String | getStatDate() 統計的納入期日を取得します。
String | getTpDate() 輸送計画日付を取得します。
String | getTpTime() 輸送計画 - 時間 (現地時間/出荷ポイント参照)を取得します。
void | setDelDatcatExt(String strDelDatcatExt) 納入期日カテゴリを設定します。
void | setDeleteInd(String strDeleteInd) 購買伝票の削除フラグを設定します。
void | setDeliveryDate(String strDeliveryDate) 納入期日を設定します。
void | setDelivTime(String strDelivTime) 納入期日における指定時間を設定します。
void | setGiDate(String strGiDate) 出庫日付を設定します。
void | setGiTime(String strGiTime) 出庫時刻 (現地時間 - プラント参照)を設定します。
void | setLoadDate(String strLoadDate) 積載日付を設定します。
void | setLoadTime(String strLoadTime) 積載時刻 (現地時間: 出荷ポイント)を設定します。
void | setMsDate(String strMsDate) 品目利用可能日を設定します。
void | setMsTime(String strMsTime) 品目供給ステージ (現地時刻: プラント参照)を設定します。
void | setPoDate(String strPoDate) 納入日程の購買発注日付を設定します。
void | setPoItem(String strPoItem) 購買伝票の明細番号を設定します。
void | setPreqItem(String strPreqItem) 購買依頼の明細番号を設定します。
void | setPreqNo(String strPreqNo) 購買依頼番号を設定します。
void | setQuantity(String strQuantity) 計画数量を設定します。
void | setRoutesched(String strRoutesched) 輸送経路計画を設定します。
void | setSchedLine(String strSchedLine) 納入日程行を設定します。
void | setScIndex(int scIndex) レコード番号を設定します｡
void | setStatDate(String strStatDate) 統計的納入期日を設定します。
void | setTpDate(String strTpDate) 輸送計画日付を設定します。
void | setTpTime(String strTpTime) 輸送計画 - 時間 (現地時間/出荷ポイント参照)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseSchedule

public PurchaseSchedule()
購買発注伝票納入日程を作成します。

PurchaseSchedule

public PurchaseSchedule(int index)
購買発注伝票納入日程を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
srtPoItem 購買伝票の明細番号

getSchedLine

public String getSchedLine()
納入日程行を取得します。

戻り値:
srtSchedLine 納入日程行

getDelDatcatExt

public String getDelDatcatExt()
納入期日カテゴリを取得します。

戻り値:
srtDelDatcatExt 納入期日カテゴリ

getDeliveryDate

public String getDeliveryDate()
納入期日を取得します。

戻り値:
srtDeliveryDate 納入期日

getQuantity

public String getQuantity()
計画数量を取得します。

戻り値:
srtQuantity 計画数量

getDelivTime

public String getDelivTime()
納入期日における指定時間を取得します。

戻り値:
srtDelivTime 納入期日における指定時間

getStatDate

public String getStatDate()
統計的納入期日を取得します。

戻り値:
srtStatDate 統計的納入期日

getPreqNo

public String getPreqNo()
購買依頼番号を取得します。

戻り値:
srtPreqNo 購買依頼番号

getPreqItem

public String getPreqItem()
購買依頼の明細番号を取得します。

戻り値:
srtPreqItem 購買依頼の明細番号

getPoDate

public String getPoDate()
納入日程の購買発注日付を取得します。

戻り値:
srtPoDate 納入日程の購買発注日付

getRoutesched

public String getRoutesched()
輸送経路計画を取得します。

戻り値:
srtRoutesched 輸送経路計画

getMsDate

public String getMsDate()
品目利用可能日を取得します。

戻り値:
srtMsDate 品目利用可能日

getMsTime

public String getMsTime()
品目供給ステージ (現地時刻: プラント参照)を取得します。

戻り値:
srtMsTime 品目供給ステージ (現地時刻: プラント参照)

getLoadDate

public String getLoadDate()
積載日付を取得します。

戻り値:
srtLoadDate 積載日付

getLoadTime

public String getLoadTime()
積載時刻 (現地時間: 出荷ポイント)を取得します。

戻り値:
srtLoadTime 積載時刻 (現地時間: 出荷ポイント)

getTpDate

public String getTpDate()
輸送計画日付を取得します。

戻り値:
srtTpDate 輸送計画日付

getTpTime

public String getTpTime()
輸送計画 - 時間 (現地時間/出荷ポイント参照)を取得します。

戻り値:
srtTpTime 輸送計画 - 時間 (現地時間/出荷ポイント参照)

getGiDate

public String getGiDate()
出庫日付を取得します。

戻り値:
srtGiDate 出庫日付

getGiTime

public String getGiTime()
出庫時刻 (現地時間 - プラント参照)を取得します。

戻り値:
srtGiTime 出庫時刻 (現地時間 - プラント参照)

getDeleteInd

public String getDeleteInd()
購買伝票の削除フラグを取得します。

戻り値:
srtDeleteInd 購買伝票の削除フラグ

getScIndex

public int getScIndex()
レコード番号を取得します｡

戻り値:
scIndex レコード番号

setPoItem

public void setPoItem(String strPoItem)
購買伝票の明細番号を設定します。

パラメータ:
strPoItem - 購買伝票の明細番号

setSchedLine

public void setSchedLine(String strSchedLine)
納入日程行を設定します。

パラメータ:
strSchedLine - 納入日程行

setDelDatcatExt

public void setDelDatcatExt(String strDelDatcatExt)
納入期日カテゴリを設定します。

パラメータ:
strDelDatcatExt - 納入期日カテゴリ

setDeliveryDate

public void setDeliveryDate(String strDeliveryDate)
納入期日を設定します。

パラメータ:
strDeliveryDate - 納入期日

setQuantity

public void setQuantity(String strQuantity)
計画数量を設定します。

パラメータ:
strQuantity - 計画数量

setDelivTime

public void setDelivTime(String strDelivTime)
納入期日における指定時間を設定します。

パラメータ:
strDelivTime - 納入期日における指定時間

setStatDate

public void setStatDate(String strStatDate)
統計的納入期日を設定します。

パラメータ:
strStatDate - 統計的納入期日

setPreqNo

public void setPreqNo(String strPreqNo)
購買依頼番号を設定します。

パラメータ:
strPreqNo - 購買依頼番号

setPreqItem

public void setPreqItem(String strPreqItem)
購買依頼の明細番号を設定します。

パラメータ:
strPreqItem - 購買依頼の明細番号

setPoDate

public void setPoDate(String strPoDate)
納入日程の購買発注日付を設定します。

パラメータ:
strPoDate - 納入日程の購買発注日付

setRoutesched

public void setRoutesched(String strRoutesched)
輸送経路計画を設定します。

パラメータ:
strRoutesched - 輸送経路計画

setMsDate

public void setMsDate(String strMsDate)
品目利用可能日を設定します。

パラメータ:
strMsDate - 品目利用可能日

setMsTime

public void setMsTime(String strMsTime)
品目供給ステージ (現地時刻: プラント参照)を設定します。

パラメータ:
strMsTime - 品目供給ステージ (現地時刻: プラント参照)

setLoadDate

public void setLoadDate(String strLoadDate)
積載日付を設定します。

パラメータ:
strLoadDate - 積載日付

setLoadTime

public void setLoadTime(String strLoadTime)
積載時刻 (現地時間: 出荷ポイント)を設定します。

パラメータ:
strLoadTime - 積載時刻 (現地時間: 出荷ポイント)

setTpDate

public void setTpDate(String strTpDate)
輸送計画日付を設定します。

パラメータ:
strTpDate - 輸送計画日付

setTpTime

public void setTpTime(String strTpTime)
輸送計画 - 時間 (現地時間/出荷ポイント参照)を設定します。

パラメータ:
strTpTime - 輸送計画 - 時間 (現地時間/出荷ポイント参照)

setGiDate

public void setGiDate(String strGiDate)
出庫日付を設定します。

パラメータ:
strGiDate - 出庫日付

setGiTime

public void setGiTime(String strGiTime)
出庫時刻 (現地時間 - プラント参照)を設定します。

パラメータ:
strGiTime - 出庫時刻 (現地時間 - プラント参照)

setDeleteInd

public void setDeleteInd(String strDeleteInd)
購買伝票の削除フラグを設定します。

パラメータ:
strDeleteInd - 購買伝票の削除フラグ

setScIndex

public void setScIndex(int scIndex)
レコード番号を設定します｡

パラメータ:
scIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseText (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ContractServiceText
public class PurchaseText
extends Object
implements Serializable

購買発注伝票テキストクラス
機能は以下の通り

  • 購買発注伝テキストを保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseText()
購買発注伝票テキストを作成します。
PurchaseText(int index)
購買発注伝票テキストを作成します。
メソッドの概要
String | getPoItem() 購買伝票の明細番号を取得します。
String | getPoNumber() 購買伝票番号を取得します。
int | getTeIndex() レコード番号を取得します｡
String | getTextForm() タグ列を取得します。
String | getTextId() テキスト IDを取得します。
String | getTextLine() テキスト行を取得します。
void | setPoItem(String strPoItem) 購買伝票の明細番号を設定します。
void | setPoNumber(String strPoNumber) 購買伝票番号を設定します。
void | setTeIndex(int teIndex) レコード番号を設定します｡
void | setTextForm(String strTextForm) タグ列を設定します。
void | setTextId(String strTextId) テキスト IDを設定します。
void | setTextLine(String strTextLine) テキスト行を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseText

public PurchaseText()
購買発注伝票テキストを作成します。

PurchaseText

public PurchaseText(int index)
購買発注伝票テキストを作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPoNumber

public String getPoNumber()
購買伝票番号を取得します。

戻り値:
srtPoNumber 購買伝票番号

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
srtPoItem 購買伝票の明細番号

getTextId

public String getTextId()
テキスト IDを取得します。

戻り値:
srtTextId テキスト ID

getTextForm

public String getTextForm()
タグ列を取得します。

戻り値:
srtTextForm タグ列

getTextLine

public String getTextLine()
テキスト行を取得します。

戻り値:
srtTextLine テキスト行

getTeIndex

public int getTeIndex()
レコード番号を取得します｡

戻り値:
teIndex レコード番号

setPoNumber

public void setPoNumber(String strPoNumber)
購買伝票番号を設定します。

パラメータ:
strPoNumber - 購買伝票番号

setPoItem

public void setPoItem(String strPoItem)
購買伝票の明細番号を設定します。

パラメータ:
strPoItem - 購買伝票の明細番号

setTextId

public void setTextId(String strTextId)
テキスト IDを設定します。

パラメータ:
strTextId - テキスト ID

setTextForm

public void setTextForm(String strTextForm)
タグ列を設定します。

パラメータ:
strTextForm - タグ列

setTextLine

public void setTextLine(String strTextLine)
テキスト行を設定します。

パラメータ:
strTextLine - テキスト行

setTeIndex

public void setTeIndex(int teIndex)
レコード番号を設定します｡

パラメータ:
teIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SalesOrganisationSelection (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス SalesOrganisationSelection

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Selection
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection
すべての実装インタフェース:
Serializable
public class SalesOrganisationSelection
extends Selection
implements Serializable

販売組織の選択オプションクラス
機能は以下の通り

  • 販売組織の選択オプションの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
SalesOrganisationSelection()
販売組織の選択オプション情報を作成します。
SalesOrganisationSelection(int index)
販売組織の選択オプション情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します。
String | getSalesorgHigh() 販売組織の範囲終了を取得します。
String | getSalesorgLow() 販売組織の範囲開始を取得します。
void | setIndex(int index) レコード番号を設定します。
void | setSalesorgHigh(String strSalesorgHigh) 販売組織の範囲終了を設定します。
void | setSalesorgLow(String strSalesorgLow) 販売組織の範囲開始を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.Selection から継承したメソッド
getOption, getSign, setOption, setSign
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesOrganisationSelection

public SalesOrganisationSelection()
販売組織の選択オプション情報を作成します。

SalesOrganisationSelection

public SalesOrganisationSelection(int index)
販売組織の選択オプション情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSalesorgLow

public String getSalesorgLow()
販売組織の範囲開始を取得します。

戻り値:
srtSalesorgLow 販売組織の範囲開始

getSalesorgHigh

public String getSalesorgHigh()
販売組織の範囲終了を取得します。

戻り値:
srtSalesorgHigh

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index レコード番号

setSalesorgLow

public void setSalesorgLow(String strSalesorgLow)
販売組織の範囲開始を設定します。

パラメータ:
strSalesorgLow - 販売組織の範囲開始

setSalesorgHigh

public void setSalesorgHigh(String strSalesorgHigh)
販売組織の範囲終了を設定します。

パラメータ:
strSalesorgHigh - 販売組織の範囲終了

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス Selection 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Selection (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス Selection

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Selection
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
DistributionChannelSelection, MaterialShortDescsel, MatnrSelection, PlantSelection, SalesOrganisationSelection, StorageLocationSelect
public class Selection
extends Object
implements Serializable

選択オプションクラス
機能は以下の通り

  • 選択オプションの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Selection()
選択オプション情報を作成します。
メソッドの概要
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setOption(String strOption) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String strSign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Selection

public Selection()
選択オプション情報を作成します。

メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
srtSign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
srtOption 選択演算子 OPTION (範囲テーブル)

setSign

public void setSign(String strSign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
strSign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String strOption)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
strOption - 選択演算子 OPTION (範囲テーブル)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StdMaterialGetIntNumberController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス StdMaterialGetIntNumberController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController
すべての実装インタフェース:
Serializable
public class StdMaterialGetIntNumberController
extends Object
implements Serializable

品目コード割当済照会コントローラクラス。
機能は以下の通り

  • 品目コード割当済情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
メソッドの概要
List | getStdMaterialGetIntNumberList() 品目コード割当済一覧(結果)を取得します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StdMaterialGetIntNumberController

public StdMaterialGetIntNumberController(String materialType,
                                         String industrySector,
                                         String requiredNumbers)
                                  throws SAPAuthAppException,
                                         SAPAuthSystemException,
                                         SAPGeneralAppException,
                                         SAPGeneralSystemException,
                                         SAPPurchaseSystemException,
                                         SAPPurchaseAppException
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。

パラメータ:
materialType - 品目タイプ
industrySector - 産業コード
requiredNumbers - 必須品目コードの設定
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseSystemException - 購買系業務システム例外
SAPPurchaseAppException - 購買系業務アプリケーション例外

StdMaterialGetIntNumberController

public StdMaterialGetIntNumberController(String materialType,
                                         String industrySector,
                                         String requiredNumbers,
                                         SapClient sapClient)
                                  throws SAPAuthAppException,
                                         SAPAuthSystemException,
                                         SAPGeneralAppException,
                                         SAPGeneralSystemException,
                                         SAPPurchaseSystemException,
                                         SAPPurchaseAppException
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバ接続が可能となります。

パラメータ:
materialType - 品目タイプ
industrySector - 産業コード
requiredNumbers - 必須品目コードの設定
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseSystemException - 購買系業務システム例外
SAPPurchaseAppException - 購買系業務アプリケーション例外
メソッドの詳細

getStdMaterialGetIntNumberList

public List getStdMaterialGetIntNumberList()
品目コード割当済一覧(結果)を取得します。

戻り値:
stdMaterialGetIntNumberList 品目コード割当済一覧(結果)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StorageLocationSelect (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス StorageLocationSelect

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Selection
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect
すべての実装インタフェース:
Serializable
public class StorageLocationSelect
extends Selection
implements Serializable

保管場所の選択オプションクラス
機能は以下の通り

  • 保管場所の選択オプションの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
StorageLocationSelect()
保管場所の選択オプション情報を作成します。
StorageLocationSelect(int index)
保管場所の選択オプション情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します。
String | getStlocHigh() 終了保管場所を取得します。
String | getStlocLow() 開始保管場所を取得します。
void | setIndex(int index) レコード番号を設定します。
void | setStlocHigh(String strStlocHigh) 終了保管場所を設定します。
void | setStlocLow(String strStlocLow) 開始保管場所を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.Selection から継承したメソッド
getOption, getSign, setOption, setSign
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StorageLocationSelect

public StorageLocationSelect()
保管場所の選択オプション情報を作成します。

StorageLocationSelect

public StorageLocationSelect(int index)
保管場所の選択オプション情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getStlocLow

public String getStlocLow()
開始保管場所を取得します。

戻り値:
srtStlocLow

getStlocHigh

public String getStlocHigh()
終了保管場所を取得します。

戻り値:
srtStlocHigh

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index

setStlocLow

public void setStlocLow(String strStlocLow)
開始保管場所を設定します。

パラメータ:
strStlocLow - 開始保管場所

setStlocHigh

public void setStlocHigh(String strStlocHigh)
終了保管場所を設定します。

パラメータ:
strStlocHigh - 終了保管場所

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス Selection 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SupplierDetail (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス SupplierDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail
すべての実装インタフェース:
Serializable
public class SupplierDetail
extends ReferenceController
implements Serializable

仕入先マスタ詳細情報クラス
機能は以下の通り

  • 仕入先マスタの詳細情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
SupplierDetail(SapClient sapClient)
仕入先詳細情報クラスを取得します
SupplierDetail(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先マスタ詳細を作成します。
メソッドの概要
void | executeBapi() BapiControllerにより仕入先マスタ詳細を作成します。
ArrayList | getBankDataInfoList() 銀行データ情報一覧を取得します｡
CompanyDataInfo | getCompanyDataInfo() 会社コード依存データ情報を取得します｡
String | getCompCode() 会社コードを取得します｡
GeneralDataInfo | getGeneralDataInfo() 一般データ情報を取得します｡
String | getVendor() 仕入先コードを取得します｡
void | setBankDataInfoList(ArrayList bankDataInfoList) 銀行データ情報を設定します｡
void | setCompanyDataInfo(CompanyDataInfo companyDataInfo) 会社依存データ情報を設定します｡
void | setCompCode(String strCompode) 会社コードを設定します｡
void | setGeneralDataInfo(GeneralDataInfo generalDataInfo) 一般データ情報を設定します｡
void | setVendor(String strVendor) 仕入先コードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SupplierDetail

public SupplierDetail(SapClient sapClient)
仕入先詳細情報クラスを取得します

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト

SupplierDetail

public SupplierDetail(String vendor,
                      String compCode,
                      SapClient sapClient)
               throws SAPAuthAppException,
                      SAPAuthSystemException,
                      SAPGeneralAppException,
                      SAPGeneralSystemException,
                      SAPPurchaseAppException,
                      SAPPurchaseSystemException
executeBapiを呼び出し仕入先マスタ詳細を作成します。

パラメータ:
vendor - 仕入先コード
compCode - 会社コード
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
BapiControllerにより仕入先マスタ詳細を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 会計業務システム例外

getVendor

public String getVendor()
仕入先コードを取得します｡

戻り値:
strVendor 仕入先コード

getCompCode

public String getCompCode()
会社コードを取得します｡

戻り値:
strCompode 会社コード

getGeneralDataInfo

public GeneralDataInfo getGeneralDataInfo()
一般データ情報を取得します｡

戻り値:
generalDataInfo

getCompanyDataInfo

public CompanyDataInfo getCompanyDataInfo()
会社コード依存データ情報を取得します｡

戻り値:
companyDataInfo

getBankDataInfoList

public ArrayList getBankDataInfoList()
銀行データ情報一覧を取得します｡

戻り値:
bankDataInfoList

setVendor

public void setVendor(String strVendor)
仕入先コードを設定します｡

パラメータ:
strVendor - 仕入先コード

setCompCode

public void setCompCode(String strCompode)
会社コードを設定します｡

パラメータ:
strCompode - 会社コード

setGeneralDataInfo

public void setGeneralDataInfo(GeneralDataInfo generalDataInfo)
一般データ情報を設定します｡

パラメータ:
generalDataInfo - 一般データ情報

setCompanyDataInfo

public void setCompanyDataInfo(CompanyDataInfo companyDataInfo)
会社依存データ情報を設定します｡

パラメータ:
companyDataInfo - 会社依存データ情報

setBankDataInfoList

public void setBankDataInfoList(ArrayList bankDataInfoList)
銀行データ情報を設定します｡

パラメータ:
bankDataInfoList - 銀行データ情報

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SupplierExistenceCheck (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス SupplierExistenceCheck

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck
すべての実装インタフェース:
Serializable
public class SupplierExistenceCheck
extends ReferenceController
implements Serializable

仕入先コード存在チェッククラス
機能は以下の通り

  • 仕入先コード存在チェック結果を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
SupplierExistenceCheck(SapClient sapClient)
仕入先詳細情報クラスを取得します
SupplierExistenceCheck(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先コード存在チェックを作成します。
メソッドの概要
void | executeBapi() BapiControllerにより仕入先コード存在チェックを作成します。
String | getCheckReturn() 結果を取得します｡
String | getCompCode() 会社コードを取得します｡
String | getVendor() 仕入先コードを取得します｡
void | setCheckReturn(String checkReturn) 結果を設定します｡
void | setCompCode(String strCompCode) 会社コードを設定します｡
void | setVendor(String strVendor) 仕入先コードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SupplierExistenceCheck

public SupplierExistenceCheck(SapClient sapClient)
仕入先詳細情報クラスを取得します

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト

SupplierExistenceCheck

public SupplierExistenceCheck(String vendor,
                              String compCode,
                              SapClient sapClient)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPPurchaseAppException,
                              SAPPurchaseSystemException
executeBapiを呼び出し仕入先コード存在チェックを作成します。

パラメータ:
vendor - 仕入先コード
compCode - 会社コード
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
BapiControllerにより仕入先コード存在チェックを作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 会計業務システム例外

getVendor

public String getVendor()
仕入先コードを取得します｡

戻り値:
strVendor 仕入先コード

getCompCode

public String getCompCode()
会社コードを取得します｡

戻り値:
strCompCode 会社コード

getCheckReturn

public String getCheckReturn()
結果を取得します｡

戻り値:
checkReturn 結果

setVendor

public void setVendor(String strVendor)
仕入先コードを設定します｡

パラメータ:
strVendor - 仕入先コード

setCompCode

public void setCompCode(String strCompCode)
会社コードを設定します｡

パラメータ:
strCompCode - 会社コード

setCheckReturn

public void setCheckReturn(String checkReturn)
結果を設定します｡

パラメータ:
checkReturn - 結果

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SupplierExistenceCheckController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス SupplierExistenceCheckController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController
すべての実装インタフェース:
Serializable
public class SupplierExistenceCheckController
extends Object
implements Serializable

仕入先コード存在チェックコントローラ
機能は以下の通り

  • 仕入先コード存在チェックを行います。

関連項目:
直列化された形式

コンストラクタの概要
SupplierExistenceCheckController()
コンストラクタ生成
SupplierExistenceCheckController(SapClient sapClient)
コンストラクタ生成
SupplierExistenceCheckController(String vendor, String compCode)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheckController(String vendor, String compCode, SapClient sapClient)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
メソッドの概要
 void executeBapi()
SupplierExistenceCheckのexecuteBapi()を呼び出し仕入先コード存在チェックを行います。
 String getCheckReturn()
結果情報を取得します｡
 String getCompCode()
会社コードを取得します｡
 SupplierExistenceCheck getSupplierExistenceCheck()
仕入先コードチェック情報を取得します｡
 String getVendor()
仕入先コードを取得します｡
static void setCheckReturn(String checkReturn)
結果を設定します｡
 void setCompCode(String strCompCode)
会社コードを設定します｡
 void setVendor(String strVendor)
仕入先コードを設定します｡
 String toString()
デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SupplierExistenceCheckController

public SupplierExistenceCheckController()
コンストラクタ生成

SupplierExistenceCheckController

public SupplierExistenceCheckController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト

SupplierExistenceCheckController

public SupplierExistenceCheckController(String vendor,
                                        String compCode)
                                 throws SAPAuthAppException,
                                        SAPAuthSystemException,
                                        SAPGeneralAppException,
                                        SAPGeneralSystemException,
                                        SAPPurchaseAppException,
                                        SAPPurchaseSystemException
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。

パラメータ:
vendor - 仕入先コード
compCode - 会社コード
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

SupplierExistenceCheckController

public SupplierExistenceCheckController(String vendor,
                                        String compCode,
                                        SapClient sapClient)
                                 throws SAPAuthAppException,
                                        SAPAuthSystemException,
                                        SAPGeneralAppException,
                                        SAPGeneralSystemException,
                                        SAPPurchaseAppException,
                                        SAPPurchaseSystemException
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。

パラメータ:
vendor - 仕入先コード
compCode - 会社コード
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
SupplierExistenceCheckのexecuteBapi()を呼び出し仕入先コード存在チェックを行います。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

setVendor

public void setVendor(String strVendor)
仕入先コードを設定します｡

パラメータ:
strVendor - 仕入先コード

setCompCode

public void setCompCode(String strCompCode)
会社コードを設定します｡

パラメータ:
strCompCode - 会社コード

setCheckReturn

public static void setCheckReturn(String checkReturn)
結果を設定します｡

パラメータ:
checkReturn - 結果

getSupplierExistenceCheck

public SupplierExistenceCheck getSupplierExistenceCheck()
仕入先コードチェック情報を取得します｡

戻り値:
supplierExistenceCheck

getCheckReturn

public String getCheckReturn()
結果情報を取得します｡

戻り値:
checkReturn

getVendor

public String getVendor()
仕入先コードを取得します｡

戻り値:
vendor

getCompCode

public String getCompCode()
会社コードを取得します｡

戻り値:
compCode

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SupplierGetDetailController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス SupplierGetDetailController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController
すべての実装インタフェース:
Serializable
public class SupplierGetDetailController
extends Object
implements Serializable

仕入先マスタの詳細情報取得コントローラ
機能は以下の通り

  • 仕入先マスタの詳細情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
SupplierGetDetailController()
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(SapClient sapClient)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(String vendor, String compCode)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(String vendor, String compCode, SapClient sapClient)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
メソッドの概要
 void executeBapi()
SupplierDetailのexecuteBapi()を呼び出し仕入先マスタ詳細情報を作成します。
 ArrayList getBankDataList()
銀行データ情報を取得します。
 CompanyDataInfo getCompanyDataInfo()
会社コード依存データ情報を取得します｡
 GeneralDataInfo getGeneralDataInfo()
一般データ情報を取得します｡
 SupplierDetail getSupplierDetail()
仕入先マスタ詳細情報を取得します｡
 void setBankDataInfoList(ArrayList bankDataInfoList)
銀行データ情報を設定します｡
 void setCompanyDataInfo(CompanyDataInfo companyDataInfo)
会社依存データ情報を設定します｡
 void setCompCode(String strCompode)
会社コードを設定します｡
 void setGeneralDataInfo(GeneralDataInfo generalDataInfo)
一般データ情報を設定します｡
 void setVendor(String strVendor)
仕入先コードを設定します｡
 String toString()
デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SupplierGetDetailController

public SupplierGetDetailController()
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。

SupplierGetDetailController

public SupplierGetDetailController(SapClient sapClient)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト

SupplierGetDetailController

public SupplierGetDetailController(String vendor,
                                   String compCode)
                            throws SAPAuthAppException,
                                   SAPAuthSystemException,
                                   SAPGeneralAppException,
                                   SAPGeneralSystemException,
                                   SAPPurchaseAppException,
                                   SAPPurchaseSystemException
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。

パラメータ:
vendor - 仕入先コード
compCode - 会社コード
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

SupplierGetDetailController

public SupplierGetDetailController(String vendor,
                                   String compCode,
                                   SapClient sapClient)
                            throws SAPAuthAppException,
                                   SAPAuthSystemException,
                                   SAPGeneralAppException,
                                   SAPGeneralSystemException,
                                   SAPPurchaseAppException,
                                   SAPPurchaseSystemException
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。

パラメータ:
vendor - 仕入先コード
compCode - 会社コード
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
SupplierDetailのexecuteBapi()を呼び出し仕入先マスタ詳細情報を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

getSupplierDetail

public SupplierDetail getSupplierDetail()
仕入先マスタ詳細情報を取得します｡

戻り値:
SupplierDetail

getGeneralDataInfo

public GeneralDataInfo getGeneralDataInfo()
一般データ情報を取得します｡

戻り値:
GeneralDataInfo

getCompanyDataInfo

public CompanyDataInfo getCompanyDataInfo()
会社コード依存データ情報を取得します｡

戻り値:
CompanyDataInfo

getBankDataList

public ArrayList getBankDataList()
銀行データ情報を取得します。

戻り値:
String 銀行国コード(銀行データ情報)

setVendor

public void setVendor(String strVendor)
仕入先コードを設定します｡

パラメータ:
strVendor - 仕入先コード

setCompCode

public void setCompCode(String strCompode)
会社コードを設定します｡

パラメータ:
strCompode - 会社コード

setGeneralDataInfo

public void setGeneralDataInfo(GeneralDataInfo generalDataInfo)
一般データ情報を設定します｡

パラメータ:
generalDataInfo - 一般データ情報

setCompanyDataInfo

public void setCompanyDataInfo(CompanyDataInfo companyDataInfo)
会社依存データ情報を設定します｡

パラメータ:
companyDataInfo - 会社依存データ情報

setBankDataInfoList

public void setBankDataInfoList(ArrayList bankDataInfoList)
銀行データ情報を設定します｡

パラメータ:
bankDataInfoList - 銀行データ情報

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


VendorAddress (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス VendorAddress

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress
すべての実装インタフェース:
Serializable
public class VendorAddress
extends GeneralDataInfo

仕入先住所情報クラス
機能は以下の通り

  • 仕入先住所を保持します。

関連項目:
直列化された形式

コンストラクタの概要
VendorAddress()
入出庫予定を作成します。
メソッドの概要
String | getAddrNo() アドレス番号を取得します。
String | getAdrNotes() 住所注記を取得します。
String | getBuilding() 旧: 建物 (番号または略称)を取得します。
String | getBuildLong() 建物 (番号またはコード)を取得します。
String | getChckstatus() 市区町村ファイルテストステータスを取得します。
String | getCityNo() 市区町村/地名ファイルの市区町村コードを取得します。
String | getCommType() 通信方法 (キー) (アドレス管理)を取得します。
String | getCOName() 気付を取得します。
String | getDelivDis() 郵便配達地域を取得します。
String | getDistrctNo() 市区町村/地名ファイルの所在地コードを取得します。
String | getEMail() 電子メールアドレスを取得します。
String | getFaxExtens() 第一 FAX 番号: 内線を取得します。
String | getFaxNumber() 第一 FAX 番号: ダイヤルコード + 番号を取得します。
String | getFloor() 建物の階を取得します。
String | getHouseNo() 番地-号を取得します。
String | getHouseNo2() 番地補足を取得します。
String | getLocation() 地名 5を取得します。
String | getPboxcitNo() 市区町村私書箱コード (市ファイル)を取得します。
String | getPoBoxCit() 私書箱住所を取得します。
String | getPoNumber() 購買伝票番号を取得します。
String | getPostlCod1() 市区町村の郵便番号を取得します。
String | getPostlCod2() 私書箱郵便番号を取得します。
String | getPostlCod3() 会社郵便番号 (大規模なユーザ用)を取得します。
String | getRegiogroup() 地域構造グループ化を取得します。
String | getRoomNo() 部屋/アパート番号を取得します。
String | getSort1() 検索条件 1を取得します。
String | getSort2() 検索条件 2を取得します。
String | getStrAbbr() 地名の略称 (例: スペイン)を取得します。
String | getStreetLng() 地名を取得します。
String | getStreetNo() 市区町村/地名ファイルの地名コードを取得します。
String | getStrSuppl1() 地名 2を取得します。
String | getStrSuppl2() 地名 3を取得します。
String | getStrSuppl3() 地名 4を取得します。
String | getTaxjurcode() 税管轄コードを取得します。
String | getTel1Ext() 第 1 電話番号: 内線を取得します。
String | getTel1Numbr() 第一電話番号: ダイヤルコード + 番号を取得します。
String | getTimeZone() アドレスタイムゾーンを取得します。
String | getTitle() タイトル (敬称)を取得します。
String | getTranspzone() 商品の納入区域を取得します。
void | setAddrNo(String strAddrNo) アドレス番号を設定します。
void | setAdrNotes(String strAdrNotes) 住所注記を設定します。
void | setBuilding(String strBuilding) 旧: 建物 (番号または略称)を設定します。
void | setBuildLong(String strBuildLong) 建物 (番号またはコード)を設定します。
void | setChckstatus(String strChckstatus) 市区町村ファイルテストステータスを設定します。
void | setCityNo(String strCityNo) 市区町村/地名ファイルの市区町村コードを設定します。
void | setCommType(String strCommType) 通信方法 (キー) (アドレス管理)を設定します。
void | setCOName(String strCOName) 気付を設定します。
void | setDelivDis(String strDelivDis) 郵便配達地域を設定します。
void | setDistrctNo(String strDistrctNo) 市区町村/地名ファイルの所在地コードを設定します。
void | setEMail(String strEMail) 電子メールアドレスを設定します。
void | setFaxExtens(String strFaxExtens) 第一 FAX 番号: 内線を設定します。
void | setFaxNumber(String strFaxNumber) 第一 FAX 番号: ダイヤルコード + 番号を設定します。
void | setFloor(String strFloor) 建物の階を設定します。
void | setHouseNo(String strHouseNo) 番地-号を設定します。
void | setHouseNo2(String strHouseNo2) 番地補足を設定します。
void | setLocation(String strLocation) 地名 5を設定します。
void | setPboxcitNo(String strPboxcitNo) 市区町村私書箱コード (市ファイル)を設定します。
void | setPoBoxCit(String strPoBoxCit) 私書箱住所を設定します。
void | setPoNumber(String strPoNumber) 購買伝票番号を設定します。
void | setPostlCod1(String strPostlCod1) 市区町村の郵便番号を設定します。
void | setPostlCod2(String strPostlCod2) 私書箱郵便番号を設定します。
void | setPostlCod3(String strPostlCod3) 会社郵便番号 (大規模なユーザ用)を設定します。
void | setRegiogroup(String strRegiogroup) 地域構造グループ化を設定します。
void | setRoomNo(String strRoomNo) 部屋/アパート番号を設定します。
void | setSort1(String strSort1) 検索条件 1を設定します。
void | setSort2(String strSort2) 検索条件 2を設定します。
void | setStrAbbr(String strStrAbbr) 地名の略称 (例: スペイン)を設定します。
void | setStreetLng(String strStreetLng) 地名を設定します。
void | setStreetNo(String strStreetNo) 市区町村/地名ファイルの地名コードを設定します。
void | setStrSuppl1(String strStrSuppl1) 地名 2を設定します。
void | setStrSuppl2(String strStrSuppl2) 地名 3を設定します。
void | setStrSuppl3(String strStrSuppl3) 地名 4を設定します。
void | setTaxjurcode(String strTaxjurcode) 税管轄コードを設定します。
void | setTel1Ext(String strTel1Ext) 第 1 電話番号: 内線を設定します。
void | setTel1Numbr(String strTel1Numbr) 第一電話番号: ダイヤルコード + 番号を設定します。
void | setTimeZone(String strTimeZone) アドレスタイムゾーンを設定します。
void | setTitle(String strTitle) タイトル (敬称)を設定します。
void | setTranspzone(String strTranspzone) 商品の納入区域を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo から継承したメソッド
getCity, getCityCode, getCountry, getCountryiso, getCountycode, getCustomer, getDistrict, getFax1, getFormofaddr, getLangu, getLanguIso, getName_2, getName_3, getName_4, getName, getPoBox, getPobxCty, getPobxPcd, getPostlCode, getRegion, getStreet, getTelephone, getTelephone2, getVendor, setCity, setCityCode, setCountry, setCountryiso, setCountycode, setCustomer, setDistrict, setFax1, setFormofaddr, setLangu, setLanguIso, setName_2, setName_3, setName_4, setName, setPoBox, setPobxCty, setPobxPcd, setPostlCode, setRegion, setStreet, setTelephone, setTelephone2, setVendor
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

VendorAddress

public VendorAddress()
入出庫予定を作成します。

メソッドの詳細

getPoNumber

public String getPoNumber()
購買伝票番号を取得します。

戻り値:
srtPoNumber 購買伝票番号

getAddrNo

public String getAddrNo()
アドレス番号を取得します。

戻り値:
srtAddrNo アドレス番号

getCOName

public String getCOName()
気付を取得します。

戻り値:
srtCOName 気付

getCityNo

public String getCityNo()
市区町村/地名ファイルの市区町村コードを取得します。

戻り値:
srtCityNo 市区町村/地名ファイルの市区町村コード

getPostlCod1

public String getPostlCod1()
市区町村の郵便番号を取得します。

戻り値:
srtPostlCod1 市区町村の郵便番号

getPostlCod2

public String getPostlCod2()
私書箱郵便番号を取得します。

戻り値:
srtPostlCod2 私書箱郵便番号

getPostlCod3

public String getPostlCod3()
会社郵便番号 (大規模なユーザ用)を取得します。

戻り値:
srtPostlCod3 会社郵便番号 (大規模なユーザ用)

getPoBoxCit

public String getPoBoxCit()
私書箱住所を取得します。

戻り値:
srtPoBoxCit 私書箱住所

getDelivDis

public String getDelivDis()
郵便配達地域を取得します。

戻り値:
srtDelivDis 郵便配達地域

getStreetNo

public String getStreetNo()
市区町村/地名ファイルの地名コードを取得します。

戻り値:
srtStreetNo 市区町村/地名ファイルの地名コード

getStrAbbr

public String getStrAbbr()
地名の略称 (例: スペイン)を取得します。

戻り値:
srtStrAbbr 地名の略称 (例: スペイン)

getHouseNo

public String getHouseNo()
番地-号を取得します。

戻り値:
srtHouseNo 番地-号

getStrSuppl1

public String getStrSuppl1()
地名 2を取得します。

戻り値:
srtStrSuppl1 地名 2

getStrSuppl2

public String getStrSuppl2()
地名 3を取得します。

戻り値:
srtStrSuppl2 地名 3

getLocation

public String getLocation()
地名 5を取得します。

戻り値:
srtLocation 地名 5

getBuilding

public String getBuilding()
旧: 建物 (番号または略称)を取得します。

戻り値:
srtBuilding 旧: 建物 (番号または略称)

getFloor

public String getFloor()
建物の階を取得します。

戻り値:
srtFloor 建物の階

getRoomNo

public String getRoomNo()
部屋/アパート番号を取得します。

戻り値:
srtRoomNo 部屋/アパート番号

getSort1

public String getSort1()
検索条件 1を取得します。

戻り値:
srtSort1 検索条件 1

getSort2

public String getSort2()
検索条件 2を取得します。

戻り値:
srtSort2 検索条件 2

getTimeZone

public String getTimeZone()
アドレスタイムゾーンを取得します。

戻り値:
srtTimeZone アドレスタイムゾーン

getTaxjurcode

public String getTaxjurcode()
税管轄コードを取得します。

戻り値:
srtTaxjurcode 税管轄コード

getAdrNotes

public String getAdrNotes()
住所注記を取得します。

戻り値:
srtAdrNotes 住所注記

getCommType

public String getCommType()
通信方法 (キー) (アドレス管理)を取得します。

戻り値:
srtCommType 通信方法 (キー) (アドレス管理)

getTel1Numbr

public String getTel1Numbr()
第一電話番号: ダイヤルコード + 番号を取得します。

戻り値:
srtTel1Numbr 第一電話番号: ダイヤルコード + 番号

getTel1Ext

public String getTel1Ext()
第 1 電話番号: 内線を取得します。

戻り値:
srtTel1Ext 第 1 電話番号: 内線

getFaxNumber

public String getFaxNumber()
第一 FAX 番号: ダイヤルコード + 番号を取得します。

戻り値:
srtFaxNumber 第一 FAX 番号: ダイヤルコード + 番号

getFaxExtens

public String getFaxExtens()
第一 FAX 番号: 内線を取得します。

戻り値:
srtFaxExtens 第一 FAX 番号: 内線

getStreetLng

public String getStreetLng()
地名を取得します。

戻り値:
srtStreetLng 地名

getDistrctNo

public String getDistrctNo()
市区町村/地名ファイルの所在地コードを取得します。

戻り値:
srtDistrctNo 市区町村/地名ファイルの所在地コード

getChckstatus

public String getChckstatus()
市区町村ファイルテストステータスを取得します。

戻り値:
srtChckstatus 市区町村ファイルテストステータス

getPboxcitNo

public String getPboxcitNo()
市区町村私書箱コード (市ファイル)を取得します。

戻り値:
srtPboxcitNo 市区町村私書箱コード (市ファイル)

getTranspzone

public String getTranspzone()
商品の納入区域を取得します。

戻り値:
srtTranspzone 商品の納入区域

getHouseNo2

public String getHouseNo2()
番地補足を取得します。

戻り値:
srtHouseNo2 番地補足

getEMail

public String getEMail()
電子メールアドレスを取得します。

戻り値:
srtEMail 電子メールアドレス

getStrSuppl3

public String getStrSuppl3()
地名 4を取得します。

戻り値:
srtStrSuppl3 地名 4

getTitle

public String getTitle()
タイトル (敬称)を取得します。

戻り値:
srtTitle タイトル (敬称)

getBuildLong

public String getBuildLong()
建物 (番号またはコード)を取得します。

戻り値:
srtBuildLong 建物 (番号またはコード)

getRegiogroup

public String getRegiogroup()
地域構造グループ化を取得します。

戻り値:
srtRegiogroup 地域構造グループ化

setPoNumber

public void setPoNumber(String strPoNumber)
購買伝票番号を設定します。

パラメータ:
strPoNumber - 購買伝票番号

setAddrNo

public void setAddrNo(String strAddrNo)
アドレス番号を設定します。

パラメータ:
strAddrNo - アドレス番号

setCOName

public void setCOName(String strCOName)
気付を設定します。

パラメータ:
strCOName - 気付

setCityNo

public void setCityNo(String strCityNo)
市区町村/地名ファイルの市区町村コードを設定します。

パラメータ:
strCityNo - 市区町村/地名ファイルの市区町村コード

setPostlCod1

public void setPostlCod1(String strPostlCod1)
市区町村の郵便番号を設定します。

パラメータ:
strPostlCod1 - 市区町村の郵便番号

setPostlCod2

public void setPostlCod2(String strPostlCod2)
私書箱郵便番号を設定します。

パラメータ:
strPostlCod2 - 私書箱郵便番号

setPostlCod3

public void setPostlCod3(String strPostlCod3)
会社郵便番号 (大規模なユーザ用)を設定します。

パラメータ:
strPostlCod3 - 会社郵便番号 (大規模なユーザ用)

setPoBoxCit

public void setPoBoxCit(String strPoBoxCit)
私書箱住所を設定します。

パラメータ:
strPoBoxCit - 私書箱住所

setDelivDis

public void setDelivDis(String strDelivDis)
郵便配達地域を設定します。

パラメータ:
strDelivDis - 郵便配達地域

setStreetNo

public void setStreetNo(String strStreetNo)
市区町村/地名ファイルの地名コードを設定します。

パラメータ:
strStreetNo - 市区町村/地名ファイルの地名コード

setStrAbbr

public void setStrAbbr(String strStrAbbr)
地名の略称 (例: スペイン)を設定します。

パラメータ:
strStrAbbr - 地名の略称 (例: スペイン)

setHouseNo

public void setHouseNo(String strHouseNo)
番地-号を設定します。

パラメータ:
strHouseNo - 番地-号

setStrSuppl1

public void setStrSuppl1(String strStrSuppl1)
地名 2を設定します。

パラメータ:
strStrSuppl1 - 地名 2

setStrSuppl2

public void setStrSuppl2(String strStrSuppl2)
地名 3を設定します。

パラメータ:
strStrSuppl2 - 地名 3

setLocation

public void setLocation(String strLocation)
地名 5を設定します。

パラメータ:
strLocation - 地名 5

setBuilding

public void setBuilding(String strBuilding)
旧: 建物 (番号または略称)を設定します。

パラメータ:
strBuilding - 旧: 建物 (番号または略称)

setFloor

public void setFloor(String strFloor)
建物の階を設定します。

パラメータ:
strFloor - 建物の階

setRoomNo

public void setRoomNo(String strRoomNo)
部屋/アパート番号を設定します。

パラメータ:
strRoomNo - 部屋/アパート番号

setSort1

public void setSort1(String strSort1)
検索条件 1を設定します。

パラメータ:
strSort1 - 検索条件 1

setSort2

public void setSort2(String strSort2)
検索条件 2を設定します。

パラメータ:
strSort2 - 検索条件 2

setTimeZone

public void setTimeZone(String strTimeZone)
アドレスタイムゾーンを設定します。

パラメータ:
strTimeZone - アドレスタイムゾーン

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税管轄コード

setAdrNotes

public void setAdrNotes(String strAdrNotes)
住所注記を設定します。

パラメータ:
strAdrNotes - 住所注記

setCommType

public void setCommType(String strCommType)
通信方法 (キー) (アドレス管理)を設定します。

パラメータ:
strCommType - 通信方法 (キー) (アドレス管理)

setTel1Numbr

public void setTel1Numbr(String strTel1Numbr)
第一電話番号: ダイヤルコード + 番号を設定します。

パラメータ:
strTel1Numbr - 第一電話番号: ダイヤルコード + 番号

setTel1Ext

public void setTel1Ext(String strTel1Ext)
第 1 電話番号: 内線を設定します。

パラメータ:
strTel1Ext - 第 1 電話番号: 内線

setFaxNumber

public void setFaxNumber(String strFaxNumber)
第一 FAX 番号: ダイヤルコード + 番号を設定します。

パラメータ:
strFaxNumber - 第一 FAX 番号: ダイヤルコード + 番号

setFaxExtens

public void setFaxExtens(String strFaxExtens)
第一 FAX 番号: 内線を設定します。

パラメータ:
strFaxExtens - 第一 FAX 番号: 内線

setStreetLng

public void setStreetLng(String strStreetLng)
地名を設定します。

パラメータ:
strStreetLng - 地名

setDistrctNo

public void setDistrctNo(String strDistrctNo)
市区町村/地名ファイルの所在地コードを設定します。

パラメータ:
strDistrctNo - 市区町村/地名ファイルの所在地コード

setChckstatus

public void setChckstatus(String strChckstatus)
市区町村ファイルテストステータスを設定します。

パラメータ:
strChckstatus - 市区町村ファイルテストステータス

setPboxcitNo

public void setPboxcitNo(String strPboxcitNo)
市区町村私書箱コード (市ファイル)を設定します。

パラメータ:
strPboxcitNo - 市区町村私書箱コード (市ファイル)

setTranspzone

public void setTranspzone(String strTranspzone)
商品の納入区域を設定します。

パラメータ:
strTranspzone - 商品の納入区域

setHouseNo2

public void setHouseNo2(String strHouseNo2)
番地補足を設定します。

パラメータ:
strHouseNo2 - 番地補足

setEMail

public void setEMail(String strEMail)
電子メールアドレスを設定します。

パラメータ:
strEMail - 電子メールアドレス

setStrSuppl3

public void setStrSuppl3(String strStrSuppl3)
地名 4を設定します。

パラメータ:
strStrSuppl3 - 地名 4

setTitle

public void setTitle(String strTitle)
タイトル (敬称)を設定します。

パラメータ:
strTitle - タイトル (敬称)

setBuildLong

public void setBuildLong(String strBuildLong)
建物 (番号またはコード)を設定します。

パラメータ:
strBuildLong - 建物 (番号またはコード)

setRegiogroup

public void setRegiogroup(String strRegiogroup)
地域構造グループ化を設定します。

パラメータ:
strRegiogroup - 地域構造グループ化

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス GeneralDataInfo 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Versions (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス Versions

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Versions
すべての実装インタフェース:
Serializable
public class Versions
extends Object
implements Serializable

バージョン管理情報クラス
機能は以下の通り

  • バージョン管理情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Versions()
バージョン管理を作成します。
メソッドの概要
String | getActivity() 処理タイプ - R/3 Enterprise で使用不可能を取得します。
String | getCompleted() ステータス "バージョン完了済"を取得します。
String | getDescription() バージョンテキスト（長）を取得します。
String | getPostDate() バージョンの転記日付を取得します。
String | getReason() 変更理由を取得します。
String | getReqBy() 変更を依頼した従業員を取得します。
String | getReqByExt() バージョンの外部変更番号を取得します。
void | setActivity(String strActivity) 処理タイプ - R/3 Enterprise で使用不可能を設定します。
void | setCompleted(String strCompleted) ステータス "バージョン完了済"を設定します。
void | setDescription(String strDescription) バージョンテキスト（長）を設定します。
void | setPostDate(String strPostDate) バージョンの転記日付を設定します。
void | setReason(String strReason) 変更理由を設定します。
void | setReqBy(String strReqBy) 変更を依頼した従業員を設定します。
void | setReqByExt(String strReqByExt) バージョンの外部変更番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Versions

public Versions()
バージョン管理を作成します。

メソッドの詳細

getPostDate

public String getPostDate()
バージョンの転記日付を取得します。

戻り値:
srtPostDate バージョンの転記日付

getCompleted

public String getCompleted()
ステータス "バージョン完了済"を取得します。

戻り値:
srtCompleted ステータス "バージョン完了済"

getReason

public String getReason()
変更理由を取得します。

戻り値:
srtReason 変更理由

getDescription

public String getDescription()
バージョンテキスト（長）を取得します。

戻り値:
srtDescription バージョンテキスト（長）

getReqBy

public String getReqBy()
変更を依頼した従業員を取得します。

戻り値:
srtReqBy 変更を依頼した従業員

getReqByExt

public String getReqByExt()
バージョンの外部変更番号を取得します。

戻り値:
srtReqByExt バージョンの外部変更番号

getActivity

public String getActivity()
処理タイプ - R/3 Enterprise で使用不可能を取得します。

戻り値:
srtActivity 処理タイプ - R/3 Enterprise で使用不可能

setPostDate

public void setPostDate(String strPostDate)
バージョンの転記日付を設定します。

パラメータ:
strPostDate - バージョンの転記日付

setCompleted

public void setCompleted(String strCompleted)
ステータス "バージョン完了済"を設定します。

パラメータ:
strCompleted - ステータス "バージョン完了済"

setReason

public void setReason(String strReason)
変更理由を設定します。

パラメータ:
strReason - 変更理由

setDescription

public void setDescription(String strDescription)
バージョンテキスト（長）を設定します。

パラメータ:
strDescription - バージョンテキスト（長）

setReqBy

public void setReqBy(String strReqBy)
変更を依頼した従業員を設定します。

パラメータ:
strReqBy - 変更を依頼した従業員

setReqByExt

public void setReqByExt(String strReqByExt)
バージョンの外部変更番号を設定します。

パラメータ:
strReqByExt - バージョンの外部変更番号

setActivity

public void setActivity(String strActivity)
処理タイプ - R/3 Enterprise で使用不可能を設定します。

パラメータ:
strActivity - 処理タイプ - R/3 Enterprise で使用不可能

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple の使用

BillingDocCreateMultiple を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales での BillingDocCreateMultiple の使用

jp.co.intra_mart.foundation.sap.module.sales での BillingDocCreateMultiple のサブクラス
 class BillingDocCreateMultipleController
請求伝票登録コントローラクラス
機能は以下の通り
請求伝票を登録します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn の使用

CreatorDataIn を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple での CreatorDataIn の使用

CreatorDataIn を返す jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple のメソッド
 CreatorDataIn BillingDocCreateMultiple.getCreatorDataIn()
取り込まれる日付の順序を取得します。

CreatorDataIn 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple のメソッド
static void | ParamCreatorDataIn.setImportParam(BapiController bapiController, CreatorDataIn creatorDataIn) 取り込まれる日付の順序の値をセットします。
void | BillingDocCreateMultiple.setCreatorDataIn(CreatorDataIn creatorDataIn) 取り込まれる日付の順序を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BillingDataIn (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス BillingDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn
すべての実装インタフェース:
Serializable
public class BillingDataIn
extends Object
implements Serializable

処理予定明細データのテーブル情報クラス
機能は以下の通り

  • 処理予定明細データのテーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
BillingDataIn()
処理予定明細データのテーブル情報を作成します。
BillingDataIn(int index)
処理予定明細データのテーブル情報を作成します。
メソッドの概要
String | getAcctasgnmt() 品目の勘定設定グループを取得します。
String | getAddrNo() アドレス: アドレス番号を取得します。
String | getBillDate() 請求索引および印刷に対する請求日を取得します。
String | getBillTo() 請求先を取得します。
String | getCity() 市区町村を取得します。
String | getConsumctry() 消費者の国キーを取得します。
String | getCostcenter() 原価センタを取得します。
String | getCountry() 出荷国 (商品発送国)を取得します。
String | getCreatedBy() オブジェクト登録者名を取得します。
String | getCurrency() 販売伝票通貨を取得します。
String | getDistrChan() 流通チャネルを取得します。
String | getDistrict() 所在地を取得します。
String | getDivision() 製品部門を取得します。
String | getDocNumber() 販売伝票を取得します。
String | getDocType() 販売伝票タイプを取得します。
String | getExchangeRate() 価格設定/統計用換算レートを取得します。
String | getHgLvItem() BOM 構成の上位レベル明細を取得します。
String | getIncoterms1() インコタームズ (1)を取得します。
String | getIncoterms2() インコタームズ (2)を取得します。
int | getIndex() レコード番号を取得します｡
String | getItem() 開始明細を取得します。
String | getItemCateg() 明細カテゴリ (販売伝票)を取得します。
String | getItmNumber() 販売伝票明細を取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getName() 名称 1を取得します。
String | getName2() 名称 2を取得します。
String | getNoMatmast() 品目マスタ確認禁止を取得します。
String | getOrdbilltyp() 受注関連請求伝票に対する提案請求伝票タイプを取得します。
String | getOrderid() 指図番号を取得します。
String | getOrigindoc() 開始伝票を取得します。
String | getPayer() 支払人を取得します。
String | getPaymentTerms() 支払条件キーを取得します。
String | getPlant() プラントを取得します。
String | getPostlCode() 郵便番号を取得します。
String | getPriceDate() 価格設定/外貨換算の実行日付を取得します。
String | getProdHier() 品目階層を取得します。
String | getProfitCtr() 利益センタを取得します。
String | getProfitSegmNo() 収益性セグメント番号 (CO-PA)を取得します。
String | getPurchOrd() 出荷先発注番号を取得します。
String | getRefDoc() 参照伝票番号を取得します。
String | getRefDocCa() 先行販売管理伝票の伝票カテゴリを取得します。
String | getRefItem() 参照明細番号を取得します。
String | getRegion() 地域 (都道府県)を取得します。
String | getReqQty() 累積受注数量 (販売単位)を取得します。
String | getSalesorg() 販売組織を取得します。
String | getSalesUnit() 販売単位を取得します。
String | getShipTo() 出荷先を取得します。
String | getShortText() テキスト (短): 受注明細を取得します。
String | getSoldTo() 受注先を取得します。
String | getStatGroup() 統計グループを取得します。
String | getStreet() 地名/番地-号を取得します。
String | getTaxcl1Mat() 品目の税分類を取得します。
String | getTaxDepartCty() 税出荷国を取得します。
String | getTaxDestCty() 税仕向国を取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getTitle() 敬称を取得します。
String | getWbsElem() WBS 要素を取得します。
void | setAcctasgnmt(String acctasgnmt) 品目の勘定設定グループを設定します。
void | setAddrNo(String addrNo) アドレス: アドレス番号を設定します。
void | setBillDate(String billDate) 請求索引および印刷に対する請求日を設定します。
void | setBillTo(String billTo) 請求先を設定します。
void | setCity(String city) 市区町村を設定します。
void | setConsumctry(String consumctry) 消費者の国キーを設定します。
void | setCostcenter(String costcenter) 原価センタを設定します。
void | setCountry(String country) 出荷国 (商品発送国)を設定します。
void | setCreatedBy(String createdBy) オブジェクト登録者名を設定します。
void | setCurrency(String currency) 販売伝票通貨を設定します。
void | setDistrChan(String distrChan) 流通チャネルを設定します。
void | setDistrict(String district) 所在地を設定します。
void | setDivision(String division) 製品部門を設定します。
void | setDocNumber(String docNumber) 販売伝票を設定します。
void | setDocType(String docType) 販売伝票タイプを設定します。
void | setExchangeRate(String exchangeRate) 価格設定/統計用換算レートを設定します。
void | setHgLvItem(String hgLvItem) BOM 構成の上位レベル明細を設定します。
void | setIncoterms1(String incoterms1) インコタームズ (1)を設定します。
void | setIncoterms2(String incoterms2) インコタームズ (2)を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItem(String item) 開始明細を設定します。
void | setItemCateg(String itemCateg) 明細カテゴリ (販売伝票)を設定します。
void | setItmNumber(String itmNumber) 販売伝票明細を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setName(String name) 名称 1を設定します。
void | setName2(String name2) 名称 2を設定します。
void | setNoMatmast(String noMatmast) 品目マスタ確認禁止を設定します。
void | setOrdbilltyp(String ordbilltyp) 受注関連請求伝票に対する提案請求伝票タイプを設定します。
void | setOrderid(String orderid) 指図番号を設定します。
void | setOrigindoc(String origindoc) 開始伝票を設定します。
void | setPayer(String payer) 支払人を設定します。
void | setPaymentTerms(String paymentTerms) 支払条件キーを設定します。
void | setPlant(String plant) プラントを設定します。
void | setPostlCode(String postlCode) 郵便番号を設定します。
void | setPriceDate(String priceDate) 価格設定/外貨換算の実行日付を設定します。
void | setProdHier(String prodHier) 品目階層を設定します。
void | setProfitCtr(String profitCtr) 利益センタを設定します。
void | setProfitSegmNo(String profitSegmNo) 収益性セグメント番号 (CO-PA)を設定します。
void | setPurchOrd(String purchOrd) 出荷先発注番号を設定します。
void | setRefDoc(String refDoc) 参照伝票番号を設定します。
void | setRefDocCa(String refDocCa) 先行販売管理伝票の伝票カテゴリを設定します。
void | setRefItem(String refItem) 参照明細番号を設定します。
void | setRegion(String region) 地域 (都道府県)を設定します。
void | setReqQty(String reqQty) 累積受注数量 (販売単位)を設定します。
void | setSalesorg(String salesorg) 販売組織を設定します。
void | setSalesUnit(String salesUnit) 販売単位を設定します。
void | setShipTo(String shipTo) 出荷先を設定します。
void | setShortText(String shortText) テキスト (短): 受注明細を設定します。
void | setSoldTo(String soldTo) 受注先を設定します。
void | setStatGroup(String statGroup) 統計グループを設定します。
void | setStreet(String street) 地名/番地-号を設定します。
void | setTaxcl1Mat(String taxcl1Mat) 品目の税分類を設定します。
void | setTaxDepartCty(String taxDepartCty) 税出荷国を設定します。
void | setTaxDestCty(String taxDestCty) 税仕向国を設定します。
void | setTaxjurcode(String taxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setTitle(String title) 敬称を設定します。
void | setWbsElem(String wbsElem) WBS 要素を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BillingDataIn

public BillingDataIn()
処理予定明細データのテーブル情報を作成します。

BillingDataIn

public BillingDataIn(int index)
処理予定明細データのテーブル情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSalesorg

public String getSalesorg()
販売組織を取得します。

戻り値:
salesorg 販売組織

getDistrChan

public String getDistrChan()
流通チャネルを取得します。

戻り値:
distrChan 流通チャネル

getDivision

public String getDivision()
製品部門を取得します。

戻り値:
division 製品部門

getDocType

public String getDocType()
販売伝票タイプを取得します。

戻り値:
docType 販売伝票タイプ

getOrdbilltyp

public String getOrdbilltyp()
受注関連請求伝票に対する提案請求伝票タイプを取得します。

戻り値:
ordbilltyp 受注関連請求伝票に対する提案請求伝票タイプ

getBillDate

public String getBillDate()
請求索引および印刷に対する請求日を取得します。

戻り値:
billDate 請求索引および印刷に対する請求日

getSoldTo

public String getSoldTo()
受注先を取得します。

戻り値:
soldTo 受注先

getItemCateg

public String getItemCateg()
明細カテゴリ (販売伝票)を取得します。

戻り値:
itemCateg 明細カテゴリ (販売伝票)

getAcctasgnmt

public String getAcctasgnmt()
品目の勘定設定グループを取得します。

戻り値:
acctasgnmt 品目の勘定設定グループ

getPriceDate

public String getPriceDate()
価格設定/外貨換算の実行日付を取得します。

戻り値:
priceDate 価格設定/外貨換算の実行日付

getCountry

public String getCountry()
出荷国 (商品発送国)を取得します。

戻り値:
country 出荷国 (商品発送国)

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getBillTo

public String getBillTo()
請求先を取得します。

戻り値:
billTo 請求先

getPayer

public String getPayer()
支払人を取得します。

戻り値:
payer 支払人

getShipTo

public String getShipTo()
出荷先を取得します。

戻り値:
shipTo 出荷先

getRefDoc

public String getRefDoc()
参照伝票番号を取得します。

戻り値:
refDoc 参照伝票番号

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getReqQty

public String getReqQty()
累積受注数量 (販売単位)を取得します。

戻り値:
reqQty 累積受注数量 (販売単位)

getCurrency

public String getCurrency()
販売伝票通貨を取得します。

戻り値:
currency 販売伝票通貨

getShortText

public String getShortText()
テキスト (短): 受注明細を取得します。

戻り値:
shortText テキスト (短): 受注明細

getTaxcl1Mat

public String getTaxcl1Mat()
品目の税分類を取得します。

戻り値:
taxcl1Mat 品目の税分類

getRefItem

public String getRefItem()
参照明細番号を取得します。

戻り値:
refItem 参照明細番号

getStatGroup

public String getStatGroup()
統計グループを取得します。

戻り値:
statGroup 統計グループ

getNoMatmast

public String getNoMatmast()
品目マスタ確認禁止を取得します。

戻り値:
noMatmast 品目マスタ確認禁止

getAddrNo

public String getAddrNo()
アドレス: アドレス番号を取得します。

戻り値:
addrNo アドレス: アドレス番号

getTitle

public String getTitle()
敬称を取得します。

戻り値:
title 敬称

getName

public String getName()
名称 1を取得します。

戻り値:
name 名称 1

getName2

public String getName2()
名称 2を取得します。

戻り値:
name2 名称 2

getPostlCode

public String getPostlCode()
郵便番号を取得します。

戻り値:
postlCode 郵便番号

getConsumctry

public String getConsumctry()
消費者の国キーを取得します。

戻り値:
consumctry 消費者の国キー

getCity

public String getCity()
市区町村を取得します。

戻り値:
city 市区町村

getDistrict

public String getDistrict()
所在地を取得します。

戻り値:
district 所在地

getStreet

public String getStreet()
地名/番地-号を取得します。

戻り値:
street 地名/番地-号

getRegion

public String getRegion()
地域 (都道府県)を取得します。

戻り値:
region 地域 (都道府県)

getProdHier

public String getProdHier()
品目階層を取得します。

戻り値:
prodHier 品目階層

getSalesUnit

public String getSalesUnit()
販売単位を取得します。

戻り値:
salesUnit 販売単位

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
profitCtr 利益センタ

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
taxjurcode 税計算管轄コード - 税管轄コード

getPurchOrd

public String getPurchOrd()
出荷先発注番号を取得します。

戻り値:
purchOrd 出荷先発注番号

getDocNumber

public String getDocNumber()
販売伝票を取得します。

戻り値:
docNumber 販売伝票

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
itmNumber 販売伝票明細

getOrigindoc

public String getOrigindoc()
開始伝票を取得します。

戻り値:
origindoc 開始伝票

getItem

public String getItem()
開始明細を取得します。

戻り値:
item 開始明細

getCreatedBy

public String getCreatedBy()
オブジェクト登録者名を取得します。

戻り値:
createdBy オブジェクト登録者名

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getIncoterms1

public String getIncoterms1()
インコタームズ (1)を取得します。

戻り値:
incoterms1 インコタームズ (1)

getIncoterms2

public String getIncoterms2()
インコタームズ (2)を取得します。

戻り値:
incoterms2 インコタームズ (2)

getExchangeRate

public String getExchangeRate()
価格設定/統計用換算レートを取得します。

戻り値:
exchangeRate 価格設定/統計用換算レート

getPaymentTerms

public String getPaymentTerms()
支払条件キーを取得します。

戻り値:
paymentTerms 支払条件キー

getHgLvItem

public String getHgLvItem()
BOM 構成の上位レベル明細を取得します。

戻り値:
hgLvItem BOM 構成の上位レベル明細

getRefDocCa

public String getRefDocCa()
先行販売管理伝票の伝票カテゴリを取得します。

戻り値:
refDocCa 先行販売管理伝票の伝票カテゴリ

getOrderid

public String getOrderid()
指図番号を取得します。

戻り値:
orderid 指図番号

getProfitSegmNo

public String getProfitSegmNo()
収益性セグメント番号 (CO-PA)を取得します。

戻り値:
profitSegmNo 収益性セグメント番号 (CO-PA)

getCostcenter

public String getCostcenter()
原価センタを取得します。

戻り値:
costcenter 原価センタ

getWbsElem

public String getWbsElem()
WBS 要素を取得します。

戻り値:
wbsElem WBS 要素

getTaxDepartCty

public String getTaxDepartCty()
税出荷国を取得します。

戻り値:
taxDepartCty 税出荷国

getTaxDestCty

public String getTaxDestCty()
税仕向国を取得します。

戻り値:
taxDestCty 税仕向国

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSalesorg

public void setSalesorg(String salesorg)
販売組織を設定します。

パラメータ:
salesorg - 販売組織

setDistrChan

public void setDistrChan(String distrChan)
流通チャネルを設定します。

パラメータ:
distrChan - 流通チャネル

setDivision

public void setDivision(String division)
製品部門を設定します。

パラメータ:
division - 製品部門

setDocType

public void setDocType(String docType)
販売伝票タイプを設定します。

パラメータ:
docType - 販売伝票タイプ

setOrdbilltyp

public void setOrdbilltyp(String ordbilltyp)
受注関連請求伝票に対する提案請求伝票タイプを設定します。

パラメータ:
ordbilltyp - 受注関連請求伝票に対する提案請求伝票タイプ

setBillDate

public void setBillDate(String billDate)
請求索引および印刷に対する請求日を設定します。

パラメータ:
billDate - 請求索引および印刷に対する請求日

setSoldTo

public void setSoldTo(String soldTo)
受注先を設定します。

パラメータ:
soldTo - 受注先

setItemCateg

public void setItemCateg(String itemCateg)
明細カテゴリ (販売伝票)を設定します。

パラメータ:
itemCateg - 明細カテゴリ (販売伝票)

setAcctasgnmt

public void setAcctasgnmt(String acctasgnmt)
品目の勘定設定グループを設定します。

パラメータ:
acctasgnmt - 品目の勘定設定グループ

setPriceDate

public void setPriceDate(String priceDate)
価格設定/外貨換算の実行日付を設定します。

パラメータ:
priceDate - 価格設定/外貨換算の実行日付

setCountry

public void setCountry(String country)
出荷国 (商品発送国)を設定します。

パラメータ:
country - 出荷国 (商品発送国)

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setBillTo

public void setBillTo(String billTo)
請求先を設定します。

パラメータ:
billTo - 請求先

setPayer

public void setPayer(String payer)
支払人を設定します。

パラメータ:
payer - 支払人

setShipTo

public void setShipTo(String shipTo)
出荷先を設定します。

パラメータ:
shipTo - 出荷先

setRefDoc

public void setRefDoc(String refDoc)
参照伝票番号を設定します。

パラメータ:
refDoc - 参照伝票番号

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setReqQty

public void setReqQty(String reqQty)
累積受注数量 (販売単位)を設定します。

パラメータ:
reqQty - 累積受注数量 (販売単位)

setCurrency

public void setCurrency(String currency)
販売伝票通貨を設定します。

パラメータ:
currency - 販売伝票通貨

setShortText

public void setShortText(String shortText)
テキスト (短): 受注明細を設定します。

パラメータ:
shortText - テキスト (短): 受注明細

setTaxcl1Mat

public void setTaxcl1Mat(String taxcl1Mat)
品目の税分類を設定します。

パラメータ:
taxcl1Mat - 品目の税分類

setRefItem

public void setRefItem(String refItem)
参照明細番号を設定します。

パラメータ:
refItem - 参照明細番号

setStatGroup

public void setStatGroup(String statGroup)
統計グループを設定します。

パラメータ:
statGroup - 統計グループ

setNoMatmast

public void setNoMatmast(String noMatmast)
品目マスタ確認禁止を設定します。

パラメータ:
noMatmast - 品目マスタ確認禁止

setAddrNo

public void setAddrNo(String addrNo)
アドレス: アドレス番号を設定します。

パラメータ:
addrNo - アドレス: アドレス番号

setTitle

public void setTitle(String title)
敬称を設定します。

パラメータ:
title - 敬称

setName

public void setName(String name)
名称 1を設定します。

パラメータ:
name - 名称 1

setName2

public void setName2(String name2)
名称 2を設定します。

パラメータ:
name2 - 名称 2

setPostlCode

public void setPostlCode(String postlCode)
郵便番号を設定します。

パラメータ:
postlCode - 郵便番号

setConsumctry

public void setConsumctry(String consumctry)
消費者の国キーを設定します。

パラメータ:
consumctry - 消費者の国キー

setCity

public void setCity(String city)
市区町村を設定します。

パラメータ:
city - 市区町村

setDistrict

public void setDistrict(String district)
所在地を設定します。

パラメータ:
district - 所在地

setStreet

public void setStreet(String street)
地名/番地-号を設定します。

パラメータ:
street - 地名/番地-号

setRegion

public void setRegion(String region)
地域 (都道府県)を設定します。

パラメータ:
region - 地域 (都道府県)

setProdHier

public void setProdHier(String prodHier)
品目階層を設定します。

パラメータ:
prodHier - 品目階層

setSalesUnit

public void setSalesUnit(String salesUnit)
販売単位を設定します。

パラメータ:
salesUnit - 販売単位

setProfitCtr

public void setProfitCtr(String profitCtr)
利益センタを設定します。

パラメータ:
profitCtr - 利益センタ

setTaxjurcode

public void setTaxjurcode(String taxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
taxjurcode - 税計算管轄コード - 税管轄コード

setPurchOrd

public void setPurchOrd(String purchOrd)
出荷先発注番号を設定します。

パラメータ:
purchOrd - 出荷先発注番号

setDocNumber

public void setDocNumber(String docNumber)
販売伝票を設定します。

パラメータ:
docNumber - 販売伝票

setItmNumber

public void setItmNumber(String itmNumber)
販売伝票明細を設定します。

パラメータ:
itmNumber - 販売伝票明細

setOrigindoc

public void setOrigindoc(String origindoc)
開始伝票を設定します。

パラメータ:
origindoc - 開始伝票

setItem

public void setItem(String item)
開始明細を設定します。

パラメータ:
item - 開始明細

setCreatedBy

public void setCreatedBy(String createdBy)
オブジェクト登録者名を設定します。

パラメータ:
createdBy - オブジェクト登録者名

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setIncoterms1

public void setIncoterms1(String incoterms1)
インコタームズ (1)を設定します。

パラメータ:
incoterms1 - インコタームズ (1)

setIncoterms2

public void setIncoterms2(String incoterms2)
インコタームズ (2)を設定します。

パラメータ:
incoterms2 - インコタームズ (2)

setExchangeRate

public void setExchangeRate(String exchangeRate)
価格設定/統計用換算レートを設定します。

パラメータ:
exchangeRate - 価格設定/統計用換算レート

setPaymentTerms

public void setPaymentTerms(String paymentTerms)
支払条件キーを設定します。

パラメータ:
paymentTerms - 支払条件キー

setHgLvItem

public void setHgLvItem(String hgLvItem)
BOM 構成の上位レベル明細を設定します。

パラメータ:
hgLvItem - BOM 構成の上位レベル明細

setRefDocCa

public void setRefDocCa(String refDocCa)
先行販売管理伝票の伝票カテゴリを設定します。

パラメータ:
refDocCa - 先行販売管理伝票の伝票カテゴリ

setOrderid

public void setOrderid(String orderid)
指図番号を設定します。

パラメータ:
orderid - 指図番号

setProfitSegmNo

public void setProfitSegmNo(String profitSegmNo)
収益性セグメント番号 (CO-PA)を設定します。

パラメータ:
profitSegmNo - 収益性セグメント番号 (CO-PA)

setCostcenter

public void setCostcenter(String costcenter)
原価センタを設定します。

パラメータ:
costcenter - 原価センタ

setWbsElem

public void setWbsElem(String wbsElem)
WBS 要素を設定します。

パラメータ:
wbsElem - WBS 要素

setTaxDepartCty

public void setTaxDepartCty(String taxDepartCty)
税出荷国を設定します。

パラメータ:
taxDepartCty - 税出荷国

setTaxDestCty

public void setTaxDestCty(String taxDestCty)
税仕向国を設定します。

パラメータ:
taxDestCty - 税仕向国

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BillingDocCreateMultiple (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス BillingDocCreateMultiple

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
BillingDocCreateMultipleController
public class BillingDocCreateMultiple
extends UpdateController
implements Serializable

請求伝票登録情報クラス
機能は以下の通り

  • 請求伝票登録情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
BillingDocCreateMultiple()
請求伝票登録情報を作成します。
BillingDocCreateMultiple(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。
BillingDocCreateMultiple(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
メソッドの概要
List | getBillingDataInList() 処理予定明細データのテーブルを取得します。
List | getCCardDataInList() 処理予定支払方法のテーブルを取得します。
List | getConditionDataInList() 処理予定条件のテーブルを取得します。
CreatorDataIn | getCreatorDataIn() 取り込まれる日付の順序を取得します。
List | getErrorsList() 前明細の不正処理に関する情報を取得します。
List | getSuccessList() 正常に処理された明細のテーブルを取得します。
String | getTestrun() シミュレーション実行 ('X')、更新実行 (' ')を取得します。
List | getTextDataInList() 請求インタフェースの通信構造テキストを取得します。
void | setBillingDataInList(List billingDataInList) 処理予定明細データのテーブルを設定します。
void | setCCardDataInList(List cCardDataInList) 処理予定支払方法のテーブルを設定します。
void | setConditionDataInList(List conditionDataInList) 処理予定条件のテーブルを設定します。
void | setCreatorDataIn(CreatorDataIn creatorDataIn) 取り込まれる日付の順序を設定します。
void | setErrorsList(List errorsList) 前明細の不正処理に関する情報を設定します。
void | setExportParam(BapiController bapiController) 請求伝票に登録する値ををセットします。
void | setImportParam(BapiController bapiController) 請求伝票に登録する値ををセットします。
void | setSuccessList(List successList) 正常に処理された明細のテーブルを設定します。
void | setTestrun(String testrun) シミュレーション実行 ('X')、更新実行 (' ')を設定します。
void | setTextDataInList(List textDataInList) 請求インタフェースの通信構造テキストを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BillingDocCreateMultiple

public BillingDocCreateMultiple()
請求伝票登録情報を作成します。

BillingDocCreateMultiple

public BillingDocCreateMultiple(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。

パラメータ:
conectionManager - コネクションマネージャー

BillingDocCreateMultiple

public BillingDocCreateMultiple(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
請求伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
請求伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getTestrun

public String getTestrun()
シミュレーション実行 ('X')、更新実行 (' ')を取得します。

戻り値:
testrun シミュレーション実行 ('X')、更新実行 (' ')

getCreatorDataIn

public CreatorDataIn getCreatorDataIn()
取り込まれる日付の順序を取得します。

戻り値:
creatorDataIn 取り込まれる日付の順序

getBillingDataInList

public List getBillingDataInList()
処理予定明細データのテーブルを取得します。

戻り値:
billingDataInList 処理予定明細データのテーブル

getCCardDataInList

public List getCCardDataInList()
処理予定支払方法のテーブルを取得します。

戻り値:
cCardDataInList 処理予定支払方法のテーブル

getConditionDataInList

public List getConditionDataInList()
処理予定条件のテーブルを取得します。

戻り値:
conditionDataInList 処理予定条件のテーブル

getErrorsList

public List getErrorsList()
前明細の不正処理に関する情報を取得します。

戻り値:
errorsList 前明細の不正処理に関する情報

getSuccessList

public List getSuccessList()
正常に処理された明細のテーブルを取得します。

戻り値:
successList 正常に処理された明細のテーブル

getTextDataInList

public List getTextDataInList()
請求インタフェースの通信構造テキストを取得します。

戻り値:
textDataInList 請求インタフェースの通信構造テキスト

setTestrun

public void setTestrun(String testrun)
シミュレーション実行 ('X')、更新実行 (' ')を設定します。

パラメータ:
testrun - シミュレーション実行 ('X')、更新実行 (' ')

setCreatorDataIn

public void setCreatorDataIn(CreatorDataIn creatorDataIn)
取り込まれる日付の順序を設定します。

パラメータ:
creatorDataIn - 取り込まれる日付の順序

setBillingDataInList

public void setBillingDataInList(List billingDataInList)
処理予定明細データのテーブルを設定します。

パラメータ:
billingDataInList - 処理予定明細データのテーブル

setCCardDataInList

public void setCCardDataInList(List cCardDataInList)
処理予定支払方法のテーブルを設定します。

パラメータ:
cCardDataInList - 処理予定支払方法のテーブル

setConditionDataInList

public void setConditionDataInList(List conditionDataInList)
処理予定条件のテーブルを設定します。

パラメータ:
conditionDataInList - 処理予定条件のテーブル

setErrorsList

public void setErrorsList(List errorsList)
前明細の不正処理に関する情報を設定します。

パラメータ:
errorsList - 前明細の不正処理に関する情報

setSuccessList

public void setSuccessList(List successList)
正常に処理された明細のテーブルを設定します。

パラメータ:
successList - 正常に処理された明細のテーブル

setTextDataInList

public void setTextDataInList(List textDataInList)
請求インタフェースの通信構造テキストを設定します。

パラメータ:
textDataInList - 請求インタフェースの通信構造テキスト

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CCardDataIn (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス CCardDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn
すべての実装インタフェース:
Serializable
public class CCardDataIn
extends Object
implements Serializable

処理予定支払方法のテーブル情報クラス
機能は以下の通り

  • 処理予定支払方法のテーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CCardDataIn()
処理予定支払方法のテーブル情報を作成します。
CCardDataIn(int index)
処理予定支払方法のテーブル情報を作成します。
メソッドの概要
String | getAuthamount() 支払カード: 承認額を取得します。
String | getAuthDate() 支払カード: 承認日を取得します。
String | getAuthFlag() 支払カード: 振替権限を取得します。
String | getAuthRefno() 支払カード: 決済代行会社の権限参照コードを取得します。
String | getAuthTime() 支払カード: 承認時刻を取得します。
String | getBillPlan() 請求計画番号を取得します。
String | getBillPlani() 明細: 請求計画/支払計画/支払カードを取得します。
String | getBillValue() 請求金額: 請求計画に請求日付が指定されている場合を取得します。
String | getCcAuthNo() 支払カード: 承認番号を取得します。
String | getCcLocId() 支払カード: トランザクション (入庫時点)を取得します。
String | getCcName() 支払カード: カード所有者の氏名を取得します。
String | getCcNumber() 支払カード: カード番号を取得します。
String | getCcSeqNo() 支払カード: 支払カード - 接尾辞を取得します。
String | getCcSettled() 支払カード: 決済終了を取得します。
String | getCcType() 支払カードタイプ: カードタイプを取得します。
String | getCcValidF() 支払カード: 使用有効開始日付を取得します。
String | getCcValidT() 支払カード: 有効終了日を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO コード通貨を取得します。
String | getDataorigin() 支払カード: 入力モードを取得します。
int | getIndex() レコード番号を取得します｡
String | getMerchidcl() 支払カード: 決済代行会社のマーチャント IDを取得します。
String | getPaytype() 支払手段: 支払カード計画の明細分類を取得します。
String | getTerminal() 支払カード: 端末を取得します。
void | setAuthamount(String authamount) 支払カード: 承認額を設定します。
void | setAuthDate(String authDate) 支払カード: 承認日を設定します。
void | setAuthFlag(String authFlag) 支払カード: 振替権限を設定します。
void | setAuthRefno(String authRefno) 支払カード: 決済代行会社の権限参照コードを設定します。
void | setAuthTime(String authTime) 支払カード: 承認時刻を設定します。
void | setBillPlan(String billPlan) 請求計画番号を設定します。
void | setBillPlani(String billPlani) 明細: 請求計画/支払計画/支払カードを設定します。
void | setBillValue(String billValue) 請求金額: 請求計画に請求日付が指定されている場合を設定します。
void | setCcAuthNo(String ccAuthNo) 支払カード: 承認番号を設定します。
void | setCcLocId(String ccLocId) 支払カード: トランザクション (入庫時点)を設定します。
void | setCcName(String ccName) 支払カード: カード所有者の氏名を設定します。
void | setCcNumber(String ccNumber) 支払カード: カード番号を設定します。
void | setCcSeqNo(String ccSeqNo) 支払カード: 支払カード - 接尾辞を設定します。
void | setCcSettled(String ccSettled) 支払カード: 決済終了を設定します。
void | setCcType(String ccType) 支払カードタイプ: カードタイプを設定します。
void | setCcValidF(String ccValidF) 支払カード: 使用有効開始日付を設定します。
void | setCcValidT(String ccValidT) 支払カード: 有効終了日を設定します。
void | setCurrency(String currency) 通貨コードを設定します。
void | setCurrencyIso(String currencyIso) ISO コード通貨を設定します。
void | setDataorigin(String dataorigin) 支払カード: 入力モードを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMerchidcl(String merchidcl) 支払カード: 決済代行会社のマーチャント IDを設定します。
void | setPaytype(String paytype) 支払手段: 支払カード計画の明細分類を設定します。
void | setTerminal(String terminal) 支払カード: 端末を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CCardDataIn

public CCardDataIn()
処理予定支払方法のテーブル情報を作成します。

CCardDataIn

public CCardDataIn(int index)
処理予定支払方法のテーブル情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPaytype

public String getPaytype()
支払手段: 支払カード計画の明細分類を取得します。

戻り値:
paytype 支払手段: 支払カード計画の明細分類

getCcType

public String getCcType()
支払カードタイプ: カードタイプを取得します。

戻り値:
ccType 支払カードタイプ: カードタイプ

getCcNumber

public String getCcNumber()
支払カード: カード番号を取得します。

戻り値:
ccNumber 支払カード: カード番号

getCcSeqNo

public String getCcSeqNo()
支払カード: 支払カード - 接尾辞を取得します。

戻り値:
ccSeqNo 支払カード: 支払カード - 接尾辞

getCcValidF

public String getCcValidF()
支払カード: 使用有効開始日付を取得します。

戻り値:
ccValidF 支払カード: 使用有効開始日付

getCcValidT

public String getCcValidT()
支払カード: 有効終了日を取得します。

戻り値:
ccValidT 支払カード: 有効終了日

getCcName

public String getCcName()
支払カード: カード所有者の氏名を取得します。

戻り値:
ccName 支払カード: カード所有者の氏名

getAuthamount

public String getAuthamount()
支払カード: 承認額を取得します。

戻り値:
authamount 支払カード: 承認額

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
currency 通貨コード

getCurrencyIso

public String getCurrencyIso()
ISO コード通貨を取得します。

戻り値:
currencyIso ISO コード通貨

getAuthFlag

public String getAuthFlag()
支払カード: 振替権限を取得します。

戻り値:
authFlag 支払カード: 振替権限

getAuthDate

public String getAuthDate()
支払カード: 承認日を取得します。

戻り値:
authDate 支払カード: 承認日

getAuthTime

public String getAuthTime()
支払カード: 承認時刻を取得します。

戻り値:
authTime 支払カード: 承認時刻

getCcAuthNo

public String getCcAuthNo()
支払カード: 承認番号を取得します。

戻り値:
ccAuthNo 支払カード: 承認番号

getAuthRefno

public String getAuthRefno()
支払カード: 決済代行会社の権限参照コードを取得します。

戻り値:
authRefno 支払カード: 決済代行会社の権限参照コード

getMerchidcl

public String getMerchidcl()
支払カード: 決済代行会社のマーチャント IDを取得します。

戻り値:
merchidcl 支払カード: 決済代行会社のマーチャント ID

getTerminal

public String getTerminal()
支払カード: 端末を取得します。

戻り値:
terminal 支払カード: 端末

getDataorigin

public String getDataorigin()
支払カード: 入力モードを取得します。

戻り値:
dataorigin 支払カード: 入力モード

getCcSettled

public String getCcSettled()
支払カード: 決済終了を取得します。

戻り値:
ccSettled 支払カード: 決済終了

getCcLocId

public String getCcLocId()
支払カード: トランザクション (入庫時点)を取得します。

戻り値:
ccLocId 支払カード: トランザクション (入庫時点)

getBillPlan

public String getBillPlan()
請求計画番号を取得します。

戻り値:
billPlan 請求計画番号

getBillPlani

public String getBillPlani()
明細: 請求計画/支払計画/支払カードを取得します。

戻り値:
billPlani 明細: 請求計画/支払計画/支払カード

getBillValue

public String getBillValue()
請求金額: 請求計画に請求日付が指定されている場合を取得します。

戻り値:
billValue 請求金額: 請求計画に請求日付が指定されている場合

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setPaytype

public void setPaytype(String paytype)
支払手段: 支払カード計画の明細分類を設定します。

パラメータ:
paytype - 支払手段: 支払カード計画の明細分類

setCcType

public void setCcType(String ccType)
支払カードタイプ: カードタイプを設定します。

パラメータ:
ccType - 支払カードタイプ: カードタイプ

setCcNumber

public void setCcNumber(String ccNumber)
支払カード: カード番号を設定します。

パラメータ:
ccNumber - 支払カード: カード番号

setCcSeqNo

public void setCcSeqNo(String ccSeqNo)
支払カード: 支払カード - 接尾辞を設定します。

パラメータ:
ccSeqNo - 支払カード: 支払カード - 接尾辞

setCcValidF

public void setCcValidF(String ccValidF)
支払カード: 使用有効開始日付を設定します。

パラメータ:
ccValidF - 支払カード: 使用有効開始日付

setCcValidT

public void setCcValidT(String ccValidT)
支払カード: 有効終了日を設定します。

パラメータ:
ccValidT - 支払カード: 有効終了日

setCcName

public void setCcName(String ccName)
支払カード: カード所有者の氏名を設定します。

パラメータ:
ccName - 支払カード: カード所有者の氏名

setAuthamount

public void setAuthamount(String authamount)
支払カード: 承認額を設定します。

パラメータ:
authamount - 支払カード: 承認額

setCurrency

public void setCurrency(String currency)
通貨コードを設定します。

パラメータ:
currency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String currencyIso)
ISO コード通貨を設定します。

パラメータ:
currencyIso - ISO コード通貨

setAuthFlag

public void setAuthFlag(String authFlag)
支払カード: 振替権限を設定します。

パラメータ:
authFlag - 支払カード: 振替権限

setAuthDate

public void setAuthDate(String authDate)
支払カード: 承認日を設定します。

パラメータ:
authDate - 支払カード: 承認日

setAuthTime

public void setAuthTime(String authTime)
支払カード: 承認時刻を設定します。

パラメータ:
authTime - 支払カード: 承認時刻

setCcAuthNo

public void setCcAuthNo(String ccAuthNo)
支払カード: 承認番号を設定します。

パラメータ:
ccAuthNo - 支払カード: 承認番号

setAuthRefno

public void setAuthRefno(String authRefno)
支払カード: 決済代行会社の権限参照コードを設定します。

パラメータ:
authRefno - 支払カード: 決済代行会社の権限参照コード

setMerchidcl

public void setMerchidcl(String merchidcl)
支払カード: 決済代行会社のマーチャント IDを設定します。

パラメータ:
merchidcl - 支払カード: 決済代行会社のマーチャント ID

setTerminal

public void setTerminal(String terminal)
支払カード: 端末を設定します。

パラメータ:
terminal - 支払カード: 端末

setDataorigin

public void setDataorigin(String dataorigin)
支払カード: 入力モードを設定します。

パラメータ:
dataorigin - 支払カード: 入力モード

setCcSettled

public void setCcSettled(String ccSettled)
支払カード: 決済終了を設定します。

パラメータ:
ccSettled - 支払カード: 決済終了

setCcLocId

public void setCcLocId(String ccLocId)
支払カード: トランザクション (入庫時点)を設定します。

パラメータ:
ccLocId - 支払カード: トランザクション (入庫時点)

setBillPlan

public void setBillPlan(String billPlan)
請求計画番号を設定します。

パラメータ:
billPlan - 請求計画番号

setBillPlani

public void setBillPlani(String billPlani)
明細: 請求計画/支払計画/支払カードを設定します。

パラメータ:
billPlani - 明細: 請求計画/支払計画/支払カード

setBillValue

public void setBillValue(String billValue)
請求金額: 請求計画に請求日付が指定されている場合を設定します。

パラメータ:
billValue - 請求金額: 請求計画に請求日付が指定されている場合

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ConditionDataIn (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス ConditionDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn
すべての実装インタフェース:
Serializable
public class ConditionDataIn
extends Object
implements Serializable

処理予定条件のテーブル情報クラス
機能は以下の通り

  • 処理予定条件のテーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ConditionDataIn()
処理予定条件のテーブル情報を作成します。
ConditionDataIn(int index)
処理予定条件のテーブル情報を作成します。
メソッドの概要
String | getCondCurr() 条件通貨 (累積項目用)を取得します。
String | getCondDUnt() 伝票の条件単位を取得します。
String | getCondPUnt() 価格条件単位を取得します。
String | getCondType() 条件タイプを取得します。
String | getCondValue() 条件金額/率を取得します。
String | getDataIndex() 別の構成のテーブル入力へのポインタを取得します。
int | getIndex() レコード番号を取得します｡
void | setCondCurr(String condCurr) 条件通貨 (累積項目用)を設定します。
void | setCondDUnt(String condDUnt) 伝票の条件単位を設定します。
void | setCondPUnt(String condPUnt) 価格条件単位を設定します。
void | setCondType(String condType) 条件タイプを設定します。
void | setCondValue(String condValue) 条件金額/率を設定します。
void | setDataIndex(String dataIndex) 別の構成のテーブル入力へのポインタを設定します。
void | setIndex(int index) レコード番号を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ConditionDataIn

public ConditionDataIn()
処理予定条件のテーブル情報を作成します。

ConditionDataIn

public ConditionDataIn(int index)
処理予定条件のテーブル情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getDataIndex

public String getDataIndex()
別の構成のテーブル入力へのポインタを取得します。

戻り値:
dataIndex 別の構成のテーブル入力へのポインタ

getCondType

public String getCondType()
条件タイプを取得します。

戻り値:
condType 条件タイプ

getCondValue

public String getCondValue()
条件金額/率を取得します。

戻り値:
condValue 条件金額/率

getCondCurr

public String getCondCurr()
条件通貨 (累積項目用)を取得します。

戻り値:
condCurr 条件通貨 (累積項目用)

getCondPUnt

public String getCondPUnt()
価格条件単位を取得します。

戻り値:
condPUnt 価格条件単位

getCondDUnt

public String getCondDUnt()
伝票の条件単位を取得します。

戻り値:
condDUnt 伝票の条件単位

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setDataIndex

public void setDataIndex(String dataIndex)
別の構成のテーブル入力へのポインタを設定します。

パラメータ:
dataIndex - 別の構成のテーブル入力へのポインタ

setCondType

public void setCondType(String condType)
条件タイプを設定します。

パラメータ:
condType - 条件タイプ

setCondValue

public void setCondValue(String condValue)
条件金額/率を設定します。

パラメータ:
condValue - 条件金額/率

setCondCurr

public void setCondCurr(String condCurr)
条件通貨 (累積項目用)を設定します。

パラメータ:
condCurr - 条件通貨 (累積項目用)

setCondPUnt

public void setCondPUnt(String condPUnt)
価格条件単位を設定します。

パラメータ:
condPUnt - 価格条件単位

setCondDUnt

public void setCondDUnt(String condDUnt)
伝票の条件単位を設定します。

パラメータ:
condDUnt - 伝票の条件単位

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CreatorDataIn (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス CreatorDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn
すべての実装インタフェース:
Serializable
public class CreatorDataIn
extends Object
implements Serializable

取り込まれる日付の順序情報クラス
機能は以下の通り

  • 取り込まれる日付の順序情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CreatorDataIn()
取り込まれる日付の順序情報を作成します。
メソッドの概要
String | getCreatedBy() オブジェクト登録者名を取得します。
String | getCreatedOn() レコード登録日を取得します。
void | setCreatedBy(String createdBy) オブジェクト登録者名を設定します。
void | setCreatedOn(String createdOn) レコード登録日を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CreatorDataIn

public CreatorDataIn()
取り込まれる日付の順序情報を作成します。

メソッドの詳細

getCreatedBy

public String getCreatedBy()
オブジェクト登録者名を取得します。

戻り値:
createdBy オブジェクト登録者名

getCreatedOn

public String getCreatedOn()
レコード登録日を取得します。

戻り値:
createdOn レコード登録日

setCreatedBy

public void setCreatedBy(String createdBy)
オブジェクト登録者名を設定します。

パラメータ:
createdBy - オブジェクト登録者名

setCreatedOn

public void setCreatedOn(String createdOn)
レコード登録日を設定します。

パラメータ:
createdOn - レコード登録日

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Errors (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス Errors

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors
すべての実装インタフェース:
Serializable
public class Errors
extends Object
implements Serializable

前明細の不正処理に関する情報情報クラス
機能は以下の通り

  • 前明細の不正処理に関する情報情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Errors()
前明細の不正処理に関する情報情報を作成します。
Errors(int index)
前明細の不正処理に関する情報情報を作成します。
メソッドの概要
String | getId() メッセージ、メッセージクラスを取得します。
int | getIndex() レコード番号を取得します｡
String | getLogMsgNo() アプリケーションログ: メッセージシリアル番号を取得します。
String | getLogNo() アプリケーションログ: ログ番号を取得します。
String | getMessage() メッセージテキストを取得します。
String | getMessageV1() メッセージ、メッセージ変数を取得します。
String | getMessageV2() メッセージ、メッセージ変数を取得します。
String | getMessageV3() メッセージ、メッセージ変数を取得します。
String | getMessageV4() メッセージ、メッセージ変数を取得します。
String | getNumber() メッセージ、メッセージ番号を取得します。
String | getRefDoc() 参照伝票番号を取得します。
String | getRefDocItem() 参照明細番号を取得します。
String | getType() メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を取得します。
void | setId(String id) メッセージ、メッセージクラスを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLogMsgNo(String logMsgNo) アプリケーションログ: メッセージシリアル番号を設定します。
void | setLogNo(String logNo) アプリケーションログ: ログ番号を設定します。
void | setMessage(String message) メッセージテキストを設定します。
void | setMessageV1(String messageV1) メッセージ、メッセージ変数を設定します。
void | setMessageV2(String messageV2) メッセージ、メッセージ変数を設定します。
void | setMessageV3(String messageV3) メッセージ、メッセージ変数を設定します。
void | setMessageV4(String messageV4) メッセージ、メッセージ変数を設定します。
void | setNumber(String number) メッセージ、メッセージ番号を設定します。
void | setRefDoc(String refDoc) 参照伝票番号を設定します。
void | setRefDocItem(String refDocItem) 参照明細番号を設定します。
void | setType(String type) メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Errors

public Errors()
前明細の不正処理に関する情報情報を作成します。

Errors

public Errors(int index)
前明細の不正処理に関する情報情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getRefDoc

public String getRefDoc()
参照伝票番号を取得します。

戻り値:
refDoc 参照伝票番号

getRefDocItem

public String getRefDocItem()
参照明細番号を取得します。

戻り値:
refDocItem 参照明細番号

getType

public String getType()
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を取得します。

戻り値:
type メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了

getId

public String getId()
メッセージ、メッセージクラスを取得します。

戻り値:
id メッセージ、メッセージクラス

getNumber

public String getNumber()
メッセージ、メッセージ番号を取得します。

戻り値:
number メッセージ、メッセージ番号

getMessage

public String getMessage()
メッセージテキストを取得します。

戻り値:
message メッセージテキスト

getLogNo

public String getLogNo()
アプリケーションログ: ログ番号を取得します。

戻り値:
logNo アプリケーションログ: ログ番号

getLogMsgNo

public String getLogMsgNo()
アプリケーションログ: メッセージシリアル番号を取得します。

戻り値:
logMsgNo アプリケーションログ: メッセージシリアル番号

getMessageV1

public String getMessageV1()
メッセージ、メッセージ変数を取得します。

戻り値:
messageV1 メッセージ、メッセージ変数

getMessageV2

public String getMessageV2()
メッセージ、メッセージ変数を取得します。

戻り値:
messageV2 メッセージ、メッセージ変数

getMessageV3

public String getMessageV3()
メッセージ、メッセージ変数を取得します。

戻り値:
messageV3 メッセージ、メッセージ変数

getMessageV4

public String getMessageV4()
メッセージ、メッセージ変数を取得します。

戻り値:
messageV4 メッセージ、メッセージ変数

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setRefDoc

public void setRefDoc(String refDoc)
参照伝票番号を設定します。

パラメータ:
refDoc - 参照伝票番号

setRefDocItem

public void setRefDocItem(String refDocItem)
参照明細番号を設定します。

パラメータ:
refDocItem - 参照明細番号

setType

public void setType(String type)
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を設定します。

パラメータ:
type - メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了

setId

public void setId(String id)
メッセージ、メッセージクラスを設定します。

パラメータ:
id - メッセージ、メッセージクラス

setNumber

public void setNumber(String number)
メッセージ、メッセージ番号を設定します。

パラメータ:
number - メッセージ、メッセージ番号

setMessage

public void setMessage(String message)
メッセージテキストを設定します。

パラメータ:
message - メッセージテキスト

setLogNo

public void setLogNo(String logNo)
アプリケーションログ: ログ番号を設定します。

パラメータ:
logNo - アプリケーションログ: ログ番号

setLogMsgNo

public void setLogMsgNo(String logMsgNo)
アプリケーションログ: メッセージシリアル番号を設定します。

パラメータ:
logMsgNo - アプリケーションログ: メッセージシリアル番号

setMessageV1

public void setMessageV1(String messageV1)
メッセージ、メッセージ変数を設定します。

パラメータ:
messageV1 - メッセージ、メッセージ変数

setMessageV2

public void setMessageV2(String messageV2)
メッセージ、メッセージ変数を設定します。

パラメータ:
messageV2 - メッセージ、メッセージ変数

setMessageV3

public void setMessageV3(String messageV3)
メッセージ、メッセージ変数を設定します。

パラメータ:
messageV3 - メッセージ、メッセージ変数

setMessageV4

public void setMessageV4(String messageV4)
メッセージ、メッセージ変数を設定します。

パラメータ:
messageV4 - メッセージ、メッセージ変数

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス
BillingDataIn
BillingDocCreateMultiple
CCardDataIn
ConditionDataIn
CreatorDataIn
Errors
ParamBillingDataIn
ParamCCardDataIn
ParamConditionDataIn
ParamCreatorDataIn
ParamErrors
ParamTextDataIn
TextDataIn


jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple

クラスの概要
BillingDataIn | 処理予定明細データのテーブル情報クラス 機能は以下の通り 処理予定明細データのテーブル情報を保持します。
BillingDocCreateMultiple | 請求伝票登録情報クラス 機能は以下の通り 請求伝票登録情報を保持します。
CCardDataIn | 処理予定支払方法のテーブル情報クラス 機能は以下の通り 処理予定支払方法のテーブル情報を保持します。
ConditionDataIn | 処理予定条件のテーブル情報クラス 機能は以下の通り 処理予定条件のテーブル情報を保持します。
CreatorDataIn | 取り込まれる日付の順序情報クラス 機能は以下の通り 取り込まれる日付の順序情報を保持します。
Errors | 前明細の不正処理に関する情報情報クラス 機能は以下の通り 前明細の不正処理に関する情報情報を保持します。
ParamBillingDataIn | 処理予定明細データのテーブルパラメータ設定クラス 機能は以下の通り 処理予定明細データのテーブルパラメータを設定します。
ParamCCardDataIn | 処理予定支払方法のテーブルパラメータ設定クラス 機能は以下の通り 処理予定支払方法のテーブルパラメータを設定します。
ParamConditionDataIn | 処理予定条件のテーブルパラメータ設定クラス 機能は以下の通り 処理予定条件のテーブルのパラメータを設定します。
ParamCreatorDataIn | 取り込まれる日付の順序パラメータ設定クラス 機能は以下の通り 取り込まれる日付の順序のパラメータを設定します。
ParamErrors | 前明細の不正処理に関する情報パラメータ設定クラス 機能は以下の通り 前明細の不正処理に関する情報のパラメータを設定します。
ParamTextDataIn | 請求インタフェースの通信構造テキストパラメータ設定クラス 機能は以下の通り 請求インタフェースの通信構造テキストのパラメータを設定します。
TextDataIn | 請求インタフェースの通信構造テキスト情報クラス 機能は以下の通り 請求インタフェースの通信構造テキスト情報を保持します。


jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple のクラス
BillingDocCreateMultiple
請求伝票登録情報クラス
機能は以下の通り
請求伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple により使用される jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple のクラス
CreatorDataIn
取り込まれる日付の順序情報クラス
機能は以下の通り
取り込まれる日付の順序情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamBillingDataIn (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス ParamBillingDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn
すべての実装インタフェース:
Serializable
public final class ParamBillingDataIn
extends Object
implements Serializable

処理予定明細データのテーブルパラメータ設定クラス
機能は以下の通り

  • 処理予定明細データのテーブルパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List billingDataInList) table(Export)情報から処理予定明細データのテーブルの値をセットします。
static void | setImportParam(BapiController bapiController, List billingDataInList) 処理予定明細データのテーブルの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List billingDataInList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
処理予定明細データのテーブルの値をセットします。

パラメータ:
bapiController - BapiController
billingDataInList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List billingDataInList)
                           throws SAPGeneralSystemException
table(Export)情報から処理予定明細データのテーブルの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
billingDataInList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCCardDataIn (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス ParamCCardDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn
すべての実装インタフェース:
Serializable
public final class ParamCCardDataIn
extends Object
implements Serializable

処理予定支払方法のテーブルパラメータ設定クラス
機能は以下の通り

  • 処理予定支払方法のテーブルパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List cCardDataInList) table(Export)情報から理予定支払方法のテーブルの値をセットします。
static void | setImportParam(BapiController bapiController, List cCardDataInList) 処理予定支払方法のテーブルの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List cCardDataInList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
処理予定支払方法のテーブルの値をセットします。

パラメータ:
bapiController - BapiController
cCardDataInList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List cCardDataInList)
                           throws SAPGeneralSystemException
table(Export)情報から理予定支払方法のテーブルの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
cCardDataInList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamConditionDataIn (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス ParamConditionDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn
すべての実装インタフェース:
Serializable
public final class ParamConditionDataIn
extends Object
implements Serializable

処理予定条件のテーブルパラメータ設定クラス
機能は以下の通り

  • 処理予定条件のテーブルのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List conditionDataInList) table(Export)情報から処理予定条件のテーブルの値をセットします。
static void | setImportParam(BapiController bapiController, List conditionDataInList) 処理予定条件のテーブルの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List conditionDataInList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
処理予定条件のテーブルの値をセットします。

パラメータ:
bapiController - BapiController
conditionDataInList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List conditionDataInList)
                           throws SAPGeneralSystemException
table(Export)情報から処理予定条件のテーブルの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
conditionDataInList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCreatorDataIn (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス ParamCreatorDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn
すべての実装インタフェース:
Serializable
public final class ParamCreatorDataIn
extends Object
implements Serializable

取り込まれる日付の順序パラメータ設定クラス
機能は以下の通り

  • 取り込まれる日付の順序のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, CreatorDataIn creatorDataIn)
取り込まれる日付の順序の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  CreatorDataIn creatorDataIn)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
取り込まれる日付の順序の値をセットします。

パラメータ:
bapiController - BapiController
creatorDataIn - CreatorDataIn
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamErrors (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス ParamErrors

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors
すべての実装インタフェース:
Serializable
public final class ParamErrors
extends Object
implements Serializable

前明細の不正処理に関する情報パラメータ設定クラス
機能は以下の通り

  • 前明細の不正処理に関する情報のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List errorsList) table(Export)情報から前明細の不正処理に関する情報の値をセットします。
static void | setImportParam(BapiController bapiController, List errorsList) 前明細の不正処理に関する情報の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List errorsList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
前明細の不正処理に関する情報の値をセットします。

パラメータ:
bapiController - BapiController
errorsList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List errorsList)
                           throws SAPGeneralSystemException
table(Export)情報から前明細の不正処理に関する情報の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
errorsList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamTextDataIn (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス ParamTextDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn
すべての実装インタフェース:
Serializable
public final class ParamTextDataIn
extends Object
implements Serializable

請求インタフェースの通信構造テキストパラメータ設定クラス
機能は以下の通り

  • 請求インタフェースの通信構造テキストのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List textDataInList) table(Export)情報から請求インタフェースの通信構造テキストの値をセットします。
static void | setImportParam(BapiController bapiController, List textDataInList) 請求インタフェースの通信構造テキストの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List textDataInList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
請求インタフェースの通信構造テキストの値をセットします。

パラメータ:
bapiController - BapiController
textDataInList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List textDataInList)
                           throws SAPGeneralSystemException
table(Export)情報から請求インタフェースの通信構造テキストの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
textDataInList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TextDataIn (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス TextDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn
すべての実装インタフェース:
Serializable
public class TextDataIn
extends Object
implements Serializable

請求インタフェースの通信構造テキスト情報クラス
機能は以下の通り

  • 請求インタフェースの通信構造テキスト情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
TextDataIn()
請求インタフェースの通信構造テキスト情報を作成します。
TextDataIn(int index)
請求インタフェースの通信構造テキスト情報を作成します。
メソッドの概要
String | getApplobject() テキスト: アプリケーションオブジェクトを取得します。
String | getFormatCol() タグ列を取得します。
int | getIndex() レコード番号を取得します｡
String | getLangu() 言語キーを取得します。
String | getRefDoc() 参照伝票番号を取得します。
String | getRefItem() 参照明細番号を取得します。
String | getTextId() テキスト IDを取得します。
String | getTextLine() テキスト行を取得します。
void | setApplobject(String applobject) テキスト: アプリケーションオブジェクトを設定します。
void | setFormatCol(String formatCol) タグ列を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLangu(String langu) 言語キーを設定します。
void | setRefDoc(String refDoc) 参照伝票番号を設定します。
void | setRefItem(String refItem) 参照明細番号を設定します。
void | setTextId(String textId) テキスト IDを設定します。
void | setTextLine(String textLine) テキスト行を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

TextDataIn

public TextDataIn()
請求インタフェースの通信構造テキスト情報を作成します。

TextDataIn

public TextDataIn(int index)
請求インタフェースの通信構造テキスト情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getRefDoc

public String getRefDoc()
参照伝票番号を取得します。

戻り値:
refDoc 参照伝票番号

getRefItem

public String getRefItem()
参照明細番号を取得します。

戻り値:
refItem 参照明細番号

getApplobject

public String getApplobject()
テキスト: アプリケーションオブジェクトを取得します。

戻り値:
applobject テキスト: アプリケーションオブジェクト

getTextId

public String getTextId()
テキスト IDを取得します。

戻り値:
textId テキスト ID

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
langu 言語キー

getFormatCol

public String getFormatCol()
タグ列を取得します。

戻り値:
formatCol タグ列

getTextLine

public String getTextLine()
テキスト行を取得します。

戻り値:
textLine テキスト行

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setRefDoc

public void setRefDoc(String refDoc)
参照伝票番号を設定します。

パラメータ:
refDoc - 参照伝票番号

setRefItem

public void setRefItem(String refItem)
参照明細番号を設定します。

パラメータ:
refItem - 参照明細番号

setApplobject

public void setApplobject(String applobject)
テキスト: アプリケーションオブジェクトを設定します。

パラメータ:
applobject - テキスト: アプリケーションオブジェクト

setTextId

public void setTextId(String textId)
テキスト IDを設定します。

パラメータ:
textId - テキスト ID

setLangu

public void setLangu(String langu)
言語キーを設定します。

パラメータ:
langu - 言語キー

setFormatCol

public void setFormatCol(String formatCol)
タグ列を設定します。

パラメータ:
formatCol - タグ列

setTextLine

public void setTextLine(String textLine)
テキスト行を設定します。

パラメータ:
textLine - テキスト行

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BillingDocGetDetail (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail
クラス BillingDocGetDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail
すべての実装インタフェース:
Serializable
public class BillingDocGetDetail
extends ReferenceController
implements Serializable

請求伝票詳細照会情報クラス
機能は以下の通り

  • 請求伝票詳細照会情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
BillingDocGetDetail(String billingdocument, SapClient sapClient)
請求伝票詳細照会情報を作成します。
メソッドの概要
 void executeBapi()
BillingDocGetDetailのexecuteBapi()を呼び出し請求伝票を検索します。
 String getBillingdocument()
処理予定の請求伝票数を取得します。
 BillingDocumentDetail getBillingDocumentDetail()
請求伝票に関する詳細情報を取得します。
 void setBillingdocument(String billingdocument)
処理予定の請求伝票数を設定します。
 void setBillingDocumentDetail(BillingDocumentDetail billingDocumentDetail)
請求伝票に関する詳細情報を設定します。
 void setExportParam(BapiController bapiController)
返却された請求伝票詳細照会情報をセットします。
 String toString()
デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BillingDocGetDetail

public BillingDocGetDetail(String billingdocument,
                           SapClient sapClient)
                    throws SAPAuthAppException,
                           SAPAuthSystemException,
                           SAPGeneralAppException,
                           SAPGeneralSystemException,
                           SAPSalesAppException,
                           SAPSalesSystemException
請求伝票詳細照会情報を作成します。

パラメータ:
sapClient - SapClient SAPクライアント
billingdocument - String 請求伝票
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPSalesAppException,
                        SAPSalesSystemException
BillingDocGetDetailのexecuteBapi()を呼び出し請求伝票を検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
返却された請求伝票詳細照会情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getBillingdocument

public String getBillingdocument()
処理予定の請求伝票数を取得します。

戻り値:
billingdocument 処理予定の請求伝票数

getBillingDocumentDetail

public BillingDocumentDetail getBillingDocumentDetail()
請求伝票に関する詳細情報を取得します。

戻り値:
billingDocumentDetail 請求伝票に関する詳細情報

setBillingdocument

public void setBillingdocument(String billingdocument)
処理予定の請求伝票数を設定します。

パラメータ:
billingdocument - 処理予定の請求伝票数

setBillingDocumentDetail

public void setBillingDocumentDetail(BillingDocumentDetail billingDocumentDetail)
請求伝票に関する詳細情報を設定します。

パラメータ:
billingDocumentDetail - 請求伝票に関する詳細情報

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail
クラス
BillingDocGetDetail


jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail

クラスの概要
BillingDocGetDetail 請求伝票詳細照会情報クラス
機能は以下の通り
請求伝票詳細照会情報を保持します。


jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList の使用

BillingDocGetList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales での BillingDocGetList の使用

jp.co.intra_mart.foundation.sap.module.sales での BillingDocGetList のサブクラス
 class BillingDocGetListController
請求伝票一覧照会情報コントローラクラス
機能は以下の通り
請求伝票一覧照会情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange の使用

RefDocRange を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist での RefDocRange の使用

RefDocRange を返す jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist のメソッド
 RefDocRange BillingDocGetList.getRefDocRange()
前伝票の範囲を取得します。

RefDocRange 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist のメソッド
static void | ParamRefDocRange.setImportParam(BapiController bapiController, RefDocRange refDocRange) 前伝票の範囲の値をセットします。
void | BillingDocGetList.setRefDocRange(RefDocRange refDocRange) 前伝票の範囲を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BillingDocGetList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist
クラス BillingDocGetList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
BillingDocGetListController
public class BillingDocGetList
extends ReferenceController
implements Serializable

請求伝票一覧照会情報クラス
機能は以下の通り

  • 請求伝票一覧照会情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
BillingDocGetList(SapClient sapClient)
請求伝票一覧照会情報を作成します。
BillingDocGetList(String sign, String option, String refDocRow, String refDocHigh, SapClient sapClient)
請求伝票一覧照会情報を作成します。
メソッドの概要
List | getBillingDocumentDetailListList() 後続請求伝票のテーブルを取得します。
RefDocRange | getRefDocRange() 前伝票の範囲を取得します。
List | getSuccessList() 後続請求伝票の明細テーブルを取得します。
void | setBillingDocumentDetailListList(ArrayList billingDocumentDetailListList) 後続請求伝票のテーブルを設定します。
void | setExportParam(BapiController bapiController) 取得した請求伝票一覧照会情報をセットします。
void | setImportParam(BapiController bapiController) 請求伝票一覧照会情報を、取得する為に必要な情報をセットします。
void | setRefDocRange(RefDocRange refDocRange) 前伝票の範囲を設定します。
void | setSuccessList(ArrayList successList) 後続請求伝票の明細テーブルを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BillingDocGetList

public BillingDocGetList(SapClient sapClient)
請求伝票一覧照会情報を作成します。

パラメータ:
sapClient - SAPクライアント

BillingDocGetList

public BillingDocGetList(String sign,
                         String option,
                         String refDocRow,
                         String refDocHigh,
                         SapClient sapClient)
請求伝票一覧照会情報を作成します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)
option - 選択演算子 OPTION (範囲テーブル)
refDocRow - 前伝票の開始伝票番号
refDocHigh - 前伝票の終了伝票番号
sapClient - SAPクライアント
メソッドの詳細

getRefDocRange

public RefDocRange getRefDocRange()
前伝票の範囲を取得します。

戻り値:
refDocRange 前伝票の範囲

getBillingDocumentDetailListList

public List getBillingDocumentDetailListList()
後続請求伝票のテーブルを取得します。

戻り値:
billingDocumentDetailListList 後続請求伝票のテーブル

getSuccessList

public List getSuccessList()
後続請求伝票の明細テーブルを取得します。

戻り値:
successList 後続請求伝票の明細テーブル

setRefDocRange

public void setRefDocRange(RefDocRange refDocRange)
前伝票の範囲を設定します。

パラメータ:
refDocRange - 前伝票の範囲

setBillingDocumentDetailListList

public void setBillingDocumentDetailListList(ArrayList billingDocumentDetailListList)
後続請求伝票のテーブルを設定します。

パラメータ:
billingDocumentDetailListList - 後続請求伝票のテーブル

setSuccessList

public void setSuccessList(ArrayList successList)
後続請求伝票の明細テーブルを設定します。

パラメータ:
successList - 後続請求伝票の明細テーブル

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralAppException,
                           SAPGeneralSystemException
請求伝票一覧照会情報を、取得する為に必要な情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
取得した請求伝票一覧照会情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist
クラス
BillingDocGetList
ParamRefDocRange
RefDocRange


jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist

クラスの概要
BillingDocGetList | 請求伝票一覧照会情報クラス 機能は以下の通り 請求伝票一覧照会情報を保持します。
ParamRefDocRange | 前伝票の範囲パラメータ設定クラス 機能は以下の通り 前伝票の範囲のパラメータを設定します。
RefDocRange | 前伝票の範囲情報クラス 機能は以下の通り 前伝票の範囲情報を保持します。


jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist のクラス
BillingDocGetList
請求伝票一覧照会情報クラス
機能は以下の通り
請求伝票一覧照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist により使用される jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist のクラス
RefDocRange
前伝票の範囲情報クラス
機能は以下の通り
前伝票の範囲情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamRefDocRange (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist
クラス ParamRefDocRange

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange
すべての実装インタフェース:
Serializable
public final class ParamRefDocRange
extends Object
implements Serializable

前伝票の範囲パラメータ設定クラス
機能は以下の通り

  • 前伝票の範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, RefDocRange refDocRange)
前伝票の範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  RefDocRange refDocRange)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
前伝票の範囲の値をセットします。

パラメータ:
bapiController - BapiController
refDocRange - RefDocRange
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RefDocRange (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist
クラス RefDocRange

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange
すべての実装インタフェース:
Serializable
public class RefDocRange
extends Object
implements Serializable

前伝票の範囲情報クラス
機能は以下の通り

  • 前伝票の範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
RefDocRange()
前伝票の範囲情報を作成します。
メソッドの概要
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getRefDocHigh() 前伝票の終了伝票番号を取得します。
String | getRefDocLow() 前伝票の開始伝票番号を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setRefDocHigh(String refDocHigh) 前伝票の終了伝票番号を設定します。
void | setRefDocLow(String refDocLow) 前伝票の開始伝票番号を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

RefDocRange

public RefDocRange()
前伝票の範囲情報を作成します。

メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getRefDocLow

public String getRefDocLow()
前伝票の開始伝票番号を取得します。

戻り値:
refDocLow 前伝票の開始伝票番号

getRefDocHigh

public String getRefDocHigh()
前伝票の終了伝票番号を取得します。

戻り値:
refDocHigh 前伝票の終了伝票番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setRefDocLow

public void setRefDocLow(String refDocLow)
前伝票の開始伝票番号を設定します。

パラメータ:
refDocLow - 前伝票の開始伝票番号

setRefDocHigh

public void setRefDocHigh(String refDocHigh)
前伝票の終了伝票番号を設定します。

パラメータ:
refDocHigh - 前伝票の終了伝票番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController の使用

jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController の使用

jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController の使用

jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller の使用

jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller の使用

jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller の使用

jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController の使用

jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController の使用

jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail の使用

BillingDocumentDetail を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail
jp.co.intra_mart.foundation.sap.module.sales.common.model

jp.co.intra_mart.foundation.sap.module.sales での BillingDocumentDetail の使用

BillingDocumentDetail を返す jp.co.intra_mart.foundation.sap.module.sales のメソッド
 BillingDocumentDetail BillingDocGetDetailController.getBillingDocumentDetail()
請求伝票に関する詳細情報を取得します。

BillingDocumentDetail 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales のメソッド
 void BillingDocGetDetailController.setBillingDocumentDetail(BillingDocumentDetail billingDocumentDetail)
請求伝票に関する詳細情報を設定します。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での BillingDocumentDetail の使用

BillingDocumentDetail を返す jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のメソッド
 BillingDocumentDetail BillingDocGetDetail.getBillingDocumentDetail()
請求伝票に関する詳細情報を取得します。

BillingDocumentDetail 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のメソッド
 void BillingDocGetDetail.setBillingDocumentDetail(BillingDocumentDetail billingDocumentDetail)
請求伝票に関する詳細情報を設定します。

jp.co.intra_mart.foundation.sap.module.sales.common.model での BillingDocumentDetail の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model での BillingDocumentDetail のサブクラス
 class BillingDocumentDetailList
後続請求伝票のテーブル情報クラス
機能は以下の通り
後続請求伝票のテーブル情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn の使用

HeaderIn を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales.common.model
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2

jp.co.intra_mart.foundation.sap.module.sales.common.model での HeaderIn の使用

HeaderIn 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.common.model のメソッド
static void ParamHeaderIn.setImportParam(BapiController bapiController, HeaderIn headerIn, String paramType)
販売伝票ヘッダデータに値をセットします。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での HeaderIn の使用

HeaderIn を返す jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
 HeaderIn InquiryCreateFromData2.getInquiryHeaderIn()
引合伝票ヘッダデータを取得します。

HeaderIn 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
 void InquiryCreateFromData2.setInquiryHeaderIn(HeaderIn inquiryHeaderIn)
引合伝票ヘッダデータを設定します。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での HeaderIn の使用

HeaderIn を返す jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
 HeaderIn QuotationCreateFromData2.getQuotationHeaderIn()
伝票ヘッダデータを取得します。

HeaderIn 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
 void QuotationCreateFromData2.setQuotationHeaderIn(HeaderIn quotationHeaderIn)
伝票ヘッダデータを設定します。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での HeaderIn の使用

HeaderIn を返す jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
 HeaderIn SalesOrderCreateFromDat2.getOrderHeaderIn()
受注伝票ヘッダを取得します。

HeaderIn 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
 void SalesOrderCreateFromDat2.setOrderHeaderIn(HeaderIn orderHeaderIn)
受注伝票ヘッダを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX の使用

HeaderInX を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales.common.model
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2

jp.co.intra_mart.foundation.sap.module.sales.common.model での HeaderInX の使用

HeaderInX 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.common.model のメソッド
static void ParamHeaderInX.setImportParam(BapiController bapiController, HeaderInX headerInX, String paramType)
ヘッダデータチェックボックスに値をセットします。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での HeaderInX の使用

HeaderInX を返す jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
 HeaderInX InquiryCreateFromData2.getInquiryHeaderInX()
ヘッダデータチェックボックスを取得します。

HeaderInX 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
 void InquiryCreateFromData2.setInquiryHeaderInX(HeaderInX inquiryHeaderInX)
ヘッダデータチェックボックスを設定します。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での HeaderInX の使用

HeaderInX を返す jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
 HeaderInX QuotationCreateFromData2.getQuotationHeaderInX()
伝票ヘッダチェックボックスを取得します。

HeaderInX 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
 void QuotationCreateFromData2.setQuotationHeaderInX(HeaderInX quotationHeaderInX)
伝票ヘッダチェックボックスを設定します。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での HeaderInX の使用

HeaderInX を返す jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
 HeaderInX SalesOrderCreateFromDat2.getOrderHeaderInX()
受注伝票チェックリストを取得します。

HeaderInX 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
 void SalesOrderCreateFromDat2.setOrderHeaderInX(HeaderInX orderHeaderInX)
受注伝票チェックリストを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch の使用

LogicSwitch を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales.common.model
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2

jp.co.intra_mart.foundation.sap.module.sales.common.model での LogicSwitch の使用

LogicSwitch 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.common.model のメソッド
static void ParamLogicSwitch.setImportParam(BapiController bapiController, LogicSwitch logicSwitch)
内部制御パラメータに値をセットします。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での LogicSwitch の使用

LogicSwitch を返す jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
 LogicSwitch InquiryCreateFromData2.getLogicSwitch()
内部制御パラメータを取得します。

LogicSwitch 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
 void InquiryCreateFromData2.setLogicSwitch(LogicSwitch logicSwitch)
内部制御パラメータを設定します。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での LogicSwitch の使用

LogicSwitch を返す jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
 LogicSwitch QuotationCreateFromData2.getLogicSwitch()
内部制御パラメータを取得します。

LogicSwitch 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
 void QuotationCreateFromData2.setLogicSwitch(LogicSwitch logicSwitch)
内部制御パラメータを設定します。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での LogicSwitch の使用

LogicSwitch を返す jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
 LogicSwitch SalesOrderCreateFromDat2.getLogicSwitch()
内部制御パラメータを取得します。

LogicSwitch 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
 void SalesOrderCreateFromDat2.setLogicSwitch(LogicSwitch logicSwitch)
内部制御パラメータを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender の使用

Sender を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales.common.model
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2

jp.co.intra_mart.foundation.sap.module.sales.common.model での Sender の使用

Sender 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.common.model のメソッド
static void ParamSender.setImportParam(BapiController bapiController, Sender sender)
論理システム - 送信者に値をセットします。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での Sender の使用

Sender を返す jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
 Sender InquiryCreateFromData2.getSender()
論理システム - 送信者を取得します。

Sender 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
 void InquiryCreateFromData2.setSender(Sender sender)
論理システム - 送信者を設定します。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での Sender の使用

Sender を返す jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
 Sender QuotationCreateFromData2.getSender()
論理システム - 送信者を取得します。

Sender 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
 void QuotationCreateFromData2.setSender(Sender sender)
論理システム - 送信者を設定します。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での Sender の使用

Sender を返す jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
 Sender SalesOrderCreateFromDat2.getSender()
論理システム - 送信者を取得します。

Sender 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
 void SalesOrderCreateFromDat2.setSender(Sender sender)
論理システム - 送信者を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Success の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.Success の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.Success はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Text の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.Text の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.Text はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BillingDocumentDetail (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス BillingDocumentDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
BillingDocumentDetailList
public class BillingDocumentDetail
extends Object
implements Serializable

後続請求伝票のテーブル情報クラス
機能は以下の通り

  • 後続請求伝票のテーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
BillingDocumentDetail()
後続請求伝票のテーブル情報を作成します。
メソッドの概要
String | getAcctstatus() 会計への転記ステータスを取得します。
String | getBillcateg() 請求カテゴリを取得します。
String | getBillingdoc() 請求伝票を取得します。
String | getBillType() 請求タイプを取得します。
String | getCancelled() 中止区分を取得します。
String | getCurrency() 販売伝票通貨を取得します。
String | getCurrencyIso() ISO 通貨コードを取得します。
String | getNetValue() 正味金額を取得します。
String | getSdDocCat() 販売管理伝票カテゴリを取得します。
String | getTaxValue() 税額を取得します。
void | setAcctstatus(String acctstatus) 会計への転記ステータスを設定します。
void | setBillcateg(String billcateg) 請求カテゴリを設定します。
void | setBillingdoc(String billingdoc) 請求伝票を設定します。
void | setBillType(String billType) 請求タイプを設定します。
void | setCancelled(String cancelled) 中止区分を設定します。
void | setCurrency(String currency) 販売伝票通貨を設定します。
void | setCurrencyIso(String currencyIso) ISO 通貨コードを設定します。
void | setNetValue(String netValue) 正味金額を設定します。
void | setSdDocCat(String sdDocCat) 販売管理伝票カテゴリを設定します。
void | setTaxValue(String taxValue) 税額を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BillingDocumentDetail

public BillingDocumentDetail()
後続請求伝票のテーブル情報を作成します。

メソッドの詳細

getBillingdoc

public String getBillingdoc()
請求伝票を取得します。

戻り値:
billingdoc 請求伝票

getBillType

public String getBillType()
請求タイプを取得します。

戻り値:
billType 請求タイプ

getBillcateg

public String getBillcateg()
請求カテゴリを取得します。

戻り値:
billcateg 請求カテゴリ

getSdDocCat

public String getSdDocCat()
販売管理伝票カテゴリを取得します。

戻り値:
sdDocCat 販売管理伝票カテゴリ

getCurrency

public String getCurrency()
販売伝票通貨を取得します。

戻り値:
currency 販売伝票通貨

getCurrencyIso

public String getCurrencyIso()
ISO 通貨コードを取得します。

戻り値:
currencyIso ISO 通貨コード

getAcctstatus

public String getAcctstatus()
会計への転記ステータスを取得します。

戻り値:
acctstatus 会計への転記ステータス

getNetValue

public String getNetValue()
正味金額を取得します。

戻り値:
netValue 正味金額

getTaxValue

public String getTaxValue()
税額を取得します。

戻り値:
taxValue 税額

getCancelled

public String getCancelled()
中止区分を取得します。

戻り値:
cancelled 中止区分

setBillingdoc

public void setBillingdoc(String billingdoc)
請求伝票を設定します。

パラメータ:
billingdoc - 請求伝票

setBillType

public void setBillType(String billType)
請求タイプを設定します。

パラメータ:
billType - 請求タイプ

setBillcateg

public void setBillcateg(String billcateg)
請求カテゴリを設定します。

パラメータ:
billcateg - 請求カテゴリ

setSdDocCat

public void setSdDocCat(String sdDocCat)
販売管理伝票カテゴリを設定します。

パラメータ:
sdDocCat - 販売管理伝票カテゴリ

setCurrency

public void setCurrency(String currency)
販売伝票通貨を設定します。

パラメータ:
currency - 販売伝票通貨

setCurrencyIso

public void setCurrencyIso(String currencyIso)
ISO 通貨コードを設定します。

パラメータ:
currencyIso - ISO 通貨コード

setAcctstatus

public void setAcctstatus(String acctstatus)
会計への転記ステータスを設定します。

パラメータ:
acctstatus - 会計への転記ステータス

setNetValue

public void setNetValue(String netValue)
正味金額を設定します。

パラメータ:
netValue - 正味金額

setTaxValue

public void setTaxValue(String taxValue)
税額を設定します。

パラメータ:
taxValue - 税額

setCancelled

public void setCancelled(String cancelled)
中止区分を設定します。

パラメータ:
cancelled - 中止区分

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BillingDocumentDetailList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス BillingDocumentDetailList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail
        拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList
すべての実装インタフェース:
Serializable
public class BillingDocumentDetailList
extends BillingDocumentDetail
implements Serializable

後続請求伝票のテーブル情報クラス
機能は以下の通り

  • 後続請求伝票のテーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
BillingDocumentDetailList()
後続請求伝票のテーブル情報を作成します。
BillingDocumentDetailList(int index)
後続請求伝票のテーブル情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail から継承したメソッド
getAcctstatus, getBillcateg, getBillingdoc, getBillType, getCancelled, getCurrency, getCurrencyIso, getNetValue, getSdDocCat, getTaxValue, setAcctstatus, setBillcateg, setBillingdoc, setBillType, setCancelled, setCurrency, setCurrencyIso, setNetValue, setSdDocCat, setTaxValue, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BillingDocumentDetailList

public BillingDocumentDetailList()
後続請求伝票のテーブル情報を作成します。

BillingDocumentDetailList

public BillingDocumentDetailList(int index)
後続請求伝票のテーブル情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CfgsBlob (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス CfgsBlob

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob
すべての実装インタフェース:
Serializable
public class CfgsBlob
extends Object
implements Serializable

選定: BLOB 内部データ (SCE)情報クラス
機能は以下の通り

  • 選定: BLOB 内部データ (SCE)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CfgsBlob()
選定: BLOB 内部データ (SCE)情報を作成します。
CfgsBlob(int index)
選定: BLOB 内部データ (SCE)情報を作成します。
メソッドの概要
String | getConfigId() 外部選定 ID (仮)を取得します。
String | getContext() CU: 選定の BLOB (SCE)を取得します。
int | getIndex() レコード番号を取得します｡
void | setConfigId(String configId) 外部選定 ID (仮)を設定します。
void | setContext(String context) CU: 選定の BLOB (SCE)を設定します。
void | setIndex(int index) レコード番号を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CfgsBlob

public CfgsBlob()
選定: BLOB 内部データ (SCE)情報を作成します。

CfgsBlob

public CfgsBlob(int index)
選定: BLOB 内部データ (SCE)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getConfigId

public String getConfigId()
外部選定 ID (仮)を取得します。

戻り値:
configId 外部選定 ID (仮)

getContext

public String getContext()
CU: 選定の BLOB (SCE)を取得します。

戻り値:
context CU: 選定の BLOB (SCE)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setConfigId

public void setConfigId(String configId)
外部選定 ID (仮)を設定します。

パラメータ:
configId - 外部選定 ID (仮)

setContext

public void setContext(String context)
CU: 選定の BLOB (SCE)を設定します。

パラメータ:
context - CU: 選定の BLOB (SCE)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CfgsInst (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス CfgsInst

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst
すべての実装インタフェース:
Serializable
public class CfgsInst
extends Object
implements Serializable

選定: インスタンス情報クラス
機能は以下の通り

  • 選定: インスタンス情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CfgsInst()
選定: インスタンス情報を作成します。
CfgsInst(int index)
選定: インスタンス情報を作成します。
メソッドの概要
String | getAuthor() 報告書提案済を取得します。
String | getClassType() クラスタイプを取得します。
String | getComplete() 一般区分を取得します。
String | getConfigId() 外部選定 ID (仮)を取得します。
String | getConsistent() 一般区分を取得します。
int | getIndex() レコード番号を取得します｡
String | getInstId() 選定におけるインスタンス番号を取得します。
String | getObjectGuid() インスタンス用 TYPE_OF ステートメントの GUIDを取得します。
String | getObjKey() 対象キーを取得します。
String | getObjTxt() 言語依存対象テキストを取得します。
String | getObjType() 対象タイプを取得します。
String | getPersistId() インスタンス番号 (固定)を取得します。
String | getPersistIdType() インスタンス番号タイプ (固定)を取得します。
String | getQuantity() インスタンス数量を取得します。
String | getQuantityUnit() 数量単位を取得します。
void | setAuthor(String author) 報告書提案済を設定します。
void | setClassType(String classType) クラスタイプを設定します。
void | setComplete(String complete) 一般区分を設定します。
void | setConfigId(String configId) 外部選定 ID (仮)を設定します。
void | setConsistent(String consistent) 一般区分を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setInstId(String instId) 選定におけるインスタンス番号を設定します。
void | setObjectGuid(String objectGuid) インスタンス用 TYPE_OF ステートメントの GUIDを設定します。
void | setObjKey(String objKey) 対象キーを設定します。
void | setObjTxt(String objTxt) 言語依存対象テキストを設定します。
void | setObjType(String objType) 対象タイプを設定します。
void | setPersistId(String persistId) インスタンス番号 (固定)を設定します。
void | setPersistIdType(String persistIdType) インスタンス番号タイプ (固定)を設定します。
void | setQuantity(String quantity) インスタンス数量を設定します。
void | setQuantityUnit(String quantityUnit) 数量単位を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CfgsInst

public CfgsInst()
選定: インスタンス情報を作成します。

CfgsInst

public CfgsInst(int index)
選定: インスタンス情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getConfigId

public String getConfigId()
外部選定 ID (仮)を取得します。

戻り値:
configId 外部選定 ID (仮)

getInstId

public String getInstId()
選定におけるインスタンス番号を取得します。

戻り値:
instId 選定におけるインスタンス番号

getObjType

public String getObjType()
対象タイプを取得します。

戻り値:
objType 対象タイプ

getClassType

public String getClassType()
クラスタイプを取得します。

戻り値:
classType クラスタイプ

getObjKey

public String getObjKey()
対象キーを取得します。

戻り値:
objKey 対象キー

getObjTxt

public String getObjTxt()
言語依存対象テキストを取得します。

戻り値:
objTxt 言語依存対象テキスト

getQuantity

public String getQuantity()
インスタンス数量を取得します。

戻り値:
quantity インスタンス数量

getAuthor

public String getAuthor()
報告書提案済を取得します。

戻り値:
author 報告書提案済

getQuantityUnit

public String getQuantityUnit()
数量単位を取得します。

戻り値:
quantityUnit 数量単位

getComplete

public String getComplete()
一般区分を取得します。

戻り値:
complete 一般区分

getConsistent

public String getConsistent()
一般区分を取得します。

戻り値:
consistent 一般区分

getObjectGuid

public String getObjectGuid()
インスタンス用 TYPE_OF ステートメントの GUIDを取得します。

戻り値:
objectGuid インスタンス用 TYPE_OF ステートメントの GUID

getPersistId

public String getPersistId()
インスタンス番号 (固定)を取得します。

戻り値:
persistId インスタンス番号 (固定)

getPersistIdType

public String getPersistIdType()
インスタンス番号タイプ (固定)を取得します。

戻り値:
persistIdType インスタンス番号タイプ (固定)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setConfigId

public void setConfigId(String configId)
外部選定 ID (仮)を設定します。

パラメータ:
configId - 外部選定 ID (仮)

setInstId

public void setInstId(String instId)
選定におけるインスタンス番号を設定します。

パラメータ:
instId - 選定におけるインスタンス番号

setObjType

public void setObjType(String objType)
対象タイプを設定します。

パラメータ:
objType - 対象タイプ

setClassType

public void setClassType(String classType)
クラスタイプを設定します。

パラメータ:
classType - クラスタイプ

setObjKey

public void setObjKey(String objKey)
対象キーを設定します。

パラメータ:
objKey - 対象キー

setObjTxt

public void setObjTxt(String objTxt)
言語依存対象テキストを設定します。

パラメータ:
objTxt - 言語依存対象テキスト

setQuantity

public void setQuantity(String quantity)
インスタンス数量を設定します。

パラメータ:
quantity - インスタンス数量

setAuthor

public void setAuthor(String author)
報告書提案済を設定します。

パラメータ:
author - 報告書提案済

setQuantityUnit

public void setQuantityUnit(String quantityUnit)
数量単位を設定します。

パラメータ:
quantityUnit - 数量単位

setComplete

public void setComplete(String complete)
一般区分を設定します。

パラメータ:
complete - 一般区分

setConsistent

public void setConsistent(String consistent)
一般区分を設定します。

パラメータ:
consistent - 一般区分

setObjectGuid

public void setObjectGuid(String objectGuid)
インスタンス用 TYPE_OF ステートメントの GUIDを設定します。

パラメータ:
objectGuid - インスタンス用 TYPE_OF ステートメントの GUID

setPersistId

public void setPersistId(String persistId)
インスタンス番号 (固定)を設定します。

パラメータ:
persistId - インスタンス番号 (固定)

setPersistIdType

public void setPersistIdType(String persistIdType)
インスタンス番号タイプ (固定)を設定します。

パラメータ:
persistIdType - インスタンス番号タイプ (固定)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CfgsPartOf (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス CfgsPartOf

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf
すべての実装インタフェース:
Serializable
public class CfgsPartOf
extends Object
implements Serializable

選定: 部分設定情報クラス
機能は以下の通り

  • 選定: 部分設定情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CfgsPartOf()
選定: 部分設定情報を作成します。
CfgsPartOf(int index)
選定: 部分設定情報を作成します。
メソッドの概要
String | getAuthor() 報告書提案済を取得します。
String | getClassType() クラスタイプを取得します。
String | getConfigId() 外部選定 ID (仮)を取得します。
int | getIndex() レコード番号を取得します｡
String | getInstId() 選定におけるインスタンス番号を取得します。
String | getObjKey() 対象キーを取得します。
String | getObjType() 対象タイプを取得します。
String | getParentId() 選定におけるインスタンス番号を取得します。
String | getPartOfGuid() インスタンス用 PART_OF ステートメントの GUIDを取得します。
String | getPartOfNo() Part_of 明細番号を取得します。
String | getSalesRelevant() この部品は販売に関連していますを取得します。
void | setAuthor(String author) 報告書提案済を設定します。
void | setClassType(String classType) クラスタイプを設定します。
void | setConfigId(String configId) 外部選定 ID (仮)を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setInstId(String instId) 選定におけるインスタンス番号を設定します。
void | setObjKey(String objKey) 対象キーを設定します。
void | setObjType(String objType) 対象タイプを設定します。
void | setParentId(String parentId) 選定におけるインスタンス番号を設定します。
void | setPartOfGuid(String partOfGuid) インスタンス用 PART_OF ステートメントの GUIDを設定します。
void | setPartOfNo(String partOfNo) Part_of 明細番号を設定します。
void | setSalesRelevant(String salesRelevant) この部品は販売に関連していますを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CfgsPartOf

public CfgsPartOf()
選定: 部分設定情報を作成します。

CfgsPartOf

public CfgsPartOf(int index)
選定: 部分設定情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getConfigId

public String getConfigId()
外部選定 ID (仮)を取得します。

戻り値:
configId 外部選定 ID (仮)

getParentId

public String getParentId()
選定におけるインスタンス番号を取得します。

戻り値:
parentId 選定におけるインスタンス番号

getInstId

public String getInstId()
選定におけるインスタンス番号を取得します。

戻り値:
instId 選定におけるインスタンス番号

getPartOfNo

public String getPartOfNo()
Part_of 明細番号を取得します。

戻り値:
partOfNo Part_of 明細番号

getObjType

public String getObjType()
対象タイプを取得します。

戻り値:
objType 対象タイプ

getClassType

public String getClassType()
クラスタイプを取得します。

戻り値:
classType クラスタイプ

getObjKey

public String getObjKey()
対象キーを取得します。

戻り値:
objKey 対象キー

getAuthor

public String getAuthor()
報告書提案済を取得します。

戻り値:
author 報告書提案済

getSalesRelevant

public String getSalesRelevant()
この部品は販売に関連していますを取得します。

戻り値:
salesRelevant この部品は販売に関連しています

getPartOfGuid

public String getPartOfGuid()
インスタンス用 PART_OF ステートメントの GUIDを取得します。

戻り値:
partOfGuid インスタンス用 PART_OF ステートメントの GUID

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setConfigId

public void setConfigId(String configId)
外部選定 ID (仮)を設定します。

パラメータ:
configId - 外部選定 ID (仮)

setParentId

public void setParentId(String parentId)
選定におけるインスタンス番号を設定します。

パラメータ:
parentId - 選定におけるインスタンス番号

setInstId

public void setInstId(String instId)
選定におけるインスタンス番号を設定します。

パラメータ:
instId - 選定におけるインスタンス番号

setPartOfNo

public void setPartOfNo(String partOfNo)
Part_of 明細番号を設定します。

パラメータ:
partOfNo - Part_of 明細番号

setObjType

public void setObjType(String objType)
対象タイプを設定します。

パラメータ:
objType - 対象タイプ

setClassType

public void setClassType(String classType)
クラスタイプを設定します。

パラメータ:
classType - クラスタイプ

setObjKey

public void setObjKey(String objKey)
対象キーを設定します。

パラメータ:
objKey - 対象キー

setAuthor

public void setAuthor(String author)
報告書提案済を設定します。

パラメータ:
author - 報告書提案済

setSalesRelevant

public void setSalesRelevant(String salesRelevant)
この部品は販売に関連していますを設定します。

パラメータ:
salesRelevant - この部品は販売に関連しています

setPartOfGuid

public void setPartOfGuid(String partOfGuid)
インスタンス用 PART_OF ステートメントの GUIDを設定します。

パラメータ:
partOfGuid - インスタンス用 PART_OF ステートメントの GUID

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CfgsRef (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス CfgsRef

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef
すべての実装インタフェース:
Serializable
public class CfgsRef
extends Object
implements Serializable

選定: 参照データ情報クラス
機能は以下の通り

  • 選定: 参照データ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CfgsRef()
選定: 参照データ情報を作成します。
CfgsRef(int index)
選定: 参照データ情報を作成します。
メソッドの概要
String | getCbaseId() インスタンス番号 (固定)を取得します。
String | getCbaseIdType() インスタンス番号タイプ (固定)を取得します。
String | getCfginfo() CU: 選定の BLOB (SCE)を取得します。
String | getComplete() 一般区分を取得します。
String | getConfigId() 外部選定 ID (仮)を取得します。
String | getConsistent() 一般区分を取得します。
int | getIndex() レコード番号を取得します｡
String | getKblanguage() システム設定の言語を取得します。
String | getKbname() ナレッジベースオブジェクトを取得します。
String | getKbprofile() ナレッジベースプロファイルを取得します。
String | getKbversion() SCE ナレッジベースの実行時バージョンを取得します。
String | getPosex() 外部明細番号を取得します。
String | getRootId() 選定におけるインスタンス番号を取得します。
String | getSce() CUX: 選定タイプを取得します。
void | setCbaseId(String cbaseId) インスタンス番号 (固定)を設定します。
void | setCbaseIdType(String cbaseIdType) インスタンス番号タイプ (固定)を設定します。
void | setCfginfo(String cfginfo) CU: 選定の BLOB (SCE)を設定します。
void | setComplete(String complete) 一般区分を設定します。
void | setConfigId(String configId) 外部選定 ID (仮)を設定します。
void | setConsistent(String consistent) 一般区分を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setKblanguage(String kblanguage) システム設定の言語を設定します。
void | setKbname(String kbname) ナレッジベースオブジェクトを設定します。
void | setKbprofile(String kbprofile) ナレッジベースプロファイルを設定します。
void | setKbversion(String kbversion) SCE ナレッジベースの実行時バージョンを設定します。
void | setPosex(String posex) 外部明細番号を設定します。
void | setRootId(String rootId) 選定におけるインスタンス番号を設定します。
void | setSce(String sce) CUX: 選定タイプを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CfgsRef

public CfgsRef()
選定: 参照データ情報を作成します。

CfgsRef

public CfgsRef(int index)
選定: 参照データ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPosex

public String getPosex()
外部明細番号を取得します。

戻り値:
posex 外部明細番号

getConfigId

public String getConfigId()
外部選定 ID (仮)を取得します。

戻り値:
configId 外部選定 ID (仮)

getRootId

public String getRootId()
選定におけるインスタンス番号を取得します。

戻り値:
rootId 選定におけるインスタンス番号

getSce

public String getSce()
CUX: 選定タイプを取得します。

戻り値:
sce CUX: 選定タイプ

getKbname

public String getKbname()
ナレッジベースオブジェクトを取得します。

戻り値:
kbname ナレッジベースオブジェクト

getKbversion

public String getKbversion()
SCE ナレッジベースの実行時バージョンを取得します。

戻り値:
kbversion SCE ナレッジベースの実行時バージョン

getComplete

public String getComplete()
一般区分を取得します。

戻り値:
complete 一般区分

getConsistent

public String getConsistent()
一般区分を取得します。

戻り値:
consistent 一般区分

getCfginfo

public String getCfginfo()
CU: 選定の BLOB (SCE)を取得します。

戻り値:
cfginfo CU: 選定の BLOB (SCE)

getKbprofile

public String getKbprofile()
ナレッジベースプロファイルを取得します。

戻り値:
kbprofile ナレッジベースプロファイル

getKblanguage

public String getKblanguage()
システム設定の言語を取得します。

戻り値:
kblanguage システム設定の言語

getCbaseId

public String getCbaseId()
インスタンス番号 (固定)を取得します。

戻り値:
cbaseId インスタンス番号 (固定)

getCbaseIdType

public String getCbaseIdType()
インスタンス番号タイプ (固定)を取得します。

戻り値:
cbaseIdType インスタンス番号タイプ (固定)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setPosex

public void setPosex(String posex)
外部明細番号を設定します。

パラメータ:
posex - 外部明細番号

setConfigId

public void setConfigId(String configId)
外部選定 ID (仮)を設定します。

パラメータ:
configId - 外部選定 ID (仮)

setRootId

public void setRootId(String rootId)
選定におけるインスタンス番号を設定します。

パラメータ:
rootId - 選定におけるインスタンス番号

setSce

public void setSce(String sce)
CUX: 選定タイプを設定します。

パラメータ:
sce - CUX: 選定タイプ

setKbname

public void setKbname(String kbname)
ナレッジベースオブジェクトを設定します。

パラメータ:
kbname - ナレッジベースオブジェクト

setKbversion

public void setKbversion(String kbversion)
SCE ナレッジベースの実行時バージョンを設定します。

パラメータ:
kbversion - SCE ナレッジベースの実行時バージョン

setComplete

public void setComplete(String complete)
一般区分を設定します。

パラメータ:
complete - 一般区分

setConsistent

public void setConsistent(String consistent)
一般区分を設定します。

パラメータ:
consistent - 一般区分

setCfginfo

public void setCfginfo(String cfginfo)
CU: 選定の BLOB (SCE)を設定します。

パラメータ:
cfginfo - CU: 選定の BLOB (SCE)

setKbprofile

public void setKbprofile(String kbprofile)
ナレッジベースプロファイルを設定します。

パラメータ:
kbprofile - ナレッジベースプロファイル

setKblanguage

public void setKblanguage(String kblanguage)
システム設定の言語を設定します。

パラメータ:
kblanguage - システム設定の言語

setCbaseId

public void setCbaseId(String cbaseId)
インスタンス番号 (固定)を設定します。

パラメータ:
cbaseId - インスタンス番号 (固定)

setCbaseIdType

public void setCbaseIdType(String cbaseIdType)
インスタンス番号タイプ (固定)を設定します。

パラメータ:
cbaseIdType - インスタンス番号タイプ (固定)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CfgsRefInst (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス CfgsRefInst

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst
すべての実装インタフェース:
Serializable
public class CfgsRefInst
extends Object
implements Serializable

選定: 参照明細/インスタンス情報クラス
機能は以下の通り

  • 選定: 参照明細/インスタンス情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CfgsRefInst()
選定: 参照明細/インスタンス情報を作成します。
CfgsRefInst(int index)
選定: 参照明細/インスタンス情報を作成します。
メソッドの概要
String | getConfigId() 外部選定 ID (仮)を取得します。
int | getIndex() レコード番号を取得します｡
String | getInstId() 選定におけるインスタンス番号を取得します。
String | getPosex() 外部明細番号を取得します。
void | setConfigId(String configId) 外部選定 ID (仮)を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setInstId(String instId) 選定におけるインスタンス番号を設定します。
void | setPosex(String posex) 外部明細番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CfgsRefInst

public CfgsRefInst()
選定: 参照明細/インスタンス情報を作成します。

CfgsRefInst

public CfgsRefInst(int index)
選定: 参照明細/インスタンス情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPosex

public String getPosex()
外部明細番号を取得します。

戻り値:
posex 外部明細番号

getConfigId

public String getConfigId()
外部選定 ID (仮)を取得します。

戻り値:
configId 外部選定 ID (仮)

getInstId

public String getInstId()
選定におけるインスタンス番号を取得します。

戻り値:
instId 選定におけるインスタンス番号

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setPosex

public void setPosex(String posex)
外部明細番号を設定します。

パラメータ:
posex - 外部明細番号

setConfigId

public void setConfigId(String configId)
外部選定 ID (仮)を設定します。

パラメータ:
configId - 外部選定 ID (仮)

setInstId

public void setInstId(String instId)
選定におけるインスタンス番号を設定します。

パラメータ:
instId - 選定におけるインスタンス番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CfgsValue (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス CfgsValue

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue
すべての実装インタフェース:
Serializable
public class CfgsValue
extends Object
implements Serializable

選定: 特性値情報クラス
機能は以下の通り

  • 選定: 特性値情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CfgsValue()
選定: 特性値情報を作成します。
CfgsValue(int index)
選定: 特性値情報を作成します。
メソッドの概要
String | getAuthor() 報告書提案済を取得します。
String | getCharc() 特性名を取得します。
String | getCharcTxt() 言語依存特性テキストを取得します。
String | getConfigId() 外部選定 ID (仮)を取得します。
int | getIndex() レコード番号を取得します｡
String | getInstId() 選定におけるインスタンス番号を取得します。
String | getValcode() 値タイプ: 範囲制限 - 単一値を取得します。
String | getValue() 特性値を取得します。
String | getValueTo() 特性値を取得します。
String | getValueTxt() 特性値の言語依存テキストを取得します。
void | setAuthor(String author) 報告書提案済を設定します。
void | setCharc(String charc) 特性名を設定します。
void | setCharcTxt(String charcTxt) 言語依存特性テキストを設定します。
void | setConfigId(String configId) 外部選定 ID (仮)を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setInstId(String instId) 選定におけるインスタンス番号を設定します。
void | setValcode(String valcode) 値タイプ: 範囲制限 - 単一値を設定します。
void | setValue(String value) 特性値を設定します。
void | setValueTo(String valueTo) 特性値を設定します。
void | setValueTxt(String valueTxt) 特性値の言語依存テキストを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CfgsValue

public CfgsValue()
選定: 特性値情報を作成します。

CfgsValue

public CfgsValue(int index)
選定: 特性値情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getConfigId

public String getConfigId()
外部選定 ID (仮)を取得します。

戻り値:
configId 外部選定 ID (仮)

getInstId

public String getInstId()
選定におけるインスタンス番号を取得します。

戻り値:
instId 選定におけるインスタンス番号

getCharc

public String getCharc()
特性名を取得します。

戻り値:
charc 特性名

getCharcTxt

public String getCharcTxt()
言語依存特性テキストを取得します。

戻り値:
charcTxt 言語依存特性テキスト

getValue

public String getValue()
特性値を取得します。

戻り値:
value 特性値

getValueTxt

public String getValueTxt()
特性値の言語依存テキストを取得します。

戻り値:
valueTxt 特性値の言語依存テキスト

getAuthor

public String getAuthor()
報告書提案済を取得します。

戻り値:
author 報告書提案済

getValueTo

public String getValueTo()
特性値を取得します。

戻り値:
valueTo 特性値

getValcode

public String getValcode()
値タイプ: 範囲制限 - 単一値を取得します。

戻り値:
valcode 値タイプ: 範囲制限 - 単一値

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setConfigId

public void setConfigId(String configId)
外部選定 ID (仮)を設定します。

パラメータ:
configId - 外部選定 ID (仮)

setInstId

public void setInstId(String instId)
選定におけるインスタンス番号を設定します。

パラメータ:
instId - 選定におけるインスタンス番号

setCharc

public void setCharc(String charc)
特性名を設定します。

パラメータ:
charc - 特性名

setCharcTxt

public void setCharcTxt(String charcTxt)
言語依存特性テキストを設定します。

パラメータ:
charcTxt - 言語依存特性テキスト

setValue

public void setValue(String value)
特性値を設定します。

パラメータ:
value - 特性値

setValueTxt

public void setValueTxt(String valueTxt)
特性値の言語依存テキストを設定します。

パラメータ:
valueTxt - 特性値の言語依存テキスト

setAuthor

public void setAuthor(String author)
報告書提案済を設定します。

パラメータ:
author - 報告書提案済

setValueTo

public void setValueTo(String valueTo)
特性値を設定します。

パラメータ:
valueTo - 特性値

setValcode

public void setValcode(String valcode)
値タイプ: 範囲制限 - 単一値を設定します。

パラメータ:
valcode - 値タイプ: 範囲制限 - 単一値

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CfgsVk (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス CfgsVk

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk
すべての実装インタフェース:
Serializable
public class CfgsVk
extends Object
implements Serializable

選定: バリアント条件キー情報クラス
機能は以下の通り

  • 選定: バリアント条件キー情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CfgsVk()
選定: バリアント条件キー情報を作成します。
CfgsVk(int index)
選定: バリアント条件キー情報を作成します。
メソッドの概要
String | getConfigId() 外部選定 ID (仮)を取得します。
String | getFactor() バリアント条件の加重係数を取得します。
int | getIndex() レコード番号を取得します｡
String | getInstId() 選定におけるインスタンス番号を取得します。
String | getVkey() バリアント条件名を取得します。
void | setConfigId(String configId) 外部選定 ID (仮)を設定します。
void | setFactor(String factor) バリアント条件の加重係数を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setInstId(String instId) 選定におけるインスタンス番号を設定します。
void | setVkey(String vkey) バリアント条件名を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CfgsVk

public CfgsVk()
選定: バリアント条件キー情報を作成します。

CfgsVk

public CfgsVk(int index)
選定: バリアント条件キー情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getConfigId

public String getConfigId()
外部選定 ID (仮)を取得します。

戻り値:
configId 外部選定 ID (仮)

getInstId

public String getInstId()
選定におけるインスタンス番号を取得します。

戻り値:
instId 選定におけるインスタンス番号

getVkey

public String getVkey()
バリアント条件名を取得します。

戻り値:
vkey バリアント条件名

getFactor

public String getFactor()
バリアント条件の加重係数を取得します。

戻り値:
factor バリアント条件の加重係数

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setConfigId

public void setConfigId(String configId)
外部選定 ID (仮)を設定します。

パラメータ:
configId - 外部選定 ID (仮)

setInstId

public void setInstId(String instId)
選定におけるインスタンス番号を設定します。

パラメータ:
instId - 選定におけるインスタンス番号

setVkey

public void setVkey(String vkey)
バリアント条件名を設定します。

パラメータ:
vkey - バリアント条件名

setFactor

public void setFactor(String factor)
バリアント条件の加重係数を設定します。

パラメータ:
factor - バリアント条件の加重係数

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ConditionsIn (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ConditionsIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn
すべての実装インタフェース:
Serializable
public class ConditionsIn
extends Object
implements Serializable

条件情報クラス
機能は以下の通り

  • 条件情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ConditionsIn()
条件情報を作成します。
ConditionsIn(int index)
条件情報を作成します。
メソッドの概要
String | getAccessSeq() 検索順序 - 検索番号を取得します。
String | getAccountKe() 勘定キー 見越/引当を取得します。
String | getAccountkey() 勘定キーを取得します。
String | getAccruals() 見越額関連条件 (運賃など)を取得します。
String | getApplicatio() アプリケーションを取得します。
String | getCalctypcon() 条件計算タイプを取得します。
String | getCdUntIso() 条件数量単位 (ISO コード)を取得します。
String | getConbaseval() 条件基礎値を取得します。
String | getCondchaman() 条件 (マニュアル変更済)を取得します。
String | getCondclass() 条件クラスを取得します。
String | getCondcntrl() 条件管理を取得します。
String | getCondcoinhd() 条件カウンタ (ヘッダ条件)を取得します。
String | getCondconfig() システム設定の条件を取得します。
String | getCondcount() 条件連続番号を取得します。
String | getCondCount() 条件カウンタを取得します。
String | getCondincomp() 会社間請求の条件を取得します。
String | getCondisacti() 無効条件を取得します。
String | getCondNo() 条件レコード番号を取得します。
String | getCondorigin() 条件生成区分を取得します。
String | getCondPUnt() 価格条件単位を取得します。
String | getCondStNo() ステップ番号を取得します。
String | getCondtype() 条件カテゴリ (例: 税、運賃、価格、原価)を取得します。
String | getCondType() 条件タイプを取得します。
String | getCondUnit() 条件単位を取得します。
String | getCondUpdat() 条件更新を取得します。
String | getCondvalue() 条件金額を取得します。
String | getCondValue() 条件レートを取得します。
String | getConexchrat() 現地通貨への換算レートに対する条件を取得します。
String | getConinvolst() 請求書一覧条件を取得します。
String | getConpricdat() 条件価格設定日付を取得します。
String | getCurrenckey() スケール通貨を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrency2() 販売伝票通貨を取得します。
String | getCurreniso() ISO コード通貨を取得します。
String | getCurrIso() ISO コード通貨を取得します。
String | getCurrIso2() ISO コード通貨を取得します。
String | getDenominato() 条件単位を基本単位へ変換する分母を取得します。
String | getFactbasval() 条件基礎値に対する要因を取得します。
String | getFactconbas() 条件基準の係数 (期間)を取得します。
String | getGroupcond() グループ条件区分を取得します。
int | getIndex() レコード番号を取得します｡
String | getIsoUnit() 単位の ISO コードを取得します。
String | getItmNumber() 条件明細番号を取得します。
String | getNumconvert() 条件単位を基本単位へ変換する分子を取得します。
String | getReflogsys() 論理システムを取得します。
String | getRefobjkey() オブジェクトキーを取得します。
String | getRefobjtype() オブジェクトタイプを取得します。
String | getRoundoffdi() BAPI の通貨額 (小数点以下９桁)を取得します。
String | getScalbasval() 条件のスケール基準値を取得します。
String | getScalebasin() スケール基準区分を取得します。
String | getScaletype() スケールタイプを取得します。
String | getStatCon() 統計に適用する条件を取得します。
String | getStructcond() 構造条件を取得します。
String | getTaxCode() 消費税コードを取得します。
String | getUnitmeasur() 条件スケール単位を取得します。
String | getVarcond() バリアント条件を取得します。
String | getWtWithcd() 源泉徴収税コードを取得します。
void | setAccessSeq(String accessSeq) 検索順序 - 検索番号を設定します。
void | setAccountKe(String accountKe) 勘定キー 見越/引当を設定します。
void | setAccountkey(String accountkey) 勘定キーを設定します。
void | setAccruals(String accruals) 見越額関連条件 (運賃など)を設定します。
void | setApplicatio(String applicatio) アプリケーションを設定します。
void | setCalctypcon(String calctypcon) 条件計算タイプを設定します。
void | setCdUntIso(String cdUntIso) 条件数量単位 (ISO コード)を設定します。
void | setConbaseval(String conbaseval) 条件基礎値を設定します。
void | setCondchaman(String condchaman) 条件 (マニュアル変更済)を設定します。
void | setCondclass(String condclass) 条件クラスを設定します。
void | setCondcntrl(String condcntrl) 条件管理を設定します。
void | setCondcoinhd(String condcoinhd) 条件カウンタ (ヘッダ条件)を設定します。
void | setCondconfig(String condconfig) システム設定の条件を設定します。
void | setCondcount(String condcount) 条件連続番号を設定します。
void | setCondCount(String condCount) 条件カウンタを設定します。
void | setCondincomp(String condincomp) 会社間請求の条件を設定します。
void | setCondisacti(String condisacti) 無効条件を設定します。
void | setCondNo(String condNo) 条件レコード番号を設定します。
void | setCondorigin(String condorigin) 条件生成区分を設定します。
void | setCondPUnt(String condPUnt) 価格条件単位を設定します。
void | setCondStNo(String condStNo) ステップ番号を設定します。
void | setCondtype(String condtype) 条件カテゴリ (例: 税、運賃、価格、原価)を設定します。
void | setCondType(String condType) 条件タイプを設定します。
void | setCondUnit(String condUnit) 条件単位を設定します。
void | setCondUpdat(String condUpdat) 条件更新を設定します。
void | setCondvalue(String condvalue) 条件金額を設定します。
void | setCondValue(String condValue) 条件レートを設定します。
void | setConexchrat(String conexchrat) 現地通貨への換算レートに対する条件を設定します。
void | setConinvolst(String coninvolst) 請求書一覧条件を設定します。
void | setConpricdat(String conpricdat) 条件価格設定日付を設定します。
void | setCurrenckey(String currenckey) スケール通貨を設定します。
void | setCurrency(String currency) 通貨コードを設定します。
void | setCurrency2(String currency2) 販売伝票通貨を設定します。
void | setCurreniso(String curreniso) ISO コード通貨を設定します。
void | setCurrIso(String currIso) ISO コード通貨を設定します。
void | setCurrIso2(String currIso2) ISO コード通貨を設定します。
void | setDenominato(String denominato) 条件単位を基本単位へ変換する分母を設定します。
void | setFactbasval(String factbasval) 条件基礎値に対する要因を設定します。
void | setFactconbas(String factconbas) 条件基準の係数 (期間)を設定します。
void | setGroupcond(String groupcond) グループ条件区分を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setIsoUnit(String isoUnit) 単位の ISO コードを設定します。
void | setItmNumber(String itmNumber) 条件明細番号を設定します。
void | setNumconvert(String numconvert) 条件単位を基本単位へ変換する分子を設定します。
void | setReflogsys(String reflogsys) 論理システムを設定します。
void | setRefobjkey(String refobjkey) オブジェクトキーを設定します。
void | setRefobjtype(String refobjtype) オブジェクトタイプを設定します。
void | setRoundoffdi(String roundoffdi) BAPI の通貨額 (小数点以下９桁)を設定します。
void | setScalbasval(String scalbasval) 条件のスケール基準値を設定します。
void | setScalebasin(String scalebasin) スケール基準区分を設定します。
void | setScaletype(String scaletype) スケールタイプを設定します。
void | setStatCon(String statCon) 統計に適用する条件を設定します。
void | setStructcond(String structcond) 構造条件を設定します。
void | setTaxCode(String taxCode) 消費税コードを設定します。
void | setUnitmeasur(String unitmeasur) 条件スケール単位を設定します。
void | setVarcond(String varcond) バリアント条件を設定します。
void | setWtWithcd(String wtWithcd) 源泉徴収税コードを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ConditionsIn

public ConditionsIn()
条件情報を作成します。

ConditionsIn

public ConditionsIn(int index)
条件情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getItmNumber

public String getItmNumber()
条件明細番号を取得します。

戻り値:
itmNumber 条件明細番号

getCondStNo

public String getCondStNo()
ステップ番号を取得します。

戻り値:
condStNo ステップ番号

getCondCount

public String getCondCount()
条件カウンタを取得します。

戻り値:
condCount 条件カウンタ

getCondType

public String getCondType()
条件タイプを取得します。

戻り値:
condType 条件タイプ

getCondValue

public String getCondValue()
条件レートを取得します。

戻り値:
condValue 条件レート

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
currency 通貨コード

getCondUnit

public String getCondUnit()
条件単位を取得します。

戻り値:
condUnit 条件単位

getCondPUnt

public String getCondPUnt()
価格条件単位を取得します。

戻り値:
condPUnt 価格条件単位

getCurrIso

public String getCurrIso()
ISO コード通貨を取得します。

戻り値:
currIso ISO コード通貨

getCdUntIso

public String getCdUntIso()
条件数量単位 (ISO コード)を取得します。

戻り値:
cdUntIso 条件数量単位 (ISO コード)

getRefobjtype

public String getRefobjtype()
オブジェクトタイプを取得します。

戻り値:
refobjtype オブジェクトタイプ

getRefobjkey

public String getRefobjkey()
オブジェクトキーを取得します。

戻り値:
refobjkey オブジェクトキー

getReflogsys

public String getReflogsys()
論理システムを取得します。

戻り値:
reflogsys 論理システム

getApplicatio

public String getApplicatio()
アプリケーションを取得します。

戻り値:
applicatio アプリケーション

getConpricdat

public String getConpricdat()
条件価格設定日付を取得します。

戻り値:
conpricdat 条件価格設定日付

getCalctypcon

public String getCalctypcon()
条件計算タイプを取得します。

戻り値:
calctypcon 条件計算タイプ

getConbaseval

public String getConbaseval()
条件基礎値を取得します。

戻り値:
conbaseval 条件基礎値

getConexchrat

public String getConexchrat()
現地通貨への換算レートに対する条件を取得します。

戻り値:
conexchrat 現地通貨への換算レートに対する条件

getNumconvert

public String getNumconvert()
条件単位を基本単位へ変換する分子を取得します。

戻り値:
numconvert 条件単位を基本単位へ変換する分子

getDenominato

public String getDenominato()
条件単位を基本単位へ変換する分母を取得します。

戻り値:
denominato 条件単位を基本単位へ変換する分母

getCondtype

public String getCondtype()
条件カテゴリ (例: 税、運賃、価格、原価)を取得します。

戻り値:
condtype 条件カテゴリ (例: 税、運賃、価格、原価)

getStatCon

public String getStatCon()
統計に適用する条件を取得します。

戻り値:
statCon 統計に適用する条件

getScaletype

public String getScaletype()
スケールタイプを取得します。

戻り値:
scaletype スケールタイプ

getAccruals

public String getAccruals()
見越額関連条件 (運賃など)を取得します。

戻り値:
accruals 見越額関連条件 (運賃など)

getConinvolst

public String getConinvolst()
請求書一覧条件を取得します。

戻り値:
coninvolst 請求書一覧条件

getCondorigin

public String getCondorigin()
条件生成区分を取得します。

戻り値:
condorigin 条件生成区分

getGroupcond

public String getGroupcond()
グループ条件区分を取得します。

戻り値:
groupcond グループ条件区分

getCondUpdat

public String getCondUpdat()
条件更新を取得します。

戻り値:
condUpdat 条件更新

getAccessSeq

public String getAccessSeq()
検索順序 - 検索番号を取得します。

戻り値:
accessSeq 検索順序 - 検索番号

getCondcount

public String getCondcount()
条件連続番号を取得します。

戻り値:
condcount 条件連続番号

getRoundoffdi

public String getRoundoffdi()
BAPI の通貨額 (小数点以下９桁)を取得します。

戻り値:
roundoffdi BAPI の通貨額 (小数点以下９桁)

getCondvalue

public String getCondvalue()
条件金額を取得します。

戻り値:
condvalue 条件金額

getCurrency2

public String getCurrency2()
販売伝票通貨を取得します。

戻り値:
currency2 販売伝票通貨

getCurrIso2

public String getCurrIso2()
ISO コード通貨を取得します。

戻り値:
currIso2 ISO コード通貨

getCondcntrl

public String getCondcntrl()
条件管理を取得します。

戻り値:
condcntrl 条件管理

getCondisacti

public String getCondisacti()
無効条件を取得します。

戻り値:
condisacti 無効条件

getCondclass

public String getCondclass()
条件クラスを取得します。

戻り値:
condclass 条件クラス

getFactbasval

public String getFactbasval()
条件基礎値に対する要因を取得します。

戻り値:
factbasval 条件基礎値に対する要因

getScalebasin

public String getScalebasin()
スケール基準区分を取得します。

戻り値:
scalebasin スケール基準区分

getScalbasval

public String getScalbasval()
条件のスケール基準値を取得します。

戻り値:
scalbasval 条件のスケール基準値

getUnitmeasur

public String getUnitmeasur()
条件スケール単位を取得します。

戻り値:
unitmeasur 条件スケール単位

getIsoUnit

public String getIsoUnit()
単位の ISO コードを取得します。

戻り値:
isoUnit 単位の ISO コード

getCurrenckey

public String getCurrenckey()
スケール通貨を取得します。

戻り値:
currenckey スケール通貨

getCurreniso

public String getCurreniso()
ISO コード通貨を取得します。

戻り値:
curreniso ISO コード通貨

getCondincomp

public String getCondincomp()
会社間請求の条件を取得します。

戻り値:
condincomp 会社間請求の条件

getCondconfig

public String getCondconfig()
システム設定の条件を取得します。

戻り値:
condconfig システム設定の条件

getCondchaman

public String getCondchaman()
条件 (マニュアル変更済)を取得します。

戻り値:
condchaman 条件 (マニュアル変更済)

getCondNo

public String getCondNo()
条件レコード番号を取得します。

戻り値:
condNo 条件レコード番号

getTaxCode

public String getTaxCode()
消費税コードを取得します。

戻り値:
taxCode 消費税コード

getVarcond

public String getVarcond()
バリアント条件を取得します。

戻り値:
varcond バリアント条件

getAccountkey

public String getAccountkey()
勘定キーを取得します。

戻り値:
accountkey 勘定キー

getAccountKe

public String getAccountKe()
勘定キー 見越/引当を取得します。

戻り値:
accountKe 勘定キー 見越/引当

getWtWithcd

public String getWtWithcd()
源泉徴収税コードを取得します。

戻り値:
wtWithcd 源泉徴収税コード

getStructcond

public String getStructcond()
構造条件を取得します。

戻り値:
structcond 構造条件

getFactconbas

public String getFactconbas()
条件基準の係数 (期間)を取得します。

戻り値:
factconbas 条件基準の係数 (期間)

getCondcoinhd

public String getCondcoinhd()
条件カウンタ (ヘッダ条件)を取得します。

戻り値:
condcoinhd 条件カウンタ (ヘッダ条件)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setItmNumber

public void setItmNumber(String itmNumber)
条件明細番号を設定します。

パラメータ:
itmNumber - 条件明細番号

setCondStNo

public void setCondStNo(String condStNo)
ステップ番号を設定します。

パラメータ:
condStNo - ステップ番号

setCondCount

public void setCondCount(String condCount)
条件カウンタを設定します。

パラメータ:
condCount - 条件カウンタ

setCondType

public void setCondType(String condType)
条件タイプを設定します。

パラメータ:
condType - 条件タイプ

setCondValue

public void setCondValue(String condValue)
条件レートを設定します。

パラメータ:
condValue - 条件レート

setCurrency

public void setCurrency(String currency)
通貨コードを設定します。

パラメータ:
currency - 通貨コード

setCondUnit

public void setCondUnit(String condUnit)
条件単位を設定します。

パラメータ:
condUnit - 条件単位

setCondPUnt

public void setCondPUnt(String condPUnt)
価格条件単位を設定します。

パラメータ:
condPUnt - 価格条件単位

setCurrIso

public void setCurrIso(String currIso)
ISO コード通貨を設定します。

パラメータ:
currIso - ISO コード通貨

setCdUntIso

public void setCdUntIso(String cdUntIso)
条件数量単位 (ISO コード)を設定します。

パラメータ:
cdUntIso - 条件数量単位 (ISO コード)

setRefobjtype

public void setRefobjtype(String refobjtype)
オブジェクトタイプを設定します。

パラメータ:
refobjtype - オブジェクトタイプ

setRefobjkey

public void setRefobjkey(String refobjkey)
オブジェクトキーを設定します。

パラメータ:
refobjkey - オブジェクトキー

setReflogsys

public void setReflogsys(String reflogsys)
論理システムを設定します。

パラメータ:
reflogsys - 論理システム

setApplicatio

public void setApplicatio(String applicatio)
アプリケーションを設定します。

パラメータ:
applicatio - アプリケーション

setConpricdat

public void setConpricdat(String conpricdat)
条件価格設定日付を設定します。

パラメータ:
conpricdat - 条件価格設定日付

setCalctypcon

public void setCalctypcon(String calctypcon)
条件計算タイプを設定します。

パラメータ:
calctypcon - 条件計算タイプ

setConbaseval

public void setConbaseval(String conbaseval)
条件基礎値を設定します。

パラメータ:
conbaseval - 条件基礎値

setConexchrat

public void setConexchrat(String conexchrat)
現地通貨への換算レートに対する条件を設定します。

パラメータ:
conexchrat - 現地通貨への換算レートに対する条件

setNumconvert

public void setNumconvert(String numconvert)
条件単位を基本単位へ変換する分子を設定します。

パラメータ:
numconvert - 条件単位を基本単位へ変換する分子

setDenominato

public void setDenominato(String denominato)
条件単位を基本単位へ変換する分母を設定します。

パラメータ:
denominato - 条件単位を基本単位へ変換する分母

setCondtype

public void setCondtype(String condtype)
条件カテゴリ (例: 税、運賃、価格、原価)を設定します。

パラメータ:
condtype - 条件カテゴリ (例: 税、運賃、価格、原価)

setStatCon

public void setStatCon(String statCon)
統計に適用する条件を設定します。

パラメータ:
statCon - 統計に適用する条件

setScaletype

public void setScaletype(String scaletype)
スケールタイプを設定します。

パラメータ:
scaletype - スケールタイプ

setAccruals

public void setAccruals(String accruals)
見越額関連条件 (運賃など)を設定します。

パラメータ:
accruals - 見越額関連条件 (運賃など)

setConinvolst

public void setConinvolst(String coninvolst)
請求書一覧条件を設定します。

パラメータ:
coninvolst - 請求書一覧条件

setCondorigin

public void setCondorigin(String condorigin)
条件生成区分を設定します。

パラメータ:
condorigin - 条件生成区分

setGroupcond

public void setGroupcond(String groupcond)
グループ条件区分を設定します。

パラメータ:
groupcond - グループ条件区分

setCondUpdat

public void setCondUpdat(String condUpdat)
条件更新を設定します。

パラメータ:
condUpdat - 条件更新

setAccessSeq

public void setAccessSeq(String accessSeq)
検索順序 - 検索番号を設定します。

パラメータ:
accessSeq - 検索順序 - 検索番号

setCondcount

public void setCondcount(String condcount)
条件連続番号を設定します。

パラメータ:
condcount - 条件連続番号

setRoundoffdi

public void setRoundoffdi(String roundoffdi)
BAPI の通貨額 (小数点以下９桁)を設定します。

パラメータ:
roundoffdi - BAPI の通貨額 (小数点以下９桁)

setCondvalue

public void setCondvalue(String condvalue)
条件金額を設定します。

パラメータ:
condvalue - 条件金額

setCurrency2

public void setCurrency2(String currency2)
販売伝票通貨を設定します。

パラメータ:
currency2 - 販売伝票通貨

setCurrIso2

public void setCurrIso2(String currIso2)
ISO コード通貨を設定します。

パラメータ:
currIso2 - ISO コード通貨

setCondcntrl

public void setCondcntrl(String condcntrl)
条件管理を設定します。

パラメータ:
condcntrl - 条件管理

setCondisacti

public void setCondisacti(String condisacti)
無効条件を設定します。

パラメータ:
condisacti - 無効条件

setCondclass

public void setCondclass(String condclass)
条件クラスを設定します。

パラメータ:
condclass - 条件クラス

setFactbasval

public void setFactbasval(String factbasval)
条件基礎値に対する要因を設定します。

パラメータ:
factbasval - 条件基礎値に対する要因

setScalebasin

public void setScalebasin(String scalebasin)
スケール基準区分を設定します。

パラメータ:
scalebasin - スケール基準区分

setScalbasval

public void setScalbasval(String scalbasval)
条件のスケール基準値を設定します。

パラメータ:
scalbasval - 条件のスケール基準値

setUnitmeasur

public void setUnitmeasur(String unitmeasur)
条件スケール単位を設定します。

パラメータ:
unitmeasur - 条件スケール単位

setIsoUnit

public void setIsoUnit(String isoUnit)
単位の ISO コードを設定します。

パラメータ:
isoUnit - 単位の ISO コード

setCurrenckey

public void setCurrenckey(String currenckey)
スケール通貨を設定します。

パラメータ:
currenckey - スケール通貨

setCurreniso

public void setCurreniso(String curreniso)
ISO コード通貨を設定します。

パラメータ:
curreniso - ISO コード通貨

setCondincomp

public void setCondincomp(String condincomp)
会社間請求の条件を設定します。

パラメータ:
condincomp - 会社間請求の条件

setCondconfig

public void setCondconfig(String condconfig)
システム設定の条件を設定します。

パラメータ:
condconfig - システム設定の条件

setCondchaman

public void setCondchaman(String condchaman)
条件 (マニュアル変更済)を設定します。

パラメータ:
condchaman - 条件 (マニュアル変更済)

setCondNo

public void setCondNo(String condNo)
条件レコード番号を設定します。

パラメータ:
condNo - 条件レコード番号

setTaxCode

public void setTaxCode(String taxCode)
消費税コードを設定します。

パラメータ:
taxCode - 消費税コード

setVarcond

public void setVarcond(String varcond)
バリアント条件を設定します。

パラメータ:
varcond - バリアント条件

setAccountkey

public void setAccountkey(String accountkey)
勘定キーを設定します。

パラメータ:
accountkey - 勘定キー

setAccountKe

public void setAccountKe(String accountKe)
勘定キー 見越/引当を設定します。

パラメータ:
accountKe - 勘定キー 見越/引当

setWtWithcd

public void setWtWithcd(String wtWithcd)
源泉徴収税コードを設定します。

パラメータ:
wtWithcd - 源泉徴収税コード

setStructcond

public void setStructcond(String structcond)
構造条件を設定します。

パラメータ:
structcond - 構造条件

setFactconbas

public void setFactconbas(String factconbas)
条件基準の係数 (期間)を設定します。

パラメータ:
factconbas - 条件基準の係数 (期間)

setCondcoinhd

public void setCondcoinhd(String condcoinhd)
条件カウンタ (ヘッダ条件)を設定します。

パラメータ:
condcoinhd - 条件カウンタ (ヘッダ条件)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ConditionsInX (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ConditionsInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX
すべての実装インタフェース:
Serializable
public class ConditionsInX
extends Object
implements Serializable

受注における条件更新の通信項目情報クラス
機能は以下の通り

  • 受注における条件更新の通信項目情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ConditionsInX()
受注における条件更新の通信項目情報を作成します。
ConditionsInX(int index)
受注における条件更新の通信項目情報を作成します。
メソッドの概要
String | getCondCount() 条件連続番号を取得します。
String | getCondPUnt() 関連ユーザデータ項目の更新情報を取得します。
String | getCondStNo() ステップ番号を取得します。
String | getCondType() 条件タイプを取得します。
String | getCondUnit() 関連ユーザデータ項目の更新情報を取得します。
String | getCondValue() 関連ユーザデータ項目の更新情報を取得します。
String | getCurrency() 関連ユーザデータ項目の更新情報を取得します。
int | getIndex() レコード番号を取得します｡
String | getItmNumber() 条件明細番号を取得します。
String | getUpdateflag() 更新区分を取得します。
String | getVarcond() バリアント条件を取得します。
void | setCondCount(String condCount) 条件連続番号を設定します。
void | setCondPUnt(String condPUnt) 関連ユーザデータ項目の更新情報を設定します。
void | setCondStNo(String condStNo) ステップ番号を設定します。
void | setCondType(String condType) 条件タイプを設定します。
void | setCondUnit(String condUnit) 関連ユーザデータ項目の更新情報を設定します。
void | setCondValue(String condValue) 関連ユーザデータ項目の更新情報を設定します。
void | setCurrency(String currency) 関連ユーザデータ項目の更新情報を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItmNumber(String itmNumber) 条件明細番号を設定します。
void | setUpdateflag(String updateflag) 更新区分を設定します。
void | setVarcond(String varcond) バリアント条件を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ConditionsInX

public ConditionsInX()
受注における条件更新の通信項目情報を作成します。

ConditionsInX

public ConditionsInX(int index)
受注における条件更新の通信項目情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getItmNumber

public String getItmNumber()
条件明細番号を取得します。

戻り値:
itmNumber 条件明細番号

getCondStNo

public String getCondStNo()
ステップ番号を取得します。

戻り値:
condStNo ステップ番号

getCondCount

public String getCondCount()
条件連続番号を取得します。

戻り値:
condCount 条件連続番号

getCondType

public String getCondType()
条件タイプを取得します。

戻り値:
condType 条件タイプ

getUpdateflag

public String getUpdateflag()
更新区分を取得します。

戻り値:
updateflag 更新区分

getCondValue

public String getCondValue()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
condValue 関連ユーザデータ項目の更新情報

getCurrency

public String getCurrency()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
currency 関連ユーザデータ項目の更新情報

getCondUnit

public String getCondUnit()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
condUnit 関連ユーザデータ項目の更新情報

getCondPUnt

public String getCondPUnt()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
condPUnt 関連ユーザデータ項目の更新情報

getVarcond

public String getVarcond()
バリアント条件を取得します。

戻り値:
varcond バリアント条件

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setItmNumber

public void setItmNumber(String itmNumber)
条件明細番号を設定します。

パラメータ:
itmNumber - 条件明細番号

setCondStNo

public void setCondStNo(String condStNo)
ステップ番号を設定します。

パラメータ:
condStNo - ステップ番号

setCondCount

public void setCondCount(String condCount)
条件連続番号を設定します。

パラメータ:
condCount - 条件連続番号

setCondType

public void setCondType(String condType)
条件タイプを設定します。

パラメータ:
condType - 条件タイプ

setUpdateflag

public void setUpdateflag(String updateflag)
更新区分を設定します。

パラメータ:
updateflag - 更新区分

setCondValue

public void setCondValue(String condValue)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
condValue - 関連ユーザデータ項目の更新情報

setCurrency

public void setCurrency(String currency)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
currency - 関連ユーザデータ項目の更新情報

setCondUnit

public void setCondUnit(String condUnit)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
condUnit - 関連ユーザデータ項目の更新情報

setCondPUnt

public void setCondPUnt(String condPUnt)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
condPUnt - 関連ユーザデータ項目の更新情報

setVarcond

public void setVarcond(String varcond)
バリアント条件を設定します。

パラメータ:
varcond - バリアント条件

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtensionIn (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ExtensionIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn
すべての実装インタフェース:
Serializable
public class ExtensionIn
extends Object
implements Serializable

VBAK、VBAP、VBEP のカスタマ拡張情報クラス
機能は以下の通り

  • VBAK、VBAP、VBEP のカスタマ拡張情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExtensionIn()
VBAK、VBAP、VBEP のカスタマ拡張情報を作成します。
ExtensionIn(int index)
VBAK、VBAP、VBEP のカスタマ拡張情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
String | getStructure() BAPI テーブル拡張の構造名を取得します。
String | getValuepart1() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart2() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart3() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart4() BAPI 拡張パラメータのデータ部分を取得します。
void | setIndex(int index) レコード番号を設定します｡
void | setStructure(String structure) BAPI テーブル拡張の構造名を設定します。
void | setValuepart1(String valuepart1) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart2(String valuepart2) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart3(String valuepart3) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart4(String valuepart4) BAPI 拡張パラメータのデータ部分を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtensionIn

public ExtensionIn()
VBAK、VBAP、VBEP のカスタマ拡張情報を作成します。

ExtensionIn

public ExtensionIn(int index)
VBAK、VBAP、VBEP のカスタマ拡張情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getStructure

public String getStructure()
BAPI テーブル拡張の構造名を取得します。

戻り値:
structure BAPI テーブル拡張の構造名

getValuepart1

public String getValuepart1()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart1 BAPI 拡張パラメータのデータ部分

getValuepart2

public String getValuepart2()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart2 BAPI 拡張パラメータのデータ部分

getValuepart3

public String getValuepart3()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart3 BAPI 拡張パラメータのデータ部分

getValuepart4

public String getValuepart4()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart4 BAPI 拡張パラメータのデータ部分

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setStructure

public void setStructure(String structure)
BAPI テーブル拡張の構造名を設定します。

パラメータ:
structure - BAPI テーブル拡張の構造名

setValuepart1

public void setValuepart1(String valuepart1)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart1 - BAPI 拡張パラメータのデータ部分

setValuepart2

public void setValuepart2(String valuepart2)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart2 - BAPI 拡張パラメータのデータ部分

setValuepart3

public void setValuepart3(String valuepart3)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart3 - BAPI 拡張パラメータのデータ部分

setValuepart4

public void setValuepart4(String valuepart4)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart4 - BAPI 拡張パラメータのデータ部分

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HeaderIn (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス HeaderIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn
すべての実装インタフェース:
Serializable
public class HeaderIn
extends Object
implements Serializable

販売伝票ヘッダデータ情報クラス
機能は以下の通り

  • 販売伝票ヘッダデータ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
HeaderIn()
販売伝票ヘッダデータ情報を作成します。
メソッドの概要
String | getAccntAsgn() 得意先の勘定設定グループを取得します。
String | getAddValDy() 有効日からの日数を取得します。
String | getAlttaxCls() 代替税分類を取得します。
String | getAssNumber() 割当番号を取得します。
String | getBillBlock() 販売管理伝票の請求ブロックを取得します。
String | getBillDate() 請求索引および印刷に対する請求日を取得します。
String | getBillSched() 請求日程 (稼働日カレンダ指定)を取得します。
String | getCampaign() 総括プロジェクト計画: 外部 R/3 システムの GUIDを取得します。
String | getChkprtauth() 取引先権限チェックを取得します。
String | getCmlqtyDat() 累積出荷数量日付を取得します。
String | getCollectNo() 一括番号を取得します。
String | getCompCdeB() 請求対象会社コードを取得します。
String | getComplDlv() 一括納入区分を取得します。
String | getCreatedBy() オブジェクト登録者名を取得します。
String | getCstcndgrp1() 得意先条件グループ１を取得します。
String | getCstcndgrp2() 得意先条件グループ２を取得します。
String | getCstcndgrp3() 得意先条件グループ３を取得します。
String | getCstcndgrp4() 得意先条件グループ４を取得します。
String | getCstcndgrp5() 得意先条件グループ５を取得します。
String | getCtValidF() 有効開始日付 (販売契約/品目提案)を取得します。
String | getCtValidT() 有効終了日付 (販売契約/品目提案)を取得します。
String | getCurrency() 販売伝票通貨を取得します。
String | getCurrIso() ISO コード通貨を取得します。
String | getCustGroup() 得意先グループを取得します。
String | getCustGrp1() 得意先グループ 1を取得します。
String | getCustGrp2() 得意先グループ 2を取得します。
String | getCustGrp3() 得意先グループ 3を取得します。
String | getCustGrp4() 得意先グループ 4を取得します。
String | getCustGrp5() 得意先グループ 5を取得します。
String | getDateType() 提案日付タイプを取得します。
String | getDepartmNo() 部門コードを取得します。
String | getDistrChan() 流通チャネルを取得します。
String | getDivision() 製品部門を取得します。
String | getDlvBlock() 出荷ブロック (伝票ヘッダ)を取得します。
String | getDlvschduse() 用途区分を取得します。
String | getDlvTime() 契約出荷期間を取得します。
String | getDocClass() リリースおよびトランザクション管理を備えた元システムを取得します。
String | getDocDate() 伝票日付 (受信日/送信日)を取得します。
String | getDocNumFi() ドキュメンタリクレジット処理: 内部番号を取得します。
String | getDocType() 販売伝票タイプを取得します。
String | getDunCount() 得意先商談回数を取得します。
String | getDunDate() 得意先との前回の商談日を取得します。
String | getDunnBlock() 督促処理保留を取得します。
String | getDunnKey() 督促処理キーを取得します。
String | getEutriDeal() フラグ: EC 内三角取引を取得します。
String | getExchgRate() 価格設定/統計の換算レート (直接引用)を取得します。
String | getExchgRateV() 価格設定/統計の換算レート (間接引用)を取得します。
String | getExchRateFiV() FI 転記の換算レート (間接相場)を取得します。
String | getExrateFi() FI 転記の換算レート (直接相場)を取得します。
String | getFixValDy() 有効日日付を取得します。
String | getFkkConacct() 長さ 12 の文字項目を取得します。
String | getHCurr() 通貨コードを取得します。
String | getHCurrIso() ISO 通貨コードを取得します。
String | getIncoterms1() インコタームズ (1)を取得します。
String | getIncoterms2() インコタームズ 2を取得します。
String | getInvoSched() 請求書一覧日程 (稼働日カレンダ指定)を取得します。
String | getMastContr() グループマスタ契約番号を取得します。
String | getMnInvoice() マニュアル請求書更新を取得します。
String | getName() 発注者名称を取得します。
String | getNotifNo() 通知番号を取得します。
String | getOrdcombIn() 受注結合出荷区分を取得します。
String | getOrdReason() 受注理由 (取引理由)を取得します。
String | getPldlvstyp() MRP: 出荷計画タイプを取得します。
String | getPmnttrms() 支払条件キーを取得します。
String | getPmtgarPro() 支払保証決定表を取得します。
String | getPoDatS() 出荷先の出荷先発注日付を取得します。
String | getPoMethod() 得意先発注タイプを取得します。
String | getPoMethS() 出荷先の出荷先発注タイプを取得します。
String | getPoSupplem() 得意先発注番号補足を取得します。
String | getPpSearch() 品目提案検索条件を取得します。
String | getPriceDate() 価格設定/外貨換算の実行日付を取得します。
String | getPriceGrp() 価格グループ (得意先)を取得します。
String | getPriceList() 価格表タイプを取得します。
String | getPurchDate() 得意先発注日付を取得します。
String | getPurchNoC() 出荷先発注番号を取得します。
String | getPurchNoS() 出荷先の得意先発注番号を取得します。
String | getPymtMeth() 支払方法を取得します。
String | getQtValidF() 見積/引合有効開始日を取得します。
String | getQtValidT() 見積の有効終了日を取得します。
String | getRecPoint() 入荷ポイントを取得します。
String | getRef1() 得意先/仕入先の内部参照コードを取得します。
String | getRef1S() 出荷先文字を取得します。
String | getRefDoc() 参照伝票番号を取得します。
String | getRefdocCat() 先行販売管理伝票の伝票カテゴリを取得します。
String | getRefDocL() 参照伝票番号を取得します。
String | getRefDocLLong() 参照伝票番号 (依存関係についてはテキスト (長) を参照)を取得します。
String | getRefdoctype() 参照オブジェクトの伝票タイプを取得します。
String | getRefobjkey() オブジェクトキーを取得します。
String | getRefobjtype() オブジェクトタイプを取得します。
String | getRefProc() 参照限定条件: 決定区分を取得します。
String | getReqDateH() 指定納入期日を取得します。
String | getSalesDist() 販売地域を取得します。
String | getSalesGrp() 営業グループを取得します。
String | getSalesOff() 営業所を取得します。
String | getSalesOrg() 販売組織を取得します。
String | getSdDocCat() 販売管理伝票カテゴリを取得します。
String | getServDate() サービス提供日を取得します。
String | getShipCond() 出荷条件を取得します。
String | getShipType() 出荷タイプを取得します。
String | getSProcInd() 特別処理区分を取得します。
String | getTaxClass2() 得意先税分類 2を取得します。
String | getTaxClass3() 得意先税分類 3を取得します。
String | getTaxClass4() 得意先に対する税クラス 4を取得します。
String | getTaxClass5() 得意先に対する税クラス 5を取得します。
String | getTaxClass6() 得意先に対する税クラス 6を取得します。
String | getTaxClass7() 得意先に対する税クラス 7を取得します。
String | getTaxClass8() 得意先に対する税クラス 8を取得します。
String | getTaxClass9() 得意先に対する税クラス 9を取得します。
String | getTaxdepCty() 税出荷国を取得します。
String | getTaxdstCty() 税仕向国を取得します。
String | getTelephone() 電話番号を取得します。
String | getVersion() 販売伝票バージョン番号を取得します。
String | getWarDate() 保証期間の開始日付を取得します。
String | getWbsElem() WBS 要素を取得します。
void | setAccntAsgn(String accntAsgn) 得意先の勘定設定グループを設定します。
void | setAddValDy(String addValDy) 有効日からの日数を設定します。
void | setAlttaxCls(String alttaxCls) 代替税分類を設定します。
void | setAssNumber(String assNumber) 割当番号を設定します。
void | setBillBlock(String billBlock) 販売管理伝票の請求ブロックを設定します。
void | setBillDate(String billDate) 請求索引および印刷に対する請求日を設定します。
void | setBillSched(String billSched) 請求日程 (稼働日カレンダ指定)を設定します。
void | setCampaign(String campaign) 総括プロジェクト計画: 外部 R/3 システムの GUIDを設定します。
void | setChkprtauth(String chkprtauth) 取引先権限チェックを設定します。
void | setCmlqtyDat(String cmlqtyDat) 累積出荷数量日付を設定します。
void | setCollectNo(String collectNo) 一括番号を設定します。
void | setCompCdeB(String compCdeB) 請求対象会社コードを設定します。
void | setComplDlv(String complDlv) 一括納入区分を設定します。
void | setCreatedBy(String createdBy) オブジェクト登録者名を設定します。
void | setCstcndgrp1(String cstcndgrp1) 得意先条件グループ１を設定します。
void | setCstcndgrp2(String cstcndgrp2) 得意先条件グループ２を設定します。
void | setCstcndgrp3(String cstcndgrp3) 得意先条件グループ３を設定します。
void | setCstcndgrp4(String cstcndgrp4) 得意先条件グループ４を設定します。
void | setCstcndgrp5(String cstcndgrp5) 得意先条件グループ５を設定します。
void | setCtValidF(String ctValidF) 有効開始日付 (販売契約/品目提案)を設定します。
void | setCtValidT(String ctValidT) 有効終了日付 (販売契約/品目提案)を設定します。
void | setCurrency(String currency) 販売伝票通貨を設定します。
void | setCurrIso(String currIso) ISO コード通貨を設定します。
void | setCustGroup(String custGroup) 得意先グループを設定します。
void | setCustGrp1(String custGrp1) 得意先グループ 1を設定します。
void | setCustGrp2(String custGrp2) 得意先グループ 2を設定します。
void | setCustGrp3(String custGrp3) 得意先グループ 3を設定します。
void | setCustGrp4(String custGrp4) 得意先グループ 4を設定します。
void | setCustGrp5(String custGrp5) 得意先グループ 5を設定します。
void | setDateType(String dateType) 提案日付タイプを設定します。
void | setDepartmNo(String departmNo) 部門コードを設定します。
void | setDistrChan(String distrChan) 流通チャネルを設定します。
void | setDivision(String division) 製品部門を設定します。
void | setDlvBlock(String dlvBlock) 出荷ブロック (伝票ヘッダ)を設定します。
void | setDlvschduse(String dlvschduse) 用途区分を設定します。
void | setDlvTime(String dlvTime) 契約出荷期間を設定します。
void | setDocClass(String docClass) リリースおよびトランザクション管理を備えた元システムを設定します。
void | setDocDate(String docDate) 伝票日付 (受信日/送信日)を設定します。
void | setDocNumFi(String docNumFi) ドキュメンタリクレジット処理: 内部番号を設定します。
void | setDocType(String docType) 販売伝票タイプを設定します。
void | setDunCount(String dunCount) 得意先商談回数を設定します。
void | setDunDate(String dunDate) 得意先との前回の商談日を設定します。
void | setDunnBlock(String dunnBlock) 督促処理保留を設定します。
void | setDunnKey(String dunnKey) 督促処理キーを設定します。
void | setEutriDeal(String eutriDeal) フラグ: EC 内三角取引を設定します。
void | setExchgRate(String exchgRate) 価格設定/統計の換算レート (直接引用)を設定します。
void | setExchgRateV(String exchgRateV) 価格設定/統計の換算レート (間接引用)を設定します。
void | setExchRateFiV(String exchRateFiV) FI 転記の換算レート (間接相場)を設定します。
void | setExrateFi(String exrateFi) FI 転記の換算レート (直接相場)を設定します。
void | setFixValDy(String fixValDy) 有効日日付を設定します。
void | setFkkConacct(String fkkConacct) 長さ 12 の文字項目を設定します。
void | setHCurr(String hCurr) 通貨コードを設定します。
void | setHCurrIso(String hCurrIso) ISO 通貨コードを設定します。
void | setIncoterms1(String incoterms1) インコタームズ (1)を設定します。
void | setIncoterms2(String incoterms2) インコタームズ 2を設定します。
void | setInvoSched(String invoSched) 請求書一覧日程 (稼働日カレンダ指定)を設定します。
void | setMastContr(String mastContr) グループマスタ契約番号を設定します。
void | setMnInvoice(String mnInvoice) マニュアル請求書更新を設定します。
void | setName(String name) 発注者名称を設定します。
void | setNotifNo(String notifNo) 通知番号を設定します。
void | setOrdcombIn(String ordcombIn) 受注結合出荷区分を設定します。
void | setOrdReason(String ordReason) 受注理由 (取引理由)を設定します。
void | setPldlvstyp(String pldlvstyp) MRP: 出荷計画タイプを設定します。
void | setPmnttrms(String pmnttrms) 支払条件キーを設定します。
void | setPmtgarPro(String pmtgarPro) 支払保証決定表を設定します。
void | setPoDatS(String poDatS) 出荷先の出荷先発注日付を設定します。
void | setPoMethod(String poMethod) 得意先発注タイプを設定します。
void | setPoMethS(String poMethS) 出荷先の出荷先発注タイプを設定します。
void | setPoSupplem(String poSupplem) 得意先発注番号補足を設定します。
void | setPpSearch(String ppSearch) 品目提案検索条件を設定します。
void | setPriceDate(String priceDate) 価格設定/外貨換算の実行日付を設定します。
void | setPriceGrp(String priceGrp) 価格グループ (得意先)を設定します。
void | setPriceList(String priceList) 価格表タイプを設定します。
void | setPurchDate(String purchDate) 得意先発注日付を設定します。
void | setPurchNoC(String purchNoC) 出荷先発注番号を設定します。
void | setPurchNoS(String purchNoS) 出荷先の得意先発注番号を設定します。
void | setPymtMeth(String pymtMeth) 支払方法を設定します。
void | setQtValidF(String qtValidF) 見積/引合有効開始日を設定します。
void | setQtValidT(String qtValidT) 見積の有効終了日を設定します。
void | setRecPoint(String recPoint) 入荷ポイントを設定します。
void | setRef1(String ref1) 得意先/仕入先の内部参照コードを設定します。
void | setRef1S(String ref1S) 出荷先文字を設定します。
void | setRefDoc(String refDoc) 参照伝票番号を設定します。
void | setRefdocCat(String refdocCat) 先行販売管理伝票の伝票カテゴリを設定します。
void | setRefDocL(String refDocL) 参照伝票番号を設定します。
void | setRefDocLLong(String refDocLLong) 参照伝票番号 (依存関係についてはテキスト (長) を参照)を設定します。
void | setRefdoctype(String refdoctype) 参照オブジェクトの伝票タイプを設定します。
void | setRefobjkey(String refobjkey) オブジェクトキーを設定します。
void | setRefobjtype(String refobjtype) オブジェクトタイプを設定します。
void | setRefProc(String refProc) 参照限定条件: 決定区分を設定します。
void | setReqDateH(String reqDateH) 指定納入期日を設定します。
void | setSalesDist(String salesDist) 販売地域を設定します。
void | setSalesGrp(String salesGrp) 営業グループを設定します。
void | setSalesOff(String salesOff) 営業所を設定します。
void | setSalesOrg(String salesOrg) 販売組織を設定します。
void | setSdDocCat(String sdDocCat) 販売管理伝票カテゴリを設定します。
void | setServDate(String servDate) サービス提供日を設定します。
void | setShipCond(String shipCond) 出荷条件を設定します。
void | setShipType(String shipType) 出荷タイプを設定します。
void | setSProcInd(String sProcInd) 特別処理区分を設定します。
void | setTaxClass2(String taxClass2) 得意先税分類 2を設定します。
void | setTaxClass3(String taxClass3) 得意先税分類 3を設定します。
void | setTaxClass4(String taxClass4) 得意先に対する税クラス 4を設定します。
void | setTaxClass5(String taxClass5) 得意先に対する税クラス 5を設定します。
void | setTaxClass6(String taxClass6) 得意先に対する税クラス 6を設定します。
void | setTaxClass7(String taxClass7) 得意先に対する税クラス 7を設定します。
void | setTaxClass8(String taxClass8) 得意先に対する税クラス 8を設定します。
void | setTaxClass9(String taxClass9) 得意先に対する税クラス 9を設定します。
void | setTaxdepCty(String taxdepCty) 税出荷国を設定します。
void | setTaxdstCty(String taxdstCty) 税仕向国を設定します。
void | setTelephone(String telephone) 電話番号を設定します。
void | setVersion(String version) 販売伝票バージョン番号を設定します。
void | setWarDate(String warDate) 保証期間の開始日付を設定します。
void | setWbsElem(String wbsElem) WBS 要素を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HeaderIn

public HeaderIn()
販売伝票ヘッダデータ情報を作成します。

メソッドの詳細

getRefobjtype

public String getRefobjtype()
オブジェクトタイプを取得します。

戻り値:
refobjtype オブジェクトタイプ

getRefobjkey

public String getRefobjkey()
オブジェクトキーを取得します。

戻り値:
refobjkey オブジェクトキー

getRefdoctype

public String getRefdoctype()
参照オブジェクトの伝票タイプを取得します。

戻り値:
refdoctype 参照オブジェクトの伝票タイプ

getDocType

public String getDocType()
販売伝票タイプを取得します。

戻り値:
docType 販売伝票タイプ

getCollectNo

public String getCollectNo()
一括番号を取得します。

戻り値:
collectNo 一括番号

getSalesOrg

public String getSalesOrg()
販売組織を取得します。

戻り値:
salesOrg 販売組織

getDistrChan

public String getDistrChan()
流通チャネルを取得します。

戻り値:
distrChan 流通チャネル

getDivision

public String getDivision()
製品部門を取得します。

戻り値:
division 製品部門

getSalesGrp

public String getSalesGrp()
営業グループを取得します。

戻り値:
salesGrp 営業グループ

getSalesOff

public String getSalesOff()
営業所を取得します。

戻り値:
salesOff 営業所

getReqDateH

public String getReqDateH()
指定納入期日を取得します。

戻り値:
reqDateH 指定納入期日

getDateType

public String getDateType()
提案日付タイプを取得します。

戻り値:
dateType 提案日付タイプ

getPurchDate

public String getPurchDate()
得意先発注日付を取得します。

戻り値:
purchDate 得意先発注日付

getPoMethod

public String getPoMethod()
得意先発注タイプを取得します。

戻り値:
poMethod 得意先発注タイプ

getPoSupplem

public String getPoSupplem()
得意先発注番号補足を取得します。

戻り値:
poSupplem 得意先発注番号補足

getRef1

public String getRef1()
得意先/仕入先の内部参照コードを取得します。

戻り値:
ref1 得意先/仕入先の内部参照コード

getName

public String getName()
発注者名称を取得します。

戻り値:
name 発注者名称

getTelephone

public String getTelephone()
電話番号を取得します。

戻り値:
telephone 電話番号

getPriceGrp

public String getPriceGrp()
価格グループ (得意先)を取得します。

戻り値:
priceGrp 価格グループ (得意先)

getCustGroup

public String getCustGroup()
得意先グループを取得します。

戻り値:
custGroup 得意先グループ

getSalesDist

public String getSalesDist()
販売地域を取得します。

戻り値:
salesDist 販売地域

getPriceList

public String getPriceList()
価格表タイプを取得します。

戻り値:
priceList 価格表タイプ

getIncoterms1

public String getIncoterms1()
インコタームズ (1)を取得します。

戻り値:
incoterms1 インコタームズ (1)

getIncoterms2

public String getIncoterms2()
インコタームズ 2を取得します。

戻り値:
incoterms2 インコタームズ 2

getPmnttrms

public String getPmnttrms()
支払条件キーを取得します。

戻り値:
pmnttrms 支払条件キー

getDlvBlock

public String getDlvBlock()
出荷ブロック (伝票ヘッダ)を取得します。

戻り値:
dlvBlock 出荷ブロック (伝票ヘッダ)

getBillBlock

public String getBillBlock()
販売管理伝票の請求ブロックを取得します。

戻り値:
billBlock 販売管理伝票の請求ブロック

getOrdReason

public String getOrdReason()
受注理由 (取引理由)を取得します。

戻り値:
ordReason 受注理由 (取引理由)

getComplDlv

public String getComplDlv()
一括納入区分を取得します。

戻り値:
complDlv 一括納入区分

getPriceDate

public String getPriceDate()
価格設定/外貨換算の実行日付を取得します。

戻り値:
priceDate 価格設定/外貨換算の実行日付

getQtValidF

public String getQtValidF()
見積/引合有効開始日を取得します。

戻り値:
qtValidF 見積/引合有効開始日

getQtValidT

public String getQtValidT()
見積の有効終了日を取得します。

戻り値:
qtValidT 見積の有効終了日

getCtValidF

public String getCtValidF()
有効開始日付 (販売契約/品目提案)を取得します。

戻り値:
ctValidF 有効開始日付 (販売契約/品目提案)

getCtValidT

public String getCtValidT()
有効終了日付 (販売契約/品目提案)を取得します。

戻り値:
ctValidT 有効終了日付 (販売契約/品目提案)

getCustGrp1

public String getCustGrp1()
得意先グループ 1を取得します。

戻り値:
custGrp1 得意先グループ 1

getCustGrp2

public String getCustGrp2()
得意先グループ 2を取得します。

戻り値:
custGrp2 得意先グループ 2

getCustGrp3

public String getCustGrp3()
得意先グループ 3を取得します。

戻り値:
custGrp3 得意先グループ 3

getCustGrp4

public String getCustGrp4()
得意先グループ 4を取得します。

戻り値:
custGrp4 得意先グループ 4

getCustGrp5

public String getCustGrp5()
得意先グループ 5を取得します。

戻り値:
custGrp5 得意先グループ 5

getPurchNoC

public String getPurchNoC()
出荷先発注番号を取得します。

戻り値:
purchNoC 出荷先発注番号

getPurchNoS

public String getPurchNoS()
出荷先の得意先発注番号を取得します。

戻り値:
purchNoS 出荷先の得意先発注番号

getPoDatS

public String getPoDatS()
出荷先の出荷先発注日付を取得します。

戻り値:
poDatS 出荷先の出荷先発注日付

getPoMethS

public String getPoMethS()
出荷先の出荷先発注タイプを取得します。

戻り値:
poMethS 出荷先の出荷先発注タイプ

getRef1S

public String getRef1S()
出荷先文字を取得します。

戻り値:
ref1S 出荷先文字

getSdDocCat

public String getSdDocCat()
販売管理伝票カテゴリを取得します。

戻り値:
sdDocCat 販売管理伝票カテゴリ

getDocDate

public String getDocDate()
伝票日付 (受信日/送信日)を取得します。

戻り値:
docDate 伝票日付 (受信日/送信日)

getWarDate

public String getWarDate()
保証期間の開始日付を取得します。

戻り値:
warDate 保証期間の開始日付

getShipCond

public String getShipCond()
出荷条件を取得します。

戻り値:
shipCond 出荷条件

getPpSearch

public String getPpSearch()
品目提案検索条件を取得します。

戻り値:
ppSearch 品目提案検索条件

getDunCount

public String getDunCount()
得意先商談回数を取得します。

戻り値:
dunCount 得意先商談回数

getDunDate

public String getDunDate()
得意先との前回の商談日を取得します。

戻り値:
dunDate 得意先との前回の商談日

getDlvschduse

public String getDlvschduse()
用途区分を取得します。

戻り値:
dlvschduse 用途区分

getPldlvstyp

public String getPldlvstyp()
MRP: 出荷計画タイプを取得します。

戻り値:
pldlvstyp MRP: 出荷計画タイプ

getRefDoc

public String getRefDoc()
参照伝票番号を取得します。

戻り値:
refDoc 参照伝票番号

getCompCdeB

public String getCompCdeB()
請求対象会社コードを取得します。

戻り値:
compCdeB 請求対象会社コード

getAlttaxCls

public String getAlttaxCls()
代替税分類を取得します。

戻り値:
alttaxCls 代替税分類

getTaxClass2

public String getTaxClass2()
得意先税分類 2を取得します。

戻り値:
taxClass2 得意先税分類 2

getTaxClass3

public String getTaxClass3()
得意先税分類 3を取得します。

戻り値:
taxClass3 得意先税分類 3

getTaxClass4

public String getTaxClass4()
得意先に対する税クラス 4を取得します。

戻り値:
taxClass4 得意先に対する税クラス 4

getTaxClass5

public String getTaxClass5()
得意先に対する税クラス 5を取得します。

戻り値:
taxClass5 得意先に対する税クラス 5

getTaxClass6

public String getTaxClass6()
得意先に対する税クラス 6を取得します。

戻り値:
taxClass6 得意先に対する税クラス 6

getTaxClass7

public String getTaxClass7()
得意先に対する税クラス 7を取得します。

戻り値:
taxClass7 得意先に対する税クラス 7

getTaxClass8

public String getTaxClass8()
得意先に対する税クラス 8を取得します。

戻り値:
taxClass8 得意先に対する税クラス 8

getTaxClass9

public String getTaxClass9()
得意先に対する税クラス 9を取得します。

戻り値:
taxClass9 得意先に対する税クラス 9

getRefDocL

public String getRefDocL()
参照伝票番号を取得します。

戻り値:
refDocL 参照伝票番号

getAssNumber

public String getAssNumber()
割当番号を取得します。

戻り値:
assNumber 割当番号

getRefdocCat

public String getRefdocCat()
先行販売管理伝票の伝票カテゴリを取得します。

戻り値:
refdocCat 先行販売管理伝票の伝票カテゴリ

getOrdcombIn

public String getOrdcombIn()
受注結合出荷区分を取得します。

戻り値:
ordcombIn 受注結合出荷区分

getBillSched

public String getBillSched()
請求日程 (稼働日カレンダ指定)を取得します。

戻り値:
billSched 請求日程 (稼働日カレンダ指定)

getInvoSched

public String getInvoSched()
請求書一覧日程 (稼働日カレンダ指定)を取得します。

戻り値:
invoSched 請求書一覧日程 (稼働日カレンダ指定)

getMnInvoice

public String getMnInvoice()
マニュアル請求書更新を取得します。

戻り値:
mnInvoice マニュアル請求書更新

getExrateFi

public String getExrateFi()
FI 転記の換算レート (直接相場)を取得します。

戻り値:
exrateFi FI 転記の換算レート (直接相場)

getAddValDy

public String getAddValDy()
有効日からの日数を取得します。

戻り値:
addValDy 有効日からの日数

getFixValDy

public String getFixValDy()
有効日日付を取得します。

戻り値:
fixValDy 有効日日付

getPymtMeth

public String getPymtMeth()
支払方法を取得します。

戻り値:
pymtMeth 支払方法

getAccntAsgn

public String getAccntAsgn()
得意先の勘定設定グループを取得します。

戻り値:
accntAsgn 得意先の勘定設定グループ

getExchgRate

public String getExchgRate()
価格設定/統計の換算レート (直接引用)を取得します。

戻り値:
exchgRate 価格設定/統計の換算レート (直接引用)

getBillDate

public String getBillDate()
請求索引および印刷に対する請求日を取得します。

戻り値:
billDate 請求索引および印刷に対する請求日

getServDate

public String getServDate()
サービス提供日を取得します。

戻り値:
servDate サービス提供日

getDunnKey

public String getDunnKey()
督促処理キーを取得します。

戻り値:
dunnKey 督促処理キー

getDunnBlock

public String getDunnBlock()
督促処理保留を取得します。

戻り値:
dunnBlock 督促処理保留

getPmtgarPro

public String getPmtgarPro()
支払保証決定表を取得します。

戻り値:
pmtgarPro 支払保証決定表

getDepartmNo

public String getDepartmNo()
部門コードを取得します。

戻り値:
departmNo 部門コード

getRecPoint

public String getRecPoint()
入荷ポイントを取得します。

戻り値:
recPoint 入荷ポイント

getDocNumFi

public String getDocNumFi()
ドキュメンタリクレジット処理: 内部番号を取得します。

戻り値:
docNumFi ドキュメンタリクレジット処理: 内部番号

getCstcndgrp1

public String getCstcndgrp1()
得意先条件グループ１を取得します。

戻り値:
cstcndgrp1 得意先条件グループ１

getCstcndgrp2

public String getCstcndgrp2()
得意先条件グループ２を取得します。

戻り値:
cstcndgrp2 得意先条件グループ２

getCstcndgrp3

public String getCstcndgrp3()
得意先条件グループ３を取得します。

戻り値:
cstcndgrp3 得意先条件グループ３

getCstcndgrp4

public String getCstcndgrp4()
得意先条件グループ４を取得します。

戻り値:
cstcndgrp4 得意先条件グループ４

getCstcndgrp5

public String getCstcndgrp5()
得意先条件グループ５を取得します。

戻り値:
cstcndgrp5 得意先条件グループ５

getDlvTime

public String getDlvTime()
契約出荷期間を取得します。

戻り値:
dlvTime 契約出荷期間

getCurrency

public String getCurrency()
販売伝票通貨を取得します。

戻り値:
currency 販売伝票通貨

getCurrIso

public String getCurrIso()
ISO コード通貨を取得します。

戻り値:
currIso ISO コード通貨

getCreatedBy

public String getCreatedBy()
オブジェクト登録者名を取得します。

戻り値:
createdBy オブジェクト登録者名

getTaxdepCty

public String getTaxdepCty()
税出荷国を取得します。

戻り値:
taxdepCty 税出荷国

getTaxdstCty

public String getTaxdstCty()
税仕向国を取得します。

戻り値:
taxdstCty 税仕向国

getEutriDeal

public String getEutriDeal()
フラグ: EC 内三角取引を取得します。

戻り値:
eutriDeal フラグ: EC 内三角取引

getMastContr

public String getMastContr()
グループマスタ契約番号を取得します。

戻り値:
mastContr グループマスタ契約番号

getRefProc

public String getRefProc()
参照限定条件: 決定区分を取得します。

戻り値:
refProc 参照限定条件: 決定区分

getChkprtauth

public String getChkprtauth()
取引先権限チェックを取得します。

戻り値:
chkprtauth 取引先権限チェック

getCmlqtyDat

public String getCmlqtyDat()
累積出荷数量日付を取得します。

戻り値:
cmlqtyDat 累積出荷数量日付

getVersion

public String getVersion()
販売伝票バージョン番号を取得します。

戻り値:
version 販売伝票バージョン番号

getNotifNo

public String getNotifNo()
通知番号を取得します。

戻り値:
notifNo 通知番号

getWbsElem

public String getWbsElem()
WBS 要素を取得します。

戻り値:
wbsElem WBS 要素

getExchRateFiV

public String getExchRateFiV()
FI 転記の換算レート (間接相場)を取得します。

戻り値:
exchRateFiV FI 転記の換算レート (間接相場)

getExchgRateV

public String getExchgRateV()
価格設定/統計の換算レート (間接引用)を取得します。

戻り値:
exchgRateV 価格設定/統計の換算レート (間接引用)

getFkkConacct

public String getFkkConacct()
長さ 12 の文字項目を取得します。

戻り値:
fkkConacct 長さ 12 の文字項目

getCampaign

public String getCampaign()
総括プロジェクト計画: 外部 R/3 システムの GUIDを取得します。

戻り値:
campaign 総括プロジェクト計画: 外部 R/3 システムの GUID

getDocClass

public String getDocClass()
リリースおよびトランザクション管理を備えた元システムを取得します。

戻り値:
docClass リリースおよびトランザクション管理を備えた元システム

getHCurr

public String getHCurr()
通貨コードを取得します。

戻り値:
hCurr 通貨コード

getHCurrIso

public String getHCurrIso()
ISO 通貨コードを取得します。

戻り値:
hCurrIso ISO 通貨コード

getShipType

public String getShipType()
出荷タイプを取得します。

戻り値:
shipType 出荷タイプ

getSProcInd

public String getSProcInd()
特別処理区分を取得します。

戻り値:
sProcInd 特別処理区分

getRefDocLLong

public String getRefDocLLong()
参照伝票番号 (依存関係についてはテキスト (長) を参照)を取得します。

戻り値:
refDocLLong 参照伝票番号 (依存関係についてはテキスト (長) を参照)

setRefobjtype

public void setRefobjtype(String refobjtype)
オブジェクトタイプを設定します。

パラメータ:
refobjtype - オブジェクトタイプ

setRefobjkey

public void setRefobjkey(String refobjkey)
オブジェクトキーを設定します。

パラメータ:
refobjkey - オブジェクトキー

setRefdoctype

public void setRefdoctype(String refdoctype)
参照オブジェクトの伝票タイプを設定します。

パラメータ:
refdoctype - 参照オブジェクトの伝票タイプ

setDocType

public void setDocType(String docType)
販売伝票タイプを設定します。

パラメータ:
docType - 販売伝票タイプ

setCollectNo

public void setCollectNo(String collectNo)
一括番号を設定します。

パラメータ:
collectNo - 一括番号

setSalesOrg

public void setSalesOrg(String salesOrg)
販売組織を設定します。

パラメータ:
salesOrg - 販売組織

setDistrChan

public void setDistrChan(String distrChan)
流通チャネルを設定します。

パラメータ:
distrChan - 流通チャネル

setDivision

public void setDivision(String division)
製品部門を設定します。

パラメータ:
division - 製品部門

setSalesGrp

public void setSalesGrp(String salesGrp)
営業グループを設定します。

パラメータ:
salesGrp - 営業グループ

setSalesOff

public void setSalesOff(String salesOff)
営業所を設定します。

パラメータ:
salesOff - 営業所

setReqDateH

public void setReqDateH(String reqDateH)
指定納入期日を設定します。

パラメータ:
reqDateH - 指定納入期日

setDateType

public void setDateType(String dateType)
提案日付タイプを設定します。

パラメータ:
dateType - 提案日付タイプ

setPurchDate

public void setPurchDate(String purchDate)
得意先発注日付を設定します。

パラメータ:
purchDate - 得意先発注日付

setPoMethod

public void setPoMethod(String poMethod)
得意先発注タイプを設定します。

パラメータ:
poMethod - 得意先発注タイプ

setPoSupplem

public void setPoSupplem(String poSupplem)
得意先発注番号補足を設定します。

パラメータ:
poSupplem - 得意先発注番号補足

setRef1

public void setRef1(String ref1)
得意先/仕入先の内部参照コードを設定します。

パラメータ:
ref1 - 得意先/仕入先の内部参照コード

setName

public void setName(String name)
発注者名称を設定します。

パラメータ:
name - 発注者名称

setTelephone

public void setTelephone(String telephone)
電話番号を設定します。

パラメータ:
telephone - 電話番号

setPriceGrp

public void setPriceGrp(String priceGrp)
価格グループ (得意先)を設定します。

パラメータ:
priceGrp - 価格グループ (得意先)

setCustGroup

public void setCustGroup(String custGroup)
得意先グループを設定します。

パラメータ:
custGroup - 得意先グループ

setSalesDist

public void setSalesDist(String salesDist)
販売地域を設定します。

パラメータ:
salesDist - 販売地域

setPriceList

public void setPriceList(String priceList)
価格表タイプを設定します。

パラメータ:
priceList - 価格表タイプ

setIncoterms1

public void setIncoterms1(String incoterms1)
インコタームズ (1)を設定します。

パラメータ:
incoterms1 - インコタームズ (1)

setIncoterms2

public void setIncoterms2(String incoterms2)
インコタームズ 2を設定します。

パラメータ:
incoterms2 - インコタームズ 2

setPmnttrms

public void setPmnttrms(String pmnttrms)
支払条件キーを設定します。

パラメータ:
pmnttrms - 支払条件キー

setDlvBlock

public void setDlvBlock(String dlvBlock)
出荷ブロック (伝票ヘッダ)を設定します。

パラメータ:
dlvBlock - 出荷ブロック (伝票ヘッダ)

setBillBlock

public void setBillBlock(String billBlock)
販売管理伝票の請求ブロックを設定します。

パラメータ:
billBlock - 販売管理伝票の請求ブロック

setOrdReason

public void setOrdReason(String ordReason)
受注理由 (取引理由)を設定します。

パラメータ:
ordReason - 受注理由 (取引理由)

setComplDlv

public void setComplDlv(String complDlv)
一括納入区分を設定します。

パラメータ:
complDlv - 一括納入区分

setPriceDate

public void setPriceDate(String priceDate)
価格設定/外貨換算の実行日付を設定します。

パラメータ:
priceDate - 価格設定/外貨換算の実行日付

setQtValidF

public void setQtValidF(String qtValidF)
見積/引合有効開始日を設定します。

パラメータ:
qtValidF - 見積/引合有効開始日

setQtValidT

public void setQtValidT(String qtValidT)
見積の有効終了日を設定します。

パラメータ:
qtValidT - 見積の有効終了日

setCtValidF

public void setCtValidF(String ctValidF)
有効開始日付 (販売契約/品目提案)を設定します。

パラメータ:
ctValidF - 有効開始日付 (販売契約/品目提案)

setCtValidT

public void setCtValidT(String ctValidT)
有効終了日付 (販売契約/品目提案)を設定します。

パラメータ:
ctValidT - 有効終了日付 (販売契約/品目提案)

setCustGrp1

public void setCustGrp1(String custGrp1)
得意先グループ 1を設定します。

パラメータ:
custGrp1 - 得意先グループ 1

setCustGrp2

public void setCustGrp2(String custGrp2)
得意先グループ 2を設定します。

パラメータ:
custGrp2 - 得意先グループ 2

setCustGrp3

public void setCustGrp3(String custGrp3)
得意先グループ 3を設定します。

パラメータ:
custGrp3 - 得意先グループ 3

setCustGrp4

public void setCustGrp4(String custGrp4)
得意先グループ 4を設定します。

パラメータ:
custGrp4 - 得意先グループ 4

setCustGrp5

public void setCustGrp5(String custGrp5)
得意先グループ 5を設定します。

パラメータ:
custGrp5 - 得意先グループ 5

setPurchNoC

public void setPurchNoC(String purchNoC)
出荷先発注番号を設定します。

パラメータ:
purchNoC - 出荷先発注番号

setPurchNoS

public void setPurchNoS(String purchNoS)
出荷先の得意先発注番号を設定します。

パラメータ:
purchNoS - 出荷先の得意先発注番号

setPoDatS

public void setPoDatS(String poDatS)
出荷先の出荷先発注日付を設定します。

パラメータ:
poDatS - 出荷先の出荷先発注日付

setPoMethS

public void setPoMethS(String poMethS)
出荷先の出荷先発注タイプを設定します。

パラメータ:
poMethS - 出荷先の出荷先発注タイプ

setRef1S

public void setRef1S(String ref1S)
出荷先文字を設定します。

パラメータ:
ref1S - 出荷先文字

setSdDocCat

public void setSdDocCat(String sdDocCat)
販売管理伝票カテゴリを設定します。

パラメータ:
sdDocCat - 販売管理伝票カテゴリ

setDocDate

public void setDocDate(String docDate)
伝票日付 (受信日/送信日)を設定します。

パラメータ:
docDate - 伝票日付 (受信日/送信日)

setWarDate

public void setWarDate(String warDate)
保証期間の開始日付を設定します。

パラメータ:
warDate - 保証期間の開始日付

setShipCond

public void setShipCond(String shipCond)
出荷条件を設定します。

パラメータ:
shipCond - 出荷条件

setPpSearch

public void setPpSearch(String ppSearch)
品目提案検索条件を設定します。

パラメータ:
ppSearch - 品目提案検索条件

setDunCount

public void setDunCount(String dunCount)
得意先商談回数を設定します。

パラメータ:
dunCount - 得意先商談回数

setDunDate

public void setDunDate(String dunDate)
得意先との前回の商談日を設定します。

パラメータ:
dunDate - 得意先との前回の商談日

setDlvschduse

public void setDlvschduse(String dlvschduse)
用途区分を設定します。

パラメータ:
dlvschduse - 用途区分

setPldlvstyp

public void setPldlvstyp(String pldlvstyp)
MRP: 出荷計画タイプを設定します。

パラメータ:
pldlvstyp - MRP: 出荷計画タイプ

setRefDoc

public void setRefDoc(String refDoc)
参照伝票番号を設定します。

パラメータ:
refDoc - 参照伝票番号

setCompCdeB

public void setCompCdeB(String compCdeB)
請求対象会社コードを設定します。

パラメータ:
compCdeB - 請求対象会社コード

setAlttaxCls

public void setAlttaxCls(String alttaxCls)
代替税分類を設定します。

パラメータ:
alttaxCls - 代替税分類

setTaxClass2

public void setTaxClass2(String taxClass2)
得意先税分類 2を設定します。

パラメータ:
taxClass2 - 得意先税分類 2

setTaxClass3

public void setTaxClass3(String taxClass3)
得意先税分類 3を設定します。

パラメータ:
taxClass3 - 得意先税分類 3

setTaxClass4

public void setTaxClass4(String taxClass4)
得意先に対する税クラス 4を設定します。

パラメータ:
taxClass4 - 得意先に対する税クラス 4

setTaxClass5

public void setTaxClass5(String taxClass5)
得意先に対する税クラス 5を設定します。

パラメータ:
taxClass5 - 得意先に対する税クラス 5

setTaxClass6

public void setTaxClass6(String taxClass6)
得意先に対する税クラス 6を設定します。

パラメータ:
taxClass6 - 得意先に対する税クラス 6

setTaxClass7

public void setTaxClass7(String taxClass7)
得意先に対する税クラス 7を設定します。

パラメータ:
taxClass7 - 得意先に対する税クラス 7

setTaxClass8

public void setTaxClass8(String taxClass8)
得意先に対する税クラス 8を設定します。

パラメータ:
taxClass8 - 得意先に対する税クラス 8

setTaxClass9

public void setTaxClass9(String taxClass9)
得意先に対する税クラス 9を設定します。

パラメータ:
taxClass9 - 得意先に対する税クラス 9

setRefDocL

public void setRefDocL(String refDocL)
参照伝票番号を設定します。

パラメータ:
refDocL - 参照伝票番号

setAssNumber

public void setAssNumber(String assNumber)
割当番号を設定します。

パラメータ:
assNumber - 割当番号

setRefdocCat

public void setRefdocCat(String refdocCat)
先行販売管理伝票の伝票カテゴリを設定します。

パラメータ:
refdocCat - 先行販売管理伝票の伝票カテゴリ

setOrdcombIn

public void setOrdcombIn(String ordcombIn)
受注結合出荷区分を設定します。

パラメータ:
ordcombIn - 受注結合出荷区分

setBillSched

public void setBillSched(String billSched)
請求日程 (稼働日カレンダ指定)を設定します。

パラメータ:
billSched - 請求日程 (稼働日カレンダ指定)

setInvoSched

public void setInvoSched(String invoSched)
請求書一覧日程 (稼働日カレンダ指定)を設定します。

パラメータ:
invoSched - 請求書一覧日程 (稼働日カレンダ指定)

setMnInvoice

public void setMnInvoice(String mnInvoice)
マニュアル請求書更新を設定します。

パラメータ:
mnInvoice - マニュアル請求書更新

setExrateFi

public void setExrateFi(String exrateFi)
FI 転記の換算レート (直接相場)を設定します。

パラメータ:
exrateFi - FI 転記の換算レート (直接相場)

setAddValDy

public void setAddValDy(String addValDy)
有効日からの日数を設定します。

パラメータ:
addValDy - 有効日からの日数

setFixValDy

public void setFixValDy(String fixValDy)
有効日日付を設定します。

パラメータ:
fixValDy - 有効日日付

setPymtMeth

public void setPymtMeth(String pymtMeth)
支払方法を設定します。

パラメータ:
pymtMeth - 支払方法

setAccntAsgn

public void setAccntAsgn(String accntAsgn)
得意先の勘定設定グループを設定します。

パラメータ:
accntAsgn - 得意先の勘定設定グループ

setExchgRate

public void setExchgRate(String exchgRate)
価格設定/統計の換算レート (直接引用)を設定します。

パラメータ:
exchgRate - 価格設定/統計の換算レート (直接引用)

setBillDate

public void setBillDate(String billDate)
請求索引および印刷に対する請求日を設定します。

パラメータ:
billDate - 請求索引および印刷に対する請求日

setServDate

public void setServDate(String servDate)
サービス提供日を設定します。

パラメータ:
servDate - サービス提供日

setDunnKey

public void setDunnKey(String dunnKey)
督促処理キーを設定します。

パラメータ:
dunnKey - 督促処理キー

setDunnBlock

public void setDunnBlock(String dunnBlock)
督促処理保留を設定します。

パラメータ:
dunnBlock - 督促処理保留

setPmtgarPro

public void setPmtgarPro(String pmtgarPro)
支払保証決定表を設定します。

パラメータ:
pmtgarPro - 支払保証決定表

setDepartmNo

public void setDepartmNo(String departmNo)
部門コードを設定します。

パラメータ:
departmNo - 部門コード

setRecPoint

public void setRecPoint(String recPoint)
入荷ポイントを設定します。

パラメータ:
recPoint - 入荷ポイント

setDocNumFi

public void setDocNumFi(String docNumFi)
ドキュメンタリクレジット処理: 内部番号を設定します。

パラメータ:
docNumFi - ドキュメンタリクレジット処理: 内部番号

setCstcndgrp1

public void setCstcndgrp1(String cstcndgrp1)
得意先条件グループ１を設定します。

パラメータ:
cstcndgrp1 - 得意先条件グループ１

setCstcndgrp2

public void setCstcndgrp2(String cstcndgrp2)
得意先条件グループ２を設定します。

パラメータ:
cstcndgrp2 - 得意先条件グループ２

setCstcndgrp3

public void setCstcndgrp3(String cstcndgrp3)
得意先条件グループ３を設定します。

パラメータ:
cstcndgrp3 - 得意先条件グループ３

setCstcndgrp4

public void setCstcndgrp4(String cstcndgrp4)
得意先条件グループ４を設定します。

パラメータ:
cstcndgrp4 - 得意先条件グループ４

setCstcndgrp5

public void setCstcndgrp5(String cstcndgrp5)
得意先条件グループ５を設定します。

パラメータ:
cstcndgrp5 - 得意先条件グループ５

setDlvTime

public void setDlvTime(String dlvTime)
契約出荷期間を設定します。

パラメータ:
dlvTime - 契約出荷期間

setCurrency

public void setCurrency(String currency)
販売伝票通貨を設定します。

パラメータ:
currency - 販売伝票通貨

setCurrIso

public void setCurrIso(String currIso)
ISO コード通貨を設定します。

パラメータ:
currIso - ISO コード通貨

setCreatedBy

public void setCreatedBy(String createdBy)
オブジェクト登録者名を設定します。

パラメータ:
createdBy - オブジェクト登録者名

setTaxdepCty

public void setTaxdepCty(String taxdepCty)
税出荷国を設定します。

パラメータ:
taxdepCty - 税出荷国

setTaxdstCty

public void setTaxdstCty(String taxdstCty)
税仕向国を設定します。

パラメータ:
taxdstCty - 税仕向国

setEutriDeal

public void setEutriDeal(String eutriDeal)
フラグ: EC 内三角取引を設定します。

パラメータ:
eutriDeal - フラグ: EC 内三角取引

setMastContr

public void setMastContr(String mastContr)
グループマスタ契約番号を設定します。

パラメータ:
mastContr - グループマスタ契約番号

setRefProc

public void setRefProc(String refProc)
参照限定条件: 決定区分を設定します。

パラメータ:
refProc - 参照限定条件: 決定区分

setChkprtauth

public void setChkprtauth(String chkprtauth)
取引先権限チェックを設定します。

パラメータ:
chkprtauth - 取引先権限チェック

setCmlqtyDat

public void setCmlqtyDat(String cmlqtyDat)
累積出荷数量日付を設定します。

パラメータ:
cmlqtyDat - 累積出荷数量日付

setVersion

public void setVersion(String version)
販売伝票バージョン番号を設定します。

パラメータ:
version - 販売伝票バージョン番号

setNotifNo

public void setNotifNo(String notifNo)
通知番号を設定します。

パラメータ:
notifNo - 通知番号

setWbsElem

public void setWbsElem(String wbsElem)
WBS 要素を設定します。

パラメータ:
wbsElem - WBS 要素

setExchRateFiV

public void setExchRateFiV(String exchRateFiV)
FI 転記の換算レート (間接相場)を設定します。

パラメータ:
exchRateFiV - FI 転記の換算レート (間接相場)

setExchgRateV

public void setExchgRateV(String exchgRateV)
価格設定/統計の換算レート (間接引用)を設定します。

パラメータ:
exchgRateV - 価格設定/統計の換算レート (間接引用)

setFkkConacct

public void setFkkConacct(String fkkConacct)
長さ 12 の文字項目を設定します。

パラメータ:
fkkConacct - 長さ 12 の文字項目

setCampaign

public void setCampaign(String campaign)
総括プロジェクト計画: 外部 R/3 システムの GUIDを設定します。

パラメータ:
campaign - 総括プロジェクト計画: 外部 R/3 システムの GUID

setDocClass

public void setDocClass(String docClass)
リリースおよびトランザクション管理を備えた元システムを設定します。

パラメータ:
docClass - リリースおよびトランザクション管理を備えた元システム

setHCurr

public void setHCurr(String hCurr)
通貨コードを設定します。

パラメータ:
hCurr - 通貨コード

setHCurrIso

public void setHCurrIso(String hCurrIso)
ISO 通貨コードを設定します。

パラメータ:
hCurrIso - ISO 通貨コード

setShipType

public void setShipType(String shipType)
出荷タイプを設定します。

パラメータ:
shipType - 出荷タイプ

setSProcInd

public void setSProcInd(String sProcInd)
特別処理区分を設定します。

パラメータ:
sProcInd - 特別処理区分

setRefDocLLong

public void setRefDocLLong(String refDocLLong)
参照伝票番号 (依存関係についてはテキスト (長) を参照)を設定します。

パラメータ:
refDocLLong - 参照伝票番号 (依存関係についてはテキスト (長) を参照)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HeaderInX (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス HeaderInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX
すべての実装インタフェース:
Serializable
public class HeaderInX
extends Object
implements Serializable

ヘッダデータチェックボックス情報クラス
機能は以下の通り

  • ヘッダデータチェックボックス情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
HeaderInX()
ヘッダデータチェックボックス情報を作成します。
メソッドの概要
String | getAccntAsgn() 関連ユーザデータ項目の更新情報を取得します。
String | getAddValDy() 関連ユーザデータ項目の更新情報を取得します。
String | getAlttaxCls() 関連ユーザデータ項目の更新情報を取得します。
String | getAssNumber() 関連ユーザデータ項目の更新情報を取得します。
String | getBillBlock() 関連ユーザデータ項目の更新情報を取得します。
String | getBillDate() 関連ユーザデータ項目の更新情報を取得します。
String | getBillSched() 関連ユーザデータ項目の更新情報を取得します。
String | getCampaign() 関連ユーザデータ項目の更新情報を取得します。
String | getChkprtauth() 関連ユーザデータ項目の更新情報を取得します。
String | getCmlqtyDat() 関連ユーザデータ項目の更新情報を取得します。
String | getCollectNo() 関連ユーザデータ項目の更新情報を取得します。
String | getCompCdeB() 関連ユーザデータ項目の更新情報を取得します。
String | getComplDlv() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp1() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp2() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp3() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp4() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp5() 関連ユーザデータ項目の更新情報を取得します。
String | getCtValidF() 関連ユーザデータ項目の更新情報を取得します。
String | getCtValidT() 関連ユーザデータ項目の更新情報を取得します。
String | getCurrency() 関連ユーザデータ項目の更新情報を取得します。
String | getCustGroup() 関連ユーザデータ項目の更新情報を取得します。
String | getCustGrp1() 関連ユーザデータ項目の更新情報を取得します。
String | getCustGrp2() 関連ユーザデータ項目の更新情報を取得します。
String | getCustGrp3() 関連ユーザデータ項目の更新情報を取得します。
String | getCustGrp4() 関連ユーザデータ項目の更新情報を取得します。
String | getCustGrp5() 関連ユーザデータ項目の更新情報を取得します。
String | getDateType() 関連ユーザデータ項目の更新情報を取得します。
String | getDepartmNo() 関連ユーザデータ項目の更新情報を取得します。
String | getDistrChan() 関連ユーザデータ項目の更新情報を取得します。
String | getDivision() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvBlock() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvschduse() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvTime() 関連ユーザデータ項目の更新情報を取得します。
String | getDocClass() 関連ユーザデータ項目の更新情報を取得します。
String | getDocDate() 関連ユーザデータ項目の更新情報を取得します。
String | getDocNumFi() 関連ユーザデータ項目の更新情報を取得します。
String | getDocType() 関連ユーザデータ項目の更新情報を取得します。
String | getDunCount() 関連ユーザデータ項目の更新情報を取得します。
String | getDunDate() 関連ユーザデータ項目の更新情報を取得します。
String | getDunnBlock() 関連ユーザデータ項目の更新情報を取得します。
String | getDunnKey() 関連ユーザデータ項目の更新情報を取得します。
String | getEutriDeal() 関連ユーザデータ項目の更新情報を取得します。
String | getExchgRate() 関連ユーザデータ項目の更新情報を取得します。
String | getExchgRateV() 関連ユーザデータ項目の更新情報を取得します。
String | getExchRateFiV() 関連ユーザデータ項目の更新情報を取得します。
String | getExrateFi() 関連ユーザデータ項目の更新情報を取得します。
String | getFixValDy() 関連ユーザデータ項目の更新情報を取得します。
String | getFkkConacct() 関連ユーザデータ項目の更新情報を取得します。
String | getHCurr() 関連ユーザデータ項目の更新情報を取得します。
String | getIncoterms1() 関連ユーザデータ項目の更新情報を取得します。
String | getIncoterms2() 関連ユーザデータ項目の更新情報を取得します。
String | getInvoSched() 関連ユーザデータ項目の更新情報を取得します。
String | getMastContr() 関連ユーザデータ項目の更新情報を取得します。
String | getMnInvoice() 関連ユーザデータ項目の更新情報を取得します。
String | getName() 関連ユーザデータ項目の更新情報を取得します。
String | getNotifNo() 関連ユーザデータ項目の更新情報を取得します。
String | getOrdcombIn() 関連ユーザデータ項目の更新情報を取得します。
String | getOrdReason() 関連ユーザデータ項目の更新情報を取得します。
String | getPldlvstyp() 関連ユーザデータ項目の更新情報を取得します。
String | getPmnttrms() 関連ユーザデータ項目の更新情報を取得します。
String | getPmtgarPro() 関連ユーザデータ項目の更新情報を取得します。
String | getPoDatS() 関連ユーザデータ項目の更新情報を取得します。
String | getPoitmNoS() 関連ユーザデータ項目の更新情報を取得します。
String | getPoMethod() 関連ユーザデータ項目の更新情報を取得します。
String | getPoMethS() 関連ユーザデータ項目の更新情報を取得します。
String | getPoSupplem() 関連ユーザデータ項目の更新情報を取得します。
String | getPpSearch() 関連ユーザデータ項目の更新情報を取得します。
String | getPriceDate() 関連ユーザデータ項目の更新情報を取得します。
String | getPriceGrp() 関連ユーザデータ項目の更新情報を取得します。
String | getPriceList() 関連ユーザデータ項目の更新情報を取得します。
String | getPromotion() 関連ユーザデータ項目の更新情報を取得します。
String | getPurchDate() 関連ユーザデータ項目の更新情報を取得します。
String | getPurchNoC() 関連ユーザデータ項目の更新情報を取得します。
String | getPurchNoS() 関連ユーザデータ項目の更新情報を取得します。
String | getPymtMeth() 関連ユーザデータ項目の更新情報を取得します。
String | getQtValidF() 関連ユーザデータ項目の更新情報を取得します。
String | getQtValidT() 関連ユーザデータ項目の更新情報を取得します。
String | getRecPoint() 関連ユーザデータ項目の更新情報を取得します。
String | getRef1() 関連ユーザデータ項目の更新情報を取得します。
String | getRef1S() 関連ユーザデータ項目の更新情報を取得します。
String | getRefDoc() 関連ユーザデータ項目の更新情報を取得します。
String | getRefdocCat() 関連ユーザデータ項目の更新情報を取得します。
String | getRefDocL() 関連ユーザデータ項目の更新情報を取得します。
String | getRefProc() 関連ユーザデータ項目の更新情報を取得します。
String | getReqDateH() 関連ユーザデータ項目の更新情報を取得します。
String | getSalesDist() 関連ユーザデータ項目の更新情報を取得します。
String | getSalesGrp() 関連ユーザデータ項目の更新情報を取得します。
String | getSalesOff() 関連ユーザデータ項目の更新情報を取得します。
String | getSalesOrg() 関連ユーザデータ項目の更新情報を取得します。
String | getSdDocCat() 関連ユーザデータ項目の更新情報を取得します。
String | getServDate() 関連ユーザデータ項目の更新情報を取得します。
String | getShipCond() 関連ユーザデータ項目の更新情報を取得します。
String | getShipType() 関連ユーザデータ項目の更新情報を取得します。
String | getSProcInd() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass2() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass3() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass4() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass5() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass6() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass7() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass8() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass9() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxdepCty() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxdstCty() 関連ユーザデータ項目の更新情報を取得します。
String | getTelephone() 関連ユーザデータ項目の更新情報を取得します。
String | getUpdateflag() 更新区分を取得します。
String | getVersion() 関連ユーザデータ項目の更新情報を取得します。
String | getWarDate() 関連ユーザデータ項目の更新情報を取得します。
String | getWbsElem() 関連ユーザデータ項目の更新情報を取得します。
void | setAccntAsgn(String accntAsgn) 関連ユーザデータ項目の更新情報を設定します。
void | setAddValDy(String addValDy) 関連ユーザデータ項目の更新情報を設定します。
void | setAlttaxCls(String alttaxCls) 関連ユーザデータ項目の更新情報を設定します。
void | setAssNumber(String assNumber) 関連ユーザデータ項目の更新情報を設定します。
void | setBillBlock(String billBlock) 関連ユーザデータ項目の更新情報を設定します。
void | setBillDate(String billDate) 関連ユーザデータ項目の更新情報を設定します。
void | setBillSched(String billSched) 関連ユーザデータ項目の更新情報を設定します。
void | setCampaign(String campaign) 関連ユーザデータ項目の更新情報を設定します。
void | setChkprtauth(String chkprtauth) 関連ユーザデータ項目の更新情報を設定します。
void | setCmlqtyDat(String cmlqtyDat) 関連ユーザデータ項目の更新情報を設定します。
void | setCollectNo(String collectNo) 関連ユーザデータ項目の更新情報を設定します。
void | setCompCdeB(String compCdeB) 関連ユーザデータ項目の更新情報を設定します。
void | setComplDlv(String complDlv) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp1(String cstcndgrp1) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp2(String cstcndgrp2) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp3(String cstcndgrp3) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp4(String cstcndgrp4) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp5(String cstcndgrp5) 関連ユーザデータ項目の更新情報を設定します。
void | setCtValidF(String ctValidF) 関連ユーザデータ項目の更新情報を設定します。
void | setCtValidT(String ctValidT) 関連ユーザデータ項目の更新情報を設定します。
void | setCurrency(String currency) 関連ユーザデータ項目の更新情報を設定します。
void | setCustGroup(String custGroup) 関連ユーザデータ項目の更新情報を設定します。
void | setCustGrp1(String custGrp1) 関連ユーザデータ項目の更新情報を設定します。
void | setCustGrp2(String custGrp2) 関連ユーザデータ項目の更新情報を設定します。
void | setCustGrp3(String custGrp3) 関連ユーザデータ項目の更新情報を設定します。
void | setCustGrp4(String custGrp4) 関連ユーザデータ項目の更新情報を設定します。
void | setCustGrp5(String custGrp5) 関連ユーザデータ項目の更新情報を設定します。
void | setDateType(String dateType) 関連ユーザデータ項目の更新情報を設定します。
void | setDepartmNo(String departmNo) 関連ユーザデータ項目の更新情報を設定します。
void | setDistrChan(String distrChan) 関連ユーザデータ項目の更新情報を設定します。
void | setDivision(String division) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvBlock(String dlvBlock) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvschduse(String dlvschduse) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvTime(String dlvTime) 関連ユーザデータ項目の更新情報を設定します。
void | setDocClass(String docClass) 関連ユーザデータ項目の更新情報を設定します。
void | setDocDate(String docDate) 関連ユーザデータ項目の更新情報を設定します。
void | setDocNumFi(String docNumFi) 関連ユーザデータ項目の更新情報を設定します。
void | setDocType(String docType) 関連ユーザデータ項目の更新情報を設定します。
void | setDunCount(String dunCount) 関連ユーザデータ項目の更新情報を設定します。
void | setDunDate(String dunDate) 関連ユーザデータ項目の更新情報を設定します。
void | setDunnBlock(String dunnBlock) 関連ユーザデータ項目の更新情報を設定します。
void | setDunnKey(String dunnKey) 関連ユーザデータ項目の更新情報を設定します。
void | setEutriDeal(String eutriDeal) 関連ユーザデータ項目の更新情報を設定します。
void | setExchgRate(String exchgRate) 関連ユーザデータ項目の更新情報を設定します。
void | setExchgRateV(String exchgRateV) 関連ユーザデータ項目の更新情報を設定します。
void | setExchRateFiV(String exchRateFiV) 関連ユーザデータ項目の更新情報を設定します。
void | setExrateFi(String exrateFi) 関連ユーザデータ項目の更新情報を設定します。
void | setFixValDy(String fixValDy) 関連ユーザデータ項目の更新情報を設定します。
void | setFkkConacct(String fkkConacct) 関連ユーザデータ項目の更新情報を設定します。
void | setHCurr(String hCurr) 関連ユーザデータ項目の更新情報を設定します。
void | setIncoterms1(String incoterms1) 関連ユーザデータ項目の更新情報を設定します。
void | setIncoterms2(String incoterms2) 関連ユーザデータ項目の更新情報を設定します。
void | setInvoSched(String invoSched) 関連ユーザデータ項目の更新情報を設定します。
void | setMastContr(String mastContr) 関連ユーザデータ項目の更新情報を設定します。
void | setMnInvoice(String mnInvoice) 関連ユーザデータ項目の更新情報を設定します。
void | setName(String name) 関連ユーザデータ項目の更新情報を設定します。
void | setNotifNo(String notifNo) 関連ユーザデータ項目の更新情報を設定します。
void | setOrdcombIn(String ordcombIn) 関連ユーザデータ項目の更新情報を設定します。
void | setOrdReason(String ordReason) 関連ユーザデータ項目の更新情報を設定します。
void | setPldlvstyp(String pldlvstyp) 関連ユーザデータ項目の更新情報を設定します。
void | setPmnttrms(String pmnttrms) 関連ユーザデータ項目の更新情報を設定します。
void | setPmtgarPro(String pmtgarPro) 関連ユーザデータ項目の更新情報を設定します。
void | setPoDatS(String poDatS) 関連ユーザデータ項目の更新情報を設定します。
void | setPoitmNoS(String poitmNoS) 関連ユーザデータ項目の更新情報を設定します。
void | setPoMethod(String poMethod) 関連ユーザデータ項目の更新情報を設定します。
void | setPoMethS(String poMethS) 関連ユーザデータ項目の更新情報を設定します。
void | setPoSupplem(String poSupplem) 関連ユーザデータ項目の更新情報を設定します。
void | setPpSearch(String ppSearch) 関連ユーザデータ項目の更新情報を設定します。
void | setPriceDate(String priceDate) 関連ユーザデータ項目の更新情報を設定します。
void | setPriceGrp(String priceGrp) 関連ユーザデータ項目の更新情報を設定します。
void | setPriceList(String priceList) 関連ユーザデータ項目の更新情報を設定します。
void | setPromotion(String promotion) 関連ユーザデータ項目の更新情報を設定します。
void | setPurchDate(String purchDate) 関連ユーザデータ項目の更新情報を設定します。
void | setPurchNoC(String purchNoC) 関連ユーザデータ項目の更新情報を設定します。
void | setPurchNoS(String purchNoS) 関連ユーザデータ項目の更新情報を設定します。
void | setPymtMeth(String pymtMeth) 関連ユーザデータ項目の更新情報を設定します。
void | setQtValidF(String qtValidF) 関連ユーザデータ項目の更新情報を設定します。
void | setQtValidT(String qtValidT) 関連ユーザデータ項目の更新情報を設定します。
void | setRecPoint(String recPoint) 関連ユーザデータ項目の更新情報を設定します。
void | setRef1(String ref1) 関連ユーザデータ項目の更新情報を設定します。
void | setRef1S(String ref1S) 関連ユーザデータ項目の更新情報を設定します。
void | setRefDoc(String refDoc) 関連ユーザデータ項目の更新情報を設定します。
void | setRefdocCat(String refdocCat) 関連ユーザデータ項目の更新情報を設定します。
void | setRefDocL(String refDocL) 関連ユーザデータ項目の更新情報を設定します。
void | setRefProc(String refProc) 関連ユーザデータ項目の更新情報を設定します。
void | setReqDateH(String reqDateH) 関連ユーザデータ項目の更新情報を設定します。
void | setSalesDist(String salesDist) 関連ユーザデータ項目の更新情報を設定します。
void | setSalesGrp(String salesGrp) 関連ユーザデータ項目の更新情報を設定します。
void | setSalesOff(String salesOff) 関連ユーザデータ項目の更新情報を設定します。
void | setSalesOrg(String salesOrg) 関連ユーザデータ項目の更新情報を設定します。
void | setSdDocCat(String sdDocCat) 関連ユーザデータ項目の更新情報を設定します。
void | setServDate(String servDate) 関連ユーザデータ項目の更新情報を設定します。
void | setShipCond(String shipCond) 関連ユーザデータ項目の更新情報を設定します。
void | setShipType(String shipType) 関連ユーザデータ項目の更新情報を設定します。
void | setSProcInd(String sProcInd) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass2(String taxClass2) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass3(String taxClass3) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass4(String taxClass4) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass5(String taxClass5) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass6(String taxClass6) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass7(String taxClass7) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass8(String taxClass8) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass9(String taxClass9) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxdepCty(String taxdepCty) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxdstCty(String taxdstCty) 関連ユーザデータ項目の更新情報を設定します。
void | setTelephone(String telephone) 関連ユーザデータ項目の更新情報を設定します。
void | setUpdateflag(String updateflag) 更新区分を設定します。
void | setVersion(String version) 関連ユーザデータ項目の更新情報を設定します。
void | setWarDate(String warDate) 関連ユーザデータ項目の更新情報を設定します。
void | setWbsElem(String wbsElem) 関連ユーザデータ項目の更新情報を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HeaderInX

public HeaderInX()
ヘッダデータチェックボックス情報を作成します。

メソッドの詳細

getUpdateflag

public String getUpdateflag()
更新区分を取得します。

戻り値:
updateflag 更新区分

getDocType

public String getDocType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
docType 関連ユーザデータ項目の更新情報

getCollectNo

public String getCollectNo()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
collectNo 関連ユーザデータ項目の更新情報

getSalesOrg

public String getSalesOrg()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
salesOrg 関連ユーザデータ項目の更新情報

getDistrChan

public String getDistrChan()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
distrChan 関連ユーザデータ項目の更新情報

getDivision

public String getDivision()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
division 関連ユーザデータ項目の更新情報

getSalesGrp

public String getSalesGrp()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
salesGrp 関連ユーザデータ項目の更新情報

getSalesOff

public String getSalesOff()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
salesOff 関連ユーザデータ項目の更新情報

getReqDateH

public String getReqDateH()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
reqDateH 関連ユーザデータ項目の更新情報

getDateType

public String getDateType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dateType 関連ユーザデータ項目の更新情報

getPurchDate

public String getPurchDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
purchDate 関連ユーザデータ項目の更新情報

getPoMethod

public String getPoMethod()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poMethod 関連ユーザデータ項目の更新情報

getPoSupplem

public String getPoSupplem()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poSupplem 関連ユーザデータ項目の更新情報

getRef1

public String getRef1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ref1 関連ユーザデータ項目の更新情報

getName

public String getName()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
name 関連ユーザデータ項目の更新情報

getTelephone

public String getTelephone()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
telephone 関連ユーザデータ項目の更新情報

getPriceGrp

public String getPriceGrp()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
priceGrp 関連ユーザデータ項目の更新情報

getCustGroup

public String getCustGroup()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custGroup 関連ユーザデータ項目の更新情報

getSalesDist

public String getSalesDist()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
salesDist 関連ユーザデータ項目の更新情報

getPriceList

public String getPriceList()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
priceList 関連ユーザデータ項目の更新情報

getIncoterms1

public String getIncoterms1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
incoterms1 関連ユーザデータ項目の更新情報

getIncoterms2

public String getIncoterms2()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
incoterms2 関連ユーザデータ項目の更新情報

getPmnttrms

public String getPmnttrms()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pmnttrms 関連ユーザデータ項目の更新情報

getDlvBlock

public String getDlvBlock()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvBlock 関連ユーザデータ項目の更新情報

getBillBlock

public String getBillBlock()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
billBlock 関連ユーザデータ項目の更新情報

getOrdReason

public String getOrdReason()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ordReason 関連ユーザデータ項目の更新情報

getComplDlv

public String getComplDlv()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
complDlv 関連ユーザデータ項目の更新情報

getPriceDate

public String getPriceDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
priceDate 関連ユーザデータ項目の更新情報

getQtValidF

public String getQtValidF()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
qtValidF 関連ユーザデータ項目の更新情報

getQtValidT

public String getQtValidT()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
qtValidT 関連ユーザデータ項目の更新情報

getCtValidF

public String getCtValidF()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ctValidF 関連ユーザデータ項目の更新情報

getCtValidT

public String getCtValidT()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ctValidT 関連ユーザデータ項目の更新情報

getCustGrp1

public String getCustGrp1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custGrp1 関連ユーザデータ項目の更新情報

getCustGrp2

public String getCustGrp2()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custGrp2 関連ユーザデータ項目の更新情報

getCustGrp3

public String getCustGrp3()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custGrp3 関連ユーザデータ項目の更新情報

getCustGrp4

public String getCustGrp4()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custGrp4 関連ユーザデータ項目の更新情報

getCustGrp5

public String getCustGrp5()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custGrp5 関連ユーザデータ項目の更新情報

getPurchNoC

public String getPurchNoC()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
purchNoC 関連ユーザデータ項目の更新情報

getPurchNoS

public String getPurchNoS()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
purchNoS 関連ユーザデータ項目の更新情報

getPoDatS

public String getPoDatS()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poDatS 関連ユーザデータ項目の更新情報

getPoMethS

public String getPoMethS()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poMethS 関連ユーザデータ項目の更新情報

getRef1S

public String getRef1S()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ref1S 関連ユーザデータ項目の更新情報

getSdDocCat

public String getSdDocCat()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
sdDocCat 関連ユーザデータ項目の更新情報

getDocDate

public String getDocDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
docDate 関連ユーザデータ項目の更新情報

getWarDate

public String getWarDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
warDate 関連ユーザデータ項目の更新情報

getShipCond

public String getShipCond()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
shipCond 関連ユーザデータ項目の更新情報

getPpSearch

public String getPpSearch()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ppSearch 関連ユーザデータ項目の更新情報

getDunCount

public String getDunCount()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dunCount 関連ユーザデータ項目の更新情報

getDunDate

public String getDunDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dunDate 関連ユーザデータ項目の更新情報

getDlvschduse

public String getDlvschduse()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvschduse 関連ユーザデータ項目の更新情報

getPldlvstyp

public String getPldlvstyp()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pldlvstyp 関連ユーザデータ項目の更新情報

getRefDoc

public String getRefDoc()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refDoc 関連ユーザデータ項目の更新情報

getCompCdeB

public String getCompCdeB()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
compCdeB 関連ユーザデータ項目の更新情報

getAlttaxCls

public String getAlttaxCls()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
alttaxCls 関連ユーザデータ項目の更新情報

getTaxClass2

public String getTaxClass2()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass2 関連ユーザデータ項目の更新情報

getTaxClass3

public String getTaxClass3()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass3 関連ユーザデータ項目の更新情報

getTaxClass4

public String getTaxClass4()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass4 関連ユーザデータ項目の更新情報

getTaxClass5

public String getTaxClass5()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass5 関連ユーザデータ項目の更新情報

getTaxClass6

public String getTaxClass6()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass6 関連ユーザデータ項目の更新情報

getTaxClass7

public String getTaxClass7()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass7 関連ユーザデータ項目の更新情報

getTaxClass8

public String getTaxClass8()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass8 関連ユーザデータ項目の更新情報

getTaxClass9

public String getTaxClass9()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass9 関連ユーザデータ項目の更新情報

getRefDocL

public String getRefDocL()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refDocL 関連ユーザデータ項目の更新情報

getAssNumber

public String getAssNumber()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
assNumber 関連ユーザデータ項目の更新情報

getRefdocCat

public String getRefdocCat()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refdocCat 関連ユーザデータ項目の更新情報

getOrdcombIn

public String getOrdcombIn()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ordcombIn 関連ユーザデータ項目の更新情報

getBillSched

public String getBillSched()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
billSched 関連ユーザデータ項目の更新情報

getInvoSched

public String getInvoSched()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
invoSched 関連ユーザデータ項目の更新情報

getMnInvoice

public String getMnInvoice()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
mnInvoice 関連ユーザデータ項目の更新情報

getExrateFi

public String getExrateFi()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
exrateFi 関連ユーザデータ項目の更新情報

getAddValDy

public String getAddValDy()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
addValDy 関連ユーザデータ項目の更新情報

getFixValDy

public String getFixValDy()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
fixValDy 関連ユーザデータ項目の更新情報

getPymtMeth

public String getPymtMeth()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pymtMeth 関連ユーザデータ項目の更新情報

getAccntAsgn

public String getAccntAsgn()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
accntAsgn 関連ユーザデータ項目の更新情報

getExchgRate

public String getExchgRate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
exchgRate 関連ユーザデータ項目の更新情報

getBillDate

public String getBillDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
billDate 関連ユーザデータ項目の更新情報

getServDate

public String getServDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
servDate 関連ユーザデータ項目の更新情報

getDunnKey

public String getDunnKey()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dunnKey 関連ユーザデータ項目の更新情報

getDunnBlock

public String getDunnBlock()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dunnBlock 関連ユーザデータ項目の更新情報

getPromotion

public String getPromotion()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
promotion 関連ユーザデータ項目の更新情報

getPmtgarPro

public String getPmtgarPro()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pmtgarPro 関連ユーザデータ項目の更新情報

getDepartmNo

public String getDepartmNo()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
departmNo 関連ユーザデータ項目の更新情報

getRecPoint

public String getRecPoint()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
recPoint 関連ユーザデータ項目の更新情報

getPoitmNoS

public String getPoitmNoS()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poitmNoS 関連ユーザデータ項目の更新情報

getDocNumFi

public String getDocNumFi()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
docNumFi 関連ユーザデータ項目の更新情報

getCstcndgrp1

public String getCstcndgrp1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp1 関連ユーザデータ項目の更新情報

getCstcndgrp2

public String getCstcndgrp2()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp2 関連ユーザデータ項目の更新情報

getCstcndgrp3

public String getCstcndgrp3()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp3 関連ユーザデータ項目の更新情報

getCstcndgrp4

public String getCstcndgrp4()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp4 関連ユーザデータ項目の更新情報

getCstcndgrp5

public String getCstcndgrp5()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp5 関連ユーザデータ項目の更新情報

getDlvTime

public String getDlvTime()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvTime 関連ユーザデータ項目の更新情報

getCurrency

public String getCurrency()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
currency 関連ユーザデータ項目の更新情報

getTaxdepCty

public String getTaxdepCty()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxdepCty 関連ユーザデータ項目の更新情報

getTaxdstCty

public String getTaxdstCty()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxdstCty 関連ユーザデータ項目の更新情報

getEutriDeal

public String getEutriDeal()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
eutriDeal 関連ユーザデータ項目の更新情報

getMastContr

public String getMastContr()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
mastContr 関連ユーザデータ項目の更新情報

getRefProc

public String getRefProc()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refProc 関連ユーザデータ項目の更新情報

getChkprtauth

public String getChkprtauth()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
chkprtauth 関連ユーザデータ項目の更新情報

getCmlqtyDat

public String getCmlqtyDat()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cmlqtyDat 関連ユーザデータ項目の更新情報

getVersion

public String getVersion()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
version 関連ユーザデータ項目の更新情報

getNotifNo

public String getNotifNo()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
notifNo 関連ユーザデータ項目の更新情報

getWbsElem

public String getWbsElem()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
wbsElem 関連ユーザデータ項目の更新情報

getExchRateFiV

public String getExchRateFiV()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
exchRateFiV 関連ユーザデータ項目の更新情報

getExchgRateV

public String getExchgRateV()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
exchgRateV 関連ユーザデータ項目の更新情報

getFkkConacct

public String getFkkConacct()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
fkkConacct 関連ユーザデータ項目の更新情報

getCampaign

public String getCampaign()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
campaign 関連ユーザデータ項目の更新情報

getDocClass

public String getDocClass()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
docClass 関連ユーザデータ項目の更新情報

getHCurr

public String getHCurr()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
hCurr 関連ユーザデータ項目の更新情報

getShipType

public String getShipType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
shipType 関連ユーザデータ項目の更新情報

getSProcInd

public String getSProcInd()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
sProcInd 関連ユーザデータ項目の更新情報

setUpdateflag

public void setUpdateflag(String updateflag)
更新区分を設定します。

パラメータ:
updateflag - 更新区分

setDocType

public void setDocType(String docType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
docType - 関連ユーザデータ項目の更新情報

setCollectNo

public void setCollectNo(String collectNo)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
collectNo - 関連ユーザデータ項目の更新情報

setSalesOrg

public void setSalesOrg(String salesOrg)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
salesOrg - 関連ユーザデータ項目の更新情報

setDistrChan

public void setDistrChan(String distrChan)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
distrChan - 関連ユーザデータ項目の更新情報

setDivision

public void setDivision(String division)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
division - 関連ユーザデータ項目の更新情報

setSalesGrp

public void setSalesGrp(String salesGrp)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
salesGrp - 関連ユーザデータ項目の更新情報

setSalesOff

public void setSalesOff(String salesOff)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
salesOff - 関連ユーザデータ項目の更新情報

setReqDateH

public void setReqDateH(String reqDateH)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
reqDateH - 関連ユーザデータ項目の更新情報

setDateType

public void setDateType(String dateType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dateType - 関連ユーザデータ項目の更新情報

setPurchDate

public void setPurchDate(String purchDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
purchDate - 関連ユーザデータ項目の更新情報

setPoMethod

public void setPoMethod(String poMethod)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poMethod - 関連ユーザデータ項目の更新情報

setPoSupplem

public void setPoSupplem(String poSupplem)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poSupplem - 関連ユーザデータ項目の更新情報

setRef1

public void setRef1(String ref1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ref1 - 関連ユーザデータ項目の更新情報

setName

public void setName(String name)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
name - 関連ユーザデータ項目の更新情報

setTelephone

public void setTelephone(String telephone)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
telephone - 関連ユーザデータ項目の更新情報

setPriceGrp

public void setPriceGrp(String priceGrp)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
priceGrp - 関連ユーザデータ項目の更新情報

setCustGroup

public void setCustGroup(String custGroup)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custGroup - 関連ユーザデータ項目の更新情報

setSalesDist

public void setSalesDist(String salesDist)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
salesDist - 関連ユーザデータ項目の更新情報

setPriceList

public void setPriceList(String priceList)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
priceList - 関連ユーザデータ項目の更新情報

setIncoterms1

public void setIncoterms1(String incoterms1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
incoterms1 - 関連ユーザデータ項目の更新情報

setIncoterms2

public void setIncoterms2(String incoterms2)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
incoterms2 - 関連ユーザデータ項目の更新情報

setPmnttrms

public void setPmnttrms(String pmnttrms)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pmnttrms - 関連ユーザデータ項目の更新情報

setDlvBlock

public void setDlvBlock(String dlvBlock)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvBlock - 関連ユーザデータ項目の更新情報

setBillBlock

public void setBillBlock(String billBlock)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
billBlock - 関連ユーザデータ項目の更新情報

setOrdReason

public void setOrdReason(String ordReason)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ordReason - 関連ユーザデータ項目の更新情報

setComplDlv

public void setComplDlv(String complDlv)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
complDlv - 関連ユーザデータ項目の更新情報

setPriceDate

public void setPriceDate(String priceDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
priceDate - 関連ユーザデータ項目の更新情報

setQtValidF

public void setQtValidF(String qtValidF)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
qtValidF - 関連ユーザデータ項目の更新情報

setQtValidT

public void setQtValidT(String qtValidT)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
qtValidT - 関連ユーザデータ項目の更新情報

setCtValidF

public void setCtValidF(String ctValidF)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ctValidF - 関連ユーザデータ項目の更新情報

setCtValidT

public void setCtValidT(String ctValidT)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ctValidT - 関連ユーザデータ項目の更新情報

setCustGrp1

public void setCustGrp1(String custGrp1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custGrp1 - 関連ユーザデータ項目の更新情報

setCustGrp2

public void setCustGrp2(String custGrp2)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custGrp2 - 関連ユーザデータ項目の更新情報

setCustGrp3

public void setCustGrp3(String custGrp3)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custGrp3 - 関連ユーザデータ項目の更新情報

setCustGrp4

public void setCustGrp4(String custGrp4)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custGrp4 - 関連ユーザデータ項目の更新情報

setCustGrp5

public void setCustGrp5(String custGrp5)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custGrp5 - 関連ユーザデータ項目の更新情報

setPurchNoC

public void setPurchNoC(String purchNoC)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
purchNoC - 関連ユーザデータ項目の更新情報

setPurchNoS

public void setPurchNoS(String purchNoS)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
purchNoS - 関連ユーザデータ項目の更新情報

setPoDatS

public void setPoDatS(String poDatS)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poDatS - 関連ユーザデータ項目の更新情報

setPoMethS

public void setPoMethS(String poMethS)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poMethS - 関連ユーザデータ項目の更新情報

setRef1S

public void setRef1S(String ref1S)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ref1S - 関連ユーザデータ項目の更新情報

setSdDocCat

public void setSdDocCat(String sdDocCat)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
sdDocCat - 関連ユーザデータ項目の更新情報

setDocDate

public void setDocDate(String docDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
docDate - 関連ユーザデータ項目の更新情報

setWarDate

public void setWarDate(String warDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
warDate - 関連ユーザデータ項目の更新情報

setShipCond

public void setShipCond(String shipCond)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
shipCond - 関連ユーザデータ項目の更新情報

setPpSearch

public void setPpSearch(String ppSearch)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ppSearch - 関連ユーザデータ項目の更新情報

setDunCount

public void setDunCount(String dunCount)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dunCount - 関連ユーザデータ項目の更新情報

setDunDate

public void setDunDate(String dunDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dunDate - 関連ユーザデータ項目の更新情報

setDlvschduse

public void setDlvschduse(String dlvschduse)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvschduse - 関連ユーザデータ項目の更新情報

setPldlvstyp

public void setPldlvstyp(String pldlvstyp)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pldlvstyp - 関連ユーザデータ項目の更新情報

setRefDoc

public void setRefDoc(String refDoc)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refDoc - 関連ユーザデータ項目の更新情報

setCompCdeB

public void setCompCdeB(String compCdeB)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
compCdeB - 関連ユーザデータ項目の更新情報

setAlttaxCls

public void setAlttaxCls(String alttaxCls)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
alttaxCls - 関連ユーザデータ項目の更新情報

setTaxClass2

public void setTaxClass2(String taxClass2)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass2 - 関連ユーザデータ項目の更新情報

setTaxClass3

public void setTaxClass3(String taxClass3)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass3 - 関連ユーザデータ項目の更新情報

setTaxClass4

public void setTaxClass4(String taxClass4)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass4 - 関連ユーザデータ項目の更新情報

setTaxClass5

public void setTaxClass5(String taxClass5)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass5 - 関連ユーザデータ項目の更新情報

setTaxClass6

public void setTaxClass6(String taxClass6)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass6 - 関連ユーザデータ項目の更新情報

setTaxClass7

public void setTaxClass7(String taxClass7)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass7 - 関連ユーザデータ項目の更新情報

setTaxClass8

public void setTaxClass8(String taxClass8)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass8 - 関連ユーザデータ項目の更新情報

setTaxClass9

public void setTaxClass9(String taxClass9)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass9 - 関連ユーザデータ項目の更新情報

setRefDocL

public void setRefDocL(String refDocL)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refDocL - 関連ユーザデータ項目の更新情報

setAssNumber

public void setAssNumber(String assNumber)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
assNumber - 関連ユーザデータ項目の更新情報

setRefdocCat

public void setRefdocCat(String refdocCat)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refdocCat - 関連ユーザデータ項目の更新情報

setOrdcombIn

public void setOrdcombIn(String ordcombIn)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ordcombIn - 関連ユーザデータ項目の更新情報

setBillSched

public void setBillSched(String billSched)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
billSched - 関連ユーザデータ項目の更新情報

setInvoSched

public void setInvoSched(String invoSched)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
invoSched - 関連ユーザデータ項目の更新情報

setMnInvoice

public void setMnInvoice(String mnInvoice)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
mnInvoice - 関連ユーザデータ項目の更新情報

setExrateFi

public void setExrateFi(String exrateFi)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
exrateFi - 関連ユーザデータ項目の更新情報

setAddValDy

public void setAddValDy(String addValDy)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
addValDy - 関連ユーザデータ項目の更新情報

setFixValDy

public void setFixValDy(String fixValDy)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
fixValDy - 関連ユーザデータ項目の更新情報

setPymtMeth

public void setPymtMeth(String pymtMeth)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pymtMeth - 関連ユーザデータ項目の更新情報

setAccntAsgn

public void setAccntAsgn(String accntAsgn)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
accntAsgn - 関連ユーザデータ項目の更新情報

setExchgRate

public void setExchgRate(String exchgRate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
exchgRate - 関連ユーザデータ項目の更新情報

setBillDate

public void setBillDate(String billDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
billDate - 関連ユーザデータ項目の更新情報

setServDate

public void setServDate(String servDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
servDate - 関連ユーザデータ項目の更新情報

setDunnKey

public void setDunnKey(String dunnKey)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dunnKey - 関連ユーザデータ項目の更新情報

setDunnBlock

public void setDunnBlock(String dunnBlock)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dunnBlock - 関連ユーザデータ項目の更新情報

setPromotion

public void setPromotion(String promotion)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
promotion - 関連ユーザデータ項目の更新情報

setPmtgarPro

public void setPmtgarPro(String pmtgarPro)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pmtgarPro - 関連ユーザデータ項目の更新情報

setDepartmNo

public void setDepartmNo(String departmNo)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
departmNo - 関連ユーザデータ項目の更新情報

setRecPoint

public void setRecPoint(String recPoint)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
recPoint - 関連ユーザデータ項目の更新情報

setPoitmNoS

public void setPoitmNoS(String poitmNoS)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poitmNoS - 関連ユーザデータ項目の更新情報

setDocNumFi

public void setDocNumFi(String docNumFi)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
docNumFi - 関連ユーザデータ項目の更新情報

setCstcndgrp1

public void setCstcndgrp1(String cstcndgrp1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp1 - 関連ユーザデータ項目の更新情報

setCstcndgrp2

public void setCstcndgrp2(String cstcndgrp2)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp2 - 関連ユーザデータ項目の更新情報

setCstcndgrp3

public void setCstcndgrp3(String cstcndgrp3)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp3 - 関連ユーザデータ項目の更新情報

setCstcndgrp4

public void setCstcndgrp4(String cstcndgrp4)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp4 - 関連ユーザデータ項目の更新情報

setCstcndgrp5

public void setCstcndgrp5(String cstcndgrp5)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp5 - 関連ユーザデータ項目の更新情報

setDlvTime

public void setDlvTime(String dlvTime)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvTime - 関連ユーザデータ項目の更新情報

setCurrency

public void setCurrency(String currency)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
currency - 関連ユーザデータ項目の更新情報

setTaxdepCty

public void setTaxdepCty(String taxdepCty)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxdepCty - 関連ユーザデータ項目の更新情報

setTaxdstCty

public void setTaxdstCty(String taxdstCty)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxdstCty - 関連ユーザデータ項目の更新情報

setEutriDeal

public void setEutriDeal(String eutriDeal)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
eutriDeal - 関連ユーザデータ項目の更新情報

setMastContr

public void setMastContr(String mastContr)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
mastContr - 関連ユーザデータ項目の更新情報

setRefProc

public void setRefProc(String refProc)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refProc - 関連ユーザデータ項目の更新情報

setChkprtauth

public void setChkprtauth(String chkprtauth)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
chkprtauth - 関連ユーザデータ項目の更新情報

setCmlqtyDat

public void setCmlqtyDat(String cmlqtyDat)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cmlqtyDat - 関連ユーザデータ項目の更新情報

setVersion

public void setVersion(String version)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
version - 関連ユーザデータ項目の更新情報

setNotifNo

public void setNotifNo(String notifNo)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
notifNo - 関連ユーザデータ項目の更新情報

setWbsElem

public void setWbsElem(String wbsElem)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
wbsElem - 関連ユーザデータ項目の更新情報

setExchRateFiV

public void setExchRateFiV(String exchRateFiV)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
exchRateFiV - 関連ユーザデータ項目の更新情報

setExchgRateV

public void setExchgRateV(String exchgRateV)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
exchgRateV - 関連ユーザデータ項目の更新情報

setFkkConacct

public void setFkkConacct(String fkkConacct)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
fkkConacct - 関連ユーザデータ項目の更新情報

setCampaign

public void setCampaign(String campaign)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
campaign - 関連ユーザデータ項目の更新情報

setDocClass

public void setDocClass(String docClass)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
docClass - 関連ユーザデータ項目の更新情報

setHCurr

public void setHCurr(String hCurr)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
hCurr - 関連ユーザデータ項目の更新情報

setShipType

public void setShipType(String shipType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
shipType - 関連ユーザデータ項目の更新情報

setSProcInd

public void setSProcInd(String sProcInd)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
sProcInd - 関連ユーザデータ項目の更新情報

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ItemsIn (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ItemsIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn
すべての実装インタフェース:
Serializable
public class ItemsIn
extends Object
implements Serializable

明細データ情報クラス
機能は以下の通り

  • 明細データ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ItemsIn()
明細データ情報を作成します。
ItemsIn(int index)
明細データ情報を作成します。
メソッドの概要
String | getAccntAsgn() 得意先の勘定設定グループを取得します。
String | getAddValDy() 有効日からの日数を取得します。
String | getAlternBom() 代替 BOMを取得します。
String | getAltToItm() 代替明細を取得します。
String | getAssortMod() 品揃モジュールを取得します。
String | getBatch() ロット番号を取得します。
String | getBegdemPer() 見越期間の提案開始日付を取得します。
String | getBilForm() 請求書式を取得します。
String | getBillBlock() ブロックを取得します。
String | getBillDate() 請求索引および印刷に対する請求日を取得します。
String | getBillRel() 請求関連 (CRM)を取得します。
String | getBillSched() 請求日程 (稼働日カレンダ指定)を取得します。
String | getBomexplNo() BOM 展開番号を取得します。
String | getBusTranst() 貿易管理の取引タイプを取得します。
String | getCampaign() 総括プロジェクト計画: 外部 R/3 システムの GUIDを取得します。
String | getCfopCode() CFOP code and extension (old 5 char version)を取得します。
String | getCfopLong() CFOP code and extensionを取得します。
String | getCompQuant() 構成品目数量を取得します。
String | getConfigId() 外部選定 ID (仮)を取得します。
String | getCreatedBy() オブジェクト登録者名を取得します。
String | getCstcndgrp1() 得意先条件グループ１を取得します。
String | getCstcndgrp2() 得意先条件グループ２を取得します。
String | getCstcndgrp3() 得意先条件グループ３を取得します。
String | getCstcndgrp4() 得意先条件グループ４を取得します。
String | getCstcndgrp5() 得意先条件グループ５を取得します。
String | getCstgSheet() 原価計算表を取得します。
String | getCurrency() 販売伝票通貨を取得します。
String | getCurrIso() ISO コード通貨を取得します。
String | getCustGroup() 得意先グループを取得します。
String | getCustMat22() 得意先品目コード (無効)を取得します。
String | getCustMat35() 得意先品目を取得します。
String | getDepartmNo() 部門コードを取得します。
String | getDeprecPer() ドキュメンタリクレジット処理に関する償却率 (%)を取得します。
String | getDivision() 製品部門を取得します。
String | getDliProfil() 動的明細プロセッサプロファイルを取得します。
String | getDlvGroup() 出荷グループ (明細一括出荷)を取得します。
String | getDlvPrio() 出荷優先順位を取得します。
String | getDlvschduse() 用途区分を取得します。
String | getDlvTime() 契約出荷期間を取得します。
String | getDocNumFi() ドキュメンタリクレジット処理: 内部番号を取得します。
String | getDunnBlock() 督促処理保留を取得します。
String | getDunnKey() 督促処理キーを取得します。
String | getEanUpc() 国際商品コード (EAN/UPC)を取得します。
String | getExchgRate() 価格設定/統計の換算レート (直接引用)を取得します。
String | getExchgRateV() 価格設定/統計の換算レート (間接引用)を取得します。
String | getExchRateFiV() FI 転記の換算レート (間接相場)を取得します。
String | getExRateFi() FI 転記の換算レート (直接相場)を取得します。
String | getFixdatQty() 納期と出荷数量の固定を取得します。
String | getFixedQuan() 数量固定区分を取得します。
String | getFixValDy() 有効日日付を取得します。
String | getFkkConacct() 長さ 12 の文字項目を取得します。
String | getFuncArea() 機能領域を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getGrossWght() 明細の総重量を取得します。
String | getHgLvItem() 上位レベル明細を取得します。
String | getIncoterms1() インコタームズ (1)を取得します。
String | getIncoterms2() インコタームズ 2を取得します。
int | getIndex() レコード番号を取得します｡
String | getInstId() 選定におけるインスタンス番号を取得します。
String | getInvoSched() 請求書一覧日程 (稼働日カレンダ指定)を取得します。
String | getItemCateg() 明細カテゴリ (販売伝票)を取得します。
String | getItemguidAtp() ATP: 暗号 - DELNR および DELPSを取得します。
String | getItmNumber() 販売伝票明細を取得します。
String | getItmTypeUsage() 明細用途を取得します。
String | getLogSystemOwn() 論理システムを取得します。
String | getMatEntrd() 入力品目を取得します。
String | getMaterial() 品目コードを取得します。
String | getMatExt() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMatfrgtgrp() 品目運賃グループを取得します。
String | getMatGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMatlGroup() 品目グループを取得します。
String | getMatPrGrp() 品目価格設定グループを取得します。
String | getMatVers() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getMaxdevamnt() 数量に関する許容偏差 (絶対値)を取得します。
String | getMaxdevDay() シフト所要日数を取得します。
String | getMaxdevper() 数量に関する許容偏差 (%)を取得します。
String | getMaxPlDlv() 明細ごとの分割納入可能な最大回数を取得します。
String | getMnInvoice() マニュアル請求書更新を取得します。
String | getNetWeight() 明細の正味重量を取得します。
String | getNoGrPost() 得意先が入庫を転記していませんを取得します。
String | getOrdcompIn() 受注結合出荷区分を取得します。
String | getOrderid() 指図番号を取得します。
String | getOrderProb() 明細の受注可能性を取得します。
String | getOverdlvtol() 過剰納入許容範囲を取得します。
String | getOverhdKey() 間接費キーを取得します。
String | getPartDlv() 明細レベルの分納納入を取得します。
String | getPlant() プラントを取得します。
String | getPldlvshdin() 出荷計画に関する指示を取得します。
String | getPMatExt() 項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を取得します。
String | getPMatGuid() 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を取得します。
String | getPMatVers() 項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を取得します。
String | getPmnttrms() 支払条件キーを取得します。
String | getPmtgarPro() 支払保証決定表を取得します。
String | getPoDatS() 出荷先の出荷先発注日付を取得します。
String | getPoItmNo() 元となる購買発注の明細番号を取得します。
String | getPoitmNoS() 元となる購買発注の明細番号を取得します。
String | getPoMethod() 得意先発注タイプを取得します。
String | getPoMethS() 出荷先の出荷先発注タイプを取得します。
String | getPrcGroup1() 品目グループ 1を取得します。
String | getPrcGroup2() 品目グループ 2を取得します。
String | getPrcGroup3() 品目グループ 3を取得します。
String | getPrcGroup4() 品目グループ 4を取得します。
String | getPrcGroup5() 品目グループ 5を取得します。
String | getPriceDate() 価格設定/外貨換算の実行日付を取得します。
String | getPriceGrp() 価格グループ (得意先)を取得します。
String | getPriceList() 価格表タイプを取得します。
String | getProdcat() 製品カタログ番号を取得します。
String | getProdHiera() 品目階層を取得します。
String | getProfitCtr() 利益センタを取得します。
String | getPromotion() プロモーションを取得します。
String | getPrRefMat() 価格設定参照品目を取得します。
String | getPurchDate() 得意先発注日付を取得します。
String | getPurchNoC() 出荷先発注番号を取得します。
String | getPurchNoS() 出荷先の得意先発注番号を取得します。
String | getPymtMeth() 支払方法を取得します。
String | getReasonRej() 見積および受注の拒否理由を取得します。
String | getRecPoint() 入荷ポイントを取得します。
String | getRef1() 得意先/仕入先の内部参照コードを取得します。
String | getRef1S() 出荷先文字を取得します。
String | getRefDoc() 参照伝票番号を取得します。
String | getRefDocCa() 先行販売管理伝票の伝票カテゴリを取得します。
String | getRefDocIt() 参照明細番号を取得します。
String | getReflogsys() 論理システムを取得します。
String | getRefobjkey() オブジェクトキーを取得します。
String | getRefobjtype() オブジェクトタイプを取得します。
String | getReqmtsTyp() 所要量タイプを取得します。
String | getResanalkey() 結果分析キーを取得します。
String | getRevType() 収益承認カテゴリを取得します。
String | getRnddlvQty() 丸め数量: 出荷を取得します。
String | getRoute() 輸送経路を取得します。
String | getSalesDist() 販売地域を取得します。
String | getSalesUnit() 販売単位を取得します。
String | getSalqtyden() 販売数量単位を SKU に換算するための分母 (除数)を取得します。
String | getSalqtynum() 販売数量単位から基本数量単位への変換係数の分子を取得します。
String | getSdTaxcode() を取得します。
String | getSelection() 選択 ID (永続)を取得します。
String | getSeqNo() KANBAN/連続番号を取得します。
String | getServDate() サービス提供日を取得します。
String | getShipPoint() 出荷ポイント/入荷ポイントを取得します。
String | getShipType() 出荷タイプを取得します。
String | getShortText() テキスト (短): 受注明細を取得します。
String | getSProcInd() 特別処理区分を取得します。
String | getStoreLoc() 保管場所を取得します。
String | getSUnitIso() 単位の ISO コードを取得します。
String | getTargetQty() 目標数量（販売単位）を取得します。
String | getTargetQu() 目標数量 (数量単位)を取得します。
String | getTargetVal() BAPI の通貨額 (小数点以下９桁)を取得します。
String | getTaxClass1() 品目の税分類を取得します。
String | getTaxClass2() 品目の税分類を取得します。
String | getTaxClass3() 品目の税分類を取得します。
String | getTaxClass4() 品目の税分類を取得します。
String | getTaxClass5() 品目の税分類を取得します。
String | getTaxClass6() 品目の税分類を取得します。
String | getTaxClass7() 品目の税分類を取得します。
String | getTaxClass8() 品目の税分類を取得します。
String | getTaxClass9() 品目の税分類を取得します。
String | getTaxlawicms() 税法: ICMSを取得します。
String | getTaxlawipi() 税法: IPIを取得します。
String | getTrgqtyDen() 販売単位から基本単位への換算係数を取得します。
String | getTrgQtyNo() 販売単位から基本単位への換算係数を取得します。
String | getTUnitIso() 目標数量単位 (ISO コード)を取得します。
String | getUnddlvTol() 不足納入許容範囲リミットを取得します。
String | getUnlmtDlv() 区分: 無制限過剰納入可能を取得します。
String | getUnofWtiso() ISO コードでの重量単位を取得します。
String | getUntofWght() 重量単位を取得します。
String | getUsageInd() 未使用 - 予約長 3を取得します。
String | getValConI() 金額契約明細を取得します。
String | getValContr() 金額契約番号を取得します。
String | getValType() 評価タイプを取得します。
String | getVolume() 明細の総数量を取得します。
String | getVolunit() 容積単位を取得します。
String | getVolunitiso() ISO コードでの容積単位を取得します。
String | getVwUepos() 上位レベル明細用途 IDを取得します。
String | getWbsElem() WBS 要素を取得します。
void | setAccntAsgn(String accntAsgn) 得意先の勘定設定グループを設定します。
void | setAddValDy(String addValDy) 有効日からの日数を設定します。
void | setAlternBom(String alternBom) 代替 BOMを設定します。
void | setAltToItm(String altToItm) 代替明細を設定します。
void | setAssortMod(String assortMod) 品揃モジュールを設定します。
void | setBatch(String batch) ロット番号を設定します。
void | setBegdemPer(String begdemPer) 見越期間の提案開始日付を設定します。
void | setBilForm(String bilForm) 請求書式を設定します。
void | setBillBlock(String billBlock) ブロックを設定します。
void | setBillDate(String billDate) 請求索引および印刷に対する請求日を設定します。
void | setBillRel(String billRel) 請求関連 (CRM)を設定します。
void | setBillSched(String billSched) 請求日程 (稼働日カレンダ指定)を設定します。
void | setBomexplNo(String bomexplNo) BOM 展開番号を設定します。
void | setBusTranst(String busTranst) 貿易管理の取引タイプを設定します。
void | setCampaign(String campaign) 総括プロジェクト計画: 外部 R/3 システムの GUIDを設定します。
void | setCfopCode(String cfopCode) CFOP code and extension (old 5 char version)を設定します。
void | setCfopLong(String cfopLong) CFOP code and extensionを設定します。
void | setCompQuant(String compQuant) 構成品目数量を設定します。
void | setConfigId(String configId) 外部選定 ID (仮)を設定します。
void | setCreatedBy(String createdBy) オブジェクト登録者名を設定します。
void | setCstcndgrp1(String cstcndgrp1) 得意先条件グループ１を設定します。
void | setCstcndgrp2(String cstcndgrp2) 得意先条件グループ２を設定します。
void | setCstcndgrp3(String cstcndgrp3) 得意先条件グループ３を設定します。
void | setCstcndgrp4(String cstcndgrp4) 得意先条件グループ４を設定します。
void | setCstcndgrp5(String cstcndgrp5) 得意先条件グループ５を設定します。
void | setCstgSheet(String cstgSheet) 原価計算表を設定します。
void | setCurrency(String currency) 販売伝票通貨を設定します。
void | setCurrIso(String currIso) ISO コード通貨を設定します。
void | setCustGroup(String custGroup) 得意先グループを設定します。
void | setCustMat22(String custMat22) 得意先品目コード (無効)を設定します。
void | setCustMat35(String custMat35) 得意先品目を設定します。
void | setDepartmNo(String departmNo) 部門コードを設定します。
void | setDeprecPer(String deprecPer) ドキュメンタリクレジット処理に関する償却率 (%)を設定します。
void | setDivision(String division) 製品部門を設定します。
void | setDliProfil(String dliProfil) 動的明細プロセッサプロファイルを設定します。
void | setDlvGroup(String dlvGroup) 出荷グループ (明細一括出荷)を設定します。
void | setDlvPrio(String dlvPrio) 出荷優先順位を設定します。
void | setDlvschduse(String dlvschduse) 用途区分を設定します。
void | setDlvTime(String dlvTime) 契約出荷期間を設定します。
void | setDocNumFi(String docNumFi) ドキュメンタリクレジット処理: 内部番号を設定します。
void | setDunnBlock(String dunnBlock) 督促処理保留を設定します。
void | setDunnKey(String dunnKey) 督促処理キーを設定します。
void | setEanUpc(String eanUpc) 国際商品コード (EAN/UPC)を設定します。
void | setExchgRate(String exchgRate) 価格設定/統計の換算レート (直接引用)を設定します。
void | setExchgRateV(String exchgRateV) 価格設定/統計の換算レート (間接引用)を設定します。
void | setExchRateFiV(String exchRateFiV) FI 転記の換算レート (間接相場)を設定します。
void | setExRateFi(String exRateFi) FI 転記の換算レート (直接相場)を設定します。
void | setFixdatQty(String fixdatQty) 納期と出荷数量の固定を設定します。
void | setFixedQuan(String fixedQuan) 数量固定区分を設定します。
void | setFixValDy(String fixValDy) 有効日日付を設定します。
void | setFkkConacct(String fkkConacct) 長さ 12 の文字項目を設定します。
void | setFuncArea(String funcArea) 機能領域を設定します。
void | setFuncAreaLong(String funcAreaLong) 機能領域を設定します。
void | setGrossWght(String grossWght) 明細の総重量を設定します。
void | setHgLvItem(String hgLvItem) 上位レベル明細を設定します。
void | setIncoterms1(String incoterms1) インコタームズ (1)を設定します。
void | setIncoterms2(String incoterms2) インコタームズ 2を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setInstId(String instId) 選定におけるインスタンス番号を設定します。
void | setInvoSched(String invoSched) 請求書一覧日程 (稼働日カレンダ指定)を設定します。
void | setItemCateg(String itemCateg) 明細カテゴリ (販売伝票)を設定します。
void | setItemguidAtp(String itemguidAtp) ATP: 暗号 - DELNR および DELPSを設定します。
void | setItmNumber(String itmNumber) 販売伝票明細を設定します。
void | setItmTypeUsage(String itmTypeUsage) 明細用途を設定します。
void | setLogSystemOwn(String logSystemOwn) 論理システムを設定します。
void | setMatEntrd(String matEntrd) 入力品目を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMatExt(String matExt) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMatfrgtgrp(String matfrgtgrp) 品目運賃グループを設定します。
void | setMatGuid(String matGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMatlGroup(String matlGroup) 品目グループを設定します。
void | setMatPrGrp(String matPrGrp) 品目価格設定グループを設定します。
void | setMatVers(String matVers) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setMaxdevamnt(String maxdevamnt) 数量に関する許容偏差 (絶対値)を設定します。
void | setMaxdevDay(String maxdevDay) シフト所要日数を設定します。
void | setMaxdevper(String maxdevper) 数量に関する許容偏差 (%)を設定します。
void | setMaxPlDlv(String maxPlDlv) 明細ごとの分割納入可能な最大回数を設定します。
void | setMnInvoice(String mnInvoice) マニュアル請求書更新を設定します。
void | setNetWeight(String netWeight) 明細の正味重量を設定します。
void | setNoGrPost(String noGrPost) 得意先が入庫を転記していませんを設定します。
void | setOrdcompIn(String ordcompIn) 受注結合出荷区分を設定します。
void | setOrderid(String orderid) 指図番号を設定します。
void | setOrderProb(String orderProb) 明細の受注可能性を設定します。
void | setOverdlvtol(String overdlvtol) 過剰納入許容範囲を設定します。
void | setOverhdKey(String overhdKey) 間接費キーを設定します。
void | setPartDlv(String partDlv) 明細レベルの分納納入を設定します。
void | setPlant(String plant) プラントを設定します。
void | setPldlvshdin(String pldlvshdin) 出荷計画に関する指示を設定します。
void | setPMatExt(String pMatExt) 項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を設定します。
void | setPMatGuid(String pMatGuid) 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を設定します。
void | setPMatVers(String pMatVers) 項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を設定します。
void | setPmnttrms(String pmnttrms) 支払条件キーを設定します。
void | setPmtgarPro(String pmtgarPro) 支払保証決定表を設定します。
void | setPoDatS(String poDatS) 出荷先の出荷先発注日付を設定します。
void | setPoItmNo(String poItmNo) 元となる購買発注の明細番号を設定します。
void | setPoitmNoS(String poitmNoS) 元となる購買発注の明細番号を設定します。
void | setPoMethod(String poMethod) 得意先発注タイプを設定します。
void | setPoMethS(String poMethS) 出荷先の出荷先発注タイプを設定します。
void | setPrcGroup1(String prcGroup1) 品目グループ 1を設定します。
void | setPrcGroup2(String prcGroup2) 品目グループ 2を設定します。
void | setPrcGroup3(String prcGroup3) 品目グループ 3を設定します。
void | setPrcGroup4(String prcGroup4) 品目グループ 4を設定します。
void | setPrcGroup5(String prcGroup5) 品目グループ 5を設定します。
void | setPriceDate(String priceDate) 価格設定/外貨換算の実行日付を設定します。
void | setPriceGrp(String priceGrp) 価格グループ (得意先)を設定します。
void | setPriceList(String priceList) 価格表タイプを設定します。
void | setProdcat(String prodcat) 製品カタログ番号を設定します。
void | setProdHiera(String prodHiera) 品目階層を設定します。
void | setProfitCtr(String profitCtr) 利益センタを設定します。
void | setPromotion(String promotion) プロモーションを設定します。
void | setPrRefMat(String prRefMat) 価格設定参照品目を設定します。
void | setPurchDate(String purchDate) 得意先発注日付を設定します。
void | setPurchNoC(String purchNoC) 出荷先発注番号を設定します。
void | setPurchNoS(String purchNoS) 出荷先の得意先発注番号を設定します。
void | setPymtMeth(String pymtMeth) 支払方法を設定します。
void | setReasonRej(String reasonRej) 見積および受注の拒否理由を設定します。
void | setRecPoint(String recPoint) 入荷ポイントを設定します。
void | setRef1(String ref1) 得意先/仕入先の内部参照コードを設定します。
void | setRef1S(String ref1S) 出荷先文字を設定します。
void | setRefDoc(String refDoc) 参照伝票番号を設定します。
void | setRefDocCa(String refDocCa) 先行販売管理伝票の伝票カテゴリを設定します。
void | setRefDocIt(String refDocIt) 参照明細番号を設定します。
void | setReflogsys(String reflogsys) 論理システムを設定します。
void | setRefobjkey(String refobjkey) オブジェクトキーを設定します。
void | setRefobjtype(String refobjtype) オブジェクトタイプを設定します。
void | setReqmtsTyp(String reqmtsTyp) 所要量タイプを設定します。
void | setResanalkey(String resanalkey) 結果分析キーを設定します。
void | setRevType(String revType) 収益承認カテゴリを設定します。
void | setRnddlvQty(String rnddlvQty) 丸め数量: 出荷を設定します。
void | setRoute(String route) 輸送経路を設定します。
void | setSalesDist(String salesDist) 販売地域を設定します。
void | setSalesUnit(String salesUnit) 販売単位を設定します。
void | setSalqtyden(String salqtyden) 販売数量単位を SKU に換算するための分母 (除数)を設定します。
void | setSalqtynum(String salqtynum) 販売数量単位から基本数量単位への変換係数の分子を設定します。
void | setSdTaxcode(String sdTaxcode) 0を設定します。
void | setSelection(String selection) 選択 ID (永続)を設定します。
void | setSeqNo(String seqNo) KANBAN/連続番号を設定します。
void | setServDate(String servDate) サービス提供日を設定します。
void | setShipPoint(String shipPoint) 出荷ポイント/入荷ポイントを設定します。
void | setShipType(String shipType) 出荷タイプを設定します。
void | setShortText(String shortText) テキスト (短): 受注明細を設定します。
void | setSProcInd(String sProcInd) 特別処理区分を設定します。
void | setStoreLoc(String storeLoc) 保管場所を設定します。
void | setSUnitIso(String sUnitIso) 単位の ISO コードを設定します。
void | setTargetQty(String targetQty) 目標数量（販売単位）を設定します。
void | setTargetQu(String targetQu) 目標数量 (数量単位)を設定します。
void | setTargetVal(String targetVal) BAPI の通貨額 (小数点以下９桁)を設定します。
void | setTaxClass1(String taxClass1) 品目の税分類を設定します。
void | setTaxClass2(String taxClass2) 品目の税分類を設定します。
void | setTaxClass3(String taxClass3) 品目の税分類を設定します。
void | setTaxClass4(String taxClass4) 品目の税分類を設定します。
void | setTaxClass5(String taxClass5) 品目の税分類を設定します。
void | setTaxClass6(String taxClass6) 品目の税分類を設定します。
void | setTaxClass7(String taxClass7) 品目の税分類を設定します。
void | setTaxClass8(String taxClass8) 品目の税分類を設定します。
void | setTaxClass9(String taxClass9) 品目の税分類を設定します。
void | setTaxlawicms(String taxlawicms) 税法: ICMSを設定します。
void | setTaxlawipi(String taxlawipi) 税法: IPIを設定します。
void | setTrgqtyDen(String trgqtyDen) 販売単位から基本単位への換算係数を設定します。
void | setTrgQtyNo(String trgQtyNo) 販売単位から基本単位への換算係数を設定します。
void | setTUnitIso(String tUnitIso) 目標数量単位 (ISO コード)を設定します。
void | setUnddlvTol(String unddlvTol) 不足納入許容範囲リミットを設定します。
void | setUnlmtDlv(String unlmtDlv) 区分: 無制限過剰納入可能を設定します。
void | setUnofWtiso(String unofWtiso) ISO コードでの重量単位を設定します。
void | setUntofWght(String untofWght) 重量単位を設定します。
void | setUsageInd(String usageInd) 未使用 - 予約長 3を設定します。
void | setValConI(String valConI) 金額契約明細を設定します。
void | setValContr(String valContr) 金額契約番号を設定します。
void | setValType(String valType) 評価タイプを設定します。
void | setVolume(String volume) 明細の総数量を設定します。
void | setVolunit(String volunit) 容積単位を設定します。
void | setVolunitiso(String volunitiso) ISO コードでの容積単位を設定します。
void | setVwUepos(String vwUepos) 上位レベル明細用途 IDを設定します。
void | setWbsElem(String wbsElem) WBS 要素を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ItemsIn

public ItemsIn()
明細データ情報を作成します。

ItemsIn

public ItemsIn(int index)
明細データ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
itmNumber 販売伝票明細

getHgLvItem

public String getHgLvItem()
上位レベル明細を取得します。

戻り値:
hgLvItem 上位レベル明細

getPoItmNo

public String getPoItmNo()
元となる購買発注の明細番号を取得します。

戻り値:
poItmNo 元となる購買発注の明細番号

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getAltToItm

public String getAltToItm()
代替明細を取得します。

戻り値:
altToItm 代替明細

getCustMat22

public String getCustMat22()
得意先品目コード (無効)を取得します。

戻り値:
custMat22 得意先品目コード (無効)

getBatch

public String getBatch()
ロット番号を取得します。

戻り値:
batch ロット番号

getDlvGroup

public String getDlvGroup()
出荷グループ (明細一括出荷)を取得します。

戻り値:
dlvGroup 出荷グループ (明細一括出荷)

getPartDlv

public String getPartDlv()
明細レベルの分納納入を取得します。

戻り値:
partDlv 明細レベルの分納納入

getReasonRej

public String getReasonRej()
見積および受注の拒否理由を取得します。

戻り値:
reasonRej 見積および受注の拒否理由

getBillBlock

public String getBillBlock()
ブロックを取得します。

戻り値:
billBlock ブロック

getBillDate

public String getBillDate()
請求索引および印刷に対する請求日を取得します。

戻り値:
billDate 請求索引および印刷に対する請求日

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getStoreLoc

public String getStoreLoc()
保管場所を取得します。

戻り値:
storeLoc 保管場所

getTargetQty

public String getTargetQty()
目標数量（販売単位）を取得します。

戻り値:
targetQty 目標数量（販売単位）

getTargetQu

public String getTargetQu()
目標数量 (数量単位)を取得します。

戻り値:
targetQu 目標数量 (数量単位)

getTUnitIso

public String getTUnitIso()
目標数量単位 (ISO コード)を取得します。

戻り値:
tUnitIso 目標数量単位 (ISO コード)

getItemCateg

public String getItemCateg()
明細カテゴリ (販売伝票)を取得します。

戻り値:
itemCateg 明細カテゴリ (販売伝票)

getShortText

public String getShortText()
テキスト (短): 受注明細を取得します。

戻り値:
shortText テキスト (短): 受注明細

getPrcGroup1

public String getPrcGroup1()
品目グループ 1を取得します。

戻り値:
prcGroup1 品目グループ 1

getPrcGroup2

public String getPrcGroup2()
品目グループ 2を取得します。

戻り値:
prcGroup2 品目グループ 2

getPrcGroup3

public String getPrcGroup3()
品目グループ 3を取得します。

戻り値:
prcGroup3 品目グループ 3

getPrcGroup4

public String getPrcGroup4()
品目グループ 4を取得します。

戻り値:
prcGroup4 品目グループ 4

getPrcGroup5

public String getPrcGroup5()
品目グループ 5を取得します。

戻り値:
prcGroup5 品目グループ 5

getProdHiera

public String getProdHiera()
品目階層を取得します。

戻り値:
prodHiera 品目階層

getMatlGroup

public String getMatlGroup()
品目グループを取得します。

戻り値:
matlGroup 品目グループ

getPurchNoC

public String getPurchNoC()
出荷先発注番号を取得します。

戻り値:
purchNoC 出荷先発注番号

getPurchDate

public String getPurchDate()
得意先発注日付を取得します。

戻り値:
purchDate 得意先発注日付

getPoMethod

public String getPoMethod()
得意先発注タイプを取得します。

戻り値:
poMethod 得意先発注タイプ

getRef1

public String getRef1()
得意先/仕入先の内部参照コードを取得します。

戻り値:
ref1 得意先/仕入先の内部参照コード

getPurchNoS

public String getPurchNoS()
出荷先の得意先発注番号を取得します。

戻り値:
purchNoS 出荷先の得意先発注番号

getPoDatS

public String getPoDatS()
出荷先の出荷先発注日付を取得します。

戻り値:
poDatS 出荷先の出荷先発注日付

getPoMethS

public String getPoMethS()
出荷先の出荷先発注タイプを取得します。

戻り値:
poMethS 出荷先の出荷先発注タイプ

getRef1S

public String getRef1S()
出荷先文字を取得します。

戻り値:
ref1S 出荷先文字

getPoitmNoS

public String getPoitmNoS()
元となる購買発注の明細番号を取得します。

戻り値:
poitmNoS 元となる購買発注の明細番号

getPriceGrp

public String getPriceGrp()
価格グループ (得意先)を取得します。

戻り値:
priceGrp 価格グループ (得意先)

getCustGroup

public String getCustGroup()
得意先グループを取得します。

戻り値:
custGroup 得意先グループ

getSalesDist

public String getSalesDist()
販売地域を取得します。

戻り値:
salesDist 販売地域

getPriceList

public String getPriceList()
価格表タイプを取得します。

戻り値:
priceList 価格表タイプ

getIncoterms1

public String getIncoterms1()
インコタームズ (1)を取得します。

戻り値:
incoterms1 インコタームズ (1)

getIncoterms2

public String getIncoterms2()
インコタームズ 2を取得します。

戻り値:
incoterms2 インコタームズ 2

getOrdcompIn

public String getOrdcompIn()
受注結合出荷区分を取得します。

戻り値:
ordcompIn 受注結合出荷区分

getBillSched

public String getBillSched()
請求日程 (稼働日カレンダ指定)を取得します。

戻り値:
billSched 請求日程 (稼働日カレンダ指定)

getInvoSched

public String getInvoSched()
請求書一覧日程 (稼働日カレンダ指定)を取得します。

戻り値:
invoSched 請求書一覧日程 (稼働日カレンダ指定)

getMnInvoice

public String getMnInvoice()
マニュアル請求書更新を取得します。

戻り値:
mnInvoice マニュアル請求書更新

getExRateFi

public String getExRateFi()
FI 転記の換算レート (直接相場)を取得します。

戻り値:
exRateFi FI 転記の換算レート (直接相場)

getAddValDy

public String getAddValDy()
有効日からの日数を取得します。

戻り値:
addValDy 有効日からの日数

getFixValDy

public String getFixValDy()
有効日日付を取得します。

戻り値:
fixValDy 有効日日付

getPmnttrms

public String getPmnttrms()
支払条件キーを取得します。

戻り値:
pmnttrms 支払条件キー

getPymtMeth

public String getPymtMeth()
支払方法を取得します。

戻り値:
pymtMeth 支払方法

getAccntAsgn

public String getAccntAsgn()
得意先の勘定設定グループを取得します。

戻り値:
accntAsgn 得意先の勘定設定グループ

getExchgRate

public String getExchgRate()
価格設定/統計の換算レート (直接引用)を取得します。

戻り値:
exchgRate 価格設定/統計の換算レート (直接引用)

getPriceDate

public String getPriceDate()
価格設定/外貨換算の実行日付を取得します。

戻り値:
priceDate 価格設定/外貨換算の実行日付

getServDate

public String getServDate()
サービス提供日を取得します。

戻り値:
servDate サービス提供日

getDunnKey

public String getDunnKey()
督促処理キーを取得します。

戻り値:
dunnKey 督促処理キー

getDunnBlock

public String getDunnBlock()
督促処理保留を取得します。

戻り値:
dunnBlock 督促処理保留

getPromotion

public String getPromotion()
プロモーションを取得します。

戻り値:
promotion プロモーション

getPmtgarPro

public String getPmtgarPro()
支払保証決定表を取得します。

戻り値:
pmtgarPro 支払保証決定表

getDocNumFi

public String getDocNumFi()
ドキュメンタリクレジット処理: 内部番号を取得します。

戻り値:
docNumFi ドキュメンタリクレジット処理: 内部番号

getDepartmNo

public String getDepartmNo()
部門コードを取得します。

戻り値:
departmNo 部門コード

getRecPoint

public String getRecPoint()
入荷ポイントを取得します。

戻り値:
recPoint 入荷ポイント

getCstcndgrp1

public String getCstcndgrp1()
得意先条件グループ１を取得します。

戻り値:
cstcndgrp1 得意先条件グループ１

getCstcndgrp2

public String getCstcndgrp2()
得意先条件グループ２を取得します。

戻り値:
cstcndgrp2 得意先条件グループ２

getCstcndgrp3

public String getCstcndgrp3()
得意先条件グループ３を取得します。

戻り値:
cstcndgrp3 得意先条件グループ３

getCstcndgrp4

public String getCstcndgrp4()
得意先条件グループ４を取得します。

戻り値:
cstcndgrp4 得意先条件グループ４

getCstcndgrp5

public String getCstcndgrp5()
得意先条件グループ５を取得します。

戻り値:
cstcndgrp5 得意先条件グループ５

getDlvTime

public String getDlvTime()
契約出荷期間を取得します。

戻り値:
dlvTime 契約出荷期間

getSalesUnit

public String getSalesUnit()
販売単位を取得します。

戻り値:
salesUnit 販売単位

getSUnitIso

public String getSUnitIso()
単位の ISO コードを取得します。

戻り値:
sUnitIso 単位の ISO コード

getTrgQtyNo

public String getTrgQtyNo()
販売単位から基本単位への換算係数を取得します。

戻り値:
trgQtyNo 販売単位から基本単位への換算係数

getTrgqtyDen

public String getTrgqtyDen()
販売単位から基本単位への換算係数を取得します。

戻り値:
trgqtyDen 販売単位から基本単位への換算係数

getRnddlvQty

public String getRnddlvQty()
丸め数量: 出荷を取得します。

戻り値:
rnddlvQty 丸め数量: 出荷

getMaxdevamnt

public String getMaxdevamnt()
数量に関する許容偏差 (絶対値)を取得します。

戻り値:
maxdevamnt 数量に関する許容偏差 (絶対値)

getMaxdevper

public String getMaxdevper()
数量に関する許容偏差 (%)を取得します。

戻り値:
maxdevper 数量に関する許容偏差 (%)

getMaxdevDay

public String getMaxdevDay()
シフト所要日数を取得します。

戻り値:
maxdevDay シフト所要日数

getUsageInd

public String getUsageInd()
未使用 - 予約長 3を取得します。

戻り値:
usageInd 未使用 - 予約長 3

getFixedQuan

public String getFixedQuan()
数量固定区分を取得します。

戻り値:
fixedQuan 数量固定区分

getUnlmtDlv

public String getUnlmtDlv()
区分: 無制限過剰納入可能を取得します。

戻り値:
unlmtDlv 区分: 無制限過剰納入可能

getOverdlvtol

public String getOverdlvtol()
過剰納入許容範囲を取得します。

戻り値:
overdlvtol 過剰納入許容範囲

getUnddlvTol

public String getUnddlvTol()
不足納入許容範囲リミットを取得します。

戻り値:
unddlvTol 不足納入許容範囲リミット

getDivision

public String getDivision()
製品部門を取得します。

戻り値:
division 製品部門

getSalqtynum

public String getSalqtynum()
販売数量単位から基本数量単位への変換係数の分子を取得します。

戻り値:
salqtynum 販売数量単位から基本数量単位への変換係数の分子

getSalqtyden

public String getSalqtyden()
販売数量単位を SKU に換算するための分母 (除数)を取得します。

戻り値:
salqtyden 販売数量単位を SKU に換算するための分母 (除数)

getGrossWght

public String getGrossWght()
明細の総重量を取得します。

戻り値:
grossWght 明細の総重量

getNetWeight

public String getNetWeight()
明細の正味重量を取得します。

戻り値:
netWeight 明細の正味重量

getUntofWght

public String getUntofWght()
重量単位を取得します。

戻り値:
untofWght 重量単位

getUnofWtiso

public String getUnofWtiso()
ISO コードでの重量単位を取得します。

戻り値:
unofWtiso ISO コードでの重量単位

getVolume

public String getVolume()
明細の総数量を取得します。

戻り値:
volume 明細の総数量

getVolunit

public String getVolunit()
容積単位を取得します。

戻り値:
volunit 容積単位

getVolunitiso

public String getVolunitiso()
ISO コードでの容積単位を取得します。

戻り値:
volunitiso ISO コードでの容積単位

getDlvPrio

public String getDlvPrio()
出荷優先順位を取得します。

戻り値:
dlvPrio 出荷優先順位

getShipPoint

public String getShipPoint()
出荷ポイント/入荷ポイントを取得します。

戻り値:
shipPoint 出荷ポイント/入荷ポイント

getRoute

public String getRoute()
輸送経路を取得します。

戻り値:
route 輸送経路

getCreatedBy

public String getCreatedBy()
オブジェクト登録者名を取得します。

戻り値:
createdBy オブジェクト登録者名

getTaxClass1

public String getTaxClass1()
品目の税分類を取得します。

戻り値:
taxClass1 品目の税分類

getTaxClass2

public String getTaxClass2()
品目の税分類を取得します。

戻り値:
taxClass2 品目の税分類

getTaxClass3

public String getTaxClass3()
品目の税分類を取得します。

戻り値:
taxClass3 品目の税分類

getTaxClass4

public String getTaxClass4()
品目の税分類を取得します。

戻り値:
taxClass4 品目の税分類

getTaxClass5

public String getTaxClass5()
品目の税分類を取得します。

戻り値:
taxClass5 品目の税分類

getTaxClass6

public String getTaxClass6()
品目の税分類を取得します。

戻り値:
taxClass6 品目の税分類

getTaxClass7

public String getTaxClass7()
品目の税分類を取得します。

戻り値:
taxClass7 品目の税分類

getTaxClass8

public String getTaxClass8()
品目の税分類を取得します。

戻り値:
taxClass8 品目の税分類

getTaxClass9

public String getTaxClass9()
品目の税分類を取得します。

戻り値:
taxClass9 品目の税分類

getMatPrGrp

public String getMatPrGrp()
品目価格設定グループを取得します。

戻り値:
matPrGrp 品目価格設定グループ

getValType

public String getValType()
評価タイプを取得します。

戻り値:
valType 評価タイプ

getFixdatQty

public String getFixdatQty()
納期と出荷数量の固定を取得します。

戻り値:
fixdatQty 納期と出荷数量の固定

getBomexplNo

public String getBomexplNo()
BOM 展開番号を取得します。

戻り値:
bomexplNo BOM 展開番号

getResanalkey

public String getResanalkey()
結果分析キーを取得します。

戻り値:
resanalkey 結果分析キー

getReqmtsTyp

public String getReqmtsTyp()
所要量タイプを取得します。

戻り値:
reqmtsTyp 所要量タイプ

getNoGrPost

public String getNoGrPost()
得意先が入庫を転記していませんを取得します。

戻り値:
noGrPost 得意先が入庫を転記していません

getBusTranst

public String getBusTranst()
貿易管理の取引タイプを取得します。

戻り値:
busTranst 貿易管理の取引タイプ

getOverhdKey

public String getOverhdKey()
間接費キーを取得します。

戻り値:
overhdKey 間接費キー

getCstgSheet

public String getCstgSheet()
原価計算表を取得します。

戻り値:
cstgSheet 原価計算表

getMatfrgtgrp

public String getMatfrgtgrp()
品目運賃グループを取得します。

戻り値:
matfrgtgrp 品目運賃グループ

getPldlvshdin

public String getPldlvshdin()
出荷計画に関する指示を取得します。

戻り値:
pldlvshdin 出荷計画に関する指示

getSeqNo

public String getSeqNo()
KANBAN/連続番号を取得します。

戻り値:
seqNo KANBAN/連続番号

getBilForm

public String getBilForm()
請求書式を取得します。

戻り値:
bilForm 請求書式

getDliProfil

public String getDliProfil()
動的明細プロセッサプロファイルを取得します。

戻り値:
dliProfil 動的明細プロセッサプロファイル

getRevType

public String getRevType()
収益承認カテゴリを取得します。

戻り値:
revType 収益承認カテゴリ

getBegdemPer

public String getBegdemPer()
見越期間の提案開始日付を取得します。

戻り値:
begdemPer 見越期間の提案開始日付

getPrRefMat

public String getPrRefMat()
価格設定参照品目を取得します。

戻り値:
prRefMat 価格設定参照品目

getRefobjtype

public String getRefobjtype()
オブジェクトタイプを取得します。

戻り値:
refobjtype オブジェクトタイプ

getRefobjkey

public String getRefobjkey()
オブジェクトキーを取得します。

戻り値:
refobjkey オブジェクトキー

getReflogsys

public String getReflogsys()
論理システムを取得します。

戻り値:
reflogsys 論理システム

getOrderProb

public String getOrderProb()
明細の受注可能性を取得します。

戻り値:
orderProb 明細の受注可能性

getMaxPlDlv

public String getMaxPlDlv()
明細ごとの分割納入可能な最大回数を取得します。

戻り値:
maxPlDlv 明細ごとの分割納入可能な最大回数

getCfopCode

public String getCfopCode()
CFOP code and extension (old 5 char version)を取得します。

戻り値:
cfopCode CFOP code and extension (old 5 char version)

getTaxlawicms

public String getTaxlawicms()
税法: ICMSを取得します。

戻り値:
taxlawicms 税法: ICMS

getTaxlawipi

public String getTaxlawipi()
税法: IPIを取得します。

戻り値:
taxlawipi 税法: IPI

getSdTaxcode

public String getSdTaxcode()
を取得します。

戻り値:
sdTaxcode

getAssortMod

public String getAssortMod()
品揃モジュールを取得します。

戻り値:
assortMod 品揃モジュール

getCompQuant

public String getCompQuant()
構成品目数量を取得します。

戻り値:
compQuant 構成品目数量

getTargetVal

public String getTargetVal()
BAPI の通貨額 (小数点以下９桁)を取得します。

戻り値:
targetVal BAPI の通貨額 (小数点以下９桁)

getCurrency

public String getCurrency()
販売伝票通貨を取得します。

戻り値:
currency 販売伝票通貨

getCurrIso

public String getCurrIso()
ISO コード通貨を取得します。

戻り値:
currIso ISO コード通貨

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
profitCtr 利益センタ

getOrderid

public String getOrderid()
指図番号を取得します。

戻り値:
orderid 指図番号

getWbsElem

public String getWbsElem()
WBS 要素を取得します。

戻り値:
wbsElem WBS 要素

getDeprecPer

public String getDeprecPer()
ドキュメンタリクレジット処理に関する償却率 (%)を取得します。

戻り値:
deprecPer ドキュメンタリクレジット処理に関する償却率 (%)

getRefDoc

public String getRefDoc()
参照伝票番号を取得します。

戻り値:
refDoc 参照伝票番号

getRefDocIt

public String getRefDocIt()
参照明細番号を取得します。

戻り値:
refDocIt 参照明細番号

getRefDocCa

public String getRefDocCa()
先行販売管理伝票の伝票カテゴリを取得します。

戻り値:
refDocCa 先行販売管理伝票の伝票カテゴリ

getCustMat35

public String getCustMat35()
得意先品目を取得します。

戻り値:
custMat35 得意先品目

getExchRateFiV

public String getExchRateFiV()
FI 転記の換算レート (間接相場)を取得します。

戻り値:
exchRateFiV FI 転記の換算レート (間接相場)

getExchgRateV

public String getExchgRateV()
価格設定/統計の換算レート (間接引用)を取得します。

戻り値:
exchgRateV 価格設定/統計の換算レート (間接引用)

getItemguidAtp

public String getItemguidAtp()
ATP: 暗号 - DELNR および DELPSを取得します。

戻り値:
itemguidAtp ATP: 暗号 - DELNR および DELPS

getValContr

public String getValContr()
金額契約番号を取得します。

戻り値:
valContr 金額契約番号

getValConI

public String getValConI()
金額契約明細を取得します。

戻り値:
valConI 金額契約明細

getConfigId

public String getConfigId()
外部選定 ID (仮)を取得します。

戻り値:
configId 外部選定 ID (仮)

getInstId

public String getInstId()
選定におけるインスタンス番号を取得します。

戻り値:
instId 選定におけるインスタンス番号

getMatExt

public String getMatExt()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
matExt 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMatGuid

public String getMatGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
matGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMatVers

public String getMatVers()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
matVers 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getPMatExt

public String getPMatExt()
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
pMatExt 項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)

getPMatGuid

public String getPMatGuid()
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
pMatGuid 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)

getPMatVers

public String getPMatVers()
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
pMatVers 項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)

getFuncArea

public String getFuncArea()
機能領域を取得します。

戻り値:
funcArea 機能領域

getAlternBom

public String getAlternBom()
代替 BOMを取得します。

戻り値:
alternBom 代替 BOM

getFkkConacct

public String getFkkConacct()
長さ 12 の文字項目を取得します。

戻り値:
fkkConacct 長さ 12 の文字項目

getEanUpc

public String getEanUpc()
国際商品コード (EAN/UPC)を取得します。

戻り値:
eanUpc 国際商品コード (EAN/UPC)

getProdcat

public String getProdcat()
製品カタログ番号を取得します。

戻り値:
prodcat 製品カタログ番号

getShipType

public String getShipType()
出荷タイプを取得します。

戻り値:
shipType 出荷タイプ

getSProcInd

public String getSProcInd()
特別処理区分を取得します。

戻り値:
sProcInd 特別処理区分

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
funcAreaLong 機能領域

getBillRel

public String getBillRel()
請求関連 (CRM)を取得します。

戻り値:
billRel 請求関連 (CRM)

getVwUepos

public String getVwUepos()
上位レベル明細用途 IDを取得します。

戻り値:
vwUepos 上位レベル明細用途 ID

getCampaign

public String getCampaign()
総括プロジェクト計画: 外部 R/3 システムの GUIDを取得します。

戻り値:
campaign 総括プロジェクト計画: 外部 R/3 システムの GUID

getDlvschduse

public String getDlvschduse()
用途区分を取得します。

戻り値:
dlvschduse 用途区分

getCfopLong

public String getCfopLong()
CFOP code and extensionを取得します。

戻り値:
cfopLong CFOP code and extension

getSelection

public String getSelection()
選択 ID (永続)を取得します。

戻り値:
selection 選択 ID (永続)

getMatEntrd

public String getMatEntrd()
入力品目を取得します。

戻り値:
matEntrd 入力品目

getLogSystemOwn

public String getLogSystemOwn()
論理システムを取得します。

戻り値:
logSystemOwn 論理システム

getItmTypeUsage

public String getItmTypeUsage()
明細用途を取得します。

戻り値:
itmTypeUsage 明細用途

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setItmNumber

public void setItmNumber(String itmNumber)
販売伝票明細を設定します。

パラメータ:
itmNumber - 販売伝票明細

setHgLvItem

public void setHgLvItem(String hgLvItem)
上位レベル明細を設定します。

パラメータ:
hgLvItem - 上位レベル明細

setPoItmNo

public void setPoItmNo(String poItmNo)
元となる購買発注の明細番号を設定します。

パラメータ:
poItmNo - 元となる購買発注の明細番号

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setAltToItm

public void setAltToItm(String altToItm)
代替明細を設定します。

パラメータ:
altToItm - 代替明細

setCustMat22

public void setCustMat22(String custMat22)
得意先品目コード (無効)を設定します。

パラメータ:
custMat22 - 得意先品目コード (無効)

setBatch

public void setBatch(String batch)
ロット番号を設定します。

パラメータ:
batch - ロット番号

setDlvGroup

public void setDlvGroup(String dlvGroup)
出荷グループ (明細一括出荷)を設定します。

パラメータ:
dlvGroup - 出荷グループ (明細一括出荷)

setPartDlv

public void setPartDlv(String partDlv)
明細レベルの分納納入を設定します。

パラメータ:
partDlv - 明細レベルの分納納入

setReasonRej

public void setReasonRej(String reasonRej)
見積および受注の拒否理由を設定します。

パラメータ:
reasonRej - 見積および受注の拒否理由

setBillBlock

public void setBillBlock(String billBlock)
ブロックを設定します。

パラメータ:
billBlock - ブロック

setBillDate

public void setBillDate(String billDate)
請求索引および印刷に対する請求日を設定します。

パラメータ:
billDate - 請求索引および印刷に対する請求日

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setStoreLoc

public void setStoreLoc(String storeLoc)
保管場所を設定します。

パラメータ:
storeLoc - 保管場所

setTargetQty

public void setTargetQty(String targetQty)
目標数量（販売単位）を設定します。

パラメータ:
targetQty - 目標数量（販売単位）

setTargetQu

public void setTargetQu(String targetQu)
目標数量 (数量単位)を設定します。

パラメータ:
targetQu - 目標数量 (数量単位)

setTUnitIso

public void setTUnitIso(String tUnitIso)
目標数量単位 (ISO コード)を設定します。

パラメータ:
tUnitIso - 目標数量単位 (ISO コード)

setItemCateg

public void setItemCateg(String itemCateg)
明細カテゴリ (販売伝票)を設定します。

パラメータ:
itemCateg - 明細カテゴリ (販売伝票)

setShortText

public void setShortText(String shortText)
テキスト (短): 受注明細を設定します。

パラメータ:
shortText - テキスト (短): 受注明細

setPrcGroup1

public void setPrcGroup1(String prcGroup1)
品目グループ 1を設定します。

パラメータ:
prcGroup1 - 品目グループ 1

setPrcGroup2

public void setPrcGroup2(String prcGroup2)
品目グループ 2を設定します。

パラメータ:
prcGroup2 - 品目グループ 2

setPrcGroup3

public void setPrcGroup3(String prcGroup3)
品目グループ 3を設定します。

パラメータ:
prcGroup3 - 品目グループ 3

setPrcGroup4

public void setPrcGroup4(String prcGroup4)
品目グループ 4を設定します。

パラメータ:
prcGroup4 - 品目グループ 4

setPrcGroup5

public void setPrcGroup5(String prcGroup5)
品目グループ 5を設定します。

パラメータ:
prcGroup5 - 品目グループ 5

setProdHiera

public void setProdHiera(String prodHiera)
品目階層を設定します。

パラメータ:
prodHiera - 品目階層

setMatlGroup

public void setMatlGroup(String matlGroup)
品目グループを設定します。

パラメータ:
matlGroup - 品目グループ

setPurchNoC

public void setPurchNoC(String purchNoC)
出荷先発注番号を設定します。

パラメータ:
purchNoC - 出荷先発注番号

setPurchDate

public void setPurchDate(String purchDate)
得意先発注日付を設定します。

パラメータ:
purchDate - 得意先発注日付

setPoMethod

public void setPoMethod(String poMethod)
得意先発注タイプを設定します。

パラメータ:
poMethod - 得意先発注タイプ

setRef1

public void setRef1(String ref1)
得意先/仕入先の内部参照コードを設定します。

パラメータ:
ref1 - 得意先/仕入先の内部参照コード

setPurchNoS

public void setPurchNoS(String purchNoS)
出荷先の得意先発注番号を設定します。

パラメータ:
purchNoS - 出荷先の得意先発注番号

setPoDatS

public void setPoDatS(String poDatS)
出荷先の出荷先発注日付を設定します。

パラメータ:
poDatS - 出荷先の出荷先発注日付

setPoMethS

public void setPoMethS(String poMethS)
出荷先の出荷先発注タイプを設定します。

パラメータ:
poMethS - 出荷先の出荷先発注タイプ

setRef1S

public void setRef1S(String ref1S)
出荷先文字を設定します。

パラメータ:
ref1S - 出荷先文字

setPoitmNoS

public void setPoitmNoS(String poitmNoS)
元となる購買発注の明細番号を設定します。

パラメータ:
poitmNoS - 元となる購買発注の明細番号

setPriceGrp

public void setPriceGrp(String priceGrp)
価格グループ (得意先)を設定します。

パラメータ:
priceGrp - 価格グループ (得意先)

setCustGroup

public void setCustGroup(String custGroup)
得意先グループを設定します。

パラメータ:
custGroup - 得意先グループ

setSalesDist

public void setSalesDist(String salesDist)
販売地域を設定します。

パラメータ:
salesDist - 販売地域

setPriceList

public void setPriceList(String priceList)
価格表タイプを設定します。

パラメータ:
priceList - 価格表タイプ

setIncoterms1

public void setIncoterms1(String incoterms1)
インコタームズ (1)を設定します。

パラメータ:
incoterms1 - インコタームズ (1)

setIncoterms2

public void setIncoterms2(String incoterms2)
インコタームズ 2を設定します。

パラメータ:
incoterms2 - インコタームズ 2

setOrdcompIn

public void setOrdcompIn(String ordcompIn)
受注結合出荷区分を設定します。

パラメータ:
ordcompIn - 受注結合出荷区分

setBillSched

public void setBillSched(String billSched)
請求日程 (稼働日カレンダ指定)を設定します。

パラメータ:
billSched - 請求日程 (稼働日カレンダ指定)

setInvoSched

public void setInvoSched(String invoSched)
請求書一覧日程 (稼働日カレンダ指定)を設定します。

パラメータ:
invoSched - 請求書一覧日程 (稼働日カレンダ指定)

setMnInvoice

public void setMnInvoice(String mnInvoice)
マニュアル請求書更新を設定します。

パラメータ:
mnInvoice - マニュアル請求書更新

setExRateFi

public void setExRateFi(String exRateFi)
FI 転記の換算レート (直接相場)を設定します。

パラメータ:
exRateFi - FI 転記の換算レート (直接相場)

setAddValDy

public void setAddValDy(String addValDy)
有効日からの日数を設定します。

パラメータ:
addValDy - 有効日からの日数

setFixValDy

public void setFixValDy(String fixValDy)
有効日日付を設定します。

パラメータ:
fixValDy - 有効日日付

setPmnttrms

public void setPmnttrms(String pmnttrms)
支払条件キーを設定します。

パラメータ:
pmnttrms - 支払条件キー

setPymtMeth

public void setPymtMeth(String pymtMeth)
支払方法を設定します。

パラメータ:
pymtMeth - 支払方法

setAccntAsgn

public void setAccntAsgn(String accntAsgn)
得意先の勘定設定グループを設定します。

パラメータ:
accntAsgn - 得意先の勘定設定グループ

setExchgRate

public void setExchgRate(String exchgRate)
価格設定/統計の換算レート (直接引用)を設定します。

パラメータ:
exchgRate - 価格設定/統計の換算レート (直接引用)

setPriceDate

public void setPriceDate(String priceDate)
価格設定/外貨換算の実行日付を設定します。

パラメータ:
priceDate - 価格設定/外貨換算の実行日付

setServDate

public void setServDate(String servDate)
サービス提供日を設定します。

パラメータ:
servDate - サービス提供日

setDunnKey

public void setDunnKey(String dunnKey)
督促処理キーを設定します。

パラメータ:
dunnKey - 督促処理キー

setDunnBlock

public void setDunnBlock(String dunnBlock)
督促処理保留を設定します。

パラメータ:
dunnBlock - 督促処理保留

setPromotion

public void setPromotion(String promotion)
プロモーションを設定します。

パラメータ:
promotion - プロモーション

setPmtgarPro

public void setPmtgarPro(String pmtgarPro)
支払保証決定表を設定します。

パラメータ:
pmtgarPro - 支払保証決定表

setDocNumFi

public void setDocNumFi(String docNumFi)
ドキュメンタリクレジット処理: 内部番号を設定します。

パラメータ:
docNumFi - ドキュメンタリクレジット処理: 内部番号

setDepartmNo

public void setDepartmNo(String departmNo)
部門コードを設定します。

パラメータ:
departmNo - 部門コード

setRecPoint

public void setRecPoint(String recPoint)
入荷ポイントを設定します。

パラメータ:
recPoint - 入荷ポイント

setCstcndgrp1

public void setCstcndgrp1(String cstcndgrp1)
得意先条件グループ１を設定します。

パラメータ:
cstcndgrp1 - 得意先条件グループ１

setCstcndgrp2

public void setCstcndgrp2(String cstcndgrp2)
得意先条件グループ２を設定します。

パラメータ:
cstcndgrp2 - 得意先条件グループ２

setCstcndgrp3

public void setCstcndgrp3(String cstcndgrp3)
得意先条件グループ３を設定します。

パラメータ:
cstcndgrp3 - 得意先条件グループ３

setCstcndgrp4

public void setCstcndgrp4(String cstcndgrp4)
得意先条件グループ４を設定します。

パラメータ:
cstcndgrp4 - 得意先条件グループ４

setCstcndgrp5

public void setCstcndgrp5(String cstcndgrp5)
得意先条件グループ５を設定します。

パラメータ:
cstcndgrp5 - 得意先条件グループ５

setDlvTime

public void setDlvTime(String dlvTime)
契約出荷期間を設定します。

パラメータ:
dlvTime - 契約出荷期間

setSalesUnit

public void setSalesUnit(String salesUnit)
販売単位を設定します。

パラメータ:
salesUnit - 販売単位

setSUnitIso

public void setSUnitIso(String sUnitIso)
単位の ISO コードを設定します。

パラメータ:
sUnitIso - 単位の ISO コード

setTrgQtyNo

public void setTrgQtyNo(String trgQtyNo)
販売単位から基本単位への換算係数を設定します。

パラメータ:
trgQtyNo - 販売単位から基本単位への換算係数

setTrgqtyDen

public void setTrgqtyDen(String trgqtyDen)
販売単位から基本単位への換算係数を設定します。

パラメータ:
trgqtyDen - 販売単位から基本単位への換算係数

setRnddlvQty

public void setRnddlvQty(String rnddlvQty)
丸め数量: 出荷を設定します。

パラメータ:
rnddlvQty - 丸め数量: 出荷

setMaxdevamnt

public void setMaxdevamnt(String maxdevamnt)
数量に関する許容偏差 (絶対値)を設定します。

パラメータ:
maxdevamnt - 数量に関する許容偏差 (絶対値)

setMaxdevper

public void setMaxdevper(String maxdevper)
数量に関する許容偏差 (%)を設定します。

パラメータ:
maxdevper - 数量に関する許容偏差 (%)

setMaxdevDay

public void setMaxdevDay(String maxdevDay)
シフト所要日数を設定します。

パラメータ:
maxdevDay - シフト所要日数

setUsageInd

public void setUsageInd(String usageInd)
未使用 - 予約長 3を設定します。

パラメータ:
usageInd - 未使用 - 予約長 3

setFixedQuan

public void setFixedQuan(String fixedQuan)
数量固定区分を設定します。

パラメータ:
fixedQuan - 数量固定区分

setUnlmtDlv

public void setUnlmtDlv(String unlmtDlv)
区分: 無制限過剰納入可能を設定します。

パラメータ:
unlmtDlv - 区分: 無制限過剰納入可能

setOverdlvtol

public void setOverdlvtol(String overdlvtol)
過剰納入許容範囲を設定します。

パラメータ:
overdlvtol - 過剰納入許容範囲

setUnddlvTol

public void setUnddlvTol(String unddlvTol)
不足納入許容範囲リミットを設定します。

パラメータ:
unddlvTol - 不足納入許容範囲リミット

setDivision

public void setDivision(String division)
製品部門を設定します。

パラメータ:
division - 製品部門

setSalqtynum

public void setSalqtynum(String salqtynum)
販売数量単位から基本数量単位への変換係数の分子を設定します。

パラメータ:
salqtynum - 販売数量単位から基本数量単位への変換係数の分子

setSalqtyden

public void setSalqtyden(String salqtyden)
販売数量単位を SKU に換算するための分母 (除数)を設定します。

パラメータ:
salqtyden - 販売数量単位を SKU に換算するための分母 (除数)

setGrossWght

public void setGrossWght(String grossWght)
明細の総重量を設定します。

パラメータ:
grossWght - 明細の総重量

setNetWeight

public void setNetWeight(String netWeight)
明細の正味重量を設定します。

パラメータ:
netWeight - 明細の正味重量

setUntofWght

public void setUntofWght(String untofWght)
重量単位を設定します。

パラメータ:
untofWght - 重量単位

setUnofWtiso

public void setUnofWtiso(String unofWtiso)
ISO コードでの重量単位を設定します。

パラメータ:
unofWtiso - ISO コードでの重量単位

setVolume

public void setVolume(String volume)
明細の総数量を設定します。

パラメータ:
volume - 明細の総数量

setVolunit

public void setVolunit(String volunit)
容積単位を設定します。

パラメータ:
volunit - 容積単位

setVolunitiso

public void setVolunitiso(String volunitiso)
ISO コードでの容積単位を設定します。

パラメータ:
volunitiso - ISO コードでの容積単位

setDlvPrio

public void setDlvPrio(String dlvPrio)
出荷優先順位を設定します。

パラメータ:
dlvPrio - 出荷優先順位

setShipPoint

public void setShipPoint(String shipPoint)
出荷ポイント/入荷ポイントを設定します。

パラメータ:
shipPoint - 出荷ポイント/入荷ポイント

setRoute

public void setRoute(String route)
輸送経路を設定します。

パラメータ:
route - 輸送経路

setCreatedBy

public void setCreatedBy(String createdBy)
オブジェクト登録者名を設定します。

パラメータ:
createdBy - オブジェクト登録者名

setTaxClass1

public void setTaxClass1(String taxClass1)
品目の税分類を設定します。

パラメータ:
taxClass1 - 品目の税分類

setTaxClass2

public void setTaxClass2(String taxClass2)
品目の税分類を設定します。

パラメータ:
taxClass2 - 品目の税分類

setTaxClass3

public void setTaxClass3(String taxClass3)
品目の税分類を設定します。

パラメータ:
taxClass3 - 品目の税分類

setTaxClass4

public void setTaxClass4(String taxClass4)
品目の税分類を設定します。

パラメータ:
taxClass4 - 品目の税分類

setTaxClass5

public void setTaxClass5(String taxClass5)
品目の税分類を設定します。

パラメータ:
taxClass5 - 品目の税分類

setTaxClass6

public void setTaxClass6(String taxClass6)
品目の税分類を設定します。

パラメータ:
taxClass6 - 品目の税分類

setTaxClass7

public void setTaxClass7(String taxClass7)
品目の税分類を設定します。

パラメータ:
taxClass7 - 品目の税分類

setTaxClass8

public void setTaxClass8(String taxClass8)
品目の税分類を設定します。

パラメータ:
taxClass8 - 品目の税分類

setTaxClass9

public void setTaxClass9(String taxClass9)
品目の税分類を設定します。

パラメータ:
taxClass9 - 品目の税分類

setMatPrGrp

public void setMatPrGrp(String matPrGrp)
品目価格設定グループを設定します。

パラメータ:
matPrGrp - 品目価格設定グループ

setValType

public void setValType(String valType)
評価タイプを設定します。

パラメータ:
valType - 評価タイプ

setFixdatQty

public void setFixdatQty(String fixdatQty)
納期と出荷数量の固定を設定します。

パラメータ:
fixdatQty - 納期と出荷数量の固定

setBomexplNo

public void setBomexplNo(String bomexplNo)
BOM 展開番号を設定します。

パラメータ:
bomexplNo - BOM 展開番号

setResanalkey

public void setResanalkey(String resanalkey)
結果分析キーを設定します。

パラメータ:
resanalkey - 結果分析キー

setReqmtsTyp

public void setReqmtsTyp(String reqmtsTyp)
所要量タイプを設定します。

パラメータ:
reqmtsTyp - 所要量タイプ

setNoGrPost

public void setNoGrPost(String noGrPost)
得意先が入庫を転記していませんを設定します。

パラメータ:
noGrPost - 得意先が入庫を転記していません

setBusTranst

public void setBusTranst(String busTranst)
貿易管理の取引タイプを設定します。

パラメータ:
busTranst - 貿易管理の取引タイプ

setOverhdKey

public void setOverhdKey(String overhdKey)
間接費キーを設定します。

パラメータ:
overhdKey - 間接費キー

setCstgSheet

public void setCstgSheet(String cstgSheet)
原価計算表を設定します。

パラメータ:
cstgSheet - 原価計算表

setMatfrgtgrp

public void setMatfrgtgrp(String matfrgtgrp)
品目運賃グループを設定します。

パラメータ:
matfrgtgrp - 品目運賃グループ

setPldlvshdin

public void setPldlvshdin(String pldlvshdin)
出荷計画に関する指示を設定します。

パラメータ:
pldlvshdin - 出荷計画に関する指示

setSeqNo

public void setSeqNo(String seqNo)
KANBAN/連続番号を設定します。

パラメータ:
seqNo - KANBAN/連続番号

setBilForm

public void setBilForm(String bilForm)
請求書式を設定します。

パラメータ:
bilForm - 請求書式

setDliProfil

public void setDliProfil(String dliProfil)
動的明細プロセッサプロファイルを設定します。

パラメータ:
dliProfil - 動的明細プロセッサプロファイル

setRevType

public void setRevType(String revType)
収益承認カテゴリを設定します。

パラメータ:
revType - 収益承認カテゴリ

setBegdemPer

public void setBegdemPer(String begdemPer)
見越期間の提案開始日付を設定します。

パラメータ:
begdemPer - 見越期間の提案開始日付

setPrRefMat

public void setPrRefMat(String prRefMat)
価格設定参照品目を設定します。

パラメータ:
prRefMat - 価格設定参照品目

setRefobjtype

public void setRefobjtype(String refobjtype)
オブジェクトタイプを設定します。

パラメータ:
refobjtype - オブジェクトタイプ

setRefobjkey

public void setRefobjkey(String refobjkey)
オブジェクトキーを設定します。

パラメータ:
refobjkey - オブジェクトキー

setReflogsys

public void setReflogsys(String reflogsys)
論理システムを設定します。

パラメータ:
reflogsys - 論理システム

setOrderProb

public void setOrderProb(String orderProb)
明細の受注可能性を設定します。

パラメータ:
orderProb - 明細の受注可能性

setMaxPlDlv

public void setMaxPlDlv(String maxPlDlv)
明細ごとの分割納入可能な最大回数を設定します。

パラメータ:
maxPlDlv - 明細ごとの分割納入可能な最大回数

setCfopCode

public void setCfopCode(String cfopCode)
CFOP code and extension (old 5 char version)を設定します。

パラメータ:
cfopCode - CFOP code and extension (old 5 char version)

setTaxlawicms

public void setTaxlawicms(String taxlawicms)
税法: ICMSを設定します。

パラメータ:
taxlawicms - 税法: ICMS

setTaxlawipi

public void setTaxlawipi(String taxlawipi)
税法: IPIを設定します。

パラメータ:
taxlawipi - 税法: IPI

setSdTaxcode

public void setSdTaxcode(String sdTaxcode)
0を設定します。

パラメータ:
sdTaxcode - 0

setAssortMod

public void setAssortMod(String assortMod)
品揃モジュールを設定します。

パラメータ:
assortMod - 品揃モジュール

setCompQuant

public void setCompQuant(String compQuant)
構成品目数量を設定します。

パラメータ:
compQuant - 構成品目数量

setTargetVal

public void setTargetVal(String targetVal)
BAPI の通貨額 (小数点以下９桁)を設定します。

パラメータ:
targetVal - BAPI の通貨額 (小数点以下９桁)

setCurrency

public void setCurrency(String currency)
販売伝票通貨を設定します。

パラメータ:
currency - 販売伝票通貨

setCurrIso

public void setCurrIso(String currIso)
ISO コード通貨を設定します。

パラメータ:
currIso - ISO コード通貨

setProfitCtr

public void setProfitCtr(String profitCtr)
利益センタを設定します。

パラメータ:
profitCtr - 利益センタ

setOrderid

public void setOrderid(String orderid)
指図番号を設定します。

パラメータ:
orderid - 指図番号

setWbsElem

public void setWbsElem(String wbsElem)
WBS 要素を設定します。

パラメータ:
wbsElem - WBS 要素

setDeprecPer

public void setDeprecPer(String deprecPer)
ドキュメンタリクレジット処理に関する償却率 (%)を設定します。

パラメータ:
deprecPer - ドキュメンタリクレジット処理に関する償却率 (%)

setRefDoc

public void setRefDoc(String refDoc)
参照伝票番号を設定します。

パラメータ:
refDoc - 参照伝票番号

setRefDocIt

public void setRefDocIt(String refDocIt)
参照明細番号を設定します。

パラメータ:
refDocIt - 参照明細番号

setRefDocCa

public void setRefDocCa(String refDocCa)
先行販売管理伝票の伝票カテゴリを設定します。

パラメータ:
refDocCa - 先行販売管理伝票の伝票カテゴリ

setCustMat35

public void setCustMat35(String custMat35)
得意先品目を設定します。

パラメータ:
custMat35 - 得意先品目

setExchRateFiV

public void setExchRateFiV(String exchRateFiV)
FI 転記の換算レート (間接相場)を設定します。

パラメータ:
exchRateFiV - FI 転記の換算レート (間接相場)

setExchgRateV

public void setExchgRateV(String exchgRateV)
価格設定/統計の換算レート (間接引用)を設定します。

パラメータ:
exchgRateV - 価格設定/統計の換算レート (間接引用)

setItemguidAtp

public void setItemguidAtp(String itemguidAtp)
ATP: 暗号 - DELNR および DELPSを設定します。

パラメータ:
itemguidAtp - ATP: 暗号 - DELNR および DELPS

setValContr

public void setValContr(String valContr)
金額契約番号を設定します。

パラメータ:
valContr - 金額契約番号

setValConI

public void setValConI(String valConI)
金額契約明細を設定します。

パラメータ:
valConI - 金額契約明細

setConfigId

public void setConfigId(String configId)
外部選定 ID (仮)を設定します。

パラメータ:
configId - 外部選定 ID (仮)

setInstId

public void setInstId(String instId)
選定におけるインスタンス番号を設定します。

パラメータ:
instId - 選定におけるインスタンス番号

setMatExt

public void setMatExt(String matExt)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
matExt - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMatGuid

public void setMatGuid(String matGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
matGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMatVers

public void setMatVers(String matVers)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
matVers - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setPMatExt

public void setPMatExt(String pMatExt)
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
pMatExt - 項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)

setPMatGuid

public void setPMatGuid(String pMatGuid)
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
pMatGuid - 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)

setPMatVers

public void setPMatVers(String pMatVers)
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
pMatVers - 項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)

setFuncArea

public void setFuncArea(String funcArea)
機能領域を設定します。

パラメータ:
funcArea - 機能領域

setAlternBom

public void setAlternBom(String alternBom)
代替 BOMを設定します。

パラメータ:
alternBom - 代替 BOM

setFkkConacct

public void setFkkConacct(String fkkConacct)
長さ 12 の文字項目を設定します。

パラメータ:
fkkConacct - 長さ 12 の文字項目

setEanUpc

public void setEanUpc(String eanUpc)
国際商品コード (EAN/UPC)を設定します。

パラメータ:
eanUpc - 国際商品コード (EAN/UPC)

setProdcat

public void setProdcat(String prodcat)
製品カタログ番号を設定します。

パラメータ:
prodcat - 製品カタログ番号

setShipType

public void setShipType(String shipType)
出荷タイプを設定します。

パラメータ:
shipType - 出荷タイプ

setSProcInd

public void setSProcInd(String sProcInd)
特別処理区分を設定します。

パラメータ:
sProcInd - 特別処理区分

setFuncAreaLong

public void setFuncAreaLong(String funcAreaLong)
機能領域を設定します。

パラメータ:
funcAreaLong - 機能領域

setBillRel

public void setBillRel(String billRel)
請求関連 (CRM)を設定します。

パラメータ:
billRel - 請求関連 (CRM)

setVwUepos

public void setVwUepos(String vwUepos)
上位レベル明細用途 IDを設定します。

パラメータ:
vwUepos - 上位レベル明細用途 ID

setCampaign

public void setCampaign(String campaign)
総括プロジェクト計画: 外部 R/3 システムの GUIDを設定します。

パラメータ:
campaign - 総括プロジェクト計画: 外部 R/3 システムの GUID

setDlvschduse

public void setDlvschduse(String dlvschduse)
用途区分を設定します。

パラメータ:
dlvschduse - 用途区分

setCfopLong

public void setCfopLong(String cfopLong)
CFOP code and extensionを設定します。

パラメータ:
cfopLong - CFOP code and extension

setSelection

public void setSelection(String selection)
選択 ID (永続)を設定します。

パラメータ:
selection - 選択 ID (永続)

setMatEntrd

public void setMatEntrd(String matEntrd)
入力品目を設定します。

パラメータ:
matEntrd - 入力品目

setLogSystemOwn

public void setLogSystemOwn(String logSystemOwn)
論理システムを設定します。

パラメータ:
logSystemOwn - 論理システム

setItmTypeUsage

public void setItmTypeUsage(String itmTypeUsage)
明細用途を設定します。

パラメータ:
itmTypeUsage - 明細用途

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ItemsInX (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ItemsInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX
すべての実装インタフェース:
Serializable
public class ItemsInX
extends Object
implements Serializable

明細データチェックボックス情報クラス
機能は以下の通り

  • 明細データチェックボックス情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ItemsInX()
明細データチェックボックス情報を作成します。
ItemsInX(int index)
明細データチェックボックス情報を作成します。
メソッドの概要
String | getAccntAsgn() 関連ユーザデータ項目の更新情報を取得します。
String | getAddValDy() 関連ユーザデータ項目の更新情報を取得します。
String | getAlternBom() 関連ユーザデータ項目の更新情報を取得します。
String | getAltToItm() 関連ユーザデータ項目の更新情報を取得します。
String | getAssortMod() 関連ユーザデータ項目の更新情報を取得します。
String | getBatch() 関連ユーザデータ項目の更新情報を取得します。
String | getBegdemPer() 関連ユーザデータ項目の更新情報を取得します。
String | getBilForm() 関連ユーザデータ項目の更新情報を取得します。
String | getBillBlock() 関連ユーザデータ項目の更新情報を取得します。
String | getBillDate() 関連ユーザデータ項目の更新情報を取得します。
String | getBillRel() 関連ユーザデータ項目の更新情報を取得します。
String | getBillSched() 関連ユーザデータ項目の更新情報を取得します。
String | getBomexplNo() 関連ユーザデータ項目の更新情報を取得します。
String | getBusTranst() 関連ユーザデータ項目の更新情報を取得します。
String | getCampaign() 関連ユーザデータ項目の更新情報を取得します。
String | getCfopCode() 関連ユーザデータ項目の更新情報を取得します。
String | getCompQuant() 関連ユーザデータ項目の更新情報を取得します。
String | getConfigId() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp1() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp2() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp3() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp4() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp5() 関連ユーザデータ項目の更新情報を取得します。
String | getCstgSheet() 関連ユーザデータ項目の更新情報を取得します。
String | getCustGroup() 関連ユーザデータ項目の更新情報を取得します。
String | getCustMat22() 関連ユーザデータ項目の更新情報を取得します。
String | getCustMat35() 関連ユーザデータ項目の更新情報を取得します。
String | getDepartmNo() 関連ユーザデータ項目の更新情報を取得します。
String | getDeprecPer() 関連ユーザデータ項目の更新情報を取得します。
String | getDivision() 関連ユーザデータ項目の更新情報を取得します。
String | getDliProfil() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvGroup() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvPrio() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvschduse() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvTime() 関連ユーザデータ項目の更新情報を取得します。
String | getDocNumFi() 関連ユーザデータ項目の更新情報を取得します。
String | getDunnBlock() 関連ユーザデータ項目の更新情報を取得します。
String | getDunnKey() 関連ユーザデータ項目の更新情報を取得します。
String | getEanUpc() 関連ユーザデータ項目の更新情報を取得します。
String | getExchgRate() 関連ユーザデータ項目の更新情報を取得します。
String | getExchgRateV() 関連ユーザデータ項目の更新情報を取得します。
String | getExchRateFiV() 関連ユーザデータ項目の更新情報を取得します。
String | getExRateFi() 関連ユーザデータ項目の更新情報を取得します。
String | getFixdatQty() 関連ユーザデータ項目の更新情報を取得します。
String | getFixedQuan() 関連ユーザデータ項目の更新情報を取得します。
String | getFixValDy() 関連ユーザデータ項目の更新情報を取得します。
String | getFkkConacct() 関連ユーザデータ項目の更新情報を取得します。
String | getFuncArea() 関連ユーザデータ項目の更新情報を取得します。
String | getGrossWght() 関連ユーザデータ項目の更新情報を取得します。
String | getHgLvItem() 関連ユーザデータ項目の更新情報を取得します。
String | getIncoterms1() 関連ユーザデータ項目の更新情報を取得します。
String | getIncoterms2() 関連ユーザデータ項目の更新情報を取得します。
int | getIndex() レコード番号を取得します｡
String | getInstId() 関連ユーザデータ項目の更新情報を取得します。
String | getInvoSched() 関連ユーザデータ項目の更新情報を取得します。
String | getItemCateg() 関連ユーザデータ項目の更新情報を取得します。
String | getItemguidAtp() 関連ユーザデータ項目の更新情報を取得します。
String | getItmNumber() 販売伝票明細を取得します。
String | getItmTypeUsage() 関連ユーザデータ項目の更新情報を取得します。
String | getLogSystemOwn() 関連ユーザデータ項目の更新情報を取得します。
String | getMatEntrd() 関連ユーザデータ項目の更新情報を取得します。
String | getMaterial() 関連ユーザデータ項目の更新情報を取得します。
String | getMatExt() 関連ユーザデータ項目の更新情報を取得します。
String | getMatfrgtgrp() 関連ユーザデータ項目の更新情報を取得します。
String | getMatGuid() 関連ユーザデータ項目の更新情報を取得します。
String | getMatlGroup() 関連ユーザデータ項目の更新情報を取得します。
String | getMatPrGrp() 関連ユーザデータ項目の更新情報を取得します。
String | getMatVers() 関連ユーザデータ項目の更新情報を取得します。
String | getMaxdevamnt() 関連ユーザデータ項目の更新情報を取得します。
String | getMaxdevDay() 関連ユーザデータ項目の更新情報を取得します。
String | getMaxdevper() 関連ユーザデータ項目の更新情報を取得します。
String | getMaxPlDlv() 関連ユーザデータ項目の更新情報を取得します。
String | getMnInvoice() 関連ユーザデータ項目の更新情報を取得します。
String | getNetWeight() 関連ユーザデータ項目の更新情報を取得します。
String | getNoGrPost() 関連ユーザデータ項目の更新情報を取得します。
String | getOrdcompIn() 関連ユーザデータ項目の更新情報を取得します。
String | getOrderid() 関連ユーザデータ項目の更新情報を取得します。
String | getOrderProb() 関連ユーザデータ項目の更新情報を取得します。
String | getOverdlvtol() 関連ユーザデータ項目の更新情報を取得します。
String | getOverhdKey() 関連ユーザデータ項目の更新情報を取得します。
String | getPartDlv() 関連ユーザデータ項目の更新情報を取得します。
String | getPlant() 関連ユーザデータ項目の更新情報を取得します。
String | getPldlvshdin() 関連ユーザデータ項目の更新情報を取得します。
String | getPMatExt() 関連ユーザデータ項目の更新情報を取得します。
String | getPMatGuid() 関連ユーザデータ項目の更新情報を取得します。
String | getPMatVers() 関連ユーザデータ項目の更新情報を取得します。
String | getPmnttrms() 関連ユーザデータ項目の更新情報を取得します。
String | getPmtgarPro() 関連ユーザデータ項目の更新情報を取得します。
String | getPoDatS() 関連ユーザデータ項目の更新情報を取得します。
String | getPoItmNo() 関連ユーザデータ項目の更新情報を取得します。
String | getPoitmNoS() 関連ユーザデータ項目の更新情報を取得します。
String | getPoMethod() 関連ユーザデータ項目の更新情報を取得します。
String | getPoMethS() 関連ユーザデータ項目の更新情報を取得します。
String | getPrcGroup1() 関連ユーザデータ項目の更新情報を取得します。
String | getPrcGroup2() 関連ユーザデータ項目の更新情報を取得します。
String | getPrcGroup3() 関連ユーザデータ項目の更新情報を取得します。
String | getPrcGroup4() 関連ユーザデータ項目の更新情報を取得します。
String | getPrcGroup5() 関連ユーザデータ項目の更新情報を取得します。
String | getPriceDate() 関連ユーザデータ項目の更新情報を取得します。
String | getPriceGrp() 関連ユーザデータ項目の更新情報を取得します。
String | getPriceList() 関連ユーザデータ項目の更新情報を取得します。
String | getProdcat() 関連ユーザデータ項目の更新情報を取得します。
String | getProdHiera() 関連ユーザデータ項目の更新情報を取得します。
String | getProfitCtr() 関連ユーザデータ項目の更新情報を取得します。
String | getPromotion() 関連ユーザデータ項目の更新情報を取得します。
String | getPrRefMat() 関連ユーザデータ項目の更新情報を取得します。
String | getPurchDate() 関連ユーザデータ項目の更新情報を取得します。
String | getPurchNoC() 関連ユーザデータ項目の更新情報を取得します。
String | getPurchNoS() 関連ユーザデータ項目の更新情報を取得します。
String | getPymtMeth() 関連ユーザデータ項目の更新情報を取得します。
String | getReasonRej() 関連ユーザデータ項目の更新情報を取得します。
String | getRecPoint() 関連ユーザデータ項目の更新情報を取得します。
String | getRef1() 関連ユーザデータ項目の更新情報を取得します。
String | getRef1S() 関連ユーザデータ項目の更新情報を取得します。
String | getRefDoc() 関連ユーザデータ項目の更新情報を取得します。
String | getRefDocCa() 関連ユーザデータ項目の更新情報を取得します。
String | getRefDocIt() 関連ユーザデータ項目の更新情報を取得します。
String | getReflogsys() 関連ユーザデータ項目の更新情報を取得します。
String | getRefobjkey() 関連ユーザデータ項目の更新情報を取得します。
String | getRefobjtype() 関連ユーザデータ項目の更新情報を取得します。
String | getReqmtsTyp() 関連ユーザデータ項目の更新情報を取得します。
String | getResanalkey() 関連ユーザデータ項目の更新情報を取得します。
String | getRevType() 関連ユーザデータ項目の更新情報を取得します。
String | getRnddlvQty() 関連ユーザデータ項目の更新情報を取得します。
String | getRoute() 関連ユーザデータ項目の更新情報を取得します。
String | getSalesDist() 関連ユーザデータ項目の更新情報を取得します。
String | getSalesUnit() 関連ユーザデータ項目の更新情報を取得します。
String | getSalqtyden() 関連ユーザデータ項目の更新情報を取得します。
String | getSalqtynum() 関連ユーザデータ項目の更新情報を取得します。
String | getSdTaxcode() 関連ユーザデータ項目の更新情報を取得します。
String | getSelection() 関連ユーザデータ項目の更新情報を取得します。
String | getSeqNo() 関連ユーザデータ項目の更新情報を取得します。
String | getServDate() 関連ユーザデータ項目の更新情報を取得します。
String | getShipPoint() 関連ユーザデータ項目の更新情報を取得します。
String | getShipType() 関連ユーザデータ項目の更新情報を取得します。
String | getShortText() 関連ユーザデータ項目の更新情報を取得します。
String | getSProcInd() 関連ユーザデータ項目の更新情報を取得します。
String | getStoreLoc() 関連ユーザデータ項目の更新情報を取得します。
String | getTargetQty() 関連ユーザデータ項目の更新情報を取得します。
String | getTargetQu() 関連ユーザデータ項目の更新情報を取得します。
String | getTargetVal() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass1() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass2() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass3() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass4() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass5() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass6() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass7() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass8() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass9() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxlawicms() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxlawipi() 関連ユーザデータ項目の更新情報を取得します。
String | getTrgqtyDen() 関連ユーザデータ項目の更新情報を取得します。
String | getTrgQtyNo() 関連ユーザデータ項目の更新情報を取得します。
String | getTUnitIso() 関連ユーザデータ項目の更新情報を取得します。
String | getUnddlvTol() 関連ユーザデータ項目の更新情報を取得します。
String | getUnlmtDlv() 関連ユーザデータ項目の更新情報を取得します。
String | getUntofWght() 関連ユーザデータ項目の更新情報を取得します。
String | getUpdateflag() 更新区分を取得します。
String | getUsageInd() 関連ユーザデータ項目の更新情報を取得します。
String | getValConI() 関連ユーザデータ項目の更新情報を取得します。
String | getValContr() 関連ユーザデータ項目の更新情報を取得します。
String | getValType() 関連ユーザデータ項目の更新情報を取得します。
String | getVolume() 関連ユーザデータ項目の更新情報を取得します。
String | getVolunit() 関連ユーザデータ項目の更新情報を取得します。
String | getVwUepos() 関連ユーザデータ項目の更新情報を取得します。
String | getWbsElem() 関連ユーザデータ項目の更新情報を取得します。
void | setAccntAsgn(String accntAsgn) 関連ユーザデータ項目の更新情報を設定します。
void | setAddValDy(String addValDy) 関連ユーザデータ項目の更新情報を設定します。
void | setAlternBom(String alternBom) 関連ユーザデータ項目の更新情報を設定します。
void | setAltToItm(String altToItm) 関連ユーザデータ項目の更新情報を設定します。
void | setAssortMod(String assortMod) 関連ユーザデータ項目の更新情報を設定します。
void | setBatch(String batch) 関連ユーザデータ項目の更新情報を設定します。
void | setBegdemPer(String begdemPer) 関連ユーザデータ項目の更新情報を設定します。
void | setBilForm(String bilForm) 関連ユーザデータ項目の更新情報を設定します。
void | setBillBlock(String billBlock) 関連ユーザデータ項目の更新情報を設定します。
void | setBillDate(String billDate) 関連ユーザデータ項目の更新情報を設定します。
void | setBillRel(String billRel) 関連ユーザデータ項目の更新情報を設定します。
void | setBillSched(String billSched) 関連ユーザデータ項目の更新情報を設定します。
void | setBomexplNo(String bomexplNo) 関連ユーザデータ項目の更新情報を設定します。
void | setBusTranst(String busTranst) 関連ユーザデータ項目の更新情報を設定します。
void | setCampaign(String campaign) 関連ユーザデータ項目の更新情報を設定します。
void | setCfopCode(String cfopCode) 関連ユーザデータ項目の更新情報を設定します。
void | setCompQuant(String compQuant) 関連ユーザデータ項目の更新情報を設定します。
void | setConfigId(String configId) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp1(String cstcndgrp1) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp2(String cstcndgrp2) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp3(String cstcndgrp3) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp4(String cstcndgrp4) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp5(String cstcndgrp5) 関連ユーザデータ項目の更新情報を設定します。
void | setCstgSheet(String cstgSheet) 関連ユーザデータ項目の更新情報を設定します。
void | setCustGroup(String custGroup) 関連ユーザデータ項目の更新情報を設定します。
void | setCustMat22(String custMat22) 関連ユーザデータ項目の更新情報を設定します。
void | setCustMat35(String custMat35) 関連ユーザデータ項目の更新情報を設定します。
void | setDepartmNo(String departmNo) 関連ユーザデータ項目の更新情報を設定します。
void | setDeprecPer(String deprecPer) 関連ユーザデータ項目の更新情報を設定します。
void | setDivision(String division) 関連ユーザデータ項目の更新情報を設定します。
void | setDliProfil(String dliProfil) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvGroup(String dlvGroup) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvPrio(String dlvPrio) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvschduse(String dlvschduse) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvTime(String dlvTime) 関連ユーザデータ項目の更新情報を設定します。
void | setDocNumFi(String docNumFi) 関連ユーザデータ項目の更新情報を設定します。
void | setDunnBlock(String dunnBlock) 関連ユーザデータ項目の更新情報を設定します。
void | setDunnKey(String dunnKey) 関連ユーザデータ項目の更新情報を設定します。
void | setEanUpc(String eanUpc) 関連ユーザデータ項目の更新情報を設定します。
void | setExchgRate(String exchgRate) 関連ユーザデータ項目の更新情報を設定します。
void | setExchgRateV(String exchgRateV) 関連ユーザデータ項目の更新情報を設定します。
void | setExchRateFiV(String exchRateFiV) 関連ユーザデータ項目の更新情報を設定します。
void | setExRateFi(String exRateFi) 関連ユーザデータ項目の更新情報を設定します。
void | setFixdatQty(String fixdatQty) 関連ユーザデータ項目の更新情報を設定します。
void | setFixedQuan(String fixedQuan) 関連ユーザデータ項目の更新情報を設定します。
void | setFixValDy(String fixValDy) 関連ユーザデータ項目の更新情報を設定します。
void | setFkkConacct(String fkkConacct) 関連ユーザデータ項目の更新情報を設定します。
void | setFuncArea(String funcArea) 関連ユーザデータ項目の更新情報を設定します。
void | setGrossWght(String grossWght) 関連ユーザデータ項目の更新情報を設定します。
void | setHgLvItem(String hgLvItem) 関連ユーザデータ項目の更新情報を設定します。
void | setIncoterms1(String incoterms1) 関連ユーザデータ項目の更新情報を設定します。
void | setIncoterms2(String incoterms2) 関連ユーザデータ項目の更新情報を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setInstId(String instId) 関連ユーザデータ項目の更新情報を設定します。
void | setInvoSched(String invoSched) 関連ユーザデータ項目の更新情報を設定します。
void | setItemCateg(String itemCateg) 関連ユーザデータ項目の更新情報を設定します。
void | setItemguidAtp(String itemguidAtp) 関連ユーザデータ項目の更新情報を設定します。
void | setItmNumber(String itmNumber) 販売伝票明細を設定します。
void | setItmTypeUsage(String itmTypeUsage) 関連ユーザデータ項目の更新情報を設定します。
void | setLogSystemOwn(String logSystemOwn) 関連ユーザデータ項目の更新情報を設定します。
void | setMatEntrd(String matEntrd) 関連ユーザデータ項目の更新情報を設定します。
void | setMaterial(String material) 関連ユーザデータ項目の更新情報を設定します。
void | setMatExt(String matExt) 関連ユーザデータ項目の更新情報を設定します。
void | setMatfrgtgrp(String matfrgtgrp) 関連ユーザデータ項目の更新情報を設定します。
void | setMatGuid(String matGuid) 関連ユーザデータ項目の更新情報を設定します。
void | setMatlGroup(String matlGroup) 関連ユーザデータ項目の更新情報を設定します。
void | setMatPrGrp(String matPrGrp) 関連ユーザデータ項目の更新情報を設定します。
void | setMatVers(String matVers) 関連ユーザデータ項目の更新情報を設定します。
void | setMaxdevamnt(String maxdevamnt) 関連ユーザデータ項目の更新情報を設定します。
void | setMaxdevDay(String maxdevDay) 関連ユーザデータ項目の更新情報を設定します。
void | setMaxdevper(String maxdevper) 関連ユーザデータ項目の更新情報を設定します。
void | setMaxPlDlv(String maxPlDlv) 関連ユーザデータ項目の更新情報を設定します。
void | setMnInvoice(String mnInvoice) 関連ユーザデータ項目の更新情報を設定します。
void | setNetWeight(String netWeight) 関連ユーザデータ項目の更新情報を設定します。
void | setNoGrPost(String noGrPost) 関連ユーザデータ項目の更新情報を設定します。
void | setOrdcompIn(String ordcompIn) 関連ユーザデータ項目の更新情報を設定します。
void | setOrderid(String orderid) 関連ユーザデータ項目の更新情報を設定します。
void | setOrderProb(String orderProb) 関連ユーザデータ項目の更新情報を設定します。
void | setOverdlvtol(String overdlvtol) 関連ユーザデータ項目の更新情報を設定します。
void | setOverhdKey(String overhdKey) 関連ユーザデータ項目の更新情報を設定します。
void | setPartDlv(String partDlv) 関連ユーザデータ項目の更新情報を設定します。
void | setPlant(String plant) 関連ユーザデータ項目の更新情報を設定します。
void | setPldlvshdin(String pldlvshdin) 関連ユーザデータ項目の更新情報を設定します。
void | setPMatExt(String pMatExt) 関連ユーザデータ項目の更新情報を設定します。
void | setPMatGuid(String pMatGuid) 関連ユーザデータ項目の更新情報を設定します。
void | setPMatVers(String pMatVers) 関連ユーザデータ項目の更新情報を設定します。
void | setPmnttrms(String pmnttrms) 関連ユーザデータ項目の更新情報を設定します。
void | setPmtgarPro(String pmtgarPro) 関連ユーザデータ項目の更新情報を設定します。
void | setPoDatS(String poDatS) 関連ユーザデータ項目の更新情報を設定します。
void | setPoItmNo(String poItmNo) 関連ユーザデータ項目の更新情報を設定します。
void | setPoitmNoS(String poitmNoS) 関連ユーザデータ項目の更新情報を設定します。
void | setPoMethod(String poMethod) 関連ユーザデータ項目の更新情報を設定します。
void | setPoMethS(String poMethS) 関連ユーザデータ項目の更新情報を設定します。
void | setPrcGroup1(String prcGroup1) 関連ユーザデータ項目の更新情報を設定します。
void | setPrcGroup2(String prcGroup2) 関連ユーザデータ項目の更新情報を設定します。
void | setPrcGroup3(String prcGroup3) 関連ユーザデータ項目の更新情報を設定します。
void | setPrcGroup4(String prcGroup4) 関連ユーザデータ項目の更新情報を設定します。
void | setPrcGroup5(String prcGroup5) 関連ユーザデータ項目の更新情報を設定します。
void | setPriceDate(String priceDate) 関連ユーザデータ項目の更新情報を設定します。
void | setPriceGrp(String priceGrp) 関連ユーザデータ項目の更新情報を設定します。
void | setPriceList(String priceList) 関連ユーザデータ項目の更新情報を設定します。
void | setProdcat(String prodcat) 関連ユーザデータ項目の更新情報を設定します。
void | setProdHiera(String prodHiera) 関連ユーザデータ項目の更新情報を設定します。
void | setProfitCtr(String profitCtr) 関連ユーザデータ項目の更新情報を設定します。
void | setPromotion(String promotion) 関連ユーザデータ項目の更新情報を設定します。
void | setPrRefMat(String prRefMat) 関連ユーザデータ項目の更新情報を設定します。
void | setPurchDate(String purchDate) 関連ユーザデータ項目の更新情報を設定します。
void | setPurchNoC(String purchNoC) 関連ユーザデータ項目の更新情報を設定します。
void | setPurchNoS(String purchNoS) 関連ユーザデータ項目の更新情報を設定します。
void | setPymtMeth(String pymtMeth) 関連ユーザデータ項目の更新情報を設定します。
void | setReasonRej(String reasonRej) 関連ユーザデータ項目の更新情報を設定します。
void | setRecPoint(String recPoint) 関連ユーザデータ項目の更新情報を設定します。
void | setRef1(String ref1) 関連ユーザデータ項目の更新情報を設定します。
void | setRef1S(String ref1S) 関連ユーザデータ項目の更新情報を設定します。
void | setRefDoc(String refDoc) 関連ユーザデータ項目の更新情報を設定します。
void | setRefDocCa(String refDocCa) 関連ユーザデータ項目の更新情報を設定します。
void | setRefDocIt(String refDocIt) 関連ユーザデータ項目の更新情報を設定します。
void | setReflogsys(String reflogsys) 関連ユーザデータ項目の更新情報を設定します。
void | setRefobjkey(String refobjkey) 関連ユーザデータ項目の更新情報を設定します。
void | setRefobjtype(String refobjtype) 関連ユーザデータ項目の更新情報を設定します。
void | setReqmtsTyp(String reqmtsTyp) 関連ユーザデータ項目の更新情報を設定します。
void | setResanalkey(String resanalkey) 関連ユーザデータ項目の更新情報を設定します。
void | setRevType(String revType) 関連ユーザデータ項目の更新情報を設定します。
void | setRnddlvQty(String rnddlvQty) 関連ユーザデータ項目の更新情報を設定します。
void | setRoute(String route) 関連ユーザデータ項目の更新情報を設定します。
void | setSalesDist(String salesDist) 関連ユーザデータ項目の更新情報を設定します。
void | setSalesUnit(String salesUnit) 関連ユーザデータ項目の更新情報を設定します。
void | setSalqtyden(String salqtyden) 関連ユーザデータ項目の更新情報を設定します。
void | setSalqtynum(String salqtynum) 関連ユーザデータ項目の更新情報を設定します。
void | setSdTaxcode(String sdTaxcode) 関連ユーザデータ項目の更新情報を設定します。
void | setSelection(String selection) 関連ユーザデータ項目の更新情報を設定します。
void | setSeqNo(String seqNo) 関連ユーザデータ項目の更新情報を設定します。
void | setServDate(String servDate) 関連ユーザデータ項目の更新情報を設定します。
void | setShipPoint(String shipPoint) 関連ユーザデータ項目の更新情報を設定します。
void | setShipType(String shipType) 関連ユーザデータ項目の更新情報を設定します。
void | setShortText(String shortText) 関連ユーザデータ項目の更新情報を設定します。
void | setSProcInd(String sProcInd) 関連ユーザデータ項目の更新情報を設定します。
void | setStoreLoc(String storeLoc) 関連ユーザデータ項目の更新情報を設定します。
void | setTargetQty(String targetQty) 関連ユーザデータ項目の更新情報を設定します。
void | setTargetQu(String targetQu) 関連ユーザデータ項目の更新情報を設定します。
void | setTargetVal(String targetVal) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass1(String taxClass1) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass2(String taxClass2) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass3(String taxClass3) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass4(String taxClass4) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass5(String taxClass5) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass6(String taxClass6) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass7(String taxClass7) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass8(String taxClass8) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass9(String taxClass9) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxlawicms(String taxlawicms) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxlawipi(String taxlawipi) 関連ユーザデータ項目の更新情報を設定します。
void | setTrgqtyDen(String trgqtyDen) 関連ユーザデータ項目の更新情報を設定します。
void | setTrgQtyNo(String trgQtyNo) 関連ユーザデータ項目の更新情報を設定します。
void | setTUnitIso(String tUnitIso) 関連ユーザデータ項目の更新情報を設定します。
void | setUnddlvTol(String unddlvTol) 関連ユーザデータ項目の更新情報を設定します。
void | setUnlmtDlv(String unlmtDlv) 関連ユーザデータ項目の更新情報を設定します。
void | setUntofWght(String untofWght) 関連ユーザデータ項目の更新情報を設定します。
void | setUpdateflag(String updateflag) 更新区分を設定します。
void | setUsageInd(String usageInd) 関連ユーザデータ項目の更新情報を設定します。
void | setValConI(String valConI) 関連ユーザデータ項目の更新情報を設定します。
void | setValContr(String valContr) 関連ユーザデータ項目の更新情報を設定します。
void | setValType(String valType) 関連ユーザデータ項目の更新情報を設定します。
void | setVolume(String volume) 関連ユーザデータ項目の更新情報を設定します。
void | setVolunit(String volunit) 関連ユーザデータ項目の更新情報を設定します。
void | setVwUepos(String vwUepos) 関連ユーザデータ項目の更新情報を設定します。
void | setWbsElem(String wbsElem) 関連ユーザデータ項目の更新情報を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ItemsInX

public ItemsInX()
明細データチェックボックス情報を作成します。

ItemsInX

public ItemsInX(int index)
明細データチェックボックス情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
itmNumber 販売伝票明細

getUpdateflag

public String getUpdateflag()
更新区分を取得します。

戻り値:
updateflag 更新区分

getHgLvItem

public String getHgLvItem()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
hgLvItem 関連ユーザデータ項目の更新情報

getPoItmNo

public String getPoItmNo()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poItmNo 関連ユーザデータ項目の更新情報

getMaterial

public String getMaterial()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
material 関連ユーザデータ項目の更新情報

getAltToItm

public String getAltToItm()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
altToItm 関連ユーザデータ項目の更新情報

getCustMat22

public String getCustMat22()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custMat22 関連ユーザデータ項目の更新情報

getBatch

public String getBatch()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
batch 関連ユーザデータ項目の更新情報

getDlvGroup

public String getDlvGroup()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvGroup 関連ユーザデータ項目の更新情報

getPartDlv

public String getPartDlv()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
partDlv 関連ユーザデータ項目の更新情報

getReasonRej

public String getReasonRej()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
reasonRej 関連ユーザデータ項目の更新情報

getBillBlock

public String getBillBlock()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
billBlock 関連ユーザデータ項目の更新情報

getBillDate

public String getBillDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
billDate 関連ユーザデータ項目の更新情報

getPlant

public String getPlant()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
plant 関連ユーザデータ項目の更新情報

getStoreLoc

public String getStoreLoc()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
storeLoc 関連ユーザデータ項目の更新情報

getTargetQty

public String getTargetQty()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
targetQty 関連ユーザデータ項目の更新情報

getTargetQu

public String getTargetQu()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
targetQu 関連ユーザデータ項目の更新情報

getTUnitIso

public String getTUnitIso()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
tUnitIso 関連ユーザデータ項目の更新情報

getItemCateg

public String getItemCateg()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
itemCateg 関連ユーザデータ項目の更新情報

getShortText

public String getShortText()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
shortText 関連ユーザデータ項目の更新情報

getPrcGroup1

public String getPrcGroup1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
prcGroup1 関連ユーザデータ項目の更新情報

getPrcGroup2

public String getPrcGroup2()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
prcGroup2 関連ユーザデータ項目の更新情報

getPrcGroup3

public String getPrcGroup3()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
prcGroup3 関連ユーザデータ項目の更新情報

getPrcGroup4

public String getPrcGroup4()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
prcGroup4 関連ユーザデータ項目の更新情報

getPrcGroup5

public String getPrcGroup5()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
prcGroup5 関連ユーザデータ項目の更新情報

getProdHiera

public String getProdHiera()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
prodHiera 関連ユーザデータ項目の更新情報

getMatlGroup

public String getMatlGroup()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
matlGroup 関連ユーザデータ項目の更新情報

getPurchNoC

public String getPurchNoC()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
purchNoC 関連ユーザデータ項目の更新情報

getPurchDate

public String getPurchDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
purchDate 関連ユーザデータ項目の更新情報

getPoMethod

public String getPoMethod()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poMethod 関連ユーザデータ項目の更新情報

getRef1

public String getRef1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ref1 関連ユーザデータ項目の更新情報

getPurchNoS

public String getPurchNoS()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
purchNoS 関連ユーザデータ項目の更新情報

getPoDatS

public String getPoDatS()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poDatS 関連ユーザデータ項目の更新情報

getPoMethS

public String getPoMethS()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poMethS 関連ユーザデータ項目の更新情報

getRef1S

public String getRef1S()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ref1S 関連ユーザデータ項目の更新情報

getPoitmNoS

public String getPoitmNoS()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poitmNoS 関連ユーザデータ項目の更新情報

getPriceGrp

public String getPriceGrp()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
priceGrp 関連ユーザデータ項目の更新情報

getCustGroup

public String getCustGroup()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custGroup 関連ユーザデータ項目の更新情報

getSalesDist

public String getSalesDist()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
salesDist 関連ユーザデータ項目の更新情報

getPriceList

public String getPriceList()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
priceList 関連ユーザデータ項目の更新情報

getIncoterms1

public String getIncoterms1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
incoterms1 関連ユーザデータ項目の更新情報

getIncoterms2

public String getIncoterms2()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
incoterms2 関連ユーザデータ項目の更新情報

getOrdcompIn

public String getOrdcompIn()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ordcompIn 関連ユーザデータ項目の更新情報

getBillSched

public String getBillSched()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
billSched 関連ユーザデータ項目の更新情報

getInvoSched

public String getInvoSched()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
invoSched 関連ユーザデータ項目の更新情報

getMnInvoice

public String getMnInvoice()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
mnInvoice 関連ユーザデータ項目の更新情報

getExRateFi

public String getExRateFi()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
exRateFi 関連ユーザデータ項目の更新情報

getAddValDy

public String getAddValDy()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
addValDy 関連ユーザデータ項目の更新情報

getFixValDy

public String getFixValDy()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
fixValDy 関連ユーザデータ項目の更新情報

getPmnttrms

public String getPmnttrms()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pmnttrms 関連ユーザデータ項目の更新情報

getPymtMeth

public String getPymtMeth()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pymtMeth 関連ユーザデータ項目の更新情報

getAccntAsgn

public String getAccntAsgn()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
accntAsgn 関連ユーザデータ項目の更新情報

getExchgRate

public String getExchgRate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
exchgRate 関連ユーザデータ項目の更新情報

getPriceDate

public String getPriceDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
priceDate 関連ユーザデータ項目の更新情報

getServDate

public String getServDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
servDate 関連ユーザデータ項目の更新情報

getDunnKey

public String getDunnKey()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dunnKey 関連ユーザデータ項目の更新情報

getDunnBlock

public String getDunnBlock()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dunnBlock 関連ユーザデータ項目の更新情報

getPromotion

public String getPromotion()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
promotion 関連ユーザデータ項目の更新情報

getPmtgarPro

public String getPmtgarPro()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pmtgarPro 関連ユーザデータ項目の更新情報

getDocNumFi

public String getDocNumFi()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
docNumFi 関連ユーザデータ項目の更新情報

getDepartmNo

public String getDepartmNo()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
departmNo 関連ユーザデータ項目の更新情報

getRecPoint

public String getRecPoint()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
recPoint 関連ユーザデータ項目の更新情報

getCstcndgrp1

public String getCstcndgrp1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp1 関連ユーザデータ項目の更新情報

getCstcndgrp2

public String getCstcndgrp2()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp2 関連ユーザデータ項目の更新情報

getCstcndgrp3

public String getCstcndgrp3()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp3 関連ユーザデータ項目の更新情報

getCstcndgrp4

public String getCstcndgrp4()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp4 関連ユーザデータ項目の更新情報

getCstcndgrp5

public String getCstcndgrp5()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp5 関連ユーザデータ項目の更新情報

getDlvTime

public String getDlvTime()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvTime 関連ユーザデータ項目の更新情報

getSalesUnit

public String getSalesUnit()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
salesUnit 関連ユーザデータ項目の更新情報

getTrgQtyNo

public String getTrgQtyNo()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
trgQtyNo 関連ユーザデータ項目の更新情報

getTrgqtyDen

public String getTrgqtyDen()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
trgqtyDen 関連ユーザデータ項目の更新情報

getRnddlvQty

public String getRnddlvQty()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
rnddlvQty 関連ユーザデータ項目の更新情報

getMaxdevamnt

public String getMaxdevamnt()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
maxdevamnt 関連ユーザデータ項目の更新情報

getMaxdevper

public String getMaxdevper()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
maxdevper 関連ユーザデータ項目の更新情報

getMaxdevDay

public String getMaxdevDay()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
maxdevDay 関連ユーザデータ項目の更新情報

getUsageInd

public String getUsageInd()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
usageInd 関連ユーザデータ項目の更新情報

getFixedQuan

public String getFixedQuan()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
fixedQuan 関連ユーザデータ項目の更新情報

getUnlmtDlv

public String getUnlmtDlv()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
unlmtDlv 関連ユーザデータ項目の更新情報

getOverdlvtol

public String getOverdlvtol()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
overdlvtol 関連ユーザデータ項目の更新情報

getUnddlvTol

public String getUnddlvTol()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
unddlvTol 関連ユーザデータ項目の更新情報

getDivision

public String getDivision()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
division 関連ユーザデータ項目の更新情報

getSalqtynum

public String getSalqtynum()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
salqtynum 関連ユーザデータ項目の更新情報

getSalqtyden

public String getSalqtyden()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
salqtyden 関連ユーザデータ項目の更新情報

getGrossWght

public String getGrossWght()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
grossWght 関連ユーザデータ項目の更新情報

getNetWeight

public String getNetWeight()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
netWeight 関連ユーザデータ項目の更新情報

getUntofWght

public String getUntofWght()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
untofWght 関連ユーザデータ項目の更新情報

getVolume

public String getVolume()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
volume 関連ユーザデータ項目の更新情報

getVolunit

public String getVolunit()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
volunit 関連ユーザデータ項目の更新情報

getDlvPrio

public String getDlvPrio()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvPrio 関連ユーザデータ項目の更新情報

getShipPoint

public String getShipPoint()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
shipPoint 関連ユーザデータ項目の更新情報

getRoute

public String getRoute()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
route 関連ユーザデータ項目の更新情報

getTaxClass1

public String getTaxClass1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass1 関連ユーザデータ項目の更新情報

getTaxClass2

public String getTaxClass2()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass2 関連ユーザデータ項目の更新情報

getTaxClass3

public String getTaxClass3()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass3 関連ユーザデータ項目の更新情報

getTaxClass4

public String getTaxClass4()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass4 関連ユーザデータ項目の更新情報

getTaxClass5

public String getTaxClass5()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass5 関連ユーザデータ項目の更新情報

getTaxClass6

public String getTaxClass6()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass6 関連ユーザデータ項目の更新情報

getTaxClass7

public String getTaxClass7()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass7 関連ユーザデータ項目の更新情報

getTaxClass8

public String getTaxClass8()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass8 関連ユーザデータ項目の更新情報

getTaxClass9

public String getTaxClass9()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass9 関連ユーザデータ項目の更新情報

getMatPrGrp

public String getMatPrGrp()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
matPrGrp 関連ユーザデータ項目の更新情報

getValType

public String getValType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
valType 関連ユーザデータ項目の更新情報

getFixdatQty

public String getFixdatQty()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
fixdatQty 関連ユーザデータ項目の更新情報

getBomexplNo

public String getBomexplNo()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
bomexplNo 関連ユーザデータ項目の更新情報

getResanalkey

public String getResanalkey()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
resanalkey 関連ユーザデータ項目の更新情報

getReqmtsTyp

public String getReqmtsTyp()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
reqmtsTyp 関連ユーザデータ項目の更新情報

getNoGrPost

public String getNoGrPost()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
noGrPost 関連ユーザデータ項目の更新情報

getBusTranst

public String getBusTranst()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
busTranst 関連ユーザデータ項目の更新情報

getOverhdKey

public String getOverhdKey()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
overhdKey 関連ユーザデータ項目の更新情報

getCstgSheet

public String getCstgSheet()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstgSheet 関連ユーザデータ項目の更新情報

getMatfrgtgrp

public String getMatfrgtgrp()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
matfrgtgrp 関連ユーザデータ項目の更新情報

getPldlvshdin

public String getPldlvshdin()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pldlvshdin 関連ユーザデータ項目の更新情報

getSeqNo

public String getSeqNo()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
seqNo 関連ユーザデータ項目の更新情報

getBilForm

public String getBilForm()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
bilForm 関連ユーザデータ項目の更新情報

getDliProfil

public String getDliProfil()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dliProfil 関連ユーザデータ項目の更新情報

getRevType

public String getRevType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
revType 関連ユーザデータ項目の更新情報

getBegdemPer

public String getBegdemPer()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
begdemPer 関連ユーザデータ項目の更新情報

getPrRefMat

public String getPrRefMat()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
prRefMat 関連ユーザデータ項目の更新情報

getRefobjtype

public String getRefobjtype()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refobjtype 関連ユーザデータ項目の更新情報

getRefobjkey

public String getRefobjkey()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refobjkey 関連ユーザデータ項目の更新情報

getReflogsys

public String getReflogsys()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
reflogsys 関連ユーザデータ項目の更新情報

getOrderProb

public String getOrderProb()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
orderProb 関連ユーザデータ項目の更新情報

getMaxPlDlv

public String getMaxPlDlv()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
maxPlDlv 関連ユーザデータ項目の更新情報

getCfopCode

public String getCfopCode()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cfopCode 関連ユーザデータ項目の更新情報

getTaxlawicms

public String getTaxlawicms()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxlawicms 関連ユーザデータ項目の更新情報

getTaxlawipi

public String getTaxlawipi()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxlawipi 関連ユーザデータ項目の更新情報

getSdTaxcode

public String getSdTaxcode()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
sdTaxcode 関連ユーザデータ項目の更新情報

getAssortMod

public String getAssortMod()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
assortMod 関連ユーザデータ項目の更新情報

getCompQuant

public String getCompQuant()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
compQuant 関連ユーザデータ項目の更新情報

getTargetVal

public String getTargetVal()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
targetVal 関連ユーザデータ項目の更新情報

getProfitCtr

public String getProfitCtr()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
profitCtr 関連ユーザデータ項目の更新情報

getOrderid

public String getOrderid()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
orderid 関連ユーザデータ項目の更新情報

getWbsElem

public String getWbsElem()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
wbsElem 関連ユーザデータ項目の更新情報

getDeprecPer

public String getDeprecPer()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
deprecPer 関連ユーザデータ項目の更新情報

getRefDoc

public String getRefDoc()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refDoc 関連ユーザデータ項目の更新情報

getRefDocIt

public String getRefDocIt()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refDocIt 関連ユーザデータ項目の更新情報

getRefDocCa

public String getRefDocCa()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refDocCa 関連ユーザデータ項目の更新情報

getCustMat35

public String getCustMat35()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custMat35 関連ユーザデータ項目の更新情報

getExchRateFiV

public String getExchRateFiV()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
exchRateFiV 関連ユーザデータ項目の更新情報

getExchgRateV

public String getExchgRateV()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
exchgRateV 関連ユーザデータ項目の更新情報

getItemguidAtp

public String getItemguidAtp()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
itemguidAtp 関連ユーザデータ項目の更新情報

getValContr

public String getValContr()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
valContr 関連ユーザデータ項目の更新情報

getValConI

public String getValConI()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
valConI 関連ユーザデータ項目の更新情報

getConfigId

public String getConfigId()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
configId 関連ユーザデータ項目の更新情報

getInstId

public String getInstId()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
instId 関連ユーザデータ項目の更新情報

getMatExt

public String getMatExt()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
matExt 関連ユーザデータ項目の更新情報

getMatGuid

public String getMatGuid()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
matGuid 関連ユーザデータ項目の更新情報

getMatVers

public String getMatVers()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
matVers 関連ユーザデータ項目の更新情報

getPMatExt

public String getPMatExt()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pMatExt 関連ユーザデータ項目の更新情報

getPMatGuid

public String getPMatGuid()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pMatGuid 関連ユーザデータ項目の更新情報

getPMatVers

public String getPMatVers()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pMatVers 関連ユーザデータ項目の更新情報

getFuncArea

public String getFuncArea()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
funcArea 関連ユーザデータ項目の更新情報

getAlternBom

public String getAlternBom()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
alternBom 関連ユーザデータ項目の更新情報

getFkkConacct

public String getFkkConacct()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
fkkConacct 関連ユーザデータ項目の更新情報

getEanUpc

public String getEanUpc()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
eanUpc 関連ユーザデータ項目の更新情報

getProdcat

public String getProdcat()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
prodcat 関連ユーザデータ項目の更新情報

getShipType

public String getShipType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
shipType 関連ユーザデータ項目の更新情報

getSProcInd

public String getSProcInd()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
sProcInd 関連ユーザデータ項目の更新情報

getBillRel

public String getBillRel()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
billRel 関連ユーザデータ項目の更新情報

getVwUepos

public String getVwUepos()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
vwUepos 関連ユーザデータ項目の更新情報

getCampaign

public String getCampaign()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
campaign 関連ユーザデータ項目の更新情報

getDlvschduse

public String getDlvschduse()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvschduse 関連ユーザデータ項目の更新情報

getSelection

public String getSelection()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
selection 関連ユーザデータ項目の更新情報

getMatEntrd

public String getMatEntrd()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
matEntrd 関連ユーザデータ項目の更新情報

getLogSystemOwn

public String getLogSystemOwn()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
logSystemOwn 関連ユーザデータ項目の更新情報

getItmTypeUsage

public String getItmTypeUsage()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
itmTypeUsage 関連ユーザデータ項目の更新情報

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setItmNumber

public void setItmNumber(String itmNumber)
販売伝票明細を設定します。

パラメータ:
itmNumber - 販売伝票明細

setUpdateflag

public void setUpdateflag(String updateflag)
更新区分を設定します。

パラメータ:
updateflag - 更新区分

setHgLvItem

public void setHgLvItem(String hgLvItem)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
hgLvItem - 関連ユーザデータ項目の更新情報

setPoItmNo

public void setPoItmNo(String poItmNo)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poItmNo - 関連ユーザデータ項目の更新情報

setMaterial

public void setMaterial(String material)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
material - 関連ユーザデータ項目の更新情報

setAltToItm

public void setAltToItm(String altToItm)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
altToItm - 関連ユーザデータ項目の更新情報

setCustMat22

public void setCustMat22(String custMat22)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custMat22 - 関連ユーザデータ項目の更新情報

setBatch

public void setBatch(String batch)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
batch - 関連ユーザデータ項目の更新情報

setDlvGroup

public void setDlvGroup(String dlvGroup)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvGroup - 関連ユーザデータ項目の更新情報

setPartDlv

public void setPartDlv(String partDlv)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
partDlv - 関連ユーザデータ項目の更新情報

setReasonRej

public void setReasonRej(String reasonRej)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
reasonRej - 関連ユーザデータ項目の更新情報

setBillBlock

public void setBillBlock(String billBlock)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
billBlock - 関連ユーザデータ項目の更新情報

setBillDate

public void setBillDate(String billDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
billDate - 関連ユーザデータ項目の更新情報

setPlant

public void setPlant(String plant)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
plant - 関連ユーザデータ項目の更新情報

setStoreLoc

public void setStoreLoc(String storeLoc)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
storeLoc - 関連ユーザデータ項目の更新情報

setTargetQty

public void setTargetQty(String targetQty)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
targetQty - 関連ユーザデータ項目の更新情報

setTargetQu

public void setTargetQu(String targetQu)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
targetQu - 関連ユーザデータ項目の更新情報

setTUnitIso

public void setTUnitIso(String tUnitIso)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
tUnitIso - 関連ユーザデータ項目の更新情報

setItemCateg

public void setItemCateg(String itemCateg)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
itemCateg - 関連ユーザデータ項目の更新情報

setShortText

public void setShortText(String shortText)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
shortText - 関連ユーザデータ項目の更新情報

setPrcGroup1

public void setPrcGroup1(String prcGroup1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
prcGroup1 - 関連ユーザデータ項目の更新情報

setPrcGroup2

public void setPrcGroup2(String prcGroup2)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
prcGroup2 - 関連ユーザデータ項目の更新情報

setPrcGroup3

public void setPrcGroup3(String prcGroup3)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
prcGroup3 - 関連ユーザデータ項目の更新情報

setPrcGroup4

public void setPrcGroup4(String prcGroup4)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
prcGroup4 - 関連ユーザデータ項目の更新情報

setPrcGroup5

public void setPrcGroup5(String prcGroup5)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
prcGroup5 - 関連ユーザデータ項目の更新情報

setProdHiera

public void setProdHiera(String prodHiera)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
prodHiera - 関連ユーザデータ項目の更新情報

setMatlGroup

public void setMatlGroup(String matlGroup)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
matlGroup - 関連ユーザデータ項目の更新情報

setPurchNoC

public void setPurchNoC(String purchNoC)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
purchNoC - 関連ユーザデータ項目の更新情報

setPurchDate

public void setPurchDate(String purchDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
purchDate - 関連ユーザデータ項目の更新情報

setPoMethod

public void setPoMethod(String poMethod)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poMethod - 関連ユーザデータ項目の更新情報

setRef1

public void setRef1(String ref1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ref1 - 関連ユーザデータ項目の更新情報

setPurchNoS

public void setPurchNoS(String purchNoS)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
purchNoS - 関連ユーザデータ項目の更新情報

setPoDatS

public void setPoDatS(String poDatS)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poDatS - 関連ユーザデータ項目の更新情報

setPoMethS

public void setPoMethS(String poMethS)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poMethS - 関連ユーザデータ項目の更新情報

setRef1S

public void setRef1S(String ref1S)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ref1S - 関連ユーザデータ項目の更新情報

setPoitmNoS

public void setPoitmNoS(String poitmNoS)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poitmNoS - 関連ユーザデータ項目の更新情報

setPriceGrp

public void setPriceGrp(String priceGrp)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
priceGrp - 関連ユーザデータ項目の更新情報

setCustGroup

public void setCustGroup(String custGroup)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custGroup - 関連ユーザデータ項目の更新情報

setSalesDist

public void setSalesDist(String salesDist)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
salesDist - 関連ユーザデータ項目の更新情報

setPriceList

public void setPriceList(String priceList)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
priceList - 関連ユーザデータ項目の更新情報

setIncoterms1

public void setIncoterms1(String incoterms1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
incoterms1 - 関連ユーザデータ項目の更新情報

setIncoterms2

public void setIncoterms2(String incoterms2)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
incoterms2 - 関連ユーザデータ項目の更新情報

setOrdcompIn

public void setOrdcompIn(String ordcompIn)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ordcompIn - 関連ユーザデータ項目の更新情報

setBillSched

public void setBillSched(String billSched)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
billSched - 関連ユーザデータ項目の更新情報

setInvoSched

public void setInvoSched(String invoSched)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
invoSched - 関連ユーザデータ項目の更新情報

setMnInvoice

public void setMnInvoice(String mnInvoice)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
mnInvoice - 関連ユーザデータ項目の更新情報

setExRateFi

public void setExRateFi(String exRateFi)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
exRateFi - 関連ユーザデータ項目の更新情報

setAddValDy

public void setAddValDy(String addValDy)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
addValDy - 関連ユーザデータ項目の更新情報

setFixValDy

public void setFixValDy(String fixValDy)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
fixValDy - 関連ユーザデータ項目の更新情報

setPmnttrms

public void setPmnttrms(String pmnttrms)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pmnttrms - 関連ユーザデータ項目の更新情報

setPymtMeth

public void setPymtMeth(String pymtMeth)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pymtMeth - 関連ユーザデータ項目の更新情報

setAccntAsgn

public void setAccntAsgn(String accntAsgn)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
accntAsgn - 関連ユーザデータ項目の更新情報

setExchgRate

public void setExchgRate(String exchgRate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
exchgRate - 関連ユーザデータ項目の更新情報

setPriceDate

public void setPriceDate(String priceDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
priceDate - 関連ユーザデータ項目の更新情報

setServDate

public void setServDate(String servDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
servDate - 関連ユーザデータ項目の更新情報

setDunnKey

public void setDunnKey(String dunnKey)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dunnKey - 関連ユーザデータ項目の更新情報

setDunnBlock

public void setDunnBlock(String dunnBlock)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dunnBlock - 関連ユーザデータ項目の更新情報

setPromotion

public void setPromotion(String promotion)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
promotion - 関連ユーザデータ項目の更新情報

setPmtgarPro

public void setPmtgarPro(String pmtgarPro)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pmtgarPro - 関連ユーザデータ項目の更新情報

setDocNumFi

public void setDocNumFi(String docNumFi)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
docNumFi - 関連ユーザデータ項目の更新情報

setDepartmNo

public void setDepartmNo(String departmNo)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
departmNo - 関連ユーザデータ項目の更新情報

setRecPoint

public void setRecPoint(String recPoint)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
recPoint - 関連ユーザデータ項目の更新情報

setCstcndgrp1

public void setCstcndgrp1(String cstcndgrp1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp1 - 関連ユーザデータ項目の更新情報

setCstcndgrp2

public void setCstcndgrp2(String cstcndgrp2)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp2 - 関連ユーザデータ項目の更新情報

setCstcndgrp3

public void setCstcndgrp3(String cstcndgrp3)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp3 - 関連ユーザデータ項目の更新情報

setCstcndgrp4

public void setCstcndgrp4(String cstcndgrp4)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp4 - 関連ユーザデータ項目の更新情報

setCstcndgrp5

public void setCstcndgrp5(String cstcndgrp5)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp5 - 関連ユーザデータ項目の更新情報

setDlvTime

public void setDlvTime(String dlvTime)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvTime - 関連ユーザデータ項目の更新情報

setSalesUnit

public void setSalesUnit(String salesUnit)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
salesUnit - 関連ユーザデータ項目の更新情報

setTrgQtyNo

public void setTrgQtyNo(String trgQtyNo)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
trgQtyNo - 関連ユーザデータ項目の更新情報

setTrgqtyDen

public void setTrgqtyDen(String trgqtyDen)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
trgqtyDen - 関連ユーザデータ項目の更新情報

setRnddlvQty

public void setRnddlvQty(String rnddlvQty)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
rnddlvQty - 関連ユーザデータ項目の更新情報

setMaxdevamnt

public void setMaxdevamnt(String maxdevamnt)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
maxdevamnt - 関連ユーザデータ項目の更新情報

setMaxdevper

public void setMaxdevper(String maxdevper)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
maxdevper - 関連ユーザデータ項目の更新情報

setMaxdevDay

public void setMaxdevDay(String maxdevDay)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
maxdevDay - 関連ユーザデータ項目の更新情報

setUsageInd

public void setUsageInd(String usageInd)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
usageInd - 関連ユーザデータ項目の更新情報

setFixedQuan

public void setFixedQuan(String fixedQuan)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
fixedQuan - 関連ユーザデータ項目の更新情報

setUnlmtDlv

public void setUnlmtDlv(String unlmtDlv)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
unlmtDlv - 関連ユーザデータ項目の更新情報

setOverdlvtol

public void setOverdlvtol(String overdlvtol)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
overdlvtol - 関連ユーザデータ項目の更新情報

setUnddlvTol

public void setUnddlvTol(String unddlvTol)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
unddlvTol - 関連ユーザデータ項目の更新情報

setDivision

public void setDivision(String division)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
division - 関連ユーザデータ項目の更新情報

setSalqtynum

public void setSalqtynum(String salqtynum)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
salqtynum - 関連ユーザデータ項目の更新情報

setSalqtyden

public void setSalqtyden(String salqtyden)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
salqtyden - 関連ユーザデータ項目の更新情報

setGrossWght

public void setGrossWght(String grossWght)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
grossWght - 関連ユーザデータ項目の更新情報

setNetWeight

public void setNetWeight(String netWeight)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
netWeight - 関連ユーザデータ項目の更新情報

setUntofWght

public void setUntofWght(String untofWght)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
untofWght - 関連ユーザデータ項目の更新情報

setVolume

public void setVolume(String volume)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
volume - 関連ユーザデータ項目の更新情報

setVolunit

public void setVolunit(String volunit)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
volunit - 関連ユーザデータ項目の更新情報

setDlvPrio

public void setDlvPrio(String dlvPrio)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvPrio - 関連ユーザデータ項目の更新情報

setShipPoint

public void setShipPoint(String shipPoint)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
shipPoint - 関連ユーザデータ項目の更新情報

setRoute

public void setRoute(String route)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
route - 関連ユーザデータ項目の更新情報

setTaxClass1

public void setTaxClass1(String taxClass1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass1 - 関連ユーザデータ項目の更新情報

setTaxClass2

public void setTaxClass2(String taxClass2)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass2 - 関連ユーザデータ項目の更新情報

setTaxClass3

public void setTaxClass3(String taxClass3)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass3 - 関連ユーザデータ項目の更新情報

setTaxClass4

public void setTaxClass4(String taxClass4)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass4 - 関連ユーザデータ項目の更新情報

setTaxClass5

public void setTaxClass5(String taxClass5)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass5 - 関連ユーザデータ項目の更新情報

setTaxClass6

public void setTaxClass6(String taxClass6)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass6 - 関連ユーザデータ項目の更新情報

setTaxClass7

public void setTaxClass7(String taxClass7)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass7 - 関連ユーザデータ項目の更新情報

setTaxClass8

public void setTaxClass8(String taxClass8)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass8 - 関連ユーザデータ項目の更新情報

setTaxClass9

public void setTaxClass9(String taxClass9)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass9 - 関連ユーザデータ項目の更新情報

setMatPrGrp

public void setMatPrGrp(String matPrGrp)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
matPrGrp - 関連ユーザデータ項目の更新情報

setValType

public void setValType(String valType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
valType - 関連ユーザデータ項目の更新情報

setFixdatQty

public void setFixdatQty(String fixdatQty)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
fixdatQty - 関連ユーザデータ項目の更新情報

setBomexplNo

public void setBomexplNo(String bomexplNo)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
bomexplNo - 関連ユーザデータ項目の更新情報

setResanalkey

public void setResanalkey(String resanalkey)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
resanalkey - 関連ユーザデータ項目の更新情報

setReqmtsTyp

public void setReqmtsTyp(String reqmtsTyp)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
reqmtsTyp - 関連ユーザデータ項目の更新情報

setNoGrPost

public void setNoGrPost(String noGrPost)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
noGrPost - 関連ユーザデータ項目の更新情報

setBusTranst

public void setBusTranst(String busTranst)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
busTranst - 関連ユーザデータ項目の更新情報

setOverhdKey

public void setOverhdKey(String overhdKey)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
overhdKey - 関連ユーザデータ項目の更新情報

setCstgSheet

public void setCstgSheet(String cstgSheet)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstgSheet - 関連ユーザデータ項目の更新情報

setMatfrgtgrp

public void setMatfrgtgrp(String matfrgtgrp)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
matfrgtgrp - 関連ユーザデータ項目の更新情報

setPldlvshdin

public void setPldlvshdin(String pldlvshdin)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pldlvshdin - 関連ユーザデータ項目の更新情報

setSeqNo

public void setSeqNo(String seqNo)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
seqNo - 関連ユーザデータ項目の更新情報

setBilForm

public void setBilForm(String bilForm)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
bilForm - 関連ユーザデータ項目の更新情報

setDliProfil

public void setDliProfil(String dliProfil)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dliProfil - 関連ユーザデータ項目の更新情報

setRevType

public void setRevType(String revType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
revType - 関連ユーザデータ項目の更新情報

setBegdemPer

public void setBegdemPer(String begdemPer)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
begdemPer - 関連ユーザデータ項目の更新情報

setPrRefMat

public void setPrRefMat(String prRefMat)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
prRefMat - 関連ユーザデータ項目の更新情報

setRefobjtype

public void setRefobjtype(String refobjtype)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refobjtype - 関連ユーザデータ項目の更新情報

setRefobjkey

public void setRefobjkey(String refobjkey)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refobjkey - 関連ユーザデータ項目の更新情報

setReflogsys

public void setReflogsys(String reflogsys)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
reflogsys - 関連ユーザデータ項目の更新情報

setOrderProb

public void setOrderProb(String orderProb)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
orderProb - 関連ユーザデータ項目の更新情報

setMaxPlDlv

public void setMaxPlDlv(String maxPlDlv)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
maxPlDlv - 関連ユーザデータ項目の更新情報

setCfopCode

public void setCfopCode(String cfopCode)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cfopCode - 関連ユーザデータ項目の更新情報

setTaxlawicms

public void setTaxlawicms(String taxlawicms)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxlawicms - 関連ユーザデータ項目の更新情報

setTaxlawipi

public void setTaxlawipi(String taxlawipi)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxlawipi - 関連ユーザデータ項目の更新情報

setSdTaxcode

public void setSdTaxcode(String sdTaxcode)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
sdTaxcode - 関連ユーザデータ項目の更新情報

setAssortMod

public void setAssortMod(String assortMod)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
assortMod - 関連ユーザデータ項目の更新情報

setCompQuant

public void setCompQuant(String compQuant)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
compQuant - 関連ユーザデータ項目の更新情報

setTargetVal

public void setTargetVal(String targetVal)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
targetVal - 関連ユーザデータ項目の更新情報

setProfitCtr

public void setProfitCtr(String profitCtr)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
profitCtr - 関連ユーザデータ項目の更新情報

setOrderid

public void setOrderid(String orderid)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
orderid - 関連ユーザデータ項目の更新情報

setWbsElem

public void setWbsElem(String wbsElem)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
wbsElem - 関連ユーザデータ項目の更新情報

setDeprecPer

public void setDeprecPer(String deprecPer)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
deprecPer - 関連ユーザデータ項目の更新情報

setRefDoc

public void setRefDoc(String refDoc)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refDoc - 関連ユーザデータ項目の更新情報

setRefDocIt

public void setRefDocIt(String refDocIt)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refDocIt - 関連ユーザデータ項目の更新情報

setRefDocCa

public void setRefDocCa(String refDocCa)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refDocCa - 関連ユーザデータ項目の更新情報

setCustMat35

public void setCustMat35(String custMat35)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custMat35 - 関連ユーザデータ項目の更新情報

setExchRateFiV

public void setExchRateFiV(String exchRateFiV)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
exchRateFiV - 関連ユーザデータ項目の更新情報

setExchgRateV

public void setExchgRateV(String exchgRateV)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
exchgRateV - 関連ユーザデータ項目の更新情報

setItemguidAtp

public void setItemguidAtp(String itemguidAtp)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
itemguidAtp - 関連ユーザデータ項目の更新情報

setValContr

public void setValContr(String valContr)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
valContr - 関連ユーザデータ項目の更新情報

setValConI

public void setValConI(String valConI)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
valConI - 関連ユーザデータ項目の更新情報

setConfigId

public void setConfigId(String configId)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
configId - 関連ユーザデータ項目の更新情報

setInstId

public void setInstId(String instId)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
instId - 関連ユーザデータ項目の更新情報

setMatExt

public void setMatExt(String matExt)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
matExt - 関連ユーザデータ項目の更新情報

setMatGuid

public void setMatGuid(String matGuid)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
matGuid - 関連ユーザデータ項目の更新情報

setMatVers

public void setMatVers(String matVers)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
matVers - 関連ユーザデータ項目の更新情報

setPMatExt

public void setPMatExt(String pMatExt)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pMatExt - 関連ユーザデータ項目の更新情報

setPMatGuid

public void setPMatGuid(String pMatGuid)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pMatGuid - 関連ユーザデータ項目の更新情報

setPMatVers

public void setPMatVers(String pMatVers)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pMatVers - 関連ユーザデータ項目の更新情報

setFuncArea

public void setFuncArea(String funcArea)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
funcArea - 関連ユーザデータ項目の更新情報

setAlternBom

public void setAlternBom(String alternBom)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
alternBom - 関連ユーザデータ項目の更新情報

setFkkConacct

public void setFkkConacct(String fkkConacct)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
fkkConacct - 関連ユーザデータ項目の更新情報

setEanUpc

public void setEanUpc(String eanUpc)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
eanUpc - 関連ユーザデータ項目の更新情報

setProdcat

public void setProdcat(String prodcat)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
prodcat - 関連ユーザデータ項目の更新情報

setShipType

public void setShipType(String shipType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
shipType - 関連ユーザデータ項目の更新情報

setSProcInd

public void setSProcInd(String sProcInd)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
sProcInd - 関連ユーザデータ項目の更新情報

setBillRel

public void setBillRel(String billRel)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
billRel - 関連ユーザデータ項目の更新情報

setVwUepos

public void setVwUepos(String vwUepos)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
vwUepos - 関連ユーザデータ項目の更新情報

setCampaign

public void setCampaign(String campaign)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
campaign - 関連ユーザデータ項目の更新情報

setDlvschduse

public void setDlvschduse(String dlvschduse)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvschduse - 関連ユーザデータ項目の更新情報

setSelection

public void setSelection(String selection)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
selection - 関連ユーザデータ項目の更新情報

setMatEntrd

public void setMatEntrd(String matEntrd)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
matEntrd - 関連ユーザデータ項目の更新情報

setLogSystemOwn

public void setLogSystemOwn(String logSystemOwn)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
logSystemOwn - 関連ユーザデータ項目の更新情報

setItmTypeUsage

public void setItmTypeUsage(String itmTypeUsage)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
itmTypeUsage - 関連ユーザデータ項目の更新情報

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Keys (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス Keys

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys
すべての実装インタフェース:
Serializable
public class Keys
extends Object
implements Serializable

参照キーの出力テーブル情報クラス
機能は以下の通り

  • 参照キーの出力テーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Keys()
参照キーの出力テーブル情報を作成します。
Keys(int index)
参照キーの出力テーブル情報を作成します。
メソッドの概要
String | getAbart() 承認タイプを取得します。
String | getAbrli() 内部納入日程番号を取得します。
String | getAddress() 住所を取得します。
String | getCondCount() 条件カウンタを取得します。
String | getConditemno() 条件明細番号を取得します。
String | getCondNo() 伝票条件番号を取得します。
String | getCondStNo() ステップ番号を取得します。
String | getCondType() 条件タイプを取得します。
String | getDocNumber() 販売管理伝票番号を取得します。
int | getIndex() レコード番号を取得します｡
String | getItmNumber() 販売伝票明細を取得します。
String | getReflogsys() 論理システムを取得します。
String | getRefobject() オブジェクト名を取得します。
String | getRefobjkey() オブジェクトキーを取得します。
String | getRefobjtyp() オブジェクトタイプを取得します。
String | getSchedLin() 納入日程行を取得します。
String | getStatus() 単一文字フラグを取得します。
String | getTindex() 数値項目: 長さ 6を取得します。
void | setAbart(String abart) 承認タイプを設定します。
void | setAbrli(String abrli) 内部納入日程番号を設定します。
void | setAddress(String address) 住所を設定します。
void | setCondCount(String condCount) 条件カウンタを設定します。
void | setConditemno(String conditemno) 条件明細番号を設定します。
void | setCondNo(String condNo) 伝票条件番号を設定します。
void | setCondStNo(String condStNo) ステップ番号を設定します。
void | setCondType(String condType) 条件タイプを設定します。
void | setDocNumber(String docNumber) 販売管理伝票番号を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItmNumber(String itmNumber) 販売伝票明細を設定します。
void | setReflogsys(String reflogsys) 論理システムを設定します。
void | setRefobject(String refobject) オブジェクト名を設定します。
void | setRefobjkey(String refobjkey) オブジェクトキーを設定します。
void | setRefobjtyp(String refobjtyp) オブジェクトタイプを設定します。
void | setSchedLin(String schedLin) 納入日程行を設定します。
void | setStatus(String status) 単一文字フラグを設定します。
void | setTindex(String tindex) 数値項目: 長さ 6を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Keys

public Keys()
参照キーの出力テーブル情報を作成します。

Keys

public Keys(int index)
参照キーの出力テーブル情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getRefobjtyp

public String getRefobjtyp()
オブジェクトタイプを取得します。

戻り値:
refobjtyp オブジェクトタイプ

getRefobject

public String getRefobject()
オブジェクト名を取得します。

戻り値:
refobject オブジェクト名

getRefobjkey

public String getRefobjkey()
オブジェクトキーを取得します。

戻り値:
refobjkey オブジェクトキー

getReflogsys

public String getReflogsys()
論理システムを取得します。

戻り値:
reflogsys 論理システム

getDocNumber

public String getDocNumber()
販売管理伝票番号を取得します。

戻り値:
docNumber 販売管理伝票番号

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
itmNumber 販売伝票明細

getSchedLin

public String getSchedLin()
納入日程行を取得します。

戻り値:
schedLin 納入日程行

getCondNo

public String getCondNo()
伝票条件番号を取得します。

戻り値:
condNo 伝票条件番号

getConditemno

public String getConditemno()
条件明細番号を取得します。

戻り値:
conditemno 条件明細番号

getCondStNo

public String getCondStNo()
ステップ番号を取得します。

戻り値:
condStNo ステップ番号

getCondCount

public String getCondCount()
条件カウンタを取得します。

戻り値:
condCount 条件カウンタ

getCondType

public String getCondType()
条件タイプを取得します。

戻り値:
condType 条件タイプ

getStatus

public String getStatus()
単一文字フラグを取得します。

戻り値:
status 単一文字フラグ

getTindex

public String getTindex()
数値項目: 長さ 6を取得します。

戻り値:
tindex 数値項目: 長さ 6

getAddress

public String getAddress()
住所を取得します。

戻り値:
address 住所

getAbrli

public String getAbrli()
内部納入日程番号を取得します。

戻り値:
abrli 内部納入日程番号

getAbart

public String getAbart()
承認タイプを取得します。

戻り値:
abart 承認タイプ

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setRefobjtyp

public void setRefobjtyp(String refobjtyp)
オブジェクトタイプを設定します。

パラメータ:
refobjtyp - オブジェクトタイプ

setRefobject

public void setRefobject(String refobject)
オブジェクト名を設定します。

パラメータ:
refobject - オブジェクト名

setRefobjkey

public void setRefobjkey(String refobjkey)
オブジェクトキーを設定します。

パラメータ:
refobjkey - オブジェクトキー

setReflogsys

public void setReflogsys(String reflogsys)
論理システムを設定します。

パラメータ:
reflogsys - 論理システム

setDocNumber

public void setDocNumber(String docNumber)
販売管理伝票番号を設定します。

パラメータ:
docNumber - 販売管理伝票番号

setItmNumber

public void setItmNumber(String itmNumber)
販売伝票明細を設定します。

パラメータ:
itmNumber - 販売伝票明細

setSchedLin

public void setSchedLin(String schedLin)
納入日程行を設定します。

パラメータ:
schedLin - 納入日程行

setCondNo

public void setCondNo(String condNo)
伝票条件番号を設定します。

パラメータ:
condNo - 伝票条件番号

setConditemno

public void setConditemno(String conditemno)
条件明細番号を設定します。

パラメータ:
conditemno - 条件明細番号

setCondStNo

public void setCondStNo(String condStNo)
ステップ番号を設定します。

パラメータ:
condStNo - ステップ番号

setCondCount

public void setCondCount(String condCount)
条件カウンタを設定します。

パラメータ:
condCount - 条件カウンタ

setCondType

public void setCondType(String condType)
条件タイプを設定します。

パラメータ:
condType - 条件タイプ

setStatus

public void setStatus(String status)
単一文字フラグを設定します。

パラメータ:
status - 単一文字フラグ

setTindex

public void setTindex(String tindex)
数値項目: 長さ 6を設定します。

パラメータ:
tindex - 数値項目: 長さ 6

setAddress

public void setAddress(String address)
住所を設定します。

パラメータ:
address - 住所

setAbrli

public void setAbrli(String abrli)
内部納入日程番号を設定します。

パラメータ:
abrli - 内部納入日程番号

setAbart

public void setAbart(String abart)
承認タイプを設定します。

パラメータ:
abart - 承認タイプ

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LogicSwitch (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス LogicSwitch

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch
すべての実装インタフェース:
Serializable
public class LogicSwitch
extends Object
implements Serializable

内部制御パラメータ情報クラス
機能は以下の通り

  • 内部制御パラメータ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
LogicSwitch()
内部制御パラメータ情報を作成します。
メソッドの概要
String | getAtpWrkmod() ATP セッション: 結果取得/新規決定 APO-ATPを取得します。
String | getCondHandl() 選択: 条件行処理 (SD 伝票変更)を取得します。
String | getNostructure() チェックボックスを取得します。
String | getPricing() 価格設定タイプを取得します。
String | getScheduling() 単一文字フラグを取得します。
void | setAtpWrkmod(String atpWrkmod) ATP セッション: 結果取得/新規決定 APO-ATPを設定します。
void | setCondHandl(String condHandl) 選択: 条件行処理 (SD 伝票変更)を設定します。
void | setNostructure(String nostructure) チェックボックスを設定します。
void | setPricing(String pricing) 価格設定タイプを設定します。
void | setScheduling(String scheduling) 単一文字フラグを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

LogicSwitch

public LogicSwitch()
内部制御パラメータ情報を作成します。

メソッドの詳細

getPricing

public String getPricing()
価格設定タイプを取得します。

戻り値:
pricing 価格設定タイプ

getAtpWrkmod

public String getAtpWrkmod()
ATP セッション: 結果取得/新規決定 APO-ATPを取得します。

戻り値:
atpWrkmod ATP セッション: 結果取得/新規決定 APO-ATP

getScheduling

public String getScheduling()
単一文字フラグを取得します。

戻り値:
scheduling 単一文字フラグ

getNostructure

public String getNostructure()
チェックボックスを取得します。

戻り値:
nostructure チェックボックス

getCondHandl

public String getCondHandl()
選択: 条件行処理 (SD 伝票変更)を取得します。

戻り値:
condHandl 選択: 条件行処理 (SD 伝票変更)

setPricing

public void setPricing(String pricing)
価格設定タイプを設定します。

パラメータ:
pricing - 価格設定タイプ

setAtpWrkmod

public void setAtpWrkmod(String atpWrkmod)
ATP セッション: 結果取得/新規決定 APO-ATPを設定します。

パラメータ:
atpWrkmod - ATP セッション: 結果取得/新規決定 APO-ATP

setScheduling

public void setScheduling(String scheduling)
単一文字フラグを設定します。

パラメータ:
scheduling - 単一文字フラグ

setNostructure

public void setNostructure(String nostructure)
チェックボックスを設定します。

パラメータ:
nostructure - チェックボックス

setCondHandl

public void setCondHandl(String condHandl)
選択: 条件行処理 (SD 伝票変更)を設定します。

パラメータ:
condHandl - 選択: 条件行処理 (SD 伝票変更)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.sales.common.model (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス
BillingDocumentDetail
BillingDocumentDetailList
CfgsBlob
CfgsInst
CfgsPartOf
CfgsRef
CfgsRefInst
CfgsValue
CfgsVk
ConditionsIn
ConditionsInX
ExtensionIn
HeaderIn
HeaderInX
ItemsIn
ItemsInX
Keys
LogicSwitch
ParamBillingDocumentDetailList
ParamCfgsBlob
ParamCfgsInst
ParamCfgsPartOf
ParamCfgsRef
ParamCfgsRefInst
ParamCfgsValue
ParamCfgsVk
ParamConditionsIn
ParamConditionsInX
ParamExtensionIn
ParamHeaderIn
ParamHeaderInX
ParamItemsIn
ParamItemsInX
ParamKeys
ParamLogicSwitch
ParamPartnerAddresses
ParamPartners
ParamSchedulesIn
ParamSchedulesInX
ParamSender
ParamSuccess
ParamText
PartnerAddresses
Partners
SchedulesIn
SchedulesInX
Sender
Success
Text


jp.co.intra_mart.foundation.sap.module.sales.common.model (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.common.model

クラスの概要
BillingDocumentDetail | 後続請求伝票のテーブル情報クラス 機能は以下の通り 後続請求伝票のテーブル情報を保持します。
BillingDocumentDetailList | 後続請求伝票のテーブル情報クラス 機能は以下の通り 後続請求伝票のテーブル情報を保持します。
CfgsBlob | 選定: BLOB 内部データ (SCE)情報クラス 機能は以下の通り 選定: BLOB 内部データ (SCE)情報を保持します。
CfgsInst | 選定: インスタンス情報クラス 機能は以下の通り 選定: インスタンス情報を保持します。
CfgsPartOf | 選定: 部分設定情報クラス 機能は以下の通り 選定: 部分設定情報を保持します。
CfgsRef | 選定: 参照データ情報クラス 機能は以下の通り 選定: 参照データ情報を保持します。
CfgsRefInst | 選定: 参照明細/インスタンス情報クラス 機能は以下の通り 選定: 参照明細/インスタンス情報を保持します。
CfgsValue | 選定: 特性値情報クラス 機能は以下の通り 選定: 特性値情報を保持します。
CfgsVk | 選定: バリアント条件キー情報クラス 機能は以下の通り 選定: バリアント条件キー情報を保持します。
ConditionsIn | 条件情報クラス 機能は以下の通り 条件情報を保持します。
ConditionsInX | 受注における条件更新の通信項目情報クラス 機能は以下の通り 受注における条件更新の通信項目情報を保持します。
ExtensionIn | VBAK、VBAP、VBEP のカスタマ拡張情報クラス 機能は以下の通り VBAK、VBAP、VBEP のカスタマ拡張情報を保持します。
HeaderIn | 販売伝票ヘッダデータ情報クラス 機能は以下の通り 販売伝票ヘッダデータ情報を保持します。
HeaderInX | ヘッダデータチェックボックス情報クラス 機能は以下の通り ヘッダデータチェックボックス情報を保持します。
ItemsIn | 明細データ情報クラス 機能は以下の通り 明細データ情報を保持します。
ItemsInX | 明細データチェックボックス情報クラス 機能は以下の通り 明細データチェックボックス情報を保持します。
Keys | 参照キーの出力テーブル情報クラス 機能は以下の通り 参照キーの出力テーブル情報を保持します。
LogicSwitch | 内部制御パラメータ情報クラス 機能は以下の通り 内部制御パラメータ情報を保持します。
ParamBillingDocumentDetailList | 後続請求伝票のテーブルパラメータ設定クラス 機能は以下の通り 後続請求伝票のテーブルのパラメータを設定します。
ParamCfgsBlob | 選定: BLOB 内部データ (SCE)パラメータ設定クラス 機能は以下の通り 選定: BLOB 内部データ (SCE)のパラメータを設定します。
ParamCfgsInst | 選定: インスタンスパラメータ設定クラス 機能は以下の通り 選定: インスタンスのパラメータを設定します。
ParamCfgsPartOf | 選定: 部分設定パラメータ設定クラス 機能は以下の通り 選定: 部分設定のパラメータを設定します。
ParamCfgsRef | 選定: 参照データパラメータ設定クラス 機能は以下の通り 選定: 参照データのパラメータを設定します。
ParamCfgsRefInst | 選定: 参照明細/インスタンスパラメータ設定クラス 機能は以下の通り 選定: 参照明細/インスタンスのパラメータを設定します。
ParamCfgsValue | 選定: 特性値パラメータ設定クラス 機能は以下の通り 選定: 特性値のパラメータを設定します。
ParamCfgsVk | 選定: バリアント条件キーパラメータ設定クラス 機能は以下の通り 選定: バリアント条件キーのパラメータを設定します。
ParamConditionsIn | 条件パラメータ設定クラス 機能は以下の通り 条件のパラメータを設定します。
ParamConditionsInX | 受注における条件更新の通信項目パラメータ設定クラス 機能は以下の通り 受注における条件更新の通信項目のパラメータを設定します。
ParamExtensionIn | VBAK、VBAP、VBEP のカスタマ拡張パラメータ設定クラス 機能は以下の通り VBAK、VBAP、VBEP のカスタマ拡張のパラメータを設定します。
ParamHeaderIn | 販売伝票ヘッダデータセグメントパラメータ設定クラス 機能は以下の通り 販売伝票ヘッダデータのパラメータを設定します。
ParamHeaderInX | ヘッダデータチェックボックスパラメータ設定クラス 機能は以下の通り ヘッダデータチェックボックスのパラメータを設定します。
ParamItemsIn | 明細データパラメータ設定クラス 機能は以下の通り 明細データのパラメータを設定します。
ParamItemsInX | 明細データチェックボックス のパラメータ設定クラス 機能は以下の通り 明細データチェックボックスのパラメータを設定します。
ParamKeys | 参照キーパラメータ設定クラス 機能は以下の通り 参照キーのパラメータを設定します。
ParamLogicSwitch | 内部制御パラメータパラメータ設定クラス 機能は以下の通り 内部制御パラメータのパラメータを設定します。
ParamPartnerAddresses | アドレス (組織/会社) 用 BAPI 参照構造パラメータ設定クラス 機能は以下の通り アドレス (組織/会社) 用 BAPI 参照構造のパラメータを設定します。
ParamPartners | 伝票取引先パラメータ設定クラス 機能は以下の通り 伝票取引先のパラメータを設定します。
ParamSchedulesIn | 納入日程行パラメータ設定クラス 機能は以下の通り 納入日程行のパラメータを設定します。
ParamSchedulesInX | 納入日程行チェックボックスパラメータ設定クラス 機能は以下の通り 納入日程行チェックボックスのパラメータを設定します。
ParamSender | 論理システム - 送信者セグメントパラメータ設定クラス 機能は以下の通り 論理システム - 送信者のパラメータを設定します。
ParamSuccess | 後続請求伝票の明細テーブルパラメータ設定クラス 機能は以下の通り 後続請求伝票の明細テーブルのパラメータを設定します。
ParamText | テキストパラメータ設定クラス 機能は以下の通り テキストのパラメータを設定します。
PartnerAddresses | アドレス (組織/会社) 用 BAPI 参照構造情報クラス 機能は以下の通り アドレス (組織/会社) 用 BAPI 参照構造情報を保持します。
Partners | 伝票取引先情報クラス 機能は以下の通り 伝票取引先情報を保持します。
SchedulesIn | 納入日程行情報クラス 機能は以下の通り 納入日程行情報を保持します。
SchedulesInX | 納入日程行チェックボックス情報クラス 機能は以下の通り 納入日程行チェックボックス情報を保持します。
Sender | 論理システム - 送信者情報クラス 機能は以下の通り 論理システム - 送信者情報を保持します。
Success | 正常に処理された明細のテーブル情報クラス 機能は以下の通り 正常に処理された明細のテーブル情報を保持します。
Text | テキスト情報クラス 機能は以下の通り テキスト情報を保持します。


jp.co.intra_mart.foundation.sap.module.sales.common.model クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.common.model の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales.common.model の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.common.model の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail
jp.co.intra_mart.foundation.sap.module.sales.common.model
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.common.model のクラス
BillingDocumentDetail
後続請求伝票のテーブル情報クラス
機能は以下の通り
後続請求伝票のテーブル情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail により使用される jp.co.intra_mart.foundation.sap.module.sales.common.model のクラス
BillingDocumentDetail
後続請求伝票のテーブル情報クラス
機能は以下の通り
後続請求伝票のテーブル情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.common.model により使用される jp.co.intra_mart.foundation.sap.module.sales.common.model のクラス
BillingDocumentDetail
後続請求伝票のテーブル情報クラス
機能は以下の通り
後続請求伝票のテーブル情報を保持します。
HeaderIn
販売伝票ヘッダデータ情報クラス
機能は以下の通り
販売伝票ヘッダデータ情報を保持します。
HeaderInX
ヘッダデータチェックボックス情報クラス
機能は以下の通り
ヘッダデータチェックボックス情報を保持します。
LogicSwitch
内部制御パラメータ情報クラス
機能は以下の通り
内部制御パラメータ情報を保持します。
Sender
論理システム - 送信者情報クラス
機能は以下の通り
論理システム - 送信者情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.module.sales.common.model のクラス
HeaderIn
販売伝票ヘッダデータ情報クラス
機能は以下の通り
販売伝票ヘッダデータ情報を保持します。
HeaderInX
ヘッダデータチェックボックス情報クラス
機能は以下の通り
ヘッダデータチェックボックス情報を保持します。
LogicSwitch
内部制御パラメータ情報クラス
機能は以下の通り
内部制御パラメータ情報を保持します。
Sender
論理システム - 送信者情報クラス
機能は以下の通り
論理システム - 送信者情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.module.sales.common.model のクラス
HeaderIn
販売伝票ヘッダデータ情報クラス
機能は以下の通り
販売伝票ヘッダデータ情報を保持します。
HeaderInX
ヘッダデータチェックボックス情報クラス
機能は以下の通り
ヘッダデータチェックボックス情報を保持します。
LogicSwitch
内部制御パラメータ情報クラス
機能は以下の通り
内部制御パラメータ情報を保持します。
Sender
論理システム - 送信者情報クラス
機能は以下の通り
論理システム - 送信者情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.module.sales.common.model のクラス
HeaderIn
販売伝票ヘッダデータ情報クラス
機能は以下の通り
販売伝票ヘッダデータ情報を保持します。
HeaderInX
ヘッダデータチェックボックス情報クラス
機能は以下の通り
ヘッダデータチェックボックス情報を保持します。
LogicSwitch
内部制御パラメータ情報クラス
機能は以下の通り
内部制御パラメータ情報を保持します。
Sender
論理システム - 送信者情報クラス
機能は以下の通り
論理システム - 送信者情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamBillingDocumentDetailList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamBillingDocumentDetailList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList
すべての実装インタフェース:
Serializable
public final class ParamBillingDocumentDetailList
extends Object
implements Serializable

後続請求伝票のテーブルパラメータ設定クラス
機能は以下の通り

    後続請求伝票のテーブルのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List billingDocumentDetailListList) table(Export)情報から請求伝票詳細の値をセットします。
static void | setImportParam(BapiController bapiController, List billingDocumentDetailListList) 請求伝票詳細に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List billingDocumentDetailListList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
請求伝票詳細に値をセットします。

パラメータ:
bapiController - BapiController
billingDocumentDetailListList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List billingDocumentDetailListList)
                           throws SAPGeneralSystemException
table(Export)情報から請求伝票詳細の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
billingDocumentDetailListList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCfgsBlob (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamCfgsBlob

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob
すべての実装インタフェース:
Serializable
public final class ParamCfgsBlob
extends Object
implements Serializable

選定: BLOB 内部データ (SCE)パラメータ設定クラス
機能は以下の通り

  • 選定: BLOB 内部データ (SCE)のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List cfgsBlobList, String paramType) table(Export)情報から選定: BLOB 内部データ (SCE)の値をセットします。
static void | setImportParam(BapiController bapiController, List cfgsBlobList, String paramType) 選定: BLOB 内部データ (SCE)に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List cfgsBlobList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
選定: BLOB 内部データ (SCE)に値をセットします。

パラメータ:
bapiController - BapiController
cfgsBlobList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List cfgsBlobList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から選定: BLOB 内部データ (SCE)の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
cfgsBlobList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCfgsInst (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamCfgsInst

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst
すべての実装インタフェース:
Serializable
public final class ParamCfgsInst
extends Object
implements Serializable

選定: インスタンスパラメータ設定クラス
機能は以下の通り

  • 選定: インスタンスのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List cfgsInstList, String paramType) table(Export)情報から選定: インスタンスの値をセットします。
static void | setImportParam(BapiController bapiController, List cfgsInstList, String paramType) 選定: インスタンスに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List cfgsInstList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
選定: インスタンスに値をセットします。

パラメータ:
bapiController - BapiController
cfgsInstList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List cfgsInstList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から選定: インスタンスの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
cfgsInstList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCfgsPartOf (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamCfgsPartOf

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf
すべての実装インタフェース:
Serializable
public final class ParamCfgsPartOf
extends Object
implements Serializable

選定: 部分設定パラメータ設定クラス
機能は以下の通り

  • 選定: 部分設定のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List cfgsPartOfList, String paramType) table(Export)情報から選定: 部分設定の値をセットします。
static void | setImportParam(BapiController bapiController, List cfgsPartOfList, String paramType) 選定: 部分設定に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List cfgsPartOfList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
選定: 部分設定に値をセットします。

パラメータ:
bapiController - BapiController
cfgsPartOfList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List cfgsPartOfList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から選定: 部分設定の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
cfgsPartOfList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCfgsRef (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamCfgsRef

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef
すべての実装インタフェース:
Serializable
public final class ParamCfgsRef
extends Object
implements Serializable

選定: 参照データパラメータ設定クラス
機能は以下の通り

  • 選定: 参照データのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List cfgsRefList, String paramType) table(Export)情報から選定: 参照データの値をセットします。
static void | setImportParam(BapiController bapiController, List cfgsRefList, String paramType) 選定: 参照データに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List cfgsRefList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
選定: 参照データに値をセットします。

パラメータ:
bapiController - BapiController
cfgsRefList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List cfgsRefList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から選定: 参照データの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
cfgsRefList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCfgsRefInst (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamCfgsRefInst

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst
すべての実装インタフェース:
Serializable
public final class ParamCfgsRefInst
extends Object
implements Serializable

選定: 参照明細/インスタンスパラメータ設定クラス
機能は以下の通り

  • 選定: 参照明細/インスタンスのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List cfgsRefInstList, String paramType) table(Export)情報から選定: 参照明細/インスタンスの値をセットします。
static void | setImportParam(BapiController bapiController, List cfgsRefInstList, String paramType) 選定: 参照明細/インスタンスに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List cfgsRefInstList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
選定: 参照明細/インスタンスに値をセットします。

パラメータ:
bapiController - BapiController
cfgsRefInstList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List cfgsRefInstList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から選定: 参照明細/インスタンスの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
cfgsRefInstList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCfgsValue (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamCfgsValue

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue
すべての実装インタフェース:
Serializable
public final class ParamCfgsValue
extends Object
implements Serializable

選定: 特性値パラメータ設定クラス
機能は以下の通り

  • 選定: 特性値のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List cfgsValueList, String paramType) table(Export)情報から選定: 特性値の値をセットします。
static void | setImportParam(BapiController bapiController, List cfgsValueList, String paramType) 選定: 特性値に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List cfgsValueList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
選定: 特性値に値をセットします。

パラメータ:
bapiController - BapiController
cfgsValueList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List cfgsValueList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から選定: 特性値の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
cfgsValueList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCfgsVk (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamCfgsVk

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk
すべての実装インタフェース:
Serializable
public final class ParamCfgsVk
extends Object
implements Serializable

選定: バリアント条件キーパラメータ設定クラス
機能は以下の通り

  • 選定: バリアント条件キーのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List cfgsVkList, String paramType) table(Export)情報から明細データの値をセットします。
static void | setImportParam(BapiController bapiController, List cfgsVkList, String paramType) 選定: バリアント条件キーに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List cfgsVkList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
選定: バリアント条件キーに値をセットします。

パラメータ:
bapiController - BapiController
cfgsVkList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List cfgsVkList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から明細データの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
cfgsVkList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamConditionsIn (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamConditionsIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn
すべての実装インタフェース:
Serializable
public final class ParamConditionsIn
extends Object
implements Serializable

条件パラメータ設定クラス
機能は以下の通り

  • 条件のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List conditionsInList, String paramType) table(Export)情報から条件の値をセットします。
static void | setImportParam(BapiController bapiController, List conditionsInList, String paramType) 条件に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List conditionsInList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
条件に値をセットします。

パラメータ:
bapiController - BapiController
conditionsInList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List conditionsInList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から条件の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
conditionsInList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamConditionsInX (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamConditionsInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX
すべての実装インタフェース:
Serializable
public final class ParamConditionsInX
extends Object
implements Serializable

受注における条件更新の通信項目パラメータ設定クラス
機能は以下の通り

  • 受注における条件更新の通信項目のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List conditionsInXList, String paramType) table(Export)情報から受注における条件更新の通信項目の値をセットします。
static void | setImportParam(BapiController bapiController, List conditionsInXList, String paramType) 受注における条件更新の通信項目に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List conditionsInXList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
受注における条件更新の通信項目に値をセットします。

パラメータ:
bapiController - BapiController
conditionsInXList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List conditionsInXList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から受注における条件更新の通信項目の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
conditionsInXList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamExtensionIn (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamExtensionIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn
すべての実装インタフェース:
Serializable
public final class ParamExtensionIn
extends Object
implements Serializable

VBAK、VBAP、VBEP のカスタマ拡張パラメータ設定クラス
機能は以下の通り

  • VBAK、VBAP、VBEP のカスタマ拡張のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List extensionInList) table(Export)情報からVBAK、VBAP、VBEP のカスタマ拡張の値をセットします。
static void | setImportParam(BapiController bapiController, List extensionInList) VBAK、VBAP、VBEP のカスタマ拡張に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List extensionInList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
VBAK、VBAP、VBEP のカスタマ拡張に値をセットします。

パラメータ:
bapiController - BapiController
extensionInList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List extensionInList)
                           throws SAPGeneralSystemException
table(Export)情報からVBAK、VBAP、VBEP のカスタマ拡張の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
extensionInList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamHeaderIn (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamHeaderIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn
すべての実装インタフェース:
Serializable
public final class ParamHeaderIn
extends Object
implements Serializable

販売伝票ヘッダデータセグメントパラメータ設定クラス
機能は以下の通り

  • 販売伝票ヘッダデータのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, HeaderIn headerIn, String paramType)
販売伝票ヘッダデータに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  HeaderIn headerIn,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
販売伝票ヘッダデータに値をセットします。

パラメータ:
bapiController - BapiController
headerIn - HeaderIn
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamHeaderInX (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamHeaderInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX
すべての実装インタフェース:
Serializable
public final class ParamHeaderInX
extends Object
implements Serializable

ヘッダデータチェックボックスパラメータ設定クラス
機能は以下の通り

  • ヘッダデータチェックボックスのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, HeaderInX headerInX, String paramType)
ヘッダデータチェックボックスに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  HeaderInX headerInX,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
ヘッダデータチェックボックスに値をセットします。

パラメータ:
bapiController - BapiController
headerInX - HeaderInX
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamItemsIn (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamItemsIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn
すべての実装インタフェース:
Serializable
public final class ParamItemsIn
extends Object
implements Serializable

明細データパラメータ設定クラス
機能は以下の通り

  • 明細データのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List itemsInList, String paramType) table(Export)情報から明細データの値をセットします。
static void | setImportParam(BapiController bapiController, List itemsInList, String paramType) 明細データに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List itemsInList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
明細データに値をセットします。

パラメータ:
bapiController - BapiController
itemsInList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List itemsInList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から明細データの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
itemsInList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamItemsInX (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamItemsInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX
すべての実装インタフェース:
Serializable
public final class ParamItemsInX
extends Object
implements Serializable

明細データチェックボックス のパラメータ設定クラス
機能は以下の通り

  • 明細データチェックボックスのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List itemsInXList, String paramType) table(Export)情報から明細データチェックボックスの値をセットします。
static void | setImportParam(BapiController bapiController, List itemsInXList, String paramType) 明細データに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List itemsInXList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
明細データに値をセットします。

パラメータ:
bapiController - BapiController
itemsInXList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List itemsInXList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から明細データチェックボックスの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
itemsInXList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamKeys (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamKeys

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys
すべての実装インタフェース:
Serializable
public final class ParamKeys
extends Object
implements Serializable

参照キーパラメータ設定クラス
機能は以下の通り

  • 参照キーのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List keysList, String paramType) table(Export)情報から参照キーの出力テーブルの値をセットします。
static void | setImportParam(BapiController bapiController, List keysList, String paramType) 参照キーの出力テーブルに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List keysList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
参照キーの出力テーブルに値をセットします。

パラメータ:
bapiController - BapiController
keysList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List keysList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から参照キーの出力テーブルの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
keysList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamLogicSwitch (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamLogicSwitch

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch
すべての実装インタフェース:
Serializable
public final class ParamLogicSwitch
extends Object
implements Serializable

内部制御パラメータパラメータ設定クラス
機能は以下の通り

  • 内部制御パラメータのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, LogicSwitch logicSwitch)
内部制御パラメータに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  LogicSwitch logicSwitch)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
内部制御パラメータに値をセットします。

パラメータ:
bapiController - BapiController
logicSwitch - LogicSwitch
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPartnerAddresses (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamPartnerAddresses

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses
すべての実装インタフェース:
Serializable
public final class ParamPartnerAddresses
extends Object
implements Serializable

アドレス (組織/会社) 用 BAPI 参照構造パラメータ設定クラス
機能は以下の通り

  • アドレス (組織/会社) 用 BAPI 参照構造のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List partnerAddressesList) table(Export)情報からアドレス (組織/会社) 用 BAPI 参照構造の値をセットします。
static void | setImportParam(BapiController bapiController, List partnerAddressesList) アドレス (組織/会社) 用 BAPI 参照構造に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List partnerAddressesList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
アドレス (組織/会社) 用 BAPI 参照構造に値をセットします。

パラメータ:
bapiController - BapiController
partnerAddressesList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List partnerAddressesList)
                           throws SAPGeneralSystemException
table(Export)情報からアドレス (組織/会社) 用 BAPI 参照構造の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
partnerAddressesList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPartners (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamPartners

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners
すべての実装インタフェース:
Serializable
public final class ParamPartners
extends Object
implements Serializable

伝票取引先パラメータ設定クラス
機能は以下の通り

  • 伝票取引先のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List partnersList, String paramType) table(Export)情報から伝票取引先の値をセットします。
static void | setImportParam(BapiController bapiController, List partnersList, String paramType) 伝票取引先に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List partnersList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
伝票取引先に値をセットします。

パラメータ:
bapiController - BapiController
partnersList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List partnersList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から伝票取引先の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
partnersList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamSchedulesIn (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamSchedulesIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn
すべての実装インタフェース:
Serializable
public final class ParamSchedulesIn
extends Object
implements Serializable

納入日程行パラメータ設定クラス
機能は以下の通り

  • 納入日程行のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List schedulesInList, String paramType) table(Export)情報から明細データの値をセットします。
static void | setImportParam(BapiController bapiController, List schedulesInList, String paramType) 納入日程行に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List schedulesInList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
納入日程行に値をセットします。

パラメータ:
bapiController - BapiController
schedulesInList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List schedulesInList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から明細データの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
schedulesInList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamSchedulesInX (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamSchedulesInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX
すべての実装インタフェース:
Serializable
public final class ParamSchedulesInX
extends Object
implements Serializable

納入日程行チェックボックスパラメータ設定クラス
機能は以下の通り

  • 納入日程行チェックボックスのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List schedulesInXList, String paramType) table(Export)情報から納入日程行チェックボックスの値をセットします。
static void | setImportParam(BapiController bapiController, List schedulesInXList, String paramType) 納入日程行チェックボックスに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List schedulesInXList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
納入日程行チェックボックスに値をセットします。

パラメータ:
bapiController - BapiController
schedulesInXList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List schedulesInXList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から納入日程行チェックボックスの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
schedulesInXList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamSender (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamSender

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender
すべての実装インタフェース:
Serializable
public final class ParamSender
extends Object
implements Serializable

論理システム - 送信者セグメントパラメータ設定クラス
機能は以下の通り

  • 論理システム - 送信者のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, Sender sender)
論理システム - 送信者に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  Sender sender)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
論理システム - 送信者に値をセットします。

パラメータ:
bapiController - BapiController
sender - Sender
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamSuccess (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamSuccess

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess
すべての実装インタフェース:
Serializable
public final class ParamSuccess
extends Object
implements Serializable

後続請求伝票の明細テーブルパラメータ設定クラス
機能は以下の通り

  • 後続請求伝票の明細テーブルのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List successList) table(Export)情報から後続請求伝票の明細テーブルの値をセットします。
static void | setImportParam(BapiController bapiController, List successList) 後続請求伝票の明細テーブルに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List successList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
後続請求伝票の明細テーブルに値をセットします。

パラメータ:
bapiController - BapiController
successList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List successList)
                           throws SAPGeneralSystemException
table(Export)情報から後続請求伝票の明細テーブルの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
successList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamText (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText
すべての実装インタフェース:
Serializable
public final class ParamText
extends Object
implements Serializable

テキストパラメータ設定クラス
機能は以下の通り

  • テキストのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List textList, String paramType) table(Export)情報からテキストの値をセットします。
static void | setImportParam(BapiController bapiController, List textList, String paramType) テキストに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List textList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
テキストに値をセットします。

パラメータ:
bapiController - BapiController
textList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List textList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報からテキストの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
textList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PartnerAddresses (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス PartnerAddresses

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses
すべての実装インタフェース:
Serializable
public class PartnerAddresses
extends Object
implements Serializable

アドレス (組織/会社) 用 BAPI 参照構造情報クラス
機能は以下の通り

  • アドレス (組織/会社) 用 BAPI 参照構造情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PartnerAddresses()
アドレス (組織/会社) 用 BAPI 参照構造情報を作成します。
PartnerAddresses(int index)
アドレス (組織/会社) 用 BAPI 参照構造情報を作成します。
メソッドの概要
String | getAddrNo() アドレス番号を取得します。
String | getAdrNotes() 住所注記を取得します。
String | getBuilding() 旧: 建物 (番号または略称)を取得します。
String | getBuildLong() 建物 (番号またはコード)を取得します。
String | getChckstatus() 市区町村ファイルテストステータスを取得します。
String | getCity() 市区町村を取得します。
String | getCityNo() 市区町村/地名ファイルの市区町村コードを取得します。
String | getCommType() 通信方法 (キー) (アドレス管理)を取得します。
String | getCOName() 気付を取得します。
String | getCountry() 国コードを取得します。
String | getCountryiso() ISO 国コードを取得します。
String | getDelivDis() 郵便配達地域を取得します。
String | getDistrctNo() 市区町村/地名ファイルの所在地コードを取得します。
String | getDistrict() 所在地を取得します。
String | getDontUseP() 私書箱住所配達不可フラグを取得します。
String | getDontUseS() 地名住所配達不可フラグを取得します。
String | getEMail() 電子メールアドレスを取得します。
String | getFaxExtens() 第一 FAX 番号: 内線を取得します。
String | getFaxNumber() 第一 FAX 番号: ダイヤルコード + 番号を取得します。
String | getFloor() 建物の階を取得します。
String | getFormofaddr() 敬称テキストを取得します。
String | getHomeCity() 市区町村 (郵便用市区町村と異なる場合)を取得します。
String | getHomecityno() 別の市区町村 (市区町村/地名ファイル)を取得します。
String | getHomepage() URI 例: ホームページ、FTP アドレスを取得します。
String | getHouseNo() 番地-号を取得します。
String | getHouseNo2() 番地補足を取得します。
String | getHouseNo3() 番地範囲を取得します。
int | getIndex() レコード番号を取得します｡
String | getLangu() 言語キーを取得します。
String | getLanguCr() アドレスレコード登録オリジナル言語を取得します。
String | getLangucriso() ISO 639 準拠の言語を取得します。
String | getLanguIso() ISO 639 準拠の言語を取得します。
String | getLocation() 地名 5を取得します。
String | getName() 名称 1を取得します。
String | getName2() 名称 2を取得します。
String | getName3() 名称 3を取得します。
String | getName4() 名称 4を取得します。
String | getPboxcitNo() 市区町村私書箱コード (市ファイル)を取得します。
String | getPcode1Ext() 市区町村郵便番号の拡張子 例: 郵便番号 +4+2を取得します。
String | getPcode2Ext() 私書箱郵便番号拡張子 例: 郵便番号 +4+2を取得します。
String | getPcode3Ext() 主要得意先郵便番号拡張子 例: 郵便番号 +4+2を取得します。
String | getPoBox() 私書箱を取得します。
String | getPoBoxCit() 私書箱住所を取得します。
String | getPoboxCtry() 私書箱の国指定を取得します。
String | getPoBoxReg() 私書箱の地域 (国、都道府県、地域、...)を取得します。
String | getPoCtryiso() ISO 国コードを取得します。
String | getPostlCod1() 市区町村の郵便番号を取得します。
String | getPostlCod2() 私書箱郵便番号を取得します。
String | getPostlCod3() 会社郵便番号 (大規模なユーザ用)を取得します。
String | getPoWONo() フラグ: 郵便私書箱 (番号なし)を取得します。
String | getRegiogroup() 地域構造グループ化を取得します。
String | getRegion() 地域 (都道府県)を取得します。
String | getRoomNo() 部屋/アパート番号を取得します。
String | getSort1() 検索条件 1を取得します。
String | getSort2() 検索条件 2を取得します。
String | getStrAbbr() 地名の略称 (例: スペイン)を取得します。
String | getStreet() 地名を取得します。
String | getStreetLng() 地名を取得します。
String | getStreetNo() 市区町村/地名ファイルの地名コードを取得します。
String | getStrSuppl1() 地名 2を取得します。
String | getStrSuppl2() 地名 3を取得します。
String | getStrSuppl3() 地名 4を取得します。
String | getTaxjurcode() 税管轄コードを取得します。
String | getTel1Ext() 第 1 電話番号: 内線を取得します。
String | getTel1Numbr() 第一電話番号: ダイヤルコード + 番号を取得します。
String | getTimeZone() アドレスタイムゾーンを取得します。
String | getTitle() タイトル (敬称)を取得します。
String | getTranspzone() 商品の納入区域を取得します。
void | setAddrNo(String addrNo) アドレス番号を設定します。
void | setAdrNotes(String adrNotes) 住所注記を設定します。
void | setBuilding(String building) 旧: 建物 (番号または略称)を設定します。
void | setBuildLong(String buildLong) 建物 (番号またはコード)を設定します。
void | setChckstatus(String chckstatus) 市区町村ファイルテストステータスを設定します。
void | setCity(String city) 市区町村を設定します。
void | setCityNo(String cityNo) 市区町村/地名ファイルの市区町村コードを設定します。
void | setCommType(String commType) 通信方法 (キー) (アドレス管理)を設定します。
void | setCOName(String cOName) 気付を設定します。
void | setCountry(String country) 国コードを設定します。
void | setCountryiso(String countryiso) ISO 国コードを設定します。
void | setDelivDis(String delivDis) 郵便配達地域を設定します。
void | setDistrctNo(String distrctNo) 市区町村/地名ファイルの所在地コードを設定します。
void | setDistrict(String district) 所在地を設定します。
void | setDontUseP(String dontUseP) 私書箱住所配達不可フラグを設定します。
void | setDontUseS(String dontUseS) 地名住所配達不可フラグを設定します。
void | setEMail(String eMail) 電子メールアドレスを設定します。
void | setFaxExtens(String faxExtens) 第一 FAX 番号: 内線を設定します。
void | setFaxNumber(String faxNumber) 第一 FAX 番号: ダイヤルコード + 番号を設定します。
void | setFloor(String floor) 建物の階を設定します。
void | setFormofaddr(String formofaddr) 敬称テキストを設定します。
void | setHomeCity(String homeCity) 市区町村 (郵便用市区町村と異なる場合)を設定します。
void | setHomecityno(String homecityno) 別の市区町村 (市区町村/地名ファイル)を設定します。
void | setHomepage(String homepage) URI 例: ホームページ、FTP アドレスを設定します。
void | setHouseNo(String houseNo) 番地-号を設定します。
void | setHouseNo2(String houseNo2) 番地補足を設定します。
void | setHouseNo3(String houseNo3) 番地範囲を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLangu(String langu) 言語キーを設定します。
void | setLanguCr(String languCr) アドレスレコード登録オリジナル言語を設定します。
void | setLangucriso(String langucriso) ISO 639 準拠の言語を設定します。
void | setLanguIso(String languIso) ISO 639 準拠の言語を設定します。
void | setLocation(String location) 地名 5を設定します。
void | setName(String name) 名称 1を設定します。
void | setName2(String name2) 名称 2を設定します。
void | setName3(String name3) 名称 3を設定します。
void | setName4(String name4) 名称 4を設定します。
void | setPboxcitNo(String pboxcitNo) 市区町村私書箱コード (市ファイル)を設定します。
void | setPcode1Ext(String pcode1Ext) 市区町村郵便番号の拡張子 例: 郵便番号 +4+2を設定します。
void | setPcode2Ext(String pcode2Ext) 私書箱郵便番号拡張子 例: 郵便番号 +4+2を設定します。
void | setPcode3Ext(String pcode3Ext) 主要得意先郵便番号拡張子 例: 郵便番号 +4+2を設定します。
void | setPoBox(String poBox) 私書箱を設定します。
void | setPoBoxCit(String poBoxCit) 私書箱住所を設定します。
void | setPoboxCtry(String poboxCtry) 私書箱の国指定を設定します。
void | setPoBoxReg(String poBoxReg) 私書箱の地域 (国、都道府県、地域、...)を設定します。
void | setPoCtryiso(String poCtryiso) ISO 国コードを設定します。
void | setPostlCod1(String postlCod1) 市区町村の郵便番号を設定します。
void | setPostlCod2(String postlCod2) 私書箱郵便番号を設定します。
void | setPostlCod3(String postlCod3) 会社郵便番号 (大規模なユーザ用)を設定します。
void | setPoWONo(String poWONo) フラグ: 郵便私書箱 (番号なし)を設定します。
void | setRegiogroup(String regiogroup) 地域構造グループ化を設定します。
void | setRegion(String region) 地域 (都道府県)を設定します。
void | setRoomNo(String roomNo) 部屋/アパート番号を設定します。
void | setSort1(String sort1) 検索条件 1を設定します。
void | setSort2(String sort2) 検索条件 2を設定します。
void | setStrAbbr(String strAbbr) 地名の略称 (例: スペイン)を設定します。
void | setStreet(String street) 地名を設定します。
void | setStreetLng(String streetLng) 地名を設定します。
void | setStreetNo(String streetNo) 市区町村/地名ファイルの地名コードを設定します。
void | setStrSuppl1(String strSuppl1) 地名 2を設定します。
void | setStrSuppl2(String strSuppl2) 地名 3を設定します。
void | setStrSuppl3(String strSuppl3) 地名 4を設定します。
void | setTaxjurcode(String taxjurcode) 税管轄コードを設定します。
void | setTel1Ext(String tel1Ext) 第 1 電話番号: 内線を設定します。
void | setTel1Numbr(String tel1Numbr) 第一電話番号: ダイヤルコード + 番号を設定します。
void | setTimeZone(String timeZone) アドレスタイムゾーンを設定します。
void | setTitle(String title) タイトル (敬称)を設定します。
void | setTranspzone(String transpzone) 商品の納入区域を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PartnerAddresses

public PartnerAddresses()
アドレス (組織/会社) 用 BAPI 参照構造情報を作成します。

PartnerAddresses

public PartnerAddresses(int index)
アドレス (組織/会社) 用 BAPI 参照構造情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getAddrNo

public String getAddrNo()
アドレス番号を取得します。

戻り値:
addrNo アドレス番号

getFormofaddr

public String getFormofaddr()
敬称テキストを取得します。

戻り値:
formofaddr 敬称テキスト

getName

public String getName()
名称 1を取得します。

戻り値:
name 名称 1

getName2

public String getName2()
名称 2を取得します。

戻り値:
name2 名称 2

getName3

public String getName3()
名称 3を取得します。

戻り値:
name3 名称 3

getName4

public String getName4()
名称 4を取得します。

戻り値:
name4 名称 4

getCOName

public String getCOName()
気付を取得します。

戻り値:
cOName 気付

getCity

public String getCity()
市区町村を取得します。

戻り値:
city 市区町村

getDistrict

public String getDistrict()
所在地を取得します。

戻り値:
district 所在地

getCityNo

public String getCityNo()
市区町村/地名ファイルの市区町村コードを取得します。

戻り値:
cityNo 市区町村/地名ファイルの市区町村コード

getPostlCod1

public String getPostlCod1()
市区町村の郵便番号を取得します。

戻り値:
postlCod1 市区町村の郵便番号

getPostlCod2

public String getPostlCod2()
私書箱郵便番号を取得します。

戻り値:
postlCod2 私書箱郵便番号

getPostlCod3

public String getPostlCod3()
会社郵便番号 (大規模なユーザ用)を取得します。

戻り値:
postlCod3 会社郵便番号 (大規模なユーザ用)

getPoBox

public String getPoBox()
私書箱を取得します。

戻り値:
poBox 私書箱

getPoBoxCit

public String getPoBoxCit()
私書箱住所を取得します。

戻り値:
poBoxCit 私書箱住所

getDelivDis

public String getDelivDis()
郵便配達地域を取得します。

戻り値:
delivDis 郵便配達地域

getStreet

public String getStreet()
地名を取得します。

戻り値:
street 地名

getStreetNo

public String getStreetNo()
市区町村/地名ファイルの地名コードを取得します。

戻り値:
streetNo 市区町村/地名ファイルの地名コード

getStrAbbr

public String getStrAbbr()
地名の略称 (例: スペイン)を取得します。

戻り値:
strAbbr 地名の略称 (例: スペイン)

getHouseNo

public String getHouseNo()
番地-号を取得します。

戻り値:
houseNo 番地-号

getStrSuppl1

public String getStrSuppl1()
地名 2を取得します。

戻り値:
strSuppl1 地名 2

getStrSuppl2

public String getStrSuppl2()
地名 3を取得します。

戻り値:
strSuppl2 地名 3

getLocation

public String getLocation()
地名 5を取得します。

戻り値:
location 地名 5

getBuilding

public String getBuilding()
旧: 建物 (番号または略称)を取得します。

戻り値:
building 旧: 建物 (番号または略称)

getFloor

public String getFloor()
建物の階を取得します。

戻り値:
floor 建物の階

getRoomNo

public String getRoomNo()
部屋/アパート番号を取得します。

戻り値:
roomNo 部屋/アパート番号

getCountry

public String getCountry()
国コードを取得します。

戻り値:
country 国コード

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
langu 言語キー

getRegion

public String getRegion()
地域 (都道府県)を取得します。

戻り値:
region 地域 (都道府県)

getSort1

public String getSort1()
検索条件 1を取得します。

戻り値:
sort1 検索条件 1

getSort2

public String getSort2()
検索条件 2を取得します。

戻り値:
sort2 検索条件 2

getTimeZone

public String getTimeZone()
アドレスタイムゾーンを取得します。

戻り値:
timeZone アドレスタイムゾーン

getTaxjurcode

public String getTaxjurcode()
税管轄コードを取得します。

戻り値:
taxjurcode 税管轄コード

getAdrNotes

public String getAdrNotes()
住所注記を取得します。

戻り値:
adrNotes 住所注記

getCommType

public String getCommType()
通信方法 (キー) (アドレス管理)を取得します。

戻り値:
commType 通信方法 (キー) (アドレス管理)

getTel1Numbr

public String getTel1Numbr()
第一電話番号: ダイヤルコード + 番号を取得します。

戻り値:
tel1Numbr 第一電話番号: ダイヤルコード + 番号

getTel1Ext

public String getTel1Ext()
第 1 電話番号: 内線を取得します。

戻り値:
tel1Ext 第 1 電話番号: 内線

getFaxNumber

public String getFaxNumber()
第一 FAX 番号: ダイヤルコード + 番号を取得します。

戻り値:
faxNumber 第一 FAX 番号: ダイヤルコード + 番号

getFaxExtens

public String getFaxExtens()
第一 FAX 番号: 内線を取得します。

戻り値:
faxExtens 第一 FAX 番号: 内線

getStreetLng

public String getStreetLng()
地名を取得します。

戻り値:
streetLng 地名

getDistrctNo

public String getDistrctNo()
市区町村/地名ファイルの所在地コードを取得します。

戻り値:
distrctNo 市区町村/地名ファイルの所在地コード

getChckstatus

public String getChckstatus()
市区町村ファイルテストステータスを取得します。

戻り値:
chckstatus 市区町村ファイルテストステータス

getPboxcitNo

public String getPboxcitNo()
市区町村私書箱コード (市ファイル)を取得します。

戻り値:
pboxcitNo 市区町村私書箱コード (市ファイル)

getTranspzone

public String getTranspzone()
商品の納入区域を取得します。

戻り値:
transpzone 商品の納入区域

getHouseNo2

public String getHouseNo2()
番地補足を取得します。

戻り値:
houseNo2 番地補足

getEMail

public String getEMail()
電子メールアドレスを取得します。

戻り値:
eMail 電子メールアドレス

getStrSuppl3

public String getStrSuppl3()
地名 4を取得します。

戻り値:
strSuppl3 地名 4

getTitle

public String getTitle()
タイトル (敬称)を取得します。

戻り値:
title タイトル (敬称)

getCountryiso

public String getCountryiso()
ISO 国コードを取得します。

戻り値:
countryiso ISO 国コード

getLanguIso

public String getLanguIso()
ISO 639 準拠の言語を取得します。

戻り値:
languIso ISO 639 準拠の言語

getBuildLong

public String getBuildLong()
建物 (番号またはコード)を取得します。

戻り値:
buildLong 建物 (番号またはコード)

getRegiogroup

public String getRegiogroup()
地域構造グループ化を取得します。

戻り値:
regiogroup 地域構造グループ化

getHomeCity

public String getHomeCity()
市区町村 (郵便用市区町村と異なる場合)を取得します。

戻り値:
homeCity 市区町村 (郵便用市区町村と異なる場合)

getHomecityno

public String getHomecityno()
別の市区町村 (市区町村/地名ファイル)を取得します。

戻り値:
homecityno 別の市区町村 (市区町村/地名ファイル)

getPcode1Ext

public String getPcode1Ext()
市区町村郵便番号の拡張子 例: 郵便番号 +4+2を取得します。

戻り値:
pcode1Ext 市区町村郵便番号の拡張子 例: 郵便番号 +4+2

getPcode2Ext

public String getPcode2Ext()
私書箱郵便番号拡張子 例: 郵便番号 +4+2を取得します。

戻り値:
pcode2Ext 私書箱郵便番号拡張子 例: 郵便番号 +4+2

getPcode3Ext

public String getPcode3Ext()
主要得意先郵便番号拡張子 例: 郵便番号 +4+2を取得します。

戻り値:
pcode3Ext 主要得意先郵便番号拡張子 例: 郵便番号 +4+2

getPoWONo

public String getPoWONo()
フラグ: 郵便私書箱 (番号なし)を取得します。

戻り値:
poWONo フラグ: 郵便私書箱 (番号なし)

getPoBoxReg

public String getPoBoxReg()
私書箱の地域 (国、都道府県、地域、...)を取得します。

戻り値:
poBoxReg 私書箱の地域 (国、都道府県、地域、...)

getPoboxCtry

public String getPoboxCtry()
私書箱の国指定を取得します。

戻り値:
poboxCtry 私書箱の国指定

getPoCtryiso

public String getPoCtryiso()
ISO 国コードを取得します。

戻り値:
poCtryiso ISO 国コード

getHomepage

public String getHomepage()
URI 例: ホームページ、FTP アドレスを取得します。

戻り値:
homepage URI 例: ホームページ、FTP アドレス

getDontUseS

public String getDontUseS()
地名住所配達不可フラグを取得します。

戻り値:
dontUseS 地名住所配達不可フラグ

getDontUseP

public String getDontUseP()
私書箱住所配達不可フラグを取得します。

戻り値:
dontUseP 私書箱住所配達不可フラグ

getHouseNo3

public String getHouseNo3()
番地範囲を取得します。

戻り値:
houseNo3 番地範囲

getLanguCr

public String getLanguCr()
アドレスレコード登録オリジナル言語を取得します。

戻り値:
languCr アドレスレコード登録オリジナル言語

getLangucriso

public String getLangucriso()
ISO 639 準拠の言語を取得します。

戻り値:
langucriso ISO 639 準拠の言語

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setAddrNo

public void setAddrNo(String addrNo)
アドレス番号を設定します。

パラメータ:
addrNo - アドレス番号

setFormofaddr

public void setFormofaddr(String formofaddr)
敬称テキストを設定します。

パラメータ:
formofaddr - 敬称テキスト

setName

public void setName(String name)
名称 1を設定します。

パラメータ:
name - 名称 1

setName2

public void setName2(String name2)
名称 2を設定します。

パラメータ:
name2 - 名称 2

setName3

public void setName3(String name3)
名称 3を設定します。

パラメータ:
name3 - 名称 3

setName4

public void setName4(String name4)
名称 4を設定します。

パラメータ:
name4 - 名称 4

setCOName

public void setCOName(String cOName)
気付を設定します。

パラメータ:
cOName - 気付

setCity

public void setCity(String city)
市区町村を設定します。

パラメータ:
city - 市区町村

setDistrict

public void setDistrict(String district)
所在地を設定します。

パラメータ:
district - 所在地

setCityNo

public void setCityNo(String cityNo)
市区町村/地名ファイルの市区町村コードを設定します。

パラメータ:
cityNo - 市区町村/地名ファイルの市区町村コード

setPostlCod1

public void setPostlCod1(String postlCod1)
市区町村の郵便番号を設定します。

パラメータ:
postlCod1 - 市区町村の郵便番号

setPostlCod2

public void setPostlCod2(String postlCod2)
私書箱郵便番号を設定します。

パラメータ:
postlCod2 - 私書箱郵便番号

setPostlCod3

public void setPostlCod3(String postlCod3)
会社郵便番号 (大規模なユーザ用)を設定します。

パラメータ:
postlCod3 - 会社郵便番号 (大規模なユーザ用)

setPoBox

public void setPoBox(String poBox)
私書箱を設定します。

パラメータ:
poBox - 私書箱

setPoBoxCit

public void setPoBoxCit(String poBoxCit)
私書箱住所を設定します。

パラメータ:
poBoxCit - 私書箱住所

setDelivDis

public void setDelivDis(String delivDis)
郵便配達地域を設定します。

パラメータ:
delivDis - 郵便配達地域

setStreet

public void setStreet(String street)
地名を設定します。

パラメータ:
street - 地名

setStreetNo

public void setStreetNo(String streetNo)
市区町村/地名ファイルの地名コードを設定します。

パラメータ:
streetNo - 市区町村/地名ファイルの地名コード

setStrAbbr

public void setStrAbbr(String strAbbr)
地名の略称 (例: スペイン)を設定します。

パラメータ:
strAbbr - 地名の略称 (例: スペイン)

setHouseNo

public void setHouseNo(String houseNo)
番地-号を設定します。

パラメータ:
houseNo - 番地-号

setStrSuppl1

public void setStrSuppl1(String strSuppl1)
地名 2を設定します。

パラメータ:
strSuppl1 - 地名 2

setStrSuppl2

public void setStrSuppl2(String strSuppl2)
地名 3を設定します。

パラメータ:
strSuppl2 - 地名 3

setLocation

public void setLocation(String location)
地名 5を設定します。

パラメータ:
location - 地名 5

setBuilding

public void setBuilding(String building)
旧: 建物 (番号または略称)を設定します。

パラメータ:
building - 旧: 建物 (番号または略称)

setFloor

public void setFloor(String floor)
建物の階を設定します。

パラメータ:
floor - 建物の階

setRoomNo

public void setRoomNo(String roomNo)
部屋/アパート番号を設定します。

パラメータ:
roomNo - 部屋/アパート番号

setCountry

public void setCountry(String country)
国コードを設定します。

パラメータ:
country - 国コード

setLangu

public void setLangu(String langu)
言語キーを設定します。

パラメータ:
langu - 言語キー

setRegion

public void setRegion(String region)
地域 (都道府県)を設定します。

パラメータ:
region - 地域 (都道府県)

setSort1

public void setSort1(String sort1)
検索条件 1を設定します。

パラメータ:
sort1 - 検索条件 1

setSort2

public void setSort2(String sort2)
検索条件 2を設定します。

パラメータ:
sort2 - 検索条件 2

setTimeZone

public void setTimeZone(String timeZone)
アドレスタイムゾーンを設定します。

パラメータ:
timeZone - アドレスタイムゾーン

setTaxjurcode

public void setTaxjurcode(String taxjurcode)
税管轄コードを設定します。

パラメータ:
taxjurcode - 税管轄コード

setAdrNotes

public void setAdrNotes(String adrNotes)
住所注記を設定します。

パラメータ:
adrNotes - 住所注記

setCommType

public void setCommType(String commType)
通信方法 (キー) (アドレス管理)を設定します。

パラメータ:
commType - 通信方法 (キー) (アドレス管理)

setTel1Numbr

public void setTel1Numbr(String tel1Numbr)
第一電話番号: ダイヤルコード + 番号を設定します。

パラメータ:
tel1Numbr - 第一電話番号: ダイヤルコード + 番号

setTel1Ext

public void setTel1Ext(String tel1Ext)
第 1 電話番号: 内線を設定します。

パラメータ:
tel1Ext - 第 1 電話番号: 内線

setFaxNumber

public void setFaxNumber(String faxNumber)
第一 FAX 番号: ダイヤルコード + 番号を設定します。

パラメータ:
faxNumber - 第一 FAX 番号: ダイヤルコード + 番号

setFaxExtens

public void setFaxExtens(String faxExtens)
第一 FAX 番号: 内線を設定します。

パラメータ:
faxExtens - 第一 FAX 番号: 内線

setStreetLng

public void setStreetLng(String streetLng)
地名を設定します。

パラメータ:
streetLng - 地名

setDistrctNo

public void setDistrctNo(String distrctNo)
市区町村/地名ファイルの所在地コードを設定します。

パラメータ:
distrctNo - 市区町村/地名ファイルの所在地コード

setChckstatus

public void setChckstatus(String chckstatus)
市区町村ファイルテストステータスを設定します。

パラメータ:
chckstatus - 市区町村ファイルテストステータス

setPboxcitNo

public void setPboxcitNo(String pboxcitNo)
市区町村私書箱コード (市ファイル)を設定します。

パラメータ:
pboxcitNo - 市区町村私書箱コード (市ファイル)

setTranspzone

public void setTranspzone(String transpzone)
商品の納入区域を設定します。

パラメータ:
transpzone - 商品の納入区域

setHouseNo2

public void setHouseNo2(String houseNo2)
番地補足を設定します。

パラメータ:
houseNo2 - 番地補足

setEMail

public void setEMail(String eMail)
電子メールアドレスを設定します。

パラメータ:
eMail - 電子メールアドレス

setStrSuppl3

public void setStrSuppl3(String strSuppl3)
地名 4を設定します。

パラメータ:
strSuppl3 - 地名 4

setTitle

public void setTitle(String title)
タイトル (敬称)を設定します。

パラメータ:
title - タイトル (敬称)

setCountryiso

public void setCountryiso(String countryiso)
ISO 国コードを設定します。

パラメータ:
countryiso - ISO 国コード

setLanguIso

public void setLanguIso(String languIso)
ISO 639 準拠の言語を設定します。

パラメータ:
languIso - ISO 639 準拠の言語

setBuildLong

public void setBuildLong(String buildLong)
建物 (番号またはコード)を設定します。

パラメータ:
buildLong - 建物 (番号またはコード)

setRegiogroup

public void setRegiogroup(String regiogroup)
地域構造グループ化を設定します。

パラメータ:
regiogroup - 地域構造グループ化

setHomeCity

public void setHomeCity(String homeCity)
市区町村 (郵便用市区町村と異なる場合)を設定します。

パラメータ:
homeCity - 市区町村 (郵便用市区町村と異なる場合)

setHomecityno

public void setHomecityno(String homecityno)
別の市区町村 (市区町村/地名ファイル)を設定します。

パラメータ:
homecityno - 別の市区町村 (市区町村/地名ファイル)

setPcode1Ext

public void setPcode1Ext(String pcode1Ext)
市区町村郵便番号の拡張子 例: 郵便番号 +4+2を設定します。

パラメータ:
pcode1Ext - 市区町村郵便番号の拡張子 例: 郵便番号 +4+2

setPcode2Ext

public void setPcode2Ext(String pcode2Ext)
私書箱郵便番号拡張子 例: 郵便番号 +4+2を設定します。

パラメータ:
pcode2Ext - 私書箱郵便番号拡張子 例: 郵便番号 +4+2

setPcode3Ext

public void setPcode3Ext(String pcode3Ext)
主要得意先郵便番号拡張子 例: 郵便番号 +4+2を設定します。

パラメータ:
pcode3Ext - 主要得意先郵便番号拡張子 例: 郵便番号 +4+2

setPoWONo

public void setPoWONo(String poWONo)
フラグ: 郵便私書箱 (番号なし)を設定します。

パラメータ:
poWONo - フラグ: 郵便私書箱 (番号なし)

setPoBoxReg

public void setPoBoxReg(String poBoxReg)
私書箱の地域 (国、都道府県、地域、...)を設定します。

パラメータ:
poBoxReg - 私書箱の地域 (国、都道府県、地域、...)

setPoboxCtry

public void setPoboxCtry(String poboxCtry)
私書箱の国指定を設定します。

パラメータ:
poboxCtry - 私書箱の国指定

setPoCtryiso

public void setPoCtryiso(String poCtryiso)
ISO 国コードを設定します。

パラメータ:
poCtryiso - ISO 国コード

setHomepage

public void setHomepage(String homepage)
URI 例: ホームページ、FTP アドレスを設定します。

パラメータ:
homepage - URI 例: ホームページ、FTP アドレス

setDontUseS

public void setDontUseS(String dontUseS)
地名住所配達不可フラグを設定します。

パラメータ:
dontUseS - 地名住所配達不可フラグ

setDontUseP

public void setDontUseP(String dontUseP)
私書箱住所配達不可フラグを設定します。

パラメータ:
dontUseP - 私書箱住所配達不可フラグ

setHouseNo3

public void setHouseNo3(String houseNo3)
番地範囲を設定します。

パラメータ:
houseNo3 - 番地範囲

setLanguCr

public void setLanguCr(String languCr)
アドレスレコード登録オリジナル言語を設定します。

パラメータ:
languCr - アドレスレコード登録オリジナル言語

setLangucriso

public void setLangucriso(String langucriso)
ISO 639 準拠の言語を設定します。

パラメータ:
langucriso - ISO 639 準拠の言語

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Partners (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス Partners

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners
すべての実装インタフェース:
Serializable
public class Partners
extends Object
implements Serializable

伝票取引先情報クラス
機能は以下の通り

  • 伝票取引先情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Partners()
伝票取引先情報を作成します。
Partners(int index)
伝票取引先情報を作成します。
メソッドの概要
String | getAddress() 住所を取得します。
String | getAddrLink() 住所コードへのリンクを取得します。
String | getAddrOrig() コピー元住所を取得します。
String | getAddrType() アドレスタイプ (1=組織、2=個人、3=取引先担当者)を取得します。
String | getCity() 市区町村を取得します。
String | getCountrIso() 国キー (ISO コード)を取得します。
String | getCountry() 国コードを取得します。
String | getDistrict() 所在地を取得します。
String | getFaxNumber() FAX 番号を取得します。
int | getIndex() レコード番号を取得します｡
String | getItmNumber() 明細番号 (販売管理伝票)を取得します。
String | getLangu() 言語キーを取得します。
String | getLanguIso() ISO 639 準拠の言語を取得します。
String | getName() 名称 1を取得します。
String | getName2() 名称 2を取得します。
String | getName3() 名称 3を取得します。
String | getName4() 名称 4を取得します。
String | getPartnNumb() 得意先コード 1を取得します。
String | getPartnRole() 取引先機能を取得します。
String | getPoBox() 私書箱を取得します。
String | getPobxCty() 私書箱住所を取得します。
String | getPobxPcd() 私書箱番号を取得します。
String | getPostlCode() 郵便番号を取得します。
String | getPrivAddr() 自宅住所を取得します。
String | getReflogsys() 論理システムを取得します。
String | getRefobjkey() オブジェクトキーを取得します。
String | getRefobjtype() オブジェクトタイプを取得します。
String | getRegion() 地域 (都道府県)を取得します。
String | getStreet() 地名/番地-号を取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getTelebox() テレボックス番号を取得します。
String | getTelephone() 電話番号 1を取得します。
String | getTelephone2() 電話番号 2を取得します。
String | getTeletexNo() テレテクス番号を取得します。
String | getTelexNo() テレックス番号を取得します。
String | getTitle() 敬称を取得します。
String | getTranspzone() 商品の納入区域を取得します。
String | getUnloadPt() 荷渡ポイントを取得します。
void | setAddress(String address) 住所を設定します。
void | setAddrLink(String addrLink) 住所コードへのリンクを設定します。
void | setAddrOrig(String addrOrig) コピー元住所を設定します。
void | setAddrType(String addrType) アドレスタイプ (1=組織、2=個人、3=取引先担当者)を設定します。
void | setCity(String city) 市区町村を設定します。
void | setCountrIso(String countrIso) 国キー (ISO コード)を設定します。
void | setCountry(String country) 国コードを設定します。
void | setDistrict(String district) 所在地を設定します。
void | setFaxNumber(String faxNumber) FAX 番号を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItmNumber(String itmNumber) 明細番号 (販売管理伝票)を設定します。
void | setLangu(String langu) 言語キーを設定します。
void | setLanguIso(String languIso) ISO 639 準拠の言語を設定します。
void | setName(String name) 名称 1を設定します。
void | setName2(String name2) 名称 2を設定します。
void | setName3(String name3) 名称 3を設定します。
void | setName4(String name4) 名称 4を設定します。
void | setPartnNumb(String partnNumb) 得意先コード 1を設定します。
void | setPartnRole(String partnRole) 取引先機能を設定します。
void | setPoBox(String poBox) 私書箱を設定します。
void | setPobxCty(String pobxCty) 私書箱住所を設定します。
void | setPobxPcd(String pobxPcd) 私書箱番号を設定します。
void | setPostlCode(String postlCode) 郵便番号を設定します。
void | setPrivAddr(String privAddr) 自宅住所を設定します。
void | setReflogsys(String reflogsys) 論理システムを設定します。
void | setRefobjkey(String refobjkey) オブジェクトキーを設定します。
void | setRefobjtype(String refobjtype) オブジェクトタイプを設定します。
void | setRegion(String region) 地域 (都道府県)を設定します。
void | setStreet(String street) 地名/番地-号を設定します。
void | setTaxjurcode(String taxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setTelebox(String telebox) テレボックス番号を設定します。
void | setTelephone(String telephone) 電話番号 1を設定します。
void | setTelephone2(String telephone2) 電話番号 2を設定します。
void | setTeletexNo(String teletexNo) テレテクス番号を設定します。
void | setTelexNo(String telexNo) テレックス番号を設定します。
void | setTitle(String title) 敬称を設定します。
void | setTranspzone(String transpzone) 商品の納入区域を設定します。
void | setUnloadPt(String unloadPt) 荷渡ポイントを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Partners

public Partners()
伝票取引先情報を作成します。

Partners

public Partners(int index)
伝票取引先情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPartnRole

public String getPartnRole()
取引先機能を取得します。

戻り値:
partnRole 取引先機能

getPartnNumb

public String getPartnNumb()
得意先コード 1を取得します。

戻り値:
partnNumb 得意先コード 1

getItmNumber

public String getItmNumber()
明細番号 (販売管理伝票)を取得します。

戻り値:
itmNumber 明細番号 (販売管理伝票)

getTitle

public String getTitle()
敬称を取得します。

戻り値:
title 敬称

getName

public String getName()
名称 1を取得します。

戻り値:
name 名称 1

getName2

public String getName2()
名称 2を取得します。

戻り値:
name2 名称 2

getName3

public String getName3()
名称 3を取得します。

戻り値:
name3 名称 3

getName4

public String getName4()
名称 4を取得します。

戻り値:
name4 名称 4

getStreet

public String getStreet()
地名/番地-号を取得します。

戻り値:
street 地名/番地-号

getCountry

public String getCountry()
国コードを取得します。

戻り値:
country 国コード

getCountrIso

public String getCountrIso()
国キー (ISO コード)を取得します。

戻り値:
countrIso 国キー (ISO コード)

getPostlCode

public String getPostlCode()
郵便番号を取得します。

戻り値:
postlCode 郵便番号

getPobxPcd

public String getPobxPcd()
私書箱番号を取得します。

戻り値:
pobxPcd 私書箱番号

getPobxCty

public String getPobxCty()
私書箱住所を取得します。

戻り値:
pobxCty 私書箱住所

getCity

public String getCity()
市区町村を取得します。

戻り値:
city 市区町村

getDistrict

public String getDistrict()
所在地を取得します。

戻り値:
district 所在地

getRegion

public String getRegion()
地域 (都道府県)を取得します。

戻り値:
region 地域 (都道府県)

getPoBox

public String getPoBox()
私書箱を取得します。

戻り値:
poBox 私書箱

getTelephone

public String getTelephone()
電話番号 1を取得します。

戻り値:
telephone 電話番号 1

getTelephone2

public String getTelephone2()
電話番号 2を取得します。

戻り値:
telephone2 電話番号 2

getTelebox

public String getTelebox()
テレボックス番号を取得します。

戻り値:
telebox テレボックス番号

getFaxNumber

public String getFaxNumber()
FAX 番号を取得します。

戻り値:
faxNumber FAX 番号

getTeletexNo

public String getTeletexNo()
テレテクス番号を取得します。

戻り値:
teletexNo テレテクス番号

getTelexNo

public String getTelexNo()
テレックス番号を取得します。

戻り値:
telexNo テレックス番号

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
langu 言語キー

getLanguIso

public String getLanguIso()
ISO 639 準拠の言語を取得します。

戻り値:
languIso ISO 639 準拠の言語

getUnloadPt

public String getUnloadPt()
荷渡ポイントを取得します。

戻り値:
unloadPt 荷渡ポイント

getTranspzone

public String getTranspzone()
商品の納入区域を取得します。

戻り値:
transpzone 商品の納入区域

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
taxjurcode 税計算管轄コード - 税管轄コード

getAddress

public String getAddress()
住所を取得します。

戻り値:
address 住所

getPrivAddr

public String getPrivAddr()
自宅住所を取得します。

戻り値:
privAddr 自宅住所

getAddrType

public String getAddrType()
アドレスタイプ (1=組織、2=個人、3=取引先担当者)を取得します。

戻り値:
addrType アドレスタイプ (1=組織、2=個人、3=取引先担当者)

getAddrOrig

public String getAddrOrig()
コピー元住所を取得します。

戻り値:
addrOrig コピー元住所

getAddrLink

public String getAddrLink()
住所コードへのリンクを取得します。

戻り値:
addrLink 住所コードへのリンク

getRefobjtype

public String getRefobjtype()
オブジェクトタイプを取得します。

戻り値:
refobjtype オブジェクトタイプ

getRefobjkey

public String getRefobjkey()
オブジェクトキーを取得します。

戻り値:
refobjkey オブジェクトキー

getReflogsys

public String getReflogsys()
論理システムを取得します。

戻り値:
reflogsys 論理システム

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setPartnRole

public void setPartnRole(String partnRole)
取引先機能を設定します。

パラメータ:
partnRole - 取引先機能

setPartnNumb

public void setPartnNumb(String partnNumb)
得意先コード 1を設定します。

パラメータ:
partnNumb - 得意先コード 1

setItmNumber

public void setItmNumber(String itmNumber)
明細番号 (販売管理伝票)を設定します。

パラメータ:
itmNumber - 明細番号 (販売管理伝票)

setTitle

public void setTitle(String title)
敬称を設定します。

パラメータ:
title - 敬称

setName

public void setName(String name)
名称 1を設定します。

パラメータ:
name - 名称 1

setName2

public void setName2(String name2)
名称 2を設定します。

パラメータ:
name2 - 名称 2

setName3

public void setName3(String name3)
名称 3を設定します。

パラメータ:
name3 - 名称 3

setName4

public void setName4(String name4)
名称 4を設定します。

パラメータ:
name4 - 名称 4

setStreet

public void setStreet(String street)
地名/番地-号を設定します。

パラメータ:
street - 地名/番地-号

setCountry

public void setCountry(String country)
国コードを設定します。

パラメータ:
country - 国コード

setCountrIso

public void setCountrIso(String countrIso)
国キー (ISO コード)を設定します。

パラメータ:
countrIso - 国キー (ISO コード)

setPostlCode

public void setPostlCode(String postlCode)
郵便番号を設定します。

パラメータ:
postlCode - 郵便番号

setPobxPcd

public void setPobxPcd(String pobxPcd)
私書箱番号を設定します。

パラメータ:
pobxPcd - 私書箱番号

setPobxCty

public void setPobxCty(String pobxCty)
私書箱住所を設定します。

パラメータ:
pobxCty - 私書箱住所

setCity

public void setCity(String city)
市区町村を設定します。

パラメータ:
city - 市区町村

setDistrict

public void setDistrict(String district)
所在地を設定します。

パラメータ:
district - 所在地

setRegion

public void setRegion(String region)
地域 (都道府県)を設定します。

パラメータ:
region - 地域 (都道府県)

setPoBox

public void setPoBox(String poBox)
私書箱を設定します。

パラメータ:
poBox - 私書箱

setTelephone

public void setTelephone(String telephone)
電話番号 1を設定します。

パラメータ:
telephone - 電話番号 1

setTelephone2

public void setTelephone2(String telephone2)
電話番号 2を設定します。

パラメータ:
telephone2 - 電話番号 2

setTelebox

public void setTelebox(String telebox)
テレボックス番号を設定します。

パラメータ:
telebox - テレボックス番号

setFaxNumber

public void setFaxNumber(String faxNumber)
FAX 番号を設定します。

パラメータ:
faxNumber - FAX 番号

setTeletexNo

public void setTeletexNo(String teletexNo)
テレテクス番号を設定します。

パラメータ:
teletexNo - テレテクス番号

setTelexNo

public void setTelexNo(String telexNo)
テレックス番号を設定します。

パラメータ:
telexNo - テレックス番号

setLangu

public void setLangu(String langu)
言語キーを設定します。

パラメータ:
langu - 言語キー

setLanguIso

public void setLanguIso(String languIso)
ISO 639 準拠の言語を設定します。

パラメータ:
languIso - ISO 639 準拠の言語

setUnloadPt

public void setUnloadPt(String unloadPt)
荷渡ポイントを設定します。

パラメータ:
unloadPt - 荷渡ポイント

setTranspzone

public void setTranspzone(String transpzone)
商品の納入区域を設定します。

パラメータ:
transpzone - 商品の納入区域

setTaxjurcode

public void setTaxjurcode(String taxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
taxjurcode - 税計算管轄コード - 税管轄コード

setAddress

public void setAddress(String address)
住所を設定します。

パラメータ:
address - 住所

setPrivAddr

public void setPrivAddr(String privAddr)
自宅住所を設定します。

パラメータ:
privAddr - 自宅住所

setAddrType

public void setAddrType(String addrType)
アドレスタイプ (1=組織、2=個人、3=取引先担当者)を設定します。

パラメータ:
addrType - アドレスタイプ (1=組織、2=個人、3=取引先担当者)

setAddrOrig

public void setAddrOrig(String addrOrig)
コピー元住所を設定します。

パラメータ:
addrOrig - コピー元住所

setAddrLink

public void setAddrLink(String addrLink)
住所コードへのリンクを設定します。

パラメータ:
addrLink - 住所コードへのリンク

setRefobjtype

public void setRefobjtype(String refobjtype)
オブジェクトタイプを設定します。

パラメータ:
refobjtype - オブジェクトタイプ

setRefobjkey

public void setRefobjkey(String refobjkey)
オブジェクトキーを設定します。

パラメータ:
refobjkey - オブジェクトキー

setReflogsys

public void setReflogsys(String reflogsys)
論理システムを設定します。

パラメータ:
reflogsys - 論理システム

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SchedulesIn (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス SchedulesIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn
すべての実装インタフェース:
Serializable
public class SchedulesIn
extends Object
implements Serializable

納入日程行情報クラス
機能は以下の通り

  • 納入日程行情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
SchedulesIn()
納入日程行情報を作成します。
SchedulesIn(int index)
納入日程行情報を作成します。
メソッドの概要
String | getDateType() 日付タイプ (日、週、月、期間)を取得します。
String | getDlvDate() 納入日程日付を取得します。
String | getDlvTime() 納入時間を取得します。
String | getGiDate() 出庫日付を取得します。
String | getGiTime() 出庫時刻 (現地時間 - プラント参照)を取得します。
int | getIndex() レコード番号を取得します｡
String | getItmNumber() 販売伝票明細を取得します。
String | getLoadDate() 積載日付を取得します。
String | getLoadTime() 積載時刻 (現地時間: 出荷ポイント)を取得します。
String | getMsDate() 品目利用可能日を取得します。
String | getMsTime() 品目供給ステージ (現地時刻: プラント参照)を取得します。
String | getPlanSchedType() 納入日程行タイプ EDIを取得します。
String | getReflogsys() 論理システムを取得します。
String | getRefobjkey() オブジェクトキーを取得します。
String | getRefobjtype() オブジェクトタイプを取得します。
String | getRelType() 承認タイプを取得します。
String | getReqDate() 納入日程日付を取得します。
String | getReqDlvBl() 出荷ブロック中の納入日程行を取得します。
String | getReqQty() 販売単位による受注数量を取得します。
String | getReqTime() 納入時間を取得します。
String | getSchedLine() 納入日程行を取得します。
String | getSchedType() 納入日程カテゴリを取得します。
String | getTpDate() 輸送計画日付を取得します。
String | getTpTime() 輸送計画 - 時間 (現地時間/出荷ポイント参照)を取得します。
void | setDateType(String dateType) 日付タイプ (日、週、月、期間)を設定します。
void | setDlvDate(String dlvDate) 納入日程日付を設定します。
void | setDlvTime(String dlvTime) 納入時間を設定します。
void | setGiDate(String giDate) 出庫日付を設定します。
void | setGiTime(String giTime) 出庫時刻 (現地時間 - プラント参照)を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItmNumber(String itmNumber) 販売伝票明細を設定します。
void | setLoadDate(String loadDate) 積載日付を設定します。
void | setLoadTime(String loadTime) 積載時刻 (現地時間: 出荷ポイント)を設定します。
void | setMsDate(String msDate) 品目利用可能日を設定します。
void | setMsTime(String msTime) 品目供給ステージ (現地時刻: プラント参照)を設定します。
void | setPlanSchedType(String planSchedType) 納入日程行タイプ EDIを設定します。
void | setReflogsys(String reflogsys) 論理システムを設定します。
void | setRefobjkey(String refobjkey) オブジェクトキーを設定します。
void | setRefobjtype(String refobjtype) オブジェクトタイプを設定します。
void | setRelType(String relType) 承認タイプを設定します。
void | setReqDate(String reqDate) 納入日程日付を設定します。
void | setReqDlvBl(String reqDlvBl) 出荷ブロック中の納入日程行を設定します。
void | setReqQty(String reqQty) 販売単位による受注数量を設定します。
void | setReqTime(String reqTime) 納入時間を設定します。
void | setSchedLine(String schedLine) 納入日程行を設定します。
void | setSchedType(String schedType) 納入日程カテゴリを設定します。
void | setTpDate(String tpDate) 輸送計画日付を設定します。
void | setTpTime(String tpTime) 輸送計画 - 時間 (現地時間/出荷ポイント参照)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SchedulesIn

public SchedulesIn()
納入日程行情報を作成します。

SchedulesIn

public SchedulesIn(int index)
納入日程行情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
itmNumber 販売伝票明細

getSchedLine

public String getSchedLine()
納入日程行を取得します。

戻り値:
schedLine 納入日程行

getReqDate

public String getReqDate()
納入日程日付を取得します。

戻り値:
reqDate 納入日程日付

getDateType

public String getDateType()
日付タイプ (日、週、月、期間)を取得します。

戻り値:
dateType 日付タイプ (日、週、月、期間)

getReqTime

public String getReqTime()
納入時間を取得します。

戻り値:
reqTime 納入時間

getReqQty

public String getReqQty()
販売単位による受注数量を取得します。

戻り値:
reqQty 販売単位による受注数量

getReqDlvBl

public String getReqDlvBl()
出荷ブロック中の納入日程行を取得します。

戻り値:
reqDlvBl 出荷ブロック中の納入日程行

getSchedType

public String getSchedType()
納入日程カテゴリを取得します。

戻り値:
schedType 納入日程カテゴリ

getTpDate

public String getTpDate()
輸送計画日付を取得します。

戻り値:
tpDate 輸送計画日付

getMsDate

public String getMsDate()
品目利用可能日を取得します。

戻り値:
msDate 品目利用可能日

getLoadDate

public String getLoadDate()
積載日付を取得します。

戻り値:
loadDate 積載日付

getGiDate

public String getGiDate()
出庫日付を取得します。

戻り値:
giDate 出庫日付

getTpTime

public String getTpTime()
輸送計画 - 時間 (現地時間/出荷ポイント参照)を取得します。

戻り値:
tpTime 輸送計画 - 時間 (現地時間/出荷ポイント参照)

getMsTime

public String getMsTime()
品目供給ステージ (現地時刻: プラント参照)を取得します。

戻り値:
msTime 品目供給ステージ (現地時刻: プラント参照)

getLoadTime

public String getLoadTime()
積載時刻 (現地時間: 出荷ポイント)を取得します。

戻り値:
loadTime 積載時刻 (現地時間: 出荷ポイント)

getGiTime

public String getGiTime()
出庫時刻 (現地時間 - プラント参照)を取得します。

戻り値:
giTime 出庫時刻 (現地時間 - プラント参照)

getRefobjtype

public String getRefobjtype()
オブジェクトタイプを取得します。

戻り値:
refobjtype オブジェクトタイプ

getRefobjkey

public String getRefobjkey()
オブジェクトキーを取得します。

戻り値:
refobjkey オブジェクトキー

getReflogsys

public String getReflogsys()
論理システムを取得します。

戻り値:
reflogsys 論理システム

getDlvDate

public String getDlvDate()
納入日程日付を取得します。

戻り値:
dlvDate 納入日程日付

getDlvTime

public String getDlvTime()
納入時間を取得します。

戻り値:
dlvTime 納入時間

getRelType

public String getRelType()
承認タイプを取得します。

戻り値:
relType 承認タイプ

getPlanSchedType

public String getPlanSchedType()
納入日程行タイプ EDIを取得します。

戻り値:
planSchedType 納入日程行タイプ EDI

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setItmNumber

public void setItmNumber(String itmNumber)
販売伝票明細を設定します。

パラメータ:
itmNumber - 販売伝票明細

setSchedLine

public void setSchedLine(String schedLine)
納入日程行を設定します。

パラメータ:
schedLine - 納入日程行

setReqDate

public void setReqDate(String reqDate)
納入日程日付を設定します。

パラメータ:
reqDate - 納入日程日付

setDateType

public void setDateType(String dateType)
日付タイプ (日、週、月、期間)を設定します。

パラメータ:
dateType - 日付タイプ (日、週、月、期間)

setReqTime

public void setReqTime(String reqTime)
納入時間を設定します。

パラメータ:
reqTime - 納入時間

setReqQty

public void setReqQty(String reqQty)
販売単位による受注数量を設定します。

パラメータ:
reqQty - 販売単位による受注数量

setReqDlvBl

public void setReqDlvBl(String reqDlvBl)
出荷ブロック中の納入日程行を設定します。

パラメータ:
reqDlvBl - 出荷ブロック中の納入日程行

setSchedType

public void setSchedType(String schedType)
納入日程カテゴリを設定します。

パラメータ:
schedType - 納入日程カテゴリ

setTpDate

public void setTpDate(String tpDate)
輸送計画日付を設定します。

パラメータ:
tpDate - 輸送計画日付

setMsDate

public void setMsDate(String msDate)
品目利用可能日を設定します。

パラメータ:
msDate - 品目利用可能日

setLoadDate

public void setLoadDate(String loadDate)
積載日付を設定します。

パラメータ:
loadDate - 積載日付

setGiDate

public void setGiDate(String giDate)
出庫日付を設定します。

パラメータ:
giDate - 出庫日付

setTpTime

public void setTpTime(String tpTime)
輸送計画 - 時間 (現地時間/出荷ポイント参照)を設定します。

パラメータ:
tpTime - 輸送計画 - 時間 (現地時間/出荷ポイント参照)

setMsTime

public void setMsTime(String msTime)
品目供給ステージ (現地時刻: プラント参照)を設定します。

パラメータ:
msTime - 品目供給ステージ (現地時刻: プラント参照)

setLoadTime

public void setLoadTime(String loadTime)
積載時刻 (現地時間: 出荷ポイント)を設定します。

パラメータ:
loadTime - 積載時刻 (現地時間: 出荷ポイント)

setGiTime

public void setGiTime(String giTime)
出庫時刻 (現地時間 - プラント参照)を設定します。

パラメータ:
giTime - 出庫時刻 (現地時間 - プラント参照)

setRefobjtype

public void setRefobjtype(String refobjtype)
オブジェクトタイプを設定します。

パラメータ:
refobjtype - オブジェクトタイプ

setRefobjkey

public void setRefobjkey(String refobjkey)
オブジェクトキーを設定します。

パラメータ:
refobjkey - オブジェクトキー

setReflogsys

public void setReflogsys(String reflogsys)
論理システムを設定します。

パラメータ:
reflogsys - 論理システム

setDlvDate

public void setDlvDate(String dlvDate)
納入日程日付を設定します。

パラメータ:
dlvDate - 納入日程日付

setDlvTime

public void setDlvTime(String dlvTime)
納入時間を設定します。

パラメータ:
dlvTime - 納入時間

setRelType

public void setRelType(String relType)
承認タイプを設定します。

パラメータ:
relType - 承認タイプ

setPlanSchedType

public void setPlanSchedType(String planSchedType)
納入日程行タイプ EDIを設定します。

パラメータ:
planSchedType - 納入日程行タイプ EDI

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SchedulesInX (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス SchedulesInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX
すべての実装インタフェース:
Serializable
public class SchedulesInX
extends Object
implements Serializable

納入日程行チェックボックス情報クラス
機能は以下の通り

  • 納入日程行チェックボックス情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
SchedulesInX()
納入日程行チェックボックス情報を作成します。
SchedulesInX(int index)
納入日程行チェックボックス情報を作成します。
メソッドの概要
String | getDateType() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvDate() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvTime() 関連ユーザデータ項目の更新情報を取得します。
String | getGiDate() 関連ユーザデータ項目の更新情報を取得します。
String | getGiTime() 関連ユーザデータ項目の更新情報を取得します。
int | getIndex() レコード番号を取得します｡
String | getItmNumber() 販売伝票明細を取得します。
String | getLoadDate() 関連ユーザデータ項目の更新情報を取得します。
String | getLoadTime() 関連ユーザデータ項目の更新情報を取得します。
String | getMsDate() 関連ユーザデータ項目の更新情報を取得します。
String | getMsTime() 関連ユーザデータ項目の更新情報を取得します。
String | getPlanSchedType() 関連ユーザデータ項目の更新情報を取得します。
String | getRefobjkey() オブジェクトキーを取得します。
String | getRefobjtype() オブジェクトタイプを取得します。
String | getRelType() 関連ユーザデータ項目の更新情報を取得します。
String | getReqDate() 関連ユーザデータ項目の更新情報を取得します。
String | getReqDlvBl() 関連ユーザデータ項目の更新情報を取得します。
String | getReqQty() 関連ユーザデータ項目の更新情報を取得します。
String | getReqTime() 関連ユーザデータ項目の更新情報を取得します。
String | getSchedLine() 納入日程行を取得します。
String | getSchedType() 関連ユーザデータ項目の更新情報を取得します。
String | getTpDate() 関連ユーザデータ項目の更新情報を取得します。
String | getTpTime() 関連ユーザデータ項目の更新情報を取得します。
String | getUpdateflag() 更新区分を取得します。
void | setDateType(String dateType) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvDate(String dlvDate) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvTime(String dlvTime) 関連ユーザデータ項目の更新情報を設定します。
void | setGiDate(String giDate) 関連ユーザデータ項目の更新情報を設定します。
void | setGiTime(String giTime) 関連ユーザデータ項目の更新情報を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItmNumber(String itmNumber) 販売伝票明細を設定します。
void | setLoadDate(String loadDate) 関連ユーザデータ項目の更新情報を設定します。
void | setLoadTime(String loadTime) 関連ユーザデータ項目の更新情報を設定します。
void | setMsDate(String msDate) 関連ユーザデータ項目の更新情報を設定します。
void | setMsTime(String msTime) 関連ユーザデータ項目の更新情報を設定します。
void | setPlanSchedType(String planSchedType) 関連ユーザデータ項目の更新情報を設定します。
void | setRefobjkey(String refobjkey) オブジェクトキーを設定します。
void | setRefobjtype(String refobjtype) オブジェクトタイプを設定します。
void | setRelType(String relType) 関連ユーザデータ項目の更新情報を設定します。
void | setReqDate(String reqDate) 関連ユーザデータ項目の更新情報を設定します。
void | setReqDlvBl(String reqDlvBl) 関連ユーザデータ項目の更新情報を設定します。
void | setReqQty(String reqQty) 関連ユーザデータ項目の更新情報を設定します。
void | setReqTime(String reqTime) 関連ユーザデータ項目の更新情報を設定します。
void | setSchedLine(String schedLine) 納入日程行を設定します。
void | setSchedType(String schedType) 関連ユーザデータ項目の更新情報を設定します。
void | setTpDate(String tpDate) 関連ユーザデータ項目の更新情報を設定します。
void | setTpTime(String tpTime) 関連ユーザデータ項目の更新情報を設定します。
void | setUpdateflag(String updateflag) 更新区分を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SchedulesInX

public SchedulesInX()
納入日程行チェックボックス情報を作成します。

SchedulesInX

public SchedulesInX(int index)
納入日程行チェックボックス情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
itmNumber 販売伝票明細

getSchedLine

public String getSchedLine()
納入日程行を取得します。

戻り値:
schedLine 納入日程行

getUpdateflag

public String getUpdateflag()
更新区分を取得します。

戻り値:
updateflag 更新区分

getReqDate

public String getReqDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
reqDate 関連ユーザデータ項目の更新情報

getDateType

public String getDateType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dateType 関連ユーザデータ項目の更新情報

getReqTime

public String getReqTime()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
reqTime 関連ユーザデータ項目の更新情報

getReqQty

public String getReqQty()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
reqQty 関連ユーザデータ項目の更新情報

getReqDlvBl

public String getReqDlvBl()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
reqDlvBl 関連ユーザデータ項目の更新情報

getSchedType

public String getSchedType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
schedType 関連ユーザデータ項目の更新情報

getTpDate

public String getTpDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
tpDate 関連ユーザデータ項目の更新情報

getMsDate

public String getMsDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
msDate 関連ユーザデータ項目の更新情報

getLoadDate

public String getLoadDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
loadDate 関連ユーザデータ項目の更新情報

getGiDate

public String getGiDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
giDate 関連ユーザデータ項目の更新情報

getTpTime

public String getTpTime()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
tpTime 関連ユーザデータ項目の更新情報

getMsTime

public String getMsTime()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
msTime 関連ユーザデータ項目の更新情報

getLoadTime

public String getLoadTime()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
loadTime 関連ユーザデータ項目の更新情報

getGiTime

public String getGiTime()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
giTime 関連ユーザデータ項目の更新情報

getRefobjtype

public String getRefobjtype()
オブジェクトタイプを取得します。

戻り値:
refobjtype オブジェクトタイプ

getRefobjkey

public String getRefobjkey()
オブジェクトキーを取得します。

戻り値:
refobjkey オブジェクトキー

getDlvDate

public String getDlvDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvDate 関連ユーザデータ項目の更新情報

getDlvTime

public String getDlvTime()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvTime 関連ユーザデータ項目の更新情報

getRelType

public String getRelType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
relType 関連ユーザデータ項目の更新情報

getPlanSchedType

public String getPlanSchedType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
planSchedType 関連ユーザデータ項目の更新情報

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setItmNumber

public void setItmNumber(String itmNumber)
販売伝票明細を設定します。

パラメータ:
itmNumber - 販売伝票明細

setSchedLine

public void setSchedLine(String schedLine)
納入日程行を設定します。

パラメータ:
schedLine - 納入日程行

setUpdateflag

public void setUpdateflag(String updateflag)
更新区分を設定します。

パラメータ:
updateflag - 更新区分

setReqDate

public void setReqDate(String reqDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
reqDate - 関連ユーザデータ項目の更新情報

setDateType

public void setDateType(String dateType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dateType - 関連ユーザデータ項目の更新情報

setReqTime

public void setReqTime(String reqTime)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
reqTime - 関連ユーザデータ項目の更新情報

setReqQty

public void setReqQty(String reqQty)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
reqQty - 関連ユーザデータ項目の更新情報

setReqDlvBl

public void setReqDlvBl(String reqDlvBl)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
reqDlvBl - 関連ユーザデータ項目の更新情報

setSchedType

public void setSchedType(String schedType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
schedType - 関連ユーザデータ項目の更新情報

setTpDate

public void setTpDate(String tpDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
tpDate - 関連ユーザデータ項目の更新情報

setMsDate

public void setMsDate(String msDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
msDate - 関連ユーザデータ項目の更新情報

setLoadDate

public void setLoadDate(String loadDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
loadDate - 関連ユーザデータ項目の更新情報

setGiDate

public void setGiDate(String giDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
giDate - 関連ユーザデータ項目の更新情報

setTpTime

public void setTpTime(String tpTime)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
tpTime - 関連ユーザデータ項目の更新情報

setMsTime

public void setMsTime(String msTime)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
msTime - 関連ユーザデータ項目の更新情報

setLoadTime

public void setLoadTime(String loadTime)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
loadTime - 関連ユーザデータ項目の更新情報

setGiTime

public void setGiTime(String giTime)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
giTime - 関連ユーザデータ項目の更新情報

setRefobjtype

public void setRefobjtype(String refobjtype)
オブジェクトタイプを設定します。

パラメータ:
refobjtype - オブジェクトタイプ

setRefobjkey

public void setRefobjkey(String refobjkey)
オブジェクトキーを設定します。

パラメータ:
refobjkey - オブジェクトキー

setDlvDate

public void setDlvDate(String dlvDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvDate - 関連ユーザデータ項目の更新情報

setDlvTime

public void setDlvTime(String dlvTime)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvTime - 関連ユーザデータ項目の更新情報

setRelType

public void setRelType(String relType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
relType - 関連ユーザデータ項目の更新情報

setPlanSchedType

public void setPlanSchedType(String planSchedType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
planSchedType - 関連ユーザデータ項目の更新情報

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Sender (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス Sender

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender
すべての実装インタフェース:
Serializable
public class Sender
extends Object
implements Serializable

論理システム - 送信者情報クラス
機能は以下の通り

  • 論理システム - 送信者情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Sender()
論理システム - 送信者情報を作成します。
メソッドの概要
String | getLogSystem() 論理システムを取得します。
void | setLogSystem(String logSystem) 論理システムを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Sender

public Sender()
論理システム - 送信者情報を作成します。

メソッドの詳細

getLogSystem

public String getLogSystem()
論理システムを取得します。

戻り値:
logSystem 論理システム

setLogSystem

public void setLogSystem(String logSystem)
論理システムを設定します。

パラメータ:
logSystem - 論理システム

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Success (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス Success

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.Success
すべての実装インタフェース:
Serializable
public class Success
extends Object
implements Serializable

正常に処理された明細のテーブル情報クラス
機能は以下の通り

  • 正常に処理された明細のテーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Success()
正常に処理された明細のテーブル情報を作成します。
Success(int index)
正常に処理された明細のテーブル情報を作成します。
メソッドの概要
String | getBillDoc() 請求伝票を取得します。
String | getBillDocItem() 請求伝票明細を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO コード通貨を取得します。
String | getGroValueItem() 総額を取得します。
int | getIndex() レコード番号を取得します｡
String | getNetValue() 正味金額を取得します。
String | getNetValueItem() 正味金額を取得します。
String | getRefDoc() 参照伝票番号を取得します。
String | getRefDocItem() 参照明細番号を取得します。
String | getTaxValue() 税額を取得します。
String | getTaxValueItem() 税額を取得します。
void | setBillDoc(String billDoc) 請求伝票を設定します。
void | setBillDocItem(String billDocItem) 請求伝票明細を設定します。
void | setCurrency(String currency) 通貨コードを設定します。
void | setCurrencyIso(String currencyIso) ISO コード通貨を設定します。
void | setGroValueItem(String groValueItem) 総額を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setNetValue(String netValue) 正味金額を設定します。
void | setNetValueItem(String netValueItem) 正味金額を設定します。
void | setRefDoc(String refDoc) 参照伝票番号を設定します。
void | setRefDocItem(String refDocItem) 参照明細番号を設定します。
void | setTaxValue(String taxValue) 税額を設定します。
void | setTaxValueItem(String taxValueItem) 税額を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Success

public Success()
正常に処理された明細のテーブル情報を作成します。

Success

public Success(int index)
正常に処理された明細のテーブル情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getRefDoc

public String getRefDoc()
参照伝票番号を取得します。

戻り値:
refDoc 参照伝票番号

getRefDocItem

public String getRefDocItem()
参照明細番号を取得します。

戻り値:
refDocItem 参照明細番号

getBillDoc

public String getBillDoc()
請求伝票を取得します。

戻り値:
billDoc 請求伝票

getBillDocItem

public String getBillDocItem()
請求伝票明細を取得します。

戻り値:
billDocItem 請求伝票明細

getNetValue

public String getNetValue()
正味金額を取得します。

戻り値:
netValue 正味金額

getTaxValue

public String getTaxValue()
税額を取得します。

戻り値:
taxValue 税額

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
currency 通貨コード

getCurrencyIso

public String getCurrencyIso()
ISO コード通貨を取得します。

戻り値:
currencyIso ISO コード通貨

getNetValueItem

public String getNetValueItem()
正味金額を取得します。

戻り値:
netValueItem 正味金額

getTaxValueItem

public String getTaxValueItem()
税額を取得します。

戻り値:
taxValueItem 税額

getGroValueItem

public String getGroValueItem()
総額を取得します。

戻り値:
groValueItem 総額

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setRefDoc

public void setRefDoc(String refDoc)
参照伝票番号を設定します。

パラメータ:
refDoc - 参照伝票番号

setRefDocItem

public void setRefDocItem(String refDocItem)
参照明細番号を設定します。

パラメータ:
refDocItem - 参照明細番号

setBillDoc

public void setBillDoc(String billDoc)
請求伝票を設定します。

パラメータ:
billDoc - 請求伝票

setBillDocItem

public void setBillDocItem(String billDocItem)
請求伝票明細を設定します。

パラメータ:
billDocItem - 請求伝票明細

setNetValue

public void setNetValue(String netValue)
正味金額を設定します。

パラメータ:
netValue - 正味金額

setTaxValue

public void setTaxValue(String taxValue)
税額を設定します。

パラメータ:
taxValue - 税額

setCurrency

public void setCurrency(String currency)
通貨コードを設定します。

パラメータ:
currency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String currencyIso)
ISO コード通貨を設定します。

パラメータ:
currencyIso - ISO コード通貨

setNetValueItem

public void setNetValueItem(String netValueItem)
正味金額を設定します。

パラメータ:
netValueItem - 正味金額

setTaxValueItem

public void setTaxValueItem(String taxValueItem)
税額を設定します。

パラメータ:
taxValueItem - 税額

setGroValueItem

public void setGroValueItem(String groValueItem)
総額を設定します。

パラメータ:
groValueItem - 総額

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Text (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス Text

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.Text
すべての実装インタフェース:
Serializable
public class Text
extends Object
implements Serializable

テキスト情報クラス
機能は以下の通り

  • テキスト情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Text()
テキスト情報を作成します。
Text(int index)
テキスト情報を作成します。
メソッドの概要
String | getDocNumber() 販売伝票を取得します。
String | getFormatCol() タグ列を取得します。
String | getFunction() 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getItmNumber() 販売伝票明細を取得します。
String | getLangu() 言語キーを取得します。
String | getLanguIso() ISO 639 準拠の言語を取得します。
String | getTextId() テキスト IDを取得します。
String | getTextLine() テキスト行を取得します。
void | setDocNumber(String docNumber) 販売伝票を設定します。
void | setFormatCol(String formatCol) タグ列を設定します。
void | setFunction(String function) 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItmNumber(String itmNumber) 販売伝票明細を設定します。
void | setLangu(String langu) 言語キーを設定します。
void | setLanguIso(String languIso) ISO 639 準拠の言語を設定します。
void | setTextId(String textId) テキスト IDを設定します。
void | setTextLine(String textLine) テキスト行を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Text

public Text()
テキスト情報を作成します。

Text

public Text(int index)
テキスト情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getDocNumber

public String getDocNumber()
販売伝票を取得します。

戻り値:
docNumber 販売伝票

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
itmNumber 販売伝票明細

getTextId

public String getTextId()
テキスト IDを取得します。

戻り値:
textId テキスト ID

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
langu 言語キー

getLanguIso

public String getLanguIso()
ISO 639 準拠の言語を取得します。

戻り値:
languIso ISO 639 準拠の言語

getFormatCol

public String getFormatCol()
タグ列を取得します。

戻り値:
formatCol タグ列

getTextLine

public String getTextLine()
テキスト行を取得します。

戻り値:
textLine テキスト行

getFunction

public String getFunction()
機能を取得します。

戻り値:
function 機能

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setDocNumber

public void setDocNumber(String docNumber)
販売伝票を設定します。

パラメータ:
docNumber - 販売伝票

setItmNumber

public void setItmNumber(String itmNumber)
販売伝票明細を設定します。

パラメータ:
itmNumber - 販売伝票明細

setTextId

public void setTextId(String textId)
テキスト IDを設定します。

パラメータ:
textId - テキスト ID

setLangu

public void setLangu(String langu)
言語キーを設定します。

パラメータ:
langu - 言語キー

setLanguIso

public void setLanguIso(String languIso)
ISO 639 準拠の言語を設定します。

パラメータ:
languIso - ISO 639 準拠の言語

setFormatCol

public void setFormatCol(String formatCol)
タグ列を設定します。

パラメータ:
formatCol - タグ列

setTextLine

public void setTextLine(String textLine)
テキスト行を設定します。

パラメータ:
textLine - テキスト行

setFunction

public void setFunction(String function)
機能を設定します。

パラメータ:
function - 機能

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException の使用

SAPSalesAppException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail

jp.co.intra_mart.foundation.sap.module.sales での SAPSalesAppException の使用

SAPSalesAppException をスローする jp.co.intra_mart.foundation.sap.module.sales のメソッド
 void SalesOrderGetStatusController.executeBapi()
SalesOrderGetStatusのexecuteBapi()を呼び出し販売伝票ステータス一覧を照会します。
 void SalesOrderGetListController.executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し販売伝票一覧を取得します。
 void SalesOrderCreateFromDat2Controller.executeBapi()
SalesOrderCreateFromDat2のexecuteBapi()を呼び出し販売伝票を登録します。
 void QuotationCreateFromData2Controller.executeBapi()
QuotationCreateFromData2のexecuteBapi()を呼び出し見積伝票を登録します。
 void InquiryCreateFromData2Controller.executeBapi()
InquiryCreateFromData2のexecuteBapi()を呼び出し引合伝票を登録します。
 void BillingDocGetListController.executeBapi()
BillingDocGetListのexecuteBapi()を呼び出し請求伝票一覧を検索します。
 void BillingDocCreateMultipleController.executeBapi()
BillingDocCreateMultipleのexecuteBapi()を呼び出し請求伝票を登録します。

SAPSalesAppException をスローする jp.co.intra_mart.foundation.sap.module.sales のコンストラクタ
BillingDocGetDetailController(String billingDocument)
コンストラクタ生成
BillingDocGetDetailController(String billingDocument, SapClient sapClient)
コンストラクタ生成

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での SAPSalesAppException の使用

SAPSalesAppException をスローする jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のメソッド
 void BillingDocGetDetail.executeBapi()
BillingDocGetDetailのexecuteBapi()を呼び出し請求伝票を検索します。

SAPSalesAppException をスローする jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のコンストラクタ
BillingDocGetDetail(String billingdocument, SapClient sapClient)
請求伝票詳細照会情報を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesSystemException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesSystemException の使用

SAPSalesSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail

jp.co.intra_mart.foundation.sap.module.sales での SAPSalesSystemException の使用

SAPSalesSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales のメソッド
 void SalesOrderGetStatusController.executeBapi()
SalesOrderGetStatusのexecuteBapi()を呼び出し販売伝票ステータス一覧を照会します。
 void SalesOrderGetStatusController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void SalesOrderGetListController.executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し販売伝票一覧を取得します。
 void SalesOrderGetListController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void SalesOrderCreateFromDat2Controller.executeBapi()
SalesOrderCreateFromDat2のexecuteBapi()を呼び出し販売伝票を登録します。
 void SalesOrderCreateFromDat2Controller.setStrParam(String paramStr, String paramName, String value)
構造体型の項目に値をセットします。
 void SalesOrderCreateFromDat2Controller.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void QuotationCreateFromData2Controller.executeBapi()
QuotationCreateFromData2のexecuteBapi()を呼び出し見積伝票を登録します。
 void QuotationCreateFromData2Controller.setStrParam(String paramStr, String paramName, String value)
構造体型の項目に値をセットします。
 void QuotationCreateFromData2Controller.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void InquiryCreateFromData2Controller.executeBapi()
InquiryCreateFromData2のexecuteBapi()を呼び出し引合伝票を登録します。
 void InquiryCreateFromData2Controller.setStrParam(String paramStr, String paramName, String value)
構造体型の項目に値をセットします。
 void InquiryCreateFromData2Controller.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void BillingDocGetListController.executeBapi()
BillingDocGetListのexecuteBapi()を呼び出し請求伝票一覧を検索します。
 void BillingDocGetListController.setStrParam(String paramStr, String paramName, String value)
構造型の項目に値をセットします。
 void BillingDocGetListController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void BillingDocCreateMultipleController.executeBapi()
BillingDocCreateMultipleのexecuteBapi()を呼び出し請求伝票を登録します。
 void BillingDocCreateMultipleController.setStrParam(String paramStr, String paramName, String value)
構造型の項目に値をセットします。
 void BillingDocCreateMultipleController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。

SAPSalesSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales のコンストラクタ
BillingDocGetDetailController(String billingDocument)
コンストラクタ生成
BillingDocGetDetailController(String billingDocument, SapClient sapClient)
コンストラクタ生成

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での SAPSalesSystemException の使用

SAPSalesSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のメソッド
 void BillingDocGetDetail.executeBapi()
BillingDocGetDetailのexecuteBapi()を呼び出し請求伝票を検索します。

SAPSalesSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のコンストラクタ
BillingDocGetDetail(String billingdocument, SapClient sapClient)
請求伝票詳細照会情報を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.sales.exception (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.exception
例外
SAPSalesAppException
SAPSalesSystemException


jp.co.intra_mart.foundation.sap.module.sales.exception (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.exception

例外の概要
SAPSalesAppException | 販売管理系APIアプリケーション例外クラス
SAPSalesSystemException | 販売管理系APIシステム例外クラス


jp.co.intra_mart.foundation.sap.module.sales.exception クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.common.exception.SAPException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
            • class jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
            • class jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesSystemException


パッケージ jp.co.intra_mart.foundation.sap.module.sales.exception の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.exception の使用

jp.co.intra_mart.foundation.sap.module.sales.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.exception のクラス
SAPSalesAppException
販売管理系APIアプリケーション例外クラス
SAPSalesSystemException
販売管理系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail により使用される jp.co.intra_mart.foundation.sap.module.sales.exception のクラス
SAPSalesAppException
販売管理系APIアプリケーション例外クラス
SAPSalesSystemException
販売管理系APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SAPSalesAppException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.exception
クラス SAPSalesAppException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
                    拡張 jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException
すべての実装インタフェース:
Serializable
public class SAPSalesAppException
extends SAPModuleAppException

販売管理系APIアプリケーション例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPSalesAppException(String message)
販売管理系APIアプリケーション例外
SAPSalesAppException(String message, Throwable ex)
販売管理系APIアプリケーション例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPSalesAppException

public SAPSalesAppException(String message,
                            Throwable ex)
販売管理系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPSalesAppException

public SAPSalesAppException(String message)
販売管理系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPSalesSystemException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.exception
クラス SAPSalesSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
                    拡張 jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesSystemException
すべての実装インタフェース:
Serializable
public class SAPSalesSystemException
extends SAPModuleSystemException

販売管理系APIシステム例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPSalesSystemException(String message, Throwable ex)
販売管理系APIシステム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPSalesSystemException

public SAPSalesSystemException(String message,
                               Throwable ex)
販売管理系APIシステム例外

パラメータ:
message - エラーメッセージ
ex - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 の使用

InquiryCreateFromData2 を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales での InquiryCreateFromData2 の使用

jp.co.intra_mart.foundation.sap.module.sales での InquiryCreateFromData2 のサブクラス
 class InquiryCreateFromData2Controller
引合伝票登録コントローラクラス
機能は以下の通り
引合伝票を登録します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


InquiryCreateFromData2 (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2
クラス InquiryCreateFromData2

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
InquiryCreateFromData2Controller
public class InquiryCreateFromData2
extends UpdateController
implements Serializable

引合伝票登録情報クラス
機能は以下の通り

  • 引合伝票登録情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
InquiryCreateFromData2()
コンストラクタ。
InquiryCreateFromData2(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。
InquiryCreateFromData2(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
メソッドの概要
String | getBehaveWhenError() エラー処理を取得します。
String | getBinaryRelationshiptype() バイナリ関連タイプ (専用)を取得します。
String | getConvert() 変換: 取引先機能 + 受注伝票タイプを取得します。
List | getExtensionInList() VBAK、VBAP、VBEP のカスタマ拡張を取得します。
List | getInquiryCfgsBlobList() 選定: BLOB 内部データ (SCE)を取得します。
List | getInquiryCfgsInstList() 選定: インスタンスを取得します。
List | getInquiryCfgsPartOfList() 選定: 部分設定を取得します。
List | getInquiryCfgsRefInstList() 選定: 参照明細/インスタンスを取得します。
List | getInquiryCfgsRefList() 選定: 参照データを取得します。
List | getInquiryCfgsValueList() 選定: 特性値を取得します。
List | getInquiryCfgsVkList() 選定: バリアント条件キーを取得します。
List | getInquiryConditionsInList() 条件を取得します。
List | getInquiryConditionsInXList() 受注における条件更新の通信項目を取得します。
HeaderIn | getInquiryHeaderIn() 引合伝票ヘッダデータを取得します。
HeaderInX | getInquiryHeaderInX() ヘッダデータチェックボックスを取得します。
List | getInquiryItemsInList() 明細データを取得します。
List | getInquiryItemsInXList() 明細データチェックボックスを取得します。
List | getInquiryKeysList() 参照キーの出力テーブルを取得します。
List | getInquiryPartnersList() 伝票取引先を取得します。
List | getInquirySchedulesInList() 納入日程行を取得します。
List | getInquirySchedulesInXList() 納入日程行チェックボックスを取得します。
List | getInquiryTextList() テキストを取得します。
String | getIntNumberAssignment() 明細番号内部採番を取得します。
LogicSwitch | getLogicSwitch() 内部制御パラメータを取得します。
List | getPartnerAddressesList() アドレス (組織/会社) 用 BAPI 参照構造を取得します。
String | getSalesdocument() 販売伝票番号を取得します。
String | getSalesdocumentin() 販売管理伝票番号を取得します。
Sender | getSender() 論理システム - 送信者を取得します。
String | getTestrun() テスト実行を取得します。
void | setBehaveWhenError(String behaveWhenError) エラー処理を設定します。
void | setBinaryRelationshiptype(String binaryRelationshiptype) バイナリ関連タイプ (専用)を設定します。
void | setConvert(String convert) 変換: 取引先機能 + 受注伝票タイプを設定します。
void | setExportParam(BapiController bapiController) 引合伝票に登録する値ををセットします。
void | setExtensionInList(List extensionInList) VBAK、VBAP、VBEP のカスタマ拡張を設定します。
void | setImportParam(BapiController bapiController) 引合伝票に登録する値ををセットします。
void | setInquiryCfgsBlobList(List inquiryCfgsBlobList) 選定: BLOB 内部データ (SCE)を設定します。
void | setInquiryCfgsInstList(List inquiryCfgsInstList) 選定: インスタンスを設定します。
void | setInquiryCfgsPartOfList(List inquiryCfgsPartOfList) 選定: 部分設定を設定します。
void | setInquiryCfgsRefInstList(List inquiryCfgsRefInstList) 選定: 参照明細/インスタンスを設定します。
void | setInquiryCfgsRefList(List inquiryCfgsRefList) 選定: 参照データを設定します。
void | setInquiryCfgsValueList(List inquiryCfgsValueList) 選定: 特性値を設定します。
void | setInquiryCfgsVkList(List inquiryCfgsVkList) 選定: バリアント条件キーを設定します。
void | setInquiryConditionsInList(List inquiryConditionsInList) 条件を設定します。
void | setInquiryConditionsInXList(List inquiryConditionsInXList) 受注における条件更新の通信項目を設定します。
void | setInquiryHeaderIn(HeaderIn inquiryHeaderIn) 引合伝票ヘッダデータを設定します。
void | setInquiryHeaderInX(HeaderInX inquiryHeaderInX) ヘッダデータチェックボックスを設定します。
void | setInquiryItemsInList(List inquiryItemsInList) 明細データを設定します。
void | setInquiryItemsInXList(List inquiryItemsInXList) 明細データチェックボックスを設定します。
void | setInquiryKeysList(List inquiryKeysList) 参照キーの出力テーブルを設定します。
void | setInquiryPartnersList(List inquiryPartnersList) 伝票取引先を設定します。
void | setInquirySchedulesInList(List inquirySchedulesInList) 納入日程行を設定します。
void | setInquirySchedulesInXList(List inquirySchedulesInXList) 納入日程行チェックボックスを設定します。
void | setInquiryTextList(List inquiryTextList) テキストを設定します。
void | setIntNumberAssignment(String intNumberAssignment) 明細番号内部採番を設定します。
void | setLogicSwitch(LogicSwitch logicSwitch) 内部制御パラメータを設定します。
void | setPartnerAddressesList(List partnerAddressesList) アドレス (組織/会社) 用 BAPI 参照構造を設定します。
void | setSalesdocument(String salesdocument) 販売伝票番号を設定します。
void | setSalesdocumentin(String salesdocumentin) 販売管理伝票番号を設定します。
void | setSender(Sender sender) 論理システム - 送信者を設定します。
void | setTestrun(String testrun) テスト実行を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

InquiryCreateFromData2

public InquiryCreateFromData2()
コンストラクタ。

InquiryCreateFromData2

public InquiryCreateFromData2(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。

パラメータ:
conectionManager - コネクションマネージャー

InquiryCreateFromData2

public InquiryCreateFromData2(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
引合伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
引合伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getTestrun

public String getTestrun()
テスト実行を取得します。

戻り値:
testrun テスト実行

getSalesdocumentin

public String getSalesdocumentin()
販売管理伝票番号を取得します。

戻り値:
salesdocumentin 販売管理伝票番号

getIntNumberAssignment

public String getIntNumberAssignment()
明細番号内部採番を取得します。

戻り値:
intNumberAssignment 明細番号内部採番

getBehaveWhenError

public String getBehaveWhenError()
エラー処理を取得します。

戻り値:
behaveWhenError エラー処理

getBinaryRelationshiptype

public String getBinaryRelationshiptype()
バイナリ関連タイプ (専用)を取得します。

戻り値:
binaryRelationshiptype バイナリ関連タイプ (専用)

getConvert

public String getConvert()
変換: 取引先機能 + 受注伝票タイプを取得します。

戻り値:
convert 変換: 取引先機能 + 受注伝票タイプ

getSalesdocument

public String getSalesdocument()
販売伝票番号を取得します。

戻り値:
salesdocument 販売伝票番号

getSender

public Sender getSender()
論理システム - 送信者を取得します。

戻り値:
sender 論理システム - 送信者

getLogicSwitch

public LogicSwitch getLogicSwitch()
内部制御パラメータを取得します。

戻り値:
logicSwitch 内部制御パラメータ

getInquiryHeaderInX

public HeaderInX getInquiryHeaderInX()
ヘッダデータチェックボックスを取得します。

戻り値:
inquiryHeaderInX ヘッダデータチェックボックス

getInquiryHeaderIn

public HeaderIn getInquiryHeaderIn()
引合伝票ヘッダデータを取得します。

戻り値:
inquiryHeaderIn 引合伝票ヘッダデータ

getPartnerAddressesList

public List getPartnerAddressesList()
アドレス (組織/会社) 用 BAPI 参照構造を取得します。

戻り値:
partnerAddressesList アドレス (組織/会社) 用 BAPI 参照構造

getExtensionInList

public List getExtensionInList()
VBAK、VBAP、VBEP のカスタマ拡張を取得します。

戻り値:
extensionInList VBAK、VBAP、VBEP のカスタマ拡張

getInquiryCfgsBlobList

public List getInquiryCfgsBlobList()
選定: BLOB 内部データ (SCE)を取得します。

戻り値:
inquiryCfgsBlobList 選定: BLOB 内部データ (SCE)

getInquiryTextList

public List getInquiryTextList()
テキストを取得します。

戻り値:
inquiryTextList テキスト

getInquirySchedulesInXList

public List getInquirySchedulesInXList()
納入日程行チェックボックスを取得します。

戻り値:
inquirySchedulesInXList 納入日程行チェックボックス

getInquirySchedulesInList

public List getInquirySchedulesInList()
納入日程行を取得します。

戻り値:
inquirySchedulesInList 納入日程行

getInquiryPartnersList

public List getInquiryPartnersList()
伝票取引先を取得します。

戻り値:
inquiryPartnersList 伝票取引先

getInquiryKeysList

public List getInquiryKeysList()
参照キーの出力テーブルを取得します。

戻り値:
inquiryKeysList 参照キーの出力テーブル

getInquiryItemsInXList

public List getInquiryItemsInXList()
明細データチェックボックスを取得します。

戻り値:
inquiryItemsInXList 明細データチェックボックス

getInquiryItemsInList

public List getInquiryItemsInList()
明細データを取得します。

戻り値:
inquiryItemsInList 明細データ

getInquiryCfgsInstList

public List getInquiryCfgsInstList()
選定: インスタンスを取得します。

戻り値:
inquiryCfgsInstList 選定: インスタンス

getInquiryCfgsPartOfList

public List getInquiryCfgsPartOfList()
選定: 部分設定を取得します。

戻り値:
inquiryCfgsPartOfList 選定: 部分設定

getInquiryConditionsInXList

public List getInquiryConditionsInXList()
受注における条件更新の通信項目を取得します。

戻り値:
inquiryConditionsInXList 受注における条件更新の通信項目

getInquiryConditionsInList

public List getInquiryConditionsInList()
条件を取得します。

戻り値:
inquiryConditionsInList 条件

getInquiryCfgsVkList

public List getInquiryCfgsVkList()
選定: バリアント条件キーを取得します。

戻り値:
inquiryCfgsVkList 選定: バリアント条件キー

getInquiryCfgsValueList

public List getInquiryCfgsValueList()
選定: 特性値を取得します。

戻り値:
inquiryCfgsValueList 選定: 特性値

getInquiryCfgsRefInstList

public List getInquiryCfgsRefInstList()
選定: 参照明細/インスタンスを取得します。

戻り値:
inquiryCfgsRefInstList 選定: 参照明細/インスタンス

getInquiryCfgsRefList

public List getInquiryCfgsRefList()
選定: 参照データを取得します。

戻り値:
inquiryCfgsRefList 選定: 参照データ

setTestrun

public void setTestrun(String testrun)
テスト実行を設定します。

パラメータ:
testrun - テスト実行

setSalesdocumentin

public void setSalesdocumentin(String salesdocumentin)
販売管理伝票番号を設定します。

パラメータ:
salesdocumentin - 販売管理伝票番号

setIntNumberAssignment

public void setIntNumberAssignment(String intNumberAssignment)
明細番号内部採番を設定します。

パラメータ:
intNumberAssignment - 明細番号内部採番

setBehaveWhenError

public void setBehaveWhenError(String behaveWhenError)
エラー処理を設定します。

パラメータ:
behaveWhenError - エラー処理

setBinaryRelationshiptype

public void setBinaryRelationshiptype(String binaryRelationshiptype)
バイナリ関連タイプ (専用)を設定します。

パラメータ:
binaryRelationshiptype - バイナリ関連タイプ (専用)

setConvert

public void setConvert(String convert)
変換: 取引先機能 + 受注伝票タイプを設定します。

パラメータ:
convert - 変換: 取引先機能 + 受注伝票タイプ

setSalesdocument

public void setSalesdocument(String salesdocument)
販売伝票番号を設定します。

パラメータ:
salesdocument - 販売伝票番号

setSender

public void setSender(Sender sender)
論理システム - 送信者を設定します。

パラメータ:
sender - 論理システム - 送信者

setLogicSwitch

public void setLogicSwitch(LogicSwitch logicSwitch)
内部制御パラメータを設定します。

パラメータ:
logicSwitch - 内部制御パラメータ

setInquiryHeaderInX

public void setInquiryHeaderInX(HeaderInX inquiryHeaderInX)
ヘッダデータチェックボックスを設定します。

パラメータ:
inquiryHeaderInX - ヘッダデータチェックボックス

setInquiryHeaderIn

public void setInquiryHeaderIn(HeaderIn inquiryHeaderIn)
引合伝票ヘッダデータを設定します。

パラメータ:
inquiryHeaderIn - 引合伝票ヘッダデータ

setPartnerAddressesList

public void setPartnerAddressesList(List partnerAddressesList)
アドレス (組織/会社) 用 BAPI 参照構造を設定します。

パラメータ:
partnerAddressesList - アドレス (組織/会社) 用 BAPI 参照構造

setExtensionInList

public void setExtensionInList(List extensionInList)
VBAK、VBAP、VBEP のカスタマ拡張を設定します。

パラメータ:
extensionInList - VBAK、VBAP、VBEP のカスタマ拡張

setInquiryCfgsBlobList

public void setInquiryCfgsBlobList(List inquiryCfgsBlobList)
選定: BLOB 内部データ (SCE)を設定します。

パラメータ:
inquiryCfgsBlobList - 選定: BLOB 内部データ (SCE)

setInquiryTextList

public void setInquiryTextList(List inquiryTextList)
テキストを設定します。

パラメータ:
inquiryTextList - テキスト

setInquirySchedulesInXList

public void setInquirySchedulesInXList(List inquirySchedulesInXList)
納入日程行チェックボックスを設定します。

パラメータ:
inquirySchedulesInXList - 納入日程行チェックボックス

setInquirySchedulesInList

public void setInquirySchedulesInList(List inquirySchedulesInList)
納入日程行を設定します。

パラメータ:
inquirySchedulesInList - 納入日程行

setInquiryPartnersList

public void setInquiryPartnersList(List inquiryPartnersList)
伝票取引先を設定します。

パラメータ:
inquiryPartnersList - 伝票取引先

setInquiryKeysList

public void setInquiryKeysList(List inquiryKeysList)
参照キーの出力テーブルを設定します。

パラメータ:
inquiryKeysList - 参照キーの出力テーブル

setInquiryItemsInXList

public void setInquiryItemsInXList(List inquiryItemsInXList)
明細データチェックボックスを設定します。

パラメータ:
inquiryItemsInXList - 明細データチェックボックス

setInquiryItemsInList

public void setInquiryItemsInList(List inquiryItemsInList)
明細データを設定します。

パラメータ:
inquiryItemsInList - 明細データ

setInquiryCfgsInstList

public void setInquiryCfgsInstList(List inquiryCfgsInstList)
選定: インスタンスを設定します。

パラメータ:
inquiryCfgsInstList - 選定: インスタンス

setInquiryCfgsPartOfList

public void setInquiryCfgsPartOfList(List inquiryCfgsPartOfList)
選定: 部分設定を設定します。

パラメータ:
inquiryCfgsPartOfList - 選定: 部分設定

setInquiryConditionsInXList

public void setInquiryConditionsInXList(List inquiryConditionsInXList)
受注における条件更新の通信項目を設定します。

パラメータ:
inquiryConditionsInXList - 受注における条件更新の通信項目

setInquiryConditionsInList

public void setInquiryConditionsInList(List inquiryConditionsInList)
条件を設定します。

パラメータ:
inquiryConditionsInList - 条件

setInquiryCfgsVkList

public void setInquiryCfgsVkList(List inquiryCfgsVkList)
選定: バリアント条件キーを設定します。

パラメータ:
inquiryCfgsVkList - 選定: バリアント条件キー

setInquiryCfgsValueList

public void setInquiryCfgsValueList(List inquiryCfgsValueList)
選定: 特性値を設定します。

パラメータ:
inquiryCfgsValueList - 選定: 特性値

setInquiryCfgsRefInstList

public void setInquiryCfgsRefInstList(List inquiryCfgsRefInstList)
選定: 参照明細/インスタンスを設定します。

パラメータ:
inquiryCfgsRefInstList - 選定: 参照明細/インスタンス

setInquiryCfgsRefList

public void setInquiryCfgsRefList(List inquiryCfgsRefList)
選定: 参照データを設定します。

パラメータ:
inquiryCfgsRefList - 選定: 参照データ

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2
クラス
InquiryCreateFromData2


jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2

クラスの概要
InquiryCreateFromData2 引合伝票登録情報クラス
機能は以下の通り
引合伝票登録情報を保持します。


jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 の使用

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のクラス
InquiryCreateFromData2
引合伝票登録情報クラス
機能は以下の通り
引合伝票登録情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 の使用

QuotationCreateFromData2 を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales での QuotationCreateFromData2 の使用

jp.co.intra_mart.foundation.sap.module.sales での QuotationCreateFromData2 のサブクラス
 class QuotationCreateFromData2Controller
見積伝票登録情報コントローラクラス
機能は以下の通り
見積伝票登録情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2
クラス
QuotationCreateFromData2


jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2

クラスの概要
QuotationCreateFromData2 見積伝票登録情報クラス
機能は以下の通り
見積伝票登録情報を保持します。


jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 の使用

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のクラス
QuotationCreateFromData2
見積伝票登録情報クラス
機能は以下の通り
見積伝票登録情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


QuotationCreateFromData2 (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2
クラス QuotationCreateFromData2

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
QuotationCreateFromData2Controller
public class QuotationCreateFromData2
extends UpdateController
implements Serializable

見積伝票登録情報クラス
機能は以下の通り

  • 見積伝票登録情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
QuotationCreateFromData2()
コンストラクタ。
QuotationCreateFromData2(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。
QuotationCreateFromData2(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
メソッドの概要
String | getBehaveWhenError() エラー処理を取得します。
String | getBinaryRelationshiptype() バイナリ関連タイプ (専用)を取得します。
String | getConvert() 取引先機能/受注伝票タイプの変換を取得します。
List | getExtensionInList() VBAK、VBAP、VBEP のカスタマ拡張を取得します。
String | getIntNumberAssignment() 明細番号内部採番を取得します。
LogicSwitch | getLogicSwitch() 内部制御パラメータを取得します。
List | getPartnerAddressesList() アドレス (組織/会社) 用 BAPI 参照構造を取得します。
List | getQuotationCfgsBlobList() 選定: BLOB 内部データ (SCE)を取得します。
List | getQuotationCfgsInstList() 選定: インスタンスを取得します。
List | getQuotationCfgsPartOfList() 選定: 部分設定を取得します。
List | getQuotationCfgsRefInstList() 選定: 参照明細/インスタンスを取得します。
List | getQuotationCfgsRefList() 選定: 参照データを取得します。
List | getQuotationCfgsValueList() 選定: 特性値を取得します。
List | getQuotationCfgsVkList() 選定: バリアント条件キーを取得します。
List | getQuotationConditionsInList() 条件を取得します。
List | getQuotationConditionsInXList() 受注における条件更新の通信項目を取得します。
HeaderIn | getQuotationHeaderIn() 伝票ヘッダデータを取得します。
HeaderInX | getQuotationHeaderInX() 伝票ヘッダチェックボックスを取得します。
List | getQuotationItemsInList() 明細データを取得します。
List | getQuotationItemsInXList() 明細データチェックボックスを取得します。
List | getQuotationKeysList() 参照キーの出力テーブルを取得します。
List | getQuotationPartnersList() 伝票取引先を取得します。
List | getQuotationSchedulesInList() 納入日程行データを取得します。
List | getQuotationSchedulesInXList() 納入日程行データチェックボックスを取得します。
List | getQuotationTextList() テキストを取得します。
String | getSalesdocument() 販売管理伝票番号を取得します。
String | getSalesdocumentin() 見積伝票番号を取得します。
Sender | getSender() 論理システム - 送信者を取得します。
String | getTestrun() テスト実行を取得します。
void | setBehaveWhenError(String behaveWhenError) エラー処理を設定します。
void | setBinaryRelationshiptype(String binaryRelationshiptype) バイナリ関連タイプ (専用)を設定します。
void | setConvert(String convert) 取引先機能/受注伝票タイプの変換を設定します。
void | setExportParam(BapiController bapiController) 見積伝票に登録する値ををセットします。
void | setExtensionInList(List extensionInList) VBAK、VBAP、VBEP のカスタマ拡張を設定します。
void | setImportParam(BapiController bapiController) 見積伝票に登録する値ををセットします。
void | setIntNumberAssignment(String intNumberAssignment) 明細番号内部採番を設定します。
void | setLogicSwitch(LogicSwitch logicSwitch) 内部制御パラメータを設定します。
void | setPartnerAddressesList(List partnerAddressesList) アドレス (組織/会社) 用 BAPI 参照構造を設定します。
void | setQuotationCfgsBlobList(List quotationCfgsBlobList) 選定: BLOB 内部データ (SCE)を設定します。
void | setQuotationCfgsInstList(List quotationCfgsInstList) 選定: インスタンスを設定します。
void | setQuotationCfgsPartOfList(List quotationCfgsPartOfList) 選定: 部分設定を設定します。
void | setQuotationCfgsRefInstList(List quotationCfgsRefInstList) 選定: 参照明細/インスタンスを設定します。
void | setQuotationCfgsRefList(List quotationCfgsRefList) 選定: 参照データを設定します。
void | setQuotationCfgsValueList(List quotationCfgsValueList) 選定: 特性値を設定します。
void | setQuotationCfgsVkList(List quotationCfgsVkList) 選定: バリアント条件キーを設定します。
void | setQuotationConditionsInList(List quotationConditionsInList) 条件を設定します。
void | setQuotationConditionsInXList(List quotationConditionsInXList) 受注における条件更新の通信項目を設定します。
void | setQuotationHeaderIn(HeaderIn quotationHeaderIn) 伝票ヘッダデータを設定します。
void | setQuotationHeaderInX(HeaderInX quotationHeaderInX) 伝票ヘッダチェックボックスを設定します。
void | setQuotationItemsInList(List quotationItemsInList) 明細データを設定します。
void | setQuotationItemsInXList(List quotationItemsInXList) 明細データチェックボックスを設定します。
void | setQuotationKeysList(List quotationKeysList) 参照キーの出力テーブルを設定します。
void | setQuotationPartnersList(List quotationPartnersList) 伝票取引先を設定します。
void | setQuotationSchedulesInList(List quotationSchedulesInList) 納入日程行データを設定します。
void | setQuotationSchedulesInXList(List quotationSchedulesInXList) 納入日程行データチェックボックスを設定します。
void | setQuotationTextList(List quotationTextList) テキストを設定します。
void | setSalesdocument(String salesdocument) 販売管理伝票番号を設定します。
void | setSalesdocumentin(String salesdocumentin) 見積伝票番号を設定します。
void | setSender(Sender sender) 論理システム - 送信者を設定します。
void | setTestrun(String testrun) テスト実行を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

QuotationCreateFromData2

public QuotationCreateFromData2()
コンストラクタ。

QuotationCreateFromData2

public QuotationCreateFromData2(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。

パラメータ:
conectionManager - コネクションマネージャー

QuotationCreateFromData2

public QuotationCreateFromData2(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
見積伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
見積伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getBehaveWhenError

public String getBehaveWhenError()
エラー処理を取得します。

戻り値:
behaveWhenError エラー処理

getBinaryRelationshiptype

public String getBinaryRelationshiptype()
バイナリ関連タイプ (専用)を取得します。

戻り値:
binaryRelationshiptype バイナリ関連タイプ (専用)

getConvert

public String getConvert()
取引先機能/受注伝票タイプの変換を取得します。

戻り値:
convert 取引先機能/受注伝票タイプの変換

getTestrun

public String getTestrun()
テスト実行を取得します。

戻り値:
testrun テスト実行

getIntNumberAssignment

public String getIntNumberAssignment()
明細番号内部採番を取得します。

戻り値:
intNumberAssignment 明細番号内部採番

getSalesdocumentin

public String getSalesdocumentin()
見積伝票番号を取得します。

戻り値:
salesdocumentin 見積伝票番号

getSalesdocument

public String getSalesdocument()
販売管理伝票番号を取得します。

戻り値:
salesdocument 販売管理伝票番号

getLogicSwitch

public LogicSwitch getLogicSwitch()
内部制御パラメータを取得します。

戻り値:
logicSwitch 内部制御パラメータ

getSender

public Sender getSender()
論理システム - 送信者を取得します。

戻り値:
sender 論理システム - 送信者

getQuotationHeaderInX

public HeaderInX getQuotationHeaderInX()
伝票ヘッダチェックボックスを取得します。

戻り値:
quotationHeaderInX 伝票ヘッダチェックボックス

getQuotationHeaderIn

public HeaderIn getQuotationHeaderIn()
伝票ヘッダデータを取得します。

戻り値:
quotationHeaderIn 伝票ヘッダデータ

getQuotationTextList

public List getQuotationTextList()
テキストを取得します。

戻り値:
quotationTextList テキスト

getQuotationSchedulesInXList

public List getQuotationSchedulesInXList()
納入日程行データチェックボックスを取得します。

戻り値:
quotationSchedulesInXList 納入日程行データチェックボックス

getQuotationSchedulesInList

public List getQuotationSchedulesInList()
納入日程行データを取得します。

戻り値:
quotationSchedulesInList 納入日程行データ

getQuotationPartnersList

public List getQuotationPartnersList()
伝票取引先を取得します。

戻り値:
quotationPartnersList 伝票取引先

getQuotationKeysList

public List getQuotationKeysList()
参照キーの出力テーブルを取得します。

戻り値:
quotationKeysList 参照キーの出力テーブル

getQuotationItemsInXList

public List getQuotationItemsInXList()
明細データチェックボックスを取得します。

戻り値:
quotationItemsInXList 明細データチェックボックス

getQuotationItemsInList

public List getQuotationItemsInList()
明細データを取得します。

戻り値:
quotationItemsInList 明細データ

getQuotationConditionsInXList

public List getQuotationConditionsInXList()
受注における条件更新の通信項目を取得します。

戻り値:
quotationConditionsInXList 受注における条件更新の通信項目

getQuotationConditionsInList

public List getQuotationConditionsInList()
条件を取得します。

戻り値:
quotationConditionsInList 条件

getQuotationCfgsVkList

public List getQuotationCfgsVkList()
選定: バリアント条件キーを取得します。

戻り値:
quotationCfgsVkList 選定: バリアント条件キー

getQuotationCfgsValueList

public List getQuotationCfgsValueList()
選定: 特性値を取得します。

戻り値:
quotationCfgsValueList 選定: 特性値

getQuotationCfgsRefInstList

public List getQuotationCfgsRefInstList()
選定: 参照明細/インスタンスを取得します。

戻り値:
quotationCfgsRefInstList 選定: 参照明細/インスタンス

getQuotationCfgsRefList

public List getQuotationCfgsRefList()
選定: 参照データを取得します。

戻り値:
quotationCfgsRefList 選定: 参照データ

getQuotationCfgsPartOfList

public List getQuotationCfgsPartOfList()
選定: 部分設定を取得します。

戻り値:
quotationCfgsPartOfList 選定: 部分設定

getQuotationCfgsInstList

public List getQuotationCfgsInstList()
選定: インスタンスを取得します。

戻り値:
quotationCfgsInstList 選定: インスタンス

getQuotationCfgsBlobList

public List getQuotationCfgsBlobList()
選定: BLOB 内部データ (SCE)を取得します。

戻り値:
quotationCfgsBlobList 選定: BLOB 内部データ (SCE)

getPartnerAddressesList

public List getPartnerAddressesList()
アドレス (組織/会社) 用 BAPI 参照構造を取得します。

戻り値:
partnerAddressesList アドレス (組織/会社) 用 BAPI 参照構造

getExtensionInList

public List getExtensionInList()
VBAK、VBAP、VBEP のカスタマ拡張を取得します。

戻り値:
extensionInList VBAK、VBAP、VBEP のカスタマ拡張

setBehaveWhenError

public void setBehaveWhenError(String behaveWhenError)
エラー処理を設定します。

パラメータ:
behaveWhenError - エラー処理

setBinaryRelationshiptype

public void setBinaryRelationshiptype(String binaryRelationshiptype)
バイナリ関連タイプ (専用)を設定します。

パラメータ:
binaryRelationshiptype - バイナリ関連タイプ (専用)

setConvert

public void setConvert(String convert)
取引先機能/受注伝票タイプの変換を設定します。

パラメータ:
convert - 取引先機能/受注伝票タイプの変換

setTestrun

public void setTestrun(String testrun)
テスト実行を設定します。

パラメータ:
testrun - テスト実行

setIntNumberAssignment

public void setIntNumberAssignment(String intNumberAssignment)
明細番号内部採番を設定します。

パラメータ:
intNumberAssignment - 明細番号内部採番

setSalesdocumentin

public void setSalesdocumentin(String salesdocumentin)
見積伝票番号を設定します。

パラメータ:
salesdocumentin - 見積伝票番号

setSalesdocument

public void setSalesdocument(String salesdocument)
販売管理伝票番号を設定します。

パラメータ:
salesdocument - 販売管理伝票番号

setLogicSwitch

public void setLogicSwitch(LogicSwitch logicSwitch)
内部制御パラメータを設定します。

パラメータ:
logicSwitch - 内部制御パラメータ

setSender

public void setSender(Sender sender)
論理システム - 送信者を設定します。

パラメータ:
sender - 論理システム - 送信者

setQuotationHeaderInX

public void setQuotationHeaderInX(HeaderInX quotationHeaderInX)
伝票ヘッダチェックボックスを設定します。

パラメータ:
quotationHeaderInX - 伝票ヘッダチェックボックス

setQuotationHeaderIn

public void setQuotationHeaderIn(HeaderIn quotationHeaderIn)
伝票ヘッダデータを設定します。

パラメータ:
quotationHeaderIn - 伝票ヘッダデータ

setQuotationTextList

public void setQuotationTextList(List quotationTextList)
テキストを設定します。

パラメータ:
quotationTextList - テキスト

setQuotationSchedulesInXList

public void setQuotationSchedulesInXList(List quotationSchedulesInXList)
納入日程行データチェックボックスを設定します。

パラメータ:
quotationSchedulesInXList - 納入日程行データチェックボックス

setQuotationSchedulesInList

public void setQuotationSchedulesInList(List quotationSchedulesInList)
納入日程行データを設定します。

パラメータ:
quotationSchedulesInList - 納入日程行データ

setQuotationPartnersList

public void setQuotationPartnersList(List quotationPartnersList)
伝票取引先を設定します。

パラメータ:
quotationPartnersList - 伝票取引先

setQuotationKeysList

public void setQuotationKeysList(List quotationKeysList)
参照キーの出力テーブルを設定します。

パラメータ:
quotationKeysList - 参照キーの出力テーブル

setQuotationItemsInXList

public void setQuotationItemsInXList(List quotationItemsInXList)
明細データチェックボックスを設定します。

パラメータ:
quotationItemsInXList - 明細データチェックボックス

setQuotationItemsInList

public void setQuotationItemsInList(List quotationItemsInList)
明細データを設定します。

パラメータ:
quotationItemsInList - 明細データ

setQuotationConditionsInXList

public void setQuotationConditionsInXList(List quotationConditionsInXList)
受注における条件更新の通信項目を設定します。

パラメータ:
quotationConditionsInXList - 受注における条件更新の通信項目

setQuotationConditionsInList

public void setQuotationConditionsInList(List quotationConditionsInList)
条件を設定します。

パラメータ:
quotationConditionsInList - 条件

setQuotationCfgsVkList

public void setQuotationCfgsVkList(List quotationCfgsVkList)
選定: バリアント条件キーを設定します。

パラメータ:
quotationCfgsVkList - 選定: バリアント条件キー

setQuotationCfgsValueList

public void setQuotationCfgsValueList(List quotationCfgsValueList)
選定: 特性値を設定します。

パラメータ:
quotationCfgsValueList - 選定: 特性値

setQuotationCfgsRefInstList

public void setQuotationCfgsRefInstList(List quotationCfgsRefInstList)
選定: 参照明細/インスタンスを設定します。

パラメータ:
quotationCfgsRefInstList - 選定: 参照明細/インスタンス

setQuotationCfgsRefList

public void setQuotationCfgsRefList(List quotationCfgsRefList)
選定: 参照データを設定します。

パラメータ:
quotationCfgsRefList - 選定: 参照データ

setQuotationCfgsPartOfList

public void setQuotationCfgsPartOfList(List quotationCfgsPartOfList)
選定: 部分設定を設定します。

パラメータ:
quotationCfgsPartOfList - 選定: 部分設定

setQuotationCfgsInstList

public void setQuotationCfgsInstList(List quotationCfgsInstList)
選定: インスタンスを設定します。

パラメータ:
quotationCfgsInstList - 選定: インスタンス

setQuotationCfgsBlobList

public void setQuotationCfgsBlobList(List quotationCfgsBlobList)
選定: BLOB 内部データ (SCE)を設定します。

パラメータ:
quotationCfgsBlobList - 選定: BLOB 内部データ (SCE)

setPartnerAddressesList

public void setPartnerAddressesList(List partnerAddressesList)
アドレス (組織/会社) 用 BAPI 参照構造を設定します。

パラメータ:
partnerAddressesList - アドレス (組織/会社) 用 BAPI 参照構造

setExtensionInList

public void setExtensionInList(List extensionInList)
VBAK、VBAP、VBEP のカスタマ拡張を設定します。

パラメータ:
extensionInList - VBAK、VBAP、VBEP のカスタマ拡張

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 の使用

SalesOrderCreateFromDat2 を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales での SalesOrderCreateFromDat2 の使用

jp.co.intra_mart.foundation.sap.module.sales での SalesOrderCreateFromDat2 のサブクラス
 class SalesOrderCreateFromDat2Controller
受注伝票登録コントローラクラス
機能は以下の通り
受注伝票を登録します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


OrderCcard (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2
クラス OrderCcard

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard
すべての実装インタフェース:
Serializable
public class OrderCcard
extends Object
implements Serializable

クレジットカードデータ情報クラス
機能は以下の通り

  • クレジットカードデータ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
OrderCcard()
クレジットカードデータ情報を作成します。
OrderCcard(int index)
クレジットカードデータ情報を作成します。
メソッドの概要
String | getAuthamount() 支払カード: 承認額を取得します。
String | getAuthCcNo() 支払カード: 承認番号を取得します。
String | getAuthDate() 支払カード: 承認日を取得します。
String | getAuthFlag() 支払カード: 振替権限を取得します。
String | getAuthRefno() 支払カード: 決済代行会社の権限参照コードを取得します。
String | getAuthTime() 支払カード: 承認時刻を取得します。
String | getBillamount() 請求金額: 請求計画に請求日付が指定されている場合を取得します。
String | getCcName() 支払カード: カード所有者の氏名を取得します。
String | getCcNumber() 支払カード: カード番号を取得します。
String | getCcReact() 支払カード: 権限確認に対する応答を取得します。
String | getCcReactT() 支払カード: 結果テキストを取得します。
String | getCcReAmount() BAPI インタフェースの通貨金額を取得します。
String | getCcStatEx() 支払カード: 外部システム呼出時のステータスを取得します。
String | getCcType() 支払カードタイプ: カードタイプを取得します。
String | getCcValidT() 支払カード: 有効終了日を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrIso() ISO コード通貨を取得します。
String | getGlAccount() G/L 勘定コードを取得します。
int | getIndex() レコード番号を取得します｡
String | getMerchidcl() 支払カード: 決済代行会社のマーチャント IDを取得します。
String | getVirtCard() チェックボックスを取得します。
void | setAuthamount(String authamount) 支払カード: 承認額を設定します。
void | setAuthCcNo(String authCcNo) 支払カード: 承認番号を設定します。
void | setAuthDate(String authDate) 支払カード: 承認日を設定します。
void | setAuthFlag(String authFlag) 支払カード: 振替権限を設定します。
void | setAuthRefno(String authRefno) 支払カード: 決済代行会社の権限参照コードを設定します。
void | setAuthTime(String authTime) 支払カード: 承認時刻を設定します。
void | setBillamount(String billamount) 請求金額: 請求計画に請求日付が指定されている場合を設定します。
void | setCcName(String ccName) 支払カード: カード所有者の氏名を設定します。
void | setCcNumber(String ccNumber) 支払カード: カード番号を設定します。
void | setCcReact(String ccReact) 支払カード: 権限確認に対する応答を設定します。
void | setCcReactT(String ccReactT) 支払カード: 結果テキストを設定します。
void | setCcReAmount(String ccReAmount) BAPI インタフェースの通貨金額を設定します。
void | setCcStatEx(String ccStatEx) 支払カード: 外部システム呼出時のステータスを設定します。
void | setCcType(String ccType) 支払カードタイプ: カードタイプを設定します。
void | setCcValidT(String ccValidT) 支払カード: 有効終了日を設定します。
void | setCurrency(String currency) 通貨コードを設定します。
void | setCurrIso(String currIso) ISO コード通貨を設定します。
void | setGlAccount(String glAccount) G/L 勘定コードを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMerchidcl(String merchidcl) 支払カード: 決済代行会社のマーチャント IDを設定します。
void | setVirtCard(String virtCard) チェックボックスを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

OrderCcard

public OrderCcard()
クレジットカードデータ情報を作成します。

OrderCcard

public OrderCcard(int index)
クレジットカードデータ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getCcType

public String getCcType()
支払カードタイプ: カードタイプを取得します。

戻り値:
ccType 支払カードタイプ: カードタイプ

getCcNumber

public String getCcNumber()
支払カード: カード番号を取得します。

戻り値:
ccNumber 支払カード: カード番号

getCcValidT

public String getCcValidT()
支払カード: 有効終了日を取得します。

戻り値:
ccValidT 支払カード: 有効終了日

getCcName

public String getCcName()
支払カード: カード所有者の氏名を取得します。

戻り値:
ccName 支払カード: カード所有者の氏名

getBillamount

public String getBillamount()
請求金額: 請求計画に請求日付が指定されている場合を取得します。

戻り値:
billamount 請求金額: 請求計画に請求日付が指定されている場合

getAuthFlag

public String getAuthFlag()
支払カード: 振替権限を取得します。

戻り値:
authFlag 支払カード: 振替権限

getAuthamount

public String getAuthamount()
支払カード: 承認額を取得します。

戻り値:
authamount 支払カード: 承認額

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
currency 通貨コード

getCurrIso

public String getCurrIso()
ISO コード通貨を取得します。

戻り値:
currIso ISO コード通貨

getAuthDate

public String getAuthDate()
支払カード: 承認日を取得します。

戻り値:
authDate 支払カード: 承認日

getAuthTime

public String getAuthTime()
支払カード: 承認時刻を取得します。

戻り値:
authTime 支払カード: 承認時刻

getAuthCcNo

public String getAuthCcNo()
支払カード: 承認番号を取得します。

戻り値:
authCcNo 支払カード: 承認番号

getAuthRefno

public String getAuthRefno()
支払カード: 決済代行会社の権限参照コードを取得します。

戻り値:
authRefno 支払カード: 決済代行会社の権限参照コード

getCcReact

public String getCcReact()
支払カード: 権限確認に対する応答を取得します。

戻り値:
ccReact 支払カード: 権限確認に対する応答

getCcReAmount

public String getCcReAmount()
BAPI インタフェースの通貨金額を取得します。

戻り値:
ccReAmount BAPI インタフェースの通貨金額

getGlAccount

public String getGlAccount()
G/L 勘定コードを取得します。

戻り値:
glAccount G/L 勘定コード

getCcStatEx

public String getCcStatEx()
支払カード: 外部システム呼出時のステータスを取得します。

戻り値:
ccStatEx 支払カード: 外部システム呼出時のステータス

getCcReactT

public String getCcReactT()
支払カード: 結果テキストを取得します。

戻り値:
ccReactT 支払カード: 結果テキスト

getVirtCard

public String getVirtCard()
チェックボックスを取得します。

戻り値:
virtCard チェックボックス

getMerchidcl

public String getMerchidcl()
支払カード: 決済代行会社のマーチャント IDを取得します。

戻り値:
merchidcl 支払カード: 決済代行会社のマーチャント ID

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setCcType

public void setCcType(String ccType)
支払カードタイプ: カードタイプを設定します。

パラメータ:
ccType - 支払カードタイプ: カードタイプ

setCcNumber

public void setCcNumber(String ccNumber)
支払カード: カード番号を設定します。

パラメータ:
ccNumber - 支払カード: カード番号

setCcValidT

public void setCcValidT(String ccValidT)
支払カード: 有効終了日を設定します。

パラメータ:
ccValidT - 支払カード: 有効終了日

setCcName

public void setCcName(String ccName)
支払カード: カード所有者の氏名を設定します。

パラメータ:
ccName - 支払カード: カード所有者の氏名

setBillamount

public void setBillamount(String billamount)
請求金額: 請求計画に請求日付が指定されている場合を設定します。

パラメータ:
billamount - 請求金額: 請求計画に請求日付が指定されている場合

setAuthFlag

public void setAuthFlag(String authFlag)
支払カード: 振替権限を設定します。

パラメータ:
authFlag - 支払カード: 振替権限

setAuthamount

public void setAuthamount(String authamount)
支払カード: 承認額を設定します。

パラメータ:
authamount - 支払カード: 承認額

setCurrency

public void setCurrency(String currency)
通貨コードを設定します。

パラメータ:
currency - 通貨コード

setCurrIso

public void setCurrIso(String currIso)
ISO コード通貨を設定します。

パラメータ:
currIso - ISO コード通貨

setAuthDate

public void setAuthDate(String authDate)
支払カード: 承認日を設定します。

パラメータ:
authDate - 支払カード: 承認日

setAuthTime

public void setAuthTime(String authTime)
支払カード: 承認時刻を設定します。

パラメータ:
authTime - 支払カード: 承認時刻

setAuthCcNo

public void setAuthCcNo(String authCcNo)
支払カード: 承認番号を設定します。

パラメータ:
authCcNo - 支払カード: 承認番号

setAuthRefno

public void setAuthRefno(String authRefno)
支払カード: 決済代行会社の権限参照コードを設定します。

パラメータ:
authRefno - 支払カード: 決済代行会社の権限参照コード

setCcReact

public void setCcReact(String ccReact)
支払カード: 権限確認に対する応答を設定します。

パラメータ:
ccReact - 支払カード: 権限確認に対する応答

setCcReAmount

public void setCcReAmount(String ccReAmount)
BAPI インタフェースの通貨金額を設定します。

パラメータ:
ccReAmount - BAPI インタフェースの通貨金額

setGlAccount

public void setGlAccount(String glAccount)
G/L 勘定コードを設定します。

パラメータ:
glAccount - G/L 勘定コード

setCcStatEx

public void setCcStatEx(String ccStatEx)
支払カード: 外部システム呼出時のステータスを設定します。

パラメータ:
ccStatEx - 支払カード: 外部システム呼出時のステータス

setCcReactT

public void setCcReactT(String ccReactT)
支払カード: 結果テキストを設定します。

パラメータ:
ccReactT - 支払カード: 結果テキスト

setVirtCard

public void setVirtCard(String virtCard)
チェックボックスを設定します。

パラメータ:
virtCard - チェックボックス

setMerchidcl

public void setMerchidcl(String merchidcl)
支払カード: 決済代行会社のマーチャント IDを設定します。

パラメータ:
merchidcl - 支払カード: 決済代行会社のマーチャント ID

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2
クラス
OrderCcard
ParamOrderCcard
SalesOrderCreateFromDat2


jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2

クラスの概要
OrderCcard | クレジットカードデータ情報クラス 機能は以下の通り クレジットカードデータ情報を保持します。
ParamOrderCcard | クレジットカードデータ情報パラメータ設定クラス 機能は以下の通り クレジットカードデータ情報のパラメータを設定します。
SalesOrderCreateFromDat2 | 受注伝票登録情報クラス 機能は以下の通り 受注伝票登録情報を保持します。


jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のクラス
SalesOrderCreateFromDat2
受注伝票登録情報クラス
機能は以下の通り
受注伝票登録情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamOrderCcard (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2
クラス ParamOrderCcard

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard
すべての実装インタフェース:
Serializable
public final class ParamOrderCcard
extends Object
implements Serializable

クレジットカードデータ情報パラメータ設定クラス
機能は以下の通り

  • クレジットカードデータ情報のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List orderCcardList) table(Export)情報からクレジットカードデータの値をセットします。
static void | setImportParam(BapiController bapiController, List orderCcardList) クレジットカードデータに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List orderCcardList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
クレジットカードデータに値をセットします。

パラメータ:
bapiController - BapiController
orderCcardList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List orderCcardList)
                           throws SAPGeneralSystemException
table(Export)情報からクレジットカードデータの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
orderCcardList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SalesOrderCreateFromDat2 (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2
クラス SalesOrderCreateFromDat2

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
SalesOrderCreateFromDat2Controller
public class SalesOrderCreateFromDat2
extends UpdateController
implements Serializable

受注伝票登録情報クラス
機能は以下の通り

  • 受注伝票登録情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
SalesOrderCreateFromDat2()
コンストラクタ。
SalesOrderCreateFromDat2(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。
SalesOrderCreateFromDat2(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
メソッドの概要
String | getBehaveWhenError() エラー処理を取得します。
String | getBinaryRelationshiptype() バイナリ関連タイプ (専用)を取得します。
String | getConvert() 変換: 取引先機能 + 受注伝票タイプを取得します。
List | getExtensionInList() VBAK、VBAP、VBEP のカスタマ拡張を取得します。
String | getIntNumberAssignment() 明細番号内部採番を取得します。
LogicSwitch | getLogicSwitch() 内部制御パラメータを取得します。
List | getOrderCcardList() クレジットカードデータを取得します。
List | getOrderCfgsBlobList() 選定: BLOB 内部データ (SCE)を取得します。
List | getOrderCfgsInstList() 選定: インスタンスを取得します。
List | getOrderCfgsPartOfList() 選定: 部分設定を取得します。
List | getOrderCfgsRefInstList() 選定: 参照明細/インスタンスを取得します。
List | getOrderCfgsRefList() 選定: 参照データを取得します。
List | getOrderCfgsValueList() 選定: 特性値を取得します。
List | getOrderCfgsVkList() 選定: バリアント条件キーを取得します。
List | getOrderConditionsInList() 条件を取得します。
List | getOrderConditionsInXList() 条件チェックボックスを取得します。
HeaderIn | getOrderHeaderIn() 受注伝票ヘッダを取得します。
HeaderInX | getOrderHeaderInX() 受注伝票チェックリストを取得します。
List | getOrderItemsInList() 明細データを取得します。
List | getOrderItemsInXList() 明細データチェックボックスを取得します。
List | getOrderKeysList() 参照キーの出力テーブルを取得します。
List | getOrderPartnersList() 伝票取引先を取得します。
List | getOrderSchedulesInList() 納入日程行データを取得します。
List | getOrderSchedulesInXList() 納入日程行データチェックボックスを取得します。
List | getOrderTextList() テキストを取得します。
List | getPartnerAddressesList() アドレス (組織/会社) 用 BAPI 参照構造を取得します。
String | getSalesdocument() 生成された伝票の番号を取得します。
String | getSalesdocumentin() 販売管理伝票番号を取得します。
Sender | getSender() 論理システム - 送信者を取得します。
String | getTestrun() テスト実行を取得します。
void | setBehaveWhenError(String behaveWhenError) エラー処理を設定します。
void | setBinaryRelationshiptype(String binaryRelationshiptype) バイナリ関連タイプ (専用)を設定します。
void | setConvert(String convert) 変換: 取引先機能 + 受注伝票タイプを設定します。
void | setExportParam(BapiController bapiController) 見積伝票に登録する値ををセットします。
void | setExtensionInList(List extensionInList) VBAK、VBAP、VBEP のカスタマ拡張を設定します。
void | setImportParam(BapiController bapiController) 見積伝票に登録する値ををセットします。
void | setIntNumberAssignment(String intNumberAssignment) 明細番号内部採番を設定します。
void | setLogicSwitch(LogicSwitch logicSwitch) 内部制御パラメータを設定します。
void | setOrderCcardList(List orderCcardList) クレジットカードデータを設定します。
void | setOrderCfgsBlobList(List orderCfgsBlobList) 選定: BLOB 内部データ (SCE)を設定します。
void | setOrderCfgsInstList(List orderCfgsInstList) 選定: インスタンスを設定します。
void | setOrderCfgsPartOfList(List orderCfgsPartOfList) 選定: 部分設定を設定します。
void | setOrderCfgsRefInstList(List orderCfgsRefInstList) 選定: 参照明細/インスタンスを設定します。
void | setOrderCfgsRefList(List orderCfgsRefList) 選定: 参照データを設定します。
void | setOrderCfgsValueList(List orderCfgsValueList) 選定: 特性値を設定します。
void | setOrderCfgsVkList(List orderCfgsVkList) 選定: バリアント条件キーを設定します。
void | setOrderConditionsInList(List orderConditionsInList) 条件を設定します。
void | setOrderConditionsInXList(List orderConditionsInXList) 条件チェックボックスを設定します。
void | setOrderHeaderIn(HeaderIn orderHeaderIn) 受注伝票ヘッダを設定します。
void | setOrderHeaderInX(HeaderInX orderHeaderInX) 受注伝票チェックリストを設定します。
void | setOrderItemsInList(List orderItemsInList) 明細データを設定します。
void | setOrderItemsInXList(List orderItemsInXList) 明細データチェックボックスを設定します。
void | setOrderKeysList(List orderKeysList) 参照キーの出力テーブルを設定します。
void | setOrderPartnersList(List orderPartnersList) 伝票取引先を設定します。
void | setOrderSchedulesInList(List orderSchedulesInList) 納入日程行データを設定します。
void | setOrderSchedulesInXList(List orderSchedulesInXList) 納入日程行データチェックボックスを設定します。
void | setOrderTextList(List orderTextList) テキストを設定します。
void | setPartnerAddressesList(List partnerAddressesList) アドレス (組織/会社) 用 BAPI 参照構造を設定します。
void | setSalesdocument(String salesdocument) 生成された伝票の番号を設定します。
void | setSalesdocumentin(String salesdocumentin) 販売管理伝票番号を設定します。
void | setSender(Sender sender) 論理システム - 送信者を設定します。
void | setTestrun(String testrun) テスト実行を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesOrderCreateFromDat2

public SalesOrderCreateFromDat2()
コンストラクタ。

SalesOrderCreateFromDat2

public SalesOrderCreateFromDat2(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。

パラメータ:
conectionManager - コネクションマネージャー

SalesOrderCreateFromDat2

public SalesOrderCreateFromDat2(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
見積伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
見積伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getSalesdocumentin

public String getSalesdocumentin()
販売管理伝票番号を取得します。

戻り値:
salesdocumentin 販売管理伝票番号

getIntNumberAssignment

public String getIntNumberAssignment()
明細番号内部採番を取得します。

戻り値:
intNumberAssignment 明細番号内部採番

getTestrun

public String getTestrun()
テスト実行を取得します。

戻り値:
testrun テスト実行

getConvert

public String getConvert()
変換: 取引先機能 + 受注伝票タイプを取得します。

戻り値:
convert 変換: 取引先機能 + 受注伝票タイプ

getBinaryRelationshiptype

public String getBinaryRelationshiptype()
バイナリ関連タイプ (専用)を取得します。

戻り値:
binaryRelationshiptype バイナリ関連タイプ (専用)

getBehaveWhenError

public String getBehaveWhenError()
エラー処理を取得します。

戻り値:
behaveWhenError エラー処理

getSalesdocument

public String getSalesdocument()
生成された伝票の番号を取得します。

戻り値:
salesdocument 生成された伝票の番号

getOrderHeaderIn

public HeaderIn getOrderHeaderIn()
受注伝票ヘッダを取得します。

戻り値:
orderHeaderIn 受注伝票ヘッダ

getOrderHeaderInX

public HeaderInX getOrderHeaderInX()
受注伝票チェックリストを取得します。

戻り値:
orderHeaderInX 受注伝票チェックリスト

getSender

public Sender getSender()
論理システム - 送信者を取得します。

戻り値:
sender 論理システム - 送信者

getLogicSwitch

public LogicSwitch getLogicSwitch()
内部制御パラメータを取得します。

戻り値:
logicSwitch 内部制御パラメータ

getOrderItemsInXList

public List getOrderItemsInXList()
明細データチェックボックスを取得します。

戻り値:
orderItemsInXList 明細データチェックボックス

getOrderKeysList

public List getOrderKeysList()
参照キーの出力テーブルを取得します。

戻り値:
orderKeysList 参照キーの出力テーブル

getOrderPartnersList

public List getOrderPartnersList()
伝票取引先を取得します。

戻り値:
orderPartnersList 伝票取引先

getOrderSchedulesInList

public List getOrderSchedulesInList()
納入日程行データを取得します。

戻り値:
orderSchedulesInList 納入日程行データ

getOrderSchedulesInXList

public List getOrderSchedulesInXList()
納入日程行データチェックボックスを取得します。

戻り値:
orderSchedulesInXList 納入日程行データチェックボックス

getOrderTextList

public List getOrderTextList()
テキストを取得します。

戻り値:
orderTextList テキスト

getPartnerAddressesList

public List getPartnerAddressesList()
アドレス (組織/会社) 用 BAPI 参照構造を取得します。

戻り値:
partnerAddressesList アドレス (組織/会社) 用 BAPI 参照構造

getExtensionInList

public List getExtensionInList()
VBAK、VBAP、VBEP のカスタマ拡張を取得します。

戻り値:
extensionInList VBAK、VBAP、VBEP のカスタマ拡張

getOrderCcardList

public List getOrderCcardList()
クレジットカードデータを取得します。

戻り値:
orderCcardList クレジットカードデータ

getOrderCfgsBlobList

public List getOrderCfgsBlobList()
選定: BLOB 内部データ (SCE)を取得します。

戻り値:
orderCfgsBlobList 選定: BLOB 内部データ (SCE)

getOrderCfgsInstList

public List getOrderCfgsInstList()
選定: インスタンスを取得します。

戻り値:
orderCfgsInstList 選定: インスタンス

getOrderCfgsPartOfList

public List getOrderCfgsPartOfList()
選定: 部分設定を取得します。

戻り値:
orderCfgsPartOfList 選定: 部分設定

getOrderCfgsRefList

public List getOrderCfgsRefList()
選定: 参照データを取得します。

戻り値:
orderCfgsRefList 選定: 参照データ

getOrderCfgsRefInstList

public List getOrderCfgsRefInstList()
選定: 参照明細/インスタンスを取得します。

戻り値:
orderCfgsRefInstList 選定: 参照明細/インスタンス

getOrderCfgsValueList

public List getOrderCfgsValueList()
選定: 特性値を取得します。

戻り値:
orderCfgsValueList 選定: 特性値

getOrderCfgsVkList

public List getOrderCfgsVkList()
選定: バリアント条件キーを取得します。

戻り値:
orderCfgsVkList 選定: バリアント条件キー

getOrderConditionsInList

public List getOrderConditionsInList()
条件を取得します。

戻り値:
orderConditionsInList 条件

getOrderConditionsInXList

public List getOrderConditionsInXList()
条件チェックボックスを取得します。

戻り値:
orderConditionsInXList 条件チェックボックス

getOrderItemsInList

public List getOrderItemsInList()
明細データを取得します。

戻り値:
orderItemsInList 明細データ

setSalesdocumentin

public void setSalesdocumentin(String salesdocumentin)
販売管理伝票番号を設定します。

パラメータ:
salesdocumentin - 販売管理伝票番号

setIntNumberAssignment

public void setIntNumberAssignment(String intNumberAssignment)
明細番号内部採番を設定します。

パラメータ:
intNumberAssignment - 明細番号内部採番

setTestrun

public void setTestrun(String testrun)
テスト実行を設定します。

パラメータ:
testrun - テスト実行

setConvert

public void setConvert(String convert)
変換: 取引先機能 + 受注伝票タイプを設定します。

パラメータ:
convert - 変換: 取引先機能 + 受注伝票タイプ

setBinaryRelationshiptype

public void setBinaryRelationshiptype(String binaryRelationshiptype)
バイナリ関連タイプ (専用)を設定します。

パラメータ:
binaryRelationshiptype - バイナリ関連タイプ (専用)

setBehaveWhenError

public void setBehaveWhenError(String behaveWhenError)
エラー処理を設定します。

パラメータ:
behaveWhenError - エラー処理

setSalesdocument

public void setSalesdocument(String salesdocument)
生成された伝票の番号を設定します。

パラメータ:
salesdocument - 生成された伝票の番号

setOrderHeaderIn

public void setOrderHeaderIn(HeaderIn orderHeaderIn)
受注伝票ヘッダを設定します。

パラメータ:
orderHeaderIn - 受注伝票ヘッダ

setOrderHeaderInX

public void setOrderHeaderInX(HeaderInX orderHeaderInX)
受注伝票チェックリストを設定します。

パラメータ:
orderHeaderInX - 受注伝票チェックリスト

setSender

public void setSender(Sender sender)
論理システム - 送信者を設定します。

パラメータ:
sender - 論理システム - 送信者

setLogicSwitch

public void setLogicSwitch(LogicSwitch logicSwitch)
内部制御パラメータを設定します。

パラメータ:
logicSwitch - 内部制御パラメータ

setOrderItemsInXList

public void setOrderItemsInXList(List orderItemsInXList)
明細データチェックボックスを設定します。

パラメータ:
orderItemsInXList - 明細データチェックボックス

setOrderKeysList

public void setOrderKeysList(List orderKeysList)
参照キーの出力テーブルを設定します。

パラメータ:
orderKeysList - 参照キーの出力テーブル

setOrderPartnersList

public void setOrderPartnersList(List orderPartnersList)
伝票取引先を設定します。

パラメータ:
orderPartnersList - 伝票取引先

setOrderSchedulesInList

public void setOrderSchedulesInList(List orderSchedulesInList)
納入日程行データを設定します。

パラメータ:
orderSchedulesInList - 納入日程行データ

setOrderSchedulesInXList

public void setOrderSchedulesInXList(List orderSchedulesInXList)
納入日程行データチェックボックスを設定します。

パラメータ:
orderSchedulesInXList - 納入日程行データチェックボックス

setOrderTextList

public void setOrderTextList(List orderTextList)
テキストを設定します。

パラメータ:
orderTextList - テキスト

setPartnerAddressesList

public void setPartnerAddressesList(List partnerAddressesList)
アドレス (組織/会社) 用 BAPI 参照構造を設定します。

パラメータ:
partnerAddressesList - アドレス (組織/会社) 用 BAPI 参照構造

setExtensionInList

public void setExtensionInList(List extensionInList)
VBAK、VBAP、VBEP のカスタマ拡張を設定します。

パラメータ:
extensionInList - VBAK、VBAP、VBEP のカスタマ拡張

setOrderCcardList

public void setOrderCcardList(List orderCcardList)
クレジットカードデータを設定します。

パラメータ:
orderCcardList - クレジットカードデータ

setOrderCfgsBlobList

public void setOrderCfgsBlobList(List orderCfgsBlobList)
選定: BLOB 内部データ (SCE)を設定します。

パラメータ:
orderCfgsBlobList - 選定: BLOB 内部データ (SCE)

setOrderCfgsInstList

public void setOrderCfgsInstList(List orderCfgsInstList)
選定: インスタンスを設定します。

パラメータ:
orderCfgsInstList - 選定: インスタンス

setOrderCfgsPartOfList

public void setOrderCfgsPartOfList(List orderCfgsPartOfList)
選定: 部分設定を設定します。

パラメータ:
orderCfgsPartOfList - 選定: 部分設定

setOrderCfgsRefList

public void setOrderCfgsRefList(List orderCfgsRefList)
選定: 参照データを設定します。

パラメータ:
orderCfgsRefList - 選定: 参照データ

setOrderCfgsRefInstList

public void setOrderCfgsRefInstList(List orderCfgsRefInstList)
選定: 参照明細/インスタンスを設定します。

パラメータ:
orderCfgsRefInstList - 選定: 参照明細/インスタンス

setOrderCfgsValueList

public void setOrderCfgsValueList(List orderCfgsValueList)
選定: 特性値を設定します。

パラメータ:
orderCfgsValueList - 選定: 特性値

setOrderCfgsVkList

public void setOrderCfgsVkList(List orderCfgsVkList)
選定: バリアント条件キーを設定します。

パラメータ:
orderCfgsVkList - 選定: バリアント条件キー

setOrderConditionsInList

public void setOrderConditionsInList(List orderConditionsInList)
条件を設定します。

パラメータ:
orderConditionsInList - 条件

setOrderConditionsInXList

public void setOrderConditionsInXList(List orderConditionsInXList)
条件チェックボックスを設定します。

パラメータ:
orderConditionsInXList - 条件チェックボックス

setOrderItemsInList

public void setOrderItemsInList(List orderItemsInList)
明細データを設定します。

パラメータ:
orderItemsInList - 明細データ

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList の使用

SalesOrderGetList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales での SalesOrderGetList の使用

jp.co.intra_mart.foundation.sap.module.sales での SalesOrderGetList のサブクラス
 class SalesOrderGetListController
販売伝票一覧照会コントローラクラス
機能は以下の通り
販売伝票一覧の情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist
クラス
ParamSalesOrders
SalesOrderGetList
SalesOrders


jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist

クラスの概要
ParamSalesOrders | 得意先受注テーブル情報パラメータ設定クラス 機能は以下の通り 得意先受注テーブル情報のパラメータを設定します。
SalesOrderGetList | 販売伝票一覧照会情報クラス 機能は以下の通り 販売伝票一覧照会情報を保持します。
SalesOrders | 得意先受注テーブル情報クラス 機能は以下の通り 得意先受注テーブル情報を保持します。


jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist のクラス
SalesOrderGetList
販売伝票一覧照会情報クラス
機能は以下の通り
販売伝票一覧照会情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamSalesOrders (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist
クラス ParamSalesOrders

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders
すべての実装インタフェース:
Serializable
public final class ParamSalesOrders
extends Object
implements Serializable

得意先受注テーブル情報パラメータ設定クラス
機能は以下の通り

  • 得意先受注テーブル情報のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List salesOrdersList) table(Export)情報から得意先受注テーブル情報の値をセットします。
static void | setImportParam(BapiController bapiController, List salesOrdersList) 得意先受注テーブル情報の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List salesOrdersList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
得意先受注テーブル情報の値をセットします。

パラメータ:
bapiController - BapiController
salesOrdersList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List salesOrdersList)
                           throws SAPGeneralSystemException
table(Export)情報から得意先受注テーブル情報の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
salesOrdersList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SalesOrderGetList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist
クラス SalesOrderGetList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
SalesOrderGetListController
public class SalesOrderGetList
extends ReferenceController
implements Serializable

販売伝票一覧照会情報クラス
機能は以下の通り

  • 販売伝票一覧照会情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
SalesOrderGetList(SapClient sapClient)
販売伝票一覧照会情報を作成します。
SalesOrderGetList(String customerNumber, String salesOrganisation, String material, String purchaseOrder, String transactionGroup, SapClient sapClient)
販売伝票一覧照会情報を作成します。
メソッドの概要
String | getCustomerNumber() 得意先コードを取得します。
String | getDocumentDate() 登録日付を取得します。
String | getDocumentDateTo() 入力日付 (以前/以降)を取得します。
String | getMaterial() 品目コードを取得します。
String | getPurchaseOrder() 得意先発注番号を取得します。
String | getPurchaseOrderNumber() 得意先発注番号1を取得します。
List | getSalesOrdersList() 得意先受注テーブルを取得します。
String | getSalesOrganization() 販売組織を取得します。
String | getTransactionGroup() 一文字フラグを取得します。
void | setCustomerNumber(String customerNumber) 得意先コードを設定します。
void | setDocumentDate(String documentDate) 登録日付を設定します。
void | setDocumentDateTo(String documentDateTo) 入力日付 (以前/以降)を設定します。
void | setExportParam(BapiController bapiController) 返却された販売伝票一覧照会情報をセットします。
void | setImportParam(BapiController bapiController) 販売伝票一覧の検索条件をセットします。
void | setMaterial(String material) 品目コードを設定します。
void | setPurchaseOrder(String purchaseOrder) 得意先発注番号を設定します。
void | setPurchaseOrderNumber(String purchaseOrderNumber) 得意先発注番号1を設定します。
void | setSalesOrdersList(List salesOrdersList) 得意先受注テーブルを設定します。
void | setSalesOrganization(String salesOrganization) 販売組織を設定します。
void | setTransactionGroup(String transactionGroup) 一文字フラグを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesOrderGetList

public SalesOrderGetList(SapClient sapClient)
販売伝票一覧照会情報を作成します。

パラメータ:
sapClient - SAPクライアント

SalesOrderGetList

public SalesOrderGetList(String customerNumber,
                         String salesOrganisation,
                         String material,
                         String purchaseOrder,
                         String transactionGroup,
                         SapClient sapClient)
販売伝票一覧照会情報を作成します。

パラメータ:
customerNumber - 得意先コード
salesOrganisation - 販売組織
material - 品目コード
purchaseOrder - 得意先発注番号
transactionGroup - 一文字フラグ
sapClient - SAPクライアント
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
販売伝票一覧の検索条件をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
返却された販売伝票一覧照会情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getCustomerNumber

public String getCustomerNumber()
得意先コードを取得します。

戻り値:
customerNumber 得意先コード

getDocumentDate

public String getDocumentDate()
登録日付を取得します。

戻り値:
documentDate 登録日付

getDocumentDateTo

public String getDocumentDateTo()
入力日付 (以前/以降)を取得します。

戻り値:
documentDateTo 入力日付 (以前/以降)

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPurchaseOrder

public String getPurchaseOrder()
得意先発注番号を取得します。

戻り値:
purchaseOrder 得意先発注番号

getPurchaseOrderNumber

public String getPurchaseOrderNumber()
得意先発注番号1を取得します。

戻り値:
purchaseOrderNumber 得意先発注番号1

getSalesOrganization

public String getSalesOrganization()
販売組織を取得します。

戻り値:
salesOrganization 販売組織

getTransactionGroup

public String getTransactionGroup()
一文字フラグを取得します。

戻り値:
transactionGroup 一文字フラグ

getSalesOrdersList

public List getSalesOrdersList()
得意先受注テーブルを取得します。

戻り値:
salesOrdersList 得意先受注テーブル

setCustomerNumber

public void setCustomerNumber(String customerNumber)
得意先コードを設定します。

パラメータ:
customerNumber - 得意先コード

setDocumentDate

public void setDocumentDate(String documentDate)
登録日付を設定します。

パラメータ:
documentDate - 登録日付

setDocumentDateTo

public void setDocumentDateTo(String documentDateTo)
入力日付 (以前/以降)を設定します。

パラメータ:
documentDateTo - 入力日付 (以前/以降)

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPurchaseOrder

public void setPurchaseOrder(String purchaseOrder)
得意先発注番号を設定します。

パラメータ:
purchaseOrder - 得意先発注番号

setPurchaseOrderNumber

public void setPurchaseOrderNumber(String purchaseOrderNumber)
得意先発注番号1を設定します。

パラメータ:
purchaseOrderNumber - 得意先発注番号1

setSalesOrganization

public void setSalesOrganization(String salesOrganization)
販売組織を設定します。

パラメータ:
salesOrganization - 販売組織

setTransactionGroup

public void setTransactionGroup(String transactionGroup)
一文字フラグを設定します。

パラメータ:
transactionGroup - 一文字フラグ

setSalesOrdersList

public void setSalesOrdersList(List salesOrdersList)
得意先受注テーブルを設定します。

パラメータ:
salesOrdersList - 得意先受注テーブル

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SalesOrders (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist
クラス SalesOrders

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders
すべての実装インタフェース:
Serializable
public class SalesOrders
extends Object
implements Serializable

得意先受注テーブル情報クラス
機能は以下の通り

  • 得意先受注テーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
SalesOrders()
得意先受注テーブル情報を作成します。
SalesOrders(int index)
得意先受注テーブル情報を作成します。
メソッドの概要
String | getBaseUom() 基本数量単位を取得します。
String | getBatch() ロット番号を取得します。
String | getBillBlock() 販売管理伝票の請求ブロックを取得します。
String | getBUomIso() ISO コードでの基本数量単位を取得します。
String | getCdUntIso() 条件数量単位 (ISO コード)を取得します。
String | getCondPUnt() 価格条件単位を取得します。
String | getCondUnit() 条件単位を取得します。
String | getCreationDate() レコード登録日を取得します。
String | getCreationTime() 登録時刻を取得します。
String | getCurrency() 販売伝票通貨を取得します。
String | getCurrIso() ISO コード通貨を取得します。
String | getDistrChan() 流通チャネルを取得します。
String | getDivision() 製品部門を取得します。
String | getDlvBlock() 出荷ブロック (伝票ヘッダ)を取得します。
String | getDlvQty() 出荷数量実績 (販売単位)を取得します。
String | getDocDate() 伝票日付 (受信日/送信日)を取得します。
String | getDocStatus() 伝票ステータスを取得します。
String | getDocType() 販売伝票タイプを取得します。
String | getExchgRate() 価格設定/統計の換算レート (直接引用)を取得します。
String | getExchgRateV() 価格設定/統計の換算レート (間接引用)を取得します。
String | getGiDate() 出庫日付を取得します。
int | getIndex() レコード番号を取得します｡
String | getItmNumber() 明細番号 (販売管理伝票)を取得します。
String | getMaterial() 品目コードを取得します。
String | getMatExt() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMatGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMatVers() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getName() 名称 1を取得します。
String | getNetPrice() 正味価格を取得します。
String | getNetValHd() 受注正味額 (伝票通貨)を取得します。
String | getNetValue() 伝票通貨による正味額を取得します。
String | getOrdReason() 受注理由 (取引理由)を取得します。
String | getPlant() プラントを取得します。
String | getPurchNo() 得意先発注番号を取得します。
String | getPurchNoC() 出荷先発注番号を取得します。
String | getReasonRej() 見積および受注の拒否理由を取得します。
String | getReqDate() 指定納期を取得します。
String | getReqQty() 累積受注数量 (販売単位)を取得します。
String | getSalesGrp() 営業グループを取得します。
String | getSalesOff() 営業所を取得します。
String | getSalesOrg() 販売組織を取得します。
String | getSalesUnit() 販売単位を取得します。
String | getSdDoc() 販売管理伝票番号を取得します。
String | getShipPoint() 出荷ポイント/入荷ポイントを取得します。
String | getShortText() テキスト (短): 受注明細を取得します。
String | getSoldTo() 受注先を取得します。
String | getStoreLoc() 保管場所を取得します。
String | getSUnitIso() ISO コードによる販売単位を取得します。
String | getValidFrom() 見積または基本契約の有効開始日を取得します。
String | getValidTo() 見積または基本契約有効終了日を取得します。
void | setBaseUom(String baseUom) 基本数量単位を設定します。
void | setBatch(String batch) ロット番号を設定します。
void | setBillBlock(String billBlock) 販売管理伝票の請求ブロックを設定します。
void | setBUomIso(String bUomIso) ISO コードでの基本数量単位を設定します。
void | setCdUntIso(String cdUntIso) 条件数量単位 (ISO コード)を設定します。
void | setCondPUnt(String condPUnt) 価格条件単位を設定します。
void | setCondUnit(String condUnit) 条件単位を設定します。
void | setCreationDate(String creationDate) レコード登録日を設定します。
void | setCreationTime(String creationTime) 登録時刻を設定します。
void | setCurrency(String currency) 販売伝票通貨を設定します。
void | setCurrIso(String currIso) ISO コード通貨を設定します。
void | setDistrChan(String distrChan) 流通チャネルを設定します。
void | setDivision(String division) 製品部門を設定します。
void | setDlvBlock(String dlvBlock) 出荷ブロック (伝票ヘッダ)を設定します。
void | setDlvQty(String dlvQty) 出荷数量実績 (販売単位)を設定します。
void | setDocDate(String docDate) 伝票日付 (受信日/送信日)を設定します。
void | setDocStatus(String docStatus) 伝票ステータスを設定します。
void | setDocType(String docType) 販売伝票タイプを設定します。
void | setExchgRate(String exchgRate) 価格設定/統計の換算レート (直接引用)を設定します。
void | setExchgRateV(String exchgRateV) 価格設定/統計の換算レート (間接引用)を設定します。
void | setGiDate(String giDate) 出庫日付を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItmNumber(String itmNumber) 明細番号 (販売管理伝票)を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMatExt(String matExt) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMatGuid(String matGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMatVers(String matVers) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setName(String name) 名称 1を設定します。
void | setNetPrice(String netPrice) 正味価格を設定します。
void | setNetValHd(String netValHd) 受注正味額 (伝票通貨)を設定します。
void | setNetValue(String netValue) 伝票通貨による正味額を設定します。
void | setOrdReason(String ordReason) 受注理由 (取引理由)を設定します。
void | setPlant(String plant) プラントを設定します。
void | setPurchNo(String purchNo) 得意先発注番号を設定します。
void | setPurchNoC(String purchNoC) 出荷先発注番号を設定します。
void | setReasonRej(String reasonRej) 見積および受注の拒否理由を設定します。
void | setReqDate(String reqDate) 指定納期を設定します。
void | setReqQty(String reqQty) 累積受注数量 (販売単位)を設定します。
void | setSalesGrp(String salesGrp) 営業グループを設定します。
void | setSalesOff(String salesOff) 営業所を設定します。
void | setSalesOrg(String salesOrg) 販売組織を設定します。
void | setSalesUnit(String salesUnit) 販売単位を設定します。
void | setSdDoc(String sdDoc) 販売管理伝票番号を設定します。
void | setShipPoint(String shipPoint) 出荷ポイント/入荷ポイントを設定します。
void | setShortText(String shortText) テキスト (短): 受注明細を設定します。
void | setSoldTo(String soldTo) 受注先を設定します。
void | setStoreLoc(String storeLoc) 保管場所を設定します。
void | setSUnitIso(String sUnitIso) ISO コードによる販売単位を設定します。
void | setValidFrom(String validFrom) 見積または基本契約の有効開始日を設定します。
void | setValidTo(String validTo) 見積または基本契約有効終了日を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesOrders

public SalesOrders()
得意先受注テーブル情報を作成します。

SalesOrders

public SalesOrders(int index)
得意先受注テーブル情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSdDoc

public String getSdDoc()
販売管理伝票番号を取得します。

戻り値:
sdDoc 販売管理伝票番号

getItmNumber

public String getItmNumber()
明細番号 (販売管理伝票)を取得します。

戻り値:
itmNumber 明細番号 (販売管理伝票)

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getShortText

public String getShortText()
テキスト (短): 受注明細を取得します。

戻り値:
shortText テキスト (短): 受注明細

getDocType

public String getDocType()
販売伝票タイプを取得します。

戻り値:
docType 販売伝票タイプ

getDocDate

public String getDocDate()
伝票日付 (受信日/送信日)を取得します。

戻り値:
docDate 伝票日付 (受信日/送信日)

getReqQty

public String getReqQty()
累積受注数量 (販売単位)を取得します。

戻り値:
reqQty 累積受注数量 (販売単位)

getReqDate

public String getReqDate()
指定納期を取得します。

戻り値:
reqDate 指定納期

getPurchNo

public String getPurchNo()
得意先発注番号を取得します。

戻り値:
purchNo 得意先発注番号

getBatch

public String getBatch()
ロット番号を取得します。

戻り値:
batch ロット番号

getValidFrom

public String getValidFrom()
見積または基本契約の有効開始日を取得します。

戻り値:
validFrom 見積または基本契約の有効開始日

getValidTo

public String getValidTo()
見積または基本契約有効終了日を取得します。

戻り値:
validTo 見積または基本契約有効終了日

getBillBlock

public String getBillBlock()
販売管理伝票の請求ブロックを取得します。

戻り値:
billBlock 販売管理伝票の請求ブロック

getDlvBlock

public String getDlvBlock()
出荷ブロック (伝票ヘッダ)を取得します。

戻り値:
dlvBlock 出荷ブロック (伝票ヘッダ)

getSoldTo

public String getSoldTo()
受注先を取得します。

戻り値:
soldTo 受注先

getName

public String getName()
名称 1を取得します。

戻り値:
name 名称 1

getExchgRate

public String getExchgRate()
価格設定/統計の換算レート (直接引用)を取得します。

戻り値:
exchgRate 価格設定/統計の換算レート (直接引用)

getDlvQty

public String getDlvQty()
出荷数量実績 (販売単位)を取得します。

戻り値:
dlvQty 出荷数量実績 (販売単位)

getBaseUom

public String getBaseUom()
基本数量単位を取得します。

戻り値:
baseUom 基本数量単位

getNetPrice

public String getNetPrice()
正味価格を取得します。

戻り値:
netPrice 正味価格

getCondPUnt

public String getCondPUnt()
価格条件単位を取得します。

戻り値:
condPUnt 価格条件単位

getCondUnit

public String getCondUnit()
条件単位を取得します。

戻り値:
condUnit 条件単位

getNetValHd

public String getNetValHd()
受注正味額 (伝票通貨)を取得します。

戻り値:
netValHd 受注正味額 (伝票通貨)

getNetValue

public String getNetValue()
伝票通貨による正味額を取得します。

戻り値:
netValue 伝票通貨による正味額

getDivision

public String getDivision()
製品部門を取得します。

戻り値:
division 製品部門

getDocStatus

public String getDocStatus()
伝票ステータスを取得します。

戻り値:
docStatus 伝票ステータス

getSalesGrp

public String getSalesGrp()
営業グループを取得します。

戻り値:
salesGrp 営業グループ

getSalesOff

public String getSalesOff()
営業所を取得します。

戻り値:
salesOff 営業所

getSalesOrg

public String getSalesOrg()
販売組織を取得します。

戻り値:
salesOrg 販売組織

getSalesUnit

public String getSalesUnit()
販売単位を取得します。

戻り値:
salesUnit 販売単位

getShipPoint

public String getShipPoint()
出荷ポイント/入荷ポイントを取得します。

戻り値:
shipPoint 出荷ポイント/入荷ポイント

getDistrChan

public String getDistrChan()
流通チャネルを取得します。

戻り値:
distrChan 流通チャネル

getGiDate

public String getGiDate()
出庫日付を取得します。

戻り値:
giDate 出庫日付

getCurrency

public String getCurrency()
販売伝票通貨を取得します。

戻り値:
currency 販売伝票通貨

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getStoreLoc

public String getStoreLoc()
保管場所を取得します。

戻り値:
storeLoc 保管場所

getOrdReason

public String getOrdReason()
受注理由 (取引理由)を取得します。

戻り値:
ordReason 受注理由 (取引理由)

getReasonRej

public String getReasonRej()
見積および受注の拒否理由を取得します。

戻り値:
reasonRej 見積および受注の拒否理由

getBUomIso

public String getBUomIso()
ISO コードでの基本数量単位を取得します。

戻り値:
bUomIso ISO コードでの基本数量単位

getCdUntIso

public String getCdUntIso()
条件数量単位 (ISO コード)を取得します。

戻り値:
cdUntIso 条件数量単位 (ISO コード)

getSUnitIso

public String getSUnitIso()
ISO コードによる販売単位を取得します。

戻り値:
sUnitIso ISO コードによる販売単位

getCurrIso

public String getCurrIso()
ISO コード通貨を取得します。

戻り値:
currIso ISO コード通貨

getPurchNoC

public String getPurchNoC()
出荷先発注番号を取得します。

戻り値:
purchNoC 出荷先発注番号

getExchgRateV

public String getExchgRateV()
価格設定/統計の換算レート (間接引用)を取得します。

戻り値:
exchgRateV 価格設定/統計の換算レート (間接引用)

getMatExt

public String getMatExt()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
matExt 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMatGuid

public String getMatGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
matGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMatVers

public String getMatVers()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
matVers 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getCreationDate

public String getCreationDate()
レコード登録日を取得します。

戻り値:
creationDate レコード登録日

getCreationTime

public String getCreationTime()
登録時刻を取得します。

戻り値:
creationTime 登録時刻

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSdDoc

public void setSdDoc(String sdDoc)
販売管理伝票番号を設定します。

パラメータ:
sdDoc - 販売管理伝票番号

setItmNumber

public void setItmNumber(String itmNumber)
明細番号 (販売管理伝票)を設定します。

パラメータ:
itmNumber - 明細番号 (販売管理伝票)

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setShortText

public void setShortText(String shortText)
テキスト (短): 受注明細を設定します。

パラメータ:
shortText - テキスト (短): 受注明細

setDocType

public void setDocType(String docType)
販売伝票タイプを設定します。

パラメータ:
docType - 販売伝票タイプ

setDocDate

public void setDocDate(String docDate)
伝票日付 (受信日/送信日)を設定します。

パラメータ:
docDate - 伝票日付 (受信日/送信日)

setReqQty

public void setReqQty(String reqQty)
累積受注数量 (販売単位)を設定します。

パラメータ:
reqQty - 累積受注数量 (販売単位)

setReqDate

public void setReqDate(String reqDate)
指定納期を設定します。

パラメータ:
reqDate - 指定納期

setPurchNo

public void setPurchNo(String purchNo)
得意先発注番号を設定します。

パラメータ:
purchNo - 得意先発注番号

setBatch

public void setBatch(String batch)
ロット番号を設定します。

パラメータ:
batch - ロット番号

setValidFrom

public void setValidFrom(String validFrom)
見積または基本契約の有効開始日を設定します。

パラメータ:
validFrom - 見積または基本契約の有効開始日

setValidTo

public void setValidTo(String validTo)
見積または基本契約有効終了日を設定します。

パラメータ:
validTo - 見積または基本契約有効終了日

setBillBlock

public void setBillBlock(String billBlock)
販売管理伝票の請求ブロックを設定します。

パラメータ:
billBlock - 販売管理伝票の請求ブロック

setDlvBlock

public void setDlvBlock(String dlvBlock)
出荷ブロック (伝票ヘッダ)を設定します。

パラメータ:
dlvBlock - 出荷ブロック (伝票ヘッダ)

setSoldTo

public void setSoldTo(String soldTo)
受注先を設定します。

パラメータ:
soldTo - 受注先

setName

public void setName(String name)
名称 1を設定します。

パラメータ:
name - 名称 1

setExchgRate

public void setExchgRate(String exchgRate)
価格設定/統計の換算レート (直接引用)を設定します。

パラメータ:
exchgRate - 価格設定/統計の換算レート (直接引用)

setDlvQty

public void setDlvQty(String dlvQty)
出荷数量実績 (販売単位)を設定します。

パラメータ:
dlvQty - 出荷数量実績 (販売単位)

setBaseUom

public void setBaseUom(String baseUom)
基本数量単位を設定します。

パラメータ:
baseUom - 基本数量単位

setNetPrice

public void setNetPrice(String netPrice)
正味価格を設定します。

パラメータ:
netPrice - 正味価格

setCondPUnt

public void setCondPUnt(String condPUnt)
価格条件単位を設定します。

パラメータ:
condPUnt - 価格条件単位

setCondUnit

public void setCondUnit(String condUnit)
条件単位を設定します。

パラメータ:
condUnit - 条件単位

setNetValHd

public void setNetValHd(String netValHd)
受注正味額 (伝票通貨)を設定します。

パラメータ:
netValHd - 受注正味額 (伝票通貨)

setNetValue

public void setNetValue(String netValue)
伝票通貨による正味額を設定します。

パラメータ:
netValue - 伝票通貨による正味額

setDivision

public void setDivision(String division)
製品部門を設定します。

パラメータ:
division - 製品部門

setDocStatus

public void setDocStatus(String docStatus)
伝票ステータスを設定します。

パラメータ:
docStatus - 伝票ステータス

setSalesGrp

public void setSalesGrp(String salesGrp)
営業グループを設定します。

パラメータ:
salesGrp - 営業グループ

setSalesOff

public void setSalesOff(String salesOff)
営業所を設定します。

パラメータ:
salesOff - 営業所

setSalesOrg

public void setSalesOrg(String salesOrg)
販売組織を設定します。

パラメータ:
salesOrg - 販売組織

setSalesUnit

public void setSalesUnit(String salesUnit)
販売単位を設定します。

パラメータ:
salesUnit - 販売単位

setShipPoint

public void setShipPoint(String shipPoint)
出荷ポイント/入荷ポイントを設定します。

パラメータ:
shipPoint - 出荷ポイント/入荷ポイント

setDistrChan

public void setDistrChan(String distrChan)
流通チャネルを設定します。

パラメータ:
distrChan - 流通チャネル

setGiDate

public void setGiDate(String giDate)
出庫日付を設定します。

パラメータ:
giDate - 出庫日付

setCurrency

public void setCurrency(String currency)
販売伝票通貨を設定します。

パラメータ:
currency - 販売伝票通貨

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setStoreLoc

public void setStoreLoc(String storeLoc)
保管場所を設定します。

パラメータ:
storeLoc - 保管場所

setOrdReason

public void setOrdReason(String ordReason)
受注理由 (取引理由)を設定します。

パラメータ:
ordReason - 受注理由 (取引理由)

setReasonRej

public void setReasonRej(String reasonRej)
見積および受注の拒否理由を設定します。

パラメータ:
reasonRej - 見積および受注の拒否理由

setBUomIso

public void setBUomIso(String bUomIso)
ISO コードでの基本数量単位を設定します。

パラメータ:
bUomIso - ISO コードでの基本数量単位

setCdUntIso

public void setCdUntIso(String cdUntIso)
条件数量単位 (ISO コード)を設定します。

パラメータ:
cdUntIso - 条件数量単位 (ISO コード)

setSUnitIso

public void setSUnitIso(String sUnitIso)
ISO コードによる販売単位を設定します。

パラメータ:
sUnitIso - ISO コードによる販売単位

setCurrIso

public void setCurrIso(String currIso)
ISO コード通貨を設定します。

パラメータ:
currIso - ISO コード通貨

setPurchNoC

public void setPurchNoC(String purchNoC)
出荷先発注番号を設定します。

パラメータ:
purchNoC - 出荷先発注番号

setExchgRateV

public void setExchgRateV(String exchgRateV)
価格設定/統計の換算レート (間接引用)を設定します。

パラメータ:
exchgRateV - 価格設定/統計の換算レート (間接引用)

setMatExt

public void setMatExt(String matExt)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
matExt - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMatGuid

public void setMatGuid(String matGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
matGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMatVers

public void setMatVers(String matVers)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
matVers - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setCreationDate

public void setCreationDate(String creationDate)
レコード登録日を設定します。

パラメータ:
creationDate - レコード登録日

setCreationTime

public void setCreationTime(String creationTime)
登録時刻を設定します。

パラメータ:
creationTime - 登録時刻

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus の使用

SalesOrderGetStatus を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales での SalesOrderGetStatus の使用

jp.co.intra_mart.foundation.sap.module.sales での SalesOrderGetStatus のサブクラス
 class SalesOrderGetStatusController
販売伝票ステータス一覧照会コントローラクラス
機能は以下の通り
販売伝票ステータス一覧の情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus
クラス
ParamStatusInfo
SalesOrderGetStatus
StatusInfo


jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus

クラスの概要
ParamStatusInfo | ステータス情報パラメータ設定クラス 機能は以下の通り ステータス情報のパラメータを設定します。
SalesOrderGetStatus | 販売伝票ステータス一覧照会情報クラス 機能は以下の通り 販売伝票ステータス一覧照会情報を保持します。
StatusInfo | ステータス情報情報クラス 機能は以下の通り ステータス情報情報を保持します。


jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus のクラス
SalesOrderGetStatus
販売伝票ステータス一覧照会情報クラス
機能は以下の通り
販売伝票ステータス一覧照会情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamStatusInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus
クラス ParamStatusInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo
すべての実装インタフェース:
Serializable
public final class ParamStatusInfo
extends Object
implements Serializable

ステータス情報パラメータ設定クラス
機能は以下の通り

  • ステータス情報のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List statusInfoList) table(Export)情報からステータス情報の値をセットします。
static void | setImportParam(BapiController bapiController, List statusInfoList) ステータス情報の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List statusInfoList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
ステータス情報の値をセットします。

パラメータ:
bapiController - BapiController
statusInfoList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List statusInfoList)
                           throws SAPGeneralSystemException
table(Export)情報からステータス情報の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
statusInfoList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SalesOrderGetStatus (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus
クラス SalesOrderGetStatus

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
SalesOrderGetStatusController
public class SalesOrderGetStatus
extends ReferenceController
implements Serializable

販売伝票ステータス一覧照会情報クラス
機能は以下の通り

  • 販売伝票ステータス一覧照会情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
SalesOrderGetStatus(SapClient sapClient)
販売伝票ステータス一覧照会情報を作成します。
SalesOrderGetStatus(String salesdocument, SapClient sapClient)
販売伝票ステータス一覧照会情報を作成します。
メソッドの概要
String | getSalesdocument() 販売管理伝票番号を取得します。
ArrayList | getStatusInfoList() ステータス情報を取得します。
void | setExportParam(BapiController bapiController) 返却された販売伝票ステータス一覧照会情報をセットします。
void | setImportParam(BapiController bapiController) 販売伝票ステータス一覧の検索条件をセットします。
void | setSalesdocument(String salesdocument) 販売管理伝票番号を設定します。
void | setStatusInfoList(ArrayList statusInfoList) ステータス情報を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesOrderGetStatus

public SalesOrderGetStatus(SapClient sapClient)
販売伝票ステータス一覧照会情報を作成します。

パラメータ:
sapClient - SAPクライアント

SalesOrderGetStatus

public SalesOrderGetStatus(String salesdocument,
                           SapClient sapClient)
販売伝票ステータス一覧照会情報を作成します。

パラメータ:
sapClient - SAPクライアント
salesdocument - 販売管理伝票番号
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
販売伝票ステータス一覧の検索条件をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
返却された販売伝票ステータス一覧照会情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getSalesdocument

public String getSalesdocument()
販売管理伝票番号を取得します。

戻り値:
salesdocument 販売管理伝票番号

getStatusInfoList

public ArrayList getStatusInfoList()
ステータス情報を取得します。

戻り値:
statusInfoList ステータス情報

setSalesdocument

public void setSalesdocument(String salesdocument)
販売管理伝票番号を設定します。

パラメータ:
salesdocument - 販売管理伝票番号

setStatusInfoList

public void setStatusInfoList(ArrayList statusInfoList)
ステータス情報を設定します。

パラメータ:
statusInfoList - ステータス情報

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StatusInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus
クラス StatusInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo
すべての実装インタフェース:
Serializable
public class StatusInfo
extends Object
implements Serializable

ステータス情報情報クラス
機能は以下の通り

  • ステータス情報情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
StatusInfo()
ステータス情報情報を作成します。
StatusInfo(int index)
ステータス情報情報を作成します。
メソッドの概要
String | getCdUntIso() 条件数量単位 (ISO コード)を取得します。
String | getCondPUnt() 価格条件単位を取得します。
String | getCondUnit() 条件単位を取得します。
String | getCreationDate() レコード登録日を取得します。
String | getCreationTime() 登録時刻を取得します。
String | getCumCfQty() 累積確認数量 (販売数量単位)を取得します。
String | getCurrency() 販売伝票通貨を取得します。
String | getCurrIso() ISO コード通貨を取得します。
String | getDelivDate() 納入期日を取得します。
String | getDelivItem() 出荷明細を取得します。
String | getDelivNumb() 出荷伝票を取得します。
String | getDlvBlock() 出荷ブロック (伝票ヘッダ)を取得します。
String | getDlvQty() 出荷数量実績 (販売単位)を取得します。
String | getDlvStatH() 全明細の出荷ステータスを取得します。
String | getDlvStatI() 明細の全体出荷ステータスを取得します。
String | getDlvUnitIso() ISO コードでの出荷単位の数量単位を取得します。
String | getDocDate() 伝票日付 (受信日/送信日)を取得します。
String | getDocNumber() 販売伝票を取得します。
int | getIndex() レコード番号を取得します｡
String | getItmNumber() 販売伝票明細を取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getNetPrice() 正味価格を取得します。
String | getNetValue() 伝票通貨での受注明細正味額を取得します。
String | getPoItmNo() 元となる購買発注の明細番号を取得します。
String | getPrcStatH() 伝票の全処理ステータスを取得します。
String | getPurchNo() 得意先発注番号を取得します。
String | getRefQty() 基本数量単位による参照数量を取得します。
String | getReqDate() 納入日程日付を取得します。
String | getReqDateH() 指定納入期日を取得します。
String | getReqQty() 累積受注数量 (販売単位)を取得します。
String | getSalesUnit() 販売単位を取得します。
String | getShortText() テキスト (短): 受注明細を取得します。
String | getSUnitDlv() 出荷単位を取得します。
String | getSUnitIso() ISO コードによる販売単位を取得します。
void | setCdUntIso(String cdUntIso) 条件数量単位 (ISO コード)を設定します。
void | setCondPUnt(String condPUnt) 価格条件単位を設定します。
void | setCondUnit(String condUnit) 条件単位を設定します。
void | setCreationDate(String creationDate) レコード登録日を設定します。
void | setCreationTime(String creationTime) 登録時刻を設定します。
void | setCumCfQty(String cumCfQty) 累積確認数量 (販売数量単位)を設定します。
void | setCurrency(String currency) 販売伝票通貨を設定します。
void | setCurrIso(String currIso) ISO コード通貨を設定します。
void | setDelivDate(String delivDate) 納入期日を設定します。
void | setDelivItem(String delivItem) 出荷明細を設定します。
void | setDelivNumb(String delivNumb) 出荷伝票を設定します。
void | setDlvBlock(String dlvBlock) 出荷ブロック (伝票ヘッダ)を設定します。
void | setDlvQty(String dlvQty) 出荷数量実績 (販売単位)を設定します。
void | setDlvStatH(String dlvStatH) 全明細の出荷ステータスを設定します。
void | setDlvStatI(String dlvStatI) 明細の全体出荷ステータスを設定します。
void | setDlvUnitIso(String dlvUnitIso) ISO コードでの出荷単位の数量単位を設定します。
void | setDocDate(String docDate) 伝票日付 (受信日/送信日)を設定します。
void | setDocNumber(String docNumber) 販売伝票を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItmNumber(String itmNumber) 販売伝票明細を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setNetPrice(String netPrice) 正味価格を設定します。
void | setNetValue(String netValue) 伝票通貨での受注明細正味額を設定します。
void | setPoItmNo(String poItmNo) 元となる購買発注の明細番号を設定します。
void | setPrcStatH(String prcStatH) 伝票の全処理ステータスを設定します。
void | setPurchNo(String purchNo) 得意先発注番号を設定します。
void | setRefQty(String refQty) 基本数量単位による参照数量を設定します。
void | setReqDate(String reqDate) 納入日程日付を設定します。
void | setReqDateH(String reqDateH) 指定納入期日を設定します。
void | setReqQty(String reqQty) 累積受注数量 (販売単位)を設定します。
void | setSalesUnit(String salesUnit) 販売単位を設定します。
void | setShortText(String shortText) テキスト (短): 受注明細を設定します。
void | setSUnitDlv(String sUnitDlv) 出荷単位を設定します。
void | setSUnitIso(String sUnitIso) ISO コードによる販売単位を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StatusInfo

public StatusInfo()
ステータス情報情報を作成します。

StatusInfo

public StatusInfo(int index)
ステータス情報情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getDocNumber

public String getDocNumber()
販売伝票を取得します。

戻り値:
docNumber 販売伝票

getDocDate

public String getDocDate()
伝票日付 (受信日/送信日)を取得します。

戻り値:
docDate 伝票日付 (受信日/送信日)

getPurchNo

public String getPurchNo()
得意先発注番号を取得します。

戻り値:
purchNo 得意先発注番号

getPrcStatH

public String getPrcStatH()
伝票の全処理ステータスを取得します。

戻り値:
prcStatH 伝票の全処理ステータス

getDlvStatH

public String getDlvStatH()
全明細の出荷ステータスを取得します。

戻り値:
dlvStatH 全明細の出荷ステータス

getReqDateH

public String getReqDateH()
指定納入期日を取得します。

戻り値:
reqDateH 指定納入期日

getDlvBlock

public String getDlvBlock()
出荷ブロック (伝票ヘッダ)を取得します。

戻り値:
dlvBlock 出荷ブロック (伝票ヘッダ)

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
itmNumber 販売伝票明細

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getShortText

public String getShortText()
テキスト (短): 受注明細を取得します。

戻り値:
shortText テキスト (短): 受注明細

getReqDate

public String getReqDate()
納入日程日付を取得します。

戻り値:
reqDate 納入日程日付

getReqQty

public String getReqQty()
累積受注数量 (販売単位)を取得します。

戻り値:
reqQty 累積受注数量 (販売単位)

getCumCfQty

public String getCumCfQty()
累積確認数量 (販売数量単位)を取得します。

戻り値:
cumCfQty 累積確認数量 (販売数量単位)

getSalesUnit

public String getSalesUnit()
販売単位を取得します。

戻り値:
salesUnit 販売単位

getNetValue

public String getNetValue()
伝票通貨での受注明細正味額を取得します。

戻り値:
netValue 伝票通貨での受注明細正味額

getCurrency

public String getCurrency()
販売伝票通貨を取得します。

戻り値:
currency 販売伝票通貨

getNetPrice

public String getNetPrice()
正味価格を取得します。

戻り値:
netPrice 正味価格

getCondPUnt

public String getCondPUnt()
価格条件単位を取得します。

戻り値:
condPUnt 価格条件単位

getCondUnit

public String getCondUnit()
条件単位を取得します。

戻り値:
condUnit 条件単位

getDlvStatI

public String getDlvStatI()
明細の全体出荷ステータスを取得します。

戻り値:
dlvStatI 明細の全体出荷ステータス

getDelivNumb

public String getDelivNumb()
出荷伝票を取得します。

戻り値:
delivNumb 出荷伝票

getDelivItem

public String getDelivItem()
出荷明細を取得します。

戻り値:
delivItem 出荷明細

getDelivDate

public String getDelivDate()
納入期日を取得します。

戻り値:
delivDate 納入期日

getDlvQty

public String getDlvQty()
出荷数量実績 (販売単位)を取得します。

戻り値:
dlvQty 出荷数量実績 (販売単位)

getRefQty

public String getRefQty()
基本数量単位による参照数量を取得します。

戻り値:
refQty 基本数量単位による参照数量

getSUnitIso

public String getSUnitIso()
ISO コードによる販売単位を取得します。

戻り値:
sUnitIso ISO コードによる販売単位

getCdUntIso

public String getCdUntIso()
条件数量単位 (ISO コード)を取得します。

戻り値:
cdUntIso 条件数量単位 (ISO コード)

getCurrIso

public String getCurrIso()
ISO コード通貨を取得します。

戻り値:
currIso ISO コード通貨

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getPoItmNo

public String getPoItmNo()
元となる購買発注の明細番号を取得します。

戻り値:
poItmNo 元となる購買発注の明細番号

getCreationDate

public String getCreationDate()
レコード登録日を取得します。

戻り値:
creationDate レコード登録日

getCreationTime

public String getCreationTime()
登録時刻を取得します。

戻り値:
creationTime 登録時刻

getSUnitDlv

public String getSUnitDlv()
出荷単位を取得します。

戻り値:
sUnitDlv 出荷単位

getDlvUnitIso

public String getDlvUnitIso()
ISO コードでの出荷単位の数量単位を取得します。

戻り値:
dlvUnitIso ISO コードでの出荷単位の数量単位

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setDocNumber

public void setDocNumber(String docNumber)
販売伝票を設定します。

パラメータ:
docNumber - 販売伝票

setDocDate

public void setDocDate(String docDate)
伝票日付 (受信日/送信日)を設定します。

パラメータ:
docDate - 伝票日付 (受信日/送信日)

setPurchNo

public void setPurchNo(String purchNo)
得意先発注番号を設定します。

パラメータ:
purchNo - 得意先発注番号

setPrcStatH

public void setPrcStatH(String prcStatH)
伝票の全処理ステータスを設定します。

パラメータ:
prcStatH - 伝票の全処理ステータス

setDlvStatH

public void setDlvStatH(String dlvStatH)
全明細の出荷ステータスを設定します。

パラメータ:
dlvStatH - 全明細の出荷ステータス

setReqDateH

public void setReqDateH(String reqDateH)
指定納入期日を設定します。

パラメータ:
reqDateH - 指定納入期日

setDlvBlock

public void setDlvBlock(String dlvBlock)
出荷ブロック (伝票ヘッダ)を設定します。

パラメータ:
dlvBlock - 出荷ブロック (伝票ヘッダ)

setItmNumber

public void setItmNumber(String itmNumber)
販売伝票明細を設定します。

パラメータ:
itmNumber - 販売伝票明細

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setShortText

public void setShortText(String shortText)
テキスト (短): 受注明細を設定します。

パラメータ:
shortText - テキスト (短): 受注明細

setReqDate

public void setReqDate(String reqDate)
納入日程日付を設定します。

パラメータ:
reqDate - 納入日程日付

setReqQty

public void setReqQty(String reqQty)
累積受注数量 (販売単位)を設定します。

パラメータ:
reqQty - 累積受注数量 (販売単位)

setCumCfQty

public void setCumCfQty(String cumCfQty)
累積確認数量 (販売数量単位)を設定します。

パラメータ:
cumCfQty - 累積確認数量 (販売数量単位)

setSalesUnit

public void setSalesUnit(String salesUnit)
販売単位を設定します。

パラメータ:
salesUnit - 販売単位

setNetValue

public void setNetValue(String netValue)
伝票通貨での受注明細正味額を設定します。

パラメータ:
netValue - 伝票通貨での受注明細正味額

setCurrency

public void setCurrency(String currency)
販売伝票通貨を設定します。

パラメータ:
currency - 販売伝票通貨

setNetPrice

public void setNetPrice(String netPrice)
正味価格を設定します。

パラメータ:
netPrice - 正味価格

setCondPUnt

public void setCondPUnt(String condPUnt)
価格条件単位を設定します。

パラメータ:
condPUnt - 価格条件単位

setCondUnit

public void setCondUnit(String condUnit)
条件単位を設定します。

パラメータ:
condUnit - 条件単位

setDlvStatI

public void setDlvStatI(String dlvStatI)
明細の全体出荷ステータスを設定します。

パラメータ:
dlvStatI - 明細の全体出荷ステータス

setDelivNumb

public void setDelivNumb(String delivNumb)
出荷伝票を設定します。

パラメータ:
delivNumb - 出荷伝票

setDelivItem

public void setDelivItem(String delivItem)
出荷明細を設定します。

パラメータ:
delivItem - 出荷明細

setDelivDate

public void setDelivDate(String delivDate)
納入期日を設定します。

パラメータ:
delivDate - 納入期日

setDlvQty

public void setDlvQty(String dlvQty)
出荷数量実績 (販売単位)を設定します。

パラメータ:
dlvQty - 出荷数量実績 (販売単位)

setRefQty

public void setRefQty(String refQty)
基本数量単位による参照数量を設定します。

パラメータ:
refQty - 基本数量単位による参照数量

setSUnitIso

public void setSUnitIso(String sUnitIso)
ISO コードによる販売単位を設定します。

パラメータ:
sUnitIso - ISO コードによる販売単位

setCdUntIso

public void setCdUntIso(String cdUntIso)
条件数量単位 (ISO コード)を設定します。

パラメータ:
cdUntIso - 条件数量単位 (ISO コード)

setCurrIso

public void setCurrIso(String currIso)
ISO コード通貨を設定します。

パラメータ:
currIso - ISO コード通貨

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setPoItmNo

public void setPoItmNo(String poItmNo)
元となる購買発注の明細番号を設定します。

パラメータ:
poItmNo - 元となる購買発注の明細番号

setCreationDate

public void setCreationDate(String creationDate)
レコード登録日を設定します。

パラメータ:
creationDate - レコード登録日

setCreationTime

public void setCreationTime(String creationTime)
登録時刻を設定します。

パラメータ:
creationTime - 登録時刻

setSUnitDlv

public void setSUnitDlv(String sUnitDlv)
出荷単位を設定します。

パラメータ:
sUnitDlv - 出荷単位

setDlvUnitIso

public void setDlvUnitIso(String dlvUnitIso)
ISO コードでの出荷単位の数量単位を設定します。

パラメータ:
dlvUnitIso - ISO コードでの出荷単位の数量単位

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BillingDocCreateMultipleController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales
クラス BillingDocCreateMultipleController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple
                拡張 jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController
すべての実装インタフェース:
Serializable
public class BillingDocCreateMultipleController
extends BillingDocCreateMultiple
implements Serializable

請求伝票登録コントローラクラス
機能は以下の通り

  • 請求伝票を登録します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
BillingDocCreateMultipleController()
BillingDocCreateMultipleControllerのコンストラクタを生成します。
BillingDocCreateMultipleController(ConnectionManager connectionManager)
BillingDocCreateMultipleControllerのコンストラクタを生成します。
BillingDocCreateMultipleController(SapClient sapClient)
BillingDocCreateMultipleControllerのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
BillingDocCreateMultipleのexecuteBapi()を呼び出し請求伝票を登録します。
 void setStrParam(String paramStr, String paramName, String value)
構造型の項目に値をセットします。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple から継承したメソッド
getBillingDataInList, getCCardDataInList, getConditionDataInList, getCreatorDataIn, getErrorsList, getSuccessList, getTestrun, getTextDataInList, setBillingDataInList, setCCardDataInList, setConditionDataInList, setCreatorDataIn, setErrorsList, setExportParam, setImportParam, setSuccessList, setTestrun, setTextDataInList, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BillingDocCreateMultipleController

public BillingDocCreateMultipleController()
BillingDocCreateMultipleControllerのコンストラクタを生成します。

BillingDocCreateMultipleController

public BillingDocCreateMultipleController(ConnectionManager connectionManager)
BillingDocCreateMultipleControllerのコンストラクタを生成します。

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

パラメータ:
connectionManager - コネクションマネージャー

BillingDocCreateMultipleController

public BillingDocCreateMultipleController(SapClient sapClient)
BillingDocCreateMultipleControllerのコンストラクタを生成します。

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバへデータを登録することが可能です。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPSalesAppException,
                        SAPSalesSystemException
BillingDocCreateMultipleのexecuteBapi()を呼び出し請求伝票を登録します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外

setStrParam

public void setStrParam(String paramStr,
                        String paramName,
                        String value)
                 throws SAPSalesSystemException
構造型の項目に値をセットします。

パラメータ:
paramStr - 構造名
paramName - 項目名
value - セットする値
例外:
SAPSalesSystemException - 販売管理業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPSalesSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - パラメータ名
value - セットする値
index - レコード番号
例外:
SAPSalesSystemException - 販売管理業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BillingDocGetDetailController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales
クラス BillingDocGetDetailController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController
すべての実装インタフェース:
Serializable
public class BillingDocGetDetailController
extends Object
implements Serializable

請求伝票詳細照会情報コントローラクラス
機能は以下の通り

  • 請求伝票詳細照会情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
BillingDocGetDetailController(String billingDocument)
コンストラクタ生成
BillingDocGetDetailController(String billingDocument, SapClient sapClient)
コンストラクタ生成
メソッドの概要
String | getBapiReturnErrMessage() ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage() 設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。
BillingDocumentDetail | getBillingDocumentDetail() 請求伝票に関する詳細情報を取得します。
void | setBillingDocumentDetail(BillingDocumentDetail billingDocumentDetail) 請求伝票に関する詳細情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BillingDocGetDetailController

public BillingDocGetDetailController(String billingDocument)
                              throws SAPAuthAppException,
                                     SAPAuthSystemException,
                                     SAPGeneralAppException,
                                     SAPGeneralSystemException,
                                     SAPSalesAppException,
                                     SAPSalesSystemException
コンストラクタ生成

パラメータ:
billingDocument - 処理予定の請求伝票数
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外

BillingDocGetDetailController

public BillingDocGetDetailController(String billingDocument,
                                     SapClient sapClient)
                              throws SAPAuthAppException,
                                     SAPAuthSystemException,
                                     SAPGeneralAppException,
                                     SAPGeneralSystemException,
                                     SAPSalesAppException,
                                     SAPSalesSystemException
コンストラクタ生成

パラメータ:
billingDocument - 処理予定の請求伝票数
sapClient - SAPクライアント
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外
メソッドの詳細

getBillingDocumentDetail

public BillingDocumentDetail getBillingDocumentDetail()
請求伝票に関する詳細情報を取得します。

戻り値:
billingDocumentDetail 請求伝票に関する詳細情報

setBillingDocumentDetail

public void setBillingDocumentDetail(BillingDocumentDetail billingDocumentDetail)
請求伝票に関する詳細情報を設定します。

パラメータ:
billingDocumentDetail - 請求伝票に関する詳細情報

getBapiReturnMessage

public String getBapiReturnMessage()
設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡ 正常と判断させる条件はプロパティファイル、 またはBapiController.setIgnoreErrMsgReturnTypes(List), BapiController.addIgnoreErrMsgReturnType(String)でカスタマイズできます。
メッセージの形式等の詳細は、BapiController.getMessage()をご参照ください。

戻り値:
BAPI実行結果のすべてのメッセージ情報

getBapiReturnErrMessage

public String getBapiReturnErrMessage()
ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡ 正常と判断させる条件はプロパティファイル、 またはBapiController.setIgnoreErrMsgReturnTypes(List), BapiController.addIgnoreErrMsgReturnType(String)でカスタマイズできます。
メッセージの形式等の詳細は、BapiController.getErrMessage()をご参照ください。

戻り値:
BAPI実行結果エラーとなった全てのメッセージ情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BillingDocGetListController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales
クラス BillingDocGetListController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList
                拡張 jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController
すべての実装インタフェース:
Serializable
public class BillingDocGetListController
extends BillingDocGetList
implements Serializable

請求伝票一覧照会情報コントローラクラス
機能は以下の通り

  • 請求伝票一覧照会情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
BillingDocGetListController()
コンストラクタ生成
BillingDocGetListController(SapClient sapClient)
コンストラクタ生成
BillingDocGetListController(String sign, String option, String refDocRow, String refDocHigh)
コンストラクタ生成
BillingDocGetListController(String sign, String option, String refDocRow, String refDocHigh, SapClient sapClient)
コンストラクタ生成
メソッドの概要
 void executeBapi()
BillingDocGetListのexecuteBapi()を呼び出し請求伝票一覧を検索します。
 void setStrParam(String paramStr, String paramName, String value)
構造型の項目に値をセットします。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList から継承したメソッド
getBillingDocumentDetailListList, getRefDocRange, getSuccessList, setBillingDocumentDetailListList, setExportParam, setImportParam, setRefDocRange, setSuccessList, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BillingDocGetListController

public BillingDocGetListController()
コンストラクタ生成

BillingDocGetListController

public BillingDocGetListController(String sign,
                                   String option,
                                   String refDocRow,
                                   String refDocHigh)
コンストラクタ生成

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)
option - 選択演算子 OPTION (範囲テーブル)
refDocRow - 前伝票の開始伝票番号
refDocHigh - 前伝票の終了伝票番号

BillingDocGetListController

public BillingDocGetListController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - SAPクライアント

BillingDocGetListController

public BillingDocGetListController(String sign,
                                   String option,
                                   String refDocRow,
                                   String refDocHigh,
                                   SapClient sapClient)
コンストラクタ生成

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)
option - 選択演算子 OPTION (範囲テーブル)
refDocRow - 前伝票の開始伝票番号
refDocHigh - 前伝票の終了伝票番号
sapClient - SAPクライアント
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPSalesAppException,
                        SAPSalesSystemException
BillingDocGetListのexecuteBapi()を呼び出し請求伝票一覧を検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外

setStrParam

public void setStrParam(String paramStr,
                        String paramName,
                        String value)
                 throws SAPSalesSystemException
構造型の項目に値をセットします。

パラメータ:
paramStr - 構造名
paramName - 項目名
value - セットする値
例外:
SAPSalesSystemException - 販売管理業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPSalesSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPSalesSystemException - 販売管理システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InquiryCreateFromData2Controller (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales
クラス InquiryCreateFromData2Controller

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2
                拡張 jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller
すべての実装インタフェース:
Serializable
public class InquiryCreateFromData2Controller
extends InquiryCreateFromData2
implements Serializable

引合伝票登録コントローラクラス
機能は以下の通り

  • 引合伝票を登録します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
InquiryCreateFromData2Controller()
InquiryCreateFromData2Controllerのコンストラクタを生成します。
InquiryCreateFromData2Controller(ConnectionManager connectionManager)
InquiryCreateFromData2Controllerのコンストラクタを生成します。
InquiryCreateFromData2Controller(SapClient sapClient)
InquiryCreateFromData2Controllerのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
InquiryCreateFromData2のexecuteBapi()を呼び出し引合伝票を登録します。
 void setStrParam(String paramStr, String paramName, String value)
構造体型の項目に値をセットします。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 から継承したメソッド
getBehaveWhenError, getBinaryRelationshiptype, getConvert, getExtensionInList, getInquiryCfgsBlobList, getInquiryCfgsInstList, getInquiryCfgsPartOfList, getInquiryCfgsRefInstList, getInquiryCfgsRefList, getInquiryCfgsValueList, getInquiryCfgsVkList, getInquiryConditionsInList, getInquiryConditionsInXList, getInquiryHeaderIn, getInquiryHeaderInX, getInquiryItemsInList, getInquiryItemsInXList, getInquiryKeysList, getInquiryPartnersList, getInquirySchedulesInList, getInquirySchedulesInXList, getInquiryTextList, getIntNumberAssignment, getLogicSwitch, getPartnerAddressesList, getSalesdocument, getSalesdocumentin, getSender, getTestrun, setBehaveWhenError, setBinaryRelationshiptype, setConvert, setExportParam, setExtensionInList, setImportParam, setInquiryCfgsBlobList, setInquiryCfgsInstList, setInquiryCfgsPartOfList, setInquiryCfgsRefInstList, setInquiryCfgsRefList, setInquiryCfgsValueList, setInquiryCfgsVkList, setInquiryConditionsInList, setInquiryConditionsInXList, setInquiryHeaderIn, setInquiryHeaderInX, setInquiryItemsInList, setInquiryItemsInXList, setInquiryKeysList, setInquiryPartnersList, setInquirySchedulesInList, setInquirySchedulesInXList, setInquiryTextList, setIntNumberAssignment, setLogicSwitch, setPartnerAddressesList, setSalesdocument, setSalesdocumentin, setSender, setTestrun, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

InquiryCreateFromData2Controller

public InquiryCreateFromData2Controller()
InquiryCreateFromData2Controllerのコンストラクタを生成します。

InquiryCreateFromData2Controller

public InquiryCreateFromData2Controller(ConnectionManager connectionManager)
InquiryCreateFromData2Controllerのコンストラクタを生成します。

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

パラメータ:
connectionManager - コネクションマネージャー

InquiryCreateFromData2Controller

public InquiryCreateFromData2Controller(SapClient sapClient)
InquiryCreateFromData2Controllerのコンストラクタを生成します。

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバへデータを登録することが可能です。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPSalesAppException,
                        SAPSalesSystemException
InquiryCreateFromData2のexecuteBapi()を呼び出し引合伝票を登録します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外

setStrParam

public void setStrParam(String paramStr,
                        String paramName,
                        String value)
                 throws SAPSalesSystemException
構造体型の項目に値をセットします。

パラメータ:
paramStr - 構造体名
paramName - パラメータ名
value - セットする値
例外:
SAPSalesSystemException - 販売管理業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPSalesSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - パラメータ名
value - セットする値
index - レコード番号
例外:
SAPSalesSystemException - 販売管理業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.sales (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales
クラス
BillingDocCreateMultipleController
BillingDocGetDetailController
BillingDocGetListController
InquiryCreateFromData2Controller
QuotationCreateFromData2Controller
SalesOrderCreateFromDat2Controller
SalesOrderGetListController
SalesOrderGetStatusController


jp.co.intra_mart.foundation.sap.module.sales (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales

クラスの概要
BillingDocCreateMultipleController | 請求伝票登録コントローラクラス 機能は以下の通り 請求伝票を登録します。
BillingDocGetDetailController | 請求伝票詳細照会情報コントローラクラス 機能は以下の通り 請求伝票詳細照会情報を保持します。
BillingDocGetListController | 請求伝票一覧照会情報コントローラクラス 機能は以下の通り 請求伝票一覧照会情報を保持します。
InquiryCreateFromData2Controller | 引合伝票登録コントローラクラス 機能は以下の通り 引合伝票を登録します。
QuotationCreateFromData2Controller | 見積伝票登録情報コントローラクラス 機能は以下の通り 見積伝票登録情報を保持します。
SalesOrderCreateFromDat2Controller | 受注伝票登録コントローラクラス 機能は以下の通り 受注伝票を登録します。
SalesOrderGetListController | 販売伝票一覧照会コントローラクラス 機能は以下の通り 販売伝票一覧の情報を取得します。
SalesOrderGetStatusController | 販売伝票ステータス一覧照会コントローラクラス 機能は以下の通り 販売伝票ステータス一覧の情報を取得します。


jp.co.intra_mart.foundation.sap.module.sales クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales の使用

jp.co.intra_mart.foundation.sap.module.sales はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


QuotationCreateFromData2Controller (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales
クラス QuotationCreateFromData2Controller

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2
                拡張 jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller
すべての実装インタフェース:
Serializable
public class QuotationCreateFromData2Controller
extends QuotationCreateFromData2
implements Serializable

見積伝票登録情報コントローラクラス
機能は以下の通り

  • 見積伝票登録情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
QuotationCreateFromData2Controller()
QuotationCreateFromData2Controllerのコンストラクタを生成します。
QuotationCreateFromData2Controller(ConnectionManager connectionManager)
QuotationCreateFromData2Controllerのコンストラクタを生成します。
QuotationCreateFromData2Controller(SapClient sapClient)
QuotationCreateFromData2Controllerのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
QuotationCreateFromData2のexecuteBapi()を呼び出し見積伝票を登録します。
 void setStrParam(String paramStr, String paramName, String value)
構造体型の項目に値をセットします。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 から継承したメソッド
getBehaveWhenError, getBinaryRelationshiptype, getConvert, getExtensionInList, getIntNumberAssignment, getLogicSwitch, getPartnerAddressesList, getQuotationCfgsBlobList, getQuotationCfgsInstList, getQuotationCfgsPartOfList, getQuotationCfgsRefInstList, getQuotationCfgsRefList, getQuotationCfgsValueList, getQuotationCfgsVkList, getQuotationConditionsInList, getQuotationConditionsInXList, getQuotationHeaderIn, getQuotationHeaderInX, getQuotationItemsInList, getQuotationItemsInXList, getQuotationKeysList, getQuotationPartnersList, getQuotationSchedulesInList, getQuotationSchedulesInXList, getQuotationTextList, getSalesdocument, getSalesdocumentin, getSender, getTestrun, setBehaveWhenError, setBinaryRelationshiptype, setConvert, setExportParam, setExtensionInList, setImportParam, setIntNumberAssignment, setLogicSwitch, setPartnerAddressesList, setQuotationCfgsBlobList, setQuotationCfgsInstList, setQuotationCfgsPartOfList, setQuotationCfgsRefInstList, setQuotationCfgsRefList, setQuotationCfgsValueList, setQuotationCfgsVkList, setQuotationConditionsInList, setQuotationConditionsInXList, setQuotationHeaderIn, setQuotationHeaderInX, setQuotationItemsInList, setQuotationItemsInXList, setQuotationKeysList, setQuotationPartnersList, setQuotationSchedulesInList, setQuotationSchedulesInXList, setQuotationTextList, setSalesdocument, setSalesdocumentin, setSender, setTestrun, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

QuotationCreateFromData2Controller

public QuotationCreateFromData2Controller()
QuotationCreateFromData2Controllerのコンストラクタを生成します。

QuotationCreateFromData2Controller

public QuotationCreateFromData2Controller(ConnectionManager connectionManager)
QuotationCreateFromData2Controllerのコンストラクタを生成します。

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

パラメータ:
connectionManager - コネクションマネージャー

QuotationCreateFromData2Controller

public QuotationCreateFromData2Controller(SapClient sapClient)
QuotationCreateFromData2Controllerのコンストラクタを生成します。

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバへデータを登録することが可能です。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPSalesAppException,
                        SAPSalesSystemException
QuotationCreateFromData2のexecuteBapi()を呼び出し見積伝票を登録します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外

setStrParam

public void setStrParam(String paramStr,
                        String paramName,
                        String value)
                 throws SAPSalesSystemException
構造体型の項目に値をセットします。

パラメータ:
paramStr - 構造体名
paramName - パラメータ名
value - セットする値
例外:
SAPSalesSystemException - 販売管理業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPSalesSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - パラメータ名
value - セットする値
index - レコード番号
例外:
SAPSalesSystemException - 販売管理業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SalesOrderCreateFromDat2Controller (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales
クラス SalesOrderCreateFromDat2Controller

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2
                拡張 jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller
すべての実装インタフェース:
Serializable
public class SalesOrderCreateFromDat2Controller
extends SalesOrderCreateFromDat2
implements Serializable

受注伝票登録コントローラクラス
機能は以下の通り

  • 受注伝票を登録します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
SalesOrderCreateFromDat2Controller()
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。
SalesOrderCreateFromDat2Controller(ConnectionManager connectionManager)
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。
SalesOrderCreateFromDat2Controller(SapClient sapClient)
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
SalesOrderCreateFromDat2のexecuteBapi()を呼び出し販売伝票を登録します。
 void setStrParam(String paramStr, String paramName, String value)
構造体型の項目に値をセットします。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 から継承したメソッド
getBehaveWhenError, getBinaryRelationshiptype, getConvert, getExtensionInList, getIntNumberAssignment, getLogicSwitch, getOrderCcardList, getOrderCfgsBlobList, getOrderCfgsInstList, getOrderCfgsPartOfList, getOrderCfgsRefInstList, getOrderCfgsRefList, getOrderCfgsValueList, getOrderCfgsVkList, getOrderConditionsInList, getOrderConditionsInXList, getOrderHeaderIn, getOrderHeaderInX, getOrderItemsInList, getOrderItemsInXList, getOrderKeysList, getOrderPartnersList, getOrderSchedulesInList, getOrderSchedulesInXList, getOrderTextList, getPartnerAddressesList, getSalesdocument, getSalesdocumentin, getSender, getTestrun, setBehaveWhenError, setBinaryRelationshiptype, setConvert, setExportParam, setExtensionInList, setImportParam, setIntNumberAssignment, setLogicSwitch, setOrderCcardList, setOrderCfgsBlobList, setOrderCfgsInstList, setOrderCfgsPartOfList, setOrderCfgsRefInstList, setOrderCfgsRefList, setOrderCfgsValueList, setOrderCfgsVkList, setOrderConditionsInList, setOrderConditionsInXList, setOrderHeaderIn, setOrderHeaderInX, setOrderItemsInList, setOrderItemsInXList, setOrderKeysList, setOrderPartnersList, setOrderSchedulesInList, setOrderSchedulesInXList, setOrderTextList, setPartnerAddressesList, setSalesdocument, setSalesdocumentin, setSender, setTestrun, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesOrderCreateFromDat2Controller

public SalesOrderCreateFromDat2Controller()
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。

SalesOrderCreateFromDat2Controller

public SalesOrderCreateFromDat2Controller(ConnectionManager connectionManager)
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

パラメータ:
connectionManager - コネクションマネージャー

SalesOrderCreateFromDat2Controller

public SalesOrderCreateFromDat2Controller(SapClient sapClient)
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバへデータを登録することが可能です。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPSalesAppException,
                        SAPSalesSystemException
SalesOrderCreateFromDat2のexecuteBapi()を呼び出し販売伝票を登録します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外

setStrParam

public void setStrParam(String paramStr,
                        String paramName,
                        String value)
                 throws SAPSalesSystemException
構造体型の項目に値をセットします。

パラメータ:
paramStr - 構造体名
paramName - パラメータ名
value - セットする値
例外:
SAPSalesSystemException - 販売管理業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPSalesSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - パラメータ名
value - セットする値
index - レコード番号
例外:
SAPSalesSystemException - 販売管理業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SalesOrderGetListController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales
クラス SalesOrderGetListController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList
                拡張 jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController
すべての実装インタフェース:
Serializable
public class SalesOrderGetListController
extends SalesOrderGetList
implements Serializable

販売伝票一覧照会コントローラクラス
機能は以下の通り

  • 販売伝票一覧の情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
SalesOrderGetListController()
コンストラクタ生成
SalesOrderGetListController(SapClient sapClient)
コンストラクタ生成
SalesOrderGetListController(String customerNumber, String salesOrganisation, String material, String purchaseOrder, String transactionGroup)
コンストラクタ生成
SalesOrderGetListController(String customerNumber, String salesOrganisation, String material, String purchaseOrder, String transactionGroup, SapClient sapClient)
コンストラクタ生成
メソッドの概要
 void executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し販売伝票一覧を取得します。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList から継承したメソッド
getCustomerNumber, getDocumentDate, getDocumentDateTo, getMaterial, getPurchaseOrder, getPurchaseOrderNumber, getSalesOrdersList, getSalesOrganization, getTransactionGroup, setCustomerNumber, setDocumentDate, setDocumentDateTo, setExportParam, setImportParam, setMaterial, setPurchaseOrder, setPurchaseOrderNumber, setSalesOrdersList, setSalesOrganization, setTransactionGroup, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesOrderGetListController

public SalesOrderGetListController()
コンストラクタ生成

SalesOrderGetListController

public SalesOrderGetListController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - SAPクライアント

SalesOrderGetListController

public SalesOrderGetListController(String customerNumber,
                                   String salesOrganisation,
                                   String material,
                                   String purchaseOrder,
                                   String transactionGroup)
コンストラクタ生成

パラメータ:
customerNumber - 得意先コード
salesOrganisation - 販売組織
material - 品目コード
purchaseOrder - 得意先発注番号
transactionGroup - 一文字フラグ

SalesOrderGetListController

public SalesOrderGetListController(String customerNumber,
                                   String salesOrganisation,
                                   String material,
                                   String purchaseOrder,
                                   String transactionGroup,
                                   SapClient sapClient)
コンストラクタ生成

パラメータ:
customerNumber - 得意先コード
salesOrganisation - 販売組織
material - 品目コード
purchaseOrder - 得意先発注番号
transactionGroup - 一文字フラグ
sapClient - SAPクライアント
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPSalesAppException,
                        SAPSalesSystemException
ReferenceControllerのexecuteBapi()を呼び出し販売伝票一覧を取得します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理アプリケーション例外
SAPSalesSystemException - 販売管理システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPSalesSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPSalesSystemException - 販売管理システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SalesOrderGetStatusController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales
クラス SalesOrderGetStatusController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus
                拡張 jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController
すべての実装インタフェース:
Serializable
public class SalesOrderGetStatusController
extends SalesOrderGetStatus
implements Serializable

販売伝票ステータス一覧照会コントローラクラス
機能は以下の通り

  • 販売伝票ステータス一覧の情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
SalesOrderGetStatusController()
コンストラクタ生成
SalesOrderGetStatusController(SapClient sapClient)
コンストラクタ生成
SalesOrderGetStatusController(String salesdocument)
コンストラクタ生成
SalesOrderGetStatusController(String salesdocument, SapClient sapClient)
コンストラクタ生成
メソッドの概要
 void executeBapi()
SalesOrderGetStatusのexecuteBapi()を呼び出し販売伝票ステータス一覧を照会します。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus から継承したメソッド
getSalesdocument, getStatusInfoList, setExportParam, setImportParam, setSalesdocument, setStatusInfoList, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesOrderGetStatusController

public SalesOrderGetStatusController()
コンストラクタ生成

SalesOrderGetStatusController

public SalesOrderGetStatusController(String salesdocument)
コンストラクタ生成

パラメータ:
salesdocument - 販売管理伝票番号

SalesOrderGetStatusController

public SalesOrderGetStatusController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - SAPクライアント

SalesOrderGetStatusController

public SalesOrderGetStatusController(String salesdocument,
                                     SapClient sapClient)
コンストラクタ生成

パラメータ:
salesdocument - 販売管理伝票番号
sapClient - SAPクライアント
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPSalesAppException,
                        SAPSalesSystemException
SalesOrderGetStatusのexecuteBapi()を呼び出し販売伝票ステータス一覧を照会します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPSalesSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPSalesSystemException - 販売管理システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AbstractController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module
クラス AbstractController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ReferenceController, UpdateController
public class AbstractController
extends Object
implements Serializable

モジュール共通抽象コントローラクラス。

機能は以下の通り

  • BapiControllerの取得用メソッド
  • BAPI実行メッセージのセットするBapiController.executeBapi()実行メソッド
  • セットされたBAPI実行メッセージの取得

関連項目:
直列化された形式

フィールドの概要
protected String | bapiReturnErrMessage BAPI実行エラーメッセージ
protected String | bapiReturnMessage BAPI実行結果メッセージ
protected SapClient | sapClient SAPクライアント
コンストラクタの概要
protected | AbstractController() コンストラクタ。
protected | AbstractController(SapClient sapClient) コンストラクタ。
メソッドの概要
protected BapiController | createBapiController(String propertyFileName) 引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。
protected void | executeBapi(BapiController bapiController) 引数で指定された bapiController のexecuteBapiメソッドを実行します。
String | getBapiReturnErrMessage() ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage() 設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

sapClient

protected SapClient sapClient
SAPクライアント

bapiReturnErrMessage

protected String bapiReturnErrMessage
BAPI実行エラーメッセージ

bapiReturnMessage

protected String bapiReturnMessage
BAPI実行結果メッセージ

コンストラクタの詳細

AbstractController

protected AbstractController()
コンストラクタ。

AbstractController

protected AbstractController(SapClient sapClient)
コンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

createBapiController

protected BapiController createBapiController(String propertyFileName)
                                       throws SAPGeneralSystemException,
                                              SAPAuthSystemException,
                                              SAPGeneralAppException
引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。

パラメータ:
propertyFileName - プロパティファイル名
戻り値:
BapiControllerインスタンス
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPAuthSystemException - 認証系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外

executeBapi

protected void executeBapi(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPAuthSystemException,
                           SAPAuthAppException,
                           SAPBapiReturnErrMessageExistException
引数で指定された bapiController のexecuteBapiメソッドを実行します。

引数で指定された bapiController のメソッドBapiController.executeBapi()を実行し、 実行後、BAPI実行エラーメッセージ、BAPI実行結果メッセージをセットします。 これらの値は getBapiReturnErrMessage()、 getBapiReturnMessage()で取得できます。 BAPI実行エラーメッセージが存在する場合、 SAPBapiReturnErrMessageExistExceptionがスローされます。

その他のスローされる例外やConnectionManagerを指定した場合の注意点等については、 BapiController.executeBapi()を参照して下さい。

パラメータ:
bapiController - BapiControllerインスタンス
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外
SAPAuthSystemException - 認証系システム例外処理
SAPAuthAppException - 認証系APIアプリケーション例外
SAPBapiReturnErrMessageExistException - BAPI実行結果例外

getBapiReturnErrMessage

public String getBapiReturnErrMessage()
ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡ 正常と判断させる条件はプロパティファイル、 またはBapiController.setIgnoreErrMsgReturnTypes(List), BapiController.addIgnoreErrMsgReturnType(String)でカスタマイズできます。
メッセージの形式等の詳細は、BapiController.getErrMessage()をご参照ください。

戻り値:
BAPI実行結果エラーとなった全てのメッセージ情報

getBapiReturnMessage

public String getBapiReturnMessage()
設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡ 正常と判断させる条件はプロパティファイル、 またはBapiController.setIgnoreErrMsgReturnTypes(List), BapiController.addIgnoreErrMsgReturnType(String)でカスタマイズできます。
メッセージの形式等の詳細は、BapiController.getMessage()をご参照ください。

戻り値:
BAPI実行結果のすべてのメッセージ情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module
クラス
AbstractController
ReferenceController
UpdateController


jp.co.intra_mart.foundation.sap.module (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module

クラスの概要
AbstractController | モジュール共通抽象コントローラクラス。
ReferenceController | 参照系モジュール共通コントローラ親クラス。
UpdateController | 登録・更新系モジュール共通コントローラ親クラス。


jp.co.intra_mart.foundation.sap.module クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module の使用

jp.co.intra_mart.foundation.sap.module を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial | ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems |
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability |
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall |
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica |
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist |
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus |

jp.co.intra_mart.foundation.sap.module により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。

jp.co.intra_mart.foundation.sap.module.accounting により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.financial により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ReferenceController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module
クラス ReferenceController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
BankList, BillingDocGetDetail, BillingDocGetList, BusinessAreaList, CommonCenterGrpGetDetail, CompanyList, ControllingAreaList, CostCenterList, CreditorGetDetail, DebtorGetDetail, ExchangeRateGetDetail, GlAccList, GoodsMvtGetItems, InternalOrderGetDetail, InternalOrderGetList, MaterialAvailability, MaterialGetAll, MaterialGetList, ProfitCenterList, ProjectGetInfo, PurchaseGetItemSrel, SalesOrderGetList, SalesOrderGetStatus, StdMaterialGetIntNumberList, SupplierDetail, SupplierExistenceCheck
public class ReferenceController
extends AbstractController
implements Serializable

参照系モジュール共通コントローラ親クラス。

このクラスは参照系モジュールに継承されることを期待しています。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
protected | ReferenceController() コンストラクタ。
protected | ReferenceController(SapClient sapClient) コンストラクタ。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ReferenceController

protected ReferenceController()
コンストラクタ。

ReferenceController

protected ReferenceController(SapClient sapClient)
コンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UpdateController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module
クラス UpdateController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccEmployeePayPostController, BillingDocCreateMultiple, GoodsMvtCreate, InquiryCreateFromData2, MaterialSaveReplica, PurchaseOrderPayPost, PurchaseRelease, QuotationCreateFromData2, SalesOrderCreateFromDat2
public class UpdateController
extends AbstractController
implements Serializable

登録・更新系モジュール共通コントローラ親クラス。

このクラスは登録・更新系モジュールに継承されることを期待しています。

関連項目:
直列化された形式

フィールドの概要
protected  ConnectionManager connectionManager
コネクション(トランザクション)オブジェクト
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
protected | UpdateController() コンストラクタ。
protected | UpdateController(ConnectionManager connectionManager) コンストラクタ。
protected | UpdateController(SapClient sapClient) コンストラクタ。
メソッドの概要
protected  BapiController createBapiController(String propertyFileName)
引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

connectionManager

protected ConnectionManager connectionManager
コネクション(トランザクション)オブジェクト

コンストラクタの詳細

UpdateController

protected UpdateController()
コンストラクタ。

UpdateController

protected UpdateController(SapClient sapClient)
コンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト

UpdateController

protected UpdateController(ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerから トランザクションを制御でき、 たとえば同一トランザクション内で複数の登録・更新処理を実行することができます。
なお、AbstractController.executeBapi(jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController)実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

【注意】トランザクション処理が記述されているBAPIもあります。 その場合、AbstractController.executeBapi(BapiController)実行後に ここまでのコネクションマネージャーで実行したすべての処理がcommitまたはrollbackされます。
※ただし、コネクションはリリースされませんので、リリースされるようにConnectionManager.commit()または ConnectionManager.rollback()を実行してください。
この振る舞いを変更するには、BAPI自体をカスタマイズする必要があります。

パラメータ:
connectionManager - コネクションマネージャー
メソッドの詳細

createBapiController

protected BapiController createBapiController(String propertyFileName)
                                       throws SAPGeneralSystemException,
                                              SAPAuthSystemException,
                                              SAPGeneralAppException
引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。

オーバーライド:
クラス AbstractController 内の createBapiController
パラメータ:
propertyFileName - プロパティファイル名
戻り値:
BapiControllerインスタンス
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPAuthSystemException - 汎用系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.scenario.FunctionContainer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.scenario.FunctionContainer の使用

FunctionContainer を使用しているパッケージ
jp.co.intra_mart.foundation.scenario スクリプト開発モデルのプログラムと連携するＡＰＩ。

jp.co.intra_mart.foundation.scenario での FunctionContainer の使用

jp.co.intra_mart.foundation.scenario での FunctionContainer のサブクラス
 class FunctionContainerFile
FunctionContainerFile クラスは、ファンクション・コンテナとなるファイルを コンパイルして実行可能な環境を提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.scenario.FunctionContainerFile の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.scenario.FunctionContainerFile の使用

jp.co.intra_mart.foundation.scenario.FunctionContainerFile はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.scenario.NoSuchPropertyException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.scenario.NoSuchPropertyException の使用

NoSuchPropertyException を使用しているパッケージ
jp.co.intra_mart.foundation.scenario スクリプト開発モデルのプログラムと連携するＡＰＩ。

jp.co.intra_mart.foundation.scenario での NoSuchPropertyException の使用

NoSuchPropertyException をスローする jp.co.intra_mart.foundation.scenario のメソッド
ScriptValue | VariableScope.invoke(String name, String arg) 指定関数を実行します。
ScriptValue | VariableScope.invoke(String name, Number arg) 指定関数を実行します。
ScriptValue | VariableScope.invoke(String name, Object[] args) 指定関数を実行します。
ScriptValue | VariableScope.getProperty(String name) プロパティ値を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.scenario.PresentationPage の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.scenario.PresentationPage の使用

jp.co.intra_mart.foundation.scenario.PresentationPage はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.scenario.ScriptCompileException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.scenario.ScriptCompileException の使用

ScriptCompileException を使用しているパッケージ
jp.co.intra_mart.foundation.scenario スクリプト開発モデルのプログラムと連携するＡＰＩ。

jp.co.intra_mart.foundation.scenario での ScriptCompileException の使用

ScriptCompileException をスローする jp.co.intra_mart.foundation.scenario のメソッド
protected void | FunctionContainer.compileString(String src) スクリプトのソースをコンパイルします。
protected void | FunctionContainer.compileReader(Reader in) スクリプトのソースをコンパイルします。

ScriptCompileException をスローする jp.co.intra_mart.foundation.scenario のコンストラクタ
FunctionContainerFile(String path, Locale locale)
ファンクション・コンテナをコンパイルします。
FunctionContainerFile(String path)
ファンクション・コンテナをコンパイルします。
FunctionContainer(Reader in)
新しいインスタンスを構築します。
FunctionContainer(String src)
新しいインスタンスを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.scenario.ScriptRuntimeException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.scenario.ScriptRuntimeException の使用

ScriptRuntimeException を使用しているパッケージ
jp.co.intra_mart.foundation.scenario スクリプト開発モデルのプログラムと連携するＡＰＩ。

jp.co.intra_mart.foundation.scenario での ScriptRuntimeException の使用

ScriptRuntimeException をスローする jp.co.intra_mart.foundation.scenario のメソッド
ScriptValue | VariableScope.invoke(String name, String arg) 指定関数を実行します。
ScriptValue | VariableScope.invoke(String name, Number arg) 指定関数を実行します。
ScriptValue | VariableScope.invoke(String name, Object[] args) 指定関数を実行します。
String | PresentationPage.execute(String path) プログラム実行。
String | PresentationPage.execute(String path, Object[] args) プログラム実行。
VariableScope | FunctionContainer.execute() スクリプトの実行。
VariableScope | FunctionContainer.execute(HttpServletRequest request, HttpServletResponse response) スクリプトの実行。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.scenario.ScriptValue の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.scenario.ScriptValue の使用

ScriptValue を使用しているパッケージ
jp.co.intra_mart.foundation.scenario スクリプト開発モデルのプログラムと連携するＡＰＩ。

jp.co.intra_mart.foundation.scenario での ScriptValue の使用

jp.co.intra_mart.foundation.scenario での ScriptValue のサブインタフェース
 interface VariableScope
スクリプトのスコープを表すオブジェクトです。

ScriptValue を返す jp.co.intra_mart.foundation.scenario のメソッド
ScriptValue | VariableScope.invoke(String name, String arg) 指定関数を実行します。
ScriptValue | VariableScope.invoke(String name, Number arg) 指定関数を実行します。
ScriptValue | VariableScope.invoke(String name, Object[] args) 指定関数を実行します。
ScriptValue | VariableScope.getProperty(String name) プロパティ値を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.scenario.VariableScope の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.scenario.VariableScope の使用

VariableScope を使用しているパッケージ
jp.co.intra_mart.foundation.scenario スクリプト開発モデルのプログラムと連携するＡＰＩ。

jp.co.intra_mart.foundation.scenario での VariableScope の使用

VariableScope を返す jp.co.intra_mart.foundation.scenario のメソッド
VariableScope | FunctionContainer.execute() スクリプトの実行。
VariableScope | FunctionContainer.execute(HttpServletRequest request, HttpServletResponse response) スクリプトの実行。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


FunctionContainer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.scenario
クラス FunctionContainer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.scenario.FunctionContainer
直系の既知のサブクラス:
FunctionContainerFile
public abstract class FunctionContainer
extends Object

FunctionContainer クラスは、ファンクション・コンテナとなるスクリプトを コンパイルして実行可能な環境を提供します。

関連項目:
Object

コンストラクタの概要
protected | FunctionContainer() 新しいインスタンスを構築します。
 | FunctionContainer(Reader in) 新しいインスタンスを構築します。
 | FunctionContainer(String src) 新しいインスタンスを構築します。
メソッドの概要
protected void | compileReader(Reader in) スクリプトのソースをコンパイルします。
protected void | compileString(String src) スクリプトのソースをコンパイルします。
VariableScope | execute() スクリプトの実行。
VariableScope | execute(HttpServletRequest request, HttpServletResponse response) スクリプトの実行。
abstract String | sourceName() ソース名称の取得。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FunctionContainer

protected FunctionContainer()
新しいインスタンスを構築します。

このコンストラクタでは、このクラスを継承したサブクラス側で compileReader() メソッド等を利用してソースをコンパイルすることを 保証しなければなりません。

FunctionContainer

public FunctionContainer(Reader in)
                  throws IOException,
                         ScriptCompileException
新しいインスタンスを構築します。

指定のファンクション・コンテナをコンパイルします。

パラメータ:
in - ファンクションコンテナのソース
例外:
IOException - Reader の入出力エラー
ScriptCompileException - コンパイルエラー

FunctionContainer

public FunctionContainer(String src)
                  throws IOException,
                         ScriptCompileException
新しいインスタンスを構築します。

指定のファンクション・コンテナをコンパイルします。

パラメータ:
src - ファンクションコンテナのソース
例外:
IOException - Reader の入出力エラー
ScriptCompileException - コンパイルエラー
メソッドの詳細

compileString

protected void compileString(String src)
                      throws IOException,
                             ScriptCompileException
スクリプトのソースをコンパイルします。

パラメータ:
src - ファンクションコンテナのソース
例外:
IOException - Reader の入出力エラー
ScriptCompileException - コンパイルエラー

compileReader

protected void compileReader(Reader in)
                      throws IOException,
                             ScriptCompileException
スクリプトのソースをコンパイルします。

パラメータ:
in - ファンクションコンテナのソース
例外:
IOException - Reader の入出力エラー
ScriptCompileException - コンパイルエラー

sourceName

public abstract String sourceName()
ソース名称の取得。

スクリプトのソース名称を返します。
このクラスの汎用規約では、スクリプトがファイルの場合は ファイルのパス名を返します。

戻り値:
ソースの名前

execute

public VariableScope execute()
                      throws ScriptRuntimeException
スクリプトの実行。

スクリプトを実行します。
このメソッドによる実行時は、セッションが不明となるため、 セッションに関連したAPIを利用したスクリプトを実行することはできません。

戻り値は、このスクリプトのスコープです。

戻り値:
スクリプトのスコープを表すオブジェクト
例外:
ScriptRuntimeException - スクリプトの実行時エラー

execute

public VariableScope execute(HttpServletRequest request,
                             HttpServletResponse response)
                      throws ScriptRuntimeException
スクリプトの実行。

セッションを伴ってスクリプトを実行します。
指定のサーブレットにより管理されているセッションを維持したまま スクリプトを実行します。 また、このメソッドを利用する事により、セッション関連の ＡＰＩをスクリプト中で利用する事ができます。
戻り値は、このスクリプトのスコープです。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
スクリプトのスコープを表すオブジェクト
例外:
ScriptRuntimeException - スクリプトの実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


FunctionContainerFile (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.scenario
クラス FunctionContainerFile

java.lang.Object
    拡張 jp.co.intra_mart.foundation.scenario.FunctionContainer
        拡張 jp.co.intra_mart.foundation.scenario.FunctionContainerFile
public class FunctionContainerFile
extends FunctionContainer

FunctionContainerFile クラスは、ファンクション・コンテナとなるファイルを コンパイルして実行可能な環境を提供します。
ファイルは Resource Service によって管理されているものに限ります。

関連項目:
FunctionContainer

コンストラクタの概要
FunctionContainerFile(String path)
ファンクション・コンテナをコンパイルします。
FunctionContainerFile(String path, Locale locale)
ファンクション・コンテナをコンパイルします。
メソッドの概要
 String sourceName()
スクリプトのファイルパス名を返します。
クラス jp.co.intra_mart.foundation.scenario.FunctionContainer から継承したメソッド
compileReader, compileString, execute, execute
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FunctionContainerFile

public FunctionContainerFile(String path,
                             Locale locale)
                      throws IOException,
                             ScriptCompileException
ファンクション・コンテナをコンパイルします。

このコンストラクタの呼び出しは、以下と同様です。 new FunctionContainerFile(path, java.util.Locale.getDefault())

パラメータ:
path - ソースファイルのパス名
locale - ソースのロケール
例外:
IOException - Reader の入出力エラー
ScriptCompileException - コンパイルエラー
導入されたバージョン:
version 5.0

FunctionContainerFile

public FunctionContainerFile(String path)
                      throws IOException,
                             ScriptCompileException
ファンクション・コンテナをコンパイルします。

ファンクション・コンテナのファイルパスは、Resource Service が 管理しているリソースルートディレクトリ(標準では pages/)からの 相対形式で指定して下さい。
例） new FunctionContainerFile("my/container/library.js")

パラメータ:
path - ソースファイルのパス名
例外:
IOException - Reader の入出力エラー
ScriptCompileException - コンパイルエラー
メソッドの詳細

sourceName

public String sourceName()
スクリプトのファイルパス名を返します。

定義:
クラス FunctionContainer 内の sourceName
戻り値:
ファイルパス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NoSuchPropertyException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.scenario
クラス NoSuchPropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.scenario.NoSuchPropertyException
すべての実装インタフェース:
Serializable
public class NoSuchPropertyException
extends Exception

NoSuchPropertyException クラスは、指定されたプロパティがオブジェクトには ないことを通知します。

関連項目:
Object, Exception, 直列化された形式

コンストラクタの概要
NoSuchPropertyException(String message)
詳細メッセージを指定して NoSuchPropertyException を構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NoSuchPropertyException

public NoSuchPropertyException(String message)
詳細メッセージを指定して NoSuchPropertyException を構築します。

文字列 message は、 java.lang.Throwable クラスの Throwable.getMessage() メソッドを使って あとで取り出すことができます。

パラメータ:
message - 詳細メッセージ
関連項目:
Throwable.getMessage()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.scenario (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.scenario
インタフェース
ScriptValue
VariableScope
クラス
FunctionContainer
FunctionContainerFile
PresentationPage
例外
NoSuchPropertyException
ScriptCompileException
ScriptRuntimeException


jp.co.intra_mart.foundation.scenario (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.scenario

スクリプト開発モデルのプログラムと連携するＡＰＩ。

参照:
説明

インタフェースの概要
ScriptValue | スクリプトの値を保持するオブジェクトです。
VariableScope | スクリプトのスコープを表すオブジェクトです。

クラスの概要
FunctionContainer | FunctionContainer クラスは、ファンクション・コンテナとなるスクリプトを コンパイルして実行可能な環境を提供します。
FunctionContainerFile | FunctionContainerFile クラスは、ファンクション・コンテナとなるファイルを コンパイルして実行可能な環境を提供します。
PresentationPage | PresentationPage クラスは、プレゼンテーション・ページとなるスクリプトを コンパイルして実行可能な環境を提供します。

例外の概要
NoSuchPropertyException | NoSuchPropertyException クラスは、指定されたプロパティがオブジェクトには ないことを通知します。
ScriptCompileException | ScriptCompileException クラスは、スクリプトのコンパイル時にエラーが発生 場合にスローされる例外です。
ScriptRuntimeException | ScriptRuntimeException クラスは、スクリプトの実行時にエラーが発生 場合にスローされる例外です。

パッケージ jp.co.intra_mart.foundation.scenario の説明

スクリプト開発モデルのプログラムと連携するＡＰＩ。


jp.co.intra_mart.foundation.scenario クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.scenario の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.scenario.FunctionContainer
      • class jp.co.intra_mart.foundation.scenario.FunctionContainerFile
    • class jp.co.intra_mart.foundation.scenario.PresentationPage
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.scenario.NoSuchPropertyException
        • class jp.co.intra_mart.foundation.scenario.ScriptCompileException
        • class jp.co.intra_mart.foundation.scenario.ScriptRuntimeException

インタフェース階層

  • interface jp.co.intra_mart.foundation.scenario.ScriptValue
    • interface jp.co.intra_mart.foundation.scenario.VariableScope


パッケージ jp.co.intra_mart.foundation.scenario の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.scenario の使用

jp.co.intra_mart.foundation.scenario を使用しているパッケージ
jp.co.intra_mart.foundation.scenario スクリプト開発モデルのプログラムと連携するＡＰＩ。

jp.co.intra_mart.foundation.scenario により使用される jp.co.intra_mart.foundation.scenario のクラス
FunctionContainer
FunctionContainer クラスは、ファンクション・コンテナとなるスクリプトを コンパイルして実行可能な環境を提供します。
NoSuchPropertyException
NoSuchPropertyException クラスは、指定されたプロパティがオブジェクトには ないことを通知します。
ScriptCompileException
ScriptCompileException クラスは、スクリプトのコンパイル時にエラーが発生 場合にスローされる例外です。
ScriptRuntimeException
ScriptRuntimeException クラスは、スクリプトの実行時にエラーが発生 場合にスローされる例外です。
ScriptValue
スクリプトの値を保持するオブジェクトです。
VariableScope
スクリプトのスコープを表すオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PresentationPage (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.scenario
クラス PresentationPage

java.lang.Object
    拡張 jp.co.intra_mart.foundation.scenario.PresentationPage
public abstract class PresentationPage
extends Object

PresentationPage クラスは、プレゼンテーション・ページとなるスクリプトを コンパイルして実行可能な環境を提供します。

プレゼンテーションページを実行するには、リンク先 URL を プログラマが意識する必要があります。

リンク先 URL とは、プレゼンテーションページ内のリンクやフォームを 表現する <IMART> タグ内で使われるもので、そのリンクをクリックした 場合や、そのフォームをサブミットした場合にリクエストを送信するアドレス になります。したがって、その URL は intra-mart に接続できて スクリプト開発モデルのページをリクエストできるという条件を 満たす必要があります。 この条件を満たす URL は、通常はログイン画面をリクエストするための URL と等しくなります。intra-mart を標準的にインストールした状態では、

http://サーバアドレス:ポート番号/imart/intramart
になります。

セッションを持つページを作成する場合は、 ログイン画面からログインした時に割り当てられた セッションを維持するように実行することが必要になります。 セッションを維持したページを作成する場合、Servlet の リクエストおよびレスポンスが必要になります。 これは、Servlet の HTTP セッションを利用してセッションを 確立しているためであり、他の方法ではセッションを維持したページを 作成することはできません。
セッションを指定しなかった場合、ユーザー情報を決定することができないため、 ユーザおよびログイングループに関わるすべての API の利用が不可能となります。

導入されたバージョン:
version 3.2
関連項目:
Object

コンストラクタの概要
PresentationPage()
セッションを持たないページ作成用オブジェクトを作成します。
PresentationPage(HttpServletRequest request, HttpServletResponse response)
任意のセッションを持つページ作成オブジェクトを構築します。
メソッドの概要
String | execute(String path) プログラム実行。
String | execute(String path, Object[] args) プログラム実行。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PresentationPage

public PresentationPage()
セッションを持たないページ作成用オブジェクトを作成します。

PresentationPage

public PresentationPage(HttpServletRequest request,
                        HttpServletResponse response)
                 throws IllegalArgumentException
任意のセッションを持つページ作成オブジェクトを構築します。

パラメータ:
request - サーブレットの引数オブジェクト
response - サーブレットのレスポンスオブジェクト
例外:
IllegalArgumentException - 引数のいずれかが NULL である場合に スローされます
メソッドの詳細

execute

public String execute(String path)
               throws ScriptRuntimeException,
                      FileNotFoundException
プログラム実行。

指定のプログラムを実行します。

プログラムは HTML および JavaScript ファイルで、引数 path には、Information Server のプログラムパスからの相対形式で拡張子を省略 した形式で指定します。実行エンジンは、自動的に path.html および path.js を探して実行します。

パラメータ:
path - 実行するプログラムのパス
戻り値:
HTML ソース
例外:
ScriptRuntimeException - ページプログラム実行時エラー
FileNotFoundException

execute

public String execute(String path,
                      Object[] args)
               throws ScriptRuntimeException,
                      FileNotFoundException
プログラム実行。

指定のプログラムを実行します。

プログラムは HTML および JavaScript ファイルで、引数 path には、Resource-Service のプログラムパスからの相対形式で拡張子を省略 した形式で指定します。実行エンジンは、自動的に path.html および path.js を探して実行します。

引数 args は、path.js に定義されている init() メソッドの 実行時引数として渡されます。 args が持つ要素の個数は、init() 関数に渡される引数の個数と 等しくなります。

パラメータ:
path - 実行するプログラムのパス
args - プログラム実行時の任意引数
戻り値:
HTML ソース
例外:
ScriptRuntimeException - ページプログラム実行時エラー
FileNotFoundException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ScriptCompileException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.scenario
クラス ScriptCompileException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.scenario.ScriptCompileException
すべての実装インタフェース:
Serializable
public class ScriptCompileException
extends Exception

ScriptCompileException クラスは、スクリプトのコンパイル時にエラーが発生 場合にスローされる例外です。
コンパイルエラーとは、主に構文エラーになります。

関連項目:
Object, Exception, 直列化された形式

コンストラクタの概要
ScriptCompileException(String message)
詳細メッセージを指定して ScriptCompileException を構築します。
ScriptCompileException(String message, Throwable cause)
詳細メッセージを指定して ScriptCompileException を構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ScriptCompileException

public ScriptCompileException(String message)
詳細メッセージを指定して ScriptCompileException を構築します。

文字列 message は、 java.lang.Throwable クラスの Throwable.getMessage() メソッドを使って あとで取り出すことができます。

パラメータ:
message - 詳細メッセージ
関連項目:
Throwable.getMessage()

ScriptCompileException

public ScriptCompileException(String message,
                              Throwable cause)
詳細メッセージを指定して ScriptCompileException を構築します。

文字列 message は、 java.lang.Throwable クラスの Throwable.getMessage() メソッドを使って あとで取り出すことができます。

パラメータ:
message - 詳細メッセージ
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す
導入されたバージョン:
version 4.3
関連項目:
Throwable.getMessage()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ScriptRuntimeException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.scenario
クラス ScriptRuntimeException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.scenario.ScriptRuntimeException
すべての実装インタフェース:
Serializable
public class ScriptRuntimeException
extends Exception

ScriptRuntimeException クラスは、スクリプトの実行時にエラーが発生 場合にスローされる例外です。

関連項目:
Object, Exception, 直列化された形式

コンストラクタの概要
ScriptRuntimeException(String message)
詳細メッセージを指定して ScriptRuntimeException を構築します。
ScriptRuntimeException(String message, Throwable cause)
詳細メッセージを指定して ScriptRuntimeException を構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ScriptRuntimeException

public ScriptRuntimeException(String message)
詳細メッセージを指定して ScriptRuntimeException を構築します。

文字列 message は、 java.lang.Throwable クラスの Throwable.getMessage() メソッドを使って あとで取り出すことができます。

パラメータ:
message - 詳細メッセージ
関連項目:
Throwable.getMessage()

ScriptRuntimeException

public ScriptRuntimeException(String message,
                              Throwable cause)
詳細メッセージを指定して ScriptRuntimeException を構築します。

文字列 message は、 java.lang.Throwable クラスの Throwable.getMessage() メソッドを使って あとで取り出すことができます。

パラメータ:
message - 詳細メッセージ
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す
導入されたバージョン:
version 4.3
関連項目:
Throwable.getMessage()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ScriptValue (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.scenario
インタフェース ScriptValue

既知のサブインタフェースの一覧:
VariableScope
public interface ScriptValue

スクリプトの値を保持するオブジェクトです。

メソッドの概要
boolean | booleanValue() このオブジェクトの示す値の真偽値表現を取得します。
double | doubleValue() このオブジェクトの示す値の数値表現を取得します。
Object | getValue() このオブジェクトの示す値を取得します。
boolean | isFunction() このオブジェクトの示す値が関数かどうか判定します。
boolean | isInstance(Class c) このオブジェクトの示す値が c が表すオブジェクトと代入互換の 関係にあるかどうか判定します。
boolean | isNull() このオブジェクトの示す値が null かどうか判定します。
boolean | isObject() このオブジェクトの示す値がオブジェクトかどうか判定します。
boolean | isUndefined() このオブジェクトの示す値が undefined かどうか判定します。
String | toString() このオブジェクトの示す値の文字列表現を取得します。

メソッドの詳細

isObject

public boolean isObject()
このオブジェクトの示す値がオブジェクトかどうか判定します。

戻り値:
オブジェクトの場合 true、そうでない場合 false

isFunction

public boolean isFunction()
このオブジェクトの示す値が関数かどうか判定します。

戻り値:
関数の場合 true、そうでない場合 false

isUndefined

public boolean isUndefined()
このオブジェクトの示す値が undefined かどうか判定します。

戻り値:
Undefined の場合 true、そうでない場合 false

isNull

public boolean isNull()
このオブジェクトの示す値が null かどうか判定します。

戻り値:
null の場合 true、そうでない場合 false

isInstance

public boolean isInstance(Class c)
このオブジェクトの示す値が c が表すオブジェクトと代入互換の 関係にあるかどうか判定します。

このメソッドは、c の isInstance() メソッドにより判定を行います。

戻り値:
代入互換の関係にある場合 true、そうでない場合 false
関連項目:
Class.isInstance(java.lang.Object)

getValue

public Object getValue()
このオブジェクトの示す値を取得します。

戻り値:
値

toString

public String toString()
このオブジェクトの示す値の文字列表現を取得します。

戻り値:
値の文字列表現

doubleValue

public double doubleValue()
このオブジェクトの示す値の数値表現を取得します。

戻り値:
値の数値表現

booleanValue

public boolean booleanValue()
このオブジェクトの示す値の真偽値表現を取得します。

戻り値:
値の真偽値表現
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


VariableScope (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.scenario
インタフェース VariableScope

すべてのスーパーインタフェース:
ScriptValue
public interface VariableScope
extends ScriptValue

スクリプトのスコープを表すオブジェクトです。

メソッドの概要
ScriptValue | getProperty(String name) プロパティ値を取得します。
boolean | hasProperty(String name) プロパティが存在しているかをチェックします。
ScriptValue | invoke(String name, Number arg) 指定関数を実行します。
ScriptValue | invoke(String name, Object[] args) 指定関数を実行します。
ScriptValue | invoke(String name, String arg) 指定関数を実行します。
Object[] | keys() プロパティの名称一覧を取得します。
インタフェース jp.co.intra_mart.foundation.scenario.ScriptValue から継承したメソッド
booleanValue, doubleValue, getValue, isFunction, isInstance, isNull, isObject, isUndefined, toString

メソッドの詳細

invoke

public ScriptValue invoke(String name,
                          String arg)
                   throws ScriptRuntimeException,
                          NoSuchPropertyException
指定関数を実行します。

指定の関数を指定の引数を伴って実行します。
返却値は、呼び出した関数の戻り値になりますが、 スクリプトおよび JAVA の双方で解釈できる型 (String, Number, Boolean)に限られます。

パラメータ:
name - 関数名
arg - 引数
戻り値:
関数の戻り値
例外:
ScriptRuntimeException - スクリプト実行時エラー
NoSuchPropertyException - 指定のプロパティが存在しない場合

invoke

public ScriptValue invoke(String name,
                          Number arg)
                   throws ScriptRuntimeException,
                          NoSuchPropertyException
指定関数を実行します。

指定の関数を指定の引数を伴って実行します。
返却値は、呼び出した関数の戻り値になりますが、 スクリプトおよび JAVA の双方で解釈できる型 (String, Number, Boolean)に限られます。

パラメータ:
name - 関数名
arg - 引数
戻り値:
関数の戻り値
例外:
ScriptRuntimeException - スクリプト実行時エラー
NoSuchPropertyException - 指定のプロパティが存在しない場合

invoke

public ScriptValue invoke(String name,
                          Object[] args)
                   throws ScriptRuntimeException,
                          NoSuchPropertyException
指定関数を実行します。

指定の関数を指定の引数を伴って実行します。
引数は配列形式で複数の値を指定できます。また、引数に指定できる データ型は、スクリプトで解釈できる型(String, Number, Boolean)に 限られます。
返却値は、呼び出した関数の戻り値になりますが、引数同様 スクリプトおよび JAVA の双方で解釈できる型 (String, Number, Boolean)に限られます。

パラメータ:
name - 関数名
args - 引数
戻り値:
関数の戻り値
例外:
ScriptRuntimeException - スクリプト実行時エラー
NoSuchPropertyException - 指定のプロパティが存在しない場合

getProperty

public ScriptValue getProperty(String name)
                        throws NoSuchPropertyException
プロパティ値を取得します。 このスコープにおいて指定のプロパティ名にマップされている 値を取得します。

パラメータ:
name - プロパティ名
戻り値:
プロパティにマップされている値
例外:
NoSuchPropertyException - 指定のプロパティが存在しない場合

hasProperty

public boolean hasProperty(String name)
プロパティが存在しているかをチェックします。 このスコープにおいて指定のプロパティが値にマップされている場合 真値(true)を返します。

パラメータ:
name - プロパティ名
戻り値:
プロパティがマップされている場合 true

keys

public Object[] keys()
プロパティの名称一覧を取得します。 このスコープが保持しているプロパティのプロパティ名を配列形式で 取得します。

戻り値:
このスコープが保持しているプロパティの名称一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.access.AccessController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.access.AccessController の使用

AccessController を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |

jp.co.intra_mart.foundation.security での AccessController の使用

AccessController を返す jp.co.intra_mart.foundation.security のメソッド
AccessController | StandardAccessControllerAccessor.getController(String groupId, String controllerId) アクセスコントローラ情報を取得します。
AccessController[] | StandardAccessControllerAccessor.getControllers(String groupId) すべてのアクセスコントローラ情報を取得します。

AccessController 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | StandardAccessControllerAccessor.insertAccessController(String groupId, AccessController controller) アクセスコントローラを作成します。
void | StandardAccessControllerAccessor.updateController(String groupId, AccessController controller) アクセスコントローラを更新します。

jp.co.intra_mart.foundation.security.access での AccessController の使用

AccessController を返す jp.co.intra_mart.foundation.security.access のメソッド
AccessController | AccessControllerReaderDecorator.doDecoration(String groupId, AccessController controller) アクセスコントローラデータストアからの読み込み直後にコールされます。
AccessController | AccessControllerManager.getController(String controllerId) 指定されたアクセスコントローラIDに対応するアクセスコントローラを取得します。
AccessController[] | AccessControllerManager.getControllers() すべてのアクセスコントローラを取得します。
AccessController | AccessControllerAccessor.getController(String groupId, String controllerId) アクセスコントローラ情報を取得します。
AccessController[] | AccessControllerAccessor.getControllers(String groupId) すべてのアクセスコントローラ情報を取得します。

AccessController 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
AccessController | AccessControllerReaderDecorator.doDecoration(String groupId, AccessController controller) アクセスコントローラデータストアからの読み込み直後にコールされます。
void | AccessControllerQueryWriterListener.queryCreate(String groupId, AccessController controller) アクセスコントローラ情報をデータストアに作成する直前にコールされます。
void | AccessControllerQueryWriterListener.queryUpdate(String groupId, AccessController controller) アクセスコントローラ情報をデータストアに更新する直前にコールされます。
void | AccessControllerPostWriterListener.postCreate(String groupId, AccessController controller) アクセスコントローラ情報をデータストアに作成した直後にコールされます。
void | AccessControllerPostWriterListener.postUpdate(String groupId, AccessController controller) アクセスコントローラ情報をデータストアに更新した直後にコールされます。
void | AccessControllerManager.addController(AccessController controller) アクセスコントローラを追加します。
void | AccessControllerManager.updateController(AccessController controller) アクセスコントローラを更新します。
void | AccessControllerAccessor.insertAccessController(String groupId, AccessController controller) アクセスコントローラを作成します。
void | AccessControllerAccessor.updateController(String groupId, AccessController controller) アクセスコントローラを更新します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.access.AccessControllerAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.access.AccessControllerAccessor の使用

AccessControllerAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での AccessControllerAccessor の使用

AccessControllerAccessor を実装している jp.co.intra_mart.foundation.security のクラス
 class StandardAccessControllerAccessor

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.access.AccessControllerExporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.access.AccessControllerExporter の使用

AccessControllerExporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.access

jp.co.intra_mart.foundation.security.access での AccessControllerExporter の使用

AccessControllerExporter を実装している jp.co.intra_mart.foundation.security.access のクラス
 class StandardAccessControllerBackup

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.access.AccessControllerImporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.access.AccessControllerImporter の使用

AccessControllerImporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.access

jp.co.intra_mart.foundation.security.access での AccessControllerImporter の使用

AccessControllerImporter を実装している jp.co.intra_mart.foundation.security.access のクラス
 class StandardAccessControllerBackup

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.access.AccessControllerManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.access.AccessControllerManager の使用

AccessControllerManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.access

jp.co.intra_mart.foundation.security.access での AccessControllerManager の使用

AccessControllerManager 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | AccessControllerImporter.doImport(InputStream inputStream, AccessControllerManager manager) インポートを行います。
void | AccessControllerExporter.doExport(AccessControllerManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardAccessControllerBackup.doImport(InputStream inputStream, AccessControllerManager manager)
void | StandardAccessControllerBackup.doExport(AccessControllerManager manager, OutputStream outputStream)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.access.AccessControllerPostWriterListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.access.AccessControllerPostWriterListener の使用

jp.co.intra_mart.foundation.security.access.AccessControllerPostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.access.AccessControllerQueryWriterListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.access.AccessControllerQueryWriterListener の使用

jp.co.intra_mart.foundation.security.access.AccessControllerQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.access.AccessControllerReaderDecorator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.access.AccessControllerReaderDecorator の使用

jp.co.intra_mart.foundation.security.access.AccessControllerReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener の使用

jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener の使用

jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener の使用

jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.access.StandardAccessControllerBackup の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.access.StandardAccessControllerBackup の使用

jp.co.intra_mart.foundation.security.access.StandardAccessControllerBackup はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AccessController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.access
クラス AccessController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.access.AccessController
すべての実装インタフェース:
Serializable
public class AccessController
extends Object
implements Serializable

アクセスコントローラ・モデルクラス。

アクセスコントローラのデータモデルを定義します。

導入されたバージョン:
6.1
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
AccessController()
コンストラクタ。
AccessController(String controllerId)
コンストラクタ。
メソッドの概要
String | getControllerId() コントローラＩＤを取得します。
String | getDescription() 説明を取得します。
String | getDisplayName() 表示名を取得します。
void | setAccessControllerId(String controllerId) コントローラＩＤを設定します。
void | setDescription(String description) 説明を設定します。
void | setDisplayName(String displayName) 表示名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AccessController

public AccessController(String controllerId)
コンストラクタ。

コントローラＩＤを指定して、インスタンスを生成します。

パラメータ:
controllerId -

AccessController

public AccessController()
コンストラクタ。

メソッドの詳細

getControllerId

public String getControllerId()
コントローラＩＤを取得します。

戻り値:
コントローラＩＤ

setAccessControllerId

public void setAccessControllerId(String controllerId)
コントローラＩＤを設定します。

パラメータ:
controllerId - コントローラＩＤ

getDescription

public String getDescription()
説明を取得します。

戻り値:
説明

setDescription

public void setDescription(String description)
説明を設定します。

パラメータ:
description - 説明

getDisplayName

public String getDisplayName()
表示名を取得します。

戻り値:
表示名

setDisplayName

public void setDisplayName(String displayName)
表示名を設定します。

パラメータ:
displayName - 表示名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccessControllerAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.access
インタフェース AccessControllerAccessor

既知の実装クラスの一覧:
StandardAccessControllerAccessor
public interface AccessControllerAccessor

アクセスコントローラアクセッサインタフェース。

アクセスコントローラ情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
void | deleteController(String groupId, String controllerId) アクセスコントローラを削除します。
void | deleteControllerDepartment(String groupId, String id, DepartmentInfo departmentInfo) アクセスコントローラ組織を削除します。
void | deleteControllerDepartments(String groupId, String id) すべてのアクセスコントローラ組織を削除します。
void | deleteControllerPost(String groupId, String id, PostInfo postInfo) アクセスコントローラ役職を削除します。
void | deleteControllerPosts(String groupId, String id) すべてのアクセスコントローラ役職を削除します。
void | deleteControllerPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) アクセスコントローラパブリックグループを削除します。
void | deleteControllerPublicGroups(String groupId, String id) すべてのアクセスコントローラパブリックグループを削除します。
void | deleteControllerRole(String groupId, String id, String roleId) アクセスコントローラロールを削除します。
void | deleteControllerRoles(String groupId, String id) すべてのアクセスコントローラロールを削除します。
AccessController | getController(String groupId, String controllerId) アクセスコントローラ情報を取得します。
DepartmentInfo[] | getControllerDepartments(String groupId, String id) すべてのアクセスコントローラ組織を取得します。
String[] | getControllerIds(String groupId) すべてのアクセスコントローラIDを取得します。
String[] | getControllerIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つコントローラIDをすべて取得します。
String[] | getControllerIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つコントローラIDをすべて取得します。
String[] | getControllerIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つコントローラIDをすべて取得します。
String[] | getControllerIdsByRole(String groupId, String[] roleIds) 指定されたロールIDを持つコントローラIDをすべて取得します。
PostInfo[] | getControllerPosts(String groupId, String id) すべてのアクセスコントローラ役職を取得します。
PublicGroupInfo[] | getControllerPublicGroups(String groupId, String id) すべてのアクセスコントローラパブリックグループを取得します。
String[] | getControllerRoles(String groupId, String id) すべてのアクセスコントローラロールを取得します。
AccessController[] | getControllers(String groupId) すべてのアクセスコントローラ情報を取得します。
void | init(Map params) アクセスコントローラアクセッサの初期化。
void | insertAccessController(String groupId, AccessController controller) アクセスコントローラを作成します。
void | insertControllerDepartment(String groupId, String id, DepartmentInfo departmentInfo) アクセスコントローラ組織を新規に作成します。
void | insertControllerPost(String groupId, String id, PostInfo postInfo) アクセスコントローラ役職を新規に作成します。
void | insertControllerPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) アクセスコントローラパブリックグループを新規に作成します。
void | insertControllerRole(String groupId, String id, String roleId) アクセスコントローラロールを新規に作成します。
void | updateController(String groupId, AccessController controller) アクセスコントローラを更新します。

メソッドの詳細

deleteController

public void deleteController(String groupId,
                             String controllerId)
                      throws AccessSecurityWriteException
アクセスコントローラを削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException

deleteControllerDepartment

public void deleteControllerDepartment(String groupId,
                                       String id,
                                       DepartmentInfo departmentInfo)
                                throws AccessSecurityWriteException
アクセスコントローラ組織を削除します。

パラメータ:
groupId - ログイングループID
id - コントローラID
departmentInfo - 組織情報
例外:
AccessSecurityWriteException

deleteControllerDepartments

public void deleteControllerDepartments(String groupId,
                                        String id)
                                 throws AccessSecurityWriteException
すべてのアクセスコントローラ組織を削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException

deleteControllerPost

public void deleteControllerPost(String groupId,
                                 String id,
                                 PostInfo postInfo)
                          throws AccessSecurityWriteException
アクセスコントローラ役職を削除します。

パラメータ:
groupId - ログイングループID
id - コントローラID
postInfo - 役職情報
例外:
AccessSecurityWriteException

deleteControllerPosts

public void deleteControllerPosts(String groupId,
                                  String id)
                           throws AccessSecurityWriteException
すべてのアクセスコントローラ役職を削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException

deleteControllerPublicGroup

public void deleteControllerPublicGroup(String groupId,
                                        String id,
                                        PublicGroupInfo publicGroupInfo)
                                 throws AccessSecurityWriteException
アクセスコントローラパブリックグループを削除します。

パラメータ:
groupId - ログイングループID
id - コントローラID
publicGroupInfo - パブリックグループ情報
例外:
AccessSecurityWriteException

deleteControllerPublicGroups

public void deleteControllerPublicGroups(String groupId,
                                         String id)
                                  throws AccessSecurityWriteException
すべてのアクセスコントローラパブリックグループを削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException

deleteControllerRole

public void deleteControllerRole(String groupId,
                                 String id,
                                 String roleId)
                          throws AccessSecurityWriteException
アクセスコントローラロールを削除します。

パラメータ:
groupId - ログイングループID
id - コントローラID
roleId - ロールID
例外:
AccessSecurityWriteException

deleteControllerRoles

public void deleteControllerRoles(String groupId,
                                  String id)
                           throws AccessSecurityWriteException
すべてのアクセスコントローラロールを削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException

getController

public AccessController getController(String groupId,
                                      String controllerId)
                               throws AccessSecurityReadException
アクセスコントローラ情報を取得します。

存在しない場合は、nullを返却します。

パラメータ:
groupId - ログイングループID
controllerId - コントローラID
戻り値:
アクセスコントローラ情報
例外:
AccessSecurityReadException

getControllers

public AccessController[] getControllers(String groupId)
                                  throws AccessSecurityReadException
すべてのアクセスコントローラ情報を取得します。

一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
戻り値:
アクセスコントローラ情報の配列
例外:
AccessSecurityReadException

getControllerDepartments

public DepartmentInfo[] getControllerDepartments(String groupId,
                                                 String id)
                                          throws AccessSecurityReadException
すべてのアクセスコントローラ組織を取得します。

一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
id - コントローラID
戻り値:
組織情報の配列
例外:
AccessSecurityReadException

getControllerIds

public String[] getControllerIds(String groupId)
                          throws AccessSecurityReadException
すべてのアクセスコントローラIDを取得します。

一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
戻り値:
クセスコントローラIDの配列
例外:
AccessSecurityReadException

getControllerIdsByDepartment

public String[] getControllerIdsByDepartment(String groupId,
                                             DepartmentInfo[] departments)
                                      throws AccessSecurityReadException
指定された組織を持つコントローラIDをすべて取得します。

パラメータ:
groupId - ログイングループID
departments - 組織情報の配列
戻り値:
コントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerIdsByPost

public String[] getControllerIdsByPost(String groupId,
                                       PostInfo[] posts)
                                throws AccessSecurityReadException
指定された役職を持つコントローラIDをすべて取得します。

パラメータ:
groupId - ログイングループID
posts - 役職情報の配列
戻り値:
コントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerIdsByPublicGroup

public String[] getControllerIdsByPublicGroup(String groupId,
                                              PublicGroupInfo[] publicGroups)
                                       throws AccessSecurityReadException
指定されたパブリックグループを持つコントローラIDをすべて取得します。

パラメータ:
groupId - ログイングループID
publicGroups - パブリックグループの配列
戻り値:
コントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerIdsByRole

public String[] getControllerIdsByRole(String groupId,
                                       String[] roleIds)
                                throws AccessSecurityReadException
指定されたロールIDを持つコントローラIDをすべて取得します。

パラメータ:
groupId - ログイングループID
roleIds - ロールIDの配列
戻り値:
コントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerPosts

public PostInfo[] getControllerPosts(String groupId,
                                     String id)
                              throws AccessSecurityReadException
すべてのアクセスコントローラ役職を取得します。

一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
id - コントローラID
戻り値:
役職情報の配列
例外:
AccessSecurityReadException

getControllerPublicGroups

public PublicGroupInfo[] getControllerPublicGroups(String groupId,
                                                   String id)
                                            throws AccessSecurityReadException
すべてのアクセスコントローラパブリックグループを取得します。

一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
id - コントローラID
戻り値:
パブリックグループ情報の配列
例外:
AccessSecurityReadException

getControllerRoles

public String[] getControllerRoles(String groupId,
                                   String id)
                            throws AccessSecurityReadException
すべてのアクセスコントローラロールを取得します。

一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
id - コントローラID
戻り値:
アクセスコントローラロールIDの配列
例外:
AccessSecurityReadException

init

public void init(Map params)
アクセスコントローラアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

insertAccessController

public void insertAccessController(String groupId,
                                   AccessController controller)
                            throws AccessSecurityWriteException
アクセスコントローラを作成します。

パラメータ:
groupId - ログイングループID
controller - アクセスコントローラ情報
例外:
AccessSecurityWriteException

insertControllerDepartment

public void insertControllerDepartment(String groupId,
                                       String id,
                                       DepartmentInfo departmentInfo)
                                throws AccessSecurityWriteException
アクセスコントローラ組織を新規に作成します。

パラメータ:
groupId - ログイングループID
id - コントローラID
departmentInfo - 組織情報
例外:
AccessSecurityWriteException

insertControllerPost

public void insertControllerPost(String groupId,
                                 String id,
                                 PostInfo postInfo)
                          throws AccessSecurityWriteException
アクセスコントローラ役職を新規に作成します。

パラメータ:
groupId - ログイングループID
id - コントローラID
postInfo - 役職情報
例外:
AccessSecurityWriteException

insertControllerPublicGroup

public void insertControllerPublicGroup(String groupId,
                                        String id,
                                        PublicGroupInfo publicGroupInfo)
                                 throws AccessSecurityWriteException
アクセスコントローラパブリックグループを新規に作成します。

パラメータ:
groupId - ログイングループID
id - コントローラID
publicGroupInfo - パブリックグループ情報
例外:
AccessSecurityWriteException

insertControllerRole

public void insertControllerRole(String groupId,
                                 String id,
                                 String roleId)
                          throws AccessSecurityWriteException
アクセスコントローラロールを新規に作成します。

パラメータ:
groupId - ログイングループID
id - コントローラID
roleId - ロールID
例外:
AccessSecurityWriteException

updateController

public void updateController(String groupId,
                             AccessController controller)
                      throws AccessSecurityWriteException
アクセスコントローラを更新します。

パラメータ:
groupId - ログイングループID
controller - アクセスコントローラ情報
例外:
AccessSecurityWriteException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccessControllerExporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.access
インタフェース AccessControllerExporter

既知の実装クラスの一覧:
StandardAccessControllerBackup
public interface AccessControllerExporter

アクセスコントローラエクスポートインタフェースです。

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
void | doExport(AccessControllerManager manager, OutputStream outputStream) エクスポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doExport

public void doExport(AccessControllerManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

アクセスコントローラ情報をバックアップファイルに出力します。

パラメータ:
manager - アクセスコントローラマネージャ
outputStream - 出力ストリーム
例外:
AccessSecurityExportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerImporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.access
インタフェース AccessControllerImporter

既知の実装クラスの一覧:
StandardAccessControllerBackup
public interface AccessControllerImporter

アクセスコントローラインポートインタフェースです。

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
void | doImport(InputStream inputStream, AccessControllerManager manager) インポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doImport

public void doImport(InputStream inputStream,
                     AccessControllerManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からアクセスコントローラ情報を取得し、生成します。

パラメータ:
manager - アクセスコントローラマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.access
クラス AccessControllerManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.access.AccessControllerManager
public final class AccessControllerManager
extends Object

アクセスコントローラマネージャクラス。

アクセスコントローラ情報の操作を行います。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
AccessControllerManager(String groupId)
コンストラクタ。
メソッドの概要
 void addController(AccessController controller)
アクセスコントローラを追加します。
 void addControllerDepartment(String controllerId, DepartmentInfo departmentInfo)
組織をアクセスコントローラに紐付けます。
 void addControllerPost(String controllerId, PostInfo postInfo)
役職をアクセスコントローラに紐付けます。
 void addControllerPublicGroup(String controllerId, PublicGroupInfo publicGroupInfo)
パブリックグループをアクセスコントローラに紐付けます。
 void addControllerRole(String controllerId, String roleId)
ロールをアクセスコントローラに紐付けます。
static void clearInstance()
アクセスコントローラマネージャのインスタンスを初期化します。
 void deleteController(String controllerId)
アクセスコントローラを削除します。
 void deleteControllerDepartment(String controllerId, DepartmentInfo departmentInfo)
組織の紐付けをアクセスコントローラから削除します。
 void deleteControllerDepartments(String controllerId)
組織の紐付けをアクセスコントローラからすべて削除します。
 void deleteControllerPost(String controllerId, PostInfo postInfo)
役織の紐付けをアクセスコントローラから削除します。
 void deleteControllerPosts(String controllerId)
役織の紐付けをアクセスコントローラからすべて削除します。
 void deleteControllerPublicGroup(String controllerId, PublicGroupInfo publicGroupInfo)
パブリックグループの紐付けをアクセスコントローラから削除します。
 void deleteControllerPublicGroups(String controllerId)
パブリックグループの紐付けをアクセスコントローラからすべて削除します。
 void deleteControllerRole(String controllerId, String roleId)
ロールの紐付けをアクセスコントローラから削除します。
 void deleteControllerRoles(String controllerId)
ロールの紐付けをアクセスコントローラから削除します。
 void deleteControllers()
すべてのアクセスコントローラを削除します。
 void exportData(String category, OutputStream outputStream)
アクセスコントローラ情報をエクスポートします。
 AccessController getController(String controllerId)
指定されたアクセスコントローラIDに対応するアクセスコントローラを取得します。
 DepartmentInfo[] getControllerDepartments(String controllerId)
アクセスコントローラに紐付いた組織の一覧を取得します。
 String[] getControllerIds()
すべてのアクセスコントローラIDを取得します。
 String[] getControllerIdsByDepartment(DepartmentInfo[] departments)
指定された組織を持つアクセスコントローラIDをすべて取得します。
 String[] getControllerIdsByPost(PostInfo[] posts)
指定された役職を持つアクセスコントローラIDをすべて取得します。
 String[] getControllerIdsByPublicGroup(PublicGroupInfo[] publicGroups)
指定されたパブリックグループを持つアクセスコントローラIDをすべて取得します。
 String[] getControllerIdsByRole(String[] roleIds)
指定されたロールIDを持つアクセスコントローラIDをすべて取得します。
 String[] getControllerIdsByUser(String userId, Date date)
指定されたユーザIDおよび日付で有効なアクセスコントローラIDをすべて取得します。
 PostInfo[] getControllerPosts(String controllerId)
アクセスコントローラに紐付いた役職の一覧を取得します。
 PublicGroupInfo[] getControllerPublicGroups(String controllerId)
アクセスコントローラに紐付いたパブリックグループの一覧を取得します。
 String[] getControllerRoles(String controllerId)
アクセスコントローラに紐付いたロールの一覧を取得します。
 AccessController[] getControllers()
すべてのアクセスコントローラを取得します。
 String[] getExportCategories()
アクセスコントローラエクスポート用のカテゴリの一覧を取得します。
 String[] getImportCategories()
アクセスコントローラインポート用のカテゴリの一覧を取得します。
 String getLoginGroupId()
ログイングループIDを取得します。
 void importData(String category, InputStream inputStream)
/** アクセスコントローラ情報をインポートします。
 boolean isUpdate(Date date)
アクセスコントローラが指定された日付よりも新しいかチェックします。
 void updateController(AccessController controller)
アクセスコントローラを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AccessControllerManager

public AccessControllerManager(String groupId)
                        throws AccessSecurityException
コンストラクタ。

ログイングループ単位のアクセスコントローラを操作するマネージャーを作成します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityException - ログイングループIDが不正な場合にスローされます。
メソッドの詳細

clearInstance

public static void clearInstance()
アクセスコントローラマネージャのインスタンスを初期化します。

アクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。
通常、このメソッドを使用する必要はありません。

addController

public void addController(AccessController controller)
                   throws AccessSecurityException
アクセスコントローラを追加します。

パラメータ:
controller - アクセスコントローラ
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

addControllerDepartment

public void addControllerDepartment(String controllerId,
                                    DepartmentInfo departmentInfo)
                             throws AccessSecurityException
組織をアクセスコントローラに紐付けます。

パラメータ:
controllerId - アクセスコントローラID
departmentInfo - 組織情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

addControllerPost

public void addControllerPost(String controllerId,
                              PostInfo postInfo)
                       throws AccessSecurityException
役職をアクセスコントローラに紐付けます。

パラメータ:
controllerId - アクセスコントローラID
postInfo - 役職情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

addControllerPublicGroup

public void addControllerPublicGroup(String controllerId,
                                     PublicGroupInfo publicGroupInfo)
                              throws AccessSecurityException
パブリックグループをアクセスコントローラに紐付けます。

パラメータ:
controllerId - アクセスコントローラID
publicGroupInfo - パブリックグループ
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

addControllerRole

public void addControllerRole(String controllerId,
                              String roleId)
                       throws AccessSecurityException
ロールをアクセスコントローラに紐付けます。

パラメータ:
controllerId - アクセスコントローラID
roleId - ロールID
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteController

public void deleteController(String controllerId)
                      throws AccessSecurityException
アクセスコントローラを削除します。

パラメータ:
controllerId - アクセスコントローラID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteControllerDepartment

public void deleteControllerDepartment(String controllerId,
                                       DepartmentInfo departmentInfo)
                                throws AccessSecurityException
組織の紐付けをアクセスコントローラから削除します。

パラメータ:
controllerId - アクセスコントローラID
departmentInfo - 組織情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteControllerDepartments

public void deleteControllerDepartments(String controllerId)
                                 throws AccessSecurityException
組織の紐付けをアクセスコントローラからすべて削除します。

パラメータ:
controllerId - アクセスコントローラID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteControllerPost

public void deleteControllerPost(String controllerId,
                                 PostInfo postInfo)
                          throws AccessSecurityException
役織の紐付けをアクセスコントローラから削除します。

パラメータ:
controllerId - アクセスコントローラID
postInfo - 役織情報
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteControllerPosts

public void deleteControllerPosts(String controllerId)
                           throws AccessSecurityException
役織の紐付けをアクセスコントローラからすべて削除します。

パラメータ:
controllerId - アクセスコントローラID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteControllerPublicGroup

public void deleteControllerPublicGroup(String controllerId,
                                        PublicGroupInfo publicGroupInfo)
                                 throws AccessSecurityException
パブリックグループの紐付けをアクセスコントローラから削除します。

パラメータ:
controllerId - アクセスコントローラID
publicGroupInfo - パブリックグループ
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteControllerPublicGroups

public void deleteControllerPublicGroups(String controllerId)
                                  throws AccessSecurityException
パブリックグループの紐付けをアクセスコントローラからすべて削除します。

パラメータ:
controllerId - アクセスコントローラID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteControllerRole

public void deleteControllerRole(String controllerId,
                                 String roleId)
                          throws AccessSecurityException
ロールの紐付けをアクセスコントローラから削除します。

パラメータ:
controllerId - アクセスコントローラID
roleId - ロールID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteControllerRoles

public void deleteControllerRoles(String controllerId)
                           throws AccessSecurityException
ロールの紐付けをアクセスコントローラから削除します。

パラメータ:
controllerId - アクセスコントローラID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteControllers

public void deleteControllers()
                       throws AccessSecurityException
すべてのアクセスコントローラを削除します。

例外:
AccessSecurityException - 削除処理に失敗した場合にスローされます。

exportData

public void exportData(String category,
                       OutputStream outputStream)
                throws AccessSecurityException
アクセスコントローラ情報をエクスポートします。

パラメータ:
category - カテゴリ
outputStream - 出力ストリーム
例外:
AccessSecurityException - エクスポートに失敗した場合、または引数が不正だった場合にスローされます。

getController

public AccessController getController(String controllerId)
                               throws AccessSecurityException
指定されたアクセスコントローラIDに対応するアクセスコントローラを取得します。

パラメータ:
controllerId - アクセスコントローラID
戻り値:
アクセスコントローラ
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getControllerDepartments

public DepartmentInfo[] getControllerDepartments(String controllerId)
                                          throws AccessSecurityException
アクセスコントローラに紐付いた組織の一覧を取得します。

パラメータ:
controllerId - アクセスコントローラID
戻り値:
組織情報の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getControllerIds

public String[] getControllerIds()
                          throws AccessSecurityException
すべてのアクセスコントローラIDを取得します。

戻り値:
アクセスコントローラIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getControllerIdsByDepartment

public String[] getControllerIdsByDepartment(DepartmentInfo[] departments)
                                      throws AccessSecurityException
指定された組織を持つアクセスコントローラIDをすべて取得します。

パラメータ:
departments - 組織情報の配列
戻り値:
アクセスコントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerIdsByPost

public String[] getControllerIdsByPost(PostInfo[] posts)
                                throws AccessSecurityException
指定された役職を持つアクセスコントローラIDをすべて取得します。

パラメータ:
posts - 役職情報の配列
戻り値:
アクセスコントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerIdsByPublicGroup

public String[] getControllerIdsByPublicGroup(PublicGroupInfo[] publicGroups)
                                       throws AccessSecurityException
指定されたパブリックグループを持つアクセスコントローラIDをすべて取得します。

パラメータ:
publicGroups - パブリックグループの配列
戻り値:
アクセスコントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerIdsByRole

public String[] getControllerIdsByRole(String[] roleIds)
                                throws AccessSecurityException
指定されたロールIDを持つアクセスコントローラIDをすべて取得します。

パラメータ:
roleIds - ロールIDの配列
戻り値:
アクセスコントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerIdsByUser

public String[] getControllerIdsByUser(String userId,
                                       Date date)
                                throws AccessSecurityException
指定されたユーザIDおよび日付で有効なアクセスコントローラIDをすべて取得します。

パラメータ:
userId - ユーザID
date - 日付
戻り値:
アクセスコントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerPosts

public PostInfo[] getControllerPosts(String controllerId)
                              throws AccessSecurityException
アクセスコントローラに紐付いた役職の一覧を取得します。

パラメータ:
controllerId - アクセスコントローラID
戻り値:
役職情報の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getControllerPublicGroups

public PublicGroupInfo[] getControllerPublicGroups(String controllerId)
                                            throws AccessSecurityException
アクセスコントローラに紐付いたパブリックグループの一覧を取得します。

パラメータ:
controllerId - アクセスコントローラID
戻り値:
パブリックグループの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getControllerRoles

public String[] getControllerRoles(String controllerId)
                            throws AccessSecurityException
アクセスコントローラに紐付いたロールの一覧を取得します。

パラメータ:
controllerId - アクセスコントローラID
戻り値:
ロールIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getControllers

public AccessController[] getControllers()
                                  throws AccessSecurityException
すべてのアクセスコントローラを取得します。

戻り値:
アクセスコントローラ情報の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getExportCategories

public String[] getExportCategories()
                             throws AccessSecurityException
アクセスコントローラエクスポート用のカテゴリの一覧を取得します。

戻り値:
アクセスコントローラエクスポート用カテゴリの一覧
例外:
AccessSecurityException - アクセスコントローラエクスポート用のカテゴリの取得に失敗した場合にスローされます。

getImportCategories

public String[] getImportCategories()
                             throws AccessSecurityException
アクセスコントローラインポート用のカテゴリの一覧を取得します。

戻り値:
アクセスコントローラインポート用カテゴリの一覧
例外:
AccessSecurityException - アクセスコントローラインポート用のカテゴリの取得に失敗した場合にスローされます。

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

戻り値:
ログイングループID

importData

public void importData(String category,
                       InputStream inputStream)
                throws AccessSecurityException
/** アクセスコントローラ情報をインポートします。

パラメータ:
category - カテゴリ
inputStream - 入力ストリーム
例外:
AccessSecurityException - インポートに失敗した場合、または引数が不正だった場合にスローされます。

updateController

public void updateController(AccessController controller)
                      throws AccessSecurityException
アクセスコントローラを更新します。

パラメータ:
controller - アクセスコントローラ情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

isUpdate

public boolean isUpdate(Date date)
                 throws AccessSecurityException
アクセスコントローラが指定された日付よりも新しいかチェックします。

パラメータ:
date - チェック日付
例外:
AccessSecurityReadException - 更新チェックに失敗した場合スローされます。
AccessSecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerPostWriterListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.access
インタフェース AccessControllerPostWriterListener

public interface AccessControllerPostWriterListener

アクセスコントローラ情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
6.1
バージョン:
1.0
関連項目:
AccessControllerManager

メソッドの概要
void | init(Map params) アクセスコントローラリスナーの初期化。
void | postCreate(String groupId, AccessController controller) アクセスコントローラ情報をデータストアに作成した直後にコールされます。
void | postDelete(String groupId, String controllerId) アクセスコントローラ情報をデータストアから削除した直後にコールされます。
void | postUpdate(String groupId, AccessController controller) アクセスコントローラ情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
アクセスコントローラリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreate

public void postCreate(String groupId,
                       AccessController controller)
                throws AccessSecurityListenerExcpetion
アクセスコントローラ情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
controller - 作成されたアクセスコントローラ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDelete

public void postDelete(String groupId,
                       String controllerId)
                throws AccessSecurityListenerExcpetion
アクセスコントローラ情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
controllerId - 削除されたアクセスコントローラID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdate

public void postUpdate(String groupId,
                       AccessController controller)
                throws AccessSecurityListenerExcpetion
アクセスコントローラ情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
controller - 更新されたアクセスコントローラ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerQueryWriterListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.access
インタフェース AccessControllerQueryWriterListener

public interface AccessControllerQueryWriterListener

アクセスコントローラ情報書き込み時（書き込む直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
6.1
バージョン:
1.0
関連項目:
AccessControllerManager

メソッドの概要
void | init(Map params) アクセスコントローラリスナーの初期化。
void | queryCreate(String groupId, AccessController controller) アクセスコントローラ情報をデータストアに作成する直前にコールされます。
void | queryDelete(String groupId, String controllerId) アクセスコントローラ情報をデータストアから削除する直前にコールされます。
void | queryUpdate(String groupId, AccessController controller) アクセスコントローラ情報をデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
アクセスコントローラリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreate

public void queryCreate(String groupId,
                        AccessController controller)
                 throws AccessSecurityListenerExcpetion
アクセスコントローラ情報をデータストアに作成する直前にコールされます。

パラメータ:
groupId - ログイングループID
controller - 作成されるアクセスコントローラ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDelete

public void queryDelete(String groupId,
                        String controllerId)
                 throws AccessSecurityListenerExcpetion
アクセスコントローラ情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
controllerId - 削除されるアクセスコントローラID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdate

public void queryUpdate(String groupId,
                        AccessController controller)
                 throws AccessSecurityListenerExcpetion
アクセスコントローラ情報をデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
controller - 更新されるアクセスコントローラ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerReaderDecorator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.access
インタフェース AccessControllerReaderDecorator

public interface AccessControllerReaderDecorator

アクセスコントローラ情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
AccessController | doDecoration(String groupId, AccessController controller) アクセスコントローラデータストアからの読み込み直後にコールされます。
void | init(Map params) アクセスコントローラデコレータの初期化。

メソッドの詳細

init

public void init(Map params)
アクセスコントローラデコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public AccessController doDecoration(String groupId,
                                     AccessController controller)
アクセスコントローラデータストアからの読み込み直後にコールされます。

パラメータ:
groupId - ログイングループID
controller - 読み込みが行われたアクセスコントローラ情報
戻り値:
拡張されたアクセスコントローラ情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyChangedControllerListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.access
クラス CompanyChangedControllerListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener
すべての実装インタフェース:
CompanyChangedListener
public class CompanyChangedControllerListener
extends Object
implements CompanyChangedListener

会社・組織・役職が削除された場合にアクセスコントローラに紐付く会社・組織・役職を削除するリスナークラスです。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
CompanyChangedControllerListener()
メソッドの概要
void | categoryDetailRemoved(String groupId, CompanyCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | categoryDetailSet(String groupId, CompanyCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | companyAdded(String groupId, Company company) 会社情報がデータストアに登録された後に呼び出されます。
void | companyDeleted(String groupId, Company company) 会社情報がデータストアから削除された後に呼び出されます。
void | departmentAdded(String groupId, Department department) 組織情報がデータストアに登録された後に呼び出されます。
void | departmentDeleted(String groupId, Department department) 組織情報がデータストアに更新された後に呼び出されます。
void | departmentJoined(String groupId, String company, String parentDepartment, String department, String version) 組織構成がデータストアに登録された後に呼び出されます。
void | departmentLeft(String groupId, String company, String department, String version) 組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
void | departmentMoved(String groupId, String company, String parentDepartment, String department, String version) 組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
void | departmentUpdated(String groupId, Department department) 組織情報がデータストアから削除された後に呼び出されます。
void | init(Map params) 会社リスナーの初期化を行います。
void | mainRemoved(String groupId, DepartmentMain main) 主所属情報がデータストアから削除された後に呼び出されます。
void | mainSet(String groupId, DepartmentMain main) 主所属情報がデータストアに登録された後に呼び出されます。
void | memberDeleted(String groupId, DepartmentAttach attach) 組織からの人員の割当がデータストアから削除された後に呼び出されます。
void | memberSet(String groupId, DepartmentAttach attach) 組織への人員の割当がデータストアに登録された後に呼び出されます。
void | postAdded(String groupId, CompanyPost post) 役職情報がデータストアに登録された後に呼び出されます。
void | postDeleted(String groupId, CompanyPost post) 役職情報がデータストアから削除された後に呼び出されます。
void | postUpdated(String groupId, CompanyPost post) 役職情報がデータストアに更新された後に呼び出されます。
void | setUserId(String userId) ログインユーザIDを設定します。
void | versionAdded(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに登録された後に呼び出されます。
void | versionCopied(String groupId, String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
void | versionDeleted(String groupId, CompanyVersion version) 会社構成バージョンがデータストアから削除された後に呼び出されます。
void | versionUpdated(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに更新された後に呼び出されます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyChangedControllerListener

public CompanyChangedControllerListener()
メソッドの詳細

init

public void init(Map params)
会社リスナーの初期化を行います。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース CompanyChangedListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

setUserId

public void setUserId(String userId)
ログインユーザIDを設定します。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース CompanyChangedListener 内の setUserId
パラメータ:
userId - ログインユーザID

companyAdded

public void companyAdded(String groupId,
                         Company company)
                  throws ChangedListenerException
会社情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の companyAdded
パラメータ:
groupId - ログイングループID
company - 会社情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

companyDeleted

public void companyDeleted(String groupId,
                           Company company)
                    throws ChangedListenerException
会社情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の companyDeleted
パラメータ:
groupId - ログイングループID
company - 会社情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentAdded

public void departmentAdded(String groupId,
                            Department department)
                     throws ChangedListenerException
組織情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentAdded
パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentUpdated

public void departmentUpdated(String groupId,
                              Department department)
                       throws ChangedListenerException
組織情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentUpdated
パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentDeleted

public void departmentDeleted(String groupId,
                              Department department)
                       throws ChangedListenerException
組織情報がデータストアに更新された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentDeleted
パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentJoined

public void departmentJoined(String groupId,
                             String company,
                             String parentDepartment,
                             String department,
                             String version)
                      throws ChangedListenerException
組織構成がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentJoined
パラメータ:
groupId - ログイングループID
company - 会社コード
parentDepartment - 新規登録する組織の上位となる組織の組織コード（または会社の会社コード）
department - 組織情報（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentMoved

public void departmentMoved(String groupId,
                            String company,
                            String parentDepartment,
                            String department,
                            String version)
                     throws ChangedListenerException
組織構成からの組織の移動がデータストアに反映された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentMoved
パラメータ:
groupId - ログイングループID
company - 上位組織と移動対象の組織が所属する会社の会社コード
parentDepartment - 上位組織の組織コード（または会社の会社コード）
department - 移動する組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentLeft

public void departmentLeft(String groupId,
                           String company,
                           String department,
                           String version)
                    throws ChangedListenerException
組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentLeft
パラメータ:
groupId - ログイングループID
company - 会社コード
department - 離脱させる組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailSet

public void categoryDetailSet(String groupId,
                              CompanyCategory category)
                       throws ChangedListenerException
分類区分情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の categoryDetailSet
パラメータ:
groupId - ログイングループID
category - 登録された分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailRemoved

public void categoryDetailRemoved(String groupId,
                                  CompanyCategory category)
                           throws ChangedListenerException
分類区分情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の categoryDetailRemoved
パラメータ:
groupId - ログイングループID
category - 削除された分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberSet

public void memberSet(String groupId,
                      DepartmentAttach attach)
               throws ChangedListenerException
組織への人員の割当がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の memberSet
パラメータ:
groupId - ログイングループID
attach - 割当られた人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberDeleted

public void memberDeleted(String groupId,
                          DepartmentAttach attach)
                   throws ChangedListenerException
組織からの人員の割当がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の memberDeleted
パラメータ:
groupId - ログイングループID
attach - 組織から外された人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

mainSet

public void mainSet(String groupId,
                    DepartmentMain main)
             throws ChangedListenerException
主所属情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の mainSet
パラメータ:
groupId - ログイングループID
main - 主所属情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

mainRemoved

public void mainRemoved(String groupId,
                        DepartmentMain main)
                 throws ChangedListenerException
主所属情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の mainRemoved
パラメータ:
groupId - ログイングループID
main - 主所属情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionAdded

public void versionAdded(String groupId,
                         CompanyVersion version)
                  throws ChangedListenerException
会社構成バージョンがデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の versionAdded
パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionUpdated

public void versionUpdated(String groupId,
                           CompanyVersion version)
                    throws ChangedListenerException
会社構成バージョンがデータストアに更新された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の versionUpdated
パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionDeleted

public void versionDeleted(String groupId,
                           CompanyVersion version)
                    throws ChangedListenerException
会社構成バージョンがデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の versionDeleted
パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionCopied

public void versionCopied(String groupId,
                          String company,
                          String srcVersion,
                          String destVersion,
                          Term term)
                   throws ChangedListenerException
登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の versionCopied
パラメータ:
groupId - ログイングループID
company - コピー元、コピー先の会社構成バージョンの会社コード
srcVersion - コピー元の会社構成バージョンのバージョンコード
destVersion - コピー先の会社構成バージョンのバージョンコード
term - コピー先の会社構成バージョンの期間
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

postAdded

public void postAdded(String groupId,
                      CompanyPost post)
               throws ChangedListenerException
役職情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の postAdded
パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

postUpdated

public void postUpdated(String groupId,
                        CompanyPost post)
                 throws ChangedListenerException
役職情報がデータストアに更新された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の postUpdated
パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

postDeleted

public void postDeleted(String groupId,
                        CompanyPost post)
                 throws ChangedListenerException
役職情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の postDeleted
パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.access (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.security.access
インタフェース
AccessControllerAccessor
AccessControllerExporter
AccessControllerImporter
AccessControllerPostWriterListener
AccessControllerQueryWriterListener
AccessControllerReaderDecorator
クラス
AccessController
AccessControllerManager
CompanyChangedControllerListener
PublicGroupChangedControllerListener
RoleChangedControllerListener
StandardAccessControllerBackup


jp.co.intra_mart.foundation.security.access (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.access

インタフェースの概要
AccessControllerAccessor | アクセスコントローラアクセッサインタフェース。
AccessControllerExporter | アクセスコントローラエクスポートインタフェースです。
AccessControllerImporter | アクセスコントローラインポートインタフェースです。
AccessControllerPostWriterListener | アクセスコントローラ情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AccessControllerQueryWriterListener | アクセスコントローラ情報書き込み時（書き込む直前）のリスナ・インターフェースを定義します。
AccessControllerReaderDecorator | アクセスコントローラ情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

クラスの概要
AccessController | アクセスコントローラ・モデルクラス。
AccessControllerManager | アクセスコントローラマネージャクラス。
CompanyChangedControllerListener | 会社・組織・役職が削除された場合にアクセスコントローラに紐付く会社・組織・役職を削除するリスナークラスです。
PublicGroupChangedControllerListener | パブリックグループが削除された場合にアクセスコントローラに紐付くパブリックグループを削除するリスナークラスです。
RoleChangedControllerListener | ロールが削除された場合にアクセスコントローラに紐付くロールを削除するリスナークラスです。
StandardAccessControllerBackup |


jp.co.intra_mart.foundation.security.access クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.access の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.access.AccessController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.access.AccessControllerManager
    • class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener)
    • class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener (implements jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener)
    • class jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener (implements jp.co.intra_mart.foundation.security.role.RoleChangedListener)
    • class jp.co.intra_mart.foundation.security.access.StandardAccessControllerBackup (implements jp.co.intra_mart.foundation.security.access.AccessControllerExporter, jp.co.intra_mart.foundation.security.access.AccessControllerImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor
  • interface jp.co.intra_mart.foundation.security.access.AccessControllerExporter
  • interface jp.co.intra_mart.foundation.security.access.AccessControllerImporter
  • interface jp.co.intra_mart.foundation.security.access.AccessControllerPostWriterListener
  • interface jp.co.intra_mart.foundation.security.access.AccessControllerQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.access.AccessControllerReaderDecorator


パッケージ jp.co.intra_mart.foundation.security.access の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.access の使用

jp.co.intra_mart.foundation.security.access を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |

jp.co.intra_mart.foundation.security により使用される jp.co.intra_mart.foundation.security.access のクラス
AccessController
アクセスコントローラ・モデルクラス。
AccessControllerAccessor
アクセスコントローラアクセッサインタフェース。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.security.access のクラス
AccessController
アクセスコントローラ・モデルクラス。
AccessControllerExporter
アクセスコントローラエクスポートインタフェースです。
AccessControllerImporter
アクセスコントローラインポートインタフェースです。
AccessControllerManager
アクセスコントローラマネージャクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupChangedControllerListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.access
クラス PublicGroupChangedControllerListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener
すべての実装インタフェース:
PublicGroupChangedListener
public class PublicGroupChangedControllerListener
extends Object
implements PublicGroupChangedListener

パブリックグループが削除された場合にアクセスコントローラに紐付くパブリックグループを削除するリスナークラスです。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
PublicGroupChangedControllerListener()
メソッドの概要
void | categoryDetailRemoved(String groupId, PublicGroupCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | categoryDetailSet(String groupId, PublicGroupCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | groupSetAdded(String groupId, PublicGroupSet groupSet) グループセットがデータストアに登録された後に呼び出されます。
void | groupSetDeleted(String groupId, PublicGroupSet groupSet) グループセットがデータストアから削除された後に呼び出されます。
void | init(Map params) アカウントリスナーの初期化を行います。
void | memberDeleted(String groupId, PublicGroupAttach attach) パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
void | memberSet(String groupId, PublicGroupAttach attach) パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
void | publicGroupAdded(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに登録された後に呼び出されます。
void | publicGroupDeleted(String groupId, PublicGroup publicGroup) パブリックグループがデータストアから削除された後に呼び出されます。
void | publicGroupJoined(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
void | publicGroupLeft(String groupId, String groupSet, String publicGroup, String version) パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
void | publicGroupMoved(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
void | publicGroupUpdated(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに更新された後に呼び出されます。
void | setUesrId(String userid) ログインユーザIDを設定します。
void | versionAdded(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
void | versionCopied(String groupId, String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
void | versionDeleted(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
void | versionUpdated(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupChangedControllerListener

public PublicGroupChangedControllerListener()
メソッドの詳細

init

public void init(Map params)
アカウントリスナーの初期化を行います。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

setUesrId

public void setUesrId(String userid)
ログインユーザIDを設定します。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の setUesrId
パラメータ:
userid - ログインユーザID

groupSetAdded

public void groupSetAdded(String groupId,
                          PublicGroupSet groupSet)
                   throws ChangedListenerException
グループセットがデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の groupSetAdded
パラメータ:
groupId - ログイングループID
groupSet - グループセット
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

groupSetDeleted

public void groupSetDeleted(String groupId,
                            PublicGroupSet groupSet)
                     throws ChangedListenerException
グループセットがデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の groupSetDeleted
パラメータ:
groupId - ログイングループID
groupSet - グループセット
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupAdded

public void publicGroupAdded(String groupId,
                             PublicGroup publicGroup)
                      throws ChangedListenerException
パブリックグループがデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupAdded
パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupUpdated

public void publicGroupUpdated(String groupId,
                               PublicGroup publicGroup)
                        throws ChangedListenerException
パブリックグループがデータストアに更新された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupUpdated
パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupDeleted

public void publicGroupDeleted(String groupId,
                               PublicGroup publicGroup)
                        throws ChangedListenerException
パブリックグループがデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupDeleted
パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupJoined

public void publicGroupJoined(String groupId,
                              String groupSet,
                              String parentGroup,
                              String publicGroup,
                              String version)
                       throws ChangedListenerException
パブリックグループ構成情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupJoined
パラメータ:
groupId - ログイングループID
groupSet - 上位パブリックグループと新規登録されるパブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup - 新規登録するパブリックグループの上位となるパブリックグループのグループコード（またはパブリックグループセットのグループセットコード）
publicGroup - パブリックグループ情報（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupMoved

public void publicGroupMoved(String groupId,
                             String groupSet,
                             String parentGroup,
                             String publicGroup,
                             String version)
                      throws ChangedListenerException
パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupMoved
パラメータ:
groupId - ログイングループID
groupSet - 上位パブリックグループと移動対象のパブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup - 上位パブリックグループのグループコード（またはパブリックグループセットのグループセットコード）
publicGroup - 移動するパブリックグループのグループコード（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupLeft

public void publicGroupLeft(String groupId,
                            String groupSet,
                            String publicGroup,
                            String version)
                     throws ChangedListenerException
パブリックグループ構成情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupLeft
パラメータ:
groupId - ログイングループID
groupSet - グループセットコード
publicGroup - 離脱させるパブリックグループのグループコード（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailSet

public void categoryDetailSet(String groupId,
                              PublicGroupCategory category)
                       throws ChangedListenerException
分類区分情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の categoryDetailSet
パラメータ:
groupId - ログイングループID
category - 分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailRemoved

public void categoryDetailRemoved(String groupId,
                                  PublicGroupCategory category)
                           throws ChangedListenerException
分類区分情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の categoryDetailRemoved
パラメータ:
groupId - ログイングループID
category - 分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberSet

public void memberSet(String groupId,
                      PublicGroupAttach attach)
               throws ChangedListenerException
パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の memberSet
パラメータ:
groupId - ログイングループID
attach - 割当られた人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberDeleted

public void memberDeleted(String groupId,
                          PublicGroupAttach attach)
                   throws ChangedListenerException
パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の memberDeleted
パラメータ:
groupId - ログイングループID
attach - パブリックグループから外された人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionAdded

public void versionAdded(String groupId,
                         PublicGroupVersion version)
                  throws ChangedListenerException
パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の versionAdded
パラメータ:
groupId - ログイングループID
version - パブリックグループ構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionUpdated

public void versionUpdated(String groupId,
                           PublicGroupVersion version)
                    throws ChangedListenerException
パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の versionUpdated
パラメータ:
groupId - ログイングループID
version - パブリックグループセット構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionDeleted

public void versionDeleted(String groupId,
                           PublicGroupVersion version)
                    throws ChangedListenerException
パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の versionDeleted
パラメータ:
groupId - ログイングループID
version - パブリックグループセット構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionCopied

public void versionCopied(String groupId,
                          String groupSet,
                          String srcVersion,
                          String destVersion,
                          Term term)
                   throws ChangedListenerException
登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の versionCopied
パラメータ:
groupId - ログイングループID
groupSet - コピー元、コピー先のパブリックグループセット構成バージョンのパブリックグループコード
srcVersion - コピー元のパブリックグループセット構成バージョンのバージョンコード
destVersion - コピー先のパブリックグループセット構成バージョンのバージョンコード
term - コピー先のパブリックグループセット構成バージョンの期間
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleChangedControllerListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.access
クラス RoleChangedControllerListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener
すべての実装インタフェース:
RoleChangedListener
public class RoleChangedControllerListener
extends Object
implements RoleChangedListener

ロールが削除された場合にアクセスコントローラに紐付くロールを削除するリスナークラスです。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
RoleChangedControllerListener()
コンストラクタ。
メソッドの概要
void | init(Map params) ロールリスナーの初期化。
void | roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | roleDeleted(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | subRoleAdded(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | subRoleDeleted(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RoleChangedControllerListener

public RoleChangedControllerListener()
コンストラクタ。

メソッドの詳細

init

public void init(Map params)
ロールリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース RoleChangedListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

roleAdded

public void roleAdded(String groupId,
                      Role role)
               throws ChangedListenerException
ロール情報をデータストアに作成した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の roleAdded
パラメータ:
groupId - ログイングループID
role - 作成されたロール
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

roleDeleted

public void roleDeleted(String groupId,
                        String roleId)
                 throws ChangedListenerException
ロール情報をデータストアから削除した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の roleDeleted
パラメータ:
groupId - ログイングループID
roleId - 削除されたロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

roleUpdated

public void roleUpdated(String groupId,
                        Role role)
                 throws ChangedListenerException
ロール情報をデータストアに更新した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の roleUpdated
パラメータ:
groupId - ログイングループID
role - 更新されたロール
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

subRoleAdded

public void subRoleAdded(String groupId,
                         String roleId,
                         String subRoleId)
                  throws ChangedListenerException
ロールにサブロールを追加した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の subRoleAdded
パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 追加されたサブロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

subRoleDeleted

public void subRoleDeleted(String groupId,
                           String roleId,
                           String subRoleId)
                    throws ChangedListenerException
ロールからサブロールを削除した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の subRoleDeleted
パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 削除されたサブロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardAccessControllerBackup (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.access
クラス StandardAccessControllerBackup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.access.StandardAccessControllerBackup
すべての実装インタフェース:
AccessControllerExporter, AccessControllerImporter
public class StandardAccessControllerBackup
extends Object
implements AccessControllerImporter, AccessControllerExporter

コンストラクタの概要
StandardAccessControllerBackup()
メソッドの概要
void | doExport(AccessControllerManager manager, OutputStream outputStream) エクスポートを行います。
void | doImport(InputStream inputStream, AccessControllerManager manager) インポートを行います。
void | init(Map params) 初期化。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardAccessControllerBackup

public StandardAccessControllerBackup()
メソッドの詳細

init

public void init(Map params)
初期化。

初期化します。

定義:
インタフェース AccessControllerImporter 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     AccessControllerManager manager)
              throws AccessSecurityImportException
インタフェース AccessControllerImporter の記述:
インポートを行います。

ストリーム内の情報からアクセスコントローラ情報を取得し、生成します。

定義:
インタフェース AccessControllerImporter 内の doImport
パラメータ:
manager - アクセスコントローラマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

doExport

public void doExport(AccessControllerManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
インタフェース AccessControllerExporter の記述:
エクスポートを行います。

アクセスコントローラ情報をバックアップファイルに出力します。

定義:
インタフェース AccessControllerExporter 内の doExport
パラメータ:
manager - アクセスコントローラマネージャ
outputStream - 出力ストリーム
例外:
AccessSecurityExportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.account.Account の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.account.Account の使用

Account を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession |
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification.ldap.extension | ユーザログインLDAP認証クラス(複数OU対応版)の設定方法。
jp.co.intra_mart.foundation.security.mobile |
jp.co.intra_mart.foundation.security.password |

jp.co.intra_mart.foundation.security での Account の使用

Account を返す jp.co.intra_mart.foundation.security のメソッド
Account | StandardAccountAccessor.getAccount(String groupId, String userId) アカウント情報を取得する。
Account[] | StandardAccountAccessor.getAccountsByUserIds(String groupId, String[] userIds) 指定されたユーザIDのアカウント情報をすべて取得する。
Account[] | StandardAccountAccessor.searchAccounts(String groupId, String userId) アカウント情報の読み込みます。

Account 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | StandardAccountAccessor.insertAccount(String groupId, Account account) アカウント情報を新規追加する。
void | StandardAccountAccessor.updateAccount(String groupId, Account account) アカウント情報を更新する。

jp.co.intra_mart.foundation.security.account での Account の使用

Account を返す jp.co.intra_mart.foundation.security.account のメソッド
Account | AccountReaderDecorator.doDecoration(String groupId, Account account) アカウントをデータストアからの読み込み直後にコールされます。
Account | AccountManager.getAccount(String userId) ユーザIDにマッチしたユーザデータを１件取得します。
Account[] | AccountManager.getAccounts() ログイングループ内のすべてのユーザアカウントを取得します。
Account[] | AccountManager.getAccountsByUserIds(String[] userIds) ログイングループ内で引数指定したユーザIDのユーザアカウントをすべて取得します。
Account[] | AccountManager.searchAccounts(String userId) ユーザIDを検索してマッチしたアカウントを配列で返します。
Account | AccountAccessor.getAccount(String groupId, String userId) アカウント情報を取得する。
Account[] | AccountAccessor.getAccountsByUserIds(String groupId, String[] userIds) 指定されたユーザIDのアカウント情報をすべて取得する。
Account[] | AccountAccessor.searchAccounts(String groupId, String userId) アカウント情報の読み込みます。
protected Account[] | StandardAccountBackup.getAllAccounts(String groupId)
protected Account[] | CsvAccountBackup.getAllAccounts(String groupId)

Account 型のパラメータを持つ jp.co.intra_mart.foundation.security.account のメソッド
Account | AccountReaderDecorator.doDecoration(String groupId, Account account) アカウントをデータストアからの読み込み直後にコールされます。
void | AccountQueryWriterListener.queryCreateAccount(String groupId, Account account) アカウント情報をデータストアに作成する直前にコールされます。
void | AccountQueryWriterListener.queryUpdateAccount(String groupId, Account account) アカウント情報をデータストアに更新する直前にコールされます。
void | AccountPostWriterListener.postCreateAccount(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | AccountPostWriterListener.postUpdateAccount(String groupId, Account account) アカウント情報をデータストアに更新した直後にコールされます。
void | AccountManager.addAccount(Account account) アカウントを新規追加します。
void | AccountManager.updateAccount(Account account) アカウントを更新します。
void | AccountChangedListener.accountAdded(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | AccountChangedListener.accountUpdated(String groupId, Account account) アカウント情報をデータストアに更新した直後にコールされます。
void | AccountAccessor.insertAccount(String groupId, Account account) アカウント情報を新規追加する。
void | AccountAccessor.updateAccount(String groupId, Account account) アカウント情報を更新する。

jp.co.intra_mart.foundation.security.activesession での Account の使用

Account 型のパラメータを持つ jp.co.intra_mart.foundation.security.activesession のメソッド
 void UserActiveSessionRegister.doCertification(int certificationResult, LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response)
ユーザの認証後にコールされるメソッドです。

jp.co.intra_mart.foundation.security.certification での Account の使用

Account 型のパラメータを持つ jp.co.intra_mart.foundation.security.certification のメソッド
void | UserCertificationListener.doCertification(int certificationResult, LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザの認証後にコールされるメソッドです。
int | UserCertification.certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証する。
int | StandardUserCertification.certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証します。
int | LDAPUserCertification.certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証する。

jp.co.intra_mart.foundation.security.certification.ldap.extension での Account の使用

Account 型のパラメータを持つ jp.co.intra_mart.foundation.security.certification.ldap.extension のメソッド
 int LDAPUserCertification.certification(LoginInfo loginInfo, Account account, HttpServletRequest req, HttpServletResponse resp)
LDAPに対してユーザを認証します。

jp.co.intra_mart.foundation.security.mobile での Account の使用

Account 型のパラメータを持つ jp.co.intra_mart.foundation.security.mobile のメソッド
void | NonceResetListener4MobileEasyLogin.queryUpdateAccount(String groupId, Account account)
void | NonceResetListener4MobileEasyLogin.postUpdateAccount(String groupId, Account account)
void | NonceResetListener4MobileEasyLogin.queryCreateAccount(String groupId, Account account)
void | NonceResetListener4MobileEasyLogin.postCreateAccount(String groupId, Account account)

jp.co.intra_mart.foundation.security.password での Account の使用

Account 型のパラメータを持つ jp.co.intra_mart.foundation.security.password のメソッド
void | PasswordHistoryAccountChangedListener.accountAdded(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | PasswordHistoryAccountChangedListener.accountUpdated(String groupId, Account account) アカウント情報をデータストアに更新した直後にコールされます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.account.AccountAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.account.AccountAccessor の使用

AccountAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での AccountAccessor の使用

AccountAccessor を実装している jp.co.intra_mart.foundation.security のクラス
 class StandardAccountAccessor
アカウントアクセッサクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.account.AccountChangedListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.account.AccountChangedListener の使用

AccountChangedListener を使用しているパッケージ
jp.co.intra_mart.foundation.security.password

jp.co.intra_mart.foundation.security.password での AccountChangedListener の使用

AccountChangedListener を実装している jp.co.intra_mart.foundation.security.password のクラス
 class PasswordHistoryAccountChangedListener
アカウント情報変更リスナー(パスワード履歴管理)。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.account.AccountExporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.account.AccountExporter の使用

AccountExporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.account アカウントに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.account での AccountExporter の使用

AccountExporter を実装している jp.co.intra_mart.foundation.security.account のクラス
class | CsvAccountBackup CSVアカウントバックアップクラスです。
class | StandardAccountBackup アカウント情報をインポート・エクスポートするクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.account.AccountImporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.account.AccountImporter の使用

AccountImporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.account アカウントに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.account での AccountImporter の使用

AccountImporter を実装している jp.co.intra_mart.foundation.security.account のクラス
class | CsvAccountBackup CSVアカウントバックアップクラスです。
class | StandardAccountBackup アカウント情報をインポート・エクスポートするクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.account.AccountManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.account.AccountManager の使用

AccountManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.account アカウントに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.account での AccountManager の使用

AccountManager 型のパラメータを持つ jp.co.intra_mart.foundation.security.account のメソッド
void | AccountImporter.doImport(InputStream inputStream, AccountManager manager) インポートを行います。
void | AccountExporter.doExport(AccountManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardAccountBackup.doImport(InputStream inputStream, AccountManager manager) インポートを行います。
void | StandardAccountBackup.doExport(AccountManager manager, OutputStream outputStream) エクスポートを行います。
void | CsvAccountBackup.doImport(InputStream inputStream, AccountManager manager) インポートを行います。
void | CsvAccountBackup.doExport(AccountManager manager, OutputStream outputStream) エクスポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.account.AccountPostWriterListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.account.AccountPostWriterListener の使用

AccountPostWriterListener を使用しているパッケージ
jp.co.intra_mart.foundation.security.mobile

jp.co.intra_mart.foundation.security.mobile での AccountPostWriterListener の使用

AccountPostWriterListener を実装している jp.co.intra_mart.foundation.security.mobile のクラス
 class NonceResetListener4MobileEasyLogin
かんたんログイン用のNonceを再設定する為のリスナーです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener の使用

AccountQueryWriterListener を使用しているパッケージ
jp.co.intra_mart.foundation.security.mobile

jp.co.intra_mart.foundation.security.mobile での AccountQueryWriterListener の使用

AccountQueryWriterListener を実装している jp.co.intra_mart.foundation.security.mobile のクラス
 class NonceResetListener4MobileEasyLogin
かんたんログイン用のNonceを再設定する為のリスナーです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.account.AccountReaderDecorator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.account.AccountReaderDecorator の使用

jp.co.intra_mart.foundation.security.account.AccountReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.account.AccountRole の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.account.AccountRole の使用

AccountRole を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.mobile |
jp.co.intra_mart.foundation.security.password |

jp.co.intra_mart.foundation.security での AccountRole の使用

AccountRole を返す jp.co.intra_mart.foundation.security のメソッド
AccountRole | StandardAccountAccessor.getAccountRole(String groupId, String userId, String roleId) アカウントロール情報を取得する。
AccountRole[] | StandardAccountAccessor.getAccountRoles(String groupId, String userId) アカウントロール情報をすべて取得する。

AccountRole 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | StandardAccountAccessor.insertAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を新規追加する。
void | StandardAccountAccessor.updateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を更新する。

jp.co.intra_mart.foundation.security.account での AccountRole の使用

AccountRole を返す jp.co.intra_mart.foundation.security.account のメソッド
AccountRole[] | AccountManager.getAccountRoles(String userId) アカウントロールをすべて取得します。
AccountRole[] | AccountManager.getAccountRoles(String userId, Date date) 有効期間内のアカウントロールをすべて取得します。
AccountRole | AccountAccessor.getAccountRole(String groupId, String userId, String roleId) アカウントロール情報を取得する。
AccountRole[] | AccountAccessor.getAccountRoles(String groupId, String userId) アカウントロール情報をすべて取得する。

AccountRole 型のパラメータを持つ jp.co.intra_mart.foundation.security.account のメソッド
void | AccountQueryWriterListener.queryCreateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | AccountQueryWriterListener.queryUpdateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新する直前にコールされます。
void | AccountPostWriterListener.postCreateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | AccountPostWriterListener.postUpdateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新した直後にコールされます。
void | AccountManager.addAccountRole(String userId, AccountRole accountRole) アカウントロールを新規追加します。
void | AccountManager.updateAccountRole(String userId, AccountRole accountRole) アカウントロールを更新します。
void | AccountChangedListener.accountRoleAdded(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | AccountChangedListener.accountRoleUpdated(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新した直後にコールされます。
void | AccountAccessor.insertAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を新規追加する。
void | AccountAccessor.updateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を更新する。

jp.co.intra_mart.foundation.security.mobile での AccountRole の使用

AccountRole 型のパラメータを持つ jp.co.intra_mart.foundation.security.mobile のメソッド
void | NonceResetListener4MobileEasyLogin.queryCreateAccountRole(String groupId, String userId, AccountRole accountRole)
void | NonceResetListener4MobileEasyLogin.queryUpdateAccountRole(String groupId, String userId, AccountRole accountRole)
void | NonceResetListener4MobileEasyLogin.postCreateAccountRole(String groupId, String userId, AccountRole accountRole)
void | NonceResetListener4MobileEasyLogin.postUpdateAccountRole(String groupId, String userId, AccountRole accountRole)

jp.co.intra_mart.foundation.security.password での AccountRole の使用

AccountRole 型のパラメータを持つ jp.co.intra_mart.foundation.security.password のメソッド
void | PasswordHistoryAccountChangedListener.accountRoleAdded(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | PasswordHistoryAccountChangedListener.accountRoleUpdated(String grouId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新した直後にコールされます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.account.CsvAccountBackup の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.account.CsvAccountBackup の使用

jp.co.intra_mart.foundation.security.account.CsvAccountBackup はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.account.FavoriteMenu の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.account.FavoriteMenu の使用

FavoriteMenu を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.mobile |

jp.co.intra_mart.foundation.security での FavoriteMenu の使用

FavoriteMenu を返す jp.co.intra_mart.foundation.security のメソッド
FavoriteMenu | StandardAccountAccessor.getFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を取得する。
FavoriteMenu[] | StandardAccountAccessor.getFavoriteMenus(String groupId, String userId) マイメニュー情報をすべて取得する。

FavoriteMenu 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | StandardAccountAccessor.insertFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を新規追加する。
void | StandardAccountAccessor.updateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を更新する。

jp.co.intra_mart.foundation.security.account での FavoriteMenu の使用

FavoriteMenu を返す jp.co.intra_mart.foundation.security.account のメソッド
FavoriteMenu[] | AccountManager.getFavoriteMenus(String userId) マイメニューをすべて取得します。
FavoriteMenu | AccountAccessor.getFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を取得する。
FavoriteMenu[] | AccountAccessor.getFavoriteMenus(String groupId, String userId) マイメニュー情報をすべて取得する。

FavoriteMenu 型のパラメータを持つ jp.co.intra_mart.foundation.security.account のメソッド
void | AccountQueryWriterListener.queryCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに作成する直前にコールされます。
void | AccountQueryWriterListener.queryUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに更新する直前にコールされます。
void | AccountPostWriterListener.postCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに作成した直後にコールされます。
void | AccountPostWriterListener.postUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに更新した直後にコールされます。
void | AccountManager.addFavoriteMenu(String userId, FavoriteMenu favoriteMenu) マイメニューを新規追加します。
void | AccountManager.updateFavoriteMenu(String userId, FavoriteMenu favoriteMenu) マイメニューを更新します。
void | AccountAccessor.insertFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を新規追加する。
void | AccountAccessor.updateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を更新する。

jp.co.intra_mart.foundation.security.mobile での FavoriteMenu の使用

FavoriteMenu 型のパラメータを持つ jp.co.intra_mart.foundation.security.mobile のメソッド
void | NonceResetListener4MobileEasyLogin.queryCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu)
void | NonceResetListener4MobileEasyLogin.queryUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu)
void | NonceResetListener4MobileEasyLogin.postCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu)
void | NonceResetListener4MobileEasyLogin.postUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener の使用

jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.account.StandardAccountBackup の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.account.StandardAccountBackup の使用

jp.co.intra_mart.foundation.security.account.StandardAccountBackup はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Account (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
クラス Account

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.account.Account
すべての実装インタフェース:
LocaleProvider, Serializable
public class Account
extends Object
implements LocaleProvider, Serializable

アカウントモデル。

このアカウントにが有効になる条件（ログインできる条件）は、
有効開始日 <= 日付 < 有効終了日の範囲でかつ、アカウントがライセンス登録してある場合です。
アカウントのライセンス登録については、ライセンスマネージャ( LicenseManager)を参照してください。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
AccountManager, 直列化された形式

コンストラクタの概要
Account(String userID)
コンストラクタ。
メソッドの概要
boolean | equals(Object account) オブジェクトを比較します。
String | getColorPatternId() カラーパターンIDを取得します。
String | getDescription() 説明を取得します。
String | getEncoding() エンコーディング情報を取得します。
Locale | getLocale() ロケールを取得します。
Date | getLockDate() アカウントロック日付を取得します。
int | getLoginFailureCount() ログイン失敗回数を取得します。
String | getMainPagePatternId() メインページパターンIDを取得します。
String | getMobilePassword() モバイル用パスワードを取得します。
String | getPassword() パスワードを取得します。
String | getUserId() ユーザIDを取得します。
Date | getValidEndDate() 有効終了日を取得します。
Date | getValidStartDate() 有効開始日取得。
int | hashCode() ハッシュコードを取得します。
void | increaseLoginFailureCount() ログイン失敗回数をカウントアップします。
boolean | isGoOut() 外出状態を取得します。
boolean | isLock() アカウントロック状態を取得します。
void | resetLock() アカウントロックをリセットします。
void | setColorPatternId(String colorPattrenId) カラーパターンIDを設定します。
void | setDescription(String description) 説明を設定します。
void | setEncoding(String encoding) エンコーディング情報を設定します。
void | setGoOut(boolean goOut) 外出状態を設定します。
void | setLocale(Locale locale) ロケールを設定します。
void | setLockDate(Date lockDate) アカウントロック日付を設定します。
void | setLoginFailureCount(int loginFailureCount) ログイン失敗回数を設定します。
void | setMainPagePatternId(String mainPagePatternId) メインページパターンIDを設定する。
void | setMobilePassword(String mobilePassword) モバイル用パスワードを設定します。
void | setPassword(String password) パスワードを設定します。
protected void | setUserId(String userId) ユーザIDを設定します。
void | setValidEndDate(Date endDate) 有効終了日を設定します。
void | setValidStartDate(Date startDate) 有効開始日を設定します。
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Account

public Account(String userID)
コンストラクタ。

パラメータ:
userID - ユーザID
メソッドの詳細

equals

public boolean equals(Object account)
オブジェクトを比較します。

指定されたオブジェクトとこのモデルが等しいかどうかを比較します。

パラメータ:
account - モデルと等しいかどうかを比較するオブジェクト
戻り値:
指定されたオブジェクトがこのモデルと等しい場合は true
関連項目:
Object.equals(Object)

getEncoding

public String getEncoding()
エンコーディング情報を取得します。

定義:
インタフェース LocaleProvider 内の getEncoding
戻り値:
エンコーディング情報
関連項目:
LocaleProvider.getEncoding()

getLocale

public Locale getLocale()
ロケールを取得します。

定義:
インタフェース LocaleProvider 内の getLocale
戻り値:
ロケール
関連項目:
LocaleProvider.getLocale()

getLockDate

public Date getLockDate()
アカウントロック日付を取得します。

戻り値:
ロックされている場合は、このアカウントがロックされた日付を返却します。
ロックされていない場合はnullを返却します。

getLoginFailureCount

public int getLoginFailureCount()
ログイン失敗回数を取得します。

このアカウントがログインに失敗している回数を返却します。

戻り値:
ログイン失敗回数

getMainPagePatternId

public String getMainPagePatternId()
メインページパターンIDを取得します。

戻り値:
メインページパターンID

getMobilePassword

public String getMobilePassword()
モバイル用パスワードを取得します。

戻り値:
モバイル用パスワード

getDescription

public String getDescription()
説明を取得します。

戻り値:
説明

getColorPatternId

public String getColorPatternId()
カラーパターンIDを取得します。

戻り値:
カラーパターンID

getPassword

public String getPassword()
パスワードを取得します。

戻り値:
パスワード

getUserId

public String getUserId()
ユーザIDを取得します。

戻り値:
ユーザID

getValidEndDate

public Date getValidEndDate()
有効終了日を取得します。

アカウントは有効終了日の前日まで有効となります。

戻り値:
有効終了日

getValidStartDate

public Date getValidStartDate()
有効開始日取得。

アカウントは有効開始日から有効となります。

戻り値:
有効開始日

hashCode

public int hashCode()
ハッシュコードを取得します。

戻り値:
ハッシュコード

increaseLoginFailureCount

public void increaseLoginFailureCount()
ログイン失敗回数をカウントアップします。

isGoOut

public boolean isGoOut()
外出状態を取得します。

戻り値:
外出している場合は、true

isLock

public boolean isLock()
アカウントロック状態を取得します。

戻り値:
ロックされている場合は、true

resetLock

public void resetLock()
アカウントロックをリセットします。

アカウントロックを解除し、ログイン失敗回数を０にリセットします。

setEncoding

public void setEncoding(String encoding)
エンコーディング情報を設定します。

パラメータ:
encoding - エンコーディング情報

setGoOut

public void setGoOut(boolean goOut)
外出状態を設定します。

パラメータ:
goOut - 外出している場合はtrue

setLocale

public void setLocale(Locale locale)
ロケールを設定します。

パラメータ:
locale - ロケール

setLockDate

public void setLockDate(Date lockDate)
アカウントロック日付を設定します。

パラメータ:
lockDate - 日付を設定した場合、アカウントはロックされる。 nullを設定した場合、アカウントのロックは解除される。

setLoginFailureCount

public void setLoginFailureCount(int loginFailureCount)
ログイン失敗回数を設定します。

設定できる値は0以上です。

パラメータ:
loginFailureCount - ログイン失敗回数

setMainPagePatternId

public void setMainPagePatternId(String mainPagePatternId)
メインページパターンIDを設定する。

パラメータ:
mainPagePatternId - メインページパターンID

setMobilePassword

public void setMobilePassword(String mobilePassword)
モバイル用パスワードを設定します。

パラメータ:
mobilePassword - モバイル用パスワード

setDescription

public void setDescription(String description)
説明を設定します。

パラメータ:
description - 説明

setColorPatternId

public void setColorPatternId(String colorPattrenId)
カラーパターンIDを設定します。

パラメータ:
colorPattrenId - カラーパターンID

setPassword

public void setPassword(String password)
パスワードを設定します。

パラメータ:
password - パスワード

setUserId

protected void setUserId(String userId)
ユーザIDを設定します。

パラメータ:
userId - ユーザID

setValidEndDate

public void setValidEndDate(Date endDate)
有効終了日を設定します。

設定されるのは、日付のみで、時間は00:00:00に設定されます。
有効になるのは設定された日付の前日までです。
nullを設定した場合は、最大未来日に設定されます。

パラメータ:
endDate - 有効終了日

setValidStartDate

public void setValidStartDate(Date startDate)
有効開始日を設定します。

設定されるのは、日付のみで、時間は00:00:00に設定されます。
有効になるのは設定された日付からです。
nullを設定した場合は、最大過去日に設定されます。

パラメータ:
startDate - 有効開始日
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccountAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
インタフェース AccountAccessor

既知の実装クラスの一覧:
StandardAccountAccessor
public interface AccountAccessor

アカウントアクセッサインタフェース。

アカウント情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | deleteAccount(String groupId, String userId) アカウント情報を削除する。
void | deleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報を削除する。
void | deleteAttribute(String groupId, String userId, String name) アカウント属性情報を削除する。
void | deleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を削除する。
Account | getAccount(String groupId, String userId) アカウント情報を取得する。
int | getAccountCount(String groupId) アカウント数を取得する。
AccountRole | getAccountRole(String groupId, String userId, String roleId) アカウントロール情報を取得する。
String[] | getAccountRoleIds(String groupId, String userId) アカウントロールIDをすべて取得する。
AccountRole[] | getAccountRoles(String groupId, String userId) アカウントロール情報をすべて取得する。
Account[] | getAccountsByUserIds(String groupId, String[] userIds) 指定されたユーザIDのアカウント情報をすべて取得する。
String | getAttribute(String groupId, String userId, String name) アカウント属性情報を取得する。
String[] | getAttributeNames(String groupId, String userId) アカウント属性情報の名前の一覧を取得する。
FavoriteMenu | getFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を取得する。
String[] | getFavoriteMenuIds(String groupId, String userId) マイメニューIDをすべて取得する。
FavoriteMenu[] | getFavoriteMenus(String groupId, String userId) マイメニュー情報をすべて取得する。
String[] | getUserIds(String groupId) ユーザIDの一覧を取得する。
String[] | getUserIdsByAccountRole(String groupId, String roleId) 引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
String[] | getUserIdsByAttribute(String groupId, String key, String value) アカウント属性情報の値と一致するユーザIDを取得する。
String[] | getUserIdsByRoles(String groupId, String[] roleIds, Date date) 指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
void | init(Map params) アカウントアクセッサの初期化。
void | insertAccount(String groupId, Account account) アカウント情報を新規追加する。
void | insertAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を新規追加する。
void | insertFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を新規追加する。
Account[] | searchAccounts(String groupId, String userId) アカウント情報の読み込みます。
void | setAttribute(String groupId, String userId, String name, String value) アカウント属性情報を設定する。
void | updateAccount(String groupId, Account account) アカウント情報を更新する。
void | updateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を更新する。
void | updateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を更新する。

メソッドの詳細

deleteAccount

public void deleteAccount(String groupId,
                          String userId)
                   throws AccessSecurityWriteException,
                          NotExistException
アカウント情報を削除する。

パラメータ:
groupId - ログイングループID
userId - 削除するユーザコード
例外:
AccessSecurityWriteException - アカウント情報の削除に失敗した場合スローされます。
NotExistException - 削除するアカウント情報が存在しない場合にスローされます。

deleteAccountRole

public void deleteAccountRole(String groupId,
                              String userId,
                              String roleId)
                       throws AccessSecurityWriteException,
                              NotExistException
アカウントロール情報を削除する。

アカウントに紐付くアカウントロール情報を削除します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
roleId - ロールID
例外:
AccessSecurityWriteException - アカウントロール情報の削除に失敗した場合スローされます。
NotExistException - 削除するアカウントロール情報が存在しない場合にスローされます。

deleteFavoriteMenu

public void deleteFavoriteMenu(String groupId,
                               String userId,
                               String menuId)
                        throws AccessSecurityWriteException,
                               NotExistException
マイメニュー情報を削除する。

アカウントに紐付くマイメニュー情報を削除します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
menuId - メニューID
例外:
AccessSecurityWriteException - マイメニュー情報の削除に失敗した場合スローされます。
NotExistException - 削除するマイメニュー情報が存在しない場合にスローされます。

getAccount

public Account getAccount(String groupId,
                          String userId)
                   throws AccessSecurityReadException
アカウント情報を取得する。

パラメータ:
groupId - ログイングループID
userId - ユーザIDの完全一致名
戻り値:
ユーザアカウントオブジェクト
存在しない場合は、nullを返却します。
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

getAccountsByUserIds

public Account[] getAccountsByUserIds(String groupId,
                                      String[] userIds)
                               throws AccessSecurityReadException
指定されたユーザIDのアカウント情報をすべて取得する。

パラメータ:
groupId - ログイングループID
userIds - ユーザIDの配列
戻り値:
ユーザアカウントオブジェクトの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

getAccountCount

public int getAccountCount(String groupId)
                    throws AccessSecurityReadException
アカウント数を取得する。

パラメータ:
groupId - ログイングループID
戻り値:
ユーザアカウント数
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

getAccountRole

public AccountRole getAccountRole(String groupId,
                                  String userId,
                                  String roleId)
                           throws AccessSecurityReadException
アカウントロール情報を取得する。

アカウントに紐付くアカウントロール情報を取得します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
roleId - ロールID
戻り値:
ユーザアカウントロール情報
存在しない場合は、nullを返却します。
例外:
AccessSecurityReadException - アカウントロール情報取得に失敗した場合スローされます。

getAccountRoleIds

public String[] getAccountRoleIds(String groupId,
                                  String userId)
                           throws AccessSecurityReadException
アカウントロールIDをすべて取得する。

アカウントに紐付くアカウントロールIDをすべて取得します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
ユーザアカウントロール情報の配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - アカウントロール情報取得に失敗した場合スローされます。

getAccountRoles

public AccountRole[] getAccountRoles(String groupId,
                                     String userId)
                              throws AccessSecurityReadException
アカウントロール情報をすべて取得する。

アカウントに紐付くアカウントロール情報をすべて取得します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
ユーザアカウントロール情報の配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - アカウントロール情報取得に失敗した場合スローされます。

getFavoriteMenu

public FavoriteMenu getFavoriteMenu(String groupId,
                                    String userId,
                                    String menuId)
                             throws AccessSecurityReadException
マイメニュー情報を取得する。

アカウントに紐付くマイメニュー情報を取得します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
menuId - メニューID
戻り値:
マイメニュー情報
存在しない場合は、nullを返却します。
例外:
AccessSecurityReadException - マイメニュー情報取得に失敗した場合スローされます。

getFavoriteMenuIds

public String[] getFavoriteMenuIds(String groupId,
                                   String userId)
                            throws AccessSecurityReadException
マイメニューIDをすべて取得する。

アカウントに紐付くマイメニューIDをすべて取得します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
マイメニュー情報の配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - マイメニュー情報取得に失敗した場合スローされます。

getFavoriteMenus

public FavoriteMenu[] getFavoriteMenus(String groupId,
                                       String userId)
                                throws AccessSecurityReadException
マイメニュー情報をすべて取得する。

アカウントに紐付くマイメニュー情報をすべて取得します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
マイメニュー情報の配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - マイメニュー情報取得に失敗した場合スローされます。

getUserIds

public String[] getUserIds(String groupId)
                    throws AccessSecurityReadException
ユーザIDの一覧を取得する。

パラメータ:
groupId - ログイングループID
戻り値:
ユーザIDの配列
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

getUserIdsByRoles

public String[] getUserIdsByRoles(String groupId,
                                  String[] roleIds,
                                  Date date)
                           throws AccessSecurityReadException
指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。

パラメータ:
groupId - ログイングループID
roleIds - 検証用ロールIDの一覧
date - 有効期間判定用の日付
戻り値:
有効なアカウントロールを持つアカウントのユーザIDの配列
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

init

public void init(Map params)
アカウントアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

insertAccount

public void insertAccount(String groupId,
                          Account account)
                   throws AccessSecurityWriteException,
                          DuplicateException
アカウント情報を新規追加する。

パラメータ:
groupId - ログイングループID
account - アカウント情報
例外:
AccessSecurityWriteException - アカウント情報の作成に失敗した場合スローされます。
DuplicateException - 追加するアカウント情報が既に存在した場合スローされます。

insertAccountRole

public void insertAccountRole(String groupId,
                              String userId,
                              AccountRole accountRole)
                       throws AccessSecurityWriteException,
                              DuplicateException
アカウントロール情報を新規追加する。

アカウントに紐付くアカウントロール情報を新規に追加します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
accountRole - アカウントロール情報
例外:
AccessSecurityWriteException - アカウントロール情報の作成に失敗した場合スローされます。
DuplicateException - 追加するアカウントロール情報が既に存在した場合スローされます。

insertFavoriteMenu

public void insertFavoriteMenu(String groupId,
                               String userId,
                               FavoriteMenu favoriteMenu)
                        throws AccessSecurityWriteException,
                               DuplicateException
マイメニュー情報を新規追加する。

アカウントに紐付くマイメニュー情報を新規に追加します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
favoriteMenu - マイメニュー情報
例外:
AccessSecurityWriteException - マイメニュー情報の作成に失敗した場合スローされます。
DuplicateException - 追加するマイメニュー情報が既に存在した場合スローされます。

searchAccounts

public Account[] searchAccounts(String groupId,
                                String userId)
                         throws AccessSecurityReadException
アカウント情報の読み込みます。 ユーザIDまたはユーザIDの一部をキーとして検索し、マッチしたアカウント情報を返します。
ただし、以下の文字列を特殊文字列として扱う。
* 0以上の長さの文字列とマッチ
? 1文字の文字列とマッチ

パラメータ:
groupId - ログイングループID
userId - ユーザID（検索キー）
戻り値:
アカウント情報配列
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

updateAccount

public void updateAccount(String groupId,
                          Account account)
                   throws AccessSecurityWriteException,
                          NotExistException
アカウント情報を更新する。

パラメータ:
groupId - ログイングループID
account - アカウント情報
例外:
AccessSecurityWriteException - アカウント情報の更新に失敗した場合スローされます。
NotExistException - 更新するアカウント情報が存在しない場合にスローされます。

updateAccountRole

public void updateAccountRole(String groupId,
                              String userId,
                              AccountRole accountRole)
                       throws AccessSecurityWriteException,
                              NotExistException
アカウントロール情報を更新する。

アカウントに紐付くアカウントロール情報を更新します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
accountRole - アカウントロール情報
例外:
AccessSecurityWriteException - アカウントロール情報の更新に失敗した場合スローされます。
NotExistException - 更新するアカウントロール情報が存在しない場合にスローされます。

updateFavoriteMenu

public void updateFavoriteMenu(String groupId,
                               String userId,
                               FavoriteMenu favoriteMenu)
                        throws AccessSecurityWriteException,
                               NotExistException
マイメニュー情報を更新する。

アカウントに紐付くマイメニュー情報を更新します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
favoriteMenu - マイメニュー情報
例外:
AccessSecurityWriteException - マイメニュー情報の更新に失敗した場合スローされます。
NotExistException - 更新するマイメニュー情報が存在しない場合にスローされます。

getUserIdsByAccountRole

public String[] getUserIdsByAccountRole(String groupId,
                                        String roleId)
                                 throws AccessSecurityReadException
引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。 引数で指定したアカウントロールを持つアカウントのユーザIDの一覧を返却します。
指定したアカウントロールの階層のチェックはお行いません。

パラメータ:
groupId - ログイングループID
roleId - String アカウントロールのロールID
戻り値:
ユーザIDの配列（データがない場合は空の配列を返します）
例外:
AccessSecurityReadException - アカウント情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getAttribute

public String getAttribute(String groupId,
                           String userId,
                           String name)
                    throws AccessSecurityReadException
アカウント属性情報を取得する。

パラメータ:
groupId - ログイングループID
userId - ユーザID
name - 属性名
戻り値:
アカウント属性値
存在しない場合は、nullを返却します。
例外:
AccessSecurityReadException - アカウント属性情報の取得に失敗した場合スローされます。

getAttributeNames

public String[] getAttributeNames(String groupId,
                                  String userId)
                           throws AccessSecurityReadException
アカウント属性情報の名前の一覧を取得する。

パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
アカウント属性の名前の一覧
存在しない場合は空の配列を返却します。
例外:
AccessSecurityReadException - アカウント属性情報の取得に失敗した場合スローされます。

getUserIdsByAttribute

public String[] getUserIdsByAttribute(String groupId,
                                      String key,
                                      String value)
                               throws AccessSecurityReadException
アカウント属性情報の値と一致するユーザIDを取得する。

パラメータ:
groupId - ログイングループID
key - 検索対象の属性キー名
value - 検索値
戻り値:
ユーザIDの一覧
存在しない場合は空の配列を返却します。
例外:
AccessSecurityReadException - アカウント属性情報の取得に失敗した場合スローされます。

setAttribute

public void setAttribute(String groupId,
                         String userId,
                         String name,
                         String value)
                  throws AccessSecurityWriteException
アカウント属性情報を設定する。
引数で指定した属性名に一致する属性情報が存在しない場合は、新規登録します。
引数で指定した属性名に一致する属性情報がすでに存在する場合は、指定された属性値で更新します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
name - 属性名
value - 属性値
例外:
AccessSecurityWriteException - アカウント情報の設定に失敗した場合スローされます。

deleteAttribute

public void deleteAttribute(String groupId,
                            String userId,
                            String name)
                     throws AccessSecurityWriteException,
                            NotExistException
アカウント属性情報を削除する。

パラメータ:
groupId - ログイングループID
userId - ユーザID
name - 属性名
例外:
AccessSecurityWriteException - アカウント属性情報の削除に失敗した場合スローされます。
NotExistException - 削除するアカウント情報が存在しない場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccountChangedListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
インタフェース AccountChangedListener

既知の実装クラスの一覧:
PasswordHistoryAccountChangedListener
public interface AccountChangedListener

アカウント情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
AccountManager

メソッドの概要
void | accountAdded(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | accountDeleted(String groupId, String userId) アカウント情報をデータストアから削除した直後にコールされます。
void | accountRoleAdded(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | accountRoleDeleted(String groupId, String userId, String roleId) アカウントロール情報をデータストアから削除した直後にコールされます。
void | accountRoleUpdated(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新した直後にコールされます。
void | accountUpdated(String groupId, Account account) アカウント情報をデータストアに更新した直後にコールされます。
void | init(Map params) アカウントリスナーの初期化。

メソッドの詳細

init

public void init(Map params)
アカウントリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

accountAdded

public void accountAdded(String groupId,
                         Account account)
                  throws ChangedListenerException
アカウント情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
account - 作成されたアカウント情報
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

accountDeleted

public void accountDeleted(String groupId,
                           String userId)
                    throws ChangedListenerException
アカウント情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 削除されたユーザID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

accountUpdated

public void accountUpdated(String groupId,
                           Account account)
                    throws ChangedListenerException
アカウント情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
account - 更新されたアカウント情報
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

accountRoleAdded

public void accountRoleAdded(String groupId,
                             String userId,
                             AccountRole accountRole)
                      throws ChangedListenerException
アカウントロール情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 作成されたアカウントロール情報
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

accountRoleDeleted

public void accountRoleDeleted(String groupId,
                               String userId,
                               String roleId)
                        throws ChangedListenerException
アカウントロール情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
roleId - 削除されたロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

accountRoleUpdated

public void accountRoleUpdated(String groupId,
                               String userId,
                               AccountRole accountRole)
                        throws ChangedListenerException
アカウントロール情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 更新されたアカウントロール情報
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountExporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
インタフェース AccountExporter

既知の実装クラスの一覧:
CsvAccountBackup, StandardAccountBackup
public interface AccountExporter

アカウントエクスポートインタフェースです。

バージョン:
1.0

メソッドの概要
void | doExport(AccountManager manager, OutputStream outputStream) エクスポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doExport

public void doExport(AccountManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

アカウント情報をバックアップファイルに出力します。

パラメータ:
manager - アカウントマネージャ
outputStream - 出力ストリーム
例外:
AccessSecurityExportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountImporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
インタフェース AccountImporter

既知の実装クラスの一覧:
CsvAccountBackup, StandardAccountBackup
public interface AccountImporter

アカウントインポートインタフェースです。

バージョン:
1.0

メソッドの概要
void | doImport(InputStream inputStream, AccountManager manager) インポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doImport

public void doImport(InputStream inputStream,
                     AccountManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からアカウント情報を取得し、生成します。

パラメータ:
manager - アカウントマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
クラス AccountManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.account.AccountManager
public final class AccountManager
extends Object

アカウントマネージャクラス。
アカウント情報の操作を行います。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
Account

フィールドの概要
static String | ACCOUNT_ROLE_PERMISSION_SELECTOR パーミッションセレクタ: ユーザが保有するすべてのロール取得用ID。
static String | ATTR_MENU_DISPLAY ユーザ属性名: ログイン時のメニュー表示・非表示用。
static String | ATTR_MENU_FOLDER_DISPLAY_METHOD ユーザ属性名: メニューフォルダの表示方法。
static String | ATTR_MOBILE_EASY_LOGIN ユーザ属性名: かんたんログイン用。
static String | ATTR_MOBILE_EASY_LOGIN_NONCE ユーザ属性名: かんたんログインのアクセスキー生成時に必要なNonce用。
static String | ATTR_MY_MENU_POSITION ユーザ属性名: マイメニュー表示位置用。
static String | ATTR_REPORT_LIMIT_DAYS ユーザ属性名: パスワード期限切れ通知用。
static String | CRYPTION_CATEGORY_MOBILE_USER_AGENT 暗号化アルゴリズムカテゴリ: モバイル端末個体識別番号用。
コンストラクタの概要
AccountManager(String groupId)
コンストラクタ。
メソッドの概要
void | addAccount(Account account) アカウントを新規追加します。
void | addAccountRole(String userId, AccountRole accountRole) アカウントロールを新規追加します。
void | addFavoriteMenu(String userId, FavoriteMenu favoriteMenu) マイメニューを新規追加します。
static void | clearInstance() アカウントマネージャのインスタンスを初期化します。
boolean | contains(String userId) アカウントの存在チェックを行います。
int | count() アカウントの登録数を取得します。
void | deleteAccount(String userId) アカウントを削除します。
void | deleteAccountRole(String userId, String roleId) アカウントロールを削除します。
void | deleteAccountRoles(String userId) アカウントロールをすべて削除します。
void | deleteAccounts() アカウントをすべて削除します。
void | deleteAttribute(String userId, String name) アカウント属性情報を削除する。
void | deleteFavoriteMenu(String userId, String menuId) マイメニューを削除します。
void | deleteFavoriteMenus(String userId) マイメニューをすべて削除します。
void | exportData(String category, OutputStream outputStream) アカウント情報をエクスポートします。
Account | getAccount(String userId) ユーザIDにマッチしたユーザデータを１件取得します。
String[] | getAccountRoleIds(String userId) アカウントロールIDをすべて取得します。
AccountRole[] | getAccountRoles(String userId) アカウントロールをすべて取得します。
AccountRole[] | getAccountRoles(String userId, Date date) 有効期間内のアカウントロールをすべて取得します。
Account[] | getAccounts() ログイングループ内のすべてのユーザアカウントを取得します。
Account[] | getAccountsByUserIds(String[] userIds) ログイングループ内で引数指定したユーザIDのユーザアカウントをすべて取得します。
String | getAttribute(String userId, String name) アカウント属性情報を取得する。
String | getAttribute(String userId, String name, String def) アカウント属性情報を取得する。
String[] | getAttributeNames(String userId) アカウント属性名の一覧を取得する。
String[] | getExportCategories() アカウントエクスポート用のカテゴリの一覧を取得します。
String[] | getFavoriteMenuIds(String userId) マイメニューIDをすべて取得します。
FavoriteMenu[] | getFavoriteMenus(String userId) マイメニューをすべて取得します。
String[] | getImportCategories() アカウントインポート用のカテゴリの一覧を取得します。
String | getLoginGroupId() ログイングループIDを取得します。
String[] | getRoleIds(String userId, Date date) アカウントに紐付く有効なロールIDをすべて取得します。
String[] | getUserIds() すべてのユーザIDを取得します。
String[] | getUserIdsByAccountRole(String roleId) 引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
String[] | getUserIdsByAttribute(String key, String value) アカウント属性情報の値と一致するユーザIDを取得します。
String[] | getUserIdsByRole(String roleId, Date date) 有効なロールIDを持つすべてのユーザIDを取得します。
void | importData(String category, InputStream inputStream) アカウント情報をインポートします。
boolean | isUpdate(Date date) アカウント情報が指定された日付よりも新しいかチェックします。
Account[] | searchAccounts(String userId) ユーザIDを検索してマッチしたアカウントを配列で返します。
void | setAttribute(String userId, String name, String value) アカウント属性情報を設定する。
void | updateAccount(Account account) アカウントを更新します。
void | updateAccountRole(String userId, AccountRole accountRole) アカウントロールを更新します。
void | updateFavoriteMenu(String userId, FavoriteMenu favoriteMenu) マイメニューを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ATTR_REPORT_LIMIT_DAYS

public static final String ATTR_REPORT_LIMIT_DAYS
ユーザ属性名: パスワード期限切れ通知用。

関連項目:
定数フィールド値

ATTR_MENU_DISPLAY

public static final String ATTR_MENU_DISPLAY
ユーザ属性名: ログイン時のメニュー表示・非表示用。

関連項目:
定数フィールド値

ATTR_MENU_FOLDER_DISPLAY_METHOD

public static final String ATTR_MENU_FOLDER_DISPLAY_METHOD
ユーザ属性名: メニューフォルダの表示方法。

関連項目:
定数フィールド値

ATTR_MY_MENU_POSITION

public static final String ATTR_MY_MENU_POSITION
ユーザ属性名: マイメニュー表示位置用。

関連項目:
定数フィールド値

ATTR_MOBILE_EASY_LOGIN

public static final String ATTR_MOBILE_EASY_LOGIN
ユーザ属性名: かんたんログイン用。

関連項目:
定数フィールド値

ACCOUNT_ROLE_PERMISSION_SELECTOR

public static final String ACCOUNT_ROLE_PERMISSION_SELECTOR
パーミッションセレクタ: ユーザが保有するすべてのロール取得用ID。

関連項目:
定数フィールド値

ATTR_MOBILE_EASY_LOGIN_NONCE

public static final String ATTR_MOBILE_EASY_LOGIN_NONCE
ユーザ属性名: かんたんログインのアクセスキー生成時に必要なNonce用。

導入されたバージョン:
6.1.11
関連項目:
定数フィールド値

CRYPTION_CATEGORY_MOBILE_USER_AGENT

public static final String CRYPTION_CATEGORY_MOBILE_USER_AGENT
暗号化アルゴリズムカテゴリ: モバイル端末個体識別番号用。

導入されたバージョン:
6.1.11
関連項目:
AccessSecurityManager.encrypt(String, String), AccessSecurityManager.decrypt(String, String), 定数フィールド値
コンストラクタの詳細

AccountManager

public AccountManager(String groupId)
               throws AccessSecurityException
コンストラクタ。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityException - ログイングループIDが不正な場合にスローされます。
メソッドの詳細

clearInstance

public static void clearInstance()
アカウントマネージャのインスタンスを初期化します。

アクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。
通常、このメソッドを使用する必要はありません。

addAccount

public void addAccount(Account account)
                throws AccessSecurityException
アカウントを新規追加します。

パラメータ:
account - アカウント情報
例外:
AccessSecurityException - アカウント情報の作成に失敗した場合、または引数が不正な場合にスローされます。

addAccountRole

public void addAccountRole(String userId,
                           AccountRole accountRole)
                    throws AccessSecurityException
アカウントロールを新規追加します。

アカウントに紐付くアカウントロールを新規追加します。

パラメータ:
userId - 対象ユーザID
accountRole - アカウントロール情報
例外:
AccessSecurityException - アカウントロール情報の作成に失敗した場合、または引数が不正な場合にスローされます。

addFavoriteMenu

public void addFavoriteMenu(String userId,
                            FavoriteMenu favoriteMenu)
                     throws AccessSecurityException
マイメニューを新規追加します。

アカウントに紐付くマイメニューを新規追加します。

パラメータ:
userId - 対象ユーザID
favoriteMenu - マイメニュー情報
例外:
AccessSecurityException - マイメニュー情報の作成に失敗した場合、または引数が不正な場合にスローされます。

contains

public boolean contains(String userId)
                 throws AccessSecurityException
アカウントの存在チェックを行います。

パラメータ:
userId - ユーザID
戻り値:
true:存在する false:存在しない
例外:
AccessSecurityException - アカウント情報の取得に失敗した場合、または引数が不正な場合にスローされます。

count

public int count()
          throws AccessSecurityException
アカウントの登録数を取得します。

戻り値:
アカウント登録数
例外:
AccessSecurityException - アカウント情報の取得に失敗した場合に、スローされます。

deleteAccount

public void deleteAccount(String userId)
                   throws AccessSecurityException
アカウントを削除します。

パラメータ:
userId - ユーザID
例外:
AccessSecurityException - アカウント情報の削除に失敗した場合、または引数が不正な場合にスローされます。

deleteAccountRole

public void deleteAccountRole(String userId,
                              String roleId)
                       throws AccessSecurityException
アカウントロールを削除します。

アカウントに紐付くアカウントロールを削除します。

パラメータ:
userId - 対象ユーザID
roleId - ロールID
例外:
AccessSecurityException - アカウントロール情報の削除に失敗した場合、または引数が不正な場合にスローされます。

deleteAccountRoles

public void deleteAccountRoles(String userId)
                        throws AccessSecurityException
アカウントロールをすべて削除します。

アカウントに紐付くアカウントロールをすべて削除します。

パラメータ:
userId - 対象ユーザID
例外:
AccessSecurityException - アカウントロール情報の削除に失敗した場合、または引数が不正な場合にスローされます。

deleteAccounts

public void deleteAccounts()
                    throws AccessSecurityException
アカウントをすべて削除します。

例外:
AccessSecurityException - アカウントの削除に失敗した場合にスローされます。

deleteFavoriteMenu

public void deleteFavoriteMenu(String userId,
                               String menuId)
                        throws AccessSecurityException
マイメニューを削除します。

アカウントに紐付くマイメニューを削除します。

パラメータ:
userId - 対象ユーザID
menuId - メニューID
例外:
AccessSecurityException - マイメニュー情報の削除に失敗した場合、または引数が不正な場合にスローされます。

deleteFavoriteMenus

public void deleteFavoriteMenus(String userId)
                         throws AccessSecurityException
マイメニューをすべて削除します。

アカウントに紐付くマイメニューをすべて削除します。

パラメータ:
userId - 対象ユーザID
例外:
AccessSecurityException - マイメニュー情報の削除に失敗した場合、または引数が不正な場合にスローされます。

exportData

public void exportData(String category,
                       OutputStream outputStream)
                throws AccessSecurityException
アカウント情報をエクスポートします。

パラメータ:
category - カテゴリ
outputStream - 出力ストリーム
例外:
AccessSecurityException - エクスポートに失敗した場合、または引数が不正な場合にスローされます。

getAccount

public Account getAccount(String userId)
                   throws AccessSecurityException
ユーザIDにマッチしたユーザデータを１件取得します。
※一度、取得したデータはキャッシュに保管します。

パラメータ:
userId -
戻り値:
ユーザデータ
例外:
AccessSecurityException - アカウントの取得に失敗した場合、または引数が不正な場合にスローされます。

getAccountRoleIds

public String[] getAccountRoleIds(String userId)
                           throws AccessSecurityException
アカウントロールIDをすべて取得します。

アカウントに紐付くアカウントロールIDをすべて取得します。

パラメータ:
userId - 対象ユーザID
戻り値:
アカウントロールIDの配列
データがない場合は空の配列を返します。
例外:
AccessSecurityException - アカウントロール情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getAccountRoles

public AccountRole[] getAccountRoles(String userId)
                              throws AccessSecurityException
アカウントロールをすべて取得します。

アカウントに紐付くアカウントロールをすべて取得します。

パラメータ:
userId - 対象ユーザID
戻り値:
アカウントロール情報の配列
データがない場合は空の配列を返します。
例外:
AccessSecurityException - アカウントロール情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getAccountRoles

public AccountRole[] getAccountRoles(String userId,
                                     Date date)
                              throws AccessSecurityException
有効期間内のアカウントロールをすべて取得します。

指定日付でアカウントに紐付く有効なアカウントロールをすべて取得します。

パラメータ:
userId - 対象ユーザID
date - 有効期間判定用の日付
戻り値:
アカウントロール情報の配列
データがない場合は空の配列を返します。
例外:
AccessSecurityException - アカウントロール情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getAccounts

public Account[] getAccounts()
                      throws AccessSecurityException
ログイングループ内のすべてのユーザアカウントを取得します。

戻り値:
アカウント情報の配列（データがない場合は空の配列を返します。）
例外:
AccessSecurityException - アカウント情報の取得に失敗した場合にスローされます。

getAccountsByUserIds

public Account[] getAccountsByUserIds(String[] userIds)
                               throws AccessSecurityException
ログイングループ内で引数指定したユーザIDのユーザアカウントをすべて取得します。

パラメータ:
userIds - ユーザIDの配列
戻り値:
アカウント情報の配列（データがない場合は空の配列を返します。）
例外:
AccessSecurityException - アカウント情報の取得に失敗した場合にスローされます。

getExportCategories

public String[] getExportCategories()
                             throws AccessSecurityException
アカウントエクスポート用のカテゴリの一覧を取得します。

戻り値:
アカウントエクスポート用カテゴリの一覧
例外:
AccessSecurityException - アカウントエクスポート用のカテゴリの取得に失敗した場合にスローされます。

getFavoriteMenuIds

public String[] getFavoriteMenuIds(String userId)
                            throws AccessSecurityException
マイメニューIDをすべて取得します。

アカウントに紐付くマイメニューIDをすべて取得します。

パラメータ:
userId - 対象ユーザID
戻り値:
マイメニューIDの配列
データがない場合は空の配列を返します。
例外:
AccessSecurityException - マイメニュー情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getFavoriteMenus

public FavoriteMenu[] getFavoriteMenus(String userId)
                                throws AccessSecurityException
マイメニューをすべて取得します。

アカウントに紐付くマイメニューをすべて取得します。

パラメータ:
userId - 対象ユーザID
戻り値:
マイメニュー情報の配列
データがない場合は空の配列を返します。
例外:
AccessSecurityException - マイメニュー情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getImportCategories

public String[] getImportCategories()
                             throws AccessSecurityException
アカウントインポート用のカテゴリの一覧を取得します。

戻り値:
アカウントインポート用カテゴリの一覧
例外:
AccessSecurityException - アカウントインポート用のカテゴリの取得に失敗した場合にスローされます。

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

戻り値:
ログイングループID

getRoleIds

public String[] getRoleIds(String userId,
                           Date date)
                    throws AccessSecurityException
アカウントに紐付く有効なロールIDをすべて取得します。

指定日付でアカウントに紐付く有効なアカウントロールをすべて取得し、
有効なアカウントロールが持つすべてのサブロールを取得して、ロールIDの一覧を返却します。

パラメータ:
userId - 対象ユーザID
date - 有効期間判定用の日付
戻り値:
ロールIDの配列
該当するロールがない場合は空の配列を返します。
例外:
AccessSecurityException - ロール情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getUserIds

public String[] getUserIds()
                    throws AccessSecurityException
すべてのユーザIDを取得します。

戻り値:
ユーザIDの配列（データがない場合は空の配列を返します）
例外:
AccessSecurityException - ユーザIDの取得に失敗した場合にスローされます。

getUserIdsByAccountRole

public String[] getUserIdsByAccountRole(String roleId)
                                 throws AccessSecurityException
引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。 引数で指定したアカウントロールを持つアカウントのユーザIDの一覧を返却します。
指定したアカウントロールの階層のチェックはお行いません。

パラメータ:
roleId - String アカウントロールのロールID
戻り値:
ユーザIDの配列（データがない場合は空の配列を返します）
例外:
AccessSecurityException - アカウント情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getUserIdsByRole

public String[] getUserIdsByRole(String roleId,
                                 Date date)
                          throws AccessSecurityException
有効なロールIDを持つすべてのユーザIDを取得します。

指定したロールIDからすべての親ロールを取得し、
指定日付で有効なアカウントロールを持つアカウントのユーザIDの一覧を返却します。

パラメータ:
roleId - ロールID
date - 有効期間判定用の日付
戻り値:
ユーザIDの配列
該当するユーザがない場合は空の配列を返します。
例外:
AccessSecurityException - アカウント情報の取得に失敗した場合、または引数が不正な場合にスローされます。

importData

public void importData(String category,
                       InputStream inputStream)
                throws AccessSecurityException
アカウント情報をインポートします。

パラメータ:
category - カテゴリ
inputStream - 入力ストリーム
例外:
AccessSecurityException - インポートに失敗した場合、または引数が不正な場合にスローされます。

searchAccounts

public Account[] searchAccounts(String userId)
                         throws AccessSecurityException
ユーザIDを検索してマッチしたアカウントを配列で返します。
ユーザIDまたはユーザIDの一部をキーとして検索し、マッチしたアカウント情報を返します。
ただし、以下の文字列を特殊文字列として扱います。
* 0以上の長さの文字列とマッチ
? 1文字の文字列とマッチ

パラメータ:
userId - 検索キー
戻り値:
ユーザアカウント配列
データがない場合は空の配列を返します。
例外:
AccessSecurityException - アカウントの取得に失敗した場合、または引数が不正な場合にスローされます。

updateAccount

public void updateAccount(Account account)
                   throws AccessSecurityException
アカウントを更新します。

パラメータ:
account - アカウント情報
例外:
AccessSecurityException - アカウントの更新に失敗した場合、または引数が不正な場合にスローされます。

updateAccountRole

public void updateAccountRole(String userId,
                              AccountRole accountRole)
                       throws AccessSecurityException
アカウントロールを更新します。

アカウントに紐付くアカウントロールを更新します。

パラメータ:
userId - 対象ユーザID
accountRole - アカウントロール情報
例外:
AccessSecurityException - アカウントロール情報の更新に失敗した場合、または引数が不正な場合にスローされます。

updateFavoriteMenu

public void updateFavoriteMenu(String userId,
                               FavoriteMenu favoriteMenu)
                        throws AccessSecurityException
マイメニューを更新します。

アカウントに紐付くマイメニューを更新します。

パラメータ:
userId - 対象ユーザID
favoriteMenu - マイメニュー情報
例外:
AccessSecurityException - マイメニュー情報の更新に失敗した場合、または引数が不正な場合にスローされます。

getAttribute

public String getAttribute(String userId,
                           String name)
                    throws AccessSecurityException
アカウント属性情報を取得する。

パラメータ:
userId - ユーザID
name - 属性名
戻り値:
アカウント属性値
存在しない場合は、nullを返却します。
例外:
AccessSecurityException - アカウント属性情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getAttribute

public String getAttribute(String userId,
                           String name,
                           String def)
                    throws AccessSecurityException
アカウント属性情報を取得する。

パラメータ:
userId - ユーザID
name - 属性名
def - デフォルト値
戻り値:
アカウント属性値
存在しない場合は、引数で指定されたデフォルト値を返却します。
例外:
AccessSecurityException - アカウント属性情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getAttributeNames

public String[] getAttributeNames(String userId)
                           throws AccessSecurityException
アカウント属性名の一覧を取得する。

パラメータ:
userId - ユーザID
戻り値:
アカウント属性の名前の一覧
存在しない場合は空の配列を返却します。
例外:
AccessSecurityException - アカウント属性情報の取得に失敗した場合、または引数が不正な場合にスローされます。

setAttribute

public void setAttribute(String userId,
                         String name,
                         String value)
                  throws AccessSecurityException
アカウント属性情報を設定する。
引数で指定した属性名に一致する属性情報が存在しない場合は、新規に登録します。
引数で指定した属性名に一致する属性情報がすでに存在する場合は、指定された属性値で更新します。

パラメータ:
userId - ユーザID
name - 属性名
value - 属性値
例外:
AccessSecurityException - アカウント情報の設定に失敗した場合、または引数が不正な場合にスローされます。

deleteAttribute

public void deleteAttribute(String userId,
                            String name)
                     throws AccessSecurityException
アカウント属性情報を削除する。

パラメータ:
userId - ユーザID
name - 属性名
例外:
AccessSecurityException - アカウント属性情報の削除に失敗した場合、または引数が不正な場合にスローされます。

getUserIdsByAttribute

public String[] getUserIdsByAttribute(String key,
                                      String value)
                               throws AccessSecurityException
アカウント属性情報の値と一致するユーザIDを取得します。

検索対象の属性キーの値が検索値と等しいユーザIDの一覧を取得します。

パラメータ:
key - 検索対象の属性キー名
value - 検索値
戻り値:
ユーザIDの一覧
存在しない場合は空の配列を返却します。
例外:
AccessSecurityException - アカウント属性情報の取得に失敗した場合スローされます。

isUpdate

public boolean isUpdate(Date date)
                 throws AccessSecurityException
アカウント情報が指定された日付よりも新しいかチェックします。

パラメータ:
date - チェック日付
例外:
AccessSecurityReadException - 更新チェックに失敗した場合スローされます。
AccessSecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountPostWriterListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
インタフェース AccountPostWriterListener

既知の実装クラスの一覧:
NonceResetListener4MobileEasyLogin
public interface AccountPostWriterListener

アカウント情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
AccountManager

メソッドの概要
void | init(Map params) アカウントリスナーの初期化。
void | postCreateAccount(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | postCreateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | postCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに作成した直後にコールされます。
void | postDeleteAccount(String groupId, String userId) アカウント情報をデータストアから削除した直後にコールされます。
void | postDeleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報をデータストアから削除した直後にコールされます。
void | postDeleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報をデータストアから削除した直後にコールされます。
void | postUpdateAccount(String groupId, Account account) アカウント情報をデータストアに更新した直後にコールされます。
void | postUpdateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新した直後にコールされます。
void | postUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
アカウントリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreateAccount

public void postCreateAccount(String groupId,
                              Account account)
                       throws AccessSecurityListenerExcpetion
アカウント情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
account - 作成されたアカウント情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteAccount

public void postDeleteAccount(String groupId,
                              String userId)
                       throws AccessSecurityListenerExcpetion
アカウント情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 削除されたユーザID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateAccount

public void postUpdateAccount(String groupId,
                              Account account)
                       throws AccessSecurityListenerExcpetion
アカウント情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
account - 更新されたアカウント情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postCreateAccountRole

public void postCreateAccountRole(String groupId,
                                  String userId,
                                  AccountRole accountRole)
                           throws AccessSecurityListenerExcpetion
アカウントロール情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 作成されたアカウントロール情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteAccountRole

public void postDeleteAccountRole(String groupId,
                                  String userId,
                                  String roleId)
                           throws AccessSecurityListenerExcpetion
アカウントロール情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
roleId - 削除されたロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateAccountRole

public void postUpdateAccountRole(String groupId,
                                  String userId,
                                  AccountRole accountRole)
                           throws AccessSecurityListenerExcpetion
アカウントロール情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 更新されたアカウントロール情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postCreateFavoriteMenu

public void postCreateFavoriteMenu(String groupId,
                                   String userId,
                                   FavoriteMenu favoriteMenu)
                            throws AccessSecurityListenerExcpetion
マイメニュー情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
favoriteMenu - 作成されたマイメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteFavoriteMenu

public void postDeleteFavoriteMenu(String groupId,
                                   String userId,
                                   String menuId)
                            throws AccessSecurityListenerExcpetion
マイメニュー情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
menuId - 削除されたマイメニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateFavoriteMenu

public void postUpdateFavoriteMenu(String groupId,
                                   String userId,
                                   FavoriteMenu favoriteMenu)
                            throws AccessSecurityListenerExcpetion
マイメニュー情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
favoriteMenu - 更新されたマイメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountQueryWriterListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
インタフェース AccountQueryWriterListener

既知の実装クラスの一覧:
NonceResetListener4MobileEasyLogin
public interface AccountQueryWriterListener

アカウント情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
AccountManager

メソッドの概要
void | init(Map params) アカウントリスナーの初期化。
void | queryCreateAccount(String groupId, Account account) アカウント情報をデータストアに作成する直前にコールされます。
void | queryCreateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | queryCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに作成する直前にコールされます。
void | queryDeleteAccount(String groupId, String userId) アカウント情報をデータストアから削除する直前にコールされます。
void | queryDeleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報をデータストアから削除する直前にコールされます。
void | queryDeleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報をデータストアから削除する直前にコールされます。
void | queryUpdateAccount(String groupId, Account account) アカウント情報をデータストアに更新する直前にコールされます。
void | queryUpdateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新する直前にコールされます。
void | queryUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
アカウントリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreateAccount

public void queryCreateAccount(String groupId,
                               Account account)
                        throws AccessSecurityListenerExcpetion
アカウント情報をデータストアに作成する直前にコールされます。

パラメータ:
groupId - ログイングループID
account - 作成されるアカウント情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteAccount

public void queryDeleteAccount(String groupId,
                               String userId)
                        throws AccessSecurityListenerExcpetion
アカウント情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
userId - 削除されるユーザコード
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdateAccount

public void queryUpdateAccount(String groupId,
                               Account account)
                        throws AccessSecurityListenerExcpetion
アカウント情報をデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
account - 更新されるアカウント情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryCreateAccountRole

public void queryCreateAccountRole(String groupId,
                                   String userId,
                                   AccountRole accountRole)
                            throws AccessSecurityListenerExcpetion
アカウントロール情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 作成されるアカウントロール情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteAccountRole

public void queryDeleteAccountRole(String groupId,
                                   String userId,
                                   String roleId)
                            throws AccessSecurityListenerExcpetion
アカウントロール情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
roleId - 削除されるロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdateAccountRole

public void queryUpdateAccountRole(String groupId,
                                   String userId,
                                   AccountRole accountRole)
                            throws AccessSecurityListenerExcpetion
アカウントロール情報をデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 更新されるアカウントロール情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryCreateFavoriteMenu

public void queryCreateFavoriteMenu(String groupId,
                                    String userId,
                                    FavoriteMenu favoriteMenu)
                             throws AccessSecurityListenerExcpetion
マイメニュー情報をデータストアに作成する直前にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
favoriteMenu - 作成されるマイメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteFavoriteMenu

public void queryDeleteFavoriteMenu(String groupId,
                                    String userId,
                                    String menuId)
                             throws AccessSecurityListenerExcpetion
マイメニュー情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
menuId - 削除されるマイメニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdateFavoriteMenu

public void queryUpdateFavoriteMenu(String groupId,
                                    String userId,
                                    FavoriteMenu favoriteMenu)
                             throws AccessSecurityListenerExcpetion
マイメニュー情報をデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
favoriteMenu - 更新されるマイメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountReaderDecorator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
インタフェース AccountReaderDecorator

public interface AccountReaderDecorator

アカウント情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
Account | doDecoration(String groupId, Account account) アカウントをデータストアからの読み込み直後にコールされます。
void | init(Map params) アカウントデコレータの初期化。

メソッドの詳細

init

public void init(Map params)
アカウントデコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public Account doDecoration(String groupId,
                            Account account)
アカウントをデータストアからの読み込み直後にコールされます。

パラメータ:
groupId - ログイングループID
account - 読み込みが行われたアカウント情報
戻り値:
拡張されたアカウント情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccountRole (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
クラス AccountRole

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.account.AccountRole
すべての実装インタフェース:
Serializable
public class AccountRole
extends Object
implements Serializable

アカウント用ロールモデル。

アカウントに対してこのロールが有効になる範囲は、有効開始日 <= 日付 < 有効終了日の範囲です。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
AccountRole(String roleId)
コンストラクタ。
メソッドの概要
String | getRoleId() ロールIDを取得します。
Date | getRoleValidEndDate() ロール有効終了日を取得します。
Date | getRoleValidStartDate() ロール有効開始日を取得します。
protected void | setRoleId(String roleId) ロールIDを設定します。
void | setRoleValidEndDate(Date roleValidEndDate) ロール有効終了日を設定します。
void | setRoleValidStartDate(Date roleValidStartDate) ロール有効開始日を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AccountRole

public AccountRole(String roleId)
コンストラクタ。

パラメータ:
roleId - ロールID
メソッドの詳細

getRoleId

public String getRoleId()
ロールIDを取得します。

戻り値:
ロールID

getRoleValidEndDate

public Date getRoleValidEndDate()
ロール有効終了日を取得します。

戻り値:
ロール有効終了日
設定されていない場合は、日付の最大過去日を返却します。

getRoleValidStartDate

public Date getRoleValidStartDate()
ロール有効開始日を取得します。

戻り値:
ロール有効開始日
設定されていない場合は、日付の最大未来日を返却します。

setRoleId

protected void setRoleId(String roleId)
ロールIDを設定します。

パラメータ:
roleId - ロールID

setRoleValidEndDate

public void setRoleValidEndDate(Date roleValidEndDate)
ロール有効終了日を設定します。

設定されるのは、日付のみで、時間は00:00:00に設定されます。
有効になるのは設定された日付の前日までです。
nullを設定した場合は、最大未来日に設定されます。

パラメータ:
roleValidEndDate - ロール有効終了日

setRoleValidStartDate

public void setRoleValidStartDate(Date roleValidStartDate)
ロール有効開始日を設定します。

設定されるのは、日付のみで、時間は00:00:00に設定されます。
有効になるのは設定された日付からです。
nullを設定した場合は、最大過去日に設定されます。

パラメータ:
roleValidStartDate - ロール有効開始日
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CsvAccountBackup (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
クラス CsvAccountBackup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.account.CsvAccountBackup
すべての実装インタフェース:
AccountExporter, AccountImporter
public class CsvAccountBackup
extends Object
implements AccountImporter, AccountExporter

CSVアカウントバックアップクラスです。
CSV形式でのアカウント情報のインポートおよびエクスポートを実現します。

アカウントのCSVフォーマットについて

各行の一列目には、情報ヘッダを記述します。
各ヘッダ情報別に、2列目以降に設定する内容が異なります。

各情報ヘッダの詳細は、以下の通りです。

account（アカウント基本情報）
account,ユーザID,パスワード,ロケール,エンコーディング,モバイル用パスワード,説明,有効開始日,有効終了日,外出フラグ,メインページパターン,カラーパターン,ライセンス

  • 有効開始日および有効終了日のフォーマットは yyyy/MM/dd|hh:mm:ss です。
  • 有効開始日を空文字列とした場合は、最大過去日付(1582/10/15|00:00:00)となります。
  • 有効終了日を空文字列とした場合は、最大未来日付(9999/12/31|23:59:59)となります。
    • roles（アカウントロール情報）
    roles,ユーザID,ロールID,ロール有効開始日,ロール有効終了日,ロールID,ロール有効開始日,ロール有効終了日,・・・

  • 複数のロールを記述する場合は、ロールID,ロール有効開始日,ロール有効終了日の順で繰り返し記述します。
  • ロール有効開始日およびロール有効終了日のフォーマットは yyyy/MM/dd|hh:mm:ss です。
  • ロール有効開始日を空文字列とした場合は、最大過去日付(1582/10/15|00:00:00)となります。
  • ロール有効終了日を空文字列とした場合は、最大未来日付(9999/12/31|23:59:59)となります。
    • my-menus（マイメニュー情報）
    my-menus,ユーザID,メニューID,表示名,イメージパス,ソート番号（数字）,メニューID,表示名,イメージパス,ソート番号（数字）,・・・

  • 複数のマイメニューを記述する場合は、メニューID,表示名,イメージパス,ソート番号（数字）の順で繰り返し記述します。
    • app-roles（アプリケーションロール）
    app-roles,ユーザID,アプリケーションID,アプリケーションID,・・・

  • 複数のアプリケーションロールを記述する場合は、アプリケーションIDを繰り返し記述します。
    • attrs （ユーザ属性）
    attrs,ユーザID,属性キー,属性S値,属性キー,属性値,・・・

  • 複数のユーザ属性を記述する場合は、属性キー,属性値の順で繰り返し記述します。
    • 記述例

    account,guest,guest,ja,Shift_JIS,0123,ゲストユーザ,1582/10/15|00:00:00,9999/12/31|23:59:59,FALSE,,,TRUE
    roles,guest,userSetting,1582/10/15|00:00:00,9999/12/31|23:59:59,level3,,
    my-menus,guest,menu_id1,メニュー別名１,images/image1.gif,1,menu_id2,メニュー別名２,images/image1.gif,2
    app-roles,guest,SP,WM
    attrs,guest,attr1,value1,attr2,value2

    導入されたバージョン:
    6.1
    バージョン:
    1.0

    フィールドの概要
    static String ID_CRYPTION_CLASS
    暗号化クラス名
    コンストラクタの概要
    CsvAccountBackup()
    メソッドの概要
void | doExport(AccountManager manager, OutputStream outputStream) エクスポートを行います。
void | doImport(InputStream inputStream, AccountManager manager) インポートを行います。
protected Account[] | getAllAccounts(String groupId)
protected Map | getParams() パラメータを取得します。
void | init(Map params) 初期化。
    クラス java.lang.Object から継承したメソッド
    clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    フィールドの詳細

    ID_CRYPTION_CLASS

    public static final String ID_CRYPTION_CLASS
    暗号化クラス名

    関連項目:
    定数フィールド値
    コンストラクタの詳細

    CsvAccountBackup

    public CsvAccountBackup()
    メソッドの詳細

    init

    public void init(Map params)
    初期化。

    初期化する。

    定義:
    インタフェース AccountImporter 内の init
    パラメータ:
    params - 初期化パラメータのマップ(Map)

    getParams

    protected Map getParams()
    パラメータを取得します。

    doImport

    public void doImport(InputStream inputStream,
                     AccountManager manager)
              throws AccessSecurityImportException
    インポートを行います。

    ストリーム内の情報からアカウント情報を生成します。

    定義:
    インタフェース AccountImporter 内の doImport
    パラメータ:
    manager - アカウントマネージャクラス
    inputStream - 入力ストリーム
    例外:
    AccessSecurityImportException

    doExport

    public void doExport(AccountManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
    エクスポートを行います。

    アカウントバックアップ情報を生成し、ストリームに返却します。

    定義:
    インタフェース AccountExporter 内の doExport
    パラメータ:
    manager - アカウントマネージャクラス
    outputStream - 出力ストリーム
    例外:
    AccessSecurityExportException

    getAllAccounts

    protected Account[] getAllAccounts(String groupId)
                            throws AccessSecurityException
    例外:
    AccessSecurityException
    概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
            intra-mart 6.1.14
    前のクラス 次のクラス フレームあり フレームなし
    概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FavoriteMenu (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
クラス FavoriteMenu

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.account.FavoriteMenu
すべての実装インタフェース:
Serializable
public class FavoriteMenu
extends Object
implements Serializable

マイメニューモデル。

マイメニューの情報を保管するモデルクラスです。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
FavoriteMenu(String menuId)
コンストラクタ。
FavoriteMenu(String menuId, String displayName, int sortNumber)
コンストラクタ。
メソッドの概要
String | getDisplayName() マイメニュー表示名を取得します。
String | getImagePath() マイメニューイメージを取得します。
String | getMenuId() メニューIDを取得します。
int | getSortNumber() ソート番号を取得します。
void | setDisplayName(String displayName) マイメニュー表示名を設定する。
void | setImagePath(String imagePath) マイメニューイメージパスを設定します。
protected void | setMenuId(String menuId) メニューIDを設定します。
void | setSortNumber(int sortNumber) ソート番号を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FavoriteMenu

public FavoriteMenu(String menuId,
                    String displayName,
                    int sortNumber)
コンストラクタ。

パラメータ:
displayName - マイメニュー表示名
menuId - メニューID
sortNumber - ソート番号

FavoriteMenu

public FavoriteMenu(String menuId)
コンストラクタ。

パラメータ:
menuId - メニューID
メソッドの詳細

getDisplayName

public String getDisplayName()
マイメニュー表示名を取得します。

戻り値:
マイメニュー表示名

getMenuId

public String getMenuId()
メニューIDを取得します。

戻り値:
メニューID

getSortNumber

public int getSortNumber()
ソート番号を取得します。

戻り値:
ソート番号

setDisplayName

public void setDisplayName(String displayName)
マイメニュー表示名を設定する。

パラメータ:
displayName - マイメニュー表示名

setMenuId

protected void setMenuId(String menuId)
メニューIDを設定します。

パラメータ:
menuId - メニューID

setSortNumber

public void setSortNumber(int sortNumber)
ソート番号を設定します。

パラメータ:
sortNumber - ソート番号

getImagePath

public String getImagePath()
マイメニューイメージを取得します。

戻り値:
String

setImagePath

public void setImagePath(String imagePath)
マイメニューイメージパスを設定します。

パラメータ:
imagePath - マイメニューイメージパス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.account (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.security.account
インタフェース
AccountAccessor
AccountChangedListener
AccountExporter
AccountImporter
AccountPostWriterListener
AccountQueryWriterListener
AccountReaderDecorator
クラス
Account
AccountManager
AccountRole
CsvAccountBackup
FavoriteMenu
RoleChangedAccountListener
StandardAccountBackup


jp.co.intra_mart.foundation.security.account (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.account

アカウントに関連するクラスを提供します。

参照:
説明

インタフェースの概要
AccountAccessor | アカウントアクセッサインタフェース。
AccountChangedListener | アカウント情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AccountExporter | アカウントエクスポートインタフェースです。
AccountImporter | アカウントインポートインタフェースです。
AccountPostWriterListener | アカウント情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AccountQueryWriterListener | アカウント情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
AccountReaderDecorator | アカウント情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

クラスの概要
Account | アカウントモデル。
AccountManager | アカウントマネージャクラス。
AccountRole | アカウント用ロールモデル。
CsvAccountBackup | CSVアカウントバックアップクラスです。
FavoriteMenu | マイメニューモデル。
RoleChangedAccountListener | ロールが削除された場合にアカウントに紐付くロールを削除するリスナークラス。
StandardAccountBackup | アカウント情報をインポート・エクスポートするクラス。

パッケージ jp.co.intra_mart.foundation.security.account の説明

アカウントに関連するクラスを提供します。


jp.co.intra_mart.foundation.security.account クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.account の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.account.Account (implements jp.co.intra_mart.foundation.security.LocaleProvider, java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.account.AccountManager
    • class jp.co.intra_mart.foundation.security.account.AccountRole (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.account.CsvAccountBackup (implements jp.co.intra_mart.foundation.security.account.AccountExporter, jp.co.intra_mart.foundation.security.account.AccountImporter)
    • class jp.co.intra_mart.foundation.security.account.FavoriteMenu (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener (implements jp.co.intra_mart.foundation.security.role.RoleChangedListener)
    • class jp.co.intra_mart.foundation.security.account.StandardAccountBackup (implements jp.co.intra_mart.foundation.security.account.AccountExporter, jp.co.intra_mart.foundation.security.account.AccountImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.account.AccountAccessor
  • interface jp.co.intra_mart.foundation.security.account.AccountChangedListener
  • interface jp.co.intra_mart.foundation.security.account.AccountExporter
  • interface jp.co.intra_mart.foundation.security.account.AccountImporter
  • interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener
  • interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.account.AccountReaderDecorator


パッケージ jp.co.intra_mart.foundation.security.account の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.account の使用

jp.co.intra_mart.foundation.security.account を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession |
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.mobile |
jp.co.intra_mart.foundation.security.password |

jp.co.intra_mart.foundation.security により使用される jp.co.intra_mart.foundation.security.account のクラス
Account
アカウントモデル。
AccountAccessor
アカウントアクセッサインタフェース。
AccountRole
アカウント用ロールモデル。
FavoriteMenu
マイメニューモデル。

jp.co.intra_mart.foundation.security.account により使用される jp.co.intra_mart.foundation.security.account のクラス
Account
アカウントモデル。
AccountExporter
アカウントエクスポートインタフェースです。
AccountImporter
アカウントインポートインタフェースです。
AccountManager
アカウントマネージャクラス。
AccountRole
アカウント用ロールモデル。
FavoriteMenu
マイメニューモデル。

jp.co.intra_mart.foundation.security.activesession により使用される jp.co.intra_mart.foundation.security.account のクラス
Account
アカウントモデル。

jp.co.intra_mart.foundation.security.certification により使用される jp.co.intra_mart.foundation.security.account のクラス
Account
アカウントモデル。

jp.co.intra_mart.foundation.security.mobile により使用される jp.co.intra_mart.foundation.security.account のクラス
Account
アカウントモデル。
AccountPostWriterListener
アカウント情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AccountQueryWriterListener
アカウント情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
AccountRole
アカウント用ロールモデル。
FavoriteMenu
マイメニューモデル。

jp.co.intra_mart.foundation.security.password により使用される jp.co.intra_mart.foundation.security.account のクラス
Account
アカウントモデル。
AccountChangedListener
アカウント情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AccountRole
アカウント用ロールモデル。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


RoleChangedAccountListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
クラス RoleChangedAccountListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener
すべての実装インタフェース:
RoleChangedListener
public class RoleChangedAccountListener
extends Object
implements RoleChangedListener

ロールが削除された場合にアカウントに紐付くロールを削除するリスナークラス。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
RoleChangedAccountListener()
コンストラクタ。
メソッドの概要
void | init(Map params) ロールリスナーの初期化。
void | roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | roleDeleted(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | subRoleAdded(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | subRoleDeleted(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RoleChangedAccountListener

public RoleChangedAccountListener()
コンストラクタ。

メソッドの詳細

init

public void init(Map params)
ロールリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース RoleChangedListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

roleAdded

public void roleAdded(String groupId,
                      Role role)
               throws ChangedListenerException
ロール情報をデータストアに作成した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の roleAdded
パラメータ:
groupId - ログイングループID
role - 作成されたロール
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

roleDeleted

public void roleDeleted(String groupId,
                        String roleId)
                 throws ChangedListenerException
ロール情報をデータストアから削除した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の roleDeleted
パラメータ:
groupId - ログイングループID
roleId - 削除されたロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

roleUpdated

public void roleUpdated(String groupId,
                        Role role)
                 throws ChangedListenerException
ロール情報をデータストアに更新した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の roleUpdated
パラメータ:
groupId - ログイングループID
role - 更新されたロール
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

subRoleAdded

public void subRoleAdded(String groupId,
                         String roleId,
                         String subRoleId)
                  throws ChangedListenerException
ロールにサブロールを追加した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の subRoleAdded
パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 追加されたサブロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

subRoleDeleted

public void subRoleDeleted(String groupId,
                           String roleId,
                           String subRoleId)
                    throws ChangedListenerException
ロールからサブロールを削除した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の subRoleDeleted
パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 削除されたサブロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardAccountBackup (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
クラス StandardAccountBackup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.account.StandardAccountBackup
すべての実装インタフェース:
AccountExporter, AccountImporter
public class StandardAccountBackup
extends Object
implements AccountImporter, AccountExporter

アカウント情報をインポート・エクスポートするクラス。

アカウント情報をXML形式でインポート・エクスポートするクラスです。

このクラスを[ServerManager]/access-security.xmlのbackup-configタグ内に設定して利用します。

設定例

 <backup-config>
   <backup-group>
     <category>カテゴリ名</category>
     <account-backup>
       <import>
          <import-class>jp.co.intra_mart.foundation.security.account.StandardAccountBackup</import-class>
       </import>
       <export>
         <export-class>jp.co.intra_mart.foundation.security.account.StandardAccountBackup</export-class>
       </export>
     </account-backup>
   </backup-group>
 <backup-config>

導入されたバージョン:
5.0
バージョン:
2.0

フィールドの概要
static String ID_CRYPTION_CLASS
暗号化クラス名
コンストラクタの概要
StandardAccountBackup()
メソッドの概要
void | doExport(AccountManager manager, OutputStream outputStream) エクスポートを行います。
void | doImport(InputStream inputStream, AccountManager manager) インポートを行います。
protected Account[] | getAllAccounts(String groupId)
void | init(Map params) 初期化。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_CRYPTION_CLASS

public static final String ID_CRYPTION_CLASS
暗号化クラス名

関連項目:
定数フィールド値
コンストラクタの詳細

StandardAccountBackup

public StandardAccountBackup()
メソッドの詳細

init

public void init(Map params)
初期化。

初期化する。

定義:
インタフェース AccountImporter 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     AccountManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からアカウント情報を生成します。

定義:
インタフェース AccountImporter 内の doImport
パラメータ:
manager - アカウントマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

doExport

public void doExport(AccountManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

アカウントバックアップ情報を生成し、ストリームに返却します。

定義:
インタフェース AccountExporter 内の doExport
パラメータ:
manager - アカウントマネージャクラス
outputStream - 出力ストリーム
例外:
AccessSecurityExportException

getAllAccounts

protected Account[] getAllAccounts(String groupId)
                            throws AccessSecurityException
例外:
AccessSecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor の使用

ActiveSessionAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.security.activesession

jp.co.intra_mart.foundation.security.activesession での ActiveSessionAccessor の使用

ActiveSessionAccessor を実装している jp.co.intra_mart.foundation.security.activesession のクラス
 class StandardActiveSessionAccessor
アクティブなセッション情報操作実装クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.activesession.ActiveSessionBindingListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.activesession.ActiveSessionBindingListener の使用

jp.co.intra_mart.foundation.security.activesession.ActiveSessionBindingListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo の使用

ActiveSessionInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security.activesession
jp.co.intra_mart.foundation.security.duplication

jp.co.intra_mart.foundation.security.activesession での ActiveSessionInfo の使用

ActiveSessionInfo を返す jp.co.intra_mart.foundation.security.activesession のメソッド
ActiveSessionInfo[] | StandardActiveSessionAccessor.getActiveSessionInfos(String groupId) アクティブなすべてのセッション情報を取得します。
ActiveSessionInfo | StandardActiveSessionAccessor.getActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を取得します。
ActiveSessionInfo | StandardActiveSessionAccessor.getInvalidatedActiveSessionInfo(String groupId, String sessionId) 無効化されたアクティブなセッション情報を取得します。
ActiveSessionInfo[] | StandardActiveSessionAccessor.getActiveSessionInfos(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | StandardActiveSessionAccessor.getActiveSessionInfos(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | StandardActiveSessionAccessor.searchActiveSessionInfosByUserId(String groupId, String loginType, String userId) 引数で指定されたユーザ条件からアクティブなセッション情報を検索します。
ActiveSessionInfo[] | ActiveSessionManager.getActiveSessionInfos(String groupId) アクティブなすべてのセッション情報を取得します。
ActiveSessionInfo | ActiveSessionManager.getActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を取得します。
ActiveSessionInfo | ActiveSessionManager.getInvalidatedActiveSessionInfo(String groupId, String sessionId) 無効化されたアクティブなセッション情報を取得します。
ActiveSessionInfo[] | ActiveSessionManager.getActiveSessionInfos(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | ActiveSessionManager.getActiveSessionInfos(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | ActiveSessionManager.searchActiveSessionInfosByUserId(String groupId, String loginType, String userId) 引数で指定されたユーザ条件からアクティブなセッション情報を検索します。
ActiveSessionInfo[] | ActiveSessionAccessor.getActiveSessionInfos(String groupId) アクティブなすべてのセッション情報を取得します。
ActiveSessionInfo | ActiveSessionAccessor.getActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を取得します。
ActiveSessionInfo | ActiveSessionAccessor.getInvalidatedActiveSessionInfo(String groupId, String sessionId) 無効化されたアクティブなセッション情報を取得します。
ActiveSessionInfo[] | ActiveSessionAccessor.getActiveSessionInfos(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | ActiveSessionAccessor.getActiveSessionInfos(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | ActiveSessionAccessor.searchActiveSessionInfosByUserId(String groupId, String loginType, String userId) 引数で指定されたユーザ条件からアクティブなセッション情報を検索します。

ActiveSessionInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.activesession のメソッド
void | StandardActiveSessionAccessor.addActiveSessionInfo(ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報を登録します。
void | ActiveSessionManager.addActiveSessionInfo(ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報を登録します。
void | ActiveSessionAccessor.addActiveSessionInfo(ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報を登録します。

ActiveSessionInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.activesession のコンストラクタ
ActiveSessionBindingListener(ActiveSessionInfo activeSessionInfo)
コンストラクタ。

jp.co.intra_mart.foundation.security.duplication での ActiveSessionInfo の使用

ActiveSessionInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.duplication のメソッド
boolean | StandardDuplicateLoginAccessor.isDetectEnable(ActiveSessionInfo activeSessionInfo) 検出処理が有効かどうか取得します。
boolean | StandardDuplicateLoginAccessor.isInvalidatableByUser(ActiveSessionInfo activeSessionInfo) ユーザ自身のセッションの無効化が可能か取得します。
boolean | DuplicateLoginManager.isDuplicateLogined(ActiveSessionInfo activeSessionInfo) 引数で指定されたユーザが重複してログインしているかどうか判別します。
boolean | DuplicateLoginManager.isDetectEnable(ActiveSessionInfo activeSessionInfo) 検出処理が有効かどうか取得します。
boolean | DuplicateLoginManager.isInvalidatableByUser(ActiveSessionInfo activeSessionInfo) ユーザ自身のセッションの無効化が可能か取得します。
void | DuplicateLoginManager.invalidateOtherSessions(ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報以外のセッション情報をすべて無効にします。
boolean | DuplicateLoginAccessor.isDetectEnable(ActiveSessionInfo activeSessionInfo) 検出処理が有効かどうか取得します。
boolean | DuplicateLoginAccessor.isInvalidatableByUser(ActiveSessionInfo activeSessionInfo) ユーザ自身のセッションの無効化が可能か取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager の使用

jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.activesession.GroupActiveSessionRegister の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.activesession.GroupActiveSessionRegister の使用

jp.co.intra_mart.foundation.security.activesession.GroupActiveSessionRegister はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.activesession.NavigatorInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.activesession.NavigatorInfo の使用

NavigatorInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security.activesession

jp.co.intra_mart.foundation.security.activesession での NavigatorInfo の使用

NavigatorInfo を返す jp.co.intra_mart.foundation.security.activesession のメソッド
 NavigatorInfo ActiveSessionManager.distinctNavigator(String userAgent)
引数で指定されたユーザエージェント情報から判別してナビゲータ情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor の使用

jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.activesession.UserActiveSessionRegister の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.activesession.UserActiveSessionRegister の使用

jp.co.intra_mart.foundation.security.activesession.UserActiveSessionRegister はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ActiveSessionAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.activesession
インタフェース ActiveSessionAccessor

既知の実装クラスの一覧:
StandardActiveSessionAccessor
public interface ActiveSessionAccessor

アクティブなセッション情報操作インターフェース。

アクティブなセッション情報操作のためのインターフェース。

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
void | addActiveSessionInfo(ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報を登録します。
int | count(String groupId) アクティブなすべてのセッション数を取得します。
int | count(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。
int | count(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなすべてのセッション数を取得します。
void | destory(String groupId) アクティブなセッション情報をすべて破棄します。
boolean | exists(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が存在するかどうか取得します。
ActiveSessionInfo | getActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | getActiveSessionInfos(String groupId) アクティブなすべてのセッション情報を取得します。
ActiveSessionInfo[] | getActiveSessionInfos(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | getActiveSessionInfos(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなセッション情報を取得します。
String | getActiveSessionInvalidatedPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 引数で指定されたアクティブなセッション情報が無効化されたされていた場合の遷移先ページURLを取得します。
ActiveSessionInfo | getInvalidatedActiveSessionInfo(String groupId, String sessionId) 無効化されたアクティブなセッション情報を取得します。
void | init(Node defaultNode, Node node) 設定ファイルの情報を基に初期化します。
void | invalidate(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
boolean | isObservable() アクティブセッションの監視を行うかどうか取得します。
boolean | isValid(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
void | removeActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を削除します。
ActiveSessionInfo[] | searchActiveSessionInfosByUserId(String groupId, String loginType, String userId) 引数で指定されたユーザ条件からアクティブなセッション情報を検索します。
void | updateLastResponseTime(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。
void | updateToProcessing(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報を処理中に更新します。

メソッドの詳細

init

public void init(Node defaultNode,
                 Node node)
          throws ActiveSessionException
設定ファイルの情報を基に初期化します。

パラメータ:
defaultNode - デフォルトノード
node - デフォルトノード
例外:
ActiveSessionException - 初期化処理で例外が発生した場合にスローします。

isObservable

public boolean isObservable()
アクティブセッションの監視を行うかどうか取得します。

戻り値:
アクティブセッションの監視を行う場合 true
導入されたバージョン:
6.1.6

addActiveSessionInfo

public void addActiveSessionInfo(ActiveSessionInfo activeSessionInfo)
                          throws ActiveSessionException
引数で指定されたアクティブなセッション情報を登録します。

パラメータ:
activeSessionInfo - アクティブなセッション情報
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

removeActiveSessionInfo

public void removeActiveSessionInfo(String groupId,
                                    String sessionId)
                             throws ActiveSessionNotExistException,
                                    ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報を削除します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

destory

public void destory(String groupId)
             throws ActiveSessionException
アクティブなセッション情報をすべて破棄します。

パラメータ:
groupId - ログイングループID
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

invalidate

public void invalidate(String groupId,
                       String sessionId)
                throws ActiveSessionNotExistException,
                       ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報を無効化します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

isValid

public boolean isValid(String groupId,
                       String sessionId)
                throws ActiveSessionNotExistException,
                       ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
戻り値:
アクティブなセッション情報が有効かどうか
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

count

public int count(String groupId)
          throws ActiveSessionException
アクティブなすべてのセッション数を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
アクティブなすべてのセッション数
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

count

public int count(String groupId,
                 String loginType,
                 String userId)
          throws ActiveSessionException
引数で指定されたユーザのアクティブなすべてのセッション数を取得します。

パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
userId - ユーザID
戻り値:
アクティブなすべてのセッション数
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

count

public int count(String groupId,
                 String loginType)
          throws ActiveSessionException
引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。

パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
戻り値:
アクティブなすべてのセッション数
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

exists

public boolean exists(String groupId,
                      String sessionId)
               throws ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報が存在するかどうか取得します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
戻り値:
アクティブなセッション情報が存在するかどうか
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getActiveSessionInfos

public ActiveSessionInfo[] getActiveSessionInfos(String groupId)
                                          throws ActiveSessionException
アクティブなすべてのセッション情報を取得します。

1件も存在しない場合、戻り値は空の配列となります。 配列の並び順はログイン時刻の昇順となります。

パラメータ:
groupId - ログイングループID
戻り値:
アクティブなセッション情報一覧
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getActiveSessionInfo

public ActiveSessionInfo getActiveSessionInfo(String groupId,
                                              String sessionId)
                                       throws ActiveSessionNotExistException,
                                              ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報を取得します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
戻り値:
アクティブなセッション情報
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getInvalidatedActiveSessionInfo

public ActiveSessionInfo getInvalidatedActiveSessionInfo(String groupId,
                                                         String sessionId)
                                                  throws ActiveSessionNotExistException,
                                                         ActiveSessionException
無効化されたアクティブなセッション情報を取得します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
戻り値:
アクティブなセッション情報
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getActiveSessionInfos

public ActiveSessionInfo[] getActiveSessionInfos(String groupId,
                                                 String loginType,
                                                 String userId)
                                          throws ActiveSessionException
引数で指定されたユーザのアクティブなセッション情報を取得します。

1件も存在しない場合、戻り値は空の配列となります。
配列の並び順はログイン時刻の昇順となります。

パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
userId - ユーザID
戻り値:
アクティブなセッション情報一覧
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getActiveSessionInfos

public ActiveSessionInfo[] getActiveSessionInfos(String groupId,
                                                 String loginType)
                                          throws ActiveSessionException
引数で指定されたログインタイプのアクティブなセッション情報を取得します。

1件も存在しない場合、戻り値は空の配列となります。
配列の並び順はログイン時刻の昇順となります。

パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
戻り値:
アクティブなセッション情報一覧
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

searchActiveSessionInfosByUserId

public ActiveSessionInfo[] searchActiveSessionInfosByUserId(String groupId,
                                                            String loginType,
                                                            String userId)
                                                     throws ActiveSessionException
引数で指定されたユーザ条件からアクティブなセッション情報を検索します。

ユーザIDに検索条件を指定します。
1件も存在しない場合、戻り値は空の配列となります。
配列の並び順はログイン時刻の昇順となります。

パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
userId - ユーザID
戻り値:
アクティブなセッション情報一覧
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

updateToProcessing

public void updateToProcessing(String groupId,
                               String sessionId)
                        throws ActiveSessionNotExistException,
                               ActiveSessionException
引数で指定されたアクティブなセッション情報を処理中に更新します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

updateLastResponseTime

public void updateLastResponseTime(String groupId,
                                   String sessionId)
                            throws ActiveSessionNotExistException,
                                   ActiveSessionException
引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getActiveSessionInvalidatedPage

public String getActiveSessionInvalidatedPage(SessionInfo sessionInfo,
                                              HttpServletRequest request,
                                              HttpServletResponse response)
引数で指定されたアクティブなセッション情報が無効化されたされていた場合の遷移先ページURLを取得します。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
遷移先ページ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ActiveSessionBindingListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.activesession
クラス ActiveSessionBindingListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.activesession.ActiveSessionBindingListener
すべての実装インタフェース:
EventListener, HttpSessionBindingListener, Serializable
public class ActiveSessionBindingListener
extends Object
implements HttpSessionBindingListener, Serializable

HttpSessionBindingListener を実装したアクティブなセッション情報を登録または削除するためのイベントトリガークラス。

導入されたバージョン:
6.1
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ActiveSessionBindingListener()
コンストラクタ。
ActiveSessionBindingListener(ActiveSessionInfo activeSessionInfo)
コンストラクタ。
メソッドの概要
void | valueBound(HttpSessionBindingEvent event) このオブジェクトがセッションに結びつけられた時に呼び出されます。
void | valueUnbound(HttpSessionBindingEvent event) このオブジェクトがセッションから取り外された時に呼び出されます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ActiveSessionBindingListener

public ActiveSessionBindingListener()
コンストラクタ。

ActiveSessionBindingListener

public ActiveSessionBindingListener(ActiveSessionInfo activeSessionInfo)
コンストラクタ。

メソッドの詳細

valueBound

public void valueBound(HttpSessionBindingEvent event)
このオブジェクトがセッションに結びつけられた時に呼び出されます。

アクティブなセッション情報が登録されていない場合、登録します。

定義:
インタフェース HttpSessionBindingListener 内の valueBound
関連項目:
HttpSessionBindingListener.valueBound(HttpSessionBindingEvent)

valueUnbound

public void valueUnbound(HttpSessionBindingEvent event)
このオブジェクトがセッションから取り外された時に呼び出されます。

アクティブなセッション情報を削除します。

定義:
インタフェース HttpSessionBindingListener 内の valueUnbound
関連項目:
HttpSessionBindingListener.valueUnbound(HttpSessionBindingEvent)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ActiveSessionInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.activesession
クラス ActiveSessionInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo
すべての実装インタフェース:
Serializable
public final class ActiveSessionInfo
extends Object
implements Serializable

アクティブなセッション情報操作クラス。

導入されたバージョン:
6.1
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ActiveSessionInfo()
コンストラクタ。
ActiveSessionInfo(HttpServletRequest request)
コンストラクタ。
ActiveSessionInfo(SessionInfo sessionInfo, HttpSession session, String remoteAddr, String userAgent)
コンストラクタ。
ActiveSessionInfo(SessionInfo sessionInfo, String sessionId, int expireInterval, String remoteAddr, String userAgent)
コンストラクタ。
メソッドの概要
int | getExpireInterval() クライアントのアクセスとアクセスの間に、サーブレットコンテナがこのセッションを保ち続ける最大の時間間隔を秒数で返します。
String | getInvalidateLoginType() 無効化したユーザのログインタイプを取得する。
long | getInvalidateTime() 無効化された時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を取得する。
String | getInvalidateUserId() 無効化したユーザのログインユーザIDを取得する。
long | getLastResponseTime() 最終応答時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を取得する。
String | getLoginGroup() ログイングループIDを取得する。
long | getLoginTime() ログイン時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を取得する。
String | getLoginType() ログインタイプを取得する。
String | getRemoteAddr() リクエスト元のクライアントの IP(Internet Protocol) アドレスを取得する。
String | getSessionId() セッションIDを取得する。
String | getUserAgent() ブラウザ情報を取得する。
String | getUserId() ログインユーザIDを取得する。
boolean | isActive() 現在の時刻と比較して、セッションが有効か無効か取得する。
boolean | isActive(long timeMillis) 引数で指定された時刻と比較して、セッションが有効か無効か取得する。
boolean | isProcessing() クライアントのアクセスに対して処理中がどうか取得する。
boolean | isValid() アクティブなセッション情報が有効かどうか取得します。
void | setExpireInterval(int expireInterval) 最終応答時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を設定する。
void | setInvalidateLoginType(String invalidateLoginType) 無効化したユーザのログインタイプを設定する。
void | setInvalidateTime(long invalidateTime) 無効化された時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を設定する。
void | setInvalidateUserId(String invalidateUserId) 無効化したユーザのログインユーザIDを設定する。
void | setLastResponseTime(long lastResponseTime) 最終応答時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を設定する。
void | setLoginGroup(String loginGroup) ログイングループIDを設定する。
void | setLoginTime(long loginTime) ログイン時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を設定する。
void | setLoginType(String loginType) ログインタイプを設定する。
void | setProcessing(boolean processing) クライアントのアクセスに対して処理中がどうか設定する。
void | setRemoteAddr(String remoteAddr) リクエスト元のクライアントの IP(Internet Protocol) アドレスを設定する。
void | setSessionId(String sessionId) セッションIDを設定する。
void | setUserAgent(String userAgent) ブラウザ情報を設定する。
void | setUserId(String userId) ログインユーザIDを設定する。
void | setValid(boolean valid) アクティブなセッション情報を有効・無効化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ActiveSessionInfo

public ActiveSessionInfo()
コンストラクタ。

無効なセッションとしてインスタンスを構成する。

ActiveSessionInfo

public ActiveSessionInfo(HttpServletRequest request)
                  throws NoFilterException,
                         AccessSecurityException,
                         NullPointerException
コンストラクタ。

有効なセッションとしてインスタンスを構成する。

パラメータ:
request - リクエスト
例外:
AccessSecurityException
NoFilterException - セッションが無効の場合にスローされます。
NullPointerException

ActiveSessionInfo

public ActiveSessionInfo(SessionInfo sessionInfo,
                         HttpSession session,
                         String remoteAddr,
                         String userAgent)
コンストラクタ。

有効なセッションとしてインスタンスを構成する。

パラメータ:
sessionInfo - intra-amrtセッション情報
session - HTTPセッション情報
remoteAddr - クライアントの IP アドレス
userAgent - ブラウザ情報

ActiveSessionInfo

public ActiveSessionInfo(SessionInfo sessionInfo,
                         String sessionId,
                         int expireInterval,
                         String remoteAddr,
                         String userAgent)
コンストラクタ。

有効なセッションとしてインスタンスを構成する。

パラメータ:
sessionInfo - intra-amrtセッション情報
sessionId - セッションID
expireInterval - セッションを保ち続ける最大の時間間隔(秒数)
remoteAddr - クライアントの IP アドレス
userAgent - ブラウザ情報
メソッドの詳細

isActive

public boolean isActive()
現在の時刻と比較して、セッションが有効か無効か取得する。

戻り値:
セッションが有効か無効

isActive

public boolean isActive(long timeMillis)
引数で指定された時刻と比較して、セッションが有効か無効か取得する。

パラメータ:
timeMillis - 時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)
戻り値:
セッションが有効か無効

getSessionId

public String getSessionId()
セッションIDを取得する。

戻り値:
セッションID

setSessionId

public void setSessionId(String sessionId)
セッションIDを設定する。

パラメータ:
sessionId - セッションID

getLoginType

public String getLoginType()
ログインタイプを取得する。

戻り値:
ログインタイプ
関連項目:
SecurityConstraint#LT_SUPER, SecurityConstraint#LT_GROUP, SecurityConstraint#LT_USER

setLoginType

public void setLoginType(String loginType)
ログインタイプを設定する。

パラメータ:
loginType - ログインタイプ

getLoginGroup

public String getLoginGroup()
ログイングループIDを取得する。

戻り値:
ログイングループID

setLoginGroup

public void setLoginGroup(String loginGroup)
ログイングループIDを設定する。

パラメータ:
loginGroup - ログイングループID

getUserId

public String getUserId()
ログインユーザIDを取得する。

戻り値:
ログインユーザID

setUserId

public void setUserId(String userId)
ログインユーザIDを設定する。

パラメータ:
userId - ログインユーザID

getLoginTime

public long getLoginTime()
ログイン時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を取得する。

戻り値:
ログイン時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)

setLoginTime

public void setLoginTime(long loginTime)
ログイン時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を設定する。

パラメータ:
loginTime - ログイン時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)

getLastResponseTime

public long getLastResponseTime()
最終応答時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を取得する。

戻り値:
最終応答時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)

setExpireInterval

public void setExpireInterval(int expireInterval)
最終応答時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を設定する。

パラメータ:
expireInterval - 最終応答時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)

setLastResponseTime

public void setLastResponseTime(long lastResponseTime)
最終応答時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を設定する。

getExpireInterval

public int getExpireInterval()
クライアントのアクセスとアクセスの間に、サーブレットコンテナがこのセッションを保ち続ける最大の時間間隔を秒数で返します。

負の値は、セッションがタイムアウトにならないことを示します。

戻り値:
このセッションが、クライアントの要求と要求との間で保持され続ける秒数を指定する整数
関連項目:
HttpSession.getMaxInactiveInterval()

getRemoteAddr

public String getRemoteAddr()
リクエスト元のクライアントの IP(Internet Protocol) アドレスを取得する。

戻り値:
リクエスト元のクライアントの IP(Internet Protocol) アドレス
関連項目:
ServletRequest#getRemoteAddr()

setRemoteAddr

public void setRemoteAddr(String remoteAddr)
リクエスト元のクライアントの IP(Internet Protocol) アドレスを設定する。

パラメータ:
remoteAddr - リクエスト元のクライアントの IP(Internet Protocol) アドレス

getUserAgent

public String getUserAgent()
ブラウザ情報を取得する。

このブラウザ情報は ServletRequest#getHeader("User-Agent") で取得できる値を想定する。

戻り値:
ブラウザ情報

setUserAgent

public void setUserAgent(String userAgent)
ブラウザ情報を設定する。

パラメータ:
userAgent - ブラウザ情報

isProcessing

public boolean isProcessing()
クライアントのアクセスに対して処理中がどうか取得する。

戻り値:
処理中がどうか

setProcessing

public void setProcessing(boolean processing)
クライアントのアクセスに対して処理中がどうか設定する。

パラメータ:
processing - 処理中がどうか

setValid

public void setValid(boolean valid)
アクティブなセッション情報を有効・無効化します。

パラメータ:
valid - 有効(true) or 無効(false)

isValid

public boolean isValid()
アクティブなセッション情報が有効かどうか取得します。

getInvalidateLoginType

public String getInvalidateLoginType()
無効化したユーザのログインタイプを取得する。

戻り値:
無効化したユーザのログインタイプ
関連項目:
SecurityConstraint#LT_SUPER, SecurityConstraint#LT_GROUP, SecurityConstraint#LT_USER

setInvalidateLoginType

public void setInvalidateLoginType(String invalidateLoginType)
無効化したユーザのログインタイプを設定する。

関連項目:
SecurityConstraint#LT_SUPER, SecurityConstraint#LT_GROUP, SecurityConstraint#LT_USER

getInvalidateUserId

public String getInvalidateUserId()
無効化したユーザのログインユーザIDを取得する。

戻り値:
無効化したユーザのログインユーザID

setInvalidateUserId

public void setInvalidateUserId(String invalidateUserId)
無効化したユーザのログインユーザIDを設定する。

getInvalidateTime

public long getInvalidateTime()
無効化された時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を取得する。

戻り値:
無効化された時刻

setInvalidateTime

public void setInvalidateTime(long invalidateTime)
無効化された時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を設定する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ActiveSessionManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.activesession
クラス ActiveSessionManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager
public class ActiveSessionManager
extends Object

アクティブセッション情報管理マネージャクラス。

アクティブなセッション情報に対して重複ログインを管理するためのクラス

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
static String | DEFAULT_ACTIVE_SESSION_ACCESSOR
static String | DEFAULT_SP_ACTIVE_SESSION_BINDING_LISTENER
コンストラクタの概要
ActiveSessionManager()
コンストラクタ。
メソッドの概要
void | addActiveSessionInfo(ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報を登録します。
int | count(String groupId) アクティブなすべてのセッション数を取得します。
int | count(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。
int | count(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなすべてのセッション数を取得します。
void | destory(String groupId) アクティブなセッション情報をすべて破棄します。
NavigatorInfo | distinctNavigator(String userAgent) 引数で指定されたユーザエージェント情報から判別してナビゲータ情報を取得します。
String | getActiveSessionBindingListenerSessionName() アクティブなセッション情報を登録・削除するために使用するセッション名を取得します。
ActiveSessionInfo | getActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | getActiveSessionInfos(String groupId) アクティブなすべてのセッション情報を取得します。
ActiveSessionInfo[] | getActiveSessionInfos(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | getActiveSessionInfos(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなセッション情報を取得します。
String | getActiveSessionInvalidatedPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 引数で指定されたアクティブなセッション情報が無効化されたされていた場合の遷移先ページURLを取得します。
ActiveSessionInfo | getInvalidatedActiveSessionInfo(String groupId, String sessionId) 無効化されたアクティブなセッション情報を取得します。
boolean | hasActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が存在するかチェックします。
void | invalidate(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
boolean | isLogined(String groupId, String loginType, String userId) 引数で指定されたユーザがログインしているかどうか判別します。
boolean | isObservable(String groupId) アクティブセッションの監視を行うかどうか取得します。
boolean | isValid(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
void | removeActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を削除します。
ActiveSessionInfo[] | searchActiveSessionInfosByUserId(String groupId, String loginType, String userId) 引数で指定されたユーザ条件からアクティブなセッション情報を検索します。
void | updateLastResponseTime(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。
void | updateToProcessing(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報を処理中に更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_SP_ACTIVE_SESSION_BINDING_LISTENER

public static final String DEFAULT_SP_ACTIVE_SESSION_BINDING_LISTENER
関連項目:
定数フィールド値

DEFAULT_ACTIVE_SESSION_ACCESSOR

public static final String DEFAULT_ACTIVE_SESSION_ACCESSOR
関連項目:
定数フィールド値
コンストラクタの詳細

ActiveSessionManager

public ActiveSessionManager()
コンストラクタ。

メソッドの詳細

isObservable

public boolean isObservable(String groupId)
アクティブセッションの監視を行うかどうか取得します。

パラメータ:
groupId - ログイングループID
戻り値:
アクティブセッションの監視を行う場合 true
導入されたバージョン:
6.1.6

addActiveSessionInfo

public void addActiveSessionInfo(ActiveSessionInfo activeSessionInfo)
                          throws ActiveSessionException
引数で指定されたアクティブなセッション情報を登録します。

パラメータ:
activeSessionInfo - アクティブなセッション情報
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

removeActiveSessionInfo

public void removeActiveSessionInfo(String groupId,
                                    String sessionId)
                             throws ActiveSessionNotExistException,
                                    ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報を削除します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

destory

public void destory(String groupId)
             throws ActiveSessionException
アクティブなセッション情報をすべて破棄します。

パラメータ:
groupId - ログイングループID
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

invalidate

public void invalidate(String groupId,
                       String sessionId)
                throws ActiveSessionNotExistException,
                       ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報を無効化します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

isValid

public boolean isValid(String groupId,
                       String sessionId)
                throws ActiveSessionNotExistException,
                       ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
戻り値:
アクティブなセッション情報が有効かどうか
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

isLogined

public boolean isLogined(String groupId,
                         String loginType,
                         String userId)
                  throws ActiveSessionException
引数で指定されたユーザがログインしているかどうか判別します。

パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
userId - ユーザID
戻り値:
ログインしている場合 true、ログインしていない場合 false
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

count

public int count(String groupId)
          throws ActiveSessionException
アクティブなすべてのセッション数を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
アクティブなすべてのセッション数
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

count

public int count(String groupId,
                 String loginType,
                 String userId)
          throws ActiveSessionException
引数で指定されたユーザのアクティブなすべてのセッション数を取得します。

パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
userId - ユーザID
戻り値:
アクティブなすべてのセッション数
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

count

public int count(String groupId,
                 String loginType)
          throws ActiveSessionException
引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。

パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
戻り値:
アクティブなすべてのセッション数
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getActiveSessionInfos

public ActiveSessionInfo[] getActiveSessionInfos(String groupId)
                                          throws ActiveSessionException
アクティブなすべてのセッション情報を取得します。

1件も存在しない場合、戻り値は空の配列となります。 配列の並び順はログイン時刻の昇順となります。

パラメータ:
groupId - ログイングループID
戻り値:
アクティブなセッション情報一覧
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getActiveSessionInfo

public ActiveSessionInfo getActiveSessionInfo(String groupId,
                                              String sessionId)
                                       throws ActiveSessionNotExistException,
                                              ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報を取得します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
戻り値:
アクティブなセッション情報
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

hasActiveSessionInfo

public boolean hasActiveSessionInfo(String groupId,
                                    String sessionId)
                             throws ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報が存在するかチェックします。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
戻り値:
アクティブなセッション情報が存在する場合 true、存在しない場合 false
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getInvalidatedActiveSessionInfo

public ActiveSessionInfo getInvalidatedActiveSessionInfo(String groupId,
                                                         String sessionId)
                                                  throws ActiveSessionNotExistException,
                                                         ActiveSessionException
無効化されたアクティブなセッション情報を取得します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
戻り値:
アクティブなセッション情報
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getActiveSessionInfos

public ActiveSessionInfo[] getActiveSessionInfos(String groupId,
                                                 String loginType,
                                                 String userId)
                                          throws ActiveSessionException
引数で指定されたユーザのアクティブなセッション情報を取得します。

1件も存在しない場合、戻り値は空の配列となります。
配列の並び順はログイン時刻の昇順となります。

パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
userId - ユーザID
戻り値:
アクティブなセッション情報一覧
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getActiveSessionInfos

public ActiveSessionInfo[] getActiveSessionInfos(String groupId,
                                                 String loginType)
                                          throws ActiveSessionException
引数で指定されたログインタイプのアクティブなセッション情報を取得します。

1件も存在しない場合、戻り値は空の配列となります。
配列の並び順はログイン時刻の昇順となります。

パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
戻り値:
アクティブなセッション情報一覧
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

searchActiveSessionInfosByUserId

public ActiveSessionInfo[] searchActiveSessionInfosByUserId(String groupId,
                                                            String loginType,
                                                            String userId)
                                                     throws ActiveSessionException
引数で指定されたユーザ条件からアクティブなセッション情報を検索します。

ユーザIDに検索条件を指定します。
1件も存在しない場合、戻り値は空の配列となります。
配列の並び順はログイン時刻の昇順となります。

パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
userId - ユーザID
戻り値:
アクティブなセッション情報一覧
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

updateToProcessing

public void updateToProcessing(String groupId,
                               String sessionId)
                        throws ActiveSessionNotExistException,
                               ActiveSessionException
引数で指定されたアクティブなセッション情報を処理中に更新します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

updateLastResponseTime

public void updateLastResponseTime(String groupId,
                                   String sessionId)
                            throws ActiveSessionNotExistException,
                                   ActiveSessionException
引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getActiveSessionInvalidatedPage

public String getActiveSessionInvalidatedPage(SessionInfo sessionInfo,
                                              HttpServletRequest request,
                                              HttpServletResponse response)
引数で指定されたアクティブなセッション情報が無効化されたされていた場合の遷移先ページURLを取得します。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
遷移先ページ

getActiveSessionBindingListenerSessionName

public String getActiveSessionBindingListenerSessionName()
アクティブなセッション情報を登録・削除するために使用するセッション名を取得します。

戻り値:
アクティブなセッション情報を登録・削除するために使用するセッション名

distinctNavigator

public NavigatorInfo distinctNavigator(String userAgent)
引数で指定されたユーザエージェント情報から判別してナビゲータ情報を取得します。

パラメータ:
userAgent - ユーザエージェント情報
戻り値:
ナビゲータ情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GroupActiveSessionRegister (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.activesession
クラス GroupActiveSessionRegister

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.activesession.GroupActiveSessionRegister
すべての実装インタフェース:
SuperCertificationListener
public class GroupActiveSessionRegister
extends Object
implements SuperCertificationListener

管理者ログイン認証リスナー実装クラス。

グループ管理者の認証成功時、アクティブなセッション情報を登録します。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
GroupActiveSessionRegister()
メソッドの概要
void | doCertification(int certificationResult, LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者の認証後にコールされるメソッドです。
void | init(Map params) 管理者ログイン認証リスナーの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GroupActiveSessionRegister

public GroupActiveSessionRegister()
メソッドの詳細

init

public void init(Map params)
管理者ログイン認証リスナーの初期化を行います。

管理者ログイン認証リスナーのインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース SuperCertificationListener 内の init
パラメータ:
params - 初期化パラメータのマップ

doCertification

public void doCertification(int certificationResult,
                            LoginInfo loginInfo,
                            SuperUser user,
                            HttpServletRequest request,
                            HttpServletResponse response)
管理者の認証後にコールされるメソッドです。

グループ管理者の認証成功時、アクティブなセッション情報を登録します。

定義:
インタフェース SuperCertificationListener 内の doCertification
パラメータ:
certificationResult - 認証結果
認証成功 | SecurityConstraint.CR_OK
ユーザ不一致 | SecurityConstraint.CR_NO_USER
認証失敗(パスワード不一致) | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
loginInfo - ログイン情報
user - 管理者情報
request - サーブレットリクエスト
response - サーブレットレスポンス
導入されたバージョン:
6.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NavigatorInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.activesession
クラス NavigatorInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.activesession.NavigatorInfo
public class NavigatorInfo
extends Object

ナビゲータ情報クラス。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
NavigatorInfo()
コンストラクタ。
メソッドの概要
String | getAppName() ブラウザ名を取得します。
void | setAppName(String appName) ブラウザ名を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NavigatorInfo

public NavigatorInfo()
コンストラクタ。

メソッドの詳細

getAppName

public String getAppName()
ブラウザ名を取得します。

戻り値:
ブラウザ名

setAppName

public void setAppName(String appName)
ブラウザ名を取得します。

パラメータ:
appName - ブラウザ名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.activesession (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.security.activesession
インタフェース
ActiveSessionAccessor
クラス
ActiveSessionBindingListener
ActiveSessionInfo
ActiveSessionManager
GroupActiveSessionRegister
NavigatorInfo
StandardActiveSessionAccessor
UserActiveSessionRegister


jp.co.intra_mart.foundation.security.activesession (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.activesession

インタフェースの概要
ActiveSessionAccessor アクティブなセッション情報操作インターフェース。

クラスの概要
ActiveSessionBindingListener | HttpSessionBindingListener を実装したアクティブなセッション情報を登録または削除するためのイベントトリガークラス。
ActiveSessionInfo | アクティブなセッション情報操作クラス。
ActiveSessionManager | アクティブセッション情報管理マネージャクラス。
GroupActiveSessionRegister | 管理者ログイン認証リスナー実装クラス。
NavigatorInfo | ナビゲータ情報クラス。
StandardActiveSessionAccessor | アクティブなセッション情報操作実装クラス。
UserActiveSessionRegister | ユーザログイン認証リスナー実装クラス。


jp.co.intra_mart.foundation.security.activesession クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.activesession の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.activesession.ActiveSessionBindingListener (implements javax.servlet.http.HttpSessionBindingListener, java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager
    • class jp.co.intra_mart.foundation.security.activesession.GroupActiveSessionRegister (implements jp.co.intra_mart.foundation.security.certification.SuperCertificationListener)
    • class jp.co.intra_mart.foundation.security.activesession.NavigatorInfo
    • class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor (implements jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor)
    • class jp.co.intra_mart.foundation.security.activesession.UserActiveSessionRegister (implements jp.co.intra_mart.foundation.security.certification.UserCertificationListener)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor


パッケージ jp.co.intra_mart.foundation.security.activesession の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.activesession の使用

jp.co.intra_mart.foundation.security.activesession を使用しているパッケージ
jp.co.intra_mart.foundation.security.activesession
jp.co.intra_mart.foundation.security.duplication

jp.co.intra_mart.foundation.security.activesession により使用される jp.co.intra_mart.foundation.security.activesession のクラス
ActiveSessionAccessor
アクティブなセッション情報操作インターフェース。
ActiveSessionInfo
アクティブなセッション情報操作クラス。
NavigatorInfo
ナビゲータ情報クラス。

jp.co.intra_mart.foundation.security.duplication により使用される jp.co.intra_mart.foundation.security.activesession のクラス
ActiveSessionInfo
アクティブなセッション情報操作クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardActiveSessionAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.activesession
クラス StandardActiveSessionAccessor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor
すべての実装インタフェース:
ActiveSessionAccessor
public class StandardActiveSessionAccessor
extends Object
implements ActiveSessionAccessor

アクティブなセッション情報操作実装クラス。

アクティブなセッション情報操作のための実装クラス
本クラスは、任意のログイングループのグループ管理者および一般ユーザ用に使用されることを期待する。

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
static String | DEFAULT_ACCESS_SECURITY_PAGE_PROVIDER_CLASS
static String | DEFAULT_PAGE_LOCATION
コンストラクタの概要
StandardActiveSessionAccessor()
メソッドの概要
void | addActiveSessionInfo(ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報を登録します。
int | count(String groupId) アクティブなすべてのセッション数を取得します。
int | count(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。
int | count(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなすべてのセッション数を取得します。
void | destory(String groupId) アクティブなセッション情報をすべて破棄します。
boolean | exists(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が存在するかどうか取得します。
ActiveSessionInfo | getActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | getActiveSessionInfos(String groupId) アクティブなすべてのセッション情報を取得します。
ActiveSessionInfo[] | getActiveSessionInfos(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | getActiveSessionInfos(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなセッション情報を取得します。
String | getActiveSessionInvalidatedPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 引数で指定されたアクティブなセッション情報が無効化されたされていた場合の遷移先ページURLを取得します。
ActiveSessionInfo | getInvalidatedActiveSessionInfo(String groupId, String sessionId) 無効化されたアクティブなセッション情報を取得します。
void | init(Node defaultNode, Node node) 設定ファイル conf/active-session-config.xml の情報を基に初期化します。
void | invalidate(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
boolean | isObservable() アクティブセッションの監視を行うかどうか取得します。
boolean | isValid(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
void | removeActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を削除します。
ActiveSessionInfo[] | searchActiveSessionInfosByUserId(String groupId, String loginType, String userId) 引数で指定されたユーザ条件からアクティブなセッション情報を検索します。
void | updateLastResponseTime(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。
void | updateToProcessing(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報を処理中に更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_ACCESS_SECURITY_PAGE_PROVIDER_CLASS

public static final String DEFAULT_ACCESS_SECURITY_PAGE_PROVIDER_CLASS
関連項目:
定数フィールド値

DEFAULT_PAGE_LOCATION

public static final String DEFAULT_PAGE_LOCATION
関連項目:
定数フィールド値
コンストラクタの詳細

StandardActiveSessionAccessor

public StandardActiveSessionAccessor()
メソッドの詳細

init

public void init(Node defaultNode,
                 Node node)
          throws ActiveSessionException
設定ファイル conf/active-session-config.xml の情報を基に初期化します。

定義:
インタフェース ActiveSessionAccessor 内の init
パラメータ:
defaultNode - デフォルトノード
node - デフォルトノード
例外:
ActiveSessionException - 初期化処理で例外が発生した場合にスローされます。

isObservable

public boolean isObservable()
アクティブセッションの監視を行うかどうか取得します。

定義:
インタフェース ActiveSessionAccessor 内の isObservable
戻り値:
アクティブセッションの監視を行う場合 true
導入されたバージョン:
6.1.6

addActiveSessionInfo

public void addActiveSessionInfo(ActiveSessionInfo activeSessionInfo)
                          throws ActiveSessionException
引数で指定されたアクティブなセッション情報を登録します。

定義:
インタフェース ActiveSessionAccessor 内の addActiveSessionInfo
パラメータ:
activeSessionInfo - アクティブなセッション情報
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローされます。

removeActiveSessionInfo

public void removeActiveSessionInfo(String groupId,
                                    String sessionId)
                             throws ActiveSessionNotExistException,
                                    ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報を削除します。

定義:
インタフェース ActiveSessionAccessor 内の removeActiveSessionInfo
パラメータ:
groupId - ログイングループID
sessionId - セッションID
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローされます。

destory

public void destory(String groupId)
             throws ActiveSessionException
アクティブなセッション情報をすべて破棄します。

定義:
インタフェース ActiveSessionAccessor 内の destory
パラメータ:
groupId - ログイングループID
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローされます。

invalidate

public void invalidate(String groupId,
                       String sessionId)
                throws ActiveSessionNotExistException,
                       ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報を無効化します。

定義:
インタフェース ActiveSessionAccessor 内の invalidate
パラメータ:
groupId - ログイングループID
sessionId - セッションID
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローされます。

isValid

public boolean isValid(String groupId,
                       String sessionId)
                throws ActiveSessionNotExistException,
                       ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。

定義:
インタフェース ActiveSessionAccessor 内の isValid
パラメータ:
groupId - ログイングループID
sessionId - セッションID
戻り値:
アクティブなセッション情報が有効かどうか
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローされます。

count

public int count(String groupId)
          throws ActiveSessionException
アクティブなすべてのセッション数を取得します。

定義:
インタフェース ActiveSessionAccessor 内の count
パラメータ:
groupId - ログイングループID
戻り値:
アクティブなすべてのセッション数
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローされます。

count

public int count(String groupId,
                 String loginType,
                 String userId)
          throws ActiveSessionException
引数で指定されたユーザのアクティブなすべてのセッション数を取得します。

定義:
インタフェース ActiveSessionAccessor 内の count
パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
userId - ユーザID
戻り値:
アクティブなすべてのセッション数
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローされます。

count

public int count(String groupId,
                 String loginType)
          throws ActiveSessionException
引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。

定義:
インタフェース ActiveSessionAccessor 内の count
パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
戻り値:
アクティブなすべてのセッション数
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

exists

public boolean exists(String groupId,
                      String sessionId)
               throws ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報が存在するかどうか取得します。

定義:
インタフェース ActiveSessionAccessor 内の exists
パラメータ:
groupId - ログイングループID
sessionId - セッションID
戻り値:
アクティブなセッション情報が存在するかどうか
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getActiveSessionInfos

public ActiveSessionInfo[] getActiveSessionInfos(String groupId)
                                          throws ActiveSessionException
アクティブなすべてのセッション情報を取得します。

1件も存在しない場合、戻り値は空の配列となります。 配列の並び順はログイン時刻の昇順となります。

定義:
インタフェース ActiveSessionAccessor 内の getActiveSessionInfos
パラメータ:
groupId - ログイングループID
戻り値:
アクティブなセッション情報一覧
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローされます。

getActiveSessionInfo

public ActiveSessionInfo getActiveSessionInfo(String groupId,
                                              String sessionId)
                                       throws ActiveSessionNotExistException,
                                              ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報を取得します。

定義:
インタフェース ActiveSessionAccessor 内の getActiveSessionInfo
パラメータ:
groupId - ログイングループID
sessionId - セッションID
戻り値:
アクティブなセッション情報
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローされます。

getInvalidatedActiveSessionInfo

public ActiveSessionInfo getInvalidatedActiveSessionInfo(String groupId,
                                                         String sessionId)
                                                  throws ActiveSessionNotExistException,
                                                         ActiveSessionException
無効化されたアクティブなセッション情報を取得します。

定義:
インタフェース ActiveSessionAccessor 内の getInvalidatedActiveSessionInfo
パラメータ:
groupId - ログイングループID
sessionId - セッションID
戻り値:
アクティブなセッション情報
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getActiveSessionInfos

public ActiveSessionInfo[] getActiveSessionInfos(String groupId,
                                                 String loginType,
                                                 String userId)
                                          throws ActiveSessionException
引数で指定されたユーザのアクティブなセッション情報を取得します。

1件も存在しない場合、戻り値は空の配列となります。
配列の並び順はログイン時刻の昇順となります。

定義:
インタフェース ActiveSessionAccessor 内の getActiveSessionInfos
パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
userId - ユーザID
戻り値:
アクティブなセッション情報一覧
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローされます。

getActiveSessionInfos

public ActiveSessionInfo[] getActiveSessionInfos(String groupId,
                                                 String loginType)
                                          throws ActiveSessionException
引数で指定されたログインタイプのアクティブなセッション情報を取得します。

1件も存在しない場合、戻り値は空の配列となります。
配列の並び順はログイン時刻の昇順となります。

定義:
インタフェース ActiveSessionAccessor 内の getActiveSessionInfos
パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
戻り値:
アクティブなセッション情報一覧
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

searchActiveSessionInfosByUserId

public ActiveSessionInfo[] searchActiveSessionInfosByUserId(String groupId,
                                                            String loginType,
                                                            String userId)
                                                     throws ActiveSessionException
引数で指定されたユーザ条件からアクティブなセッション情報を検索します。

ユーザIDに検索条件を指定します。
1件も存在しない場合、戻り値は空の配列となります。
配列の並び順はログイン時刻の昇順となります。

定義:
インタフェース ActiveSessionAccessor 内の searchActiveSessionInfosByUserId
パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
userId - ユーザID
戻り値:
アクティブなセッション情報一覧
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

updateToProcessing

public void updateToProcessing(String groupId,
                               String sessionId)
                        throws ActiveSessionNotExistException,
                               ActiveSessionException
引数で指定されたアクティブなセッション情報を処理中に更新します。

定義:
インタフェース ActiveSessionAccessor 内の updateToProcessing
パラメータ:
groupId - ログイングループID
sessionId - セッションID
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローされます。

updateLastResponseTime

public void updateLastResponseTime(String groupId,
                                   String sessionId)
                            throws ActiveSessionNotExistException,
                                   ActiveSessionException
引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。

定義:
インタフェース ActiveSessionAccessor 内の updateLastResponseTime
パラメータ:
groupId - ログイングループID
sessionId - セッションID
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローされます。

getActiveSessionInvalidatedPage

public String getActiveSessionInvalidatedPage(SessionInfo sessionInfo,
                                              HttpServletRequest request,
                                              HttpServletResponse response)
引数で指定されたアクティブなセッション情報が無効化されたされていた場合の遷移先ページURLを取得します。

定義:
インタフェース ActiveSessionAccessor 内の getActiveSessionInvalidatedPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
遷移先ページ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserActiveSessionRegister (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.activesession
クラス UserActiveSessionRegister

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.activesession.UserActiveSessionRegister
すべての実装インタフェース:
UserCertificationListener
public class UserActiveSessionRegister
extends Object
implements UserCertificationListener

ユーザログイン認証リスナー実装クラス。

認証成功時、アクティブなセッション情報を登録します。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
UserActiveSessionRegister()
メソッドの概要
void | doCertification(int certificationResult, LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザの認証後にコールされるメソッドです。
void | init(Map params) ユーザログイン認証リスナーの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserActiveSessionRegister

public UserActiveSessionRegister()
メソッドの詳細

init

public void init(Map params)
ユーザログイン認証リスナーの初期化を行います。

ユーザログイン認証リスナーのインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース UserCertificationListener 内の init
パラメータ:
params - 初期化パラメータのマップ

doCertification

public void doCertification(int certificationResult,
                            LoginInfo loginInfo,
                            Account user,
                            HttpServletRequest request,
                            HttpServletResponse response)
ユーザの認証後にコールされるメソッドです。

認証成功時、アクティブなセッション情報を登録します。

定義:
インタフェース UserCertificationListener 内の doCertification
パラメータ:
certificationResult - 認証結果
認証成功 | SecurityConstraint.CR_OK
認証失敗 | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
loginInfo - ログイン情報
user - ユーザ情報
request - サーブレットリクエスト
response - サーブレットレスポンス
導入されたバージョン:
6.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.admin.SuperUser の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.admin.SuperUser の使用

SuperUser を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession |
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security での SuperUser の使用

SuperUser を返す jp.co.intra_mart.foundation.security のメソッド
 SuperUser SystemManager.getSuperUser()
システム管理者情報を取得します。

SuperUser 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | SystemManager.addSuperUser(SuperUser superUser) システム管理者情報を新規に作成します。
void | SystemManager.updateSuperUser(SuperUser superUser) システム管理者情報を更新します。

jp.co.intra_mart.foundation.security.activesession での SuperUser の使用

SuperUser 型のパラメータを持つ jp.co.intra_mart.foundation.security.activesession のメソッド
 void GroupActiveSessionRegister.doCertification(int certificationResult, LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response)
管理者の認証後にコールされるメソッドです。

jp.co.intra_mart.foundation.security.admin での SuperUser の使用

SuperUser を返す jp.co.intra_mart.foundation.security.admin のメソッド
SuperUser | SuperUserReaderDecorator.doDecoration(SuperUser superUser) システム管理者情報をデータストアからの読み込み直後にコールされます。
SuperUser | SuperUserAccessor.getSuperUser() システム管理者情報を取得します。

SuperUser 型のパラメータを持つ jp.co.intra_mart.foundation.security.admin のメソッド
SuperUser | SuperUserReaderDecorator.doDecoration(SuperUser superUser) システム管理者情報をデータストアからの読み込み直後にコールされます。
void | SuperUserQueryWriterListener.queryCreate(SuperUser superUser) システム管理者情報をデータストアに作成する直前にコールされます。
void | SuperUserQueryWriterListener.queryUpdate(SuperUser superUser) システム管理者情報をデータストアに更新する直前にコールされます。
void | SuperUserPostWriterListener.postCreate(SuperUser superUser) システム管理者情報をデータストアに作成した直後にコールされます。
void | SuperUserPostWriterListener.postUpdate(SuperUser superUser) システム管理者情報をデータストアに更新した直後にコールされます。
void | SuperUserAccessor.insertSuperUser(SuperUser superUser) システム管理者情報を新規追加します。
void | SuperUserAccessor.updateSuperUser(SuperUser superUser) システム管理者情報を更新します。

jp.co.intra_mart.foundation.security.certification での SuperUser の使用

SuperUser 型のパラメータを持つ jp.co.intra_mart.foundation.security.certification のメソッド
int | SuperUserNoCertification.certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証します。
void | SuperCertificationListener.doCertification(int certificationResult, LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者の認証後にコールされるメソッドです。
int | SuperCertification.certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証する。
int | StandardSuperUserCertification.certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証します。

jp.co.intra_mart.foundation.security.group での SuperUser の使用

SuperUser を返す jp.co.intra_mart.foundation.security.group のメソッド
SuperUser | LoginGroupManager.getSuperUser(String groupId) グループ管理者情報を取得します。
SuperUser | GroupSuperUserReaderDecorator.doDecoration(String groupId, SuperUser superUser) アカウントをデータストアからの読み込み直後にコールされます。
SuperUser | GroupSuperUserAccessor.getSuperUser(String groupId) グループ管理者情報を取得します。

SuperUser 型のパラメータを持つ jp.co.intra_mart.foundation.security.group のメソッド
void | LoginGroupManager.addSuperUser(String groupId, SuperUser superUser) グループ管理者を新規追加します。
void | LoginGroupManager.updateSuperUser(String groupId, SuperUser superUser) グループ管理者情報を更新します。
SuperUser | GroupSuperUserReaderDecorator.doDecoration(String groupId, SuperUser superUser) アカウントをデータストアからの読み込み直後にコールされます。
void | GroupSuperUserQueryWriterListener.queryCreate(String groupId, SuperUser superUser) グループ管理者情報をデータストアに作成する直前にコールされます。
void | GroupSuperUserQueryWriterListener.queryUpdate(String groupId, SuperUser superUser) グループ管理者情報をデータストアに更新する直前にコールされます。
void | GroupSuperUserPostWriterListener.postCreate(String groupId, SuperUser superUser) グループ管理者情報をデータストアに作成した直後にコールされます。
void | GroupSuperUserPostWriterListener.postUpdate(String groupId, SuperUser superUser) グループ管理者情報をデータストアに更新した直後にコールされます。
void | GroupSuperUserAccessor.insertSuperUser(String groupId, SuperUser superUser) グループ管理者情報を新規追加します。
void | GroupSuperUserAccessor.updateSuperUser(String groupId, SuperUser superUser) グループ管理者情報を更新します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.admin.SuperUserAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.admin.SuperUserAccessor の使用

jp.co.intra_mart.foundation.security.admin.SuperUserAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener の使用

jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener の使用

jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator の使用

jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.security.admin (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.security.admin
インタフェース
SuperUserAccessor
SuperUserPostWriterListener
SuperUserQueryWriterListener
SuperUserReaderDecorator
クラス
SuperUser


jp.co.intra_mart.foundation.security.admin (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.admin

システム管理者に関連するクラスを提供します。

参照:
説明

インタフェースの概要
SuperUserAccessor | システム管理者アクセッサインタフェース。
SuperUserPostWriterListener | システム管理者情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
SuperUserQueryWriterListener | システム管理者情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
SuperUserReaderDecorator | システム管理者情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

クラスの概要
SuperUser スーパーユーザ・モデルインタフェース。

パッケージ jp.co.intra_mart.foundation.security.admin の説明

システム管理者に関連するクラスを提供します。


jp.co.intra_mart.foundation.security.admin クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.admin の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.admin.SuperUser (implements jp.co.intra_mart.foundation.security.LocaleProvider, java.io.Serializable)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor
  • interface jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener
  • interface jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator


パッケージ jp.co.intra_mart.foundation.security.admin の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.admin の使用

jp.co.intra_mart.foundation.security.admin を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession |
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security により使用される jp.co.intra_mart.foundation.security.admin のクラス
SuperUser
スーパーユーザ・モデルインタフェース。

jp.co.intra_mart.foundation.security.activesession により使用される jp.co.intra_mart.foundation.security.admin のクラス
SuperUser
スーパーユーザ・モデルインタフェース。

jp.co.intra_mart.foundation.security.admin により使用される jp.co.intra_mart.foundation.security.admin のクラス
SuperUser
スーパーユーザ・モデルインタフェース。

jp.co.intra_mart.foundation.security.certification により使用される jp.co.intra_mart.foundation.security.admin のクラス
SuperUser
スーパーユーザ・モデルインタフェース。

jp.co.intra_mart.foundation.security.group により使用される jp.co.intra_mart.foundation.security.admin のクラス
SuperUser
スーパーユーザ・モデルインタフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SuperUser (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.admin
クラス SuperUser

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.admin.SuperUser
すべての実装インタフェース:
LocaleProvider, Serializable
public class SuperUser
extends Object
implements LocaleProvider, Serializable

スーパーユーザ・モデルインタフェース。 スーパーユーザのデータモデルインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
SystemManager, 直列化された形式

コンストラクタの概要
protected | SuperUser() コンストラクタ。
 | SuperUser(String userId) コンストラクタ。
メソッドの概要
boolean | equals(Object superUser) オブジェクトの比較。
String | getEncoding() エンコーディングの取得。
Locale | getLocale() ロケールの取得。
String | getMailAddress() メールアドレス取得。
String | getPassword() パスワード取得。
String | getTelNo() 電話番号取得。
String | getUserId() ユーザID取得。
int | hashCode() ハッシュコード値取得。
void | setEncoding(String encoding) エンコーディングの設定。
void | setLocale(Locale locale) ロケールの設定。
void | setMailAddress(String mailAddress) メールアドレス設定。
void | setPassword(String password) パスワード設定。
void | setTelNo(String telNo) 電話番号設定。
void | setUserId(String id) ユーザID設定。
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SuperUser

protected SuperUser()
コンストラクタ。

SuperUser

public SuperUser(String userId)
コンストラクタ。

パラメータ:
userId - スーパーユーザのユーザID
メソッドの詳細

equals

public boolean equals(Object superUser)
オブジェクトの比較。

指定されたオブジェクトとこのモデルが等しいかどうかを比較します。

パラメータ:
superUser - モデルと等しいかどうかを比較するオブジェクト
戻り値:
指定されたオブジェクトがこのモデルと等しい場合は true
関連項目:
Object.equals(Object)

getEncoding

public String getEncoding()
エンコーディングの取得。

定義:
インタフェース LocaleProvider 内の getEncoding
戻り値:
エンコード
関連項目:
LocaleProvider.getEncoding()

getLocale

public Locale getLocale()
ロケールの取得。

定義:
インタフェース LocaleProvider 内の getLocale
戻り値:
ロケール
関連項目:
LocaleProvider.getLocale()

getMailAddress

public String getMailAddress()
メールアドレス取得。

スーパーユーザのメールアドレスを取得します

戻り値:
メールアドレス
関連項目:
getMailAddress()

getPassword

public String getPassword()
パスワード取得。

スーパーユーザのパスワードを取得します

戻り値:
パスワード
関連項目:
getPassword()

getTelNo

public String getTelNo()
電話番号取得。

スーパーユーザの電話番号を取得します

戻り値:
電話番号
関連項目:
getTelNo()

getUserId

public String getUserId()
ユーザID取得。

スーパーユーザのユーザIDを取得します

戻り値:
ユーザID
関連項目:
getUserId()

hashCode

public int hashCode()
ハッシュコード値取得。

このモデルのハッシュコード値を返します

戻り値:
ハッシュコード
関連項目:
Object.hashCode()

setEncoding

public void setEncoding(String encoding)
エンコーディングの設定。

パラメータ:
encoding - エンコーディング
関連項目:
setEncoding(String)

setLocale

public void setLocale(Locale locale)
ロケールの設定。

パラメータ:
locale - ロケール
関連項目:
setLocale(Locale)

setMailAddress

public void setMailAddress(String mailAddress)
メールアドレス設定。

スーパーユーザのメールアドレスを設定します

パラメータ:
mailAddress - メールアドレス
関連項目:
setMailAddress(String)

setPassword

public void setPassword(String password)
パスワード設定。

スーパーユーザのパスワードを設定します

パラメータ:
password - パスワード
関連項目:
setPassword(String)

setTelNo

public void setTelNo(String telNo)
電話番号設定。

スーパーユーザの電話番号を設定します

パラメータ:
telNo - 電話番号
関連項目:
setTelNo(String)

setUserId

public void setUserId(String id)
ユーザID設定。

スーパーユーザのユーザIDを設定します

パラメータ:
id - ユーザID
関連項目:
setUserId(String)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SuperUserAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.admin
インタフェース SuperUserAccessor

public interface SuperUserAccessor

システム管理者アクセッサインタフェース。

システム管理者情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
SuperUser | getSuperUser() システム管理者情報を取得します。
void | init(Map params) システム管理者アクセッサを初期化します。
void | insertSuperUser(SuperUser superUser) システム管理者情報を新規追加します。
void | updateSuperUser(SuperUser superUser) システム管理者情報を更新します。

メソッドの詳細

getSuperUser

public SuperUser getSuperUser()
                       throws AccessSecurityReadException
システム管理者情報を取得します。

戻り値:
システム管理者情報
例外:
AccessSecurityReadException - システム管理者情報の取得に失敗した場合にスローされます。

init

public void init(Map params)
システム管理者アクセッサを初期化します。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

insertSuperUser

public void insertSuperUser(SuperUser superUser)
                     throws AccessSecurityWriteException,
                            DuplicateException
システム管理者情報を新規追加します。

パラメータ:
superUser - システム管理者情報
例外:
AccessSecurityWriteException - システム管理者情報の作成に失敗した場合にスローされます。
DuplicateException - 追加するシステム管理者が既に存在した場合にスローされます。

updateSuperUser

public void updateSuperUser(SuperUser superUser)
                     throws AccessSecurityWriteException,
                            NotExistException
システム管理者情報を更新します。

パラメータ:
superUser - システム管理者情報
例外:
AccessSecurityWriteException - システム管理者情報の更新に失敗した場合にスローされます。
NotExistException - 更新するシステム管理者が存在しない場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SuperUserPostWriterListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.admin
インタフェース SuperUserPostWriterListener

public interface SuperUserPostWriterListener

システム管理者情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | init(Map params) システム管理者リスナーの初期化。
void | postCreate(SuperUser superUser) システム管理者情報をデータストアに作成した直後にコールされます。
void | postUpdate(SuperUser superUser) システム管理者情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
システム管理者リスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreate

public void postCreate(SuperUser superUser)
                throws AccessSecurityListenerExcpetion
システム管理者情報をデータストアに作成した直後にコールされます。

パラメータ:
superUser - 作成されたシステム管理者情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdate

public void postUpdate(SuperUser superUser)
                throws AccessSecurityListenerExcpetion
システム管理者情報をデータストアに更新した直後にコールされます。

パラメータ:
superUser - 更新されたシステム管理者情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SuperUserQueryWriterListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.admin
インタフェース SuperUserQueryWriterListener

public interface SuperUserQueryWriterListener

システム管理者情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | init(Map params) システム管理者リスナーの初期化。
void | queryCreate(SuperUser superUser) システム管理者情報をデータストアに作成する直前にコールされます。
void | queryUpdate(SuperUser superUser) システム管理者情報をデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
システム管理者リスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreate

public void queryCreate(SuperUser superUser)
                 throws AccessSecurityListenerExcpetion
システム管理者情報をデータストアに作成する直前にコールされます。

パラメータ:
superUser - 作成されるシステム管理者情報
戻り値:
システム管理者情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdate

public void queryUpdate(SuperUser superUser)
                 throws AccessSecurityListenerExcpetion
システム管理者情報をデータストアに更新する直前にコールされます。

パラメータ:
superUser - 更新されるシステム管理者情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SuperUserReaderDecorator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.admin
インタフェース SuperUserReaderDecorator

public interface SuperUserReaderDecorator

システム管理者情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
SuperUser | doDecoration(SuperUser superUser) システム管理者情報をデータストアからの読み込み直後にコールされます。
void | init(Map params) システム管理者デコレータの初期化。

メソッドの詳細

init

public void init(Map params)
システム管理者デコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public SuperUser doDecoration(SuperUser superUser)
システム管理者情報をデータストアからの読み込み直後にコールされます。

パラメータ:
superUser - 読み込みが行われた管理者情報
戻り値:
拡張された管理者情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.batch.Batch の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.batch.Batch の使用

Batch を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での Batch の使用

Batch を返す jp.co.intra_mart.foundation.security のメソッド
Batch | StandardBatchAccessor.getBatch(String groupId, String batchId) バッチを取得します。
Batch[] | StandardBatchAccessor.getBatches(String groupId) バッチの一覧を取得します。
Batch[] | StandardBatchAccessor.getBatchesByIds(String groupId, String[] batchIds) 引数に指定したバッチIDのバッチ情報をすべて取得します。

Batch 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | StandardBatchAccessor.insertBatch(String groupId, Batch batch) バッチを登録します。
void | StandardBatchAccessor.updateBatch(String groupId, Batch batch) バッチを更新します。

jp.co.intra_mart.foundation.security.batch での Batch の使用

Batch を返す jp.co.intra_mart.foundation.security.batch のメソッド
Batch | BatchReaderDecorator.doDecoration(String groupId, Batch batch) バッチをデータストアからの読み込み直後にコールされます。
Batch | BatchManager.getBatch(String batchId) バッチ情報を取得します。
Batch[] | BatchManager.getBatches() すべてのバッチ情報を取得します。
Batch[] | BatchManager.getBatchesByIds(String[] batchIds) ログイングループ内で引数指定したバッチIDのバッチ情報をすべて取得します。
Batch | BatchAccessor.getBatch(String groupId, String batchId) バッチ情報を取得します。
Batch[] | BatchAccessor.getBatches(String groupId) すべてのバッチ情報を取得します。
Batch[] | BatchAccessor.getBatchesByIds(String groupId, String[] batchIds) 引数に指定したバッチIDのバッチ情報をすべて取得します。

Batch 型のパラメータを持つ jp.co.intra_mart.foundation.security.batch のメソッド
Batch | BatchReaderDecorator.doDecoration(String groupId, Batch batch) バッチをデータストアからの読み込み直後にコールされます。
void | BatchQueryWriterListener.queryCreate(String groupId, Batch batch) バッチ情報をデータストアに作成する直前にコールされます。
void | BatchQueryWriterListener.queryUpdate(String groupId, Batch batch) バッチ情報をデータストアに更新する直前にコールされます。
void | BatchPostWriterListener.postCreate(String groupId, Batch batch) バッチ情報をデータストアに作成した直後にコールされます。
void | BatchPostWriterListener.postUpdate(String groupId, Batch batch) バッチ情報をデータストアに更新した直後にコールされます。
void | BatchManager.addBatch(Batch batch) バッチ情報を新規登録します。
void | BatchManager.updateBatch(Batch batch) バッチ情報を更新します。
void | BatchAccessor.updateBatch(String groupId, Batch batch) バッチ情報を更新します。
void | BatchAccessor.insertBatch(String groupId, Batch batch) バッチ情報を新規に追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.batch.BatchAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.batch.BatchAccessor の使用

BatchAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での BatchAccessor の使用

BatchAccessor を実装している jp.co.intra_mart.foundation.security のクラス
 class StandardBatchAccessor
バッチアクセッサクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.batch.BatchExporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.batch.BatchExporter の使用

BatchExporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.batch バッチに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.batch での BatchExporter の使用

BatchExporter を実装している jp.co.intra_mart.foundation.security.batch のクラス
 class StandardBatchBackup
バッチバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.batch.BatchImporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.batch.BatchImporter の使用

BatchImporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.batch バッチに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.batch での BatchImporter の使用

BatchImporter を実装している jp.co.intra_mart.foundation.security.batch のクラス
 class StandardBatchBackup
バッチバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.batch.BatchManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.batch.BatchManager の使用

BatchManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.batch バッチに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.batch での BatchManager の使用

BatchManager 型のパラメータを持つ jp.co.intra_mart.foundation.security.batch のメソッド
void | BatchImporter.doImport(InputStream inputStream, BatchManager manager) インポートを行います。
void | BatchExporter.doExport(BatchManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardBatchBackup.doImport(InputStream inputStream, BatchManager manager) インポートを行います。
void | StandardBatchBackup.doExport(BatchManager manager, OutputStream outputStream) エクスポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener の使用

jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener の使用

jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator の使用

jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.batch.StandardBatchBackup の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.batch.StandardBatchBackup の使用

jp.co.intra_mart.foundation.security.batch.StandardBatchBackup はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Batch (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
クラス Batch

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.batch.Batch
すべての実装インタフェース:
Serializable
public class Batch
extends Object
implements Serializable

バッチ・モデルクラス

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
BatchManager, 直列化された形式

フィールドの概要
static String | LANG_JAVA プログラム言語(JAVA)。
static String | LANG_JAVA_SCRIPT プログラム言語(JavaScript)。
コンストラクタの概要
Batch()
コンストラクタ。
Batch(String batchId)
コンストラクタ。
メソッドの概要
String | getBatchId() バッチＩＤを取得します。
String | getDescription() バッチ内容を取得します。
String | getName() バッチ名を取得します。
String | getProgramLanguage() 実行プログラム言語を取得します。
String | getProgramPath() 実行プログラムパスを取得します。
int | getRunDay() 実行日を取得します。
int | getRunDayWeek() 実行曜日を取得します。
int | getRunHour() 実行時を取得します。
int | getRunMinute() 実行分を取得します。
int | getRunMonth() 実行月を取得します。
int | getRunSecond() 実行秒を取得します。
int | getRunYear() 実行年を取得します。
boolean | isValidate() 有効・無効フラグを取得します。
protected void | setBatchId(String batchId) バッチＩＤを設定します。
void | setDescription(String description) バッチ内容を設定します。
void | setName(String name) バッチ名を設定します。
void | setProgramLanguage(String programLanguage) 実行プログラム言語の種類を設定します。
void | setProgramPath(String programPath) 実行プログラムパスを設定します。
void | setRunDay(int runDay) 実行日を設定します。
void | setRunDayWeek(int runDayWeek) 実行曜日を設定します。
void | setRunHour(int runHour) 実行時を設定します。
void | setRunMinute(int runMinute) 実行分を設定します。
void | setRunMonth(int runMonth) 実行月を設定します。
void | setRunSecond(int runSecond) 実行秒を設定します。
void | setRunYear(int runYear) 実行年を設定します。
void | setValidate(boolean validFlg) バッチの有効・無効を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

LANG_JAVA

public static final String LANG_JAVA
プログラム言語(JAVA)。
バッチを実行するプログラム言語の種類。

関連項目:
setProgramLanguage(String), 定数フィールド値

LANG_JAVA_SCRIPT

public static final String LANG_JAVA_SCRIPT
プログラム言語(JavaScript)。
バッチを実行するプログラム言語の種類。

関連項目:
setProgramLanguage(String), 定数フィールド値
コンストラクタの詳細

Batch

public Batch()
コンストラクタ。

バッチIDは自動採番されます。

Batch

public Batch(String batchId)
コンストラクタ。

パラメータ:
batchId - バッチID
メソッドの詳細

getBatchId

public String getBatchId()
バッチＩＤを取得します。

戻り値:
バッチＩＤ

getDescription

public String getDescription()
バッチ内容を取得します。

戻り値:
バッチ内容

getName

public String getName()
バッチ名を取得します。

戻り値:
バッチ名

getProgramLanguage

public String getProgramLanguage()
実行プログラム言語を取得します。
(java/js)

戻り値:
実行プログラム言語

getProgramPath

public String getProgramPath()
実行プログラムパスを取得します。

戻り値:
実行プログラムパス

getRunDay

public int getRunDay()
実行日を取得します。

戻り値:
実行日

getRunDayWeek

public int getRunDayWeek()
実行曜日を取得します。

戻り値:
曜日

getRunHour

public int getRunHour()
実行時を取得します。

戻り値:
実行時

getRunMinute

public int getRunMinute()
実行分を取得します。

戻り値:
実行分

getRunMonth

public int getRunMonth()
実行月を取得します。

戻り値:
実行月

getRunSecond

public int getRunSecond()
実行秒を取得します。

戻り値:
実行秒

getRunYear

public int getRunYear()
実行年を取得します。

戻り値:
実行年

isValidate

public boolean isValidate()
有効・無効フラグを取得します。

戻り値:
有効/無効

setBatchId

protected void setBatchId(String batchId)
バッチＩＤを設定します。

パラメータ:
batchId - バッチＩＤ

setDescription

public void setDescription(String description)
バッチ内容を設定します。

パラメータ:
description - バッチ内容

setName

public void setName(String name)
バッチ名を設定します。

パラメータ:
name - バッチ名

setProgramLanguage

public void setProgramLanguage(String programLanguage)
実行プログラム言語の種類を設定します。

設定できる値は、JavaScript( LANG_JAVA_SCRIPT)または、java( LANG_JAVA)のいずれかです。
デフォルトは、JavaScriptです。

パラメータ:
programLanguage - 実行プログラム言語

setProgramPath

public void setProgramPath(String programPath)
実行プログラムパスを設定します。 実行プログラム言語がJavaScriptである場合は、pages以下のパスを設定してください。 実行プログラム言語がjavaである場合は、クラスのフルパッケージ名を設定してください。

パラメータ:
programPath - 実行プログラムパス
関連項目:
getProgramLanguage()

setRunDay

public void setRunDay(int runDay)
実行日を設定します。

設定できる値は、-1,１～３１です。
範囲外の値を設定した場合は、-1に設定されます。
-1を設定した場合は、毎日実行されます。

パラメータ:
runDay - 実行日

setRunDayWeek

public void setRunDayWeek(int runDayWeek)
実行曜日を設定します。

設定できる値は、0(日曜日)から6(土曜日)までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。
実行日が設定されいる場合は、この設定は無視されます。

パラメータ:
runDayWeek - 曜日

setRunHour

public void setRunHour(int runHour)
実行時を設定します。

設定できる値は、-1,０～２３です。
範囲外の値を設定した場合は、-1に設定されます。
-1を設定した場合は、毎時実行されます。

パラメータ:
runHour - 実行時

setRunMinute

public void setRunMinute(int runMinute)
実行分を設定します。

設定できる値は、-1,０～５９です。
範囲外の値を設定した場合は、-1に設定されます。
-1を設定した場合は、毎分実行されます。

パラメータ:
runMinute - 実行分

setRunMonth

public void setRunMonth(int runMonth)
実行月を設定します。

設定できる値は、-1,１～１２です。
範囲外の値を設定した場合は、-1に設定されます。
-1を設定した場合は、毎月実行されます。

パラメータ:
runMonth - 実行月

setRunSecond

public void setRunSecond(int runSecond)
実行秒を設定します。

設定できる値は、-1,０～５９です。
範囲外の値を設定した場合は、-1に設定されます。
-1を設定した場合は、毎秒実行されます。

パラメータ:
runSecond - 実行秒

setRunYear

public void setRunYear(int runYear)
実行年を設定します。

設定できる値は、-1,０～です。
-1以下を設定した場合は、-1に設定されます。
-1を設定した場合は、毎年実行されます。

パラメータ:
runYear - 実行年

setValidate

public void setValidate(boolean validFlg)
バッチの有効・無効を設定します。

パラメータ:
validFlg - 有効/無効
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BatchAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
インタフェース BatchAccessor

既知の実装クラスの一覧:
StandardBatchAccessor
public interface BatchAccessor

メソッドの概要
void | deleteBatch(String groupId, String batchId) バッチ情報を削除します。
Batch | getBatch(String groupId, String batchId) バッチ情報を取得します。
Batch[] | getBatches(String groupId) すべてのバッチ情報を取得します。
Batch[] | getBatchesByIds(String groupId, String[] batchIds) 引数に指定したバッチIDのバッチ情報をすべて取得します。
String[] | getBatchIds(String groupId) すべてのバッチIDを取得します。
void | init(Map params) アクセッサの初期化。
void | insertBatch(String groupId, Batch batch) バッチ情報を新規に追加します。
void | updateBatch(String groupId, Batch batch) バッチ情報を更新します。

メソッドの詳細

deleteBatch

public void deleteBatch(String groupId,
                        String batchId)
                 throws AccessSecurityWriteException,
                        NotExistException
バッチ情報を削除します。

パラメータ:
groupId - ログイングループID
batchId - 削除するバッチID
例外:
AccessSecurityWriteException - バッチ情報の削除に失敗した場合スローされます。
NotExistException - 削除するバッチ情報が存在しない場合スローされます。

updateBatch

public void updateBatch(String groupId,
                        Batch batch)
                 throws AccessSecurityWriteException,
                        NotExistException
バッチ情報を更新します。

パラメータ:
groupId - ログイングループID
batch - 更新するバッチ
例外:
AccessSecurityWriteException - バッチ情報の更新に失敗した場合スローされます。
NotExistException - 削除するバッチ情報が存在しない場合スローされます。

insertBatch

public void insertBatch(String groupId,
                        Batch batch)
                 throws AccessSecurityWriteException,
                        DuplicateException
バッチ情報を新規に追加します。

パラメータ:
groupId - ログイングループID
batch - 新規登録するバッチ
例外:
AccessSecurityWriteException - バッチ情報の新規登録に失敗した場合スローされます。
DuplicateException - 追加するバッチ情報が既に存在した場合スローされます。

getBatch

public Batch getBatch(String groupId,
                      String batchId)
               throws AccessSecurityReadException
バッチ情報を取得します。

パラメータ:
groupId - ログイングループID
batchId - バッチＩＤ
戻り値:
取得されたバッチ
例外:
AccessSecurityReadException - バッチ情報の取得に失敗した場合スローされます。

getBatches

public Batch[] getBatches(String groupId)
                   throws AccessSecurityReadException
すべてのバッチ情報を取得します。 一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
戻り値:
取得されたバッチ
例外:
AccessSecurityReadException - バッチ情報の取得に失敗した場合スローされます。

getBatchesByIds

public Batch[] getBatchesByIds(String groupId,
                               String[] batchIds)
                        throws AccessSecurityReadException
引数に指定したバッチIDのバッチ情報をすべて取得します。
一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
batchIds - バッチＩＤの配列
戻り値:
取得されたバッチの配列
例外:
AccessSecurityReadException - バッチ情報の取得に失敗した場合スローされます。

getBatchIds

public String[] getBatchIds(String groupId)
                     throws AccessSecurityReadException
すべてのバッチIDを取得します。
一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
戻り値:
バッチIDの配列
例外:
AccessSecurityReadException - バッチ情報の取得に失敗した場合スローされます。

init

public void init(Map params)
アクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BatchExporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
インタフェース BatchExporter

既知の実装クラスの一覧:
StandardBatchBackup
public interface BatchExporter

バッチバックアップインタフェースです。

バージョン:
1.0

メソッドの概要
void | doExport(BatchManager manager, OutputStream outputStream) エクスポートを行います。
void | init(Map params) バッチバックアップエクスポータの初期化。

メソッドの詳細

init

public void init(Map params)
バッチバックアップエクスポータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doExport

public void doExport(BatchManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

バッチ情報をバックアップファイルに出力します。

パラメータ:
manager - バッチマネージャ バッチモデルクラスの配列
outputStream - 出力ストリーム
例外:
AccessSecurityExportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BatchImporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
インタフェース BatchImporter

既知の実装クラスの一覧:
StandardBatchBackup
public interface BatchImporter

バッチバックアップインタフェースです。

バージョン:
1.0

メソッドの概要
void | doImport(InputStream inputStream, BatchManager manager) インポートを行います。
void | init(Map params) バッチバックアップインポータの初期化。

メソッドの詳細

init

public void init(Map params)
バッチバックアップインポータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     BatchManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からバッチ情報を取得し、生成します。

パラメータ:
manager - バッチマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BatchManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
クラス BatchManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.batch.BatchManager
public class BatchManager
extends Object

バッチマネージャクラス。

バッチ情報の操作を行います。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
Batch

コンストラクタの概要
BatchManager(String groupId)
コンストラクタ。
メソッドの概要
void | addBatch(Batch batch) バッチ情報を新規登録します。
static void | clearInstance() バッチマネージャのインスタンスを初期化します。
void | deleteBatch(String batchId) バッチ情報を削除します。
void | deleteBatches() すべてのバッチ情報を削除します。
void | exportData(String category, OutputStream outputStream) エクスポートを行います。
Batch | getBatch(String batchId) バッチ情報を取得します。
Batch[] | getBatches() すべてのバッチ情報を取得します。
Batch[] | getBatchesByIds(String[] batchIds) ログイングループ内で引数指定したバッチIDのバッチ情報をすべて取得します。
String[] | getBatchIds() バッチIDの一覧を取得します。
String[] | getExportCategories() バッチエクスポート用のカテゴリの一覧を取得します。
String[] | getImportCategories() バッチインポート用のカテゴリの一覧を取得します。
String | getLoginGroupId() ログイングループIDを取得します。
void | importData(String category, InputStream inputStream) インポートを行います。
boolean | isUpdate(Date date) バッチ情報が指定された日付よりも新しいかチェックします。
void | updateBatch(Batch batch) バッチ情報を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BatchManager

public BatchManager(String groupId)
             throws AccessSecurityException
コンストラクタ。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityException - ログイングループIDが不正な場合にスローされます。
導入されたバージョン:
5.0
メソッドの詳細

clearInstance

public static void clearInstance()
バッチマネージャのインスタンスを初期化します。

アクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。
通常、このメソッドを使用する必要はありません。

addBatch

public void addBatch(Batch batch)
              throws AccessSecurityException
バッチ情報を新規登録します。

パラメータ:
batch - 新規登録するバッチ
例外:
AccessSecurityException - バッチ情報の新規登録に失敗した場合、または引数が不正だった場合にスローされます。

deleteBatch

public void deleteBatch(String batchId)
                 throws AccessSecurityException
バッチ情報を削除します。

パラメータ:
batchId - 削除するバッチID
例外:
AccessSecurityException - バッチ情報の削除に失敗した場合、または引数が不正だった場合にスローされます。

deleteBatches

public void deleteBatches()
                   throws AccessSecurityException
すべてのバッチ情報を削除します。

例外:
AccessSecurityException - バッチ情報の削除に失敗した場合、または引数が不正だった場合にスローされます。

exportData

public void exportData(String category,
                       OutputStream outputStream)
                throws AccessSecurityException
エクスポートを行います。

パラメータ:
category - カテゴリ名
outputStream - 出力ストリーム
例外:
AccessSecurityException - エクスポートに失敗した場合、または引数が不正だった場合にスローされます。

getBatch

public Batch getBatch(String batchId)
               throws AccessSecurityException
バッチ情報を取得します。

パラメータ:
batchId - バッチＩＤ
戻り値:
取得されたバッチ
例外:
AccessSecurityException - バッチ情報の取得に失敗した場合、または引数が不正だった場合にスローされます。

getBatches

public Batch[] getBatches()
                   throws AccessSecurityException
すべてのバッチ情報を取得します。

戻り値:
取得されたバッチ
例外:
AccessSecurityException - バッチ情報の取得に失敗した場合にスローされます。

getBatchesByIds

public Batch[] getBatchesByIds(String[] batchIds)
                        throws AccessSecurityException
ログイングループ内で引数指定したバッチIDのバッチ情報をすべて取得します。

パラメータ:
batchIds - バッチIDの配列
戻り値:
バッチ情報の配列（データがない場合は空の配列を返します。）
例外:
AccessSecurityException - バッチ情報の取得に失敗した場合にスローされます。

getBatchIds

public String[] getBatchIds()
                     throws AccessSecurityException
バッチIDの一覧を取得します。

戻り値:
バッチIDの配列
例外:
AccessSecurityException - バッチ情報の取得に失敗した場合にスローされます。

getExportCategories

public String[] getExportCategories()
                             throws AccessSecurityException
バッチエクスポート用のカテゴリの一覧を取得します。

戻り値:
バッチエクスポート用カテゴリの一覧
例外:
AccessSecurityException - バッチエクスポート用のカテゴリの取得に失敗した場合にスローされます。

getImportCategories

public String[] getImportCategories()
                             throws AccessSecurityException
バッチインポート用のカテゴリの一覧を取得します。

戻り値:
バッチインポート用カテゴリの一覧
例外:
AccessSecurityException - バッチインポート用のカテゴリの取得に失敗した場合にスローされます。

importData

public void importData(String category,
                       InputStream inputStream)
                throws AccessSecurityException
インポートを行います。

パラメータ:
category - カテゴリ名
inputStream - 入力ストリーム
例外:
AccessSecurityException - インポートに失敗した場合、または引数が不正だった場合にスローされます。

updateBatch

public void updateBatch(Batch batch)
                 throws AccessSecurityException
バッチ情報を更新します。

パラメータ:
batch - 更新するバッチ
例外:
AccessSecurityException - バッチ情報の更新に失敗した場合、または引数が不正だった場合にスローされます。

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

戻り値:
ログイングループID

isUpdate

public boolean isUpdate(Date date)
                 throws AccessSecurityException
バッチ情報が指定された日付よりも新しいかチェックします。

パラメータ:
date - チェック日付
例外:
AccessSecurityReadException - 更新チェックに失敗した場合スローされます。
AccessSecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BatchPostWriterListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
インタフェース BatchPostWriterListener

public interface BatchPostWriterListener

メソッドの概要
void | init(Map params) バッチリスナーの初期化。
void | postCreate(String groupId, Batch batch) バッチ情報をデータストアに作成した直後にコールされます。
void | postDelete(String groupId, String batchId) バッチ情報をデータストアから削除した直後にコールされます。
void | postUpdate(String groupId, Batch batch) バッチ情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
バッチリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreate

public void postCreate(String groupId,
                       Batch batch)
                throws AccessSecurityListenerExcpetion
バッチ情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
batch - 作成されたバッチ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDelete

public void postDelete(String groupId,
                       String batchId)
                throws AccessSecurityListenerExcpetion
バッチ情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
batchId - 削除されたバッチId
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdate

public void postUpdate(String groupId,
                       Batch batch)
                throws AccessSecurityListenerExcpetion
バッチ情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
batch - 更新されたバッチ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BatchQueryWriterListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
インタフェース BatchQueryWriterListener

public interface BatchQueryWriterListener

メソッドの概要
void | init(Map params) バッチリスナーの初期化。
void | queryCreate(String groupId, Batch batch) バッチ情報をデータストアに作成する直前にコールされます。
void | queryDelete(String groupId, String batchId) バッチ情報をデータストアから削除する直前にコールされます。
void | queryUpdate(String groupId, Batch batch) バッチ情報をデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
バッチリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreate

public void queryCreate(String groupId,
                        Batch batch)
                 throws AccessSecurityListenerExcpetion
バッチ情報をデータストアに作成する直前にコールされます。

パラメータ:
groupId - ログイングループID
batch - 作成されるバッチ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDelete

public void queryDelete(String groupId,
                        String batchId)
                 throws AccessSecurityListenerExcpetion
バッチ情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
batchId - 削除されるバッチID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdate

public void queryUpdate(String groupId,
                        Batch batch)
                 throws AccessSecurityListenerExcpetion
バッチ情報をデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
batch - 更新されるバッチ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BatchReaderDecorator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
インタフェース BatchReaderDecorator

public interface BatchReaderDecorator

メソッドの概要
Batch | doDecoration(String groupId, Batch batch) バッチをデータストアからの読み込み直後にコールされます。
void | init(Map params) バッチデコレータの初期化。

メソッドの詳細

init

public void init(Map params)
バッチデコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public Batch doDecoration(String groupId,
                          Batch batch)
バッチをデータストアからの読み込み直後にコールされます。

パラメータ:
groupId - ログイングループID
batch - 読み込みが行われたバッチ情報
戻り値:
拡張されたバッチ情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.batch (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.security.batch
インタフェース
BatchAccessor
BatchExporter
BatchImporter
BatchPostWriterListener
BatchQueryWriterListener
BatchReaderDecorator
クラス
Batch
BatchManager
StandardBatchBackup


jp.co.intra_mart.foundation.security.batch (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.batch

バッチに関連するクラスを提供します。

参照:
説明

インタフェースの概要
BatchAccessor |
BatchExporter | バッチバックアップインタフェースです。
BatchImporter | バッチバックアップインタフェースです。
BatchPostWriterListener |
BatchQueryWriterListener |
BatchReaderDecorator |

クラスの概要
Batch | バッチ・モデルクラス
BatchManager | バッチマネージャクラス。
StandardBatchBackup | バッチバックアップクラスです。

パッケージ jp.co.intra_mart.foundation.security.batch の説明

バッチに関連するクラスを提供します。


jp.co.intra_mart.foundation.security.batch クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.batch の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.batch.Batch (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.batch.BatchManager
    • class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup (implements jp.co.intra_mart.foundation.security.batch.BatchExporter, jp.co.intra_mart.foundation.security.batch.BatchImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.batch.BatchAccessor
  • interface jp.co.intra_mart.foundation.security.batch.BatchExporter
  • interface jp.co.intra_mart.foundation.security.batch.BatchImporter
  • interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener
  • interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator


パッケージ jp.co.intra_mart.foundation.security.batch の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.batch の使用

jp.co.intra_mart.foundation.security.batch を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。

jp.co.intra_mart.foundation.security により使用される jp.co.intra_mart.foundation.security.batch のクラス
Batch
バッチ・モデルクラス
BatchAccessor

jp.co.intra_mart.foundation.security.batch により使用される jp.co.intra_mart.foundation.security.batch のクラス
Batch
バッチ・モデルクラス
BatchExporter
バッチバックアップインタフェースです。
BatchImporter
バッチバックアップインタフェースです。
BatchManager
バッチマネージャクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardBatchBackup (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
クラス StandardBatchBackup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.batch.StandardBatchBackup
すべての実装インタフェース:
BatchExporter, BatchImporter
public class StandardBatchBackup
extends Object
implements BatchImporter, BatchExporter

バッチバックアップクラスです。

バージョン:
1.0

コンストラクタの概要
StandardBatchBackup()
メソッドの概要
void | doExport(BatchManager manager, OutputStream outputStream) エクスポートを行います。
void | doImport(InputStream inputStream, BatchManager manager) インポートを行います。
void | init(Map params) バッチバックアップの初期化。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardBatchBackup

public StandardBatchBackup()
メソッドの詳細

init

public void init(Map params)
バッチバックアップの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース BatchImporter 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     BatchManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からバッチ情報を生成します。

定義:
インタフェース BatchImporter 内の doImport
パラメータ:
manager - バッチマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

doExport

public void doExport(BatchManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

バッチバックアップ情報を生成し、ストリームに返却します。

定義:
インタフェース BatchExporter 内の doExport
パラメータ:
manager - バッチマネージャ
outputStream - 出力ストリーム
例外:
AccessSecurityExportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.security.calendar.CalendarAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.CalendarAccessor の使用

CalendarAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での CalendarAccessor の使用

CalendarAccessor を実装している jp.co.intra_mart.foundation.security のクラス
 class StandardCalendarAccessor
カレンダーアクセッサクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.calendar.CalendarExporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.CalendarExporter の使用

CalendarExporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.calendar カレンダーに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.calendar での CalendarExporter の使用

CalendarExporter を実装している jp.co.intra_mart.foundation.security.calendar のクラス
 class StandardCalendarBackup
カレンダーバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.calendar.CalendarImporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.CalendarImporter の使用

CalendarImporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.calendar カレンダーに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.calendar での CalendarImporter の使用

CalendarImporter を実装している jp.co.intra_mart.foundation.security.calendar のクラス
 class StandardCalendarBackup
カレンダーバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.CalendarInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.CalendarInfo の使用

CalendarInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での CalendarInfo の使用

CalendarInfo を返す jp.co.intra_mart.foundation.security のメソッド
CalendarInfo | StandardCalendarAccessor.getCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータを取得します。
CalendarInfo[] | StandardCalendarAccessor.getCalendarInfos(String groupId, String calendarId) すべてのカレンダーデータを取得します。
CalendarInfo[] | StandardCalendarAccessor.getCalendarInfosByIds(String groupId, String calendarId, String[] calendarInfoIds) 指定されたカレンダーデータIDのカレンダー情報をすべて取得する。

CalendarInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | StandardCalendarAccessor.insertCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に作成します。
void | StandardCalendarAccessor.updateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。

jp.co.intra_mart.foundation.security.calendar での CalendarInfo の使用

CalendarInfo を返す jp.co.intra_mart.foundation.security.calendar のメソッド
CalendarInfo[] | DayInfo.getCalendarInfo() マッチしたカレンダーデータの一覧を取得します。
CalendarInfo[] | CategorizedCalendarInfo.getConfigDayInfos() データタイプが名称であるカレンダーデータの一覧を取得します。
CalendarInfo[] | CategorizedCalendarInfo.getHodildayInfos() データタイプが休日であるカレンダーデータの一覧を取得します。
CalendarInfo[] | CategorizedCalendarInfo.getNationalHodildayInfos() データタイプが祝祭日であるカレンダーデータの一覧を取得します。
CalendarInfo[] | CategorizedCalendarInfo.getWeekdayInfos() データタイプが非休日であるカレンダーデータの一覧を取得します。
CalendarInfo | CalendarReaderDecorator.doDecoration(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアからの読み込み直後にコールされます。
CalendarInfo | CalendarManager.getCalendarInfo(String calendarId, String dataId) カレンダーデータを取得します。
CalendarInfo[] | CalendarManager.getCalendarInfos(String calendarId) すべてのカレンダーデータを取得します。
CalendarInfo[] | CalendarManager.getCalendarInfosByIds(String calendarId, String[] calendarInfoIds) ログイングループ内で引数指定したカレンダーデータIDのカレンダーをすべて取得します。
CalendarInfo | CalendarAccessor.getCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータを取得します。
CalendarInfo[] | CalendarAccessor.getCalendarInfos(String groupId, String calendarId) すべてのカレンダーデータを取得します。
CalendarInfo[] | CalendarAccessor.getCalendarInfosByIds(String groupId, String calendarId, String[] calendarInfoIds) 指定されたカレンダIDのカレンダ情報をすべて取得する。

CalendarInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.calendar のメソッド
CalendarInfo | CalendarReaderDecorator.doDecoration(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアからの読み込み直後にコールされます。
void | CalendarQueryWriterListener.queryCreateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに作成する直前にコールされます。
void | CalendarQueryWriterListener.queryUpdateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに更新する直前にコールされます。
void | CalendarPostWriterListener.postCreateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに作成した直後にコールされます。
void | CalendarPostWriterListener.postUpdateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに更新した直後にコールされます。
boolean | CalendarPluginVernalEquinox.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginMondayMakeupHoliday.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginLastDayInTheMonth.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginEndOfTheMonth.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginAutumnalEquinox.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPlugin.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
void | CalendarManager.addCalendarInfo(String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に追加します。
void | CalendarManager.updateCalendarInfo(String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。
void | CalendarAccessor.insertCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に作成します。
void | CalendarAccessor.updateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。

CalendarInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.calendar のコンストラクタ
CategorizedCalendarInfo(CalendarInfo[] calendarInfos)
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.CalendarManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.CalendarManager の使用

CalendarManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.calendar カレンダーに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.calendar での CalendarManager の使用

CalendarManager 型のパラメータを持つ jp.co.intra_mart.foundation.security.calendar のメソッド
boolean | CalendarPluginVernalEquinox.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginMondayMakeupHoliday.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginLastDayInTheMonth.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginEndOfTheMonth.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginAutumnalEquinox.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPlugin.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
void | CalendarImporter.doImport(InputStream inputStream, CalendarManager manager) インポートを行います。
void | CalendarExporter.doExport(CalendarManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardCalendarBackup.doImport(InputStream inputStream, CalendarManager manager) インポートを行います。
void | StandardCalendarBackup.doExport(CalendarManager manager, OutputStream outputStream) エクスポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.calendar.CalendarPlugin の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.CalendarPlugin の使用

CalendarPlugin を使用しているパッケージ
jp.co.intra_mart.foundation.security.calendar カレンダーに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.calendar での CalendarPlugin の使用

CalendarPlugin を実装している jp.co.intra_mart.foundation.security.calendar のクラス
class | CalendarPluginAutumnalEquinox カレンダデータプラグインクラス。
class | CalendarPluginEndOfTheMonth カレンダデータプラグインクラス。
class | CalendarPluginLastDayInTheMonth カレンダデータプラグインクラス。
class | CalendarPluginMondayMakeupHoliday カレンダデータプラグインクラス。
class | CalendarPluginVernalEquinox カレンダデータプラグインクラス。

CalendarPlugin を返す jp.co.intra_mart.foundation.security.calendar のメソッド
 CalendarPlugin CalendarManager.getPlugin(String pluginId)
カレンダーデータプラグインを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox の使用

jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth の使用

jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo の使用

jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth の使用

jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday の使用

jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox の使用

jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener の使用

jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener の使用

jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator の使用

jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo の使用

CategorizedCalendarInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security.calendar カレンダーに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.calendar での CategorizedCalendarInfo の使用

CategorizedCalendarInfo を返す jp.co.intra_mart.foundation.security.calendar のメソッド
 CategorizedCalendarInfo CalendarManager.getCategorizedCalendarInfos(String calendarId)
すべてのカレンダーデータをデータタイプ別に分類して取得します。

CategorizedCalendarInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.calendar のメソッド
boolean | CalendarPluginVernalEquinox.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginMondayMakeupHoliday.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginLastDayInTheMonth.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginEndOfTheMonth.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginAutumnalEquinox.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPlugin.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
DayInfo | CalendarManager.getDayInfo(CategorizedCalendarInfo categorizedCalendarInfo, Date date) 日付情報を取得します。
DayInfo[] | CalendarManager.getMonthInfos(CategorizedCalendarInfo categorizedCalendarInfo, int year, int month) 月情報を取得します。
boolean | CalendarManager.isHoliday(String calendarId, CategorizedCalendarInfo categorizedCalendarInfo, Date date) 休日かどうか判定します。
boolean | CalendarManager.isNationalHoliday(CategorizedCalendarInfo categorizedCalendarInfo, Date date) 祝日かどうか判定します。
boolean | CalendarManager.isWeekday(String calendarId, CategorizedCalendarInfo categorizedCalendarInfo, Date date) 平日かどうか判定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.calendar.DayInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.DayInfo の使用

DayInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security.calendar カレンダーに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.calendar での DayInfo の使用

DayInfo を返す jp.co.intra_mart.foundation.security.calendar のメソッド
DayInfo | CalendarManager.getDayInfo(CategorizedCalendarInfo categorizedCalendarInfo, Date date) 日付情報を取得します。
DayInfo[] | CalendarManager.getMonthInfos(CategorizedCalendarInfo categorizedCalendarInfo, int year, int month) 月情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup の使用

jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CalendarAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース CalendarAccessor

既知の実装クラスの一覧:
StandardCalendarAccessor
public interface CalendarAccessor

カレンダーアクセッサインタフェース。

カレンダー情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | deleteCalendar(String groupId, String calendarId) カレンダーを削除します。
void | deleteCalendarInfo(String groupId, String calendarId, String dataId) 指定されたカレンダーデータを削除します。
String[] | getCalendarIds(String groupId) すべてのカレンダーIDを取得します。
CalendarInfo | getCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータを取得します。
String[] | getCalendarInfoIds(String groupId, String calendarId) すべてのカレンダーデータIDを取得します。
CalendarInfo[] | getCalendarInfos(String groupId, String calendarId) すべてのカレンダーデータを取得します。
CalendarInfo[] | getCalendarInfosByIds(String groupId, String calendarId, String[] calendarInfoIds) 指定されたカレンダIDのカレンダ情報をすべて取得する。
void | init(Map params) カレンダーアクセッサの初期化。
void | insertCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に作成します。
void | updateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。

メソッドの詳細

deleteCalendar

public void deleteCalendar(String groupId,
                           String calendarId)
                    throws AccessSecurityWriteException,
                           NotExistException
カレンダーを削除します。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
例外:
AccessSecurityWriteException
NotExistException

deleteCalendarInfo

public void deleteCalendarInfo(String groupId,
                               String calendarId,
                               String dataId)
                        throws AccessSecurityWriteException,
                               NotExistException
指定されたカレンダーデータを削除します。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
dataId - カレンダーデータID
例外:
AccessSecurityWriteException
NotExistException

getCalendarIds

public String[] getCalendarIds(String groupId)
                        throws AccessSecurityReadException
すべてのカレンダーIDを取得します。
カレンダーIDが存在しない場合は空の配列を返却します。

パラメータ:
groupId - ログイングループID
戻り値:
カレンダーIDの配列
例外:
AccessSecurityReadException

getCalendarInfo

public CalendarInfo getCalendarInfo(String groupId,
                                    String calendarId,
                                    String dataId)
                             throws AccessSecurityReadException
カレンダーデータを取得します。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
dataId - カレンダーデータID
戻り値:
カレンダーデータ
例外:
AccessSecurityReadException

getCalendarInfoIds

public String[] getCalendarInfoIds(String groupId,
                                   String calendarId)
                            throws AccessSecurityReadException
すべてのカレンダーデータIDを取得します。
カレンダーデータIDが存在しない場合は空の配列を返却します。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
戻り値:
カレンダーデータIDの配列
例外:
AccessSecurityReadException

getCalendarInfos

public CalendarInfo[] getCalendarInfos(String groupId,
                                       String calendarId)
                                throws AccessSecurityReadException
すべてのカレンダーデータを取得します。

カレンダーデータが存在しない場合は空の配列を返却します。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
戻り値:
カレンダーデータの配列
例外:
AccessSecurityReadException

getCalendarInfosByIds

public CalendarInfo[] getCalendarInfosByIds(String groupId,
                                            String calendarId,
                                            String[] calendarInfoIds)
                                     throws AccessSecurityReadException
指定されたカレンダIDのカレンダ情報をすべて取得する。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfoIds - カレンダーデータIDの配列
戻り値:
カレンダオブジェクトの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - カレンダ情報取得に失敗した場合スローされます。

init

public void init(Map params)
カレンダーアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

insertCalendarInfo

public void insertCalendarInfo(String groupId,
                               String calendarId,
                               CalendarInfo calendarInfo)
                        throws AccessSecurityWriteException,
                               DuplicateException
カレンダーデータを新規に作成します。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfo - カレンダーデータ
例外:
AccessSecurityWriteException
DuplicateException

updateCalendarInfo

public void updateCalendarInfo(String groupId,
                               String calendarId,
                               CalendarInfo calendarInfo)
                        throws AccessSecurityWriteException,
                               NotExistException
カレンダーデータを更新します。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfo - カレンダーデータ
例外:
AccessSecurityWriteException
NotExistException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CalendarExporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース CalendarExporter

既知の実装クラスの一覧:
StandardCalendarBackup
public interface CalendarExporter

カレンダーバックアップインタフェースです。

バージョン:
1.0

メソッドの概要
void | doExport(CalendarManager manager, OutputStream outputStream) エクスポートを行います。
void | init(Map params) カレンダーバックアップエクスポータの初期化。

メソッドの詳細

init

public void init(Map params)
カレンダーバックアップエクスポータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doExport

public void doExport(CalendarManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

カレンダーとカレンダー情報を
バックアップファイルに出力します。

パラメータ:
manager - カレンダーマネージャクラス
outputStream - 出力ストリーム
例外:
AccessSecurityExportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarImporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース CalendarImporter

既知の実装クラスの一覧:
StandardCalendarBackup
public interface CalendarImporter

カレンダーバックアップインタフェースです。

バージョン:
1.0

メソッドの概要
void | doImport(InputStream inputStream, CalendarManager manager) インポートを行います。
void | init(Map params) カレンダーバックアップインポータの初期化。

メソッドの詳細

init

public void init(Map params)
カレンダーバックアップインポータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     CalendarManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からカレンダーと
付随するカレンダー情報を取得し、生成します。

パラメータ:
manager - カレンダーマネージャクラス
inputStream - 入力ストリーム
戻り値:
バッチモデルクラスの配列
例外:
AccessSecurityImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス CalendarInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.CalendarInfo
すべての実装インタフェース:
Serializable
public class CalendarInfo
extends Object
implements Serializable

カレンダーデータ・モデルクラス

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
CalendarManager, 直列化された形式

フィールドの概要
static String | TYPE_CONFIG 名称（データタイプの定数）。
static String | TYPE_HOLIDAY 休日（データタイプの定数）。
static String | TYPE_NATIONAL_HOLDAY 祝祭日（データタイプの定数）。
static String | TYPE_WEEKDAY 非休日（データタイプの定数）。
コンストラクタの概要
CalendarInfo()
コンストラクタ。
CalendarInfo(String dataId)
コンストラクタ。
メソッドの概要
String | getColor() 色を取得します。
String | getDataId() データＩＤを取得します。
String | getDataType() データタイプを取得します。
int | getDay() 日を取得します。
int | getDayWeek() 曜日を取得します。
String | getDescription() データの説明を取得します。
String | getDisplayName(Locale locale) 表示名を取得します。
Locale[] | getLocales() 表示名として保管されているロケールの一覧を取得します。
int | getMonth() 月を取得します。
String | getPlugin() プラグインIDを取得します。
int | getPriority() 優先度を取得します。
int | getTimes() 次を取得します。
int | getValidEndYear() 有効終了年を取得します。
int | getValidStartYear() 有効開始年を取得します。
int | getWeek() 週を取得します。
int | getYear() 年を取得します。
void | removeDisplayName(Locale locale) ロケールに対応した表示名を削除します。
void | setColor(String color) 色を設定します。
protected void | setDataId(String dataId) データIDを設定します。
void | setDataType(String dataType) データタイプを設定します。
void | setDay(int day) 日を設定します。
void | setDayWeek(int dayWeek) 曜日を設定します。
void | setDescription(String description) データの説明を設定します。
void | setDisplayName(Locale locale, String displayName) 表示名を設定します。
void | setMonth(int month) 月を設定します。
void | setPlugin(String plugin) プラグインIDを設定します。
void | setTimes(int times) 第ｎ～曜日を設定します。
void | setValidEndYear(int validEndYear) 有効終了年を設定します。
void | setValidStartYear(int validStartYear) 有効開始年を設定します。
void | setWeek(int week) 第ｎ週目を設定します。
void | setYear(int year) 年を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

TYPE_CONFIG

public static final String TYPE_CONFIG
名称（データタイプの定数）。

関連項目:
定数フィールド値

TYPE_HOLIDAY

public static final String TYPE_HOLIDAY
休日（データタイプの定数）。

関連項目:
定数フィールド値

TYPE_WEEKDAY

public static final String TYPE_WEEKDAY
非休日（データタイプの定数）。

関連項目:
定数フィールド値

TYPE_NATIONAL_HOLDAY

public static final String TYPE_NATIONAL_HOLDAY
祝祭日（データタイプの定数）。

関連項目:
定数フィールド値
コンストラクタの詳細

CalendarInfo

public CalendarInfo()
コンストラクタ。

データIDは自動採番されます。

CalendarInfo

public CalendarInfo(String dataId)
コンストラクタ。

パラメータ:
dataId - カレンダーデータID
メソッドの詳細

getColor

public String getColor()
色を取得します。

戻り値:
色

getDataId

public String getDataId()
データＩＤを取得します。

戻り値:
データＩＤ

getDataType

public String getDataType()
データタイプを取得します。

戻り値:
データタイプ

getDay

public int getDay()
日を取得します。

戻り値:
日

getDayWeek

public int getDayWeek()
曜日を取得します。

戻り値:
曜日

getDescription

public String getDescription()
データの説明を取得します。

戻り値:
データの説明

getDisplayName

public String getDisplayName(Locale locale)
表示名を取得します。

引数のロケールに対応した表示名を取得します。

パラメータ:
locale - ロケール
戻り値:
ロケールに対応した表示名

removeDisplayName

public void removeDisplayName(Locale locale)
ロケールに対応した表示名を削除します。

ロケールに対応した表示名を削除します。

パラメータ:
locale - ロケール

getLocales

public Locale[] getLocales()
表示名として保管されているロケールの一覧を取得します。

戻り値:
表示名として保管されているロケールの配列

getMonth

public int getMonth()
月を取得します。

戻り値:
月

getPlugin

public String getPlugin()
プラグインIDを取得します。

戻り値:
プラグインID

getTimes

public int getTimes()
次を取得します。
第ｎ～曜日

戻り値:
次

getValidEndYear

public int getValidEndYear()
有効終了年を取得します。

戻り値:
有効終了年

getValidStartYear

public int getValidStartYear()
有効開始年を取得します。

戻り値:
有効開始年

getWeek

public int getWeek()
週を取得します。
第ｎ週目

戻り値:
週

getYear

public int getYear()
年を取得します。

戻り値:
年

setColor

public void setColor(String color)
色を設定します。

パラメータ:
color - 色

setDataId

protected void setDataId(String dataId)
データIDを設定します。

パラメータ:
dataId - データID

setDataType

public void setDataType(String dataType)
データタイプを設定します。

設定できる値は、 TYPE_CONFIG(名称)、 TYPE_HOLIDAY(休日)、 TYPE_WEEKDAY (非休日)、 TYPE_NATIONAL_HOLDAY(祝祭日)のいずれかです。
上記以外の値が設定された場合は、 TYPE_CONFIG(名称)に設定されます。

パラメータ:
dataType - データタイプ

setDay

public void setDay(int day)
日を設定します。

設定できる値は、1から31までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。

パラメータ:
day - 日

setDayWeek

public void setDayWeek(int dayWeek)
曜日を設定します。

設定できる値は、0(日曜日)から6(土曜日)までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。

設定した曜日(日)を特定したい場合は、第ｎ～曜日の設定( getTimes())
または第ｎ週の設定( getWeek())と共に設定が可能です。
第ｎ～曜日の設定、第ｎ週の設定共に設定を行わなかった場合は、すべての指定曜日の設定となります。

パラメータ:
dayWeek - 曜日

setDescription

public void setDescription(String description)
データの説明を設定します。

パラメータ:
description - データの説明

setDisplayName

public void setDisplayName(Locale locale,
                           String displayName)
表示名を設定します。

ロケールに対応する表示名を設定します。

パラメータ:
locale - ロケール
displayName - 表示名

setMonth

public void setMonth(int month)
月を設定します。

設定できる値は、1から12までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。

パラメータ:
month - 月

setPlugin

public void setPlugin(String plugin)
プラグインIDを設定します。

この設定を無効にするにはnullまたは空文字列を設定します。

パラメータ:
plugin - プラグインID

setTimes

public void setTimes(int times)
第ｎ～曜日を設定します。

設定できる値は、1から5までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。

曜日の設定( setDayWeek(int)) と共に設定すると、日を特定できます。

パラメータ:
times - 第ｎ～曜日

setValidEndYear

public void setValidEndYear(int validEndYear)
有効終了年を設定します。

この設定を無効にするには-1を設定します。

パラメータ:
validEndYear - 有効終了年

setValidStartYear

public void setValidStartYear(int validStartYear)
有効開始年を設定します。

この設定を無効にするには-1を設定します。

パラメータ:
validStartYear - 有効開始年

setWeek

public void setWeek(int week)
第ｎ週目を設定します。

設定できる値は、1から6までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。

曜日の設定( setDayWeek(int)) と共に設定すると、日が特定できます。

パラメータ:
week - 週

setYear

public void setYear(int year)
年を設定します。

この設定を無効にするには-1を設定します。

パラメータ:
year - 年

getPriority

public int getPriority()
優先度を取得します。

戻り値:
優先度
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CalendarManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス CalendarManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.CalendarManager
public class CalendarManager
extends Object

カレンダーマネージャクラス

カレンダー情報の操作を行います。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
CalendarInfo

コンストラクタの概要
CalendarManager(String groupId)
コンストラクタ。
メソッドの概要
void | addCalendarInfo(String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に追加します。
static void | clearInstance() カレンダーマネージャのインスタンスを初期化します。
void | deleteCalendar(String calendarId) カレンダーを削除します。
void | deleteCalendarInfo(String calendarId, String dataId) カレンダーデータを削除します。
void | deleteCalendarInfos(String calendarId) すべてのカレンダーデータを削除します。
void | deleteCalendars() すべてのカレンダーを削除します。
void | exportData(String category, OutputStream outputStream) エクスポートを行います。
String[] | getCalendarIds() すべてのカレンダーIDを取得します。
CalendarInfo | getCalendarInfo(String calendarId, String dataId) カレンダーデータを取得します。
String[] | getCalendarInfoIds(String calendarId) すべてのカレンダーデータIDを取得します。
CalendarInfo[] | getCalendarInfos(String calendarId) すべてのカレンダーデータを取得します。
CalendarInfo[] | getCalendarInfosByIds(String calendarId, String[] calendarInfoIds) ログイングループ内で引数指定したカレンダーデータIDのカレンダーをすべて取得します。
CategorizedCalendarInfo | getCategorizedCalendarInfos(String calendarId) すべてのカレンダーデータをデータタイプ別に分類して取得します。
DayInfo | getDayInfo(CategorizedCalendarInfo categorizedCalendarInfo, Date date) 日付情報を取得します。
String | getDefaultCalendarId() デフォルトカレンダーIDを取得します。
String[] | getExportCategories() カレンダーエクスポート用のカテゴリの一覧を取得します。
String[] | getImportCategories() カレンダーインポート用のカテゴリの一覧を取得します。
String | getLoginGroupId() ログイングループIDを取得します。
DayInfo[] | getMonthInfos(CategorizedCalendarInfo categorizedCalendarInfo, int year, int month) 月情報を取得します。
CalendarPlugin | getPlugin(String pluginId) カレンダーデータプラグインを取得します。
String[] | getPluginIds() カレンダーデータプラグインIDの一覧を取得します。
void | importData(String category, InputStream inputStream) インポートを行います。
boolean | isHoliday(String calendarId, CategorizedCalendarInfo categorizedCalendarInfo, Date date) 休日かどうか判定します。
boolean | isNationalHoliday(CategorizedCalendarInfo categorizedCalendarInfo, Date date) 祝日かどうか判定します。
boolean | isUpdate(String calendarId, Date date) カレンダーデータが指定された日付よりも新しいかチェックします。
boolean | isWeekday(String calendarId, CategorizedCalendarInfo categorizedCalendarInfo, Date date) 平日かどうか判定します。
void | updateCalendarInfo(String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CalendarManager

public CalendarManager(String groupId)
                throws AccessSecurityException
コンストラクタ。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityException - ログイングループIDが不正な場合にスローされます。
メソッドの詳細

clearInstance

public static void clearInstance()
カレンダーマネージャのインスタンスを初期化します。

アクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。
通常、このメソッドを使用する必要はありません。

addCalendarInfo

public void addCalendarInfo(String calendarId,
                            CalendarInfo calendarInfo)
                     throws AccessSecurityException
カレンダーデータを新規に追加します。

パラメータ:
calendarId - カレンダーID
calendarInfo - カレンダーデータ
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正な場合にスローされます。

deleteCalendar

public void deleteCalendar(String calendarId)
                    throws AccessSecurityException
カレンダーを削除します。

パラメータ:
calendarId - カレンダーID
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正な場合にスローされます。

deleteCalendarInfo

public void deleteCalendarInfo(String calendarId,
                               String dataId)
                        throws AccessSecurityException
カレンダーデータを削除します。

パラメータ:
calendarId - カレンダーID
dataId - 削除するカレンダーデータID
戻り値:
カレンダーデータ
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正な場合にスローされます。

deleteCalendarInfos

public void deleteCalendarInfos(String calendarId)
                         throws AccessSecurityException
すべてのカレンダーデータを削除します。

パラメータ:
calendarId - カレンダーID
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正な場合にスローされます。

deleteCalendars

public void deleteCalendars()
                     throws AccessSecurityException
すべてのカレンダーを削除します。

例外:
AccessSecurityException - 書き込みに失敗した場合にスローされます。

exportData

public void exportData(String category,
                       OutputStream outputStream)
                throws AccessSecurityException
エクスポートを行います。

パラメータ:
outputStream - 出力ストリーム
例外:
AccessSecurityException - エクスポートに失敗した場合、または引数が不正な場合にスローされます。

getCalendarIds

public String[] getCalendarIds()
                        throws AccessSecurityException
すべてのカレンダーIDを取得します。

戻り値:
カレンダーIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getCalendarInfo

public CalendarInfo getCalendarInfo(String calendarId,
                                    String dataId)
                             throws AccessSecurityException
カレンダーデータを取得します。

パラメータ:
calendarId - カレンダーID
dataId - カレンダーデータID
戻り値:
カレンダーデータ
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正な場合にスローされます。

getCalendarInfoIds

public String[] getCalendarInfoIds(String calendarId)
                            throws AccessSecurityException
すべてのカレンダーデータIDを取得します。

パラメータ:
calendarId - カレンダーID
戻り値:
カレンダーデータIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正な場合にスローされます。

getCalendarInfos

public CalendarInfo[] getCalendarInfos(String calendarId)
                                throws AccessSecurityException
すべてのカレンダーデータを取得します。

パラメータ:
calendarId - カレンダーID
戻り値:
カレンダーに属するすべてのカレンダーデータ
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正な場合にスローされます。

getCalendarInfosByIds

public CalendarInfo[] getCalendarInfosByIds(String calendarId,
                                            String[] calendarInfoIds)
                                     throws AccessSecurityException
ログイングループ内で引数指定したカレンダーデータIDのカレンダーをすべて取得します。

パラメータ:
calendarId - カレンダーID
calendarInfoIds - カレンダーデータIDの配列
戻り値:
カレンダー情報の配列（データがない場合は空の配列を返します。）
例外:
AccessSecurityException - カレンダー情報の取得に失敗した場合にスローされます。

getCategorizedCalendarInfos

public CategorizedCalendarInfo getCategorizedCalendarInfos(String calendarId)
                                                    throws AccessSecurityException
すべてのカレンダーデータをデータタイプ別に分類して取得します。

一度、取得したカレンダーデータは、変更がない限りメモリ上にプールされ、
取得パフォーマンスの向上がなされています。(since 6.1.3)

パラメータ:
calendarId - カレンダーID
戻り値:
カレンダーに属するデータタイプ別に分類されたべてのカレンダーデータ
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getDayInfo

public DayInfo getDayInfo(CategorizedCalendarInfo categorizedCalendarInfo,
                          Date date)
                   throws AccessSecurityException
日付情報を取得します。

パラメータ:
categorizedCalendarInfo - カテゴライズカレンダーデータ
date - 日付
戻り値:
カレンダーに属するデータタイプ別に分類されたすべてのカレンダーデータ
例外:
AccessSecurityException - 引数が不正な場合にスローされます。

getDefaultCalendarId

public String getDefaultCalendarId()
デフォルトカレンダーIDを取得します。

戻り値:
デフォルトカレンダーID

getExportCategories

public String[] getExportCategories()
                             throws AccessSecurityException
カレンダーエクスポート用のカテゴリの一覧を取得します。

戻り値:
カレンダーエクスポート用カテゴリの一覧
例外:
AccessSecurityException - カレンダーエクスポート用のカテゴリの取得に失敗した場合にスローされます。

getImportCategories

public String[] getImportCategories()
                             throws AccessSecurityException
カレンダーインポート用のカテゴリの一覧を取得します。

戻り値:
カレンダーインポート用カテゴリの一覧
例外:
AccessSecurityException - カレンダーインポート用のカテゴリの取得に失敗した場合にスローされます。

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

戻り値:
ログイングループID

getMonthInfos

public DayInfo[] getMonthInfos(CategorizedCalendarInfo categorizedCalendarInfo,
                               int year,
                               int month)
                        throws AccessSecurityException
月情報を取得します。

パラメータ:
categorizedCalendarInfo - カテゴライズカレンダーデータ
year - 年
month - 月
戻り値:
カレンダーに属するデータタイプ別に分類されたすべてのカレンダーデータ
例外:
AccessSecurityException - 引数が不正な場合にスローされます。

getPlugin

public CalendarPlugin getPlugin(String pluginId)
                         throws AccessSecurityException
カレンダーデータプラグインを取得します。

存在しない場合は、nullを返却します。

パラメータ:
pluginId - 取得するカレンダーデータプラグインID
戻り値:
カレンダーデータプラグイン 引数が不正な場合にスローされます。
例外:
AccessSecurityException

getPluginIds

public String[] getPluginIds()
カレンダーデータプラグインIDの一覧を取得します。

戻り値:
カレンダーデータプラグインIDの配列

importData

public void importData(String category,
                       InputStream inputStream)
                throws AccessSecurityException
インポートを行います。

パラメータ:
category - カテゴリ名
inputStream - 入力ストリーム
例外:
AccessSecurityException - インポートに失敗した場合、または引数が不正な場合にスローされます。

isHoliday

public boolean isHoliday(String calendarId,
                         CategorizedCalendarInfo categorizedCalendarInfo,
                         Date date)
                  throws AccessSecurityException
休日かどうか判定します。

パラメータ:
calendarId - カレンダーId
categorizedCalendarInfo - カテゴライズカレンダーデータ
date - 日付情報
戻り値:
判定結果 true:休日 false:平日
例外:
AccessSecurityException - 引数が不正な場合にスローされます。

isNationalHoliday

public boolean isNationalHoliday(CategorizedCalendarInfo categorizedCalendarInfo,
                                 Date date)
                          throws AccessSecurityException
祝日かどうか判定します。

パラメータ:
categorizedCalendarInfo - カテゴライズカレンダーデータ
date - 日付情報
戻り値:
判定結果 true:祝日 false:祝日以外の日
例外:
AccessSecurityExceptionc - 引数が不正な場合にスローされます。
AccessSecurityException

isWeekday

public boolean isWeekday(String calendarId,
                         CategorizedCalendarInfo categorizedCalendarInfo,
                         Date date)
                  throws AccessSecurityException
平日かどうか判定します。

パラメータ:
calendarId - カレンダーId
categorizedCalendarInfo - カテゴライズカレンダーデータ
date - 日付情報
戻り値:
判定結果 true:平日 false:休日
例外:
AccessSecurityException - 引数が不正な場合にスローされます。

updateCalendarInfo

public void updateCalendarInfo(String calendarId,
                               CalendarInfo calendarInfo)
                        throws AccessSecurityException
カレンダーデータを更新します。

パラメータ:
calendarId - カレンダーID
calendarInfo - カレンダーデータ
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正な場合にスローされます。

isUpdate

public boolean isUpdate(String calendarId,
                        Date date)
                 throws AccessSecurityException
カレンダーデータが指定された日付よりも新しいかチェックします。

パラメータ:
calendarId - カレンダーID
date - チェック日付
例外:
AccessSecurityReadException - カレンダー情報取得に失敗した場合スローされます。
AccessSecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarPlugin (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース CalendarPlugin

既知の実装クラスの一覧:
CalendarPluginAutumnalEquinox, CalendarPluginEndOfTheMonth, CalendarPluginLastDayInTheMonth, CalendarPluginMondayMakeupHoliday, CalendarPluginVernalEquinox
public interface CalendarPlugin

カレンダデータプラグインインターフェース。

カレンダデータの有効無効を判定するプラグインのインターフェース

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
 boolean validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date)
カレンダーデータが有効かどうか検証します。

メソッドの詳細

validate

public boolean validate(CalendarManager calendarManager,
                        CategorizedCalendarInfo categorizedCalendarInfo,
                        CalendarInfo calendarInfo,
                        Date date)
カレンダーデータが有効かどうか検証します。

指定した日付に対して、カレンダーデータが有効かどうか検証します。

パラメータ:
categorizedCalendarInfo - 対象カレンダーのカテゴライズされたカレンダーデータ
calendarInfo - 対象カレンダーデータ
date - 対象の日付
戻り値:
対象のカレンダーデータが有効な場合は、trueを返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarPluginAutumnalEquinox (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス CalendarPluginAutumnalEquinox

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox
すべての実装インタフェース:
CalendarPlugin
public class CalendarPluginAutumnalEquinox
extends Object
implements CalendarPlugin

カレンダデータプラグインクラス。

カレンダデータの有効無効を判定するプラグインのクラスです。
利用方法：設定画面において、休日設定・9 月・22, 23 および 24 日
プラグイン設定で『秋分の日』を選択して利用します。
(２種類の同時設定が必要です)
判定基準：グレゴリオ歴をもとにして天文学の黄道起動計算に基づいて
定義された簡易計算式を用いて決定します。
指定の日付が秋分の日である場合に真値を、秋分の日ではない
場合に偽値を返却します。
注意事項：簡易計算式を用いて計算しているため、このロジックの有効
期間は、1900 年 3 月以降 2099 年までとなります。
(この期間外では、正しい結果を返さないことがあります)
このロジックは計算式による予測値にすぎず、日本の法律で
定められている秋分の日と完全に一致しないことがあります。
日本の祝日として定められた秋分の日の正式な日付は、前年の
2 月 1 日に国立天文台より官報として公示される文書を
参照するようにして下さい。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
CalendarPluginAutumnalEquinox()
メソッドの概要
 boolean validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date)
カレンダーデータが有効かどうか検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CalendarPluginAutumnalEquinox

public CalendarPluginAutumnalEquinox()
メソッドの詳細

validate

public boolean validate(CalendarManager calendarManager,
                        CategorizedCalendarInfo categorizedCalendarInfo,
                        CalendarInfo calendarInfo,
                        Date date)
カレンダーデータが有効かどうか検証します。

指定した日付に対して、カレンダーデータが有効かどうか検証します。
指定日付が秋分の日かどうかをチェックします。

定義:
インタフェース CalendarPlugin 内の validate
パラメータ:
categorizedCalendarInfo - 対象カレンダーのカテゴライズされたカレンダーデータ
calendarInfo - 対象カレンダーデータ
date - 対象の日付
戻り値:
対象のカレンダーデータが有効な場合は、trueを返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarPluginEndOfTheMonth (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス CalendarPluginEndOfTheMonth

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth
すべての実装インタフェース:
CalendarPlugin
public class CalendarPluginEndOfTheMonth
extends Object
implements CalendarPlugin

カレンダデータプラグインクラス。

カレンダデータの有効無効を判定するプラグインクラスです。
利用方法：設定画面において、休日設定・月曜日・プラグイン設定で
『月末』を選択して利用します。
判定基準：日付がその月の最終日である状態を
真値(月末)として判定します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
CalendarPluginEndOfTheMonth()
メソッドの概要
 boolean validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date)
カレンダーデータが有効かどうか検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CalendarPluginEndOfTheMonth

public CalendarPluginEndOfTheMonth()
メソッドの詳細

validate

public boolean validate(CalendarManager calendarManager,
                        CategorizedCalendarInfo categorizedCalendarInfo,
                        CalendarInfo calendarInfo,
                        Date date)
カレンダーデータが有効かどうか検証します。

指定した日付に対して、カレンダーデータが有効かどうか検証します。
指定日付が月末かどうかをチェックします。

定義:
インタフェース CalendarPlugin 内の validate
パラメータ:
categorizedCalendarInfo - 対象カレンダーのカテゴライズされたカレンダーデータ
calendarInfo - 対象カレンダーデータ
date - 対象の日付
戻り値:
対象のカレンダーデータが有効な場合は、trueを返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarPluginInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース CalendarPluginInfo

public interface CalendarPluginInfo

カレンダーデータプラグイン情報のインターフェース。

カレンダーデータプラグイン情報のインターフェースです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getPluginClass() カレンダーデータプラグインクラス名を取得します。
String | getPluginId() カレンダーデータプラグインIDを取得します。

メソッドの詳細

getPluginClass

public String getPluginClass()
カレンダーデータプラグインクラス名を取得します。

カレンダーデータプラグインクラスのフルパッケージ名を返却します。
CalendarPluginを実装したクラスでなければなりません。

戻り値:
カレンダーデータプラグインクラス名

getPluginId

public String getPluginId()
カレンダーデータプラグインIDを取得します。

戻り値:
カレンダーデータプラグインID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarPluginLastDayInTheMonth (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス CalendarPluginLastDayInTheMonth

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth
すべての実装インタフェース:
CalendarPlugin
public class CalendarPluginLastDayInTheMonth
extends Object
implements CalendarPlugin

カレンダデータプラグインクラス。

カレンダデータの有効無効を判定するプラグインクラスです。
月内の最終曜日を定義するためのプラグインクラスです。
利用方法：設定画面において、休日設定・月曜日・プラグイン設定で
『最終曜日』を選択して利用します。
判定基準：日付がその月の最終曜日である状態を
真値(最終曜日)として判定します。
これにより、月曜日設定と組み合わせた場合、
最終月曜日という設定が可能になります。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
CalendarPluginLastDayInTheMonth()
メソッドの概要
 boolean validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date)
カレンダーデータが有効かどうか検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CalendarPluginLastDayInTheMonth

public CalendarPluginLastDayInTheMonth()
メソッドの詳細

validate

public boolean validate(CalendarManager calendarManager,
                        CategorizedCalendarInfo categorizedCalendarInfo,
                        CalendarInfo calendarInfo,
                        Date date)
カレンダーデータが有効かどうか検証します。

指定した日付に対して、カレンダーデータが有効かどうか検証します。
指定日付が最終曜日かどうかをチェックします。

定義:
インタフェース CalendarPlugin 内の validate
パラメータ:
categorizedCalendarInfo - 対象カレンダーのカテゴライズされたカレンダーデータ
calendarInfo - 対象カレンダーデータ
date - 対象の日付
戻り値:
対象のカレンダーデータが有効な場合は、trueを返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarPluginMondayMakeupHoliday (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス CalendarPluginMondayMakeupHoliday

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday
すべての実装インタフェース:
CalendarPlugin
public class CalendarPluginMondayMakeupHoliday
extends Object
implements CalendarPlugin

カレンダデータプラグインクラス。

カレンダデータの有効無効を判定するプラグインのクラスです。
振替休日を定義するためのプラグインです。
利用方法：設定画面において、休日設定・月曜日・プラグイン設定で
『振替休日』を選択して利用します。
判定基準：前日が休日設定であり、２種類以上の休日設定が重なっている
状態を真値(振替休日)とし１種類の休日設定のみの判定である
状態を偽値(休日ではない)と判定します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
CalendarPluginMondayMakeupHoliday()
メソッドの概要
 boolean validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date)
カレンダーデータが有効かどうか検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CalendarPluginMondayMakeupHoliday

public CalendarPluginMondayMakeupHoliday()
メソッドの詳細

validate

public boolean validate(CalendarManager calendarManager,
                        CategorizedCalendarInfo categorizedCalendarInfo,
                        CalendarInfo calendarInfo,
                        Date date)
カレンダーデータが有効かどうか検証します。

指定した日付に対して、カレンダーデータが有効かどうか検証します。
指定日付が振替休日扱いかどうかをチェックします。

定義:
インタフェース CalendarPlugin 内の validate
パラメータ:
categorizedCalendarInfo - 対象カレンダーのカテゴライズされたカレンダーデータ
calendarInfo - 対象カレンダーデータ
date - 対象の日付
戻り値:
対象のカレンダーデータが有効な場合は、trueを返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarPluginVernalEquinox (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス CalendarPluginVernalEquinox

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox
すべての実装インタフェース:
CalendarPlugin
public class CalendarPluginVernalEquinox
extends Object
implements CalendarPlugin

カレンダデータプラグインクラス。

カレンダデータの有効無効を判定するプラグインのクラスです。
利用方法：設定画面において、休日設定・3 月・19, 20, 21 および 22 日
プラグイン設定で『春分の日』を選択して利用します。
(２種類の同時設定が必要です)
判定基準：グレゴリオ歴をもとにして天文学の黄道起動計算に基づいて
定義された簡易計算式を用いて決定します。
指定の日付が春分の日である場合に真値を、春分の日ではない
場合に偽値を返却します。
注意事項：簡易計算式を用いて計算しているため、このロジックの有効
期間は、1960 年 3 月以降 2099 年までとなります。
(この期間外では、正しい結果を返さないことがあります)
このロジックは計算式による予測値にすぎず、日本の法律で
定められている春分の日と完全に一致しないことがあります。
日本の祝日として定められた春分の日の正式な日付は、前年の
2 月 1 日に国立天文台より官報として公示される文書を
参照するようにして下さい。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
CalendarPluginVernalEquinox()
メソッドの概要
 boolean validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date)
カレンダーデータが有効かどうか検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CalendarPluginVernalEquinox

public CalendarPluginVernalEquinox()
メソッドの詳細

validate

public boolean validate(CalendarManager calendarManager,
                        CategorizedCalendarInfo categorizedCalendarInfo,
                        CalendarInfo calendarInfo,
                        Date date)
カレンダーデータが有効かどうか検証します。

指定した日付に対して、カレンダーデータが有効かどうか検証します。
指定日付が春分の日かどうかをチェックします。

定義:
インタフェース CalendarPlugin 内の validate
パラメータ:
categorizedCalendarInfo - 対象カレンダーのカテゴライズされたカレンダーデータ
calendarInfo - 対象カレンダーデータ
date - 対象の日付
戻り値:
対象のカレンダーデータが有効な場合は、trueを返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarPostWriterListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース CalendarPostWriterListener

public interface CalendarPostWriterListener

カレンダー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
CalendarManager

メソッドの概要
void | init(Map params) カレンダーリスナーの初期化。
void | postCreateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに作成した直後にコールされます。
void | postDeleteCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータをデータストアから削除した直後にコールされます。
void | postUpdateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
カレンダーリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreateCalendarInfo

public void postCreateCalendarInfo(String groupId,
                                   String calendarId,
                                   CalendarInfo calendarInfo)
                            throws AccessSecurityListenerExcpetion
カレンダーデータをデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfo - 作成されたカレンダーデータ
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteCalendarInfo

public void postDeleteCalendarInfo(String groupId,
                                   String calendarId,
                                   String dataId)
                            throws AccessSecurityListenerExcpetion
カレンダーデータをデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
dataId - 削除されたカレンダーデータID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateCalendarInfo

public void postUpdateCalendarInfo(String groupId,
                                   String calendarId,
                                   CalendarInfo calendarInfo)
                            throws AccessSecurityListenerExcpetion
カレンダーデータをデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfo - 更新されたカレンダーデータ
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarQueryWriterListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース CalendarQueryWriterListener

public interface CalendarQueryWriterListener

カレンダー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
CalendarManager

メソッドの概要
void | init(Map params) カレンダーリスナーの初期化。
void | queryCreateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに作成する直前にコールされます。
void | queryDeleteCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータをデータストアから削除する直前にコールされます。
void | queryUpdateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
カレンダーリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreateCalendarInfo

public void queryCreateCalendarInfo(String groupId,
                                    String calendarId,
                                    CalendarInfo calendarInfo)
                             throws AccessSecurityListenerExcpetion
カレンダーデータをデータストアに作成する直前にコールされます。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfo - 作成されるカレンダーデータ
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteCalendarInfo

public void queryDeleteCalendarInfo(String groupId,
                                    String calendarId,
                                    String dataId)
                             throws AccessSecurityListenerExcpetion
カレンダーデータをデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
dataId - 削除されるカレンダーデータID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdateCalendarInfo

public void queryUpdateCalendarInfo(String groupId,
                                    String calendarId,
                                    CalendarInfo calendarInfo)
                             throws AccessSecurityListenerExcpetion
カレンダーデータをデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfo - 更新されるカレンダーデータ
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarReaderDecorator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース CalendarReaderDecorator

public interface CalendarReaderDecorator

アカウント情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
CalendarInfo | doDecoration(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアからの読み込み直後にコールされます。
void | init(Map params) カレンダーデコレータの初期化。

メソッドの詳細

init

public void init(Map params)
カレンダーデコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public CalendarInfo doDecoration(String groupId,
                                 String calendarId,
                                 CalendarInfo calendarInfo)
カレンダーデータをデータストアからの読み込み直後にコールされます。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfo - 読み込みが行われたカレンダーデータ
戻り値:
拡張されたカレンダーデータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CategorizedCalendarInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス CategorizedCalendarInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo
public class CategorizedCalendarInfo
extends Object

カテゴライズカレンダーデータクラス。

データタイプで分類されたされたカレンダーデータの情報を保持するクラス。

分類されるデータタイプの種類は、以下の通りです。

  • 名称（ CalendarInfo.TYPE_CONFIG） getConfigDayInfos()
  • 休日（ CalendarInfo.TYPE_HOLIDAY） getHodildayInfos()
  • 非休日（ CalendarInfo.TYPE_WEEKDAY） getWeekdayInfos()
  • 祝祭日（ CalendarInfo.TYPE_NATIONAL_HOLDAY） getNationalHodildayInfos()

    • 導入されたバージョン:
    5.0
    バージョン:
    1.0

    コンストラクタの概要
    protected CategorizedCalendarInfo(CalendarInfo[] calendarInfos)
    コンストラクタ。
    メソッドの概要
CalendarInfo[] | getConfigDayInfos() データタイプが名称であるカレンダーデータの一覧を取得します。
CalendarInfo[] | getHodildayInfos() データタイプが休日であるカレンダーデータの一覧を取得します。
CalendarInfo[] | getNationalHodildayInfos() データタイプが祝祭日であるカレンダーデータの一覧を取得します。
CalendarInfo[] | getWeekdayInfos() データタイプが非休日であるカレンダーデータの一覧を取得します。
    クラス java.lang.Object から継承したメソッド
    clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    コンストラクタの詳細

    CategorizedCalendarInfo

    protected CategorizedCalendarInfo(CalendarInfo[] calendarInfos)
    コンストラクタ。

    パラメータ:
    calendarInfos - カレンダデータの配列
    メソッドの詳細

    getConfigDayInfos

    public CalendarInfo[] getConfigDayInfos()
    データタイプが名称であるカレンダーデータの一覧を取得します。

    戻り値:
    データタイプが名称であるカレンダーデータの配列

    getHodildayInfos

    public CalendarInfo[] getHodildayInfos()
    データタイプが休日であるカレンダーデータの一覧を取得します。

    戻り値:
    データタイプが休日であるカレンダーデータの配列

    getNationalHodildayInfos

    public CalendarInfo[] getNationalHodildayInfos()
    データタイプが祝祭日であるカレンダーデータの一覧を取得します。

    戻り値:
    データタイプが祝祭日であるカレンダーデータの配列

    getWeekdayInfos

    public CalendarInfo[] getWeekdayInfos()
    データタイプが非休日であるカレンダーデータの一覧を取得します。

    戻り値:
    データタイプが非休日であるカレンダーデータの配列
    概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
            intra-mart 6.1.14
    前のクラス 次のクラス フレームあり フレームなし
    概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DayInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース DayInfo

public interface DayInfo

日付に対するカレンダーデータ情報の取得インターフェース。

日付に対するカレンダーデータの情報にアクセスするインターフェースです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
CalendarInfo[] | getCalendarInfo() マッチしたカレンダーデータの一覧を取得します。
String | getColor() 背景色を取得します。
Date | getDate() 対象の日付を取得します。
int | getMatchCount() 名称設定以外でマッチしたカレンダーデータの数を取得します。
boolean | isHoliday() 休日設定にマッチしているかどうかを取得します。
boolean | isNationalHoliday() 祝祭日設定にマッチしているかどうかを取得します。。
boolean | isWeekday() 非休日設定にマッチしているかどうかを取得します。

メソッドの詳細

getColor

public String getColor()
背景色を取得します。

戻り値:
背景色

getDate

public Date getDate()
対象の日付を取得します。

戻り値:
date

getCalendarInfo

public CalendarInfo[] getCalendarInfo()
マッチしたカレンダーデータの一覧を取得します。

戻り値:
マッチしたカレンダーデータの配列

isHoliday

public boolean isHoliday()
休日設定にマッチしているかどうかを取得します。

戻り値:
休日設定にマッチしている場合はtrue

isNationalHoliday

public boolean isNationalHoliday()
祝祭日設定にマッチしているかどうかを取得します。。

戻り値:
祝祭日設定にマッチしている場合はtrue

isWeekday

public boolean isWeekday()
非休日設定にマッチしているかどうかを取得します。

戻り値:
非休日設定にマッチしている場合はtrue

getMatchCount

public int getMatchCount()
名称設定以外でマッチしたカレンダーデータの数を取得します。

戻り値:
名称設定以外でマッチしたカレンダーデータの数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.calendar (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.security.calendar
インタフェース
CalendarAccessor
CalendarExporter
CalendarImporter
CalendarPlugin
CalendarPluginInfo
CalendarPostWriterListener
CalendarQueryWriterListener
CalendarReaderDecorator
DayInfo
クラス
CalendarInfo
CalendarManager
CalendarPluginAutumnalEquinox
CalendarPluginEndOfTheMonth
CalendarPluginLastDayInTheMonth
CalendarPluginMondayMakeupHoliday
CalendarPluginVernalEquinox
CategorizedCalendarInfo
StandardCalendarBackup


jp.co.intra_mart.foundation.security.calendar (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.calendar

カレンダーに関連するクラスを提供します。

参照:
説明

インタフェースの概要
CalendarAccessor | カレンダーアクセッサインタフェース。
CalendarExporter | カレンダーバックアップインタフェースです。
CalendarImporter | カレンダーバックアップインタフェースです。
CalendarPlugin | カレンダデータプラグインインターフェース。
CalendarPluginInfo | カレンダーデータプラグイン情報のインターフェース。
CalendarPostWriterListener | カレンダー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
CalendarQueryWriterListener | カレンダー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
CalendarReaderDecorator | アカウント情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
DayInfo | 日付に対するカレンダーデータ情報の取得インターフェース。

クラスの概要
CalendarInfo | カレンダーデータ・モデルクラス
CalendarManager | カレンダーマネージャクラス カレンダー情報の操作を行います。
CalendarPluginAutumnalEquinox | カレンダデータプラグインクラス。
CalendarPluginEndOfTheMonth | カレンダデータプラグインクラス。
CalendarPluginLastDayInTheMonth | カレンダデータプラグインクラス。
CalendarPluginMondayMakeupHoliday | カレンダデータプラグインクラス。
CalendarPluginVernalEquinox | カレンダデータプラグインクラス。
CategorizedCalendarInfo | カテゴライズカレンダーデータクラス。
StandardCalendarBackup | カレンダーバックアップクラスです。

パッケージ jp.co.intra_mart.foundation.security.calendar の説明

カレンダーに関連するクラスを提供します。


jp.co.intra_mart.foundation.security.calendar クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.calendar の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.calendar.CalendarInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarManager
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo
    • class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup (implements jp.co.intra_mart.foundation.security.calendar.CalendarExporter, jp.co.intra_mart.foundation.security.calendar.CalendarImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarExporter
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarImporter
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarPlugin
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator
  • interface jp.co.intra_mart.foundation.security.calendar.DayInfo


パッケージ jp.co.intra_mart.foundation.security.calendar の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.calendar の使用

jp.co.intra_mart.foundation.security.calendar を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。

jp.co.intra_mart.foundation.security により使用される jp.co.intra_mart.foundation.security.calendar のクラス
CalendarAccessor
カレンダーアクセッサインタフェース。
CalendarInfo
カレンダーデータ・モデルクラス

jp.co.intra_mart.foundation.security.calendar により使用される jp.co.intra_mart.foundation.security.calendar のクラス
CalendarExporter
カレンダーバックアップインタフェースです。
CalendarImporter
カレンダーバックアップインタフェースです。
CalendarInfo
カレンダーデータ・モデルクラス
CalendarManager
カレンダーマネージャクラス

カレンダー情報の操作を行います。
CalendarPlugin
カレンダデータプラグインインターフェース。
CategorizedCalendarInfo
カテゴライズカレンダーデータクラス。
DayInfo
日付に対するカレンダーデータ情報の取得インターフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardCalendarBackup (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス StandardCalendarBackup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup
すべての実装インタフェース:
CalendarExporter, CalendarImporter
public class StandardCalendarBackup
extends Object
implements CalendarImporter, CalendarExporter

カレンダーバックアップクラスです。

バージョン:
1.0

コンストラクタの概要
StandardCalendarBackup()
メソッドの概要
void | doExport(CalendarManager manager, OutputStream outputStream) エクスポートを行います。
void | doImport(InputStream inputStream, CalendarManager manager) インポートを行います。
void | init(Map params) カレンダーバックアップの初期化。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardCalendarBackup

public StandardCalendarBackup()
メソッドの詳細

init

public void init(Map params)
カレンダーバックアップの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース CalendarImporter 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     CalendarManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリームからカレンダーと
付随するカレンダーデータを取得し、生成します。

定義:
インタフェース CalendarImporter 内の doImport
パラメータ:
manager - カレンダーマネージャクラス
inputStream - 入力ストリーム
戻り値:
バッチモデルクラスの配列
例外:
AccessSecurityImportException

doExport

public void doExport(CalendarManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

カレンダーとカレンダーデータを
バックアップファイルに出力します。

定義:
インタフェース CalendarExporter 内の doExport
パラメータ:
manager - カレンダーマネージャクラス
outputStream - 出力ストリーム
例外:
AccessSecurityExportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.security.certification.ErrorPageProvider の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.certification.ErrorPageProvider の使用

ErrorPageProvider を使用しているパッケージ
jp.co.intra_mart.foundation.security.certification 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.certification での ErrorPageProvider の使用

ErrorPageProvider を実装している jp.co.intra_mart.foundation.security.certification のクラス
 class StandardErrorPageProvider
標準のエラーページプロバイダクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.LDAPUserCertification の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.LDAPUserCertification の使用

jp.co.intra_mart.foundation.security.certification.LDAPUserCertification はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.certification.LoginInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.certification.LoginInfo の使用

LoginInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession |
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification.ldap.extension | ユーザログインLDAP認証クラス(複数OU対応版)の設定方法。

jp.co.intra_mart.foundation.security での LoginInfo の使用

LoginInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
 int AccessSecurityManager.getLicense(LoginInfo loginInfo)
アカウントライセンスチェックを行います。

jp.co.intra_mart.foundation.security.activesession での LoginInfo の使用

LoginInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.activesession のメソッド
void | UserActiveSessionRegister.doCertification(int certificationResult, LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザの認証後にコールされるメソッドです。
void | GroupActiveSessionRegister.doCertification(int certificationResult, LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者の認証後にコールされるメソッドです。

jp.co.intra_mart.foundation.security.certification での LoginInfo の使用

jp.co.intra_mart.foundation.security.certification での LoginInfo のサブインタフェース
 interface LoginRequestInfo
intra-martログイン情報操作インタフェース。

LoginInfo を返す jp.co.intra_mart.foundation.security.certification のメソッド
LoginInfo | RequestAnalyzer.parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。
LoginInfo | StandardRequestAnalyzer.parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。
LoginInfo | SSORequestAnalyzer.parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。

LoginInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.certification のメソッド
void | UserCertificationListener.doCertification(int certificationResult, LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザの認証後にコールされるメソッドです。
int | UserCertification.certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証する。
int | SuperUserNoCertification.certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証します。
void | SuperCertificationListener.doCertification(int certificationResult, LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者の認証後にコールされるメソッドです。
int | SuperCertification.certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証する。
int | StandardUserCertification.certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証します。
int | StandardSuperUserCertification.certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証します。
int | LDAPUserCertification.certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証する。

jp.co.intra_mart.foundation.security.certification.ldap.extension での LoginInfo の使用

LoginInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.certification.ldap.extension のメソッド
 int LDAPUserCertification.certification(LoginInfo loginInfo, Account account, HttpServletRequest req, HttpServletResponse resp)
LDAPに対してユーザを認証します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.certification.LoginRequestInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.certification.LoginRequestInfo の使用

LoginRequestInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security での LoginRequestInfo の使用

LoginRequestInfo を返す jp.co.intra_mart.foundation.security のメソッド
 LoginRequestInfo AccessSecurityManager.createLoginRequestInfo(String loginType)
ログイン情報を作成します。

LoginRequestInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
int | AccessSecurityManager.forceLogin(LoginRequestInfo loginRequestInfo) 強制ログイン処理を行います。
int | AccessSecurityManager.forceLogin(LoginRequestInfo loginRequestInfo, HttpServletRequest request, HttpServletResponse response) 強制ログイン処理を行います。
int | AccessSecurityManager.getInitialCertification(LoginRequestInfo loginInfo) カレントスレッドの情報から初期アクセス処理を行います。
int | AccessSecurityManager.getInitialCertification(LoginRequestInfo loginInfo, HttpServletRequest request, HttpServletResponse response) 初期アクセス処理を行います。
int | AccessSecurityManager.login(LoginRequestInfo loginRequestInfo) ログイン処理を行います。
int | AccessSecurityManager.login(LoginRequestInfo loginRequestInfo, HttpServletRequest request, HttpServletResponse response) ログイン処理を行います。

jp.co.intra_mart.foundation.security.certification での LoginRequestInfo の使用

LoginRequestInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.certification のメソッド
LoginInfo | RequestAnalyzer.parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。
LoginInfo | StandardRequestAnalyzer.parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。
LoginInfo | SSORequestAnalyzer.parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider の使用

PortalStandardUserPageProvider を使用しているパッケージ
jp.co.intra_mart.foundation.security.password

jp.co.intra_mart.foundation.security.password での PortalStandardUserPageProvider の使用

jp.co.intra_mart.foundation.security.password での PortalStandardUserPageProvider のサブクラス
 class PasswordHistoryUserPageProvider
パスワード履歴管理スタンダードユーザページプロバイダクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.certification.RequestAnalyzer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.certification.RequestAnalyzer の使用

RequestAnalyzer を使用しているパッケージ
jp.co.intra_mart.foundation.security.certification 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.certification での RequestAnalyzer の使用

RequestAnalyzer を実装している jp.co.intra_mart.foundation.security.certification のクラス
class | SSORequestAnalyzer SSOのログインリクエスト解析クラス。
class | StandardRequestAnalyzer 標準のログインリクエスト解析クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の使用

jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider の使用

jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider の使用

jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer の使用

StandardRequestAnalyzer を使用しているパッケージ
jp.co.intra_mart.foundation.security.certification 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.certification での StandardRequestAnalyzer の使用

jp.co.intra_mart.foundation.security.certification での StandardRequestAnalyzer のサブクラス
 class SSORequestAnalyzer
SSOのログインリクエスト解析クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification の使用

jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider の使用

jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.StandardUserCertification の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.StandardUserCertification の使用

StandardUserCertification を使用しているパッケージ
jp.co.intra_mart.foundation.security.certification 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.certification での StandardUserCertification の使用

jp.co.intra_mart.foundation.security.certification での StandardUserCertification のサブクラス
 class LDAPUserCertification
ユーザログインLDAP認証クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider の使用

StandardUserPageProvider を使用しているパッケージ
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.password |

jp.co.intra_mart.foundation.security.certification での StandardUserPageProvider の使用

jp.co.intra_mart.foundation.security.certification での StandardUserPageProvider のサブクラス
 class PortalStandardUserPageProvider
ポータルユーザページプロバイダクラス。

jp.co.intra_mart.foundation.security.password での StandardUserPageProvider の使用

jp.co.intra_mart.foundation.security.password での StandardUserPageProvider のサブクラス
 class PasswordHistoryUserPageProvider
パスワード履歴管理スタンダードユーザページプロバイダクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.certification.SuperCertification の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.certification.SuperCertification の使用

SuperCertification を使用しているパッケージ
jp.co.intra_mart.foundation.security.certification 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.certification での SuperCertification の使用

SuperCertification を実装している jp.co.intra_mart.foundation.security.certification のクラス
class | StandardSuperUserCertification 管理者ログイン認証の実装クラス。
class | SuperUserNoCertification システム管理者ログイン時に強制認証を行う実装クラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.certification.SuperCertificationListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.certification.SuperCertificationListener の使用

SuperCertificationListener を使用しているパッケージ
jp.co.intra_mart.foundation.security.activesession

jp.co.intra_mart.foundation.security.activesession での SuperCertificationListener の使用

SuperCertificationListener を実装している jp.co.intra_mart.foundation.security.activesession のクラス
 class GroupActiveSessionRegister
管理者ログイン認証リスナー実装クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification の使用

jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.certification.UserCertification の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.certification.UserCertification の使用

UserCertification を使用しているパッケージ
jp.co.intra_mart.foundation.security.certification 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.certification での UserCertification の使用

UserCertification を実装している jp.co.intra_mart.foundation.security.certification のクラス
class | LDAPUserCertification ユーザログインLDAP認証クラス。
class | StandardUserCertification ユーザログイン認証クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.certification.UserCertificationListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.certification.UserCertificationListener の使用

UserCertificationListener を使用しているパッケージ
jp.co.intra_mart.foundation.security.activesession

jp.co.intra_mart.foundation.security.activesession での UserCertificationListener の使用

UserCertificationListener を実装している jp.co.intra_mart.foundation.security.activesession のクラス
 class UserActiveSessionRegister
ユーザログイン認証リスナー実装クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.certification.UserPageProvider の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.certification.UserPageProvider の使用

UserPageProvider を使用しているパッケージ
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.password |

jp.co.intra_mart.foundation.security.certification での UserPageProvider の使用

UserPageProvider を実装している jp.co.intra_mart.foundation.security.certification のクラス
class | PortalStandardUserPageProvider ポータルユーザページプロバイダクラス。
class | StandardGroupSuperUserPageProvider 標準のログイングループ管理者用ページプロバイダクラス。
class | StandardSuperUserPageProvider 標準のシステム管理者用のユーザページプロバイダクラス。
class | StandardUserPageProvider 標準のユーザページプロバイダクラス。

jp.co.intra_mart.foundation.security.password での UserPageProvider の使用

UserPageProvider を実装している jp.co.intra_mart.foundation.security.password のクラス
 class PasswordHistoryUserPageProvider
パスワード履歴管理スタンダードユーザページプロバイダクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoBuilder の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoBuilder の使用

jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoBuilder はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel の使用

jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPUserCertification の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPUserCertification の使用

jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPUserCertification はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


LDAPContextInfoBuilder (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification.ldap.extension
クラス LDAPContextInfoBuilder

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoBuilder
public class LDAPContextInfoBuilder
extends Object

ログイングループ毎の設定情報モデルを作成するビルドクラス。
作成された設定情報モデルは、ログイングループID毎に纏められ、
Mapに格納されて返される。

key | value
String：ログイングループID | LDAPContextInfoModel：設定情報モデル

導入されたバージョン:
5.1
バージョン:
1.0

コンストラクタの概要
LDAPContextInfoBuilder()
メソッドの概要
static Map buildLDAPContextInfo(Map params)
設定情報モデルをログイングループID毎に作成し、Mapで返す。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LDAPContextInfoBuilder

public LDAPContextInfoBuilder()
メソッドの詳細

buildLDAPContextInfo

public static Map buildLDAPContextInfo(Map params)
設定情報モデルをログイングループID毎に作成し、Mapで返す。
「[AP_HOME]/conf/access-security.xml」の"security-config/user-security/auto-certification"及び
"security-config/user-security/certification"に設定されている＜init-param＞タグ情報を元に
作成する。

パラメータ:
params - xml上の設定情報
戻り値:
ログイングループID毎の設定情報モデルのMap
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LDAPContextInfoModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification.ldap.extension
クラス LDAPContextInfoModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel
public class LDAPContextInfoModel
extends Object

ユーザログインLDAP認証で認証情報モデルクラス(複数OU対応版)。

LDAPログイン認証を行うための認証情報を保持するクラス

導入されたバージョン:
5.1
バージョン:
1.0

コンストラクタの概要
LDAPContextInfoModel()
メソッドの概要
void | addOtherInfo(Object key, Object value) その他情報を追加する。
String | getBaseDn() ベースDNを取得する。
String | getConnectTimeout() 接続タイムアウト時間を取得する。
String | getConnectTimeoutPropertyName() 接続タイムアウトを設定するプロパティ名を取得する。
String | getGroupId() ログイングループIDを取得する。
String | getSerchFilter() 検索フィルタを取得する。
boolean | isAttemptOnFailedAuthentication() LDAP認証失敗(ユーザIDまたはパスワードが不正)時に次のプロバイダURLに認証の試みを取得する。
boolean | isLoadBalancing() ロードバランサの有効・無効を設定を取得する。
Hashtable | makeCertifyEnvironment(Hashtable serchEnvironment, String userDn, String delim, String passwd) LDAP認証用の設定情報を作成する。
SearchControls | makeSearchControls() 検索用のサーチコントローラーを作成する。
Hashtable[] | makeSerchEnvironments() LDAP上のユーザを検索する為の設定情報を作成する。
void | setAttemptOnFailedAuthentication(String attemptOnFailedAuthentication) LDAP認証失敗(ユーザIDまたはパスワードが不正)時に次のプロバイダURLに認証の試みを設定する。
void | setBaseDn(String baseDn) ベースDNを設定する。
void | setConnectTimeout(String connectTimeout) 接続タイムアウト時間を設定する。
void | setConnectTimeoutPropertyName(String connectTimeoutPropertyName) 接続タイムアウトを設定するプロパティ名を設定する。
void | setContextFactory(String contextFactory) コンテキストファクトリを設定する。
void | setCountLimit(String countLimit) 最大検索数を設定する。
void | setDerefLinf(String derefLinf) 間接参照の有無を設定する。
void | setGroupId(String groupId) ログイングループIDを設定する。
void | setLoadBalancing(String loadBalancing) ロードバランサの有効・無効を設定する。
void | setProviderUrl(String providerUrl) プロパイダーURLを設定する。
void | setReturningAttributes(String returningAttributes, String delim) 結果属性指定を設定する。
void | setReturningObj(String returningObj) 結果としてオブジェクト許可を設定する。
void | setSerchFilter(String serchFilter) 検索フィルタを設定する。
void | setSerchingDn(String serchingDn) 検索用ユーザDNを設定する。
void | setSerchingPw(String serchingPw) 検索用ユーザパスワードを設定する。
void | setTimeLimit(String timeLimit) 時間制限を設定する。
String | toString() 設定情報モデルの内容を返す。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

LDAPContextInfoModel

public LDAPContextInfoModel()
メソッドの詳細

getBaseDn

public String getBaseDn()
ベースDNを取得する。

戻り値:
ベースDN

setBaseDn

public void setBaseDn(String baseDn)
ベースDNを設定する。

パラメータ:
baseDn - ベースDN

setContextFactory

public void setContextFactory(String contextFactory)
コンテキストファクトリを設定する。

パラメータ:
contextFactory - コンテキストファクトリ

setCountLimit

public void setCountLimit(String countLimit)
最大検索数を設定する。

パラメータ:
countLimit - 最大検索数(文字列)

setDerefLinf

public void setDerefLinf(String derefLinf)
間接参照の有無を設定する。

パラメータ:
derefLinf - 間接参照の有無(文字列)

setProviderUrl

public void setProviderUrl(String providerUrl)
プロパイダーURLを設定する。

パラメータ:
providerUrl - プロパイダーURL

setReturningAttributes

public void setReturningAttributes(String returningAttributes,
                                   String delim)
結果属性指定を設定する。

パラメータ:
returningAttributes - 結果属性指定(複数指定可能)
delim - 区切文字

setReturningObj

public void setReturningObj(String returningObj)
結果としてオブジェクト許可を設定する。

パラメータ:
returningObj - 結果としてオブジェクト許可

getSerchFilter

public String getSerchFilter()
検索フィルタを取得する。

戻り値:
検索フィルタ

setSerchFilter

public void setSerchFilter(String serchFilter)
検索フィルタを設定する。

パラメータ:
serchFilter - 検索フィルタ

setLoadBalancing

public void setLoadBalancing(String loadBalancing)
ロードバランサの有効・無効を設定する。

パラメータ:
loadBalancing - ロードバランサの有効・無効

isLoadBalancing

public boolean isLoadBalancing()
ロードバランサの有効・無効を設定を取得する。

戻り値:
ロードバランサの有効・無効

setConnectTimeoutPropertyName

public void setConnectTimeoutPropertyName(String connectTimeoutPropertyName)
接続タイムアウトを設定するプロパティ名を設定する。

パラメータ:
connectTimeoutPropertyName - 接続タイムアウトを設定するプロパティ名

getConnectTimeoutPropertyName

public String getConnectTimeoutPropertyName()
接続タイムアウトを設定するプロパティ名を取得する。

戻り値:
接続タイムアウトを設定するプロパティ名

setConnectTimeout

public void setConnectTimeout(String connectTimeout)
接続タイムアウト時間を設定する。

パラメータ:
connectTimeout - 接続タイムアウト時間

getConnectTimeout

public String getConnectTimeout()
接続タイムアウト時間を取得する。

戻り値:
接続タイムアウト時間

isAttemptOnFailedAuthentication

public boolean isAttemptOnFailedAuthentication()
LDAP認証失敗(ユーザIDまたはパスワードが不正)時に次のプロバイダURLに認証の試みを取得する。

戻り値:
LDAP認証失敗時に次のプロバイダURLに認証の試み

setAttemptOnFailedAuthentication

public void setAttemptOnFailedAuthentication(String attemptOnFailedAuthentication)
LDAP認証失敗(ユーザIDまたはパスワードが不正)時に次のプロバイダURLに認証の試みを設定する。

パラメータ:
attemptOnFailedAuthentication - LDAP認証失敗時に次のプロバイダURLに認証の試み

setSerchingDn

public void setSerchingDn(String serchingDn)
検索用ユーザDNを設定する。

パラメータ:
serchingDn - 検索用ユーザDN

setSerchingPw

public void setSerchingPw(String serchingPw)
検索用ユーザパスワードを設定する。

パラメータ:
serchingPw - 検索用ユーザパスワード

setTimeLimit

public void setTimeLimit(String timeLimit)
時間制限を設定する。

パラメータ:
timeLimit - 時間制限

getGroupId

public String getGroupId()
ログイングループIDを取得する。

戻り値:
ログイングループID

setGroupId

public void setGroupId(String groupId)
ログイングループIDを設定する。

パラメータ:
groupId - ログイングループID

addOtherInfo

public void addOtherInfo(Object key,
                         Object value)
その他情報を追加する。

パラメータ:
key - キー
value - 値

makeSerchEnvironments

public Hashtable[] makeSerchEnvironments()
LDAP上のユーザを検索する為の設定情報を作成する。

戻り値:
設定情報

makeSearchControls

public SearchControls makeSearchControls()
検索用のサーチコントローラーを作成する。

戻り値:
サーチコントローラー

makeCertifyEnvironment

public Hashtable makeCertifyEnvironment(Hashtable serchEnvironment,
                                        String userDn,
                                        String delim,
                                        String passwd)
LDAP認証用の設定情報を作成する。

パラメータ:
serchEnvironment - 設定情報
userDn - ユーザDN
delim - ユーザDNとベースDNを繋げる区切文字(デフォルト：カンマ[,])
passwd - パスワード
戻り値:
設定情報

toString

public String toString()
設定情報モデルの内容を返す。

戻り値:
設定情報モデルの内容
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LDAPUserCertification (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification.ldap.extension
クラス LDAPUserCertification

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardUserCertification
        拡張 jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPUserCertification
すべての実装インタフェース:
UserCertification
public class LDAPUserCertification
extends StandardUserCertification

ユーザログインLDAP認証クラス(複数OU対応版)。

一般ユーザのLDAPログイン認証を行うためのクラス

初期化パラメータは以下のものを必要とします。
ログイングループごとに必須パラメータとLDAP環境による任意パラメータが必要です。

必須パラメータ | 説明
ログイングループID.provider-url | プロバイダURLを設定します(Ex : ldap://localhost:389/)。 カンマ(,)区切りで複数指定可能(Ex : ldap://localhost:389/, ldap://localhost:27272/)。 複数指定した場合、左から順にLDAPサーバに通信を試みます。通信できない場合のみ次の接続先に通信を試みます。
ログイングループID.context-factory | コンテキストファクトリを設定します。（Ex : com.sun.jndi.ldap.LdapCtxFactory）
ログイングループID.base-dn | 識別情報のベースを設定します。（Ex : dc=ldaps,dc=intra-mart,dc=jp）
ログイングループID.serch-filter | ユーザを特定する為に一意になる属性を設定します。（Ex : uid=?）
任意パラメータ | 説明
ログイングループID.load-balancing | ロードバランサを有効にします。(true/false) 設定しない場合はfalseとして扱います。 falseを指定した場合、プロバイダURLを左から順に認証を試みます。 trueを指定した場合、プロバイダURLの開始位置をランダムに決定し、決定した位置を基準に右方向に順に認証を試みます。
ログイングループID.attempt-on-failed-authentication | LDAP認証失敗(ユーザIDまたはパスワードが不正)時に次のプロバイダURLに認証を試みます(true/false)。 設定しない場合はfalseとして扱います。 falseを指定した場合、次のプロバイダURLに認証を試みません。 trueを指定した場合、次のプロバイダURLに認証を試みます。
ログイングループID.connect-timeout-property-name | 接続タイムアウトを設定するプロパティ名を設定します。（Ex : com.sun.jndi.ldap.connect.timeout）
ログイングループID.connect-timeout | 接続タイムアウト時間を設定します。 プロパティに com.sun.jndi.ldap.connect.timeout を指定した場合、ミリ秒数を示す0より大きい整数で指定し、LDAP プロバイダがこの値の期間中に接続を確立できないと、接続の試行は中止されます。 0 以下の整数指定した場合または設定しない場合は、TCP などのネットワークプロトコルのタイムアウト値が使用されます。
ログイングループID.serching-dn | LDAP上でユーザを検索する為のユーザ(DN)を設定します。(Ex : uid=admin,cn=User,dc=ldaps,dc=intra,dc=intra-mart,dc=jp) この設定は、ActiveDirectoryの場合には必要になります。
ログイングループID.serching-pw | LDAP上でユーザを検索する為のユーザパスワードを設定します。（Ex : admin） この設定は、ActiveDirectoryの場合には必要になります。
検索パラメータ | 説明
ログイングループID.count-limit | 最大検索数を設定します。デフォルト：0（上限無し）
ログイングループID.time-limit | 時間制限（ミリ秒）を設定します。デフォルト：0（無制限）
ログイングループID.deref-linf | 間接参照の有無を設定します。デフォルト：false
ログイングループID.returning-obj | 結果の一部がオブジェクトとして返るかを設定します。デフォルト：false
ログイングループID.returning-attribute 結果として返される属性を設定します。デフォルト：指定なし(すべての属性)
属性ID
指定した属性のみ返す。（複数指定可能：[,]カンマで区切る）
指定なし
すべての属性を返す

以下はログイングループ全体に対して設定するパラメータです。
パラメータ | 説明
permit-no-password | 空パスワードによる認証処理を許可するかどうか設定します。(true/false) 設定しない場合はfalseとして扱います。 falseを指定した場合、パスワード無しを認証失敗とみなします。 trueを指定した場合、空パスワードでLDAPに問い合わせます。
log | ログをコンソールに出力します。(true/false) 設定しない場合はfalseとして扱います。 デバッグ用オプションです。

ログイングループID.base-dnを元に、ログイングループID.serch-filterの'?'の部分をユーザIDに置換して、 LDAP検索を行い、ユーザのフルDNを作成し、そのフルDNで認証を行います。
このdnの記述方法は、LDAPサーバによって異なります。

導入されたバージョン:
5.1
バージョン:
1.0

コンストラクタの概要
LDAPUserCertification()
メソッドの概要
int | certification(LoginInfo loginInfo, Account account, HttpServletRequest req, HttpServletResponse resp) LDAPに対してユーザを認証します。
void | init(Map params) ユーザログイン認証の初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LDAPUserCertification

public LDAPUserCertification()
メソッドの詳細

init

public void init(Map params)
ユーザログイン認証の初期化を行います。

ユーザログイン認証のインスタンス生成時に一度だけ呼び出されます。

初期化パラメータを元にログイングループID毎の設定情報モデルを作成します。

定義:
インタフェース UserCertification 内の init
オーバーライド:
クラス StandardUserCertification 内の init
パラメータ:
params - 初期化パラメータのマップ

certification

public int certification(LoginInfo loginInfo,
                         Account account,
                         HttpServletRequest req,
                         HttpServletResponse resp)
LDAPに対してユーザを認証します。

定義:
インタフェース UserCertification 内の certification
オーバーライド:
クラス StandardUserCertification 内の certification
パラメータ:
loginInfo - ログイン情報
account - ユーザ情報
req - サーブレットリクエスト
resp - サーブレットレスポンス
戻り値:
認証結果
認証成功 | SecurityConstraint.CR_OK
認証失敗 | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.certification.ldap.extension (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.security.certification.ldap.extension
クラス
LDAPContextInfoBuilder
LDAPContextInfoModel
LDAPUserCertification


jp.co.intra_mart.foundation.security.certification.ldap.extension (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.certification.ldap.extension

ユーザログインLDAP認証クラス(複数OU対応版)の設定方法。

参照:
説明

クラスの概要
LDAPContextInfoBuilder | ログイングループ毎の設定情報モデルを作成するビルドクラス。
LDAPContextInfoModel | ユーザログインLDAP認証で認証情報モデルクラス(複数OU対応版)。
LDAPUserCertification | ユーザログインLDAP認証クラス(複数OU対応版)。

パッケージ jp.co.intra_mart.foundation.security.certification.ldap.extension の説明

ユーザログインLDAP認証クラス(複数OU対応版)の設定方法。

はじめにアプリケーションランタイム/doc/imart/WEB-INF/libフォルダにlib/ldap_extension.jarファイルをコピーします。

次にLDAPUserCertificationクラスを以下の設定ファイルに記述します。
サーバーマネージャインストールディレクトリ/conf/access-security.xml
<access-security>/<security-config>/<user-security>のタグに記述します。

    <auto-certification>
      <certification-class>jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPUserCertification</certification-class>
      <init-param>
        <param-name>初期化パラメータ名</param-name>
        <param-value>初期化パラメータ値</param-value>
      </init-param>
    </auto-certification>
    <certification>
      <certification-class>jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPUserCertification</certification-class>
      <init-param>
        <param-name>初期化パラメータ名</param-name>
        <param-value>初期化パラメータ値</param-value>
      </init-param>
    </certification>
<auto-certification>タグには、ログイン画面表示前のリクエストから認証処理を行うユーザログイン認証インタフェース実装クラスを設定します。
また、このタグは省略可能です。省略した場合は、自動ログインができなくなります。（ログイン画面を出さずにログイン）

<certification>タグには、ログイン画面からのリクエストから認証処理を行うユーザログイン認証インタフェース実装クラスを設定します。

<init-param>タグは複数設定可能です。
このタグに設定された値は、クラス初期化時に、init関数の引数として渡されます。
初期化パラメータの詳細はLDAPUserCertificationをご覧ください。

最後にサーバを再起動します。


jp.co.intra_mart.foundation.security.certification.ldap.extension クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.certification.ldap.extension の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoBuilder
    • class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel
    • class jp.co.intra_mart.foundation.security.certification.StandardUserCertification (implements jp.co.intra_mart.foundation.security.certification.UserCertification)
      • class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPUserCertification


パッケージ jp.co.intra_mart.foundation.security.certification.ldap.extension の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.certification.ldap.extension の使用

jp.co.intra_mart.foundation.security.certification.ldap.extension はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ErrorPageProvider (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
インタフェース ErrorPageProvider

既知の実装クラスの一覧:
StandardErrorPageProvider
public interface ErrorPageProvider

エラーページプロバイダインタフェース。

ユーザ用の各種エラーページを取得するためのインタフェース
エラーページプロバイダを実装する場合は必ずこのインタフェースを実装します。
アクセスセキュリティAPIはこのインタフェースを通じて必要なエラーページを取得します。

このインターフェースを実装したクラスを以下の設定ファイルに記述します。
サーバーマネージャインストールディレクトリ/conf/access-security.xml

 <access-security>
   <security-config>
     <error-page-provider>
       <page-provider-class>エラーページプロバイダインタフェース実装クラス名（フルパッケージ名）</page-provider-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </error-page-provider>
   </security-config>
 </access-security>
<init-param>タグは複数設定可能です。
このタグに設定された値は、クラス初期化時に、init関数の引数として渡されます。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getCertificationErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 認証失敗エラーページURLを取得する。
String | getGroupErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ログイングループエラーページURLを取得する。
String | getLicenceErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ライセンスエラーページURLを取得する。
String | getLockedErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ユーザロックエラーページURLを取得する。
String | getNoPermissionErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 無許可アクセスエラーページURLを取得する。
String | getSessionErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) セッションエラーページURLを取得する。
String | getSessionTimeoutErrorPage(HttpServletRequest request, HttpServletResponse response) セッションタイムアウトエラーページURLを取得する。
String | getSystemErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 認証処理エラーページURLを取得する。
void | init(Map params) ページプロバイダの初期化を行います。

メソッドの詳細

init

public void init(Map params)
ページプロバイダの初期化を行います。

ページプロバイダのインスタンス生成時に一度だけ呼び出されます。

パラメータ:
params - 初期化パラメータのマップ

getCertificationErrorPage

public String getCertificationErrorPage(SessionInfo sessionInfo,
                                        HttpServletRequest request,
                                        HttpServletResponse response)
認証失敗エラーページURLを取得する。

認証に失敗した場合( SecurityConstraint.CR_NG)に表示するページを取得する。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証失敗エラーページURL

getLockedErrorPage

public String getLockedErrorPage(SessionInfo sessionInfo,
                                 HttpServletRequest request,
                                 HttpServletResponse response)
ユーザロックエラーページURLを取得する。

各ログインタイプ別のページプロバイダからユーザロックエラーページが取得できなかった場合に利用される。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ユーザロックエラーページURL

getLicenceErrorPage

public String getLicenceErrorPage(SessionInfo sessionInfo,
                                  HttpServletRequest request,
                                  HttpServletResponse response)
ライセンスエラーページURLを取得する。

認証するユーザにライセンスがないか、または有効期間内でない場合( SecurityConstraint.CR_NO_LICENSE )に表示するページを取得する。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ライセンスエラーページURL

getGroupErrorPage

public String getGroupErrorPage(SessionInfo sessionInfo,
                                HttpServletRequest request,
                                HttpServletResponse response)
ログイングループエラーページURLを取得する。

認証するログイングループが存在しない場合( SecurityConstraint.CR_NO_GROUP )に表示するページを取得する。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ログイングループエラーページURL

getSessionErrorPage

public String getSessionErrorPage(SessionInfo sessionInfo,
                                  HttpServletRequest request,
                                  HttpServletResponse response)
セッションエラーページURLを取得する。

セッション情報に不整合が出た場合( SecurityConstraint.CR_SESSION_UNMATCH )に表示するページを取得する。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
セッションエラーページURL

getSessionTimeoutErrorPage

public String getSessionTimeoutErrorPage(HttpServletRequest request,
                                         HttpServletResponse response)
セッションタイムアウトエラーページURLを取得する。

セッションがタイムアウトになった場合( SecurityConstraint.CR_SESSION_TIMEOUT )に表示するページを取得する。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
セッションタイムアウトエラーページURL

getNoPermissionErrorPage

public String getNoPermissionErrorPage(SessionInfo sessionInfo,
                                       HttpServletRequest request,
                                       HttpServletResponse response)
無許可アクセスエラーページURLを取得する。

無許可のURLにアクセスした場合( SecurityConstraint.CR_NO_PERMISSION )に表示するページを取得する。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
無許可アクセスエラーページURL

getSystemErrorPage

public String getSystemErrorPage(SessionInfo sessionInfo,
                                 HttpServletRequest request,
                                 HttpServletResponse response)
認証処理エラーページURLを取得する。

認証処理中にエラーが発生した場合( SecurityConstraint.CR_ERROR)に表示するページを取得する。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証処理エラーページURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LDAPUserCertification (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス LDAPUserCertification

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardUserCertification
        拡張 jp.co.intra_mart.foundation.security.certification.LDAPUserCertification
すべての実装インタフェース:
UserCertification
public class LDAPUserCertification
extends StandardUserCertification

ユーザログインLDAP認証クラス。

一般ユーザのLDAPログイン認証を行うためのクラス

初期化パラメータは以下のものを必要とします。
ログイングループごとに3つのパラメータが必要です。

パラメータ名 | 説明
ログイングループID.provider-url | プロバイダURLを設定します(Ex : ldap://localhost:389/)。 カンマ(,)区切りで複数指定可能(Ex : ldap://localhost:389/, ldap://localhost:27272/)。 複数指定した場合、左から順にLDAPサーバに通信を試みます。通信できない場合のみ次の接続先に通信を試みます。
ログイングループID.load-balancing | ロードバランサを有効にします。(true/false) 設定しない場合はfalseとして扱います。 falseを指定した場合、プロバイダURLを左から順に認証を試みます。 trueを指定した場合、プロバイダURLの開始位置をランダムに決定し、決定した位置を基準に右方向に順に認証を試みます。
ログイングループID.dn | 識別情報を設定します。（Ex : uid=?,ou=People, o=ldaps.intra-mart.jp）
ログイングループID.context-factory | コンテキストファクトリを設定します。（Ex : com.sun.jndi.ldap.LdapCtxFactory）
ログイングループID.connect-timeout-property-name | 接続タイムアウトを設定するプロパティ名を設定します。（Ex : com.sun.jndi.ldap.connect.timeout）
ログイングループID.connect-timeout | 接続タイムアウト時間を設定します。 プロパティに com.sun.jndi.ldap.connect.timeout を指定した場合、ミリ秒数を示す0より大きい整数で指定し、LDAP プロバイダがこの値の期間中に接続を確立できないと、接続の試行は中止されます。 0 以下の整数指定した場合または設定しない場合は、TCP などのネットワークプロトコルのタイムアウト値が使用されます。
ログイングループID.attempt-on-failed-authentication | LDAP認証失敗(ユーザIDまたはパスワードが不正)時に次のプロバイダURLに認証を試みます(true/false)。 設定しない場合はfalseとして扱います。 falseを指定した場合、次のプロバイダURLに認証を試みません。 trueを指定した場合、次のプロバイダURLに認証を試みます。
permit-no-password | パスワードなしを許可します。(true/false) 設定しない場合はfalseとして扱います。 falseを指定した場合、パスワード無しを認証失敗とみなします。 trueを指定した場合、空パスワードでLDAPに問い合わせます。
log | ログをコンソールに出力します。(true/false) 設定しない場合はfalseとして扱います。 デバッグ用オプションです。

ログイングループID.dn に設定する'?'の部分をユーザIDに置換して、認証を行います。
このdnの記述方法は、LDAPサーバによって異なります。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
LDAPUserCertification()
メソッドの概要
int | certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証する。
void | init(Map params) ユーザログイン認証の初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LDAPUserCertification

public LDAPUserCertification()
メソッドの詳細

certification

public int certification(LoginInfo loginInfo,
                         Account user,
                         HttpServletRequest request,
                         HttpServletResponse response)
ユーザを認証する。

定義:
インタフェース UserCertification 内の certification
オーバーライド:
クラス StandardUserCertification 内の certification
パラメータ:
loginInfo - ログイン情報
user - ユーザ情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証結果
認証成功 | SecurityConstraint.CR_OK
認証失敗 | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
導入されたバージョン:
5.0

init

public void init(Map params)
ユーザログイン認証の初期化を行います。

ユーザログイン認証のインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース UserCertification 内の init
オーバーライド:
クラス StandardUserCertification 内の init
パラメータ:
params - 初期化パラメータのマップ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LoginInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
インタフェース LoginInfo

すべてのスーパーインタフェース:
LocaleProvider
既知のサブインタフェースの一覧:
LoginRequestInfo
public interface LoginInfo
extends LocaleProvider

intra-martログイン情報操作インタフェース。

intra-martログイン情報を操作するためのインタフェース
intra-martログイン情報を操作する場合は、必ずこのインターフェースを利用して行う。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getClientType() クライアントタイプを取得する。
String | getEncoding() エンコーディングを取得する。
String | getInitialUrl() 初期アクセスURLを取得する。
Locale | getLocale() ロケールを取得する。
String | getLoginGroup() ログイングループIDを取得する。
String | getLoginType() ログインタイプを取得する。
String | getPassword() ログインパスワードを取得する。
String | getUrl() ダイレクトＵＲＬを取得する。
String | getUrlSignature() ダイレクトＵＲＬ署名を取得する。
String | getUser() ログインユーザIDを取得する。
boolean | isDoneCertification() 認証が終了しているかどうかを取得する。

メソッドの詳細

getClientType

public String getClientType()
クライアントタイプを取得する。

戻り値:
クライアントタイプ

getEncoding

public String getEncoding()
エンコーディングを取得する。

定義:
インタフェース LocaleProvider 内の getEncoding
戻り値:
エンコーディング

getLocale

public Locale getLocale()
ロケールを取得する。

定義:
インタフェース LocaleProvider 内の getLocale
戻り値:
ロケール

getLoginGroup

public String getLoginGroup()
ログイングループIDを取得する。

戻り値:
ログイングループID

getLoginType

public String getLoginType()
ログインタイプを取得する。

戻り値:
ログインタイプ
関連項目:
SecurityConstraint.LT_SUPER, SecurityConstraint.LT_GROUP, SecurityConstraint.LT_USER

getPassword

public String getPassword()
ログインパスワードを取得する。

戻り値:
パスワード

getUrl

public String getUrl()
ダイレクトＵＲＬを取得する。

戻り値:
ダイレクトＵＲＬ

getUrlSignature

public String getUrlSignature()
ダイレクトＵＲＬ署名を取得する。

戻り値:
ダイレクトＵＲＬ署名

getUser

public String getUser()
ログインユーザIDを取得する。

戻り値:
ログインユーザID

getInitialUrl

public String getInitialUrl()
初期アクセスURLを取得する。

戻り値:
初期アクセスURL

isDoneCertification

public boolean isDoneCertification()
認証が終了しているかどうかを取得する。

戻り値:
すでに認証が終了している：true
まだ認証が終了していない：false
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginRequestInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
インタフェース LoginRequestInfo

すべてのスーパーインタフェース:
LocaleProvider, LoginInfo
public interface LoginRequestInfo
extends LoginInfo

intra-martログイン情報操作インタフェース。

intra-martログイン情報を操作するためのインタフェース
intra-martログイン情報を操作する場合は、必ずこのインターフェースを利用して行う。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getClientType() クライアントタイプを取得する。
String | getEncoding() エンコーディングを取得する。
Locale | getLocale() ロケールを取得する。
String | getLoginGroup() ログイングループIDを取得する。
String | getLoginType() ログインタイプを取得する。
String | getPassword() ログインパスワードを取得する。
String | getUrl() ダイレクトＵＲＬを取得する。
String | getUrlSignature() ダイレクトＵＲＬ署名を取得する。
String | getUser() ログインユーザIDを取得する。
void | setClientType(String clientType) クライアントタイプを設定する。
void | setDoneCertification(boolean cert) 認証が終了しているかどうかを設定する。
void | setEncoding(String encoding) ログインエンコーディングを設定する。
void | setInitialUrl(String url) 初期アクセスURLを設定する。
void | setLocale(Locale locale) ログインロケールを設定する。
void | setLoginGroup(String groupId) ログイングループIDを設定する。
void | setPassword(String password) ログインパスワードを設定する。
void | setUrl(String url) ダイレクトＵＲＬを設定する。
void | setUrlSignature(String signature) ダイレクトＵＲＬ署名を設定する。
void | setUser(String user) ログインユーザIDを設定する。
インタフェース jp.co.intra_mart.foundation.security.certification.LoginInfo から継承したメソッド
getInitialUrl, isDoneCertification

メソッドの詳細

getClientType

public String getClientType()
クライアントタイプを取得する。

定義:
インタフェース LoginInfo 内の getClientType
戻り値:
クライアントタイプ

getEncoding

public String getEncoding()
エンコーディングを取得する。

定義:
インタフェース LoginInfo 内の getEncoding
戻り値:
エンコーディング

getLocale

public Locale getLocale()
ロケールを取得する。

定義:
インタフェース LoginInfo 内の getLocale
戻り値:
ロケール

getLoginGroup

public String getLoginGroup()
ログイングループIDを取得する。

定義:
インタフェース LoginInfo 内の getLoginGroup
戻り値:
ログイングループID

getLoginType

public String getLoginType()
ログインタイプを取得する。

定義:
インタフェース LoginInfo 内の getLoginType
戻り値:
ログインタイプ
関連項目:
SecurityConstraint.LT_SUPER, SecurityConstraint.LT_GROUP, SecurityConstraint.LT_USER

getPassword

public String getPassword()
ログインパスワードを取得する。

定義:
インタフェース LoginInfo 内の getPassword
戻り値:
パスワード

getUrl

public String getUrl()
ダイレクトＵＲＬを取得する。

定義:
インタフェース LoginInfo 内の getUrl
戻り値:
ダイレクトＵＲＬ

getUrlSignature

public String getUrlSignature()
ダイレクトＵＲＬ署名を取得する。

定義:
インタフェース LoginInfo 内の getUrlSignature
戻り値:
ダイレクトＵＲＬ署名

getUser

public String getUser()
ログインユーザIDを取得する。

定義:
インタフェース LoginInfo 内の getUser
戻り値:
ログインユーザID

setClientType

public void setClientType(String clientType)
クライアントタイプを設定する。

パラメータ:
clientType - クライアントタイプ

setEncoding

public void setEncoding(String encoding)
ログインエンコーディングを設定する。

パラメータ:
encoding - ログインエンコーディング

setLocale

public void setLocale(Locale locale)
ログインロケールを設定する。

導入されたバージョン:
5.0

setLoginGroup

public void setLoginGroup(String groupId)
ログイングループIDを設定する。

パラメータ:
groupId - ログイングループID

setPassword

public void setPassword(String password)
ログインパスワードを設定する。

パラメータ:
password - パスワード

setUrl

public void setUrl(String url)
ダイレクトＵＲＬを設定する。

パラメータ:
url - ダイレクトＵＲＬ

setUrlSignature

public void setUrlSignature(String signature)
ダイレクトＵＲＬ署名を設定する。

パラメータ:
signature - ダイレクトＵＲＬ署名

setUser

public void setUser(String user)
ログインユーザIDを設定する。

パラメータ:
user - ログインユーザID

setInitialUrl

public void setInitialUrl(String url)
初期アクセスURLを設定する。

戻り値:
初期アクセスURL

setDoneCertification

public void setDoneCertification(boolean cert)
認証が終了しているかどうかを設定する。

パラメータ:
cert - 認証が終了している場合はtrueを設定
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.certification (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.security.certification
インタフェース
ErrorPageProvider
LoginInfo
LoginRequestInfo
RequestAnalyzer
SuperCertification
SuperCertificationListener
UserCertification
UserCertificationListener
UserPageProvider
クラス
LDAPUserCertification
PortalStandardUserPageProvider
SSORequestAnalyzer
StandardErrorPageProvider
StandardGroupSuperUserPageProvider
StandardRequestAnalyzer
StandardSuperUserCertification
StandardSuperUserPageProvider
StandardUserCertification
StandardUserPageProvider
SuperUserNoCertification


jp.co.intra_mart.foundation.security.certification (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.certification

認証に関連するクラスを提供します。

参照:
説明

インタフェースの概要
ErrorPageProvider | エラーページプロバイダインタフェース。
LoginInfo | intra-martログイン情報操作インタフェース。
LoginRequestInfo | intra-martログイン情報操作インタフェース。
RequestAnalyzer | リクエストアナライザインタフェース。
SuperCertification | 管理者ログイン認証インタフェース。
SuperCertificationListener | 管理者ログイン認証リスナーインタフェース。
UserCertification | ユーザログイン認証インタフェース。
UserCertificationListener | ユーザログイン認証リスナーインタフェース。
UserPageProvider | ユーザページプロバイダインタフェース。

クラスの概要
LDAPUserCertification | ユーザログインLDAP認証クラス。
PortalStandardUserPageProvider | ポータルユーザページプロバイダクラス。
SSORequestAnalyzer | SSOのログインリクエスト解析クラス。
StandardErrorPageProvider | 標準のエラーページプロバイダクラス。
StandardGroupSuperUserPageProvider | 標準のログイングループ管理者用ページプロバイダクラス。
StandardRequestAnalyzer | 標準のログインリクエスト解析クラス。
StandardSuperUserCertification | 管理者ログイン認証の実装クラス。
StandardSuperUserPageProvider | 標準のシステム管理者用のユーザページプロバイダクラス。
StandardUserCertification | ユーザログイン認証クラス。
StandardUserPageProvider | 標準のユーザページプロバイダクラス。
SuperUserNoCertification | システム管理者ログイン時に強制認証を行う実装クラスです。

パッケージ jp.co.intra_mart.foundation.security.certification の説明

認証に関連するクラスを提供します。


jp.co.intra_mart.foundation.security.certification クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.certification の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider (implements jp.co.intra_mart.foundation.security.certification.ErrorPageProvider)
    • class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider (implements jp.co.intra_mart.foundation.security.certification.UserPageProvider)
    • class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer (implements jp.co.intra_mart.foundation.security.certification.RequestAnalyzer)
      • class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer
    • class jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification (implements jp.co.intra_mart.foundation.security.certification.SuperCertification)
    • class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider (implements jp.co.intra_mart.foundation.security.certification.UserPageProvider)
    • class jp.co.intra_mart.foundation.security.certification.StandardUserCertification (implements jp.co.intra_mart.foundation.security.certification.UserCertification)
      • class jp.co.intra_mart.foundation.security.certification.LDAPUserCertification
    • class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider (implements jp.co.intra_mart.foundation.security.certification.UserPageProvider)
      • class jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider
    • class jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification (implements jp.co.intra_mart.foundation.security.certification.SuperCertification)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider
  • interface jp.co.intra_mart.foundation.security.LocaleProvider
    • interface jp.co.intra_mart.foundation.security.certification.LoginInfo
      • interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo
  • interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer
  • interface jp.co.intra_mart.foundation.security.certification.SuperCertification
  • interface jp.co.intra_mart.foundation.security.certification.SuperCertificationListener
  • interface jp.co.intra_mart.foundation.security.certification.UserCertification
  • interface jp.co.intra_mart.foundation.security.certification.UserCertificationListener
  • interface jp.co.intra_mart.foundation.security.certification.UserPageProvider


パッケージ jp.co.intra_mart.foundation.security.certification の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.certification の使用

jp.co.intra_mart.foundation.security.certification を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession |
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.password |

jp.co.intra_mart.foundation.security により使用される jp.co.intra_mart.foundation.security.certification のクラス
LoginInfo
intra-martログイン情報操作インタフェース。
LoginRequestInfo
intra-martログイン情報操作インタフェース。

jp.co.intra_mart.foundation.security.activesession により使用される jp.co.intra_mart.foundation.security.certification のクラス
LoginInfo
intra-martログイン情報操作インタフェース。
SuperCertificationListener
管理者ログイン認証リスナーインタフェース。
UserCertificationListener
ユーザログイン認証リスナーインタフェース。

jp.co.intra_mart.foundation.security.certification により使用される jp.co.intra_mart.foundation.security.certification のクラス
ErrorPageProvider
エラーページプロバイダインタフェース。
LoginInfo
intra-martログイン情報操作インタフェース。
LoginRequestInfo
intra-martログイン情報操作インタフェース。
RequestAnalyzer
リクエストアナライザインタフェース。
StandardRequestAnalyzer
標準のログインリクエスト解析クラス。
StandardUserCertification
ユーザログイン認証クラス。
StandardUserPageProvider
標準のユーザページプロバイダクラス。
SuperCertification
管理者ログイン認証インタフェース。
UserCertification
ユーザログイン認証インタフェース。
UserPageProvider
ユーザページプロバイダインタフェース。

jp.co.intra_mart.foundation.security.password により使用される jp.co.intra_mart.foundation.security.certification のクラス
PortalStandardUserPageProvider
ポータルユーザページプロバイダクラス。
StandardUserPageProvider
標準のユーザページプロバイダクラス。
UserPageProvider
ユーザページプロバイダインタフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PortalStandardUserPageProvider (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス PortalStandardUserPageProvider

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider
        拡張 jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider
すべての実装インタフェース:
UserPageProvider
直系の既知のサブクラス:
PasswordHistoryUserPageProvider
public class PortalStandardUserPageProvider
extends StandardUserPageProvider

ポータルユーザページプロバイダクラス。

標準のポータルユーザページプロバイダクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
PortalStandardUserPageProvider()
コンストラクタ。
メソッドの概要
protected String | getExtendedMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 拡張メインページURLを取得します。
String | getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得します。
void | init(Map params) ページプロバイダの初期化を行います。
クラス jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider から継承したメソッド
getMainPage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PortalStandardUserPageProvider

public PortalStandardUserPageProvider()
コンストラクタ。

メソッドの詳細

init

public void init(Map params)
ページプロバイダの初期化を行います。

ページプロバイダのインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース UserPageProvider 内の init
オーバーライド:
クラス StandardUserPageProvider 内の init
パラメータ:
params - 初期化パラメータのマップ

getInitalPage

public String getInitalPage(SessionInfo sessionInfo,
                            HttpServletRequest request,
                            HttpServletResponse response)
初期ページURLを取得します。

初期アクセス時に表示するURLを取得します。

定義:
インタフェース UserPageProvider 内の getInitalPage
オーバーライド:
クラス StandardUserPageProvider 内の getInitalPage
パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL

getExtendedMainPage

protected String getExtendedMainPage(SessionInfo sessionInfo,
                                     HttpServletRequest request,
                                     HttpServletResponse response)
拡張メインページURLを取得します。

ログイン後の拡張メイン画面を表示するURLを取得する。

オーバーライド:
クラス StandardUserPageProvider 内の getExtendedMainPage
パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RequestAnalyzer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
インタフェース RequestAnalyzer

既知の実装クラスの一覧:
StandardRequestAnalyzer
public interface RequestAnalyzer

リクエストアナライザインタフェース。

サーブレットリクエストからログインに必要な情報を取得して返却するするインタフェース。
アクセスセキュリティAPIはこのインタフェースを通じて必要なログイン情報を取得します。

このインターフェースを実装したクラスを以下の設定ファイルに記述します。
サーバーマネージャインストールディレクトリ/conf/access-security.xml
<access-security>/<security-config>以下の<super-user-security>,<group-super-user-security>,<user-security>の各タグに記述します。

<super-user-security>は、システム管理者に対する設定です。
<group-super-user-security>は、ログイングループ管理者に対する設定です。
<user-security>は、一般ユーザに対する設定です。

     <initial-request-analyzer>
       <request-analyzer-class>クエストアナライザインタフェース実装クラス名（フルパッケージ名）</request-analyzer-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </initial-request-analyzer>
     <login-request-analyzer>
       <request-analyzer-class>クエストアナライザインタフェース実装クラス名（フルパッケージ名）</request-analyzer-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </login-request-analyzer>
<initial-request-analyzer>タグには、ログイン画面表示前のリクエストを解析するクエストアナライザインタフェース実装クラスを設定します。

<login-request-analyzer>タグには、ログイン画面からのリクエストを解析するクエストアナライザインタフェース実装クラスを設定します。

<init-param>タグは複数設定可能です。
このタグに設定された値は、クラス初期化時に、init関数の引数として渡されます。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getLoginGroupParameterName() ログイングループＩＤリクエストパラメータ名を取得する。
String | getUrlParameterName() ダイレクトＵＲＬリクエストパラメータ名を取得する。
String | getUrlSignParameterName() ダイレクトＵＲＬ署名リクエストパラメータ名を取得する。
String | getUserParameterName() ユーザＩＤリクエストパラメータ名を取得する。
void | init(Map params) ログインリクエストアナライザの初期化。
LoginInfo | parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。

メソッドの詳細

init

public void init(Map params)
ログインリクエストアナライザの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

parseRequest

public LoginInfo parseRequest(LoginRequestInfo loginInfo,
                              HttpServletRequest request)
リクエストパラメータの解析。

リクエストを解析してログイン情報を返却します。

パラメータ:
loginInfo - ベースとなるログインリクエスト情報
サーブレットリクエスト(request)から取得した情報をこのパラメータ(loginRequestInfo)のプロパティに設定して返却する。
request - HTTPサーブレットリクエスト
戻り値:
ログイン情報

getLoginGroupParameterName

public String getLoginGroupParameterName()
ログイングループＩＤリクエストパラメータ名を取得する。

戻り値:
ログイングループＩＤリクエストパラメータ名

getUserParameterName

public String getUserParameterName()
ユーザＩＤリクエストパラメータ名を取得する。

戻り値:
ユーザＩＤリクエストパラメータ名

getUrlParameterName

public String getUrlParameterName()
ダイレクトＵＲＬリクエストパラメータ名を取得する。

戻り値:
ダイレクトＵＲＬリクエストパラメータ名

getUrlSignParameterName

public String getUrlSignParameterName()
ダイレクトＵＲＬ署名リクエストパラメータ名を取得する。

戻り値:
ダイレクトＵＲＬ署名リクエストパラメータ名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SSORequestAnalyzer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス SSORequestAnalyzer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer
        拡張 jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer
すべての実装インタフェース:
RequestAnalyzer
public class SSORequestAnalyzer
extends StandardRequestAnalyzer

SSOのログインリクエスト解析クラス。

im-SecureSignOnと連動するSSOログインリクエスト解析クラスです。

各リクエストパラメータから情報を取得してLoginInfoに設定します。
各リクエストパラメータから情報が取得されなかったものはLoginInfoに設定しません。
解析では、im-SecureSignOnののクッキー情報からログイングループ、ユーザ情報を取得します。

ログアウト時に特定のURLへのリクエストを行う場合は初期化パラメータで設定します。

パラメータ名 | 説明
sso-logout-url | ログアウト時にリクエストを行うURLを設定します。(Ex : http://server:8080/sso/logout.do)

設定方法：
このクラスを以下の設定ファイルに記述します。
サーバーマネージャインストールディレクトリ/conf/access-security.xml

   <user-security>
     <initial-request-analyzer>
       <request-analyzer-class>jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer</request-analyzer-class>
       <init-param>
         <param-name>sso-logout-url</param-name>
         <param-value>http://server:8080/sso/logout.do</param-value>
       </init-param>
     </initial-request-analyzer>
     .....
     <auto-certification>
       <certification-class>jp.co.intra_mart.foundation.security.certification.StandardUserCertification</certification-class>
       <init-param>
         <param-name>mobile-client-type</param-name>
         <param-value>mobile</param-value>
       </init-param>
     </auto-certification>
     <certification>
       <certification-class>jp.co.intra_mart.foundation.security.certification.StandardUserCertification</certification-class>
       <init-param>
       <param-name>mobile-client-type</param-name>
       <param-value>mobile</param-value>
     </init-param>
   </user-security>

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String | DEFAULT_AUTH_COOKIE_NAME
static String | DEFAULT_LOGIN_KEY
static String | KEY_AUTH_COOKIE_NAME
static String | KEY_LOGIN_KEY
static String | SSO_LOGOUT_URL
コンストラクタの概要
SSORequestAnalyzer()
メソッドの概要
void | init(Map params) ログインリクエストアナライザの初期化。
LoginInfo | parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。
クラス jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer から継承したメソッド
getLoginGroupParameterName, getShortCutName, getUrlParameterName, getUrlSignParameterName, getUserParameterName
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KEY_LOGIN_KEY

public static final String KEY_LOGIN_KEY
関連項目:
定数フィールド値

KEY_AUTH_COOKIE_NAME

public static final String KEY_AUTH_COOKIE_NAME
関連項目:
定数フィールド値

DEFAULT_LOGIN_KEY

public static final String DEFAULT_LOGIN_KEY
関連項目:
定数フィールド値

DEFAULT_AUTH_COOKIE_NAME

public static final String DEFAULT_AUTH_COOKIE_NAME
関連項目:
定数フィールド値

SSO_LOGOUT_URL

public static final String SSO_LOGOUT_URL
関連項目:
定数フィールド値
コンストラクタの詳細

SSORequestAnalyzer

public SSORequestAnalyzer()
メソッドの詳細

init

public void init(Map params)
ログインリクエストアナライザの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース RequestAnalyzer 内の init
オーバーライド:
クラス StandardRequestAnalyzer 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

parseRequest

public LoginInfo parseRequest(LoginRequestInfo loginInfo,
                              HttpServletRequest request)
リクエストパラメータの解析。

リクエストを解析してログイン情報を返却します。

定義:
インタフェース RequestAnalyzer 内の parseRequest
オーバーライド:
クラス StandardRequestAnalyzer 内の parseRequest
パラメータ:
loginInfo - ベースとなるログインリクエスト情報
サーブレットリクエスト(request)から取得した情報をこのパラメータ(loginRequestInfo)のプロパティに設定して返却する。
request - HTTPサーブレットリクエスト
戻り値:
ログイン情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardErrorPageProvider (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス StandardErrorPageProvider

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider
すべての実装インタフェース:
ErrorPageProvider
public class StandardErrorPageProvider
extends Object
implements ErrorPageProvider

標準のエラーページプロバイダクラス。

初期化パラメータは以下のものを必要とします。

パラメータ名 | 説明
certification-error-page | デフォルトの認証失敗画面URLを設定します。
locked-error-page | ユーザがロック状態の場合のデフォルト画面URLを設定します。
license-error-page | ログインライセンスがないの場合のデフォルト画面URLを設定します。
group-error-page | ログイングループが存在しない場合のデフォルト画面URLを設定します。
permission-error-page | 無許可アクセスページにアクセスした場合の画面のURLを設定します。
session-error-page | セッション情報不整合の場合のデフォルト画面URLを設定します。
session-timeout-page | セッションタイムアウトの場合のデフォルト画面URLを設定します。
system-error-page | デフォルトの認証処理失敗時のデフォルト画面URLを設定します。
certification-error-page.クライアントタイプ | クライアントタイプ別に認証失敗画面のURLを設定します。
locked-error-page.クライアントタイプ | クライアントタイプ別にユーザがロック状態の場合の画面URLを設定します。
license-error-page.クライアントタイプ | クライアントタイプ別にログインライセンスがない場合の画面URLを設定します。
group-error-page.クライアントタイプ | クライアントタイプ別にログイングループが存在しない場合の画面URLを設定します。
permission-error-page.クライアントタイプ | クライアントタイプ別に無許可アクセスページにアクセスした場合の画面のURLを設定します。
session-error-page.クライアントタイプ | クライアントタイプ別セッション情報不整合の場合の画面URLを設定します。
session-timeout-page.クライアントタイプ | クライアントタイプ別セッションタイムアウトの場合の画面URLを設定します。
system-error-page.クライアントタイプ | クライアントタイプ別認証処理失敗時の画面URLを設定します。

ページ決定のルール
certification-error-page.クライアントタイプ を例に取った場合
クライアントタイプ（large）の場合は

① certification-error-page.largeのＵＲＬ
② certification-error-pageのＵＲＬ

の順序でＵＲＬを決定します。
なお、設定するURLはコンテキストパスからの相対パスで記述します。
取得されるURLの先頭には、'/'をつけたものを返却します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
StandardErrorPageProvider()
デフォルトコンストラクタ
メソッドの概要
String | getCertificationErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 認証失敗エラーページURLを取得します。
String | getGroupErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ログイングループエラーページURLを取得します。
String | getLicenceErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ライセンスエラーページURLを取得します。
String | getLockedErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ユーザロックエラーページURLを取得します。
String | getNoPermissionErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 無許可アクセスエラーページURLを取得する。
String | getSessionErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) セッションエラーページURLを取得する。
String | getSessionTimeoutErrorPage(HttpServletRequest request, HttpServletResponse response) セッションタイムアウトエラーページURLを取得する。
String | getSystemErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 認証処理エラーページURLを取得する。
void | init(Map params) ページプロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardErrorPageProvider

public StandardErrorPageProvider()
デフォルトコンストラクタ

メソッドの詳細

init

public void init(Map params)
ページプロバイダの初期化を行います。

ページプロバイダのインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース ErrorPageProvider 内の init
パラメータ:
params - 初期化パラメータのマップ

getCertificationErrorPage

public String getCertificationErrorPage(SessionInfo sessionInfo,
                                        HttpServletRequest request,
                                        HttpServletResponse response)
認証失敗エラーページURLを取得します。

認証に失敗した場合( SecurityConstraint.CR_NG)に表示するページを取得します。

定義:
インタフェース ErrorPageProvider 内の getCertificationErrorPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証失敗エラーページURL

getGroupErrorPage

public String getGroupErrorPage(SessionInfo sessionInfo,
                                HttpServletRequest request,
                                HttpServletResponse response)
ログイングループエラーページURLを取得します。

認証するログイングループが存在しない場合( SecurityConstraint.CR_NO_GROUP )に表示するページを取得します。

定義:
インタフェース ErrorPageProvider 内の getGroupErrorPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ログイングループエラーページURL

getLicenceErrorPage

public String getLicenceErrorPage(SessionInfo sessionInfo,
                                  HttpServletRequest request,
                                  HttpServletResponse response)
ライセンスエラーページURLを取得します。

認証するユーザにライセンスがないか、または有効期間内でない場合( SecurityConstraint.CR_NO_LICENSE )に表示するページを取得します。

定義:
インタフェース ErrorPageProvider 内の getLicenceErrorPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ライセンスエラーページURL

getLockedErrorPage

public String getLockedErrorPage(SessionInfo sessionInfo,
                                 HttpServletRequest request,
                                 HttpServletResponse response)
ユーザロックエラーページURLを取得します。

各ログインタイプ別のページプロバイダからユーザロックエラーページが取得できなかった場合に利用される。

定義:
インタフェース ErrorPageProvider 内の getLockedErrorPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ユーザロックエラーページURL

getNoPermissionErrorPage

public String getNoPermissionErrorPage(SessionInfo sessionInfo,
                                       HttpServletRequest request,
                                       HttpServletResponse response)
無許可アクセスエラーページURLを取得する。

無許可のURLにアクセスした場合( SecurityConstraint.CR_NO_PERMISSION )に表示するページを取得する。

定義:
インタフェース ErrorPageProvider 内の getNoPermissionErrorPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
無許可アクセスエラーページURL

getSessionErrorPage

public String getSessionErrorPage(SessionInfo sessionInfo,
                                  HttpServletRequest request,
                                  HttpServletResponse response)
セッションエラーページURLを取得する。

セッション情報に不整合が出た場合( SecurityConstraint.CR_SESSION_UNMATCH )に表示するページを取得する。

定義:
インタフェース ErrorPageProvider 内の getSessionErrorPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
セッションエラーページURL

getSessionTimeoutErrorPage

public String getSessionTimeoutErrorPage(HttpServletRequest request,
                                         HttpServletResponse response)
セッションタイムアウトエラーページURLを取得する。

セッションがタイムアウトになった場合( SecurityConstraint.CR_SESSION_TIMEOUT )に表示するページを取得する。

定義:
インタフェース ErrorPageProvider 内の getSessionTimeoutErrorPage
パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
セッションタイムアウトエラーページURL

getSystemErrorPage

public String getSystemErrorPage(SessionInfo sessionInfo,
                                 HttpServletRequest request,
                                 HttpServletResponse response)
認証処理エラーページURLを取得する。

認証処理中にエラーが発生した場合( SecurityConstraint.CR_ERROR)に表示するページを取得する。

定義:
インタフェース ErrorPageProvider 内の getSystemErrorPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証処理エラーページURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardGroupSuperUserPageProvider (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス StandardGroupSuperUserPageProvider

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider
すべての実装インタフェース:
UserPageProvider
public class StandardGroupSuperUserPageProvider
extends Object
implements UserPageProvider

標準のログイングループ管理者用ページプロバイダクラス。

初期化パラメータは以下のものを必要とします。

パラメータ名 | 説明
initial-page | 初期画面のURLを設定します。
main-page | メイン画面のURLを設定します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
StandardGroupSuperUserPageProvider()
デフォルトコンストラクタ
メソッドの概要
String | getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得する。
String | getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得する。
void | init(Map params) ページプロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardGroupSuperUserPageProvider

public StandardGroupSuperUserPageProvider()
デフォルトコンストラクタ

メソッドの詳細

init

public void init(Map params)
ページプロバイダの初期化を行います。

ページプロバイダのインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース UserPageProvider 内の init
パラメータ:
params - 初期化パラメータのマップ

getInitalPage

public String getInitalPage(SessionInfo sessionInfo,
                            HttpServletRequest request,
                            HttpServletResponse response)
初期ページURLを取得する。

初期アクセス時に表示するURLを取得する。

定義:
インタフェース UserPageProvider 内の getInitalPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL

getMainPage

public String getMainPage(SessionInfo sessionInfo,
                          HttpServletRequest request,
                          HttpServletResponse response)
メインページURLを取得する。

ログイン後のメイン画面を表示するURLを取得する。

定義:
インタフェース UserPageProvider 内の getMainPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardRequestAnalyzer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス StandardRequestAnalyzer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer
すべての実装インタフェース:
RequestAnalyzer
直系の既知のサブクラス:
SSORequestAnalyzer
public class StandardRequestAnalyzer
extends Object
implements RequestAnalyzer

標準のログインリクエスト解析クラス。

各リクエストパラメータから情報を取得してLoginInfoに設定します。
各リクエストパラメータから情報が取得されなかったものはLoginInfoに設定しません。
解析では、デフォルトのリクエストパラメータを使用して各情報を取得します。

初期化パラメータは以下のものを必要とします。
初期化パラメータは、すべて省略可能です。省略した場合は、各デフォルトのリクエストパラメータ名から情報を取得します。

パラメータ名 | 説明 | デフォルト値
login-type | ログインタイプが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_LOGIN_TYPE
client-type | クライアントタイプが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_CLIENT_TYPE
locale | ロケールが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_LOCALE
encoding | エンコーディングが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_ENCODING
login-group | ログイングループが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_LOGIN_GROUP
user | ユーザIDが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_USER
passward | パスワードが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_PASSWORD
url | ダイレクトＵＲＬが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_URL
url-sign | ダイレクトＵＲＬ署名が設定されるパラメータ名を設定します。 | SecurityConstraint.RP_URL_SIGN
shortcut | ショートカットＩＤが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_SHORTCUT

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
StandardRequestAnalyzer()
デフォルトコンストラクタ。
メソッドの概要
String | getLoginGroupParameterName() ログイングループＩＤリクエストパラメータ名を取得する。
String | getShortCutName() ショートカット用ＵＲＬパラメータ名を取得する。
String | getUrlParameterName() ダイレクトＵＲＬリクエストパラメータ名を取得する。
String | getUrlSignParameterName() ダイレクトＵＲＬ署名リクエストパラメータ名を取得する。
String | getUserParameterName() ユーザＩＤリクエストパラメータ名を取得する。
void | init(Map params) ログインリクエストアナライザの初期化。
LoginInfo | parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardRequestAnalyzer

public StandardRequestAnalyzer()
デフォルトコンストラクタ。

メソッドの詳細

getLoginGroupParameterName

public String getLoginGroupParameterName()
ログイングループＩＤリクエストパラメータ名を取得する。

定義:
インタフェース RequestAnalyzer 内の getLoginGroupParameterName
戻り値:
ログイングループＩＤリクエストパラメータ名

getUrlParameterName

public String getUrlParameterName()
ダイレクトＵＲＬリクエストパラメータ名を取得する。

定義:
インタフェース RequestAnalyzer 内の getUrlParameterName
戻り値:
ダイレクトＵＲＬリクエストパラメータ名

getUrlSignParameterName

public String getUrlSignParameterName()
ダイレクトＵＲＬ署名リクエストパラメータ名を取得する。

定義:
インタフェース RequestAnalyzer 内の getUrlSignParameterName
戻り値:
ダイレクトＵＲＬ署名リクエストパラメータ名

getUserParameterName

public String getUserParameterName()
ユーザＩＤリクエストパラメータ名を取得する。

定義:
インタフェース RequestAnalyzer 内の getUserParameterName
戻り値:
ユーザＩＤリクエストパラメータ名

getShortCutName

public String getShortCutName()
ショートカット用ＵＲＬパラメータ名を取得する。

戻り値:
ショートカット用ＵＲＬパラメータ名

init

public void init(Map params)
ログインリクエストアナライザの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース RequestAnalyzer 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

parseRequest

public LoginInfo parseRequest(LoginRequestInfo loginInfo,
                              HttpServletRequest request)
リクエストパラメータの解析。

リクエストを解析してログイン情報を返却します。

定義:
インタフェース RequestAnalyzer 内の parseRequest
パラメータ:
loginInfo - ベースとなるログインリクエスト情報
サーブレットリクエスト(request)から取得した情報をこのパラメータ(loginRequestInfo)のプロパティに設定して返却する。
request - HTTPサーブレットリクエスト
戻り値:
ログイン情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardSuperUserCertification (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス StandardSuperUserCertification

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification
すべての実装インタフェース:
SuperCertification
public class StandardSuperUserCertification
extends Object
implements SuperCertification

管理者ログイン認証の実装クラス。

管理者ログイン認証を行うためのクラス

初期化パラメータは以下のものを必要とします。

パラメータ名 | 説明
address-filter | クライアントのIPアドレスでフィルタリングします。 IPアドレスの正規表現を設定設定します。 必要ない場合は省略可能です。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
StandardSuperUserCertification()
デフォルトコンストラクタ
メソッドの概要
int | certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証します。
void | init(Map params) 管理者ログイン認証の初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardSuperUserCertification

public StandardSuperUserCertification()
デフォルトコンストラクタ

メソッドの詳細

init

public void init(Map params)
管理者ログイン認証の初期化を行います。

管理者ログイン認証のインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース SuperCertification 内の init
パラメータ:
params - 初期化パラメータのマップ

certification

public int certification(LoginInfo loginInfo,
                         SuperUser user,
                         HttpServletRequest request,
                         HttpServletResponse response)
管理者を認証します。

定義:
インタフェース SuperCertification 内の certification
パラメータ:
loginInfo - ログイン情報
user - 管理者情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証結果
認証成功 | SecurityConstraint.CR_OK
ユーザ不一致 | SecurityConstraint.CR_NO_USER
認証失敗(パスワード不一致) | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardSuperUserPageProvider (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス StandardSuperUserPageProvider

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider
すべての実装インタフェース:
UserPageProvider
public class StandardSuperUserPageProvider
extends Object
implements UserPageProvider

標準のシステム管理者用のユーザページプロバイダクラス。

初期化パラメータは以下のものを必要とします。

パラメータ名 | 説明
initial-page | 初期画面のURLを設定します。
main-page | メイン画面のURLを設定します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
StandardSuperUserPageProvider()
デフォルトコンストラクタ
メソッドの概要
String | getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得する。
String | getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得する。
void | init(Map params) ページプロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardSuperUserPageProvider

public StandardSuperUserPageProvider()
デフォルトコンストラクタ

メソッドの詳細

init

public void init(Map params)
ページプロバイダの初期化を行います。

ページプロバイダのインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース UserPageProvider 内の init
パラメータ:
params - 初期化パラメータのマップ

getInitalPage

public String getInitalPage(SessionInfo sessionInfo,
                            HttpServletRequest request,
                            HttpServletResponse response)
初期ページURLを取得する。

初期アクセス時に表示するURLを取得する。

定義:
インタフェース UserPageProvider 内の getInitalPage
パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL

getMainPage

public String getMainPage(SessionInfo sessionInfo,
                          HttpServletRequest request,
                          HttpServletResponse response)
メインページURLを取得する。

ログイン後のメイン画面を表示するURLを取得する。

定義:
インタフェース UserPageProvider 内の getMainPage
パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardUserCertification (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス StandardUserCertification

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardUserCertification
すべての実装インタフェース:
UserCertification
直系の既知のサブクラス:
LDAPUserCertification, LDAPUserCertification
public class StandardUserCertification
extends Object
implements UserCertification

ユーザログイン認証クラス。

標準のユーザログイン認証を行うためのクラス

初期化パラメータは以下のものを必要とします。

パラメータ名 | 説明
mobile-client-type | モバイルパスワードで認証を行うクライアントタイプを設定します。 (複数設定する場合は、カンマ区切りで設定します。) 例）small,medium

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
StandardUserCertification()
デフォルトコンストラクタ。
メソッドの概要
int | certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証します。
void | init(Map params) ユーザログイン認証の初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardUserCertification

public StandardUserCertification()
デフォルトコンストラクタ。

メソッドの詳細

init

public void init(Map params)
ユーザログイン認証の初期化を行います。

ユーザログイン認証のインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース UserCertification 内の init
パラメータ:
params - 初期化パラメータのマップ

certification

public int certification(LoginInfo loginInfo,
                         Account user,
                         HttpServletRequest request,
                         HttpServletResponse response)
ユーザを認証します。

定義:
インタフェース UserCertification 内の certification
パラメータ:
loginInfo - ログイン情報
user - ユーザ情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証結果
認証成功 | SecurityConstraint.CR_OK
認証失敗 | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardUserPageProvider (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス StandardUserPageProvider

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider
すべての実装インタフェース:
UserPageProvider
直系の既知のサブクラス:
PortalStandardUserPageProvider
public class StandardUserPageProvider
extends Object
implements UserPageProvider

標準のユーザページプロバイダクラス。
初期化パラメータは以下のものを必要とします。

パラメータ名 | 説明
initial-page | デフォルトの初期画面のURLを設定します。
initial-page.クライアントタイプ | クライアント別にデフォルトの初期画面のURLを設定します。
initial-page.クライアントタイプ.ログイングループID | ログイングループ別にデフォルトの初期画面のURLを設定します。
main-page | デフォルトのメイン画面のURLを設定します。
main-page.クライアントタイプ | クライアント別にデフォルトのメイン画面のURLを設定します。
main-page.クライアントタイプ.ログイングループID | ログイングループ別にデフォルトのメイン画面のURLを設定します。

ページ決定のルール
main-page.クライアントタイプ.[ログイングループID]を例に取った場合
ユーザがログイングループID（group_01）、クライアントタイプ（large）の場合は

① ダイレクトURLのURL
② ユーザに設定されているメインパターンIDのURL
③ main-page.large.group_01のURL
④ main-page.largeのURL
⑤ main-pageのURL

の順序でURLを決定します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
StandardUserPageProvider()
デフォルトコンストラクタ
メソッドの概要
protected String | getExtendedMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 拡張メインページURLを取得します。
String | getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得します。
String | getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得します。
void | init(Map params) ページプロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardUserPageProvider

public StandardUserPageProvider()
デフォルトコンストラクタ

メソッドの詳細

init

public void init(Map params)
ページプロバイダの初期化を行います。

ページプロバイダのインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース UserPageProvider 内の init
パラメータ:
params - 初期化パラメータのマップ

getInitalPage

public String getInitalPage(SessionInfo sessionInfo,
                            HttpServletRequest request,
                            HttpServletResponse response)
初期ページURLを取得します。

初期アクセス時に表示するURLを取得します。

定義:
インタフェース UserPageProvider 内の getInitalPage
パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL

getMainPage

public String getMainPage(SessionInfo sessionInfo,
                          HttpServletRequest request,
                          HttpServletResponse response)
メインページURLを取得します。

ログイン後のメイン画面を表示するURLを取得する。
拡張メインページが存在する（getExtendedMainPage()の返却値がNULLでない。）場合は、そのページを返却します。

定義:
インタフェース UserPageProvider 内の getMainPage
パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL

getExtendedMainPage

protected String getExtendedMainPage(SessionInfo sessionInfo,
                                     HttpServletRequest request,
                                     HttpServletResponse response)
拡張メインページURLを取得します。

ログイン後の拡張メイン画面を表示するURLを取得します。

ダイレクトURLが有効な場合は、ダイレクトURLをメインページとして返却します。
ログインユーザにメインページパターンIDが設定されている場合は、そのメインページを返却します。
上記のいずれにも当てはまらない場合はNULLを返却します。

パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SuperCertification (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
インタフェース SuperCertification

既知の実装クラスの一覧:
StandardSuperUserCertification, SuperUserNoCertification
public interface SuperCertification

管理者ログイン認証インタフェース。

管理者ログイン認証を行うためのインタフェース
管理者ログイン認証を実装する場合は必ずこのインターフェースを実装する。
アクセスセキュリティAPIはこのインタフェースを通じて認証処理を行います。

このインターフェースを実装したクラスを以下の設定ファイルに記述します。
サーバーマネージャインストールディレクトリ/conf/access-security.xml
<access-security>/<security-config>以下の<super-user-security>,<group-super-user-security>の各タグに記述します。

<super-user-security>は、システム管理者に対する設定です。
<group-super-user-security>は、ログイングループ管理者に対する設定です。

     <auto-certification>
       <certification-class>管理者ログイン認証インタフェース実装クラス名（フルパッケージ名）</certification-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </auto-certification>
     <certification>
       <certification-class>管理者ログイン認証インタフェース実装クラス名（フルパッケージ名）</certification-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </certification>
<auto-certification>タグには、ログイン画面表示前のリクエストから認証処理を行う管理者ログイン認証インタフェース実装クラスを設定します。
また、このタグは省略可能です。省略した場合は、自動ログインができなくなります。（ログイン画面を出さずにログイン）

<certification>タグには、ログイン画面からのリクエストから認証処理を行う管理者ログイン認証インタフェース実装クラスを設定します。

<init-param>タグは複数設定可能です。
このタグに設定された値は、クラス初期化時に、init関数の引数として渡されます。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
int | certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証する。
void | init(Map params) 管理者ログイン認証の初期化を行います。

メソッドの詳細

init

public void init(Map params)
管理者ログイン認証の初期化を行います。

管理者ログイン認証のインスタンス生成時に一度だけ呼び出されます。

パラメータ:
params - 初期化パラメータのマップ

certification

public int certification(LoginInfo loginInfo,
                         SuperUser user,
                         HttpServletRequest request,
                         HttpServletResponse response)
管理者を認証する。

パラメータ:
loginInfo - ログイン情報
user - 管理者情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証結果
認証成功 | SecurityConstraint.CR_OK
ユーザ不一致 | SecurityConstraint.CR_NO_USER
認証失敗(パスワード不一致) | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SuperCertificationListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
インタフェース SuperCertificationListener

既知の実装クラスの一覧:
GroupActiveSessionRegister
public interface SuperCertificationListener

管理者ログイン認証リスナーインタフェース。

管理者ログイン認証後にコールされる認証用リスナーインタフェース
管理者ログイン認証リスナーを実装する場合は必ずこのインターフェースを実装する。

このインターフェースを実装したクラスを以下の設定ファイルに記述します。
サーバーマネージャインストールディレクトリ/conf/access-security.xml
<access-security>/<security-config>以下の<super-user-security>,<group-super-user-security>の各タグに記述します。

<super-user-security>は、システム管理者に対する設定です。
<group-super-user-security>は、ログイングループ管理者に対する設定です。

     <certification-listener>
       <listener-class>管理者ログイン認証リスナーインタフェース実装クラス名（フルパッケージ名）</listener-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </certification-listener>

<init-param>タグは複数設定可能です。
このタグに設定された値は、クラス初期化時に、init関数の引数として渡されます。

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
void | doCertification(int certificationResult, LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者の認証後にコールされるメソッドです。
void | init(Map params) 管理者ログイン認証リスナーの初期化を行います。

メソッドの詳細

init

public void init(Map params)
管理者ログイン認証リスナーの初期化を行います。

管理者ログイン認証リスナーのインスタンス生成時に一度だけ呼び出されます。

パラメータ:
params - 初期化パラメータのマップ

doCertification

public void doCertification(int certificationResult,
                            LoginInfo loginInfo,
                            SuperUser user,
                            HttpServletRequest request,
                            HttpServletResponse response)
管理者の認証後にコールされるメソッドです。

パラメータ:
certificationResult - 認証結果
認証成功 | SecurityConstraint.CR_OK
ユーザ不一致 | SecurityConstraint.CR_NO_USER
認証失敗(パスワード不一致) | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
loginInfo - ログイン情報
user - 管理者情報
request - サーブレットリクエスト
response - サーブレットレスポンス
導入されたバージョン:
6.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SuperUserNoCertification (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス SuperUserNoCertification

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification
すべての実装インタフェース:
SuperCertification
public class SuperUserNoCertification
extends Object
implements SuperCertification

システム管理者ログイン時に強制認証を行う実装クラスです。

このクラスは、システム管理者ログインの認証を必ず成功させるクラスです。

システム管理者のパスワードを忘れた場合などの緊急事態にこのクラスを設定することで、必ずログインできるようになります。
事態を回避できた後は、セキュリティ上、必ず設定を元の状態に戻してください。
サーバ/conf/access-security.xmlのsecurity-configにこのクラスを利用するように設定することでクラスが利用されるようになります。

<security-config>
.....
<super-user-security>
.....
<certification>
<certification-class>jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification</certification-class>
 </certification>
.....
</super-user-security>
.....
</security-config>

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
SuperUserNoCertification()
デフォルトコンストラクタ
メソッドの概要
int | certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証します。
void | init(Map params) 管理者ログイン認証の初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SuperUserNoCertification

public SuperUserNoCertification()
デフォルトコンストラクタ

メソッドの詳細

init

public void init(Map params)
管理者ログイン認証の初期化を行います。

管理者ログイン認証のインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース SuperCertification 内の init
パラメータ:
params - 初期化パラメータのマップ

certification

public int certification(LoginInfo loginInfo,
                         SuperUser user,
                         HttpServletRequest request,
                         HttpServletResponse response)
管理者を認証します。

定義:
インタフェース SuperCertification 内の certification
パラメータ:
loginInfo - ログイン情報
user - 管理者情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証結果
認証成功 | SecurityConstraint.CR_OK
認証失敗 | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UserCertification (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
インタフェース UserCertification

既知の実装クラスの一覧:
StandardUserCertification
public interface UserCertification

ユーザログイン認証インタフェース。

ユーザログイン認証を行うためのインタフェース
ユーザログイン認証を実装する場合は必ずこのインターフェースを実装する。
アクセスセキュリティAPIはこのインタフェースを通じて認証処理を行います。

このインターフェースを実装したクラスを以下の設定ファイルに記述します。
サーバーマネージャインストールディレクトリ/conf/access-security.xml
<access-security>/<security-config>/<user-security>のタグに記述します。

     <auto-certification>
       <certification-class>ユーザログイン認証インタフェース実装クラス名（フルパッケージ名）</certification-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </auto-certification>
     <certification>
       <certification-class>ユーザログイン認証インタフェース実装クラス名（フルパッケージ名）</certification-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </certification>
<auto-certification>タグには、ログイン画面表示前のリクエストから認証処理を行ユーザログイン認証インタフェース実装クラスを設定します。
また、このタグは省略可能です。省略した場合は、自動ログインができなくなります。（ログイン画面を出さずにログイン）

<certification>タグには、ログイン画面からのリクエストから認証処理を行うユーザログイン認証インタフェース実装クラスを設定します。

<init-param>タグは複数設定可能です。
このタグに設定された値は、クラス初期化時に、init関数の引数として渡されます。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
int | certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証する。
void | init(Map params) ユーザログイン認証の初期化を行います。

メソッドの詳細

init

public void init(Map params)
ユーザログイン認証の初期化を行います。

ユーザログイン認証のインスタンス生成時に一度だけ呼び出されます。

パラメータ:
params - 初期化パラメータのマップ

certification

public int certification(LoginInfo loginInfo,
                         Account user,
                         HttpServletRequest request,
                         HttpServletResponse response)
ユーザを認証する。

パラメータ:
loginInfo - ログイン情報
user - ユーザ情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証結果
認証成功 | SecurityConstraint.CR_OK
認証失敗 | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserCertificationListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
インタフェース UserCertificationListener

既知の実装クラスの一覧:
UserActiveSessionRegister
public interface UserCertificationListener

ユーザログイン認証リスナーインタフェース。

ユーザログイン認証後にコールされる認証リスナーインタフェース
ユーザログイン認証リスナーを実装する場合は必ずこのインターフェースを実装する。

このインターフェースを実装したクラスを以下の設定ファイルに記述します。
サーバーマネージャインストールディレクトリ/conf/access-security.xml
<access-security>/<security-config>/<user-security> の
<certification> または <auto-certification> タグに記述します。

     <certification-listener>
       <listener-class>ユーザログイン認証リスナーインタフェース実装クラス名（フルパッケージ名）</listener-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </certification-listener>

<certification-listener>タグは複数設定可能です。
<init-param>タグは複数設定可能です。
このタグに設定された値は、クラス初期化時に、init関数の引数として渡されます。

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
void | doCertification(int certificationResult, LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザの認証後にコールされるメソッドです。
void | init(Map params) ユーザログイン認証リスナーの初期化を行います。

メソッドの詳細

init

public void init(Map params)
ユーザログイン認証リスナーの初期化を行います。

ユーザログイン認証リスナーのインスタンス生成時に一度だけ呼び出されます。

パラメータ:
params - 初期化パラメータのマップ

doCertification

public void doCertification(int certificationResult,
                            LoginInfo loginInfo,
                            Account user,
                            HttpServletRequest request,
                            HttpServletResponse response)
ユーザの認証後にコールされるメソッドです。

パラメータ:
certificationResult - 認証結果
認証成功 | SecurityConstraint.CR_OK
認証失敗 | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
loginInfo - ログイン情報
user - ユーザ情報
request - サーブレットリクエスト
response - サーブレットレスポンス
導入されたバージョン:
6.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserPageProvider (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
インタフェース UserPageProvider

既知の実装クラスの一覧:
StandardGroupSuperUserPageProvider, StandardSuperUserPageProvider, StandardUserPageProvider
public interface UserPageProvider

ユーザページプロバイダインタフェース。

ユーザ用の各種ページを取得するためのインタフェース
ユーザページプロバイダを実装する場合は必ずこのインターフェースを実装する。
アクセスセキュリティAPIはこのインタフェースを通じてログイン画面およびログイン後のメイン画面を行います。

このインターフェースを実装したクラスを以下の設定ファイルに記述します。
サーバーマネージャインストールディレクトリ/conf/access-security.xml
<access-security>/<security-config>以下の<super-user-security>,<group-super-user-security><user-security>の各タグに記述します。

<super-user-security>は、システム管理者に対する設定です。
<group-super-user-security>は、ログイングループ管理者に対する設定です。
<user-security>は、一般ユーザに対する設定です。

     <page-provider>
       <page-provider-class>ユーザページプロバイダ実装クラス名（フルパッケージ名）</page-provider-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </page-provider>
<init-param>タグは複数設定可能です。
このタグに設定された値は、クラス初期化時に、init関数の引数として渡されます。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得する。
String | getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得する。
void | init(Map params) ページプロバイダの初期化を行います。

メソッドの詳細

init

public void init(Map params)
ページプロバイダの初期化を行います。

ページプロバイダのインスタンス生成時に一度だけ呼び出されます。

パラメータ:
params - 初期化パラメータのマップ

getInitalPage

public String getInitalPage(SessionInfo sessionInfo,
                            HttpServletRequest request,
                            HttpServletResponse response)
初期ページURLを取得する。

初期アクセス時に表示するURLを取得する。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL

getMainPage

public String getMainPage(SessionInfo sessionInfo,
                          HttpServletRequest request,
                          HttpServletResponse response)
メインページURLを取得する。

ログイン後のメイン画面を表示するURLを取得する。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.AccessSecurityManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.AccessSecurityManager の使用

AccessSecurityManager を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での AccessSecurityManager の使用

AccessSecurityManager を返す jp.co.intra_mart.foundation.security のメソッド
static AccessSecurityManager AccessSecurityManager.getInstance()
セキュリティマネージャのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.ClientTypeInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.ClientTypeInfo の使用

ClientTypeInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での ClientTypeInfo の使用

ClientTypeInfo を返す jp.co.intra_mart.foundation.security のメソッド
ClientTypeInfo | SystemManager.getClientType(Locale reqLocale, String clientType) 指定ロケールでクライアントタイプ情報を取得します。
ClientTypeInfo[] | SystemManager.getClientTypes(Locale reqLocale) 指定ロケールでクライアントタイプ情報の一覧を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.ColorPatternInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.ColorPatternInfo の使用

ColorPatternInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での ColorPatternInfo の使用

ColorPatternInfo を返す jp.co.intra_mart.foundation.security のメソッド
ColorPatternInfo | SystemManager.getColorPattern(Locale reqLocale, String colorPatternId) 指定ロケールでカラーパターン情報を取得します。
ColorPatternInfo[] | SystemManager.getColorPatterns(Locale reqLocale) 指定ロケールでカラーパターン情報の一覧を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.DepartmentInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.DepartmentInfo の使用

DepartmentInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.navigator での DepartmentInfo の使用

DepartmentInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
DepartmentInfo[] | EventAccessInfo.getDepartments()
DepartmentInfo | EventAccessInfo.getDepartment(int i)

DepartmentInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | EventAccessInfo.setDepartments(DepartmentInfo[] departments)
void | EventAccessInfo.setDepartment(int i, DepartmentInfo department)
void | EventAccessInfo.addDepartment(DepartmentInfo department)

jp.co.intra_mart.foundation.security での DepartmentInfo の使用

DepartmentInfo を返す jp.co.intra_mart.foundation.security のメソッド
DepartmentInfo[] | StandardMenuAccessor.getMenuDepartments(String groupId, String id) すべてのメニュー組織を取得します。
DepartmentInfo[] | StandardAccessControllerAccessor.getControllerDepartments(String groupId, String id) すべてのアクセスコントローラ組織を取得します。

DepartmentInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | StandardMenuAccessor.deleteMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を削除します。
String[] | StandardMenuAccessor.getMenuIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つメニューIDをすべて取得します。
void | StandardMenuAccessor.insertMenuDepartment(String groupId, String menuId, DepartmentInfo departmentInfo) メニュー組織を新規に作成します。
void | StandardAccessControllerAccessor.deleteControllerDepartment(String groupId, String id, DepartmentInfo departmentInfo) アクセスコントローラ組織を削除します。
String[] | StandardAccessControllerAccessor.getControllerIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つコントローラIDをすべて取得します。
void | StandardAccessControllerAccessor.insertControllerDepartment(String groupId, String id, DepartmentInfo departmentInfo) アクセスコントローラ組織を新規に作成します。

jp.co.intra_mart.foundation.security.access での DepartmentInfo の使用

DepartmentInfo を返す jp.co.intra_mart.foundation.security.access のメソッド
DepartmentInfo[] | AccessControllerManager.getControllerDepartments(String controllerId) アクセスコントローラに紐付いた組織の一覧を取得します。
DepartmentInfo[] | AccessControllerAccessor.getControllerDepartments(String groupId, String id) すべてのアクセスコントローラ組織を取得します。

DepartmentInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | AccessControllerManager.addControllerDepartment(String controllerId, DepartmentInfo departmentInfo) 組織をアクセスコントローラに紐付けます。
void | AccessControllerManager.deleteControllerDepartment(String controllerId, DepartmentInfo departmentInfo) 組織の紐付けをアクセスコントローラから削除します。
String[] | AccessControllerManager.getControllerIdsByDepartment(DepartmentInfo[] departments) 指定された組織を持つアクセスコントローラIDをすべて取得します。
void | AccessControllerAccessor.deleteControllerDepartment(String groupId, String id, DepartmentInfo departmentInfo) アクセスコントローラ組織を削除します。
String[] | AccessControllerAccessor.getControllerIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つコントローラIDをすべて取得します。
void | AccessControllerAccessor.insertControllerDepartment(String groupId, String id, DepartmentInfo departmentInfo) アクセスコントローラ組織を新規に作成します。

jp.co.intra_mart.foundation.security.menu での DepartmentInfo の使用

DepartmentInfo を返す jp.co.intra_mart.foundation.security.menu のメソッド
DepartmentInfo[] | MenuManager.getMenuDepartments(String menuId) メニューに紐付いた組織の一覧を取得します。
DepartmentInfo[] | MenuAccessor.getMenuDepartments(String groupId, String id) すべてのメニュー組織を取得します。

DepartmentInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuManager.addMenuDepartment(String menuId, DepartmentInfo departmentInfo) 組織をメニューに紐付けます。
void | MenuManager.deleteMenuDepartment(String menuId, DepartmentInfo departmentInfo) 組織の紐付けをメニューから削除します。
String[] | MenuManager.getMenuIdsByDepartment(DepartmentInfo[] departments) 指定された組織を持つメニューIDをすべて取得します。
void | MenuAccessor.deleteMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を削除します。
String[] | MenuAccessor.getMenuIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つメニューIDをすべて取得します。
void | MenuAccessor.insertMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を新規に作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.ExtendsImport の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.ExtendsImport の使用

jp.co.intra_mart.foundation.security.ExtendsImport はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.ExtendsImportManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.ExtendsImportManager の使用

ExtendsImportManager を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での ExtendsImportManager の使用

ExtendsImportManager を返す jp.co.intra_mart.foundation.security のメソッド
static ExtendsImportManager ExtendsImportManager.getInstance()

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.INonTransaction の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.INonTransaction の使用

jp.co.intra_mart.foundation.security.INonTransaction はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.LocaleInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.LocaleInfo の使用

LocaleInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での LocaleInfo の使用

LocaleInfo を返す jp.co.intra_mart.foundation.security のメソッド
LocaleInfo | SystemManager.getLocale(Locale reqLocale, Locale locale) 指定ロケールでロケール情報を取得します。
LocaleInfo[] | SystemManager.getLocales(Locale reqLocale) 指定ロケールでロケール情報の一覧を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.LocaleProvider の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.LocaleProvider の使用

LocaleProvider を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security での LocaleProvider の使用

jp.co.intra_mart.foundation.security での LocaleProvider のサブインタフェース
interface | LocaleInfo ロケｰル情報・モデルインタフェース。
interface | SessionInfo intra-martセッション情報参照インタフェース。

jp.co.intra_mart.foundation.security.account での LocaleProvider の使用

LocaleProvider を実装している jp.co.intra_mart.foundation.security.account のクラス
 class Account
アカウントモデル。

jp.co.intra_mart.foundation.security.admin での LocaleProvider の使用

LocaleProvider を実装している jp.co.intra_mart.foundation.security.admin のクラス
 class SuperUser
スーパーユーザ・モデルインタフェース。

jp.co.intra_mart.foundation.security.certification での LocaleProvider の使用

jp.co.intra_mart.foundation.security.certification での LocaleProvider のサブインタフェース
interface | LoginInfo intra-martログイン情報操作インタフェース。
interface | LoginRequestInfo intra-martログイン情報操作インタフェース。

jp.co.intra_mart.foundation.security.group での LocaleProvider の使用

LocaleProvider を実装している jp.co.intra_mart.foundation.security.group のクラス
 class LoginGroup
ログイングループ・モデル。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.PostInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.PostInfo の使用

PostInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.navigator での PostInfo の使用

PostInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
PostInfo[] | EventAccessInfo.getPosts()
PostInfo | EventAccessInfo.getPost(int i)

PostInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | EventAccessInfo.setPosts(PostInfo[] posts)
void | EventAccessInfo.setPost(int i, PostInfo post)
void | EventAccessInfo.addPost(PostInfo post)

jp.co.intra_mart.foundation.security での PostInfo の使用

PostInfo を返す jp.co.intra_mart.foundation.security のメソッド
PostInfo[] | StandardMenuAccessor.getMenuPosts(String groupId, String id) すべてのメニュー役職を取得します。
PostInfo[] | StandardAccessControllerAccessor.getControllerPosts(String groupId, String id) すべてのアクセスコントローラ役職を取得します。

PostInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | StandardMenuAccessor.deleteMenuPost(String groupId, String id, PostInfo postInfo) メニュー役職を削除します。
String[] | StandardMenuAccessor.getMenuIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つメニューIDをすべて取得します。
void | StandardMenuAccessor.insertMenuPost(String groupId, String menuId, PostInfo postInfo) メニュー役職を新規に作成します。
void | StandardAccessControllerAccessor.deleteControllerPost(String groupId, String id, PostInfo postInfo) アクセスコントローラ役職を削除します。
String[] | StandardAccessControllerAccessor.getControllerIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つコントローラIDをすべて取得します。
void | StandardAccessControllerAccessor.insertControllerPost(String groupId, String id, PostInfo postInfo) アクセスコントローラ役職を新規に作成します。

jp.co.intra_mart.foundation.security.access での PostInfo の使用

PostInfo を返す jp.co.intra_mart.foundation.security.access のメソッド
PostInfo[] | AccessControllerManager.getControllerPosts(String controllerId) アクセスコントローラに紐付いた役職の一覧を取得します。
PostInfo[] | AccessControllerAccessor.getControllerPosts(String groupId, String id) すべてのアクセスコントローラ役職を取得します。

PostInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | AccessControllerManager.addControllerPost(String controllerId, PostInfo postInfo) 役職をアクセスコントローラに紐付けます。
void | AccessControllerManager.deleteControllerPost(String controllerId, PostInfo postInfo) 役織の紐付けをアクセスコントローラから削除します。
String[] | AccessControllerManager.getControllerIdsByPost(PostInfo[] posts) 指定された役職を持つアクセスコントローラIDをすべて取得します。
void | AccessControllerAccessor.deleteControllerPost(String groupId, String id, PostInfo postInfo) アクセスコントローラ役職を削除します。
String[] | AccessControllerAccessor.getControllerIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つコントローラIDをすべて取得します。
void | AccessControllerAccessor.insertControllerPost(String groupId, String id, PostInfo postInfo) アクセスコントローラ役職を新規に作成します。

jp.co.intra_mart.foundation.security.menu での PostInfo の使用

PostInfo を返す jp.co.intra_mart.foundation.security.menu のメソッド
PostInfo[] | MenuManager.getMenuPosts(String menuId) メニューに紐付いた役職の一覧を取得します。
PostInfo[] | MenuAccessor.getMenuPosts(String groupId, String id) すべてのメニュー役職を取得します。

PostInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuManager.addMenuPost(String menuId, PostInfo postInfo) 役職をメニューに紐付けます。
void | MenuManager.deleteMenuPost(String menuId, PostInfo postInfo) 役織の紐付けをメニューから削除します。
String[] | MenuManager.getMenuIdsByPost(PostInfo[] posts) 指定された役職を持つメニューIDをすべて取得します。
void | MenuAccessor.deleteMenuPost(String groupId, String id, PostInfo postInfo) メニュー役職を削除します。
String[] | MenuAccessor.getMenuIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つメニューIDをすべて取得します。
void | MenuAccessor.insertMenuPost(String groupId, String id, PostInfo postInfo) メニュー役職を新規に作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.PublicGroupInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.PublicGroupInfo の使用

PublicGroupInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.navigator での PublicGroupInfo の使用

PublicGroupInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
PublicGroupInfo[] | EventAccessInfo.getPublicGroups()
PublicGroupInfo | EventAccessInfo.getPublicGroup(int i)

PublicGroupInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | EventAccessInfo.setPublicGroups(PublicGroupInfo[] publicGroups)
void | EventAccessInfo.setPublicGroup(int i, PublicGroupInfo publicGroup)
void | EventAccessInfo.addPublicGroup(PublicGroupInfo publicGroup)

jp.co.intra_mart.foundation.security での PublicGroupInfo の使用

PublicGroupInfo を返す jp.co.intra_mart.foundation.security のメソッド
PublicGroupInfo[] | StandardMenuAccessor.getMenuPublicGroups(String groupId, String id) すべてのメニューパブリックグループを取得します。
PublicGroupInfo[] | StandardAccessControllerAccessor.getControllerPublicGroups(String groupId, String id) すべてのアクセスコントローラパブリックグループを取得します。

PublicGroupInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | StandardMenuAccessor.deleteMenuPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) メニューパブリックグループを削除します。
String[] | StandardMenuAccessor.getMenuIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つメニューIDをすべて取得します。
void | StandardMenuAccessor.insertMenuPublicGroup(String groupId, String menuId, PublicGroupInfo publicGroupInfo) メニューパブリックグループを新規に作成します。
void | StandardAccessControllerAccessor.deleteControllerPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) アクセスコントローラパブリックグループを削除します。
String[] | StandardAccessControllerAccessor.getControllerIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つコントローラIDをすべて取得します。
void | StandardAccessControllerAccessor.insertControllerPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) アクセスコントローラパブリックグループを新規に作成します。

jp.co.intra_mart.foundation.security.access での PublicGroupInfo の使用

PublicGroupInfo を返す jp.co.intra_mart.foundation.security.access のメソッド
PublicGroupInfo[] | AccessControllerManager.getControllerPublicGroups(String controllerId) アクセスコントローラに紐付いたパブリックグループの一覧を取得します。
PublicGroupInfo[] | AccessControllerAccessor.getControllerPublicGroups(String groupId, String id) すべてのアクセスコントローラパブリックグループを取得します。

PublicGroupInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | AccessControllerManager.addControllerPublicGroup(String controllerId, PublicGroupInfo publicGroupInfo) パブリックグループをアクセスコントローラに紐付けます。
void | AccessControllerManager.deleteControllerPublicGroup(String controllerId, PublicGroupInfo publicGroupInfo) パブリックグループの紐付けをアクセスコントローラから削除します。
String[] | AccessControllerManager.getControllerIdsByPublicGroup(PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つアクセスコントローラIDをすべて取得します。
void | AccessControllerAccessor.deleteControllerPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) アクセスコントローラパブリックグループを削除します。
String[] | AccessControllerAccessor.getControllerIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つコントローラIDをすべて取得します。
void | AccessControllerAccessor.insertControllerPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) アクセスコントローラパブリックグループを新規に作成します。

jp.co.intra_mart.foundation.security.menu での PublicGroupInfo の使用

PublicGroupInfo を返す jp.co.intra_mart.foundation.security.menu のメソッド
PublicGroupInfo[] | MenuManager.getMenuPublicGroups(String menuId) メニューに紐付いたパブリックグループの一覧を取得します。
PublicGroupInfo[] | MenuAccessor.getMenuPublicGroups(String groupId, String id) すべてのメニューパブリックグループを取得します。

PublicGroupInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuManager.addMenuPublicGroup(String menuId, PublicGroupInfo publicGroupInfo) パブリックグループをメニューに紐付けます。
void | MenuManager.deleteMenuPublicGroup(String menuId, PublicGroupInfo publicGroupInfo) パブリックグループの紐付けをメニューから削除します。
String[] | MenuManager.getMenuIdsByPublicGroup(PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つメニューIDをすべて取得します。
void | MenuAccessor.deleteMenuPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) メニューパブリックグループを削除します。
String[] | MenuAccessor.getMenuIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つメニューIDをすべて取得します。
void | MenuAccessor.insertMenuPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) メニューパブリックグループを新規に作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.SecurityConstraint の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.SecurityConstraint の使用

jp.co.intra_mart.foundation.security.SecurityConstraint はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.SessionConfig の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.SessionConfig の使用

SessionConfig を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での SessionConfig の使用

SessionConfig を返す jp.co.intra_mart.foundation.security のメソッド
 SessionConfig AccessSecurityManager.getSessionConfig()
セッション情報保管パラメータを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.SessionInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.SessionInfo の使用

SessionInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession |
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.duplication |
jp.co.intra_mart.foundation.security.password |

jp.co.intra_mart.foundation.security での SessionInfo の使用

SessionInfo を返す jp.co.intra_mart.foundation.security のメソッド
SessionInfo | AccessSecurityManager.getCookieSessionInfo() カレントスレッド情報のクッキーからintra-martセッション情報を取得します。
SessionInfo | AccessSecurityManager.getCookieSessionInfo(HttpServletRequest request) クッキーからintra-martセッション情報を取得します。
SessionInfo | AccessSecurityManager.getSessionInfo() カレントスレッド情報からintra-martセッション情報を取得します。
SessionInfo | AccessSecurityManager.getSessionInfo(HttpServletRequest request, HttpServletResponse response) intra-martセッション情報を取得します。

SessionInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
String | AccessSecurityManager.getInitialPage(SessionInfo sessionInfo) カレントスレッド情報から初期アクセスページURLを取得します。
String | AccessSecurityManager.getInitialPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期アクセスページURLを取得します。
String | AccessSecurityManager.getMainPage(SessionInfo sessionInfo) カレントスレッド情報からメインページURLを取得します。
String | AccessSecurityManager.getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得します。
int | AccessSecurityManager.getSessionMode(SessionInfo sessionInfo) intra-martセッションの状態を取得します。

jp.co.intra_mart.foundation.security.activesession での SessionInfo の使用

SessionInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.activesession のメソッド
String | StandardActiveSessionAccessor.getActiveSessionInvalidatedPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 引数で指定されたアクティブなセッション情報が無効化されたされていた場合の遷移先ページURLを取得します。
String | ActiveSessionManager.getActiveSessionInvalidatedPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 引数で指定されたアクティブなセッション情報が無効化されたされていた場合の遷移先ページURLを取得します。
String | ActiveSessionAccessor.getActiveSessionInvalidatedPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 引数で指定されたアクティブなセッション情報が無効化されたされていた場合の遷移先ページURLを取得します。

SessionInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.activesession のコンストラクタ
ActiveSessionInfo(SessionInfo sessionInfo, HttpSession session, String remoteAddr, String userAgent)
コンストラクタ。
ActiveSessionInfo(SessionInfo sessionInfo, String sessionId, int expireInterval, String remoteAddr, String userAgent)
コンストラクタ。

jp.co.intra_mart.foundation.security.certification での SessionInfo の使用

SessionInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.certification のメソッド
String | UserPageProvider.getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得する。
String | UserPageProvider.getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得する。
String | ErrorPageProvider.getCertificationErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 認証失敗エラーページURLを取得する。
String | ErrorPageProvider.getLockedErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ユーザロックエラーページURLを取得する。
String | ErrorPageProvider.getLicenceErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ライセンスエラーページURLを取得する。
String | ErrorPageProvider.getGroupErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ログイングループエラーページURLを取得する。
String | ErrorPageProvider.getSessionErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) セッションエラーページURLを取得する。
String | ErrorPageProvider.getNoPermissionErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 無許可アクセスエラーページURLを取得する。
String | ErrorPageProvider.getSystemErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 認証処理エラーページURLを取得する。
String | StandardUserPageProvider.getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得します。
String | StandardUserPageProvider.getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得します。
protected String | StandardUserPageProvider.getExtendedMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 拡張メインページURLを取得します。
String | StandardSuperUserPageProvider.getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得する。
String | StandardSuperUserPageProvider.getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得する。
String | StandardGroupSuperUserPageProvider.getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得する。
String | StandardGroupSuperUserPageProvider.getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得する。
String | StandardErrorPageProvider.getCertificationErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 認証失敗エラーページURLを取得します。
String | StandardErrorPageProvider.getGroupErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ログイングループエラーページURLを取得します。
String | StandardErrorPageProvider.getLicenceErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ライセンスエラーページURLを取得します。
String | StandardErrorPageProvider.getLockedErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ユーザロックエラーページURLを取得します。
String | StandardErrorPageProvider.getNoPermissionErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 無許可アクセスエラーページURLを取得する。
String | StandardErrorPageProvider.getSessionErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) セッションエラーページURLを取得する。
String | StandardErrorPageProvider.getSystemErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 認証処理エラーページURLを取得する。
String | PortalStandardUserPageProvider.getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得します。
protected String | PortalStandardUserPageProvider.getExtendedMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 拡張メインページURLを取得します。

jp.co.intra_mart.foundation.security.duplication での SessionInfo の使用

SessionInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.duplication のメソッド
String | StandardDuplicateLoginAccessor.getDuplicateLoginDetectionPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 引数で指定されたアクティブなセッション情報が重複ログインした場合の遷移先ページURLを取得します。
String | DuplicateLoginManager.getDuplicateLoginDetectionPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 引数で指定されたアクティブなセッション情報が重複ログインした場合の遷移先ページURLを取得します。
String | DuplicateLoginAccessor.getDuplicateLoginDetectionPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 引数で指定されたアクティブなセッション情報が重複ログインした場合の遷移先ページURLを取得します。

jp.co.intra_mart.foundation.security.password での SessionInfo の使用

SessionInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.password のメソッド
protected  String PasswordHistoryUserPageProvider.getExtendedMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor の使用

jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.StandardAccountAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.StandardAccountAccessor の使用

jp.co.intra_mart.foundation.security.StandardAccountAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.StandardBatchAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.StandardBatchAccessor の使用

jp.co.intra_mart.foundation.security.StandardBatchAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.StandardCalendarAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.StandardCalendarAccessor の使用

jp.co.intra_mart.foundation.security.StandardCalendarAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.StandardMenuAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.StandardMenuAccessor の使用

jp.co.intra_mart.foundation.security.StandardMenuAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.StandardRoleAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.StandardRoleAccessor の使用

jp.co.intra_mart.foundation.security.StandardRoleAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.SystemManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.SystemManager の使用

SystemManager を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での SystemManager の使用

SystemManager を返す jp.co.intra_mart.foundation.security のメソッド
static SystemManager SystemManager.getInstance()
システムマネージャインスタンスを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.SystemSourceProvider の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.SystemSourceProvider の使用

SystemSourceProvider を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での SystemSourceProvider の使用

SystemSourceProvider 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
static void SystemManager.setSorucePovider(SystemSourceProvider provider)
ソースプロバイダを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.cryption.Cryption の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.cryption.Cryption の使用

Cryption を使用しているパッケージ
jp.co.intra_mart.foundation.security.cryption 暗号化に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.cryption での Cryption の使用

Cryption を実装している jp.co.intra_mart.foundation.security.cryption のクラス
class | NoCryption 暗号化処理を行わない実装クラス。
class | StandardCryption 文字列の暗号化・復号化を行う標準の実装クラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.cryption.NoCryption の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.cryption.NoCryption の使用

jp.co.intra_mart.foundation.security.cryption.NoCryption はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.cryption.StandardCryption の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.cryption.StandardCryption の使用

jp.co.intra_mart.foundation.security.cryption.StandardCryption はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Cryption (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.cryption
インタフェース Cryption

既知の実装クラスの一覧:
NoCryption, StandardCryption
public interface Cryption

文字列の暗号化・復号化インタフェース。

文字列の暗号化・復号化を行うインタフェース

jp.co.intra_mart.foundation.security.StandardAccountAccessorを用いている場合は、
サーバ/conf/access-security.xmlのaccess-configにこのクラスを実装したクラスを利用するように設定することでこのクラスが利用されるようになります。

jp.co.intra_mart.foundation.security.StandardAccountAccessorでは、パスワードおよびモバイルパスワードを
このクラスを実装したクラスの暗号化処理を使って暗号化・復号化を行っています。
<access-config>
.....
<account>
<accessor>
<accessor-class>jp.co.intra_mart.foundation.security.StandardAccountAccessor</accessor-class>
<init-param>
<param-name>cryption-class</param-name>
<param-value>jp.co.intra_mart.foundation.security.cryption.Cryptionを実装したクラス</param-value>
</init-param>
 </accessor>
</account>
.....
</access-config>

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | decrypt(String secret) 暗号化された文字列を復号するe。
String | encrypt(String plane) 文字列を暗号化する。

メソッドの詳細

decrypt

public String decrypt(String secret)
暗号化された文字列を復号するe。

パラメータ:
secret - 暗号化された文字列
戻り値:
復号化された文字列

encrypt

public String encrypt(String plane)
文字列を暗号化する。

パラメータ:
plane - 暗号化する文字列
戻り値:
暗号化された文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


NoCryption (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.cryption
クラス NoCryption

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.cryption.NoCryption
すべての実装インタフェース:
Cryption
public class NoCryption
extends Object
implements Cryption

暗号化処理を行わない実装クラス。

暗号化処理を行わないクラスです。
標準では、アカウントのパスワード、モバイルパスワードを暗号化するためにStandardCryption が利用されますが、
このクラスを用いることにより、データストアに暗号化を行わないで、保管することができます。
サーバ/conf/access-security.xmlのaccess-configにこのクラスを利用するように設定することでこのクラスが利用されるようになります。

<access-config>
.....
<account>
<accessor>
<accessor-class>jp.co.intra_mart.foundation.security.StandardAccountAccessor</accessor-class>
<init-param>
<param-name>cryption-class</param-name>
<param-value>jp.co.intra_mart.foundation.security.cryption.NoCryption</param-value>
</init-param>
 </accessor>
</account>
.....
</access-config>

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
NoCryption()
コンストラクタ。
メソッドの概要
String | decrypt(String secret) 暗号化された文字列を復号するe。
String | encrypt(String plane) 文字列を暗号化する。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NoCryption

public NoCryption()
コンストラクタ。

メソッドの詳細

decrypt

public String decrypt(String secret)
暗号化された文字列を復号するe。

このメソッドでは、引数に渡された値をそのまま返却します。

定義:
インタフェース Cryption 内の decrypt
パラメータ:
secret - 暗号化された文字列
戻り値:
復号化された文字列

encrypt

public String encrypt(String plane)
文字列を暗号化する。

このメソッドでは、引数に渡された値をそのまま返却します。

定義:
インタフェース Cryption 内の encrypt
パラメータ:
plane - 暗号化する文字列
戻り値:
暗号化された文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.cryption (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.security.cryption
インタフェース
Cryption
クラス
NoCryption
StandardCryption


jp.co.intra_mart.foundation.security.cryption (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.cryption

暗号化に関連するクラスを提供します。

参照:
説明

インタフェースの概要
Cryption 文字列の暗号化・復号化インタフェース。

クラスの概要
NoCryption | 暗号化処理を行わない実装クラス。
StandardCryption | 文字列の暗号化・復号化を行う標準の実装クラスです。

パッケージ jp.co.intra_mart.foundation.security.cryption の説明

暗号化に関連するクラスを提供します。


jp.co.intra_mart.foundation.security.cryption クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.cryption の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.cryption.NoCryption (implements jp.co.intra_mart.foundation.security.cryption.Cryption)
    • class jp.co.intra_mart.foundation.security.cryption.StandardCryption (implements jp.co.intra_mart.foundation.security.cryption.Cryption)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.cryption.Cryption


パッケージ jp.co.intra_mart.foundation.security.cryption の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.cryption の使用

jp.co.intra_mart.foundation.security.cryption を使用しているパッケージ
jp.co.intra_mart.foundation.security.cryption 暗号化に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.cryption により使用される jp.co.intra_mart.foundation.security.cryption のクラス
Cryption
文字列の暗号化・復号化インタフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardCryption (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.cryption
クラス StandardCryption

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.cryption.StandardCryption
すべての実装インタフェース:
Cryption
public class StandardCryption
extends Object
implements Cryption

文字列の暗号化・復号化を行う標準の実装クラスです。

jp.co.intra_mart.foundation.security.StandardAccountAccessorでパスワードとモバイルパスワードを
暗号化して保存、復号化して取得するための標準のクラスとして利用しています。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
StandardCryption()
コンストラクタ。
メソッドの概要
String | decrypt(String secret) 暗号化された文字列を復号するe。
String | encrypt(String plane) 文字列を暗号化する。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardCryption

public StandardCryption()
コンストラクタ。

メソッドの詳細

decrypt

public String decrypt(String secret)
暗号化された文字列を復号するe。

定義:
インタフェース Cryption 内の decrypt
パラメータ:
secret - 暗号化された文字列
戻り値:
復号化された文字列 復号に失敗した場合はnullを返却します。
関連項目:
Cryption.decrypt(java.lang.String)

encrypt

public String encrypt(String plane)
文字列を暗号化する。

定義:
インタフェース Cryption 内の encrypt
パラメータ:
plane - 暗号化する文字列
戻り値:
暗号化された文字列 暗号化に失敗した場合はnullを返却します。
関連項目:
Cryption.encrypt(java.lang.String)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor の使用

DuplicateLoginAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.security.duplication

jp.co.intra_mart.foundation.security.duplication での DuplicateLoginAccessor の使用

DuplicateLoginAccessor を実装している jp.co.intra_mart.foundation.security.duplication のクラス
 class StandardDuplicateLoginAccessor
重複ログイン操作インターフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager の使用

jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor の使用

jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DuplicateLoginAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.duplication
インタフェース DuplicateLoginAccessor

既知の実装クラスの一覧:
StandardDuplicateLoginAccessor
public interface DuplicateLoginAccessor

重複ログイン操作インターフェース。

アクティブなセッション情報に対して重複ログインを管理するためのクラス

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
String | getDuplicateLoginDetectionPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 引数で指定されたアクティブなセッション情報が重複ログインした場合の遷移先ページURLを取得します。
void | init(Node defaultNode, Node node) 設定ファイルの情報を基に初期化します。
boolean | isDetectEnable(ActiveSessionInfo activeSessionInfo) 検出処理が有効かどうか取得します。
boolean | isDetectEnable(String loginGroup, String loginType) 検出処理が有効かどうか取得します。
boolean | isInvalidatableByUser(ActiveSessionInfo activeSessionInfo) ユーザ自身のセッションの無効化が可能か取得します。
boolean | isInvalidatableByUser(String loginGroup, String loginType) ユーザ自身のセッションの無効化が可能か取得します。

メソッドの詳細

init

public void init(Node defaultNode,
                 Node node)
          throws DuplicateLoginException
設定ファイルの情報を基に初期化します。

パラメータ:
defaultNode - デフォルトノード
node - デフォルトノード
例外:
DuplicateLoginException - 初期化処理で例外が発生した場合にスローされます。

isDetectEnable

public boolean isDetectEnable(ActiveSessionInfo activeSessionInfo)
検出処理が有効かどうか取得します。

パラメータ:
activeSessionInfo - アクティブなセッション情報
戻り値:
検出処理が有効かどうか

isDetectEnable

public boolean isDetectEnable(String loginGroup,
                              String loginType)
検出処理が有効かどうか取得します。

パラメータ:
loginGroup - ログイングループ
loginType - ログインタイプ
戻り値:
検出処理が有効かどうか

isInvalidatableByUser

public boolean isInvalidatableByUser(ActiveSessionInfo activeSessionInfo)
ユーザ自身のセッションの無効化が可能か取得します。

パラメータ:
activeSessionInfo - アクティブなセッション情報
戻り値:
検出処理が有効かどうか

isInvalidatableByUser

public boolean isInvalidatableByUser(String loginGroup,
                                     String loginType)
ユーザ自身のセッションの無効化が可能か取得します。

パラメータ:
loginGroup - ログイングループ
loginType - ログインタイプ
戻り値:
検出処理が有効かどうか

getDuplicateLoginDetectionPage

public String getDuplicateLoginDetectionPage(SessionInfo sessionInfo,
                                             HttpServletRequest request,
                                             HttpServletResponse response)
引数で指定されたアクティブなセッション情報が重複ログインした場合の遷移先ページURLを取得します。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
遷移先ページ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DuplicateLoginManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.duplication
クラス DuplicateLoginManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager
public class DuplicateLoginManager
extends Object

重複ログイン管理マネージャクラス。

アクティブなセッション情報に対して重複ログインを管理するためのクラス

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
static String | DEFAULT_ATTR_INVALIDATE_OTHER_SESSIONS
static String | DEFAULT_ATTR_REQUESTED_PAGE
static String | DEFAULT_DUPLICATE_LOGIN_ACCESSOR
コンストラクタの概要
DuplicateLoginManager()
コンストラクタ。
メソッドの概要
String | getDuplicateLoginDetectionPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 引数で指定されたアクティブなセッション情報が重複ログインした場合の遷移先ページURLを取得します。
String | getInvalidateOtherSessionsAttributeName() 現在のセッション以外のアクティブなセッション情報を削除するために使用する属性名を取得します。
String | getRequestedPageAttributeName() リクエストされたページURLを保持するために使用する属性名を取得します。
void | invalidateOtherSessions(ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報以外のセッション情報をすべて無効にします。
boolean | isDetectEnable(ActiveSessionInfo activeSessionInfo) 検出処理が有効かどうか取得します。
boolean | isDetectEnable(String loginGroup, String loginType) 検出処理が有効かどうか取得します。
boolean | isDuplicateLogined(ActiveSessionInfo activeSessionInfo) 引数で指定されたユーザが重複してログインしているかどうか判別します。
boolean | isDuplicateLogined(String loginGroup, String loginType, String userId, String sessionId) 引数で指定されたユーザが重複してログインしているかどうか判別します。
boolean | isInvalidatableByUser(ActiveSessionInfo activeSessionInfo) ユーザ自身のセッションの無効化が可能か取得します。
boolean | isInvalidatableByUser(String loginGroup, String loginType) ユーザ自身のセッションの無効化が可能か取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_ATTR_REQUESTED_PAGE

public static final String DEFAULT_ATTR_REQUESTED_PAGE
関連項目:
定数フィールド値

DEFAULT_ATTR_INVALIDATE_OTHER_SESSIONS

public static final String DEFAULT_ATTR_INVALIDATE_OTHER_SESSIONS
関連項目:
定数フィールド値

DEFAULT_DUPLICATE_LOGIN_ACCESSOR

public static final String DEFAULT_DUPLICATE_LOGIN_ACCESSOR
関連項目:
定数フィールド値
コンストラクタの詳細

DuplicateLoginManager

public DuplicateLoginManager()
コンストラクタ。

メソッドの詳細

isDuplicateLogined

public boolean isDuplicateLogined(ActiveSessionInfo activeSessionInfo)
                           throws DuplicateLoginException
引数で指定されたユーザが重複してログインしているかどうか判別します。

パラメータ:
activeSessionInfo - アクティブなセッション情報
戻り値:
重複してログインしているかどうか
例外:
DuplicateLoginException - 重複ログイン制御処理中にエラーが発生した場合にスローされます。

isDuplicateLogined

public boolean isDuplicateLogined(String loginGroup,
                                  String loginType,
                                  String userId,
                                  String sessionId)
                           throws DuplicateLoginException
引数で指定されたユーザが重複してログインしているかどうか判別します。

パラメータ:
loginGroup - ログイングループID
loginType - ログインタイプ
userId - ユーザID
sessionId - セッションID
戻り値:
重複してログインしている場合 true、重複してログインしていない場合 false
例外:
DuplicateLoginException - 重複ログイン制御処理中にエラーが発生した場合にスローされます。

isDetectEnable

public boolean isDetectEnable(ActiveSessionInfo activeSessionInfo)
検出処理が有効かどうか取得します。

パラメータ:
activeSessionInfo - アクティブなセッション情報
戻り値:
検出処理が有効かどうか

isDetectEnable

public boolean isDetectEnable(String loginGroup,
                              String loginType)
検出処理が有効かどうか取得します。

パラメータ:
loginGroup - ログイングループ
loginType - ログインタイプ
戻り値:
検出処理が有効かどうか

isInvalidatableByUser

public boolean isInvalidatableByUser(ActiveSessionInfo activeSessionInfo)
ユーザ自身のセッションの無効化が可能か取得します。

パラメータ:
activeSessionInfo - アクティブなセッション情報
戻り値:
検出処理が有効かどうか

isInvalidatableByUser

public boolean isInvalidatableByUser(String loginGroup,
                                     String loginType)
ユーザ自身のセッションの無効化が可能か取得します。

パラメータ:
loginGroup - ログイングループ
loginType - ログインタイプ
戻り値:
検出処理が有効かどうか

invalidateOtherSessions

public void invalidateOtherSessions(ActiveSessionInfo activeSessionInfo)
                             throws DuplicateLoginException
引数で指定されたアクティブなセッション情報以外のセッション情報をすべて無効にします。

パラメータ:
activeSessionInfo - アクティブなセッション情報
例外:
DuplicateLoginException - 重複ログイン制御処理中にエラーが発生した場合にスローされます。

getDuplicateLoginDetectionPage

public String getDuplicateLoginDetectionPage(SessionInfo sessionInfo,
                                             HttpServletRequest request,
                                             HttpServletResponse response)
引数で指定されたアクティブなセッション情報が重複ログインした場合の遷移先ページURLを取得します。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
遷移先ページ

getRequestedPageAttributeName

public String getRequestedPageAttributeName()
リクエストされたページURLを保持するために使用する属性名を取得します。

戻り値:
リクエストされたページURLを保持するために使用する属性名

getInvalidateOtherSessionsAttributeName

public String getInvalidateOtherSessionsAttributeName()
現在のセッション以外のアクティブなセッション情報を削除するために使用する属性名を取得します。

戻り値:
現在のセッション以外のアクティブなセッション情報を削除するために使用する属性名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.duplication (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.security.duplication
インタフェース
DuplicateLoginAccessor
クラス
DuplicateLoginManager
StandardDuplicateLoginAccessor


jp.co.intra_mart.foundation.security.duplication (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.duplication

インタフェースの概要
DuplicateLoginAccessor 重複ログイン操作インターフェース。

クラスの概要
DuplicateLoginManager | 重複ログイン管理マネージャクラス。
StandardDuplicateLoginAccessor | 重複ログイン操作インターフェース。


jp.co.intra_mart.foundation.security.duplication クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.duplication の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager
    • class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor (implements jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor


パッケージ jp.co.intra_mart.foundation.security.duplication の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.duplication の使用

jp.co.intra_mart.foundation.security.duplication を使用しているパッケージ
jp.co.intra_mart.foundation.security.duplication

jp.co.intra_mart.foundation.security.duplication により使用される jp.co.intra_mart.foundation.security.duplication のクラス
DuplicateLoginAccessor
重複ログイン操作インターフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardDuplicateLoginAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.duplication
クラス StandardDuplicateLoginAccessor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor
すべての実装インタフェース:
DuplicateLoginAccessor
public class StandardDuplicateLoginAccessor
extends Object
implements DuplicateLoginAccessor

重複ログイン操作インターフェース。

アクティブなセッション情報に対して重複ログインを管理するためのクラス

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
static String | DEFAULT_ACCESS_SECURITY_PAGE_PROVIDER_CLASS
static String | DEFAULT_DUPLICATE_LOGIN_DETECT_ENABLE
static String | DEFAULT_INVALIDATABLE_BY_USER
static String | DEFAULT_PAGE_LOCATION
コンストラクタの概要
StandardDuplicateLoginAccessor()
メソッドの概要
String | getDuplicateLoginDetectionPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 引数で指定されたアクティブなセッション情報が重複ログインした場合の遷移先ページURLを取得します。
void | init(Node defaultNode, Node node) 設定ファイル conf/duplicate-login.xml の情報を基に初期化します。
boolean | isDetectEnable(ActiveSessionInfo activeSessionInfo) 検出処理が有効かどうか取得します。
boolean | isDetectEnable(String loginGroup, String loginType) 重複ログイン検出処理が有効かどうか取得します。
boolean | isInvalidatableByUser(ActiveSessionInfo activeSessionInfo) ユーザ自身のセッションの無効化が可能か取得します。
boolean | isInvalidatableByUser(String loginGroup, String loginType) ユーザ自身のセッションの無効化が可能か取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_ACCESS_SECURITY_PAGE_PROVIDER_CLASS

public static final String DEFAULT_ACCESS_SECURITY_PAGE_PROVIDER_CLASS
関連項目:
定数フィールド値

DEFAULT_PAGE_LOCATION

public static final String DEFAULT_PAGE_LOCATION
関連項目:
定数フィールド値

DEFAULT_DUPLICATE_LOGIN_DETECT_ENABLE

public static final String DEFAULT_DUPLICATE_LOGIN_DETECT_ENABLE
関連項目:
定数フィールド値

DEFAULT_INVALIDATABLE_BY_USER

public static final String DEFAULT_INVALIDATABLE_BY_USER
関連項目:
定数フィールド値
コンストラクタの詳細

StandardDuplicateLoginAccessor

public StandardDuplicateLoginAccessor()
メソッドの詳細

init

public void init(Node defaultNode,
                 Node node)
          throws DuplicateLoginException
設定ファイル conf/duplicate-login.xml の情報を基に初期化します。

定義:
インタフェース DuplicateLoginAccessor 内の init
パラメータ:
defaultNode - デフォルトノード
node - デフォルトノード
例外:
ActiveSessionException - 初期化処理で例外が発生した場合にスローされます。
DuplicateLoginException - 初期化処理で例外が発生した場合にスローされます。

isDetectEnable

public boolean isDetectEnable(ActiveSessionInfo activeSessionInfo)
検出処理が有効かどうか取得します。

定義:
インタフェース DuplicateLoginAccessor 内の isDetectEnable
パラメータ:
activeSessionInfo - アクティブなセッション情報
戻り値:
検出処理が有効かどうか

isDetectEnable

public boolean isDetectEnable(String loginGroup,
                              String loginType)
重複ログイン検出処理が有効かどうか取得します。

定義:
インタフェース DuplicateLoginAccessor 内の isDetectEnable
パラメータ:
loginGroup - ログイングループ
loginType - ログインタイプ
戻り値:
検出処理が有効かどうか

isInvalidatableByUser

public boolean isInvalidatableByUser(ActiveSessionInfo activeSessionInfo)
ユーザ自身のセッションの無効化が可能か取得します。

定義:
インタフェース DuplicateLoginAccessor 内の isInvalidatableByUser
パラメータ:
activeSessionInfo - アクティブなセッション情報
戻り値:
検出処理が有効かどうか

isInvalidatableByUser

public boolean isInvalidatableByUser(String loginGroup,
                                     String loginType)
ユーザ自身のセッションの無効化が可能か取得します。

定義:
インタフェース DuplicateLoginAccessor 内の isInvalidatableByUser
パラメータ:
loginGroup - ログイングループ
loginType - ログインタイプ
戻り値:
検出処理が有効かどうか

getDuplicateLoginDetectionPage

public String getDuplicateLoginDetectionPage(SessionInfo sessionInfo,
                                             HttpServletRequest request,
                                             HttpServletResponse response)
引数で指定されたアクティブなセッション情報が重複ログインした場合の遷移先ページURLを取得します。

定義:
インタフェース DuplicateLoginAccessor 内の getDuplicateLoginDetectionPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
遷移先ページ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException の使用

AccessSecurityConfigException を使用しているパッケージ
jp.co.intra_mart.foundation.security.mobile

jp.co.intra_mart.foundation.security.mobile での AccessSecurityConfigException の使用

AccessSecurityConfigException をスローする jp.co.intra_mart.foundation.security.mobile のメソッド
static String | MobileEasyLoginUtil.getMobileEasyLoginURL(String groupId, String userId) かんたんログイン用のURLを取得します。
static String | MobileEasyLoginUtil.getMobileEasyLoginURL(HttpServletRequest request, String groupId, String userId) かんたんログイン用のURLを取得します。
static String | MobileEasyLoginUtil.getAccessKeyWithRequestParameter(String groupId, String userId) かんたんログイン用のアクセスキーをリクエストパラメータの形式で取得します。
static String | MobileEasyLoginUtil.getAccessKey(String groupId, String userId) かんたんログイン用のアクセスキーを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException の使用

jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException の使用

jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityException の使用

AccessSecurityException を使用しているパッケージ
jp.co.intra_mart.foundation.database | データベースへアクセスするためのクラスを提供します。
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession |
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.license | ライセンスに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.message | メッセージに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.mobile |
jp.co.intra_mart.foundation.security.permission | 権限に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.shortcut |

jp.co.intra_mart.foundation.database での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.database のメソッド
Connection | DatabaseManager.getLoginGroupConnection(String groupId) ログイングループIDからコネクションオブジェクトを取得します。
Connection | DatabaseManager.getSystemConnection(String connectId) システム接続名からコネクションオブジェクトを取得します。

jp.co.intra_mart.foundation.navigator での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.navigator のメソッド
 Collection EventNavigatorPermissionSelector.doSelection(String groupId, String[] infos)
選択用情報を利用して選別された情報のリストを返却します。

jp.co.intra_mart.foundation.security での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security のメソッド
static void | SystemManager.setSorucePovider(SystemSourceProvider provider) ソースプロバイダを設定します。
void | SystemManager.addSuperUser(SuperUser superUser) システム管理者情報を新規に作成します。
ClientTypeInfo | SystemManager.getClientType(Locale reqLocale, String clientType) 指定ロケールでクライアントタイプ情報を取得します。
ClientTypeInfo[] | SystemManager.getClientTypes(Locale reqLocale) 指定ロケールでクライアントタイプ情報の一覧を取得します。
ColorPatternInfo | SystemManager.getColorPattern(Locale reqLocale, String colorPatternId) 指定ロケールでカラーパターン情報を取得します。
ColorPatternInfo[] | SystemManager.getColorPatterns(Locale reqLocale) 指定ロケールでカラーパターン情報の一覧を取得します。
String | SystemManager.getDefaultEncoding(Locale reqLocale) ロケールに対応するデフォルトエンコーディングを取得します。
LocaleInfo | SystemManager.getLocale(Locale reqLocale, Locale locale) 指定ロケールでロケール情報を取得します。
LocaleInfo[] | SystemManager.getLocales(Locale reqLocale) 指定ロケールでロケール情報の一覧を取得します。
SuperUser | SystemManager.getSuperUser() システム管理者情報を取得します。
void | SystemManager.updateSuperUser(SuperUser superUser) システム管理者情報を更新します。
void | ExtendsImportManager.doImport(String groupId, String module) 拡張インポート処理を実行します。
static AccessSecurityManager | AccessSecurityManager.getInstance() セキュリティマネージャのインスタンスを取得します。
String | AccessSecurityManager.createUrlSignature(String url, String groupId, String userId) ダイレクトＵＲＬ署名を作成します。
int | AccessSecurityManager.forceLogin(LoginRequestInfo loginRequestInfo) 強制ログイン処理を行います。
int | AccessSecurityManager.forceLogin(LoginRequestInfo loginRequestInfo, HttpServletRequest request, HttpServletResponse response) 強制ログイン処理を行います。
void | AccessSecurityManager.forward(HttpServletRequest request, HttpServletResponse response, String url) 指定したURLにフォワードします。
void | AccessSecurityManager.forward(String url) 指定したURLにフォワードします。
String | AccessSecurityManager.getErrorPage(int errorCode) カレントスレッド情報からエラーページＵＲＬを取得します。
String | AccessSecurityManager.getErrorPage(int errorCode, HttpServletRequest request, HttpServletResponse response) エラーページＵＲＬを取得します。
int | AccessSecurityManager.getInitialCertification(LoginRequestInfo loginInfo) カレントスレッドの情報から初期アクセス処理を行います。
int | AccessSecurityManager.getInitialCertification(LoginRequestInfo loginInfo, HttpServletRequest request, HttpServletResponse response) 初期アクセス処理を行います。
String | AccessSecurityManager.getInitialPage() カレントスレッド情報から初期アクセスページURLを取得します。
String | AccessSecurityManager.getInitialPage(SessionInfo sessionInfo) カレントスレッド情報から初期アクセスページURLを取得します。
String | AccessSecurityManager.getInitialPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期アクセスページURLを取得します。
int | AccessSecurityManager.getLicense(LoginInfo loginInfo) アカウントライセンスチェックを行います。
int | AccessSecurityManager.getLoginCertification() カレントスレッド情報からログイン処理を行います。
int | AccessSecurityManager.getLoginCertification(HttpServletRequest request, HttpServletResponse response) ログイン処理を行います。
String | AccessSecurityManager.getMainPage() カレントスレッド情報からメインページURLを取得します。
String | AccessSecurityManager.getMainPage(SessionInfo sessionInfo) カレントスレッド情報からメインページURLを取得します。
String | AccessSecurityManager.getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得します。
SessionConfig | AccessSecurityManager.getSessionConfig() セッション情報保管パラメータを取得します。
SessionInfo | AccessSecurityManager.getSessionInfo() カレントスレッド情報からintra-martセッション情報を取得します。
SessionInfo | AccessSecurityManager.getSessionInfo(HttpServletRequest request, HttpServletResponse response) intra-martセッション情報を取得します。
int | AccessSecurityManager.getSessionMode() intra-martセッションの状態を取得します。
int | AccessSecurityManager.getSessionMode(SessionInfo sessionInfo) intra-martセッションの状態を取得します。
int | AccessSecurityManager.login(LoginRequestInfo loginRequestInfo) ログイン処理を行います。
int | AccessSecurityManager.login(LoginRequestInfo loginRequestInfo, HttpServletRequest request, HttpServletResponse response) ログイン処理を行います。
void | AccessSecurityManager.logout() ログアウト処理を行います。
void | AccessSecurityManager.logout(HttpServletRequest request, HttpServletResponse response) ログアウト処理を行います。

jp.co.intra_mart.foundation.security.access での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.access のメソッド
 void AccessControllerManager.addController(AccessController controller)
アクセスコントローラを追加します。
 void AccessControllerManager.addControllerDepartment(String controllerId, DepartmentInfo departmentInfo)
組織をアクセスコントローラに紐付けます。
 void AccessControllerManager.addControllerPost(String controllerId, PostInfo postInfo)
役職をアクセスコントローラに紐付けます。
 void AccessControllerManager.addControllerPublicGroup(String controllerId, PublicGroupInfo publicGroupInfo)
パブリックグループをアクセスコントローラに紐付けます。
 void AccessControllerManager.addControllerRole(String controllerId, String roleId)
ロールをアクセスコントローラに紐付けます。
 void AccessControllerManager.deleteController(String controllerId)
アクセスコントローラを削除します。
 void AccessControllerManager.deleteControllerDepartment(String controllerId, DepartmentInfo departmentInfo)
組織の紐付けをアクセスコントローラから削除します。
 void AccessControllerManager.deleteControllerDepartments(String controllerId)
組織の紐付けをアクセスコントローラからすべて削除します。
 void AccessControllerManager.deleteControllerPost(String controllerId, PostInfo postInfo)
役織の紐付けをアクセスコントローラから削除します。
 void AccessControllerManager.deleteControllerPosts(String controllerId)
役織の紐付けをアクセスコントローラからすべて削除します。
 void AccessControllerManager.deleteControllerPublicGroup(String controllerId, PublicGroupInfo publicGroupInfo)
パブリックグループの紐付けをアクセスコントローラから削除します。
 void AccessControllerManager.deleteControllerPublicGroups(String controllerId)
パブリックグループの紐付けをアクセスコントローラからすべて削除します。
 void AccessControllerManager.deleteControllerRole(String controllerId, String roleId)
ロールの紐付けをアクセスコントローラから削除します。
 void AccessControllerManager.deleteControllerRoles(String controllerId)
ロールの紐付けをアクセスコントローラから削除します。
 void AccessControllerManager.deleteControllers()
すべてのアクセスコントローラを削除します。
 void AccessControllerManager.exportData(String category, OutputStream outputStream)
アクセスコントローラ情報をエクスポートします。
 AccessController AccessControllerManager.getController(String controllerId)
指定されたアクセスコントローラIDに対応するアクセスコントローラを取得します。
 DepartmentInfo[] AccessControllerManager.getControllerDepartments(String controllerId)
アクセスコントローラに紐付いた組織の一覧を取得します。
 String[] AccessControllerManager.getControllerIds()
すべてのアクセスコントローラIDを取得します。
 String[] AccessControllerManager.getControllerIdsByDepartment(DepartmentInfo[] departments)
指定された組織を持つアクセスコントローラIDをすべて取得します。
 String[] AccessControllerManager.getControllerIdsByPost(PostInfo[] posts)
指定された役職を持つアクセスコントローラIDをすべて取得します。
 String[] AccessControllerManager.getControllerIdsByPublicGroup(PublicGroupInfo[] publicGroups)
指定されたパブリックグループを持つアクセスコントローラIDをすべて取得します。
 String[] AccessControllerManager.getControllerIdsByRole(String[] roleIds)
指定されたロールIDを持つアクセスコントローラIDをすべて取得します。
 String[] AccessControllerManager.getControllerIdsByUser(String userId, Date date)
指定されたユーザIDおよび日付で有効なアクセスコントローラIDをすべて取得します。
 PostInfo[] AccessControllerManager.getControllerPosts(String controllerId)
アクセスコントローラに紐付いた役職の一覧を取得します。
 PublicGroupInfo[] AccessControllerManager.getControllerPublicGroups(String controllerId)
アクセスコントローラに紐付いたパブリックグループの一覧を取得します。
 String[] AccessControllerManager.getControllerRoles(String controllerId)
アクセスコントローラに紐付いたロールの一覧を取得します。
 AccessController[] AccessControllerManager.getControllers()
すべてのアクセスコントローラを取得します。
 String[] AccessControllerManager.getExportCategories()
アクセスコントローラエクスポート用のカテゴリの一覧を取得します。
 String[] AccessControllerManager.getImportCategories()
アクセスコントローラインポート用のカテゴリの一覧を取得します。
 void AccessControllerManager.importData(String category, InputStream inputStream)
/** アクセスコントローラ情報をインポートします。
 void AccessControllerManager.updateController(AccessController controller)
アクセスコントローラを更新します。
 boolean AccessControllerManager.isUpdate(Date date)
アクセスコントローラが指定された日付よりも新しいかチェックします。

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.access のコンストラクタ
AccessControllerManager(String groupId)
コンストラクタ。

jp.co.intra_mart.foundation.security.account での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.account のメソッド
void | AccountManager.addAccount(Account account) アカウントを新規追加します。
void | AccountManager.addAccountRole(String userId, AccountRole accountRole) アカウントロールを新規追加します。
void | AccountManager.addFavoriteMenu(String userId, FavoriteMenu favoriteMenu) マイメニューを新規追加します。
boolean | AccountManager.contains(String userId) アカウントの存在チェックを行います。
int | AccountManager.count() アカウントの登録数を取得します。
void | AccountManager.deleteAccount(String userId) アカウントを削除します。
void | AccountManager.deleteAccountRole(String userId, String roleId) アカウントロールを削除します。
void | AccountManager.deleteAccountRoles(String userId) アカウントロールをすべて削除します。
void | AccountManager.deleteAccounts() アカウントをすべて削除します。
void | AccountManager.deleteFavoriteMenu(String userId, String menuId) マイメニューを削除します。
void | AccountManager.deleteFavoriteMenus(String userId) マイメニューをすべて削除します。
void | AccountManager.exportData(String category, OutputStream outputStream) アカウント情報をエクスポートします。
Account | AccountManager.getAccount(String userId) ユーザIDにマッチしたユーザデータを１件取得します。
String[] | AccountManager.getAccountRoleIds(String userId) アカウントロールIDをすべて取得します。
AccountRole[] | AccountManager.getAccountRoles(String userId) アカウントロールをすべて取得します。
AccountRole[] | AccountManager.getAccountRoles(String userId, Date date) 有効期間内のアカウントロールをすべて取得します。
Account[] | AccountManager.getAccounts() ログイングループ内のすべてのユーザアカウントを取得します。
Account[] | AccountManager.getAccountsByUserIds(String[] userIds) ログイングループ内で引数指定したユーザIDのユーザアカウントをすべて取得します。
String[] | AccountManager.getExportCategories() アカウントエクスポート用のカテゴリの一覧を取得します。
String[] | AccountManager.getFavoriteMenuIds(String userId) マイメニューIDをすべて取得します。
FavoriteMenu[] | AccountManager.getFavoriteMenus(String userId) マイメニューをすべて取得します。
String[] | AccountManager.getImportCategories() アカウントインポート用のカテゴリの一覧を取得します。
String[] | AccountManager.getRoleIds(String userId, Date date) アカウントに紐付く有効なロールIDをすべて取得します。
String[] | AccountManager.getUserIds() すべてのユーザIDを取得します。
String[] | AccountManager.getUserIdsByAccountRole(String roleId) 引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
String[] | AccountManager.getUserIdsByRole(String roleId, Date date) 有効なロールIDを持つすべてのユーザIDを取得します。
void | AccountManager.importData(String category, InputStream inputStream) アカウント情報をインポートします。
Account[] | AccountManager.searchAccounts(String userId) ユーザIDを検索してマッチしたアカウントを配列で返します。
void | AccountManager.updateAccount(Account account) アカウントを更新します。
void | AccountManager.updateAccountRole(String userId, AccountRole accountRole) アカウントロールを更新します。
void | AccountManager.updateFavoriteMenu(String userId, FavoriteMenu favoriteMenu) マイメニューを更新します。
String | AccountManager.getAttribute(String userId, String name) アカウント属性情報を取得する。
String | AccountManager.getAttribute(String userId, String name, String def) アカウント属性情報を取得する。
String[] | AccountManager.getAttributeNames(String userId) アカウント属性名の一覧を取得する。
void | AccountManager.setAttribute(String userId, String name, String value) アカウント属性情報を設定する。
void | AccountManager.deleteAttribute(String userId, String name) アカウント属性情報を削除する。
String[] | AccountManager.getUserIdsByAttribute(String key, String value) アカウント属性情報の値と一致するユーザIDを取得します。
boolean | AccountManager.isUpdate(Date date) アカウント情報が指定された日付よりも新しいかチェックします。
protected Account[] | StandardAccountBackup.getAllAccounts(String groupId)
protected Account[] | CsvAccountBackup.getAllAccounts(String groupId)

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.account のコンストラクタ
AccountManager(String groupId)
コンストラクタ。

jp.co.intra_mart.foundation.security.activesession での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.activesession のコンストラクタ
ActiveSessionInfo(HttpServletRequest request)
コンストラクタ。

jp.co.intra_mart.foundation.security.batch での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.batch のメソッド
void | BatchManager.addBatch(Batch batch) バッチ情報を新規登録します。
void | BatchManager.deleteBatch(String batchId) バッチ情報を削除します。
void | BatchManager.deleteBatches() すべてのバッチ情報を削除します。
void | BatchManager.exportData(String category, OutputStream outputStream) エクスポートを行います。
Batch | BatchManager.getBatch(String batchId) バッチ情報を取得します。
Batch[] | BatchManager.getBatches() すべてのバッチ情報を取得します。
Batch[] | BatchManager.getBatchesByIds(String[] batchIds) ログイングループ内で引数指定したバッチIDのバッチ情報をすべて取得します。
String[] | BatchManager.getBatchIds() バッチIDの一覧を取得します。
String[] | BatchManager.getExportCategories() バッチエクスポート用のカテゴリの一覧を取得します。
String[] | BatchManager.getImportCategories() バッチインポート用のカテゴリの一覧を取得します。
void | BatchManager.importData(String category, InputStream inputStream) インポートを行います。
void | BatchManager.updateBatch(Batch batch) バッチ情報を更新します。
boolean | BatchManager.isUpdate(Date date) バッチ情報が指定された日付よりも新しいかチェックします。

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.batch のコンストラクタ
BatchManager(String groupId)
コンストラクタ。

jp.co.intra_mart.foundation.security.calendar での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.calendar のメソッド
void | CalendarManager.addCalendarInfo(String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に追加します。
void | CalendarManager.deleteCalendar(String calendarId) カレンダーを削除します。
void | CalendarManager.deleteCalendarInfo(String calendarId, String dataId) カレンダーデータを削除します。
void | CalendarManager.deleteCalendarInfos(String calendarId) すべてのカレンダーデータを削除します。
void | CalendarManager.deleteCalendars() すべてのカレンダーを削除します。
void | CalendarManager.exportData(String category, OutputStream outputStream) エクスポートを行います。
String[] | CalendarManager.getCalendarIds() すべてのカレンダーIDを取得します。
CalendarInfo | CalendarManager.getCalendarInfo(String calendarId, String dataId) カレンダーデータを取得します。
String[] | CalendarManager.getCalendarInfoIds(String calendarId) すべてのカレンダーデータIDを取得します。
CalendarInfo[] | CalendarManager.getCalendarInfos(String calendarId) すべてのカレンダーデータを取得します。
CalendarInfo[] | CalendarManager.getCalendarInfosByIds(String calendarId, String[] calendarInfoIds) ログイングループ内で引数指定したカレンダーデータIDのカレンダーをすべて取得します。
CategorizedCalendarInfo | CalendarManager.getCategorizedCalendarInfos(String calendarId) すべてのカレンダーデータをデータタイプ別に分類して取得します。
DayInfo | CalendarManager.getDayInfo(CategorizedCalendarInfo categorizedCalendarInfo, Date date) 日付情報を取得します。
String[] | CalendarManager.getExportCategories() カレンダーエクスポート用のカテゴリの一覧を取得します。
String[] | CalendarManager.getImportCategories() カレンダーインポート用のカテゴリの一覧を取得します。
DayInfo[] | CalendarManager.getMonthInfos(CategorizedCalendarInfo categorizedCalendarInfo, int year, int month) 月情報を取得します。
CalendarPlugin | CalendarManager.getPlugin(String pluginId) カレンダーデータプラグインを取得します。
void | CalendarManager.importData(String category, InputStream inputStream) インポートを行います。
boolean | CalendarManager.isHoliday(String calendarId, CategorizedCalendarInfo categorizedCalendarInfo, Date date) 休日かどうか判定します。
boolean | CalendarManager.isNationalHoliday(CategorizedCalendarInfo categorizedCalendarInfo, Date date) 祝日かどうか判定します。
boolean | CalendarManager.isWeekday(String calendarId, CategorizedCalendarInfo categorizedCalendarInfo, Date date) 平日かどうか判定します。
void | CalendarManager.updateCalendarInfo(String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。
boolean | CalendarManager.isUpdate(String calendarId, Date date) カレンダーデータが指定された日付よりも新しいかチェックします。

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.calendar のコンストラクタ
CalendarManager(String groupId)
コンストラクタ。

jp.co.intra_mart.foundation.security.exception での AccessSecurityException の使用

jp.co.intra_mart.foundation.security.exception での AccessSecurityException のサブクラス
class | AccessSecurityCreateException アクセスセキュリティ情報作成例外クラス。
class | AccessSecurityDeleteException アクセスセキュリティ情報削除例外クラス。
class | AccessSecurityExportException エクスポート時例外クラス。
class | AccessSecurityImportException インポート時例外クラス。
class | AccessSecurityListenerExcpetion アクセスセキュリティリスナーの例外クラス。
class | AccessSecurityReadException アクセスセキュリティ情報の取得例外クラス。
class | AccessSecurityUpdateException アクセスセキュリティ情報更新例外クラス。
class | AccessSecurityWriteException アクセスセキュリティ情報の更新例外クラス。
class | ActiveSessionException アクティブなセッション情報例外の基本となる例外クラス。
class | ActiveSessionInvalidatedByForceException アクティブなセッションが強制的に無効化されたことに関する例外クラス
class | ActiveSessionNotExistException アクティブなセッションが存在しない例外クラス。
class | DuplicateException 作成時重複例外クラス。
class | DuplicateLoginDetectedException 重複ログイン検出例外クラス
class | DuplicateLoginException 重複ログイン制御例外の基本となる例外クラス。
class | IllegalArgumentException 引数が不正の例外クラス。
class | NoFilterException HTTPリクエスト・レスポンス取得例外クラス。
class | NoSessionCookieException セッション情報クッキー取得例外クラス。
class | NoSessionException セッション取得例外クラス。
class | NotExistException アクセスセキュリティ情報が存在しなかった場合の例外クラス。
class | NotFoundDataSourceException データソースの参照名未解決例外クラス。
class | NotSupportMethodException アクセスセキュリティのマネージャでサポートされないメソッドがコールされた場合の例外クラス。

jp.co.intra_mart.foundation.security.group での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.group のメソッド
void | LoginGroupManager.addLoginGroup(LoginGroup loginGroup) ログイングループを新規追加します。
void | LoginGroupManager.addMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを新規追加します。
void | LoginGroupManager.addSuperUser(String groupId, SuperUser superUser) グループ管理者を新規追加します。
int | LoginGroupManager.countLoginGroups() ログイングループ数を取得します。
void | LoginGroupManager.deleteMainPagePatterns(String groupId) メインページパターンをすべて削除します。
void | LoginGroupManager.deleteLoginGroup(String groupId) ログイングループを削除します。
void | LoginGroupManager.deleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを削除します。
void | LoginGroupManager.deleteSuperUser(String groupId) グループ管理者情報を削除します。
LoginGroup | LoginGroupManager.getLoginGroup(String groupId) ログイングループ情報を取得します。
String[] | LoginGroupManager.getLoginGroupIds() ログイングループIDの一覧を取得します。
LoginGroup[] | LoginGroupManager.getLoginGroups() ログイングループの一覧を取得します。
MainPagePatternInfo | LoginGroupManager.getMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを取得します。
String[] | LoginGroupManager.getMainPagePatternIds(String groupId) メインページパターンIDの一覧を取得します。
MainPagePatternInfo[] | LoginGroupManager.getMainPagePatterns(String groupId) メインページパターンの一覧を取得します。
SuperUser | LoginGroupManager.getSuperUser(String groupId) グループ管理者情報を取得します。
void | LoginGroupManager.updateLoginGroup(LoginGroup loginGroup) ログイングループ情報を更新します。
void | LoginGroupManager.updateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを更新します。
void | LoginGroupManager.updateSuperUser(String groupId, SuperUser superUser) グループ管理者情報を更新します。

jp.co.intra_mart.foundation.security.license での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.license のメソッド
static ApplicationInfo | LicenseManager.getApplication(String applicaionId) アプリケーション情報を取得します。
static double | LicenseManager.getApplicationLicense(String applicaionId) アプリケーションの登録ユーザ数を取得します。
static ApplicationInfo[] | LicenseManager.getApplications() アプリケーション情報の一覧を取得します。
static ApplicationInfo | LicenseManager.getProduct() システム情報を取得します。
static double | LicenseManager.getSystemLicense() システム全体の登録ライセンス数。
static double | LicenseManager.getSystemMaxLicense() システム全体のライセンス数。
void | LicenseManager.deleteAccountLicense(String userId) 指定されたユーザのライセンスを削除します。
void | LicenseManager.deleteApplicationLicenseFromAccount(String userId, String applicationId) アプリケーションライセンスをアカウントから削除します。
double | LicenseManager.getLicense() グループ内で登録されているライセンス数を取得します。
double | LicenseManager.getMaxLicense() ログイングループ内の最大登録可能ライセンス数を取得します。
String[] | LicenseManager.getRegisteredAccountLicenses() ログイングループにライセンス登録されているすべてのユーザIDを返します。
String[] | LicenseManager.getRegisteredApplicationLicensesToAccount(String userId) アカウントに登録されているアプリケーションライセンスの一覧を取得します。
boolean | LicenseManager.isRegisteredAccountLicense(String userId) 指定されたユーザがライセンスに登録されているかどうかをチェックします。
boolean | LicenseManager.isRegisteredApplicationLicenseToAccount(String userId, String applicationId) アカウントにアプリケーションライセンスが登録されてるか検証します。
boolean | LicenseManager.registerAccountLicense(String userId) ライセンス登録します。
boolean | LicenseManager.registerApplicationLicenseToAccount(String userId, String applicationId) アプリケーションライセンスをアカウントに登録します。
boolean | LicenseManager.setMaxLicense(double maxLicense) ログイングループ内の最大登録可能ライセンス数を設定します。

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.license のコンストラクタ
LicenseManager(String groupId)
コンストラクタ。

jp.co.intra_mart.foundation.security.menu での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuManager.addMenuDepartment(String menuId, DepartmentInfo departmentInfo) 組織をメニューに紐付けます。
void | MenuManager.addMenuItem(String parentMenuId, MenuItem menuItem) メニューを追加します。
void | MenuManager.addMenuPost(String menuId, PostInfo postInfo) 役職をメニューに紐付けます。
void | MenuManager.addMenuPublicGroup(String menuId, PublicGroupInfo publicGroupInfo) パブリックグループをメニューに紐付けます。
void | MenuManager.addMenuRole(String menuId, String roleId) ロールをメニューに紐付けます。
void | MenuManager.deleteMenuDepartment(String menuId, DepartmentInfo departmentInfo) 組織の紐付けをメニューから削除します。
void | MenuManager.deleteMenuDepartments(String menuId) 組織の紐付けをメニューからすべて削除します。
void | MenuManager.deleteMenuItem(String menuId) メニューを削除します。
void | MenuManager.deleteMenuItems() すべてのメニューを削除します。
void | MenuManager.deleteMenuPost(String menuId, PostInfo postInfo) 役織の紐付けをメニューから削除します。
void | MenuManager.deleteMenuPosts(String menuId) 役織の紐付けをメニューからすべて削除します。
void | MenuManager.deleteMenuPublicGroup(String menuId, PublicGroupInfo publicGroupInfo) パブリックグループの紐付けをメニューから削除します。
void | MenuManager.deleteMenuPublicGroups(String menuId) パブリックグループの紐付けをメニューからすべて削除します。
void | MenuManager.deleteMenuRole(String menuId, String roleId) ロールの紐付けをメニューから削除します。
void | MenuManager.deleteMenuRoles(String menuId) ロールの紐付けをメニューから削除します。
void | MenuManager.exportData(String category, OutputStream outputStream) メニュー情報をエクスポートします。
MenuTree[] | MenuManager.getAccountMenuTree(String userId, String clientType) 指定したアカウントのメニュー構成を取得します。
String[] | MenuManager.getChildMenuIds(String menuId) 子メニューIDを取得します。
String[] | MenuManager.getExportCategories() メニューエクスポート用のカテゴリの一覧を取得します。
String[] | MenuManager.getFirstMenuIds() 第一階層のメニューIDをすべて取得します。
String[] | MenuManager.getImportCategories() メニューインポート用のカテゴリの一覧を取得します。
DepartmentInfo[] | MenuManager.getMenuDepartments(String menuId) メニューに紐付いた組織の一覧を取得します。
String[] | MenuManager.getMenuIds() すべてのメニューIDを取得します。
String[] | MenuManager.getMenuIdsByDepartment(DepartmentInfo[] departments) 指定された組織を持つメニューIDをすべて取得します。
String[] | MenuManager.getMenuIdsByPost(PostInfo[] posts) 指定された役職を持つメニューIDをすべて取得します。
String[] | MenuManager.getMenuIdsByPublicGroup(PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つメニューIDをすべて取得します。
String[] | MenuManager.getMenuIdsByRole(String[] roleIds) 指定されたロールIDを持つメニューIDをすべて取得します。
MenuItem | MenuManager.getMenuItem(String menuId) 指定されたメニューIDに対応するメニューを取得します。
MenuItem[] | MenuManager.getMenuItems() すべてのメニューを取得します。
MenuItem[] | MenuManager.getMenuItemsByIds(String[] menuIds) ログイングループ内で引数指定したメニューIDのメニュー情報をすべて取得します。
PostInfo[] | MenuManager.getMenuPosts(String menuId) メニューに紐付いた役職の一覧を取得します。
PublicGroupInfo[] | MenuManager.getMenuPublicGroups(String menuId) メニューに紐付いたパブリックグループの一覧を取得します。
String[] | MenuManager.getMenuRoles(String menuId) メニューに紐付いたロールの一覧を取得します。
MenuTree[] | MenuManager.getMenuTree() メニュー構成を取得します。
MenuTree[] | MenuManager.getMenuTree(String clientType) 指定されたクライアントタイプのみのメニュー構成を取得します。
MenuTree[] | MenuManager.getMenuTree(String clientType, String[] menuIds, boolean showNoChildFolder) 指定されたクライアントタイプと指定されたメニューIDのみのメニュー構成を取得します。
String | MenuManager.getParentMenuId(String menuId) 指定されたメニューの親メニューを取得します。
void | MenuManager.importData(String category, InputStream inputStream) メニュー情報をインポートします。
void | MenuManager.moveMenuItem(MenuInclusion menuInclusion) メニューを移動します。
void | MenuManager.updateMenuItem(MenuItem menuItem) メニューを更新します。
boolean | MenuManager.isUpdate(Date date) メニュー情報が指定された日付よりも新しいかチェックします。
void | AdminMenuManager.addMenuItem(String parentMenuId, MenuItem menuItem) メニューを追加します。
void | AdminMenuManager.addMenuLoginGroup(String menuId, String groupId) 指定したログイングループのアクセス権をメニューに設定します。
void | AdminMenuManager.deleteMenuItem(String menuId) メニューを削除します。
void | AdminMenuManager.deleteMenuItems() すべてのメニューを削除します。
void | AdminMenuManager.deleteMenuLoginGroup(String menuId, String groupId) 指定したログイングループのアクセス権をメニューから削除します。
void | AdminMenuManager.exportData(String category, OutputStream outputStream) メニュー情報・エクスポート。
String[] | AdminMenuManager.getChildMenuIds(String menuId) 子メニューIDを取得します。
String[] | AdminMenuManager.getFirstMenuIds() 第一階層のメニューIDをすべて取得します。
String[] | AdminMenuManager.getMenuIds() すべてのメニューIDを取得します。
MenuItem | AdminMenuManager.getMenuItem(String menuId) 指定されたメニューIDに対応するメニューを取得します。
MenuItem[] | AdminMenuManager.getMenuItems() すべてのメニューを取得します。
MenuTree[] | AdminMenuManager.getMenuTree() メニュー構成を取得します。
MenuTree[] | AdminMenuManager.getMenuTree(String groupId) 引数に指定したログイングループのメニュー構成を取得します。
String[] | AdminMenuManager.getMenuLoginGroups(String menuId) 引数に指定したメニューを参照可能なログイングループIDの一覧を取得します。
String | AdminMenuManager.getParentMenuId(String menuId) 指定されたメニューの親メニューを取得します。
void | AdminMenuManager.importData(String category, InputStream inputStream) メニュー情報・インポート。
void | AdminMenuManager.moveMenuItem(MenuInclusion menuInclusion) メニューを移動します。
void | AdminMenuManager.updateMenuItem(MenuItem menuItem) メニューを更新します。
String[] | AdminMenuManager.getMenuIdsByLoginGroup(String groupId) 引き数に指定したログイングループが参照可能なメニューIDの一覧を取得します。
MenuItem[] | AdminMenuManager.getMenuItemsByIds(String[] menuIds) 引き数に指定したメニューIDに一致するメニューアイテムの一覧を取得します。
void | AdminMenuManager.setAccessControlEnabled(String menuId, boolean accessControl) メニューアイテムに対するアクセス権を設定します。
boolean | AdminMenuManager.isAccessControlEnabled(String menuId) メニューアイテムのアクセス権の有無を取得します。

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.menu のコンストラクタ
MenuManager(String groupId)
コンストラクタ。

jp.co.intra_mart.foundation.security.message での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.message のメソッド
String | MessageManager.getMessage(Locale locale, String key) メッセージを取得します。
String | MessageManager.getMessage(Locale locale, String key, String arg) メッセージを取得します。
String | MessageManager.getMessage(Locale locale, String key, String arg1, String arg2) メッセージを取得します。
String | MessageManager.getMessage(Locale locale, String key, String arg1, String arg2, String arg3) メッセージを取得します。
String | MessageManager.getMessage(Locale locale, String key, String[] args) メッセージを取得します。
String | MessageManager.getMessage(String key) メッセージを取得します。
String | MessageManager.getMessage(String key, String arg) メッセージを取得します。
String | MessageManager.getMessage(String key, String arg1, String arg2) メッセージを取得します。
String | MessageManager.getMessage(String key, String arg1, String arg2, String arg3) メッセージを取得します。
String | MessageManager.getMessage(String key, String[] args) メッセージを取得します。

jp.co.intra_mart.foundation.security.mobile での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.mobile のメソッド
static String | MobileEasyLoginUtil.getMobileEasyLoginURL(String groupId, String userId) かんたんログイン用のURLを取得します。
static String | MobileEasyLoginUtil.getMobileEasyLoginURL(HttpServletRequest request, String groupId, String userId) かんたんログイン用のURLを取得します。
static String | MobileEasyLoginUtil.getAccessKeyWithRequestParameter(String groupId, String userId) かんたんログイン用のアクセスキーをリクエストパラメータの形式で取得します。
static String | MobileEasyLoginUtil.getAccessKey(String groupId, String userId) かんたんログイン用のアクセスキーを取得します。
static void | MobileEasyLoginUtil.reGenerateNonce(String groupId, String userId) かんたんログイン用のNonceを新たに生成し、アカウント属性情報として保存します。

jp.co.intra_mart.foundation.security.permission での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.permission のメソッド
Collection | PermissionSelector.doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
PermissionSelector | PermissionManager.getPermissionSelector(String category) 指定されたカテゴリについて、設定XMLファイルで定義されているPermissionSelectorを返します。
Collection | PermissionManager.doSelection(String category, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
Collection | PermissionManager.doSelection(String category, String info) 選択用情報を利用して選別された情報のリストを返却します。
Collection | AdminMenuPermissionSelector.doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
Collection | MenuPermissionSelector.doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
Collection | AccountRolePermissionSelector.doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
Collection | AccessControllerPermissionSelector.doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.permission のコンストラクタ
PermissionManager(String groupId)
コンストラクタ。

jp.co.intra_mart.foundation.security.role での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.role のメソッド
void | RoleManager.addRole(Role role) ロール情報を新規登録します。
void | RoleManager.addSubRole(String roleId, String subRoleId) サブロールIDを追加します。
boolean | RoleManager.certify(String[] users, String[] roles) ロール内包を認証します。
boolean | RoleManager.contains(String roleId) ロールの存在チェックを行います。
boolean | RoleManager.containsCategory(String category) カテゴリーの存在チェックをします。
int | RoleManager.countByCategory(String category) カテゴリーに属するロール数を取得します。
void | RoleManager.deleteCategories() すべてのカテゴリーを削除します。
void | RoleManager.deleteCategory(String category) カテゴリーを削除します。
void | RoleManager.deleteRole(String roleId) ロールを削除します。
void | RoleManager.deleteRoles() すべてのロールを削除します。
void | RoleManager.deleteSubRole(String roleId, String subRoleId) 指定したサブロールIDを削除します。
void | RoleManager.deleteSubRoles(String roleId) 全てのサブロールIDを削除します。
void | RoleManager.exportData(String category, OutputStream outputStream) ロール情報・エクスポート。
String[] | RoleManager.getAllParentRoleIds(String roleId) 全ての親ロールIDを取得します。
String[] | RoleManager.getAllSubRoleIds(String roleId) 全てのサブロールサマリを取得します。
String[] | RoleManager.getExportCategories() ロールエクスポート用のカテゴリの一覧を取得します。
String[] | RoleManager.getImportCategories() ロールインポート用のカテゴリの一覧を取得します。
String[] | RoleManager.getParentRoleIds(String roleId) 親ロールIDを取得します。
Role | RoleManager.getRole(String roleId) ロール情報を取得します。
Role[] | RoleManager.getRolesByCategory(String category) カテゴリー検索によりロールを取得します。
Role[] | RoleManager.getRolesByIds(String[] roleIds) ログイングループ内で引数指定したロールIDのロール情報をすべて取得します。
String[] | RoleManager.getSubRole(String roleId) サブロール(一階層のみ)を取得します。
void | RoleManager.importData(String category, InputStream inputStream) ロール情報・インポート。
void | RoleManager.moveCategory(String oldCategory, String newCategory) カテゴリーを更新します。
Role[] | RoleManager.searchRolesById(String key) ロールID検索によりロールを取得します。
Role[] | RoleManager.searchRolesByName(String name) ロール名称検索によりロールを取得します。
void | RoleManager.updateRole(Role role) ロール情報を更新します。
boolean | RoleManager.isUpdate(Date date) ロール情報が指定された日付よりも新しいかチェックします。

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.role のコンストラクタ
RoleManager(String gid)
コンストラクタ。

jp.co.intra_mart.foundation.security.shortcut での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.shortcut のメソッド
String | ShortCutManager.createShortCut(ShortCutInfo shortCutInfo) ショートカットＩＤ作成。
void | ShortCutManager.deleteShortCut(String shortCutId) ショートカットＩＤ削除。
int | ShortCutManager.verifyShortCut(Date verifyDate) ショートカット検証。
ShortCutInfo | ShortCutManager.getShortCutInfo(String shortCutId) ショートカット情報取得。
String | ShortCutManager.getErrorPage() ショートカットエラーページ取得。
String | ShortCutManager.getMainPage() ショートカットメインページ取得。
Date | ShortCutManager.addValidEndDate(int countDays) SYSTEM日付に指定した日数を加えた日付を取得します。
String | ShortCutAccessor.createShortCut(String groupId, ShortCutInfo shortCutInfo) ショートカットIDを作成します。
void | ShortCutAccessor.deleteShortCut(String groupId, String shortCutId) ショートカットIDを削除します。
int | ShortCutAccessor.verifyShortCut(String groupId, Date verifyDate) ショートカットIDを検証します。
ShortCutInfo | ShortCutAccessor.getShortCutInfo(String groupId, String shortCutId) ショートカット情報を取得します。
Date | ShortCutAccessor.addValidEndDate(int countDays) SYSTEM日付に指定した日数を加えた日付を取得します。
String | StandardShortCutAccessor.createShortCut(String groupId, ShortCutInfo shortCutInfo) ショートカットIDを作成します。
void | StandardShortCutAccessor.deleteShortCut(String groupId, String shortCutId) ショートカットIDを削除します。
int | StandardShortCutAccessor.verifyShortCut(String groupId, Date verifyDate) ショートカットIDを検証します。
ShortCutInfo | StandardShortCutAccessor.getShortCutInfo(String groupId, String shortCutId) ショートカット情報を取得します。
Date | StandardShortCutAccessor.addValidEndDate(int countDays) SYSTEM日付に指定した日数を加えた日付を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException の使用

AccessSecurityExportException を使用しているパッケージ
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.access での AccessSecurityExportException の使用

AccessSecurityExportException をスローする jp.co.intra_mart.foundation.security.access のメソッド
void | AccessControllerExporter.doExport(AccessControllerManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardAccessControllerBackup.doExport(AccessControllerManager manager, OutputStream outputStream)

jp.co.intra_mart.foundation.security.account での AccessSecurityExportException の使用

AccessSecurityExportException をスローする jp.co.intra_mart.foundation.security.account のメソッド
void | AccountExporter.doExport(AccountManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardAccountBackup.doExport(AccountManager manager, OutputStream outputStream) エクスポートを行います。
void | CsvAccountBackup.doExport(AccountManager manager, OutputStream outputStream) エクスポートを行います。

jp.co.intra_mart.foundation.security.batch での AccessSecurityExportException の使用

AccessSecurityExportException をスローする jp.co.intra_mart.foundation.security.batch のメソッド
void | BatchExporter.doExport(BatchManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardBatchBackup.doExport(BatchManager manager, OutputStream outputStream) エクスポートを行います。

jp.co.intra_mart.foundation.security.calendar での AccessSecurityExportException の使用

AccessSecurityExportException をスローする jp.co.intra_mart.foundation.security.calendar のメソッド
void | CalendarExporter.doExport(CalendarManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardCalendarBackup.doExport(CalendarManager manager, OutputStream outputStream) エクスポートを行います。

jp.co.intra_mart.foundation.security.menu での AccessSecurityExportException の使用

AccessSecurityExportException をスローする jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuExporter.doExport(MenuManager manager, OutputStream outputStream) エクスポートを行います。
void | AdminMenuExporter.doExport(AdminMenuManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardMenuBackup.doExport(MenuManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardAdminMenuBackup.doExport(AdminMenuManager manager, OutputStream outputStream) エクスポートを行います。

jp.co.intra_mart.foundation.security.role での AccessSecurityExportException の使用

AccessSecurityExportException をスローする jp.co.intra_mart.foundation.security.role のメソッド
void | RoleExporter.doExport(RoleManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardRoleBackup.doExport(RoleManager manager, OutputStream outputStream) エクスポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException の使用

AccessSecurityImportException を使用しているパッケージ
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.access での AccessSecurityImportException の使用

AccessSecurityImportException をスローする jp.co.intra_mart.foundation.security.access のメソッド
void | AccessControllerImporter.doImport(InputStream inputStream, AccessControllerManager manager) インポートを行います。
void | StandardAccessControllerBackup.doImport(InputStream inputStream, AccessControllerManager manager)

jp.co.intra_mart.foundation.security.account での AccessSecurityImportException の使用

AccessSecurityImportException をスローする jp.co.intra_mart.foundation.security.account のメソッド
void | AccountImporter.doImport(InputStream inputStream, AccountManager manager) インポートを行います。
void | StandardAccountBackup.doImport(InputStream inputStream, AccountManager manager) インポートを行います。
void | CsvAccountBackup.doImport(InputStream inputStream, AccountManager manager) インポートを行います。

jp.co.intra_mart.foundation.security.batch での AccessSecurityImportException の使用

AccessSecurityImportException をスローする jp.co.intra_mart.foundation.security.batch のメソッド
void | BatchImporter.doImport(InputStream inputStream, BatchManager manager) インポートを行います。
void | StandardBatchBackup.doImport(InputStream inputStream, BatchManager manager) インポートを行います。

jp.co.intra_mart.foundation.security.calendar での AccessSecurityImportException の使用

AccessSecurityImportException をスローする jp.co.intra_mart.foundation.security.calendar のメソッド
void | CalendarImporter.doImport(InputStream inputStream, CalendarManager manager) インポートを行います。
void | StandardCalendarBackup.doImport(InputStream inputStream, CalendarManager manager) インポートを行います。

jp.co.intra_mart.foundation.security.menu での AccessSecurityImportException の使用

AccessSecurityImportException をスローする jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuImporter.doImport(InputStream inputStream, MenuManager manager) インポートを行います。
void | AdminMenuImporter.doImport(InputStream inputStream, AdminMenuManager manager) インポートを行います。
void | StandardMenuBackup.doImport(InputStream inputStream, MenuManager manager) インポートを行います。
void | StandardAdminMenuBackup.doImport(InputStream inputStream, AdminMenuManager manager) インポートを行います。

jp.co.intra_mart.foundation.security.role での AccessSecurityImportException の使用

AccessSecurityImportException をスローする jp.co.intra_mart.foundation.security.role のメソッド
void | RoleImporter.doImport(InputStream inputStream, RoleManager manager) インポートを行います。
void | StandardRoleBackup.doImport(InputStream inputStream, RoleManager manager) インポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion を使用しているパッケージ
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.mobile |
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.access での AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion をスローする jp.co.intra_mart.foundation.security.access のメソッド
void | AccessControllerQueryWriterListener.queryCreate(String groupId, AccessController controller) アクセスコントローラ情報をデータストアに作成する直前にコールされます。
void | AccessControllerQueryWriterListener.queryDelete(String groupId, String controllerId) アクセスコントローラ情報をデータストアから削除する直前にコールされます。
void | AccessControllerQueryWriterListener.queryUpdate(String groupId, AccessController controller) アクセスコントローラ情報をデータストアに更新する直前にコールされます。
void | AccessControllerPostWriterListener.postCreate(String groupId, AccessController controller) アクセスコントローラ情報をデータストアに作成した直後にコールされます。
void | AccessControllerPostWriterListener.postDelete(String groupId, String controllerId) アクセスコントローラ情報をデータストアから削除した直後にコールされます。
void | AccessControllerPostWriterListener.postUpdate(String groupId, AccessController controller) アクセスコントローラ情報をデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.account での AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion をスローする jp.co.intra_mart.foundation.security.account のメソッド
void | AccountQueryWriterListener.queryCreateAccount(String groupId, Account account) アカウント情報をデータストアに作成する直前にコールされます。
void | AccountQueryWriterListener.queryDeleteAccount(String groupId, String userId) アカウント情報をデータストアから削除する直前にコールされます。
void | AccountQueryWriterListener.queryUpdateAccount(String groupId, Account account) アカウント情報をデータストアに更新する直前にコールされます。
void | AccountQueryWriterListener.queryCreateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | AccountQueryWriterListener.queryDeleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報をデータストアから削除する直前にコールされます。
void | AccountQueryWriterListener.queryUpdateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新する直前にコールされます。
void | AccountQueryWriterListener.queryCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに作成する直前にコールされます。
void | AccountQueryWriterListener.queryDeleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報をデータストアから削除する直前にコールされます。
void | AccountQueryWriterListener.queryUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに更新する直前にコールされます。
void | AccountPostWriterListener.postCreateAccount(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | AccountPostWriterListener.postDeleteAccount(String groupId, String userId) アカウント情報をデータストアから削除した直後にコールされます。
void | AccountPostWriterListener.postUpdateAccount(String groupId, Account account) アカウント情報をデータストアに更新した直後にコールされます。
void | AccountPostWriterListener.postCreateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | AccountPostWriterListener.postDeleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報をデータストアから削除した直後にコールされます。
void | AccountPostWriterListener.postUpdateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新した直後にコールされます。
void | AccountPostWriterListener.postCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに作成した直後にコールされます。
void | AccountPostWriterListener.postDeleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報をデータストアから削除した直後にコールされます。
void | AccountPostWriterListener.postUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.admin での AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion をスローする jp.co.intra_mart.foundation.security.admin のメソッド
void | SuperUserQueryWriterListener.queryCreate(SuperUser superUser) システム管理者情報をデータストアに作成する直前にコールされます。
void | SuperUserQueryWriterListener.queryUpdate(SuperUser superUser) システム管理者情報をデータストアに更新する直前にコールされます。
void | SuperUserPostWriterListener.postCreate(SuperUser superUser) システム管理者情報をデータストアに作成した直後にコールされます。
void | SuperUserPostWriterListener.postUpdate(SuperUser superUser) システム管理者情報をデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.batch での AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion をスローする jp.co.intra_mart.foundation.security.batch のメソッド
void | BatchQueryWriterListener.queryCreate(String groupId, Batch batch) バッチ情報をデータストアに作成する直前にコールされます。
void | BatchQueryWriterListener.queryDelete(String groupId, String batchId) バッチ情報をデータストアから削除する直前にコールされます。
void | BatchQueryWriterListener.queryUpdate(String groupId, Batch batch) バッチ情報をデータストアに更新する直前にコールされます。
void | BatchPostWriterListener.postCreate(String groupId, Batch batch) バッチ情報をデータストアに作成した直後にコールされます。
void | BatchPostWriterListener.postDelete(String groupId, String batchId) バッチ情報をデータストアから削除した直後にコールされます。
void | BatchPostWriterListener.postUpdate(String groupId, Batch batch) バッチ情報をデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.calendar での AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion をスローする jp.co.intra_mart.foundation.security.calendar のメソッド
void | CalendarQueryWriterListener.queryCreateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに作成する直前にコールされます。
void | CalendarQueryWriterListener.queryDeleteCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータをデータストアから削除する直前にコールされます。
void | CalendarQueryWriterListener.queryUpdateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに更新する直前にコールされます。
void | CalendarPostWriterListener.postCreateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに作成した直後にコールされます。
void | CalendarPostWriterListener.postDeleteCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータをデータストアから削除した直後にコールされます。
void | CalendarPostWriterListener.postUpdateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.group での AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion をスローする jp.co.intra_mart.foundation.security.group のメソッド
void | MainPageImportLoginGroupPostWriterListener.postCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成した直後にコールされます。
void | MainPageImportLoginGroupPostWriterListener.postCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成した直後にコールされます。
void | MainPageImportLoginGroupPostWriterListener.postDeleteLoginGroup(String groupId) ログイングループ情報をデータストアから削除した直後にコールされます。
void | MainPageImportLoginGroupPostWriterListener.postDeleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターン情報をデータストアから削除した直後にコールされます。
void | MainPageImportLoginGroupPostWriterListener.postUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新した直後にコールされます。
void | MainPageImportLoginGroupPostWriterListener.postUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新した直後にコールされます。
void | LoginGroupQueryWriterListener.queryCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成する直前にコールされます。
void | LoginGroupQueryWriterListener.queryCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成する前にコールされます。
void | LoginGroupQueryWriterListener.queryDeleteLoginGroup(String groupId) ログイングループ情報をデータストアから削除する直前にコールされます。
void | LoginGroupQueryWriterListener.queryDeleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターン情報をデータストアから削除する前にコールされます。
void | LoginGroupQueryWriterListener.queryUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新する直前にコールされます。
void | LoginGroupQueryWriterListener.queryUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新する前にコールされます。
void | LoginGroupPostWriterListener.postCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成した直後にコールされます。
void | LoginGroupPostWriterListener.postCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成した直後にコールされます。
void | LoginGroupPostWriterListener.postDeleteLoginGroup(String groupId) ログイングループ情報をデータストアから削除した直後にコールされます。
void | LoginGroupPostWriterListener.postDeleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターン情報をデータストアから削除した直後にコールされます。
void | LoginGroupPostWriterListener.postUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新した直後にコールされます。
void | LoginGroupPostWriterListener.postUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.menu での AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion をスローする jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuQueryWriterListener.queryCreate(String groupId, MenuItem item) メニュー情報をデータストアに作成する直前にコールされます。
void | MenuQueryWriterListener.queryDelete(String groupId, String menuId) メニュー情報をデータストアから削除する直前にコールされます。
void | MenuQueryWriterListener.queryUpdate(String groupId, MenuItem item) メニュー情報をデータストアに更新する直前にコールされます。
void | MenuQueryWriterListener.queryMove(String groupId, String parentId, String childId) メニューの親子関係を更新する直前にコールされます。
void | MenuPostWriterListener.postCreate(String groupId, MenuItem item) メニュー情報をデータストアに作成した直後にコールされます。
void | MenuPostWriterListener.postDelete(String groupId, String menuId) メニュー情報をデータストアから削除した直後にコールされます。
void | MenuPostWriterListener.postUpdate(String groupId, MenuItem item) メニュー情報をデータストアに更新した直後にコールされます。
void | MenuPostWriterListener.postMove(String groupId, String parentId, String childId) メニューの親子関係を更新した直後にコールされます。
void | AdminMenuQueryWriterListener.queryCreate(MenuItem item) メニュー情報をデータストアに作成する直前にコールされます。
void | AdminMenuQueryWriterListener.queryDelete(String menuId) メニュー情報をデータストアから削除する直前にコールされます。
void | AdminMenuQueryWriterListener.queryUpdate(MenuItem item) メニュー情報をデータストアに更新する直前にコールされます。
void | AdminMenuQueryWriterListener.queryMove(String parentId, String childId) メニューの親子関係を更新する直前にコールされます。
void | AdminMenuQueryWriterListener.querySetAccessControlEnabled(String menuId, boolean accessControl) アクセス権限を設定する直前にコールされます。
void | AdminMenuQueryWriterListener.queryAddMenuLoginGroup(String menuId, String groupId) アクセスを許可するログイングループを追加する直前にコールされます。
void | AdminMenuQueryWriterListener.queryDeleteMenuLoginGroup(String menuId, String groupId) アクセスを許可するログイングループを削除する直前にコールされます。
void | AdminMenuPostWriterListener.postCreate(MenuItem item) メニュー情報をデータストアに作成した直後にコールされます。
void | AdminMenuPostWriterListener.postDelete(String menuId) メニュー情報をデータストアから削除した直後にコールされます。
void | AdminMenuPostWriterListener.postUpdate(MenuItem item) メニュー情報をデータストアに更新した直後にコールされます。
void | AdminMenuPostWriterListener.postMove(String parentId, String childId) メニューの親子関係を更新した直後にコールされます。
void | AdminMenuPostWriterListener.postSetAccessControlEnabled(String menuId, boolean accessControl) アクセス権限を設定する直前にコールされます。
void | AdminMenuPostWriterListener.postAddMenuLoginGroup(String menuId, String groupId) アクセスを許可するログイングループを追加する直後にコールされます。
void | AdminMenuPostWriterListener.postDeleteMenuLoginGroup(String menuId, String groupId) アクセスを許可するログイングループを削除する直後にコールされます。

jp.co.intra_mart.foundation.security.mobile での AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion をスローする jp.co.intra_mart.foundation.security.mobile のメソッド
void | NonceResetListener4MobileEasyLogin.queryUpdateAccount(String groupId, Account account)
void | NonceResetListener4MobileEasyLogin.postUpdateAccount(String groupId, Account account)
void | NonceResetListener4MobileEasyLogin.queryCreateAccount(String groupId, Account account)
void | NonceResetListener4MobileEasyLogin.queryCreateAccountRole(String groupId, String userId, AccountRole accountRole)
void | NonceResetListener4MobileEasyLogin.queryCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu)
void | NonceResetListener4MobileEasyLogin.queryDeleteAccount(String groupId, String userId)
void | NonceResetListener4MobileEasyLogin.queryDeleteAccountRole(String groupId, String userId, String roleId)
void | NonceResetListener4MobileEasyLogin.queryDeleteFavoriteMenu(String groupId, String userId, String menuId)
void | NonceResetListener4MobileEasyLogin.queryUpdateAccountRole(String groupId, String userId, AccountRole accountRole)
void | NonceResetListener4MobileEasyLogin.queryUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu)
void | NonceResetListener4MobileEasyLogin.postCreateAccount(String groupId, Account account)
void | NonceResetListener4MobileEasyLogin.postCreateAccountRole(String groupId, String userId, AccountRole accountRole)
void | NonceResetListener4MobileEasyLogin.postCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu)
void | NonceResetListener4MobileEasyLogin.postDeleteAccount(String groupId, String userId)
void | NonceResetListener4MobileEasyLogin.postDeleteAccountRole(String groupId, String userId, String roleId)
void | NonceResetListener4MobileEasyLogin.postDeleteFavoriteMenu(String groupId, String userId, String menuId)
void | NonceResetListener4MobileEasyLogin.postUpdateAccountRole(String groupId, String userId, AccountRole accountRole)
void | NonceResetListener4MobileEasyLogin.postUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu)

jp.co.intra_mart.foundation.security.role での AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion をスローする jp.co.intra_mart.foundation.security.role のメソッド
void | RoleQueryWriterListener.queryCreateRole(String groupId, Role role) ロール情報をデータストアに作成する直前にコールされます。
void | RoleQueryWriterListener.queryDeleteRole(String groupId, String roleId) ロール情報をデータストアから削除する直前にコールされます。
void | RoleQueryWriterListener.queryUpdateRole(String groupId, Role role) ロール情報をデータストアに更新する直前にコールされます。
void | RoleQueryWriterListener.postCreateSubRole(String groupId, String roleId, String subRoleId) ロールにサブロールを追加する直前にコールされます。
void | RoleQueryWriterListener.postDeleteSubRole(String groupId, String roleId, String subRoleId) ロールからサブロールを削除する直前にコールされます。
void | RolePostWriterListener.postCreateRole(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RolePostWriterListener.postDeleteRole(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | RolePostWriterListener.postUpdateRole(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | RolePostWriterListener.postCreateSubRole(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | RolePostWriterListener.postDeleteSubRole(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException の使用

AccessSecurityReadException を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での AccessSecurityReadException の使用

AccessSecurityReadException をスローする jp.co.intra_mart.foundation.security のメソッド
String[] | StandardRoleAccessor.getAllParentRoleIds(String groupId, String roleId) すべての親ロールの一覧を取得します。
String[] | StandardRoleAccessor.getAllSubRoleIds(String groupId, String roleId) すべてのサブロールの一覧を取得します。
String[] | StandardRoleAccessor.getCategories(String groupId) カテゴリの一覧を取得します。
String[] | StandardRoleAccessor.getParentRoleIds(String groupId, String roleId) 親ロールの一覧を取得します。
Role[] | StandardRoleAccessor.getRoleData(String groupId) ロール情報を全件取得します。
Role | StandardRoleAccessor.getRoleData(String groupId, String roleId) ロール情報を取得します。
Role[] | StandardRoleAccessor.getRoleDataByCategory(String groupId, String category) カテゴリからロール情報を取得します。
Role[] | StandardRoleAccessor.getRolesByIds(String groupId, String[] roleIds) 指定されたロールIDのロール情報をすべて取得します。
String[] | StandardRoleAccessor.getSubRoleIds(String groupId, String roleId) サブロールIDサマリを取得します。
String[] | StandardMenuAccessor.getChildMenuIds(String groupId, String menuId) 引数で指定されたノードの直下の子メニューIDを配列で取得します。
String[] | StandardMenuAccessor.getFirstMenuIds(String groupId) 第一階層に属するメニューIDを配列で取得します。
DepartmentInfo[] | StandardMenuAccessor.getMenuDepartments(String groupId, String id) すべてのメニュー組織を取得します。
String[] | StandardMenuAccessor.getMenuIds(String groupId) すべてのメニューIDを取得します。
String[] | StandardMenuAccessor.getMenuIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つメニューIDをすべて取得します。
String[] | StandardMenuAccessor.getMenuIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つメニューIDをすべて取得します。
String[] | StandardMenuAccessor.getMenuIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つメニューIDをすべて取得します。
String[] | StandardMenuAccessor.getMenuIdsByRole(String groupId, String[] roleIds) 指定されたロールIDを持つメニューIDをすべて取得します。
MenuInclusion[] | StandardMenuAccessor.getMenuInclusions(String groupId) すべてのメニュー構成を取得します。
MenuItem | StandardMenuAccessor.getMenuItem(String groupId, String menuId) 指定されたメニューIDに対するノードを取得します。
MenuItem[] | StandardMenuAccessor.getMenuItems(String groupId) すべてのノードを取得します。
MenuItem[] | StandardMenuAccessor.getMenuItemsByIds(String groupId, String[] menuIds) 指定されたメニューIDのメニュー情報をすべて取得します。
PostInfo[] | StandardMenuAccessor.getMenuPosts(String groupId, String id) すべてのメニュー役職を取得します。
PublicGroupInfo[] | StandardMenuAccessor.getMenuPublicGroups(String groupId, String id) すべてのメニューパブリックグループを取得します。
String[] | StandardMenuAccessor.getMenuRoles(String groupId, String menuId) すべてのメニューロールを取得します。
String | StandardMenuAccessor.getParentMenuId(String groupId, String menuId) 引数で指定されたノードの親ノードを取得します。
String[] | StandardCalendarAccessor.getCalendarIds(String groupId) すべてのカレンダーIDを取得します。
CalendarInfo | StandardCalendarAccessor.getCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータを取得します。
String[] | StandardCalendarAccessor.getCalendarInfoIds(String groupId, String calendarId) すべてのカレンダーデータIDを取得します。
CalendarInfo[] | StandardCalendarAccessor.getCalendarInfos(String groupId, String calendarId) すべてのカレンダーデータを取得します。
CalendarInfo[] | StandardCalendarAccessor.getCalendarInfosByIds(String groupId, String calendarId, String[] calendarInfoIds) 指定されたカレンダーデータIDのカレンダー情報をすべて取得する。
Batch | StandardBatchAccessor.getBatch(String groupId, String batchId) バッチを取得します。
Batch[] | StandardBatchAccessor.getBatches(String groupId) バッチの一覧を取得します。
Batch[] | StandardBatchAccessor.getBatchesByIds(String groupId, String[] batchIds) 引数に指定したバッチIDのバッチ情報をすべて取得します。
String[] | StandardBatchAccessor.getBatchIds(String groupId) バッチIDの一覧を取得します。
protected String[] | StandardAccountAccessor.getUserIdsByRolesIn(String groupId, String[] roleIds, Date date) 指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
protected String[] | StandardAccountAccessor.getUserIdsByRolesPlural(String groupId, String[] roleIds, Date date) 指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
Account | StandardAccountAccessor.getAccount(String groupId, String userId) アカウント情報を取得する。
int | StandardAccountAccessor.getAccountCount(String groupId) アカウント数を取得する。
AccountRole | StandardAccountAccessor.getAccountRole(String groupId, String userId, String roleId) アカウントロール情報を取得する。
String[] | StandardAccountAccessor.getAccountRoleIds(String groupId, String userId) アカウントロールIDをすべて取得する。
AccountRole[] | StandardAccountAccessor.getAccountRoles(String groupId, String userId) アカウントロール情報をすべて取得する。
Account[] | StandardAccountAccessor.getAccountsByUserIds(String groupId, String[] userIds) 指定されたユーザIDのアカウント情報をすべて取得する。
FavoriteMenu | StandardAccountAccessor.getFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を取得する。
String[] | StandardAccountAccessor.getFavoriteMenuIds(String groupId, String userId) マイメニューIDをすべて取得する。
FavoriteMenu[] | StandardAccountAccessor.getFavoriteMenus(String groupId, String userId) マイメニュー情報をすべて取得する。
String[] | StandardAccountAccessor.getUserIds(String groupId) ユーザIDの一覧を取得する。
String[] | StandardAccountAccessor.getUserIdsByAccountRole(String groupId, String roleId) 引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
String[] | StandardAccountAccessor.getUserIdsByRoles(String groupId, String[] roleIds, Date date) 指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
Account[] | StandardAccountAccessor.searchAccounts(String groupId, String userId) アカウント情報の読み込みます。
String | StandardAccountAccessor.getAttribute(String groupId, String userId, String name) アカウント属性情報を取得する。
String[] | StandardAccountAccessor.getAttributeNames(String groupId, String userId) アカウント属性名の一覧を取得する。
String[] | StandardAccountAccessor.getUserIdsByAttribute(String groupId, String key, String value) アカウント属性情報の値と一致するユーザIDを取得する。
AccessController | StandardAccessControllerAccessor.getController(String groupId, String controllerId) アクセスコントローラ情報を取得します。
AccessController[] | StandardAccessControllerAccessor.getControllers(String groupId) すべてのアクセスコントローラ情報を取得します。
DepartmentInfo[] | StandardAccessControllerAccessor.getControllerDepartments(String groupId, String id) すべてのアクセスコントローラ組織を取得します。
String[] | StandardAccessControllerAccessor.getControllerIds(String groupId) すべてのアクセスコントローラIDを取得します。
String[] | StandardAccessControllerAccessor.getControllerIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つコントローラIDをすべて取得します。
String[] | StandardAccessControllerAccessor.getControllerIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つコントローラIDをすべて取得します。
String[] | StandardAccessControllerAccessor.getControllerIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つコントローラIDをすべて取得します。
String[] | StandardAccessControllerAccessor.getControllerIdsByRole(String groupId, String[] roleIds) 指定されたロールIDを持つコントローラIDをすべて取得します。
PostInfo[] | StandardAccessControllerAccessor.getControllerPosts(String groupId, String id) すべてのアクセスコントローラ役職を取得します。
PublicGroupInfo[] | StandardAccessControllerAccessor.getControllerPublicGroups(String groupId, String id) すべてのアクセスコントローラパブリックグループを取得します。
String[] | StandardAccessControllerAccessor.getControllerRoles(String groupId, String id) すべてのアクセスコントローラロールを取得します。

jp.co.intra_mart.foundation.security.access での AccessSecurityReadException の使用

AccessSecurityReadException をスローする jp.co.intra_mart.foundation.security.access のメソッド
AccessController | AccessControllerAccessor.getController(String groupId, String controllerId) アクセスコントローラ情報を取得します。
AccessController[] | AccessControllerAccessor.getControllers(String groupId) すべてのアクセスコントローラ情報を取得します。
DepartmentInfo[] | AccessControllerAccessor.getControllerDepartments(String groupId, String id) すべてのアクセスコントローラ組織を取得します。
String[] | AccessControllerAccessor.getControllerIds(String groupId) すべてのアクセスコントローラIDを取得します。
String[] | AccessControllerAccessor.getControllerIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つコントローラIDをすべて取得します。
String[] | AccessControllerAccessor.getControllerIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つコントローラIDをすべて取得します。
String[] | AccessControllerAccessor.getControllerIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つコントローラIDをすべて取得します。
String[] | AccessControllerAccessor.getControllerIdsByRole(String groupId, String[] roleIds) 指定されたロールIDを持つコントローラIDをすべて取得します。
PostInfo[] | AccessControllerAccessor.getControllerPosts(String groupId, String id) すべてのアクセスコントローラ役職を取得します。
PublicGroupInfo[] | AccessControllerAccessor.getControllerPublicGroups(String groupId, String id) すべてのアクセスコントローラパブリックグループを取得します。
String[] | AccessControllerAccessor.getControllerRoles(String groupId, String id) すべてのアクセスコントローラロールを取得します。

jp.co.intra_mart.foundation.security.account での AccessSecurityReadException の使用

AccessSecurityReadException をスローする jp.co.intra_mart.foundation.security.account のメソッド
Account | AccountAccessor.getAccount(String groupId, String userId) アカウント情報を取得する。
Account[] | AccountAccessor.getAccountsByUserIds(String groupId, String[] userIds) 指定されたユーザIDのアカウント情報をすべて取得する。
int | AccountAccessor.getAccountCount(String groupId) アカウント数を取得する。
AccountRole | AccountAccessor.getAccountRole(String groupId, String userId, String roleId) アカウントロール情報を取得する。
String[] | AccountAccessor.getAccountRoleIds(String groupId, String userId) アカウントロールIDをすべて取得する。
AccountRole[] | AccountAccessor.getAccountRoles(String groupId, String userId) アカウントロール情報をすべて取得する。
FavoriteMenu | AccountAccessor.getFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を取得する。
String[] | AccountAccessor.getFavoriteMenuIds(String groupId, String userId) マイメニューIDをすべて取得する。
FavoriteMenu[] | AccountAccessor.getFavoriteMenus(String groupId, String userId) マイメニュー情報をすべて取得する。
String[] | AccountAccessor.getUserIds(String groupId) ユーザIDの一覧を取得する。
String[] | AccountAccessor.getUserIdsByRoles(String groupId, String[] roleIds, Date date) 指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
Account[] | AccountAccessor.searchAccounts(String groupId, String userId) アカウント情報の読み込みます。
String[] | AccountAccessor.getUserIdsByAccountRole(String groupId, String roleId) 引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
String | AccountAccessor.getAttribute(String groupId, String userId, String name) アカウント属性情報を取得する。
String[] | AccountAccessor.getAttributeNames(String groupId, String userId) アカウント属性情報の名前の一覧を取得する。
String[] | AccountAccessor.getUserIdsByAttribute(String groupId, String key, String value) アカウント属性情報の値と一致するユーザIDを取得する。

jp.co.intra_mart.foundation.security.admin での AccessSecurityReadException の使用

AccessSecurityReadException をスローする jp.co.intra_mart.foundation.security.admin のメソッド
 SuperUser SuperUserAccessor.getSuperUser()
システム管理者情報を取得します。

jp.co.intra_mart.foundation.security.batch での AccessSecurityReadException の使用

AccessSecurityReadException をスローする jp.co.intra_mart.foundation.security.batch のメソッド
Batch | BatchAccessor.getBatch(String groupId, String batchId) バッチ情報を取得します。
Batch[] | BatchAccessor.getBatches(String groupId) すべてのバッチ情報を取得します。
Batch[] | BatchAccessor.getBatchesByIds(String groupId, String[] batchIds) 引数に指定したバッチIDのバッチ情報をすべて取得します。
String[] | BatchAccessor.getBatchIds(String groupId) すべてのバッチIDを取得します。

jp.co.intra_mart.foundation.security.calendar での AccessSecurityReadException の使用

AccessSecurityReadException をスローする jp.co.intra_mart.foundation.security.calendar のメソッド
String[] | CalendarAccessor.getCalendarIds(String groupId) すべてのカレンダーIDを取得します。
CalendarInfo | CalendarAccessor.getCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータを取得します。
String[] | CalendarAccessor.getCalendarInfoIds(String groupId, String calendarId) すべてのカレンダーデータIDを取得します。
CalendarInfo[] | CalendarAccessor.getCalendarInfos(String groupId, String calendarId) すべてのカレンダーデータを取得します。
CalendarInfo[] | CalendarAccessor.getCalendarInfosByIds(String groupId, String calendarId, String[] calendarInfoIds) 指定されたカレンダIDのカレンダ情報をすべて取得する。

jp.co.intra_mart.foundation.security.group での AccessSecurityReadException の使用

AccessSecurityReadException をスローする jp.co.intra_mart.foundation.security.group のメソッド
LoginGroup | LoginGroupAccessor.getLoginGroup(String groupId) ログイングループ情報を取得します。
String[] | LoginGroupAccessor.getLoginGroupIds() ログイングループIDの一覧を取得します。
MainPagePatternInfo | LoginGroupAccessor.getMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを取得します。
String[] | LoginGroupAccessor.getMainPagePatternIds(String groupId) メインページパターンIDの一覧を取得します。
SuperUser | GroupSuperUserAccessor.getSuperUser(String groupId) グループ管理者情報を取得します。

jp.co.intra_mart.foundation.security.menu での AccessSecurityReadException の使用

AccessSecurityReadException をスローする jp.co.intra_mart.foundation.security.menu のメソッド
String[] | MenuAccessor.getChildMenuIds(String groupId, String menuId) 引数で指定されたノードの直下の子ノードを配列で取得します。
String[] | MenuAccessor.getFirstMenuIds(String groupId) 第一階層に属するノードを配列で取得します。
DepartmentInfo[] | MenuAccessor.getMenuDepartments(String groupId, String id) すべてのメニュー組織を取得します。
String[] | MenuAccessor.getMenuIds(String groupId) すべてのメニューIDを取得します。
String[] | MenuAccessor.getMenuIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つメニューIDをすべて取得します。
String[] | MenuAccessor.getMenuIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つメニューIDをすべて取得します。
String[] | MenuAccessor.getMenuIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つメニューIDをすべて取得します。
String[] | MenuAccessor.getMenuIdsByRole(String groupId, String[] roleIds) 指定されたロールIDを持つメニューIDをすべて取得します。
MenuInclusion[] | MenuAccessor.getMenuInclusions(String groupId) すべてのメニュー構成を取得します。
MenuItem | MenuAccessor.getMenuItem(String groupId, String menuId) 指定されたメニューIDに対するノードを取得します。
MenuItem[] | MenuAccessor.getMenuItems(String groupId) すべてのノードを取得します。
MenuItem[] | MenuAccessor.getMenuItemsByIds(String groupId, String[] menuIds) 指定されたユーザIDのメニュー情報をすべて取得します。
PostInfo[] | MenuAccessor.getMenuPosts(String groupId, String id) すべてのメニュー役職を取得します。
PublicGroupInfo[] | MenuAccessor.getMenuPublicGroups(String groupId, String id) すべてのメニューパブリックグループを取得します。
String[] | MenuAccessor.getMenuRoles(String groupId, String id) すべてのメニューロールを取得します。
String | MenuAccessor.getParentMenuId(String groupId, String menuId) 引数で指定されたノードの親ノードを取得します。
String[] | AdminMenuAccessor.getChildMenuIds(String menuId) 引数で指定されたノードの直下の子ノードを配列で取得します。
String[] | AdminMenuAccessor.getFirstMenuIds() 第一階層に属するノードを配列で取得します。
String[] | AdminMenuAccessor.getMenuIds() すべてのメニューIDを取得します。
MenuInclusion[] | AdminMenuAccessor.getMenuInclusions() すべてのメニュー構成を取得します。
MenuItem | AdminMenuAccessor.getMenuItem(String menuId) 指定されたメニューIDに対するノードを取得します。
MenuItem[] | AdminMenuAccessor.getMenuItems() すべてのノードを取得します。
String | AdminMenuAccessor.getParentMenuId(String menuId) 引数で指定されたノードの親ノードを取得します。
String[] | AdminMenuAccessor.getMenuIdsByLoginGroup(String groupId) ログイングループがアクセス可能な管理メニューIDの一覧を取得します。
MenuItem[] | AdminMenuAccessor.getMenuItemsByIds(String[] menuIds) 管理メニューIDの一覧からメニューアイテムを取得します。
String[] | AdminMenuAccessor.getMenuLoginGroups(String menuId) 管理メニューにアクセス可能なログイングループの一覧を取得します。
boolean | AdminMenuAccessor.isAccessControlEnabled(String menuId) メニューアイテムのアクセス権の有無を取得します。

jp.co.intra_mart.foundation.security.role での AccessSecurityReadException の使用

AccessSecurityReadException をスローする jp.co.intra_mart.foundation.security.role のメソッド
int | RoleManager.count() ロール数を取得します。
String[] | RoleManager.getCategories() カテゴリーの一覧を取得します。
String[] | RoleManager.getRoleIds() すべてのロールIDを取得します。
Role[] | RoleManager.getRoles() すべてのロール情報を取得します。
String[] | RoleAccessor.getAllParentRoleIds(String groupId, String roleId) すべての親ロールの一覧を取得する。
String[] | RoleAccessor.getAllSubRoleIds(String groupId, String roleId) すべてのサブロールの一覧を取得する。
String[] | RoleAccessor.getCategories(String groupId) カテゴリの一覧を取得する。
String[] | RoleAccessor.getParentRoleIds(String groupId, String roleId) 親ロールの一覧を取得する。
Role[] | RoleAccessor.getRoleData(String groupId) ロール情報を全件取得する。
Role | RoleAccessor.getRoleData(String groupId, String roleId) ロール情報を取得する。
Role[] | RoleAccessor.getRoleDataByCategory(String groupId, String category) カテゴリからロール情報を取得する。
Role[] | RoleAccessor.getRolesByIds(String groupId, String[] roleIds) 指定されたロールIDのロール情報をすべて取得する。
String[] | RoleAccessor.getSubRoleIds(String groupId, String roleId) サブロールIDサマリを取得する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException の使用

AccessSecurityRuntimeException を使用しているパッケージ
jp.co.intra_mart.foundation.security.exception アクセスセキュリティ例外に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.exception での AccessSecurityRuntimeException の使用

jp.co.intra_mart.foundation.security.exception での AccessSecurityRuntimeException のサブクラス
class | AccessSecurityConfigException アクセスセキュリティ設定に関する例外クラス。
class | SystemConfigException システム設定に関する例外クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException の使用

jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException の使用

AccessSecurityWriteException を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での AccessSecurityWriteException の使用

AccessSecurityWriteException をスローする jp.co.intra_mart.foundation.security のメソッド
void | StandardRoleAccessor.createRole(String groupId, Role role) ロール情報を新規追加します。
void | StandardRoleAccessor.deleteCategory(String groupId) すべてのカテゴリを削除します。
void | StandardRoleAccessor.deleteCategory(String groupId, String category) カテゴリを削除します。
void | StandardRoleAccessor.deleteRole(String groupId) すべてのロール情報を削除します。
void | StandardRoleAccessor.deleteRole(String groupId, String roleId) ロール情報を削除します。
void | StandardRoleAccessor.deleteSubRole(String groupId, String roleId) サブロールIDを削除します。
void | StandardRoleAccessor.deleteSubRole(String groupId, String roleId, String subRoleId) 指定したサブロールIDを削除します。
void | StandardRoleAccessor.insertSubRole(String groupId, String roleId, String subRoleId) サブロールを作成します。
void | StandardRoleAccessor.updateCategory(String groupId, String oldCategory, String newCategory) カテゴリを更新します。
void | StandardRoleAccessor.updateRole(String groupId, Role role) ロール情報を更新します。
void | StandardMenuAccessor.deleteMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を削除します。
void | StandardMenuAccessor.deleteMenuDepartments(String groupId, String id) すべてのメニュー組織を削除します。
void | StandardMenuAccessor.deleteMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を削除します。
void | StandardMenuAccessor.deleteMenuItem(String groupId, String id) 引数で渡されたノードを削除します。
void | StandardMenuAccessor.deleteMenuPost(String groupId, String id, PostInfo postInfo) メニュー役職を削除します。
void | StandardMenuAccessor.deleteMenuPosts(String groupId, String id) すべてのメニュー役職を削除します。
void | StandardMenuAccessor.deleteMenuPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) メニューパブリックグループを削除します。
void | StandardMenuAccessor.deleteMenuPublicGroups(String groupId, String id) すべてのメニューパブリックグループを削除します。
void | StandardMenuAccessor.deleteMenuRole(String groupId, String id, String roleId) メニューロールを削除します。
void | StandardMenuAccessor.deleteMenuRoles(String groupId, String menuId) すべてのメニューロールを削除します。
void | StandardMenuAccessor.insertMenuDepartment(String groupId, String menuId, DepartmentInfo departmentInfo) メニュー組織を新規に作成します。
void | StandardMenuAccessor.insertMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を新規に作成します。
void | StandardMenuAccessor.insertMenuItem(String groupId, MenuItem menuItem, String parentId) 引数で渡されたノードを新規追加します。
void | StandardMenuAccessor.insertMenuPost(String groupId, String menuId, PostInfo postInfo) メニュー役職を新規に作成します。
void | StandardMenuAccessor.insertMenuPublicGroup(String groupId, String menuId, PublicGroupInfo publicGroupInfo) メニューパブリックグループを新規に作成します。
void | StandardMenuAccessor.insertMenuRole(String groupId, String menuId, String roleId) メニューロールを新規に作成します。
void | StandardMenuAccessor.updateMenuItem(String groupId, MenuItem menuItem) 引数で渡されたノードを更新します。
void | StandardCalendarAccessor.deleteCalendar(String groupId, String calendarId) カレンダーを削除します。
void | StandardCalendarAccessor.deleteCalendarInfo(String groupId, String calendarId, String dataId) 指定されたカレンダーデータを削除します。
void | StandardCalendarAccessor.insertCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に作成します。
void | StandardCalendarAccessor.updateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。
void | StandardBatchAccessor.deleteBatch(String groupId, String batchId) バッチを削除します。
void | StandardBatchAccessor.insertBatch(String groupId, Batch batch) バッチを登録します。
void | StandardBatchAccessor.updateBatch(String groupId, Batch batch) バッチを更新します。
void | StandardAccountAccessor.deleteAccount(String groupId, String userId) アカウント情報を削除する。
void | StandardAccountAccessor.deleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報を削除する。
void | StandardAccountAccessor.deleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を削除する。
void | StandardAccountAccessor.insertAccount(String groupId, Account account) アカウント情報を新規追加する。
void | StandardAccountAccessor.insertAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を新規追加する。
void | StandardAccountAccessor.insertFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を新規追加する。
void | StandardAccountAccessor.updateAccount(String groupId, Account account) アカウント情報を更新する。
void | StandardAccountAccessor.updateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を更新する。
void | StandardAccountAccessor.updateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を更新する。
void | StandardAccountAccessor.setAttribute(String groupId, String userId, String name, String value) アカウント属性情報を設定する。
void | StandardAccountAccessor.deleteAttribute(String groupId, String userId, String name) アカウント属性情報を削除する。
void | StandardAccessControllerAccessor.deleteController(String groupId, String controllerId) アクセスコントローラを削除します。
void | StandardAccessControllerAccessor.deleteControllerDepartment(String groupId, String id, DepartmentInfo departmentInfo) アクセスコントローラ組織を削除します。
void | StandardAccessControllerAccessor.deleteControllerDepartments(String groupId, String id) すべてのアクセスコントローラ組織を削除します。
void | StandardAccessControllerAccessor.deleteControllerPost(String groupId, String id, PostInfo postInfo) アクセスコントローラ役職を削除します。
void | StandardAccessControllerAccessor.deleteControllerPosts(String groupId, String id) すべてのアクセスコントローラ役職を削除します。
void | StandardAccessControllerAccessor.deleteControllerPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) アクセスコントローラパブリックグループを削除します。
void | StandardAccessControllerAccessor.deleteControllerPublicGroups(String groupId, String id) すべてのアクセスコントローラパブリックグループを削除します。
void | StandardAccessControllerAccessor.deleteControllerRole(String groupId, String id, String roleId) アクセスコントローラロールを削除します。
void | StandardAccessControllerAccessor.deleteControllerRoles(String groupId, String id) すべてのアクセスコントローラロールを削除します。
void | StandardAccessControllerAccessor.insertAccessController(String groupId, AccessController controller) アクセスコントローラを作成します。
void | StandardAccessControllerAccessor.insertControllerDepartment(String groupId, String id, DepartmentInfo departmentInfo) アクセスコントローラ組織を新規に作成します。
void | StandardAccessControllerAccessor.insertControllerPost(String groupId, String id, PostInfo postInfo) アクセスコントローラ役職を新規に作成します。
void | StandardAccessControllerAccessor.insertControllerPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) アクセスコントローラパブリックグループを新規に作成します。
void | StandardAccessControllerAccessor.insertControllerRole(String groupId, String id, String roleId) アクセスコントローラロールを新規に作成します。
void | StandardAccessControllerAccessor.updateController(String groupId, AccessController controller) アクセスコントローラを更新します。

jp.co.intra_mart.foundation.security.access での AccessSecurityWriteException の使用

AccessSecurityWriteException をスローする jp.co.intra_mart.foundation.security.access のメソッド
void | AccessControllerAccessor.deleteController(String groupId, String controllerId) アクセスコントローラを削除します。
void | AccessControllerAccessor.deleteControllerDepartment(String groupId, String id, DepartmentInfo departmentInfo) アクセスコントローラ組織を削除します。
void | AccessControllerAccessor.deleteControllerDepartments(String groupId, String id) すべてのアクセスコントローラ組織を削除します。
void | AccessControllerAccessor.deleteControllerPost(String groupId, String id, PostInfo postInfo) アクセスコントローラ役職を削除します。
void | AccessControllerAccessor.deleteControllerPosts(String groupId, String id) すべてのアクセスコントローラ役職を削除します。
void | AccessControllerAccessor.deleteControllerPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) アクセスコントローラパブリックグループを削除します。
void | AccessControllerAccessor.deleteControllerPublicGroups(String groupId, String id) すべてのアクセスコントローラパブリックグループを削除します。
void | AccessControllerAccessor.deleteControllerRole(String groupId, String id, String roleId) アクセスコントローラロールを削除します。
void | AccessControllerAccessor.deleteControllerRoles(String groupId, String id) すべてのアクセスコントローラロールを削除します。
void | AccessControllerAccessor.insertAccessController(String groupId, AccessController controller) アクセスコントローラを作成します。
void | AccessControllerAccessor.insertControllerDepartment(String groupId, String id, DepartmentInfo departmentInfo) アクセスコントローラ組織を新規に作成します。
void | AccessControllerAccessor.insertControllerPost(String groupId, String id, PostInfo postInfo) アクセスコントローラ役職を新規に作成します。
void | AccessControllerAccessor.insertControllerPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) アクセスコントローラパブリックグループを新規に作成します。
void | AccessControllerAccessor.insertControllerRole(String groupId, String id, String roleId) アクセスコントローラロールを新規に作成します。
void | AccessControllerAccessor.updateController(String groupId, AccessController controller) アクセスコントローラを更新します。

jp.co.intra_mart.foundation.security.account での AccessSecurityWriteException の使用

AccessSecurityWriteException をスローする jp.co.intra_mart.foundation.security.account のメソッド
void | AccountAccessor.deleteAccount(String groupId, String userId) アカウント情報を削除する。
void | AccountAccessor.deleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報を削除する。
void | AccountAccessor.deleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を削除する。
void | AccountAccessor.insertAccount(String groupId, Account account) アカウント情報を新規追加する。
void | AccountAccessor.insertAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を新規追加する。
void | AccountAccessor.insertFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を新規追加する。
void | AccountAccessor.updateAccount(String groupId, Account account) アカウント情報を更新する。
void | AccountAccessor.updateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を更新する。
void | AccountAccessor.updateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を更新する。
void | AccountAccessor.setAttribute(String groupId, String userId, String name, String value) アカウント属性情報を設定する。
void | AccountAccessor.deleteAttribute(String groupId, String userId, String name) アカウント属性情報を削除する。

jp.co.intra_mart.foundation.security.admin での AccessSecurityWriteException の使用

AccessSecurityWriteException をスローする jp.co.intra_mart.foundation.security.admin のメソッド
void | SuperUserAccessor.insertSuperUser(SuperUser superUser) システム管理者情報を新規追加します。
void | SuperUserAccessor.updateSuperUser(SuperUser superUser) システム管理者情報を更新します。

jp.co.intra_mart.foundation.security.batch での AccessSecurityWriteException の使用

AccessSecurityWriteException をスローする jp.co.intra_mart.foundation.security.batch のメソッド
void | BatchAccessor.deleteBatch(String groupId, String batchId) バッチ情報を削除します。
void | BatchAccessor.updateBatch(String groupId, Batch batch) バッチ情報を更新します。
void | BatchAccessor.insertBatch(String groupId, Batch batch) バッチ情報を新規に追加します。

jp.co.intra_mart.foundation.security.calendar での AccessSecurityWriteException の使用

AccessSecurityWriteException をスローする jp.co.intra_mart.foundation.security.calendar のメソッド
void | CalendarAccessor.deleteCalendar(String groupId, String calendarId) カレンダーを削除します。
void | CalendarAccessor.deleteCalendarInfo(String groupId, String calendarId, String dataId) 指定されたカレンダーデータを削除します。
void | CalendarAccessor.insertCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に作成します。
void | CalendarAccessor.updateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。

jp.co.intra_mart.foundation.security.exception での AccessSecurityWriteException の使用

jp.co.intra_mart.foundation.security.exception での AccessSecurityWriteException のサブクラス
class | AccessSecurityCreateException アクセスセキュリティ情報作成例外クラス。
class | AccessSecurityDeleteException アクセスセキュリティ情報削除例外クラス。
class | AccessSecurityUpdateException アクセスセキュリティ情報更新例外クラス。
class | DuplicateException 作成時重複例外クラス。
class | NotExistException アクセスセキュリティ情報が存在しなかった場合の例外クラス。
class | NotSupportMethodException アクセスセキュリティのマネージャでサポートされないメソッドがコールされた場合の例外クラス。

jp.co.intra_mart.foundation.security.group での AccessSecurityWriteException の使用

AccessSecurityWriteException をスローする jp.co.intra_mart.foundation.security.group のメソッド
void | LoginGroupAccessor.deleteLoginGroup(String groupId) ログイングループを削除します。
void | LoginGroupAccessor.deleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを削除します。
void | LoginGroupAccessor.insertLoginGroup(LoginGroup loginGroup) ログイングループを新規追加します。
void | LoginGroupAccessor.insertMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを新規追加します。
void | LoginGroupAccessor.updateLoginGroup(LoginGroup loginGroup) ログイングループを更新します。
void | LoginGroupAccessor.updateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを更新します。
void | GroupSuperUserAccessor.deleteSuperUser(String groupId) グループ管理者情報を削除します。
void | GroupSuperUserAccessor.insertSuperUser(String groupId, SuperUser superUser) グループ管理者情報を新規追加します。
void | GroupSuperUserAccessor.updateSuperUser(String groupId, SuperUser superUser) グループ管理者情報を更新します。

jp.co.intra_mart.foundation.security.menu での AccessSecurityWriteException の使用

AccessSecurityWriteException をスローする jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuAccessor.deleteMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を削除します。
void | MenuAccessor.deleteMenuDepartments(String groupId, String id) すべてのメニュー組織を削除します。
void | MenuAccessor.deleteMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を削除します。
void | MenuAccessor.deleteMenuItem(String groupId, String id) 引数で渡されたノードを削除します。
void | MenuAccessor.deleteMenuPost(String groupId, String id, PostInfo postInfo) メニュー役職を削除します。
void | MenuAccessor.deleteMenuPosts(String groupId, String id) すべてのメニュー役職を削除します。
void | MenuAccessor.deleteMenuPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) メニューパブリックグループを削除します。
void | MenuAccessor.deleteMenuPublicGroups(String groupId, String id) すべてのメニューパブリックグループを削除します。
void | MenuAccessor.deleteMenuRole(String groupId, String id, String roleId) メニューロールを削除します。
void | MenuAccessor.deleteMenuRoles(String groupId, String id) すべてのメニューロールを削除します。
void | MenuAccessor.insertMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を新規に作成します。
void | MenuAccessor.insertMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を新規に作成します。
void | MenuAccessor.insertMenuItem(String groupId, MenuItem menuItem, String parentId) 引数で渡されたノードを新規追加します。
void | MenuAccessor.insertMenuPost(String groupId, String id, PostInfo postInfo) メニュー役職を新規に作成します。
void | MenuAccessor.insertMenuPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) メニューパブリックグループを新規に作成します。
void | MenuAccessor.insertMenuRole(String groupId, String id, String roleId) メニューロールを新規に作成します。
void | MenuAccessor.updateMenuItem(String groupId, MenuItem menuItem) 引数で渡されたノードを更新します。
void | AdminMenuAccessor.deleteMenuInclusion(MenuInclusion menuInclusion) メニュー構成を削除します。
void | AdminMenuAccessor.deleteMenuItem(String menuId) 引数で渡されたノードを削除します。
void | AdminMenuAccessor.insertMenuInclusion(MenuInclusion menuInclusion) メニュー構成を新規に作成します。
void | AdminMenuAccessor.insertMenuItem(MenuItem menuItem, String parentId) 引数で渡されたノードを新規追加します。
void | AdminMenuAccessor.updateMenuItem(MenuItem menuItem) 引数で渡されたノードを更新します。
void | AdminMenuAccessor.addMenuLoginGroup(String menuId, String groupId) 管理メニューにアクセス権を設定します。
void | AdminMenuAccessor.deleteMenuLoginGroup(String menuId, String groupId) 管理メニューに設定されているアクセス権を削除します。
void | AdminMenuAccessor.setAccessControlEnabled(String menuId, boolean accessControl) メニューアイテムに対するアクセス権を設定します。

jp.co.intra_mart.foundation.security.role での AccessSecurityWriteException の使用

AccessSecurityWriteException をスローする jp.co.intra_mart.foundation.security.role のメソッド
void | RoleAccessor.createRole(String groupId, Role role) ロール情報を新規に追加する。
void | RoleAccessor.deleteCategory(String groupId) すべてのカテゴリを削除する。
void | RoleAccessor.deleteCategory(String groupId, String category) カテゴリを削除する。
void | RoleAccessor.deleteRole(String groupId) すべてのロール情報を削除する。
void | RoleAccessor.deleteRole(String groupId, String roleId) ロール情報を削除する。
void | RoleAccessor.updateCategory(String groupId, String oldCategory, String newCategory) カテゴリを更新する。
void | RoleAccessor.updateRole(String groupId, Role role) ロール情報を更新する。
void | RoleAccessor.insertSubRole(String groupId, String roleId, String subRoleId) サブロールを作成する。
void | RoleAccessor.deleteSubRole(String groupId, String roleId, String subRoleId) サブロールIDサマリを削除する。
void | RoleAccessor.deleteSubRole(String groupId, String roleId) 指定したロールのサブロールIDサマリを全削除する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.ActiveSessionException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.ActiveSessionException の使用

ActiveSessionException を使用しているパッケージ
jp.co.intra_mart.foundation.security.activesession |
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.activesession での ActiveSessionException の使用

ActiveSessionException をスローする jp.co.intra_mart.foundation.security.activesession のメソッド
void | StandardActiveSessionAccessor.init(Node defaultNode, Node node) 設定ファイル conf/active-session-config.xml の情報を基に初期化します。
void | StandardActiveSessionAccessor.addActiveSessionInfo(ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報を登録します。
void | StandardActiveSessionAccessor.removeActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を削除します。
void | StandardActiveSessionAccessor.destory(String groupId) アクティブなセッション情報をすべて破棄します。
void | StandardActiveSessionAccessor.invalidate(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
boolean | StandardActiveSessionAccessor.isValid(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
int | StandardActiveSessionAccessor.count(String groupId) アクティブなすべてのセッション数を取得します。
int | StandardActiveSessionAccessor.count(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなすべてのセッション数を取得します。
int | StandardActiveSessionAccessor.count(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。
boolean | StandardActiveSessionAccessor.exists(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が存在するかどうか取得します。
ActiveSessionInfo[] | StandardActiveSessionAccessor.getActiveSessionInfos(String groupId) アクティブなすべてのセッション情報を取得します。
ActiveSessionInfo | StandardActiveSessionAccessor.getActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を取得します。
ActiveSessionInfo | StandardActiveSessionAccessor.getInvalidatedActiveSessionInfo(String groupId, String sessionId) 無効化されたアクティブなセッション情報を取得します。
ActiveSessionInfo[] | StandardActiveSessionAccessor.getActiveSessionInfos(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | StandardActiveSessionAccessor.getActiveSessionInfos(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | StandardActiveSessionAccessor.searchActiveSessionInfosByUserId(String groupId, String loginType, String userId) 引数で指定されたユーザ条件からアクティブなセッション情報を検索します。
void | StandardActiveSessionAccessor.updateToProcessing(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報を処理中に更新します。
void | StandardActiveSessionAccessor.updateLastResponseTime(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。
void | ActiveSessionManager.addActiveSessionInfo(ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報を登録します。
void | ActiveSessionManager.removeActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を削除します。
void | ActiveSessionManager.destory(String groupId) アクティブなセッション情報をすべて破棄します。
void | ActiveSessionManager.invalidate(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
boolean | ActiveSessionManager.isValid(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
boolean | ActiveSessionManager.isLogined(String groupId, String loginType, String userId) 引数で指定されたユーザがログインしているかどうか判別します。
int | ActiveSessionManager.count(String groupId) アクティブなすべてのセッション数を取得します。
int | ActiveSessionManager.count(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなすべてのセッション数を取得します。
int | ActiveSessionManager.count(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。
ActiveSessionInfo[] | ActiveSessionManager.getActiveSessionInfos(String groupId) アクティブなすべてのセッション情報を取得します。
ActiveSessionInfo | ActiveSessionManager.getActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を取得します。
boolean | ActiveSessionManager.hasActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が存在するかチェックします。
ActiveSessionInfo | ActiveSessionManager.getInvalidatedActiveSessionInfo(String groupId, String sessionId) 無効化されたアクティブなセッション情報を取得します。
ActiveSessionInfo[] | ActiveSessionManager.getActiveSessionInfos(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | ActiveSessionManager.getActiveSessionInfos(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | ActiveSessionManager.searchActiveSessionInfosByUserId(String groupId, String loginType, String userId) 引数で指定されたユーザ条件からアクティブなセッション情報を検索します。
void | ActiveSessionManager.updateToProcessing(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報を処理中に更新します。
void | ActiveSessionManager.updateLastResponseTime(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。
void | ActiveSessionAccessor.init(Node defaultNode, Node node) 設定ファイルの情報を基に初期化します。
void | ActiveSessionAccessor.addActiveSessionInfo(ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報を登録します。
void | ActiveSessionAccessor.removeActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を削除します。
void | ActiveSessionAccessor.destory(String groupId) アクティブなセッション情報をすべて破棄します。
void | ActiveSessionAccessor.invalidate(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
boolean | ActiveSessionAccessor.isValid(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
int | ActiveSessionAccessor.count(String groupId) アクティブなすべてのセッション数を取得します。
int | ActiveSessionAccessor.count(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなすべてのセッション数を取得します。
int | ActiveSessionAccessor.count(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。
boolean | ActiveSessionAccessor.exists(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が存在するかどうか取得します。
ActiveSessionInfo[] | ActiveSessionAccessor.getActiveSessionInfos(String groupId) アクティブなすべてのセッション情報を取得します。
ActiveSessionInfo | ActiveSessionAccessor.getActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を取得します。
ActiveSessionInfo | ActiveSessionAccessor.getInvalidatedActiveSessionInfo(String groupId, String sessionId) 無効化されたアクティブなセッション情報を取得します。
ActiveSessionInfo[] | ActiveSessionAccessor.getActiveSessionInfos(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | ActiveSessionAccessor.getActiveSessionInfos(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | ActiveSessionAccessor.searchActiveSessionInfosByUserId(String groupId, String loginType, String userId) 引数で指定されたユーザ条件からアクティブなセッション情報を検索します。
void | ActiveSessionAccessor.updateToProcessing(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報を処理中に更新します。
void | ActiveSessionAccessor.updateLastResponseTime(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。

jp.co.intra_mart.foundation.security.exception での ActiveSessionException の使用

jp.co.intra_mart.foundation.security.exception での ActiveSessionException のサブクラス
class | ActiveSessionInvalidatedByForceException アクティブなセッションが強制的に無効化されたことに関する例外クラス
class | ActiveSessionNotExistException アクティブなセッションが存在しない例外クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.ActiveSessionInvalidatedByForceException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.ActiveSessionInvalidatedByForceException の使用

jp.co.intra_mart.foundation.security.exception.ActiveSessionInvalidatedByForceException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.ActiveSessionNotExistException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.ActiveSessionNotExistException の使用

ActiveSessionNotExistException を使用しているパッケージ
jp.co.intra_mart.foundation.security.activesession

jp.co.intra_mart.foundation.security.activesession での ActiveSessionNotExistException の使用

ActiveSessionNotExistException をスローする jp.co.intra_mart.foundation.security.activesession のメソッド
void | StandardActiveSessionAccessor.removeActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を削除します。
void | StandardActiveSessionAccessor.invalidate(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
boolean | StandardActiveSessionAccessor.isValid(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
ActiveSessionInfo | StandardActiveSessionAccessor.getActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を取得します。
ActiveSessionInfo | StandardActiveSessionAccessor.getInvalidatedActiveSessionInfo(String groupId, String sessionId) 無効化されたアクティブなセッション情報を取得します。
void | StandardActiveSessionAccessor.updateToProcessing(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報を処理中に更新します。
void | StandardActiveSessionAccessor.updateLastResponseTime(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。
void | ActiveSessionManager.removeActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を削除します。
void | ActiveSessionManager.invalidate(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
boolean | ActiveSessionManager.isValid(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
ActiveSessionInfo | ActiveSessionManager.getActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を取得します。
ActiveSessionInfo | ActiveSessionManager.getInvalidatedActiveSessionInfo(String groupId, String sessionId) 無効化されたアクティブなセッション情報を取得します。
void | ActiveSessionManager.updateToProcessing(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報を処理中に更新します。
void | ActiveSessionManager.updateLastResponseTime(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。
void | ActiveSessionAccessor.removeActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を削除します。
void | ActiveSessionAccessor.invalidate(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
boolean | ActiveSessionAccessor.isValid(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
ActiveSessionInfo | ActiveSessionAccessor.getActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を取得します。
ActiveSessionInfo | ActiveSessionAccessor.getInvalidatedActiveSessionInfo(String groupId, String sessionId) 無効化されたアクティブなセッション情報を取得します。
void | ActiveSessionAccessor.updateToProcessing(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報を処理中に更新します。
void | ActiveSessionAccessor.updateLastResponseTime(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.DuplicateException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.DuplicateException の使用

DuplicateException を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security での DuplicateException の使用

DuplicateException をスローする jp.co.intra_mart.foundation.security のメソッド
void | StandardCalendarAccessor.insertCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に作成します。
void | StandardBatchAccessor.insertBatch(String groupId, Batch batch) バッチを登録します。
void | StandardAccountAccessor.insertAccount(String groupId, Account account) アカウント情報を新規追加する。
void | StandardAccountAccessor.insertAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を新規追加する。
void | StandardAccountAccessor.insertFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を新規追加する。

jp.co.intra_mart.foundation.security.account での DuplicateException の使用

DuplicateException をスローする jp.co.intra_mart.foundation.security.account のメソッド
void | AccountAccessor.insertAccount(String groupId, Account account) アカウント情報を新規追加する。
void | AccountAccessor.insertAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を新規追加する。
void | AccountAccessor.insertFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を新規追加する。

jp.co.intra_mart.foundation.security.admin での DuplicateException の使用

DuplicateException をスローする jp.co.intra_mart.foundation.security.admin のメソッド
 void SuperUserAccessor.insertSuperUser(SuperUser superUser)
システム管理者情報を新規追加します。

jp.co.intra_mart.foundation.security.batch での DuplicateException の使用

DuplicateException をスローする jp.co.intra_mart.foundation.security.batch のメソッド
 void BatchAccessor.insertBatch(String groupId, Batch batch)
バッチ情報を新規に追加します。

jp.co.intra_mart.foundation.security.calendar での DuplicateException の使用

DuplicateException をスローする jp.co.intra_mart.foundation.security.calendar のメソッド
 void CalendarAccessor.insertCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo)
カレンダーデータを新規に作成します。

jp.co.intra_mart.foundation.security.group での DuplicateException の使用

DuplicateException をスローする jp.co.intra_mart.foundation.security.group のメソッド
void | LoginGroupAccessor.insertLoginGroup(LoginGroup loginGroup) ログイングループを新規追加します。
void | LoginGroupAccessor.insertMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを新規追加します。
void | GroupSuperUserAccessor.insertSuperUser(String groupId, SuperUser superUser) グループ管理者情報を新規追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.DuplicateLoginDetectedException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.DuplicateLoginDetectedException の使用

jp.co.intra_mart.foundation.security.exception.DuplicateLoginDetectedException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.DuplicateLoginException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.DuplicateLoginException の使用

DuplicateLoginException を使用しているパッケージ
jp.co.intra_mart.foundation.security.duplication |
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.duplication での DuplicateLoginException の使用

DuplicateLoginException をスローする jp.co.intra_mart.foundation.security.duplication のメソッド
void | StandardDuplicateLoginAccessor.init(Node defaultNode, Node node) 設定ファイル conf/duplicate-login.xml の情報を基に初期化します。
boolean | DuplicateLoginManager.isDuplicateLogined(ActiveSessionInfo activeSessionInfo) 引数で指定されたユーザが重複してログインしているかどうか判別します。
boolean | DuplicateLoginManager.isDuplicateLogined(String loginGroup, String loginType, String userId, String sessionId) 引数で指定されたユーザが重複してログインしているかどうか判別します。
void | DuplicateLoginManager.invalidateOtherSessions(ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報以外のセッション情報をすべて無効にします。
void | DuplicateLoginAccessor.init(Node defaultNode, Node node) 設定ファイルの情報を基に初期化します。

jp.co.intra_mart.foundation.security.exception での DuplicateLoginException の使用

jp.co.intra_mart.foundation.security.exception での DuplicateLoginException のサブクラス
 class DuplicateLoginDetectedException
重複ログイン検出例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.IllegalArgumentException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.IllegalArgumentException の使用

jp.co.intra_mart.foundation.security.exception.IllegalArgumentException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.NoFilterException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.NoFilterException の使用

NoFilterException を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession |

jp.co.intra_mart.foundation.security での NoFilterException の使用

NoFilterException をスローする jp.co.intra_mart.foundation.security のメソッド
int | AccessSecurityManager.forceLogin(LoginRequestInfo loginRequestInfo) 強制ログイン処理を行います。
void | AccessSecurityManager.forward(String url) 指定したURLにフォワードします。
SessionInfo | AccessSecurityManager.getCookieSessionInfo() カレントスレッド情報のクッキーからintra-martセッション情報を取得します。
String | AccessSecurityManager.getErrorPage(int errorCode) カレントスレッド情報からエラーページＵＲＬを取得します。
int | AccessSecurityManager.getInitialCertification(LoginRequestInfo loginInfo) カレントスレッドの情報から初期アクセス処理を行います。
String | AccessSecurityManager.getInitialPage() カレントスレッド情報から初期アクセスページURLを取得します。
String | AccessSecurityManager.getInitialPage(SessionInfo sessionInfo) カレントスレッド情報から初期アクセスページURLを取得します。
int | AccessSecurityManager.getLoginCertification() カレントスレッド情報からログイン処理を行います。
String | AccessSecurityManager.getMainPage() カレントスレッド情報からメインページURLを取得します。
String | AccessSecurityManager.getMainPage(SessionInfo sessionInfo) カレントスレッド情報からメインページURLを取得します。
SessionInfo | AccessSecurityManager.getSessionInfo() カレントスレッド情報からintra-martセッション情報を取得します。
int | AccessSecurityManager.getSessionMode() intra-martセッションの状態を取得します。
int | AccessSecurityManager.login(LoginRequestInfo loginRequestInfo) ログイン処理を行います。
void | AccessSecurityManager.logout() ログアウト処理を行います。
void | AccessSecurityManager.secureRedirect(String url, Map args) 呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。
String | AccessSecurityManager.getMobileUserAgent() モバイル端末の固体識別番号を取得します。

jp.co.intra_mart.foundation.security.activesession での NoFilterException の使用

NoFilterException をスローする jp.co.intra_mart.foundation.security.activesession のコンストラクタ
ActiveSessionInfo(HttpServletRequest request)
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.NoSessionCookieException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.NoSessionCookieException の使用

jp.co.intra_mart.foundation.security.exception.NoSessionCookieException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.NoSessionException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.NoSessionException の使用

jp.co.intra_mart.foundation.security.exception.NoSessionException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.NotExistException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.NotExistException の使用

NotExistException を使用しているパッケージ
jp.co.intra_mart.foundation.database | データベースへアクセスするためのクラスを提供します。
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.database での NotExistException の使用

NotExistException をスローする jp.co.intra_mart.foundation.database のメソッド
Connection | DatabaseManager.getLoginGroupConnection(String groupId) ログイングループIDからコネクションオブジェクトを取得します。
Connection | DatabaseManager.getSystemConnection(String connectId) システム接続名からコネクションオブジェクトを取得します。

jp.co.intra_mart.foundation.security での NotExistException の使用

NotExistException をスローする jp.co.intra_mart.foundation.security のメソッド
void | StandardMenuAccessor.deleteMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を削除します。
void | StandardCalendarAccessor.deleteCalendar(String groupId, String calendarId) カレンダーを削除します。
void | StandardCalendarAccessor.deleteCalendarInfo(String groupId, String calendarId, String dataId) 指定されたカレンダーデータを削除します。
void | StandardCalendarAccessor.updateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。
void | StandardBatchAccessor.deleteBatch(String groupId, String batchId) バッチを削除します。
void | StandardBatchAccessor.updateBatch(String groupId, Batch batch) バッチを更新します。
void | StandardAccountAccessor.deleteAccount(String groupId, String userId) アカウント情報を削除する。
void | StandardAccountAccessor.deleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報を削除する。
void | StandardAccountAccessor.deleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を削除する。
void | StandardAccountAccessor.updateAccount(String groupId, Account account) アカウント情報を更新する。
void | StandardAccountAccessor.updateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を更新する。
void | StandardAccountAccessor.updateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を更新する。
void | StandardAccountAccessor.deleteAttribute(String groupId, String userId, String name) アカウント属性情報を削除する。

jp.co.intra_mart.foundation.security.account での NotExistException の使用

NotExistException をスローする jp.co.intra_mart.foundation.security.account のメソッド
void | AccountAccessor.deleteAccount(String groupId, String userId) アカウント情報を削除する。
void | AccountAccessor.deleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報を削除する。
void | AccountAccessor.deleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を削除する。
void | AccountAccessor.updateAccount(String groupId, Account account) アカウント情報を更新する。
void | AccountAccessor.updateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を更新する。
void | AccountAccessor.updateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を更新する。
void | AccountAccessor.deleteAttribute(String groupId, String userId, String name) アカウント属性情報を削除する。

jp.co.intra_mart.foundation.security.admin での NotExistException の使用

NotExistException をスローする jp.co.intra_mart.foundation.security.admin のメソッド
 void SuperUserAccessor.updateSuperUser(SuperUser superUser)
システム管理者情報を更新します。

jp.co.intra_mart.foundation.security.batch での NotExistException の使用

NotExistException をスローする jp.co.intra_mart.foundation.security.batch のメソッド
void | BatchAccessor.deleteBatch(String groupId, String batchId) バッチ情報を削除します。
void | BatchAccessor.updateBatch(String groupId, Batch batch) バッチ情報を更新します。

jp.co.intra_mart.foundation.security.calendar での NotExistException の使用

NotExistException をスローする jp.co.intra_mart.foundation.security.calendar のメソッド
void | CalendarAccessor.deleteCalendar(String groupId, String calendarId) カレンダーを削除します。
void | CalendarAccessor.deleteCalendarInfo(String groupId, String calendarId, String dataId) 指定されたカレンダーデータを削除します。
void | CalendarAccessor.updateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。

jp.co.intra_mart.foundation.security.group での NotExistException の使用

NotExistException をスローする jp.co.intra_mart.foundation.security.group のメソッド
void | LoginGroupAccessor.deleteLoginGroup(String groupId) ログイングループを削除します。
void | LoginGroupAccessor.deleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを削除します。
void | LoginGroupAccessor.updateLoginGroup(LoginGroup loginGroup) ログイングループを更新します。
void | LoginGroupAccessor.updateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを更新します。
void | GroupSuperUserAccessor.deleteSuperUser(String groupId) グループ管理者情報を削除します。
void | GroupSuperUserAccessor.updateSuperUser(String groupId, SuperUser superUser) グループ管理者情報を更新します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException の使用

jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.NotSupportMethodException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.NotSupportMethodException の使用

jp.co.intra_mart.foundation.security.exception.NotSupportMethodException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.SystemConfigException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.SystemConfigException の使用

jp.co.intra_mart.foundation.security.exception.SystemConfigException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AccessSecurityConfigException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityConfigException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.exception.FoundationRuntimeException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException
                        拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException
すべての実装インタフェース:
Serializable
public class AccessSecurityConfigException
extends AccessSecurityRuntimeException

アクセスセキュリティ設定に関する例外クラス。

アクセスセキュリティ設定が正しく設定されていない場合にスローされる。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
AccessSecurityConfigException()
コンストラクタ。
AccessSecurityConfigException(String message)
コンストラクタ。
AccessSecurityConfigException(String message, Throwable cause)
コンストラクタ。
AccessSecurityConfigException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityConfigException

public AccessSecurityConfigException()
コンストラクタ。

AccessSecurityConfigException

public AccessSecurityConfigException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

AccessSecurityConfigException

public AccessSecurityConfigException(String message,
                                     Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

AccessSecurityConfigException

public AccessSecurityConfigException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityCreateException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityCreateException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
                        拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException
すべての実装インタフェース:
Serializable
public class AccessSecurityCreateException
extends AccessSecurityWriteException

アクセスセキュリティ情報作成例外クラス。

アクセスセキュリティ情報の作成に失敗した場合にスローされます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
AccessSecurityCreateException(String key, String kind)
コンストラクタ。
AccessSecurityCreateException(String key, String kind, String group)
コンストラクタ。
AccessSecurityCreateException(String key, String kind, String group, Throwable cause)
コンストラクタ。
AccessSecurityCreateException(String key, String kind, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityCreateException

public AccessSecurityCreateException(String key,
                                     String kind,
                                     String group)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ

AccessSecurityCreateException

public AccessSecurityCreateException(String key,
                                     String kind)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別

AccessSecurityCreateException

public AccessSecurityCreateException(String key,
                                     String kind,
                                     String group,
                                     Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ
cause - 原因となる例外

AccessSecurityCreateException

public AccessSecurityCreateException(String key,
                                     String kind,
                                     Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityDeleteException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityDeleteException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
                        拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException
すべての実装インタフェース:
Serializable
public class AccessSecurityDeleteException
extends AccessSecurityWriteException

アクセスセキュリティ情報削除例外クラス。

アクセスセキュリティ情報の削除に失敗した場合にスローされます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
AccessSecurityDeleteException(String key, String kind)
コンストラクタ。
AccessSecurityDeleteException(String key, String kind, String group)
コンストラクタ。
AccessSecurityDeleteException(String key, String kind, String group, Throwable cause)
コンストラクタ。
AccessSecurityDeleteException(String key, String kind, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityDeleteException

public AccessSecurityDeleteException(String key,
                                     String kind,
                                     String group)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ

AccessSecurityDeleteException

public AccessSecurityDeleteException(String key,
                                     String kind)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別

AccessSecurityDeleteException

public AccessSecurityDeleteException(String key,
                                     String kind,
                                     String group,
                                     Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ
cause - 原因となる例外

AccessSecurityDeleteException

public AccessSecurityDeleteException(String key,
                                     String kind,
                                     Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccessSecurityExportException, AccessSecurityImportException, AccessSecurityListenerExcpetion, AccessSecurityReadException, AccessSecurityWriteException, ActiveSessionException, DuplicateLoginException, IllegalArgumentException, NoFilterException, NoSessionCookieException, NoSessionException, NotFoundDataSourceException
public class AccessSecurityException
extends FoundationException

アクセスセキュリティの基本となる例外クラス。

アクセスセキュリティで例外が発生した場合にスローされる。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
static String | KIND_ROLE 種別 ロール。
static String | KIND_ROLE_SUB 種別 サブロール(ロール)。
コンストラクタの概要
AccessSecurityException()
コンストラクタ。
AccessSecurityException(String message)
コンストラクタ。
AccessSecurityException(String message, Throwable cause)
コンストラクタ。
AccessSecurityException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

フィールドの詳細

KIND_ROLE

public static final String KIND_ROLE
種別 ロール。

関連項目:
定数フィールド値

KIND_ROLE_SUB

public static final String KIND_ROLE_SUB
種別 サブロール(ロール)。

関連項目:
定数フィールド値
コンストラクタの詳細

AccessSecurityException

public AccessSecurityException()
コンストラクタ。

AccessSecurityException

public AccessSecurityException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

AccessSecurityException

public AccessSecurityException(String message,
                               Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

AccessSecurityException

public AccessSecurityException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityExportException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityExportException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException
すべての実装インタフェース:
Serializable
public class AccessSecurityExportException
extends AccessSecurityException

エクスポート時例外クラス。

エクスポート時に例外が発生した場合にスローする。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
AccessSecurityExportException(String name)
コンストラクタ。
AccessSecurityExportException(String name, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityExportException

public AccessSecurityExportException(String name)
コンストラクタ。

パラメータ:
name - 重複している名称

AccessSecurityExportException

public AccessSecurityExportException(String name,
                                     Throwable cause)
コンストラクタ。

パラメータ:
name - 重複している名称
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityImportException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityImportException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException
すべての実装インタフェース:
Serializable
public class AccessSecurityImportException
extends AccessSecurityException

インポート時例外クラス。

インポート時に例外が発生した場合にスローする。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
AccessSecurityImportException(String name)
コンストラクタ。
AccessSecurityImportException(String name, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityImportException

public AccessSecurityImportException(String name)
コンストラクタ。

パラメータ:
name - 重複している名称

AccessSecurityImportException

public AccessSecurityImportException(String name,
                                     Throwable cause)
コンストラクタ。

パラメータ:
name - 重複している名称
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityListenerExcpetion (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityListenerExcpetion

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion
すべての実装インタフェース:
Serializable
public class AccessSecurityListenerExcpetion
extends AccessSecurityException

アクセスセキュリティリスナーの例外クラス。

アクセスセキュリティリスナー内で例外が発せした場合にスローされます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
AccessSecurityListenerExcpetion()
コンストラクタ。
AccessSecurityListenerExcpetion(String message)
コンストラクタ。
AccessSecurityListenerExcpetion(String message, Throwable cause)
コンストラクタ。
AccessSecurityListenerExcpetion(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityListenerExcpetion

public AccessSecurityListenerExcpetion()
コンストラクタ。

AccessSecurityListenerExcpetion

public AccessSecurityListenerExcpetion(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

AccessSecurityListenerExcpetion

public AccessSecurityListenerExcpetion(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

AccessSecurityListenerExcpetion

public AccessSecurityListenerExcpetion(String message,
                                       Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityReadException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityReadException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException
すべての実装インタフェース:
Serializable
public class AccessSecurityReadException
extends AccessSecurityException

アクセスセキュリティ情報の取得例外クラス。

アクセスセキュリティ情報の取得に失敗した場合にスローされる。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
AccessSecurityReadException(String message)
コンストラクタ。
AccessSecurityReadException(String key, String kind)
コンストラクタ。
AccessSecurityReadException(String key, String kind, String group)
コンストラクタ。
AccessSecurityReadException(String key, String kind, String group, Throwable cause)
コンストラクタ。
AccessSecurityReadException(String key, String kind, Throwable cause)
コンストラクタ。
AccessSecurityReadException(String message, Throwable cause)
コンストラクタ。
AccessSecurityReadException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityReadException

public AccessSecurityReadException(String key,
                                   String kind,
                                   String group)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ

AccessSecurityReadException

public AccessSecurityReadException(String key,
                                   String kind)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別

AccessSecurityReadException

public AccessSecurityReadException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

AccessSecurityReadException

public AccessSecurityReadException(String key,
                                   String kind,
                                   String group,
                                   Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ
cause - 原因となる例外

AccessSecurityReadException

public AccessSecurityReadException(String key,
                                   String kind,
                                   Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
cause - 原因となる例外

AccessSecurityReadException

public AccessSecurityReadException(String message,
                                   Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

AccessSecurityReadException

public AccessSecurityReadException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityRuntimeException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityRuntimeException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.exception.FoundationRuntimeException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccessSecurityConfigException, SystemConfigException
public class AccessSecurityRuntimeException
extends FoundationRuntimeException

アクセスセキュリティランタイム例外クラス。

アクセスセキュリティ設定ファイル群の不備などでシステム運用が続行不可な場合のランタイム例外クラスです。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
AccessSecurityRuntimeException()
コンストラクタ。
AccessSecurityRuntimeException(String message)
コンストラクタ。
AccessSecurityRuntimeException(String message, Throwable cause)
コンストラクタ。
AccessSecurityRuntimeException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityRuntimeException

public AccessSecurityRuntimeException()
コンストラクタ。

AccessSecurityRuntimeException

public AccessSecurityRuntimeException(String message)
コンストラクタ。

パラメータ:
message - メッセージ

AccessSecurityRuntimeException

public AccessSecurityRuntimeException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

AccessSecurityRuntimeException

public AccessSecurityRuntimeException(String message,
                                      Throwable cause)
コンストラクタ。

パラメータ:
message - メッセージ
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityUpdateException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityUpdateException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
                        拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException
すべての実装インタフェース:
Serializable
public class AccessSecurityUpdateException
extends AccessSecurityWriteException

アクセスセキュリティ情報更新例外クラス。

アクセスセキュリティ情報の更新に失敗した場合にスローされます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
AccessSecurityUpdateException(String key, String kind)
コンストラクタ。
AccessSecurityUpdateException(String key, String kind, String group)
コンストラクタ。
AccessSecurityUpdateException(String key, String kind, String group, Throwable cause)
コンストラクタ。
AccessSecurityUpdateException(String key, String kind, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityUpdateException

public AccessSecurityUpdateException(String key,
                                     String kind,
                                     String group)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ

AccessSecurityUpdateException

public AccessSecurityUpdateException(String key,
                                     String kind)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別

AccessSecurityUpdateException

public AccessSecurityUpdateException(String key,
                                     String kind,
                                     String group,
                                     Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ
cause - 原因となる例外

AccessSecurityUpdateException

public AccessSecurityUpdateException(String key,
                                     String kind,
                                     Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityWriteException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityWriteException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccessSecurityCreateException, AccessSecurityDeleteException, AccessSecurityUpdateException, DuplicateException, NotExistException, NotSupportMethodException
public class AccessSecurityWriteException
extends AccessSecurityException

アクセスセキュリティ情報の更新例外クラス。

アクセスセキュリティ情報の更新に失敗した場合にスローされる。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
AccessSecurityWriteException()
コンストラクタ。
AccessSecurityWriteException(String message)
コンストラクタ。
AccessSecurityWriteException(String message, Throwable cause)
コンストラクタ。
AccessSecurityWriteException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityWriteException

public AccessSecurityWriteException()
コンストラクタ。

AccessSecurityWriteException

public AccessSecurityWriteException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

AccessSecurityWriteException

public AccessSecurityWriteException(String message,
                                    Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

AccessSecurityWriteException

public AccessSecurityWriteException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ActiveSessionException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス ActiveSessionException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.ActiveSessionException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ActiveSessionInvalidatedByForceException, ActiveSessionNotExistException
public class ActiveSessionException
extends AccessSecurityException

アクティブなセッション情報例外の基本となる例外クラス。

導入されたバージョン:
6.1
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
ActiveSessionException()
コンストラクタ。
ActiveSessionException(String message)
コンストラクタ。
ActiveSessionException(String message, Throwable cause)
コンストラクタ。
ActiveSessionException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ActiveSessionException

public ActiveSessionException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

ActiveSessionException

public ActiveSessionException(String message,
                              Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

ActiveSessionException

public ActiveSessionException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

ActiveSessionException

public ActiveSessionException()
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ActiveSessionInvalidatedByForceException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス ActiveSessionInvalidatedByForceException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.ActiveSessionException
                        拡張 jp.co.intra_mart.foundation.security.exception.ActiveSessionInvalidatedByForceException
すべての実装インタフェース:
Serializable
public class ActiveSessionInvalidatedByForceException
extends ActiveSessionException

アクティブなセッションが強制的に無効化されたことに関する例外クラス

導入されたバージョン:
6.1
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
ActiveSessionInvalidatedByForceException()
コンストラクタ。
ActiveSessionInvalidatedByForceException(String message)
コンストラクタ。
ActiveSessionInvalidatedByForceException(String message, Throwable cause)
コンストラクタ。
ActiveSessionInvalidatedByForceException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ActiveSessionInvalidatedByForceException

public ActiveSessionInvalidatedByForceException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

ActiveSessionInvalidatedByForceException

public ActiveSessionInvalidatedByForceException(String message,
                                                Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

ActiveSessionInvalidatedByForceException

public ActiveSessionInvalidatedByForceException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

ActiveSessionInvalidatedByForceException

public ActiveSessionInvalidatedByForceException()
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ActiveSessionNotExistException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス ActiveSessionNotExistException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.ActiveSessionException
                        拡張 jp.co.intra_mart.foundation.security.exception.ActiveSessionNotExistException
すべての実装インタフェース:
Serializable
public class ActiveSessionNotExistException
extends ActiveSessionException

アクティブなセッションが存在しない例外クラス。

導入されたバージョン:
6.1
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
ActiveSessionNotExistException()
コンストラクタ。
ActiveSessionNotExistException(String message)
コンストラクタ。
ActiveSessionNotExistException(String message, Throwable cause)
コンストラクタ。
ActiveSessionNotExistException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ActiveSessionNotExistException

public ActiveSessionNotExistException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

ActiveSessionNotExistException

public ActiveSessionNotExistException(String message,
                                      Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

ActiveSessionNotExistException

public ActiveSessionNotExistException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

ActiveSessionNotExistException

public ActiveSessionNotExistException()
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DuplicateException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス DuplicateException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
                        拡張 jp.co.intra_mart.foundation.security.exception.DuplicateException
すべての実装インタフェース:
Serializable
public class DuplicateException
extends AccessSecurityWriteException

作成時重複例外クラス。

アクセスセキュリティ情報を新規作成する場合に重複が起こった場合にスローする。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
DuplicateException(String key, String kind)
コンストラクタ。
DuplicateException(String key, String kind, String group)
コンストラクタ。
DuplicateException(String key, String kind, String group, Throwable cause)
コンストラクタ。
DuplicateException(String key, String kind, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DuplicateException

public DuplicateException(String key,
                          String kind,
                          String group)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ

DuplicateException

public DuplicateException(String key,
                          String kind)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別

DuplicateException

public DuplicateException(String key,
                          String kind,
                          String group,
                          Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ
cause - 原因となる例外

DuplicateException

public DuplicateException(String key,
                          String kind,
                          Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DuplicateLoginDetectedException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス DuplicateLoginDetectedException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.DuplicateLoginException
                        拡張 jp.co.intra_mart.foundation.security.exception.DuplicateLoginDetectedException
すべての実装インタフェース:
Serializable
public class DuplicateLoginDetectedException
extends DuplicateLoginException

重複ログイン検出例外クラス

導入されたバージョン:
6.1
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
DuplicateLoginDetectedException()
コンストラクタ。
DuplicateLoginDetectedException(String message)
コンストラクタ。
DuplicateLoginDetectedException(String message, Throwable cause)
コンストラクタ。
DuplicateLoginDetectedException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DuplicateLoginDetectedException

public DuplicateLoginDetectedException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

DuplicateLoginDetectedException

public DuplicateLoginDetectedException(String message,
                                       Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

DuplicateLoginDetectedException

public DuplicateLoginDetectedException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

DuplicateLoginDetectedException

public DuplicateLoginDetectedException()
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DuplicateLoginException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス DuplicateLoginException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.DuplicateLoginException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
DuplicateLoginDetectedException
public class DuplicateLoginException
extends AccessSecurityException

重複ログイン制御例外の基本となる例外クラス。

導入されたバージョン:
6.1
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
DuplicateLoginException()
コンストラクタ。
DuplicateLoginException(String message)
コンストラクタ。
DuplicateLoginException(String message, Throwable cause)
コンストラクタ。
DuplicateLoginException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DuplicateLoginException

public DuplicateLoginException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

DuplicateLoginException

public DuplicateLoginException(String message,
                               Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

DuplicateLoginException

public DuplicateLoginException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

DuplicateLoginException

public DuplicateLoginException()
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IllegalArgumentException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス IllegalArgumentException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.IllegalArgumentException
すべての実装インタフェース:
Serializable
public class IllegalArgumentException
extends AccessSecurityException

引数が不正の例外クラス。

引数が不正であった場合にスローされます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
IllegalArgumentException(String argName, String function)
コンストラクタ。
IllegalArgumentException(String argName, String function, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalArgumentException

public IllegalArgumentException(String argName,
                                String function)
コンストラクタ。

パラメータ:
argName - 不正な引数名

IllegalArgumentException

public IllegalArgumentException(String argName,
                                String function,
                                Throwable cause)
コンストラクタ。

パラメータ:
argName - 不正な引数名
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NoFilterException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス NoFilterException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.NoFilterException
すべての実装インタフェース:
Serializable
public class NoFilterException
extends AccessSecurityException

HTTPリクエスト・レスポンス取得例外クラス。

HTTPリクエスト・レスポンス情報が取得できなかった場合の例外。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
NoFilterException()
コンストラクタ。
NoFilterException(String message)
コンストラクタ。
NoFilterException(String message, Throwable cause)
コンストラクタ。
NoFilterException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NoFilterException

public NoFilterException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

NoFilterException

public NoFilterException(String message,
                         Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

NoFilterException

public NoFilterException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

NoFilterException

public NoFilterException()
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NoSessionCookieException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス NoSessionCookieException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.NoSessionCookieException
すべての実装インタフェース:
Serializable
public class NoSessionCookieException
extends AccessSecurityException

セッション情報クッキー取得例外クラス。

セッション情報クッキーが取得できなかった場合の例外。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
NoSessionCookieException(String cookieName)
コンストラクタ。
NoSessionCookieException(String cookieName, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NoSessionCookieException

public NoSessionCookieException(String cookieName,
                                Throwable cause)
コンストラクタ。

パラメータ:
cookieName - 存在しなかったクッキー名
cause - 原因となる例外

NoSessionCookieException

public NoSessionCookieException(String cookieName)
コンストラクタ。

パラメータ:
cookieName - 存在しなかったクッキー名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NoSessionException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス NoSessionException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.NoSessionException
すべての実装インタフェース:
Serializable
public class NoSessionException
extends AccessSecurityException

セッション取得例外クラス。

セッション情報が取得できなかった場合の例外。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
NoSessionException()
コンストラクタ。
NoSessionException(String message)
コンストラクタ。
NoSessionException(String message, Throwable cause)
コンストラクタ。
NoSessionException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NoSessionException

public NoSessionException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

NoSessionException

public NoSessionException(String message,
                          Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

NoSessionException

public NoSessionException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

NoSessionException

public NoSessionException()
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NotExistException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス NotExistException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
                        拡張 jp.co.intra_mart.foundation.security.exception.NotExistException
すべての実装インタフェース:
Serializable
public class NotExistException
extends AccessSecurityWriteException

アクセスセキュリティ情報が存在しなかった場合の例外クラス。

アクセスセキュリティ情報が存在しなかった場合にスローする。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
NotExistException(String key, String kind)
コンストラクタ。
NotExistException(String key, String kind, String group)
コンストラクタ。
NotExistException(String key, String kind, String group, Throwable cause)
コンストラクタ。
NotExistException(String key, String kind, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NotExistException

public NotExistException(String key,
                         String kind,
                         String group)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ

NotExistException

public NotExistException(String key,
                         String kind)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別

NotExistException

public NotExistException(String key,
                         String kind,
                         String group,
                         Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ
cause - 原因となる例外

NotExistException

public NotExistException(String key,
                         String kind,
                         Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NotFoundDataSourceException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス NotFoundDataSourceException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException
すべての実装インタフェース:
Serializable
public class NotFoundDataSourceException
extends AccessSecurityException

データソースの参照名未解決例外クラス。

ログイングループおよび接続名に紐付いたデータソース参照名が見つからなかった場合にスローする。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
NotFoundDataSourceException(String name, String type)
コンストラクタ。
NotFoundDataSourceException(String name, String type, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NotFoundDataSourceException

public NotFoundDataSourceException(String name,
                                   String type)
コンストラクタ。

パラメータ:
name - 見つからなかったログイングループまたは接続名
type - 接続種別

NotFoundDataSourceException

public NotFoundDataSourceException(String name,
                                   String type,
                                   Throwable cause)
コンストラクタ。

パラメータ:
name - 見つからなかったログイングループまたは接続名
type - 接続種別
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NotSupportMethodException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス NotSupportMethodException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
                        拡張 jp.co.intra_mart.foundation.security.exception.NotSupportMethodException
すべての実装インタフェース:
Serializable
public class NotSupportMethodException
extends AccessSecurityWriteException

アクセスセキュリティのマネージャでサポートされないメソッドがコールされた場合の例外クラス。

アクセスセキュリティのマネージャでサポートされないメソッドがコールされた場合にスローする。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
NotSupportMethodException()
コンストラクタ。
NotSupportMethodException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NotSupportMethodException

public NotSupportMethodException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

NotSupportMethodException

public NotSupportMethodException()
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.exception (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.security.exception
例外
AccessSecurityConfigException
AccessSecurityCreateException
AccessSecurityDeleteException
AccessSecurityException
AccessSecurityExportException
AccessSecurityImportException
AccessSecurityListenerExcpetion
AccessSecurityReadException
AccessSecurityRuntimeException
AccessSecurityUpdateException
AccessSecurityWriteException
ActiveSessionException
ActiveSessionInvalidatedByForceException
ActiveSessionNotExistException
DuplicateException
DuplicateLoginDetectedException
DuplicateLoginException
IllegalArgumentException
NoFilterException
NoSessionCookieException
NoSessionException
NotExistException
NotFoundDataSourceException
NotSupportMethodException
SystemConfigException


jp.co.intra_mart.foundation.security.exception (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.exception

アクセスセキュリティ例外に関連するクラスを提供します。

参照:
説明

例外の概要
AccessSecurityConfigException | アクセスセキュリティ設定に関する例外クラス。
AccessSecurityCreateException | アクセスセキュリティ情報作成例外クラス。
AccessSecurityDeleteException | アクセスセキュリティ情報削除例外クラス。
AccessSecurityException | アクセスセキュリティの基本となる例外クラス。
AccessSecurityExportException | エクスポート時例外クラス。
AccessSecurityImportException | インポート時例外クラス。
AccessSecurityListenerExcpetion | アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException | アクセスセキュリティ情報の取得例外クラス。
AccessSecurityRuntimeException | アクセスセキュリティランタイム例外クラス。
AccessSecurityUpdateException | アクセスセキュリティ情報更新例外クラス。
AccessSecurityWriteException | アクセスセキュリティ情報の更新例外クラス。
ActiveSessionException | アクティブなセッション情報例外の基本となる例外クラス。
ActiveSessionInvalidatedByForceException | アクティブなセッションが強制的に無効化されたことに関する例外クラス
ActiveSessionNotExistException | アクティブなセッションが存在しない例外クラス。
DuplicateException | 作成時重複例外クラス。
DuplicateLoginDetectedException | 重複ログイン検出例外クラス
DuplicateLoginException | 重複ログイン制御例外の基本となる例外クラス。
IllegalArgumentException | 引数が不正の例外クラス。
NoFilterException | HTTPリクエスト・レスポンス取得例外クラス。
NoSessionCookieException | セッション情報クッキー取得例外クラス。
NoSessionException | セッション取得例外クラス。
NotExistException | アクセスセキュリティ情報が存在しなかった場合の例外クラス。
NotFoundDataSourceException | データソースの参照名未解決例外クラス。
NotSupportMethodException | アクセスセキュリティのマネージャでサポートされないメソッドがコールされた場合の例外クラス。
SystemConfigException | システム設定に関する例外クラス。

パッケージ jp.co.intra_mart.foundation.security.exception の説明

アクセスセキュリティ例外に関連するクラスを提供します。


jp.co.intra_mart.foundation.security.exception クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.exception.FoundationException
          • class jp.co.intra_mart.foundation.security.exception.AccessSecurityException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException
              • class jp.co.intra_mart.foundation.security.exception.DuplicateException
              • class jp.co.intra_mart.foundation.security.exception.NotExistException
              • class jp.co.intra_mart.foundation.security.exception.NotSupportMethodException
            • class jp.co.intra_mart.foundation.security.exception.ActiveSessionException
              • class jp.co.intra_mart.foundation.security.exception.ActiveSessionInvalidatedByForceException
              • class jp.co.intra_mart.foundation.security.exception.ActiveSessionNotExistException
            • class jp.co.intra_mart.foundation.security.exception.DuplicateLoginException
              • class jp.co.intra_mart.foundation.security.exception.DuplicateLoginDetectedException
            • class jp.co.intra_mart.foundation.security.exception.IllegalArgumentException
            • class jp.co.intra_mart.foundation.security.exception.NoFilterException
            • class jp.co.intra_mart.foundation.security.exception.NoSessionCookieException
            • class jp.co.intra_mart.foundation.security.exception.NoSessionException
            • class jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.exception.FoundationRuntimeException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException
              • class jp.co.intra_mart.foundation.security.exception.SystemConfigException


パッケージ jp.co.intra_mart.foundation.security.exception の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.exception の使用

jp.co.intra_mart.foundation.security.exception を使用しているパッケージ
jp.co.intra_mart.foundation.database | データベースへアクセスするためのクラスを提供します。
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession |
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.duplication |
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.license | ライセンスに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.message | メッセージに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.mobile |
jp.co.intra_mart.foundation.security.permission | 権限に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.shortcut |

jp.co.intra_mart.foundation.database により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
NotExistException
アクセスセキュリティ情報が存在しなかった場合の例外クラス。

jp.co.intra_mart.foundation.navigator により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。

jp.co.intra_mart.foundation.security により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityReadException
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。
DuplicateException
作成時重複例外クラス。
NoFilterException
HTTPリクエスト・レスポンス取得例外クラス。
NotExistException
アクセスセキュリティ情報が存在しなかった場合の例外クラス。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityExportException
エクスポート時例外クラス。
AccessSecurityImportException
インポート時例外クラス。
AccessSecurityListenerExcpetion
アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。

jp.co.intra_mart.foundation.security.account により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityExportException
エクスポート時例外クラス。
AccessSecurityImportException
インポート時例外クラス。
AccessSecurityListenerExcpetion
アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。
DuplicateException
作成時重複例外クラス。
NotExistException
アクセスセキュリティ情報が存在しなかった場合の例外クラス。

jp.co.intra_mart.foundation.security.activesession により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
ActiveSessionException
アクティブなセッション情報例外の基本となる例外クラス。
ActiveSessionNotExistException
アクティブなセッションが存在しない例外クラス。
NoFilterException
HTTPリクエスト・レスポンス取得例外クラス。

jp.co.intra_mart.foundation.security.admin により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityListenerExcpetion
アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。
DuplicateException
作成時重複例外クラス。
NotExistException
アクセスセキュリティ情報が存在しなかった場合の例外クラス。

jp.co.intra_mart.foundation.security.batch により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityExportException
エクスポート時例外クラス。
AccessSecurityImportException
インポート時例外クラス。
AccessSecurityListenerExcpetion
アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。
DuplicateException
作成時重複例外クラス。
NotExistException
アクセスセキュリティ情報が存在しなかった場合の例外クラス。

jp.co.intra_mart.foundation.security.calendar により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityExportException
エクスポート時例外クラス。
AccessSecurityImportException
インポート時例外クラス。
AccessSecurityListenerExcpetion
アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。
DuplicateException
作成時重複例外クラス。
NotExistException
アクセスセキュリティ情報が存在しなかった場合の例外クラス。

jp.co.intra_mart.foundation.security.duplication により使用される jp.co.intra_mart.foundation.security.exception のクラス
DuplicateLoginException
重複ログイン制御例外の基本となる例外クラス。

jp.co.intra_mart.foundation.security.exception により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityRuntimeException
アクセスセキュリティランタイム例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。
ActiveSessionException
アクティブなセッション情報例外の基本となる例外クラス。
DuplicateLoginException
重複ログイン制御例外の基本となる例外クラス。

jp.co.intra_mart.foundation.security.group により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityListenerExcpetion
アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。
DuplicateException
作成時重複例外クラス。
NotExistException
アクセスセキュリティ情報が存在しなかった場合の例外クラス。

jp.co.intra_mart.foundation.security.license により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityExportException
エクスポート時例外クラス。
AccessSecurityImportException
インポート時例外クラス。
AccessSecurityListenerExcpetion
アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。

jp.co.intra_mart.foundation.security.message により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。

jp.co.intra_mart.foundation.security.mobile により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityConfigException
アクセスセキュリティ設定に関する例外クラス。
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityListenerExcpetion
アクセスセキュリティリスナーの例外クラス。

jp.co.intra_mart.foundation.security.permission により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。

jp.co.intra_mart.foundation.security.role により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityExportException
エクスポート時例外クラス。
AccessSecurityImportException
インポート時例外クラス。
AccessSecurityListenerExcpetion
アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。

jp.co.intra_mart.foundation.security.shortcut により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SystemConfigException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス SystemConfigException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.exception.FoundationRuntimeException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException
                        拡張 jp.co.intra_mart.foundation.security.exception.SystemConfigException
すべての実装インタフェース:
Serializable
public class SystemConfigException
extends AccessSecurityRuntimeException

システム設定に関する例外クラス。

システム設定が正しく設定されていない場合にスローされる。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SystemConfigException()
コンストラクタ。
SystemConfigException(String message)
コンストラクタ。
SystemConfigException(String message, Throwable cause)
コンストラクタ。
SystemConfigException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SystemConfigException

public SystemConfigException()
コンストラクタ。

SystemConfigException

public SystemConfigException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

SystemConfigException

public SystemConfigException(String message,
                             Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

SystemConfigException

public SystemConfigException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.filter.ActiveSessionFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.filter.ActiveSessionFilter の使用

jp.co.intra_mart.foundation.security.filter.ActiveSessionFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.filter.DuplicateLoginHandlingFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.filter.DuplicateLoginHandlingFilter の使用

jp.co.intra_mart.foundation.security.filter.DuplicateLoginHandlingFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter の使用

jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter の使用

jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter の使用

jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.filter.SessionFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.filter.SessionFilter の使用

jp.co.intra_mart.foundation.security.filter.SessionFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.filter.URLAccessFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.filter.URLAccessFilter の使用

jp.co.intra_mart.foundation.security.filter.URLAccessFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ActiveSessionFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.filter
クラス ActiveSessionFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.foundation.security.filter.ActiveSessionFilter
すべての実装インタフェース:
Filter
public class ActiveSessionFilter
extends AbstractFilter

アクティブセッションフィルタ。

無効にされたアクティブセッションを検出するためのフィルターです。
アクティブセッションとは、フィルターSessionFilterによって有効であると判断されたセッションのことを表します。
注意
このフィルターは必ず SessionFilter が設定された各サーブレットの最後に設定してください。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
ActiveSessionFilter()
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタを実行します。
protected void | handleInit() 初期化します。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ActiveSessionFilter

public ActiveSessionFilter()
メソッドの詳細

handleInit

protected void handleInit()
                   throws ServletException
初期化します。

オーバーライド:
クラス AbstractFilter 内の handleInit
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
関連項目:
Filter.init(javax.servlet.FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタを実行します。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
chain - フィルタチェーン
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラー
関連項目:
Filter.doFilter(javax.servlet.ServletRequest, javax.servlet.ServletResponse, javax.servlet.FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DuplicateLoginHandlingFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.filter
クラス DuplicateLoginHandlingFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.foundation.security.filter.DuplicateLoginHandlingFilter
すべての実装インタフェース:
Filter
public class DuplicateLoginHandlingFilter
extends AbstractFilter

重複ログインハンドリングフィルタ。

重複ログインをハンドリングするためのフィルターです。

注意
このフィルターは必ず ActiveSessionFilter が設定された各サーブレットの最後に設定してください。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
DuplicateLoginHandlingFilter()
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタを実行します。
protected void | handleInit() 初期化します。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DuplicateLoginHandlingFilter

public DuplicateLoginHandlingFilter()
メソッドの詳細

handleInit

protected void handleInit()
                   throws ServletException
初期化します。

オーバーライド:
クラス AbstractFilter 内の handleInit
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
関連項目:
Filter.init(javax.servlet.FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタを実行します。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
chain - フィルタチェーン
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラー
関連項目:
Filter.doFilter(javax.servlet.ServletRequest, javax.servlet.ServletResponse, javax.servlet.FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InitialPageSessionHandlingFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.filter
クラス InitialPageSessionHandlingFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter
すべての実装インタフェース:
Filter
public class InitialPageSessionHandlingFilter
extends AbstractFilter

ログインしている状態にログイン画面を表示しようとした際に警告ページを表示するためのフィルタ。

ログインしている状態とは「ログインページ表示要求のリクエストにセッション(HttpSession)が存在し、 そのセッションがintra-martのアクセスセキュリティ上のセッションモード(AccessSecurityManager.getSessionMode())が ログイン状態(SecurityConstraint.CR_SESSION_LOGON)の場合」

このフィルタを利用することで、たとえば以下のことが行える。

  • タブブラウザで任意のタブAでintra-martにログイン後、任意のタブBでintra-martにログインするためにログイン画面を表示しようとすると指定した警告ページを表示できる。
    これは、クッキー内にタブAのセッションID(クッキー名：jsessionid)が保管されており、そのセッションIDのHttpSessionの有効な期間まで、またはブラウザのプロセスが終了されるまで残っているためであり、 クッキーからそのセッションIDが消えればログイン画面は表示される。

パラメータ：
パラメータ名 | 説明
enable | このフィルターを利用する場合 true を指定。無効にする場合は false を指定。 ※上記以外の値が設定された場合は本フィルターは無効になります。
warning-page-path | フォワード先の警告ページ画面のURLを指定してください ※例： system/security/error/request_session_already_logon_error.jssp

このフィルタは以下のサーブレットに対して使用されることを想定しています。
  • UserInitialServlet
  • GroupSuperUserInitialServlet
  • SuperUserInitialServlet
上記のサーブレットに使用する場合、そのサーブレットのフィルターマッピングの設定の最後に追加設定してください。

【使用例】 UserInitialServlet に本フィルターを設定する例
   <filter>
       <filter-name>InitialPageSessionHandlingFilter</filter-name>
       <filter-class>jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter</filter-class>
       <init-param>
           <param-name>enable</param-name>
           <param-value>true</param-value>
       </init-param>
       <init-param>
           <param-name>warning-page-path</param-name>
           <param-value>system/security/error/request_session_already_logon_error.jssp</param-value>
       </init-param>
   </filter>

       : (省略)

   <filter-mapping>
       <filter-name>InitialPageSessionHandlingFilter</filter-name>
        <servlet-name>UserInitialServlet</servlet-name>
   </filter-mapping>

導入されたバージョン:
6.1.7

フィールドの概要
static String DEFAULT_ATTR_REQUESTED_PAGE
遷移先の警告ページにリクエストURLを渡すために利用するリクエスト属性名のデフォルト名
コンストラクタの概要
InitialPageSessionHandlingFilter()
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタを実行します。
protected void | handleInit() 初期化します。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_ATTR_REQUESTED_PAGE

public static final String DEFAULT_ATTR_REQUESTED_PAGE
遷移先の警告ページにリクエストURLを渡すために利用するリクエスト属性名のデフォルト名

関連項目:
定数フィールド値
コンストラクタの詳細

InitialPageSessionHandlingFilter

public InitialPageSessionHandlingFilter()
メソッドの詳細

handleInit

protected void handleInit()
                   throws ServletException
初期化します。

オーバーライド:
クラス AbstractFilter 内の handleInit
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
関連項目:
Filter.init(javax.servlet.FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタを実行します。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
chain - フィルタチェーン
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラー
関連項目:
Filter.doFilter(javax.servlet.ServletRequest, javax.servlet.ServletResponse, javax.servlet.FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.filter (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.security.filter
クラス
ActiveSessionFilter
DuplicateLoginHandlingFilter
InitialPageSessionHandlingFilter
RequestCharacterEncodingFilter
ResponseCharacterEncodingFilter
SessionFilter
URLAccessFilter


jp.co.intra_mart.foundation.security.filter (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.filter

アクセスセキュリティのフィルタに関連するクラスを提供します。

参照:
説明

クラスの概要
ActiveSessionFilter | アクティブセッションフィルタ。
DuplicateLoginHandlingFilter | 重複ログインハンドリングフィルタ。
InitialPageSessionHandlingFilter | ログインしている状態にログイン画面を表示しようとした際に警告ページを表示するためのフィルタ。
RequestCharacterEncodingFilter | リクエストに対するエンコードは SessionInfo.getEncoding()が 返す値をになります。
ResponseCharacterEncodingFilter | レスポンスの文字エンコーディングを自動解決するフィルタです。
SessionFilter | セッションフィルタ。
URLAccessFilter | URLアクセスフィルタ。

パッケージ jp.co.intra_mart.foundation.security.filter の説明

アクセスセキュリティのフィルタに関連するクラスを提供します。


jp.co.intra_mart.foundation.security.filter クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.filter の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter (implements javax.servlet.Filter)
      • class jp.co.intra_mart.foundation.security.filter.ActiveSessionFilter
      • class jp.co.intra_mart.foundation.security.filter.DuplicateLoginHandlingFilter
      • class jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter
      • class jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter
      • class jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter
    • class jp.co.intra_mart.foundation.security.filter.SessionFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.foundation.security.filter.URLAccessFilter (implements javax.servlet.Filter)


パッケージ jp.co.intra_mart.foundation.security.filter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.filter の使用

jp.co.intra_mart.foundation.security.filter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


RequestCharacterEncodingFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.filter
クラス RequestCharacterEncodingFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter
すべての実装インタフェース:
Filter
public class RequestCharacterEncodingFilter
extends AbstractFilter

リクエストに対するエンコードは SessionInfo.getEncoding()が 返す値をになります。 リクエストの文字エンコーディングは、 ServletRequest.setCharacterEncoding(java.lang.String) によってセットされます。
ここでSessionInfo.getEncoding() を取得できなかった場合エンコードの設定はしないで次の処理に遷移します。

バージョン:
1.0

コンストラクタの概要
RequestCharacterEncodingFilter()
メソッドの概要
 void doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain)
リクエストの文字エンコードをアクセスセキュリティ情報を基にエンコーディングを設定して、 次のフィルタチェーンを実行します。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, handleInit, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RequestCharacterEncodingFilter

public RequestCharacterEncodingFilter()
メソッドの詳細

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws ServletException,
                     IOException
リクエストの文字エンコードをアクセスセキュリティ情報を基にエンコーディングを設定して、 次のフィルタチェーンを実行します。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ResponseCharacterEncodingFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.filter
クラス ResponseCharacterEncodingFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter
すべての実装インタフェース:
Filter
public class ResponseCharacterEncodingFilter
extends AbstractFilter

レスポンスの文字エンコーディングを自動解決するフィルタです。

レスポンスに対するエンコードは SessionInfo.getEncoding()が 返す値をになります。 レスポンスの文字エンコーディングは、Content-Type 設定と共に ServletResponse.setContentType(java.lang.String) によってセットされます。

このフィルタでは、ServletResponse をラップします。 ラップされた ServletResponse に対して #setContentType(String) を 明示的に実行した場合、自動的に Content-Type を書き換えません。 このフィルタ動作によって Content-Type が自動的にセットされるのは、 ラップされた ServletResponse の #setContentType(String) が実行されていない 状態で、ServletResponse の #getOutputStream() または #getWriter() が 呼び出された場合に限られます。

このフィルタに設定可能な初期化パラメータは以下のとおりです。

mime このフィルタがContent-Typeを自動的にセットする時の MIME タイプ。標準は text/html です。

バージョン:
1.0

コンストラクタの概要
ResponseCharacterEncodingFilter()
新しくフィルタを作成します。
メソッドの概要
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) レスポンスソースの文字エンコードをアクセスセキュリティ情報を基にして 自動解決する HttpServletResponse を作成して、 次のフィルタチェーンを実行します。
void | handleInit() このフィルタを初期化します。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ResponseCharacterEncodingFilter

public ResponseCharacterEncodingFilter()
新しくフィルタを作成します。

メソッドの詳細

handleInit

public void handleInit()
このフィルタを初期化します。

オーバーライド:
クラス AbstractFilter 内の handleInit
関連項目:
AbstractFilter.init(FilterConfig)

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws ServletException,
                     IOException
レスポンスソースの文字エンコードをアクセスセキュリティ情報を基にして 自動解決する HttpServletResponse を作成して、 次のフィルタチェーンを実行します。

このメソッドが作る HttpServletResponse は、引数 response をラップし、 #getWriter() メソッドが実行された時に #setContentType() を一度も 呼び出されていない場合、アクセスセキュリティＡＰＩを通して、 現在のセッションで有効な文字エンコーディングを自動解決し、 Content-Type をセットしてから、引数 response の #getWriter() メソッドを 呼び出します。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.filter
クラス SessionFilter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.filter.SessionFilter
すべての実装インタフェース:
Filter
public class SessionFilter
extends Object
implements Filter

セッションフィルタ。

セッション情報の状況をチェックします。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String SESSION_TIMEOUT_HEADER_KEY
セッションタイムアウトレスポンスヘッダーキー。
コンストラクタの概要
SessionFilter()
メソッドの概要
void | destroy() 破棄します。
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタを実行します。
void | init(FilterConfig config) 初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

SESSION_TIMEOUT_HEADER_KEY

public static final String SESSION_TIMEOUT_HEADER_KEY
セッションタイムアウトレスポンスヘッダーキー。

セッションタイムアウトが発生した場合
レスポンスヘッダに、このキーを設定します。

関連項目:
定数フィールド値
コンストラクタの詳細

SessionFilter

public SessionFilter()
メソッドの詳細

init

public void init(FilterConfig config)
          throws ServletException
初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
config - フィルタコンフィグ
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
関連項目:
Filter.init(javax.servlet.FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタを実行します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
chain - フィルタチェーン
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException
関連項目:
Filter.doFilter(javax.servlet.ServletRequest, javax.servlet.ServletResponse, javax.servlet.FilterChain)

destroy

public void destroy()
破棄します。

定義:
インタフェース Filter 内の destroy
関連項目:
Filter.destroy()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


URLAccessFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.filter
クラス URLAccessFilter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.filter.URLAccessFilter
すべての実装インタフェース:
Filter
public class URLAccessFilter
extends Object
implements Filter

URLアクセスフィルタ。

初期パラメータで設定されたＵＲＬでフィルタを行います。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
URLAccessFilter()
メソッドの概要
void | destroy() 破棄します。
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタを実行します。
void | init(FilterConfig config) 初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLAccessFilter

public URLAccessFilter()
メソッドの詳細

init

public void init(FilterConfig config)
          throws ServletException
初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
config - フィルタコンフィグ
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
関連項目:
Filter.init(javax.servlet.FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタを実行します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
chain - フィルタチェーン
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException
関連項目:
Filter.doFilter(javax.servlet.ServletRequest, javax.servlet.ServletResponse, javax.servlet.FilterChain)

destroy

public void destroy()
破棄します。

定義:
インタフェース Filter 内の destroy
関連項目:
Filter.destroy()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor の使用

jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener の使用

jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener の使用

jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator の使用

jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.group.LoginGroup の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.group.LoginGroup の使用

LoginGroup を使用しているパッケージ
jp.co.intra_mart.foundation.security.group グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.group での LoginGroup の使用

LoginGroup を返す jp.co.intra_mart.foundation.security.group のメソッド
LoginGroup | LoginGroupReaderDecorator.doDecoration(LoginGroup loginGroup) ログイングループをデータストアからの読み込み直後にコールされます。
LoginGroup | LoginGroupManager.getLoginGroup(String groupId) ログイングループ情報を取得します。
LoginGroup[] | LoginGroupManager.getLoginGroups() ログイングループの一覧を取得します。
LoginGroup | LoginGroupAccessor.getLoginGroup(String groupId) ログイングループ情報を取得します。

LoginGroup 型のパラメータを持つ jp.co.intra_mart.foundation.security.group のメソッド
void | MainPageImportLoginGroupPostWriterListener.postCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成した直後にコールされます。
void | MainPageImportLoginGroupPostWriterListener.postUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新した直後にコールされます。
LoginGroup | LoginGroupReaderDecorator.doDecoration(LoginGroup loginGroup) ログイングループをデータストアからの読み込み直後にコールされます。
void | LoginGroupQueryWriterListener.queryCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成する直前にコールされます。
void | LoginGroupQueryWriterListener.queryUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新する直前にコールされます。
void | LoginGroupPostWriterListener.postCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成した直後にコールされます。
void | LoginGroupPostWriterListener.postUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新した直後にコールされます。
void | LoginGroupManager.addLoginGroup(LoginGroup loginGroup) ログイングループを新規追加します。
void | LoginGroupManager.updateLoginGroup(LoginGroup loginGroup) ログイングループ情報を更新します。
void | LoginGroupAccessor.insertLoginGroup(LoginGroup loginGroup) ログイングループを新規追加します。
void | LoginGroupAccessor.updateLoginGroup(LoginGroup loginGroup) ログイングループを更新します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.group.LoginGroupAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.group.LoginGroupAccessor の使用

jp.co.intra_mart.foundation.security.group.LoginGroupAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.group.LoginGroupManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.group.LoginGroupManager の使用

LoginGroupManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.group グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.group での LoginGroupManager の使用

LoginGroupManager を返す jp.co.intra_mart.foundation.security.group のメソッド
static LoginGroupManager LoginGroupManager.getInstance()
ログイングループマネージャのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener の使用

LoginGroupPostWriterListener を使用しているパッケージ
jp.co.intra_mart.foundation.security.group グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.group での LoginGroupPostWriterListener の使用

LoginGroupPostWriterListener を実装している jp.co.intra_mart.foundation.security.group のクラス
 class MainPageImportLoginGroupPostWriterListener
ログイングループ作成時にメインページパターンを設定するリスナークラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener の使用

jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator の使用

jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener の使用

jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.group.MainPagePatternInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.group.MainPagePatternInfo の使用

MainPagePatternInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security.group グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.group での MainPagePatternInfo の使用

MainPagePatternInfo を返す jp.co.intra_mart.foundation.security.group のメソッド
MainPagePatternInfo | LoginGroupManager.getMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを取得します。
MainPagePatternInfo[] | LoginGroupManager.getMainPagePatterns(String groupId) メインページパターンの一覧を取得します。
MainPagePatternInfo | LoginGroupAccessor.getMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを取得します。

MainPagePatternInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.group のメソッド
void | MainPageImportLoginGroupPostWriterListener.postCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成した直後にコールされます。
void | MainPageImportLoginGroupPostWriterListener.postUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新した直後にコールされます。
void | LoginGroupQueryWriterListener.queryCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成する前にコールされます。
void | LoginGroupQueryWriterListener.queryUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新する前にコールされます。
void | LoginGroupPostWriterListener.postCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成した直後にコールされます。
void | LoginGroupPostWriterListener.postUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新した直後にコールされます。
void | LoginGroupManager.addMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを新規追加します。
void | LoginGroupManager.updateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを更新します。
void | LoginGroupAccessor.insertMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを新規追加します。
void | LoginGroupAccessor.updateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを更新します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


GroupSuperUserAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
インタフェース GroupSuperUserAccessor

public interface GroupSuperUserAccessor

グループ管理者アクセッサインタフェース。

グループ管理者情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | deleteSuperUser(String groupId) グループ管理者情報を削除します。
SuperUser | getSuperUser(String groupId) グループ管理者情報を取得します。
void | init(Map params) グループ管理者アクセッサを初期化します。
void | insertSuperUser(String groupId, SuperUser superUser) グループ管理者情報を新規追加します。
void | updateSuperUser(String groupId, SuperUser superUser) グループ管理者情報を更新します。

メソッドの詳細

deleteSuperUser

public void deleteSuperUser(String groupId)
                     throws AccessSecurityWriteException,
                            NotExistException
グループ管理者情報を削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException - グループ管理者情報の削除に失敗した場合にスローされます。
NotExistException - 削除するグループ管理者が存在しない場合にスローされます。

getSuperUser

public SuperUser getSuperUser(String groupId)
                       throws AccessSecurityReadException
グループ管理者情報を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
グループ管理者情報
存在しない場合は、nullを返却します。
例外:
AccessSecurityReadException - グループ管理者情報の取得に失敗した場合にスローされます。

init

public void init(Map params)
グループ管理者アクセッサを初期化します。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

insertSuperUser

public void insertSuperUser(String groupId,
                            SuperUser superUser)
                     throws AccessSecurityWriteException,
                            DuplicateException
グループ管理者情報を新規追加します。

パラメータ:
groupId - ログイングループID
superUser - グループ管理者情報
例外:
AccessSecurityWriteException - グループ管理者情報の作成に失敗した場合にスローされます。
DuplicateException - 追加するグループ管理者が既に存在した場合にスローされます。

updateSuperUser

public void updateSuperUser(String groupId,
                            SuperUser superUser)
                     throws AccessSecurityWriteException,
                            NotExistException
グループ管理者情報を更新します。

パラメータ:
groupId - ログイングループID
superUser - グループ管理者情報
例外:
AccessSecurityWriteException - グループ管理者情報の更新に失敗した場合にスローされます。
NotExistException - 更新するグループ管理者が存在しない場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


GroupSuperUserPostWriterListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
インタフェース GroupSuperUserPostWriterListener

public interface GroupSuperUserPostWriterListener

グループ管理者情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | init(Map params) グループ管理者リスナーの初期化。
void | postCreate(String groupId, SuperUser superUser) グループ管理者情報をデータストアに作成した直後にコールされます。
void | postDelete(String groupId) グループ管理者情報をデータストアから削除した直後にコールされます。
void | postUpdate(String groupId, SuperUser superUser) グループ管理者情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
グループ管理者リスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreate

public void postCreate(String groupId,
                       SuperUser superUser)
グループ管理者情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
superUser - 作成されたグループ管理者情報

postUpdate

public void postUpdate(String groupId,
                       SuperUser superUser)
グループ管理者情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
superUser - 更新されたグループ管理者情報

postDelete

public void postDelete(String groupId)
グループ管理者情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GroupSuperUserQueryWriterListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
インタフェース GroupSuperUserQueryWriterListener

public interface GroupSuperUserQueryWriterListener

グループ管理者情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | init(Map params) グループ管理者リスナーの初期化。
void | queryCreate(String groupId, SuperUser superUser) グループ管理者情報をデータストアに作成する直前にコールされます。
void | queryDelete(String groupId) グループ管理者情報をデータストアから削除する直前にコールされます。
void | queryUpdate(String groupId, SuperUser superUser) グループ管理者情報をデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
グループ管理者リスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreate

public void queryCreate(String groupId,
                        SuperUser superUser)
グループ管理者情報をデータストアに作成する直前にコールされます。

パラメータ:
groupId - ログイングループID
superUser - 作成されるグループ管理者情報
戻り値:
グループ管理者情報

queryUpdate

public void queryUpdate(String groupId,
                        SuperUser superUser)
グループ管理者情報をデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
superUser - 更新されるグループ管理者情報

queryDelete

public void queryDelete(String groupId)
グループ管理者情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GroupSuperUserReaderDecorator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
インタフェース GroupSuperUserReaderDecorator

public interface GroupSuperUserReaderDecorator

管理者情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
SuperUser | doDecoration(String groupId, SuperUser superUser) アカウントをデータストアからの読み込み直後にコールされます。
void | init(Map params) 管理者デコレータの初期化。

メソッドの詳細

init

public void init(Map params)
管理者デコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public SuperUser doDecoration(String groupId,
                              SuperUser superUser)
アカウントをデータストアからの読み込み直後にコールされます。

引数のgroupIdがnullの場合はシステム管理者の管理者情報を拡張して返却します。
引数のgroupIdがnullのでない場合はグループ管理者の管理者情報を拡張して返却します。

パラメータ:
groupId - ログイングループID
superUser - 読み込みが行われた管理者情報
戻り値:
拡張された管理者情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginGroup (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
クラス LoginGroup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.group.LoginGroup
すべての実装インタフェース:
LocaleProvider, Serializable
public class LoginGroup
extends Object
implements LocaleProvider, Serializable

ログイングループ・モデル。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
LoginGroupManager, 直列化された形式

コンストラクタの概要
protected | LoginGroup() コンストラクタ。
 | LoginGroup(String groupId) コンストラクタ。
メソッドの概要
boolean | equals(Object loginGroup) オブジェクトの比較。
String | getColorPatternId() カラーパターンIDを取得します。
String | getEncoding() エンコーディングを取得します。
Locale | getLocale() ロケールを取得します。
int | getLockCount() アカウントをロックするログイン失敗回数を取得します。
int | getLockTerm() アカウントをロックする期間を取得します。
String | getLoginGroupId() ログイングループIDを取得します。
int | hashCode() ハッシュコードを取得します。
void | setColorPatternId(String colorPattrenId) カラーパターンIDを設定します。
void | setEncoding(String encoding) エンコーディングを設定します。
void | setLocale(Locale locale) ロケールを設定します。
void | setLockCount(int count) アカウントをロックするログイン失敗回数を設定します。
void | setLockTerm(int term) アカウントをロックする期間を設定します。
protected void | setLoginGroupId(String groupId) ログイングループIDを設定します。
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LoginGroup

protected LoginGroup()
コンストラクタ。

LoginGroup

public LoginGroup(String groupId)
コンストラクタ。

パラメータ:
groupId - ログイングループID
メソッドの詳細

equals

public boolean equals(Object loginGroup)
オブジェクトの比較。 指定されたオブジェクトとこのモデルが等しいかどうかを比較します。

パラメータ:
loginGroup - モデルと等しいかどうかを比較するオブジェクト
戻り値:
指定されたオブジェクトがこのモデルと等しい場合は true
関連項目:
Object.equals(Object)

getEncoding

public String getEncoding()
エンコーディングを取得します。

定義:
インタフェース LocaleProvider 内の getEncoding
戻り値:
エンコーディング
関連項目:
LocaleProvider.getEncoding()

getLocale

public Locale getLocale()
ロケールを取得します。

定義:
インタフェース LocaleProvider 内の getLocale
戻り値:
ロケール
関連項目:
LocaleProvider.getLocale()

getLockCount

public int getLockCount()
アカウントをロックするログイン失敗回数を取得します。

戻り値:
アカウントをロックするログイン失敗回数
アカウントロックを行わない場合は0を返却します。

getLockTerm

public int getLockTerm()
アカウントをロックする期間を取得します。

戻り値:
アカウントをロックする期間（分）
ロックする期間が設定されていない場合は0が返却されます。

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

戻り値:
ログイングループID

getColorPatternId

public String getColorPatternId()
カラーパターンIDを取得します。

戻り値:
カラーパターンID

hashCode

public int hashCode()
ハッシュコードを取得します。

戻り値:
ハッシュコード
関連項目:
Object.hashCode()

setEncoding

public void setEncoding(String encoding)
エンコーディングを設定します。

パラメータ:
encoding - エンコーディング

setLocale

public void setLocale(Locale locale)
ロケールを設定します。

パラメータ:
locale - ロケール名
関連項目:
setLocale(Locale)

setLockCount

public void setLockCount(int count)
アカウントをロックするログイン失敗回数を設定します。

設定できる値は、0以上です。
0が設定された場合はアカウントロックを行ないません。

パラメータ:
count - アカウントをロックするログイン失敗回数

setLockTerm

public void setLockTerm(int term)
アカウントをロックする期間を設定します。

設定できる値は、0以上です。
アカウントがロックされた場合の、ロック解除までの時間を分単位で設定します。
0が設定された場合は、自動的にアカウントロックは解除されません。

パラメータ:
term - アカウントをロックする期間

setLoginGroupId

protected void setLoginGroupId(String groupId)
ログイングループIDを設定します。

パラメータ:
groupId - ログイングループID

setColorPatternId

public void setColorPatternId(String colorPattrenId)
カラーパターンIDを設定します。

パラメータ:
colorPattrenId - カラーパターンID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LoginGroupAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
インタフェース LoginGroupAccessor

public interface LoginGroupAccessor

ログイングループアクセッサインタフェース。

ログイングループ情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | deleteLoginGroup(String groupId) ログイングループを削除します。
void | deleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを削除します。
LoginGroup | getLoginGroup(String groupId) ログイングループ情報を取得します。
String[] | getLoginGroupIds() ログイングループIDの一覧を取得します。
MainPagePatternInfo | getMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを取得します。
String[] | getMainPagePatternIds(String groupId) メインページパターンIDの一覧を取得します。
void | init(Map params) ログイングアクセッサの初期化。
void | insertLoginGroup(LoginGroup loginGroup) ログイングループを新規追加します。
void | insertMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを新規追加します。
void | updateLoginGroup(LoginGroup loginGroup) ログイングループを更新します。
void | updateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを更新します。

メソッドの詳細

deleteLoginGroup

public void deleteLoginGroup(String groupId)
                      throws AccessSecurityWriteException,
                             NotExistException
ログイングループを削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException - ログイングループ情報の削除に失敗した場合にスローされます。
NotExistException - 削除するログイングループ情報が存在しない場合にスローされます。

deleteMainPagePattern

public void deleteMainPagePattern(String groupId,
                                  String mainPagePatternId)
                           throws AccessSecurityWriteException,
                                  NotExistException
メインページパターンを削除します。

ログイングループに紐付くメインページパターンを削除します。

パラメータ:
groupId - ログイングループID
mainPagePatternId - メインページパターンID
例外:
AccessSecurityWriteException - メインページパターン情報の更新に失敗した場合にスローされます。
NotExistException - 削除するメインページパターン情報が存在しない場合にスローされます。

getLoginGroup

public LoginGroup getLoginGroup(String groupId)
                         throws AccessSecurityReadException
ログイングループ情報を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
ログイングループ情報
存在しない場合は、nullを返却します。
例外:
AccessSecurityReadException - ログイングループ情報の取得に失敗した場合にスローされます。

getLoginGroupIds

public String[] getLoginGroupIds()
                          throws AccessSecurityReadException
ログイングループIDの一覧を取得します。

戻り値:
ログイングループIDの配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - ログイングループ情報の取得に失敗した場合にスローされます。

getMainPagePattern

public MainPagePatternInfo getMainPagePattern(String groupId,
                                              String mainPagePatternId)
                                       throws AccessSecurityReadException
メインページパターンを取得します。

パラメータ:
groupId - ログイングループID
mainPagePatternId - メインページパターンID
戻り値:
メインパターン情報
例外:
AccessSecurityReadException - メインページパターン情報の取得に失敗した場合にスローされます。

getMainPagePatternIds

public String[] getMainPagePatternIds(String groupId)
                               throws AccessSecurityReadException
メインページパターンIDの一覧を取得します。

ログイングループに紐付くメインページパターンIDの一覧を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
メインページパターンIDの配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - メインページパターン情報の取得に失敗した場合にスローされます。

init

public void init(Map params)
ログイングアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

insertLoginGroup

public void insertLoginGroup(LoginGroup loginGroup)
                      throws AccessSecurityWriteException,
                             DuplicateException
ログイングループを新規追加します。

パラメータ:
loginGroup - ログイングループ情報
例外:
AccessSecurityWriteException - ログイングループ情報の作成に失敗した場合にスローされます。
DuplicateException - 追加するログイングループ情報が既に存在した場合にスローされます。

insertMainPagePattern

public void insertMainPagePattern(String groupId,
                                  MainPagePatternInfo mainPagePatternInfo)
                           throws AccessSecurityWriteException,
                                  DuplicateException
メインページパターンを新規追加します。

ログイングループに紐付くメインページパターンを新規追加します。

パラメータ:
groupId - ログイングループID
mainPagePatternInfo -
例外:
AccessSecurityWriteException - メインページパターン情報の作成に失敗した場合にスローされます。
DuplicateException - 追加するメインページパターン情報が既に存在した場合にスローされます。

updateLoginGroup

public void updateLoginGroup(LoginGroup loginGroup)
                      throws AccessSecurityWriteException,
                             NotExistException
ログイングループを更新します。

パラメータ:
loginGroup - ログイングループ情報
例外:
AccessSecurityWriteException - ログイングループ情報の更新に失敗した場合にスローされます。
NotExistException - 更新するログイングループ情報が存在しない場合にスローされます。

updateMainPagePattern

public void updateMainPagePattern(String groupId,
                                  MainPagePatternInfo mainPagePatternInfo)
                           throws AccessSecurityWriteException,
                                  NotExistException
メインページパターンを更新します。

ログイングループに紐付くメインページパターンを更新します。

パラメータ:
groupId - ログイングループID
mainPagePatternInfo -
例外:
AccessSecurityWriteException - メインページパターン情報の更新に失敗した場合にスローされます。
NotExistException - 更新するメインページパターン情報が存在しない場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginGroupManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
クラス LoginGroupManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.group.LoginGroupManager
public class LoginGroupManager
extends Object

ログイングループマネージャクラス。

ログイングループ情報を操作を行います。
ログイングループマネージャでは、以下の操作が可能です。

  • ログイングループの追加、更新、削除。
  • ログイングループへのグループ管理者の追加、更新、削除。
  • ログイングループへのメインページパターンの追加、更新、削除。

    • 導入されたバージョン:
    5.0
    バージョン:
    1.0
    関連項目:
    LoginGroup, SuperUser, MainPagePatternInfo

    メソッドの概要
void | addLoginGroup(LoginGroup loginGroup) ログイングループを新規追加します。
void | addMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを新規追加します。
void | addSuperUser(String groupId, SuperUser superUser) グループ管理者を新規追加します。
static void | clearInstance() ログイングループマネージャのインスタンスを初期化します。
int | countLoginGroups() ログイングループ数を取得します。
void | deleteLoginGroup(String groupId) ログイングループを削除します。
void | deleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを削除します。
void | deleteMainPagePatterns(String groupId) メインページパターンをすべて削除します。
void | deleteSuperUser(String groupId) グループ管理者情報を削除します。
static LoginGroupManager | getInstance() ログイングループマネージャのインスタンスを取得します。
LoginGroup | getLoginGroup(String groupId) ログイングループ情報を取得します。
String[] | getLoginGroupIds() ログイングループIDの一覧を取得します。
LoginGroup[] | getLoginGroups() ログイングループの一覧を取得します。
MainPagePatternInfo | getMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを取得します。
String[] | getMainPagePatternIds(String groupId) メインページパターンIDの一覧を取得します。
MainPagePatternInfo[] | getMainPagePatterns(String groupId) メインページパターンの一覧を取得します。
SuperUser | getSuperUser(String groupId) グループ管理者情報を取得します。
void | updateLoginGroup(LoginGroup loginGroup) ログイングループ情報を更新します。
void | updateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを更新します。
void | updateSuperUser(String groupId, SuperUser superUser) グループ管理者情報を更新します。
    クラス java.lang.Object から継承したメソッド
    clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    メソッドの詳細

    clearInstance

    public static void clearInstance()
    ログイングループマネージャのインスタンスを初期化します。

    アクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

    アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。
    通常、このメソッドを使用する必要はありません。

    getInstance

    public static LoginGroupManager getInstance()
    ログイングループマネージャのインスタンスを取得します。

    戻り値:
    ログイングループマネージャのインスタンス

    addLoginGroup

    public void addLoginGroup(LoginGroup loginGroup)
                   throws AccessSecurityException
    ログイングループを新規追加します。

    ログイングループを新規に追加します。
    ログイングループIDはユニークなものを設定してください。

    パラメータ:
    loginGroup - ログイングループ情報
    例外:
    AccessSecurityException - ログイングループ情報の追加に失敗した場合にスローされます。

    addMainPagePattern

    public void addMainPagePattern(String groupId,
                               MainPagePatternInfo mainPagePatternInfo)
                        throws AccessSecurityException
    メインページパターンを新規追加します。

    ログイングループに対してメインページパターンを新規に追加します。
    メインページパターンIDはログイングループ単位でユニークなものを設定してください。
    存在しないログイングループに対して、メインページパターンは追加できません。

    パラメータ:
    groupId - ログイングループID
    mainPagePatternInfo - メインページパターン情報
    例外:
    AccessSecurityWriteException - メインページパターン情報の追加に失敗した場合、または引数が不正だった場合にスローされます。
    AccessSecurityException

    addSuperUser

    public void addSuperUser(String groupId,
                         SuperUser superUser)
                  throws AccessSecurityException
    グループ管理者を新規追加します。

    ログイングループに対してグループ管理者を新規に追加します。
    存在しないログイングループに対して、グループ管理者は追加できません。

    パラメータ:
    groupId - ログイングループID
    superUser - グループ管理者情報
    例外:
    AccessSecurityException - グループ管理者情報の追加に失敗した場合、または引数が不正だった場合にスローされます。

    countLoginGroups

    public int countLoginGroups()
                     throws AccessSecurityException
    ログイングループ数を取得します。

    現在登録されているログイングループの数を返却します。

    戻り値:
    ログイングループ数
    例外:
    AccessSecurityException - ログイングループ情報の取得に失敗した場合にスローされます。

    deleteMainPagePatterns

    public void deleteMainPagePatterns(String groupId)
                            throws AccessSecurityException
    メインページパターンをすべて削除します。

    ログイングループに属するすべてのメインページパターンを削除します。
    存在しないログイングループに対して、メインページパターンの削除はできません。

    パラメータ:
    groupId - ログイングループID
    例外:
    AccessSecurityWriteException - メインページパターン情報の更新に失敗した場合にスローされます。
    AccessSecurityException

    deleteLoginGroup

    public void deleteLoginGroup(String groupId)
                      throws AccessSecurityException
    ログイングループを削除します。 ログイングループに属するすべてのアクセスセキュリティ情報も同時に削除されます。

    削除対象情報：
  • メインページパターン
  • グループ管理者
  • ロール
  • アカウント
  • メニュー
  • カレンダ
  • アクセスコントローラ
  • バッチ

    • パラメータ:
    groupId - ログイングループID
    例外:
    AccessSecurityException - ログイングループ情報の削除に失敗した場合にスローされます。

    deleteMainPagePattern

    public void deleteMainPagePattern(String groupId,
                                  String mainPagePatternId)
                           throws AccessSecurityException
    メインページパターンを削除します。

    ログイングループに属するメインページパターンを削除します。
    存在しないログイングループに対して、メインページパターンの削除はできません。

    パラメータ:
    groupId - ログイングループID
    mainPagePatternId - メインページパターンID
    例外:
    AccessSecurityWriteException - メインページパターン情報の更新に失敗した場合に、または引数が不正だった場合にスローされます。
    AccessSecurityException

    deleteSuperUser

    public void deleteSuperUser(String groupId)
                     throws AccessSecurityException
    グループ管理者情報を削除します。

    ログイングループに属するグループ管理者を削除します。
    存在しないログイングループに対して、グループ管理者の削除はできません。

    パラメータ:
    groupId - ログイングループID
    例外:
    AccessSecurityException - グループ管理者情報の削除に失敗した場合にスローされます。

    getLoginGroup

    public LoginGroup getLoginGroup(String groupId)
                         throws AccessSecurityException
    ログイングループ情報を取得します。

    引数で指定したログイングループIDのログイングループ情報を取得します。
    指定したログイングループIDのログイングループが存在しない場合は、nullを返却します。

    パラメータ:
    groupId - ログイングルーID
    戻り値:
    ログイングループ情報
    例外:
    AccessSecurityException - ログイングループ情報の取得に失敗した場合にスローされます。

    getLoginGroupIds

    public String[] getLoginGroupIds()
                          throws AccessSecurityException
    ログイングループIDの一覧を取得します。

    現在登録されているログイングループのログイングループIDの一覧を取得します。
    ログイングループが一件も存在しない場合は、空の配列を返却します。

    戻り値:
    ログイングループIDの配列
    例外:
    AccessSecurityException - ログイングループ情報の取得に失敗した場合にスローされます。

    getLoginGroups

    public LoginGroup[] getLoginGroups()
                            throws AccessSecurityException
    ログイングループの一覧を取得します。

    現在登録されているログイングループの一覧を取得します。
    ログイングループが一件も存在しない場合は、空の配列を返却します。

    戻り値:
    ログイングループ情報の配列
    例外:
    AccessSecurityException - ログイングループ情報の取得に失敗した場合にスローされます。

    getMainPagePattern

    public MainPagePatternInfo getMainPagePattern(String groupId,
                                              String mainPagePatternId)
                                       throws AccessSecurityException
    メインページパターンを取得します。

    ログイングループに属するメインページパターンを取得します。
    ログイングループに属するメインページパターンIDが存在しない場合は、nullを返却します。

    パラメータ:
    groupId - ログイングループID
    mainPagePatternId - メインページパターンID
    戻り値:
    メインページパターン情報
    例外:
    AccessSecurityReadException - メインページパターン情報の取得に失敗した場合、または引数が不正だった場合にスローされます。
    AccessSecurityException

    getMainPagePatternIds

    public String[] getMainPagePatternIds(String groupId)
                               throws AccessSecurityException
    メインページパターンIDの一覧を取得します。

    ログイングループに属するメインパターンIDの一覧を取得します。
    ログイングループに属するメインパターンが一件も存在しない場合は、空の配列を返却します。

    パラメータ:
    groupId - ログイングループID
    戻り値:
    メインページパターンIDの配列
    例外:
    AccessSecurityReadException - メインページパターン情報の取得に失敗した場合にスローされます。
    AccessSecurityException

    getMainPagePatterns

    public MainPagePatternInfo[] getMainPagePatterns(String groupId)
                                          throws AccessSecurityException
    メインページパターンの一覧を取得します。

    ログイングループに属するメインパターンの一覧を取得します。
    ログイングループに属するメインパターンが一件も存在しない場合は、空の配列を返却します。

    パラメータ:
    groupId - ログイングループID
    戻り値:
    メインページパターン情報の配列
    例外:
    AccessSecurityReadException - メインページパターン情報の取得に失敗した場合にスローされます。
    AccessSecurityException

    getSuperUser

    public SuperUser getSuperUser(String groupId)
                       throws AccessSecurityException
    グループ管理者情報を取得します。

    ログイングループに属するグループ管理者を取得します。
    ログイングループに属するグループ管理者が存在しない場合は、nullを返却します。

    パラメータ:
    groupId - ログイングループID
    戻り値:
    グループ管理者情報
    例外:
    AccessSecurityException - グループ管理者情報の取得に失敗した場合にスローされます。

    updateLoginGroup

    public void updateLoginGroup(LoginGroup loginGroup)
                      throws AccessSecurityException
    ログイングループ情報を更新します。

    既に登録されているログイングループを更新します。
    存在しないログイングループに対して、ログイングループの更新はできません。

    パラメータ:
    loginGroup - ログイングループID
    例外:
    AccessSecurityException - ログイングループ情報の更新に失敗した場合にスローされます。

    updateMainPagePattern

    public void updateMainPagePattern(String groupId,
                                  MainPagePatternInfo mainPagePatternInfo)
                           throws AccessSecurityException
    メインページパターンを更新します。

    既に登録されているログイングループに属するメインページパターンを更新します。
    存在しないログイングループに対して、メインページパターンの更新はできません。

    パラメータ:
    groupId - ログイングループID
    mainPagePatternInfo -
    例外:
    AccessSecurityWriteException - メインページパターン情報の更新に失敗した場合、または引数が不正だった場合にスローされます。
    AccessSecurityException

    updateSuperUser

    public void updateSuperUser(String groupId,
                            SuperUser superUser)
                     throws AccessSecurityException
    グループ管理者情報を更新します。

    既に登録されているログイングループに属するグループ管理者を更新します。
    存在しないログイングループに対して、グループ管理者の更新はできません。

    パラメータ:
    groupId - ログイングループID
    superUser - グループ管理者情報
    例外:
    AccessSecurityException - グループ管理者情報の更新に失敗した場合、または引数が不正だった場合にスローされます。
    概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
            intra-mart 6.1.14
    前のクラス 次のクラス フレームあり フレームなし
    概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginGroupPostWriterListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
インタフェース LoginGroupPostWriterListener

既知の実装クラスの一覧:
MainPageImportLoginGroupPostWriterListener
public interface LoginGroupPostWriterListener

ログイングループ情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
LoginGroupManager

メソッドの概要
void | init(Map params) ログイングループ書き込み時（書き込み直前）のリスナの初期化。
void | postCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成した直後にコールされます。
void | postCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成した直後にコールされます。
void | postDeleteLoginGroup(String groupId) ログイングループ情報をデータストアから削除した直後にコールされます。
void | postDeleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターン情報をデータストアから削除した直後にコールされます。
void | postUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新した直後にコールされます。
void | postUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
ログイングループ書き込み時（書き込み直前）のリスナの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreateLoginGroup

public void postCreateLoginGroup(LoginGroup loginGroup)
                          throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアに作成した直後にコールされます。

パラメータ:
loginGroup - 作成されたログイングループ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postCreateMainPagePattern

public void postCreateMainPagePattern(String groupId,
                                      MainPagePatternInfo mainPagePatternInfo)
                               throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - 対象ログイングループID
mainPagePatternInfo - 作成されたメインページパターン情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteLoginGroup

public void postDeleteLoginGroup(String groupId)
                          throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - 削除されたログイングループID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteMainPagePattern

public void postDeleteMainPagePattern(String groupId,
                                      String mainPagePatternId)
                               throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - 対象ログイングループID
mainPagePatternId - 削除されたメインページパターンID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateLoginGroup

public void postUpdateLoginGroup(LoginGroup loginGroup)
                          throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアに更新した直後にコールされます。

パラメータ:
loginGroup - 更新されたログイングループ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateMainPagePattern

public void postUpdateMainPagePattern(String groupId,
                                      MainPagePatternInfo mainPagePatternInfo)
                               throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - 対象ログイングループID
mainPagePatternInfo - 更新されたメインページパターン情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginGroupQueryWriterListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
インタフェース LoginGroupQueryWriterListener

public interface LoginGroupQueryWriterListener

ログイングループ情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
LoginGroupManager

メソッドの概要
void | init(Map params) ログイングループ書き込み時（書き込み直前）のリスナの初期化。
void | queryCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成する直前にコールされます。
void | queryCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成する前にコールされます。
void | queryDeleteLoginGroup(String groupId) ログイングループ情報をデータストアから削除する直前にコールされます。
void | queryDeleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターン情報をデータストアから削除する前にコールされます。
void | queryUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新する直前にコールされます。
void | queryUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新する前にコールされます。

メソッドの詳細

init

public void init(Map params)
ログイングループ書き込み時（書き込み直前）のリスナの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreateLoginGroup

public void queryCreateLoginGroup(LoginGroup loginGroup)
                           throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアに作成する直前にコールされます。

パラメータ:
loginGroup - 作成されるログイングループ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryCreateMainPagePattern

public void queryCreateMainPagePattern(String groupId,
                                       MainPagePatternInfo mainPagePatternInfo)
                                throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアに作成する前にコールされます。

パラメータ:
groupId - 対象ログイングループID
mainPagePatternInfo - 作成されるメインページパターン情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteLoginGroup

public void queryDeleteLoginGroup(String groupId)
                           throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - 削除されるログイングループID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteMainPagePattern

public void queryDeleteMainPagePattern(String groupId,
                                       String mainPagePatternId)
                                throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアから削除する前にコールされます。

パラメータ:
groupId - 対象ログイングループID
mainPagePatternId - 削除されるメインページパターンID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdateLoginGroup

public void queryUpdateLoginGroup(LoginGroup loginGroup)
                           throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアに更新する直前にコールされます。

パラメータ:
loginGroup - 更新されるログイングループ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdateMainPagePattern

public void queryUpdateMainPagePattern(String groupId,
                                       MainPagePatternInfo mainPagePatternInfo)
                                throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアに更新する前にコールされます。

パラメータ:
groupId - 対象ログイングループID
mainPagePatternInfo - 更新されるメインページパターン情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginGroupReaderDecorator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
インタフェース LoginGroupReaderDecorator

public interface LoginGroupReaderDecorator

ログイングループ情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
LoginGroup | doDecoration(LoginGroup loginGroup) ログイングループをデータストアからの読み込み直後にコールされます。
void | init(Map params) ログイングループデコレータの初期化。

メソッドの詳細

init

public void init(Map params)
ログイングループデコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public LoginGroup doDecoration(LoginGroup loginGroup)
ログイングループをデータストアからの読み込み直後にコールされます。

パラメータ:
loginGroup - 読み込みが行われたログイングループ情報
戻り値:
拡張されたログイングループ情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MainPageImportLoginGroupPostWriterListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
クラス MainPageImportLoginGroupPostWriterListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener
すべての実装インタフェース:
LoginGroupPostWriterListener
public class MainPageImportLoginGroupPostWriterListener
extends Object
implements LoginGroupPostWriterListener

ログイングループ作成時にメインページパターンを設定するリスナークラス。

ログイングループ作成時に設定されたメインページパターン情報を追加します。
デフォルトの設定ファイルはストレージサーバ/system/basic/init-main-page.xmlです。
初期化パラメータ(main-page-file)で見込む設定ファイルを変更できます。
初期化パラメータには、ストレージサーバからの相対パスで指定してください。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
MainPageImportLoginGroupPostWriterListener()
コンストラクタ。
メソッドの概要
void | init(Map params) ログイングループ書き込み時（書き込み直前）のリスナの初期化。
void | postCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成した直後にコールされます。
void | postCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成した直後にコールされます。
void | postDeleteLoginGroup(String groupId) ログイングループ情報をデータストアから削除した直後にコールされます。
void | postDeleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターン情報をデータストアから削除した直後にコールされます。
void | postUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新した直後にコールされます。
void | postUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新した直後にコールされます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MainPageImportLoginGroupPostWriterListener

public MainPageImportLoginGroupPostWriterListener()
コンストラクタ。

メソッドの詳細

init

public void init(Map params)
ログイングループ書き込み時（書き込み直前）のリスナの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース LoginGroupPostWriterListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

postCreateLoginGroup

public void postCreateLoginGroup(LoginGroup loginGroup)
                          throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアに作成した直後にコールされます。

定義:
インタフェース LoginGroupPostWriterListener 内の postCreateLoginGroup
パラメータ:
loginGroup - 作成されたログイングループ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postCreateMainPagePattern

public void postCreateMainPagePattern(String groupId,
                                      MainPagePatternInfo mainPagePatternInfo)
                               throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアに作成した直後にコールされます。

定義:
インタフェース LoginGroupPostWriterListener 内の postCreateMainPagePattern
パラメータ:
groupId - 対象ログイングループID
mainPagePatternInfo - 作成されたメインページパターン情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteLoginGroup

public void postDeleteLoginGroup(String groupId)
                          throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアから削除した直後にコールされます。

定義:
インタフェース LoginGroupPostWriterListener 内の postDeleteLoginGroup
パラメータ:
groupId - 削除されたログイングループID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteMainPagePattern

public void postDeleteMainPagePattern(String groupId,
                                      String mainPagePatternId)
                               throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアから削除した直後にコールされます。

定義:
インタフェース LoginGroupPostWriterListener 内の postDeleteMainPagePattern
パラメータ:
groupId - 対象ログイングループID
mainPagePatternId - 削除されたメインページパターンID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateLoginGroup

public void postUpdateLoginGroup(LoginGroup loginGroup)
                          throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアに更新した直後にコールされます。

定義:
インタフェース LoginGroupPostWriterListener 内の postUpdateLoginGroup
パラメータ:
loginGroup - 更新されたログイングループ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateMainPagePattern

public void postUpdateMainPagePattern(String groupId,
                                      MainPagePatternInfo mainPagePatternInfo)
                               throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアに更新した直後にコールされます。

定義:
インタフェース LoginGroupPostWriterListener 内の postUpdateMainPagePattern
パラメータ:
groupId - 対象ログイングループID
mainPagePatternInfo - 更新されたメインページパターン情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MainPagePatternInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
クラス MainPagePatternInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.group.MainPagePatternInfo
すべての実装インタフェース:
Serializable
public class MainPagePatternInfo
extends Object
implements Serializable

メインページパターン情報クラス。

メインページパターン情報を保管するクラス。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
MainPagePatternInfo(String mainPagePatternId)
コンストラクタ。
メソッドの概要
String | getMainPagePatternId() メインページパターンIDを取得する。
String | getMainPagePatternImageUrl() メインページパターンイメージURLを取得する。
String | getMainPagePatternUrl() メインページパターンURLを取得する。
void | setMainPagePatternImageUrl(String mainPagePatternImageUrl) メインページパターンイメージURLを設定する。
void | setMainPagePatternUrl(String mainPagePatternUrl) メインページパターンURLを設定する。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MainPagePatternInfo

public MainPagePatternInfo(String mainPagePatternId)
コンストラクタ。

パラメータ:
mainPagePatternId - メインページパターンID
メソッドの詳細

getMainPagePatternId

public String getMainPagePatternId()
メインページパターンIDを取得する。

戻り値:
メインページパターンID

getMainPagePatternImageUrl

public String getMainPagePatternImageUrl()
メインページパターンイメージURLを取得する。

戻り値:
メインページパターンイメージURL。

getMainPagePatternUrl

public String getMainPagePatternUrl()
メインページパターンURLを取得する。

戻り値:
メインページパターンURL。

setMainPagePatternImageUrl

public void setMainPagePatternImageUrl(String mainPagePatternImageUrl)
メインページパターンイメージURLを設定する。

パラメータ:
mainPagePatternImageUrl - メインページパターンイメージURL。

setMainPagePatternUrl

public void setMainPagePatternUrl(String mainPagePatternUrl)
メインページパターンURLを設定する。

パラメータ:
mainPagePatternUrl - メインページパターンURL。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.group (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.security.group
インタフェース
GroupSuperUserAccessor
GroupSuperUserPostWriterListener
GroupSuperUserQueryWriterListener
GroupSuperUserReaderDecorator
LoginGroupAccessor
LoginGroupPostWriterListener
LoginGroupQueryWriterListener
LoginGroupReaderDecorator
クラス
LoginGroup
LoginGroupManager
MainPageImportLoginGroupPostWriterListener
MainPagePatternInfo


jp.co.intra_mart.foundation.security.group (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.group

グループ管理者に関連するクラスを提供します。

参照:
説明

インタフェースの概要
GroupSuperUserAccessor | グループ管理者アクセッサインタフェース。
GroupSuperUserPostWriterListener | グループ管理者情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
GroupSuperUserQueryWriterListener | グループ管理者情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
GroupSuperUserReaderDecorator | 管理者情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
LoginGroupAccessor | ログイングループアクセッサインタフェース。
LoginGroupPostWriterListener | ログイングループ情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
LoginGroupQueryWriterListener | ログイングループ情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
LoginGroupReaderDecorator | ログイングループ情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

クラスの概要
LoginGroup | ログイングループ・モデル。
LoginGroupManager | ログイングループマネージャクラス。
MainPageImportLoginGroupPostWriterListener | ログイングループ作成時にメインページパターンを設定するリスナークラス。
MainPagePatternInfo | メインページパターン情報クラス。

パッケージ jp.co.intra_mart.foundation.security.group の説明

グループ管理者に関連するクラスを提供します。


jp.co.intra_mart.foundation.security.group クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.group の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.group.LoginGroup (implements jp.co.intra_mart.foundation.security.LocaleProvider, java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.group.LoginGroupManager
    • class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener (implements jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener)
    • class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo (implements java.io.Serializable)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor
  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener
  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator


パッケージ jp.co.intra_mart.foundation.security.group の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.group の使用

jp.co.intra_mart.foundation.security.group を使用しているパッケージ
jp.co.intra_mart.foundation.security.group グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.group により使用される jp.co.intra_mart.foundation.security.group のクラス
LoginGroup
ログイングループ・モデル。
LoginGroupManager
ログイングループマネージャクラス。
LoginGroupPostWriterListener
ログイングループ情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
MainPagePatternInfo
メインページパターン情報クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.license.ApplicationInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.license.ApplicationInfo の使用

ApplicationInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security.license ライセンスに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.license での ApplicationInfo の使用

ApplicationInfo を返す jp.co.intra_mart.foundation.security.license のメソッド
static ApplicationInfo | LicenseManager.getApplication(String applicaionId) アプリケーション情報を取得します。
static ApplicationInfo[] | LicenseManager.getApplications() アプリケーション情報の一覧を取得します。
static ApplicationInfo | LicenseManager.getProduct() システム情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.license.LicenseManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.license.LicenseManager の使用

jp.co.intra_mart.foundation.security.license.LicenseManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ApplicationInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.license
インタフェース ApplicationInfo

public interface ApplicationInfo

アプリケーション情報のインタフェース。

インストールされているアプリケーションの情報を提供するインタフェース

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
long | getExpiredDate() 試用期限の日付を取得します。
long | getInstallDate() インストールされた日付を取得します。
double | getLicense() アプリケーションライセンスが登録されているアカウント数を取得する。
String[] | getLicenseKeys() ライセンス・キーの取得 ライセンス・キーが登録されていない場合は、空の配列を返却します。
long | getLimitedDate() 使用期限の日付を取得します。
double | getMaxLicense() アプリケーションの最大登録可能なラインセンス数を取得します。
double | getMaxProcess() アプリケーションランタイムの最大使用可能なラインセンス数を取得します。
String | getName() アプリケーション名を取得します。
String | getPackageVersion() パッケージバージョンを取得します。
String[] | getProperties(String key) インストール情報を取得します。
String | getProperty(String key) インストール情報を取得します。
Integer[] | getSerialNumbers() シリアル番号の取得 ライセンス・キーが登録されていない場合は、空の配列を返却します。
Locale[] | getTargetLocales() 対象ロケールの取得。
String | getType() アプリケーションタイプを取得します。
String | getVersion() バージョンを取得します。
boolean | isExpired() 試用期限が切れているかどうかを判定します。
boolean | isFree() ライセンスフリーであるかどうかを判定します。
boolean | isLimited() 期限付きライセンスであるかどうかを判定します。
boolean | isTrial() 試用版であるかどうかを判定します。

メソッドの詳細

getLicenseKeys

public String[] getLicenseKeys()
ライセンス・キーの取得
ライセンス・キーが登録されていない場合は、空の配列を返却します。

戻り値:
ライセンス・キー。

getName

public String getName()
アプリケーション名を取得します。

戻り値:
アプリケーション名

getType

public String getType()
アプリケーションタイプを取得します。

戻り値:
アプリケーションタイプ

getVersion

public String getVersion()
バージョンを取得します。

戻り値:
バージョン

getPackageVersion

public String getPackageVersion()
パッケージバージョンを取得します。

戻り値:
パッケージバージョン

getSerialNumbers

public Integer[] getSerialNumbers()
シリアル番号の取得
ライセンス・キーが登録されていない場合は、空の配列を返却します。

戻り値:
シリアル番号。

getMaxProcess

public double getMaxProcess()
アプリケーションランタイムの最大使用可能なラインセンス数を取得します。
無制限の場合は Double.POSITIVE_INFINITYを返します。

戻り値:
アプリケーションランタイムの最大使用可能なラインセンス数

getMaxLicense

public double getMaxLicense()
アプリケーションの最大登録可能なラインセンス数を取得します。
無制限の場合は Double.POSITIVE_INFINITYを返します。

戻り値:
アプリケーションの最大登録可能なライセンス数

isTrial

public boolean isTrial()
試用版であるかどうかを判定します。

戻り値:
true : 試用版 / false : 製品版

isFree

public boolean isFree()
ライセンスフリーであるかどうかを判定します。

戻り値:
true : ライセンスフリー / false : ライセンス必須

isExpired

public boolean isExpired()
試用期限が切れているかどうかを判定します。

戻り値:
true : 試用期限が切れている / false : 試用期限内

isLimited

public boolean isLimited()
期限付きライセンスであるかどうかを判定します。

戻り値:
true : 期限付きライセンス / false : 通常ライセンス

getInstallDate

public long getInstallDate()
インストールされた日付を取得します。
単位はミリ秒で返却します。

戻り値:
インストールされた日付（ミリ秒）

getExpiredDate

public long getExpiredDate()
試用期限の日付を取得します。
単位はミリ秒で返却します。

戻り値:
試用期限の日付（ミリ秒）

getLimitedDate

public long getLimitedDate()
使用期限の日付を取得します。
単位はミリ秒で返却します。

戻り値:
使用期限の日付（ミリ秒）

getProperty

public String getProperty(String key)
インストール情報を取得します。

パラメータ:
key - インストール情報のキー
戻り値:
キーに対応するインストール情報

getProperties

public String[] getProperties(String key)
インストール情報を取得します。

パラメータ:
key - インストール情報のキー
戻り値:
キーに対応するインストール情報の配列

getLicense

public double getLicense()
アプリケーションライセンスが登録されているアカウント数を取得する。

戻り値:
登録されているアカウント数

getTargetLocales

public Locale[] getTargetLocales()
対象ロケールの取得。
言語パックライセンスが登録されていない場合は、空の配列を返却します。

戻り値:
対象ロケール。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LicenseManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.license
クラス LicenseManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.license.LicenseManager
public final class LicenseManager
extends Object

ライセンス・マネージャクラス。 イントラマートのライセンスを管理するマネージャクラスを定義します

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
ApplicationInfo

コンストラクタの概要
LicenseManager(String groupId)
コンストラクタ。
メソッドの概要
void | deleteAccountLicense(String userId) 指定されたユーザのライセンスを削除します。
void | deleteApplicationLicenseFromAccount(String userId, String applicationId) アプリケーションライセンスをアカウントから削除します。
static ApplicationInfo | getApplication(String applicaionId) アプリケーション情報を取得します。
static double | getApplicationLicense(String applicaionId) アプリケーションの登録ユーザ数を取得します。
static ApplicationInfo[] | getApplications() アプリケーション情報の一覧を取得します。
double | getLicense() グループ内で登録されているライセンス数を取得します。
double | getMaxLicense() ログイングループ内の最大登録可能ライセンス数を取得します。
static ApplicationInfo | getProduct() システム情報を取得します。
String[] | getRegisteredAccountLicenses() ログイングループにライセンス登録されているすべてのユーザIDを返します。
String[] | getRegisteredApplicationLicensesToAccount(String userId) アカウントに登録されているアプリケーションライセンスの一覧を取得します。
static double | getSystemLicense() システム全体の登録ライセンス数。
static double | getSystemMaxLicense() システム全体のライセンス数。
boolean | isRegisteredAccountLicense(String userId) 指定されたユーザがライセンスに登録されているかどうかをチェックします。
boolean | isRegisteredApplicationLicenseToAccount(String userId, String applicationId) アカウントにアプリケーションライセンスが登録されてるか検証します。
boolean | registerAccountLicense(String userId) ライセンス登録します。
boolean | registerApplicationLicenseToAccount(String userId, String applicationId) アプリケーションライセンスをアカウントに登録します。
boolean | setMaxLicense(double maxLicense) ログイングループ内の最大登録可能ライセンス数を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LicenseManager

public LicenseManager(String groupId)
               throws AccessSecurityException
コンストラクタ。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityException - 引数が不正だった場合にスローされます。
メソッドの詳細

getApplication

public static ApplicationInfo getApplication(String applicaionId)
                                      throws AccessSecurityException
アプリケーション情報を取得します。
引数に指定されたアプリケーションの情報を取得します。

パラメータ:
applicaionId - アプリケーションID
戻り値:
アプリケーション情報
指定したアプリケーションが存在しない場合はnullを返します。
例外:
AccessSecurityException - アプリケーション情報の取得に失敗した場合にスローされます。

getApplicationLicense

public static double getApplicationLicense(String applicaionId)
                                    throws AccessSecurityException
アプリケーションの登録ユーザ数を取得します。

引数に指定されたアプリケーションIDを持つユーザの数を取得します。

パラメータ:
applicaionId - アプリケーションID
戻り値:
アプリケーションIDを持つユーザの数
指定したアプリケーションが存在しない場合は0
例外:
AccessSecurityException

getApplications

public static ApplicationInfo[] getApplications()
                                         throws AccessSecurityException
アプリケーション情報の一覧を取得します。

戻り値:
アプリケーション情報の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getProduct

public static ApplicationInfo getProduct()
                                  throws AccessSecurityException
システム情報を取得します。

戻り値:
ApplicationInfo システム情報
システム情報の取得に失敗した場合はnull システム情報の取得に失敗した場合にスローされます。
例外:
AccessSecurityException

getSystemLicense

public static double getSystemLicense()
                               throws AccessSecurityException
システム全体の登録ライセンス数。

戻り値:
システム全体の登録ライセンス数
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getSystemMaxLicense

public static double getSystemMaxLicense()
                                  throws AccessSecurityException
システム全体のライセンス数。
無制限の場合は Double.POSITIVE_INFINITYを返します。

戻り値:
システム全体のライセンス数
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

deleteAccountLicense

public void deleteAccountLicense(String userId)
                          throws AccessSecurityException
指定されたユーザのライセンスを削除します。

パラメータ:
userId - ユーザID
例外:
AccessSecurityException - 引数が不正だった場合、または書き込み処理に失敗した場合にスローされます。

deleteApplicationLicenseFromAccount

public void deleteApplicationLicenseFromAccount(String userId,
                                                String applicationId)
                                         throws AccessSecurityException
アプリケーションライセンスをアカウントから削除します。

パラメータ:
userId - ユーザID
applicationId - アプリケーションID
例外:
AccessSecurityException - 引数が不正だった場合、または書き込み処理に失敗した場合にスローされます。

getLicense

public double getLicense()
                  throws AccessSecurityException
グループ内で登録されているライセンス数を取得します。

戻り値:
登録ライセンス数
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getMaxLicense

public double getMaxLicense()
                     throws AccessSecurityException
ログイングループ内の最大登録可能ライセンス数を取得します。
無制限の場合は Double.POSITIVE_INFINITYを返します。

戻り値:
最大登録可能ライセンス数
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getRegisteredAccountLicenses

public String[] getRegisteredAccountLicenses()
                                      throws AccessSecurityException
ログイングループにライセンス登録されているすべてのユーザIDを返します。

戻り値:
ユーザID配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getRegisteredApplicationLicensesToAccount

public String[] getRegisteredApplicationLicensesToAccount(String userId)
                                                   throws AccessSecurityException
アカウントに登録されているアプリケーションライセンスの一覧を取得します。

パラメータ:
userId - ユーザID
戻り値:
アカウントに登録されているアプリケーションライセンスの一覧
例外:
AccessSecurityException - 引数が不正だった場合、または読み込み処理に失敗した場合にスローされます。

isRegisteredAccountLicense

public boolean isRegisteredAccountLicense(String userId)
                                   throws AccessSecurityException
指定されたユーザがライセンスに登録されているかどうかをチェックします。

パラメータ:
userId - ユーザID
戻り値:
true:登録されている場合 false:登録されていない場合
例外:
AccessSecurityException - 引数が不正だった場合、または読み込み処理に失敗した場合にスローされます。

isRegisteredApplicationLicenseToAccount

public boolean isRegisteredApplicationLicenseToAccount(String userId,
                                                       String applicationId)
                                                throws AccessSecurityException
アカウントにアプリケーションライセンスが登録されてるか検証します。

パラメータ:
userId - ユーザID
applicationId - アプリケーションID
戻り値:
true:登録されている場合 false:登録されていない場合
例外:
AccessSecurityException - 引数が不正だった場合、または読み込み処理に失敗した場合にスローされます。

registerAccountLicense

public boolean registerAccountLicense(String userId)
                               throws AccessSecurityException
ライセンス登録します。
指定されたユーザIDとコンストラクタで指定したログイングループIDでライセンス登録をします。
最大登録可能ライセンス数とログイングループ内最大登録可能ライセンス数を調査して これを超えた場合はエラーとします。

パラメータ:
userId - ユーザID
戻り値:
true：処理成功 false：処理失敗
例外:
AccessSecurityException - 引数が不正だった場合、または書き込み処理に失敗した場合にスローされます。

registerApplicationLicenseToAccount

public boolean registerApplicationLicenseToAccount(String userId,
                                                   String applicationId)
                                            throws AccessSecurityException
アプリケーションライセンスをアカウントに登録します。

すでに登録されているアプリケーション最大登録可能ライセンス数と合わせて
最大登録可能ライセンス数を超えた場合はエラーとします。

パラメータ:
userId - ユーザID
applicationId - アプリケーションID
戻り値:
true：処理成功 false：処理失敗
例外:
AccessSecurityException - 引数が不正だった場合、または書き込み処理に失敗した場合にスローされます。

setMaxLicense

public boolean setMaxLicense(double maxLicense)
                      throws AccessSecurityException
ログイングループ内の最大登録可能ライセンス数を設定します。

すでに登録されているログイングループ内最大登録可能ライセンス数の合計と合わせて
最大登録可能ライセンス数を超えた場合はエラーとします。

パラメータ:
maxLicense - 最大登録可能ライセンス数
戻り値:
true：処理成功 false：処理失敗
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.license (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.security.license
インタフェース
ApplicationInfo
クラス
LicenseManager


jp.co.intra_mart.foundation.security.license (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.license

ライセンスに関連するクラスを提供します。

参照:
説明

インタフェースの概要
ApplicationInfo アプリケーション情報のインタフェース。

クラスの概要
LicenseManager ライセンス・マネージャクラス。

パッケージ jp.co.intra_mart.foundation.security.license の説明

ライセンスに関連するクラスを提供します。


jp.co.intra_mart.foundation.security.license クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.license の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.license.LicenseManager

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.license.ApplicationInfo


パッケージ jp.co.intra_mart.foundation.security.license の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.license の使用

jp.co.intra_mart.foundation.security.license を使用しているパッケージ
jp.co.intra_mart.foundation.security.license ライセンスに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.license により使用される jp.co.intra_mart.foundation.security.license のクラス
ApplicationInfo
アプリケーション情報のインタフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor の使用

jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.AdminMenuExporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.AdminMenuExporter の使用

AdminMenuExporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での AdminMenuExporter の使用

AdminMenuExporter を実装している jp.co.intra_mart.foundation.security.menu のクラス
 class StandardAdminMenuBackup
メニューバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.AdminMenuImporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.AdminMenuImporter の使用

AdminMenuImporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での AdminMenuImporter の使用

AdminMenuImporter を実装している jp.co.intra_mart.foundation.security.menu のクラス
 class StandardAdminMenuBackup
メニューバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion の使用

jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.AdminMenuManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.AdminMenuManager の使用

AdminMenuManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での AdminMenuManager の使用

AdminMenuManager を返す jp.co.intra_mart.foundation.security.menu のメソッド
static AdminMenuManager AdminMenuManager.getInstance()
ログイングループマネージャのインスタンスを取得します。

AdminMenuManager 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | AdminMenuImporter.doImport(InputStream inputStream, AdminMenuManager manager) インポートを行います。
void | AdminMenuExporter.doExport(AdminMenuManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardAdminMenuBackup.doImport(InputStream inputStream, AdminMenuManager manager) インポートを行います。
void | StandardAdminMenuBackup.doExport(AdminMenuManager manager, OutputStream outputStream) エクスポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener の使用

jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener の使用

jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator の使用

jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener の使用

jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.MenuAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.MenuAccessor の使用

MenuAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での MenuAccessor の使用

MenuAccessor を実装している jp.co.intra_mart.foundation.security のクラス
 class StandardMenuAccessor
メニューアクセッサクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.MenuExporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.MenuExporter の使用

MenuExporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での MenuExporter の使用

MenuExporter を実装している jp.co.intra_mart.foundation.security.menu のクラス
 class StandardMenuBackup
メニューバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.MenuImporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.MenuImporter の使用

MenuImporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での MenuImporter の使用

MenuImporter を実装している jp.co.intra_mart.foundation.security.menu のクラス
 class StandardMenuBackup
メニューバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.MenuInclusion の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.MenuInclusion の使用

MenuInclusion を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での MenuInclusion の使用

MenuInclusion を返す jp.co.intra_mart.foundation.security のメソッド
 MenuInclusion[] StandardMenuAccessor.getMenuInclusions(String groupId)
すべてのメニュー構成を取得します。

MenuInclusion 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | StandardMenuAccessor.deleteMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を削除します。
void | StandardMenuAccessor.insertMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を新規に作成します。

jp.co.intra_mart.foundation.security.menu での MenuInclusion の使用

MenuInclusion を返す jp.co.intra_mart.foundation.security.menu のメソッド
MenuInclusion[] | MenuAccessor.getMenuInclusions(String groupId) すべてのメニュー構成を取得します。
MenuInclusion[] | AdminMenuAccessor.getMenuInclusions() すべてのメニュー構成を取得します。

MenuInclusion 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuManager.moveMenuItem(MenuInclusion menuInclusion) メニューを移動します。
void | MenuAccessor.deleteMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を削除します。
void | MenuAccessor.insertMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を新規に作成します。
void | AdminMenuManager.moveMenuItem(MenuInclusion menuInclusion) メニューを移動します。
void | AdminMenuAccessor.deleteMenuInclusion(MenuInclusion menuInclusion) メニュー構成を削除します。
void | AdminMenuAccessor.insertMenuInclusion(MenuInclusion menuInclusion) メニュー構成を新規に作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.MenuItem の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.MenuItem の使用

MenuItem を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での MenuItem の使用

MenuItem を返す jp.co.intra_mart.foundation.security のメソッド
MenuItem[] | SystemManager.getSystemMenu() システムメニューを取得します。
MenuItem | StandardMenuAccessor.getMenuItem(String groupId, String menuId) 指定されたメニューIDに対するノードを取得します。
MenuItem[] | StandardMenuAccessor.getMenuItems(String groupId) すべてのノードを取得します。
MenuItem[] | StandardMenuAccessor.getMenuItemsByIds(String groupId, String[] menuIds) 指定されたメニューIDのメニュー情報をすべて取得します。

MenuItem 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | StandardMenuAccessor.insertMenuItem(String groupId, MenuItem menuItem, String parentId) 引数で渡されたノードを新規追加します。
void | StandardMenuAccessor.updateMenuItem(String groupId, MenuItem menuItem) 引数で渡されたノードを更新します。

jp.co.intra_mart.foundation.security.menu での MenuItem の使用

MenuItem を返す jp.co.intra_mart.foundation.security.menu のメソッド
MenuItem | MenuTree.getMenuItem() メニューを取得します。
MenuItem | MenuReaderDecorator.doDecoration(String groupId, MenuItem item) メニューデータストアからの読み込み直後にコールされます。
MenuItem | MenuManager.getMenuItem(String menuId) 指定されたメニューIDに対応するメニューを取得します。
MenuItem[] | MenuManager.getMenuItems() すべてのメニューを取得します。
MenuItem[] | MenuManager.getMenuItemsByIds(String[] menuIds) ログイングループ内で引数指定したメニューIDのメニュー情報をすべて取得します。
MenuItem | MenuAccessor.getMenuItem(String groupId, String menuId) 指定されたメニューIDに対するノードを取得します。
MenuItem[] | MenuAccessor.getMenuItems(String groupId) すべてのノードを取得します。
MenuItem[] | MenuAccessor.getMenuItemsByIds(String groupId, String[] menuIds) 指定されたユーザIDのメニュー情報をすべて取得します。
MenuItem | AdminMenuReaderDecorator.doDecoration(MenuItem item) メニューデータストアからの読み込み直後にコールされます。
MenuItem | AdminMenuManager.getMenuItem(String menuId) 指定されたメニューIDに対応するメニューを取得します。
MenuItem[] | AdminMenuManager.getMenuItems() すべてのメニューを取得します。
MenuItem[] | AdminMenuManager.getMenuItemsByIds(String[] menuIds) 引き数に指定したメニューIDに一致するメニューアイテムの一覧を取得します。
MenuItem | AdminMenuAccessor.getMenuItem(String menuId) 指定されたメニューIDに対するノードを取得します。
MenuItem[] | AdminMenuAccessor.getMenuItems() すべてのノードを取得します。
MenuItem[] | AdminMenuAccessor.getMenuItemsByIds(String[] menuIds) 管理メニューIDの一覧からメニューアイテムを取得します。

MenuItem 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
MenuItem | MenuReaderDecorator.doDecoration(String groupId, MenuItem item) メニューデータストアからの読み込み直後にコールされます。
void | MenuQueryWriterListener.queryCreate(String groupId, MenuItem item) メニュー情報をデータストアに作成する直前にコールされます。
void | MenuQueryWriterListener.queryUpdate(String groupId, MenuItem item) メニュー情報をデータストアに更新する直前にコールされます。
void | MenuPostWriterListener.postCreate(String groupId, MenuItem item) メニュー情報をデータストアに作成した直後にコールされます。
void | MenuPostWriterListener.postUpdate(String groupId, MenuItem item) メニュー情報をデータストアに更新した直後にコールされます。
void | MenuManager.addMenuItem(String parentMenuId, MenuItem menuItem) メニューを追加します。
void | MenuManager.updateMenuItem(MenuItem menuItem) メニューを更新します。
void | MenuAccessor.insertMenuItem(String groupId, MenuItem menuItem, String parentId) 引数で渡されたノードを新規追加します。
void | MenuAccessor.updateMenuItem(String groupId, MenuItem menuItem) 引数で渡されたノードを更新します。
MenuItem | AdminMenuReaderDecorator.doDecoration(MenuItem item) メニューデータストアからの読み込み直後にコールされます。
void | AdminMenuQueryWriterListener.queryCreate(MenuItem item) メニュー情報をデータストアに作成する直前にコールされます。
void | AdminMenuQueryWriterListener.queryUpdate(MenuItem item) メニュー情報をデータストアに更新する直前にコールされます。
void | AdminMenuPostWriterListener.postCreate(MenuItem item) メニュー情報をデータストアに作成した直後にコールされます。
void | AdminMenuPostWriterListener.postUpdate(MenuItem item) メニュー情報をデータストアに更新した直後にコールされます。
void | AdminMenuManager.addMenuItem(String parentMenuId, MenuItem menuItem) メニューを追加します。
void | AdminMenuManager.updateMenuItem(MenuItem menuItem) メニューを更新します。
void | AdminMenuAccessor.insertMenuItem(MenuItem menuItem, String parentId) 引数で渡されたノードを新規追加します。
void | AdminMenuAccessor.updateMenuItem(MenuItem menuItem) 引数で渡されたノードを更新します。

MenuItem 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のコンストラクタ
MenuTree(MenuItem menuItem)
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.MenuManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.MenuManager の使用

MenuManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での MenuManager の使用

MenuManager 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuImporter.doImport(InputStream inputStream, MenuManager manager) インポートを行います。
void | MenuExporter.doExport(MenuManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardMenuBackup.doImport(InputStream inputStream, MenuManager manager) インポートを行います。
void | StandardMenuBackup.doExport(MenuManager manager, OutputStream outputStream) エクスポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener の使用

jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener の使用

jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator の使用

jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.MenuTree の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.MenuTree の使用

MenuTree を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での MenuTree の使用

MenuTree を返す jp.co.intra_mart.foundation.security.menu のメソッド
MenuTree[] | MenuTree.getChildren() 子メニューの一覧を取得します。
MenuTree[] | MenuManager.getAccountMenuTree(String userId, String clientType) 指定したアカウントのメニュー構成を取得します。
MenuTree[] | MenuManager.getMenuTree() メニュー構成を取得します。
MenuTree[] | MenuManager.getMenuTree(String clientType) 指定されたクライアントタイプのみのメニュー構成を取得します。
MenuTree[] | MenuManager.getMenuTree(String clientType, String[] menuIds, boolean showNoChildFolder) 指定されたクライアントタイプと指定されたメニューIDのみのメニュー構成を取得します。
MenuTree[] | AdminMenuManager.getMenuTree() メニュー構成を取得します。
MenuTree[] | AdminMenuManager.getMenuTree(String groupId) 引数に指定したログイングループのメニュー構成を取得します。

MenuTree 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
 void MenuTree.addChild(MenuTree menuTree)
子メニューを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener の使用

jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener の使用

jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup の使用

jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.StandardMenuBackup の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.StandardMenuBackup の使用

jp.co.intra_mart.foundation.security.menu.StandardMenuBackup はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AdminMenuAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース AdminMenuAccessor

public interface AdminMenuAccessor

メニューアクセッサインタフェース。

メニュー情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | addMenuLoginGroup(String menuId, String groupId) 管理メニューにアクセス権を設定します。
void | deleteMenuInclusion(MenuInclusion menuInclusion) メニュー構成を削除します。
void | deleteMenuItem(String menuId) 引数で渡されたノードを削除します。
void | deleteMenuLoginGroup(String menuId, String groupId) 管理メニューに設定されているアクセス権を削除します。
String[] | getChildMenuIds(String menuId) 引数で指定されたノードの直下の子ノードを配列で取得します。
String[] | getFirstMenuIds() 第一階層に属するノードを配列で取得します。
String[] | getMenuIds() すべてのメニューIDを取得します。
String[] | getMenuIdsByLoginGroup(String groupId) ログイングループがアクセス可能な管理メニューIDの一覧を取得します。
MenuInclusion[] | getMenuInclusions() すべてのメニュー構成を取得します。
MenuItem | getMenuItem(String menuId) 指定されたメニューIDに対するノードを取得します。
MenuItem[] | getMenuItems() すべてのノードを取得します。
MenuItem[] | getMenuItemsByIds(String[] menuIds) 管理メニューIDの一覧からメニューアイテムを取得します。
String[] | getMenuLoginGroups(String menuId) 管理メニューにアクセス可能なログイングループの一覧を取得します。
String | getParentMenuId(String menuId) 引数で指定されたノードの親ノードを取得します。
void | init(Map params) メニューアクセッサの初期化。
void | insertMenuInclusion(MenuInclusion menuInclusion) メニュー構成を新規に作成します。
void | insertMenuItem(MenuItem menuItem, String parentId) 引数で渡されたノードを新規追加します。
boolean | isAccessControlEnabled(String menuId) メニューアイテムのアクセス権の有無を取得します。
void | setAccessControlEnabled(String menuId, boolean accessControl) メニューアイテムに対するアクセス権を設定します。
void | updateMenuItem(MenuItem menuItem) 引数で渡されたノードを更新します。

メソッドの詳細

deleteMenuInclusion

public void deleteMenuInclusion(MenuInclusion menuInclusion)
                         throws AccessSecurityWriteException
メニュー構成を削除します。

パラメータ:
menuInclusion - メニュー構成
例外:
AccessSecurityWriteException

deleteMenuItem

public void deleteMenuItem(String menuId)
                    throws AccessSecurityWriteException
引数で渡されたノードを削除します。

パラメータ:
menuId - メニューID
例外:
AccessSecurityWriteException

getChildMenuIds

public String[] getChildMenuIds(String menuId)
                         throws AccessSecurityReadException
引数で指定されたノードの直下の子ノードを配列で取得します。

パラメータ:
menuId - メニューID
戻り値:
子メニューIDの配列
例外:
AccessSecurityReadException

getFirstMenuIds

public String[] getFirstMenuIds()
                         throws AccessSecurityReadException
第一階層に属するノードを配列で取得します。

戻り値:
第一階層のメニューIDの配列
例外:
AccessSecurityReadException

getMenuIds

public String[] getMenuIds()
                    throws AccessSecurityReadException
すべてのメニューIDを取得します。

戻り値:
メニューIDの配列
例外:
AccessSecurityReadException

getMenuInclusions

public MenuInclusion[] getMenuInclusions()
                                  throws AccessSecurityReadException
すべてのメニュー構成を取得します。

戻り値:
メニュー構成の配列
例外:
AccessSecurityReadException

getMenuItem

public MenuItem getMenuItem(String menuId)
                     throws AccessSecurityReadException
指定されたメニューIDに対するノードを取得します。

パラメータ:
menuId - メニューID
戻り値:
ノード
例外:
AccessSecurityReadException

getMenuItems

public MenuItem[] getMenuItems()
                        throws AccessSecurityReadException
すべてのノードを取得します。

戻り値:
ノード配列
例外:
AccessSecurityReadException

getParentMenuId

public String getParentMenuId(String menuId)
                       throws AccessSecurityReadException
引数で指定されたノードの親ノードを取得します。

パラメータ:
menuId - メニューID
戻り値:
親メニューID
例外:
AccessSecurityReadException

init

public void init(Map params)
メニューアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

insertMenuInclusion

public void insertMenuInclusion(MenuInclusion menuInclusion)
                         throws AccessSecurityWriteException
メニュー構成を新規に作成します。

パラメータ:
menuInclusion - メニュー構成
例外:
AccessSecurityWriteException

insertMenuItem

public void insertMenuItem(MenuItem menuItem,
                           String parentId)
                    throws AccessSecurityWriteException
引数で渡されたノードを新規追加します。

パラメータ:
menuItem - メニューID
parentId -
例外:
AccessSecurityWriteException

updateMenuItem

public void updateMenuItem(MenuItem menuItem)
                    throws AccessSecurityWriteException
引数で渡されたノードを更新します。

パラメータ:
menuItem - メニュー
例外:
AccessSecurityWriteException

getMenuIdsByLoginGroup

public String[] getMenuIdsByLoginGroup(String groupId)
                                throws AccessSecurityReadException
ログイングループがアクセス可能な管理メニューIDの一覧を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
管理メニューIDの一覧
例外:
AccessSecurityReadException - メニューID取得時に例外が発生
導入されたバージョン:
5.1

getMenuItemsByIds

public MenuItem[] getMenuItemsByIds(String[] menuIds)
                             throws AccessSecurityReadException
管理メニューIDの一覧からメニューアイテムを取得します。

パラメータ:
menuIds - 管理メニューIDの一覧
戻り値:
メニューアイテムの一覧
例外:
AccessSecurityReadException - メニューアイテム取得時に例外が発生
導入されたバージョン:
5.1

addMenuLoginGroup

public void addMenuLoginGroup(String menuId,
                              String groupId)
                       throws AccessSecurityWriteException
管理メニューにアクセス権を設定します。

パラメータ:
menuId - 管理メニューID
groupId - ログイングループID
例外:
AccessSecurityWriteException - アクセス権設定時に例外が発生
導入されたバージョン:
5.1

deleteMenuLoginGroup

public void deleteMenuLoginGroup(String menuId,
                                 String groupId)
                          throws AccessSecurityWriteException
管理メニューに設定されているアクセス権を削除します。

パラメータ:
menuId - 管理メニューID
groupId - ログイングループID
例外:
AccessSecurityWriteException - アクセス権削除時に例外が発生
導入されたバージョン:
5.1

getMenuLoginGroups

public String[] getMenuLoginGroups(String menuId)
                            throws AccessSecurityReadException
管理メニューにアクセス可能なログイングループの一覧を取得します。

パラメータ:
menuId - 管理メニューID
例外:
AccessSecurityReadException - アクセス権取得時に例外が発生
導入されたバージョン:
5.1

setAccessControlEnabled

public void setAccessControlEnabled(String menuId,
                                    boolean accessControl)
                             throws AccessSecurityWriteException
メニューアイテムに対するアクセス権を設定します。 アクセス権を有効にすると、ログイングループ毎にアクセス制限を設定可能です。 未設定の場合はアクセス制限を行いません。

パラメータ:
menuId - メニューID
accessControl - true/有効、false/無効
例外:
AccessSecurityWriteException - アクセス権限設定時に例外が発生

isAccessControlEnabled

public boolean isAccessControlEnabled(String menuId)
                               throws AccessSecurityReadException
メニューアイテムのアクセス権の有無を取得します。

パラメータ:
menuId - メニューID
戻り値:
true/有効、false/無効
例外:
AccessSecurityReadException - アクセス権限取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AdminMenuExporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース AdminMenuExporter

既知の実装クラスの一覧:
StandardAdminMenuBackup
public interface AdminMenuExporter

メニューエクスポートインタフェースです。

バージョン:
1.0

メソッドの概要
void | doExport(AdminMenuManager manager, OutputStream outputStream) エクスポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doExport

public void doExport(AdminMenuManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

メニュー情報をバックアップファイルに出力します。

パラメータ:
manager - メニューマネージャ
outputStream - 出力ストリーム
例外:
AccessSecurityExportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AdminMenuImporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース AdminMenuImporter

既知の実装クラスの一覧:
StandardAdminMenuBackup
public interface AdminMenuImporter

メニューインポートインタフェースです。

バージョン:
1.0

メソッドの概要
void | doImport(InputStream inputStream, AdminMenuManager manager) インポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doImport

public void doImport(InputStream inputStream,
                     AdminMenuManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からメニュー情報を取得し、生成します。

パラメータ:
manager - メニューマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AdminMenuInclusion (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス AdminMenuInclusion

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion
すべての実装インタフェース:
Serializable
public class AdminMenuInclusion
extends Object
implements Serializable

メニュー内包情報クラス。

メニューの親子関係を保持するクラスです。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
AdminMenuInclusion(String parentMenuId, String childMenuId)
コンストラクタ。
メソッドの概要
String | getChildMenuId() 子メニューIDを取得します。
String | getParentMenuId() 親メニューIDを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AdminMenuInclusion

public AdminMenuInclusion(String parentMenuId,
                          String childMenuId)
コンストラクタ。

メソッドの詳細

getChildMenuId

public String getChildMenuId()
子メニューIDを取得します。

戻り値:
子メニューID

getParentMenuId

public String getParentMenuId()
親メニューIDを取得します。

戻り値:
親メニューID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AdminMenuManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス AdminMenuManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.AdminMenuManager
public final class AdminMenuManager
extends Object

管理メニューマネージャクラス。

グループ管理者が利用する管理メニュー情報の操作を行います。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | addMenuItem(String parentMenuId, MenuItem menuItem) メニューを追加します。
void | addMenuLoginGroup(String menuId, String groupId) 指定したログイングループのアクセス権をメニューに設定します。
static void | clearInstance() ログイングループマネージャのインスタンスを初期化します。
void | deleteMenuItem(String menuId) メニューを削除します。
void | deleteMenuItems() すべてのメニューを削除します。
void | deleteMenuLoginGroup(String menuId, String groupId) 指定したログイングループのアクセス権をメニューから削除します。
void | exportData(String category, OutputStream outputStream) メニュー情報・エクスポート。
String[] | getChildMenuIds(String menuId) 子メニューIDを取得します。
String[] | getExportCategories() 管理メニューエクスポート用のカテゴリの一覧を取得します。
String[] | getFirstMenuIds() 第一階層のメニューIDをすべて取得します。
String[] | getImportCategories() 管理メニューインポート用のカテゴリの一覧を取得します。
static AdminMenuManager | getInstance() ログイングループマネージャのインスタンスを取得します。
String[] | getMenuIds() すべてのメニューIDを取得します。
String[] | getMenuIdsByLoginGroup(String groupId) 引き数に指定したログイングループが参照可能なメニューIDの一覧を取得します。
MenuItem | getMenuItem(String menuId) 指定されたメニューIDに対応するメニューを取得します。
MenuItem[] | getMenuItems() すべてのメニューを取得します。
MenuItem[] | getMenuItemsByIds(String[] menuIds) 引き数に指定したメニューIDに一致するメニューアイテムの一覧を取得します。
String[] | getMenuLoginGroups(String menuId) 引数に指定したメニューを参照可能なログイングループIDの一覧を取得します。
MenuTree[] | getMenuTree() メニュー構成を取得します。
MenuTree[] | getMenuTree(String groupId) 引数に指定したログイングループのメニュー構成を取得します。
String | getParentMenuId(String menuId) 指定されたメニューの親メニューを取得します。
void | importData(String category, InputStream inputStream) メニュー情報・インポート。
boolean | isAccessControlEnabled(String menuId) メニューアイテムのアクセス権の有無を取得します。
void | moveMenuItem(MenuInclusion menuInclusion) メニューを移動します。
void | setAccessControlEnabled(String menuId, boolean accessControl) メニューアイテムに対するアクセス権を設定します。
void | updateMenuItem(MenuItem menuItem) メニューを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

clearInstance

public static void clearInstance()
ログイングループマネージャのインスタンスを初期化します。

アクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。
通常、このメソッドを使用する必要はありません。

getInstance

public static AdminMenuManager getInstance()
ログイングループマネージャのインスタンスを取得します。

戻り値:
ログイングループマネージャのインスタンス

addMenuItem

public void addMenuItem(String parentMenuId,
                        MenuItem menuItem)
                 throws AccessSecurityException
メニューを追加します。

パラメータ:
parentMenuId - 親メニューID
nullの場合は、第一階層へ追加される。
例外:
AccessSecurityException - メニューの追加に失敗した場合にスローされます。

addMenuLoginGroup

public void addMenuLoginGroup(String menuId,
                              String groupId)
                       throws AccessSecurityException
指定したログイングループのアクセス権をメニューに設定します。

パラメータ:
menuId - メニューID
groupId - ログイングループID
例外:
AccessSecurityException - アクセス権設定時に例外が発生
導入されたバージョン:
5.1

deleteMenuItem

public void deleteMenuItem(String menuId)
                    throws AccessSecurityException
メニューを削除します。

パラメータ:
menuId - メニューID
例外:
AccessSecurityException

deleteMenuItems

public void deleteMenuItems()
                     throws AccessSecurityException
すべてのメニューを削除します。

例外:
AccessSecurityException

deleteMenuLoginGroup

public void deleteMenuLoginGroup(String menuId,
                                 String groupId)
                          throws AccessSecurityException
指定したログイングループのアクセス権をメニューから削除します。

パラメータ:
menuId - メニューID
groupId - ログイングループID
例外:
AccessSecurityException - アクセス権削除時に例外が発生
導入されたバージョン:
5.1

exportData

public void exportData(String category,
                       OutputStream outputStream)
                throws AccessSecurityException
メニュー情報・エクスポート。

パラメータ:
category - カテゴリ
outputStream - 出力ストリーム
例外:
AccessSecurityException

getChildMenuIds

public String[] getChildMenuIds(String menuId)
                         throws AccessSecurityException
子メニューIDを取得します。

パラメータ:
menuId - 親メニューID
戻り値:
子メニューの配列
例外:
AccessSecurityException

getFirstMenuIds

public String[] getFirstMenuIds()
                         throws AccessSecurityException
第一階層のメニューIDをすべて取得します。

戻り値:
第一階層のメニューIDの配列
例外:
AccessSecurityException

getMenuIds

public String[] getMenuIds()
                    throws AccessSecurityException
すべてのメニューIDを取得します。

戻り値:
メニューIDの配列
例外:
AccessSecurityException

getMenuItem

public MenuItem getMenuItem(String menuId)
                     throws AccessSecurityException
指定されたメニューIDに対応するメニューを取得します。

パラメータ:
menuId - メニューID
戻り値:
メニュー
例外:
AccessSecurityException

getMenuItems

public MenuItem[] getMenuItems()
                        throws AccessSecurityException
すべてのメニューを取得します。

戻り値:
メニューの配列
例外:
AccessSecurityException

getMenuTree

public MenuTree[] getMenuTree()
                       throws AccessSecurityException
メニュー構成を取得します。

戻り値:
メニュー構成の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getMenuTree

public MenuTree[] getMenuTree(String groupId)
                       throws AccessSecurityException
引数に指定したログイングループのメニュー構成を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
メニュー構成の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。
導入されたバージョン:
5.1

getMenuLoginGroups

public String[] getMenuLoginGroups(String menuId)
                            throws AccessSecurityException
引数に指定したメニューを参照可能なログイングループIDの一覧を取得します。

パラメータ:
menuId - メニューID
戻り値:
ログイングループIDの一覧
例外:
AccessSecurityException - メニュー情報取得時に例外発生
導入されたバージョン:
5.1

getParentMenuId

public String getParentMenuId(String menuId)
                       throws AccessSecurityException
指定されたメニューの親メニューを取得します。

パラメータ:
menuId - メニューID
戻り値:
親メニューID
例外:
AccessSecurityException

importData

public void importData(String category,
                       InputStream inputStream)
                throws AccessSecurityException
メニュー情報・インポート。

パラメータ:
category - カテゴリ
inputStream - 入力ストリーム
例外:
AccessSecurityException

moveMenuItem

public void moveMenuItem(MenuInclusion menuInclusion)
                  throws AccessSecurityException
メニューを移動します。

パラメータ:
menuInclusion - 新しいメニュー構成
例外:
AccessSecurityException - メニューの更新に失敗した場合にスローされます。

updateMenuItem

public void updateMenuItem(MenuItem menuItem)
                    throws AccessSecurityException
メニューを更新します。

パラメータ:
menuItem -
例外:
AccessSecurityException

getExportCategories

public String[] getExportCategories()
管理メニューエクスポート用のカテゴリの一覧を取得します。

戻り値:
管理メニューエクスポート用カテゴリの一覧

getImportCategories

public String[] getImportCategories()
管理メニューインポート用のカテゴリの一覧を取得します。

戻り値:
管理メニューインポート用カテゴリの一覧

getMenuIdsByLoginGroup

public String[] getMenuIdsByLoginGroup(String groupId)
                                throws AccessSecurityException
引き数に指定したログイングループが参照可能なメニューIDの一覧を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
メニューIDの一覧
例外:
AccessSecurityException - メニュー情報取得時に例外が発生
導入されたバージョン:
5.1

getMenuItemsByIds

public MenuItem[] getMenuItemsByIds(String[] menuIds)
                             throws AccessSecurityException
引き数に指定したメニューIDに一致するメニューアイテムの一覧を取得します。

パラメータ:
menuIds - メニューID
戻り値:
メニューアイテムの一覧
例外:
AccessSecurityException - メニュー情報取得時に例外発生
導入されたバージョン:
5.1

setAccessControlEnabled

public void setAccessControlEnabled(String menuId,
                                    boolean accessControl)
                             throws AccessSecurityException
メニューアイテムに対するアクセス権を設定します。 アクセス権を有効にすると、ログイングループ毎にアクセス制限を設定可能です。 未設定の場合はアクセス制限を行いません。

パラメータ:
menuId - メニューID
accessControl - true/有効、false/無効
例外:
AccessSecurityException - アクセス権限設定時に例外が発生
導入されたバージョン:
5.1

isAccessControlEnabled

public boolean isAccessControlEnabled(String menuId)
                               throws AccessSecurityException
メニューアイテムのアクセス権の有無を取得します。

パラメータ:
menuId - メニューID
戻り値:
true/有効、false/無効
例外:
AccessSecurityException - アクセス権限取得時に例外が発生
導入されたバージョン:
5.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AdminMenuPostWriterListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース AdminMenuPostWriterListener

public interface AdminMenuPostWriterListener

メニュー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
MenuManager

メソッドの概要
void | init(Map params) メニューリスナーの初期化。
void | postAddMenuLoginGroup(String menuId, String groupId) アクセスを許可するログイングループを追加する直後にコールされます。
void | postCreate(MenuItem item) メニュー情報をデータストアに作成した直後にコールされます。
void | postDelete(String menuId) メニュー情報をデータストアから削除した直後にコールされます。
void | postDeleteMenuLoginGroup(String menuId, String groupId) アクセスを許可するログイングループを削除する直後にコールされます。
void | postMove(String parentId, String childId) メニューの親子関係を更新した直後にコールされます。
void | postSetAccessControlEnabled(String menuId, boolean accessControl) アクセス権限を設定する直前にコールされます。
void | postUpdate(MenuItem item) メニュー情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
メニューリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreate

public void postCreate(MenuItem item)
                throws AccessSecurityListenerExcpetion
メニュー情報をデータストアに作成した直後にコールされます。

パラメータ:
item - 作成されたメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDelete

public void postDelete(String menuId)
                throws AccessSecurityListenerExcpetion
メニュー情報をデータストアから削除した直後にコールされます。

パラメータ:
menuId - 削除されたメニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdate

public void postUpdate(MenuItem item)
                throws AccessSecurityListenerExcpetion
メニュー情報をデータストアに更新した直後にコールされます。

パラメータ:
item - 更新されたメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postMove

public void postMove(String parentId,
                     String childId)
              throws AccessSecurityListenerExcpetion
メニューの親子関係を更新した直後にコールされます。

パラメータ:
parentId - 新しい親メニューID
childId - 新しい子メニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postSetAccessControlEnabled

public void postSetAccessControlEnabled(String menuId,
                                        boolean accessControl)
                                 throws AccessSecurityListenerExcpetion
アクセス権限を設定する直前にコールされます。

パラメータ:
menuId - メニューID
accessControl - true/有効、false/無効
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
導入されたバージョン:
5.1

postAddMenuLoginGroup

public void postAddMenuLoginGroup(String menuId,
                                  String groupId)
                           throws AccessSecurityListenerExcpetion
アクセスを許可するログイングループを追加する直後にコールされます。

パラメータ:
menuId - メニューID
groupId - ログイングループID
例外:
AccessSecurityListenerExcpetion
導入されたバージョン:
5.1

postDeleteMenuLoginGroup

public void postDeleteMenuLoginGroup(String menuId,
                                     String groupId)
                              throws AccessSecurityListenerExcpetion
アクセスを許可するログイングループを削除する直後にコールされます。

パラメータ:
menuId - メニューID
groupId - ログイングループID
例外:
AccessSecurityListenerExcpetion
導入されたバージョン:
5.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AdminMenuQueryWriterListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース AdminMenuQueryWriterListener

public interface AdminMenuQueryWriterListener

メニュー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
MenuManager

メソッドの概要
void | init(Map params) メニューリスナーの初期化。
void | queryAddMenuLoginGroup(String menuId, String groupId) アクセスを許可するログイングループを追加する直前にコールされます。
void | queryCreate(MenuItem item) メニュー情報をデータストアに作成する直前にコールされます。
void | queryDelete(String menuId) メニュー情報をデータストアから削除する直前にコールされます。
void | queryDeleteMenuLoginGroup(String menuId, String groupId) アクセスを許可するログイングループを削除する直前にコールされます。
void | queryMove(String parentId, String childId) メニューの親子関係を更新する直前にコールされます。
void | querySetAccessControlEnabled(String menuId, boolean accessControl) アクセス権限を設定する直前にコールされます。
void | queryUpdate(MenuItem item) メニュー情報をデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
メニューリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreate

public void queryCreate(MenuItem item)
                 throws AccessSecurityListenerExcpetion
メニュー情報をデータストアに作成する直前にコールされます。

パラメータ:
item - 作成されるメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDelete

public void queryDelete(String menuId)
                 throws AccessSecurityListenerExcpetion
メニュー情報をデータストアから削除する直前にコールされます。

パラメータ:
menuId - 削除されるメニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdate

public void queryUpdate(MenuItem item)
                 throws AccessSecurityListenerExcpetion
メニュー情報をデータストアに更新する直前にコールされます。

パラメータ:
item - 更新されるメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryMove

public void queryMove(String parentId,
                      String childId)
               throws AccessSecurityListenerExcpetion
メニューの親子関係を更新する直前にコールされます。

パラメータ:
parentId - 新しい親メニューID
childId - 新しい子メニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

querySetAccessControlEnabled

public void querySetAccessControlEnabled(String menuId,
                                         boolean accessControl)
                                  throws AccessSecurityListenerExcpetion
アクセス権限を設定する直前にコールされます。

パラメータ:
menuId - メニューID
accessControl - true/有効、false/無効
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
導入されたバージョン:
5.1

queryAddMenuLoginGroup

public void queryAddMenuLoginGroup(String menuId,
                                   String groupId)
                            throws AccessSecurityListenerExcpetion
アクセスを許可するログイングループを追加する直前にコールされます。

パラメータ:
menuId - メニューID
groupId - ログイングループID
例外:
AccessSecurityListenerExcpetion
導入されたバージョン:
5.1

queryDeleteMenuLoginGroup

public void queryDeleteMenuLoginGroup(String menuId,
                                      String groupId)
                               throws AccessSecurityListenerExcpetion
アクセスを許可するログイングループを削除する直前にコールされます。

パラメータ:
menuId - メニューID
groupId - ログイングループID
例外:
AccessSecurityListenerExcpetion
導入されたバージョン:
5.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AdminMenuReaderDecorator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース AdminMenuReaderDecorator

public interface AdminMenuReaderDecorator

メニュー情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
MenuItem | doDecoration(MenuItem item) メニューデータストアからの読み込み直後にコールされます。
void | init(Map params) メニューデコレータの初期化。

メソッドの詳細

init

public void init(Map params)
メニューデコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public MenuItem doDecoration(MenuItem item)
メニューデータストアからの読み込み直後にコールされます。

パラメータ:
item - 読み込みが行われたメニュー情報
戻り値:
拡張されたメニュー情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyChangedMenuListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス CompanyChangedMenuListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener
すべての実装インタフェース:
CompanyChangedListener
public class CompanyChangedMenuListener
extends Object
implements CompanyChangedListener

会社・組織に関する情報の変更時のリスナーです。

導入されたバージョン:
5.0

コンストラクタの概要
CompanyChangedMenuListener()
メソッドの概要
void | categoryDetailRemoved(String groupId, CompanyCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | categoryDetailSet(String groupId, CompanyCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | companyAdded(String groupId, Company company) 会社情報がデータストアに登録された後に呼び出されます。
void | companyDeleted(String groupId, Company company) 会社情報がデータストアから削除された後に呼び出されます。
void | departmentAdded(String groupId, Department department) 組織情報がデータストアに登録された後に呼び出されます。
void | departmentDeleted(String groupId, Department department) 組織情報がデータストアに更新された後に呼び出されます。
void | departmentJoined(String groupId, String company, String parentDepartment, String department, String version) 組織構成がデータストアに登録された後に呼び出されます。
void | departmentLeft(String groupId, String company, String department, String version) 組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
void | departmentMoved(String groupId, String company, String parentDepartment, String department, String version) 組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
void | departmentUpdated(String groupId, Department department) 組織情報がデータストアから削除された後に呼び出されます。
void | init(Map params) 会社リスナーの初期化を行います。
void | mainRemoved(String groupId, DepartmentMain main) 主所属情報がデータストアから削除された後に呼び出されます。
void | mainSet(String groupId, DepartmentMain main) 主所属情報がデータストアに登録された後に呼び出されます。
void | memberDeleted(String groupId, DepartmentAttach attach) 組織からの人員の割当がデータストアから削除された後に呼び出されます。
void | memberSet(String groupId, DepartmentAttach attach) 組織への人員の割当がデータストアに登録された後に呼び出されます。
void | postAdded(String groupId, CompanyPost post) 役職情報がデータストアに登録された後に呼び出されます。
void | postDeleted(String groupId, CompanyPost post) 役職情報がデータストアから削除された後に呼び出されます。
void | postUpdated(String groupId, CompanyPost post) 役職情報がデータストアに更新された後に呼び出されます。
void | setUserId(String userId) ログインユーザIDを設定します。
void | versionAdded(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに登録された後に呼び出されます。
void | versionCopied(String groupId, String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
void | versionDeleted(String groupId, CompanyVersion version) 会社構成バージョンがデータストアから削除された後に呼び出されます。
void | versionUpdated(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに更新された後に呼び出されます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyChangedMenuListener

public CompanyChangedMenuListener()
メソッドの詳細

init

public void init(Map params)
会社リスナーの初期化を行います。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース CompanyChangedListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

setUserId

public void setUserId(String userId)
ログインユーザIDを設定します。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース CompanyChangedListener 内の setUserId
パラメータ:
userId - ログインユーザID

companyAdded

public void companyAdded(String groupId,
                         Company company)
                  throws ChangedListenerException
会社情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の companyAdded
パラメータ:
groupId - ログイングループID
company - 会社情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

companyDeleted

public void companyDeleted(String groupId,
                           Company company)
                    throws ChangedListenerException
会社情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の companyDeleted
パラメータ:
groupId - ログイングループID
company - 会社情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentAdded

public void departmentAdded(String groupId,
                            Department department)
                     throws ChangedListenerException
組織情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentAdded
パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentUpdated

public void departmentUpdated(String groupId,
                              Department department)
                       throws ChangedListenerException
組織情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentUpdated
パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentDeleted

public void departmentDeleted(String groupId,
                              Department department)
                       throws ChangedListenerException
組織情報がデータストアに更新された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentDeleted
パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentJoined

public void departmentJoined(String groupId,
                             String company,
                             String parentDepartment,
                             String department,
                             String version)
                      throws ChangedListenerException
組織構成がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentJoined
パラメータ:
groupId - ログイングループID
company - 会社コード
parentDepartment - 新規登録する組織の上位となる組織の組織コード（または会社の会社コード）
department - 組織情報（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentMoved

public void departmentMoved(String groupId,
                            String company,
                            String parentDepartment,
                            String department,
                            String version)
                     throws ChangedListenerException
組織構成からの組織の移動がデータストアに反映された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentMoved
パラメータ:
groupId - ログイングループID
company - 上位組織と移動対象の組織が所属する会社の会社コード
parentDepartment - 上位組織の組織コード（または会社の会社コード）
department - 移動する組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentLeft

public void departmentLeft(String groupId,
                           String company,
                           String department,
                           String version)
                    throws ChangedListenerException
組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentLeft
パラメータ:
groupId - ログイングループID
company - 会社コード
department - 離脱させる組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailSet

public void categoryDetailSet(String groupId,
                              CompanyCategory category)
                       throws ChangedListenerException
分類区分情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の categoryDetailSet
パラメータ:
groupId - ログイングループID
category - 登録された分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailRemoved

public void categoryDetailRemoved(String groupId,
                                  CompanyCategory category)
                           throws ChangedListenerException
分類区分情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の categoryDetailRemoved
パラメータ:
groupId - ログイングループID
category - 削除された分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberSet

public void memberSet(String groupId,
                      DepartmentAttach attach)
               throws ChangedListenerException
組織への人員の割当がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の memberSet
パラメータ:
groupId - ログイングループID
attach - 割当られた人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberDeleted

public void memberDeleted(String groupId,
                          DepartmentAttach attach)
                   throws ChangedListenerException
組織からの人員の割当がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の memberDeleted
パラメータ:
groupId - ログイングループID
attach - 組織から外された人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

mainSet

public void mainSet(String groupId,
                    DepartmentMain main)
             throws ChangedListenerException
主所属情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の mainSet
パラメータ:
groupId - ログイングループID
main - 主所属情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

mainRemoved

public void mainRemoved(String groupId,
                        DepartmentMain main)
                 throws ChangedListenerException
主所属情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の mainRemoved
パラメータ:
groupId - ログイングループID
main - 主所属情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionAdded

public void versionAdded(String groupId,
                         CompanyVersion version)
                  throws ChangedListenerException
会社構成バージョンがデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の versionAdded
パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionUpdated

public void versionUpdated(String groupId,
                           CompanyVersion version)
                    throws ChangedListenerException
会社構成バージョンがデータストアに更新された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の versionUpdated
パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionDeleted

public void versionDeleted(String groupId,
                           CompanyVersion version)
                    throws ChangedListenerException
会社構成バージョンがデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の versionDeleted
パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionCopied

public void versionCopied(String groupId,
                          String company,
                          String srcVersion,
                          String destVersion,
                          Term term)
                   throws ChangedListenerException
登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の versionCopied
パラメータ:
groupId - ログイングループID
company - コピー元、コピー先の会社構成バージョンの会社コード
srcVersion - コピー元の会社構成バージョンのバージョンコード
destVersion - コピー先の会社構成バージョンのバージョンコード
term - コピー先の会社構成バージョンの期間
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

postAdded

public void postAdded(String groupId,
                      CompanyPost post)
               throws ChangedListenerException
役職情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の postAdded
パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

postUpdated

public void postUpdated(String groupId,
                        CompanyPost post)
                 throws ChangedListenerException
役職情報がデータストアに更新された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の postUpdated
パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

postDeleted

public void postDeleted(String groupId,
                        CompanyPost post)
                 throws ChangedListenerException
役職情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の postDeleted
パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース MenuAccessor

既知の実装クラスの一覧:
StandardMenuAccessor
public interface MenuAccessor

メニューアクセッサインタフェース。

メニュー情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | deleteMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を削除します。
void | deleteMenuDepartments(String groupId, String id) すべてのメニュー組織を削除します。
void | deleteMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を削除します。
void | deleteMenuItem(String groupId, String id) 引数で渡されたノードを削除します。
void | deleteMenuPost(String groupId, String id, PostInfo postInfo) メニュー役職を削除します。
void | deleteMenuPosts(String groupId, String id) すべてのメニュー役職を削除します。
void | deleteMenuPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) メニューパブリックグループを削除します。
void | deleteMenuPublicGroups(String groupId, String id) すべてのメニューパブリックグループを削除します。
void | deleteMenuRole(String groupId, String id, String roleId) メニューロールを削除します。
void | deleteMenuRoles(String groupId, String id) すべてのメニューロールを削除します。
String[] | getChildMenuIds(String groupId, String menuId) 引数で指定されたノードの直下の子ノードを配列で取得します。
String[] | getFirstMenuIds(String groupId) 第一階層に属するノードを配列で取得します。
DepartmentInfo[] | getMenuDepartments(String groupId, String id) すべてのメニュー組織を取得します。
String[] | getMenuIds(String groupId) すべてのメニューIDを取得します。
String[] | getMenuIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つメニューIDをすべて取得します。
String[] | getMenuIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つメニューIDをすべて取得します。
String[] | getMenuIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つメニューIDをすべて取得します。
String[] | getMenuIdsByRole(String groupId, String[] roleIds) 指定されたロールIDを持つメニューIDをすべて取得します。
MenuInclusion[] | getMenuInclusions(String groupId) すべてのメニュー構成を取得します。
MenuItem | getMenuItem(String groupId, String menuId) 指定されたメニューIDに対するノードを取得します。
MenuItem[] | getMenuItems(String groupId) すべてのノードを取得します。
MenuItem[] | getMenuItemsByIds(String groupId, String[] menuIds) 指定されたユーザIDのメニュー情報をすべて取得します。
PostInfo[] | getMenuPosts(String groupId, String id) すべてのメニュー役職を取得します。
PublicGroupInfo[] | getMenuPublicGroups(String groupId, String id) すべてのメニューパブリックグループを取得します。
String[] | getMenuRoles(String groupId, String id) すべてのメニューロールを取得します。
String | getParentMenuId(String groupId, String menuId) 引数で指定されたノードの親ノードを取得します。
void | init(Map params) メニューアクセッサの初期化。
void | insertMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を新規に作成します。
void | insertMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を新規に作成します。
void | insertMenuItem(String groupId, MenuItem menuItem, String parentId) 引数で渡されたノードを新規追加します。
void | insertMenuPost(String groupId, String id, PostInfo postInfo) メニュー役職を新規に作成します。
void | insertMenuPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) メニューパブリックグループを新規に作成します。
void | insertMenuRole(String groupId, String id, String roleId) メニューロールを新規に作成します。
void | updateMenuItem(String groupId, MenuItem menuItem) 引数で渡されたノードを更新します。

メソッドの詳細

deleteMenuDepartment

public void deleteMenuDepartment(String groupId,
                                 String id,
                                 DepartmentInfo departmentInfo)
                          throws AccessSecurityWriteException
メニュー組織を削除します。

パラメータ:
groupId - ログイングループID
id - メニューID
departmentInfo - 組織情報
例外:
AccessSecurityWriteException

deleteMenuDepartments

public void deleteMenuDepartments(String groupId,
                                  String id)
                           throws AccessSecurityWriteException
すべてのメニュー組織を削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException

deleteMenuInclusion

public void deleteMenuInclusion(String groupId,
                                MenuInclusion menuInclusion)
                         throws AccessSecurityWriteException
メニュー構成を削除します。

パラメータ:
groupId - ログイングループID
menuInclusion - メニュー構成
例外:
AccessSecurityWriteException

deleteMenuItem

public void deleteMenuItem(String groupId,
                           String id)
                    throws AccessSecurityWriteException
引数で渡されたノードを削除します。

パラメータ:
groupId -
id -
例外:
AccessSecurityWriteException

deleteMenuPost

public void deleteMenuPost(String groupId,
                           String id,
                           PostInfo postInfo)
                    throws AccessSecurityWriteException
メニュー役職を削除します。

パラメータ:
groupId - ログイングループID
id - メニューID
postInfo - 役職情報
例外:
AccessSecurityWriteException

deleteMenuPosts

public void deleteMenuPosts(String groupId,
                            String id)
                     throws AccessSecurityWriteException
すべてのメニュー役職を削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException

deleteMenuPublicGroup

public void deleteMenuPublicGroup(String groupId,
                                  String id,
                                  PublicGroupInfo publicGroupInfo)
                           throws AccessSecurityWriteException
メニューパブリックグループを削除します。

パラメータ:
groupId - ログイングループID
id - メニューID
publicGroupInfo - パブリックグループ情報
例外:
AccessSecurityWriteException

deleteMenuPublicGroups

public void deleteMenuPublicGroups(String groupId,
                                   String id)
                            throws AccessSecurityWriteException
すべてのメニューパブリックグループを削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException

deleteMenuRole

public void deleteMenuRole(String groupId,
                           String id,
                           String roleId)
                    throws AccessSecurityWriteException
メニューロールを削除します。

パラメータ:
groupId - ログイングループID
id - メニューID
roleId - ロールID
例外:
AccessSecurityWriteException

deleteMenuRoles

public void deleteMenuRoles(String groupId,
                            String id)
                     throws AccessSecurityWriteException
すべてのメニューロールを削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException

getChildMenuIds

public String[] getChildMenuIds(String groupId,
                                String menuId)
                         throws AccessSecurityReadException
引数で指定されたノードの直下の子ノードを配列で取得します。

パラメータ:
groupId - ログイングループID
menuId - メニューID
戻り値:
子メニューIDの配列
例外:
AccessSecurityReadException

getFirstMenuIds

public String[] getFirstMenuIds(String groupId)
                         throws AccessSecurityReadException
第一階層に属するノードを配列で取得します。

パラメータ:
groupId - ログイングループID
戻り値:
第一階層のメニューIDの配列
例外:
AccessSecurityReadException

getMenuDepartments

public DepartmentInfo[] getMenuDepartments(String groupId,
                                           String id)
                                    throws AccessSecurityReadException
すべてのメニュー組織を取得します。

一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
id - メニューID
戻り値:
組織情報の配列
例外:
AccessSecurityReadException

getMenuIds

public String[] getMenuIds(String groupId)
                    throws AccessSecurityReadException
すべてのメニューIDを取得します。

パラメータ:
groupId -
戻り値:
メニューIDの配列
例外:
AccessSecurityReadException

getMenuIdsByDepartment

public String[] getMenuIdsByDepartment(String groupId,
                                       DepartmentInfo[] departments)
                                throws AccessSecurityReadException
指定された組織を持つメニューIDをすべて取得します。

パラメータ:
groupId - ログイングループID
departments - 組織情報の配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - メニュー情報取得に失敗した場合スローされます。

getMenuIdsByPost

public String[] getMenuIdsByPost(String groupId,
                                 PostInfo[] posts)
                          throws AccessSecurityReadException
指定された役職を持つメニューIDをすべて取得します。

パラメータ:
groupId - ログイングループID
posts - 役職情報の配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - メニュー情報取得に失敗した場合スローされます。

getMenuIdsByPublicGroup

public String[] getMenuIdsByPublicGroup(String groupId,
                                        PublicGroupInfo[] publicGroups)
                                 throws AccessSecurityReadException
指定されたパブリックグループを持つメニューIDをすべて取得します。

パラメータ:
groupId - ログイングループID
publicGroups - パブリックグループの配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - メニュー情報取得に失敗した場合スローされます。

getMenuIdsByRole

public String[] getMenuIdsByRole(String groupId,
                                 String[] roleIds)
                          throws AccessSecurityReadException
指定されたロールIDを持つメニューIDをすべて取得します。

パラメータ:
groupId - ログイングループID
roleIds - ロールIDの配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - メニュー情報取得に失敗した場合スローされます。

getMenuInclusions

public MenuInclusion[] getMenuInclusions(String groupId)
                                  throws AccessSecurityReadException
すべてのメニュー構成を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
メニュー構成の配列
例外:
AccessSecurityReadException

getMenuItem

public MenuItem getMenuItem(String groupId,
                            String menuId)
                     throws AccessSecurityReadException
指定されたメニューIDに対するノードを取得します。

パラメータ:
groupId - グループID
menuId - メニューID
戻り値:
ノード
例外:
AccessSecurityReadException

getMenuItems

public MenuItem[] getMenuItems(String groupId)
                        throws AccessSecurityReadException
すべてのノードを取得します。

パラメータ:
groupId -
戻り値:
ノード配列
例外:
AccessSecurityReadException

getMenuItemsByIds

public MenuItem[] getMenuItemsByIds(String groupId,
                                    String[] menuIds)
                             throws AccessSecurityReadException
指定されたユーザIDのメニュー情報をすべて取得します。

パラメータ:
groupId - ログイングループID
menuIds - メニューIDの配列
戻り値:
メニューオブジェクトの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - メニュー情報取得に失敗した場合スローされます。

getMenuPosts

public PostInfo[] getMenuPosts(String groupId,
                               String id)
                        throws AccessSecurityReadException
すべてのメニュー役職を取得します。

一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
id - メニューID
戻り値:
役職情報の配列
例外:
AccessSecurityReadException

getMenuPublicGroups

public PublicGroupInfo[] getMenuPublicGroups(String groupId,
                                             String id)
                                      throws AccessSecurityReadException
すべてのメニューパブリックグループを取得します。

一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
id - メニューID
戻り値:
パブリックグループ情報の配列
例外:
AccessSecurityReadException

getMenuRoles

public String[] getMenuRoles(String groupId,
                             String id)
                      throws AccessSecurityReadException
すべてのメニューロールを取得します。

一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
id - メニューID
戻り値:
メニューロールIDの配列
例外:
AccessSecurityReadException

getParentMenuId

public String getParentMenuId(String groupId,
                              String menuId)
                       throws AccessSecurityReadException
引数で指定されたノードの親ノードを取得します。

パラメータ:
groupId - ログイングループID
menuId - メニューID
戻り値:
親メニューID
例外:
AccessSecurityReadException

init

public void init(Map params)
メニューアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

insertMenuDepartment

public void insertMenuDepartment(String groupId,
                                 String id,
                                 DepartmentInfo departmentInfo)
                          throws AccessSecurityWriteException
メニュー組織を新規に作成します。

パラメータ:
groupId - ログイングループID
id - メニューID
departmentInfo - 組織情報
例外:
AccessSecurityWriteException

insertMenuInclusion

public void insertMenuInclusion(String groupId,
                                MenuInclusion menuInclusion)
                         throws AccessSecurityWriteException
メニュー構成を新規に作成します。

パラメータ:
groupId - ログイングループID
menuInclusion - メニュー構成
例外:
AccessSecurityWriteException

insertMenuItem

public void insertMenuItem(String groupId,
                           MenuItem menuItem,
                           String parentId)
                    throws AccessSecurityWriteException
引数で渡されたノードを新規追加します。

パラメータ:
groupId -
menuItem -
parentId -
例外:
AccessSecurityWriteException

insertMenuPost

public void insertMenuPost(String groupId,
                           String id,
                           PostInfo postInfo)
                    throws AccessSecurityWriteException
メニュー役職を新規に作成します。

パラメータ:
groupId - ログイングループID
id - メニューID
postInfo - 役職情報
例外:
AccessSecurityWriteException

insertMenuPublicGroup

public void insertMenuPublicGroup(String groupId,
                                  String id,
                                  PublicGroupInfo publicGroupInfo)
                           throws AccessSecurityWriteException
メニューパブリックグループを新規に作成します。

パラメータ:
groupId - ログイングループID
id - メニューID
publicGroupInfo - パブリックグループ情報
例外:
AccessSecurityWriteException

insertMenuRole

public void insertMenuRole(String groupId,
                           String id,
                           String roleId)
                    throws AccessSecurityWriteException
メニューロールを新規に作成します。

パラメータ:
groupId - ログイングループID
id - メニューID
roleId - ロールID
例外:
AccessSecurityWriteException

updateMenuItem

public void updateMenuItem(String groupId,
                           MenuItem menuItem)
                    throws AccessSecurityWriteException
引数で渡されたノードを更新します。

パラメータ:
groupId - ログイングループID
menuItem - メニュー
例外:
AccessSecurityWriteException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuExporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース MenuExporter

既知の実装クラスの一覧:
StandardMenuBackup
public interface MenuExporter

メニューエクスポートインタフェースです。

バージョン:
1.0

メソッドの概要
void | doExport(MenuManager manager, OutputStream outputStream) エクスポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doExport

public void doExport(MenuManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

メニュー情報をバックアップファイルに出力します。

パラメータ:
manager - メニューマネージャ
outputStream - 出力ストリーム
例外:
AccessSecurityExportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuImporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース MenuImporter

既知の実装クラスの一覧:
StandardMenuBackup
public interface MenuImporter

メニューインポートインタフェースです。

バージョン:
1.0

メソッドの概要
void | doImport(InputStream inputStream, MenuManager manager) インポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doImport

public void doImport(InputStream inputStream,
                     MenuManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からメニュー情報を取得し、生成します。

パラメータ:
manager - メニューマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuInclusion (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス MenuInclusion

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.MenuInclusion
すべての実装インタフェース:
Serializable
public class MenuInclusion
extends Object
implements Serializable

メニュー内包情報クラス。

メニューの親子関係を保持するクラスです。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
MenuInclusion(String parentMenuId, String childMenuId)
コンストラクタ。
メソッドの概要
String | getChildMenuId() 子メニューIDを取得します。
String | getKeyString() メニュー内包情報の識別子を取得します。
String | getParentMenuId() 親メニューIDを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MenuInclusion

public MenuInclusion(String parentMenuId,
                     String childMenuId)
コンストラクタ。

メソッドの詳細

getChildMenuId

public String getChildMenuId()
子メニューIDを取得します。

戻り値:
子メニューID

getParentMenuId

public String getParentMenuId()
親メニューIDを取得します。

戻り値:
親メニューID

getKeyString

public String getKeyString()
メニュー内包情報の識別子を取得します。

戻り値:
メニュー内包情報の識別子
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuItem (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス MenuItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.MenuItem
すべての実装インタフェース:
Serializable
public class MenuItem
extends Object
implements Serializable

メニュー・モデルクラス。 メニューのデータモデルを定義します

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
MenuManager, 直列化された形式

フィールドの概要
static String | CONTENT_TYPE_IN メニューコンテンツの種類（内部URL）。
static String | CONTENT_TYPE_OUT メニューコンテンツの種類（外部URL）。
static String | MENU_TYPE_FOLDER メニュータイプ（フォルダ）。
static String | MENU_TYPE_ITEM メニュータイプ（アイテム）。
コンストラクタの概要
MenuItem()
コンストラクタ。
MenuItem(String id)
コンストラクタ。
メソッドの概要
boolean | equals(Object obj) このオブジェクトと他のオブジェクトが等しいかどうかを示します。
String | getArgument(String key) 引数を取得します。
String[] | getArgumentKeys() 引数キーの一覧を取得します。
String | getClientType() クライアントタイプを取します。
String | getContents() コンテンツの種類を取得します。
String | getDescription() 説明を取得します。
String | getDisplayName(Locale locale) メニュー名を取得します。
String | getId() メニューIDを取得します。
String | getImagePath() メニューイメージパスを取得します。
Locale[] | getLocales() メニュー名として保管されているロケールの一覧を取得します。
int | getSortNumber() ソート番号を取得します。
String | getType() ノードのタイプを取得します。
String | getUrl() URLを取得します。
int | hashCode() ハッシュコードを取得します。
void | removeArgument(String key) 引数を削除します。
void | removeDisplayName(Locale locale) ロケールに対応したメニュー名を削除します。
void | setArgument(String key, String value) 引数を設定します。
void | setClientType(String clientType) クライアントタイプを設定します。
void | setContents(String contents) コンテンツの種類を設定します。
void | setDescription(String description) 説明を設定します。
void | setDisplayName(Locale locale, String displayName) メニュー名を設定します。
void | setId(String id) メニューIDを設定します。
void | setImagePath(String imagePath) メニューイメージパスを設定します。
void | setSortNumber(int sortNumber) ソート番号を設定します。
void | setType(String type) ノードのタイプを設定します。
void | setUrl(String url) URLを設定します。
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

CONTENT_TYPE_IN

public static final String CONTENT_TYPE_IN
メニューコンテンツの種類（内部URL）。

関連項目:
定数フィールド値

CONTENT_TYPE_OUT

public static final String CONTENT_TYPE_OUT
メニューコンテンツの種類（外部URL）。

関連項目:
定数フィールド値

MENU_TYPE_FOLDER

public static final String MENU_TYPE_FOLDER
メニュータイプ（フォルダ）。

関連項目:
定数フィールド値

MENU_TYPE_ITEM

public static final String MENU_TYPE_ITEM
メニュータイプ（アイテム）。

関連項目:
定数フィールド値
コンストラクタの詳細

MenuItem

public MenuItem()
コンストラクタ。

メニューIDは自動採番されます。

MenuItem

public MenuItem(String id)
コンストラクタ。

パラメータ:
id - メニューID
メソッドの詳細

equals

public boolean equals(Object obj)
このオブジェクトと他のオブジェクトが等しいかどうかを示します。

パラメータ:
obj - 比較対象の参照オブジェクト
戻り値:
引数に指定されたオブジェクトとこのオブジェクトが等しい場合は true、そうでない場合は false
関連項目:
Object.equals(java.lang.Object)

getArgument

public String getArgument(String key)
引数を取得します。

パラメータ:
key - 属性のキー
戻り値:
属性値

getArgumentKeys

public String[] getArgumentKeys()
引数キーの一覧を取得します。

戻り値:
引数キーの配列

getClientType

public String getClientType()
クライアントタイプを取します。

戻り値:
クライアントタイプ

getContents

public String getContents()
コンテンツの種類を取得します。

戻り値:
コンテンツの種類

getDescription

public String getDescription()
説明を取得します。

戻り値:
説明

getDisplayName

public String getDisplayName(Locale locale)
メニュー名を取得します。

パラメータ:
locale - ロケール名
戻り値:
メニュー名

getId

public String getId()
メニューIDを取得します。

戻り値:
メニューID

getLocales

public Locale[] getLocales()
メニュー名として保管されているロケールの一覧を取得します。

戻り値:
メニュー名として保管されているロケールの配列

getSortNumber

public int getSortNumber()
ソート番号を取得します。

戻り値:
ソート番号

getType

public String getType()
ノードのタイプを取得します。

返却される値は、フォルダ( MENU_TYPE_FOLDER)、またはアイテム(MENU_TYPE_ITEM)です。

戻り値:
ノードのタイプ

getUrl

public String getUrl()
URLを取得します。

戻り値:
URL

hashCode

public int hashCode()
ハッシュコードを取得します。

戻り値:
ハッシュコード
関連項目:
Object.hashCode()

removeArgument

public void removeArgument(String key)
引数を削除します。

パラメータ:
key - 引数キー

removeDisplayName

public void removeDisplayName(Locale locale)
ロケールに対応したメニュー名を削除します。

パラメータ:
locale - ロケール

setArgument

public void setArgument(String key,
                        String value)
引数を設定します。

パラメータ:
key - 引数キー
value - 引数値

setClientType

public void setClientType(String clientType)
クライアントタイプを設定します。

パラメータ:
clientType - クライアントタイプ

setContents

public void setContents(String contents)
コンテンツの種類を設定します。

パラメータ:
contents - コンテンツの種類

setDescription

public void setDescription(String description)
説明を設定します。

パラメータ:
description - 説明

setDisplayName

public void setDisplayName(Locale locale,
                           String displayName)
メニュー名を設定します。

パラメータ:
locale - ロケール名
displayName - メニュー名

setId

public void setId(String id)
メニューIDを設定します。

パラメータ:
id - メニューID

setSortNumber

public void setSortNumber(int sortNumber)
ソート番号を設定します。

パラメータ:
sortNumber - ソート番号

setType

public void setType(String type)
ノードのタイプを設定します。

設定できる値は、フォルダ( MENU_TYPE_FOLDER)、またはアイテム(MENU_TYPE_ITEM)です。
上記の値以外を設定した場合は、アイテム( MENU_TYPE_ITEM)に設定されます。

パラメータ:
type - メニュータイプ

setUrl

public void setUrl(String url)
URLを設定します。

パラメータ:
url - URL

getImagePath

public String getImagePath()
メニューイメージパスを取得します。

戻り値:
イメージパス

setImagePath

public void setImagePath(String imagePath)
メニューイメージパスを設定します。

パラメータ:
imagePath - イメージパス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス MenuManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.MenuManager
public final class MenuManager
extends Object

メニューマネージャクラス。

メニュー情報の操作を行います。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
MenuManager(String groupId)
コンストラクタ。
メソッドの概要
void | addMenuDepartment(String menuId, DepartmentInfo departmentInfo) 組織をメニューに紐付けます。
void | addMenuItem(String parentMenuId, MenuItem menuItem) メニューを追加します。
void | addMenuPost(String menuId, PostInfo postInfo) 役職をメニューに紐付けます。
void | addMenuPublicGroup(String menuId, PublicGroupInfo publicGroupInfo) パブリックグループをメニューに紐付けます。
void | addMenuRole(String menuId, String roleId) ロールをメニューに紐付けます。
static void | clearInstance() メニューマネージャのインスタンスを初期化します。
void | deleteMenuDepartment(String menuId, DepartmentInfo departmentInfo) 組織の紐付けをメニューから削除します。
void | deleteMenuDepartments(String menuId) 組織の紐付けをメニューからすべて削除します。
void | deleteMenuItem(String menuId) メニューを削除します。
void | deleteMenuItems() すべてのメニューを削除します。
void | deleteMenuPost(String menuId, PostInfo postInfo) 役織の紐付けをメニューから削除します。
void | deleteMenuPosts(String menuId) 役織の紐付けをメニューからすべて削除します。
void | deleteMenuPublicGroup(String menuId, PublicGroupInfo publicGroupInfo) パブリックグループの紐付けをメニューから削除します。
void | deleteMenuPublicGroups(String menuId) パブリックグループの紐付けをメニューからすべて削除します。
void | deleteMenuRole(String menuId, String roleId) ロールの紐付けをメニューから削除します。
void | deleteMenuRoles(String menuId) ロールの紐付けをメニューから削除します。
void | exportData(String category, OutputStream outputStream) メニュー情報をエクスポートします。
MenuTree[] | getAccountMenuTree(String userId, String clientType) 指定したアカウントのメニュー構成を取得します。
String[] | getChildMenuIds(String menuId) 子メニューIDを取得します。
String[] | getExportCategories() メニューエクスポート用のカテゴリの一覧を取得します。
String[] | getFirstMenuIds() 第一階層のメニューIDをすべて取得します。
String[] | getImportCategories() メニューインポート用のカテゴリの一覧を取得します。
String | getLoginGroupId() ログイングループIDを取得します。
DepartmentInfo[] | getMenuDepartments(String menuId) メニューに紐付いた組織の一覧を取得します。
String[] | getMenuIds() すべてのメニューIDを取得します。
String[] | getMenuIdsByDepartment(DepartmentInfo[] departments) 指定された組織を持つメニューIDをすべて取得します。
String[] | getMenuIdsByPost(PostInfo[] posts) 指定された役職を持つメニューIDをすべて取得します。
String[] | getMenuIdsByPublicGroup(PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つメニューIDをすべて取得します。
String[] | getMenuIdsByRole(String[] roleIds) 指定されたロールIDを持つメニューIDをすべて取得します。
MenuItem | getMenuItem(String menuId) 指定されたメニューIDに対応するメニューを取得します。
MenuItem[] | getMenuItems() すべてのメニューを取得します。
MenuItem[] | getMenuItemsByIds(String[] menuIds) ログイングループ内で引数指定したメニューIDのメニュー情報をすべて取得します。
PostInfo[] | getMenuPosts(String menuId) メニューに紐付いた役職の一覧を取得します。
PublicGroupInfo[] | getMenuPublicGroups(String menuId) メニューに紐付いたパブリックグループの一覧を取得します。
String[] | getMenuRoles(String menuId) メニューに紐付いたロールの一覧を取得します。
MenuTree[] | getMenuTree() メニュー構成を取得します。
MenuTree[] | getMenuTree(String clientType) 指定されたクライアントタイプのみのメニュー構成を取得します。
MenuTree[] | getMenuTree(String clientType, String[] menuIds, boolean showNoChildFolder) 指定されたクライアントタイプと指定されたメニューIDのみのメニュー構成を取得します。
String | getParentMenuId(String menuId) 指定されたメニューの親メニューを取得します。
void | importData(String category, InputStream inputStream) メニュー情報をインポートします。
boolean | isUpdate(Date date) メニュー情報が指定された日付よりも新しいかチェックします。
void | moveMenuItem(MenuInclusion menuInclusion) メニューを移動します。
void | updateMenuItem(MenuItem menuItem) メニューを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MenuManager

public MenuManager(String groupId)
            throws AccessSecurityException
コンストラクタ。

ログイングループ単位のメニューを操作するマネージャーを作成します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityException - ログイングループIDが不正な場合にスローされます。
メソッドの詳細

clearInstance

public static void clearInstance()
メニューマネージャのインスタンスを初期化します。

アクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。
通常、このメソッドを使用する必要はありません。

addMenuDepartment

public void addMenuDepartment(String menuId,
                              DepartmentInfo departmentInfo)
                       throws AccessSecurityException
組織をメニューに紐付けます。

パラメータ:
menuId - メニューID
departmentInfo - 組織情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

addMenuItem

public void addMenuItem(String parentMenuId,
                        MenuItem menuItem)
                 throws AccessSecurityException
メニューを追加します。

パラメータ:
parentMenuId - 親メニューID
nullの場合は、第一階層へ追加されます。
menuItem - メニュー
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

addMenuPost

public void addMenuPost(String menuId,
                        PostInfo postInfo)
                 throws AccessSecurityException
役職をメニューに紐付けます。

パラメータ:
menuId - メニューID
postInfo - 役職情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

addMenuPublicGroup

public void addMenuPublicGroup(String menuId,
                               PublicGroupInfo publicGroupInfo)
                        throws AccessSecurityException
パブリックグループをメニューに紐付けます。

パラメータ:
menuId - メニューID
publicGroupInfo - パブリックグループ
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

addMenuRole

public void addMenuRole(String menuId,
                        String roleId)
                 throws AccessSecurityException
ロールをメニューに紐付けます。

パラメータ:
menuId - メニューID
roleId - ロールID
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuDepartment

public void deleteMenuDepartment(String menuId,
                                 DepartmentInfo departmentInfo)
                          throws AccessSecurityException
組織の紐付けをメニューから削除します。

パラメータ:
menuId - メニューID
departmentInfo - 組織情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuDepartments

public void deleteMenuDepartments(String menuId)
                           throws AccessSecurityException
組織の紐付けをメニューからすべて削除します。

パラメータ:
menuId - メニューID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuItem

public void deleteMenuItem(String menuId)
                    throws AccessSecurityException
メニューを削除します。

パラメータ:
menuId - メニューID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuItems

public void deleteMenuItems()
                     throws AccessSecurityException
すべてのメニューを削除します。

例外:
AccessSecurityException - 削除処理に失敗した場合にスローされます。

deleteMenuPost

public void deleteMenuPost(String menuId,
                           PostInfo postInfo)
                    throws AccessSecurityException
役織の紐付けをメニューから削除します。

パラメータ:
menuId - メニューID
postInfo - 役織情報
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuPosts

public void deleteMenuPosts(String menuId)
                     throws AccessSecurityException
役織の紐付けをメニューからすべて削除します。

パラメータ:
menuId - メニューID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuPublicGroup

public void deleteMenuPublicGroup(String menuId,
                                  PublicGroupInfo publicGroupInfo)
                           throws AccessSecurityException
パブリックグループの紐付けをメニューから削除します。

パラメータ:
menuId - メニューID
publicGroupInfo - パブリックグループ
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuPublicGroups

public void deleteMenuPublicGroups(String menuId)
                            throws AccessSecurityException
パブリックグループの紐付けをメニューからすべて削除します。

パラメータ:
menuId - メニューID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuRole

public void deleteMenuRole(String menuId,
                           String roleId)
                    throws AccessSecurityException
ロールの紐付けをメニューから削除します。

パラメータ:
menuId - メニューID
roleId - ロールID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuRoles

public void deleteMenuRoles(String menuId)
                     throws AccessSecurityException
ロールの紐付けをメニューから削除します。

パラメータ:
menuId - メニューID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

exportData

public void exportData(String category,
                       OutputStream outputStream)
                throws AccessSecurityException
メニュー情報をエクスポートします。

パラメータ:
category - カテゴリ
outputStream - 出力ストリーム
例外:
AccessSecurityException - エクスポートに失敗した場合、または引数が不正だった場合にスローされます。

getAccountMenuTree

public MenuTree[] getAccountMenuTree(String userId,
                                     String clientType)
                              throws AccessSecurityException
指定したアカウントのメニュー構成を取得します。

このメソッドはメニューの絞り込みにPermissionManagerを利用しています。
PermissionManagerでメニューの絞り込みに利用されるカテゴリは、'account-menu'です。

パラメータ:
userId - ユーザID
clientType - クライアントタイプ
戻り値:
メニュー構成の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getChildMenuIds

public String[] getChildMenuIds(String menuId)
                         throws AccessSecurityException
子メニューIDを取得します。

パラメータ:
menuId - 親メニューID
戻り値:
子メニューIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getExportCategories

public String[] getExportCategories()
                             throws AccessSecurityException
メニューエクスポート用のカテゴリの一覧を取得します。

戻り値:
メニューエクスポート用カテゴリの一覧
例外:
AccessSecurityException - メニューエクスポート用のカテゴリの取得に失敗した場合にスローされます。

getFirstMenuIds

public String[] getFirstMenuIds()
                         throws AccessSecurityException
第一階層のメニューIDをすべて取得します。

戻り値:
第一階層のメニューIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getImportCategories

public String[] getImportCategories()
                             throws AccessSecurityException
メニューインポート用のカテゴリの一覧を取得します。

戻り値:
メニューインポート用カテゴリの一覧
例外:
AccessSecurityException - メニューインポート用のカテゴリの取得に失敗した場合にスローされます。

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

戻り値:
ログイングループID

getMenuDepartments

public DepartmentInfo[] getMenuDepartments(String menuId)
                                    throws AccessSecurityException
メニューに紐付いた組織の一覧を取得します。

パラメータ:
menuId - メニューID
戻り値:
組織情報の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getMenuIds

public String[] getMenuIds()
                    throws AccessSecurityException
すべてのメニューIDを取得します。

戻り値:
メニューIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getMenuIdsByDepartment

public String[] getMenuIdsByDepartment(DepartmentInfo[] departments)
                                throws AccessSecurityException
指定された組織を持つメニューIDをすべて取得します。

パラメータ:
departments - 組織情報の配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityException - メニュー情報取得に失敗した場合スローされます。

getMenuIdsByPost

public String[] getMenuIdsByPost(PostInfo[] posts)
                          throws AccessSecurityException
指定された役職を持つメニューIDをすべて取得します。

パラメータ:
posts - 役職情報の配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityException - メニュー情報取得に失敗した場合スローされます。

getMenuIdsByPublicGroup

public String[] getMenuIdsByPublicGroup(PublicGroupInfo[] publicGroups)
                                 throws AccessSecurityException
指定されたパブリックグループを持つメニューIDをすべて取得します。

パラメータ:
publicGroups - パブリックグループの配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityException - メニュー情報取得に失敗した場合スローされます。

getMenuIdsByRole

public String[] getMenuIdsByRole(String[] roleIds)
                          throws AccessSecurityException
指定されたロールIDを持つメニューIDをすべて取得します。

パラメータ:
roleIds - ロールIDの配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityException - メニュー情報取得に失敗した場合スローされます。

getMenuItem

public MenuItem getMenuItem(String menuId)
                     throws AccessSecurityException
指定されたメニューIDに対応するメニューを取得します。

パラメータ:
menuId - メニューID
戻り値:
メニュー
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getMenuItems

public MenuItem[] getMenuItems()
                        throws AccessSecurityException
すべてのメニューを取得します。

戻り値:
メニュー情報の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getMenuItemsByIds

public MenuItem[] getMenuItemsByIds(String[] menuIds)
                             throws AccessSecurityException
ログイングループ内で引数指定したメニューIDのメニュー情報をすべて取得します。

パラメータ:
menuIds - メニューIDの配列
戻り値:
メニュー情報の配列（データがない場合は空の配列を返します。）
例外:
AccessSecurityException - メニュー情報の取得に失敗した場合にスローされます。

getMenuPosts

public PostInfo[] getMenuPosts(String menuId)
                        throws AccessSecurityException
メニューに紐付いた役職の一覧を取得します。

パラメータ:
menuId - メニューID
戻り値:
役職情報の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getMenuPublicGroups

public PublicGroupInfo[] getMenuPublicGroups(String menuId)
                                      throws AccessSecurityException
メニューに紐付いたパブリックグループの一覧を取得します。

パラメータ:
menuId - メニューID
戻り値:
パブリックグループの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getMenuRoles

public String[] getMenuRoles(String menuId)
                      throws AccessSecurityException
メニューに紐付いたロールの一覧を取得します。

パラメータ:
menuId - メニューID
戻り値:
ロールIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getMenuTree

public MenuTree[] getMenuTree()
                       throws AccessSecurityException
メニュー構成を取得します。

戻り値:
メニュー構成の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getMenuTree

public MenuTree[] getMenuTree(String clientType)
                       throws AccessSecurityException
指定されたクライアントタイプのみのメニュー構成を取得します。

パラメータ:
clientType - クライアントタイプ この値がnullの場合は、すべてのクライアントタイプが対象となります。
戻り値:
メニュー構成の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getMenuTree

public MenuTree[] getMenuTree(String clientType,
                              String[] menuIds,
                              boolean showNoChildFolder)
                       throws AccessSecurityException
指定されたクライアントタイプと指定されたメニューIDのみのメニュー構成を取得します。

パラメータ:
clientType - クライアントタイプ
この値がnullの場合は、すべてのクライアントタイプが対象となります。
menuIds - 作成対象のメニューIDの配列
この値がnullの場合は、すべてのメニューIDが対象となります。
showNoChildFolder - 子メニューを持た持たないフォルダーを表示するかどうか
戻り値:
メニュー構成の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getParentMenuId

public String getParentMenuId(String menuId)
                       throws AccessSecurityException
指定されたメニューの親メニューを取得します。

メニューIDがトップメニューであった場合は、nullを返却します。

パラメータ:
menuId - メニューID
戻り値:
親メニューID
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

importData

public void importData(String category,
                       InputStream inputStream)
                throws AccessSecurityException
メニュー情報をインポートします。

パラメータ:
category - カテゴリ
inputStream - 入力ストリーム
例外:
AccessSecurityException - インポートに失敗した場合、または引数が不正だった場合にスローされます。

moveMenuItem

public void moveMenuItem(MenuInclusion menuInclusion)
                  throws AccessSecurityException
メニューを移動します。

パラメータ:
menuInclusion - 新しいメニュー構成
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または書き込み処理に失敗した場合にスローされます。

updateMenuItem

public void updateMenuItem(MenuItem menuItem)
                    throws AccessSecurityException
メニューを更新します。

パラメータ:
menuItem - メニュー情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

isUpdate

public boolean isUpdate(Date date)
                 throws AccessSecurityException
メニュー情報が指定された日付よりも新しいかチェックします。

パラメータ:
date - チェック日付
例外:
AccessSecurityReadException - 更新チェックに失敗した場合スローされます。
AccessSecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuPostWriterListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース MenuPostWriterListener

public interface MenuPostWriterListener

メニュー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
MenuManager

メソッドの概要
void | init(Map params) メニューリスナーの初期化。
void | postCreate(String groupId, MenuItem item) メニュー情報をデータストアに作成した直後にコールされます。
void | postDelete(String groupId, String menuId) メニュー情報をデータストアから削除した直後にコールされます。
void | postMove(String groupId, String parentId, String childId) メニューの親子関係を更新した直後にコールされます。
void | postUpdate(String groupId, MenuItem item) メニュー情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
メニューリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreate

public void postCreate(String groupId,
                       MenuItem item)
                throws AccessSecurityListenerExcpetion
メニュー情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
item - 作成されたメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDelete

public void postDelete(String groupId,
                       String menuId)
                throws AccessSecurityListenerExcpetion
メニュー情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
menuId - 削除されたメニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdate

public void postUpdate(String groupId,
                       MenuItem item)
                throws AccessSecurityListenerExcpetion
メニュー情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
item - 更新されたメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postMove

public void postMove(String groupId,
                     String parentId,
                     String childId)
              throws AccessSecurityListenerExcpetion
メニューの親子関係を更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
parentId - 新しい親メニューID
childId - 新しい子メニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuQueryWriterListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース MenuQueryWriterListener

public interface MenuQueryWriterListener

メニュー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
MenuManager

メソッドの概要
void | init(Map params) メニューリスナーの初期化。
void | queryCreate(String groupId, MenuItem item) メニュー情報をデータストアに作成する直前にコールされます。
void | queryDelete(String groupId, String menuId) メニュー情報をデータストアから削除する直前にコールされます。
void | queryMove(String groupId, String parentId, String childId) メニューの親子関係を更新する直前にコールされます。
void | queryUpdate(String groupId, MenuItem item) メニュー情報をデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
メニューリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreate

public void queryCreate(String groupId,
                        MenuItem item)
                 throws AccessSecurityListenerExcpetion
メニュー情報をデータストアに作成する直前にコールされます。

パラメータ:
groupId - ログイングループID
item - 作成されるメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDelete

public void queryDelete(String groupId,
                        String menuId)
                 throws AccessSecurityListenerExcpetion
メニュー情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
menuId - 削除されるメニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdate

public void queryUpdate(String groupId,
                        MenuItem item)
                 throws AccessSecurityListenerExcpetion
メニュー情報をデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
item - 更新されるメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryMove

public void queryMove(String groupId,
                      String parentId,
                      String childId)
               throws AccessSecurityListenerExcpetion
メニューの親子関係を更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
parentId - 新しい親メニューID
childId - 新しい子メニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuReaderDecorator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース MenuReaderDecorator

public interface MenuReaderDecorator

メニュー情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
MenuItem | doDecoration(String groupId, MenuItem item) メニューデータストアからの読み込み直後にコールされます。
void | init(Map params) メニューデコレータの初期化。

メソッドの詳細

init

public void init(Map params)
メニューデコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public MenuItem doDecoration(String groupId,
                             MenuItem item)
メニューデータストアからの読み込み直後にコールされます。

パラメータ:
groupId - ログイングループID
item - 読み込みが行われたメニュー情報
戻り値:
拡張されたメニュー情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MenuTree (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス MenuTree

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.MenuTree
すべての実装インタフェース:
Comparator
public class MenuTree
extends Object
implements Comparator

メニューツリークラス。

メニューをツリー形式で保管するクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
MenuTree(MenuItem menuItem)
コンストラクタ。
メソッドの概要
void | addChild(MenuTree menuTree) 子メニューを追加します。
int | compare(Object o1, Object o2) 順序付けのために 2 つの引数を比較します。
void | deleteChild(String menuId) 子メニューを削除します。
boolean | equals(Object obj) このオブジェクトと他のオブジェクトが等しいかどうかを示します。
MenuTree[] | getChildren() 子メニューの一覧を取得します。
MenuItem | getMenuItem() メニューを取得します。
boolean | hasChildren() 子メニューが存在するかどうかを取得します。
int | hashCode() ハッシュコードを取得します。
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MenuTree

public MenuTree(MenuItem menuItem)
コンストラクタ。

パラメータ:
menuItem - メニュー
メソッドの詳細

addChild

public void addChild(MenuTree menuTree)
子メニューを追加します。

パラメータ:
menuTree - 子メニューのMenuTree

compare

public int compare(Object o1,
                   Object o2)
順序付けのために 2 つの引数を比較します。

定義:
インタフェース Comparator 内の compare
パラメータ:
o1 - 比較対象の最初のオブジェクト
o2 - 比較対象の 2 番目のオブジェクト
戻り値:
最初の引数が 2 番目の引数より小さい場合は負の整数、両方が等しい場合は 0、最初の引数が 2 番目の引数より大きい場合は正の整数
関連項目:
Comparator.compare(java.lang.Object, java.lang.Object)

deleteChild

public void deleteChild(String menuId)
子メニューを削除します。

パラメータ:
menuId - メニューID

equals

public boolean equals(Object obj)
このオブジェクトと他のオブジェクトが等しいかどうかを示します。

定義:
インタフェース Comparator 内の equals
パラメータ:
obj - 比較対象の参照オブジェクト
戻り値:
引数に指定されたオブジェクトとこのオブジェクトが等しい場合は true、そうでない場合は false
関連項目:
Object.equals(java.lang.Object)

getChildren

public MenuTree[] getChildren()
子メニューの一覧を取得します。

戻り値:
子メニュー(MenuTree)の配列

hasChildren

public boolean hasChildren()
子メニューが存在するかどうかを取得します。

戻り値:
true : 子メニューあり / false : 子メニューなし

getMenuItem

public MenuItem getMenuItem()
メニューを取得します。

戻り値:
メニュー

hashCode

public int hashCode()
ハッシュコードを取得します。

戻り値:
ハッシュコード
関連項目:
Object.hashCode()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.menu (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.security.menu
インタフェース
AdminMenuAccessor
AdminMenuExporter
AdminMenuImporter
AdminMenuPostWriterListener
AdminMenuQueryWriterListener
AdminMenuReaderDecorator
MenuAccessor
MenuExporter
MenuImporter
MenuPostWriterListener
MenuQueryWriterListener
MenuReaderDecorator
クラス
AdminMenuInclusion
AdminMenuManager
CompanyChangedMenuListener
MenuInclusion
MenuItem
MenuManager
MenuTree
PublicGroupChangedMenuListener
RoleChangedMenuListener
StandardAdminMenuBackup
StandardMenuBackup


jp.co.intra_mart.foundation.security.menu (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.menu

メニューに関連するクラスを提供します。

参照:
説明

インタフェースの概要
AdminMenuAccessor | メニューアクセッサインタフェース。
AdminMenuExporter | メニューエクスポートインタフェースです。
AdminMenuImporter | メニューインポートインタフェースです。
AdminMenuPostWriterListener | メニュー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AdminMenuQueryWriterListener | メニュー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
AdminMenuReaderDecorator | メニュー情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
MenuAccessor | メニューアクセッサインタフェース。
MenuExporter | メニューエクスポートインタフェースです。
MenuImporter | メニューインポートインタフェースです。
MenuPostWriterListener | メニュー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
MenuQueryWriterListener | メニュー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
MenuReaderDecorator | メニュー情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

クラスの概要
AdminMenuInclusion | メニュー内包情報クラス。
AdminMenuManager | 管理メニューマネージャクラス。
CompanyChangedMenuListener | 会社・組織に関する情報の変更時のリスナーです。
MenuInclusion | メニュー内包情報クラス。
MenuItem | メニュー・モデルクラス。
MenuManager | メニューマネージャクラス。
MenuTree | メニューツリークラス。
PublicGroupChangedMenuListener | パブリックグループに関する情報の変更時のリスナーです。
RoleChangedMenuListener | ロールが削除された場合にメニューに紐付くロールを削除するリスナークラス。
StandardAdminMenuBackup | メニューバックアップクラスです。
StandardMenuBackup | メニューバックアップクラスです。

パッケージ jp.co.intra_mart.foundation.security.menu の説明

メニューに関連するクラスを提供します。


jp.co.intra_mart.foundation.security.menu クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.menu の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.AdminMenuManager
    • class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener)
    • class jp.co.intra_mart.foundation.security.menu.MenuInclusion (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.MenuItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.MenuManager
    • class jp.co.intra_mart.foundation.security.menu.MenuTree (implements java.util.Comparator)
    • class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener (implements jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener)
    • class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener (implements jp.co.intra_mart.foundation.security.role.RoleChangedListener)
    • class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup (implements jp.co.intra_mart.foundation.security.menu.AdminMenuExporter, jp.co.intra_mart.foundation.security.menu.AdminMenuImporter)
    • class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup (implements jp.co.intra_mart.foundation.security.menu.MenuExporter, jp.co.intra_mart.foundation.security.menu.MenuImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuExporter
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuImporter
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator
  • interface jp.co.intra_mart.foundation.security.menu.MenuAccessor
  • interface jp.co.intra_mart.foundation.security.menu.MenuExporter
  • interface jp.co.intra_mart.foundation.security.menu.MenuImporter
  • interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator


パッケージ jp.co.intra_mart.foundation.security.menu の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.menu の使用

jp.co.intra_mart.foundation.security.menu を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security により使用される jp.co.intra_mart.foundation.security.menu のクラス
MenuAccessor
メニューアクセッサインタフェース。
MenuInclusion
メニュー内包情報クラス。
MenuItem
メニュー・モデルクラス。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.security.menu のクラス
AdminMenuExporter
メニューエクスポートインタフェースです。
AdminMenuImporter
メニューインポートインタフェースです。
AdminMenuManager
管理メニューマネージャクラス。
MenuExporter
メニューエクスポートインタフェースです。
MenuImporter
メニューインポートインタフェースです。
MenuInclusion
メニュー内包情報クラス。
MenuItem
メニュー・モデルクラス。
MenuManager
メニューマネージャクラス。
MenuTree
メニューツリークラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupChangedMenuListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス PublicGroupChangedMenuListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener
すべての実装インタフェース:
PublicGroupChangedListener
public class PublicGroupChangedMenuListener
extends Object
implements PublicGroupChangedListener

パブリックグループに関する情報の変更時のリスナーです。

導入されたバージョン:
5.0

コンストラクタの概要
PublicGroupChangedMenuListener()
メソッドの概要
void | categoryDetailRemoved(String groupId, PublicGroupCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | categoryDetailSet(String groupId, PublicGroupCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | groupSetAdded(String groupId, PublicGroupSet groupSet) グループセットがデータストアに登録された後に呼び出されます。
void | groupSetDeleted(String groupId, PublicGroupSet groupSet) グループセットがデータストアから削除された後に呼び出されます。
void | init(Map params) アカウントリスナーの初期化を行います。
void | memberDeleted(String groupId, PublicGroupAttach attach) パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
void | memberSet(String groupId, PublicGroupAttach attach) パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
void | publicGroupAdded(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに登録された後に呼び出されます。
void | publicGroupDeleted(String groupId, PublicGroup publicGroup) パブリックグループがデータストアから削除された後に呼び出されます。
void | publicGroupJoined(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
void | publicGroupLeft(String groupId, String groupSet, String publicGroup, String version) パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
void | publicGroupMoved(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
void | publicGroupUpdated(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに更新された後に呼び出されます。
void | setUesrId(String userid) ログインユーザIDを設定します。
void | versionAdded(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
void | versionCopied(String groupId, String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
void | versionDeleted(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
void | versionUpdated(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupChangedMenuListener

public PublicGroupChangedMenuListener()
メソッドの詳細

init

public void init(Map params)
アカウントリスナーの初期化を行います。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

setUesrId

public void setUesrId(String userid)
ログインユーザIDを設定します。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の setUesrId
パラメータ:
userid - ログインユーザID

groupSetAdded

public void groupSetAdded(String groupId,
                          PublicGroupSet groupSet)
                   throws ChangedListenerException
グループセットがデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の groupSetAdded
パラメータ:
groupId - ログイングループID
groupSet - グループセット
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

groupSetDeleted

public void groupSetDeleted(String groupId,
                            PublicGroupSet groupSet)
                     throws ChangedListenerException
グループセットがデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の groupSetDeleted
パラメータ:
groupId - ログイングループID
groupSet - グループセット
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupAdded

public void publicGroupAdded(String groupId,
                             PublicGroup publicGroup)
                      throws ChangedListenerException
パブリックグループがデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupAdded
パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupUpdated

public void publicGroupUpdated(String groupId,
                               PublicGroup publicGroup)
                        throws ChangedListenerException
パブリックグループがデータストアに更新された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupUpdated
パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupDeleted

public void publicGroupDeleted(String groupId,
                               PublicGroup publicGroup)
                        throws ChangedListenerException
パブリックグループがデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupDeleted
パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupJoined

public void publicGroupJoined(String groupId,
                              String groupSet,
                              String parentGroup,
                              String publicGroup,
                              String version)
                       throws ChangedListenerException
パブリックグループ構成情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupJoined
パラメータ:
groupId - ログイングループID
groupSet - 上位パブリックグループと新規登録されるパブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup - 新規登録するパブリックグループの上位となるパブリックグループのグループコード（またはパブリックグループセットのグループセットコード）
publicGroup - パブリックグループ情報（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupMoved

public void publicGroupMoved(String groupId,
                             String groupSet,
                             String parentGroup,
                             String publicGroup,
                             String version)
                      throws ChangedListenerException
パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupMoved
パラメータ:
groupId - ログイングループID
groupSet - 上位パブリックグループと移動対象のパブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup - 上位パブリックグループのグループコード（またはパブリックグループセットのグループセットコード）
publicGroup - 移動するパブリックグループのグループコード（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupLeft

public void publicGroupLeft(String groupId,
                            String groupSet,
                            String publicGroup,
                            String version)
                     throws ChangedListenerException
パブリックグループ構成情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupLeft
パラメータ:
groupId - ログイングループID
groupSet - グループセットコード
publicGroup - 離脱させるパブリックグループのグループコード（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailSet

public void categoryDetailSet(String groupId,
                              PublicGroupCategory category)
                       throws ChangedListenerException
分類区分情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の categoryDetailSet
パラメータ:
groupId - ログイングループID
category - 分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailRemoved

public void categoryDetailRemoved(String groupId,
                                  PublicGroupCategory category)
                           throws ChangedListenerException
分類区分情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の categoryDetailRemoved
パラメータ:
groupId - ログイングループID
category - 分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberSet

public void memberSet(String groupId,
                      PublicGroupAttach attach)
               throws ChangedListenerException
パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の memberSet
パラメータ:
groupId - ログイングループID
attach - 割当られた人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberDeleted

public void memberDeleted(String groupId,
                          PublicGroupAttach attach)
                   throws ChangedListenerException
パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の memberDeleted
パラメータ:
groupId - ログイングループID
attach - パブリックグループから外された人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionAdded

public void versionAdded(String groupId,
                         PublicGroupVersion version)
                  throws ChangedListenerException
パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の versionAdded
パラメータ:
groupId - ログイングループID
version - パブリックグループ構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionUpdated

public void versionUpdated(String groupId,
                           PublicGroupVersion version)
                    throws ChangedListenerException
パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の versionUpdated
パラメータ:
groupId - ログイングループID
version - パブリックグループセット構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionDeleted

public void versionDeleted(String groupId,
                           PublicGroupVersion version)
                    throws ChangedListenerException
パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の versionDeleted
パラメータ:
groupId - ログイングループID
version - パブリックグループセット構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionCopied

public void versionCopied(String groupId,
                          String groupSet,
                          String srcVersion,
                          String destVersion,
                          Term term)
                   throws ChangedListenerException
登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の versionCopied
パラメータ:
groupId - ログイングループID
groupSet - コピー元、コピー先のパブリックグループセット構成バージョンのパブリックグループコード
srcVersion - コピー元のパブリックグループセット構成バージョンのバージョンコード
destVersion - コピー先のパブリックグループセット構成バージョンのバージョンコード
term - コピー先のパブリックグループセット構成バージョンの期間
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleChangedMenuListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス RoleChangedMenuListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener
すべての実装インタフェース:
RoleChangedListener
public class RoleChangedMenuListener
extends Object
implements RoleChangedListener

ロールが削除された場合にメニューに紐付くロールを削除するリスナークラス。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
RoleChangedMenuListener()
コンストラクタ。
メソッドの概要
void | init(Map params) ロールリスナーの初期化。
void | roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | roleDeleted(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | subRoleAdded(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | subRoleDeleted(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RoleChangedMenuListener

public RoleChangedMenuListener()
コンストラクタ。

メソッドの詳細

init

public void init(Map params)
ロールリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース RoleChangedListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

roleAdded

public void roleAdded(String groupId,
                      Role role)
               throws ChangedListenerException
ロール情報をデータストアに作成した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の roleAdded
パラメータ:
groupId - ログイングループID
role - 作成されたロール
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

roleDeleted

public void roleDeleted(String groupId,
                        String roleId)
                 throws ChangedListenerException
ロール情報をデータストアから削除した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の roleDeleted
パラメータ:
groupId - ログイングループID
roleId - 削除されたロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

roleUpdated

public void roleUpdated(String groupId,
                        Role role)
                 throws ChangedListenerException
ロール情報をデータストアに更新した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の roleUpdated
パラメータ:
groupId - ログイングループID
role - 更新されたロール
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

subRoleAdded

public void subRoleAdded(String groupId,
                         String roleId,
                         String subRoleId)
                  throws ChangedListenerException
ロールにサブロールを追加した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の subRoleAdded
パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 追加されたサブロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

subRoleDeleted

public void subRoleDeleted(String groupId,
                           String roleId,
                           String subRoleId)
                    throws ChangedListenerException
ロールからサブロールを削除した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の subRoleDeleted
パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 削除されたサブロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardAdminMenuBackup (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス StandardAdminMenuBackup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup
すべての実装インタフェース:
AdminMenuExporter, AdminMenuImporter
public class StandardAdminMenuBackup
extends Object
implements AdminMenuImporter, AdminMenuExporter

メニューバックアップクラスです。

バージョン:
1.0

コンストラクタの概要
StandardAdminMenuBackup()
メソッドの概要
void | doExport(AdminMenuManager manager, OutputStream outputStream) エクスポートを行います。
void | doImport(InputStream inputStream, AdminMenuManager manager) インポートを行います。
void | init(Map params) 初期化。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardAdminMenuBackup

public StandardAdminMenuBackup()
メソッドの詳細

init

public void init(Map params)
初期化。

初期化します。

定義:
インタフェース AdminMenuImporter 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     AdminMenuManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からメニュー情報を生成します。

定義:
インタフェース AdminMenuImporter 内の doImport
パラメータ:
manager - メニューマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

doExport

public void doExport(AdminMenuManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

メニューバックアップ情報を生成し、ストリームに返却します。

定義:
インタフェース AdminMenuExporter 内の doExport
パラメータ:
manager - メニューマネージャクラス
outputStream - 出力ストリーム
例外:
AccessSecurityExportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardMenuBackup (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス StandardMenuBackup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.StandardMenuBackup
すべての実装インタフェース:
MenuExporter, MenuImporter
public class StandardMenuBackup
extends Object
implements MenuImporter, MenuExporter

メニューバックアップクラスです。

バージョン:
1.0

コンストラクタの概要
StandardMenuBackup()
メソッドの概要
void | doExport(MenuManager manager, OutputStream outputStream) エクスポートを行います。
void | doImport(InputStream inputStream, MenuManager manager) インポートを行います。
void | init(Map params) 初期化。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardMenuBackup

public StandardMenuBackup()
メソッドの詳細

init

public void init(Map params)
初期化。

初期化します。

定義:
インタフェース MenuImporter 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     MenuManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からメニュー情報を生成します。

定義:
インタフェース MenuImporter 内の doImport
パラメータ:
manager - メニューマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

doExport

public void doExport(MenuManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

メニューバックアップ情報を生成し、ストリームに返却します。

定義:
インタフェース MenuExporter 内の doExport
パラメータ:
manager - メニューマネージャクラス
outputStream - 出力ストリーム
例外:
AccessSecurityExportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.message.MessageManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.message.MessageManager の使用

MessageManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.message メッセージに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.message での MessageManager の使用

MessageManager を返す jp.co.intra_mart.foundation.security.message のメソッド
static MessageManager MessageManager.getInstance()
メッセージマネージャのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


MessageManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.message
クラス MessageManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.message.MessageManager
public class MessageManager
extends Object

メッセージマネージャクラス。

メッセージを取得するクラス。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
static MessageManager | getInstance() メッセージマネージャのインスタンスを取得します。
String | getMessage(Locale locale, String key) メッセージを取得します。
String | getMessage(Locale locale, String key, String arg) メッセージを取得します。
String | getMessage(Locale locale, String key, String[] args) メッセージを取得します。
String | getMessage(Locale locale, String key, String arg1, String arg2) メッセージを取得します。
String | getMessage(Locale locale, String key, String arg1, String arg2, String arg3) メッセージを取得します。
String | getMessage(String key) メッセージを取得します。
String | getMessage(String key, String arg) メッセージを取得します。
String | getMessage(String key, String[] args) メッセージを取得します。
String | getMessage(String key, String arg1, String arg2) メッセージを取得します。
String | getMessage(String key, String arg1, String arg2, String arg3) メッセージを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getInstance

public static MessageManager getInstance()
メッセージマネージャのインスタンスを取得します。

戻り値:
メッセージマネージャのインスタンス

getMessage

public String getMessage(Locale locale,
                         String key)
                  throws AccessSecurityException
メッセージを取得します。

指定ロケールでメッセージを取得します。

パラメータ:
locale - 指定ロケール
key - メッセージキー名
戻り値:
アクセスセキュリティメッセージ
例外:
AccessSecurityException - 引数が不正な場合にスローされます。

getMessage

public String getMessage(Locale locale,
                         String key,
                         String arg)
                  throws AccessSecurityException
メッセージを取得します。

指定ロケールでメッセージを取得します。
引数に置換文字列を１つ取ります。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。
よってメッセージキー名により取得されるメッセージの内容を上記メソッドの第1引数に渡して処理しますので、
対応するメッセージの内容（propertiesファイルの内容）は、MessageFormatのpattern文字列に沿ったメッセージを記述してください。

置換文字列を利用した場合,取得結果に対して
"'"を表現するには"''"
"{"を表現するには"'{"
を対象のメッセージに記述してください。

パラメータ:
locale - 指定ロケール
key - メッセージキー名
arg - 置換文字列
戻り値:
置換文字列をを挿入したメッセージ
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。

getMessage

public String getMessage(Locale locale,
                         String key,
                         String arg1,
                         String arg2)
                  throws AccessSecurityException
メッセージを取得します。

指定ロケールでメッセージを取得します。
引数に置換文字列を２つ取ります。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。
よってメッセージキー名により取得されるメッセージの内容を上記メソッドの第1引数に渡して処理しますので、
対応するメッセージの内容（propertiesファイルの内容）は、MessageFormatのpattern文字列に沿ったメッセージを記述してください。

置換文字列を利用した場合,取得結果に対して
"'"を表現するには"''"
"{"を表現するには"'{"
を対象のメッセージに記述してください。

パラメータ:
locale - 指定ロケール
key - メッセージキー名
arg1 - 置換文字列１
arg2 - 置換文字列２
戻り値:
置換文字列をを挿入したメッセージ
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。

getMessage

public String getMessage(Locale locale,
                         String key,
                         String arg1,
                         String arg2,
                         String arg3)
                  throws AccessSecurityException
メッセージを取得します。

指定ロケールでメッセージを取得します。
引数に置換文字列を３つ取ります。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。
よってメッセージキー名により取得されるメッセージの内容を上記メソッドの第1引数に渡して処理しますので、
対応するメッセージの内容（propertiesファイルの内容）は、MessageFormatのpattern文字列に沿ったメッセージを記述してください。

置換文字列を利用した場合,取得結果に対して
"'"を表現するには"''"
"{"を表現するには"'{"
を対象のメッセージに記述してください。

パラメータ:
locale - 指定ロケール
key - メッセージキー名
arg1 - 置換文字列１
arg2 - 置換文字列２
arg3 - 置換文字列３
戻り値:
置換文字列をを挿入したメッセージ
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。

getMessage

public String getMessage(Locale locale,
                         String key,
                         String[] args)
                  throws AccessSecurityException
メッセージを取得します。

指定ロケールでメッセージを取得します。
引数に置換文字列の配列を取ります。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。
よってメッセージキー名により取得されるメッセージの内容を上記メソッドの第1引数に渡して処理しますので、
対応するメッセージの内容（propertiesファイルの内容）は、MessageFormatのpattern文字列に沿ったメッセージを記述してください。

置換文字列を利用した場合,取得結果に対して
"'"を表現するには"''"
"{"を表現するには"'{"
を対象のメッセージに記述してください。

置換文字列の配列に空の配列を指定した場合、MessageFormat#format関数を利用しませんので、取得したメッセージを変換せずにそのまま返却します。

パラメータ:
locale - 指定ロケール
key - メッセージキー名
args - 置換文字列の配列
戻り値:
置換文字列をを挿入したメッセージ
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。

getMessage

public String getMessage(String key)
                  throws AccessSecurityException
メッセージを取得します。

現在ログインしているユーザのロケールでメッセージを取得します。

パラメータ:
key - メッセージキー名
戻り値:
メッセージ
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。

getMessage

public String getMessage(String key,
                         String arg)
                  throws AccessSecurityException
メッセージを取得します。

現在ログインしているユーザのロケールでメッセージを取得します。
引数に置換文字列を１つ取ります。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。
よってメッセージキー名により取得されるメッセージの内容を上記メソッドの第1引数に渡して処理しますので、
対応するメッセージの内容（propertiesファイルの内容）は、MessageFormatのpattern文字列に沿ったメッセージを記述してください。

置換文字列を利用した場合,取得結果に対して
"'"を表現するには"''"
"{"を表現するには"'{"
を対象のメッセージに記述してください。

パラメータ:
key - メッセージキー名
arg - 置換文字列
戻り値:
置換文字列をを挿入したメッセージ
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。

getMessage

public String getMessage(String key,
                         String arg1,
                         String arg2)
                  throws AccessSecurityException
メッセージを取得します。

現在ログインしているユーザのロケールでメッセージを取得します。
引数に置換文字列を２つ取ります。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。
よってメッセージキー名により取得されるメッセージの内容を上記メソッドの第1引数に渡して処理しますので、
対応するメッセージの内容（propertiesファイルの内容）は、MessageFormatのpattern文字列に沿ったメッセージを記述してください。

置換文字列を利用した場合,取得結果に対して
"'"を表現するには"''"
"{"を表現するには"'{"
を対象のメッセージに記述してください。

パラメータ:
key - メッセージキー名
arg1 - 置換文字列１
arg2 - 置換文字列２
戻り値:
置換文字列をを挿入したメッセージ
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。

getMessage

public String getMessage(String key,
                         String arg1,
                         String arg2,
                         String arg3)
                  throws AccessSecurityException
メッセージを取得します。

現在ログインしているユーザのロケールでメッセージを取得します。
引数に置換文字列を３つ取ります。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。
よってメッセージキー名により取得されるメッセージの内容を上記メソッドの第1引数に渡して処理しますので、
対応するメッセージの内容（propertiesファイルの内容）は、MessageFormatのpattern文字列に沿ったメッセージを記述してください。

置換文字列を利用した場合,取得結果に対して
"'"を表現するには"''"
"{"を表現するには"'{"
を対象のメッセージに記述してください。

パラメータ:
key - メッセージキー名
arg1 - 置換文字列１
arg2 - 置換文字列２
arg3 - 置換文字列３
戻り値:
置換文字列をを挿入したメッセージ
例外:
AccessSecurityException - 引数が不正な場合にスローされます。

getMessage

public String getMessage(String key,
                         String[] args)
                  throws AccessSecurityException
メッセージを取得します。

現在ログインしているユーザのロケールでメッセージを取得します。
引数に置換文字列の配列を取ります。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。
よってメッセージキー名により取得されるメッセージの内容を上記メソッドの第1引数に渡して処理しますので、
対応するメッセージの内容（propertiesファイルの内容）は、MessageFormatのpattern文字列に沿ったメッセージを記述してください。

置換文字列を利用した場合,取得結果に対して
"'"を表現するには"''"
"{"を表現するには"'{"
を対象のメッセージに記述してください。

置換文字列の配列に空の配列を指定した場合、MessageFormat#format関数を利用しませんので、取得したメッセージを変換せずにそのまま返却します。

パラメータ:
key - メッセージキー名
args - 置換文字列の配列
戻り値:
置換文字列をを挿入したメッセージ
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.message (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.security.message
クラス
MessageManager


jp.co.intra_mart.foundation.security.message (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.message

メッセージに関連するクラスを提供します。

参照:
説明

クラスの概要
MessageManager メッセージマネージャクラス。

パッケージ jp.co.intra_mart.foundation.security.message の説明

メッセージに関連するクラスを提供します。


jp.co.intra_mart.foundation.security.message クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.message の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.message.MessageManager


パッケージ jp.co.intra_mart.foundation.security.message の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.message の使用

jp.co.intra_mart.foundation.security.message を使用しているパッケージ
jp.co.intra_mart.foundation.security.message メッセージに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.message により使用される jp.co.intra_mart.foundation.security.message のクラス
MessageManager
メッセージマネージャクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuAnalyzer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuAnalyzer の使用

jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuAnalyzer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuHdmlAnalyzer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuHdmlAnalyzer の使用

jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuHdmlAnalyzer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoAnalyzer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoAnalyzer の使用

jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoAnalyzer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoMoveAnalyzer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoMoveAnalyzer の使用

jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoMoveAnalyzer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginJphoneAnalyzer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginJphoneAnalyzer の使用

jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginJphoneAnalyzer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginSoftBankAnalyzer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginSoftBankAnalyzer の使用

jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginSoftBankAnalyzer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginVodafoneAnalyzer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginVodafoneAnalyzer の使用

jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginVodafoneAnalyzer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider の使用

MobileUserAgentProvider を使用しているパッケージ
jp.co.intra_mart.foundation.security.mobile

jp.co.intra_mart.foundation.security.mobile での MobileUserAgentProvider の使用

MobileUserAgentProvider を実装している jp.co.intra_mart.foundation.security.mobile のクラス
class | MobileEasyLoginAuAnalyzer モバイル端末固体識別番号取得プロバイダクラス Au用(WAP2.0)
class | MobileEasyLoginAuHdmlAnalyzer 推奨されていません。
class | MobileEasyLoginDocomoAnalyzer モバイル端末固体識別番号取得プロバイダクラス NTT DoCoMo用(FOMA)
class | MobileEasyLoginDocomoMoveAnalyzer 推奨されていません。
class | MobileEasyLoginJphoneAnalyzer 推奨されていません。
class | MobileEasyLoginSoftBankAnalyzer モバイル端末固体識別番号取得プロバイダクラス SoftBank用(3GC型)
class | MobileEasyLoginVodafoneAnalyzer モバイル端末固体識別番号取得プロバイダクラス Vodafone用(3GC型)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


MobileEasyLoginAuAnalyzer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.mobile
クラス MobileEasyLoginAuAnalyzer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuAnalyzer
すべての実装インタフェース:
MobileUserAgentProvider
public class MobileEasyLoginAuAnalyzer
extends Object
implements MobileUserAgentProvider

モバイル端末固体識別番号取得プロバイダクラス Au用(WAP2.0)

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
MobileEasyLoginAuAnalyzer()
メソッドの概要
boolean | checkMobile(String userAgent, HttpServletRequest request) モバイル端末の種別をチェックします。
String | getUserAgent(String userAgent, HttpServletRequest request) モバイル端末固体識別番号を取得します。
void | init(Node node) モバイル端末固体識別番号取得プロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MobileEasyLoginAuAnalyzer

public MobileEasyLoginAuAnalyzer()
メソッドの詳細

init

public void init(Node node)
モバイル端末固体識別番号取得プロバイダの初期化を行います。

定義:
インタフェース MobileUserAgentProvider 内の init
パラメータ:
node - ノード

checkMobile

public boolean checkMobile(String userAgent,
                           HttpServletRequest request)
モバイル端末の種別をチェックします。

定義:
インタフェース MobileUserAgentProvider 内の checkMobile
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
対象のモバイル端末の場合は true を返却します。

getUserAgent

public String getUserAgent(String userAgent,
                           HttpServletRequest request)
モバイル端末固体識別番号を取得します。 モバイル端末固体識別番号が取得できなかった場合はnullを返却します。

定義:
インタフェース MobileUserAgentProvider 内の getUserAgent
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
固体識別番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MobileEasyLoginAuHdmlAnalyzer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.mobile
クラス MobileEasyLoginAuHdmlAnalyzer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuHdmlAnalyzer
すべての実装インタフェース:
MobileUserAgentProvider

public class MobileEasyLoginAuHdmlAnalyzer
extends Object
implements MobileUserAgentProvider

モバイル端末固体識別番号取得プロバイダクラス Au用(HDML)

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
MobileEasyLoginAuHdmlAnalyzer()
推奨されていません。
メソッドの概要
boolean | checkMobile(String userAgent, HttpServletRequest request) 推奨されていません。 モバイル端末の種別をチェックします。
String | getUserAgent(String userAgent, HttpServletRequest request) 推奨されていません。 モバイル端末固体識別番号を取得します。
void | init(Node node) 推奨されていません。 モバイル端末固体識別番号取得プロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MobileEasyLoginAuHdmlAnalyzer

public MobileEasyLoginAuHdmlAnalyzer()
推奨されていません。
メソッドの詳細

init

public void init(Node node)
推奨されていません。
モバイル端末固体識別番号取得プロバイダの初期化を行います。

定義:
インタフェース MobileUserAgentProvider 内の init
パラメータ:
node - ノード

checkMobile

public boolean checkMobile(String userAgent,
                           HttpServletRequest request)
推奨されていません。
モバイル端末の種別をチェックします。

定義:
インタフェース MobileUserAgentProvider 内の checkMobile
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
対象のモバイル端末の場合は true を返却します。

getUserAgent

public String getUserAgent(String userAgent,
                           HttpServletRequest request)
推奨されていません。
モバイル端末固体識別番号を取得します。 モバイル端末固体識別番号が取得できなかった場合はnullを返却します。

定義:
インタフェース MobileUserAgentProvider 内の getUserAgent
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
固体識別番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MobileEasyLoginDocomoAnalyzer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.mobile
クラス MobileEasyLoginDocomoAnalyzer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoAnalyzer
すべての実装インタフェース:
MobileUserAgentProvider
public class MobileEasyLoginDocomoAnalyzer
extends Object
implements MobileUserAgentProvider

モバイル端末固体識別番号取得プロバイダクラス NTT DoCoMo用(FOMA)

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
MobileEasyLoginDocomoAnalyzer()
メソッドの概要
boolean | checkMobile(String userAgent, HttpServletRequest request) モバイル端末の種別をチェックします。
String | getUserAgent(String userAgent, HttpServletRequest request) モバイル端末固体識別番号を取得します。
void | init(Node node) モバイル端末固体識別番号取得プロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MobileEasyLoginDocomoAnalyzer

public MobileEasyLoginDocomoAnalyzer()
メソッドの詳細

init

public void init(Node node)
モバイル端末固体識別番号取得プロバイダの初期化を行います。

定義:
インタフェース MobileUserAgentProvider 内の init
パラメータ:
node - ノード

checkMobile

public boolean checkMobile(String userAgent,
                           HttpServletRequest request)
モバイル端末の種別をチェックします。

定義:
インタフェース MobileUserAgentProvider 内の checkMobile
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
対象のモバイル端末の場合は true を返却します。

getUserAgent

public String getUserAgent(String userAgent,
                           HttpServletRequest request)
モバイル端末固体識別番号を取得します。 モバイル端末固体識別番号が取得できなかった場合はnullを返却します。

定義:
インタフェース MobileUserAgentProvider 内の getUserAgent
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
固体識別番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MobileEasyLoginDocomoMoveAnalyzer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.mobile
クラス MobileEasyLoginDocomoMoveAnalyzer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoMoveAnalyzer
すべての実装インタフェース:
MobileUserAgentProvider

public class MobileEasyLoginDocomoMoveAnalyzer
extends Object
implements MobileUserAgentProvider

モバイル端末固体識別番号取得プロバイダクラス NTT DoCoMo用(move)

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
MobileEasyLoginDocomoMoveAnalyzer()
推奨されていません。
メソッドの概要
boolean | checkMobile(String userAgent, HttpServletRequest request) 推奨されていません。 モバイル端末の種別をチェックします。
String | getUserAgent(String userAgent, HttpServletRequest request) 推奨されていません。 モバイル端末固体識別番号を取得します。
void | init(Node node) 推奨されていません。 モバイル端末固体識別番号取得プロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MobileEasyLoginDocomoMoveAnalyzer

public MobileEasyLoginDocomoMoveAnalyzer()
推奨されていません。
メソッドの詳細

init

public void init(Node node)
推奨されていません。
モバイル端末固体識別番号取得プロバイダの初期化を行います。

定義:
インタフェース MobileUserAgentProvider 内の init
パラメータ:
node - ノード

checkMobile

public boolean checkMobile(String userAgent,
                           HttpServletRequest request)
推奨されていません。
モバイル端末の種別をチェックします。

定義:
インタフェース MobileUserAgentProvider 内の checkMobile
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
対象のモバイル端末の場合は true を返却します。

getUserAgent

public String getUserAgent(String userAgent,
                           HttpServletRequest request)
推奨されていません。
モバイル端末固体識別番号を取得します。 モバイル端末固体識別番号が取得できなかった場合はnullを返却します。

定義:
インタフェース MobileUserAgentProvider 内の getUserAgent
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
固体識別番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MobileEasyLoginJphoneAnalyzer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.mobile
クラス MobileEasyLoginJphoneAnalyzer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginJphoneAnalyzer
すべての実装インタフェース:
MobileUserAgentProvider

public class MobileEasyLoginJphoneAnalyzer
extends Object
implements MobileUserAgentProvider

モバイル端末固体識別番号取得プロバイダクラス J-PHONE用

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
MobileEasyLoginJphoneAnalyzer()
推奨されていません。
メソッドの概要
boolean | checkMobile(String userAgent, HttpServletRequest request) 推奨されていません。 モバイル端末の種別をチェックします。
String | getUserAgent(String userAgent, HttpServletRequest request) 推奨されていません。 モバイル端末固体識別番号を取得します。
void | init(Node node) 推奨されていません。 モバイル端末固体識別番号取得プロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MobileEasyLoginJphoneAnalyzer

public MobileEasyLoginJphoneAnalyzer()
推奨されていません。
メソッドの詳細

init

public void init(Node node)
推奨されていません。
モバイル端末固体識別番号取得プロバイダの初期化を行います。

定義:
インタフェース MobileUserAgentProvider 内の init
パラメータ:
node - ノード

checkMobile

public boolean checkMobile(String userAgent,
                           HttpServletRequest request)
推奨されていません。
モバイル端末の種別をチェックします。

定義:
インタフェース MobileUserAgentProvider 内の checkMobile
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
対象のモバイル端末の場合は true を返却します。

getUserAgent

public String getUserAgent(String userAgent,
                           HttpServletRequest request)
推奨されていません。
モバイル端末固体識別番号を取得します。 モバイル端末固体識別番号が取得できなかった場合はnullを返却します。

定義:
インタフェース MobileUserAgentProvider 内の getUserAgent
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
固体識別番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MobileEasyLoginSoftBankAnalyzer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.mobile
クラス MobileEasyLoginSoftBankAnalyzer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginSoftBankAnalyzer
すべての実装インタフェース:
MobileUserAgentProvider
public class MobileEasyLoginSoftBankAnalyzer
extends Object
implements MobileUserAgentProvider

モバイル端末固体識別番号取得プロバイダクラス SoftBank用(3GC型)

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
MobileEasyLoginSoftBankAnalyzer()
メソッドの概要
boolean | checkMobile(String userAgent, HttpServletRequest request) モバイル端末の種別をチェックします。
String | getUserAgent(String userAgent, HttpServletRequest request) モバイル端末固体識別番号を取得します。
void | init(Node node) モバイル端末固体識別番号取得プロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MobileEasyLoginSoftBankAnalyzer

public MobileEasyLoginSoftBankAnalyzer()
メソッドの詳細

init

public void init(Node node)
モバイル端末固体識別番号取得プロバイダの初期化を行います。

定義:
インタフェース MobileUserAgentProvider 内の init
パラメータ:
node - ノード

checkMobile

public boolean checkMobile(String userAgent,
                           HttpServletRequest request)
モバイル端末の種別をチェックします。

定義:
インタフェース MobileUserAgentProvider 内の checkMobile
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
対象のモバイル端末の場合は true を返却します。

getUserAgent

public String getUserAgent(String userAgent,
                           HttpServletRequest request)
モバイル端末固体識別番号を取得します。 モバイル端末固体識別番号が取得できなかった場合はnullを返却します。

定義:
インタフェース MobileUserAgentProvider 内の getUserAgent
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
固体識別番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MobileEasyLoginVodafoneAnalyzer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.mobile
クラス MobileEasyLoginVodafoneAnalyzer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginVodafoneAnalyzer
すべての実装インタフェース:
MobileUserAgentProvider
public class MobileEasyLoginVodafoneAnalyzer
extends Object
implements MobileUserAgentProvider

モバイル端末固体識別番号取得プロバイダクラス Vodafone用(3GC型)

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
MobileEasyLoginVodafoneAnalyzer()
メソッドの概要
boolean | checkMobile(String userAgent, HttpServletRequest request) モバイル端末の種別をチェックします。
String | getUserAgent(String userAgent, HttpServletRequest request) モバイル端末固体識別番号を取得します。
void | init(Node node) モバイル端末固体識別番号取得プロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MobileEasyLoginVodafoneAnalyzer

public MobileEasyLoginVodafoneAnalyzer()
メソッドの詳細

init

public void init(Node node)
モバイル端末固体識別番号取得プロバイダの初期化を行います。

定義:
インタフェース MobileUserAgentProvider 内の init
パラメータ:
node - ノード

checkMobile

public boolean checkMobile(String userAgent,
                           HttpServletRequest request)
モバイル端末の種別をチェックします。

定義:
インタフェース MobileUserAgentProvider 内の checkMobile
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
対象のモバイル端末の場合は true を返却します。

getUserAgent

public String getUserAgent(String userAgent,
                           HttpServletRequest request)
モバイル端末固体識別番号を取得します。 モバイル端末固体識別番号が取得できなかった場合はnullを返却します。

定義:
インタフェース MobileUserAgentProvider 内の getUserAgent
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
固体識別番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MobileUserAgentProvider (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.mobile
インタフェース MobileUserAgentProvider

既知の実装クラスの一覧:
MobileEasyLoginAuAnalyzer, MobileEasyLoginAuHdmlAnalyzer, MobileEasyLoginDocomoAnalyzer, MobileEasyLoginDocomoMoveAnalyzer, MobileEasyLoginJphoneAnalyzer, MobileEasyLoginSoftBankAnalyzer, MobileEasyLoginVodafoneAnalyzer
public interface MobileUserAgentProvider

モバイル端末固体識別番号取得プロバイダインタフェース。

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
boolean | checkMobile(String userAgent, HttpServletRequest request) モバイル端末の種別をチェックします。
String | getUserAgent(String userAgent, HttpServletRequest request) モバイル端末固体識別番号を取得します。
void | init(Node node) 設定ファイルの情報を基に初期化します。

メソッドの詳細

init

public void init(Node node)
設定ファイルの情報を基に初期化します。

パラメータ:
node - ノード

checkMobile

public boolean checkMobile(String userAgent,
                           HttpServletRequest request)
モバイル端末の種別をチェックします。

パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
対象のモバイル端末の場合は true を返却します。

getUserAgent

public String getUserAgent(String userAgent,
                           HttpServletRequest request)
モバイル端末固体識別番号を取得します。

モバイル端末固体識別番号が取得できなかった場合はnullを返却します。

パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
固体識別番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.mobile (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.security.mobile
インタフェース
MobileUserAgentProvider
クラス
MobileEasyLoginAuAnalyzer
MobileEasyLoginAuHdmlAnalyzer
MobileEasyLoginDocomoAnalyzer
MobileEasyLoginDocomoMoveAnalyzer
MobileEasyLoginJphoneAnalyzer
MobileEasyLoginSoftBankAnalyzer
MobileEasyLoginUtil
MobileEasyLoginVodafoneAnalyzer
NonceResetListener4MobileEasyLogin


jp.co.intra_mart.foundation.security.mobile (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.mobile

インタフェースの概要
MobileUserAgentProvider モバイル端末固体識別番号取得プロバイダインタフェース。

クラスの概要
MobileEasyLoginAuAnalyzer | モバイル端末固体識別番号取得プロバイダクラス Au用(WAP2.0)
MobileEasyLoginAuHdmlAnalyzer | 推奨されていません。
MobileEasyLoginDocomoAnalyzer | モバイル端末固体識別番号取得プロバイダクラス NTT DoCoMo用(FOMA)
MobileEasyLoginDocomoMoveAnalyzer | 推奨されていません。
MobileEasyLoginJphoneAnalyzer | 推奨されていません。
MobileEasyLoginSoftBankAnalyzer | モバイル端末固体識別番号取得プロバイダクラス SoftBank用(3GC型)
MobileEasyLoginUtil | かんたんログイン機能のユーティリティクラスです。
MobileEasyLoginVodafoneAnalyzer | モバイル端末固体識別番号取得プロバイダクラス Vodafone用(3GC型)
NonceResetListener4MobileEasyLogin | かんたんログイン用のNonceを再設定する為のリスナーです。


jp.co.intra_mart.foundation.security.mobile クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.mobile の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuHdmlAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoMoveAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginJphoneAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginSoftBankAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginVodafoneAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin (implements jp.co.intra_mart.foundation.security.account.AccountPostWriterListener, jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider


パッケージ jp.co.intra_mart.foundation.security.mobile の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.mobile の使用

jp.co.intra_mart.foundation.security.mobile を使用しているパッケージ
jp.co.intra_mart.foundation.security.mobile

jp.co.intra_mart.foundation.security.mobile により使用される jp.co.intra_mart.foundation.security.mobile のクラス
MobileUserAgentProvider
モバイル端末固体識別番号取得プロバイダインタフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.password.PasswordHistory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.password.PasswordHistory の使用

PasswordHistory を使用しているパッケージ
jp.co.intra_mart.foundation.security.password

jp.co.intra_mart.foundation.security.password での PasswordHistory の使用

PasswordHistory を返す jp.co.intra_mart.foundation.security.password のメソッド
PasswordHistory[] | StandardPasswordHistoryAccessor.getPasswordHistories(String groupId, String userId) パスワード履歴を取得。
PasswordHistory | StandardPasswordHistoryAccessor.getLatestPasswordHistory(String groupId, String userId) 最新のパスワードと更新日付を取得。
PasswordHistory | PasswordHistoryManager.getLatestPasswordHistory(String userId) 最新のパスワードと更新日付を取得。
PasswordHistory[] | PasswordHistoryManager.getPasswordHistories(String userId) パスワード履歴を取得。
PasswordHistory[] | PasswordHistoryAccessor.getPasswordHistories(String groupId, String userId) パスワード履歴を取得。
PasswordHistory | PasswordHistoryAccessor.getLatestPasswordHistory(String groupId, String userId) 最新のパスワードと更新日付を取得。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor の使用

PasswordHistoryAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.security.password

jp.co.intra_mart.foundation.security.password での PasswordHistoryAccessor の使用

PasswordHistoryAccessor を実装している jp.co.intra_mart.foundation.security.password のクラス
 class StandardPasswordHistoryAccessor
パスワード履歴管理アクセッサクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener の使用

jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.password.PasswordHistoryException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.password.PasswordHistoryException の使用

PasswordHistoryException を使用しているパッケージ
jp.co.intra_mart.foundation.security.password

jp.co.intra_mart.foundation.security.password での PasswordHistoryException の使用

PasswordHistoryException をスローする jp.co.intra_mart.foundation.security.password のメソッド
void | StandardPasswordHistoryAccessor.addPasswordHistory(String groupId, String userId, String password) パスワード履歴の追加。
PasswordHistoryResult | StandardPasswordHistoryAccessor.checkPasswordHistory(String groupId, String userId, String password) 入力パスワードのチェック。
void | StandardPasswordHistoryAccessor.clearPasswordHistories(String groupId) パスワード履歴の消去。
void | StandardPasswordHistoryAccessor.clearPasswordHistory(String groupId, String userId) 指定ユーザのパスワード履歴の消去。
PasswordHistory[] | StandardPasswordHistoryAccessor.getPasswordHistories(String groupId, String userId) パスワード履歴を取得。
int | StandardPasswordHistoryAccessor.getPasswordHistoryCount(String groupId, String userId) パスワード履歴数を取得。
void | StandardPasswordHistoryAccessor.verifyPasswordHistory(String groupId, String userId, int remain) ユーザのパスワードを消去。
PasswordHistory | StandardPasswordHistoryAccessor.getLatestPasswordHistory(String groupId, String userId) 最新のパスワードと更新日付を取得。
void | PasswordHistoryManager.addPasswordHistory(String userId, String password) パスワード履歴の追加。
PasswordHistoryResult | PasswordHistoryManager.checkPasswordHistory(String userId, String password) パスワードの入力チェック。
void | PasswordHistoryManager.clearPasswordHistories() パスワード履歴の消去。
void | PasswordHistoryManager.clearPasswordHistory(String userId) 指定ユーザのパスワード履歴の消去。
PasswordHistory | PasswordHistoryManager.getLatestPasswordHistory(String userId) 最新のパスワードと更新日付を取得。
PasswordHistory[] | PasswordHistoryManager.getPasswordHistories(String userId) パスワード履歴を取得。
int | PasswordHistoryManager.getPasswordHistoryCount(String userId) パスワード履歴数を取得。
void | PasswordHistoryManager.verifyPasswordHistory(String userId, int remain) ユーザのパスワード履歴を消去。
void | PasswordHistoryAccessor.addPasswordHistory(String groupId, String userId, String password) パスワード履歴の追加。
PasswordHistoryResult | PasswordHistoryAccessor.checkPasswordHistory(String groupId, String userId, String password) パスワードの入力チェック。
void | PasswordHistoryAccessor.clearPasswordHistories(String groupId) パスワード履歴の消去。
void | PasswordHistoryAccessor.clearPasswordHistory(String groupId, String userId) 指定ユーザのパスワード履歴の消去。
PasswordHistory[] | PasswordHistoryAccessor.getPasswordHistories(String groupId, String userId) パスワード履歴を取得。
PasswordHistory | PasswordHistoryAccessor.getLatestPasswordHistory(String groupId, String userId) 最新のパスワードと更新日付を取得。
int | PasswordHistoryAccessor.getPasswordHistoryCount(String groupId, String userId) パスワード履歴数を取得。
void | PasswordHistoryAccessor.verifyPasswordHistory(String groupId, String userId, int remain) ユーザのパスワードを消去。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.password.PasswordHistoryManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.password.PasswordHistoryManager の使用

jp.co.intra_mart.foundation.security.password.PasswordHistoryManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.password.PasswordHistoryManagerInitializerImpl の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.password.PasswordHistoryManagerInitializerImpl の使用

jp.co.intra_mart.foundation.security.password.PasswordHistoryManagerInitializerImpl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.password.PasswordHistoryNewArrivedProvider の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.password.PasswordHistoryNewArrivedProvider の使用

jp.co.intra_mart.foundation.security.password.PasswordHistoryNewArrivedProvider はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.password.PasswordHistoryResult の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.password.PasswordHistoryResult の使用

PasswordHistoryResult を使用しているパッケージ
jp.co.intra_mart.foundation.security.password

jp.co.intra_mart.foundation.security.password での PasswordHistoryResult の使用

PasswordHistoryResult を返す jp.co.intra_mart.foundation.security.password のメソッド
PasswordHistoryResult | StandardPasswordHistoryAccessor.checkPasswordHistory(String groupId, String userId, String password) 入力パスワードのチェック。
PasswordHistoryResult | PasswordHistoryManager.checkPasswordHistory(String userId, String password) パスワードの入力チェック。
PasswordHistoryResult | PasswordHistoryAccessor.checkPasswordHistory(String groupId, String userId, String password) パスワードの入力チェック。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.password.PasswordHistoryUserPageProvider の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.password.PasswordHistoryUserPageProvider の使用

jp.co.intra_mart.foundation.security.password.PasswordHistoryUserPageProvider はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor の使用

jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.security.password (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.security.password
インタフェース
PasswordHistoryAccessor
クラス
PasswordHistory
PasswordHistoryAccountChangedListener
PasswordHistoryManager
PasswordHistoryManagerInitializerImpl
PasswordHistoryNewArrivedProvider
PasswordHistoryResult
PasswordHistoryUserPageProvider
StandardPasswordHistoryAccessor
例外
PasswordHistoryException


jp.co.intra_mart.foundation.security.password (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.password

インタフェースの概要
PasswordHistoryAccessor パスワード履歴管理アクセッサインターフェース。

クラスの概要
PasswordHistory | パスワード履歴管理情報クラス
PasswordHistoryAccountChangedListener | アカウント情報変更リスナー(パスワード履歴管理)。
PasswordHistoryManager | パスワード履歴管理マネージャクラス ServerManager/conf/password-history.xmlからパスワード履歴管理に関するパラメータを取得します。
PasswordHistoryManagerInitializerImpl | パスワード履歴管理マネージャの初期化クラス。
PasswordHistoryNewArrivedProvider | パスワード履歴管理汎用新着情報のプロバイダ。
PasswordHistoryResult | パスワード履歴管理リザルトクラス。
PasswordHistoryUserPageProvider | パスワード履歴管理スタンダードユーザページプロバイダクラス。
StandardPasswordHistoryAccessor | パスワード履歴管理アクセッサクラス。

例外の概要
PasswordHistoryException イメージアイコンの例外クラス。


jp.co.intra_mart.foundation.security.password クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.password の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.password.PasswordHistory
    • class jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener (implements jp.co.intra_mart.foundation.security.account.AccountChangedListener)
    • class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager
    • class jp.co.intra_mart.foundation.security.password.PasswordHistoryManagerInitializerImpl (implements jp.co.intra_mart.system.service.ApplicationInitializer)
    • class jp.co.intra_mart.foundation.security.password.PasswordHistoryNewArrivedProvider (implements jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider)
    • class jp.co.intra_mart.foundation.security.password.PasswordHistoryResult
    • class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor (implements jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor)
    • class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider (implements jp.co.intra_mart.foundation.security.certification.UserPageProvider)
      • class jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider
        • class jp.co.intra_mart.foundation.security.password.PasswordHistoryUserPageProvider
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.exception.FoundationException
          • class jp.co.intra_mart.foundation.security.password.PasswordHistoryException

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor


パッケージ jp.co.intra_mart.foundation.security.password の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.password の使用

jp.co.intra_mart.foundation.security.password を使用しているパッケージ
jp.co.intra_mart.foundation.security.password

jp.co.intra_mart.foundation.security.password により使用される jp.co.intra_mart.foundation.security.password のクラス
PasswordHistory
パスワード履歴管理情報クラス
PasswordHistoryAccessor
パスワード履歴管理アクセッサインターフェース。
PasswordHistoryException
イメージアイコンの例外クラス。
PasswordHistoryResult
パスワード履歴管理リザルトクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PasswordHistory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.password
クラス PasswordHistory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.password.PasswordHistory
public class PasswordHistory
extends Object

パスワード履歴管理情報クラス

コンストラクタの概要
PasswordHistory()
メソッドの概要
Date | getDate() 日付を取得します。
String | getPassword() パスワードを取得します。
void | setDate(Date date) 日付を設定します。
void | setPassword(String password) パスワードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PasswordHistory

public PasswordHistory()
メソッドの詳細

getPassword

public String getPassword()
パスワードを取得します。

戻り値:
password を戻します。

setPassword

public void setPassword(String password)
パスワードを設定します。

パラメータ:
password - password を設定。

getDate

public Date getDate()
日付を取得します。

戻り値:
date を戻します。

setDate

public void setDate(Date date)
日付を設定します。

パラメータ:
date - date を設定。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PasswordHistoryAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.password
インタフェース PasswordHistoryAccessor

既知の実装クラスの一覧:
StandardPasswordHistoryAccessor
public interface PasswordHistoryAccessor

パスワード履歴管理アクセッサインターフェース。

パスワード履歴管理情報の読み込みおよび書き込みのインタフェースを定義します。

メソッドの概要
void | addPasswordHistory(String groupId, String userId, String password) パスワード履歴の追加。
PasswordHistoryResult | checkPasswordHistory(String groupId, String userId, String password) パスワードの入力チェック。
void | clearPasswordHistories(String groupId) パスワード履歴の消去。
void | clearPasswordHistory(String groupId, String userId) 指定ユーザのパスワード履歴の消去。
String | createPassword(int count) パスワードをランダムに生成。
PasswordHistory | getLatestPasswordHistory(String groupId, String userId) 最新のパスワードと更新日付を取得。
int | getPasswordExpireLimit(String groupId) パスワード履歴数を取得。
PasswordHistory[] | getPasswordHistories(String groupId, String userId) パスワード履歴を取得。
int | getPasswordHistoryCount(String groupId, String userId) パスワード履歴数を取得。
int | getPasswordHistoryManagedCount(String groupId) 世代管理数を取得。
String | getPasswordPage(String groupId) パスワード変更画面のＵＲＬを取得。
void | init(Node defaultNode, Node groupNode) パラメータを取得。
boolean | isChangePasswordFirstLogin(String groupId) 初回ログイン時にパスワード変更要求を行うかの判定。
boolean | isDenyClientType(String clientType) クライアントタイプの判定 パラメータdeny-client-typesに記述があるクライアントタイプの判定を行う。
boolean | isFirstLogin(String groupId, String userId) 初回ログインの判定
boolean | isForwardInitialPage(String groupId) パスワード変更後の画面遷移。
boolean | isPasswordExpired(String groupId, String userId, String clientType, Date date) パスワード変更要求の判定。
boolean | isPasswordHistoryManaged(String groupId) 履歴管理の有無。
void | verifyPasswordHistory(String groupId, String userId, int remain) ユーザのパスワードを消去。

メソッドの詳細

addPasswordHistory

public void addPasswordHistory(String groupId,
                               String userId,
                               String password)
                        throws PasswordHistoryException
パスワード履歴の追加。

指定ユーザの入力パスワードをデータベースに追加します。

パラメータ:
groupId - グループID
userId - ユーザID
password - 入力パスワード
例外:
PasswordHistoryException - パスワード履歴の追加に失敗した場合にスローされます。

checkPasswordHistory

public PasswordHistoryResult checkPasswordHistory(String groupId,
                                                  String userId,
                                                  String password)
                                           throws PasswordHistoryException
パスワードの入力チェック。

パスワードの入力チェックを行います。

パラメータ:
groupId - グループID
userId - ユーザID
password - 入力パスワード
戻り値:
true　/　false,メッセージ,詳細メッセージ
例外:
PasswordHistoryException - パスワードの入力チェックに失敗した場合にスローされます。

clearPasswordHistories

public void clearPasswordHistories(String groupId)
                            throws PasswordHistoryException
パスワード履歴の消去。

引数のログイングループのパスワード履歴をすべて消去します。

パラメータ:
groupId - グループID
例外:
PasswordHistoryException - パスワード履歴の消去に失敗した場合にスローされます。

clearPasswordHistory

public void clearPasswordHistory(String groupId,
                                 String userId)
                          throws PasswordHistoryException
指定ユーザのパスワード履歴の消去。

引数のユーザのパスワード履歴を消去します。

パラメータ:
groupId - グループID
userId - ユーザID
例外:
PasswordHistoryException - 指定ユーザのパスワード履歴の消去に失敗した場合にスローされます。

getPasswordHistories

public PasswordHistory[] getPasswordHistories(String groupId,
                                              String userId)
                                       throws PasswordHistoryException
パスワード履歴を取得。

指定ユーザのパスワード履歴を取得します。

パラメータ:
groupId - グループID
userId - ユーザID
戻り値:
指定ユーザのパスワード履歴一覧
例外:
PasswordHistoryException - パスワード履歴の取得に失敗した場合にスローされます。

getLatestPasswordHistory

public PasswordHistory getLatestPasswordHistory(String groupId,
                                                String userId)
                                         throws PasswordHistoryException
最新のパスワードと更新日付を取得。

指定ユーザの最新パスワードと更新日付を取得します。

パラメータ:
groupId - グループID
userId - ユーザID
戻り値:
パスワード、更新日付
例外:
PasswordHistoryException - 最新のパスワード情報の取得に失敗した場合にスローされます。

getPasswordHistoryCount

public int getPasswordHistoryCount(String groupId,
                                   String userId)
                            throws PasswordHistoryException
パスワード履歴数を取得。

指定ユーザのパスワード履歴数を取得します。

パラメータ:
groupId - グループID
userId - ユーザID
戻り値:
パスワード履歴数
例外:
PasswordHistoryException - パスワード履歴数の取得に失敗した場合にスローされます。

getPasswordHistoryManagedCount

public int getPasswordHistoryManagedCount(String groupId)
世代管理数を取得。

パスワードの世代管理数を取得します。

パラメータ:
groupId - グループID
戻り値:
パスワード世代管理数

getPasswordPage

public String getPasswordPage(String groupId)
パスワード変更画面のＵＲＬを取得。

パスワード変更画面のＵＲＬを取得します。

パラメータ:
groupId - グループID
戻り値:
パスワード変更画面のＵＲＬ

init

public void init(Node defaultNode,
                 Node groupNode)
パラメータを取得。

設定したパスワード履歴管理に関するパラメータを取得します。

パラメータ:
defaultNode - デフォルトパラメータ
groupNode - グループパラメータ

isForwardInitialPage

public boolean isForwardInitialPage(String groupId)
パスワード変更後の画面遷移。

パスワードの有効期限切れによるパスワード再設定後、ログイン画面に戻るか、ログイン処理を継続してログインするかを判定します。

パラメータ:
groupId - グループID
戻り値:
true / false

isPasswordExpired

public boolean isPasswordExpired(String groupId,
                                 String userId,
                                 String clientType,
                                 Date date)
パスワード変更要求の判定。

パスワード変更要求を行うか判定します。

パラメータ:
groupId - グループID
userId - ユーザID
clientType - クライアントタイプ
date - パスワードのチェックの基準となる日付。省略された場合、現在日付が利用されます。
戻り値:
true / false

isPasswordHistoryManaged

public boolean isPasswordHistoryManaged(String groupId)
履歴管理の有無。

履歴管理を行うかどうか判定します。

パラメータ:
groupId - グループID
戻り値:
ture / false

verifyPasswordHistory

public void verifyPasswordHistory(String groupId,
                                  String userId,
                                  int remain)
                           throws PasswordHistoryException
ユーザのパスワードを消去。

引数 remain の値分残してユーザの履歴を消去します。
引数 remain が0以下の場合、履歴をすべて消去します。

パラメータ:
groupId - グループID
userId - ユーザID
remain - 残す履歴の数
例外:
PasswordHistoryException - パスワードの消去に失敗した場合にスローされます。

createPassword

public String createPassword(int count)
パスワードをランダムに生成。

引数の値の長さのパスワードをランダムに生成します。
呼出し毎に異なるパスワードを生成します。

パラメータ:
count - パスワードの長さ
戻り値:
生成されたパスワード

isChangePasswordFirstLogin

public boolean isChangePasswordFirstLogin(String groupId)
初回ログイン時にパスワード変更要求を行うかの判定。

パラメータ:
groupId - グループID
戻り値:
true：パスワード変更要求を行う / false：パスワード変更要求を行わない

isFirstLogin

public boolean isFirstLogin(String groupId,
                            String userId)
初回ログインの判定

パラメータ:
groupId - グループID
userId - ユーザID
戻り値:
true：初回ログイン / false　初回ログインではない

isDenyClientType

public boolean isDenyClientType(String clientType)
クライアントタイプの判定

パラメータdeny-client-typesに記述があるクライアントタイプの判定を行う。

パラメータ:
clientType - クライアントタイプ
戻り値:
true：クライアントタイプが含まれている false：クライアントタイプが含まれていない

getPasswordExpireLimit

public int getPasswordExpireLimit(String groupId)
パスワード履歴数を取得。

指定ユーザのパスワード履歴数を取得します。

パラメータ:
groupId - グループID
戻り値:
パスワード履歴数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PasswordHistoryAccountChangedListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.password
クラス PasswordHistoryAccountChangedListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener
すべての実装インタフェース:
AccountChangedListener
public class PasswordHistoryAccountChangedListener
extends Object
implements AccountChangedListener

アカウント情報変更リスナー(パスワード履歴管理)。

アカウント情報が変更された時に
パスワード履歴管理情報との整合性を保つクラスです。

導入されたバージョン:
6.1.3
バージョン:
1.0

コンストラクタの概要
PasswordHistoryAccountChangedListener()
メソッドの概要
void | accountAdded(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | accountDeleted(String groupId, String userId) アカウント情報をデータストアから削除した直後にコールされます。
void | accountRoleAdded(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | accountRoleDeleted(String groupId, String userId, String roleId) アカウントロール情報をデータストアから削除した直後にコールされます。
void | accountRoleUpdated(String grouId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新した直後にコールされます。
void | accountUpdated(String groupId, Account account) アカウント情報をデータストアに更新した直後にコールされます。
void | init(Map params) アカウントリスナーの初期化。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PasswordHistoryAccountChangedListener

public PasswordHistoryAccountChangedListener()
メソッドの詳細

init

public void init(Map params)
アカウントリスナーの初期化。

定義:
インタフェース AccountChangedListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

accountAdded

public void accountAdded(String groupId,
                         Account account)
                  throws ChangedListenerException
アカウント情報をデータストアに作成した直後にコールされます。 作成されたアカウント情報に対するプロファイルが存在する場合に、 アカウントフラグを設定します。

定義:
インタフェース AccountChangedListener 内の accountAdded
パラメータ:
groupId - ログイングループID
account - 作成されたアカウント情報
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

accountDeleted

public void accountDeleted(String groupId,
                           String userId)
                    throws ChangedListenerException
アカウント情報をデータストアから削除した直後にコールされます。

削除されたアカウント情報に対するパスワード履歴管理情報が存在した場合に、
パスワード履歴管理情報を削除します。

定義:
インタフェース AccountChangedListener 内の accountDeleted
パラメータ:
groupId - ログイングループID
userId - 削除されたユーザID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

accountUpdated

public void accountUpdated(String groupId,
                           Account account)
アカウント情報をデータストアに更新した直後にコールされます。 このリスナーでは、このイベントに対して処理は何も行いません。

定義:
インタフェース AccountChangedListener 内の accountUpdated
パラメータ:
groupId - ログイングループID
account - 更新されたアカウント情報

accountRoleAdded

public void accountRoleAdded(String groupId,
                             String userId,
                             AccountRole accountRole)
アカウントロール情報をデータストアに作成した直後にコールされます。 このリスナーでは、このイベントに対して処理は何も行いません。

定義:
インタフェース AccountChangedListener 内の accountRoleAdded
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 作成されたアカウントロール情報

accountRoleDeleted

public void accountRoleDeleted(String groupId,
                               String userId,
                               String roleId)
アカウントロール情報をデータストアから削除した直後にコールされます。 このリスナーでは、このイベントに対して処理は何も行いません。

定義:
インタフェース AccountChangedListener 内の accountRoleDeleted
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
roleId - 削除されたロールID

accountRoleUpdated

public void accountRoleUpdated(String grouId,
                               String userId,
                               AccountRole accountRole)
アカウントロール情報をデータストアに更新した直後にコールされます。 このリスナーでは、このイベントに対して処理は何も行いません。

定義:
インタフェース AccountChangedListener 内の accountRoleUpdated
パラメータ:
userId - 対象ユーザID
accountRole - 更新されたアカウントロール情報
grouId - ログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PasswordHistoryException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.password
クラス PasswordHistoryException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.password.PasswordHistoryException
すべての実装インタフェース:
Serializable
public class PasswordHistoryException
extends FoundationException

イメージアイコンの例外クラス。

イメージアイコン内で例外が発生した場合にスローされます。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
PasswordHistoryException()
コンストラクタ。
PasswordHistoryException(String message)
コンストラクタ。
PasswordHistoryException(String message, Throwable cause)
コンストラクタ。
PasswordHistoryException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PasswordHistoryException

public PasswordHistoryException()
コンストラクタ。

PasswordHistoryException

public PasswordHistoryException(String message)
コンストラクタ。

パラメータ:
message - メッセージ

PasswordHistoryException

public PasswordHistoryException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

PasswordHistoryException

public PasswordHistoryException(String message,
                                Throwable cause)
コンストラクタ。

パラメータ:
message - メッセージ
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PasswordHistoryManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.password
クラス PasswordHistoryManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.password.PasswordHistoryManager
public class PasswordHistoryManager
extends Object

パスワード履歴管理マネージャクラス

ServerManager/conf/password-history.xmlからパスワード履歴管理に関するパラメータを取得します。

以下はpassword-history.xmlのタグの説明です。

<password-history>
  <group-default accessor-class="jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor">
     <change-password-first-login>false</change-password-first-login>
      <password-expire-limit>0</password-expire-limit>
                        ・
                デフォルトパラメータ群
                        ・
  </group-default>

  <group name="default" accessor-class="jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor">
    <change-password-first-login>true</change-password-first-login>
    <password-expire-limit>0</password-expire-limit>
                        ・
                ログイングループパラメータ群
                        ・
  </group>
</password-history>

その他のタグに関してはこちらを参照してください。StandardPasswordHistoryAccessor

タグ名 | 説明 | デフォルト値
accessor-class | パスワード履歴管理のデフォルトパラメータ | jp.co.intra_mart.foundation. security.password. StandardPasswardAccessor
group | ログイングループのグループ名を属性として所持します。 複数記述することが可能です。 | なし

コンストラクタの概要
PasswordHistoryManager(String groupId)
メソッドの概要
void | addPasswordHistory(String userId, String password) パスワード履歴の追加。
PasswordHistoryResult | checkPasswordHistory(String userId, String password) パスワードの入力チェック。
static void | clearInstance()
void | clearPasswordHistories() パスワード履歴の消去。
void | clearPasswordHistory(String userId) 指定ユーザのパスワード履歴の消去。
String | createPassword(int count)
String | getGroupId()
PasswordHistory | getLatestPasswordHistory(String userId) 最新のパスワードと更新日付を取得。
int | getPasswordExpireLimit() 設定したパスワードの有効期限を取得。
PasswordHistory[] | getPasswordHistories(String userId) パスワード履歴を取得。
int | getPasswordHistoryCount(String userId) パスワード履歴数を取得。
int | getPasswordHistoryManagedCount() 世代管理数を取得。
String | getPasswordPage() パスワード変更画面のＵＲＬを取得。
boolean | isChangePasswordFirstLogin() 初回ログイン時のパスワード変更要求を行うかの判定。
boolean | isDenyClientType(String clientType) クライアントタイプの判定 パラメータmobile-client-typesに記述があるクライアントタイプの判定を行う。
boolean | isFirstLogin(String userId) 初回ログインの判定 初回ログインかどうかを判定します。
boolean | isForwardInitialPage() パスワード変更後の画面遷移。
boolean | isPasswordExpired(String userId, String clientType, Date date) パスワード有効期限切れかどうかの判定。
boolean | isPasswordHistoryManaged() 履歴管理の有無。
void | verifyPasswordHistory(String userId, int remain) ユーザのパスワード履歴を消去。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PasswordHistoryManager

public PasswordHistoryManager(String groupId)
メソッドの詳細

clearInstance

public static void clearInstance()

addPasswordHistory

public void addPasswordHistory(String userId,
                               String password)
                        throws PasswordHistoryException
パスワード履歴の追加。

指定ユーザの入力パスワードをデータベースに追加します。

パラメータ:
userId -
password -
例外:
PasswordHistoryException - パスワード履歴の追加に失敗した場合にスローされます。

checkPasswordHistory

public PasswordHistoryResult checkPasswordHistory(String userId,
                                                  String password)
                                           throws PasswordHistoryException
パスワードの入力チェック。

パスワードの入力チェックを行います。

パラメータ:
userId -
password -
戻り値:
true　/　false,メッセージ,詳細メッセージ
例外:
PasswordHistoryException - パスワードの入力チェックに失敗した場合にスローされます。

getPasswordPage

public String getPasswordPage()
パスワード変更画面のＵＲＬを取得。

パスワード変更画面のＵＲＬを取得します。

戻り値:
パスワード変更画面のＵＲＬ

isPasswordExpired

public boolean isPasswordExpired(String userId,
                                 String clientType,
                                 Date date)
パスワード有効期限切れかどうかの判定。

パスワード有効期限切れを判定します。

パラメータ:
userId -
clientType -
date - パスワードのチェックの基準となる日付。省略された場合、現在日付が利用されます。
戻り値:
true : パスワードが有効期限切れの場合 / false : パスワードが有効期限内の場合

isPasswordHistoryManaged

public boolean isPasswordHistoryManaged()
履歴管理の有無。

履歴管理を行うかどうか判定します。

戻り値:
ture / false

clearPasswordHistories

public void clearPasswordHistories()
                            throws PasswordHistoryException
パスワード履歴の消去。

パスワード履歴をすべて消去します。

例外:
PasswordHistoryException - パスワード履歴の消去に失敗した場合にスローされます。

clearPasswordHistory

public void clearPasswordHistory(String userId)
                          throws PasswordHistoryException
指定ユーザのパスワード履歴の消去。

引数のユーザのパスワード履歴を消去します。

パラメータ:
userId -
例外:
PasswordHistoryException - 指定ユーザのパスワードの消去に失敗した場合にスローされます。

getLatestPasswordHistory

public PasswordHistory getLatestPasswordHistory(String userId)
                                         throws PasswordHistoryException
最新のパスワードと更新日付を取得。

指定ユーザの最新パスワードと更新日付を取得します。

パラメータ:
userId -
戻り値:
最新パスワード、更新日付
例外:
PasswordHistoryException - 最新のパスワード情報の取得に失敗した場合にスローされます。

getPasswordHistories

public PasswordHistory[] getPasswordHistories(String userId)
                                       throws PasswordHistoryException
パスワード履歴を取得。

指定ユーザのパスワード履歴を取得します。

パラメータ:
userId -
戻り値:
指定ユーザのパスワード履歴一覧
例外:
PasswordHistoryException - パスワード履歴の取得に失敗した場合にスローされます。

getPasswordHistoryCount

public int getPasswordHistoryCount(String userId)
                            throws PasswordHistoryException
パスワード履歴数を取得。

指定ユーザのパスワード履歴数を取得します。

パラメータ:
userId -
戻り値:
パスワード履歴数
例外:
PasswordHistoryException - パスワード履歴数の取得に失敗した場合にスローされます。

getPasswordHistoryManagedCount

public int getPasswordHistoryManagedCount()
世代管理数を取得。

パスワードの世代管理数を取得します。

戻り値:
パスワード世代管理数

isForwardInitialPage

public boolean isForwardInitialPage()
パスワード変更後の画面遷移。

パスワードの有効期限切れによるパスワード再設定後、ログイン画面に戻るか、ログイン処理を継続してログインするかを判定します。

戻り値:
true/false

verifyPasswordHistory

public void verifyPasswordHistory(String userId,
                                  int remain)
                           throws PasswordHistoryException
ユーザのパスワード履歴を消去。

引数の値分残してユーザの履歴を消去します。

パラメータ:
userId -
remain -
例外:
PasswordHistoryException - 指定ユーザのパスワード履歴の消去に失敗した場合にスローされます。

getGroupId

public String getGroupId()
戻り値:
groupId を戻します。

createPassword

public String createPassword(int count)
戻り値:
passwordを戻します。

isChangePasswordFirstLogin

public boolean isChangePasswordFirstLogin()
初回ログイン時のパスワード変更要求を行うかの判定。

初回ログイン時にパスワード変更要求を行うかを判定します。

戻り値:
true：パスワード変更要求を行う / false：パスワード変更要求を行わない

isFirstLogin

public boolean isFirstLogin(String userId)
初回ログインの判定

初回ログインかどうかを判定します。

パラメータ:
userId - ユーザID
戻り値:
true:初回ログイン / false:初回ログインではない

isDenyClientType

public boolean isDenyClientType(String clientType)
クライアントタイプの判定

パラメータmobile-client-typesに記述があるクライアントタイプの判定を行う。

パラメータ:
clientType - クライアントタイプ
戻り値:
true：クライアントタイプが含まれている false：クライアントタイプが含まれていない

getPasswordExpireLimit

public int getPasswordExpireLimit()
設定したパスワードの有効期限を取得。

パラメータで設定したパスワードの有効期限日数を取得します。

戻り値:
パスワードの有効期限日数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PasswordHistoryManagerInitializerImpl (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.password
クラス PasswordHistoryManagerInitializerImpl

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.password.PasswordHistoryManagerInitializerImpl
すべての実装インタフェース:
jp.co.intra_mart.system.service.ApplicationInitializer
public class PasswordHistoryManagerInitializerImpl
extends Object
implements jp.co.intra_mart.system.service.ApplicationInitializer

パスワード履歴管理マネージャの初期化クラス。
パスワード履歴管理マネージャの初期化を行います。
アプリケーションライタイム起動時に呼ばれます。

導入されたバージョン:
6.0.2
バージョン:
1.0

コンストラクタの概要
PasswordHistoryManagerInitializerImpl()
メソッドの概要
 void initialize()
初期化処理を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PasswordHistoryManagerInitializerImpl

public PasswordHistoryManagerInitializerImpl()
メソッドの詳細

initialize

public void initialize()
初期化処理を行います。

定義:
インタフェース jp.co.intra_mart.system.service.ApplicationInitializer 内の initialize
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PasswordHistoryNewArrivedProvider (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.password
クラス PasswordHistoryNewArrivedProvider

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.password.PasswordHistoryNewArrivedProvider
すべての実装インタフェース:
NewArrivedProvider
public class PasswordHistoryNewArrivedProvider
extends Object
implements NewArrivedProvider

パスワード履歴管理汎用新着情報のプロバイダ。

パスワード履歴管理を行っている場合でかつ、設定された日数以内にパスワードの有効期限が入った場合、汎用新着ポートレットに情報を供給します。

「初期化パラメータ一覧」

パラメータ | 説明 | デフォルト値
report-limit-days | 有効期限の何日前に報告するかの日数を設定します。 | 5 (5日前から通知)
link-page | リンク先のページです。 スクリプト開発モデルプログラムのURLの場合は拡張子(.jssp)を付加します。 | パスワード変更画面 /system/setting/user/password/main.jssp

導入されたバージョン:
6.0
バージョン:
1.0

コンストラクタの概要
PasswordHistoryNewArrivedProvider()
メソッドの概要
NewArrived[] | getNewArrivedList(String user, String group) パスワード履歴管理の新着情報を一覧を取得します。
void | init(Properties properties) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PasswordHistoryNewArrivedProvider

public PasswordHistoryNewArrivedProvider()
メソッドの詳細

init

public void init(Properties properties)
初期化を行います。

定義:
インタフェース NewArrivedProvider 内の init
パラメータ:
properties - 初期化パラメータ

getNewArrivedList

public NewArrived[] getNewArrivedList(String user,
                                      String group)
パスワード履歴管理の新着情報を一覧を取得します。

新着情報が存在しない場合は、空の配列を返します。
初期化パラメータで設定された日数以内にパスワードの有効期限が入った場合、汎用新着ポートレットに情報を供給します。

定義:
インタフェース NewArrivedProvider 内の getNewArrivedList
パラメータ:
user - ログインユーザコード
group - ログイングループID
戻り値:
新着情報の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PasswordHistoryResult (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.password
クラス PasswordHistoryResult

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.password.PasswordHistoryResult
public class PasswordHistoryResult
extends Object

パスワード履歴管理リザルトクラス。

パスワード入力チェック結果を取得します。

コンストラクタの概要
PasswordHistoryResult()
PasswordHistoryResult(String message, String detail)
メソッドの概要
String | getDetail() 詳細メッセージを取得します。
String | getMessage() メッセージを取得します。
boolean | isSuccess() パスワードチェックの成否を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PasswordHistoryResult

public PasswordHistoryResult()

PasswordHistoryResult

public PasswordHistoryResult(String message,
                             String detail)
パラメータ:
message - メッセージ
detail - 詳細メッセージ
メソッドの詳細

getDetail

public String getDetail()
詳細メッセージを取得します。

戻り値:
detail を戻します。

getMessage

public String getMessage()
メッセージを取得します。

戻り値:
message を戻します。

isSuccess

public boolean isSuccess()
パスワードチェックの成否を取得します。

戻り値:
success を戻します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PasswordHistoryUserPageProvider (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.password
クラス PasswordHistoryUserPageProvider

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider
        拡張 jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider
            拡張 jp.co.intra_mart.foundation.security.password.PasswordHistoryUserPageProvider
すべての実装インタフェース:
UserPageProvider
public class PasswordHistoryUserPageProvider
extends PortalStandardUserPageProvider

パスワード履歴管理スタンダードユーザページプロバイダクラス。

コンストラクタの概要
PasswordHistoryUserPageProvider()
メソッドの概要
protected String | getExtendedMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 拡張メインページURLを取得します。
void | init(Map params) ページプロバイダの初期化を行います。
クラス jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider から継承したメソッド
getInitalPage
クラス jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider から継承したメソッド
getMainPage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PasswordHistoryUserPageProvider

public PasswordHistoryUserPageProvider()
メソッドの詳細

getExtendedMainPage

protected String getExtendedMainPage(SessionInfo sessionInfo,
                                     HttpServletRequest request,
                                     HttpServletResponse response)
クラス PortalStandardUserPageProvider の記述:
拡張メインページURLを取得します。

ログイン後の拡張メイン画面を表示するURLを取得する。

オーバーライド:
クラス PortalStandardUserPageProvider 内の getExtendedMainPage
パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL

init

public void init(Map params)
クラス PortalStandardUserPageProvider の記述:
ページプロバイダの初期化を行います。

ページプロバイダのインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース UserPageProvider 内の init
オーバーライド:
クラス PortalStandardUserPageProvider 内の init
パラメータ:
params - 初期化パラメータのマップ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardPasswordHistoryAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.password
クラス StandardPasswordHistoryAccessor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor
すべての実装インタフェース:
PasswordHistoryAccessor
public class StandardPasswordHistoryAccessor
extends Object
implements PasswordHistoryAccessor

パスワード履歴管理アクセッサクラス。

パスワード履歴の読み込みおよび書き込みクラスです。

タグ名 | 属性 | 説明 | デフォルト値
change-password-first-login | (なし) | 初回ログイン時のパスワード変更要求の有無を設定します。 | false
password-expire-limit | (なし) | パスワードの有効期限（日数）を設定します。0の場合無期限となります。 | 0
password-history-count | (なし) | 何世代前まで世代管理を行うかを設定します。0の場合履歴管理を行いません。 | 0
deny-client-types | なし | パスワード変更画面に遷移させないクライアントタイプをカンマ区切りで設定します。 | mobile
password-expire-page | (なし) | パスワード変更画面ＵＲＬを設定します。 | /system/security/user /password_expire.jssp
check-password | enable | パスワードチェックの利用有無を判定します。 enable属性： true：利用 false：利用なし | false
check-password-length | enable | パスワードの文字数判定の利用有無とその範囲を設定します。 enable属性： true：利用 false：利用なし min属性：パスワードの最小文字数（半角数字,0以上）を設定します。 max属性：パスワードの最大文字数（半角数字,最大50）を設定します。 51文字以上は入力することができません。 | false
 | min |  | 0
 | max |  | 50
allow-latin-letters | required | 使用可能文字の設定(アルファベット)を行います。 required属性：混在判定の利用有無 true：利用 false：利用なし | ABCDEFGHIJ KLMNOPQRS TUVWXYZabc defghijklmnop qrstuvwxyz
allow-number | required | 使用可能文字の設定(数字)を行います。 required属性：混在判定の利用有無 true：利用 false：利用なし | 0123456789
allow-extra-char | required | 使用可能文字の設定（その他の文字列、記号など)を行います。 required属性：混在判定の利用有無 true：利用 false：利用なし | _-.+$#!/@
deny-old-password | (なし) | パスワード履歴管理で管理されているパスワードは拒否するかどうかを設定します。 true：利用 false：利用なし | false
deny-userid | (なし) | useridと同じパスワードを拒否するかどうかを設定します。 true：利用 false：利用なし | false
password-cryption-class | (なし) | 暗号化を行うクラスを設定します。 | jp.co.intra_mart. foundation.security.cryption. StandardCryption
return-initial-page | (なし) | パスワード有効期限切れの場合、パスワード変更後 ログイン画面に戻るかそのままログイン処理を継続し てログインするか判定します。 true:ログイン画面に戻ります。 false:ログイン処理を継続してログインします。 | false

コンストラクタの概要
StandardPasswordHistoryAccessor()
メソッドの概要
void | addPasswordHistory(String groupId, String userId, String password) パスワード履歴の追加。
PasswordHistoryResult | checkPasswordHistory(String groupId, String userId, String password) 入力パスワードのチェック。
void | clearPasswordHistories(String groupId) パスワード履歴の消去。
void | clearPasswordHistory(String groupId, String userId) 指定ユーザのパスワード履歴の消去。
String | createPassword(int count) パスワードをランダムに生成。
PasswordHistory | getLatestPasswordHistory(String groupId, String userId) 最新のパスワードと更新日付を取得。
int | getPasswordExpireLimit(String groupId) 設定したパスワードの有効期限を取得。
PasswordHistory[] | getPasswordHistories(String groupId, String userId) パスワード履歴を取得。
int | getPasswordHistoryCount(String groupId, String userId) パスワード履歴数を取得。
int | getPasswordHistoryManagedCount(String groupId) 世代管理数を取得。
String | getPasswordPage(String groupId) パスワード変更画面のＵＲＬを取得。
void | init(Node defaultNode, Node groupNode) パラメータを取得。
boolean | isChangePasswordFirstLogin(String groupId) 初回ログイン時にパスワード変更要求を行うかの判定。
boolean | isDenyClientType(String clientType) クライアントタイプの判定 パラメータdeny-client-typesに記述があるクライアントタイプの判定を行う。
boolean | isFirstLogin(String groupId, String userId) 初回ログインの判定
boolean | isForwardInitialPage(String groupId) パスワード変更後の画面遷移。
boolean | isPasswordExpired(String groupId, String userId, String clientType, Date date) パスワードが有効期限切れかどうかの判定。
boolean | isPasswordHistoryManaged(String groupId) 履歴管理の有無。
void | verifyPasswordHistory(String groupId, String userId, int remain) ユーザのパスワードを消去。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardPasswordHistoryAccessor

public StandardPasswordHistoryAccessor()
メソッドの詳細

init

public void init(Node defaultNode,
                 Node groupNode)
パラメータを取得。

設定したパスワード履歴管理に関するパラメータを取得します。

定義:
インタフェース PasswordHistoryAccessor 内の init
パラメータ:
defaultNode - デフォルトパラメータ
groupNode - ログイングループパラメータ

addPasswordHistory

public void addPasswordHistory(String groupId,
                               String userId,
                               String password)
                        throws PasswordHistoryException
パスワード履歴の追加。

指定ユーザの入力パスワードをデータベースに追加します。

定義:
インタフェース PasswordHistoryAccessor 内の addPasswordHistory
パラメータ:
groupId - グループID
userId - ユーザID
password - 入力パスワード
例外:
PasswordHistoryException - パスワード履歴の追加に失敗した場合にスローされます。

checkPasswordHistory

public PasswordHistoryResult checkPasswordHistory(String groupId,
                                                  String userId,
                                                  String password)
                                           throws PasswordHistoryException
入力パスワードのチェック。

パスワードのチェックを行います。

パスワードの文字数をチェックします。
パスワードが51文字以上の場合、falseを返します。

パスワードの入力チェックの利用について判定します。
パラメータ"check-password"で設定した値が設定した値がfalseの場合trueを返します。パスワードチェックは行いません。
trueの場合は以下のパスワードチェックを行います。

使用不可能文字が混在していないかチェックを行います。

check-password-lengthがtrueの場合文字数チェックを行います。

deny-useridがtrueの場合useridと同一パスワードの判定を行います。

英数字記号混在判定チェックを行います。
英字　数字　記号全ての判定をtrueにした場合、最低3文字以上のパスワードを設定する必要があります。

deny-old-passwordがtrueかつがpassword-history-countが0より大きい場合、世代管理チェックを行います。

定義:
インタフェース PasswordHistoryAccessor 内の checkPasswordHistory
パラメータ:
groupId - グループID
userId - ユーザID
password - 入力パスワード
戻り値:
true：入力チェック成功　false：入力チェック失敗,メッセージ,詳細メッセージ
例外:
PasswordHistoryException - 入力パスワードのチェックに失敗した場合にスローされます。

clearPasswordHistories

public void clearPasswordHistories(String groupId)
                            throws PasswordHistoryException
パスワード履歴の消去。

引数のログイングループのパスワード履歴をすべて消去します。

定義:
インタフェース PasswordHistoryAccessor 内の clearPasswordHistories
パラメータ:
groupId - グループID
例外:
PasswordHistoryException - パスワード履歴の消去に失敗した場合にスローされます。

clearPasswordHistory

public void clearPasswordHistory(String groupId,
                                 String userId)
                          throws PasswordHistoryException
指定ユーザのパスワード履歴の消去。

引数のユーザのパスワード履歴を消去します。

定義:
インタフェース PasswordHistoryAccessor 内の clearPasswordHistory
パラメータ:
groupId - グループID
userId - ユーザID
例外:
PasswordHistoryException - 指定ユーザのパスワード履歴の消去に失敗した場合にスローされます。

getPasswordHistories

public PasswordHistory[] getPasswordHistories(String groupId,
                                              String userId)
                                       throws PasswordHistoryException
パスワード履歴を取得。

指定ユーザのパスワード履歴を取得します。

定義:
インタフェース PasswordHistoryAccessor 内の getPasswordHistories
パラメータ:
groupId - グループID
userId - ユーザID
戻り値:
指定ユーザのパスワード履歴一覧
例外:
PasswordHistoryException - パスワード履歴の取得に失敗した場合にスローされます。

getPasswordHistoryCount

public int getPasswordHistoryCount(String groupId,
                                   String userId)
                            throws PasswordHistoryException
パスワード履歴数を取得。

指定ユーザのパスワード履歴数を取得します。

定義:
インタフェース PasswordHistoryAccessor 内の getPasswordHistoryCount
パラメータ:
groupId - グループID
userId - ユーザID
戻り値:
パスワード履歴数
例外:
PasswordHistoryException - パスワード履歴数の取得に失敗した場合にスローされます。

getPasswordHistoryManagedCount

public int getPasswordHistoryManagedCount(String groupId)
世代管理数を取得。

パスワードの世代管理数を取得します。

定義:
インタフェース PasswordHistoryAccessor 内の getPasswordHistoryManagedCount
パラメータ:
groupId - グループID
戻り値:
パスワード世代管理数

getPasswordPage

public String getPasswordPage(String groupId)
パスワード変更画面のＵＲＬを取得。

パスワード変更画面のＵＲＬを取得します。

定義:
インタフェース PasswordHistoryAccessor 内の getPasswordPage
パラメータ:
groupId - グループID
戻り値:
パスワード変更画面のＵＲＬ

isForwardInitialPage

public boolean isForwardInitialPage(String groupId)
パスワード変更後の画面遷移。

パスワードの有効期限切れによるパスワード再設定後、ログイン画面に戻るか、ログイン処理を継続してログインするかを判定します。

定義:
インタフェース PasswordHistoryAccessor 内の isForwardInitialPage
パラメータ:
groupId - グループID
戻り値:
true：ログイン画面に戻ります。　false：ログイン処理を継続してログインします。

isPasswordExpired

public boolean isPasswordExpired(String groupId,
                                 String userId,
                                 String clientType,
                                 Date date)
パスワードが有効期限切れかどうかの判定。

パスワードが有効期限切れかどうかを行うか判定します。
クライアントタイプがdeny-client-typesに記述されているクライアントタイプの場合はパスワードの有効期限チェックを行いません。

定義:
インタフェース PasswordHistoryAccessor 内の isPasswordExpired
パラメータ:
groupId - グループID
userId - ユーザID
clientType - クライアントタイプ
date - パスワードのチェックの基準となる日付。省略された場合、現在日付が利用されます。
戻り値:
true：パスワード変更要求を行います。　false：パスワード変更要求を行いません。

isPasswordHistoryManaged

public boolean isPasswordHistoryManaged(String groupId)
履歴管理の有無。

履歴管理を行うかどうか判定します。
パラメータ"password-expire-limit"が0の場合履歴管理は行いません。

定義:
インタフェース PasswordHistoryAccessor 内の isPasswordHistoryManaged
パラメータ:
groupId - グループID
戻り値:
ture：履歴管理を行います。　false：履歴管理を行いません。

verifyPasswordHistory

public void verifyPasswordHistory(String groupId,
                                  String userId,
                                  int remain)
                           throws PasswordHistoryException
ユーザのパスワードを消去。

引数 remain の値分残してユーザの履歴を消去します。
引数 remain が0以下の場合、履歴をすべて消去します。

定義:
インタフェース PasswordHistoryAccessor 内の verifyPasswordHistory
パラメータ:
groupId - グループID
userId - ユーザID
remain - 残す履歴の数
例外:
PasswordHistoryException - パスワード履歴の消去に失敗した場合にスローされます。

getLatestPasswordHistory

public PasswordHistory getLatestPasswordHistory(String groupId,
                                                String userId)
                                         throws PasswordHistoryException
最新のパスワードと更新日付を取得。

指定ユーザの最新パスワードと更新日付を取得します。

定義:
インタフェース PasswordHistoryAccessor 内の getLatestPasswordHistory
パラメータ:
groupId - グループID
userId - ユーザID
戻り値:
パスワード、更新日付
例外:
PasswordHistoryException - 最新のパスワード情報の取得に失敗した場合にスローされます。

createPassword

public String createPassword(int count)
パスワードをランダムに生成。

引数の値の長さのパスワードをランダムに生成します。
呼出し毎に異なるパスワードを生成します。

定義:
インタフェース PasswordHistoryAccessor 内の createPassword
パラメータ:
count - パスワードの長さ
戻り値:
生成されたパスワード

isChangePasswordFirstLogin

public boolean isChangePasswordFirstLogin(String groupId)
初回ログイン時にパスワード変更要求を行うかの判定。

定義:
インタフェース PasswordHistoryAccessor 内の isChangePasswordFirstLogin
パラメータ:
groupId - グループID
戻り値:
true：パスワード変更要求を行う / false：パスワード変更要求を行わない

isFirstLogin

public boolean isFirstLogin(String groupId,
                            String userId)
初回ログインの判定

定義:
インタフェース PasswordHistoryAccessor 内の isFirstLogin
パラメータ:
groupId - グループID
userId - ユーザID
戻り値:
true：初回ログイン / false：初回ログインではない

isDenyClientType

public boolean isDenyClientType(String clientType)
クライアントタイプの判定

パラメータdeny-client-typesに記述があるクライアントタイプの判定を行う。

定義:
インタフェース PasswordHistoryAccessor 内の isDenyClientType
パラメータ:
clientType - クライアントタイプ
戻り値:
true：クライアントタイプが含まれている false：クライアントタイプが含まれていない

getPasswordExpireLimit

public int getPasswordExpireLimit(String groupId)
設定したパスワードの有効期限を取得。

パラメータで設定したパスワードの有効期限日数を取得します。

定義:
インタフェース PasswordHistoryAccessor 内の getPasswordExpireLimit
パラメータ:
groupId - グループID
戻り値:
パスワード有効期限日数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.permission.AccessControllerPermissionSelector の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.permission.AccessControllerPermissionSelector の使用

jp.co.intra_mart.foundation.security.permission.AccessControllerPermissionSelector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector の使用

jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.permission.AdminMenuPermissionSelector の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.permission.AdminMenuPermissionSelector の使用

jp.co.intra_mart.foundation.security.permission.AdminMenuPermissionSelector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector の使用

jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.permission.PermissionManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.permission.PermissionManager の使用

jp.co.intra_mart.foundation.security.permission.PermissionManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.permission.PermissionSelector の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.permission.PermissionSelector の使用

PermissionSelector を使用しているパッケージ
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.security.permission | 権限に関連するクラスを提供します。

jp.co.intra_mart.foundation.navigator での PermissionSelector の使用

PermissionSelector を実装している jp.co.intra_mart.foundation.navigator のクラス
 class EventNavigatorPermissionSelector
ユーザIDから有効なID一覧を取得するセレクタ。

jp.co.intra_mart.foundation.security.permission での PermissionSelector の使用

PermissionSelector を実装している jp.co.intra_mart.foundation.security.permission のクラス
class | AccessControllerPermissionSelector ユーザIDから有効なアクセスコントローラのID一覧を取得するセレクタ。
class | AccountRolePermissionSelector ユーザIDから有効なすべてのロールを取得するセレクタ。
class | AdminMenuPermissionSelector ユーザIDから有効なメニューのID一覧を取得するセレクタ。
class | MenuPermissionSelector ユーザIDから有効なメニューのID一覧を取得するセレクタ。

PermissionSelector を返す jp.co.intra_mart.foundation.security.permission のメソッド
 PermissionSelector PermissionManager.getPermissionSelector(String category)
指定されたカテゴリについて、設定XMLファイルで定義されているPermissionSelectorを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AccessControllerPermissionSelector (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.permission
クラス AccessControllerPermissionSelector

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.permission.AccessControllerPermissionSelector
すべての実装インタフェース:
PermissionSelector
public class AccessControllerPermissionSelector
extends Object
implements PermissionSelector

ユーザIDから有効なアクセスコントローラのID一覧を取得するセレクタ。

選択条件としてのユーザIDと日付からアクセス可能なアクセスコントローラのアクセスコントローラIDを選択します。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
AccessControllerPermissionSelector()
コンストラクタ。
メソッドの概要
Collection | doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
void | init(Map param) インスタンスの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AccessControllerPermissionSelector

public AccessControllerPermissionSelector()
コンストラクタ。

メソッドの詳細

doSelection

public Collection doSelection(String groupId,
                              String[] infos)
                       throws AccessSecurityException
選択用情報を利用して選別された情報のリストを返却します。
返却される情報のリストの各要素はJavaBeansの規格に準ずるオブジェクトでなければなりません。

定義:
インタフェース PermissionSelector 内の doSelection
パラメータ:
groupId - ログイングループID
infos - 選択用情報(配列)
0 : ログイングループID
1 : 対象日付(YYYY/MM/DD|hh:mm:ss)(省略可)
対象日付を省略した場合は、現在の日付を使用します。
上記の情報を利用して、選別された情報のリストを作成して返却します。
戻り値:
選別された情報のリスト
例外:
AccessSecurityException

init

public void init(Map param)
インスタンスの初期化を行います。
このインスタンスが生成された時に1度だけコールされます。

定義:
インタフェース PermissionSelector 内の init
パラメータ:
param - XMLで定義されたPermissionSelectorに関連付けられたパラメータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccountRolePermissionSelector (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.permission
クラス AccountRolePermissionSelector

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector
すべての実装インタフェース:
PermissionSelector
public class AccountRolePermissionSelector
extends Object
implements PermissionSelector

ユーザIDから有効なすべてのロールを取得するセレクタ。

選択条件としてのユーザIDからユーザが保有するすべてのロールIDを選択します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
AccountRolePermissionSelector()
コンストラクタ。
メソッドの概要
Collection | doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
void | init(Map param) インスタンスの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AccountRolePermissionSelector

public AccountRolePermissionSelector()
コンストラクタ。

メソッドの詳細

doSelection

public Collection doSelection(String groupId,
                              String[] infos)
                       throws AccessSecurityException
選択用情報を利用して選別された情報のリストを返却します。
返却される情報のリストの各要素はJavaBeansの規格に準ずるオブジェクトでなければなりません。

定義:
インタフェース PermissionSelector 内の doSelection
パラメータ:
groupId - ログイングループID
infos - 選択用情報(配列)
この情報を利用して、選別された情報のリストを作成して返却します。
戻り値:
選別された情報のリスト
例外:
AccessSecurityException

init

public void init(Map param)
インスタンスの初期化を行います。
このインスタンスが生成された時に1度だけコールされます。

定義:
インタフェース PermissionSelector 内の init
パラメータ:
param - XMLで定義されたPermissionSelectorに関連付けられたパラメータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AdminMenuPermissionSelector (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.permission
クラス AdminMenuPermissionSelector

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.permission.AdminMenuPermissionSelector
すべての実装インタフェース:
PermissionSelector
public class AdminMenuPermissionSelector
extends Object
implements PermissionSelector

ユーザIDから有効なメニューのID一覧を取得するセレクタ。

選択条件としてのユーザIDからアクセス可能なメニューのメニューIDを選択します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
AdminMenuPermissionSelector()
コンストラクタ。
メソッドの概要
Collection | doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
void | init(Map param) インスタンスの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AdminMenuPermissionSelector

public AdminMenuPermissionSelector()
コンストラクタ。

メソッドの詳細

doSelection

public Collection doSelection(String groupId,
                              String[] infos)
                       throws AccessSecurityException
選択用情報を利用して選別された情報のリストを返却します。
返却される情報のリストの各要素はJavaBeansの規格に準ずるオブジェクトでなければなりません。

定義:
インタフェース PermissionSelector 内の doSelection
パラメータ:
groupId - ログイングループID
infos - 選択用情報(配列)
この情報を利用して、選別された情報のリストを作成して返却します。
戻り値:
選別された情報のリスト
例外:
AccessSecurityException

init

public void init(Map param)
インスタンスの初期化を行います。
このインスタンスが生成された時に1度だけコールされます。

定義:
インタフェース PermissionSelector 内の init
パラメータ:
param - XMLで定義されたPermissionSelectorに関連付けられたパラメータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuPermissionSelector (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.permission
クラス MenuPermissionSelector

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector
すべての実装インタフェース:
PermissionSelector
public class MenuPermissionSelector
extends Object
implements PermissionSelector

ユーザIDから有効なメニューのID一覧を取得するセレクタ。

選択条件としてのユーザIDからアクセス可能なメニューのメニューIDを選択します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
MenuPermissionSelector()
コンストラクタ。
メソッドの概要
Collection | doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
void | init(Map param) インスタンスの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MenuPermissionSelector

public MenuPermissionSelector()
コンストラクタ。

メソッドの詳細

doSelection

public Collection doSelection(String groupId,
                              String[] infos)
                       throws AccessSecurityException
選択用情報を利用して選別された情報のリストを返却します。
返却される情報のリストの各要素はJavaBeansの規格に準ずるオブジェクトでなければなりません。

定義:
インタフェース PermissionSelector 内の doSelection
パラメータ:
groupId - ログイングループID
infos - 選択用情報(配列)
この情報を利用して、選別された情報のリストを作成して返却します。
戻り値:
選別された情報のリスト
例外:
AccessSecurityException

init

public void init(Map param)
インスタンスの初期化を行います。
このインスタンスが生成された時に1度だけコールされます。

定義:
インタフェース PermissionSelector 内の init
パラメータ:
param - XMLで定義されたPermissionSelectorに関連付けられたパラメータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.permission (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.security.permission
インタフェース
PermissionSelector
クラス
AccessControllerPermissionSelector
AccountRolePermissionSelector
AdminMenuPermissionSelector
MenuPermissionSelector
PermissionManager


jp.co.intra_mart.foundation.security.permission (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.permission

権限に関連するクラスを提供します。

参照:
説明

インタフェースの概要
PermissionSelector パーミッション・作成クラスインタフェース。

クラスの概要
AccessControllerPermissionSelector | ユーザIDから有効なアクセスコントローラのID一覧を取得するセレクタ。
AccountRolePermissionSelector | ユーザIDから有効なすべてのロールを取得するセレクタ。
AdminMenuPermissionSelector | ユーザIDから有効なメニューのID一覧を取得するセレクタ。
MenuPermissionSelector | ユーザIDから有効なメニューのID一覧を取得するセレクタ。
PermissionManager | パーミッション・マネージャクラス。

パッケージ jp.co.intra_mart.foundation.security.permission の説明

権限に関連するクラスを提供します。


jp.co.intra_mart.foundation.security.permission クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.permission の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.permission.AccessControllerPermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.foundation.security.permission.AdminMenuPermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.foundation.security.permission.PermissionManager

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.permission.PermissionSelector


パッケージ jp.co.intra_mart.foundation.security.permission の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.permission の使用

jp.co.intra_mart.foundation.security.permission を使用しているパッケージ
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.security.permission | 権限に関連するクラスを提供します。

jp.co.intra_mart.foundation.navigator により使用される jp.co.intra_mart.foundation.security.permission のクラス
PermissionSelector
パーミッション・作成クラスインタフェース。

jp.co.intra_mart.foundation.security.permission により使用される jp.co.intra_mart.foundation.security.permission のクラス
PermissionSelector
パーミッション・作成クラスインタフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PermissionManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.permission
クラス PermissionManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.permission.PermissionManager
public class PermissionManager
extends Object

パーミッション・マネージャクラス。

パーミッションを生成するマネージャクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
PermissionManager(String groupId)
コンストラクタ。
メソッドの概要
Collection | doSelection(String category, String info) 選択用情報を利用して選別された情報のリストを返却します。
Collection | doSelection(String category, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
String[] | getCategories() 設定XMLファイルで定義されているすべてのカテゴリ名を返却します。
PermissionSelector | getPermissionSelector(String category) 指定されたカテゴリについて、設定XMLファイルで定義されているPermissionSelectorを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PermissionManager

public PermissionManager(String groupId)
                  throws AccessSecurityException
コンストラクタ。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityException - ログイングループIDが不正な場合にスローされます。
メソッドの詳細

getCategories

public String[] getCategories()
設定XMLファイルで定義されているすべてのカテゴリ名を返却します。

戻り値:
カテゴリ名配列
導入されたバージョン:
5.0

getPermissionSelector

public PermissionSelector getPermissionSelector(String category)
                                         throws AccessSecurityException
指定されたカテゴリについて、設定XMLファイルで定義されているPermissionSelectorを返します。
カテゴリに一致する情報がない場合は、nullが返却されます。

パラメータ:
category - 設定ファイル内のカテゴリ名
戻り値:
カテゴリに対応するPermissionSelectorインスタンス
例外:
AccessSecurityException - 引数が不正だった場合にスローされます。

doSelection

public Collection doSelection(String category,
                              String[] infos)
                       throws AccessSecurityException
選択用情報を利用して選別された情報のリストを返却します。
返却される情報のリストの各要素はJavaBeansの規格に準ずるオブジェクトです。

パラメータ:
category - カテゴリ
設定XMLファイルで定義されています。
infos - 選択用情報(配列)
この情報を利用して、選別された情報のリストを作成して返却します。
戻り値:
選別された情報リスト
カテゴリが存在しなかった場合は、nullを返却します。
例外:
AccessSecurityException - パーミッション作成に失敗した場合、または引数が不正だった場合にスローされます。

doSelection

public Collection doSelection(String category,
                              String info)
                       throws AccessSecurityException
選択用情報を利用して選別された情報のリストを返却します。
返却される情報のリストの各要素はJavaBeansの規格に準ずるオブジェクトです。

パラメータ:
category - カテゴリ
設定XMLファイルで定義されています。
info - 選択用情報
この情報を利用して、選別された情報のリストを作成して返却します。
戻り値:
選別された情報リスト
カテゴリが存在しなかった場合は、nullを返却します。
例外:
AccessSecurityException - パーミッション作成に失敗した場合、または引数が不正だった場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PermissionSelector (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.permission
インタフェース PermissionSelector

既知の実装クラスの一覧:
AccessControllerPermissionSelector, AccountRolePermissionSelector, AdminMenuPermissionSelector, EventNavigatorPermissionSelector, MenuPermissionSelector
public interface PermissionSelector

パーミッション・作成クラスインタフェース。 パーミッションの作成クラスが実装するメソッドを定義します。
各種PermissionFactoryクラスは必ずこのインタフェースを実装し、設定XMLファイルに登録します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
Collection | doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
void | init(Map param) インスタンスの初期化を行います。

メソッドの詳細

doSelection

public Collection doSelection(String groupId,
                              String[] infos)
                       throws AccessSecurityException
選択用情報を利用して選別された情報のリストを返却します。
返却される情報のリストの各要素はJavaBeansの規格に準ずるオブジェクトでなければなりません。

パラメータ:
groupId - ログイングループID
infos - 選択用情報(配列)
この情報を利用して、選別された情報のリストを作成して返却します。
戻り値:
選別された情報のリスト
例外:
AccessSecurityException

init

public void init(Map param)
インスタンスの初期化を行います。
このインスタンスが生成された時に1度だけコールされます。

パラメータ:
param - XMLで定義されたPermissionSelectorに関連付けられたパラメータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.role.Role の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.role.Role の使用

Role を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal での Role の使用

Role を返す jp.co.intra_mart.foundation.datastore.application.domain.deal のメソッド
abstract  Role[] DealPermissionManager.getRoles(Deal deal)
取扱情報を保有するアクセス権をもつロールを返します。

jp.co.intra_mart.foundation.navigator での Role の使用

Role を返す jp.co.intra_mart.foundation.navigator のメソッド
Role[] | EventAccessInfo.getRoles()
Role | EventAccessInfo.getRole(int i)

Role 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | EventAccessInfo.setRoles(Role[] roles)
void | EventAccessInfo.setRole(int i, Role role)
void | EventAccessInfo.addRole(Role role)

jp.co.intra_mart.foundation.security での Role の使用

Role を返す jp.co.intra_mart.foundation.security のメソッド
Role[] | StandardRoleAccessor.getRoleData(String groupId) ロール情報を全件取得します。
Role | StandardRoleAccessor.getRoleData(String groupId, String roleId) ロール情報を取得します。
Role[] | StandardRoleAccessor.getRoleDataByCategory(String groupId, String category) カテゴリからロール情報を取得します。
Role[] | StandardRoleAccessor.getRolesByIds(String groupId, String[] roleIds) 指定されたロールIDのロール情報をすべて取得します。

Role 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | StandardRoleAccessor.createRole(String groupId, Role role) ロール情報を新規追加します。
void | StandardRoleAccessor.updateRole(String groupId, Role role) ロール情報を更新します。

jp.co.intra_mart.foundation.security.access での Role の使用

Role 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | RoleChangedControllerListener.roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RoleChangedControllerListener.roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.account での Role の使用

Role 型のパラメータを持つ jp.co.intra_mart.foundation.security.account のメソッド
void | RoleChangedAccountListener.roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RoleChangedAccountListener.roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.menu での Role の使用

Role 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | RoleChangedMenuListener.roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RoleChangedMenuListener.roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.role での Role の使用

Role を返す jp.co.intra_mart.foundation.security.role のメソッド
Role | RoleReaderDecorator.doDecoration(String groupId, Role role) ロール情報をデータストアから読み込んだ直後にコールされます。
Role | RoleManager.getRole(String roleId) ロール情報を取得します。
Role[] | RoleManager.getRoles() すべてのロール情報を取得します。
Role[] | RoleManager.getRolesByCategory(String category) カテゴリー検索によりロールを取得します。
Role[] | RoleManager.getRolesByIds(String[] roleIds) ログイングループ内で引数指定したロールIDのロール情報をすべて取得します。
Role[] | RoleManager.searchRolesById(String key) ロールID検索によりロールを取得します。
Role[] | RoleManager.searchRolesByName(String name) ロール名称検索によりロールを取得します。
Role[] | RoleAccessor.getRoleData(String groupId) ロール情報を全件取得する。
Role | RoleAccessor.getRoleData(String groupId, String roleId) ロール情報を取得する。
Role[] | RoleAccessor.getRoleDataByCategory(String groupId, String category) カテゴリからロール情報を取得する。
Role[] | RoleAccessor.getRolesByIds(String groupId, String[] roleIds) 指定されたロールIDのロール情報をすべて取得する。

Role 型のパラメータを持つ jp.co.intra_mart.foundation.security.role のメソッド
Role | RoleReaderDecorator.doDecoration(String groupId, Role role) ロール情報をデータストアから読み込んだ直後にコールされます。
void | RoleQueryWriterListener.queryCreateRole(String groupId, Role role) ロール情報をデータストアに作成する直前にコールされます。
void | RoleQueryWriterListener.queryUpdateRole(String groupId, Role role) ロール情報をデータストアに更新する直前にコールされます。
void | RolePostWriterListener.postCreateRole(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RolePostWriterListener.postUpdateRole(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | RoleManager.addRole(Role role) ロール情報を新規登録します。
void | RoleManager.updateRole(Role role) ロール情報を更新します。
void | RoleChangedListener.roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RoleChangedListener.roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | RoleAccessor.createRole(String groupId, Role role) ロール情報を新規に追加する。
void | RoleAccessor.updateRole(String groupId, Role role) ロール情報を更新する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.role.RoleAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.role.RoleAccessor の使用

RoleAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での RoleAccessor の使用

RoleAccessor を実装している jp.co.intra_mart.foundation.security のクラス
 class StandardRoleAccessor
ロールアクセッサクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.role.RoleChangedListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.role.RoleChangedListener の使用

RoleChangedListener を使用しているパッケージ
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.access での RoleChangedListener の使用

RoleChangedListener を実装している jp.co.intra_mart.foundation.security.access のクラス
 class RoleChangedControllerListener
ロールが削除された場合にアクセスコントローラに紐付くロールを削除するリスナークラスです。

jp.co.intra_mart.foundation.security.account での RoleChangedListener の使用

RoleChangedListener を実装している jp.co.intra_mart.foundation.security.account のクラス
 class RoleChangedAccountListener
ロールが削除された場合にアカウントに紐付くロールを削除するリスナークラス。

jp.co.intra_mart.foundation.security.menu での RoleChangedListener の使用

RoleChangedListener を実装している jp.co.intra_mart.foundation.security.menu のクラス
 class RoleChangedMenuListener
ロールが削除された場合にメニューに紐付くロールを削除するリスナークラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.role.RoleExporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.role.RoleExporter の使用

RoleExporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.role ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.role での RoleExporter の使用

RoleExporter を実装している jp.co.intra_mart.foundation.security.role のクラス
 class StandardRoleBackup
ロールバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.role.RoleImporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.role.RoleImporter の使用

RoleImporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.role ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.role での RoleImporter の使用

RoleImporter を実装している jp.co.intra_mart.foundation.security.role のクラス
 class StandardRoleBackup
ロールバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.role.RoleManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.role.RoleManager の使用

RoleManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.role ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.role での RoleManager の使用

RoleManager 型のパラメータを持つ jp.co.intra_mart.foundation.security.role のメソッド
void | RoleImporter.doImport(InputStream inputStream, RoleManager manager) インポートを行います。
void | RoleExporter.doExport(RoleManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardRoleBackup.doImport(InputStream inputStream, RoleManager manager) インポートを行います。
void | StandardRoleBackup.doExport(RoleManager manager, OutputStream outputStream) エクスポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.role.RolePostWriterListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.role.RolePostWriterListener の使用

jp.co.intra_mart.foundation.security.role.RolePostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener の使用

jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.role.RoleReaderDecorator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.role.RoleReaderDecorator の使用

jp.co.intra_mart.foundation.security.role.RoleReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.role.StandardRoleBackup の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.role.StandardRoleBackup の使用

jp.co.intra_mart.foundation.security.role.StandardRoleBackup はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.security.role (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.security.role
インタフェース
RoleAccessor
RoleChangedListener
RoleExporter
RoleImporter
RolePostWriterListener
RoleQueryWriterListener
RoleReaderDecorator
クラス
Role
RoleManager
StandardRoleBackup


jp.co.intra_mart.foundation.security.role (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.role

ロールに関連するクラスを提供します。

参照:
説明

インタフェースの概要
RoleAccessor | ロールアクセッサインタフェース。
RoleChangedListener | ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
RoleExporter | ロールエクスポートインタフェースです。
RoleImporter | ロールインポートインタフェースです。
RolePostWriterListener | ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
RoleQueryWriterListener | ロール情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
RoleReaderDecorator | ロール情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

クラスの概要
Role | ロール・モデルインタフェース。
RoleManager | ロールマネージャクラス。
StandardRoleBackup | ロールバックアップクラスです。

パッケージ jp.co.intra_mart.foundation.security.role の説明

ロールに関連するクラスを提供します。


jp.co.intra_mart.foundation.security.role クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.role の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.role.Role (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.role.RoleManager
    • class jp.co.intra_mart.foundation.security.role.StandardRoleBackup (implements jp.co.intra_mart.foundation.security.role.RoleExporter, jp.co.intra_mart.foundation.security.role.RoleImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.role.RoleAccessor
  • interface jp.co.intra_mart.foundation.security.role.RoleChangedListener
  • interface jp.co.intra_mart.foundation.security.role.RoleExporter
  • interface jp.co.intra_mart.foundation.security.role.RoleImporter
  • interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener
  • interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.role.RoleReaderDecorator


パッケージ jp.co.intra_mart.foundation.security.role の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.role の使用

jp.co.intra_mart.foundation.security.role を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal により使用される jp.co.intra_mart.foundation.security.role のクラス
Role
ロール・モデルインタフェース。

jp.co.intra_mart.foundation.navigator により使用される jp.co.intra_mart.foundation.security.role のクラス
Role
ロール・モデルインタフェース。

jp.co.intra_mart.foundation.security により使用される jp.co.intra_mart.foundation.security.role のクラス
Role
ロール・モデルインタフェース。
RoleAccessor
ロールアクセッサインタフェース。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.security.role のクラス
Role
ロール・モデルインタフェース。
RoleChangedListener
ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

jp.co.intra_mart.foundation.security.account により使用される jp.co.intra_mart.foundation.security.role のクラス
Role
ロール・モデルインタフェース。
RoleChangedListener
ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.security.role のクラス
Role
ロール・モデルインタフェース。
RoleChangedListener
ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

jp.co.intra_mart.foundation.security.role により使用される jp.co.intra_mart.foundation.security.role のクラス
Role
ロール・モデルインタフェース。
RoleExporter
ロールエクスポートインタフェースです。
RoleImporter
ロールインポートインタフェースです。
RoleManager
ロールマネージャクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Role (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
クラス Role

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.role.Role
すべての実装インタフェース:
Serializable
public class Role
extends Object
implements Serializable

ロール・モデルインタフェース。

ロールのデータモデルインタフェースを定義する。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
Role()
コンストラクタ。
Role(String roleId)
コンストラクタ。
Role(String roleId, String roleName)
コンストラクタ。
メソッドの概要
boolean | equals(Object role) データモデルのチェック。
String | getCategory() ロールカテゴリを取得します。
String | getDescription() 説明を取得します。
String | getDisplayName(Locale locale) ロール表示名を取得します。
Locale[] | getLocales() ロケールの一覧を取得します。
String | getRoleId() ロールIDを取得します。
String | getRoleName() ロール名を取得します。
int | hashCode() ハッシュコードを取得します。
void | removeDisplayName(Locale locale) ロケールに対応したロール表示名を削除します。
void | setCategory(String category) ロールカテゴリを設定します。
void | setDescription(String description) 説明を設定します。
void | setDisplayName(Locale locale, String displayName) ロール表示名を設定します。
void | setRoleId(String roleId) ロールIDを設定します。
void | setRoleName(String name) ロール名を設定します。
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Role

public Role()
コンストラクタ。

ロールIDは自動採番されます。

Role

public Role(String roleId)
コンストラクタ。

パラメータ:
roleId - ロールID

Role

public Role(String roleId,
            String roleName)
     throws IOException
コンストラクタ。

パラメータ:
roleId - ロールID
roleName - ロール名
メソッドの詳細

equals

public boolean equals(Object role)
データモデルのチェック。

指定されたオブジェクトがモデルと一致するかをチェックする

パラメータ:
role - :チェック対象のオブジェクト
戻り値:
true :オブジェクトがモデルと一致 false :オブジェクトがモデルと不一致
関連項目:
Object.equals(Object)

getCategory

public String getCategory()
ロールカテゴリを取得します。

戻り値:
ロールカテゴリ

getDescription

public String getDescription()
説明を取得します。

戻り値:
ロールの説明

getDisplayName

public String getDisplayName(Locale locale)
ロール表示名を取得します。

ロケールに対応したロール表示名を取得します。
存在しないロケールの場合は空文字を返します 。

パラメータ:
locale - ロケール
戻り値:
ロール表示名

getLocales

public Locale[] getLocales()
ロケールの一覧を取得します。

表示名として登録されているロケールの一覧を取得します。

戻り値:
登録されているロケールの一覧。

getRoleId

public String getRoleId()
ロールIDを取得します。

戻り値:
ロールID

getRoleName

public String getRoleName()
ロール名を取得します。

戻り値:
ロール名

hashCode

public int hashCode()
ハッシュコードを取得します。

戻り値:
ハッシュコード
関連項目:
Object.hashCode()

setCategory

public void setCategory(String category)
ロールカテゴリを設定します。

パラメータ:
category - ロールカテゴリ

setDescription

public void setDescription(String description)
説明を設定します。

パラメータ:
description - ロールの説明

setDisplayName

public void setDisplayName(Locale locale,
                           String displayName)
ロール表示名を設定します。

ロケールに対応したロール表示名を設定します。

パラメータ:
locale - ロケール
displayName - ロール表示名

removeDisplayName

public void removeDisplayName(Locale locale)
ロケールに対応したロール表示名を削除します。

ロケールに対応したロール表示名を削除します。

パラメータ:
locale - ロケール

setRoleId

public void setRoleId(String roleId)
ロールIDを設定します。

パラメータ:
roleId - ロールID

setRoleName

public void setRoleName(String name)
ロール名を設定します。

パラメータ:
name - ロール名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


RoleAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
インタフェース RoleAccessor

既知の実装クラスの一覧:
StandardRoleAccessor
public interface RoleAccessor

ロールアクセッサインタフェース。

ロール情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | createRole(String groupId, Role role) ロール情報を新規に追加する。
void | deleteCategory(String groupId) すべてのカテゴリを削除する。
void | deleteCategory(String groupId, String category) カテゴリを削除する。
void | deleteRole(String groupId) すべてのロール情報を削除する。
void | deleteRole(String groupId, String roleId) ロール情報を削除する。
void | deleteSubRole(String groupId, String roleId) 指定したロールのサブロールIDサマリを全削除する。
void | deleteSubRole(String groupId, String roleId, String subRoleId) サブロールIDサマリを削除する。
String[] | getAllParentRoleIds(String groupId, String roleId) すべての親ロールの一覧を取得する。
String[] | getAllSubRoleIds(String groupId, String roleId) すべてのサブロールの一覧を取得する。
String[] | getCategories(String groupId) カテゴリの一覧を取得する。
String[] | getParentRoleIds(String groupId, String roleId) 親ロールの一覧を取得する。
Role[] | getRoleData(String groupId) ロール情報を全件取得する。
Role | getRoleData(String groupId, String roleId) ロール情報を取得する。
Role[] | getRoleDataByCategory(String groupId, String category) カテゴリからロール情報を取得する。
Role[] | getRolesByIds(String groupId, String[] roleIds) 指定されたロールIDのロール情報をすべて取得する。
String[] | getSubRoleIds(String groupId, String roleId) サブロールIDサマリを取得する。
void | init(Map params) ロールアクセッサの初期化。
void | insertSubRole(String groupId, String roleId, String subRoleId) サブロールを作成する。
void | updateCategory(String groupId, String oldCategory, String newCategory) カテゴリを更新する。
void | updateRole(String groupId, Role role) ロール情報を更新する。

メソッドの詳細

createRole

public void createRole(String groupId,
                       Role role)
                throws AccessSecurityWriteException
ロール情報を新規に追加する。

パラメータ:
groupId - ログイングループID
role - ロール情報
例外:
AccessSecurityWriteException - ロール情報の作成に失敗した場合にスローされます。

deleteCategory

public void deleteCategory(String groupId)
                    throws AccessSecurityWriteException
すべてのカテゴリを削除する。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException - カテゴリの削除に失敗した場合にスローされます。

deleteCategory

public void deleteCategory(String groupId,
                           String category)
                    throws AccessSecurityWriteException
カテゴリを削除する。

パラメータ:
groupId - ログイングループID
category - カテゴリ名
例外:
AccessSecurityWriteException - カテゴリの削除に失敗した場合にスローされます。

deleteRole

public void deleteRole(String groupId)
                throws AccessSecurityWriteException
すべてのロール情報を削除する。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException - ロール情報の削除に失敗した場合にスローされます。

deleteRole

public void deleteRole(String groupId,
                       String roleId)
                throws AccessSecurityWriteException
ロール情報を削除する。

パラメータ:
groupId - ログイングループID
roleId - ロールID
例外:
AccessSecurityWriteException - ロール情報の削除に失敗した場合にスローされます。

getAllParentRoleIds

public String[] getAllParentRoleIds(String groupId,
                                    String roleId)
                             throws AccessSecurityReadException
すべての親ロールの一覧を取得する。

引数に指定したロールの上位階層にあるすべての親ロールを取得する。
親ロールが一件も存在しない場合空の配列を返却する。

パラメータ:
groupId - ログイングループID
roleId - ロールID
戻り値:
すべての親ロールIDの配列
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getAllSubRoleIds

public String[] getAllSubRoleIds(String groupId,
                                 String roleId)
                          throws AccessSecurityReadException
すべてのサブロールの一覧を取得する。

引数に指定したロールの下位階層にあるすべてのサブロールを取得する。
サブロールが一件も存在しない場合空の配列を返却する。

パラメータ:
groupId - ログイングループID
roleId - ロールID
戻り値:
すべてのサブロールIDの配列
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getCategories

public String[] getCategories(String groupId)
                       throws AccessSecurityReadException
カテゴリの一覧を取得する。

指定したログイングループに属するカテゴリが存在しない場合は空の配列を返却する。

パラメータ:
groupId - ログイングループID
戻り値:
カテゴリ名の配列
例外:
AccessSecurityReadException - カテゴリの取得に失敗した場合にスローされます。

getParentRoleIds

public String[] getParentRoleIds(String groupId,
                                 String roleId)
                          throws AccessSecurityReadException
親ロールの一覧を取得する。

引数に指定したロールの１階層上位にあるすべての親ロールを取得する。
親ロールが一件も存在しない場合空の配列を返却する。

パラメータ:
groupId - ログイングループID
roleId - ロールID
戻り値:
親ロールIDの配列
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getRoleData

public Role[] getRoleData(String groupId)
                   throws AccessSecurityReadException
ロール情報を全件取得する。

指定されたログイングループに属するロールが存在しない場合は空の配列を返却する。

パラメータ:
groupId - ログイングループID
戻り値:
ロール情報の配列
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getRoleData

public Role getRoleData(String groupId,
                        String roleId)
                 throws AccessSecurityReadException
ロール情報を取得する。

指定されたロールIDをもつロールが存在しない場合はnullを返す

パラメータ:
groupId - ログイングループID
roleId - ロールID
戻り値:
ロールデータ
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getRoleDataByCategory

public Role[] getRoleDataByCategory(String groupId,
                                    String category)
                             throws AccessSecurityReadException
カテゴリからロール情報を取得する。

指定されたカテゴリに属するロール情報を取得する
指定したカテゴリーに属するロールが存在しない場合は空の配列を返却する。

パラメータ:
groupId - ログイングループID
category - カテゴリ名
戻り値:
ロール情報の配列
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getRolesByIds

public Role[] getRolesByIds(String groupId,
                            String[] roleIds)
                     throws AccessSecurityReadException
指定されたロールIDのロール情報をすべて取得する。

パラメータ:
groupId - ログイングループID
roleIds - ロールIDの配列
戻り値:
ロールオブジェクトの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - ロール情報取得に失敗した場合スローされます。

init

public void init(Map params)
ロールアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

updateCategory

public void updateCategory(String groupId,
                           String oldCategory,
                           String newCategory)
                    throws AccessSecurityWriteException
カテゴリを更新する。

旧カテゴリ名を新カテゴリ名に更新する。

パラメータ:
groupId - ログイングループID
oldCategory - 旧カテゴリ名
newCategory - 新カテゴリ名
例外:
AccessSecurityWriteException - カテゴリの更新に失敗した場合にスローされます。

updateRole

public void updateRole(String groupId,
                       Role role)
                throws AccessSecurityWriteException
ロール情報を更新する。

パラメータ:
groupId - ログイングループID
role - ロール情報
例外:
AccessSecurityWriteException - ロール情報の更新に失敗した場合にスローされます。

insertSubRole

public void insertSubRole(String groupId,
                          String roleId,
                          String subRoleId)
                   throws AccessSecurityWriteException
サブロールを作成する。

パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 追加するサブロールID
例外:
AccessSecurityWriteException - ロール情報の更新に失敗した場合にスローされます。

deleteSubRole

public void deleteSubRole(String groupId,
                          String roleId,
                          String subRoleId)
                   throws AccessSecurityWriteException
サブロールIDサマリを削除する。

パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 削除するサブロールID
例外:
AccessSecurityWriteException - ロール情報の更新に失敗した場合にスローされます。

deleteSubRole

public void deleteSubRole(String groupId,
                          String roleId)
                   throws AccessSecurityWriteException
指定したロールのサブロールIDサマリを全削除する。

パラメータ:
groupId - ログイングループID
roleId - ロールID
例外:
AccessSecurityWriteException - ロール情報の更新に失敗した場合にスローされます。

getSubRoleIds

public String[] getSubRoleIds(String groupId,
                              String roleId)
                       throws AccessSecurityReadException
サブロールIDサマリを取得する。

パラメータ:
groupId - ログイングループID
roleId - ロールID
戻り値:
String[] サブロールID
例外:
AccessSecurityWriteException - ロール情報の更新に失敗した場合にスローされます。
AccessSecurityReadException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


RoleChangedListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
インタフェース RoleChangedListener

既知の実装クラスの一覧:
RoleChangedAccountListener, RoleChangedControllerListener, RoleChangedMenuListener
public interface RoleChangedListener

ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | init(Map params) ロールリスナーの初期化。
void | roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | roleDeleted(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | subRoleAdded(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | subRoleDeleted(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
ロールリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

roleAdded

public void roleAdded(String groupId,
                      Role role)
               throws ChangedListenerException
ロール情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
role - 作成されたロール
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

roleDeleted

public void roleDeleted(String groupId,
                        String roleId)
                 throws ChangedListenerException
ロール情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
roleId - 削除されたロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

roleUpdated

public void roleUpdated(String groupId,
                        Role role)
                 throws ChangedListenerException
ロール情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
role - 更新されたロール
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

subRoleAdded

public void subRoleAdded(String groupId,
                         String roleId,
                         String subRoleId)
                  throws ChangedListenerException
ロールにサブロールを追加した直後にコールされます。

パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 追加されたサブロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

subRoleDeleted

public void subRoleDeleted(String groupId,
                           String roleId,
                           String subRoleId)
                    throws ChangedListenerException
ロールからサブロールを削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 削除されたサブロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleExporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
インタフェース RoleExporter

既知の実装クラスの一覧:
StandardRoleBackup
public interface RoleExporter

ロールエクスポートインタフェースです。

バージョン:
1.0

メソッドの概要
void | doExport(RoleManager manager, OutputStream outputStream) エクスポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doExport

public void doExport(RoleManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

ロール情報をバックアップファイルに出力します。

パラメータ:
manager - ロールマネージャ
outputStream - 出力ストリーム
例外:
AccessSecurityExportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleImporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
インタフェース RoleImporter

既知の実装クラスの一覧:
StandardRoleBackup
public interface RoleImporter

ロールインポートインタフェースです。

バージョン:
1.0

メソッドの概要
void | doImport(InputStream inputStream, RoleManager manager) インポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doImport

public void doImport(InputStream inputStream,
                     RoleManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からロール情報を取得し、生成します。

パラメータ:
manager - ロールマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
クラス RoleManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.role.RoleManager
public class RoleManager
extends Object

ロールマネージャクラス。

ロール情報に関連する操作を行います。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
RoleManager(String gid)
コンストラクタ。
メソッドの概要
void | addRole(Role role) ロール情報を新規登録します。
void | addSubRole(String roleId, String subRoleId) サブロールIDを追加します。
boolean | certify(String[] users, String[] roles) ロール内包を認証します。
boolean | contains(String roleId) ロールの存在チェックを行います。
boolean | containsCategory(String category) カテゴリーの存在チェックをします。
int | count() ロール数を取得します。
int | countByCategory(String category) カテゴリーに属するロール数を取得します。
void | deleteCategories() すべてのカテゴリーを削除します。
void | deleteCategory(String category) カテゴリーを削除します。
void | deleteRole(String roleId) ロールを削除します。
void | deleteRoles() すべてのロールを削除します。
void | deleteSubRole(String roleId, String subRoleId) 指定したサブロールIDを削除します。
void | deleteSubRoles(String roleId) 全てのサブロールIDを削除します。
void | exportData(String category, OutputStream outputStream) ロール情報・エクスポート。
String[] | getAllParentRoleIds(String roleId) 全ての親ロールIDを取得します。
String[] | getAllSubRoleIds(String roleId) 全てのサブロールサマリを取得します。
String[] | getCategories() カテゴリーの一覧を取得します。
String[] | getExportCategories() ロールエクスポート用のカテゴリの一覧を取得します。
String[] | getImportCategories() ロールインポート用のカテゴリの一覧を取得します。
String | getLoginGroupId() ログイングループIDを取得します。
String[] | getParentRoleIds(String roleId) 親ロールIDを取得します。
Role | getRole(String roleId) ロール情報を取得します。
String[] | getRoleIds() すべてのロールIDを取得します。
Role[] | getRoles() すべてのロール情報を取得します。
Role[] | getRolesByCategory(String category) カテゴリー検索によりロールを取得します。
Role[] | getRolesByIds(String[] roleIds) ログイングループ内で引数指定したロールIDのロール情報をすべて取得します。
String[] | getSubRole(String roleId) サブロール(一階層のみ)を取得します。
void | importData(String category, InputStream inputStream) ロール情報・インポート。
boolean | isUpdate(Date date) ロール情報が指定された日付よりも新しいかチェックします。
void | moveCategory(String oldCategory, String newCategory) カテゴリーを更新します。
Role[] | searchRolesById(String key) ロールID検索によりロールを取得します。
Role[] | searchRolesByName(String name) ロール名称検索によりロールを取得します。
void | updateRole(Role role) ロール情報を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RoleManager

public RoleManager(String gid)
            throws AccessSecurityException
コンストラクタ。

パラメータ:
gid - ログイングループID
例外:
AccessSecurityException - 指定のログイングループIDが不正の場合にスローされます。
メソッドの詳細

addRole

public void addRole(Role role)
             throws AccessSecurityException
ロール情報を新規登録します。

ロール情報をデータソースに新規登録します。

パラメータ:
role - ロール情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

addSubRole

public void addSubRole(String roleId,
                       String subRoleId)
                throws AccessSecurityException
サブロールIDを追加します。

パラメータ:
roleId - ロールID
subRoleId - サブロールID
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

certify

public boolean certify(String[] users,
                       String[] roles)
                throws AccessSecurityException
ロール内包を認証します。

第1引数で指定されたロール配列と第2引数で指定されたロールの配列で同一のものがあるかをチェックします。
第1引数のロールのみ、ネストしたロールも含めてチェックします。

パラメータ:
users - ロールIDの配列
roles - ロールIDの配列
戻り値:
同じロールがある場合:true ない場合:false
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

contains

public boolean contains(String roleId)
                 throws AccessSecurityException
ロールの存在チェックを行います。

指定のロールが存在するかをチェックします。

パラメータ:
roleId - ロールID
戻り値:
true: 指定のロールが存在します。
false: 指定のロールが存在しません。
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

containsCategory

public boolean containsCategory(String category)
                         throws AccessSecurityException
カテゴリーの存在チェックをします。

指定のカテゴリーが該当するログイングループ内で登録されているかをチェックします。

パラメータ:
category - カテゴリー
戻り値:
true:登録済み false:未登録
例外:
AccessSecurityException - 引数が不正だった場合にスローされます。

count

public int count()
          throws AccessSecurityReadException
ロール数を取得します。

ログイングループ内のロール数を取得します。

戻り値:
ロール数
例外:
AccessSecurityReadException - 読み込み処理に失敗した場合にスローされます。

countByCategory

public int countByCategory(String category)
                    throws AccessSecurityException
カテゴリーに属するロール数を取得します。

ログイングループ内の指定カテゴリーに属するロールの数を取得します。

戻り値:
ロール数
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteCategories

public void deleteCategories()
                      throws AccessSecurityException
すべてのカテゴリーを削除します。

ログイングループに属するカテゴリーを全件削除します

例外:
AccessSecurityException - 更新処理に失敗した場合にスローされます。

deleteCategory

public void deleteCategory(String category)
                    throws AccessSecurityException
カテゴリーを削除します。

ログイングループ内のカテゴリーを削除します。

パラメータ:
category - カテゴリー
例外:
AccessSecurityReadException - 読み込み処理、または書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。
AccessSecurityException

deleteRole

public void deleteRole(String roleId)
                throws AccessSecurityException
ロールを削除します。

指定のロール情報を削除します。

パラメータ:
roleId - ロールID
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteRoles

public void deleteRoles()
                 throws AccessSecurityException
すべてのロールを削除します。

すべてのロール情報を削除します 。

例外:
AccessSecurityException - 書き込み処理、または読み込み処理に失敗した場合にスローされます。

deleteSubRole

public void deleteSubRole(String roleId,
                          String subRoleId)
                   throws AccessSecurityException
指定したサブロールIDを削除します。

パラメータ:
roleId - ロールID
subRoleId - サブロールID
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteSubRoles

public void deleteSubRoles(String roleId)
                    throws AccessSecurityException
全てのサブロールIDを削除します。

パラメータ:
roleId -
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

exportData

public void exportData(String category,
                       OutputStream outputStream)
                throws AccessSecurityException
ロール情報・エクスポート。

パラメータ:
category - カテゴリ
outputStream - 出力ストリーム
例外:
AccessSecurityException - エクスポートに失敗した場合、または引数が不正だった場合にスローされます。

getAllParentRoleIds

public String[] getAllParentRoleIds(String roleId)
                             throws AccessSecurityException
全ての親ロールIDを取得します。

指定したロールに属する親ロールのロールIDをすべて取得します。
ネストした親ロールについても全て取得します。
存在しない場合は空の文字列を返却します。

パラメータ:
roleId - ロールID
戻り値:
親ロールのロールID配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getAllSubRoleIds

public String[] getAllSubRoleIds(String roleId)
                          throws AccessSecurityException
全てのサブロールサマリを取得します。

パラメータ:
roleId - ロールID
戻り値:
サブロールIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getCategories

public String[] getCategories()
                       throws AccessSecurityReadException
カテゴリーの一覧を取得します。

ログイングループに属するカテゴリーの一覧を取得します。

戻り値:
カテゴリー一覧
例外:
AccessSecurityReadException - 読み込み処理に失敗した場合にスローされます。

getExportCategories

public String[] getExportCategories()
                             throws AccessSecurityException
ロールエクスポート用のカテゴリの一覧を取得します。

戻り値:
ロールエクスポート用カテゴリの一覧
例外:
AccessSecurityException - ロールエクスポート用のカテゴリの取得に失敗した場合にスローされます。

getImportCategories

public String[] getImportCategories()
                             throws AccessSecurityException
ロールインポート用のカテゴリの一覧を取得します。

戻り値:
ロールインポート用カテゴリの一覧
例外:
AccessSecurityException - ロールインポート用のカテゴリの取得に失敗した場合にスローされます。

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

戻り値:
ログイングループID

getParentRoleIds

public String[] getParentRoleIds(String roleId)
                          throws AccessSecurityException
親ロールIDを取得します。

指定のロールの一階層上のロールを取得します。
存在しない場合は空の配列を返却します。

パラメータ:
roleId - ロールID
戻り値:
親ロールIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getRole

public Role getRole(String roleId)
             throws AccessSecurityException
ロール情報を取得します。

指定されたロールの情報を取得します。
存在しない場合はnullを返却します。

パラメータ:
roleId - ロールID
戻り値:
ロール情報
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getRoleIds

public String[] getRoleIds()
                    throws AccessSecurityReadException
すべてのロールIDを取得します。

ログイングループ内で登録されている全てのロールのIDを取得します。
存在しない場合は空の配列を返却します。

戻り値:
ロールIDの配列
例外:
AccessSecurityReadException - 読み込み処理に失敗した場合にスローされます。

getRoles

public Role[] getRoles()
                throws AccessSecurityReadException
すべてのロール情報を取得します。

ログイングループ内のロール情報を全て取得します。

戻り値:
ロール情報の配列(存在しない場合は空のモデルを返却します。)
例外:
AccessSecurityReadException - 読み込み処理に失敗した場合にスローされます。

getRolesByCategory

public Role[] getRolesByCategory(String category)
                          throws AccessSecurityException
カテゴリー検索によりロールを取得します。

指定したカテゴリーに属するロール情報を全て取得します。

パラメータ:
category - カテゴリー
戻り値:
ロールの配列(検索にヒットしない場合は空のロール)
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getRolesByIds

public Role[] getRolesByIds(String[] roleIds)
                     throws AccessSecurityException
ログイングループ内で引数指定したロールIDのロール情報をすべて取得します。

パラメータ:
roleIds - ロールIDの配列
戻り値:
ロール情報の配列（データがない場合は空の配列を返します。）
例外:
AccessSecurityException - ロール情報の取得に失敗した場合にスローされます。

getSubRole

public String[] getSubRole(String roleId)
                    throws AccessSecurityException
サブロール(一階層のみ)を取得します。

パラメータ:
roleId -
戻り値:
ロールの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

importData

public void importData(String category,
                       InputStream inputStream)
                throws AccessSecurityException
ロール情報・インポート。

パラメータ:
category - カテゴリ
inputStream - 入力ストリーム
例外:
AccessSecurityException - インポートに失敗した場合、または引数が不正だった場合にスローされます。

moveCategory

public void moveCategory(String oldCategory,
                         String newCategory)
                  throws AccessSecurityException
カテゴリーを更新します。

ログイングループ内のカテゴリーを更新します。

パラメータ:
oldCategory - 旧カテゴリー
newCategory - 新カテゴリー
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

searchRolesById

public Role[] searchRolesById(String key)
                       throws AccessSecurityException
ロールID検索によりロールを取得します。

引数に類似(前方後方一致)するロールIDを持つロール情報を全て取得します。

パラメータ:
key - 検索ロールID
戻り値:
ロールの配列(検索にヒットしない場合は空のロール)
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

searchRolesByName

public Role[] searchRolesByName(String name)
                         throws AccessSecurityException
ロール名称検索によりロールを取得します。

引数に類似(前方後方一致)する名称を持つロール情報を全て取得します。

パラメータ:
name - 検索ロール名称
戻り値:
ロールの配列(検索にヒットしない場合は空の配列)
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

updateRole

public void updateRole(Role role)
                throws AccessSecurityException
ロール情報を更新します。

データソース上の指定のロール情報を更新します。

パラメータ:
role - ロール情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

isUpdate

public boolean isUpdate(Date date)
                 throws AccessSecurityException
ロール情報が指定された日付よりも新しいかチェックします。

パラメータ:
date - チェック日付
例外:
AccessSecurityReadException - 更新チェックに失敗した場合スローされます。
AccessSecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RolePostWriterListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
インタフェース RolePostWriterListener

public interface RolePostWriterListener

ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | init(Map params) ロールリスナーの初期化。
void | postCreateRole(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | postCreateSubRole(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | postDeleteRole(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | postDeleteSubRole(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。
void | postUpdateRole(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
ロールリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreateRole

public void postCreateRole(String groupId,
                           Role role)
                    throws AccessSecurityListenerExcpetion
ロール情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
role - 作成されたロール
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteRole

public void postDeleteRole(String groupId,
                           String roleId)
                    throws AccessSecurityListenerExcpetion
ロール情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
roleId - 削除されたロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateRole

public void postUpdateRole(String groupId,
                           Role role)
                    throws AccessSecurityListenerExcpetion
ロール情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
role - 更新されたロール
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postCreateSubRole

public void postCreateSubRole(String groupId,
                              String roleId,
                              String subRoleId)
                       throws AccessSecurityListenerExcpetion
ロールにサブロールを追加した直後にコールされます。

パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 追加されたサブロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteSubRole

public void postDeleteSubRole(String groupId,
                              String roleId,
                              String subRoleId)
                       throws AccessSecurityListenerExcpetion
ロールからサブロールを削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 削除されたサブロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleQueryWriterListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
インタフェース RoleQueryWriterListener

public interface RoleQueryWriterListener

ロール情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | init(Map params) ロールリスナーの初期化。
void | postCreateSubRole(String groupId, String roleId, String subRoleId) ロールにサブロールを追加する直前にコールされます。
void | postDeleteSubRole(String groupId, String roleId, String subRoleId) ロールからサブロールを削除する直前にコールされます。
void | queryCreateRole(String groupId, Role role) ロール情報をデータストアに作成する直前にコールされます。
void | queryDeleteRole(String groupId, String roleId) ロール情報をデータストアから削除する直前にコールされます。
void | queryUpdateRole(String groupId, Role role) ロール情報をデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
ロールリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreateRole

public void queryCreateRole(String groupId,
                            Role role)
                     throws AccessSecurityListenerExcpetion
ロール情報をデータストアに作成する直前にコールされます。

パラメータ:
groupId - ログイングループID
role - 作成されるロール
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteRole

public void queryDeleteRole(String groupId,
                            String roleId)
                     throws AccessSecurityListenerExcpetion
ロール情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
roleId - 削除されるロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdateRole

public void queryUpdateRole(String groupId,
                            Role role)
                     throws AccessSecurityListenerExcpetion
ロール情報をデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
role - 更新されるロール
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postCreateSubRole

public void postCreateSubRole(String groupId,
                              String roleId,
                              String subRoleId)
                       throws AccessSecurityListenerExcpetion
ロールにサブロールを追加する直前にコールされます。

パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 追加されるサブロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteSubRole

public void postDeleteSubRole(String groupId,
                              String roleId,
                              String subRoleId)
                       throws AccessSecurityListenerExcpetion
ロールからサブロールを削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 削除されるサブロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleReaderDecorator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
インタフェース RoleReaderDecorator

public interface RoleReaderDecorator

ロール情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
Role | doDecoration(String groupId, Role role) ロール情報をデータストアから読み込んだ直後にコールされます。
void | init(Map params) ロールデコレータの初期化。

メソッドの詳細

doDecoration

public Role doDecoration(String groupId,
                         Role role)
ロール情報をデータストアから読み込んだ直後にコールされます。

パラメータ:
groupId - ログイングループID
role - 読み込みが行われたロール情報
戻り値:
拡張されたロール情報

init

public void init(Map params)
ロールデコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


StandardRoleBackup (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
クラス StandardRoleBackup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.role.StandardRoleBackup
すべての実装インタフェース:
RoleExporter, RoleImporter
public class StandardRoleBackup
extends Object
implements RoleImporter, RoleExporter

ロールバックアップクラスです。

バージョン:
1.0

フィールドの概要
static String KIND_ROLE
種別 ロール。
コンストラクタの概要
StandardRoleBackup()
メソッドの概要
void | doExport(RoleManager manager, OutputStream outputStream) エクスポートを行います。
void | doImport(InputStream inputStream, RoleManager manager) インポートを行います。
void | init(Map params) 初期化。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KIND_ROLE

public static final String KIND_ROLE
種別 ロール。

関連項目:
定数フィールド値
コンストラクタの詳細

StandardRoleBackup

public StandardRoleBackup()
メソッドの詳細

init

public void init(Map params)
初期化。

初期化する。

定義:
インタフェース RoleImporter 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     RoleManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からロール情報を生成します。

定義:
インタフェース RoleImporter 内の doImport
パラメータ:
manager - ロールマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

doExport

public void doExport(RoleManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

ロールバックアップ情報を生成し、ストリームに返却します。

定義:
インタフェース RoleExporter 内の doExport
パラメータ:
manager - ロールマネージャクラス
outputStream - 出力ストリーム
例外:
AccessSecurityExportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet の使用

jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.servlet.LogoutInitialUrlValidator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.servlet.LogoutInitialUrlValidator の使用

jp.co.intra_mart.foundation.security.servlet.LogoutInitialUrlValidator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.servlet.LogoutServlet の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.servlet.LogoutServlet の使用

jp.co.intra_mart.foundation.security.servlet.LogoutServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.servlet.MenuServlet の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.servlet.MenuServlet の使用

jp.co.intra_mart.foundation.security.servlet.MenuServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet の使用

jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet の使用

jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.servlet.UserInitialServlet の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.servlet.UserInitialServlet の使用

jp.co.intra_mart.foundation.security.servlet.UserInitialServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


GroupSuperUserInitialServlet (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.servlet
クラス GroupSuperUserInitialServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
public class GroupSuperUserInitialServlet
extends HttpServlet

グループ管理者初期アクセスサーブレット。

システム管理者での初期アクセスを処理するサーブレット。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
GroupSuperUserInitialServlet()
メソッドの概要
void | destroy() サーブレットの放棄を行います。
protected void | doGet(HttpServletRequest request, HttpServletResponse response) GETメソッドに対するサービスを行います。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) POSTメソッドに対するサービスを行います。
void | init() サーブレットの初期化を行います。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GroupSuperUserInitialServlet

public GroupSuperUserInitialServlet()
メソッドの詳細

destroy

public void destroy()
サーブレットの放棄を行います。

導入されたバージョン:
5.0
関連項目:
Servlet.destroy()

init

public void init()
          throws ServletException
サーブレットの初期化を行います。

例外:
ServletException
導入されたバージョン:
5.0
関連項目:
GenericServlet.init()

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
GETメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doGet(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
POSTメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doPost(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LogoutInitialUrlValidator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.servlet
インタフェース LogoutInitialUrlValidator

public interface LogoutInitialUrlValidator

ログアウト後に遷移するURL検証インタフェース ログアウト後に遷移するURLを検証するためのインタフェースです。

導入されたバージョン:
6.0.9

メソッドの概要
 String validation(String initialUrl)
ログアウト後に遷移しようとするURLを検証します。

メソッドの詳細

validation

public String validation(String initialUrl)
ログアウト後に遷移しようとするURLを検証します。

検証後、遷移したいURLを返します。
nullまたは空文字列を返却した場合、ログアウトサーブレットは、レスポンスコード(204)を返却します。

パラメータ:
initialUrl - ログアウト後に遷移しようとするURL
戻り値:
検証後の遷移先のURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LogoutServlet (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.servlet
クラス LogoutServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.foundation.security.servlet.LogoutServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
public class LogoutServlet
extends HttpServlet

ログアウトサーブレット。

ログアウトの処理を行うサーブレット。

ログアウト処理を行った後、指定のURLに遷移します。
遷移先ページの決定順位は以下の通りです。

1．サーブレットの引数パラメータ(im_initial_url)に指定したURL
2．セッションに保管されている初期URL
3．クッキーに保管されている初期URL
この後、サーブレット初期化パラメータ(validator-class)に検証用実装クラスが
設定されている場合は、このクラスを用いて、URLの検証を行います。
なお、検証用実装クラスは、LogoutInitialUrlValidatorを実装している必要があります。

URLがnullの場合、および空文字列の場合は、レスポンスコード(204)を返却します。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
LogoutServlet()
メソッドの概要
void | destroy() サーブレットの放棄を行います。
protected void | doGet(HttpServletRequest request, HttpServletResponse response) GETメソッドに対するサービスを行います。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) POSTメソッドに対するサービスを行います。
void | init() サーブレットの初期化を行います。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LogoutServlet

public LogoutServlet()
メソッドの詳細

destroy

public void destroy()
サーブレットの放棄を行います。

関連項目:
Servlet.destroy()

init

public void init()
          throws ServletException
サーブレットの初期化を行います。

例外:
ServletException - サーブレットでエラーが発生した場合スローします。
関連項目:
GenericServlet.init()

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
GETメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doGet(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
POSTメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doPost(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuServlet (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.servlet
クラス MenuServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.foundation.security.servlet.MenuServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
public class MenuServlet
extends HttpServlet

メニュー連携サーブレットクラス。

メニューIDから画面に遷移を行うサーブレットです。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
MenuServlet()
コンストラクタ。
メソッドの概要
protected void | doGet(HttpServletRequest request, HttpServletResponse response) GETメソッドです。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) POSTメソッドです。
void | init() メニューサーブレットの初期化を行います。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
destroy, getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MenuServlet

public MenuServlet()
コンストラクタ。

メソッドの詳細

init

public void init()
          throws ServletException
メニューサーブレットの初期化を行います。

例外:
ServletException
関連項目:
Servlet.init(javax.servlet.ServletConfig)

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
POSTメソッドです。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
例外:
ServletException
IOException
関連項目:
HttpServlet.doPost(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
GETメソッドです。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
例外:
ServletException
IOException
関連項目:
HttpServlet.doPost(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.servlet (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.security.servlet
インタフェース
LogoutInitialUrlValidator
クラス
GroupSuperUserInitialServlet
LogoutServlet
MenuServlet
SuperUserInitialServlet
UserCertificationServlet
UserInitialServlet


jp.co.intra_mart.foundation.security.servlet (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.servlet

サーブレットに関連するクラスを提供します。

参照:
説明

インタフェースの概要
LogoutInitialUrlValidator ログアウト後に遷移するURL検証インタフェース ログアウト後に遷移するURLを検証するためのインタフェースです。

クラスの概要
GroupSuperUserInitialServlet | グループ管理者初期アクセスサーブレット。
LogoutServlet | ログアウトサーブレット。
MenuServlet | メニュー連携サーブレットクラス。
SuperUserInitialServlet | システム管理者初期アクセスサーブレット。
UserCertificationServlet | ユーザ認証サーブレット。
UserInitialServlet | ユーザ初期アクセスサーブレット。

パッケージ jp.co.intra_mart.foundation.security.servlet の説明

サーブレットに関連するクラスを提供します。


jp.co.intra_mart.foundation.security.servlet クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.servlet の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • class javax.servlet.http.HttpServlet (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet
        • class jp.co.intra_mart.foundation.security.servlet.LogoutServlet
        • class jp.co.intra_mart.foundation.security.servlet.MenuServlet
        • class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet
        • class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet
        • class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.servlet.LogoutInitialUrlValidator


パッケージ jp.co.intra_mart.foundation.security.servlet の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.servlet の使用

jp.co.intra_mart.foundation.security.servlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SuperUserInitialServlet (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.servlet
クラス SuperUserInitialServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
public class SuperUserInitialServlet
extends HttpServlet

システム管理者初期アクセスサーブレット。

システム管理者での初期アクセスを処理するサーブレット。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SuperUserInitialServlet()
メソッドの概要
void | destroy() サーブレットの放棄を行います。
protected void | doGet(HttpServletRequest request, HttpServletResponse response) GETメソッドに対するサービスを行います。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) POSTメソッドに対するサービスを行います。
void | init() サーブレットの初期化を行います。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SuperUserInitialServlet

public SuperUserInitialServlet()
メソッドの詳細

destroy

public void destroy()
サーブレットの放棄を行います。

導入されたバージョン:
5.0
関連項目:
Servlet.destroy()

init

public void init()
          throws ServletException
サーブレットの初期化を行います。

例外:
ServletException - サーブレットでエラーが発生した場合スローします。
導入されたバージョン:
5.0
関連項目:
GenericServlet.init()

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
GETメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doGet(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
POSTメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doPost(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserCertificationServlet (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.servlet
クラス UserCertificationServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
public class UserCertificationServlet
extends HttpServlet

ユーザ認証サーブレット。

ユーザでの認証アクセスを処理するサーブレット。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
UserCertificationServlet()
メソッドの概要
void | destroy() サーブレットの放棄を行います。
protected void | doGet(HttpServletRequest request, HttpServletResponse response) GETメソッドに対するサービスを行います。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) POSTメソッドに対するサービスを行います。
void | init() サーブレットの初期化を行います。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserCertificationServlet

public UserCertificationServlet()
メソッドの詳細

destroy

public void destroy()
サーブレットの放棄を行います。

導入されたバージョン:
5.0
関連項目:
Servlet.destroy()

init

public void init()
          throws ServletException
サーブレットの初期化を行います。

例外:
ServletException - サーブレットでエラーが発生した場合スローします。
導入されたバージョン:
5.0
関連項目:
GenericServlet.init()

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
GETメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doGet(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
POSTメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doPost(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserInitialServlet (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.servlet
クラス UserInitialServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.foundation.security.servlet.UserInitialServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
public class UserInitialServlet
extends HttpServlet

ユーザ初期アクセスサーブレット。

ユーザでの初期アクセスを処理するサーブレット。

利用するクライアントタイプ別にサーブレットおよびサーブレットマッピングを定義します。(web.xml)
サーブレットを定義する場合に必以下の初期化パラメータが必要です。

パラメータ名 | 説明
client-type | このサーブレットが処理するクライアントタイプです。
group-regexp | URLからログイングループIDを抜き出すための正規表現です。 正規表現の()内にマッチしたものをログイングループIDと見なします。 省略した場合のデフォルトは(.+)\.です。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
UserInitialServlet()
メソッドの概要
void | destroy() サーブレットの放棄を行います。
protected void | doGet(HttpServletRequest request, HttpServletResponse response) GETメソッドに対するサービスを行います。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) POSTメソッドに対するサービスを行います。
void | init() サーブレットの初期化を行います。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserInitialServlet

public UserInitialServlet()
メソッドの詳細

destroy

public void destroy()
サーブレットの放棄を行います。

導入されたバージョン:
5.0
関連項目:
Servlet.destroy()

init

public void init()
          throws ServletException
サーブレットの初期化を行います。

例外:
ServletException - サーブレットでエラーが発生した場合スローします。
導入されたバージョン:
5.0
関連項目:
GenericServlet.init()

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
GETメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doGet(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
POSTメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doPost(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor の使用

ShortCutAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.security.shortcut

jp.co.intra_mart.foundation.security.shortcut での ShortCutAccessor の使用

ShortCutAccessor を実装している jp.co.intra_mart.foundation.security.shortcut のクラス
 class StandardShortCutAccessor
ショートカットアクセッサクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo の使用

ShortCutInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security.shortcut

jp.co.intra_mart.foundation.security.shortcut での ShortCutInfo の使用

ShortCutInfo を返す jp.co.intra_mart.foundation.security.shortcut のメソッド
ShortCutInfo | ShortCutManager.getShortCutInfo(String shortCutId) ショートカット情報取得。
ShortCutInfo | ShortCutAccessor.getShortCutInfo(String groupId, String shortCutId) ショートカット情報を取得します。
ShortCutInfo | StandardShortCutAccessor.getShortCutInfo(String groupId, String shortCutId) ショートカット情報を取得します。

ShortCutInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.shortcut のメソッド
String | ShortCutManager.createShortCut(ShortCutInfo shortCutInfo) ショートカットＩＤ作成。
String | ShortCutAccessor.createShortCut(String groupId, ShortCutInfo shortCutInfo) ショートカットIDを作成します。
String | StandardShortCutAccessor.createShortCut(String groupId, ShortCutInfo shortCutInfo) ショートカットIDを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.shortcut.ShortCutManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.shortcut.ShortCutManager の使用

jp.co.intra_mart.foundation.security.shortcut.ShortCutManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor の使用

jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.security.shortcut (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.security.shortcut
インタフェース
ShortCutAccessor
クラス
ShortCutInfo
ShortCutManager
StandardShortCutAccessor


jp.co.intra_mart.foundation.security.shortcut (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.shortcut

インタフェースの概要
ShortCutAccessor ショートカットアクセッサインタフェース。

クラスの概要
ShortCutInfo | ショートカット情報クラス。
ShortCutManager | ショートカットマネージャクラス ServerManager/conf/short-cut-config.xmlからショートカット情報に関するパラメータを取得します。
StandardShortCutAccessor | ショートカットアクセッサクラス。


jp.co.intra_mart.foundation.security.shortcut クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.shortcut の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.shortcut.ShortCutManager
    • class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor (implements jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor


パッケージ jp.co.intra_mart.foundation.security.shortcut の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.shortcut の使用

jp.co.intra_mart.foundation.security.shortcut を使用しているパッケージ
jp.co.intra_mart.foundation.security.shortcut

jp.co.intra_mart.foundation.security.shortcut により使用される jp.co.intra_mart.foundation.security.shortcut のクラス
ShortCutAccessor
ショートカットアクセッサインタフェース。
ShortCutInfo
ショートカット情報クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ShortCutAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.shortcut
インタフェース ShortCutAccessor

既知の実装クラスの一覧:
StandardShortCutAccessor
public interface ShortCutAccessor

ショートカットアクセッサインタフェース。

ショートカット情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
Date | addValidEndDate(int countDays) SYSTEM日付に指定した日数を加えた日付を取得します。
String | createShortCut(String groupId, ShortCutInfo shortCutInfo) ショートカットIDを作成します。
void | deleteShortCut(String groupId, String shortCutId) ショートカットIDを削除します。
String | getErrorPage(String groupId) エラーページのパスを取得します。
String | getMainPage(String groupId) ショートカット表示用のパスを取得します。
ShortCutInfo | getShortCutInfo(String groupId, String shortCutId) ショートカット情報を取得します。
void | init(Node node) ショートカットアクセッサを初期化します。
int | verifyShortCut(String groupId, Date verifyDate) ショートカットIDを検証します。

メソッドの詳細

init

public void init(Node node)
ショートカットアクセッサを初期化します。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
node - 初期化パラメータのDOM

createShortCut

public String createShortCut(String groupId,
                             ShortCutInfo shortCutInfo)
                      throws AccessSecurityException
ショートカットIDを作成します。

パラメータ:
groupId - ログイングループID
shortCutInfo - ショートカット情報
戻り値:
ショートカットID
例外:
ショートカット情報の登録に失敗した場合、スローされます。
AccessSecurityException

deleteShortCut

public void deleteShortCut(String groupId,
                           String shortCutId)
                    throws AccessSecurityException
ショートカットIDを削除します。

パラメータ:
groupId - ログイングループID
shortCutId - ショートカットID
例外:
ショートカット情報の削除に失敗した場合、スローされます。
AccessSecurityException

verifyShortCut

public int verifyShortCut(String groupId,
                          Date verifyDate)
                   throws AccessSecurityException
ショートカットIDを検証します。

パラメータ:
groupId - ログイングループID
verifyDate - 検証日付
戻り値:
削除件数
例外:
過去のショートカット情報の削除に失敗した場合、スローされます。
AccessSecurityException

getShortCutInfo

public ShortCutInfo getShortCutInfo(String groupId,
                                    String shortCutId)
                             throws AccessSecurityException
ショートカット情報を取得します。

パラメータ:
groupId - ログイングループID
shortCutId - ショートカットID
戻り値:
ショートカット情報(取得できなかった場合、NULLを返却)
例外:
ショートカット情報の取得に失敗した場合、スローされます。
AccessSecurityException

getErrorPage

public String getErrorPage(String groupId)
エラーページのパスを取得します。

パラメータ:
groupId - ログイングループID
戻り値:
エラーページパス

getMainPage

public String getMainPage(String groupId)
ショートカット表示用のパスを取得します。

パラメータ:
groupId - ログイングループID
戻り値:
メインページパス

addValidEndDate

public Date addValidEndDate(int countDays)
                     throws AccessSecurityException
SYSTEM日付に指定した日数を加えた日付を取得します。

パラメータ:
countDays - 指定日数
戻り値:
SYSTEM日付に指定した日数を加えた日付
例外:
日付の取得に失敗した場合、スローされます。
AccessSecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ShortCutInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.shortcut
クラス ShortCutInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo
すべての実装インタフェース:
Serializable
public class ShortCutInfo
extends Object
implements Serializable

ショートカット情報クラス。

ショートカット情報を保管するクラスです。
ショートカット機能のユーザ判定、ログイン判定情報として利用します。

導入されたバージョン:
6.1
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ShortCutInfo()
メソッドの概要
String[] | getAllowsUsers() 許可ユーザを取得します。
String | getUrl() ＵＲＬを取得します。
String | getUrlParam(String key) ＵＲＬ引数(Map)の値を取得します。
String[] | getUrlParamKeys() ＵＲＬ引数(MAP)のキーの一覧を取得します。
Date | getValidEndDate() 有効終了日を取得します。
boolean | isAuth() 認証フラグを取得します。
void | removeUrlParam(String key) ＵＲＬ引数(Map)を削除します。
void | setAllowsUsers(String[] allowsUsers) 許可ユーザを設定します。
void | setIsAuth(boolean isAuth) 認証フラグを設定します。
void | setUrl(String url) ＵＲＬを設定します。
void | setUrlParam(String key, String value) ＵＲＬ引数(MAP)をセットする。
void | setValidEndDate(Date validEndDate) 有効終了日を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ShortCutInfo

public ShortCutInfo()
メソッドの詳細

getUrl

public String getUrl()
ＵＲＬを取得します。

戻り値:
url ＵＲＬ

getUrlParamKeys

public String[] getUrlParamKeys()
ＵＲＬ引数(MAP)のキーの一覧を取得します。

戻り値:
urlParams Mapのキーの一覧

setUrlParam

public void setUrlParam(String key,
                        String value)
ＵＲＬ引数(MAP)をセットする。

パラメータ:
key - Mapのキー
value - Mapの値

getUrlParam

public String getUrlParam(String key)
ＵＲＬ引数(Map)の値を取得します。

パラメータ:
key - Mapのキー
戻り値:
this.urlParams.get(key) Mapの値

removeUrlParam

public void removeUrlParam(String key)
ＵＲＬ引数(Map)を削除します。

パラメータ:
key - Mapのキー

getAllowsUsers

public String[] getAllowsUsers()
許可ユーザを取得します。

戻り値:
allowsUsers 許可ユーザ

isAuth

public boolean isAuth()
認証フラグを取得します。

戻り値:
isAuth 認証フラグ

getValidEndDate

public Date getValidEndDate()
有効終了日を取得します。

戻り値:
validEndDate 有効終了日

setUrl

public void setUrl(String url)
ＵＲＬを設定します。

パラメータ:
url - ＵＲＬ

setAllowsUsers

public void setAllowsUsers(String[] allowsUsers)
許可ユーザを設定します。

パラメータ:
allowsUsers - 許可ユーザ

setIsAuth

public void setIsAuth(boolean isAuth)
認証フラグを設定します。

パラメータ:
isAuth - 認証フラグ

setValidEndDate

public void setValidEndDate(Date validEndDate)
有効終了日を設定します。

設定できる最大日付は9999/12/31です。
nullを指定した場合は、SYSTEM日付が設定されます。

パラメータ:
validEndDate - 有効終了日
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ShortCutManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.shortcut
クラス ShortCutManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.shortcut.ShortCutManager
public class ShortCutManager
extends Object

ショートカットマネージャクラス

ServerManager/conf/short-cut-config.xmlからショートカット情報に関するパラメータを取得します。

以下はshort-cut-config.xmlのタグの説明です。

<short-cut-config>
  <short-cut-accessor>
     <short-cut-accessor-class>ShortCutAccessor</short-cut-accessor-class>
     <error-page>error.jssp</error-page>
     <main-page>main.jssp</main-page>
  <short-cut-accessor>
<short-cut-config>

その他のタグに関してはこちらを参照してください。StandardShortCutAccessor

タグ名 | 説明 | デフォルト値
accessor-class | ショートカットのデフォルトパラメータ | jp.co.intra_mart.foundation. security.shortcut. StandardShortCutAccessor

コンストラクタの概要
ShortCutManager(String groupId)
メソッドの概要
Date | addValidEndDate(int countDays) SYSTEM日付に指定した日数を加えた日付を取得します。
static void | clearInstance()
String | createShortCut(ShortCutInfo shortCutInfo) ショートカットＩＤ作成。
void | deleteShortCut(String shortCutId) ショートカットＩＤ削除。
String | getErrorPage() ショートカットエラーページ取得。
String | getMainPage() ショートカットメインページ取得。
ShortCutInfo | getShortCutInfo(String shortCutId) ショートカット情報取得。
int | verifyShortCut(Date verifyDate) ショートカット検証。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ShortCutManager

public ShortCutManager(String groupId)
メソッドの詳細

clearInstance

public static void clearInstance()

createShortCut

public String createShortCut(ShortCutInfo shortCutInfo)
                      throws AccessSecurityException
ショートカットＩＤ作成。

ショートカット情報を元に固有のＩＤをキーとしてショートカット情報を登録し、そのＩＤを返却します。

パラメータ:
shortCutInfo - ショートカット情報
戻り値:
shortCutId ショートカットＩＤ
例外:
AccessSecurityException - ショートカット情報の登録に失敗した場合にスローされます。

deleteShortCut

public void deleteShortCut(String shortCutId)
                    throws AccessSecurityException
ショートカットＩＤ削除。

ショートカットＩＤを削除します。

パラメータ:
shortCutId - ショートカットＩＤ
例外:
AccessSecurityException - ショートカット情報の削除に失敗した場合にスローされます。

verifyShortCut

public int verifyShortCut(Date verifyDate)
                   throws AccessSecurityException
ショートカット検証。

指定された日付において無効なショートカットＩＤを削除します。

パラメータ:
verifyDate - 検証日付
戻り値:
削除件数
例外:
AccessSecurityException - ショートカット情報の削除に失敗した場合にスローされます。

getShortCutInfo

public ShortCutInfo getShortCutInfo(String shortCutId)
                             throws AccessSecurityException
ショートカット情報取得。

指定されたショートカットＩＤからショートカット情報を取得します。

パラメータ:
shortCutId - ショートカットＩＤ
戻り値:
ショートカット情報
例外:
AccessSecurityException - ショートカット検証、またはショートカット情報の取得に失敗した場合にスローされます。

getErrorPage

public String getErrorPage()
                    throws AccessSecurityException
ショートカットエラーページ取得。

ショートカットが表示できない場合のエラーページパス

戻り値:
エラーページパス
例外:
AccessSecurityException - ショートカットエラーページ取得に失敗した場合にスローされます。

getMainPage

public String getMainPage()
                   throws AccessSecurityException
ショートカットメインページ取得。

ショートカット表示用のメインページパス

戻り値:
メインページパス
例外:
AccessSecurityException - ショートカットメインページ取得に失敗した場合にスローされます。

addValidEndDate

public Date addValidEndDate(int countDays)
                     throws AccessSecurityException
SYSTEM日付に指定した日数を加えた日付を取得します。

指定日数を加算した日付

パラメータ:
countDays - 指定日数
戻り値:
SYSTEM日付に指定した日数を加えた日付
例外:
日付の取得に失敗した場合、スローされます。
AccessSecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardShortCutAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.shortcut
クラス StandardShortCutAccessor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor
すべての実装インタフェース:
ShortCutAccessor
public class StandardShortCutAccessor
extends Object
implements ShortCutAccessor

ショートカットアクセッサクラス。

ショートカット情報の読み込みおよび書き込みのクラスです。

タグ名 | 説明
error-page | ショートカット情報が存在しない場合に表示するページパスを指定します。
main-page | ショートカットページを表示するためのメインページパスを設定します。

フィールドの概要
String | errorPagePath クラス変数
String | mainPagePath
コンストラクタの概要
StandardShortCutAccessor()
メソッドの概要
Date | addValidEndDate(int countDays) SYSTEM日付に指定した日数を加えた日付を取得します。
String | createShortCut(String groupId, ShortCutInfo shortCutInfo) ショートカットIDを作成します。
void | deleteShortCut(String groupId, String shortCutId) ショートカットIDを削除します。
String | getErrorPage(String groupId) エラーページのパスを取得します。
String | getMainPage(String groupId) ショートカット表示用のパスを取得します。
ShortCutInfo | getShortCutInfo(String groupId, String shortCutId) ショートカット情報を取得します。
void | init(Node node) ショートカットアクセッサを初期化します。
int | verifyShortCut(String groupId, Date verifyDate) ショートカットIDを検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

errorPagePath

public String errorPagePath
クラス変数

mainPagePath

public String mainPagePath
コンストラクタの詳細

StandardShortCutAccessor

public StandardShortCutAccessor()
メソッドの詳細

init

public void init(Node node)
ショートカットアクセッサを初期化します。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース ShortCutAccessor 内の init
パラメータ:
node - 初期化パラメータのDOM

createShortCut

public String createShortCut(String groupId,
                             ShortCutInfo shortCutInfo)
                      throws AccessSecurityException
ショートカットIDを作成します。
ショートカット情報の許可ユーザを複数指定した場合、認証フラグは必ずONになります。

定義:
インタフェース ShortCutAccessor 内の createShortCut
パラメータ:
groupId - ログイングループID
shortCutInfo - ショートカット情報
戻り値:
ショートカットID
例外:
ショートカット情報の登録に失敗した場合、スローされます。
AccessSecurityException

deleteShortCut

public void deleteShortCut(String groupId,
                           String shortCutId)
                    throws AccessSecurityException
ショートカットIDを削除します。

定義:
インタフェース ShortCutAccessor 内の deleteShortCut
パラメータ:
groupId - ログイングループID
shortCutId - ショートカットID
例外:
ショートカット情報の削除に失敗した場合、スローされます。
AccessSecurityException

verifyShortCut

public int verifyShortCut(String groupId,
                          Date verifyDate)
                   throws AccessSecurityException
ショートカットIDを検証します。

定義:
インタフェース ShortCutAccessor 内の verifyShortCut
パラメータ:
groupId - ログイングループID
verifyDate - 検証日付
戻り値:
削除件数
例外:
過去のショートカット情報の削除に失敗した場合、スローされます。
AccessSecurityException

getShortCutInfo

public ShortCutInfo getShortCutInfo(String groupId,
                                    String shortCutId)
                             throws AccessSecurityException
ショートカット情報を取得します。

定義:
インタフェース ShortCutAccessor 内の getShortCutInfo
パラメータ:
groupId - ログイングループID
shortCutId - ショートカットID
戻り値:
ショートカット情報(取得できなかった場合、NULLを返却)
例外:
ショートカット情報の取得に失敗した場合、スローされます。
AccessSecurityException

getErrorPage

public String getErrorPage(String groupId)
エラーページのパスを取得します。

定義:
インタフェース ShortCutAccessor 内の getErrorPage
パラメータ:
groupId - ログイングループID
戻り値:
エラーページパス

getMainPage

public String getMainPage(String groupId)
ショートカット表示用のパスを取得します。

定義:
インタフェース ShortCutAccessor 内の getMainPage
パラメータ:
groupId - ログイングループID
戻り値:
メインページパス

addValidEndDate

public Date addValidEndDate(int countDays)
                     throws AccessSecurityException
SYSTEM日付に指定した日数を加えた日付を取得します。

SYSTEM日付に指定した日数を加えた日付が9999/12/31を超えた場合は9999/12/31を返却します。
日数に負の数を与えた場合はSYSTEM日付を返却します。

定義:
インタフェース ShortCutAccessor 内の addValidEndDate
パラメータ:
countDays - 指定日数
戻り値:
SYSTEM日付に指定した日数を加えた日付
例外:
AccessSecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス AccessSecurityManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.AccessSecurityManager
public class AccessSecurityManager
extends Object

アクセスセキュリティマネージャクラス。

アクセスセキュリティの認証処理をするためのクラスです。
アクセスセキュリティの認証処理を行う場合は、必ずこのクラスを利用します。
また、システムセッション情報を取得する場合は、このクラスを利用して取得します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
static void | clearInstance() アクセスセキュリティマネージャのインスタンスを初期化します。
LoginRequestInfo | createLoginRequestInfo(String loginType) ログイン情報を作成します。
String | createUrlSignature(String url, String groupId, String userId) ダイレクトＵＲＬ署名を作成します。
String | decrypt(String secret) デフォルトの暗号化アルゴリズムカテゴリを利用して暗号化された文字列を復号します。
String | decrypt(String category, String secret) 指定された暗号化アルゴリズムカテゴリを利用して暗号化された文字列を復号します。
String | encrypt(String plane) デフォルトの暗号化アルゴリズムカテゴリを利用して文字列を暗号化します。
String | encrypt(String category, String plane) 指定された暗号化アルゴリズムカテゴリを利用して文字列を暗号化します。
int | forceLogin(LoginRequestInfo loginRequestInfo) 強制ログイン処理を行います。
int | forceLogin(LoginRequestInfo loginRequestInfo, HttpServletRequest request, HttpServletResponse response) 強制ログイン処理を行います。
void | forward(HttpServletRequest request, HttpServletResponse response, String url) 指定したURLにフォワードします。
void | forward(String url) 指定したURLにフォワードします。
SessionInfo | getCookieSessionInfo() カレントスレッド情報のクッキーからintra-martセッション情報を取得します。
SessionInfo | getCookieSessionInfo(HttpServletRequest request) クッキーからintra-martセッション情報を取得します。
String | getErrorPage(int errorCode) カレントスレッド情報からエラーページＵＲＬを取得します。
String | getErrorPage(int errorCode, HttpServletRequest request, HttpServletResponse response) エラーページＵＲＬを取得します。
int | getInitialCertification(LoginRequestInfo loginInfo) カレントスレッドの情報から初期アクセス処理を行います。
int | getInitialCertification(LoginRequestInfo loginInfo, HttpServletRequest request, HttpServletResponse response) 初期アクセス処理を行います。
String | getInitialPage() カレントスレッド情報から初期アクセスページURLを取得します。
String | getInitialPage(SessionInfo sessionInfo) カレントスレッド情報から初期アクセスページURLを取得します。
String | getInitialPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期アクセスページURLを取得します。
static AccessSecurityManager | getInstance() セキュリティマネージャのインスタンスを取得します。
int | getLicense(LoginInfo loginInfo) アカウントライセンスチェックを行います。
int | getLoginCertification() カレントスレッド情報からログイン処理を行います。
int | getLoginCertification(HttpServletRequest request, HttpServletResponse response) ログイン処理を行います。
String | getMainPage() カレントスレッド情報からメインページURLを取得します。
String | getMainPage(SessionInfo sessionInfo) カレントスレッド情報からメインページURLを取得します。
String | getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得します。
String | getMobileUserAgent() モバイル端末の固体識別番号を取得します。
String | getMobileUserAgent(HttpServletRequest request, HttpServletResponse response) モバイル端末の固体識別番号を取得します。
SessionConfig | getSessionConfig() セッション情報保管パラメータを取得します。
SessionInfo | getSessionInfo() カレントスレッド情報からintra-martセッション情報を取得します。
SessionInfo | getSessionInfo(HttpServletRequest request, HttpServletResponse response) intra-martセッション情報を取得します。
int | getSessionMode() intra-martセッションの状態を取得します。
int | getSessionMode(SessionInfo sessionInfo) intra-martセッションの状態を取得します。
int | login(LoginRequestInfo loginRequestInfo) ログイン処理を行います。
int | login(LoginRequestInfo loginRequestInfo, HttpServletRequest request, HttpServletResponse response) ログイン処理を行います。
void | logout() ログアウト処理を行います。
void | logout(HttpServletRequest request, HttpServletResponse response) ログアウト処理を行います。
void | secureRedirect(HttpServletRequest request, HttpServletResponse response, String url, Map args) 呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。
void | secureRedirect(String url, Map args) 呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

clearInstance

public static void clearInstance()
アクセスセキュリティマネージャのインスタンスを初期化します。

アクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。
通常、このメソッドを使用する必要はありません。

getInstance

public static AccessSecurityManager getInstance()
                                         throws AccessSecurityException
セキュリティマネージャのインスタンスを取得します。

戻り値:
セキュリティマネージャインスタンス
例外:
AccessSecurityException - アクセスセキュリティ設定またはシステム設定に誤りがあった場合にスローします。

createLoginRequestInfo

public LoginRequestInfo createLoginRequestInfo(String loginType)
ログイン情報を作成します。

パラメータ:
loginType - ログインタイプ
システム管理者 | SecurityConstraint.LT_SUPER
グループ管理者 | SecurityConstraint.LT_GROUP
ユーザ | SecurityConstraint.LT_USER
戻り値:
ログイン情報

createUrlSignature

public String createUrlSignature(String url,
                                 String groupId,
                                 String userId)
                          throws AccessSecurityException
ダイレクトＵＲＬ署名を作成します。

パラメータ:
url - ダイレクトＵＲＬ
groupId - ログイングループＩＤ
userId - ユーザＩＤ
戻り値:
ダイレクトURL署名
例外:
AccessSecurityException - 引数が不正だった場合に例外がスローされます。

forceLogin

public int forceLogin(LoginRequestInfo loginRequestInfo)
               throws NoFilterException,
                      AccessSecurityException
強制ログイン処理を行います。

パスワード認証を行わずに強制的にログインします。
ただし、引数のログイン情報に存在しないログイングループを設定した場合は、ログインできません。

パラメータ:
loginRequestInfo - ログイン情報
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

forceLogin

public int forceLogin(LoginRequestInfo loginRequestInfo,
                      HttpServletRequest request,
                      HttpServletResponse response)
               throws AccessSecurityException
強制ログイン処理を行います。

パスワード認証を行わずに強制的にログインします。
ただし、引数のログイン情報に存在しないログイングループを設定した場合は、ログインできません。

パラメータ:
loginRequestInfo - ログイン情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

forward

public void forward(HttpServletRequest request,
                    HttpServletResponse response,
                    String url)
             throws ServletException,
                    IOException,
                    AccessSecurityException
指定したURLにフォワードします。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
url - ＵＲＬ
例外:
IOException - 最終的なフォワード先となるリソースがこの例外をスローした場合にスローします。
ServletException - 最終的なフォワード先となるリソースがこの例外をスローした場合にスローします。
AccessSecurityException - 引数が不正だった場合にスローされます。

forward

public void forward(String url)
             throws NoFilterException,
                    ServletException,
                    IOException,
                    AccessSecurityException
指定したURLにフォワードします。

パラメータ:
url - ＵＲＬ
例外:
IOException - 最終的なフォワード先となるリソースがこの例外をスローした場合にスローします。
ServletException - 最終的なフォワード先となるリソースがこの例外をスローした場合にスローします。
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 引数が不正だった場合にスローされます。

getCookieSessionInfo

public SessionInfo getCookieSessionInfo()
                                 throws NoFilterException
カレントスレッド情報のクッキーからintra-martセッション情報を取得します。

このメソッドを利用するためには、jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestManagementFilterを
web.xmlにフィルタとして設定する必要があります。

戻り値:
クッキーに保管されているintra-martセッション情報
セッション情報保管用のクッキーが存在しない場合はnullを返します。
例外:
NoFilterException - カレントスレッドからサーブレットリクエストが取得できなかった場合にスローします。

getCookieSessionInfo

public SessionInfo getCookieSessionInfo(HttpServletRequest request)
クッキーからintra-martセッション情報を取得します。

パラメータ:
request - サーブレットリクエスト
戻り値:
クッキーに保管されているintra-martセッション情報
セッション情報保管用のクッキーが存在しない場合はnullを返します。

getErrorPage

public String getErrorPage(int errorCode)
                    throws NoFilterException,
                           AccessSecurityException
カレントスレッド情報からエラーページＵＲＬを取得します。

引数で指定したエラーページＵＲＬを返却します。

パラメータ:
errorCode - ログインエラーコード (SecurityConstraint.CR_* を参照)
戻り値:
エラーページのＵＲＬ
ページが存在しなかった場合はnullを返します。
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - アクセスセキュリティ設定またはシステム設定に誤りがあった場合にスローします。

getErrorPage

public String getErrorPage(int errorCode,
                           HttpServletRequest request,
                           HttpServletResponse response)
                    throws AccessSecurityException
エラーページＵＲＬを取得します。

引数で指定したエラーページＵＲＬを返却します。

パラメータ:
errorCode - ログインエラーコード (SecurityConstraint.CR_* を参照)
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
エラーページのURL
ページが存在しなかった場合はnullを返します。
例外:
AccessSecurityException - アクセスセキュリティ設定またはシステム設定に誤りがあった場合にスローします。

getInitialCertification

public int getInitialCertification(LoginRequestInfo loginInfo)
                            throws NoFilterException,
                                   AccessSecurityException
カレントスレッドの情報から初期アクセス処理を行います。

パラメータ:
loginInfo - ログインリクエスト情報
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getInitialCertification

public int getInitialCertification(LoginRequestInfo loginInfo,
                                   HttpServletRequest request,
                                   HttpServletResponse response)
                            throws AccessSecurityException
初期アクセス処理を行います。

パラメータ:
loginInfo - ログインリクエスト情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getInitialPage

public String getInitialPage()
                      throws NoFilterException,
                             AccessSecurityException
カレントスレッド情報から初期アクセスページURLを取得します。

現在のセッション情報から初期アクセスページURLを取得します。

戻り値:
初期アクセスページURL
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getInitialPage

public String getInitialPage(SessionInfo sessionInfo)
                      throws NoFilterException,
                             AccessSecurityException
カレントスレッド情報から初期アクセスページURLを取得します。

パラメータ:
sessionInfo - intra-martセッション情報
戻り値:
初期アクセスページURL
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getInitialPage

public String getInitialPage(SessionInfo sessionInfo,
                             HttpServletRequest request,
                             HttpServletResponse response)
                      throws AccessSecurityException
初期アクセスページURLを取得します。

パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getLicense

public int getLicense(LoginInfo loginInfo)
               throws AccessSecurityException
アカウントライセンスチェックを行います。

パラメータ:
loginInfo - ログインリクエスト情報
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getLoginCertification

public int getLoginCertification()
                          throws NoFilterException,
                                 AccessSecurityException
カレントスレッド情報からログイン処理を行います。

ログイン処理後のページを取得します。

戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getLoginCertification

public int getLoginCertification(HttpServletRequest request,
                                 HttpServletResponse response)
                          throws AccessSecurityException
ログイン処理を行います。

ログイン処理後のページを取得します。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getMainPage

public String getMainPage()
                   throws NoFilterException,
                          AccessSecurityException
カレントスレッド情報からメインページURLを取得します。

現在のセッション情報からログイン後のメインページを取得します。

戻り値:
メインページURL
ページが存在しなかった場合は、nullを返却します。
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getMainPage

public String getMainPage(SessionInfo sessionInfo)
                   throws NoFilterException,
                          AccessSecurityException
カレントスレッド情報からメインページURLを取得します。

ログイン後のメインページを取得します。

パラメータ:
sessionInfo - intra-martセッション情報
戻り値:
メインページURL
ページが存在しなかった場合はnullを返します。
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getMainPage

public String getMainPage(SessionInfo sessionInfo,
                          HttpServletRequest request,
                          HttpServletResponse response)
                   throws AccessSecurityException
メインページURLを取得します。

ログイン後のメインページを取得します。

パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
メインページURL
ページが存在しなかった場合は、nullを返します。
例外:
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getSessionConfig

public SessionConfig getSessionConfig()
                               throws AccessSecurityException
セッション情報保管パラメータを取得します。

戻り値:
セッション情報保管パラメータ情報
例外:
AccessSecurityException - アクセスセキュリティ設定またはシステム設定に誤りがあった場合にスローします。

getSessionInfo

public SessionInfo getSessionInfo()
                           throws NoFilterException,
                                  AccessSecurityException
カレントスレッド情報からintra-martセッション情報を取得します。

このメソッドを利用するためには、jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilterを
web.xmlにフィルタとして設定する必要があります。

戻り値:
intra-martセッション情報
セッションが存在しない場合はnullを返します。
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 引数が不正だった場合にスローされます。

getSessionInfo

public SessionInfo getSessionInfo(HttpServletRequest request,
                                  HttpServletResponse response)
                           throws AccessSecurityException
intra-martセッション情報を取得します。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
intra-martセッション情報
セッションが存在しない場合はnullを返します。
例外:
AccessSecurityException - 引数が不正だった場合にスローされます。

getSessionMode

public int getSessionMode()
                   throws AccessSecurityException,
                          NoFilterException
intra-martセッションの状態を取得します。

戻り値:
セッション状態
初期状態 | SecurityConstraint.CR_SESSION_INITIAL
ログオン状態 | SecurityConstraint.CR_SESSION_LOGON
セッション不整合状態 | SecurityConstraint.CR_SESSION_UNMATCH
セッションタイムアウト状態 | SecurityConstraint.CR_SESSION_TIMEOUT
例外:
AccessSecurityException - アクセスセキュリティ設定またはシステム設定に誤りがあった場合にスローします。
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。

getSessionMode

public int getSessionMode(SessionInfo sessionInfo)
                   throws AccessSecurityException
intra-martセッションの状態を取得します。

パラメータ:
sessionInfo - intra-martセッション情報
戻り値:
セッション状態
初期状態 | SecurityConstraint.CR_SESSION_INITIAL
ログオン状態 | SecurityConstraint.CR_SESSION_LOGON
セッション不整合状態 | SecurityConstraint.CR_SESSION_UNMATCH
セッションタイムアウト状態 | SecurityConstraint.CR_SESSION_TIMEOUT
例外:
AccessSecurityException - アクセスセキュリティ設定またはシステム設定に誤りがあった場合にスローします。

login

public int login(LoginRequestInfo loginRequestInfo)
          throws NoFilterException,
                 AccessSecurityException
ログイン処理を行います。

引数のログイン情報を使用して通常のログイン処理を行います。

パラメータ:
loginRequestInfo - ログイン情報
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

login

public int login(LoginRequestInfo loginRequestInfo,
                 HttpServletRequest request,
                 HttpServletResponse response)
          throws AccessSecurityException
ログイン処理を行います。

引数のログイン情報を使用して通常のログイン処理を行います。

パラメータ:
loginRequestInfo - ログイン情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

logout

public void logout()
            throws NoFilterException,
                   AccessSecurityException
ログアウト処理を行います。

セッション情報を初期化します。

例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

logout

public void logout(HttpServletRequest request,
                   HttpServletResponse response)
            throws AccessSecurityException
ログアウト処理を行います。

セッション情報を初期化します。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ログインエラーコード
例外:
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

secureRedirect

public void secureRedirect(HttpServletRequest request,
                           HttpServletResponse response,
                           String url,
                           Map args)
                    throws ServletException,
                           IOException
呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。

外部のURLの場合は、プロトコルから指定します。

内部のURLの場合は以下の通りです。
スクリプト開発モデルプログラムのパスにリダイレクトする場合は、最後に拡張子".jssp"が必要です。
その他のパスにダイレクトする場合は、コンテキストパスからの相対URLとなります。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
url - リダイレクトURL
args - リダイレクトURLの引数(マップ形式)
例外:
IOException
ServletException

secureRedirect

public void secureRedirect(String url,
                           Map args)
                    throws NoFilterException,
                           ServletException,
                           IOException
呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。

外部のURLの場合は、プロトコルから指定します。

内部のURLの場合は以下の通りです。
スクリプト開発モデルプログラムのパスにリダイレクトする場合は、最後に拡張子".jssp"が必要です。
その他のパスにダイレクトする場合は、コンテキストパスからの相対URLとなります。

パラメータ:
url - リダイレクトURL（コンテキストパスからの相対URL）
args - リダイレクトURLの引数(マップ形式)
例外:
ServletException
IOException
NoFilterException

getMobileUserAgent

public String getMobileUserAgent(HttpServletRequest request,
                                 HttpServletResponse response)
モバイル端末の固体識別番号を取得します。

モバイル端末の固体識別番号が取得できなかった場合はnullを返却します。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
モバイル端末固体識別番号

getMobileUserAgent

public String getMobileUserAgent()
                          throws NoFilterException
モバイル端末の固体識別番号を取得します。

モバイル端末の固体識別番号が取得できなかった場合はnullを返却します。

戻り値:
モバイル端末固体識別番号
例外:
NoFilterException

decrypt

public String decrypt(String secret)
デフォルトの暗号化アルゴリズムカテゴリを利用して暗号化された文字列を復号します。

暗号化アルゴリズムカテゴリを「default」として処理を行います。

cryption-config.xmlに「default」カテゴリの設定が存在しない場合は、
「default」カテゴリを自動的に作成します。
自動的に作成される「default」カテゴリの暗号化アルゴリズムはStandardCryptionが設定されます。

パラメータ:
secret - 暗号化された文字列
戻り値:
復号化された文字列

encrypt

public String encrypt(String plane)
デフォルトの暗号化アルゴリズムカテゴリを利用して文字列を暗号化します。

暗号化アルゴリズムカテゴリを「default」として処理を行います。

cryption-config.xmlに「default」カテゴリの設定が存在しない場合は、
「default」カテゴリを自動的に作成します。
自動的に作成される「default」カテゴリの暗号化アルゴリズムはStandardCryptionが設定されます。

パラメータ:
plane - 暗号化する文字列
戻り値:
暗号化された文字列

decrypt

public String decrypt(String category,
                      String secret)
指定された暗号化アルゴリズムカテゴリを利用して暗号化された文字列を復号します。

暗号化アルゴリズムカテゴリは,サーバマネージャ/conf/cryption-config.xmlの
cryptionタグのcategory属性に指定した名称を指定します。

暗号化アルゴリズムカテゴリが存在しない場合は、
暗号化アルゴリズムカテゴリに「default」を指定して再度試みます。

cryption-config.xmlに「default」カテゴリの設定が存在しない場合は、
「default」カテゴリを自動的に作成します。
自動的に作成される「default」カテゴリの暗号化アルゴリズムはStandardCryptionが設定されます。

パラメータ:
category - 暗号化アルゴリズムカテゴリ
secret - 暗号化された文字列
戻り値:
復号化された文字列

encrypt

public String encrypt(String category,
                      String plane)
指定された暗号化アルゴリズムカテゴリを利用して文字列を暗号化します。

暗号化アルゴリズムカテゴリは,サーバマネージャ/conf/cryption-config.xmlの
cryptionタグのcategory属性に指定した名称を指定します。

暗号化アルゴリズムカテゴリが存在しない場合は、
暗号化アルゴリズムカテゴリに「default」を指定して再度試みます。

cryption-config.xmlに「default」カテゴリの設定が存在しない場合は、
「default」カテゴリを自動的に作成します。
自動的に作成される「default」カテゴリの暗号化ロジックはStandardCryptionが設定されます。

パラメータ:
category - 暗号化アルゴリズムカテゴリ
plane - 暗号化する文字列
戻り値:
暗号化された文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ClientTypeInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース ClientTypeInfo

public interface ClientTypeInfo

クライアントタイプ情報インタフェース。

クライアントタイプの情報を参照するインタフェース。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getClientType() クライアントタイプを取得する。
String | getDisplayName() クライアントタイプ表示名を取得する。

メソッドの詳細

getClientType

public String getClientType()
クライアントタイプを取得する。

戻り値:
クライアントタイプ

getDisplayName

public String getDisplayName()
クライアントタイプ表示名を取得する。

戻り値:
クライアントタイプの表示名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ColorPatternInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース ColorPatternInfo

public interface ColorPatternInfo

カラーパターン情報を取得するインタフェース。

カラーパターン情報を参照する場合はこのインタフェースを利用して取得する。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getColorCode() カラーパターンコードを取得します。
String | getColorPatternId() カラーパターンIDを取得します。
String | getCssFile() カラーパターンのCSSファイルパスを取得します。
String[] | getCssFiles() カラーパターンのCSSファイルパスの一覧を取得します。
String | getDisplayName() カラーパターン表示名を取得します。
String | getImageFolder() カラーパターンのイメージファイルのフォルダを取得します。
String | getProperty(String key) カラーパターンのプロパティ情報を取得します。
String[] | getPropertyKeys() カラーパターンのプロパティ情報のキー一覧を取得します。

メソッドの詳細

getColorCode

public String getColorCode()
カラーパターンコードを取得します。

カラーパターンをイメージするカラーコード
#rrggbb形式で返却する。

戻り値:
カラーパターンコード

getColorPatternId

public String getColorPatternId()
カラーパターンIDを取得します。

戻り値:
カラーパターンID

getCssFile

public String getCssFile()
カラーパターンのCSSファイルパスを取得します。

先頭の１つを返却します。 コンテキストパスからの相対パス。（'/'から始まります。）

戻り値:
cssPath CSSファイルパス

getCssFiles

public String[] getCssFiles()
カラーパターンのCSSファイルパスの一覧を取得します。

コンテキストパスからの相対パス。（'/'から始まります。）

戻り値:
cssPath CSSファイルパスの一覧

getDisplayName

public String getDisplayName()
カラーパターン表示名を取得します。

戻り値:
カラーパターンの表示名

getImageFolder

public String getImageFolder()
カラーパターンのイメージファイルのフォルダを取得します。

コンテキストパスからの相対パス。（'/'から始まります。）

戻り値:
imagePath イメージファイルのフォルダ

getProperty

public String getProperty(String key)
カラーパターンのプロパティ情報を取得します。

パラメータ:
key - プロパティキー
戻り値:
プロパティ情報

getPropertyKeys

public String[] getPropertyKeys()
カラーパターンのプロパティ情報のキー一覧を取得します。

戻り値:
カラーパターンのプロパティ情報のキー一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DepartmentInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス DepartmentInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.DepartmentInfo
すべての実装インタフェース:
Serializable
public class DepartmentInfo
extends Object
implements Serializable

組織情報クラス。

組織情報を保管するクラスです。
メニュー、アクセスコントロールの組織設定情報として利用します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DepartmentInfo(String companyCode, String departmentCode)
コンストラクタ。
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
String | getKeyString() 組織情報の識別子を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DepartmentInfo

public DepartmentInfo(String companyCode,
                      String departmentCode)
コンストラクタ。

メソッドの詳細

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
companyCode 会社コード

getDepartmentCode

public String getDepartmentCode()
組織コードを取得します。

戻り値:
departmentCode 組織コード

getKeyString

public String getKeyString()
組織情報の識別子を取得します。

戻り値:
組織情報の識別子
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendsImport (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース ExtendsImport

public interface ExtendsImport

拡張インポート処理インターフェース。

拡張インポート処理を行うためのインターフェース。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
 void doImport(String groupId)
拡張インポート処理を行います。

メソッドの詳細

doImport

public void doImport(String groupId)
拡張インポート処理を行います。

トランザクションが必要な場合は、内部でトランザクション処理を行ってください。

パラメータ:
groupId - 対象のログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendsImportManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス ExtendsImportManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.ExtendsImportManager
public class ExtendsImportManager
extends Object

拡張インポートマネージャクラス。

拡張インポート処理を実行するマネージャクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | doImport(String groupId, String module) 拡張インポート処理を実行します。
static ExtendsImportManager | getInstance()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getInstance

public static ExtendsImportManager getInstance()

doImport

public void doImport(String groupId,
                     String module)
              throws AccessSecurityException
拡張インポート処理を実行します。

引数moduleには、クラスまたはJSのパスを指定できます。
クラスを指定する場合は、ExtendsImportを継承したクラスのフルパッケージ名を指定してください。

JSのパスを指定する場合は、指定するJSファイルに記述されている"doImport""関数をコールします。
"doImport""関数の第一引数にログイングループIDを引き渡します。
パスの指定は、pagesからの相対パスで、最後に".js"を含んだものである必要があります。
例：
function doImport(group){
......

}

パラメータ:
groupId - ログイングループID
module - 拡張インポート処理を行うクラス名またはJSのパス
例外:
AccessSecurityException - クラス名のインスタンスの生成に失敗した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


INonTransaction (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース INonTransaction

public interface INonTransaction

分散トランザクション未対応のアクセッサに実装するインターフェース。

分散トランザクション未対応のアクセッサに実装する。

導入されたバージョン:
5.0
バージョン:
1.0

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LocaleInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース LocaleInfo

すべてのスーパーインタフェース:
LocaleProvider
public interface LocaleInfo
extends LocaleProvider

ロケｰル情報・モデルインタフェース。

ロケールのデータモデルのインタフェースを定義

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getDisplayName() ロケ－ル表示名取得。
String | getEncoding() デフォルトエンコーディングの取得。
String[] | getEncodings() ロケ－ルに対応しているエンコーディングの一覧の取得。
Locale | getLocale() ロケ－ル取得。

メソッドの詳細

getDisplayName

public String getDisplayName()
ロケ－ル表示名取得。

ロケ－ル表示名を取得する

戻り値:
ロケｰル表示名

getEncoding

public String getEncoding()
デフォルトエンコーディングの取得。

定義:
インタフェース LocaleProvider 内の getEncoding
戻り値:
デフォルトエンコーディング

getEncodings

public String[] getEncodings()
ロケ－ルに対応しているエンコーディングの一覧の取得。

ロケ－ルに対応しているエンコーディングの一覧の取得

戻り値:
対応しているエンコーディングの一覧

getLocale

public Locale getLocale()
ロケ－ル取得。

ロケ－ルを取得する

定義:
インタフェース LocaleProvider 内の getLocale
戻り値:
ロケｰル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LocaleProvider (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース LocaleProvider

既知のサブインタフェースの一覧:
LocaleInfo, LoginInfo, LoginRequestInfo, SessionInfo
既知の実装クラスの一覧:
Account, LoginGroup, SuperUser
public interface LocaleProvider

ロケール取得プロバイダーインタフェース。 ロケール情報を取得するためのインタフェース。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getEncoding() エンコーディングを取得する。
Locale | getLocale() ロケールを取得する。

メソッドの詳細

getLocale

public Locale getLocale()
ロケールを取得する。

戻り値:
ロケール

getEncoding

public String getEncoding()
エンコーディングを取得する。

戻り値:
エンコーディング
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.security
インタフェース
ClientTypeInfo
ColorPatternInfo
ExtendsImport
INonTransaction
LocaleInfo
LocaleProvider
SecurityConstraint
SessionConfig
SessionInfo
SystemSourceProvider
クラス
AccessSecurityManager
DepartmentInfo
ExtendsImportManager
PostInfo
PublicGroupInfo
StandardAccessControllerAccessor
StandardAccountAccessor
StandardBatchAccessor
StandardCalendarAccessor
StandardMenuAccessor
StandardRoleAccessor
SystemManager


jp.co.intra_mart.foundation.security (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security

アクセスセキュリティに関連するクラスを提供します。

参照:
説明

インタフェースの概要
ClientTypeInfo | クライアントタイプ情報インタフェース。
ColorPatternInfo | カラーパターン情報を取得するインタフェース。
ExtendsImport | 拡張インポート処理インターフェース。
INonTransaction | 分散トランザクション未対応のアクセッサに実装するインターフェース。
LocaleInfo | ロケｰル情報・モデルインタフェース。
LocaleProvider | ロケール取得プロバイダーインタフェース。
SecurityConstraint | アクセスセキュリティ定数インタフェース。
SessionConfig | セッションに関する設定情報を取得するインタフェース。
SessionInfo | intra-martセッション情報参照インタフェース。
SystemSourceProvider | ロケール情報取得インターフェース。

クラスの概要
AccessSecurityManager | アクセスセキュリティマネージャクラス。
DepartmentInfo | 組織情報クラス。
ExtendsImportManager | 拡張インポートマネージャクラス。
PostInfo | 役職情報クラス。
PublicGroupInfo | パブリックグループ情報クラス。
StandardAccessControllerAccessor |
StandardAccountAccessor | アカウントアクセッサクラス。
StandardBatchAccessor | バッチアクセッサクラス。
StandardCalendarAccessor | カレンダーアクセッサクラス。
StandardMenuAccessor | メニューアクセッサクラス。
StandardRoleAccessor | ロールアクセッサクラス。
SystemManager | システムマネージャクラス。

パッケージ jp.co.intra_mart.foundation.security の説明

アクセスセキュリティに関連するクラスを提供します。


jp.co.intra_mart.foundation.security クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.AccessSecurityManager
    • class jp.co.intra_mart.foundation.security.DepartmentInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.ExtendsImportManager
    • class jp.co.intra_mart.foundation.security.PostInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.PublicGroupInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor (implements jp.co.intra_mart.foundation.security.access.AccessControllerAccessor)
    • class jp.co.intra_mart.foundation.security.StandardAccountAccessor (implements jp.co.intra_mart.foundation.security.account.AccountAccessor)
    • class jp.co.intra_mart.foundation.security.StandardBatchAccessor (implements jp.co.intra_mart.foundation.security.batch.BatchAccessor)
    • class jp.co.intra_mart.foundation.security.StandardCalendarAccessor (implements jp.co.intra_mart.foundation.security.calendar.CalendarAccessor)
    • class jp.co.intra_mart.foundation.security.StandardMenuAccessor (implements jp.co.intra_mart.foundation.security.menu.MenuAccessor)
    • class jp.co.intra_mart.foundation.security.StandardRoleAccessor (implements jp.co.intra_mart.foundation.security.role.RoleAccessor)
    • class jp.co.intra_mart.foundation.security.SystemManager

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.ClientTypeInfo
  • interface jp.co.intra_mart.foundation.security.ColorPatternInfo
  • interface jp.co.intra_mart.foundation.security.ExtendsImport
  • interface jp.co.intra_mart.foundation.security.INonTransaction
  • interface jp.co.intra_mart.foundation.security.LocaleProvider
    • interface jp.co.intra_mart.foundation.security.LocaleInfo
    • interface jp.co.intra_mart.foundation.security.SessionInfo
  • interface jp.co.intra_mart.foundation.security.SecurityConstraint
  • interface jp.co.intra_mart.foundation.security.SessionConfig
  • interface jp.co.intra_mart.foundation.security.SystemSourceProvider


パッケージ jp.co.intra_mart.foundation.security の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security の使用

jp.co.intra_mart.foundation.security を使用しているパッケージ
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession |
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.duplication |
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.password |

jp.co.intra_mart.foundation.navigator により使用される jp.co.intra_mart.foundation.security のクラス
DepartmentInfo
組織情報クラス。
PostInfo
役職情報クラス。
PublicGroupInfo
パブリックグループ情報クラス。

jp.co.intra_mart.foundation.security により使用される jp.co.intra_mart.foundation.security のクラス
AccessSecurityManager
アクセスセキュリティマネージャクラス。
ClientTypeInfo
クライアントタイプ情報インタフェース。
ColorPatternInfo
カラーパターン情報を取得するインタフェース。
DepartmentInfo
組織情報クラス。
ExtendsImportManager
拡張インポートマネージャクラス。
LocaleInfo
ロケｰル情報・モデルインタフェース。
LocaleProvider
ロケール取得プロバイダーインタフェース。
PostInfo
役職情報クラス。
PublicGroupInfo
パブリックグループ情報クラス。
SessionConfig
セッションに関する設定情報を取得するインタフェース。
SessionInfo
intra-martセッション情報参照インタフェース。
SystemManager
システムマネージャクラス。
SystemSourceProvider
ロケール情報取得インターフェース。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.security のクラス
DepartmentInfo
組織情報クラス。
PostInfo
役職情報クラス。
PublicGroupInfo
パブリックグループ情報クラス。

jp.co.intra_mart.foundation.security.account により使用される jp.co.intra_mart.foundation.security のクラス
LocaleProvider
ロケール取得プロバイダーインタフェース。

jp.co.intra_mart.foundation.security.activesession により使用される jp.co.intra_mart.foundation.security のクラス
SessionInfo
intra-martセッション情報参照インタフェース。

jp.co.intra_mart.foundation.security.admin により使用される jp.co.intra_mart.foundation.security のクラス
LocaleProvider
ロケール取得プロバイダーインタフェース。

jp.co.intra_mart.foundation.security.certification により使用される jp.co.intra_mart.foundation.security のクラス
LocaleProvider
ロケール取得プロバイダーインタフェース。
SessionInfo
intra-martセッション情報参照インタフェース。

jp.co.intra_mart.foundation.security.duplication により使用される jp.co.intra_mart.foundation.security のクラス
SessionInfo
intra-martセッション情報参照インタフェース。

jp.co.intra_mart.foundation.security.group により使用される jp.co.intra_mart.foundation.security のクラス
LocaleProvider
ロケール取得プロバイダーインタフェース。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.security のクラス
DepartmentInfo
組織情報クラス。
PostInfo
役職情報クラス。
PublicGroupInfo
パブリックグループ情報クラス。

jp.co.intra_mart.foundation.security.password により使用される jp.co.intra_mart.foundation.security のクラス
SessionInfo
intra-martセッション情報参照インタフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PostInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス PostInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.PostInfo
すべての実装インタフェース:
Serializable
public class PostInfo
extends Object
implements Serializable

役職情報クラス。

役職情報を保管するクラスです。
メニュー、アクセスコントロールの役職設定情報として利用します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
PostInfo(String companyCode, String postCode)
コンストラクタ。
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getKeyString() 役職情報の識別子を取得します。
String | getPostCode() 役職コードを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PostInfo

public PostInfo(String companyCode,
                String postCode)
コンストラクタ。

メソッドの詳細

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
companyCode 会社コード

getPostCode

public String getPostCode()
役職コードを取得します。

戻り値:
postCode 役職コード

getKeyString

public String getKeyString()
役職情報の識別子を取得します。

戻り値:
役職情報の識別子
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PublicGroupInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス PublicGroupInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.PublicGroupInfo
すべての実装インタフェース:
Serializable
public class PublicGroupInfo
extends Object
implements Serializable

パブリックグループ情報クラス。

パブリックグループ情報を保管するクラスです。
メニュー、アクセスコントロールのパブリックグループ設定情報として利用します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupInfo(String groupSetCode, String groupCode)
コンストラクタ。
メソッドの概要
String | getGroupCode() グループコードを取得します。
String | getGroupSetCode() グループセットコードを取得します。
String | getKeyString() パブリックグループ情報の識別子を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupInfo

public PublicGroupInfo(String groupSetCode,
                       String groupCode)
コンストラクタ。

メソッドの詳細

getGroupSetCode

public String getGroupSetCode()
グループセットコードを取得します。

戻り値:
groupSetCode グループセットコード

getGroupCode

public String getGroupCode()
グループコードを取得します。

戻り値:
groupCode グループコード

getKeyString

public String getKeyString()
パブリックグループ情報の識別子を取得します。

戻り値:
パブリックグループ情報の識別子
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SecurityConstraint (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース SecurityConstraint

public interface SecurityConstraint

アクセスセキュリティ定数インタフェース。 アクセスセキュリティで使用する定数値を定義したインターフェース。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String | ATTR_CERTIFICATION_MODE 認証モード制御パラメータ名。
static String | ATTR_DO_FILTER セッションフィルター制御パラメータ名。
static String | CP_COOKIE セッション情報をクッキーに保管するパラメータ名。
static int | CR_ERROR 認証処理エラーの返却値。
static int | CR_LOCKED アカウントロック状態の返却値。
static int | CR_NG ログインエラーの返却値。
static int | CR_NO_GROUP ログイングループ未登録状態の返却値。
static int | CR_NO_LICENSE ライセンスなし、または有効期間外状態の返却値。
static int | CR_NO_PERMISSION 無許可ページへのアクセスの返却値。
static int | CR_NO_USER ユーザ未登録状態の返却値。
static int | CR_OK 認証成功の返却値。
static int | CR_SESSION_INITIAL セッション初期状態の返却値。
static int | CR_SESSION_LOGON セッションログオン状態の返却値。
static int | CR_SESSION_TIMEOUT セッションタイムアウト状態の返却値。
static int | CR_SESSION_UNMATCH セッション不整合状態の返却値。
static String | LT_GROUP グループマネージャー（ログインタイプ）。
static String | LT_SUPER スーパーユーザ（ログインタイプ）。
static String | LT_USER ユーザ（ログインタイプ）。
static String | RP_CLIENT_TYPE クライアントタイプのデフォルトＵＲＬ引数名。
static String | RP_ENCODING ログインエンコーディングのデフォルトＵＲＬ引数名。
static String | RP_INITIAL_URL 初期ＵＲＬのデフォルトＵＲＬ引数名。
static String | RP_LOCALE ログインロケールのデフォルトＵＲＬ引数名。
static String | RP_LOGIN_GROUP ログイングループIDのデフォルトＵＲＬ引数名。
static String | RP_LOGIN_TYPE ログインタイプのデフォルトＵＲＬ引数名。
static String | RP_PASSWORD パスワードのデフォルトＵＲＬ引数名。
static String | RP_SHORTCUT ショートカットＵＲＬパラメータのデフォルト値
static String | RP_URL ダイレクトＵＲＬのデフォルトＵＲＬ引数名。
static String | RP_URL_SIGN ダイレクトＵＲＬ署名のデフォルトＵＲＬ引数名。
static String | RP_USER ログインユーザＩＤのデフォルトＵＲＬ引数名。
static String | SP_CLIENT_TYPE クライアントタイプをセッションに保管するパラメータ名。
static String | SP_COLOR_PATTERN_ID カラーパターンIDをセッションに保管するパラメータ名。
static String | SP_ENCODING ログインエンコーディングをセッションに保管するパラメータ名。
static String | SP_INITIAL_URL 初期ページURLを属性に保管するパラメータ名。
static String | SP_LOCALE ログインロケールをセッションに保管するパラメータ名。
static String | SP_LOGIN_GROUP ログイングループIDをセッションに保管するパラメータ名。
static String | SP_LOGIN_TIME ログインした時間をセッションに保管するパラメータ名。
static String | SP_LOGIN_TYPE ログインタイプをセッションに保管するパラメータ名。
static String | SP_SHORTCUT ショートカットIDをセッションに保管するパラメータ名
static String | SP_SIGNATURE ログイン署名をセッションに保管するパラメータ名。
static String | SP_URL 認証後表示するメインページをセッションに保管するパラメータ名。
static String | SP_URL_SIGN ダイレクトＵＲＬの署名をセッションに保管するパラメータ名。
static String | SP_USER ログインユーザＩＤをセッションに保管するパラメータ名。

フィールドの詳細

SP_LOGIN_TYPE

public static final String SP_LOGIN_TYPE
ログインタイプをセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_CLIENT_TYPE

public static final String SP_CLIENT_TYPE
クライアントタイプをセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_COLOR_PATTERN_ID

public static final String SP_COLOR_PATTERN_ID
カラーパターンIDをセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_LOCALE

public static final String SP_LOCALE
ログインロケールをセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_ENCODING

public static final String SP_ENCODING
ログインエンコーディングをセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_LOGIN_GROUP

public static final String SP_LOGIN_GROUP
ログイングループIDをセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_USER

public static final String SP_USER
ログインユーザＩＤをセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_SIGNATURE

public static final String SP_SIGNATURE
ログイン署名をセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_LOGIN_TIME

public static final String SP_LOGIN_TIME
ログインした時間をセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_URL

public static final String SP_URL
認証後表示するメインページをセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_URL_SIGN

public static final String SP_URL_SIGN
ダイレクトＵＲＬの署名をセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_INITIAL_URL

public static final String SP_INITIAL_URL
初期ページURLを属性に保管するパラメータ名。

関連項目:
定数フィールド値

CP_COOKIE

public static final String CP_COOKIE
セッション情報をクッキーに保管するパラメータ名。

関連項目:
定数フィールド値

RP_LOGIN_TYPE

public static final String RP_LOGIN_TYPE
ログインタイプのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_CLIENT_TYPE

public static final String RP_CLIENT_TYPE
クライアントタイプのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_LOCALE

public static final String RP_LOCALE
ログインロケールのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_ENCODING

public static final String RP_ENCODING
ログインエンコーディングのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_LOGIN_GROUP

public static final String RP_LOGIN_GROUP
ログイングループIDのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_USER

public static final String RP_USER
ログインユーザＩＤのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_PASSWORD

public static final String RP_PASSWORD
パスワードのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_URL

public static final String RP_URL
ダイレクトＵＲＬのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_URL_SIGN

public static final String RP_URL_SIGN
ダイレクトＵＲＬ署名のデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_INITIAL_URL

public static final String RP_INITIAL_URL
初期ＵＲＬのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

LT_SUPER

public static final String LT_SUPER
スーパーユーザ（ログインタイプ）。

関連項目:
定数フィールド値

LT_GROUP

public static final String LT_GROUP
グループマネージャー（ログインタイプ）。

関連項目:
定数フィールド値

LT_USER

public static final String LT_USER
ユーザ（ログインタイプ）。

関連項目:
定数フィールド値

CR_OK

public static final int CR_OK
認証成功の返却値。

関連項目:
定数フィールド値

CR_NG

public static final int CR_NG
ログインエラーの返却値。

関連項目:
定数フィールド値

CR_NO_LICENSE

public static final int CR_NO_LICENSE
ライセンスなし、または有効期間外状態の返却値。

関連項目:
定数フィールド値

CR_NO_GROUP

public static final int CR_NO_GROUP
ログイングループ未登録状態の返却値。

関連項目:
定数フィールド値

CR_LOCKED

public static final int CR_LOCKED
アカウントロック状態の返却値。

関連項目:
定数フィールド値

CR_NO_USER

public static final int CR_NO_USER
ユーザ未登録状態の返却値。

関連項目:
定数フィールド値

CR_SESSION_INITIAL

public static final int CR_SESSION_INITIAL
セッション初期状態の返却値。

関連項目:
定数フィールド値

CR_SESSION_LOGON

public static final int CR_SESSION_LOGON
セッションログオン状態の返却値。

関連項目:
定数フィールド値

CR_SESSION_UNMATCH

public static final int CR_SESSION_UNMATCH
セッション不整合状態の返却値。

関連項目:
定数フィールド値

CR_SESSION_TIMEOUT

public static final int CR_SESSION_TIMEOUT
セッションタイムアウト状態の返却値。

関連項目:
定数フィールド値

CR_NO_PERMISSION

public static final int CR_NO_PERMISSION
無許可ページへのアクセスの返却値。

関連項目:
定数フィールド値

CR_ERROR

public static final int CR_ERROR
認証処理エラーの返却値。

関連項目:
定数フィールド値

ATTR_DO_FILTER

public static final String ATTR_DO_FILTER
セッションフィルター制御パラメータ名。

関連項目:
定数フィールド値

ATTR_CERTIFICATION_MODE

public static final String ATTR_CERTIFICATION_MODE
認証モード制御パラメータ名。

関連項目:
定数フィールド値

RP_SHORTCUT

public static final String RP_SHORTCUT
ショートカットＵＲＬパラメータのデフォルト値

関連項目:
定数フィールド値

SP_SHORTCUT

public static final String SP_SHORTCUT
ショートカットIDをセッションに保管するパラメータ名

関連項目:
定数フィールド値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionConfig (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース SessionConfig

public interface SessionConfig

セッションに関する設定情報を取得するインタフェース。

セッションに関する設定情報を取得するためのインタフェースです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getClientTypeName() クライアントタイプをセッションに保管するためのパラメータ名を取得する。
String | getColorPatternIdName() カラーパターンIDをセッションに保管するためのパラメータ名を取得する。
String | getEncodingName() エンコーディングをセッションに保管するためのパラメータ名を取得する。
String | getInitialUrlName() 初期ページURLをセッションに保管するためパラメータ名を取得する。
String | getLocaleName() ロケールをセッションに保管するためのパラメータ名を取得する。
String | getLoginGroupName() ログイングループをセッションに保管するためのパラメータ名を取得する。
String | getLoginTimeName() ログイン時間をセッションに保管するためのパラメータ名を取得する。
String | getLoginTypeName() ログインタイプをセッションに保管するためのパラメータ名を取得する。
String | getSessionCookieName() クッキーにセッション情報を保管するためパラメータ名を取得する。
String | getShortcutName() ショートカットＩＤをセッションに保管するためのパラメータ名を取得する。
String | getSignatureName() ログイン署名をセッションに保管するためのパラメータ名を取得する。
String | getUrlName() ダイレクトＵＲＬをセッションに保管するためパラメータ名を取得する。
String | getUrlSignatureName() ダイレクトＵＲＬ署名をセッションに保管するためパラメータ名を取得する。
String | getUserName() ユーザＩＤをセッションに保管するためのパラメータ名を取得する。

メソッドの詳細

getClientTypeName

public String getClientTypeName()
クライアントタイプをセッションに保管するためのパラメータ名を取得する。

戻り値:
ログインタイプをセッションに保管するためのパラメータ名

getColorPatternIdName

public String getColorPatternIdName()
カラーパターンIDをセッションに保管するためのパラメータ名を取得する。

戻り値:
カラーパターンIDをセッションに保管するためのパラメータ名

getEncodingName

public String getEncodingName()
エンコーディングをセッションに保管するためのパラメータ名を取得する。

戻り値:
エンコーディングをセッションに保管するためのパラメータ名

getInitialUrlName

public String getInitialUrlName()
初期ページURLをセッションに保管するためパラメータ名を取得する。

戻り値:
初期ページURLをセッションに保管するためパラメータ名

getLocaleName

public String getLocaleName()
ロケールをセッションに保管するためのパラメータ名を取得する。

戻り値:
ロケールをセッションに保管するためのパラメータ名

getLoginGroupName

public String getLoginGroupName()
ログイングループをセッションに保管するためのパラメータ名を取得する。

戻り値:
ログイングループをセッションに保管するためのパラメータ名

getLoginTimeName

public String getLoginTimeName()
ログイン時間をセッションに保管するためのパラメータ名を取得する。

戻り値:
ログイン時間をセッションに保管するためのパラメータ名

getLoginTypeName

public String getLoginTypeName()
ログインタイプをセッションに保管するためのパラメータ名を取得する。

戻り値:
ログインタイプをセッションに保管するためのパラメータ名

getSessionCookieName

public String getSessionCookieName()
クッキーにセッション情報を保管するためパラメータ名を取得する。

戻り値:
クッキーにセッション情報を保管するためパラメータ名

getSignatureName

public String getSignatureName()
ログイン署名をセッションに保管するためのパラメータ名を取得する。

戻り値:
ログイン署名をセッションに保管するためのパラメータ名

getUrlName

public String getUrlName()
ダイレクトＵＲＬをセッションに保管するためパラメータ名を取得する。

戻り値:
ログイン署名をセッションに保管するためのパラメータ名

getUrlSignatureName

public String getUrlSignatureName()
ダイレクトＵＲＬ署名をセッションに保管するためパラメータ名を取得する。

戻り値:
ログイン署名をセッションに保管するためのパラメータ名

getUserName

public String getUserName()
ユーザＩＤをセッションに保管するためのパラメータ名を取得する。

戻り値:
ユーザＩＤをセッションに保管するためのパラメータ名

getShortcutName

public String getShortcutName()
ショートカットＩＤをセッションに保管するためのパラメータ名を取得する。

戻り値:
ショートカットＩＤをセッションに保管するためのパラメータ名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース SessionInfo

すべてのスーパーインタフェース:
LocaleProvider
public interface SessionInfo
extends LocaleProvider

intra-martセッション情報参照インタフェース。

intra-martセッション情報を参照するためのインタフェース
intra-martセッション情報を参照する場合は、必ずこのインターフェースを利用して行う。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String COOKIE_SEPARATOR
セッション情報をクッキーに保管する際のセパレータ。
メソッドの概要
void | clearUrl() ダイレクトＵＲＬを削除する。
Object | getAttribute(String key) セッションから指定した属性の値を取得します。
String | getClientType() クライアントタイプを取得する。
String | getColorPatternId() カラーパターンIDを取得する。
String | getEncoding() エンコーディングを取得する。
String | getInitialUrl() 初期ページURLを取得します。
Locale | getLocale() ロケールを取得する。
String | getLoginGroup() ログイングループIDを取得する。
Date | getLoginTime() ログインした時間を取得する。
String | getLoginType() ログインタイプを取得する。
String | getSignature() ログイン署名を取得する。
String | getUrl() ダイレクトＵＲＬを取得する。
String | getUrlSignature() ダイレクトＵＲＬ署名を取得する。
String | getUser() ログインユーザIDを取得する。
Object | removeAttribute(String key) セッションから指定された属性を削除します。
Object | setAttribute(String key, Object value) セッションから指定した属性に値を保管します。

フィールドの詳細

COOKIE_SEPARATOR

public static final String COOKIE_SEPARATOR
セッション情報をクッキーに保管する際のセパレータ。

同じパッケージ内のみ使用可能。

関連項目:
定数フィールド値
メソッドの詳細

clearUrl

public void clearUrl()
ダイレクトＵＲＬを削除する。
セッション情報のダイレクトURLとダイレクトＵＲＬ署名を初期化します。

getClientType

public String getClientType()
クライアントタイプを取得する。
セッション情報にクライアントタイプが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
クライアントタイプ

getColorPatternId

public String getColorPatternId()
カラーパターンIDを取得する。
セッション情報にログインユーザIDが存在しない場合、および空文字列の場合はデフォルトのカラーパターンIDを返却する。

戻り値:
カラーパターンID

getEncoding

public String getEncoding()
エンコーディングを取得する。
セッション情報にエンコーディングが存在しない場合、および空文字列の場合は空文字列を返却する。

定義:
インタフェース LocaleProvider 内の getEncoding
戻り値:
エンコーディング

getInitialUrl

public String getInitialUrl()
初期ページURLを取得します。
セッション情報に初期ページURLが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
初期ページURL

getLocale

public Locale getLocale()
ロケールを取得する。
セッション情報にロケールが存在しない場合、および空文字列の場合はnullを返却する。

定義:
インタフェース LocaleProvider 内の getLocale
戻り値:
ロケール

getLoginGroup

public String getLoginGroup()
ログイングループIDを取得する。
セッション情報にログイングループIDが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
ログイングループID

getLoginTime

public Date getLoginTime()
ログインした時間を取得する。
セッション情報にログイン時間が存在しない場合、nullを返却する。

戻り値:
ログイン時間

getLoginType

public String getLoginType()
ログインタイプを取得する。
セッション情報にログインタイプが存在しない場合、および空文字列の場合は SecurityConstraint.LT_USER を返却する。

戻り値:
ログインタイプ
関連項目:
SecurityConstraint.LT_SUPER, SecurityConstraint.LT_GROUP, SecurityConstraint.LT_USER

getSignature

public String getSignature()
ログイン署名を取得する。
セッション情報にログイン署名が存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
ログイン署名

getUrl

public String getUrl()
ダイレクトＵＲＬを取得する。
セッション情報にダイレクトURLが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
ダイレクトＵＲＬ

getUrlSignature

public String getUrlSignature()
ダイレクトＵＲＬ署名を取得する。
セッション情報にダイレクトURL署名が存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
ダイレクトＵＲＬ署名

getUser

public String getUser()
ログインユーザIDを取得する。
セッション情報にログインユーザIDが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
ログインユーザID

getAttribute

public Object getAttribute(String key)
セッションから指定した属性の値を取得します。

パラメータ:
key - 属性名
戻り値:
属性値
導入されたバージョン:
6.1

setAttribute

public Object setAttribute(String key,
                           Object value)
セッションから指定した属性に値を保管します。

パラメータ:
key - 属性名
value - 属性値
戻り値:
保管されていた属性値
導入されたバージョン:
6.1

removeAttribute

public Object removeAttribute(String key)
セッションから指定された属性を削除します。

パラメータ:
key - 属性名
戻り値:
削除された属性値
導入されたバージョン:
6.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardAccessControllerAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス StandardAccessControllerAccessor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor
すべての実装インタフェース:
AccessControllerAccessor
public class StandardAccessControllerAccessor
extends Object
implements AccessControllerAccessor

フィールドの概要
static String | APPLICATION_NAME アプリケーション名
static String | ENTITY_CONTROLLER_DEPARTMENT_NAME
static String | ENTITY_CONTROLLER_NAME エンティティ名
static String | ENTITY_CONTROLLER_POST_NAME
static String | ENTITY_CONTROLLER_PUBLIC_GROUP_NAME
static String | ENTITY_CONTROLLER_ROLE_NAME
コンストラクタの概要
StandardAccessControllerAccessor()
メソッドの概要
void | deleteController(String groupId, String controllerId) アクセスコントローラを削除します。
void | deleteControllerDepartment(String groupId, String id, DepartmentInfo departmentInfo) アクセスコントローラ組織を削除します。
void | deleteControllerDepartments(String groupId, String id) すべてのアクセスコントローラ組織を削除します。
void | deleteControllerPost(String groupId, String id, PostInfo postInfo) アクセスコントローラ役職を削除します。
void | deleteControllerPosts(String groupId, String id) すべてのアクセスコントローラ役職を削除します。
void | deleteControllerPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) アクセスコントローラパブリックグループを削除します。
void | deleteControllerPublicGroups(String groupId, String id) すべてのアクセスコントローラパブリックグループを削除します。
void | deleteControllerRole(String groupId, String id, String roleId) アクセスコントローラロールを削除します。
void | deleteControllerRoles(String groupId, String id) すべてのアクセスコントローラロールを削除します。
AccessController | getController(String groupId, String controllerId) アクセスコントローラ情報を取得します。
DepartmentInfo[] | getControllerDepartments(String groupId, String id) すべてのアクセスコントローラ組織を取得します。
String[] | getControllerIds(String groupId) すべてのアクセスコントローラIDを取得します。
String[] | getControllerIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つコントローラIDをすべて取得します。
String[] | getControllerIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つコントローラIDをすべて取得します。
String[] | getControllerIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つコントローラIDをすべて取得します。
String[] | getControllerIdsByRole(String groupId, String[] roleIds) 指定されたロールIDを持つコントローラIDをすべて取得します。
PostInfo[] | getControllerPosts(String groupId, String id) すべてのアクセスコントローラ役職を取得します。
PublicGroupInfo[] | getControllerPublicGroups(String groupId, String id) すべてのアクセスコントローラパブリックグループを取得します。
String[] | getControllerRoles(String groupId, String id) すべてのアクセスコントローラロールを取得します。
AccessController[] | getControllers(String groupId) すべてのアクセスコントローラ情報を取得します。
protected String | getLoginUser() ログインユーザを取得します。
void | init(Map params) アクセスコントローラアクセッサの初期化。
void | insertAccessController(String groupId, AccessController controller) アクセスコントローラを作成します。
void | insertControllerDepartment(String groupId, String id, DepartmentInfo departmentInfo) アクセスコントローラ組織を新規に作成します。
void | insertControllerPost(String groupId, String id, PostInfo postInfo) アクセスコントローラ役職を新規に作成します。
void | insertControllerPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) アクセスコントローラパブリックグループを新規に作成します。
void | insertControllerRole(String groupId, String id, String roleId) アクセスコントローラロールを新規に作成します。
void | updateController(String groupId, AccessController controller) アクセスコントローラを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

APPLICATION_NAME

public static final String APPLICATION_NAME
アプリケーション名

関連項目:
定数フィールド値

ENTITY_CONTROLLER_DEPARTMENT_NAME

public static final String ENTITY_CONTROLLER_DEPARTMENT_NAME
関連項目:
定数フィールド値

ENTITY_CONTROLLER_NAME

public static final String ENTITY_CONTROLLER_NAME
エンティティ名

関連項目:
定数フィールド値

ENTITY_CONTROLLER_POST_NAME

public static final String ENTITY_CONTROLLER_POST_NAME
関連項目:
定数フィールド値

ENTITY_CONTROLLER_PUBLIC_GROUP_NAME

public static final String ENTITY_CONTROLLER_PUBLIC_GROUP_NAME
関連項目:
定数フィールド値

ENTITY_CONTROLLER_ROLE_NAME

public static final String ENTITY_CONTROLLER_ROLE_NAME
関連項目:
定数フィールド値
コンストラクタの詳細

StandardAccessControllerAccessor

public StandardAccessControllerAccessor()
メソッドの詳細

deleteController

public void deleteController(String groupId,
                             String controllerId)
                      throws AccessSecurityWriteException
アクセスコントローラを削除します。

定義:
インタフェース AccessControllerAccessor 内の deleteController
パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException

deleteControllerDepartment

public void deleteControllerDepartment(String groupId,
                                       String id,
                                       DepartmentInfo departmentInfo)
                                throws AccessSecurityWriteException
アクセスコントローラ組織を削除します。

定義:
インタフェース AccessControllerAccessor 内の deleteControllerDepartment
パラメータ:
groupId - ログイングループID
id - コントローラID
departmentInfo - 組織情報
例外:
AccessSecurityWriteException

deleteControllerDepartments

public void deleteControllerDepartments(String groupId,
                                        String id)
                                 throws AccessSecurityWriteException
すべてのアクセスコントローラ組織を削除します。

定義:
インタフェース AccessControllerAccessor 内の deleteControllerDepartments
パラメータ:
groupId - ログイングループID
id - アクセスコントローラID
例外:
AccessSecurityWriteException

deleteControllerPost

public void deleteControllerPost(String groupId,
                                 String id,
                                 PostInfo postInfo)
                          throws AccessSecurityWriteException
アクセスコントローラ役職を削除します。

定義:
インタフェース AccessControllerAccessor 内の deleteControllerPost
パラメータ:
groupId - ログイングループID
id - コントローラID
postInfo - 役職情報
例外:
AccessSecurityWriteException

deleteControllerPosts

public void deleteControllerPosts(String groupId,
                                  String id)
                           throws AccessSecurityWriteException
すべてのアクセスコントローラ役職を削除します。

定義:
インタフェース AccessControllerAccessor 内の deleteControllerPosts
パラメータ:
groupId - ログイングループID
id - コントローラID
例外:
AccessSecurityWriteException

deleteControllerPublicGroup

public void deleteControllerPublicGroup(String groupId,
                                        String id,
                                        PublicGroupInfo publicGroupInfo)
                                 throws AccessSecurityWriteException
アクセスコントローラパブリックグループを削除します。

定義:
インタフェース AccessControllerAccessor 内の deleteControllerPublicGroup
パラメータ:
groupId - ログイングループID
id - コントローラID
publicGroupInfo - パブリックグループ情報
例外:
AccessSecurityWriteException

deleteControllerPublicGroups

public void deleteControllerPublicGroups(String groupId,
                                         String id)
                                  throws AccessSecurityWriteException
すべてのアクセスコントローラパブリックグループを削除します。

定義:
インタフェース AccessControllerAccessor 内の deleteControllerPublicGroups
パラメータ:
groupId - ログイングループID
id - コントローラID
例外:
AccessSecurityWriteException

deleteControllerRole

public void deleteControllerRole(String groupId,
                                 String id,
                                 String roleId)
                          throws AccessSecurityWriteException
アクセスコントローラロールを削除します。

定義:
インタフェース AccessControllerAccessor 内の deleteControllerRole
パラメータ:
groupId - ログイングループID
id - コントローラID
roleId - ロールID
例外:
AccessSecurityWriteException

deleteControllerRoles

public void deleteControllerRoles(String groupId,
                                  String id)
                           throws AccessSecurityWriteException
すべてのアクセスコントローラロールを削除します。

定義:
インタフェース AccessControllerAccessor 内の deleteControllerRoles
パラメータ:
groupId - ログイングループID
id - コントローラID
例外:
AccessSecurityWriteException

getController

public AccessController getController(String groupId,
                                      String controllerId)
                               throws AccessSecurityReadException
アクセスコントローラ情報を取得します。

存在しない場合は、nullを返却します。

定義:
インタフェース AccessControllerAccessor 内の getController
パラメータ:
groupId - ログイングループID
controllerId - コントローラID
戻り値:
アクセスコントローラ情報
例外:
AccessSecurityReadException

getControllers

public AccessController[] getControllers(String groupId)
                                  throws AccessSecurityReadException
すべてのアクセスコントローラ情報を取得します。

一件も存在しない場合は、空の配列を返却します。

定義:
インタフェース AccessControllerAccessor 内の getControllers
パラメータ:
groupId - ログイングループID
戻り値:
アクセスコントローラ情報の配列
例外:
AccessSecurityReadException

getControllerDepartments

public DepartmentInfo[] getControllerDepartments(String groupId,
                                                 String id)
                                          throws AccessSecurityReadException
すべてのアクセスコントローラ組織を取得します。

一件も存在しない場合は、空の配列を返却します。

定義:
インタフェース AccessControllerAccessor 内の getControllerDepartments
パラメータ:
groupId - ログイングループID
id - コントローラID
戻り値:
組織情報の配列
例外:
AccessSecurityReadException

getControllerIds

public String[] getControllerIds(String groupId)
                          throws AccessSecurityReadException
すべてのアクセスコントローラIDを取得します。

一件も存在しない場合は、空の配列を返却します。

定義:
インタフェース AccessControllerAccessor 内の getControllerIds
パラメータ:
groupId - ログイングループID
戻り値:
クセスコントローラIDの配列
例外:
AccessSecurityReadException

getControllerIdsByDepartment

public String[] getControllerIdsByDepartment(String groupId,
                                             DepartmentInfo[] departments)
                                      throws AccessSecurityReadException
指定された組織を持つコントローラIDをすべて取得します。

定義:
インタフェース AccessControllerAccessor 内の getControllerIdsByDepartment
パラメータ:
groupId - ログイングループID
departments - 組織情報の配列
戻り値:
コントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerIdsByPost

public String[] getControllerIdsByPost(String groupId,
                                       PostInfo[] posts)
                                throws AccessSecurityReadException
指定された役職を持つコントローラIDをすべて取得します。

定義:
インタフェース AccessControllerAccessor 内の getControllerIdsByPost
パラメータ:
groupId - ログイングループID
posts - 役職情報の配列
戻り値:
コントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerIdsByPublicGroup

public String[] getControllerIdsByPublicGroup(String groupId,
                                              PublicGroupInfo[] publicGroups)
                                       throws AccessSecurityReadException
指定されたパブリックグループを持つコントローラIDをすべて取得します。

定義:
インタフェース AccessControllerAccessor 内の getControllerIdsByPublicGroup
パラメータ:
groupId - ログイングループID
publicGroups - パブリックグループの配列
戻り値:
コントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerIdsByRole

public String[] getControllerIdsByRole(String groupId,
                                       String[] roleIds)
                                throws AccessSecurityReadException
指定されたロールIDを持つコントローラIDをすべて取得します。

定義:
インタフェース AccessControllerAccessor 内の getControllerIdsByRole
パラメータ:
groupId - ログイングループID
roleIds - ロールIDの配列
戻り値:
コントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerPosts

public PostInfo[] getControllerPosts(String groupId,
                                     String id)
                              throws AccessSecurityReadException
すべてのアクセスコントローラ役職を取得します。

一件も存在しない場合は、空の配列を返却します。

定義:
インタフェース AccessControllerAccessor 内の getControllerPosts
パラメータ:
groupId - ログイングループID
id - コントローラID
戻り値:
役職情報の配列
例外:
AccessSecurityReadException

getControllerPublicGroups

public PublicGroupInfo[] getControllerPublicGroups(String groupId,
                                                   String id)
                                            throws AccessSecurityReadException
すべてのアクセスコントローラパブリックグループを取得します。

一件も存在しない場合は、空の配列を返却します。

定義:
インタフェース AccessControllerAccessor 内の getControllerPublicGroups
パラメータ:
groupId - ログイングループID
id - コントローラID
戻り値:
パブリックグループ情報の配列
例外:
AccessSecurityReadException

getControllerRoles

public String[] getControllerRoles(String groupId,
                                   String id)
                            throws AccessSecurityReadException
すべてのアクセスコントローラロールを取得します。

一件も存在しない場合は、空の配列を返却します。

定義:
インタフェース AccessControllerAccessor 内の getControllerRoles
パラメータ:
groupId - ログイングループID
id - コントローラID
戻り値:
アクセスコントローラロールIDの配列
例外:
AccessSecurityReadException

getLoginUser

protected String getLoginUser()
ログインユーザを取得します。
ログインユーザの取得に失敗した場合は空文字列を返却します。

戻り値:
ログインユーザID

init

public void init(Map params)
アクセスコントローラアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース AccessControllerAccessor 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

insertAccessController

public void insertAccessController(String groupId,
                                   AccessController controller)
                            throws AccessSecurityWriteException
アクセスコントローラを作成します。

定義:
インタフェース AccessControllerAccessor 内の insertAccessController
パラメータ:
groupId - ログイングループID
controller - アクセスコントローラ情報
例外:
AccessSecurityWriteException

insertControllerDepartment

public void insertControllerDepartment(String groupId,
                                       String id,
                                       DepartmentInfo departmentInfo)
                                throws AccessSecurityWriteException
アクセスコントローラ組織を新規に作成します。

定義:
インタフェース AccessControllerAccessor 内の insertControllerDepartment
パラメータ:
groupId - ログイングループID
id - コントローラID
departmentInfo - 組織情報
例外:
AccessSecurityWriteException

insertControllerPost

public void insertControllerPost(String groupId,
                                 String id,
                                 PostInfo postInfo)
                          throws AccessSecurityWriteException
アクセスコントローラ役職を新規に作成します。

定義:
インタフェース AccessControllerAccessor 内の insertControllerPost
パラメータ:
groupId - ログイングループID
id - コントローラID
postInfo - 役職情報
例外:
AccessSecurityWriteException

insertControllerPublicGroup

public void insertControllerPublicGroup(String groupId,
                                        String id,
                                        PublicGroupInfo publicGroupInfo)
                                 throws AccessSecurityWriteException
アクセスコントローラパブリックグループを新規に作成します。

定義:
インタフェース AccessControllerAccessor 内の insertControllerPublicGroup
パラメータ:
groupId - ログイングループID
id - コントローラID
publicGroupInfo - パブリックグループ情報
例外:
AccessSecurityWriteException

insertControllerRole

public void insertControllerRole(String groupId,
                                 String id,
                                 String roleId)
                          throws AccessSecurityWriteException
アクセスコントローラロールを新規に作成します。

定義:
インタフェース AccessControllerAccessor 内の insertControllerRole
パラメータ:
groupId - ログイングループID
id - コントローラID
roleId - ロールID
例外:
AccessSecurityWriteException

updateController

public void updateController(String groupId,
                             AccessController controller)
                      throws AccessSecurityWriteException
アクセスコントローラを更新します。

定義:
インタフェース AccessControllerAccessor 内の updateController
パラメータ:
groupId - ログイングループID
controller - アクセスコントローラ情報
例外:
AccessSecurityWriteException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardAccountAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス StandardAccountAccessor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.StandardAccountAccessor
すべての実装インタフェース:
AccountAccessor
public class StandardAccountAccessor
extends Object
implements AccountAccessor

アカウントアクセッサクラス。

アカウント情報の読み込みおよび書き込みのクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String | APPLICATION_NAME アプリケーション名
static String | ENTITY_NAME_ACCOUNT エンティティ名
static String | ENTITY_NAME_ACCOUNT_ATTRIBUTE
static String | ENTITY_NAME_ACCOUNT_ROLE
static String | ENTITY_NAME_FAVORITE_MENU
static String | ID_CRYPTION_CLASS 暗号化クラス名
コンストラクタの概要
StandardAccountAccessor()
コンストラクタ。
メソッドの概要
void | deleteAccount(String groupId, String userId) アカウント情報を削除する。
void | deleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報を削除する。
void | deleteAttribute(String groupId, String userId, String name) アカウント属性情報を削除する。
void | deleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を削除する。
Account | getAccount(String groupId, String userId) アカウント情報を取得する。
int | getAccountCount(String groupId) アカウント数を取得する。
AccountRole | getAccountRole(String groupId, String userId, String roleId) アカウントロール情報を取得する。
String[] | getAccountRoleIds(String groupId, String userId) アカウントロールIDをすべて取得する。
AccountRole[] | getAccountRoles(String groupId, String userId) アカウントロール情報をすべて取得する。
Account[] | getAccountsByUserIds(String groupId, String[] userIds) 指定されたユーザIDのアカウント情報をすべて取得する。
String | getAttribute(String groupId, String userId, String name) アカウント属性情報を取得する。
String[] | getAttributeNames(String groupId, String userId) アカウント属性名の一覧を取得する。
FavoriteMenu | getFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を取得する。
String[] | getFavoriteMenuIds(String groupId, String userId) マイメニューIDをすべて取得する。
FavoriteMenu[] | getFavoriteMenus(String groupId, String userId) マイメニュー情報をすべて取得する。
protected String | getLoginUser() ログインユーザを取得します。
String[] | getUserIds(String groupId) ユーザIDの一覧を取得する。
String[] | getUserIdsByAccountRole(String groupId, String roleId) 引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
String[] | getUserIdsByAttribute(String groupId, String key, String value) アカウント属性情報の値と一致するユーザIDを取得する。
String[] | getUserIdsByRoles(String groupId, String[] roleIds, Date date) 指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
protected String[] | getUserIdsByRolesIn(String groupId, String[] roleIds, Date date) 指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
protected String[] | getUserIdsByRolesPlural(String groupId, String[] roleIds, Date date) 指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
void | init(Map params) アカウントアクセッサの初期化。
void | insertAccount(String groupId, Account account) アカウント情報を新規追加する。
void | insertAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を新規追加する。
void | insertFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を新規追加する。
Account[] | searchAccounts(String groupId, String userId) アカウント情報の読み込みます。
void | setAttribute(String groupId, String userId, String name, String value) アカウント属性情報を設定する。
void | updateAccount(String groupId, Account account) アカウント情報を更新する。
void | updateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を更新する。
void | updateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を更新する。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

APPLICATION_NAME

public static final String APPLICATION_NAME
アプリケーション名

関連項目:
定数フィールド値

ENTITY_NAME_ACCOUNT

public static final String ENTITY_NAME_ACCOUNT
エンティティ名

関連項目:
定数フィールド値

ENTITY_NAME_ACCOUNT_ROLE

public static final String ENTITY_NAME_ACCOUNT_ROLE
関連項目:
定数フィールド値

ENTITY_NAME_FAVORITE_MENU

public static final String ENTITY_NAME_FAVORITE_MENU
関連項目:
定数フィールド値

ENTITY_NAME_ACCOUNT_ATTRIBUTE

public static final String ENTITY_NAME_ACCOUNT_ATTRIBUTE
関連項目:
定数フィールド値

ID_CRYPTION_CLASS

public static final String ID_CRYPTION_CLASS
暗号化クラス名

関連項目:
定数フィールド値
コンストラクタの詳細

StandardAccountAccessor

public StandardAccountAccessor()
コンストラクタ。

メソッドの詳細

getUserIdsByRolesIn

protected String[] getUserIdsByRolesIn(String groupId,
                                       String[] roleIds,
                                       Date date)
                                throws AccessSecurityReadException
指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。

ロールID一覧を条件につなげてSQL一回発行版

パラメータ:
groupId - ログイングループID
roleIds - 検証用ロールIDの一覧
date - 有効期間判定用の日付
戻り値:
有効なアカウントロールを持つアカウントのユーザIDの配列
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

getUserIdsByRolesPlural

protected String[] getUserIdsByRolesPlural(String groupId,
                                           String[] roleIds,
                                           Date date)
                                    throws AccessSecurityReadException
指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。

ロールID一覧分SQL発行版

パラメータ:
groupId - ログイングループID
roleIds - 検証用ロールIDの一覧
date - 有効期間判定用の日付
戻り値:
有効なアカウントロールを持つアカウントのユーザIDの配列
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

getLoginUser

protected String getLoginUser()
ログインユーザを取得します。
ログインユーザの取得に失敗した場合は空文字列を返却します。

戻り値:
ログインユーザID

deleteAccount

public void deleteAccount(String groupId,
                          String userId)
                   throws AccessSecurityWriteException,
                          NotExistException
アカウント情報を削除する。

定義:
インタフェース AccountAccessor 内の deleteAccount
パラメータ:
groupId - ログイングループID
userId - 削除するユーザコード
例外:
AccessSecurityWriteException - アカウント情報の削除に失敗した場合スローされます。
NotExistException - 削除するアカウント情報が存在しない場合にスローされます。

deleteAccountRole

public void deleteAccountRole(String groupId,
                              String userId,
                              String roleId)
                       throws AccessSecurityWriteException,
                              NotExistException
アカウントロール情報を削除する。

アカウントに紐付くアカウントロール情報を削除します。

定義:
インタフェース AccountAccessor 内の deleteAccountRole
パラメータ:
groupId - ログイングループID
userId - ユーザID
roleId - ロールID
例外:
AccessSecurityWriteException - アカウントロール情報の削除に失敗した場合スローされます。
NotExistException - 削除するアカウントロール情報が存在しない場合にスローされます。

deleteFavoriteMenu

public void deleteFavoriteMenu(String groupId,
                               String userId,
                               String menuId)
                        throws AccessSecurityWriteException,
                               NotExistException
マイメニュー情報を削除する。

アカウントに紐付くマイメニュー情報を削除します。

定義:
インタフェース AccountAccessor 内の deleteFavoriteMenu
パラメータ:
groupId - ログイングループID
userId - ユーザID
menuId - メニューID
例外:
AccessSecurityWriteException - マイメニュー情報の削除に失敗した場合スローされます。
NotExistException - 削除するマイメニュー情報が存在しない場合にスローされます。

getAccount

public Account getAccount(String groupId,
                          String userId)
                   throws AccessSecurityReadException
アカウント情報を取得する。

定義:
インタフェース AccountAccessor 内の getAccount
パラメータ:
groupId - ログイングループID
userId - ユーザIDの完全一致名
戻り値:
ユーザアカウントオブジェクト
存在しない場合は、nullを返却します。
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

getAccountCount

public int getAccountCount(String groupId)
                    throws AccessSecurityReadException
アカウント数を取得する。

定義:
インタフェース AccountAccessor 内の getAccountCount
パラメータ:
groupId - ログイングループID
戻り値:
ユーザアカウント数
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

getAccountRole

public AccountRole getAccountRole(String groupId,
                                  String userId,
                                  String roleId)
                           throws AccessSecurityReadException
アカウントロール情報を取得する。

アカウントに紐付くアカウントロール情報を取得します。

定義:
インタフェース AccountAccessor 内の getAccountRole
パラメータ:
groupId - ログイングループID
userId - ユーザID
roleId - ロールID
戻り値:
ユーザアカウントロール情報
存在しない場合は、nullを返却します。
例外:
AccessSecurityReadException - アカウントロール情報取得に失敗した場合スローされます。

getAccountRoleIds

public String[] getAccountRoleIds(String groupId,
                                  String userId)
                           throws AccessSecurityReadException
アカウントロールIDをすべて取得する。

アカウントに紐付くアカウントロールIDをすべて取得します。

定義:
インタフェース AccountAccessor 内の getAccountRoleIds
パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
ユーザアカウントロール情報の配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - アカウントロール情報取得に失敗した場合スローされます。

getAccountRoles

public AccountRole[] getAccountRoles(String groupId,
                                     String userId)
                              throws AccessSecurityReadException
アカウントロール情報をすべて取得する。

アカウントに紐付くアカウントロール情報をすべて取得します。

定義:
インタフェース AccountAccessor 内の getAccountRoles
パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
ユーザアカウントロール情報の配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - アカウントロール情報取得に失敗した場合スローされます。

getAccountsByUserIds

public Account[] getAccountsByUserIds(String groupId,
                                      String[] userIds)
                               throws AccessSecurityReadException
指定されたユーザIDのアカウント情報をすべて取得する。

定義:
インタフェース AccountAccessor 内の getAccountsByUserIds
パラメータ:
groupId - ログイングループID
userIds - ユーザIDの配列
戻り値:
ユーザアカウントオブジェクトの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

getFavoriteMenu

public FavoriteMenu getFavoriteMenu(String groupId,
                                    String userId,
                                    String menuId)
                             throws AccessSecurityReadException
マイメニュー情報を取得する。

アカウントに紐付くマイメニュー情報を取得します。

定義:
インタフェース AccountAccessor 内の getFavoriteMenu
パラメータ:
groupId - ログイングループID
userId - ユーザID
menuId - メニューID
戻り値:
マイメニュー情報
存在しない場合は、nullを返却します。
例外:
AccessSecurityReadException - マイメニュー情報取得に失敗した場合スローされます。

getFavoriteMenuIds

public String[] getFavoriteMenuIds(String groupId,
                                   String userId)
                            throws AccessSecurityReadException
マイメニューIDをすべて取得する。

アカウントに紐付くマイメニューIDをすべて取得します。

定義:
インタフェース AccountAccessor 内の getFavoriteMenuIds
パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
マイメニュー情報の配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - マイメニュー情報取得に失敗した場合スローされます。

getFavoriteMenus

public FavoriteMenu[] getFavoriteMenus(String groupId,
                                       String userId)
                                throws AccessSecurityReadException
マイメニュー情報をすべて取得する。

アカウントに紐付くマイメニュー情報をすべて取得します。

定義:
インタフェース AccountAccessor 内の getFavoriteMenus
パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
マイメニュー情報の配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - マイメニュー情報取得に失敗した場合スローされます。

getUserIds

public String[] getUserIds(String groupId)
                    throws AccessSecurityReadException
ユーザIDの一覧を取得する。

定義:
インタフェース AccountAccessor 内の getUserIds
パラメータ:
groupId - ログイングループID
戻り値:
ユーザIDの配列
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

getUserIdsByAccountRole

public String[] getUserIdsByAccountRole(String groupId,
                                        String roleId)
                                 throws AccessSecurityReadException
引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。 引数で指定したアカウントロールを持つアカウントのユーザIDの一覧を返却します。
指定したアカウントロールの階層のチェックはお行いません。

定義:
インタフェース AccountAccessor 内の getUserIdsByAccountRole
パラメータ:
groupId - ログイングループID
roleId - String アカウントロールのロールID
戻り値:
ユーザIDの配列（データがない場合は空の配列を返します）
例外:
AccessSecurityReadException - アカウント情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getUserIdsByRoles

public String[] getUserIdsByRoles(String groupId,
                                  String[] roleIds,
                                  Date date)
                           throws AccessSecurityReadException
指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。

定義:
インタフェース AccountAccessor 内の getUserIdsByRoles
パラメータ:
groupId - ログイングループID
roleIds - 検証用ロールIDの一覧
date - 有効期間判定用の日付
戻り値:
有効なアカウントロールを持つアカウントのユーザIDの配列
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

init

public void init(Map params)
アカウントアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース AccountAccessor 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

insertAccount

public void insertAccount(String groupId,
                          Account account)
                   throws AccessSecurityWriteException,
                          DuplicateException
アカウント情報を新規追加する。

定義:
インタフェース AccountAccessor 内の insertAccount
パラメータ:
groupId - ログイングループID
account - アカウント情報
例外:
AccessSecurityWriteException - アカウント情報の作成に失敗した場合スローされます。
DuplicateException - 追加するアカウント情報が既に存在した場合スローされます。

insertAccountRole

public void insertAccountRole(String groupId,
                              String userId,
                              AccountRole accountRole)
                       throws AccessSecurityWriteException,
                              DuplicateException
アカウントロール情報を新規追加する。

アカウントに紐付くアカウントロール情報を新規に追加します。

定義:
インタフェース AccountAccessor 内の insertAccountRole
パラメータ:
groupId - ログイングループID
userId - ユーザID
accountRole - アカウントロール情報
例外:
AccessSecurityWriteException - アカウントロール情報の作成に失敗した場合スローされます。
DuplicateException - 追加するアカウントロール情報が既に存在した場合スローされます。

insertFavoriteMenu

public void insertFavoriteMenu(String groupId,
                               String userId,
                               FavoriteMenu favoriteMenu)
                        throws AccessSecurityWriteException,
                               DuplicateException
マイメニュー情報を新規追加する。

アカウントに紐付くマイメニュー情報を新規に追加します。

定義:
インタフェース AccountAccessor 内の insertFavoriteMenu
パラメータ:
groupId - ログイングループID
userId - ユーザID
favoriteMenu - マイメニュー情報
例外:
AccessSecurityWriteException - マイメニュー情報の作成に失敗した場合スローされます。
DuplicateException - 追加するマイメニュー情報が既に存在した場合スローされます。

searchAccounts

public Account[] searchAccounts(String groupId,
                                String userId)
                         throws AccessSecurityReadException
アカウント情報の読み込みます。 ユーザIDまたはユーザIDの一部をキーとして検索し、マッチしたアカウント情報を返します。
ただし、以下の文字列を特殊文字列として扱う。
* 0以上の長さの文字列とマッチ
? 1文字の文字列とマッチ

定義:
インタフェース AccountAccessor 内の searchAccounts
パラメータ:
groupId - ログイングループID
userId - ユーザID（検索キー）
戻り値:
アカウント情報配列
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

updateAccount

public void updateAccount(String groupId,
                          Account account)
                   throws AccessSecurityWriteException,
                          NotExistException
アカウント情報を更新する。

定義:
インタフェース AccountAccessor 内の updateAccount
パラメータ:
groupId - ログイングループID
account - アカウント情報
例外:
AccessSecurityWriteException - アカウント情報の更新に失敗した場合スローされます。
NotExistException - 更新するアカウント情報が存在しない場合にスローされます。

updateAccountRole

public void updateAccountRole(String groupId,
                              String userId,
                              AccountRole accountRole)
                       throws AccessSecurityWriteException,
                              NotExistException
アカウントロール情報を更新する。

アカウントに紐付くアカウントロール情報を更新します。

定義:
インタフェース AccountAccessor 内の updateAccountRole
パラメータ:
groupId - ログイングループID
userId - ユーザID
accountRole - アカウントロール情報
例外:
AccessSecurityWriteException - アカウントロール情報の更新に失敗した場合スローされます。
NotExistException - 更新するアカウントロール情報が存在しない場合にスローされます。

updateFavoriteMenu

public void updateFavoriteMenu(String groupId,
                               String userId,
                               FavoriteMenu favoriteMenu)
                        throws AccessSecurityWriteException,
                               NotExistException
マイメニュー情報を更新する。

アカウントに紐付くマイメニュー情報を更新します。

定義:
インタフェース AccountAccessor 内の updateFavoriteMenu
パラメータ:
groupId - ログイングループID
userId - ユーザID
favoriteMenu - マイメニュー情報
例外:
AccessSecurityWriteException - マイメニュー情報の更新に失敗した場合スローされます。
NotExistException - 更新するマイメニュー情報が存在しない場合にスローされます。

getAttribute

public String getAttribute(String groupId,
                           String userId,
                           String name)
                    throws AccessSecurityReadException
アカウント属性情報を取得する。

定義:
インタフェース AccountAccessor 内の getAttribute
パラメータ:
groupId - ログイングループID
userId - ユーザID
name - 属性名
戻り値:
アカウント属性値
存在しない場合は、nullを返却します。
例外:
AccessSecurityReadException - アカウント属性情報の取得に失敗した場合スローされます。

getAttributeNames

public String[] getAttributeNames(String groupId,
                                  String userId)
                           throws AccessSecurityReadException
アカウント属性名の一覧を取得する。

定義:
インタフェース AccountAccessor 内の getAttributeNames
パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
アカウント属性の名前の一覧
存在しない場合は空の配列を返却します。
例外:
AccessSecurityReadException - アカウント属性情報の取得に失敗した場合スローされます。

setAttribute

public void setAttribute(String groupId,
                         String userId,
                         String name,
                         String value)
                  throws AccessSecurityWriteException
アカウント属性情報を設定する。
引数で指定した属性名に一致する属性情報が存在しない場合は、新規登録します。
引数で指定した属性名に一致する属性情報がすでに存在する場合は、指定された属性値で更新します。

定義:
インタフェース AccountAccessor 内の setAttribute
パラメータ:
groupId - ログイングループID
userId - ユーザID
name - 属性名
value - 属性値
例外:
AccessSecurityWriteException - アカウント情報の設定に失敗した場合スローされます。

deleteAttribute

public void deleteAttribute(String groupId,
                            String userId,
                            String name)
                     throws AccessSecurityWriteException,
                            NotExistException
アカウント属性情報を削除する。

定義:
インタフェース AccountAccessor 内の deleteAttribute
パラメータ:
groupId - ログイングループID
userId - ユーザID
name - 属性名
例外:
AccessSecurityWriteException - アカウント属性情報の削除に失敗した場合スローされます。
NotExistException - 削除するアカウント情報が存在しない場合にスローされます。

getUserIdsByAttribute

public String[] getUserIdsByAttribute(String groupId,
                                      String key,
                                      String value)
                               throws AccessSecurityReadException
アカウント属性情報の値と一致するユーザIDを取得する。

定義:
インタフェース AccountAccessor 内の getUserIdsByAttribute
パラメータ:
groupId - ログイングループID
key - 検索対象の属性キー名
value - 検索値
戻り値:
ユーザIDの一覧
存在しない場合は空の配列を返却します。
例外:
AccessSecurityReadException - アカウント属性情報の取得に失敗した場合スローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardBatchAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス StandardBatchAccessor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.StandardBatchAccessor
すべての実装インタフェース:
BatchAccessor
public class StandardBatchAccessor
extends Object
implements BatchAccessor

バッチアクセッサクラス。

バッチ情報の読み込みおよび書き込みクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String | APPLICATION_NAME アプリケーション名
static String | ENTITY_NAME エンティティ名
コンストラクタの概要
StandardBatchAccessor()
コンストラクタ。
メソッドの概要
void | deleteBatch(String groupId, String batchId) バッチを削除します。
Batch | getBatch(String groupId, String batchId) バッチを取得します。
Batch[] | getBatches(String groupId) バッチの一覧を取得します。
Batch[] | getBatchesByIds(String groupId, String[] batchIds) 引数に指定したバッチIDのバッチ情報をすべて取得します。
String[] | getBatchIds(String groupId) バッチIDの一覧を取得します。
protected String | getLoginUser() ログインユーザを取得します。
void | init(Map params) 初期化します。
void | insertBatch(String groupId, Batch batch) バッチを登録します。
void | updateBatch(String groupId, Batch batch) バッチを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

APPLICATION_NAME

public static final String APPLICATION_NAME
アプリケーション名

関連項目:
定数フィールド値

ENTITY_NAME

public static final String ENTITY_NAME
エンティティ名

関連項目:
定数フィールド値
コンストラクタの詳細

StandardBatchAccessor

public StandardBatchAccessor()
コンストラクタ。

メソッドの詳細

getLoginUser

protected String getLoginUser()
ログインユーザを取得します。
ログインユーザの取得に失敗した場合は空文字列を返却します。

戻り値:
ログインユーザID

deleteBatch

public void deleteBatch(String groupId,
                        String batchId)
                 throws AccessSecurityWriteException,
                        NotExistException
バッチを削除します。

定義:
インタフェース BatchAccessor 内の deleteBatch
パラメータ:
groupId - グル－プID
batchId - バッチID
例外:
AccessSecurityWriteException - データの削除に失敗した場合にスローされます。
NotExistException - 削除対象のデータが存在しない場合スローされます。

getBatch

public Batch getBatch(String groupId,
                      String batchId)
               throws AccessSecurityReadException
バッチを取得します。

定義:
インタフェース BatchAccessor 内の getBatch
パラメータ:
groupId - グループID
batchId - バッチID
戻り値:
バッチ情報
例外:
AccessSecurityReadException - データの読み込みに失敗した場合にスローされます。

getBatches

public Batch[] getBatches(String groupId)
                   throws AccessSecurityReadException
バッチの一覧を取得します。

バッチIDで昇順でソートされたバッチの一覧を取得します。

定義:
インタフェース BatchAccessor 内の getBatches
パラメータ:
groupId - グループID
戻り値:
バッチ配列
例外:
AccessSecurityReadException - データの読み込みに失敗した場合にスローされます。

getBatchesByIds

public Batch[] getBatchesByIds(String groupId,
                               String[] batchIds)
                        throws AccessSecurityReadException
引数に指定したバッチIDのバッチ情報をすべて取得します。

引数に指定したバッチIDの順でソートされたバッチ情報を取得します。 一件も存在しない場合は、空の配列を返却します。

定義:
インタフェース BatchAccessor 内の getBatchesByIds
パラメータ:
groupId - ログイングループID
batchIds - バッチIDの配列
戻り値:
取得されたバッチの配列
例外:
AccessSecurityReadException - バッチ情報の取得に失敗した場合スローされます。

getBatchIds

public String[] getBatchIds(String groupId)
                     throws AccessSecurityReadException
バッチIDの一覧を取得します。

バッチIDで昇順でソートされたバッチIDの一覧を取得します。

定義:
インタフェース BatchAccessor 内の getBatchIds
パラメータ:
groupId - グループID
戻り値:
バッチID配列
例外:
AccessSecurityReadException - データの取得に失敗した場合にスローされます。

init

public void init(Map params)
初期化します。

定義:
インタフェース BatchAccessor 内の init
パラメータ:
params - 初期化パラメータ

insertBatch

public void insertBatch(String groupId,
                        Batch batch)
                 throws AccessSecurityWriteException,
                        DuplicateException
バッチを登録します。

定義:
インタフェース BatchAccessor 内の insertBatch
パラメータ:
groupId - バッチID
batch - バッチ情報
例外:
AccessSecurityWriteException - データの登録に失敗した場合にスローされます。
DuplicateException - キーが重複した場合にスローされます。

updateBatch

public void updateBatch(String groupId,
                        Batch batch)
                 throws AccessSecurityWriteException,
                        NotExistException
バッチを更新します。

定義:
インタフェース BatchAccessor 内の updateBatch
パラメータ:
groupId - グループID
batch - バッチ情報
例外:
AccessSecurityWriteException - データの更新に失敗した場合にスローされます。
NotExistException - 更新データがない場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardCalendarAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス StandardCalendarAccessor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.StandardCalendarAccessor
すべての実装インタフェース:
CalendarAccessor
public class StandardCalendarAccessor
extends Object
implements CalendarAccessor

カレンダーアクセッサクラス。

カレンダー情報の読み込みおよび書き込みクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String | APPLICATION_NAME アプリケーション名
static String | ENTITY_NAME エンティティ名
コンストラクタの概要
StandardCalendarAccessor()
コンストラクタ。
メソッドの概要
void | deleteCalendar(String groupId, String calendarId) カレンダーを削除します。
void | deleteCalendarInfo(String groupId, String calendarId, String dataId) 指定されたカレンダーデータを削除します。
String[] | getCalendarIds(String groupId) すべてのカレンダーIDを取得します。
CalendarInfo | getCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータを取得します。
String[] | getCalendarInfoIds(String groupId, String calendarId) すべてのカレンダーデータIDを取得します。
CalendarInfo[] | getCalendarInfos(String groupId, String calendarId) すべてのカレンダーデータを取得します。
CalendarInfo[] | getCalendarInfosByIds(String groupId, String calendarId, String[] calendarInfoIds) 指定されたカレンダーデータIDのカレンダー情報をすべて取得する。
protected String | getLoginUser() ログインユーザを取得します。
void | init(Map params) カレンダーアクセッサの初期化。
void | insertCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に作成します。
void | updateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

APPLICATION_NAME

public static final String APPLICATION_NAME
アプリケーション名

関連項目:
定数フィールド値

ENTITY_NAME

public static final String ENTITY_NAME
エンティティ名

関連項目:
定数フィールド値
コンストラクタの詳細

StandardCalendarAccessor

public StandardCalendarAccessor()
コンストラクタ。

メソッドの詳細

getLoginUser

protected String getLoginUser()
ログインユーザを取得します。
ログインユーザの取得に失敗した場合は空文字列を返却します。

戻り値:
ログインユーザID

deleteCalendar

public void deleteCalendar(String groupId,
                           String calendarId)
                    throws AccessSecurityWriteException,
                           NotExistException
カレンダーを削除します。

定義:
インタフェース CalendarAccessor 内の deleteCalendar
パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
例外:
AccessSecurityWriteException
NotExistException

deleteCalendarInfo

public void deleteCalendarInfo(String groupId,
                               String calendarId,
                               String dataId)
                        throws AccessSecurityWriteException,
                               NotExistException
指定されたカレンダーデータを削除します。

定義:
インタフェース CalendarAccessor 内の deleteCalendarInfo
パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
dataId - カレンダーデータID
例外:
AccessSecurityWriteException
NotExistException

getCalendarIds

public String[] getCalendarIds(String groupId)
                        throws AccessSecurityReadException
すべてのカレンダーIDを取得します。
カレンダーIDが存在しない場合は空の配列を返却します。

定義:
インタフェース CalendarAccessor 内の getCalendarIds
パラメータ:
groupId - ログイングループID
戻り値:
カレンダーIDの配列
例外:
AccessSecurityReadException

getCalendarInfo

public CalendarInfo getCalendarInfo(String groupId,
                                    String calendarId,
                                    String dataId)
                             throws AccessSecurityReadException
カレンダーデータを取得します。

定義:
インタフェース CalendarAccessor 内の getCalendarInfo
パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
dataId - カレンダーデータID
戻り値:
カレンダーデータ
例外:
AccessSecurityReadException

getCalendarInfoIds

public String[] getCalendarInfoIds(String groupId,
                                   String calendarId)
                            throws AccessSecurityReadException
すべてのカレンダーデータIDを取得します。

カレンダーデータIDが存在しない場合は空の配列を返却します。

定義:
インタフェース CalendarAccessor 内の getCalendarInfoIds
パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
戻り値:
カレンダーデータIDの配列
例外:
AccessSecurityReadException

getCalendarInfos

public CalendarInfo[] getCalendarInfos(String groupId,
                                       String calendarId)
                                throws AccessSecurityReadException
すべてのカレンダーデータを取得します。

カレンダーデータが存在しない場合は空の配列を返却します。

定義:
インタフェース CalendarAccessor 内の getCalendarInfos
パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
戻り値:
カレンダーデータの配列
例外:
AccessSecurityReadException

getCalendarInfosByIds

public CalendarInfo[] getCalendarInfosByIds(String groupId,
                                            String calendarId,
                                            String[] calendarInfoIds)
                                     throws AccessSecurityReadException
指定されたカレンダーデータIDのカレンダー情報をすべて取得する。

定義:
インタフェース CalendarAccessor 内の getCalendarInfosByIds
パラメータ:
groupId - ログイングループID
calendarId - カレンダーIDの配列
calendarInfoIds - カレンダーデータIDの配列
戻り値:
カレンダーオブジェクトの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - カレンダー情報取得に失敗した場合スローされます。

init

public void init(Map params)
カレンダーアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース CalendarAccessor 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

insertCalendarInfo

public void insertCalendarInfo(String groupId,
                               String calendarId,
                               CalendarInfo calendarInfo)
                        throws AccessSecurityWriteException,
                               DuplicateException
カレンダーデータを新規に作成します。

定義:
インタフェース CalendarAccessor 内の insertCalendarInfo
パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfo - カレンダーデータ
例外:
AccessSecurityWriteException
DuplicateException

updateCalendarInfo

public void updateCalendarInfo(String groupId,
                               String calendarId,
                               CalendarInfo calendarInfo)
                        throws AccessSecurityWriteException,
                               NotExistException
カレンダーデータを更新します。

定義:
インタフェース CalendarAccessor 内の updateCalendarInfo
パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfo - カレンダーデータ
例外:
AccessSecurityWriteException
NotExistException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardMenuAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス StandardMenuAccessor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.StandardMenuAccessor
すべての実装インタフェース:
MenuAccessor
public class StandardMenuAccessor
extends Object
implements MenuAccessor

メニューアクセッサクラス。

メニュー情報の読み込みおよび書き込みクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String | APPLICATION_NAME アプリケーション名
static String | ENTITY_NAME_MENU メニュー エンティティ名
static String | ENTITY_NAME_MENU_ARGUMENT メニュー引数 エンティティ名
static String | ENTITY_NAME_MENU_DEPARTMENT メニュー組織 エンティティ名
static String | ENTITY_NAME_MENU_POST メニュー役職 エンティティ名
static String | ENTITY_NAME_MENU_PUBLIC_GROUP メニューパブリックグループ エンティティ名
static String | ENTITY_NAME_MENU_ROLE メニューロール エンティティ名
コンストラクタの概要
StandardMenuAccessor()
コンストラクタ。
メソッドの概要
void | deleteMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を削除します。
void | deleteMenuDepartments(String groupId, String id) すべてのメニュー組織を削除します。
void | deleteMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を削除します。
void | deleteMenuItem(String groupId, String id) 引数で渡されたノードを削除します。
void | deleteMenuPost(String groupId, String id, PostInfo postInfo) メニュー役職を削除します。
void | deleteMenuPosts(String groupId, String id) すべてのメニュー役職を削除します。
void | deleteMenuPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) メニューパブリックグループを削除します。
void | deleteMenuPublicGroups(String groupId, String id) すべてのメニューパブリックグループを削除します。
void | deleteMenuRole(String groupId, String id, String roleId) メニューロールを削除します。
void | deleteMenuRoles(String groupId, String menuId) すべてのメニューロールを削除します。
String[] | getChildMenuIds(String groupId, String menuId) 引数で指定されたノードの直下の子メニューIDを配列で取得します。
String[] | getFirstMenuIds(String groupId) 第一階層に属するメニューIDを配列で取得します。
protected String | getLoginUser() ログインユーザを取得します。
DepartmentInfo[] | getMenuDepartments(String groupId, String id) すべてのメニュー組織を取得します。
String[] | getMenuIds(String groupId) すべてのメニューIDを取得します。
String[] | getMenuIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つメニューIDをすべて取得します。
String[] | getMenuIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つメニューIDをすべて取得します。
String[] | getMenuIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つメニューIDをすべて取得します。
String[] | getMenuIdsByRole(String groupId, String[] roleIds) 指定されたロールIDを持つメニューIDをすべて取得します。
MenuInclusion[] | getMenuInclusions(String groupId) すべてのメニュー構成を取得します。
MenuItem | getMenuItem(String groupId, String menuId) 指定されたメニューIDに対するノードを取得します。
MenuItem[] | getMenuItems(String groupId) すべてのノードを取得します。
MenuItem[] | getMenuItemsByIds(String groupId, String[] menuIds) 指定されたメニューIDのメニュー情報をすべて取得します。
PostInfo[] | getMenuPosts(String groupId, String id) すべてのメニュー役職を取得します。
PublicGroupInfo[] | getMenuPublicGroups(String groupId, String id) すべてのメニューパブリックグループを取得します。
String[] | getMenuRoles(String groupId, String menuId) すべてのメニューロールを取得します。
String | getParentMenuId(String groupId, String menuId) 引数で指定されたノードの親ノードを取得します。
void | init(Map params) メニューアクセッサの初期化。
void | insertMenuDepartment(String groupId, String menuId, DepartmentInfo departmentInfo) メニュー組織を新規に作成します。
void | insertMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を新規に作成します。
void | insertMenuItem(String groupId, MenuItem menuItem, String parentId) 引数で渡されたノードを新規追加します。
void | insertMenuPost(String groupId, String menuId, PostInfo postInfo) メニュー役職を新規に作成します。
void | insertMenuPublicGroup(String groupId, String menuId, PublicGroupInfo publicGroupInfo) メニューパブリックグループを新規に作成します。
void | insertMenuRole(String groupId, String menuId, String roleId) メニューロールを新規に作成します。
void | updateMenuItem(String groupId, MenuItem menuItem) 引数で渡されたノードを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

APPLICATION_NAME

public static final String APPLICATION_NAME
アプリケーション名

関連項目:
定数フィールド値

ENTITY_NAME_MENU

public static final String ENTITY_NAME_MENU
メニュー エンティティ名

関連項目:
定数フィールド値

ENTITY_NAME_MENU_ARGUMENT

public static final String ENTITY_NAME_MENU_ARGUMENT
メニュー引数 エンティティ名

関連項目:
定数フィールド値

ENTITY_NAME_MENU_DEPARTMENT

public static final String ENTITY_NAME_MENU_DEPARTMENT
メニュー組織 エンティティ名

関連項目:
定数フィールド値

ENTITY_NAME_MENU_POST

public static final String ENTITY_NAME_MENU_POST
メニュー役職 エンティティ名

関連項目:
定数フィールド値

ENTITY_NAME_MENU_PUBLIC_GROUP

public static final String ENTITY_NAME_MENU_PUBLIC_GROUP
メニューパブリックグループ エンティティ名

関連項目:
定数フィールド値

ENTITY_NAME_MENU_ROLE

public static final String ENTITY_NAME_MENU_ROLE
メニューロール エンティティ名

関連項目:
定数フィールド値
コンストラクタの詳細

StandardMenuAccessor

public StandardMenuAccessor()
コンストラクタ。

メソッドの詳細

getLoginUser

protected String getLoginUser()
ログインユーザを取得します。
ログインユーザの取得に失敗した場合は空文字列を返却します。

戻り値:
ログインユーザID

deleteMenuDepartment

public void deleteMenuDepartment(String groupId,
                                 String id,
                                 DepartmentInfo departmentInfo)
                          throws AccessSecurityWriteException,
                                 NotExistException
メニュー組織を削除します。

定義:
インタフェース MenuAccessor 内の deleteMenuDepartment
パラメータ:
groupId - ログイングループID
id - メニューID
departmentInfo - 組織情報
例外:
AccessSecurityWriteException - メニュー組織の削除に失敗した場合にスローされます。
NotExistException

deleteMenuDepartments

public void deleteMenuDepartments(String groupId,
                                  String id)
                           throws AccessSecurityWriteException
すべてのメニュー組織を削除します。

定義:
インタフェース MenuAccessor 内の deleteMenuDepartments
パラメータ:
groupId - ログイングループID
id - メニューID
例外:
AccessSecurityWriteException - メニュー組織の削除に失敗した場合にスローされます。

deleteMenuInclusion

public void deleteMenuInclusion(String groupId,
                                MenuInclusion menuInclusion)
                         throws AccessSecurityWriteException
メニュー構成を削除します。

定義:
インタフェース MenuAccessor 内の deleteMenuInclusion
パラメータ:
groupId - ログイングループID
menuInclusion - メニュー構成
例外:
AccessSecurityWriteException - メニュー構成の削除に失敗した場合にスローされます。

deleteMenuItem

public void deleteMenuItem(String groupId,
                           String id)
                    throws AccessSecurityWriteException
引数で渡されたノードを削除します。

定義:
インタフェース MenuAccessor 内の deleteMenuItem
パラメータ:
groupId - グループID
id - メニューID
例外:
AccessSecurityWriteException - メニューの削除に失敗した場合にスローされます。

deleteMenuPost

public void deleteMenuPost(String groupId,
                           String id,
                           PostInfo postInfo)
                    throws AccessSecurityWriteException
メニュー役職を削除します。

定義:
インタフェース MenuAccessor 内の deleteMenuPost
パラメータ:
groupId - ログイングループID
id - メニューID
postInfo - 役職情報
例外:
AccessSecurityWriteException - メニュー役職の削除に失敗した場合にスローされます。

deleteMenuPosts

public void deleteMenuPosts(String groupId,
                            String id)
                     throws AccessSecurityWriteException
すべてのメニュー役職を削除します。

定義:
インタフェース MenuAccessor 内の deleteMenuPosts
パラメータ:
groupId - ログイングループID
id - メニューID
例外:
AccessSecurityWriteException - メニュー役職の削除に失敗した場合にスローされます。

deleteMenuPublicGroup

public void deleteMenuPublicGroup(String groupId,
                                  String id,
                                  PublicGroupInfo publicGroupInfo)
                           throws AccessSecurityWriteException
メニューパブリックグループを削除します。

定義:
インタフェース MenuAccessor 内の deleteMenuPublicGroup
パラメータ:
groupId - ログイングループID
id - メニューID
publicGroupInfo - パブリックグループ情報
例外:
AccessSecurityWriteException - メニューパブリックグループの削除に失敗した場合にスローされます。

deleteMenuPublicGroups

public void deleteMenuPublicGroups(String groupId,
                                   String id)
                            throws AccessSecurityWriteException
すべてのメニューパブリックグループを削除します。

定義:
インタフェース MenuAccessor 内の deleteMenuPublicGroups
パラメータ:
groupId - ログイングループID
id - メニューID
例外:
AccessSecurityWriteException - メニューパブリックグループの削除に失敗した場合にスローされます。

deleteMenuRole

public void deleteMenuRole(String groupId,
                           String id,
                           String roleId)
                    throws AccessSecurityWriteException
メニューロールを削除します。

定義:
インタフェース MenuAccessor 内の deleteMenuRole
パラメータ:
groupId - ログイングループID
id - メニューID
roleId - ロールID
例外:
AccessSecurityWriteException - メニューロールの削除に失敗した場合にスローされます。

deleteMenuRoles

public void deleteMenuRoles(String groupId,
                            String menuId)
                     throws AccessSecurityWriteException
すべてのメニューロールを削除します。

定義:
インタフェース MenuAccessor 内の deleteMenuRoles
パラメータ:
groupId - ログイングループID
menuId - メニューID
例外:
AccessSecurityWriteException - メニューロールの削除に失敗した場合にスローされます。

getChildMenuIds

public String[] getChildMenuIds(String groupId,
                                String menuId)
                         throws AccessSecurityReadException
引数で指定されたノードの直下の子メニューIDを配列で取得します。

定義:
インタフェース MenuAccessor 内の getChildMenuIds
パラメータ:
groupId - グループID
menuId - メニューID
戻り値:
子メニューIDの配列
例外:
AccessSecurityReadException - メニューIDの取得に失敗した場合にスローされます。

getFirstMenuIds

public String[] getFirstMenuIds(String groupId)
                         throws AccessSecurityReadException
第一階層に属するメニューIDを配列で取得します。

定義:
インタフェース MenuAccessor 内の getFirstMenuIds
パラメータ:
groupId - グループID
戻り値:
第一階層に属するメニューIDの配列
例外:
AccessSecurityReadException - メニューIDの取得に失敗した場合にスローされます。

getMenuDepartments

public DepartmentInfo[] getMenuDepartments(String groupId,
                                           String id)
                                    throws AccessSecurityReadException
すべてのメニュー組織を取得します。

一件も存在しない場合は、空の配列を返却します。

定義:
インタフェース MenuAccessor 内の getMenuDepartments
パラメータ:
groupId - ログイングループID
id - メニューID
戻り値:
組織情報の配列
例外:
AccessSecurityReadException - メニュー組織の取得に失敗した場合にスローされます。

getMenuIds

public String[] getMenuIds(String groupId)
                    throws AccessSecurityReadException
すべてのメニューIDを取得します。

定義:
インタフェース MenuAccessor 内の getMenuIds
パラメータ:
groupId - グループID
戻り値:
メニューIDの配列
例外:
AccessSecurityReadException - メニューIDの取得に失敗した場合にスローされます。

getMenuIdsByDepartment

public String[] getMenuIdsByDepartment(String groupId,
                                       DepartmentInfo[] departments)
                                throws AccessSecurityReadException
指定された組織を持つメニューIDをすべて取得します。

定義:
インタフェース MenuAccessor 内の getMenuIdsByDepartment
パラメータ:
groupId - ログイングループID
departments - 組織情報の配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - メニュー情報取得に失敗した場合スローされます。

getMenuIdsByPost

public String[] getMenuIdsByPost(String groupId,
                                 PostInfo[] posts)
                          throws AccessSecurityReadException
指定された役職を持つメニューIDをすべて取得します。

定義:
インタフェース MenuAccessor 内の getMenuIdsByPost
パラメータ:
groupId - ログイングループID
posts - 役職情報の配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - メニュー情報取得に失敗した場合スローされます。

getMenuIdsByPublicGroup

public String[] getMenuIdsByPublicGroup(String groupId,
                                        PublicGroupInfo[] publicGroups)
                                 throws AccessSecurityReadException
指定されたパブリックグループを持つメニューIDをすべて取得します。

定義:
インタフェース MenuAccessor 内の getMenuIdsByPublicGroup
パラメータ:
groupId - ログイングループID
publicGroups - パブリックグループの配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - メニュー情報取得に失敗した場合スローされます。

getMenuIdsByRole

public String[] getMenuIdsByRole(String groupId,
                                 String[] roleIds)
                          throws AccessSecurityReadException
指定されたロールIDを持つメニューIDをすべて取得します。

定義:
インタフェース MenuAccessor 内の getMenuIdsByRole
パラメータ:
groupId - ログイングループID
roleIds - ロールIDの配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - メニュー情報取得に失敗した場合スローされます。

getMenuInclusions

public MenuInclusion[] getMenuInclusions(String groupId)
                                  throws AccessSecurityReadException
すべてのメニュー構成を取得します。

定義:
インタフェース MenuAccessor 内の getMenuInclusions
パラメータ:
groupId - ログイングループID
戻り値:
メニュー構成の配列
例外:
AccessSecurityReadException - メニュー構成の取得に失敗した場合にスローされます。

getMenuItem

public MenuItem getMenuItem(String groupId,
                            String menuId)
                     throws AccessSecurityReadException
指定されたメニューIDに対するノードを取得します。

定義:
インタフェース MenuAccessor 内の getMenuItem
パラメータ:
groupId - グループID
menuId - メニューID
戻り値:
ノード
例外:
AccessSecurityReadException - メニューIDの取得に失敗した場合にスローされます。

getMenuItems

public MenuItem[] getMenuItems(String groupId)
                        throws AccessSecurityReadException
すべてのノードを取得します。

定義:
インタフェース MenuAccessor 内の getMenuItems
パラメータ:
groupId - グループID
戻り値:
ノード配列
例外:
AccessSecurityReadException - メニューの取得に失敗した場合にスローされます。

getMenuItemsByIds

public MenuItem[] getMenuItemsByIds(String groupId,
                                    String[] menuIds)
                             throws AccessSecurityReadException
指定されたメニューIDのメニュー情報をすべて取得します。

定義:
インタフェース MenuAccessor 内の getMenuItemsByIds
パラメータ:
groupId - ログイングループID
menuIds - メニューIDの配列
戻り値:
メニューオブジェクトの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - メニュー情報取得に失敗した場合スローされます。

getMenuPosts

public PostInfo[] getMenuPosts(String groupId,
                               String id)
                        throws AccessSecurityReadException
すべてのメニュー役職を取得します。

一件も存在しない場合は、空の配列を返却します。

定義:
インタフェース MenuAccessor 内の getMenuPosts
パラメータ:
groupId - ログイングループID
id - メニューID
戻り値:
役職情報の配列
例外:
AccessSecurityReadException - メニュー役職の取得に失敗した場合にスローされます。

getMenuPublicGroups

public PublicGroupInfo[] getMenuPublicGroups(String groupId,
                                             String id)
                                      throws AccessSecurityReadException
すべてのメニューパブリックグループを取得します。

一件も存在しない場合は、空の配列を返却します。

定義:
インタフェース MenuAccessor 内の getMenuPublicGroups
パラメータ:
groupId - ログイングループID
id - メニューID
戻り値:
パブリックグループ情報の配列
例外:
AccessSecurityReadException - メニューパブリックグループの取得に失敗した場合にスローされます。

getMenuRoles

public String[] getMenuRoles(String groupId,
                             String menuId)
                      throws AccessSecurityReadException
すべてのメニューロールを取得します。

一件も存在しない場合は、空の配列を返却します。

定義:
インタフェース MenuAccessor 内の getMenuRoles
パラメータ:
groupId - ログイングループID
menuId - メニューID
戻り値:
メニューロールIDの配列
例外:
AccessSecurityReadException - メニューロールの取得に失敗した場合にスローされます。

getParentMenuId

public String getParentMenuId(String groupId,
                              String menuId)
                       throws AccessSecurityReadException
引数で指定されたノードの親ノードを取得します。

定義:
インタフェース MenuAccessor 内の getParentMenuId
パラメータ:
groupId - グループID
menuId - メニューID
戻り値:
親メニューID
例外:
AccessSecurityReadException - メニューIDの取得に失敗した場合にスローされます。

init

public void init(Map params)
メニューアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース MenuAccessor 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

insertMenuDepartment

public void insertMenuDepartment(String groupId,
                                 String menuId,
                                 DepartmentInfo departmentInfo)
                          throws AccessSecurityWriteException
メニュー組織を新規に作成します。

定義:
インタフェース MenuAccessor 内の insertMenuDepartment
パラメータ:
groupId - ログイングループID
menuId - メニューID
departmentInfo - 組織情報
例外:
AccessSecurityWriteException - メニュー組織の追加に失敗した場合にスローされます。

insertMenuInclusion

public void insertMenuInclusion(String groupId,
                                MenuInclusion menuInclusion)
                         throws AccessSecurityWriteException
メニュー構成を新規に作成します。

定義:
インタフェース MenuAccessor 内の insertMenuInclusion
パラメータ:
groupId - ログイングループID
menuInclusion - メニュー構成
例外:
AccessSecurityWriteException - メニュー構成の追加に失敗した場合にスローされます。

insertMenuItem

public void insertMenuItem(String groupId,
                           MenuItem menuItem,
                           String parentId)
                    throws AccessSecurityWriteException
引数で渡されたノードを新規追加します。

定義:
インタフェース MenuAccessor 内の insertMenuItem
パラメータ:
groupId - グループID
menuItem - メニューアイテム
parentId - 親メニューID
例外:
AccessSecurityWriteException - メニュ－の追加に失敗した場合にスローされます。

insertMenuPost

public void insertMenuPost(String groupId,
                           String menuId,
                           PostInfo postInfo)
                    throws AccessSecurityWriteException
メニュー役職を新規に作成します。

定義:
インタフェース MenuAccessor 内の insertMenuPost
パラメータ:
groupId - ログイングループID
menuId - メニューID
postInfo - 役職情報
例外:
AccessSecurityWriteException - メニュ－役職の追加に失敗した場合にスローされます。

insertMenuPublicGroup

public void insertMenuPublicGroup(String groupId,
                                  String menuId,
                                  PublicGroupInfo publicGroupInfo)
                           throws AccessSecurityWriteException
メニューパブリックグループを新規に作成します。

定義:
インタフェース MenuAccessor 内の insertMenuPublicGroup
パラメータ:
groupId - ログイングループID
menuId - メニューID
publicGroupInfo - パブリックグループ情報
例外:
AccessSecurityWriteException - メニュ－パブリックグループの追加に失敗した場合にスローされます。

insertMenuRole

public void insertMenuRole(String groupId,
                           String menuId,
                           String roleId)
                    throws AccessSecurityWriteException
メニューロールを新規に作成します。

定義:
インタフェース MenuAccessor 内の insertMenuRole
パラメータ:
groupId - ログイングループID
menuId - メニューID
roleId - ロールID
例外:
AccessSecurityWriteException - メニュ－ロールの追加に失敗した場合にスローされます。

updateMenuItem

public void updateMenuItem(String groupId,
                           MenuItem menuItem)
                    throws AccessSecurityWriteException
引数で渡されたノードを更新します。

定義:
インタフェース MenuAccessor 内の updateMenuItem
パラメータ:
groupId - グループID
menuItem - メニューアイテム
例外:
AccessSecurityWriteException - メニュ－の更新に失敗した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardRoleAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス StandardRoleAccessor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.StandardRoleAccessor
すべての実装インタフェース:
RoleAccessor
public class StandardRoleAccessor
extends Object
implements RoleAccessor

ロールアクセッサクラス。

ロール情報の読み込みおよび書き込みを行うクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String | APPLICATION_NAME
static String | ENTITY_NAME_ROLE
static String | ENTITY_NAME_ROLE_INCLUSION
static String | ENTITY_NAME_ROLE_SUMMARY
static String | KIND_ROLE 種別 ロール。
static String | KIND_ROLE_SUB 種別 サブロール(ロール)。
コンストラクタの概要
StandardRoleAccessor()
コンストラクタ
メソッドの概要
void | createRole(String groupId, Role role) ロール情報を新規追加します。
void | deleteCategory(String groupId) すべてのカテゴリを削除します。
void | deleteCategory(String groupId, String category) カテゴリを削除します。
void | deleteRole(String groupId) すべてのロール情報を削除します。
void | deleteRole(String groupId, String roleId) ロール情報を削除します。
void | deleteSubRole(String groupId, String roleId) サブロールIDを削除します。
void | deleteSubRole(String groupId, String roleId, String subRoleId) 指定したサブロールIDを削除します。
String[] | getAllParentRoleIds(String groupId, String roleId) すべての親ロールの一覧を取得します。
String[] | getAllSubRoleIds(String groupId, String roleId) すべてのサブロールの一覧を取得します。
String[] | getCategories(String groupId) カテゴリの一覧を取得します。
protected String | getLoginUser() ログインユーザを取得します。
String[] | getParentRoleIds(String groupId, String roleId) 親ロールの一覧を取得します。
Role[] | getRoleData(String groupId) ロール情報を全件取得します。
Role | getRoleData(String groupId, String roleId) ロール情報を取得します。
Role[] | getRoleDataByCategory(String groupId, String category) カテゴリからロール情報を取得します。
Role[] | getRolesByIds(String groupId, String[] roleIds) 指定されたロールIDのロール情報をすべて取得します。
String[] | getSubRoleIds(String groupId, String roleId) サブロールIDサマリを取得します。
void | init(Map params) ロールアクセッサの初期化。
void | insertSubRole(String groupId, String roleId, String subRoleId) サブロールを作成します。
void | updateCategory(String groupId, String oldCategory, String newCategory) カテゴリを更新します。
void | updateRole(String groupId, Role role) ロール情報を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

APPLICATION_NAME

public static final String APPLICATION_NAME
関連項目:
定数フィールド値

ENTITY_NAME_ROLE

public static final String ENTITY_NAME_ROLE
関連項目:
定数フィールド値

ENTITY_NAME_ROLE_INCLUSION

public static final String ENTITY_NAME_ROLE_INCLUSION
関連項目:
定数フィールド値

ENTITY_NAME_ROLE_SUMMARY

public static final String ENTITY_NAME_ROLE_SUMMARY
関連項目:
定数フィールド値

KIND_ROLE

public static final String KIND_ROLE
種別 ロール。

関連項目:
定数フィールド値

KIND_ROLE_SUB

public static final String KIND_ROLE_SUB
種別 サブロール(ロール)。

関連項目:
定数フィールド値
コンストラクタの詳細

StandardRoleAccessor

public StandardRoleAccessor()
コンストラクタ

メソッドの詳細

getLoginUser

protected String getLoginUser()
ログインユーザを取得します。
ログインユーザの取得に失敗した場合は空文字列を返却します。

戻り値:
ログインユーザID

createRole

public void createRole(String groupId,
                       Role role)
                throws AccessSecurityWriteException
ロール情報を新規追加します。

定義:
インタフェース RoleAccessor 内の createRole
パラメータ:
groupId - ログイングループID
role - ロール情報
例外:
AccessSecurityWriteException - ロール情報の作成に失敗した場合にスローされます。

deleteCategory

public void deleteCategory(String groupId)
                    throws AccessSecurityWriteException
すべてのカテゴリを削除します。

定義:
インタフェース RoleAccessor 内の deleteCategory
パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException - カテゴリの削除に失敗した場合にスローされます。

deleteCategory

public void deleteCategory(String groupId,
                           String category)
                    throws AccessSecurityWriteException
カテゴリを削除します。

定義:
インタフェース RoleAccessor 内の deleteCategory
パラメータ:
groupId - ログイングループID
category - カテゴリ名
例外:
AccessSecurityWriteException - カテゴリの削除に失敗した場合にスローされます。

deleteRole

public void deleteRole(String groupId)
                throws AccessSecurityWriteException
すべてのロール情報を削除します。

定義:
インタフェース RoleAccessor 内の deleteRole
パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException - ロール情報の削除に失敗した場合にスローされます。

deleteRole

public void deleteRole(String groupId,
                       String roleId)
                throws AccessSecurityWriteException
ロール情報を削除します。

定義:
インタフェース RoleAccessor 内の deleteRole
パラメータ:
groupId - ログイングループID
roleId - ロール情ID
例外:
AccessSecurityWriteException - ロール情報の削除に失敗した場合にスローされます。

deleteSubRole

public void deleteSubRole(String groupId,
                          String roleId)
                   throws AccessSecurityWriteException
サブロールIDを削除します。

定義:
インタフェース RoleAccessor 内の deleteSubRole
パラメータ:
groupId - ログイングループID
roleId - ロールID
例外:
AccessSecurityWriteException - ロール情報の更新に失敗した場合にスローされます。

deleteSubRole

public void deleteSubRole(String groupId,
                          String roleId,
                          String subRoleId)
                   throws AccessSecurityWriteException
指定したサブロールIDを削除します。

定義:
インタフェース RoleAccessor 内の deleteSubRole
パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 削除するサブロールID
例外:
AccessSecurityWriteException - ロール情報の更新に失敗した場合にスローされます。

getAllParentRoleIds

public String[] getAllParentRoleIds(String groupId,
                                    String roleId)
                             throws AccessSecurityReadException
すべての親ロールの一覧を取得します。

引数に指定したロールの上位階層にあるすべての親ロールを取得します。
親ロールが一件も存在しない場合空の配列を返却します。

定義:
インタフェース RoleAccessor 内の getAllParentRoleIds
パラメータ:
groupId - ログイングループID
roleId - ロールID
戻り値:
すべての親ロールIDの配列
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getAllSubRoleIds

public String[] getAllSubRoleIds(String groupId,
                                 String roleId)
                          throws AccessSecurityReadException
すべてのサブロールの一覧を取得します。

引数に指定したロールの下位階層にあるすべてのサブロールを取得します。
サブロールが一件も存在しない場合空の配列を返却します。

定義:
インタフェース RoleAccessor 内の getAllSubRoleIds
パラメータ:
groupId - ログイングループID
roleId - ロールID
戻り値:
すべてのサブロールIDの配列
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getCategories

public String[] getCategories(String groupId)
                       throws AccessSecurityReadException
カテゴリの一覧を取得します。

指定したログイングループに属するカテゴリが存在しない場合は空の配列を返却します。

定義:
インタフェース RoleAccessor 内の getCategories
パラメータ:
groupId - ログイングループID
戻り値:
カテゴリ名の配列
例外:
AccessSecurityReadException - カテゴリの取得に失敗した場合にスローされます。

getParentRoleIds

public String[] getParentRoleIds(String groupId,
                                 String roleId)
                          throws AccessSecurityReadException
親ロールの一覧を取得します。

引数に指定したロールの１階層上位にあるすべての親ロールを取得します。
親ロールが一件も存在しない場合空の配列を返却します。

定義:
インタフェース RoleAccessor 内の getParentRoleIds
パラメータ:
groupId - ログイングループID
roleId - ロールID
戻り値:
親ロールIDの配列
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getRoleData

public Role[] getRoleData(String groupId)
                   throws AccessSecurityReadException
ロール情報を全件取得します。

指定されたログイングループに属するロールが存在しない場合は空の配列を返却します。

定義:
インタフェース RoleAccessor 内の getRoleData
パラメータ:
groupId - ログイングループID
戻り値:
ロール情報の配列
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getRoleData

public Role getRoleData(String groupId,
                        String roleId)
                 throws AccessSecurityReadException
ロール情報を取得します。

指定されたロールIDをもつロールが存在しない場合はnullを返します。

定義:
インタフェース RoleAccessor 内の getRoleData
パラメータ:
groupId - ログイングループID
roleId - ロールID
戻り値:
ロールデータ
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getRoleDataByCategory

public Role[] getRoleDataByCategory(String groupId,
                                    String category)
                             throws AccessSecurityReadException
カテゴリからロール情報を取得します。

指定されたカテゴリに属するロール情報を取得します。
指定したカテゴリーに属するロールが存在しない場合は空の配列を返却します。

定義:
インタフェース RoleAccessor 内の getRoleDataByCategory
パラメータ:
groupId - ログイングループID
category - カテゴリ名
戻り値:
ロール情報の配列
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getRolesByIds

public Role[] getRolesByIds(String groupId,
                            String[] roleIds)
                     throws AccessSecurityReadException
指定されたロールIDのロール情報をすべて取得します。

定義:
インタフェース RoleAccessor 内の getRolesByIds
パラメータ:
groupId - ログイングループID
roleIds - ロールIDの配列
戻り値:
ロールオブジェクトの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - ロール情報取得に失敗した場合スローされます。

getSubRoleIds

public String[] getSubRoleIds(String groupId,
                              String roleId)
                       throws AccessSecurityReadException
サブロールIDサマリを取得します。

定義:
インタフェース RoleAccessor 内の getSubRoleIds
パラメータ:
groupId - ログイングループID
roleId - ロールID
戻り値:
String[] サブロールID
例外:
AccessSecurityWriteException - ロール情報の更新に失敗した場合にスローされます。
AccessSecurityReadException

init

public void init(Map params)
ロールアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース RoleAccessor 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

insertSubRole

public void insertSubRole(String groupId,
                          String roleId,
                          String subRoleId)
                   throws AccessSecurityWriteException
サブロールを作成します。

定義:
インタフェース RoleAccessor 内の insertSubRole
パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 追加するサブロールID
例外:
AccessSecurityWriteException - ロール情報の更新に失敗した場合にスローされます。

updateCategory

public void updateCategory(String groupId,
                           String oldCategory,
                           String newCategory)
                    throws AccessSecurityWriteException
カテゴリを更新します。

旧カテゴリ名を新カテゴリ名に更新します。

定義:
インタフェース RoleAccessor 内の updateCategory
パラメータ:
groupId - ログイングループID
oldCategory - 旧カテゴリ名
newCategory - 新カテゴリ名
例外:
AccessSecurityWriteException - カテゴリの更新に失敗した場合にスローされます。

updateRole

public void updateRole(String groupId,
                       Role role)
                throws AccessSecurityWriteException
ロール情報を更新します。

定義:
インタフェース RoleAccessor 内の updateRole
パラメータ:
groupId - ログイングループID
role - ロール情報
例外:
AccessSecurityWriteException - ロール情報の更新に失敗した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SystemManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス SystemManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.SystemManager
public class SystemManager
extends Object

システムマネージャクラス。 システムで共通に使用する以下の情報を取得します。

  • システムで対応しているロケール情報
  • システムで対応しているクライアント情報
  • システムで対応しているカラーパターン情報

    • また、システム管理者情報の操作を行います。

    導入されたバージョン:
    5.0
    バージョン:
    1.0

    メソッドの概要
void | addSuperUser(SuperUser superUser) システム管理者情報を新規に作成します。
static void | clearInstance() システムマネージャのインスタンスを初期化を行います。
ClientTypeInfo | getClientType(Locale reqLocale, String clientType) 指定ロケールでクライアントタイプ情報を取得します。
ClientTypeInfo[] | getClientTypes(Locale reqLocale) 指定ロケールでクライアントタイプ情報の一覧を取得します。
ColorPatternInfo | getColorPattern(Locale reqLocale, String colorPatternId) 指定ロケールでカラーパターン情報を取得します。
ColorPatternInfo[] | getColorPatterns(Locale reqLocale) 指定ロケールでカラーパターン情報の一覧を取得します。
String | getDefaultClientType() システムのデフォルトクライアントタイプを取得します。
String | getDefaultColorPatternId() デフォルトカラーパターンIDを取得します。
String | getDefaultEncoding(Locale reqLocale) ロケールに対応するデフォルトエンコーディングを取得します。
Locale | getDefaultLocale() デフォルトロケールを取得します。
static SystemManager | getInstance() システムマネージャインスタンスを生成します。
LocaleInfo | getLocale(Locale reqLocale, Locale locale) 指定ロケールでロケール情報を取得します。
LocaleInfo[] | getLocales(Locale reqLocale) 指定ロケールでロケール情報の一覧を取得します。
SuperUser | getSuperUser() システム管理者情報を取得します。
Date | getSystemMaxDate() 最大の未来日を取得します。
MenuItem[] | getSystemMenu() システムメニューを取得します。
Date | getSystemMinDate() 最大の過去日を取得します。
static void | setSorucePovider(SystemSourceProvider provider) ソースプロバイダを設定します。
void | updateSuperUser(SuperUser superUser) システム管理者情報を更新します。
    クラス java.lang.Object から継承したメソッド
    clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    メソッドの詳細

    clearInstance

    public static void clearInstance()
    システムマネージャのインスタンスを初期化を行います。

    システム設定ファイルおよびアクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

    システム設定ファイルは(system.xml)は、サーバマネージャルート/confに存在します。 アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。 通常、このメソッドを使用する必要はありません。

    setSorucePovider

    public static void setSorucePovider(SystemSourceProvider provider)
                             throws AccessSecurityException
    ソースプロバイダを設定します。

    システム設定ファイルを提供するプロバイダを設定します。

    通常、このメソッドを使用する必要はありません。

    パラメータ:
    provider - ソースプロバイダ
    例外:
    AccessSecurityException - 引数が不正だった場合にスローされます。

    getInstance

    public static SystemManager getInstance()
    システムマネージャインスタンスを生成します。

    戻り値:
    システムマネージャインスタンス

    addSuperUser

    public void addSuperUser(SuperUser superUser)
                  throws AccessSecurityException
    システム管理者情報を新規に作成します。

    パラメータ:
    superUser - システム管理者情報
    例外:
    AccessSecurityException - システム管理者情報が作成できなかった場合、または引数が不正だった場合にスローされます。

    getClientType

    public ClientTypeInfo getClientType(Locale reqLocale,
                                    String clientType)
                             throws AccessSecurityException
    指定ロケールでクライアントタイプ情報を取得します。

    存在しない指定ロケールおよびクライアントタイプが指定された場合はデフォルトのクライアントタイプ情報を返却します。

    パラメータ:
    reqLocale - 指定ロケール
    clientType - クライアントタイプ
    戻り値:
    クライアントタイプ情報
    例外:
    AccessSecurityException - 引数が不正だった場合にスローされます。

    getClientTypes

    public ClientTypeInfo[] getClientTypes(Locale reqLocale)
                                throws AccessSecurityException
    指定ロケールでクライアントタイプ情報の一覧を取得します。

    存在しない指定ロケールが指定された場合はデフォルトのクライアントタイプ情報の配列を返却します。

    パラメータ:
    reqLocale - 指定ロケール
    戻り値:
    クライアントタイプ情報の配列
    例外:
    AccessSecurityException - 引数が不正だった場合にスローされます。

    getColorPattern

    public ColorPatternInfo getColorPattern(Locale reqLocale,
                                        String colorPatternId)
                                 throws AccessSecurityException
    指定ロケールでカラーパターン情報を取得します。

    存在しない指定ロケールおよびカラーパターンIDが指定された場合はデフォルトのカラーパターン情報を返却します。

    パラメータ:
    reqLocale - 指定ロケール
    colorPatternId - カラーパターンID
    戻り値:
    カラーパターン情報。
    例外:
    AccessSecurityException - 引数が不正だった場合にスローされます。

    getColorPatterns

    public ColorPatternInfo[] getColorPatterns(Locale reqLocale)
                                    throws AccessSecurityException
    指定ロケールでカラーパターン情報の一覧を取得します。

    存在しない指定ロケールが指定された場合はデフォルトのカラーパターン情報の配列を返却します。

    パラメータ:
    reqLocale - 指定ロケール
    戻り値:
    カラーパターン情報の配列。
    例外:
    AccessSecurityException - 引数が不正だった場合にスローされます。

    getDefaultClientType

    public String getDefaultClientType()
    システムのデフォルトクライアントタイプを取得します。

    戻り値:
    デフォルトクライアントタイプ

    getDefaultColorPatternId

    public String getDefaultColorPatternId()
    デフォルトカラーパターンIDを取得します。

    戻り値:
    デフォルトカラーパターンID。

    getDefaultEncoding

    public String getDefaultEncoding(Locale reqLocale)
                          throws AccessSecurityException
    ロケールに対応するデフォルトエンコーディングを取得します。

    パラメータ:
    reqLocale - 指定ロケール
    戻り値:
    デフォルトエンコーディング
    例外:
    AccessSecurityException - 引数が不正だった場合にスローされます。

    getDefaultLocale

    public Locale getDefaultLocale()
    デフォルトロケールを取得します。

    戻り値:
    デフォルトロケール

    getLocale

    public LocaleInfo getLocale(Locale reqLocale,
                            Locale locale)
                     throws AccessSecurityException
    指定ロケールでロケール情報を取得します。

    存在しない指定ロケールおよび取得ロケールが指定された場合はデフォルトのロケール情報を返却します。

    パラメータ:
    reqLocale - 指定ロケール
    locale - 取得ロケール
    戻り値:
    ロケール情報
    例外:
    AccessSecurityException - 引数が不正だった場合にスローされます。

    getLocales

    public LocaleInfo[] getLocales(Locale reqLocale)
                        throws AccessSecurityException
    指定ロケールでロケール情報の一覧を取得します。

    存在しない指定ロケールが指定された場合はデフォルトのロケール情報の配列を返却します。

    パラメータ:
    reqLocale - 指定ロケール
    戻り値:
    ロケール情報の配列
    例外:
    AccessSecurityException - 引数が不正だった場合にスローされます。

    getSuperUser

    public SuperUser getSuperUser()
                       throws AccessSecurityException
    システム管理者情報を取得します。

    システム管理者の情報モデルを取得します。

    戻り値:
    システム管理者の情報モデル
    例外:
    AccessSecurityReadException - システム管理者情報が取得できなかった場合にスローされます。
    AccessSecurityException

    updateSuperUser

    public void updateSuperUser(SuperUser superUser)
                     throws AccessSecurityException
    システム管理者情報を更新します。

    パラメータ:
    superUser - システム管理者の情報モデル
    例外:
    AccessSecurityException - システム管理者情報が更新できなかった場合にスローされます。

    getSystemMenu

    public MenuItem[] getSystemMenu()
    システムメニューを取得します。

    戻り値:
    システムメニューの配列

    getSystemMinDate

    public Date getSystemMinDate()
    最大の過去日を取得します。

    システムで取り扱う最大過去日を返却します。

    戻り値:
    システムで取り扱う最大過去日

    getSystemMaxDate

    public Date getSystemMaxDate()
    最大の未来日を取得します。

    システムで取り扱う最大未来日を返却します。

    戻り値:
    システムで取り扱う最大未来日
    概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
            intra-mart 6.1.14
    前のクラス 次のクラス | フレームあり フレームなし
    概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SystemSourceProvider (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース SystemSourceProvider

public interface SystemSourceProvider

ロケール情報取得インターフェース。

設定ファイルからロケール情報を取得するためのインターフェースを定義します

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
SystemManager

メソッドの概要
InputStream | getPropertyStreamAsClientType(Locale locale) プロパティファイル(クライアントタイプ)の内容取得。
InputStream | getPropertyStreamAsColor(Locale locale) プロパティファイル(カラーパターン)の内容取得。
InputStream | getPropertyStreamAsColorProperty(String colorId, Locale locale) プロパティファイル(カラーパターン)の内容取得。
InputStream | getPropertyStreamAsLocale(Locale locale) プロパティファイル(ロケール)の内容取得。
InputStream | getStream() システム設定ファイルの内容取得。

メソッドの詳細

getPropertyStreamAsClientType

public InputStream getPropertyStreamAsClientType(Locale locale)
プロパティファイル(クライアントタイプ)の内容取得。
与えられた引数(ロケール)からプロパティファイルのストリームを返却する。
引数がnullの場合はデフォルトのプロパティファイルのストリームを返却する。

パラメータ:
locale - ロケール

getPropertyStreamAsColorProperty

public InputStream getPropertyStreamAsColorProperty(String colorId,
                                                    Locale locale)
プロパティファイル(カラーパターン)の内容取得。
与えられた引数(カラーパターンID、ロケール)からプロパティファイルのストリームを返却する 。
引数のロケールがnullの場合はデフォルトのカラーパターンIDのプロパティファイルのストリームを返却する。

パラメータ:
colorId - カラーパターンID
locale - ロケール

getPropertyStreamAsColor

public InputStream getPropertyStreamAsColor(Locale locale)
プロパティファイル(カラーパターン)の内容取得。
与えられた引数(ロケール)からカラーパターンプロパティファイルのストリームを返却する 。
引数のロケールがnullの場合はデフォルトのカラーパターンプロパティファイルのストリームを返却する。

パラメータ:
locale - ロケール

getPropertyStreamAsLocale

public InputStream getPropertyStreamAsLocale(Locale locale)
プロパティファイル(ロケール)の内容取得。
与えられた引数(ロケール)からプロパティファイルのストリームを返却する 。
引数がnullの場合はデフォルトのプロパティファイルのストリームを返却する。

パラメータ:
locale - ロケール

getStream

public InputStream getStream()
システム設定ファイルの内容取得。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler の使用

AccountSecurityHTTPActionEventFilterHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での AccountSecurityHTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application での AccountSecurityHTTPActionEventFilterHandler のサブクラス
 class PasswordSecurityHTTPActionEventFilterHandler
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler の使用

GroupSecurityHTTPActionEventFilterHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での GroupSecurityHTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application での GroupSecurityHTTPActionEventFilterHandler のサブクラス
class | AccountSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | PasswordSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent の使用

HTTPActionEventContent を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventContent の使用

HTTPActionEventContent を返す jp.co.intra_mart.foundation.service.client.application のメソッド
 HTTPActionEventContent HTTPActionEventURL.getContent()
HTTPActionEventURL.getURL() によって表されるコンテンツのソースを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler の使用

HTTPActionEventEntityHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventEntityHandler の使用

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventEntityHandler のサブクラス
class | ActivityHTTPActionEventHandler 持続したセッションを確立するためのハンドラです。
class | ConcreteHTTPActionEventHandler 任意の HTTPActionEvent を実行するためのハンドラです。
class | ServletHTTPActionEventHandler Web-Application を実行するためのイベントハンドラです。
class | WebApplicationHTTPActionEventHandler フレームワークを実行するためのイベントハンドラの抽象実装です。

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventEntityHandler の使用

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventEntityHandler のサブクラス
class | PresentationPageHTTPActionEventHandler スクリプト開発モデルのプレゼンテーションページを実行するためのハンドラです。
class | ServiceFrameworkHTTPActionEventHandler im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler の使用

HTTPActionEventFilterHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventFilterHandler のサブクラス
class | AccountSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | GroupSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | LimitedSessionHTTPActionEventFilterHandler セッションを一時利用のみに限定するためのフィルタです。
class | PasswordSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventFilterHandler のサブクラス
class | AccessibleLinkHTTPActionEventFilterHandler 再接続の為のＵＲＬを制御するフィルタ実装です。
class | ActivityFrameworkHTTPActionEventFilterHandler 推奨されていません。 このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler の使用

HTTPActionEventHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventHandler のサブクラス
class | AccountSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | ActivityHTTPActionEventHandler 持続したセッションを確立するためのハンドラです。
class | ConcreteHTTPActionEventHandler 任意の HTTPActionEvent を実行するためのハンドラです。
class | GroupSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | HTTPActionEventEntityHandler HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
class | HTTPActionEventFilterHandler HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
class | LimitedSessionHTTPActionEventFilterHandler セッションを一時利用のみに限定するためのフィルタです。
class | PasswordSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | ServletHTTPActionEventHandler Web-Application を実行するためのイベントハンドラです。
class | WebApplicationHTTPActionEventHandler フレームワークを実行するためのイベントハンドラの抽象実装です。

HTTPActionEventHandler を返す jp.co.intra_mart.foundation.service.client.application のメソッド
 HTTPActionEventHandler HTTPActionEventFilterHandler.getParent()
このオブジェクトがフィルタリングしているハンドラを返します。

HTTPActionEventHandler 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.application のメソッド
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

HTTPActionEventHandler 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.application のコンストラクタ
PasswordSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId, String accountId, String password)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
LimitedSessionHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
セッションを一時利用に限定するためのフィルタハンドラを作成します。
HTTPActionEventFilterHandler(HTTPActionEventHandler handler)
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラを作成します。
GroupSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId)
ログイングループセッション環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
AccountSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId, String accountId)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventHandler のサブクラス
class | AccessibleLinkHTTPActionEventFilterHandler 再接続の為のＵＲＬを制御するフィルタ実装です。
class | ActivityFrameworkHTTPActionEventFilterHandler 推奨されていません。 このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。
class | PresentationPageHTTPActionEventHandler スクリプト開発モデルのプレゼンテーションページを実行するためのハンドラです。
class | ServiceFrameworkHTTPActionEventHandler im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。

HTTPActionEventHandler 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.application.content のコンストラクタ
ActivityFrameworkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
推奨されていません。 フレームワークのセッション環境を作成するためのフィルタハンドラを作成します。
AccessibleLinkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
ＵＲＬを絶対形式に変換するためのフィルタハンドラを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException の使用

HTTPActionEventHandlerException を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventHandlerException の使用

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventHandlerException のサブクラス
 class HTTPActionEventHandlerParameterException
HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。

HTTPActionEventHandlerException をスローする jp.co.intra_mart.foundation.service.client.application のメソッド
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventResult | HTTPActionEventHandler.execute(String url) 指定された URL に接続して、 イベントの実行を要求します。
HTTPActionEventResult | HTTPActionEventHandler.execute(URL url) 指定された URL に接続して、 イベントの実行を要求します。
HTTPActionEventResult | HTTPActionEventHandler.execute(HttpURLConnection connection) 指定された URL コネクションを利用してにサーバに接続し、 イベントの実行を要求します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException の使用

HTTPActionEventHandlerParameterException を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventHandlerParameterException の使用

HTTPActionEventHandlerParameterException をスローする jp.co.intra_mart.foundation.service.client.application のメソッド
protected abstract Properties | WebApplicationHTTPActionEventHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected Properties | ServletHTTPActionEventHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected abstract Properties | HTTPActionEventHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected Properties | HTTPActionEventFilterHandler.getFilterParameterMap() このハンドラによって実行されるフィルタイベントに対する 設定済みパラメータのマップを返します。
protected Properties | HTTPActionEventFilterHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected Properties | HTTPActionEventEntityHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected Properties | ActivityHTTPActionEventHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventHandlerParameterException の使用

HTTPActionEventHandlerParameterException をスローする jp.co.intra_mart.foundation.service.client.application.content のメソッド
protected Properties | ServiceFrameworkHTTPActionEventHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected Properties | PresentationPageHTTPActionEventHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult の使用

HTTPActionEventResult を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventResult の使用

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventResult のサブインタフェース
interface | HTTPActionEventContent Web コンテンツを取得するための共通インターフェースです。
interface | HTTPActionEventURL Web コンテンツへのアクセスＵＲＬを取得するための共通インターフェースです。

HTTPActionEventResult を実装している jp.co.intra_mart.foundation.service.client.application のクラス
 class HTTPActionEventResultWrapper
HTTPActionEventResult のラッパーオブジェクトです。

HTTPActionEventResult を返す jp.co.intra_mart.foundation.service.client.application のメソッド
protected HTTPActionEventResult | HTTPActionEventResultWrapper.getParent() ラップしている親オブジェクトを返します。
HTTPActionEventResult | HTTPActionEventHandler.execute(String url) 指定された URL に接続して、 イベントの実行を要求します。
HTTPActionEventResult | HTTPActionEventHandler.execute(URL url) 指定された URL に接続して、 イベントの実行を要求します。
HTTPActionEventResult | HTTPActionEventHandler.execute(HttpURLConnection connection) 指定された URL コネクションを利用してにサーバに接続し、 イベントの実行を要求します。

HTTPActionEventResult 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.application のコンストラクタ
HTTPActionEventResultWrapper(HTTPActionEventResult parent)
指定の結果オブジェクトをラップする新しい結果オブジェクトを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper の使用

jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL の使用

HTTPActionEventURL を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventURL の使用

HTTPActionEventURL を返す jp.co.intra_mart.foundation.service.client.application のメソッド
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler の使用

ServletHTTPActionEventHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での ServletHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application での ServletHTTPActionEventHandler のサブクラス
 class ActivityHTTPActionEventHandler
持続したセッションを確立するためのハンドラです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の使用

WebApplicationHTTPActionEventHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での WebApplicationHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application での WebApplicationHTTPActionEventHandler のサブクラス
class | ActivityHTTPActionEventHandler 持続したセッションを確立するためのハンドラです。
class | ServletHTTPActionEventHandler Web-Application を実行するためのイベントハンドラです。

jp.co.intra_mart.foundation.service.client.application.content での WebApplicationHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.content での WebApplicationHTTPActionEventHandler のサブクラス
class | PresentationPageHTTPActionEventHandler スクリプト開発モデルのプレゼンテーションページを実行するためのハンドラです。
class | ServiceFrameworkHTTPActionEventHandler im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AccessibleLinkHTTPActionEventFilterHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application.content
クラス AccessibleLinkHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler
public class AccessibleLinkHTTPActionEventFilterHandler
extends HTTPActionEventFilterHandler

再接続の為のＵＲＬを制御するフィルタ実装です。

このフィルタを利用する事で、同じセッション内でのその他のリクエストにおいて、 AbsoluteLinkFilter を経由した場合、全ての再接続リクエストのためのＵＲＬが 絶対形式の表現となります。
つまり、返される画面ソース(HTML)内の、 <FORM> の action 属性や、<A> の href 属性に指定する URL が、プロトコルおよびサーバアドレス等を含む絶対形式となります (javax.servlet.HttpServletResponse#encodeURL(java.lang.String) を利用して URL をエンコードしなかった場合は除く)。

これにより、例えばポータルサーバが別サイトとして運用されている場合においても、 各ポートレット内に配置されたリンクやフォームからシステムに直接アクセス できるようになります。

このフィルタは、サーバでの処理実行時に HttpSession が開始されていなかった場合、 HttpSession を新しく開始するように働きます。 それでもセッションを取得できなかった場合、将来の予期せぬエラーを防ぐため、 例外をスローしてサーバ処理をエラー終了します。 結果として、ハンドラの #execute() メソッドは、エラーを示す結果オブジェクトを 返す事になります。

導入されたバージョン:
version 4.3

コンストラクタの概要
AccessibleLinkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
ＵＲＬを絶対形式に変換するためのフィルタハンドラを作成します。
メソッドの概要
 String getName()
フィルタイベント名を返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AccessibleLinkHTTPActionEventFilterHandler

public AccessibleLinkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
ＵＲＬを絶対形式に変換するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventFilterHandler 内の getName
戻り値:
イベント名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ActivityFrameworkHTTPActionEventFilterHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application.content
クラス ActivityFrameworkHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler
推奨されていません。 このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。

public class ActivityFrameworkHTTPActionEventFilterHandler
extends HTTPActionEventFilterHandler

サービスフレームワークおよびプレゼンテーションフレームワークの実行環境を作成するためのフィルタ実装です。

このフィルタを利用する場合、事前にログイン環境を作成しておく必要があります。 したがって、AccountSecurityHTTPActionEventFilterHandler も 併用するようにしてください。

導入されたバージョン:
version 4.3

コンストラクタの概要
ActivityFrameworkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
推奨されていません。 フレームワークのセッション環境を作成するためのフィルタハンドラを作成します。
メソッドの概要
 String getName()
推奨されていません。 フィルタイベント名を返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ActivityFrameworkHTTPActionEventFilterHandler

public ActivityFrameworkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
推奨されていません。
フレームワークのセッション環境を作成するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
推奨されていません。
フィルタイベント名を返します。

実際には、Application Runtime で実行される FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventFilterHandler 内の getName
戻り値:
イベント名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.client.application.content (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.service.client.application.content
クラス
AccessibleLinkHTTPActionEventFilterHandler
ActivityFrameworkHTTPActionEventFilterHandler
PresentationPageHTTPActionEventHandler
ServiceFrameworkHTTPActionEventHandler


jp.co.intra_mart.foundation.service.client.application.content (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.application.content

このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

参照:
説明

クラスの概要
AccessibleLinkHTTPActionEventFilterHandler | 再接続の為のＵＲＬを制御するフィルタ実装です。
ActivityFrameworkHTTPActionEventFilterHandler | 推奨されていません。 このフィルタは、何もしません。
PresentationPageHTTPActionEventHandler | スクリプト開発モデルのプレゼンテーションページを実行するためのハンドラです。
ServiceFrameworkHTTPActionEventHandler | im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。

パッケージ jp.co.intra_mart.foundation.service.client.application.content の説明

このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

導入されたバージョン:
version 4.0


jp.co.intra_mart.foundation.service.client.application.content クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.application.content の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
        • class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler


パッケージ jp.co.intra_mart.foundation.service.client.application.content の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client.application.content の使用

jp.co.intra_mart.foundation.service.client.application.content はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PresentationPageHTTPActionEventHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application.content
クラス PresentationPageHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler
public class PresentationPageHTTPActionEventHandler
extends WebApplicationHTTPActionEventHandler

スクリプト開発モデルのプレゼンテーションページを実行するためのハンドラです。

このハンドラを利用する事により、指定のプレゼンテーションページを実行して、 画面ソースを取得する事ができます。
主にポータルサーバなどと連携してスクリプト開発モデルによる画面を １つのポートレットとして表示する場合に利用できます。 なお、 セッションタイムアウト後の 取得した画面ソース内のリンクやフォームによるリクエストは 無効となりますので注意してください。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected | PresentationPageHTTPActionEventHandler() ハンドラを作成します。
 | PresentationPageHTTPActionEventHandler(String path) ハンドラを作成します。
メソッドの概要
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
String | getName() イベント名を返します。
String | getPagePath() 設定されているページパスを返します。
protected void | setPagePath(String url) 実行するスクリプト開発モデルのページパスを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler から継承したメソッド
getQueryString, getURL, getURL, getURL, getURL, getURL, getURL
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PresentationPageHTTPActionEventHandler

protected PresentationPageHTTPActionEventHandler()
ハンドラを作成します。
このコンストラクタでは、必要な情報が設定されません。

実行するプレゼンテーションページのパスは、 setPagePath(String) で設定してください。

PresentationPageHTTPActionEventHandler

public PresentationPageHTTPActionEventHandler(String path)
ハンドラを作成します。
引数 path には、実行するプレゼンテーションページのパスを設定してください。

パラメータ:
path - スクリプト開発モデルのプログラムパス
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getName
戻り値:
イベント名

setPagePath

protected void setPagePath(String url)
実行するスクリプト開発モデルのページパスを設定します。

ページパスは、Resource Service のスクリプト開発モデルの プログラムルート（標準では pages/）からの相対パス指定になります。

パラメータ:
url - 接続ＵＲＬ

getPagePath

public String getPagePath()
設定されているページパスを返します。

戻り値:
ページパス

getEventRequestParameterMap

protected Properties getEventRequestParameterMap()
                                          throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServiceFrameworkHTTPActionEventHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application.content
クラス ServiceFrameworkHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler
public class ServiceFrameworkHTTPActionEventHandler
extends WebApplicationHTTPActionEventHandler

im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。

このハンドラを利用する事により、指定のサービスフレームワークを実行して、 画面のソースを取得する事ができます。
主にポータルサーバなどと連携してサービスフレームワークによる画面を １つのポートレットとして表示する場合に利用できます。

なお、 セッションタイムアウト後の 取得した画面ソース内のリンクやフォームによるリクエストは 無効となりますので注意してください。

このクラスは、プレゼンテーションフレームワークに必要な各引数値に関する 共通インターフェースを提供しているだけの抽象実装です。 したがって、このクラスを単独で使用しても正しい結果を得る事はできません。 サブクラスを作成して、適切な実装を追加しなければいけません。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected | ServiceFrameworkHTTPActionEventHandler() サービスフレームワークを実行するためのハンドラを作成します。
 | ServiceFrameworkHTTPActionEventHandler(String application, String service) サービスフレームワークを実行するためのハンドラを作成します。
メソッドの概要
String | getApplication() 設定されているアプリケーションＩＤを返します。
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
String | getName() イベント名を返します。
String | getService() 設定されているサービスＩＤを返します。
protected void | setApplication(String id) 実行するフレームワークのアプリケーションＩＤを設定します。
protected void | setService(String id) 実行するフレームワークのサービスＩＤを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler から継承したメソッド
getQueryString, getURL, getURL, getURL, getURL, getURL, getURL
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ServiceFrameworkHTTPActionEventHandler

protected ServiceFrameworkHTTPActionEventHandler()
サービスフレームワークを実行するためのハンドラを作成します。

このコンストラクタでは、特に設定を行いません。 イベント実行要求前に、必要な情報の設定を行ってください。

ServiceFrameworkHTTPActionEventHandler

public ServiceFrameworkHTTPActionEventHandler(String application,
                                              String service)
サービスフレームワークを実行するためのハンドラを作成します。

このコンストラクタでは、特に設定を行いません。 イベント実行要求前に、必要な情報の設定を行ってください。

パラメータ:
application - アプリケーションＩＤ
service - サービスＩＤ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getName
戻り値:
イベント名

setApplication

protected void setApplication(String id)
実行するフレームワークのアプリケーションＩＤを設定します。

パラメータ:
id - アプリケーションＩＤ
例外:
NullPointerException - 引数が null の場合

getApplication

public String getApplication()
設定されているアプリケーションＩＤを返します。

戻り値:
アプリケーションＩＤ

setService

protected void setService(String id)
実行するフレームワークのサービスＩＤを設定します。

パラメータ:
id - サービスＩＤ
例外:
NullPointerException - 引数が null の場合

getService

public String getService()
設定されているサービスＩＤを返します。

戻り値:
サービスＩＤ

getEventRequestParameterMap

protected Properties getEventRequestParameterMap()
                                          throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccountSecurityHTTPActionEventFilterHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス AccountSecurityHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
直系の既知のサブクラス:
PasswordSecurityHTTPActionEventFilterHandler
public class AccountSecurityHTTPActionEventFilterHandler
extends GroupSecurityHTTPActionEventFilterHandler

ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

このフィルタを利用する事により、任意のログイングループ内の任意のアカウントで ログインした状態の環境を作る事ができます。 ログイン環境でイベントを動作させる事により、 イベントプログラム中でログインセッションを必要とするＡＰＩを 利用可能になります。

このフィルタを利用する場合は、 必ずログイン環境を作れるアカウントを作成しておく必要があります。 実在しないアカウントを指定した場合、 未来の予測できないエラーを回避するために、 フィルタ処理の途中で即座に例外がスローされてます。 結果として、イベント実行はエラー終了します。
フィルタがエラー終了した場合、セキュリティホールとならないために セッションを破棄(javax.servlet.http.HttpSession#invalidate())します。 したがって、認証前にセッションに保存した情報にはアクセスできなくなります。 認証エラー後にセッション内の情報が必要な場合は、 事前に取得して別な場所へ保管するなどの対策が必要です。

導入されたバージョン:
version 4.3

フィールドの概要
protected static String ID_SECURITY_ACCOUNT
クラス jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler から継承したフィールド
ID_SECURITY_GROUP
コンストラクタの概要
AccountSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId, String accountId)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
メソッドの概要
String | getAccount() 設定されているアカウントＩＤを返します。
String | getName() フィルタイベント名を返します。
protected void | setAccount(String accountId) アカウントＩＤを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler から継承したメソッド
getGroup, setGroup
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_SECURITY_ACCOUNT

protected static final String ID_SECURITY_ACCOUNT
関連項目:
定数フィールド値
コンストラクタの詳細

AccountSecurityHTTPActionEventFilterHandler

public AccountSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler,
                                                   String groupId,
                                                   String accountId)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
groupId - グループＩＤ
accountId - アカウントＩＤ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

オーバーライド:
クラス GroupSecurityHTTPActionEventFilterHandler 内の getName
戻り値:
イベント名

setAccount

protected void setAccount(String accountId)
アカウントＩＤを設定します。

パラメータ:
accountId - アカウントＩＤ

getAccount

public String getAccount()
設定されているアカウントＩＤを返します。

戻り値:
アカウントＩＤ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ActivityHTTPActionEventHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス ActivityHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler
                    拡張 jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler
public class ActivityHTTPActionEventHandler
extends ServletHTTPActionEventHandler

持続したセッションを確立するためのハンドラです。

このハンドラを利用すると、結果として同一のセッションを維持したまま 他のハンドラでサーバに再接続するためのＵＲＬを取得する事ができます。
セッションとは、HTTP セッションであり、 セッションを維持する事によりイベントは javax.servlet.http.HttpSession を 通してセッションデータを共有する事ができます。

複数のハンドラを利用して、同一のセッションでいくつかのイベントを 実行する必要がある場合、まずこのハンドラを利用して セッションを維持しながらイベント実行を要求できるＵＲＬを 取得してください。

このハンドラは、セッションを維持する事を目的としているため、 LimitedSessionHTTPActionEventFilterHandler と併用しても 意味がありません。
また、取得されたＵＲＬを利用する事により維持されたセッションに アクセスする事になるため、毎回ログインセッション環境を作る事も 意味を持ちません。ログインセッション環境を利用する場合は、 このハンドラを実行するときに AccountSecurityHTTPActionEventFilterHandler と併用して環境を作成してしまう方法が最も効率的です。 一度ログインセッション環境を作成してしまえば、以後の呼び出しでは ログイン環境を作成するためのフィルタを利用する必要はありません。

導入されたバージョン:
version 4.3

コンストラクタの概要
ActivityHTTPActionEventHandler()
新しいイベントハンドラを作成します。
ActivityHTTPActionEventHandler(String url)
指定のＵＲＬに再接続するための新しいイベントハンドラを作成します。
メソッドの概要
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
String | getName() イベント名を返します。
クラス jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler から継承したメソッド
getLocation, setLocation
クラス jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler から継承したメソッド
getQueryString, getURL, getURL, getURL, getURL, getURL, getURL
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ActivityHTTPActionEventHandler

public ActivityHTTPActionEventHandler()
新しいイベントハンドラを作成します。

このコンストラクタを利用して作成されたハンドラでは、 再接続ＵＲＬはサーバ内で自動解決されます。 明示的にＵＲＬを指定したい場合は、 ServletHTTPActionEventHandler.setLocation(java.lang.String) メソッドを利用して 再接続 URL を設定してください。

ActivityHTTPActionEventHandler

public ActivityHTTPActionEventHandler(String url)
指定のＵＲＬに再接続するための新しいイベントハンドラを作成します。

引数 url には、HTTPActionEvent のリスナーとなっている サーブレットへアクセスするためのＵＲＬを指定してください。

パラメータ:
url - URL
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
イベント名を返します。

実際には、Application Runtime で実行される jp.co.intra_mart.foundation.service.client.application.HTTPActionEvent を 実装したクラスのクラス名を返します。

オーバーライド:
クラス ServletHTTPActionEventHandler 内の getName
戻り値:
イベント名

getEventRequestParameterMap

protected Properties getEventRequestParameterMap()
                                          throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

オーバーライド:
クラス ServletHTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ConcreteHTTPActionEventHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス ConcreteHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler
public class ConcreteHTTPActionEventHandler
extends HTTPActionEventEntityHandler

任意の HTTPActionEvent を実行するためのハンドラです。

このハンドラを利用する事により、作成したイベントに 対応するハンドラを特別に作成することなく、 任意のイベントを実行する事ができます。
このハンドラは、HTTPActionEvent の汎用ハンドラのため、 HTTPActionEvent 呼び出し時のパラメータを隠蔽化したい場合などは、 独自のハンドラを定義する必要がありますが、通常はこのハンドラで ほとんどの要件を満たせると思われます。

導入されたバージョン:
version 4.3

コンストラクタの概要
ConcreteHTTPActionEventHandler(String name)
指定のイベント名で表されるイベントを実行するためのハンドラを作成します。
メソッドの概要
 String getName()
イベント名を返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getEventRequestParameterMap, getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ConcreteHTTPActionEventHandler

public ConcreteHTTPActionEventHandler(String name)
指定のイベント名で表されるイベントを実行するためのハンドラを作成します。

パラメータ:
name - イベント名
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventEntityHandler 内の getName
戻り値:
イベント名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GroupSecurityHTTPActionEventFilterHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス GroupSecurityHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
直系の既知のサブクラス:
AccountSecurityHTTPActionEventFilterHandler
public class GroupSecurityHTTPActionEventFilterHandler
extends HTTPActionEventFilterHandler

ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

このフィルタを利用する事により、任意のログイングループによる ログインセッション環境を作る事ができます。 このフィルタを利用する事により、 イベントプログラム中でログイングループを自動解決するＡＰＩを 利用可能になります。

実在しないグループを指定した場合、 未来の予測できないエラーを回避するために、 フィルタ処理の途中で即座に例外がスローされてます。 結果として、イベント実行はエラー終了します。
フィルタがエラー終了した場合、セキュリティホールとならないために セッションを破棄(javax.servlet.http.HttpSession#invalidate())します。 したがって、認証前にセッションに保存した情報にはアクセスできなくなります。 認証エラー後にセッション内の情報が必要な場合は、 事前に取得して別な場所へ保管するなどの対策が必要です。

導入されたバージョン:
version 4.3

フィールドの概要
protected static String ID_SECURITY_GROUP
コンストラクタの概要
GroupSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId)
ログイングループセッション環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
メソッドの概要
String | getGroup() 設定されているグループＩＤを返します。
String | getName() フィルタイベント名を返します。
protected void | setGroup(String groupId) グループＩＤを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_SECURITY_GROUP

protected static final String ID_SECURITY_GROUP
関連項目:
定数フィールド値
コンストラクタの詳細

GroupSecurityHTTPActionEventFilterHandler

public GroupSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler,
                                                 String groupId)
ログイングループセッション環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
groupId - グループＩＤ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventFilterHandler 内の getName
戻り値:
イベント名

setGroup

protected void setGroup(String groupId)
グループＩＤを設定します。

パラメータ:
groupId - グループＩＤ

getGroup

public String getGroup()
設定されているグループＩＤを返します。

戻り値:
グループＩＤ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventContent (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
インタフェース HTTPActionEventContent

すべてのスーパーインタフェース:
HTTPActionEventResult
public interface HTTPActionEventContent
extends HTTPActionEventResult

Web コンテンツを取得するための共通インターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
byte[] | getBytes() サーバからレスポンスされたコンテンツのソースをバイト列として返します。
URL | getRequestURL() このコンテンツを取得するために使用した URL を返します。
インタフェース jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult から継承したメソッド
getConnection, getInputStream, getResponseCode, getResponseMessage, isError

メソッドの詳細

getRequestURL

public URL getRequestURL()
このコンテンツを取得するために使用した URL を返します。

戻り値:
URL

getBytes

public byte[] getBytes()
                throws IOException
サーバからレスポンスされたコンテンツのソースをバイト列として返します。

何らかのエラーによりソースを受信できなかった場合、 このメソッドは null を返します。

戻り値:
コンテンツソースのバイト列。または null。
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventEntityHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventEntityHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
直系の既知のサブクラス:
ConcreteHTTPActionEventHandler, WebApplicationHTTPActionEventHandler
public abstract class HTTPActionEventEntityHandler
extends HTTPActionEventHandler

HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。

この抽象実装は、すべての HTTPActionEvent ハンドラの スーパークラスになります。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected HTTPActionEventEntityHandler()
新しいイベントハンドラを作成します。
メソッドの概要
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
abstract String | getName() イベント名を返します。
String | getParameter(String key) 設定したパラメータ値を取得します。
Set | getParameterKeySet() 現在、パラメータとして設定されているキーの一覧を返します。
Properties | getParameterMap() 設定済みパラメータのマップのコピーを返します。
boolean | hasParameter(String key) 設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
void | removeParameter(String key) 指定のキーのマップを削除します。
void | setParameter(String key, String value) イベントへのパラメータを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPActionEventEntityHandler

protected HTTPActionEventEntityHandler()
新しいイベントハンドラを作成します。

メソッドの詳細

getName

public abstract String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventHandler 内の getName
戻り値:
イベント名

setParameter

public void setParameter(String key,
                         String value)
イベントへのパラメータを設定します。 ここで設定した値は、Application Runtime で実行されるイベントにて、 通常のＵＲＬ引数として受け取ることができます。 値を取得するには、サーブレットプログラムにおいてＵＲＬパラメータを 取得する一般的な方法と同様に、HttpServletRequest#getParameter(String) を利用してください。

定義:
クラス HTTPActionEventHandler 内の setParameter
パラメータ:
key - キー
value - 値

getParameter

public String getParameter(String key)
設定したパラメータ値を取得します。 指定のキーにマップされている値が存在しない場合、null を返します。

定義:
クラス HTTPActionEventHandler 内の getParameter
パラメータ:
key - キー
戻り値:
キーにマップされているパラメータ値

hasParameter

public boolean hasParameter(String key)
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。

定義:
クラス HTTPActionEventHandler 内の hasParameter
パラメータ:
key - キー
戻り値:
キーにパラメータ値がマップされている場合 true。

getParameterKeySet

public Set getParameterKeySet()
現在、パラメータとして設定されているキーの一覧を返します。

定義:
クラス HTTPActionEventHandler 内の getParameterKeySet
戻り値:
キーのセット

removeParameter

public void removeParameter(String key)
指定のキーのマップを削除します。 削除されたキーおよびそのキーにマップされた値は、Application Runtime に送信されなくなります。

定義:
クラス HTTPActionEventHandler 内の removeParameter
パラメータ:
key - キー

getParameterMap

public Properties getParameterMap()
設定済みパラメータのマップのコピーを返します。 パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。

定義:
クラス HTTPActionEventHandler 内の getParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

getEventRequestParameterMap

protected Properties getEventRequestParameterMap()
                                          throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

定義:
クラス HTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventFilterHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
直系の既知のサブクラス:
AccessibleLinkHTTPActionEventFilterHandler, ActivityFrameworkHTTPActionEventFilterHandler, GroupSecurityHTTPActionEventFilterHandler, LimitedSessionHTTPActionEventFilterHandler
public abstract class HTTPActionEventFilterHandler
extends HTTPActionEventHandler

HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。

HTTPActionEventHandler をフィルタリングする HTTPActionEventHandler は、 このクラスをスーパークラスとして実装する事を推奨します。

ユーザプログラムでは、フィルタリングしたいハンドラを基礎ハンドラとして フィルタハンドラを作成し、フィルタハンドラの HTTPActionEventHandler.execute(java.net.HttpURLConnection) を呼び出すことで、 Application Runtime でフィルタされた効果を得ながら 基礎ハンドラが指定するイベントを実行する事ができます。
なお、このハンドラを利用して呼び出すフィルターイベントは、 FilterHTTPActionEvent を実装しているクラスでなければいけません。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected HTTPActionEventFilterHandler(HTTPActionEventHandler handler)
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラを作成します。
メソッドの概要
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected String | getFilterParameter(String key) このフィルタのパラメータを返します。
protected Properties | getFilterParameterMap() このハンドラによって実行されるフィルタイベントに対する 設定済みパラメータのマップを返します。
abstract String | getName() フィルタイベント名を返します。
String | getParameter(String key) 設定したパラメータ値を取得します。
Set | getParameterKeySet() 現在、パラメータとして設定されているキーの一覧を返します。
Properties | getParameterMap() 設定済みパラメータのマップのコピーを返します。
HTTPActionEventHandler | getParent() このオブジェクトがフィルタリングしているハンドラを返します。
boolean | hasParameter(String key) 設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
protected String | removeFilterParameter(String key) このフィルタのパラメータを削除します。
void | removeParameter(String key) 指定のキーのマップを削除します。
protected void | setFilterParameter(String key, String value) このフィルタのパラメータを設定します。
void | setParameter(String key, String value) イベントへのパラメータを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPActionEventFilterHandler

protected HTTPActionEventFilterHandler(HTTPActionEventHandler handler)
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getParent

public HTTPActionEventHandler getParent()
このオブジェクトがフィルタリングしているハンドラを返します。

戻り値:
ハンドラ

getName

public abstract String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventHandler 内の getName
戻り値:
イベント名

setParameter

public void setParameter(String key,
                         String value)
イベントへのパラメータを設定します。 ここで設定した値は、Application Runtime で実行されるイベントにて、 通常のＵＲＬ引数として受け取ることができます。 値を取得するには、サーブレットプログラムにおいてＵＲＬパラメータを 取得する一般的な方法と同様に、HttpServletRequest#getParameter(String) を利用してください。

このメソッドは、単純のラップしている親ハンドラの #getParameter(String, String) を呼び出します。

定義:
クラス HTTPActionEventHandler 内の setParameter
パラメータ:
key - キー
value - 値

getParameter

public String getParameter(String key)
設定したパラメータ値を取得します。 指定のキーにマップされている値が存在しない場合、null を返します。

このメソッドは、単純のラップしている親ハンドラの #getParameter(String) を呼び出します。

定義:
クラス HTTPActionEventHandler 内の getParameter
パラメータ:
key - キー
戻り値:
キーにマップされているパラメータ値

hasParameter

public boolean hasParameter(String key)
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。

このメソッドは、単純のラップしている親ハンドラの #hasParameter(String) を呼び出します。

定義:
クラス HTTPActionEventHandler 内の hasParameter
パラメータ:
key - キー
戻り値:
キーにパラメータ値がマップされている場合 true。

getParameterKeySet

public Set getParameterKeySet()
現在、パラメータとして設定されているキーの一覧を返します。

このメソッドは、単純のラップしている親ハンドラの #getParameterKeySet() を呼び出します。

定義:
クラス HTTPActionEventHandler 内の getParameterKeySet
戻り値:
キーのセット

removeParameter

public void removeParameter(String key)
指定のキーのマップを削除します。 削除されたキーおよびそのキーにマップされた値は、Application Runtime に送信されなくなります。

このメソッドは、単純のラップしている親ハンドラの #removeParameter(String) を 呼び出します。

定義:
クラス HTTPActionEventHandler 内の removeParameter
パラメータ:
key - キー

getParameterMap

public Properties getParameterMap()
設定済みパラメータのマップのコピーを返します。 パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。

このメソッドは、単純のラップしている親ハンドラの #getParameterMap() を 呼び出します。

定義:
クラス HTTPActionEventHandler 内の getParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

setFilterParameter

protected void setFilterParameter(String key,
                                  String value)
このフィルタのパラメータを設定します。

パラメータ:
key - パラメータ名
value - パラメータの値

getFilterParameter

protected String getFilterParameter(String key)
このフィルタのパラメータを返します。

パラメータ:
key - パラメータ名
戻り値:
パラメータの値

removeFilterParameter

protected String removeFilterParameter(String key)
このフィルタのパラメータを削除します。

パラメータ:
key - パラメータ名
戻り値:
設定されていたパラメータの値

getFilterParameterMap

protected Properties getFilterParameterMap()
                                    throws HTTPActionEventHandlerParameterException
このハンドラによって実行されるフィルタイベントに対する 設定済みパラメータのマップを返します。 パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。

戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

getEventRequestParameterMap

protected final Properties getEventRequestParameterMap()
                                                throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。

定義:
クラス HTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
直系の既知のサブクラス:
HTTPActionEventEntityHandler, HTTPActionEventFilterHandler
public abstract class HTTPActionEventHandler
extends Object

HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。

この抽象実装は、すべての HTTPActionEvent ハンドラの スーパークラスになります。

ハンドラを作成してイベント実行を要求する場合、execute(String) または execute(java.net.URL) を利用します。 execute(java.net.HttpURLConnection) も利用できますが、 通常はこの方法を使わない方が良いと思われます。

イベント実行を要求するＵＲＬは、 HTTPActionEventListener へ接続できるものを指定します。 標準では、下記のようになります。
http://<サーバアドレス>[:<ポート番号>]/imart/HTTPActionEventListener

外部ソフトウェア接続モジュールでは、HTTPS プロトコルを利用した通信が可能です。
以下に、簡単にHTTPSプロトコルを利用した通信を行う方法を記します。

  1. 証明書の追加

    2. JDK 付属のツール keytool の -import コマンドを使って、信頼できる証明書をリストに追加します。
    例えば、サーバ証明書「C:¥temp¥server.crt」を、 別名「sample_alias」でキーストアエントリに格納するには、以下のコマンドを実行します。
     >keytool -import -alias sample_alias -file C:¥temp¥server.crt
    上記コマンドを実行すると、ユーザのホームディレクトリの「.keystore」ファイルに、キーストアが作成されます。
    （keytoolの詳細は、 keytool - 鍵と証明書の管理ツール を参照してください）

  2. キーストアを指定して、クライアントを実行

    3. 外部ソフトウェア接続モジュールのクライアントが、証明書ファイルを利用できる状態に設定します。
    java コマンドを実行する際、次のオプションをコマンド行に追加し、手順1 で追加したキーストアを指定します。
    ここでは、ユーザのホームディレクトリを「 /home/user_name 」とします。
    -Djavax.net.ssl.trustStore=/home/user_name/.keystore

    Windows環境の例 （ホームディレクトリが「 C:¥Documents and Settings¥user_name 」の場合）
    -Djavax.net.ssl.trustStore="C:¥¥Documents and Settings¥¥user_name¥¥.keystore"
簡単にHTTPSプロトコルを利用した通信を行う方法は 以上です。

外部ソフトウェア接続モジュールは、HTTPS プロトコルを利用した通信を行う際に、 HttpsURLConnection を利用して通信を行います。
そのため、デフォルト動作をオーバライドしたい場合、以下の二つを設定する必要があります。

  • javax.net.ssl.HostnameVerifier

    • 外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の HostnameVerifier を setHostnameVerifier(HostnameVerifier) メソッドで設定します。
    （この HostnameVerifier は、URL ホスト名のデフォルトの検証規則が失敗した場合に使用されます）
    HostnameVerifier が設定されていない場合、
    ホスト名が認証方式に準拠しているかどうかに関わらず、接続を許可します。

  • javax.net.ssl.SSLContext

    • 外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の SSLSocketFactory を生成する SSLContextを、setSSLContext(SSLContext) メソッドで設定します。
    SSLContext が設定されていない場合、
    HttpsURLConnection に対して SSLSocketFactory の設定を行いません。
HTTPS プロトコルを利用した通信を行うには、Java Secure Socket Extension (JSSE) の知識が必要です。
詳しくは、 Java Secure Socket Extension (JSSE) リファレンスガイド を参照してください。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected HTTPActionEventHandler()
新しいイベントハンドラを作成します。
メソッドの概要
HTTPActionEventResult | execute(HttpURLConnection connection) 指定された URL コネクションを利用してにサーバに接続し、 イベントの実行を要求します。
HTTPActionEventResult | execute(String url) 指定された URL に接続して、 イベントの実行を要求します。
HTTPActionEventResult | execute(URL url) 指定された URL に接続して、 イベントの実行を要求します。
String | getCharacterEncoding() パラメータを符号化するためのエンコーディング名を返します。
protected abstract Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
abstract String | getName() イベント名を返します。
abstract String | getParameter(String key) 設定したパラメータ値を取得します。
abstract Set | getParameterKeySet() 現在、パラメータとして設定されているキーの一覧を返します。
abstract Properties | getParameterMap() 設定済みパラメータのマップのコピーを返します。
abstract boolean | hasParameter(String key) 設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
abstract void | removeParameter(String key) 指定のキーのマップを削除します。
void | setCharacterEncoding(String enc) パラメータを符号化するためのエンコーディング名を指定します。
void | setHostnameVerifier(HostnameVerifier hostnameVerifier) 外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の HostnameVerifier を設定します。
abstract void | setParameter(String key, String value) イベントへのパラメータを設定します。
void | setSSLContext(SSLContext sslContext) 外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の SSLSocketFactory を生成する SSLContextを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPActionEventHandler

protected HTTPActionEventHandler()
新しいイベントハンドラを作成します。

メソッドの詳細

getName

public abstract String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

戻り値:
イベント名

setParameter

public abstract void setParameter(String key,
                                  String value)
イベントへのパラメータを設定します。 ここで設定した値は、Application Runtime で実行されるイベントにて、 通常のＵＲＬ引数として受け取ることができます。 値を取得するには、サーブレットプログラムにおいてＵＲＬパラメータを 取得する一般的な方法と同様に、HttpServletRequest#getParameter(String) を利用してください。

パラメータ:
key - キー
value - 値

getParameter

public abstract String getParameter(String key)
設定したパラメータ値を取得します。 指定のキーにマップされている値が存在しない場合、null を返します。

パラメータ:
key - キー
戻り値:
キーにマップされているパラメータ値

hasParameter

public abstract boolean hasParameter(String key)
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。

パラメータ:
key - キー
戻り値:
キーにパラメータ値がマップされている場合 true。

getParameterKeySet

public abstract Set getParameterKeySet()
現在、パラメータとして設定されているキーの一覧を返します。

戻り値:
キーのセット

removeParameter

public abstract void removeParameter(String key)
指定のキーのマップを削除します。 削除されたキーおよびそのキーにマップされた値は、Application Runtime に送信されなくなります。

パラメータ:
key - キー

getParameterMap

public abstract Properties getParameterMap()
設定済みパラメータのマップのコピーを返します。 パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。

戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

getEventRequestParameterMap

protected abstract Properties getEventRequestParameterMap()
                                                   throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

getCharacterEncoding

public String getCharacterEncoding()
パラメータを符号化するためのエンコーディング名を返します。

戻り値:
文字エンコーディング名

setCharacterEncoding

public void setCharacterEncoding(String enc)
                          throws UnsupportedEncodingException
パラメータを符号化するためのエンコーディング名を指定します。

デフォルトでは UTF-8 を用いてパラメータを符号化します。 また、イベントへの各パラメータ値は Unicode のまま扱われますので、 通常は文字エンコーディングを変更する必要はありません。

パラメータ:
enc - 文字エンコーディング名
例外:
UnsupportedEncodingException - 指定のエンコーディング名がサポートされない場合

execute

public HTTPActionEventResult execute(String url)
                              throws MalformedURLException,
                                     IOException,
                                     HTTPActionEventHandlerException
指定された URL に接続して、 イベントの実行を要求します。

このメソッドは、指定の URL 文字列から java.net.URL のインスタンスを 作成して execute(java.net.URL) メソッドを呼び出します。

パラメータ:
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
HTTPActionEventHandlerException - 実行時エラー
MalformedURLException
IOException

execute

public HTTPActionEventResult execute(URL url)
                              throws IOException,
                                     HTTPActionEventHandlerException
指定された URL に接続して、 イベントの実行を要求します。

このメソッドは、指定の java.net.URL から java.net.HttpURLConnection を取得して execute(java.net.HttpURLConnection) メソッドを呼び出します。

パラメータ:
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
HTTPActionEventHandlerException - 実行時エラー
IOException

execute

public HTTPActionEventResult execute(HttpURLConnection connection)
                              throws IOException,
                                     HTTPActionEventHandlerException
指定された URL コネクションを利用してにサーバに接続し、 イベントの実行を要求します。

このメソッドは、 getParameterMap() の返り値をイベントの引数として サーバに対して getName() が表すイベントの 実行を要求します。

パラメータ:
connection - コネクション
戻り値:
実行結果オブジェクト
例外:
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー

setHostnameVerifier

public void setHostnameVerifier(HostnameVerifier hostnameVerifier)
外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の HostnameVerifier を設定します。
（このHostnameVerifierは、URL ホスト名のデフォルトの検証規則が失敗した場合に使用されます）

HostnameVerifier が設定されていない場合、
ホスト名が認証方式に準拠しているかどうかに関わらず、接続を許可します。

パラメータ:
hostnameVerifier - 外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の HostnameVerifier
導入されたバージョン:
version 6.1

setSSLContext

public void setSSLContext(SSLContext sslContext)
外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の SSLSocketFactory を生成する SSLContextを設定します。
SSLContext が設定されていない場合、
HttpsURLConnection に対して SSLSocketFactory の設定を行いません。

デフォルト動作をオーバライドする場合を除き、 SSLContext オブジェクトを直接作成したり初期化したりする必要はありません。

パラメータ:
sslContext - SSLContext
導入されたバージョン:
version 6.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventHandlerException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventHandlerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
HTTPActionEventHandlerParameterException
public class HTTPActionEventHandlerException
extends Exception

HTTPActionEventHandler 内で発生したエラーを通知するための例外です。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
HTTPActionEventHandlerException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerException(String msg, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HTTPActionEventHandlerException

public HTTPActionEventHandlerException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

HTTPActionEventHandlerException

public HTTPActionEventHandlerException(String msg,
                                       Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventHandlerParameterException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventHandlerParameterException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException
                拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException
すべての実装インタフェース:
Serializable
public class HTTPActionEventHandlerParameterException
extends HTTPActionEventHandlerException

HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
HTTPActionEventHandlerParameterException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerParameterException(String msg, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HTTPActionEventHandlerParameterException

public HTTPActionEventHandlerParameterException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

HTTPActionEventHandlerParameterException

public HTTPActionEventHandlerParameterException(String msg,
                                                Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventResult (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
インタフェース HTTPActionEventResult

既知のサブインタフェースの一覧:
HTTPActionEventContent, HTTPActionEventURL
既知の実装クラスの一覧:
HTTPActionEventResultWrapper
public interface HTTPActionEventResult

HTTPActionEvent 実行要求の結果に関する共通インターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
HttpURLConnection | getConnection() 接続に利用したコネクションを返します。
InputStream | getInputStream() サーバからの入力を受け付ける入力ストリームを返します。
int | getResponseCode() サーバからのHTTPレスポンスコードを返します。
String | getResponseMessage() サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。
boolean | isError() 処理要求が成功したかどうかを判定します。

メソッドの詳細

getConnection

public HttpURLConnection getConnection()
接続に利用したコネクションを返します。

戻り値:
コネクション

getResponseCode

public int getResponseCode()
                    throws IOException
サーバからのHTTPレスポンスコードを返します。

返されるレスポンスコードについては、 HttpURLConnection の 仕様に準じます。

接続そのものに失敗した場合など、サーバから HTTP レスポンスコードを 受け取れなかった場合、 このメソッドは java.io.IOException をスローします。

戻り値:
レスポンスコード
例外:
IOException - 入出力エラーが発生した場合

getResponseMessage

public String getResponseMessage()
                          throws IOException
サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。

このメソッドは、java.net.HttpURLConnection の #getResponseMessage() メソッドの仕様に準じます。

戻り値:
HTTP 応答メッセージまたは null
例外:
IOException - サーバへの接続でエラーが発生した場合

getInputStream

public InputStream getInputStream()
                           throws IOException
サーバからの入力を受け付ける入力ストリームを返します。 この入力ストリームによりレスポンスデータを得る事ができます。

戻り値:
入力ストリーム
例外:
IOException - 入力ストリームの作成中に入出力エラーが発生した場合
UnknownServiceException - プロトコルが入力をサポートしていない場合

isError

public boolean isError()
処理要求が成功したかどうかを判定します。

このメソッドでは、HTTP のレスポンスコードが 200 かどうかで、 判定しています。

戻り値:
エラーなく処理終了しなかった場合 true。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventResultWrapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventResultWrapper

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper
すべての実装インタフェース:
HTTPActionEventResult
public class HTTPActionEventResultWrapper
extends Object
implements HTTPActionEventResult

HTTPActionEventResult のラッパーオブジェクトです。
このクラスでは、基本的にラップしているオブジェクトからの 返り値をそのままリターンします。 必要に応じてサブクラスを作成し、サブクラス側で必要な処理を メソッドをオーバーライドすることにより実装してください。

導入されたバージョン:
version 4.3

コンストラクタの概要
HTTPActionEventResultWrapper(HTTPActionEventResult parent)
指定の結果オブジェクトをラップする新しい結果オブジェクトを作成します。
メソッドの概要
HttpURLConnection | getConnection() 接続に利用したコネクションを返します。
InputStream | getInputStream() サーバからの入力を受け付ける入力ストリームを返します。
protected HTTPActionEventResult | getParent() ラップしている親オブジェクトを返します。
int | getResponseCode() サーバからのHTTPレスポンスコードを返します。
String | getResponseMessage() サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。
boolean | isError() 処理要求が成功したかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPActionEventResultWrapper

public HTTPActionEventResultWrapper(HTTPActionEventResult parent)
指定の結果オブジェクトをラップする新しい結果オブジェクトを作成します。

パラメータ:
parent - ラップする結果オブジェクト
メソッドの詳細

getConnection

public HttpURLConnection getConnection()
接続に利用したコネクションを返します。

定義:
インタフェース HTTPActionEventResult 内の getConnection
戻り値:
コネクション

getResponseCode

public int getResponseCode()
                    throws IOException
サーバからのHTTPレスポンスコードを返します。

返されるレスポンスコードについては、 javax.servlet.http.HttpURLConnection#getResponseCode() の 仕様に準じます。

接続そのものに失敗した場合など、サーバから HTTP レスポンスコードを 受け取れなかった場合、 このメソッドは java.io.IOException をスローします。

定義:
インタフェース HTTPActionEventResult 内の getResponseCode
戻り値:
レスポンスコード
例外:
IOException - 入出力エラーが発生した場合

getResponseMessage

public String getResponseMessage()
                          throws IOException
サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。

このメソッドは、java.net.HttpURLConnection の #getResponseMessage() メソッドの仕様に準じます。

定義:
インタフェース HTTPActionEventResult 内の getResponseMessage
戻り値:
HTTP 応答メッセージまたは null
例外:
IOException - サーバへの接続でエラーが発生した場合

getInputStream

public InputStream getInputStream()
                           throws IOException
サーバからの入力を受け付ける入力ストリームを返します。 この入力ストリームによりレスポンスデータを得る事ができます。

定義:
インタフェース HTTPActionEventResult 内の getInputStream
戻り値:
入力ストリーム
例外:
IOException - 入力ストリームの作成中に入出力エラーが発生した場合
UnknownServiceException - プロトコルが入力をサポートしていない場合

isError

public boolean isError()
処理要求が成功したかどうかを判定します。

定義:
インタフェース HTTPActionEventResult 内の isError
戻り値:
エラーなく処理終了した場合 false。

getParent

protected HTTPActionEventResult getParent()
ラップしている親オブジェクトを返します。

戻り値:
ラップしている結果オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventURL (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
インタフェース HTTPActionEventURL

すべてのスーパーインタフェース:
HTTPActionEventResult
public interface HTTPActionEventURL
extends HTTPActionEventResult

Web コンテンツへのアクセスＵＲＬを取得するための共通インターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
 HTTPActionEventContent getContent()
getURL() によって表されるコンテンツのソースを取得します。
 String getURL()
サーバから返されたＵＲＬを返します。
インタフェース jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult から継承したメソッド
getConnection, getInputStream, getResponseCode, getResponseMessage, isError

メソッドの詳細

getURL

public String getURL()
              throws IOException
サーバから返されたＵＲＬを返します。

戻り値:
ＵＲＬ
例外:
IOException - 入出力エラー

getContent

public HTTPActionEventContent getContent()
                                  throws MalformedURLException,
                                         IOException
getURL() によって表されるコンテンツのソースを取得します。

戻り値:
サーバからの応答オブジェクト
例外:
MalformedURLException - URL のフォーマットエラー
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LimitedSessionHTTPActionEventFilterHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス LimitedSessionHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler
public class LimitedSessionHTTPActionEventFilterHandler
extends HTTPActionEventFilterHandler

セッションを一時利用のみに限定するためのフィルタです。

イベント HTTPActionEvent では、セッション情報を扱う場合 javax.servlet.http.HttpSession を利用します。 したがって、明示的にセッション(javax.servlet.http.HttpSession)を破棄しない場合、 セッションのタイムアウトが発生するまで、サーバのメモリリソースを 消費したままの状態が維持されてしまいます。
このフィルタは、イベント処理終了時に javax.servlet.http.HttpSession#invalidate() を 実行してセッションを明示的に破棄します。 セッションを維持する必要のないイベント実行では、 このフィルタを利用することにより、サーバリソースの無駄な利用を 回避する事ができます。

導入されたバージョン:
version 4.3

コンストラクタの概要
LimitedSessionHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
セッションを一時利用に限定するためのフィルタハンドラを作成します。
メソッドの概要
 String getName()
フィルタイベント名を返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LimitedSessionHTTPActionEventFilterHandler

public LimitedSessionHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
セッションを一時利用に限定するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventFilterHandler 内の getName
戻り値:
イベント名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.client.application (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.service.client.application
インタフェース
HTTPActionEventContent
HTTPActionEventResult
HTTPActionEventURL
クラス
AccountSecurityHTTPActionEventFilterHandler
ActivityHTTPActionEventHandler
ConcreteHTTPActionEventHandler
GroupSecurityHTTPActionEventFilterHandler
HTTPActionEventEntityHandler
HTTPActionEventFilterHandler
HTTPActionEventHandler
HTTPActionEventResultWrapper
LimitedSessionHTTPActionEventFilterHandler
PasswordSecurityHTTPActionEventFilterHandler
ServletHTTPActionEventHandler
WebApplicationHTTPActionEventHandler
例外
HTTPActionEventHandlerException
HTTPActionEventHandlerParameterException


jp.co.intra_mart.foundation.service.client.application (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.application

このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

参照:
説明

インタフェースの概要
HTTPActionEventContent | Web コンテンツを取得するための共通インターフェースです。
HTTPActionEventResult | HTTPActionEvent 実行要求の結果に関する共通インターフェースです。
HTTPActionEventURL | Web コンテンツへのアクセスＵＲＬを取得するための共通インターフェースです。

クラスの概要
AccountSecurityHTTPActionEventFilterHandler | ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
ActivityHTTPActionEventHandler | 持続したセッションを確立するためのハンドラです。
ConcreteHTTPActionEventHandler | 任意の HTTPActionEvent を実行するためのハンドラです。
GroupSecurityHTTPActionEventFilterHandler | ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
HTTPActionEventEntityHandler | HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventFilterHandler | HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
HTTPActionEventHandler | HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventResultWrapper | HTTPActionEventResult のラッパーオブジェクトです。
LimitedSessionHTTPActionEventFilterHandler | セッションを一時利用のみに限定するためのフィルタです。
PasswordSecurityHTTPActionEventFilterHandler | ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
ServletHTTPActionEventHandler | Web-Application を実行するためのイベントハンドラです。
WebApplicationHTTPActionEventHandler | フレームワークを実行するためのイベントハンドラの抽象実装です。

例外の概要
HTTPActionEventHandlerException | HTTPActionEventHandler 内で発生したエラーを通知するための例外です。
HTTPActionEventHandlerParameterException | HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。

パッケージ jp.co.intra_mart.foundation.service.client.application の説明

このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
このパッケージを利用することにより、intra-mart ではない環境から intra-mart 内のプログラム実行を行うことができるようになりますので、例えばユーザ情報の同期など、様々なことを実現することができます。

導入されたバージョン:
version 4.0


jp.co.intra_mart.foundation.service.client.application クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.application の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
        • class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler
        • class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler
            • class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
          • class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
            • class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper (implements jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException
          • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException

インタフェース階層

  • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult
    • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent
    • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL


パッケージ jp.co.intra_mart.foundation.service.client.application の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client.application の使用

jp.co.intra_mart.foundation.service.client.application を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application により使用される jp.co.intra_mart.foundation.service.client.application のクラス
AccountSecurityHTTPActionEventFilterHandler
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
GroupSecurityHTTPActionEventFilterHandler
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
HTTPActionEventContent
Web コンテンツを取得するための共通インターフェースです。
HTTPActionEventEntityHandler
HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventFilterHandler
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
HTTPActionEventHandler
HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventHandlerException
HTTPActionEventHandler 内で発生したエラーを通知するための例外です。
HTTPActionEventHandlerParameterException
HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。
HTTPActionEventResult
HTTPActionEvent 実行要求の結果に関する共通インターフェースです。
HTTPActionEventURL
Web コンテンツへのアクセスＵＲＬを取得するための共通インターフェースです。
ServletHTTPActionEventHandler
Web-Application を実行するためのイベントハンドラです。
WebApplicationHTTPActionEventHandler
フレームワークを実行するためのイベントハンドラの抽象実装です。

jp.co.intra_mart.foundation.service.client.application.content により使用される jp.co.intra_mart.foundation.service.client.application のクラス
HTTPActionEventEntityHandler
HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventFilterHandler
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
HTTPActionEventHandler
HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventHandlerParameterException
HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。
WebApplicationHTTPActionEventHandler
フレームワークを実行するためのイベントハンドラの抽象実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PasswordSecurityHTTPActionEventFilterHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス PasswordSecurityHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
                    拡張 jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler
public class PasswordSecurityHTTPActionEventFilterHandler
extends AccountSecurityHTTPActionEventFilterHandler

ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

このフィルタを利用する事により、任意のログイングループ内の任意のアカウントで ログインした状態の環境を作る事ができます。 ログイン環境でイベントを動作させる事により、 イベントプログラム中でログインセッションを必要とするＡＰＩを 利用可能になります。

このフィルタは、AccountSecurityHTTPActionEventFilterHandler の機能に加えて パスワード認証も行います。したがって、AccountSecurityHTTPActionEventFilterHandler よりも 高度なセキュリティを実現しながらイベントを実行する事が可能となります。

このフィルタを利用する場合は、 必ずログイン環境を作れるアカウントを作成しておく必要があります。 実在しないアカウントを指定したりパスワードが正しくない場合、 未来の予測できないエラーを回避するために、 フィルタ処理の途中で即座に例外がスローされてます。 結果として、イベント実行はエラー終了します。
フィルタがエラー終了した場合、セキュリティホールとならないために セッションを破棄(javax.servlet.http.HttpSession#invalidate())します。 したがって、認証前にセッションに保存した情報にはアクセスできなくなります。 認証エラー後にセッション内の情報が必要な場合は、 事前に取得して別な場所へ保管するなどの対策が必要です。

導入されたバージョン:
version 4.3

フィールドの概要
protected static String ID_SECURITY_PASSWORD
クラス jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler から継承したフィールド
ID_SECURITY_ACCOUNT
クラス jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler から継承したフィールド
ID_SECURITY_GROUP
コンストラクタの概要
PasswordSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId, String accountId, String password)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
メソッドの概要
String | getName() フィルタイベント名を返します。
String | getPassword() 設定されているパスワードを返します。
protected void | setPassword(String password) パスワードを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler から継承したメソッド
getAccount, setAccount
クラス jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler から継承したメソッド
getGroup, setGroup
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_SECURITY_PASSWORD

protected static final String ID_SECURITY_PASSWORD
関連項目:
定数フィールド値
コンストラクタの詳細

PasswordSecurityHTTPActionEventFilterHandler

public PasswordSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler,
                                                    String groupId,
                                                    String accountId,
                                                    String password)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
groupId - グループＩＤ
accountId - アカウントＩＤ
password - パスワード
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

オーバーライド:
クラス AccountSecurityHTTPActionEventFilterHandler 内の getName
戻り値:
イベント名

setPassword

protected void setPassword(String password)
パスワードを設定します。

パラメータ:
password - パスワード

getPassword

public String getPassword()
設定されているパスワードを返します。

戻り値:
パスワード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServletHTTPActionEventHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス ServletHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler
直系の既知のサブクラス:
ActivityHTTPActionEventHandler
public class ServletHTTPActionEventHandler
extends WebApplicationHTTPActionEventHandler

Web-Application を実行するためのイベントハンドラです。

このハンドラは、指定の Web-Application を実行するための URL を作成して 返します。 ユーザプログラムでは、このハンドラを利用して取得した URL を用いて、 サーバにリクエストすることにより目的のコンテンツのソースを 取得する事ができます。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected | ServletHTTPActionEventHandler() Web-Application をイベント実行するためのハンドラを作成します。
 | ServletHTTPActionEventHandler(String location) 指定のパスで表される Web-Application をイベント実行するためのハンドラを作成します。
メソッドの概要
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
String | getLocation() 設定されている遷移先パスを返します。
String | getName() イベント名を返します。
protected void | setLocation(String location) 遷移先のページパスを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler から継承したメソッド
getQueryString, getURL, getURL, getURL, getURL, getURL, getURL
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ServletHTTPActionEventHandler

protected ServletHTTPActionEventHandler()
Web-Application をイベント実行するためのハンドラを作成します。
このコンストラクタでは表示する画面のパスが設定されません。 サブクラスで setLocation(String) を利用して 画面パスを設定しなければいけません。

ServletHTTPActionEventHandler

public ServletHTTPActionEventHandler(String location)
指定のパスで表される Web-Application をイベント実行するためのハンドラを作成します。

パラメータ:
location - Web-Application のパス
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getName
戻り値:
イベント名

setLocation

protected void setLocation(String location)
遷移先のページパスを設定します。

パラメータ:
location - ページパス
例外:
NullPointerException - 引数が null の場合

getLocation

public String getLocation()
設定されている遷移先パスを返します。

戻り値:
遷移先を表すパス

getEventRequestParameterMap

protected Properties getEventRequestParameterMap()
                                          throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

このメソッドが返す値は、イベントに対するパラメータであって、 getLocation() によって表される画面プログラムに対する リクエストパラメータではない点に注意してください。 getLocation() によって表される画面プログラムに対する リクエストパラメータに関しては、HTTPActionEventEntityHandler.getParameterMap() によって 取得できます。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


WebApplicationHTTPActionEventHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス WebApplicationHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
直系の既知のサブクラス:
PresentationPageHTTPActionEventHandler, ServiceFrameworkHTTPActionEventHandler, ServletHTTPActionEventHandler
public abstract class WebApplicationHTTPActionEventHandler
extends HTTPActionEventEntityHandler

フレームワークを実行するためのイベントハンドラの抽象実装です。

このハンドラは、指定のフレームワークを実行するための URL を作成して 返します。 ユーザプログラムでは、このハンドラを利用して取得した URL を用いて、 サーバにリクエストすることにより目的のコンテンツのソースを 取得する事ができます。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected WebApplicationHTTPActionEventHandler()
Web-Application をイベント実行するためのハンドラを作成します。
メソッドの概要
protected abstract Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
abstract String | getName() イベント名を返します。
protected String | getQueryString() 設定されているパラメータ情報からクエリ文字列を作成して返します。
static HTTPActionEventURL | getURL(HTTPActionEventHandler handler, HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | getURL(HTTPActionEventHandler handler, String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | getURL(HTTPActionEventHandler handler, URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | getURL(HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | getURL(String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | getURL(URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

WebApplicationHTTPActionEventHandler

protected WebApplicationHTTPActionEventHandler()
Web-Application をイベント実行するためのハンドラを作成します。
このコンストラクタでは表示する画面のパスが設定されません。 サブクラスで #setLocation(String) を利用して 画面パスを設定しなければいけません。

メソッドの詳細

getURL

public static HTTPActionEventURL getURL(HTTPActionEventHandler handler,
                                        String url)
                                 throws MalformedURLException,
                                        IOException,
                                        HTTPActionEventHandlerException
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

このメソッドは、HTTPActionEventHandler.execute(String) の結果を HTTPActionEventURL インターフェースでラップして返します。

引数 handler には、このクラスと代入互換のあるオブジェクトまたは、 代入互換のあるオブジェクトをラップしているフィルタハンドラを 指定してください。他のハンドラを指定した場合、正しく結果を得られません。

パラメータ:
handler - ハンドラ
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
MalformedURLException - URL のフォーマットエラー
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー

getURL

public static HTTPActionEventURL getURL(HTTPActionEventHandler handler,
                                        URL url)
                                 throws IOException,
                                        HTTPActionEventHandlerException
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

このメソッドは、HTTPActionEventHandler.execute(URL) の結果を HTTPActionEventURL インターフェースでラップして返します。

引数 handler には、このクラスと代入互換のあるオブジェクトまたは、 代入互換のあるオブジェクトをラップしているフィルタハンドラを 指定してください。他のハンドラを指定した場合、正しく結果を得られません。

パラメータ:
handler - ハンドラ
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー

getURL

public static HTTPActionEventURL getURL(HTTPActionEventHandler handler,
                                        HttpURLConnection connection)
                                 throws IOException,
                                        HTTPActionEventHandlerException
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

このメソッドは、HTTPActionEventHandler.execute(HttpURLConnection) の結果を HTTPActionEventURL インターフェースでラップして返します。

引数 handler には、このクラスと代入互換のあるオブジェクトまたは、 代入互換のあるオブジェクトをラップしているフィルタハンドラを 指定してください。他のハンドラを指定した場合、正しく結果を得られません。

パラメータ:
handler - ハンドラ
戻り値:
実行結果オブジェクト
例外:
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー

getName

public abstract String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventEntityHandler 内の getName
戻り値:
イベント名

getEventRequestParameterMap

protected abstract Properties getEventRequestParameterMap()
                                                   throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。

オーバーライド:
クラス HTTPActionEventEntityHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

getQueryString

protected String getQueryString()
                         throws UnsupportedEncodingException
設定されているパラメータ情報からクエリ文字列を作成して返します。

戻り値:
クエリ。パラメータが設定されていない場合は null。
例外:
UnsupportedEncodingException - 設定されている文字エンコーディング名がサポート外

getURL

public HTTPActionEventURL getURL(String url)
                          throws MalformedURLException,
                                 IOException,
                                 HTTPActionEventHandlerException
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

このメソッドは、HTTPActionEventHandler.execute(String) の結果を HTTPActionEventURL インターフェースでラップして返します。

パラメータ:
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
MalformedURLException - URL のフォーマットエラー
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー

getURL

public HTTPActionEventURL getURL(URL url)
                          throws IOException,
                                 HTTPActionEventHandlerException
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

このメソッドは、HTTPActionEventHandler.execute(URL) の結果を HTTPActionEventURL インターフェースでラップして返します。

パラメータ:
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー

getURL

public HTTPActionEventURL getURL(HttpURLConnection connection)
                          throws IOException,
                                 HTTPActionEventHandlerException
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

このメソッドは、HTTPActionEventHandler.execute(HttpURLConnection) の結果を HTTPActionEventURL インターフェースでラップして返します。

戻り値:
実行結果オブジェクト
例外:
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.service.client.batch.Scheduler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.batch.Scheduler の使用

jp.co.intra_mart.foundation.service.client.batch.Scheduler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.service.client.batch (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.service.client.batch
クラス
Scheduler


jp.co.intra_mart.foundation.service.client.batch (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.batch

Schedule Service を利用するためのクラスを提供します。

参照:
説明

クラスの概要
Scheduler Schedule Service の制御をするオブジェクトです。

パッケージ jp.co.intra_mart.foundation.service.client.batch の説明

Schedule Service を利用するためのクラスを提供します。

Schedule Service の情報を取得したり、Schedule Service でプログラムを実行することの できるクラスが用意されています。

導入されたバージョン:
version 3.1


jp.co.intra_mart.foundation.service.client.batch クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.batch の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.client.NetworkConnector (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.service.client.NetworkAgent (implements jp.co.intra_mart.foundation.service.client.ActionListener)
        • class jp.co.intra_mart.foundation.service.client.batch.Scheduler (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.service.client.batch の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client.batch の使用

jp.co.intra_mart.foundation.service.client.batch はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Scheduler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.batch
クラス Scheduler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
            拡張 jp.co.intra_mart.foundation.service.client.batch.Scheduler
すべての実装インタフェース:
ActionListener, Serializable
public class Scheduler
extends NetworkAgent
implements Serializable

Schedule Service の制御をするオブジェクトです。

このオブジェクトのすべてのメソッドは、Schedule Service に対する オペレーションになります。
このオブジェクトの各メソッド実行時は、Schedule Service と通信を行います。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したフィールド
NULL_DATA
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
Scheduler()
新しいオブジェクトを構築します。
メソッドの概要
Object | action(Object args) 推奨されていません。
protected SocketConnection | connection() サーバに接続するためのコネクションを取得します。
boolean | defineInitializeTime(int hour, int minute, int second) バッチ初期化時間の設定。
void | executeBatchProgram(String loginGroupId, String batchId) バッチプログラムを実行します。
String | initializeTime() バッチ初期化時間の取得。
boolean | isAlive() スケジューラが動作しているかどうかをチェックします。
boolean | restart() スケジューラの再開通知。
boolean | start() スケジューラの開始通知。
boolean | stop() スケジューラの停止通知。
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したメソッド
execute
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Scheduler

public Scheduler()
新しいオブジェクトを構築します。

メソッドの詳細

connection

protected SocketConnection connection()
                               throws IOException
サーバに接続するためのコネクションを取得します。

定義:
クラス NetworkConnector 内の connection
戻り値:
コネクション
例外:
IOException - 入出力エラー

start

public boolean start()
              throws IOException
スケジューラの開始通知。

スケジューラが動作を開始すると、バッチ設定に基づいて、 指定時刻に指定されたバッチプログラムを実行します。
Schedule Service は開始通知を受けると、バッチ初期化時間まで待機状態となり、 バッチプログラムの実行は現在に最も近い未来のバッチ初期化時間以降と なります。

restart() メソッドとの違いは、start() メソッドの場合、 現在から現在に最も近い未来のバッチ初期化時間までのバッチ設定を 無視します。

戻り値:
スケジューラが動作を開始した場合 true、そうでない場合 false。
例外:
IOException - 入出力エラー
関連項目:
restart()

restart

public boolean restart()
                throws IOException
スケジューラの再開通知。

スケジューラが動作を開始すると、バッチ設定に基づいて、 指定時刻に指定されたバッチプログラムを実行します。
Schedule Service は再開通知を受けると、即時に スケジューラとして動作を開始します。

start() メソッドとの違いは、restart() メソッドの場合、 現在から現在に最も近い未来のバッチ初期化時間までのバッチ設定を 読み込んで即時に実行可能状態になる点にあります。

戻り値:
スケジューラが動作を開始した場合 true、そうでない場合 false。
例外:
IOException - 入出力エラー
関連項目:
start()

stop

public boolean stop()
             throws IOException
スケジューラの停止通知。

Schedule Serviceは停止通知を受けると、 スケジューラとして動作を停止します。

通知前に実行状態に入ったバッチプログラムは、そのバッチプログラムが 終了するまで実行を継続します。

戻り値:
スケジューラが動作を停止した場合 true、そうでない場合 false。
例外:
IOException - 入出力エラー
関連項目:
start(), restart()

isAlive

public boolean isAlive()
                throws IOException
スケジューラが動作しているかどうかをチェックします。

戻り値:
スケジューラが動作している場合 true、そうでない場合 false。
例外:
IOException - 入出力エラー
関連項目:
start(),
restart(),
stop()

defineInitializeTime

public boolean defineInitializeTime(int hour,
                                    int minute,
                                    int second)
                             throws IOException
バッチ初期化時間の設定。

パラメータ:
hour - 初期化時間（時間）
minute - 初期化時間（分）
second - 初期化時間（秒）
戻り値:
設定が正しく行われた場合 true、そうでない場合 false。
例外:
IOException - 入出力エラー

initializeTime

public String initializeTime()
                      throws IOException
バッチ初期化時間の取得。

バッチ初期化時間は『00:00:00』というフォーマットされた文字列で 返されます。 初期化時間設定の文字列化に失敗した場合 null が返されます。

戻り値:
バッチ初期化時間
例外:
IOException - 入出力エラー

executeBatchProgram

public void executeBatchProgram(String loginGroupId,
                                String batchId)
                         throws IOException
バッチプログラムを実行します。
ログイングループIDとバッチIDで特定されるバッチプログラムを実行します。

本メソッドを実行すると、Schedule Serviceにバッチプログラムの実行開始要求を送信します。
その要求を受け付けたSchedule Serviceでは、 新しいスレッドを作成してバッチプログラムの実行を開始します。
バッチプログラムの実行結果は、バッチログを参照してください。

なお、本メソッドは、バッチプログラムの実行開始要求を送信するためのものであり、 バッチプログラムのテスト用に用意されたものではありません。
（つまり、本メソッドを利用してバッチプログラムの実行結果を取得することは出来ません）

パラメータ:
loginGroupId - ログイングループID
batchId - バッチID
例外:
IOException - 入出力エラー

action

public final Object action(Object args)
推奨されていません。

処理ロジックの実行。

定義:
インタフェース ActionListener 内の action
定義:
クラス NetworkAgent 内の action
パラメータ:
args - 実行時引数
戻り値:
任意の実行結果
例外:
IllegalArgumentException - 想定外の通信（プロトコル違反）
関連項目:
NetworkAgent.execute(Object)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.service.client.ActionListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.client.ActionListener の使用

ActionListener を使用しているパッケージ
jp.co.intra_mart.foundation.service.client | このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.client.batch | Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file | Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client での ActionListener の使用

ActionListener を実装している jp.co.intra_mart.foundation.service.client のクラス
 class NetworkAgent
このクラスは、他のサーバで実行されるロジックを実装する ためのスケルトンを提供します。

ActionListener 型のパラメータを持つ jp.co.intra_mart.foundation.service.client のメソッド
 Object NetworkConnector.execute(ActionListener target, Object arg)
サーバに対して実行要求をします。

jp.co.intra_mart.foundation.service.client.batch での ActionListener の使用

ActionListener を実装している jp.co.intra_mart.foundation.service.client.batch のクラス
 class Scheduler
Schedule Service の制御をするオブジェクトです。

jp.co.intra_mart.foundation.service.client.file での ActionListener の使用

ActionListener を実装している jp.co.intra_mart.foundation.service.client.file のクラス
class | AbstractComponent このクラスは、Storage Service で実行される ロジックを実装するためのスケルトンを提供します。
class | NetworkFile Storage Service のファイルを扱う事の出来るオブジェクトです。

jp.co.intra_mart.foundation.service.client.information での ActionListener の使用

ActionListener を実装している jp.co.intra_mart.foundation.service.client.information のクラス
class | ExternalDirectory 共有データグループを管理するオブジェクトです。
class | ExternalMemory 共有データを管理するオブジェクトです。
class | Lock アプリケーションロックをするための機能を提供します。
class | PermanentDirectory ファイルベースでデータを保存します。
class | PermanentFile ファイルベースでデータを保存します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.NetworkAgent の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.NetworkAgent の使用

NetworkAgent を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.batch | Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file | Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.batch での NetworkAgent の使用

jp.co.intra_mart.foundation.service.client.batch での NetworkAgent のサブクラス
 class Scheduler
Schedule Service の制御をするオブジェクトです。

jp.co.intra_mart.foundation.service.client.file での NetworkAgent の使用

jp.co.intra_mart.foundation.service.client.file での NetworkAgent のサブクラス
class | AbstractComponent このクラスは、Storage Service で実行される ロジックを実装するためのスケルトンを提供します。
class | NetworkFile Storage Service のファイルを扱う事の出来るオブジェクトです。

jp.co.intra_mart.foundation.service.client.information での NetworkAgent の使用

jp.co.intra_mart.foundation.service.client.information での NetworkAgent のサブクラス
class | ExternalDirectory 共有データグループを管理するオブジェクトです。
class | ExternalMemory 共有データを管理するオブジェクトです。
class | Lock アプリケーションロックをするための機能を提供します。
class | PermanentDirectory ファイルベースでデータを保存します。
class | PermanentFile ファイルベースでデータを保存します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.NetworkConnector の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.NetworkConnector の使用

NetworkConnector を使用しているパッケージ
jp.co.intra_mart.foundation.service.client | このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.client.batch | Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file | Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.manager | このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。

jp.co.intra_mart.foundation.service.client での NetworkConnector の使用

jp.co.intra_mart.foundation.service.client での NetworkConnector のサブクラス
 class NetworkAgent
このクラスは、他のサーバで実行されるロジックを実装する ためのスケルトンを提供します。

jp.co.intra_mart.foundation.service.client.batch での NetworkConnector の使用

jp.co.intra_mart.foundation.service.client.batch での NetworkConnector のサブクラス
 class Scheduler
Schedule Service の制御をするオブジェクトです。

jp.co.intra_mart.foundation.service.client.file での NetworkConnector の使用

jp.co.intra_mart.foundation.service.client.file での NetworkConnector のサブクラス
class | AbstractComponent このクラスは、Storage Service で実行される ロジックを実装するためのスケルトンを提供します。
class | NetworkFile Storage Service のファイルを扱う事の出来るオブジェクトです。

jp.co.intra_mart.foundation.service.client.information での NetworkConnector の使用

jp.co.intra_mart.foundation.service.client.information での NetworkConnector のサブクラス
class | ExternalDirectory 共有データグループを管理するオブジェクトです。
class | ExternalMemory 共有データを管理するオブジェクトです。
class | Lock アプリケーションロックをするための機能を提供します。
class | PermanentDirectory ファイルベースでデータを保存します。
class | PermanentFile ファイルベースでデータを保存します。

jp.co.intra_mart.foundation.service.client.manager での NetworkConnector の使用

jp.co.intra_mart.foundation.service.client.manager での NetworkConnector のサブクラス
 class ServerConnector
このクラスは、Server-Manager にリクエストを送信して 処理を要求するためのオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.file.AbstractComponent の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.file.AbstractComponent の使用

AbstractComponent を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.file Storage Service を利用するためのクラスを提供します。

jp.co.intra_mart.foundation.service.client.file での AbstractComponent の使用

jp.co.intra_mart.foundation.service.client.file での AbstractComponent のサブクラス
 class NetworkFile
Storage Service のファイルを扱う事の出来るオブジェクトです。

AbstractComponent を返す jp.co.intra_mart.foundation.service.client.file のメソッド
static AbstractComponent AbstractComponent.getInstance()
このクラスの新しいインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.file.NetworkFile の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.file.NetworkFile の使用

NetworkFile を使用しているパッケージ
jp.co.intra_mart.foundation.database | データベースへアクセスするためのクラスを提供します。
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.foundation.database での NetworkFile の使用

NetworkFile 型のパラメータを持つ jp.co.intra_mart.foundation.database のメソッド
int | DatabaseExport.exportCSV(PreparedStatement stmt, NetworkFile file, boolean isTitle) 推奨されていません。 CSVファイルをストレージに出力します。
int | DatabaseExport.exportCSV(PreparedStatement stmt, NetworkFile file, int startIndex, int maxRow, boolean isTitle) 推奨されていません。 CSVファイルをストレージに出力します。

jp.co.intra_mart.framework.base.data での NetworkFile の使用

NetworkFile を返す jp.co.intra_mart.framework.base.data のメソッド
protected NetworkFile | IntramartFileServerDAO.getNetworkFile(String path) パスに該当するNetworkFileを取得します。
NetworkFile | IntramartFileServerConnector.getNetworkFile(String path) Storageサービス上の指定されたパスのファイルにアクセスするNetworkFileを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AbstractComponent (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.file
クラス AbstractComponent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
            拡張 jp.co.intra_mart.foundation.service.client.file.AbstractComponent
すべての実装インタフェース:
ActionListener, Serializable
直系の既知のサブクラス:
NetworkFile
public abstract class AbstractComponent
extends NetworkAgent
implements Serializable

このクラスは、Storage Service で実行される ロジックを実装するためのスケルトンを提供します。
このクラスを継承したサブクラスでは、他のサーバでロジックを実行するための メソッドと実際にサーバで実行されるロジックを定義する必要があります。
また、サブクラスは直列化可能なクラスである必要があります。 サブクラスが直列化できない場合、ロジックの呼び出し時に例外がスローされます。

関連項目:
NetworkAgent, 直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したフィールド
NULL_DATA
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
protected AbstractComponent()
唯一のコンストラクタ。
メソッドの概要
protected SocketConnection | connection() サーバに接続するためのコネクションを取得します。
static AbstractComponent | getInstance() このクラスの新しいインスタンスを取得します。
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したメソッド
action, execute
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractComponent

protected AbstractComponent()
唯一のコンストラクタ。

メソッドの詳細

connection

protected SocketConnection connection()
                               throws IOException
サーバに接続するためのコネクションを取得します。

定義:
クラス NetworkConnector 内の connection
戻り値:
コネクション
例外:
IOException - 入出力エラーが発生した場合

getInstance

public static AbstractComponent getInstance()
このクラスの新しいインスタンスを取得します。

戻り値:
このクラスから生成されるインスタンス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


NetworkFile (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.file
クラス NetworkFile

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
            拡張 jp.co.intra_mart.foundation.service.client.file.AbstractComponent
                拡張 jp.co.intra_mart.foundation.service.client.file.NetworkFile
すべての実装インタフェース:
ActionListener, Serializable
public class NetworkFile
extends AbstractComponent
implements Serializable

Storage Service のファイルを扱う事の出来るオブジェクトです。

このオブジェクトのすべてのメソッドは、Storage Service に対する オペレーションになります。
分散サーバ形態で運用している場合、他のコンピュータに 保管されているファイルを扱う事が出来ます。 このオブジェクトの各メソッド実行時は、Storage Service と通信を行います。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したフィールド
NULL_DATA
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
NetworkFile(String path)
新しいオブジェクトを構築します。
メソッドの概要
Object | action(Object args) 推奨されていません。
boolean | append(String src) ファイルにテキストを追記します。
Collection | directories() ディレクトリ中のサブディレクトリの一覧を取得します。
boolean | exists() このパス名が示すファイルが存在するかどうかを判定します。
Collection | files() ディレクトリ中のファイルの一覧を取得します。
String | getPath() このオブジェクトが表すパスを返します。
boolean | isDirectory() このパス名が示すファイルがディレクトリであるかどうかを判定します。
boolean | isFile() このパス名が示すファイルが普通のファイルかどうかを判定します。
long | lastModified() このパス名が示すファイルが最後に変更された時刻を返します。
long | length() このパス名が示すファイルの長さを返します。
Collection | lists() ディレクトリ中のファイルの一覧を取得します。
byte[] | load() ファイルの内容を取得します。
boolean | makeDirectories() このパス名が示すディレクトリを生成します。
boolean | move(String newPath) このパス名が示すファイルの名前を変更します。
String | read() ファイルの内容を取得します。
boolean | remove() このパス名が示すファイルまたはディレクトリを削除します。
boolean | save(byte[] byteStream) ファイルにバイトを出力します。
boolean | write(String src) ファイルにテキストを出力します。
クラス jp.co.intra_mart.foundation.service.client.file.AbstractComponent から継承したメソッド
connection, getInstance
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したメソッド
execute
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NetworkFile

public NetworkFile(String path)
新しいオブジェクトを構築します。

このインスタンスは、Storage Service のファイル管理ディレクトリ(標準では storage/)以下の path で アクセスできるファイルまたはディレクトリを扱う事が出来ます。

パラメータ:
path - パス名
例外:
NullPointerException - 引数が null
メソッドの詳細

getPath

public String getPath()
このオブジェクトが表すパスを返します。 このメソッドは、コンストラクタで指定されたパスをそのまま返します。

戻り値:
パス

files

public Collection files()
                 throws IOException
ディレクトリ中のファイルの一覧を取得します。

コレクションの各要素は String です。

戻り値:
ファイル名一覧
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

directories

public Collection directories()
                       throws IOException
ディレクトリ中のサブディレクトリの一覧を取得します。

コレクションの各要素は String です。

戻り値:
サブディレクトリ名一覧
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

lists

public Collection lists()
                 throws IOException
ディレクトリ中のファイルの一覧を取得します。

ディレクトリに含まれるすべてのファイルを検索します。
ファイル名の取得対象は、サブディレクトリに存在するファイルも含まれます。
ディレクトリは取得対象ではありません。
コレクションの各要素は String です。

戻り値:
ファイル一覧
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

read

public String read()
            throws IOException
ファイルの内容を取得します。

ファイル内のテキストを Unicode に変換して返します。
テキストは、Storage Service の動作している Service Platform のサーバ側文字コードに設定されている文字コードで あるものとして読み込みます。

以下の場合は、空文字列が返却されます。
・対象パスのファイルが存在しない
・対象パスがディレクトリ
・対象パスのファイルの内容が空

戻り値:
ファイルの内容
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

write

public boolean write(String src)
              throws IOException
ファイルにテキストを出力します。

指定の内容のテキストファイルを作成します。 すでにファイルが存在している場合は、上書きされます。
ファイルに書き出されたテキストは、Storage Service の動作している Service Platform のサーバ側文字コードに設定されている文字コードに 変換されています。

このメソッドは、ファイルに出力する文字を文字コード変換する際に、 AdvancedOutputStreamWriter を利用しています。 これにより、Java-VM が持つ文字コード間のマッピングに起因した文字化けに 対して、いくつかの文字の文字化けを回避しています。 文字化けを回避できる文字については、 CharacterEncoder の仕様を参照してください。

パラメータ:
src - ファイルに書き出すテキスト
戻り値:
ファイルへのテキストの書き出しに成功した場合 true
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

append

public boolean append(String src)
               throws IOException
ファイルにテキストを追記します。

指定の内容をテキストファイルに追記します。 すでにファイルが存在している場合は、追記されます。 ファイルが存在していない場合、新しいファイルを作成します。
ファイルに書き出されたテキストは、Storage Service の動作している Service Platform のサーバ側文字コードに設定されている文字コードに 変換されています。

このメソッドは、ファイルに出力する文字を文字コード変換する際に、 AdvancedOutputStreamWriter を利用しています。 これにより、Java-VM が持つ文字コード間のマッピングに起因した文字化けに 対して、いくつかの文字の文字化けを回避しています。 文字化けを回避できる文字については、 CharacterEncoder の仕様を参照してください。

パラメータ:
src - ファイルに書き出すテキスト
戻り値:
ファイルへのテキストの書き出しに成功した場合 true
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

load

public byte[] load()
            throws IOException
ファイルの内容を取得します。

ファイルデータはバイナリ形式で取得されます。

以下の場合は、空の配列が返却されます。
・対象パスのファイルの内容が空

また以下の場合は、nullが返却されます。
・対象パスのファイルが存在しない
・対象パスがディレクトリ

戻り値:
バイト列
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

save

public boolean save(byte[] byteStream)
             throws IOException
ファイルにバイトを出力します。

指定の内容のファイルを作成します。 すでにファイルが存在している場合は、上書きされます。 ファイルが存在していない場合、新しいファイルを作成します。

パラメータ:
byteStream - ファイルに書き出すバイト
戻り値:
ファイルへのバイト列の書き出しに成功した場合 true
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

makeDirectories

public boolean makeDirectories()
                        throws IOException
このパス名が示すディレクトリを生成します。

存在していないが必要な親ディレクトリも一緒に作成されます。 このオペレーションが失敗した場合でも、いくつかの必要な 親ディレクトリの生成には成功した場合があります。

戻り値:
必要なすべての親ディレクトリを含めてディレクトリが作成された場合 は true、そうでない場合は false
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

remove

public boolean remove()
               throws IOException
このパス名が示すファイルまたはディレクトリを削除します。

このパス名がディレクトリを示す場合、 そのディレクトリが削除されるためには空である必要があります。

戻り値:
ファイルまたはディレクトリが正常に削除された場合は true、そうでない場合は false
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

move

public boolean move(String newPath)
             throws IOException
このパス名が示すファイルの名前を変更します。

パラメータ:
newPath - 示されたファイルの新しいパス名
戻り値:
名前の変更が成功した場合は true、そうでない場合は false
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

exists

public boolean exists()
               throws IOException
このパス名が示すファイルが存在するかどうかを判定します。

戻り値:
このパス名が示すファイルが存在する場合は true、 そうでない場合は false
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

isFile

public boolean isFile()
               throws IOException
このパス名が示すファイルが普通のファイルかどうかを判定します。

ファイルは、それがディレクトリではなく、システムに依存するほかの 基準を満たす場合に「普通」のファイルと見なされます。 このオブジェクトにより生成されたディレクトリ以外のファイルは、 必ず普通のファイルです。

戻り値:
このパス名が示すファイルが存在し、 それが普通のファイルである場合は true、 そうでない場合は false
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

isDirectory

public boolean isDirectory()
                    throws IOException
このパス名が示すファイルがディレクトリであるかどうかを判定します。

戻り値:
このパス名が示すファイルが存在し、 それがディレクトリである場合は true、 そうでない場合は false
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

lastModified

public long lastModified()
                  throws IOException
このパス名が示すファイルが最後に変更された時刻を返します。

戻り値:
ファイルが最後に変更された時刻を表す long 値。 エポック (00:00:00 GMT, January 1, 1970) からミリ秒単位で測定。 ファイルが存在しないか、入出力エラーが発生した場合は 0L
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

length

public long length()
            throws IOException
このパス名が示すファイルの長さを返します。

戻り値:
このパス名が示すファイルの長さ (バイト単位)、 ファイルが存在しない場合は 0L
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

action

public Object action(Object args)
推奨されていません。

処理ロジックの実行。

定義:
インタフェース ActionListener 内の action
定義:
クラス NetworkAgent 内の action
パラメータ:
args - 実行時引数
戻り値:
実行結果
関連項目:
NetworkAgent.execute(Object)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.client.file (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.service.client.file
クラス
AbstractComponent
NetworkFile


jp.co.intra_mart.foundation.service.client.file (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.file

Storage Service を利用するためのクラスを提供します。

参照:
説明

クラスの概要
AbstractComponent | このクラスは、Storage Service で実行される ロジックを実装するためのスケルトンを提供します。
NetworkFile | Storage Service のファイルを扱う事の出来るオブジェクトです。

パッケージ jp.co.intra_mart.foundation.service.client.file の説明

Storage Service を利用するためのクラスを提供します。

Storage Service の情報を取得したり、Storage Service でプログラムを実行することの できるクラスが用意されています。
Storage Service が別なプロセスとしてサービスを提供している場合、 このパッケージのクラスは、ネットワークにより Storage Service に対して アクセスを試みます。 これにより、intra-mart サーバの運用形態が変更されても、 プログラマはまったく意識することなく、 Storage Service を利用することができます。


jp.co.intra_mart.foundation.service.client.file クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.file の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.client.NetworkConnector (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.service.client.NetworkAgent (implements jp.co.intra_mart.foundation.service.client.ActionListener)
        • class jp.co.intra_mart.foundation.service.client.file.AbstractComponent (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.service.client.file.NetworkFile (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.service.client.file の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client.file の使用

jp.co.intra_mart.foundation.service.client.file を使用しているパッケージ
jp.co.intra_mart.foundation.database | データベースへアクセスするためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file | Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.foundation.database により使用される jp.co.intra_mart.foundation.service.client.file のクラス
NetworkFile
Storage Service のファイルを扱う事の出来るオブジェクトです。

jp.co.intra_mart.foundation.service.client.file により使用される jp.co.intra_mart.foundation.service.client.file のクラス
AbstractComponent
このクラスは、Storage Service で実行される ロジックを実装するためのスケルトンを提供します。

jp.co.intra_mart.framework.base.data により使用される jp.co.intra_mart.foundation.service.client.file のクラス
NetworkFile
Storage Service のファイルを扱う事の出来るオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.ExternalDirectory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.ExternalDirectory の使用

ExternalDirectory を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.information このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.information での ExternalDirectory の使用

ExternalDirectory を返す jp.co.intra_mart.foundation.service.client.information のメソッド
static ExternalDirectory ExternalDirectory.getInstance(String dir)
共有データを扱うためのオブジェクトを取得します。

ExternalDirectory 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.information のコンストラクタ
ExternalMemory(ExternalDirectory parent, String id)
共有データを扱うための新しいオブジェクトを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.ExternalMemory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.ExternalMemory の使用

jp.co.intra_mart.foundation.service.client.information.ExternalMemory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.Identifier の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.Identifier の使用

jp.co.intra_mart.foundation.service.client.information.Identifier はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.InitialFile の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.InitialFile の使用

jp.co.intra_mart.foundation.service.client.information.InitialFile はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.Lock の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.Lock の使用

jp.co.intra_mart.foundation.service.client.information.Lock はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.PermanentDirectory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.PermanentDirectory の使用

PermanentDirectory を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.information このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.information での PermanentDirectory の使用

PermanentDirectory を返す jp.co.intra_mart.foundation.service.client.information のメソッド
static PermanentDirectory PermanentDirectory.getInstance(String dir)
共有データを扱うためのオブジェクトを取得します。

PermanentDirectory 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.information のコンストラクタ
PermanentFile(PermanentDirectory parent, String id)
共有データを扱うための新しいオブジェクトを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.PermanentFile の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.PermanentFile の使用

jp.co.intra_mart.foundation.service.client.information.PermanentFile はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.SessionFactory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.SessionFactory の使用

jp.co.intra_mart.foundation.service.client.information.SessionFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.SessionMemory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.SessionMemory の使用

SessionMemory を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。

jp.co.intra_mart.foundation.service.client.information での SessionMemory の使用

SessionMemory を返す jp.co.intra_mart.foundation.service.client.information のメソッド
SessionMemory | SessionFactory.getFile() 現在有効なセッションを扱う SessionMemory インスタンスを取得します。
SessionMemory | SessionFactory.entry() 新しい空のセッションを作成します。

jp.co.intra_mart.framework.base.session での SessionMemory の使用

SessionMemory 型のパラメータを持つ jp.co.intra_mart.framework.base.session のコンストラクタ
IntramartSessionObject(SessionMemory session)
推奨されていません。 IntramartSessionObjectを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.client.information.TreasureDirectory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.client.information.TreasureDirectory の使用

TreasureDirectory を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.information このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.information での TreasureDirectory の使用

TreasureDirectory を実装している jp.co.intra_mart.foundation.service.client.information のクラス
class | ExternalDirectory 共有データグループを管理するオブジェクトです。
class | PermanentDirectory ファイルベースでデータを保存します。
class | SessionFactory 共有データグループを管理するオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.client.information.TreasureFile の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.client.information.TreasureFile の使用

TreasureFile を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.information このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.information での TreasureFile の使用

TreasureFile を実装している jp.co.intra_mart.foundation.service.client.information のクラス
class | ExternalMemory 共有データを管理するオブジェクトです。
class | PermanentFile ファイルベースでデータを保存します。
class | SessionMemory 共有データを管理するオブジェクトです。

TreasureFile を返す jp.co.intra_mart.foundation.service.client.information のメソッド
TreasureFile | TreasureDirectory.getFile(String id) このオブジェクトの表すディレクトリにキー id でマップされた TreasureFile インスタンスを取得します。
TreasureFile | TreasureDirectory.entry(String id) 空のグループを作成します。
TreasureFile | SessionFactory.getFile(String id) このオブジェクトの表すディレクトリにキー id でマップされた SessionMemory インスタンスを取得します。
TreasureFile | SessionFactory.entry(String id) 新しい空のセッションを作成します。
TreasureFile | PermanentDirectory.getFile(String id) このオブジェクトの表すディレクトリにキー id でマップされた PermanentFile インスタンスを取得します。
TreasureFile | PermanentDirectory.entry(String id) 空のグループを作成します。
TreasureFile | ExternalDirectory.getFile(String id) このオブジェクトの表すディレクトリにキー id でマップされた ExternalMemory インスタンスを取得します。
TreasureFile | ExternalDirectory.entry(String id) 空のグループを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ExternalDirectory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス ExternalDirectory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
            拡張 jp.co.intra_mart.foundation.service.client.information.ExternalDirectory
すべての実装インタフェース:
ActionListener, Serializable, TreasureDirectory
public class ExternalDirectory
extends NetworkAgent
implements Serializable, TreasureDirectory

共有データグループを管理するオブジェクトです。

グループ化された共有データのグループに関する情報を操作します。 各グループに保存されているデータの取得や各グループへのデータの保存には、 ExternalMemory クラスを利用します。
このオブジェクトにより扱うデータは、Shared Memory Service で一元管理されます。 そのため、intra-mart の各サーバモジュールを分散は位置している場合、 このオブジェクトの各メソッド実行時は、Shared Memory Service と通信を行います。

このオブジェクトで保管されるデータは、Shared Memory Service のメモリ中で 管理され、Shared Memory Service が動作している間、その存在が保証されます。

導入されたバージョン:
version 3.1
関連項目:
ExternalMemory, 直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したフィールド
NULL_DATA
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
protected ExternalDirectory(String dir)
共有データを扱うための新しいオブジェクトを構築します。
メソッドの概要
Object | action(Object argV) 推奨されていません。
protected SocketConnection | connection() サーバに接続するためのコネクションを取得します。
Map | destroy(String id) グループデータを削除します。
List | entries() このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。
TreasureFile | entry(String id) 空のグループを作成します。
TreasureFile | getFile(String id) このオブジェクトの表すディレクトリにキー id でマップされた ExternalMemory インスタンスを取得します。
static ExternalDirectory | getInstance(String dir) 共有データを扱うためのオブジェクトを取得します。
String | getName() このオブジェクトの表すディレクトリ名称を取得します。
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したメソッド
execute
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExternalDirectory

protected ExternalDirectory(String dir)
共有データを扱うための新しいオブジェクトを構築します。

このインスタンスは、dir に保存されている共有データ に関する情報を扱えます。

メソッドの詳細

getInstance

public static ExternalDirectory getInstance(String dir)
共有データを扱うためのオブジェクトを取得します。

このインスタンスは、dir に保存されている共有データ に関する情報を扱えます。

パラメータ:
dir - 保存ディレクトリ
例外:
NullPointerException - 引数が null

connection

protected SocketConnection connection()
                               throws IOException
サーバに接続するためのコネクションを取得します。

定義:
クラス NetworkConnector 内の connection
戻り値:
コネクション
例外:
IOException - 入出力エラーが発生した場合

getName

public String getName()
このオブジェクトの表すディレクトリ名称を取得します。

定義:
インタフェース TreasureDirectory 内の getName
戻り値:
このオブジェクトの表すディレクトリ名称

getFile

public TreasureFile getFile(String id)
このオブジェクトの表すディレクトリにキー id でマップされた ExternalMemory インスタンスを取得します。

定義:
インタフェース TreasureDirectory 内の getFile
戻り値:
ExternalMemory インスタンス

entries

public List entries()
             throws IOException,
                    ClassNotFoundException
このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。

コレクションの各要素は String です。

定義:
インタフェース TreasureDirectory 内の entries
戻り値:
グループＩＤのリスト
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー

entry

public TreasureFile entry(String id)
                   throws IOException
空のグループを作成します。

すでにグループが存在していた場合、このメソッドは何もしません。
このメソッドで作成されたグループにはデータが存在しません。
グループを作成する事により、entries() で取得できるグループリストに このオブジェクトが表すグループが含まれます。
返却値としてグループ id のデータを扱うためのオブジェクトを返します。

定義:
インタフェース TreasureDirectory 内の entry
パラメータ:
id - グループ
戻り値:
TreasureFile インスタンス
例外:
NullPointerException - 引数が null
IOException - 入出力エラー
関連項目:
entries()

destroy

public Map destroy(String id)
            throws IOException,
                   ClassNotFoundException
グループデータを削除します。

id に属する共有データをすべて削除し、 共有データ領域から id に属するデータを保管する領域も削除します。 このメソッドが実行されると entries() で取得できるグループリストに このオブジェクトが示すグループが含まれなくなります。

返却値は、id に属していたデータ一覧になります。返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureDirectory 内の destroy
戻り値:
id に属するデータ一覧
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

action

public Object action(Object argV)
推奨されていません。

処理ロジック。

定義:
インタフェース ActionListener 内の action
定義:
クラス NetworkAgent 内の action
パラメータ:
argV - 引数
戻り値:
実行結果
関連項目:
NetworkAgent.action(Object), NetworkAgent.execute(Object)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExternalMemory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス ExternalMemory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
            拡張 jp.co.intra_mart.foundation.service.client.information.ExternalMemory
すべての実装インタフェース:
ActionListener, Serializable, TreasureFile
public class ExternalMemory
extends NetworkAgent
implements Serializable, TreasureFile

共有データを管理するオブジェクトです。

共有データはグループ化させて保存することができます。 グループ化にはグループＩＤを用い、このグループＩＤがそれぞれの グループ間でユニークである必要があります。 グループ化された共有データのグループ情報に関しては、 ExternalDirectory クラスを利用することによりアクセスすることができます。
このオブジェクトにより扱うデータは、Shared Memory Service で一元管理されます。 そのため、intra-mart の各サーバモジュールを分散配置している場合、 このオブジェクトの各メソッド実行時は、Shared Memory Service と通信を行います。

このオブジェクトで保管されるデータは、Shared Memory Service のメモリ中で 管理され、Shared Memory Service が動作している間、その存在が保証されます。

導入されたバージョン:
version 3.1
関連項目:
ExternalDirectory, 直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したフィールド
NULL_DATA
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
protected | ExternalMemory(ExternalDirectory parent, String id) 共有データを扱うための新しいオブジェクトを構築します。
protected | ExternalMemory(String parent, String id) 共有データを扱うための新しいオブジェクトを構築します。
メソッドの概要
Object | action(Object argV) 推奨されていません。
void | clear() データを削除します。
protected SocketConnection | connection() サーバに接続するためのコネクションを取得します。
Map | entryMap() グループデータを取得します。
Object | get(String key) データを取得します。
String | getName() このインスタンスが表すグループＩＤを取得します。
List | keyList() キー一覧を取得します。
Object | put(String key, Object value) データを保存します。
void | putAll(Map list) データを保存します。
Object | remove(String key) データを削除します。
Map | subMap(String[] keys) データを取得します。
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したメソッド
execute
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExternalMemory

protected ExternalMemory(String parent,
                         String id)
                  throws NullPointerException
共有データを扱うための新しいオブジェクトを構築します。

このインスタンスは、parent に保存されている共有データの中の id に属するデータを扱えます。 domain に保存されているデータや、他の id に属するデータを扱う事は できません。

パラメータ:
parent - 親ディレクトリ名称
id - グループ
例外:
NullPointerException - 引数が null

ExternalMemory

protected ExternalMemory(ExternalDirectory parent,
                         String id)
                  throws NullPointerException
共有データを扱うための新しいオブジェクトを構築します。

このインスタンスは、parent に保存されている共有データの中の id に属するデータを扱えます。 domain に保存されているデータや、他の id に属するデータを扱う事は できません。

パラメータ:
parent - 親ディレクトリ
id - グループ
例外:
NullPointerException - 引数が null
メソッドの詳細

connection

protected SocketConnection connection()
                               throws IOException
サーバに接続するためのコネクションを取得します。

定義:
クラス NetworkConnector 内の connection
戻り値:
コネクション
例外:
IOException - 入出力エラーが発生した場合

getName

public String getName()
このインスタンスが表すグループＩＤを取得します。

定義:
インタフェース TreasureFile 内の getName
戻り値:
グループＩＤ

put

public Object put(String key,
                  Object value)
           throws IOException,
                  ClassNotFoundException,
                  OptionalDataException
データを保存します。

id に属する共有データとして key と value をマップします。 id が存在していない場合、新しいグループが作成されます。
返却値は、key にマップされていたデータになります。返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の put
パラメータ:
key - データを保存するキー
value - 保存するデータ
戻り値:
key にマップされていた値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

putAll

public void putAll(Map list)
            throws IOException
データを保存します。

id に属する共有データとして list をマップに追加します。 id が存在していない場合、新しいグループが作成されます。
list 内のキーがすでにマップに存在している場合、list のマップ情報で 上書きされます。

定義:
インタフェース TreasureFile 内の putAll
パラメータ:
list - データ
例外:
IOException - 入出力エラー

get

public Object get(String key)
           throws IOException,
                  ClassNotFoundException
データを取得します。

id に属する共有データの中から key にマップされているデータを 取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の get
パラメータ:
key - キー
戻り値:
key にマップされている値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

subMap

public Map subMap(String[] keys)
           throws IOException,
                  ClassNotFoundException
データを取得します。

id に属する共有データの中から keys の各要素にマップされているデータ群を取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の subMap
パラメータ:
keys - キーの配列
戻り値:
指定されたキーとそのキーにマップされている値を持つマップ。指定したキーが存在しなかった場合、マップはそのキーを持ちません。
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー
NullPointerException - 引数が null の場合
導入されたバージョン:
version 5.0

entryMap

public Map entryMap()
             throws IOException,
                    ClassNotFoundException
グループデータを取得します。

このマップのデータ一覧を取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の entryMap
戻り値:
このマップの全データ
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

clear

public void clear()
           throws IOException
データを削除します。

id に属する共有データをすべて削除します。

定義:
インタフェース TreasureFile 内の clear
例外:
IOException - 入出力エラー

remove

public Object remove(String key)
              throws IOException,
                     ClassNotFoundException
データを削除します。

id に属するデータの中から key にマップされているデータを 削除します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の remove
パラメータ:
key - キー
戻り値:
key にマップされている値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

keyList

public List keyList()
             throws IOException,
                    ClassNotFoundException
キー一覧を取得します。

id に属するデータとしてマップされている key のリストを 取得します。

実行環境のバージョン等が異なると ClassNotFoundException がスロー される事があります。
コレクションの各要素は String です。

定義:
インタフェース TreasureFile 内の keyList
戻り値:
マップされているキーのリスト
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー

action

public Object action(Object argV)
推奨されていません。

処理ロジック。

定義:
インタフェース ActionListener 内の action
定義:
クラス NetworkAgent 内の action
パラメータ:
argV - 引数
戻り値:
実行結果
関連項目:
NetworkAgent.action(Object), NetworkAgent.execute(Object)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Identifier (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス Identifier

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.information.Identifier
public final class Identifier
extends Object

ユニークなＩＤを生成する機能を提供します。

このオブジェクトは、システム全体で一意性が保証されるＩＤを生成します。 そのため、intra-mart の各サーバモジュールを分散は位置している場合、 このオブジェクトのget() メソッド実行時は、 共通の Server Manager に管理されているすべてのプロセスで一意性を保証 されたＩＤを扱うことができます。

コンストラクタの概要
Identifier()
唯一のコンストラクタ。
メソッドの概要
String | get() 一意性を保証されたＩＤを取得します。
static String | make()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Identifier

public Identifier()
唯一のコンストラクタ。

メソッドの詳細

get

public String get()
           throws IOException
一意性を保証されたＩＤを取得します。 生成される文字列の長さは 15 バイトです。

戻り値:
ＩＤ
例外:
IOException - Server Manager との通信エラー

make

public static String make()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InitialFile (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス InitialFile

java.lang.Object
    拡張 java.util.Dictionary
        拡張 java.util.Hashtable
            拡張 java.util.Properties
                拡張 jp.co.intra_mart.foundation.service.client.information.InitialFile
すべての実装インタフェース:
Cloneable, Map, Serializable
public final class InitialFile
extends Properties

設定ファイル(*.ini)の内容を読み込むためのクラスです。

このクラスは、Resource Service のリソースディレクトリ(標準では pages/)に 保存されている設定ファイル(*.ini)を読み込んで Properties インターフェースで 値へのアクセスを可能にします。
このクラスを利用することにより、スクリプト開発モデルで作成された プログラムと設定ファイルを共有することが可能となり、 異なるモデル間において共通的な設定内容に基づいたアプリケーションを 作成できます。

関連項目:
直列化された形式

フィールドの概要
クラス java.util.Properties から継承したフィールド
defaults
コンストラクタの概要
InitialFile(String path)
リソースサービスが動作しているサーバのリソースディレクトリ内にある 指定の ini ファイルを読み込みます。
クラス java.util.Properties から継承したメソッド
getProperty, getProperty, list, list, load, propertyNames, save, setProperty, store
クラス java.util.Hashtable から継承したメソッド
clear, clone, contains, containsKey, containsValue, elements, entrySet, equals, get, hashCode, isEmpty, keys, keySet, put, putAll, rehash, remove, size, toString, values
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

InitialFile

public InitialFile(String path)
            throws IOException
リソースサービスが動作しているサーバのリソースディレクトリ内にある 指定の ini ファイルを読み込みます。

パラメータ:
path - ini ファイルのパス
例外:
FileNotFoundException - 指定ファイルが存在しないか、指定ファイルの読み込みに失敗した場合
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Lock (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス Lock

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
            拡張 jp.co.intra_mart.foundation.service.client.information.Lock
すべての実装インタフェース:
ActionListener, Serializable
public class Lock
extends NetworkAgent
implements Serializable

アプリケーションロックをするための機能を提供します。

このクラスでは、ロックのフラグ情報を Serialization Servive において 一元的に管理するため、異なる Application Runtime プロセス間における プログラム実行の直列化を実現することができます。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したフィールド
NULL_DATA
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
Lock(String id)
ロックをするためのインスタンスを作ります。
メソッドの概要
Object | action(Object args) 推奨されていません。
void | begin() ロックフラグを立てます。
boolean | begin(long timeout) ロックフラグを立てます。
void | beginRequestScope() ロックフラグを立てます。
boolean | beginRequestScope(long timeout) ロックフラグを立てます。
protected SocketConnection | connection() サーバに接続するためのコネクションを取得します。
boolean | end() ロックを解除します。
String | getName() このインスタンスの表すロックＩＤを返します。
boolean | isLocked() ロックの状態を確認します。
static List | releaseCurrentThread() 現在のスレッドに紐付いたロックを全て解除します。
static List | releaseRequestScope() 推奨されていません。 このメソッドは、RequestScopeLockReleaseFilter 専用です。
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したメソッド
execute
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Lock

public Lock(String id)
     throws NullPointerException
ロックをするためのインスタンスを作ります。 コンストラクタの引数に指定したキーに対するロック機構を提供します。 ロックの機能は Serialization Servive 上に実装されているので このＡＰＩが分散の環境において実行された場合においても同一のキーに マッピングされたロックとして排他制御を行う事が出来ます。

パラメータ:
id - ロックＩＤ
例外:
NullPointerException - 引数が null
メソッドの詳細

connection

protected SocketConnection connection()
                               throws IOException
サーバに接続するためのコネクションを取得します。

定義:
クラス NetworkConnector 内の connection
戻り値:
コネクション
例外:
IOException - 入出力エラーが発生した場合

getName

public String getName()
このインスタンスの表すロックＩＤを返します。

戻り値:
ロックＩＤ

begin

public void begin()
           throws IOException
ロックフラグを立てます。 このオブジェクトが表すキーに対してロックフラグを立てます。 既にロックフラグが設定されている場合には、ロックフラグが解除されるまで 待機します。このＡＰＩによりロックフラグが設定された場合、ロックフラグを 解除するまで他の begin() 要求は待機状態となります。

例外:
IOException - 入出力エラー

begin

public boolean begin(long timeout)
              throws IOException
ロックフラグを立てます。 このオブジェクトが表すキーに対してロックフラグを立てます。 既にロックフラグが設定されている場合には、ロックフラグが解除されるまで 待機します。このＡＰＩによりロックフラグが設定された場合、ロックフラグを 解除するまで他の begin() 要求は待機状態となります。 既にロック状態であり、引数 timeout 秒経過してもロックが解除されなかった 場合、このメソッドは false を返します。

パラメータ:
timeout - ロック開始要求の待ち時間（秒）
戻り値:
ロックの設定に成功した場合 true
例外:
IOException - 入出力エラー

beginRequestScope

public void beginRequestScope()
                       throws IOException
ロックフラグを立てます。

このメソッドは、begin()と同様の機能を提供しますが、 現在のリクエストが終了する際（＝レスポンスを返却する際）に、ロックの解除が自動的に行われる点が異なります。
自動的なロックの解除は、RequestScopeLockReleaseFilter にて行われます。

例外:
IOException - 入出力エラー
導入されたバージョン:
6.1.7

beginRequestScope

public boolean beginRequestScope(long timeout)
                          throws IOException
ロックフラグを立てます。 このメソッドは、begin(long)と同様の機能を提供しますが、 現在のリクエストが終了する際（＝レスポンスを返却する際）に、ロックの解除が自動的に行われる点が異なります。
自動的なロックの解除は、RequestScopeLockReleaseFilter にて行われます。

パラメータ:
timeout - ロック開始要求の待ち時間（秒）
戻り値:
ロックの設定に成功した場合 true
例外:
IOException - 入出力エラー
導入されたバージョン:
6.1.7

end

public boolean end()
            throws IOException
ロックを解除します。 このオブジェクトが表すキーに対してロックを解除します。

戻り値:
ロック解除に成功した場合 true
例外:
IOException - 入出力エラー

isLocked

public boolean isLocked()
                 throws IOException
ロックの状態を確認します。 このオブジェクトが表すキーに対するロックの状態を確認します。 このオブジェクトが表すキーに対して begin() メソッドが実行されていて また、ロックセッション時間内であって end() メソッドが実行されていない場合、このメソッドは true を 返します。

戻り値:
すでにロック状態である場合 true
例外:
IOException - 入出力エラー

action

public Object action(Object args)
推奨されていません。

処理ロジックの実行。

定義:
インタフェース ActionListener 内の action
定義:
クラス NetworkAgent 内の action
パラメータ:
args - 実行時引数
戻り値:
処理結果
関連項目:
NetworkAgent.execute(Object)

releaseCurrentThread

public static List releaseCurrentThread()
現在のスレッドに紐付いたロックを全て解除します。

戻り値:
現在のスレッドに紐づいたロックが存在しない場合は null を返却します。
上記以外の場合、ロックの解除に失敗したロックID(String)を格納したListを返却します。
（ロック解除に全て成功した際には、要素が空のListが返却されます）

releaseRequestScope

public static List releaseRequestScope()
推奨されていません。 このメソッドは、RequestScopeLockReleaseFilter 専用です。

現在のリクエストに紐付いたロックを全て解除します。
具体的には、beginRequestScope()で行ったロックを全て解除します。

戻り値:
現在のリクエストに紐づいたロックが存在しない場合は null を返却します。
上記以外の場合、ロックの解除に失敗したロックID(String)を格納したListを返却します。
（ロック解除に全て成功した際には、要素が空のListが返却されます）
導入されたバージョン:
6.1.7
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.client.information (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.service.client.information
インタフェース
TreasureDirectory
TreasureFile
クラス
ExternalDirectory
ExternalMemory
Identifier
InitialFile
Lock
PermanentDirectory
PermanentFile
SessionFactory
SessionMemory


jp.co.intra_mart.foundation.service.client.information (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.information

このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

参照:
説明

インタフェースの概要
TreasureDirectory | 情報データベースのディレクトリを操作するためのインターフェースを定義します。
TreasureFile | 情報データベースのファイルを操作するためのインターフェースを定義します。

クラスの概要
ExternalDirectory | 共有データグループを管理するオブジェクトです。
ExternalMemory | 共有データを管理するオブジェクトです。
Identifier | ユニークなＩＤを生成する機能を提供します。
InitialFile | 設定ファイル(*.ini)の内容を読み込むためのクラスです。
Lock | アプリケーションロックをするための機能を提供します。
PermanentDirectory | ファイルベースでデータを保存します。
PermanentFile | ファイルベースでデータを保存します。
SessionFactory | 共有データグループを管理するオブジェクトです。
SessionMemory | 共有データを管理するオブジェクトです。

パッケージ jp.co.intra_mart.foundation.service.client.information の説明

このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

このパッケージに含まれるクラスにより利用可能なサービスは、以下のとおりです。

  • Permanent Data Service
  • Resource Service
  • Serialization Service
  • Sharead Memory Service


jp.co.intra_mart.foundation.service.client.information クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.information の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.util.Dictionary
      • class java.util.Hashtable (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class java.util.Properties
          • class jp.co.intra_mart.foundation.service.client.information.InitialFile
    • class jp.co.intra_mart.foundation.service.client.information.Identifier
    • class jp.co.intra_mart.foundation.service.client.NetworkConnector (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.service.client.NetworkAgent (implements jp.co.intra_mart.foundation.service.client.ActionListener)
        • class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureDirectory)
        • class jp.co.intra_mart.foundation.service.client.information.ExternalMemory (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureFile)
        • class jp.co.intra_mart.foundation.service.client.information.Lock (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureDirectory)
        • class jp.co.intra_mart.foundation.service.client.information.PermanentFile (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureFile)
    • class jp.co.intra_mart.foundation.service.client.information.SessionFactory (implements jp.co.intra_mart.foundation.service.client.information.TreasureDirectory)
    • class jp.co.intra_mart.foundation.service.client.information.SessionMemory (implements jp.co.intra_mart.foundation.service.client.information.TreasureFile)

インタフェース階層

  • interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory
  • interface jp.co.intra_mart.foundation.service.client.information.TreasureFile


パッケージ jp.co.intra_mart.foundation.service.client.information の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client.information の使用

jp.co.intra_mart.foundation.service.client.information を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。

jp.co.intra_mart.foundation.service.client.information により使用される jp.co.intra_mart.foundation.service.client.information のクラス
ExternalDirectory
共有データグループを管理するオブジェクトです。
PermanentDirectory
ファイルベースでデータを保存します。
SessionMemory
共有データを管理するオブジェクトです。
TreasureDirectory
情報データベースのディレクトリを操作するためのインターフェースを定義します。
TreasureFile
情報データベースのファイルを操作するためのインターフェースを定義します。

jp.co.intra_mart.framework.base.session により使用される jp.co.intra_mart.foundation.service.client.information のクラス
SessionMemory
共有データを管理するオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PermanentDirectory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス PermanentDirectory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
            拡張 jp.co.intra_mart.foundation.service.client.information.PermanentDirectory
すべての実装インタフェース:
ActionListener, Serializable, TreasureDirectory
public class PermanentDirectory
extends NetworkAgent
implements Serializable, TreasureDirectory

ファイルベースでデータを保存します。

データをそのままファイルに保存して、サーバの再起動後も保存したデータを 扱うためのＡＰＩを提供します。
保存するデータは、直列化可能なオブジェクトに限ります。 また、保存した時の環境と取り出した時の環境において、そのデータに関連する クラスの構造が異なっている場合、正常に値をやりとりできません。

このオブジェクトにより扱うデータは、Permanent Data Service で一元管理されます。 そのため、intra-mart の各サーバモジュールを分散配置している場合、 このオブジェクトの各メソッド実行時は、Permanent Data Service と通信を行います。 また、データファイルが保存されるディレクトリは、 treasure/ 以下の getDomain() メソッドで示されるディレクトリになります。
サブディレクトリを任意に指定する事が可能で、そのサブディレクトリ内に グループが存在し、そのグループ内にデータがキーにマップされる形で 保存されます。

getDomain() メソッドで表される情報保存ディレクトリには、 すでに用法が定められているものがあります。
ベースモジュールの各機能が利用する情報は vault/ ディレクトリに保存され、またスクリプト開発モデルからの情報は、 articles/ ディレクトリ内に保存されます。 これらのディレクトリに情報を保存(また更新や削除)した場合、関係機能への 情報の干渉を引き起こしシステムを不安定にしてしまう危険性があります。

このオブジェクトで保管されるデータは、Permanent Data Service のファイルで 管理され、Permanent Data Service の再起動後も、その存在が保証されます。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したフィールド
NULL_DATA
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
protected PermanentDirectory(String dir)
共有データを扱うための新しいオブジェクトを構築します。
メソッドの概要
Object | action(Object argV) 推奨されていません。
protected SocketConnection | connection() サーバに接続するためのコネクションを取得します。
Map | destroy(String id) グループデータを削除します。
List | entries() このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。
TreasureFile | entry(String id) 空のグループを作成します。
TreasureFile | getFile(String id) このオブジェクトの表すディレクトリにキー id でマップされた PermanentFile インスタンスを取得します。
static PermanentDirectory | getInstance(String dir) 共有データを扱うためのオブジェクトを取得します。
String | getName() このオブジェクトの表すディレクトリ名称を取得します。
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したメソッド
execute
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PermanentDirectory

protected PermanentDirectory(String dir)
                      throws NullPointerException
共有データを扱うための新しいオブジェクトを構築します。

このインスタンスは、dir に保存されている共有データ に関する情報を扱えます。

パラメータ:
dir - 保存ディレクトリ
例外:
NullPointerException - 引数が null
メソッドの詳細

getInstance

public static PermanentDirectory getInstance(String dir)
共有データを扱うためのオブジェクトを取得します。

このインスタンスは、dir に保存されている共有データ に関する情報を扱えます。

パラメータ:
dir - 保存ディレクトリ
例外:
NullPointerException - 引数が null

connection

protected SocketConnection connection()
                               throws IOException
サーバに接続するためのコネクションを取得します。

定義:
クラス NetworkConnector 内の connection
戻り値:
コネクション
例外:
IOException - 入出力エラーが発生した場合

getName

public String getName()
このオブジェクトの表すディレクトリ名称を取得します。

定義:
インタフェース TreasureDirectory 内の getName
戻り値:
このオブジェクトの表すディレクトリ名称

getFile

public TreasureFile getFile(String id)
このオブジェクトの表すディレクトリにキー id でマップされた PermanentFile インスタンスを取得します。

定義:
インタフェース TreasureDirectory 内の getFile
戻り値:
PermanentFile インスタンス

entries

public List entries()
             throws IOException,
                    ClassNotFoundException
このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。

コレクションの各要素は String です。

定義:
インタフェース TreasureDirectory 内の entries
戻り値:
グループＩＤのリスト
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー

entry

public TreasureFile entry(String id)
                   throws IOException
空のグループを作成します。

すでにグループが存在していた場合、このメソッドは何もしません。
このメソッドで作成されたグループにはデータが存在しません。
グループを作成する事により、entries() で取得できるグループリストに このオブジェクトが表すグループが含まれます。
返却値としてグループ id のデータを扱うためのオブジェクトを返します。

定義:
インタフェース TreasureDirectory 内の entry
パラメータ:
id - グループ
戻り値:
TreasureFile インスタンス
例外:
NullPointerException - 引数が null
IOException - 入出力エラー
関連項目:
entries()

destroy

public Map destroy(String id)
            throws IOException,
                   ClassNotFoundException
グループデータを削除します。

id に属する共有データをすべて削除し、 共有データ領域から id に属するデータを保管する領域も削除します。 このメソッドが実行されると entries() で取得できるグループリストに このオブジェクトが示すグループが含まれなくなります。

返却値は、id に属していたデータ一覧になります。返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureDirectory 内の destroy
戻り値:
id に属するデータ一覧
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

action

public Object action(Object argV)
推奨されていません。

処理ロジック。

定義:
インタフェース ActionListener 内の action
定義:
クラス NetworkAgent 内の action
パラメータ:
argV - 引数
戻り値:
実行結果
関連項目:
NetworkAgent.action(Object), NetworkAgent.execute(Object)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PermanentFile (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス PermanentFile

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
            拡張 jp.co.intra_mart.foundation.service.client.information.PermanentFile
すべての実装インタフェース:
ActionListener, Serializable, TreasureFile
public class PermanentFile
extends NetworkAgent
implements Serializable, TreasureFile

ファイルベースでデータを保存します。

データをそのままファイルに保存して、サーバの再起動後も保存したデータを 扱うためのＡＰＩを提供します。
保存するデータは、直列化可能なオブジェクトに限ります。 また、保存した時の環境と取り出した時の環境において、そのデータに関連する クラスの構造が異なっている場合、正常に値をやりとりできません。

このオブジェクトにより扱うデータは、Permanent Data Service で一元管理されます。 そのため、intra-mart の各サーバモジュールを分散配置している場合、 このオブジェクトの各メソッド実行時は、Permanent Data Service と通信を行います。 また、データファイルが保存されるディレクトリは、 treasure/ 以下の getParentName() メソッドで示されるディレクトリになります。 サブディレクトリを任意に指定する事が可能で、そのサブディレクトリ内に グループが存在し、そのグループ内にデータがキーにマップされる形で 保存されます。

このオブジェクトで保管されるデータは、Permanent Data Service のファイルで 管理され、Permanent Data Service の再起動後も、その存在が保証されます。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したフィールド
NULL_DATA
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
protected | PermanentFile(PermanentDirectory parent, String id) 共有データを扱うための新しいオブジェクトを構築します。
protected | PermanentFile(String parent, String id) 共有データを扱うための新しいオブジェクトを構築します。
メソッドの概要
Object | action(Object argV) 推奨されていません。
void | clear() データを削除します。
protected SocketConnection | connection() サーバに接続するためのコネクションを取得します。
Map | entryMap() グループデータを取得します。
Object | get(String key) データを取得します。
String | getName() このインスタンスが表すグループＩＤを取得します。
String | getParentName() 保存ディレクトリを取得します。
List | keyList() キー一覧を取得します。
boolean | move(String new_id) グループキーを変更します。
Object | put(String key, Object value) データを保存します。
void | putAll(Map list) データを保存します。
Object | remove(String key) データを削除します。
Map | subMap(String[] keys) データを取得します。
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したメソッド
execute
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PermanentFile

protected PermanentFile(String parent,
                        String id)
                 throws NullPointerException
共有データを扱うための新しいオブジェクトを構築します。

このインスタンスは、parent に保存されている共有データの中の id に属するデータを扱えます。 domain に保存されているデータや、他の id に属するデータを扱う事は できません。

パラメータ:
parent - 親ディレクトリ名称
id - グループ
例外:
NullPointerException - 引数が null

PermanentFile

protected PermanentFile(PermanentDirectory parent,
                        String id)
                 throws NullPointerException
共有データを扱うための新しいオブジェクトを構築します。

このインスタンスは、parent に保存されている共有データの中の id に属するデータを扱えます。 domain に保存されているデータや、他の id に属するデータを扱う事は できません。

パラメータ:
parent - 親ディレクトリ
id - グループ
例外:
NullPointerException - 引数が null
メソッドの詳細

connection

protected SocketConnection connection()
                               throws IOException
サーバに接続するためのコネクションを取得します。

定義:
クラス NetworkConnector 内の connection
戻り値:
コネクション
例外:
IOException - 入出力エラーが発生した場合

getParentName

public String getParentName()
保存ディレクトリを取得します。

実際には、Permanent Data Service のルート直下 tresure/ ディレクトリに サブディレクトリとして、このメソッドが表すディレクトリを作成して データを保存します。

戻り値:
保存ディレクトリ名称

getName

public String getName()
このインスタンスが表すグループＩＤを取得します。

定義:
インタフェース TreasureFile 内の getName
戻り値:
グループＩＤ

put

public Object put(String key,
                  Object value)
           throws IOException,
                  ClassNotFoundException,
                  OptionalDataException
データを保存します。

id に属する共有データとして key と value をマップします。 id が存在していない場合、新しいグループが作成されます。
返却値は、key にマップされていたデータになります。返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の put
パラメータ:
key - データを保存するキー
value - 保存するデータ
戻り値:
key にマップされていた値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

putAll

public void putAll(Map list)
            throws IOException
データを保存します。

id に属する共有データとして list をマップに追加します。 id が存在していない場合、新しいグループが作成されます。
list 内のキーがすでにマップに存在している場合、list のマップ情報で 上書きされます。

定義:
インタフェース TreasureFile 内の putAll
パラメータ:
list - データ
例外:
IOException - 入出力エラー

get

public Object get(String key)
           throws IOException,
                  ClassNotFoundException
データを取得します。

id に属する共有データの中から key にマップされているデータを 取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の get
パラメータ:
key - キー
戻り値:
key にマップされている値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

subMap

public Map subMap(String[] keys)
           throws IOException,
                  ClassNotFoundException
データを取得します。

id に属する共有データの中から keys の各要素にマップされているデータ群を取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の subMap
パラメータ:
keys - キーの配列
戻り値:
指定されたキーとそのキーにマップされている値を持つマップ。指定したキーが存在しなかった場合、マップはそのキーを持ちません。
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー
NullPointerException - 引数が null の場合
導入されたバージョン:
version 5.0

entryMap

public Map entryMap()
             throws IOException,
                    ClassNotFoundException
グループデータを取得します。

このマップのデータ一覧を取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の entryMap
戻り値:
このマップの全データ
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

clear

public void clear()
           throws IOException
データを削除します。

id に属する共有データをすべて削除します。

定義:
インタフェース TreasureFile 内の clear
例外:
IOException - 入出力エラー

remove

public Object remove(String key)
              throws IOException,
                     ClassNotFoundException
データを削除します。

id に属するデータの中から key にマップされているデータを 削除します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の remove
パラメータ:
key - キー
戻り値:
key にマップされている値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

move

public boolean move(String new_id)
             throws IOException
グループキーを変更します。

現在のグループのキー(id)を新しいキー(new_id)に変更します。
new_id が、domain 内にすでに存在する場合は、変更に失敗します。

パラメータ:
new_id - 新しいグループ名
戻り値:
グループの変更ができた場合 true、失敗した場合 false
例外:
IOException - 入出力エラー

keyList

public List keyList()
             throws IOException,
                    ClassNotFoundException
キー一覧を取得します。

id に属するデータとしてマップされている key のリストを 取得します。

実行環境のバージョン等が異なると ClassNotFoundException がスロー される事があります。
コレクションの各要素は String です。

定義:
インタフェース TreasureFile 内の keyList
戻り値:
マップされているキーのリスト
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー

action

public Object action(Object argV)
推奨されていません。

処理ロジック。

定義:
インタフェース ActionListener 内の action
定義:
クラス NetworkAgent 内の action
パラメータ:
argV - 引数
戻り値:
実行結果
関連項目:
NetworkAgent.action(Object), NetworkAgent.execute(Object)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionFactory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス SessionFactory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.information.SessionFactory
すべての実装インタフェース:
TreasureDirectory
public class SessionFactory
extends Object
implements TreasureDirectory

共有データグループを管理するオブジェクトです。

グループ化された共有データのグループに関する情報を操作します。 各グループに保存されているデータの取得や各グループへのデータの保存には、 SessionMemory クラスを利用します。
このオブジェクトにより扱うデータは、HTTP セッションにて管理されます。 情報の入出力に関する仕様は、実行環境における HTTP セッションの仕様に 準拠します。

導入されたバージョン:
version 3.1
関連項目:
SessionMemory

コンストラクタの概要
SessionFactory(HttpServletRequest request, HttpServletResponse response)
共有データを扱うための新しいオブジェクトを構築します。
メソッドの概要
void | destroy() このメソッドは、現在のセッションを破棄してしまいます。
Map | destroy(String id) id によりアクセスできるセッションデータを破棄します。
List | entries() セッションＩＤ一覧を取得します。
SessionMemory | entry() 新しい空のセッションを作成します。
TreasureFile | entry(String id) 新しい空のセッションを作成します。
Number | expiration() セッションの維持時間を取得します。
SessionMemory | getFile() 現在有効なセッションを扱う SessionMemory インスタンスを取得します。
TreasureFile | getFile(String id) このオブジェクトの表すディレクトリにキー id でマップされた SessionMemory インスタンスを取得します。
String | getName() このオブジェクトの表すディレクトリ名称を取得します。
String | newIdentifier() 新しいセッションＩＤを生成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SessionFactory

public SessionFactory(HttpServletRequest request,
                      HttpServletResponse response)
共有データを扱うための新しいオブジェクトを構築します。

このインスタンスは、dir に保存されている共有データ に関する情報を扱えます。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
メソッドの詳細

getName

public String getName()
このオブジェクトの表すディレクトリ名称を取得します。

このメソッドは常に null を返します。

定義:
インタフェース TreasureDirectory 内の getName
戻り値:
このオブジェクトの表すディレクトリ名称

getFile

public TreasureFile getFile(String id)
このオブジェクトの表すディレクトリにキー id でマップされた SessionMemory インスタンスを取得します。

ただし、id は現在有効なセッションＩＤを渡さなければなりません。 指定された id が、現在のセッションを表すものとして不適切と判断した場合、 このメソッドは null を返します。

定義:
インタフェース TreasureDirectory 内の getFile
戻り値:
SessionMemory インスタンス

getFile

public SessionMemory getFile()
現在有効なセッションを扱う SessionMemory インスタンスを取得します。

戻り値:
SessionMemory インスタンス

entries

public List entries()
セッションＩＤ一覧を取得します。

コレクションに含まれるセッションＩＤは、現在のセッションに関わるもの のみです。 したがって、コレクションに含まれる要素は常に１つだけです。 ただし、セッションを作成していない状態では、 要素を一つも持たないコレクションを返します。

コレクションの各要素は String です。

定義:
インタフェース TreasureDirectory 内の entries
戻り値:
セッションＩＤのリスト

entry

public TreasureFile entry(String id)
新しい空のセッションを作成します。

このメソッドで作成されたセッションにはデータが存在しません。 ただし、すでにセッションが作成済みの場合には、 現在のセッションが返されます。
返却値として新しいセッションのデータを扱うためのオブジェクトを 返します。

定義:
インタフェース TreasureDirectory 内の entry
パラメータ:
id - グループ
戻り値:
SessionMemory インスタンス
例外:
IllegalArgumentException - id が現在のセッションのIDとして有効ではない場合
関連項目:
TreasureDirectory.entries()

entry

public SessionMemory entry()
新しい空のセッションを作成します。

このメソッドで作成されたセッションにはデータが存在しません。 ただし、すでにセッションが作成済みの場合には、 現在のセッションが返されます。
返却値として新しいセッションのデータを扱うためのオブジェクトを 返します。

戻り値:
SessionMemory インスタンス

destroy

public Map destroy(String id)
id によりアクセスできるセッションデータを破棄します。

定義:
インタフェース TreasureDirectory 内の destroy
戻り値:
セッションの破棄に成功した場合は空の Map が返され、セッションの破棄が出来なかった場合は null が返されます。

destroy

public void destroy()
このメソッドは、現在のセッションを破棄してしまいます。 したがって、メソッド実行後はセッションが無効となり、 セッション維持が出来なくなってしまいます。

expiration

public Number expiration()
セッションの維持時間を取得します。

戻り値:
セッション時間

newIdentifier

public String newIdentifier()
新しいセッションＩＤを生成します。

このメソッドは、単純に現在の環境のセッションＩＤを返します。 HTTP セッションが未作成の場合は、新しく作成してＩＤを返します。

戻り値:
新しく作成されたセッションＩＤ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionMemory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス SessionMemory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.information.SessionMemory
すべての実装インタフェース:
TreasureFile
public class SessionMemory
extends Object
implements TreasureFile

共有データを管理するオブジェクトです。

このオブジェクトにより扱うデータは、HTTPセッションにより管理されます。

導入されたバージョン:
version 3.1
関連項目:
SessionFactory

コンストラクタの概要
protected SessionMemory(HttpSession session)
共有データを扱うための新しいオブジェクトを構築します。
メソッドの概要
void | clear() すべてのデータを削除します。
Map | entryMap() グループデータを取得します。
Object | get(String key) データを取得します。
String | getName() このインスタンスが表すセッションＩＤを取得します。
List | keyList() キー一覧を取得します。
Object | put(String key, Object value) データを保存します。
void | putAll(Map list) データを保存します。
Object | remove(String key) データを削除します。
Map | subMap(String[] keys) データを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SessionMemory

protected SessionMemory(HttpSession session)
                 throws NullPointerException
共有データを扱うための新しいオブジェクトを構築します。

パラメータ:
session - ＨＴＴＰセッションオブジェクト
例外:
NullPointerException - 引数が null
メソッドの詳細

getName

public String getName()
このインスタンスが表すセッションＩＤを取得します。

定義:
インタフェース TreasureFile 内の getName
戻り値:
グループＩＤ
関連項目:
SessionFactory.entry(),
SessionFactory.entry(String),
SessionFactory.getFile(String)

put

public Object put(String key,
                  Object value)
データを保存します。

共有データとして key と value をマップします。 返却値は、key にマップされていたデータになります。返却データに関して、

定義:
インタフェース TreasureFile 内の put
パラメータ:
key - データを保存するキー
value - 保存するデータ
戻り値:
key にマップされていた値

putAll

public void putAll(Map list)
データを保存します。

共有データとして list をマップに追加します。 list 内のキーがすでにマップに存在している場合、list のマップ情報で 上書きされます。

定義:
インタフェース TreasureFile 内の putAll
パラメータ:
list - データ

get

public Object get(String key)
データを取得します。

共有データの中から key にマップされているデータを 取得します。

定義:
インタフェース TreasureFile 内の get
パラメータ:
key - キー
戻り値:
key にマップされている値

subMap

public Map subMap(String[] keys)
データを取得します。

セッションの中から keys の各要素にマップされているデータ群を取得します。
返却データに関して、

定義:
インタフェース TreasureFile 内の subMap
パラメータ:
keys - キーの配列
戻り値:
指定されたキーとそのキーにマップされている値を持つマップ。指定したキーが存在しなかった場合、マップはそのキーを持ちません。
例外:
NullPointerException - 引数が null の場合
導入されたバージョン:
version 5.0

entryMap

public Map entryMap()
グループデータを取得します。

このマップのデータ一覧を取得します。
返却データに関して、

定義:
インタフェース TreasureFile 内の entryMap
戻り値:
このマップの全データ

clear

public void clear()
すべてのデータを削除します。

定義:
インタフェース TreasureFile 内の clear

remove

public Object remove(String key)
データを削除します。

共有データの中から key にマップされているデータを 削除します。

定義:
インタフェース TreasureFile 内の remove
パラメータ:
key - キー
戻り値:
key にマップされている値

keyList

public List keyList()
キー一覧を取得します。

コレクションの各要素は String です。

定義:
インタフェース TreasureFile 内の keyList
戻り値:
マップされているキーのリスト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


TreasureDirectory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
インタフェース TreasureDirectory

既知の実装クラスの一覧:
ExternalDirectory, PermanentDirectory, SessionFactory
public interface TreasureDirectory

情報データベースのディレクトリを操作するためのインターフェースを定義します。

このインターフェースを継承するクラスでは、情報データベースの ディレクトリ情報へのアクセスを実装して下さい。

メソッドの概要
Map | destroy(String id) グループデータを削除します。
List | entries() このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。
TreasureFile | entry(String id) 空のグループを作成します。
TreasureFile | getFile(String id) このオブジェクトの表すディレクトリにキー id でマップされた TreasureFile インスタンスを取得します。
String | getName() このオブジェクトの表す名称を取得します。

メソッドの詳細

getFile

public TreasureFile getFile(String id)
このオブジェクトの表すディレクトリにキー id でマップされた TreasureFile インスタンスを取得します。

戻り値:
TreasureFile インスタンス

getName

public String getName()
このオブジェクトの表す名称を取得します。

戻り値:
このオブジェクトの名称

entries

public List entries()
             throws IOException,
                    ClassNotFoundException
このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。

コレクションの各要素は String です。

戻り値:
グループＩＤのリスト
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー

entry

public TreasureFile entry(String id)
                   throws IOException
空のグループを作成します。

すでにグループが存在していた場合、このメソッドは何もしません。
このメソッドで作成されたグループにはデータが存在しません。
グループを作成する事により、entries() で取得できるグループリストに このオブジェクトが表すグループが含まれます。
返却値としてグループ id のデータを扱うためのオブジェクトを返します。

パラメータ:
id - グループ
戻り値:
TreasureFile インスタンス
例外:
NullPointerException - 引数が null
IOException - 入出力エラー
関連項目:
entries()

destroy

public Map destroy(String id)
            throws IOException,
                   ClassNotFoundException
グループデータを削除します。

id に属する共有データをすべて削除し、 共有データ領域から id に属するデータを保管する領域も削除します。 このメソッドが実行されると entries() で取得できるグループリストに このオブジェクトが示すグループが含まれなくなります。

返却値は、id に属していたデータ一覧になります。返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

戻り値:
id に属するデータ一覧
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


TreasureFile (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
インタフェース TreasureFile

既知の実装クラスの一覧:
ExternalMemory, PermanentFile, SessionMemory
public interface TreasureFile

情報データベースのファイルを操作するためのインターフェースを定義します。

このインターフェースを継承するクラスでは、情報データベースの ファイル情報へのアクセスを実装して下さい。

メソッドの概要
void | clear() このオブジェクトのマップからマッピングをすべて削除します。
Map | entryMap() グループデータを取得します。
Object | get(String key) データを取得します。
String | getName() このオブジェクトの表す名称を取得します。
List | keyList() キー一覧を取得します。
Object | put(String key, Object value) データを保存します。
void | putAll(Map list) データを保存します。
Object | remove(String key) データを削除します。
Map | subMap(String[] keys) データを取得します。

メソッドの詳細

getName

public String getName()
このオブジェクトの表す名称を取得します。

戻り値:
このオブジェクトの名称

clear

public void clear()
           throws IOException
このオブジェクトのマップからマッピングをすべて削除します。

例外:
IOException

put

public Object put(String key,
                  Object value)
           throws IOException,
                  ClassNotFoundException,
                  OptionalDataException
データを保存します。

このオブジェクトに key と value をマップします。 返却値は、key にマップされていたデータになります。返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

パラメータ:
key - データを保存するキー
value - 保存するデータ
戻り値:
key にマップされていた値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

putAll

public void putAll(Map list)
            throws IOException
データを保存します。

このオブジェクトに list をマップに追加します。 list 内のキーがすでにマップに存在している場合、list のマップ情報で 上書きされます。

パラメータ:
list - データ
例外:
IOException - 入出力エラー

get

public Object get(String key)
           throws IOException,
                  ClassNotFoundException
データを取得します。

このマップの中から key にマップされているデータを取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

パラメータ:
key - キー
戻り値:
key にマップされている値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

subMap

public Map subMap(String[] keys)
           throws IOException,
                  ClassNotFoundException
データを取得します。

このマップの中から keys の各要素にマップされているデータ群を取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

パラメータ:
keys - キーの配列
戻り値:
指定されたキーとそのキーにマップされている値を持つマップ。指定したキーが存在しなかった場合、マップはそのキーを持ちません。
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー
導入されたバージョン:
version 5.0

entryMap

public Map entryMap()
             throws IOException,
                    ClassNotFoundException
グループデータを取得します。

このマップのデータ一覧を取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

戻り値:
このマップの全データ
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

remove

public Object remove(String key)
              throws IOException,
                     ClassNotFoundException
データを削除します。

マップの中から key にマップされているデータを削除します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

パラメータ:
key - キー
戻り値:
key にマップされている値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

keyList

public List keyList()
             throws IOException,
                    ClassNotFoundException
キー一覧を取得します。

マップされている key のリストを取得します。

実行環境のバージョン等が異なると ClassNotFoundException がスロー される事があります。
コレクションの各要素は String です。

戻り値:
マップされているキーのリスト
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException の使用

IllegalPasswordException を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.manager このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。

jp.co.intra_mart.foundation.service.client.manager での IllegalPasswordException の使用

IllegalPasswordException をスローする jp.co.intra_mart.foundation.service.client.manager のメソッド
 SocketConnectionDistributor SocketConnectionDistributorFactory.createSocketConnectionDistributor(String passwd)
Server-Manager に接続するためのネットワークコネクション管理 オブジェクトを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.manager.ServerConnector の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.manager.ServerConnector の使用

jp.co.intra_mart.foundation.service.client.manager.ServerConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory の使用

jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


IllegalPasswordException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.manager
クラス IllegalPasswordException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException
すべての実装インタフェース:
Serializable
public class IllegalPasswordException
extends Exception

パスワードが認証されなかったことを通知するための例外です。

パスワードが間違っている場合にスローされます。

導入されたバージョン:
intra-mart Version 4.1
関連項目:
直列化された形式

コンストラクタの概要
IllegalPasswordException(String message)
指定のメッセージで例外を作成します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalPasswordException

public IllegalPasswordException(String message)
指定のメッセージで例外を作成します。

メッセージは、java.lang.Throwable クラスの getMessage メソッドから取得することができます。

パラメータ:
message - メッセージ
関連項目:
Throwable.getMessage()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.client.manager (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.service.client.manager
クラス
ServerConnector
SocketConnectionDistributorFactory
例外
IllegalPasswordException


jp.co.intra_mart.foundation.service.client.manager (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.manager

このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。

参照:
説明

クラスの概要
ServerConnector | このクラスは、Server-Manager にリクエストを送信して 処理を要求するためのオブジェクトです。
SocketConnectionDistributorFactory | このクラスは、Server-Manager に接続するための ネットワークコネクション管理オブジェクトを作成するためのクラスです。

例外の概要
IllegalPasswordException パスワードが認証されなかったことを通知するための例外です。

パッケージ jp.co.intra_mart.foundation.service.client.manager の説明

このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。
それぞれのサーバの持つ機能を利用するための具体的なＡＰＩに関しては、 サブパッケージを参照してください。


jp.co.intra_mart.foundation.service.client.manager クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.manager の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.client.NetworkConnector (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.service.client.manager.ServerConnector (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException


パッケージ jp.co.intra_mart.foundation.service.client.manager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client.manager の使用

jp.co.intra_mart.foundation.service.client.manager を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.manager このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。

jp.co.intra_mart.foundation.service.client.manager により使用される jp.co.intra_mart.foundation.service.client.manager のクラス
IllegalPasswordException
パスワードが認証されなかったことを通知するための例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ServerConnector (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.manager
クラス ServerConnector

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.manager.ServerConnector
すべての実装インタフェース:
Serializable
public class ServerConnector
extends NetworkConnector
implements Serializable

このクラスは、Server-Manager にリクエストを送信して 処理を要求するためのオブジェクトです。

導入されたバージョン:
intra-mart Version 4.1
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
ServerConnector(SocketConnectionDistributor socketConnectionDistributor)
オブジェクトを作成します。
メソッドの概要
protected SocketConnection | connection() サーバに接続するためのコネクションを取得します。
SocketConnectionDistributor | getSocketConnectionDistributor() このオブジェクトが保持しているネットワークのコネクションプールを 返します。
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ServerConnector

public ServerConnector(SocketConnectionDistributor socketConnectionDistributor)
オブジェクトを作成します。

socketConnectionDistributor には、SocketConnectionDistributorFactory クラスから 作成されたオブジェクトを渡してください。

パラメータ:
socketConnectionDistributor - ネットワークコネクション管理オブジェクト
関連項目:
SocketConnectionDistributorFactory.createSocketConnectionDistributor(String)
メソッドの詳細

getSocketConnectionDistributor

public SocketConnectionDistributor getSocketConnectionDistributor()
このオブジェクトが保持しているネットワークのコネクションプールを 返します。

connection

protected SocketConnection connection()
                               throws IOException
サーバに接続するためのコネクションを取得します。

定義:
クラス NetworkConnector 内の connection
戻り値:
コネクション
例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SocketConnectionDistributorFactory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.manager
クラス SocketConnectionDistributorFactory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory
public class SocketConnectionDistributorFactory
extends Object

このクラスは、Server-Manager に接続するための ネットワークコネクション管理オブジェクトを作成するためのクラスです。

導入されたバージョン:
intra-mart Version 4.1

コンストラクタの概要
SocketConnectionDistributorFactory(String address, int port)
オブジェクトを作成します。
SocketConnectionDistributorFactory(String address, int port, int timeout)
オブジェクトを作成します。
メソッドの概要
 SocketConnectionDistributor createSocketConnectionDistributor(String passwd)
Server-Manager に接続するためのネットワークコネクション管理 オブジェクトを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SocketConnectionDistributorFactory

public SocketConnectionDistributorFactory(String address,
                                          int port)
オブジェクトを作成します。

パラメータ:
address - Server-Manager が動作しているコンピュータのアドレス
port - Server-Manager がサービスを提供しているネットワークポート番号

SocketConnectionDistributorFactory

public SocketConnectionDistributorFactory(String address,
                                          int port,
                                          int timeout)
オブジェクトを作成します。

timeout には、リクエストに対する Server-Manager からの応答 タイムアウトをミリ秒で指定します。 タイムアウトを設定することにより、Server-Manager から応答がない場合に、 デットロックしてしまう可能性を回避することができます。 逆に、タイムアウトを設定することによって、 正常に動作している場合に置いてもタイムアウトが発生してしまうと、 リクエストはエラー終了扱いとなってしまいます。

パラメータ:
address - Server-Manager が動作しているコンピュータのアドレス
port - Server-Manager がサービスを提供しているネットワークポート番号
timeout - リクエストのタイムアウト時間
メソッドの詳細

createSocketConnectionDistributor

public SocketConnectionDistributor createSocketConnectionDistributor(String passwd)
                                                              throws IllegalPasswordException,
                                                                     IOException
Server-Manager に接続するためのネットワークコネクション管理 オブジェクトを取得します。 引数のパスワードには、Administrator を利用するためのパスワードとして 設定されている文字列を指定してください。

パラメータ:
passwd - パスワード
戻り値:
ネットワークコネクション管理オブジェクト
例外:
IllegalPasswordException - パスワード違反
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ActionListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client
インタフェース ActionListener

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
NetworkAgent
public interface ActionListener
extends Serializable

このクラスは、主にイベントにより処理されるリスナーを実装する ためのスケルトンを提供します。

導入されたバージョン:
version 4.0

メソッドの概要
 Object action(Object arg)
このメソッドは、特定のイベント発生時に実行されます。

メソッドの詳細

action

public Object action(Object arg)
              throws RuntimeException,
                     Error
このメソッドは、特定のイベント発生時に実行されます。

どのイベントに対してのリスナーになるかということは、 このインターフェースを扱うオブジェクトに依存します。 したがって、このインターフェースは様々な種類のリスナーとして動作する 可能性があり、サブクラスは目的と動作を十分に認識した上で 実装する必要があります。

パラメータ:
arg - 引数オブジェクト
戻り値:
実行結果
例外:
RuntimeException - 実行時エラー
Error - 致命的なエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


NetworkAgent (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client
クラス NetworkAgent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
すべての実装インタフェース:
ActionListener, Serializable
直系の既知のサブクラス:
AbstractComponent, ExternalDirectory, ExternalMemory, Lock, PermanentDirectory, PermanentFile, Scheduler
public abstract class NetworkAgent
extends NetworkConnector
implements ActionListener

このクラスは、他のサーバで実行されるロジックを実装する ためのスケルトンを提供します。

サーバがネットワーク型構成で動作している場合は、ネットワーク通信を行い 目的のサーバでロジックを実行します。サーバがスタンドアロン型構成で動作 している場合は、そのサーバ内で直接ロジックを実行します。
このクラスを継承したサブクラスでは、他のサーバでロジックを実行するための メソッドと実際にサーバで実行されるロジックを定義する必要があります。
また、サブクラスは直列化可能なクラスである必要があります。 サブクラスが直列化できない場合、ロジックの呼び出し時に例外がスローされます。

関連項目:
直列化された形式

フィールドの概要
protected static Object NULL_DATA
NULL を表します。
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
protected NetworkAgent()
唯一のコンストラクタ。
メソッドの概要
abstract Object | action(Object arg) このオブジェクトの実行ロジック。
protected Object | execute(Object arg) サーバに対して実行要求をします。
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, connection, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

NULL_DATA

protected static final Object NULL_DATA
NULL を表します。 値は null です。

コンストラクタの詳細

NetworkAgent

protected NetworkAgent()
唯一のコンストラクタ。

メソッドの詳細

action

public abstract Object action(Object arg)
                       throws RuntimeException,
                              Error
このオブジェクトの実行ロジック。

このメソッドは、execute(Object) を実行すると リスナーを実行する対象となっているサーバにより呼び出されます。 このメソッドの引数 arg は execute(Object) に渡された引数が そのまま渡されます。
このメソッドは、サブクラスでオーバーライドする必要があります。

サーバがスタンドアロン型で運用されている場合、現在動作しているサーバ内で 実行されます。 また、サーバがネットワーク型で運用されている場合、 NetworkConnector.connection() から取得したコネクションにより 接続されたサーバで実行されます。
サーバがネットワーク型で運用されている場合、このメソッドの実行結果は 直列化されてサーバ間を転送されるため、このメソッドの返却値は 直列化可能なオブジェクトである必要があります。
このメソッドの返却値が直列化ができなくて、サーバがネットワーク型で 運用されていた場合、実行要求をしたサーバ側で例外がスローされます。

定義:
インタフェース ActionListener 内の action
パラメータ:
arg - 引数オブジェクト
戻り値:
実行結果
例外:
RuntimeException - 実行時エラー
Error - 致命的なエラー
関連項目:
execute(Object)

execute

protected final Object execute(Object arg)
                        throws IOException,
                               RuntimeException,
                               Error
サーバに対して実行要求をします。

サーバがスタンドアロン型で運用されている場合、現在動作しているサーバ内で サブクラスによりオーバーライドされた action(Object) を 実行し、その結果を返します。
サーバがネットワーク型で運用されている場合、 NetworkConnector.connection() から取得したコネクションにより 接続されたサーバにこのインスタンスを転送して実行を依頼します。 接続先サーバでは、このオブジェクトを復元して サブクラスによりオーバーライドされた action(Object) を 実行します。実行結果はネットワークにより転送され、復元した後に、 このメソッドの実行結果として返します。

このメソッドに渡す引数は、直列化可能なオブジェクトに限ります。 引数を直列化できない場合、このメソッドは例外をスローします。

パラメータ:
arg - action() に渡す引数
戻り値:
action() の実行結果
例外:
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
StreamCorruptedException - ストリームの制御情報に一貫性がない場合
OptionalDataException - プリミティブデータが、オブジェクトではなくストリームに見つかった場合
NotSerializableException - 直列化の対象が java.io.Serializable インタフェースを実装していない場合
IOException - 入出力エラーが発生した場合
RuntimeException - 実行時エラー
Error - 致命的なエラー
関連項目:
action(Object)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


NetworkConnector (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client
クラス NetworkConnector

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
NetworkAgent, ServerConnector
public abstract class NetworkConnector
extends Object
implements Serializable

このクラスは、他のサーバで実行されるロジックを転送する ためのスケルトンを提供します。

サーバがネットワーク型構成で動作している場合は、ネットワーク通信を行い 目的のサーバにロジックを転送します。サーバがスタンドアロン型構成で動作 している場合は、そのサーバ内で直接ロジックを実行します。
このクラスを継承したサブクラスでは、他のサーバでロジックを実行するための ネットワークコネクションを定義する必要があります。
また、サブクラスは直列化可能なクラスである必要があります。 サブクラスが直列化できない場合、ロジックの呼び出し時に例外がスローされます。

導入されたバージョン:
version 4.0
関連項目:
直列化された形式

フィールドの概要
protected static int | GET
protected static int | GET_ENTIRETY
protected static int | GET_ENTIRETY_KEY
protected static int | GET_ITEM
protected static int | GET_ITEM_KEY
protected static int | GET_SUBSET
protected static int | MOVE
protected static int | MOVE_ENTIRETY
protected static int | MOVE_ITEM
protected static int | REMOVE
protected static int | REMOVE_ENTIRETY
protected static int | REMOVE_ITEM
protected static int | SET
protected static int | SET_ENTIRETY
protected static int | SET_ITEM
コンストラクタの概要
protected NetworkConnector()
唯一のコンストラクタ。
メソッドの概要
void | close() ネットワークを切断します。
protected abstract SocketConnection | connection() サーバに接続するためのコネクションを取得します。
Object | execute(ActionListener target, Object arg) サーバに対して実行要求をします。
long | freeMemory() サーバシステムの空きメモリの量を返します。
boolean | isConnected() サーバとの接続状態をチェックします。
long | serverTime() サーバのミリ秒で表される現在の時間を返します。
long | totalMemory() サーバプロセスの Java Virtual Machine のメモリの総容量を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

SET

protected static final int SET
関連項目:
定数フィールド値

SET_ITEM

protected static final int SET_ITEM
関連項目:
定数フィールド値

SET_ENTIRETY

protected static final int SET_ENTIRETY
関連項目:
定数フィールド値

GET

protected static final int GET
関連項目:
定数フィールド値

GET_ITEM

protected static final int GET_ITEM
関連項目:
定数フィールド値

GET_ENTIRETY

protected static final int GET_ENTIRETY
関連項目:
定数フィールド値

GET_SUBSET

protected static final int GET_SUBSET
導入されたバージョン:
version 5.0
関連項目:
定数フィールド値

GET_ITEM_KEY

protected static final int GET_ITEM_KEY
関連項目:
定数フィールド値

GET_ENTIRETY_KEY

protected static final int GET_ENTIRETY_KEY
関連項目:
定数フィールド値

REMOVE

protected static final int REMOVE
関連項目:
定数フィールド値

REMOVE_ITEM

protected static final int REMOVE_ITEM
関連項目:
定数フィールド値

REMOVE_ENTIRETY

protected static final int REMOVE_ENTIRETY
関連項目:
定数フィールド値

MOVE

protected static final int MOVE
関連項目:
定数フィールド値

MOVE_ITEM

protected static final int MOVE_ITEM
関連項目:
定数フィールド値

MOVE_ENTIRETY

protected static final int MOVE_ENTIRETY
関連項目:
定数フィールド値
コンストラクタの詳細

NetworkConnector

protected NetworkConnector()
唯一のコンストラクタ。

メソッドの詳細

connection

protected abstract SocketConnection connection()
                                        throws UnsupportedNetworkConnectException,
                                               IOException
サーバに接続するためのコネクションを取得します。
ネットワーク接続が必要ではない場合は、 UnsupportedNetworkConnectException をスローします。

このメソッドは、サブクラスでオーバーライドする必要があります。

戻り値:
コネクション
例外:
UnsupportedNetworkConnectException - ネットワーク接続が許可されていない場合
IOException - 入出力エラーが発生した場合

execute

public Object execute(ActionListener target,
                      Object arg)
               throws IOException,
                      RuntimeException,
                      Error
サーバに対して実行要求をします。

サーバがスタンドアロン型で運用されている場合、 現在動作しているサーバ内で リスナー ActionListener.action(Object) を 実行し、その結果を返します。
サーバがネットワーク型で運用されている場合、connection() メソッドにより取得したコネクションを利用してサーバに接続し、 リスナーオブジェクトを直列化して転送します。 接続先サーバでは、転送したリスナーオブジェクトを復元して リスナーオブジェクトの ActionListener.action(Object) を 実行します。実行結果はネットワークにより転送され、復元した後に、 このメソッドの実行結果として返します。

このメソッドに渡す引数は、直列化可能なオブジェクトに限ります。 引数を直列化できない場合、このメソッドは例外をスローします。

パラメータ:
target - サーバで実行するリスナーオブジェクト
arg - action() に渡す引数
戻り値:
action() の実行結果
例外:
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
StreamCorruptedException - ストリームの制御情報に一貫性がない場合
OptionalDataException - プリミティブデータが、オブジェクトではなくストリームに見つかった場合
NotSerializableException - 直列化の対象が java.io.Serializable インタフェースを実装していない場合
IOException - 入出力エラーが発生した場合
RuntimeException - 実行時エラー
Error - 致命的なエラー
関連項目:
NetworkAgent.action(Object)

isConnected

public boolean isConnected()
サーバとの接続状態をチェックします。

このメソッド実行時に取得したネットワークコネクションについて接続確認を します。他のコネクションに関してはチェックしないため、このメソッドの 結果接続を確認できたとしても次のリクエストで取得したコネクションで 接続エラーが発生する場合があります。

戻り値:
接続に成功した場合は true、そうでない場合は false。

serverTime

public long serverTime()
                throws IOException
サーバのミリ秒で表される現在の時間を返します。

戻り値:
ミリ秒で測定した、現在時刻と UTC 1970 年 1 月 1 日午前 0 時との差
例外:
IOException - 入出力エラーが発生した場合
関連項目:
System.currentTimeMillis()

totalMemory

public long totalMemory()
                 throws IOException
サーバプロセスの Java Virtual Machine のメモリの総容量を返します。

戻り値:
現在および将来のオブジェクトに利用可能なメモリの総容量 (バイト単位)
例外:
IOException - 入出力エラーが発生した場合
関連項目:
Runtime.totalMemory()

freeMemory

public long freeMemory()
                throws IOException
サーバシステムの空きメモリの量を返します。

戻り値:
将来のオブジェクトに利用可能なメモリの推定総容量 (バイト単位)
例外:
IOException - 入出力エラーが発生した場合
関連項目:
Runtime.freeMemory()

close

public void close()
           throws IOException
ネットワークを切断します。

切断されるネットワークコネクションは、このメソッドを実行した時に、 このメソッド内でこのオブジェクトの connection() メソッドから 取得したコネクションに関してのみです。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.client (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.service.client
インタフェース
ActionListener
クラス
NetworkAgent
NetworkConnector


jp.co.intra_mart.foundation.service.client (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client

このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。

参照:
説明

インタフェースの概要
ActionListener このクラスは、主にイベントにより処理されるリスナーを実装する ためのスケルトンを提供します。

クラスの概要
NetworkAgent | このクラスは、他のサーバで実行されるロジックを実装する ためのスケルトンを提供します。
NetworkConnector | このクラスは、他のサーバで実行されるロジックを転送する ためのスケルトンを提供します。

パッケージ jp.co.intra_mart.foundation.service.client の説明

このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
それぞれのサーバの持つ機能を利用するための具体的なＡＰＩに関しては、 サブパッケージを参照してください。

関連項目:
jp.co.intra_mart.foundation.service.client.batch, jp.co.intra_mart.foundation.service.client.file, jp.co.intra_mart.foundation.service.client.information


jp.co.intra_mart.foundation.service.client クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.client.NetworkConnector (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.service.client.NetworkAgent (implements jp.co.intra_mart.foundation.service.client.ActionListener)

インタフェース階層

  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.service.client.ActionListener


パッケージ jp.co.intra_mart.foundation.service.client の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client の使用

jp.co.intra_mart.foundation.service.client を使用しているパッケージ
jp.co.intra_mart.foundation.service.client | このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.client.batch | Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file | Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.manager | このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。

jp.co.intra_mart.foundation.service.client により使用される jp.co.intra_mart.foundation.service.client のクラス
ActionListener
このクラスは、主にイベントにより処理されるリスナーを実装する ためのスケルトンを提供します。
NetworkConnector
このクラスは、他のサーバで実行されるロジックを転送する ためのスケルトンを提供します。

jp.co.intra_mart.foundation.service.client.batch により使用される jp.co.intra_mart.foundation.service.client のクラス
ActionListener
このクラスは、主にイベントにより処理されるリスナーを実装する ためのスケルトンを提供します。
NetworkAgent
このクラスは、他のサーバで実行されるロジックを実装する ためのスケルトンを提供します。
NetworkConnector
このクラスは、他のサーバで実行されるロジックを転送する ためのスケルトンを提供します。

jp.co.intra_mart.foundation.service.client.file により使用される jp.co.intra_mart.foundation.service.client のクラス
ActionListener
このクラスは、主にイベントにより処理されるリスナーを実装する ためのスケルトンを提供します。
NetworkAgent
このクラスは、他のサーバで実行されるロジックを実装する ためのスケルトンを提供します。
NetworkConnector
このクラスは、他のサーバで実行されるロジックを転送する ためのスケルトンを提供します。

jp.co.intra_mart.foundation.service.client.information により使用される jp.co.intra_mart.foundation.service.client のクラス
ActionListener
このクラスは、主にイベントにより処理されるリスナーを実装する ためのスケルトンを提供します。
NetworkAgent
このクラスは、他のサーバで実行されるロジックを実装する ためのスケルトンを提供します。
NetworkConnector
このクラスは、他のサーバで実行されるロジックを転送する ためのスケルトンを提供します。

jp.co.intra_mart.foundation.service.client.manager により使用される jp.co.intra_mart.foundation.service.client のクラス
NetworkConnector
このクラスは、他のサーバで実行されるロジックを転送する ためのスケルトンを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent の使用

jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain の使用

FilterHTTPActionEventChain を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

jp.co.intra_mart.foundation.service.provider.application での FilterHTTPActionEventChain の使用

FilterHTTPActionEventChain 型のパラメータを持つ jp.co.intra_mart.foundation.service.provider.application のメソッド
protected abstract  void FilterHTTPActionEvent.doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain)
イベントのフィルタ処理です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の使用

HTTPActionEvent を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

jp.co.intra_mart.foundation.service.provider.application での HTTPActionEvent の使用

HTTPActionEvent を実装している jp.co.intra_mart.foundation.service.provider.application のクラス
 class FilterHTTPActionEvent
Application Runtime で実行されるイベントのための フィルターイベントの抽象実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext の使用

HTTPActionEventClientContext を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

jp.co.intra_mart.foundation.service.provider.application での HTTPActionEventClientContext の使用

HTTPActionEventClientContext を返す jp.co.intra_mart.foundation.service.provider.application のメソッド
 HTTPActionEventClientContext HTTPActionEventContext.getClientContext()
イベントの実行を要求したクライアントに関する情報オブジェクトを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext の使用

HTTPActionEventContext を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

jp.co.intra_mart.foundation.service.provider.application での HTTPActionEventContext の使用

HTTPActionEventContext 型のパラメータを持つ jp.co.intra_mart.foundation.service.provider.application のメソッド
void | HTTPActionEvent.action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response) イベント処理メソッドです。
void | FilterHTTPActionEvent.action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response) イベント処理メソッドです。
protected abstract void | FilterHTTPActionEvent.doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain) イベントのフィルタ処理です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException の使用

HTTPActionEventException を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

jp.co.intra_mart.foundation.service.provider.application での HTTPActionEventException の使用

HTTPActionEventException をスローする jp.co.intra_mart.foundation.service.provider.application のメソッド
 long HTTPActionEventContext.getRequestTime()
イベントの実行を要求した時刻を返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext の使用

HTTPActionEventListenerContext を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

jp.co.intra_mart.foundation.service.provider.application での HTTPActionEventListenerContext の使用

HTTPActionEventListenerContext を返す jp.co.intra_mart.foundation.service.provider.application のメソッド
 HTTPActionEventListenerContext HTTPActionEventContext.getListenerContext()
イベントの実行要求を受け付けたリスナーに関する情報オブジェクトを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


FilterHTTPActionEvent (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
クラス FilterHTTPActionEvent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent
すべての実装インタフェース:
HTTPActionEvent
public abstract class FilterHTTPActionEvent
extends Object
implements HTTPActionEvent

Application Runtime で実行されるイベントのための フィルターイベントの抽象実装です。
実際のイベントをフィルタリングしてラップする場合に利用します。

フィルターイベントを作成する場合は、この抽象実装をスーパークラスとして サブクラスを作成します。 その際、引数を１つも持たない public なコンストラクタを持つ必要があります。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected FilterHTTPActionEvent()
指定のイベントをラップするためのフィルターを作成します。
メソッドの概要
void | action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response) イベント処理メソッドです。
protected abstract void | doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain) イベントのフィルタ処理です。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FilterHTTPActionEvent

protected FilterHTTPActionEvent()
指定のイベントをラップするためのフィルターを作成します。

メソッドの詳細

action

public final void action(HTTPActionEventContext context,
                         HttpServletRequest request,
                         HttpServletResponse response)
                  throws ServletException
イベント処理メソッドです。

Application Runtime で HTTPActionEventListenerServlet により 実行されます。 このメソッドは、Application Runtime 内で実行されるため、 このメソッド内で使用するすべてのクラスは、Application Runtime の 動作する環境内においてアクセスできる必要があります。

このメソッドは、リクエストを適切に処理した後に、 doFilter(HTTPActionEventContext, HttpServletRequest, HttpServletResponse, FilterHTTPActionEventChain) を呼び出します。 サブクラスは、doFilter(HTTPActionEventContext, HttpServletRequest, HttpServletResponse, FilterHTTPActionEventChain) をオーバーライドして、 フィルタとして処理したい内容を実装してください。

定義:
インタフェース HTTPActionEvent 内の action
パラメータ:
context - イベントに関する情報
request - HTTPリクエストオブジェクト
response - HTTPレスポンスオブジェクト
例外:
ServletException - 実行時エラー

doFilter

protected abstract void doFilter(HTTPActionEventContext context,
                                 HttpServletRequest request,
                                 HttpServletResponse response,
                                 FilterHTTPActionEventChain chain)
                          throws ServletException
イベントのフィルタ処理です。

パラメータ:
context - イベントに関する情報
request - HTTPリクエストオブジェクト
response - HTTPレスポンスオブジェクト
chain - チェーン内の次のエンティティ
例外:
ServletException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


FilterHTTPActionEventChain (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
インタフェース FilterHTTPActionEventChain

public interface FilterHTTPActionEventChain

FilterHTTPActionEventChain は、FilterHTTPActionEvent によって提供され、 FilterHTTPActionEvent へのフィルタリングされた要求のチェーンに対する ビューを提供します。
FilterHTTPActionEvent は、チェーン内の次のフィルタを呼び出す時、 あるいは FilterHTTPActionEvent がチェーン内の最後のフィルタの場合は イベント(HTTPActionEvent)を呼び出す時に、 FilterHTTPActionEventChain を利用します。

導入されたバージョン:
version 4.3

メソッドの概要
void | doChain() チェーン内の次のフィルタまたはイベントを デフォルトのリクエストとレスポンスを利用して呼び出します。
void | doChain(HttpServletRequest request, HttpServletResponse response) チェーン内の次のフィルタまたはイベントを 指定のリクエストとレスポンスを利用して呼び出します。
HttpServletRequest | getRequest() チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのリクエストを 返します。
HttpServletResponse | getResponse() チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのレスポンスを 返します。

メソッドの詳細

getRequest

public HttpServletRequest getRequest()
チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのリクエストを 返します。

戻り値:
リクエスト

getResponse

public HttpServletResponse getResponse()
チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのレスポンスを 返します。

戻り値:
リクエスト

doChain

public void doChain()
             throws ServletException
チェーン内の次のフィルタまたはイベントを デフォルトのリクエストとレスポンスを利用して呼び出します。
このメソッドの呼び出しは、以下の呼び出しと同様です。

doChain(getRequest(), getResponse())

例外:
ServletException - 実行時エラー

doChain

public void doChain(HttpServletRequest request,
                    HttpServletResponse response)
             throws ServletException
チェーン内の次のフィルタまたはイベントを 指定のリクエストとレスポンスを利用して呼び出します。

パラメータ:
request - HTTPリクエストオブジェクト
response - HTTPレスポンスオブジェクト
例外:
ServletException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEvent (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
インタフェース HTTPActionEvent

既知の実装クラスの一覧:
FilterHTTPActionEvent
public interface HTTPActionEvent

Application Runtime で実行されるイベントのためのインターフェースです。
このインターフェースを実装したクラスは、 Application Runtime でインスタンス化されます。 したがって、通常は WEB-INF 内にクラスを配置する事になります。

また、イベントはイベントリスナーにより引数を持たないコンストラクタを 利用してインスタンス化されます。 したがって、このインターフェースを実装するクラスは、 引数を持たない public なコンストラクタが必要になります。

導入されたバージョン:
version 4.3

メソッドの概要
 void action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response)
イベント処理メソッドです。

メソッドの詳細

action

public void action(HTTPActionEventContext context,
                   HttpServletRequest request,
                   HttpServletResponse response)
            throws ServletException
イベント処理メソッドです。

Application Runtime で HTTPActionEventListenerServlet により 実行されます。 このメソッドは、Application Runtime 内で実行されるため、 このメソッド内で使用するすべてのクラスは、Application Runtime の 動作する環境内においてアクセスできる必要があります。

パラメータ:
context - イベントに関する情報
request - HTTPリクエストオブジェクト
response - HTTPレスポンスオブジェクト
例外:
ServletException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventClientContext (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
インタフェース HTTPActionEventClientContext

public interface HTTPActionEventClientContext

Application Runtime で実行されるイベントの実行を要求した クライアントに関する情報インターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
String | getRemoteHostAddress() イベント実行要求をしたクライアントのアドレスを返します。
String | getRemoteHostName() イベント実行要求をしたクライアントのホスト名を返します。
String | getSystemProperty(String name) クライアントの Java 実行環境のシステムプロパティの値を返します。
Set | getSystemPropertyNameSet() クライアントの Java 実行環境のシステムプロパティの名前のセットを返します。

メソッドの詳細

getRemoteHostAddress

public String getRemoteHostAddress()
イベント実行要求をしたクライアントのアドレスを返します。

戻り値:
アドレスを表す文字列

getRemoteHostName

public String getRemoteHostName()
イベント実行要求をしたクライアントのホスト名を返します。

戻り値:
ホスト名

getSystemProperty

public String getSystemProperty(String name)
クライアントの Java 実行環境のシステムプロパティの値を返します。

パラメータ:
name - プロパティ名
戻り値:
プロパティ名に対する値。指定のプロパティ名に関する定義値が見つからない場合は null。

getSystemPropertyNameSet

public Set getSystemPropertyNameSet()
クライアントの Java 実行環境のシステムプロパティの名前のセットを返します。 セットの各要素はプロパティ名を表す java.lang.String 型の値です。

戻り値:
プロパティ名のセット
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventContext (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
インタフェース HTTPActionEventContext

public interface HTTPActionEventContext

Application Runtime で実行されるイベントに関する情報インターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
long | getAcceptTime() イベント実行要求を受け付けたおよその時刻を返します。
String | getCharacterEncoding() リクエストパラメータの文字エンコーディングを返します。
HTTPActionEventClientContext | getClientContext() イベントの実行を要求したクライアントに関する情報オブジェクトを返します。
HttpServletRequest | getHttpServletRequest() 現在のイベントを要求したリクエストを返します。
HTTPActionEventListenerContext | getListenerContext() イベントの実行要求を受け付けたリスナーに関する情報オブジェクトを返します。
long | getRequestTime() イベントの実行を要求した時刻を返します。

メソッドの詳細

getAcceptTime

public long getAcceptTime()
イベント実行要求を受け付けたおよその時刻を返します。
Servlet コンテナによって、リスナーとなっている Servlet が実行される 以前に javax.servlet.Filter 等が実行されたりします。 したがって、このメソッドの返す値はサーバがリクエストを受け付けた時刻と 一致するとは限りません。

返す時刻の単位はミリ秒で、java.lang.System#currentTimeMillis() の仕様に 準じます。

戻り値:
時刻を表すミリ秒

getCharacterEncoding

public String getCharacterEncoding()
リクエストパラメータの文字エンコーディングを返します。

戻り値:
文字エンコーディング名

getRequestTime

public long getRequestTime()
                    throws HTTPActionEventException
イベントの実行を要求した時刻を返します。 このメソッドの返す時刻は、 1970/1/1 を基準から現在までのミリ秒です。

戻り値:
1970/1/1 を基準から現在までのミリ秒
例外:
HTTPActionEventException - 要求時刻が不明な場合

getHttpServletRequest

public HttpServletRequest getHttpServletRequest()
現在のイベントを要求したリクエストを返します。

戻り値:
リクエスト

getClientContext

public HTTPActionEventClientContext getClientContext()
イベントの実行を要求したクライアントに関する情報オブジェクトを返します。

戻り値:
クライアント情報オブジェクト

getListenerContext

public HTTPActionEventListenerContext getListenerContext()
イベントの実行要求を受け付けたリスナーに関する情報オブジェクトを返します。

戻り値:
リスナー情報オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
クラス HTTPActionEventException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException
すべての実装インタフェース:
Serializable
public class HTTPActionEventException
extends Exception

HTTPActionEvent に関するエラーを通知するための例外です。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
HTTPActionEventException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventException(String msg, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HTTPActionEventException

public HTTPActionEventException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

HTTPActionEventException

public HTTPActionEventException(String msg,
                                Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventListenerContext (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
インタフェース HTTPActionEventListenerContext

public interface HTTPActionEventListenerContext

Application Runtime でイベントの実行制御を行うリスナーに関する情報インターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
Class | getListenerClass() リスナーとなっている Servlet の実行時クラスを返します。
ServletConfig | getServletConfig() イベントを制御したリスナー となっている Servlet が初期化された時に Servlet コンテナから渡された設定オブジェクトが返されます。

メソッドの詳細

getServletConfig

public ServletConfig getServletConfig()
イベントを制御したリスナー となっている Servlet が初期化された時に Servlet コンテナから渡された設定オブジェクトが返されます。

戻り値:
Servlet 設定情報を含んでいる ServletConfig オブジェクト

getListenerClass

public Class getListenerClass()
リスナーとなっている Servlet の実行時クラスを返します。

戻り値:
java.lang.Class 型オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.provider.application (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.service.provider.application
インタフェース
FilterHTTPActionEventChain
HTTPActionEvent
HTTPActionEventClientContext
HTTPActionEventContext
HTTPActionEventListenerContext
クラス
FilterHTTPActionEvent
例外
HTTPActionEventException


jp.co.intra_mart.foundation.service.provider.application (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.application

このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

参照:
説明

インタフェースの概要
FilterHTTPActionEventChain | FilterHTTPActionEventChain は、FilterHTTPActionEvent によって提供され、 FilterHTTPActionEvent へのフィルタリングされた要求のチェーンに対する ビューを提供します。
HTTPActionEvent | Application Runtime で実行されるイベントのためのインターフェースです。
HTTPActionEventClientContext | Application Runtime で実行されるイベントの実行を要求した クライアントに関する情報インターフェースです。
HTTPActionEventContext | Application Runtime で実行されるイベントに関する情報インターフェースです。
HTTPActionEventListenerContext | Application Runtime でイベントの実行制御を行うリスナーに関する情報インターフェースです。

クラスの概要
FilterHTTPActionEvent Application Runtime で実行されるイベントのための フィルターイベントの抽象実装です。

例外の概要
HTTPActionEventException HTTPActionEvent に関するエラーを通知するための例外です。

パッケージ jp.co.intra_mart.foundation.service.provider.application の説明

このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

導入されたバージョン:
version 4.0


jp.co.intra_mart.foundation.service.provider.application クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.application の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent (implements jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException

インタフェース階層

  • interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext


パッケージ jp.co.intra_mart.foundation.service.provider.application の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.provider.application の使用

jp.co.intra_mart.foundation.service.provider.application を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

jp.co.intra_mart.foundation.service.provider.application により使用される jp.co.intra_mart.foundation.service.provider.application のクラス
FilterHTTPActionEventChain
FilterHTTPActionEventChain は、FilterHTTPActionEvent によって提供され、 FilterHTTPActionEvent へのフィルタリングされた要求のチェーンに対する ビューを提供します。
HTTPActionEvent
Application Runtime で実行されるイベントのためのインターフェースです。
HTTPActionEventClientContext
Application Runtime で実行されるイベントの実行を要求した クライアントに関する情報インターフェースです。
HTTPActionEventContext
Application Runtime で実行されるイベントに関する情報インターフェースです。
HTTPActionEventException
HTTPActionEvent に関するエラーを通知するための例外です。
HTTPActionEventListenerContext
Application Runtime でイベントの実行制御を行うリスナーに関する情報インターフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory の使用

jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent の使用

ProcedureComponent を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.batch このパッケージには、スケジュール実行されるバッチプログラム機能を利用するための共通的な機能を提供します。

jp.co.intra_mart.foundation.service.provider.batch での ProcedureComponent の使用

ProcedureComponent を実装している jp.co.intra_mart.foundation.service.provider.batch のクラス
 class PermanentDataArchiveFactory
推奨されていません。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.service.provider.batch (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.service.provider.batch
インタフェース
ProcedureComponent
クラス
PermanentDataArchiveFactory


jp.co.intra_mart.foundation.service.provider.batch (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.batch

このパッケージには、スケジュール実行されるバッチプログラム機能を利用するための共通的な機能を提供します。

参照:
説明

インタフェースの概要
ProcedureComponent スケジュール実行されるバッチプログラムのためのインターフェースを定義します。

クラスの概要
PermanentDataArchiveFactory 推奨されていません。

パッケージ jp.co.intra_mart.foundation.service.provider.batch の説明

このパッケージには、スケジュール実行されるバッチプログラム機能を利用するための共通的な機能を提供します。
このパッケージに含まれるクラスは、現在動作しているApplication Runtimeプロセス環境において実行されます。また、バッチプログラムを作成する場合に必要なインターフェースを提供しています。


jp.co.intra_mart.foundation.service.provider.batch クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.batch の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory (implements jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent)

インタフェース階層

  • interface jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent


パッケージ jp.co.intra_mart.foundation.service.provider.batch の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.provider.batch の使用

jp.co.intra_mart.foundation.service.provider.batch を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.batch このパッケージには、スケジュール実行されるバッチプログラム機能を利用するための共通的な機能を提供します。

jp.co.intra_mart.foundation.service.provider.batch により使用される jp.co.intra_mart.foundation.service.provider.batch のクラス
ProcedureComponent
スケジュール実行されるバッチプログラムのためのインターフェースを定義します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PermanentDataArchiveFactory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.batch
クラス PermanentDataArchiveFactory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory
すべての実装インタフェース:
ProcedureComponent

public class PermanentDataArchiveFactory
extends Object
implements ProcedureComponent

Permanent-data Service に保存されている永続データをバックアップするための バッチプログラムです。
このクラスをバッチプログラムとして登録することで、 定期的にデータをバックアップすることができます。

なお、このバッチプログラムは、マルチログイングループ環境を サポートしておりません。 バッチとして実行されると、すべてのデータをバックアップします。 したがって、複数のログイングループでバッチ設定をしても ログイングループ単位でのデータバックアップ等を行うことはできません。

導入されたバージョン:
Version 4.2

コンストラクタの概要
PermanentDataArchiveFactory()
推奨されていません。 バッチプログラム実行環境からインスタンス化されるためのコンストラクタ。
メソッドの概要
 void execute(Properties arg)
推奨されていません。 インタフェース ProcedureComponent を実装したオブジェクトの実行クラスを Application Runtime に登録することで、 Application Runtime はこのクラスをインスタンス化し、 execute() メソッドをバッチプログラムとして実行します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PermanentDataArchiveFactory

public PermanentDataArchiveFactory()
推奨されていません。
バッチプログラム実行環境からインスタンス化されるためのコンストラクタ。

メソッドの詳細

execute

public void execute(Properties arg)
             throws RuntimeException,
                    Error
推奨されていません。
インタフェース ProcedureComponent の記述:
インタフェース ProcedureComponent を実装したオブジェクトの実行クラスを Application Runtime に登録することで、 Application Runtime はこのクラスをインスタンス化し、 execute() メソッドをバッチプログラムとして実行します。

バッチとして動作するロジック。

バッチ起動引数は、バッチの設定がバッチ設定画面で登録されている場合、 以下のような項目を持ちます。

group | バッチ設定グループ名（通常はログイングループＩＤ） | String
name | バッチ名称 | String

定義:
インタフェース ProcedureComponent 内の execute
パラメータ:
arg - バッチ起動引数
例外:
Error - 致命的なエラー
RuntimeException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ProcedureComponent (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.batch
インタフェース ProcedureComponent

既知の実装クラスの一覧:
PermanentDataArchiveFactory
public interface ProcedureComponent

スケジュール実行されるバッチプログラムのためのインターフェースを定義します。

このインターフェースを継承するクラスでは、Application Runtime により呼び出された際のバッチ処理を実装して下さい。 また、実装クラスはパラメータを持たない public 宣言されたコンストラクタを 定義しておく必要があります。 バッチサーバは、このゼロパラメータ・コンストラクタを 利用して実装クラスをインスタンス化して execute() メソッドを実行します。

    public class MyBatch implements ProcedureComponent{

        // バッチサーバにインスタンス化されるためのコンストラクタ

        public MyBatch(){

            super();

        }

        public void execute(Properties arg) throws java.lang.RuntimeException, java.lang.Error{

            // バッチのロジック

            System.out.println("Hello. my batch program !");
        }

    }

バッチプログラムを作成したら、コンパイルをしてクラスファイルを作成します。
できあがったクラスファイルをApplication Runtimeが実行可能な環境（ クラスパスの設定されているディレクトリ内）に保存して下さい。 なお、Application Runtime は Webアプリケーションとして動作していますので、 クラスファイルの保存場所には十分注意してください。

バッチ設定画面で MyBatch クラスを登録することで設定した時刻に execute() メソッドがApplication Runtimeにより実行されます。
上記プログラムでは、コンソール画面に「Hello. my batch program !」と 表示されます。

メソッドの概要
 void execute(Properties arg)
インタフェース ProcedureComponent を実装したオブジェクトの実行クラスを Application Runtime に登録することで、 Application Runtime はこのクラスをインスタンス化し、 execute() メソッドをバッチプログラムとして実行します。

メソッドの詳細

execute

public void execute(Properties arg)
             throws RuntimeException,
                    Error
インタフェース ProcedureComponent を実装したオブジェクトの実行クラスを Application Runtime に登録することで、 Application Runtime はこのクラスをインスタンス化し、 execute() メソッドをバッチプログラムとして実行します。

バッチとして動作するロジック。

バッチ起動引数は、バッチの設定がバッチ設定画面で登録されている場合、 以下のような項目を持ちます。

group | バッチ設定グループ名（通常はログイングループＩＤ） | String
name | バッチ名称 | String

パラメータ:
arg - バッチ起動引数
例外:
RuntimeException - 実行時エラー
Error - 致命的なエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.service.provider.Environment の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.Environment の使用

Environment を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

jp.co.intra_mart.foundation.service.provider での Environment の使用

Environment を返す jp.co.intra_mart.foundation.service.provider のメソッド
static Environment Platform.getEnvironment()
システムの設定値を持つオブジェクトを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.GarbageController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.GarbageController の使用

jp.co.intra_mart.foundation.service.provider.GarbageController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.GCConditioner の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.GCConditioner の使用

GCConditioner を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

jp.co.intra_mart.foundation.service.provider での GCConditioner の使用

GCConditioner 型のパラメータを持つ jp.co.intra_mart.foundation.service.provider のメソッド
static void | GarbageController.addConditioner(GCConditioner conditioner) 推奨されていません。
static void | GarbageController.removeConditioner(GCConditioner conditioner) 推奨されていません。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.HomeDirectory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.HomeDirectory の使用

HomeDirectory を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

jp.co.intra_mart.foundation.service.provider での HomeDirectory の使用

HomeDirectory を返す jp.co.intra_mart.foundation.service.provider のメソッド
static HomeDirectory HomeDirectory.instance()
ホームディレクトリを表すオブジェクトを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.Platform の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.Platform の使用

jp.co.intra_mart.foundation.service.provider.Platform はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.SystemErrorReporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.SystemErrorReporter の使用

SystemErrorReporter を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

jp.co.intra_mart.foundation.service.provider での SystemErrorReporter の使用

SystemErrorReporter として宣言されている jp.co.intra_mart.foundation.service.provider のフィールド
static SystemErrorReporter Platform.err
エラーログに対するメッセージ出力ストリームです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.SystemReporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.SystemReporter の使用

SystemReporter を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

jp.co.intra_mart.foundation.service.provider での SystemReporter の使用

jp.co.intra_mart.foundation.service.provider での SystemReporter のサブインタフェース
 interface SystemErrorReporter
エラーログ出力用のインターフェースです。

SystemReporter として宣言されている jp.co.intra_mart.foundation.service.provider のフィールド
static SystemReporter Platform.out
システムログに対するメッセージ出力ストリームです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.TemporaryDirectory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.TemporaryDirectory の使用

TemporaryDirectory を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

jp.co.intra_mart.foundation.service.provider での TemporaryDirectory の使用

TemporaryDirectory を返す jp.co.intra_mart.foundation.service.provider のメソッド
static TemporaryDirectory TemporaryDirectory.instance()
一時ファイル保存用ディレクトリを表すオブジェクトを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.TemporaryFile の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.TemporaryFile の使用

jp.co.intra_mart.foundation.service.provider.TemporaryFile はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.file.StorageDirectory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.file.StorageDirectory の使用

StorageDirectory を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.file このパッケージには、Storage Service 環境内で利用可能な機能を提供します。

jp.co.intra_mart.foundation.service.provider.file での StorageDirectory の使用

StorageDirectory を返す jp.co.intra_mart.foundation.service.provider.file のメソッド
static StorageDirectory StorageDirectory.instance()
ファイルコンテンツの保存ディレクトリを表すオブジェクトを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.service.provider.file (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.service.provider.file
クラス
StorageDirectory


jp.co.intra_mart.foundation.service.provider.file (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.file

このパッケージには、Storage Service 環境内で利用可能な機能を提供します。

参照:
説明

クラスの概要
StorageDirectory Storage Service の基準ディレクトリを表すクラスです。

パッケージ jp.co.intra_mart.foundation.service.provider.file の説明

このパッケージには、Storage Service 環境内で利用可能な機能を提供します。


jp.co.intra_mart.foundation.service.provider.file クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.file の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.io.File (implements java.lang.Comparable, java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.file.Directory
        • class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
          • class jp.co.intra_mart.foundation.service.provider.file.StorageDirectory


パッケージ jp.co.intra_mart.foundation.service.provider.file の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.provider.file の使用

jp.co.intra_mart.foundation.service.provider.file を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.file このパッケージには、Storage Service 環境内で利用可能な機能を提供します。

jp.co.intra_mart.foundation.service.provider.file により使用される jp.co.intra_mart.foundation.service.provider.file のクラス
StorageDirectory
Storage Service の基準ディレクトリを表すクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StorageDirectory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.file
クラス StorageDirectory

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.foundation.utility.file.Directory
            拡張 jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
                拡張 jp.co.intra_mart.foundation.service.provider.file.StorageDirectory
すべての実装インタフェース:
Comparable, Serializable
public class StorageDirectory
extends ExtendedDirectory

Storage Service の基準ディレクトリを表すクラスです。

Storage Service は、このクラスが表すパスを基準ディレクトリとして、 各コンテンツのファイルパスを解決します。 標準では、サーバインストールディレクトリの storage ディレクトリが 基準ディレクトリとなります。

関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
メソッドの概要
static StorageDirectory instance()
ファイルコンテンツの保存ディレクトリを表すオブジェクトを取得します。
クラス jp.co.intra_mart.foundation.utility.file.ExtendedDirectory から継承したメソッド
archive, archive, archive, archive, archive, archive, childDirectory, childFile, childPath, findDirectory, findFile, findPath, reset
クラス jp.co.intra_mart.foundation.utility.file.Directory から継承したメソッド
childDirectories, childFiles, files, paths
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

メソッドの詳細

instance

public static StorageDirectory instance()
ファイルコンテンツの保存ディレクトリを表すオブジェクトを取得します。

戻り値:
File クラスのインスタンス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory の使用

PermanentDataDirectory を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.information このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。

jp.co.intra_mart.foundation.service.provider.information での PermanentDataDirectory の使用

PermanentDataDirectory を返す jp.co.intra_mart.foundation.service.provider.information のメソッド
static PermanentDataDirectory PermanentDataDirectory.instance()
データ保存ディレクトリを表すオブジェクトを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.service.provider.information (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.service.provider.information
クラス
PermanentDataDirectory


jp.co.intra_mart.foundation.service.provider.information (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.information

このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。

参照:
説明

クラスの概要
PermanentDataDirectory Permanent-data を保存するディレクトリを表すオブジェクトです。

パッケージ jp.co.intra_mart.foundation.service.provider.information の説明

このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。 このパッケージに含まれるクラスは、特定の実行環境内でのみ利用可能であり、クラスと各種サービスが密接に関わりあっています。したがって、このパッケージのクラスを利用する場合は、プログラムの実行環境に関して十分に注意をしてください。


jp.co.intra_mart.foundation.service.provider.information クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.information の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.io.File (implements java.lang.Comparable, java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.file.Directory
        • class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
          • class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory


パッケージ jp.co.intra_mart.foundation.service.provider.information の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.provider.information の使用

jp.co.intra_mart.foundation.service.provider.information を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.information このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。

jp.co.intra_mart.foundation.service.provider.information により使用される jp.co.intra_mart.foundation.service.provider.information のクラス
PermanentDataDirectory
Permanent-data を保存するディレクトリを表すオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PermanentDataDirectory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.information
クラス PermanentDataDirectory

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.foundation.utility.file.Directory
            拡張 jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
                拡張 jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory
すべての実装インタフェース:
Comparable, Serializable
public class PermanentDataDirectory
extends ExtendedDirectory

Permanent-data を保存するディレクトリを表すオブジェクトです。 このオブジェクトが表すパスにデータファイルが作成されます。

導入されたバージョン:
Version 4.2
関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
メソッドの概要
void | backup(File f) このデータを指定のファイルにバックアップします。
ExtendedDirectory | entityDirectory() データファイルを保存しておくための ディレクトリを表すオブジェクトを取得します。
static PermanentDataDirectory | instance() データ保存ディレクトリを表すオブジェクトを取得します。
ExtendedDirectory | temporaryDirectory() 削除対象のデータファイルを一時的に保存しておくための ディレクトリを表すオブジェクトを取得します。
クラス jp.co.intra_mart.foundation.utility.file.ExtendedDirectory から継承したメソッド
archive, archive, archive, archive, archive, archive, childDirectory, childFile, childPath, findDirectory, findFile, findPath, reset
クラス jp.co.intra_mart.foundation.utility.file.Directory から継承したメソッド
childDirectories, childFiles, files, paths
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

メソッドの詳細

instance

public static PermanentDataDirectory instance()
データ保存ディレクトリを表すオブジェクトを取得します。

戻り値:
File クラスのインスタンス

entityDirectory

public ExtendedDirectory entityDirectory()
データファイルを保存しておくための ディレクトリを表すオブジェクトを取得します。

戻り値:
ディレクトリを表すオブジェクト

temporaryDirectory

public ExtendedDirectory temporaryDirectory()
削除対象のデータファイルを一時的に保存しておくための ディレクトリを表すオブジェクトを取得します。

このディレクトリには、データを更新する直前のデータファイルが 保存されます。

戻り値:
ディレクトリを表すオブジェクト

backup

public void backup(File f)
            throws IOException
このデータを指定のファイルにバックアップします。 作成されるファイルは、ZIP ファイル形式となります。

パラメータ:
f - 出力ファイルパス
例外:
IOException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Environment (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
インタフェース Environment

public interface Environment

このクラスは、 システムプロパティへアクセスするためのインターフェースです。

システムプロパティとは、サーバが動作するために必要な環境設定値のことです。 このクラスでアクセスできるプロパティは、Java-VM の持つシステムプロパティ とは異なります。Java-VM のシステムプロパティ値を取得する場合は、 java.lang.System クラスを利用して下さい。
このシステムプロパティのセットには、必ず以下のキーに対応する値が 含まれています。

キー | 対応する値の説明
system/server-charset | サーバが外部(ファイルなど)にアクセスする際に標準で利用する文字エンコーディング名
system/root | サーバのインストールディレクトリ

導入されたバージョン:
version4.0
関連項目:
System,
System.getProperty(String),
System.getProperty(String key, String),
System.getProperties()

メソッドの概要
String | getProperty(String key) 指定されたキーによって示されるシステムプロパティを取得します。
String | getProperty(String key, String defaultValue) 指定されたキーによって示されるシステムプロパティを取得します。
Enumeration | propertyNames() システムプロパティリストにあるすべてのキーのリストを返します。

メソッドの詳細

getProperty

public String getProperty(String key)
指定されたキーによって示されるシステムプロパティを取得します。 Enumeration から取得できる各要素は、すべて String クラスのインスタンス になります。

パラメータ:
key - システムプロパティの名前
戻り値:
システムプロパティの文字列値。そのキーにプロパティがない場合は null。
導入されたバージョン:
version4.0

getProperty

public String getProperty(String key,
                          String defaultValue)
指定されたキーによって示されるシステムプロパティを取得します。 Enumeration から取得できる各要素は、すべて String クラスのインスタンス になります。

パラメータ:
key - システムプロパティの名前
defaultValue - デフォルト値
戻り値:
システムプロパティの文字列値。そのキーにプロパティがない場合はデフォルト値。
導入されたバージョン:
version4.0

propertyNames

public Enumeration propertyNames()
システムプロパティリストにあるすべてのキーのリストを返します。 Enumeration から取得できる各要素は、すべて String クラスのインスタンス になります。

戻り値:
プロパティリストにあるすべてのキーのリスト。
導入されたバージョン:
version4.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


GarbageController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
クラス GarbageController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.provider.GarbageController
public class GarbageController
extends Object

ガーベージコレクタを実行するクラスです。

このクラスにリスナーを登録しておくことにより、 gc メソッドが呼び出された時に任意のロジックを実行させることができます。 この機能を利用することにより、ガーベージコレクタ実行前に キャッシュデータなどを削除して、効率的にメモリ空間を開放することができます。

導入されたバージョン:
Version 3.2

メソッドの概要
static void | addConditioner(GCConditioner conditioner) 推奨されていません。
static void | addListener(EventListener listener) リスナーを登録します。
static void | clean() システムのガベージコレクタを実行します。
static void | removeConditioner(GCConditioner conditioner) 推奨されていません。
static boolean | removeListener(EventListener listener) 指定されたリスナーを削除します。
static void | startAutomaticExecution(long millis) 推奨されていません。 gc によるシステム停止や監視スレッドを停止処理しないことによるメモリリークなどの問題を引き起こす危険性があります。
static void | stopAutomaticExecution() 推奨されていません。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

addListener

public static void addListener(EventListener listener)
                        throws NullPointerException
リスナーを登録します。
clean メソッドが呼び出された時に、登録されているすべてのリスナーの handleEvent メソッドを呼び出します。 リスナーの実行順は、保証されません。
このメソッドは、listener が既に登録済みの場合は何もしません。

例外:
NullPointerException - listener が null の場合
関連項目:
clean(), EventListener.handleEvent()

removeListener

public static boolean removeListener(EventListener listener)
指定されたリスナーを削除します。

戻り値:
指定されたリスナーを格納していた場合 true

startAutomaticExecution

public static void startAutomaticExecution(long millis)
推奨されていません。 gc によるシステム停止や監視スレッドを停止処理しないことによるメモリリークなどの問題を引き起こす危険性があります。

gc の自動実行を行うモードを開始します。

この機能は、新しい専用のスレッドで millis ミリ秒おきに addConditioner メソッドで登録されたコンディショナオブジェクトを 実行して gc 実行の必要があると判断された場合に clean メソッドを実行します。 この自動実行スレッドは、stopAutomaticExecution メソッドが 呼び出されるまで上記処理を継続実行します。

gc 実行をするかどうかの判定をするためのコンディショナオブジェクトが 一つも登録されていない場合、このメソッドは何も行いません。
gc 自動実行モードが有効な状態でも、clean メソッドを呼び出すことによって 明示的に gc を実行することができます。

パラメータ:
millis - gc 自動実行のための監視間隔

stopAutomaticExecution

public static void stopAutomaticExecution()
推奨されていません。

gc 自動実行モードを終了します。

addConditioner

public static void addConditioner(GCConditioner conditioner)
推奨されていません。

gc 自動実行において gc を実行するかどうかを判断するための コンディショナを登録します。

パラメータ:
conditioner - コンディショナ
例外:
NullPointerException - conditioner が null の場合

removeConditioner

public static void removeConditioner(GCConditioner conditioner)
推奨されていません。

コンディショナを削除します。

パラメータ:
conditioner - コンディショナ

clean

public static void clean()
システムのガベージコレクタを実行します。

このメソッドは、addListener メソッドで登録された全てのイベントリスナーを 呼び出した後に、ＶＭのガーベージコレクタを実行します。
ガーベージコレクタの実行は、以下の呼出とおなじです。

System.gc()

このメソッドは、複数のスレッドからの多重処理を行いません。 あるスレッドによる実行中に他のスレッドでこのメソッドが呼び出された場合、 このメソッドは何もせずにリターンします。

関連項目:
System.gc()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


GCConditioner (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
インタフェース GCConditioner

public interface GCConditioner

GarbageController クラスが gc を実行するかどうか判断するための インターフェースを提供します。
GarbageController クラスは、startAutomaticExecution メソッドにより 自動実行されている場合、gc を実行するかどうか判断するために このインターフェースのサブクラスを呼び出します。 GarbageController クラスに登録されている GCConditioner のサブクラスのうち、 １つ以上のオブジェクトの cleanUp メソッドが true を返した場合、 GarbageController クラスは gc を実行します。

関連項目:
GarbageController

メソッドの概要
 boolean cleanUp()
gc を実行するかどうかを判断します。

メソッドの詳細

cleanUp

public boolean cleanUp()
gc を実行するかどうかを判断します。
このメソッドは、GarbageController クラスの自動実行プログラムにより gc を実行する前に呼び出されます。

戻り値:
gc を実行させたい場合 true
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HomeDirectory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
クラス HomeDirectory

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory
                拡張 jp.co.intra_mart.foundation.service.provider.HomeDirectory
すべての実装インタフェース:
Comparable, Serializable
public class HomeDirectory
extends ExtendedDirectory

このクラスは、サーバ実行システムのホームディレクトリに関する機能を 提供します。

導入されたバージョン:
version 4.0
関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
メソッドの概要
static void | definePath(String path) 推奨されていません。
static String | findPath() システムのホームディレクトリを返します。
static HomeDirectory | instance() ホームディレクトリを表すオブジェクトを取得します。
クラス jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory から継承したメソッド
archive, archive, archive, archive, archive, archive, childDirectory, childFile, childPath, findDirectory, findFile, findPath, reset
クラス jp.co.intra_mart.common.aid.jdk.java.io.file.Directory から継承したメソッド
childDirectories, childFiles, deleteAll, deleteChilds, files, paths
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

メソッドの詳細

instance

public static HomeDirectory instance()
ホームディレクトリを表すオブジェクトを取得します。

戻り値:
ホームディレクトリを表す File クラスのインスタンス

definePath

public static void definePath(String path)
推奨されていません。

システムのホームディレクトリを設定します。 ホームディレクトリは、インストールディレクトリと同義です。

このメソッドは、システム全体を不安定にしてしまう危険性があるため、 通常は使用してはいけません。

パラメータ:
path - ホームディレクトリを表すパス名
例外:
NullPointerException - 引数が null の場合

findPath

public static String findPath()
システムのホームディレクトリを返します。 ホームディレクトリは、インストールディレクトリと同義です。

通常は、インストールされた環境と設定値から自動的にホームディレクトリが 決定されます。例外として、definePath() メソッドを使用して 意図的にホームディレクトリの情報を書き換えてしまった場合は、 書き換えられたパス情報が返されます。

戻り値:
ホームディレクトリを表すパス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.provider (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.service.provider
インタフェース
Environment
GCConditioner
SystemErrorReporter
SystemReporter
クラス
GarbageController
HomeDirectory
Platform
TemporaryDirectory
TemporaryFile


jp.co.intra_mart.foundation.service.provider (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider

このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

参照:
説明

インタフェースの概要
Environment | このクラスは、 システムプロパティへアクセスするためのインターフェースです。
GCConditioner | GarbageController クラスが gc を実行するかどうか判断するための インターフェースを提供します。
SystemErrorReporter | エラーログ出力用のインターフェースです。
SystemReporter | システムログの共通インターフェースです。

クラスの概要
GarbageController | ガーベージコレクタを実行するクラスです。
HomeDirectory | このクラスは、サーバ実行システムのホームディレクトリに関する機能を 提供します。
Platform | Platform クラスには、システム動作に関わる有用な情報を持つ フィールドおよびメソッドがあります。
TemporaryDirectory | このクラスは、一時ファイル保存用ディレクトリに関する機能を 提供します。
TemporaryFile | このクラスは、一時ファイルに関する機能を提供します。

パッケージ jp.co.intra_mart.foundation.service.provider の説明

このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
このパッケージまたはサブパッケージに含まれるクラスは、現在動作しているサーバプロセス環境において実行されます。他のサーバプロセスに対してリモートアクセスするためには、jp.co.intra_mart.foundation.service.client パッケージおよびそのサブパッケージに含まれるクラスを利用して下さい。

関連項目:
jp.co.intra_mart.foundation.service.client


jp.co.intra_mart.foundation.service.provider クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.io.File (implements java.lang.Comparable, java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.file.Directory
        • class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
          • class jp.co.intra_mart.foundation.service.provider.TemporaryDirectory
      • class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory
        • class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory
          • class jp.co.intra_mart.foundation.service.provider.HomeDirectory
      • class jp.co.intra_mart.foundation.utility.file.ExtendedFile
        • class jp.co.intra_mart.foundation.service.provider.TemporaryFile
    • class jp.co.intra_mart.foundation.service.provider.GarbageController
    • class jp.co.intra_mart.foundation.service.provider.Platform

インタフェース階層

  • interface jp.co.intra_mart.foundation.service.provider.Environment
  • interface jp.co.intra_mart.foundation.service.provider.GCConditioner
  • interface jp.co.intra_mart.foundation.service.provider.SystemReporter
    • interface jp.co.intra_mart.foundation.service.provider.SystemErrorReporter


パッケージ jp.co.intra_mart.foundation.service.provider の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.provider の使用

jp.co.intra_mart.foundation.service.provider を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

jp.co.intra_mart.foundation.service.provider により使用される jp.co.intra_mart.foundation.service.provider のクラス
Environment
このクラスは、 システムプロパティへアクセスするためのインターフェースです。
GCConditioner
GarbageController クラスが gc を実行するかどうか判断するための インターフェースを提供します。
HomeDirectory
このクラスは、サーバ実行システムのホームディレクトリに関する機能を 提供します。
SystemErrorReporter
エラーログ出力用のインターフェースです。
SystemReporter
システムログの共通インターフェースです。
TemporaryDirectory
このクラスは、一時ファイル保存用ディレクトリに関する機能を 提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Platform (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
クラス Platform

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.provider.Platform
public final class Platform
extends Object

Platform クラスには、システム動作に関わる有用な情報を持つ フィールドおよびメソッドがあります。 インスタンスを生成することはできません。

導入されたバージョン:
version 4.2

フィールドの概要
static SystemErrorReporter | err エラーログに対するメッセージ出力ストリームです。
static SystemReporter | out システムログに対するメッセージ出力ストリームです。
メソッドの概要
static Environment | getEnvironment() システムの設定値を持つオブジェクトを取得します。
static String | getEnvironmentProperty(String key) 指定のキーに対応するシステムの設定値を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

out

public static SystemReporter out
システムログに対するメッセージ出力ストリームです。 この出力に対して書き込まれたメッセージは、 システムログの設定に指定された出力先に書き出されます。

err

public static SystemErrorReporter err
エラーログに対するメッセージ出力ストリームです。 この出力に対して書き込まれたメッセージは、 エラーログの設定に指定された出力先に書き出されます。

メソッドの詳細

getEnvironmentProperty

public static String getEnvironmentProperty(String key)
指定のキーに対応するシステムの設定値を取得します。 このメソッドは該当するキーが存在しない場合 null を返します。

このメソッドの呼び出しは、以下の呼び出しと同じです。
Platform.getEnvironment().getProperty(key)

パラメータ:
key - 設定値へのキー名
戻り値:
キーに対応する設定値

getEnvironment

public static Environment getEnvironment()
システムの設定値を持つオブジェクトを取得します。 このメソッドにより返される設定値オブジェクトの状態は、 設定ファイル(conf/imart.xml)の状態に影響されます。

戻り値:
設定値オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SystemErrorReporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
インタフェース SystemErrorReporter

すべてのスーパーインタフェース:
SystemReporter
public interface SystemErrorReporter
extends SystemReporter

エラーログ出力用のインターフェースです。

メソッドの概要
 void write(String message, Throwable t)
メッセージをログに書き込みます。
インタフェース jp.co.intra_mart.foundation.service.provider.SystemReporter から継承したメソッド
flush, write

メソッドの詳細

write

public void write(String message,
                  Throwable t)
メッセージをログに書き込みます。 例外は、個別にファイル出力されます。

パラメータ:
message - ログに書き込むエラーメッセージ
t - 発生した例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SystemReporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
インタフェース SystemReporter

既知のサブインタフェースの一覧:
SystemErrorReporter
public interface SystemReporter

システムログの共通インターフェースです。

メソッドの概要
void | flush() ストリームをフラッシュします。
void | write(String message) メッセージをログに書き込みます。

メソッドの詳細

write

public void write(String message)
メッセージをログに書き込みます。

パラメータ:
message - ログに書き込むメッセージ

flush

public void flush()
           throws IOException
ストリームをフラッシュします。

現在バッファに保存されているデータが置換対象の文字データと 比較途中である場合、比較中のデータはフラッシュされません。 このストリームの持つすべてのバッファをフラッシュするためには、 finish() メソッドを呼び出したあとにこのメソッドを呼び出して下さい。
宛先が別の文字またはバイトストリームの場合は、 この宛先をフラッシュします。つまり 1 つの flush() の呼び出しで、 関連する Writer および OutputStream のすべてのバッファを フラッシュします。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


TemporaryDirectory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
クラス TemporaryDirectory

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.foundation.utility.file.Directory
            拡張 jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
                拡張 jp.co.intra_mart.foundation.service.provider.TemporaryDirectory
すべての実装インタフェース:
Comparable, Serializable
public class TemporaryDirectory
extends ExtendedDirectory

このクラスは、一時ファイル保存用ディレクトリに関する機能を 提供します。

アプリケーション実行時に利用する一時ファイルを保存するための ディレクトリとして利用することができます。

導入されたバージョン:
version 4.0
関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
メソッドの概要
static File | getSystemTemporaryDirectory() システムが使用する一時ファイル保存ディレクトリを表す オブジェクトを返します。
static TemporaryDirectory | instance() 一時ファイル保存用ディレクトリを表すオブジェクトを取得します。
クラス jp.co.intra_mart.foundation.utility.file.ExtendedDirectory から継承したメソッド
archive, archive, archive, archive, archive, archive, childDirectory, childFile, childPath, findDirectory, findFile, findPath, reset
クラス jp.co.intra_mart.foundation.utility.file.Directory から継承したメソッド
childDirectories, childFiles, files, paths
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

メソッドの詳細

getSystemTemporaryDirectory

public static File getSystemTemporaryDirectory()
システムが使用する一時ファイル保存ディレクトリを表す オブジェクトを返します。
このメソッドが返すディレクトリに対してサブディレクトリや ファイルを作成すると、システムが不安定になる可能性があります。 ユーザプログラムで一時ファイルを利用する場合は、 instance() メソッドにて得られるパスに 作成するようにしてください。

戻り値:
一時ファイル保存用ディレクトリを表す File クラスのインスタンス

instance

public static TemporaryDirectory instance()
一時ファイル保存用ディレクトリを表すオブジェクトを取得します。

戻り値:
一時ファイル保存用ディレクトリを表す File クラスのインスタンス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TemporaryFile (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
クラス TemporaryFile

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.foundation.utility.file.ExtendedFile
            拡張 jp.co.intra_mart.foundation.service.provider.TemporaryFile
すべての実装インタフェース:
Comparable, Serializable
public class TemporaryFile
extends ExtendedFile

このクラスは、一時ファイルに関する機能を提供します。

アプリケーション実行時に一時的にデータを保存するための ファイルとして利用することができます。
このクラスは、インスタンス化されるたびに、新しいファイルのパスを 作成します。そのパスは、インスタンス化の時点ではディスク上に ファイルとして存在していません。

このクラスは、インスタンス化のたびに新しいファイルのパスを作成するため、 作成したファイルを削除しない場合、ディスク上に不要ファイルとして 残りつづけてしまう可能性がありますので、使用の際には十分に注意してください。

導入されたバージョン:
version 4.2
関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
コンストラクタの概要
TemporaryFile()
一時ファイルのパスを作成します。
クラス jp.co.intra_mart.foundation.utility.file.ExtendedFile から継承したメソッド
append, append, append, getBytes, readLines, readLines, readString, readString, write, write, write
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

TemporaryFile

public TemporaryFile()
一時ファイルのパスを作成します。 このコンストラクタを呼び出した時点では、ファイルとして 存在していないため、インスタンス化の後に新規ファイルとして 作成する必要があります。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.smtp.Mail の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.smtp.Mail の使用

jp.co.intra_mart.foundation.smtp.Mail はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Mail (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.smtp
クラス Mail

java.lang.Object
    拡張 jp.co.intra_mart.system.mail.smtp.InetMail
        拡張 jp.co.intra_mart.foundation.smtp.Mail
すべての実装インタフェース:
jp.co.intra_mart.system.javascript.imapi.MailSendErrDef, Serializable
推奨されていません。 MailSenderに置き換えられました。

public class Mail
extends jp.co.intra_mart.system.mail.smtp.InetMail
implements jp.co.intra_mart.system.javascript.imapi.MailSendErrDef, Serializable

SMTPサーバに対し、メールを送信します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.system.mail.smtp.InetMail から継承したフィールド
MAILER_NAME
インタフェース jp.co.intra_mart.system.javascript.imapi.MailSendErrDef から継承したフィールド
ERR_MAIL_CONFIG, ERR_MAIL_CONNECT, ERR_MAIL_FROM, ERR_MAIL_SERVER, ERR_MAIL_TO, ERR_UNEXPECTED, MAIL_SENDED
コンストラクタの概要
Mail()
推奨されていません。 メール送信オブジェクトの生成。
Mail(String server)
推奨されていません。 メール送信オブジェクトの生成。
Mail(String server, int port)
推奨されていません。 メール送信オブジェクトの生成。
メソッドの概要
void | attachFile(String fName, String b64Body) 推奨されていません。 添付ファイルの内容をセットする。
int | getErrCode() 推奨されていません。 メール送信時のエラーコードを返す。
String | getErrMessage() 推奨されていません。 メール送信時のエラーメッセージを返す。
boolean | send() 推奨されていません。 指定されたSMTPサーバへメールを送信する。
boolean | setBcc(String bcc) 推奨されていません。 Bccをセットする。
boolean | setBcc(String bcc, String alias) 推奨されていません。 Bccをセットする。
boolean | setBody(String body) 推奨されていません。 本文をセットする。
boolean | setCc(String cc) 推奨されていません。 Ccをセットする。
boolean | setCc(String cc, String alias) 推奨されていません。 Ccをセットする。
boolean | setFrom(String from) 推奨されていません。 Fromをセットする。
boolean | setFrom(String from, String alias) 推奨されていません。 Fromをセットする。
boolean | setHeader(String key, String value) 推奨されていません。 メールヘッダを設定する。
boolean | setReplyTo(String replyto) 推奨されていません。 リプライをセットする。
boolean | setReplyTo(String replyto, String alias) 推奨されていません。 リプライをセットする。
boolean | setSubject(String subject) 推奨されていません。 タイトルをセットする。
boolean | setTo(String to) 推奨されていません。 To(宛先)をセットする。
boolean | setTo(String to, String alias) 推奨されていません。 To(宛先)をセットする。
クラス jp.co.intra_mart.system.mail.smtp.InetMail から継承したメソッド
addBcc, addCc, addFile, addReplyTo, addTo, getBody, getHead, removeBcc, removeCc, removeReplyTo, removeTo, sendMail, setAnyHeader, setMailerName
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Mail

public Mail(String server,
            int port)
推奨されていません。
メール送信オブジェクトの生成。

パラメータ:
server - SMTPサーバアドレス

Mail

public Mail(String server)
推奨されていません。
メール送信オブジェクトの生成。

パラメータ:
server - SMTPサーバアドレス
ポート番号は 25 を使用します。

Mail

public Mail()
推奨されていません。
メール送信オブジェクトの生成。 SMTPサーバは conf/imart.confで設定されたサーバ を使用します。

メソッドの詳細

getErrMessage

public String getErrMessage()
推奨されていません。
メール送信時のエラーメッセージを返す。

戻り値:
エラーメッセージ

getErrCode

public int getErrCode()
推奨されていません。
メール送信時のエラーコードを返す。

戻り値:
エラーコード

attachFile

public void attachFile(String fName,
                       String b64Body)
                throws UnsupportedEncodingException,
                       IOException
推奨されていません。
添付ファイルの内容をセットする。

パラメータ:
fName - ファイル名
b64Body - BASE64エンコードされたファイルの内容
戻り値:
成功 true/失敗 false
例外:
UnsupportedEncodingException,IOException
UnsupportedEncodingException
IOException

setHeader

public boolean setHeader(String key,
                         String value)
推奨されていません。
メールヘッダを設定する。

送信するメールヘッダ情報を設定する。 設定可能なメールヘッダの種類は以下の通り。
Sender : 送った人のメールアドレス
Reply-To: 返信先メールアドレス
(その他にも任意にヘッダ情報を追加できますが、任意のヘッダを追加した場合の動作は 未検証です。)

パラメータ:
key - 設定するメールヘッダの種類
value - メールヘッダへの情報
戻り値:
成功 true/失敗 false

setBody

public boolean setBody(String body)
推奨されていません。
本文をセットする。

パラメータ:
body - 本文文字列
戻り値:
成功 true/失敗 false

setFrom

public boolean setFrom(String from,
                       String alias)
推奨されていません。
Fromをセットする。

パラメータ:
from - 送信者アドレス
alias - 送信者ニックネーム
戻り値:
成功 true/失敗 false

setFrom

public boolean setFrom(String from)
推奨されていません。
Fromをセットする。

パラメータ:
from - 送信者アドレス
戻り値:
成功 true/失敗 false

setSubject

public boolean setSubject(String subject)
推奨されていません。
タイトルをセットする。

パラメータ:
subject - タイトル文字列
戻り値:
成功 true/失敗 false

setReplyTo

public boolean setReplyTo(String replyto,
                          String alias)
推奨されていません。
リプライをセットする。

パラメータ:
replyto - リプライアドレス文字列
alias - リプライニックネーム
戻り値:
成功 true/失敗 false

setReplyTo

public boolean setReplyTo(String replyto)
推奨されていません。
リプライをセットする。

パラメータ:
replyto - リプライアドレス文字列
戻り値:
成功 true/失敗 false

setBcc

public boolean setBcc(String bcc,
                      String alias)
推奨されていません。
Bccをセットする。

パラメータ:
bcc - Bccアドレス文字列
alias - Bccニックネーム
戻り値:
成功 true/失敗 false

setBcc

public boolean setBcc(String bcc)
推奨されていません。
Bccをセットする。

パラメータ:
bcc - Bccアドレス文字列
戻り値:
成功 true/失敗 false

setCc

public boolean setCc(String cc,
                     String alias)
推奨されていません。
Ccをセットする。

パラメータ:
cc - Ccアドレス文字列
alias - Ccニックネーム
戻り値:
成功 true/失敗 false

setCc

public boolean setCc(String cc)
推奨されていません。
Ccをセットする。

パラメータ:
cc - Ccアドレス文字列
戻り値:
成功 true/失敗 false

setTo

public boolean setTo(String to,
                     String alias)
推奨されていません。
To(宛先)をセットする。

パラメータ:
to - Toアドレス文字列
alias - Toニックネーム
戻り値:
成功 true/失敗 false

setTo

public boolean setTo(String to)
推奨されていません。
To(宛先)をセットする。

パラメータ:
to - Toアドレス文字列
戻り値:
成功 true/失敗 false

send

public boolean send()
推奨されていません。
指定されたSMTPサーバへメールを送信する。

他のメソッドで設定した情報をもとにメールを送信する。 最低限必要な設定は宛先と送信者（setTo(),setFrom()メソッドで設定）

戻り値:
成功 true/失敗 false
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.smtp (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.smtp
クラス
Mail


jp.co.intra_mart.foundation.smtp (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.smtp

メール連携モジュール。

参照:
説明

クラスの概要
Mail 推奨されていません。 MailSenderに置き換えられました。

パッケージ jp.co.intra_mart.foundation.smtp の説明

メール連携モジュール。 メール送信のためのAPI群。


jp.co.intra_mart.foundation.smtp クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.smtp の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.system.mail.smtp.InetMail (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.smtp.Mail (implements jp.co.intra_mart.system.javascript.imapi.MailSendErrDef, java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.smtp の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.smtp の使用

jp.co.intra_mart.foundation.smtp はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.update.StandardUpdateAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.update.StandardUpdateAccessor の使用

jp.co.intra_mart.foundation.update.StandardUpdateAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.update.UpdateAccessor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.update.UpdateAccessor の使用

UpdateAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.update

jp.co.intra_mart.foundation.update での UpdateAccessor の使用

UpdateAccessor を実装している jp.co.intra_mart.foundation.update のクラス
 class StandardUpdateAccessor
情報更新管理アクセッサ標準実装クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.update.UpdateManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.update.UpdateManager の使用

jp.co.intra_mart.foundation.update.UpdateManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.update (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.update
インタフェース
UpdateAccessor
クラス
StandardUpdateAccessor
UpdateManager


jp.co.intra_mart.foundation.update (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.update

インタフェースの概要
UpdateAccessor 情報更新管理アクセッサインタフェース。

クラスの概要
StandardUpdateAccessor | 情報更新管理アクセッサ標準実装クラス。
UpdateManager | 情報更新管理マネージャ。


jp.co.intra_mart.foundation.update クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.update の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.update.StandardUpdateAccessor (implements jp.co.intra_mart.foundation.update.UpdateAccessor)
    • class jp.co.intra_mart.foundation.update.UpdateManager

インタフェース階層

  • interface jp.co.intra_mart.foundation.update.UpdateAccessor


パッケージ jp.co.intra_mart.foundation.update の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.update の使用

jp.co.intra_mart.foundation.update を使用しているパッケージ
jp.co.intra_mart.foundation.update

jp.co.intra_mart.foundation.update により使用される jp.co.intra_mart.foundation.update のクラス
UpdateAccessor
情報更新管理アクセッサインタフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardUpdateAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.update
クラス StandardUpdateAccessor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.update.StandardUpdateAccessor
すべての実装インタフェース:
UpdateAccessor
public class StandardUpdateAccessor
extends Object
implements UpdateAccessor

情報更新管理アクセッサ標準実装クラス。

情報更新の情報をＤＢに対して操作するアクセッサ実装クラスです。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
StandardUpdateAccessor()
メソッドの概要
void | delete(String groupId, String key) キーを削除します。
void | deleteAll(String groupId) すべてのキーを削除します。
String[] | getKeys(String groupId) 保存されているキーの一覧を取得します。
void | insert(String groupId, String key, Date date) キーを取得します。
Date | select(String groupId, String key) 更新日付を取得します。
void | update(String groupId, String key, Date date) キーの更新日付を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardUpdateAccessor

public StandardUpdateAccessor()
メソッドの詳細

delete

public void delete(String groupId,
                   String key)
            throws FoundationException
キーを削除します。

定義:
インタフェース UpdateAccessor 内の delete
パラメータ:
groupId - ログイングループID
key - 削除するキー
例外:
FoundationException

deleteAll

public void deleteAll(String groupId)
               throws FoundationException
すべてのキーを削除します。

定義:
インタフェース UpdateAccessor 内の deleteAll
パラメータ:
groupId - ログイングループID
例外:
FoundationException

getKeys

public String[] getKeys(String groupId)
                 throws FoundationException
保存されているキーの一覧を取得します。

定義:
インタフェース UpdateAccessor 内の getKeys
パラメータ:
groupId - ログイングループID
戻り値:
キーの一覧
例外:
FoundationException

insert

public void insert(String groupId,
                   String key,
                   Date date)
            throws FoundationException
キーを取得します。

定義:
インタフェース UpdateAccessor 内の insert
パラメータ:
groupId - ログイングループID
key - 作成するキー
例外:
FoundationException

select

public Date select(String groupId,
                   String key)
            throws FoundationException
更新日付を取得します。

定義:
インタフェース UpdateAccessor 内の select
パラメータ:
groupId - ログイングループID
key - 対象となるキー
戻り値:
更新日付
キーが存在しない場合はnullを返却します。
例外:
FoundationException

update

public void update(String groupId,
                   String key,
                   Date date)
            throws FoundationException
キーの更新日付を更新します。

定義:
インタフェース UpdateAccessor 内の update
パラメータ:
groupId - ログイングループID
key - 更新するキー
例外:
FoundationException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UpdateAccessor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.update
インタフェース UpdateAccessor

既知の実装クラスの一覧:
StandardUpdateAccessor
public interface UpdateAccessor

情報更新管理アクセッサインタフェース。

情報更新の情報を操作するアクセッサインタフェースです。
UpdateManagerでこのインタフェースを利用して情報にアクセスしています。

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
void | delete(String groupId, String key) キーを削除します。
void | deleteAll(String groupId) すべてのキーを削除します。
String[] | getKeys(String groupId) 保存されているキーの一覧を取得します。
void | insert(String groupId, String key, Date date) キーを取得します。
Date | select(String groupId, String key) 更新日付を取得します。
void | update(String groupId, String key, Date date) キーの更新日付を更新します。

メソッドの詳細

delete

public void delete(String groupId,
                   String key)
            throws FoundationException
キーを削除します。

パラメータ:
groupId - ログイングループID
key - 削除するキー
例外:
FoundationException

deleteAll

public void deleteAll(String groupId)
               throws FoundationException
すべてのキーを削除します。

パラメータ:
groupId - ログイングループID
例外:
FoundationException

getKeys

public String[] getKeys(String groupId)
                 throws FoundationException
保存されているキーの一覧を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
キーの一覧
例外:
FoundationException

insert

public void insert(String groupId,
                   String key,
                   Date date)
            throws FoundationException
キーを取得します。

パラメータ:
groupId - ログイングループID
key - 作成するキー
例外:
FoundationException

select

public Date select(String groupId,
                   String key)
            throws FoundationException
更新日付を取得します。

パラメータ:
groupId - ログイングループID
key - 対象となるキー
戻り値:
更新日付
キーが存在しない場合はnullを返却します。
例外:
FoundationException

update

public void update(String groupId,
                   String key,
                   Date date)
            throws FoundationException
キーの更新日付を更新します。

パラメータ:
groupId - ログイングループID
key - 更新するキー
例外:
FoundationException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UpdateManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.update
クラス UpdateManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.update.UpdateManager
public class UpdateManager
extends Object

情報更新管理マネージャ。

マスタデータなどの最終更新操作の日付を管理します。
マスタデータをメモリ上でプールする場合、
マスタデータの更新と同時にmodifyメソッドを利用して、更新管理を行っておくことにより、
getLastModifiedメソッドを用いて効果的にメモリ上にプールされているデータを更新できます。 データの種類によってユニークな更新管理キーを用いて管理できます。

なお、更新管理キーが 'im_' から始まるキーは、システム用として予約されています。
上記のキーを用いての更新系API（modfiy,remove など)を使用しないでください。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
UpdateManager(String groupId)
コンストラクタ。
メソッドの概要
String | getGroupId() ログイングループIDを取得します。
String[] | getKeys() 保存されている更新管理キーの一覧を取得します。
Date | getLastModified(String key) 更新日付を取得します。
boolean | isUpDate(String key, Date now) 更新管理キーの更新日付が検証日付より新しいか検証します。
Date | modify(String key) 対象となる更新管理キーの更新日付を更新します。
void | remove(String key) 更新管理キーを削除します。
void | removeAll() すべての更新管理キーを削除します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UpdateManager

public UpdateManager(String groupId)
              throws FoundationException
コンストラクタ。

パラメータ:
groupId - ログイングループID。
例外:
FoundationException
メソッドの詳細

getKeys

public String[] getKeys()
                 throws FoundationException
保存されている更新管理キーの一覧を取得します。

戻り値:
更新管理キーの一覧
例外:
FoundationException

getLastModified

public Date getLastModified(String key)
                     throws FoundationException
更新日付を取得します。

パラメータ:
key - 対象となる更新管理キー
戻り値:
更新日付
更新管理キーが存在しない場合はnullを返却します。
例外:
FoundationException

isUpDate

public boolean isUpDate(String key,
                        Date now)
                 throws FoundationException
更新管理キーの更新日付が検証日付より新しいか検証します。

パラメータ:
key - 対象となる更新管理キー
now - 検証する日付
戻り値:
検証日付以降更新されていない：false
検証日付以降更新された：true
更新管理キーが存在しない場合： true
例外:
FoundationException

modify

public Date modify(String key)
            throws FoundationException
対象となる更新管理キーの更新日付を更新します。

更新日付にはこのメソッドが呼び出された時の日付が自動的に設定されます。
更新管理キーが存在しない場合は、新規に設定します。

パラメータ:
key - 対象となる更新管理キー
戻り値:
設定された更新日付
例外:
FoundationException

remove

public void remove(String key)
            throws FoundationException
更新管理キーを削除します。

パラメータ:
key - 削除対象の更新管理キー
例外:
FoundationException

removeAll

public void removeAll()
               throws FoundationException
すべての更新管理キーを削除します。

例外:
FoundationException

getGroupId

public String getGroupId()
ログイングループIDを取得します。

コンストラクタで指定したログイングループIDを返却します。

戻り値:
ログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter の使用

jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.charset.CharacterEncoder の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.charset.CharacterEncoder の使用

jp.co.intra_mart.foundation.utility.charset.CharacterEncoder はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.charset.ResourceFormatException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.charset.ResourceFormatException の使用

ResourceFormatException を使用しているパッケージ
jp.co.intra_mart.foundation.utility.charset このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.charset での ResourceFormatException の使用

ResourceFormatException をスローする jp.co.intra_mart.foundation.utility.charset のメソッド
protected void | CharacterEncoder.setCharacterEncoding(String enc) 推奨されていません。 このオブジェクトが対象とする文字エンコーディングを設定します。
static AdvancedOutputStreamWriter | AdvancedOutputStreamWriter.createWriter(OutputStreamWriter writer) 推奨されていません。 AdvancedOutputStreamWriter のスーパークラス AdvancedOutputStreamWriter を作成します。

ResourceFormatException をスローする jp.co.intra_mart.foundation.utility.charset のコンストラクタ
CharacterEncoder(String enc)
推奨されていません。 文字コード変換のためのエンコーダを作成します。
AdvancedOutputStreamWriter(OutputStream out, String charsetName)
推奨されていません。 指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out)
推奨されていません。 デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, Charset cs)
推奨されていません。 与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, CharsetEncoder enc)
推奨されていません。 与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter writer)
推奨されていません。 OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException の使用

ResourceNotFoundException を使用しているパッケージ
jp.co.intra_mart.foundation.utility.charset このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.charset での ResourceNotFoundException の使用

ResourceNotFoundException をスローする jp.co.intra_mart.foundation.utility.charset のメソッド
protected void | CharacterEncoder.setCharacterEncoding(String enc) 推奨されていません。 このオブジェクトが対象とする文字エンコーディングを設定します。
static AdvancedOutputStreamWriter | AdvancedOutputStreamWriter.createWriter(OutputStreamWriter writer) 推奨されていません。 AdvancedOutputStreamWriter のスーパークラス AdvancedOutputStreamWriter を作成します。

ResourceNotFoundException をスローする jp.co.intra_mart.foundation.utility.charset のコンストラクタ
CharacterEncoder(String enc)
推奨されていません。 文字コード変換のためのエンコーダを作成します。
AdvancedOutputStreamWriter(OutputStream out, String charsetName)
推奨されていません。 指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out)
推奨されていません。 デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, Charset cs)
推奨されていません。 与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, CharsetEncoder enc)
推奨されていません。 与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter writer)
推奨されていません。 OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AdvancedOutputStreamWriter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.charset
クラス AdvancedOutputStreamWriter

java.lang.Object
    拡張 java.io.Writer
        拡張 java.io.FilterWriter
            拡張 jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter クラスを使用してください。

public class AdvancedOutputStreamWriter
extends FilterWriter

このクラスは、基礎となる java.io.OutputStreamWriter をフィルタリングした Writer 機能を提供します。

通常、ASCII の範囲に含まれない文字は、java.io.OutputStreamWriter を 利用して相互に文字コード変換した場合、各文字エンコーディングの Unicode に対するマッピングの相違により、本来その文字エンコーディングにおいて 存在する文字であってもコード不明を意味する「?」に置き換えられてしまう ことがあります。 いわゆる、この文字化けに対して、文字コード変換前に、 対象となる文字エンコーディングに対する Unicode の正しい文字に 置換することで、いくつかの文字については正しく文字コード変換することが できます。
このクラスでは、この方式により文字化けを回避します。

文字化けに対する文字のマッピングおよび対応する文字エンコーディングに 関しては、CharacterEncoder クラスの仕様に準じます。

導入されたバージョン:
version4.3
関連項目:
jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter, jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException, jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException, CharacterEncoder

フィールドの概要
クラス java.io.FilterWriter から継承したフィールド
out
クラス java.io.Writer から継承したフィールド
lock
コンストラクタの概要
AdvancedOutputStreamWriter(OutputStream out)
推奨されていません。 デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, Charset cs)
推奨されていません。 与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, CharsetEncoder enc)
推奨されていません。 与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, String charsetName)
推奨されていません。 指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter writer)
推奨されていません。 OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。
メソッドの概要
static AdvancedOutputStreamWriter | createWriter(OutputStreamWriter writer) 推奨されていません。 AdvancedOutputStreamWriter のスーパークラス AdvancedOutputStreamWriter を作成します。
String | getCharacterEncoding() 推奨されていません。 このオブジェクトが対象としている文字エンコーディング名を返します。
OutputStreamWriter | getOutputStreamWriter() 推奨されていません。 このオブジェクトの基礎出力となっている java.io.OutputStreamWriter を返します。
void | write(char[] cbuf, int off, int len) 推奨されていません。 文字の配列の一部を書き込みます。
void | write(int c) 推奨されていません。 単一の文字を書き込みます。
void | write(String str, int off, int len) 推奨されていません。 文字列の一部を書き込みます。
クラス java.io.FilterWriter から継承したメソッド
close, flush
クラス java.io.Writer から継承したメソッド
write, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStream out,
                                  String charsetName)
                           throws UnsupportedEncodingException,
                                  ResourceNotFoundException,
                                  ResourceFormatException,
                                  IOException
推奨されていません。
指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。

パラメータ:
out - 基礎となる出力ストリーム
charsetName - サポートされる charset の名前
例外:
UnsupportedEncodingException - 指定された文字エンコーディングがサポートされていない場合
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
IOException - 設定の読み込みエラー
ResourceFormatException - 設定に不整合がある場合

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStream out)
                           throws ResourceFormatException,
                                  ResourceNotFoundException,
                                  IOException
推奨されていません。
デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。

パラメータ:
out - 基礎となる出力ストリーム
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
IOException - 設定の読み込みエラー
ResourceFormatException - 設定に不整合がある場合

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStream out,
                                  Charset cs)
                           throws IOException,
                                  ResourceFormatException,
                                  ResourceNotFoundException
推奨されていません。
与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。

パラメータ:
out - 基礎となる出力ストリーム
cs - サポートされる Charset
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
IOException - 入出力エラー
ResourceFormatException - 設定に不整合がある場合

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStream out,
                                  CharsetEncoder enc)
                           throws ResourceFormatException,
                                  IOException,
                                  ResourceNotFoundException
推奨されていません。
与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。

パラメータ:
out - 基礎となる出力ストリーム
enc - 文字エンコーディングエンコーダ
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
IOException - 設定の読み込みエラー
ResourceFormatException - 設定に不整合がある場合

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStreamWriter writer)
                           throws ResourceNotFoundException,
                                  IOException,
                                  ResourceFormatException
推奨されていません。
OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。

なお、このオブジェクトが対応する文字エンコーディングは、 java.io.OutputStreamWriter#getEncoding() の返す値によって 決定します。 java.io.OutputStreamWriter#getEncoding() が null を返す場合、 このコンストラクタは NUllPointerException をスローして オブジェクトの作成に失敗します。

パラメータ:
writer - 基本となるストリームを提供する java.io.OutputStreamWriter オブジェクト
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
ResourceFormatException - 設定に不整合がある場合
IOException - 設定の読み込みエラー
ResourceNotFoundException
ResourceFormatException
メソッドの詳細

createWriter

public static AdvancedOutputStreamWriter createWriter(OutputStreamWriter writer)
                                               throws IOException,
                                                      ResourceNotFoundException,
                                                      ResourceFormatException
推奨されていません。
AdvancedOutputStreamWriter のスーパークラス AdvancedOutputStreamWriter を作成します。

パラメータ:
writer -
戻り値:
jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter
例外:
IOException
ResourceNotFoundException
ResourceFormatException

getCharacterEncoding

public String getCharacterEncoding()
推奨されていません。
このオブジェクトが対象としている文字エンコーディング名を返します。

戻り値:
文字エンコーディング名

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
推奨されていません。
文字の配列の一部を書き込みます。

パラメータ:
cbuf - き込む文字のバッファ
off - 文字の読み込み開始オフセット
len - 書き込む文字数
例外:
IOException - 入出力エラーが発生した場合

write

public void write(int c)
           throws IOException
推奨されていません。
単一の文字を書き込みます。

パラメータ:
c - 書き込む文字を指定する int
例外:
IOException - 入出力エラーが発生した場合

write

public void write(String str,
                  int off,
                  int len)
           throws IOException
推奨されていません。
文字列の一部を書き込みます。

パラメータ:
str - 書き込まれる文字列
off - 文字の読み込み開始オフセット
len - 書き込む文字数
例外:
IOException - 入出力エラーが発生した場合

getOutputStreamWriter

public OutputStreamWriter getOutputStreamWriter()
推奨されていません。
このオブジェクトの基礎出力となっている java.io.OutputStreamWriter を返します。

戻り値:
基礎となっている java.io.OutputStreamWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CharacterEncoder (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.charset
クラス CharacterEncoder

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.charset.CharacterEncoder
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder クラスを使用してください。

public class CharacterEncoder
extends Object

このクラスは、文字エンコードの機能を提供します。

このクラスは、Java runtime が提供する通常の文字コード変換において 文字のマッピング定義の相違に起因して文字化けしてしまう現象を解決するための 一つの方法となります。 実際には、定義ファイルに設定されている文字をネイティブコードへ変換する前に 他の文字へ変更する事により、文字化けを防ぎます。

例えば、EUC_JP における文字「～」は、 Unicode へ変換した際 0x301C(Wave Dash) にマッピングされます。 これに対して、SJIS では文字「～」は、 Unicode の 0xFF5E(Fullwidth Tilde) にマッピングされています。 このため、相互に文字コード変換をすると、 文字「?」に置き換わると言う現象(いわゆる文字化け)が発生します。
このクラスでは、Unicode から SJIS へ変換する際に Unicode の文字 0x301C(Wave Dash) を 0xFF5E(Fullwidth Tilde) へ変更してから 文字コード変換を行います。

定義ファイルは、クラスローダを利用して検索および読み込まれます。 したがって、定義ファイルはクラスパスに設定されているディレクトリまたは アーカイブファイル内に配置する必要があります。
各文字エンコーディングと文字の変換テーブルの関連については、 定義ファイル jp/co/intra_mart/resources/charset/encoding/mapping.xml に記載されています。

導入されたバージョン:
version4.3
関連項目:
CharacterEncoder, ResourceNotFoundException, ResourceFormatException

コンストラクタの概要
CharacterEncoder(String enc)
推奨されていません。 文字コード変換のためのエンコーダを作成します。
メソッドの概要
byte[] | encode(char c) 推奨されていません。 指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。
byte[] | encode(char[] c) 推奨されていません。 指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。
byte[] | encode(String str) 推奨されていません。 指定の文字列を getCharacterEncoding() で表される文字コードへ エンコードします。
String | getCharacterEncoding() 推奨されていません。 このオブジェクトが対象としている文字エンコーディング名を返します。
String | newString(char[] c) 推奨されていません。 getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
String | newString(String str) 推奨されていません。 getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
protected void | setCharacterEncoding(String enc) 推奨されていません。 このオブジェクトが対象とする文字エンコーディングを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CharacterEncoder

public CharacterEncoder(String enc)
                 throws ResourceNotFoundException,
                        ResourceFormatException,
                        IOException
推奨されていません。
文字コード変換のためのエンコーダを作成します。

パラメータ:
enc - エンコーディング名
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 設定が見つからなかった場合
ResourceFormatException - 設定情報が不適切だった場合
IOException - 入出力エラー
メソッドの詳細

getCharacterEncoding

public String getCharacterEncoding()
推奨されていません。
このオブジェクトが対象としている文字エンコーディング名を返します。

戻り値:
文字エンコーディング名

setCharacterEncoding

protected void setCharacterEncoding(String enc)
                             throws ResourceFormatException,
                                    ResourceNotFoundException,
                                    IOException
推奨されていません。
このオブジェクトが対象とする文字エンコーディングを設定します。

パラメータ:
enc - エンコーディング名
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 設定が見つからなかった場合
ResourceFormatException - 設定情報が不適切だった場合
IOException - 入出力エラー

encode

public byte[] encode(char c)
              throws UnsupportedEncodingException,
                     IOException
推奨されていません。
指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。

パラメータ:
c - 文字
戻り値:
エンコードされたバイト列
例外:
UnsupportedEncodingException
IOException

encode

public byte[] encode(char[] c)
              throws UnsupportedEncodingException,
                     IOException
推奨されていません。
指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。

パラメータ:
c - 文字配列
戻り値:
エンコードされたバイト列
例外:
UnsupportedEncodingException
IOException

encode

public byte[] encode(String str)
              throws UnsupportedEncodingException,
                     IOException
推奨されていません。
指定の文字列を getCharacterEncoding() で表される文字コードへ エンコードします。

パラメータ:
str - 文字列
戻り値:
エンコードされたバイト列
例外:
UnsupportedEncodingException
IOException

newString

public String newString(String str)
推奨されていません。
getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。

返される文字列は、引数 str のマッピングを修正した 新しい文字列です。

パラメータ:
str - 文字列
戻り値:
マッピングを修正された新しい文字列

newString

public String newString(char[] c)
推奨されていません。
getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。

返される文字列は、引数 c のマッピングを修正した 新しい文字列です。
引数の配列 c は変化しません。

パラメータ:
c - 文字配列
戻り値:
新しい文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.utility.charset (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.utility.charset
クラス
AdvancedOutputStreamWriter
CharacterEncoder
例外
ResourceFormatException
ResourceNotFoundException


jp.co.intra_mart.foundation.utility.charset (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.charset

このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

参照:
説明

クラスの概要
AdvancedOutputStreamWriter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter クラスを使用してください。
CharacterEncoder | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder クラスを使用してください。

例外の概要
ResourceFormatException | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException クラスを使用してください。
ResourceNotFoundException | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException クラスを使用してください。

パッケージ jp.co.intra_mart.foundation.utility.charset の説明

このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。


jp.co.intra_mart.foundation.utility.charset クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.charset の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException
          • class jp.co.intra_mart.foundation.utility.charset.ResourceFormatException
        • class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException
          • class jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException
    • class java.io.Writer
      • class java.io.FilterWriter
        • class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter


パッケージ jp.co.intra_mart.foundation.utility.charset の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.utility.charset の使用

jp.co.intra_mart.foundation.utility.charset を使用しているパッケージ
jp.co.intra_mart.foundation.utility.charset このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.charset により使用される jp.co.intra_mart.foundation.utility.charset のクラス
ResourceFormatException
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException クラスを使用してください。
ResourceNotFoundException
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ResourceFormatException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.charset
クラス ResourceFormatException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException
                拡張 jp.co.intra_mart.foundation.utility.charset.ResourceFormatException
すべての実装インタフェース:
Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException クラスを使用してください。

public class ResourceFormatException
extends ResourceFormatException

リソースの内容が不適切であることを通知する例外です。

設定の内容に誤りがあるか、または定義の書式が正しくない場合にスローされます。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
ResourceFormatException(String msg)
推奨されていません。 指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceFormatException(String msg, Throwable cause)
推奨されていません。 指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ResourceFormatException

public ResourceFormatException(String msg)
推奨されていません。
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

ResourceFormatException

public ResourceFormatException(String msg,
                               Throwable cause)
推奨されていません。
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ResourceNotFoundException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.charset
クラス ResourceNotFoundException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException
                拡張 jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException
すべての実装インタフェース:
Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException クラスを使用してください。

public class ResourceNotFoundException
extends ResourceNotFoundException

リソースがないことを通知する例外です。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
ResourceNotFoundException(String msg)
推奨されていません。 指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceNotFoundException(String msg, Throwable cause)
推奨されていません。 指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ResourceNotFoundException

public ResourceNotFoundException(String msg)
推奨されていません。
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

ResourceNotFoundException

public ResourceNotFoundException(String msg,
                                 Throwable cause)
推奨されていません。
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.utility.AbstractDualComparator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.AbstractDualComparator の使用

AbstractDualComparator を使用しているパッケージ
jp.co.intra_mart.foundation.page | ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.utility | このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.page での AbstractDualComparator の使用

jp.co.intra_mart.foundation.page での AbstractDualComparator のサブクラス
 class NodeTypeComparator
ツリービューのノードを種類順にソートするためのコンパレータです。

jp.co.intra_mart.foundation.utility での AbstractDualComparator の使用

jp.co.intra_mart.foundation.utility での AbstractDualComparator のサブクラス
 class MultiComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.Counter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.Counter の使用

jp.co.intra_mart.foundation.utility.Counter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.DualComparator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.DualComparator の使用

jp.co.intra_mart.foundation.utility.DualComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.ErrorEvent の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.ErrorEvent の使用

ErrorEvent を使用しているパッケージ
jp.co.intra_mart.foundation.utility このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility での ErrorEvent の使用

ErrorEvent 型のパラメータを持つ jp.co.intra_mart.foundation.utility のメソッド
 void ErrorEventListener.reportError(ErrorEvent err)
推奨されていません。 発生した例外を通知します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.ErrorEventListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.ErrorEventListener の使用

ErrorEventListener を使用しているパッケージ
jp.co.intra_mart.foundation.utility.io このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.io での ErrorEventListener の使用

ErrorEventListener 型のパラメータを持つ jp.co.intra_mart.foundation.utility.io のコンストラクタ
ExtendedOutputStream(OutputStream out, ErrorEventListener listener)
推奨されていません。 出力ストリームを構築します。
ExtendedInputStream(InputStream in, ErrorEventListener listener)
推奨されていません。 入力ストリームを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.EventListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.EventListener の使用

EventListener を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.utility | このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.service.provider での EventListener の使用

EventListener 型のパラメータを持つ jp.co.intra_mart.foundation.service.provider のメソッド
static void | GarbageController.addListener(EventListener listener) リスナーを登録します。
static boolean | GarbageController.removeListener(EventListener listener) 指定されたリスナーを削除します。

jp.co.intra_mart.foundation.utility での EventListener の使用

EventListener 型のパラメータを持つ jp.co.intra_mart.foundation.utility のメソッド
 void EventQueueController.entry(EventListener listener)
推奨されていません。 イベントリスナーの登録。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.EventQueueController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.EventQueueController の使用

EventQueueController を使用しているパッケージ
jp.co.intra_mart.foundation.utility.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.report での EventQueueController の使用

EventQueueController 型のパラメータを持つ jp.co.intra_mart.foundation.utility.report のコンストラクタ
RepresentativeReporter(MessageReporter out, EventQueueController queue)
推奨されていません。 指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.ExtendedThread の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.ExtendedThread の使用

jp.co.intra_mart.foundation.utility.ExtendedThread はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.FilterComparator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.FilterComparator の使用

FilterComparator を使用しているパッケージ
jp.co.intra_mart.foundation.utility このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility での FilterComparator の使用

jp.co.intra_mart.foundation.utility での FilterComparator のサブクラス
 class ReverseComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.FixedSizeMap の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.FixedSizeMap の使用

jp.co.intra_mart.foundation.utility.FixedSizeMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.LockMonitor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.LockMonitor の使用

jp.co.intra_mart.foundation.utility.LockMonitor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.MultiComparator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.MultiComparator の使用

jp.co.intra_mart.foundation.utility.MultiComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions の使用

MultipurposeInternetMailExtensions を使用しているパッケージ
jp.co.intra_mart.foundation.http ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.http での MultipurposeInternetMailExtensions の使用

MultipurposeInternetMailExtensions 型のパラメータを持つ jp.co.intra_mart.foundation.http のコンストラクタ
FileSender(HttpServletResponse httpResponse, MultipurposeInternetMailExtensions mimeType)
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSender(HttpServletResponse httpResponse, MultipurposeInternetMailExtensions mimeType, String filename)
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.ResourceBundleProperties の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.ResourceBundleProperties の使用

jp.co.intra_mart.foundation.utility.ResourceBundleProperties はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.ReverseComparator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.ReverseComparator の使用

jp.co.intra_mart.foundation.utility.ReverseComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.SequenceComparator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.SequenceComparator の使用

jp.co.intra_mart.foundation.utility.SequenceComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.ThreadStopListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.ThreadStopListener の使用

ThreadStopListener を使用しているパッケージ
jp.co.intra_mart.foundation.utility このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility での ThreadStopListener の使用

ThreadStopListener 型のパラメータを持つ jp.co.intra_mart.foundation.utility のメソッド
 void ExtendedThread.addThreadStopListener(ThreadStopListener listener)
推奨されていません。 このスレッドが終了したときに呼び出されるイベントリスナーを登録します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.file.Directory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.file.Directory の使用

Directory を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.service.provider.file | このパッケージには、Storage Service 環境内で利用可能な機能を提供します。
jp.co.intra_mart.foundation.service.provider.information | このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。
jp.co.intra_mart.foundation.utility.file | このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

jp.co.intra_mart.foundation.service.provider での Directory の使用

jp.co.intra_mart.foundation.service.provider での Directory のサブクラス
 class TemporaryDirectory
このクラスは、一時ファイル保存用ディレクトリに関する機能を 提供します。

jp.co.intra_mart.foundation.service.provider.file での Directory の使用

jp.co.intra_mart.foundation.service.provider.file での Directory のサブクラス
 class StorageDirectory
Storage Service の基準ディレクトリを表すクラスです。

jp.co.intra_mart.foundation.service.provider.information での Directory の使用

jp.co.intra_mart.foundation.service.provider.information での Directory のサブクラス
 class PermanentDataDirectory
Permanent-data を保存するディレクトリを表すオブジェクトです。

jp.co.intra_mart.foundation.utility.file での Directory の使用

jp.co.intra_mart.foundation.utility.file での Directory のサブクラス
 class ExtendedDirectory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.file.ExtendedDirectory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.file.ExtendedDirectory の使用

ExtendedDirectory を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.service.provider.file | このパッケージには、Storage Service 環境内で利用可能な機能を提供します。
jp.co.intra_mart.foundation.service.provider.information | このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。
jp.co.intra_mart.foundation.utility.file | このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

jp.co.intra_mart.foundation.service.provider での ExtendedDirectory の使用

jp.co.intra_mart.foundation.service.provider での ExtendedDirectory のサブクラス
 class TemporaryDirectory
このクラスは、一時ファイル保存用ディレクトリに関する機能を 提供します。

jp.co.intra_mart.foundation.service.provider.file での ExtendedDirectory の使用

jp.co.intra_mart.foundation.service.provider.file での ExtendedDirectory のサブクラス
 class StorageDirectory
Storage Service の基準ディレクトリを表すクラスです。

jp.co.intra_mart.foundation.service.provider.information での ExtendedDirectory の使用

jp.co.intra_mart.foundation.service.provider.information での ExtendedDirectory のサブクラス
 class PermanentDataDirectory
Permanent-data を保存するディレクトリを表すオブジェクトです。

ExtendedDirectory を返す jp.co.intra_mart.foundation.service.provider.information のメソッド
ExtendedDirectory | PermanentDataDirectory.entityDirectory() データファイルを保存しておくための ディレクトリを表すオブジェクトを取得します。
ExtendedDirectory | PermanentDataDirectory.temporaryDirectory() 削除対象のデータファイルを一時的に保存しておくための ディレクトリを表すオブジェクトを取得します。

jp.co.intra_mart.foundation.utility.file での ExtendedDirectory の使用

ExtendedDirectory を返す jp.co.intra_mart.foundation.utility.file のメソッド
ExtendedDirectory | ExtendedDirectory.childDirectory(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
protected ExtendedDirectory | ExtendedDirectory.findDirectory(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.file.ExtendedFile の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.file.ExtendedFile の使用

ExtendedFile を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.utility.file | このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

jp.co.intra_mart.foundation.service.provider での ExtendedFile の使用

jp.co.intra_mart.foundation.service.provider での ExtendedFile のサブクラス
 class TemporaryFile
このクラスは、一時ファイルに関する機能を提供します。

jp.co.intra_mart.foundation.utility.file での ExtendedFile の使用

ExtendedFile を返す jp.co.intra_mart.foundation.utility.file のメソッド
ExtendedFile | ExtendedDirectory.childFile(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
protected ExtendedFile | ExtendedDirectory.findFile(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Directory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.file
クラス Directory

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.foundation.utility.file.Directory
すべての実装インタフェース:
Comparable, Serializable
直系の既知のサブクラス:
ExtendedDirectory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。

public class Directory
extends File

このクラスは、ディレクトリを扱う時に便利な機能を提供します。

このクラスは java.io.File クラスをベースに、オブジェクトが表す抽象パスが ディレクトリである場合に利用することができます。

関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
コンストラクタの概要
Directory(File parent, String child)
推奨されていません。 親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
Directory(String pathname)
推奨されていません。 指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
Directory(String parent, String child)
推奨されていません。 親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
メソッドの概要
Collection | childDirectories() 推奨されていません。 この抽象パス名が示すディレクトリにあるサブディレクトリの抽象パスを 繰り返し処理する反復子を作成します。
Collection | childFiles() 推奨されていません。 この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
Collection | files(int depth) 推奨されていません。 この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
Collection | paths(int depth) 推奨されていません。 この抽象パス名が示すディレクトリにあるファイルおよびディレクトリの 抽象パスを繰り返し処理する反復子を作成します。
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Directory

public Directory(String pathname)
推奨されていません。
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。 指定された文字列が空の文字列の場合、結果は空の抽象パス名になります。

パラメータ:
pathname - パス名文字列
例外:
NullPointerException - pathname 引数が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合
関連項目:
File.File(File, String)

Directory

public Directory(File parent,
                 String child)
推奨されていません。
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。

parent が null の場合、新しい File のインスタンスは、 指定された child パス名文字列で単一引数の File コンストラクタを 呼び出したように生成されます。

そうでない場合、parent 抽象パス名はディレクトリを示し、 child パス名文字列はディレクトリまたはファイルを示します。 child パス名文字列が絶対の場合、 それはシステムに依存する方法で相対パス名に変換されます。 parent が空の抽象パス名の場合、新しい File のインスタンスは、 child を抽象パス名に変換し、その結果をシステムに依存する デフォルトディレクトリを基準に解決することで生成されます。 そうでない場合、各パス名文字列は抽象パス名に変換され、 子抽象パス名は親を基準に解決されます。

パラメータ:
parent - 親抽象パス名
child - 子パス名文字列
例外:
NullPointerException - child が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合
関連項目:
File.File(File, String)

Directory

public Directory(String parent,
                 String child)
推奨されていません。
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。

parent が null の場合、新しい File のインスタンスは、 指定された child パス名文字列で単一引数の File コンストラクタを 呼び出したように生成されます。 そうでない場合、parent パス名文字列はディレクトリを示し、 child パス名文字列はディレクトリまたはファイルを示します。 child パス名文字列が絶対の場合、 それはシステムに依存する方法で相対パス名に変換されます。 parent が空の文字列の場合、新しい File のインスタンスは、 child を抽象パス名に変換し、 その結果をシステムに依存するデフォルトディレクトリを基準に 解決することで生成されます。 そうでない場合、各パス名文字列は抽象パス名に変換され、 子抽象パス名は親を基準に解決されます。

パラメータ:
parent - 親パス名文字列
child - 子パス名文字列
例外:
NullPointerException - child が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合
関連項目:
File.File(File, String)
メソッドの詳細

childDirectories

public Collection childDirectories()
推奨されていません。
この抽象パス名が示すディレクトリにあるサブディレクトリの抽象パスを 繰り返し処理する反復子を作成します。 反復子が返す各要素は、ディレクトリを表す java.io.File クラスのインスタンスです。

戻り値:
ディレクトリパスを繰り返し処理する反復子

childFiles

public Collection childFiles()
推奨されていません。
この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。 反復子が返す各要素は、ファイルを表す java.io.File クラスのインスタンスです。

戻り値:
ファイルパスを繰り返し処理する反復子

paths

public Collection paths(int depth)
推奨されていません。
この抽象パス名が示すディレクトリにあるファイルおよびディレクトリの 抽象パスを繰り返し処理する反復子を作成します。 反復子が返す各要素は、ファイルまたはディレクトリを表す java.io.File クラスのインスタンスです。

パラメータ:
depth - 検索をするサブディレクトリの深さ
戻り値:
ファイルパスを繰り返し処理する反復子
例外:
IllegalArgumentException - depth 引数が 1 よりも小さい場合

files

public Collection files(int depth)
推奨されていません。
この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。 反復子が返す各要素は、ファイルを表す java.io.File クラスのインスタンスです。

パラメータ:
depth - 検索をするサブディレクトリの深さ
戻り値:
ファイルパスを繰り返し処理する反復子
例外:
IllegalArgumentException - depth 引数が 1 よりも小さい場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedDirectory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.file
クラス ExtendedDirectory

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.foundation.utility.file.Directory
            拡張 jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
すべての実装インタフェース:
Comparable, Serializable
直系の既知のサブクラス:
PermanentDataDirectory, StorageDirectory, TemporaryDirectory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。

public class ExtendedDirectory
extends Directory

File インスタンスを作成するためのファクトリクラスです。

このクラスは、指定のディレクトリを親とすして、相対パスにより解決される 抽象パスを表す File インスタンスを生成する機能を提供します。 生成された File インスタンスは、オブジェクト内にプールされるため、 同じパスを繰り返し利用ようなプログラムで利用することにより、 メモリリソースを節約することができます。

関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
コンストラクタの概要
ExtendedDirectory(File parent, String path, int size)
推奨されていません。 File オブジェクトを作成するためのファクトリオブジェクトを作成します。
ExtendedDirectory(String pathname, int size)
推奨されていません。 File オブジェクトを作成するためのファクトリオブジェクトを作成します。
メソッドの概要
void | archive(File f) 推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
void | archive(File f, FileFilter filter) 推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
void | archive(OutputStream out) 推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
void | archive(OutputStream out, FileFilter filter) 推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
void | archive(ZipOutputStream out) 推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
void | archive(ZipOutputStream out, FileFilter filter) 推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
ExtendedDirectory | childDirectory(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
ExtendedFile | childFile(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
File | childPath(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
protected ExtendedDirectory | findDirectory(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
protected ExtendedFile | findFile(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
protected File | findPath(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
void | reset() 推奨されていません。 キャッシュ領域をクリアします。
クラス jp.co.intra_mart.foundation.utility.file.Directory から継承したメソッド
childDirectories, childFiles, files, paths
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtendedDirectory

public ExtendedDirectory(String pathname,
                         int size)
推奨されていません。
File オブジェクトを作成するためのファクトリオブジェクトを作成します。

このオブジェクトは、File インスタンスのプール機能を実装しています。 引数 size はプールのサイズを指定して下さい。プールは、最大で size 個のインスタンスをキャッシュするように動作します。

パラメータ:
pathname - ディレクトリパス
size - キャッシュサイズ
例外:
NullPointerException - 引数 parent が null の場合
IllegalArgumentException - 引数 size が 1 よりも小さい場合

ExtendedDirectory

public ExtendedDirectory(File parent,
                         String path,
                         int size)
推奨されていません。
File オブジェクトを作成するためのファクトリオブジェクトを作成します。

このオブジェクトは、File インスタンスのプール機能を実装しています。 このオブジェクトのパスは、parent を親ディレクトリとした 子抽象パス path により解決されます。
引数 size はプールのサイズを指定して下さい。プールは、最大で size 個のインスタンスをキャッシュするように動作します。

パラメータ:
parent - 親ディレクトリ
path - パス
size - キャッシュサイズ
例外:
NullPointerException - 引数 parent が null の場合
IllegalArgumentException - 引数 size が 1 よりも小さい場合
メソッドの詳細

childFile

public ExtendedFile childFile(String path)
推奨されていません。
このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合

findFile

protected ExtendedFile findFile(String path)
推奨されていません。
このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。

このメソッドは、childFile メソッドが要求されたファイルオブジェクトを プールしていなかった場合に、新しいファイルオブジェクトを作成するために 呼び出します。 サブクラスは、このメソッドをオーバーライドすることにより、 ファイルインスタンスを任意に作成することができます。

このメソッドは、単純にこのオブジェクトを親ディレクトリとして 引数 path を解決したファイルオブジェクトを作成して返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合

childDirectory

public ExtendedDirectory childDirectory(String path)
推奨されていません。
このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。 このメソッドは、このオブジェクトのプール許容値と等しい プール許容値を持つ ExtendedDirectory のインスタンスを返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合

findDirectory

protected ExtendedDirectory findDirectory(String path)
推奨されていません。
このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。

このメソッドは、childDirectory メソッドが要求されたファイルオブジェクトを プールしていなかった場合に、新しいファイルオブジェクトを作成するために 呼び出します。 サブクラスは、このメソッドをオーバーライドすることにより、 ファイルインスタンスを任意に作成することができます。

このメソッドは、単純にこのオブジェクトを親ディレクトリとして 引数 path を解決したファイルオブジェクトを作成して返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合

childPath

public File childPath(String path)
推奨されていません。
このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合

findPath

protected File findPath(String path)
推奨されていません。
このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。

このメソッドは、childPath メソッドが要求されたファイルオブジェクトを プールしていなかった場合に、新しいファイルオブジェクトを作成するために 呼び出します。 サブクラスは、このメソッドをオーバーライドすることにより、 ファイルインスタンスを任意に作成することができます。

このメソッドは、単純にこのオブジェクトを親ディレクトリとして 引数 path を解決したファイルオブジェクトを作成して返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合

reset

public void reset()
推奨されていません。
キャッシュ領域をクリアします。

archive

public void archive(File f)
             throws IOException
推奨されていません。
このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。 作成されるファイルは、ZIP ファイル形式となります。

パラメータ:
f - 出力ファイルパス
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(File f,
                    FileFilter filter)
             throws IOException
推奨されていません。
このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。 作成されるファイルは、ZIP ファイル形式となります。 ファイルに出力されるファイルは、フィルタの基準を満たす必要があります。 圧縮されるファイルは、 FileFilter.accept(java.io.File) メソッドが呼び出されたときに true が返される場合だけです。

パラメータ:
f - 出力ファイルパス
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(OutputStream out)
             throws IOException
推奨されていません。
このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。

パラメータ:
out - 出力ストリーム
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(OutputStream out,
                    FileFilter filter)
             throws IOException
推奨されていません。
このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。 ストリームに出力されるファイルは、フィルタの基準を満たす必要があります。 ストリームにファイルの内容が出力されるのは、 FileFilter.accept(java.io.File) メソッドが呼び出されたときに true が返される場合だけです。

パラメータ:
out - 出力ストリーム
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(ZipOutputStream out)
             throws IOException
推奨されていません。
このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。

パラメータ:
out - 出力ストリーム
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(ZipOutputStream out,
                    FileFilter filter)
             throws IOException
推奨されていません。
このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。 ストリームに出力されるファイルは、フィルタの基準を満たす必要があります。 ストリームにファイルの内容が出力されるのは、 FileFilter.accept(java.io.File) メソッドが呼び出されたときに true が返される場合だけです。

パラメータ:
out - 出力ストリーム
filter - ファイル名フィルタ
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedFile (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.file
クラス ExtendedFile

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.foundation.utility.file.ExtendedFile
すべての実装インタフェース:
Comparable, Serializable
直系の既知のサブクラス:
TemporaryFile
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile クラスを使用してください。

public class ExtendedFile
extends File

このクラスは、ファイルを扱う時に便利な機能を提供します。

このクラスは java.io.File クラスをベースに、オブジェクトが表す抽象パスが ファイルである場合に利用することができます。

関連項目:
File, ExtendedDirectory, 直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
コンストラクタの概要
ExtendedFile(File parent, String child)
推奨されていません。 親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
ExtendedFile(String pathname)
推奨されていません。 指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
ExtendedFile(String parent, String child)
推奨されていません。 親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
メソッドの概要
void | append(byte[] b) 推奨されていません。 指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
void | append(String str) 推奨されていません。 デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
void | append(String str, String enc) 推奨されていません。 指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
byte[] | getBytes() 推奨されていません。 この抽象パスが表すファイルからデータを読み込みます。
Iterator | readLines() 推奨されていません。 ファイルの行を繰り返し処理する反復子を作成します。
Iterator | readLines(String enc) 推奨されていません。 ファイルの行を繰り返し処理する反復子を作成します。
String | readString() 推奨されていません。 このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
String | readString(String enc) 推奨されていません。 このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
void | write(byte[] b) 推奨されていません。 指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
void | write(String str) 推奨されていません。 デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
void | write(String str, String enc) 推奨されていません。 指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtendedFile

public ExtendedFile(String pathname)
推奨されていません。
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。 指定された文字列が空の文字列の場合、結果は空の抽象パス名になります。

パラメータ:
pathname - パス名文字列
例外:
NullPointerException - pathname 引数が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合
関連項目:
File.File(File, String)

ExtendedFile

public ExtendedFile(File parent,
                    String child)
推奨されていません。
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。

parent が null の場合、新しい File のインスタンスは、 指定された child パス名文字列で単一引数の File コンストラクタを 呼び出したように生成されます。

そうでない場合、parent 抽象パス名はディレクトリを示し、 child パス名文字列はディレクトリまたはファイルを示します。 child パス名文字列が絶対の場合、 それはシステムに依存する方法で相対パス名に変換されます。 parent が空の抽象パス名の場合、新しい File のインスタンスは、 child を抽象パス名に変換し、その結果をシステムに依存する デフォルトディレクトリを基準に解決することで生成されます。 そうでない場合、各パス名文字列は抽象パス名に変換され、 子抽象パス名は親を基準に解決されます。

パラメータ:
parent - 親抽象パス名
child - 子パス名文字列
例外:
NullPointerException - child が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合
関連項目:
File.File(File, String)

ExtendedFile

public ExtendedFile(String parent,
                    String child)
推奨されていません。
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。

parent が null の場合、新しい File のインスタンスは、 指定された child パス名文字列で単一引数の File コンストラクタを 呼び出したように生成されます。 そうでない場合、parent パス名文字列はディレクトリを示し、 child パス名文字列はディレクトリまたはファイルを示します。 child パス名文字列が絶対の場合、 それはシステムに依存する方法で相対パス名に変換されます。 parent が空の文字列の場合、新しい File のインスタンスは、 child を抽象パス名に変換し、 その結果をシステムに依存するデフォルトディレクトリを基準に 解決することで生成されます。 そうでない場合、各パス名文字列は抽象パス名に変換され、 子抽象パス名は親を基準に解決されます。

パラメータ:
parent - 親パス名文字列
child - 子パス名文字列
例外:
NullPointerException - child が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合
関連項目:
File.File(File, String)
メソッドの詳細

getBytes

public byte[] getBytes()
                throws FileNotFoundException,
                       IOException
推奨されていません。
この抽象パスが表すファイルからデータを読み込みます。

戻り値:
ファイルの内容
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
IOException - 入出力エラーが発生した場合

readString

public String readString()
                  throws FileNotFoundException,
                         IOException
推奨されていません。
このオブジェクトの抽象パスが表すファイルからデータを読み込みます。

データはテキストとして扱い、デフォルトの文字エンコーディングから Unicode に変換して返します。

戻り値:
ファイルのデータ
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
IOException - 入出力エラーが発生した場合

readString

public String readString(String enc)
                  throws FileNotFoundException,
                         UnsupportedEncodingException,
                         IOException
推奨されていません。
このオブジェクトの抽象パスが表すファイルからデータを読み込みます。

データはテキストとして扱い、指定の文字エンコーディングから Unicode に変換して返します。

パラメータ:
enc - 文字エンコーディング名
戻り値:
ファイルのデータ
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
UnsupportedEncodingException - 指定の文字のエンコーディングがサポートされていない場合
IOException - 入出力エラーが発生した場合

readLines

public Iterator readLines()
                   throws FileNotFoundException,
                          IOException
推奨されていません。
ファイルの行を繰り返し処理する反復子を作成します。

データはテキストとして扱い、デフォルトの文字エンコーディングを使って Unicode に変換されます。 反復子が返す各要素は、ファイル内の 1 行のテキストです。 1 つの行は、改行 ('\n')、復帰 ('\r')、 または復帰とその直後に続く改行のどれかにより終了したと見なされます。

戻り値:
ファイルの行を繰り返し処理する反復子
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
IOException - 入出力エラーが発生した場合

readLines

public Iterator readLines(String enc)
                   throws FileNotFoundException,
                          UnsupportedEncodingException,
                          IOException
推奨されていません。
ファイルの行を繰り返し処理する反復子を作成します。

データはテキストとして扱い、指定の文字エンコーディングを使って Unicode に変換されます。 反復子が返す各要素は、ファイル内の 1 行のテキストです。 1 つの行は、改行 ('\n')、復帰 ('\r')、 または復帰とその直後に続く改行のどれかにより終了したと見なされます。

パラメータ:
enc - 文字エンコーディング名
戻り値:
ファイルの行を繰り返し処理する反復子
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
UnsupportedEncodingException - 指定の文字のエンコーディングがサポートされていない場合
IOException - 入出力エラーが発生した場合

write

public void write(String str)
           throws IOException
推奨されていません。
デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。

パラメータ:
str - 書き込む文字列
例外:
IOException - 入出力エラーが発生した場合

write

public void write(String str,
                  String enc)
           throws UnsupportedEncodingException,
                  IOException
推奨されていません。
指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。

パラメータ:
str - 書き込む文字列
enc - 使用するエンコーディングの名前
例外:
UnsupportedEncodingException - 指定の文字のエンコーディングがサポートされていない場合
IOException - 入出力エラーが発生した場合

append

public void append(String str)
            throws IOException
推奨されていません。
デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。

文字列は、ファイルの先頭ではなくファイルの最後に書き込まれます。 したがって、すでに存在するファイルに対して文字列を追記する場合に、 このメソッドを利用します。 このメソッドは、ファイルが存在しなかった場合、新しくファイルを 作成して文字列をファイルの先頭に書き込みます。

パラメータ:
str - 書き込む文字列
例外:
IOException - 入出力エラーが発生した場合

append

public void append(String str,
                   String enc)
            throws UnsupportedEncodingException,
                   IOException
推奨されていません。
指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。

文字列は、ファイルの先頭ではなくファイルの最後に書き込まれます。 したがって、すでに存在するファイルに対して文字列を追記する場合に、 このメソッドを利用します。 このメソッドは、ファイルが存在しなかった場合、新しくファイルを 作成して文字列をファイルの先頭に書き込みます。

パラメータ:
str - 書き込む文字列
enc - 使用するエンコーディングの名前
例外:
UnsupportedEncodingException - 指定の文字のエンコーディングがサポートされていない場合
IOException - 入出力エラーが発生した場合

append

public void append(byte[] b)
            throws IOException
推奨されていません。
指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。

バイトは、ファイルの先頭ではなくファイルの最後に書き込まれます。 したがって、すでに存在するファイルに対してバイトを追記する場合に、 このメソッドを利用します。 このメソッドは、ファイルが存在しなかった場合、新しくファイルを 作成してバイトをファイルの先頭に書き込みます。

パラメータ:
b - データ
例外:
IOException - 入出力エラーが発生した場合

write

public void write(byte[] b)
           throws IOException
推奨されていません。
指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。

パラメータ:
b - データ
例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.utility.file (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.utility.file
クラス
Directory
ExtendedDirectory
ExtendedFile


jp.co.intra_mart.foundation.utility.file (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.file

このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

参照:
説明

クラスの概要
Directory | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。
ExtendedDirectory | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。
ExtendedFile | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile クラスを使用してください。

パッケージ jp.co.intra_mart.foundation.utility.file の説明

このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。


jp.co.intra_mart.foundation.utility.file クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.file の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.io.File (implements java.lang.Comparable, java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.file.Directory
        • class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
      • class jp.co.intra_mart.foundation.utility.file.ExtendedFile


パッケージ jp.co.intra_mart.foundation.utility.file の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.utility.file の使用

jp.co.intra_mart.foundation.utility.file を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.service.provider.file | このパッケージには、Storage Service 環境内で利用可能な機能を提供します。
jp.co.intra_mart.foundation.service.provider.information | このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。
jp.co.intra_mart.foundation.utility.file | このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

jp.co.intra_mart.foundation.service.provider により使用される jp.co.intra_mart.foundation.utility.file のクラス
Directory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。
ExtendedDirectory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。
ExtendedFile
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile クラスを使用してください。

jp.co.intra_mart.foundation.service.provider.file により使用される jp.co.intra_mart.foundation.utility.file のクラス
Directory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。
ExtendedDirectory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。

jp.co.intra_mart.foundation.service.provider.information により使用される jp.co.intra_mart.foundation.utility.file のクラス
Directory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。
ExtendedDirectory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。

jp.co.intra_mart.foundation.utility.file により使用される jp.co.intra_mart.foundation.utility.file のクラス
Directory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。
ExtendedDirectory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。
ExtendedFile
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream の使用

jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream の使用

jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream の使用

jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.ExtendedInputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.ExtendedInputStream の使用

ExtendedInputStream を使用しているパッケージ
jp.co.intra_mart.foundation.utility.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.utility.net での ExtendedInputStream の使用

ExtendedInputStream を返す jp.co.intra_mart.foundation.utility.net のメソッド
 ExtendedInputStream ExtendedSocket.getInputStream()
推奨されていません。 入力ストリームの取得。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream の使用

ExtendedOutputStream を使用しているパッケージ
jp.co.intra_mart.foundation.utility.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.utility.net での ExtendedOutputStream の使用

ExtendedOutputStream を返す jp.co.intra_mart.foundation.utility.net のメソッド
 ExtendedOutputStream ExtendedSocket.getOutputStream()
推奨されていません。 出力ストリームの取得。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.HexInputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.HexInputStream の使用

jp.co.intra_mart.foundation.utility.io.HexInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.HexOutputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.HexOutputStream の使用

jp.co.intra_mart.foundation.utility.io.HexOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.ReplaceWriter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.ReplaceWriter の使用

jp.co.intra_mart.foundation.utility.io.ReplaceWriter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream の使用

jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream の使用

jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream の使用

jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.XORInputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.XORInputStream の使用

jp.co.intra_mart.foundation.utility.io.XORInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.XOROutputStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.XOROutputStream の使用

jp.co.intra_mart.foundation.utility.io.XOROutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BASE64DecodeInputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス BASE64DecodeInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 java.io.FilterInputStream
            拡張 jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream クラスを使用してください。

public class BASE64DecodeInputStream
extends FilterInputStream

このクラスは、BASE64 エンコードされたデータを読み込むための ストリームフィルタを実装します。
入力ストリームより読み込まれたバイトは、BASE64 デコードされ read() メソッドにより返されます。

関連項目:
InputStream

フィールドの概要
クラス java.io.FilterInputStream から継承したフィールド
in
コンストラクタの概要
BASE64DecodeInputStream(InputStream in)
推奨されていません。 指定された InputStream から読み込む BASE64 デコード入力ストリームを作成します。
メソッドの概要
int | read() 推奨されていません。 デコードデータのバイトを読み込みます。
int | read(byte[] b, int off, int len) 推奨されていません。 入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
クラス java.io.FilterInputStream から継承したメソッド
available, close, mark, markSupported, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BASE64DecodeInputStream

public BASE64DecodeInputStream(InputStream in)
推奨されていません。
指定された InputStream から読み込む BASE64 デコード入力ストリームを作成します。

パラメータ:
in - 入力ストリーム
メソッドの詳細

read

public int read()
         throws IOException
推奨されていません。
デコードデータのバイトを読み込みます。

このメソッドは、BASE64 のデコードに十分な入力が利用できるようになるまで ブロックします。

戻り値:
読み込まれたバイト。圧縮された入力の最後に達した場合は -1
例外:
IOException - 入出力エラーが発生した場合

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
推奨されていません。
入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。 このメソッドは入力データが読み込み可能になるまでブロックします。

パラメータ:
b - データが読み込まれるバッファ
off - データの開始オフセット
len - 読み込むバイトの最大値
戻り値:
バッファに読み込まれたバイト数。ストリームの終わりに達して読み込むデータがない場合は -1
例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BASE64DecodeOutputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス BASE64DecodeOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream クラスを使用してください。

public class BASE64DecodeOutputStream
extends FilterOutputStream

このクラスは、BASE64 デコードされたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、BASE64 デコードされ 基礎出力ストリームに書き込まれます。

関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
BASE64DecodeOutputStream(OutputStream out)
推奨されていません。 指定された OutputStream に書き込む BASE64デコーダーを作成します。
メソッドの概要
void | write(byte[] b, int off, int len) 推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) 推奨されていません。 バイトをデコードして出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
close, flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BASE64DecodeOutputStream

public BASE64DecodeOutputStream(OutputStream out)
推奨されていません。
指定された OutputStream に書き込む BASE64デコーダーを作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
推奨されていません。
バイトをデコードして出力ストリームに書き込みます。

このメソッドは、デコード結果が出力可能な 1 バイトのデータになるまで、 バッファに溜め込みます。 バッファに溜め込まれたデータは、flush メソッドや close メソッドを 実行しても基礎出力ストリームに書き出されることはありません。 バッファにデータが溜まった状態で、flush メソッドや close メソッドを 実行した場合、バッファ内のデータは破棄されます。

パラメータ:
b - 書き込まれるバイト
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が ASCII 文字の範囲に含まれない場合（ASCII のコントロールコードの場合も含む）や不正なコードが指定された場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
推奨されていません。
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。
このメソッドは、配列 b 内の off から len バイトについて、 int 型引数をひとつだけとる write メソッドを呼び出します。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BASE64EncodeOutputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス BASE64EncodeOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream クラスを使用してください。

public class BASE64EncodeOutputStream
extends FilterOutputStream

このクラスは、BASE64 エンコードされたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、BASE64 エンコードされ 基礎出力ストリームに書き込まれます。

関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
BASE64EncodeOutputStream(OutputStream out)
推奨されていません。 指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。
BASE64EncodeOutputStream(OutputStream out, boolean isAppnendReturnCodePer76chars)
推奨されていません。 指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。
メソッドの概要
void | close() 推奨されていません。 ストリームを閉じます。
void | finish() 推奨されていません。 出力ストリームへのエンコードデータの書き込みを終了します。
void | write(byte[] b, int off, int len) 推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) 推奨されていません。 バイトをエンコード出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BASE64EncodeOutputStream

public BASE64EncodeOutputStream(OutputStream out)
推奨されていません。
指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。

パラメータ:
out - 出力ストリーム

BASE64EncodeOutputStream

public BASE64EncodeOutputStream(OutputStream out,
                                boolean isAppnendReturnCodePer76chars)
推奨されていません。
指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。

パラメータ:
out - 出力ストリーム
isAppnendReturnCodePer76chars - 76文字ごとに改行コード(=LF)を追加する場合は true、 改行コードを追加しない場合は、 falseを指定してください。
メソッドの詳細

write

public void write(int b)
           throws IOException
推奨されていません。
バイトをエンコード出力ストリームに書き込みます。

このメソッドは、3 バイトのデータを受け取るとエンコードされたバイトを 出力ストリームに書き込みます。入力されたバイトが 3 バイトに満たない 場合は、入力されたバイトが合計で 3 バイトになるまでバッファに 溜め込みます。

パラメータ:
b - 書き込まれるバイト
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
推奨されていません。
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

finish

public void finish()
            throws IOException
推奨されていません。
出力ストリームへのエンコードデータの書き込みを終了します。

このときストリームは閉じられません。 複数のフィルタを同じ出力ストリームに連続して適用するときに このメソッドを使用します。

例外:
IOException - 入出力エラーが発生した場合

close

public void close()
           throws IOException
推奨されていません。
ストリームを閉じます。

ストリームを閉じ、これに関連するすべての システムリソースを解放します。 もし、このストリームがバッファ内に出力バイトを保持している場合、 それらを終端処理をして出力ストリームに強制的に書き込みます。
このメソッドは、finish メソッドを呼び出した後、 スーパークラス(java.io.FilterOutputStream)の close メソッドを呼び出します。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedInputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス ExtendedInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 jp.co.intra_mart.foundation.utility.io.ExtendedInputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream クラスを使用してください。

public class ExtendedInputStream
extends InputStream

このクラスは、標準の入力ストリームを拡張した機能を提供します。

このクラスは、jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream により 書き出されたストリームを読み込むための実装を提供します。
このクラスの各メソッドは、データをストリームから読み込むときに、 java.io.DataInputStream または java.io.ObjectInputStream の 適切なメソッドを使います。

データをストリームに書き出したときに使ったメソッドに対応した 適切なメソッドを利用することにより、データを読み込むことができます。

このクラスを jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream と対で使うことにより、 データをファイルに保存したり、ネットワークにより他のプロセスへ データを転送することができます。

jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream の writeObject メソッドにより 書き出されたオブジェクトは、readObject メソッドにより インスタンス化することができます。 この時、インスタンスに必要なクラスが存在している必要があります。

コンストラクタの概要
ExtendedInputStream(InputStream in)
推奨されていません。 入力ストリームを構築します。
ExtendedInputStream(InputStream in, ErrorEventListener listener)
推奨されていません。 入力ストリームを構築します。
メソッドの概要
void | close() 推奨されていません。 入出力ストリームおよびソケットを閉じます。
boolean | isClosed() 推奨されていません。 この入出力ストリームが閉じられているかチェックします。
int | read() 推奨されていません。 データ取得。
int | read(byte[] b, int off, int len) 推奨されていません。 データ取得。
boolean | readBoolean() 推奨されていません。 boolean 型データ取得。
int | readInt() 推奨されていません。 int 型データ取得。
long | readLong() 推奨されていません。 long 型データ取得。
Object | readObject() 推奨されていません。 Object の取得。
String | readString() 推奨されていません。 文字列の取得。
クラス java.io.InputStream から継承したメソッド
available, mark, markSupported, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedInputStream

public ExtendedInputStream(InputStream in)
                    throws IOException
推奨されていません。
入力ストリームを構築します。

パラメータ:
in - 基礎入力ストリーム
例外:
IOException - 入出力ストリームの作成時エラー

ExtendedInputStream

public ExtendedInputStream(InputStream in,
                           ErrorEventListener listener)
                    throws IOException
推奨されていません。
入力ストリームを構築します。

パラメータ:
in - 基礎入力ストリーム
listener - エラーイベントのリスナーオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー
メソッドの詳細

read

public int read()
         throws IOException
推奨されていません。
データ取得。

入力ストリームから次のバイトのデータを取得します。

戻り値:
取得したバイトデータ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
InputStream.read(), ExtendedOutputStream.write(int)

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
推奨されていません。
データ取得。

入力ストリームから len バイトまでのデータをバイト配列に 読み込みます。

パラメータ:
b - バイト配列
off - データの開始オフセット
len - 読み込むバイト数
戻り値:
取得したバイト数
例外:
IOException - 入出力エラーが発生した場合
関連項目:
InputStream.read(byte[], int, int), ExtendedOutputStream.write(int)

readInt

public int readInt()
            throws IOException
推奨されていません。
int 型データ取得。

基本データ型の整数データを読み込みます。

戻り値:
int 型数値データ
例外:
EOFException - データ受信完了前にストリームの終わりに達した場合
IOException - 入出力エラーが発生した場合
関連項目:
DataInputStream.readInt(), ExtendedOutputStream.writeInt(int)

readLong

public long readLong()
              throws IOException
推奨されていません。
long 型データ取得。

基本データ型の長整数データを読み込みます。

戻り値:
long 型数値データ
例外:
EOFException - データ受信完了前にストリームの終わりに達した場合
IOException - 入出力エラーが発生した場合
関連項目:
DataInputStream.readLong(), ExtendedOutputStream.writeLong(long)

readBoolean

public boolean readBoolean()
                    throws IOException
推奨されていません。
boolean 型データ取得。

基本データ型の真偽値データを読み込みます。

戻り値:
long 型数値データ
例外:
EOFException - データ受信完了前にストリームの終わりに達した場合
IOException - 入出力エラーが発生した場合
関連項目:
DataInputStream.readBoolean(), ExtendedOutputStream.writeBoolean(boolean)

readObject

public Object readObject()
                  throws OptionalDataException,
                         ClassNotFoundException,
                         IOException
推奨されていません。
Object の取得。

戻り値:
入力して復元したオブジェクト
例外:
ClassNotFoundException - 直列化されたオブジェクトのクラスが見つからなかった場合
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
StreamCorruptedException - ストリームの制御情報に一貫性がない場合
OptionalDataException - プリミティブデータが、オブジェクトではなくストリームに見つかった場合
IOException - 通常の入出力関連の例外
関連項目:
ObjectInputStream.readObject(), ExtendedOutputStream.writeObject(Object)

readString

public String readString()
                  throws OptionalDataException,
                         ClassNotFoundException,
                         IOException
推奨されていません。
文字列の取得。

このメソッドは、jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream クラスの writeString メソッドを使って書き込んだデータを読み込むための メソッドです。他の方法で書き込んだデータを読み込むことはできません。

戻り値:
入力した文字列
例外:
ClassNotFoundException - 直列化されたオブジェクトのクラスが見つからなかった場合
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
StreamCorruptedException - ストリームの制御情報に一貫性がない場合
OptionalDataException - プリミティブデータが、オブジェクトではなくストリームに見つかった場合
IOException - 通常の入出力関連の例外
関連項目:
ExtendedOutputStream.writeString(String)

close

public void close()
           throws IOException
推奨されていません。
入出力ストリームおよびソケットを閉じます。
入出力ストリームを閉じる前にバッファに溜められているデータをすべて 出力ストリームに書き出します。

例外:
IOException - 入出力エラーが発生した場合

isClosed

public boolean isClosed()
推奨されていません。
この入出力ストリームが閉じられているかチェックします。

戻り値:
すでに閉じられている場合 true、そうでない場合 false。
関連項目:
close()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedOutputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス ExtendedOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream クラスを使用してください。

public class ExtendedOutputStream
extends OutputStream

このクラスは、標準の出力ストリームを拡張した機能を提供します。

このクラスの各メソッドは、データをストリームに書き出すときに、 java.io.DataOutputStream または java.io.ObjectOutputStream の 適切なメソッドを使います。
writeObject メソッドを使ってオブジェクトをストリームに書き出す 場合、ストリームに書き込めるのは java.io.Serializable インタフェースを サポートするオブジェクトに限ります。それ以外のオブジェクトを ストリームに書き込もうとした場合、例外がスローされます。

この出力ストリームに書き込んだデータを入力する場合、 jp.co.intra_mart.foundation.utility.io.ExtendedInputStream を利用する必要があります。 他の入力ストリームから読み込んだ場合例外がスローされることがあります。

関連項目:
ExtendedInputStream

コンストラクタの概要
ExtendedOutputStream(OutputStream out)
推奨されていません。 出力ストリームを構築します。
ExtendedOutputStream(OutputStream out, ErrorEventListener listener)
推奨されていません。 出力ストリームを構築します。
メソッドの概要
void | close() 推奨されていません。 入出力ストリームおよびソケットを閉じます。
void | flush() 推奨されていません。 書き出しストリーム内のデータをすべて出力。
boolean | isClosed() 推奨されていません。 この入出力ストリームが閉じられているかチェックします。
void | write(byte[] b, int off, int len) 推奨されていません。 オフセット off から始まる指定のバイト配列から この出力ストリームに len バイトを書き込みます。
void | write(int data) 推奨されていません。 指定されたバイトを書き込みます。
void | writeBoolean(boolean data) 推奨されていません。 boolean 型データの送信。
void | writeInt(int data) 推奨されていません。 int 型データの送信。
void | writeLong(long data) 推奨されていません。 long 型データの送信。
void | writeObject(Object data) 推奨されていません。 オブジェクトの送信。
void | writeString(String data) 推奨されていません。 文字列の送信。
クラス java.io.OutputStream から継承したメソッド
write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedOutputStream

public ExtendedOutputStream(OutputStream out)
                     throws IOException
推奨されていません。
出力ストリームを構築します。

パラメータ:
out - 基礎出力ストリーム
例外:
IOException - 入出力ストリームの作成時エラー

ExtendedOutputStream

public ExtendedOutputStream(OutputStream out,
                            ErrorEventListener listener)
                     throws IOException
推奨されていません。
出力ストリームを構築します。

パラメータ:
out - 基礎出力ストリーム
listener - エラーイベントのリスナーオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー
メソッドの詳細

write

public void write(int data)
           throws IOException
推奨されていません。
指定されたバイトを書き込みます。

パラメータ:
data - バイトデータ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
OutputStream.write(int), ExtendedInputStream.read()

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
推奨されていません。
オフセット off から始まる指定のバイト配列から この出力ストリームに len バイトを書き込みます。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラーが発生した場合
関連項目:
OutputStream.write(byte[],int,int), ExtendedInputStream.read()

writeInt

public void writeInt(int data)
              throws IOException
推奨されていません。
int 型データの送信。
基本データ型の整数データを基礎出力ストリームに書き込みます。

パラメータ:
data - データ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
DataOutputStream.writeInt(int), ExtendedInputStream.readInt()

writeLong

public void writeLong(long data)
               throws IOException
推奨されていません。
long 型データの送信。
基本データ型の長整数データを基礎出力ストリームに書き込みます。

パラメータ:
data - データ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
DataOutputStream.writeLong(long), ExtendedInputStream.readLong()

writeBoolean

public void writeBoolean(boolean data)
                  throws IOException
推奨されていません。
boolean 型データの送信。
基本データ型の真偽値データを基礎出力ストリームに書き込みます。

パラメータ:
data - データ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
DataOutputStream.writeBoolean(boolean), ExtendedInputStream.readBoolean()

writeObject

public void writeObject(Object data)
                 throws IOException
推奨されていません。
オブジェクトの送信。

java.io.Serializable インタフェースを実装している オブジェクトを基礎出力ストリームに書き込みます。
このメソッドはオブジェクトをストリームに書き込む際に、 java.io.ObjectOutputStream の writeObject メソッドを使います。

パラメータ:
data - オブジェクト
例外:
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
NotSerializableException - 直列化の対象が java.io.Serializable インタフェースを実装していない場合
IOException - 基礎の OutputStream に例外が発生した場合
関連項目:
ObjectOutputStream.writeObject(Object), Serializable, ExtendedInputStream.readObject()

writeString

public void writeString(String data)
                 throws IOException
推奨されていません。
文字列の送信。
このメソッドは、writeObject() メソッドを使い文字列をストリームに 書き込みます。 java.io.DataOutputStream や java.io.ObjectOutputStream の writeUTF メソッドとの違いは、ストリームに書き込める文字列の 長さに制約がないことです。

パラメータ:
data - ストリームに書き込む文字列
例外:
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
NotSerializableException - 直列化の対象が java.io.Serializable インタフェースを実装していない場合
IOException - 基礎の OutputStream に例外が発生した場合
関連項目:
DataOutputStream.writeUTF(String),
ObjectOutputStream.writeUTF(String),
ExtendedInputStream.readString()

flush

public void flush()
           throws IOException
推奨されていません。
書き出しストリーム内のデータをすべて出力。

例外:
IOException - 入出力エラーが発生した場合

close

public void close()
           throws IOException
推奨されていません。
入出力ストリームおよびソケットを閉じます。
入出力ストリームを閉じる前にバッファに溜められているデータをすべて 出力ストリームに書き出します。

例外:
IOException - 入出力エラーが発生した場合

isClosed

public boolean isClosed()
推奨されていません。
この入出力ストリームが閉じられているかチェックします。

戻り値:
すでに閉じられている場合 true、そうでない場合 false。
関連項目:
close()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HexInputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス HexInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 jp.co.intra_mart.foundation.utility.io.HexInputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream クラスを使用してください。

public class HexInputStream
extends InputStream

このクラスは、16進数表現されたデータを読み込むための ストリームフィルタを実装します。
入力ストリームより読み込まれたバイトは、16進数表現からバイトに変換され read() メソッドにより返されます。

関連項目:
InputStream

フィールドの概要
protected  InputStream in
推奨されていません。 フィルタ処理される入力ストリームです。
コンストラクタの概要
HexInputStream(InputStream in)
推奨されていません。 指定された InputStream から読み込む HexInputStream を作成します。
メソッドの概要
void | close() 推奨されていません。 ストリームを閉じます。
int | read() 推奨されていません。 デコードデータのバイトを読み込みます。
クラス java.io.InputStream から継承したメソッド
available, mark, markSupported, read, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

in

protected InputStream in
推奨されていません。
フィルタ処理される入力ストリームです。

コンストラクタの詳細

HexInputStream

public HexInputStream(InputStream in)
推奨されていません。
指定された InputStream から読み込む HexInputStream を作成します。

パラメータ:
in - 入力ストリーム
メソッドの詳細

read

public int read()
         throws IOException,
                NumberFormatException
推奨されていません。
デコードデータのバイトを読み込みます。

２バイトの 16進数表現されたキャラクタデータを 読み込んで１バイトの数値として返します。 このメソッドは、２バイトの入力があるまでブロックします。

戻り値:
読み込まれたバイト。
例外:
IOException - 入出力エラーが発生した場合
NumberFormatException - 16進数として有効ではない文字を読み込んだ場合

close

public void close()
           throws IOException
推奨されていません。
ストリームを閉じます。

入力ストリームを閉じ、これに関連するすべての システムリソースを解放します。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HexOutputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス HexOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 jp.co.intra_mart.foundation.utility.io.HexOutputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream クラスを使用してください。

public class HexOutputStream
extends OutputStream

このクラスは、16進数表現されたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、16進数表現され 基礎出力ストリームに書き込まれます。
フィルタリングされた結果、基礎ストリームに書き込まれるデータは、 [0-9a-f] の範囲のキャラクタで構成されます。

関連項目:
OutputStream

フィールドの概要
protected  OutputStream out
推奨されていません。 フィルタ処理される基礎出力ストリームです。
コンストラクタの概要
HexOutputStream(OutputStream out)
推奨されていません。 指定された OutputStream に書き込む HexOutputStream を作成します。
メソッドの概要
void | close() 推奨されていません。 ストリームを閉じます。
void | write(byte[] b, int off, int len) 推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) 推奨されていません。 バイトをエンコード出力ストリームに書き込みます。
クラス java.io.OutputStream から継承したメソッド
flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

out

protected OutputStream out
推奨されていません。
フィルタ処理される基礎出力ストリームです。

コンストラクタの詳細

HexOutputStream

public HexOutputStream(OutputStream out)
推奨されていません。
指定された OutputStream に書き込む HexOutputStream を作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
推奨されていません。
バイトをエンコード出力ストリームに書き込みます。

このメソッドは、バイトを上位４ビットと下位ビットに分け、 それぞれ16進数表現されたキャラクターコードに置き換えて、 計２バイトのデータを基礎ストリームに書き込みます。

パラメータ:
b - 書き込まれるバイト
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
推奨されていません。
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

close

public void close()
           throws IOException
推奨されていません。
ストリームを閉じます。

ストリームを閉じ、これに関連するすべての システムリソースを解放します。
もし、このストリームがバッファ内に出力バイトを保持している場合、 それらを終端処理をして出力ストリームに強制的に書き込みます。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.utility.io (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.utility.io
クラス
BASE64DecodeInputStream
BASE64DecodeOutputStream
BASE64EncodeOutputStream
ExtendedInputStream
ExtendedOutputStream
HexInputStream
HexOutputStream
ReplaceWriter
URLDecodeInputStream
URLDecodeOutputStream
URLEncodeOutputStream
XORInputStream
XOROutputStream


jp.co.intra_mart.foundation.utility.io (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.io

このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。

参照:
説明

クラスの概要
BASE64DecodeInputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream クラスを使用してください。
BASE64DecodeOutputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream クラスを使用してください。
BASE64EncodeOutputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream クラスを使用してください。
ExtendedInputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream クラスを使用してください。
ExtendedOutputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream クラスを使用してください。
HexInputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream クラスを使用してください。
HexOutputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream クラスを使用してください。
ReplaceWriter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter クラスを使用してください。
URLDecodeInputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream クラスを使用してください。
URLDecodeOutputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream クラスを使用してください。
URLEncodeOutputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream クラスを使用してください。
XORInputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream クラスを使用してください。
XOROutputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream クラスを使用してください。

パッケージ jp.co.intra_mart.foundation.utility.io の説明

このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
このパッケージには、java.io パッケージに含まれるクラスを拡張したものが多く含まれています。


jp.co.intra_mart.foundation.utility.io クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.io の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.io.InputStream
      • class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream
      • class java.io.FilterInputStream
        • class jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream
        • class jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream
        • class jp.co.intra_mart.foundation.utility.io.XORInputStream
      • class jp.co.intra_mart.foundation.utility.io.HexInputStream
    • class java.io.OutputStream
      • class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream
      • class java.io.FilterOutputStream
        • class jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.XOROutputStream
      • class jp.co.intra_mart.foundation.utility.io.HexOutputStream
    • class java.io.Writer
      • class jp.co.intra_mart.foundation.utility.io.ReplaceWriter


パッケージ jp.co.intra_mart.foundation.utility.io の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.utility.io の使用

jp.co.intra_mart.foundation.utility.io を使用しているパッケージ
jp.co.intra_mart.foundation.utility.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.utility.net により使用される jp.co.intra_mart.foundation.utility.io のクラス
ExtendedInputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream クラスを使用してください。
ExtendedOutputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ReplaceWriter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス ReplaceWriter

java.lang.Object
    拡張 java.io.Writer
        拡張 jp.co.intra_mart.foundation.utility.io.ReplaceWriter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter クラスを使用してください。

public class ReplaceWriter
extends Writer

このクラスは、部分文字列を別な部分文字列へ置換しながら ストリームに文字列を書き込むためのストリームフィルタを実装します。
置換対象となる部分文字列と置換する文字列の長さは同じ必要はありません。 置換対象となる文字データと異なる長さの文字データを置換後のデータとして 指定することも可能です。この場合、 このクラスによって基礎ストリームに書き込まれるデータ量は、 元のデータ量と変化します。

   java.io.StringWriter sw = new java.io.StringWriter();

   ReplaceWriter rw = new ReplaceWriter(sw, "abc", "xyz");

   rw.write("abc");
   String result = sw.toString();
文字データ "abc" は、"xyz" に変化します。この場合、以下のように 記述しても同様の結果が得られます。
   java.io.StringWriter sw = new java.io.StringWriter();

   ReplaceWriter rw = new ReplaceWriter(sw, "abc", "xyz");

   rw.write("a");
   rw.write("b");
   rw.write("c");
   String result = sw.toString();

導入されたバージョン:
version 3.2

フィールドの概要
クラス java.io.Writer から継承したフィールド
lock
コンストラクタの概要
ReplaceWriter(Writer out, char[] oldChars)
推奨されていません。 文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer out, char[] oldChars, char[] newChars)
推奨されていません。 文字列置換のためのストリームフィルタを作成します。
ReplaceWriter(Writer out, String oldString)
推奨されていません。 文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer out, String oldString, String newString)
推奨されていません。 文字列置換のためのストリームフィルタを作成します。
メソッドの概要
void | close() 推奨されていません。 ストリームを閉じてフラッシュします。
void | finish() 推奨されていません。 バッファに保存してあるデータを書き出します。
void | flush() 推奨されていません。 ストリームをフラッシュします。
void | write(char[] cbuf, int off, int len) 推奨されていません。 文字列の一部を基礎ストリームに書き込みます。
void | write(int c) 推奨されていません。 単一文字を書き込みます。
クラス java.io.Writer から継承したメソッド
write, write, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ReplaceWriter

public ReplaceWriter(Writer out,
                     char[] oldChars)
推奨されていません。
文字列削除のためのストリームフィルタを作成します。
このインスタンスに書き込まれた文字データは部分文字列の削除を行いながら 基礎ストリームに書き込まれます。

パラメータ:
out - 基礎ストリーム
oldChars - 削除対象となる文字の配列

ReplaceWriter

public ReplaceWriter(Writer out,
                     String oldString)
推奨されていません。
文字列削除のためのストリームフィルタを作成します。
このインスタンスに書き込まれた文字データは部分文字列の削除を行いながら 基礎ストリームに書き込まれます。

パラメータ:
out - 基礎ストリーム
oldString - 削除対象となる文字列

ReplaceWriter

public ReplaceWriter(Writer out,
                     char[] oldChars,
                     char[] newChars)
推奨されていません。
文字列置換のためのストリームフィルタを作成します。
このインスタンスに書き込まれた文字データは適切な置換を行いながら 基礎ストリームに書き込まれます。

パラメータ:
out - 基礎ストリーム
oldChars - 置換対象となる文字の配列
newChars - 置換する文字の配列

ReplaceWriter

public ReplaceWriter(Writer out,
                     String oldString,
                     String newString)
推奨されていません。
文字列置換のためのストリームフィルタを作成します。

パラメータ:
out - 基礎ストリーム
oldString - 置換対象となる文字列
newString - 置換する文字列
メソッドの詳細

write

public void write(int c)
           throws IOException
推奨されていません。
単一文字を書き込みます。 書き込まれる文字は、指定された整数値の下位 16 ビットに格納されます。 上位 16 ビットは無視されます。

パラメータ:
c - 文字
例外:
IOException - 入出力エラーが発生した場合

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
推奨されていません。
文字列の一部を基礎ストリームに書き込みます。

パラメータ:
cbuf - 文字の配列
off - 文字の書き込み開始オフセット
len - 書き込む文字数
例外:
IOException - 入出力エラーが発生した場合

finish

public void finish()
            throws IOException
推奨されていません。
バッファに保存してあるデータを書き出します。

ストリームがさまざまな write() メソッドからの文字をバッファに 保存してある場合、これらの文字を基礎ストリームへただちに 書き込みます。
このメソッドは、このストリームの持つ置換対象データと比較中の 文字データを含むすべてのバッファを基礎ストリームに書き込みます。 このメソッドを呼び出し後は、write() メソッドによって与えられる データを改めて検索し直します。この機能のより、このストリームフィルタの 複数のストリームでの再利用が可能となります。

このときストリームは閉じられません。 複数のフィルタを同じ出力ストリームに連続して適用するときに このメソッドを使用します。

例外:
IOException - 入出力エラーが発生した場合

flush

public void flush()
           throws IOException
推奨されていません。
ストリームをフラッシュします。

現在バッファに保存されているデータが置換対象の文字データと 比較途中である場合、比較中のデータはフラッシュされません。 このストリームの持つすべてのバッファをフラッシュするためには、 finish() メソッドを呼び出したあとにこのメソッドを呼び出して下さい。
宛先が別の文字またはバイトストリームの場合は、 この宛先をフラッシュします。つまり 1 つの flush() の呼び出しで、 関連する Writer および OutputStream のすべてのバッファを フラッシュします。

例外:
IOException - 入出力エラーが発生した場合

close

public void close()
           throws IOException
推奨されていません。
ストリームを閉じてフラッシュします。
ストリームを一度閉じると、以降 write() または flush() を呼び出すと、 IOException がスローされます。 ただし、前に閉じたストリームを閉じても効果はありません。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


URLDecodeInputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス URLDecodeInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 java.io.FilterInputStream
            拡張 jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream クラスを使用してください。

public class URLDecodeInputStream
extends FilterInputStream

このクラスは、URL デコードされたデータを読み込むための ストリームフィルタを実装します。
この入力ストリームに読み込まれたバイトは、URL デコードされ 基礎入力ストリームに読み込まれます。

導入されたバージョン:
version 4.0

フィールドの概要
クラス java.io.FilterInputStream から継承したフィールド
in
コンストラクタの概要
URLDecodeInputStream(InputStream in)
推奨されていません。 指定された InputStream から URL デコードしながらバイトを読み込む 入力ストリームを作成します。
メソッドの概要
int | read() 推奨されていません。 デコードデータのバイトを読み込みます。
int | read(byte[] b, int off, int len) 推奨されていません。 入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
クラス java.io.FilterInputStream から継承したメソッド
available, close, mark, markSupported, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLDecodeInputStream

public URLDecodeInputStream(InputStream in)
推奨されていません。
指定された InputStream から URL デコードしながらバイトを読み込む 入力ストリームを作成します。

パラメータ:
in - 入力ストリーム
メソッドの詳細

read

public int read()
         throws IOException
推奨されていません。
デコードデータのバイトを読み込みます。

このメソッドは、BASE64 のデコードに十分な入力が利用できるようになるまで ブロックします。

戻り値:
読み込まれたバイト。圧縮された入力の最後に達した場合は -1
例外:
EOFException - デコード途中で入力が終了した場合
IOException - 入出力エラーが発生した場合

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
推奨されていません。
入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。 このメソッドは入力データが読み込み可能になるまでブロックします。

パラメータ:
b - データが読み込まれるバッファ
off - データの開始オフセット
len - 読み込むバイトの最大値
戻り値:
バッファに読み込まれたバイト数。ストリームの終わりに達して読み込むデータがない場合は -1
例外:
EOFException - デコード途中で入力が終了した場合
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


URLDecodeOutputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス URLDecodeOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream クラスを使用してください。

public class URLDecodeOutputStream
extends FilterOutputStream

このクラスは、URL デコードされたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、URL デコードされ 基礎出力ストリームに書き込まれます。

関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
URLDecodeOutputStream(OutputStream out)
推奨されていません。 指定された OutputStream に書き込む BASE64デコーダーを作成します。
メソッドの概要
void | write(byte[] b, int off, int len) 推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) 推奨されていません。 バイトをデコードして出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
close, flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLDecodeOutputStream

public URLDecodeOutputStream(OutputStream out)
推奨されていません。
指定された OutputStream に書き込む BASE64デコーダーを作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
推奨されていません。
バイトをデコードして出力ストリームに書き込みます。

このメソッドは、デコード結果が出力可能な 1 バイトのデータになるまで、 バッファに溜め込みます。 バッファに溜め込まれたデータは、flush メソッドや close メソッドを 実行しても基礎出力ストリームに書き出されることはありません。 バッファにデータが溜まった状態で、flush メソッドや close メソッドを 実行した場合、バッファ内のデータは破棄されます。

パラメータ:
b - 書き込まれるバイト
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
推奨されていません。
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。
このメソッドは、配列 b 内の off から len バイトについて、 int 型引数をひとつだけとる write メソッドを呼び出します。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


URLEncodeOutputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス URLEncodeOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream クラスを使用してください。

public class URLEncodeOutputStream
extends FilterOutputStream

このクラスは、URL エンコードされたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、URL エンコードされ 基礎出力ストリームに書き込まれます。

関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
URLEncodeOutputStream(OutputStream out)
推奨されていません。 指定された OutputStream に書き込む BASE64デコーダーを作成します。
メソッドの概要
void | write(byte[] b, int off, int len) 推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) 推奨されていません。 バイトをデコードして出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
close, flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLEncodeOutputStream

public URLEncodeOutputStream(OutputStream out)
推奨されていません。
指定された OutputStream に書き込む BASE64デコーダーを作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
推奨されていません。
バイトをデコードして出力ストリームに書き込みます。

このメソッドは、デコード結果が出力可能な 1 バイトのデータになるまで、 バッファに溜め込みます。 バッファに溜め込まれたデータは、flush メソッドや close メソッドを 実行しても基礎出力ストリームに書き出されることはありません。 バッファにデータが溜まった状態で、flush メソッドや close メソッドを 実行した場合、バッファ内のデータは破棄されます。

パラメータ:
b - 書き込まれるバイト
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
推奨されていません。
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。
このメソッドは、配列 b 内の off から len バイトについて、 int 型引数をひとつだけとる write メソッドを呼び出します。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XORInputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス XORInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 java.io.FilterInputStream
            拡張 jp.co.intra_mart.foundation.utility.io.XORInputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream クラスを使用してください。

public class XORInputStream
extends FilterInputStream

このクラスは、指定されたバイトとの排他論理和計算された結果の データを読み込むためのストリームフィルタを実装します。
入力ストリームより読み込まれたバイトは、 指定されたバイトデータとの排他論理和を計算した結果として read() メソッドにより返されます。

導入されたバージョン:
version4.0
関連項目:
InputStream

フィールドの概要
クラス java.io.FilterInputStream から継承したフィールド
in
コンストラクタの概要
XORInputStream(InputStream in, int b)
推奨されていません。 指定された InputStream から指定されたバイトとの排他論理和を 取りながら読み込む XORInputStream を作成します。
メソッドの概要
int | read() 推奨されていません。 デコードデータのバイトを読み込みます。
int | read(byte[] b, int off, int len) 推奨されていません。 入力ストリームからバイト配列へ最大 len バイトのデータを読み込みます。
クラス java.io.FilterInputStream から継承したメソッド
available, close, mark, markSupported, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

XORInputStream

public XORInputStream(InputStream in,
                      int b)
推奨されていません。
指定された InputStream から指定されたバイトとの排他論理和を 取りながら読み込む XORInputStream を作成します。

パラメータ:
in - 入力ストリーム
b - 排他論理和を取るためのバイト
メソッドの詳細

read

public int read()
         throws IOException,
                NumberFormatException
推奨されていません。
デコードデータのバイトを読み込みます。

２バイトの 16進数表現されたキャラクタデータを 読み込んで１バイトの数値として返します。 このメソッドは、２バイトの入力があるまでブロックします。

戻り値:
読み込まれたバイト。
例外:
IOException - 入出力エラーが発生した場合
NumberFormatException - 16進数として有効ではない文字を読み込んだ場合

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
推奨されていません。
入力ストリームからバイト配列へ最大 len バイトのデータを読み込みます。このメソッドは、入力が可能になるまでブロックします。

パラメータ:
b - データの読み込み先のバッファ
off - データの開始オフセット
len - 読み込まれる最大バイト数
戻り値:
バッファに読み込まれたバイトの合計数。ストリームの終わりに達してデータがない場合は -1
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XOROutputStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス XOROutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.foundation.utility.io.XOROutputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream クラスを使用してください。

public class XOROutputStream
extends FilterOutputStream

このクラスは、指定のバイトデータとの排他論理和を計算した結果の バイトデータを書き込むためのストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、指定のバイトデータとの 排他論理和を計算して、その結果のバイトデータが 基礎出力ストリームに書き込まれます。
フィルタリングされた結果、基礎ストリームに書き込まれるデータは、 同じバイトデータによって排他論理和を取ることにより、 もとのバイトデータに戻すことができます。

導入されたバージョン:
version4.0
関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
XOROutputStream(OutputStream out, int b)
推奨されていません。 指定された OutputStream に対して b との排他論理和を取ったバイトデータを書き込む XOROutputStream を作成します。
メソッドの概要
void | write(byte[] b, int off, int len) 推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) 推奨されていません。 バイトをエンコード出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
close, flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

XOROutputStream

public XOROutputStream(OutputStream out,
                       int b)
推奨されていません。
指定された OutputStream に対して b との排他論理和を取ったバイトデータを書き込む XOROutputStream を作成します。

パラメータ:
out - 出力ストリーム
b - 排他論理和を取るためのバイト
メソッドの詳細

write

public void write(int b)
           throws IOException
推奨されていません。
バイトをエンコード出力ストリームに書き込みます。

パラメータ:
b - 書き込まれるバイト
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
推奨されていません。
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor の使用

AbstractSocketConnectionDistributor を使用しているパッケージ
jp.co.intra_mart.foundation.utility.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.utility.net での AbstractSocketConnectionDistributor の使用

jp.co.intra_mart.foundation.utility.net での AbstractSocketConnectionDistributor のサブクラス
 class SocketPool
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketPool クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.net.ExtendedSocket の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.net.ExtendedSocket の使用

ExtendedSocket を使用しているパッケージ
jp.co.intra_mart.foundation.utility.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.utility.net での ExtendedSocket の使用

jp.co.intra_mart.foundation.utility.net での ExtendedSocket のサブクラス
 class SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。

ExtendedSocket 型のパラメータを持つ jp.co.intra_mart.foundation.utility.net のメソッド
 void SocketEventListener.handleSocketEvent(ExtendedSocket socket)
推奨されていません。 ソケットに関するイベント発生時に呼び出されるメソッド。

ExtendedSocket 型のパラメータを持つ jp.co.intra_mart.foundation.utility.net のコンストラクタ
SocketConnection(ExtendedSocket socket)
推奨されていません。 ソケット入出力インスタンスを構築します。
ExtendedSocket(ExtendedSocket socket)
推奨されていません。 ソケットを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.net.Localhost の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.net.Localhost の使用

Localhost を使用しているパッケージ
jp.co.intra_mart.foundation.utility.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.utility.net での Localhost の使用

Localhost を返す jp.co.intra_mart.foundation.utility.net のメソッド
static Localhost Localhost.instance()
推奨されていません。 このクラスから生成される唯一のインスタンスを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.net.SocketConnection の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.net.SocketConnection の使用

SocketConnection を使用しているパッケージ
jp.co.intra_mart.foundation.service.client | このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.client.batch | Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file | Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.manager | このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.utility.net | ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.service.client での SocketConnection の使用

SocketConnection を返す jp.co.intra_mart.foundation.service.client のメソッド
protected abstract  SocketConnection NetworkConnector.connection()
サーバに接続するためのコネクションを取得します。

jp.co.intra_mart.foundation.service.client.batch での SocketConnection の使用

SocketConnection を返す jp.co.intra_mart.foundation.service.client.batch のメソッド
protected  SocketConnection Scheduler.connection()
サーバに接続するためのコネクションを取得します。

jp.co.intra_mart.foundation.service.client.file での SocketConnection の使用

SocketConnection を返す jp.co.intra_mart.foundation.service.client.file のメソッド
protected  SocketConnection AbstractComponent.connection()
サーバに接続するためのコネクションを取得します。

jp.co.intra_mart.foundation.service.client.information での SocketConnection の使用

SocketConnection を返す jp.co.intra_mart.foundation.service.client.information のメソッド
protected SocketConnection | PermanentFile.connection() サーバに接続するためのコネクションを取得します。
protected SocketConnection | PermanentDirectory.connection() サーバに接続するためのコネクションを取得します。
protected SocketConnection | Lock.connection() サーバに接続するためのコネクションを取得します。
protected SocketConnection | ExternalMemory.connection() サーバに接続するためのコネクションを取得します。
protected SocketConnection | ExternalDirectory.connection() サーバに接続するためのコネクションを取得します。

jp.co.intra_mart.foundation.service.client.manager での SocketConnection の使用

SocketConnection を返す jp.co.intra_mart.foundation.service.client.manager のメソッド
protected  SocketConnection ServerConnector.connection()
サーバに接続するためのコネクションを取得します。

jp.co.intra_mart.foundation.utility.net での SocketConnection の使用

SocketConnection を返す jp.co.intra_mart.foundation.utility.net のメソッド
SocketConnection | SocketPool.connection() 推奨されていません。 コネクションの取得。
SocketConnection | SocketConnectionDistributor.connection() 推奨されていません。 コネクションの取得。

SocketConnection 型のパラメータを持つ jp.co.intra_mart.foundation.utility.net のメソッド
 boolean SocketPool.eject(SocketConnection connection)
推奨されていません。 指定コネクションをこのプールの管理から切り離します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor の使用

SocketConnectionDistributor を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.manager | このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.utility.net | ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.service.client.manager での SocketConnectionDistributor の使用

SocketConnectionDistributor を返す jp.co.intra_mart.foundation.service.client.manager のメソッド
SocketConnectionDistributor | SocketConnectionDistributorFactory.createSocketConnectionDistributor(String passwd) Server-Manager に接続するためのネットワークコネクション管理 オブジェクトを取得します。
SocketConnectionDistributor | ServerConnector.getSocketConnectionDistributor() このオブジェクトが保持しているネットワークのコネクションプールを 返します。

SocketConnectionDistributor 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.manager のコンストラクタ
ServerConnector(SocketConnectionDistributor socketConnectionDistributor)
オブジェクトを作成します。

jp.co.intra_mart.foundation.utility.net での SocketConnectionDistributor の使用

jp.co.intra_mart.foundation.utility.net での SocketConnectionDistributor のサブインタフェース
 interface SocketConnectionManager
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager クラスを使用してください。

SocketConnectionDistributor を実装している jp.co.intra_mart.foundation.utility.net のクラス
class | AbstractSocketConnectionDistributor 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor クラスを使用してください。
class | SocketPool 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketPool クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.net.SocketConnectionManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.net.SocketConnectionManager の使用

SocketConnectionManager を使用しているパッケージ
jp.co.intra_mart.foundation.utility.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.utility.net での SocketConnectionManager の使用

SocketConnectionManager を実装している jp.co.intra_mart.foundation.utility.net のクラス
 class SocketPool
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketPool クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.net.SocketEventListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.net.SocketEventListener の使用

SocketEventListener を使用しているパッケージ
jp.co.intra_mart.foundation.utility.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.utility.net での SocketEventListener の使用

SocketEventListener 型のパラメータを持つ jp.co.intra_mart.foundation.utility.net のメソッド
void | SocketPool.addCreateSocketEventListener(SocketEventListener listener) 推奨されていません。 ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。
void | SocketPool.addCloseSocketEventListener(SocketEventListener listener) 推奨されていません。 ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
void | ExtendedSocket.addCloseSocketEventListener(SocketEventListener listener) 推奨されていません。 ソケットをクローズしたイベントを通知するためのリスナーを 設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.net.SocketPool の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.net.SocketPool の使用

jp.co.intra_mart.foundation.utility.net.SocketPool はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException の使用

UnsupportedNetworkConnectException を使用しているパッケージ
jp.co.intra_mart.foundation.service.client このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。

jp.co.intra_mart.foundation.service.client での UnsupportedNetworkConnectException の使用

UnsupportedNetworkConnectException をスローする jp.co.intra_mart.foundation.service.client のメソッド
protected abstract  SocketConnection NetworkConnector.connection()
サーバに接続するためのコネクションを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AbstractSocketConnectionDistributor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
クラス AbstractSocketConnectionDistributor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor
すべての実装インタフェース:
SocketConnectionDistributor
直系の既知のサブクラス:
SocketPool
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor クラスを使用してください。

public abstract class AbstractSocketConnectionDistributor
extends Object
implements SocketConnectionDistributor

このクラスは、通信ソケットを作成する機能を提供します。

このクラスを継承してソケットプールを作成することができます。

コンストラクタの概要
protected AbstractSocketConnectionDistributor(String address, int port)
推奨されていません。 ソケット作成オブジェクトを構築します。
メソッドの概要
protected Socket | createSocket() 推奨されていません。 新しいソケットを作成します。
String | getAddress() 推奨されていません。 アドレスを返します。
int | getPort() 推奨されていません。 ポートを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor から継承したメソッド
clean, connection, destroy

コンストラクタの詳細

AbstractSocketConnectionDistributor

protected AbstractSocketConnectionDistributor(String address,
                                              int port)
推奨されていません。
ソケット作成オブジェクトを構築します。

パラメータ:
address - 接続するサーバのアドレス
port - 接続するサーバがサービスを提供しているポート
メソッドの詳細

createSocket

protected Socket createSocket()
                       throws UnknownHostException,
                              IOException
推奨されていません。
新しいソケットを作成します。

戻り値:
ソケット
例外:
UnknownHostException - ホストの IP アドレスを判定できなかった場合
IOException - ソケットの生成中に入出力エラーが発生した場合

getAddress

public String getAddress()
推奨されていません。
アドレスを返します。

戻り値:
このプールのネットワーク接続先サーバアドレス

getPort

public int getPort()
推奨されていません。
ポートを返します。

戻り値:
このプールのネットワーク接続先サーバポート
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedSocket (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
クラス ExtendedSocket

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.net.ExtendedSocket
直系の既知のサブクラス:
SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket クラスを使用してください。

public class ExtendedSocket
extends Object

このクラスは、ソケット通信用の入出力機能を提供します。

このクラスの提供している独自機能や、このクラスの持つメソッドから 取得したオブジェクトを使っている最中に例外がスローされた場合、 このクラスのインスタンスは発生した例外を保存します。 保存された例外は、lastError メソッドにより知ることができます。
ただし、このクラスが継承しているスーパークラスのメソッドの 呼び出し時にスローされた例外に関しては感知することはできません。

コンストラクタの概要
protected | ExtendedSocket(ExtendedSocket socket) 推奨されていません。 ソケットを構築します。
 | ExtendedSocket(Socket socket) 推奨されていません。 ソケットを構築します。
 | ExtendedSocket(String address, int port) 推奨されていません。 ソケットを構築します。
メソッドの概要
void | addCloseSocketEventListener(SocketEventListener listener) 推奨されていません。 ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
void | clearError() 推奨されていません。 このインスタンスのメソッド実行中に発生した例外をすべて破棄します。
void | close() 推奨されていません。 入出力ストリームおよびソケットを閉じます。
Iterator | errorIterator() 推奨されていません。 このインスタンスのメソッド実行中に発生した例外を返します。
Collection | getCloseSocketEventListeners() 推奨されていません。 このソケットに登録されているクローズ・イベント・リスナーを返します。
ExtendedInputStream | getInputStream() 推奨されていません。 入力ストリームの取得。
ExtendedOutputStream | getOutputStream() 推奨されていません。 出力ストリームの取得。
Socket | getSocket() 推奨されていません。 このオブジェクトの持つソケットオブジェクトを返します。
boolean | isClosed() 推奨されていません。 このソケットが閉じられているかどうかをチェックします。
Throwable | lastError() 推奨されていません。 このインスタンスのメソッド中で最後に発生した例外を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedSocket

public ExtendedSocket(String address,
                      int port)
               throws UnknownHostException,
                      IOException
推奨されていません。
ソケットを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
address - 接続先アドレス
port - 接続先ポート
例外:
UnknownHostException - ホストの IP アドレスが判定できなかった場合にスローされます。
IOException - 入出力ストリームの作成時エラー

ExtendedSocket

public ExtendedSocket(Socket socket)
               throws IOException
推奨されていません。
ソケットを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
socket - ソケットオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー

ExtendedSocket

protected ExtendedSocket(ExtendedSocket socket)
推奨されていません。
ソケットを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
socket - ソケットオブジェクト
メソッドの詳細

getSocket

public Socket getSocket()
推奨されていません。
このオブジェクトの持つソケットオブジェクトを返します。 このメソッドから取得したソケットオブジェクトの入出力ストリームと このオブジェクト自身から取得した入出力ストリームを 同時に利用した場合、データ送受信の整合性が失われてしまう可能性が あります。

戻り値:
ソケットオブジェクト

getInputStream

public ExtendedInputStream getInputStream()
推奨されていません。
入力ストリームの取得。

戻り値:
入力ストリーム

getOutputStream

public ExtendedOutputStream getOutputStream()
推奨されていません。
出力ストリームの取得。

戻り値:
出力ストリーム

addCloseSocketEventListener

public void addCloseSocketEventListener(SocketEventListener listener)
推奨されていません。
ソケットをクローズしたイベントを通知するためのリスナーを 設定します。 このメソッドで追加したリスナーには、このソケットが クローズされたときに、そのソケットをメソッド引数として handleSocketEventメソッドが実行されます。

パラメータ:
listener - ソケットイベントリスナー
導入されたバージョン:
version 4.2

getCloseSocketEventListeners

public Collection getCloseSocketEventListeners()
推奨されていません。
このソケットに登録されているクローズ・イベント・リスナーを返します。 このメソッドの戻り値となる Collection の各要素は SocketEventListener 型オブジェクトです。

戻り値:
SocketEventListener を要素とする Collection
導入されたバージョン:
version 4.2

lastError

public Throwable lastError()
推奨されていません。
このインスタンスのメソッド中で最後に発生した例外を返します。

戻り値:
最後に発生した例外

clearError

public void clearError()
推奨されていません。
このインスタンスのメソッド実行中に発生した例外をすべて破棄します。

このメソッドを実行すると、次に例外が発生するまで lastError()メソッドは null を返し、 errorIterator()メソッドは空の反復子を返します。

導入されたバージョン:
version 4.0

errorIterator

public Iterator errorIterator()
推奨されていません。
このインスタンスのメソッド実行中に発生した例外を返します。 このメソッドの返す反復子は発生時間順に例外オブジェクトを返します。 反復子の返すオブジェクトは、Throwable クラスと代入互換のある オブジェクトになります。

戻り値:
例外の反復子

close

public void close()
           throws IOException
推奨されていません。
入出力ストリームおよびソケットを閉じます。
入出力ストリームを閉じる前にバッファに溜められているデータをすべて 出力ストリームに書き出します。

例外:
IOException - 入出力エラーが発生した場合

isClosed

public boolean isClosed()
推奨されていません。
このソケットが閉じられているかどうかをチェックします。

戻り値:
ソケットが閉じられている場合は true
導入されたバージョン:
version4.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Localhost (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
クラス Localhost

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.net.Localhost
すべての実装インタフェース:
Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.Localhost クラスを使用してください。

public class Localhost
extends Object
implements Serializable

このクラスは、サーバプロセスの基礎情報を管理します。

導入されたバージョン:
version 4.0
関連項目:
直列化された形式

メソッドの概要
byte[] | getAddress() 推奨されていません。 このコンピュータのＩＰアドレスを返します。
String | getHostAddress() 推奨されていません。 このコンピュータのアドレスを返します。
String | getHostName() 推奨されていません。 このコンピュータのホスト名を返します。
static Localhost | instance() 推奨されていません。 このクラスから生成される唯一のインスタンスを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

instance

public static Localhost instance()
推奨されていません。
このクラスから生成される唯一のインスタンスを返します。 このメソッドが返すインスタンスは、常に一定で、 VM 内で共有されます。

戻り値:
このクラスのインスタンス

getAddress

public byte[] getAddress()
推奨されていません。
このコンピュータのＩＰアドレスを返します。

戻り値:
IPアドレス

getHostAddress

public String getHostAddress()
推奨されていません。
このコンピュータのアドレスを返します。

戻り値:
アドレス

getHostName

public String getHostName()
推奨されていません。
このコンピュータのホスト名を返します。

戻り値:
ホスト名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.utility.net (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.utility.net
インタフェース
SocketConnectionDistributor
SocketConnectionManager
SocketEventListener
クラス
AbstractSocketConnectionDistributor
ExtendedSocket
Localhost
SocketConnection
SocketPool
例外
UnsupportedNetworkConnectException


jp.co.intra_mart.foundation.utility.net (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.net

ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

参照:
説明

インタフェースの概要
SocketConnectionDistributor | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor クラスを使用してください。
SocketConnectionManager | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager クラスを使用してください。
SocketEventListener | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener クラスを使用してください。

クラスの概要
AbstractSocketConnectionDistributor | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor クラスを使用してください。
ExtendedSocket | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket クラスを使用してください。
Localhost | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.Localhost クラスを使用してください。
SocketConnection | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。
SocketPool | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketPool クラスを使用してください。

例外の概要
UnsupportedNetworkConnectException 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException クラスを使用してください。

パッケージ jp.co.intra_mart.foundation.utility.net の説明

ソケットによるネットワーク対応機能を実装するためのクラスを提供します。


jp.co.intra_mart.foundation.utility.net クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.net の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor (implements jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor)
      • class jp.co.intra_mart.foundation.utility.net.SocketPool (implements jp.co.intra_mart.foundation.utility.net.SocketConnectionManager)
    • class jp.co.intra_mart.foundation.utility.net.ExtendedSocket
      • class jp.co.intra_mart.foundation.utility.net.SocketConnection
    • class jp.co.intra_mart.foundation.utility.net.Localhost (implements java.io.Serializable)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.io.IOException
          • class jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException

インタフェース階層

  • interface jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor
    • interface jp.co.intra_mart.foundation.utility.net.SocketConnectionManager
  • interface jp.co.intra_mart.foundation.utility.net.SocketEventListener


パッケージ jp.co.intra_mart.foundation.utility.net の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.utility.net の使用

jp.co.intra_mart.foundation.utility.net を使用しているパッケージ
jp.co.intra_mart.foundation.service.client | このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.client.batch | Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file | Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.manager | このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.utility.net | ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.service.client により使用される jp.co.intra_mart.foundation.utility.net のクラス
SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。
UnsupportedNetworkConnectException
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException クラスを使用してください。

jp.co.intra_mart.foundation.service.client.batch により使用される jp.co.intra_mart.foundation.utility.net のクラス
SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。

jp.co.intra_mart.foundation.service.client.file により使用される jp.co.intra_mart.foundation.utility.net のクラス
SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。

jp.co.intra_mart.foundation.service.client.information により使用される jp.co.intra_mart.foundation.utility.net のクラス
SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。

jp.co.intra_mart.foundation.service.client.manager により使用される jp.co.intra_mart.foundation.utility.net のクラス
SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。
SocketConnectionDistributor
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor クラスを使用してください。

jp.co.intra_mart.foundation.utility.net により使用される jp.co.intra_mart.foundation.utility.net のクラス
AbstractSocketConnectionDistributor
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor クラスを使用してください。
ExtendedSocket
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket クラスを使用してください。
Localhost
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.Localhost クラスを使用してください。
SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。
SocketConnectionDistributor
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor クラスを使用してください。
SocketConnectionManager
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager クラスを使用してください。
SocketEventListener
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SocketConnection (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
クラス SocketConnection

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.net.ExtendedSocket
        拡張 jp.co.intra_mart.foundation.utility.net.SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。

public abstract class SocketConnection
extends ExtendedSocket

ソケットプール用のスケルトン実装を提供します。

関連項目:
SocketPool

コンストラクタの概要
protected | SocketConnection(ExtendedSocket socket) 推奨されていません。 ソケット入出力インスタンスを構築します。
protected | SocketConnection(Socket socket) 推奨されていません。 ソケット入出力インスタンスを構築します。
protected | SocketConnection(String address, int port) 推奨されていません。 ソケット入出力インスタンスを構築します。
メソッドの概要
abstract  void release()
推奨されていません。 ソケットおよび入出力ストリームの利用を中止します。
クラス jp.co.intra_mart.foundation.utility.net.ExtendedSocket から継承したメソッド
addCloseSocketEventListener, clearError, close, errorIterator, getCloseSocketEventListeners, getInputStream, getOutputStream, getSocket, isClosed, lastError
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SocketConnection

protected SocketConnection(String address,
                           int port)
                    throws IOException
推奨されていません。
ソケット入出力インスタンスを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
address - 接続先アドレス
port - 接続先ポート
例外:
IOException - 入出力ストリームの作成時エラー

SocketConnection

protected SocketConnection(Socket socket)
                    throws IOException
推奨されていません。
ソケット入出力インスタンスを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
socket - ソケットオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー

SocketConnection

protected SocketConnection(ExtendedSocket socket)
                    throws IOException
推奨されていません。
ソケット入出力インスタンスを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
socket - ソケットオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー
メソッドの詳細

release

public abstract void release()
                      throws IOException
推奨されていません。
ソケットおよび入出力ストリームの利用を中止します。

このインスタンスの利用が終了したら、必ず呼び出して下さい。
このメソッドを呼び出さないと、プール領域中のリソースが完全には 開放されません。
また、スーパークラス ExtendedSocket の close メソッドを呼び出した場合も プール中のリソースが完全に開放されない可能性があります。

リソースの開放は、プールオブジェクトが必要に応じて行います。

例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SocketConnectionDistributor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
インタフェース SocketConnectionDistributor

既知のサブインタフェースの一覧:
SocketConnectionManager
既知の実装クラスの一覧:
AbstractSocketConnectionDistributor, SocketPool
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor クラスを使用してください。

public interface SocketConnectionDistributor

このクラスは、通信ソケットをプールする機能を提供します。

プール機能を利用することにより少ないソケットを複数のプログラムから 利用できるようになります。
このプールは、１つのインスタンスに付き１つの専用スレッドを持ちます。 プールは専用のスレッドにより管理され、一定時間に１つのコネクションが 順に破棄されていきます。したがって、コネクションを全く使用しないまま 長い時間が経過すると、このプール中にプールされているソケット・コネクションは ０個になります。

メソッドの概要
void | clean() 推奨されていません。 プール中のコネクションをすべて破棄します。
SocketConnection | connection() 推奨されていません。 コネクションの取得。
void | destroy() 推奨されていません。 このプールを破棄します。

メソッドの詳細

connection

public SocketConnection connection()
                            throws IOException
推奨されていません。
コネクションの取得。

プール中にコネクションが待機している場合にはプールの中から 待機中のコネクションを返却します。 プール中にコネクションが存在しない場合には、 新しいコネクションを生成して返します。

戻り値:
通信用インスタンス
例外:
IOException - ソケットの接続エラー
関連項目:
SocketConnection

destroy

public void destroy()
推奨されていません。
このプールを破棄します。

clean

public void clean()
推奨されていません。
プール中のコネクションをすべて破棄します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SocketConnectionManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
インタフェース SocketConnectionManager

すべてのスーパーインタフェース:
SocketConnectionDistributor
既知の実装クラスの一覧:
SocketPool
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager クラスを使用してください。

public interface SocketConnectionManager
extends SocketConnectionDistributor

通信ソケットをプールする機能のインターフェースです。

導入されたバージョン:
version 4.2

メソッドの概要
int | getCapacity() 推奨されていません。 コネクション作成最大数の取得。
int | getSize() 推奨されていません。 このプールが現在管理しているコネクション数です。
int | usableConnection() 推奨されていません。 現在待機中のコネクションをです。
インタフェース jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor から継承したメソッド
clean, connection, destroy

メソッドの詳細

getCapacity

public int getCapacity()
推奨されていません。
コネクション作成最大数の取得。

戻り値:
このプールにより作成されるコネクションの最大数

getSize

public int getSize()
推奨されていません。
このプールが現在管理しているコネクション数です。

この数は、最小が 0 で最大が getCapacity() メソッドにより得られる値の 間で変動します。

戻り値:
有効なコネクション数
導入されたバージョン:
version 4.2

usableConnection

public int usableConnection()
推奨されていません。
現在待機中のコネクションをです。

戻り値:
待機中のコネクション数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SocketEventListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
インタフェース SocketEventListener

推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener クラスを使用してください。

public interface SocketEventListener

通信ソケットに関するイベント発生を受け取るためのスケルトン実装です。

ソケットに関するイベント通知側と組み合わせて利用することにより、 ソケットに関する特定のイベント発生時に独自の処理を実行することができます。

メソッドの概要
 void handleSocketEvent(ExtendedSocket socket)
推奨されていません。 ソケットに関するイベント発生時に呼び出されるメソッド。

メソッドの詳細

handleSocketEvent

public void handleSocketEvent(ExtendedSocket socket)
                       throws IOException
推奨されていません。
ソケットに関するイベント発生時に呼び出されるメソッド。 サブクラスは、このメソッドを実装することにより、特定のソケットに関する イベントの発生を知ることができます。

パラメータ:
socket - イベントの発生したソケット
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SocketPool (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
クラス SocketPool

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor
        拡張 jp.co.intra_mart.foundation.utility.net.SocketPool
すべての実装インタフェース:
SocketConnectionDistributor, SocketConnectionManager
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketPool クラスを使用してください。

public class SocketPool
extends AbstractSocketConnectionDistributor
implements SocketConnectionManager

このクラスは、通信ソケットをプールする機能を提供します。

プール機能を利用することにより少ないソケットを複数のプログラムから 利用できるようになります。
このプールは、１つのインスタンスに付き１つの専用スレッドを持ちます。 プールは専用のスレッドにより管理され、一定時間に１つのコネクションが 順に破棄されていきます。したがって、コネクションを全く使用しないまま 長い時間が経過すると、このプール中にプールされているソケット・コネクションは ０個になります。

コンストラクタの概要
SocketPool(String address, int port)
推奨されていません。 ソケットプールを構築します。
SocketPool(String address, int port, int capacity)
推奨されていません。 ソケットプールを構築します。
メソッドの概要
void | addCloseSocketEventListener(SocketEventListener listener) 推奨されていません。 ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
void | addCreateSocketEventListener(SocketEventListener listener) 推奨されていません。 ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。
void | clean() 推奨されていません。 プール中のコネクションをすべて破棄します。
SocketConnection | connection() 推奨されていません。 コネクションの取得。
void | destroy() 推奨されていません。 このプールを破棄します。
boolean | eject(SocketConnection connection) 推奨されていません。 指定コネクションをこのプールの管理から切り離します。
protected void | finalize() 推奨されていません。 このオブジェクトへの参照はもうないとガーベージコレクションによって 判断されたときに、ガーベージコレクタによって呼び出されます。
int | getCapacity() 推奨されていません。 コネクション作成最大数の取得。
Collection | getCloseSocketEventListeners() 推奨されていません。 このプールに登録されている ソケットをクローズしたイベントを通知するためのリスナーを 返します。
Collection | getCreateSocketEventListeners() 推奨されていません。 このプールに登録されている ソケットを新規に作成したイベントを通知するためのリスナーを 返します。
int | getSize() 推奨されていません。 このプールが現在管理しているコネクション数です。
int | usableConnection() 推奨されていません。 現在待機中のコネクションをです。
クラス jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor から継承したメソッド
createSocket, getAddress, getPort
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SocketPool

public SocketPool(String address,
                  int port)
推奨されていません。
ソケットプールを構築します。

このプールで管理できるソケットコネクションは 1 個になります。

パラメータ:
address - 接続するサーバのアドレス
port - 接続するサーバがサービスを提供しているポート

SocketPool

public SocketPool(String address,
                  int port,
                  int capacity)
推奨されていません。
ソケットプールを構築します。

コネクションは動的に生成されます。 capacity 個よりも多くのコネクション要求があった場合、 コネクションが開放されるまで待ち状態になります。
capacity にはプールの性質上、 1 以上の値を指定して下さい。 capacity に 1 より小さな値を指定した場合、プール数は 1 になります。

パラメータ:
address - 接続するサーバのアドレス
port - 接続するサーバがサービスを提供しているポート
capacity - 接続コネクションの最大数
メソッドの詳細

addCreateSocketEventListener

public void addCreateSocketEventListener(SocketEventListener listener)
推奨されていません。
ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。 このメソッドで追加したリスナーには、このプールで新規にソケットが 作成されたときに、そのソケットをメソッド引数として handleSocketEventメソッドが実行されます。

パラメータ:
listener - ソケットイベントリスナー

getCreateSocketEventListeners

public Collection getCreateSocketEventListeners()
推奨されていません。
このプールに登録されている ソケットを新規に作成したイベントを通知するためのリスナーを 返します。 このメソッドの戻り値となる Collection の各要素は SocketEventListener 型オブジェクトです。

戻り値:
SocketEventListener を要素とする Collection

addCloseSocketEventListener

public void addCloseSocketEventListener(SocketEventListener listener)
推奨されていません。
ソケットをクローズしたイベントを通知するためのリスナーを 設定します。 このメソッドで追加したリスナーには、このプールのソケットが クローズされたときに、そのソケットをメソッド引数として handleSocketEventメソッドが実行されます。

パラメータ:
listener - ソケットイベントリスナー

getCloseSocketEventListeners

public Collection getCloseSocketEventListeners()
推奨されていません。
このプールに登録されている ソケットをクローズしたイベントを通知するためのリスナーを 返します。 このメソッドの戻り値となる Collection の各要素は SocketEventListener 型オブジェクトです。

戻り値:
SocketEventListener を要素とする Collection

getCapacity

public int getCapacity()
推奨されていません。
コネクション作成最大数の取得。

定義:
インタフェース SocketConnectionManager 内の getCapacity
戻り値:
このプールにより作成されるコネクションの最大数

getSize

public int getSize()
推奨されていません。
このプールが現在管理しているコネクション数です。

この数は、最小が 0 で最大が getCapacity() メソッドにより得られる値の 間で変動します。

定義:
インタフェース SocketConnectionManager 内の getSize
戻り値:
有効なコネクション数
導入されたバージョン:
version 4.2

usableConnection

public int usableConnection()
推奨されていません。
現在待機中のコネクションをです。

定義:
インタフェース SocketConnectionManager 内の usableConnection
戻り値:
待機中のコネクション数

connection

public SocketConnection connection()
                            throws IOException
推奨されていません。
コネクションの取得。

プール中にコネクションが待機している場合にはプールの中から 待機中のコネクションを返却します。 プール中にコネクションが存在しない場合には、 新しいコネクションを生成して返します。

定義:
インタフェース SocketConnectionDistributor 内の connection
戻り値:
通信用インスタンス
例外:
IOException - ソケットの接続エラー
関連項目:
SocketConnection

eject

public boolean eject(SocketConnection connection)
推奨されていません。
指定コネクションをこのプールの管理から切り離します。

指定コネクションがこのプールに管理されていたものなら、 このメソッド実行後はこのプールの管理するコネクションが１つ減少するので、 新たにコネクションを作成することができるようになります。

指定のコネクションをこのプールが管理していて他のスレッドによって 使用（connection() メソッドにより取得）されていない場合 true を 返します。指定のコネクションがこのプールにより管理されているもの であった場合でも、他のスレッドにより使用中の場合は false を返します。

パラメータ:
connection - 管理から切り離すコネクション
戻り値:
コネクションの切り離しに成功した場合 true

destroy

public void destroy()
推奨されていません。
このプールを破棄します。

定義:
インタフェース SocketConnectionDistributor 内の destroy

clean

public void clean()
推奨されていません。
プール中のコネクションをすべて破棄します。

定義:
インタフェース SocketConnectionDistributor 内の clean

finalize

protected void finalize()
                 throws Throwable
推奨されていません。
このオブジェクトへの参照はもうないとガーベージコレクションによって 判断されたときに、ガーベージコレクタによって呼び出されます。 SocketPool クラスは、このメソッドによりオブジェクトの破棄前に リソースのクリーンアップをします。

例外:
Throwable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UnsupportedNetworkConnectException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
クラス UnsupportedNetworkConnectException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.io.IOException
                拡張 jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException
すべての実装インタフェース:
Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException クラスを使用してください。

public class UnsupportedNetworkConnectException
extends IOException

関連項目:
直列化された形式

コンストラクタの概要
UnsupportedNetworkConnectException()
推奨されていません。 Constructor for UnsupportedNetworkConnectException.
UnsupportedNetworkConnectException(String arg0)
推奨されていません。 Constructor for UnsupportedNetworkConnectException.
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UnsupportedNetworkConnectException

public UnsupportedNetworkConnectException()
推奨されていません。
Constructor for UnsupportedNetworkConnectException.

UnsupportedNetworkConnectException

public UnsupportedNetworkConnectException(String arg0)
推奨されていません。
Constructor for UnsupportedNetworkConnectException.

パラメータ:
arg0 -
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter の使用

AbstractMessageReporter を使用しているパッケージ
jp.co.intra_mart.foundation.utility.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.report での AbstractMessageReporter の使用

jp.co.intra_mart.foundation.utility.report での AbstractMessageReporter のサブクラス
class | FileReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileReporter クラスを使用してください。
class | MultiCastReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter クラスを使用してください。
class | PrintStreamReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.EverydayConditioner の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.EverydayConditioner の使用

jp.co.intra_mart.foundation.utility.report.EverydayConditioner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.FileReporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.FileReporter の使用

jp.co.intra_mart.foundation.utility.report.FileReporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.FileSizeConditioner の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.FileSizeConditioner の使用

jp.co.intra_mart.foundation.utility.report.FileSizeConditioner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.FilterMessageReporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.FilterMessageReporter の使用

FilterMessageReporter を使用しているパッケージ
jp.co.intra_mart.foundation.utility.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.report での FilterMessageReporter の使用

jp.co.intra_mart.foundation.utility.report での FilterMessageReporter のサブクラス
class | LineReportFilter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter クラスを使用してください。
class | ReportLevelFilter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter クラスを使用してください。
class | RepresentativeReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.LineReportFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.LineReportFilter の使用

jp.co.intra_mart.foundation.utility.report.LineReportFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.report.MessageReporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.report.MessageReporter の使用

MessageReporter を使用しているパッケージ
jp.co.intra_mart.foundation.utility.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.report での MessageReporter の使用

MessageReporter を実装している jp.co.intra_mart.foundation.utility.report のクラス
class | AbstractMessageReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter クラスを使用してください。
class | FileReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileReporter クラスを使用してください。
class | FilterMessageReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter クラスを使用してください。
class | LineReportFilter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter クラスを使用してください。
class | MultiCastReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter クラスを使用してください。
class | PrintStreamReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter クラスを使用してください。
class | ReportLevelFilter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter クラスを使用してください。
class | RepresentativeReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter クラスを使用してください。

MessageReporter として宣言されている jp.co.intra_mart.foundation.utility.report のフィールド
protected  MessageReporter FilterMessageReporter.out
推奨されていません。 基礎出力ストリームです。

MessageReporter 型のパラメータを持つ jp.co.intra_mart.foundation.utility.report のメソッド
void | MultiCastReporter.addReporter(MessageReporter reporter) 推奨されていません。 指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。
boolean | MultiCastReporter.hasReporter(MessageReporter reporter) 推奨されていません。 指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。
boolean | MultiCastReporter.removeReporter(MessageReporter reporter) 推奨されていません。 指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。

MessageReporter 型のパラメータを持つ jp.co.intra_mart.foundation.utility.report のコンストラクタ
RepresentativeReporter(MessageReporter out, EventQueueController queue)
推奨されていません。 指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。
ReportLevelFilter(MessageReporter out, int level)
推奨されていません。 指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。
LineReportFilter(MessageReporter out)
推奨されていません。 指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。
FilterMessageReporter(MessageReporter out)
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.MultiCastReporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.MultiCastReporter の使用

jp.co.intra_mart.foundation.utility.report.MultiCastReporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner の使用

jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.PeriodicConditioner の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.PeriodicConditioner の使用

jp.co.intra_mart.foundation.utility.report.PeriodicConditioner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.PrintStreamReporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.PrintStreamReporter の使用

jp.co.intra_mart.foundation.utility.report.PrintStreamReporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.report.ReportFileConditioner の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.report.ReportFileConditioner の使用

ReportFileConditioner を使用しているパッケージ
jp.co.intra_mart.foundation.utility.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.report での ReportFileConditioner の使用

ReportFileConditioner を実装している jp.co.intra_mart.foundation.utility.report のクラス
class | EverydayConditioner 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner クラスを使用してください。
class | FileSizeConditioner 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner クラスを使用してください。
class | OutputSizeConditioner 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner クラスを使用してください。
class | PeriodicConditioner 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner クラスを使用してください。

ReportFileConditioner 型のパラメータを持つ jp.co.intra_mart.foundation.utility.report のメソッド
void | FileReporter.addConditioner(ReportFileConditioner conditioner) 推奨されていません。 ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
boolean | FileReporter.removeConditioner(ReportFileConditioner conditioner) 推奨されていません。 ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.ReportFileWriter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.ReportFileWriter の使用

ReportFileWriter を使用しているパッケージ
jp.co.intra_mart.foundation.utility.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.report での ReportFileWriter の使用

ReportFileWriter として宣言されている jp.co.intra_mart.foundation.utility.report のフィールド
protected  ReportFileWriter FileReporter.out
推奨されていません。 基礎出力ストリームです。

ReportFileWriter 型のパラメータを持つ jp.co.intra_mart.foundation.utility.report のメソッド
boolean | ReportFileConditioner.expiration(ReportFileWriter writer) 推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
boolean | PeriodicConditioner.expiration(ReportFileWriter writer) 推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
boolean | OutputSizeConditioner.expiration(ReportFileWriter writer) 推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
boolean | FileSizeConditioner.expiration(ReportFileWriter writer) 推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
boolean | EverydayConditioner.expiration(ReportFileWriter writer) 推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。

ReportFileWriter 型のパラメータを持つ jp.co.intra_mart.foundation.utility.report のコンストラクタ
FileReporter(ReportFileWriter out)
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.report.ReportLevel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.report.ReportLevel の使用

ReportLevel を使用しているパッケージ
jp.co.intra_mart.foundation.utility.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.report での ReportLevel の使用

ReportLevel を実装している jp.co.intra_mart.foundation.utility.report のクラス
 class ReportLevelFilter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.ReportLevelFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.ReportLevelFilter の使用

jp.co.intra_mart.foundation.utility.report.ReportLevelFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.RepresentativeReporter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.RepresentativeReporter の使用

jp.co.intra_mart.foundation.utility.report.RepresentativeReporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AbstractMessageReporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス AbstractMessageReporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter
すべての実装インタフェース:
MessageReporter
直系の既知のサブクラス:
FileReporter, MultiCastReporter, PrintStreamReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter クラスを使用してください。

public abstract class AbstractMessageReporter
extends Object
implements MessageReporter

メッセージ出力用のスケルトンクラスです。

サブクラスでは、report メソッドをオーバーライドして、 任意の出力先にメッセージを出力する機能を実装する必要があります。

導入されたバージョン:
version 3.2

コンストラクタの概要
protected AbstractMessageReporter()
推奨されていません。 唯一のコンストラクタ。
メソッドの概要
void | close() 推奨されていません。 このオブジェクトを閉じます。
void | flush() 推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
void | report(Object data) 推奨されていません。 data をメッセージとして出力します。
abstract void | report(String message) 推奨されていません。 メッセージを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractMessageReporter

protected AbstractMessageReporter()
推奨されていません。
唯一のコンストラクタ。

メソッドの詳細

report

public abstract void report(String message)
推奨されていません。
メッセージを出力します。

定義:
インタフェース MessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
推奨されていません。
data をメッセージとして出力します。
このメソッドは、以下の呼出と同じです。

report(String.valueOf(data))

定義:
インタフェース MessageReporter 内の report
パラメータ:
data - データ

close

public void close()
           throws IOException
推奨されていません。
このオブジェクトを閉じます。 オブジェクトが閉じられると、report メソッドは何もしなくなります。 必要に応じてサブクラスでオーバーライドしてください。

定義:
インタフェース MessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
推奨されていません。
このオブジェクトのバッファの情報をすべて出力します。 このメソッドは、何も行いません。 必要に応じてサブクラスでオーバーライドしてください。

定義:
インタフェース MessageReporter 内の flush
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EverydayConditioner (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス EverydayConditioner

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.EverydayConditioner
すべての実装インタフェース:
ReportFileConditioner
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner クラスを使用してください。

public class EverydayConditioner
extends Object
implements ReportFileConditioner

このクラスは、時間によりリフレッシュイベントを 発生させるためのヘルパークラスです。
このクラスは、FileReporter と組み合わせて利用します。 このクラスのオブジェクトを FileReporter オブジェクトにセットすることで、 指定時間になった(指定時間を経過した)ときに、 メッセージファイルのローテイト機能イベントを発生させることができます。 時間のチェックは時および分によるものなので、FileReporter の中で リフレッシュイベントは毎日発生することになります。

導入されたバージョン:
version 3.2
関連項目:
FileReporter, ReportFileWriter

コンストラクタの概要
EverydayConditioner(int hours, int minutes)
推奨されていません。 毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
EverydayConditioner(int hours, int minutes, TimeZone timeZone)
推奨されていません。 毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
メソッドの概要
 boolean expiration(ReportFileWriter writer)
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EverydayConditioner

public EverydayConditioner(int hours,
                           int minutes,
                           TimeZone timeZone)
                    throws IllegalArgumentException
推奨されていません。
毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
このオブジェクトは、毎日指定された時刻に なった場合にリフレッシュイベント発生を通知します。
時刻の計算は、指定されたタイムゾーンに基づきます。

パラメータ:
hours - 時間(0 ～ 23)
minutes - 分(0 ～ 59)
timeZone - タイムゾーン
例外:
IllegalArgumentException - 引数が有効範囲外の場合

EverydayConditioner

public EverydayConditioner(int hours,
                           int minutes)
                    throws IllegalArgumentException
推奨されていません。
毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
このオブジェクトは、毎日指定された時刻に なった場合にリフレッシュイベント発生を通知します。
時刻の計算は、デフォルトタイムゾーンに基づきます。

パラメータ:
hours - 時間(0 ～ 23)
minutes - 分(0 ～ 59)
例外:
IllegalArgumentException - 引数が有効範囲外の場合
メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
推奨されていません。
メッセージファイルを再作成する必要があるかどうかを判定します。
このオブジェクトの作成時に指定された時刻を経過して最初の呼び出し時 の場合 true を返します。

定義:
インタフェース ReportFileConditioner 内の expiration
パラメータ:
writer - 出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
関連項目:
FileReporter, ReportFileWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FileReporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス FileReporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter
        拡張 jp.co.intra_mart.foundation.utility.report.FileReporter
すべての実装インタフェース:
MessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileReporter クラスを使用してください。

public class FileReporter
extends AbstractMessageReporter

メッセージのファイル出力機能を提供します。

このクラスは、report メソッドで渡されたメッセージを指定のファイルに 出力します。

導入されたバージョン:
version 3.2

フィールドの概要
protected  ReportFileWriter out
推奨されていません。 基礎出力ストリームです。
コンストラクタの概要
FileReporter(ReportFileWriter out)
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
メソッドの概要
void | addConditioner(ReportFileConditioner conditioner) 推奨されていません。 ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
void | close() 推奨されていません。 このオブジェクトを閉じます。
protected void | finalize() 推奨されていません。 このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
void | flush() 推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
boolean | removeConditioner(ReportFileConditioner conditioner) 推奨されていません。 ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。
void | report(String message) 推奨されていません。 メッセージを出力します。
クラス jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter から継承したメソッド
report
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

out

protected ReportFileWriter out
推奨されていません。
基礎出力ストリームです。

コンストラクタの詳細

FileReporter

public FileReporter(ReportFileWriter out)
推奨されていません。
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。

パラメータ:
out - 基礎出力ストリーム
メソッドの詳細

addConditioner

public void addConditioner(ReportFileConditioner conditioner)
推奨されていません。
ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
引数が null の場合は、何の効果もありません。 また、conditioner が既に登録済みのインスタンスである場合、 追加登録はされません。

パラメータ:
conditioner - 追加する ReportFileConditioner のインスタンス

removeConditioner

public boolean removeConditioner(ReportFileConditioner conditioner)
推奨されていません。
ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。
引数が null の場合は、何の効果もありません。

パラメータ:
conditioner - 削除する ReportFileConditioner のインスタンス
戻り値:
指定のオブジェクトを削除できた場合 true。

report

public void report(String message)
推奨されていません。
メッセージを出力します。 このオブジェクトが既に閉じられている場合、このメソッドは 何も行いません。

定義:
インタフェース MessageReporter 内の report
定義:
クラス AbstractMessageReporter 内の report
パラメータ:
message - メッセージ

close

public void close()
           throws IOException
推奨されていません。
このオブジェクトを閉じます。 このオブジェクトに関わる全てのリソースを開放します。 オブジェクトが閉じられると、report メソッドは何もしなくなります。

定義:
インタフェース MessageReporter 内の close
オーバーライド:
クラス AbstractMessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
推奨されていません。
このオブジェクトのバッファの情報をすべて出力します。 また、このメソッドは基礎ストリームも同時にフラッシュします。

定義:
インタフェース MessageReporter 内の flush
オーバーライド:
クラス AbstractMessageReporter 内の flush
例外:
IOException - 入出力エラー

finalize

protected void finalize()
                 throws Throwable
推奨されていません。
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
このオブジェクトの全てのリソースを破棄します。

例外:
Throwable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FileSizeConditioner (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス FileSizeConditioner

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.FileSizeConditioner
すべての実装インタフェース:
ReportFileConditioner
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner クラスを使用してください。

public class FileSizeConditioner
extends Object
implements ReportFileConditioner

このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
このクラスは、FileReporter と組み合わせて利用します。 このクラスのオブジェクトを FileReporter オブジェクトにセットすることで、 メッセージファイルが一定サイズ以上になったときに、 メッセージファイルのローテイト機能イベントを発生させることができます。

導入されたバージョン:
version 3.2
関連項目:
FileReporter, ReportFileWriter

コンストラクタの概要
FileSizeConditioner(long max)
推奨されていません。 メッセージファイルのサイズによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
メソッドの概要
 boolean expiration(ReportFileWriter writer)
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FileSizeConditioner

public FileSizeConditioner(long max)
                    throws IllegalArgumentException
推奨されていません。
メッセージファイルのサイズによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
このオブジェクトは、メッセージファイルが指定の大きさ(max)以上に なった場合にリフレッシュイベント発生を通知します。

例外:
IllegalArgumentException - max がゼロ以下の場合
メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
推奨されていません。
メッセージファイルを再作成する必要があるかどうかを判定します。
ファイルサイズが、このオブジェクトの作成時に指定された 値以上の場合 true を返します。

定義:
インタフェース ReportFileConditioner 内の expiration
パラメータ:
writer - 出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
関連項目:
FileReporter, ReportFileWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FilterMessageReporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス FilterMessageReporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.FilterMessageReporter
すべての実装インタフェース:
MessageReporter
直系の既知のサブクラス:
LineReportFilter, ReportLevelFilter, RepresentativeReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter クラスを使用してください。

public class FilterMessageReporter
extends Object
implements MessageReporter

メッセージ出力ストリームをフィルタ処理するクラスのスーパークラスです。

基礎出力ストリームにメッセージを出力する前にメッセージを加工したりする 追加機能を提供するクラスを作成するために利用することができます。

このクラスは、単に MessageReporter の全てのメソッドを オーバーライドし、各要求を基礎出力ストリームに渡す機能を提供しています。 サブクラスでは、メソッドを追加したり、必要に応じてメソッドをオーバーライド することがあります。

導入されたバージョン:
version 3.2

フィールドの概要
protected  MessageReporter out
推奨されていません。 基礎出力ストリームです。
コンストラクタの概要
FilterMessageReporter(MessageReporter out)
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。
メソッドの概要
void | close() 推奨されていません。 このオブジェクトを閉じます。
void | flush() 推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
void | report(Object data) 推奨されていません。 基礎出力ストリームに対してメッセージを出力します。
void | report(String message) 推奨されていません。 基礎出力ストリームに対してメッセージを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

out

protected MessageReporter out
推奨されていません。
基礎出力ストリームです。

コンストラクタの詳細

FilterMessageReporter

public FilterMessageReporter(MessageReporter out)
推奨されていません。
指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。

パラメータ:
out - 基礎出力リポーター
メソッドの詳細

report

public void report(String message)
推奨されていません。
基礎出力ストリームに対してメッセージを出力します。
このメソッドは、単純に message を基礎出力ストリームに渡します。 サブクラスで、このメソッドをオーバーライドすることにより、 データの加工などのフィルタリング処理を追加することができます。

定義:
インタフェース MessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
推奨されていません。
基礎出力ストリームに対してメッセージを出力します。
このメソッドは、単純に data を基礎出力ストリームに渡します。 サブクラスで、このメソッドをオーバーライドすることにより、 データの加工などのフィルタリング処理を追加することができます。

定義:
インタフェース MessageReporter 内の report
パラメータ:
data - データ

close

public void close()
           throws IOException
推奨されていません。
このオブジェクトを閉じます。 オブジェクトが閉じられると、report メソッドは何もしなくなります。

定義:
インタフェース MessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
推奨されていません。
このオブジェクトのバッファの情報をすべて出力します。 このメソッドでは、基礎出力リポートオブジェクトも同時にフラッシュします。

定義:
インタフェース MessageReporter 内の flush
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LineReportFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス LineReportFilter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.FilterMessageReporter
        拡張 jp.co.intra_mart.foundation.utility.report.LineReportFilter
すべての実装インタフェース:
MessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter クラスを使用してください。

public class LineReportFilter
extends FilterMessageReporter

メッセージを行出力するためのフィルタークラスです。

このクラスを利用すると、report メソッドに渡されたメッセージ文字列に 改行コードを付加して、行出力することができます。
以下のようなプログラムにより、ログファイルをログファイルを作成することが できます。

FIle logFile = new File("test.log");
ReportFileWriter writer = new ReportFileWriter(logFile);
FileReporter writer = new FileReporter(writer);
MessageReporter reporter = new LineReportFilter(writer);
これで、変数 reporter の report メソッドを呼び出す毎に、 ファイル test.log に report メソッド指定したメッセージが １行として出力されます。

導入されたバージョン:
version 3.2
関連項目:
ReportLevel

フィールドの概要
クラス jp.co.intra_mart.foundation.utility.report.FilterMessageReporter から継承したフィールド
out
コンストラクタの概要
LineReportFilter(MessageReporter out)
推奨されていません。 指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。
メソッドの概要
void | report(Object data) 推奨されていません。 基礎出力ストリームに対してメッセージを出力します。
void | report(String message) 推奨されていません。 メッセージを出力します。
クラス jp.co.intra_mart.foundation.utility.report.FilterMessageReporter から継承したメソッド
close, flush
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LineReportFilter

public LineReportFilter(MessageReporter out)
推奨されていません。
指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。

パラメータ:
out - 基礎出力ストリーム
メソッドの詳細

report

public void report(String message)
推奨されていません。
メッセージを出力します。
このメソッドは、基礎出力ストリームに対して、message に 改行コードを付加してメッセージを１行出力します。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
推奨されていません。
基礎出力ストリームに対してメッセージを出力します。
このメソッドは、単純に data を基礎出力ストリームに渡します。 サブクラスで、このメソッドをオーバーライドすることにより、 データの加工などのフィルタリング処理を追加することができます。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
data - データ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MessageReporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
インタフェース MessageReporter

既知の実装クラスの一覧:
AbstractMessageReporter, FilterMessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter クラスを使用してください。

public interface MessageReporter

メッセージ出力のためのインターフェースです。

このインターフェースを実装したクラスでは、report メソッドで 指定されたメッセージを任意の出力先に対して出力する機能を提供します。

導入されたバージョン:
version 3.2

メソッドの概要
void | close() 推奨されていません。 このオブジェクトを閉じます。
void | flush() 推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
void | report(Object data) 推奨されていません。 data をメッセージとして出力します。
void | report(String message) 推奨されていません。 メッセージを出力します。

メソッドの詳細

report

public void report(String message)
推奨されていません。
メッセージを出力します。

パラメータ:
message - メッセージ

report

public void report(Object data)
推奨されていません。
data をメッセージとして出力します。

パラメータ:
data - データ

close

public void close()
           throws IOException
推奨されていません。
このオブジェクトを閉じます。 オブジェクトが閉じられると、report メソッドは何もしなくなります。 このメソッドは、任意のオペレーションです。

例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
推奨されていません。
このオブジェクトのバッファの情報をすべて出力します。 このメソッドは、任意のオペレーションです。

例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MultiCastReporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス MultiCastReporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter
        拡張 jp.co.intra_mart.foundation.utility.report.MultiCastReporter
すべての実装インタフェース:
MessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter クラスを使用してください。

public class MultiCastReporter
extends AbstractMessageReporter

メッセージを複数のストリームに出力するためのフィルタークラスです。

このクラスは、MessageReporter インターフェースを実装したクラスに対する フィルタークラスとして働きます。 report メソッドに渡されたメッセージデータは、指定された複数の MessageReporter インターフェースすべてに渡されます。
このフィルタークラスを利用することにより、複数の MessageReporter に 対して同じメッセージを渡すことができるため、メッセージ出力プログラムを 効率的に記述することができます。

メッセージの出力先となる MessageReporter は、addReporter メソッドで 定義します。addReporter メソッドでの定義順と、実際の実行順は 保証されません。

導入されたバージョン:
version 3.2

コンストラクタの概要
MultiCastReporter()
推奨されていません。 唯一のコンストラクタ。
メソッドの概要
void | addReporter(MessageReporter reporter) 推奨されていません。 指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。
void | close() 推奨されていません。 このオブジェクトを閉じます。
void | flush() 推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
Iterator | getReporters() 推奨されていません。 セット内の要素についての反復子を返します。
boolean | hasReporter(MessageReporter reporter) 推奨されていません。 指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。
boolean | removeReporter(MessageReporter reporter) 推奨されていません。 指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。
void | report(Object data) 推奨されていません。 data をメッセージとして出力します。
void | report(String message) 推奨されていません。 メッセージを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MultiCastReporter

public MultiCastReporter()
推奨されていません。
唯一のコンストラクタ。

メソッドの詳細

addReporter

public void addReporter(MessageReporter reporter)
推奨されていません。
指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。 すでに指定のオブジェクトを要素としてもっていた場合、 このメソッドは何も行いません。

パラメータ:
reporter - セットに追加される要素

hasReporter

public boolean hasReporter(MessageReporter reporter)
推奨されていません。
指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。

パラメータ:
reporter - セットに含まれているかチェックする要素
戻り値:
セット内に指定された要素がある場合は true

removeReporter

public boolean removeReporter(MessageReporter reporter)
推奨されていません。
指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。

パラメータ:
reporter - セットにあった場合に削除されるオブジェクト
戻り値:
指定された要素がセット内にあった場合は true

getReporters

public Iterator getReporters()
推奨されていません。
セット内の要素についての反復子を返します。 反復子から取得される各要素は、addReporter メソッドにより追加された リポーターオブジェクトになります。 各要素の取得順は保証されません。 このオブジェクトが閉じられている場合 null を返します。

戻り値:
セット内の要素についての反復子

report

public void report(String message)
推奨されていません。
メッセージを出力します。

定義:
インタフェース MessageReporter 内の report
定義:
クラス AbstractMessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
推奨されていません。
data をメッセージとして出力します。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス AbstractMessageReporter 内の report
パラメータ:
data - データ

close

public void close()
           throws IOException
推奨されていません。
このオブジェクトを閉じます。 オブジェクトが閉じられると、report メソッドは何もしなくなります。 このオブジェクトの持つすべての Reporter オブジェクトを閉じて、 リソースを開放します。

定義:
インタフェース MessageReporter 内の close
オーバーライド:
クラス AbstractMessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
推奨されていません。
このオブジェクトのバッファの情報をすべて出力します。 このメソッドは、何も行いません。 このオブジェクトの持つすべての Reporter オブジェクトをフラッシュします。

定義:
インタフェース MessageReporter 内の flush
オーバーライド:
クラス AbstractMessageReporter 内の flush
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


OutputSizeConditioner (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス OutputSizeConditioner

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner
すべての実装インタフェース:
ReportFileConditioner
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner クラスを使用してください。

public class OutputSizeConditioner
extends Object
implements ReportFileConditioner

このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
このクラスは、FileReporter と組み合わせて利用します。 このクラスのオブジェクトを FileReporter オブジェクトにセットすることで、 メッセージファイルが一定サイズ以上になったときに、 メッセージファイルのローテイト機能イベントを発生させることができます。

導入されたバージョン:
version 3.2
関連項目:
FileReporter, ReportFileWriter

コンストラクタの概要
OutputSizeConditioner(long max)
推奨されていません。 メッセージファイルへのデータ出力量によりリフレッシュイベントを 発生させるためのヘルパーオブジェクトを構築します。
メソッドの概要
 boolean expiration(ReportFileWriter writer)
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

OutputSizeConditioner

public OutputSizeConditioner(long max)
                      throws IllegalArgumentException
推奨されていません。
メッセージファイルへのデータ出力量によりリフレッシュイベントを 発生させるためのヘルパーオブジェクトを構築します。
このオブジェクトは、ログファイルへ書き出したメッセージの量が 一定(max)以上の大きさに なった場合にリフレッシュイベント発生を通知します。

例外:
IllegalArgumentException - max がゼロ以下の場合
メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
推奨されていません。
メッセージファイルを再作成する必要があるかどうかを判定します。
ファイルへの出力文字数が、このオブジェクトの作成時に指定された 値以上の場合 true を返します。

定義:
インタフェース ReportFileConditioner 内の expiration
パラメータ:
writer - 出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
関連項目:
FileReporter, ReportFileWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.utility.report (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.utility.report
インタフェース
MessageReporter
ReportFileConditioner
ReportLevel
クラス
AbstractMessageReporter
EverydayConditioner
FileReporter
FileSizeConditioner
FilterMessageReporter
LineReportFilter
MultiCastReporter
OutputSizeConditioner
PeriodicConditioner
PrintStreamReporter
ReportFileWriter
ReportLevelFilter
RepresentativeReporter


jp.co.intra_mart.foundation.utility.report (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.report

このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

参照:
説明

インタフェースの概要
MessageReporter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter クラスを使用してください。
ReportFileConditioner | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner クラスを使用してください。
ReportLevel | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel クラスを使用してください。

クラスの概要
AbstractMessageReporter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter クラスを使用してください。
EverydayConditioner | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner クラスを使用してください。
FileReporter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileReporter クラスを使用してください。
FileSizeConditioner | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner クラスを使用してください。
FilterMessageReporter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter クラスを使用してください。
LineReportFilter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter クラスを使用してください。
MultiCastReporter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter クラスを使用してください。
OutputSizeConditioner | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner クラスを使用してください。
PeriodicConditioner | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner クラスを使用してください。
PrintStreamReporter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter クラスを使用してください。
ReportFileWriter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter クラスを使用してください。
ReportLevelFilter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter クラスを使用してください。
RepresentativeReporter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter クラスを使用してください。

パッケージ jp.co.intra_mart.foundation.utility.report の説明

このパッケージには、ログ機能を実装するための汎用クラスが含まれています。


jp.co.intra_mart.foundation.utility.report クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.report の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter (implements jp.co.intra_mart.foundation.utility.report.MessageReporter)
      • class jp.co.intra_mart.foundation.utility.report.FileReporter
      • class jp.co.intra_mart.foundation.utility.report.MultiCastReporter
      • class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter
    • class jp.co.intra_mart.foundation.utility.report.EverydayConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.utility.report.FileSizeConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter (implements jp.co.intra_mart.foundation.utility.report.MessageReporter)
      • class jp.co.intra_mart.foundation.utility.report.LineReportFilter
      • class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter (implements jp.co.intra_mart.foundation.utility.report.ReportLevel)
      • class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter
    • class jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.utility.report.PeriodicConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class java.io.Writer
      • class jp.co.intra_mart.foundation.utility.report.ReportFileWriter

インタフェース階層

  • interface jp.co.intra_mart.foundation.utility.report.MessageReporter
  • interface jp.co.intra_mart.foundation.utility.report.ReportFileConditioner
  • interface jp.co.intra_mart.foundation.utility.report.ReportLevel


パッケージ jp.co.intra_mart.foundation.utility.report の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.utility.report の使用

jp.co.intra_mart.foundation.utility.report を使用しているパッケージ
jp.co.intra_mart.foundation.utility.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.report により使用される jp.co.intra_mart.foundation.utility.report のクラス
AbstractMessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter クラスを使用してください。
FilterMessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter クラスを使用してください。
MessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter クラスを使用してください。
ReportFileConditioner
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner クラスを使用してください。
ReportFileWriter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter クラスを使用してください。
ReportLevel
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PeriodicConditioner (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス PeriodicConditioner

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.PeriodicConditioner
すべての実装インタフェース:
ReportFileConditioner
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner クラスを使用してください。

public class PeriodicConditioner
extends Object
implements ReportFileConditioner

このクラスは、タイマーによりリフレッシュイベントを 発生させるためのヘルパークラスです。
このクラスは、FileReporter と組み合わせて利用します。 このクラスのオブジェクトを FileReporter オブジェクトにセットすることで、 一定期間の経過に合わせてに、 メッセージファイルのローテイト機能イベントを発生させることができます。

導入されたバージョン:
version 3.2
関連項目:
FileReporter, ReportFileWriter

コンストラクタの概要
PeriodicConditioner(long millis)
推奨されていません。 タイマーによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
メソッドの概要
 boolean expiration(ReportFileWriter writer)
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PeriodicConditioner

public PeriodicConditioner(long millis)
                    throws IllegalArgumentException
推奨されていません。
タイマーによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
このオブジェクトは、指定の時間が経過した時に リフレッシュイベント発生を通知します。

例外:
IllegalArgumentException - millis がゼロ以下の場合
メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
推奨されていません。
メッセージファイルを再作成する必要があるかどうかを判定します。
引数 outputSize の値が、このオブジェクトの作成時に指定された 値以上の場合 true を返します。

定義:
インタフェース ReportFileConditioner 内の expiration
パラメータ:
writer - 出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
関連項目:
FileReporter, ReportFileWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PrintStreamReporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス PrintStreamReporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter
        拡張 jp.co.intra_mart.foundation.utility.report.PrintStreamReporter
すべての実装インタフェース:
MessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter クラスを使用してください。

public class PrintStreamReporter
extends AbstractMessageReporter

メッセージ出力用クラスです。

このクラスは、指定の PrintStream に対してメッセージを出力するための 機能を実装しています。 例えば、このクラスのコンストラクタの引数に java.lang.System.out を指定した 場合、標準出力に対してメッセージを出力することができます。
このクラスの特徴は、report メソッドに渡されたメッセージを PrintStream の println メソッドに渡します。 これにより、report メソッドの呼び出し毎にメッセージを改行付きで 指定の PrintStream に出力することができます（１行毎に出力）。

導入されたバージョン:
version 3.2

コンストラクタの概要
PrintStreamReporter(PrintStream out)
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
メソッドの概要
void | close() 推奨されていません。 このオブジェクトを閉じます。
void | flush() 推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
void | report(String message) 推奨されていません。 メッセージを出力します。
クラス jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter から継承したメソッド
report
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PrintStreamReporter

public PrintStreamReporter(PrintStream out)
推奨されていません。
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。

パラメータ:
out - 基礎出力ストリーム
メソッドの詳細

report

public void report(String message)
推奨されていません。
メッセージを出力します。 このオブジェクトが既に閉じられている場合、このメソッドは 何も行いません。

定義:
インタフェース MessageReporter 内の report
定義:
クラス AbstractMessageReporter 内の report
パラメータ:
message - メッセージ

close

public void close()
           throws IOException
推奨されていません。
このオブジェクトを閉じます。 このオブジェクトに関わる全てのリソースを開放します。 オブジェクトが閉じられると、report メソッドは何もしなくなります。

定義:
インタフェース MessageReporter 内の close
オーバーライド:
クラス AbstractMessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
推奨されていません。
このオブジェクトのバッファの情報をすべて出力します。 また、このメソッドは基礎ストリームも同時にフラッシュします。

定義:
インタフェース MessageReporter 内の flush
オーバーライド:
クラス AbstractMessageReporter 内の flush
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReportFileConditioner (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
インタフェース ReportFileConditioner

既知の実装クラスの一覧:
EverydayConditioner, FileSizeConditioner, OutputSizeConditioner, PeriodicConditioner
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner クラスを使用してください。

public interface ReportFileConditioner

このクラスは、ReportFileWriter の初期化チェックのインターフェースです。

このクラスは FileReporter クラスにより ReportFileWriter へのメッセージ 書き出し前に呼び出されます。
このクラスは、FileReporter および ReportFileWriter オブジェクトと 組み合わせて使います。 これらのクラスと連携することにより、メッセージファイルの ローテイト機能などを実装することができます。

導入されたバージョン:
version 3.2

メソッドの概要
 boolean expiration(ReportFileWriter writer)
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。

メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
推奨されていません。
メッセージファイルを再作成する必要があるかどうかを判定します。
このメソッドは、FileReporter クラスにより呼び出されます。 真値(true)を返すと、ReportFileWriter は現在のログファイルに対して 初期化処理を行います。 メッセージファイルの初期化処理に関しては、 ReportFileWriter クラス(または、そのサブクラス)により行われます。

パラメータ:
writer - メッセージファイルへの出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReportFileWriter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス ReportFileWriter

java.lang.Object
    拡張 java.io.Writer
        拡張 jp.co.intra_mart.foundation.utility.report.ReportFileWriter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter クラスを使用してください。

public class ReportFileWriter
extends Writer

メッセージをファイルに出力するストリームクラスです。

このクラスは、メッセージを指定のファイルに対して出力するための スケルトンです。 また、このクラスは reset メソッドをオーバーライドすることにより、 ファイルのローテイト機能などを実装することができます。

導入されたバージョン:
version 3.2

フィールドの概要
クラス java.io.Writer から継承したフィールド
lock
コンストラクタの概要
ReportFileWriter(File f)
推奨されていません。 ファイルへメッセージを書き出すためのライターオブジェクトを作成します。
メソッドの概要
void | close() 推奨されていません。 ストリームを閉じてフラッシュします。
protected Writer | createWriter() 推奨されていません。 メッセージをファイルへ書き出すための出力ストリームを作成します。
Writer | currentWriter() 推奨されていません。 このオブジェクトが文字を書き出している基礎 Writer を返します。
protected void | finalize() 推奨されていません。 このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
void | flush() 推奨されていません。 ストリームをフラッシュします。
File | getFile() 推奨されていません。 このオブジェクトが文字を書き出すファイルを取得します。
long | length() 推奨されていません。 このライターの出力文字数を取得します。
protected void | reconstruction() 推奨されていません。 現在使用中の Writer をリセットします。
protected Writer | reset(Writer writer) 推奨されていません。 文字の出力ストリームをリセットします。
void | write(char[] cbuf, int off, int len) 推奨されていません。 基礎ストリームに文字を出力します。
クラス java.io.Writer から継承したメソッド
write, write, write, write
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ReportFileWriter

public ReportFileWriter(File f)
                 throws IOException
推奨されていません。
ファイルへメッセージを書き出すためのライターオブジェクトを作成します。

パラメータ:
f - このライターで書き出すファイル
例外:
IOException - 入出力エラー
メソッドの詳細

getFile

public File getFile()
推奨されていません。
このオブジェクトが文字を書き出すファイルを取得します。
このメソッドは、このオブジェクトの作成時にコンストラクタの引数として 与えられた File オブジェクトへの参照を返します。

戻り値:
このライターで書き出すファイル

createWriter

protected Writer createWriter()
                       throws IOException
推奨されていません。
メッセージをファイルへ書き出すための出力ストリームを作成します。

このメソッドは、単に getFile メソッドが返すファイルに対して 文字を書き出すための出力ストリームを作成して返します。 このメソッドの返す出力ストリームを使うことで、 getFile メソッドの返す ファイルに対してメッセージを追記していくことができます。
メッセージを任意の文字コードに変換したり、出力バッファを備えた Writer オブジェクトを作成する必要がある場合には、サブクラスで このメソッドをオーバーライドして実装して下さい。

戻り値:
出力ストリーム
例外:
IOException

length

public long length()
推奨されていません。
このライターの出力文字数を取得します。
このメソッドで返される文字数は、このファイルに対して 現在までに出力した文字数です。 文字数カウンタは、reset メソッドを実行することにより 0 (ゼロ)にリセットされます。

戻り値:
出力文字数

currentWriter

public Writer currentWriter()
推奨されていません。
このオブジェクトが文字を書き出している基礎 Writer を返します。

戻り値:
基礎 Writer オブジェクト

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
推奨されていません。
基礎ストリームに文字を出力します。
このメソッドをサブクラスがオーバーライドすることにより、 バッファ機能などを実装することができます。 ただし、このメソッドをオーバーライドしたサブクラスは、 同時に length メソッドもオーバーライドする必要があります。

パラメータ:
cbuf - 文字の配列
off - 文字の書き込み開始オフセット
len - 書き込む文字数
例外:
IOException

reconstruction

protected void reconstruction()
                       throws IOException
推奨されていません。
現在使用中の Writer をリセットします。
このメソッドは、FileReporter クラスにより呼び出されます。 FileReporter オブジェクトでは、ReportFileConditioner オブジェクトが ファイルの初期化を必要と判断した場合に、このメソッドを呼び出して、 Writer の初期化を求めてきます。 これにより、リポートファイルのローテイト機能などを 実装することができます。

例外:
IOException

reset

protected Writer reset(Writer writer)
                throws IOException
推奨されていません。
文字の出力ストリームをリセットします。

このメソッドは reset メソッドに呼び出されます。
このメソッドは、単に引数のストリーム(writer)をそのまま リターンします。ファイルのローテイト機能などを実装する場合、 サブクラスでこのメソッドをオーバーライドして下さい。

パラメータ:
writer - 現在のストリーム
戻り値:
新しいストリーム
例外:
IOException

close

public void close()
           throws IOException
推奨されていません。
ストリームを閉じてフラッシュします。
ストリームを一度閉じると、以降 write() または flush() を呼び出すと、 IOException がスローされます。 ただし、前に閉じたストリームを閉じても効果はありません。

例外:
IOException - 入出力エラーが発生した場合

flush

public void flush()
           throws IOException
推奨されていません。
ストリームをフラッシュします。
ストリームがさまざまな write() メソッドからの文字をバッファに 保存してある場合、これらの文字の目的の宛先にただちに文字を書き込みます。 宛先が別の文字またはバイトストリームの場合は、 この宛先をフラッシュします。 つまり 1 つの flush() の呼び出しで、 関連する Writer および OutputStream の すべてのバッファをフラッシュします。

サブクラスで、文字のバッファリング機能を実装している場合、 このメソッドをオーバーライドしてバッファに保存している 文字をフラッシュするように実装しなければいけません。

例外:
IOException - 入出力エラーが発生した場合

finalize

protected void finalize()
                 throws Throwable
推奨されていません。
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
このオブジェクトの全てのリソースを破棄します。

例外:
Throwable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReportLevel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
インタフェース ReportLevel

既知の実装クラスの一覧:
ReportLevelFilter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel クラスを使用してください。

public interface ReportLevel

メッセージレベルのインターフェースです。

このインターフェースは、定数値化したメッセージレベルを示します。 すべてのメッセージに関して、必ずしもこのインターフェースで定義されている レベル値を使う必要はありませんが、このインターフェースを利用することにより プログラム全体でレベル値を統一することができます。

導入されたバージョン:
version 3.2

フィールドの概要
static int | MAX_VALUE 推奨されていません。 レベル値として使用可能な最大値 この値は、java.lang.Integer.MAX_VALUE と同じです。
static int | MIN_VALUE 推奨されていません。 レベル値として使用可能な最小値 この値は、java.lang.Integer.MIN_VALUE と同じです。
static int | TYPE_DEBUG 推奨されていません。 デバッグレベル。
static int | TYPE_ERROR 推奨されていません。 エラーレベル。
static int | TYPE_REPORT 推奨されていません。 通常の情報レベル。
static int | TYPE_WARNING 推奨されていません。 警告レベル。

フィールドの詳細

MIN_VALUE

public static final int MIN_VALUE
推奨されていません。
レベル値として使用可能な最小値 この値は、java.lang.Integer.MIN_VALUE と同じです。

関連項目:
定数フィールド値

MAX_VALUE

public static final int MAX_VALUE
推奨されていません。
レベル値として使用可能な最大値 この値は、java.lang.Integer.MAX_VALUE と同じです。

関連項目:
定数フィールド値

TYPE_DEBUG

public static final int TYPE_DEBUG
推奨されていません。
デバッグレベル。 デバッグ情報を出力する場合に利用します。

関連項目:
定数フィールド値

TYPE_REPORT

public static final int TYPE_REPORT
推奨されていません。
通常の情報レベル。
常に以下の関係が成り立ちます。

TYPE_DEBUG < TYPE_REPORT

関連項目:
定数フィールド値

TYPE_WARNING

public static final int TYPE_WARNING
推奨されていません。
警告レベル。 警告メッセージ出力時に利用します。
常に以下の関係が成り立ちます。

TYPE_REPORT < TYPE_WARNING

関連項目:
定数フィールド値

TYPE_ERROR

public static final int TYPE_ERROR
推奨されていません。
エラーレベル。 エラーメッセージ出力時に利用します。
常に以下の関係が成り立ちます。

TYPE_WARNING < TYPE_ERROR

関連項目:
定数フィールド値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ReportLevelFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス ReportLevelFilter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.FilterMessageReporter
        拡張 jp.co.intra_mart.foundation.utility.report.ReportLevelFilter
すべての実装インタフェース:
MessageReporter, ReportLevel
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter クラスを使用してください。

public class ReportLevelFilter
extends FilterMessageReporter
implements ReportLevel

メッセージの出力制御を行うためのフィルタークラスです。

このクラスを利用することにより、メッセージをメッセージレベルにより、 出力制御を行うことができます。

導入されたバージョン:
version 3.2
関連項目:
ReportLevel

フィールドの概要
protected  int datumpoint
推奨されていません。 このリポーターがフィルタリングする基準レベル値
クラス jp.co.intra_mart.foundation.utility.report.FilterMessageReporter から継承したフィールド
out
インタフェース jp.co.intra_mart.foundation.utility.report.ReportLevel から継承したフィールド
MAX_VALUE, MIN_VALUE, TYPE_DEBUG, TYPE_ERROR, TYPE_REPORT, TYPE_WARNING
コンストラクタの概要
ReportLevelFilter(MessageReporter out, int level)
推奨されていません。 指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。
メソッドの概要
void | report(Object data) 推奨されていません。 data をメッセージとして出力します。
void | report(Object data, int level) 推奨されていません。 指定のメッセージレベルが基準値以上のメッセージを出力します。
void | report(String message) 推奨されていません。 メッセージを出力します。
void | report(String message, int level) 推奨されていません。 指定のメッセージレベルが基準値以上のメッセージを出力します。
クラス jp.co.intra_mart.foundation.utility.report.FilterMessageReporter から継承したメソッド
close, flush
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

datumpoint

protected int datumpoint
推奨されていません。
このリポーターがフィルタリングする基準レベル値

コンストラクタの詳細

ReportLevelFilter

public ReportLevelFilter(MessageReporter out,
                         int level)
推奨されていません。
指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。

パラメータ:
out - 基礎出力リポーター
メソッドの詳細

report

public void report(String message)
推奨されていません。
メッセージを出力します。
このメソッドは、以下の呼出と同じです。

report(message, ReportLevel.MAX_VALUE)

つまり、メッセージ message は必ず基礎出力リポーターに出力されます。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(String message,
                   int level)
推奨されていません。
指定のメッセージレベルが基準値以上のメッセージを出力します。
メッセージレベルは以下の式で判定されます。

this.datumpoint <= level

判定式が true の場合、基礎出力リポーターに対して メッセージが出力されます。逆に判定結果が false の場合、 このメソッドは何も行いません。

パラメータ:
message - メッセージ
level - メッセージレベル

report

public void report(Object data)
推奨されていません。
data をメッセージとして出力します。
このメソッドは、以下の呼出と同じです。

report(data, ReportLevel.MAX_VALUE)

つまり、メッセージデータ data は必ず基礎出力リポーターに出力されます。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
data - データ

report

public void report(Object data,
                   int level)
推奨されていません。
指定のメッセージレベルが基準値以上のメッセージを出力します。
メッセージレベルは以下の式で判定されます。

this.datumpoint <= level

判定式が true の場合、基礎出力リポーターに対して メッセージが出力されます。逆に判定結果が false の場合、 このメソッドは何も行いません。

パラメータ:
data - データ
level - メッセージレベル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RepresentativeReporter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス RepresentativeReporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.FilterMessageReporter
        拡張 jp.co.intra_mart.foundation.utility.report.RepresentativeReporter
すべての実装インタフェース:
MessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter クラスを使用してください。

public class RepresentativeReporter
extends FilterMessageReporter

メッセージ出力をイベント処理するためのフィルタークラスです。

このクラスを利用することにより、メッセージの MessageReporter における 処理を現在のスレッドと並列実行させることができます。 これにより、このクラスの report メソッドと、出力先となる MessageReporter の report メソッドの実行は非同期に処理されます。

このクラスを利用することのメリットは、メッセージの出力処理を 待たなくても、現在のスレッドの実行を継続できることにあります。 逆に、このクラスを利用することにより、メッセージ出力処理と現在のスレッド処理 がスレッドセーフであることが保証されなければなりません。
report メソッドで指定されたメッセージはキューに蓄積され、 現在のスレッドと異なるメッセージ処理専用のスレッドで 基礎出力ストリームに渡されます。 メッセージの出力処理は、現在のスレッドと非同期ですが、 report メソッドの実行順とメッセージの出力順は保証されます。

導入されたバージョン:
version 3.2

フィールドの概要
クラス jp.co.intra_mart.foundation.utility.report.FilterMessageReporter から継承したフィールド
out
コンストラクタの概要
RepresentativeReporter(MessageReporter out, EventQueueController queue)
推奨されていません。 指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。
メソッドの概要
boolean | canReport() 推奨されていません。 このストリームが書き込み可能かどうかをチェックします。
void | close() 推奨されていません。 ストリームを閉じます。
void | flush() 推奨されていません。 ストリームをフラッシュします。
void | report(Object data) 推奨されていません。 data をメッセージとして出力します。
void | report(String message) 推奨されていません。 メッセージを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RepresentativeReporter

public RepresentativeReporter(MessageReporter out,
                              EventQueueController queue)
推奨されていません。
指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。

パラメータ:
out - 基礎出力リポーター
メソッドの詳細

canReport

public boolean canReport()
推奨されていません。
このストリームが書き込み可能かどうかをチェックします。

戻り値:
ストリームの書き込みが可能な場合 true、そうでない場合 false。

report

public void report(String message)
推奨されていません。
メッセージを出力します。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
推奨されていません。
data をメッセージとして出力します。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
data - データ

close

public void close()
           throws IOException
推奨されていません。
ストリームを閉じます。
このメソッドは、ストリームを閉じる前に flush メソッドを実行します。 オブジェクトが閉じられると、report メソッドは何もしなくなります。

定義:
インタフェース MessageReporter 内の close
オーバーライド:
クラス FilterMessageReporter 内の close
例外:
IOException - 入出力エラーが発生した場合

flush

public void flush()
           throws IOException
推奨されていません。
ストリームをフラッシュします。

ストリームに蓄積されているすべてのメッセージイベントを処理します。 このメソッドを実行した場合、現在のスレッドで メッセージが処理されます。また、このメソッドはすべてのメッセージ出力 処理が完了するまでブロックします。

定義:
インタフェース MessageReporter 内の flush
オーバーライド:
クラス FilterMessageReporter 内の flush
例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AbstractDualComparator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス AbstractDualComparator

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.AbstractDualComparator
すべての実装インタフェース:
Comparator, DualComparator, Serializable
直系の既知のサブクラス:
MultiComparator, NodeTypeComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator クラスを使用してください。

public abstract class AbstractDualComparator
extends Object
implements DualComparator

２つのコンパレータを使用してソートを行うクラスです。
比較の順番は、指定された第１コンパレータ、第２コンパレータの順に行われます。まず、第１コンパレータで比較を行います。 もし、その比較の結果が０の時は第２コンパレータで比較を行いその結果を返します。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
AbstractDualComparator()
推奨されていません。 新しいオブジェクトを生成します。
メソッドの概要
 int compare(Object arg0, Object arg1)
推奨されていません。 順序付けのために ２ つの引数を比較するメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.foundation.utility.DualComparator から継承したメソッド
getPrimaryComparator, getSecondaryComparator
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

AbstractDualComparator

public AbstractDualComparator()
推奨されていません。
新しいオブジェクトを生成します。

メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
推奨されていません。
順序付けのために ２ つの引数を比較するメソッドです。
最初の引数が ２ 番目の引数より小さ い場合は負の整数、両方が等しい場合は ０、最初の引数が ２ 番目の引 数より大きい場合は正の整数を返します。
このメソッドは ２ つのコンパレータを使用して比較を行いその結果を返します。 比較の順番は、指定された第１コンパレータ、第２コンパレータの順に行われます。まず、第１コンパレータで比較を行います。 比較の結果が０でないときは、その比較した結果を返します。もし比較の結果が０の時は第２コンパレータで比較を行いその結果を返します。

定義:
インタフェース Comparator 内の compare
パラメータ:
arg0 - 引数１
arg1 - 引数２
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Counter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス Counter

java.lang.Object
    拡張 java.lang.Number
        拡張 jp.co.intra_mart.foundation.utility.Counter
すべての実装インタフェース:
Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.Counter クラスを使用してください。

public class Counter
extends Number
implements Serializable

このクラスは、カウンター機能を提供します。

ある数値を基準として１ずつ増やしたり１ずつ減らしたりすることができます。

導入されたバージョン:
version4.2
関連項目:
直列化された形式

コンストラクタの概要
Counter()
推奨されていません。 カウンターオブジェクトを作成します。
Counter(long initValue)
推奨されていません。 指定の初期値でカウンターオブジェクトを作成します。
メソッドの概要
long | decrement() 推奨されていません。 カウンターの値を１だけ減少させます。
double | doubleValue() 推奨されていません。 カウンターの現在の値を double 型として返します。
float | floatValue() 推奨されていません。 カウンターの現在の値を float 型として返します。
long | increment() 推奨されていません。 カウンターの値を１だけ増加させます。
int | intValue() 推奨されていません。 カウンターの現在の値を int 型として返します。
long | longValue() 推奨されていません。 カウンターの現在の値を long 型として返します。
クラス java.lang.Number から継承したメソッド
byteValue, shortValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Counter

public Counter()
推奨されていません。
カウンターオブジェクトを作成します。

初期値は０です。したがって、このコンストラクタの呼び出しは、 以下の呼び出しと同義です。
new Counter(0)

Counter

public Counter(long initValue)
推奨されていません。
指定の初期値でカウンターオブジェクトを作成します。

パラメータ:
initValue - カウンターの初期値
メソッドの詳細

increment

public long increment()
推奨されていません。
カウンターの値を１だけ増加させます。

戻り値:
変化後のカウンターの値

decrement

public long decrement()
推奨されていません。
カウンターの値を１だけ減少させます。

戻り値:
変化後のカウンターの値

intValue

public int intValue()
推奨されていません。
カウンターの現在の値を int 型として返します。 値を丸めたり切り捨てたりすることもあります。

戻り値:
このオブジェクトが表す数値を int 型に変換した値;

longValue

public long longValue()
推奨されていません。
カウンターの現在の値を long 型として返します。

戻り値:
このオブジェクトが表す数値を long 型に変換した値

floatValue

public float floatValue()
推奨されていません。
カウンターの現在の値を float 型として返します。 値を丸めることもあります。

戻り値:
このオブジェクトが表す数値を float 型に変換した値

doubleValue

public double doubleValue()
推奨されていません。
カウンターの現在の値を double 型として返します。 値を丸めることもあります。

戻り値:
このオブジェクトが表す数値を double 型に変換した値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DualComparator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
インタフェース DualComparator

すべてのスーパーインタフェース:
Comparator, Serializable
既知の実装クラスの一覧:
AbstractDualComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.DualComparator クラスを使用してください。

public interface DualComparator
extends Serializable, Comparator

２つのコンパレータを使用してソートを行うためのインターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
Comparator | getPrimaryComparator() 推奨されていません。 １番目コンパレータを取得します。
Comparator | getSecondaryComparator() 推奨されていません。 ２番目コンパレータを取得します。
インタフェース java.util.Comparator から継承したメソッド
compare, equals

メソッドの詳細

getPrimaryComparator

public Comparator getPrimaryComparator()
推奨されていません。
１番目コンパレータを取得します。

戻り値:
１番目のコンパレータ

getSecondaryComparator

public Comparator getSecondaryComparator()
推奨されていません。
２番目コンパレータを取得します。

戻り値:
２番目のコンパレータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ErrorEvent (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス ErrorEvent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.ErrorEvent
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEvent クラスを使用してください。

public class ErrorEvent
extends Object

例外をイベントとして扱うためのプロトコルです。

イベントリスナー(インターフェース ErrorEventListener を実装したクラス) のオーナーオブジェクトは、例外の発生時にこのクラスのインスタンスを 生成して各リスナーに通知する義務があります。

関連項目:
ErrorEventListener

コンストラクタの概要
ErrorEvent(Throwable t, Object obj)
推奨されていません。 エラーを通知するためのイベントを構築します。
ErrorEvent(Throwable t, String msg, Object obj)
推奨されていません。 エラーを通知するためのイベントを構築します。
メソッドの概要
Throwable | getException() 推奨されていません。 通知されたエラーまたは例外を取得します。
String | getMessage() 推奨されていません。 通知されたエラーメッセージを取得します。
Object | getObject() 推奨されていません。 通知されたエラー発生オブジェクトを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ErrorEvent

public ErrorEvent(Throwable t,
                  Object obj)
推奨されていません。
エラーを通知するためのイベントを構築します。

obj パラメータはエラーの発生したクラスまたはインスタンスです。

パラメータ:
t - 発生した例外
obj - エラーの発生したオブジェクト

ErrorEvent

public ErrorEvent(Throwable t,
                  String msg,
                  Object obj)
推奨されていません。
エラーを通知するためのイベントを構築します。

obj パラメータはエラーの発生したクラスまたはインスタンスです。

パラメータ:
t - 発生した例外
msg - エラーメッセージ
obj - エラーの発生したオブジェクト
メソッドの詳細

getObject

public Object getObject()
推奨されていません。
通知されたエラー発生オブジェクトを取得します。

戻り値:
通知されたエラーオブジェクト

getMessage

public String getMessage()
推奨されていません。
通知されたエラーメッセージを取得します。 メッセージが通知されていない場合、通知されたエラーのメッセージを 返します。

戻り値:
通知されたエラーメッセージ
関連項目:
Throwable.getMessage()

getException

public Throwable getException()
推奨されていません。
通知されたエラーまたは例外を取得します。

戻り値:
通知されたエラーまたは例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ErrorEventListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
インタフェース ErrorEventListener

推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener クラスを使用してください。

public interface ErrorEventListener

例外をイベントとして扱うためのスケルトン実装を提供します。

このインターフェースを実装したクラスのインスタンスは例外の発生に伴い その例外をイベントとして受け取ることができます。 このインターフェースを実装しているクラスから生成されたインスタンスの オーナーオブジェクトは、 例外発生をイベントとしてインスタンスに対して通知する義務があります。

メソッドの概要
 void reportError(ErrorEvent err)
推奨されていません。 発生した例外を通知します。

メソッドの詳細

reportError

public void reportError(ErrorEvent err)
推奨されていません。
発生した例外を通知します。

パラメータ:
err - 発生したエラーイベント
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
インタフェース EventListener

推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventListener クラスを使用してください。

public interface EventListener

このクラスは、イベントリスナーのインターフェースです。

イベントコントローラと組み合わせて使うことにより、 様々なイベント機能を実装することができます。

導入されたバージョン:
version 3.2
関連項目:
EventQueueController

メソッドの概要
 void handleEvent()
推奨されていません。 イベントが発生した時にコントローラから呼び出されます。

メソッドの詳細

handleEvent

public void handleEvent()
推奨されていません。
イベントが発生した時にコントローラから呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventQueueController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス EventQueueController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.EventQueueController
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventQueueController クラスを使用してください。

public class EventQueueController
extends Object

このクラスは、イベントリスナーを実行するイベント機能を実装します。

イベントコントローラは、指定された時間間隔に従ってリスナー登録状況を確認し、 リスナーの登録が１つ以上あった場合、これらを専用スレッドで実行します。 このとき、イベントリスナーの実行順と実行の直列化が保証されます。
これらの機能により、通常の関数実行や java.lang.Thread クラスを利用した 並列処理などと異なった機能を実装することができます。

このクラスを利用することにより、現在の処理とイベント処理を並列化することが できます。また、一つのコントローラは同時に一つのイベントリスナーしか 実行しないため、それぞれのリスナーの処理が並列処理されることはありません。 従って、リスナーはマルチスレッドを意識したプログラムにする必要がありますが、 リスナー間でマルチスレッドを意識する必要はありません。

導入されたバージョン:
version 3.2
関連項目:
EventListener

コンストラクタの概要
EventQueueController()
推奨されていません。 イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
EventQueueController(long millis)
推奨されていません。 イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
メソッドの概要
void | destroy() 推奨されていません。 このイベントコントローラの破棄処理を行います。
void | entry(EventListener listener) 推奨されていません。 イベントリスナーの登録。
void | eventGenerating() 推奨されていません。 キューに登録されているイベントリスナーを一つ実行します。
protected void | finalize() 推奨されていません。 このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
void | flush() 推奨されていません。 キューに溜まっているすべてのイベントリスナーを実行します。
boolean | isAlive() 推奨されていません。 このイベントコントローラが有効かどうかチェックします。
void | setCapacity(int max) 推奨されていません。 キューの容量を変更します。
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventQueueController

public EventQueueController()
推奨されていません。
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。 コントローラがリスナー登録状況を監視する時間間隔はデフォルト値(60秒)が 適用されます。

EventQueueController

public EventQueueController(long millis)
                     throws IllegalArgumentException
推奨されていません。
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。 millis は、リスナーの登録状況を監視する時間間隔です。 コントローラは、リスナーが一つも登録されていない状態になると、 millis ミリ秒間隔でリスナー登録の有無を確認します。

パラメータ:
millis - イベントの監視間隔(ミリ秒)
例外:
IllegalArgumentException - millis が 0 以下の場合
メソッドの詳細

setCapacity

public void setCapacity(int max)
                 throws IllegalStateException,
                        IllegalArgumentException
推奨されていません。
キューの容量を変更します。

パラメータ:
max - イベントをプールできる最大量
例外:
IllegalStateException - max 個以上のリスナーが登録されている場合
IllegalArgumentException - max が 0 以下の場合

entry

public void entry(EventListener listener)
           throws NullPointerException,
                  IndexOutOfBoundsException,
                  IllegalStateException
推奨されていません。
イベントリスナーの登録。
イベントリスナーは、一旦キューに溜められます。 キューに保管されたリスナーは、 このコントローラにより現在実行中のスレッドとは 別のスレッドで登録順に呼び出されます。

実行されたリスナーは、処理が終了すると破棄されます。

通常のスレッドクラスを利用した並列処理との違いは、 イベントリスナーが登録順に実行される点と、 イベントリスナーの実行が直列化される点にあります。

パラメータ:
listener - イベントリスナー
例外:
NullPointerException - listener が null の場合
IndexOutOfBoundsException - キューが飽和状態の場合
IllegalStateException - コントローラが破棄処理済の場合

isAlive

public boolean isAlive()
推奨されていません。
このイベントコントローラが有効かどうかチェックします。

戻り値:
イベントコントローラが有効な場合は true、すでに破棄処理済の場合は false。

destroy

public void destroy()
推奨されていません。
このイベントコントローラの破棄処理を行います。 破棄処理を行うと、それ以上リスナーを登録することができなくなります。

このメソッドによる破棄処理と、登録済みリスナーの実行は非同期に 行われます。そのため、このメソッドがリターンしても 実行されないリスナーが残ることがあります。
すでに登録済みのリスナーの実行は破棄処理後も保証されます (登録済みのリスナーは非同期にすべて実行されます)。

flush

public void flush()
推奨されていません。
キューに溜まっているすべてのイベントリスナーを実行します。

このメソッドは、現在実行中のスレッドで すべてのイベント処理を行います。

eventGenerating

public void eventGenerating()
                     throws NoSuchElementException
推奨されていません。
キューに登録されているイベントリスナーを一つ実行します。 実行されるリスナーは、現在キューに保管されているリスナーの中で 最も過去に登録されたリスナーです。 このメソッドは、現在実行中のスレッドで 登録順で最も過去のイベントを１つ実行します。

例外:
NoSuchElementException - 登録リスナーがない場合

finalize

protected void finalize()
                 throws Throwable
推奨されていません。
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
このオブジェクトの全てのリソースを破棄します。

例外:
Throwable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedThread (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス ExtendedThread

java.lang.Object
    拡張 java.lang.Thread
        拡張 jp.co.intra_mart.foundation.utility.ExtendedThread
すべての実装インタフェース:
Runnable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread クラスを使用してください。

public class ExtendedThread
extends Thread

フィールドの概要
クラス java.lang.Thread から継承したフィールド
MAX_PRIORITY, MIN_PRIORITY, NORM_PRIORITY
コンストラクタの概要
ExtendedThread()
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(Runnable target)
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(Runnable target, String name)
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(String name)
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(ThreadGroup group, Runnable target)
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(ThreadGroup group, Runnable target, String name)
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(ThreadGroup group, String name)
推奨されていません。 Constructor for ExtendedThread.
メソッドの概要
void | addThreadStopListener(ThreadStopListener listener) 推奨されていません。 このスレッドが終了したときに呼び出されるイベントリスナーを登録します。
void | fire() 推奨されていません。 スレッド実行されるロジック。
void | run() 推奨されていません。 このオブジェクトのスレッド実行ロジックです。
クラス java.lang.Thread から継承したメソッド
activeCount, checkAccess, countStackFrames, currentThread, destroy, dumpStack, enumerate, getContextClassLoader, getName, getPriority, getThreadGroup, holdsLock, interrupt, interrupted, isAlive, isDaemon, isInterrupted, join, join, join, resume, setContextClassLoader, setDaemon, setName, setPriority, sleep, sleep, start, stop, stop, suspend, toString, yield
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtendedThread

public ExtendedThread()
推奨されていません。
Constructor for ExtendedThread.

ExtendedThread

public ExtendedThread(Runnable target)
推奨されていません。
Constructor for ExtendedThread.

パラメータ:
target -

ExtendedThread

public ExtendedThread(ThreadGroup group,
                      Runnable target)
推奨されていません。
Constructor for ExtendedThread.

パラメータ:
group -
target -

ExtendedThread

public ExtendedThread(String name)
推奨されていません。
Constructor for ExtendedThread.

パラメータ:
name -

ExtendedThread

public ExtendedThread(ThreadGroup group,
                      String name)
推奨されていません。
Constructor for ExtendedThread.

パラメータ:
group -
name -

ExtendedThread

public ExtendedThread(Runnable target,
                      String name)
推奨されていません。
Constructor for ExtendedThread.

パラメータ:
target -
name -

ExtendedThread

public ExtendedThread(ThreadGroup group,
                      Runnable target,
                      String name)
推奨されていません。
Constructor for ExtendedThread.

パラメータ:
group -
target -
name -
メソッドの詳細

run

public final void run()
推奨されていません。
このオブジェクトのスレッド実行ロジックです。 このメソッドをサブクラスがオーバーライドすることはできません。 サブクラスがスレッド実行ロジックを定義するためには、fireメソッドを オーバーライドしてください。

fire

public void fire()
推奨されていません。
スレッド実行されるロジック。 Thread クラスを継承したサブクラスにおいて、通常 run メソッドに 記述する内容をこのメソッドに定義してください。

addThreadStopListener

public void addThreadStopListener(ThreadStopListener listener)
推奨されていません。
このスレッドが終了したときに呼び出されるイベントリスナーを登録します。

パラメータ:
listener - スレッド終了イベントリスナー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FilterComparator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス FilterComparator

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.FilterComparator
すべての実装インタフェース:
Comparator, Serializable
直系の既知のサブクラス:
ReverseComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator クラスを使用してください。

public abstract class FilterComparator
extends Object
implements Comparator, Serializable

コンパレータのフィルターとして機能する抽象クラスです。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
FilterComparator(Comparator comparator)
推奨されていません。 指定されれたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
メソッドの概要
int | compare(Object arg0, Object arg1) 推奨されていません。 順序付けのために 2 つの引数を比較するメソッドです。
Comparator | getParentComparator() 推奨されていません。 フィルター対象のコンパレータを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

FilterComparator

public FilterComparator(Comparator comparator)
推奨されていません。
指定されれたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。

パラメータ:
comparator - フィルター対象のコンパレータ
メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
推奨されていません。
順序付けのために 2 つの引数を比較するメソッドです。
最初の引数が 2 番目の引数より小さ い場合は負の整数、両方が等しい場合は 0、最初の引数が 2 番目の引 数より大きい場合は正の整数を返します。

定義:
インタフェース Comparator 内の compare
パラメータ:
arg0 - 引数１
arg1 - 引数２
戻り値:
比較した結果

getParentComparator

public Comparator getParentComparator()
推奨されていません。
フィルター対象のコンパレータを返します。

戻り値:
フィルター対象のコンパレータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FixedSizeMap (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス FixedSizeMap

java.lang.Object
    拡張 java.util.AbstractMap
        拡張 jp.co.intra_mart.foundation.utility.FixedSizeMap
すべての実装インタフェース:
Map
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap クラスを使用してください。

public class FixedSizeMap
extends AbstractMap

LRU(Least Recently Used) アルゴリズムによる Map インターフェースの実装を提供します。

このクラスのマップは、決められたサイズの領域持ちます。 キーはコンストラクタで指定された マップのサイズに等しい個数しか、このマップに関連付けることはできません。 すでにマップのサイズに等しい個数のキーが関連付けられている状態で、 別の新しいキーを関連付けようとした場合、LRU アルゴリズムに従い 最も古くに使われたキーが削除され、全体のキー数がマップのサイズに 等しくなるように調整されます。
このオブジェクトは、Thread safe となっています。
このマップは LRU アルゴリズムにより動作するため、 マッピングの追加や更新をしたり、キーにマッピングされている値の取得を した時に、キーのアクセス順をチェックします。 したがって、マップのサイズが大きさに比例して put() や get() メソッドの レスポンス時間が長くなります。 このハッシュテーブルは、適度な大きさで利用することを推奨します。

導入されたバージョン:
Version 3.2
関連項目:
Hashtable

入れ子クラスの概要
クラス java.util.Map から継承した入れ子クラス
Map.Entry
コンストラクタの概要
FixedSizeMap(int size)
推奨されていません。 指定されたサイズの領域を持つマップを構築します。
メソッドの概要
int | capacity() 推奨されていません。 このマップに対してマップできるキーの最大個数を返します。
void | clear() 推奨されていません。 マップからマッピングをすべて削除します。
boolean | containsKey(Object key) 推奨されていません。 指定されたキーへのマッピングをこのマップが格納する場合に true を返します。
Set | entrySet() 推奨されていません。 このマップに格納されているマッピングのセットビューを返します。
Object | get(Object key) 推奨されていません。 マップが、指定されたキーにマッピングしている値を返します。
Object | put(Object key, Object value) 推奨されていません。 指定された値を、マップ内の指定されたキーに関連付けます 。
Object | remove(Object key) 推奨されていません。 このキーにマッピングがある場合に、そのマッピングをマップから削除します。
クラス java.util.AbstractMap から継承したメソッド
clone, containsValue, equals, hashCode, isEmpty, keySet, putAll, size, toString, values
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

FixedSizeMap

public FixedSizeMap(int size)
             throws IllegalArgumentException
推奨されていません。
指定されたサイズの領域を持つマップを構築します。

パラメータ:
size - ハッシュテーブルの容量
例外:
IllegalArgumentException - 容量が 1 より小さい場合
メソッドの詳細

capacity

public int capacity()
推奨されていません。
このマップに対してマップできるキーの最大個数を返します。 このメソッドの返す値は、コンストラクタで指定されたハッシュテーブルの 容量値をそのまま返すものです。

戻り値:
このマップにエントリできるキーの最大個数

clear

public void clear()
推奨されていません。
マップからマッピングをすべて削除します。

containsKey

public boolean containsKey(Object key)
推奨されていません。
指定されたキーへのマッピングをこのマップが格納する場合に true を返します。

パラメータ:
key - このマップにあるかどうかを判定するキー
戻り値:
指定されたキーへのマッピングをこのマップが含む場合は true

entrySet

public Set entrySet()
推奨されていません。
このマップに格納されているマッピングのセットビューを返します。 このセットの各要素は Map.Entry です。セットはこのマップを 基にしているので、マップへの変更、およびセットへの変更は、 互いに反映されます。 セットでの繰り返し処理が進行中にマップが変更された場合、 反復の結果は保証されません。セットは要素の削除をサポートしており、 対応するエントリをマップから削除することができます。 削除には、Iterator.remove、Set.remove、removeAll、retainAll、 および clear オペレーションが使えます。 add または addAll オペレーションはサポートされません。

戻り値:
このマップに格納されているマッピングのセットビュー

get

public Object get(Object key)
推奨されていません。
マップが、指定されたキーにマッピングしている値を返します。 マップに、このキーに対するマッピングがない場合は null を返します。

パラメータ:
key - 関連付けられている値が返されるキー
戻り値:
マップが、指定されたキーにマッピングしている値。このキーに対するマッピングがマップにない場合は null
関連項目:
containsKey(Object)

put

public Object put(Object key,
                  Object value)
推奨されていません。
指定された値を、マップ内の指定されたキーに関連付けます 。 マップにすでにこのキーに対するマッピングがある場合、 古い値は置き換えられます。

パラメータ:
key - 指定された値が関連付けられるキー
value - 指定されたキーに関連付けられる値
戻り値:
指定されたキーに関連付けられていた以前の値。key にマッピングがなかった場合は null。
例外:
NullPointerException - キーまたは値が null の場合

remove

public Object remove(Object key)
推奨されていません。
このキーにマッピングがある場合に、そのマッピングをマップから削除します。

パラメータ:
key - マッピングがマップから削除されるキー
戻り値:
指定されたキーに関連付けられていた以前の値。key にマッピングがなかった場合は null。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LockMonitor (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス LockMonitor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.LockMonitor
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.LockMonitor クラスを使用してください。

public class LockMonitor
extends Object

このクラスはモニター機能を提供します。
このクラスでは、複数個のモニターを管理することができます。 アプリケーションでは、entry() メソッドによりモニターを取得し、 release() メソッドでモニターを開放します。

コンストラクタの概要
LockMonitor(int max)
推奨されていません。 モニターを構築します。
メソッドの概要
int | activeCount() 推奨されていません。 現在取得済みモニターの数を取得します。
void | entry() 推奨されていません。 モニターの取得。
int | queue() 推奨されていません。 モニターを取得するための待ち行列に入っているスレッドの数です。
void | release() 推奨されていません。 モニターの開放。
int | size() 推奨されていません。 このオブジェクトの管理するモニターの数を取得します。
int | total() 推奨されていません。 モニターを利用中、または利用しようとしているスレッドの数です。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LockMonitor

public LockMonitor(int max)
推奨されていません。
モニターを構築します。

パラメータ:
max - 管理するモニターの個数
メソッドの詳細

entry

public void entry()
推奨されていません。
モニターの取得。

モニターを取得できるまでブロックします。 モニターの取得＝動作の権利を取得

size

public int size()
推奨されていません。
このオブジェクトの管理するモニターの数を取得します。

戻り値:
モニターの数

activeCount

public int activeCount()
推奨されていません。
現在取得済みモニターの数を取得します。

戻り値:
取得済みモニターの数

total

public int total()
推奨されていません。
モニターを利用中、または利用しようとしているスレッドの数です。

戻り値:
entry() メソッドを実行して release() メソッドを実行していないスレッドの数
導入されたバージョン:
version 4.2

queue

public int queue()
推奨されていません。
モニターを取得するための待ち行列に入っているスレッドの数です。

戻り値:
entry() メソッドを実行して、ブロック状態になっているスレッドの数
導入されたバージョン:
version 4.2

release

public void release()
推奨されていません。
モニターの開放。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MultiComparator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス MultiComparator

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.AbstractDualComparator
        拡張 jp.co.intra_mart.foundation.utility.MultiComparator
すべての実装インタフェース:
Comparator, DualComparator, Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator クラスを使用してください。

public class MultiComparator
extends AbstractDualComparator

複数のコンパレータを使用してソートを行うためにクラスです。
実行したコンパレータの compare() メソッドの戻り値が０でなくなるか、全てのコンパレータの実行が完了するまで下記の順番でコンパレータの実行が行われます。

・コンストラクタで指定された第１コンパレータ
・コンストラクタで指定された第２コンパレータ
・addComparator()で追加されたコンパレータ

このクラスは同じインスタンスのコンパレータを２つ以上持つことを想定されていません。 そのような操作を行うと、正しい結果が得られない可能性があります。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
MultiComparator(Comparator primaryComparator, Comparator secondaryComparator)
推奨されていません。 第１コンパレータ 、第２コンパレータを指定して、新しいオブジェクトを生成します。
メソッドの概要
void | addComparator(Comparator comparator) 推奨されていません。 指定されたコンパレータ comparator を追加します。
Collection | getComparators() 推奨されていません。 設定されている全てのコンパレータを取得します。
Comparator | getPrimaryComparator() 推奨されていません。 第１コンパレータを返します。
Comparator | getSecondaryComparator() 推奨されていません。 第２コンパレータを返します。
boolean | removeComparator(Comparator comparator) 推奨されていません。 指定されたコンパレータ comparatorを削除します。
クラス jp.co.intra_mart.foundation.utility.AbstractDualComparator から継承したメソッド
compare
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

MultiComparator

public MultiComparator(Comparator primaryComparator,
                       Comparator secondaryComparator)
                throws NullPointerException
推奨されていません。
第１コンパレータ 、第２コンパレータを指定して、新しいオブジェクトを生成します。
もし primaryComparator がnullで、 secondaryComparator がnullでない時は、secondaryComparator が第１コンパレータとして扱われます。
primaryComparator 、secondaryComparator がともにnullの時は例外を発生させます。

パラメータ:
primaryComparator - 第１コンパレータ
secondaryComparator - 第２コンパレータ
例外:
NullPointerException - primaryComparator 、 secondaryComparator がともにnullの時発生します。
メソッドの詳細

getPrimaryComparator

public Comparator getPrimaryComparator()
推奨されていません。
第１コンパレータを返します。

戻り値:
第１コンパレータ

getSecondaryComparator

public Comparator getSecondaryComparator()
推奨されていません。
第２コンパレータを返します。 このメソッドの戻り値は、設定された第２コンパレータをラップしたMultiComparatorのオブジェクトになります。 もし、第２コンパレータが設定されていないときはnullを返します。

戻り値:
第２コンパレータ

addComparator

public void addComparator(Comparator comparator)
                   throws NullPointerException
推奨されていません。
指定されたコンパレータ comparator を追加します。 指定されたコンパレータ comparatorがnullの時は例外を発生させます。

パラメータ:
comparator - コンパレータ
例外:
NullPointerException - 指定されたcomparatorがnullの時に発生します。

removeComparator

public boolean removeComparator(Comparator comparator)
                         throws IllegalArgumentException
推奨されていません。
指定されたコンパレータ comparatorを削除します。 指定されたコンパレータの削除に成功したときはtrue、失敗したときはfalseを返します。 このクラスのオブジェクトが持つ全てのコンパレータを削除しようとすると例外が発生します。

パラメータ:
comparator - 削除対象のコンパレータ
戻り値:
削除に成功したときはtrue、失敗したときはfalseを返す。
例外:
IllegalArgumentException - 全てのコンパレータを削除しようとした時に発生します。

getComparators

public Collection getComparators()
推奨されていません。
設定されている全てのコンパレータを取得します。

戻り値:
設定されている全てのコンパレータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MultipurposeInternetMailExtensions (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス MultipurposeInternetMailExtensions

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions クラスを使用してください。

public class MultipurposeInternetMailExtensions
extends Object

MIME タイプを持つオブジェクトです。

コンストラクタの概要
MultipurposeInternetMailExtensions(File path)
推奨されていません。 MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(String filename)
推奨されていません。 MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(String mediaType, String subType)
推奨されていません。 指定のMIMEタイプを表すオブジェクトを構築します。
メソッドの概要
String | getMediaType() 推奨されていません。 このオブジェクトが表す MIME タイプの Media Type を返します。
String | getSubType() 推奨されていません。 このオブジェクトが表す MIME タイプの subtype を返します。
String | getType() 推奨されていません。 このオブジェクトが表す MIME タイプを返します。
String | toString() 推奨されていません。 このオブジェクトの文字列表現を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MultipurposeInternetMailExtensions

public MultipurposeInternetMailExtensions(String filename)
推奨されていません。
MIMEタイプを表すオブジェクトを構築します。

MIME タイプは引数 filename の拡張子により解決されます。
引数 filename に拡張子がない場合や、拡張子から MIME タイプを解決 出来なかった場合には、オブジェクトの表す MIME タイプは application/octet-stream となります。

パラメータ:
filename - ファイル名

MultipurposeInternetMailExtensions

public MultipurposeInternetMailExtensions(File path)
推奨されていません。
MIMEタイプを表すオブジェクトを構築します。

MIME タイプは引数 path の表すファイル名の拡張子により解決されます。
引数 path の表すファイル名に拡張子がない場合や、拡張子から MIME タイプを 解決出来なかった場合には、オブジェクトの表す MIME タイプは application/octet-stream となります。

パラメータ:
path - ファイル名を表す File クラスのインスタンス

MultipurposeInternetMailExtensions

public MultipurposeInternetMailExtensions(String mediaType,
                                          String subType)
推奨されていません。
指定のMIMEタイプを表すオブジェクトを構築します。

このコンストラクタにより構築されたオブジェクトの表す MIME タイプは、 mediaType "/" subType となります。

パラメータ:
mediaType - メディアタイプを表すキーワード
subType - サブタイプを表すキーワード
メソッドの詳細

getMediaType

public String getMediaType()
推奨されていません。
このオブジェクトが表す MIME タイプの Media Type を返します。

戻り値:
Media Type を表す文字列

getSubType

public String getSubType()
推奨されていません。
このオブジェクトが表す MIME タイプの subtype を返します。

戻り値:
subtype を表す文字列

getType

public String getType()
推奨されていません。
このオブジェクトが表す MIME タイプを返します。

戻り値:
MIME タイプを表す文字列

toString

public String toString()
推奨されていません。
このオブジェクトの文字列表現を返します。

戻り値:
MIME タイプを表す文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.utility (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.utility
インタフェース
DualComparator
ErrorEventListener
EventListener
ThreadStopListener
クラス
AbstractDualComparator
Counter
ErrorEvent
EventQueueController
ExtendedThread
FilterComparator
FixedSizeMap
LockMonitor
MultiComparator
MultipurposeInternetMailExtensions
ResourceBundleProperties
ReverseComparator
SequenceComparator


jp.co.intra_mart.foundation.utility (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility

このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

参照:
説明

インタフェースの概要
DualComparator | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.DualComparator クラスを使用してください。
ErrorEventListener | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener クラスを使用してください。
EventListener | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventListener クラスを使用してください。
ThreadStopListener | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener クラスを使用してください。

クラスの概要
AbstractDualComparator | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator クラスを使用してください。
Counter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.Counter クラスを使用してください。
ErrorEvent | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEvent クラスを使用してください。
EventQueueController | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventQueueController クラスを使用してください。
ExtendedThread | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread クラスを使用してください。
FilterComparator | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator クラスを使用してください。
FixedSizeMap | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap クラスを使用してください。
LockMonitor | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.LockMonitor クラスを使用してください。
MultiComparator | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator クラスを使用してください。
MultipurposeInternetMailExtensions | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions クラスを使用してください。
ResourceBundleProperties | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties クラスを使用してください。
ReverseComparator | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator クラスを使用してください。
SequenceComparator | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator クラスを使用してください。

パッケージ jp.co.intra_mart.foundation.utility の説明

このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。


jp.co.intra_mart.foundation.utility クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.utility.AbstractDualComparator (implements jp.co.intra_mart.foundation.utility.DualComparator)
      • class jp.co.intra_mart.foundation.utility.MultiComparator
    • class java.util.AbstractMap (implements java.util.Map)
      • class jp.co.intra_mart.foundation.utility.FixedSizeMap
    • class java.util.Dictionary
      • class java.util.Hashtable (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class java.util.Properties
          • class jp.co.intra_mart.foundation.utility.ResourceBundleProperties
    • class jp.co.intra_mart.foundation.utility.ErrorEvent
    • class jp.co.intra_mart.foundation.utility.EventQueueController
    • class jp.co.intra_mart.foundation.utility.FilterComparator (implements java.util.Comparator, java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.ReverseComparator
    • class jp.co.intra_mart.foundation.utility.LockMonitor
    • class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions
    • class java.lang.Number (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.Counter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.utility.SequenceComparator (implements java.util.Comparator, java.io.Serializable)
    • class java.lang.Thread (implements java.lang.Runnable)
      • class jp.co.intra_mart.foundation.utility.ExtendedThread

インタフェース階層

  • interface java.util.Comparator
    • interface jp.co.intra_mart.foundation.utility.DualComparator (同様に extends java.io.Serializable)
  • interface jp.co.intra_mart.foundation.utility.ErrorEventListener
  • interface jp.co.intra_mart.foundation.utility.EventListener
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.utility.DualComparator (同様に extends java.util.Comparator)
  • interface jp.co.intra_mart.foundation.utility.ThreadStopListener


パッケージ jp.co.intra_mart.foundation.utility の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.utility の使用

jp.co.intra_mart.foundation.utility を使用しているパッケージ
jp.co.intra_mart.foundation.http | ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.page | ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.utility | このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.io | このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.report | このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.http により使用される jp.co.intra_mart.foundation.utility のクラス
MultipurposeInternetMailExtensions
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions クラスを使用してください。

jp.co.intra_mart.foundation.page により使用される jp.co.intra_mart.foundation.utility のクラス
AbstractDualComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator クラスを使用してください。

jp.co.intra_mart.foundation.service.provider により使用される jp.co.intra_mart.foundation.utility のクラス
EventListener
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventListener クラスを使用してください。

jp.co.intra_mart.foundation.utility により使用される jp.co.intra_mart.foundation.utility のクラス
AbstractDualComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator クラスを使用してください。
ErrorEvent
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEvent クラスを使用してください。
EventListener
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventListener クラスを使用してください。
FilterComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator クラスを使用してください。
ThreadStopListener
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener クラスを使用してください。

jp.co.intra_mart.foundation.utility.io により使用される jp.co.intra_mart.foundation.utility のクラス
ErrorEventListener
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener クラスを使用してください。

jp.co.intra_mart.foundation.utility.report により使用される jp.co.intra_mart.foundation.utility のクラス
EventQueueController
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventQueueController クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ResourceBundleProperties (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス ResourceBundleProperties

java.lang.Object
    拡張 java.util.Dictionary
        拡張 java.util.Hashtable
            拡張 java.util.Properties
                拡張 jp.co.intra_mart.foundation.utility.ResourceBundleProperties
すべての実装インタフェース:
Cloneable, Map, Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties クラスを使用してください。

public class ResourceBundleProperties
extends Properties

このクラスは、java.util.Properties クラスのインターフェースを実装した、 プロパティ管理クラスです。プロパティデータは、java.util.ResourceBundle により取得されます。
ロードできるリソースに関しては、java.util.ResourceBundle の 説明を参照して下さい。
このクラスのコンストラクタが、java.util.ResourceBundle クラスの getBundle() メソッドと同様の機能を提供しています。 各コンストラクタは、引数の同じ getBundle() メソッドに対応しています。

導入されたバージョン:
version 4.0
関連項目:
Properties, ResourceBundle, 直列化された形式

フィールドの概要
クラス java.util.Properties から継承したフィールド
defaults
コンストラクタの概要
ResourceBundleProperties(String baseName)
推奨されていません。 リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String baseName, Locale locale)
推奨されていません。 リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String baseName, Locale locale, ClassLoader loader)
推奨されていません。 リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
メソッドの概要
 Locale getLocale()
推奨されていません。 ResourceBundle の Locale を返します。
クラス java.util.Properties から継承したメソッド
getProperty, getProperty, list, list, load, propertyNames, save, setProperty, store
クラス java.util.Hashtable から継承したメソッド
clear, clone, contains, containsKey, containsValue, elements, entrySet, equals, get, hashCode, isEmpty, keys, keySet, put, putAll, rehash, remove, size, toString, values
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ResourceBundleProperties

public ResourceBundleProperties(String baseName)
                         throws MissingResourceException
推奨されていません。
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。

パラメータ:
baseName - 目的のオブジェクトを含むリソースバンドルのファミリ名
例外:
MissingResourceException - リソースの照合に失敗した場合

ResourceBundleProperties

public ResourceBundleProperties(String baseName,
                                Locale locale)
                         throws MissingResourceException
推奨されていません。
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。

パラメータ:
baseName - 目的のオブジェクトを含むリソースバンドルのファミリ名
locale - 目的のロケール
例外:
MissingResourceException - リソースの照合に失敗した場合

ResourceBundleProperties

public ResourceBundleProperties(String baseName,
                                Locale locale,
                                ClassLoader loader)
                         throws MissingResourceException
推奨されていません。
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。

パラメータ:
baseName - 目的のオブジェクトを含むリソースバンドルのファミリ名
locale - 目的のロケール
loader - リソースをロードする ClassLoader
例外:
MissingResourceException - リソースの照合に失敗した場合
メソッドの詳細

getLocale

public Locale getLocale()
推奨されていません。
ResourceBundle の Locale を返します。
この関数は、このオブジェクトが本当に要求されたロケールに対応しているか、 またはフォールバックであるかを判定するために、このオブジェクトが 構築されたあとで使用できます。

この関数は、java.util.ResourceBundle クラスの getLocale() と 同じであり、java.util.ResourceBundle クラスとインターフェースを 合わせるために提供されています。 java.util.ResourceBundle クラスの getLocale() の説明を参照して下さい。

戻り値:
ロケール
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReverseComparator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス ReverseComparator

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.FilterComparator
        拡張 jp.co.intra_mart.foundation.utility.ReverseComparator
すべての実装インタフェース:
Comparator, Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator クラスを使用してください。

public class ReverseComparator
extends FilterComparator

コンパレータのフィルタとして機能します。
フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
ReverseComparator(Comparator comparator)
推奨されていません。 指定されたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
メソッドの概要
 int compare(Object arg0, Object arg1)
推奨されていません。 フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。
クラス jp.co.intra_mart.foundation.utility.FilterComparator から継承したメソッド
getParentComparator
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

ReverseComparator

public ReverseComparator(Comparator comparator)
推奨されていません。
指定されたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。

パラメータ:
comparator - フィルター対象のコンパレータ
メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
推奨されていません。
フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。

定義:
インタフェース Comparator 内の compare
オーバーライド:
クラス FilterComparator 内の compare
パラメータ:
arg0 - 引数１
arg1 - 引数２
戻り値:
フィルタ対象のコンパレータの compare() メソッドの結果を反転させた値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SequenceComparator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス SequenceComparator

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.SequenceComparator
すべての実装インタフェース:
Comparator, Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator クラスを使用してください。

public class SequenceComparator
extends Object
implements Comparator, Serializable

挿入順にソートするためのコンパレータです。
このコンパレータは挿入が早い物から遅い物の順に並べます。
このコンパレータは、挿入されたオブジェクトの順番をインスタンス変数として持っています。 そのため、複数のオブジェクトでこのコンパレータを共有使用すると正しく動作しない可能性があります。
またこのクラスは、java.lang.TreeSet、java.lang.TreeMapで使用されることを想定して作られています。 そのため、他のクラスのコンパレータとして使用すると正しく動作しない可能性があります。 クラスで管理できるオブジェクトの数は、２の３１乗-１までのみ管理できます。

導入されたバージョン:
version 4.3
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SequenceComparator()
推奨されていません。 新しいオブジェクトを生成します。
メソッドの概要
 int compare(Object arg0, Object arg1)
推奨されていません。 順序付けのために ２ つの引数を比較するメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

SequenceComparator

public SequenceComparator()
推奨されていません。
新しいオブジェクトを生成します。

メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
推奨されていません。
順序付けのために ２ つの引数を比較するメソッドです。
最初の引数が ２ 番目の引数より小さ い場合は負の整数、両方が等しい場合は 0、最初の引数が 2 番目の引 数より大きい場合は正の整数を返します。
このメソッドの目的は、挿入順にソートすることです。 引数１と引数２を比較したとき、引数１の方が挿入が遅いときは正の数、早い時は負の数を返します。
引数１と引数２が同じインスタンスの時は０を返します

定義:
インタフェース Comparator 内の compare
パラメータ:
arg0 - 引き数１
arg1 - 引き数２
戻り値:
比較した結果
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ThreadStopListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
インタフェース ThreadStopListener

推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener クラスを使用してください。

public interface ThreadStopListener

メソッドの概要
 void handleThreadStop()
推奨されていません。 監視していたスレッドが終了したときに実行されるメソッドです。

メソッドの詳細

handleThreadStop

public void handleThreadStop()
推奨されていません。
監視していたスレッドが終了したときに実行されるメソッドです。 このメソッドをサブクラスが実行することで、特定のスレッド終了時に プログラムを実行することができます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.base.data.ConnectorModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.ConnectorModel の使用

jp.co.intra_mart.framework.base.data.ConnectorModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.data.DAO の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.data.DAO の使用

DAO を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DAO の使用

DAO を実装している jp.co.intra_mart.framework.base.data のクラス
class | DAOAdapter DAOのすべてのメソッドを何もしないように実装したクラスです。
class | DBDAO データベースに特化したDAOです。
class | IntramartDBDAO 推奨されていません。 このクラスではなくLoginGroupDBDAOまたは SystemDBDAOを使用してください。
class | IntramartFileServerDAO intra-martのStorageサービスを使用する場合のDAOです。
class | LoginGroupDBDAO イントラマートで設定されたDBへアクセスするDAOです。
class | SystemDBDAO イントラマートで設定されたDBへアクセスするDAOです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DAOAdapter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DAOAdapter の使用

jp.co.intra_mart.framework.base.data.DAOAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DAOException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DAOException の使用

DAOException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.seasar.data |

jp.co.intra_mart.framework.base.data での DAOException の使用

DAOException をスローする jp.co.intra_mart.framework.base.data のメソッド
 Object DataAccessController.getDAO(String application, String key, String connect)
DAOを取得します。

jp.co.intra_mart.framework.base.event での DAOException の使用

DAOException をスローする jp.co.intra_mart.framework.base.event のメソッド
protected Object | StandardEventListener.getDAO(String application, String key, String connect) DAOを取得します。
protected Object | EventTriggerAdapter.getDAO(String application, String key, String connect) DAOを取得します。

jp.co.intra_mart.framework.extension.seasar.data での DAOException の使用

DAOException をスローする jp.co.intra_mart.framework.extension.seasar.data のメソッド
 Object S2DataAccessController.getDAO(String application, String key, String connect)
DAOを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DaoModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DaoModel の使用

jp.co.intra_mart.framework.base.data.DaoModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataAccessController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataAccessController の使用

DataAccessController を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.data.container |
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.seasar.data |

jp.co.intra_mart.framework.base.data での DataAccessController の使用

DataAccessController を返す jp.co.intra_mart.framework.base.data のメソッド
 DataAccessController DataManager.getDataAccessController()
データアクセスコントローラを取得します。

jp.co.intra_mart.framework.base.data.container での DataAccessController の使用

DataAccessController を返す jp.co.intra_mart.framework.base.data.container のメソッド
DataAccessController | DataContainerImpl.getDataAccessController() データアクセスコントローラを取得します。
DataAccessController | DataContainer.getDataAccessController() データアクセスコントローラを取得します。

jp.co.intra_mart.framework.base.event での DataAccessController の使用

DataAccessController を返す jp.co.intra_mart.framework.base.event のメソッド
protected  DataAccessController StandardEventListener.getDataAccessController()
このイベントリスナで使用するデータアクセスコントローラです。

DataAccessController 型のパラメータを持つ jp.co.intra_mart.framework.base.event のメソッド
protected abstract EventResult | StandardEJBEventListenerAgentBean.fire(Event event, DataAccessController dataAccessController) イベントに対する処理です。
void | EventTriggerList.fireAll(Event event, DataAccessController controller) すべてのトリガに対してイベントの処理を行います。
void | EventTriggerAdapter.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
void | EventTrigger.fire(Event event, DataAccessController controller) イベントに対する処理を行います。

jp.co.intra_mart.framework.extension.seasar.data での DataAccessController の使用

jp.co.intra_mart.framework.extension.seasar.data での DataAccessController のサブクラス
 class S2DataAccessController
S2DataAccessControllerはSeasar2　と連携しdaoを生成します。

DataAccessController を返す jp.co.intra_mart.framework.extension.seasar.data のメソッド
 DataAccessController S2DataContainer.getDataAccessController()
データアクセスコントローラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataAccessException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataAccessException の使用

DataAccessException を使用しているパッケージ
jp.co.intra_mart.framework.extension.seasar.util

jp.co.intra_mart.framework.extension.seasar.util での DataAccessException の使用

DataAccessException をスローする jp.co.intra_mart.framework.extension.seasar.util のメソッド
protected DataSource | LoginGroupDataSource.findLoginGroupDataSource() このオブジェクトがラップするデータソースを返します。
protected DataSource | AutoDetectedDataSource.findLoginGroupDataSource() セッション情報からログイングループに設定されているデータソースを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataConnectException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataConnectException の使用

DataConnectException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.seasar.data |

jp.co.intra_mart.framework.base.data での DataConnectException の使用

DataConnectException をスローする jp.co.intra_mart.framework.base.data のメソッド
void | SystemDBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
Connection | SystemDBDAO.getConnection() イントラマートで設定されているDBへのコネクションを取得します。
void | SystemDBConnector.commit() コミットします。
void | SystemDBConnector.rollback() ロールバックします。
void | SystemDBConnector.release() データストアの資源を解放します。
Connection | SystemDBConnector.getConnection(String connect) データベースへのコネクションを取得します。
protected Object | SystemDBConnector.getResource(String key, String connect, String resource) リソースを取得します。
void | LoginGroupDBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
Connection | LoginGroupDBDAO.getConnection() イントラマートで設定されているDBへのコネクションを取得します。
void | LoginGroupDBConnector.commit() コミットします。
void | LoginGroupDBConnector.rollback() ロールバックします。
void | LoginGroupDBConnector.release() データストアの資源を解放します。
Connection | LoginGroupDBConnector.getConnection(String connect) データベースへのコネクションを取得します。
protected Object | LoginGroupDBConnector.getResource(String key, String connect, String resource) リソースを取得します。
void | JDBCConnector.commit() 推奨されていません。 コミットします。
void | JDBCConnector.rollback() 推奨されていません。 ロールバックします。
void | JDBCConnector.release() 推奨されていません。 データストアの資源を解放します。
protected Connection | JDBCConnector.putResource(String resource, ResourceParam[] params) 推奨されていません。 接続先のリソースを追加します。
void | IntramartFileServerDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
protected Object | IntramartFileServerConnector.getResource(String key, String connect, String resource) リソースを取得します。
void | IntramartFileServerConnector.commit() コミットします。
void | IntramartFileServerConnector.rollback() ロールバックします。
void | IntramartFileServerConnector.release() データストアの資源を解放します。
void | IntramartDBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) 推奨されていません。 データリソースに接続する時の情報を設定します。
DbsConnection | IntramartDBDAO.getConnection() 推奨されていません。 イントラマートで設定されているDBへのコネクションを取得します。
void | IntramartDBConnector.commit() 推奨されていません。 コミットします。
void | IntramartDBConnector.rollback() 推奨されていません。 ロールバックします。
void | IntramartDBConnector.release() 推奨されていません。 データストアの資源を解放します。
protected Object | IntramartDBConnector.getResource(String key, String connect, String resource) 推奨されていません。 リソースを取得します。
DbsConnection | IntramartDBConnector.getConnection(String connect) 推奨されていません。 データベースへのコネクションを取得します。
void | DBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
protected Connection | DBDAO.getConnection() このDAOに関連づけられたコネクションを取得します。
protected abstract Connection | DBConnector.putResource(String resource, ResourceParam[] params) 接続先のリソースを追加します。
protected Object | DBConnector.getResource(String key, String connect, String resource) リソースを取得します。
Connection | DBConnector.getConnection(String resource) データベースへのコネクションを取得します。
void | DBConnector.commit() コミットします。
void | DBConnector.rollback() ロールバックします。
void | DBConnector.release() データストアの資源を解放します。
void | DataSourceConnector.commit() コミットします。
void | DataSourceConnector.rollback() ロールバックします。
void | DataSourceConnector.release() データストアの資源を解放します。
protected Connection | DataSourceConnector.putResource(String resource, ResourceParam[] params) 接続先のリソースを追加します。
protected abstract Object | DataConnector.getResource(String key, String connect, String resource) リソースを取得します。
abstract void | DataConnector.commit() コミットします。
abstract void | DataConnector.rollback() ロールバックします。
abstract void | DataConnector.release() データストアの資源を解放します。
Object | DataAccessController.getDAO(String application, String key, String connect) DAOを取得します。
void | DataAccessController.commit() すべてのデータコネクタをコミットします。
void | DataAccessController.rollback() すべてのデータコネクタをロールバックします。
void | DataAccessController.release() すべてのデータストアの資源を解放します。
void | DAOAdapter.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
void | DAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。

jp.co.intra_mart.framework.base.event での DataConnectException の使用

DataConnectException をスローする jp.co.intra_mart.framework.base.event のメソッド
protected Object | StandardEventListener.getDAO(String application, String key, String connect) DAOを取得します。
protected Object | EventTriggerAdapter.getDAO(String application, String key, String connect) DAOを取得します。

jp.co.intra_mart.framework.extension.seasar.data での DataConnectException の使用

DataConnectException をスローする jp.co.intra_mart.framework.extension.seasar.data のメソッド
 Object S2DataAccessController.getDAO(String application, String key, String connect)
DAOを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataConnector の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataConnector の使用

DataConnector を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataConnector の使用

jp.co.intra_mart.framework.base.data での DataConnector のサブクラス
class | DataSourceConnector DataSourceに関連するデータコネクタです。
class | DBConnector データベースに対するコネクタです。
class | IntramartDBConnector 推奨されていません。 このクラスではなくLoginGroupDBConnectorまたは SystemDBConnectorを使用してください。
class | IntramartFileServerConnector intra-martのStorageサービスに接続するデータコネクタです。
class | JDBCConnector 推奨されていません。 JDBCを直接扱わず、DataSourceを使用するようにしてください。
class | LoginGroupDBConnector イントラマートで設定されているDBコネクションです。
class | SystemDBConnector イントラマートで設定されているDBコネクションです。

DataConnector 型のパラメータを持つ jp.co.intra_mart.framework.base.data のメソッド
void | SystemDBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
void | LoginGroupDBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
void | IntramartFileServerDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
void | IntramartDBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) 推奨されていません。 データリソースに接続する時の情報を設定します。
void | DBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
void | DAOAdapter.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
void | DAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataConnectorException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataConnectorException の使用

DataConnectorException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.seasar.data |

jp.co.intra_mart.framework.base.data での DataConnectorException の使用

DataConnectorException をスローする jp.co.intra_mart.framework.base.data のメソッド
protected NetworkFile | IntramartFileServerDAO.getNetworkFile(String path) パスに該当するNetworkFileを取得します。
Object | DataAccessController.getDAO(String application, String key, String connect) DAOを取得します。

jp.co.intra_mart.framework.base.event での DataConnectorException の使用

DataConnectorException をスローする jp.co.intra_mart.framework.base.event のメソッド
protected Object | StandardEventListener.getDAO(String application, String key, String connect) DAOを取得します。
protected Object | EventTriggerAdapter.getDAO(String application, String key, String connect) DAOを取得します。

jp.co.intra_mart.framework.extension.seasar.data での DataConnectorException の使用

DataConnectorException をスローする jp.co.intra_mart.framework.extension.seasar.data のメソッド
 Object S2DataAccessController.getDAO(String application, String key, String connect)
DAOを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataManager の使用

DataManager を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataManager の使用

DataManager を返す jp.co.intra_mart.framework.base.data のメソッド
static DataManager DataManager.getDataManager()
データマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataManagerException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataManagerException の使用

DataManagerException を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataManagerException の使用

DataManagerException をスローする jp.co.intra_mart.framework.base.data のメソッド
static DataManager DataManager.getDataManager()
データマネージャを取得します。

DataManagerException をスローする jp.co.intra_mart.framework.base.data のコンストラクタ
DataManager()
データマネージャを生成するコンストラクタです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataPropertyException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataPropertyException の使用

DataPropertyException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.seasar.data |

jp.co.intra_mart.framework.base.data での DataPropertyException の使用

DataPropertyException をスローする jp.co.intra_mart.framework.base.data のメソッド
boolean | XmlDataPropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | XmlDataPropertyHandler.getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
String | XmlDataPropertyHandler.getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | XmlDataPropertyHandler.getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | XmlDataPropertyHandler.getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
ResourceParam[] | XmlDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
String | TextFileDataPropertyHandler.getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
String | TextFileDataPropertyHandler.getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | TextFileDataPropertyHandler.getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | TextFileDataPropertyHandler.getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
ResourceParam[] | TextFileDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
Connection | SystemDBDAO.getConnection() イントラマートで設定されているDBへのコネクションを取得します。
Connection | SystemDBConnector.getConnection(String connect) データベースへのコネクションを取得します。
Connection | LoginGroupDBDAO.getConnection() イントラマートで設定されているDBへのコネクションを取得します。
Connection | LoginGroupDBConnector.getConnection(String connect) データベースへのコネクションを取得します。
protected Object | IntramartFileServerConnector.getResource(String key, String connect, String resource) リソースを取得します。
DbsConnection | IntramartDBDAO.getConnection() 推奨されていません。 イントラマートで設定されているDBへのコネクションを取得します。
protected Object | IntramartDBConnector.getResource(String key, String connect, String resource) 推奨されていません。 リソースを取得します。
DbsConnection | IntramartDBConnector.getConnection(String connect) 推奨されていません。 データベースへのコネクションを取得します。
boolean | DistributesDataPropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | DistributesDataPropertyHandler.getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
String | DistributesDataPropertyHandler.getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | DistributesDataPropertyHandler.getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | DistributesDataPropertyHandler.getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
ResourceParam[] | DistributesDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
boolean | DefaultDataPropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | DefaultDataPropertyHandler.getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
String | DefaultDataPropertyHandler.getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | DefaultDataPropertyHandler.getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | DefaultDataPropertyHandler.getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
ResourceParam[] | DefaultDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
protected Connection | DBDAO.getConnection() このDAOに関連づけられたコネクションを取得します。
protected Object | DBConnector.getResource(String key, String connect, String resource) リソースを取得します。
Connection | DBConnector.getConnection(String resource) データベースへのコネクションを取得します。
boolean | DataPropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | DataPropertyHandler.getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
String | DataPropertyHandler.getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | DataPropertyHandler.getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | DataPropertyHandler.getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
ResourceParam[] | DataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
protected abstract Object | DataConnector.getResource(String key, String connect, String resource) リソースを取得します。
Object | DataAccessController.getDAO(String application, String key, String connect) DAOを取得します。

jp.co.intra_mart.framework.base.event での DataPropertyException の使用

DataPropertyException をスローする jp.co.intra_mart.framework.base.event のメソッド
protected Object | StandardEventListener.getDAO(String application, String key, String connect) DAOを取得します。
protected Object | EventTriggerAdapter.getDAO(String application, String key, String connect) DAOを取得します。

jp.co.intra_mart.framework.extension.seasar.data での DataPropertyException の使用

DataPropertyException をスローする jp.co.intra_mart.framework.extension.seasar.data のメソッド
 Object S2DataAccessController.getDAO(String application, String key, String connect)
DAOを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.data.DataPropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.data.DataPropertyHandler の使用

DataPropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.data.container |
jp.co.intra_mart.framework.extension.seasar.data |

jp.co.intra_mart.framework.base.data での DataPropertyHandler の使用

DataPropertyHandler を実装している jp.co.intra_mart.framework.base.data のクラス
class | DefaultDataPropertyHandler デフォルトのデータプロパティハンドラです。
class | DistributesDataPropertyHandler アプリケーション毎のプロパティハンドラを呼び出します。
class | TextFileDataPropertyHandler 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
class | XmlDataPropertyHandler XMLのデータプロパティハンドラです。

DataPropertyHandler を返す jp.co.intra_mart.framework.base.data のメソッド
DataPropertyHandler | DataManager.getDataPropertyHandler() データプロパティハンドラを取得します。
DataPropertyHandler | DataConnector.getDataPropertyHandler() データプロパティハンドラを取得します。
DataPropertyHandler | DataAccessController.getDataPropertyHandler() データプロパティハンドラを取得します。

DataPropertyHandler 型のパラメータを持つ jp.co.intra_mart.framework.base.data のメソッド
 void DataConnector.setDataPropertyHandler(DataPropertyHandler handler)
データプロパティハンドラを設定します。

DataPropertyHandler 型のパラメータを持つ jp.co.intra_mart.framework.base.data のコンストラクタ
DataAccessController(DataPropertyHandler handler)
データアクセスコントローラを生成します。

jp.co.intra_mart.framework.base.data.container での DataPropertyHandler の使用

DataPropertyHandler を返す jp.co.intra_mart.framework.base.data.container のメソッド
DataPropertyHandler | DataContainerImpl.getDataPropertyHandler() データプロパティハンドラを取得します。
DataPropertyHandler | DataContainer.getDataPropertyHandler() データプロパティハンドラを取得します。

jp.co.intra_mart.framework.extension.seasar.data での DataPropertyHandler の使用

DataPropertyHandler を返す jp.co.intra_mart.framework.extension.seasar.data のメソッド
 DataPropertyHandler S2DataContainer.getDataPropertyHandler()
データプロパティハンドラを取得します。

DataPropertyHandler 型のパラメータを持つ jp.co.intra_mart.framework.extension.seasar.data のコンストラクタ
S2DataAccessController(DataPropertyHandler handler)
データアクセスコントローラを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataSourceConnector の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataSourceConnector の使用

jp.co.intra_mart.framework.base.data.DataSourceConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DBConnector の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DBConnector の使用

DBConnector を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DBConnector の使用

jp.co.intra_mart.framework.base.data での DBConnector のサブクラス
class | DataSourceConnector DataSourceに関連するデータコネクタです。
class | JDBCConnector 推奨されていません。 JDBCを直接扱わず、DataSourceを使用するようにしてください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DBDAO の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DBDAO の使用

jp.co.intra_mart.framework.base.data.DBDAO はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler の使用

jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の使用

jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.IntramartDBConnector の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.IntramartDBConnector の使用

jp.co.intra_mart.framework.base.data.IntramartDBConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.IntramartDBDAO の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.IntramartDBDAO の使用

jp.co.intra_mart.framework.base.data.IntramartDBDAO はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.IntramartFileServerConnector の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.IntramartFileServerConnector の使用

jp.co.intra_mart.framework.base.data.IntramartFileServerConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.IntramartFileServerDAO の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.IntramartFileServerDAO の使用

jp.co.intra_mart.framework.base.data.IntramartFileServerDAO はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.JDBCConnector の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.JDBCConnector の使用

jp.co.intra_mart.framework.base.data.JDBCConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.LoginGroupDBConnector の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.LoginGroupDBConnector の使用

jp.co.intra_mart.framework.base.data.LoginGroupDBConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.LoginGroupDBDAO の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.LoginGroupDBDAO の使用

jp.co.intra_mart.framework.base.data.LoginGroupDBDAO はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.ResourceModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.ResourceModel の使用

jp.co.intra_mart.framework.base.data.ResourceModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.ResourceParam の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.ResourceParam の使用

ResourceParam を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での ResourceParam の使用

ResourceParam を返す jp.co.intra_mart.framework.base.data のメソッド
ResourceParam[] | XmlDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
ResourceParam[] | TextFileDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
ResourceParam[] | DistributesDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
ResourceParam[] | DefaultDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
ResourceParam[] | DataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。

ResourceParam 型のパラメータを持つ jp.co.intra_mart.framework.base.data のメソッド
protected Connection | JDBCConnector.putResource(String resource, ResourceParam[] params) 推奨されていません。 接続先のリソースを追加します。
protected abstract Connection | DBConnector.putResource(String resource, ResourceParam[] params) 接続先のリソースを追加します。
protected Connection | DataSourceConnector.putResource(String resource, ResourceParam[] params) 接続先のリソースを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.SystemDBConnector の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.SystemDBConnector の使用

jp.co.intra_mart.framework.base.data.SystemDBConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.SystemDBDAO の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.SystemDBDAO の使用

jp.co.intra_mart.framework.base.data.SystemDBDAO はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler の使用

jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler の使用

jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.data.container.DataContainer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.data.container.DataContainer の使用

DataContainer を使用しているパッケージ
jp.co.intra_mart.framework.base.data.container
jp.co.intra_mart.framework.extension.seasar.data

jp.co.intra_mart.framework.base.data.container での DataContainer の使用

DataContainer を実装している jp.co.intra_mart.framework.base.data.container のクラス
 class DataContainerImpl
DataContainerの標準的な実装クラスです。

jp.co.intra_mart.framework.extension.seasar.data での DataContainer の使用

DataContainer を実装している jp.co.intra_mart.framework.extension.seasar.data のクラス
 class S2DataContainer
S2DataContainer　は　Seasar2　と連携するためのDataContainer実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.container.DataContainerException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.container.DataContainerException の使用

jp.co.intra_mart.framework.base.data.container.DataContainerException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.container.DataContainerImpl の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.container.DataContainerImpl の使用

jp.co.intra_mart.framework.base.data.container.DataContainerImpl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.container.factory.DataContainerFactory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.container.factory.DataContainerFactory の使用

jp.co.intra_mart.framework.base.data.container.factory.DataContainerFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.container.factory.DefaultDataProvider の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.container.factory.DefaultDataProvider の使用

jp.co.intra_mart.framework.base.data.container.factory.DefaultDataProvider はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DataContainerFactory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data.container.factory
クラス DataContainerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.container.factory.DataContainerFactory
すべての実装インタフェース:
IMContainerFactory
public class DataContainerFactory
extends Object
implements IMContainerFactory

DataContainerのファクトリクラスです。 生成されるデータコンテナはプロバイダーにより決定されます。

導入されたバージョン:
6.0

フィールドの概要
protected static Provider provider
コンストラクタの概要
DataContainerFactory()
メソッドの概要
IMContainer | create() DataContainerを生成します。
Provider | getProvider() プロバイダを返します。
void | setProvider(Provider p) プロバイダを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

provider

protected static Provider provider
コンストラクタの詳細

DataContainerFactory

public DataContainerFactory()
メソッドの詳細

create

public IMContainer create()
                   throws IMContainerException
DataContainerを生成します。

定義:
インタフェース IMContainerFactory 内の create
戻り値:
データコンテナ
例外:
IMContainerException - データコンテナ生成時に例外が発生。

getProvider

public Provider getProvider()
プロバイダを返します。

定義:
インタフェース IMContainerFactory 内の getProvider
戻り値:
データコンテナのプロバイダ

setProvider

public void setProvider(Provider p)
プロバイダを設定します。

定義:
インタフェース IMContainerFactory 内の setProvider
パラメータ:
p - データコンテナのプロバイダ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DefaultDataProvider (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data.container.factory
クラス DefaultDataProvider

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.container.factory.DefaultDataProvider
すべての実装インタフェース:
Provider
public class DefaultDataProvider
extends Object
implements Provider

標準的なプロバイダーです。
クラスパス上のリソースファイルを取得し、データコンテナの実装を決定します。

リソースファイル名 - imartContainer.properties
キー - dataContainer

キーにはDataContainerインターフェースの実装クラスをフルパッケージ名で指定してください。

導入されたバージョン:
6.0

コンストラクタの概要
DefaultDataProvider()
DefaultDataProviderを新規に生成します。
メソッドの概要
 IMContainer create()
DataContainerを生成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DefaultDataProvider

public DefaultDataProvider()
DefaultDataProviderを新規に生成します。

メソッドの詳細

create

public IMContainer create()
                   throws IMContainerException
DataContainerを生成します。

定義:
インタフェース Provider 内の create
戻り値:
データコンテナ
例外:
IMContainerException - データコンテナ生成時に例外が発生。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.data.container.factory (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.base.data.container.factory
クラス
DataContainerFactory
DefaultDataProvider


jp.co.intra_mart.framework.base.data.container.factory (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.data.container.factory

クラスの概要
DataContainerFactory | DataContainerのファクトリクラスです。
DefaultDataProvider | 標準的なプロバイダーです。


jp.co.intra_mart.framework.base.data.container.factory クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.data.container.factory の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.data.container.factory.DataContainerFactory (implements jp.co.intra_mart.framework.system.container.factory.IMContainerFactory)
    • class jp.co.intra_mart.framework.base.data.container.factory.DefaultDataProvider (implements jp.co.intra_mart.framework.system.container.factory.Provider)


パッケージ jp.co.intra_mart.framework.base.data.container.factory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.data.container.factory の使用

jp.co.intra_mart.framework.base.data.container.factory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DataContainer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data.container
インタフェース DataContainer

すべてのスーパーインタフェース:
IMContainer
既知の実装クラスの一覧:
DataContainerImpl, S2DataContainer
public interface DataContainer
extends IMContainer

データコンテナのインターフェースです。
データコンテナはDataManagerの振る舞いを決定します。 DataManagerではデータコンテナを保管し、その挙動はデータコンテナの実装クラスに依存します。 データコンテナの実装は通常DataContainerFactoryによって生成されます。

導入されたバージョン:
6.0

フィールドの概要
static String DATA_PROPERTY_HANDLER_KEY
データプロパティハンドラのキー
メソッドの概要
DataAccessController | getDataAccessController() データアクセスコントローラを取得します。
DataPropertyHandler | getDataPropertyHandler() データプロパティハンドラを取得します。
インタフェース jp.co.intra_mart.framework.system.container.IMContainer から継承したメソッド
init

フィールドの詳細

DATA_PROPERTY_HANDLER_KEY

public static final String DATA_PROPERTY_HANDLER_KEY
データプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getDataPropertyHandler

public DataPropertyHandler getDataPropertyHandler()
データプロパティハンドラを取得します。

戻り値:
データプロパティハンドラ

getDataAccessController

public DataAccessController getDataAccessController()
データアクセスコントローラを取得します。

戻り値:
データアクセスコントローラ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DataContainerException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data.container
クラス DataContainerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.container.DataContainerException
すべての実装インタフェース:
Serializable
public class DataContainerException
extends SystemException

データコンテナ設定時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DataContainerException()
詳細メッセージを指定しないで DataContainerException を構築します。
DataContainerException(String msg)
指定された詳細メッセージを持つ DataContainerException を構築します。
DataContainerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataContainerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataContainerException

public DataContainerException()
詳細メッセージを指定しないで DataContainerException を構築します。

DataContainerException

public DataContainerException(String msg)
指定された詳細メッセージを持つ DataContainerException を構築します。

パラメータ:
msg - 詳細メッセージ

DataContainerException

public DataContainerException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataContainerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DataContainerImpl (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data.container
クラス DataContainerImpl

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.container.DataContainerImpl
すべての実装インタフェース:
DataContainer, IMContainer
public class DataContainerImpl
extends Object
implements DataContainer

DataContainerの標準的な実装クラスです。

フィールドの概要
インタフェース jp.co.intra_mart.framework.base.data.container.DataContainer から継承したフィールド
DATA_PROPERTY_HANDLER_KEY
コンストラクタの概要
DataContainerImpl()
DataContainerImplを生成します。
メソッドの概要
DataAccessController | getDataAccessController() データアクセスコントローラを取得します。
DataPropertyHandler | getDataPropertyHandler() データプロパティハンドラを取得します。
void | init() DataContainerを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DataContainerImpl

public DataContainerImpl()
DataContainerImplを生成します。

メソッドの詳細

init

public void init()
          throws IMContainerException
DataContainerを初期化します。

定義:
インタフェース IMContainer 内の init
例外:
IMContainerException

getDataPropertyHandler

public DataPropertyHandler getDataPropertyHandler()
データプロパティハンドラを取得します。

定義:
インタフェース DataContainer 内の getDataPropertyHandler
戻り値:
データプロパティハンドラ

getDataAccessController

public DataAccessController getDataAccessController()
データアクセスコントローラを取得します。

定義:
インタフェース DataContainer 内の getDataAccessController
戻り値:
データアクセスコントローラ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.data.container (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.base.data.container
インタフェース
DataContainer
クラス
DataContainerImpl
例外
DataContainerException


jp.co.intra_mart.framework.base.data.container (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.data.container

インタフェースの概要
DataContainer データコンテナのインターフェースです。

クラスの概要
DataContainerImpl DataContainerの標準的な実装クラスです。

例外の概要
DataContainerException データコンテナ設定時の例外です。


jp.co.intra_mart.framework.base.data.container クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.data.container の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.data.container.DataContainerImpl (implements jp.co.intra_mart.framework.base.data.container.DataContainer)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.data.container.DataContainerException

インタフェース階層

  • interface jp.co.intra_mart.framework.system.container.IMContainer
    • interface jp.co.intra_mart.framework.base.data.container.DataContainer


パッケージ jp.co.intra_mart.framework.base.data.container の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.data.container の使用

jp.co.intra_mart.framework.base.data.container を使用しているパッケージ
jp.co.intra_mart.framework.base.data.container
jp.co.intra_mart.framework.extension.seasar.data

jp.co.intra_mart.framework.base.data.container により使用される jp.co.intra_mart.framework.base.data.container のクラス
DataContainer
データコンテナのインターフェースです。

jp.co.intra_mart.framework.extension.seasar.data により使用される jp.co.intra_mart.framework.base.data.container のクラス
DataContainer
データコンテナのインターフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ConnectorModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス ConnectorModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.ConnectorModel
public class ConnectorModel
extends Object

コネクタ情報を管理するクラスです。

バージョン:
1.0

フィールドの概要
static String | ID
static String | P_ID_CONNECTOR_CLASS
static String | P_ID_CONNECTOR_NAME
static String | P_ID_RESOURCE_NAME
コンストラクタの概要
ConnectorModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID

public static final String ID
関連項目:
定数フィールド値

P_ID_CONNECTOR_NAME

public static final String P_ID_CONNECTOR_NAME
関連項目:
定数フィールド値

P_ID_CONNECTOR_CLASS

public static final String P_ID_CONNECTOR_CLASS
関連項目:
定数フィールド値

P_ID_RESOURCE_NAME

public static final String P_ID_RESOURCE_NAME
関連項目:
定数フィールド値
コンストラクタの詳細

ConnectorModel

public ConnectorModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DAO (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
インタフェース DAO

既知の実装クラスの一覧:
DAOAdapter, DBDAO, IntramartDBDAO, IntramartFileServerDAO, LoginGroupDBDAO, SystemDBDAO
public interface DAO

データリソースにアクセスするインタフェースです。 すべてのDAOはこのインタフェースを実装する必要があります。

バージョン:
1.0

メソッドの概要
 void setConnectInfo(DataConnector connector, String resource, String key, String connect)
データリソースに接続する時の情報を設定します。

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
データリソースに接続する時の情報を設定します。

パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DAOAdapter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DAOAdapter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DAOAdapter
すべての実装インタフェース:
DAO
public class DAOAdapter
extends Object
implements DAO

DAOのすべてのメソッドを何もしないように実装したクラスです。 データリソースへの接続を必要としない場合や、 開発時のスタブ用のDAOとして一時的に使うDAOを作るときなどは このクラスを継承すると便利です。

導入されたバージョン:
3.2

コンストラクタの概要
DAOAdapter()
DAOAdapterを新規に生成します。
メソッドの概要
 void setConnectInfo(DataConnector connector, String resource, String key, String connect)
データリソースに接続する時の情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DAOAdapter

public DAOAdapter()
DAOAdapterを新規に生成します。

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
データリソースに接続する時の情報を設定します。 このクラスではkのメソッドは何もしません。

定義:
インタフェース DAO 内の setConnectInfo
パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DAOException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DAOException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.DAOException
すべての実装インタフェース:
Serializable
public class DAOException
extends SystemException

リソースコネクタの情報取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DAOException()
詳細メッセージを指定しないで DAOException を構築します。
DAOException(String msg)
指定された詳細メッセージを持つ DAOException を構築します。
DAOException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DAOException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DAOException

public DAOException()
詳細メッセージを指定しないで DAOException を構築します。

DAOException

public DAOException(String msg)
指定された詳細メッセージを持つ DAOException を構築します。

パラメータ:
msg - 詳細メッセージ

DAOException

public DAOException(String msg,
                    Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DAOException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DaoModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DaoModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DaoModel
public class DaoModel
extends Object

DaoModelを管理するクラスです。

バージョン:
1.0

フィールドの概要
static String | ID
static String | P_ID_CONNECT_NAME
static String | P_ID_DAO_CLASS
static String | P_ID_DAO_CONNECTOR_NAME
コンストラクタの概要
DaoModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID

public static final String ID
関連項目:
定数フィールド値

P_ID_CONNECT_NAME

public static final String P_ID_CONNECT_NAME
関連項目:
定数フィールド値

P_ID_DAO_CLASS

public static final String P_ID_DAO_CLASS
関連項目:
定数フィールド値

P_ID_DAO_CONNECTOR_NAME

public static final String P_ID_DAO_CONNECTOR_NAME
関連項目:
定数フィールド値
コンストラクタの詳細

DaoModel

public DaoModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataAccessController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataAccessController

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataAccessController
直系の既知のサブクラス:
S2DataAccessController
public class DataAccessController
extends Object

データアクセスを制御します。 DAOの取得、コネクタの管理等を行います。 このクラスを利用して簡易トランザクションを実現することも可能ですが、この方法は推奨されません。 トランザクションはできる限りJava Transaction API(JTA)のUserTransactionを利用して行ってください。

バージョン:
1.0

コンストラクタの概要
DataAccessController(DataPropertyHandler handler)
データアクセスコントローラを生成します。
メソッドの概要
void | commit() すべてのデータコネクタをコミットします。
Object | getDAO(String application, String key, String connect) DAOを取得します。
protected Map | getDataConnectors() DataAccessControllerがキャッシュしているDataConnectorの一覧を取得します。
DataPropertyHandler | getDataPropertyHandler() データプロパティハンドラを取得します。
void | release() すべてのデータストアの資源を解放します。
void | rollback() すべてのデータコネクタをロールバックします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DataAccessController

public DataAccessController(DataPropertyHandler handler)
データアクセスコントローラを生成します。

パラメータ:
handler - データプロパティハンドラ
メソッドの詳細

getDataConnectors

protected Map getDataConnectors()
DataAccessControllerがキャッシュしているDataConnectorの一覧を取得します。

戻り値:
DataConnector

getDataPropertyHandler

public DataPropertyHandler getDataPropertyHandler()
データプロパティハンドラを取得します。

戻り値:
データプロパティハンドラ
導入されたバージョン:
6.0

getDAO

public Object getDAO(String application,
                     String key,
                     String connect)
              throws DataPropertyException,
                     DataConnectorException,
                     DAOException,
                     DataConnectException
DAOを取得します。 キーと接続情報で指定されたDAOを取得します。

パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAO
例外:
DataPropertyException - プロパティの取得に失敗
DataConnectorException - データコネクタの取得に失敗
DAOException - DAOの取得に失敗
DataConnectException - データリソースとの接続に失敗

commit

public void commit()
            throws DataConnectException
すべてのデータコネクタをコミットします。 このメソッドはこのクラスのgetDAO(String, String, String)で取得されたDAOに関連するデータコネクタのDataConnector.commit()を順に呼び出すことで簡易的なトランザクションを実現しています。 そのため、複数のデータベースにアクセスしたトランザクションの場合は2-Phaseコミットほど堅牢なトランザクションにはならない場合があります。

例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
すべてのデータコネクタをロールバックします。 このメソッドはこのクラスのgetDAO(String, String, String)で取得されたDAOに関連するデータコネクタのDataConnector.rollback()を順に呼び出すことで簡易的なトランザクションを実現しています。 そのため、複数のデータベースにアクセスしたトランザクションの場合は2-Phaseコミットほど堅牢なトランザクションにはならない場合があります。

例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
すべてのデータストアの資源を解放します。 このメソッドはこのクラスのgetDAO(String, String, String)で取得されたDAOに関連するデータコネクタのDataConnector.release()を順に呼び出しています。

例外:
DataConnectException - 資源開放に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataAccessException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataAccessException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.DataAccessException
すべての実装インタフェース:
Serializable
public class DataAccessException
extends SystemException

データアクセス時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DataAccessException()
詳細メッセージを指定しないで DataAccessException を構築します。
DataAccessException(String msg)
指定された詳細メッセージを持つ DataAccessException を構築します。
DataAccessException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataAccessException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataAccessException

public DataAccessException()
詳細メッセージを指定しないで DataAccessException を構築します。

DataAccessException

public DataAccessException(String msg)
指定された詳細メッセージを持つ DataAccessException を構築します。

パラメータ:
msg - 詳細メッセージ

DataAccessException

public DataAccessException(String msg,
                           Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataAccessException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataConnectException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataConnectException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.DataConnectException
すべての実装インタフェース:
Serializable
public class DataConnectException
extends SystemException

データ接続に関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DataConnectException()
詳細メッセージを指定しないで DataConnectException を構築します。
DataConnectException(String msg)
指定された詳細メッセージを持つ DataConnectException を構築します。
DataConnectException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataConnectException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataConnectException

public DataConnectException()
詳細メッセージを指定しないで DataConnectException を構築します。

DataConnectException

public DataConnectException(String msg)
指定された詳細メッセージを持つ DataConnectException を構築します。

パラメータ:
msg - 詳細メッセージ

DataConnectException

public DataConnectException(String msg,
                            Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataConnectException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataConnector (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
直系の既知のサブクラス:
DBConnector, IntramartDBConnector, IntramartFileServerConnector, LoginGroupDBConnector, SystemDBConnector
public abstract class DataConnector
extends Object

データストアに接続するコネクタです。

バージョン:
1.0

コンストラクタの概要
DataConnector()
新規のDataConnectorを生成します。
メソッドの概要
abstract void | commit() コミットします。
DataPropertyHandler | getDataPropertyHandler() データプロパティハンドラを取得します。
protected abstract Object | getResource(String key, String connect, String resource) リソースを取得します。
abstract void | release() データストアの資源を解放します。
abstract void | rollback() ロールバックします。
void | setDataPropertyHandler(DataPropertyHandler handler) データプロパティハンドラを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DataConnector

public DataConnector()
新規のDataConnectorを生成します。

メソッドの詳細

setDataPropertyHandler

public void setDataPropertyHandler(DataPropertyHandler handler)
データプロパティハンドラを設定します。

パラメータ:
handler - データプロパティハンドラ

getDataPropertyHandler

public DataPropertyHandler getDataPropertyHandler()
データプロパティハンドラを取得します。

戻り値:
データプロパティハンドラ

getResource

protected abstract Object getResource(String key,
                                      String connect,
                                      String resource)
                               throws DataPropertyException,
                                      DataConnectException
リソースを取得します。

パラメータ:
key - キー
connect - 接続情報
resource - リソース名
戻り値:
リソース
例外:
DataPropertyException - リソースの取得に失敗
DataConnectException - 接続に失敗

commit

public abstract void commit()
                     throws DataConnectException
コミットします。

例外:
DataConnectException - コミットに失敗

rollback

public abstract void rollback()
                       throws DataConnectException
ロールバックします。

例外:
DataConnectException - ロールバックに失敗

release

public abstract void release()
                      throws DataConnectException
データストアの資源を解放します。

例外:
DataConnectException - 資源開放に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataConnectorException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataConnectorException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.DataConnectorException
すべての実装インタフェース:
Serializable
public class DataConnectorException
extends SystemException

データコネクタ取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DataConnectorException()
詳細メッセージを指定しないで DataConnectorException を構築します。
DataConnectorException(String msg)
指定された詳細メッセージを持つ DataConnectorException を構築します。
DataConnectorException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataConnectorException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataConnectorException

public DataConnectorException()
詳細メッセージを指定しないで DataConnectorException を構築します。

DataConnectorException

public DataConnectorException(String msg)
指定された詳細メッセージを持つ DataConnectorException を構築します。

パラメータ:
msg - 詳細メッセージ

DataConnectorException

public DataConnectorException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataConnectorException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataManager
public class DataManager
extends Object

データストアとの接続を管理します。

バージョン:
1.0

フィールドの概要
static String DATA_PROPERTY_HANDLER_KEY
データプロパティハンドラのキー
コンストラクタの概要
protected DataManager()
データマネージャを生成するコンストラクタです。
メソッドの概要
DataAccessController | getDataAccessController() データアクセスコントローラを取得します。
static DataManager | getDataManager() データマネージャを取得します。
DataPropertyHandler | getDataPropertyHandler() データプロパティハンドラを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DATA_PROPERTY_HANDLER_KEY

public static final String DATA_PROPERTY_HANDLER_KEY
データプロパティハンドラのキー

関連項目:
定数フィールド値
コンストラクタの詳細

DataManager

protected DataManager()
               throws DataManagerException
データマネージャを生成するコンストラクタです。 このコンストラクタは明示的に呼び出すことはできません。

例外:
DataManagerException - データマネージャの生成に失敗した
メソッドの詳細

getDataManager

public static DataManager getDataManager()
                                  throws DataManagerException
データマネージャを取得します。

戻り値:
データマネージャ
例外:
DataManagerException - データマネージャの設定に失敗した

getDataAccessController

public DataAccessController getDataAccessController()
データアクセスコントローラを取得します。

戻り値:
データアクセスコントローラ

getDataPropertyHandler

public DataPropertyHandler getDataPropertyHandler()
データプロパティハンドラを取得します。

戻り値:
データプロパティハンドラ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataManagerException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.DataManagerException
すべての実装インタフェース:
Serializable
public class DataManagerException
extends SystemException

データマネージャの設定時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DataManagerException()
詳細メッセージを指定しないで DataManagerException を構築します。
DataManagerException(String msg)
指定された詳細メッセージを持つ DataManagerException を構築します。
DataManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataManagerException

public DataManagerException()
詳細メッセージを指定しないで DataManagerException を構築します。

DataManagerException

public DataManagerException(String msg)
指定された詳細メッセージを持つ DataManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

DataManagerException

public DataManagerException(String msg,
                            Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataPropertyException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataPropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.DataPropertyException
すべての実装インタフェース:
Serializable
public class DataPropertyException
extends SystemException

データプロパティ取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DataPropertyException()
詳細メッセージを指定しないで DataPropertyException を構築します。
DataPropertyException(String msg)
指定された詳細メッセージを持つ DataPropertyException を構築します。
DataPropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataPropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataPropertyException

public DataPropertyException()
詳細メッセージを指定しないで DataPropertyException を構築します。

DataPropertyException

public DataPropertyException(String msg)
指定された詳細メッセージを持つ DataPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

DataPropertyException

public DataPropertyException(String msg,
                             Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DataPropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
インタフェース DataPropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultDataPropertyHandler, DistributesDataPropertyHandler, TextFileDataPropertyHandler, XmlDataPropertyHandler
public interface DataPropertyHandler
extends PropertyHandler

DAOの設定情報に接続するクラスです。

バージョン:
1.0

メソッドの概要
String | getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
String | getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
ResourceParam[] | getResourceParams(String name) リソースのパラメータを取得します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws DataPropertyException
プロパティの動的読み込みが可能かどうか調べます。

戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可
例外:
DataPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getDAOName

public String getDAOName(String application,
                         String key,
                         String connect)
                  throws DataPropertyException
DAOのクラス名を取得します。 application、keyとconnectで指定されたDAOのクラス名を取得します。

パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAOのクラス名
例外:
DataPropertyException - DAOのクラス名の取得に失敗

getConnectorName

public String getConnectorName(String application,
                               String key,
                               String connect)
                        throws DataPropertyException
DAOに対するデータコネクタ名を取得します。 application、keyとconnectで指定されたDAOのデータコネクタ名を取得します。 対応するデータコネクタ名が指定されていない場合、nullが返ります。

パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
データコネクタの名前
例外:
DataPropertyException - データコネクタ名の取得時に例外が発生

getConnectorClassName

public String getConnectorClassName(String connectorName)
                             throws DataPropertyException
データコネクタのクラス名を取得します。 application、keyとconnectで指定されたデータコネクタのクラス名を取得します。

パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのクラス名
例外:
DataPropertyException - データコネクタのクラス名の取得に失敗

getConnectorResource

public String getConnectorResource(String connectorName)
                            throws DataPropertyException
データコネクタのリソース名を取得します。 application、keyとconnectで指定されたデータコネクタのリソース名を取得します。 対応するリソース名がない場合、nullを返します。

パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのリソース名
例外:
DataPropertyException - データコネクタのリソース名の取得時に例外が発生

getResourceParams

public ResourceParam[] getResourceParams(String name)
                                  throws DataPropertyException
リソースのパラメータを取得します。 nameで指定されたリソースのパラメータを取得します。

パラメータ:
name - リソース名
戻り値:
リソースのパラメータ
例外:
DataPropertyException - リソースのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DataSourceConnector (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataSourceConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.DBConnector
            拡張 jp.co.intra_mart.framework.base.data.DataSourceConnector
public class DataSourceConnector
extends DBConnector

DataSourceに関連するデータコネクタです。 このデータコネクタはJava Transaction API(JTA)のUserTransactionの中で使うことが前提となっています。 また、KEY_JNDI_NAMEで指定されるパラメータにDataSourceのJNDI名を必ず指定してください。

バージョン:
1.0

フィールドの概要
static String KEY_JNDI_NAME
DataSourceのJNDI名のキー
クラス jp.co.intra_mart.framework.base.data.DBConnector から継承したフィールド
resources
コンストラクタの概要
DataSourceConnector()
DataSourceConnectorを新規に生成します。
メソッドの概要
void | commit() コミットします。
protected Connection | putResource(String resource, ResourceParam[] params) 接続先のリソースを追加します。
void | release() データストアの資源を解放します。
void | rollback() ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DBConnector から継承したメソッド
getConnection, getResource
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KEY_JNDI_NAME

public static final String KEY_JNDI_NAME
DataSourceのJNDI名のキー

関連項目:
定数フィールド値
コンストラクタの詳細

DataSourceConnector

public DataSourceConnector()
DataSourceConnectorを新規に生成します。

メソッドの詳細

commit

public void commit()
            throws DataConnectException
コミットします。 実際にはこのクラスではこのメソッドは何もしません。

オーバーライド:
クラス DBConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
ロールバックします。 実際にはこのクラスではこのメソッドは何もしません。

オーバーライド:
クラス DBConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
データストアの資源を解放します。

オーバーライド:
クラス DBConnector 内の release
例外:
DataConnectException - 資源開放に失敗

putResource

protected Connection putResource(String resource,
                                 ResourceParam[] params)
                          throws DataConnectException
接続先のリソースを追加します。

定義:
クラス DBConnector 内の putResource
パラメータ:
resource - リソース
params - リソースのパラメータ
戻り値:
コネクション
例外:
DataConnectException - 接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBConnector (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DBConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.DBConnector
直系の既知のサブクラス:
DataSourceConnector, JDBCConnector
public abstract class DBConnector
extends DataConnector

データベースに対するコネクタです。

バージョン:
1.0

フィールドの概要
protected  Map resources
リソース一覧
コンストラクタの概要
DBConnector()
DBConnectorを新規に生成します。
メソッドの概要
void | commit() コミットします。
Connection | getConnection(String resource) データベースへのコネクションを取得します。
protected Object | getResource(String key, String connect, String resource) リソースを取得します。
protected abstract Connection | putResource(String resource, ResourceParam[] params) 接続先のリソースを追加します。
void | release() データストアの資源を解放します。
void | rollback() ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

resources

protected Map resources
リソース一覧

コンストラクタの詳細

DBConnector

public DBConnector()
DBConnectorを新規に生成します。

メソッドの詳細

putResource

protected abstract Connection putResource(String resource,
                                          ResourceParam[] params)
                                   throws DataConnectException
接続先のリソースを追加します。

パラメータ:
resource - リソース
params - リソースのパラメータ
戻り値:
コネクション
例外:
DataConnectException - 接続に失敗

getResource

protected Object getResource(String key,
                             String connect,
                             String resource)
                      throws DataPropertyException,
                             DataConnectException
リソースを取得します。

定義:
クラス DataConnector 内の getResource
パラメータ:
key - キー
connect - 接続情報
resource - リソース名
戻り値:
リソース
例外:
DataPropertyException - リソースの取得に失敗
DataConnectException - 接続に失敗

getConnection

public Connection getConnection(String resource)
                         throws DataPropertyException,
                                DataConnectException
データベースへのコネクションを取得します。

パラメータ:
resource - リソース名
戻り値:
データベースへのコネクション
例外:
DataPropertyException - データベースへのコネクションの取得に失敗
DataConnectException - データベースへの接続に失敗

commit

public void commit()
            throws DataConnectException
コミットします。 実際にはこのクラスではこのメソッドは何もしません。

定義:
クラス DataConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
ロールバックします。 実際にはこのクラスではこのメソッドは何もしません。

定義:
クラス DataConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
データストアの資源を解放します。

定義:
クラス DataConnector 内の release
例外:
DataConnectException - 資源開放に失敗 実際にはこのクラスではこのメソッドは何もしません。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBDAO (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DBDAO

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DBDAO
すべての実装インタフェース:
DAO
public abstract class DBDAO
extends Object
implements DAO

データベースに特化したDAOです。

バージョン:
1.0

コンストラクタの概要
DBDAO()
デフォルトのコンストラクタ
メソッドの概要
protected Connection | getConnection() このDAOに関連づけられたコネクションを取得します。
void | setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBDAO

public DBDAO()
デフォルトのコンストラクタ

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
データリソースに接続する時の情報を設定します。

定義:
インタフェース DAO 内の setConnectInfo
パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗

getConnection

protected Connection getConnection()
                            throws DataConnectException,
                                   DataPropertyException
このDAOに関連づけられたコネクションを取得します。

戻り値:
コネクション
例外:
DataConnectException - コネクションの取得に失敗
DataPropertyException - データプロパティの取得に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DefaultDataPropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DefaultDataPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler
すべての実装インタフェース:
DataPropertyHandler, PropertyHandler
public class DefaultDataPropertyHandler
extends Object
implements DataPropertyHandler

デフォルトのデータプロパティハンドラです。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「プレフィックス_アプリケーションID.properties」です。また、アプリケーションに依存しない「プレフィックス.properties」があります。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにDataManager.DATA_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスはDEFAULT_BUNDLE_NAME_PARAMで示されるものです。
プロパティの検索順は、アプリケーションごとのプロパティファイル「プレフィックス_アプリケーションID.properties」が優先されます。該当するプロパティが見つからない場合、引き続いて「プレフィックス.properties」を検索します。
プロパティの設定内容は以下のとおりです。

キー | 内容 | 共通 | アプリケーション毎
dao.class.キー.接続名 | キーと接続名に対応するDAOのクラス名 | × | ○
dao.class.キー | キーに対応するデフォルトのDAOのクラス名 | × | ○
dao.connector.キー.接続名 | キーと接続名に対応するDAOのデータコネクタ名 | × | ○
dao.connector.キー | キーに対応するデフォルトのDAOのデータコネクタ名 | × | ○
connector.class.データコネクタ名 | データコネクタ名に対応するデータコネクタのクラス名 | ○ | ×
connector.resource.データコネクタ名 | データコネクタ名に対応するデータコネクタのリソース名 | ○ | ×
resource.param.リソース名.パラメータ名 | リソース名に対応するリソースのパラメータの値 | ○ | ×

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
コンストラクタの概要
DefaultDataPropertyHandler()
DefaultDataPropertyHandlerを新規に生成します。
メソッドの概要
String | getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
String | getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
ResourceParam[] | getResourceParams(String name) リソースのパラメータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultDataPropertyHandler

public DefaultDataPropertyHandler()
DefaultDataPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws DataPropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース DataPropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
DataPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getDAOName

public String getDAOName(String application,
                         String key,
                         String connect)
                  throws DataPropertyException
DAOのクラス名を取得します。 application、keyとconnectで指定されたDAOのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getDAOName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAOのクラス名
例外:
DataPropertyException - DAOのクラス名の取得に失敗

getConnectorName

public String getConnectorName(String application,
                               String key,
                               String connect)
                        throws DataPropertyException
DAOに対するデータコネクタ名を取得します。 application、keyとconnectで指定されたDAOのデータコネクタ名を取得します。 対応するデータコネクタ名が指定されていない場合、nullが返ります。

定義:
インタフェース DataPropertyHandler 内の getConnectorName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
データコネクタの名前
例外:
DataPropertyException - データコネクタ名の取得時に例外が発生

getConnectorClassName

public String getConnectorClassName(String connectorName)
                             throws DataPropertyException
データコネクタのクラス名を取得します。 application、keyとconnectで指定されたデータコネクタのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getConnectorClassName
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのクラス名
例外:
DataPropertyException - データコネクタのクラス名の取得に失敗

getConnectorResource

public String getConnectorResource(String connectorName)
                            throws DataPropertyException
データコネクタのリソース名を取得します。 application、keyとconnectで指定されたデータコネクタのリソース名を取得します。 対応するリソース名がない場合、nullを返します。

定義:
インタフェース DataPropertyHandler 内の getConnectorResource
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのリソース名
例外:
DataPropertyException - データコネクタのリソース名の取得時に例外が発生

getResourceParams

public ResourceParam[] getResourceParams(String name)
                                  throws DataPropertyException
リソースのパラメータを取得します。 nameで指定されたリソースのパラメータを取得します。

定義:
インタフェース DataPropertyHandler 内の getResourceParams
パラメータ:
name - リソース名
戻り値:
リソースのパラメータ
例外:
DataPropertyException - リソースのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DistributesDataPropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DistributesDataPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler
すべての実装インタフェース:
DataPropertyHandler, PropertyHandler
public class DistributesDataPropertyHandler
extends Object
implements DataPropertyHandler

アプリケーション毎のプロパティハンドラを呼び出します。
プロパティファイルはアプリケーション毎に分割されます。
この場合のファイル名は「プレフィックス_アプリケーションID.properties」、「プレフィックス_アプリケーションID.xml」です。
また、アプリケーションに依存しない「プレフィックス.properties」があります。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにDataManager.DATA_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスはDEFAULT_BUNDLE_NAME_PARAMで示されるものです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
static String | PARAM_APPLICATION プロパティファイルのアプリケーションのパラメータ名
static String | PARAM_APPLICATION_CLASS プロパティファイルのクラスのパラメータ名
static String | PARAM_APPLICATION_PARAM プロパティファイルのパラメータのパラメータ名
static String | PARAM_BUNDLE プロパティファイルのバンドルのパラメータ名
static String | PARAM_DEFAULT プロパティファイルのデフォルトのパラメータ名
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
コンストラクタの概要
DistributesDataPropertyHandler()
DefaultDataPropertyHandlerを新規に生成します。
メソッドの概要
String | getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
String | getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
ResourceParam[] | getResourceParams(String name) リソースのパラメータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値

PARAM_DEFAULT

public static final String PARAM_DEFAULT
プロパティファイルのデフォルトのパラメータ名

関連項目:
定数フィールド値

PARAM_APPLICATION

public static final String PARAM_APPLICATION
プロパティファイルのアプリケーションのパラメータ名

関連項目:
定数フィールド値

PARAM_APPLICATION_PARAM

public static final String PARAM_APPLICATION_PARAM
プロパティファイルのパラメータのパラメータ名

関連項目:
定数フィールド値

PARAM_APPLICATION_CLASS

public static final String PARAM_APPLICATION_CLASS
プロパティファイルのクラスのパラメータ名

関連項目:
定数フィールド値

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値

PARAM_BUNDLE

public static final String PARAM_BUNDLE
プロパティファイルのバンドルのパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DistributesDataPropertyHandler

public DistributesDataPropertyHandler()
DefaultDataPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws DataPropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース DataPropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
DataPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getDAOName

public String getDAOName(String application,
                         String key,
                         String connect)
                  throws DataPropertyException
DAOのクラス名を取得します。 application、keyとconnectで指定されたDAOのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getDAOName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAOのクラス名
例外:
DataPropertyException - DAOのクラス名の取得に失敗

getConnectorName

public String getConnectorName(String application,
                               String key,
                               String connect)
                        throws DataPropertyException
DAOに対するデータコネクタ名を取得します。 application、keyとconnectで指定されたDAOのデータコネクタ名を取得します。 対応するデータコネクタ名が指定されていない場合、nullが返ります。

定義:
インタフェース DataPropertyHandler 内の getConnectorName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
データコネクタの名前
例外:
DataPropertyException - データコネクタ名の取得時に例外が発生

getConnectorClassName

public String getConnectorClassName(String connectorName)
                             throws DataPropertyException
データコネクタのクラス名を取得します。 application、keyとconnectで指定されたデータコネクタのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getConnectorClassName
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのクラス名
例外:
DataPropertyException - データコネクタのクラス名の取得に失敗

getConnectorResource

public String getConnectorResource(String connectorName)
                            throws DataPropertyException
データコネクタのリソース名を取得します。 application、keyとconnectで指定されたデータコネクタのリソース名を取得します。 対応するリソース名がない場合、nullを返します。

定義:
インタフェース DataPropertyHandler 内の getConnectorResource
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのリソース名
例外:
DataPropertyException - データコネクタのリソース名の取得時に例外が発生

getResourceParams

public ResourceParam[] getResourceParams(String name)
                                  throws DataPropertyException
リソースのパラメータを取得します。 nameで指定されたリソースのパラメータを取得します。

定義:
インタフェース DataPropertyHandler 内の getResourceParams
パラメータ:
name - リソース名
戻り値:
リソースのパラメータ
例外:
DataPropertyException - リソースのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartDBConnector (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス IntramartDBConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.IntramartDBConnector
推奨されていません。 このクラスではなくLoginGroupDBConnectorまたは SystemDBConnectorを使用してください。

public class IntramartDBConnector
extends DataConnector

イントラマートで設定されているDBコネクションです。

バージョン:
1.0

フィールドの概要
protected  Map connections
推奨されていません。 DbsConnectionの一覧
コンストラクタの概要
IntramartDBConnector()
推奨されていません。 IntramartDBConnectorを新規に生成します。
メソッドの概要
void | commit() 推奨されていません。 コミットします。
DbsConnection | getConnection(String connect) 推奨されていません。 データベースへのコネクションを取得します。
protected Object | getResource(String key, String connect, String resource) 推奨されていません。 リソースを取得します。
void | release() 推奨されていません。 データストアの資源を解放します。
void | rollback() 推奨されていません。 ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

connections

protected Map connections
推奨されていません。
DbsConnectionの一覧

コンストラクタの詳細

IntramartDBConnector

public IntramartDBConnector()
推奨されていません。
IntramartDBConnectorを新規に生成します。

メソッドの詳細

commit

public void commit()
            throws DataConnectException
推奨されていません。
コミットします。

定義:
クラス DataConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
推奨されていません。
ロールバックします。

定義:
クラス DataConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
推奨されていません。
データストアの資源を解放します。

定義:
クラス DataConnector 内の release
例外:
DataConnectException - 資源開放に失敗

getResource

protected Object getResource(String key,
                             String connect,
                             String resource)
                      throws DataPropertyException,
                             DataConnectException
推奨されていません。
リソースを取得します。

定義:
クラス DataConnector 内の getResource
パラメータ:
key - キー
connect - 接続情報
resource - リソース名
戻り値:
リソース
例外:
DataPropertyException - リソースの取得に失敗
DataConnectException - 接続に失敗

getConnection

public DbsConnection getConnection(String connect)
                            throws DataPropertyException,
                                   DataConnectException
推奨されていません。
データベースへのコネクションを取得します。

パラメータ:
connect - 接続情報
戻り値:
データベースへのコネクション
例外:
DataPropertyException - データベースへのコネクションの取得に失敗
DataConnectException - データベースへの接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartDBDAO (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス IntramartDBDAO

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.IntramartDBDAO
すべての実装インタフェース:
DAO
推奨されていません。 このクラスではなくLoginGroupDBDAOまたは SystemDBDAOを使用してください。

public class IntramartDBDAO
extends Object
implements DAO

イントラマートで設定されたDBへアクセスするDAOです。 イントラマートで設定されたDBへアクセスするDAOを作る場合、このクラスをextendsします。

バージョン:
1.0

コンストラクタの概要
IntramartDBDAO()
推奨されていません。 IntramartDBDAOを新規に生成します。
メソッドの概要
DbsConnection | getConnection() 推奨されていません。 イントラマートで設定されているDBへのコネクションを取得します。
void | setConnectInfo(DataConnector connector, String resource, String key, String connect) 推奨されていません。 データリソースに接続する時の情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartDBDAO

public IntramartDBDAO()
推奨されていません。
IntramartDBDAOを新規に生成します。

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
推奨されていません。
データリソースに接続する時の情報を設定します。

定義:
インタフェース DAO 内の setConnectInfo
パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗

getConnection

public DbsConnection getConnection()
                            throws DataConnectException,
                                   DataPropertyException
推奨されていません。
イントラマートで設定されているDBへのコネクションを取得します。

戻り値:
イントラマートで設定されているDBへのコネクション
例外:
DataConnectException - データベース接続時に例外が発生
DataPropertyException - データプロパティ取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartFileServerConnector (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス IntramartFileServerConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.IntramartFileServerConnector
public class IntramartFileServerConnector
extends DataConnector

intra-martのStorageサービスに接続するデータコネクタです。 Storageサービスに対する各種のオペレーションは呼び出し終了時に書き込み等が完了するため、 実際にはトランザクションの対象とならないため注意が必要です。

導入されたバージョン:
3.2

フィールドの概要
protected  Map resources
リソース一覧
コンストラクタの概要
IntramartFileServerConnector()
IntramartFileServerConnectorを新規に生成します。
メソッドの概要
void | commit() コミットします。
NetworkFile | getNetworkFile(String path) Storageサービス上の指定されたパスのファイルにアクセスするNetworkFileを取得します。
protected Object | getResource(String key, String connect, String resource) リソースを取得します。
void | release() データストアの資源を解放します。
void | rollback() ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

resources

protected Map resources
リソース一覧

コンストラクタの詳細

IntramartFileServerConnector

public IntramartFileServerConnector()
IntramartFileServerConnectorを新規に生成します。

メソッドの詳細

getResource

protected Object getResource(String key,
                             String connect,
                             String resource)
                      throws DataPropertyException,
                             DataConnectException
リソースを取得します。

定義:
クラス DataConnector 内の getResource
パラメータ:
key - キー
connect - 接続情報
resource - リソース名
戻り値:
リソース
例外:
DataPropertyException - リソースの取得に失敗
DataConnectException - 接続に失敗

getNetworkFile

public NetworkFile getNetworkFile(String path)
Storageサービス上の指定されたパスのファイルにアクセスするNetworkFileを取得します。

パラメータ:
path - Storageサービス上のパス
戻り値:
Storageサービス上の指定されたパスのファイルにアクセスするNetworkFile

commit

public void commit()
            throws DataConnectException
コミットします。 注意:実際にはNetworkFileの各種のメソッド完了時に書き込み等が行われています。

定義:
クラス DataConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
ロールバックします。 注意:実際にはNetworkFileの各種のメソッド完了時に書き込み等が行われているため、既にファイルに書き込んだ情報は元に戻りません。

定義:
クラス DataConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
データストアの資源を解放します。

定義:
クラス DataConnector 内の release
例外:
DataConnectException - 資源開放に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartFileServerDAO (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス IntramartFileServerDAO

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.IntramartFileServerDAO
すべての実装インタフェース:
DAO
public class IntramartFileServerDAO
extends Object
implements DAO

intra-martのStorageサービスを使用する場合のDAOです。

導入されたバージョン:
3.2

コンストラクタの概要
IntramartFileServerDAO()
IntramartFileServerDAOを新規に生成します。
メソッドの概要
protected NetworkFile | getNetworkFile(String path) パスに該当するNetworkFileを取得します。
void | setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartFileServerDAO

public IntramartFileServerDAO()
IntramartFileServerDAOを新規に生成します。

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
データリソースに接続する時の情報を設定します。

定義:
インタフェース DAO 内の setConnectInfo
パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗

getNetworkFile

protected NetworkFile getNetworkFile(String path)
                              throws DataConnectorException
パスに該当するNetworkFileを取得します。

パラメータ:
path - intra-martStorageサービス上のファイルパス
戻り値:
パスに該当するNetworkFile
例外:
DataConnectorException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


JDBCConnector (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス JDBCConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.DBConnector
            拡張 jp.co.intra_mart.framework.base.data.JDBCConnector
推奨されていません。 JDBCを直接扱わず、DataSourceを使用するようにしてください。

public class JDBCConnector
extends DBConnector

JDBCを利用するデータコネクタです。

バージョン:
1.0
関連項目:
DataSourceConnector

フィールドの概要
static String | KEY_DRIVER 推奨されていません。 データベースドライバのキー
static String | KEY_PASSWORD 推奨されていません。 データベース接続ユーザパスワードのキー
static String | KEY_URL 推奨されていません。 データベースURLのキー
static String | KEY_USERNAME 推奨されていません。 データベース接続ユーザ名のキー
クラス jp.co.intra_mart.framework.base.data.DBConnector から継承したフィールド
resources
コンストラクタの概要
JDBCConnector()
推奨されていません。 新規のJDBCConnectorを生成します。
メソッドの概要
void | commit() 推奨されていません。 コミットします。
protected Connection | putResource(String resource, ResourceParam[] params) 推奨されていません。 接続先のリソースを追加します。
void | release() 推奨されていません。 データストアの資源を解放します。
void | rollback() 推奨されていません。 ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DBConnector から継承したメソッド
getConnection, getResource
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KEY_DRIVER

public static final String KEY_DRIVER
推奨されていません。
データベースドライバのキー

関連項目:
定数フィールド値

KEY_URL

public static final String KEY_URL
推奨されていません。
データベースURLのキー

関連項目:
定数フィールド値

KEY_USERNAME

public static final String KEY_USERNAME
推奨されていません。
データベース接続ユーザ名のキー

関連項目:
定数フィールド値

KEY_PASSWORD

public static final String KEY_PASSWORD
推奨されていません。
データベース接続ユーザパスワードのキー

関連項目:
定数フィールド値
コンストラクタの詳細

JDBCConnector

public JDBCConnector()
推奨されていません。
新規のJDBCConnectorを生成します。

メソッドの詳細

commit

public void commit()
            throws DataConnectException
推奨されていません。
コミットします。

オーバーライド:
クラス DBConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
推奨されていません。
ロールバックします。

オーバーライド:
クラス DBConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
推奨されていません。
データストアの資源を解放します。

オーバーライド:
クラス DBConnector 内の release
例外:
DataConnectException - 資源開放に失敗

putResource

protected Connection putResource(String resource,
                                 ResourceParam[] params)
                          throws DataConnectException
推奨されていません。
接続先のリソースを追加します。

定義:
クラス DBConnector 内の putResource
パラメータ:
resource - リソース
params - リソースのパラメータ
戻り値:
リソース
例外:
DataConnectException - 接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginGroupDBConnector (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス LoginGroupDBConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.LoginGroupDBConnector
public class LoginGroupDBConnector
extends DataConnector

イントラマートで設定されているDBコネクションです。
ログイングループIDからコネクションを取得します。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
protected  Map connections
リソース一覧
コンストラクタの概要
LoginGroupDBConnector()
LoginGroupDBConnectorを新規に生成します。
メソッドの概要
void | commit() コミットします。
Connection | getConnection(String connect) データベースへのコネクションを取得します。
protected Object | getResource(String key, String connect, String resource) リソースを取得します。
void | release() データストアの資源を解放します。
void | rollback() ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

connections

protected Map connections
リソース一覧

コンストラクタの詳細

LoginGroupDBConnector

public LoginGroupDBConnector()
LoginGroupDBConnectorを新規に生成します。

メソッドの詳細

commit

public void commit()
            throws DataConnectException
コミットします。 実際にはこのクラスではこのメソッドは何もしません。

定義:
クラス DataConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
ロールバックします。 実際にはこのクラスではこのメソッドは何もしません。

定義:
クラス DataConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
データストアの資源を解放します。

定義:
クラス DataConnector 内の release
例外:
DataConnectException - 資源開放に失敗

getConnection

public Connection getConnection(String connect)
                         throws DataPropertyException,
                                DataConnectException
データベースへのコネクションを取得します。

パラメータ:
connect - 接続情報
戻り値:
データベースへのコネクション
例外:
DataPropertyException - データベースへのコネクションの取得に失敗
DataConnectException - データベースへの接続に失敗

getResource

protected Object getResource(String key,
                             String connect,
                             String resource)
                      throws DataConnectException
リソースを取得します。

定義:
クラス DataConnector 内の getResource
パラメータ:
key - キー
connect - 接続情報
resource - リソース名
戻り値:
リソース
例外:
DataPropertyException - リソースの取得に失敗
DataConnectException - 接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginGroupDBDAO (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス LoginGroupDBDAO

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.LoginGroupDBDAO
すべての実装インタフェース:
DAO
public class LoginGroupDBDAO
extends Object
implements DAO

イントラマートで設定されたDBへアクセスするDAOです。 ログイングループIDをキーとしてDBへアクセスするDAOを作る場合、このクラスをextendsします。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
LoginGroupDBDAO()
IntramartDBDAOを新規に生成します。
メソッドの概要
Connection | getConnection() イントラマートで設定されているDBへのコネクションを取得します。
void | setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LoginGroupDBDAO

public LoginGroupDBDAO()
IntramartDBDAOを新規に生成します。

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
データリソースに接続する時の情報を設定します。

定義:
インタフェース DAO 内の setConnectInfo
パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗

getConnection

public Connection getConnection()
                         throws DataConnectException,
                                DataPropertyException
イントラマートで設定されているDBへのコネクションを取得します。

戻り値:
イントラマートで設定されているDBへのコネクション
例外:
DataConnectException - データベース接続時に例外が発生
DataPropertyException - データプロパティ取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.data (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.base.data
インタフェース
DAO
DataPropertyHandler
クラス
ConnectorModel
DAOAdapter
DaoModel
DataAccessController
DataConnector
DataManager
DataSourceConnector
DBConnector
DBDAO
DefaultDataPropertyHandler
DistributesDataPropertyHandler
IntramartDBConnector
IntramartDBDAO
IntramartFileServerConnector
IntramartFileServerDAO
JDBCConnector
LoginGroupDBConnector
LoginGroupDBDAO
ResourceModel
ResourceParam
SystemDBConnector
SystemDBDAO
TextFileDataPropertyHandler
XmlDataPropertyHandler
例外
DAOException
DataAccessException
DataConnectException
DataConnectorException
DataManagerException
DataPropertyException


jp.co.intra_mart.framework.base.data (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.data

データアクセスに関連するクラスのパッケージです。

参照:
説明

インタフェースの概要
DAO | データリソースにアクセスするインタフェースです。
DataPropertyHandler | DAOの設定情報に接続するクラスです。

クラスの概要
ConnectorModel | コネクタ情報を管理するクラスです。
DAOAdapter | DAOのすべてのメソッドを何もしないように実装したクラスです。
DaoModel | DaoModelを管理するクラスです。
DataAccessController | データアクセスを制御します。
DataConnector | データストアに接続するコネクタです。
DataManager | データストアとの接続を管理します。
DataSourceConnector | DataSourceに関連するデータコネクタです。
DBConnector | データベースに対するコネクタです。
DBDAO | データベースに特化したDAOです。
DefaultDataPropertyHandler | デフォルトのデータプロパティハンドラです。
DistributesDataPropertyHandler | アプリケーション毎のプロパティハンドラを呼び出します。
IntramartDBConnector | 推奨されていません。 このクラスではなくLoginGroupDBConnectorまたは SystemDBConnectorを使用してください。
IntramartDBDAO | 推奨されていません。 このクラスではなくLoginGroupDBDAOまたは SystemDBDAOを使用してください。
IntramartFileServerConnector | intra-martのStorageサービスに接続するデータコネクタです。
IntramartFileServerDAO | intra-martのStorageサービスを使用する場合のDAOです。
JDBCConnector | 推奨されていません。 JDBCを直接扱わず、DataSourceを使用するようにしてください。
LoginGroupDBConnector | イントラマートで設定されているDBコネクションです。
LoginGroupDBDAO | イントラマートで設定されたDBへアクセスするDAOです。
ResourceModel | Resource情報を管理するクラスです。
ResourceParam | データコネクタの初期パラメータです。
SystemDBConnector | イントラマートで設定されているDBコネクションです。
SystemDBDAO | イントラマートで設定されたDBへアクセスするDAOです。
TextFileDataPropertyHandler | 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
XmlDataPropertyHandler | XMLのデータプロパティハンドラです。

例外の概要
DAOException | リソースコネクタの情報取得時の例外です。
DataAccessException | データアクセス時の例外です。
DataConnectException | データ接続に関連する例外です。
DataConnectorException | データコネクタ取得時の例外です。
DataManagerException | データマネージャの設定時の例外です。
DataPropertyException | データプロパティ取得時の例外です。

パッケージ jp.co.intra_mart.framework.base.data の説明

データアクセスに関連するクラスのパッケージです。 EIS層（データベース、基幹システムなど）にアクセスするためのクラスがあります。


jp.co.intra_mart.framework.base.data クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.data の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.data.ConnectorModel
    • class jp.co.intra_mart.framework.base.data.DAOAdapter (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.DaoModel
    • class jp.co.intra_mart.framework.base.data.DataAccessController
    • class jp.co.intra_mart.framework.base.data.DataConnector
      • class jp.co.intra_mart.framework.base.data.DBConnector
        • class jp.co.intra_mart.framework.base.data.DataSourceConnector
        • class jp.co.intra_mart.framework.base.data.JDBCConnector
      • class jp.co.intra_mart.framework.base.data.IntramartDBConnector
      • class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector
      • class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector
      • class jp.co.intra_mart.framework.base.data.SystemDBConnector
    • class jp.co.intra_mart.framework.base.data.DataManager
    • class jp.co.intra_mart.framework.base.data.DBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class jp.co.intra_mart.framework.base.data.IntramartDBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.IntramartFileServerDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.LoginGroupDBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.base.data.ResourceParam
    • class jp.co.intra_mart.framework.base.data.ResourceModel
    • class jp.co.intra_mart.framework.base.data.SystemDBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.data.DAOException
            • class jp.co.intra_mart.framework.base.data.DataAccessException
            • class jp.co.intra_mart.framework.base.data.DataConnectException
            • class jp.co.intra_mart.framework.base.data.DataConnectorException
            • class jp.co.intra_mart.framework.base.data.DataManagerException
            • class jp.co.intra_mart.framework.base.data.DataPropertyException
    • class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)

インタフェース階層

  • interface jp.co.intra_mart.framework.base.data.DAO
  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.base.data.DataPropertyHandler


パッケージ jp.co.intra_mart.framework.base.data の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.data の使用

jp.co.intra_mart.framework.base.data を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.data.container |
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.seasar.data |
jp.co.intra_mart.framework.extension.seasar.util |

jp.co.intra_mart.framework.base.data により使用される jp.co.intra_mart.framework.base.data のクラス
DAO
データリソースにアクセスするインタフェースです。
DAOException
リソースコネクタの情報取得時の例外です。
DataAccessController
データアクセスを制御します。
DataConnectException
データ接続に関連する例外です。
DataConnector
データストアに接続するコネクタです。
DataConnectorException
データコネクタ取得時の例外です。
DataManager
データストアとの接続を管理します。
DataManagerException
データマネージャの設定時の例外です。
DataPropertyException
データプロパティ取得時の例外です。
DataPropertyHandler
DAOの設定情報に接続するクラスです。
DBConnector
データベースに対するコネクタです。
ResourceParam
データコネクタの初期パラメータです。

jp.co.intra_mart.framework.base.data.container により使用される jp.co.intra_mart.framework.base.data のクラス
DataAccessController
データアクセスを制御します。
DataPropertyHandler
DAOの設定情報に接続するクラスです。

jp.co.intra_mart.framework.base.event により使用される jp.co.intra_mart.framework.base.data のクラス
DAOException
リソースコネクタの情報取得時の例外です。
DataAccessController
データアクセスを制御します。
DataConnectException
データ接続に関連する例外です。
DataConnectorException
データコネクタ取得時の例外です。
DataPropertyException
データプロパティ取得時の例外です。

jp.co.intra_mart.framework.extension.seasar.data により使用される jp.co.intra_mart.framework.base.data のクラス
DAOException
リソースコネクタの情報取得時の例外です。
DataAccessController
データアクセスを制御します。
DataConnectException
データ接続に関連する例外です。
DataConnectorException
データコネクタ取得時の例外です。
DataPropertyException
データプロパティ取得時の例外です。
DataPropertyHandler
DAOの設定情報に接続するクラスです。

jp.co.intra_mart.framework.extension.seasar.util により使用される jp.co.intra_mart.framework.base.data のクラス
DataAccessException
データアクセス時の例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ResourceModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス ResourceModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.ResourceModel
public class ResourceModel
extends Object

Resource情報を管理するクラスです。

バージョン:
1.0

フィールドの概要
static String | ID
static String | P_ID_PARAM_NAME
static String | P_ID_PARAM_VALUE
static String | P_ID_RESOURCE_NAME
static String | P_ID_RESOURCE_PARAM
コンストラクタの概要
ResourceModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID

public static final String ID
関連項目:
定数フィールド値

P_ID_RESOURCE_NAME

public static final String P_ID_RESOURCE_NAME
関連項目:
定数フィールド値

P_ID_RESOURCE_PARAM

public static final String P_ID_RESOURCE_PARAM
関連項目:
定数フィールド値

P_ID_PARAM_NAME

public static final String P_ID_PARAM_NAME
関連項目:
定数フィールド値

P_ID_PARAM_VALUE

public static final String P_ID_PARAM_VALUE
関連項目:
定数フィールド値
コンストラクタの詳細

ResourceModel

public ResourceModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ResourceParam (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス ResourceParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
        拡張 jp.co.intra_mart.framework.base.data.ResourceParam
public class ResourceParam
extends PropertyParam

データコネクタの初期パラメータです。

バージョン:
1.0

コンストラクタの概要
ResourceParam()
ResourceParamを新規に生成します。
クラス jp.co.intra_mart.framework.system.property.PropertyParam から継承したメソッド
getName, getValue, setName, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ResourceParam

public ResourceParam()
ResourceParamを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SystemDBConnector (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス SystemDBConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.SystemDBConnector
public class SystemDBConnector
extends DataConnector

イントラマートで設定されているDBコネクションです。
システムに設定されている情報からコネクションを取得します。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
protected  Map connections
リソース一覧
コンストラクタの概要
SystemDBConnector()
SystemDBConnectorを新規に生成します。
メソッドの概要
void | commit() コミットします。
Connection | getConnection(String connect) データベースへのコネクションを取得します。
protected Object | getResource(String key, String connect, String resource) リソースを取得します。
void | release() データストアの資源を解放します。
void | rollback() ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

connections

protected Map connections
リソース一覧

コンストラクタの詳細

SystemDBConnector

public SystemDBConnector()
SystemDBConnectorを新規に生成します。

メソッドの詳細

commit

public void commit()
            throws DataConnectException
コミットします。 実際にはこのクラスではこのメソッドは何もしません。

定義:
クラス DataConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
ロールバックします。 実際にはこのクラスではこのメソッドは何もしません。

定義:
クラス DataConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
データストアの資源を解放します。

定義:
クラス DataConnector 内の release
例外:
DataConnectException - 資源開放に失敗

getConnection

public Connection getConnection(String connect)
                         throws DataPropertyException,
                                DataConnectException
データベースへのコネクションを取得します。

パラメータ:
connect - 接続情報
戻り値:
データベースへのコネクション
例外:
DataPropertyException - データベースへのコネクションの取得に失敗
DataConnectException - データベースへの接続に失敗

getResource

protected Object getResource(String key,
                             String connect,
                             String resource)
                      throws DataConnectException
リソースを取得します。

定義:
クラス DataConnector 内の getResource
パラメータ:
key - キー
connect - 接続情報
resource - リソース名
戻り値:
リソース
例外:
DataPropertyException - リソースの取得に失敗
DataConnectException - 接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SystemDBDAO (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス SystemDBDAO

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.SystemDBDAO
すべての実装インタフェース:
DAO
public class SystemDBDAO
extends Object
implements DAO

イントラマートで設定されたDBへアクセスするDAOです。 システム登録されているIDをキーとしてDBへアクセスするDAOを作る場合、このクラスをextendsします。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
SystemDBDAO()
IntramartDBDAOを新規に生成します。
メソッドの概要
Connection | getConnection() イントラマートで設定されているDBへのコネクションを取得します。
void | setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SystemDBDAO

public SystemDBDAO()
IntramartDBDAOを新規に生成します。

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
データリソースに接続する時の情報を設定します。

定義:
インタフェース DAO 内の setConnectInfo
パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗

getConnection

public Connection getConnection()
                         throws DataConnectException,
                                DataPropertyException
イントラマートで設定されているDBへのコネクションを取得します。

戻り値:
イントラマートで設定されているDBへのコネクション
例外:
DataConnectException - データベース接続時に例外が発生
DataPropertyException - データプロパティ取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TextFileDataPropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス TextFileDataPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler
すべての実装インタフェース:
DataPropertyHandler, PropertyHandler
public class TextFileDataPropertyHandler
extends Object
implements DataPropertyHandler

指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。 ファイルの書式はDefaultDataPropertyHandlerで示されるものと同じです。
ファイルが存在するディレクトリ名はPARAM_FILE_DIRで示されるパラメータ名で指定します。
PARAM_DYNAMICで示されるパラメータにtrueを指定した場合 アプリケーション実行時にもプロパティの変更を動的に反映させることが可能となりますが、 パラメータの取得時に毎回ファイル操作を行うためパフォーマンスに悪影響を与える可能性があります。 このオプションは、開発時やデバッグ時のようにパラメータを頻繁に変更する必要がある場合のみtrueとし、 通常はfalseに設定しておいてください。

導入されたバージョン:
3.2

フィールドの概要
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
コンストラクタの概要
TextFileDataPropertyHandler()
TextFileDataPropertyHandlerを新規に生成します。
メソッドの概要
String | getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
String | getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
ResourceParam[] | getResourceParams(String name) リソースのパラメータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

TextFileDataPropertyHandler

public TextFileDataPropertyHandler()
TextFileDataPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
プロパティの動的読み込みが可能かどうか調べます。

定義:
インタフェース DataPropertyHandler 内の isDynamic
戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可

getDAOName

public String getDAOName(String application,
                         String key,
                         String connect)
                  throws DataPropertyException
DAOのクラス名を取得します。 application、keyとconnectで指定されたDAOのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getDAOName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAOのクラス名
例外:
DataPropertyException - DAOのクラス名の取得に失敗

getConnectorName

public String getConnectorName(String application,
                               String key,
                               String connect)
                        throws DataPropertyException
DAOに対するデータコネクタ名を取得します。 application、keyとconnectで指定されたDAOのデータコネクタ名を取得します。 対応するデータコネクタ名が指定されていない場合、nullが返ります。

定義:
インタフェース DataPropertyHandler 内の getConnectorName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
データコネクタの名前
例外:
DataPropertyException - データコネクタ名の取得時に例外が発生

getConnectorClassName

public String getConnectorClassName(String connectorName)
                             throws DataPropertyException
データコネクタのクラス名を取得します。 application、keyとconnectで指定されたデータコネクタのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getConnectorClassName
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのクラス名
例外:
DataPropertyException - データコネクタのクラス名の取得に失敗

getConnectorResource

public String getConnectorResource(String connectorName)
                            throws DataPropertyException
データコネクタのリソース名を取得します。 application、keyとconnectで指定されたデータコネクタのリソース名を取得します。 対応するリソース名がない場合、nullを返します。

定義:
インタフェース DataPropertyHandler 内の getConnectorResource
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのリソース名
例外:
DataPropertyException - データコネクタのリソース名の取得時に例外が発生

getResourceParams

public ResourceParam[] getResourceParams(String name)
                                  throws DataPropertyException
リソースのパラメータを取得します。 nameで指定されたリソースのパラメータを取得します。

定義:
インタフェース DataPropertyHandler 内の getResourceParams
パラメータ:
name - リソース名
戻り値:
リソースのパラメータ
例外:
DataPropertyException - リソースのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XmlDataPropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス XmlDataPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler
すべての実装インタフェース:
DataPropertyHandler, PropertyHandler
public class XmlDataPropertyHandler
extends Object
implements DataPropertyHandler

XMLのデータプロパティハンドラです。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「プレフィックス_アプリケーションID.xml」です。また、アプリケーションに依存しない「プレフィックス.properties」があります。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにDataManager.DATA_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのXMLファイル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM XMLファイル名のパラメータ名
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
コンストラクタの概要
XmlDataPropertyHandler()
コンストラクタです。
メソッドの概要
String | getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
String | getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
ResourceParam[] | getResourceParams(String name) リソースのパラメータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのXMLファイル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
XMLファイル名のパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

XmlDataPropertyHandler

public XmlDataPropertyHandler()
コンストラクタです。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws DataPropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース DataPropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
DataPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getDAOName

public String getDAOName(String application,
                         String key,
                         String connect)
                  throws DataPropertyException
DAOのクラス名を取得します。 application、keyとconnectで指定されたDAOのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getDAOName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAOのクラス名
例外:
DataPropertyException - DAOのクラス名の取得に失敗

getConnectorName

public String getConnectorName(String application,
                               String key,
                               String connect)
                        throws DataPropertyException
DAOに対するデータコネクタ名を取得します。 application、keyとconnectで指定されたDAOのデータコネクタ名を取得します。 対応するデータコネクタ名が指定されていない場合、nullが返ります。

定義:
インタフェース DataPropertyHandler 内の getConnectorName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
データコネクタの名前
例外:
DataPropertyException - データコネクタ名の取得時に例外が発生

getConnectorClassName

public String getConnectorClassName(String connectorName)
                             throws DataPropertyException
データコネクタのクラス名を取得します。 application、keyとconnectで指定されたデータコネクタのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getConnectorClassName
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのクラス名
例外:
DataPropertyException - データコネクタのクラス名の取得に失敗

getConnectorResource

public String getConnectorResource(String connectorName)
                            throws DataPropertyException
データコネクタのリソース名を取得します。 application、keyとconnectで指定されたデータコネクタのリソース名を取得します。 対応するリソース名がない場合、nullを返します。

定義:
インタフェース DataPropertyHandler 内の getConnectorResource
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのリソース名
例外:
DataPropertyException - データコネクタのリソース名の取得時に例外が発生

getResourceParams

public ResourceParam[] getResourceParams(String name)
                                  throws DataPropertyException
リソースのパラメータを取得します。 nameで指定されたリソースのパラメータを取得します。

定義:
インタフェース DataPropertyHandler 内の getResourceParams
パラメータ:
name - リソース名
戻り値:
リソースのパラメータ
例外:
DataPropertyException - リソースのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler の使用

jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の使用

jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EJBEventListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EJBEventListener の使用

EJBEventListener を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EJBEventListener の使用

jp.co.intra_mart.framework.base.event での EJBEventListener のサブクラス
class | GenericEJBEventListener EJBを利用する汎用的なイベントリスナです。
class | GenericEJBEventListenerLocal ローカルEJBを利用する汎用的なイベントリスナです。
class | StandardEJBEventListener StandardEJBEventListenerAgentに接続するイベントリスナです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean の使用

EJBEventListenerAgentBean を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EJBEventListenerAgentBean の使用

jp.co.intra_mart.framework.base.event での EJBEventListenerAgentBean のサブクラス
class | GenericEJBEventListenerAgentBean EJBを利用する汎用的なイベントリスナーのBeanです。
class | StandardEJBEventListenerAgentBean EJBを利用する場合の抽象的なイベントリスナです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EJBEventListenerFactory の使用

EJBEventListenerFactory を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EJBEventListenerFactory の使用

jp.co.intra_mart.framework.base.event での EJBEventListenerFactory のサブクラス
class | GenericEJBEventListenerFactory GenericEJBEventListenerを生成します。
class | GenericEJBEventListenerLocalFactory GenericEJBEventListnerLocalを新規に生成します。
class | StandardEJBEventListenerFactory 標準的なEJB用のイベントリスナファクトリです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EmptyEvent の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EmptyEvent の使用

jp.co.intra_mart.framework.base.event.EmptyEvent はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.Event の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.Event の使用

Event を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event.container |
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.common.util | im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.seasar.event |
jp.co.intra_mart.framework.extension.struts.action | im-J2EE FrameworkとStrutsを連携するためのユーティリティです。

jp.co.intra_mart.framework.base.event での Event の使用

jp.co.intra_mart.framework.base.event での Event のサブクラス
 class EmptyEvent
情報を何も持たないイベントです。

Event を返す jp.co.intra_mart.framework.base.event のメソッド
 Event EventManager.createEvent(String application, String key, UserInfo info)
パラメータで指定された内容に該当するイベントを生成します。
 Event EventManager.createEvent(String application, String key, String loginUser, String loginGroup)
推奨されていません。 このメソッドではなくEventManager.createEvent(String, String, UserInfo)を使用してください。

Event 型のパラメータを持つ jp.co.intra_mart.framework.base.event のメソッド
EventListener | StandardEventListenerFactory.create(Event event) イベントリスナを生成します。
EventResult | StandardEventListener.execute(Event event) 処理を実行します。
protected abstract EventResult | StandardEventListener.fire(Event event) イベントに対する処理です。
protected EventResult | StandardEventListener.dispatchEvent(Event event) イベント処理を実行します。
EventListener | StandardEJBEventListenerFactory.create(Event event) イベントリスナを生成します。
EventResult | StandardEJBEventListenerAgentBean.execute(Event event) イベント処理を実行します。
protected abstract EventResult | StandardEJBEventListenerAgentBean.fire(Event event, DataAccessController dataAccessController) イベントに対する処理です。
EventResult | StandardEJBEventListenerAgent.execute(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListener.execute(Event event) 処理を実行します。
EventListener | GenericEventListenerFactory.create(Event event) イベントリスナを生成します。
EventResult | GenericEventListener.execute(Event event) 処理を実行します。
EventListener | GenericEJBEventListenerLocalFactory.create(Event event) イベントリスナを生成します。
EventResult | GenericEJBEventListenerLocal.execute(Event event) 処理を実行します。
EventListener | GenericEJBEventListenerFactory.create(Event event) イベントリスナを生成します。
EventResult | GenericEJBEventListenerAgentLocal.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListenerAgentBean.execute(Event event, String listenerName) イベント処理を実行します。
EventResult | GenericEJBEventListenerAgent.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListener.execute(Event event) 処理を実行します。
void | EventTriggerList.fireAll(Event event, DataAccessController controller) すべてのトリガに対してイベントの処理を行います。
void | EventTriggerAdapter.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
protected abstract void | EventTriggerAdapter.fire(Event event) イベントに対する処理を行います。
void | EventTrigger.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
EventResult | EventManager.dispatch(Event event) イベントに対する処理を実行します。
EventResult | EventManager.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventListener | EventListenerFactory.create(Event event) イベントリスナを生成します。
EventResult | EventListener.execute(Event event) 処理を実行します。
protected EventResult | EJBEventListenerAgentBean.dispatchEvent(Event event) イベント処理を実行します。
protected EventResult | EJBEventListener.dispatchEvent(Event event) イベント処理を実行します。

jp.co.intra_mart.framework.base.event.container での Event の使用

Event を返す jp.co.intra_mart.framework.base.event.container のメソッド
Event | EventContainerImpl.createEvent(String application, String key) パラメータで指定された内容に該当するイベントを生成します。
Event | EventContainer.createEvent(String application, String key) パラメータで指定された内容に該当するイベントを生成します。

Event 型のパラメータを持つ jp.co.intra_mart.framework.base.event.container のメソッド
EventResult | EventContainerImpl.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventResult | EventContainer.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。

jp.co.intra_mart.framework.base.service での Event の使用

Event を返す jp.co.intra_mart.framework.base.service のメソッド
protected  Event ServiceControllerAdapter.createEvent(String application, String key)
アプリケーションIDとキーに対応するイベントを取得します。

Event 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
protected  EventResult ServiceControllerAdapter.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.base.web.bean での Event の使用

Event を返す jp.co.intra_mart.framework.base.web.bean のメソッド
protected  Event HelperBean.createEvent(String application, String key)
アプリケーションIDとキーに対応するイベントを取得します。

Event 型のパラメータを持つ jp.co.intra_mart.framework.base.web.bean のメソッド
protected  EventResult HelperBean.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.extension.common.util での Event の使用

Event を返す jp.co.intra_mart.framework.extension.common.util のメソッド
static Event ServiceUtils.createEvent(String application, String key, HttpServletRequest request, HttpServletResponse response)
アプリケーションIDとキーに対応するイベントを取得します。

Event 型のパラメータを持つ jp.co.intra_mart.framework.extension.common.util のメソッド
static EventResult ServiceUtils.dispatchEvent(Event event)
イベントを実行します。

jp.co.intra_mart.framework.extension.seasar.event での Event の使用

Event を返す jp.co.intra_mart.framework.extension.seasar.event のメソッド
 Event S2EventContainer.createEvent(String application, String key)

Event 型のパラメータを持つ jp.co.intra_mart.framework.extension.seasar.event のメソッド
EventListener | S2EventListenerFactory.create(Event event) イベントリスナを生成します。
EventResult | S2EventContainer.dispatch(Event event, boolean transaction)

jp.co.intra_mart.framework.extension.struts.action での Event の使用

Event を返す jp.co.intra_mart.framework.extension.struts.action のメソッド
protected  Event IntramartAction.createEvent(String application, String key, HttpServletRequest request, HttpServletResponse response)
アプリケーションIDとキーに対応するイベントを取得します。

Event 型のパラメータを持つ jp.co.intra_mart.framework.extension.struts.action のメソッド
protected  EventResult IntramartAction.dispatchEvent(Event event)
イベント処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventException の使用

EventException を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event.container |
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.common.util | im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.seasar.event |
jp.co.intra_mart.framework.extension.struts.action | im-J2EE FrameworkとStrutsを連携するためのユーティリティです。

jp.co.intra_mart.framework.base.event での EventException の使用

EventException をスローする jp.co.intra_mart.framework.base.event のメソッド
protected  EventResult StandardEventListener.dispatchEvent(Event event)
イベント処理を実行します。
 Event EventManager.createEvent(String application, String key, UserInfo info)
パラメータで指定された内容に該当するイベントを生成します。
 Event EventManager.createEvent(String application, String key, String loginUser, String loginGroup)
推奨されていません。 このメソッドではなくEventManager.createEvent(String, String, UserInfo)を使用してください。
 EventResult EventManager.dispatch(Event event)
イベントに対する処理を実行します。
 EventResult EventManager.dispatch(Event event, boolean transaction)
イベントに対する処理を実行します。
protected  EventResult EJBEventListenerAgentBean.dispatchEvent(Event event)
イベント処理を実行します。
protected  EventResult EJBEventListener.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.base.event.container での EventException の使用

EventException をスローする jp.co.intra_mart.framework.base.event.container のメソッド
Event | EventContainerImpl.createEvent(String application, String key) パラメータで指定された内容に該当するイベントを生成します。
EventResult | EventContainerImpl.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
Event | EventContainer.createEvent(String application, String key) パラメータで指定された内容に該当するイベントを生成します。
EventResult | EventContainer.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。

jp.co.intra_mart.framework.base.service での EventException の使用

EventException をスローする jp.co.intra_mart.framework.base.service のメソッド
protected  EventResult ServiceControllerAdapter.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.base.web.bean での EventException の使用

EventException をスローする jp.co.intra_mart.framework.base.web.bean のメソッド
protected  EventResult HelperBean.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.extension.common.util での EventException の使用

EventException をスローする jp.co.intra_mart.framework.extension.common.util のメソッド
static EventResult ServiceUtils.dispatchEvent(Event event)
イベントを実行します。

jp.co.intra_mart.framework.extension.seasar.event での EventException の使用

EventException をスローする jp.co.intra_mart.framework.extension.seasar.event のメソッド
Event | S2EventContainer.createEvent(String application, String key)
EventResult | S2EventContainer.dispatch(Event event, boolean transaction)

jp.co.intra_mart.framework.extension.struts.action での EventException の使用

EventException をスローする jp.co.intra_mart.framework.extension.struts.action のメソッド
protected  EventResult IntramartAction.dispatchEvent(Event event)
イベント処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventFactoryModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventFactoryModel の使用

jp.co.intra_mart.framework.base.event.EventFactoryModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventGroupModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventGroupModel の使用

jp.co.intra_mart.framework.base.event.EventGroupModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.EventListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.EventListener の使用

EventListener を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.seasar.event |

jp.co.intra_mart.framework.base.event での EventListener の使用

EventListener を実装している jp.co.intra_mart.framework.base.event のクラス
class | EJBEventListener EJBを利用する場合のイベントリスナです。
class | GenericEJBEventListener EJBを利用する汎用的なイベントリスナです。
class | GenericEJBEventListenerLocal ローカルEJBを利用する汎用的なイベントリスナです。
class | GenericEventListener 汎用的なイベントリスナです。
class | StandardEJBEventListener StandardEJBEventListenerAgentに接続するイベントリスナです。
class | StandardEventListener 汎用的なビジネスロジック用のクラスです。

EventListener を返す jp.co.intra_mart.framework.base.event のメソッド
EventListener | StandardEventListenerFactory.create(Event event) イベントリスナを生成します。
EventListener | StandardEJBEventListenerFactory.create(Event event) イベントリスナを生成します。
EventListener | GenericEventListenerFactory.create(Event event) イベントリスナを生成します。
EventListener | GenericEJBEventListenerLocalFactory.create(Event event) イベントリスナを生成します。
EventListener | GenericEJBEventListenerFactory.create(Event event) イベントリスナを生成します。
EventListener | EventListenerFactory.create(Event event) イベントリスナを生成します。

jp.co.intra_mart.framework.extension.seasar.event での EventListener の使用

EventListener を返す jp.co.intra_mart.framework.extension.seasar.event のメソッド
 EventListener S2EventListenerFactory.create(Event event)
イベントリスナを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventListenerException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventListenerException の使用

EventListenerException を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.seasar.event |

jp.co.intra_mart.framework.base.event での EventListenerException の使用

EventListenerException をスローする jp.co.intra_mart.framework.base.event のメソッド
EventListener | StandardEventListenerFactory.create(Event event) イベントリスナを生成します。
void | StandardEventListenerFactory.initParam(String name, String value) 初期パラメータを設定します。
EventListener | StandardEJBEventListenerFactory.create(Event event) イベントリスナを生成します。
void | StandardEJBEventListenerFactory.initParam(String name, String value) 初期パラメータを設定します。
EventListener | GenericEventListenerFactory.create(Event event) イベントリスナを生成します。
void | GenericEventListenerFactory.initParam(String name, String value) 初期パラメータを設定します。
EventListener | GenericEJBEventListenerLocalFactory.create(Event event) イベントリスナを生成します。
void | GenericEJBEventListenerLocalFactory.initParam(String name, String value) 初期パラメータを設定します。
EventListener | GenericEJBEventListenerFactory.create(Event event) イベントリスナを生成します。
void | GenericEJBEventListenerFactory.initParam(String name, String value) 初期パラメータを設定します。
EventListener | EventListenerFactory.create(Event event) イベントリスナを生成します。
void | EventListenerFactory.initParam(String name, String value) 初期パラメータを設定します。

jp.co.intra_mart.framework.extension.seasar.event での EventListenerException の使用

EventListenerException をスローする jp.co.intra_mart.framework.extension.seasar.event のメソッド
EventListener | S2EventListenerFactory.create(Event event) イベントリスナを生成します。
void | S2EventListenerFactory.initParam(String name, String value) 初期パラメータを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.EventListenerFactory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.EventListenerFactory の使用

EventListenerFactory を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.seasar.event |

jp.co.intra_mart.framework.base.event での EventListenerFactory の使用

EventListenerFactory を実装している jp.co.intra_mart.framework.base.event のクラス
class | EJBEventListenerFactory EJBEventListenerFactoryを生成します。
class | GenericEJBEventListenerFactory GenericEJBEventListenerを生成します。
class | GenericEJBEventListenerLocalFactory GenericEJBEventListnerLocalを新規に生成します。
class | GenericEventListenerFactory GenericEventListenerを生成するイベントリスナファクトリです。
class | StandardEJBEventListenerFactory 標準的なEJB用のイベントリスナファクトリです。
class | StandardEventListenerFactory 通常のJavaクラスのイベントリスナを生成します。

jp.co.intra_mart.framework.extension.seasar.event での EventListenerFactory の使用

EventListenerFactory を実装している jp.co.intra_mart.framework.extension.seasar.event のクラス
 class S2EventListenerFactory
S2EventListenerFactoryはEventListener生成時にS2Containerから取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventListenerFactoryParam の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventListenerFactoryParam の使用

EventListenerFactoryParam を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventListenerFactoryParam の使用

EventListenerFactoryParam を返す jp.co.intra_mart.framework.base.event のメソッド
EventListenerFactoryParam[] | XmlEventPropertyHandler.getEventListenerFactoryParams(String application, String key) アプリケーションIDとキーに該当するイベントリスナファクトリの初期パラメータを取得します。
EventListenerFactoryParam[] | TextFileEventPropertyHandler.getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
EventListenerFactoryParam[] | EventPropertyHandler.getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
EventListenerFactoryParam[] | DistributesEventPropertyHandler.getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
EventListenerFactoryParam[] | DefaultEventPropertyHandler.getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventManager の使用

EventManager を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventManager の使用

EventManager を返す jp.co.intra_mart.framework.base.event のメソッド
static EventManager EventManager.getEventManager()
イベントマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventManagerException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventManagerException の使用

EventManagerException を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.common.util | im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.struts.action | im-J2EE FrameworkとStrutsを連携するためのユーティリティです。

jp.co.intra_mart.framework.base.event での EventManagerException の使用

EventManagerException をスローする jp.co.intra_mart.framework.base.event のメソッド
protected EventResult | StandardEventListener.dispatchEvent(Event event) イベント処理を実行します。
static EventManager | EventManager.getEventManager() イベントマネージャを取得します。
protected EventResult | EJBEventListenerAgentBean.dispatchEvent(Event event) イベント処理を実行します。
protected EventResult | EJBEventListener.dispatchEvent(Event event) イベント処理を実行します。

EventManagerException をスローする jp.co.intra_mart.framework.base.event のコンストラクタ
EventTriggerList(String application, String key)
EventTriggerListを新規に生成します。
EventTriggerList(String application, String key, boolean pre)
EventTriggerListを新規に生成します。

jp.co.intra_mart.framework.base.service での EventManagerException の使用

EventManagerException をスローする jp.co.intra_mart.framework.base.service のメソッド
protected  EventResult ServiceControllerAdapter.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.extension.common.util での EventManagerException の使用

EventManagerException をスローする jp.co.intra_mart.framework.extension.common.util のメソッド
static EventResult ServiceUtils.dispatchEvent(Event event)
イベントを実行します。

jp.co.intra_mart.framework.extension.struts.action での EventManagerException の使用

EventManagerException をスローする jp.co.intra_mart.framework.extension.struts.action のメソッド
protected  EventResult IntramartAction.dispatchEvent(Event event)
イベント処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventModelProducer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventModelProducer の使用

jp.co.intra_mart.framework.base.event.EventModelProducer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventPropertyException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventPropertyException の使用

EventPropertyException を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event.container |
jp.co.intra_mart.framework.extension.seasar.event |

jp.co.intra_mart.framework.base.event での EventPropertyException の使用

EventPropertyException をスローする jp.co.intra_mart.framework.base.event のメソッド
 boolean XmlEventPropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String XmlEventPropertyHandler.getEventName(String application, String key)
アプリケーションIDとキーに該当するイベントのクラス名を取得します。
 String XmlEventPropertyHandler.getEventListenerFactoryName(String application, String key)
アプリケーションIDとキーに該当するイベントリスナファクトリのクラス名を取得します。
 EventListenerFactoryParam[] XmlEventPropertyHandler.getEventListenerFactoryParams(String application, String key)
アプリケーションIDとキーに該当するイベントリスナファクトリの初期パラメータを取得します。
 Collection XmlEventPropertyHandler.getEventTriggerInfos(String application, String key)
アプリケーションIDとキーに該当するイベントのイベントトリガ情報をすべて取得します。
 Collection XmlEventPropertyHandler.getPostEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 String TextFileEventPropertyHandler.getEventName(String application, String key)
キーに該当するイベントのクラス名を取得します。
 String TextFileEventPropertyHandler.getEventListenerFactoryName(String application, String key)
キーに該当するイベントリスナファクトリのクラス名を取得します。
 EventListenerFactoryParam[] TextFileEventPropertyHandler.getEventListenerFactoryParams(String application, String key)
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
 Collection TextFileEventPropertyHandler.getEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 Collection TextFileEventPropertyHandler.getPostEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 boolean EventPropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String EventPropertyHandler.getEventName(String application, String key)
キーに該当するイベントのクラス名を取得します。
 String EventPropertyHandler.getEventListenerFactoryName(String application, String key)
キーに該当するイベントリスナファクトリのクラス名を取得します。
 EventListenerFactoryParam[] EventPropertyHandler.getEventListenerFactoryParams(String application, String key)
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
 Collection EventPropertyHandler.getEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 Collection EventPropertyHandler.getPostEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 Event EventManager.createEvent(String application, String key, UserInfo info)
パラメータで指定された内容に該当するイベントを生成します。
 Event EventManager.createEvent(String application, String key, String loginUser, String loginGroup)
推奨されていません。 このメソッドではなくEventManager.createEvent(String, String, UserInfo)を使用してください。
 boolean DistributesEventPropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String DistributesEventPropertyHandler.getEventName(String application, String key)
キーに該当するイベントのクラス名を取得します。
 String DistributesEventPropertyHandler.getEventListenerFactoryName(String application, String key)
キーに該当するイベントリスナファクトリのクラス名を取得します。
 EventListenerFactoryParam[] DistributesEventPropertyHandler.getEventListenerFactoryParams(String application, String key)
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
 Collection DistributesEventPropertyHandler.getEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 Collection DistributesEventPropertyHandler.getPostEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 boolean DefaultEventPropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String DefaultEventPropertyHandler.getEventName(String application, String key)
キーに該当するイベントのクラス名を取得します。
 String DefaultEventPropertyHandler.getEventListenerFactoryName(String application, String key)
キーに該当するイベントリスナファクトリのクラス名を取得します。
 EventListenerFactoryParam[] DefaultEventPropertyHandler.getEventListenerFactoryParams(String application, String key)
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
 Collection DefaultEventPropertyHandler.getEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 Collection DefaultEventPropertyHandler.getPostEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。

EventPropertyException をスローする jp.co.intra_mart.framework.base.event のコンストラクタ
EventTriggerList(String application, String key)
EventTriggerListを新規に生成します。
EventTriggerList(String application, String key, boolean pre)
EventTriggerListを新規に生成します。

jp.co.intra_mart.framework.base.event.container での EventPropertyException の使用

EventPropertyException をスローする jp.co.intra_mart.framework.base.event.container のメソッド
Event | EventContainerImpl.createEvent(String application, String key) パラメータで指定された内容に該当するイベントを生成します。
Event | EventContainer.createEvent(String application, String key) パラメータで指定された内容に該当するイベントを生成します。

jp.co.intra_mart.framework.extension.seasar.event での EventPropertyException の使用

EventPropertyException をスローする jp.co.intra_mart.framework.extension.seasar.event のメソッド
 Event S2EventContainer.createEvent(String application, String key)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.EventPropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.EventPropertyHandler の使用

EventPropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event.container |
jp.co.intra_mart.framework.extension.seasar.event |

jp.co.intra_mart.framework.base.event での EventPropertyHandler の使用

EventPropertyHandler を実装している jp.co.intra_mart.framework.base.event のクラス
class | DefaultEventPropertyHandler デフォルトのEventPropertyHandlerです。
class | DistributesEventPropertyHandler アプリケーション毎のEventPropertyHandlerを呼び出します。
class | TextFileEventPropertyHandler 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
class | XmlEventPropertyHandler XMLのEventPropertyHandlerです。

EventPropertyHandler を返す jp.co.intra_mart.framework.base.event のメソッド
 EventPropertyHandler EventManager.getEventPropertyHandler()
イベントプロパティハンドラを取得します。

jp.co.intra_mart.framework.base.event.container での EventPropertyHandler の使用

EventPropertyHandler を返す jp.co.intra_mart.framework.base.event.container のメソッド
EventPropertyHandler | EventContainerImpl.getEventPropertyHandler() イベントプロパティハンドラを取得します。
EventPropertyHandler | EventContainer.getEventPropertyHandler() イベントプロパティハンドラを取得します。

jp.co.intra_mart.framework.extension.seasar.event での EventPropertyHandler の使用

EventPropertyHandler を返す jp.co.intra_mart.framework.extension.seasar.event のメソッド
 EventPropertyHandler S2EventContainer.getEventPropertyHandler()

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.EventResult の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.EventResult の使用

EventResult を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event.container |
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.common.util | im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.seasar.event |
jp.co.intra_mart.framework.extension.struts.action | im-J2EE FrameworkとStrutsを連携するためのユーティリティです。

jp.co.intra_mart.framework.base.event での EventResult の使用

EventResult を返す jp.co.intra_mart.framework.base.event のメソッド
EventResult | StandardEventListener.execute(Event event) 処理を実行します。
protected abstract EventResult | StandardEventListener.fire(Event event) イベントに対する処理です。
protected EventResult | StandardEventListener.dispatchEvent(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListenerAgentBean.execute(Event event) イベント処理を実行します。
protected abstract EventResult | StandardEJBEventListenerAgentBean.fire(Event event, DataAccessController dataAccessController) イベントに対する処理です。
EventResult | StandardEJBEventListenerAgent.execute(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListener.execute(Event event) 処理を実行します。
EventResult | GenericEventListener.execute(Event event) 処理を実行します。
EventResult | GenericEJBEventListenerLocal.execute(Event event) 処理を実行します。
EventResult | GenericEJBEventListenerAgentLocal.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListenerAgentBean.execute(Event event, String listenerName) イベント処理を実行します。
EventResult | GenericEJBEventListenerAgent.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListener.execute(Event event) 処理を実行します。
EventResult | EventManager.dispatch(Event event) イベントに対する処理を実行します。
EventResult | EventManager.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventResult | EventListener.execute(Event event) 処理を実行します。
protected EventResult | EJBEventListenerAgentBean.dispatchEvent(Event event) イベント処理を実行します。
protected EventResult | EJBEventListener.dispatchEvent(Event event) イベント処理を実行します。

jp.co.intra_mart.framework.base.event.container での EventResult の使用

EventResult を返す jp.co.intra_mart.framework.base.event.container のメソッド
EventResult | EventContainerImpl.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventResult | EventContainer.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。

jp.co.intra_mart.framework.base.service での EventResult の使用

EventResult を返す jp.co.intra_mart.framework.base.service のメソッド
protected  EventResult ServiceControllerAdapter.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.base.web.bean での EventResult の使用

EventResult を返す jp.co.intra_mart.framework.base.web.bean のメソッド
protected  EventResult HelperBean.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.extension.common.util での EventResult の使用

EventResult を返す jp.co.intra_mart.framework.extension.common.util のメソッド
static EventResult ServiceUtils.dispatchEvent(Event event)
イベントを実行します。

jp.co.intra_mart.framework.extension.seasar.event での EventResult の使用

EventResult を返す jp.co.intra_mart.framework.extension.seasar.event のメソッド
 EventResult S2EventContainer.dispatch(Event event, boolean transaction)

jp.co.intra_mart.framework.extension.struts.action での EventResult の使用

EventResult を返す jp.co.intra_mart.framework.extension.struts.action のメソッド
protected  EventResult IntramartAction.dispatchEvent(Event event)
イベント処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.EventTrigger の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.EventTrigger の使用

EventTrigger を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventTrigger の使用

EventTrigger を実装している jp.co.intra_mart.framework.base.event のクラス
 class EventTriggerAdapter
DAOを取得するメソッドを持ったイベントトリガです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventTriggerAdapter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventTriggerAdapter の使用

jp.co.intra_mart.framework.base.event.EventTriggerAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventTriggerException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventTriggerException の使用

EventTriggerException を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventTriggerException の使用

EventTriggerException をスローする jp.co.intra_mart.framework.base.event のコンストラクタ
EventTriggerList(String application, String key)
EventTriggerListを新規に生成します。
EventTriggerList(String application, String key, boolean pre)
EventTriggerListを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventTriggerInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventTriggerInfo の使用

jp.co.intra_mart.framework.base.event.EventTriggerInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventTriggerList の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventTriggerList の使用

jp.co.intra_mart.framework.base.event.EventTriggerList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.GenericEJBEventListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEJBEventListener の使用

jp.co.intra_mart.framework.base.event.GenericEJBEventListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent の使用

GenericEJBEventListenerAgent を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での GenericEJBEventListenerAgent の使用

GenericEJBEventListenerAgent を返す jp.co.intra_mart.framework.base.event のメソッド
 GenericEJBEventListenerAgent GenericEJBEventListenerAgentHome.create()
リモートインタフェースGenericEJBEventListenerAgentを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean の使用

jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome の使用

GenericEJBEventListenerAgentHome を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での GenericEJBEventListenerAgentHome の使用

GenericEJBEventListenerAgentHome 型のパラメータを持つ jp.co.intra_mart.framework.base.event のコンストラクタ
GenericEJBEventListener(GenericEJBEventListenerAgentHome home, String listenerName)
GenericEJBEventListenerを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocal の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocal の使用

GenericEJBEventListenerAgentLocal を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での GenericEJBEventListenerAgentLocal の使用

GenericEJBEventListenerAgentLocal を返す jp.co.intra_mart.framework.base.event のメソッド
 GenericEJBEventListenerAgentLocal GenericEJBEventListenerAgentLocalHome.create()
ローカルインタフェース GenericEJBEventListenerAgentLocalを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocalHome の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocalHome の使用

GenericEJBEventListenerAgentLocalHome を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での GenericEJBEventListenerAgentLocalHome の使用

GenericEJBEventListenerAgentLocalHome 型のパラメータを持つ jp.co.intra_mart.framework.base.event のコンストラクタ
GenericEJBEventListenerLocal(GenericEJBEventListenerAgentLocalHome home, String listenerName)
GenericEJBEventListnerLocalを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory の使用

jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal の使用

jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory の使用

jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.GenericEventListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEventListener の使用

jp.co.intra_mart.framework.base.event.GenericEventListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.GenericEventListenerFactory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEventListenerFactory の使用

jp.co.intra_mart.framework.base.event.GenericEventListenerFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.StandardEJBEventListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.StandardEJBEventListener の使用

jp.co.intra_mart.framework.base.event.StandardEJBEventListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent の使用

StandardEJBEventListenerAgent を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での StandardEJBEventListenerAgent の使用

StandardEJBEventListenerAgent を返す jp.co.intra_mart.framework.base.event のメソッド
 StandardEJBEventListenerAgent StandardEJBEventListenerAgentHome.create()
StandardEJBEventListenerAgentと接続します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean の使用

jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome の使用

StandardEJBEventListenerAgentHome を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での StandardEJBEventListenerAgentHome の使用

StandardEJBEventListenerAgentHome 型のパラメータを持つ jp.co.intra_mart.framework.base.event のコンストラクタ
StandardEJBEventListener(StandardEJBEventListenerAgentHome home)
StandardEJBEventListenerを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory の使用

jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.StandardEventListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.StandardEventListener の使用

StandardEventListener を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での StandardEventListener の使用

StandardEventListener 型のパラメータを持つ jp.co.intra_mart.framework.base.event のメソッド
 void GenericEventListener.setListener(StandardEventListener listener)
イベント処理クラスを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.StandardEventListenerFactory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.StandardEventListenerFactory の使用

jp.co.intra_mart.framework.base.event.StandardEventListenerFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler の使用

jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler の使用

jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.container.EventContainer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.container.EventContainer の使用

EventContainer を使用しているパッケージ
jp.co.intra_mart.framework.base.event.container
jp.co.intra_mart.framework.extension.seasar.event

jp.co.intra_mart.framework.base.event.container での EventContainer の使用

EventContainer を実装している jp.co.intra_mart.framework.base.event.container のクラス
 class EventContainerImpl
EventContainerの標準的な実装クラスです。

jp.co.intra_mart.framework.extension.seasar.event での EventContainer の使用

EventContainer を実装している jp.co.intra_mart.framework.extension.seasar.event のクラス
 class S2EventContainer
S2EventContainer　は　Seasar2　と連携しオブジェクトを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.container.EventContainerException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.container.EventContainerException の使用

jp.co.intra_mart.framework.base.event.container.EventContainerException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.container.EventContainerImpl の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.container.EventContainerImpl の使用

jp.co.intra_mart.framework.base.event.container.EventContainerImpl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.container.factory.DefaultEventProvider の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.container.factory.DefaultEventProvider の使用

jp.co.intra_mart.framework.base.event.container.factory.DefaultEventProvider はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.container.factory.EventContainerFactory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.container.factory.EventContainerFactory の使用

jp.co.intra_mart.framework.base.event.container.factory.EventContainerFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DefaultEventProvider (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event.container.factory
クラス DefaultEventProvider

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.container.factory.DefaultEventProvider
すべての実装インタフェース:
Provider
public class DefaultEventProvider
extends Object
implements Provider

標準的なプロバイダーです。
クラスパス上のリソースファイルを取得し、イベントコンテナの実装を決定します。

リソースファイル名 - imartContainer.properties
キー - eventContainer

キーにはEventContainerインターフェースの実装クラスをフルパッケージ名で指定してください。

導入されたバージョン:
6.0

コンストラクタの概要
DefaultEventProvider()
DefaultEventProviderを新規に生成します。
メソッドの概要
 IMContainer create()
EventContainerを生成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DefaultEventProvider

public DefaultEventProvider()
DefaultEventProviderを新規に生成します。

メソッドの詳細

create

public IMContainer create()
                   throws IMContainerException
EventContainerを生成します。

定義:
インタフェース Provider 内の create
戻り値:
イベントコンテナ
例外:
IMContainerException - イベントコンテナ生成時に例外が発生。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventContainerFactory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event.container.factory
クラス EventContainerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.container.factory.EventContainerFactory
すべての実装インタフェース:
IMContainerFactory
public class EventContainerFactory
extends Object
implements IMContainerFactory

EventContainerのファクトリクラスです。 生成されるイベントコンテナはプロバイダーにより決定されます。

導入されたバージョン:
6.0

フィールドの概要
protected static Provider provider
コンストラクタの概要
EventContainerFactory()
メソッドの概要
IMContainer | create() EventContainerを生成します。
Provider | getProvider() プロバイダを返します。
void | setProvider(Provider p) プロバイダを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

provider

protected static Provider provider
コンストラクタの詳細

EventContainerFactory

public EventContainerFactory()
メソッドの詳細

create

public IMContainer create()
                   throws IMContainerException
EventContainerを生成します。

定義:
インタフェース IMContainerFactory 内の create
戻り値:
イベントコンテナ
例外:
IMContainerException - イベントコンテナ生成時に例外が発生。

getProvider

public Provider getProvider()
プロバイダを返します。

定義:
インタフェース IMContainerFactory 内の getProvider
戻り値:
イベントコンテナのプロバイダ

setProvider

public void setProvider(Provider p)
プロバイダを設定します。

定義:
インタフェース IMContainerFactory 内の setProvider
パラメータ:
p - イベントコンテナのプロバイダ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.event.container.factory (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.base.event.container.factory
クラス
DefaultEventProvider
EventContainerFactory


jp.co.intra_mart.framework.base.event.container.factory (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.event.container.factory

クラスの概要
DefaultEventProvider | 標準的なプロバイダーです。
EventContainerFactory | EventContainerのファクトリクラスです。


jp.co.intra_mart.framework.base.event.container.factory クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.event.container.factory の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.event.container.factory.DefaultEventProvider (implements jp.co.intra_mart.framework.system.container.factory.Provider)
    • class jp.co.intra_mart.framework.base.event.container.factory.EventContainerFactory (implements jp.co.intra_mart.framework.system.container.factory.IMContainerFactory)


パッケージ jp.co.intra_mart.framework.base.event.container.factory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.event.container.factory の使用

jp.co.intra_mart.framework.base.event.container.factory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


EventContainer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event.container
インタフェース EventContainer

すべてのスーパーインタフェース:
IMContainer
既知の実装クラスの一覧:
EventContainerImpl, S2EventContainer
public interface EventContainer
extends IMContainer

イベントコンテナのインターフェースです。
イベントコンテナはEventManagerの振る舞いを決定します。 EventManagerではイベントコンテナを保管し、その挙動はイベントコンテナの実装クラスに依存します。 イベントコンテナの実装は通常EventContainerFactoryによって生成されます。

導入されたバージョン:
6.0

フィールドの概要
static String EVENT_PROPERTY_HANDLER_KEY
イベントプロパティハンドラのキー
メソッドの概要
Event | createEvent(String application, String key) パラメータで指定された内容に該当するイベントを生成します。
EventResult | dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventPropertyHandler | getEventPropertyHandler() イベントプロパティハンドラを取得します。
インタフェース jp.co.intra_mart.framework.system.container.IMContainer から継承したメソッド
init

フィールドの詳細

EVENT_PROPERTY_HANDLER_KEY

public static final String EVENT_PROPERTY_HANDLER_KEY
イベントプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getEventPropertyHandler

public EventPropertyHandler getEventPropertyHandler()
イベントプロパティハンドラを取得します。

戻り値:
イベントプロパティハンドラ

createEvent

public Event createEvent(String application,
                         String key)
                  throws EventPropertyException,
                         EventException
パラメータで指定された内容に該当するイベントを生成します。

パラメータ:
application - アプリケーション名
key - キー
戻り値:
パラメータに該当するイベント
例外:
EventException - イベント生成に失敗
EventPropertyException - イベントプロパティの取得に失敗
導入されたバージョン:
6.0

dispatch

public EventResult dispatch(Event event,
                            boolean transaction)
                     throws EventException,
                            SystemException,
                            ApplicationException
イベントに対する処理を実行します。

パラメータ:
event - イベント
transaction - トランザクションの中で実行されているかどうかを示すフラグ（トランザクション内の場合true、トランザクション外の場合false）
戻り値:
イベント処理結果
例外:
EventException - 不正なイベントが渡された
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生
導入されたバージョン:
6.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventContainerException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event.container
クラス EventContainerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.event.container.EventContainerException
すべての実装インタフェース:
Serializable
public class EventContainerException
extends SystemException

イベントコンテナ設定時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EventContainerException()
詳細メッセージを指定しないで EventContainerException を構築します。
EventContainerException(String msg)
指定された詳細メッセージを持つ EventContainerException を構築します。
EventContainerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventContainerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EventContainerException

public EventContainerException()
詳細メッセージを指定しないで EventContainerException を構築します。

EventContainerException

public EventContainerException(String msg)
指定された詳細メッセージを持つ EventContainerException を構築します。

パラメータ:
msg - 詳細メッセージ

EventContainerException

public EventContainerException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventContainerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventContainerImpl (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event.container
クラス EventContainerImpl

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.container.EventContainerImpl
すべての実装インタフェース:
EventContainer, IMContainer
public class EventContainerImpl
extends Object
implements EventContainer

EventContainerの標準的な実装クラスです。

導入されたバージョン:
6.0

フィールドの概要
インタフェース jp.co.intra_mart.framework.base.event.container.EventContainer から継承したフィールド
EVENT_PROPERTY_HANDLER_KEY
コンストラクタの概要
EventContainerImpl()
EventContainerImplを生成します。
メソッドの概要
Event | createEvent(String application, String key) パラメータで指定された内容に該当するイベントを生成します。
EventResult | dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventPropertyHandler | getEventPropertyHandler() イベントプロパティハンドラを取得します。
void | init() EventContainerを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventContainerImpl

public EventContainerImpl()
EventContainerImplを生成します。

メソッドの詳細

init

public void init()
          throws IMContainerException
EventContainerを初期化します。

定義:
インタフェース IMContainer 内の init
例外:
IMContainerException

getEventPropertyHandler

public EventPropertyHandler getEventPropertyHandler()
イベントプロパティハンドラを取得します。

定義:
インタフェース EventContainer 内の getEventPropertyHandler
戻り値:
イベントプロパティハンドラ

createEvent

public Event createEvent(String application,
                         String key)
                  throws EventPropertyException,
                         EventException
パラメータで指定された内容に該当するイベントを生成します。 該当するイベントがEventPropertyHandlerのパラメータで設定されていない場合、EmptyEventを返します。

定義:
インタフェース EventContainer 内の createEvent
パラメータ:
application - アプリケーション名
key - キー
戻り値:
パラメータに該当するイベント
例外:
EventException - イベント生成に失敗
EventPropertyException - イベントプロパティの取得に失敗
導入されたバージョン:
6.0

dispatch

public EventResult dispatch(Event event,
                            boolean transaction)
                     throws EventException,
                            SystemException,
                            ApplicationException
イベントに対する処理を実行します。

定義:
インタフェース EventContainer 内の dispatch
パラメータ:
event - イベント
transaction - トランザクションの中で実行されているかどうかを示すフラグ（トランザクション内の場合true、トランザクション外の場合false）
戻り値:
イベント処理結果
例外:
EventException - 不正なイベントが渡された
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生
導入されたバージョン:
6.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.event.container (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.base.event.container
インタフェース
EventContainer
クラス
EventContainerImpl
例外
EventContainerException


jp.co.intra_mart.framework.base.event.container (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.event.container

インタフェースの概要
EventContainer イベントコンテナのインターフェースです。

クラスの概要
EventContainerImpl EventContainerの標準的な実装クラスです。

例外の概要
EventContainerException イベントコンテナ設定時の例外です。


jp.co.intra_mart.framework.base.event.container クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.event.container の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.event.container.EventContainerImpl (implements jp.co.intra_mart.framework.base.event.container.EventContainer)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.event.container.EventContainerException

インタフェース階層

  • interface jp.co.intra_mart.framework.system.container.IMContainer
    • interface jp.co.intra_mart.framework.base.event.container.EventContainer


パッケージ jp.co.intra_mart.framework.base.event.container の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.event.container の使用

jp.co.intra_mart.framework.base.event.container を使用しているパッケージ
jp.co.intra_mart.framework.base.event.container
jp.co.intra_mart.framework.extension.seasar.event

jp.co.intra_mart.framework.base.event.container により使用される jp.co.intra_mart.framework.base.event.container のクラス
EventContainer
イベントコンテナのインターフェースです。

jp.co.intra_mart.framework.extension.seasar.event により使用される jp.co.intra_mart.framework.base.event.container のクラス
EventContainer
イベントコンテナのインターフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DefaultEventPropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス DefaultEventPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler
すべての実装インタフェース:
EventPropertyHandler, PropertyHandler
public class DefaultEventPropertyHandler
extends Object
implements EventPropertyHandler

デフォルトのEventPropertyHandlerです。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「プレフィックス_アプリケーションID.properties」です。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにEventManager.EVENT_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスはDEFAULT_BUNDLE_NAME_PARAMで示されるものです。
プロパティの設定内容は以下のとおりです。

キー | 内容
event.class.キー | キーに対応するEventのクラス名
factory.class.キー | キーに対応するEventListenerFactoryのクラス名
factory.param.キー.パラメータ名 | キーに対応するEventListenerFactoryのパラメータの値
trigger.class.キー.ソート番号[.pre] | キーに対応するEventTriggerのクラス名 複数指定した場合、トリガはソート番号の順番に処理されます。 このトリガは該当するイベントリスナが処理される前に起動します。
trigger.class.キー.ソート番号.post | キーに対応するEventTriggerのクラス名 複数指定した場合、トリガはソート番号の順番に処理されます。 このトリガは該当するイベントリスナが処理された後に起動します。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
コンストラクタの概要
DefaultEventPropertyHandler()
DefaultEventPropertyHandlerを新規に生成します。
メソッドの概要
String | getEventListenerFactoryName(String application, String key) キーに該当するイベントリスナファクトリのクラス名を取得します。
EventListenerFactoryParam[] | getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
String | getEventName(String application, String key) キーに該当するイベントのクラス名を取得します。
Collection | getEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
Collection | getPostEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultEventPropertyHandler

public DefaultEventPropertyHandler()
DefaultEventPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws EventPropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース EventPropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
EventPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getEventName

public String getEventName(String application,
                           String key)
                    throws EventPropertyException
キーに該当するイベントのクラス名を取得します。 該当するイベントが存在しない場合、nullを返します。

定義:
インタフェース EventPropertyHandler 内の getEventName
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントのクラス名
例外:
EventPropertyException - イベントのクラス名の取得に失敗

getEventListenerFactoryName

public String getEventListenerFactoryName(String application,
                                          String key)
                                   throws EventPropertyException
キーに該当するイベントリスナファクトリのクラス名を取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryName
パラメータ:
application - アプリケーション
key - イベントリスナファクトリのキー
戻り値:
イベントリスナファクトリのクラス名
例外:
EventPropertyException - イベントリスナファクトリのクラス名の取得に失敗

getEventListenerFactoryParams

public EventListenerFactoryParam[] getEventListenerFactoryParams(String application,
                                                                 String key)
                                                          throws EventPropertyException
キーに該当するイベントリスナファクトリの初期パラメータを取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryParams
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントリスナファクトリの初期パラメータ
例外:
EventPropertyException - イベントリスナファクトリの初期パラメータの取得に失敗

getEventTriggerInfos

public Collection getEventTriggerInfos(String application,
                                       String key)
                                throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener

getPostEventTriggerInfos

public Collection getPostEventTriggerInfos(String application,
                                           String key)
                                    throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 ここで取得されるイベントトリガはイベントの処理後に実行されます。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getPostEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DistributesEventPropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス DistributesEventPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler
すべての実装インタフェース:
EventPropertyHandler, PropertyHandler
public class DistributesEventPropertyHandler
extends Object
implements EventPropertyHandler

アプリケーション毎のEventPropertyHandlerを呼び出します。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「プレフィックス_アプリケーションID.properties」、または「プレフィックス_アプリケーションID.xml」です。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにEventManager.EVENT_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスはDEFAULT_BUNDLE_NAME_PARAMで示されるものです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
static String | PARAM_APPLICATION アプリケーション
static String | PARAM_APPLICATION_CLASS クラス
static String | PARAM_APPLICATION_PARAM パラメータ
static String | PARAM_BUNDLE プロパティファイルのバンドルのパラメータ名
static String | PARAM_DEFAULT デフォルト
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
コンストラクタの概要
DistributesEventPropertyHandler()
DistributesEventPropertyHandlerを新規に生成します。
メソッドの概要
String | getEventListenerFactoryName(String application, String key) キーに該当するイベントリスナファクトリのクラス名を取得します。
EventListenerFactoryParam[] | getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
String | getEventName(String application, String key) キーに該当するイベントのクラス名を取得します。
Collection | getEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
Collection | getPostEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値

PARAM_DEFAULT

public static final String PARAM_DEFAULT
デフォルト

関連項目:
定数フィールド値

PARAM_APPLICATION

public static final String PARAM_APPLICATION
アプリケーション

関連項目:
定数フィールド値

PARAM_APPLICATION_PARAM

public static final String PARAM_APPLICATION_PARAM
パラメータ

関連項目:
定数フィールド値

PARAM_APPLICATION_CLASS

public static final String PARAM_APPLICATION_CLASS
クラス

関連項目:
定数フィールド値

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値

PARAM_BUNDLE

public static final String PARAM_BUNDLE
プロパティファイルのバンドルのパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DistributesEventPropertyHandler

public DistributesEventPropertyHandler()
DistributesEventPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws EventPropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース EventPropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
EventPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getEventName

public String getEventName(String application,
                           String key)
                    throws EventPropertyException
キーに該当するイベントのクラス名を取得します。 該当するイベントが存在しない場合、nullを返します。

定義:
インタフェース EventPropertyHandler 内の getEventName
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントのクラス名
例外:
EventPropertyException - イベントのクラス名の取得に失敗

getEventListenerFactoryName

public String getEventListenerFactoryName(String application,
                                          String key)
                                   throws EventPropertyException
キーに該当するイベントリスナファクトリのクラス名を取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryName
パラメータ:
application - アプリケーション
key - イベントリスナファクトリのキー
戻り値:
イベントリスナファクトリのクラス名
例外:
EventPropertyException - イベントリスナファクトリのクラス名の取得に失敗

getEventListenerFactoryParams

public EventListenerFactoryParam[] getEventListenerFactoryParams(String application,
                                                                 String key)
                                                          throws EventPropertyException
キーに該当するイベントリスナファクトリの初期パラメータを取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryParams
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントリスナファクトリの初期パラメータ
例外:
EventPropertyException - イベントリスナファクトリの初期パラメータの取得に失敗

getEventTriggerInfos

public Collection getEventTriggerInfos(String application,
                                       String key)
                                throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener

getPostEventTriggerInfos

public Collection getPostEventTriggerInfos(String application,
                                           String key)
                                    throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 ここで取得されるイベントトリガはイベントの処理後に実行されます。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getPostEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EJBEventListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EJBEventListener

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListener
すべての実装インタフェース:
EventListener
直系の既知のサブクラス:
GenericEJBEventListener, GenericEJBEventListenerLocal, StandardEJBEventListener
public abstract class EJBEventListener
extends Object
implements EventListener

EJBを利用する場合のイベントリスナです。

バージョン:
1.0

コンストラクタの概要
EJBEventListener()
EJBEventListenerを新規に生成します。
メソッドの概要
protected EventResult | dispatchEvent(Event event) イベント処理を実行します。
void | setInTransaction(boolean transaction) このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.framework.base.event.EventListener から継承したメソッド
execute

コンストラクタの詳細

EJBEventListener

public EJBEventListener()
EJBEventListenerを新規に生成します。

メソッドの詳細

setInTransaction

public void setInTransaction(boolean transaction)
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。 このクラスでは実際には何も行いません。

定義:
インタフェース EventListener 内の setInTransaction
パラメータ:
transaction - トランザクションの中で実行されている場合：true、そうでない場合：false
導入されたバージョン:
4.2

dispatchEvent

protected EventResult dispatchEvent(Event event)
                             throws EventManagerException,
                                    EventException,
                                    SystemException,
                                    ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventManagerException - イベントマネージャの生成に失敗
EventException - イベント処理実行に失敗
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生
導入されたバージョン:
4.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EJBEventListenerAgentBean (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EJBEventListenerAgentBean

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean
すべての実装インタフェース:
EnterpriseBean, Serializable, SessionBean
直系の既知のサブクラス:
GenericEJBEventListenerAgentBean, StandardEJBEventListenerAgentBean
public abstract class EJBEventListenerAgentBean
extends Object
implements SessionBean

Session Beanを利用したイベントリスナの抽象クラスです。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
protected  SessionContext sessionContext
セッションコンテキスト
コンストラクタの概要
EJBEventListenerAgentBean()
EJBEventListenerAgentBeanを新規に生成します。
メソッドの概要
protected EventResult | dispatchEvent(Event event) イベント処理を実行します。
void | ejbActivate() "passive"状態の時にインスタンスが活性化される時に呼ばれるメソッドです。
void | ejbPassivate() インスタンスが"passive"状態に移る前に呼ばれるメソッドです。
void | ejbRemove() Session Beanのが終了する前にEJBコンテナが呼び出すメソッドです。
void | setSessionContext(SessionContext sessionContext) 関連するSessionContextを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

sessionContext

protected SessionContext sessionContext
セッションコンテキスト

コンストラクタの詳細

EJBEventListenerAgentBean

public EJBEventListenerAgentBean()
EJBEventListenerAgentBeanを新規に生成します。

メソッドの詳細

setSessionContext

public void setSessionContext(SessionContext sessionContext)
関連するSessionContextを設定します。 コンテナはインスタンス生成後にこのメソッドを呼び出します。

定義:
インタフェース SessionBean 内の setSessionContext
パラメータ:
sessionContext - SessionContextインタフェース

ejbRemove

public void ejbRemove()
               throws EJBException
Session Beanのが終了する前にEJBコンテナが呼び出すメソッドです。

定義:
インタフェース SessionBean 内の ejbRemove
例外:
EJBException - システムレベルのエラー
RemoteException - EJB 1.0以前との互換性のための例外

ejbActivate

public void ejbActivate()
                 throws EJBException
"passive"状態の時にインスタンスが活性化される時に呼ばれるメソッドです。 ejbPassivate()メソッドで先にリリースされたすべてのリソースを再取得します。

定義:
インタフェース SessionBean 内の ejbActivate
例外:
EJBException - システムレベルのエラー
RemoteException - EJB 1.0以前との互換性のための例外

ejbPassivate

public void ejbPassivate()
                  throws EJBException
インスタンスが"passive"状態に移る前に呼ばれるメソッドです。 ejbActivate()メソッドで再取得されるリソースをすべてリリースします。

定義:
インタフェース SessionBean 内の ejbPassivate
例外:
EJBException - システムレベルのエラー
RemoteException - EJB 1.0以前との互換性のための例外

dispatchEvent

protected EventResult dispatchEvent(Event event)
                             throws EventManagerException,
                                    EventException,
                                    SystemException,
                                    ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventManagerException - イベントマネージャの生成に失敗
EventException - イベント処理実行に失敗
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生
導入されたバージョン:
4.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EJBEventListenerFactory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EJBEventListenerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerFactory
すべての実装インタフェース:
EventListenerFactory
直系の既知のサブクラス:
GenericEJBEventListenerFactory, GenericEJBEventListenerLocalFactory, StandardEJBEventListenerFactory
public abstract class EJBEventListenerFactory
extends Object
implements EventListenerFactory

EJBEventListenerFactoryを生成します。 イベントリスナファクトリの設定では、以下の初期パラメータの設定が必須です。

バージョン:
1.0

フィールドの概要
static String HOME_PARAM
ホームインタフェースを取得するときのJNDI名のパラメータ名
コンストラクタの概要
EJBEventListenerFactory()
EJBEventListenerFactoryを新規に生成します。
メソッドの概要
String | getJNDIName() EJBEventListenerAgentHomeのJNDI名を取得します。
protected void | setJNDIName(String jndiName) EJBEventListenerAgentHomeのJNDI名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.framework.base.event.EventListenerFactory から継承したメソッド
create, initParam

フィールドの詳細

HOME_PARAM

public static final String HOME_PARAM
ホームインタフェースを取得するときのJNDI名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

EJBEventListenerFactory

public EJBEventListenerFactory()
EJBEventListenerFactoryを新規に生成します。

メソッドの詳細

setJNDIName

protected void setJNDIName(String jndiName)
EJBEventListenerAgentHomeのJNDI名を設定します。

パラメータ:
jndiName - EJBEventListenerAgentHomeのJNDI名

getJNDIName

public String getJNDIName()
EJBEventListenerAgentHomeのJNDI名を取得します。

戻り値:
EJBEventListenerAgentHomeのJNDI名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EmptyEvent (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EmptyEvent

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.Event
        拡張 jp.co.intra_mart.framework.base.event.EmptyEvent
すべての実装インタフェース:
Serializable
public class EmptyEvent
extends Event

情報を何も持たないイベントです。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EmptyEvent()
クラス jp.co.intra_mart.framework.base.event.Event から継承したメソッド
getApplication, getKey, getLoginGroup, getLoginGroupID, getLoginUser, getLoginUserID, getUserInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EmptyEvent

public EmptyEvent()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Event (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス Event

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.Event
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
EmptyEvent
public abstract class Event
extends Object
implements Serializable

処理を実行するための情報です。 処理はEventListenerで行われますが、その際に渡される情報をEventのサブクラスで定義します。 Eventのサブクラスを生成する場合はコンストラクタを使用せず、変わりにEventManager.createEvent(String, String, String, String)を使用してください。
注意：
このクラスのサブクラスでは以下のフィールドは定義しないでください。

  • applicationフィールド
  • keyフィールド
  • loginUserIDフィールド
  • loginGroupIDフィールド

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
Event()
イベントを新規に生成します。
メソッドの概要
String | getApplication() アプリケーションを取得します。
String | getKey() イベントキーを取得します。
String | getLoginGroup() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
String | getLoginGroupID() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
String | getLoginUser() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
String | getLoginUserID() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
UserInfo | getUserInfo() ログインユーザの情報を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Event

public Event()
イベントを新規に生成します。

メソッドの詳細

getKey

public final String getKey()
イベントキーを取得します。

戻り値:
イベントキー

getApplication

public final String getApplication()
アプリケーションを取得します。

戻り値:
アプリケーション

getUserInfo

public UserInfo getUserInfo()
ログインユーザの情報を取得します。
ログインセッションが存在しない場合nullを返却します。

戻り値:
ログインユーザの情報
導入されたバージョン:
5.0

getLoginUser

public final String getLoginUser()
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログインユーザIDを取得します。

戻り値:
ログインユーザID

getLoginUserID

public final String getLoginUserID()
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログインユーザIDを取得します。

戻り値:
ログインユーザID
導入されたバージョン:
3.2

getLoginGroup

public final String getLoginGroup()
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログイングループIDを取得します。

戻り値:
ログイングループID

getLoginGroupID

public final String getLoginGroupID()
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログイングループIDを取得します。

戻り値:
ログイングループID
導入されたバージョン:
3.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.event.EventException
すべての実装インタフェース:
Serializable
public class EventException
extends SystemException

イベント生成時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EventException()
詳細メッセージを指定しないで EventException を構築します。
EventException(String msg)
指定された詳細メッセージを持つ EventException を構築します。
EventException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EventException

public EventException()
詳細メッセージを指定しないで EventException を構築します。

EventException

public EventException(String msg)
指定された詳細メッセージを持つ EventException を構築します。

パラメータ:
msg - 詳細メッセージ

EventException

public EventException(String msg,
                      Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventFactoryModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventFactoryModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventFactoryModel
public class EventFactoryModel
extends Object

イベントリスナーファクトリー情報を管理するクラスです。

バージョン:
1.0

フィールドの概要
static String | ID
static String | P_ID_FACTORY_CLASS
static String | P_ID_FACTORY_PARAM
static String | P_ID_PARAM_NAME
static String | P_ID_PARAM_VALUE
コンストラクタの概要
EventFactoryModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID

public static final String ID
関連項目:
定数フィールド値

P_ID_FACTORY_CLASS

public static final String P_ID_FACTORY_CLASS
関連項目:
定数フィールド値

P_ID_FACTORY_PARAM

public static final String P_ID_FACTORY_PARAM
関連項目:
定数フィールド値

P_ID_PARAM_NAME

public static final String P_ID_PARAM_NAME
関連項目:
定数フィールド値

P_ID_PARAM_VALUE

public static final String P_ID_PARAM_VALUE
関連項目:
定数フィールド値
コンストラクタの詳細

EventFactoryModel

public EventFactoryModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventGroupModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventGroupModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventGroupModel
public class EventGroupModel
extends Object

Event情報を管理するクラスです。

バージョン:
1.0

フィールドの概要
static String | ID
static String | P_ID_EVENT_KEY
static String | P_ID_EVENT_NAME
static String | P_ID_POST_TRIGGER
static String | P_ID_PRE_TRIGGER
static String | P_ID_TRIGGER_CLASS
コンストラクタの概要
EventGroupModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID

public static final String ID
関連項目:
定数フィールド値

P_ID_EVENT_KEY

public static final String P_ID_EVENT_KEY
関連項目:
定数フィールド値

P_ID_EVENT_NAME

public static final String P_ID_EVENT_NAME
関連項目:
定数フィールド値

P_ID_PRE_TRIGGER

public static final String P_ID_PRE_TRIGGER
関連項目:
定数フィールド値

P_ID_POST_TRIGGER

public static final String P_ID_POST_TRIGGER
関連項目:
定数フィールド値

P_ID_TRIGGER_CLASS

public static final String P_ID_TRIGGER_CLASS
関連項目:
定数フィールド値
コンストラクタの詳細

EventGroupModel

public EventGroupModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース EventListener

既知の実装クラスの一覧:
EJBEventListener, GenericEventListener, StandardEventListener
public interface EventListener

イベントリスナです。

バージョン:
1.0

メソッドの概要
EventResult | execute(Event event) 処理を実行します。
void | setInTransaction(boolean transaction) このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。

メソッドの詳細

execute

public EventResult execute(Event event)
                    throws SystemException,
                           ApplicationException
処理を実行します。 イベントを元に処理を実行します。 このインタフェースを実装するすべてのクラスは、 すべてのイベントトリガを実行した後に処理を 実行するように設計されている必要があります。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生

setInTransaction

public void setInTransaction(boolean transaction)
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。

パラメータ:
transaction - トランザクションの中で実行されている場合：true、そうでない場合：false
導入されたバージョン:
4.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventListenerException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventListenerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.event.EventListenerException
すべての実装インタフェース:
Serializable
public class EventListenerException
extends SystemException

イベントリスナ生成時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EventListenerException()
詳細メッセージを指定しないで EventListenerException を構築します。
EventListenerException(String msg)
指定された詳細メッセージを持つ EventListenerException を構築します。
EventListenerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventListenerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EventListenerException

public EventListenerException()
詳細メッセージを指定しないで EventListenerException を構築します。

EventListenerException

public EventListenerException(String msg)
指定された詳細メッセージを持つ EventListenerException を構築します。

パラメータ:
msg - 詳細メッセージ

EventListenerException

public EventListenerException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventListenerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventListenerFactory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース EventListenerFactory

既知の実装クラスの一覧:
EJBEventListenerFactory, GenericEventListenerFactory, S2EventListenerFactory, StandardEventListenerFactory
public interface EventListenerFactory

イベントリスナを生成します。 EventListenerFactoryは生成するEventListenerの種別ごとに必要です。

バージョン:
1.0

メソッドの概要
EventListener | create(Event event) イベントリスナを生成します。
void | initParam(String name, String value) 初期パラメータを設定します。

メソッドの詳細

create

public EventListener create(Event event)
                     throws EventListenerException
イベントリスナを生成します。

パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

パラメータ:
name - パラメータ名
value - パラメータの値
例外:
EventListenerException - パラメータの設定時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventListenerFactoryParam (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventListenerFactoryParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
        拡張 jp.co.intra_mart.framework.base.event.EventListenerFactoryParam
public class EventListenerFactoryParam
extends PropertyParam

イベントリスナファクトリの初期パラメータです。

バージョン:
1.0

コンストラクタの概要
EventListenerFactoryParam()
EventListenerFactoryParamを新規に生成します。
クラス jp.co.intra_mart.framework.system.property.PropertyParam から継承したメソッド
getName, getValue, setName, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventListenerFactoryParam

public EventListenerFactoryParam()
EventListenerFactoryParamを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventManager
public class EventManager
extends Object

イベントマネージャです。

バージョン:
1.0

フィールドの概要
static String EVENT_PROPERTY_HANDLER_KEY
イベントプロパティハンドラのキー
メソッドの概要
Event | createEvent(String application, String key, String loginUser, String loginGroup) 推奨されていません。 このメソッドではなくcreateEvent(String, String, UserInfo)を使用してください。
Event | createEvent(String application, String key, UserInfo info) パラメータで指定された内容に該当するイベントを生成します。
EventResult | dispatch(Event event) イベントに対する処理を実行します。
EventResult | dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
static EventManager | getEventManager() イベントマネージャを取得します。
EventPropertyHandler | getEventPropertyHandler() イベントプロパティハンドラを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

EVENT_PROPERTY_HANDLER_KEY

public static final String EVENT_PROPERTY_HANDLER_KEY
イベントプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getEventManager

public static EventManager getEventManager()
                                    throws EventManagerException
イベントマネージャを取得します。

戻り値:
イベントマネージャ
例外:
EventManagerException - イベントマネージャの生成時に例外が発生

getEventPropertyHandler

public EventPropertyHandler getEventPropertyHandler()
イベントプロパティハンドラを取得します。

戻り値:
イベントプロパティハンドラ

createEvent

public Event createEvent(String application,
                         String key,
                         UserInfo info)
                  throws EventPropertyException,
                         EventException
パラメータで指定された内容に該当するイベントを生成します。 該当するイベントがEventPropertyHandlerのパラメータで設定されていない場合、EmptyEventを返します。

パラメータ:
application - アプリケーション名
key - キー
info - ログインユーザ情報
戻り値:
パラメータに該当するイベント
例外:
EventException - イベント生成に失敗
EventPropertyException - イベントプロパティの取得に失敗
導入されたバージョン:
5.0

createEvent

public Event createEvent(String application,
                         String key,
                         String loginUser,
                         String loginGroup)
                  throws EventPropertyException,
                         EventException
推奨されていません。 このメソッドではなくcreateEvent(String, String, UserInfo)を使用してください。

パラメータで指定された内容に該当するイベントを生成します。 該当するイベントがEventPropertyHandlerのパラメータで設定されていない場合、EmptyEventを返します。

パラメータ:
application - アプリケーション名
key - キー
loginUser - ログインユーザ
loginGroup - ログイングループ
戻り値:
パラメータに該当するイベント
例外:
EventException - イベント生成に失敗
EventPropertyException - イベントプロパティの取得に失敗

dispatch

public EventResult dispatch(Event event)
                     throws EventException,
                            SystemException,
                            ApplicationException
イベントに対する処理を実行します。 イベントを渡されると、イベントに関連するEventListenerFactoryから EventListenerを生成し、EventListenerに処理を依頼します。 eventには必ずcreateEvent(String, String, String, String)で取得したイベントを設定してください。 このメソッドはdispatch(event, false)を呼び出したときと同じ効果があります。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventException - 不正なイベントが渡された
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生

dispatch

public EventResult dispatch(Event event,
                            boolean transaction)
                     throws EventException,
                            SystemException,
                            ApplicationException
イベントに対する処理を実行します。 イベントを渡されると、イベントに関連するEventListenerFactoryから EventListenerを生成し、EventListenerに処理を依頼します。 eventには必ずcreateEvent(String, String, String, String)で取得したイベントを設定してください。
EventListenerに処理を依頼する際、EventListener.setInTransaction(boolean)メソッドが呼ばれます。 このときにtransactionで指定された値が渡されます。

パラメータ:
event - イベント
transaction - トランザクションの中で実行されているかどうかを示すフラグ（トランザクション内の場合true、トランザクション外の場合false）
戻り値:
イベント処理結果
例外:
EventException - 不正なイベントが渡された
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生
導入されたバージョン:
4.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventManagerException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.event.EventManagerException
すべての実装インタフェース:
Serializable
public class EventManagerException
extends SystemException

イベントマネージャ設定時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EventManagerException()
詳細メッセージを指定しないで EventManagerException を構築します。
EventManagerException(String msg)
指定された詳細メッセージを持つ EventManagerException を構築します。
EventManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EventManagerException

public EventManagerException()
詳細メッセージを指定しないで EventManagerException を構築します。

EventManagerException

public EventManagerException(String msg)
指定された詳細メッセージを持つ EventManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

EventManagerException

public EventManagerException(String msg,
                             Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventModelProducer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventModelProducer

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventModelProducer
public class EventModelProducer
extends Object

イベント情報を作成するクラスです。

バージョン:
1.0

コンストラクタの概要
EventModelProducer()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventModelProducer

public EventModelProducer()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventPropertyException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventPropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.event.EventPropertyException
すべての実装インタフェース:
Serializable
public class EventPropertyException
extends SystemException

イベントプロパティ取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EventPropertyException()
詳細メッセージを指定しないで EventPropertyException を構築します。
EventPropertyException(String msg)
指定された詳細メッセージを持つ EventPropertyException を構築します。
EventPropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventPropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EventPropertyException

public EventPropertyException()
詳細メッセージを指定しないで EventPropertyException を構築します。

EventPropertyException

public EventPropertyException(String msg)
指定された詳細メッセージを持つ EventPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

EventPropertyException

public EventPropertyException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventPropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース EventPropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultEventPropertyHandler, DistributesEventPropertyHandler, TextFileEventPropertyHandler, XmlEventPropertyHandler
public interface EventPropertyHandler
extends PropertyHandler

イベントの設定情報に接続するクラスです。

バージョン:
1.0

メソッドの概要
String | getEventListenerFactoryName(String application, String key) キーに該当するイベントリスナファクトリのクラス名を取得します。
EventListenerFactoryParam[] | getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
String | getEventName(String application, String key) キーに該当するイベントのクラス名を取得します。
Collection | getEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
Collection | getPostEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws EventPropertyException
プロパティの動的読み込みが可能かどうか調べます。

戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可
例外:
EventPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getEventName

public String getEventName(String application,
                           String key)
                    throws EventPropertyException
キーに該当するイベントのクラス名を取得します。 該当するイベントが存在しない場合、nullを返します。

パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントのクラス名
例外:
EventPropertyException - イベントのクラス名の取得に失敗

getEventListenerFactoryName

public String getEventListenerFactoryName(String application,
                                          String key)
                                   throws EventPropertyException
キーに該当するイベントリスナファクトリのクラス名を取得します。

パラメータ:
application - アプリケーション
key - イベントリスナファクトリのキー
戻り値:
イベントリスナファクトリのクラス名
例外:
EventPropertyException - イベントリスナファクトリのクラス名の取得に失敗

getEventListenerFactoryParams

public EventListenerFactoryParam[] getEventListenerFactoryParams(String application,
                                                                 String key)
                                                          throws EventPropertyException
キーに該当するイベントリスナファクトリの初期パラメータを取得します。

パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントリスナファクトリの初期パラメータ
例外:
EventPropertyException - イベントリスナファクトリの初期パラメータの取得に失敗

getEventTriggerInfos

public Collection getEventTriggerInfos(String application,
                                       String key)
                                throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener

getPostEventTriggerInfos

public Collection getPostEventTriggerInfos(String application,
                                           String key)
                                    throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 ここで取得されるイベントトリガはイベントの処理後に実行されます。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventResult (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース EventResult

すべてのスーパーインタフェース:
Serializable
public interface EventResult
extends Serializable

イベント処理の結果です。

バージョン:
1.0

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventTrigger (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース EventTrigger

既知の実装クラスの一覧:
EventTriggerAdapter
public interface EventTrigger

イベントトリガです。 このインタフェースを実装するクラスでは、定数(static final)以外のフィールドは定義しないでください。

バージョン:
1.0

メソッドの概要
 void fire(Event event, DataAccessController controller)
イベントに対する処理を行います。

メソッドの詳細

fire

public void fire(Event event,
                 DataAccessController controller)
          throws SystemException,
                 ApplicationException
イベントに対する処理を行います。 トランザクションはcontrollerで管理されています。 このメソッドを実装するとき、内部でトランザクションのロールバックやコミットを行わないようにしてください。 メソッドが失敗した場合、またはロールバックを行いたい場合は、ApplicationExceptionのサブクラスを例外としてthrowしてください。

パラメータ:
event - イベント
controller - データアクセスコントローラ
例外:
SystemException - システム例外が発生
ApplicationException - アプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventTriggerAdapter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventTriggerAdapter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventTriggerAdapter
すべての実装インタフェース:
EventTrigger
public abstract class EventTriggerAdapter
extends Object
implements EventTrigger

DAOを取得するメソッドを持ったイベントトリガです。

バージョン:
1.0

コンストラクタの概要
EventTriggerAdapter()
EventTriggerAdapterを新規に生成します。
メソッドの概要
protected abstract void | fire(Event event) イベントに対する処理を行います。
void | fire(Event event, DataAccessController controller) イベントに対する処理を行います。
protected Object | getDAO(String application, String key, String connect) DAOを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventTriggerAdapter

public EventTriggerAdapter()
EventTriggerAdapterを新規に生成します。

メソッドの詳細

getDAO

protected Object getDAO(String application,
                        String key,
                        String connect)
                 throws DataPropertyException,
                        DataConnectorException,
                        DAOException,
                        DataConnectException
DAOを取得します。 キーと接続情報で指定されたDAOを取得します。

パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAO
例外:
DataPropertyException - プロパティの取得に失敗
DataConnectorException - データコネクタの取得に失敗
DAOException - DAOの取得に失敗
DataConnectException - データリソースとの接続に失敗

fire

public void fire(Event event,
                 DataAccessController controller)
          throws SystemException,
                 ApplicationException
イベントに対する処理を行います。 トランザクションはcontrollerで管理されています。 このメソッドはfire(jp.co.intra_mart.framework.base.event.Event)メソッドを呼ぶように実装されています。

定義:
インタフェース EventTrigger 内の fire
パラメータ:
event - イベント
controller - データアクセスコントローラ
例外:
SystemException - システム例外が発生
ApplicationException - アプリケーション例外が発生

fire

protected abstract void fire(Event event)
                      throws SystemException,
                             ApplicationException
イベントに対する処理を行います。 このメソッドを実装するとき、内部でトランザクションのロールバックやコミットを行わないようにしてください。 メソッドが失敗した場合、またはロールバックを行いたい場合は、ApplicationExceptionのサブクラスを例外としてthrowしてください。

パラメータ:
event - イベント
例外:
SystemException - システム例外が発生
ApplicationException - アプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventTriggerException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventTriggerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.event.EventTriggerException
すべての実装インタフェース:
Serializable
public class EventTriggerException
extends SystemException

イベントトリガ生成時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EventTriggerException()
詳細メッセージを指定しないで EventTriggerException を構築します。
EventTriggerException(String msg)
指定された詳細メッセージを持つ EventTriggerException を構築します。
EventTriggerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventTriggerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EventTriggerException

public EventTriggerException()
詳細メッセージを指定しないで EventTriggerException を構築します。

EventTriggerException

public EventTriggerException(String msg)
指定された詳細メッセージを持つ EventTriggerException を構築します。

パラメータ:
msg - 詳細メッセージ

EventTriggerException

public EventTriggerException(String msg,
                             Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventTriggerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventTriggerInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventTriggerInfo

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventTriggerInfo
public class EventTriggerInfo
extends Object

イベントトリガの情報です。

バージョン:
1.0

コンストラクタの概要
EventTriggerInfo()
EventTriggerInfoを新規に生成します。
メソッドの概要
String | getName() イベントトリガ名を取得します。
int | getNumber() ソート番号を取得します。
void | setName(String name) イベントトリガ名を設定します。
void | setNumber(int number) ソート番号を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventTriggerInfo

public EventTriggerInfo()
EventTriggerInfoを新規に生成します。

メソッドの詳細

setNumber

public void setNumber(int number)
ソート番号を設定します。

パラメータ:
number - ソート番号

getNumber

public int getNumber()
ソート番号を取得します。

戻り値:
ソート番号

setName

public void setName(String name)
イベントトリガ名を設定します。

パラメータ:
name - イベントトリガ名

getName

public String getName()
イベントトリガ名を取得します。

戻り値:
イベントトリガ名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventTriggerList (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventTriggerList

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventTriggerList
public class EventTriggerList
extends Object

イベントトリガの集合を扱います。 イベントトリガの生成し、順番に実行します。

バージョン:
1.0

コンストラクタの概要
EventTriggerList(String application, String key)
EventTriggerListを新規に生成します。
EventTriggerList(String application, String key, boolean pre)
EventTriggerListを新規に生成します。
メソッドの概要
 void fireAll(Event event, DataAccessController controller)
すべてのトリガに対してイベントの処理を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventTriggerList

public EventTriggerList(String application,
                        String key)
                 throws EventManagerException,
                        EventPropertyException,
                        EventTriggerException
EventTriggerListを新規に生成します。 このコンストラクタではイベントの前に処理するEventTriggerListを生成します。 このコンストラクタはEvent(application, key, true) と同じ結果となります。

パラメータ:
application - アプリケーション名
key - キー
例外:
EventManagerException - EventManager生成時に例外が発生した
EventPropertyException - イベントプロパティの取得時に例外が発生した
EventTriggerException - イベントトリガ生成時に例外が発生した

EventTriggerList

public EventTriggerList(String application,
                        String key,
                        boolean pre)
                 throws EventManagerException,
                        EventPropertyException,
                        EventTriggerException
EventTriggerListを新規に生成します。 preによってイベントの前に処理されるイベントトリガであるか イベントの後に処理されるイベントトリガであるかを指定します。

パラメータ:
application - アプリケーション名
key - キー
pre - true:イベントの前に起動するイベントトリガ、false:イベントの後に起動するイベントトリガ
例外:
EventManagerException - EventManager生成時に例外が発生した
EventPropertyException - イベントプロパティの取得時に例外が発生した
EventTriggerException - イベントトリガ生成時に例外が発生した
導入されたバージョン:
4.3
メソッドの詳細

fireAll

public void fireAll(Event event,
                    DataAccessController controller)
             throws SystemException,
                    ApplicationException
すべてのトリガに対してイベントの処理を行います。

パラメータ:
event - イベント
controller - データアクセスコントローラ
例外:
SystemException - システム例外が発生した
ApplicationException - アプリケーション例外が発生した
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEJBEventListener

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListener
        拡張 jp.co.intra_mart.framework.base.event.GenericEJBEventListener
すべての実装インタフェース:
EventListener
public class GenericEJBEventListener
extends EJBEventListener

EJBを利用する汎用的なイベントリスナです。

バージョン:
1.0

コンストラクタの概要
GenericEJBEventListener(GenericEJBEventListenerAgentHome home, String listenerName)
GenericEJBEventListenerを新規に生成します。
メソッドの概要
 EventResult execute(Event event)
処理を実行します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListener から継承したメソッド
dispatchEvent, setInTransaction
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericEJBEventListener

public GenericEJBEventListener(GenericEJBEventListenerAgentHome home,
                               String listenerName)
GenericEJBEventListenerを新規に生成します。

パラメータ:
home - ホームインタフェースGenericEJBEventListenerAgentHome
listenerName - 実際に処理を行うStandardEventListenerのクラス名
メソッドの詳細

execute

public EventResult execute(Event event)
                    throws SystemException,
                           ApplicationException
処理を実行します。 イベントを元に処理を実行します。 このインタフェースを実装するすべてのクラスは、 すべてのイベントトリガを実行した後に処理を 実行するように設計されている必要があります。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListenerAgent (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース GenericEJBEventListenerAgent

すべてのスーパーインタフェース:
EJBObject, Remote
public interface GenericEJBEventListenerAgent
extends EJBObject

汎用的なEJB用のイベントリスナのリモートインタフェースです。

バージョン:
1.0

メソッドの概要
 EventResult execute(Event event, String listenerName)
イベント処理を行います。
インタフェース javax.ejb.EJBObject から継承したメソッド
getEJBHome, getHandle, getPrimaryKey, isIdentical, remove

メソッドの詳細

execute

public EventResult execute(Event event,
                           String listenerName)
                    throws ApplicationException,
                           SystemException,
                           RemoteException,
                           EJBException
イベント処理を行います。 実際の処理はlistenerNameで定義されたクラスで行われます。 listenerNameで指定されるクラスはStandardEventListenerを継承し、引数のないコンストラクタを持つ必要があります。

パラメータ:
event - イベント
listenerName - イベントリスナのクラス名
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
EJBException - システムレベルのエラー
RemoteException - システムエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListenerAgentBean (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEJBEventListenerAgentBean

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean
        拡張 jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean
すべての実装インタフェース:
EnterpriseBean, Serializable, SessionBean
public class GenericEJBEventListenerAgentBean
extends EJBEventListenerAgentBean

EJBを利用する汎用的なイベントリスナーのBeanです。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean から継承したフィールド
sessionContext
コンストラクタの概要
GenericEJBEventListenerAgentBean()
GenericEJBEventListenerAgentBeanを新規に生成します。
メソッドの概要
void | ejbCreate() ホームインタフェースの引数なしのcreate()メソッドに対応します。
EventResult | execute(Event event, String listenerName) イベント処理を実行します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean から継承したメソッド
dispatchEvent, ejbActivate, ejbPassivate, ejbRemove, setSessionContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericEJBEventListenerAgentBean

public GenericEJBEventListenerAgentBean()
GenericEJBEventListenerAgentBeanを新規に生成します。

メソッドの詳細

ejbCreate

public void ejbCreate()
ホームインタフェースの引数なしのcreate()メソッドに対応します。

execute

public EventResult execute(Event event,
                           String listenerName)
                    throws ApplicationException,
                           SystemException,
                           EJBException
イベント処理を実行します。 listenerNameはStandardEventListenerを継承したクラスであり、引数を持たないコンストラクタが存在する必要があります。

パラメータ:
event - イベント
listenerName - リスナーのクラス名
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
EJBException - システムレベルのエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListenerAgentHome (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース GenericEJBEventListenerAgentHome

すべてのスーパーインタフェース:
EJBHome, Remote
public interface GenericEJBEventListenerAgentHome
extends EJBHome

リモートインタフェースGenericEJBEventListenerAgentを取得するホームインタフェースです。

バージョン:
1.0

メソッドの概要
 GenericEJBEventListenerAgent create()
リモートインタフェースGenericEJBEventListenerAgentを取得します。
インタフェース javax.ejb.EJBHome から継承したメソッド
getEJBMetaData, getHomeHandle, remove, remove

メソッドの詳細

create

public GenericEJBEventListenerAgent create()
                                    throws RemoteException,
                                           CreateException
リモートインタフェースGenericEJBEventListenerAgentを取得します。

戻り値:
GenericEJBEventListenerAgent
例外:
RemoteException - システムエラー
CreateException - リモートインタフェース取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListenerAgentLocal (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース GenericEJBEventListenerAgentLocal

すべてのスーパーインタフェース:
EJBLocalObject
public interface GenericEJBEventListenerAgentLocal
extends EJBLocalObject

汎用的なEJB用のイベントリスナのローカルインタフェースです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
 EventResult execute(Event event, String listenerName)
イベント処理を行います。
インタフェース javax.ejb.EJBLocalObject から継承したメソッド
getEJBLocalHome, getPrimaryKey, isIdentical, remove

メソッドの詳細

execute

public EventResult execute(Event event,
                           String listenerName)
                    throws ApplicationException,
                           SystemException,
                           EJBException
イベント処理を行います。 実際の処理はlistenerNameで定義されたクラスで行われます。 listenerNameで指定されるクラスはStandardEventListenerを継承し、引数のないコンストラクタを持つ必要があります。

パラメータ:
event - イベント
listenerName - イベントリスナのクラス名
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
EJBException - システムレベルのエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListenerAgentLocalHome (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース GenericEJBEventListenerAgentLocalHome

すべてのスーパーインタフェース:
EJBLocalHome
public interface GenericEJBEventListenerAgentLocalHome
extends EJBLocalHome

ローカルインタフェースGenericEJBEventListenerAgentLocalを取得するホームインタフェースです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
 GenericEJBEventListenerAgentLocal create()
ローカルインタフェース GenericEJBEventListenerAgentLocalを取得します。
インタフェース javax.ejb.EJBLocalHome から継承したメソッド
remove

メソッドの詳細

create

public GenericEJBEventListenerAgentLocal create()
                                         throws CreateException
ローカルインタフェース GenericEJBEventListenerAgentLocalを取得します。

戻り値:
GenericEJBEventListenerAgentLocal
例外:
RemoteException - システムエラー
CreateException - リモートインタフェース取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListenerFactory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEJBEventListenerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerFactory
        拡張 jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory
すべての実装インタフェース:
EventListenerFactory
public class GenericEJBEventListenerFactory
extends EJBEventListenerFactory

GenericEJBEventListenerを生成します。

バージョン:
1.0

フィールドの概要
static String LISTENER_PARAM
イベントリスナーのクラス名のパラメータ名
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory から継承したフィールド
HOME_PARAM
コンストラクタの概要
GenericEJBEventListenerFactory()
GenericEJBEventListenerFactoryを新規に生成します。
メソッドの概要
EventListener | create(Event event) イベントリスナを生成します。
String | getListenerName() EJBEventListenerAgentBeanのクラス名を取得します。
void | initParam(String name, String value) 初期パラメータを設定します。
protected void | setListenerName(String listenerName) EJBEventListenerAgentBeanのクラス名を設定します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory から継承したメソッド
getJNDIName, setJNDIName
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

LISTENER_PARAM

public static final String LISTENER_PARAM
イベントリスナーのクラス名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

GenericEJBEventListenerFactory

public GenericEJBEventListenerFactory()
GenericEJBEventListenerFactoryを新規に生成します。

メソッドの詳細

create

public EventListener create(Event event)
                     throws EventListenerException
イベントリスナを生成します。

パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

パラメータ:
name - パラメータ名
value - パラメータの値
例外:
EventListenerException - パラメータの設定時に例外が発生

setListenerName

protected void setListenerName(String listenerName)
EJBEventListenerAgentBeanのクラス名を設定します。

パラメータ:
listenerName - EJBEventListenerAgentBeanのクラス名

getListenerName

public String getListenerName()
EJBEventListenerAgentBeanのクラス名を取得します。

戻り値:
EJBEventListenerAgentBeanのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListenerLocal (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEJBEventListenerLocal

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListener
        拡張 jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal
すべての実装インタフェース:
EventListener
public class GenericEJBEventListenerLocal
extends EJBEventListener

ローカルEJBを利用する汎用的なイベントリスナです。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
GenericEJBEventListenerLocal(GenericEJBEventListenerAgentLocalHome home, String listenerName)
GenericEJBEventListnerLocalを新規に生成します。
メソッドの概要
 EventResult execute(Event event)
処理を実行します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListener から継承したメソッド
dispatchEvent, setInTransaction
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericEJBEventListenerLocal

public GenericEJBEventListenerLocal(GenericEJBEventListenerAgentLocalHome home,
                                    String listenerName)
GenericEJBEventListnerLocalを新規に生成します。

パラメータ:
home - ホームインタフェース
listenerName - 実際に処理を行うStandardEventListenerのクラス名
メソッドの詳細

execute

public EventResult execute(Event event)
                    throws SystemException,
                           ApplicationException
処理を実行します。 イベントを元に処理を実行します。 このインタフェースを実装するすべてのクラスは、 すべてのイベントトリガを実行した後に処理を 実行するように設計されている必要があります。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListenerLocalFactory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEJBEventListenerLocalFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerFactory
        拡張 jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory
すべての実装インタフェース:
EventListenerFactory
public class GenericEJBEventListenerLocalFactory
extends EJBEventListenerFactory

GenericEJBEventListnerLocalを新規に生成します。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String LISTENER_PARAM
イベントリスナーのクラス名のパラメータ名
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory から継承したフィールド
HOME_PARAM
コンストラクタの概要
GenericEJBEventListenerLocalFactory()
GenericEJBEventListnerLocalFactoryを新規に生成します。
メソッドの概要
EventListener | create(Event event) イベントリスナを生成します。
String | getListenerName() EJBEventListenerAgentBeanのクラス名を取得します。
void | initParam(String name, String value) 初期パラメータを設定します。
protected void | setListenerName(String listenerName) EJBEventListenerAgentBeanのクラス名を設定します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory から継承したメソッド
getJNDIName, setJNDIName
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

LISTENER_PARAM

public static final String LISTENER_PARAM
イベントリスナーのクラス名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

GenericEJBEventListenerLocalFactory

public GenericEJBEventListenerLocalFactory()
GenericEJBEventListnerLocalFactoryを新規に生成します。

メソッドの詳細

create

public EventListener create(Event event)
                     throws EventListenerException
イベントリスナを生成します。

パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

パラメータ:
name - パラメータ名
value - パラメータの値
例外:
EventListenerException - パラメータの設定時に例外が発生

setListenerName

protected void setListenerName(String listenerName)
EJBEventListenerAgentBeanのクラス名を設定します。

パラメータ:
listenerName - EJBEventListenerAgentBeanのクラス名

getListenerName

public String getListenerName()
EJBEventListenerAgentBeanのクラス名を取得します。

戻り値:
EJBEventListenerAgentBeanのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEventListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEventListener

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.GenericEventListener
すべての実装インタフェース:
EventListener
public class GenericEventListener
extends Object
implements EventListener

汎用的なイベントリスナです。

バージョン:
1.0

コンストラクタの概要
GenericEventListener()
GenericEventListenerを新規に生成します。
メソッドの概要
EventResult | execute(Event event) 処理を実行します。
void | setInTransaction(boolean transaction) このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
void | setListener(StandardEventListener listener) イベント処理クラスを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericEventListener

public GenericEventListener()
GenericEventListenerを新規に生成します。

メソッドの詳細

execute

public EventResult execute(Event event)
                    throws SystemException,
                           ApplicationException
処理を実行します。 イベントを元に処理を実行します。 このインタフェースを実装するすべてのクラスは、 すべてのイベントトリガを実行した後に処理を 実行するように設計されている必要があります。

定義:
インタフェース EventListener 内の execute
パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生

setListener

public void setListener(StandardEventListener listener)
イベント処理クラスを設定します。

パラメータ:
listener - イベント処理クラス

setInTransaction

public void setInTransaction(boolean transaction)
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。

定義:
インタフェース EventListener 内の setInTransaction
パラメータ:
transaction - トランザクションの中で実行されている場合：true、そうでない場合：false
導入されたバージョン:
4.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEventListenerFactory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEventListenerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.GenericEventListenerFactory
すべての実装インタフェース:
EventListenerFactory
public class GenericEventListenerFactory
extends Object
implements EventListenerFactory

GenericEventListenerを生成するイベントリスナファクトリです。 このファクトリで指定できる初期パラメータは以下のとおりです。

パラメータ名 | 値
listener | 包含するイベントリスナ

バージョン:
1.0

コンストラクタの概要
GenericEventListenerFactory()
GenericEventListenerFactoryを新規に生成します。
メソッドの概要
EventListener | create(Event event) イベントリスナを生成します。
void | initParam(String name, String value) 初期パラメータを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericEventListenerFactory

public GenericEventListenerFactory()
GenericEventListenerFactoryを新規に生成します。

メソッドの詳細

create

public EventListener create(Event event)
                     throws EventListenerException
イベントリスナを生成します。

定義:
インタフェース EventListenerFactory 内の create
パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

定義:
インタフェース EventListenerFactory 内の initParam
パラメータ:
name - パラメータ名
value - パラメータの値
例外:
EventListenerException - パラメータの設定時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.event (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.base.event
インタフェース
EventListener
EventListenerFactory
EventPropertyHandler
EventResult
EventTrigger
GenericEJBEventListenerAgent
GenericEJBEventListenerAgentHome
GenericEJBEventListenerAgentLocal
GenericEJBEventListenerAgentLocalHome
StandardEJBEventListenerAgent
StandardEJBEventListenerAgentHome
クラス
DefaultEventPropertyHandler
DistributesEventPropertyHandler
EJBEventListener
EJBEventListenerAgentBean
EJBEventListenerFactory
EmptyEvent
Event
EventFactoryModel
EventGroupModel
EventListenerFactoryParam
EventManager
EventModelProducer
EventTriggerAdapter
EventTriggerInfo
EventTriggerList
GenericEJBEventListener
GenericEJBEventListenerAgentBean
GenericEJBEventListenerFactory
GenericEJBEventListenerLocal
GenericEJBEventListenerLocalFactory
GenericEventListener
GenericEventListenerFactory
StandardEJBEventListener
StandardEJBEventListenerAgentBean
StandardEJBEventListenerFactory
StandardEventListener
StandardEventListenerFactory
TextFileEventPropertyHandler
XmlEventPropertyHandler
例外
EventException
EventListenerException
EventManagerException
EventPropertyException
EventTriggerException


jp.co.intra_mart.framework.base.event (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.event

イベントフレームワークに関連するクラスのパッケージです。

参照:
説明

インタフェースの概要
EventListener | イベントリスナです。
EventListenerFactory | イベントリスナを生成します。
EventPropertyHandler | イベントの設定情報に接続するクラスです。
EventResult | イベント処理の結果です。
EventTrigger | イベントトリガです。
GenericEJBEventListenerAgent | 汎用的なEJB用のイベントリスナのリモートインタフェースです。
GenericEJBEventListenerAgentHome | リモートインタフェースGenericEJBEventListenerAgentを取得するホームインタフェースです。
GenericEJBEventListenerAgentLocal | 汎用的なEJB用のイベントリスナのローカルインタフェースです。
GenericEJBEventListenerAgentLocalHome | ローカルインタフェースGenericEJBEventListenerAgentLocalを取得するホームインタフェースです。
StandardEJBEventListenerAgent | EJBを利用するときのイベントリスナのリモートインタフェースです。
StandardEJBEventListenerAgentHome | StandardEJBEventListenerAgentのホームインタフェースです。

クラスの概要
DefaultEventPropertyHandler | デフォルトのEventPropertyHandlerです。
DistributesEventPropertyHandler | アプリケーション毎のEventPropertyHandlerを呼び出します。
EJBEventListener | EJBを利用する場合のイベントリスナです。
EJBEventListenerAgentBean | Session Beanを利用したイベントリスナの抽象クラスです。
EJBEventListenerFactory | EJBEventListenerFactoryを生成します。
EmptyEvent | 情報を何も持たないイベントです。
Event | 処理を実行するための情報です。
EventFactoryModel | イベントリスナーファクトリー情報を管理するクラスです。
EventGroupModel | Event情報を管理するクラスです。
EventListenerFactoryParam | イベントリスナファクトリの初期パラメータです。
EventManager | イベントマネージャです。
EventModelProducer | イベント情報を作成するクラスです。
EventTriggerAdapter | DAOを取得するメソッドを持ったイベントトリガです。
EventTriggerInfo | イベントトリガの情報です。
EventTriggerList | イベントトリガの集合を扱います。
GenericEJBEventListener | EJBを利用する汎用的なイベントリスナです。
GenericEJBEventListenerAgentBean | EJBを利用する汎用的なイベントリスナーのBeanです。
GenericEJBEventListenerFactory | GenericEJBEventListenerを生成します。
GenericEJBEventListenerLocal | ローカルEJBを利用する汎用的なイベントリスナです。
GenericEJBEventListenerLocalFactory | GenericEJBEventListnerLocalを新規に生成します。
GenericEventListener | 汎用的なイベントリスナです。
GenericEventListenerFactory | GenericEventListenerを生成するイベントリスナファクトリです。
StandardEJBEventListener | StandardEJBEventListenerAgentに接続するイベントリスナです。
StandardEJBEventListenerAgentBean | EJBを利用する場合の抽象的なイベントリスナです。
StandardEJBEventListenerFactory | 標準的なEJB用のイベントリスナファクトリです。
StandardEventListener | 汎用的なビジネスロジック用のクラスです。
StandardEventListenerFactory | 通常のJavaクラスのイベントリスナを生成します。
TextFileEventPropertyHandler | 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
XmlEventPropertyHandler | XMLのEventPropertyHandlerです。

例外の概要
EventException | イベント生成時の例外です。
EventListenerException | イベントリスナ生成時の例外です。
EventManagerException | イベントマネージャ設定時の例外です。
EventPropertyException | イベントプロパティ取得時の例外です。
EventTriggerException | イベントトリガ生成時の例外です。

パッケージ jp.co.intra_mart.framework.base.event の説明

イベントフレームワークに関連するクラスのパッケージです。 イベントフレームワークを利用して処理を行う手順の概要は次のとおりです。

  • アプリケーションIDとイベントキーからEventを生成する。
  • Eventに処理に必要となる情報を設定する。
  • アプリケーションIDとイベントキーに対応するEventListenerにEventを渡し、処理を行う。
  • EventListenerは処理結果となるEventResultを返す。


jp.co.intra_mart.framework.base.event クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.event の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class jp.co.intra_mart.framework.base.event.EJBEventListener (implements jp.co.intra_mart.framework.base.event.EventListener)
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListener
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal
      • class jp.co.intra_mart.framework.base.event.StandardEJBEventListener
    • class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean (implements javax.ejb.SessionBean)
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean
      • class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean
    • class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory
      • class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory
    • class jp.co.intra_mart.framework.base.event.Event (implements java.io.Serializable)
      • class jp.co.intra_mart.framework.base.event.EmptyEvent
    • class jp.co.intra_mart.framework.base.event.EventFactoryModel
    • class jp.co.intra_mart.framework.base.event.EventGroupModel
    • class jp.co.intra_mart.framework.base.event.EventManager
    • class jp.co.intra_mart.framework.base.event.EventModelProducer
    • class jp.co.intra_mart.framework.base.event.EventTriggerAdapter (implements jp.co.intra_mart.framework.base.event.EventTrigger)
    • class jp.co.intra_mart.framework.base.event.EventTriggerInfo
    • class jp.co.intra_mart.framework.base.event.EventTriggerList
    • class jp.co.intra_mart.framework.base.event.GenericEventListener (implements jp.co.intra_mart.framework.base.event.EventListener)
    • class jp.co.intra_mart.framework.base.event.GenericEventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.base.event.EventListenerFactoryParam
    • class jp.co.intra_mart.framework.base.event.StandardEventListener (implements jp.co.intra_mart.framework.base.event.EventListener)
    • class jp.co.intra_mart.framework.base.event.StandardEventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
    • class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.event.EventException
            • class jp.co.intra_mart.framework.base.event.EventListenerException
            • class jp.co.intra_mart.framework.base.event.EventManagerException
            • class jp.co.intra_mart.framework.base.event.EventPropertyException
            • class jp.co.intra_mart.framework.base.event.EventTriggerException
    • class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)

インタフェース階層

  • interface javax.ejb.EJBLocalHome
    • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocalHome
  • interface javax.ejb.EJBLocalObject
    • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocal
  • interface jp.co.intra_mart.framework.base.event.EventListener
  • interface jp.co.intra_mart.framework.base.event.EventListenerFactory
  • interface jp.co.intra_mart.framework.base.event.EventTrigger
  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.base.event.EventPropertyHandler
  • interface java.rmi.Remote
    • interface javax.ejb.EJBHome
      • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome
      • interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome
    • interface javax.ejb.EJBObject
      • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent
      • interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent
  • interface java.io.Serializable
    • interface jp.co.intra_mart.framework.base.event.EventResult


パッケージ jp.co.intra_mart.framework.base.event の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.event の使用

jp.co.intra_mart.framework.base.event を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event.container |
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.common.util | im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.seasar.event |
jp.co.intra_mart.framework.extension.struts.action | im-J2EE FrameworkとStrutsを連携するためのユーティリティです。

jp.co.intra_mart.framework.base.event により使用される jp.co.intra_mart.framework.base.event のクラス
EJBEventListener
EJBを利用する場合のイベントリスナです。
EJBEventListenerAgentBean
Session Beanを利用したイベントリスナの抽象クラスです。
EJBEventListenerFactory
EJBEventListenerFactoryを生成します。
Event
処理を実行するための情報です。
EventException
イベント生成時の例外です。
EventListener
イベントリスナです。
EventListenerException
イベントリスナ生成時の例外です。
EventListenerFactory
イベントリスナを生成します。
EventListenerFactoryParam
イベントリスナファクトリの初期パラメータです。
EventManager
イベントマネージャです。
EventManagerException
イベントマネージャ設定時の例外です。
EventPropertyException
イベントプロパティ取得時の例外です。
EventPropertyHandler
イベントの設定情報に接続するクラスです。
EventResult
イベント処理の結果です。
EventTrigger
イベントトリガです。
EventTriggerException
イベントトリガ生成時の例外です。
GenericEJBEventListenerAgent
汎用的なEJB用のイベントリスナのリモートインタフェースです。
GenericEJBEventListenerAgentHome
リモートインタフェースGenericEJBEventListenerAgentを取得するホームインタフェースです。
GenericEJBEventListenerAgentLocal
汎用的なEJB用のイベントリスナのローカルインタフェースです。
GenericEJBEventListenerAgentLocalHome
ローカルインタフェースGenericEJBEventListenerAgentLocalを取得するホームインタフェースです。
StandardEJBEventListenerAgent
EJBを利用するときのイベントリスナのリモートインタフェースです。
StandardEJBEventListenerAgentHome
StandardEJBEventListenerAgentのホームインタフェースです。
StandardEventListener
汎用的なビジネスロジック用のクラスです。

jp.co.intra_mart.framework.base.event.container により使用される jp.co.intra_mart.framework.base.event のクラス
Event
処理を実行するための情報です。
EventException
イベント生成時の例外です。
EventPropertyException
イベントプロパティ取得時の例外です。
EventPropertyHandler
イベントの設定情報に接続するクラスです。
EventResult
イベント処理の結果です。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.base.event のクラス
Event
処理を実行するための情報です。
EventException
イベント生成時の例外です。
EventManagerException
イベントマネージャ設定時の例外です。
EventResult
イベント処理の結果です。

jp.co.intra_mart.framework.base.web.bean により使用される jp.co.intra_mart.framework.base.event のクラス
Event
処理を実行するための情報です。
EventException
イベント生成時の例外です。
EventResult
イベント処理の結果です。

jp.co.intra_mart.framework.extension.common.util により使用される jp.co.intra_mart.framework.base.event のクラス
Event
処理を実行するための情報です。
EventException
イベント生成時の例外です。
EventManagerException
イベントマネージャ設定時の例外です。
EventResult
イベント処理の結果です。

jp.co.intra_mart.framework.extension.seasar.event により使用される jp.co.intra_mart.framework.base.event のクラス
Event
処理を実行するための情報です。
EventException
イベント生成時の例外です。
EventListener
イベントリスナです。
EventListenerException
イベントリスナ生成時の例外です。
EventListenerFactory
イベントリスナを生成します。
EventPropertyException
イベントプロパティ取得時の例外です。
EventPropertyHandler
イベントの設定情報に接続するクラスです。
EventResult
イベント処理の結果です。

jp.co.intra_mart.framework.extension.struts.action により使用される jp.co.intra_mart.framework.base.event のクラス
Event
処理を実行するための情報です。
EventException
イベント生成時の例外です。
EventManagerException
イベントマネージャ設定時の例外です。
EventResult
イベント処理の結果です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardEJBEventListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス StandardEJBEventListener

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListener
        拡張 jp.co.intra_mart.framework.base.event.StandardEJBEventListener
すべての実装インタフェース:
EventListener
public class StandardEJBEventListener
extends EJBEventListener

StandardEJBEventListenerAgentに接続するイベントリスナです。

バージョン:
1.0

コンストラクタの概要
StandardEJBEventListener(StandardEJBEventListenerAgentHome home)
StandardEJBEventListenerを新規に生成します。
メソッドの概要
 EventResult execute(Event event)
処理を実行します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListener から継承したメソッド
dispatchEvent, setInTransaction
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardEJBEventListener

public StandardEJBEventListener(StandardEJBEventListenerAgentHome home)
StandardEJBEventListenerを新規に生成します。

パラメータ:
home - ホームインタフェースStandardEJBEventListenerAgentHome
メソッドの詳細

execute

public EventResult execute(Event event)
                    throws SystemException,
                           ApplicationException
処理を実行します。 イベントを元に処理を実行します。 このインタフェースを実装するすべてのクラスは、 すべてのイベントトリガを実行した後に処理を 実行するように設計されている必要があります。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardEJBEventListenerAgent (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース StandardEJBEventListenerAgent

すべてのスーパーインタフェース:
EJBObject, Remote
public interface StandardEJBEventListenerAgent
extends EJBObject

EJBを利用するときのイベントリスナのリモートインタフェースです。

バージョン:
1.0

メソッドの概要
 EventResult execute(Event event)
イベント処理を実行します。
インタフェース javax.ejb.EJBObject から継承したメソッド
getEJBHome, getHandle, getPrimaryKey, isIdentical, remove

メソッドの詳細

execute

public EventResult execute(Event event)
                    throws ApplicationException,
                           SystemException,
                           RemoteException,
                           EJBException
イベント処理を実行します。 実際の処理はStandardEJBEventListenerAgentBean.execute(jp.co.intra_mart.framework.base.event.Event)で行われます。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
EJBException - システムレベルのエラー
RemoteException - システムエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardEJBEventListenerAgentBean (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス StandardEJBEventListenerAgentBean

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean
        拡張 jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean
すべての実装インタフェース:
EnterpriseBean, Serializable, SessionBean
public abstract class StandardEJBEventListenerAgentBean
extends EJBEventListenerAgentBean

EJBを利用する場合の抽象的なイベントリスナです。 メソッドfire(jp.co.intra_mart.framework.base.event.Event, jp.co.intra_mart.framework.base.data.DataAccessController)を実装する必要があります。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean から継承したフィールド
sessionContext
コンストラクタの概要
StandardEJBEventListenerAgentBean()
StandardEJBEventListenerAgentBeanを新規に生成します。
メソッドの概要
void | ejbCreate() ホームインタフェースの引数なしのcreate()メソッドに対応します。
EventResult | execute(Event event) イベント処理を実行します。
protected abstract EventResult | fire(Event event, DataAccessController dataAccessController) イベントに対する処理です。
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean から継承したメソッド
dispatchEvent, ejbActivate, ejbPassivate, ejbRemove, setSessionContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardEJBEventListenerAgentBean

public StandardEJBEventListenerAgentBean()
StandardEJBEventListenerAgentBeanを新規に生成します。

メソッドの詳細

ejbCreate

public void ejbCreate()
ホームインタフェースの引数なしのcreate()メソッドに対応します。

導入されたバージョン:
3.2

execute

public EventResult execute(Event event)
                    throws ApplicationException,
                           SystemException,
                           EJBException
イベント処理を実行します。 このクラスでは以下のような順番で処理を行います。
  1. イベントトリガの実行(前処理)
  2. イベント処理の実行(fire(Event, DataAccessController))
  3. イベントトリガの実行(後処理)
  4. 簡易トランザクションのコミット(DataAccessController.commit())
このクラスではStandardEventListener.execute(Event)とは違い直接UserTransactionを扱っていません。そのため、このEJBを使うためにはコンテナ管理トランザクション(Container-management Transaction:CMT)を使用してください。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
EJBException - システムレベルのエラー

fire

protected abstract EventResult fire(Event event,
                                    DataAccessController dataAccessController)
                             throws SystemException,
                                    ApplicationException
イベントに対する処理です。

パラメータ:
event - イベント
dataAccessController - データアクセスコントローラ
戻り値:
イベント処理結果
例外:
SystemException - システム例外が発生
ApplicationException - アプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardEJBEventListenerAgentHome (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース StandardEJBEventListenerAgentHome

すべてのスーパーインタフェース:
EJBHome, Remote
public interface StandardEJBEventListenerAgentHome
extends EJBHome

StandardEJBEventListenerAgentのホームインタフェースです。

バージョン:
1.0

メソッドの概要
 StandardEJBEventListenerAgent create()
StandardEJBEventListenerAgentと接続します。
インタフェース javax.ejb.EJBHome から継承したメソッド
getEJBMetaData, getHomeHandle, remove, remove

メソッドの詳細

create

public StandardEJBEventListenerAgent create()
                                     throws RemoteException,
                                            CreateException
StandardEJBEventListenerAgentと接続します。

戻り値:
StandardEJBEventListenerAgent
例外:
RemoteException - システムレベルエラー
CreateException - EJBEventListenerAgent生成時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


StandardEJBEventListenerFactory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス StandardEJBEventListenerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerFactory
        拡張 jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory
すべての実装インタフェース:
EventListenerFactory
public class StandardEJBEventListenerFactory
extends EJBEventListenerFactory

標準的なEJB用のイベントリスナファクトリです。

バージョン:
1.0

フィールドの概要
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory から継承したフィールド
HOME_PARAM
コンストラクタの概要
StandardEJBEventListenerFactory()
StandardEJBEventListenerFactoryを新規に生成します。
メソッドの概要
EventListener | create(Event event) イベントリスナを生成します。
void | initParam(String name, String value) 初期パラメータを設定します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory から継承したメソッド
getJNDIName, setJNDIName
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardEJBEventListenerFactory

public StandardEJBEventListenerFactory()
StandardEJBEventListenerFactoryを新規に生成します。

メソッドの詳細

create

public EventListener create(Event event)
                     throws EventListenerException
イベントリスナを生成します。

パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

パラメータ:
name - パラメータ名
value - パラメータの値
例外:
EventListenerException - パラメータの設定時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardEventListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス StandardEventListener

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.StandardEventListener
すべての実装インタフェース:
EventListener
public abstract class StandardEventListener
extends Object
implements EventListener

汎用的なビジネスロジック用のクラスです。

バージョン:
1.0

コンストラクタの概要
StandardEventListener()
メソッドの概要
protected EventResult | dispatchEvent(Event event) イベント処理を実行します。
EventResult | execute(Event event) 処理を実行します。
protected abstract EventResult | fire(Event event) イベントに対する処理です。
protected Object | getDAO(String application, String key, String connect) DAOを取得します。
protected DataAccessController | getDataAccessController() このイベントリスナで使用するデータアクセスコントローラです。
void | setInTransaction(boolean transaction) このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardEventListener

public StandardEventListener()
メソッドの詳細

getDataAccessController

protected DataAccessController getDataAccessController()
このイベントリスナで使用するデータアクセスコントローラです。 このクラスを継承する場合、メソッドfire(jp.co.intra_mart.framework.base.event.Event)内ではデータアクセスコントローラの取得にはこのメソッドを使うようにしてください。

戻り値:
データアクセスコントローラ

getDAO

protected Object getDAO(String application,
                        String key,
                        String connect)
                 throws DataPropertyException,
                        DataConnectorException,
                        DAOException,
                        DataConnectException
DAOを取得します。 キーと接続情報で指定されたDAOを取得します。

パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAO
例外:
DataPropertyException - プロパティの取得に失敗
DataConnectorException - データコネクタの取得に失敗
DAOException - DAOの取得に失敗
DataConnectException - データリソースとの接続に失敗

execute

public EventResult execute(Event event)
                    throws SystemException,
                           ApplicationException
処理を実行します。 このクラスでは以下のような順番で処理を行います。
  1. ユーザトランザクションの開始
  2. イベントトリガの実行(前処理)
  3. イベント処理の実行(fire(jp.co.intra_mart.framework.base.event.Event))
  4. イベントトリガの実行(後処理)
  5. 簡易トランザクションのコミット(DataAccessController.commit())
  6. ユーザトランザクションのコミット

定義:
インタフェース EventListener 内の execute
パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生

fire

protected abstract EventResult fire(Event event)
                             throws SystemException,
                                    ApplicationException
イベントに対する処理です。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
SystemException - システム例外が発生
ApplicationException - アプリケーション例外が発生

setInTransaction

public void setInTransaction(boolean transaction)
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。

定義:
インタフェース EventListener 内の setInTransaction
パラメータ:
transaction - トランザクションの中で実行されている場合：true、そうでない場合：false
導入されたバージョン:
4.2

dispatchEvent

protected EventResult dispatchEvent(Event event)
                             throws EventManagerException,
                                    EventException,
                                    SystemException,
                                    ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventManagerException - イベントマネージャの生成に失敗
EventException - イベント処理実行に失敗
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生
導入されたバージョン:
4.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardEventListenerFactory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス StandardEventListenerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.StandardEventListenerFactory
すべての実装インタフェース:
EventListenerFactory
public class StandardEventListenerFactory
extends Object
implements EventListenerFactory

通常のJavaクラスのイベントリスナを生成します。 このファクトリで指定できる初期パラメータは以下のとおりです。

パラメータ名 | 値
listener | 生成するイベントリスナ

バージョン:
1.0

コンストラクタの概要
StandardEventListenerFactory()
StandardEventListenerFactoryを新規に生成します。
メソッドの概要
EventListener | create(Event event) イベントリスナを生成します。
void | initParam(String name, String value) 初期パラメータを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardEventListenerFactory

public StandardEventListenerFactory()
StandardEventListenerFactoryを新規に生成します。

メソッドの詳細

create

public EventListener create(Event event)
                     throws EventListenerException
イベントリスナを生成します。 初期パラメータで指定されたクラスをイベントリスナとして生成します。 初期パラメータで指定されたクラスはStandardEventListenerを継承している必要があります。

定義:
インタフェース EventListenerFactory 内の create
パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

定義:
インタフェース EventListenerFactory 内の initParam
パラメータ:
name - パラメータ名
value - パラメータの値
例外:
EventListenerException - パラメータの設定時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TextFileEventPropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス TextFileEventPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler
すべての実装インタフェース:
EventPropertyHandler, PropertyHandler
public class TextFileEventPropertyHandler
extends Object
implements EventPropertyHandler

指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。 ファイルの書式はDefaultEventPropertyHandlerで示されるものと同じです。
ファイルが存在するディレクトリ名はPARAM_FILE_DIRで示されるパラメータ名で指定します。
PARAM_DYNAMICで示されるパラメータにtrueを指定した場合 アプリケーション実行時にもプロパティの変更を動的に反映させることが可能となりますが、 パラメータの取得時に毎回ファイル操作を行うためパフォーマンスに悪影響を与える可能性があります。 このオプションは、開発時やデバッグ時のようにパラメータを頻繁に変更する必要がある場合のみtrueとし、 通常はfalseに設定しておいてください。

導入されたバージョン:
3.2

フィールドの概要
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
コンストラクタの概要
TextFileEventPropertyHandler()
TextFileEventPropertyHandlerを新規に生成します。
メソッドの概要
String | getEventListenerFactoryName(String application, String key) キーに該当するイベントリスナファクトリのクラス名を取得します。
EventListenerFactoryParam[] | getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
String | getEventName(String application, String key) キーに該当するイベントのクラス名を取得します。
Collection | getEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
Collection | getPostEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

TextFileEventPropertyHandler

public TextFileEventPropertyHandler()
TextFileEventPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
プロパティの動的読み込みが可能かどうか調べます。

定義:
インタフェース EventPropertyHandler 内の isDynamic
戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可

getEventName

public String getEventName(String application,
                           String key)
                    throws EventPropertyException
キーに該当するイベントのクラス名を取得します。 該当するイベントが存在しない場合、nullを返します。

定義:
インタフェース EventPropertyHandler 内の getEventName
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントのクラス名
例外:
EventPropertyException - イベントのクラス名の取得に失敗

getEventListenerFactoryName

public String getEventListenerFactoryName(String application,
                                          String key)
                                   throws EventPropertyException
キーに該当するイベントリスナファクトリのクラス名を取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryName
パラメータ:
application - アプリケーション
key - イベントリスナファクトリのキー
戻り値:
イベントリスナファクトリのクラス名
例外:
EventPropertyException - イベントリスナファクトリのクラス名の取得に失敗

getEventListenerFactoryParams

public EventListenerFactoryParam[] getEventListenerFactoryParams(String application,
                                                                 String key)
                                                          throws EventPropertyException
キーに該当するイベントリスナファクトリの初期パラメータを取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryParams
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントリスナファクトリの初期パラメータ
例外:
EventPropertyException - イベントリスナファクトリの初期パラメータの取得に失敗

getEventTriggerInfos

public Collection getEventTriggerInfos(String application,
                                       String key)
                                throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener

getPostEventTriggerInfos

public Collection getPostEventTriggerInfos(String application,
                                           String key)
                                    throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 ここで取得されるイベントトリガはイベントの処理後に実行されます。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getPostEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XmlEventPropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス XmlEventPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler
すべての実装インタフェース:
EventPropertyHandler, PropertyHandler
public class XmlEventPropertyHandler
extends Object
implements EventPropertyHandler

XMLのEventPropertyHandlerです。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「プレフィックス_アプリケーションID.xml」です。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにEventManager.EVENT_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスはDEFAULT_BUNDLE_NAME_PARAMで示されるものです。
プロパティの設定内容は以下のとおりです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのxmlファイルのプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM xmlのパラメータ名
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
コンストラクタの概要
XmlEventPropertyHandler()
DefaultEventPropertyHandlerを新規に生成します。
メソッドの概要
String | getEventListenerFactoryName(String application, String key) アプリケーションIDとキーに該当するイベントリスナファクトリのクラス名を取得します。
EventListenerFactoryParam[] | getEventListenerFactoryParams(String application, String key) アプリケーションIDとキーに該当するイベントリスナファクトリの初期パラメータを取得します。
String | getEventName(String application, String key) アプリケーションIDとキーに該当するイベントのクラス名を取得します。
Collection | getEventTriggerInfos(String application, String key) アプリケーションIDとキーに該当するイベントのイベントトリガ情報をすべて取得します。
Collection | getPostEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのxmlファイルのプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
xmlのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

XmlEventPropertyHandler

public XmlEventPropertyHandler()
DefaultEventPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws EventPropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース EventPropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
EventPropertyException - チェック時に例外が発生

getEventName

public String getEventName(String application,
                           String key)
                    throws EventPropertyException
アプリケーションIDとキーに該当するイベントのクラス名を取得します。 該当するイベントが存在しない場合、nullを返します。

定義:
インタフェース EventPropertyHandler 内の getEventName
パラメータ:
application - アプリケーションID
key - イベントのキー
戻り値:
イベントのクラス名
例外:
EventPropertyException - イベントのクラス名の取得に失敗

getEventListenerFactoryName

public String getEventListenerFactoryName(String application,
                                          String key)
                                   throws EventPropertyException
アプリケーションIDとキーに該当するイベントリスナファクトリのクラス名を取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryName
パラメータ:
application - アプリケーションID
key - イベントリスナファクトリのキー
戻り値:
イベントリスナファクトリのクラス名
例外:
EventPropertyException - イベントリスナファクトリのクラス名の取得に失敗

getEventListenerFactoryParams

public EventListenerFactoryParam[] getEventListenerFactoryParams(String application,
                                                                 String key)
                                                          throws EventPropertyException
アプリケーションIDとキーに該当するイベントリスナファクトリの初期パラメータを取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryParams
パラメータ:
application - アプリケーションID
key - イベントのキー
戻り値:
イベントリスナファクトリの初期パラメータ
例外:
EventPropertyException - イベントリスナファクトリの初期パラメータの取得に失敗

getEventTriggerInfos

public Collection getEventTriggerInfos(String application,
                                       String key)
                                throws EventPropertyException
アプリケーションIDとキーに該当するイベントのイベントトリガ情報をすべて取得します。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getEventTriggerInfos
パラメータ:
application - アプリケーションID
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener

getPostEventTriggerInfos

public Collection getPostEventTriggerInfos(String application,
                                           String key)
                                    throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 ここで取得されるイベントトリガはイベントの処理後に実行されます。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getPostEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler の使用

jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.message.MessageManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.message.MessageManager の使用

MessageManager を使用しているパッケージ
jp.co.intra_mart.framework.base.message メッセージフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.message での MessageManager の使用

MessageManager を返す jp.co.intra_mart.framework.base.message のメソッド
static MessageManager MessageManager.getMessageManager()
メッセージマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.message.MessageManagerException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.message.MessageManagerException の使用

MessageManagerException を使用しているパッケージ
jp.co.intra_mart.framework.base.message メッセージフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.message での MessageManagerException の使用

MessageManagerException をスローする jp.co.intra_mart.framework.base.message のメソッド
static MessageManager MessageManager.getMessageManager()
メッセージマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.message.MessagePropertyException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.message.MessagePropertyException の使用

MessagePropertyException を使用しているパッケージ
jp.co.intra_mart.framework.base.message メッセージフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.message での MessagePropertyException の使用

MessagePropertyException をスローする jp.co.intra_mart.framework.base.message のメソッド
boolean | TextFileMessagePropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | TextFileMessagePropertyHandler.getMessage(String application, String key) メッセージを取得します。
String | TextFileMessagePropertyHandler.getMessage(String application, String key, Locale locale) メッセージを取得します。
boolean | MessagePropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | MessagePropertyHandler.getMessage(String application, String key) メッセージを取得します。
String | MessagePropertyHandler.getMessage(String application, String key, Locale locale) メッセージを取得します。
boolean | DefaultMessagePropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | DefaultMessagePropertyHandler.getMessage(String application, String key) メッセージを取得します。
String | DefaultMessagePropertyHandler.getMessage(String application, String key, Locale locale) メッセージを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.message.MessagePropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.message.MessagePropertyHandler の使用

MessagePropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.base.message メッセージフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.message での MessagePropertyHandler の使用

MessagePropertyHandler を実装している jp.co.intra_mart.framework.base.message のクラス
class | DefaultMessagePropertyHandler メッセージの設定情報に接続するデフォルトのプロパティハンドラです。
class | TextFileMessagePropertyHandler 指定されたファイルからプロパティ情報を取得するメッセージプロパティハンドラです。

MessagePropertyHandler を返す jp.co.intra_mart.framework.base.message のメソッド
 MessagePropertyHandler MessageManager.getMessagePropertyHandler()
メッセージプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler の使用

jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DefaultMessagePropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.message
クラス DefaultMessagePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler
すべての実装インタフェース:
MessagePropertyHandler, PropertyHandler
public class DefaultMessagePropertyHandler
extends Object
implements MessagePropertyHandler

メッセージの設定情報に接続するデフォルトのプロパティハンドラです。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「プレフィックス_アプリケーションID[_ロケール].properties」です。
_ロケールを追加することによってロケールごとにメッセージを変更することも可能です。ロケールによるプロパティファイルの優先順位はJavaTMのjava.util.ResourceBundleと同様のルールに従って決定されます。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにMessageManager.MESSAGE_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスはDEFAULT_BUNDLE_NAME_PARAMで示されるものです。

プロパティの内容は「キー=メッセージ」の形式で指定します。

導入されたバージョン:
4.2

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
コンストラクタの概要
DefaultMessagePropertyHandler()
DefaultMessagePropertyHandlerを新規に生成します。
メソッドの概要
String | getMessage(String application, String key) メッセージを取得します。
String | getMessage(String application, String key, Locale locale) メッセージを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultMessagePropertyHandler

public DefaultMessagePropertyHandler()
DefaultMessagePropertyHandlerを新規に生成します。

メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws MessagePropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース MessagePropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
MessagePropertyException - チェック時に例外が発生

getMessage

public String getMessage(String application,
                         String key)
                  throws MessagePropertyException
メッセージを取得します。 applicationで指定されるアプリケーション固有のプロパティから keyに該当するメッセージを取得します。 システムが稼動しているロケールをヒントにメッセージを取得します。

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
application - アプリケーションID
key - メッセージのキー
戻り値:
メッセージ
例外:
MessagePropertyException - メッセージ取得時に例外が発生

getMessage

public String getMessage(String application,
                         String key,
                         Locale locale)
                  throws MessagePropertyException
メッセージを取得します。 applicationで指定されるアプリケーション固有のプロパティから keyに該当するメッセージを取得します。 localeで指定されたロケールをヒントにメッセージを取得します。

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
application - アプリケーションID
key - メッセージのキー
locale - ロケール
戻り値:
メッセージ
例外:
MessagePropertyException - メッセージ取得時に例外が発生

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MessageManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.message
クラス MessageManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.message.MessageManager
public class MessageManager
extends Object

メッセージマネージャです。

導入されたバージョン:
4.2

フィールドの概要
static String MESSAGE_PROPERTY_HANDLER_KEY
メッセージプロパティハンドラのキー
メソッドの概要
String | getMessage(String application, String key, Object[] args) ロケールを指定せず、キーに該当するメッセージを取得します。
String | getMessage(String application, String key, Object[] args, Locale locale) ロケールを指定し、キーに該当するメッセージを取得します。
static MessageManager | getMessageManager() メッセージマネージャを取得します。
MessagePropertyHandler | getMessagePropertyHandler() メッセージプロパティハンドラを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

MESSAGE_PROPERTY_HANDLER_KEY

public static final String MESSAGE_PROPERTY_HANDLER_KEY
メッセージプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getMessageManager

public static MessageManager getMessageManager()
                                        throws MessageManagerException
メッセージマネージャを取得します。

戻り値:
メッセージマネージャ
例外:
MessageManagerException - メッセージマネージャの生成に失敗した

getMessage

public String getMessage(String application,
                         String key,
                         Object[] args)
ロケールを指定せず、キーに該当するメッセージを取得します。 このメソッドはgetMessage(application, key, args, java.util.Locale.getDefault())を呼んだときと同じ動作をします。

パラメータ:
application - アプリケーションID
key - キー
args - メッセージに設定するパラメータ
戻り値:
メッセージ（存在しない場合???key???）

getMessage

public String getMessage(String application,
                         String key,
                         Object[] args,
                         Locale locale)
ロケールを指定し、キーに該当するメッセージを取得します。 指定されたアプリケーションID、キー、ロケールに一致するメッセージをプロパティから取得し、 パラメータをメッセージ内部に埋め込んだ結果を返します。

このメソッドでは内部で以下のような動作をします。
  1. getMessagePropertyHandler()を呼び、MessagePropertyHandlerを取得する。
  2. MessagePropertyHandler.getMessage(application, key, locale)を呼び、メッセージを取得する。
  3. new java.text.MessageFormat(上で取得したメッセージ).format(args)を呼び、パラメータを埋め込んだメッセージを返す。

パラメータ:
application - アプリケーションID
key - キー
args - メッセージに設定するパラメータ
locale - ロケール
戻り値:
メッセージ（存在しない場合???key???）

getMessagePropertyHandler

public MessagePropertyHandler getMessagePropertyHandler()
メッセージプロパティハンドラを取得します。

戻り値:
メッセージプロパティハンドラ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MessageManagerException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.message
クラス MessageManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.message.MessageManagerException
すべての実装インタフェース:
Serializable
public class MessageManagerException
extends SystemException

サービスマネージャ設定時の例外です。

導入されたバージョン:
4.2
関連項目:
直列化された形式

コンストラクタの概要
MessageManagerException()
詳細メッセージを指定しないで MessageManagerException を構築します。
MessageManagerException(String msg)
指定された詳細メッセージを持つ MessageManagerException を構築します。
MessageManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessageManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MessageManagerException

public MessageManagerException()
詳細メッセージを指定しないで MessageManagerException を構築します。

MessageManagerException

public MessageManagerException(String msg)
指定された詳細メッセージを持つ MessageManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

MessageManagerException

public MessageManagerException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessageManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MessagePropertyException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.message
クラス MessagePropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.message.MessagePropertyException
すべての実装インタフェース:
Serializable
public class MessagePropertyException
extends SystemException

メッセージプロパティ取得時の例外です。 * @author INTRAMART

導入されたバージョン:
4.2
関連項目:
直列化された形式

コンストラクタの概要
MessagePropertyException()
詳細メッセージを指定しないで MessagePropertyException を構築します。
MessagePropertyException(String msg)
指定された詳細メッセージを持つ MessagePropertyException を構築します。
MessagePropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessagePropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MessagePropertyException

public MessagePropertyException()
詳細メッセージを指定しないで MessagePropertyException を構築します。

MessagePropertyException

public MessagePropertyException(String msg)
指定された詳細メッセージを持つ MessagePropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

MessagePropertyException

public MessagePropertyException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessagePropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MessagePropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.message
インタフェース MessagePropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultMessagePropertyHandler, TextFileMessagePropertyHandler
public interface MessagePropertyHandler
extends PropertyHandler

メッセージの設定情報に接続するクラスです。

導入されたバージョン:
4.2

メソッドの概要
String | getMessage(String application, String key) メッセージを取得します。
String | getMessage(String application, String key, Locale locale) メッセージを取得します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws MessagePropertyException
プロパティの動的読み込みが可能かどうか調べます。

戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可
例外:
MessagePropertyException - チェック時に例外が発生

getMessage

public String getMessage(String application,
                         String key)
                  throws MessagePropertyException
メッセージを取得します。 applicationで指定されるアプリケーション固有のプロパティから keyに該当するメッセージを取得します。 システムが稼動しているロケールをヒントにメッセージを取得します。

パラメータ:
application - アプリケーションID
key - メッセージのキー
戻り値:
メッセージ
例外:
MessagePropertyException - メッセージ取得時に例外が発生

getMessage

public String getMessage(String application,
                         String key,
                         Locale locale)
                  throws MessagePropertyException
メッセージを取得します。 applicationで指定されるアプリケーション固有のプロパティから keyに該当するメッセージを取得します。 localeで指定されるロケールをヒントにメッセージを取得します。

パラメータ:
application - アプリケーションID
key - メッセージのキー
locale - ロケール
戻り値:
メッセージ
例外:
MessagePropertyException - メッセージ取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.message (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.base.message
インタフェース
MessagePropertyHandler
クラス
DefaultMessagePropertyHandler
MessageManager
TextFileMessagePropertyHandler
例外
MessageManagerException
MessagePropertyException


jp.co.intra_mart.framework.base.message (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.message

メッセージフレームワークに関連するクラスのパッケージです。

参照:
説明

インタフェースの概要
MessagePropertyHandler メッセージの設定情報に接続するクラスです。

クラスの概要
DefaultMessagePropertyHandler | メッセージの設定情報に接続するデフォルトのプロパティハンドラです。
MessageManager | メッセージマネージャです。
TextFileMessagePropertyHandler | 指定されたファイルからプロパティ情報を取得するメッセージプロパティハンドラです。

例外の概要
MessageManagerException | サービスマネージャ設定時の例外です。
MessagePropertyException | メッセージプロパティ取得時の例外です。

パッケージ jp.co.intra_mart.framework.base.message の説明

メッセージフレームワークに関連するクラスのパッケージです。 国際化対応したメッセージを取得します。


jp.co.intra_mart.framework.base.message クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.message の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler (implements jp.co.intra_mart.framework.base.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.base.message.MessageManager
    • class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler (implements jp.co.intra_mart.framework.base.message.MessagePropertyHandler)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.message.MessageManagerException
            • class jp.co.intra_mart.framework.base.message.MessagePropertyException

インタフェース階層

  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.base.message.MessagePropertyHandler


パッケージ jp.co.intra_mart.framework.base.message の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.message の使用

jp.co.intra_mart.framework.base.message を使用しているパッケージ
jp.co.intra_mart.framework.base.message メッセージフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.message により使用される jp.co.intra_mart.framework.base.message のクラス
MessageManager
メッセージマネージャです。
MessageManagerException
サービスマネージャ設定時の例外です。
MessagePropertyException
メッセージプロパティ取得時の例外です。
MessagePropertyHandler
メッセージの設定情報に接続するクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


TextFileMessagePropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.message
クラス TextFileMessagePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler
すべての実装インタフェース:
MessagePropertyHandler, PropertyHandler
public class TextFileMessagePropertyHandler
extends Object
implements MessagePropertyHandler

指定されたファイルからプロパティ情報を取得するメッセージプロパティハンドラです。 ファイルの書式はDefaultMessagePropertyHandlerで示されるものと同じです。
ファイルが存在するディレクトリ名はPARAM_FILE_DIRで示されるパラメータ名で指定します。
PARAM_DYNAMICで示されるパラメータにtrueを指定した場合 アプリケーション実行時にもプロパティの変更を動的に反映させることが可能となりますが、 パラメータの取得時に毎回ファイル操作を行うためパフォーマンスに悪影響を与える可能性があります。 このオプションは、開発時やデバッグ時のようにパラメータを頻繁に変更する必要がある場合のみtrueとし、 通常はfalseに設定しておいてください。

導入されたバージョン:
4.2

フィールドの概要
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
コンストラクタの概要
TextFileMessagePropertyHandler()
メソッドの概要
String | getMessage(String application, String key) メッセージを取得します。
String | getMessage(String application, String key, Locale locale) メッセージを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

TextFileMessagePropertyHandler

public TextFileMessagePropertyHandler()
メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws MessagePropertyException
プロパティの動的読み込みが可能かどうか調べます。

定義:
インタフェース MessagePropertyHandler 内の isDynamic
戻り値:
true 再設定可能、false 再設定不可
例外:
MessagePropertyException - チェック時に例外が発生

getMessage

public String getMessage(String application,
                         String key)
                  throws MessagePropertyException
メッセージを取得します。 applicationで指定されるアプリケーション固有のプロパティから keyに該当するメッセージを取得します。 システムが稼動しているロケールをヒントにメッセージを取得します。

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
application - アプリケーションID
key - メッセージのキー
戻り値:
メッセージ
例外:
MessagePropertyException - メッセージ取得時に例外が発生

getMessage

public String getMessage(String application,
                         String key,
                         Locale locale)
                  throws MessagePropertyException
メッセージを取得します。 applicationで指定されるアプリケーション固有のプロパティから keyに該当するメッセージを取得します。 localeで指定されたロケールをヒントにメッセージを取得します。

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
application - アプリケーションID
key - メッセージのキー
locale - ロケール
戻り値:
メッセージ
例外:
MessagePropertyException - メッセージ取得時に例外が発生

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.base.service.ControllerConverterModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ControllerConverterModel の使用

jp.co.intra_mart.framework.base.service.ControllerConverterModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler の使用

jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.DefaultTransition の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.DefaultTransition の使用

DefaultTransition を使用しているパッケージ
jp.co.intra_mart.extension.maskat.service

jp.co.intra_mart.extension.maskat.service での DefaultTransition の使用

jp.co.intra_mart.extension.maskat.service での DefaultTransition のサブクラス
 class MKTransition
マスカットに電文を送信するトランジションです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の使用

jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.EmptyServiceResult の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.EmptyServiceResult の使用

jp.co.intra_mart.framework.base.service.EmptyServiceResult はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.EncodingFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.EncodingFilter の使用

jp.co.intra_mart.framework.base.service.EncodingFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.FileUploadFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.FileUploadFilter の使用

jp.co.intra_mart.framework.base.service.FileUploadFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter の使用

jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.IntramartConnectFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.IntramartConnectFilter の使用

jp.co.intra_mart.framework.base.service.IntramartConnectFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.IntramartConnectServlet の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.IntramartConnectServlet の使用

jp.co.intra_mart.framework.base.service.IntramartConnectServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.IntramartLocaleFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.IntramartLocaleFilter の使用

jp.co.intra_mart.framework.base.service.IntramartLocaleFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition の使用

jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.LocaleFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.LocaleFilter の使用

jp.co.intra_mart.framework.base.service.LocaleFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.RequestException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.RequestException の使用

RequestException を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.validator |

jp.co.intra_mart.framework.base.service での RequestException の使用

RequestException 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
abstract String | Transition.getInputErrorPage(RequestException e) 入力エラーのページを取得します。
String | IntramartPageBaseTransition.getInputErrorPage(RequestException e) 入力エラーのページを取得します。
String | DefaultTransition.getInputErrorPage(RequestException e) 入力エラーのページを取得します。

RequestException をスローする jp.co.intra_mart.framework.base.service のメソッド
void | ServiceControllerAdapter.check() 入力内容をチェックします。
void | ServiceController.check() 入力内容をチェックします。

jp.co.intra_mart.framework.base.service.validator での RequestException の使用

jp.co.intra_mart.framework.base.service.validator での RequestException のサブクラス
 class ValidationException
検証結果が不正であるときの例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.service.RequestInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.RequestInfo の使用

RequestInfo を使用しているパッケージ
jp.co.intra_mart.extension.maskat.service.controller |
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.controller |
jp.co.intra_mart.framework.base.service.validator |

jp.co.intra_mart.extension.maskat.service.controller での RequestInfo の使用

RequestInfo 型のパラメータを持つ jp.co.intra_mart.extension.maskat.service.controller のメソッド
ControllerObject | NodePathControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
ControllerObject | MKControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。

jp.co.intra_mart.framework.base.service での RequestInfo の使用

RequestInfo 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
 ControllerObject ServiceManager.getControllerObject(String application, String service, Locale locale, RequestInfo info)
コントーラオブジェクトを取得します。

jp.co.intra_mart.framework.base.service.controller での RequestInfo の使用

RequestInfo 型のパラメータを持つ jp.co.intra_mart.framework.base.service.controller のメソッド
ControllerObject | SimpleControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
ControllerObject | ControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。

jp.co.intra_mart.framework.base.service.validator での RequestInfo の使用

RequestInfo 型のパラメータを持つ jp.co.intra_mart.framework.base.service.validator のメソッド
ValidationExceptionDetail | Validator.validate(RequestInfo info) リクエスト内容の検証をします。
ValidationExceptionDetail | NumericValidator.validate(RequestInfo info) 数値の検証をします。
ValidationExceptionDetail | NumericRangeValidator.validate(RequestInfo info) 数値の範囲を検証します。
ValidationExceptionDetail | LengthValidator.validate(RequestInfo info) 文字列の長さを検証します。
ValidationExceptionDetail | FormatValidator.validate(RequestInfo info) 文字列の不正文字（フォーマット）を検証します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.service.ServiceController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.ServiceController の使用

ServiceController を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.container |
jp.co.intra_mart.framework.extension.seasar.service |

jp.co.intra_mart.framework.base.service での ServiceController の使用

ServiceController を実装している jp.co.intra_mart.framework.base.service のクラス
 class ServiceControllerAdapter
いくつかのユーティリティメソッドと空のメソッドを実装したサービスコントローラです。

ServiceController を返す jp.co.intra_mart.framework.base.service のメソッド
 ServiceController ServiceManager.getServiceController(String application, String service)
推奨されていません。 このメソッドではなくServiceManager.getServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
 ServiceController ServiceManager.getServiceController(String application, String service, Locale locale)
サービスコントローラを取得します。

jp.co.intra_mart.framework.base.service.container での ServiceController の使用

ServiceController を返す jp.co.intra_mart.framework.base.service.container のメソッド
ServiceController | ServiceContainerImpl.getServiceController(String application, String service, Locale locale) サービスコントローラを取得します。
ServiceController | ServiceContainer.getServiceController(String application, String service, Locale locale) サービスコントローラを取得します。

jp.co.intra_mart.framework.extension.seasar.service での ServiceController の使用

ServiceController を返す jp.co.intra_mart.framework.extension.seasar.service のメソッド
 ServiceController S2ServiceContainer.getServiceController(String application, String service, Locale locale)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ServiceControllerAdapter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceControllerAdapter の使用

jp.co.intra_mart.framework.base.service.ServiceControllerAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ServiceControllerException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceControllerException の使用

ServiceControllerException を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.container |
jp.co.intra_mart.framework.extension.seasar.service |

jp.co.intra_mart.framework.base.service での ServiceControllerException の使用

ServiceControllerException をスローする jp.co.intra_mart.framework.base.service のメソッド
 ServiceController ServiceManager.getServiceController(String application, String service)
推奨されていません。 このメソッドではなくServiceManager.getServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
 ServiceController ServiceManager.getServiceController(String application, String service, Locale locale)
サービスコントローラを取得します。
 String ServiceControllerAdapter.getLoginUserID()
推奨されていません。 このメソッドではなくServiceControllerAdapter.getUserInfo()を使用してください。
 String ServiceControllerAdapter.getLoginGroupID()
推奨されていません。 このメソッドではなくServiceControllerAdapter.getUserInfo()を使用してください。
 UserInfo ServiceControllerAdapter.getUserInfo()
ユーザ情報を取得します。
protected  Event ServiceControllerAdapter.createEvent(String application, String key)
アプリケーションIDとキーに対応するイベントを取得します。

jp.co.intra_mart.framework.base.service.container での ServiceControllerException の使用

ServiceControllerException をスローする jp.co.intra_mart.framework.base.service.container のメソッド
ServiceController | ServiceContainerImpl.getServiceController(String application, String service, Locale locale) サービスコントローラを取得します。
ServiceController | ServiceContainer.getServiceController(String application, String service, Locale locale) サービスコントローラを取得します。

jp.co.intra_mart.framework.extension.seasar.service での ServiceControllerException の使用

ServiceControllerException をスローする jp.co.intra_mart.framework.extension.seasar.service のメソッド
 ServiceController S2ServiceContainer.getServiceController(String application, String service, Locale locale)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ServiceManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceManager の使用

ServiceManager を使用しているパッケージ
jp.co.intra_mart.framework.base.service サービスフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での ServiceManager の使用

ServiceManager を返す jp.co.intra_mart.framework.base.service のメソッド
protected ServiceManager | Transition.getServiceManager() サービスマネージャを取得します。
static ServiceManager | ServiceManager.getServiceManager() サービスマネージャを取得します。
protected ServiceManager | IntramartConnectServlet.getServiceManager() 推奨されていません。 サービスマネージャを取得します。

ServiceManager 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
protected  void Transition.setServiceManager(ServiceManager manager)
サービスマネージャを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ServiceManagerException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceManagerException の使用

ServiceManagerException を使用しているパッケージ
jp.co.intra_mart.framework.base.service サービスフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での ServiceManagerException の使用

ServiceManagerException をスローする jp.co.intra_mart.framework.base.service のメソッド
static ServiceManager | ServiceManager.getServiceManager() サービスマネージャを取得します。
String | ServiceManager.getExtesion() サービスフレームワークを呼び出すための拡張子を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ServicePropertyException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServicePropertyException の使用

ServicePropertyException を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.container |
jp.co.intra_mart.framework.extension.seasar.service |

jp.co.intra_mart.framework.base.service での ServicePropertyException の使用

ServicePropertyException をスローする jp.co.intra_mart.framework.base.service のメソッド
 boolean XmlServicePropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String XmlServicePropertyHandler.getClientEncoding()
クライアントのエンコードを取得します。
 Locale XmlServicePropertyHandler.getClientLocale()
クライアントのエンコードを取得します。
 String XmlServicePropertyHandler.getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
 String XmlServicePropertyHandler.getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getInputErrorPagePath()
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
 String XmlServicePropertyHandler.getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String XmlServicePropertyHandler.getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String XmlServicePropertyHandler.getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String XmlServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
 String XmlServicePropertyHandler.getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getServiceErrorPagePath()
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
 String XmlServicePropertyHandler.getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
 String XmlServicePropertyHandler.getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getSystemErrorPagePath()
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
 String XmlServicePropertyHandler.getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getTransitionName(String application, String service)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 String XmlServicePropertyHandler.getControllerConverterName(String application, String service, Locale locale)
コントローラコンバータのクラス名を取得します。
 ControllerConverterConfig XmlServicePropertyHandler.getControllerConverterConfig(String application, String service, Locale locale)
キーに該当するコントローラコンバータの初期パラメータを取得します。
 ValidatorMapping[] XmlServicePropertyHandler.getValidators(String application, String service, Locale locale)
キーに該当するバリデータを取得します。
 String XmlServicePropertyHandler.getServiceServletPath()
サービスサーブレットのパスを取得します。
 String XmlServicePropertyHandler.getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String XmlServicePropertyHandler.getApplicationParamName()
推奨されていません。 この実装は廃止されました。
 String XmlServicePropertyHandler.getServiceParamName()
推奨されていません。 この実装は廃止されました。
 String XmlServicePropertyHandler.getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String XmlServicePropertyHandler.getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String XmlServicePropertyHandler.getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
protected  String Transition.getNextPagePath()
このトランジションに設定されているアプリケーションIDとサービスIDに該当する次ページのパスを取得します。
protected  String Transition.getNextPagePath(String key)
このトランジションに設定されているアプリケーションIDとサービスIDと、指定されたキーに該当する次ページのパスを取得します。
abstract  String Transition.getInputErrorPage(RequestException e)
入力エラーのページを取得します。
abstract  String Transition.getSystemErrorPage(Exception e)
システムエラーのページを取得します。
abstract  String Transition.getServiceErrorPage(Exception e)
処理エラーのページを取得します。
abstract  String Transition.getNextPage()
次に遷移するページを取得します。
 String TextFileServicePropertyHandler.getClientEncoding()
クライアントのエンコードを取得します。
 Locale TextFileServicePropertyHandler.getClientLocale()
クライアントのロケールを取得します。
 String TextFileServicePropertyHandler.getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getNextPagePath(String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String TextFileServicePropertyHandler.getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getNextPagePath(String, String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String TextFileServicePropertyHandler.getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getInputErrorPagePath()
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
 String TextFileServicePropertyHandler.getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getServiceErrorPagePath()
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(Locale)を使用してください。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getSystemErrorPagePath()
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceControllerName(String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String TextFileServicePropertyHandler.getTransitionName(String application, String service)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getTransitionName(String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 String TextFileServicePropertyHandler.getServiceServletPath()
サービスサーブレットのパスを取得します。
 String TextFileServicePropertyHandler.getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String TextFileServicePropertyHandler.getApplicationParamName()
推奨されていません。 この実装は廃止されました。
 String TextFileServicePropertyHandler.getServiceParamName()
推奨されていません。 この実装は廃止されました。
 String TextFileServicePropertyHandler.getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String TextFileServicePropertyHandler.getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String TextFileServicePropertyHandler.getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 String TextFileServicePropertyHandler.getControllerConverterName(String application, String service, Locale locale)
 ControllerConverterConfig TextFileServicePropertyHandler.getControllerConverterConfig(String application, String service, Locale locale)
 ValidatorMapping[] TextFileServicePropertyHandler.getValidators(String application, String service, Locale locale)
 boolean ServicePropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String ServicePropertyHandler.getClientEncoding()
クライアントのエンコードを取得します。
 String ServicePropertyHandler.getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 Locale ServicePropertyHandler.getClientLocale()
クライアントのロケールを取得します。
 String ServicePropertyHandler.getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 String ServicePropertyHandler.getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなくServicePropertyHandler.getNextPagePath(String, String, Locale)を使用してください。
 String ServicePropertyHandler.getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String ServicePropertyHandler.getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくServicePropertyHandler.getNextPagePath(String, String, String, Locale)を使用してください。
 String ServicePropertyHandler.getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String ServicePropertyHandler.getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale)を使用してください。
 String ServicePropertyHandler.getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String ServicePropertyHandler.getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, String, Locale)を使用してください。
 String ServicePropertyHandler.getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String ServicePropertyHandler.getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, Locale)を使用してください。
 String ServicePropertyHandler.getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String ServicePropertyHandler.getInputErrorPagePath()
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
 String ServicePropertyHandler.getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String ServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale)を使用してください。
 String ServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String ServicePropertyHandler.getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, String, Locale)を使用してください。
 String ServicePropertyHandler.getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String ServicePropertyHandler.getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, Locale)を使用してください。
 String ServicePropertyHandler.getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String ServicePropertyHandler.getServiceErrorPagePath()
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(Locale)を使用してください。
 String ServicePropertyHandler.getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String ServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale)を使用してください。
 String ServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String ServicePropertyHandler.getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, String, Locale)を使用してください。
 String ServicePropertyHandler.getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String ServicePropertyHandler.getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, Locale)を使用してください。
 String ServicePropertyHandler.getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String ServicePropertyHandler.getSystemErrorPagePath()
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
 String ServicePropertyHandler.getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String ServicePropertyHandler.getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceControllerName(String, String, Locale)を使用してください。
 String ServicePropertyHandler.getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String ServicePropertyHandler.getTransitionName(String application, String service)
推奨されていません。 このメソッドではなくServicePropertyHandler.getTransitionName(String, String, Locale)を使用してください。
 String ServicePropertyHandler.getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 String ServicePropertyHandler.getControllerConverterName(String application, String service, Locale locale)
コントローラコンバータのクラス名を取得します。
 ControllerConverterConfig ServicePropertyHandler.getControllerConverterConfig(String application, String service, Locale locale)
キーに該当するコントローラコンバータの初期パラメータを取得します。
 ValidatorMapping[] ServicePropertyHandler.getValidators(String application, String service, Locale locale)
キーに該当するバリデータを取得します。
 String ServicePropertyHandler.getServiceServletPath()
推奨されていません。 この実装は廃止されました。
 String ServicePropertyHandler.getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String ServicePropertyHandler.getApplicationParamName()
推奨されていません。 この実装は廃止されました。
 String ServicePropertyHandler.getServiceParamName()
推奨されていません。 この実装は廃止されました。
 String ServicePropertyHandler.getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 ServiceController ServiceManager.getServiceController(String application, String service)
推奨されていません。 このメソッドではなくServiceManager.getServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
 ServiceController ServiceManager.getServiceController(String application, String service, Locale locale)
サービスコントローラを取得します。
 Transition ServiceManager.getTransition(String application, String service)
推奨されていません。 このメソッドではなくServiceManager.getTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
 Transition ServiceManager.getTransition(String application, String service, Locale locale)
トランジションを取得します。
 ControllerObject ServiceManager.getControllerObject(String application, String service, Locale locale, RequestInfo info)
コントーラオブジェクトを取得します。
 ValidatorMapping[] ServiceManager.getValidatorMapping(String application, String service, Locale locale)
バリデータを取得します。
 String ServiceManager.getApplication(HttpServletRequest request, HttpServletResponse response)
現在のリクエストに対するアプリケーションIDを取得します。
 String ServiceManager.getService(HttpServletRequest request, HttpServletResponse response)
現在のリクエストに対するサービスIDを取得します。
 Locale ServiceManager.getLocale(HttpServletRequest request, HttpServletResponse response)
現在のリクエストに対するロケールを取得します。
 String ServiceManager.getEncoding(HttpServletRequest request, HttpServletResponse response)
現在のリクエストに対するエンコーディングを取得します。
 String IntramartPageBaseTransition.getInputErrorPage(RequestException e)
入力エラーのページを取得します。
 String IntramartPageBaseTransition.getServiceErrorPage(Exception e)
処理エラーのページを取得します。
 String IntramartPageBaseTransition.getSystemErrorPage(Exception e)
システムエラーのページを取得します。
 String IntramartPageBaseTransition.getNextPage()
次に遷移するページを取得します。
 boolean DistributesServicePropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String DistributesServicePropertyHandler.getClientEncoding()
クライアントのエンコードを取得します。
 Locale DistributesServicePropertyHandler.getClientLocale()
クライアントのエンコードを取得します。
 String DistributesServicePropertyHandler.getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getInputErrorPagePath()
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
 String DistributesServicePropertyHandler.getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String DistributesServicePropertyHandler.getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String DistributesServicePropertyHandler.getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getServiceErrorPagePath()
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getSystemErrorPagePath()
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getTransitionName(String application, String service)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 String DistributesServicePropertyHandler.getServiceServletPath()
サービスサーブレットのパスを取得します。
 String DistributesServicePropertyHandler.getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String DistributesServicePropertyHandler.getApplicationParamName()
アプリケーションIDに該当するパラメータ名を取得します。
 String DistributesServicePropertyHandler.getServiceParamName()
サービスIDに該当するパラメータ名を取得します。
 String DistributesServicePropertyHandler.getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String DistributesServicePropertyHandler.getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String DistributesServicePropertyHandler.getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 String DistributesServicePropertyHandler.getControllerConverterName(String application, String service, Locale locale)
 ControllerConverterConfig DistributesServicePropertyHandler.getControllerConverterConfig(String application, String service, Locale locale)
 ValidatorMapping[] DistributesServicePropertyHandler.getValidators(String application, String service, Locale locale)
 String DefaultTransition.getInputErrorPage(RequestException e)
入力エラーのページを取得します。
 String DefaultTransition.getSystemErrorPage(Exception e)
システムエラーのページを取得します。
 String DefaultTransition.getServiceErrorPage(Exception e)
処理エラーのページを取得します。
 String DefaultTransition.getNextPage()
次に遷移するページを取得します。
 boolean DefaultServicePropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String DefaultServicePropertyHandler.getClientEncoding()
クライアントのエンコードを取得します。
 Locale DefaultServicePropertyHandler.getClientLocale()
クライアントのエンコードを取得します。
 String DefaultServicePropertyHandler.getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getInputErrorPagePath()
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
 String DefaultServicePropertyHandler.getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String DefaultServicePropertyHandler.getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String DefaultServicePropertyHandler.getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getServiceErrorPagePath()
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getSystemErrorPagePath()
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getTransitionName(String application, String service)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 String DefaultServicePropertyHandler.getServiceServletPath()
サービスサーブレットのパスを取得します。
 String DefaultServicePropertyHandler.getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String DefaultServicePropertyHandler.getApplicationParamName()
推奨されていません。 この実装は廃止されました。
 String DefaultServicePropertyHandler.getServiceParamName()
推奨されていません。 この実装は廃止されました。
 String DefaultServicePropertyHandler.getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String DefaultServicePropertyHandler.getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String DefaultServicePropertyHandler.getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 String DefaultServicePropertyHandler.getControllerConverterName(String application, String service, Locale locale)
 ControllerConverterConfig DefaultServicePropertyHandler.getControllerConverterConfig(String application, String service, Locale locale)
 ValidatorMapping[] DefaultServicePropertyHandler.getValidators(String application, String service, Locale locale)

jp.co.intra_mart.framework.base.service.container での ServicePropertyException の使用

ServicePropertyException をスローする jp.co.intra_mart.framework.base.service.container のメソッド
ServiceController | ServiceContainerImpl.getServiceController(String application, String service, Locale locale) サービスコントローラを取得します。
Transition | ServiceContainerImpl.getTransition(String application, String service, Locale locale) トランジションを取得します。
ServiceController | ServiceContainer.getServiceController(String application, String service, Locale locale) サービスコントローラを取得します。
Transition | ServiceContainer.getTransition(String application, String service, Locale locale) トランジションを取得します。

jp.co.intra_mart.framework.extension.seasar.service での ServicePropertyException の使用

ServicePropertyException をスローする jp.co.intra_mart.framework.extension.seasar.service のメソッド
ServiceController | S2ServiceContainer.getServiceController(String application, String service, Locale locale)
Transition | S2ServiceContainer.getTransition(String application, String service, Locale locale)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.service.ServicePropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.ServicePropertyHandler の使用

ServicePropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.container |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.seasar.service |

jp.co.intra_mart.framework.base.service での ServicePropertyHandler の使用

ServicePropertyHandler を実装している jp.co.intra_mart.framework.base.service のクラス
class | DefaultServicePropertyHandler サービスの設定情報に接続するデフォルトのプロパティハンドラです。
class | DistributesServicePropertyHandler アプリケーションごとに異なるサービスプロパティハンドラを使用するサービスプロパティハンドラです。
class | TextFileServicePropertyHandler 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
class | XmlServicePropertyHandler サービスの設定情報に接続するプロパティハンドラです。

ServicePropertyHandler を返す jp.co.intra_mart.framework.base.service のメソッド
ServicePropertyHandler | ServiceManager.getServicePropertyHandler() サービスプロパティハンドラを取得します。
protected ServicePropertyHandler | IntramartConnectServlet.getServicePropertyHandler() 推奨されていません。 サービスプロパティハンドラを取得します。

jp.co.intra_mart.framework.base.service.container での ServicePropertyHandler の使用

ServicePropertyHandler を返す jp.co.intra_mart.framework.base.service.container のメソッド
ServicePropertyHandler | ServiceContainerImpl.getServicePropertyHandler() サービスプロパティハンドラを取得します。
ServicePropertyHandler | ServiceContainer.getServicePropertyHandler() サービスプロパティハンドラを取得します。

jp.co.intra_mart.framework.base.web.bean での ServicePropertyHandler の使用

ServicePropertyHandler を返す jp.co.intra_mart.framework.base.web.bean のメソッド
 ServicePropertyHandler HelperBean.getServicePropertyHandler()
サービスプロパティハンドラを取得します。

jp.co.intra_mart.framework.extension.seasar.service での ServicePropertyHandler の使用

ServicePropertyHandler を返す jp.co.intra_mart.framework.extension.seasar.service のメソッド
 ServicePropertyHandler S2ServiceContainer.getServicePropertyHandler()

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.service.ServiceResult の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.ServiceResult の使用

ServiceResult を使用しているパッケージ
jp.co.intra_mart.extension.maskat.service |
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.extension.maskat.service での ServiceResult の使用

jp.co.intra_mart.extension.maskat.service での ServiceResult のサブインタフェース
 interface MKServiceResult
マスカット連携を行う処理結果です。

ServiceResult を実装している jp.co.intra_mart.extension.maskat.service のクラス
class | DefaultMKServiceResult デフォルトのMKServiceResult実装です。
class | MKErrorsResult マスカットにエラーを返すサービス処理結果です。

jp.co.intra_mart.framework.base.service での ServiceResult の使用

ServiceResult を実装している jp.co.intra_mart.framework.base.service のクラス
 class EmptyServiceResult
情報を何も持たないServiceResultの実装です。

ServiceResult を返す jp.co.intra_mart.framework.base.service のメソッド
ServiceResult | Transition.getResult() サービス処理結果を取得します。
ServiceResult | ServiceControllerAdapter.service() 入力に対する処理を実行します。
ServiceResult | ServiceController.service() 入力に対する処理を実行します。
ServiceResult | RequestInfo.getResult() サービス処理結果を取得します。

ServiceResult 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
 void Transition.setResult(ServiceResult result)
サービス処理結果を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ServiceSecurityFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceSecurityFilter の使用

jp.co.intra_mart.framework.base.service.ServiceSecurityFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ServiceServlet の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceServlet の使用

jp.co.intra_mart.framework.base.service.ServiceServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ServiceServletException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceServletException の使用

jp.co.intra_mart.framework.base.service.ServiceServletException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler の使用

jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.Transition の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.Transition の使用

Transition を使用しているパッケージ
jp.co.intra_mart.extension.maskat.service |
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.container |
jp.co.intra_mart.framework.extension.seasar.service |

jp.co.intra_mart.extension.maskat.service での Transition の使用

jp.co.intra_mart.extension.maskat.service での Transition のサブクラス
 class MKTransition
マスカットに電文を送信するトランジションです。

jp.co.intra_mart.framework.base.service での Transition の使用

jp.co.intra_mart.framework.base.service での Transition のサブクラス
class | DefaultTransition デフォルトの画面遷移をします。
class | IntramartPageBaseTransition ページベースの画面に遷移する場合に使用するトランジションです。

Transition を返す jp.co.intra_mart.framework.base.service のメソッド
 Transition ServiceManager.getTransition(String application, String service)
推奨されていません。 このメソッドではなくServiceManager.getTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
 Transition ServiceManager.getTransition(String application, String service, Locale locale)
トランジションを取得します。

jp.co.intra_mart.framework.base.service.container での Transition の使用

Transition を返す jp.co.intra_mart.framework.base.service.container のメソッド
Transition | ServiceContainerImpl.getTransition(String application, String service, Locale locale) トランジションを取得します。
Transition | ServiceContainer.getTransition(String application, String service, Locale locale) トランジションを取得します。

jp.co.intra_mart.framework.extension.seasar.service での Transition の使用

Transition を返す jp.co.intra_mart.framework.extension.seasar.service のメソッド
 Transition S2ServiceContainer.getTransition(String application, String service, Locale locale)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.TransitionException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.TransitionException の使用

TransitionException を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.container |
jp.co.intra_mart.framework.extension.seasar.service |

jp.co.intra_mart.framework.base.service での TransitionException の使用

TransitionException をスローする jp.co.intra_mart.framework.base.service のメソッド
abstract  String Transition.getInputErrorPage(RequestException e)
入力エラーのページを取得します。
abstract  String Transition.getSystemErrorPage(Exception e)
システムエラーのページを取得します。
abstract  String Transition.getServiceErrorPage(Exception e)
処理エラーのページを取得します。
abstract  void Transition.setInformation()
次の遷移先に渡す情報を設定します。
abstract  String Transition.getNextPage()
次に遷移するページを取得します。
 Transition ServiceManager.getTransition(String application, String service)
推奨されていません。 このメソッドではなくServiceManager.getTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
 Transition ServiceManager.getTransition(String application, String service, Locale locale)
トランジションを取得します。
 String IntramartPageBaseTransition.getInputErrorPage(RequestException e)
入力エラーのページを取得します。
 String IntramartPageBaseTransition.getServiceErrorPage(Exception e)
処理エラーのページを取得します。
 String IntramartPageBaseTransition.getSystemErrorPage(Exception e)
システムエラーのページを取得します。
 String IntramartPageBaseTransition.getNextPage()
次に遷移するページを取得します。
 void IntramartPageBaseTransition.setInformation()
次の遷移先に渡す情報を設定します。
 String DefaultTransition.getInputErrorPage(RequestException e)
入力エラーのページを取得します。
 String DefaultTransition.getSystemErrorPage(Exception e)
システムエラーのページを取得します。
 String DefaultTransition.getServiceErrorPage(Exception e)
処理エラーのページを取得します。
 void DefaultTransition.setInformation()
次の遷移先に渡す情報を設定します。
 String DefaultTransition.getNextPage()
次に遷移するページを取得します。

jp.co.intra_mart.framework.base.service.container での TransitionException の使用

TransitionException をスローする jp.co.intra_mart.framework.base.service.container のメソッド
Transition | ServiceContainerImpl.getTransition(String application, String service, Locale locale) トランジションを取得します。
Transition | ServiceContainer.getTransition(String application, String service, Locale locale) トランジションを取得します。

jp.co.intra_mart.framework.extension.seasar.service での TransitionException の使用

TransitionException をスローする jp.co.intra_mart.framework.extension.seasar.service のメソッド
 Transition S2ServiceContainer.getTransition(String application, String service, Locale locale)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ValidatorMapping の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ValidatorMapping の使用

ValidatorMapping を使用しているパッケージ
jp.co.intra_mart.framework.base.service サービスフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での ValidatorMapping の使用

ValidatorMapping を返す jp.co.intra_mart.framework.base.service のメソッド
ValidatorMapping[] | XmlServicePropertyHandler.getValidators(String application, String service, Locale locale) キーに該当するバリデータを取得します。
ValidatorMapping[] | TextFileServicePropertyHandler.getValidators(String application, String service, Locale locale)
ValidatorMapping[] | ServicePropertyHandler.getValidators(String application, String service, Locale locale) キーに該当するバリデータを取得します。
ValidatorMapping[] | ServiceManager.getValidatorMapping(String application, String service, Locale locale) バリデータを取得します。
ValidatorMapping[] | DistributesServicePropertyHandler.getValidators(String application, String service, Locale locale)
ValidatorMapping[] | DefaultServicePropertyHandler.getValidators(String application, String service, Locale locale)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ValidatorModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ValidatorModel の使用

jp.co.intra_mart.framework.base.service.ValidatorModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler の使用

jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.service.container.ServiceContainer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.container.ServiceContainer の使用

ServiceContainer を使用しているパッケージ
jp.co.intra_mart.framework.base.service.container
jp.co.intra_mart.framework.extension.seasar.service

jp.co.intra_mart.framework.base.service.container での ServiceContainer の使用

ServiceContainer を実装している jp.co.intra_mart.framework.base.service.container のクラス
 class ServiceContainerImpl
ServiceContainerの標準的な実装クラスです。

jp.co.intra_mart.framework.extension.seasar.service での ServiceContainer の使用

ServiceContainer を実装している jp.co.intra_mart.framework.extension.seasar.service のクラス
 class S2ServiceContainer
S2ServiceContainer　は　Seasar2　と連携しオブジェクトを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.container.ServiceContainerException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.container.ServiceContainerException の使用

jp.co.intra_mart.framework.base.service.container.ServiceContainerException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.container.ServiceContainerImpl の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.container.ServiceContainerImpl の使用

jp.co.intra_mart.framework.base.service.container.ServiceContainerImpl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.container.factory.DefaultServiceProvider の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.container.factory.DefaultServiceProvider の使用

jp.co.intra_mart.framework.base.service.container.factory.DefaultServiceProvider はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.container.factory.ServiceContainerFactory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.container.factory.ServiceContainerFactory の使用

jp.co.intra_mart.framework.base.service.container.factory.ServiceContainerFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DefaultServiceProvider (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.container.factory
クラス DefaultServiceProvider

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.container.factory.DefaultServiceProvider
すべての実装インタフェース:
Provider
public class DefaultServiceProvider
extends Object
implements Provider

標準的なプロバイダーです。
クラスパス上のリソースファイルを取得し、サービスコンテナの実装を決定します。

リソースファイル名 - imartContainer.properties
キー - serviceContainer

キーにはServiceContainerインターフェースの実装クラスをフルパッケージ名で指定してください。

導入されたバージョン:
6.0

コンストラクタの概要
DefaultServiceProvider()
DefaultServiceProviderを新規に生成します。
メソッドの概要
 IMContainer create()
ServiceContainerを生成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DefaultServiceProvider

public DefaultServiceProvider()
DefaultServiceProviderを新規に生成します。

メソッドの詳細

create

public IMContainer create()
                   throws IMContainerException
ServiceContainerを生成します。

定義:
インタフェース Provider 内の create
戻り値:
サービスコンテナ
例外:
IMContainerException - サービスコンテナ生成時に例外が発生。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.service.container.factory (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.base.service.container.factory
クラス
DefaultServiceProvider
ServiceContainerFactory


jp.co.intra_mart.framework.base.service.container.factory (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.service.container.factory

クラスの概要
DefaultServiceProvider | 標準的なプロバイダーです。
ServiceContainerFactory | ServiceContainerのファクトリクラスです。


jp.co.intra_mart.framework.base.service.container.factory クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.service.container.factory の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.service.container.factory.DefaultServiceProvider (implements jp.co.intra_mart.framework.system.container.factory.Provider)
    • class jp.co.intra_mart.framework.base.service.container.factory.ServiceContainerFactory (implements jp.co.intra_mart.framework.system.container.factory.IMContainerFactory)


パッケージ jp.co.intra_mart.framework.base.service.container.factory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.service.container.factory の使用

jp.co.intra_mart.framework.base.service.container.factory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ServiceContainerFactory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.container.factory
クラス ServiceContainerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.container.factory.ServiceContainerFactory
すべての実装インタフェース:
IMContainerFactory
public class ServiceContainerFactory
extends Object
implements IMContainerFactory

ServiceContainerのファクトリクラスです。 生成されるサービスコンテナはプロバイダーにより決定されます。

導入されたバージョン:
6.0

フィールドの概要
protected  Provider provider
コンストラクタの概要
ServiceContainerFactory()
メソッドの概要
IMContainer | create() ServiceContainerを生成します。
Provider | getProvider() プロバイダを返します。
void | setProvider(Provider p) プロバイダを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

provider

protected Provider provider
コンストラクタの詳細

ServiceContainerFactory

public ServiceContainerFactory()
メソッドの詳細

create

public IMContainer create()
                   throws IMContainerException
ServiceContainerを生成します。

定義:
インタフェース IMContainerFactory 内の create
戻り値:
サービスコンテナ
例外:
IMContainerException - サービスコンテナ生成時に例外が発生。

getProvider

public Provider getProvider()
プロバイダを返します。

定義:
インタフェース IMContainerFactory 内の getProvider
戻り値:
サービスコンテナのプロバイダ

setProvider

public void setProvider(Provider p)
プロバイダを設定します。

定義:
インタフェース IMContainerFactory 内の setProvider
パラメータ:
p - サービスコンテナのプロバイダ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.service.container (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.base.service.container
インタフェース
ServiceContainer
クラス
ServiceContainerImpl
例外
ServiceContainerException


jp.co.intra_mart.framework.base.service.container (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.service.container

インタフェースの概要
ServiceContainer サービスコンテナのインターフェースです。

クラスの概要
ServiceContainerImpl ServiceContainerの標準的な実装クラスです。

例外の概要
ServiceContainerException サービスコンテナ設定時の例外です。


jp.co.intra_mart.framework.base.service.container クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.service.container の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.service.container.ServiceContainerImpl (implements jp.co.intra_mart.framework.base.service.container.ServiceContainer)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.service.container.ServiceContainerException

インタフェース階層

  • interface jp.co.intra_mart.framework.system.container.IMContainer
    • interface jp.co.intra_mart.framework.base.service.container.ServiceContainer


パッケージ jp.co.intra_mart.framework.base.service.container の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.service.container の使用

jp.co.intra_mart.framework.base.service.container を使用しているパッケージ
jp.co.intra_mart.framework.base.service.container
jp.co.intra_mart.framework.extension.seasar.service

jp.co.intra_mart.framework.base.service.container により使用される jp.co.intra_mart.framework.base.service.container のクラス
ServiceContainer
サービスコンテナのインターフェースです。

jp.co.intra_mart.framework.extension.seasar.service により使用される jp.co.intra_mart.framework.base.service.container のクラス
ServiceContainer
サービスコンテナのインターフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ServiceContainer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.container
インタフェース ServiceContainer

すべてのスーパーインタフェース:
IMContainer
既知の実装クラスの一覧:
S2ServiceContainer, ServiceContainerImpl
public interface ServiceContainer
extends IMContainer

サービスコンテナのインターフェースです。
サービスコンテナはServiceManagerの振る舞いを決定します。 ServiceManagerではサービスコンテナを保管し、その挙動はサービスコンテナの実装クラスに依存します。 サービスコンテナの実装は通常ServiceContainerFactoryによって生成されます。

導入されたバージョン:
6.0

フィールドの概要
static String SERVICE_PROPERTY_HANDLER_KEY
サービスプロパティハンドラのキー
メソッドの概要
ServiceController | getServiceController(String application, String service, Locale locale) サービスコントローラを取得します。
ServicePropertyHandler | getServicePropertyHandler() サービスプロパティハンドラを取得します。
Transition | getTransition(String application, String service, Locale locale) トランジションを取得します。
インタフェース jp.co.intra_mart.framework.system.container.IMContainer から継承したメソッド
init

フィールドの詳細

SERVICE_PROPERTY_HANDLER_KEY

public static final String SERVICE_PROPERTY_HANDLER_KEY
サービスプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getServicePropertyHandler

public ServicePropertyHandler getServicePropertyHandler()
サービスプロパティハンドラを取得します。

戻り値:
サービスプロパティハンドラ

getServiceController

public ServiceController getServiceController(String application,
                                              String service,
                                              Locale locale)
                                       throws ServicePropertyException,
                                              ServiceControllerException
サービスコントローラを取得します。 指定されたアプリケーションID、サービスID、ロケールに該当するサービスコントローラを取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

パラメータ:
application - アプリケーション
service - サービス
locale - ロケール
戻り値:
サービスコントローラ、存在しない場合はnull
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
ServiceControllerException - サービスコントローラ取得時に例外が発生

getTransition

public Transition getTransition(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException,
                                TransitionException
トランジションを取得します。 指定されたアプリケーションID、サービスID、ロケールに該当するトランジションを取得します。 該当するトランジションが存在しない場合、DefaultTransitionを返します。

パラメータ:
application - アプリケーション
service - サービス
locale - ロケール
戻り値:
トランジション
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
TransitionException - トランジション取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ServiceContainerException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.container
クラス ServiceContainerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.container.ServiceContainerException
すべての実装インタフェース:
Serializable
public class ServiceContainerException
extends SystemException

サービスコンテナ設定時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ServiceContainerException()
詳細メッセージを指定しないで ServiceContainerException を構築します。
ServiceContainerException(String msg)
指定された詳細メッセージを持つ ServiceContainerException を構築します。
ServiceContainerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceContainerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ServiceContainerException

public ServiceContainerException()
詳細メッセージを指定しないで ServiceContainerException を構築します。

ServiceContainerException

public ServiceContainerException(String msg)
指定された詳細メッセージを持つ ServiceContainerException を構築します。

パラメータ:
msg - 詳細メッセージ

ServiceContainerException

public ServiceContainerException(String msg,
                                 Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceContainerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ServiceContainerImpl (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.container
クラス ServiceContainerImpl

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.container.ServiceContainerImpl
すべての実装インタフェース:
IMContainer, ServiceContainer
public class ServiceContainerImpl
extends Object
implements ServiceContainer

ServiceContainerの標準的な実装クラスです。

フィールドの概要
インタフェース jp.co.intra_mart.framework.base.service.container.ServiceContainer から継承したフィールド
SERVICE_PROPERTY_HANDLER_KEY
コンストラクタの概要
ServiceContainerImpl()
ServiceContainerImplを生成します。
メソッドの概要
ServiceController | getServiceController(String application, String service, Locale locale) サービスコントローラを取得します。
ServicePropertyHandler | getServicePropertyHandler() サービスプロパティハンドラを取得します。
Transition | getTransition(String application, String service, Locale locale) トランジションを取得します。
void | init() ServiceContainerを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ServiceContainerImpl

public ServiceContainerImpl()
ServiceContainerImplを生成します。

メソッドの詳細

init

public void init()
          throws IMContainerException
ServiceContainerを初期化します。

定義:
インタフェース IMContainer 内の init
例外:
IMContainerException

getServiceController

public ServiceController getServiceController(String application,
                                              String service,
                                              Locale locale)
                                       throws ServicePropertyException,
                                              ServiceControllerException
サービスコントローラを取得します。 指定されたアプリケーションID、サービスID、ロケールに該当するサービスコントローラを取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

定義:
インタフェース ServiceContainer 内の getServiceController
パラメータ:
application - アプリケーション
service - サービス
locale - ロケール
戻り値:
サービスコントローラ、存在しない場合はnull
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
ServiceControllerException - サービスコントローラ取得時に例外が発生

getServicePropertyHandler

public ServicePropertyHandler getServicePropertyHandler()
サービスプロパティハンドラを取得します。

定義:
インタフェース ServiceContainer 内の getServicePropertyHandler
戻り値:
サービスプロパティハンドラ

getTransition

public Transition getTransition(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException,
                                TransitionException
トランジションを取得します。 指定されたアプリケーションID、サービスID、ロケールに該当するトランジションを取得します。 該当するトランジションが存在しない場合、DefaultTransitionを返します。

定義:
インタフェース ServiceContainer 内の getTransition
パラメータ:
application - アプリケーション
service - サービス
locale - ロケール
戻り値:
トランジション
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
TransitionException - トランジション取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.framework.base.service.controller.ControllerConverter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.controller.ControllerConverter の使用

ControllerConverter を使用しているパッケージ
jp.co.intra_mart.extension.maskat.service.controller
jp.co.intra_mart.framework.base.service.controller

jp.co.intra_mart.extension.maskat.service.controller での ControllerConverter の使用

ControllerConverter を実装している jp.co.intra_mart.extension.maskat.service.controller のクラス
class | MKControllerConverter マスカット連携時に使用する汎用的なコントローラコンバータです。
class | NodePathControllerConverter コントローラオブジェクトに「PATH_フィールド名」となる名前の静的フィールドを定義し、 代入されるノードのパスを指定することにより、ノードの値をコントローラオブジェクトに代入します。

jp.co.intra_mart.framework.base.service.controller での ControllerConverter の使用

ControllerConverter を実装している jp.co.intra_mart.framework.base.service.controller のクラス
 class SimpleControllerConverter
リクエストの内容をコントローラオブジェクトにマッピングする単純なコントローラコンバータです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfig の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfig の使用

ControllerConverterConfig を使用しているパッケージ
jp.co.intra_mart.extension.maskat.service.controller |
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.controller |

jp.co.intra_mart.extension.maskat.service.controller での ControllerConverterConfig の使用

ControllerConverterConfig 型のパラメータを持つ jp.co.intra_mart.extension.maskat.service.controller のメソッド
void | NodePathControllerConverter.init(ControllerConverterConfig config) NodePathControllerConverterを初期化します。
void | MKControllerConverter.init(ControllerConverterConfig config) MKControllerConverterを初期化します。

jp.co.intra_mart.framework.base.service での ControllerConverterConfig の使用

ControllerConverterConfig を返す jp.co.intra_mart.framework.base.service のメソッド
ControllerConverterConfig | XmlServicePropertyHandler.getControllerConverterConfig(String application, String service, Locale locale) キーに該当するコントローラコンバータの初期パラメータを取得します。
ControllerConverterConfig | TextFileServicePropertyHandler.getControllerConverterConfig(String application, String service, Locale locale)
ControllerConverterConfig | ServicePropertyHandler.getControllerConverterConfig(String application, String service, Locale locale) キーに該当するコントローラコンバータの初期パラメータを取得します。
ControllerConverterConfig | DistributesServicePropertyHandler.getControllerConverterConfig(String application, String service, Locale locale)
ControllerConverterConfig | DefaultServicePropertyHandler.getControllerConverterConfig(String application, String service, Locale locale)

jp.co.intra_mart.framework.base.service.controller での ControllerConverterConfig の使用

ControllerConverterConfig を実装している jp.co.intra_mart.framework.base.service.controller のクラス
 class ControllerConverterConfigImpl
ControllerConverterの初期化情報です。

ControllerConverterConfig 型のパラメータを持つ jp.co.intra_mart.framework.base.service.controller のメソッド
void | SimpleControllerConverter.init(ControllerConverterConfig config) SimpleControllerConverterを初期化します。
void | ControllerConverter.init(ControllerConverterConfig config) ControllerConverterを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfigImpl の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfigImpl の使用

jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfigImpl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.controller.ControllerConverterException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.controller.ControllerConverterException の使用

ControllerConverterException を使用しているパッケージ
jp.co.intra_mart.extension.maskat.service.controller |
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.controller |

jp.co.intra_mart.extension.maskat.service.controller での ControllerConverterException の使用

ControllerConverterException をスローする jp.co.intra_mart.extension.maskat.service.controller のメソッド
void | NodePathControllerConverter.init(ControllerConverterConfig config) NodePathControllerConverterを初期化します。
void | MKControllerConverter.init(ControllerConverterConfig config) MKControllerConverterを初期化します。

jp.co.intra_mart.framework.base.service での ControllerConverterException の使用

ControllerConverterException をスローする jp.co.intra_mart.framework.base.service のメソッド
 ControllerObject ServiceManager.getControllerObject(String application, String service, Locale locale, RequestInfo info)
コントーラオブジェクトを取得します。

jp.co.intra_mart.framework.base.service.controller での ControllerConverterException の使用

ControllerConverterException をスローする jp.co.intra_mart.framework.base.service.controller のメソッド
void | SimpleControllerConverter.init(ControllerConverterConfig config) SimpleControllerConverterを初期化します。
void | ControllerConverter.init(ControllerConverterConfig config) ControllerConverterを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.service.controller.ControllerObject の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.controller.ControllerObject の使用

ControllerObject を使用しているパッケージ
jp.co.intra_mart.extension.maskat.service.controller |
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.controller |

jp.co.intra_mart.extension.maskat.service.controller での ControllerObject の使用

ControllerObject を実装している jp.co.intra_mart.extension.maskat.service.controller のクラス
 class MKControllerObject
マスカット連携時に使用する汎用的なコントローラオブジェクトです。

ControllerObject を返す jp.co.intra_mart.extension.maskat.service.controller のメソッド
ControllerObject | NodePathControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
ControllerObject | MKControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。

jp.co.intra_mart.framework.base.service での ControllerObject の使用

ControllerObject を返す jp.co.intra_mart.framework.base.service のメソッド
ControllerObject | ServiceManager.getControllerObject(String application, String service, Locale locale, RequestInfo info) コントーラオブジェクトを取得します。
ControllerObject | ServiceControllerAdapter.getControllerObject() コントローラオブジェクトを取得します。
ControllerObject | ServiceController.getControllerObject() コントローラオブジェクトを取得します。
ControllerObject | RequestInfo.getControllerObject() リクエストから生成されたコントローラオブジェクトを取得します。

ControllerObject 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
void | ServiceControllerAdapter.setControllerObject(ControllerObject controllerObject) コントローラオブジェクトを設定します。
void | ServiceController.setControllerObject(ControllerObject controllerObject) コントローラオブジェクトを設定します。

jp.co.intra_mart.framework.base.service.controller での ControllerObject の使用

ControllerObject を返す jp.co.intra_mart.framework.base.service.controller のメソッド
ControllerObject | SimpleControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
ControllerObject | ControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.controller.RequestFormatException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.controller.RequestFormatException の使用

RequestFormatException を使用しているパッケージ
jp.co.intra_mart.extension.maskat.service.controller |
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.controller |

jp.co.intra_mart.extension.maskat.service.controller での RequestFormatException の使用

RequestFormatException をスローする jp.co.intra_mart.extension.maskat.service.controller のメソッド
ControllerObject | NodePathControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
ControllerObject | MKControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。

jp.co.intra_mart.framework.base.service での RequestFormatException の使用

RequestFormatException をスローする jp.co.intra_mart.framework.base.service のメソッド
 ControllerObject ServiceManager.getControllerObject(String application, String service, Locale locale, RequestInfo info)
コントーラオブジェクトを取得します。

jp.co.intra_mart.framework.base.service.controller での RequestFormatException の使用

RequestFormatException をスローする jp.co.intra_mart.framework.base.service.controller のメソッド
ControllerObject | SimpleControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
ControllerObject | ControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter の使用

jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ControllerConverter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.controller
インタフェース ControllerConverter

既知の実装クラスの一覧:
MKControllerConverter, NodePathControllerConverter, SimpleControllerConverter
public interface ControllerConverter

リクエストをコントローラオブジェクトに変換します。 コントローラオブジェクトはリクエストの内容を入力情報として変換されたものです。 開発者はこのインタフェースを実装し、適切なコントローラオブジェクトを返すように convert(RequestInfo)メソッドを実装する 必要があります。

生成されるコントローラオブジェクトはJavaBeansTM の仕様に従う必要があります。

導入されたバージョン:
6.1

メソッドの概要
ControllerObject | convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
void | destroy() ControllerConverterを破棄します。
void | init(ControllerConverterConfig config) ControllerConverterを初期化します。

メソッドの詳細

init

public void init(ControllerConverterConfig config)
          throws ControllerConverterException
ControllerConverterを初期化します。

パラメータ:
config - 初期化情報
例外:
ControllerConverterException - 初期化時に例外が発生

destroy

public void destroy()
ControllerConverterを破棄します。

convert

public ControllerObject convert(RequestInfo info)
                         throws RequestFormatException,
                                ServletException,
                                IOException
リクエスト情報をもとに入力オブジェクトを生成します。

パラメータ:
info - リクエスト情報
戻り値:
リクエストの内容が含まれる入力オブジェクト
例外:
RequestFormatException - リクエストのフォーマットが不正
ServletException - 変換中にServletExceptionが発生
IOException - 変換中にIOExceptionが発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ControllerConverterConfig (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.controller
インタフェース ControllerConverterConfig

既知の実装クラスの一覧:
ControllerConverterConfigImpl
public interface ControllerConverterConfig

ControllerConverterの初期化情報です。

導入されたバージョン:
6.1

メソッドの概要
String | getInitParameter(String name) ControllerConverterを初期化するときのパラメータを取得します。
Enumeration | getInitParameterNames() 初期化パラメータの名前の一覧を取得します。

メソッドの詳細

getInitParameter

public String getInitParameter(String name)
ControllerConverterを初期化するときのパラメータを取得します。

パラメータ:
name - 初期化パラメータ名
戻り値:
初期化パラメータの値

getInitParameterNames

public Enumeration getInitParameterNames()
初期化パラメータの名前の一覧を取得します。

戻り値:
初期化パラメータの名前の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ControllerConverterConfigImpl (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.controller
クラス ControllerConverterConfigImpl

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.util.Config
        拡張 jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfigImpl
すべての実装インタフェース:
ControllerConverterConfig
public class ControllerConverterConfigImpl
extends Config
implements ControllerConverterConfig

ControllerConverterの初期化情報です。

導入されたバージョン:
6.1

フィールドの概要
クラス jp.co.intra_mart.framework.system.util.Config から継承したフィールド
parameters
コンストラクタの概要
ControllerConverterConfigImpl()
クラス jp.co.intra_mart.framework.system.util.Config から継承したメソッド
getInitParameter, getInitParameterNames, setInitParameter
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfig から継承したメソッド
getInitParameter, getInitParameterNames

コンストラクタの詳細

ControllerConverterConfigImpl

public ControllerConverterConfigImpl()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ControllerConverterException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.controller
クラス ControllerConverterException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.controller.ControllerConverterException
すべての実装インタフェース:
Serializable
public class ControllerConverterException
extends SystemException

ControllerConverterに関連する例外です。

導入されたバージョン:
6.1
関連項目:
直列化された形式

コンストラクタの概要
ControllerConverterException()
詳細メッセージを指定しないで ForwardSelectorException を構築します。
ControllerConverterException(String msg)
指定された詳細メッセージを持つ ForwardSelectorException を構築します。
ControllerConverterException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ForwardSelectorException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ControllerConverterException

public ControllerConverterException()
詳細メッセージを指定しないで ForwardSelectorException を構築します。

ControllerConverterException

public ControllerConverterException(String msg)
指定された詳細メッセージを持つ ForwardSelectorException を構築します。

パラメータ:
msg - 詳細メッセージ

ControllerConverterException

public ControllerConverterException(String msg,
                                    Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ForwardSelectorException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ControllerObject (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.controller
インタフェース ControllerObject

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
MKControllerObject
public interface ControllerObject
extends Serializable

コントローラオブジェクトのインタフェースです。 すべてのコントローラオブジェクトはこのインタフェースを実装する必要があります。 このインタフェースを実装するクラスはJavaBeansの仕様に沿っている必要があります。

導入されたバージョン:
6.1

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.service.controller (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.base.service.controller
インタフェース
ControllerConverter
ControllerConverterConfig
ControllerObject
クラス
ControllerConverterConfigImpl
SimpleControllerConverter
例外
ControllerConverterException
RequestFormatException


jp.co.intra_mart.framework.base.service.controller (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.service.controller

インタフェースの概要
ControllerConverter | リクエストをコントローラオブジェクトに変換します。
ControllerConverterConfig | ControllerConverterの初期化情報です。
ControllerObject | コントローラオブジェクトのインタフェースです。

クラスの概要
ControllerConverterConfigImpl | ControllerConverterの初期化情報です。
SimpleControllerConverter | リクエストの内容をコントローラオブジェクトにマッピングする単純なコントローラコンバータです。

例外の概要
ControllerConverterException | ControllerConverterに関連する例外です。
RequestFormatException | フォーマットが不正であるときの例外です。


jp.co.intra_mart.framework.base.service.controller クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.service.controller の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.system.util.Config
      • class jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfigImpl (implements jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfig)
    • class jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter (implements jp.co.intra_mart.framework.base.service.controller.ControllerConverter)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.service.controller.ControllerConverterException
            • class jp.co.intra_mart.framework.base.service.controller.RequestFormatException

インタフェース階層

  • interface jp.co.intra_mart.framework.base.service.controller.ControllerConverter
  • interface jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfig
  • interface java.io.Serializable
    • interface jp.co.intra_mart.framework.base.service.controller.ControllerObject


パッケージ jp.co.intra_mart.framework.base.service.controller の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.service.controller の使用

jp.co.intra_mart.framework.base.service.controller を使用しているパッケージ
jp.co.intra_mart.extension.maskat.service.controller |
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.controller |

jp.co.intra_mart.extension.maskat.service.controller により使用される jp.co.intra_mart.framework.base.service.controller のクラス
ControllerConverter
リクエストをコントローラオブジェクトに変換します。
ControllerConverterConfig
ControllerConverterの初期化情報です。
ControllerConverterException
ControllerConverterに関連する例外です。
ControllerObject
コントローラオブジェクトのインタフェースです。
RequestFormatException
フォーマットが不正であるときの例外です。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.base.service.controller のクラス
ControllerConverterConfig
ControllerConverterの初期化情報です。
ControllerConverterException
ControllerConverterに関連する例外です。
ControllerObject
コントローラオブジェクトのインタフェースです。
RequestFormatException
フォーマットが不正であるときの例外です。

jp.co.intra_mart.framework.base.service.controller により使用される jp.co.intra_mart.framework.base.service.controller のクラス
ControllerConverter
リクエストをコントローラオブジェクトに変換します。
ControllerConverterConfig
ControllerConverterの初期化情報です。
ControllerConverterException
ControllerConverterに関連する例外です。
ControllerObject
コントローラオブジェクトのインタフェースです。
RequestFormatException
フォーマットが不正であるときの例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


RequestFormatException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.controller
クラス RequestFormatException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.controller.RequestFormatException
すべての実装インタフェース:
Serializable
public class RequestFormatException
extends SystemException

フォーマットが不正であるときの例外です。

導入されたバージョン:
6.1
関連項目:
直列化された形式

コンストラクタの概要
RequestFormatException()
詳細メッセージを指定しないで RequestFormatException を構築します。
RequestFormatException(String msg)
指定された詳細メッセージを持つ RequestFormatException を構築します。
RequestFormatException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestFormatException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

RequestFormatException

public RequestFormatException()
詳細メッセージを指定しないで RequestFormatException を構築します。

RequestFormatException

public RequestFormatException(String msg)
指定された詳細メッセージを持つ RequestFormatException を構築します。

パラメータ:
msg - 詳細メッセージ

RequestFormatException

public RequestFormatException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestFormatException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SimpleControllerConverter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.controller
クラス SimpleControllerConverter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter
すべての実装インタフェース:
ControllerConverter
public class SimpleControllerConverter
extends Object
implements ControllerConverter

リクエストの内容をコントローラオブジェクトにマッピングする単純なコントローラコンバータです。 ここではコントローラオブジェクトはJavaBeansとして扱われます。 リクエストのパラメータから取得される値をコントローラオブジェクトのプロパティに設定します。 ここで対応付けられるコントローラオブジェクトのプロパティはすべてStringである必要があります。 パラメータとプロパティの対応ルールは以下のとおりです。

  • リクエストのパラメータ名とコントローラオブジェクトのプロパティ名が一致するものが対応付けられる
  • ある名前に対してリクエストのパラメータが存在するがコントローラオブジェクトのプロパティが存在しない、 またはリクエストのパラメータは存在しないがコントローラオブジェクトのプロパティが存在する場合は何も行われない
  • リクエストのパラメータが同一のパラメータ名でただ1つの値を持ち、 コントローラオブジェクトが同一名のプロパティのインデックスなしのsetterメソッド （引数はStringまたはその配列）を持つ場合はそのメソッドが使用される
  • リクエストのパラメータが同一のパラメータ名でただ1つの値を持ち、 コントローラオブジェクトが同一名のプロパティのインデックスなしのsetterメソッド （引数はStringの配列）を持たない場合は インデックス付きのsetterメソッド（第1引数はint、第2引数はString）が使用される
  • リクエストのパラメータが同一のパラメータ名で複数の値を持ち、 コントローラオブジェクトが同一名のプロパティのインデックスなしのsetterメソッド （引数はStringの配列）を持つ場合はそのメソッドが使用される
  • リクエストのパラメータが同一のパラメータ名で複数の値を持ち、 コントローラオブジェクトが同一名のプロパティのインデックスなしのsetterメソッド （引数はStringの配列）を持たない場合は インデックス付きのsetterメソッド（第1引数はint、第2引数はString）が使用される （この場合設定される順番はリクエストのパラメータと同一となる）
  • リクエストのパラメータが同一のパラメータ名で複数の値を持ち、 コントローラオブジェクトが同一名のプロパティにおいて複数の値を扱うsetterメソッドを持たない場合は インデックスなしのsetterメソッド（引数はString）が使用される （この場合リクエストのパラメータの最初の値のみが設定される）
  • コントローラオブジェクトが対応するプロパティのsetterメソッドを持たない場合何も行われない

導入されたバージョン:
6.1

フィールドの概要
static String OBJECT_PARAM_NAME
コントローラオブジェクトのクラス名を設定するパラメータ名
コンストラクタの概要
SimpleControllerConverter()
メソッドの概要
ControllerObject | convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
void | destroy() SimpleControllerConverterを破棄します。
void | init(ControllerConverterConfig config) SimpleControllerConverterを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

OBJECT_PARAM_NAME

public static final String OBJECT_PARAM_NAME
コントローラオブジェクトのクラス名を設定するパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

SimpleControllerConverter

public SimpleControllerConverter()
メソッドの詳細

init

public void init(ControllerConverterConfig config)
          throws ControllerConverterException
SimpleControllerConverterを初期化します。

定義:
インタフェース ControllerConverter 内の init
パラメータ:
config - 初期化情報
例外:
ControllerConverterException - 初期化時に例外が発生

destroy

public void destroy()
SimpleControllerConverterを破棄します。

定義:
インタフェース ControllerConverter 内の destroy

convert

public ControllerObject convert(RequestInfo info)
                         throws RequestFormatException,
                                ServletException,
                                IOException
リクエスト情報をもとに入力オブジェクトを生成します。

定義:
インタフェース ControllerConverter 内の convert
パラメータ:
info - リクエスト情報
戻り値:
リクエストの内容が含まれる入力オブジェクト
例外:
RequestFormatException - リクエストのフォーマットが不正
ServletException - 変換中にServletExceptionが発生
IOException - 変換中にIOExceptionが発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.base.service.validator.FormatValidator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.validator.FormatValidator の使用

jp.co.intra_mart.framework.base.service.validator.FormatValidator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.validator.LengthValidator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.validator.LengthValidator の使用

jp.co.intra_mart.framework.base.service.validator.LengthValidator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator の使用

jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.validator.NumericValidator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.validator.NumericValidator の使用

jp.co.intra_mart.framework.base.service.validator.NumericValidator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.validator.ValidationException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.validator.ValidationException の使用

jp.co.intra_mart.framework.base.service.validator.ValidationException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.validator.ValidationExceptionDetail の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.validator.ValidationExceptionDetail の使用

ValidationExceptionDetail を使用しているパッケージ
jp.co.intra_mart.framework.base.service.validator

jp.co.intra_mart.framework.base.service.validator での ValidationExceptionDetail の使用

ValidationExceptionDetail を返す jp.co.intra_mart.framework.base.service.validator のメソッド
ValidationExceptionDetail | Validator.validate(RequestInfo info) リクエスト内容の検証をします。
ValidationExceptionDetail | NumericValidator.validate(RequestInfo info) 数値の検証をします。
ValidationExceptionDetail | NumericRangeValidator.validate(RequestInfo info) 数値の範囲を検証します。
ValidationExceptionDetail | LengthValidator.validate(RequestInfo info) 文字列の長さを検証します。
ValidationExceptionDetail | FormatValidator.validate(RequestInfo info) 文字列の不正文字（フォーマット）を検証します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.service.validator.Validator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.validator.Validator の使用

Validator を使用しているパッケージ
jp.co.intra_mart.framework.base.service.validator

jp.co.intra_mart.framework.base.service.validator での Validator の使用

Validator を実装している jp.co.intra_mart.framework.base.service.validator のクラス
class | FormatValidator 文字列の不正文字（フォーマット）チェックを行います。
class | LengthValidator 文字列の長さをチェックします。
class | NumericRangeValidator 数値の範囲をチェックします。
class | NumericValidator 数値（整数）として妥当であるかどうかをチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.service.validator.ValidatorConfig の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.validator.ValidatorConfig の使用

ValidatorConfig を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.validator |

jp.co.intra_mart.framework.base.service での ValidatorConfig の使用

ValidatorConfig を返す jp.co.intra_mart.framework.base.service のメソッド
 ValidatorConfig ValidatorMapping.getValidatorConfig()
バリデータの初期化パラメータを取得します。

ValidatorConfig 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
 void ValidatorMapping.setValidatorConfig(ValidatorConfig validatorConfig)
バリデータの初期化パラメータを設定します。

jp.co.intra_mart.framework.base.service.validator での ValidatorConfig の使用

ValidatorConfig を実装している jp.co.intra_mart.framework.base.service.validator のクラス
 class ValidatorConfigImpl
ValidatorConfigの実装です。

ValidatorConfig 型のパラメータを持つ jp.co.intra_mart.framework.base.service.validator のメソッド
void | Validator.init(ValidatorConfig config) Validatorを初期化します。
void | NumericValidator.init(ValidatorConfig config) NumericValidatorを初期化します。
void | NumericRangeValidator.init(ValidatorConfig config) NumericRangeValidatorを初期化します。
void | LengthValidator.init(ValidatorConfig config) LengthValidatorを初期化します。
void | FormatValidator.init(ValidatorConfig config) FormatValidatorを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.validator.ValidatorConfigImpl の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.validator.ValidatorConfigImpl の使用

jp.co.intra_mart.framework.base.service.validator.ValidatorConfigImpl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.validator.ValidatorException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.validator.ValidatorException の使用

ValidatorException を使用しているパッケージ
jp.co.intra_mart.framework.base.service.validator

jp.co.intra_mart.framework.base.service.validator での ValidatorException の使用

ValidatorException をスローする jp.co.intra_mart.framework.base.service.validator のメソッド
void | Validator.init(ValidatorConfig config) Validatorを初期化します。
ValidationExceptionDetail | Validator.validate(RequestInfo info) リクエスト内容の検証をします。
void | NumericValidator.init(ValidatorConfig config) NumericValidatorを初期化します。
ValidationExceptionDetail | NumericValidator.validate(RequestInfo info) 数値の検証をします。
void | NumericRangeValidator.init(ValidatorConfig config) NumericRangeValidatorを初期化します。
ValidationExceptionDetail | NumericRangeValidator.validate(RequestInfo info) 数値の範囲を検証します。
void | LengthValidator.init(ValidatorConfig config) LengthValidatorを初期化します。
ValidationExceptionDetail | LengthValidator.validate(RequestInfo info) 文字列の長さを検証します。
void | FormatValidator.init(ValidatorConfig config) FormatValidatorを初期化します。
ValidationExceptionDetail | FormatValidator.validate(RequestInfo info) 文字列の不正文字（フォーマット）を検証します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


FormatValidator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.validator
クラス FormatValidator

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.validator.FormatValidator
すべての実装インタフェース:
Validator
public class FormatValidator
extends Object
implements Validator

文字列の不正文字（フォーマット）チェックを行います。 このクラスではControllerObjectのプロパティが、指定された正規表現に一致しているかどうかを検証します。

検証対象となるプロパティ名と正規表現のフォーマットは初期化パラメータで指定します。 プロパティ名はPARAM_PROPERTYで、フォーマットはPARAM_REGEXで与えられる名前でそれぞれ指定します。 正規表現はString.matches(java.lang.String)の引数で指定できるものと同じです。

該当するプロパティの内容がnullだった場合、 そのプロパティには空文字列が設定されているものとみなされます。

プロパティが正規表現に一致しない場合、PARAM_MESSAGEで与えられる名前のパラメータに設定されたメッセージが返されます。 このパラメータが設定されていない場合、このクラスで用意されたメッセージが返されます。

導入されたバージョン:
6.1

フィールドの概要
static String | PARAM_MESSAGE 不正文字列である場合のメッセージが設定されているパラメータ名
static String | PARAM_PROPERTY 検証対象となるコントローラオブジェクトのプロパティ名を示すパラメータ名
static String | PARAM_REGEX 正規表現によるフォーマットが設定されているパラメータ名
コンストラクタの概要
FormatValidator()
メソッドの概要
void | destroy() FormatValidatorを破棄します。
void | init(ValidatorConfig config) FormatValidatorを初期化します。
ValidationExceptionDetail | validate(RequestInfo info) 文字列の不正文字（フォーマット）を検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_PROPERTY

public static final String PARAM_PROPERTY
検証対象となるコントローラオブジェクトのプロパティ名を示すパラメータ名

関連項目:
定数フィールド値

PARAM_REGEX

public static final String PARAM_REGEX
正規表現によるフォーマットが設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MESSAGE

public static final String PARAM_MESSAGE
不正文字列である場合のメッセージが設定されているパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

FormatValidator

public FormatValidator()
メソッドの詳細

init

public void init(ValidatorConfig config)
          throws ValidatorException
FormatValidatorを初期化します。

定義:
インタフェース Validator 内の init
パラメータ:
config - 初期化情報
例外:
ValidatorException - 初期化時に例外が発生

destroy

public void destroy()
FormatValidatorを破棄します。

定義:
インタフェース Validator 内の destroy

validate

public ValidationExceptionDetail validate(RequestInfo info)
                                   throws ValidatorException
文字列の不正文字（フォーマット）を検証します。 検証の結果、リクエスト内容が不正である場合ValidationExceptionDetailを返します。 リクエスト内容が正常なものである場合、nullを返します。

定義:
インタフェース Validator 内の validate
パラメータ:
info - リクエスト情報
戻り値:
リクエスト内容が不正な場合：検証結果の詳細
正常な場合：null
例外:
ValidatorException - 該当するプロパティが存在しない、またはプロパティの取得に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LengthValidator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.validator
クラス LengthValidator

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.validator.LengthValidator
すべての実装インタフェース:
Validator
public class LengthValidator
extends Object
implements Validator

文字列の長さをチェックします。 このクラスではControllerObjectのプロパティの文字列長が、指定された範囲に含まれるかどうかを検証します。

検証対象となるプロパティ名と長さの範囲は初期化パラメータで指定します。 プロパティ名はPARAM_PROPERTYで、長さの範囲はPARAM_MINとPARAM_MAXで与えられる名前でそれぞれ指定します。 文字列長の最小値と最大値で設定できる値は、ともに0以上の整数かつintの最大値以下です。 最大値と最小値のパラメータは0以上かつInteger.MAX_VALUE以下である必要があります。 該当するプロパティの内容がnullだった場合、 そのプロパティには空文字列が設定されているものとみなされます。

プロパティの文字列長が最小値に満たない場合、PARAM_MESSAGE_SHORTで与えられる名前のパラメータに設定されたメッセージが返されます。 プロパティの文字列長が最大値を超える場合、PARAM_MESSAGE_LONGで与えられる名前のパラメータに設定されたメッセージが返されます。 これらのパラメータが設定されていない場合、このクラスで用意されたメッセージが返されます。

導入されたバージョン:
6.1

フィールドの概要
static String | PARAM_MAX 文字列長の最大値が設定されているパラメータ名
static String | PARAM_MESSAGE_LONG 文字列長が長い場合のメッセージが設定されているパラメータ名
static String | PARAM_MESSAGE_SHORT 文字列長が短い場合のメッセージが設定されているパラメータ名
static String | PARAM_MIN 文字列長の最小値が設定されているパラメータ名
static String | PARAM_PROPERTY 検証対象のプロパティ名が設定されているパラメータ名
コンストラクタの概要
LengthValidator()
メソッドの概要
void | destroy() LengthValidatorを破棄します。
void | init(ValidatorConfig config) LengthValidatorを初期化します。
ValidationExceptionDetail | validate(RequestInfo info) 文字列の長さを検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_PROPERTY

public static final String PARAM_PROPERTY
検証対象のプロパティ名が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MIN

public static final String PARAM_MIN
文字列長の最小値が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MAX

public static final String PARAM_MAX
文字列長の最大値が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MESSAGE_SHORT

public static final String PARAM_MESSAGE_SHORT
文字列長が短い場合のメッセージが設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MESSAGE_LONG

public static final String PARAM_MESSAGE_LONG
文字列長が長い場合のメッセージが設定されているパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

LengthValidator

public LengthValidator()
メソッドの詳細

init

public void init(ValidatorConfig config)
          throws ValidatorException
LengthValidatorを初期化します。

定義:
インタフェース Validator 内の init
パラメータ:
config - 初期化情報
例外:
ValidatorException - 初期化時に例外が発生

destroy

public void destroy()
LengthValidatorを破棄します。

定義:
インタフェース Validator 内の destroy

validate

public ValidationExceptionDetail validate(RequestInfo info)
                                   throws ValidatorException
文字列の長さを検証します。 検証の結果、リクエスト内容が不正である場合ValidationExceptionDetailを返します。 リクエスト内容が正常なものである場合、nullを返します。

定義:
インタフェース Validator 内の validate
パラメータ:
info - リクエスト情報
戻り値:
リクエスト内容が不正な場合：検証結果の詳細
正常な場合：null
例外:
ValidatorException - 該当するプロパティが存在しない、またはプロパティの取得に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NumericRangeValidator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.validator
クラス NumericRangeValidator

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator
すべての実装インタフェース:
Validator
public class NumericRangeValidator
extends Object
implements Validator

数値の範囲をチェックします。 このクラスではControllerObjectのプロパティの数値が、指定された範囲に含まれるかどうかを検証します。

検証対象となるプロパティ名と範囲は初期化パラメータで指定します。 プロパティ名はPARAM_PROPERTYで、数値の範囲はPARAM_MINとPARAM_MAXで与えられる名前でそれぞれ指定します。 数値の最小値と最大値で設定できる値は、ともに整数のみです。

最小値が省略された場合、数値の下限はチェックされません。 最大値が省略された場合、数値の上限はチェックされません。

最大値と最小値はともにチェック対象の範囲に含まれます。

最大値と最小値のパラメータはLong.parseLong(java.lang.String)の引数に指定できるものである必要があります。

プロパティの値が次のいずれかに該当する場合、 PARAM_MESSAGEで与えられる名前のパラメータに設定されたメッセージが返されます。

  • nullである
  • プロパティの数値が最小値に満たない
  • プロパティの数値が最大値を超える
  • プロパティがStringであり、その値がBigInteger.BigInteger(java.lang.String)の引数に指定できる値ではない
チェック対象のプロパティが以下のいずれかでもない場合、例外が返されます。
  • int
  • long
  • Integer
  • Long
  • BigInteger
  • String
チェック対象のプロパティが存在しない場合も、例外が返されます。

導入されたバージョン:
6.1

フィールドの概要
static String | PARAM_MAX 数値の最大値が設定されているパラメータ名
static String | PARAM_MESSAGE 数値が範囲外の場合のメッセージが設定されているパラメータ名
static String | PARAM_MIN 数値の最小値が設定されているパラメータ名
static String | PARAM_PROPERTY 検証対象のプロパティ名が設定されているパラメータ名
コンストラクタの概要
NumericRangeValidator()
メソッドの概要
void | destroy() NumericRangeValidatorを破棄します。
void | init(ValidatorConfig config) NumericRangeValidatorを初期化します。
ValidationExceptionDetail | validate(RequestInfo info) 数値の範囲を検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_MIN

public static final String PARAM_MIN
数値の最小値が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MAX

public static final String PARAM_MAX
数値の最大値が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_PROPERTY

public static final String PARAM_PROPERTY
検証対象のプロパティ名が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MESSAGE

public static final String PARAM_MESSAGE
数値が範囲外の場合のメッセージが設定されているパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

NumericRangeValidator

public NumericRangeValidator()
メソッドの詳細

init

public void init(ValidatorConfig config)
          throws ValidatorException
NumericRangeValidatorを初期化します。

定義:
インタフェース Validator 内の init
パラメータ:
config - 初期化情報
例外:
ValidatorException - 初期化時に例外が発生

destroy

public void destroy()
NumericRangeValidatorを破棄します。

定義:
インタフェース Validator 内の destroy

validate

public ValidationExceptionDetail validate(RequestInfo info)
                                   throws ValidatorException
数値の範囲を検証します。 検証の結果、リクエスト内容が不正である場合ValidationExceptionDetailを返します。 リクエスト内容が正常なものである場合、nullを返します。

定義:
インタフェース Validator 内の validate
パラメータ:
info - リクエスト情報
戻り値:
リクエスト内容が不正な場合：検証結果の詳細
正常な場合：null
例外:
ValidatorException - 該当するプロパティが存在しない、またはプロパティが数値として正しくない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NumericValidator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.validator
クラス NumericValidator

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.validator.NumericValidator
すべての実装インタフェース:
Validator
public class NumericValidator
extends Object
implements Validator

数値（整数）として妥当であるかどうかをチェックします。 このクラスではControllerObjectのプロパティが整数として妥当であるかどうかを検証します。

検証対象となるプロパティ名は初期化パラメータで指定します。 プロパティ名はPARAM_PROPERTYで指定します。

プロパティの型が以下のものであれば無条件で整数であるとみなされます。

  • int
  • long
プロパティの型が以下のものであり、かつnullでなければ無条件で整数であるとみなされます。
  • Integer
  • Long
  • BigInteger
プロパティがStringである場合、以下の条件をすべて満たせば整数として妥当であるとみなされます。
  • nullではない
  • 先頭にはマイナス符号が1つだけ付いてもよい。
  • 以降は1つ以上の10進数字の列で構成される。
上記以外の場合、該当するプロパティは数値として妥当でないものとみなされます。 この場合、validate(RequestInfo)の戻り値であるValidationExceptionにはPARAM_MESSAGEで与えられる名前のパラメータに設定されたメッセージが返されます。 このパラメータが設定されていない場合、このクラスで用意されたメッセージが返されます。

導入されたバージョン:
6.1

フィールドの概要
static String | PARAM_MESSAGE 数値として妥当ではない場合のメッセージが設定されているパラメータ名
static String | PARAM_PROPERTY 検証対象のプロパティ名が設定されているパラメータ名
コンストラクタの概要
NumericValidator()
メソッドの概要
void | destroy() NumericValidatorを破棄します。
void | init(ValidatorConfig config) NumericValidatorを初期化します。
ValidationExceptionDetail | validate(RequestInfo info) 数値の検証をします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_PROPERTY

public static final String PARAM_PROPERTY
検証対象のプロパティ名が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MESSAGE

public static final String PARAM_MESSAGE
数値として妥当ではない場合のメッセージが設定されているパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

NumericValidator

public NumericValidator()
メソッドの詳細

init

public void init(ValidatorConfig config)
          throws ValidatorException
NumericValidatorを初期化します。

定義:
インタフェース Validator 内の init
パラメータ:
config - 初期化情報
例外:
ValidatorException - 初期化時に例外が発生

destroy

public void destroy()
NumericValidatorを破棄します。

定義:
インタフェース Validator 内の destroy

validate

public ValidationExceptionDetail validate(RequestInfo info)
                                   throws ValidatorException
数値の検証をします。 検証の結果、リクエスト内容が不正である場合ValidationExceptionDetailを返します。 リクエスト内容が正常なものである場合、nullを返します。

定義:
インタフェース Validator 内の validate
パラメータ:
info - リクエスト情報
戻り値:
リクエスト内容が不正な場合：検証結果の詳細
正常な場合：null
例外:
ValidatorException - 該当するプロパティが存在しない、またはプロパティの取得に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.service.validator (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.base.service.validator
インタフェース
Validator
ValidatorConfig
クラス
FormatValidator
LengthValidator
NumericRangeValidator
NumericValidator
ValidationExceptionDetail
ValidatorConfigImpl
例外
ValidationException
ValidatorException


jp.co.intra_mart.framework.base.service.validator (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.service.validator

インタフェースの概要
Validator | リクエスト内容の検証をします。
ValidatorConfig | Validatorの初期化情報です。

クラスの概要
FormatValidator | 文字列の不正文字（フォーマット）チェックを行います。
LengthValidator | 文字列の長さをチェックします。
NumericRangeValidator | 数値の範囲をチェックします。
NumericValidator | 数値（整数）として妥当であるかどうかをチェックします。
ValidationExceptionDetail | 検証結果の詳細情報です。
ValidatorConfigImpl | ValidatorConfigの実装です。

例外の概要
ValidationException | 検証結果が不正であるときの例外です。
ValidatorException | Validatorに関連する例外です。


jp.co.intra_mart.framework.base.service.validator クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.service.validator の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.system.util.Config
      • class jp.co.intra_mart.framework.base.service.validator.ValidatorConfigImpl (implements jp.co.intra_mart.framework.base.service.validator.ValidatorConfig)
    • class jp.co.intra_mart.framework.base.service.validator.FormatValidator (implements jp.co.intra_mart.framework.base.service.validator.Validator)
    • class jp.co.intra_mart.framework.base.service.validator.LengthValidator (implements jp.co.intra_mart.framework.base.service.validator.Validator)
    • class jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator (implements jp.co.intra_mart.framework.base.service.validator.Validator)
    • class jp.co.intra_mart.framework.base.service.validator.NumericValidator (implements jp.co.intra_mart.framework.base.service.validator.Validator)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.ApplicationException
            • class jp.co.intra_mart.framework.base.service.RequestException
              • class jp.co.intra_mart.framework.base.service.validator.ValidationException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.service.validator.ValidatorException
    • class jp.co.intra_mart.framework.base.service.validator.ValidationExceptionDetail

インタフェース階層

  • interface jp.co.intra_mart.framework.base.service.validator.Validator
  • interface jp.co.intra_mart.framework.base.service.validator.ValidatorConfig


パッケージ jp.co.intra_mart.framework.base.service.validator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.service.validator の使用

jp.co.intra_mart.framework.base.service.validator を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.validator |

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.base.service.validator のクラス
ValidatorConfig
Validatorの初期化情報です。

jp.co.intra_mart.framework.base.service.validator により使用される jp.co.intra_mart.framework.base.service.validator のクラス
ValidationExceptionDetail
検証結果の詳細情報です。
Validator
リクエスト内容の検証をします。
ValidatorConfig
Validatorの初期化情報です。
ValidatorException
Validatorに関連する例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ValidationException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.validator
クラス ValidationException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.ApplicationException
                    拡張 jp.co.intra_mart.framework.base.service.RequestException
                        拡張 jp.co.intra_mart.framework.base.service.validator.ValidationException
すべての実装インタフェース:
Serializable
public class ValidationException
extends RequestException

検証結果が不正であるときの例外です。

導入されたバージョン:
6.1
関連項目:
直列化された形式

コンストラクタの概要
ValidationException()
詳細メッセージを指定しないで ValidationException を構築します。
ValidationException(String msg)
指定された詳細メッセージを持つ ValidationException を構築します。
ValidationException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestFormatException を構築します。
メソッドの概要
String | getMessage() 例外メッセージを取得します。
Iterator | getValidationExceptionDetails() 検証結果の詳細の一覧を取得します。
void | setValidationExceptionDetails(Collection details) 検証結果の詳細を設定します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ValidationException

public ValidationException()
詳細メッセージを指定しないで ValidationException を構築します。

ValidationException

public ValidationException(String msg)
指定された詳細メッセージを持つ ValidationException を構築します。

パラメータ:
msg - 詳細メッセージ

ValidationException

public ValidationException(String msg,
                           Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestFormatException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
メソッドの詳細

setValidationExceptionDetails

public void setValidationExceptionDetails(Collection details)
検証結果の詳細を設定します。 detailsはValidationExceptionDetailのコレクションである必要があります。

パラメータ:
details - 検証結果の詳細

getValidationExceptionDetails

public Iterator getValidationExceptionDetails()
検証結果の詳細の一覧を取得します。 戻り値はValidationExceptionDetailのコレクションのIteratorです。

戻り値:
検証結果の詳細の一覧

getMessage

public String getMessage()
例外メッセージを取得します。 詳細情報を含んだ形式で例外情報が取得されます。

戻り値:
例外メッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ValidationExceptionDetail (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.validator
クラス ValidationExceptionDetail

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.validator.ValidationExceptionDetail
public class ValidationExceptionDetail
extends Object

検証結果の詳細情報です。

導入されたバージョン:
6.1

コンストラクタの概要
ValidationExceptionDetail()
メッセージなしのValidatorExceptionDetailを生成します。
ValidationExceptionDetail(String message)
メッセージ付きのValidatorExceptionDetailを生成します。
メソッドの概要
void | addDetail(String detail) 検証結果の詳細を追加します。
Iterator | getDetails() 検証結果の詳細の一覧を取得します。
String | getMessage() 検証結果のメッセージを取得します。
void | setMessage(String message) 検証結果のメッセージを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ValidationExceptionDetail

public ValidationExceptionDetail()
メッセージなしのValidatorExceptionDetailを生成します。 この場合、メッセージとして空文字列が設定されたものとみなされます。

ValidationExceptionDetail

public ValidationExceptionDetail(String message)
メッセージ付きのValidatorExceptionDetailを生成します。

パラメータ:
message - メッセージ
メソッドの詳細

getMessage

public String getMessage()
検証結果のメッセージを取得します。

戻り値:
検証結果のメッセージ

setMessage

public void setMessage(String message)
検証結果のメッセージを設定します。

パラメータ:
message - 検証結果のメッセージ

addDetail

public void addDetail(String detail)
検証結果の詳細を追加します。

パラメータ:
detail - 検証結果の詳細

getDetails

public Iterator getDetails()
検証結果の詳細の一覧を取得します。 StringのCollectionのIteratorが返されます。

戻り値:
検証結果の詳細の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Validator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.validator
インタフェース Validator

既知の実装クラスの一覧:
FormatValidator, LengthValidator, NumericRangeValidator, NumericValidator
public interface Validator

リクエスト内容の検証をします。

導入されたバージョン:
6.1

メソッドの概要
void | destroy() Validatorを破棄します。
void | init(ValidatorConfig config) Validatorを初期化します。
ValidationExceptionDetail | validate(RequestInfo info) リクエスト内容の検証をします。

メソッドの詳細

init

public void init(ValidatorConfig config)
          throws ValidatorException
Validatorを初期化します。

パラメータ:
config - 初期化情報
例外:
ValidatorException - 初期化時に例外が発生

destroy

public void destroy()
Validatorを破棄します。

validate

public ValidationExceptionDetail validate(RequestInfo info)
                                   throws ValidatorException
リクエスト内容の検証をします。 検証の結果、リクエスト内容が不正である場合ValidationExceptionDetailを返します。 リクエスト内容が正常なものである場合、nullを返します。

パラメータ:
info - リクエスト情報
戻り値:
リクエスト内容が不正な場合：検証結果の詳細
正常な場合：null
例外:
検証中に想定外の例外が発生
ValidatorException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ValidatorConfig (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.validator
インタフェース ValidatorConfig

既知の実装クラスの一覧:
ValidatorConfigImpl
public interface ValidatorConfig

Validatorの初期化情報です。

導入されたバージョン:
6.1

メソッドの概要
String | getInitParameter(String name) Validatorを初期化するときのパラメータを取得します。
Enumeration | getInitParameterNames() 初期化パラメータの名前の一覧を取得します。

メソッドの詳細

getInitParameter

public String getInitParameter(String name)
Validatorを初期化するときのパラメータを取得します。

パラメータ:
name - 初期化パラメータ名
戻り値:
初期化パラメータの値

getInitParameterNames

public Enumeration getInitParameterNames()
初期化パラメータの名前の一覧を取得します。

戻り値:
初期化パラメータの名前の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ValidatorConfigImpl (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.validator
クラス ValidatorConfigImpl

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.util.Config
        拡張 jp.co.intra_mart.framework.base.service.validator.ValidatorConfigImpl
すべての実装インタフェース:
ValidatorConfig
public class ValidatorConfigImpl
extends Config
implements ValidatorConfig

ValidatorConfigの実装です。

導入されたバージョン:
6.1

フィールドの概要
クラス jp.co.intra_mart.framework.system.util.Config から継承したフィールド
parameters
コンストラクタの概要
ValidatorConfigImpl()
クラス jp.co.intra_mart.framework.system.util.Config から継承したメソッド
getInitParameter, getInitParameterNames, setInitParameter
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.framework.base.service.validator.ValidatorConfig から継承したメソッド
getInitParameter, getInitParameterNames

コンストラクタの詳細

ValidatorConfigImpl

public ValidatorConfigImpl()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ValidatorException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.validator
クラス ValidatorException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.validator.ValidatorException
すべての実装インタフェース:
Serializable
public class ValidatorException
extends SystemException

Validatorに関連する例外です。

導入されたバージョン:
6.1
関連項目:
直列化された形式

コンストラクタの概要
ValidatorException()
詳細メッセージを指定しないで ValidatorException を構築します。
ValidatorException(String msg)
指定された詳細メッセージを持つ ValidatorException を構築します。
ValidatorException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ValidatorException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ValidatorException

public ValidatorException()
詳細メッセージを指定しないで ValidatorException を構築します。

ValidatorException

public ValidatorException(String msg)
指定された詳細メッセージを持つ ValidatorException を構築します。

パラメータ:
msg - 詳細メッセージ

ValidatorException

public ValidatorException(String msg,
                          Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ValidatorException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ControllerConverterModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ControllerConverterModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.ControllerConverterModel
public class ControllerConverterModel
extends Object

コントローラコンバータ情報を管理するクラスです。

導入されたバージョン:
6.1

フィールドの概要
static String | ID
static String | P_ID_CONVERTER_CLASS
static String | P_ID_CONVERTER_PARAM
static String | P_ID_PARAM_NAME
static String | P_ID_PARAM_VALUE
コンストラクタの概要
ControllerConverterModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID

public static final String ID
関連項目:
定数フィールド値

P_ID_CONVERTER_CLASS

public static final String P_ID_CONVERTER_CLASS
関連項目:
定数フィールド値

P_ID_CONVERTER_PARAM

public static final String P_ID_CONVERTER_PARAM
関連項目:
定数フィールド値

P_ID_PARAM_NAME

public static final String P_ID_PARAM_NAME
関連項目:
定数フィールド値

P_ID_PARAM_VALUE

public static final String P_ID_PARAM_VALUE
関連項目:
定数フィールド値
コンストラクタの詳細

ControllerConverterModel

public ControllerConverterModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DefaultServicePropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス DefaultServicePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler
すべての実装インタフェース:
PropertyHandler, ServicePropertyHandler
public class DefaultServicePropertyHandler
extends Object
implements ServicePropertyHandler

サービスの設定情報に接続するデフォルトのプロパティハンドラです。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「 プレフィックス _ アプリケーションID .properties」です。また、アプリケーションに依存しない「 プレフィックス .properties」があります。
プロパティファイルのプレフィックスは PropertyManager.getPropertyHandlerParams(String) でキーに ServiceManager.SERVICE_PROPERTY_HANDLER_KEY を指定したときに取得されるパラメータのうち DEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスは DEFAULT_BUNDLE_NAME_PARAMで示されるものです。
プロパティの検索順は、アプリケーションごとのプロパティファイル「 プレフィックス _ アプリケーションID .properties」が優先されます。該当するプロパティが見つからない場合、引き続いて「 プレフィックス .properties」を検索します。
プロパティの設定内容は以下のとおりです。 プロパティの設定内容は以下のとおりです。

キー | 内容 | 共通 | アプリケーション毎
client.encoding | クライアントのエンコーディング 設定しない場合、リクエストに対する文字コードの変換は行われません。 | ○ | ×
encoding.attribute | ログインユーザのエンコーディングを保存する属性名 このプロパティは共通のプロパティファイルのみに設定します。 | ○ | ×
client.locale | クライアントのロケール クライアントからのリクエストのロケールのデフォルトです。 | ○ | ×
locale.attribute | ログインユーザのロケールを保存する属性名 このプロパティは共通のプロパティファイルのみに設定します。 | ○ | ×
context.path | 非推奨です。このプロパティは設定しないでください。コンテキストパスの取得はjavax.servlet.http.HttpServletRequestのgetContextPathメソッドを使用してください。 コンテキストパス / コンテキストパス で指定します。 パスの指定は必ず"/"で開始してください。（例：/imart） このプロパティは共通のプロパティファイルのみに設定します。 このプロパティが設定されている場合、im-J2EE Frameworkのタグライブラリを使用したときに遷移するWebアプリケーションが変更されます。 | ○ | ×
servlet.path | ServiceServletにマッピングされているパス（必須） / web.xmlで指定したサーブレットのマッピング で指定します。 パスの指定は必ず"/"で開始してください。（例：/ServiceServlet） このプロパティは共通のプロパティファイルのみに設定します。 | ○ | ×
application.param | アプリケーションIDを引き渡すときに使われる、リクエストのパラメータ名 このプロパティは共通のプロパティファイルのみに設定します。 | ○ | ×
service.param | サービスIDを引き渡すときに使われる、リクエストのパラメータ名 このプロパティは共通のプロパティファイルのみに設定します。 | ○ | ×
exception.attribute | 例外を例外ページに渡すときの属性名 このプロパティは共通のプロパティファイルのみに設定します。 | ○ | ×
controller.class. サービスID | アプリケーションID と サービスID に対応する ServiceControllerのクラス名 | × | ○
transition.class. サービスID | アプリケーションID と サービスID に対応する Transitionのクラス名 | × | ○
nextpage.path. サービスID . キー | アプリケーションID 、 サービスID と キー に対応する次の遷移先のパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） 遷移先を アプリケーションID と サービスID よりも細かく指定したい場合などに使用します。 | × | ○
nextpage.path. サービスID | アプリケーションID と サービスID に対応する次の遷移先のパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
input.error.page.path. サービスID . キー | サービスID と キー に対応する入力エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
input.error.page.path. サービスID | サービスID に対応するデフォルトの入力エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
input.error.page.path | デフォルトの入力エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | ○ | ○
service.error.page.path. サービスID . キー | サービスID と キー に対応するサービス処理エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
service.error.page.path. サービスID | サービスID に対応するデフォルトのサービス処理エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
service.error.page.path | デフォルトのサービス処理エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | ○ | ○
system.error.page.path. サービスID . キー | サービスID と キー に対応するシステム処理エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
system.error.page.path. サービスID | サービスID に対応するデフォルトのシステム処理エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
system.error.page.path | デフォルトのシステム処理エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | ○ | ○

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
インタフェース jp.co.intra_mart.framework.base.service.ServicePropertyHandler から継承したフィールド
DEFAULT_APPLICATION_PARAMETER, DEFAULT_ENCODING_ATTRIBUTE, DEFAULT_EXCEPTION_ATTRIBUTE, DEFAULT_LOCALE_ATTRIBUTE, DEFAULT_SERVICE_PARAMETER, REQUEST_INFO_ATTRIBUTE
コンストラクタの概要
DefaultServicePropertyHandler()
DefaultServicePropertyHandlerを新規に生成します。
メソッドの概要
 String getApplicationParamName()
推奨されていません。 この実装は廃止されました。
 String getClientEncoding()
クライアントのエンコードを取得します。
 Locale getClientLocale()
クライアントのエンコードを取得します。
 String getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 ControllerConverterConfig getControllerConverterConfig(String application, String service, Locale locale)
キーに該当するコントローラコンバータの初期パラメータを取得します。
 String getControllerConverterName(String application, String service, Locale locale)
コントローラコンバータのクラス名を取得します。
 String getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String getInputErrorPagePath()
推奨されていません。 このメソッドではなく getInputErrorPagePath(Locale)を使用してください。
 String getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, Locale) を使用してください。
 String getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, Locale) を使用してください。
 String getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, String, Locale) を使用してください。
 String getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 String getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなく getNextPagePath(String, String, Locale) を使用してください。
 String getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getNextPagePath(String, String, String, Locale) を使用してください。
 String getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなく getServiceControllerName(String, String, Locale) を使用してください。
 String getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String getServiceErrorPagePath()
推奨されていません。 このメソッドではなく getServiceErrorPagePath(Locale) を使用してください。
 String getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceParamName()
推奨されていません。 この実装は廃止されました。
 String getServiceServletPath()
サービスサーブレットのパスを取得します。
 String getSystemErrorPagePath()
推奨されていません。 このメソッドではなく getSystemErrorPagePath(Locale)を使用してください。
 String getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String getTransitionName(String application, String service)
推奨されていません。 このメソッドではなく getTransitionName(String, String, Locale) を使用してください。
 String getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 ValidatorMapping[] getValidators(String application, String service, Locale locale)
キーに該当するバリデータを取得します。
 void init(PropertyParam[] params)
プロパティハンドラを初期化します。
 boolean isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultServicePropertyHandler

public DefaultServicePropertyHandler()
DefaultServicePropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws ServicePropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース ServicePropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
ServicePropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getClientEncoding

public String getClientEncoding()
                         throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientEncoding
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getClientLocale

public Locale getClientLocale()
                       throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientLocale
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String, String)で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String)で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath() で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath() で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath()
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(Locale)を使用してください。

入力例外時のページのパスを取得します。 このメソッドは getInputErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getNextPagePath

public String getNextPagePath(String application,
                              String service)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなく getNextPagePath(String, String, Locale) を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。 このメソッドは getNextPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなく getNextPagePath(String, String, String, Locale) を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。 key が null の場合、 getNextPagePath(String, String) と同じ動作になります。 このメソッドは getNextPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。 key が null の場合、 getNextPagePath(String, String) と同じ動作になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service)
                                throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceControllerName(String, String, Locale) を使用してください。

サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。 このメソッドは getServiceControllerName(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service,
                                       Locale locale)
                                throws ServicePropertyException
サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, String, Locale) を使用してください。

処理例外時のページのパスを取得します。 このメソッドは getServiceErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, Locale) を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath(String)で取得されるページを返します。 このメソッドは getServiceErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, Locale) を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath()で取得されるページを返します。 このメソッドは getServiceErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath()
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(Locale) を使用してください。

処理例外時のページのパスを取得します。 このメソッドは getServiceErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String, String)で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String)で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath()で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath()
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(Locale)を使用してください。

システム例外時のページのパスを取得します。 このメソッドは getSystemErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getTransitionName

public String getTransitionName(String application,
                                String service)
                         throws ServicePropertyException
推奨されていません。 このメソッドではなく getTransitionName(String, String, Locale) を使用してください。

トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。 このメソッドは getTransitionName(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException
トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生
導入されたバージョン:
4.2

getServiceServletPath

public String getServiceServletPath()
                             throws ServicePropertyException
サービスサーブレットのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceServletPath
戻り値:
サービスサーブレットのパス
例外:
ServicePropertyException - サービスサーブレットのパスの取得時に例外が発生

getContextPath

public String getContextPath()
                      throws ServicePropertyException
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。

コンテキストパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getContextPath
戻り値:
コンテキストパス
例外:
ServicePropertyException - コンテキストパスの取得時に例外が発生

getApplicationParamName

public String getApplicationParamName()
                               throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

アプリケーションIDに該当するパラメータ名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_APPLICATION_PARAMETER で定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getApplicationParamName
戻り値:
アプリケーションIDに該当するパラメータ名
例外:
ServicePropertyException - アプリケーションIDに該当するパラメータ名の取得時に例外が発生

getServiceParamName

public String getServiceParamName()
                           throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

サービスIDに該当するパラメータ名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_SERVICE_PARAMETERで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceParamName
戻り値:
サービスIDに該当するパラメータ名
例外:
ServicePropertyException - サービスIDに該当するパラメータ名の取得時に例外が発生

getExceptionAttributeName

public String getExceptionAttributeName()
                                 throws ServicePropertyException
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_EXCEPTION_ATTRIBUTE で定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getExceptionAttributeName
戻り値:
例外の属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getEncodingAttributeName

public String getEncodingAttributeName()
                                throws ServicePropertyException
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_ENCODING_ATTRIBUTEで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getEncodingAttributeName
戻り値:
エンコードの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getLocaleAttributeName

public String getLocaleAttributeName()
                              throws ServicePropertyException
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_LOCALE_ATTRIBUTEで定義されている値を返します 。

定義:
インタフェース ServicePropertyHandler 内の getLocaleAttributeName
戻り値:
ロケールの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生
導入されたバージョン:
4.2

getControllerConverterName

public String getControllerConverterName(String application,
                                         String service,
                                         Locale locale)
                                  throws ServicePropertyException
インタフェース ServicePropertyHandler の記述:
コントローラコンバータのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するコントローラコンバータ名を取得します。 特に設定されていない場合、nullが返ります。

定義:
インタフェース ServicePropertyHandler 内の getControllerConverterName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - コントローラコンバータのクラス名の取得時に例外が発生

getControllerConverterConfig

public ControllerConverterConfig getControllerConverterConfig(String application,
                                                              String service,
                                                              Locale locale)
                                                       throws ServicePropertyException
インタフェース ServicePropertyHandler の記述:
キーに該当するコントローラコンバータの初期パラメータを取得します。

定義:
インタフェース ServicePropertyHandler 内の getControllerConverterConfig
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータの初期パラメータ
例外:
ServicePropertyException - コントローラコンバータの初期パラメータの取得に失敗

getValidators

public ValidatorMapping[] getValidators(String application,
                                        String service,
                                        Locale locale)
                                 throws ServicePropertyException
インタフェース ServicePropertyHandler の記述:
キーに該当するバリデータを取得します。

定義:
インタフェース ServicePropertyHandler 内の getValidators
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータの初期パラメータ
例外:
ServicePropertyException - バリデータの取得に失敗
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart 6.1.14
 前のクラス   次のクラス フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド 詳細:  フィールド | コンストラクタ | メソッド


DefaultTransition (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス DefaultTransition

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.Transition
        拡張 jp.co.intra_mart.framework.base.service.DefaultTransition
直系の既知のサブクラス:
MKTransition
public class DefaultTransition
extends Transition

デフォルトの画面遷移をします。

バージョン:
1.0

コンストラクタの概要
DefaultTransition()
DefaultTransitionを新規に生成します。
メソッドの概要
String | getInputErrorPage(RequestException e) 入力エラーのページを取得します。
String | getNextPage() 次に遷移するページを取得します。
String | getServiceErrorPage(Exception e) 処理エラーのページを取得します。
String | getSystemErrorPage(Exception e) システムエラーのページを取得します。
void | setInformation() 次の遷移先に渡す情報を設定します。
void | transfer() 次のページに遷移します。
クラス jp.co.intra_mart.framework.base.service.Transition から継承したメソッド
getApplication, getEntity, getNextPagePath, getNextPagePath, getRequest, getResponse, getResult, getService, getServiceManager, getSessionObject, setRequest, setResponse, setResult, setServiceManager
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DefaultTransition

public DefaultTransition()
DefaultTransitionを新規に生成します。

メソッドの詳細

getInputErrorPage

public String getInputErrorPage(RequestException e)
                         throws ServicePropertyException,
                                TransitionException
入力エラーのページを取得します。

定義:
クラス Transition 内の getInputErrorPage
パラメータ:
e - 例外
戻り値:
入力エラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getSystemErrorPage

public String getSystemErrorPage(Exception e)
                          throws ServicePropertyException,
                                 TransitionException
システムエラーのページを取得します。

定義:
クラス Transition 内の getSystemErrorPage
パラメータ:
e - 処理時の例外
戻り値:
システムエラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getServiceErrorPage

public String getServiceErrorPage(Exception e)
                           throws ServicePropertyException,
                                  TransitionException
処理エラーのページを取得します。

定義:
クラス Transition 内の getServiceErrorPage
パラメータ:
e - 処理時の例外
戻り値:
処理エラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

setInformation

public void setInformation()
                    throws TransitionException
次の遷移先に渡す情報を設定します。 このクラスでは何も行いません。

定義:
クラス Transition 内の setInformation
例外:
TransitionException - 情報設定時に例外が発生

getNextPage

public String getNextPage()
                   throws ServicePropertyException,
                          TransitionException
次に遷移するページを取得します。

定義:
クラス Transition 内の getNextPage
戻り値:
次に遷移するページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

transfer

public void transfer()
              throws SystemException
次のページに遷移します。 getNextPage()で取得されるページにforwardされます。

定義:
クラス Transition 内の transfer
例外:
SystemException - システム例外が発生
導入されたバージョン:
3.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DistributesServicePropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス DistributesServicePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler
すべての実装インタフェース:
PropertyHandler, ServicePropertyHandler
public class DistributesServicePropertyHandler
extends Object
implements ServicePropertyHandler

アプリケーションごとに異なるサービスプロパティハンドラを使用するサービスプロパティハンドラです。
通常時に使用されるサービスプロパティハンドラは default.class で示されるパラメータ名で指定します。 ここで指定されるサービスプロパティハンドラに渡す初期値は、 default.param.パラメータ名 で示されるパラメータ名で指定します。 ある特定のアプリケーションに対して特定のサービスプロパティハンドラを割り当てたい場合、 application.class.アプリケーションID で示されるパラメータ名で指定します。 ここで指定されるサービスプロパティハンドラに渡す初期値は、 application.param.アプリケーションID.パラメータ名 で示されるパラメータ名で指定します。 ファイルが存在するディレクトリ名は PARAM_FILE_DIRで示されるパラメータ名で指定します。
PARAM_DYNAMICで示されるパラメータにtrueを指定した場合 アプリケーション実行時にもプロパティの変更を動的に反映させることが可能となりますが、 パラメータの取得時に毎回ファイル操作を行うためパフォーマンスに悪影響を与える可能性があります。 このオプションは、開発時やデバッグ時のようにパラメータを頻繁に変更する必要がある場合のみtrueとし、 通常はfalseに設定しておいてください。

導入されたバージョン:
5.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
static String | PARAM_APPLICATION アプリケーション
static String | PARAM_APPLICATION_CLASS クラス
static String | PARAM_APPLICATION_PARAM パラメータ
static String | PARAM_BUNDLE プロパティファイルのバンドルのパラメータ名
static String | PARAM_DEFAULT デフォルト
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
インタフェース jp.co.intra_mart.framework.base.service.ServicePropertyHandler から継承したフィールド
DEFAULT_APPLICATION_PARAMETER, DEFAULT_ENCODING_ATTRIBUTE, DEFAULT_EXCEPTION_ATTRIBUTE, DEFAULT_LOCALE_ATTRIBUTE, DEFAULT_SERVICE_PARAMETER, REQUEST_INFO_ATTRIBUTE
コンストラクタの概要
DistributesServicePropertyHandler()
DefaultServicePropertyHandlerを新規に生成します。
メソッドの概要
 String getApplicationParamName()
アプリケーションIDに該当するパラメータ名を取得します。
 String getClientEncoding()
クライアントのエンコードを取得します。
 Locale getClientLocale()
クライアントのエンコードを取得します。
 String getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 ControllerConverterConfig getControllerConverterConfig(String application, String service, Locale locale)
キーに該当するコントローラコンバータの初期パラメータを取得します。
 String getControllerConverterName(String application, String service, Locale locale)
コントローラコンバータのクラス名を取得します。
 String getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String getInputErrorPagePath()
推奨されていません。 このメソッドではなく getInputErrorPagePath(Locale)を使用してください。
 String getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, Locale) を使用してください。
 String getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, Locale) を使用してください。
 String getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, String, Locale) を使用してください。
 String getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 String getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなく getNextPagePath(String, String, Locale) を使用してください。
 String getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getNextPagePath(String, String, String, Locale) を使用してください。
 String getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなく getServiceControllerName(String, String, Locale) を使用してください。
 String getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String getServiceErrorPagePath()
推奨されていません。 このメソッドではなく getServiceErrorPagePath(Locale) を使用してください。
 String getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceParamName()
サービスIDに該当するパラメータ名を取得します。
 String getServiceServletPath()
サービスサーブレットのパスを取得します。
 String getSystemErrorPagePath()
推奨されていません。 このメソッドではなく getSystemErrorPagePath(Locale)を使用してください。
 String getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String getTransitionName(String application, String service)
推奨されていません。 このメソッドではなく getTransitionName(String, String, Locale) を使用してください。
 String getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 ValidatorMapping[] getValidators(String application, String service, Locale locale)
キーに該当するバリデータを取得します。
 void init(PropertyParam[] params)
プロパティハンドラを初期化します。
 boolean isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値

PARAM_DEFAULT

public static final String PARAM_DEFAULT
デフォルト

関連項目:
定数フィールド値

PARAM_APPLICATION

public static final String PARAM_APPLICATION
アプリケーション

関連項目:
定数フィールド値

PARAM_APPLICATION_PARAM

public static final String PARAM_APPLICATION_PARAM
パラメータ

関連項目:
定数フィールド値

PARAM_APPLICATION_CLASS

public static final String PARAM_APPLICATION_CLASS
クラス

関連項目:
定数フィールド値

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値

PARAM_BUNDLE

public static final String PARAM_BUNDLE
プロパティファイルのバンドルのパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DistributesServicePropertyHandler

public DistributesServicePropertyHandler()
DefaultServicePropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws ServicePropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース ServicePropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
ServicePropertyException - チェック時に例外が発生

getClientEncoding

public String getClientEncoding()
                         throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientEncoding
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getClientLocale

public Locale getClientLocale()
                       throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientLocale
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String, String)で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String)で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath() で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath() で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath()
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(Locale)を使用してください。

入力例外時のページのパスを取得します。 このメソッドは getInputErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなく getNextPagePath(String, String, Locale) を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。 このメソッドは getNextPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなく getNextPagePath(String, String, String, Locale) を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。 key が null の場合、 getNextPagePath(String, String) と同じ動作になります。 このメソッドは getNextPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。 key が null の場合、 getNextPagePath(String, String) と同じ動作になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service)
                                throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceControllerName(String, String, Locale) を使用してください。

サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。 このメソッドは getServiceControllerName(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service,
                                       Locale locale)
                                throws ServicePropertyException
サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, String, Locale) を使用してください。

処理例外時のページのパスを取得します。 このメソッドは getServiceErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, Locale) を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath(String)で取得されるページを返します。 このメソッドは getServiceErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, Locale) を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath()で取得されるページを返します。 このメソッドは getServiceErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath()
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(Locale) を使用してください。

処理例外時のページのパスを取得します。 このメソッドは getServiceErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String, String)で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String)で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath()で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath()
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(Locale)を使用してください。

システム例外時のページのパスを取得します。 このメソッドは getSystemErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service)
                         throws ServicePropertyException
推奨されていません。 このメソッドではなく getTransitionName(String, String, Locale) を使用してください。

トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。 このメソッドは getTransitionName(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException
トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getServiceServletPath

public String getServiceServletPath()
                             throws ServicePropertyException
サービスサーブレットのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceServletPath
戻り値:
サービスサーブレットのパス
例外:
ServicePropertyException - サービスサーブレットのパスの取得時に例外が発生

getContextPath

public String getContextPath()
                      throws ServicePropertyException
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。

コンテキストパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getContextPath
戻り値:
コンテキストパス
例外:
ServicePropertyException - コンテキストパスの取得時に例外が発生

getApplicationParamName

public String getApplicationParamName()
                               throws ServicePropertyException
アプリケーションIDに該当するパラメータ名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_APPLICATION_PARAMETER で定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getApplicationParamName
戻り値:
アプリケーションIDに該当するパラメータ名
例外:
ServicePropertyException - アプリケーションIDに該当するパラメータ名の取得時に例外が発生

getServiceParamName

public String getServiceParamName()
                           throws ServicePropertyException
サービスIDに該当するパラメータ名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_SERVICE_PARAMETERで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceParamName
戻り値:
サービスIDに該当するパラメータ名
例外:
ServicePropertyException - サービスIDに該当するパラメータ名の取得時に例外が発生

getExceptionAttributeName

public String getExceptionAttributeName()
                                 throws ServicePropertyException
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_EXCEPTION_ATTRIBUTE で定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getExceptionAttributeName
戻り値:
例外の属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getEncodingAttributeName

public String getEncodingAttributeName()
                                throws ServicePropertyException
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_ENCODING_ATTRIBUTEで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getEncodingAttributeName
戻り値:
エンコードの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getLocaleAttributeName

public String getLocaleAttributeName()
                              throws ServicePropertyException
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_LOCALE_ATTRIBUTEで定義されている値を返します 。

定義:
インタフェース ServicePropertyHandler 内の getLocaleAttributeName
戻り値:
ロケールの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getControllerConverterName

public String getControllerConverterName(String application,
                                         String service,
                                         Locale locale)
                                  throws ServicePropertyException
インタフェース ServicePropertyHandler の記述:
コントローラコンバータのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するコントローラコンバータ名を取得します。 特に設定されていない場合、nullが返ります。

定義:
インタフェース ServicePropertyHandler 内の getControllerConverterName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - コントローラコンバータのクラス名の取得時に例外が発生

getControllerConverterConfig

public ControllerConverterConfig getControllerConverterConfig(String application,
                                                              String service,
                                                              Locale locale)
                                                       throws ServicePropertyException
インタフェース ServicePropertyHandler の記述:
キーに該当するコントローラコンバータの初期パラメータを取得します。

定義:
インタフェース ServicePropertyHandler 内の getControllerConverterConfig
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータの初期パラメータ
例外:
ServicePropertyException - コントローラコンバータの初期パラメータの取得に失敗

getValidators

public ValidatorMapping[] getValidators(String application,
                                        String service,
                                        Locale locale)
                                 throws ServicePropertyException
インタフェース ServicePropertyHandler の記述:
キーに該当するバリデータを取得します。

定義:
インタフェース ServicePropertyHandler 内の getValidators
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータの初期パラメータ
例外:
ServicePropertyException - バリデータの取得に失敗
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart 6.1.14
 前のクラス   次のクラス フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド 詳細:  フィールド | コンストラクタ | メソッド


EmptyServiceResult (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス EmptyServiceResult

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.EmptyServiceResult
すべての実装インタフェース:
ServiceResult
public class EmptyServiceResult
extends Object
implements ServiceResult

情報を何も持たないServiceResultの実装です。

導入されたバージョン:
6.0
バージョン:
1.0

コンストラクタの概要
EmptyServiceResult()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EmptyServiceResult

public EmptyServiceResult()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EncodingFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス EncodingFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.EncodingFilter
すべての実装インタフェース:
Filter
public class EncodingFilter
extends Object
implements Filter

リクエストのエンコードを設定します。 リクエストに対するエンコードは

  1. ServicePropertyHandler.getClientEncoding()で取得されるもの
  2. ServiceManager.getLocale(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)
の順位で決定されます。

この時に取得されたエンコードはServletRequest.setCharacterEncoding(java.lang.String)に設定され、 さらにHttpSessionが存在すればその中にも設定されます。この場合の属性名はServicePropertyHandler.getEncodingAttributeName()で取得されるものです。

バージョン:
1.0

コンストラクタの概要
EncodingFilter()
メソッドの概要
void | destroy() フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) リクエストのエンコードを設定します。
void | init(FilterConfig filterConfig) エンコーディング用のフィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EncodingFilter

public EncodingFilter()
メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
エンコーディング用のフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
リクエストのエンコードを設定します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FileUploadFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス FileUploadFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.FileUploadFilter
すべての実装インタフェース:
Filter
public class FileUploadFilter
extends Object
implements Filter

ファイルアップロード用にリクエストを変換するフィルタです。 このフィルタは受け取ったリクエストが以下の条件をすべて満たす場合にServiceControllerAdapter.getEntity(String)でアップロードされた内容が取得できるようにします。

  • メソッドが"POST"である
  • ContentTypeが"multipart/form-data"である

    導入されたバージョン:
    3.2

    コンストラクタの概要
    FileUploadFilter()
    メソッドの概要
     void destroy()
    フィルタを破棄します。
     void doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain)
    リクエストの内容がファイルアップロードを含むかどうかによってリクエストを選択します。
     void init(FilterConfig filterConfig)
    ファイルアップロード用のフィルタを初期化します。
    クラス java.lang.Object から継承したメソッド
    clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    コンストラクタの詳細

    FileUploadFilter

    public FileUploadFilter()
    メソッドの詳細

    init

    public void init(FilterConfig filterConfig)
          throws ServletException
    ファイルアップロード用のフィルタを初期化します。

    定義:
    インタフェース Filter 内の init
    パラメータ:
    filterConfig - FilterConfig
    例外:
    ServletException - フィルタ内で例外が発生

    doFilter

    public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
    リクエストの内容がファイルアップロードを含むかどうかによってリクエストを選択します。

    定義:
    インタフェース Filter 内の doFilter
    パラメータ:
    servletRequest - リクエスト
    servletResponse - レスポンス
    filterChain - フィルタ
    例外:
    IOException - フィルタ処理実行時にIOExceptionが発生
    ServletException - フィルタ処理実行時にServletExceptionが発生

    destroy

    public void destroy()
    フィルタを破棄します。

    定義:
    インタフェース Filter 内の destroy
    概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
            intra-mart 6.1.14
    前のクラス 次のクラス フレームあり フレームなし
    概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FrameworkParameterSettingFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス FrameworkParameterSettingFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter
すべての実装インタフェース:
Filter
推奨されていません。 このフィルタは下位互換のためのフィルタです。将来廃止される可能性があります。

public class FrameworkParameterSettingFilter
extends Object
implements Filter

以前のバージョンのサービスフレームワークが使用していたアプリケーションID及びサービスIDを リクエストのパラメータに設定します。
このフィルタを使用することによりServletRequest.getParameter(String)から アプリケーションID及びサービスIDを取得することができますが、この方法は正しくありません。
正しくは以下のメソッドを使用してください。

ServiceManager.getApplication(HttpServletRequest, HttpServletResponse)
ServiceManager.getService(HttpServletRequest, HttpServletResponse)

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
FrameworkParameterSettingFilter()
推奨されていません。
メソッドの概要
void | destroy() 推奨されていません。 フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) 推奨されていません。 リクエストのパラメーターを設定後、次の処理に遷移します。
void | init(FilterConfig filterConfig) 推奨されていません。 フィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FrameworkParameterSettingFilter

public FrameworkParameterSettingFilter()
推奨されていません。
メソッドの詳細

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws ServletException,
                     IOException
推奨されていません。
リクエストのパラメーターを設定後、次の処理に遷移します。
パラメータ名は以下のメソッドから取得したものを使用します。
ServicePropertyHandler.getApplicationParamName()
ServicePropertyHandler.getServiceParamName()

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタのチェーン
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

init

public void init(FilterConfig filterConfig)
          throws ServletException
推奨されていません。
フィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - フィルタ設定オブジェクト
例外:
ServletException - フィルタを初期化時に例外が発生。

destroy

public void destroy()
推奨されていません。
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartConnectFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス IntramartConnectFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.IntramartConnectFilter
すべての実装インタフェース:
Filter
推奨されていません。 この機能は廃止されました。

public class IntramartConnectFilter
extends Object
implements Filter

intra-martのページベースの画面からim-J2EE Frameworkの画面に遷移する時に使うフィルタです。 intra-martから来るリクエストをim-J2EE Frameworkで扱う形式に変換します。 このフィルタで変換されたリクエストはServiceServletで扱えるようになります。

このフィルタは以下の初期化パラメータを設定することができます。

パラメータ名 | パラメータの値
referrerFormat | セッションに登録されるintramartのページベースへの画面に戻るためのURLの書式を決定します。 short（大文字と小文字は区別しない）：URLからプロトコル、ホスト名、ポート番号が省略された形式をセッションに登録 それ以外：パラメータreferrerの内容をそのままセッションに登録
securityExt | セキュリティの有効／無効を設定する拡張子です。 このパラメータが設定されるとセキュリティが有効になります。 ServiceServletに対するURLマッピングは*.拡張子とする必要があります。 拡張子（ドットは含まない）

導入されたバージョン:
4.2

フィールドの概要
static String | INTRAMART_URL_NAME 推奨されていません。 セッションに登録するintra-martのサーブレットのURLの属性名
static String | PARAM_ARGUMENT 推奨されていません。 ページ引数のリクエストパラメータ名
static String | PARAM_ARGUMENT_DELIMITER 推奨されていません。 ページ引数のデリミタ
static String | PARAM_ARGUMENT_OPERATOR 推奨されていません。 ページ引数の演算子
static String | PARAM_LOGIN_GROUP_ID 推奨されていません。 ログイングループIDのリクエストパラメータ名
static String | PARAM_LOGIN_USER_ID 推奨されていません。 ログインユーザIDのリクエストパラメータ名
static String | PARAM_REFERER 推奨されていません。 参照元URLのリクエストパラメータ名
static String | PARAM_SECURITY_EXT 推奨されていません。 セキュリティの拡張子
コンストラクタの概要
IntramartConnectFilter()
推奨されていません。
メソッドの概要
void | destroy() 推奨されていません。 フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) 推奨されていません。 intra-martから来るリクエストをim-J2EE Frameworkで扱う形式に変換します。
String | getSecurityExt() 推奨されていません。 セキュリティの拡張子を取得します。
void | init(FilterConfig filterConfig) 推奨されていません。 このフィルタを初期化します。
void | setSecurityExt(String securityExt) 推奨されていません。 セキュリティの拡張子を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_LOGIN_USER_ID

public static final String PARAM_LOGIN_USER_ID
推奨されていません。
ログインユーザIDのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_LOGIN_GROUP_ID

public static final String PARAM_LOGIN_GROUP_ID
推奨されていません。
ログイングループIDのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_ARGUMENT

public static final String PARAM_ARGUMENT
推奨されていません。
ページ引数のリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_REFERER

public static final String PARAM_REFERER
推奨されていません。
参照元URLのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_ARGUMENT_DELIMITER

public static final String PARAM_ARGUMENT_DELIMITER
推奨されていません。
ページ引数のデリミタ

関連項目:
定数フィールド値

PARAM_ARGUMENT_OPERATOR

public static final String PARAM_ARGUMENT_OPERATOR
推奨されていません。
ページ引数の演算子

関連項目:
定数フィールド値

INTRAMART_URL_NAME

public static final String INTRAMART_URL_NAME
推奨されていません。
セッションに登録するintra-martのサーブレットのURLの属性名

関連項目:
定数フィールド値

PARAM_SECURITY_EXT

public static final String PARAM_SECURITY_EXT
推奨されていません。
セキュリティの拡張子

導入されたバージョン:
4.3
関連項目:
定数フィールド値
コンストラクタの詳細

IntramartConnectFilter

public IntramartConnectFilter()
推奨されていません。
メソッドの詳細

getSecurityExt

public String getSecurityExt()
推奨されていません。
セキュリティの拡張子を取得します。

戻り値:
セキュリティの拡張子

setSecurityExt

public void setSecurityExt(String securityExt)
推奨されていません。
セキュリティの拡張子を設定します。

パラメータ:
securityExt - セキュリティの拡張子

init

public void init(FilterConfig filterConfig)
          throws ServletException
推奨されていません。
このフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
推奨されていません。
intra-martから来るリクエストをim-J2EE Frameworkで扱う形式に変換します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタチェイン
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
推奨されていません。
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartConnectServlet (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス IntramartConnectServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.framework.base.service.IntramartConnectServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
推奨されていません。 この機能は廃止されました。

public class IntramartConnectServlet
extends HttpServlet

intra-martのページベースの画面からJ2EEベースの画面に遷移する時に使うサーブレットです。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
static String | INTRAMART_URL_NAME 推奨されていません。 このパラメータではなくIntramartConnectFilter.INTRAMART_URL_NAMEを使用してください。
static String | PARAM_ARGUMENT 推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENTを使用してください。
static String | PARAM_ARGUMENT_DELIMITER 推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_DELIMITERを使用してください。
static String | PARAM_ARGUMENT_OPERATOR 推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_OPERATORを使用してください。
static String | PARAM_LOGIN_GROUP_ID 推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_GROUP_IDを使用してください。
static String | PARAM_LOGIN_USER_ID 推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_USER_IDを使用してください。
static String | PARAM_REFERER 推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_REFERERを使用してください。
コンストラクタの概要
IntramartConnectServlet()
推奨されていません。 IntramartConnectServletを新規に生成します。
メソッドの概要
protected void | doGet(HttpServletRequest request, HttpServletResponse response) 推奨されていません。 GETメソッドに対応します。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) 推奨されていません。 POSTメソッドに対応します。
protected void | execute(HttpServletRequest request, HttpServletResponse response) 推奨されていません。 intra-martベースモジュールのメニューからのリクエストを受け付けます。
protected ServiceManager | getServiceManager() 推奨されていません。 サービスマネージャを取得します。
protected ServicePropertyHandler | getServicePropertyHandler() 推奨されていません。 サービスプロパティハンドラを取得します。
protected SessionManager | getSessionManager() 推奨されていません。 セッションマネージャを取得します。
protected SessionPropertyHandler | getSessionPropertyHandler() 推奨されていません。 セッションプロパティハンドラを取得します。
void | init(ServletConfig servletConfig) 推奨されていません。 このサーブレットを初期化します。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
destroy, getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_LOGIN_USER_ID

public static final String PARAM_LOGIN_USER_ID
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_USER_IDを使用してください。

ログインユーザIDのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_LOGIN_GROUP_ID

public static final String PARAM_LOGIN_GROUP_ID
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_GROUP_IDを使用してください。

ログイングループIDのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_ARGUMENT

public static final String PARAM_ARGUMENT
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENTを使用してください。

ページ引数のリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_REFERER

public static final String PARAM_REFERER
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_REFERERを使用してください。

参照元URLのリクエストパラメータ名

導入されたバージョン:
3.2
関連項目:
定数フィールド値

PARAM_ARGUMENT_DELIMITER

public static final String PARAM_ARGUMENT_DELIMITER
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_DELIMITERを使用してください。

ページ引数のデリミタ

関連項目:
定数フィールド値

PARAM_ARGUMENT_OPERATOR

public static final String PARAM_ARGUMENT_OPERATOR
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_OPERATORを使用してください。

ページ引数の演算子

関連項目:
定数フィールド値

INTRAMART_URL_NAME

public static final String INTRAMART_URL_NAME
推奨されていません。 このパラメータではなくIntramartConnectFilter.INTRAMART_URL_NAMEを使用してください。

セッションに登録するintra-martのサーブレットのURLの属性名 （この値はVersion 4.0から変更されています）

導入されたバージョン:
3.2
関連項目:
定数フィールド値
コンストラクタの詳細

IntramartConnectServlet

public IntramartConnectServlet()
推奨されていません。
IntramartConnectServletを新規に生成します。

メソッドの詳細

getServiceManager

protected ServiceManager getServiceManager()
推奨されていません。
サービスマネージャを取得します。

戻り値:
サービスマネージャ

getServicePropertyHandler

protected ServicePropertyHandler getServicePropertyHandler()
推奨されていません。
サービスプロパティハンドラを取得します。

戻り値:
サービスプロパティハンドラ

getSessionManager

protected SessionManager getSessionManager()
推奨されていません。
セッションマネージャを取得します。

戻り値:
セッションマネージャ

getSessionPropertyHandler

protected SessionPropertyHandler getSessionPropertyHandler()
推奨されていません。
セッションプロパティハンドラを取得します。

戻り値:
セッションプロパティハンドラ

init

public void init(ServletConfig servletConfig)
          throws ServletException
推奨されていません。
このサーブレットを初期化します。

パラメータ:
servletConfig - Servlet Config
例外:
ServletException - 初期化時に例外が発生

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
推奨されていません。
GETメソッドに対応します。 詳細はexecute(HttpServletRequest, HttpServletResponse)を参照してください。

パラメータ:
request - リクエスト
response - レスポンス
例外:
ServletException - サーブレット例外が発生
IOException - 入出力例外が発生

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
推奨されていません。
POSTメソッドに対応します。 詳細はexecute(HttpServletRequest, HttpServletResponse)を参照してください。

パラメータ:
request - リクエスト
response - レスポンス
例外:
ServletException - サーブレット例外が発生
IOException - 入出力例外が発生

execute

protected void execute(HttpServletRequest request,
                       HttpServletResponse response)
                throws ServletException,
                       IOException
推奨されていません。
intra-martベースモジュールのメニューからのリクエストを受け付けます。 ページ引数に以下の情報を含める必要があります。
application=<アプリケーションＩＤ>,service=<サービスＩＤ>

パラメータ:
request - リクエスト
response - レスポンス
例外:
ServletException - サーブレット例外が発生
IOException - 入出力例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartLocaleFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス IntramartLocaleFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.IntramartLocaleFilter
すべての実装インタフェース:
Filter
public class IntramartLocaleFilter
extends Object
implements Filter

セッションにロケールを設定します。
ロケールはクライアントの保持するアクセスセキュリティ情報が優先されます。

アクセスセキュリティ情報からロケールを取得できない場合はServiceManager.getLocale(HttpServletRequest, HttpServletResponse) から取得した値が設定されます。

この時に取得されたロケールはHttpSessionが存在すればその中に設定されます。この場合の属性名はServicePropertyHandler.getLocaleAttributeName()で取得されるものです。

導入されたバージョン:
5.0

コンストラクタの概要
IntramartLocaleFilter()
メソッドの概要
void | destroy() フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) リクエストのロケールを設定します。
void | init(FilterConfig filterConfig) ロケール用のフィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartLocaleFilter

public IntramartLocaleFilter()
メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
ロケール用のフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
リクエストのロケールを設定します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartPageBaseTransition (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス IntramartPageBaseTransition

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.Transition
        拡張 jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition
public class IntramartPageBaseTransition
extends Transition

ページベースの画面に遷移する場合に使用するトランジションです。

導入されたバージョン:
3.2

コンストラクタの概要
IntramartPageBaseTransition()
IntramartPageBaseTransitionを新規に生成します。
メソッドの概要
String | getInputErrorPage(RequestException e) 入力エラーのページを取得します。
String | getNextPage() 次に遷移するページを取得します。
String | getServiceErrorPage(Exception e) 処理エラーのページを取得します。
String | getSystemErrorPage(Exception e) システムエラーのページを取得します。
void | setInformation() 次の遷移先に渡す情報を設定します。
void | transfer() ページベースの画面に遷移します。
クラス jp.co.intra_mart.framework.base.service.Transition から継承したメソッド
getApplication, getEntity, getNextPagePath, getNextPagePath, getRequest, getResponse, getResult, getService, getServiceManager, getSessionObject, setRequest, setResponse, setResult, setServiceManager
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartPageBaseTransition

public IntramartPageBaseTransition()
IntramartPageBaseTransitionを新規に生成します。

メソッドの詳細

getInputErrorPage

public String getInputErrorPage(RequestException e)
                         throws ServicePropertyException,
                                TransitionException
入力エラーのページを取得します。

定義:
クラス Transition 内の getInputErrorPage
パラメータ:
e - 入力時の例外
戻り値:
入力エラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getServiceErrorPage

public String getServiceErrorPage(Exception e)
                           throws ServicePropertyException,
                                  TransitionException
処理エラーのページを取得します。

定義:
クラス Transition 内の getServiceErrorPage
パラメータ:
e - 処理時の例外
戻り値:
処理エラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getSystemErrorPage

public String getSystemErrorPage(Exception e)
                          throws ServicePropertyException,
                                 TransitionException
システムエラーのページを取得します。

定義:
クラス Transition 内の getSystemErrorPage
パラメータ:
e - 処理時の例外
戻り値:
システムエラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getNextPage

public String getNextPage()
                   throws ServicePropertyException,
                          TransitionException
次に遷移するページを取得します。

定義:
クラス Transition 内の getNextPage
戻り値:
次に遷移するページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

setInformation

public void setInformation()
                    throws TransitionException
次の遷移先に渡す情報を設定します。

定義:
クラス Transition 内の setInformation
例外:
TransitionException - 情報設定時に例外が発生

transfer

public void transfer()
              throws SystemException
ページベースの画面に遷移します。 遷移する方法は次のページで要求される形式に依存します。

定義:
クラス Transition 内の transfer
例外:
SystemException - システム例外が発生
導入されたバージョン:
3.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LocaleFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス LocaleFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.LocaleFilter
すべての実装インタフェース:
Filter
public class LocaleFilter
extends Object
implements Filter

リクエストのロケールを設定します。 リクエストに対するロケールの決定方法はServiceManager.getLocale(HttpServletRequest, HttpServletResponse)と同じです。

この時に取得されたロケールはHttpSessionが存在すればその中に設定されます。この場合の属性名はServicePropertyHandler.getLocaleAttributeName()で取得されるものです。

導入されたバージョン:
4.2

コンストラクタの概要
LocaleFilter()
メソッドの概要
void | destroy() フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) リクエストのロケールを設定します。
void | init(FilterConfig filterConfig) ロケール用のフィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LocaleFilter

public LocaleFilter()
メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
ロケール用のフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
リクエストのロケールを設定します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.service (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.base.service
インタフェース
RequestInfo
ServiceController
ServicePropertyHandler
ServiceResult
クラス
ControllerConverterModel
DefaultServicePropertyHandler
DefaultTransition
DistributesServicePropertyHandler
EmptyServiceResult
EncodingFilter
FileUploadFilter
FrameworkParameterSettingFilter
IntramartConnectFilter
IntramartConnectServlet
IntramartLocaleFilter
IntramartPageBaseTransition
LocaleFilter
ServiceControllerAdapter
ServiceManager
ServiceSecurityFilter
ServiceServlet
TextFileServicePropertyHandler
Transition
ValidatorMapping
ValidatorModel
XmlServicePropertyHandler
例外
RequestException
ServiceControllerException
ServiceManagerException
ServicePropertyException
ServiceServletException
TransitionException


jp.co.intra_mart.framework.base.service (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.service

サービスフレームワークに関連するクラスのパッケージです。

参照:
説明

インタフェースの概要
RequestInfo | リクエストに対する情報を取得します。
ServiceController | クライアントからの入力に対する処理を行います。
ServicePropertyHandler | サービスの設定情報に接続するクラスです。
ServiceResult | サービスの処理結果です。

クラスの概要
ControllerConverterModel | コントローラコンバータ情報を管理するクラスです。
DefaultServicePropertyHandler | サービスの設定情報に接続するデフォルトのプロパティハンドラです。
DefaultTransition | デフォルトの画面遷移をします。
DistributesServicePropertyHandler | アプリケーションごとに異なるサービスプロパティハンドラを使用するサービスプロパティハンドラです。
EmptyServiceResult | 情報を何も持たないServiceResultの実装です。
EncodingFilter | リクエストのエンコードを設定します。
FileUploadFilter | ファイルアップロード用にリクエストを変換するフィルタです。
FrameworkParameterSettingFilter | 推奨されていません。 このフィルタは下位互換のためのフィルタです。
IntramartConnectFilter | 推奨されていません。 この機能は廃止されました。
IntramartConnectServlet | 推奨されていません。 この機能は廃止されました。
IntramartLocaleFilter | セッションにロケールを設定します。
IntramartPageBaseTransition | ページベースの画面に遷移する場合に使用するトランジションです。
LocaleFilter | リクエストのロケールを設定します。
ServiceControllerAdapter | いくつかのユーティリティメソッドと空のメソッドを実装したサービスコントローラです。
ServiceManager | サービスマネージャです。
ServiceSecurityFilter | intra-mart画面を表示するURLの詐称をチェックするためのフィルタです。
ServiceServlet | サービスを振り分けるサーブレットです。
TextFileServicePropertyHandler | 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
Transition | 画面遷移に関連するクラスのインタフェースです。
ValidatorMapping | バリデータの設定を保持します。
ValidatorModel | バリデータ情報を管理するクラスです。
XmlServicePropertyHandler | サービスの設定情報に接続するプロパティハンドラです。

例外の概要
RequestException | リクエストの内容に関連する間違いがある場合の例外です。
ServiceControllerException | サービスコントローラに関連する例外です。
ServiceManagerException | サービスマネージャ設定時の例外です。
ServicePropertyException | サービスプロパティ取得時の例外です。
ServiceServletException | サービスに関連する例外です。
TransitionException | トランジションに関連する例外です。

パッケージ jp.co.intra_mart.framework.base.service の説明

サービスフレームワークに関連するクラスのパッケージです。 画面からのアクション（Submit、リンク等）に対して処理や画面遷移の制御をします。


jp.co.intra_mart.framework.base.service クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.service の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.service.ControllerConverterModel
    • class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class jp.co.intra_mart.framework.base.service.EmptyServiceResult (implements jp.co.intra_mart.framework.base.service.ServiceResult)
    • class jp.co.intra_mart.framework.base.service.EncodingFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.service.FileUploadFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter (implements javax.servlet.Filter)
    • class javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • class javax.servlet.http.HttpServlet (implements java.io.Serializable)
        • class jp.co.intra_mart.framework.base.service.IntramartConnectServlet
        • class jp.co.intra_mart.framework.base.service.ServiceServlet
    • class jp.co.intra_mart.framework.base.service.IntramartConnectFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.service.LocaleFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter (implements jp.co.intra_mart.framework.base.service.ServiceController)
    • class jp.co.intra_mart.framework.base.service.ServiceManager
    • class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.ApplicationException
            • class jp.co.intra_mart.framework.base.service.RequestException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.service.ServiceControllerException
            • class jp.co.intra_mart.framework.base.service.ServiceManagerException
            • class jp.co.intra_mart.framework.base.service.ServicePropertyException
            • class jp.co.intra_mart.framework.base.service.ServiceServletException
            • class jp.co.intra_mart.framework.base.service.TransitionException
    • class jp.co.intra_mart.framework.base.service.Transition
      • class jp.co.intra_mart.framework.base.service.DefaultTransition
      • class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition
    • class jp.co.intra_mart.framework.base.service.ValidatorMapping
    • class jp.co.intra_mart.framework.base.service.ValidatorModel
    • class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)

インタフェース階層

  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler
  • interface jp.co.intra_mart.framework.base.service.RequestInfo
  • interface jp.co.intra_mart.framework.base.service.ServiceController
  • interface jp.co.intra_mart.framework.base.service.ServiceResult


パッケージ jp.co.intra_mart.framework.base.service の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.service の使用

jp.co.intra_mart.framework.base.service を使用しているパッケージ
jp.co.intra_mart.extension.maskat.service |
jp.co.intra_mart.extension.maskat.service.controller |
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.container |
jp.co.intra_mart.framework.base.service.controller |
jp.co.intra_mart.framework.base.service.validator |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.seasar.service |

jp.co.intra_mart.extension.maskat.service により使用される jp.co.intra_mart.framework.base.service のクラス
DefaultTransition
デフォルトの画面遷移をします。
ServiceResult
サービスの処理結果です。
Transition
画面遷移に関連するクラスのインタフェースです。

jp.co.intra_mart.extension.maskat.service.controller により使用される jp.co.intra_mart.framework.base.service のクラス
RequestInfo
リクエストに対する情報を取得します。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.base.service のクラス
RequestException
リクエストの内容に関連する間違いがある場合の例外です。
RequestInfo
リクエストに対する情報を取得します。
ServiceController
クライアントからの入力に対する処理を行います。
ServiceControllerException
サービスコントローラに関連する例外です。
ServiceManager
サービスマネージャです。
ServiceManagerException
サービスマネージャ設定時の例外です。
ServicePropertyException
サービスプロパティ取得時の例外です。
ServicePropertyHandler
サービスの設定情報に接続するクラスです。
ServiceResult
サービスの処理結果です。
Transition
画面遷移に関連するクラスのインタフェースです。
TransitionException
トランジションに関連する例外です。
ValidatorMapping
バリデータの設定を保持します。

jp.co.intra_mart.framework.base.service.container により使用される jp.co.intra_mart.framework.base.service のクラス
ServiceController
クライアントからの入力に対する処理を行います。
ServiceControllerException
サービスコントローラに関連する例外です。
ServicePropertyException
サービスプロパティ取得時の例外です。
ServicePropertyHandler
サービスの設定情報に接続するクラスです。
Transition
画面遷移に関連するクラスのインタフェースです。
TransitionException
トランジションに関連する例外です。

jp.co.intra_mart.framework.base.service.controller により使用される jp.co.intra_mart.framework.base.service のクラス
RequestInfo
リクエストに対する情報を取得します。

jp.co.intra_mart.framework.base.service.validator により使用される jp.co.intra_mart.framework.base.service のクラス
RequestException
リクエストの内容に関連する間違いがある場合の例外です。
RequestInfo
リクエストに対する情報を取得します。

jp.co.intra_mart.framework.base.web.bean により使用される jp.co.intra_mart.framework.base.service のクラス
ServicePropertyHandler
サービスの設定情報に接続するクラスです。

jp.co.intra_mart.framework.extension.seasar.service により使用される jp.co.intra_mart.framework.base.service のクラス
ServiceController
クライアントからの入力に対する処理を行います。
ServiceControllerException
サービスコントローラに関連する例外です。
ServicePropertyException
サービスプロパティ取得時の例外です。
ServicePropertyHandler
サービスの設定情報に接続するクラスです。
Transition
画面遷移に関連するクラスのインタフェースです。
TransitionException
トランジションに関連する例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


RequestException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス RequestException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.ApplicationException
                    拡張 jp.co.intra_mart.framework.base.service.RequestException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ValidationException
public class RequestException
extends ApplicationException

リクエストの内容に関連する間違いがある場合の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
RequestException()
詳細メッセージを指定しないで RequestException を構築します。
RequestException(String msg)
指定された詳細メッセージを持つ RequestException を構築します。
RequestException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

RequestException

public RequestException()
詳細メッセージを指定しないで RequestException を構築します。

RequestException

public RequestException(String msg)
指定された詳細メッセージを持つ RequestException を構築します。

パラメータ:
msg - 詳細メッセージ

RequestException

public RequestException(String msg,
                        Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


RequestInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
インタフェース RequestInfo

public interface RequestInfo

リクエストに対する情報を取得します。

導入されたバージョン:
6.1

メソッドの概要
ControllerObject | getControllerObject() リクエストから生成されたコントローラオブジェクトを取得します。
HttpServletRequest | getRequest() リクエストを取得します。
HttpServletResponse | getResponse() レスポンスを取得します。
ServiceResult | getResult() サービス処理結果を取得します。
Throwable | getThrowable() 処理中に発生した例外を取得します。

メソッドの詳細

getRequest

public HttpServletRequest getRequest()
リクエストを取得します。

戻り値:
リクエスト

getResponse

public HttpServletResponse getResponse()
レスポンスを取得します。

戻り値:
レスポンス

getControllerObject

public ControllerObject getControllerObject()
リクエストから生成されたコントローラオブジェクトを取得します。 このメソッドはコントローラオブジェクトが生成されていないとき、 またはControllerConverterが指定されていないときはnullが戻ります。

戻り値:
リクエストから生成されたコントローラオブジェクト（コントローラオブジェクトが生成されていない、またはControllerConverterが指定されていないときはnull）

getResult

public ServiceResult getResult()
サービス処理結果を取得します。 このメソッドはサービス処理結果が生成されていないとき、 またはServiceControllerが指定されていないときはnullが戻ります。

戻り値:
サービス処理結果（サービス処理結果が生成されていない、またはServiceControllerが指定されていないときはnull）

getThrowable

public Throwable getThrowable()
処理中に発生した例外を取得します。

戻り値:
処理中に発生した例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ServiceController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
インタフェース ServiceController

既知の実装クラスの一覧:
ServiceControllerAdapter
public interface ServiceController

クライアントからの入力に対する処理を行います。

バージョン:
1.0

メソッドの概要
void | check() 入力内容をチェックします。
ControllerObject | getControllerObject() コントローラオブジェクトを取得します。
HttpServletRequest | getRequest() リクエストを取得します。
HttpServletResponse | getResponse() レスポンスを取得します。
ServiceResult | service() 入力に対する処理を実行します。
void | setControllerObject(ControllerObject controllerObject) コントローラオブジェクトを設定します。
void | setRequest(HttpServletRequest request) リクエストを設定します。
void | setResponse(HttpServletResponse response) レスポンスを設定します。

メソッドの詳細

setRequest

public void setRequest(HttpServletRequest request)
リクエストを設定します。

パラメータ:
request - リクエスト

getRequest

public HttpServletRequest getRequest()
リクエストを取得します。

戻り値:
リクエスト

setResponse

public void setResponse(HttpServletResponse response)
レスポンスを設定します。

パラメータ:
response - レスポンス

getResponse

public HttpServletResponse getResponse()
レスポンスを取得します。

戻り値:
レスポンス

check

public void check()
           throws RequestException,
                  SystemException
入力内容をチェックします。

例外:
RequestException - 入力内容に誤りがある
SystemException - チェック時にシステム例外が発生

service

public ServiceResult service()
                      throws SystemException,
                             ApplicationException
入力に対する処理を実行します。

戻り値:
処理結果
例外:
SystemException - 処理実行時にシステム例外が発生
ApplicationException - 処理実行時にアプリケーション例外が発生

setControllerObject

public void setControllerObject(ControllerObject controllerObject)
コントローラオブジェクトを設定します。

パラメータ:
controllerObject - コントローラオブジェクト
導入されたバージョン:
6.1

getControllerObject

public ControllerObject getControllerObject()
コントローラオブジェクトを取得します。

戻り値:
コントローラオブジェクト
導入されたバージョン:
6.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServiceControllerAdapter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceControllerAdapter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.ServiceControllerAdapter
すべての実装インタフェース:
ServiceController
public class ServiceControllerAdapter
extends Object
implements ServiceController

いくつかのユーティリティメソッドと空のメソッドを実装したサービスコントローラです。 このクラスにはいくつかのユーティリティメソッドがあります。 このクラスを継承し、必要に応じてcheck()やservice()を実装することでコーディング量を減らすことが可能です。

バージョン:
1.0

コンストラクタの概要
ServiceControllerAdapter()
ServiceControllerAdapterを新規に生成します。
メソッドの概要
void | check() 入力内容をチェックします。
protected Event | createEvent(String application, String key) アプリケーションIDとキーに対応するイベントを取得します。
protected EventResult | dispatchEvent(Event event) イベント処理を実行します。
ControllerObject | getControllerObject() コントローラオブジェクトを取得します。
MultipartFormData.Entity | getEntity(String name) リクエストから指定された名前に該当するエンティティを取得します。
String | getLoginGroupID() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
String | getLoginUserID() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
HttpServletRequest | getRequest() リクエストを取得します。
HttpServletResponse | getResponse() レスポンスを取得します。
UserInfo | getUserInfo() ユーザ情報を取得します。
ServiceResult | service() 入力に対する処理を実行します。
void | setControllerObject(ControllerObject controllerObject) コントローラオブジェクトを設定します。
void | setRequest(HttpServletRequest request) リクエストを設定します。
void | setResponse(HttpServletResponse response) レスポンスを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ServiceControllerAdapter

public ServiceControllerAdapter()
ServiceControllerAdapterを新規に生成します。

メソッドの詳細

setRequest

public void setRequest(HttpServletRequest request)
リクエストを設定します。

定義:
インタフェース ServiceController 内の setRequest
パラメータ:
request - リクエスト

getRequest

public HttpServletRequest getRequest()
リクエストを取得します。

定義:
インタフェース ServiceController 内の getRequest
戻り値:
リクエスト

setResponse

public void setResponse(HttpServletResponse response)
レスポンスを設定します。

定義:
インタフェース ServiceController 内の setResponse
パラメータ:
response - レスポンス

getResponse

public HttpServletResponse getResponse()
レスポンスを取得します。

定義:
インタフェース ServiceController 内の getResponse
戻り値:
レスポンス

getEntity

public MultipartFormData.Entity getEntity(String name)
                                   throws SystemException
リクエストから指定された名前に該当するエンティティを取得します。 このメソッドは、ファイルアップロード時にその内容を取得する場合などに使用します。 このメソッドは、ファイルアップロードのリクエストが送られた場合のみ使用できます。 それ以外のリクエストが送られた場合にこのメソッドを呼ぶと例外が発生します。

パラメータ:
name - パラメータ名
戻り値:
パラメータ名に該当するエンティティ
例外:
SystemException - エンティティの取得に失敗
導入されたバージョン:
3.2

check

public void check()
           throws RequestException,
                  SystemException
入力内容をチェックします。

定義:
インタフェース ServiceController 内の check
例外:
RequestException - 入力内容に誤りがある
SystemException - チェック時にシステム例外が発生

service

public ServiceResult service()
                      throws SystemException,
                             ApplicationException
入力に対する処理を実行します。 このサービスコントローラでは何もせず、nullを返します。

定義:
インタフェース ServiceController 内の service
戻り値:
処理結果(null)
例外:
SystemException - 処理実行時にシステム例外が発生
ApplicationException - 処理実行時にアプリケーション例外が発生

getLoginUserID

public String getLoginUserID()
                      throws ServiceControllerException
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログインユーザIDを取得します。

戻り値:
ログインユーザID
例外:
ServiceControllerException - ログインユーザID取得時に例外が発生

getLoginGroupID

public String getLoginGroupID()
                       throws ServiceControllerException
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログイングループIDを取得します。

戻り値:
ログイングループID
例外:
ServiceControllerException - ログイングループID取得時に例外が発生

getUserInfo

public UserInfo getUserInfo()
                     throws ServiceControllerException
ユーザ情報を取得します。

戻り値:
ログインユーザ情報
例外:
ServiceControllerException - ユーザ情報取得時に例外が発生
導入されたバージョン:
5.0

createEvent

protected Event createEvent(String application,
                            String key)
                     throws ServiceControllerException
アプリケーションIDとキーに対応するイベントを取得します。 イベントにはログイン時のログイングループIDが自動的に登録されます。

パラメータ:
application - アプリケーションID
key - キー
戻り値:
イベント
例外:
ServiceControllerException - イベント取得時に例外が発生

dispatchEvent

protected EventResult dispatchEvent(Event event)
                             throws EventManagerException,
                                    EventException,
                                    SystemException,
                                    ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventManagerException - イベントマネージャの生成に失敗
EventException - イベント処理実行に失敗
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生

setControllerObject

public void setControllerObject(ControllerObject controllerObject)
コントローラオブジェクトを設定します。

定義:
インタフェース ServiceController 内の setControllerObject
パラメータ:
controllerObject - コントローラオブジェクト
導入されたバージョン:
6.1

getControllerObject

public ControllerObject getControllerObject()
コントローラオブジェクトを取得します。

定義:
インタフェース ServiceController 内の getControllerObject
戻り値:
コントローラオブジェクト
導入されたバージョン:
6.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServiceControllerException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceControllerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.ServiceControllerException
すべての実装インタフェース:
Serializable
public class ServiceControllerException
extends SystemException

サービスコントローラに関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ServiceControllerException()
詳細メッセージを指定しないで ServiceControllerException を構築します。
ServiceControllerException(String msg)
指定された詳細メッセージを持つ ServiceControllerException を構築します。
ServiceControllerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceControllerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ServiceControllerException

public ServiceControllerException()
詳細メッセージを指定しないで ServiceControllerException を構築します。

ServiceControllerException

public ServiceControllerException(String msg)
指定された詳細メッセージを持つ ServiceControllerException を構築します。

パラメータ:
msg - 詳細メッセージ

ServiceControllerException

public ServiceControllerException(String msg,
                                  Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceControllerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServiceManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.ServiceManager
public class ServiceManager
extends Object

サービスマネージャです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_SERVICE_EXTENSION サービスフレームワークをコールするためのデフォルトの拡張子
static String | SERVICE_EXTENSION_KEY 拡張子を指定するキー
static String | SERVICE_PROPERTY_HANDLER_KEY サービスプロパティハンドラのキー
メソッドの概要
String | getApplication(HttpServletRequest request, HttpServletResponse response) 現在のリクエストに対するアプリケーションIDを取得します。
ControllerObject | getControllerObject(String application, String service, Locale locale, RequestInfo info) コントーラオブジェクトを取得します。
String | getEncoding(HttpServletRequest request, HttpServletResponse response) 現在のリクエストに対するエンコーディングを取得します。
String | getExtesion() サービスフレームワークを呼び出すための拡張子を取得します。
Locale | getLocale(HttpServletRequest request, HttpServletResponse response) 現在のリクエストに対するロケールを取得します。
String | getService(HttpServletRequest request, HttpServletResponse response) 現在のリクエストに対するサービスIDを取得します。
ServiceController | getServiceController(String application, String service) 推奨されていません。 このメソッドではなくgetServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
ServiceController | getServiceController(String application, String service, Locale locale) サービスコントローラを取得します。
static ServiceManager | getServiceManager() サービスマネージャを取得します。
ServicePropertyHandler | getServicePropertyHandler() サービスプロパティハンドラを取得します。
Transition | getTransition(String application, String service) 推奨されていません。 このメソッドではなくgetTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
Transition | getTransition(String application, String service, Locale locale) トランジションを取得します。
ValidatorMapping[] | getValidatorMapping(String application, String service, Locale locale) バリデータを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

SERVICE_PROPERTY_HANDLER_KEY

public static final String SERVICE_PROPERTY_HANDLER_KEY
サービスプロパティハンドラのキー

関連項目:
定数フィールド値

SERVICE_EXTENSION_KEY

public static final String SERVICE_EXTENSION_KEY
拡張子を指定するキー

導入されたバージョン:
5.0
関連項目:
getExtesion(), 定数フィールド値

DEFAULT_SERVICE_EXTENSION

public static final String DEFAULT_SERVICE_EXTENSION
サービスフレームワークをコールするためのデフォルトの拡張子

導入されたバージョン:
5.0
関連項目:
getExtesion(), 定数フィールド値
メソッドの詳細

getServiceManager

public static ServiceManager getServiceManager()
                                        throws ServiceManagerException
サービスマネージャを取得します。

戻り値:
サービスマネージャ
例外:
ServiceManagerException - サービスマネージャの生成に失敗した

getServicePropertyHandler

public ServicePropertyHandler getServicePropertyHandler()
サービスプロパティハンドラを取得します。

戻り値:
サービスプロパティハンドラ

getServiceController

public ServiceController getServiceController(String application,
                                              String service)
                                       throws ServicePropertyException,
                                              ServiceControllerException
推奨されていません。 このメソッドではなくgetServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。

サービスコントローラを取得します。 該当するサービスコントローラが存在しない場合、nullを返します。 このメソッドはgetServiceController(application, service, null)を呼んだときと同じ結果を返します。

パラメータ:
application - アプリケーション
service - サービス
戻り値:
サービスコントローラ、存在しない場合はnull
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
ServiceControllerException - サービスコントローラ取得時に例外が発生

getServiceController

public ServiceController getServiceController(String application,
                                              String service,
                                              Locale locale)
                                       throws ServicePropertyException,
                                              ServiceControllerException
サービスコントローラを取得します。 指定されたアプリケーションID、サービスID、ロケールに該当するサービスコントローラを取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

パラメータ:
application - アプリケーション
service - サービス
locale - ロケール
戻り値:
サービスコントローラ、存在しない場合はnull
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
ServiceControllerException - サービスコントローラ取得時に例外が発生
導入されたバージョン:
4.2

getTransition

public Transition getTransition(String application,
                                String service)
                         throws ServicePropertyException,
                                TransitionException
推奨されていません。 このメソッドではなくgetTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。

トランジションを取得します。 該当するトランジションが存在しない場合、DefaultTransitionを返します。 このメソッドはgetTransition(application, service, null)を呼んだときと同じ結果を返します。

パラメータ:
application - アプリケーション
service - サービス
戻り値:
トランジション
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
TransitionException - トランジション取得時に例外が発生

getTransition

public Transition getTransition(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException,
                                TransitionException
トランジションを取得します。 指定されたアプリケーションID、サービスID、ロケールに該当するトランジションを取得します。 該当するトランジションが存在しない場合、DefaultTransitionを返します。

パラメータ:
application - アプリケーション
service - サービス
locale - ロケール
戻り値:
トランジション
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
TransitionException - トランジション取得時に例外が発生
導入されたバージョン:
4.2

getControllerObject

public ControllerObject getControllerObject(String application,
                                            String service,
                                            Locale locale,
                                            RequestInfo info)
                                     throws ServletException,
                                            ServicePropertyException,
                                            ControllerConverterException,
                                            RequestFormatException,
                                            IOException
コントーラオブジェクトを取得します。 指定されたアプリケーションID、サービスID、ロケールに該当するコントーラオブジェクトを取得します。 コントーラオブジェクトは設定されたコントローラコンバータによって生成されます。 コントローラコンバータが設定されていない場合nullが返されます。

パラメータ:
application - アプリケーション
service - サービス
locale - ロケール
info - リクエスト情報
戻り値:
コントーラオブジェクト
例外:
ServletException - 変換中にServletExceptionが発生
IOException - 変換中にIOExceptionが発生
ServicePropertyException - サービスプロパティの取得時に例外が発生
ControllerConverterException - コントローラオブジェクト生成時に例外が発生
RequestFormatException - リクエストのフォーマットが不正
IOException - 変換中にIOExceptionが発生
導入されたバージョン:
6.1

getValidatorMapping

public ValidatorMapping[] getValidatorMapping(String application,
                                              String service,
                                              Locale locale)
                                       throws ServicePropertyException
バリデータを取得します。

パラメータ:
application - アプリケーション
service - サービス
locale - ロケール
戻り値:
バリデータ
例外:
ServicePropertyException - バリデータ取得時に例外が発生
導入されたバージョン:
6.1

getApplication

public String getApplication(HttpServletRequest request,
                             HttpServletResponse response)
                      throws ServicePropertyException
現在のリクエストに対するアプリケーションIDを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
現在のリクエストに対するアプリケーションID
例外:
ServicePropertyException - アプリケーションID取得時に例外が発生
導入されたバージョン:
4.2

getService

public String getService(HttpServletRequest request,
                         HttpServletResponse response)
                  throws ServicePropertyException
現在のリクエストに対するサービスIDを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
現在のリクエストに対するサービスID
例外:
ServicePropertyException - サービスID取得時に例外が発生
導入されたバージョン:
4.2

getLocale

public Locale getLocale(HttpServletRequest request,
                        HttpServletResponse response)
                 throws ServicePropertyException
現在のリクエストに対するロケールを取得します。 ロケールの取得は以下の優先順位に従います。
  1. セッション内のServicePropertyHandler.getLocaleAttributeName()で取得される属性名で登録されたロケール
  2. ServicePropertyHandler.getClientLocale()で取得されるロケール
  3. ServletRequest.getLocale()で取得されるロケール
  4. Locale.getDefault()で取得されるロケール

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ロケール
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
導入されたバージョン:
4.2

getEncoding

public String getEncoding(HttpServletRequest request,
                          HttpServletResponse response)
                   throws ServicePropertyException
現在のリクエストに対するエンコーディングを取得します。 エンコーディングの取得は以下の優先順位に従います。
  1. セッション内のServicePropertyHandler.getEncodingAttributeName()で取得される属性名で登録されたエンコーディング
  2. ServicePropertyHandler.getClientEncoding()で取得されるエンコーディング
  3. ServletRequest.getCharacterEncoding()で取得されるエンコーディング
  4. null

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
エンコーディング
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
導入されたバージョン:
4.2

getExtesion

public String getExtesion()
                   throws ServiceManagerException
サービスフレームワークを呼び出すための拡張子を取得します。
#SERVICE_EXTESION_KEYをキーとしたシステムプロパティを検索し、 存在しない場合は#DEFAULT_SERVICE_EXTを返却します。

戻り値:
サービスフレームワークを呼び出すための拡張子
例外:
ServiceManagerException
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServiceManagerException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.ServiceManagerException
すべての実装インタフェース:
Serializable
public class ServiceManagerException
extends SystemException

サービスマネージャ設定時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ServiceManagerException()
詳細メッセージを指定しないで ServiceManagerException を構築します。
ServiceManagerException(String msg)
指定された詳細メッセージを持つ ServiceManagerException を構築します。
ServiceManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ServiceManagerException

public ServiceManagerException()
詳細メッセージを指定しないで ServiceManagerException を構築します。

ServiceManagerException

public ServiceManagerException(String msg)
指定された詳細メッセージを持つ ServiceManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

ServiceManagerException

public ServiceManagerException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServicePropertyException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServicePropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.ServicePropertyException
すべての実装インタフェース:
Serializable
public class ServicePropertyException
extends SystemException

サービスプロパティ取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ServicePropertyException()
詳細メッセージを指定しないで ServicePropertyException を構築します。
ServicePropertyException(String msg)
指定された詳細メッセージを持つ ServicePropertyException を構築します。
ServicePropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServicePropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ServicePropertyException

public ServicePropertyException()
詳細メッセージを指定しないで ServicePropertyException を構築します。

ServicePropertyException

public ServicePropertyException(String msg)
指定された詳細メッセージを持つ ServicePropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

ServicePropertyException

public ServicePropertyException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServicePropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServicePropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
インタフェース ServicePropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultServicePropertyHandler, DistributesServicePropertyHandler, TextFileServicePropertyHandler, XmlServicePropertyHandler
public interface ServicePropertyHandler
extends PropertyHandler

サービスの設定情報に接続するクラスです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_APPLICATION_PARAMETER 推奨されていません。 この実装は廃止されました。
static String | DEFAULT_ENCODING_ATTRIBUTE ログインユーザのエンコーディングのデフォルトの属性名
static String | DEFAULT_EXCEPTION_ATTRIBUTE 例外属性のデフォルトの属性名
static String | DEFAULT_LOCALE_ATTRIBUTE ログインユーザのロケールのデフォルトの属性名
static String | DEFAULT_SERVICE_PARAMETER 推奨されていません。 この実装は廃止されました。
static String | REQUEST_INFO_ATTRIBUTE リクエスト情報の属性地
メソッドの概要
String | getApplicationParamName() 推奨されていません。 この実装は廃止されました。
String | getClientEncoding() クライアントのエンコードを取得します。
Locale | getClientLocale() クライアントのロケールを取得します。
String | getContextPath() 推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
ControllerConverterConfig | getControllerConverterConfig(String application, String service, Locale locale) キーに該当するコントローラコンバータの初期パラメータを取得します。
String | getControllerConverterName(String application, String service, Locale locale) コントローラコンバータのクラス名を取得します。
String | getEncodingAttributeName() ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
String | getExceptionAttributeName() 例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
String | getInputErrorPagePath() 推奨されていません。 このメソッドではなくgetInputErrorPagePath(Locale)を使用してください。
String | getInputErrorPagePath(Locale locale) 入力例外時のページのパスを取得します。
String | getInputErrorPagePath(String application) 推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, Locale)を使用してください。
String | getInputErrorPagePath(String application, Locale locale) 入力例外時のページのパスを取得します。
String | getInputErrorPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, Locale)を使用してください。
String | getInputErrorPagePath(String application, String service, Locale locale) 入力例外時のページのパスを取得します。
String | getInputErrorPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, String, Locale)を使用してください。
String | getInputErrorPagePath(String application, String service, String key, Locale locale) 入力例外時のページのパスを取得します。
String | getLocaleAttributeName() ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
String | getNextPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetNextPagePath(String, String, Locale)を使用してください。
String | getNextPagePath(String application, String service, Locale locale) 遷移先のページのパスを取得します。
String | getNextPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetNextPagePath(String, String, String, Locale)を使用してください。
String | getNextPagePath(String application, String service, String key, Locale locale) 遷移先のページのパスを取得します。
String | getServiceControllerName(String application, String service) 推奨されていません。 このメソッドではなくgetServiceControllerName(String, String, Locale)を使用してください。
String | getServiceControllerName(String application, String service, Locale locale) サービスコントローラのクラス名を取得します。
String | getServiceErrorPagePath() 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(Locale)を使用してください。
String | getServiceErrorPagePath(Locale locale) 処理例外時のページのパスを取得します。
String | getServiceErrorPagePath(String application) 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, Locale)を使用してください。
String | getServiceErrorPagePath(String application, Locale locale) 処理例外時のページのパスを取得します。
String | getServiceErrorPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, Locale)を使用してください。
String | getServiceErrorPagePath(String application, String service, Locale locale) 処理例外時のページのパスを取得します。
String | getServiceErrorPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, String, Locale)を使用してください。
String | getServiceErrorPagePath(String application, String service, String key, Locale locale) 処理例外時のページのパスを取得します。
String | getServiceParamName() 推奨されていません。 この実装は廃止されました。
String | getServiceServletPath() 推奨されていません。 この実装は廃止されました。
String | getSystemErrorPagePath() 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(Locale)を使用してください。
String | getSystemErrorPagePath(Locale locale) システム例外時のページのパスを取得します。
String | getSystemErrorPagePath(String application) 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, Locale)を使用してください。
String | getSystemErrorPagePath(String application, Locale locale) システム例外時のページのパスを取得します。
String | getSystemErrorPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, Locale)を使用してください。
String | getSystemErrorPagePath(String application, String service, Locale locale) システム例外時のページのパスを取得します。
String | getSystemErrorPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, String, Locale)を使用してください。
String | getSystemErrorPagePath(String application, String service, String key, Locale locale) システム例外時のページのパスを取得します。
String | getTransitionName(String application, String service) 推奨されていません。 このメソッドではなくgetTransitionName(String, String, Locale)を使用してください。
String | getTransitionName(String application, String service, Locale locale) トランジションのクラス名を取得します。
ValidatorMapping[] | getValidators(String application, String service, Locale locale) キーに該当するバリデータを取得します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

フィールドの詳細

DEFAULT_APPLICATION_PARAMETER

public static final String DEFAULT_APPLICATION_PARAMETER
推奨されていません。 この実装は廃止されました。

アプリケーションIDのデフォルトのパラメータ名

関連項目:
定数フィールド値

DEFAULT_SERVICE_PARAMETER

public static final String DEFAULT_SERVICE_PARAMETER
推奨されていません。 この実装は廃止されました。

サービスIDのデフォルトのパラメータ名

関連項目:
定数フィールド値

DEFAULT_EXCEPTION_ATTRIBUTE

public static final String DEFAULT_EXCEPTION_ATTRIBUTE
例外属性のデフォルトの属性名

関連項目:
定数フィールド値

DEFAULT_ENCODING_ATTRIBUTE

public static final String DEFAULT_ENCODING_ATTRIBUTE
ログインユーザのエンコーディングのデフォルトの属性名

関連項目:
定数フィールド値

DEFAULT_LOCALE_ATTRIBUTE

public static final String DEFAULT_LOCALE_ATTRIBUTE
ログインユーザのロケールのデフォルトの属性名

関連項目:
定数フィールド値

REQUEST_INFO_ATTRIBUTE

public static final String REQUEST_INFO_ATTRIBUTE
リクエスト情報の属性地

関連項目:
定数フィールド値
メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws ServicePropertyException
プロパティの動的読み込みが可能かどうか調べます。

戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可
例外:
ServicePropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getClientEncoding

public String getClientEncoding()
                         throws ServicePropertyException
クライアントのエンコードを取得します。

戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getEncodingAttributeName

public String getEncodingAttributeName()
                                throws ServicePropertyException
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。 設定されていない場合、DEFAULT_ENCODING_ATTRIBUTEで定義されている値を返します。

戻り値:
エンコードの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getClientLocale

public Locale getClientLocale()
                       throws ServicePropertyException
クライアントのロケールを取得します。

戻り値:
クライアントのロケール（設定されていない場合はnull）
例外:
ServicePropertyException - クライアントのロケールの取得時に例外が発生
導入されたバージョン:
4.2

getLocaleAttributeName

public String getLocaleAttributeName()
                              throws ServicePropertyException
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。 設定されていない場合、DEFAULT_LOCALE_ATTRIBUTEで定義されている値を返します。

戻り値:
ロケールの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生
導入されたバージョン:
4.2

getNextPagePath

public String getNextPagePath(String application,
                              String service)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなくgetNextPagePath(String, String, Locale)を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。 このメソッドはgetNextPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなくgetNextPagePath(String, String, String, Locale)を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。keyがnullの場合、getNextPagePath(String, String)と同じ動作になります。 このメソッドはgetNextPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。keyがnullの場合、getNextPagePath(String, String)と同じ動作になります。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, String, Locale)を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String, String)で取得されるページを返します。 このメソッドはgetInputErrorPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String, String)で取得されるページを返します。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, Locale)を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String)で取得されるページを返します。 このメソッドはgetInputErrorPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String)で取得されるページを返します。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, Locale)を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath()で取得されるページを返します。 このメソッドはgetInputErrorPagePath(application, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath()で取得されるページを返します。

パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath()
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(Locale)を使用してください。

入力例外時のページのパスを取得します。 このメソッドはgetInputErrorPagePath((java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。

パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, String, Locale)を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String, String)で取得されるページを返します。 このメソッドはgetServiceErrorPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String, String)で取得されるページを返します。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, Locale)を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String)で取得されるページを返します。 このメソッドはgetServiceErrorPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String)で取得されるページを返します。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, Locale)を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath()で取得されるページを返します。 このメソッドはgetServiceErrorPagePath(application, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath()で取得されるページを返します。

パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath()
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(Locale)を使用してください。

処理例外時のページのパスを取得します。 このメソッドはgetServiceErrorPagePath((java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, String, Locale)を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String, String)で取得されるページを返します。 このメソッドはgetSystemErrorPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String, String)で取得されるページを返します。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, Locale)を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String)で取得されるページを返します。 このメソッドはgetSystemErrorPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String)で取得されるページを返します。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, Locale)を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath()で取得されるページを返します。 このメソッドはgetSystemErrorPagePath(application, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath()で取得されるページを返します。

パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath()
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(Locale)を使用してください。

システム例外時のページのパスを取得します。 このメソッドはgetSystemErrorPagePath((java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。

パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service)
                                throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceControllerName(String, String, Locale)を使用してください。

サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。 このメソッドはgetServiceControllerName(application, service, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service,
                                       Locale locale)
                                throws ServicePropertyException
サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生
導入されたバージョン:
4.2

getTransitionName

public String getTransitionName(String application,
                                String service)
                         throws ServicePropertyException
推奨されていません。 このメソッドではなくgetTransitionName(String, String, Locale)を使用してください。

トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。 このメソッドはgetTransitionName(application, service, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException
トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生
導入されたバージョン:
4.2

getControllerConverterName

public String getControllerConverterName(String application,
                                         String service,
                                         Locale locale)
                                  throws ServicePropertyException
コントローラコンバータのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するコントローラコンバータ名を取得します。 特に設定されていない場合、nullが返ります。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - コントローラコンバータのクラス名の取得時に例外が発生
導入されたバージョン:
6.1

getControllerConverterConfig

public ControllerConverterConfig getControllerConverterConfig(String application,
                                                              String service,
                                                              Locale locale)
                                                       throws ServicePropertyException
キーに該当するコントローラコンバータの初期パラメータを取得します。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータの初期パラメータ
例外:
ServicePropertyException - コントローラコンバータの初期パラメータの取得に失敗
導入されたバージョン:
6.1

getValidators

public ValidatorMapping[] getValidators(String application,
                                        String service,
                                        Locale locale)
                                 throws ServicePropertyException
キーに該当するバリデータを取得します。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータの初期パラメータ
例外:
ServicePropertyException - バリデータの取得に失敗
導入されたバージョン:
6.1

getServiceServletPath

public String getServiceServletPath()
                             throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

サービスサーブレットのパスを取得します。

戻り値:
サービスサーブレットのパス
例外:
ServicePropertyException - サービスサーブレットのパスの取得時に例外が発生

getContextPath

public String getContextPath()
                      throws ServicePropertyException
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。

コンテキストパスを取得します。

戻り値:
コンテキストパス(設定されていない場合はnull)
例外:
ServicePropertyException - コンテキストパスの取得時に例外が発生

getApplicationParamName

public String getApplicationParamName()
                               throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

アプリケーションIDに該当するパラメータ名を取得します。 設定されていない場合、DEFAULT_APPLICATION_PARAMETERで定義されている値を返します。

戻り値:
アプリケーションIDに該当するパラメータ名
例外:
ServicePropertyException - アプリケーションIDに該当するパラメータ名の取得時に例外が発生

getServiceParamName

public String getServiceParamName()
                           throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

サービスIDに該当するパラメータ名を取得します。 設定されていない場合、DEFAULT_SERVICE_PARAMETERで定義されている値を返します。

戻り値:
サービスIDに該当するパラメータ名
例外:
ServicePropertyException - サービスIDに該当するパラメータ名の取得時に例外が発生

getExceptionAttributeName

public String getExceptionAttributeName()
                                 throws ServicePropertyException
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。

戻り値:
例外の属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart 6.1.14
 前のクラス   次のクラス フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド 詳細:  フィールド | コンストラクタ | メソッド


ServiceResult (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
インタフェース ServiceResult

既知のサブインタフェースの一覧:
MKServiceResult
既知の実装クラスの一覧:
DefaultMKServiceResult, EmptyServiceResult, MKErrorsResult
public interface ServiceResult

サービスの処理結果です。

バージョン:
1.0

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ServiceSecurityFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceSecurityFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.ServiceSecurityFilter
すべての実装インタフェース:
Filter
public class ServiceSecurityFilter
extends Object
implements Filter

intra-mart画面を表示するURLの詐称をチェックするためのフィルタです。 このフィルタは次の初期化パラメータを設定する必要があります。

パラメータ名 | 値
error-page | セキュリティ違反時に遷移するページのパス。 コンテキストパスからの相対パスで指定する必要がある。 パスの先頭は"/"で指定する。

このフィルタを設定する場合、ServiceServletは拡張子によるマッピングが行われる必要があります。

導入されたバージョン:
4.3

フィールドの概要
static String | ID_SERVICE_SECURITY_FILTER リクエストに登録するServiceServletFilterの属性名
static String | PARAM_ERROR_PAGE エラーページパスのパラメータ名
コンストラクタの概要
ServiceSecurityFilter()
メソッドの概要
void | destroy() フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) sessionに登録された情報と、parameterの情報を比較します。
void | init(FilterConfig filterConfig) このフィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_SERVICE_SECURITY_FILTER

public static final String ID_SERVICE_SECURITY_FILTER
リクエストに登録するServiceServletFilterの属性名

関連項目:
定数フィールド値

PARAM_ERROR_PAGE

public static final String PARAM_ERROR_PAGE
エラーページパスのパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

ServiceSecurityFilter

public ServiceSecurityFilter()
メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
このフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws ServletException,
                     IOException
sessionに登録された情報と、parameterの情報を比較します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタチェイン
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServiceServlet (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.framework.base.service.ServiceServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
public class ServiceServlet
extends HttpServlet

サービスを振り分けるサーブレットです。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
static String REQUEST_SEPARATOR
リクエストの情報を分割するセパレータ
コンストラクタの概要
ServiceServlet()
ServiceServletを新規に生成します。
メソッドの概要
void | destroy() サーブレットを解放します。
protected void | doGet(HttpServletRequest request, HttpServletResponse response) GETメソッドに対するサービスを行います。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) POSTメソッドに対するサービスを行います。
void | init(ServletConfig servletConfig) サーブレットを初期化します。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

REQUEST_SEPARATOR

public static final String REQUEST_SEPARATOR
リクエストの情報を分割するセパレータ

導入されたバージョン:
5.0
関連項目:
定数フィールド値
コンストラクタの詳細

ServiceServlet

public ServiceServlet()
ServiceServletを新規に生成します。

メソッドの詳細

init

public void init(ServletConfig servletConfig)
          throws ServletException
サーブレットを初期化します。

パラメータ:
servletConfig - ServletConfig
例外:
ServletException - サーブレット初期化時に例外が発生

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
GETメソッドに対するサービスを行います。 このメソッドでは対応するサービスコントローラを呼び、次の画面に遷移します。

パラメータ:
request - リクエスト
response - レスポンス
例外:
ServletException - サーブレット例外が発生
IOException - 入出力例外が発生

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
POSTメソッドに対するサービスを行います。 このメソッドでは対応するサービスコントローラを呼び、次の画面に遷移します。

パラメータ:
request - リクエスト
response - レスポンス
例外:
ServletException - サーブレット例外が発生
IOException - 入出力例外が発生

destroy

public void destroy()
サーブレットを解放します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServiceServletException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceServletException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.ServiceServletException
すべての実装インタフェース:
Serializable
public class ServiceServletException
extends SystemException

サービスに関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ServiceServletException()
詳細メッセージを指定しないで ServiceServletException を構築します。
ServiceServletException(String msg)
指定された詳細メッセージを持つ ServiceServletException を構築します。
ServiceServletException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceServletException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ServiceServletException

public ServiceServletException()
詳細メッセージを指定しないで ServiceServletException を構築します。

ServiceServletException

public ServiceServletException(String msg)
指定された詳細メッセージを持つ ServiceServletException を構築します。

パラメータ:
msg - 詳細メッセージ

ServiceServletException

public ServiceServletException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceServletException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TextFileServicePropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス TextFileServicePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler
すべての実装インタフェース:
PropertyHandler, ServicePropertyHandler
public class TextFileServicePropertyHandler
extends Object
implements ServicePropertyHandler

指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。 ファイルの書式はDefaultServicePropertyHandlerで示されるものと同じです。
ファイルが存在するディレクトリ名はPARAM_FILE_DIRで示されるパラメータ名で指定します。
PARAM_DYNAMICで示されるパラメータにtrueを指定した場合 アプリケーション実行時にもプロパティの変更を動的に反映させることが可能となりますが、 パラメータの取得時に毎回ファイル操作を行うためパフォーマンスに悪影響を与える可能性があります。 このオプションは、開発時やデバッグ時のようにパラメータを頻繁に変更する必要がある場合のみtrueとし、 通常はfalseに設定しておいてください。

導入されたバージョン:
3.2

フィールドの概要
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
インタフェース jp.co.intra_mart.framework.base.service.ServicePropertyHandler から継承したフィールド
DEFAULT_APPLICATION_PARAMETER, DEFAULT_ENCODING_ATTRIBUTE, DEFAULT_EXCEPTION_ATTRIBUTE, DEFAULT_LOCALE_ATTRIBUTE, DEFAULT_SERVICE_PARAMETER, REQUEST_INFO_ATTRIBUTE
コンストラクタの概要
TextFileServicePropertyHandler()
TextFileServicePropertyHandlerを新規に生成します。
メソッドの概要
String | getApplicationParamName() 推奨されていません。 この実装は廃止されました。
String | getClientEncoding() クライアントのエンコードを取得します。
Locale | getClientLocale() クライアントのロケールを取得します。
String | getContextPath() 推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
ControllerConverterConfig | getControllerConverterConfig(String application, String service, Locale locale) キーに該当するコントローラコンバータの初期パラメータを取得します。
String | getControllerConverterName(String application, String service, Locale locale) コントローラコンバータのクラス名を取得します。
String | getEncodingAttributeName() ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
String | getExceptionAttributeName() 例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
String | getInputErrorPagePath() 推奨されていません。 このメソッドではなくgetInputErrorPagePath(Locale)を使用してください。
String | getInputErrorPagePath(Locale locale) 入力例外時のページのパスを取得します。
String | getInputErrorPagePath(String application) 推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, Locale)を使用してください。
String | getInputErrorPagePath(String application, Locale locale) 入力例外時のページのパスを取得します。
String | getInputErrorPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, Locale)を使用してください。
String | getInputErrorPagePath(String application, String service, Locale locale) 入力例外時のページのパスを取得します。
String | getInputErrorPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, String, Locale)を使用してください。
String | getInputErrorPagePath(String application, String service, String key, Locale locale) 入力例外時のページのパスを取得します。
String | getLocaleAttributeName() ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
String | getNextPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetNextPagePath(String, String, Locale)を使用してください。
String | getNextPagePath(String application, String service, Locale locale) 遷移先のページのパスを取得します。
String | getNextPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetNextPagePath(String, String, String, Locale)を使用してください。
String | getNextPagePath(String application, String service, String key, Locale locale) 遷移先のページのパスを取得します。
String | getServiceControllerName(String application, String service) 推奨されていません。 このメソッドではなくgetServiceControllerName(String, String, Locale)を使用してください。
String | getServiceControllerName(String application, String service, Locale locale) サービスコントローラのクラス名を取得します。
String | getServiceErrorPagePath() 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(Locale)を使用してください。
String | getServiceErrorPagePath(Locale locale) 処理例外時のページのパスを取得します。
String | getServiceErrorPagePath(String application) 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, Locale)を使用してください。
String | getServiceErrorPagePath(String application, Locale locale) 処理例外時のページのパスを取得します。
String | getServiceErrorPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, Locale)を使用してください。
String | getServiceErrorPagePath(String application, String service, Locale locale) 処理例外時のページのパスを取得します。
String | getServiceErrorPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, String, Locale)を使用してください。
String | getServiceErrorPagePath(String application, String service, String key, Locale locale) 処理例外時のページのパスを取得します。
String | getServiceParamName() 推奨されていません。 この実装は廃止されました。
String | getServiceServletPath() サービスサーブレットのパスを取得します。
String | getSystemErrorPagePath() 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(Locale)を使用してください。
String | getSystemErrorPagePath(Locale locale) システム例外時のページのパスを取得します。
String | getSystemErrorPagePath(String application) 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, Locale)を使用してください。
String | getSystemErrorPagePath(String application, Locale locale) システム例外時のページのパスを取得します。
String | getSystemErrorPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, Locale)を使用してください。
String | getSystemErrorPagePath(String application, String service, Locale locale) システム例外時のページのパスを取得します。
String | getSystemErrorPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, String, Locale)を使用してください。
String | getSystemErrorPagePath(String application, String service, String key, Locale locale) システム例外時のページのパスを取得します。
String | getTransitionName(String application, String service) 推奨されていません。 このメソッドではなくgetTransitionName(String, String, Locale)を使用してください。
String | getTransitionName(String application, String service, Locale locale) トランジションのクラス名を取得します。
ValidatorMapping[] | getValidators(String application, String service, Locale locale) キーに該当するバリデータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() 再設定可能かどうかをチェックします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

TextFileServicePropertyHandler

public TextFileServicePropertyHandler()
TextFileServicePropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
再設定可能かどうかをチェックします。

定義:
インタフェース ServicePropertyHandler 内の isDynamic
戻り値:
true 再設定可能、false 再設定不可

getClientEncoding

public String getClientEncoding()
                         throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientEncoding
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getClientLocale

public Locale getClientLocale()
                       throws ServicePropertyException
クライアントのロケールを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientLocale
戻り値:
クライアントのロケール
例外:
ServicePropertyException - クライアントのロケールの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなくgetNextPagePath(String, String, Locale)を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。 このメソッドはgetNextPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなくgetNextPagePath(String, String, String, Locale)を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。keyがnullの場合、getNextPagePath(String, String)と同じ動作になります。 このメソッドはgetNextPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。keyがnullの場合、getNextPagePath(String, String)と同じ動作になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, String, Locale)を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String, String)で取得されるページを返します。 このメソッドはgetInputErrorPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, Locale)を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String)で取得されるページを返します。 このメソッドはgetInputErrorPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, Locale)を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath()で取得されるページを返します。 このメソッドはgetInputErrorPagePath(application, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath()
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(Locale)を使用してください。

入力例外時のページのパスを取得します。 このメソッドはgetInputErrorPagePath((java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, String, Locale)を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String, String)で取得されるページを返します。 このメソッドはgetServiceErrorPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, Locale)を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String)で取得されるページを返します。 このメソッドはgetServiceErrorPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, Locale)を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath()で取得されるページを返します。 このメソッドはgetServiceErrorPagePath(application, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath()
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(Locale)を使用してください。

処理例外時のページのパスを取得します。 このメソッドはgetServiceErrorPagePath((java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, String, Locale)を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String, String)で取得されるページを返します。 このメソッドはgetSystemErrorPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, Locale)を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String)で取得されるページを返します。 このメソッドはgetSystemErrorPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, Locale)を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath()で取得されるページを返します。 このメソッドはgetSystemErrorPagePath(application, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath()
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(Locale)を使用してください。

システム例外時のページのパスを取得します。 このメソッドはgetSystemErrorPagePath((java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service)
                                throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceControllerName(String, String, Locale)を使用してください。

サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。 このメソッドはgetServiceControllerName(application, service, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service,
                                       Locale locale)
                                throws ServicePropertyException
サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生
導入されたバージョン:
4.2

getTransitionName

public String getTransitionName(String application,
                                String service)
                         throws ServicePropertyException
推奨されていません。 このメソッドではなくgetTransitionName(String, String, Locale)を使用してください。

トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。 このメソッドはgetTransitionName(application, service, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException
トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生
導入されたバージョン:
4.2

getServiceServletPath

public String getServiceServletPath()
                             throws ServicePropertyException
サービスサーブレットのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceServletPath
戻り値:
サービスサーブレットのパス
例外:
ServicePropertyException - サービスサーブレットのパスの取得時に例外が発生

getContextPath

public String getContextPath()
                      throws ServicePropertyException
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。

コンテキストパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getContextPath
戻り値:
コンテキストパス
例外:
ServicePropertyException - コンテキストパスの取得時に例外が発生

getApplicationParamName

public String getApplicationParamName()
                               throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

アプリケーションIDに該当するパラメータ名を取得します。 設定されていない場合、ServicePropertyHandler.DEFAULT_APPLICATION_PARAMETERで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getApplicationParamName
戻り値:
アプリケーションIDに該当するパラメータ名
例外:
ServicePropertyException - アプリケーションIDに該当するパラメータ名の取得時に例外が発生

getServiceParamName

public String getServiceParamName()
                           throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

サービスIDに該当するパラメータ名を取得します。 設定されていない場合、ServicePropertyHandler.DEFAULT_SERVICE_PARAMETERで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceParamName
戻り値:
サービスIDに該当するパラメータ名
例外:
ServicePropertyException - サービスIDに該当するパラメータ名の取得時に例外が発生

getExceptionAttributeName

public String getExceptionAttributeName()
                                 throws ServicePropertyException
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。

定義:
インタフェース ServicePropertyHandler 内の getExceptionAttributeName
戻り値:
例外の属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getEncodingAttributeName

public String getEncodingAttributeName()
                                throws ServicePropertyException
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。 設定されていない場合、ServicePropertyHandler.DEFAULT_ENCODING_ATTRIBUTEで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getEncodingAttributeName
戻り値:
エンコードの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getLocaleAttributeName

public String getLocaleAttributeName()
                              throws ServicePropertyException
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。 設定されていない場合、ServicePropertyHandler.DEFAULT_LOCALE_ATTRIBUTEで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getLocaleAttributeName
戻り値:
ロケールの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生
導入されたバージョン:
4.2

getControllerConverterName

public String getControllerConverterName(String application,
                                         String service,
                                         Locale locale)
                                  throws ServicePropertyException
インタフェース ServicePropertyHandler の記述:
コントローラコンバータのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するコントローラコンバータ名を取得します。 特に設定されていない場合、nullが返ります。

定義:
インタフェース ServicePropertyHandler 内の getControllerConverterName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - コントローラコンバータのクラス名の取得時に例外が発生

getControllerConverterConfig

public ControllerConverterConfig getControllerConverterConfig(String application,
                                                              String service,
                                                              Locale locale)
                                                       throws ServicePropertyException
インタフェース ServicePropertyHandler の記述:
キーに該当するコントローラコンバータの初期パラメータを取得します。

定義:
インタフェース ServicePropertyHandler 内の getControllerConverterConfig
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータの初期パラメータ
例外:
ServicePropertyException - コントローラコンバータの初期パラメータの取得に失敗

getValidators

public ValidatorMapping[] getValidators(String application,
                                        String service,
                                        Locale locale)
                                 throws ServicePropertyException
インタフェース ServicePropertyHandler の記述:
キーに該当するバリデータを取得します。

定義:
インタフェース ServicePropertyHandler 内の getValidators
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータの初期パラメータ
例外:
ServicePropertyException - バリデータの取得に失敗
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart 6.1.14
 前のクラス   次のクラス フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド 詳細:  フィールド | コンストラクタ | メソッド


Transition (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス Transition

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.Transition
直系の既知のサブクラス:
DefaultTransition, IntramartPageBaseTransition
public abstract class Transition
extends Object

画面遷移に関連するクラスのインタフェースです。

バージョン:
1.0

コンストラクタの概要
Transition()
Transitionを新規に生成します。
メソッドの概要
protected String | getApplication() アプリケーションIDを取得します。
MultipartFormData.Entity | getEntity(String name) リクエストから指定された名前に該当するエンティティを取得します。
abstract String | getInputErrorPage(RequestException e) 入力エラーのページを取得します。
abstract String | getNextPage() 次に遷移するページを取得します。
protected String | getNextPagePath() このトランジションに設定されているアプリケーションIDとサービスIDに該当する次ページのパスを取得します。
protected String | getNextPagePath(String key) このトランジションに設定されているアプリケーションIDとサービスIDと、指定されたキーに該当する次ページのパスを取得します。
HttpServletRequest | getRequest() リクエストを取得します。
HttpServletResponse | getResponse() レスポンスを取得します。
ServiceResult | getResult() サービス処理結果を取得します。
protected String | getService() サービスIDを取得します。
abstract String | getServiceErrorPage(Exception e) 処理エラーのページを取得します。
protected ServiceManager | getServiceManager() サービスマネージャを取得します。
SessionObject | getSessionObject() 推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
abstract String | getSystemErrorPage(Exception e) システムエラーのページを取得します。
abstract void | setInformation() 次の遷移先に渡す情報を設定します。
void | setRequest(HttpServletRequest request) リクエストを設定します。
void | setResponse(HttpServletResponse response) レスポンスを設定します。
void | setResult(ServiceResult result) サービス処理結果を設定します。
protected void | setServiceManager(ServiceManager manager) サービスマネージャを設定します。
abstract void | transfer() 次のページに遷移します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Transition

public Transition()
Transitionを新規に生成します。

メソッドの詳細

setServiceManager

protected void setServiceManager(ServiceManager manager)
サービスマネージャを設定します。

パラメータ:
manager - サービスマネージャ

getServiceManager

protected ServiceManager getServiceManager()
サービスマネージャを取得します。

戻り値:
サービスマネージャ

getApplication

protected String getApplication()
アプリケーションIDを取得します。

戻り値:
アプリケーションID

getService

protected String getService()
サービスIDを取得します。

戻り値:
サービスID

setRequest

public void setRequest(HttpServletRequest request)
リクエストを設定します。

パラメータ:
request - リクエスト

getRequest

public HttpServletRequest getRequest()
リクエストを取得します。

戻り値:
リクエスト

setResponse

public void setResponse(HttpServletResponse response)
レスポンスを設定します。

パラメータ:
response - レスポンス

getResponse

public HttpServletResponse getResponse()
レスポンスを取得します。

戻り値:
レスポンス

getEntity

public MultipartFormData.Entity getEntity(String name)
                                   throws SystemException
リクエストから指定された名前に該当するエンティティを取得します。 このメソッドは、ファイルアップロード時にその内容を取得する場合などに使用します。 このメソッドは、ファイルアップロードのリクエストが送られた場合のみ使用できます。 それ以外のリクエストが送られた場合にこのメソッドを呼ぶと例外が発生します。

パラメータ:
name - パラメータ名
戻り値:
パラメータ名に該当するエンティティ
例外:
SystemException - エンティティの取得に失敗
導入されたバージョン:
3.2

getSessionObject

public SessionObject getSessionObject()
                               throws SessionManagerException,
                                      SessionPropertyException,
                                      SessionFactoryException
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

セッションオブジェクトを取得します。

戻り値:
セッションオブジェクト
例外:
SessionManagerException - セッションマネージャの取得時に例外が発生
SessionPropertyException - セッションのプロパティ情報取得時に例外が発生
SessionFactoryException - セッションオブジェクトの生成時に例外が発生

setResult

public void setResult(ServiceResult result)
サービス処理結果を設定します。

パラメータ:
result - サービス処理結果

getResult

public ServiceResult getResult()
サービス処理結果を取得します。

戻り値:
サービス処理結果

getNextPagePath

protected String getNextPagePath()
                          throws ServicePropertyException
このトランジションに設定されているアプリケーションIDとサービスIDに該当する次ページのパスを取得します。

戻り値:
次ページのパス
例外:
ServicePropertyException - プロパティの取得時に例外が発生

getNextPagePath

protected String getNextPagePath(String key)
                          throws ServicePropertyException
このトランジションに設定されているアプリケーションIDとサービスIDと、指定されたキーに該当する次ページのパスを取得します。

パラメータ:
key - キー
戻り値:
次ページのパス
例外:
ServicePropertyException - プロパティの取得時に例外が発生

getInputErrorPage

public abstract String getInputErrorPage(RequestException e)
                                  throws ServicePropertyException,
                                         TransitionException
入力エラーのページを取得します。

パラメータ:
e - 入力時の例外
戻り値:
入力エラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getSystemErrorPage

public abstract String getSystemErrorPage(Exception e)
                                   throws ServicePropertyException,
                                          TransitionException
システムエラーのページを取得します。

パラメータ:
e - 処理時の例外
戻り値:
システムエラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getServiceErrorPage

public abstract String getServiceErrorPage(Exception e)
                                    throws ServicePropertyException,
                                           TransitionException
処理エラーのページを取得します。

パラメータ:
e - 処理時の例外
戻り値:
処理エラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

setInformation

public abstract void setInformation()
                             throws TransitionException
次の遷移先に渡す情報を設定します。

例外:
TransitionException - 情報設定時に例外が発生

getNextPage

public abstract String getNextPage()
                            throws ServicePropertyException,
                                   TransitionException
次に遷移するページを取得します。

戻り値:
次に遷移するページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

transfer

public abstract void transfer()
                       throws SystemException
次のページに遷移します。 遷移する方法は次のページで要求される形式に依存します。

例外:
SystemException - システム例外が発生
導入されたバージョン:
3.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TransitionException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス TransitionException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.TransitionException
すべての実装インタフェース:
Serializable
public class TransitionException
extends SystemException

トランジションに関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
TransitionException()
詳細メッセージを指定しないで TransitionException を構築します。
TransitionException(String msg)
指定された詳細メッセージを持つ TransitionException を構築します。
TransitionException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ TransitionException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

TransitionException

public TransitionException()
詳細メッセージを指定しないで TransitionException を構築します。

TransitionException

public TransitionException(String msg)
指定された詳細メッセージを持つ TransitionException を構築します。

パラメータ:
msg - 詳細メッセージ

TransitionException

public TransitionException(String msg,
                           Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ TransitionException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ValidatorMapping (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ValidatorMapping

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.ValidatorMapping
public class ValidatorMapping
extends Object

バリデータの設定を保持します。

導入されたバージョン:
6.1

コンストラクタの概要
ValidatorMapping()
ValidatorMappingを新規に生成します。
メソッドの概要
String | getValidatorClassName() バリデータ名を取得します。
ValidatorConfig | getValidatorConfig() バリデータの初期化パラメータを取得します。
void | setValidatorClassName(String validatorClassName) バリデータ名を設定します。
void | setValidatorConfig(ValidatorConfig validatorConfig) バリデータの初期化パラメータを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ValidatorMapping

public ValidatorMapping()
ValidatorMappingを新規に生成します。

メソッドの詳細

getValidatorClassName

public String getValidatorClassName()
バリデータ名を取得します。

戻り値:

setValidatorClassName

public void setValidatorClassName(String validatorClassName)
バリデータ名を設定します。

パラメータ:
validatorClassName -

getValidatorConfig

public ValidatorConfig getValidatorConfig()
バリデータの初期化パラメータを取得します。

戻り値:

setValidatorConfig

public void setValidatorConfig(ValidatorConfig validatorConfig)
バリデータの初期化パラメータを設定します。

パラメータ:
validatorConfig -
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ValidatorModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ValidatorModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.ValidatorModel
public class ValidatorModel
extends Object

バリデータ情報を管理するクラスです。

バージョン:
1.0

フィールドの概要
static String | ID
static String | P_ID_PARAM_NAME
static String | P_ID_PARAM_VALUE
static String | P_ID_VALIDATOR_CLASS
static String | P_ID_VALIDATOR_PARAM
コンストラクタの概要
ValidatorModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID

public static final String ID
関連項目:
定数フィールド値

P_ID_VALIDATOR_CLASS

public static final String P_ID_VALIDATOR_CLASS
関連項目:
定数フィールド値

P_ID_VALIDATOR_PARAM

public static final String P_ID_VALIDATOR_PARAM
関連項目:
定数フィールド値

P_ID_PARAM_NAME

public static final String P_ID_PARAM_NAME
関連項目:
定数フィールド値

P_ID_PARAM_VALUE

public static final String P_ID_PARAM_VALUE
関連項目:
定数フィールド値
コンストラクタの詳細

ValidatorModel

public ValidatorModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XmlServicePropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス XmlServicePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler
すべての実装インタフェース:
PropertyHandler, ServicePropertyHandler
public class XmlServicePropertyHandler
extends Object
implements ServicePropertyHandler

サービスの設定情報に接続するプロパティハンドラです。
XML形式で記述されたプロパティ情報を読み取ります。XMLファイルはアプリケーション毎に分割されます。この場合のファイル名は「 プレフィックス _ アプリケーションID .xml」です。また、アプリケーションに依存しない「 プレフィックス .xml」があります。
XMLファイルのプレフィックスは PropertyManager.getPropertyHandlerParams(String) でキーに ServiceManager.SERVICE_PROPERTY_HANDLER_KEY を指定したときに取得されるパラメータのうち DEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスは DEFAULT_BUNDLE_NAME_PARAMで示されるものです。
プロパティの検索順は、アプリケーションごとのプロパティファイル「 プレフィックス _ アプリケーションID .xml」が優先されます。該当するプロパティが見つからない場合、引き続いて「 プレフィックス .xml」を検索します。

導入されたバージョン:
5.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
インタフェース jp.co.intra_mart.framework.base.service.ServicePropertyHandler から継承したフィールド
DEFAULT_APPLICATION_PARAMETER, DEFAULT_ENCODING_ATTRIBUTE, DEFAULT_EXCEPTION_ATTRIBUTE, DEFAULT_LOCALE_ATTRIBUTE, DEFAULT_SERVICE_PARAMETER, REQUEST_INFO_ATTRIBUTE
コンストラクタの概要
XmlServicePropertyHandler()
XmlServicePropertyHandlerを新規に生成します。
メソッドの概要
 String getApplicationParamName()
推奨されていません。 この実装は廃止されました。
 String getClientEncoding()
クライアントのエンコードを取得します。
 Locale getClientLocale()
クライアントのエンコードを取得します。
 String getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 ControllerConverterConfig getControllerConverterConfig(String application, String service, Locale locale)
キーに該当するコントローラコンバータの初期パラメータを取得します。
 String getControllerConverterName(String application, String service, Locale locale)
コントローラコンバータのクラス名を取得します。
 String getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String getInputErrorPagePath()
推奨されていません。 このメソッドではなく getInputErrorPagePath(Locale)を使用してください。
 String getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, Locale) を使用してください。
 String getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, Locale) を使用してください。
 String getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, String, Locale) を使用してください。
 String getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 String getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなく getNextPagePath(String, String, Locale) を使用してください。
 String getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getNextPagePath(String, String, String, Locale) を使用してください。
 String getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなく getServiceControllerName(String, String, Locale) を使用してください。
 String getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String getServiceErrorPagePath()
推奨されていません。 このメソッドではなく getServiceErrorPagePath(Locale) を使用してください。
 String getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceParamName()
推奨されていません。 この実装は廃止されました。
 String getServiceServletPath()
サービスサーブレットのパスを取得します。
 String getSystemErrorPagePath()
推奨されていません。 このメソッドではなく getSystemErrorPagePath(Locale)を使用してください。
 String getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String getTransitionName(String application, String service)
推奨されていません。 このメソッドではなく getTransitionName(String, String, Locale) を使用してください。
 String getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 ValidatorMapping[] getValidators(String application, String service, Locale locale)
キーに該当するバリデータを取得します。
 void init(PropertyParam[] params)
プロパティハンドラを初期化します。
 boolean isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

XmlServicePropertyHandler

public XmlServicePropertyHandler()
XmlServicePropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws ServicePropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース ServicePropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
ServicePropertyException - チェック時に例外が発生

getClientEncoding

public String getClientEncoding()
                         throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientEncoding
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getClientLocale

public Locale getClientLocale()
                       throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientLocale
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String, String)で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String)で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath() で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath() で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath()
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(Locale)を使用してください。

入力例外時のページのパスを取得します。 このメソッドは getInputErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなく getNextPagePath(String, String, Locale) を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。 このメソッドは getNextPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなく getNextPagePath(String, String, String, Locale) を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。 key が null の場合、 getNextPagePath(String, String) と同じ動作になります。 このメソッドは getNextPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。 key が null の場合、 getNextPagePath(String, String) と同じ動作になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service)
                                throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceControllerName(String, String, Locale) を使用してください。

サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。 このメソッドは getServiceControllerName(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service,
                                       Locale locale)
                                throws ServicePropertyException
サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, String, Locale) を使用してください。

処理例外時のページのパスを取得します。 このメソッドは getServiceErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, Locale) を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath(String)で取得されるページを返します。 このメソッドは getServiceErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, Locale) を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath()で取得されるページを返します。 このメソッドは getServiceErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath()
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(Locale) を使用してください。

処理例外時のページのパスを取得します。 このメソッドは getServiceErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String, String)で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String)で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath()で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath()
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(Locale)を使用してください。

システム例外時のページのパスを取得します。 このメソッドは getSystemErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service)
                         throws ServicePropertyException
推奨されていません。 このメソッドではなく getTransitionName(String, String, Locale) を使用してください。

トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。 このメソッドは getTransitionName(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException
トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getControllerConverterName

public String getControllerConverterName(String application,
                                         String service,
                                         Locale locale)
                                  throws ServicePropertyException
コントローラコンバータのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するコントローラコンバータ名を取得します。 特に設定されていない場合、nullが返ります。

定義:
インタフェース ServicePropertyHandler 内の getControllerConverterName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - コントローラコンバータのクラス名の取得時に例外が発生
導入されたバージョン:
6.1

getControllerConverterConfig

public ControllerConverterConfig getControllerConverterConfig(String application,
                                                              String service,
                                                              Locale locale)
                                                       throws ServicePropertyException
キーに該当するコントローラコンバータの初期パラメータを取得します。

定義:
インタフェース ServicePropertyHandler 内の getControllerConverterConfig
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータの初期パラメータ
例外:
ServicePropertyException - コントローラコンバータの初期パラメータの取得に失敗
導入されたバージョン:
6.1

getValidators

public ValidatorMapping[] getValidators(String application,
                                        String service,
                                        Locale locale)
                                 throws ServicePropertyException
キーに該当するバリデータを取得します。

定義:
インタフェース ServicePropertyHandler 内の getValidators
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータの初期パラメータ
例外:
ServicePropertyException - バリデータの取得に失敗
導入されたバージョン:
6.1

getServiceServletPath

public String getServiceServletPath()
                             throws ServicePropertyException
サービスサーブレットのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceServletPath
戻り値:
サービスサーブレットのパス
例外:
ServicePropertyException - サービスサーブレットのパスの取得時に例外が発生

getContextPath

public String getContextPath()
                      throws ServicePropertyException
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。

コンテキストパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getContextPath
戻り値:
コンテキストパス
例外:
ServicePropertyException - コンテキストパスの取得時に例外が発生

getApplicationParamName

public String getApplicationParamName()
                               throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

アプリケーションIDに該当するパラメータ名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_APPLICATION_PARAMETER で定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getApplicationParamName
戻り値:
アプリケーションIDに該当するパラメータ名
例外:
ServicePropertyException - アプリケーションIDに該当するパラメータ名の取得時に例外が発生

getServiceParamName

public String getServiceParamName()
                           throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

サービスIDに該当するパラメータ名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_SERVICE_PARAMETERで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceParamName
戻り値:
サービスIDに該当するパラメータ名
例外:
ServicePropertyException - サービスIDに該当するパラメータ名の取得時に例外が発生

getExceptionAttributeName

public String getExceptionAttributeName()
                                 throws ServicePropertyException
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_EXCEPTION_ATTRIBUTE で定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getExceptionAttributeName
戻り値:
例外の属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getEncodingAttributeName

public String getEncodingAttributeName()
                                throws ServicePropertyException
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_ENCODING_ATTRIBUTEで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getEncodingAttributeName
戻り値:
エンコードの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getLocaleAttributeName

public String getLocaleAttributeName()
                              throws ServicePropertyException
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_LOCALE_ATTRIBUTEで定義されている値を返します 。

定義:
インタフェース ServicePropertyHandler 内の getLocaleAttributeName
戻り値:
ロケールの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart 6.1.14
 前のクラス   次のクラス | フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド | 詳細:  フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler の使用

jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.HttpSessionFactory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.HttpSessionFactory の使用

jp.co.intra_mart.framework.base.session.HttpSessionFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.HttpSessionObject の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.HttpSessionObject の使用

jp.co.intra_mart.framework.base.session.HttpSessionObject はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.IllegalSessionException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.IllegalSessionException の使用

jp.co.intra_mart.framework.base.session.IllegalSessionException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.IntramartSessionFactory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.IntramartSessionFactory の使用

jp.co.intra_mart.framework.base.session.IntramartSessionFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.IntramartSessionObject の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.IntramartSessionObject の使用

jp.co.intra_mart.framework.base.session.IntramartSessionObject はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.session.SessionFactory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.session.SessionFactory の使用

SessionFactory を使用しているパッケージ
jp.co.intra_mart.framework.base.session セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.session での SessionFactory の使用

SessionFactory を実装している jp.co.intra_mart.framework.base.session のクラス
class | HttpSessionFactory 推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
class | IntramartSessionFactory 推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。

SessionFactory を返す jp.co.intra_mart.framework.base.session のメソッド
 SessionFactory SessionManager.getSessionFactory()
セッションファクトリを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.SessionFactoryException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.SessionFactoryException の使用

SessionFactoryException を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での SessionFactoryException の使用

SessionFactoryException をスローする jp.co.intra_mart.framework.base.service のメソッド
 SessionObject Transition.getSessionObject()
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

jp.co.intra_mart.framework.base.session での SessionFactoryException の使用

SessionFactoryException をスローする jp.co.intra_mart.framework.base.session のメソッド
SessionObject | SessionManager.getSessionObject(ServletRequest request) セッションオブジェクトを取得します。
SessionObject | SessionFactory.createSessionObject(ServletRequest request) セッションオブジェクトを新規に生成します。
String | SessionFactory.encodeURL(ServletRequest request, ServletResponse response, String url) セッションIDをエンコードしてURLに追加します。
SessionObject | IntramartSessionFactory.createSessionObject(ServletRequest request) 推奨されていません。 セッションオブジェクトを新規に生成します。
String | IntramartSessionFactory.encodeURL(ServletRequest request, ServletResponse response, String url) 推奨されていません。 セッションIDをエンコードしてURLに追加します。
SessionObject | HttpSessionFactory.createSessionObject(ServletRequest request) 推奨されていません。 セッションオブジェクトを新規に生成します。
String | HttpSessionFactory.encodeURL(ServletRequest request, ServletResponse response, String url) 推奨されていません。 セッションIDをエンコードしてURLに追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.SessionFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.SessionFilter の使用

jp.co.intra_mart.framework.base.session.SessionFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.SessionManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.SessionManager の使用

SessionManager を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での SessionManager の使用

SessionManager を返す jp.co.intra_mart.framework.base.service のメソッド
protected  SessionManager IntramartConnectServlet.getSessionManager()
推奨されていません。 セッションマネージャを取得します。

jp.co.intra_mart.framework.base.session での SessionManager の使用

SessionManager を返す jp.co.intra_mart.framework.base.session のメソッド
static SessionManager SessionManager.getSessionManager()
セッションマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.SessionManagerException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.SessionManagerException の使用

SessionManagerException を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での SessionManagerException の使用

SessionManagerException をスローする jp.co.intra_mart.framework.base.service のメソッド
 SessionObject Transition.getSessionObject()
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

jp.co.intra_mart.framework.base.session での SessionManagerException の使用

SessionManagerException をスローする jp.co.intra_mart.framework.base.session のメソッド
static SessionManager SessionManager.getSessionManager()
セッションマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.session.SessionObject の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.session.SessionObject の使用

SessionObject を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での SessionObject の使用

SessionObject を返す jp.co.intra_mart.framework.base.service のメソッド
 SessionObject Transition.getSessionObject()
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

jp.co.intra_mart.framework.base.session での SessionObject の使用

SessionObject を実装している jp.co.intra_mart.framework.base.session のクラス
class | HttpSessionObject 推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
class | IntramartSessionObject 推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。

SessionObject を返す jp.co.intra_mart.framework.base.session のメソッド
SessionObject | SessionManager.getSessionObject(ServletRequest request) セッションオブジェクトを取得します。
SessionObject | SessionFactory.createSessionObject(ServletRequest request) セッションオブジェクトを新規に生成します。
SessionObject | IntramartSessionFactory.createSessionObject(ServletRequest request) 推奨されていません。 セッションオブジェクトを新規に生成します。
SessionObject | HttpSessionFactory.createSessionObject(ServletRequest request) 推奨されていません。 セッションオブジェクトを新規に生成します。

jp.co.intra_mart.framework.base.web.bean での SessionObject の使用

SessionObject を返す jp.co.intra_mart.framework.base.web.bean のメソッド
 SessionObject HelperBean.getSession()
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.SessionObjectException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.SessionObjectException の使用

SessionObjectException を使用しているパッケージ
jp.co.intra_mart.framework.base.session セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.session での SessionObjectException の使用

SessionObjectException をスローする jp.co.intra_mart.framework.base.session のメソッド
void | SessionObject.setAttribute(String name, Object value) 指定された名前に対応するオブジェクトを追加します。
Object | SessionObject.getAttribute(String name) 指定された名前に対応するオブジェクトを取得します。
void | SessionObject.removeAttribute(String name) 指定された名前に対応するオブジェクトを削除します。
Enumeration | SessionObject.getAttributeNames() セッション内に存在する名前の一覧を取得します。
void | SessionObject.clear() セッション内に存在するすべてのオブジェクトを削除します。
void | IntramartSessionObject.setAttribute(String name, Object value) 推奨されていません。 指定された名前に対応するオブジェクトを追加します。
Object | IntramartSessionObject.getAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを取得します。
Enumeration | IntramartSessionObject.getAttributeNames() 推奨されていません。 セッション内に存在する名前の一覧を取得します。
void | IntramartSessionObject.removeAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを削除します。
void | IntramartSessionObject.clear() 推奨されていません。 セッション内に存在するすべてのオブジェクトを削除します。
void | HttpSessionObject.setAttribute(String name, Object value) 推奨されていません。 指定された名前に対応するオブジェクトを追加します。
void | HttpSessionObject.removeAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを削除します。
Object | HttpSessionObject.getAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを取得します。
Enumeration | HttpSessionObject.getAttributeNames() 推奨されていません。 セッション内に存在する名前の一覧を取得します。
void | HttpSessionObject.clear() 推奨されていません。 セッション内に存在するすべてのオブジェクトを削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.SessionPropertyException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.SessionPropertyException の使用

SessionPropertyException を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での SessionPropertyException の使用

SessionPropertyException をスローする jp.co.intra_mart.framework.base.service のメソッド
 SessionObject Transition.getSessionObject()
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

jp.co.intra_mart.framework.base.session での SessionPropertyException の使用

SessionPropertyException をスローする jp.co.intra_mart.framework.base.session のメソッド
String | XmlSessionPropertyHandler.getSessionFactoryName() 推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
String | XmlSessionPropertyHandler.getSessionParameter() 推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
String | XmlSessionPropertyHandler.getSessionObjectKey() 推奨されていません。 HttpSessionを直接取得するようにしてください。
String | XmlSessionPropertyHandler.getLoginUserIDKey() セッションに登録されているログインユーザIDのキーを取得します。
String | XmlSessionPropertyHandler.getLoginGroupIDKey() セッションに登録されているログイングループIDのキーを取得します。
String | XmlSessionPropertyHandler.getSessionErrorPagePath() セッションエラーページのパスを取得します。
String | SessionPropertyHandler.getSessionObjectKey() 推奨されていません。 HttpSessionを直接取得するようにしてください。
String | SessionPropertyHandler.getSessionParameter() 推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
String | SessionPropertyHandler.getSessionFactoryName() 推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
String | SessionPropertyHandler.getLoginUserIDKey() セッションに登録されているログインユーザIDのキーを取得します。
String | SessionPropertyHandler.getLoginGroupIDKey() セッションに登録されているログイングループIDのキーを取得します。
String | SessionPropertyHandler.getSessionErrorPagePath() セッションエラーページのパスを取得します。
SessionObject | SessionManager.getSessionObject(ServletRequest request) セッションオブジェクトを取得します。
String | DefaultSessionPropertyHandler.getSessionFactoryName() 推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
String | DefaultSessionPropertyHandler.getSessionParameter() 推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
String | DefaultSessionPropertyHandler.getSessionObjectKey() 推奨されていません。 HttpSessionを直接取得するようにしてください。
String | DefaultSessionPropertyHandler.getLoginUserIDKey() セッションに登録されているログインユーザIDのキーを取得します。
String | DefaultSessionPropertyHandler.getLoginGroupIDKey() セッションに登録されているログイングループIDのキーを取得します。
String | DefaultSessionPropertyHandler.getSessionErrorPagePath() セッションエラーページのパスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.session.SessionPropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.session.SessionPropertyHandler の使用

SessionPropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での SessionPropertyHandler の使用

SessionPropertyHandler を返す jp.co.intra_mart.framework.base.service のメソッド
protected  SessionPropertyHandler IntramartConnectServlet.getSessionPropertyHandler()
推奨されていません。 セッションプロパティハンドラを取得します。

jp.co.intra_mart.framework.base.session での SessionPropertyHandler の使用

SessionPropertyHandler を実装している jp.co.intra_mart.framework.base.session のクラス
class | DefaultSessionPropertyHandler セッションに関連するデフォルトのプロパティハンドラです。
class | XmlSessionPropertyHandler セッションに関連するXMLのプロパティハンドラです。

SessionPropertyHandler を返す jp.co.intra_mart.framework.base.session のメソッド
 SessionPropertyHandler SessionManager.getSessionPropertyHandler()
セッションプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler の使用

jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DefaultSessionPropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス DefaultSessionPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler
すべての実装インタフェース:
PropertyHandler, SessionPropertyHandler
public class DefaultSessionPropertyHandler
extends Object
implements SessionPropertyHandler

セッションに関連するデフォルトのプロパティハンドラです。 プロパティの設定内容は以下のとおりです。

キー | 内容
factory.name | SessionFactoryのクラス名
object.param | リクエストに渡すセッションIDのパラメータ名
error.page.path | セッションエラー（セッションタイムアウト等）のときに表示するページのパス
object.key | リクエストの属性にSessionObjectを保存する時のキー
reserved.user.key | SessionObjectの属性に設定されているユーザIDのキー
reserved.group.key | SessionObjectの属性に設定されているログイングループIDのキー

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
コンストラクタの概要
DefaultSessionPropertyHandler()
DefaultSessionPropertyHandlerを新規に生成します。
メソッドの概要
String | getLoginGroupIDKey() セッションに登録されているログイングループIDのキーを取得します。
String | getLoginUserIDKey() セッションに登録されているログインユーザIDのキーを取得します。
String | getSessionErrorPagePath() セッションエラーページのパスを取得します。
String | getSessionFactoryName() 推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
String | getSessionObjectKey() 推奨されていません。 HttpSessionを直接取得するようにしてください。
String | getSessionParameter() 推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultSessionPropertyHandler

public DefaultSessionPropertyHandler()
DefaultSessionPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

getSessionFactoryName

public String getSessionFactoryName()
                             throws SessionPropertyException
推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。

セッションファクトリのクラス名を取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース SessionPropertyHandler 内の getSessionFactoryName
戻り値:
セッションファクトリのクラス名（設定されていない場合null）
例外:
SessionPropertyException - セッションファクトリのクラス名の取得時に例外が発生

getSessionParameter

public String getSessionParameter()
                           throws SessionPropertyException
推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。

セッションIDのパラメータ名を取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース SessionPropertyHandler 内の getSessionParameter
戻り値:
セッションIDのパラメータ名（設定されていない場合null）
例外:
SessionPropertyException - セッションIDのパラメータ名の取得時に例外が発生

getSessionObjectKey

public String getSessionObjectKey()
                           throws SessionPropertyException
推奨されていません。 HttpSessionを直接取得するようにしてください。

セッションオブジェクトのキーを取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース SessionPropertyHandler 内の getSessionObjectKey
戻り値:
セッションオブジェクトのキー（設定されていない場合null）
例外:
SessionPropertyException - セッションオブジェクトのキーの取得時に例外が発生

getLoginUserIDKey

public String getLoginUserIDKey()
                         throws SessionPropertyException
セッションに登録されているログインユーザIDのキーを取得します。

定義:
インタフェース SessionPropertyHandler 内の getLoginUserIDKey
戻り値:
ログインユーザIDのキー
例外:
SessionPropertyException - 属性名の取得時に例外が発生

getLoginGroupIDKey

public String getLoginGroupIDKey()
                          throws SessionPropertyException
セッションに登録されているログイングループIDのキーを取得します。

定義:
インタフェース SessionPropertyHandler 内の getLoginGroupIDKey
戻り値:
ログイングループIDのキー
例外:
SessionPropertyException - 属性名の取得時に例外が発生

getSessionErrorPagePath

public String getSessionErrorPagePath()
                               throws SessionPropertyException
セッションエラーページのパスを取得します。

定義:
インタフェース SessionPropertyHandler 内の getSessionErrorPagePath
戻り値:
セッションエラーページのパス
例外:
SessionPropertyException - セッションエラーページのパスの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HttpSessionFactory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス HttpSessionFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.HttpSessionFactory
すべての実装インタフェース:
SessionFactory
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。

public class HttpSessionFactory
extends Object
implements SessionFactory

HTTPセッションに関連するセッションファクトリです。

バージョン:
1.0

コンストラクタの概要
HttpSessionFactory()
推奨されていません。 HttpSessionFactoryを新規に生成します。
メソッドの概要
SessionObject | createSessionObject(ServletRequest request) 推奨されていません。 セッションオブジェクトを新規に生成します。
String | encodeURL(ServletRequest request, ServletResponse response, String url) 推奨されていません。 セッションIDをエンコードしてURLに追加します。
boolean | isEncodeRequired() 推奨されていません。 セッション情報をURLに含めてエンコードする必要があるかどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HttpSessionFactory

public HttpSessionFactory()
推奨されていません。
HttpSessionFactoryを新規に生成します。

メソッドの詳細

createSessionObject

public SessionObject createSessionObject(ServletRequest request)
                                  throws SessionFactoryException
推奨されていません。
セッションオブジェクトを新規に生成します。 HttpSessionObjectを生成します。

定義:
インタフェース SessionFactory 内の createSessionObject
パラメータ:
request - リクエスト
戻り値:
セッションオブジェクト
例外:
SessionFactoryException - セッションオブジェクトの取得に失敗
関連項目:
HttpSessionObject

isEncodeRequired

public boolean isEncodeRequired()
推奨されていません。
セッション情報をURLに含めてエンコードする必要があるかどうか調べます。

定義:
インタフェース SessionFactory 内の isEncodeRequired
戻り値:
エンコードが必要な場合true、そうでない場合false

encodeURL

public String encodeURL(ServletRequest request,
                        ServletResponse response,
                        String url)
                 throws SessionFactoryException
推奨されていません。
セッションIDをエンコードしてURLに追加します。 追加される内容はセッションオブジェクトの実装に依存します。

定義:
インタフェース SessionFactory 内の encodeURL
パラメータ:
request - リクエスト
response - レスポンス
url - リクエストのURL
戻り値:
セッションIDが反映されたURL
例外:
SessionFactoryException - URLの生成時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpSessionObject (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス HttpSessionObject

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.HttpSessionObject
すべての実装インタフェース:
SessionObject
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。

public class HttpSessionObject
extends Object
implements SessionObject

HttpSessionを利用したSessionObjectです。

バージョン:
1.0

コンストラクタの概要
HttpSessionObject(HttpSession session)
推奨されていません。 HttpSessionObjectを新規に生成します。
メソッドの概要
void | clear() 推奨されていません。 セッション内に存在するすべてのオブジェクトを削除します。
Object | getAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを取得します。
Enumeration | getAttributeNames() 推奨されていません。 セッション内に存在する名前の一覧を取得します。
String | getSessionID() 推奨されていません。 セッションを一意に識別するIDを取得します。
void | removeAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを削除します。
void | setAttribute(String name, Object value) 推奨されていません。 指定された名前に対応するオブジェクトを追加します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HttpSessionObject

public HttpSessionObject(HttpSession session)
推奨されていません。
HttpSessionObjectを新規に生成します。

パラメータ:
session - HttpSession
メソッドの詳細

getSessionID

public String getSessionID()
推奨されていません。
セッションを一意に識別するIDを取得します。

定義:
インタフェース SessionObject 内の getSessionID
戻り値:
セッションを識別するID

setAttribute

public void setAttribute(String name,
                         Object value)
                  throws SessionObjectException
推奨されていません。
指定された名前に対応するオブジェクトを追加します。

定義:
インタフェース SessionObject 内の setAttribute
パラメータ:
name - オブジェクトに関連付けられる名前
value - オブジェクト
例外:
SessionObjectException - オブジェクトの追加時に例外が発生

removeAttribute

public void removeAttribute(String name)
                     throws SessionObjectException
推奨されていません。
指定された名前に対応するオブジェクトを削除します。 指定された名前で登録されていない場合、何もしません。

定義:
インタフェース SessionObject 内の removeAttribute
パラメータ:
name - オブジェクトに関連付けられる名前
例外:
SessionObjectException - オブジェクトの削除時に例外が発生

getAttribute

public Object getAttribute(String name)
                    throws SessionObjectException
推奨されていません。
指定された名前に対応するオブジェクトを取得します。 対応するオブジェクトがない場合、nullが返ります。

定義:
インタフェース SessionObject 内の getAttribute
パラメータ:
name - オブジェクトに関連付けられる名前
戻り値:
キーに対応するオブジェクト
例外:
SessionObjectException - オブジェクトの取得時に例外が発生

getAttributeNames

public Enumeration getAttributeNames()
                              throws SessionObjectException
推奨されていません。
セッション内に存在する名前の一覧を取得します。

定義:
インタフェース SessionObject 内の getAttributeNames
戻り値:
名前のコレクション
例外:
SessionObjectException - 名前の一覧取得時に例外が発生

clear

public void clear()
           throws SessionObjectException
推奨されていません。
セッション内に存在するすべてのオブジェクトを削除します。

定義:
インタフェース SessionObject 内の clear
例外:
SessionObjectException - オブジェクトの削除時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IllegalSessionException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス IllegalSessionException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.session.IllegalSessionException
すべての実装インタフェース:
Serializable
public class IllegalSessionException
extends SystemException

セッション情報取得の失敗や不正なセッションを検出した場合にスローされます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
IllegalSessionException()
詳細メッセージを指定しないで IllegalSessionException を構築します。
IllegalSessionException(String msg)
指定された詳細メッセージを持つ IllegalSessionException を構築します。
IllegalSessionException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IllegalSessionException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalSessionException

public IllegalSessionException()
詳細メッセージを指定しないで IllegalSessionException を構築します。

IllegalSessionException

public IllegalSessionException(String msg)
指定された詳細メッセージを持つ IllegalSessionException を構築します。

パラメータ:
msg - 詳細メッセージ

IllegalSessionException

public IllegalSessionException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IllegalSessionException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


IntramartSessionFactory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス IntramartSessionFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.IntramartSessionFactory
すべての実装インタフェース:
SessionFactory
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。

public class IntramartSessionFactory
extends Object
implements SessionFactory

intra-martのセッションを利用するセッションオブジェクトを生成します。 このクラスを利用するためには、intra-martをインストールする必要があります。

バージョン:
1.0

コンストラクタの概要
IntramartSessionFactory()
推奨されていません。 IntramartSessionFactoryを新規に生成します。
メソッドの概要
SessionObject | createSessionObject(ServletRequest request) 推奨されていません。 セッションオブジェクトを新規に生成します。
String | encodeURL(ServletRequest request, ServletResponse response, String url) 推奨されていません。 セッションIDをエンコードしてURLに追加します。
boolean | isEncodeRequired() 推奨されていません。 セッション情報をURLに含めてエンコードする必要があるかどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartSessionFactory

public IntramartSessionFactory()
推奨されていません。
IntramartSessionFactoryを新規に生成します。

メソッドの詳細

createSessionObject

public SessionObject createSessionObject(ServletRequest request)
                                  throws SessionFactoryException
推奨されていません。
セッションオブジェクトを新規に生成します。

定義:
インタフェース SessionFactory 内の createSessionObject
パラメータ:
request - リクエスト
戻り値:
セッションオブジェクト
例外:
SessionFactoryException - セッションオブジェクトの取得に失敗

isEncodeRequired

public boolean isEncodeRequired()
推奨されていません。
セッション情報をURLに含めてエンコードする必要があるかどうか調べます。

定義:
インタフェース SessionFactory 内の isEncodeRequired
戻り値:
エンコードが必要な場合true、そうでない場合false

encodeURL

public String encodeURL(ServletRequest request,
                        ServletResponse response,
                        String url)
                 throws SessionFactoryException
推奨されていません。
セッションIDをエンコードしてURLに追加します。 追加される内容はセッションオブジェクトの実装に依存します。

定義:
インタフェース SessionFactory 内の encodeURL
パラメータ:
request - リクエスト
response - レスポンス
url - リクエストのURL
戻り値:
セッションIDが反映されたURL
例外:
SessionFactoryException - URLの生成時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartSessionObject (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス IntramartSessionObject

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.IntramartSessionObject
すべての実装インタフェース:
SessionObject
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。

public class IntramartSessionObject
extends Object
implements SessionObject

intra-martのSessionを利用したSessionObjectです。 このクラスを利用するためには、intra-martをインストールする必要があります。

バージョン:
1.0

コンストラクタの概要
IntramartSessionObject(SessionMemory session)
推奨されていません。 IntramartSessionObjectを生成します。
メソッドの概要
void | clear() 推奨されていません。 セッション内に存在するすべてのオブジェクトを削除します。
Object | getAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを取得します。
Enumeration | getAttributeNames() 推奨されていません。 セッション内に存在する名前の一覧を取得します。
String | getSessionID() 推奨されていません。 セッションを一意に識別するIDを取得します。
void | removeAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを削除します。
void | setAttribute(String name, Object value) 推奨されていません。 指定された名前に対応するオブジェクトを追加します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartSessionObject

public IntramartSessionObject(SessionMemory session)
推奨されていません。
IntramartSessionObjectを生成します。

パラメータ:
session - intra-martの共有データオブジェクト
メソッドの詳細

getSessionID

public String getSessionID()
推奨されていません。
セッションを一意に識別するIDを取得します。

定義:
インタフェース SessionObject 内の getSessionID
戻り値:
セッションを識別するID

setAttribute

public void setAttribute(String name,
                         Object value)
                  throws SessionObjectException
推奨されていません。
指定された名前に対応するオブジェクトを追加します。

定義:
インタフェース SessionObject 内の setAttribute
パラメータ:
name - オブジェクトに関連付けられる名前
value - オブジェクト
例外:
SessionObjectException - オブジェクトの追加時に例外が発生

getAttribute

public Object getAttribute(String name)
                    throws SessionObjectException
推奨されていません。
指定された名前に対応するオブジェクトを取得します。 対応するオブジェクトがない場合、nullが返ります。

定義:
インタフェース SessionObject 内の getAttribute
パラメータ:
name - オブジェクトに関連付けられる名前
戻り値:
キーに対応するオブジェクト
例外:
SessionObjectException - オブジェクトの取得時に例外が発生

getAttributeNames

public Enumeration getAttributeNames()
                              throws SessionObjectException
推奨されていません。
セッション内に存在する名前の一覧を取得します。

定義:
インタフェース SessionObject 内の getAttributeNames
戻り値:
名前のコレクション
例外:
SessionObjectException - 名前の一覧取得時に例外が発生

removeAttribute

public void removeAttribute(String name)
                     throws SessionObjectException
推奨されていません。
指定された名前に対応するオブジェクトを削除します。 指定された名前で登録されていない場合、何もしません。

定義:
インタフェース SessionObject 内の removeAttribute
パラメータ:
name - オブジェクトに関連付けられる名前
例外:
SessionObjectException - オブジェクトの削除時に例外が発生

clear

public void clear()
           throws SessionObjectException
推奨されていません。
セッション内に存在するすべてのオブジェクトを削除します。

定義:
インタフェース SessionObject 内の clear
例外:
SessionObjectException - オブジェクトの削除時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.session (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.base.session
インタフェース
SessionFactory
SessionObject
SessionPropertyHandler
クラス
DefaultSessionPropertyHandler
HttpSessionFactory
HttpSessionObject
IntramartSessionFactory
IntramartSessionObject
SessionFilter
SessionManager
XmlSessionPropertyHandler
例外
IllegalSessionException
SessionFactoryException
SessionManagerException
SessionObjectException
SessionPropertyException


jp.co.intra_mart.framework.base.session (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.session

セッションに関連するクラスのパッケージです。

参照:
説明

インタフェースの概要
SessionFactory | セッションに関連するファクトリクラスとなるインタフェースです。
SessionObject | セッションに関連する情報を持つオブジェクトです。
SessionPropertyHandler | セッションに関連するプロパティを取得します。

クラスの概要
DefaultSessionPropertyHandler | セッションに関連するデフォルトのプロパティハンドラです。
HttpSessionFactory | 推奨されていません。 このクラスは互換性のために残されています。
HttpSessionObject | 推奨されていません。 このクラスは互換性のために残されています。
IntramartSessionFactory | 推奨されていません。 このクラスは互換性のために残されています。
IntramartSessionObject | 推奨されていません。 このクラスは互換性のために残されています。
SessionFilter | セッション管理をします。
SessionManager | セッションマネージャです。
XmlSessionPropertyHandler | セッションに関連するXMLのプロパティハンドラです。

例外の概要
IllegalSessionException | セッション情報取得の失敗や不正なセッションを検出した場合にスローされます。
SessionFactoryException | セッションファクトリ内の例外です。
SessionManagerException | セッションマネージャ内の例外です。
SessionObjectException | セッションオブジェクト内の例外です。
SessionPropertyException | セッションプロパティ取得時の例外です。

パッケージ jp.co.intra_mart.framework.base.session の説明

セッションに関連するクラスのパッケージです。


jp.co.intra_mart.framework.base.session クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.session の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler (implements jp.co.intra_mart.framework.base.session.SessionPropertyHandler)
    • class jp.co.intra_mart.framework.base.session.HttpSessionFactory (implements jp.co.intra_mart.framework.base.session.SessionFactory)
    • class jp.co.intra_mart.framework.base.session.HttpSessionObject (implements jp.co.intra_mart.framework.base.session.SessionObject)
    • class jp.co.intra_mart.framework.base.session.IntramartSessionFactory (implements jp.co.intra_mart.framework.base.session.SessionFactory)
    • class jp.co.intra_mart.framework.base.session.IntramartSessionObject (implements jp.co.intra_mart.framework.base.session.SessionObject)
    • class jp.co.intra_mart.framework.base.session.SessionFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.session.SessionManager
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.session.IllegalSessionException
            • class jp.co.intra_mart.framework.base.session.SessionFactoryException
            • class jp.co.intra_mart.framework.base.session.SessionManagerException
            • class jp.co.intra_mart.framework.base.session.SessionObjectException
            • class jp.co.intra_mart.framework.base.session.SessionPropertyException
    • class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler (implements jp.co.intra_mart.framework.base.session.SessionPropertyHandler)

インタフェース階層

  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler
  • interface jp.co.intra_mart.framework.base.session.SessionFactory
  • interface jp.co.intra_mart.framework.base.session.SessionObject


パッケージ jp.co.intra_mart.framework.base.session の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.session の使用

jp.co.intra_mart.framework.base.session を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.base.session のクラス
SessionFactoryException
セッションファクトリ内の例外です。
SessionManager
セッションマネージャです。
SessionManagerException
セッションマネージャ内の例外です。
SessionObject
セッションに関連する情報を持つオブジェクトです。
SessionPropertyException
セッションプロパティ取得時の例外です。
SessionPropertyHandler
セッションに関連するプロパティを取得します。

jp.co.intra_mart.framework.base.session により使用される jp.co.intra_mart.framework.base.session のクラス
SessionFactory
セッションに関連するファクトリクラスとなるインタフェースです。
SessionFactoryException
セッションファクトリ内の例外です。
SessionManager
セッションマネージャです。
SessionManagerException
セッションマネージャ内の例外です。
SessionObject
セッションに関連する情報を持つオブジェクトです。
SessionObjectException
セッションオブジェクト内の例外です。
SessionPropertyException
セッションプロパティ取得時の例外です。
SessionPropertyHandler
セッションに関連するプロパティを取得します。

jp.co.intra_mart.framework.base.web.bean により使用される jp.co.intra_mart.framework.base.session のクラス
SessionObject
セッションに関連する情報を持つオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SessionFactory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
インタフェース SessionFactory

既知の実装クラスの一覧:
HttpSessionFactory, IntramartSessionFactory
public interface SessionFactory

セッションに関連するファクトリクラスとなるインタフェースです。

バージョン:
1.0

メソッドの概要
SessionObject | createSessionObject(ServletRequest request) セッションオブジェクトを新規に生成します。
String | encodeURL(ServletRequest request, ServletResponse response, String url) セッションIDをエンコードしてURLに追加します。
boolean | isEncodeRequired() セッション情報をURLに含めてエンコードする必要があるかどうか調べます。

メソッドの詳細

createSessionObject

public SessionObject createSessionObject(ServletRequest request)
                                  throws SessionFactoryException
セッションオブジェクトを新規に生成します。

パラメータ:
request - リクエスト
戻り値:
セッションオブジェクト
例外:
SessionFactoryException - セッションオブジェクトの取得に失敗

isEncodeRequired

public boolean isEncodeRequired()
セッション情報をURLに含めてエンコードする必要があるかどうか調べます。

戻り値:
エンコードが必要な場合true、そうでない場合false

encodeURL

public String encodeURL(ServletRequest request,
                        ServletResponse response,
                        String url)
                 throws SessionFactoryException
セッションIDをエンコードしてURLに追加します。 追加される内容はセッションオブジェクトの実装に依存します。

パラメータ:
request - リクエスト
response - レスポンス
url - リクエストのURL
戻り値:
セッションIDが反映されたURL
例外:
SessionFactoryException - URLの生成時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SessionFactoryException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス SessionFactoryException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.session.SessionFactoryException
すべての実装インタフェース:
Serializable
public class SessionFactoryException
extends SystemException

セッションファクトリ内の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SessionFactoryException()
詳細メッセージを指定しないで SessionFactoryException を構築します。
SessionFactoryException(String msg)
指定された詳細メッセージを持つ SessionFactoryException を構築します。
SessionFactoryException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionFactoryException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SessionFactoryException

public SessionFactoryException()
詳細メッセージを指定しないで SessionFactoryException を構築します。

SessionFactoryException

public SessionFactoryException(String msg)
指定された詳細メッセージを持つ SessionFactoryException を構築します。

パラメータ:
msg - 詳細メッセージ

SessionFactoryException

public SessionFactoryException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionFactoryException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス SessionFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.SessionFilter
すべての実装インタフェース:
Filter
public class SessionFilter
extends Object
implements Filter

セッション管理をします。

バージョン:
1.0

コンストラクタの概要
SessionFilter()
メソッドの概要
void | destroy() フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) リクエストのセッション管理をします。
void | init(FilterConfig filterConfig) セッション用のフィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SessionFilter

public SessionFilter()
メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
セッション用のフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
リクエストのセッション管理をします。 SessionFactoryを利用しない場合、以下の条件がすべて満たされるときセッションが継続しているものとみなされます。
  • セッションが存在する
SessionFactoryを利用する場合、以下の条件がすべて満たされるときセッションが継続しているものとみなされます。
  • sessionにSessionPropertyHandler.getLoginUserIDKey()で指定された属性（ログインユーザID）が登録されている
  • sessionにSessionPropertyHandler.getLoginGroupIDKey()で指定された属性（ログイングループID）が登録されている

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス SessionManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.SessionManager
public class SessionManager
extends Object

セッションマネージャです。

バージョン:
1.0

フィールドの概要
static String SESSION_PROPERTY_HANDLER_KEY
セッションプロパティハンドラのキー
メソッドの概要
SessionFactory | getSessionFactory() セッションファクトリを取得します。
static SessionManager | getSessionManager() セッションマネージャを取得します。
SessionObject | getSessionObject(ServletRequest request) セッションオブジェクトを取得します。
SessionPropertyHandler | getSessionPropertyHandler() セッションプロパティハンドラを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

SESSION_PROPERTY_HANDLER_KEY

public static final String SESSION_PROPERTY_HANDLER_KEY
セッションプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getSessionManager

public static SessionManager getSessionManager()
                                        throws SessionManagerException
セッションマネージャを取得します。

戻り値:
セッションマネージャ
例外:
SessionManagerException - セッションマネージャの生成に失敗した

getSessionPropertyHandler

public SessionPropertyHandler getSessionPropertyHandler()
セッションプロパティハンドラを取得します。

戻り値:
セッションプロパティハンドラ

getSessionFactory

public SessionFactory getSessionFactory()
セッションファクトリを取得します。 セッションプロパティにSessionFactoryが指定されていない場合、nullが返ります。

戻り値:
セッションファクトリ（プロパティが設定されていない場合null）

getSessionObject

public SessionObject getSessionObject(ServletRequest request)
                               throws SessionPropertyException,
                                      SessionFactoryException
セッションオブジェクトを取得します。 指定されたリクエスト内にあるセッションオブジェクトを取得します。 セッションが存在しない場合、新規にセッションを生成します。 このメソッドはセッションプロパティにSessionFactoryを指定したときに有効になります。

パラメータ:
request - リクエスト
戻り値:
セッションオブジェクト
例外:
SessionPropertyException - セッションプロパティの取得に失敗
SessionFactoryException - セッションオブジェクトの生成に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionManagerException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス SessionManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.session.SessionManagerException
すべての実装インタフェース:
Serializable
public class SessionManagerException
extends SystemException

セッションマネージャ内の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SessionManagerException()
詳細メッセージを指定しないで SessionManagerException を構築します。
SessionManagerException(String msg)
指定された詳細メッセージを持つ SessionManagerException を構築します。
SessionManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SessionManagerException

public SessionManagerException()
詳細メッセージを指定しないで SessionManagerException を構築します。

SessionManagerException

public SessionManagerException(String msg)
指定された詳細メッセージを持つ SessionManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

SessionManagerException

public SessionManagerException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionObject (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
インタフェース SessionObject

既知の実装クラスの一覧:
HttpSessionObject, IntramartSessionObject
public interface SessionObject

セッションに関連する情報を持つオブジェクトです。 セッション管理の方法に応じてこのインタフェースを実装してください。

バージョン:
1.0

メソッドの概要
void | clear() セッション内に存在するすべてのオブジェクトを削除します。
Object | getAttribute(String name) 指定された名前に対応するオブジェクトを取得します。
Enumeration | getAttributeNames() セッション内に存在する名前の一覧を取得します。
String | getSessionID() セッションを一意に識別するIDを取得します。
void | removeAttribute(String name) 指定された名前に対応するオブジェクトを削除します。
void | setAttribute(String name, Object value) 指定された名前に対応するオブジェクトを追加します。

メソッドの詳細

getSessionID

public String getSessionID()
セッションを一意に識別するIDを取得します。

戻り値:
セッションを識別するID

setAttribute

public void setAttribute(String name,
                         Object value)
                  throws SessionObjectException
指定された名前に対応するオブジェクトを追加します。

パラメータ:
name - オブジェクトに関連付けられる名前
value - オブジェクト
例外:
SessionObjectException - オブジェクトの追加時に例外が発生

getAttribute

public Object getAttribute(String name)
                    throws SessionObjectException
指定された名前に対応するオブジェクトを取得します。 対応するオブジェクトがない場合、nullが返ります。

パラメータ:
name - オブジェクトに関連付けられる名前
戻り値:
キーに対応するオブジェクト
例外:
SessionObjectException - オブジェクトの取得時に例外が発生

removeAttribute

public void removeAttribute(String name)
                     throws SessionObjectException
指定された名前に対応するオブジェクトを削除します。 指定された名前で登録されていない場合、何もしません。

パラメータ:
name - オブジェクトに関連付けられる名前
例外:
SessionObjectException - オブジェクトの削除時に例外が発生

getAttributeNames

public Enumeration getAttributeNames()
                              throws SessionObjectException
セッション内に存在する名前の一覧を取得します。

戻り値:
名前のコレクション
例外:
SessionObjectException - 名前の一覧取得時に例外が発生

clear

public void clear()
           throws SessionObjectException
セッション内に存在するすべてのオブジェクトを削除します。

例外:
SessionObjectException - オブジェクトの削除時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionObjectException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス SessionObjectException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.session.SessionObjectException
すべての実装インタフェース:
Serializable
public class SessionObjectException
extends SystemException

セッションオブジェクト内の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SessionObjectException()
詳細メッセージを指定しないで SessionObjectException を構築します。
SessionObjectException(String msg)
指定された詳細メッセージを持つ SessionObjectException を構築します。
SessionObjectException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionObjectException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SessionObjectException

public SessionObjectException()
詳細メッセージを指定しないで SessionObjectException を構築します。

SessionObjectException

public SessionObjectException(String msg)
指定された詳細メッセージを持つ SessionObjectException を構築します。

パラメータ:
msg - 詳細メッセージ

SessionObjectException

public SessionObjectException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionObjectException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionPropertyException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス SessionPropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.session.SessionPropertyException
すべての実装インタフェース:
Serializable
public class SessionPropertyException
extends SystemException

セッションプロパティ取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SessionPropertyException()
詳細メッセージを指定しないで SessionPropertyException を構築します。
SessionPropertyException(String msg)
指定された詳細メッセージを持つ SessionPropertyException を構築します。
SessionPropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionPropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SessionPropertyException

public SessionPropertyException()
詳細メッセージを指定しないで SessionPropertyException を構築します。

SessionPropertyException

public SessionPropertyException(String msg)
指定された詳細メッセージを持つ SessionPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

SessionPropertyException

public SessionPropertyException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SessionPropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
インタフェース SessionPropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultSessionPropertyHandler, XmlSessionPropertyHandler
public interface SessionPropertyHandler
extends PropertyHandler

セッションに関連するプロパティを取得します。

バージョン:
1.0

メソッドの概要
String | getLoginGroupIDKey() セッションに登録されているログイングループIDのキーを取得します。
String | getLoginUserIDKey() セッションに登録されているログインユーザIDのキーを取得します。
String | getSessionErrorPagePath() セッションエラーページのパスを取得します。
String | getSessionFactoryName() 推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
String | getSessionObjectKey() 推奨されていません。 HttpSessionを直接取得するようにしてください。
String | getSessionParameter() 推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

getSessionObjectKey

public String getSessionObjectKey()
                           throws SessionPropertyException
推奨されていません。 HttpSessionを直接取得するようにしてください。

セッションオブジェクトのキーを取得します。 何も設定されていない場合nullが返ります。

戻り値:
セッションオブジェクトのキー
例外:
SessionPropertyException - セッションオブジェクトのキーの取得時に例外が発生

getSessionParameter

public String getSessionParameter()
                           throws SessionPropertyException
推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。

セッションIDのパラメータ名を取得します。 何も設定されていない場合nullが返ります。

戻り値:
セッションIDのパラメータ名
例外:
SessionPropertyException - セッションIDのパラメータ名の取得時に例外が発生

getSessionFactoryName

public String getSessionFactoryName()
                             throws SessionPropertyException
推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。

セッションファクトリのクラス名を取得します。 何も設定されていない場合nullが返ります。

戻り値:
セッションファクトリのクラス名
例外:
SessionPropertyException - セッションファクトリのクラス名の取得時に例外が発生

getLoginUserIDKey

public String getLoginUserIDKey()
                         throws SessionPropertyException
セッションに登録されているログインユーザIDのキーを取得します。

戻り値:
ログインユーザIDのキー
例外:
SessionPropertyException - 属性名の取得時に例外が発生

getLoginGroupIDKey

public String getLoginGroupIDKey()
                          throws SessionPropertyException
セッションに登録されているログイングループIDのキーを取得します。

戻り値:
ログイングループIDのキー
例外:
SessionPropertyException - 属性名の取得時に例外が発生

getSessionErrorPagePath

public String getSessionErrorPagePath()
                               throws SessionPropertyException
セッションエラーページのパスを取得します。

戻り値:
セッションエラーページのパス
例外:
SessionPropertyException - セッションエラーページのパスの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


XmlSessionPropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス XmlSessionPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler
すべての実装インタフェース:
PropertyHandler, SessionPropertyHandler
public class XmlSessionPropertyHandler
extends Object
implements SessionPropertyHandler

セッションに関連するXMLのプロパティハンドラです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのxmlファイル名
static String | DEFAULT_BUNDLE_NAME_PARAM xmlファイル名のパラメータ名
コンストラクタの概要
XmlSessionPropertyHandler()
メソッドの概要
String | getLoginGroupIDKey() セッションに登録されているログイングループIDのキーを取得します。
String | getLoginUserIDKey() セッションに登録されているログインユーザIDのキーを取得します。
String | getSessionErrorPagePath() セッションエラーページのパスを取得します。
String | getSessionFactoryName() 推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
String | getSessionObjectKey() 推奨されていません。 HttpSessionを直接取得するようにしてください。
String | getSessionParameter() 推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのxmlファイル名

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
xmlファイル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

XmlSessionPropertyHandler

public XmlSessionPropertyHandler()
メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

getSessionFactoryName

public String getSessionFactoryName()
                             throws SessionPropertyException
推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。

セッションファクトリのクラス名を取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース SessionPropertyHandler 内の getSessionFactoryName
戻り値:
セッションファクトリのクラス名（設定されていない場合null）
例外:
SessionPropertyException - セッションファクトリのクラス名の取得時に例外が発生

getSessionParameter

public String getSessionParameter()
                           throws SessionPropertyException
推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。

セッションIDのパラメータ名を取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース SessionPropertyHandler 内の getSessionParameter
戻り値:
セッションIDのパラメータ名（設定されていない場合null）
例外:
SessionPropertyException - セッションパラメータ取得時に例外が発生

getSessionObjectKey

public String getSessionObjectKey()
                           throws SessionPropertyException
推奨されていません。 HttpSessionを直接取得するようにしてください。

セッションオブジェクトのキーを取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース SessionPropertyHandler 内の getSessionObjectKey
戻り値:
セッションオブジェクトのキー（設定されていない場合null）
例外:
SessionPropertyException - セッションオブジェクトキー取得時に例外が発生

getLoginUserIDKey

public String getLoginUserIDKey()
                         throws SessionPropertyException
セッションに登録されているログインユーザIDのキーを取得します。

定義:
インタフェース SessionPropertyHandler 内の getLoginUserIDKey
戻り値:
ログインユーザIDのキー
例外:
SessionPropertyException - 属性名の取得時に例外が発生

getLoginGroupIDKey

public String getLoginGroupIDKey()
                          throws SessionPropertyException
セッションに登録されているログイングループIDのキーを取得します。

定義:
インタフェース SessionPropertyHandler 内の getLoginGroupIDKey
戻り値:
ログイングループIDのキー
例外:
SessionPropertyException - 属性名の取得時に例外が発生

getSessionErrorPagePath

public String getSessionErrorPagePath()
                               throws SessionPropertyException
セッションエラーページのパスを取得します。

定義:
インタフェース SessionPropertyHandler 内の getSessionErrorPagePath
戻り値:
セッションエラーページのパス
例外:
SessionPropertyException - セッションエラーページのパスの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.base.util.ConfigurationUserInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.util.ConfigurationUserInfo の使用

jp.co.intra_mart.framework.base.util.ConfigurationUserInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.util.EmptyUserInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.util.EmptyUserInfo の使用

jp.co.intra_mart.framework.base.util.EmptyUserInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.util.UserInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.util.UserInfo の使用

UserInfo を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.common.util | im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.seasar.util |
jp.co.intra_mart.framework.extension.struts.action | im-J2EE FrameworkとStrutsを連携するためのユーティリティです。

jp.co.intra_mart.framework.base.event での UserInfo の使用

UserInfo を返す jp.co.intra_mart.framework.base.event のメソッド
 UserInfo Event.getUserInfo()
ログインユーザの情報を取得します。

UserInfo 型のパラメータを持つ jp.co.intra_mart.framework.base.event のメソッド
 Event EventManager.createEvent(String application, String key, UserInfo info)
パラメータで指定された内容に該当するイベントを生成します。

jp.co.intra_mart.framework.base.service での UserInfo の使用

UserInfo を返す jp.co.intra_mart.framework.base.service のメソッド
 UserInfo ServiceControllerAdapter.getUserInfo()
ユーザ情報を取得します。

jp.co.intra_mart.framework.base.util での UserInfo の使用

UserInfo を実装している jp.co.intra_mart.framework.base.util のクラス
class | ConfigurationUserInfo 情報を自由に設定可能なUserInfoです。
class | EmptyUserInfo 情報を何も持たないUserInfoです。
class | UserInfoWrapper UserInfoを拡張するための実装です。

UserInfo を返す jp.co.intra_mart.framework.base.util のメソッド
protected UserInfo | UserInfoWrapper.getRealUserInfo() このオブジェクトがラップしているUserInfoの実装を返します。
static UserInfo | UserInfoUtil.createUserInfo(HttpServletRequest request, HttpServletResponse response) intra-martのセッション情報からUserInfoを新規に生成します。

UserInfo 型のパラメータを持つ jp.co.intra_mart.framework.base.util のメソッド
protected  void UserInfoWrapper.setRealUserInfo(UserInfo userInfo)
このオブジェクトがラップするUserInfoの実装を設定します。

jp.co.intra_mart.framework.base.web.bean での UserInfo の使用

UserInfo を返す jp.co.intra_mart.framework.base.web.bean のメソッド
 UserInfo HelperBean.getUserInfo()
ログインユーザ情報を取得します。

jp.co.intra_mart.framework.extension.common.util での UserInfo の使用

UserInfo を返す jp.co.intra_mart.framework.extension.common.util のメソッド
static UserInfo ServiceUtils.getUserInfo(HttpServletRequest request, HttpServletResponse response)
ユーザ情報を取得します。

jp.co.intra_mart.framework.extension.seasar.util での UserInfo の使用

UserInfo を実装している jp.co.intra_mart.framework.extension.seasar.util のクラス
 class AutoDetectedUserInfo
セッションからログイン情報を取得するUserInfoのラッパークラスです。

UserInfo を返す jp.co.intra_mart.framework.extension.seasar.util のメソッド
protected  UserInfo AutoDetectedUserInfo.getRealUserInfo()
このオブジェクトがラップしているUserInfoの実装を返します。

jp.co.intra_mart.framework.extension.struts.action での UserInfo の使用

UserInfo を返す jp.co.intra_mart.framework.extension.struts.action のメソッド
protected  UserInfo IntramartAction.getUserInfo(HttpServletRequest request, HttpServletResponse response)
ユーザ情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.util.UserInfoException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.util.UserInfoException の使用

UserInfoException を使用しているパッケージ
jp.co.intra_mart.framework.base.util

jp.co.intra_mart.framework.base.util での UserInfoException の使用

UserInfoException をスローする jp.co.intra_mart.framework.base.util のメソッド
static UserInfo UserInfoUtil.createUserInfo(HttpServletRequest request, HttpServletResponse response)
intra-martのセッション情報からUserInfoを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.util.UserInfoUtil の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.util.UserInfoUtil の使用

jp.co.intra_mart.framework.base.util.UserInfoUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.util.UserInfoWrapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.util.UserInfoWrapper の使用

UserInfoWrapper を使用しているパッケージ
jp.co.intra_mart.framework.extension.seasar.util

jp.co.intra_mart.framework.extension.seasar.util での UserInfoWrapper の使用

jp.co.intra_mart.framework.extension.seasar.util での UserInfoWrapper のサブクラス
 class AutoDetectedUserInfo
セッションからログイン情報を取得するUserInfoのラッパークラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ConfigurationUserInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.util
クラス ConfigurationUserInfo

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.util.ConfigurationUserInfo
すべての実装インタフェース:
Serializable, UserInfo
public class ConfigurationUserInfo
extends Object
implements UserInfo, Serializable

情報を自由に設定可能なUserInfoです。
アクセスセキュリティと連動したユーザ情報が必要ではない場合、このクラスを利用して 任意のUserInfoを生成することが可能です。
バッチ処理などログインセッションに依存しない環境でのイベント実行時にも利用可能です。

 ConfigurationUserInfo info = new ConfigurationUserInfo();
 info.setUserID("user_id");
 info.setLoginGroupID("group_id");

 EventManager manager = EventManager.getEventManager();
 FooEvent event = (FooEvent)manager.createEvent("foo", "bar", info);
 event.doSomething();

 manager.dispatch(event);
アクセスセキュリティと連動したユーザ情報が必要な場合は UserInfoUtil.createUserInfo(HttpServletRequest, HttpServletResponse) を使用してください。

導入されたバージョン:
5.0.5
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ConfigurationUserInfo()
メソッドの概要
String | getClientType() クライアントタイプを取得する。
String | getColorPatternID() カラーパターンIDを取得する。
String | getEncoding() エンコーディングを取得する。
Locale | getLocale() ユーザのロケールを取得する。
String | getLoginGroupID() ログイングループIDを取得する。
Date | getLoginTime() ログインした時間を取得する。
String | getLoginType() ログインタイプを取得する。
String | getUserID() ログインユーザIDを取得する。
void | setClientType(String clientType) クライアントタイプを設定する。
void | setColorPatternID(String colorPatternID) カラーパターンIDを設定する。
void | setEncoding(String encoding) エンコーディングを設定する。
void | setLocale(Locale locale) ユーザのロケールを設定する。
void | setLoginGroupID(String loginGroupID) ログイングループIDを設定する。
void | setLoginTime(Date loginTime) ログインした時間を設定する。
void | setLoginType(String loginType) ログインタイプを設定する。
void | setUserID(String userID) ログインユーザIDを設定する。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ConfigurationUserInfo

public ConfigurationUserInfo()
メソッドの詳細

getClientType

public String getClientType()
クライアントタイプを取得する。
値が未設定の場合は空文字列を返却します。

定義:
インタフェース UserInfo 内の getClientType
戻り値:
クライアントタイプ

setClientType

public void setClientType(String clientType)
クライアントタイプを設定する。

パラメータ:
clientType - クライアントタイプ

getColorPatternID

public String getColorPatternID()
カラーパターンIDを取得する。
値が未設定の場合は空文字列を返却します。

定義:
インタフェース UserInfo 内の getColorPatternID
戻り値:
カラーパターンID

setColorPatternID

public void setColorPatternID(String colorPatternID)
カラーパターンIDを設定する。

パラメータ:
colorPatternID - カラーパターンID

getEncoding

public String getEncoding()
エンコーディングを取得する。
値が未設定の場合は空文字列を返却します。

定義:
インタフェース UserInfo 内の getEncoding
戻り値:
エンコーディング

setEncoding

public void setEncoding(String encoding)
エンコーディングを設定する。

パラメータ:
encoding - エンコーディング

getLocale

public Locale getLocale()
ユーザのロケールを取得する。 値が未設定の場合はnullを返却します。

定義:
インタフェース UserInfo 内の getLocale
戻り値:
ロケール

setLocale

public void setLocale(Locale locale)
ユーザのロケールを設定する。

パラメータ:
locale - ロケール

getLoginGroupID

public String getLoginGroupID()
ログイングループIDを取得する。
値が未設定の場合は空文字列を返却します。

定義:
インタフェース UserInfo 内の getLoginGroupID
戻り値:
ログイングループID

setLoginGroupID

public void setLoginGroupID(String loginGroupID)
ログイングループIDを設定する。

パラメータ:
loginGroupID - ログイングループID

getLoginTime

public Date getLoginTime()
ログインした時間を取得する。
値が未設定の場合はnullを返却します。

定義:
インタフェース UserInfo 内の getLoginTime
戻り値:
ログイン時間

setLoginTime

public void setLoginTime(Date loginTime)
ログインした時間を設定する。

パラメータ:
loginTime - ログインした時間

getLoginType

public String getLoginType()
ログインタイプを取得する。
値が未設定の場合はUserInfoUtil.LT_USERを返却します。

定義:
インタフェース UserInfo 内の getLoginType
戻り値:
ログインタイプ
関連項目:
UserInfoUtil.LT_SUPER, UserInfoUtil.LT_GROUP, UserInfoUtil.LT_USER

setLoginType

public void setLoginType(String loginType)
ログインタイプを設定する。

パラメータ:
loginType - ログインタイプ

getUserID

public String getUserID()
ログインユーザIDを取得する。
値が未設定の場合は空文字列を返却します。

定義:
インタフェース UserInfo 内の getUserID
戻り値:
ログインユーザID

setUserID

public void setUserID(String userID)
ログインユーザIDを設定する。

パラメータ:
userID - ログインユーザID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EmptyUserInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.util
クラス EmptyUserInfo

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.util.EmptyUserInfo
すべての実装インタフェース:
Serializable, UserInfo
public class EmptyUserInfo
extends Object
implements UserInfo, Serializable

情報を何も持たないUserInfoです。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EmptyUserInfo()
メソッドの概要
String | getClientType() クライアントタイプを取得する。
String | getColorPatternID() カラーパターンIDを取得する。
String | getEncoding() エンコーディングを取得する。
Locale | getLocale() ユーザのロケールを取得する。
String | getLoginGroupID() ログイングループIDを取得する。
Date | getLoginTime() ログインした時間を取得する。
String | getLoginType() ログインタイプを取得する。
String | getUserID() ログインユーザIDを取得する。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EmptyUserInfo

public EmptyUserInfo()
メソッドの詳細

getClientType

public String getClientType()
クライアントタイプを取得する。
このメソッドは常に空文字列を返却します。

定義:
インタフェース UserInfo 内の getClientType
戻り値:
クライアントタイプ

getColorPatternID

public String getColorPatternID()
カラーパターンIDを取得する。
このメソッドは常に空文字列を返却します。

定義:
インタフェース UserInfo 内の getColorPatternID
戻り値:
カラーパターンID

getEncoding

public String getEncoding()
エンコーディングを取得する。
このメソッドは常に空文字列を返却します。

定義:
インタフェース UserInfo 内の getEncoding
戻り値:
エンコーディング

getLocale

public Locale getLocale()
ユーザのロケールを取得する。 このメソッドは常にnullを返却します。

定義:
インタフェース UserInfo 内の getLocale
戻り値:
ロケール

getLoginGroupID

public String getLoginGroupID()
ログイングループIDを取得する。
このメソッドは常に空文字列を返却します。

定義:
インタフェース UserInfo 内の getLoginGroupID
戻り値:
ログイングループID

getLoginTime

public Date getLoginTime()
ログインした時間を取得する。
このメソッドは常にnullを返却します。

定義:
インタフェース UserInfo 内の getLoginTime
戻り値:
ログイン時間

getLoginType

public String getLoginType()
ログインタイプを取得する。
このメソッドは常にUserInfoUtil.LT_USERを返却します。

定義:
インタフェース UserInfo 内の getLoginType
戻り値:
ログインタイプ
関連項目:
UserInfoUtil.LT_SUPER, UserInfoUtil.LT_GROUP, UserInfoUtil.LT_USER

getUserID

public String getUserID()
ログインユーザIDを取得する。 このメソッドは常に空文字列を返却します。

定義:
インタフェース UserInfo 内の getUserID
戻り値:
ログインユーザID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.util (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.base.util
インタフェース
UserInfo
クラス
ConfigurationUserInfo
EmptyUserInfo
UserInfoUtil
UserInfoWrapper
例外
UserInfoException


jp.co.intra_mart.framework.base.util (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.util

インタフェースの概要
UserInfo ログインユーザの情報を管理します。

クラスの概要
ConfigurationUserInfo | 情報を自由に設定可能なUserInfoです。
EmptyUserInfo | 情報を何も持たないUserInfoです。
UserInfoUtil | ログインユーザの情報に関するユーティリティクラスです。
UserInfoWrapper | UserInfoを拡張するための実装です。

例外の概要
UserInfoException ユーザ情報に関連する例外です。


jp.co.intra_mart.framework.base.util クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo (implements java.io.Serializable, jp.co.intra_mart.framework.base.util.UserInfo)
    • class jp.co.intra_mart.framework.base.util.EmptyUserInfo (implements java.io.Serializable, jp.co.intra_mart.framework.base.util.UserInfo)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.util.UserInfoException
    • class jp.co.intra_mart.framework.base.util.UserInfoUtil
    • class jp.co.intra_mart.framework.base.util.UserInfoWrapper (implements jp.co.intra_mart.framework.base.util.UserInfo)

インタフェース階層

  • interface java.io.Serializable
    • interface jp.co.intra_mart.framework.base.util.UserInfo


パッケージ jp.co.intra_mart.framework.base.util の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.util の使用

jp.co.intra_mart.framework.base.util を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.common.util | im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.seasar.util |
jp.co.intra_mart.framework.extension.struts.action | im-J2EE FrameworkとStrutsを連携するためのユーティリティです。

jp.co.intra_mart.framework.base.event により使用される jp.co.intra_mart.framework.base.util のクラス
UserInfo
ログインユーザの情報を管理します。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.base.util のクラス
UserInfo
ログインユーザの情報を管理します。

jp.co.intra_mart.framework.base.util により使用される jp.co.intra_mart.framework.base.util のクラス
UserInfo
ログインユーザの情報を管理します。
UserInfoException
ユーザ情報に関連する例外です。

jp.co.intra_mart.framework.base.web.bean により使用される jp.co.intra_mart.framework.base.util のクラス
UserInfo
ログインユーザの情報を管理します。

jp.co.intra_mart.framework.extension.common.util により使用される jp.co.intra_mart.framework.base.util のクラス
UserInfo
ログインユーザの情報を管理します。

jp.co.intra_mart.framework.extension.seasar.util により使用される jp.co.intra_mart.framework.base.util のクラス
UserInfo
ログインユーザの情報を管理します。
UserInfoWrapper
UserInfoを拡張するための実装です。

jp.co.intra_mart.framework.extension.struts.action により使用される jp.co.intra_mart.framework.base.util のクラス
UserInfo
ログインユーザの情報を管理します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


UserInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.util
インタフェース UserInfo

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
ConfigurationUserInfo, EmptyUserInfo, UserInfoWrapper
public interface UserInfo
extends Serializable

ログインユーザの情報を管理します。 イントラマートにアクセスしたクライアント情報をラップしたオブジェクトです。
このオブジェクトは通常UserInfoUtil.createUserInfo(HttpServletRequest, HttpServletResponse) から生成されます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
UserInfoUtil

メソッドの概要
String | getClientType() クライアントタイプを取得する。
String | getColorPatternID() カラーパターンIDを取得する。
String | getEncoding() エンコーディングを取得する。
Locale | getLocale() ユーザのロケールを取得する。
String | getLoginGroupID() ログイングループIDを取得する。
Date | getLoginTime() ログインした時間を取得する。
String | getLoginType() ログインタイプを取得する。
String | getUserID() ログインユーザIDを取得する。

メソッドの詳細

getClientType

public String getClientType()
クライアントタイプを取得する。
セッション情報にクライアントタイプが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
クライアントタイプ

getColorPatternID

public String getColorPatternID()
カラーパターンIDを取得する。
セッション情報にログインユーザIDが存在しない場合、および空文字列の場合はデフォルトのカラーパターンIDを返却する。

戻り値:
カラーパターンID

getEncoding

public String getEncoding()
エンコーディングを取得する。
セッション情報にエンコーディングが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
エンコーディング

getLocale

public Locale getLocale()
ユーザのロケールを取得する。
セッション情報にロケールが存在しない場合、および空文字列の場合はnullを返却する。

戻り値:
ロケール

getLoginGroupID

public String getLoginGroupID()
ログイングループIDを取得する。
セッション情報にログイングループIDが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
ログイングループID

getLoginTime

public Date getLoginTime()
ログインした時間を取得する。
セッション情報にログイン時間が存在しない場合、nullを返却する。

戻り値:
ログイン時間

getLoginType

public String getLoginType()
ログインタイプを取得する。
セッション情報にログインタイプが存在しない場合、および空文字列の場合は UserInfoUtil.LT_USER を返却する。

戻り値:
ログインタイプ
関連項目:
UserInfoUtil.LT_SUPER, UserInfoUtil.LT_GROUP, UserInfoUtil.LT_USER

getUserID

public String getUserID()
ログインユーザIDを取得する。
セッション情報にログインユーザIDが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
ログインユーザID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UserInfoException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.util
クラス UserInfoException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.util.UserInfoException
すべての実装インタフェース:
Serializable
public class UserInfoException
extends SystemException

ユーザ情報に関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
UserInfoException()
詳細メッセージを指定しないで UserInfoException を構築します。
UserInfoException(String msg)
指定された詳細メッセージを持つ UserInfoException を構築します。
UserInfoException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ UserInfoException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UserInfoException

public UserInfoException()
詳細メッセージを指定しないで UserInfoException を構築します。

UserInfoException

public UserInfoException(String msg)
指定された詳細メッセージを持つ UserInfoException を構築します。

パラメータ:
msg - 詳細メッセージ

UserInfoException

public UserInfoException(String msg,
                         Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ UserInfoException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UserInfoUtil (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.util
クラス UserInfoUtil

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.util.UserInfoUtil
public class UserInfoUtil
extends Object

ログインユーザの情報に関するユーティリティクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String | LT_GROUP グループマネージャ
static String | LT_SUPER スーパーユーザ
static String | LT_USER ユーザ
メソッドの概要
static UserInfo createUserInfo(HttpServletRequest request, HttpServletResponse response)
intra-martのセッション情報からUserInfoを新規に生成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

LT_SUPER

public static final String LT_SUPER
スーパーユーザ

関連項目:
定数フィールド値

LT_GROUP

public static final String LT_GROUP
グループマネージャ

関連項目:
定数フィールド値

LT_USER

public static final String LT_USER
ユーザ

関連項目:
定数フィールド値
メソッドの詳細

createUserInfo

public static UserInfo createUserInfo(HttpServletRequest request,
                                      HttpServletResponse response)
                               throws UserInfoException
intra-martのセッション情報からUserInfoを新規に生成します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ログインユーザの情報
例外:
UserInfoException - UserInfo生成時に例外が発生。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserInfoWrapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.util
クラス UserInfoWrapper

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.util.UserInfoWrapper
すべての実装インタフェース:
Serializable, UserInfo
直系の既知のサブクラス:
AutoDetectedUserInfo
public class UserInfoWrapper
extends Object
implements UserInfo

UserInfoを拡張するための実装です。 デフォルトではEmptyUserInfoをラップします。

導入されたバージョン:
6.0
関連項目:
直列化された形式

フィールドの概要
static Class BLANK_USER_INFO
デフォルトでラップされているクラスです。
コンストラクタの概要
UserInfoWrapper()
UserInfoWrapperを新規に生成します。
メソッドの概要
String | getClientType() ラップされたUserInfoのgetClientType()を呼び出します。
String | getColorPatternID() ラップされたUserInfoのgetColorPatternID()を呼び出します。
String | getEncoding() ラップされたUserInfoのgetEncoding()を呼び出します。
Locale | getLocale() ラップされたUserInfoのgetLocale()を呼び出します。
String | getLoginGroupID() ラップされたUserInfoのgetLoginGroupID()を呼び出します。
Date | getLoginTime() ラップされたUserInfoのgetLoginTime()を呼び出します。
String | getLoginType() ラップされたUserInfoのgetLoginType()を呼び出します。
protected UserInfo | getRealUserInfo() このオブジェクトがラップしているUserInfoの実装を返します。
String | getUserID() ラップされたUserInfoのgetUserID()を呼び出します。
protected void | setRealUserInfo(UserInfo userInfo) このオブジェクトがラップするUserInfoの実装を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

BLANK_USER_INFO

public static Class BLANK_USER_INFO
デフォルトでラップされているクラスです。

コンストラクタの詳細

UserInfoWrapper

public UserInfoWrapper()
UserInfoWrapperを新規に生成します。

メソッドの詳細

setRealUserInfo

protected void setRealUserInfo(UserInfo userInfo)
このオブジェクトがラップするUserInfoの実装を設定します。

パラメータ:
userInfo - UserInfoの実装

getRealUserInfo

protected UserInfo getRealUserInfo()
このオブジェクトがラップしているUserInfoの実装を返します。

戻り値:
UserInfoの実装

getClientType

public String getClientType()
ラップされたUserInfoのgetClientType()を呼び出します。

定義:
インタフェース UserInfo 内の getClientType
戻り値:
クライアントタイプ

getColorPatternID

public String getColorPatternID()
ラップされたUserInfoのgetColorPatternID()を呼び出します。

定義:
インタフェース UserInfo 内の getColorPatternID
戻り値:
カラーパターンID

getEncoding

public String getEncoding()
ラップされたUserInfoのgetEncoding()を呼び出します。

定義:
インタフェース UserInfo 内の getEncoding
戻り値:
エンコーディング

getLocale

public Locale getLocale()
ラップされたUserInfoのgetLocale()を呼び出します。

定義:
インタフェース UserInfo 内の getLocale
戻り値:
ロケール

getLoginGroupID

public String getLoginGroupID()
ラップされたUserInfoのgetLoginGroupID()を呼び出します。

定義:
インタフェース UserInfo 内の getLoginGroupID
戻り値:
ログイングループID

getLoginTime

public Date getLoginTime()
ラップされたUserInfoのgetLoginTime()を呼び出します。

定義:
インタフェース UserInfo 内の getLoginTime
戻り値:
ログインした時間

getLoginType

public String getLoginType()
ラップされたUserInfoのgetLoginType()を呼び出します。

定義:
インタフェース UserInfo 内の getLoginType
戻り値:
ログインタイプ
関連項目:
UserInfoUtil.LT_SUPER, UserInfoUtil.LT_GROUP, UserInfoUtil.LT_USER

getUserID

public String getUserID()
ラップされたUserInfoのgetUserID()を呼び出します。

定義:
インタフェース UserInfo 内の getUserID
戻り値:
ログインユーザID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean の使用

jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.bean.HelperBean の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.bean.HelperBean の使用

HelperBean を使用しているパッケージ
jp.co.intra_mart.framework.base.web.bean JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.web.bean での HelperBean の使用

jp.co.intra_mart.framework.base.web.bean での HelperBean のサブクラス
 class ErrorHelperBean
例外ページで使用するHelperBeanです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.bean.HelperBeanException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.bean.HelperBeanException の使用

HelperBeanException を使用しているパッケージ
jp.co.intra_mart.framework.base.web.bean JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.web.bean での HelperBeanException の使用

HelperBeanException をスローする jp.co.intra_mart.framework.base.web.bean のメソッド
 void HelperBean.init()
HelperBeanを初期化します。
 SessionObject HelperBean.getSession()
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
 String HelperBean.getLoginUserID()
推奨されていません。 このメソッドではなくHelperBean.getUserInfo()を使用してください。
 String HelperBean.getLoginGroupID()
推奨されていません。 このメソッドではなくHelperBean.getUserInfo()を使用してください。
 UserInfo HelperBean.getUserInfo()
ログインユーザ情報を取得します。
protected  Event HelperBean.createEvent(String application, String key)
アプリケーションIDとキーに対応するイベントを取得します。
 Throwable ErrorHelperBean.getException()
例外を取得します。

HelperBeanException をスローする jp.co.intra_mart.framework.base.web.bean のコンストラクタ
HelperBean()
HelperBeanを新規に生成します。
ErrorHelperBean()
ErrorHelperBeanを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ErrorHelperBean (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.bean
クラス ErrorHelperBean

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.bean.HelperBean
        拡張 jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean
すべての実装インタフェース:
Serializable
public class ErrorHelperBean
extends HelperBean

例外ページで使用するHelperBeanです。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ErrorHelperBean()
ErrorHelperBeanを新規に生成します。
メソッドの概要
 Throwable getException()
例外を取得します。
クラス jp.co.intra_mart.framework.base.web.bean.HelperBean から継承したメソッド
createEvent, dispatchEvent, getLoginGroupID, getLoginUserID, getRequest, getResponse, getServicePropertyHandler, getSession, getUserInfo, init, setRequest, setResponse
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ErrorHelperBean

public ErrorHelperBean()
                throws HelperBeanException
ErrorHelperBeanを新規に生成します。

例外:
HelperBeanException - ErrorHelperBean生成時に例外が発生
メソッドの詳細

getException

public Throwable getException()
                       throws HelperBeanException
例外を取得します。

戻り値:
例外
例外:
HelperBeanException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HelperBean (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.bean
クラス HelperBean

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.bean.HelperBean
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ErrorHelperBean
public abstract class HelperBean
extends Object
implements Serializable

画面表示をする時のヘルパークラスです。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
HelperBean()
HelperBeanを新規に生成します。
メソッドの概要
protected Event | createEvent(String application, String key) アプリケーションIDとキーに対応するイベントを取得します。
protected EventResult | dispatchEvent(Event event) イベント処理を実行します。
String | getLoginGroupID() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
String | getLoginUserID() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
HttpServletRequest | getRequest() リクエストを取得します。
HttpServletResponse | getResponse() レスポンスを取得します。
ServicePropertyHandler | getServicePropertyHandler() サービスプロパティハンドラを取得します。
SessionObject | getSession() 推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
UserInfo | getUserInfo() ログインユーザ情報を取得します。
void | init() HelperBeanを初期化します。
void | setRequest(HttpServletRequest request) リクエストを設定します。
void | setResponse(HttpServletResponse response) レスポンスを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HelperBean

public HelperBean()
           throws HelperBeanException
HelperBeanを新規に生成します。

例外:
HelperBeanException - HelperBean生成時に例外が発生
メソッドの詳細

init

public void init()
          throws HelperBeanException
HelperBeanを初期化します。

例外:
HelperBeanException - 初期化時に例外が発生
導入されたバージョン:
3.2

setRequest

public void setRequest(HttpServletRequest request)
リクエストを設定します。

パラメータ:
request - リクエスト

getRequest

public HttpServletRequest getRequest()
リクエストを取得します。

戻り値:
リクエスト

setResponse

public void setResponse(HttpServletResponse response)
レスポンスを設定します。

パラメータ:
response - レスポンス

getResponse

public HttpServletResponse getResponse()
レスポンスを取得します。

戻り値:
レスポンス

getSession

public SessionObject getSession()
                         throws HelperBeanException
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

セッションオブジェクトを取得します。 このメソッドはセッションプロパティにSessionFactoryとSessionObjectKeyを指定したときに有効になります。

戻り値:
セッションオブジェクト
例外:
HelperBeanException - セッションオブジェクト取得時に例外が発生

getLoginUserID

public String getLoginUserID()
                      throws HelperBeanException
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログインユーザIDを取得します。

戻り値:
ログインユーザID
例外:
HelperBeanException - ログインユーザID取得時に例外が発生
導入されたバージョン:
3.2

getLoginGroupID

public String getLoginGroupID()
                       throws HelperBeanException
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログイングループIDを取得します。

戻り値:
ログイングループID
例外:
HelperBeanException - ログイングループID取得時に例外が発生
導入されたバージョン:
3.2

getUserInfo

public UserInfo getUserInfo()
                     throws HelperBeanException
ログインユーザ情報を取得します。
ログインセッションが存在しない場合はnullを返却します。

戻り値:
ログインユーザ情報
例外:
ServiceControllerException - ログインユーザ情報取得時に例外が発生
HelperBeanException
導入されたバージョン:
5.0

createEvent

protected Event createEvent(String application,
                            String key)
                     throws HelperBeanException
アプリケーションIDとキーに対応するイベントを取得します。 イベントにはログイン時のログイングループIDが自動的に登録されます。

パラメータ:
application - アプリケーションID
key - キー
戻り値:
イベント
例外:
HelperBeanException - イベント生成時に例外が発生

dispatchEvent

protected EventResult dispatchEvent(Event event)
                             throws EventException,
                                    SystemException,
                                    ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventException - イベント処理時に例外が発生
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生

getServicePropertyHandler

public ServicePropertyHandler getServicePropertyHandler()
サービスプロパティハンドラを取得します。

戻り値:
サービスプロパティハンドラ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HelperBeanException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.bean
クラス HelperBeanException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.web.bean.HelperBeanException
すべての実装インタフェース:
Serializable
public class HelperBeanException
extends SystemException

HelperBean内で発生した例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
HelperBeanException()
詳細メッセージを指定しないで HelperBeanException を構築します。
HelperBeanException(String msg)
指定された詳細メッセージを持つ HelperBeanException を構築します。
HelperBeanException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ HelperBeanException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HelperBeanException

public HelperBeanException()
詳細メッセージを指定しないで HelperBeanException を構築します。

HelperBeanException

public HelperBeanException(String msg)
指定された詳細メッセージを持つ HelperBeanException を構築します。

パラメータ:
msg - 詳細メッセージ

HelperBeanException

public HelperBeanException(String msg,
                           Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ HelperBeanException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.web.bean (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.base.web.bean
クラス
ErrorHelperBean
HelperBean
例外
HelperBeanException


jp.co.intra_mart.framework.base.web.bean (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.bean

JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

参照:
説明

クラスの概要
ErrorHelperBean | 例外ページで使用するHelperBeanです。
HelperBean | 画面表示をする時のヘルパークラスです。

例外の概要
HelperBeanException HelperBean内で発生した例外です。

パッケージ jp.co.intra_mart.framework.base.web.bean の説明

JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。


jp.co.intra_mart.framework.base.web.bean クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.bean の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.web.bean.HelperBean (implements java.io.Serializable)
      • class jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.web.bean.HelperBeanException


パッケージ jp.co.intra_mart.framework.base.web.bean の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.web.bean の使用

jp.co.intra_mart.framework.base.web.bean を使用しているパッケージ
jp.co.intra_mart.framework.base.web.bean JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.web.bean により使用される jp.co.intra_mart.framework.base.web.bean のクラス
HelperBean
画面表示をする時のヘルパークラスです。
HelperBeanException
HelperBean内で発生した例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes の使用

jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes の使用

jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes の使用

GenericAttributes を使用しているパッケージ
jp.co.intra_mart.framework.base.web.tag.attribute タグ属性のパッケージです。

jp.co.intra_mart.framework.base.web.tag.attribute での GenericAttributes の使用

jp.co.intra_mart.framework.base.web.tag.attribute での GenericAttributes のサブクラス
class | CoreAttributes コア属性です。
class | EventsAttributes ブラウザのイベントに関連するタグの属性情報です。
class | I18nAttributes 国際化の属性です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes の使用

jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CoreAttributes (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag.attribute
クラス CoreAttributes

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes
        拡張 jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes
public class CoreAttributes
extends GenericAttributes

コア属性です。

バージョン:
1.0

コンストラクタの概要
CoreAttributes()
CoreAttributesを新規に生成します。
メソッドの概要
String | getStyle() 属性styleの値を取得します。
String | getTagClass() 属性classの値を取得します。
String | getTitle() 属性titleの値を取得します。
void | printAttributes() 属性の内容を表示します。
void | setStyle(String style) 属性styleの値を設定します。
void | setTagClass(String tagClass) 属性classの値を設定します。
void | setTitle(String title) 属性titleの値を設定します。
クラス jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes から継承したメソッド
getTagWriter, setTagWriter
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CoreAttributes

public CoreAttributes()
CoreAttributesを新規に生成します。

メソッドの詳細

getTagClass

public String getTagClass()
属性classの値を取得します。

戻り値:
class

setTagClass

public void setTagClass(String tagClass)
属性classの値を設定します。

パラメータ:
tagClass - class

getStyle

public String getStyle()
属性styleの値を取得します。

戻り値:
style

setStyle

public void setStyle(String style)
属性styleの値を設定します。

パラメータ:
style - style

getTitle

public String getTitle()
属性titleの値を取得します。

戻り値:
title

setTitle

public void setTitle(String title)
属性titleの値を設定します。

パラメータ:
title - title

printAttributes

public void printAttributes()
                     throws IOException
属性の内容を表示します。

定義:
クラス GenericAttributes 内の printAttributes
例外:
IOException - 出力中に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventsAttributes (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag.attribute
クラス EventsAttributes

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes
        拡張 jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes
public class EventsAttributes
extends GenericAttributes

ブラウザのイベントに関連するタグの属性情報です。

バージョン:
1.0

コンストラクタの概要
EventsAttributes()
EventsAttributesを新規に生成します。
メソッドの概要
String | getOnClick() 属性onClickの値を取得します。
String | getOnDblClick() 属性onDblClickの値を取得します。
String | getOnKeyDown() 属性onKeyDownの値を取得します。
String | getOnKeyPress() 属性onKeyPressの値を取得します。
String | getOnKeyUp() 属性onKeyUpの値を取得します。
String | getOnMouseDown() 属性onMouseDownの値を取得します。
String | getOnMouseMove() 属性onMouseMoveの値を取得します。
String | getOnMouseOut() 属性onMouseOutの値を取得します。
String | getOnMouseOver() 属性onMouseOverの値を取得します。
String | getOnMouseUp() 属性onMouseUpの値を取得します。
void | printAttributes() 属性の内容を表示します。
protected void | printOnClick() 属性onClickを出力します。
protected void | printOnDblClick() 属性onDblClickを出力します。
protected void | printOnKeyDown() 属性onKeyDownを出力します。
protected void | printOnKeyPress() 属性onKeyPressを出力します。
protected void | printOnKeyUp() 属性onKeyUpを出力します。
protected void | printOnMouseDown() 属性onMouseDownを出力します。
protected void | printOnMouseMove() 属性onMouseMoveを出力します。
protected void | printOnMouseOut() 属性onMouseOutを出力します。
protected void | printOnMouseOver() 属性onMouseOverを出力します。
protected void | printOnMouseUp() 属性onMouseUpを出力します。
void | setOnClick(String onClick) 属性onClickの値を設定します。
void | setOnDblClick(String onDblClick) 属性obDblClickの値を設定します。
void | setOnKeyDown(String onKeyDown) 属性onKeyDownの値を設定します。
void | setOnKeyPress(String onKeyPress) 属性onKeyPressの値を設定します。
void | setOnKeyUp(String onKeyUp) 属性onKeyUpの値を設定します。
void | setOnMouseDown(String onMouseDown) 属性onMouseDownの値を設定します。
void | setOnMouseMove(String onMouseMove) 属性onMouseMoveの値を設定します。
void | setOnMouseOut(String onMouseOut) 属性onMouseOutの値を設定します。
void | setOnMouseOver(String onMouseOver) 属性onMouseOverの値を設定します。
void | setOnMouseUp(String onMouseUp) 属性onMouseUpの値を設定します。
クラス jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes から継承したメソッド
getTagWriter, setTagWriter
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventsAttributes

public EventsAttributes()
EventsAttributesを新規に生成します。

メソッドの詳細

getOnClick

public String getOnClick()
属性onClickの値を取得します。

戻り値:
onClick

setOnClick

public void setOnClick(String onClick)
属性onClickの値を設定します。

パラメータ:
onClick - onClick

getOnDblClick

public String getOnDblClick()
属性onDblClickの値を取得します。

戻り値:
onDblClick

setOnDblClick

public void setOnDblClick(String onDblClick)
属性obDblClickの値を設定します。

パラメータ:
onDblClick - onDblClick

getOnMouseDown

public String getOnMouseDown()
属性onMouseDownの値を取得します。

戻り値:
onMouseDown

setOnMouseDown

public void setOnMouseDown(String onMouseDown)
属性onMouseDownの値を設定します。

パラメータ:
onMouseDown - onMouseDown

getOnMouseUp

public String getOnMouseUp()
属性onMouseUpの値を取得します。

戻り値:
onMouseUp

setOnMouseUp

public void setOnMouseUp(String onMouseUp)
属性onMouseUpの値を設定します。

パラメータ:
onMouseUp - onMouseUp

getOnMouseOver

public String getOnMouseOver()
属性onMouseOverの値を取得します。

戻り値:
onMouseOver

setOnMouseOver

public void setOnMouseOver(String onMouseOver)
属性onMouseOverの値を設定します。

パラメータ:
onMouseOver - onMouseOver

getOnMouseMove

public String getOnMouseMove()
属性onMouseMoveの値を取得します。

戻り値:
onMouseMove

setOnMouseMove

public void setOnMouseMove(String onMouseMove)
属性onMouseMoveの値を設定します。

パラメータ:
onMouseMove - onMouseMove

getOnMouseOut

public String getOnMouseOut()
属性onMouseOutの値を取得します。

戻り値:
onMouseOut

setOnMouseOut

public void setOnMouseOut(String onMouseOut)
属性onMouseOutの値を設定します。

パラメータ:
onMouseOut - onMouseOut

getOnKeyPress

public String getOnKeyPress()
属性onKeyPressの値を取得します。

戻り値:
onKeyPress

setOnKeyPress

public void setOnKeyPress(String onKeyPress)
属性onKeyPressの値を設定します。

パラメータ:
onKeyPress - onKeyPress

getOnKeyDown

public String getOnKeyDown()
属性onKeyDownの値を取得します。

戻り値:
onKeyDown

setOnKeyDown

public void setOnKeyDown(String onKeyDown)
属性onKeyDownの値を設定します。

パラメータ:
onKeyDown - onKeyDown

getOnKeyUp

public String getOnKeyUp()
属性onKeyUpの値を取得します。

戻り値:
onKeyUp

setOnKeyUp

public void setOnKeyUp(String onKeyUp)
属性onKeyUpの値を設定します。

パラメータ:
onKeyUp - onKeyUp

printOnClick

protected void printOnClick()
                     throws IOException
属性onClickを出力します。

例外:
IOException - 出力中に例外が発生

printOnDblClick

protected void printOnDblClick()
                        throws IOException
属性onDblClickを出力します。

例外:
IOException - 出力中に例外が発生

printOnMouseDown

protected void printOnMouseDown()
                         throws IOException
属性onMouseDownを出力します。

例外:
IOException - 出力中に例外が発生

printOnMouseUp

protected void printOnMouseUp()
                       throws IOException
属性onMouseUpを出力します。

例外:
IOException - 出力中に例外が発生

printOnMouseOver

protected void printOnMouseOver()
                         throws IOException
属性onMouseOverを出力します。

例外:
IOException - 出力中に例外が発生

printOnMouseMove

protected void printOnMouseMove()
                         throws IOException
属性onMouseMoveを出力します。

例外:
IOException - 出力中に例外が発生

printOnMouseOut

protected void printOnMouseOut()
                        throws IOException
属性onMouseOutを出力します。

例外:
IOException - 出力中に例外が発生

printOnKeyPress

protected void printOnKeyPress()
                        throws IOException
属性onKeyPressを出力します。

例外:
IOException - 出力中に例外が発生

printOnKeyDown

protected void printOnKeyDown()
                       throws IOException
属性onKeyDownを出力します。

例外:
IOException - 出力中に例外が発生

printOnKeyUp

protected void printOnKeyUp()
                     throws IOException
属性onKeyUpを出力します。

例外:
IOException - 出力中に例外が発生

printAttributes

public void printAttributes()
                     throws IOException
属性の内容を表示します。

定義:
クラス GenericAttributes 内の printAttributes
例外:
IOException - 出力中に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericAttributes (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag.attribute
クラス GenericAttributes

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes
直系の既知のサブクラス:
CoreAttributes, EventsAttributes, I18nAttributes
public abstract class GenericAttributes
extends Object

汎用属性の集合です。

バージョン:
1.0

コンストラクタの概要
GenericAttributes()
GenericAttributesを新規に生成します。
メソッドの概要
TagWriter | getTagWriter() TagWriterを取得します。
abstract void | printAttributes() 属性の内容を表示します。
void | setTagWriter(TagWriter writer) TagWriterを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericAttributes

public GenericAttributes()
GenericAttributesを新規に生成します。

メソッドの詳細

getTagWriter

public TagWriter getTagWriter()
TagWriterを取得します。

戻り値:
TagWriter

setTagWriter

public void setTagWriter(TagWriter writer)
TagWriterを設定します。

パラメータ:
writer - TagWriter

printAttributes

public abstract void printAttributes()
                              throws IOException
属性の内容を表示します。

例外:
IOException - 出力中に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


I18nAttributes (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag.attribute
クラス I18nAttributes

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes
        拡張 jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes
public class I18nAttributes
extends GenericAttributes

国際化の属性です。

バージョン:
1.0

コンストラクタの概要
I18nAttributes()
I18nAttributesを新規に生成します。
メソッドの概要
String | getDir() 属性dirの値を取得します。
String | getLang() 属性langの値を取得します。
void | printAttributes() 属性の内容を表示します。
void | setDir(String dir) 属性dirの値を取得します。
void | setLang(String lang) 属性langの値を設定します。
クラス jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes から継承したメソッド
getTagWriter, setTagWriter
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

I18nAttributes

public I18nAttributes()
I18nAttributesを新規に生成します。

メソッドの詳細

getLang

public String getLang()
属性langの値を取得します。

戻り値:
lang

setLang

public void setLang(String lang)
属性langの値を設定します。

パラメータ:
lang - lang

getDir

public String getDir()
属性dirの値を取得します。

戻り値:
dir

setDir

public void setDir(String dir)
属性dirの値を取得します。

パラメータ:
dir - dir

printAttributes

public void printAttributes()
                     throws IOException
属性の内容を表示します。

定義:
クラス GenericAttributes 内の printAttributes
例外:
IOException - 出力中に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.web.tag.attribute (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.base.web.tag.attribute
クラス
CoreAttributes
EventsAttributes
GenericAttributes
I18nAttributes


jp.co.intra_mart.framework.base.web.tag.attribute (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.tag.attribute

タグ属性のパッケージです。

参照:
説明

クラスの概要
CoreAttributes | コア属性です。
EventsAttributes | ブラウザのイベントに関連するタグの属性情報です。
GenericAttributes | 汎用属性の集合です。
I18nAttributes | 国際化の属性です。

パッケージ jp.co.intra_mart.framework.base.web.tag.attribute の説明

タグ属性のパッケージです。


jp.co.intra_mart.framework.base.web.tag.attribute クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.tag.attribute の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes
      • class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes
      • class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes
      • class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes


パッケージ jp.co.intra_mart.framework.base.web.tag.attribute の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.web.tag.attribute の使用

jp.co.intra_mart.framework.base.web.tag.attribute を使用しているパッケージ
jp.co.intra_mart.framework.base.web.tag.attribute タグ属性のパッケージです。

jp.co.intra_mart.framework.base.web.tag.attribute により使用される jp.co.intra_mart.framework.base.web.tag.attribute のクラス
GenericAttributes
汎用属性の集合です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.FormTag の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FormTag の使用

jp.co.intra_mart.framework.base.web.tag.FormTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo の使用

jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.FormTEI の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FormTEI の使用

jp.co.intra_mart.framework.base.web.tag.FormTEI はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.FrameTag の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FrameTag の使用

jp.co.intra_mart.framework.base.web.tag.FrameTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo の使用

jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.FrameTEI の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FrameTEI の使用

jp.co.intra_mart.framework.base.web.tag.FrameTEI はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.FrameworkTagException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FrameworkTagException の使用

jp.co.intra_mart.framework.base.web.tag.FrameworkTagException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam の使用

jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.HelperBeanTag の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.HelperBeanTag の使用

jp.co.intra_mart.framework.base.web.tag.HelperBeanTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo の使用

jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI の使用

jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.LinkTag の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.LinkTag の使用

jp.co.intra_mart.framework.base.web.tag.LinkTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo の使用

jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.LinkTEI の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.LinkTEI の使用

jp.co.intra_mart.framework.base.web.tag.LinkTEI はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.MessageParamTag の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.MessageParamTag の使用

jp.co.intra_mart.framework.base.web.tag.MessageParamTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.MessageTag の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.MessageTag の使用

jp.co.intra_mart.framework.base.web.tag.MessageTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.MessageTEI の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.MessageTEI の使用

jp.co.intra_mart.framework.base.web.tag.MessageTEI はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.web.tag.ParameterSendable の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.web.tag.ParameterSendable の使用

ParameterSendable を使用しているパッケージ
jp.co.intra_mart.framework.base.web.tag J2EEフレームワークで使用する各種のタグのパッケージです。

jp.co.intra_mart.framework.base.web.tag での ParameterSendable の使用

ParameterSendable を実装している jp.co.intra_mart.framework.base.web.tag のクラス
class | FrameTag FRAMEタグです。
class | LinkTag LINKタグです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.ParamTag の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.ParamTag の使用

jp.co.intra_mart.framework.base.web.tag.ParamTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag の使用

jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo の使用

jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.SubmitTag の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.SubmitTag の使用

jp.co.intra_mart.framework.base.web.tag.SubmitTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo の使用

jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.SubmitTEI の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.SubmitTEI の使用

jp.co.intra_mart.framework.base.web.tag.SubmitTEI はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.TagWriter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.TagWriter の使用

TagWriter を使用しているパッケージ
jp.co.intra_mart.framework.base.web.tag.attribute タグ属性のパッケージです。

jp.co.intra_mart.framework.base.web.tag.attribute での TagWriter の使用

TagWriter を返す jp.co.intra_mart.framework.base.web.tag.attribute のメソッド
 TagWriter GenericAttributes.getTagWriter()
TagWriterを取得します。

TagWriter 型のパラメータを持つ jp.co.intra_mart.framework.base.web.tag.attribute のメソッド
 void GenericAttributes.setTagWriter(TagWriter writer)
TagWriterを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


FormTag (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FormTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.FormTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class FormTag
extends BodyTagSupport

FORMタグです。 intra-martフレームワークを使用する場合のセッションフレームワーク、サービスフレームワークの一部となります。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
FormTag()
FormTagを新規に生成します。
メソッドの概要
int | doEndTag() 終了タグを検知したときにJSPエンジンから呼ばれます。
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getAccept() 属性acceptの値を取得します。
String | getAcceptcharset() 属性accept-charsetの値を取得します。
String | getApplication() 属性applicationの値を取得します。
String | getDir() 属性dirの値を取得します。
String | getEnctype() 属性enctypeの値を取得します。
String | getFormclass() 属性classの値を取得します。
String | getLang() 属性langの値を取得します。
String | getMethod() 属性methodの値を取得します。
String | getName() 属性nameの値を取得します。
String | getOnclick() 属性onClickの値を取得します。
String | getOndblclick() 属性onDblClickの値を取得します。
String | getOnkeydown() 属性onKeyDownの値を取得します。
String | getOnkeypress() 属性onKeyPressの値を取得します。
String | getOnkeyup() 属性onKeyUpの値を取得します。
String | getOnmousedown() 属性onMouseDownの値を取得します。
String | getOnmousemove() 属性onMouseMoveの値を取得します。
String | getOnmouseout() 属性onMouseOutの値を取得します。
String | getOnmouseover() 属性onMouseOverの値を取得します。
String | getOnmouseup() 属性onMouseUpの値を取得します。
String | getOnreset() 属性onResetの値を取得します。
String | getOnsubmit() 属性onSubmitの値を取得します。
String | getService() 属性serviceの値を取得します。
String | getStyle() 属性styleの値を取得します。
String | getTarget() 属性targetの値を取得します。
String | getTitle() 属性titleの値を取得します。
void | setAccept(String accept) 属性acceptの値を設定します。
void | setAcceptcharset(String acceptCharset) 属性accept-charsetの値を設定します。
void | setApplication(String application) 属性applicationの値を設定します。
void | setDir(String dir) 属性dirの値を設定します。
void | setEnctype(String enctype) 属性enctypeの値を設定します。
void | setFormclass(String formClass) 属性classの値を設定します。
void | setLang(String lang) 属性langの値を設定します。
void | setMethod(String method) 属性methodの値を設定します。
void | setName(String name) 属性nameの値を設定します。
void | setOnclick(String onClick) 属性onClickの値を設定します。
void | setOndblclick(String onDblClick) 属性obDblClickの値を設定します。
void | setOnkeydown(String onKeyDown) 属性onKeyDownの値を設定します。
void | setOnkeypress(String onKeyPress) 属性onKeyPressの値を設定します。
void | setOnkeyup(String onKeyUp) 属性onKeyUpの値を設定します。
void | setOnmousedown(String onMouseDown) 属性onMouseDownの値を設定します。
void | setOnmousemove(String onMouseMove) 属性onMouseMoveの値を設定します。
void | setOnmouseout(String onMouseOut) 属性onMouseOutの値を設定します。
void | setOnmouseover(String onMouseOver) 属性onMouseOverの値を設定します。
void | setOnmouseup(String onMouseUp) 属性onMouseUpの値を設定します。
void | setOnreset(String onReset) 属性onResetの値を設定します。
void | setOnsubmit(String onSubmit) 属性onSubmitの値を設定します。
void | setService(String service) 属性serviceの値を設定します。
void | setStyle(String style) 属性styleの値を設定します。
void | setTarget(String target) 属性targetの値を設定します。
void | setTitle(String title) 属性titleの値を設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

FormTag

public FormTag()
FormTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 FORMタグを解釈します。

戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - タグの解釈時に例外が発生

doEndTag

public int doEndTag()
             throws JspException
終了タグを検知したときにJSPエンジンから呼ばれます。 FORMタグを終了します。

戻り値:
EVAL_PAGE
例外:
JspException - タグの終了時に例外が発生

getApplication

public String getApplication()
属性applicationの値を取得します。

戻り値:
アプリケーション

setApplication

public void setApplication(String application)
属性applicationの値を設定します。

パラメータ:
application - アプリケーション

getService

public String getService()
属性serviceの値を取得します。

戻り値:
サービス

setService

public void setService(String service)
属性serviceの値を設定します。

パラメータ:
service - サービス

getMethod

public String getMethod()
属性methodの値を取得します。

戻り値:
method

setMethod

public void setMethod(String method)
属性methodの値を設定します。

パラメータ:
method - method

getEnctype

public String getEnctype()
属性enctypeの値を取得します。

戻り値:
enctype

getTarget

public String getTarget()
属性targetの値を取得します。

戻り値:
target

setTarget

public void setTarget(String target)
属性targetの値を設定します。

パラメータ:
target - target

setEnctype

public void setEnctype(String enctype)
属性enctypeの値を設定します。

パラメータ:
enctype - enctype

getAccept

public String getAccept()
属性acceptの値を取得します。

戻り値:
accept

setAccept

public void setAccept(String accept)
属性acceptの値を設定します。

パラメータ:
accept - accept

getName

public String getName()
属性nameの値を取得します。

戻り値:
name

setName

public void setName(String name)
属性nameの値を設定します。

パラメータ:
name - name

getOnsubmit

public String getOnsubmit()
属性onSubmitの値を取得します。

戻り値:
onSubmit

setOnsubmit

public void setOnsubmit(String onSubmit)
属性onSubmitの値を設定します。

パラメータ:
onSubmit - onSubmit

getOnreset

public String getOnreset()
属性onResetの値を取得します。

戻り値:
onReset

setOnreset

public void setOnreset(String onReset)
属性onResetの値を設定します。

パラメータ:
onReset - onReset

getAcceptcharset

public String getAcceptcharset()
属性accept-charsetの値を取得します。

戻り値:
accept-charset

setAcceptcharset

public void setAcceptcharset(String acceptCharset)
属性accept-charsetの値を設定します。

パラメータ:
acceptCharset - accept-charset

getFormclass

public String getFormclass()
属性classの値を取得します。

戻り値:
class

setFormclass

public void setFormclass(String formClass)
属性classの値を設定します。

パラメータ:
formClass - class

getStyle

public String getStyle()
属性styleの値を取得します。

戻り値:
style

setStyle

public void setStyle(String style)
属性styleの値を設定します。

パラメータ:
style - style

getTitle

public String getTitle()
属性titleの値を取得します。

戻り値:
title

setTitle

public void setTitle(String title)
属性titleの値を設定します。

パラメータ:
title - title

getLang

public String getLang()
属性langの値を取得します。

戻り値:
lang

setLang

public void setLang(String lang)
属性langの値を設定します。

パラメータ:
lang - lang

getDir

public String getDir()
属性dirの値を取得します。

戻り値:
dir

setDir

public void setDir(String dir)
属性dirの値を設定します。

パラメータ:
dir - dir

getOnclick

public String getOnclick()
属性onClickの値を取得します。

戻り値:
onClick

setOnclick

public void setOnclick(String onClick)
属性onClickの値を設定します。

パラメータ:
onClick - onClick

getOndblclick

public String getOndblclick()
属性onDblClickの値を取得します。

戻り値:
onDblClick

setOndblclick

public void setOndblclick(String onDblClick)
属性obDblClickの値を設定します。

パラメータ:
onDblClick - onDblClick

getOnmousedown

public String getOnmousedown()
属性onMouseDownの値を取得します。

戻り値:
onMouseDown

setOnmousedown

public void setOnmousedown(String onMouseDown)
属性onMouseDownの値を設定します。

パラメータ:
onMouseDown - onMouseDown

getOnmouseup

public String getOnmouseup()
属性onMouseUpの値を取得します。

戻り値:
onMouseUp

setOnmouseup

public void setOnmouseup(String onMouseUp)
属性onMouseUpの値を設定します。

パラメータ:
onMouseUp - onMouseUp

getOnmouseover

public String getOnmouseover()
属性onMouseOverの値を取得します。

戻り値:
onMouseOver

setOnmouseover

public void setOnmouseover(String onMouseOver)
属性onMouseOverの値を設定します。

パラメータ:
onMouseOver - onMouseOver

getOnmousemove

public String getOnmousemove()
属性onMouseMoveの値を取得します。

戻り値:
onMouseMove

setOnmousemove

public void setOnmousemove(String onMouseMove)
属性onMouseMoveの値を設定します。

パラメータ:
onMouseMove - onMouseMove

getOnmouseout

public String getOnmouseout()
属性onMouseOutの値を取得します。

戻り値:
onMouseOut

setOnmouseout

public void setOnmouseout(String onMouseOut)
属性onMouseOutの値を設定します。

パラメータ:
onMouseOut - onMouseOut

getOnkeypress

public String getOnkeypress()
属性onKeyPressの値を取得します。

戻り値:
onKeyPress

setOnkeypress

public void setOnkeypress(String onKeyPress)
属性onKeyPressの値を設定します。

パラメータ:
onKeyPress - onKeyPress

getOnkeydown

public String getOnkeydown()
属性onKeyDownの値を取得します。

戻り値:
onKeyDown

setOnkeydown

public void setOnkeydown(String onKeyDown)
属性onKeyDownの値を設定します。

パラメータ:
onKeyDown - onKeyDown

getOnkeyup

public String getOnkeyup()
属性onKeyUpの値を取得します。

戻り値:
onKeyUp

setOnkeyup

public void setOnkeyup(String onKeyUp)
属性onKeyUpの値を設定します。

パラメータ:
onKeyUp - onKeyUp
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


FormTagBeanInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FormTagBeanInfo

java.lang.Object
    拡張 java.beans.SimpleBeanInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo
すべての実装インタフェース:
BeanInfo
public class FormTagBeanInfo
extends SimpleBeanInfo

FormTagのBeanInfoです。

導入されたバージョン:
4.0

フィールドの概要
インタフェース java.beans.BeanInfo から継承したフィールド
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
コンストラクタの概要
FormTagBeanInfo()
FormTagBeanInfoを新規に生成します。
メソッドの概要
 PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。
クラス java.beans.SimpleBeanInfo から継承したメソッド
getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, loadImage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FormTagBeanInfo

public FormTagBeanInfo()
FormTagBeanInfoを新規に生成します。

メソッドの詳細

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。

戻り値:
PropertyDescriptor
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FormTEI (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FormTEI

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagExtraInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.FormTEI
public class FormTEI
extends TagExtraInfo

Formタグの拡張情報です。

導入されたバージョン:
4.0

コンストラクタの概要
FormTEI()
FormTEIを新規に生成します。
メソッドの概要
 boolean isValid(TagData tagData)
Formタグに指定された内容の正当性を検証します。
クラス javax.servlet.jsp.tagext.TagExtraInfo から継承したメソッド
getTagInfo, getVariableInfo, setTagInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FormTEI

public FormTEI()
FormTEIを新規に生成します。

メソッドの詳細

isValid

public boolean isValid(TagData tagData)
Formタグに指定された内容の正当性を検証します。 検証内容は以下のとおりです。
  • class属性またはformclass属性がある場合、いずれかのみが設定されている
  • acceptcharset属性またはaccept-charset属性がある場合、いずれかのみが設定されている

パラメータ:
tagData - タグ情報
戻り値:
タグが正当な場合true、それ以外の場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FrameTag (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FrameTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.FrameTag
すべての実装インタフェース:
BodyTag, IterationTag, ParameterSendable, Serializable, Tag
public class FrameTag
extends BodyTagSupport
implements ParameterSendable

FRAMEタグです。 intra-martフレームワークを使用する場合のセッションフレームワーク、サービスフレームワークの一部となります。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
FrameTag()
FrameTagを新規に生成します。
メソッドの概要
void | addParameter(String name, String value) パラメータを追加します。
int | doEndTag() 終了タグを検知したときにJSPエンジンから呼ばれます。
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getApplication() アプリケーションを取得します。
String | getFrameborder() frameborderを取得します。
String | getFrameclass() frameClassを取得します。
String | getFrameClass() 推奨されていません。 このメソッドではなくgetFrameclass()メソッドを使用してください。
String | getLongdesc() longdescを取得します。
String | getMarginheight() marginheightを取得します。
String | getMarginwidth() marginwidthを取得します。
String | getName() nameを取得します。
String | getNoresize() noresizeを取得します。
String | getScrolling() scrollingを取得します。
String | getService() サービスを取得します。
String | getStyle() styleを取得します。
String | getTitle() titleを取得します。
void | setApplication(String application) アプリケーションを設定します。
void | setFrameborder(String frameborder) frameborderを設定します。
void | setFrameclass(String frameClass) frameClassを設定します。
void | setFrameClass(String frameClass) 推奨されていません。 このメソッドではなくsetFrameclass(String)メソッドを使用してください。
void | setLongdesc(String longdesc) longdescを設定します。
void | setMarginheight(String marginheight) marginheightを設定します。
void | setMarginwidth(String marginwidth) marginwidthを設定します。
void | setName(String name) nameを設定します。
void | setNoresize(String noresize) noresizeを設定します。
void | setScrolling(String scrolling) scrollingを設定します。
void | setService(String service) serviceを設定します。
void | setStyle(String style) styleを設定します。
void | setTitle(String title) titleを設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

FrameTag

public FrameTag()
FrameTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 FRAMEタグを解釈します。

定義:
インタフェース Tag 内の doStartTag
戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - タグの解釈時に例外が発生

doEndTag

public int doEndTag()
             throws JspException
終了タグを検知したときにJSPエンジンから呼ばれます。 FRAMEタグを終了します。

定義:
インタフェース Tag 内の doEndTag
戻り値:
EVAL_PAGE
例外:
JspException - タグの終了時に例外が発生

addParameter

public void addParameter(String name,
                         String value)
パラメータを追加します。

定義:
インタフェース ParameterSendable 内の addParameter
パラメータ:
name - パラメータ名
value - パラメータの値

getApplication

public String getApplication()
アプリケーションを取得します。

戻り値:
アプリケーション

setApplication

public void setApplication(String application)
アプリケーションを設定します。

パラメータ:
application - アプリケーション

getService

public String getService()
サービスを取得します。

戻り値:
サービス

setService

public void setService(String service)
serviceを設定します。

パラメータ:
service - サービス

getLongdesc

public String getLongdesc()
longdescを取得します。

戻り値:
longdesc

setLongdesc

public void setLongdesc(String longdesc)
longdescを設定します。

パラメータ:
longdesc - longdesc

getName

public String getName()
nameを取得します。

戻り値:
name

setName

public void setName(String name)
nameを設定します。

パラメータ:
name - name

getFrameborder

public String getFrameborder()
frameborderを取得します。

戻り値:
frameborder

setFrameborder

public void setFrameborder(String frameborder)
frameborderを設定します。

パラメータ:
frameborder - frameborder

getMarginwidth

public String getMarginwidth()
marginwidthを取得します。

戻り値:
marginwidth

setMarginwidth

public void setMarginwidth(String marginwidth)
marginwidthを設定します。

パラメータ:
marginwidth - marginwidth

getMarginheight

public String getMarginheight()
marginheightを取得します。

戻り値:
marginheight

setMarginheight

public void setMarginheight(String marginheight)
marginheightを設定します。

パラメータ:
marginheight - marginheight

getNoresize

public String getNoresize()
noresizeを取得します。

戻り値:
noresize

setNoresize

public void setNoresize(String noresize)
noresizeを設定します。

パラメータ:
noresize - noresize

getScrolling

public String getScrolling()
scrollingを取得します。

戻り値:
scrolling

setScrolling

public void setScrolling(String scrolling)
scrollingを設定します。

パラメータ:
scrolling - scrolling

getFrameClass

public String getFrameClass()
推奨されていません。 このメソッドではなくgetFrameclass()メソッドを使用してください。

frameClassを取得します。

戻り値:
frameClass

setFrameClass

public void setFrameClass(String frameClass)
推奨されていません。 このメソッドではなくsetFrameclass(String)メソッドを使用してください。

frameClassを設定します。

パラメータ:
frameClass - frameClass

getFrameclass

public String getFrameclass()
frameClassを取得します。

戻り値:
frameClass

setFrameclass

public void setFrameclass(String frameClass)
frameClassを設定します。

パラメータ:
frameClass - frameClass

getStyle

public String getStyle()
styleを取得します。

戻り値:
style

setStyle

public void setStyle(String style)
styleを設定します。

パラメータ:
style - style

getTitle

public String getTitle()
titleを取得します。

戻り値:
title

setTitle

public void setTitle(String title)
titleを設定します。

パラメータ:
title - title
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FrameTagBeanInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FrameTagBeanInfo

java.lang.Object
    拡張 java.beans.SimpleBeanInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo
すべての実装インタフェース:
BeanInfo
public class FrameTagBeanInfo
extends SimpleBeanInfo

FrameTagのBeanInfoです。

導入されたバージョン:
4.0

フィールドの概要
インタフェース java.beans.BeanInfo から継承したフィールド
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
コンストラクタの概要
FrameTagBeanInfo()
FrameTagBeanInfoを新規に生成します。
メソッドの概要
 PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。
クラス java.beans.SimpleBeanInfo から継承したメソッド
getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, loadImage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FrameTagBeanInfo

public FrameTagBeanInfo()
FrameTagBeanInfoを新規に生成します。

メソッドの詳細

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。

戻り値:
PropertyDescriptor
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FrameTEI (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FrameTEI

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagExtraInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.FrameTEI
public class FrameTEI
extends TagExtraInfo

Frameタグの拡張情報です。

導入されたバージョン:
4.0

コンストラクタの概要
FrameTEI()
FrameTEIを新規に生成します。
メソッドの概要
 boolean isValid(TagData tagData)
Frameタグに指定された内容の正当性を検証します。
クラス javax.servlet.jsp.tagext.TagExtraInfo から継承したメソッド
getTagInfo, getVariableInfo, setTagInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FrameTEI

public FrameTEI()
FrameTEIを新規に生成します。

メソッドの詳細

isValid

public boolean isValid(TagData tagData)
Frameタグに指定された内容の正当性を検証します。 検証内容は以下のとおりです。
  • class属性またはframeclass属性がある場合、いずれかのみが設定されている

パラメータ:
tagData - タグ情報
戻り値:
タグが正当な場合true、それ以外の場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FrameworkTagException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FrameworkTagException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.jsp.JspException
                拡張 jp.co.intra_mart.framework.base.web.tag.FrameworkTagException
すべての実装インタフェース:
Serializable
public class FrameworkTagException
extends JspException

拡張タグの例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
FrameworkTagException()
詳細メッセージを指定しないで FrameworkTagException を構築します。
FrameworkTagException(String msg)
指定された詳細メッセージを持つ FrameworkTagException を構築します。
FrameworkTagException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkTagException を構築します。
FrameworkTagException(Throwable throwable)
この例外の発生原因となる例外を持つ FrameworkTagException を構築します。
メソッドの概要
void | printStackTrace()
void | printStackTrace(PrintStream printStream)
void | printStackTrace(PrintWriter printWriter)
クラス javax.servlet.jsp.JspException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

FrameworkTagException

public FrameworkTagException()
詳細メッセージを指定しないで FrameworkTagException を構築します。

FrameworkTagException

public FrameworkTagException(String msg)
指定された詳細メッセージを持つ FrameworkTagException を構築します。

パラメータ:
msg - 詳細メッセージ

FrameworkTagException

public FrameworkTagException(String msg,
                             Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkTagException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外

FrameworkTagException

public FrameworkTagException(Throwable throwable)
この例外の発生原因となる例外を持つ FrameworkTagException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外
メソッドの詳細

printStackTrace

public void printStackTrace()

printStackTrace

public void printStackTrace(PrintStream printStream)

printStackTrace

public void printStackTrace(PrintWriter printWriter)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


FrameworkTagParam (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FrameworkTagParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
        拡張 jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam
public class FrameworkTagParam
extends PropertyParam

タグに追加されるパラメータです。

バージョン:
1.0

コンストラクタの概要
FrameworkTagParam()
FrameworkTagParamを新規に生成します。
クラス jp.co.intra_mart.framework.system.property.PropertyParam から継承したメソッド
getName, getValue, setName, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FrameworkTagParam

public FrameworkTagParam()
FrameworkTagParamを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HelperBeanTag (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス HelperBeanTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.HelperBeanTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class HelperBeanTag
extends BodyTagSupport

HelperBeanタグです。

導入されたバージョン:
3.2
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
HelperBeanTag()
HelperBeanTagを新規に生成します。
メソッドの概要
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getHelperclass() クラス名を取得します。
void | setClass(String className) 推奨されていません。 このメソッドではなくsetHelperclass(java.lang.String)メソッドを使用してください。
void | setHelperclass(String helperclass) クラス名を設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doEndTag, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

HelperBeanTag

public HelperBeanTag()
HelperBeanTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 HelperBeanタグを解釈します。

戻り値:
SKIP_BODY
例外:
JspException - タグの解釈時に例外が発生

setClass

public void setClass(String className)
推奨されていません。 このメソッドではなくsetHelperclass(java.lang.String)メソッドを使用してください。

クラス名を設定します。

パラメータ:
className - クラス名

setHelperclass

public void setHelperclass(String helperclass)
クラス名を設定します。

パラメータ:
helperclass - クラス名
導入されたバージョン:
4.0

getHelperclass

public String getHelperclass()
クラス名を取得します。

戻り値:
クラス名
導入されたバージョン:
4.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HelperBeanTagBeanInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス HelperBeanTagBeanInfo

java.lang.Object
    拡張 java.beans.SimpleBeanInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo
すべての実装インタフェース:
BeanInfo
public class HelperBeanTagBeanInfo
extends SimpleBeanInfo

HelperBeanTagのBeanInfoです。

導入されたバージョン:
4.0

フィールドの概要
インタフェース java.beans.BeanInfo から継承したフィールド
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
コンストラクタの概要
HelperBeanTagBeanInfo()
HelperBeanTagBeanInfoを新規に生成します。
メソッドの概要
 PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。
クラス java.beans.SimpleBeanInfo から継承したメソッド
getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, loadImage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HelperBeanTagBeanInfo

public HelperBeanTagBeanInfo()
HelperBeanTagBeanInfoを新規に生成します。

メソッドの詳細

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。

戻り値:
PropertyDescriptor
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HelperBeanTEI (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス HelperBeanTEI

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagExtraInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI
public class HelperBeanTEI
extends TagExtraInfo

HelperBeanタグの拡張情報です。

導入されたバージョン:
3.2

コンストラクタの概要
HelperBeanTEI()
HelperBeanTEIを新規に生成します。
メソッドの概要
VariableInfo[] | getVariableInfo(TagData tagData) スクリプティング変数に関連付けたHelperBeanの情報を取得します。
boolean | isValid(TagData tagData) HelperBeanタグに指定された内容の正当性を検証します。
クラス javax.servlet.jsp.tagext.TagExtraInfo から継承したメソッド
getTagInfo, setTagInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HelperBeanTEI

public HelperBeanTEI()
HelperBeanTEIを新規に生成します。

メソッドの詳細

getVariableInfo

public VariableInfo[] getVariableInfo(TagData tagData)
スクリプティング変数に関連付けたHelperBeanの情報を取得します。 属性idで指定された変数に属性class（またはhelperclass）で指定されたHelperBeanを割り当てます。

パラメータ:
tagData - タグデータ
戻り値:
スクリプティング変数の情報

isValid

public boolean isValid(TagData tagData)
HelperBeanタグに指定された内容の正当性を検証します。 検証内容は以下のとおりです。
  • class属性またはhelperclass属性のいずれかのみが設定されている

パラメータ:
tagData - タグ情報
戻り値:
タグが正当な場合true、それ以外の場合はfalse
導入されたバージョン:
4.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LinkTag (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス LinkTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.LinkTag
すべての実装インタフェース:
BodyTag, IterationTag, ParameterSendable, Serializable, Tag
public class LinkTag
extends BodyTagSupport
implements ParameterSendable

LINKタグです。 intra-martフレームワークを使用する場合のセッションフレームワーク、サービスフレームワークの一部となります。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
LinkTag()
LinkTagを新規に生成します。
メソッドの概要
void | addParameter(String name, String value) パラメータを追加します。
int | doEndTag() 終了タグを検知したときにJSPエンジンから呼ばれます。
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getAccesskey() accesskeyを取得します。
String | getApplication() アプリケーションを取得します。
String | getCharset() charsetを取得します。
String | getCoords() coordsを取得します。
String | getDir() dirを取得します。
String | getHreflang() hreflangを取得します。
String | getLang() langを取得します。
String | getLinkclass() linkClassを取得します。
String | getLinkClass() 推奨されていません。 このメソッドではなくgetLinkclass()メソッドを使用してください。
String | getName() nameを取得します。
String | getOnblur() onblurを取得します。
String | getOnclick() 属性onClickの値を取得します。
String | getOndblclick() 属性onDblClickの値を取得します。
String | getOnfocus() onfocusを取得します。
String | getOnkeydown() 属性onKeyDownの値を取得します。
String | getOnkeypress() 属性onKeyPressの値を取得します。
String | getOnkeyup() 属性onKeyUpの値を取得します。
String | getOnmousedown() 属性onMouseDownの値を取得します。
String | getOnmousemove() 属性onMouseMoveの値を取得します。
String | getOnmouseout() 属性onMouseOutの値を取得します。
String | getOnmouseover() 属性onMouseOverの値を取得します。
String | getOnmouseup() 属性onMouseUpの値を取得します。
String | getRel() relを取得します。
String | getRev() revを取得します。
String | getService() サービスを取得します。
String | getShape() shapeを取得します。
String | getStyle() styleを取得します。
String | getTabindex() tabindexを取得します。
String | getTarget() targetを取得します。
String | getTitle() titleを取得します。
String | getType() typeを取得します。
void | setAccesskey(String accesskey) accesskeyを設定します。
void | setApplication(String application) アプリケーションを設定します。
void | setCharset(String charset) charsetを設定します。
void | setCoords(String coords) coordsを設定します。
void | setDir(String dir) dirを設定します。
void | setHreflang(String hreflang) hreflangを設定します。
void | setLang(String lang) langを設定します。
void | setLinkclass(String linkClass) linkClassを設定します。
void | setLinkClass(String linkClass) 推奨されていません。 このメソッドではなくsetLinkclass(String)メソッドを使用してください。
void | setName(String name) nameを設定します。
void | setOnblur(String onblur) onblurを設定します。
void | setOnclick(String onClick) 属性onClickの値を設定します。
void | setOndblclick(String onDblClick) 属性obDblClickの値を設定します。
void | setOnfocus(String onfocus) onfocusを設定します。
void | setOnkeydown(String onKeyDown) 属性onKeyDownの値を設定します。
void | setOnkeypress(String onKeyPress) 属性onKeyPressの値を設定します。
void | setOnkeyup(String onKeyUp) 属性onKeyUpの値を設定します。
void | setOnmousedown(String onMouseDown) 属性onMouseDownの値を設定します。
void | setOnmousemove(String onMouseMove) 属性onMouseMoveの値を設定します。
void | setOnmouseout(String onMouseOut) 属性onMouseOutの値を設定します。
void | setOnmouseover(String onMouseOver) 属性onMouseOverの値を設定します。
void | setOnmouseup(String onMouseUp) 属性onMouseUpの値を設定します。
void | setRel(String rel) relを設定します。
void | setRev(String rev) relを設定します。
void | setService(String service) serviceを設定します。
void | setShape(String shape) shapeを設定します。
void | setStyle(String style) styleを設定します。
void | setTabindex(String tabindex) tabindexを設定します。
void | setTarget(String target) targetを設定します。
void | setTitle(String title) titleを設定します。
void | setType(String type) typeを設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

LinkTag

public LinkTag()
LinkTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 LINKタグを解釈します。

定義:
インタフェース Tag 内の doStartTag
戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - タグの解釈時に例外が発生

doEndTag

public int doEndTag()
             throws JspException
終了タグを検知したときにJSPエンジンから呼ばれます。 LINKタグを終了します。

定義:
インタフェース Tag 内の doEndTag
戻り値:
EVAL_PAGE
例外:
JspException - タグの終了時に例外が発生

addParameter

public void addParameter(String name,
                         String value)
パラメータを追加します。

定義:
インタフェース ParameterSendable 内の addParameter
パラメータ:
name - パラメータ名
value - パラメータの値

getCharset

public String getCharset()
charsetを取得します。

戻り値:
charset

setCharset

public void setCharset(String charset)
charsetを設定します。

パラメータ:
charset - charset

getType

public String getType()
typeを取得します。

戻り値:
type

setType

public void setType(String type)
typeを設定します。

パラメータ:
type - type

getName

public String getName()
nameを取得します。

戻り値:
name

setName

public void setName(String name)
nameを設定します。

パラメータ:
name - name

getApplication

public String getApplication()
アプリケーションを取得します。

戻り値:
アプリケーション

setApplication

public void setApplication(String application)
アプリケーションを設定します。

パラメータ:
application - アプリケーション

getService

public String getService()
サービスを取得します。

戻り値:
サービス

setService

public void setService(String service)
serviceを設定します。

パラメータ:
service - サービス

getHreflang

public String getHreflang()
hreflangを取得します。

戻り値:
hreflang

setHreflang

public void setHreflang(String hreflang)
hreflangを設定します。

パラメータ:
hreflang - hreflang

getRel

public String getRel()
relを取得します。

戻り値:
rel

setRel

public void setRel(String rel)
relを設定します。

パラメータ:
rel - rel

getRev

public String getRev()
revを取得します。

戻り値:
rev

setRev

public void setRev(String rev)
relを設定します。

パラメータ:
rev - rev

getAccesskey

public String getAccesskey()
accesskeyを取得します。

戻り値:
accesskey

setAccesskey

public void setAccesskey(String accesskey)
accesskeyを設定します。

パラメータ:
accesskey - accesskey

getShape

public String getShape()
shapeを取得します。

戻り値:
shape

setShape

public void setShape(String shape)
shapeを設定します。

パラメータ:
shape - shape

getCoords

public String getCoords()
coordsを取得します。

戻り値:
coords

setCoords

public void setCoords(String coords)
coordsを設定します。

パラメータ:
coords - coords

getTarget

public String getTarget()
targetを取得します。

戻り値:
target
導入されたバージョン:
3.2

setTarget

public void setTarget(String target)
targetを設定します。

パラメータ:
target - target
導入されたバージョン:
3.2

getTabindex

public String getTabindex()
tabindexを取得します。

戻り値:
tabindex

setTabindex

public void setTabindex(String tabindex)
tabindexを設定します。

パラメータ:
tabindex - tabindex

getOnfocus

public String getOnfocus()
onfocusを取得します。

戻り値:
onfocus

setOnfocus

public void setOnfocus(String onfocus)
onfocusを設定します。

パラメータ:
onfocus - onfocus

getOnblur

public String getOnblur()
onblurを取得します。

戻り値:
onblur

setOnblur

public void setOnblur(String onblur)
onblurを設定します。

パラメータ:
onblur - onblur

getLinkClass

public String getLinkClass()
推奨されていません。 このメソッドではなくgetLinkclass()メソッドを使用してください。

linkClassを取得します。

戻り値:
linkClass

setLinkClass

public void setLinkClass(String linkClass)
推奨されていません。 このメソッドではなくsetLinkclass(String)メソッドを使用してください。

linkClassを設定します。

パラメータ:
linkClass - class

getLinkclass

public String getLinkclass()
linkClassを取得します。

戻り値:
linkClass

setLinkclass

public void setLinkclass(String linkClass)
linkClassを設定します。

パラメータ:
linkClass - class

getStyle

public String getStyle()
styleを取得します。

戻り値:
style

setStyle

public void setStyle(String style)
styleを設定します。

パラメータ:
style - style

getTitle

public String getTitle()
titleを取得します。

戻り値:
title

setTitle

public void setTitle(String title)
titleを設定します。

パラメータ:
title - title

getLang

public String getLang()
langを取得します。

戻り値:
lang

setLang

public void setLang(String lang)
langを設定します。

パラメータ:
lang - lang

getDir

public String getDir()
dirを取得します。

戻り値:
dir

setDir

public void setDir(String dir)
dirを設定します。

パラメータ:
dir - dir

getOnclick

public String getOnclick()
属性onClickの値を取得します。

戻り値:
onClick

setOnclick

public void setOnclick(String onClick)
属性onClickの値を設定します。

パラメータ:
onClick - onClick

getOndblclick

public String getOndblclick()
属性onDblClickの値を取得します。

戻り値:
onDblClick

setOndblclick

public void setOndblclick(String onDblClick)
属性obDblClickの値を設定します。

パラメータ:
onDblClick - onDblClick

getOnmousedown

public String getOnmousedown()
属性onMouseDownの値を取得します。

戻り値:
onMouseDown

setOnmousedown

public void setOnmousedown(String onMouseDown)
属性onMouseDownの値を設定します。

パラメータ:
onMouseDown - onMouseDown

getOnmouseup

public String getOnmouseup()
属性onMouseUpの値を取得します。

戻り値:
onMouseUp

setOnmouseup

public void setOnmouseup(String onMouseUp)
属性onMouseUpの値を設定します。

パラメータ:
onMouseUp - onMouseUp

getOnmouseover

public String getOnmouseover()
属性onMouseOverの値を取得します。

戻り値:
onMouseOver

setOnmouseover

public void setOnmouseover(String onMouseOver)
属性onMouseOverの値を設定します。

パラメータ:
onMouseOver - onMouseOver

getOnmousemove

public String getOnmousemove()
属性onMouseMoveの値を取得します。

戻り値:
onMouseMove

setOnmousemove

public void setOnmousemove(String onMouseMove)
属性onMouseMoveの値を設定します。

パラメータ:
onMouseMove - onMouseMove

getOnmouseout

public String getOnmouseout()
属性onMouseOutの値を取得します。

戻り値:
onMouseOut

setOnmouseout

public void setOnmouseout(String onMouseOut)
属性onMouseOutの値を設定します。

パラメータ:
onMouseOut - onMouseOut

getOnkeypress

public String getOnkeypress()
属性onKeyPressの値を取得します。

戻り値:
onKeyPress

setOnkeypress

public void setOnkeypress(String onKeyPress)
属性onKeyPressの値を設定します。

パラメータ:
onKeyPress - onKeyPress

getOnkeydown

public String getOnkeydown()
属性onKeyDownの値を取得します。

戻り値:
onKeyDown

setOnkeydown

public void setOnkeydown(String onKeyDown)
属性onKeyDownの値を設定します。

パラメータ:
onKeyDown - onKeyDown

getOnkeyup

public String getOnkeyup()
属性onKeyUpの値を取得します。

戻り値:
onKeyUp

setOnkeyup

public void setOnkeyup(String onKeyUp)
属性onKeyUpの値を設定します。

パラメータ:
onKeyUp - onKeyUp
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LinkTagBeanInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス LinkTagBeanInfo

java.lang.Object
    拡張 java.beans.SimpleBeanInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo
すべての実装インタフェース:
BeanInfo
public class LinkTagBeanInfo
extends SimpleBeanInfo

LinkTagのBeanInfoです。

導入されたバージョン:
4.0

フィールドの概要
インタフェース java.beans.BeanInfo から継承したフィールド
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
コンストラクタの概要
LinkTagBeanInfo()
LinkTagBeanInfoを新規に生成します。
メソッドの概要
 PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。
クラス java.beans.SimpleBeanInfo から継承したメソッド
getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, loadImage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LinkTagBeanInfo

public LinkTagBeanInfo()
LinkTagBeanInfoを新規に生成します。

メソッドの詳細

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。

戻り値:
PropertyDescriptor
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LinkTEI (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス LinkTEI

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagExtraInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.LinkTEI
public class LinkTEI
extends TagExtraInfo

Linkタグの拡張情報です。

導入されたバージョン:
4.0

コンストラクタの概要
LinkTEI()
LinkTEIを新規に生成します。
メソッドの概要
 boolean isValid(TagData tagData)
Linkタグに指定された内容の正当性を検証します。
クラス javax.servlet.jsp.tagext.TagExtraInfo から継承したメソッド
getTagInfo, getVariableInfo, setTagInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LinkTEI

public LinkTEI()
LinkTEIを新規に生成します。

メソッドの詳細

isValid

public boolean isValid(TagData tagData)
Linkタグに指定された内容の正当性を検証します。 検証内容は以下のとおりです。
  • class属性またはlinkclass属性がある場合、いずれかのみが設定されている

パラメータ:
tagData - タグ情報
戻り値:
タグが正当な場合true、それ以外の場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MessageParamTag (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス MessageParamTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.MessageParamTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class MessageParamTag
extends BodyTagSupport

メッセージの生成で使用するパラメータを設定します。

導入されたバージョン:
4.2
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
MessageParamTag()
ParamTagを新規に生成します。
メソッドの概要
int | doStartTag() 外側の一番近いMessageTagにパラメータを設定します。
Object | getValue() パラメータの値を取得します。
void | setValue(Object value) パラメータの値を設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doEndTag, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

MessageParamTag

public MessageParamTag()
ParamTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
外側の一番近いMessageTagにパラメータを設定します。

戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - JSP出力時に例外が発生

getValue

public Object getValue()
パラメータの値を取得します。

戻り値:
パラメータの値

setValue

public void setValue(Object value)
パラメータの値を設定します。

パラメータ:
value - パラメータの値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MessageTag (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス MessageTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.MessageTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class MessageTag
extends BodyTagSupport

Messageタグです。 im-J2EE Frameworkを使用する場合のMessageフレームワークの一部となります。

導入されたバージョン:
4.2
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
MessageTag()
MessageTagを新規に生成します。
メソッドの概要
void | addParameter(Object value) パラメータを追加します。
int | doEndTag() 終了タグを検知したときにJSPエンジンから呼ばれます。
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getApplication() applicationを取得します。
String | getKey() keyを取得します。
String | getLocale() localeを取得します。
void | setApplication(String application) applicationを設定します。
void | setKey(String key) keyを設定します。
void | setLocale(String locale) localeを設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

MessageTag

public MessageTag()
MessageTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 Messageタグを解釈します。

戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - タグの解釈時に例外が発生

doEndTag

public int doEndTag()
             throws JspException
終了タグを検知したときにJSPエンジンから呼ばれます。 Messageタグを終了します。

戻り値:
EVAL_PAGE
例外:
JspException - タグの終了時に例外が発生

addParameter

public void addParameter(Object value)
パラメータを追加します。

パラメータ:
value - パラメータの値

getApplication

public String getApplication()
applicationを取得します。

戻り値:
application

setApplication

public void setApplication(String application)
applicationを設定します。

パラメータ:
application - application

getKey

public String getKey()
keyを取得します。

戻り値:
key

setKey

public void setKey(String key)
keyを設定します。

パラメータ:
key - key

getLocale

public String getLocale()
localeを取得します。

戻り値:
locale

setLocale

public void setLocale(String locale)
localeを設定します。

パラメータ:
locale - locale
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MessageTEI (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス MessageTEI

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagExtraInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.MessageTEI
public class MessageTEI
extends TagExtraInfo

Messageタグの拡張情報です。

導入されたバージョン:
4.2

コンストラクタの概要
MessageTEI()
メソッドの概要
 boolean isValid(TagData tagData)
Messageタグに指定された内容の正当性を検証します。
クラス javax.servlet.jsp.tagext.TagExtraInfo から継承したメソッド
getTagInfo, getVariableInfo, setTagInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MessageTEI

public MessageTEI()
メソッドの詳細

isValid

public boolean isValid(TagData tagData)
Messageタグに指定された内容の正当性を検証します。 検証内容は以下のとおりです。
  • locale属性が指定されている場合、書式が言語_国[_バリアント]となっていること
    ロケール文字列のアンダーバー(_)はハイフン(-)であってもかまいません。
locale属性が指定されていない場合、trueが返されます。

パラメータ:
tagData - タグ情報
戻り値:
タグが正当な場合true、それ以外の場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.web.tag (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.base.web.tag
インタフェース
ParameterSendable
クラス
FormTag
FormTagBeanInfo
FormTEI
FrameTag
FrameTagBeanInfo
FrameTEI
FrameworkTagParam
HelperBeanTag
HelperBeanTagBeanInfo
HelperBeanTEI
LinkTag
LinkTagBeanInfo
LinkTEI
MessageParamTag
MessageTag
MessageTEI
ParamTag
SubmitLinkTag
SubmitLinkTagBeanInfo
SubmitTag
SubmitTagBeanInfo
SubmitTEI
TagWriter
例外
FrameworkTagException


jp.co.intra_mart.framework.base.web.tag (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.tag

J2EEフレームワークで使用する各種のタグのパッケージです。

参照:
説明

インタフェースの概要
ParameterSendable パラメータを渡すことができるタグです。

クラスの概要
FormTag | FORMタグです。
FormTagBeanInfo | FormTagのBeanInfoです。
FormTEI | Formタグの拡張情報です。
FrameTag | FRAMEタグです。
FrameTagBeanInfo | FrameTagのBeanInfoです。
FrameTEI | Frameタグの拡張情報です。
FrameworkTagParam | タグに追加されるパラメータです。
HelperBeanTag | HelperBeanタグです。
HelperBeanTagBeanInfo | HelperBeanTagのBeanInfoです。
HelperBeanTEI | HelperBeanタグの拡張情報です。
LinkTag | LINKタグです。
LinkTagBeanInfo | LinkTagのBeanInfoです。
LinkTEI | Linkタグの拡張情報です。
MessageParamTag | メッセージの生成で使用するパラメータを設定します。
MessageTag | Messageタグです。
MessageTEI | Messageタグの拡張情報です。
ParamTag | リンク先、遷移先に渡すパラメータを設定します。
SubmitLinkTag | サブミット専用のLINKタグです。
SubmitLinkTagBeanInfo | SubmitLinkTagのBeanInfoです。
SubmitTag | Submitタグです。
SubmitTagBeanInfo | SubmitTagのBeanInfoです。
SubmitTEI | Submitタグの拡張情報です。
TagWriter | タグの出力を行います。

例外の概要
FrameworkTagException 拡張タグの例外です。

パッケージ jp.co.intra_mart.framework.base.web.tag の説明

J2EEフレームワークで使用する各種のタグのパッケージです。 セッション情報を保ったまま画面遷移することが可能になります。


jp.co.intra_mart.framework.base.web.tag クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.tag の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam
    • class java.beans.SimpleBeanInfo (implements java.beans.BeanInfo)
      • class jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo
    • class javax.servlet.jsp.tagext.TagExtraInfo
      • class jp.co.intra_mart.framework.base.web.tag.FormTEI
      • class jp.co.intra_mart.framework.base.web.tag.FrameTEI
      • class jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI
      • class jp.co.intra_mart.framework.base.web.tag.LinkTEI
      • class jp.co.intra_mart.framework.base.web.tag.MessageTEI
      • class jp.co.intra_mart.framework.base.web.tag.SubmitTEI
    • class javax.servlet.jsp.tagext.TagSupport (implements javax.servlet.jsp.tagext.IterationTag, java.io.Serializable)
      • class javax.servlet.jsp.tagext.BodyTagSupport (implements javax.servlet.jsp.tagext.BodyTag)
        • class jp.co.intra_mart.framework.base.web.tag.FormTag
        • class jp.co.intra_mart.framework.base.web.tag.FrameTag (implements jp.co.intra_mart.framework.base.web.tag.ParameterSendable)
        • class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag
        • class jp.co.intra_mart.framework.base.web.tag.LinkTag (implements jp.co.intra_mart.framework.base.web.tag.ParameterSendable)
        • class jp.co.intra_mart.framework.base.web.tag.MessageParamTag
        • class jp.co.intra_mart.framework.base.web.tag.MessageTag
        • class jp.co.intra_mart.framework.base.web.tag.ParamTag
        • class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag
        • class jp.co.intra_mart.framework.base.web.tag.SubmitTag
    • class jp.co.intra_mart.framework.base.web.tag.TagWriter
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.servlet.jsp.JspException
          • class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException

インタフェース階層

  • interface jp.co.intra_mart.framework.base.web.tag.ParameterSendable


パッケージ jp.co.intra_mart.framework.base.web.tag の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.web.tag の使用

jp.co.intra_mart.framework.base.web.tag を使用しているパッケージ
jp.co.intra_mart.framework.base.web.tag | J2EEフレームワークで使用する各種のタグのパッケージです。
jp.co.intra_mart.framework.base.web.tag.attribute | タグ属性のパッケージです。

jp.co.intra_mart.framework.base.web.tag により使用される jp.co.intra_mart.framework.base.web.tag のクラス
ParameterSendable
パラメータを渡すことができるタグです。

jp.co.intra_mart.framework.base.web.tag.attribute により使用される jp.co.intra_mart.framework.base.web.tag のクラス
TagWriter
タグの出力を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParameterSendable (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
インタフェース ParameterSendable

既知の実装クラスの一覧:
FrameTag, LinkTag
public interface ParameterSendable

パラメータを渡すことができるタグです。

バージョン:
1.0

メソッドの概要
 void addParameter(String name, String value)
パラメータを追加します。

メソッドの詳細

addParameter

public void addParameter(String name,
                         String value)
パラメータを追加します。

パラメータ:
name - パラメータ名
value - パラメータの値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ParamTag (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス ParamTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.ParamTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class ParamTag
extends BodyTagSupport

リンク先、遷移先に渡すパラメータを設定します。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
ParamTag()
ParamTagを新規に生成します。
メソッドの概要
int | doStartTag() 外側の一番近いParameterSendableにパラメータを設定します。
String | getName() パラメータ名を取得します。
String | getValue() パラメータの値を取得します。
void | setName(String name) パラメータ名を設定します。
void | setValue(String value) パラメータの値を設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doEndTag, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

ParamTag

public ParamTag()
ParamTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
外側の一番近いParameterSendableにパラメータを設定します。

戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - JSP出力時に例外が発生

getName

public String getName()
パラメータ名を取得します。

戻り値:
パラメータ名

setName

public void setName(String name)
パラメータ名を設定します。

パラメータ:
name - パラメータ名

getValue

public String getValue()
パラメータの値を取得します。

戻り値:
パラメータの値

setValue

public void setValue(String value)
パラメータの値を設定します。

パラメータ:
value - パラメータの値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SubmitLinkTag (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス SubmitLinkTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class SubmitLinkTag
extends BodyTagSupport

サブミット専用のLINKタグです。 im-J2EE Frameworkを使用する場合のセッションフレームワーク、サービスフレームワークの一部となります。

導入されたバージョン:
4.2
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
SubmitLinkTag()
SubmitLinkTagを新規に生成します。
メソッドの概要
int | doEndTag() 終了タグを検知したときにJSPエンジンから呼ばれます。
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getAccesskey() accesskeyを取得します。
String | getApplication() アプリケーションを取得します。
String | getCoords() coordsを取得します。
String | getDir() dirを取得します。
String | getForm() ターゲットとなるフォーム名を取得します。
String | getLang() langを取得します。
String | getLinkclass() linkClassを取得します。
String | getName() nameを取得します。
String | getOnblur() onblurを取得します。
String | getOnclick() 属性onClickの値を取得します。
String | getOndblclick() 属性onDblClickの値を取得します。
String | getOnfocus() onfocusを取得します。
String | getOnkeydown() 属性onKeyDownの値を取得します。
String | getOnkeypress() 属性onKeyPressの値を取得します。
String | getOnkeyup() 属性onKeyUpの値を取得します。
String | getOnmousedown() 属性onMouseDownの値を取得します。
String | getOnmousemove() 属性onMouseMoveの値を取得します。
String | getOnmouseout() 属性onMouseOutの値を取得します。
String | getOnmouseover() 属性onMouseOverの値を取得します。
String | getOnmouseup() 属性onMouseUpの値を取得します。
String | getService() サービスを取得します。
String | getShape() shapeを取得します。
String | getStyle() styleを取得します。
String | getTabindex() tabindexを取得します。
String | getTitle() titleを取得します。
void | setAccesskey(String accesskey) accesskeyを設定します。
void | setApplication(String application) アプリケーションを設定します。
void | setCoords(String coords) coordsを設定します。
void | setDir(String dir) dirを設定します。
void | setForm(String form) ターゲットとなるフォーム名を設定します。
void | setLang(String lang) langを設定します。
void | setLinkclass(String linkClass) linkClassを設定します。
void | setName(String name) nameを設定します。
void | setOnblur(String onblur) onblurを設定します。
void | setOnclick(String onClick) 属性onClickの値を設定します。
void | setOndblclick(String onDblClick) 属性obDblClickの値を設定します。
void | setOnfocus(String onfocus) onfocusを設定します。
void | setOnkeydown(String onKeyDown) 属性onKeyDownの値を設定します。
void | setOnkeypress(String onKeyPress) 属性onKeyPressの値を設定します。
void | setOnkeyup(String onKeyUp) 属性onKeyUpの値を設定します。
void | setOnmousedown(String onMouseDown) 属性onMouseDownの値を設定します。
void | setOnmousemove(String onMouseMove) 属性onMouseMoveの値を設定します。
void | setOnmouseout(String onMouseOut) 属性onMouseOutの値を設定します。
void | setOnmouseover(String onMouseOver) 属性onMouseOverの値を設定します。
void | setOnmouseup(String onMouseUp) 属性onMouseUpの値を設定します。
void | setService(String service) サービスを設定します。
void | setShape(String shape) shapeを設定します。
void | setStyle(String style) styleを設定します。
void | setTabindex(String tabindex) tabindexを設定します。
void | setTitle(String title) titleを設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

SubmitLinkTag

public SubmitLinkTag()
SubmitLinkTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 SUBMIT LINKタグを解釈します。

戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - タグの解釈時に例外が発生

doEndTag

public int doEndTag()
             throws JspException
終了タグを検知したときにJSPエンジンから呼ばれます。 SUBMIT LINKタグを終了します。

戻り値:
EVAL_PAGE
例外:
JspException - タグの終了時に例外が発生

getName

public String getName()
nameを取得します。

戻り値:
name

setName

public void setName(String name)
nameを設定します。

パラメータ:
name - name

getApplication

public String getApplication()
アプリケーションを取得します。

戻り値:
アプリケーション

setApplication

public void setApplication(String application)
アプリケーションを設定します。

パラメータ:
application - アプリケーション

getService

public String getService()
サービスを取得します。

戻り値:
サービス

setService

public void setService(String service)
サービスを設定します。

パラメータ:
service - サービス

getForm

public String getForm()
ターゲットとなるフォーム名を取得します。

戻り値:
ターゲットとなるフォーム名

setForm

public void setForm(String form)
ターゲットとなるフォーム名を設定します。

パラメータ:
form - ターゲットとなるフォーム名

getAccesskey

public String getAccesskey()
accesskeyを取得します。

戻り値:
accesskey

setAccesskey

public void setAccesskey(String accesskey)
accesskeyを設定します。

パラメータ:
accesskey - accesskey

getShape

public String getShape()
shapeを取得します。

戻り値:
shape

setShape

public void setShape(String shape)
shapeを設定します。

パラメータ:
shape - shape

getCoords

public String getCoords()
coordsを取得します。

戻り値:
coords

setCoords

public void setCoords(String coords)
coordsを設定します。

パラメータ:
coords - coords

getTabindex

public String getTabindex()
tabindexを取得します。

戻り値:
tabindex

setTabindex

public void setTabindex(String tabindex)
tabindexを設定します。

パラメータ:
tabindex - tabindex

getOnfocus

public String getOnfocus()
onfocusを取得します。

戻り値:
onfocus

setOnfocus

public void setOnfocus(String onfocus)
onfocusを設定します。

パラメータ:
onfocus - onfocus

getOnblur

public String getOnblur()
onblurを取得します。

戻り値:
onblur

setOnblur

public void setOnblur(String onblur)
onblurを設定します。

パラメータ:
onblur - onblur

getLinkclass

public String getLinkclass()
linkClassを取得します。

戻り値:
linkClass

setLinkclass

public void setLinkclass(String linkClass)
linkClassを設定します。

パラメータ:
linkClass - class

getStyle

public String getStyle()
styleを取得します。

戻り値:
style

setStyle

public void setStyle(String style)
styleを設定します。

パラメータ:
style - style

getTitle

public String getTitle()
titleを取得します。

戻り値:
title

setTitle

public void setTitle(String title)
titleを設定します。

パラメータ:
title - title

getLang

public String getLang()
langを取得します。

戻り値:
lang

setLang

public void setLang(String lang)
langを設定します。

パラメータ:
lang - lang

getDir

public String getDir()
dirを取得します。

戻り値:
dir

setDir

public void setDir(String dir)
dirを設定します。

パラメータ:
dir - dir

getOnclick

public String getOnclick()
属性onClickの値を取得します。

戻り値:
onClick

setOnclick

public void setOnclick(String onClick)
属性onClickの値を設定します。

パラメータ:
onClick - onClick

getOndblclick

public String getOndblclick()
属性onDblClickの値を取得します。

戻り値:
onDblClick

setOndblclick

public void setOndblclick(String onDblClick)
属性obDblClickの値を設定します。

パラメータ:
onDblClick - onDblClick

getOnmousedown

public String getOnmousedown()
属性onMouseDownの値を取得します。

戻り値:
onMouseDown

setOnmousedown

public void setOnmousedown(String onMouseDown)
属性onMouseDownの値を設定します。

パラメータ:
onMouseDown - onMouseDown

getOnmouseup

public String getOnmouseup()
属性onMouseUpの値を取得します。

戻り値:
onMouseUp

setOnmouseup

public void setOnmouseup(String onMouseUp)
属性onMouseUpの値を設定します。

パラメータ:
onMouseUp - onMouseUp

getOnmouseover

public String getOnmouseover()
属性onMouseOverの値を取得します。

戻り値:
onMouseOver

setOnmouseover

public void setOnmouseover(String onMouseOver)
属性onMouseOverの値を設定します。

パラメータ:
onMouseOver - onMouseOver

getOnmousemove

public String getOnmousemove()
属性onMouseMoveの値を取得します。

戻り値:
onMouseMove

setOnmousemove

public void setOnmousemove(String onMouseMove)
属性onMouseMoveの値を設定します。

パラメータ:
onMouseMove - onMouseMove

getOnmouseout

public String getOnmouseout()
属性onMouseOutの値を取得します。

戻り値:
onMouseOut

setOnmouseout

public void setOnmouseout(String onMouseOut)
属性onMouseOutの値を設定します。

パラメータ:
onMouseOut - onMouseOut

getOnkeypress

public String getOnkeypress()
属性onKeyPressの値を取得します。

戻り値:
onKeyPress

setOnkeypress

public void setOnkeypress(String onKeyPress)
属性onKeyPressの値を設定します。

パラメータ:
onKeyPress - onKeyPress

getOnkeydown

public String getOnkeydown()
属性onKeyDownの値を取得します。

戻り値:
onKeyDown

setOnkeydown

public void setOnkeydown(String onKeyDown)
属性onKeyDownの値を設定します。

パラメータ:
onKeyDown - onKeyDown

getOnkeyup

public String getOnkeyup()
属性onKeyUpの値を取得します。

戻り値:
onKeyUp

setOnkeyup

public void setOnkeyup(String onKeyUp)
属性onKeyUpの値を設定します。

パラメータ:
onKeyUp - onKeyUp
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SubmitLinkTagBeanInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス SubmitLinkTagBeanInfo

java.lang.Object
    拡張 java.beans.SimpleBeanInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo
すべての実装インタフェース:
BeanInfo
public class SubmitLinkTagBeanInfo
extends SimpleBeanInfo

SubmitLinkTagのBeanInfoです。

導入されたバージョン:
4.2

フィールドの概要
インタフェース java.beans.BeanInfo から継承したフィールド
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
コンストラクタの概要
SubmitLinkTagBeanInfo()
SubmitLinkTagBeanInfoを新規に生成します。
メソッドの概要
 PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。
クラス java.beans.SimpleBeanInfo から継承したメソッド
getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, loadImage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SubmitLinkTagBeanInfo

public SubmitLinkTagBeanInfo()
SubmitLinkTagBeanInfoを新規に生成します。

メソッドの詳細

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。

戻り値:
PropertyDescriptor
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SubmitTag (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス SubmitTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.SubmitTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class SubmitTag
extends BodyTagSupport

Submitタグです。 intra-martフレームワークのFormタグ内でのみ使用できるタグです。

導入されたバージョン:
3.2
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
SubmitTag()
SubmitTagを新規に生成します。
メソッドの概要
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getApplication() 属性applicationの値を取得します。
String | getDir() 属性dirの値を取得します。
String | getLang() 属性langの値を取得します。
String | getName() 属性nameを取得します。
String | getOnblur() 属性onBlurを取得します。
String | getOnclick() 属性onClickの値を取得します。
String | getOndblclick() 属性onDblClickの値を取得します。
String | getOnfocus() 属性onFocusを取得します。
String | getOnkeydown() 属性onKeyDownの値を取得します。
String | getOnkeypress() 属性onKeyPressの値を取得します。
String | getOnkeyup() 属性onKeyUpの値を取得します。
String | getOnmousedown() 属性onMouseDownの値を取得します。
String | getOnmousemove() 属性onMouseMoveの値を取得します。
String | getOnmouseout() 属性onMouseOutの値を取得します。
String | getOnmouseover() 属性onMouseOverの値を取得します。
String | getOnmouseup() 属性onMouseUpの値を取得します。
String | getService() 属性serviceの値を取得します。
String | getStyle() 属性styleの値を取得します。
String | getSubmitclass() 属性classの値を取得します。
String | getTabindex() tabindexを取得します。
String | getTitle() 属性titleの値を取得します。
String | getValue() 属性valueを取得します。
void | setApplication(String application) 属性applicationの値を設定します。
void | setDir(String dir) 属性dirの値を設定します。
void | setLang(String lang) 属性langの値を設定します。
void | setName(String name) 属性nameを設定します。
void | setOnblur(String onBlur) 属性onBlurを設定します。
void | setOnclick(String onClick) 属性onClickの値を設定します。
void | setOndblclick(String onDblClick) 属性obDblClickの値を設定します。
void | setOnfocus(String onFocus) 属性onFocusを設定します。
void | setOnkeydown(String onKeyDown) 属性onKeyDownの値を設定します。
void | setOnkeypress(String onKeyPress) 属性onKeyPressの値を設定します。
void | setOnkeyup(String onKeyUp) 属性onKeyUpの値を設定します。
void | setOnmousedown(String onMouseDown) 属性onMouseDownの値を設定します。
void | setOnmousemove(String onMouseMove) 属性onMouseMoveの値を設定します。
void | setOnmouseout(String onMouseOut) 属性onMouseOutの値を設定します。
void | setOnmouseover(String onMouseOver) 属性onMouseOverの値を設定します。
void | setOnmouseup(String onMouseUp) 属性onMouseUpの値を設定します。
void | setService(String service) 属性serviceの値を設定します。
void | setStyle(String style) 属性styleの値を設定します。
void | setSubmitclass(String submitClass) 属性classの値を設定します。
void | setTabindex(String tabindex) tabindexを設定します。
void | setTitle(String title) 属性titleの値を設定します。
void | setValue(String value) 属性valueを設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doEndTag, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

SubmitTag

public SubmitTag()
SubmitTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 Submitタグを解釈します。

戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - JSP出力時に例外が発生

getApplication

public String getApplication()
属性applicationの値を取得します。

戻り値:
アプリケーション

setApplication

public void setApplication(String application)
属性applicationの値を設定します。

パラメータ:
application - アプリケーション

getService

public String getService()
属性serviceの値を取得します。

戻り値:
サービス

setService

public void setService(String service)
属性serviceの値を設定します。

パラメータ:
service - サービス

getName

public String getName()
属性nameを取得します。

戻り値:
name

setName

public void setName(String name)
属性nameを設定します。

パラメータ:
name - name

getValue

public String getValue()
属性valueを取得します。

戻り値:
value

setValue

public void setValue(String value)
属性valueを設定します。

パラメータ:
value - value

getTabindex

public String getTabindex()
tabindexを取得します。

戻り値:
tabindex

setTabindex

public void setTabindex(String tabindex)
tabindexを設定します。

パラメータ:
tabindex - tabindex

getOnfocus

public String getOnfocus()
属性onFocusを取得します。

戻り値:
onFocus

setOnfocus

public void setOnfocus(String onFocus)
属性onFocusを設定します。

パラメータ:
onFocus - onFocus

getOnblur

public String getOnblur()
属性onBlurを取得します。

戻り値:
onBlur

setOnblur

public void setOnblur(String onBlur)
属性onBlurを設定します。

パラメータ:
onBlur - onBlur

getSubmitclass

public String getSubmitclass()
属性classの値を取得します。

戻り値:
class

setSubmitclass

public void setSubmitclass(String submitClass)
属性classの値を設定します。

パラメータ:
submitClass - class

getStyle

public String getStyle()
属性styleの値を取得します。

戻り値:
style

setStyle

public void setStyle(String style)
属性styleの値を設定します。

パラメータ:
style - style

getTitle

public String getTitle()
属性titleの値を取得します。

戻り値:
title

setTitle

public void setTitle(String title)
属性titleの値を設定します。

パラメータ:
title - title

getLang

public String getLang()
属性langの値を取得します。

戻り値:
lang

setLang

public void setLang(String lang)
属性langの値を設定します。

パラメータ:
lang - lang

getDir

public String getDir()
属性dirの値を取得します。

戻り値:
dir

setDir

public void setDir(String dir)
属性dirの値を設定します。

パラメータ:
dir - dir

getOnclick

public String getOnclick()
属性onClickの値を取得します。

戻り値:
onClick

setOnclick

public void setOnclick(String onClick)
属性onClickの値を設定します。

パラメータ:
onClick - onClick

getOndblclick

public String getOndblclick()
属性onDblClickの値を取得します。

戻り値:
onDblClick

setOndblclick

public void setOndblclick(String onDblClick)
属性obDblClickの値を設定します。

パラメータ:
onDblClick - onDblClick

getOnmousedown

public String getOnmousedown()
属性onMouseDownの値を取得します。

戻り値:
onMouseDown

setOnmousedown

public void setOnmousedown(String onMouseDown)
属性onMouseDownの値を設定します。

パラメータ:
onMouseDown - onMouseDown

getOnmouseup

public String getOnmouseup()
属性onMouseUpの値を取得します。

戻り値:
onMouseUp

setOnmouseup

public void setOnmouseup(String onMouseUp)
属性onMouseUpの値を設定します。

パラメータ:
onMouseUp - onMouseUp

getOnmouseover

public String getOnmouseover()
属性onMouseOverの値を取得します。

戻り値:
onMouseOver

setOnmouseover

public void setOnmouseover(String onMouseOver)
属性onMouseOverの値を設定します。

パラメータ:
onMouseOver - onMouseOver

getOnmousemove

public String getOnmousemove()
属性onMouseMoveの値を取得します。

戻り値:
onMouseMove

setOnmousemove

public void setOnmousemove(String onMouseMove)
属性onMouseMoveの値を設定します。

パラメータ:
onMouseMove - onMouseMove

getOnmouseout

public String getOnmouseout()
属性onMouseOutの値を取得します。

戻り値:
onMouseOut

setOnmouseout

public void setOnmouseout(String onMouseOut)
属性onMouseOutの値を設定します。

パラメータ:
onMouseOut - onMouseOut

getOnkeypress

public String getOnkeypress()
属性onKeyPressの値を取得します。

戻り値:
onKeyPress

setOnkeypress

public void setOnkeypress(String onKeyPress)
属性onKeyPressの値を設定します。

パラメータ:
onKeyPress - onKeyPress

getOnkeydown

public String getOnkeydown()
属性onKeyDownの値を取得します。

戻り値:
onKeyDown

setOnkeydown

public void setOnkeydown(String onKeyDown)
属性onKeyDownの値を設定します。

パラメータ:
onKeyDown - onKeyDown

getOnkeyup

public String getOnkeyup()
属性onKeyUpの値を取得します。

戻り値:
onKeyUp

setOnkeyup

public void setOnkeyup(String onKeyUp)
属性onKeyUpの値を設定します。

パラメータ:
onKeyUp - onKeyUp
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SubmitTagBeanInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス SubmitTagBeanInfo

java.lang.Object
    拡張 java.beans.SimpleBeanInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo
すべての実装インタフェース:
BeanInfo
public class SubmitTagBeanInfo
extends SimpleBeanInfo

SubmitTagのBeanInfoです。

導入されたバージョン:
4.0

フィールドの概要
インタフェース java.beans.BeanInfo から継承したフィールド
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
コンストラクタの概要
SubmitTagBeanInfo()
SubmitTagBeanInfoを新規に生成します。
メソッドの概要
 PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。
クラス java.beans.SimpleBeanInfo から継承したメソッド
getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, loadImage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SubmitTagBeanInfo

public SubmitTagBeanInfo()
SubmitTagBeanInfoを新規に生成します。

メソッドの詳細

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。

戻り値:
PropertyDescriptor
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SubmitTEI (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス SubmitTEI

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagExtraInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.SubmitTEI
public class SubmitTEI
extends TagExtraInfo

Submitタグの拡張情報です。

導入されたバージョン:
4.0

コンストラクタの概要
SubmitTEI()
SubmitTEIを新規に生成します。
メソッドの概要
 boolean isValid(TagData tagData)
Linkタグに指定された内容の正当性を検証します。
クラス javax.servlet.jsp.tagext.TagExtraInfo から継承したメソッド
getTagInfo, getVariableInfo, setTagInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SubmitTEI

public SubmitTEI()
SubmitTEIを新規に生成します。

メソッドの詳細

isValid

public boolean isValid(TagData tagData)
Linkタグに指定された内容の正当性を検証します。 検証内容は以下のとおりです。
  • class属性またはsubmitclass属性がある場合、いずれかのみが設定されている

パラメータ:
tagData - タグ情報
戻り値:
タグが正当な場合true、それ以外の場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TagWriter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス TagWriter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.tag.TagWriter
public class TagWriter
extends Object

タグの出力を行います。

バージョン:
1.0

コンストラクタの概要
TagWriter(JspWriter writer)
TagWriterを新規に生成します。
メソッドの概要
static String | createURL(String url, Collection params) 推奨されていません。 このメソッドではなくcreateURL(String, Collection, String)を使用してください。
static String | createURL(String url, Collection params, String encoding) 複数のパラメータをURLに追加します。
void | printAttribute(String name, String value) 属性を出力します。
void | printURL(String url) URLを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

TagWriter

public TagWriter(JspWriter writer)
TagWriterを新規に生成します。

パラメータ:
writer - JSP出力子
メソッドの詳細

createURL

public static String createURL(String url,
                               Collection params)
                        throws IOException
推奨されていません。 このメソッドではなくcreateURL(String, Collection, String)を使用してください。

複数のパラメータをURLに追加します。 paramsはFrameworkTagParamの集合（java.util.Collection）である必要があります。

パラメータ:
url - 元のURL
params - 追加するパラメータ
戻り値:
パラメータが追加されたURL
例外:
IOException - 出力時に例外が発生

createURL

public static String createURL(String url,
                               Collection params,
                               String encoding)
                        throws IOException
複数のパラメータをURLに追加します。 paramsはFrameworkTagParamの集合（java.util.Collection）である必要があります。

パラメータ:
url - 元のURL
params - 追加するパラメータ
encoding - エンコーディング
戻り値:
パラメータが追加されたURL
例外:
IOException - 出力時に例外が発生
導入されたバージョン:
4.3

printURL

public void printURL(String url)
              throws IOException
URLを出力します。 このurlは<FORM>タグのaction属性、<A>タグのhref属性、<FRAME>タグのsrc属性などに定義するものと同じです。

パラメータ:
url - 出力するURL
例外:
IOException - 出力時に例外が発生

printAttribute

public void printAttribute(String name,
                           String value)
                    throws IOException
属性を出力します。 タグの属性として属性名="属性値"の形式で出力します。 属性値がnullまたは空文字列である場合、何も出力しません。

パラメータ:
name - 属性名
value - 属性値
例外:
IOException - 出力時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.base.web.util.HTMLEncoder の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.util.HTMLEncoder の使用

jp.co.intra_mart.framework.base.web.util.HTMLEncoder はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


HTMLEncoder (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.util
クラス HTMLEncoder

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.util.HTMLEncoder
public class HTMLEncoder
extends Object

文字列をHTML形式で表示するための変換を行うユーティリティクラスです。

バージョン:
1.0

コンストラクタの概要
HTMLEncoder()
メソッドの概要
static String | encodeCaption(String caption) キャプションを変換します。
static String | encodeValue(String value) <TEXTAREA>タグまたはvalue属性に入る文字列を変換します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTMLEncoder

public HTMLEncoder()
メソッドの詳細

encodeCaption

public static String encodeCaption(String caption)
キャプションを変換します。 HTML中で特殊な扱いを受ける文字（>,<等）を変換します。
ここでは以下の変換が行われます。
変換前 | 変換後
> &gt;
< &lt;
& &amp;
" &quot;
(半角空白) | &nbsp;
(改行)(*) | <BR>

(*)変換ルールは以下のとおりです。
"\n" -> "\n"
"\r" -> "\n"
ただし、"\r"と"\n"が連続して続く箇所は"\r\n" -> "\n"となります。

パラメータ:
caption - 変換前のキャプション
戻り値:
変換後のキャプション

encodeValue

public static String encodeValue(String value)
<TEXTAREA>タグまたはvalue属性に入る文字列を変換します。 ここでは以下の変換が行われます。
変換前 変換後
> &gt;
< &lt;
& &amp;
" &quot;

パラメータ:
value - 変換前の値
戻り値:
変換後の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.web.util (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.base.web.util
クラス
HTMLEncoder


jp.co.intra_mart.framework.base.web.util (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.util

Web上で使用するユーティリティのパッケージです。

参照:
説明

クラスの概要
HTMLEncoder 文字列をHTML形式で表示するための変換を行うユーティリティクラスです。

パッケージ jp.co.intra_mart.framework.base.web.util の説明

Web上で使用するユーティリティのパッケージです。


jp.co.intra_mart.framework.base.web.util クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.web.util.HTMLEncoder


パッケージ jp.co.intra_mart.framework.base.web.util の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.web.util の使用

jp.co.intra_mart.framework.base.web.util はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.common.util.ServiceUtils の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.common.util.ServiceUtils の使用

jp.co.intra_mart.framework.extension.common.util.ServiceUtils はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.framework.extension.common.util (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.extension.common.util
クラス
ServiceUtils


jp.co.intra_mart.framework.extension.common.util (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.common.util

im-J2EE Frameworkに連携するためのユーティリティです。

参照:
説明

クラスの概要
ServiceUtils im-J2EE Frameworkのサービスフレームワークに連携するためのユーティリティです。

パッケージ jp.co.intra_mart.framework.extension.common.util の説明

im-J2EE Frameworkに連携するためのユーティリティです。 im-J2EE Framework以外のコンポーネントからim-J2EE Frameworkにアクセスできます。


jp.co.intra_mart.framework.extension.common.util クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.common.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.extension.common.util.ServiceUtils


パッケージ jp.co.intra_mart.framework.extension.common.util の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.extension.common.util の使用

jp.co.intra_mart.framework.extension.common.util はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ServiceUtils (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.common.util
クラス ServiceUtils

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.common.util.ServiceUtils
public class ServiceUtils
extends Object

im-J2EE Frameworkのサービスフレームワークに連携するためのユーティリティです。

コンストラクタの概要
ServiceUtils()
メソッドの概要
static Event createEvent(String application, String key, HttpServletRequest request, HttpServletResponse response)
アプリケーションIDとキーに対応するイベントを取得します。
static EventResult dispatchEvent(Event event)
イベントを実行します。
static String getLoginGroupID(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
static String getLoginUserID(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
static UserInfo getUserInfo(HttpServletRequest request, HttpServletResponse response)
ユーザ情報を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ServiceUtils

public ServiceUtils()
メソッドの詳細

getLoginUserID

public static String getLoginUserID(HttpServletRequest request,
                                    HttpServletResponse response)
                             throws SystemException
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。

ログインユーザIDを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ログインユーザID
例外:
SystemException - ログインユーザID取得時に例外が発生

getLoginGroupID

public static String getLoginGroupID(HttpServletRequest request,
                                     HttpServletResponse response)
                              throws SystemException
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。

ログイングループIDを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ログイングループID
例外:
SystemException - ログイングループID取得時に例外が発生

getUserInfo

public static UserInfo getUserInfo(HttpServletRequest request,
                                   HttpServletResponse response)
                            throws SystemException
ユーザ情報を取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ユーザ情報
例外:
SystemException - ユーザ情報取得時に例外が発生

createEvent

public static Event createEvent(String application,
                                String key,
                                HttpServletRequest request,
                                HttpServletResponse response)
                         throws SystemException
アプリケーションIDとキーに対応するイベントを取得します。 イベントにはログイン時のログイングループIDが自動的に登録されます。

パラメータ:
application - アプリケーションID
key - キー
request - リクエスト
response - レスポンス
戻り値:
イベント
例外:
SystemException - イベント取得時に例外が発生

dispatchEvent

public static EventResult dispatchEvent(Event event)
                                 throws EventManagerException,
                                        EventException,
                                        ApplicationException,
                                        SystemException
イベントを実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventManagerException - イベントマネージャの生成に失敗
EventException - イベント処理実行に失敗
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - イベント処理時にシステム例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.extension.seasar.data.S2DataAccessController の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.data.S2DataAccessController の使用

jp.co.intra_mart.framework.extension.seasar.data.S2DataAccessController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.seasar.data.S2DataContainer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.data.S2DataContainer の使用

jp.co.intra_mart.framework.extension.seasar.data.S2DataContainer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.framework.extension.seasar.data (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.extension.seasar.data
クラス
S2DataAccessController
S2DataContainer


jp.co.intra_mart.framework.extension.seasar.data (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.seasar.data

クラスの概要
S2DataAccessController | S2DataAccessControllerはSeasar2 と連携しdaoを生成します。
S2DataContainer | S2DataContainer は Seasar2 と連携するためのDataContainer実装です。


jp.co.intra_mart.framework.extension.seasar.data クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.seasar.data の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.data.DataAccessController
      • class jp.co.intra_mart.framework.extension.seasar.data.S2DataAccessController
    • class jp.co.intra_mart.framework.extension.seasar.data.S2DataContainer (implements jp.co.intra_mart.framework.base.data.container.DataContainer)


パッケージ jp.co.intra_mart.framework.extension.seasar.data の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.extension.seasar.data の使用

jp.co.intra_mart.framework.extension.seasar.data はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


S2DataAccessController (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.data
クラス S2DataAccessController

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataAccessController
        拡張 jp.co.intra_mart.framework.extension.seasar.data.S2DataAccessController
public class S2DataAccessController
extends DataAccessController

S2DataAccessControllerはSeasar2　と連携しdaoを生成します。
S2DataAccessControllerは要求されたdaoオブジェクトをS2Containerから取得し、未登録のdaoは自動的に登録します。
このときS2Containerから返されるdaoオブジェクトは全て新規に生成されたものです。

また、要求されたdaoがインターフェースの場合、S2Containarが保持するコンポーネントとみなし、S2Containarから直接コンポーネントを取得します。

導入されたバージョン:
6.0

コンストラクタの概要
S2DataAccessController(DataPropertyHandler handler)
データアクセスコントローラを生成します。
メソッドの概要
 Object getDAO(String application, String key, String connect)
DAOを取得します。
クラス jp.co.intra_mart.framework.base.data.DataAccessController から継承したメソッド
commit, getDataConnectors, getDataPropertyHandler, release, rollback
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

S2DataAccessController

public S2DataAccessController(DataPropertyHandler handler)
データアクセスコントローラを生成します。

パラメータ:
handler - データプロパティハンドラ
メソッドの詳細

getDAO

public Object getDAO(String application,
                     String key,
                     String connect)
              throws DataPropertyException,
                     DataConnectorException,
                     DAOException,
                     DataConnectException
DAOを取得します。 キーと接続情報で指定されたDAOを取得します。

指定されたDAOがインターフェースの場合S2Containerからコンポーネントを取得します。
この場合、diconファイルへの定義、dao.dicon等の設定が必要です。
S2Containerからコンポーネントを取得する場合接続情報を指定する必要はありません。 接続先データベースの解決はdiconファイルのデータソース設定に依存するため、 AutoDetectedDataSource等をデータソースに設定してください。

オーバーライド:
クラス DataAccessController 内の getDAO
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAOまたはS2Containerから取得したオブジェクト
例外:
DataPropertyException - プロパティの取得に失敗
DataConnectorException - データコネクタの取得に失敗
DAOException - DAOの取得に失敗
DataConnectException - データリソースとの接続に失敗
関連項目:
AutoDetectedDataSource, LoginGroupDataSource, SystemDataSource
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


S2DataContainer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.data
クラス S2DataContainer

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.seasar.data.S2DataContainer
すべての実装インタフェース:
DataContainer, IMContainer
public class S2DataContainer
extends Object
implements DataContainer

S2DataContainer　は　Seasar2　と連携するためのDataContainer実装です。
実際の連携はS2DataContainerが保持するS2DataAccessControllerが行います。

導入されたバージョン:
6.0
関連項目:
S2DataAccessController

フィールドの概要
インタフェース jp.co.intra_mart.framework.base.data.container.DataContainer から継承したフィールド
DATA_PROPERTY_HANDLER_KEY
コンストラクタの概要
S2DataContainer()
S2DataContainerを生成します。
メソッドの概要
DataAccessController | getDataAccessController() データアクセスコントローラを取得します。
DataPropertyHandler | getDataPropertyHandler() データプロパティハンドラを取得します。
void | init() DataContainerを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

S2DataContainer

public S2DataContainer()
S2DataContainerを生成します。

メソッドの詳細

init

public void init()
          throws IMContainerException
DataContainerを初期化します。

定義:
インタフェース IMContainer 内の init
例外:
IMContainerException

getDataPropertyHandler

public DataPropertyHandler getDataPropertyHandler()
データプロパティハンドラを取得します。

定義:
インタフェース DataContainer 内の getDataPropertyHandler
戻り値:
データプロパティハンドラ

getDataAccessController

public DataAccessController getDataAccessController()
データアクセスコントローラを取得します。

定義:
インタフェース DataContainer 内の getDataAccessController
戻り値:
データアクセスコントローラ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.extension.seasar.event.S2EventContainer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.event.S2EventContainer の使用

jp.co.intra_mart.framework.extension.seasar.event.S2EventContainer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.seasar.event.S2EventListenerFactory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.event.S2EventListenerFactory の使用

jp.co.intra_mart.framework.extension.seasar.event.S2EventListenerFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.framework.extension.seasar.event (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.extension.seasar.event
クラス
S2EventContainer
S2EventListenerFactory


jp.co.intra_mart.framework.extension.seasar.event (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.seasar.event

クラスの概要
S2EventContainer | S2EventContainer は Seasar2 と連携しオブジェクトを生成します。
S2EventListenerFactory | S2EventListenerFactoryはEventListener生成時にS2Containerから取得します。


jp.co.intra_mart.framework.extension.seasar.event クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.seasar.event の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.extension.seasar.event.S2EventContainer (implements jp.co.intra_mart.framework.base.event.container.EventContainer)
    • class jp.co.intra_mart.framework.extension.seasar.event.S2EventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)


パッケージ jp.co.intra_mart.framework.extension.seasar.event の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.extension.seasar.event の使用

jp.co.intra_mart.framework.extension.seasar.event はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


S2EventContainer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.event
クラス S2EventContainer

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.seasar.event.S2EventContainer
すべての実装インタフェース:
EventContainer, IMContainer
public class S2EventContainer
extends Object
implements EventContainer

S2EventContainer　は　Seasar2　と連携しオブジェクトを生成します。
S2EventContainerは要求されたEventオブジェクトをS2Containerから取得し、未登録のEventオブジェクトは自動的に登録します。
このときS2Containerから返されるEventオブジェクトは全て新規に生成されたものです。

導入されたバージョン:
6.0

フィールドの概要
インタフェース jp.co.intra_mart.framework.base.event.container.EventContainer から継承したフィールド
EVENT_PROPERTY_HANDLER_KEY
コンストラクタの概要
S2EventContainer()
メソッドの概要
Event | createEvent(String application, String key) パラメータで指定された内容に該当するイベントを生成します。
EventResult | dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventPropertyHandler | getEventPropertyHandler() イベントプロパティハンドラを取得します。
void | init() IMContainerを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

S2EventContainer

public S2EventContainer()
メソッドの詳細

createEvent

public Event createEvent(String application,
                         String key)
                  throws EventPropertyException,
                         EventException
インタフェース EventContainer の記述:
パラメータで指定された内容に該当するイベントを生成します。

定義:
インタフェース EventContainer 内の createEvent
パラメータ:
application - アプリケーション名
key - キー
戻り値:
パラメータに該当するイベント
例外:
EventPropertyException - イベントプロパティの取得に失敗
EventException - イベント生成に失敗

dispatch

public EventResult dispatch(Event event,
                            boolean transaction)
                     throws EventException,
                            SystemException,
                            ApplicationException
インタフェース EventContainer の記述:
イベントに対する処理を実行します。

定義:
インタフェース EventContainer 内の dispatch
パラメータ:
event - イベント
transaction - トランザクションの中で実行されているかどうかを示すフラグ（トランザクション内の場合true、トランザクション外の場合false）
戻り値:
イベント処理結果
例外:
SystemException - イベント処理時にシステム例外が発生
EventException - 不正なイベントが渡された
ApplicationException - イベント処理時にアプリケーション例外が発生

getEventPropertyHandler

public EventPropertyHandler getEventPropertyHandler()
インタフェース EventContainer の記述:
イベントプロパティハンドラを取得します。

定義:
インタフェース EventContainer 内の getEventPropertyHandler
戻り値:
イベントプロパティハンドラ

init

public void init()
          throws IMContainerException
インタフェース IMContainer の記述:
IMContainerを初期化します。

定義:
インタフェース IMContainer 内の init
例外:
IMContainerException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


S2EventListenerFactory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.event
クラス S2EventListenerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.seasar.event.S2EventListenerFactory
すべての実装インタフェース:
EventListenerFactory
public class S2EventListenerFactory
extends Object
implements EventListenerFactory

S2EventListenerFactoryはEventListener生成時にS2Containerから取得します。
EventListenerがS2Containerに登録されていない場合EventListenerを自動的に登録し、 他のコンポーネントとバインドされたEventListenerを返します。
このファクトリで指定できる初期パラメータは以下のとおりです。

パラメータ名 | 値
listener | 生成するイベントリスナ

導入されたバージョン:
6.0

コンストラクタの概要
S2EventListenerFactory()
S2EventListenerFactoryを新規に生成します。
メソッドの概要
EventListener | create(Event event) イベントリスナを生成します。
void | initParam(String name, String value) 初期パラメータを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

S2EventListenerFactory

public S2EventListenerFactory()
S2EventListenerFactoryを新規に生成します。

メソッドの詳細

create

public EventListener create(Event event)
                     throws EventListenerException
イベントリスナを生成します。 初期パラメータで指定されたクラスをイベントリスナとして生成します。 初期パラメータで指定されたクラスはStandardEventListenerを継承している必要があります。

定義:
インタフェース EventListenerFactory 内の create
パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

定義:
インタフェース EventListenerFactory 内の initParam
パラメータ:
name - パラメータ名
value - パラメータの値
例外:
EventListenerException - パラメータの設定時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager の使用

jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction の使用

jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


LoggingTransactionManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.jta
クラス LoggingTransactionManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager
すべての実装インタフェース:
TransactionManager
public class LoggingTransactionManager
extends Object
implements TransactionManager

TransactionManagerをラップし、以下のメソッドの呼び出し時にintra-mart データベースログを出力します。

・begin
・commit
・rollback

コンストラクタの概要
LoggingTransactionManager()
LoggingTransactionManager(TransactionManager tm)
TransactionManagerをラップし、新規にDBLogTransactionManagerを生成します。
メソッドの概要
void | begin() ラップしたTransactionManagerのbeginを呼び出します。
void | commit() ラップしたTransactionManagerのcommitを呼び出します。
int | getStatus() ラップしたTransactionManagerのgetStatusを呼び出します。
Transaction | getTransaction() ラップしたTransactionManagerのgetTransactionを呼び出します。
void | resume(Transaction transaction) ラップしたTransactionManagerのresumeを呼び出します。
void | rollback() ラップしたTransactionManagerのrollbackを呼び出します。
void | setRollbackOnly() ラップしたTransactionManagerのsetRollbackOnlyを呼び出します。
void | setTransactionTimeout(int time) ラップしたTransactionManagerのsetTransactionTimeoutを呼び出します。
Transaction | suspend() ラップしたTransactionManagerのsuspendを呼び出します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LoggingTransactionManager

public LoggingTransactionManager()

LoggingTransactionManager

public LoggingTransactionManager(TransactionManager tm)
TransactionManagerをラップし、新規にDBLogTransactionManagerを生成します。

パラメータ:
tm - TransactionManagerのインスタンス
メソッドの詳細

begin

public void begin()
           throws NotSupportedException,
                  SystemException
ラップしたTransactionManagerのbeginを呼び出します。
呼出し後にデータベースログを出力します。

定義:
インタフェース TransactionManager 内の begin
例外:
NotSupportedException
SystemException

commit

public void commit()
            throws RollbackException,
                   HeuristicMixedException,
                   HeuristicRollbackException,
                   SecurityException,
                   IllegalStateException,
                   SystemException
ラップしたTransactionManagerのcommitを呼び出します。
呼出し後にデータベースログを出力します。

定義:
インタフェース TransactionManager 内の commit
例外:
RollbackException
HeuristicMixedException
HeuristicRollbackException
SecurityException
IllegalStateException
SystemException

getStatus

public int getStatus()
              throws SystemException
ラップしたTransactionManagerのgetStatusを呼び出します。

定義:
インタフェース TransactionManager 内の getStatus
例外:
SystemException

getTransaction

public Transaction getTransaction()
                           throws SystemException
ラップしたTransactionManagerのgetTransactionを呼び出します。

定義:
インタフェース TransactionManager 内の getTransaction
例外:
SystemException

resume

public void resume(Transaction transaction)
            throws InvalidTransactionException,
                   IllegalStateException,
                   SystemException
ラップしたTransactionManagerのresumeを呼び出します。

定義:
インタフェース TransactionManager 内の resume
例外:
InvalidTransactionException
IllegalStateException
SystemException

rollback

public void rollback()
              throws IllegalStateException,
                     SecurityException,
                     SystemException
ラップしたTransactionManagerのrollbackを呼び出します。
呼出し後にデータベースログを出力します。

定義:
インタフェース TransactionManager 内の rollback
例外:
IllegalStateException
SecurityException
SystemException

setRollbackOnly

public void setRollbackOnly()
                     throws IllegalStateException,
                            SystemException
ラップしたTransactionManagerのsetRollbackOnlyを呼び出します。

定義:
インタフェース TransactionManager 内の setRollbackOnly
例外:
IllegalStateException
SystemException

setTransactionTimeout

public void setTransactionTimeout(int time)
                           throws SystemException
ラップしたTransactionManagerのsetTransactionTimeoutを呼び出します。

定義:
インタフェース TransactionManager 内の setTransactionTimeout
例外:
SystemException

suspend

public Transaction suspend()
                    throws SystemException
ラップしたTransactionManagerのsuspendを呼び出します。

定義:
インタフェース TransactionManager 内の suspend
例外:
SystemException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LoggingUserTransaction (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.jta
クラス LoggingUserTransaction

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction
すべての実装インタフェース:
UserTransaction
public class LoggingUserTransaction
extends Object
implements UserTransaction

UserTransactionをラップし、以下のメソッドの呼び出し時にintra-mart データベースログを出力します。

・begin
・commit
・rollback

コンストラクタの概要
LoggingUserTransaction()
LoggingUserTransaction(UserTransaction ut)
UserTransactionをラップし、新規にDBLogUserTransactionを生成します。
メソッドの概要
void | begin() ラップしたUserTransactionのbeginを呼び出します。
void | commit() ラップしたUserTransactionのcommitを呼び出します。
int | getStatus() ラップしたUserTransactionのgeｔStatusを呼び出します。
void | rollback() ラップしたUserTransactionのrollbackを呼び出します。
void | setRollbackOnly() ラップしたUserTransactionのsetRollbackOnlyを呼び出します。
void | setTransactionTimeout(int time) ラップしたUserTransactionのsetTransactionTimeoutを呼び出します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LoggingUserTransaction

public LoggingUserTransaction()

LoggingUserTransaction

public LoggingUserTransaction(UserTransaction ut)
UserTransactionをラップし、新規にDBLogUserTransactionを生成します。

パラメータ:
ut - UserTransactionのインスタンス
メソッドの詳細

begin

public void begin()
           throws NotSupportedException,
                  SystemException
ラップしたUserTransactionのbeginを呼び出します。
呼出し後にデータベースログを出力します。

定義:
インタフェース UserTransaction 内の begin
例外:
NotSupportedException
SystemException

commit

public void commit()
            throws RollbackException,
                   HeuristicMixedException,
                   HeuristicRollbackException,
                   SecurityException,
                   IllegalStateException,
                   SystemException
ラップしたUserTransactionのcommitを呼び出します。
呼出し後にデータベースログを出力します。

定義:
インタフェース UserTransaction 内の commit
例外:
RollbackException
HeuristicMixedException
HeuristicRollbackException
SecurityException
IllegalStateException
SystemException

getStatus

public int getStatus()
              throws SystemException
ラップしたUserTransactionのgeｔStatusを呼び出します。

定義:
インタフェース UserTransaction 内の getStatus
例外:
SystemException

rollback

public void rollback()
              throws IllegalStateException,
                     SecurityException,
                     SystemException
ラップしたUserTransactionのrollbackを呼び出します。
呼出し後にデータベースログを出力します。

定義:
インタフェース UserTransaction 内の rollback
例外:
IllegalStateException
SecurityException
SystemException

setRollbackOnly

public void setRollbackOnly()
                     throws IllegalStateException,
                            SystemException
ラップしたUserTransactionのsetRollbackOnlyを呼び出します。

定義:
インタフェース UserTransaction 内の setRollbackOnly
例外:
IllegalStateException
SystemException

setTransactionTimeout

public void setTransactionTimeout(int time)
                           throws SystemException
ラップしたUserTransactionのsetTransactionTimeoutを呼び出します。

定義:
インタフェース UserTransaction 内の setTransactionTimeout
例外:
SystemException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.extension.seasar.jta (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.extension.seasar.jta
クラス
LoggingTransactionManager
LoggingUserTransaction


jp.co.intra_mart.framework.extension.seasar.jta (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.seasar.jta

クラスの概要
LoggingTransactionManager | TransactionManagerをラップし、以下のメソッドの呼び出し時にintra-mart データベースログを出力します。
LoggingUserTransaction | UserTransactionをラップし、以下のメソッドの呼び出し時にintra-mart データベースログを出力します。


jp.co.intra_mart.framework.extension.seasar.jta クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.seasar.jta の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager (implements javax.transaction.TransactionManager)
    • class jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction (implements javax.transaction.UserTransaction)


パッケージ jp.co.intra_mart.framework.extension.seasar.jta の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.extension.seasar.jta の使用

jp.co.intra_mart.framework.extension.seasar.jta はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.seasar.service.S2ServiceContainer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.service.S2ServiceContainer の使用

jp.co.intra_mart.framework.extension.seasar.service.S2ServiceContainer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.framework.extension.seasar.service (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.extension.seasar.service
クラス
S2ServiceContainer


jp.co.intra_mart.framework.extension.seasar.service (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.seasar.service

クラスの概要
S2ServiceContainer S2ServiceContainer　は　Seasar2　と連携しオブジェクトを生成します。


jp.co.intra_mart.framework.extension.seasar.service クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.seasar.service の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.extension.seasar.service.S2ServiceContainer (implements jp.co.intra_mart.framework.base.service.container.ServiceContainer)


パッケージ jp.co.intra_mart.framework.extension.seasar.service の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.extension.seasar.service の使用

jp.co.intra_mart.framework.extension.seasar.service はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


S2ServiceContainer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.service
クラス S2ServiceContainer

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.seasar.service.S2ServiceContainer
すべての実装インタフェース:
IMContainer, ServiceContainer
public class S2ServiceContainer
extends Object
implements ServiceContainer

S2ServiceContainer　は　Seasar2　と連携しオブジェクトを生成します。
S2ServiceContainerはオブジェクト生成時にS2Containerから取得します。 コンポーネントが登録されていない場合コンポーネントを自動的に登録し、 他のコンポーネントとバインドされたオブジェクトを返します。
自動的にS2Containerに登録されるオブジェクトは以下の通りです。

ServiceController
Transition

これらのオブジェクトは全て新規に生成されたものです。

導入されたバージョン:
6.0

フィールドの概要
インタフェース jp.co.intra_mart.framework.base.service.container.ServiceContainer から継承したフィールド
SERVICE_PROPERTY_HANDLER_KEY
コンストラクタの概要
S2ServiceContainer()
S2ServiceContainerを生成します。
メソッドの概要
ServiceController | getServiceController(String application, String service, Locale locale) サービスコントローラを取得します。
ServicePropertyHandler | getServicePropertyHandler() サービスプロパティハンドラを取得します。
Transition | getTransition(String application, String service, Locale locale) トランジションを取得します。
void | init() ServiceContainerを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

S2ServiceContainer

public S2ServiceContainer()
S2ServiceContainerを生成します。

メソッドの詳細

init

public void init()
          throws IMContainerException
ServiceContainerを初期化します。

定義:
インタフェース IMContainer 内の init
例外:
IMContainerException

getServiceController

public ServiceController getServiceController(String application,
                                              String service,
                                              Locale locale)
                                       throws ServicePropertyException,
                                              ServiceControllerException
インタフェース ServiceContainer の記述:
サービスコントローラを取得します。 指定されたアプリケーションID、サービスID、ロケールに該当するサービスコントローラを取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

定義:
インタフェース ServiceContainer 内の getServiceController
パラメータ:
application - アプリケーション
service - サービス
locale - ロケール
戻り値:
サービスコントローラ、存在しない場合はnull
例外:
ServiceControllerException - サービスコントローラ取得時に例外が発生
ServicePropertyException - サービスプロパティの取得時に例外が発生

getServicePropertyHandler

public ServicePropertyHandler getServicePropertyHandler()
インタフェース ServiceContainer の記述:
サービスプロパティハンドラを取得します。

定義:
インタフェース ServiceContainer 内の getServicePropertyHandler
戻り値:
サービスプロパティハンドラ

getTransition

public Transition getTransition(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException,
                                TransitionException
インタフェース ServiceContainer の記述:
トランジションを取得します。 指定されたアプリケーションID、サービスID、ロケールに該当するトランジションを取得します。 該当するトランジションが存在しない場合、DefaultTransitionを返します。

定義:
インタフェース ServiceContainer 内の getTransition
パラメータ:
application - アプリケーション
service - サービス
locale - ロケール
戻り値:
トランジション
例外:
TransitionException - トランジション取得時に例外が発生
ServicePropertyException - サービスプロパティの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedDataSource の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedDataSource の使用

jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedDataSource はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedUserInfo の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedUserInfo の使用

jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedUserInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator の使用

jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.seasar.util.ComponentUtil の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.util.ComponentUtil の使用

jp.co.intra_mart.framework.extension.seasar.util.ComponentUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource の使用

LoginGroupDataSource を使用しているパッケージ
jp.co.intra_mart.framework.extension.seasar.util

jp.co.intra_mart.framework.extension.seasar.util での LoginGroupDataSource の使用

jp.co.intra_mart.framework.extension.seasar.util での LoginGroupDataSource のサブクラス
 class AutoDetectedDataSource
セッション情報からログイングループに設定されているデータソースを取得しラップします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource の使用

jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AutoDetectedDataSource (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.util
クラス AutoDetectedDataSource

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource
        拡張 jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedDataSource
すべての実装インタフェース:
DataSource
public class AutoDetectedDataSource
extends LoginGroupDataSource

セッション情報からログイングループに設定されているデータソースを取得しラップします。
この機能を利用するためには、S2ContainerFilterをweb.xmlに設定し、URLにマッピングする必要があります。

導入されたバージョン:
6.0

コンストラクタの概要
protected | AutoDetectedDataSource()
 | AutoDetectedDataSource(InitialContext ctx) AutoDetectedDataSourceを新規に生成します。
メソッドの概要
protected DataSource | findLoginGroupDataSource() セッション情報からログイングループに設定されているデータソースを取得します。
String | getLoginGroupId() ログイングループIDを取得します。
クラス jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource から継承したメソッド
getConnection, getConnection, getLoginTimeout, getLogWriter, setLoginTimeout, setLogWriter
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AutoDetectedDataSource

protected AutoDetectedDataSource()

AutoDetectedDataSource

public AutoDetectedDataSource(InitialContext ctx)
AutoDetectedDataSourceを新規に生成します。

パラメータ:
ctx - 初期コンテキスト
メソッドの詳細

findLoginGroupDataSource

protected DataSource findLoginGroupDataSource()
                                       throws DataAccessException
セッション情報からログイングループに設定されているデータソースを取得します。

オーバーライド:
クラス LoginGroupDataSource 内の findLoginGroupDataSource
戻り値:
データソース
例外:
DataAccessException - データソース取得時にエラーが発生

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

オーバーライド:
クラス LoginGroupDataSource 内の getLoginGroupId
戻り値:
ログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AutoDetectedUserInfo (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.util
クラス AutoDetectedUserInfo

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.util.UserInfoWrapper
        拡張 jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedUserInfo
すべての実装インタフェース:
Serializable, UserInfo
public class AutoDetectedUserInfo
extends UserInfoWrapper

セッションからログイン情報を取得するUserInfoのラッパークラスです。 この機能を利用するためには、S2ContainerFilterをweb.xmlに設定し、URLにマッピングする必要があります。

導入されたバージョン:
6.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.framework.base.util.UserInfoWrapper から継承したフィールド
BLANK_USER_INFO
コンストラクタの概要
AutoDetectedUserInfo()
AutoDetectedUserInfoを新規に生成します。
メソッドの概要
protected  UserInfo getRealUserInfo()
このオブジェクトがラップしているUserInfoの実装を返します。
クラス jp.co.intra_mart.framework.base.util.UserInfoWrapper から継承したメソッド
getClientType, getColorPatternID, getEncoding, getLocale, getLoginGroupID, getLoginTime, getLoginType, getUserID, setRealUserInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AutoDetectedUserInfo

public AutoDetectedUserInfo()
AutoDetectedUserInfoを新規に生成します。

メソッドの詳細

getRealUserInfo

protected UserInfo getRealUserInfo()
このオブジェクトがラップしているUserInfoの実装を返します。

オーバーライド:
クラス UserInfoWrapper 内の getRealUserInfo
戻り値:
UserInfoオブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ComponentNameCreator (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.util
クラス ComponentNameCreator

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator
public class ComponentNameCreator
extends Object

導入されたバージョン:
6.0

フィールドの概要
static String | CONTROLLER_SUFFIX
static String | DAO_SUFFIX
static String | EVENT_LISTENER_SUFFIX
static String | EVENT_OBJECT_SUFFIX
static String | TRANSITION_SUFFIX
コンストラクタの概要
ComponentNameCreator()
メソッドの概要
static String | createControllerName(String application, String service) サービスコントローラのコンポーネント名を返します。
static String | createDaoName(String application, String daoKey) daoのコンポーネント名を返します。
static String | createEventListenerName(String application, String eventKey) イベントリスナのコンポーネント名を返します。
static String | createEventName(String application, String eventKey) イベントオブジェクトのコンポーネント名を返します。
static String | createTransitionName(String application, String service) トランジションのコンポーネント名を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

CONTROLLER_SUFFIX

public static String CONTROLLER_SUFFIX

TRANSITION_SUFFIX

public static String TRANSITION_SUFFIX

EVENT_OBJECT_SUFFIX

public static String EVENT_OBJECT_SUFFIX

EVENT_LISTENER_SUFFIX

public static String EVENT_LISTENER_SUFFIX

DAO_SUFFIX

public static String DAO_SUFFIX
コンストラクタの詳細

ComponentNameCreator

public ComponentNameCreator()
メソッドの詳細

createControllerName

public static String createControllerName(String application,
                                          String service)
サービスコントローラのコンポーネント名を返します。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
コンポーネント名

createTransitionName

public static String createTransitionName(String application,
                                          String service)
トランジションのコンポーネント名を返します。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
コンポーネント名

createEventName

public static String createEventName(String application,
                                     String eventKey)
イベントオブジェクトのコンポーネント名を返します。

パラメータ:
application - アプリケーションID
eventKey - イベントキー
戻り値:
コンポーネント名

createEventListenerName

public static String createEventListenerName(String application,
                                             String eventKey)
イベントリスナのコンポーネント名を返します。

パラメータ:
application - アプリケーションID
eventKey - イベントキー
戻り値:
コンポーネント名

createDaoName

public static String createDaoName(String application,
                                   String daoKey)
daoのコンポーネント名を返します。

パラメータ:
application - アプリケーションID
daoKey - daoキー
戻り値:
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ComponentUtil (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.util
クラス ComponentUtil

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.seasar.util.ComponentUtil
public class ComponentUtil
extends Object

イントラマート、Seasar2連携のユーティリティクラスです。

導入されたバージョン:
6.0

メソッドの概要
static void register(S2Container container, Class component, String componentKey, InstanceDef instanceType)
指定したキーでS2Containerにコンポーネントを登録します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

register

public static void register(S2Container container,
                            Class component,
                            String componentKey,
                            InstanceDef instanceType)
指定したキーでS2Containerにコンポーネントを登録します。 既にキーが登録されている場合は登録しません。

パラメータ:
container - S2Container
component - S2Containerに登録するクラス
componentKey - コンポーネントキー
instanceType - インスタンス属性
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginGroupDataSource (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.util
クラス LoginGroupDataSource

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource
すべての実装インタフェース:
DataSource
直系の既知のサブクラス:
AutoDetectedDataSource
public class LoginGroupDataSource
extends Object
implements DataSource

ログイングループに設定されたデータソースをラップします。 このデータソースの動作はラップされたデータソースと同じです。

導入されたバージョン:
6.0

コンストラクタの概要
protected | LoginGroupDataSource()
 | LoginGroupDataSource(InitialContext ctx, String loginGroupId) 指定したログイングループに設定されたデータソースをラップします。
メソッドの概要
protected DataSource | findLoginGroupDataSource() このオブジェクトがラップするデータソースを返します。
Connection | getConnection() ラップされたデータソースのgetConnection()を呼び出します。
Connection | getConnection(String username, String password) ラップされたデータソースのgetConnection(String, String)を呼び出します。
String | getLoginGroupId() ログイングループIDを取得します。
int | getLoginTimeout() ラップされたデータソースのgetLoginTimeout()を呼び出します。
PrintWriter | getLogWriter() ラップされたデータソースのgetLogWriter()を呼び出します。
void | setLoginTimeout(int seconds) ラップされたデータソースのsetLoginTimeout(int)を呼び出します。
void | setLogWriter(PrintWriter out) ラップされたデータソースのsetLogWriter(PrintWriter)を呼び出します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LoginGroupDataSource

protected LoginGroupDataSource()

LoginGroupDataSource

public LoginGroupDataSource(InitialContext ctx,
                            String loginGroupId)
指定したログイングループに設定されたデータソースをラップします。

パラメータ:
ctx - 初期コンテキスト
loginGroupId - ログイングループID
メソッドの詳細

getConnection

public Connection getConnection()
                         throws SQLException
ラップされたデータソースのgetConnection()を呼び出します。

定義:
インタフェース DataSource 内の getConnection
戻り値:
コネクション
例外:
SQLException - データベースエラーが発生

getConnection

public Connection getConnection(String username,
                                String password)
                         throws SQLException
ラップされたデータソースのgetConnection(String, String)を呼び出します。

定義:
インタフェース DataSource 内の getConnection
パラメータ:
username - データベースユーザ
password - ユーザのパスワード
戻り値:
コネクション
例外:
SQLException - データベースエラーが発生

getLogWriter

public PrintWriter getLogWriter()
                         throws SQLException
ラップされたデータソースのgetLogWriter()を呼び出します。

定義:
インタフェース DataSource 内の getLogWriter
戻り値:
データソースのログライター
例外:
SQLException - データベースエラーが発生

getLoginTimeout

public int getLoginTimeout()
                    throws SQLException
ラップされたデータソースのgetLoginTimeout()を呼び出します。

定義:
インタフェース DataSource 内の getLoginTimeout
戻り値:
データソースのログイン制限時間
例外:
SQLException - データベースエラーが発生

setLogWriter

public void setLogWriter(PrintWriter out)
                  throws SQLException
ラップされたデータソースのsetLogWriter(PrintWriter)を呼び出します。

定義:
インタフェース DataSource 内の setLogWriter
パラメータ:
out - 新しいログライター
例外:
SQLException - データベースエラーが発生

setLoginTimeout

public void setLoginTimeout(int seconds)
                     throws SQLException
ラップされたデータソースのsetLoginTimeout(int)を呼び出します。

定義:
インタフェース DataSource 内の setLoginTimeout
パラメータ:
seconds - データソースのログイン制限時間
例外:
SQLException - データベースエラーが発生

findLoginGroupDataSource

protected DataSource findLoginGroupDataSource()
                                       throws DataAccessException
このオブジェクトがラップするデータソースを返します。

戻り値:
データソース
例外:
DataAccessException - データベースエラーが発生

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

戻り値:
ログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.extension.seasar.util (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.extension.seasar.util
クラス
AutoDetectedDataSource
AutoDetectedUserInfo
ComponentNameCreator
ComponentUtil
LoginGroupDataSource
SystemDataSource


jp.co.intra_mart.framework.extension.seasar.util (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.seasar.util

クラスの概要
AutoDetectedDataSource | セッション情報からログイングループに設定されているデータソースを取得しラップします。
AutoDetectedUserInfo | セッションからログイン情報を取得するUserInfoのラッパークラスです。
ComponentNameCreator |
ComponentUtil | イントラマート、Seasar2連携のユーティリティクラスです。
LoginGroupDataSource | ログイングループに設定されたデータソースをラップします。
SystemDataSource | システムに設定されたデータソースをラップします。


jp.co.intra_mart.framework.extension.seasar.util クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.seasar.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator
    • class jp.co.intra_mart.framework.extension.seasar.util.ComponentUtil
    • class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource (implements javax.sql.DataSource)
      • class jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedDataSource
    • class jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource (implements javax.sql.DataSource)
    • class jp.co.intra_mart.framework.base.util.UserInfoWrapper (implements jp.co.intra_mart.framework.base.util.UserInfo)
      • class jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedUserInfo


パッケージ jp.co.intra_mart.framework.extension.seasar.util の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.extension.seasar.util の使用

jp.co.intra_mart.framework.extension.seasar.util を使用しているパッケージ
jp.co.intra_mart.framework.extension.seasar.util

jp.co.intra_mart.framework.extension.seasar.util により使用される jp.co.intra_mart.framework.extension.seasar.util のクラス
LoginGroupDataSource
ログイングループに設定されたデータソースをラップします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SystemDataSource (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.util
クラス SystemDataSource

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource
すべての実装インタフェース:
DataSource
public class SystemDataSource
extends Object
implements DataSource

システムに設定されたデータソースをラップします。 このデータソースの動作はラップされたデータソースと同じです。

導入されたバージョン:
6.0

コンストラクタの概要
protected | SystemDataSource()
 | SystemDataSource(InitialContext ctx, String connectId) 指定した識別子に設定されたデータソースをラップします。
メソッドの概要
String | getConnectId() システムデータソースの識別子を取得します。
Connection | getConnection() ラップされたデータソースのgetConnection()を呼び出します。
Connection | getConnection(String username, String password) ラップされたデータソースのgetConnection(String, String)を呼び出します。
int | getLoginTimeout() ラップされたデータソースのgetLoginTimeout()を呼び出します。
PrintWriter | getLogWriter() ラップされたデータソースのgetLogWriter()を呼び出します。
void | setLoginTimeout(int seconds) ラップされたデータソースのsetLoginTimeout(int)を呼び出します。
void | setLogWriter(PrintWriter out) ラップされたデータソースのsetLogWriter(PrintWriter)を呼び出します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SystemDataSource

protected SystemDataSource()

SystemDataSource

public SystemDataSource(InitialContext ctx,
                        String connectId)
指定した識別子に設定されたデータソースをラップします。

パラメータ:
ctx - 初期コンテキスト
メソッドの詳細

getConnection

public Connection getConnection()
                         throws SQLException
ラップされたデータソースのgetConnection()を呼び出します。

定義:
インタフェース DataSource 内の getConnection
戻り値:
コネクション
例外:
SQLException - データベースエラーが発生

getConnection

public Connection getConnection(String username,
                                String password)
                         throws SQLException
ラップされたデータソースのgetConnection(String, String)を呼び出します。

定義:
インタフェース DataSource 内の getConnection
パラメータ:
username - データベースユーザ
password - ユーザのパスワード
戻り値:
コネクション
例外:
SQLException - データベースエラーが発生

getLogWriter

public PrintWriter getLogWriter()
                         throws SQLException
ラップされたデータソースのgetLogWriter()を呼び出します。

定義:
インタフェース DataSource 内の getLogWriter
戻り値:
データソースのログライター
例外:
SQLException - データベースエラーが発生

getLoginTimeout

public int getLoginTimeout()
                    throws SQLException
ラップされたデータソースのgetLoginTimeout()を呼び出します。

定義:
インタフェース DataSource 内の getLoginTimeout
戻り値:
データソースのログイン制限時間
例外:
SQLException - データベースエラーが発生

setLogWriter

public void setLogWriter(PrintWriter out)
                  throws SQLException
ラップされたデータソースのsetLogWriter(PrintWriter)を呼び出します。

定義:
インタフェース DataSource 内の setLogWriter
パラメータ:
out - 新しいログライター
例外:
SQLException - データベースエラーが発生

setLoginTimeout

public void setLoginTimeout(int seconds)
                     throws SQLException
ラップされたデータソースのsetLoginTimeout(int)を呼び出します。

定義:
インタフェース DataSource 内の setLoginTimeout
パラメータ:
seconds - データソースのログイン制限時間
例外:
SQLException - データベースエラーが発生

getConnectId

public String getConnectId()
システムデータソースの識別子を取得します。

戻り値:
システムデータソースの識別子
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.extension.struts.action.IntramartAction の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.struts.action.IntramartAction の使用

jp.co.intra_mart.framework.extension.struts.action.IntramartAction はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter の使用

jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


IntramartAction (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.struts.action
クラス IntramartAction

java.lang.Object
    拡張 org.apache.struts.action.Action
        拡張 jp.co.intra_mart.framework.extension.struts.action.IntramartAction
public class IntramartAction
extends org.apache.struts.action.Action

ServiceControllerAdapterと似たメソッドを持つActionクラスです。 いくつかのメソッドはHttpServletRequestと HttpServletResponseを必要とする点が ServiceControllerAdapter と異なります。

関連項目:
ServiceControllerAdapter

フィールドの概要
クラス org.apache.struts.action.Action から継承したフィールド
defaultLocale, servlet
コンストラクタの概要
IntramartAction()
メソッドの概要
protected  Event createEvent(String application, String key, HttpServletRequest request, HttpServletResponse response)
アプリケーションIDとキーに対応するイベントを取得します。
protected  EventResult dispatchEvent(Event event)
イベント処理を実行します。
protected  String getLoginGroupID(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
protected  String getLoginUserID(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
protected  UserInfo getUserInfo(HttpServletRequest request, HttpServletResponse response)
ユーザ情報を取得します。
クラス org.apache.struts.action.Action から継承したメソッド
addErrors, addMessages, execute, execute, generateToken, getDataSource, getDataSource, getErrors, getLocale, getMessages, getResources, getResources, getServlet, isCancelled, isTokenValid, isTokenValid, resetToken, saveErrors, saveErrors, saveErrors, saveMessages, saveMessages, saveToken, setLocale, setServlet
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartAction

public IntramartAction()
メソッドの詳細

getLoginUserID

protected String getLoginUserID(HttpServletRequest request,
                                HttpServletResponse response)
                         throws SystemException
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。

ログインユーザIDを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ログインユーザID
例外:
SystemException - ログインユーザID取得時に例外が発生

getLoginGroupID

protected String getLoginGroupID(HttpServletRequest request,
                                 HttpServletResponse response)
                          throws SystemException
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。

ログイングループIDを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ログイングループID
例外:
SystemException - ログイングループID取得時に例外が発生

getUserInfo

protected UserInfo getUserInfo(HttpServletRequest request,
                               HttpServletResponse response)
                        throws SystemException
ユーザ情報を取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ユーザ情報
例外:
SystemException - ユーザ情報取得時に例外が発生

createEvent

protected Event createEvent(String application,
                            String key,
                            HttpServletRequest request,
                            HttpServletResponse response)
                     throws SystemException
アプリケーションIDとキーに対応するイベントを取得します。 イベントにはログイン時のログイングループIDが自動的に登録されます。

パラメータ:
application - アプリケーションID
key - キー
request - リクエスト
response - レスポンス
戻り値:
イベント
例外:
SystemException - イベント取得時に例外が発生

dispatchEvent

protected EventResult dispatchEvent(Event event)
                             throws EventManagerException,
                                    EventException,
                                    SystemException,
                                    ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventManagerException - イベントマネージャの生成に失敗
EventException - イベント処理実行に失敗
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.extension.struts.action (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.extension.struts.action
クラス
IntramartAction
StrutsConnectFilter


jp.co.intra_mart.framework.extension.struts.action (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.struts.action

im-J2EE FrameworkとStrutsを連携するためのユーティリティです。

参照:
説明

クラスの概要
IntramartAction | ServiceControllerAdapterと似たメソッドを持つActionクラスです。
StrutsConnectFilter | intra-martのメニューからStrutsに接続するフィルターです。

パッケージ jp.co.intra_mart.framework.extension.struts.action の説明

im-J2EE FrameworkとStrutsを連携するためのユーティリティです。 Strutsからim-J2EE Frameworkにアクセスできます。


jp.co.intra_mart.framework.extension.struts.action クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.struts.action の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class org.apache.struts.action.Action
      • class jp.co.intra_mart.framework.extension.struts.action.IntramartAction
    • class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter (implements javax.servlet.Filter)


パッケージ jp.co.intra_mart.framework.extension.struts.action の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.extension.struts.action の使用

jp.co.intra_mart.framework.extension.struts.action はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StrutsConnectFilter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.struts.action
クラス StrutsConnectFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter
すべての実装インタフェース:
Filter
public class StrutsConnectFilter
extends Object
implements Filter

intra-martのメニューからStrutsに接続するフィルターです。 Struts用のロケールをセッションに登録します。

コンストラクタの概要
StrutsConnectFilter()
メソッドの概要
void | destroy() フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) ロケールをセッションに登録し、次のフィルタに処理を移します。
void | init(FilterConfig filterConfig) フィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StrutsConnectFilter

public StrutsConnectFilter()
メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
フィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
ロケールをセッションに登録し、次のフィルタに処理を移します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.framework.system.container.IMContainer の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.container.IMContainer の使用

IMContainer を使用しているパッケージ
jp.co.intra_mart.framework.base.data.container
jp.co.intra_mart.framework.base.data.container.factory
jp.co.intra_mart.framework.base.event.container
jp.co.intra_mart.framework.base.event.container.factory
jp.co.intra_mart.framework.base.service.container
jp.co.intra_mart.framework.base.service.container.factory
jp.co.intra_mart.framework.extension.seasar.data
jp.co.intra_mart.framework.extension.seasar.event
jp.co.intra_mart.framework.extension.seasar.service
jp.co.intra_mart.framework.system.container.factory

jp.co.intra_mart.framework.base.data.container での IMContainer の使用

jp.co.intra_mart.framework.base.data.container での IMContainer のサブインタフェース
 interface DataContainer
データコンテナのインターフェースです。

IMContainer を実装している jp.co.intra_mart.framework.base.data.container のクラス
 class DataContainerImpl
DataContainerの標準的な実装クラスです。

jp.co.intra_mart.framework.base.data.container.factory での IMContainer の使用

IMContainer を返す jp.co.intra_mart.framework.base.data.container.factory のメソッド
IMContainer | DefaultDataProvider.create() DataContainerを生成します。
IMContainer | DataContainerFactory.create() DataContainerを生成します。

jp.co.intra_mart.framework.base.event.container での IMContainer の使用

jp.co.intra_mart.framework.base.event.container での IMContainer のサブインタフェース
 interface EventContainer
イベントコンテナのインターフェースです。

IMContainer を実装している jp.co.intra_mart.framework.base.event.container のクラス
 class EventContainerImpl
EventContainerの標準的な実装クラスです。

jp.co.intra_mart.framework.base.event.container.factory での IMContainer の使用

IMContainer を返す jp.co.intra_mart.framework.base.event.container.factory のメソッド
IMContainer | EventContainerFactory.create() EventContainerを生成します。
IMContainer | DefaultEventProvider.create() EventContainerを生成します。

jp.co.intra_mart.framework.base.service.container での IMContainer の使用

jp.co.intra_mart.framework.base.service.container での IMContainer のサブインタフェース
 interface ServiceContainer
サービスコンテナのインターフェースです。

IMContainer を実装している jp.co.intra_mart.framework.base.service.container のクラス
 class ServiceContainerImpl
ServiceContainerの標準的な実装クラスです。

jp.co.intra_mart.framework.base.service.container.factory での IMContainer の使用

IMContainer を返す jp.co.intra_mart.framework.base.service.container.factory のメソッド
IMContainer | ServiceContainerFactory.create() ServiceContainerを生成します。
IMContainer | DefaultServiceProvider.create() ServiceContainerを生成します。

jp.co.intra_mart.framework.extension.seasar.data での IMContainer の使用

IMContainer を実装している jp.co.intra_mart.framework.extension.seasar.data のクラス
 class S2DataContainer
S2DataContainer　は　Seasar2　と連携するためのDataContainer実装です。

jp.co.intra_mart.framework.extension.seasar.event での IMContainer の使用

IMContainer を実装している jp.co.intra_mart.framework.extension.seasar.event のクラス
 class S2EventContainer
S2EventContainer　は　Seasar2　と連携しオブジェクトを生成します。

jp.co.intra_mart.framework.extension.seasar.service での IMContainer の使用

IMContainer を実装している jp.co.intra_mart.framework.extension.seasar.service のクラス
 class S2ServiceContainer
S2ServiceContainer　は　Seasar2　と連携しオブジェクトを生成します。

jp.co.intra_mart.framework.system.container.factory での IMContainer の使用

IMContainer を返す jp.co.intra_mart.framework.system.container.factory のメソッド
IMContainer | Provider.create() IMContainerを生成します
IMContainer | IMContainerFactory.create()

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.system.container.factory.IMContainerFactory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.container.factory.IMContainerFactory の使用

IMContainerFactory を使用しているパッケージ
jp.co.intra_mart.framework.base.data.container.factory
jp.co.intra_mart.framework.base.event.container.factory
jp.co.intra_mart.framework.base.service.container.factory

jp.co.intra_mart.framework.base.data.container.factory での IMContainerFactory の使用

IMContainerFactory を実装している jp.co.intra_mart.framework.base.data.container.factory のクラス
 class DataContainerFactory
DataContainerのファクトリクラスです。

jp.co.intra_mart.framework.base.event.container.factory での IMContainerFactory の使用

IMContainerFactory を実装している jp.co.intra_mart.framework.base.event.container.factory のクラス
 class EventContainerFactory
EventContainerのファクトリクラスです。

jp.co.intra_mart.framework.base.service.container.factory での IMContainerFactory の使用

IMContainerFactory を実装している jp.co.intra_mart.framework.base.service.container.factory のクラス
 class ServiceContainerFactory
ServiceContainerのファクトリクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.system.container.factory.Provider の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.container.factory.Provider の使用

Provider を使用しているパッケージ
jp.co.intra_mart.framework.base.data.container.factory
jp.co.intra_mart.framework.base.event.container.factory
jp.co.intra_mart.framework.base.service.container.factory
jp.co.intra_mart.framework.system.container.factory

jp.co.intra_mart.framework.base.data.container.factory での Provider の使用

Provider を実装している jp.co.intra_mart.framework.base.data.container.factory のクラス
 class DefaultDataProvider
標準的なプロバイダーです。

Provider として宣言されている jp.co.intra_mart.framework.base.data.container.factory のフィールド
protected static Provider DataContainerFactory.provider

Provider を返す jp.co.intra_mart.framework.base.data.container.factory のメソッド
 Provider DataContainerFactory.getProvider()
プロバイダを返します。

Provider 型のパラメータを持つ jp.co.intra_mart.framework.base.data.container.factory のメソッド
 void DataContainerFactory.setProvider(Provider p)
プロバイダを設定します。

jp.co.intra_mart.framework.base.event.container.factory での Provider の使用

Provider を実装している jp.co.intra_mart.framework.base.event.container.factory のクラス
 class DefaultEventProvider
標準的なプロバイダーです。

Provider として宣言されている jp.co.intra_mart.framework.base.event.container.factory のフィールド
protected static Provider EventContainerFactory.provider

Provider を返す jp.co.intra_mart.framework.base.event.container.factory のメソッド
 Provider EventContainerFactory.getProvider()
プロバイダを返します。

Provider 型のパラメータを持つ jp.co.intra_mart.framework.base.event.container.factory のメソッド
 void EventContainerFactory.setProvider(Provider p)
プロバイダを設定します。

jp.co.intra_mart.framework.base.service.container.factory での Provider の使用

Provider を実装している jp.co.intra_mart.framework.base.service.container.factory のクラス
 class DefaultServiceProvider
標準的なプロバイダーです。

Provider として宣言されている jp.co.intra_mart.framework.base.service.container.factory のフィールド
protected  Provider ServiceContainerFactory.provider

Provider を返す jp.co.intra_mart.framework.base.service.container.factory のメソッド
 Provider ServiceContainerFactory.getProvider()
プロバイダを返します。

Provider 型のパラメータを持つ jp.co.intra_mart.framework.base.service.container.factory のメソッド
 void ServiceContainerFactory.setProvider(Provider p)
プロバイダを設定します。

jp.co.intra_mart.framework.system.container.factory での Provider の使用

Provider を返す jp.co.intra_mart.framework.system.container.factory のメソッド
 Provider IMContainerFactory.getProvider()

Provider 型のパラメータを持つ jp.co.intra_mart.framework.system.container.factory のメソッド
 void IMContainerFactory.setProvider(Provider p)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


IMContainerFactory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.container.factory
インタフェース IMContainerFactory

既知の実装クラスの一覧:
DataContainerFactory, EventContainerFactory, ServiceContainerFactory
public interface IMContainerFactory

ServiceContainerのクラスです。

導入されたバージョン:
6.0

メソッドの概要
IMContainer | create()
Provider | getProvider()
void | setProvider(Provider p)

メソッドの詳細

create

public IMContainer create()
                   throws IMContainerException
例外:
IMContainerException

getProvider

public Provider getProvider()

setProvider

public void setProvider(Provider p)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.system.container.factory (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.system.container.factory
インタフェース
IMContainerFactory
Provider


jp.co.intra_mart.framework.system.container.factory (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.container.factory

インタフェースの概要
IMContainerFactory | ServiceContainerのクラスです。
Provider | IMContainerのファクトリクラスです。


jp.co.intra_mart.framework.system.container.factory クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.container.factory の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.framework.system.container.factory.IMContainerFactory
  • interface jp.co.intra_mart.framework.system.container.factory.Provider


パッケージ jp.co.intra_mart.framework.system.container.factory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.system.container.factory の使用

jp.co.intra_mart.framework.system.container.factory を使用しているパッケージ
jp.co.intra_mart.framework.base.data.container.factory
jp.co.intra_mart.framework.base.event.container.factory
jp.co.intra_mart.framework.base.service.container.factory
jp.co.intra_mart.framework.system.container.factory

jp.co.intra_mart.framework.base.data.container.factory により使用される jp.co.intra_mart.framework.system.container.factory のクラス
IMContainerFactory
ServiceContainerのクラスです。
Provider
IMContainerのファクトリクラスです。

jp.co.intra_mart.framework.base.event.container.factory により使用される jp.co.intra_mart.framework.system.container.factory のクラス
IMContainerFactory
ServiceContainerのクラスです。
Provider
IMContainerのファクトリクラスです。

jp.co.intra_mart.framework.base.service.container.factory により使用される jp.co.intra_mart.framework.system.container.factory のクラス
IMContainerFactory
ServiceContainerのクラスです。
Provider
IMContainerのファクトリクラスです。

jp.co.intra_mart.framework.system.container.factory により使用される jp.co.intra_mart.framework.system.container.factory のクラス
Provider
IMContainerのファクトリクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Provider (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.container.factory
インタフェース Provider

既知の実装クラスの一覧:
DefaultDataProvider, DefaultEventProvider, DefaultServiceProvider
public interface Provider

IMContainerのファクトリクラスです。

導入されたバージョン:
6.0

メソッドの概要
 IMContainer create()
IMContainerを生成します

メソッドの詳細

create

public IMContainer create()
                   throws IMContainerException
IMContainerを生成します

戻り値:
IMContainer
例外:
IMContainerException - IMContainer生成時に例外が発生。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


IMContainer (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.container
インタフェース IMContainer

既知のサブインタフェースの一覧:
DataContainer, EventContainer, ServiceContainer
既知の実装クラスの一覧:
DataContainerImpl, EventContainerImpl, S2DataContainer, S2EventContainer, S2ServiceContainer, ServiceContainerImpl
public interface IMContainer

イントラマートコンテナのインターフェースです。

メソッドの概要
 void init()
IMContainerを初期化します。

メソッドの詳細

init

public void init()
          throws IMContainerException
IMContainerを初期化します。

例外:
IMContainerException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.system.container (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.system.container
インタフェース
IMContainer


jp.co.intra_mart.framework.system.container (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.container

インタフェースの概要
IMContainer イントラマートコンテナのインターフェースです。


jp.co.intra_mart.framework.system.container クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.container の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.framework.system.container.IMContainer


パッケージ jp.co.intra_mart.framework.system.container の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.system.container の使用

jp.co.intra_mart.framework.system.container を使用しているパッケージ
jp.co.intra_mart.framework.base.data.container
jp.co.intra_mart.framework.base.data.container.factory
jp.co.intra_mart.framework.base.event.container
jp.co.intra_mart.framework.base.event.container.factory
jp.co.intra_mart.framework.base.service.container
jp.co.intra_mart.framework.base.service.container.factory
jp.co.intra_mart.framework.extension.seasar.data
jp.co.intra_mart.framework.extension.seasar.event
jp.co.intra_mart.framework.extension.seasar.service
jp.co.intra_mart.framework.system.container.factory

jp.co.intra_mart.framework.base.data.container により使用される jp.co.intra_mart.framework.system.container のクラス
IMContainer
イントラマートコンテナのインターフェースです。

jp.co.intra_mart.framework.base.data.container.factory により使用される jp.co.intra_mart.framework.system.container のクラス
IMContainer
イントラマートコンテナのインターフェースです。

jp.co.intra_mart.framework.base.event.container により使用される jp.co.intra_mart.framework.system.container のクラス
IMContainer
イントラマートコンテナのインターフェースです。

jp.co.intra_mart.framework.base.event.container.factory により使用される jp.co.intra_mart.framework.system.container のクラス
IMContainer
イントラマートコンテナのインターフェースです。

jp.co.intra_mart.framework.base.service.container により使用される jp.co.intra_mart.framework.system.container のクラス
IMContainer
イントラマートコンテナのインターフェースです。

jp.co.intra_mart.framework.base.service.container.factory により使用される jp.co.intra_mart.framework.system.container のクラス
IMContainer
イントラマートコンテナのインターフェースです。

jp.co.intra_mart.framework.extension.seasar.data により使用される jp.co.intra_mart.framework.system.container のクラス
IMContainer
イントラマートコンテナのインターフェースです。

jp.co.intra_mart.framework.extension.seasar.event により使用される jp.co.intra_mart.framework.system.container のクラス
IMContainer
イントラマートコンテナのインターフェースです。

jp.co.intra_mart.framework.extension.seasar.service により使用される jp.co.intra_mart.framework.system.container のクラス
IMContainer
イントラマートコンテナのインターフェースです。

jp.co.intra_mart.framework.system.container.factory により使用される jp.co.intra_mart.framework.system.container のクラス
IMContainer
イントラマートコンテナのインターフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.exception.ApplicationException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.exception.ApplicationException の使用

ApplicationException を使用しているパッケージ
jp.co.intra_mart.foundation.portal.general_purpose_portlet |
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider |
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event.container |
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.validator |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.common.util | im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.seasar.event |
jp.co.intra_mart.framework.extension.struts.action | im-J2EE FrameworkとStrutsを連携するためのユーティリティです。

jp.co.intra_mart.foundation.portal.general_purpose_portlet での ApplicationException の使用

ApplicationException をスローする jp.co.intra_mart.foundation.portal.general_purpose_portlet のメソッド
static NewArrived[] NewArrivedManager.getNewArrivedList(String config)
汎用新着情報の一覧を取得します。

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider での ApplicationException の使用

ApplicationException をスローする jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider のメソッド
NewArrived[] | PageBaseCallProvider.getNewArrivedList(String user, String group) 汎用新着情報を取得
NewArrived[] | NewArrivedProvider.getNewArrivedList(String user, String group) 新着情報を一覧を取得します。

jp.co.intra_mart.framework.base.event での ApplicationException の使用

ApplicationException をスローする jp.co.intra_mart.framework.base.event のメソッド
EventResult | StandardEventListener.execute(Event event) 処理を実行します。
protected abstract EventResult | StandardEventListener.fire(Event event) イベントに対する処理です。
protected EventResult | StandardEventListener.dispatchEvent(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListenerAgentBean.execute(Event event) イベント処理を実行します。
protected abstract EventResult | StandardEJBEventListenerAgentBean.fire(Event event, DataAccessController dataAccessController) イベントに対する処理です。
EventResult | StandardEJBEventListenerAgent.execute(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListener.execute(Event event) 処理を実行します。
EventResult | GenericEventListener.execute(Event event) 処理を実行します。
EventResult | GenericEJBEventListenerLocal.execute(Event event) 処理を実行します。
EventResult | GenericEJBEventListenerAgentLocal.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListenerAgentBean.execute(Event event, String listenerName) イベント処理を実行します。
EventResult | GenericEJBEventListenerAgent.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListener.execute(Event event) 処理を実行します。
void | EventTriggerList.fireAll(Event event, DataAccessController controller) すべてのトリガに対してイベントの処理を行います。
void | EventTriggerAdapter.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
protected abstract void | EventTriggerAdapter.fire(Event event) イベントに対する処理を行います。
void | EventTrigger.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
EventResult | EventManager.dispatch(Event event) イベントに対する処理を実行します。
EventResult | EventManager.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventResult | EventListener.execute(Event event) 処理を実行します。
protected EventResult | EJBEventListenerAgentBean.dispatchEvent(Event event) イベント処理を実行します。
protected EventResult | EJBEventListener.dispatchEvent(Event event) イベント処理を実行します。

jp.co.intra_mart.framework.base.event.container での ApplicationException の使用

ApplicationException をスローする jp.co.intra_mart.framework.base.event.container のメソッド
EventResult | EventContainerImpl.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventResult | EventContainer.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。

jp.co.intra_mart.framework.base.service での ApplicationException の使用

jp.co.intra_mart.framework.base.service での ApplicationException のサブクラス
 class RequestException
リクエストの内容に関連する間違いがある場合の例外です。

ApplicationException をスローする jp.co.intra_mart.framework.base.service のメソッド
ServiceResult | ServiceControllerAdapter.service() 入力に対する処理を実行します。
protected EventResult | ServiceControllerAdapter.dispatchEvent(Event event) イベント処理を実行します。
ServiceResult | ServiceController.service() 入力に対する処理を実行します。

jp.co.intra_mart.framework.base.service.validator での ApplicationException の使用

jp.co.intra_mart.framework.base.service.validator での ApplicationException のサブクラス
 class ValidationException
検証結果が不正であるときの例外です。

jp.co.intra_mart.framework.base.web.bean での ApplicationException の使用

ApplicationException をスローする jp.co.intra_mart.framework.base.web.bean のメソッド
protected  EventResult HelperBean.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.extension.common.util での ApplicationException の使用

ApplicationException をスローする jp.co.intra_mart.framework.extension.common.util のメソッド
static EventResult ServiceUtils.dispatchEvent(Event event)
イベントを実行します。

jp.co.intra_mart.framework.extension.seasar.event での ApplicationException の使用

ApplicationException をスローする jp.co.intra_mart.framework.extension.seasar.event のメソッド
 EventResult S2EventContainer.dispatch(Event event, boolean transaction)

jp.co.intra_mart.framework.extension.struts.action での ApplicationException の使用

ApplicationException をスローする jp.co.intra_mart.framework.extension.struts.action のメソッド
protected  EventResult IntramartAction.dispatchEvent(Event event)
イベント処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.exception.FrameworkException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.exception.FrameworkException の使用

FrameworkException を使用しているパッケージ
jp.co.intra_mart.extension.maskat.exception |
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.data.container |
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event.container |
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.container |
jp.co.intra_mart.framework.base.service.controller |
jp.co.intra_mart.framework.base.service.validator |
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.system.exception | J2EEフレームワークの例外に関連するパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。

jp.co.intra_mart.extension.maskat.exception での FrameworkException の使用

jp.co.intra_mart.extension.maskat.exception での FrameworkException のサブクラス
 class MKSystemException
マスカットアプリケーション実行時に出力される例外です。

jp.co.intra_mart.framework.base.data での FrameworkException の使用

jp.co.intra_mart.framework.base.data での FrameworkException のサブクラス
class | DAOException リソースコネクタの情報取得時の例外です。
class | DataAccessException データアクセス時の例外です。
class | DataConnectException データ接続に関連する例外です。
class | DataConnectorException データコネクタ取得時の例外です。
class | DataManagerException データマネージャの設定時の例外です。
class | DataPropertyException データプロパティ取得時の例外です。

jp.co.intra_mart.framework.base.data.container での FrameworkException の使用

jp.co.intra_mart.framework.base.data.container での FrameworkException のサブクラス
 class DataContainerException
データコンテナ設定時の例外です。

jp.co.intra_mart.framework.base.event での FrameworkException の使用

jp.co.intra_mart.framework.base.event での FrameworkException のサブクラス
class | EventException イベント生成時の例外です。
class | EventListenerException イベントリスナ生成時の例外です。
class | EventManagerException イベントマネージャ設定時の例外です。
class | EventPropertyException イベントプロパティ取得時の例外です。
class | EventTriggerException イベントトリガ生成時の例外です。

jp.co.intra_mart.framework.base.event.container での FrameworkException の使用

jp.co.intra_mart.framework.base.event.container での FrameworkException のサブクラス
 class EventContainerException
イベントコンテナ設定時の例外です。

jp.co.intra_mart.framework.base.message での FrameworkException の使用

jp.co.intra_mart.framework.base.message での FrameworkException のサブクラス
class | MessageManagerException サービスマネージャ設定時の例外です。
class | MessagePropertyException メッセージプロパティ取得時の例外です。

jp.co.intra_mart.framework.base.service での FrameworkException の使用

jp.co.intra_mart.framework.base.service での FrameworkException のサブクラス
class | RequestException リクエストの内容に関連する間違いがある場合の例外です。
class | ServiceControllerException サービスコントローラに関連する例外です。
class | ServiceManagerException サービスマネージャ設定時の例外です。
class | ServicePropertyException サービスプロパティ取得時の例外です。
class | ServiceServletException サービスに関連する例外です。
class | TransitionException トランジションに関連する例外です。

jp.co.intra_mart.framework.base.service.container での FrameworkException の使用

jp.co.intra_mart.framework.base.service.container での FrameworkException のサブクラス
 class ServiceContainerException
サービスコンテナ設定時の例外です。

jp.co.intra_mart.framework.base.service.controller での FrameworkException の使用

jp.co.intra_mart.framework.base.service.controller での FrameworkException のサブクラス
class | ControllerConverterException ControllerConverterに関連する例外です。
class | RequestFormatException フォーマットが不正であるときの例外です。

jp.co.intra_mart.framework.base.service.validator での FrameworkException の使用

jp.co.intra_mart.framework.base.service.validator での FrameworkException のサブクラス
class | ValidationException 検証結果が不正であるときの例外です。
class | ValidatorException Validatorに関連する例外です。

jp.co.intra_mart.framework.base.session での FrameworkException の使用

jp.co.intra_mart.framework.base.session での FrameworkException のサブクラス
class | IllegalSessionException セッション情報取得の失敗や不正なセッションを検出した場合にスローされます。
class | SessionFactoryException セッションファクトリ内の例外です。
class | SessionManagerException セッションマネージャ内の例外です。
class | SessionObjectException セッションオブジェクト内の例外です。
class | SessionPropertyException セッションプロパティ取得時の例外です。

jp.co.intra_mart.framework.base.util での FrameworkException の使用

jp.co.intra_mart.framework.base.util での FrameworkException のサブクラス
 class UserInfoException
ユーザ情報に関連する例外です。

jp.co.intra_mart.framework.base.web.bean での FrameworkException の使用

jp.co.intra_mart.framework.base.web.bean での FrameworkException のサブクラス
 class HelperBeanException
HelperBean内で発生した例外です。

jp.co.intra_mart.framework.system.exception での FrameworkException の使用

jp.co.intra_mart.framework.system.exception での FrameworkException のサブクラス
class | ApplicationException フレームワーク内で発生したアプリケーション例外です。
class | IllegalSystemException 想定外の例外が発生したときの例外です。
class | IMContainerException イントラマートコンテナ内で発生した例外です。
class | SystemException フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.system.log での FrameworkException の使用

jp.co.intra_mart.framework.system.log での FrameworkException のサブクラス
 class LogPropertyException
ログプロパティ取得時の例外です。

jp.co.intra_mart.framework.system.property での FrameworkException の使用

jp.co.intra_mart.framework.system.property での FrameworkException のサブクラス
class | PropertyHandlerException プロパティハンドラの情報取得時の例外です。
class | PropertyManagerException プロパティマネージャの設定時の例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.exception.FrameworkRuntimeException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.exception.FrameworkRuntimeException の使用

jp.co.intra_mart.framework.system.exception.FrameworkRuntimeException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.exception.IllegalSystemException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.exception.IllegalSystemException の使用

jp.co.intra_mart.framework.system.exception.IllegalSystemException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.exception.IMContainerException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.exception.IMContainerException の使用

IMContainerException を使用しているパッケージ
jp.co.intra_mart.framework.base.data.container
jp.co.intra_mart.framework.base.data.container.factory
jp.co.intra_mart.framework.base.event.container
jp.co.intra_mart.framework.base.event.container.factory
jp.co.intra_mart.framework.base.service.container
jp.co.intra_mart.framework.base.service.container.factory
jp.co.intra_mart.framework.extension.seasar.data
jp.co.intra_mart.framework.extension.seasar.event
jp.co.intra_mart.framework.extension.seasar.service
jp.co.intra_mart.framework.system.container
jp.co.intra_mart.framework.system.container.factory

jp.co.intra_mart.framework.base.data.container での IMContainerException の使用

IMContainerException をスローする jp.co.intra_mart.framework.base.data.container のメソッド
 void DataContainerImpl.init()
DataContainerを初期化します。

jp.co.intra_mart.framework.base.data.container.factory での IMContainerException の使用

IMContainerException をスローする jp.co.intra_mart.framework.base.data.container.factory のメソッド
IMContainer | DefaultDataProvider.create() DataContainerを生成します。
IMContainer | DataContainerFactory.create() DataContainerを生成します。

jp.co.intra_mart.framework.base.event.container での IMContainerException の使用

IMContainerException をスローする jp.co.intra_mart.framework.base.event.container のメソッド
 void EventContainerImpl.init()
EventContainerを初期化します。

jp.co.intra_mart.framework.base.event.container.factory での IMContainerException の使用

IMContainerException をスローする jp.co.intra_mart.framework.base.event.container.factory のメソッド
IMContainer | EventContainerFactory.create() EventContainerを生成します。
IMContainer | DefaultEventProvider.create() EventContainerを生成します。

jp.co.intra_mart.framework.base.service.container での IMContainerException の使用

IMContainerException をスローする jp.co.intra_mart.framework.base.service.container のメソッド
 void ServiceContainerImpl.init()
ServiceContainerを初期化します。

jp.co.intra_mart.framework.base.service.container.factory での IMContainerException の使用

IMContainerException をスローする jp.co.intra_mart.framework.base.service.container.factory のメソッド
IMContainer | ServiceContainerFactory.create() ServiceContainerを生成します。
IMContainer | DefaultServiceProvider.create() ServiceContainerを生成します。

jp.co.intra_mart.framework.extension.seasar.data での IMContainerException の使用

IMContainerException をスローする jp.co.intra_mart.framework.extension.seasar.data のメソッド
 void S2DataContainer.init()
DataContainerを初期化します。

jp.co.intra_mart.framework.extension.seasar.event での IMContainerException の使用

IMContainerException をスローする jp.co.intra_mart.framework.extension.seasar.event のメソッド
 void S2EventContainer.init()

jp.co.intra_mart.framework.extension.seasar.service での IMContainerException の使用

IMContainerException をスローする jp.co.intra_mart.framework.extension.seasar.service のメソッド
 void S2ServiceContainer.init()
ServiceContainerを初期化します。

jp.co.intra_mart.framework.system.container での IMContainerException の使用

IMContainerException をスローする jp.co.intra_mart.framework.system.container のメソッド
 void IMContainer.init()
IMContainerを初期化します。

jp.co.intra_mart.framework.system.container.factory での IMContainerException の使用

IMContainerException をスローする jp.co.intra_mart.framework.system.container.factory のメソッド
IMContainer | Provider.create() IMContainerを生成します
IMContainer | IMContainerFactory.create()

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.exception.SystemException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.exception.SystemException の使用

SystemException を使用しているパッケージ
jp.co.intra_mart.extension.maskat.exception |
jp.co.intra_mart.extension.maskat.service |
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.data.container |
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event.container |
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.container |
jp.co.intra_mart.framework.base.service.controller |
jp.co.intra_mart.framework.base.service.validator |
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.common.util | im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.seasar.event |
jp.co.intra_mart.framework.extension.struts.action | im-J2EE FrameworkとStrutsを連携するためのユーティリティです。
jp.co.intra_mart.framework.system.exception | J2EEフレームワークの例外に関連するパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.extension.maskat.exception での SystemException の使用

jp.co.intra_mart.extension.maskat.exception での SystemException のサブクラス
 class MKSystemException
マスカットアプリケーション実行時に出力される例外です。

jp.co.intra_mart.extension.maskat.service での SystemException の使用

SystemException をスローする jp.co.intra_mart.extension.maskat.service のメソッド
 void MKTransition.transfer()
サービス処理結果に格納されたドキュメントをレスポンスとして送信します。

jp.co.intra_mart.framework.base.data での SystemException の使用

jp.co.intra_mart.framework.base.data での SystemException のサブクラス
class | DAOException リソースコネクタの情報取得時の例外です。
class | DataAccessException データアクセス時の例外です。
class | DataConnectException データ接続に関連する例外です。
class | DataConnectorException データコネクタ取得時の例外です。
class | DataManagerException データマネージャの設定時の例外です。
class | DataPropertyException データプロパティ取得時の例外です。

jp.co.intra_mart.framework.base.data.container での SystemException の使用

jp.co.intra_mart.framework.base.data.container での SystemException のサブクラス
 class DataContainerException
データコンテナ設定時の例外です。

jp.co.intra_mart.framework.base.event での SystemException の使用

jp.co.intra_mart.framework.base.event での SystemException のサブクラス
class | EventException イベント生成時の例外です。
class | EventListenerException イベントリスナ生成時の例外です。
class | EventManagerException イベントマネージャ設定時の例外です。
class | EventPropertyException イベントプロパティ取得時の例外です。
class | EventTriggerException イベントトリガ生成時の例外です。

SystemException をスローする jp.co.intra_mart.framework.base.event のメソッド
EventResult | StandardEventListener.execute(Event event) 処理を実行します。
protected abstract EventResult | StandardEventListener.fire(Event event) イベントに対する処理です。
protected EventResult | StandardEventListener.dispatchEvent(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListenerAgentBean.execute(Event event) イベント処理を実行します。
protected abstract EventResult | StandardEJBEventListenerAgentBean.fire(Event event, DataAccessController dataAccessController) イベントに対する処理です。
EventResult | StandardEJBEventListenerAgent.execute(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListener.execute(Event event) 処理を実行します。
EventResult | GenericEventListener.execute(Event event) 処理を実行します。
EventResult | GenericEJBEventListenerLocal.execute(Event event) 処理を実行します。
EventResult | GenericEJBEventListenerAgentLocal.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListenerAgentBean.execute(Event event, String listenerName) イベント処理を実行します。
EventResult | GenericEJBEventListenerAgent.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListener.execute(Event event) 処理を実行します。
void | EventTriggerList.fireAll(Event event, DataAccessController controller) すべてのトリガに対してイベントの処理を行います。
void | EventTriggerAdapter.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
protected abstract void | EventTriggerAdapter.fire(Event event) イベントに対する処理を行います。
void | EventTrigger.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
EventResult | EventManager.dispatch(Event event) イベントに対する処理を実行します。
EventResult | EventManager.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventResult | EventListener.execute(Event event) 処理を実行します。
protected EventResult | EJBEventListenerAgentBean.dispatchEvent(Event event) イベント処理を実行します。
protected EventResult | EJBEventListener.dispatchEvent(Event event) イベント処理を実行します。

jp.co.intra_mart.framework.base.event.container での SystemException の使用

jp.co.intra_mart.framework.base.event.container での SystemException のサブクラス
 class EventContainerException
イベントコンテナ設定時の例外です。

SystemException をスローする jp.co.intra_mart.framework.base.event.container のメソッド
EventResult | EventContainerImpl.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventResult | EventContainer.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。

jp.co.intra_mart.framework.base.message での SystemException の使用

jp.co.intra_mart.framework.base.message での SystemException のサブクラス
class | MessageManagerException サービスマネージャ設定時の例外です。
class | MessagePropertyException メッセージプロパティ取得時の例外です。

jp.co.intra_mart.framework.base.service での SystemException の使用

jp.co.intra_mart.framework.base.service での SystemException のサブクラス
class | ServiceControllerException サービスコントローラに関連する例外です。
class | ServiceManagerException サービスマネージャ設定時の例外です。
class | ServicePropertyException サービスプロパティ取得時の例外です。
class | ServiceServletException サービスに関連する例外です。
class | TransitionException トランジションに関連する例外です。

SystemException をスローする jp.co.intra_mart.framework.base.service のメソッド
MultipartFormData.Entity | Transition.getEntity(String name) リクエストから指定された名前に該当するエンティティを取得します。
abstract void | Transition.transfer() 次のページに遷移します。
MultipartFormData.Entity | ServiceControllerAdapter.getEntity(String name) リクエストから指定された名前に該当するエンティティを取得します。
void | ServiceControllerAdapter.check() 入力内容をチェックします。
ServiceResult | ServiceControllerAdapter.service() 入力に対する処理を実行します。
protected EventResult | ServiceControllerAdapter.dispatchEvent(Event event) イベント処理を実行します。
void | ServiceController.check() 入力内容をチェックします。
ServiceResult | ServiceController.service() 入力に対する処理を実行します。
void | IntramartPageBaseTransition.transfer() ページベースの画面に遷移します。
void | DefaultTransition.transfer() 次のページに遷移します。

jp.co.intra_mart.framework.base.service.container での SystemException の使用

jp.co.intra_mart.framework.base.service.container での SystemException のサブクラス
 class ServiceContainerException
サービスコンテナ設定時の例外です。

jp.co.intra_mart.framework.base.service.controller での SystemException の使用

jp.co.intra_mart.framework.base.service.controller での SystemException のサブクラス
class | ControllerConverterException ControllerConverterに関連する例外です。
class | RequestFormatException フォーマットが不正であるときの例外です。

jp.co.intra_mart.framework.base.service.validator での SystemException の使用

jp.co.intra_mart.framework.base.service.validator での SystemException のサブクラス
 class ValidatorException
Validatorに関連する例外です。

jp.co.intra_mart.framework.base.session での SystemException の使用

jp.co.intra_mart.framework.base.session での SystemException のサブクラス
class | IllegalSessionException セッション情報取得の失敗や不正なセッションを検出した場合にスローされます。
class | SessionFactoryException セッションファクトリ内の例外です。
class | SessionManagerException セッションマネージャ内の例外です。
class | SessionObjectException セッションオブジェクト内の例外です。
class | SessionPropertyException セッションプロパティ取得時の例外です。

jp.co.intra_mart.framework.base.util での SystemException の使用

jp.co.intra_mart.framework.base.util での SystemException のサブクラス
 class UserInfoException
ユーザ情報に関連する例外です。

jp.co.intra_mart.framework.base.web.bean での SystemException の使用

jp.co.intra_mart.framework.base.web.bean での SystemException のサブクラス
 class HelperBeanException
HelperBean内で発生した例外です。

SystemException をスローする jp.co.intra_mart.framework.base.web.bean のメソッド
protected  EventResult HelperBean.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.extension.common.util での SystemException の使用

SystemException をスローする jp.co.intra_mart.framework.extension.common.util のメソッド
static String ServiceUtils.getLoginUserID(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
static String ServiceUtils.getLoginGroupID(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
static UserInfo ServiceUtils.getUserInfo(HttpServletRequest request, HttpServletResponse response)
ユーザ情報を取得します。
static Event ServiceUtils.createEvent(String application, String key, HttpServletRequest request, HttpServletResponse response)
アプリケーションIDとキーに対応するイベントを取得します。
static EventResult ServiceUtils.dispatchEvent(Event event)
イベントを実行します。

jp.co.intra_mart.framework.extension.seasar.event での SystemException の使用

SystemException をスローする jp.co.intra_mart.framework.extension.seasar.event のメソッド
 EventResult S2EventContainer.dispatch(Event event, boolean transaction)

jp.co.intra_mart.framework.extension.struts.action での SystemException の使用

SystemException をスローする jp.co.intra_mart.framework.extension.struts.action のメソッド
protected  String IntramartAction.getLoginUserID(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
protected  String IntramartAction.getLoginGroupID(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
protected  UserInfo IntramartAction.getUserInfo(HttpServletRequest request, HttpServletResponse response)
ユーザ情報を取得します。
protected  Event IntramartAction.createEvent(String application, String key, HttpServletRequest request, HttpServletResponse response)
アプリケーションIDとキーに対応するイベントを取得します。
protected  EventResult IntramartAction.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.system.exception での SystemException の使用

jp.co.intra_mart.framework.system.exception での SystemException のサブクラス
class | IllegalSystemException 想定外の例外が発生したときの例外です。
class | IMContainerException イントラマートコンテナ内で発生した例外です。

jp.co.intra_mart.framework.system.log での SystemException の使用

jp.co.intra_mart.framework.system.log での SystemException のサブクラス
 class LogPropertyException
ログプロパティ取得時の例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ApplicationException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.exception
クラス ApplicationException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.ApplicationException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
RequestException
public class ApplicationException
extends FrameworkException

フレームワーク内で発生したアプリケーション例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ApplicationException()
詳細メッセージを指定しないで ApplicationException を構築します。
ApplicationException(String msg)
指定された詳細メッセージを持つ ApplicationException を構築します。
ApplicationException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ApplicationException を構築します。
ApplicationException(Throwable throwable)
この例外の発生原因となる例外を持つ ApplicationException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ApplicationException

public ApplicationException()
詳細メッセージを指定しないで ApplicationException を構築します。

ApplicationException

public ApplicationException(String msg)
指定された詳細メッセージを持つ ApplicationException を構築します。

パラメータ:
msg - 詳細メッセージ

ApplicationException

public ApplicationException(Throwable throwable)
この例外の発生原因となる例外を持つ ApplicationException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外

ApplicationException

public ApplicationException(String msg,
                            Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ApplicationException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


FrameworkException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.exception
クラス FrameworkException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ApplicationException, PropertyHandlerException, PropertyManagerException, SystemException
public class FrameworkException
extends Exception

フレームワークに共通するの例外のスーパークラスです。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
FrameworkException()
詳細メッセージを指定しないで FrameworkException を構築します。
FrameworkException(String msg)
指定された詳細メッセージを持つ FrameworkException を構築します。
FrameworkException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkException を構築します。
FrameworkException(Throwable throwable)
この例外の発生原因となる例外を持つ FrameworkException を構築します。
メソッドの概要
Throwable | getException() この例外が発生した原因となる例外を取得します。
void | printStackTrace()
void | printStackTrace(PrintStream printStream)
void | printStackTrace(PrintWriter printWriter)
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

FrameworkException

public FrameworkException()
詳細メッセージを指定しないで FrameworkException を構築します。

FrameworkException

public FrameworkException(String msg)
指定された詳細メッセージを持つ FrameworkException を構築します。

パラメータ:
msg - 詳細メッセージ

FrameworkException

public FrameworkException(Throwable throwable)
この例外の発生原因となる例外を持つ FrameworkException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外

FrameworkException

public FrameworkException(String msg,
                          Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
メソッドの詳細

getException

public Throwable getException()
この例外が発生した原因となる例外を取得します。

戻り値:
この例外が発生した原因となる例外

printStackTrace

public void printStackTrace()

printStackTrace

public void printStackTrace(PrintStream printStream)

printStackTrace

public void printStackTrace(PrintWriter printWriter)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FrameworkRuntimeException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.exception
クラス FrameworkRuntimeException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.framework.system.exception.FrameworkRuntimeException
すべての実装インタフェース:
Serializable
public class FrameworkRuntimeException
extends RuntimeException

フレームワーク内で発生したランタイム例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
FrameworkRuntimeException()
詳細メッセージを指定しないで FrameworkRuntimeException を構築します。
FrameworkRuntimeException(String msg)
指定された詳細メッセージを持つ FrameworkRuntimeException を構築します。
FrameworkRuntimeException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkRuntimeException を構築します。
FrameworkRuntimeException(Throwable throwable)
この例外の発生原因となる例外を持つ FrameworkRuntimeException を構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

FrameworkRuntimeException

public FrameworkRuntimeException()
詳細メッセージを指定しないで FrameworkRuntimeException を構築します。

FrameworkRuntimeException

public FrameworkRuntimeException(String msg)
指定された詳細メッセージを持つ FrameworkRuntimeException を構築します。

パラメータ:
msg - 詳細メッセージ

FrameworkRuntimeException

public FrameworkRuntimeException(Throwable throwable)
この例外の発生原因となる例外を持つ FrameworkRuntimeException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外

FrameworkRuntimeException

public FrameworkRuntimeException(String msg,
                                 Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkRuntimeException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IllegalSystemException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.exception
クラス IllegalSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.system.exception.IllegalSystemException
すべての実装インタフェース:
Serializable
public class IllegalSystemException
extends SystemException

想定外の例外が発生したときの例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
IllegalSystemException()
詳細メッセージを指定しないで IllegalSystemException を構築します。
IllegalSystemException(String msg)
指定された詳細メッセージを持つ IllegalSystemException を構築します。
IllegalSystemException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IllegalSystemException を構築します。
IllegalSystemException(Throwable throwable)
この例外の発生原因となる例外を持つ IllegalSystemException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalSystemException

public IllegalSystemException()
詳細メッセージを指定しないで IllegalSystemException を構築します。

IllegalSystemException

public IllegalSystemException(String msg)
指定された詳細メッセージを持つ IllegalSystemException を構築します。

パラメータ:
msg - 詳細メッセージ

IllegalSystemException

public IllegalSystemException(Throwable throwable)
この例外の発生原因となる例外を持つ IllegalSystemException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外

IllegalSystemException

public IllegalSystemException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IllegalSystemException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IMContainerException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.exception
クラス IMContainerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.system.exception.IMContainerException
すべての実装インタフェース:
Serializable
public class IMContainerException
extends SystemException

イントラマートコンテナ内で発生した例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
IMContainerException()
詳細メッセージを指定しないで IMContainerException を構築します。
IMContainerException(String msg)
指定された詳細メッセージを持つ IMContainerException を構築します。
IMContainerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IMContainerException を構築します。
IMContainerException(Throwable throwable)
この例外の発生原因となる例外を持つ IMContainerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IMContainerException

public IMContainerException()
詳細メッセージを指定しないで IMContainerException を構築します。

IMContainerException

public IMContainerException(String msg)
指定された詳細メッセージを持つ IMContainerException を構築します。

パラメータ:
msg - 詳細メッセージ

IMContainerException

public IMContainerException(Throwable throwable)
この例外の発生原因となる例外を持つ IMContainerException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外

IMContainerException

public IMContainerException(String msg,
                            Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IMContainerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.system.exception (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.system.exception
例外
ApplicationException
FrameworkException
FrameworkRuntimeException
IllegalSystemException
IMContainerException
SystemException


jp.co.intra_mart.framework.system.exception (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.exception

J2EEフレームワークの例外に関連するパッケージです。

参照:
説明

例外の概要
ApplicationException | フレームワーク内で発生したアプリケーション例外です。
FrameworkException | フレームワークに共通するの例外のスーパークラスです。
FrameworkRuntimeException | フレームワーク内で発生したランタイム例外です。
IllegalSystemException | 想定外の例外が発生したときの例外です。
IMContainerException | イントラマートコンテナ内で発生した例外です。
SystemException | フレームワーク内で発生したシステム例外です。

パッケージ jp.co.intra_mart.framework.system.exception の説明

J2EEフレームワークの例外に関連するパッケージです。


jp.co.intra_mart.framework.system.exception クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.ApplicationException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.system.exception.IllegalSystemException
            • class jp.co.intra_mart.framework.system.exception.IMContainerException
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.framework.system.exception.FrameworkRuntimeException


パッケージ jp.co.intra_mart.framework.system.exception の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.system.exception の使用

jp.co.intra_mart.framework.system.exception を使用しているパッケージ
jp.co.intra_mart.extension.maskat.exception |
jp.co.intra_mart.extension.maskat.service |
jp.co.intra_mart.foundation.portal.general_purpose_portlet |
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider |
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.data.container |
jp.co.intra_mart.framework.base.data.container.factory |
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event.container |
jp.co.intra_mart.framework.base.event.container.factory |
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.container |
jp.co.intra_mart.framework.base.service.container.factory |
jp.co.intra_mart.framework.base.service.controller |
jp.co.intra_mart.framework.base.service.validator |
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.common.util | im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.seasar.data |
jp.co.intra_mart.framework.extension.seasar.event |
jp.co.intra_mart.framework.extension.seasar.service |
jp.co.intra_mart.framework.extension.struts.action | im-J2EE FrameworkとStrutsを連携するためのユーティリティです。
jp.co.intra_mart.framework.system.container |
jp.co.intra_mart.framework.system.container.factory |
jp.co.intra_mart.framework.system.exception | J2EEフレームワークの例外に関連するパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。

jp.co.intra_mart.extension.maskat.exception により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.extension.maskat.service により使用される jp.co.intra_mart.framework.system.exception のクラス
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.foundation.portal.general_purpose_portlet により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。

jp.co.intra_mart.framework.base.data により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.data.container により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
IMContainerException
イントラマートコンテナ内で発生した例外です。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.data.container.factory により使用される jp.co.intra_mart.framework.system.exception のクラス
IMContainerException
イントラマートコンテナ内で発生した例外です。

jp.co.intra_mart.framework.base.event により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.event.container により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
IMContainerException
イントラマートコンテナ内で発生した例外です。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.event.container.factory により使用される jp.co.intra_mart.framework.system.exception のクラス
IMContainerException
イントラマートコンテナ内で発生した例外です。

jp.co.intra_mart.framework.base.message により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.service.container により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
IMContainerException
イントラマートコンテナ内で発生した例外です。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.service.container.factory により使用される jp.co.intra_mart.framework.system.exception のクラス
IMContainerException
イントラマートコンテナ内で発生した例外です。

jp.co.intra_mart.framework.base.service.controller により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.service.validator により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.session により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.util により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.web.bean により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.extension.common.util により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.extension.seasar.data により使用される jp.co.intra_mart.framework.system.exception のクラス
IMContainerException
イントラマートコンテナ内で発生した例外です。

jp.co.intra_mart.framework.extension.seasar.event により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
IMContainerException
イントラマートコンテナ内で発生した例外です。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.extension.seasar.service により使用される jp.co.intra_mart.framework.system.exception のクラス
IMContainerException
イントラマートコンテナ内で発生した例外です。

jp.co.intra_mart.framework.extension.struts.action により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.system.container により使用される jp.co.intra_mart.framework.system.exception のクラス
IMContainerException
イントラマートコンテナ内で発生した例外です。

jp.co.intra_mart.framework.system.container.factory により使用される jp.co.intra_mart.framework.system.exception のクラス
IMContainerException
イントラマートコンテナ内で発生した例外です。

jp.co.intra_mart.framework.system.exception により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.system.log により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.system.property により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SystemException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.exception
クラス SystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ControllerConverterException, DAOException, DataAccessException, DataConnectException, DataConnectorException, DataContainerException, DataManagerException, DataPropertyException, EventContainerException, EventException, EventListenerException, EventManagerException, EventPropertyException, EventTriggerException, HelperBeanException, IllegalSessionException, IllegalSystemException, IMContainerException, LogPropertyException, MessageManagerException, MessageManagerException, MessagePropertyException, MessagePropertyException, MKSystemException, RequestFormatException, ServiceContainerException, ServiceControllerException, ServiceManagerException, ServicePropertyException, ServiceServletException, SessionFactoryException, SessionManagerException, SessionObjectException, SessionPropertyException, TransitionException, UserInfoException, ValidatorException
public class SystemException
extends FrameworkException

フレームワーク内で発生したシステム例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SystemException()
詳細メッセージを指定しないで SystemException を構築します。
SystemException(String msg)
指定された詳細メッセージを持つ SystemException を構築します。
SystemException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SystemException を構築します。
SystemException(Throwable throwable)
この例外の発生原因となる例外を持つ SystemException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SystemException

public SystemException()
詳細メッセージを指定しないで SystemException を構築します。

SystemException

public SystemException(String msg)
指定された詳細メッセージを持つ SystemException を構築します。

パラメータ:
msg - 詳細メッセージ

SystemException

public SystemException(Throwable throwable)
この例外の発生原因となる例外を持つ SystemException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外

SystemException

public SystemException(String msg,
                       Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SystemException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.system.log.DefaultLogAgent の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.DefaultLogAgent の使用

jp.co.intra_mart.framework.system.log.DefaultLogAgent はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler の使用

jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.log.IntramartLogAgent の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.IntramartLogAgent の使用

jp.co.intra_mart.framework.system.log.IntramartLogAgent はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.system.log.LogAgent の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.log.LogAgent の使用

LogAgent を使用しているパッケージ
jp.co.intra_mart.framework.system.log J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.system.log での LogAgent の使用

LogAgent を実装している jp.co.intra_mart.framework.system.log のクラス
class | DefaultLogAgent デフォルトのログエージェントです。
class | IntramartLogAgent intra-mart で管理されているログに出力するログエージェントです。

LogAgent を返す jp.co.intra_mart.framework.system.log のメソッド
 LogAgent LogManager.getLogAgent()
ログエージェントを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.log.LogAgentParam の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.LogAgentParam の使用

LogAgentParam を使用しているパッケージ
jp.co.intra_mart.framework.system.log J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.system.log での LogAgentParam の使用

LogAgentParam を返す jp.co.intra_mart.framework.system.log のメソッド
LogAgentParam[] | XmlLogPropertyHandler.getLogAgentParams() ログエージェントのパラメータを取得します。
LogAgentParam[] | LogPropertyHandler.getLogAgentParams() ログエージェントのパラメータを取得します。
LogAgentParam[] | DefaultLogPropertyHandler.getLogAgentParams() ログエージェントのパラメータを取得します。

LogAgentParam 型のパラメータを持つ jp.co.intra_mart.framework.system.log のメソッド
void | LogAgent.init(LogAgentParam[] params) 初期化します。
void | IntramartLogAgent.init(LogAgentParam[] params) 初期化します。
void | DefaultLogAgent.init(LogAgentParam[] params) 初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.system.log.LogConstant の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.log.LogConstant の使用

jp.co.intra_mart.framework.system.log.LogConstant はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.log.LogManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.LogManager の使用

LogManager を使用しているパッケージ
jp.co.intra_mart.framework.system.log J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.system.log での LogManager の使用

LogManager を返す jp.co.intra_mart.framework.system.log のメソッド
static LogManager LogManager.getLogManager()
ログマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.log.LogPropertyException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.LogPropertyException の使用

LogPropertyException を使用しているパッケージ
jp.co.intra_mart.framework.system.log J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.system.log での LogPropertyException の使用

LogPropertyException をスローする jp.co.intra_mart.framework.system.log のメソッド
String | XmlLogPropertyHandler.getLogAgentName() ログエージェントのクラス名を取得します。
LogAgentParam[] | XmlLogPropertyHandler.getLogAgentParams() ログエージェントのパラメータを取得します。
String | LogPropertyHandler.getLogAgentName() ログエージェントのクラス名を取得します。
LogAgentParam[] | LogPropertyHandler.getLogAgentParams() ログエージェントのパラメータを取得します。
String | DefaultLogPropertyHandler.getLogAgentName() ログエージェントのクラス名を取得します。
LogAgentParam[] | DefaultLogPropertyHandler.getLogAgentParams() ログエージェントのパラメータを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.system.log.LogPropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.log.LogPropertyHandler の使用

LogPropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.system.log J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.system.log での LogPropertyHandler の使用

LogPropertyHandler を実装している jp.co.intra_mart.framework.system.log のクラス
class | DefaultLogPropertyHandler ログに関連するデフォルトのプロパティハンドラです。
class | XmlLogPropertyHandler リソースからログプロパティ情報を取得するプロパティハンドラです。

LogPropertyHandler を返す jp.co.intra_mart.framework.system.log のメソッド
 LogPropertyHandler LogManager.getLogPropertyHandler()
ログプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler の使用

jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DefaultLogAgent (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス DefaultLogAgent

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.log.DefaultLogAgent
すべての実装インタフェース:
LogAgent
public class DefaultLogAgent
extends Object
implements LogAgent

デフォルトのログエージェントです。 標準出力にログを出力します。 出力されるメッセージは以下のような形式になります。
[カテゴリ][レベル]メッセージ

導入されたバージョン:
4.2

コンストラクタの概要
DefaultLogAgent()

メソッドの概要
void | init(LogAgentParam[] params) 初期化します。
void | sendMessage(String category, String level, String message) メッセージを出力します。
void | sendMessage(String category, String level, String message, Object detail) メッセージを出力します。

クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DefaultLogAgent

public DefaultLogAgent()
メソッドの詳細

init

public void init(LogAgentParam[] params)
初期化します。 このクラスでは実際には何も行われません。

定義:
インタフェース LogAgent 内の init
パラメータ:
params - ログエージェントのパラメータ

sendMessage

public void sendMessage(String category,
                        String level,
                        String message)
メッセージを出力します。 このクラスでは通常、messageを標準出力にログとして出力します。 ただし、levelがLogConstant.LEVEL_ERRORである場合は 標準例外出力にログを出力します。

定義:
インタフェース LogAgent 内の sendMessage
パラメータ:
category - ログのカテゴリ
level - メッセージのレベル
message - メッセージ

sendMessage

public void sendMessage(String category,
                        String level,
                        String message,
                        Object detail)
メッセージを出力します。 このクラスでは通常、messageはそのまま、 detailはObject.toString()の値を標準出力にログとして出力します。 ただし、levelがLogConstant.LEVEL_ERRORである場合は 標準例外出力にログを出力します。

detailがThrowableのサブクラスである場合、 Throwable.printStackTrace(java.io.PrintWriter)を使用して スタックトレースが出力されます。出力先はdetailによる出力先に従います。

定義:
インタフェース LogAgent 内の sendMessage
パラメータ:
category - ログのカテゴリ
level - メッセージのレベル
message - メッセージ
detail - 詳細
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart 6.1.14
 前のクラス   次のクラス | フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド | 詳細:  フィールド | コンストラクタ | メソッド


DefaultLogPropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス DefaultLogPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler
すべての実装インタフェース:
LogPropertyHandler, PropertyHandler
public class DefaultLogPropertyHandler
extends Object
implements LogPropertyHandler

ログに関連するデフォルトのプロパティハンドラです。 プロパティの設定内容は以下のとおりです。

キー | 内容
agent.class | LogAgentのクラス名
agent.param.パラメータ名 | ログエージェントに渡すパラメータ

導入されたバージョン:
4.2

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
コンストラクタの概要
DefaultLogPropertyHandler()
DefaultLogPropertyHandlerを新規に生成します。
メソッドの概要
String | getLogAgentName() ログエージェントのクラス名を取得します。
LogAgentParam[] | getLogAgentParams() ログエージェントのパラメータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultLogPropertyHandler

public DefaultLogPropertyHandler()
DefaultLogPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

getLogAgentName

public String getLogAgentName()
                       throws LogPropertyException
ログエージェントのクラス名を取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース LogPropertyHandler 内の getLogAgentName
戻り値:
ログエージェントのクラス名（設定されていない場合null）
例外:
LogPropertyException - ログエージェントのクラス名の取得時に例外が発生

getLogAgentParams

public LogAgentParam[] getLogAgentParams()
                                  throws LogPropertyException
ログエージェントのパラメータを取得します。 何も設定されていない場合大きさが0の配列が返ります。

定義:
インタフェース LogPropertyHandler 内の getLogAgentParams
戻り値:
ログエージェントのパラメータの配列
例外:
LogPropertyException - ログエージェントのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartLogAgent (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス IntramartLogAgent

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.log.IntramartLogAgent
すべての実装インタフェース:
LogAgent
public class IntramartLogAgent
extends Object
implements LogAgent

intra-mart で管理されているログに出力するログエージェントです。 出力先は intra-mart の設定に依存します。 出力されるメッセージは以下のような形式になります。
[レベル]メッセージ
init(LogAgentParam[])に渡すパラメータは以下のように解釈されます。

パラメータ名 | パラメータの値
カテゴリ | カテゴリの種類

カテゴリの種類にTYPE_DBの値を指定するとデータベースログとして出力されます。

導入されたバージョン:
4.2

フィールドの概要
static String TYPE_DB
          データベースログに出力する場合のカテゴリの種類

コンストラクタの概要
IntramartLogAgent()
          IntramartLogAgentを新規に生成します。

メソッドの概要
void | init(LogAgentParam[] params) 初期化します。
void | sendMessage(String category, String level, String message) メッセージを出力します。
void | sendMessage(String category, String level, String message, Object detail) メッセージを出力します。

クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

TYPE_DB

public static final String TYPE_DB
データベースログに出力する場合のカテゴリの種類

関連項目:
定数フィールド値
コンストラクタの詳細

IntramartLogAgent

public IntramartLogAgent()
IntramartLogAgentを新規に生成します。

メソッドの詳細

init

public void init(LogAgentParam[] params)
初期化します。 パラメータで指定されたカテゴリを登録します。

定義:
インタフェース LogAgent 内の init
パラメータ:
params - ログエージェントのパラメータ

sendMessage

public void sendMessage(String category,
                        String level,
                        String message)
メッセージを出力します。 levelがLogConstant.LEVEL_ERROR以外の場合はメッセージをintra-martのシステムログとして出力します。 levelがLogConstant.LEVEL_ERRORである場合、 categoryをもとに取得されるカテゴリの種類によって以下のようにさらに出力先が分かれます。
  • カテゴリの種類がTYPE_DBである場合、データベースログとして出力
  • カテゴリの種類がTYPE_DB以外である場合、エラーログとして出力

定義:
インタフェース LogAgent 内の sendMessage
パラメータ:
category - ログのカテゴリ
level - メッセージのレベル
message - メッセージ

sendMessage

public void sendMessage(String category,
                        String level,
                        String message,
                        Object detail)
メッセージを出力します。 levelがLogConstant.LEVEL_ERROR以外の場合はメッセージをintra-martのシステムログとして出力します。 levelがLogConstant.LEVEL_ERRORである場合、以下のように出力先が異なります。
  • detailがThrowableのインスタンスであり
    • カテゴリがDBに関連するものはデータベースログとして出力
    • カテゴリがDBに関連するもの以外であるときはエラーログとして出力
  • detailがThrowable以外のインスタンスであり
    • 詳細文字列が存在し
      • カテゴリの種類がTYPE_DBである場合データベースログとして詳細ごと出力
      • カテゴリの種類がTYPE_DB以外であるときはエラーログとして詳細ごと出力
    • 詳細文字列が存在しないで
      • カテゴリがDBに関連するものはデータベースログとして詳細なしで出力
      • カテゴリがDBに関連するもの以外であるときはエラーログとして詳細なしで出力

定義:
インタフェース LogAgent 内の sendMessage
パラメータ:
category - ログのカテゴリ
level - メッセージのレベル
message - メッセージ
detail - 詳細
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart 6.1.14
 前のクラス   次のクラス フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド 詳細:  フィールド | コンストラクタ | メソッド


LogAgent (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
インタフェース LogAgent

既知の実装クラスの一覧:
DefaultLogAgent, IntramartLogAgent
public interface LogAgent

ログに出力するエージェントです。 im-J2EE Framework から出るログの出力先を変更したい場合、 このインタフェースを実装したクラスを設定します。

導入されたバージョン:
4.2

メソッドの概要
void | init(LogAgentParam[] params) 初期化します。
void | sendMessage(String category, String level, String message) メッセージを出力します。
void | sendMessage(String category, String level, String message, Object detail) メッセージを出力します。

メソッドの詳細

init

public void init(LogAgentParam[] params)
初期化します。

パラメータ:
params - ログエージェントのパラメータ

sendMessage

public void sendMessage(String category,
                        String level,
                        String message)
メッセージを出力します。

パラメータ:
category - ログのカテゴリ
level - メッセージのレベル
message - メッセージ

sendMessage

public void sendMessage(String category,
                        String level,
                        String message,
                        Object detail)
メッセージを出力します。 詳細な情報が添付されたメッセージを出力します。

パラメータ:
category - ログのカテゴリ
level - メッセージのレベル
message - メッセージ
detail - 詳細
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LogAgentParam (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス LogAgentParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
        拡張 jp.co.intra_mart.framework.system.log.LogAgentParam
public class LogAgentParam
extends PropertyParam

ログエージェントの初期パラメータです。

導入されたバージョン:
4.2

コンストラクタの概要
LogAgentParam()
LogAgentParamを新規に生成します。
クラス jp.co.intra_mart.framework.system.property.PropertyParam から継承したメソッド
getName, getValue, setName, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LogAgentParam

public LogAgentParam()
LogAgentParamを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LogConstant (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
インタフェース LogConstant

public interface LogConstant

ログフレームワークで使用される定数値です。

導入されたバージョン:
4.2

フィールドの概要
static String | CATEGORY_BEGIN_TRANSACTION トランザクションを開始するタイプです。
static String | CATEGORY_COMMIT_TRANSACTION トランザクションをコミットするタイプです。
static String | CATEGORY_ROLLBACK_TRANSACTION トランザクションをロールバックするタイプです。
static String | LEVEL_DEBUG DEBUG時に出力するレベルです。
static String | LEVEL_ERROR 例外を出力するレベルです。
static String | LEVEL_INFO 情報を出力するレベルです。
static String | LEVEL_WARNNING 警告を出力するレベルです。

フィールドの詳細

LEVEL_DEBUG

public static final String LEVEL_DEBUG
DEBUG時に出力するレベルです。

関連項目:
定数フィールド値

LEVEL_INFO

public static final String LEVEL_INFO
情報を出力するレベルです。

関連項目:
定数フィールド値

LEVEL_WARNNING

public static final String LEVEL_WARNNING
警告を出力するレベルです。

関連項目:
定数フィールド値

LEVEL_ERROR

public static final String LEVEL_ERROR
例外を出力するレベルです。

関連項目:
定数フィールド値

CATEGORY_BEGIN_TRANSACTION

public static final String CATEGORY_BEGIN_TRANSACTION
トランザクションを開始するタイプです。

導入されたバージョン:
6.1
関連項目:
定数フィールド値

CATEGORY_COMMIT_TRANSACTION

public static final String CATEGORY_COMMIT_TRANSACTION
トランザクションをコミットするタイプです。

導入されたバージョン:
6.1
関連項目:
定数フィールド値

CATEGORY_ROLLBACK_TRANSACTION

public static final String CATEGORY_ROLLBACK_TRANSACTION
トランザクションをロールバックするタイプです。

導入されたバージョン:
6.1
関連項目:
定数フィールド値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LogManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス LogManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.log.LogManager
public class LogManager
extends Object

ログマネージャです。

導入されたバージョン:
4.2

フィールドの概要
static String LOG_PROPERTY_HANDLER_KEY
ログプロパティハンドラのキー
メソッドの概要
LogAgent | getLogAgent() ログエージェントを取得します。
static LogManager | getLogManager() ログマネージャを取得します。
LogPropertyHandler | getLogPropertyHandler() ログプロパティハンドラを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

LOG_PROPERTY_HANDLER_KEY

public static final String LOG_PROPERTY_HANDLER_KEY
ログプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getLogManager

public static LogManager getLogManager()
ログマネージャを取得します。

戻り値:
ログマネージャ

getLogPropertyHandler

public LogPropertyHandler getLogPropertyHandler()
ログプロパティハンドラを取得します。

戻り値:
ログプロパティハンドラ

getLogAgent

public LogAgent getLogAgent()
ログエージェントを取得します。

戻り値:
ログエージェント
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LogPropertyException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス LogPropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.system.log.LogPropertyException
すべての実装インタフェース:
Serializable
public class LogPropertyException
extends SystemException

ログプロパティ取得時の例外です。

導入されたバージョン:
4.2
関連項目:
直列化された形式

コンストラクタの概要
LogPropertyException()
詳細メッセージを指定しないで LogPropertyException を構築します。
LogPropertyException(String msg)
指定された詳細メッセージを持つ LogPropertyException を構築します。
LogPropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ LogPropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

LogPropertyException

public LogPropertyException()
詳細メッセージを指定しないで LogPropertyException を構築します。

LogPropertyException

public LogPropertyException(String msg)
指定された詳細メッセージを持つ LogPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

LogPropertyException

public LogPropertyException(String msg,
                            Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ LogPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LogPropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
インタフェース LogPropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultLogPropertyHandler, XmlLogPropertyHandler
public interface LogPropertyHandler
extends PropertyHandler

ログフレームワークで使用するプロパティハンドラです。

導入されたバージョン:
4.2

メソッドの概要
String | getLogAgentName() ログエージェントのクラス名を取得します。
LogAgentParam[] | getLogAgentParams() ログエージェントのパラメータを取得します。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

getLogAgentName

public String getLogAgentName()
                       throws LogPropertyException
ログエージェントのクラス名を取得します。 何も設定されていない場合nullを返すように実装する必要があります。

戻り値:
ログエージェントのクラス名（設定されていない場合null）
例外:
LogPropertyException - ログエージェントのクラス名の取得時に例外が発生

getLogAgentParams

public LogAgentParam[] getLogAgentParams()
                                  throws LogPropertyException
ログエージェントのパラメータを取得します。 何も設定されていない場合大きさが0の配列を返すように実装する必要があります。

戻り値:
ログエージェントのパラメータの配列
例外:
LogPropertyException - ログエージェントのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.system.log (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.system.log
インタフェース
LogAgent
LogConstant
LogPropertyHandler
クラス
DefaultLogAgent
DefaultLogPropertyHandler
IntramartLogAgent
LogAgentParam
LogManager
XmlLogPropertyHandler
例外
LogPropertyException


jp.co.intra_mart.framework.system.log (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.log

J2EEフレームワークのログに関連するパッケージです。

参照:
説明

インタフェースの概要
LogAgent | ログに出力するエージェントです。
LogConstant | ログフレームワークで使用される定数値です。
LogPropertyHandler | ログフレームワークで使用するプロパティハンドラです。

クラスの概要
DefaultLogAgent | デフォルトのログエージェントです。
DefaultLogPropertyHandler | ログに関連するデフォルトのプロパティハンドラです。
IntramartLogAgent | intra-mart で管理されているログに出力するログエージェントです。
LogAgentParam | ログエージェントの初期パラメータです。
LogManager | ログマネージャです。
XmlLogPropertyHandler | リソースからログプロパティ情報を取得するプロパティハンドラです。

例外の概要
LogPropertyException ログプロパティ取得時の例外です。

パッケージ jp.co.intra_mart.framework.system.log の説明

J2EEフレームワークのログに関連するパッケージです。


jp.co.intra_mart.framework.system.log クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.log の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.system.log.DefaultLogAgent (implements jp.co.intra_mart.framework.system.log.LogAgent)
    • class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler (implements jp.co.intra_mart.framework.system.log.LogPropertyHandler)
    • class jp.co.intra_mart.framework.system.log.IntramartLogAgent (implements jp.co.intra_mart.framework.system.log.LogAgent)
    • class jp.co.intra_mart.framework.system.log.LogManager
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.system.log.LogAgentParam
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.system.log.LogPropertyException
    • class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler (implements jp.co.intra_mart.framework.system.log.LogPropertyHandler)

インタフェース階層

  • interface jp.co.intra_mart.framework.system.log.LogAgent
  • interface jp.co.intra_mart.framework.system.log.LogConstant
  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.system.log.LogPropertyHandler


パッケージ jp.co.intra_mart.framework.system.log の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.system.log の使用

jp.co.intra_mart.framework.system.log を使用しているパッケージ
jp.co.intra_mart.framework.system.log J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.system.log により使用される jp.co.intra_mart.framework.system.log のクラス
LogAgent
ログに出力するエージェントです。
LogAgentParam
ログエージェントの初期パラメータです。
LogManager
ログマネージャです。
LogPropertyException
ログプロパティ取得時の例外です。
LogPropertyHandler
ログフレームワークで使用するプロパティハンドラです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


XmlLogPropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス XmlLogPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler
すべての実装インタフェース:
LogPropertyHandler, PropertyHandler
public class XmlLogPropertyHandler
extends Object
implements LogPropertyHandler

リソースからログプロパティ情報を取得するプロパティハンドラです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのXMLファイル名
static String | DEFAULT_BUNDLE_NAME_PARAM XMLファイル名のパラメータ名
コンストラクタの概要
XmlLogPropertyHandler()
XMLLogPropertyHandlerを新規に生成します。
メソッドの概要
String | getLogAgentName() ログエージェントのクラス名を取得します。
LogAgentParam[] | getLogAgentParams() ログエージェントのパラメータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのXMLファイル名

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
XMLファイル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

XmlLogPropertyHandler

public XmlLogPropertyHandler()
XMLLogPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

getLogAgentName

public String getLogAgentName()
                       throws LogPropertyException
ログエージェントのクラス名を取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース LogPropertyHandler 内の getLogAgentName
戻り値:
ログエージェントのクラス名（設定されていない場合null）
例外:
LogPropertyException - ログエージェントのクラス名の取得時に例外が発生

getLogAgentParams

public LogAgentParam[] getLogAgentParams()
                                  throws LogPropertyException
ログエージェントのパラメータを取得します。 何も設定されていない場合大きさが0の配列が返ります。

定義:
インタフェース LogPropertyHandler 内の getLogAgentParams
戻り値:
ログエージェントのパラメータの配列
例外:
LogPropertyException - ログエージェントのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler の使用

jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler の使用

jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.message.MessageManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.message.MessageManager の使用

MessageManager を使用しているパッケージ
jp.co.intra_mart.framework.system.message メッセージに関連するパッケージです。

jp.co.intra_mart.framework.system.message での MessageManager の使用

MessageManager を返す jp.co.intra_mart.framework.system.message のメソッド
static MessageManager MessageManager.getMessageManager()
MessageManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.message.MessageManagerException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.message.MessageManagerException の使用

MessageManagerException を使用しているパッケージ
jp.co.intra_mart.framework.system.message メッセージに関連するパッケージです。

jp.co.intra_mart.framework.system.message での MessageManagerException の使用

MessageManagerException をスローする jp.co.intra_mart.framework.system.message のメソッド
static MessageManager MessageManager.getMessageManager()
MessageManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.message.MessagePropertyException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.message.MessagePropertyException の使用

jp.co.intra_mart.framework.system.message.MessagePropertyException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.system.message.MessagePropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.message.MessagePropertyHandler の使用

MessagePropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.system.message メッセージに関連するパッケージです。

jp.co.intra_mart.framework.system.message での MessagePropertyHandler の使用

MessagePropertyHandler を返す jp.co.intra_mart.framework.system.message のメソッド
 MessagePropertyHandler MessageManager.getMessagePropertyHandler()
メッセージプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.message.MessagePropertyParam の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.message.MessagePropertyParam の使用

jp.co.intra_mart.framework.system.message.MessagePropertyParam はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DefaultMessagePropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
クラス DefaultMessagePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler
すべての実装インタフェース:
MessagePropertyHandler, PropertyHandler
public class DefaultMessagePropertyHandler
extends Object
implements MessagePropertyHandler

デフォルトのメッセージプロパティハンドラです。 プロパティの設定内容は以下のとおりです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
コンストラクタの概要
DefaultMessagePropertyHandler()
DefaultMessagePropertyHandlerを新規に生成します。
メソッドの概要
String | getMessage(String key) キーに該当するメッセージを取得します。
String | getMessage(String key, String loginGroup) 推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。 getMessage(String)を使用してください。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultMessagePropertyHandler

public DefaultMessagePropertyHandler()
DefaultMessagePropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

getMessage

public String getMessage(String key,
                         String loginGroup)
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
getMessage(String)を使用してください。

キーに該当するメッセージを取得します。 該当するキーが存在しない場合、空文字列を返します。 プロパティの設定内容は以下のとおりです。
キー | 内容
ログイングループID.キー | ログイングループIDとキーに対応するメッセージ

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
key - メッセージのキー
loginGroup - ログイングループ
戻り値:
メッセージ

getMessage

public String getMessage(String key)
キーに該当するメッセージを取得します。 該当するキーが存在しない場合、空文字列を返します。 プロパティの設定内容は以下のとおりです。
キー | 内容
キー | キーに対応するメッセージ

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
key - メッセージのキー
戻り値:
メッセージ
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


IntramartMessagePropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
クラス IntramartMessagePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler
すべての実装インタフェース:
MessagePropertyHandler, PropertyHandler
public class IntramartMessagePropertyHandler
extends Object
implements MessagePropertyHandler

イントラマートで設定されたメッセージにアクセスするメッセージプロパティハンドラです。

バージョン:
1.0

コンストラクタの概要
IntramartMessagePropertyHandler()
IntramartMessagePropertyHandlerを新規に生成します。
メソッドの概要
String | getMessage(String key) キーに該当するメッセージを取得します。
String | getMessage(String key, String loginGroup) 推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。 パラメータloginGroupは実際には使用しません。getMessage(String)を使用してください。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartMessagePropertyHandler

public IntramartMessagePropertyHandler()
IntramartMessagePropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

getMessage

public String getMessage(String key,
                         String loginGroup)
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
パラメータloginGroupは実際には使用しません。getMessage(String)を使用してください。

キーに該当するメッセージを取得します。 該当するキーが存在しない場合、空文字列を返します。

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
key - メッセージのキー
loginGroup - ログイングループ
戻り値:
メッセージ

getMessage

public String getMessage(String key)
キーに該当するメッセージを取得します。 該当するキーが存在しない場合、空文字列を返します。

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
key - メッセージのキー
戻り値:
メッセージ
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MessageManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
クラス MessageManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.message.MessageManager
public class MessageManager
extends Object

メッセージを制御します。

バージョン:
1.0

フィールドの概要
static String MESSAGE_PROPERTY_HANDLER_KEY
メッセージプロパティハンドラのキー
メソッドの概要
String | getMessage(String key) キーに該当するメッセージを取得します。
String | getMessage(String key, String loginGroup) 推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。 設定されているMessagePropertyHandlerによっては、 パラメータloginGroupは実際には使用しない可能性があります。getMessage(String)を使用してください。
static MessageManager | getMessageManager() MessageManagerを取得します。
MessagePropertyHandler | getMessagePropertyHandler() メッセージプロパティハンドラを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

MESSAGE_PROPERTY_HANDLER_KEY

public static final String MESSAGE_PROPERTY_HANDLER_KEY
メッセージプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getMessageManager

public static MessageManager getMessageManager()
                                        throws MessageManagerException
MessageManagerを取得します。

戻り値:
メッセージマネージャ
例外:
MessageManagerException - メッセージマネージャの取得時に例外が発生

getMessagePropertyHandler

public MessagePropertyHandler getMessagePropertyHandler()
メッセージプロパティハンドラを取得します。

戻り値:
メッセージプロパティハンドラ

getMessage

public String getMessage(String key,
                         String loginGroup)
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
設定されているMessagePropertyHandlerによっては、 パラメータloginGroupは実際には使用しない可能性があります。getMessage(String)を使用してください。

キーに該当するメッセージを取得します。 キーがnullの場合、またはキーに該当するメッセージが存在しない場合、空文字列を返します。

パラメータ:
key - キー
loginGroup - ログイングループ
戻り値:
メッセージ

getMessage

public String getMessage(String key)
キーに該当するメッセージを取得します。 キーがnullの場合、またはキーに該当するメッセージが存在しない場合、空文字列を返します。

パラメータ:
key - キー
戻り値:
メッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MessageManagerException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
クラス MessageManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.system.message.MessageManagerException
すべての実装インタフェース:
Serializable
public class MessageManagerException
extends SystemException

メッセージマネージャに関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
MessageManagerException()
詳細メッセージを指定しないで MessageManagerException を構築します。
MessageManagerException(String msg)
指定された詳細メッセージを持つ MessageManagerException を構築します。
MessageManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessageManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MessageManagerException

public MessageManagerException()
詳細メッセージを指定しないで MessageManagerException を構築します。

MessageManagerException

public MessageManagerException(String msg)
指定された詳細メッセージを持つ MessageManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

MessageManagerException

public MessageManagerException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessageManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MessagePropertyException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
クラス MessagePropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.system.message.MessagePropertyException
すべての実装インタフェース:
Serializable
public class MessagePropertyException
extends SystemException

メッセージプロパティハンドラに関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
MessagePropertyException()
詳細メッセージを指定しないで MessagePropertyException を構築します。
MessagePropertyException(String msg)
指定された詳細メッセージを持つ MessagePropertyException を構築します。
MessagePropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessagePropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MessagePropertyException

public MessagePropertyException()
詳細メッセージを指定しないで MessagePropertyException を構築します。

MessagePropertyException

public MessagePropertyException(String msg)
指定された詳細メッセージを持つ MessagePropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

MessagePropertyException

public MessagePropertyException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessagePropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MessagePropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
インタフェース MessagePropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultMessagePropertyHandler, IntramartMessagePropertyHandler
public interface MessagePropertyHandler
extends PropertyHandler

メッセージに関連するプロパティを取得します。

バージョン:
1.0

メソッドの概要
String | getMessage(String key) キーに該当するメッセージを取得します。
String | getMessage(String key, String loginGroup) 推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。 getMessage(String)を使用してください。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

getMessage

public String getMessage(String key,
                         String loginGroup)
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
getMessage(String)を使用してください。

キーに該当するメッセージを取得します。 該当するキーが存在しない場合、空文字列を返します。

パラメータ:
key - メッセージのキー
loginGroup - ログイングループ
戻り値:
メッセージ

getMessage

public String getMessage(String key)
キーに該当するメッセージを取得します。 該当するキーが存在しない場合、空文字列を返します。

パラメータ:
key - メッセージのキー
戻り値:
メッセージ
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MessagePropertyParam (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
クラス MessagePropertyParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
        拡張 jp.co.intra_mart.framework.system.message.MessagePropertyParam
public class MessagePropertyParam
extends PropertyParam

メッセージプロパティハンドラの初期パラメータです。

バージョン:
1.0

コンストラクタの概要
MessagePropertyParam()
MessagePropertyParamを新規に生成します。
クラス jp.co.intra_mart.framework.system.property.PropertyParam から継承したメソッド
getName, getValue, setName, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MessagePropertyParam

public MessagePropertyParam()
MessagePropertyParamを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.system.message (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.system.message
インタフェース
MessagePropertyHandler
クラス
DefaultMessagePropertyHandler
IntramartMessagePropertyHandler
MessageManager
MessagePropertyParam
例外
MessageManagerException
MessagePropertyException


jp.co.intra_mart.framework.system.message (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.message

メッセージに関連するパッケージです。

参照:
説明

インタフェースの概要
MessagePropertyHandler メッセージに関連するプロパティを取得します。

クラスの概要
DefaultMessagePropertyHandler | デフォルトのメッセージプロパティハンドラです。
IntramartMessagePropertyHandler | イントラマートで設定されたメッセージにアクセスするメッセージプロパティハンドラです。
MessageManager | メッセージを制御します。
MessagePropertyParam | メッセージプロパティハンドラの初期パラメータです。

例外の概要
MessageManagerException | メッセージマネージャに関連する例外です。
MessagePropertyException | メッセージプロパティハンドラに関連する例外です。

パッケージ jp.co.intra_mart.framework.system.message の説明

メッセージに関連するパッケージです。


jp.co.intra_mart.framework.system.message クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.message の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler (implements jp.co.intra_mart.framework.system.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler (implements jp.co.intra_mart.framework.system.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.system.message.MessageManager
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.system.message.MessagePropertyParam
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.system.message.MessageManagerException
            • class jp.co.intra_mart.framework.system.message.MessagePropertyException

インタフェース階層

  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.system.message.MessagePropertyHandler


パッケージ jp.co.intra_mart.framework.system.message の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.system.message の使用

jp.co.intra_mart.framework.system.message を使用しているパッケージ
jp.co.intra_mart.framework.system.message メッセージに関連するパッケージです。

jp.co.intra_mart.framework.system.message により使用される jp.co.intra_mart.framework.system.message のクラス
MessageManager
メッセージを制御します。
MessageManagerException
メッセージマネージャに関連する例外です。
MessagePropertyHandler
メッセージに関連するプロパティを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.DefaultPropertyManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.DefaultPropertyManager の使用

jp.co.intra_mart.framework.system.property.DefaultPropertyManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.PropertyConfigModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyConfigModel の使用

jp.co.intra_mart.framework.system.property.PropertyConfigModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.property.PropertyHandler の使用

PropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.message | メッセージに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.base.data での PropertyHandler の使用

jp.co.intra_mart.framework.base.data での PropertyHandler のサブインタフェース
 interface DataPropertyHandler
DAOの設定情報に接続するクラスです。

PropertyHandler を実装している jp.co.intra_mart.framework.base.data のクラス
class | DefaultDataPropertyHandler デフォルトのデータプロパティハンドラです。
class | DistributesDataPropertyHandler アプリケーション毎のプロパティハンドラを呼び出します。
class | TextFileDataPropertyHandler 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
class | XmlDataPropertyHandler XMLのデータプロパティハンドラです。

jp.co.intra_mart.framework.base.event での PropertyHandler の使用

jp.co.intra_mart.framework.base.event での PropertyHandler のサブインタフェース
 interface EventPropertyHandler
イベントの設定情報に接続するクラスです。

PropertyHandler を実装している jp.co.intra_mart.framework.base.event のクラス
class | DefaultEventPropertyHandler デフォルトのEventPropertyHandlerです。
class | DistributesEventPropertyHandler アプリケーション毎のEventPropertyHandlerを呼び出します。
class | TextFileEventPropertyHandler 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
class | XmlEventPropertyHandler XMLのEventPropertyHandlerです。

jp.co.intra_mart.framework.base.message での PropertyHandler の使用

jp.co.intra_mart.framework.base.message での PropertyHandler のサブインタフェース
 interface MessagePropertyHandler
メッセージの設定情報に接続するクラスです。

PropertyHandler を実装している jp.co.intra_mart.framework.base.message のクラス
class | DefaultMessagePropertyHandler メッセージの設定情報に接続するデフォルトのプロパティハンドラです。
class | TextFileMessagePropertyHandler 指定されたファイルからプロパティ情報を取得するメッセージプロパティハンドラです。

jp.co.intra_mart.framework.base.service での PropertyHandler の使用

jp.co.intra_mart.framework.base.service での PropertyHandler のサブインタフェース
 interface ServicePropertyHandler
サービスの設定情報に接続するクラスです。

PropertyHandler を実装している jp.co.intra_mart.framework.base.service のクラス
class | DefaultServicePropertyHandler サービスの設定情報に接続するデフォルトのプロパティハンドラです。
class | DistributesServicePropertyHandler アプリケーションごとに異なるサービスプロパティハンドラを使用するサービスプロパティハンドラです。
class | TextFileServicePropertyHandler 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
class | XmlServicePropertyHandler サービスの設定情報に接続するプロパティハンドラです。

jp.co.intra_mart.framework.base.session での PropertyHandler の使用

jp.co.intra_mart.framework.base.session での PropertyHandler のサブインタフェース
 interface SessionPropertyHandler
セッションに関連するプロパティを取得します。

PropertyHandler を実装している jp.co.intra_mart.framework.base.session のクラス
class | DefaultSessionPropertyHandler セッションに関連するデフォルトのプロパティハンドラです。
class | XmlSessionPropertyHandler セッションに関連するXMLのプロパティハンドラです。

jp.co.intra_mart.framework.system.log での PropertyHandler の使用

jp.co.intra_mart.framework.system.log での PropertyHandler のサブインタフェース
 interface LogPropertyHandler
ログフレームワークで使用するプロパティハンドラです。

PropertyHandler を実装している jp.co.intra_mart.framework.system.log のクラス
class | DefaultLogPropertyHandler ログに関連するデフォルトのプロパティハンドラです。
class | XmlLogPropertyHandler リソースからログプロパティ情報を取得するプロパティハンドラです。

jp.co.intra_mart.framework.system.message での PropertyHandler の使用

PropertyHandler を実装している jp.co.intra_mart.framework.system.message のクラス
 class IntramartMessagePropertyHandler
イントラマートで設定されたメッセージにアクセスするメッセージプロパティハンドラです。

jp.co.intra_mart.framework.system.property での PropertyHandler の使用

PropertyHandler を返す jp.co.intra_mart.framework.system.property のメソッド
 PropertyHandler PropertyManager.getPropertyHandler(String key)
キーで指定されたプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.PropertyHandlerException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyHandlerException の使用

PropertyHandlerException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.message | メッセージに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.base.data での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.base.data のメソッド
void | XmlDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | TextFileDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DistributesDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.event での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.base.event のメソッド
void | XmlEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | TextFileEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DistributesEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.message での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.base.message のメソッド
void | TextFileMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.service での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.base.service のメソッド
void | XmlServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | TextFileServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DistributesServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.session での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.base.session のメソッド
void | XmlSessionPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultSessionPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.system.log での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.system.log のメソッド
void | XmlLogPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultLogPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.system.message での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.system.message のメソッド
void | IntramartMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.system.property での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.system.property のメソッド
protected String | XmlPropertyManager.getPropertyHandlerName(String key) キーで指定されたプロパティハンドラのクラス名を取得します。
protected abstract String | PropertyManager.getPropertyHandlerName(String key) キーで指定されたプロパティハンドラのクラス名を取得します。
PropertyHandler | PropertyManager.getPropertyHandler(String key) キーで指定されたプロパティハンドラを取得します。
void | PropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
protected String | DefaultPropertyManager.getPropertyHandlerName(String key) キーで指定されたプロパティハンドラのクラス名を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.PropertyHandlerParam の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyHandlerParam の使用

PropertyHandlerParam を使用しているパッケージ
jp.co.intra_mart.framework.system.property プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.system.property での PropertyHandlerParam の使用

PropertyHandlerParam を返す jp.co.intra_mart.framework.system.property のメソッド
protected PropertyHandlerParam[] | XmlPropertyManager.getPropertyHandlerParams(String key) キーで指定されたプロパティハンドラの初期化データを取得します。
protected abstract PropertyHandlerParam[] | PropertyManager.getPropertyHandlerParams(String key) キーで指定されたプロパティハンドラの初期化データを取得します。
protected PropertyHandlerParam[] | PropertyConfigModel.getPropertyParams(String key) 指定されたキーのプロパティのパラメータを取得します。
protected PropertyHandlerParam[] | DefaultPropertyManager.getPropertyHandlerParams(String key) キーで指定されたプロパティハンドラの初期化データを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.PropertyManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyManager の使用

PropertyManager を使用しているパッケージ
jp.co.intra_mart.framework.system.property プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.system.property での PropertyManager の使用

jp.co.intra_mart.framework.system.property での PropertyManager のサブクラス
class | DefaultPropertyManager デフォルトのプロパティマネージャです。
class | XmlPropertyManager xmlのプロパティマネージャです。

PropertyManager を返す jp.co.intra_mart.framework.system.property のメソッド
static PropertyManager PropertyManager.getPropertyManager()
プロパティマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.PropertyManagerException の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyManagerException の使用

PropertyManagerException を使用しているパッケージ
jp.co.intra_mart.framework.system.property プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.system.property での PropertyManagerException の使用

PropertyManagerException をスローする jp.co.intra_mart.framework.system.property のメソッド
static PropertyManager PropertyManager.getPropertyManager()
プロパティマネージャを取得します。

PropertyManagerException をスローする jp.co.intra_mart.framework.system.property のコンストラクタ
XmlPropertyManager()
コンストラクタです。
DefaultPropertyManager()
コンストラクタです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.PropertyModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyModel の使用

jp.co.intra_mart.framework.system.property.PropertyModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.PropertyParam の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyParam の使用

PropertyParam を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.tag | J2EEフレームワークで使用する各種のタグのパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.message | メッセージに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.base.data での PropertyParam の使用

jp.co.intra_mart.framework.base.data での PropertyParam のサブクラス
 class ResourceParam
データコネクタの初期パラメータです。

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.base.data のメソッド
void | XmlDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | TextFileDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DistributesDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.event での PropertyParam の使用

jp.co.intra_mart.framework.base.event での PropertyParam のサブクラス
 class EventListenerFactoryParam
イベントリスナファクトリの初期パラメータです。

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.base.event のメソッド
void | XmlEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | TextFileEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DistributesEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.message での PropertyParam の使用

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.base.message のメソッド
void | TextFileMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.service での PropertyParam の使用

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
void | XmlServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | TextFileServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DistributesServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.session での PropertyParam の使用

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.base.session のメソッド
void | XmlSessionPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultSessionPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.web.tag での PropertyParam の使用

jp.co.intra_mart.framework.base.web.tag での PropertyParam のサブクラス
 class FrameworkTagParam
タグに追加されるパラメータです。

jp.co.intra_mart.framework.system.log での PropertyParam の使用

jp.co.intra_mart.framework.system.log での PropertyParam のサブクラス
 class LogAgentParam
ログエージェントの初期パラメータです。

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.system.log のメソッド
void | XmlLogPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultLogPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.system.message での PropertyParam の使用

jp.co.intra_mart.framework.system.message での PropertyParam のサブクラス
 class MessagePropertyParam
メッセージプロパティハンドラの初期パラメータです。

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.system.message のメソッド
void | IntramartMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.system.property での PropertyParam の使用

jp.co.intra_mart.framework.system.property での PropertyParam のサブクラス
 class PropertyHandlerParam
プロパティハンドラを生成する時の初期パラメータです。

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.system.property のメソッド
 void PropertyHandler.init(PropertyParam[] params)
プロパティハンドラを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.XmlPropertyManager の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.XmlPropertyManager の使用

jp.co.intra_mart.framework.system.property.XmlPropertyManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DefaultPropertyManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス DefaultPropertyManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyManager
        拡張 jp.co.intra_mart.framework.system.property.DefaultPropertyManager
public class DefaultPropertyManager
extends PropertyManager

デフォルトのプロパティマネージャです。 リソースバンドルで設定されたプロパティ情報を管理します。 プロパティ情報のリソースバンドルは以下の順番で決定されます。

 1.システムプロパティKEYで設定されているリソースバンドル
 2.デフォルトのプロパティマネージャDEFAULT_BUNDLE_NAMEで設定されているリソースバンドル

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名
static String | KEY プロパティマネージャを指定するキー
クラス jp.co.intra_mart.framework.system.property.PropertyManager から継承したフィールド
DEFAULT_SYSTEM_MANAGER
コンストラクタの概要
DefaultPropertyManager()
コンストラクタです。
メソッドの概要
protected String | getPropertyHandlerName(String key) キーで指定されたプロパティハンドラのクラス名を取得します。
protected PropertyHandlerParam[] | getPropertyHandlerParams(String key) キーで指定されたプロパティハンドラの初期化データを取得します。
クラス jp.co.intra_mart.framework.system.property.PropertyManager から継承したメソッド
getPropertyHandler, getPropertyManager
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KEY

public static final String KEY
プロパティマネージャを指定するキー

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultPropertyManager

public DefaultPropertyManager()
                       throws PropertyManagerException
コンストラクタです。

例外:
PropertyManagerException - プロパティマネージャの設定に失敗
メソッドの詳細

getPropertyHandlerName

protected String getPropertyHandlerName(String key)
                                 throws PropertyHandlerException
キーで指定されたプロパティハンドラのクラス名を取得します。

定義:
クラス PropertyManager 内の getPropertyHandlerName
パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラのクラス名
例外:
PropertyHandlerException - クラス名の取得に失敗

getPropertyHandlerParams

protected PropertyHandlerParam[] getPropertyHandlerParams(String key)
キーで指定されたプロパティハンドラの初期化データを取得します。 初期化データが存在しない場合、nullが返ります。

定義:
クラス PropertyManager 内の getPropertyHandlerParams
パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラの初期化データ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.system.property (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.system.property
インタフェース
PropertyHandler
クラス
DefaultPropertyManager
PropertyConfigModel
PropertyHandlerParam
PropertyManager
PropertyModel
PropertyParam
XmlPropertyManager
例外
PropertyHandlerException
PropertyManagerException


jp.co.intra_mart.framework.system.property (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.property

プロパティ取得に関連するパッケージです。

参照:
説明

インタフェースの概要
PropertyHandler プロパティにアクセスするインタフェースです。

クラスの概要
DefaultPropertyManager | デフォルトのプロパティマネージャです。
PropertyConfigModel | データモデルクラスです。
PropertyHandlerParam | プロパティハンドラを生成する時の初期パラメータです。
PropertyManager | システム設定の情報を管理します。
PropertyModel | プロパティモデルクラスです。
PropertyParam | プロパティのパラメータを表現する汎用的なクラスです。
XmlPropertyManager | xmlのプロパティマネージャです。

例外の概要
PropertyHandlerException | プロパティハンドラの情報取得時の例外です。
PropertyManagerException | プロパティマネージャの設定時の例外です。

パッケージ jp.co.intra_mart.framework.system.property の説明

プロパティ取得に関連するパッケージです。


jp.co.intra_mart.framework.system.property クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.property の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.system.property.PropertyConfigModel
    • class jp.co.intra_mart.framework.system.property.PropertyManager
      • class jp.co.intra_mart.framework.system.property.DefaultPropertyManager
      • class jp.co.intra_mart.framework.system.property.XmlPropertyManager
    • class jp.co.intra_mart.framework.system.property.PropertyModel
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.system.property.PropertyHandlerParam
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.property.PropertyHandlerException
          • class jp.co.intra_mart.framework.system.property.PropertyManagerException

インタフェース階層

  • interface jp.co.intra_mart.framework.system.property.PropertyHandler


パッケージ jp.co.intra_mart.framework.system.property の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.system.property の使用

jp.co.intra_mart.framework.system.property を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.tag | J2EEフレームワークで使用する各種のタグのパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.message | メッセージに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.base.data により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.base.event により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.base.message により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.base.session により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.base.web.tag により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.system.log により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.system.message により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.system.property により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyHandlerParam
プロパティハンドラを生成する時の初期パラメータです。
PropertyManager
システム設定の情報を管理します。
PropertyManagerException
プロパティマネージャの設定時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PropertyConfigModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyConfigModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyConfigModel
public class PropertyConfigModel
extends Object

データモデルクラスです。

バージョン:
1.0

コンストラクタの概要
PropertyConfigModel()
メソッドの概要
protected String | getPropertyHandlerName(String key) 指定されたキーのプロパティハンドラ名を取得します。
protected PropertyHandlerParam[] | getPropertyParams(String key) 指定されたキーのプロパティのパラメータを取得します。
protected void | setProperties(Map map) パラメータを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PropertyConfigModel

public PropertyConfigModel()
メソッドの詳細

setProperties

protected void setProperties(Map map)
パラメータを設定します。

パラメータ:
map -

getPropertyHandlerName

protected String getPropertyHandlerName(String key)
指定されたキーのプロパティハンドラ名を取得します。

戻り値:
String

getPropertyParams

protected PropertyHandlerParam[] getPropertyParams(String key)
指定されたキーのプロパティのパラメータを取得します。

戻り値:
PropertyParam[]
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PropertyHandler (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
インタフェース PropertyHandler

既知のサブインタフェースの一覧:
DataPropertyHandler, EventPropertyHandler, LogPropertyHandler, MessagePropertyHandler, MessagePropertyHandler, ServicePropertyHandler, SessionPropertyHandler
既知の実装クラスの一覧:
DefaultDataPropertyHandler, DefaultEventPropertyHandler, DefaultLogPropertyHandler, DefaultMessagePropertyHandler, DefaultMessagePropertyHandler, DefaultServicePropertyHandler, DefaultSessionPropertyHandler, DistributesDataPropertyHandler, DistributesEventPropertyHandler, DistributesServicePropertyHandler, IntramartMessagePropertyHandler, TextFileDataPropertyHandler, TextFileEventPropertyHandler, TextFileMessagePropertyHandler, TextFileServicePropertyHandler, XmlDataPropertyHandler, XmlEventPropertyHandler, XmlLogPropertyHandler, XmlServicePropertyHandler, XmlSessionPropertyHandler
public interface PropertyHandler

プロパティにアクセスするインタフェースです。 このインタフェースを実装するすべてのクラスは、引数なしのコンストラクタが必要です。

バージョン:
1.0

メソッドの概要
 void init(PropertyParam[] params)
プロパティハンドラを初期化します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PropertyHandlerException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyHandlerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.property.PropertyHandlerException
すべての実装インタフェース:
Serializable
public class PropertyHandlerException
extends FrameworkException

プロパティハンドラの情報取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
PropertyHandlerException()
詳細メッセージを指定しないで PropertyHandlerException を構築します。
PropertyHandlerException(String msg)
指定された詳細メッセージを持つ PropertyHandlerException を構築します。
PropertyHandlerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PropertyHandlerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PropertyHandlerException

public PropertyHandlerException()
詳細メッセージを指定しないで PropertyHandlerException を構築します。

PropertyHandlerException

public PropertyHandlerException(String msg)
指定された詳細メッセージを持つ PropertyHandlerException を構築します。

パラメータ:
msg - 詳細メッセージ

PropertyHandlerException

public PropertyHandlerException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PropertyHandlerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PropertyHandlerParam (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyHandlerParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
        拡張 jp.co.intra_mart.framework.system.property.PropertyHandlerParam
public class PropertyHandlerParam
extends PropertyParam

プロパティハンドラを生成する時の初期パラメータです。

バージョン:
1.0

コンストラクタの概要
PropertyHandlerParam()
PropertyHandlerParamを新規に生成します。
クラス jp.co.intra_mart.framework.system.property.PropertyParam から継承したメソッド
getName, getValue, setName, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PropertyHandlerParam

public PropertyHandlerParam()
PropertyHandlerParamを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PropertyManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyManager
直系の既知のサブクラス:
DefaultPropertyManager, XmlPropertyManager
public abstract class PropertyManager
extends Object

システム設定の情報を管理します。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_SYSTEM_MANAGER デフォルトのプロパティマネージャクラス
static String | KEY プロパティマネージャを指定するキー
コンストラクタの概要
protected PropertyManager()
プロパティマネージャのコンストラクタです。
メソッドの概要
PropertyHandler | getPropertyHandler(String key) キーで指定されたプロパティハンドラを取得します。
protected abstract String | getPropertyHandlerName(String key) キーで指定されたプロパティハンドラのクラス名を取得します。
protected abstract PropertyHandlerParam[] | getPropertyHandlerParams(String key) キーで指定されたプロパティハンドラの初期化データを取得します。
static PropertyManager | getPropertyManager() プロパティマネージャを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KEY

public static final String KEY
プロパティマネージャを指定するキー

関連項目:
定数フィールド値

DEFAULT_SYSTEM_MANAGER

public static final String DEFAULT_SYSTEM_MANAGER
デフォルトのプロパティマネージャクラス

関連項目:
定数フィールド値
コンストラクタの詳細

PropertyManager

protected PropertyManager()
プロパティマネージャのコンストラクタです。 コンストラクタの明示的な使用はできません。

メソッドの詳細

getPropertyManager

public static PropertyManager getPropertyManager()
                                          throws PropertyManagerException
プロパティマネージャを取得します。 プロパティマネージャは常に１つだけ存在します。 プロパティマネージャが未設定の状態でこのメソッドが呼ばれた場合、以下の順番でプロパティマネージャを取得します。
 1.システムプロパティKEYで設定されているプロパティマネージャ
 2.デフォルトのプロパティマネージャ

戻り値:
プロパティマネージャ
例外:
PropertyManagerException - プロパティマネージャの設定時に発生する例外

getPropertyHandlerName

protected abstract String getPropertyHandlerName(String key)
                                          throws PropertyHandlerException
キーで指定されたプロパティハンドラのクラス名を取得します。

パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラのクラス名
例外:
PropertyHandlerException - プロパティハンドラのクラス名を取得できなかった場合に発生する例外

getPropertyHandlerParams

protected abstract PropertyHandlerParam[] getPropertyHandlerParams(String key)
キーで指定されたプロパティハンドラの初期化データを取得します。 初期化データが存在しない場合、nullが返ります。

パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラの初期化データ

getPropertyHandler

public PropertyHandler getPropertyHandler(String key)
                                   throws PropertyHandlerException
キーで指定されたプロパティハンドラを取得します。

パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラ
例外:
PropertyHandlerException - プロパティハンドラの取得に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PropertyManagerException (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.property.PropertyManagerException
すべての実装インタフェース:
Serializable
public class PropertyManagerException
extends FrameworkException

プロパティマネージャの設定時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
PropertyManagerException()
詳細メッセージを指定しないで PropertyManagerException を構築します。
PropertyManagerException(String msg)
指定された詳細メッセージを持つ PropertyManagerException を構築します。
PropertyManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PropertyManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PropertyManagerException

public PropertyManagerException()
詳細メッセージを指定しないで PropertyManagerException を構築します。

PropertyManagerException

public PropertyManagerException(String msg)
指定された詳細メッセージを持つ PropertyManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

PropertyManagerException

public PropertyManagerException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PropertyManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PropertyModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyModel
public class PropertyModel
extends Object

プロパティモデルクラスです。

バージョン:
1.0

コンストラクタの概要
PropertyModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PropertyModel

public PropertyModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PropertyParam (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
直系の既知のサブクラス:
EventListenerFactoryParam, FrameworkTagParam, LogAgentParam, MessagePropertyParam, PropertyHandlerParam, ResourceParam
public class PropertyParam
extends Object

プロパティのパラメータを表現する汎用的なクラスです。 このクラスのインスタンス１つがパラメータ名とパラメータの値という１つのペアに対応します。

バージョン:
1.0

コンストラクタの概要
PropertyParam()
PropertyParamを新規に生成します。
メソッドの概要
String | getName() パラメータ名を取得します。
String | getValue() パラメータの値を取得します。
void | setName(String name) パラメータ名を設定します。
void | setValue(String value) パラメータの値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PropertyParam

public PropertyParam()
PropertyParamを新規に生成します。

メソッドの詳細

setName

public void setName(String name)
パラメータ名を設定します。

パラメータ:
name - パラメータ名

getName

public String getName()
パラメータ名を取得します。

戻り値:
パラメータ名

setValue

public void setValue(String value)
パラメータの値を設定します。

パラメータ:
value - パラメータの値

getValue

public String getValue()
パラメータの値を取得します。

戻り値:
パラメータの値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XmlPropertyManager (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス XmlPropertyManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyManager
        拡張 jp.co.intra_mart.framework.system.property.XmlPropertyManager
public class XmlPropertyManager
extends PropertyManager

xmlのプロパティマネージャです。 プロパティ情報を管理します。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名
static String | KEY プロパティマネージャを指定するキー
クラス jp.co.intra_mart.framework.system.property.PropertyManager から継承したフィールド
DEFAULT_SYSTEM_MANAGER
コンストラクタの概要
XmlPropertyManager()
コンストラクタです。
メソッドの概要
protected String | getPropertyHandlerName(String key) キーで指定されたプロパティハンドラのクラス名を取得します。
protected PropertyHandlerParam[] | getPropertyHandlerParams(String key) キーで指定されたプロパティハンドラの初期化データを取得します。
クラス jp.co.intra_mart.framework.system.property.PropertyManager から継承したメソッド
getPropertyHandler, getPropertyManager
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KEY

public static final String KEY
プロパティマネージャを指定するキー

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名

関連項目:
定数フィールド値
コンストラクタの詳細

XmlPropertyManager

public XmlPropertyManager()
                   throws PropertyManagerException
コンストラクタです。

例外:
PropertyManagerException - プロパティマネージャの設定に失敗
メソッドの詳細

getPropertyHandlerName

protected String getPropertyHandlerName(String key)
                                 throws PropertyHandlerException
キーで指定されたプロパティハンドラのクラス名を取得します。

定義:
クラス PropertyManager 内の getPropertyHandlerName
パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラのクラス名
例外:
PropertyHandlerException - クラス名の取得に失敗

getPropertyHandlerParams

protected PropertyHandlerParam[] getPropertyHandlerParams(String key)
キーで指定されたプロパティハンドラの初期化データを取得します。 初期化データが存在しない場合、nullが返ります。

定義:
クラス PropertyManager 内の getPropertyHandlerParams
パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラの初期化データ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.system.util.Config の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.util.Config の使用

Config を使用しているパッケージ
jp.co.intra_mart.framework.base.service.controller
jp.co.intra_mart.framework.base.service.validator

jp.co.intra_mart.framework.base.service.controller での Config の使用

jp.co.intra_mart.framework.base.service.controller での Config のサブクラス
 class ControllerConverterConfigImpl
ControllerConverterの初期化情報です。

jp.co.intra_mart.framework.base.service.validator での Config の使用

jp.co.intra_mart.framework.base.service.validator での Config のサブクラス
 class ValidatorConfigImpl
ValidatorConfigの実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Config (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.util
クラス Config

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.util.Config
直系の既知のサブクラス:
ControllerConverterConfigImpl, ValidatorConfigImpl
public abstract class Config
extends Object

標準的な初期化情報です。

導入されたバージョン:
6.1

フィールドの概要
protected  Map parameters
パラメータの集合
コンストラクタの概要
Config()
メソッドの概要
String | getInitParameter(String name) Validatorを初期化するときのパラメータを取得します。
Enumeration | getInitParameterNames() 初期化パラメータの名前の一覧を取得します。
void | setInitParameter(String name, String value) Validatorを初期化するときのパラメータを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

parameters

protected Map parameters
パラメータの集合

コンストラクタの詳細

Config

public Config()
メソッドの詳細

getInitParameter

public String getInitParameter(String name)
Validatorを初期化するときのパラメータを取得します。

パラメータ:
name - 初期化パラメータ名
戻り値:
初期化パラメータの値

setInitParameter

public void setInitParameter(String name,
                             String value)
Validatorを初期化するときのパラメータを設定します。

パラメータ:
name - 初期化パラメータ名
value - 初期化パラメータの値

getInitParameterNames

public Enumeration getInitParameterNames()
初期化パラメータの名前の一覧を取得します。

戻り値:
初期化パラメータの名前の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.system.util (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.framework.system.util
クラス
Config


jp.co.intra_mart.framework.system.util (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.util

クラスの概要
Config 標準的な初期化情報です。


jp.co.intra_mart.framework.system.util クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.system.util.Config


パッケージ jp.co.intra_mart.framework.system.util の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.system.util の使用

jp.co.intra_mart.framework.system.util を使用しているパッケージ
jp.co.intra_mart.framework.base.service.controller
jp.co.intra_mart.framework.base.service.validator

jp.co.intra_mart.framework.base.service.controller により使用される jp.co.intra_mart.framework.system.util のクラス
Config
標準的な初期化情報です。

jp.co.intra_mart.framework.base.service.validator により使用される jp.co.intra_mart.framework.system.util のクラス
Config
標準的な初期化情報です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.jssp.net.GenericURLBuilder の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.jssp.net.GenericURLBuilder の使用

GenericURLBuilder を使用しているパッケージ
jp.co.intra_mart.jssp.net

jp.co.intra_mart.jssp.net での GenericURLBuilder の使用

jp.co.intra_mart.jssp.net での GenericURLBuilder のサブクラス
 class URLBuilder
スクリプト開発モデルの画面を呼び出すための URL を作成するビルダです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.jssp.net.URLBuilder の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.jssp.net.URLBuilder の使用

jp.co.intra_mart.jssp.net.URLBuilder はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


GenericURLBuilder (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.jssp.net
クラス GenericURLBuilder

java.lang.Object
    拡張 jp.co.intra_mart.jssp.net.GenericURLBuilder
直系の既知のサブクラス:
URLBuilder
public class GenericURLBuilder
extends Object

スクリプト開発モデルの画面を呼び出すための URL を作成するビルダです。

このクラスを利用する事により、 スクリプト開発モデルの画面へアクセスする URL を作成できます。 また、このクラスが生成する URL は、セッションチェック機能を持ったものに なるため、異なるセッションに対して生成された URL を用いてアクセスすると、 セッションエラーとなります。 つまり、このクラスが生成する URL は、セキュリティの強固なリンクとなります。

以下は「sample/example/string/main」を呼び出すためのURLを作成するサンプルコードです。

 HttpServletRequest request   = ... ;
 HttpServletResponse response = ... ;

 GenericURLBuilder urlBuilder = new GenericURLBuilder(request, response);
 URL urlContext = jp.co.intra_mart.common.aid.jsdk.utility.URLUtil.getContextURL(request);

 URL url = urlBuilder.createURL(urlContext, "sample/example/string/main");
 String urlString = url.toExternalForm();

 URL sessionURL = new URL(response.encodeURL(urlString));
 String pageURL = sessionURL.toExternalForm();

バージョン:
Version 5.0

コンストラクタの概要
GenericURLBuilder(HttpServletRequest request, HttpServletResponse response)
新しいビルダを作成します。
メソッドの概要
String | createFilePath(String path) 指定のページパスからリンクの為のページパスを作成して返します。
URL | createURL(String path) 現在のリクエストを元にして、指定の画面へリンクするための URL を作成します。
URL | createURL(URL context, String path) 指定の URL を仕様解析のコンテキストとして スクリプト開発モデルの画面への URL を解決した URL を返します。
protected HttpServletRequest | getRequest() 現在のリクエストを返します。
protected HttpServletResponse | getResponse() 現在のレスポンスを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericURLBuilder

public GenericURLBuilder(HttpServletRequest request,
                         HttpServletResponse response)
新しいビルダを作成します。

このオブジェクトでは、指定のリクエストおよびレスポンスにを利用して、 スクリプト開発モデルの画面へリンクするための情報を操作します。

パラメータ:
request - リクエスト
response - レスポンス
例外:
NullPointerException - 引数が null
メソッドの詳細

getRequest

protected HttpServletRequest getRequest()
現在のリクエストを返します。 返すリクエストは、コンストラクタの引数に渡されたリクエストです。

戻り値:
リクエスト

getResponse

protected HttpServletResponse getResponse()
現在のレスポンスを返します。 返すレスポンスは、コンストラクタの引数に渡されたレスポンスです。

戻り値:
レスポンス

createURL

public URL createURL(String path)
              throws MalformedURLException
現在のリクエストを元にして、指定の画面へリンクするための URL を作成します。

現在のリクエストを生成するのに使用した URL をコンテキストＵＲＬとして 絶対形式のＵＲＬを自動解決します。 コンテキストＵＲＬを任意に指定したい場合は、 createURL(URL context, String path)を利用してください。

パラメータ:
path - スクリプト開発モデルのプログラムパス
戻り値:
指定の画面へリンクするためのＵＲＬ
例外:
MalformedURLException - URL が無効な書式の場合

createURL

public URL createURL(URL context,
                     String path)
              throws MalformedURLException
指定の URL を仕様解析のコンテキストとして スクリプト開発モデルの画面への URL を解決した URL を返します。

このメソッドは、以下の動作と同じです。
new java.net.URL(context, this.createURL(path))

パラメータ:
context - 仕様を解析するコンテキスト
path - スクリプト開発モデルのプログラムパス
戻り値:
指定の画面へリンクするためのＵＲＬ
例外:
MalformedURLException - URL が無効な書式の場合

createFilePath

public String createFilePath(String path)
指定のページパスからリンクの為のページパスを作成して返します。

パラメータ:
path - スクリプト開発モデルの画面プログラムのパス
戻り値:
リンクの為のパス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.jssp.net (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.jssp.net
クラス
GenericURLBuilder
URLBuilder


jp.co.intra_mart.jssp.net (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.jssp.net

クラスの概要
GenericURLBuilder | スクリプト開発モデルの画面を呼び出すための URL を作成するビルダです。
URLBuilder | スクリプト開発モデルの画面を呼び出すための URL を作成するビルダです。


jp.co.intra_mart.jssp.net クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.jssp.net の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.jssp.net.GenericURLBuilder
      • class jp.co.intra_mart.jssp.net.URLBuilder


パッケージ jp.co.intra_mart.jssp.net の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.jssp.net の使用

jp.co.intra_mart.jssp.net を使用しているパッケージ
jp.co.intra_mart.jssp.net

jp.co.intra_mart.jssp.net により使用される jp.co.intra_mart.jssp.net のクラス
GenericURLBuilder
スクリプト開発モデルの画面を呼び出すための URL を作成するビルダです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


URLBuilder (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.jssp.net
クラス URLBuilder

java.lang.Object
    拡張 jp.co.intra_mart.jssp.net.GenericURLBuilder
        拡張 jp.co.intra_mart.jssp.net.URLBuilder
public class URLBuilder
extends GenericURLBuilder

スクリプト開発モデルの画面を呼び出すための URL を作成するビルダです。

このクラスを利用する事により、セッションを維持したまま スクリプト開発モデルの画面へリンクさせる事ができます。 また、このクラスが生成する URL は、セッションチェック機能を持ったものに なるため、異なるセッションに対して生成された URL を用いてアクセスすると、 セッションエラーとなります。 つまり、このクラスが生成する URL は、セキュリティの強固なリンクとなります。

以下は「sample/example/string/main」を呼び出すためのURLを作成するサンプルコードです。

 HttpServletRequest request   = ... ;
 HttpServletResponse response = ... ;

 URLBuilder urlBuilder = new URLBuilder(request, response);
 URL urlContext = jp.co.intra_mart.common.aid.jsdk.utility.URLUtil.getContextURL(request);

 URL sessionURL = urlBuilder.createURLonSession(urlContext, "sample/example/string/main");
 String pageURL = sessionURL.toExternalForm();

バージョン:
Version 5.0

コンストラクタの概要
URLBuilder(HttpServletRequest request, HttpServletResponse response)
新しいビルダを作成します。
メソッドの概要
URL | createURLonSession(String path) HTTP セッションを維持したまま指定のスクリプト開発モデルの画面へ リンクするための URL を返します。
URL | createURLonSession(URL context, String path) HTTP セッションを維持したまま指定のスクリプト開発モデルの画面へ リンクするための URL を返します。
クラス jp.co.intra_mart.jssp.net.GenericURLBuilder から継承したメソッド
createFilePath, createURL, createURL, getRequest, getResponse
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLBuilder

public URLBuilder(HttpServletRequest request,
                  HttpServletResponse response)
新しいビルダを作成します。

このオブジェクトでは、指定のリクエストおよびレスポンスにを利用して、 スクリプト開発モデルの画面へリンクするための情報を操作します。

パラメータ:
request - リクエスト
response - レスポンス
例外:
NullPointerException - 引数が null
メソッドの詳細

createURLonSession

public URL createURLonSession(String path)
                       throws MalformedURLException
HTTP セッションを維持したまま指定のスクリプト開発モデルの画面へ リンクするための URL を返します。

このメソッドは、 GenericURLBuilder.createURL(String path)が返す URL に対して、 HttpServletResponse.encodeURL(String url)を 実行した結果を返します。

パラメータ:
path - スクリプト開発モデルのプログラムパス
戻り値:
指定の画面へリンクするためのＵＲＬ
例外:
MalformedURLException - URL が無効な書式の場合

createURLonSession

public URL createURLonSession(URL context,
                              String path)
                       throws MalformedURLException
HTTP セッションを維持したまま指定のスクリプト開発モデルの画面へ リンクするための URL を返します。

このメソッドは、 GenericURLBuilder.createURL(URL context, String path)が返す URL に対して、 HttpServletResponse.encodeURL(String url)を 実行した結果を返します。

なお、このメソッドの引数 context の生成に便利なユーティリティクラス URLUtilが存在します。

パラメータ:
context - 仕様を解析するコンテキスト
path - スクリプト開発モデルのプログラムパス
戻り値:
指定の画面へリンクするためのＵＲＬ
例外:
MalformedURLException - URL が無効な書式の場合
関連項目:
URLUtil
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel の使用

AccessControllerBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での AccessControllerBaseModel の使用

AccessControllerBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
AccessControllerBaseModel | AccessControllerMapper.create(String accessControllerId) プライマリキーに該当するアクセスコントローラ情報を生成します。
AccessControllerBaseModel | AccessControllerMapper.select(String accessControllerId) プライマリーキーで特定されるアクセスコントローラ情報の基本モデルを取得します。

AccessControllerBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | AccessControllerMapper.insert(AccessControllerBaseModel model) アクセスコントローラ情報の基本モデルを1つだけ挿入します。
void | AccessControllerMapper.update(AccessControllerBaseModel model) アクセスコントローラ情報の基本モデルを1つだけ更新します。
void | AccessControllerMapper.delete(AccessControllerBaseModel model) アクセスコントローラ情報の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel の使用

AccessControllerDepartmentBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での AccessControllerDepartmentBaseModel の使用

AccessControllerDepartmentBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
AccessControllerDepartmentBaseModel | AccessControllerDepartmentMapper.create(String accessControllerId, String companyCd, String departmentCd) プライマリキーに該当するアクセスコントローラの利用権限を保有する組織を生成します。
AccessControllerDepartmentBaseModel | AccessControllerDepartmentMapper.select(String accessControllerId, String companyCd, String departmentCd) プライマリーキーで特定されるアクセスコントローラの利用権限を保有する組織の基本モデルを取得します。

AccessControllerDepartmentBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | AccessControllerDepartmentMapper.insert(AccessControllerDepartmentBaseModel model) アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ挿入します。
void | AccessControllerDepartmentMapper.update(AccessControllerDepartmentBaseModel model) アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ更新します。
void | AccessControllerDepartmentMapper.delete(AccessControllerDepartmentBaseModel model) アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper の使用

jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper の使用

jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel の使用

AccessControllerPostBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での AccessControllerPostBaseModel の使用

AccessControllerPostBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
AccessControllerPostBaseModel | AccessControllerPostMapper.create(String accessControllerId, String companyCd, String postCd) プライマリキーに該当するアクセスコントローラの利用権限を保有する役職を生成します。
AccessControllerPostBaseModel | AccessControllerPostMapper.select(String accessControllerId, String companyCd, String postCd) プライマリーキーで特定されるアクセスコントローラの利用権限を保有する役職の基本モデルを取得します。

AccessControllerPostBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | AccessControllerPostMapper.insert(AccessControllerPostBaseModel model) アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ挿入します。
void | AccessControllerPostMapper.update(AccessControllerPostBaseModel model) アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ更新します。
void | AccessControllerPostMapper.delete(AccessControllerPostBaseModel model) アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper の使用

jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel の使用

AccessControllerPublicGroupBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での AccessControllerPublicGroupBaseModel の使用

AccessControllerPublicGroupBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
AccessControllerPublicGroupBaseModel | AccessControllerPublicGroupMapper.create(String accessControllerId, String publicGroupSetCd, String publicGroupCd) プライマリキーに該当するアクセスコントローラの利用権限を保有するパブリックグループを生成します。
AccessControllerPublicGroupBaseModel | AccessControllerPublicGroupMapper.select(String accessControllerId, String publicGroupSetCd, String publicGroupCd) プライマリーキーで特定されるアクセスコントローラの利用権限を保有するパブリックグループの基本モデルを取得します。

AccessControllerPublicGroupBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | AccessControllerPublicGroupMapper.insert(AccessControllerPublicGroupBaseModel model) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ挿入します。
void | AccessControllerPublicGroupMapper.update(AccessControllerPublicGroupBaseModel model) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ更新します。
void | AccessControllerPublicGroupMapper.delete(AccessControllerPublicGroupBaseModel model) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper の使用

jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel の使用

AccessControllerRoleBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での AccessControllerRoleBaseModel の使用

AccessControllerRoleBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
AccessControllerRoleBaseModel | AccessControllerRoleMapper.create(String accessControllerId, String roleId) プライマリキーに該当するアクセスコントローラの利用権限を保有するロールを生成します。
AccessControllerRoleBaseModel | AccessControllerRoleMapper.select(String accessControllerId, String roleId) プライマリーキーで特定されるアクセスコントローラの利用権限を保有するロールの基本モデルを取得します。

AccessControllerRoleBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | AccessControllerRoleMapper.insert(AccessControllerRoleBaseModel model) アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ挿入します。
void | AccessControllerRoleMapper.update(AccessControllerRoleBaseModel model) アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ更新します。
void | AccessControllerRoleMapper.delete(AccessControllerRoleBaseModel model) アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper の使用

jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel の使用

AccountAttributeBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での AccountAttributeBaseModel の使用

AccountAttributeBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
AccountAttributeBaseModel | AccountAttributeMapper.create(String userId, String attributeName) プライマリキーに該当するアカウントが保有する属性を生成します。
AccountAttributeBaseModel | AccountAttributeMapper.select(String userId, String attributeName) プライマリーキーで特定されるアカウントが保有する属性の基本モデルを取得します。

AccountAttributeBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | AccountAttributeMapper.insert(AccountAttributeBaseModel model) アカウントが保有する属性の基本モデルを1つだけ挿入します。
void | AccountAttributeMapper.update(AccountAttributeBaseModel model) アカウントが保有する属性の基本モデルを1つだけ更新します。
void | AccountAttributeMapper.delete(AccountAttributeBaseModel model) アカウントが保有する属性の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper の使用

jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の使用

AccountBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での AccountBaseModel の使用

AccountBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
AccountBaseModel | AccountMapper.create(String userId) プライマリキーに該当するアカウントを生成します。
AccountBaseModel | AccountMapper.select(String userId) プライマリーキーで特定されるアカウントの基本モデルを取得します。

AccountBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | AccountMapper.insert(AccountBaseModel model) アカウントの基本モデルを1つだけ挿入します。
void | AccountMapper.update(AccountBaseModel model) アカウントの基本モデルを1つだけ更新します。
void | AccountMapper.delete(AccountBaseModel model) アカウントの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccountMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccountMapper の使用

jp.co.intra_mart.system.security.datastore.inf.AccountMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel の使用

AccountRoleBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での AccountRoleBaseModel の使用

AccountRoleBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
AccountRoleBaseModel | AccountRoleMapper.create(String userId, String roleId) プライマリキーに該当するアカウントが保有するロールを生成します。
AccountRoleBaseModel | AccountRoleMapper.select(String userId, String roleId) プライマリーキーで特定されるアカウントが保有するロールの基本モデルを取得します。

AccountRoleBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | AccountRoleMapper.insert(AccountRoleBaseModel model) アカウントが保有するロールの基本モデルを1つだけ挿入します。
void | AccountRoleMapper.update(AccountRoleBaseModel model) アカウントが保有するロールの基本モデルを1つだけ更新します。
void | AccountRoleMapper.delete(AccountRoleBaseModel model) アカウントが保有するロールの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper の使用

jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の使用

BatchBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での BatchBaseModel の使用

BatchBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
BatchBaseModel | BatchMapper.create(String batchId) プライマリキーに該当するバッチ情報を生成します。
BatchBaseModel | BatchMapper.select(String batchId) プライマリーキーで特定されるバッチ情報の基本モデルを取得します。

BatchBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | BatchMapper.insert(BatchBaseModel model) バッチ情報の基本モデルを1つだけ挿入します。
void | BatchMapper.update(BatchBaseModel model) バッチ情報の基本モデルを1つだけ更新します。
void | BatchMapper.delete(BatchBaseModel model) バッチ情報の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.BatchMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.BatchMapper の使用

jp.co.intra_mart.system.security.datastore.inf.BatchMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の使用

CalendarInfoBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での CalendarInfoBaseModel の使用

CalendarInfoBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
CalendarInfoBaseModel | CalendarInfoMapper.create(String calendarId, String dataId) プライマリキーに該当するカレンダーが保有するデータを生成します。
CalendarInfoBaseModel | CalendarInfoMapper.select(String calendarId, String dataId) プライマリーキーで特定されるカレンダーが保有するデータの基本モデルを取得します。

CalendarInfoBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | CalendarInfoMapper.insert(CalendarInfoBaseModel model) カレンダーが保有するデータの基本モデルを1つだけ挿入します。
void | CalendarInfoMapper.update(CalendarInfoBaseModel model) カレンダーが保有するデータの基本モデルを1つだけ更新します。
void | CalendarInfoMapper.delete(CalendarInfoBaseModel model) カレンダーが保有するデータの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.CalendarInfoInternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.CalendarInfoInternationalModel の使用

CalendarInfoInternationalModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での CalendarInfoInternationalModel の使用

CalendarInfoInternationalModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
 CalendarInfoInternationalModel CalendarInfoBaseModel.selectCalendarInfoInternationalModel(Locale locale)
指定された言語に該当するカレンダーが保有するデータの国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper の使用

jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の使用

jp.co.intra_mart.system.security.datastore.inf.DataStoreConst はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel の使用

FavoriteMenuBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での FavoriteMenuBaseModel の使用

FavoriteMenuBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
FavoriteMenuBaseModel | FavoriteMenuMapper.create(String userId, String menuId) プライマリキーに該当するアカウントが保有するメニューを生成します。
FavoriteMenuBaseModel | FavoriteMenuMapper.select(String userId, String menuId) プライマリーキーで特定されるアカウントが保有するメニューの基本モデルを取得します。

FavoriteMenuBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | FavoriteMenuMapper.insert(FavoriteMenuBaseModel model) アカウントが保有するメニューの基本モデルを1つだけ挿入します。
void | FavoriteMenuMapper.update(FavoriteMenuBaseModel model) アカウントが保有するメニューの基本モデルを1つだけ更新します。
void | FavoriteMenuMapper.delete(FavoriteMenuBaseModel model) アカウントが保有するメニューの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper の使用

jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel の使用

MenuArgumentBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での MenuArgumentBaseModel の使用

MenuArgumentBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
MenuArgumentBaseModel | MenuArgumentMapper.create(String menuId, String argumentName) プライマリキーに該当するメニューの保有する引数を生成します。
MenuArgumentBaseModel | MenuArgumentMapper.select(String menuId, String argumentName) プライマリーキーで特定されるメニューの保有する引数の基本モデルを取得します。

MenuArgumentBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | MenuArgumentMapper.insert(MenuArgumentBaseModel model) メニューの保有する引数の基本モデルを1つだけ挿入します。
void | MenuArgumentMapper.update(MenuArgumentBaseModel model) メニューの保有する引数の基本モデルを1つだけ更新します。
void | MenuArgumentMapper.delete(MenuArgumentBaseModel model) メニューの保有する引数の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper の使用

jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の使用

MenuBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での MenuBaseModel の使用

MenuBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
MenuBaseModel | MenuMapper.create(String menuId) プライマリキーに該当するメニュー情報を生成します。
MenuBaseModel | MenuMapper.select(String menuId) プライマリーキーで特定されるメニュー情報の基本モデルを取得します。

MenuBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | MenuMapper.insert(MenuBaseModel model) メニュー情報の基本モデルを1つだけ挿入します。
void | MenuMapper.update(MenuBaseModel model) メニュー情報の基本モデルを1つだけ更新します。
void | MenuMapper.delete(MenuBaseModel model) メニュー情報の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel の使用

MenuDepartmentBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での MenuDepartmentBaseModel の使用

MenuDepartmentBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
MenuDepartmentBaseModel | MenuDepartmentMapper.create(String menuId, String companyCd, String departmentCd) プライマリキーに該当するメニューの利用権限を保有する組織を生成します。
MenuDepartmentBaseModel | MenuDepartmentMapper.select(String menuId, String companyCd, String departmentCd) プライマリーキーで特定されるメニューの利用権限を保有する組織の基本モデルを取得します。

MenuDepartmentBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | MenuDepartmentMapper.insert(MenuDepartmentBaseModel model) メニューの利用権限を保有する組織の基本モデルを1つだけ挿入します。
void | MenuDepartmentMapper.update(MenuDepartmentBaseModel model) メニューの利用権限を保有する組織の基本モデルを1つだけ更新します。
void | MenuDepartmentMapper.delete(MenuDepartmentBaseModel model) メニューの利用権限を保有する組織の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper の使用

jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuInternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuInternationalModel の使用

MenuInternationalModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での MenuInternationalModel の使用

MenuInternationalModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
 MenuInternationalModel MenuBaseModel.selectMenuInternationalModel(Locale locale)
指定された言語に該当するメニュー情報の国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuMapper の使用

jp.co.intra_mart.system.security.datastore.inf.MenuMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel の使用

MenuPostBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での MenuPostBaseModel の使用

MenuPostBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
MenuPostBaseModel | MenuPostMapper.create(String menuId, String companyCd, String postCd) プライマリキーに該当するメニューの利用権限を保有する役職を生成します。
MenuPostBaseModel | MenuPostMapper.select(String menuId, String companyCd, String postCd) プライマリーキーで特定されるメニューの利用権限を保有する役職の基本モデルを取得します。

MenuPostBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | MenuPostMapper.insert(MenuPostBaseModel model) メニューの利用権限を保有する役職の基本モデルを1つだけ挿入します。
void | MenuPostMapper.update(MenuPostBaseModel model) メニューの利用権限を保有する役職の基本モデルを1つだけ更新します。
void | MenuPostMapper.delete(MenuPostBaseModel model) メニューの利用権限を保有する役職の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper の使用

jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel の使用

MenuPublicGroupBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での MenuPublicGroupBaseModel の使用

MenuPublicGroupBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
MenuPublicGroupBaseModel | MenuPublicGroupMapper.create(String menuId, String publicGroupSetCd, String publicGroupCd) プライマリキーに該当するメニューの利用権限を保有するパブリックグループを生成します。
MenuPublicGroupBaseModel | MenuPublicGroupMapper.select(String menuId, String publicGroupSetCd, String publicGroupCd) プライマリーキーで特定されるメニューの利用権限を保有するパブリックグループの基本モデルを取得します。

MenuPublicGroupBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | MenuPublicGroupMapper.insert(MenuPublicGroupBaseModel model) メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ挿入します。
void | MenuPublicGroupMapper.update(MenuPublicGroupBaseModel model) メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ更新します。
void | MenuPublicGroupMapper.delete(MenuPublicGroupBaseModel model) メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper の使用

jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel の使用

MenuRoleBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での MenuRoleBaseModel の使用

MenuRoleBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
MenuRoleBaseModel | MenuRoleMapper.create(String menuId, String roleId) プライマリキーに該当するメニューの利用権限を保有するロールを生成します。
MenuRoleBaseModel | MenuRoleMapper.select(String menuId, String roleId) プライマリーキーで特定されるメニューの利用権限を保有するロールの基本モデルを取得します。

MenuRoleBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | MenuRoleMapper.insert(MenuRoleBaseModel model) メニューの利用権限を保有するロールの基本モデルを1つだけ挿入します。
void | MenuRoleMapper.update(MenuRoleBaseModel model) メニューの利用権限を保有するロールの基本モデルを1つだけ更新します。
void | MenuRoleMapper.delete(MenuRoleBaseModel model) メニューの利用権限を保有するロールの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper の使用

jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel の使用

RoleBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での RoleBaseModel の使用

RoleBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
RoleBaseModel | RoleMapper.create(String roleId) プライマリキーに該当するロールを生成します。
RoleBaseModel | RoleMapper.select(String roleId) プライマリーキーで特定されるロールの基本モデルを取得します。

RoleBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | RoleMapper.insert(RoleBaseModel model) ロールの基本モデルを1つだけ挿入します。
void | RoleMapper.update(RoleBaseModel model) ロールの基本モデルを1つだけ更新します。
void | RoleMapper.delete(RoleBaseModel model) ロールの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel の使用

RoleInclusionBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での RoleInclusionBaseModel の使用

RoleInclusionBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
RoleInclusionBaseModel | RoleInclusionMapper.create(String parentRoleId, String childRoleId) プライマリキーに該当するロール内包を生成します。
RoleInclusionBaseModel | RoleInclusionMapper.select(String parentRoleId, String childRoleId) プライマリーキーで特定されるロール内包の基本モデルを取得します。

RoleInclusionBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | RoleInclusionMapper.insert(RoleInclusionBaseModel model) ロール内包の基本モデルを1つだけ挿入します。
void | RoleInclusionMapper.update(RoleInclusionBaseModel model) ロール内包の基本モデルを1つだけ更新します。
void | RoleInclusionMapper.delete(RoleInclusionBaseModel model) ロール内包の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper の使用

jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.RoleInternationalModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.RoleInternationalModel の使用

RoleInternationalModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での RoleInternationalModel の使用

RoleInternationalModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
 RoleInternationalModel RoleBaseModel.selectRoleInternationalModel(Locale locale)
指定された言語に該当するロールの国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.RoleMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.RoleMapper の使用

jp.co.intra_mart.system.security.datastore.inf.RoleMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel の使用

RoleSummaryBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での RoleSummaryBaseModel の使用

RoleSummaryBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
RoleSummaryBaseModel | RoleSummaryMapper.create(String roleId, String summaryRoleId) プライマリキーに該当するロールサマリを生成します。
RoleSummaryBaseModel | RoleSummaryMapper.select(String roleId, String summaryRoleId) プライマリーキーで特定されるロールサマリの基本モデルを取得します。

RoleSummaryBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | RoleSummaryMapper.insert(RoleSummaryBaseModel model) ロールサマリの基本モデルを1つだけ挿入します。
void | RoleSummaryMapper.update(RoleSummaryBaseModel model) ロールサマリの基本モデルを1つだけ更新します。
void | RoleSummaryMapper.delete(RoleSummaryBaseModel model) ロールサマリの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper の使用

jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AccessControllerBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccessControllerBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface AccessControllerBaseModel
extends BaseModel

アクセスコントローラ情報の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | ACCESS_CONTROLLER_ID アクセスコントローラID
static String | ACCESS_CONTROLLER_NAME アクセスコントローラ名
static String | NOTES 説明
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getAccessControllerId() アクセスコントローラIDを取得します。
String | getAccessControllerName() アクセスコントローラ名を取得します。
String | getNotes() 説明を取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
void | setAccessControllerName(String accessControllerName) アクセスコントローラ名を設定します。
void | setNotes(String notes) 説明を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ACCESS_CONTROLLER_ID

public static final String ACCESS_CONTROLLER_ID
アクセスコントローラID

関連項目:
定数フィールド値

ACCESS_CONTROLLER_NAME

public static final String ACCESS_CONTROLLER_NAME
アクセスコントローラ名

関連項目:
定数フィールド値

NOTES

public static final String NOTES
説明

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getAccessControllerId

public String getAccessControllerId()
                             throws AccessorException
アクセスコントローラIDを取得します。

戻り値:
アクセスコントローラID
例外:
AccessorException - データの取得に失敗した場合

getAccessControllerName

public String getAccessControllerName()
                               throws AccessorException
アクセスコントローラ名を取得します。

戻り値:
アクセスコントローラ名
例外:
AccessorException - データの取得に失敗した場合

setAccessControllerName

public void setAccessControllerName(String accessControllerName)
                             throws AccessorException
アクセスコントローラ名を設定します。

パラメータ:
accessControllerName - アクセスコントローラ名
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
説明を取得します。

戻り値:
説明
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
説明を設定します。

パラメータ:
notes - 説明
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccessControllerDepartmentBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccessControllerDepartmentBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface AccessControllerDepartmentBaseModel
extends BaseModel

アクセスコントローラの利用権限を保有する組織の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | ACCESS_CONTROLLER_ID アクセスコントローラID
static String | COMPANY_CD 会社CD
static String | DEPARTMENT_CD 組織CD
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getAccessControllerId() アクセスコントローラIDを取得します。
String | getCompanyCd() 会社CDを取得します。
String | getDepartmentCd() 組織CDを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ACCESS_CONTROLLER_ID

public static final String ACCESS_CONTROLLER_ID
アクセスコントローラID

関連項目:
定数フィールド値

COMPANY_CD

public static final String COMPANY_CD
会社CD

関連項目:
定数フィールド値

DEPARTMENT_CD

public static final String DEPARTMENT_CD
組織CD

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getAccessControllerId

public String getAccessControllerId()
                             throws AccessorException
アクセスコントローラIDを取得します。

戻り値:
アクセスコントローラID
例外:
AccessorException - データの取得に失敗した場合

getCompanyCd

public String getCompanyCd()
                    throws AccessorException
会社CDを取得します。

戻り値:
会社CD
例外:
AccessorException - データの取得に失敗した場合

getDepartmentCd

public String getDepartmentCd()
                       throws AccessorException
組織CDを取得します。

戻り値:
組織CD
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerDepartmentMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccessControllerDepartmentMapper

すべてのスーパーインタフェース:
Mapper
public interface AccessControllerDepartmentMapper
extends Mapper

アクセスコントローラの利用権限を保有する組織に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
AccessControllerDepartmentBaseModel | create(String accessControllerId, String companyCd, String departmentCd) プライマリキーに該当するアクセスコントローラの利用権限を保有する組織を生成します。
void | delete(AccessControllerDepartmentBaseModel model) アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ削除します。
void | delete(Collection models) アクセスコントローラの利用権限を保有する組織の基本モデルを複数削除します。
void | insert(AccessControllerDepartmentBaseModel model) アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ挿入します。
void | insert(Collection models) アクセスコントローラの利用権限を保有する組織の基本モデルを複数挿入します。
AccessControllerDepartmentBaseModel | select(String accessControllerId, String companyCd, String departmentCd) プライマリーキーで特定されるアクセスコントローラの利用権限を保有する組織の基本モデルを取得します。
void | update(AccessControllerDepartmentBaseModel model) アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ更新します。
void | update(Collection models) アクセスコントローラの利用権限を保有する組織の基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public AccessControllerDepartmentBaseModel create(String accessControllerId,
                                                  String companyCd,
                                                  String departmentCd)
                                           throws MapperException
プライマリキーに該当するアクセスコントローラの利用権限を保有する組織を生成します。

パラメータ:
accessControllerId - アクセスコントローラID
companyCd - 会社CD
departmentCd - 組織CD
戻り値:
プライマリキーに該当するアクセスコントローラの利用権限を保有する組織の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public AccessControllerDepartmentBaseModel select(String accessControllerId,
                                                  String companyCd,
                                                  String departmentCd)
                                           throws MapperException
プライマリーキーで特定されるアクセスコントローラの利用権限を保有する組織の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
accessControllerId - アクセスコントローラID
companyCd - 会社CD
departmentCd - 組織CD
戻り値:
アクセスコントローラの利用権限を保有する組織の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(AccessControllerDepartmentBaseModel model)
            throws MapperException
アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ挿入します。 引数に指定するアクセスコントローラの利用権限を保有する組織の基本モデルは同一の AccessControllerDepartmentMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するアクセスコントローラの利用権限を保有する組織の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
アクセスコントローラの利用権限を保有する組織の基本モデルを複数挿入します。 引数に指定するものは同一の AccessControllerDepartmentMapperの create(String,String,String) で生成されたアクセスコントローラの利用権限を保有する組織の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するアクセスコントローラの利用権限を保有する組織の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(AccessControllerDepartmentBaseModel model)
            throws MapperException
アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ更新します。 引数に指定するアクセスコントローラの利用権限を保有する組織の基本モデルは同一の AccessControllerDepartmentMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するアクセスコントローラの利用権限を保有する組織の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
アクセスコントローラの利用権限を保有する組織の基本モデルを複数更新します。 引数に指定するものは同一の AccessControllerDepartmentMapperの select 系メソッド から取得されたものかで生成されたアクセスコントローラの利用権限を保有する組織の基本モデルの集合である必要があります。

パラメータ:
models - 更新するアクセスコントローラの利用権限を保有する組織の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(AccessControllerDepartmentBaseModel model)
            throws MapperException
アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ削除します。 引数で指定されたアクセスコントローラの利用権限を保有する組織の基本モデルに該当するデータのすべての情報を削除します。引数に指定するアクセスコントローラの利用権限を保有する組織の基本モデルは同一の AccessControllerDepartmentMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するアクセスコントローラの利用権限を保有する組織の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
アクセスコントローラの利用権限を保有する組織の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するアクセスコントローラの利用権限を保有する組織の基本モデルは同一の AccessControllerDepartmentMapperの select 系メソッド から取得されたアクセスコントローラの利用権限を保有する組織の基本モデルの集合である必要があります。

パラメータ:
models - 削除するアクセスコントローラの利用権限を保有する組織の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccessControllerMapper

すべてのスーパーインタフェース:
Mapper
public interface AccessControllerMapper
extends Mapper

アクセスコントローラ情報に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
AccessControllerBaseModel | create(String accessControllerId) プライマリキーに該当するアクセスコントローラ情報を生成します。
void | delete(AccessControllerBaseModel model) アクセスコントローラ情報の基本モデルを1つだけ削除します。
void | delete(Collection models) アクセスコントローラ情報の基本モデルを複数削除します。
void | insert(AccessControllerBaseModel model) アクセスコントローラ情報の基本モデルを1つだけ挿入します。
void | insert(Collection models) アクセスコントローラ情報の基本モデルを複数挿入します。
AccessControllerBaseModel | select(String accessControllerId) プライマリーキーで特定されるアクセスコントローラ情報の基本モデルを取得します。
void | update(AccessControllerBaseModel model) アクセスコントローラ情報の基本モデルを1つだけ更新します。
void | update(Collection models) アクセスコントローラ情報の基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public AccessControllerBaseModel create(String accessControllerId)
                                 throws MapperException
プライマリキーに該当するアクセスコントローラ情報を生成します。

パラメータ:
accessControllerId - アクセスコントローラID
戻り値:
プライマリキーに該当するアクセスコントローラ情報の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public AccessControllerBaseModel select(String accessControllerId)
                                 throws MapperException
プライマリーキーで特定されるアクセスコントローラ情報の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
accessControllerId - アクセスコントローラID
戻り値:
アクセスコントローラ情報の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(AccessControllerBaseModel model)
            throws MapperException
アクセスコントローラ情報の基本モデルを1つだけ挿入します。 引数に指定するアクセスコントローラ情報の基本モデルは同一の AccessControllerMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入するアクセスコントローラ情報の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
アクセスコントローラ情報の基本モデルを複数挿入します。 引数に指定するものは同一の AccessControllerMapperの create(String) で生成されたアクセスコントローラ情報の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するアクセスコントローラ情報の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(AccessControllerBaseModel model)
            throws MapperException
アクセスコントローラ情報の基本モデルを1つだけ更新します。 引数に指定するアクセスコントローラ情報の基本モデルは同一の AccessControllerMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するアクセスコントローラ情報の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
アクセスコントローラ情報の基本モデルを複数更新します。 引数に指定するものは同一の AccessControllerMapperの select 系メソッド から取得されたものかで生成されたアクセスコントローラ情報の基本モデルの集合である必要があります。

パラメータ:
models - 更新するアクセスコントローラ情報の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(AccessControllerBaseModel model)
            throws MapperException
アクセスコントローラ情報の基本モデルを1つだけ削除します。 引数で指定されたアクセスコントローラ情報の基本モデルに該当するデータのすべての情報を削除します。引数に指定するアクセスコントローラ情報の基本モデルは同一の AccessControllerMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するアクセスコントローラ情報の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
アクセスコントローラ情報の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するアクセスコントローラ情報の基本モデルは同一の AccessControllerMapperの select 系メソッド から取得されたアクセスコントローラ情報の基本モデルの集合である必要があります。

パラメータ:
models - 削除するアクセスコントローラ情報の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerPostBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccessControllerPostBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface AccessControllerPostBaseModel
extends BaseModel

アクセスコントローラの利用権限を保有する役職の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | ACCESS_CONTROLLER_ID アクセスコントローラID
static String | COMPANY_CD 会社CD
static String | POST_CD 役職CD
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getAccessControllerId() アクセスコントローラIDを取得します。
String | getCompanyCd() 会社CDを取得します。
String | getPostCd() 役職CDを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ACCESS_CONTROLLER_ID

public static final String ACCESS_CONTROLLER_ID
アクセスコントローラID

関連項目:
定数フィールド値

COMPANY_CD

public static final String COMPANY_CD
会社CD

関連項目:
定数フィールド値

POST_CD

public static final String POST_CD
役職CD

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getAccessControllerId

public String getAccessControllerId()
                             throws AccessorException
アクセスコントローラIDを取得します。

戻り値:
アクセスコントローラID
例外:
AccessorException - データの取得に失敗した場合

getCompanyCd

public String getCompanyCd()
                    throws AccessorException
会社CDを取得します。

戻り値:
会社CD
例外:
AccessorException - データの取得に失敗した場合

getPostCd

public String getPostCd()
                 throws AccessorException
役職CDを取得します。

戻り値:
役職CD
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerPostMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccessControllerPostMapper

すべてのスーパーインタフェース:
Mapper
public interface AccessControllerPostMapper
extends Mapper

アクセスコントローラの利用権限を保有する役職に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
AccessControllerPostBaseModel | create(String accessControllerId, String companyCd, String postCd) プライマリキーに該当するアクセスコントローラの利用権限を保有する役職を生成します。
void | delete(AccessControllerPostBaseModel model) アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ削除します。
void | delete(Collection models) アクセスコントローラの利用権限を保有する役職の基本モデルを複数削除します。
void | insert(AccessControllerPostBaseModel model) アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ挿入します。
void | insert(Collection models) アクセスコントローラの利用権限を保有する役職の基本モデルを複数挿入します。
AccessControllerPostBaseModel | select(String accessControllerId, String companyCd, String postCd) プライマリーキーで特定されるアクセスコントローラの利用権限を保有する役職の基本モデルを取得します。
void | update(AccessControllerPostBaseModel model) アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ更新します。
void | update(Collection models) アクセスコントローラの利用権限を保有する役職の基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public AccessControllerPostBaseModel create(String accessControllerId,
                                            String companyCd,
                                            String postCd)
                                     throws MapperException
プライマリキーに該当するアクセスコントローラの利用権限を保有する役職を生成します。

パラメータ:
accessControllerId - アクセスコントローラID
companyCd - 会社CD
postCd - 役職CD
戻り値:
プライマリキーに該当するアクセスコントローラの利用権限を保有する役職の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public AccessControllerPostBaseModel select(String accessControllerId,
                                            String companyCd,
                                            String postCd)
                                     throws MapperException
プライマリーキーで特定されるアクセスコントローラの利用権限を保有する役職の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
accessControllerId - アクセスコントローラID
companyCd - 会社CD
postCd - 役職CD
戻り値:
アクセスコントローラの利用権限を保有する役職の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(AccessControllerPostBaseModel model)
            throws MapperException
アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ挿入します。 引数に指定するアクセスコントローラの利用権限を保有する役職の基本モデルは同一の AccessControllerPostMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するアクセスコントローラの利用権限を保有する役職の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
アクセスコントローラの利用権限を保有する役職の基本モデルを複数挿入します。 引数に指定するものは同一の AccessControllerPostMapperの create(String,String,String) で生成されたアクセスコントローラの利用権限を保有する役職の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するアクセスコントローラの利用権限を保有する役職の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(AccessControllerPostBaseModel model)
            throws MapperException
アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ更新します。 引数に指定するアクセスコントローラの利用権限を保有する役職の基本モデルは同一の AccessControllerPostMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するアクセスコントローラの利用権限を保有する役職の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
アクセスコントローラの利用権限を保有する役職の基本モデルを複数更新します。 引数に指定するものは同一の AccessControllerPostMapperの select 系メソッド から取得されたものかで生成されたアクセスコントローラの利用権限を保有する役職の基本モデルの集合である必要があります。

パラメータ:
models - 更新するアクセスコントローラの利用権限を保有する役職の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(AccessControllerPostBaseModel model)
            throws MapperException
アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ削除します。 引数で指定されたアクセスコントローラの利用権限を保有する役職の基本モデルに該当するデータのすべての情報を削除します。引数に指定するアクセスコントローラの利用権限を保有する役職の基本モデルは同一の AccessControllerPostMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するアクセスコントローラの利用権限を保有する役職の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
アクセスコントローラの利用権限を保有する役職の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するアクセスコントローラの利用権限を保有する役職の基本モデルは同一の AccessControllerPostMapperの select 系メソッド から取得されたアクセスコントローラの利用権限を保有する役職の基本モデルの集合である必要があります。

パラメータ:
models - 削除するアクセスコントローラの利用権限を保有する役職の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerPublicGroupBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccessControllerPublicGroupBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface AccessControllerPublicGroupBaseModel
extends BaseModel

アクセスコントローラの利用権限を保有するパブリックグループの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | ACCESS_CONTROLLER_ID アクセスコントローラID
static String | PUBLIC_GROUP_CD グルーピングCD
static String | PUBLIC_GROUP_SET_CD グループセットCD
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getAccessControllerId() アクセスコントローラIDを取得します。
String | getPublicGroupCd() グルーピングCDを取得します。
String | getPublicGroupSetCd() グループセットCDを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ACCESS_CONTROLLER_ID

public static final String ACCESS_CONTROLLER_ID
アクセスコントローラID

関連項目:
定数フィールド値

PUBLIC_GROUP_SET_CD

public static final String PUBLIC_GROUP_SET_CD
グループセットCD

関連項目:
定数フィールド値

PUBLIC_GROUP_CD

public static final String PUBLIC_GROUP_CD
グルーピングCD

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getAccessControllerId

public String getAccessControllerId()
                             throws AccessorException
アクセスコントローラIDを取得します。

戻り値:
アクセスコントローラID
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupSetCd

public String getPublicGroupSetCd()
                           throws AccessorException
グループセットCDを取得します。

戻り値:
グループセットCD
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupCd

public String getPublicGroupCd()
                        throws AccessorException
グルーピングCDを取得します。

戻り値:
グルーピングCD
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerPublicGroupMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccessControllerPublicGroupMapper

すべてのスーパーインタフェース:
Mapper
public interface AccessControllerPublicGroupMapper
extends Mapper

アクセスコントローラの利用権限を保有するパブリックグループに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
AccessControllerPublicGroupBaseModel | create(String accessControllerId, String publicGroupSetCd, String publicGroupCd) プライマリキーに該当するアクセスコントローラの利用権限を保有するパブリックグループを生成します。
void | delete(AccessControllerPublicGroupBaseModel model) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ削除します。
void | delete(Collection models) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを複数削除します。
void | insert(AccessControllerPublicGroupBaseModel model) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ挿入します。
void | insert(Collection models) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを複数挿入します。
AccessControllerPublicGroupBaseModel | select(String accessControllerId, String publicGroupSetCd, String publicGroupCd) プライマリーキーで特定されるアクセスコントローラの利用権限を保有するパブリックグループの基本モデルを取得します。
void | update(AccessControllerPublicGroupBaseModel model) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ更新します。
void | update(Collection models) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public AccessControllerPublicGroupBaseModel create(String accessControllerId,
                                                   String publicGroupSetCd,
                                                   String publicGroupCd)
                                            throws MapperException
プライマリキーに該当するアクセスコントローラの利用権限を保有するパブリックグループを生成します。

パラメータ:
accessControllerId - アクセスコントローラID
publicGroupSetCd - グループセットCD
publicGroupCd - グルーピングCD
戻り値:
プライマリキーに該当するアクセスコントローラの利用権限を保有するパブリックグループの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public AccessControllerPublicGroupBaseModel select(String accessControllerId,
                                                   String publicGroupSetCd,
                                                   String publicGroupCd)
                                            throws MapperException
プライマリーキーで特定されるアクセスコントローラの利用権限を保有するパブリックグループの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
accessControllerId - アクセスコントローラID
publicGroupSetCd - グループセットCD
publicGroupCd - グルーピングCD
戻り値:
アクセスコントローラの利用権限を保有するパブリックグループの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(AccessControllerPublicGroupBaseModel model)
            throws MapperException
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ挿入します。 引数に指定するアクセスコントローラの利用権限を保有するパブリックグループの基本モデルは同一の AccessControllerPublicGroupMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するアクセスコントローラの利用権限を保有するパブリックグループの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを複数挿入します。 引数に指定するものは同一の AccessControllerPublicGroupMapperの create(String,String,String) で生成されたアクセスコントローラの利用権限を保有するパブリックグループの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するアクセスコントローラの利用権限を保有するパブリックグループの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(AccessControllerPublicGroupBaseModel model)
            throws MapperException
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ更新します。 引数に指定するアクセスコントローラの利用権限を保有するパブリックグループの基本モデルは同一の AccessControllerPublicGroupMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するアクセスコントローラの利用権限を保有するパブリックグループの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを複数更新します。 引数に指定するものは同一の AccessControllerPublicGroupMapperの select 系メソッド から取得されたものかで生成されたアクセスコントローラの利用権限を保有するパブリックグループの基本モデルの集合である必要があります。

パラメータ:
models - 更新するアクセスコントローラの利用権限を保有するパブリックグループの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(AccessControllerPublicGroupBaseModel model)
            throws MapperException
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ削除します。 引数で指定されたアクセスコントローラの利用権限を保有するパブリックグループの基本モデルに該当するデータのすべての情報を削除します。引数に指定するアクセスコントローラの利用権限を保有するパブリックグループの基本モデルは同一の AccessControllerPublicGroupMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するアクセスコントローラの利用権限を保有するパブリックグループの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するアクセスコントローラの利用権限を保有するパブリックグループの基本モデルは同一の AccessControllerPublicGroupMapperの select 系メソッド から取得されたアクセスコントローラの利用権限を保有するパブリックグループの基本モデルの集合である必要があります。

パラメータ:
models - 削除するアクセスコントローラの利用権限を保有するパブリックグループの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerRoleBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccessControllerRoleBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface AccessControllerRoleBaseModel
extends BaseModel

アクセスコントローラの利用権限を保有するロールの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | ACCESS_CONTROLLER_ID アクセスコントローラID
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | ROLE_ID ロールCD
メソッドの概要
String | getAccessControllerId() アクセスコントローラIDを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getRoleId() ロールCDを取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ACCESS_CONTROLLER_ID

public static final String ACCESS_CONTROLLER_ID
アクセスコントローラID

関連項目:
定数フィールド値

ROLE_ID

public static final String ROLE_ID
ロールCD

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getAccessControllerId

public String getAccessControllerId()
                             throws AccessorException
アクセスコントローラIDを取得します。

戻り値:
アクセスコントローラID
例外:
AccessorException - データの取得に失敗した場合

getRoleId

public String getRoleId()
                 throws AccessorException
ロールCDを取得します。

戻り値:
ロールCD
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerRoleMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccessControllerRoleMapper

すべてのスーパーインタフェース:
Mapper
public interface AccessControllerRoleMapper
extends Mapper

アクセスコントローラの利用権限を保有するロールに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
AccessControllerRoleBaseModel | create(String accessControllerId, String roleId) プライマリキーに該当するアクセスコントローラの利用権限を保有するロールを生成します。
void | delete(AccessControllerRoleBaseModel model) アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ削除します。
void | delete(Collection models) アクセスコントローラの利用権限を保有するロールの基本モデルを複数削除します。
void | insert(AccessControllerRoleBaseModel model) アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ挿入します。
void | insert(Collection models) アクセスコントローラの利用権限を保有するロールの基本モデルを複数挿入します。
AccessControllerRoleBaseModel | select(String accessControllerId, String roleId) プライマリーキーで特定されるアクセスコントローラの利用権限を保有するロールの基本モデルを取得します。
void | update(AccessControllerRoleBaseModel model) アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ更新します。
void | update(Collection models) アクセスコントローラの利用権限を保有するロールの基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public AccessControllerRoleBaseModel create(String accessControllerId,
                                            String roleId)
                                     throws MapperException
プライマリキーに該当するアクセスコントローラの利用権限を保有するロールを生成します。

パラメータ:
accessControllerId - アクセスコントローラID
roleId - ロールCD
戻り値:
プライマリキーに該当するアクセスコントローラの利用権限を保有するロールの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public AccessControllerRoleBaseModel select(String accessControllerId,
                                            String roleId)
                                     throws MapperException
プライマリーキーで特定されるアクセスコントローラの利用権限を保有するロールの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
accessControllerId - アクセスコントローラID
roleId - ロールCD
戻り値:
アクセスコントローラの利用権限を保有するロールの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(AccessControllerRoleBaseModel model)
            throws MapperException
アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ挿入します。 引数に指定するアクセスコントローラの利用権限を保有するロールの基本モデルは同一の AccessControllerRoleMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するアクセスコントローラの利用権限を保有するロールの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
アクセスコントローラの利用権限を保有するロールの基本モデルを複数挿入します。 引数に指定するものは同一の AccessControllerRoleMapperの create(String,String) で生成されたアクセスコントローラの利用権限を保有するロールの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するアクセスコントローラの利用権限を保有するロールの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(AccessControllerRoleBaseModel model)
            throws MapperException
アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ更新します。 引数に指定するアクセスコントローラの利用権限を保有するロールの基本モデルは同一の AccessControllerRoleMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するアクセスコントローラの利用権限を保有するロールの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
アクセスコントローラの利用権限を保有するロールの基本モデルを複数更新します。 引数に指定するものは同一の AccessControllerRoleMapperの select 系メソッド から取得されたものかで生成されたアクセスコントローラの利用権限を保有するロールの基本モデルの集合である必要があります。

パラメータ:
models - 更新するアクセスコントローラの利用権限を保有するロールの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(AccessControllerRoleBaseModel model)
            throws MapperException
アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ削除します。 引数で指定されたアクセスコントローラの利用権限を保有するロールの基本モデルに該当するデータのすべての情報を削除します。引数に指定するアクセスコントローラの利用権限を保有するロールの基本モデルは同一の AccessControllerRoleMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するアクセスコントローラの利用権限を保有するロールの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
アクセスコントローラの利用権限を保有するロールの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するアクセスコントローラの利用権限を保有するロールの基本モデルは同一の AccessControllerRoleMapperの select 系メソッド から取得されたアクセスコントローラの利用権限を保有するロールの基本モデルの集合である必要があります。

パラメータ:
models - 削除するアクセスコントローラの利用権限を保有するロールの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountAttributeBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccountAttributeBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface AccountAttributeBaseModel
extends BaseModel

アカウントが保有する属性の基本モデルです。

導入されたバージョン:
5.2

フィールドの概要
static String | ATTRIBUTE_NAME 属性キー
static String | ATTRIBUTE_VALUE 属性値
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | USER_ID ユーザID
メソッドの概要
String | getAttributeName() 属性キーを取得します。
String | getAttributeValue() 属性値を取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getUserId() ユーザIDを取得します。
void | setAttributeValue(String attributeValue) 属性値を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

USER_ID

public static final String USER_ID
ユーザID

関連項目:
定数フィールド値

ATTRIBUTE_NAME

public static final String ATTRIBUTE_NAME
属性キー

関連項目:
定数フィールド値

ATTRIBUTE_VALUE

public static final String ATTRIBUTE_VALUE
属性値

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getUserId

public String getUserId()
                 throws AccessorException
ユーザIDを取得します。

戻り値:
ユーザID
例外:
AccessorException - データの取得に失敗した場合

getAttributeName

public String getAttributeName()
                        throws AccessorException
属性キーを取得します。

戻り値:
属性キー
例外:
AccessorException - データの取得に失敗した場合

getAttributeValue

public String getAttributeValue()
                         throws AccessorException
属性値を取得します。

戻り値:
属性値
例外:
AccessorException - データの取得に失敗した場合

setAttributeValue

public void setAttributeValue(String attributeValue)
                       throws AccessorException
属性値を設定します。

パラメータ:
attributeValue - 属性値
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountAttributeMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccountAttributeMapper

すべてのスーパーインタフェース:
Mapper
public interface AccountAttributeMapper
extends Mapper

アカウントが保有する属性に関連するマッパです。

導入されたバージョン:
5.2

メソッドの概要
AccountAttributeBaseModel | create(String userId, String attributeName) プライマリキーに該当するアカウントが保有する属性を生成します。
void | delete(AccountAttributeBaseModel model) アカウントが保有する属性の基本モデルを1つだけ削除します。
void | delete(Collection models) アカウントが保有する属性の基本モデルを複数削除します。
void | insert(AccountAttributeBaseModel model) アカウントが保有する属性の基本モデルを1つだけ挿入します。
void | insert(Collection models) アカウントが保有する属性の基本モデルを複数挿入します。
AccountAttributeBaseModel | select(String userId, String attributeName) プライマリーキーで特定されるアカウントが保有する属性の基本モデルを取得します。
void | update(AccountAttributeBaseModel model) アカウントが保有する属性の基本モデルを1つだけ更新します。
void | update(Collection models) アカウントが保有する属性の基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public AccountAttributeBaseModel create(String userId,
                                        String attributeName)
                                 throws MapperException
プライマリキーに該当するアカウントが保有する属性を生成します。

パラメータ:
userId - ユーザID
attributeName - 属性キー
戻り値:
プライマリキーに該当するアカウントが保有する属性の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public AccountAttributeBaseModel select(String userId,
                                        String attributeName)
                                 throws MapperException
プライマリーキーで特定されるアカウントが保有する属性の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
userId - ユーザID
attributeName - 属性キー
戻り値:
アカウントが保有する属性の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(AccountAttributeBaseModel model)
            throws MapperException
アカウントが保有する属性の基本モデルを1つだけ挿入します。 引数に指定するアカウントが保有する属性の基本モデルは同一の AccountAttributeMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するアカウントが保有する属性の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
アカウントが保有する属性の基本モデルを複数挿入します。 引数に指定するものは同一の AccountAttributeMapperの create(String,String) で生成されたアカウントが保有する属性の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するアカウントが保有する属性の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(AccountAttributeBaseModel model)
            throws MapperException
アカウントが保有する属性の基本モデルを1つだけ更新します。 引数に指定するアカウントが保有する属性の基本モデルは同一の AccountAttributeMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するアカウントが保有する属性の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
アカウントが保有する属性の基本モデルを複数更新します。 引数に指定するものは同一の AccountAttributeMapperの select 系メソッド から取得されたものかで生成されたアカウントが保有する属性の基本モデルの集合である必要があります。

パラメータ:
models - 更新するアカウントが保有する属性の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(AccountAttributeBaseModel model)
            throws MapperException
アカウントが保有する属性の基本モデルを1つだけ削除します。 引数で指定されたアカウントが保有する属性の基本モデルに該当するデータのすべての情報を削除します。引数に指定するアカウントが保有する属性の基本モデルは同一の AccountAttributeMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するアカウントが保有する属性の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
アカウントが保有する属性の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するアカウントが保有する属性の基本モデルは同一の AccountAttributeMapperの select 系メソッド から取得されたアカウントが保有する属性の基本モデルの集合である必要があります。

パラメータ:
models - 削除するアカウントが保有する属性の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccountBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface AccountBaseModel
extends BaseModel

アカウントの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | COLOR_PATTERN_ID ページカラーパターン
static String | ENCODING エンコーディング
static String | GO_OUT 外出フラグ
static String | LOCALE ロケール
static String | LOCK_DATE アカウントロック日付
static String | LOGIN_FAILURE_COUNT ログイン失敗回数
static String | MOBILE_PASSWORD モバイル用パスワード
static String | NOTES 説明
static String | PAGE_PATTERN_ID メインページパターン
static String | PASSWORD パスワード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | USER_ID ユーザID
static String | VALID_END_DATE 有効終了日
static String | VALID_START_DATE 有効開始日
メソッドの概要
String | getColorPatternId() ページカラーパターンを取得します。
String | getEncoding() エンコーディングを取得します。
String | getGoOut() 外出フラグを取得します。
String | getLocale() ロケールを取得します。
String | getLockDate() アカウントロック日付を取得します。
int | getLoginFailureCount() ログイン失敗回数を取得します。
String | getMobilePassword() モバイル用パスワードを取得します。
String | getNotes() 説明を取得します。
String | getPagePatternId() メインページパターンを取得します。
String | getPassword() パスワードを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getUserId() ユーザIDを取得します。
String | getValidEndDate() 有効終了日を取得します。
String | getValidStartDate() 有効開始日を取得します。
void | setColorPatternId(String colorPatternId) ページカラーパターンを設定します。
void | setEncoding(String encoding) エンコーディングを設定します。
void | setGoOut(String goOut) 外出フラグを設定します。
void | setLocale(String locale) ロケールを設定します。
void | setLockDate(String lockDate) アカウントロック日付を設定します。
void | setLoginFailureCount(int loginFailureCount) ログイン失敗回数を設定します。
void | setMobilePassword(String mobilePassword) モバイル用パスワードを設定します。
void | setNotes(String notes) 説明を設定します。
void | setPagePatternId(String pagePatternId) メインページパターンを設定します。
void | setPassword(String password) パスワードを設定します。
void | setValidEndDate(String validEndDate) 有効終了日を設定します。
void | setValidStartDate(String validStartDate) 有効開始日を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

USER_ID

public static final String USER_ID
ユーザID

関連項目:
定数フィールド値

LOCALE

public static final String LOCALE
ロケール

関連項目:
定数フィールド値

ENCODING

public static final String ENCODING
エンコーディング

関連項目:
定数フィールド値

PASSWORD

public static final String PASSWORD
パスワード

関連項目:
定数フィールド値

MOBILE_PASSWORD

public static final String MOBILE_PASSWORD
モバイル用パスワード

関連項目:
定数フィールド値

NOTES

public static final String NOTES
説明

関連項目:
定数フィールド値

VALID_START_DATE

public static final String VALID_START_DATE
有効開始日

関連項目:
定数フィールド値

VALID_END_DATE

public static final String VALID_END_DATE
有効終了日

関連項目:
定数フィールド値

GO_OUT

public static final String GO_OUT
外出フラグ

関連項目:
定数フィールド値

LOCK_DATE

public static final String LOCK_DATE
アカウントロック日付

関連項目:
定数フィールド値

LOGIN_FAILURE_COUNT

public static final String LOGIN_FAILURE_COUNT
ログイン失敗回数

関連項目:
定数フィールド値

PAGE_PATTERN_ID

public static final String PAGE_PATTERN_ID
メインページパターン

関連項目:
定数フィールド値

COLOR_PATTERN_ID

public static final String COLOR_PATTERN_ID
ページカラーパターン

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getUserId

public String getUserId()
                 throws AccessorException
ユーザIDを取得します。

戻り値:
ユーザID
例外:
AccessorException - データの取得に失敗した場合

getLocale

public String getLocale()
                 throws AccessorException
ロケールを取得します。

戻り値:
ロケール
例外:
AccessorException - データの取得に失敗した場合

setLocale

public void setLocale(String locale)
               throws AccessorException
ロケールを設定します。

パラメータ:
locale - ロケール
例外:
AccessorException - データの設定に失敗した場合

getEncoding

public String getEncoding()
                   throws AccessorException
エンコーディングを取得します。

戻り値:
エンコーディング
例外:
AccessorException - データの取得に失敗した場合

setEncoding

public void setEncoding(String encoding)
                 throws AccessorException
エンコーディングを設定します。

パラメータ:
encoding - エンコーディング
例外:
AccessorException - データの設定に失敗した場合

getPassword

public String getPassword()
                   throws AccessorException
パスワードを取得します。

戻り値:
パスワード
例外:
AccessorException - データの取得に失敗した場合

setPassword

public void setPassword(String password)
                 throws AccessorException
パスワードを設定します。

パラメータ:
password - パスワード
例外:
AccessorException - データの設定に失敗した場合

getMobilePassword

public String getMobilePassword()
                         throws AccessorException
モバイル用パスワードを取得します。

戻り値:
モバイル用パスワード
例外:
AccessorException - データの取得に失敗した場合

setMobilePassword

public void setMobilePassword(String mobilePassword)
                       throws AccessorException
モバイル用パスワードを設定します。

パラメータ:
mobilePassword - モバイル用パスワード
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
説明を取得します。

戻り値:
説明
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
説明を設定します。

パラメータ:
notes - 説明
例外:
AccessorException - データの設定に失敗した場合

getValidStartDate

public String getValidStartDate()
                         throws AccessorException
有効開始日を取得します。

戻り値:
有効開始日
例外:
AccessorException - データの取得に失敗した場合

setValidStartDate

public void setValidStartDate(String validStartDate)
                       throws AccessorException
有効開始日を設定します。

パラメータ:
validStartDate - 有効開始日
例外:
AccessorException - データの設定に失敗した場合

getValidEndDate

public String getValidEndDate()
                       throws AccessorException
有効終了日を取得します。

戻り値:
有効終了日
例外:
AccessorException - データの取得に失敗した場合

setValidEndDate

public void setValidEndDate(String validEndDate)
                     throws AccessorException
有効終了日を設定します。

パラメータ:
validEndDate - 有効終了日
例外:
AccessorException - データの設定に失敗した場合

getGoOut

public String getGoOut()
                throws AccessorException
外出フラグを取得します。

戻り値:
外出フラグ
例外:
AccessorException - データの取得に失敗した場合

setGoOut

public void setGoOut(String goOut)
              throws AccessorException
外出フラグを設定します。

パラメータ:
goOut - 外出フラグ
例外:
AccessorException - データの設定に失敗した場合

getLockDate

public String getLockDate()
                   throws AccessorException
アカウントロック日付を取得します。

戻り値:
アカウントロック日付
例外:
AccessorException - データの取得に失敗した場合

setLockDate

public void setLockDate(String lockDate)
                 throws AccessorException
アカウントロック日付を設定します。

パラメータ:
lockDate - アカウントロック日付
例外:
AccessorException - データの設定に失敗した場合

getLoginFailureCount

public int getLoginFailureCount()
                         throws AccessorException
ログイン失敗回数を取得します。

戻り値:
ログイン失敗回数
例外:
AccessorException - データの取得に失敗した場合

setLoginFailureCount

public void setLoginFailureCount(int loginFailureCount)
                          throws AccessorException
ログイン失敗回数を設定します。

パラメータ:
loginFailureCount - ログイン失敗回数
例外:
AccessorException - データの設定に失敗した場合

getPagePatternId

public String getPagePatternId()
                        throws AccessorException
メインページパターンを取得します。

戻り値:
メインページパターン
例外:
AccessorException - データの取得に失敗した場合

setPagePatternId

public void setPagePatternId(String pagePatternId)
                      throws AccessorException
メインページパターンを設定します。

パラメータ:
pagePatternId - メインページパターン
例外:
AccessorException - データの設定に失敗した場合

getColorPatternId

public String getColorPatternId()
                         throws AccessorException
ページカラーパターンを取得します。

戻り値:
ページカラーパターン
例外:
AccessorException - データの取得に失敗した場合

setColorPatternId

public void setColorPatternId(String colorPatternId)
                       throws AccessorException
ページカラーパターンを設定します。

パラメータ:
colorPatternId - ページカラーパターン
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccountMapper

すべてのスーパーインタフェース:
Mapper
public interface AccountMapper
extends Mapper

アカウントに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
AccountBaseModel | create(String userId) プライマリキーに該当するアカウントを生成します。
void | delete(AccountBaseModel model) アカウントの基本モデルを1つだけ削除します。
void | delete(Collection models) アカウントの基本モデルを複数削除します。
void | insert(AccountBaseModel model) アカウントの基本モデルを1つだけ挿入します。
void | insert(Collection models) アカウントの基本モデルを複数挿入します。
AccountBaseModel | select(String userId) プライマリーキーで特定されるアカウントの基本モデルを取得します。
void | update(AccountBaseModel model) アカウントの基本モデルを1つだけ更新します。
void | update(Collection models) アカウントの基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public AccountBaseModel create(String userId)
                        throws MapperException
プライマリキーに該当するアカウントを生成します。

パラメータ:
userId - ユーザID
戻り値:
プライマリキーに該当するアカウントの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public AccountBaseModel select(String userId)
                        throws MapperException
プライマリーキーで特定されるアカウントの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
userId - ユーザID
戻り値:
アカウントの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(AccountBaseModel model)
            throws MapperException
アカウントの基本モデルを1つだけ挿入します。 引数に指定するアカウントの基本モデルは同一の AccountMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入するアカウントの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
アカウントの基本モデルを複数挿入します。 引数に指定するものは同一の AccountMapperの create(String) で生成されたアカウントの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するアカウントの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(AccountBaseModel model)
            throws MapperException
アカウントの基本モデルを1つだけ更新します。 引数に指定するアカウントの基本モデルは同一の AccountMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するアカウントの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
アカウントの基本モデルを複数更新します。 引数に指定するものは同一の AccountMapperの select 系メソッド から取得されたものかで生成されたアカウントの基本モデルの集合である必要があります。

パラメータ:
models - 更新するアカウントの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(AccountBaseModel model)
            throws MapperException
アカウントの基本モデルを1つだけ削除します。 引数で指定されたアカウントの基本モデルに該当するデータのすべての情報を削除します。引数に指定するアカウントの基本モデルは同一の AccountMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するアカウントの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
アカウントの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するアカウントの基本モデルは同一の AccountMapperの select 系メソッド から取得されたアカウントの基本モデルの集合である必要があります。

パラメータ:
models - 削除するアカウントの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountRoleBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccountRoleBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface AccountRoleBaseModel
extends BaseModel

アカウントが保有するロールの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | ROLE_ID メニューID
static String | USER_ID ユーザID
static String | VALID_END_DATE 有効終了日
static String | VALID_START_DATE 有効開始日
メソッドの概要
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getRoleId() メニューIDを取得します。
String | getUserId() ユーザIDを取得します。
String | getValidEndDate() 有効終了日を取得します。
String | getValidStartDate() 有効開始日を取得します。
void | setValidEndDate(String validEndDate) 有効終了日を設定します。
void | setValidStartDate(String validStartDate) 有効開始日を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

USER_ID

public static final String USER_ID
ユーザID

関連項目:
定数フィールド値

ROLE_ID

public static final String ROLE_ID
メニューID

関連項目:
定数フィールド値

VALID_START_DATE

public static final String VALID_START_DATE
有効開始日

関連項目:
定数フィールド値

VALID_END_DATE

public static final String VALID_END_DATE
有効終了日

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getUserId

public String getUserId()
                 throws AccessorException
ユーザIDを取得します。

戻り値:
ユーザID
例外:
AccessorException - データの取得に失敗した場合

getRoleId

public String getRoleId()
                 throws AccessorException
メニューIDを取得します。

戻り値:
メニューID
例外:
AccessorException - データの取得に失敗した場合

getValidStartDate

public String getValidStartDate()
                         throws AccessorException
有効開始日を取得します。

戻り値:
有効開始日
例外:
AccessorException - データの取得に失敗した場合

setValidStartDate

public void setValidStartDate(String validStartDate)
                       throws AccessorException
有効開始日を設定します。

パラメータ:
validStartDate - 有効開始日
例外:
AccessorException - データの設定に失敗した場合

getValidEndDate

public String getValidEndDate()
                       throws AccessorException
有効終了日を取得します。

戻り値:
有効終了日
例外:
AccessorException - データの取得に失敗した場合

setValidEndDate

public void setValidEndDate(String validEndDate)
                     throws AccessorException
有効終了日を設定します。

パラメータ:
validEndDate - 有効終了日
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountRoleMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccountRoleMapper

すべてのスーパーインタフェース:
Mapper
public interface AccountRoleMapper
extends Mapper

アカウントが保有するロールに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
AccountRoleBaseModel | create(String userId, String roleId) プライマリキーに該当するアカウントが保有するロールを生成します。
void | delete(AccountRoleBaseModel model) アカウントが保有するロールの基本モデルを1つだけ削除します。
void | delete(Collection models) アカウントが保有するロールの基本モデルを複数削除します。
void | insert(AccountRoleBaseModel model) アカウントが保有するロールの基本モデルを1つだけ挿入します。
void | insert(Collection models) アカウントが保有するロールの基本モデルを複数挿入します。
AccountRoleBaseModel | select(String userId, String roleId) プライマリーキーで特定されるアカウントが保有するロールの基本モデルを取得します。
void | update(AccountRoleBaseModel model) アカウントが保有するロールの基本モデルを1つだけ更新します。
void | update(Collection models) アカウントが保有するロールの基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public AccountRoleBaseModel create(String userId,
                                   String roleId)
                            throws MapperException
プライマリキーに該当するアカウントが保有するロールを生成します。

パラメータ:
userId - ユーザID
roleId - メニューID
戻り値:
プライマリキーに該当するアカウントが保有するロールの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public AccountRoleBaseModel select(String userId,
                                   String roleId)
                            throws MapperException
プライマリーキーで特定されるアカウントが保有するロールの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
userId - ユーザID
roleId - メニューID
戻り値:
アカウントが保有するロールの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(AccountRoleBaseModel model)
            throws MapperException
アカウントが保有するロールの基本モデルを1つだけ挿入します。 引数に指定するアカウントが保有するロールの基本モデルは同一の AccountRoleMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するアカウントが保有するロールの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
アカウントが保有するロールの基本モデルを複数挿入します。 引数に指定するものは同一の AccountRoleMapperの create(String,String) で生成されたアカウントが保有するロールの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するアカウントが保有するロールの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(AccountRoleBaseModel model)
            throws MapperException
アカウントが保有するロールの基本モデルを1つだけ更新します。 引数に指定するアカウントが保有するロールの基本モデルは同一の AccountRoleMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するアカウントが保有するロールの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
アカウントが保有するロールの基本モデルを複数更新します。 引数に指定するものは同一の AccountRoleMapperの select 系メソッド から取得されたものかで生成されたアカウントが保有するロールの基本モデルの集合である必要があります。

パラメータ:
models - 更新するアカウントが保有するロールの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(AccountRoleBaseModel model)
            throws MapperException
アカウントが保有するロールの基本モデルを1つだけ削除します。 引数で指定されたアカウントが保有するロールの基本モデルに該当するデータのすべての情報を削除します。引数に指定するアカウントが保有するロールの基本モデルは同一の AccountRoleMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するアカウントが保有するロールの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
アカウントが保有するロールの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するアカウントが保有するロールの基本モデルは同一の AccountRoleMapperの select 系メソッド から取得されたアカウントが保有するロールの基本モデルの集合である必要があります。

パラメータ:
models - 削除するアカウントが保有するロールの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BatchBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース BatchBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface BatchBaseModel
extends BaseModel

バッチ情報の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | BATCH_ID バッチID
static String | BATCH_NAME バッチ名
static String | PROGRAM_LANGUAGE 実行プログラム言語
static String | PROGRAM_PATH 実行プログラムパス
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | RUN_DAY 実行日
static String | RUN_DAY_WEEK 実行曜日
static String | RUN_HOUR 実行時
static String | RUN_MINUTE 実行分
static String | RUN_MONTH 実行月
static String | RUN_SECOND 実行秒
static String | RUN_YEAR 実行年
static String | VALID_FLG 有効フラグ
メソッドの概要
String | getBatchId() バッチIDを取得します。
String | getBatchName() バッチ名を取得します。
String | getProgramLanguage() 実行プログラム言語を取得します。
String | getProgramPath() 実行プログラムパスを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getRunDay() 実行日を取得します。
int | getRunDayWeek() 実行曜日を取得します。
int | getRunHour() 実行時を取得します。
int | getRunMinute() 実行分を取得します。
int | getRunMonth() 実行月を取得します。
int | getRunSecond() 実行秒を取得します。
int | getRunYear() 実行年を取得します。
String | getValidFlg() 有効フラグを取得します。
void | setBatchName(String batchName) バッチ名を設定します。
void | setProgramLanguage(String programLanguage) 実行プログラム言語を設定します。
void | setProgramPath(String programPath) 実行プログラムパスを設定します。
void | setRunDay(int runDay) 実行日を設定します。
void | setRunDayWeek(int runDayWeek) 実行曜日を設定します。
void | setRunHour(int runHour) 実行時を設定します。
void | setRunMinute(int runMinute) 実行分を設定します。
void | setRunMonth(int runMonth) 実行月を設定します。
void | setRunSecond(int runSecond) 実行秒を設定します。
void | setRunYear(int runYear) 実行年を設定します。
void | setValidFlg(String validFlg) 有効フラグを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

BATCH_ID

public static final String BATCH_ID
バッチID

関連項目:
定数フィールド値

BATCH_NAME

public static final String BATCH_NAME
バッチ名

関連項目:
定数フィールド値

PROGRAM_LANGUAGE

public static final String PROGRAM_LANGUAGE
実行プログラム言語

関連項目:
定数フィールド値

PROGRAM_PATH

public static final String PROGRAM_PATH
実行プログラムパス

関連項目:
定数フィールド値

RUN_YEAR

public static final String RUN_YEAR
実行年

関連項目:
定数フィールド値

RUN_MONTH

public static final String RUN_MONTH
実行月

関連項目:
定数フィールド値

RUN_DAY

public static final String RUN_DAY
実行日

関連項目:
定数フィールド値

RUN_DAY_WEEK

public static final String RUN_DAY_WEEK
実行曜日

関連項目:
定数フィールド値

RUN_HOUR

public static final String RUN_HOUR
実行時

関連項目:
定数フィールド値

RUN_MINUTE

public static final String RUN_MINUTE
実行分

関連項目:
定数フィールド値

RUN_SECOND

public static final String RUN_SECOND
実行秒

関連項目:
定数フィールド値

VALID_FLG

public static final String VALID_FLG
有効フラグ

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getBatchId

public String getBatchId()
                  throws AccessorException
バッチIDを取得します。

戻り値:
バッチID
例外:
AccessorException - データの取得に失敗した場合

getBatchName

public String getBatchName()
                    throws AccessorException
バッチ名を取得します。

戻り値:
バッチ名
例外:
AccessorException - データの取得に失敗した場合

setBatchName

public void setBatchName(String batchName)
                  throws AccessorException
バッチ名を設定します。

パラメータ:
batchName - バッチ名
例外:
AccessorException - データの設定に失敗した場合

getProgramLanguage

public String getProgramLanguage()
                          throws AccessorException
実行プログラム言語を取得します。

戻り値:
実行プログラム言語
例外:
AccessorException - データの取得に失敗した場合

setProgramLanguage

public void setProgramLanguage(String programLanguage)
                        throws AccessorException
実行プログラム言語を設定します。

パラメータ:
programLanguage - 実行プログラム言語
例外:
AccessorException - データの設定に失敗した場合

getProgramPath

public String getProgramPath()
                      throws AccessorException
実行プログラムパスを取得します。

戻り値:
実行プログラムパス
例外:
AccessorException - データの取得に失敗した場合

setProgramPath

public void setProgramPath(String programPath)
                    throws AccessorException
実行プログラムパスを設定します。

パラメータ:
programPath - 実行プログラムパス
例外:
AccessorException - データの設定に失敗した場合

getRunYear

public int getRunYear()
               throws AccessorException
実行年を取得します。

戻り値:
実行年
例外:
AccessorException - データの取得に失敗した場合

setRunYear

public void setRunYear(int runYear)
                throws AccessorException
実行年を設定します。

パラメータ:
runYear - 実行年
例外:
AccessorException - データの設定に失敗した場合

getRunMonth

public int getRunMonth()
                throws AccessorException
実行月を取得します。

戻り値:
実行月
例外:
AccessorException - データの取得に失敗した場合

setRunMonth

public void setRunMonth(int runMonth)
                 throws AccessorException
実行月を設定します。

パラメータ:
runMonth - 実行月
例外:
AccessorException - データの設定に失敗した場合

getRunDay

public int getRunDay()
              throws AccessorException
実行日を取得します。

戻り値:
実行日
例外:
AccessorException - データの取得に失敗した場合

setRunDay

public void setRunDay(int runDay)
               throws AccessorException
実行日を設定します。

パラメータ:
runDay - 実行日
例外:
AccessorException - データの設定に失敗した場合

getRunDayWeek

public int getRunDayWeek()
                  throws AccessorException
実行曜日を取得します。

戻り値:
実行曜日
例外:
AccessorException - データの取得に失敗した場合

setRunDayWeek

public void setRunDayWeek(int runDayWeek)
                   throws AccessorException
実行曜日を設定します。

パラメータ:
runDayWeek - 実行曜日
例外:
AccessorException - データの設定に失敗した場合

getRunHour

public int getRunHour()
               throws AccessorException
実行時を取得します。

戻り値:
実行時
例外:
AccessorException - データの取得に失敗した場合

setRunHour

public void setRunHour(int runHour)
                throws AccessorException
実行時を設定します。

パラメータ:
runHour - 実行時
例外:
AccessorException - データの設定に失敗した場合

getRunMinute

public int getRunMinute()
                 throws AccessorException
実行分を取得します。

戻り値:
実行分
例外:
AccessorException - データの取得に失敗した場合

setRunMinute

public void setRunMinute(int runMinute)
                  throws AccessorException
実行分を設定します。

パラメータ:
runMinute - 実行分
例外:
AccessorException - データの設定に失敗した場合

getRunSecond

public int getRunSecond()
                 throws AccessorException
実行秒を取得します。

戻り値:
実行秒
例外:
AccessorException - データの取得に失敗した場合

setRunSecond

public void setRunSecond(int runSecond)
                  throws AccessorException
実行秒を設定します。

パラメータ:
runSecond - 実行秒
例外:
AccessorException - データの設定に失敗した場合

getValidFlg

public String getValidFlg()
                   throws AccessorException
有効フラグを取得します。

戻り値:
有効フラグ
例外:
AccessorException - データの取得に失敗した場合

setValidFlg

public void setValidFlg(String validFlg)
                 throws AccessorException
有効フラグを設定します。

パラメータ:
validFlg - 有効フラグ
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BatchMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース BatchMapper

すべてのスーパーインタフェース:
Mapper
public interface BatchMapper
extends Mapper

バッチ情報に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
BatchBaseModel | create(String batchId) プライマリキーに該当するバッチ情報を生成します。
void | delete(BatchBaseModel model) バッチ情報の基本モデルを1つだけ削除します。
void | delete(Collection models) バッチ情報の基本モデルを複数削除します。
void | insert(BatchBaseModel model) バッチ情報の基本モデルを1つだけ挿入します。
void | insert(Collection models) バッチ情報の基本モデルを複数挿入します。
BatchBaseModel | select(String batchId) プライマリーキーで特定されるバッチ情報の基本モデルを取得します。
void | update(BatchBaseModel model) バッチ情報の基本モデルを1つだけ更新します。
void | update(Collection models) バッチ情報の基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public BatchBaseModel create(String batchId)
                      throws MapperException
プライマリキーに該当するバッチ情報を生成します。

パラメータ:
batchId - バッチID
戻り値:
プライマリキーに該当するバッチ情報の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public BatchBaseModel select(String batchId)
                      throws MapperException
プライマリーキーで特定されるバッチ情報の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
batchId - バッチID
戻り値:
バッチ情報の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(BatchBaseModel model)
            throws MapperException
バッチ情報の基本モデルを1つだけ挿入します。 引数に指定するバッチ情報の基本モデルは同一の BatchMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入するバッチ情報の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
バッチ情報の基本モデルを複数挿入します。 引数に指定するものは同一の BatchMapperの create(String) で生成されたバッチ情報の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するバッチ情報の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(BatchBaseModel model)
            throws MapperException
バッチ情報の基本モデルを1つだけ更新します。 引数に指定するバッチ情報の基本モデルは同一の BatchMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するバッチ情報の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
バッチ情報の基本モデルを複数更新します。 引数に指定するものは同一の BatchMapperの select 系メソッド から取得されたものかで生成されたバッチ情報の基本モデルの集合である必要があります。

パラメータ:
models - 更新するバッチ情報の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(BatchBaseModel model)
            throws MapperException
バッチ情報の基本モデルを1つだけ削除します。 引数で指定されたバッチ情報の基本モデルに該当するデータのすべての情報を削除します。引数に指定するバッチ情報の基本モデルは同一の BatchMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するバッチ情報の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
バッチ情報の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するバッチ情報の基本モデルは同一の BatchMapperの select 系メソッド から取得されたバッチ情報の基本モデルの集合である必要があります。

パラメータ:
models - 削除するバッチ情報の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarInfoBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース CalendarInfoBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface CalendarInfoBaseModel
extends BaseModel

カレンダーが保有するデータの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | CALENDAR_ID カレンダーID
static String | COLOR 表示色
static String | DATA_ID データID
static String | DATA_NAME データ名称
static String | DATA_TYPE データタイプ
static String | DAY 日
static String | DAY_WEEK 曜日
static String | DISPLAY_NAME データ表示名
static String | MONTH 月
static String | PLUGIN_METHOD プラグイン関数
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | TIMES 次
static String | VALID_END_YEAR 有効終了年
static String | VALID_START_YEAR 有効開始年
static String | WEEK 週
static String | YEAR 年
メソッドの概要
String | getCalendarId() カレンダーIDを取得します。
String | getColor() 表示色を取得します。
String | getDataId() データIDを取得します。
String | getDataName() データ名称を取得します。
String | getDataType() データタイプを取得します。
int | getDay() 日を取得します。
int | getDayWeek() 曜日を取得します。
String | getDisplayName() データ表示名を取得します。
String | getDisplayName(Locale locale) データ表示名を取得します。
int | getMonth() 月を取得します。
String | getPluginMethod() プラグイン関数を取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getTimes() 次を取得します。
int | getValidEndYear() 有効終了年を取得します。
int | getValidStartYear() 有効開始年を取得します。
int | getWeek() 週を取得します。
int | getYear() 年を取得します。
CalendarInfoInternationalModel | selectCalendarInfoInternationalModel(Locale locale) 指定された言語に該当するカレンダーが保有するデータの国際化モデルを取得します。
void | setColor(String color) 表示色を設定します。
void | setDataName(String dataName) データ名称を設定します。
void | setDataType(String dataType) データタイプを設定します。
void | setDay(int day) 日を設定します。
void | setDayWeek(int dayWeek) 曜日を設定します。
void | setDisplayName(String displayName) データ表示名を設定します。
void | setDisplayName(String displayName, Locale locale) データ表示名を設定します。
void | setMonth(int month) 月を設定します。
void | setPluginMethod(String pluginMethod) プラグイン関数を設定します。
void | setTimes(int times) 次を設定します。
void | setValidEndYear(int validEndYear) 有効終了年を設定します。
void | setValidStartYear(int validStartYear) 有効開始年を設定します。
void | setWeek(int week) 週を設定します。
void | setYear(int year) 年を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

CALENDAR_ID

public static final String CALENDAR_ID
カレンダーID

関連項目:
定数フィールド値

DATA_ID

public static final String DATA_ID
データID

関連項目:
定数フィールド値

DATA_TYPE

public static final String DATA_TYPE
データタイプ

関連項目:
定数フィールド値

DATA_NAME

public static final String DATA_NAME
データ名称

関連項目:
定数フィールド値

YEAR

public static final String YEAR
年

関連項目:
定数フィールド値

MONTH

public static final String MONTH
月

関連項目:
定数フィールド値

DAY

public static final String DAY
日

関連項目:
定数フィールド値

WEEK

public static final String WEEK
週

関連項目:
定数フィールド値

TIMES

public static final String TIMES
次

関連項目:
定数フィールド値

DAY_WEEK

public static final String DAY_WEEK
曜日

関連項目:
定数フィールド値

VALID_START_YEAR

public static final String VALID_START_YEAR
有効開始年

関連項目:
定数フィールド値

VALID_END_YEAR

public static final String VALID_END_YEAR
有効終了年

関連項目:
定数フィールド値

PLUGIN_METHOD

public static final String PLUGIN_METHOD
プラグイン関数

関連項目:
定数フィールド値

COLOR

public static final String COLOR
表示色

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

DISPLAY_NAME

public static final String DISPLAY_NAME
データ表示名

関連項目:
定数フィールド値
メソッドの詳細

getCalendarId

public String getCalendarId()
                     throws AccessorException
カレンダーIDを取得します。

戻り値:
カレンダーID
例外:
AccessorException - データの取得に失敗した場合

getDataId

public String getDataId()
                 throws AccessorException
データIDを取得します。

戻り値:
データID
例外:
AccessorException - データの取得に失敗した場合

getDataType

public String getDataType()
                   throws AccessorException
データタイプを取得します。

戻り値:
データタイプ
例外:
AccessorException - データの取得に失敗した場合

setDataType

public void setDataType(String dataType)
                 throws AccessorException
データタイプを設定します。

パラメータ:
dataType - データタイプ
例外:
AccessorException - データの設定に失敗した場合

getDataName

public String getDataName()
                   throws AccessorException
データ名称を取得します。

戻り値:
データ名称
例外:
AccessorException - データの取得に失敗した場合

setDataName

public void setDataName(String dataName)
                 throws AccessorException
データ名称を設定します。

パラメータ:
dataName - データ名称
例外:
AccessorException - データの設定に失敗した場合

getYear

public int getYear()
            throws AccessorException
年を取得します。

戻り値:
年
例外:
AccessorException - データの取得に失敗した場合

setYear

public void setYear(int year)
             throws AccessorException
年を設定します。

パラメータ:
year - 年
例外:
AccessorException - データの設定に失敗した場合

getMonth

public int getMonth()
             throws AccessorException
月を取得します。

戻り値:
月
例外:
AccessorException - データの取得に失敗した場合

setMonth

public void setMonth(int month)
              throws AccessorException
月を設定します。

パラメータ:
month - 月
例外:
AccessorException - データの設定に失敗した場合

getDay

public int getDay()
           throws AccessorException
日を取得します。

戻り値:
日
例外:
AccessorException - データの取得に失敗した場合

setDay

public void setDay(int day)
            throws AccessorException
日を設定します。

パラメータ:
day - 日
例外:
AccessorException - データの設定に失敗した場合

getWeek

public int getWeek()
            throws AccessorException
週を取得します。

戻り値:
週
例外:
AccessorException - データの取得に失敗した場合

setWeek

public void setWeek(int week)
             throws AccessorException
週を設定します。

パラメータ:
week - 週
例外:
AccessorException - データの設定に失敗した場合

getTimes

public int getTimes()
             throws AccessorException
次を取得します。

戻り値:
次
例外:
AccessorException - データの取得に失敗した場合

setTimes

public void setTimes(int times)
              throws AccessorException
次を設定します。

パラメータ:
times - 次
例外:
AccessorException - データの設定に失敗した場合

getDayWeek

public int getDayWeek()
               throws AccessorException
曜日を取得します。

戻り値:
曜日
例外:
AccessorException - データの取得に失敗した場合

setDayWeek

public void setDayWeek(int dayWeek)
                throws AccessorException
曜日を設定します。

パラメータ:
dayWeek - 曜日
例外:
AccessorException - データの設定に失敗した場合

getValidStartYear

public int getValidStartYear()
                      throws AccessorException
有効開始年を取得します。

戻り値:
有効開始年
例外:
AccessorException - データの取得に失敗した場合

setValidStartYear

public void setValidStartYear(int validStartYear)
                       throws AccessorException
有効開始年を設定します。

パラメータ:
validStartYear - 有効開始年
例外:
AccessorException - データの設定に失敗した場合

getValidEndYear

public int getValidEndYear()
                    throws AccessorException
有効終了年を取得します。

戻り値:
有効終了年
例外:
AccessorException - データの取得に失敗した場合

setValidEndYear

public void setValidEndYear(int validEndYear)
                     throws AccessorException
有効終了年を設定します。

パラメータ:
validEndYear - 有効終了年
例外:
AccessorException - データの設定に失敗した場合

getPluginMethod

public String getPluginMethod()
                       throws AccessorException
プラグイン関数を取得します。

戻り値:
プラグイン関数
例外:
AccessorException - データの取得に失敗した場合

setPluginMethod

public void setPluginMethod(String pluginMethod)
                     throws AccessorException
プラグイン関数を設定します。

パラメータ:
pluginMethod - プラグイン関数
例外:
AccessorException - データの設定に失敗した場合

getColor

public String getColor()
                throws AccessorException
表示色を取得します。

戻り値:
表示色
例外:
AccessorException - データの取得に失敗した場合

setColor

public void setColor(String color)
              throws AccessorException
表示色を設定します。

パラメータ:
color - 表示色
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getDisplayName

public String getDisplayName()
                      throws AccessorException
データ表示名を取得します。

戻り値:
データ表示名
例外:
AccessorException - データの取得に失敗した場合

getDisplayName

public String getDisplayName(Locale locale)
                      throws AccessorException
データ表示名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
データ表示名
例外:
AccessorException - データの取得に失敗した場合

setDisplayName

public void setDisplayName(String displayName)
                    throws AccessorException
データ表示名を設定します。

パラメータ:
displayName - データ表示名
例外:
AccessorException - データの設定に失敗した場合

setDisplayName

public void setDisplayName(String displayName,
                           Locale locale)
                    throws AccessorException
データ表示名を設定します。

パラメータ:
displayName - データ表示名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectCalendarInfoInternationalModel

public CalendarInfoInternationalModel selectCalendarInfoInternationalModel(Locale locale)
                                                                    throws IllegalLocaleException
指定された言語に該当するカレンダーが保有するデータの国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
カレンダーが保有するデータの国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarInfoInternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース CalendarInfoInternationalModel

すべてのスーパーインタフェース:
InternationalModel, Serializable
public interface CalendarInfoInternationalModel
extends InternationalModel

カレンダーが保有するデータの国際化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getDisplayName() データ表示名を取得します。
void | setDisplayName(String displayName) データ表示名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModel から継承したメソッド
getExtendedInternationalModelMap, getLocale, init

メソッドの詳細

getDisplayName

public String getDisplayName()
                      throws AccessorException
データ表示名を取得します。

戻り値:
データ表示名
例外:
AccessorException - データの取得に失敗した場合

setDisplayName

public void setDisplayName(String displayName)
                    throws AccessorException
データ表示名を設定します。

パラメータ:
displayName - データ表示名
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarInfoMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース CalendarInfoMapper

すべてのスーパーインタフェース:
Mapper
public interface CalendarInfoMapper
extends Mapper

カレンダーが保有するデータに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
CalendarInfoBaseModel | create(String calendarId, String dataId) プライマリキーに該当するカレンダーが保有するデータを生成します。
void | delete(CalendarInfoBaseModel model) カレンダーが保有するデータの基本モデルを1つだけ削除します。
void | delete(Collection models) カレンダーが保有するデータの基本モデルを複数削除します。
void | insert(CalendarInfoBaseModel model) カレンダーが保有するデータの基本モデルを1つだけ挿入します。
void | insert(Collection models) カレンダーが保有するデータの基本モデルを複数挿入します。
CalendarInfoBaseModel | select(String calendarId, String dataId) プライマリーキーで特定されるカレンダーが保有するデータの基本モデルを取得します。
void | update(CalendarInfoBaseModel model) カレンダーが保有するデータの基本モデルを1つだけ更新します。
void | update(Collection models) カレンダーが保有するデータの基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public CalendarInfoBaseModel create(String calendarId,
                                    String dataId)
                             throws MapperException
プライマリキーに該当するカレンダーが保有するデータを生成します。

パラメータ:
calendarId - カレンダーID
dataId - データID
戻り値:
プライマリキーに該当するカレンダーが保有するデータの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public CalendarInfoBaseModel select(String calendarId,
                                    String dataId)
                             throws MapperException
プライマリーキーで特定されるカレンダーが保有するデータの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
calendarId - カレンダーID
dataId - データID
戻り値:
カレンダーが保有するデータの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(CalendarInfoBaseModel model)
            throws MapperException
カレンダーが保有するデータの基本モデルを1つだけ挿入します。 引数に指定するカレンダーが保有するデータの基本モデルは同一の CalendarInfoMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するカレンダーが保有するデータの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
カレンダーが保有するデータの基本モデルを複数挿入します。 引数に指定するものは同一の CalendarInfoMapperの create(String,String) で生成されたカレンダーが保有するデータの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するカレンダーが保有するデータの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(CalendarInfoBaseModel model)
            throws MapperException
カレンダーが保有するデータの基本モデルを1つだけ更新します。 引数に指定するカレンダーが保有するデータの基本モデルは同一の CalendarInfoMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するカレンダーが保有するデータの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
カレンダーが保有するデータの基本モデルを複数更新します。 引数に指定するものは同一の CalendarInfoMapperの select 系メソッド から取得されたものかで生成されたカレンダーが保有するデータの基本モデルの集合である必要があります。

パラメータ:
models - 更新するカレンダーが保有するデータの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(CalendarInfoBaseModel model)
            throws MapperException
カレンダーが保有するデータの基本モデルを1つだけ削除します。 引数で指定されたカレンダーが保有するデータの基本モデルに該当するデータのすべての情報を削除します。引数に指定するカレンダーが保有するデータの基本モデルは同一の CalendarInfoMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するカレンダーが保有するデータの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
カレンダーが保有するデータの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するカレンダーが保有するデータの基本モデルは同一の CalendarInfoMapperの select 系メソッド から取得されたカレンダーが保有するデータの基本モデルの集合である必要があります。

パラメータ:
models - 削除するカレンダーが保有するデータの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataStoreConst (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース DataStoreConst

すべてのスーパーインタフェース:
Serializable
public interface DataStoreConst
extends Serializable

データストアの定数クラス

導入されたバージョン:
5.0

フィールドの概要
static String | ACCESS_CONTROLLER アクセスコントローラ情報
static String | ACCESS_CONTROLLER_DEPARTMENT アクセスコントローラの利用権限を保有する組織
static String | ACCESS_CONTROLLER_POST アクセスコントローラの利用権限を保有する役職
static String | ACCESS_CONTROLLER_PUBLIC_GROUP アクセスコントローラの利用権限を保有するパブリックグループ
static String | ACCESS_CONTROLLER_ROLE アクセスコントローラの利用権限を保有するロール
static String | ACCOUNT アカウント
static String | ACCOUNT_ATTRIBUTE アカウント属性
static String | ACCOUNT_ROLE アカウントが保有するロール
static String | APPLICATION_NAME アプリケーション
static String | BATCH バッチ情報
static String | CALENDAR_INFO カレンダーが保有するデータ
static String | FAVORITE_MENU アカウントが保有するメニュー
static String | MENU メニュー情報
static String | MENU_ARGUMENT メニューの保有する引数
static String | MENU_DEPARTMENT メニューの利用権限を保有する組織
static String | MENU_POST メニューの利用権限を保有する役職
static String | MENU_PUBLIC_GROUP メニューの利用権限を保有するパブリックグループ
static String | MENU_ROLE メニューの利用権限を保有するロール
static String | ROLE ロール
static String | ROLE_INCLUSION ロール内包
static String | ROLE_SUMMARY ロールサマリ

フィールドの詳細

APPLICATION_NAME

public static final String APPLICATION_NAME
アプリケーション

関連項目:
定数フィールド値

ROLE

public static final String ROLE
ロール

関連項目:
定数フィールド値

ROLE_INCLUSION

public static final String ROLE_INCLUSION
ロール内包

関連項目:
定数フィールド値

ROLE_SUMMARY

public static final String ROLE_SUMMARY
ロールサマリ

関連項目:
定数フィールド値

ACCOUNT

public static final String ACCOUNT
アカウント

関連項目:
定数フィールド値

FAVORITE_MENU

public static final String FAVORITE_MENU
アカウントが保有するメニュー

関連項目:
定数フィールド値

ACCOUNT_ROLE

public static final String ACCOUNT_ROLE
アカウントが保有するロール

関連項目:
定数フィールド値

MENU

public static final String MENU
メニュー情報

関連項目:
定数フィールド値

MENU_ARGUMENT

public static final String MENU_ARGUMENT
メニューの保有する引数

関連項目:
定数フィールド値

MENU_DEPARTMENT

public static final String MENU_DEPARTMENT
メニューの利用権限を保有する組織

関連項目:
定数フィールド値

MENU_POST

public static final String MENU_POST
メニューの利用権限を保有する役職

関連項目:
定数フィールド値

MENU_PUBLIC_GROUP

public static final String MENU_PUBLIC_GROUP
メニューの利用権限を保有するパブリックグループ

関連項目:
定数フィールド値

MENU_ROLE

public static final String MENU_ROLE
メニューの利用権限を保有するロール

関連項目:
定数フィールド値

CALENDAR_INFO

public static final String CALENDAR_INFO
カレンダーが保有するデータ

関連項目:
定数フィールド値

BATCH

public static final String BATCH
バッチ情報

関連項目:
定数フィールド値

ACCESS_CONTROLLER

public static final String ACCESS_CONTROLLER
アクセスコントローラ情報

関連項目:
定数フィールド値

ACCESS_CONTROLLER_DEPARTMENT

public static final String ACCESS_CONTROLLER_DEPARTMENT
アクセスコントローラの利用権限を保有する組織

関連項目:
定数フィールド値

ACCESS_CONTROLLER_POST

public static final String ACCESS_CONTROLLER_POST
アクセスコントローラの利用権限を保有する役職

関連項目:
定数フィールド値

ACCESS_CONTROLLER_PUBLIC_GROUP

public static final String ACCESS_CONTROLLER_PUBLIC_GROUP
アクセスコントローラの利用権限を保有するパブリックグループ

関連項目:
定数フィールド値

ACCESS_CONTROLLER_ROLE

public static final String ACCESS_CONTROLLER_ROLE
アクセスコントローラの利用権限を保有するロール

関連項目:
定数フィールド値

ACCOUNT_ATTRIBUTE

public static final String ACCOUNT_ATTRIBUTE
アカウント属性

関連項目:
定数フィールド値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FavoriteMenuBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース FavoriteMenuBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface FavoriteMenuBaseModel
extends BaseModel

アカウントが保有するメニューの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | DISPLAY_NAME メニュー表示名
static String | IMAGE_PATH イメージパス
static String | MENU_ID メニューID
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_NUMBER ソート番号
static String | USER_ID ユーザID
メソッドの概要
String | getDisplayName() メニュー表示名を取得します。
String | getImagePath() イメージパスを取得します。
String | getMenuId() メニューIDを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortNumber() ソート番号を取得します。
String | getUserId() ユーザIDを取得します。
void | setDisplayName(String displayName) メニュー表示名を設定します。
void | setImagePath(String imagePath) イメージパスを設定します。
void | setSortNumber(int sortNumber) ソート番号を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

USER_ID

public static final String USER_ID
ユーザID

関連項目:
定数フィールド値

MENU_ID

public static final String MENU_ID
メニューID

関連項目:
定数フィールド値

DISPLAY_NAME

public static final String DISPLAY_NAME
メニュー表示名

関連項目:
定数フィールド値

IMAGE_PATH

public static final String IMAGE_PATH
イメージパス

関連項目:
定数フィールド値

SORT_NUMBER

public static final String SORT_NUMBER
ソート番号

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getUserId

public String getUserId()
                 throws AccessorException
ユーザIDを取得します。

戻り値:
ユーザID
例外:
AccessorException - データの取得に失敗した場合

getMenuId

public String getMenuId()
                 throws AccessorException
メニューIDを取得します。

戻り値:
メニューID
例外:
AccessorException - データの取得に失敗した場合

getDisplayName

public String getDisplayName()
                      throws AccessorException
メニュー表示名を取得します。

戻り値:
メニュー表示名
例外:
AccessorException - データの取得に失敗した場合

setDisplayName

public void setDisplayName(String displayName)
                    throws AccessorException
メニュー表示名を設定します。

パラメータ:
displayName - メニュー表示名
例外:
AccessorException - データの設定に失敗した場合

getImagePath

public String getImagePath()
                    throws AccessorException
イメージパスを取得します。

戻り値:
イメージパス
例外:
AccessorException - データの取得に失敗した場合
導入されたバージョン:
6.0

setImagePath

public void setImagePath(String imagePath)
                  throws AccessorException
イメージパスを設定します。

パラメータ:
imagePath - イメージパス
例外:
AccessorException - データの設定に失敗した場合
導入されたバージョン:
6.0

getSortNumber

public int getSortNumber()
                  throws AccessorException
ソート番号を取得します。

戻り値:
ソート番号
例外:
AccessorException - データの取得に失敗した場合

setSortNumber

public void setSortNumber(int sortNumber)
                   throws AccessorException
ソート番号を設定します。

パラメータ:
sortNumber - ソート番号
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FavoriteMenuMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース FavoriteMenuMapper

すべてのスーパーインタフェース:
Mapper
public interface FavoriteMenuMapper
extends Mapper

アカウントが保有するメニューに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
FavoriteMenuBaseModel | create(String userId, String menuId) プライマリキーに該当するアカウントが保有するメニューを生成します。
void | delete(Collection models) アカウントが保有するメニューの基本モデルを複数削除します。
void | delete(FavoriteMenuBaseModel model) アカウントが保有するメニューの基本モデルを1つだけ削除します。
void | insert(Collection models) アカウントが保有するメニューの基本モデルを複数挿入します。
void | insert(FavoriteMenuBaseModel model) アカウントが保有するメニューの基本モデルを1つだけ挿入します。
FavoriteMenuBaseModel | select(String userId, String menuId) プライマリーキーで特定されるアカウントが保有するメニューの基本モデルを取得します。
void | update(Collection models) アカウントが保有するメニューの基本モデルを複数更新します。
void | update(FavoriteMenuBaseModel model) アカウントが保有するメニューの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public FavoriteMenuBaseModel create(String userId,
                                    String menuId)
                             throws MapperException
プライマリキーに該当するアカウントが保有するメニューを生成します。

パラメータ:
userId - ユーザID
menuId - メニューID
戻り値:
プライマリキーに該当するアカウントが保有するメニューの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public FavoriteMenuBaseModel select(String userId,
                                    String menuId)
                             throws MapperException
プライマリーキーで特定されるアカウントが保有するメニューの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
userId - ユーザID
menuId - メニューID
戻り値:
アカウントが保有するメニューの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(FavoriteMenuBaseModel model)
            throws MapperException
アカウントが保有するメニューの基本モデルを1つだけ挿入します。 引数に指定するアカウントが保有するメニューの基本モデルは同一の FavoriteMenuMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するアカウントが保有するメニューの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
アカウントが保有するメニューの基本モデルを複数挿入します。 引数に指定するものは同一の FavoriteMenuMapperの create(String,String) で生成されたアカウントが保有するメニューの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するアカウントが保有するメニューの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(FavoriteMenuBaseModel model)
            throws MapperException
アカウントが保有するメニューの基本モデルを1つだけ更新します。 引数に指定するアカウントが保有するメニューの基本モデルは同一の FavoriteMenuMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するアカウントが保有するメニューの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
アカウントが保有するメニューの基本モデルを複数更新します。 引数に指定するものは同一の FavoriteMenuMapperの select 系メソッド から取得されたものかで生成されたアカウントが保有するメニューの基本モデルの集合である必要があります。

パラメータ:
models - 更新するアカウントが保有するメニューの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(FavoriteMenuBaseModel model)
            throws MapperException
アカウントが保有するメニューの基本モデルを1つだけ削除します。 引数で指定されたアカウントが保有するメニューの基本モデルに該当するデータのすべての情報を削除します。引数に指定するアカウントが保有するメニューの基本モデルは同一の FavoriteMenuMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するアカウントが保有するメニューの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
アカウントが保有するメニューの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するアカウントが保有するメニューの基本モデルは同一の FavoriteMenuMapperの select 系メソッド から取得されたアカウントが保有するメニューの基本モデルの集合である必要があります。

パラメータ:
models - 削除するアカウントが保有するメニューの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuArgumentBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuArgumentBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface MenuArgumentBaseModel
extends BaseModel

メニューの保有する引数の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | ARGUMENT_NAME 引数名
static String | ARGUMENT_VALUE 引数値
static String | MENU_ID メニューID
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getArgumentName() 引数名を取得します。
String | getArgumentValue() 引数値を取得します。
String | getMenuId() メニューIDを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
void | setArgumentValue(String argumentValue) 引数値を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

MENU_ID

public static final String MENU_ID
メニューID

関連項目:
定数フィールド値

ARGUMENT_NAME

public static final String ARGUMENT_NAME
引数名

関連項目:
定数フィールド値

ARGUMENT_VALUE

public static final String ARGUMENT_VALUE
引数値

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getMenuId

public String getMenuId()
                 throws AccessorException
メニューIDを取得します。

戻り値:
メニューID
例外:
AccessorException - データの取得に失敗した場合

getArgumentName

public String getArgumentName()
                       throws AccessorException
引数名を取得します。

戻り値:
引数名
例外:
AccessorException - データの取得に失敗した場合

getArgumentValue

public String getArgumentValue()
                        throws AccessorException
引数値を取得します。

戻り値:
引数値
例外:
AccessorException - データの取得に失敗した場合

setArgumentValue

public void setArgumentValue(String argumentValue)
                      throws AccessorException
引数値を設定します。

パラメータ:
argumentValue - 引数値
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuArgumentMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuArgumentMapper

すべてのスーパーインタフェース:
Mapper
public interface MenuArgumentMapper
extends Mapper

メニューの保有する引数に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
MenuArgumentBaseModel | create(String menuId, String argumentName) プライマリキーに該当するメニューの保有する引数を生成します。
void | delete(Collection models) メニューの保有する引数の基本モデルを複数削除します。
void | delete(MenuArgumentBaseModel model) メニューの保有する引数の基本モデルを1つだけ削除します。
void | insert(Collection models) メニューの保有する引数の基本モデルを複数挿入します。
void | insert(MenuArgumentBaseModel model) メニューの保有する引数の基本モデルを1つだけ挿入します。
MenuArgumentBaseModel | select(String menuId, String argumentName) プライマリーキーで特定されるメニューの保有する引数の基本モデルを取得します。
void | update(Collection models) メニューの保有する引数の基本モデルを複数更新します。
void | update(MenuArgumentBaseModel model) メニューの保有する引数の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public MenuArgumentBaseModel create(String menuId,
                                    String argumentName)
                             throws MapperException
プライマリキーに該当するメニューの保有する引数を生成します。

パラメータ:
menuId - メニューID
argumentName - 引数名
戻り値:
プライマリキーに該当するメニューの保有する引数の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public MenuArgumentBaseModel select(String menuId,
                                    String argumentName)
                             throws MapperException
プライマリーキーで特定されるメニューの保有する引数の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
menuId - メニューID
argumentName - 引数名
戻り値:
メニューの保有する引数の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(MenuArgumentBaseModel model)
            throws MapperException
メニューの保有する引数の基本モデルを1つだけ挿入します。 引数に指定するメニューの保有する引数の基本モデルは同一の MenuArgumentMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するメニューの保有する引数の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
メニューの保有する引数の基本モデルを複数挿入します。 引数に指定するものは同一の MenuArgumentMapperの create(String,String) で生成されたメニューの保有する引数の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するメニューの保有する引数の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(MenuArgumentBaseModel model)
            throws MapperException
メニューの保有する引数の基本モデルを1つだけ更新します。 引数に指定するメニューの保有する引数の基本モデルは同一の MenuArgumentMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するメニューの保有する引数の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
メニューの保有する引数の基本モデルを複数更新します。 引数に指定するものは同一の MenuArgumentMapperの select 系メソッド から取得されたものかで生成されたメニューの保有する引数の基本モデルの集合である必要があります。

パラメータ:
models - 更新するメニューの保有する引数の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(MenuArgumentBaseModel model)
            throws MapperException
メニューの保有する引数の基本モデルを1つだけ削除します。 引数で指定されたメニューの保有する引数の基本モデルに該当するデータのすべての情報を削除します。引数に指定するメニューの保有する引数の基本モデルは同一の MenuArgumentMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するメニューの保有する引数の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
メニューの保有する引数の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するメニューの保有する引数の基本モデルは同一の MenuArgumentMapperの select 系メソッド から取得されたメニューの保有する引数の基本モデルの集合である必要があります。

パラメータ:
models - 削除するメニューの保有する引数の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface MenuBaseModel
extends BaseModel

メニュー情報の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | CLIENT_TYPE クライアントタイプ
static String | CONTENTS コンテンツの種類
static String | DISPLAY_NAME メニュー表示名
static String | IMAGE_PATH イメージパス
static String | MENU_ID メニューID
static String | MENU_TYPE メニュータイプ
static String | NOTES 説明
static String | PARENT_MENU_ID 親メニューID
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_NUMBER ソート番号
static String | URL URL
メソッドの概要
String | getClientType() クライアントタイプを取得します。
String | getContents() コンテンツの種類を取得します。
String | getDisplayName() メニュー表示名を取得します。
String | getDisplayName(Locale locale) メニュー表示名を取得します。
String | getImagePath() イメージパスを取得します。
String | getMenuId() メニューIDを取得します。
String | getMenuType() メニュータイプを取得します。
String | getNotes() 説明を取得します。
String | getParentMenuId() 親メニューIDを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortNumber() ソート番号を取得します。
String | getUrl() URLを取得します。
MenuInternationalModel | selectMenuInternationalModel(Locale locale) 指定された言語に該当するメニュー情報の国際化モデルを取得します。
void | setClientType(String clientType) クライアントタイプを設定します。
void | setContents(String contents) コンテンツの種類を設定します。
void | setDisplayName(String displayName) メニュー表示名を設定します。
void | setDisplayName(String displayName, Locale locale) メニュー表示名を設定します。
void | setImagePath(String imagePath) イメージパスを設定します。
void | setMenuType(String menuType) メニュータイプを設定します。
void | setNotes(String notes) 説明を設定します。
void | setParentMenuId(String parentMenuId) 親メニューIDを設定します。
void | setSortNumber(int sortNumber) ソート番号を設定します。
void | setUrl(String url) URLを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

MENU_ID

public static final String MENU_ID
メニューID

関連項目:
定数フィールド値

MENU_TYPE

public static final String MENU_TYPE
メニュータイプ

関連項目:
定数フィールド値

NOTES

public static final String NOTES
説明

関連項目:
定数フィールド値

SORT_NUMBER

public static final String SORT_NUMBER
ソート番号

関連項目:
定数フィールド値

CLIENT_TYPE

public static final String CLIENT_TYPE
クライアントタイプ

関連項目:
定数フィールド値

CONTENTS

public static final String CONTENTS
コンテンツの種類

関連項目:
定数フィールド値

URL

public static final String URL
URL

関連項目:
定数フィールド値

PARENT_MENU_ID

public static final String PARENT_MENU_ID
親メニューID

関連項目:
定数フィールド値

IMAGE_PATH

public static final String IMAGE_PATH
イメージパス

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

DISPLAY_NAME

public static final String DISPLAY_NAME
メニュー表示名

関連項目:
定数フィールド値
メソッドの詳細

getMenuId

public String getMenuId()
                 throws AccessorException
メニューIDを取得します。

戻り値:
メニューID
例外:
AccessorException - データの取得に失敗した場合

getMenuType

public String getMenuType()
                   throws AccessorException
メニュータイプを取得します。

戻り値:
メニュータイプ
例外:
AccessorException - データの取得に失敗した場合

setMenuType

public void setMenuType(String menuType)
                 throws AccessorException
メニュータイプを設定します。

パラメータ:
menuType - メニュータイプ
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
説明を取得します。

戻り値:
説明
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
説明を設定します。

パラメータ:
notes - 説明
例外:
AccessorException - データの設定に失敗した場合

getSortNumber

public int getSortNumber()
                  throws AccessorException
ソート番号を取得します。

戻り値:
ソート番号
例外:
AccessorException - データの取得に失敗した場合

setSortNumber

public void setSortNumber(int sortNumber)
                   throws AccessorException
ソート番号を設定します。

パラメータ:
sortNumber - ソート番号
例外:
AccessorException - データの設定に失敗した場合

getClientType

public String getClientType()
                     throws AccessorException
クライアントタイプを取得します。

戻り値:
クライアントタイプ
例外:
AccessorException - データの取得に失敗した場合

setClientType

public void setClientType(String clientType)
                   throws AccessorException
クライアントタイプを設定します。

パラメータ:
clientType - クライアントタイプ
例外:
AccessorException - データの設定に失敗した場合

getContents

public String getContents()
                   throws AccessorException
コンテンツの種類を取得します。

戻り値:
コンテンツの種類
例外:
AccessorException - データの取得に失敗した場合

setContents

public void setContents(String contents)
                 throws AccessorException
コンテンツの種類を設定します。

パラメータ:
contents - コンテンツの種類
例外:
AccessorException - データの設定に失敗した場合

getUrl

public String getUrl()
              throws AccessorException
URLを取得します。

戻り値:
URL
例外:
AccessorException - データの取得に失敗した場合

setUrl

public void setUrl(String url)
            throws AccessorException
URLを設定します。

パラメータ:
url - URL
例外:
AccessorException - データの設定に失敗した場合

getParentMenuId

public String getParentMenuId()
                       throws AccessorException
親メニューIDを取得します。

戻り値:
親メニューID
例外:
AccessorException - データの取得に失敗した場合

setParentMenuId

public void setParentMenuId(String parentMenuId)
                     throws AccessorException
親メニューIDを設定します。

パラメータ:
parentMenuId - 親メニューID
例外:
AccessorException - データの設定に失敗した場合

getImagePath

public String getImagePath()
                    throws AccessorException
イメージパスを取得します。

戻り値:
イメージパス
例外:
AccessorException - データの取得に失敗した場合

setImagePath

public void setImagePath(String imagePath)
                  throws AccessorException
イメージパスを設定します。

パラメータ:
imagePath - イメージパス
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getDisplayName

public String getDisplayName()
                      throws AccessorException
メニュー表示名を取得します。

戻り値:
メニュー表示名
例外:
AccessorException - データの取得に失敗した場合

getDisplayName

public String getDisplayName(Locale locale)
                      throws AccessorException
メニュー表示名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
メニュー表示名
例外:
AccessorException - データの取得に失敗した場合

setDisplayName

public void setDisplayName(String displayName)
                    throws AccessorException
メニュー表示名を設定します。

パラメータ:
displayName - メニュー表示名
例外:
AccessorException - データの設定に失敗した場合

setDisplayName

public void setDisplayName(String displayName,
                           Locale locale)
                    throws AccessorException
メニュー表示名を設定します。

パラメータ:
displayName - メニュー表示名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectMenuInternationalModel

public MenuInternationalModel selectMenuInternationalModel(Locale locale)
                                                    throws IllegalLocaleException
指定された言語に該当するメニュー情報の国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
メニュー情報の国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuDepartmentBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuDepartmentBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface MenuDepartmentBaseModel
extends BaseModel

メニューの利用権限を保有する組織の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | COMPANY_CD 会社CD
static String | DEPARTMENT_CD 組織CD
static String | MENU_ID メニューID
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getCompanyCd() 会社CDを取得します。
String | getDepartmentCd() 組織CDを取得します。
String | getMenuId() メニューIDを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

MENU_ID

public static final String MENU_ID
メニューID

関連項目:
定数フィールド値

COMPANY_CD

public static final String COMPANY_CD
会社CD

関連項目:
定数フィールド値

DEPARTMENT_CD

public static final String DEPARTMENT_CD
組織CD

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getMenuId

public String getMenuId()
                 throws AccessorException
メニューIDを取得します。

戻り値:
メニューID
例外:
AccessorException - データの取得に失敗した場合

getCompanyCd

public String getCompanyCd()
                    throws AccessorException
会社CDを取得します。

戻り値:
会社CD
例外:
AccessorException - データの取得に失敗した場合

getDepartmentCd

public String getDepartmentCd()
                       throws AccessorException
組織CDを取得します。

戻り値:
組織CD
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuDepartmentMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuDepartmentMapper

すべてのスーパーインタフェース:
Mapper
public interface MenuDepartmentMapper
extends Mapper

メニューの利用権限を保有する組織に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
MenuDepartmentBaseModel | create(String menuId, String companyCd, String departmentCd) プライマリキーに該当するメニューの利用権限を保有する組織を生成します。
void | delete(Collection models) メニューの利用権限を保有する組織の基本モデルを複数削除します。
void | delete(MenuDepartmentBaseModel model) メニューの利用権限を保有する組織の基本モデルを1つだけ削除します。
void | insert(Collection models) メニューの利用権限を保有する組織の基本モデルを複数挿入します。
void | insert(MenuDepartmentBaseModel model) メニューの利用権限を保有する組織の基本モデルを1つだけ挿入します。
MenuDepartmentBaseModel | select(String menuId, String companyCd, String departmentCd) プライマリーキーで特定されるメニューの利用権限を保有する組織の基本モデルを取得します。
void | update(Collection models) メニューの利用権限を保有する組織の基本モデルを複数更新します。
void | update(MenuDepartmentBaseModel model) メニューの利用権限を保有する組織の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public MenuDepartmentBaseModel create(String menuId,
                                      String companyCd,
                                      String departmentCd)
                               throws MapperException
プライマリキーに該当するメニューの利用権限を保有する組織を生成します。

パラメータ:
menuId - メニューID
companyCd - 会社CD
departmentCd - 組織CD
戻り値:
プライマリキーに該当するメニューの利用権限を保有する組織の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public MenuDepartmentBaseModel select(String menuId,
                                      String companyCd,
                                      String departmentCd)
                               throws MapperException
プライマリーキーで特定されるメニューの利用権限を保有する組織の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
menuId - メニューID
companyCd - 会社CD
departmentCd - 組織CD
戻り値:
メニューの利用権限を保有する組織の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(MenuDepartmentBaseModel model)
            throws MapperException
メニューの利用権限を保有する組織の基本モデルを1つだけ挿入します。 引数に指定するメニューの利用権限を保有する組織の基本モデルは同一の MenuDepartmentMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するメニューの利用権限を保有する組織の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
メニューの利用権限を保有する組織の基本モデルを複数挿入します。 引数に指定するものは同一の MenuDepartmentMapperの create(String,String,String) で生成されたメニューの利用権限を保有する組織の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するメニューの利用権限を保有する組織の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(MenuDepartmentBaseModel model)
            throws MapperException
メニューの利用権限を保有する組織の基本モデルを1つだけ更新します。 引数に指定するメニューの利用権限を保有する組織の基本モデルは同一の MenuDepartmentMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するメニューの利用権限を保有する組織の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
メニューの利用権限を保有する組織の基本モデルを複数更新します。 引数に指定するものは同一の MenuDepartmentMapperの select 系メソッド から取得されたものかで生成されたメニューの利用権限を保有する組織の基本モデルの集合である必要があります。

パラメータ:
models - 更新するメニューの利用権限を保有する組織の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(MenuDepartmentBaseModel model)
            throws MapperException
メニューの利用権限を保有する組織の基本モデルを1つだけ削除します。 引数で指定されたメニューの利用権限を保有する組織の基本モデルに該当するデータのすべての情報を削除します。引数に指定するメニューの利用権限を保有する組織の基本モデルは同一の MenuDepartmentMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するメニューの利用権限を保有する組織の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
メニューの利用権限を保有する組織の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するメニューの利用権限を保有する組織の基本モデルは同一の MenuDepartmentMapperの select 系メソッド から取得されたメニューの利用権限を保有する組織の基本モデルの集合である必要があります。

パラメータ:
models - 削除するメニューの利用権限を保有する組織の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuInternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuInternationalModel

すべてのスーパーインタフェース:
InternationalModel, Serializable
public interface MenuInternationalModel
extends InternationalModel

メニュー情報の国際化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getDisplayName() メニュー表示名を取得します。
void | setDisplayName(String displayName) メニュー表示名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModel から継承したメソッド
getExtendedInternationalModelMap, getLocale, init

メソッドの詳細

getDisplayName

public String getDisplayName()
                      throws AccessorException
メニュー表示名を取得します。

戻り値:
メニュー表示名
例外:
AccessorException - データの取得に失敗した場合

setDisplayName

public void setDisplayName(String displayName)
                    throws AccessorException
メニュー表示名を設定します。

パラメータ:
displayName - メニュー表示名
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuMapper

すべてのスーパーインタフェース:
Mapper
public interface MenuMapper
extends Mapper

メニュー情報に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
MenuBaseModel | create(String menuId) プライマリキーに該当するメニュー情報を生成します。
void | delete(Collection models) メニュー情報の基本モデルを複数削除します。
void | delete(MenuBaseModel model) メニュー情報の基本モデルを1つだけ削除します。
void | insert(Collection models) メニュー情報の基本モデルを複数挿入します。
void | insert(MenuBaseModel model) メニュー情報の基本モデルを1つだけ挿入します。
MenuBaseModel | select(String menuId) プライマリーキーで特定されるメニュー情報の基本モデルを取得します。
void | update(Collection models) メニュー情報の基本モデルを複数更新します。
void | update(MenuBaseModel model) メニュー情報の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public MenuBaseModel create(String menuId)
                     throws MapperException
プライマリキーに該当するメニュー情報を生成します。

パラメータ:
menuId - メニューID
戻り値:
プライマリキーに該当するメニュー情報の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public MenuBaseModel select(String menuId)
                     throws MapperException
プライマリーキーで特定されるメニュー情報の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
menuId - メニューID
戻り値:
メニュー情報の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(MenuBaseModel model)
            throws MapperException
メニュー情報の基本モデルを1つだけ挿入します。 引数に指定するメニュー情報の基本モデルは同一の MenuMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入するメニュー情報の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
メニュー情報の基本モデルを複数挿入します。 引数に指定するものは同一の MenuMapperの create(String) で生成されたメニュー情報の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するメニュー情報の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(MenuBaseModel model)
            throws MapperException
メニュー情報の基本モデルを1つだけ更新します。 引数に指定するメニュー情報の基本モデルは同一の MenuMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するメニュー情報の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
メニュー情報の基本モデルを複数更新します。 引数に指定するものは同一の MenuMapperの select 系メソッド から取得されたものかで生成されたメニュー情報の基本モデルの集合である必要があります。

パラメータ:
models - 更新するメニュー情報の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(MenuBaseModel model)
            throws MapperException
メニュー情報の基本モデルを1つだけ削除します。 引数で指定されたメニュー情報の基本モデルに該当するデータのすべての情報を削除します。引数に指定するメニュー情報の基本モデルは同一の MenuMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するメニュー情報の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
メニュー情報の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するメニュー情報の基本モデルは同一の MenuMapperの select 系メソッド から取得されたメニュー情報の基本モデルの集合である必要があります。

パラメータ:
models - 削除するメニュー情報の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuPostBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuPostBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface MenuPostBaseModel
extends BaseModel

メニューの利用権限を保有する役職の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | COMPANY_CD 会社CD
static String | MENU_ID メニューID
static String | POST_CD 役職CD
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getCompanyCd() 会社CDを取得します。
String | getMenuId() メニューIDを取得します。
String | getPostCd() 役職CDを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

MENU_ID

public static final String MENU_ID
メニューID

関連項目:
定数フィールド値

COMPANY_CD

public static final String COMPANY_CD
会社CD

関連項目:
定数フィールド値

POST_CD

public static final String POST_CD
役職CD

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getMenuId

public String getMenuId()
                 throws AccessorException
メニューIDを取得します。

戻り値:
メニューID
例外:
AccessorException - データの取得に失敗した場合

getCompanyCd

public String getCompanyCd()
                    throws AccessorException
会社CDを取得します。

戻り値:
会社CD
例外:
AccessorException - データの取得に失敗した場合

getPostCd

public String getPostCd()
                 throws AccessorException
役職CDを取得します。

戻り値:
役職CD
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuPostMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuPostMapper

すべてのスーパーインタフェース:
Mapper
public interface MenuPostMapper
extends Mapper

メニューの利用権限を保有する役職に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
MenuPostBaseModel | create(String menuId, String companyCd, String postCd) プライマリキーに該当するメニューの利用権限を保有する役職を生成します。
void | delete(Collection models) メニューの利用権限を保有する役職の基本モデルを複数削除します。
void | delete(MenuPostBaseModel model) メニューの利用権限を保有する役職の基本モデルを1つだけ削除します。
void | insert(Collection models) メニューの利用権限を保有する役職の基本モデルを複数挿入します。
void | insert(MenuPostBaseModel model) メニューの利用権限を保有する役職の基本モデルを1つだけ挿入します。
MenuPostBaseModel | select(String menuId, String companyCd, String postCd) プライマリーキーで特定されるメニューの利用権限を保有する役職の基本モデルを取得します。
void | update(Collection models) メニューの利用権限を保有する役職の基本モデルを複数更新します。
void | update(MenuPostBaseModel model) メニューの利用権限を保有する役職の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public MenuPostBaseModel create(String menuId,
                                String companyCd,
                                String postCd)
                         throws MapperException
プライマリキーに該当するメニューの利用権限を保有する役職を生成します。

パラメータ:
menuId - メニューID
companyCd - 会社CD
postCd - 役職CD
戻り値:
プライマリキーに該当するメニューの利用権限を保有する役職の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public MenuPostBaseModel select(String menuId,
                                String companyCd,
                                String postCd)
                         throws MapperException
プライマリーキーで特定されるメニューの利用権限を保有する役職の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
menuId - メニューID
companyCd - 会社CD
postCd - 役職CD
戻り値:
メニューの利用権限を保有する役職の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(MenuPostBaseModel model)
            throws MapperException
メニューの利用権限を保有する役職の基本モデルを1つだけ挿入します。 引数に指定するメニューの利用権限を保有する役職の基本モデルは同一の MenuPostMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するメニューの利用権限を保有する役職の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
メニューの利用権限を保有する役職の基本モデルを複数挿入します。 引数に指定するものは同一の MenuPostMapperの create(String,String,String) で生成されたメニューの利用権限を保有する役職の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するメニューの利用権限を保有する役職の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(MenuPostBaseModel model)
            throws MapperException
メニューの利用権限を保有する役職の基本モデルを1つだけ更新します。 引数に指定するメニューの利用権限を保有する役職の基本モデルは同一の MenuPostMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するメニューの利用権限を保有する役職の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
メニューの利用権限を保有する役職の基本モデルを複数更新します。 引数に指定するものは同一の MenuPostMapperの select 系メソッド から取得されたものかで生成されたメニューの利用権限を保有する役職の基本モデルの集合である必要があります。

パラメータ:
models - 更新するメニューの利用権限を保有する役職の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(MenuPostBaseModel model)
            throws MapperException
メニューの利用権限を保有する役職の基本モデルを1つだけ削除します。 引数で指定されたメニューの利用権限を保有する役職の基本モデルに該当するデータのすべての情報を削除します。引数に指定するメニューの利用権限を保有する役職の基本モデルは同一の MenuPostMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するメニューの利用権限を保有する役職の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
メニューの利用権限を保有する役職の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するメニューの利用権限を保有する役職の基本モデルは同一の MenuPostMapperの select 系メソッド から取得されたメニューの利用権限を保有する役職の基本モデルの集合である必要があります。

パラメータ:
models - 削除するメニューの利用権限を保有する役職の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuPublicGroupBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuPublicGroupBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface MenuPublicGroupBaseModel
extends BaseModel

メニューの利用権限を保有するパブリックグループの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | MENU_ID メニューID
static String | PUBLIC_GROUP_CD グルーピングCD
static String | PUBLIC_GROUP_SET_CD グループセットCD
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getMenuId() メニューIDを取得します。
String | getPublicGroupCd() グルーピングCDを取得します。
String | getPublicGroupSetCd() グループセットCDを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

MENU_ID

public static final String MENU_ID
メニューID

関連項目:
定数フィールド値

PUBLIC_GROUP_SET_CD

public static final String PUBLIC_GROUP_SET_CD
グループセットCD

関連項目:
定数フィールド値

PUBLIC_GROUP_CD

public static final String PUBLIC_GROUP_CD
グルーピングCD

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getMenuId

public String getMenuId()
                 throws AccessorException
メニューIDを取得します。

戻り値:
メニューID
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupSetCd

public String getPublicGroupSetCd()
                           throws AccessorException
グループセットCDを取得します。

戻り値:
グループセットCD
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupCd

public String getPublicGroupCd()
                        throws AccessorException
グルーピングCDを取得します。

戻り値:
グルーピングCD
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuPublicGroupMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuPublicGroupMapper

すべてのスーパーインタフェース:
Mapper
public interface MenuPublicGroupMapper
extends Mapper

メニューの利用権限を保有するパブリックグループに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
MenuPublicGroupBaseModel | create(String menuId, String publicGroupSetCd, String publicGroupCd) プライマリキーに該当するメニューの利用権限を保有するパブリックグループを生成します。
void | delete(Collection models) メニューの利用権限を保有するパブリックグループの基本モデルを複数削除します。
void | delete(MenuPublicGroupBaseModel model) メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ削除します。
void | insert(Collection models) メニューの利用権限を保有するパブリックグループの基本モデルを複数挿入します。
void | insert(MenuPublicGroupBaseModel model) メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ挿入します。
MenuPublicGroupBaseModel | select(String menuId, String publicGroupSetCd, String publicGroupCd) プライマリーキーで特定されるメニューの利用権限を保有するパブリックグループの基本モデルを取得します。
void | update(Collection models) メニューの利用権限を保有するパブリックグループの基本モデルを複数更新します。
void | update(MenuPublicGroupBaseModel model) メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public MenuPublicGroupBaseModel create(String menuId,
                                       String publicGroupSetCd,
                                       String publicGroupCd)
                                throws MapperException
プライマリキーに該当するメニューの利用権限を保有するパブリックグループを生成します。

パラメータ:
menuId - メニューID
publicGroupSetCd - グループセットCD
publicGroupCd - グルーピングCD
戻り値:
プライマリキーに該当するメニューの利用権限を保有するパブリックグループの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public MenuPublicGroupBaseModel select(String menuId,
                                       String publicGroupSetCd,
                                       String publicGroupCd)
                                throws MapperException
プライマリーキーで特定されるメニューの利用権限を保有するパブリックグループの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
menuId - メニューID
publicGroupSetCd - グループセットCD
publicGroupCd - グルーピングCD
戻り値:
メニューの利用権限を保有するパブリックグループの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(MenuPublicGroupBaseModel model)
            throws MapperException
メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ挿入します。 引数に指定するメニューの利用権限を保有するパブリックグループの基本モデルは同一の MenuPublicGroupMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するメニューの利用権限を保有するパブリックグループの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
メニューの利用権限を保有するパブリックグループの基本モデルを複数挿入します。 引数に指定するものは同一の MenuPublicGroupMapperの create(String,String,String) で生成されたメニューの利用権限を保有するパブリックグループの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するメニューの利用権限を保有するパブリックグループの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(MenuPublicGroupBaseModel model)
            throws MapperException
メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ更新します。 引数に指定するメニューの利用権限を保有するパブリックグループの基本モデルは同一の MenuPublicGroupMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するメニューの利用権限を保有するパブリックグループの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
メニューの利用権限を保有するパブリックグループの基本モデルを複数更新します。 引数に指定するものは同一の MenuPublicGroupMapperの select 系メソッド から取得されたものかで生成されたメニューの利用権限を保有するパブリックグループの基本モデルの集合である必要があります。

パラメータ:
models - 更新するメニューの利用権限を保有するパブリックグループの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(MenuPublicGroupBaseModel model)
            throws MapperException
メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ削除します。 引数で指定されたメニューの利用権限を保有するパブリックグループの基本モデルに該当するデータのすべての情報を削除します。引数に指定するメニューの利用権限を保有するパブリックグループの基本モデルは同一の MenuPublicGroupMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するメニューの利用権限を保有するパブリックグループの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
メニューの利用権限を保有するパブリックグループの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するメニューの利用権限を保有するパブリックグループの基本モデルは同一の MenuPublicGroupMapperの select 系メソッド から取得されたメニューの利用権限を保有するパブリックグループの基本モデルの集合である必要があります。

パラメータ:
models - 削除するメニューの利用権限を保有するパブリックグループの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuRoleBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuRoleBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface MenuRoleBaseModel
extends BaseModel

メニューの利用権限を保有するロールの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | MENU_ID メニューID
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | ROLE_ID ロールCD
メソッドの概要
String | getMenuId() メニューIDを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getRoleId() ロールCDを取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

MENU_ID

public static final String MENU_ID
メニューID

関連項目:
定数フィールド値

ROLE_ID

public static final String ROLE_ID
ロールCD

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getMenuId

public String getMenuId()
                 throws AccessorException
メニューIDを取得します。

戻り値:
メニューID
例外:
AccessorException - データの取得に失敗した場合

getRoleId

public String getRoleId()
                 throws AccessorException
ロールCDを取得します。

戻り値:
ロールCD
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuRoleMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuRoleMapper

すべてのスーパーインタフェース:
Mapper
public interface MenuRoleMapper
extends Mapper

メニューの利用権限を保有するロールに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
MenuRoleBaseModel | create(String menuId, String roleId) プライマリキーに該当するメニューの利用権限を保有するロールを生成します。
void | delete(Collection models) メニューの利用権限を保有するロールの基本モデルを複数削除します。
void | delete(MenuRoleBaseModel model) メニューの利用権限を保有するロールの基本モデルを1つだけ削除します。
void | insert(Collection models) メニューの利用権限を保有するロールの基本モデルを複数挿入します。
void | insert(MenuRoleBaseModel model) メニューの利用権限を保有するロールの基本モデルを1つだけ挿入します。
MenuRoleBaseModel | select(String menuId, String roleId) プライマリーキーで特定されるメニューの利用権限を保有するロールの基本モデルを取得します。
void | update(Collection models) メニューの利用権限を保有するロールの基本モデルを複数更新します。
void | update(MenuRoleBaseModel model) メニューの利用権限を保有するロールの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public MenuRoleBaseModel create(String menuId,
                                String roleId)
                         throws MapperException
プライマリキーに該当するメニューの利用権限を保有するロールを生成します。

パラメータ:
menuId - メニューID
roleId - ロールCD
戻り値:
プライマリキーに該当するメニューの利用権限を保有するロールの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public MenuRoleBaseModel select(String menuId,
                                String roleId)
                         throws MapperException
プライマリーキーで特定されるメニューの利用権限を保有するロールの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
menuId - メニューID
roleId - ロールCD
戻り値:
メニューの利用権限を保有するロールの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(MenuRoleBaseModel model)
            throws MapperException
メニューの利用権限を保有するロールの基本モデルを1つだけ挿入します。 引数に指定するメニューの利用権限を保有するロールの基本モデルは同一の MenuRoleMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するメニューの利用権限を保有するロールの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
メニューの利用権限を保有するロールの基本モデルを複数挿入します。 引数に指定するものは同一の MenuRoleMapperの create(String,String) で生成されたメニューの利用権限を保有するロールの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するメニューの利用権限を保有するロールの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(MenuRoleBaseModel model)
            throws MapperException
メニューの利用権限を保有するロールの基本モデルを1つだけ更新します。 引数に指定するメニューの利用権限を保有するロールの基本モデルは同一の MenuRoleMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するメニューの利用権限を保有するロールの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
メニューの利用権限を保有するロールの基本モデルを複数更新します。 引数に指定するものは同一の MenuRoleMapperの select 系メソッド から取得されたものかで生成されたメニューの利用権限を保有するロールの基本モデルの集合である必要があります。

パラメータ:
models - 更新するメニューの利用権限を保有するロールの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(MenuRoleBaseModel model)
            throws MapperException
メニューの利用権限を保有するロールの基本モデルを1つだけ削除します。 引数で指定されたメニューの利用権限を保有するロールの基本モデルに該当するデータのすべての情報を削除します。引数に指定するメニューの利用権限を保有するロールの基本モデルは同一の MenuRoleMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するメニューの利用権限を保有するロールの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
メニューの利用権限を保有するロールの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するメニューの利用権限を保有するロールの基本モデルは同一の MenuRoleMapperの select 系メソッド から取得されたメニューの利用権限を保有するロールの基本モデルの集合である必要があります。

パラメータ:
models - 削除するメニューの利用権限を保有するロールの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.system.security.datastore.inf (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.system.security.datastore.inf
インタフェース
AccessControllerBaseModel
AccessControllerDepartmentBaseModel
AccessControllerDepartmentMapper
AccessControllerMapper
AccessControllerPostBaseModel
AccessControllerPostMapper
AccessControllerPublicGroupBaseModel
AccessControllerPublicGroupMapper
AccessControllerRoleBaseModel
AccessControllerRoleMapper
AccountAttributeBaseModel
AccountAttributeMapper
AccountBaseModel
AccountMapper
AccountRoleBaseModel
AccountRoleMapper
BatchBaseModel
BatchMapper
CalendarInfoBaseModel
CalendarInfoInternationalModel
CalendarInfoMapper
DataStoreConst
FavoriteMenuBaseModel
FavoriteMenuMapper
MenuArgumentBaseModel
MenuArgumentMapper
MenuBaseModel
MenuDepartmentBaseModel
MenuDepartmentMapper
MenuInternationalModel
MenuMapper
MenuPostBaseModel
MenuPostMapper
MenuPublicGroupBaseModel
MenuPublicGroupMapper
MenuRoleBaseModel
MenuRoleMapper
RoleBaseModel
RoleInclusionBaseModel
RoleInclusionMapper
RoleInternationalModel
RoleMapper
RoleSummaryBaseModel
RoleSummaryMapper


jp.co.intra_mart.system.security.datastore.inf (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.system.security.datastore.inf

インタフェースの概要
AccessControllerBaseModel | アクセスコントローラ情報の基本モデルです。
AccessControllerDepartmentBaseModel | アクセスコントローラの利用権限を保有する組織の基本モデルです。
AccessControllerDepartmentMapper | アクセスコントローラの利用権限を保有する組織に関連するマッパです。
AccessControllerMapper | アクセスコントローラ情報に関連するマッパです。
AccessControllerPostBaseModel | アクセスコントローラの利用権限を保有する役職の基本モデルです。
AccessControllerPostMapper | アクセスコントローラの利用権限を保有する役職に関連するマッパです。
AccessControllerPublicGroupBaseModel | アクセスコントローラの利用権限を保有するパブリックグループの基本モデルです。
AccessControllerPublicGroupMapper | アクセスコントローラの利用権限を保有するパブリックグループに関連するマッパです。
AccessControllerRoleBaseModel | アクセスコントローラの利用権限を保有するロールの基本モデルです。
AccessControllerRoleMapper | アクセスコントローラの利用権限を保有するロールに関連するマッパです。
AccountAttributeBaseModel | アカウントが保有する属性の基本モデルです。
AccountAttributeMapper | アカウントが保有する属性に関連するマッパです。
AccountBaseModel | アカウントの基本モデルです。
AccountMapper | アカウントに関連するマッパです。
AccountRoleBaseModel | アカウントが保有するロールの基本モデルです。
AccountRoleMapper | アカウントが保有するロールに関連するマッパです。
BatchBaseModel | バッチ情報の基本モデルです。
BatchMapper | バッチ情報に関連するマッパです。
CalendarInfoBaseModel | カレンダーが保有するデータの基本モデルです。
CalendarInfoInternationalModel | カレンダーが保有するデータの国際化モデルです。
CalendarInfoMapper | カレンダーが保有するデータに関連するマッパです。
DataStoreConst | データストアの定数クラス
FavoriteMenuBaseModel | アカウントが保有するメニューの基本モデルです。
FavoriteMenuMapper | アカウントが保有するメニューに関連するマッパです。
MenuArgumentBaseModel | メニューの保有する引数の基本モデルです。
MenuArgumentMapper | メニューの保有する引数に関連するマッパです。
MenuBaseModel | メニュー情報の基本モデルです。
MenuDepartmentBaseModel | メニューの利用権限を保有する組織の基本モデルです。
MenuDepartmentMapper | メニューの利用権限を保有する組織に関連するマッパです。
MenuInternationalModel | メニュー情報の国際化モデルです。
MenuMapper | メニュー情報に関連するマッパです。
MenuPostBaseModel | メニューの利用権限を保有する役職の基本モデルです。
MenuPostMapper | メニューの利用権限を保有する役職に関連するマッパです。
MenuPublicGroupBaseModel | メニューの利用権限を保有するパブリックグループの基本モデルです。
MenuPublicGroupMapper | メニューの利用権限を保有するパブリックグループに関連するマッパです。
MenuRoleBaseModel | メニューの利用権限を保有するロールの基本モデルです。
MenuRoleMapper | メニューの利用権限を保有するロールに関連するマッパです。
RoleBaseModel | ロールの基本モデルです。
RoleInclusionBaseModel | ロール内包の基本モデルです。
RoleInclusionMapper | ロール内包に関連するマッパです。
RoleInternationalModel | ロールの国際化モデルです。
RoleMapper | ロールに関連するマッパです。
RoleSummaryBaseModel | ロールサマリの基本モデルです。
RoleSummaryMapper | ロールサマリに関連するマッパです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.system.security.datastore.inf クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.system.security.datastore.inf の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccountMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.BatchMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.RoleMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel
      • interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoInternationalModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuInternationalModel
      • interface jp.co.intra_mart.system.security.datastore.inf.RoleInternationalModel
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.system.security.datastore.inf の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.system.security.datastore.inf の使用

jp.co.intra_mart.system.security.datastore.inf を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf により使用される jp.co.intra_mart.system.security.datastore.inf のクラス
AccessControllerBaseModel
アクセスコントローラ情報の基本モデルです。
AccessControllerDepartmentBaseModel
アクセスコントローラの利用権限を保有する組織の基本モデルです。
AccessControllerPostBaseModel
アクセスコントローラの利用権限を保有する役職の基本モデルです。
AccessControllerPublicGroupBaseModel
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルです。
AccessControllerRoleBaseModel
アクセスコントローラの利用権限を保有するロールの基本モデルです。
AccountAttributeBaseModel
アカウントが保有する属性の基本モデルです。
AccountBaseModel
アカウントの基本モデルです。
AccountRoleBaseModel
アカウントが保有するロールの基本モデルです。
BatchBaseModel
バッチ情報の基本モデルです。
CalendarInfoBaseModel
カレンダーが保有するデータの基本モデルです。
CalendarInfoInternationalModel
カレンダーが保有するデータの国際化モデルです。
FavoriteMenuBaseModel
アカウントが保有するメニューの基本モデルです。
MenuArgumentBaseModel
メニューの保有する引数の基本モデルです。
MenuBaseModel
メニュー情報の基本モデルです。
MenuDepartmentBaseModel
メニューの利用権限を保有する組織の基本モデルです。
MenuInternationalModel
メニュー情報の国際化モデルです。
MenuPostBaseModel
メニューの利用権限を保有する役職の基本モデルです。
MenuPublicGroupBaseModel
メニューの利用権限を保有するパブリックグループの基本モデルです。
MenuRoleBaseModel
メニューの利用権限を保有するロールの基本モデルです。
RoleBaseModel
ロールの基本モデルです。
RoleInclusionBaseModel
ロール内包の基本モデルです。
RoleInternationalModel
ロールの国際化モデルです。
RoleSummaryBaseModel
ロールサマリの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


RoleBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース RoleBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface RoleBaseModel
extends BaseModel

ロールの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | CATEGORY カテゴリ
static String | DISPLAY_NAME ロール表示名
static String | NAME ロール名
static String | NOTES 備考
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | ROLE_ID ロールID
メソッドの概要
String | getCategory() カテゴリを取得します。
String | getDisplayName() ロール表示名を取得します。
String | getDisplayName(Locale locale) ロール表示名を取得します。
String | getName() ロール名を取得します。
String | getNotes() 備考を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getRoleId() ロールIDを取得します。
RoleInternationalModel | selectRoleInternationalModel(Locale locale) 指定された言語に該当するロールの国際化モデルを取得します。
void | setCategory(String category) カテゴリを設定します。
void | setDisplayName(String displayName) ロール表示名を設定します。
void | setDisplayName(String displayName, Locale locale) ロール表示名を設定します。
void | setName(String name) ロール名を設定します。
void | setNotes(String notes) 備考を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ROLE_ID

public static final String ROLE_ID
ロールID

関連項目:
定数フィールド値

NAME

public static final String NAME
ロール名

関連項目:
定数フィールド値

CATEGORY

public static final String CATEGORY
カテゴリ

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

DISPLAY_NAME

public static final String DISPLAY_NAME
ロール表示名

関連項目:
定数フィールド値
メソッドの詳細

getRoleId

public String getRoleId()
                 throws AccessorException
ロールIDを取得します。

戻り値:
ロールID
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName()
               throws AccessorException
ロール名を取得します。

戻り値:
ロール名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
ロール名を設定します。

パラメータ:
name - ロール名
例外:
AccessorException - データの設定に失敗した場合

getCategory

public String getCategory()
                   throws AccessorException
カテゴリを取得します。

戻り値:
カテゴリ
例外:
AccessorException - データの取得に失敗した場合

setCategory

public void setCategory(String category)
                 throws AccessorException
カテゴリを設定します。

パラメータ:
category - カテゴリ
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getDisplayName

public String getDisplayName()
                      throws AccessorException
ロール表示名を取得します。

戻り値:
ロール表示名
例外:
AccessorException - データの取得に失敗した場合

getDisplayName

public String getDisplayName(Locale locale)
                      throws AccessorException
ロール表示名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ロール表示名
例外:
AccessorException - データの取得に失敗した場合

setDisplayName

public void setDisplayName(String displayName)
                    throws AccessorException
ロール表示名を設定します。

パラメータ:
displayName - ロール表示名
例外:
AccessorException - データの設定に失敗した場合

setDisplayName

public void setDisplayName(String displayName,
                           Locale locale)
                    throws AccessorException
ロール表示名を設定します。

パラメータ:
displayName - ロール表示名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectRoleInternationalModel

public RoleInternationalModel selectRoleInternationalModel(Locale locale)
                                                    throws IllegalLocaleException
指定された言語に該当するロールの国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ロールの国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleInclusionBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース RoleInclusionBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface RoleInclusionBaseModel
extends BaseModel

ロール内包の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | CHILD_ROLE_ID 子ロールコード
static String | PARENT_ROLE_ID 親ロールコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getChildRoleId() 子ロールコードを取得します。
String | getParentRoleId() 親ロールコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

PARENT_ROLE_ID

public static final String PARENT_ROLE_ID
親ロールコード

関連項目:
定数フィールド値

CHILD_ROLE_ID

public static final String CHILD_ROLE_ID
子ロールコード

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getParentRoleId

public String getParentRoleId()
                       throws AccessorException
親ロールコードを取得します。

戻り値:
親ロールコード
例外:
AccessorException - データの取得に失敗した場合

getChildRoleId

public String getChildRoleId()
                      throws AccessorException
子ロールコードを取得します。

戻り値:
子ロールコード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleInclusionMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース RoleInclusionMapper

すべてのスーパーインタフェース:
Mapper
public interface RoleInclusionMapper
extends Mapper

ロール内包に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
RoleInclusionBaseModel | create(String parentRoleId, String childRoleId) プライマリキーに該当するロール内包を生成します。
void | delete(Collection models) ロール内包の基本モデルを複数削除します。
void | delete(RoleInclusionBaseModel model) ロール内包の基本モデルを1つだけ削除します。
void | insert(Collection models) ロール内包の基本モデルを複数挿入します。
void | insert(RoleInclusionBaseModel model) ロール内包の基本モデルを1つだけ挿入します。
RoleInclusionBaseModel | select(String parentRoleId, String childRoleId) プライマリーキーで特定されるロール内包の基本モデルを取得します。
void | update(Collection models) ロール内包の基本モデルを複数更新します。
void | update(RoleInclusionBaseModel model) ロール内包の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public RoleInclusionBaseModel create(String parentRoleId,
                                     String childRoleId)
                              throws MapperException
プライマリキーに該当するロール内包を生成します。

パラメータ:
parentRoleId - 親ロールコード
childRoleId - 子ロールコード
戻り値:
プライマリキーに該当するロール内包の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public RoleInclusionBaseModel select(String parentRoleId,
                                     String childRoleId)
                              throws MapperException
プライマリーキーで特定されるロール内包の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
parentRoleId - 親ロールコード
childRoleId - 子ロールコード
戻り値:
ロール内包の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(RoleInclusionBaseModel model)
            throws MapperException
ロール内包の基本モデルを1つだけ挿入します。 引数に指定するロール内包の基本モデルは同一の RoleInclusionMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するロール内包の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
ロール内包の基本モデルを複数挿入します。 引数に指定するものは同一の RoleInclusionMapperの create(String,String) で生成されたロール内包の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するロール内包の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(RoleInclusionBaseModel model)
            throws MapperException
ロール内包の基本モデルを1つだけ更新します。 引数に指定するロール内包の基本モデルは同一の RoleInclusionMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するロール内包の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
ロール内包の基本モデルを複数更新します。 引数に指定するものは同一の RoleInclusionMapperの select 系メソッド から取得されたものかで生成されたロール内包の基本モデルの集合である必要があります。

パラメータ:
models - 更新するロール内包の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(RoleInclusionBaseModel model)
            throws MapperException
ロール内包の基本モデルを1つだけ削除します。 引数で指定されたロール内包の基本モデルに該当するデータのすべての情報を削除します。引数に指定するロール内包の基本モデルは同一の RoleInclusionMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するロール内包の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
ロール内包の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するロール内包の基本モデルは同一の RoleInclusionMapperの select 系メソッド から取得されたロール内包の基本モデルの集合である必要があります。

パラメータ:
models - 削除するロール内包の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleInternationalModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース RoleInternationalModel

すべてのスーパーインタフェース:
InternationalModel, Serializable
public interface RoleInternationalModel
extends InternationalModel

ロールの国際化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getDisplayName() ロール表示名を取得します。
void | setDisplayName(String displayName) ロール表示名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModel から継承したメソッド
getExtendedInternationalModelMap, getLocale, init

メソッドの詳細

getDisplayName

public String getDisplayName()
                      throws AccessorException
ロール表示名を取得します。

戻り値:
ロール表示名
例外:
AccessorException - データの取得に失敗した場合

setDisplayName

public void setDisplayName(String displayName)
                    throws AccessorException
ロール表示名を設定します。

パラメータ:
displayName - ロール表示名
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース RoleMapper

すべてのスーパーインタフェース:
Mapper
public interface RoleMapper
extends Mapper

ロールに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
RoleBaseModel | create(String roleId) プライマリキーに該当するロールを生成します。
void | delete(Collection models) ロールの基本モデルを複数削除します。
void | delete(RoleBaseModel model) ロールの基本モデルを1つだけ削除します。
void | insert(Collection models) ロールの基本モデルを複数挿入します。
void | insert(RoleBaseModel model) ロールの基本モデルを1つだけ挿入します。
RoleBaseModel | select(String roleId) プライマリーキーで特定されるロールの基本モデルを取得します。
void | update(Collection models) ロールの基本モデルを複数更新します。
void | update(RoleBaseModel model) ロールの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public RoleBaseModel create(String roleId)
                     throws MapperException
プライマリキーに該当するロールを生成します。

パラメータ:
roleId - ロールID
戻り値:
プライマリキーに該当するロールの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public RoleBaseModel select(String roleId)
                     throws MapperException
プライマリーキーで特定されるロールの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
roleId - ロールID
戻り値:
ロールの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(RoleBaseModel model)
            throws MapperException
ロールの基本モデルを1つだけ挿入します。 引数に指定するロールの基本モデルは同一の RoleMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入するロールの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
ロールの基本モデルを複数挿入します。 引数に指定するものは同一の RoleMapperの create(String) で生成されたロールの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するロールの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(RoleBaseModel model)
            throws MapperException
ロールの基本モデルを1つだけ更新します。 引数に指定するロールの基本モデルは同一の RoleMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するロールの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
ロールの基本モデルを複数更新します。 引数に指定するものは同一の RoleMapperの select 系メソッド から取得されたものかで生成されたロールの基本モデルの集合である必要があります。

パラメータ:
models - 更新するロールの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(RoleBaseModel model)
            throws MapperException
ロールの基本モデルを1つだけ削除します。 引数で指定されたロールの基本モデルに該当するデータのすべての情報を削除します。引数に指定するロールの基本モデルは同一の RoleMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するロールの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
ロールの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するロールの基本モデルは同一の RoleMapperの select 系メソッド から取得されたロールの基本モデルの集合である必要があります。

パラメータ:
models - 削除するロールの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleSummaryBaseModel (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース RoleSummaryBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface RoleSummaryBaseModel
extends BaseModel

ロールサマリの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | ROLE_ID ロールID
static String | SUMMARY_ROLE_ID サマリロールID
メソッドの概要
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getRoleId() ロールIDを取得します。
String | getSummaryRoleId() サマリロールIDを取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ROLE_ID

public static final String ROLE_ID
ロールID

関連項目:
定数フィールド値

SUMMARY_ROLE_ID

public static final String SUMMARY_ROLE_ID
サマリロールID

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getRoleId

public String getRoleId()
                 throws AccessorException
ロールIDを取得します。

戻り値:
ロールID
例外:
AccessorException - データの取得に失敗した場合

getSummaryRoleId

public String getSummaryRoleId()
                        throws AccessorException
サマリロールIDを取得します。

戻り値:
サマリロールID
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleSummaryMapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース RoleSummaryMapper

すべてのスーパーインタフェース:
Mapper
public interface RoleSummaryMapper
extends Mapper

ロールサマリに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
RoleSummaryBaseModel | create(String roleId, String summaryRoleId) プライマリキーに該当するロールサマリを生成します。
void | delete(Collection models) ロールサマリの基本モデルを複数削除します。
void | delete(RoleSummaryBaseModel model) ロールサマリの基本モデルを1つだけ削除します。
void | insert(Collection models) ロールサマリの基本モデルを複数挿入します。
void | insert(RoleSummaryBaseModel model) ロールサマリの基本モデルを1つだけ挿入します。
RoleSummaryBaseModel | select(String roleId, String summaryRoleId) プライマリーキーで特定されるロールサマリの基本モデルを取得します。
void | update(Collection models) ロールサマリの基本モデルを複数更新します。
void | update(RoleSummaryBaseModel model) ロールサマリの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public RoleSummaryBaseModel create(String roleId,
                                   String summaryRoleId)
                            throws MapperException
プライマリキーに該当するロールサマリを生成します。

パラメータ:
roleId - ロールID
summaryRoleId - サマリロールID
戻り値:
プライマリキーに該当するロールサマリの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public RoleSummaryBaseModel select(String roleId,
                                   String summaryRoleId)
                            throws MapperException
プライマリーキーで特定されるロールサマリの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
roleId - ロールID
summaryRoleId - サマリロールID
戻り値:
ロールサマリの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(RoleSummaryBaseModel model)
            throws MapperException
ロールサマリの基本モデルを1つだけ挿入します。 引数に指定するロールサマリの基本モデルは同一の RoleSummaryMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するロールサマリの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
ロールサマリの基本モデルを複数挿入します。 引数に指定するものは同一の RoleSummaryMapperの create(String,String) で生成されたロールサマリの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するロールサマリの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(RoleSummaryBaseModel model)
            throws MapperException
ロールサマリの基本モデルを1つだけ更新します。 引数に指定するロールサマリの基本モデルは同一の RoleSummaryMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するロールサマリの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
ロールサマリの基本モデルを複数更新します。 引数に指定するものは同一の RoleSummaryMapperの select 系メソッド から取得されたものかで生成されたロールサマリの基本モデルの集合である必要があります。

パラメータ:
models - 更新するロールサマリの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(RoleSummaryBaseModel model)
            throws MapperException
ロールサマリの基本モデルを1つだけ削除します。 引数で指定されたロールサマリの基本モデルに該当するデータのすべての情報を削除します。引数に指定するロールサマリの基本モデルは同一の RoleSummaryMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するロールサマリの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
ロールサマリの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するロールサマリの基本モデルは同一の RoleSummaryMapperの select 系メソッド から取得されたロールサマリの基本モデルの集合である必要があります。

パラメータ:
models - 削除するロールサマリの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


すべてのクラス (javadoc_entire 6.1.14 API)

 すべてのクラス
AbsoluteLinkFilter
AbstractComponent
AbstractController
AbstractDrawer
AbstractDualComparator
AbstractDualComparator
AbstractExportManagerClient
AbstractFilter
AbstractHttpServletResponseEventConfig
AbstractHttpServletResponseEventController
AbstractHttpServletResponseEventListener
AbstractHttpSessionManager
AbstractImportManagerClient
AbstractMessageReporter
AbstractMessageReporter
AbstractSocketConnectionDistributor
AbstractSocketConnectionDistributor
AbstractTreeNodeContainer
AccEmployeePayPostController
AccessController
AccessControllerAccessor
AccessControllerBaseModel
AccessControllerDepartmentBaseModel
AccessControllerDepartmentMapper
AccessControllerExporter
AccessControllerImporter
AccessControllerManager
AccessControllerMapper
AccessControllerPermissionSelector
AccessControllerPostBaseModel
AccessControllerPostMapper
AccessControllerPostWriterListener
AccessControllerPublicGroupBaseModel
AccessControllerPublicGroupMapper
AccessControllerQueryWriterListener
AccessControllerReaderDecorator
AccessControllerRoleBaseModel
AccessControllerRoleMapper
AccessSecurityConfigException
AccessSecurityCreateException
AccessSecurityDeleteException
AccessSecurityException
AccessSecurityExportException
AccessSecurityImportException
AccessSecurityListenerExcpetion
AccessSecurityManager
AccessSecurityReadException
AccessSecurityRuntimeException
AccessSecurityUpdateException
AccessSecurityWriteException
AccessibleLinkHTTPActionEventFilterHandler
AccessorClosedException
AccessorException
AccessorIllegalPropertyValueException
AccessorSystemException
Account
AccountAccessor
AccountAttributeBaseModel
AccountAttributeMapper
AccountBaseModel
AccountChangedListener
AccountExporter
AccountGl
AccountImporter
AccountManager
AccountManager
AccountMapper
AccountPayable
AccountPostWriterListener
AccountQueryWriterListener
AccountReaderDecorator
AccountRole
AccountRoleBaseModel
AccountRoleMapper
AccountRolePermissionSelector
AccountSecurityHTTPActionEventFilterHandler
AccountTax
AcsData
AcssecurityException
ActionListener
ActivationKey
ActiveSessionAccessor
ActiveSessionBindingListener
ActiveSessionException
ActiveSessionFilter
ActiveSessionInfo
ActiveSessionInvalidatedByForceException
ActiveSessionManager
ActiveSessionNotExistException
ActivityFrameworkHTTPActionEventFilterHandler
ActivityHTTPActionEventHandler
AdminMenuAccessor
AdminMenuExporter
AdminMenuImporter
AdminMenuInclusion
AdminMenuManager
AdminMenuPermissionSelector
AdminMenuPostWriterListener
AdminMenuQueryWriterListener
AdminMenuReaderDecorator
AdvancedOutputStreamWriter
AdvancedOutputStreamWriter
AllVersions
AllowedBusTract
Application
ApplicationException
ApplicationInfo
AttachmentFile
Attribute
AttributeType
AutoDetectedDataSource
AutoDetectedUserInfo
BASE64DecodeInputStream
BASE64DecodeInputStream
BASE64DecodeOutputStream
BASE64DecodeOutputStream
BASE64EncodeOutputStream
BASE64EncodeOutputStream
BadRequestException
Bank
BankController
BankDataInfo
BankList
BapiController
BapiHash
BapiReturn
BarGraphDrawer
BarGraphObject
BaseAccessor
BaseModel
BaseModel
BaseModelContext
BaseTable
Batch
BatchAccessor
BatchBaseModel
BatchExporter
BatchImporter
BatchManager
BatchMapper
BatchPostWriterListener
BatchProcessException
BatchQueryWriterListener
BatchRa
BatchReaderDecorator
BatchSystemException
BillingDataIn
BillingDocCreateMultiple
BillingDocCreateMultipleController
BillingDocGetDetail
BillingDocGetDetailController
BillingDocGetList
BillingDocGetListController
BillingDocumentDetail
BillingDocumentDetailList
BrowseString
BusinessArea
BusinessAreaController
BusinessAreaList
CCardDataIn
CGIEnvironment
CalendarAccessor
CalendarExporter
CalendarImporter
CalendarInfo
CalendarInfoBaseModel
CalendarInfoInternationalModel
CalendarInfoMapper
CalendarManager
CalendarPlugin
CalendarPluginAutumnalEquinox
CalendarPluginEndOfTheMonth
CalendarPluginInfo
CalendarPluginLastDayInTheMonth
CalendarPluginMondayMakeupHoliday
CalendarPluginVernalEquinox
CalendarPostWriterListener
CalendarQueryWriterListener
CalendarReaderDecorator
CategorizedCalendarInfo
CategoryDetail
CategoryDetailBaseModel
CategoryDetailInternational
CategoryDetailInternationalModel
CategoryDetailMapper
CategoryManager
CateogryClass
CateogryClassBaseModel
CateogryClassInternational
CateogryClassInternationalModel
CateogryClassMapper
CfgsBlob
CfgsInst
CfgsPartOf
CfgsRef
CfgsRefInst
CfgsValue
CfgsVk
ChangedListenerException
CharacterEncoder
CharacterEncoder
CharacterSetManager
CircleGraphDrawer
CircleGraphObject
ClientData
ClientDataList
ClientTypeInfo
ColorPatternInfo
Column
ColumnMapping
CommandLineArgument
CommonCenterGrpGetDetail
Company
Company
CompanyBaseModel
CompanyCategory
CompanyCategoryBaseModel
CompanyCategoryMapper
CompanyCategoryTerminable
CompanyCategoryTerminableModel
CompanyChangedControllerListener
CompanyChangedListener
CompanyChangedMenuListener
CompanyController
CompanyDataInfo
CompanyExportManager
CompanyExportManagerClient
CompanyImportManager
CompanyImportManagerClient
CompanyImporter
CompanyList
CompanyManager
CompanyMapper
CompanyPost
CompanyPostBaseModel
CompanyPostExportManager
CompanyPostExportManagerClient
CompanyPostImportManager
CompanyPostImportManagerClient
CompanyPostImporter
CompanyPostMapper
CompanyPostTerminable
CompanyPostTerminableInternational
CompanyPostTerminableInternationalModel
CompanyPostTerminableModel
CompanyTerminable
CompanyTerminableInternational
CompanyVersion
CompanyVersionBaseModel
CompanyVersionMapper
ComponentNameCreator
ComponentUtil
ConInfo
ConcreteHTTPActionEventHandler
Cond
ConditionDataIn
ConditionsIn
ConditionsInX
Config
Configuration
ConfigurationFactory
ConfigurationUserInfo
ConnectionManager
ConnectorModel
ContractLimits
ContractService
ContractServiceAccount
ContractServiceText
ControllerConverter
ControllerConverterConfig
ControllerConverterConfigImpl
ControllerConverterException
ControllerConverterModel
ControllerObject
ControllingArea
ControllingAreaController
ControllingAreaList
Convertor
CoreAttributes
CostCenter
CostCenterController
CostCenterGroupGetDetail
CostCenterGroupGetDetailController
CostCenterList
Counter
Counter
CreatorDataIn
CreditorGetDetail
CreditorGetDetailController
Cryption
CsvAccountBackup
CurlFieldBean
CurlRecordBeanIF
CurlXMLComposer
CurlXMLParser
CurrencyAmount
CurrencyManager
DAO
DAOAdapter
DAOException
DBConnector
DBDAO
DBResultAdapter
DBResultArrayAdapter
DBResultBigDecimalAdapter
DBResultBigIntAdapter
DBResultBinaryAdapter
DBResultBlobAdapter
DBResultBooleanAdapter
DBResultByteAdapter
DBResultClobAdapter
DBResultDateAdapter
DBResultDoubleAdapter
DBResultImTimestampAdapter
DBResultIntegerAdapter
DBResultNullAdapter
DBResultObjectAdapter
DBResultRealAdapter
DBResultRefAdapter
DBResultShortAdapter
DBResultStringAdapter
DBResultStructAdapter
DBResultTimeAdapter
DBResultTimestampAdapter
DaoModel
DataAccessController
DataAccessException
DataConnectException
DataConnector
DataConnectorException
DataContainer
DataContainerException
DataContainerFactory
DataContainerImpl
DataManager
DataManagerException
DataNotFoundException
DataPropertyException
DataPropertyHandler
DataSourceConnector
DataSourceProvider
DataStoreApplicationException
DataStoreConfigException
DataStoreConst
DataStoreSystemException
DatabaseAccessor
DatabaseColumn
DatabaseExport
DatabaseExportException
DatabaseManager
DatabaseSQLException
DateHandler
DateUtil
DayInfo
DbManager
DbTypes
DbsConnection
Deal
DealBaseModel
DealDetail
DealDetailBaseModel
DealDetailMapper
DealDetailTerminableModel
DealManager
DealMapper
DealPermissionManager
DealTerminable
DealTerminableModel
DealerDepartment
DealerDepartmentBaseModel
DealerDepartmentMapper
DealerPublicGroup
DealerPublicGroupBaseModel
DealerPublicGroupMapper
DealerRole
DealerRoleBaseModel
DealerRoleMapper
DebtorGetDetail
DebtorGetDetailController
DefaultDataPropertyHandler
DefaultDataProvider
DefaultEventPropertyHandler
DefaultEventProvider
DefaultLogAgent
DefaultLogPropertyHandler
DefaultMKServiceResult
DefaultMessagePropertyHandler
DefaultMessagePropertyHandler
DefaultPropertyManager
DefaultServicePropertyHandler
DefaultServiceProvider
DefaultSessionPropertyHandler
DefaultTransition
Delete
DeleteType
DeliveryAddress
Department
DepartmentAttach
DepartmentAttachBaseModel
DepartmentAttachMapper
DepartmentAttachTerminable
DepartmentAttachTerminableModel
DepartmentBaseModel
DepartmentInclusionBaseModel
DepartmentInclusionMapper
DepartmentInfo
DepartmentMain
DepartmentMainBaseModel
DepartmentMainMapper
DepartmentMainTerminable
DepartmentMainTerminableModel
DepartmentMapper
DepartmentStruct
DepartmentTerminable
DepartmentTerminableInternational
DepartmentTerminableInternationalModel
DepartmentTerminableModel
Directory
Directory
DistributesDataPropertyHandler
DistributesEventPropertyHandler
DistributesServicePropertyHandler
DistributionChannelSelection
DocumentHeader
DualComparator
DualComparator
DuplicateException
DuplicateImageIconCodeException
DuplicateImageIconSrcException
DuplicateLoginAccessor
DuplicateLoginDetectedException
DuplicateLoginException
DuplicateLoginHandlingFilter
DuplicateLoginManager
EJBEventListener
EJBEventListenerAgentBean
EJBEventListenerFactory
ElementProperties
EmptyEvent
EmptyParameterHttpServletRequestWrapper
EmptyQueryException
EmptyServiceResult
EmptyUserInfo
EnCodeInterface
EncodingFilter
Entity
Environment
ErrorEvent
ErrorEvent
ErrorEventListener
ErrorEventListener
ErrorHelperBean
ErrorPageProvider
Errors
Event
EventAccessInfo
EventContainer
EventContainerException
EventContainerFactory
EventContainerImpl
EventException
EventFactoryModel
EventFlow
EventFlowInfo
EventGroupModel
EventHistoryInfo
EventItem
EventItemInfo
EventListener
EventListener
EventListener
EventListenerException
EventListenerFactory
EventListenerFactoryParam
EventManager
EventManagerException
EventModelProducer
EventNavigatorAccessor
EventNavigatorConst
EventNavigatorException
EventNavigatorExporter
EventNavigatorHandler
EventNavigatorImporter
EventNavigatorManager
EventNavigatorPermissionSelector
EventNavigatorReaderDecorator
EventPropertyException
EventPropertyHandler
EventQueueController
EventQueueController
EventResult
EventResultItem
EventResultItemInfo
EventScript
EventTrigger
EventTriggerAdapter
EventTriggerException
EventTriggerInfo
EventTriggerList
EventsAttributes
EverydayConditioner
EverydayConditioner
ExceptionHandlingFilter
ExcessiveQueryException
ExchRate
ExchangeRateGetDetail
ExchangeRateGetDetailController
ExpActivity
ExpMessage
ExpWbsElement
ExpWbsHierarchie
ExpWbsMilestone
ExpirationKey
ExportConfigurationReader
ExportConfigurationReaderException
ExportHeader
ExportInitializeException
ExportItem
ExportManager
ExportManagerClient
ExportManagerImpl
ExtendedBaseAccessor
ExtendedBaseAccessorMap
ExtendedBaseModel
ExtendedBaseModel
ExtendedBaseModelMap
ExtendedBaseTable
ExtendedClassLoader
ExtendedDirectory
ExtendedDirectory
ExtendedEntity
ExtendedFile
ExtendedFile
ExtendedGenericBaseModel
ExtendedGenericBaseModelMap
ExtendedGenericInternationalModel
ExtendedGenericInternationalModelMap
ExtendedGenericTerminableInternationalModel
ExtendedGenericTerminableInternationalModelMap
ExtendedGenericTerminableModel
ExtendedGenericTerminableModelMap
ExtendedHttpServletResponse
ExtendedHttpServletResponseWrapper
ExtendedInputStream
ExtendedInputStream
ExtendedInternationalAccessor
ExtendedInternationalAccessorMap
ExtendedInternationalModel
ExtendedInternationalModel
ExtendedInternationalModelMap
ExtendedInternationalTable
ExtendedModel
ExtendedOutputStream
ExtendedOutputStream
ExtendedParamConverter
ExtendedProperties
ExtendedServletException
ExtendedServletResponse
ExtendedSocket
ExtendedSocket
ExtendedTable
ExtendedTerminableAccessor
ExtendedTerminableAccessorMap
ExtendedTerminableInternationalAccessor
ExtendedTerminableInternationalAccessorMap
ExtendedTerminableInternationalModel
ExtendedTerminableInternationalModel
ExtendedTerminableInternationalModelMap
ExtendedTerminableInternationalTable
ExtendedTerminableModel
ExtendedTerminableModel
ExtendedTerminableModelMap
ExtendedTerminableTable
ExtendedThread
ExtendedThread
ExtendsImport
ExtendsImportManager
Extension
ExtensionIn
ExtensionIn
ExtensionInX
ExtensionOut
ExternalDirectory
ExternalMemory
FavoriteMenu
FavoriteMenuBaseModel
FavoriteMenuMapper
FileReporter
FileReporter
FileSender
FileSizeConditioner
FileSizeConditioner
FileUploadFilter
Filter
FilterComparator
FilterComparator
FilterHTTPActionEvent
FilterHTTPActionEventChain
FilterMessageReporter
FilterMessageReporter
FilterServletInputStream
FixedSizeMap
FixedSizeMap
ForbiddenException
ForecastParameters
ForecastParametersList
ForecastValues
FormTEI
FormTag
FormTagBeanInfo
FormatValidator
FoundationException
FoundationRuntimeException
FrameTEI
FrameTag
FrameTagBeanInfo
FrameworkException
FrameworkParameterSettingFilter
FrameworkRuntimeException
FrameworkTagException
FrameworkTagParam
FunctionContainer
FunctionContainerFile
GCConditioner
GarbageController
GeneralDataInfo
GenericAttributes
GenericBaseModel
GenericEJBEventListener
GenericEJBEventListenerAgent
GenericEJBEventListenerAgentBean
GenericEJBEventListenerAgentHome
GenericEJBEventListenerAgentLocal
GenericEJBEventListenerAgentLocalHome
GenericEJBEventListenerFactory
GenericEJBEventListenerLocal
GenericEJBEventListenerLocalFactory
GenericEventListener
GenericEventListenerFactory
GenericInternationalModel
GenericInternationalModelMap
GenericTerminableInternationalModel
GenericTerminableInternationalModelMap
GenericTerminableModel
GenericTerminableModelMap
GenericURLBuilder
GlAcc
GlAccController
GlAccList
GoodsMvtCode
GoodsMvtCreate
GoodsMvtCreateController
GoodsMvtGetItems
GoodsMvtGetItemsController
GoodsMvtHeader
GoodsMvtHeaderList
GoodsMvtHeadret
GoodsMvtItem
GoodsMvtItems
GoodsMvtSerialNumber
GroupActiveSessionRegister
GroupSecurityHTTPActionEventFilterHandler
GroupSuperUserAccessor
GroupSuperUserInitialServlet
GroupSuperUserPostWriterListener
GroupSuperUserQueryWriterListener
GroupSuperUserReaderDecorator
HTMLEncoder
HTTPActionEvent
HTTPActionEventClientContext
HTTPActionEventContent
HTTPActionEventContext
HTTPActionEventEntityHandler
HTTPActionEventException
HTTPActionEventFilterHandler
HTTPActionEventHandler
HTTPActionEventHandlerException
HTTPActionEventHandlerParameterException
HTTPActionEventListenerContext
HTTPActionEventResult
HTTPActionEventResultWrapper
HTTPActionEventURL
HTTPContext
HTTPContextHandlingFilter
HTTPContextManager
HalfKanaTransrateListener
HeadData
HeaderIn
HeaderInX
HelperBean
HelperBeanException
HelperBeanTEI
HelperBeanTag
HelperBeanTagBeanInfo
HexInputStream
HexInputStream
HexOutputStream
HexOutputStream
HierarchyNodes
HierarchyValues
HomeDirectory
HttpServletRequestMessageBodyWrapper
HttpServletRequestMessageBodyWrapperBuilder
HttpServletResponseEventComponentBuilder
HttpServletResponseEventConfig
HttpServletResponseEventController
HttpServletResponseEventControllerBuilder
HttpServletResponseEventControllerException
HttpServletResponseEventException
HttpServletResponseEventFilter
HttpServletResponseEventFilterException
HttpServletResponseEventListener
HttpServletResponseEventListenerException
HttpServletResponseEventValidator
HttpServletResponseEventValidatorException
HttpSessionFactory
HttpSessionManager
HttpSessionManagerFactory
HttpSessionMonitoringFilter
HttpSessionMonitoringListener
HttpSessionObject
I18nAttributes
IMContainer
IMContainerException
IMContainerFactory
IMDiskFileItem
IMDiskFileItemFactory
IMFileItemFactory
IMMultipartStream
IMServletFileUpload
INonTransaction
Identifier
IllegalArgumentException
IllegalExtensionException
IllegalLocaleException
IllegalPasswordException
IllegalRelationshipException
IllegalSessionException
IllegalSystemException
IllegalTermException
ImAjaxUtil
ImageIconException
ImageIconInfo
ImageIconManager
ImageIconMessageBundle
ImpWbsElement
ImportConfigurationReader
ImportConfigurationReaderException
ImportException
ImportInitializeException
ImportManager
ImportManagerClient
ImportManagerImpl
InitialFile
InitialPageSessionHandlingFilter
InputCheck
InquiryCreateFromData2
InquiryCreateFromData2Controller
InternalOrderGetDetail
InternalOrderGetDetailController
InternalOrderGetList
InternalOrderGetListController
InternationArticleNumbers
InternationalAccessor
InternationalAccessorMap
InternationalArtnos
InternationalKey
InternationalModel
InternationalModel
InternationalModelContext
InternationalModelMap
InternationalTable
InternetPortlet
IntramartAction
IntramartConnectFilter
IntramartConnectServlet
IntramartDBConnector
IntramartDBDAO
IntramartDBMapper
IntramartFileServerConnector
IntramartFileServerDAO
IntramartLocaleFilter
IntramartLogAgent
IntramartMessagePropertyHandler
IntramartPageBaseTransition
IntramartSessionFactory
IntramartSessionObject
Item
ItemAttach
ItemAttachBaseModel
ItemAttachImporter
ItemAttachMapper
ItemAttribute
ItemAttributeBaseModel
ItemAttributeInternational
ItemAttributeInternationalModel
ItemAttributeMapper
ItemBaseModel
ItemCatalogue
ItemCatalogueBaseModel
ItemCatalogueMapper
ItemCatalogueMediaManager
ItemCategory
ItemCategoryBaseModel
ItemCategoryImporter
ItemCategoryInternational
ItemCategoryInternationalModel
ItemCategoryManager
ItemCategoryMapper
ItemCategoryStruct
ItemCategoryType
ItemCategoryTypeBaseModel
ItemCategoryTypeMapper
ItemImporter
ItemManager
ItemMapper
ItemTemplate
ItemTemplateBaseModel
ItemTemplateDetail
ItemTemplateDetailBaseModel
ItemTemplateDetailInternational
ItemTemplateDetailInternationalModel
ItemTemplateDetailMapper
ItemTemplateImporter
ItemTemplateInternational
ItemTemplateInternationalModel
ItemTemplateManager
ItemTemplateMapper
ItemTerminable
ItemTerminableInternational
ItemTerminableInternationalModel
ItemTerminableModel
ItemUnitManager
ItemsIn
ItemsInX
J2eeFwPortlet
JDBCConnector
JavaMailPropertyException
JavaMailPropertyHandler
JavaMailPropertyHandlerInitializerImpl
JavaMailSender
JspPortlet
Keys
LDAPContextInfoBuilder
LDAPContextInfoModel
LDAPUserCertification
LDAPUserCertification
LengthRequiredException
LengthValidator
LicenseManager
Lifetime
LifetimeType
LifoValuationData
LimitedSessionHTTPActionEventFilterHandler
Limits
LineGraphDrawer
LineGraphObject
LineProperty
LineReportFilter
LineReportFilter
LinkPageInfo
LinkTEI
LinkTag
LinkTagBeanInfo
LocaleFilter
LocaleInfo
LocaleProvider
Localhost
Localhost
Lock
LockMonitor
LockMonitor
LogAgent
LogAgentParam
LogConstant
LogConstraint
LogManager
LogPropertyException
LogPropertyHandler
LoggingTransactionManager
LoggingUserTransaction
LogicSwitch
LoginGroup
LoginGroupAccessor
LoginGroupDBConnector
LoginGroupDBDAO
LoginGroupDataSource
LoginGroupManager
LoginGroupPostWriterListener
LoginGroupQueryWriterListener
LoginGroupReaderDecorator
LoginInfo
LoginRequestInfo
Logingp
LogoutInitialUrlValidator
LogoutServlet
LuxuryResponseWriterFilter
MKConst
MKControllerConverter
MKControllerObject
MKError
MKErrors
MKErrorsResult
MKRuntimeException
MKServiceResult
MKSystemException
MKTransition
Mail
MailAddress
MailSendEvent
MailSendListener
MailSender
MailSenderException
MainPageImportLoginGroupPostWriterListener
MainPagePatternInfo
ManagerException
ManufacturerPartNumb
Mapper
MapperDAOException
MapperException
MapperFactory
MasterData
MaterialAvailability
MaterialAvailabilityController
MaterialDescription
MaterialGetAll
MaterialGetAllController
MaterialGetList
MaterialGetListController
MaterialLongText
MaterialRa
MaterialSaveReplica
MaterialSaveReplicaController
MaterialShortDescsel
MaterialText
MatnrList
MatnrSelection
MenuAccessor
MenuArgumentBaseModel
MenuArgumentMapper
MenuBaseModel
MenuDepartmentBaseModel
MenuDepartmentMapper
MenuExporter
MenuImporter
MenuInclusion
MenuInternationalModel
MenuItem
MenuLinkSetPortlet
MenuManager
MenuMapper
MenuPermissionSelector
MenuPostBaseModel
MenuPostMapper
MenuPostWriterListener
MenuPublicGroupBaseModel
MenuPublicGroupMapper
MenuQueryWriterListener
MenuReaderDecorator
MenuRoleBaseModel
MenuRoleMapper
MenuServlet
MenuTree
MessageManager
MessageManager
MessageManager
MessageManagerException
MessageManagerException
MessageParamTag
MessagePropertyException
MessagePropertyException
MessagePropertyHandler
MessagePropertyHandler
MessagePropertyParam
MessageReporter
MessageReporter
MessageTEI
MessageTag
MobileEasyLoginAuAnalyzer
MobileEasyLoginAuHdmlAnalyzer
MobileEasyLoginDocomoAnalyzer
MobileEasyLoginDocomoMoveAnalyzer
MobileEasyLoginJphoneAnalyzer
MobileEasyLoginSoftBankAnalyzer
MobileEasyLoginUtil
MobileEasyLoginVodafoneAnalyzer
MobileUserAgentProvider
Model
MoveTypeRa
MultiCastReporter
MultiCastReporter
MultiComparator
MultiComparator
MultipartFormData
MultipartFormData
MultipartFormData.Entity
MultipartFormData.Entity
MultipartFormDataResourceBundle
MultipleOutputStream
MultipurposeInternetMailExtensions
MultipurposeInternetMailExtensions
NavigatorAuthenticateItem
NavigatorInfo
NavigatorItem
NetworkAgent
NetworkConnector
NetworkFile
NewArrived
NewArrivedManager
NewArrivedProvider
NoCacheFilter
NoCryption
NoFilterException
NoSessionCookieException
NoSessionException
NoSuchPropertyException
NoSuchSessionException
NodeNameComparator
NodePathControllerConverter
NodeTypeComparator
NonceResetListener4MobileEasyLogin
NotExistException
NotExistImageIconException
NotFoundDataSourceException
NotFoundException
NotSupportMethodException
NumericRangeValidator
NumericValidator
OrderCcard
OrderList
OutputSizeConditioner
OutputSizeConditioner
PageBaseCallProvider
ParamAllVersions
ParamBatchRa
ParamBillingDataIn
ParamBillingDocumentDetailList
ParamCCardDataIn
ParamCfgsBlob
ParamCfgsInst
ParamCfgsPartOf
ParamCfgsRef
ParamCfgsRefInst
ParamCfgsValue
ParamCfgsVk
ParamClientDataList
ParamCondHeader
ParamCondItem
ParamConditionDataIn
ParamConditionsIn
ParamConditionsInX
ParamContractLimits
ParamContractService
ParamContractServiceAccount
ParamContractServiceText
ParamConverter
ParamCreatorDataIn
ParamDeliveryAddress
ParamErrors
ParamExportHeader
ParamExportItem
ParamExtension
ParamExtensionIn
ParamExtensionIn
ParamExtensionInX
ParamForecastParametersList
ParamForecastValues
ParamGoodsMvtCode
ParamGoodsMvtHeader
ParamGoodsMvtHeaderList
ParamGoodsMvtHeadret
ParamGoodsMvtItem
ParamGoodsMvtItems
ParamGoodsMvtSerialNumber
ParamHeadData
ParamHeader
ParamHeaderIn
ParamHeaderInX
ParamHeaderText
ParamInternationalArtnos
ParamItem
ParamItemText
ParamItemsIn
ParamItemsInX
ParamKeys
ParamLimits
ParamLogicSwitch
ParamMaterialDescription
ParamMaterialLongText
ParamMaterialRa
ParamMoveTypeRa
ParamOrderCcard
ParamPartner
ParamPartnerAddresses
ParamPartners
ParamPlanningDataList
ParamPlantDataList
ParamPlantRa
ParamProfitSegment
ParamPrtData
ParamPstngDateRa
ParamPurchaseAccount
ParamPurchaseSchedule
ParamRefDocRange
ParamReturnMessages
ParamSalesDataList
ParamSalesOrders
ParamSchedulesIn
ParamSchedulesInX
ParamSender
ParamSpecStockRa
ParamStatusInfo
ParamStgeLocRa
ParamStorageLocationDataList
ParamStorageTypeDataList
ParamSuccess
ParamTag
ParamTaxClassifications
ParamText
ParamTextDataIn
ParamTotalConsumption
ParamTrEvTypeRa
ParamUnitSofmeasure
ParamUnplndConsumption
ParamUserNameRa
ParamValuationDataList
ParamVendorAddress
ParamVendorRa
ParamVersions
ParamWarehouseNumberDataList
ParamWmdvex
ParamWmdvsx
ParameterManager
ParameterSendable
ParameterSourceProvider
Partner
PartnerAddresses
Partners
PasswordHistory
PasswordHistoryAccessor
PasswordHistoryAccountChangedListener
PasswordHistoryException
PasswordHistoryManager
PasswordHistoryManagerInitializerImpl
PasswordHistoryNewArrivedProvider
PasswordHistoryResult
PasswordHistoryUserPageProvider
PasswordSecurityHTTPActionEventFilterHandler
PeriodicConditioner
PeriodicConditioner
PermanentDataArchiveFactory
PermanentDataDirectory
PermanentDirectory
PermanentFile
PermissionManager
PermissionSelector
PlainCompanyPost
PlanningData
PlanningDataList
PlantData
PlantDataList
PlantRa
PlantSelection
Platform
PortFolioDrawer
PortFolioObject
PortalStandardUserPageProvider
Portlet
PortletManager
PortletManagerException
PortletMapping
PostInfo
PresentationPage
PresentationPageHTTPActionEventHandler
PresentationPagePortlet
PrimaryKeyMapping
PrintStreamReporter
PrintStreamReporter
PrivateGroup
PrivateGroupAttach
PrivateGroupAttachBaseModel
PrivateGroupAttachMapper
PrivateGroupBaseModel
PrivateGroupChangedListener
PrivateGroupManager
PrivateGroupMapper
ProcedureComponent
ProductionResourceToolData
ProfitCenter
ProfitCenterController
ProfitCenterGrpGetDetail
ProfitCenterGrpGetDetailController
ProfitCenterList
ProfitSegment
ProjectDefinition
ProjectGetInfo
ProjectGetInfoController
PropertiesFile
Property
PropertyConfigModel
PropertyDescriptorBox
PropertyHandler
PropertyHandlerException
PropertyHandlerParam
PropertyManager
PropertyManagerException
PropertyModel
PropertyParam
Provider
PrtData
PstngDateRa
PublicGroup
PublicGroupAttach
PublicGroupAttachBaseModel
PublicGroupAttachMapper
PublicGroupAttachTerminable
PublicGroupAttachTerminableModel
PublicGroupBaseModel
PublicGroupCategory
PublicGroupCategoryBaseModel
PublicGroupCategoryMapper
PublicGroupCategoryTerminable
PublicGroupCategoryTerminableModel
PublicGroupChangedControllerListener
PublicGroupChangedListener
PublicGroupChangedMenuListener
PublicGroupExportManager
PublicGroupExportManagerClient
PublicGroupImportManager
PublicGroupImportManagerClient
PublicGroupImporter
PublicGroupInclusionBaseModel
PublicGroupInclusionMapper
PublicGroupInfo
PublicGroupManager
PublicGroupMapper
PublicGroupSet
PublicGroupSetBaseModel
PublicGroupSetMapper
PublicGroupSetTerminable
PublicGroupSetTerminableInternational
PublicGroupStruct
PublicGroupTerminable
PublicGroupTerminableInternational
PublicGroupTerminableInternationalModel
PublicGroupTerminableModel
PublicGroupVersion
PublicGroupVersionBaseModel
PublicGroupVersionMapper
PurchaseAccount
PurchaseGetItemSrel
PurchaseGetItemSrelController
PurchaseHeader
PurchaseHeaderPost
PurchaseHeaders
PurchaseItem
PurchaseItemPost
PurchaseItems
PurchaseOrderPayPost
PurchaseOrderPayPostController
PurchaseOrderPostChangeController
PurchaseRelease
PurchaseReleaseController
PurchaseResetReleaseController
PurchaseSchedule
PurchaseText
QuotationCreateFromData2
QuotationCreateFromData2Controller
RSSParserIF
RadarChartDrawer
RadarChartObject
RefDocRange
ReferenceController
Relationship
ReplaceWriter
ReplaceWriter
ReportFileConditioner
ReportFileConditioner
ReportFileWriter
ReportFileWriter
ReportLevel
ReportLevel
ReportLevelFilter
ReportLevelFilter
RepresentativeReporter
RepresentativeReporter
RequestAnalyzer
RequestCharacterEncodingFilter
RequestEntityTooLargeException
RequestException
RequestFormatException
RequestInfo
RequestMessageBodyFilter
RequestParameter
ResourceBundleProperties
ResourceBundleProperties
ResourceFormatException
ResourceFormatException
ResourceLoader
ResourceModel
ResourceNotFoundException
ResourceNotFoundException
ResourceParam
ResponseCharacterEncodingFilter
ResponseContentTypeManagementFilter
ResultPageItem
ResultPageItemInfo
ReturnMessages
ReverseComparator
ReverseComparator
Role
RoleAccessor
RoleBaseModel
RoleChangedAccountListener
RoleChangedControllerListener
RoleChangedListener
RoleChangedMenuListener
RoleExporter
RoleImporter
RoleInclusionBaseModel
RoleInclusionMapper
RoleInternationalModel
RoleManager
RoleManager
RoleMapper
RolePostWriterListener
RoleQueryWriterListener
RoleReaderDecorator
RoleSummaryBaseModel
RoleSummaryMapper
RssPortlet
S2DataAccessController
S2DataContainer
S2EventContainer
S2EventListenerFactory
S2ServiceContainer
SAPAccountingAppException
SAPAccountingSystemException
SAPAuthAppException
SAPAuthSystemException
SAPBapiReturnErrMessageExistException
SAPConnectorMessageBundle
SAPException
SAPFinancialAppException
SAPFinancialSystemException
SAPGeneralAppException
SAPGeneralSystemException
SAPModuleAppException
SAPModuleSystemException
SAPPurchaseAppException
SAPPurchaseSystemException
SAPRuntimeException
SAPSalesAppException
SAPSalesSystemException
SSORequestAnalyzer
SalesData
SalesDataList
SalesOrderCreateFromDat2
SalesOrderCreateFromDat2Controller
SalesOrderGetList
SalesOrderGetListController
SalesOrderGetStatus
SalesOrderGetStatusController
SalesOrders
SalesOrganisationSelection
SapAuthInfoBundle
SapClient
SapClientManager
SapClientNoLoadBalancing
SapClientPool
SapClientPoolManager
SapClientPoolNoLoadBalancing
SapClientPoolWithLoadBalancing
SapClientWithLoadBalancing
SapConnector
SapRepositoryManager
SaveEventHistoryInfo
SaveEventResultItemInfo
Scheduler
SchedulesIn
SchedulesInX
ScriptCompileException
ScriptRuntimeException
ScriptValue
SearchableClassLoader
SearchableHttpServletResponseWrapper
SecurityConstraint
SelectItem
SelectItemInfo
Selection
Sender
SequenceComparator
SequenceComparator
ServerConnector
ServiceContainer
ServiceContainerException
ServiceContainerFactory
ServiceContainerImpl
ServiceController
ServiceControllerAdapter
ServiceControllerException
ServiceFrameworkHTTPActionEventHandler
ServiceManager
ServiceManagerException
ServicePropertyException
ServicePropertyHandler
ServiceResult
ServiceSecurityFilter
ServiceServlet
ServiceServletException
ServiceUnavailableException
ServiceUtils
ServletHTTPActionEventHandler
SessionConfig
SessionFactory
SessionFactory
SessionFactoryException
SessionFilter
SessionFilter
SessionInfo
SessionManager
SessionManagerException
SessionMemory
SessionObject
SessionObjectException
SessionPropertyException
SessionPropertyHandler
SessionQuery
ShortCutAccessor
ShortCutInfo
ShortCutManager
ShutdownEventController
ShutdownListener
SimpleControllerConverter
SimpleHttpServletResponseEventListener
SocketConnection
SocketConnection
SocketConnectionDistributor
SocketConnectionDistributor
SocketConnectionDistributorFactory
SocketConnectionManager
SocketConnectionManager
SocketEventListener
SocketEventListener
SocketPool
SocketPool
SourceProviderHandler
SpecStockRa
StandardAccessControllerAccessor
StandardAccessControllerBackup
StandardAccountAccessor
StandardAccountBackup
StandardActiveSessionAccessor
StandardAdminMenuBackup
StandardBatchAccessor
StandardBatchBackup
StandardCalendarAccessor
StandardCalendarBackup
StandardCompanyImporter
StandardCompanyPostImporter
StandardCryption
StandardDuplicateLoginAccessor
StandardEJBEventListener
StandardEJBEventListenerAgent
StandardEJBEventListenerAgentBean
StandardEJBEventListenerAgentHome
StandardEJBEventListenerFactory
StandardErrorPageProvider
StandardEventListener
StandardEventListenerFactory
StandardEventNavigatorAccessor
StandardEventNavigatorExporter
StandardEventNavigatorImporter
StandardGroupSuperUserPageProvider
StandardHttpServletResponseEventControllerBuilder
StandardItemAttachImporter
StandardItemCategoryImporter
StandardItemImporter
StandardItemTemplateImporter
StandardMail
StandardMenuAccessor
StandardMenuBackup
StandardPasswordHistoryAccessor
StandardPortlet
StandardPublicGroupImporter
StandardRequestAnalyzer
StandardRoleAccessor
StandardRoleBackup
StandardShortCutAccessor
StandardSuperUserCertification
StandardSuperUserPageProvider
StandardUpdateAccessor
StandardUserCertification
StandardUserImporter
StandardUserPageProvider
StatusInfo
StdErr
StdMaterialGetIntNumber
StdMaterialGetIntNumberController
StdMaterialGetIntNumberList
StdOut
StgeLocRa
StorageDirectory
StorageLocationData
StorageLocationDataList
StorageLocationSelect
StorageTypeData
StorageTypeDataList
StrutsConnectFilter
SubmitLinkTag
SubmitLinkTagBeanInfo
SubmitTEI
SubmitTag
SubmitTagBeanInfo
Success
SuperCertification
SuperCertificationListener
SuperUser
SuperUserAccessor
SuperUserInitialServlet
SuperUserNoCertification
SuperUserPostWriterListener
SuperUserQueryWriterListener
SuperUserReaderDecorator
SupplierDetail
SupplierExistenceCheck
SupplierExistenceCheckController
SupplierGetDetailController
SystemConfigException
SystemDBConnector
SystemDBDAO
SystemDataSource
SystemErrorReporter
SystemException
SystemManager
SystemReporter
SystemSourceProvider
SystemStatus
Table
TagWriter
TaxClassifications
TemporaryDirectory
TemporaryFile
Term
TermManager
TermManagerException
TerminableAccessor
TerminableAccessorMap
TerminableInternationalAccessor
TerminableInternationalAccessorMap
TerminableInternationalModel
TerminableInternationalModel
TerminableInternationalModelContext
TerminableInternationalModelMap
TerminableInternationalTable
TerminableKey
TerminableModel
TerminableModel
TerminableModelContext
TerminableModelMap
TerminableTable
Text
TextDataIn
TextFileDataPropertyHandler
TextFileEventPropertyHandler
TextFileMessagePropertyHandler
TextFileServicePropertyHandler
ThreadStopListener
ThreadStopListener
ThrowablePrintListener
TitleInfo
TotalConsumption
TrEvTypeRa
Transition
TransitionException
TreasureDirectory
TreasureFile
TreeBranch
TreeLeaf
TreeNode
TreeNodeContainer
TreeNodeProvider
TreeRoot
TrimmedFilterReader
TrimmedFilterWriter
URLAccessFilter
URLBuilder
URLDecodeInputStream
URLDecodeInputStream
URLDecodeOutputStream
URLDecodeOutputStream
URLEncodeOutputStream
URLEncodeOutputStream
URLUtil
UnauthorizedException
UnitBaseModel
UnitMapper
UnitSofmeasure
UnlimitedBufferedOutputStream
UnplndConsumption
UnripeQueryException
UnsupportedNetworkConnectException
UnsupportedNetworkConnectException
UnsupportedProductEditionException
UpdateAccessor
UpdateController
UpdateInfo
UpdateManager
User
UserActiveSessionRegister
UserAttachExportManager
UserAttachExportManagerClient
UserAttachImportManager
UserAttachImportManagerClient
UserBaseModel
UserCertification
UserCertificationListener
UserCertificationServlet
UserChangedListener
UserImporter
UserInfo
UserInfoException
UserInfoUtil
UserInfoWrapper
UserInitialServlet
UserManager
UserMapper
UserNameRa
UserPageProvider
UserProfileExportManager
UserProfileExportManagerClient
UserProfileImportManager
UserProfileImportManagerClient
UserStatus
UserTerminable
UserTerminableInternational
UserTerminableInternationalModel
UserTerminableModel
ValidationException
ValidationExceptionDetail
Validator
ValidatorConfig
ValidatorConfigImpl
ValidatorException
ValidatorMapping
ValidatorModel
ValuationData
ValuationDataList
VariableScope
VendorAddress
VendorRa
Versions
WarehouseNumberData
WarehouseNumberDataList
WebApplicationHTTPActionEventHandler
Wmdvex
Wmdvsx
XMLProperties
XMLUtil
XORInputStream
XORInputStream
XOROutputStream
XOROutputStream
XmlDataPropertyHandler
XmlEventPropertyHandler
XmlLogPropertyHandler
XmlPropertyManager
XmlServicePropertyHandler
XmlSessionPropertyHandler


定数フィールド値 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
  • jp.co.*
jp.co.*

jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle
public static final String | DEFAULT_MULTIPART_PROPERTIES | "jp.co.intra_mart.common.aid.javaee.http.MultipartFormData"
public static final int | DEFAULT_SIZETHRESHOLD | 10240
public static final String | KEY_REPOSITORY | "repository"
public static final String | KEY_SIZE_THRESHOLD | "size_threshold"
public static final String | KEY_USE_COMMONS_FILEUPLOAD | "use_commons_fileupload"

jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel
public static final int | MAX_VALUE | 2147483647
public static final int | MIN_VALUE | -2147483648
public static final int | TYPE_DEBUG | 0
public static final int | TYPE_ERROR | 3
public static final int | TYPE_REPORT | 1
public static final int | TYPE_WARNING | 2

jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter
public static final String OBJECT_PARAM_NAME "object"

jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter
public static final String | NODE_PATH_PREFIX | "PATH_"
public static final String | OBJECT_PARAM_NAME | "object"

jp.co.intra_mart.extension.maskat.util.MKConst
public static final String | MASKAT_COMPONENT_ID_HEAD | "maskat_componentID"
public static final String | MASKAT_DEFAULT_COMPONENT_ID | "onload"
public static final String | MASKAT_EVENT_ID_HEAD | "maskat_eventID"
public static final String | MASKAT_LAYOUT_ID_HEAD | "maskat_layoutID"

jp.co.intra_mart.foundation.database.ConInfo
public static final String | TYPE_DATA_SOURCE | "DataSource"
public static final String | TYPE_GROUP | "Group"
public static final String | TYPE_JDBC | "Jdbc"
public static final String | TYPE_SYSTEM | "System"

jp.co.intra_mart.foundation.database.DatabaseColumn
public static final int | INDEX_UNDEFINED | -2
public static final int | TYPE_DATE | 3
public static final int | TYPE_NUMBER | 2
public static final int | TYPE_STRING | 1
public static final int | TYPE_UNDEFINED | -1

jp.co.intra_mart.foundation.database.DatabaseExport
public static final int | DBTYPE_DB2 | 2
public static final int | DBTYPE_ORACLE | 1
public static final int | DBTYPE_POSTGRESQL | 3
public static final int | DBTYPE_SQLSERVER | 4

jp.co.intra_mart.foundation.database.exception.DatabaseExportException
public static final int | PROCESS_BUSY | 1
public static final int | WRITE_TIMEOUT | 2

jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel
public static final String | CATEGORY_CLASS_CODE | "categoryClassCode"
public static final String | NAME | "name"
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel
public static final String | CATEGORY_CLASS_CODE | "categoryClassCode"
public static final String | CATEGORY_CODE | "categoryCode"
public static final String | NAME | "name"
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | DEPARTMENT_CODE | "departmentCode"
public static final String | POST_CODE | "postCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"
public static final String | USER_CODE | "userCode"

jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel
public static final String | CATEGORY_CLASS_CODE | "categoryClassCode"
public static final String | CATEGORY_CODE | "categoryCode"
public static final String | COMPANY_CODE | "companyCode"
public static final String | DEPARTMENT_CODE | "departmentCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel
public static final String | ADDRESS1 | "address1"
public static final String | ADDRESS2 | "address2"
public static final String | COMPANY_CODE | "companyCode"
public static final String | COUNTRY_CODE | "countryCode"
public static final String | DEPARTMENT_CODE | "departmentCode"
public static final String | EMAIL_ADDRESS1 | "emailAddress1"
public static final String | EMAIL_ADDRESS2 | "emailAddress2"
public static final String | EXTENSION_FAX_NUMBER | "extensionFaxNumber"
public static final String | EXTENSION_NUMBER | "extensionNumber"
public static final String | FAX_NUMBER | "faxNumber"
public static final String | NAME | "name"
public static final String | NAME_ENGLISH | "nameEnglish"
public static final String | NAME_SYLLABARY | "nameSyllabary"
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"
public static final String | TELEPHONE_NUMBER | "telephoneNumber"
public static final String | URL | "url"
public static final String | ZIP_CODE | "zipCode"

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | DEPARTMENT_CODE | "departmentCode"
public static final String | DEPTH | "depth"
public static final String | PARENT_DEPARTMENT_CODE | "parentDepartmentCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | VERSION_CODE | "versionCode"

jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | DEPARTMENT_CODE | "departmentCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | USER_CODE | "userCode"

jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | NAME | "name"
public static final String | NOTES | "notes"
public static final String | POST_CODE | "postCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"

jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | END_DATE | "endDate"
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | START_DATE | "startDate"
public static final String | VERSION_CODE | "versionCode"

jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel
public static final String | CURRENCY_CODE | "currencyCode"
public static final String | CUSTOMER_COMPANY_CODE | "customerCompanyCode"
public static final String | CUSTOMER_DEPARTMENT_CODE | "customerDepartmentCode"
public static final String | DEAL_CODE | "dealCode"
public static final String | DEAL_NAME | "dealName"
public static final String | DEAL_TYPE | "dealType"
public static final int | DEAL_TYPE_BUY | 0
public static final int | DEAL_TYPE_SELL | 1
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | UNIT_PRICE | "unitPrice"

jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | CUSTOMER_COMPANY_CODE | "customerCompanyCode"
public static final String | CUSTOMER_DEPARTMENT_CODE | "customerDepartmentCode"
public static final String | DEAL_CODE | "dealCode"
public static final String | DEPARTMENT_CODE | "departmentCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel
public static final String | AMOUNT | "amount"
public static final String | CUSTOMER_COMPANY_CODE | "customerCompanyCode"
public static final String | CUSTOMER_DEPARTMENT_CODE | "customerDepartmentCode"
public static final String | DEAL_CODE | "dealCode"
public static final String | ITEM_CODE | "itemCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | UNIT_CODE | "unitCode"
public static final String | UNIT_PRICE | "unitPrice"

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel
public static final String | CUSTOMER_COMPANY_CODE | "customerCompanyCode"
public static final String | CUSTOMER_DEPARTMENT_CODE | "customerDepartmentCode"
public static final String | DEAL_CODE | "dealCode"
public static final String | PUBLIC_GROUP_CODE | "publicGroupCode"
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel
public static final String | CUSTOMER_COMPANY_CODE | "customerCompanyCode"
public static final String | CUSTOMER_DEPARTMENT_CODE | "customerDepartmentCode"
public static final String | DEAL_CODE | "dealCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | ROLE_ID | "roleId"

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel
public static final String | ITEM_CATEGORY_CODE | "itemCategoryCode"
public static final String | ITEM_CATEGORY_TYPE_CODE | "itemCategoryTypeCode"
public static final String | ITEM_CODE | "itemCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CD | "recordUserCd"

jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel
public static final String | ITEM_CATEGORY_CODE | "itemCategoryCode"
public static final String | ITEM_CATEGORY_NAME | "itemCategoryName"
public static final String | ITEM_CATEGORY_TYPE_CODE | "itemCategoryTypeCode"
public static final String | NOTES | "notes"
public static final String | PARENT_ITEM_CATEGORY_CODE | "parentItemCategoryCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"

jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel
public static final String | ITEM_CATEGORY_TYPE_CODE | "itemCategoryTypeCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel
public static final String | DATA_TYPE | "dataType"
public static final int | DATA_TYPE_NUMBER | 0
public static final int | DATA_TYPE_STRING | 1
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CD | "recordUserCd"
public static final String | SORT_KEY | "sortKey"
public static final String | TEMPLATE_CODE | "templateCode"
public static final String | TEMPLATE_DETAIL_CODE | "templateDetailCode"
public static final String | TEMPLATE_DETAIL_NAME | "templateDetailName"

jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CD | "recordUserCd"
public static final String | TEMPLATE_CODE | "templateCode"
public static final String | TEMPLATE_NAME | "templateName"

jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel
public static final String | ITEM_CODE | "itemCode"
public static final String | NUMBER_VALUE | "numberValue"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | STRING_VALUE | "stringValue"
public static final String | TEMPLATE_CODE | "templateCode"
public static final String | TEMPLATE_DETAIL_CODE | "templateDetailCode"

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel
public static final String | ITEM_CATALOGUE_CODE | "itemCatalogueCode"
public static final String | ITEM_CODE | "itemCode"
public static final String | MEDIA | "media"
public static final String | MEDIA_CLS | "mediaCls"
public static final int | MEDIA_CLS_FILE | 0
public static final int | MEDIA_CLS_URL | 1
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "SortKey"

jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel
public static final String | ITEM_CAPTION | "itemCaption"
public static final String | ITEM_CODE | "itemCode"
public static final String | ITEM_NAME | "itemName"
public static final String | NOTES | "notes"
public static final String | PRODUCT_MODEL_CODE | "productModelCode"
public static final String | PURCHASE_UNIT_PRICE | "purchaseUnitPrice"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SALES_UNIT_PRICE | "salesUnitPrice"

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel
public static final String | OWNER_CODE | "ownerCode"
public static final String | PRIVATE_GROUP_CODE | "privateGroupCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"
public static final String | USER_CODE | "userCode"

jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel
public static final String | NAME | "name"
public static final String | NAME_ENGLISH | "nameEnglish"
public static final String | NAME_SYLLABARY | "nameSyllabary"
public static final String | NOTES | "notes"
public static final String | OWNER_CODE | "ownerCode"
public static final String | PRIVATE_GROUP_CODE | "privateGroupCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel
public static final String | PUBLIC_GROUP_CODE | "publicGroupCode"
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"
public static final String | USER_CODE | "userCode"

jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel
public static final String | CATEGORY_CLASS_CODE | "categoryClassCode"
public static final String | CATEGORY_CODE | "categoryCode"
public static final String | PUBLIC_GROUP_CODE | "publicGroupCode"
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel
public static final String | NAME | "name"
public static final String | NAME_ENGLISH | "nameEnglish"
public static final String | NAME_SYLLABARY | "nameSyllabary"
public static final String | NOTES | "notes"
public static final String | PUBLIC_GROUP_CODE | "publicGroupCode"
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel
public static final String | DEPTH | "depth"
public static final String | PARENT_PUBLIC_GROUP_CODE | "parentPublicGroupCode"
public static final String | PUBLIC_GROUP_CODE | "publicGroupCode"
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | VERSION_CODE | "versionCode"

jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel
public static final String | END_DATE | "endDate"
public static final String | NOTES | "notes"
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | START_DATE | "startDate"
public static final String | VERSION_CODE | "versionCode"

jp.co.intra_mart.foundation.datastore.application.model.unit.UnitBaseModel
public static final String | UNIT_CODE | "unitCode"
public static final String | UNIT_NAME | "unitName"

jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel
public static final String | ACCOUNT_FLAG | "accountFlag"
public static final String | ADDRESS | "address"
public static final String | AVALIABLE_LOGIN_USER | "1"
public static final String | COUNTRY_CODE | "countryCode"
public static final String | EMAIL_ADDRESS1 | "emailAddress1"
public static final String | EMAIL_ADDRESS2 | "emailAddress2"
public static final String | EXTENSION_FAX_NUMBER | "extensionFaxNumber"
public static final String | EXTENSION_NUMBER | "extensionNumber"
public static final String | FAX_NUMBER | "faxNumber"
public static final String | MOBILE_EMAIL_ADDRESS | "mobileEmailAddress"
public static final String | MOBILE_NUMBER | "mobileNumber"
public static final String | NAME | "name"
public static final String | NAME_ENGLISH | "nameEnglish"
public static final String | NAME_SYLLABARY | "nameSyllabary"
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"
public static final String | TELEPHONE_NUMBER | "telephoneNumber"
public static final String | UNAVALIABLE_LOGIN_USER | "0"
public static final String | URL | "url"
public static final String | USER_CODE | "userCode"
public static final String | ZIP_CODE | "zipCode"

jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil
public static final String | IM_AJAX_USER_AGENT_FIREFOX | "Firefox"
public static final String | IM_AJAX_USER_AGENT_IE | "IE"
public static final String | IM_AJAX_USER_AGENT_NETSCAPE | "Netscape"
public static final String | IM_AJAX_USER_AGENT_OPERA | "Opera"
public static final String | IM_AJAX_USER_AGENT_SAFARI | "Safari"
public static final String | REQUEST_HEADER_NAME_IM_AJAX_REQUEST | "x-jp-co-intra-mart-ajax-request"
public static final String | REQUEST_HEADER_NAME_IM_AJAX_USER_AGENT | "x-jp-co-intra-mart-ajax-user-agent"
public static final String | RESPONSE_HEADER_NAME_IM_AJAX_ERROR_CODE | "x-jp-co-intra-mart-ajax-error-code"
public static final String | RESPONSE_HEADER_NAME_IM_AJAX_ERROR_MESSAGE | "x-jp-co-intra-mart-ajax-error-message"

jp.co.intra_mart.foundation.image.ImageIconInfo
public static final int DEFAULT_SORT_KEY 0

jp.co.intra_mart.foundation.log.LogConstraint
public static final String RESPONSE_HEADER_NAME_NEXT_PAGE_TITLE "x-jp-co-intra-mart-log-next-page-title"

jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener
public static final int | CONTINUE | 0
public static final int | SKIP_LISTENER | 1
public static final int | STOP_MAILSEND | 2

jp.co.intra_mart.foundation.navigator.EventNavigatorConst
public static final String | ATTRIBUTE_TYPE_HISTORY_COUNT | "history_count"
public static final String | COLUMN_NAVIGATOR_ACTION_TYPE | "action_type"
public static final String | COLUMN_NAVIGATOR_ANSWER | "answer"
public static final String | COLUMN_NAVIGATOR_COMPANY_CD | "company_cd"
public static final String | COLUMN_NAVIGATOR_DEPARTMENT_CD | "department_cd"
public static final String | COLUMN_NAVIGATOR_DESCRIPTION | "description"
public static final String | COLUMN_NAVIGATOR_EVENT_FLOW_ID | "event_flow_id"
public static final String | COLUMN_NAVIGATOR_EVENT_ITEM_ID | "event_item_id"
public static final String | COLUMN_NAVIGATOR_EVENT_RESULT_ID | "event_result_id"
public static final String | COLUMN_NAVIGATOR_IDENTIFICATION_ID | "identification_id"
public static final String | COLUMN_NAVIGATOR_LOCALE | "locale"
public static final String | COLUMN_NAVIGATOR_MAX_SORT_NUM | "max_sort_num"
public static final String | COLUMN_NAVIGATOR_NEXT_ITEM_ID | "next_item_id"
public static final String | COLUMN_NAVIGATOR_OPEN | "open_flag"
public static final String | COLUMN_NAVIGATOR_PAGE_URL | "page_url"
public static final String | COLUMN_NAVIGATOR_PARAM_KEY | "param_key"
public static final String | COLUMN_NAVIGATOR_PARAM_VALUE | "param_value"
public static final String | COLUMN_NAVIGATOR_PERMISSION_CHECK_FLAG | "permission_check_flag"
public static final String | COLUMN_NAVIGATOR_POST_CD | "post_cd"
public static final String | COLUMN_NAVIGATOR_PUBLIC_GROUP_CD | "public_group_cd"
public static final String | COLUMN_NAVIGATOR_PUBLIC_GROUP_SET_CD | "public_group_set_cd"
public static final String | COLUMN_NAVIGATOR_QUESTION | "question"
public static final String | COLUMN_NAVIGATOR_RECORD_DATE | "record_date"
public static final String | COLUMN_NAVIGATOR_RECORD_USER | "record_user_cd"
public static final String | COLUMN_NAVIGATOR_RESULT_PAGE_ID | "result_page_id"
public static final String | COLUMN_NAVIGATOR_ROLE_ID | "role_id"
public static final String | COLUMN_NAVIGATOR_SELECT_ITEM_ID | "select_item_id"
public static final String | COLUMN_NAVIGATOR_SORT_NUMBER | "sort_number"
public static final String | COLUMN_NAVIGATOR_START_EVENT_ITEM_ID | "start_event_item_id"
public static final String | COLUMN_NAVIGATOR_TITLE | "title"
public static final String | COLUMN_NAVIGATOR_TYPE | "type"
public static final String | COLUMN_NAVIGATOR_USER_ID | "user_id"
public static final String | CONFIG_FILE | "conf/event-navigator-config.xml"
public static final String | DB_DB2 | "db2"
public static final String | DB_ORACLE | "oracle"
public static final String | DB_POSTGRE | "postgresql"
public static final String | DEFAULT_ACCESSOR | "jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor"
public static final String | DEFAULT_COMMENT | "\u8cea\u554f\u5185\u5bb9\uff11"
public static final String | DEFAULT_CONFIG_PAGE_COUNT | "5"
public static final String | DEFAULT_EXPORTER | "jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter"
public static final String | DEFAULT_IMPORTER | "jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter"
public static final String | DEFAULT_TITLE | "\u8cea\u554f\u5185\u5bb9\uff11"
public static final String | ESCAPE_LEFT_PARENTHESIS | "["
public static final String | ESCAPE_PERCENTAGE | "%"
public static final String | ESCAPE_RIGHT_PARENTHESIS | "]"
public static final String | ESCAPE_STRING | "@"
public static final String | ESCAPE_UNDER_SCORE | "_"
public static final String | EVENT_NAVIGATOR_PERMISSION_SELECTOR | "event-navigator"
public static final String | ID_NAVIGATOR_ACCESS_INFO | "access-info"
public static final String | ID_NAVIGATOR_COMMENT | "comment"
public static final String | ID_NAVIGATOR_COMPANY_ID | "company-cd"
public static final String | ID_NAVIGATOR_DEPARTMENT | "department"
public static final String | ID_NAVIGATOR_DEPARTMENT_ID | "department-cd"
public static final String | ID_NAVIGATOR_EVENT_FLOW | "event-flow"
public static final String | ID_NAVIGATOR_EVENT_FLOW_ID | "event-flow-id"
public static final String | ID_NAVIGATOR_EVENT_FLOW_OPEN | "event-flow-open"
public static final String | ID_NAVIGATOR_EVENT_FLOW_SORT_NUMBER | "event-flow-sort-number"
public static final String | ID_NAVIGATOR_EVENT_ITEM | "event-item"
public static final String | ID_NAVIGATOR_EVENT_ITEM_ID | "event-item_id"
public static final String | ID_NAVIGATOR_EVENT_RESULT | "event-result"
public static final String | ID_NAVIGATOR_EVENT_RESULT_ID | "event-result_id"
public static final String | ID_NAVIGATOR_GROUP_ID | "group-cd"
public static final String | ID_NAVIGATOR_GROUP_SET_ID | "group-set-cd"
public static final String | ID_NAVIGATOR_ITEM_TYPE | "item-type"
public static final String | ID_NAVIGATOR_LINK_PAGE | "link-page"
public static final String | ID_NAVIGATOR_LOCALE | "locale"
public static final String | ID_NAVIGATOR_PARAM | "param"
public static final String | ID_NAVIGATOR_PARAM_KEY | "param-key"
public static final String | ID_NAVIGATOR_PARAM_VALUE | "param-value"
public static final String | ID_NAVIGATOR_POST | "post"
public static final String | ID_NAVIGATOR_POST_ID | "post-cd"
public static final String | ID_NAVIGATOR_PUBLIC_GROUP | "public-group"
public static final String | ID_NAVIGATOR_RESULT_PAGE | "result-page"
public static final String | ID_NAVIGATOR_RESULT_PAGE_ID | "result-page-id"
public static final String | ID_NAVIGATOR_RESULT_PAGE_LIST | "result-page-list"
public static final String | ID_NAVIGATOR_ROLE | "role"
public static final String | ID_NAVIGATOR_ROLE_ID | "role-id"
public static final String | ID_NAVIGATOR_SELECT_ITEM | "select-item"
public static final String | ID_NAVIGATOR_SELECT_ITEM_ID | "select-item_id"
public static final String | ID_NAVIGATOR_SELECT_ITEM_LIST | "select-item-list"
public static final String | ID_NAVIGATOR_TITLE | "title"
public static final String | ID_NAVIGATOR_TITLE_INFO | "title-info"
public static final String | ID_NAVIGATOR_URL | "url"
public static final String | ID_ROOT | "intra-mart"
public static final String | ID_ROOT_NAVIGATOR | "navigator"
public static final String | KIND_NAVIGATOR | "EventNavigator "
public static final String | OPEN_FLG_CLOSE | "close"
public static final String | OPEN_FLG_EDIT | "edit"
public static final String | OPEN_FLG_OPEN | "open"
public static final String | ROOT_FOLDER | "conf/"
public static final String | SAVE_TYPE_FAVORITE | "favorite"
public static final String | SAVE_TYPE_HISTORY | "history"
public static final String | TABLE_B_M_EVENT_DEPARTMENT | "b_m_event_department"
public static final String | TABLE_B_M_EVENT_FLOW | "b_m_event_flow"
public static final String | TABLE_B_M_EVENT_ITEM | "b_m_event_item"
public static final String | TABLE_B_M_EVENT_PAGE | "b_m_event_page"
public static final String | TABLE_B_M_EVENT_PAGE_PARAM | "b_m_event_page_param"
public static final String | TABLE_B_M_EVENT_POST | "b_m_event_post"
public static final String | TABLE_B_M_EVENT_PUBLIC_GROUP | "b_m_event_public_group"
public static final String | TABLE_B_M_EVENT_RESULT | "b_m_event_result"
public static final String | TABLE_B_M_EVENT_ROLE | "b_m_event_role"
public static final String | TABLE_B_M_EVENT_SAVE_RESULT | "b_m_event_save_result"
public static final String | TABLE_B_M_EVENT_SELECT | "b_m_event_select"
public static final String | TABLE_B_M_EVENT_TITLE_INFO | "b_m_event_title_info"
public static final String | TYPE_EVENT | "event"
public static final String | TYPE_RESULT | "result"

jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor
public static final String | DEFAULT_COMMENT | "\u8cea\u554f\u5185\u5bb9\uff11"
public static final String | DEFAULT_FAVORITE | "favorite"
public static final String | DEFAULT_HISTORY | "history"
public static final String | DEFAULT_TITLE | "\u8cea\u554f\u5185\u5bb9\uff11"
public static final String | KIND_NAVIGATOR | "EventNavigator "

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider
public static final String PAGE_PATH "pagePath"

jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet
public static final String PAGE_KIND "internet"

jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet
public static final String PAGE_KIND "framework"

jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet
public static final String PAGE_KIND "jsp"

jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet
public static final String PAGE_KIND "menu"

jp.co.intra_mart.foundation.portal.portlet.model.Portlet
public static final String | DISPLAY_PERCENT | "c"
public static final String | DISPLAY_PIXCEL | "p"

jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet
public static final String PAGE_KIND "pagebase"

jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet
public static final String PAGE_KIND "rss"

jp.co.intra_mart.foundation.security.SecurityConstraint
public static final String | ATTR_CERTIFICATION_MODE | "jp.co.intr_mart.certification.do"
public static final String | ATTR_DO_FILTER | "jp.co.intr_mart.session.filter.do"
public static final String | CP_COOKIE | "jp.co.intra_mart.session.cookie"
public static final int | CR_ERROR | -7
public static final int | CR_LOCKED | -3
public static final int | CR_NG | 0
public static final int | CR_NO_GROUP | -2
public static final int | CR_NO_LICENSE | -1
public static final int | CR_NO_PERMISSION | -6
public static final int | CR_NO_USER | -8
public static final int | CR_OK | 1
public static final int | CR_SESSION_INITIAL | 2
public static final int | CR_SESSION_LOGON | 3
public static final int | CR_SESSION_TIMEOUT | -5
public static final int | CR_SESSION_UNMATCH | -4
public static final String | LT_GROUP | "group"
public static final String | LT_SUPER | "super"
public static final String | LT_USER | "user"
public static final String | RP_CLIENT_TYPE | "im_client_type"
public static final String | RP_ENCODING | "im_encoding"
public static final String | RP_INITIAL_URL | "im_initial_url"
public static final String | RP_LOCALE | "im_locale"
public static final String | RP_LOGIN_GROUP | "im_login_group"
public static final String | RP_LOGIN_TYPE | "im_login_type"
public static final String | RP_PASSWORD | "im_password"
public static final String | RP_SHORTCUT | "im_shortcut"
public static final String | RP_URL | "im_url"
public static final String | RP_URL_SIGN | "im_url_sign"
public static final String | RP_USER | "im_user"
public static final String | SP_CLIENT_TYPE | "jp.co.intra_mart.session.client_type"
public static final String | SP_COLOR_PATTERN_ID | "jp.co.intra_mart.session.color_pattern_id"
public static final String | SP_ENCODING | "jp.co.intra_mart.session.encoding"
public static final String | SP_INITIAL_URL | "jp.co.intra_mart.session.initial.url"
public static final String | SP_LOCALE | "jp.co.intra_mart.session.locale"
public static final String | SP_LOGIN_GROUP | "jp.co.intra_mart.session.group"
public static final String | SP_LOGIN_TIME | "jp.co.intra_mart.session.login_time"
public static final String | SP_LOGIN_TYPE | "jp.co.intra_mart.session.login_type"
public static final String | SP_SHORTCUT | "jp.co.intra_mart.session.shortcut"
public static final String | SP_SIGNATURE | "jp.co.intra_mart.session.signature"
public static final String | SP_URL | "jp.co.intra_mart.session.url"
public static final String | SP_URL_SIGN | "jp.co.intra_mart.session.url.signature"
public static final String | SP_USER | "jp.co.intra_mart.session.user"

jp.co.intra_mart.foundation.security.SessionInfo
public static final String COOKIE_SEPARATOR "|"

jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor
public static final String | APPLICATION_NAME | "jp.co.intramart.foundation.datastore.common"
public static final String | ENTITY_CONTROLLER_DEPARTMENT_NAME | "AccessControllerDepartment"
public static final String | ENTITY_CONTROLLER_NAME | "AccessController"
public static final String | ENTITY_CONTROLLER_POST_NAME | "AccessControllerPost"
public static final String | ENTITY_CONTROLLER_PUBLIC_GROUP_NAME | "AccessControllerPublicGroup"
public static final String | ENTITY_CONTROLLER_ROLE_NAME | "AccessControllerRole"

jp.co.intra_mart.foundation.security.StandardAccountAccessor
public static final String | APPLICATION_NAME | "jp.co.intramart.foundation.datastore.common"
public static final String | ENTITY_NAME_ACCOUNT | "Account"
public static final String | ENTITY_NAME_ACCOUNT_ATTRIBUTE | "AccountAttribute"
public static final String | ENTITY_NAME_ACCOUNT_ROLE | "AccountRole"
public static final String | ENTITY_NAME_FAVORITE_MENU | "FavoriteMenu"
public static final String | ID_CRYPTION_CLASS | "cryption-class"

jp.co.intra_mart.foundation.security.StandardBatchAccessor
public static final String | APPLICATION_NAME | "jp.co.intramart.foundation.datastore.common"
public static final String | ENTITY_NAME | "Batch"

jp.co.intra_mart.foundation.security.StandardCalendarAccessor
public static final String | APPLICATION_NAME | "jp.co.intramart.foundation.datastore.common"
public static final String | ENTITY_NAME | "CalendarInfo"

jp.co.intra_mart.foundation.security.StandardMenuAccessor
public static final String | APPLICATION_NAME | "jp.co.intramart.foundation.datastore.common"
public static final String | ENTITY_NAME_MENU | "Menu"
public static final String | ENTITY_NAME_MENU_ARGUMENT | "MenuArgument"
public static final String | ENTITY_NAME_MENU_DEPARTMENT | "MenuDepartment"
public static final String | ENTITY_NAME_MENU_POST | "MenuPost"
public static final String | ENTITY_NAME_MENU_PUBLIC_GROUP | "MenuPublicGroup"
public static final String | ENTITY_NAME_MENU_ROLE | "MenuRole"

jp.co.intra_mart.foundation.security.StandardRoleAccessor
public static final String | APPLICATION_NAME | "jp.co.intramart.foundation.datastore.common"
public static final String | ENTITY_NAME_ROLE | "Role"
public static final String | ENTITY_NAME_ROLE_INCLUSION | "RoleInclusion"
public static final String | ENTITY_NAME_ROLE_SUMMARY | "RoleSummary"
public static final String | KIND_ROLE | "Role"
public static final String | KIND_ROLE_SUB | "SubRole"

jp.co.intra_mart.foundation.security.account.AccountManager
public static final String | ACCOUNT_ROLE_PERMISSION_SELECTOR | "account-role"
public static final String | ATTR_MENU_DISPLAY | "im_menu_display"
public static final String | ATTR_MENU_FOLDER_DISPLAY_METHOD | "im_menu_folder_display_method"
public static final String | ATTR_MOBILE_EASY_LOGIN | "im_mobile_easy_login"
public static final String | ATTR_MOBILE_EASY_LOGIN_NONCE | "im_mobile_easy_login_nonce"
public static final String | ATTR_MY_MENU_POSITION | "im_my_menu_position"
public static final String | ATTR_REPORT_LIMIT_DAYS | "im_report_limit_days"
public static final String | CRYPTION_CATEGORY_MOBILE_USER_AGENT | "mobile-user-agent"

jp.co.intra_mart.foundation.security.account.CsvAccountBackup
public static final String ID_CRYPTION_CLASS "cryption-class"

jp.co.intra_mart.foundation.security.account.StandardAccountBackup
public static final String ID_CRYPTION_CLASS "cryption-class"

jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager
public static final String | DEFAULT_ACTIVE_SESSION_ACCESSOR | "jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor"
public static final String | DEFAULT_SP_ACTIVE_SESSION_BINDING_LISTENER | "jp.co.intra_mart.session.active.session.binding.listener"

jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor
public static final String | DEFAULT_ACCESS_SECURITY_PAGE_PROVIDER_CLASS | "jp.co.intra_mart.system.security.AccessSecurityPageProviderImpl"
public static final String | DEFAULT_PAGE_LOCATION | "system/security/error/active_session_invalidated_page.jssp"

jp.co.intra_mart.foundation.security.batch.Batch
public static final String | LANG_JAVA | "JAVA"
public static final String | LANG_JAVA_SCRIPT | "JavaScript"

jp.co.intra_mart.foundation.security.calendar.CalendarInfo
public static final String | TYPE_CONFIG | "config"
public static final String | TYPE_HOLIDAY | "holiday"
public static final String | TYPE_NATIONAL_HOLDAY | "nationalHoliday"
public static final String | TYPE_WEEKDAY | "weekday"

jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer
public static final String | DEFAULT_AUTH_COOKIE_NAME | "comauth"
public static final String | DEFAULT_LOGIN_KEY | "comid"
public static final String | KEY_AUTH_COOKIE_NAME | "comauth"
public static final String | KEY_LOGIN_KEY | "comid"
public static final String | SSO_LOGOUT_URL | "sso-logout-url"

jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager
public static final String | DEFAULT_ATTR_INVALIDATE_OTHER_SESSIONS | "jp.co.intra_mart.request.duplicate.login.invalidate.other.sessions"
public static final String | DEFAULT_ATTR_REQUESTED_PAGE | "jp.co.intra_mart.request.duplicate.login.requested.page"
public static final String | DEFAULT_DUPLICATE_LOGIN_ACCESSOR | "jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor"

jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor
public static final String | DEFAULT_ACCESS_SECURITY_PAGE_PROVIDER_CLASS | "jp.co.intra_mart.system.security.AccessSecurityPageProviderImpl"
public static final String | DEFAULT_DUPLICATE_LOGIN_DETECT_ENABLE | "false"
public static final String | DEFAULT_INVALIDATABLE_BY_USER | "false"
public static final String | DEFAULT_PAGE_LOCATION | "system/security/error/duplicate_login_detection_page.jssp"

jp.co.intra_mart.foundation.security.exception.AccessSecurityException
public static final String | KIND_ROLE | "Role"
public static final String | KIND_ROLE_SUB | "SubRole"

jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter
public static final String DEFAULT_ATTR_REQUESTED_PAGE "jp.co.intra_mart.request.active.session.requested.page"

jp.co.intra_mart.foundation.security.filter.SessionFilter
public static final String SESSION_TIMEOUT_HEADER_KEY "x-jp-co-intra-mart-session-timeout"

jp.co.intra_mart.foundation.security.menu.MenuItem
public static final String | CONTENT_TYPE_IN | "in"
public static final String | CONTENT_TYPE_OUT | "out"
public static final String | MENU_TYPE_FOLDER | "folder"
public static final String | MENU_TYPE_ITEM | "item"

jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil
public static final String REQUEST_PARAM_NAME_4_EASYLOGIN_ACCESS_KEY "eak"

jp.co.intra_mart.foundation.security.role.StandardRoleBackup
public static final String KIND_ROLE "Role"

jp.co.intra_mart.foundation.service.client.NetworkConnector
protected static final int | GET | 32
protected static final int | GET_ENTIRETY | 34
protected static final int | GET_ENTIRETY_KEY | 40
protected static final int | GET_ITEM | 33
protected static final int | GET_ITEM_KEY | 36
protected static final int | GET_SUBSET | 35
protected static final int | MOVE | 128
protected static final int | MOVE_ENTIRETY | 130
protected static final int | MOVE_ITEM | 129
protected static final int | REMOVE | 64
protected static final int | REMOVE_ENTIRETY | 66
protected static final int | REMOVE_ITEM | 65
protected static final int | SET | 16
protected static final int | SET_ENTIRETY | 18
protected static final int | SET_ITEM | 17

jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
protected static final String ID_SECURITY_ACCOUNT "filter-security-account"

jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
protected static final String ID_SECURITY_GROUP "filter-security-group"

jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler
protected static final String ID_SECURITY_PASSWORD "filter-security-password"

jp.co.intra_mart.foundation.utility.report.ReportLevel
public static final int | MAX_VALUE | 2147483647
public static final int | MIN_VALUE | -2147483648
public static final int | TYPE_DEBUG | 0
public static final int | TYPE_ERROR | 3
public static final int | TYPE_REPORT | 1
public static final int | TYPE_WARNING | 2

jp.co.intra_mart.framework.base.data.ConnectorModel
public static final String | ID | "connector"
public static final String | P_ID_CONNECTOR_CLASS | "connector-class"
public static final String | P_ID_CONNECTOR_NAME | "connector-name"
public static final String | P_ID_RESOURCE_NAME | "resource-name"

jp.co.intra_mart.framework.base.data.DaoModel
public static final String | ID | "dao"
public static final String | P_ID_CONNECT_NAME | "connect-name"
public static final String | P_ID_DAO_CLASS | "dao-class"
public static final String | P_ID_DAO_CONNECTOR_NAME | "connector-name"

jp.co.intra_mart.framework.base.data.DataManager
public static final String DATA_PROPERTY_HANDLER_KEY "data"

jp.co.intra_mart.framework.base.data.DataSourceConnector
public static final String KEY_JNDI_NAME "jndi"

jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "DataConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "DataConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"
public static final String | PARAM_APPLICATION | "application"
public static final String | PARAM_APPLICATION_CLASS | "class"
public static final String | PARAM_APPLICATION_PARAM | "param"
public static final String | PARAM_BUNDLE | "bundle"
public static final String | PARAM_DEFAULT | "default"
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.data.JDBCConnector
public static final String | KEY_DRIVER | "driver"
public static final String | KEY_PASSWORD | "password"
public static final String | KEY_URL | "url"
public static final String | KEY_USERNAME | "username"

jp.co.intra_mart.framework.base.data.ResourceModel
public static final String | ID | "resource"
public static final String | P_ID_PARAM_NAME | "param-name"
public static final String | P_ID_PARAM_VALUE | "param-value"
public static final String | P_ID_RESOURCE_NAME | "resource-name"
public static final String | P_ID_RESOURCE_PARAM | "init-param"

jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "data-config"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"
public static final String | PARAM_DYNAMIC | "dynamic"

jp.co.intra_mart.framework.base.data.container.DataContainer
public static final String DATA_PROPERTY_HANDLER_KEY "data"

jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "EventConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "EventConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"
public static final String | PARAM_APPLICATION | "application"
public static final String | PARAM_APPLICATION_CLASS | "class"
public static final String | PARAM_APPLICATION_PARAM | "param"
public static final String | PARAM_BUNDLE | "bundle"
public static final String | PARAM_DEFAULT | "default"
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.event.EJBEventListenerFactory
public static final String HOME_PARAM "home"

jp.co.intra_mart.framework.base.event.EventFactoryModel
public static final String | ID | "event-factory"
public static final String | P_ID_FACTORY_CLASS | "factory-class"
public static final String | P_ID_FACTORY_PARAM | "init-param"
public static final String | P_ID_PARAM_NAME | "param-name"
public static final String | P_ID_PARAM_VALUE | "param-value"

jp.co.intra_mart.framework.base.event.EventGroupModel
public static final String | ID | "event-group"
public static final String | P_ID_EVENT_KEY | "event-key"
public static final String | P_ID_EVENT_NAME | "event-class"
public static final String | P_ID_POST_TRIGGER | "post-trigger"
public static final String | P_ID_PRE_TRIGGER | "pre-trigger"
public static final String | P_ID_TRIGGER_CLASS | "trigger-class"

jp.co.intra_mart.framework.base.event.EventManager
public static final String EVENT_PROPERTY_HANDLER_KEY "event"

jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory
public static final String LISTENER_PARAM "listener"

jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory
public static final String LISTENER_PARAM "listener"

jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "event-config"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"
public static final String | PARAM_DYNAMIC | "dynamic"

jp.co.intra_mart.framework.base.event.container.EventContainer
public static final String EVENT_PROPERTY_HANDLER_KEY "event"

jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "MessageConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.base.message.MessageManager
public static final String MESSAGE_PROPERTY_HANDLER_KEY "i18n_message"

jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.service.ControllerConverterModel
public static final String | ID | "controller-converter"
public static final String | P_ID_CONVERTER_CLASS | "converter-class"
public static final String | P_ID_CONVERTER_PARAM | "init-param"
public static final String | P_ID_PARAM_NAME | "param-name"
public static final String | P_ID_PARAM_VALUE | "param-value"

jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "ServiceConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "ServiceConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"
public static final String | PARAM_APPLICATION | "application"
public static final String | PARAM_APPLICATION_CLASS | "class"
public static final String | PARAM_APPLICATION_PARAM | "param"
public static final String | PARAM_BUNDLE | "bundle"
public static final String | PARAM_DEFAULT | "default"
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.service.IntramartConnectFilter
public static final String | INTRAMART_URL_NAME | "jp.co.intra_mart.framework.base.service.IntramartConnectServlet.intramart"
public static final String | PARAM_ARGUMENT | "argument"
public static final String | PARAM_ARGUMENT_DELIMITER | ","
public static final String | PARAM_ARGUMENT_OPERATOR | "="
public static final String | PARAM_LOGIN_GROUP_ID | "group"
public static final String | PARAM_LOGIN_USER_ID | "account"
public static final String | PARAM_REFERER | "referrer"
public static final String | PARAM_SECURITY_EXT | "securityExt"

jp.co.intra_mart.framework.base.service.IntramartConnectServlet
public static final String | INTRAMART_URL_NAME | "jp.co.intra_mart.framework.base.service.IntramartConnectServlet.intramart"
public static final String | PARAM_ARGUMENT | "argument"
public static final String | PARAM_ARGUMENT_DELIMITER | ","
public static final String | PARAM_ARGUMENT_OPERATOR | "="
public static final String | PARAM_LOGIN_GROUP_ID | "group"
public static final String | PARAM_LOGIN_USER_ID | "account"
public static final String | PARAM_REFERER | "referrer"

jp.co.intra_mart.framework.base.service.ServiceManager
public static final String | DEFAULT_SERVICE_EXTENSION | "service"
public static final String | SERVICE_EXTENSION_KEY | "jp.co.intra_mart.framework.base.service.ServiceManager.extesion"
public static final String | SERVICE_PROPERTY_HANDLER_KEY | "service"

jp.co.intra_mart.framework.base.service.ServicePropertyHandler
public static final String | DEFAULT_APPLICATION_PARAMETER | "application"
public static final String | DEFAULT_ENCODING_ATTRIBUTE | "jp.co.intra_mart.framework.base.service.encoding"
public static final String | DEFAULT_EXCEPTION_ATTRIBUTE | "exception"
public static final String | DEFAULT_LOCALE_ATTRIBUTE | "jp.co.intra_mart.framework.base.service.locale"
public static final String | DEFAULT_SERVICE_PARAMETER | "service"
public static final String | REQUEST_INFO_ATTRIBUTE | "REQUEST_INFO_ATTRIBUTE"

jp.co.intra_mart.framework.base.service.ServiceSecurityFilter
public static final String | ID_SERVICE_SECURITY_FILTER | "jp.co.intra_mart.framework.base.service.ServiceSecurityFilter"
public static final String | PARAM_ERROR_PAGE | "error-page"

jp.co.intra_mart.framework.base.service.ServiceServlet
public static final String REQUEST_SEPARATOR "-"

jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.service.ValidatorModel
public static final String | ID | "validator"
public static final String | P_ID_PARAM_NAME | "param-name"
public static final String | P_ID_PARAM_VALUE | "param-value"
public static final String | P_ID_VALIDATOR_CLASS | "validator-class"
public static final String | P_ID_VALIDATOR_PARAM | "init-param"

jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "service-config"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"
public static final String | PARAM_DYNAMIC | "dynamic"

jp.co.intra_mart.framework.base.service.container.ServiceContainer
public static final String SERVICE_PROPERTY_HANDLER_KEY "service"

jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter
public static final String OBJECT_PARAM_NAME "object"

jp.co.intra_mart.framework.base.service.validator.FormatValidator
public static final String | PARAM_MESSAGE | "message"
public static final String | PARAM_PROPERTY | "property"
public static final String | PARAM_REGEX | "regex"

jp.co.intra_mart.framework.base.service.validator.LengthValidator
public static final String | PARAM_MAX | "max"
public static final String | PARAM_MESSAGE_LONG | "message_long"
public static final String | PARAM_MESSAGE_SHORT | "message_short"
public static final String | PARAM_MIN | "min"
public static final String | PARAM_PROPERTY | "property"

jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator
public static final String | PARAM_MAX | "max"
public static final String | PARAM_MESSAGE | "message"
public static final String | PARAM_MIN | "min"
public static final String | PARAM_PROPERTY | "property"

jp.co.intra_mart.framework.base.service.validator.NumericValidator
public static final String | PARAM_MESSAGE | "message"
public static final String | PARAM_PROPERTY | "property"

jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "SessionConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.base.session.SessionManager
public static final String SESSION_PROPERTY_HANDLER_KEY "session"

jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "session-config"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.base.util.UserInfoUtil
public static final String | LT_GROUP | "group"
public static final String | LT_SUPER | "super"
public static final String | LT_USER | "user"

jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "LogConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.system.log.IntramartLogAgent
public static final String TYPE_DB "DB"

jp.co.intra_mart.framework.system.log.LogConstant
public static final String | CATEGORY_BEGIN_TRANSACTION | "BEGIN_TRANSACTION"
public static final String | CATEGORY_COMMIT_TRANSACTION | "COMMIT_TRANSACTION"
public static final String | CATEGORY_ROLLBACK_TRANSACTION | "ROLLBACK_TRANSACTION"
public static final String | LEVEL_DEBUG | "DEBUG"
public static final String | LEVEL_ERROR | "ERROR"
public static final String | LEVEL_INFO | "INFO"
public static final String | LEVEL_WARNNING | "WARNNING"

jp.co.intra_mart.framework.system.log.LogManager
public static final String LOG_PROPERTY_HANDLER_KEY "log"

jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "log-config"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "MessageConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.system.message.MessageManager
public static final String MESSAGE_PROPERTY_HANDLER_KEY "message"

jp.co.intra_mart.framework.system.property.DefaultPropertyManager
public static final String | DEFAULT_BUNDLE_NAME | "/PropertyConfig.properties"
public static final String | KEY | "jp.co.intra_mart.framework.system.property.DefaultPropertyManager"

jp.co.intra_mart.framework.system.property.PropertyManager
public static final String | DEFAULT_SYSTEM_MANAGER | "jp.co.intra_mart.framework.system.property.XmlPropertyManager"
public static final String | KEY | "jp.co.intra_mart.framework.system.property.PropertyManager"

jp.co.intra_mart.framework.system.property.XmlPropertyManager
public static final String | DEFAULT_BUNDLE_NAME | "property-config.xml"
public static final String | KEY | "jp.co.intra_mart.framework.system.property.XmlPropertyManager"

jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel
public static final String | ACCESS_CONTROLLER_ID | "accessControllerId"
public static final String | ACCESS_CONTROLLER_NAME | "accessControllerName"
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel
public static final String | ACCESS_CONTROLLER_ID | "accessControllerId"
public static final String | COMPANY_CD | "companyCd"
public static final String | DEPARTMENT_CD | "departmentCd"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel
public static final String | ACCESS_CONTROLLER_ID | "accessControllerId"
public static final String | COMPANY_CD | "companyCd"
public static final String | POST_CD | "postCd"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel
public static final String | ACCESS_CONTROLLER_ID | "accessControllerId"
public static final String | PUBLIC_GROUP_CD | "publicGroupCd"
public static final String | PUBLIC_GROUP_SET_CD | "publicGroupSetCd"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel
public static final String | ACCESS_CONTROLLER_ID | "accessControllerId"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | ROLE_ID | "roleId"

jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel
public static final String | ATTRIBUTE_NAME | "attributeName"
public static final String | ATTRIBUTE_VALUE | "attributeValue"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | USER_ID | "userId"

jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel
public static final String | COLOR_PATTERN_ID | "colorPatternId"
public static final String | ENCODING | "encoding"
public static final String | GO_OUT | "goOut"
public static final String | LOCALE | "locale"
public static final String | LOCK_DATE | "lockDate"
public static final String | LOGIN_FAILURE_COUNT | "loginFailureCount"
public static final String | MOBILE_PASSWORD | "mobilePassword"
public static final String | NOTES | "notes"
public static final String | PAGE_PATTERN_ID | "pagePatternId"
public static final String | PASSWORD | "password"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | USER_ID | "userId"
public static final String | VALID_END_DATE | "validEndDate"
public static final String | VALID_START_DATE | "validStartDate"

jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | ROLE_ID | "roleId"
public static final String | USER_ID | "userId"
public static final String | VALID_END_DATE | "validEndDate"
public static final String | VALID_START_DATE | "validStartDate"

jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel
public static final String | BATCH_ID | "batchId"
public static final String | BATCH_NAME | "batchName"
public static final String | PROGRAM_LANGUAGE | "programLanguage"
public static final String | PROGRAM_PATH | "programPath"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | RUN_DAY | "runDay"
public static final String | RUN_DAY_WEEK | "runDayWeek"
public static final String | RUN_HOUR | "runHour"
public static final String | RUN_MINUTE | "runMinute"
public static final String | RUN_MONTH | "runMonth"
public static final String | RUN_SECOND | "runSecond"
public static final String | RUN_YEAR | "runYear"
public static final String | VALID_FLG | "validFlg"

jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel
public static final String | CALENDAR_ID | "calendarId"
public static final String | COLOR | "color"
public static final String | DATA_ID | "dataId"
public static final String | DATA_NAME | "dataName"
public static final String | DATA_TYPE | "dataType"
public static final String | DAY | "day"
public static final String | DAY_WEEK | "dayWeek"
public static final String | DISPLAY_NAME | "displayName"
public static final String | MONTH | "month"
public static final String | PLUGIN_METHOD | "pluginMethod"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | TIMES | "times"
public static final String | VALID_END_YEAR | "validEndYear"
public static final String | VALID_START_YEAR | "validStartYear"
public static final String | WEEK | "week"
public static final String | YEAR | "year"

jp.co.intra_mart.system.security.datastore.inf.DataStoreConst
public static final String | ACCESS_CONTROLLER | "AccessController"
public static final String | ACCESS_CONTROLLER_DEPARTMENT | "AccessControllerDepartment"
public static final String | ACCESS_CONTROLLER_POST | "AccessControllerPost"
public static final String | ACCESS_CONTROLLER_PUBLIC_GROUP | "AccessControllerPublicGroup"
public static final String | ACCESS_CONTROLLER_ROLE | "AccessControllerRole"
public static final String | ACCOUNT | "Account"
public static final String | ACCOUNT_ATTRIBUTE | "AccountAttribute"
public static final String | ACCOUNT_ROLE | "AccountRole"
public static final String | APPLICATION_NAME | "jp.co.intramart.foundation.datastore.common"
public static final String | BATCH | "Batch"
public static final String | CALENDAR_INFO | "CalendarInfo"
public static final String | FAVORITE_MENU | "FavoriteMenu"
public static final String | MENU | "Menu"
public static final String | MENU_ARGUMENT | "MenuArgument"
public static final String | MENU_DEPARTMENT | "MenuDepartment"
public static final String | MENU_POST | "MenuPost"
public static final String | MENU_PUBLIC_GROUP | "MenuPublicGroup"
public static final String | MENU_ROLE | "MenuRole"
public static final String | ROLE | "Role"
public static final String | ROLE_INCLUSION | "RoleInclusion"
public static final String | ROLE_SUMMARY | "RoleSummary"

jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel
public static final String | DISPLAY_NAME | "displayName"
public static final String | IMAGE_PATH | "imagePath"
public static final String | MENU_ID | "menuId"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_NUMBER | "sortNumber"
public static final String | USER_ID | "userId"

jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel
public static final String | ARGUMENT_NAME | "argumentName"
public static final String | ARGUMENT_VALUE | "argumentValue"
public static final String | MENU_ID | "menuId"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel
public static final String | CLIENT_TYPE | "clientType"
public static final String | CONTENTS | "contents"
public static final String | DISPLAY_NAME | "displayName"
public static final String | IMAGE_PATH | "imagePath"
public static final String | MENU_ID | "menuId"
public static final String | MENU_TYPE | "menuType"
public static final String | NOTES | "notes"
public static final String | PARENT_MENU_ID | "parentMenuId"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_NUMBER | "sortNumber"
public static final String | URL | "url"

jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel
public static final String | COMPANY_CD | "companyCd"
public static final String | DEPARTMENT_CD | "departmentCd"
public static final String | MENU_ID | "menuId"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel
public static final String | COMPANY_CD | "companyCd"
public static final String | MENU_ID | "menuId"
public static final String | POST_CD | "postCd"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel
public static final String | MENU_ID | "menuId"
public static final String | PUBLIC_GROUP_CD | "publicGroupCd"
public static final String | PUBLIC_GROUP_SET_CD | "publicGroupSetCd"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel
public static final String | MENU_ID | "menuId"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | ROLE_ID | "roleId"

jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel
public static final String | CATEGORY | "category"
public static final String | DISPLAY_NAME | "displayName"
public static final String | NAME | "name"
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | ROLE_ID | "roleId"

jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel
public static final String | CHILD_ROLE_ID | "childRoleId"
public static final String | PARENT_ROLE_ID | "parentRoleId"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | ROLE_ID | "roleId"
public static final String | SUMMARY_ROLE_ID | "summaryRoleId"

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


非推奨 API のリスト (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

推奨されていない API

推奨されていないクラス
jp.co.intra_mart.foundation.utility.AbstractDualComparator
jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter
jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor
jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor クラスを使用してください。
jp.co.intra_mart.foundation.acssecurity.AccountManager
jp.co.intra_mart.foundation.security.account.AccountManagerに置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData
jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler
このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。
jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter
jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream
jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream
jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream
jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.charset.CharacterEncoder
jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder クラスを使用してください。
jp.co.intra_mart.foundation.utility.Counter
jp.co.intra_mart.common.aid.jdk.util.Counter クラスを使用してください。
jp.co.intra_mart.foundation.database.DatabaseExport
システム内部で利用しているクラスです。
jp.co.intra_mart.foundation.database.DbManager
DatabaseManagerを使用してください。
jp.co.intra_mart.foundation.utility.file.Directory
jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。
jp.co.intra_mart.foundation.utility.ErrorEvent
jp.co.intra_mart.common.aid.jdk.util.ErrorEvent クラスを使用してください。
jp.co.intra_mart.foundation.utility.EventQueueController
jp.co.intra_mart.common.aid.jdk.util.EventQueueController クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.EverydayConditioner
jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner クラスを使用してください。
jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。
jp.co.intra_mart.foundation.utility.file.ExtendedFile
jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.ExtendedInputStream
jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream
jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.ExtendedSocket
jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket クラスを使用してください。
jp.co.intra_mart.foundation.utility.ExtendedThread
jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.FileReporter
jp.co.intra_mart.common.aid.jdk.util.report.FileReporter クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.FileSizeConditioner
jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner クラスを使用してください。
jp.co.intra_mart.foundation.utility.FilterComparator
jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.FilterMessageReporter
jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter クラスを使用してください。
jp.co.intra_mart.foundation.utility.FixedSizeMap
jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap クラスを使用してください。
jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter
このフィルタは下位互換のためのフィルタです。将来廃止される可能性があります。
jp.co.intra_mart.foundation.utility.io.HexInputStream
jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.HexOutputStream
jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream クラスを使用してください。
jp.co.intra_mart.framework.base.session.HttpSessionFactory
このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.session.HttpSessionObject
このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.service.IntramartConnectFilter
この機能は廃止されました。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet
この機能は廃止されました。
jp.co.intra_mart.framework.base.data.IntramartDBConnector
このクラスではなくLoginGroupDBConnectorまたは SystemDBConnectorを使用してください。
jp.co.intra_mart.framework.base.data.IntramartDBDAO
このクラスではなくLoginGroupDBDAOまたは SystemDBDAOを使用してください。
jp.co.intra_mart.framework.base.session.IntramartSessionFactory
このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.session.IntramartSessionObject
このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.data.JDBCConnector
JDBCを直接扱わず、DataSourceを使用するようにしてください。
jp.co.intra_mart.foundation.utility.report.LineReportFilter
jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.Localhost
jp.co.intra_mart.common.aid.jdk.java.net.Localhost クラスを使用してください。
jp.co.intra_mart.foundation.utility.LockMonitor
jp.co.intra_mart.common.aid.jdk.util.LockMonitor クラスを使用してください。
jp.co.intra_mart.foundation.acssecurity.Logingp
jp.co.intra_mart.foundation.smtp.Mail
MailSenderに置き換えられました。
jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuHdmlAnalyzer
jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoMoveAnalyzer
jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginJphoneAnalyzer
jp.co.intra_mart.foundation.utility.report.MultiCastReporter
jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter クラスを使用してください。
jp.co.intra_mart.foundation.utility.MultiComparator
jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator クラスを使用してください。
jp.co.intra_mart.foundation.http.MultipartFormData
jp.co.intra_mart.common.aid.javaee.http.MultipartFormData クラスを使用してください。
jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions
jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner
jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.PeriodicConditioner
jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner クラスを使用してください。
jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory
jp.co.intra_mart.foundation.utility.report.PrintStreamReporter
jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.ReplaceWriter
jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.ReportFileWriter
jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.ReportLevelFilter
jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.RepresentativeReporter
jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter クラスを使用してください。
jp.co.intra_mart.foundation.utility.ResourceBundleProperties
jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties クラスを使用してください。
jp.co.intra_mart.foundation.utility.ReverseComparator
jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator クラスを使用してください。
jp.co.intra_mart.foundation.acssecurity.RoleManager
jp.co.intra_mart.foundation.sap.common.auth.SapConnector
本クラスは現在、標準では使用されておりません。
本機能はクラス SapClientManager に置き換えられました。
jp.co.intra_mart.foundation.utility.SequenceComparator
jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator クラスを使用してください。
jp.co.intra_mart.foundation.http.SessionQuery
GenericURLBuilder および URLBuilder に置き替えられました。
jp.co.intra_mart.foundation.utility.net.SocketConnection
jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.SocketPool
jp.co.intra_mart.common.aid.jdk.java.net.SocketPool クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream
jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream
jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream
jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.XORInputStream
jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.XOROutputStream
jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream クラスを使用してください。

推奨されていないインタフェース
jp.co.intra_mart.foundation.database.DbsConnection
Connectionを利用してください。
jp.co.intra_mart.foundation.utility.DualComparator
jp.co.intra_mart.common.aid.jdk.java.util.DualComparator クラスを使用してください。
jp.co.intra_mart.foundation.utility.ErrorEventListener
jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener クラスを使用してください。
jp.co.intra_mart.foundation.utility.EventListener
jp.co.intra_mart.common.aid.jdk.util.EventListener クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.MessageReporter
jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter クラスを使用してください。
jp.co.intra_mart.foundation.http.MultipartFormData.Entity
jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity インタフェースを使用してください。
jp.co.intra_mart.foundation.utility.report.ReportFileConditioner
jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.ReportLevel
jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor
jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.SocketConnectionManager
jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.SocketEventListener
jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener クラスを使用してください。
jp.co.intra_mart.foundation.utility.ThreadStopListener
jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener クラスを使用してください。

推奨されていない例外
jp.co.intra_mart.foundation.database.exception.DatabaseExportException
システム内部で利用しているクラスです。
jp.co.intra_mart.foundation.utility.charset.ResourceFormatException
jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException クラスを使用してください。
jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException
jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException
jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException クラスを使用してください。

推奨されていないフィールド
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.DEFAULT_APPLICATION_PARAMETER
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.DEFAULT_SERVICE_PARAMETER
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.INTRAMART_URL_NAME
このパラメータではなくIntramartConnectFilter.INTRAMART_URL_NAMEを使用してください。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.PARAM_ARGUMENT
このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENTを使用してください。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.PARAM_ARGUMENT_DELIMITER
このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_DELIMITERを使用してください。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.PARAM_ARGUMENT_OPERATOR
このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_OPERATORを使用してください。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.PARAM_LOGIN_GROUP_ID
このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_GROUP_IDを使用してください。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.PARAM_LOGIN_USER_ID
このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_USER_IDを使用してください。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.PARAM_REFERER
このパラメータではなくIntramartConnectFilter.PARAM_REFERERを使用してください。

推奨されていないメソッド
jp.co.intra_mart.foundation.acssecurity.AcsData.acntFromDBToIS(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.acntFromISToDB(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.service.client.batch.Scheduler.action(Object)
jp.co.intra_mart.foundation.service.client.file.NetworkFile.action(Object)
jp.co.intra_mart.foundation.service.client.information.PermanentFile.action(Object)
jp.co.intra_mart.foundation.service.client.information.PermanentDirectory.action(Object)
jp.co.intra_mart.foundation.service.client.information.Lock.action(Object)
jp.co.intra_mart.foundation.service.client.information.ExternalMemory.action(Object)
jp.co.intra_mart.foundation.service.client.information.ExternalDirectory.action(Object)
jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController.addAutoCommitCondition(String)
BapiController.addIgnoreErrMsgReturnType(java.lang.String)に置き換えられました。
jp.co.intra_mart.foundation.service.provider.GarbageController.addConditioner(GCConditioner)
jp.co.intra_mart.foundation.http.SessionQuery.addURL(String)
GenericURLBuilder.createFilePath(String) および URLBuilder.createURLonSession(String)に置き替えられました。
jp.co.intra_mart.foundation.database.DbManager.contact()
代替えメソッドはありません。
jp.co.intra_mart.foundation.database.DbManager.contact(ConInfo)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.RoleManager.contains(String)
jp.co.intra_mart.foundation.security.role.RoleManager.contains(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.contains(String)
jp.co.intra_mart.foundation.security.account.AccountManager.contains(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.RoleManager.count()
jp.co.intra_mart.foundation.security.role.RoleManager.count()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.Logingp.count()
LoginGroupManager.countLoginGroups()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.count()
jp.co.intra_mart.foundation.security.account.AccountManager.count()に置き換えられました。
jp.co.intra_mart.framework.base.event.EventManager.createEvent(String, String, String, String)
このメソッドではなくEventManager.createEvent(String, String, UserInfo)を使用してください。
jp.co.intra_mart.framework.base.web.tag.TagWriter.createURL(String, Collection)
このメソッドではなくTagWriter.createURL(String, Collection, String)を使用してください。
jp.co.intra_mart.foundation.database.DbManager.dateToString(Date)
DatabaseManager.dateToString(Date)を使用してください。
jp.co.intra_mart.foundation.acssecurity.AcsData.dbConsistChk(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.service.provider.HomeDirectory.definePath(String)
jp.co.intra_mart.foundation.acssecurity.Logingp.del(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.delAllAccount(String)
AccountManager.deleteAccounts()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.delAllLink(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.delAllMenu(String)
MenuManager.deleteMenuItems()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.delAllMessage(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.delAllRole(String)
RoleManager.deleteRoles()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.delAllSchedule(String)
BatchManager.deleteBatches()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.RoleManager.delData(String)
jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.delData(String)
jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.RoleManager.delData(String, boolean)
jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.delData(String, boolean)
jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.Logingp.entries()
LoginGroupManager.getLoginGroupIds()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.Logingp.get(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.getAccount(String, String)
AccountManager.exportData(String category, OutputStream outputStream)に置き換えられました。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getApplicationParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getApplicationParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getApplicationParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getApplicationParamName()
この実装は廃止されました。
jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController.getAutoCommitConditions()
BapiController.getIgnoreErrMsgReturnTypes()に置き換えられました。
jp.co.intra_mart.foundation.database.DbManager.getConnectIDs()
DatabaseManager.getConnectIdsBySystem()を使用してください。
jp.co.intra_mart.foundation.database.DbManager.getConnectInfo()
代替えメソッドはありません。
jp.co.intra_mart.foundation.database.DbManager.getConnection()
DatabaseManager.getLoginGroupConnection(String) および DatabaseManager.getSystemConnection(String)を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getContextPath()
このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getContextPath()
このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getContextPath()
このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getContextPath()
このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getContextPath()
このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
jp.co.intra_mart.foundation.acssecurity.RoleManager.getData(String)
jp.co.intra_mart.foundation.security.role.RoleManager.getRole(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.getData(String)
jp.co.intra_mart.foundation.security.account.AccountManager.getAccount(String)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.isRegisteredAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.model.user.UserMapperを利用して取得してください。
jp.co.intra_mart.framework.base.web.tag.FrameTag.getFrameClass()
このメソッドではなくFrameTag.getFrameclass()メソッドを使用してください。
jp.co.intra_mart.foundation.acssecurity.RoleManager.getIdByName(String)
jp.co.intra_mart.foundation.security.role.RoleManager.searchRolesByName(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.RoleManager.getIDs()
jp.co.intra_mart.foundation.security.role.RoleManager.getRoleIds()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.getIDs()
jp.co.intra_mart.foundation.security.account.AccountManager.getUserIds()に置き換えられました。
jp.co.intra_mart.foundation.graph.RadarChartDrawer.getImgaeBackgroundColor()
jp.co.intra_mart.foundation.graph.PortFolioDrawer.getImgaeBackgroundColor()
jp.co.intra_mart.foundation.graph.LineGraphDrawer.getImgaeBackgroundColor()
jp.co.intra_mart.foundation.graph.CircleGraphDrawer.getImgaeBackgroundColor()
jp.co.intra_mart.foundation.graph.BarGraphDrawer.getImgaeBackgroundColor()
jp.co.intra_mart.foundation.graph.RadarChartDrawer.getImgaeBorderColor()
jp.co.intra_mart.foundation.graph.PortFolioDrawer.getImgaeBorderColor()
jp.co.intra_mart.foundation.graph.LineGraphDrawer.getImgaeBorderColor()
jp.co.intra_mart.foundation.graph.CircleGraphDrawer.getImgaeBorderColor()
jp.co.intra_mart.foundation.graph.BarGraphDrawer.getImgaeBorderColor()
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getInputErrorPagePath()
このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getInputErrorPagePath()
このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getInputErrorPagePath()
このメソッドではなくServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getInputErrorPagePath()
このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getInputErrorPagePath()
このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getInputErrorPagePath(String)
このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getInputErrorPagePath(String)
このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getInputErrorPagePath(String)
このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getInputErrorPagePath(String)
このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getInputErrorPagePath(String)
このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getInputErrorPagePath(String, String)
このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getInputErrorPagePath(String, String)
このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getInputErrorPagePath(String, String)
このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getInputErrorPagePath(String, String)
このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getInputErrorPagePath(String, String)
このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getInputErrorPagePath(String, String, String)
このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getInputErrorPagePath(String, String, String)
このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getInputErrorPagePath(String, String, String)
このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getInputErrorPagePath(String, String, String)
このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getInputErrorPagePath(String, String, String)
このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.foundation.acssecurity.AcsData.getLink(String, String)
代替えメソッドはありません。
jp.co.intra_mart.framework.base.web.tag.LinkTag.getLinkClass()
このメソッドではなくLinkTag.getLinkclass()メソッドを使用してください。
jp.co.intra_mart.foundation.acssecurity.RoleManager.getListData(String)
jp.co.intra_mart.foundation.security.role.RoleManager.getAllSubRoleIds(String)に置き換えられました。
jp.co.intra_mart.framework.base.event.Event.getLoginGroup()
このメソッドではなくEvent.getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.event.Event.getLoginGroupID()
このメソッドではなくEvent.getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.service.ServiceControllerAdapter.getLoginGroupID()
このメソッドではなくServiceControllerAdapter.getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.web.bean.HelperBean.getLoginGroupID()
このメソッドではなくHelperBean.getUserInfo()を使用してください。
jp.co.intra_mart.framework.extension.common.util.ServiceUtils.getLoginGroupID(HttpServletRequest, HttpServletResponse)
このメソッドではなく#getUserInfo()を使用してください。
jp.co.intra_mart.framework.extension.struts.action.IntramartAction.getLoginGroupID(HttpServletRequest, HttpServletResponse)
このメソッドではなく#getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.event.Event.getLoginUser()
このメソッドではなくEvent.getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.event.Event.getLoginUserID()
このメソッドではなくEvent.getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.service.ServiceControllerAdapter.getLoginUserID()
このメソッドではなくServiceControllerAdapter.getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.web.bean.HelperBean.getLoginUserID()
このメソッドではなくHelperBean.getUserInfo()を使用してください。
jp.co.intra_mart.framework.extension.common.util.ServiceUtils.getLoginUserID(HttpServletRequest, HttpServletResponse)
このメソッドではなく#getUserInfo()を使用してください。
jp.co.intra_mart.framework.extension.struts.action.IntramartAction.getLoginUserID(HttpServletRequest, HttpServletResponse)
このメソッドではなく#getUserInfo()を使用してください。
jp.co.intra_mart.foundation.acssecurity.AcsData.getMenu(String, String)
MenuManager.exportData(String category, OutputStream outputStream)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.getMessage(String, String)
代替えメソッドはありません。
jp.co.intra_mart.framework.system.message.MessagePropertyHandler.getMessage(String, String)
intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
MessagePropertyHandler.getMessage(String)を使用してください。
jp.co.intra_mart.framework.system.message.MessageManager.getMessage(String, String)
intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
設定されているMessagePropertyHandlerによっては、 パラメータloginGroupは実際には使用しない可能性があります。MessageManager.getMessage(String)を使用してください。
jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler.getMessage(String, String)
intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
パラメータloginGroupは実際には使用しません。IntramartMessagePropertyHandler.getMessage(String)を使用してください。
jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler.getMessage(String, String)
intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
DefaultMessagePropertyHandler.getMessage(String)を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getNextPagePath(String, String)
このメソッドではなく XmlServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getNextPagePath(String, String)
このメソッドではなくTextFileServicePropertyHandler.getNextPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getNextPagePath(String, String)
このメソッドではなくServicePropertyHandler.getNextPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getNextPagePath(String, String)
このメソッドではなく DistributesServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getNextPagePath(String, String)
このメソッドではなく DefaultServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getNextPagePath(String, String, String)
このメソッドではなく XmlServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getNextPagePath(String, String, String)
このメソッドではなくTextFileServicePropertyHandler.getNextPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getNextPagePath(String, String, String)
このメソッドではなくServicePropertyHandler.getNextPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getNextPagePath(String, String, String)
このメソッドではなく DistributesServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getNextPagePath(String, String, String)
このメソッドではなく DefaultServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.foundation.acssecurity.RoleManager.getParentData(String)
jp.co.intra_mart.foundation.security.role.RoleManager.getParentRoleIds(String)に置き換えられました。
jp.co.intra_mart.foundation.http.SessionQuery.getQuery()
代替えメソッドはありません。
jp.co.intra_mart.foundation.http.SessionQuery.getQueryName()
代替えメソッドはありません。
jp.co.intra_mart.foundation.http.SessionQuery.getQueryValue()
GenericURLBuilder.createFilePath(String) に置き替えられました。
jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity.getReader()
MultipartFormData.Entity.getReader(String) に置き換えられました。
jp.co.intra_mart.foundation.http.MultipartFormData.Entity.getReader()
MultipartFormData.Entity.getReader(String) に置き換えられました。
jp.co.intra_mart.foundation.database.DbManager.getReference()
DatabaseManager.getConnectIdsBySystem()を使用してください。
jp.co.intra_mart.foundation.acssecurity.AcsData.getRole(String, String)
RoleManager.exportData(String category, OutputStream outputStream)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.getSchedule(String, String)
BatchManager.exportData(String category, OutputStream outputStream)に置き換えられました。
jp.co.intra_mart.framework.base.service.ServiceManager.getServiceController(String, String)
このメソッドではなくServiceManager.getServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getServiceControllerName(String, String)
このメソッドではなく XmlServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getServiceControllerName(String, String)
このメソッドではなくTextFileServicePropertyHandler.getServiceControllerName(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceControllerName(String, String)
このメソッドではなくServicePropertyHandler.getServiceControllerName(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getServiceControllerName(String, String)
このメソッドではなく DistributesServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getServiceControllerName(String, String)
このメソッドではなく DefaultServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getServiceErrorPagePath()
このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getServiceErrorPagePath()
このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceErrorPagePath()
このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getServiceErrorPagePath()
このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getServiceErrorPagePath()
このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getServiceErrorPagePath(String)
このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getServiceErrorPagePath(String)
このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceErrorPagePath(String)
このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getServiceErrorPagePath(String)
このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getServiceErrorPagePath(String)
このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getServiceErrorPagePath(String, String)
このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getServiceErrorPagePath(String, String)
このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceErrorPagePath(String, String)
このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getServiceErrorPagePath(String, String)
このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getServiceErrorPagePath(String, String)
このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getServiceErrorPagePath(String, String, String)
このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getServiceErrorPagePath(String, String, String)
このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceErrorPagePath(String, String, String)
このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, String)
このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, String)
このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getServiceParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getServiceParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getServiceParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceServletPath()
この実装は廃止されました。
jp.co.intra_mart.framework.base.web.bean.HelperBean.getSession()
このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler.getSessionFactoryName()
セッションとしてはHttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.session.SessionPropertyHandler.getSessionFactoryName()
セッションとしてはHttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler.getSessionFactoryName()
セッションとしてはHttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.service.Transition.getSessionObject()
このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler.getSessionObjectKey()
HttpSessionを直接取得するようにしてください。
jp.co.intra_mart.framework.base.session.SessionPropertyHandler.getSessionObjectKey()
HttpSessionを直接取得するようにしてください。
jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler.getSessionObjectKey()
HttpSessionを直接取得するようにしてください。
jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler.getSessionParameter()
HttpSessionを直接使用する場合、このメソッドは不要になります。
jp.co.intra_mart.framework.base.session.SessionPropertyHandler.getSessionParameter()
HttpSessionを直接使用する場合、このメソッドは不要になります。
jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler.getSessionParameter()
HttpSessionを直接使用する場合、このメソッドは不要になります。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getSystemErrorPagePath()
このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getSystemErrorPagePath()
このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getSystemErrorPagePath()
このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getSystemErrorPagePath()
このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getSystemErrorPagePath()
このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getSystemErrorPagePath(String)
このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getSystemErrorPagePath(String)
このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getSystemErrorPagePath(String)
このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getSystemErrorPagePath(String)
このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getSystemErrorPagePath(String)
このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getSystemErrorPagePath(String, String)
このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getSystemErrorPagePath(String, String)
このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getSystemErrorPagePath(String, String)
このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getSystemErrorPagePath(String, String)
このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getSystemErrorPagePath(String, String)
このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getSystemErrorPagePath(String, String, String)
このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getSystemErrorPagePath(String, String, String)
このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getSystemErrorPagePath(String, String, String)
このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, String)
このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, String)
このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.ServiceManager.getTransition(String, String)
このメソッドではなくServiceManager.getTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getTransitionName(String, String)
このメソッドではなく XmlServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getTransitionName(String, String)
このメソッドではなくTextFileServicePropertyHandler.getTransitionName(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getTransitionName(String, String)
このメソッドではなくServicePropertyHandler.getTransitionName(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getTransitionName(String, String)
このメソッドではなく DistributesServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getTransitionName(String, String)
このメソッドではなく DefaultServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter.getValueAsReader()
RequestParameter.getValueAsReader(String) に置き換えられました。
jp.co.intra_mart.foundation.database.DbManager.isConnect()
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.Logingp.isGroup(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.commons.validation.InputCheck.isValidDate(String, String, String)
この関数は使用できません。次期バージョンにて削除されます。
jp.co.intra_mart.foundation.commons.validation.InputCheck.isWeekDate(String, int)
この関数は使用できません。次期バージョンにて削除されます。
jp.co.intra_mart.foundation.commons.validation.InputCheck.isWeekDate(String, Integer)
この関数は使用できません。次期バージョンにて削除されます。
jp.co.intra_mart.foundation.service.client.information.Lock.releaseRequestScope()
このメソッドは、RequestScopeLockReleaseFilter 専用です。
jp.co.intra_mart.foundation.service.provider.GarbageController.removeConditioner(GCConditioner)
jp.co.intra_mart.foundation.acssecurity.Logingp.set(String, Number)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.Logingp.set(String, String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.setAccount(String, String)
AccountManager.importData(String category, InputStream inputStream)に置き換えられました。
jp.co.intra_mart.foundation.database.DbsConnection.setAutoCommit(boolean)
jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController.setAutoCommitConditions(List)
BapiController.setIgnoreErrMsgReturnTypes(java.util.List)に置き換えられました。
jp.co.intra_mart.framework.base.web.tag.HelperBeanTag.setClass(String)
このメソッドではなくHelperBeanTag.setHelperclass(java.lang.String)メソッドを使用してください。
jp.co.intra_mart.foundation.acssecurity.RoleManager.setData(Map)
jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.setData(Map)
jp.co.intra_mart.foundation.security.account.AccountManager.addAcount(Account) およびupdateAccount(Account)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.registerAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.domain.user.UserManagerを利用して、更新してください。
jp.co.intra_mart.foundation.acssecurity.RoleManager.setData(Map, boolean)
jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.setData(Map, boolean)
jp.co.intra_mart.framework.base.web.tag.FrameTag.setFrameClass(String)
このメソッドではなくFrameTag.setFrameclass(String)メソッドを使用してください。
jp.co.intra_mart.foundation.graph.RadarChartDrawer.setImgaeBackgroundColor(Color)
jp.co.intra_mart.foundation.graph.PortFolioDrawer.setImgaeBackgroundColor(Color)
jp.co.intra_mart.foundation.graph.LineGraphDrawer.setImgaeBackgroundColor(Color)
jp.co.intra_mart.foundation.graph.CircleGraphDrawer.setImgaeBackgroundColor(Color)
jp.co.intra_mart.foundation.graph.BarGraphDrawer.setImgaeBackgroundColor(Color)
jp.co.intra_mart.foundation.graph.RadarChartDrawer.setImgaeBorderColor(Color)
jp.co.intra_mart.foundation.graph.PortFolioDrawer.setImgaeBorderColor(Color)
jp.co.intra_mart.foundation.graph.LineGraphDrawer.setImgaeBorderColor(Color)
jp.co.intra_mart.foundation.graph.CircleGraphDrawer.setImgaeBorderColor(Color)
jp.co.intra_mart.foundation.graph.BarGraphDrawer.setImgaeBorderColor(Color)
jp.co.intra_mart.foundation.acssecurity.AcsData.setLink(String, String)
代替えメソッドはありません。
jp.co.intra_mart.framework.base.web.tag.LinkTag.setLinkClass(String)
このメソッドではなくLinkTag.setLinkclass(String)メソッドを使用してください。
jp.co.intra_mart.foundation.acssecurity.AcsData.setMenu(String, String)
MenuManager.importData(String category, InputStream inputStream)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.setMessage(String, String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.setRole(String, String)
RoleManager.importData(String category, InputStream inputStream)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.setSchedule(String, String)
BatchManager.importData(String category, InputStream inputStream)に置き換えられました。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper.setStatus(int, String)
jp.co.intra_mart.foundation.http.SessionQuery.setTo(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.service.provider.GarbageController.startAutomaticExecution(long)
gc によるシステム停止や監視スレッドを停止処理しないことによるメモリリークなどの問題を引き起こす危険性があります。
jp.co.intra_mart.foundation.service.provider.GarbageController.stopAutomaticExecution()
jp.co.intra_mart.foundation.database.DbManager.stringToDate(String)
DatabaseManager.stringToDate(String)を使用してください。

推奨されていないコンストラクタ
jp.co.intra_mart.foundation.acssecurity.AccountManager(String)
jp.co.intra_mart.foundation.database.DbManager(String)
DatabaseManagerを使用してください。
jp.co.intra_mart.foundation.acssecurity.Logingp(String)
LoginGroupManagerに置き換えられました。
jp.co.intra_mart.foundation.acssecurity.RoleManager(String)
jp.co.intra_mart.foundation.security.role.RoleManagerに置き換えられました。
jp.co.intra_mart.foundation.http.SessionQuery(HttpServletRequest, HttpServletResponse)
GenericURLBuilder および URLBuilder に置き替えられました。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


API ヘルプ (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

API ドキュメントの構成

この API (Application Programming Interface) ドキュメントには、次に説明するナビゲーションバーにある項目に対応するページが含まれます。

概要

概要 ページは API ドキュメントのフロントページで、各パッケージの概要を含む全パッケージの一覧が表示されます。一連のパッケージの概要説明も表示されます。

パッケージ

各パッケージは、そのパッケージのクラスとインタフェースへのリンクを含むページを持ちます。このページは 4 つのカテゴリで構成されます:

  • インタフェース (イタリック)
  • クラス
  • 例外
  • エラー

クラスまたはインタフェース

各クラス、インタフェース、入れ子クラス、および入れ子インタフェースは個別のページを持ちます。各ページには次のように、クラスまたはインタフェースの説明と、概要テーブル、およびメンバの詳細説明が含まれます:

  • クラス階層表示
  • 直系のサブクラス
  • 既知のサブインタフェースの一覧
  • 既知の実装クラスの一覧
  • クラスまたはインタフェースの宣言
  • クラスまたはインタフェースの記述

  • 入れ子クラスの概要
  • フィールドの概要
  • コンストラクタの概要
  • メソッドの概要

  • フィールドの詳細
  • コンストラクタの詳細
  • メソッドの詳細
各概要エントリには、その項目の詳細な記述の中から 1 行目の文が表示されます。詳細な記述はソースコードに現われる順に並べられますが、概要エントリはアルファベット順に並べられます。これによって、プログラマが設定した論理的なグループ分けが保持されます。

使用

各ドキュメント化されたパッケージ、クラス、およびインタフェースはそれぞれ [使用] ページを持っています。このページには、どのようなパッケージ、クラス、メソッド、コンストラクタ、およびフィールドが、特定のクラスまたはパッケージの一部を使用しているかが記述されています。たとえば、クラス A またはインタフェース A の場合、その [使用] ページには、A のサブクラス、A として宣言されるフィールド、A を返すメソッド、および、型 A を持つメソッドとコンストラクタが含まれます。このページにアクセスするには、まずそのパッケージ、クラス、またはインタフェースに移動し、ナビゲーションバーの [使用] リンクをクリックしてください。

階層ツリー (クラス階層)

すべてのパッケージには クラス階層 ページがあり、さらに各パッケージの階層があります。各階層ページは、クラスのリストとインタフェースのリストを含みます。クラスは java.lang.Object を開始点とする継承構造で編成されます。インタフェースは、java.lang.Object からは継承しません。
  • 概要ページを表示しているときに [ツリー] をクリックすると、全パッケージの階層が表示されます。
  • 特定のパッケージ、クラス、またはインタフェースを表示しているときに [ツリー] をクリックすると、該当するパッケージだけの階層が表示されます。

推奨されていない API

推奨されていない API ページは、推奨されていないすべての API のリストを表示します。非推奨 API とは、機能改良などの理由から使用をお勧めできなくなった API のことで、通常はそれに代わる API が提供されます。非推奨 API は今後の実装で削除される可能性があります。

索引

索引 には、すべてのクラス、インタフェース、コンストラクタ、メソッド、およびフィールドのアルファベット順のリストが含まれます。

前/次

これらのリンクにより、前または次のクラス、インタフェース、パッケージ、または関連ページへ移動できます。

フレームあり/フレームなし

これらのリンクは HTML フレームを表示したり隠したりします。すべてのページはフレームありでも、フレームなしでも表示できます。

直列化された形式

直列化可能、または外部化可能な各クラスは、直列化フィールドとメソッドの記述を含みます。この情報は、API を使用する開発者ではなく、再実装を行う担当者に役立ちます。ナビゲーションバーにリンクがない場合、直列化されたクラスに移動して、クラス記述の [関連項目] セクションにある [直列化された形式] をクリックすることにより、この情報を表示できます。

このヘルプファイルは、標準の doclet によって生成された API ドキュメントに適用されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


索引 (javadoc_entire 6.1.14 API)

概要

パッケージ

クラス

使用

階層ツリー

非推奨 API

索引

ヘルプ

intra-mart 6.1.14

前 次

フレームあり フレームなし

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

A

ACCESS_CONTROLLER - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
アクセスコントローラ情報
ACCESS_CONTROLLER_DEPARTMENT - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
アクセスコントローラの利用権限を保有する組織
ACCESS_CONTROLLER_ID - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel の static 変数
アクセスコントローラID
ACCESS_CONTROLLER_ID - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel の static 変数
アクセスコントローラID
ACCESS_CONTROLLER_ID - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel の static 変数
アクセスコントローラID
ACCESS_CONTROLLER_ID - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel の static 変数
アクセスコントローラID
ACCESS_CONTROLLER_ID - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel の static 変数
アクセスコントローラID
ACCESS_CONTROLLER_NAME - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel の static 変数
アクセスコントローラ名
ACCESS_CONTROLLER_POST - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
アクセスコントローラの利用権限を保有する役職
ACCESS_CONTROLLER_PUBLIC_GROUP - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
アクセスコントローラの利用権限を保有するパブリックグループ
ACCESS_CONTROLLER_ROLE - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
アクセスコントローラの利用権限を保有するロール
ACCOUNT - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
アカウント
ACCOUNT_ATTRIBUTE - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
アカウント属性
ACCOUNT_FLAG - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
アカウントフラグ
ACCOUNT_ROLE - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
アカウントが保有するロール
ACCOUNT_ROLE_PERMISSION_SELECTOR - class jp.co.intra_mart.foundation.security.account.AccountManager の static 変数
パーミッションセレクタ: ユーザが保有するすべてのロール取得用ID。
ADDRESS - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
住所
ADDRESS1 - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
住所1
ADDRESS2 - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
住所2
AMOUNT - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel の static 変数
数量
APPLICATION_NAME - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor の static 変数
アプリケーション名
APPLICATION_NAME - class jp.co.intra_mart.foundation.security.StandardAccountAccessor の static 変数
アプリケーション名
APPLICATION_NAME - class jp.co.intra_mart.foundation.security.StandardBatchAccessor の static 変数
アプリケーション名
APPLICATION_NAME - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor の static 変数
アプリケーション名
APPLICATION_NAME - class jp.co.intra_mart.foundation.security.StandardMenuAccessor の static 変数
アプリケーション名
APPLICATION_NAME - class jp.co.intra_mart.foundation.security.StandardRoleAccessor の static 変数

APPLICATION_NAME - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
アプリケーション
ARGUMENT_NAME - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel の static 変数
引数名
ARGUMENT_VALUE - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel の static 変数
引数値
ATTRIBUTE_NAME - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel の static 変数
属性キー
ATTRIBUTE_TYPE_HISTORY_COUNT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
属性タイプ ：履歴表示件数
ATTRIBUTE_VALUE - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel の static 変数
属性値
ATTR_CERTIFICATION_MODE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
認証モード制御パラメータ名。
ATTR_DO_FILTER - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
セッションフィルター制御パラメータ名。
ATTR_MENU_DISPLAY - class jp.co.intra_mart.foundation.security.account.AccountManager の static 変数
ユーザ属性名: ログイン時のメニュー表示・非表示用。
ATTR_MENU_FOLDER_DISPLAY_METHOD - class jp.co.intra_mart.foundation.security.account.AccountManager の static 変数
ユーザ属性名: メニューフォルダの表示方法。
ATTR_MOBILE_EASY_LOGIN - class jp.co.intra_mart.foundation.security.account.AccountManager の static 変数
ユーザ属性名: かんたんログイン用。
ATTR_MOBILE_EASY_LOGIN_NONCE - class jp.co.intra_mart.foundation.security.account.AccountManager の static 変数
ユーザ属性名: かんたんログインのアクセスキー生成時に必要なNonce用。
ATTR_MY_MENU_POSITION - class jp.co.intra_mart.foundation.security.account.AccountManager の static 変数
ユーザ属性名: マイメニュー表示位置用。
ATTR_REPORT_LIMIT_DAYS - class jp.co.intra_mart.foundation.security.account.AccountManager の static 変数
ユーザ属性名: パスワード期限切れ通知用。
AVALIABLE_LOGIN_USER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ログインできるアカウントを表す定数
AbsoluteLinkFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter.
絶対表現のＵＲＬをレスポンスするためのフィルタ。
AbsoluteLinkFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter のコンストラクタ
フィルタを新しく作成します。
AbstractComponent - class jp.co.intra_mart.foundation.service.client.file.AbstractComponent.
このクラスは、Storage Service で実行される ロジックを実装するためのスケルトンを提供します。
AbstractComponent() - class jp.co.intra_mart.foundation.service.client.file.AbstractComponent のコンストラクタ
唯一のコンストラクタ。
AbstractController - class jp.co.intra_mart.foundation.sap.module.AbstractController.
モジュール共通抽象コントローラクラス。
AbstractController() - class jp.co.intra_mart.foundation.sap.module.AbstractController のコンストラクタ
コンストラクタ。
AbstractController(SapClient) - class jp.co.intra_mart.foundation.sap.module.AbstractController のコンストラクタ
コンストラクタ。
AbstractDrawer - class jp.co.intra_mart.foundation.drawer.AbstractDrawer.
画像ファイル出力用のスケルトンクラスです。
AbstractDrawer() - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のコンストラクタ
唯一のコンストラクタ。
AbstractDualComparator - class jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator.
２つのコンパレータを使用してソートを行うクラスです。
AbstractDualComparator() - class jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator のコンストラクタ
新しいオブジェクトを生成します。
AbstractDualComparator - class jp.co.intra_mart.foundation.utility.AbstractDualComparator.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator クラスを使用してください。
AbstractDualComparator() - class jp.co.intra_mart.foundation.utility.AbstractDualComparator のコンストラクタ
推奨されていません。 新しいオブジェクトを生成します。
AbstractExportManagerClient - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient.
エクスポートマネージャークライアントの汎用的な実装です。
AbstractExportManagerClient() - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のコンストラクタ

AbstractFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter.
フィルタを実装するための抽象クラスです。
AbstractFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のコンストラクタ
フィルタオブジェクトを作成します。
AbstractHttpServletResponseEventConfig - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventConfig.
レスポンスの各メソッド呼び出しに対するイベントを 設定するためのオブジェクトの抽象実装です。
AbstractHttpServletResponseEventConfig(ServletContext) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventConfig のコンストラクタ
新しい設定オブジェクトを作成します。
AbstractHttpServletResponseEventController - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController.
イベントを制御するレスポンスの抽象実装です。
AbstractHttpServletResponseEventController(ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のコンストラクタ
新しいインスタンスを生成します。
AbstractHttpServletResponseEventListener - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener.
レスポンスの各メソッド呼び出しに対するイベントをフックするための抽象実装です。
AbstractHttpServletResponseEventListener() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のコンストラクタ
新しいリスナを作成します。
AbstractHttpSessionManager - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager.
インタフェース HttpSessionManager の抽象実装です。
AbstractHttpSessionManager() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager のコンストラクタ
HttpSessionManager の抽象実装を構築します。
AbstractImportManagerClient - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient.
インポートマネージャークライアントの汎用的な実装です。
AbstractImportManagerClient() - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のコンストラクタ

AbstractMessageReporter - class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter.
メッセージ出力用のスケルトンクラスです。
AbstractMessageReporter() - class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter のコンストラクタ
唯一のコンストラクタ。
AbstractMessageReporter - class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter クラスを使用してください。
AbstractMessageReporter() - class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter のコンストラクタ
推奨されていません。 唯一のコンストラクタ。
AbstractSocketConnectionDistributor - class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor.
このクラスは、通信ソケットを作成する機能を提供します。
AbstractSocketConnectionDistributor(String, int) - class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor のコンストラクタ
ソケット作成オブジェクトを構築します。
AbstractSocketConnectionDistributor - class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor クラスを使用してください。
AbstractSocketConnectionDistributor(String, int) - class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor のコンストラクタ
推奨されていません。 ソケット作成オブジェクトを構築します。
AbstractTreeNodeContainer - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer.
ツリービューの子ノードを扱うためのメソッドを提供する抽象クラスです。
AbstractTreeNodeContainer() - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のコンストラクタ
子ノードを追加順に並べる、新しいオブジェクトを生成します。
AbstractTreeNodeContainer(Comparator) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のコンストラクタ
指定されたコンパレータに従って子ノードを並べる、新しいオブジェクトを生成します。
AccEmployeePayPostController - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController.
伝票登録コントローラクラス
機能は以下の通り
伝票を登録します。
AccEmployeePayPostController() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のコンストラクタ
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、 明細通貨項目一覧を作成します｡
AccEmployeePayPostController(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のコンストラクタ
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

ConnectionManagerを使用することで、ConnectionManagerから トランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
AccEmployeePayPostController(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のコンストラクタ
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバへデータを登録することが可能です。
AccessController - class jp.co.intra_mart.foundation.security.access.AccessController.
アクセスコントローラ・モデルクラス。
AccessController(String) - class jp.co.intra_mart.foundation.security.access.AccessController のコンストラクタ
コンストラクタ。
AccessController() - class jp.co.intra_mart.foundation.security.access.AccessController のコンストラクタ
コンストラクタ。
AccessControllerAccessor - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor.
アクセスコントローラアクセッサインタフェース。
AccessControllerBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel.
アクセスコントローラ情報の基本モデルです。
AccessControllerDepartmentBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel.
アクセスコントローラの利用権限を保有する組織の基本モデルです。
AccessControllerDepartmentMapper - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper.
アクセスコントローラの利用権限を保有する組織に関連するマッパです。
AccessControllerExporter - interface jp.co.intra_mart.foundation.security.access.AccessControllerExporter.
アクセスコントローラエクスポートインタフェースです。
AccessControllerImporter - interface jp.co.intra_mart.foundation.security.access.AccessControllerImporter.
アクセスコントローラインポートインタフェースです。
AccessControllerManager - class jp.co.intra_mart.foundation.security.access.AccessControllerManager.
アクセスコントローラマネージャクラス。
AccessControllerManager(String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のコンストラクタ
コンストラクタ。
AccessControllerMapper - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper.
アクセスコントローラ情報に関連するマッパです。
AccessControllerPermissionSelector - class jp.co.intra_mart.foundation.security.permission.AccessControllerPermissionSelector.
ユーザIDから有効なアクセスコントローラのID一覧を取得するセレクタ。
AccessControllerPermissionSelector() - class jp.co.intra_mart.foundation.security.permission.AccessControllerPermissionSelector のコンストラクタ
コンストラクタ。
AccessControllerPostBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel.
アクセスコントローラの利用権限を保有する役職の基本モデルです。
AccessControllerPostMapper - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper.
アクセスコントローラの利用権限を保有する役職に関連するマッパです。
AccessControllerPostWriterListener - interface jp.co.intra_mart.foundation.security.access.AccessControllerPostWriterListener.
アクセスコントローラ情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AccessControllerPublicGroupBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel.
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルです。
AccessControllerPublicGroupMapper - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper.
アクセスコントローラの利用権限を保有するパブリックグループに関連するマッパです。
AccessControllerQueryWriterListener - interface jp.co.intra_mart.foundation.security.access.AccessControllerQueryWriterListener.
アクセスコントローラ情報書き込み時（書き込む直前）のリスナ・インターフェースを定義します。
AccessControllerReaderDecorator - interface jp.co.intra_mart.foundation.security.access.AccessControllerReaderDecorator.
アクセスコントローラ情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
AccessControllerRoleBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel.
アクセスコントローラの利用権限を保有するロールの基本モデルです。
AccessControllerRoleMapper - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper.
アクセスコントローラの利用権限を保有するロールに関連するマッパです。
AccessSecurityConfigException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException.
アクセスセキュリティ設定に関する例外クラス。
AccessSecurityConfigException() - class jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException のコンストラクタ
コンストラクタ。
AccessSecurityConfigException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException のコンストラクタ
コンストラクタ。
AccessSecurityConfigException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException のコンストラクタ
コンストラクタ。
AccessSecurityConfigException(Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException のコンストラクタ
コンストラクタ。
AccessSecurityCreateException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException.
アクセスセキュリティ情報作成例外クラス。
AccessSecurityCreateException(String, String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException のコンストラクタ
コンストラクタ。
AccessSecurityCreateException(String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException のコンストラクタ
コンストラクタ。
AccessSecurityCreateException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException のコンストラクタ
コンストラクタ。
AccessSecurityCreateException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException のコンストラクタ
コンストラクタ。
AccessSecurityDeleteException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException.
アクセスセキュリティ情報削除例外クラス。
AccessSecurityDeleteException(String, String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException のコンストラクタ
コンストラクタ。
AccessSecurityDeleteException(String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException のコンストラクタ
コンストラクタ。
AccessSecurityDeleteException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException のコンストラクタ
コンストラクタ。
AccessSecurityDeleteException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException のコンストラクタ
コンストラクタ。
AccessSecurityException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityException.
アクセスセキュリティの基本となる例外クラス。
AccessSecurityException() - class jp.co.intra_mart.foundation.security.exception.AccessSecurityException のコンストラクタ
コンストラクタ。
AccessSecurityException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityException のコンストラクタ
コンストラクタ。
AccessSecurityException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityException のコンストラクタ
コンストラクタ。
AccessSecurityException(Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityException のコンストラクタ
コンストラクタ。
AccessSecurityExportException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException.
エクスポート時例外クラス。
AccessSecurityExportException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException のコンストラクタ
コンストラクタ。
AccessSecurityExportException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException のコンストラクタ
コンストラクタ。
AccessSecurityImportException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException.
インポート時例外クラス。
AccessSecurityImportException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException のコンストラクタ
コンストラクタ。
AccessSecurityImportException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException のコンストラクタ
コンストラクタ。
AccessSecurityListenerExcpetion - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion.
アクセスセキュリティリスナーの例外クラス。
AccessSecurityListenerExcpetion() - class jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion のコンストラクタ
コンストラクタ。
AccessSecurityListenerExcpetion(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion のコンストラクタ
コンストラクタ。
AccessSecurityListenerExcpetion(Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion のコンストラクタ
コンストラクタ。
AccessSecurityListenerExcpetion(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion のコンストラクタ
コンストラクタ。
AccessSecurityManager - class jp.co.intra_mart.foundation.security.AccessSecurityManager.
アクセスセキュリティマネージャクラス。
AccessSecurityReadException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException.
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityReadException(String, String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityReadException(String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityReadException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityReadException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityReadException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityReadException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityReadException(Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityRuntimeException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException.
アクセスセキュリティランタイム例外クラス。
AccessSecurityRuntimeException() - class jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException のコンストラクタ
コンストラクタ。
AccessSecurityRuntimeException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException のコンストラクタ
コンストラクタ。
AccessSecurityRuntimeException(Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException のコンストラクタ
コンストラクタ。
AccessSecurityRuntimeException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException のコンストラクタ
コンストラクタ。
AccessSecurityUpdateException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException.
アクセスセキュリティ情報更新例外クラス。
AccessSecurityUpdateException(String, String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException のコンストラクタ
コンストラクタ。
AccessSecurityUpdateException(String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException のコンストラクタ
コンストラクタ。
AccessSecurityUpdateException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException のコンストラクタ
コンストラクタ。
AccessSecurityUpdateException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException のコンストラクタ
コンストラクタ。
AccessSecurityWriteException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException.
アクセスセキュリティ情報の更新例外クラス。
AccessSecurityWriteException() - class jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException のコンストラクタ
コンストラクタ。
AccessSecurityWriteException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException のコンストラクタ
コンストラクタ。
AccessSecurityWriteException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException のコンストラクタ
コンストラクタ。
AccessSecurityWriteException(Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException のコンストラクタ
コンストラクタ。
AccessibleLinkHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler.
再接続の為のＵＲＬを制御するフィルタ実装です。
AccessibleLinkHTTPActionEventFilterHandler(HTTPActionEventHandler) - class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler のコンストラクタ
ＵＲＬを絶対形式に変換するためのフィルタハンドラを作成します。
AccessorClosedException - exception jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException.
アクセサのクローズ時に発生する例外クラス

アクセサがクローズされている場合に、以下のメソッドを呼び出された時にスローする。
AccessorClosedException() - class jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException のコンストラクタ
コンストラクタ
AccessorClosedException(String) - class jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException のコンストラクタ
コンストラクタ
AccessorClosedException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException のコンストラクタ
コンストラクタ
AccessorClosedException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException のコンストラクタ
コンストラクタ
AccessorException - exception jp.co.intra_mart.foundation.datastore.exception.AccessorException.
アクセサで発生する例外の基底クラス
AccessorException() - class jp.co.intra_mart.foundation.datastore.exception.AccessorException のコンストラクタ
コンストラクタ
AccessorException(String) - class jp.co.intra_mart.foundation.datastore.exception.AccessorException のコンストラクタ
コンストラクタ
AccessorException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorException のコンストラクタ
コンストラクタ
AccessorException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorException のコンストラクタ
コンストラクタ
AccessorIllegalPropertyValueException - exception jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException.
アクセサのプロパティ設定に関する例外クラス

アクセサに不正な値が設定された場合にスローする。
AccessorIllegalPropertyValueException() - class jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException のコンストラクタ
コンストラクタ
AccessorIllegalPropertyValueException(String) - class jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException のコンストラクタ
コンストラクタ
AccessorIllegalPropertyValueException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException のコンストラクタ
コンストラクタ
AccessorIllegalPropertyValueException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException のコンストラクタ
コンストラクタ
AccessorSystemException - exception jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException.
アクセサのプロパティに関する例外クラス

指定されたプロパティがアクセサに存在しない場合にスローする。
AccessorSystemException() - class jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException のコンストラクタ
コンストラクタ
AccessorSystemException(String) - class jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException のコンストラクタ
コンストラクタ
AccessorSystemException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException のコンストラクタ
コンストラクタ
AccessorSystemException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException のコンストラクタ
コンストラクタ
Account - class jp.co.intra_mart.foundation.security.account.Account.
アカウントモデル。
Account(String) - class jp.co.intra_mart.foundation.security.account.Account のコンストラクタ
コンストラクタ。
AccountAccessor - interface jp.co.intra_mart.foundation.security.account.AccountAccessor.
アカウントアクセッサインタフェース。
AccountAttributeBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel.
アカウントが保有する属性の基本モデルです。
AccountAttributeMapper - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper.
アカウントが保有する属性に関連するマッパです。
AccountBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel.
アカウントの基本モデルです。
AccountChangedListener - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener.
アカウント情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AccountExporter - interface jp.co.intra_mart.foundation.security.account.AccountExporter.
アカウントエクスポートインタフェースです。
AccountGl - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl.
G/L 勘定明細クラス
機能は以下の通り
G/L 勘定明細の情報を保持します。
AccountGl(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のコンストラクタ
G/L 勘定明細情報を作成します。
AccountImporter - interface jp.co.intra_mart.foundation.security.account.AccountImporter.
アカウントインポートインタフェースです。
AccountManager - class jp.co.intra_mart.foundation.acssecurity.AccountManager.
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManagerに置き換えられました。
AccountManager(String) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のコンストラクタ
推奨されていません。
AccountManager - class jp.co.intra_mart.foundation.security.account.AccountManager.
アカウントマネージャクラス。
AccountManager(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のコンストラクタ
コンストラクタ。
AccountMapper - interface jp.co.intra_mart.system.security.datastore.inf.AccountMapper.
アカウントに関連するマッパです。
AccountPayable - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable.
仕入先明細クラス
機能は以下の通り
仕入先明細の情報を保持します。
AccountPayable(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のコンストラクタ
仕入先明細情報を作成します。
AccountPostWriterListener - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener.
アカウント情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AccountQueryWriterListener - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener.
アカウント情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
AccountReaderDecorator - interface jp.co.intra_mart.foundation.security.account.AccountReaderDecorator.
アカウント情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
AccountRole - class jp.co.intra_mart.foundation.security.account.AccountRole.
アカウント用ロールモデル。
AccountRole(String) - class jp.co.intra_mart.foundation.security.account.AccountRole のコンストラクタ
コンストラクタ。
AccountRoleBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel.
アカウントが保有するロールの基本モデルです。
AccountRoleMapper - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper.
アカウントが保有するロールに関連するマッパです。
AccountRolePermissionSelector - class jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector.
ユーザIDから有効なすべてのロールを取得するセレクタ。
AccountRolePermissionSelector() - class jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector のコンストラクタ
コンストラクタ。
AccountSecurityHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler.
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
AccountSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler, String, String) - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler のコンストラクタ
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
AccountTax - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax.
税明細クラス
機能は以下の通り
税明細の情報を保持します。
AccountTax(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のコンストラクタ
指定されたレコード番号でAccountTaxを作成します｡
AcsData - class jp.co.intra_mart.foundation.acssecurity.AcsData.
推奨されていません。
AcsData() - class jp.co.intra_mart.foundation.acssecurity.AcsData のコンストラクタ
推奨されていません。
AcssecurityException - exception jp.co.intra_mart.foundation.acssecurity.AcssecurityException.
アクセスセキュリティ情報操作時にエラーが発生した場合にスローされます。
ActionListener - interface jp.co.intra_mart.foundation.service.client.ActionListener.
このクラスは、主にイベントにより処理されるリスナーを実装する ためのスケルトンを提供します。
ActivationKey - interface jp.co.intra_mart.foundation.datastore.common.config.ActivationKey.
ライフタイム期間の有効開始日時を定義します。
ActiveSessionAccessor - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor.
アクティブなセッション情報操作インターフェース。
ActiveSessionBindingListener - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionBindingListener.
HttpSessionBindingListener を実装したアクティブなセッション情報を登録または削除するためのイベントトリガークラス。
ActiveSessionBindingListener() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionBindingListener のコンストラクタ
コンストラクタ。
ActiveSessionBindingListener(ActiveSessionInfo) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionBindingListener のコンストラクタ
コンストラクタ。
ActiveSessionException - exception jp.co.intra_mart.foundation.security.exception.ActiveSessionException.
アクティブなセッション情報例外の基本となる例外クラス。
ActiveSessionException(String) - class jp.co.intra_mart.foundation.security.exception.ActiveSessionException のコンストラクタ
コンストラクタ。
ActiveSessionException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.ActiveSessionException のコンストラクタ
コンストラクタ。
ActiveSessionException(Throwable) - class jp.co.intra_mart.foundation.security.exception.ActiveSessionException のコンストラクタ
コンストラクタ。
ActiveSessionException() - class jp.co.intra_mart.foundation.security.exception.ActiveSessionException のコンストラクタ
コンストラクタ。
ActiveSessionFilter - class jp.co.intra_mart.foundation.security.filter.ActiveSessionFilter.
アクティブセッションフィルタ。
ActiveSessionFilter() - class jp.co.intra_mart.foundation.security.filter.ActiveSessionFilter のコンストラクタ

ActiveSessionInfo - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo.
アクティブなセッション情報操作クラス。
ActiveSessionInfo() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のコンストラクタ
コンストラクタ。
ActiveSessionInfo(HttpServletRequest) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のコンストラクタ
コンストラクタ。
ActiveSessionInfo(SessionInfo, HttpSession, String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のコンストラクタ
コンストラクタ。
ActiveSessionInfo(SessionInfo, String, int, String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のコンストラクタ
コンストラクタ。
ActiveSessionInvalidatedByForceException - exception jp.co.intra_mart.foundation.security.exception.ActiveSessionInvalidatedByForceException.
アクティブなセッションが強制的に無効化されたことに関する例外クラス

ActiveSessionInvalidatedByForceException(String) - class jp.co.intra_mart.foundation.security.exception.ActiveSessionInvalidatedByForceException のコンストラクタ
コンストラクタ。
ActiveSessionInvalidatedByForceException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.ActiveSessionInvalidatedByForceException のコンストラクタ
コンストラクタ。
ActiveSessionInvalidatedByForceException(Throwable) - class jp.co.intra_mart.foundation.security.exception.ActiveSessionInvalidatedByForceException のコンストラクタ
コンストラクタ。
ActiveSessionInvalidatedByForceException() - class jp.co.intra_mart.foundation.security.exception.ActiveSessionInvalidatedByForceException のコンストラクタ
コンストラクタ。
ActiveSessionManager - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager.
アクティブセッション情報管理マネージャクラス。
ActiveSessionManager() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のコンストラクタ
コンストラクタ。
ActiveSessionNotExistException - exception jp.co.intra_mart.foundation.security.exception.ActiveSessionNotExistException.
アクティブなセッションが存在しない例外クラス。
ActiveSessionNotExistException(String) - class jp.co.intra_mart.foundation.security.exception.ActiveSessionNotExistException のコンストラクタ
コンストラクタ。
ActiveSessionNotExistException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.ActiveSessionNotExistException のコンストラクタ
コンストラクタ。
ActiveSessionNotExistException(Throwable) - class jp.co.intra_mart.foundation.security.exception.ActiveSessionNotExistException のコンストラクタ
コンストラクタ。
ActiveSessionNotExistException() - class jp.co.intra_mart.foundation.security.exception.ActiveSessionNotExistException のコンストラクタ
コンストラクタ。
ActivityFrameworkHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler.
推奨されていません。 このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。
ActivityFrameworkHTTPActionEventFilterHandler(HTTPActionEventHandler) - class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler のコンストラクタ
推奨されていません。 フレームワークのセッション環境を作成するためのフィルタハンドラを作成します。
ActivityHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler.
持続したセッションを確立するためのハンドラです。
ActivityHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler のコンストラクタ
新しいイベントハンドラを作成します。
ActivityHTTPActionEventHandler(String) - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler のコンストラクタ
指定のＵＲＬに再接続するための新しいイベントハンドラを作成します。
AdminMenuAccessor - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor.
メニューアクセッサインタフェース。
AdminMenuExporter - interface jp.co.intra_mart.foundation.security.menu.AdminMenuExporter.
メニューエクスポートインタフェースです。
AdminMenuImporter - interface jp.co.intra_mart.foundation.security.menu.AdminMenuImporter.
メニューインポートインタフェースです。
AdminMenuInclusion - class jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion.
メニュー内包情報クラス。
AdminMenuInclusion(String, String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion のコンストラクタ
コンストラクタ。
AdminMenuManager - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager.
管理メニューマネージャクラス。
AdminMenuPermissionSelector - class jp.co.intra_mart.foundation.security.permission.AdminMenuPermissionSelector.
ユーザIDから有効なメニューのID一覧を取得するセレクタ。
AdminMenuPermissionSelector() - class jp.co.intra_mart.foundation.security.permission.AdminMenuPermissionSelector のコンストラクタ
コンストラクタ。
AdminMenuPostWriterListener - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener.
メニュー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AdminMenuQueryWriterListener - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener.
メニュー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
AdminMenuReaderDecorator - interface jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator.
メニュー情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
AdvancedOutputStreamWriter - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter.
このクラスは、基礎となる java.io.OutputStreamWriter をフィルタリングした Writer 機能を提供します。
AdvancedOutputStreamWriter(OutputStream, String) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のコンストラクタ
指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のコンストラクタ
デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream, Charset) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のコンストラクタ
与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream, CharsetEncoder) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のコンストラクタ
与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のコンストラクタ
OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter クラスを使用してください。
AdvancedOutputStreamWriter(OutputStream, String) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のコンストラクタ
推奨されていません。 指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のコンストラクタ
推奨されていません。 デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream, Charset) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のコンストラクタ
推奨されていません。 与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream, CharsetEncoder) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のコンストラクタ
推奨されていません。 与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のコンストラクタ
推奨されていません。 OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。
AllVersions - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions.
全バージョン管理情報クラス
機能は以下の通り
全バージョン管理情報を保持します。
AllVersions() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のコンストラクタ
バージョン管理を作成します。
AllowedBusTract - class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract.
使用可能業務トランザクションのテーブル情報クラス 機能は以下の通り
使用可能業務トランザクションのテーブル情報を保持します。
AllowedBusTract() - class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract のコンストラクタ
使用可能業務トランザクションのテーブルを作成します。
Application - interface jp.co.intra_mart.foundation.datastore.common.config.Application.
アプリケーションを定義します。
ApplicationException - exception jp.co.intra_mart.framework.system.exception.ApplicationException.
フレームワーク内で発生したアプリケーション例外です。
ApplicationException() - class jp.co.intra_mart.framework.system.exception.ApplicationException のコンストラクタ
詳細メッセージを指定しないで ApplicationException を構築します。
ApplicationException(String) - class jp.co.intra_mart.framework.system.exception.ApplicationException のコンストラクタ
指定された詳細メッセージを持つ ApplicationException を構築します。
ApplicationException(Throwable) - class jp.co.intra_mart.framework.system.exception.ApplicationException のコンストラクタ
この例外の発生原因となる例外を持つ ApplicationException を構築します。
ApplicationException(String, Throwable) - class jp.co.intra_mart.framework.system.exception.ApplicationException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ApplicationException を構築します。
ApplicationInfo - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo.
アプリケーション情報のインタフェース。
AttachmentFile - interface jp.co.intra_mart.foundation.mail.javamail.model.AttachmentFile.
添付ファイルのモデルです。
Attribute - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute.
属性を定義します。
AttributeType - class jp.co.intra_mart.foundation.datastore.common.config.AttributeType.
属性で指定できる型です。
AutoDetectedDataSource - class jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedDataSource.
セッション情報からログイングループに設定されているデータソースを取得しラップします。
AutoDetectedDataSource() - class jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedDataSource のコンストラクタ

AutoDetectedDataSource(InitialContext) - class jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedDataSource のコンストラクタ
AutoDetectedDataSourceを新規に生成します。
AutoDetectedUserInfo - class jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedUserInfo.
セッションからログイン情報を取得するUserInfoのラッパークラスです。
AutoDetectedUserInfo() - class jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedUserInfo のコンストラクタ
AutoDetectedUserInfoを新規に生成します。
accountAdded(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウント情報をデータストアに作成した直後にコールされます。
accountAdded(String, Account) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener のメソッド
アカウント情報をデータストアに作成した直後にコールされます。
accountDeleted(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウント情報をデータストアから削除した直後にコールされます。
accountDeleted(String, String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener のメソッド
アカウント情報をデータストアから削除した直後にコールされます。
accountRoleAdded(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウントロール情報をデータストアに作成した直後にコールされます。
accountRoleAdded(String, String, AccountRole) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener のメソッド
アカウントロール情報をデータストアに作成した直後にコールされます。
accountRoleDeleted(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウントロール情報をデータストアから削除した直後にコールされます。
accountRoleDeleted(String, String, String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener のメソッド
アカウントロール情報をデータストアから削除した直後にコールされます。
accountRoleUpdated(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウントロール情報をデータストアに更新した直後にコールされます。
accountRoleUpdated(String, String, AccountRole) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener のメソッド
アカウントロール情報をデータストアに更新した直後にコールされます。
accountUpdated(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウント情報をデータストアに更新した直後にコールされます。
accountUpdated(String, Account) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener のメソッド
アカウント情報をデータストアに更新した直後にコールされます。
acntFromDBToIS(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
acntFromISToDB(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
action(Object) - interface jp.co.intra_mart.foundation.service.client.ActionListener のメソッド
このメソッドは、特定のイベント発生時に実行されます。
action(Object) - class jp.co.intra_mart.foundation.service.client.NetworkAgent のメソッド
このオブジェクトの実行ロジック。
action(Object) - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
推奨されていません。
action(Object) - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
推奨されていません。
action(Object) - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
推奨されていません。
action(Object) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
推奨されていません。
action(Object) - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
推奨されていません。
action(Object) - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
推奨されていません。
action(Object) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
推奨されていません。
action(HTTPActionEventContext, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent のメソッド
イベント処理メソッドです。
action(HTTPActionEventContext, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent のメソッド
イベント処理メソッドです。
activeCount() - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のメソッド
現在取得済みモニターの数を取得します。
activeCount() - class jp.co.intra_mart.foundation.utility.LockMonitor のメソッド
推奨されていません。 現在取得済みモニターの数を取得します。
add(int, Object) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リストの指定された位置に、指定された要素を挿入します。
add(Object) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リストの最後に、指定された要素を追加します。
add(int, Object) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リストの指定された位置に、指定された要素を挿入します。
add(Object) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リストの最後に、指定された要素を追加します。
add(SelectItem) - class jp.co.intra_mart.foundation.navigator.EventItem のメソッド
イベントノード追加
addAccount(Account) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントを新規追加します。
addAccountRole(String, AccountRole) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントロールを新規追加します。
addActiveSessionInfo(ActiveSessionInfo) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたアクティブなセッション情報を登録します。
addActiveSessionInfo(ActiveSessionInfo) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたアクティブなセッション情報を登録します。
addActiveSessionInfo(ActiveSessionInfo) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたアクティブなセッション情報を登録します。
addAll(Collection) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リストの末尾に、指定された Collection のすべての要素を追加します。
addAll(int, Collection) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リスト内の指定された位置から、指定された Collection のすべての要素を挿入します。
addAll(Collection) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リストの末尾に、指定された Collection のすべての要素を追加します。
addAll(int, Collection) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リスト内の指定された位置から、指定された Collection のすべての要素を挿入します。
addAttachment(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
添付ファイルを追加します。
addAutoCommitCondition(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
推奨されていません。 BapiController.addIgnoreErrMsgReturnType(java.lang.String)に置き換えられました。
addBatch(Batch) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチ情報を新規登録します。
addBcc(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Bccを追加します。
addBcc(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Bccを追加します。
addCSVHeaderText(String) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 出力するCSVのヘッダ部分をセットします。
addCalendarInfo(String, CalendarInfo) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータを新規に追加します。
addCategory(ItemCategory) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のメソッド
商品カテゴリを新規登録します。
addCategoryDetail(CategoryDetail) - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のメソッド
分類区分詳細を登録します。
addCc(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Ccを追加します。
addCc(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Ccを追加します。
addChild(MenuTree) - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
子メニューを追加します。
addChildBranch(TreeBranch) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
指定されたブランチ branchを子ノードとして追加します。
addChildLeaf(TreeLeaf) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
指定されたリーフ leafを子ノードとして追加します。
addChildNode(TreeNode) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
指定されたノード node を子ノードとして追加します。
addClassArchive(File) - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
クラスパスに指定のアーカイブファイルを追加します。
addClassArchiveLibrary(File) - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
クラスパスに指定のアーカイブファイル格納ディレクトリを追加します。
addClassPath(File) - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
クラスパスを追加します。
addCloseSocketEventListener(SocketEventListener) - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
addCloseSocketEventListener(SocketEventListener) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
addCloseSocketEventListener(SocketEventListener) - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
addCloseSocketEventListener(SocketEventListener) - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
addCompany(Company) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
会社を登録します。
addComparator(Comparator) - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator のメソッド
指定されたコンパレータ comparator を追加します。
addComparator(Comparator) - class jp.co.intra_mart.foundation.utility.MultiComparator のメソッド
推奨されていません。 指定されたコンパレータ comparator を追加します。
addConditioner(ReportFileConditioner) - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のメソッド
ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
addConditioner(GCConditioner) - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
推奨されていません。
addConditioner(ReportFileConditioner) - class jp.co.intra_mart.foundation.utility.report.FileReporter のメソッド
推奨されていません。 ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
addController(AccessController) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
アクセスコントローラを追加します。
addControllerDepartment(String, DepartmentInfo) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
組織をアクセスコントローラに紐付けます。
addControllerPost(String, PostInfo) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
役職をアクセスコントローラに紐付けます。
addControllerPublicGroup(String, PublicGroupInfo) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
パブリックグループをアクセスコントローラに紐付けます。
addControllerRole(String, String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
ロールをアクセスコントローラに紐付けます。
addCookie(Cookie) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
指定されたCookieをレスポンスに追加します。
addCookie(HttpServletRequest, ExtendedHttpServletResponse, Cookie) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
指定されたCookieをレスポンスに追加します。
addCookie(HttpServletRequest, ExtendedHttpServletResponse, Cookie) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
指定されたCookieをレスポンスに追加します。
addCookie(HttpServletRequest, ExtendedHttpServletResponse, Cookie) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
指定されたCookieをレスポンスに追加します。
addCookie(Cookie) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このメソッドは、スーパークラスにある HttpServletResponseWrapper.addCookie(Cookie cookie) メソッドをそのまま呼び出します。
addCreateSocketEventListener(SocketEventListener) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。
addCreateSocketEventListener(SocketEventListener) - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。
addData(BarGraphObject) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
描画オブジェクトに新しいデータを追加します。
addData(int, BarGraphObject) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
指定された位置に、指定された描画オブジェクトを追加します。
addData(double) - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
値を追加します。
addData(int) - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
値を追加します。
addData(CircleGraphObject) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
描画オブジェクトに新しいデータを追加します。
addData(int, CircleGraphObject) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
指定された位置に、指定された描画オブジェクトを追加します。
addData(LineGraphObject) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
描画オブジェクトに新しいデータを追加します。
addData(int, LineGraphObject) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
指定された位置に、指定された描画オブジェクトを追加します。
addData(double) - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
値を追加します。
addData(int) - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
値を追加します。
addData(PortFolioObject) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
描画オブジェクトに新しいデータを追加します。
addData(int, PortFolioObject) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
指定された位置に、指定された描画オブジェクトを追加します。
addData(RadarChartObject) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
描画オブジェクトに新しいデータを追加します。
addData(int, RadarChartObject) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
指定された位置に、指定された描画オブジェクトを追加します。
addData(double) - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
値を追加します。
addData(int) - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
値を追加します。
addDateHeader(String, long) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。
addDateHeader(HttpServletRequest, ExtendedHttpServletResponse, String, long) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。
addDateHeader(HttpServletRequest, ExtendedHttpServletResponse, String, long) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。
addDateHeader(HttpServletRequest, ExtendedHttpServletResponse, String, long) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。
addDateHeader(String, long) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このメソッドは、スーパークラスの HttpServletResponseWrapper.addDateHeader(java.lang.String name, long date) メソッドをそのまま呼び出します。
addDeal(Deal) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
取扱情報を新規登録します。
addDepartment(Department) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織を登録します。
addDepartment(DepartmentInfo) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

addDetail(DealDetail) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable のメソッド
取扱詳細を追加します。
addDetail(String) - class jp.co.intra_mart.framework.base.service.validator.ValidationExceptionDetail のメソッド
検証結果の詳細を追加します。
addError(MKError) - class jp.co.intra_mart.extension.maskat.util.MKErrors のメソッド
エラー要素を追加します。
addEventResultItemInfo(EventNavigatorManager, String, String, EventResultItemInfo) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
addEventResultItemInfo(String, String, EventResultItemInfo) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
addEventResultItemInfo(EventNavigatorManager, String, String, EventResultItemInfo) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
addFavoriteMenu(String, FavoriteMenu) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
マイメニューを新規追加します。
addFavoriteSaveEventResultItemInfo(EventNavigatorManager, String, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。
addFavoriteSaveEventResultItemInfo(String, String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。
addFavoriteSaveEventResultItemInfo(EventNavigatorManager, String, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。
addField(CurlFieldBean) - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer のメソッド
フィールド一覧リストにフィールドを追加します。
addGroupImageIcon(ImageIconInfo) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
グループのイメージアイコン情報を新規登録します。
addGroupSet(PublicGroupSet) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループセットを登録します。
addHeader(String, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
指定された名称で指定された値を持つレスポンスヘッダを追加します。
addHeader(HttpServletRequest, ExtendedHttpServletResponse, String, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
指定された名称で指定された値を持つレスポンスヘッダを追加します。
addHeader(HttpServletRequest, ExtendedHttpServletResponse, String, String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
指定された名称で指定された値を持つレスポンスヘッダを追加します。
addHeader(HttpServletRequest, ExtendedHttpServletResponse, String, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
指定された名称で指定された値を持つレスポンスヘッダを追加します。
addHeader(String, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このメソッドは、スーパークラスの HttpServletResponseWrapper.addHeader(java.lang.String name, java.lang.String value) メソッドをそのまま呼び出します。
addHeader(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
ヘッダーを追加します。
addIgnoreErrMsgReturnType(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
エラーメッセージを無視するRETURN-TYPEを追加します。
addIntHeader(String, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
指定された名称で指定された整数値を持つレスポンスヘッダを追加します。
addIntHeader(HttpServletRequest, ExtendedHttpServletResponse, String, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
指定された名称で指定された整数値を持つレスポンスヘッダを追加します。
addIntHeader(HttpServletRequest, ExtendedHttpServletResponse, String, int) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
指定された名称で指定された整数値を持つレスポンスヘッダを追加します。
addIntHeader(HttpServletRequest, ExtendedHttpServletResponse, String, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
指定された名称で指定された整数値を持つレスポンスヘッダを追加します。
addIntHeader(String, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このメソッドは、スーパークラスの HttpServletResponseWrapper.addIntHeader(java.lang.String name, int value) メソッドをそのまま呼び出します。
addItem(Item) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
商品情報を新規登録します。
addListener(ShutdownListener) - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の static メソッド
シャットダウンリスナーを登録します。
addListener(EventListener) - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
リスナーを登録します。
addLoginGroup(LoginGroup) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループを新規追加します。
addMainPagePattern(String, MainPagePatternInfo) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンを新規追加します。
addMenuDepartment(String, DepartmentInfo) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
組織をメニューに紐付けます。
addMenuItem(String, MenuItem) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニューを追加します。
addMenuItem(String, MenuItem) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューを追加します。
addMenuLoginGroup(String, String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
管理メニューにアクセス権を設定します。
addMenuLoginGroup(String, String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
指定したログイングループのアクセス権をメニューに設定します。
addMenuPost(String, PostInfo) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
役職をメニューに紐付けます。
addMenuPublicGroup(String, PublicGroupInfo) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
パブリックグループをメニューに紐付けます。
addMenuRole(String, String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
ロールをメニューに紐付けます。
addNativePath(File) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader のメソッド
クラスパスを追加します。
addOtherInfo(Object, Object) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
その他情報を追加する。
addOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
メッセージの出力先を追加します。
addOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
メッセージの出力先を追加します。
addOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の static メソッド
メッセージの出力先を追加します。
addPage(ResultPageItem) - class jp.co.intra_mart.foundation.navigator.EventResultItem のメソッド
リンクページ情報追加
addParameter(String, String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
パラメータを追加します。
addParameter(String, String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
パラメータを追加します。
addParameter(Object) - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
パラメータを追加します。
addParameter(String, String) - interface jp.co.intra_mart.framework.base.web.tag.ParameterSendable のメソッド
パラメータを追加します。
addPasswordHistory(String, String, String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
パスワード履歴の追加。
addPasswordHistory(String, String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
パスワード履歴の追加。
addPasswordHistory(String, String, String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
パスワード履歴の追加。
addPost(CompanyPost) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
役職を登録します。
addPost(PostInfo) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

addPrivateGroup(PrivateGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
プライベートグループを登録します。
addPublicGroup(PublicGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループを登録します。
addPublicGroup(PublicGroupInfo) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

addRecord(CurlRecordBeanIF) - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer のメソッド
レコード一覧リストにレコードを追加します。
addReplyTo(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
ReplyToを追加します。
addReporter(MessageReporter) - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。
addReporter(MessageReporter) - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。
addRole(Role) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

addRole(Role) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール情報を新規登録します。
addSearchPath(File) - class jp.co.intra_mart.common.aid.jdk.java.lang.SearchableClassLoader のメソッド
指定されたパスがファイルを表している場合、jar または zip を指定されたと判断して、 ResourceLoader.addClassArchive(File)を呼び出します。
addSubRole(String, String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
サブロールIDを追加します。
addSuperUser(SuperUser) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
システム管理者情報を新規に作成します。
addSuperUser(String, SuperUser) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
グループ管理者を新規追加します。
addTemplate(ItemTemplate) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager のメソッド
商品属性テンプレート情報を新規登録します。
addThreadStopListener(ThreadStopListener) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のメソッド
このスレッドが終了したときに呼び出されるイベントリスナーを登録します。
addThreadStopListener(ThreadStopListener) - class jp.co.intra_mart.foundation.utility.ExtendedThread のメソッド
推奨されていません。 このスレッドが終了したときに呼び出されるイベントリスナーを登録します。
addTo(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Toを追加します。
addTo(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Toを追加します。
addURL(String) - class jp.co.intra_mart.foundation.http.SessionQuery のメソッド
推奨されていません。 GenericURLBuilder.createFilePath(String) および URLBuilder.createURLonSession(String)に置き替えられました。
addUnit(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager のメソッド
単位を追加します。
addUser(User) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager のメソッド
ユーザを登録します。
addUserImageIcon(ImageIconInfo, String) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
ユーザのイメージアイコン情報を新規登録します。
addValidEndDate(int) - interface jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor のメソッド
SYSTEM日付に指定した日数を加えた日付を取得します。
addValidEndDate(int) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutManager のメソッド
SYSTEM日付に指定した日数を加えた日付を取得します。
addValidEndDate(int) - class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor のメソッド
SYSTEM日付に指定した日数を加えた日付を取得します。
addVersion(CompanyVersion) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
会社構成バージョンを新規に登録します。
addVersion(PublicGroupVersion) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループセット構成バージョンを新規に登録します。
append(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
append(String, String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
append(byte[]) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
append(String) - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ファイルにテキストを追記します。
append(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
append(String, String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
append(byte[]) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
archive(File) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
archive(File, FileFilter) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
archive(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
archive(OutputStream, FileFilter) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
archive(ZipOutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
archive(ZipOutputStream, FileFilter) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
archive(File) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
archive(File, FileFilter) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
archive(OutputStream) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
archive(OutputStream, FileFilter) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
archive(ZipOutputStream) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
archive(ZipOutputStream, FileFilter) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
attachFile(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 添付ファイルの内容をセットする。
available() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
この入力ストリームのメソッドの次の呼び出し側からブロックされることなく、 この入力ストリームから読み込むことができる(またはスキップできる)バイト数 を返します。

B

BASE64DecodeInputStream - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream.
このクラスは、BASE64 エンコードされたデータを読み込むための ストリームフィルタを実装します。
BASE64DecodeInputStream(InputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream のコンストラクタ
指定された InputStream から読み込む BASE64 デコード入力ストリームを作成します。
BASE64DecodeInputStream - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream クラスを使用してください。
BASE64DecodeInputStream(InputStream) - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream のコンストラクタ
推奨されていません。 指定された InputStream から読み込む BASE64 デコード入力ストリームを作成します。
BASE64DecodeOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream.
このクラスは、BASE64 デコードされたデータを書き込むための ストリームフィルタを実装します。
BASE64DecodeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream のコンストラクタ
指定された OutputStream に書き込む BASE64デコーダーを作成します。
BASE64DecodeOutputStream - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream クラスを使用してください。
BASE64DecodeOutputStream(OutputStream) - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に書き込む BASE64デコーダーを作成します。
BASE64EncodeOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream.
このクラスは、BASE64 エンコードされたデータを書き込むための ストリームフィルタを実装します。
BASE64EncodeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream のコンストラクタ
指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。
BASE64EncodeOutputStream(OutputStream, boolean) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream のコンストラクタ
指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。
BASE64EncodeOutputStream - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream クラスを使用してください。
BASE64EncodeOutputStream(OutputStream) - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。
BASE64EncodeOutputStream(OutputStream, boolean) - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。
BATCH - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
バッチ情報
BATCH_ID - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
バッチID
BATCH_NAME - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
バッチ名
BLANK_USER_INFO - class jp.co.intra_mart.framework.base.util.UserInfoWrapper の static 変数
デフォルトでラップされているクラスです。
BadRequestException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException.
不正なリクエストを受け付けたことを通知するための例外です。
BadRequestException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException のコンストラクタ
指定のメッセージを持つ例外を作成します。
BadRequestException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
BadRequestException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException のコンストラクタ
例外を作成します。
Bank - class jp.co.intra_mart.foundation.sap.module.accounting.Bank.
銀行情報クラス
機能は以下の通り
銀行の情報を保持します。
Bank() - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のコンストラクタ
銀行情報を作成します。
BankController - class jp.co.intra_mart.foundation.sap.module.accounting.BankController.
銀行コントローラクラス
機能は以下の通り
銀行の情報を取得します。
BankController() - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のコンストラクタ
BankListのコンストラクタを呼び出し銀行一覧を作成します。
BankController(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のコンストラクタ
BankListのコンストラクタを呼び出し銀行一覧を作成します。
BankDataInfo - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo.
銀行データ情報クラス
機能は以下の通り
銀行データの情報を保持します。
BankDataInfo() - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のコンストラクタ
銀行データ情報を作成します。
BankList - class jp.co.intra_mart.foundation.sap.module.accounting.BankList.
銀行一覧クラス
機能は以下の通り
銀行の情報を一覧形式で取得します。
BankList(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.BankList のコンストラクタ
executeBapiを呼び出し銀行一覧を作成します。
BapiController - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController.
BAPIコントローラクラス。
BapiController(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のコンストラクタ
プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡
BapiController(String, ConnectionManager) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のコンストラクタ
コネクションマネージャのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録・更新処理を実行することができます。
BapiController(String, SapClient) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のコンストラクタ
サップクライアントのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。
BapiHash - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash.
BapiHashクラス
機能は以下の通り
汎用モジュールAPIを呼び出すソリューション特化型APIが、BAPIを実行する為に 使用するパラメータ値を設定する｡ SAPのBAPI処理にて使用されるパラメータの値を保持します。
BapiHash(String, String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のコンストラクタ
指定された入力／出力区分、パラメータ属性でBapiHashオブジェクトを生成します｡ このコンストラクタはパラメタ属性が"import" / "export"の場合に使用します｡ パラメータ名は""が設定されます｡
BapiHash(String, String, String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のコンストラクタ
入力／出力区分、パラメータ属性、パラメータ名でBapiHashオブジェクトを生成します｡ このコンストラクタはパラメタ属性が"structure"の場合に使用します。
BapiHash(String, String, String, int) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のコンストラクタ
入力／出力区分、パラメータ属性、パラメータ名、レコード番号でBapiHash オブジェクトを生成します｡このコンストラクタはパラメタ属性が"table"の場合 に使用します。
BapiReturn - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn.
BapiReturnクラス
機能は以下の通り
SAPのBAPI処理の実行結果に関する値を保持します。
BapiReturn(JCO.Structure) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のコンストラクタ
指定されたJCO.Structure情報でBapiReturnを作成します。
BapiReturn(JCO.Table) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のコンストラクタ
指定されたJCO.Table情報でBapiReturnを作成します。
BarGraphDrawer - class jp.co.intra_mart.foundation.graph.BarGraphDrawer.
棒グラフを描画します。
BarGraphDrawer(int, int, int) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のコンストラクタ
ｙ軸の目盛値をint表現で棒グラフを作成します。
BarGraphDrawer(double, double, double) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のコンストラクタ
ｙ軸の目盛値をdouble表現で棒グラフを作成します。
BarGraphObject - class jp.co.intra_mart.foundation.graph.BarGraphObject.
BarGraphDrawerクラスのデータを保存するオブジェクトです。
BarGraphObject() - class jp.co.intra_mart.foundation.graph.BarGraphObject のコンストラクタ
デフォルトのデータオブジェクトを作成します。
BarGraphObject(Color) - class jp.co.intra_mart.foundation.graph.BarGraphObject のコンストラクタ
線の色を指定して、データオブジェクトを作成します。
BaseAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor.
基本エンティティに対する情報操作用のインタフェースです。
BaseModel - interface jp.co.intra_mart.foundation.datastore.common.config.BaseModel.
基本モデルを定義します。
BaseModel - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel.
基本モデルの情報です。
BaseModelContext - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext.
基本モデルの初期化に必要な設定を持ちます。
BaseTable - interface jp.co.intra_mart.foundation.datastore.common.config.BaseTable.
基本テーブルを定義します。
Batch - class jp.co.intra_mart.foundation.security.batch.Batch.
バッチ・モデルクラス
Batch() - class jp.co.intra_mart.foundation.security.batch.Batch のコンストラクタ
コンストラクタ。
Batch(String) - class jp.co.intra_mart.foundation.security.batch.Batch のコンストラクタ
コンストラクタ。
BatchAccessor - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor.

BatchBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel.
バッチ情報の基本モデルです。
BatchExporter - interface jp.co.intra_mart.foundation.security.batch.BatchExporter.
バッチバックアップインタフェースです。
BatchImporter - interface jp.co.intra_mart.foundation.security.batch.BatchImporter.
バッチバックアップインタフェースです。
BatchManager - class jp.co.intra_mart.foundation.security.batch.BatchManager.
バッチマネージャクラス。
BatchManager(String) - class jp.co.intra_mart.foundation.security.batch.BatchManager のコンストラクタ
コンストラクタ。
BatchMapper - interface jp.co.intra_mart.system.security.datastore.inf.BatchMapper.
バッチ情報に関連するマッパです。
BatchPostWriterListener - interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener.

BatchProcessException - exception jp.co.intra_mart.foundation.datastore.exception.BatchProcessException.
バッチ実行時に処理エラーが発生したことを示すためにスローされます。
BatchProcessException() - class jp.co.intra_mart.foundation.datastore.exception.BatchProcessException のコンストラクタ
コンストラクタ
BatchProcessException(String) - class jp.co.intra_mart.foundation.datastore.exception.BatchProcessException のコンストラクタ
コンストラクタ
BatchProcessException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.BatchProcessException のコンストラクタ
コンストラクタ
BatchProcessException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.BatchProcessException のコンストラクタ
コンストラクタ
BatchQueryWriterListener - interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener.

BatchRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa.
ロットの範囲情報クラス
機能は以下の通り
ロットの範囲情報を保持します。
BatchRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のコンストラクタ
ロットの範囲情報を作成します。
BatchRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のコンストラクタ
ロットの範囲情報を作成します。
BatchReaderDecorator - interface jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator.

BatchSystemException - exception jp.co.intra_mart.foundation.datastore.exception.BatchSystemException.
バッチ実行時にシステムエラーが発生したことを示すためにスローされます。
BatchSystemException() - class jp.co.intra_mart.foundation.datastore.exception.BatchSystemException のコンストラクタ
コンストラクタ
BatchSystemException(String) - class jp.co.intra_mart.foundation.datastore.exception.BatchSystemException のコンストラクタ
コンストラクタ
BatchSystemException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.BatchSystemException のコンストラクタ
コンストラクタ
BatchSystemException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.BatchSystemException のコンストラクタ
コンストラクタ
BillingDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn.
処理予定明細データのテーブル情報クラス
機能は以下の通り
処理予定明細データのテーブル情報を保持します。
BillingDataIn() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のコンストラクタ
処理予定明細データのテーブル情報を作成します。
BillingDataIn(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のコンストラクタ
処理予定明細データのテーブル情報を作成します。
BillingDocCreateMultiple - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple.
請求伝票登録情報クラス
機能は以下の通り
請求伝票登録情報を保持します。
BillingDocCreateMultiple() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のコンストラクタ
請求伝票登録情報を作成します。
BillingDocCreateMultiple(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のコンストラクタ
コネクションマネージャーを引数に持つコンストラクタ。
BillingDocCreateMultiple(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のコンストラクタ
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
BillingDocCreateMultipleController - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController.
請求伝票登録コントローラクラス
機能は以下の通り
請求伝票を登録します。
BillingDocCreateMultipleController() - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController のコンストラクタ
BillingDocCreateMultipleControllerのコンストラクタを生成します。
BillingDocCreateMultipleController(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController のコンストラクタ
BillingDocCreateMultipleControllerのコンストラクタを生成します。
BillingDocCreateMultipleController(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController のコンストラクタ
BillingDocCreateMultipleControllerのコンストラクタを生成します。
BillingDocGetDetail - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail.
請求伝票詳細照会情報クラス
機能は以下の通り
請求伝票詳細照会情報を保持します。
BillingDocGetDetail(String, SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail のコンストラクタ
請求伝票詳細照会情報を作成します。
BillingDocGetDetailController - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController.
請求伝票詳細照会情報コントローラクラス
機能は以下の通り
請求伝票詳細照会情報を保持します。
BillingDocGetDetailController(String) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController のコンストラクタ
コンストラクタ生成
BillingDocGetDetailController(String, SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController のコンストラクタ
コンストラクタ生成
BillingDocGetList - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList.
請求伝票一覧照会情報クラス
機能は以下の通り
請求伝票一覧照会情報を保持します。
BillingDocGetList(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のコンストラクタ
請求伝票一覧照会情報を作成します。
BillingDocGetList(String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のコンストラクタ
請求伝票一覧照会情報を作成します。
BillingDocGetListController - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController.
請求伝票一覧照会情報コントローラクラス
機能は以下の通り
請求伝票一覧照会情報を保持します。
BillingDocGetListController() - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController のコンストラクタ
コンストラクタ生成
BillingDocGetListController(String, String, String, String) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController のコンストラクタ
コンストラクタ生成
BillingDocGetListController(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController のコンストラクタ
コンストラクタ生成
BillingDocGetListController(String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController のコンストラクタ
コンストラクタ生成
BillingDocumentDetail - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail.
後続請求伝票のテーブル情報クラス
機能は以下の通り
後続請求伝票のテーブル情報を保持します。
BillingDocumentDetail() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のコンストラクタ
後続請求伝票のテーブル情報を作成します。
BillingDocumentDetailList - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList.
後続請求伝票のテーブル情報クラス
機能は以下の通り
後続請求伝票のテーブル情報を保持します。
BillingDocumentDetailList() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList のコンストラクタ
後続請求伝票のテーブル情報を作成します。
BillingDocumentDetailList(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList のコンストラクタ
後続請求伝票のテーブル情報を作成します。
BrowseString - class jp.co.intra_mart.common.aid.jsdk.utility.BrowseString.
HTML表示用文字列変換ユーティリティクラス。
BusinessArea - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea.
事業領域情報クラス
機能は以下の通り
事業領域の情報を保持します。
BusinessArea() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のコンストラクタ
事業領域情報を作成します。
BusinessAreaController - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController.
事業領域コントローラクラス
機能は以下の通り
事業領域の情報を取得します。
BusinessAreaController() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のコンストラクタ
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BusinessAreaController(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のコンストラクタ
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BusinessAreaList - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList.
事業領域一覧クラス
機能は以下の通り
事業領域の情報を一覧形式で取得します。
BusinessAreaList(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList のコンストラクタ
executeBapiを呼び出し事業領域一覧を作成します。
backup(File) - class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory のメソッド
このデータを指定のファイルにバックアップします。
bapiReturnErrMessage - class jp.co.intra_mart.foundation.sap.module.AbstractController の変数
BAPI実行エラーメッセージ
bapiReturnMessage - class jp.co.intra_mart.foundation.sap.module.AbstractController の変数
BAPI実行結果メッセージ
begin() - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
ロックフラグを立てます。
begin(long) - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
ロックフラグを立てます。
begin() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager のメソッド
ラップしたTransactionManagerのbeginを呼び出します。
begin() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction のメソッド
ラップしたUserTransactionのbeginを呼び出します。
beginRequestScope() - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
ロックフラグを立てます。
beginRequestScope(long) - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
ロックフラグを立てます。
beginTransaction() - interface jp.co.intra_mart.foundation.database.DatabaseAccessor のメソッド
データベースアクセスのトランザクションを開始します。
beginTransaction() - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
データベースアクセスのトランザクションを開始します。
booleanValue() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値の真偽値表現を取得します。
buildExtendedHttpServletRequest(HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder のメソッド
ExtendedHttpServletRequest を作成して返します。
buildLDAPContextInfo(Map) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoBuilder の static メソッド
設定情報モデルをログイングループID毎に作成し、Mapで返す。

C

CALENDAR_ID - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
カレンダーID
CALENDAR_INFO - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
カレンダーが保有するデータ
CASCADE - class jp.co.intra_mart.foundation.datastore.common.config.DeleteType の static 変数
削除 ターゲットエンティティのデータを参照しているソースエンティティのデータを削除します。
CASCADE - class jp.co.intra_mart.foundation.datastore.common.config.LifetimeType の static 変数
削除 ターゲットエンティティの期間を参照しているソースエンティティのデータを削除します。
CATEGORY - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel の static 変数
カテゴリ
CATEGORY_BEGIN_TRANSACTION - interface jp.co.intra_mart.framework.system.log.LogConstant の static 変数
トランザクションを開始するタイプです。
CATEGORY_CLASS_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の static 変数
分類区分コード
CATEGORY_CLASS_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の static 変数
分類区分コード
CATEGORY_CLASS_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の static 変数
分類区分コード
CATEGORY_CLASS_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の static 変数
分類区分コード
CATEGORY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の static 変数
分類コード
CATEGORY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の static 変数
分類コード
CATEGORY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の static 変数
分類コード
CATEGORY_COMMIT_TRANSACTION - interface jp.co.intra_mart.framework.system.log.LogConstant の static 変数
トランザクションをコミットするタイプです。
CATEGORY_ROLLBACK_TRANSACTION - interface jp.co.intra_mart.framework.system.log.LogConstant の static 変数
トランザクションをロールバックするタイプです。
CCardDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn.
処理予定支払方法のテーブル情報クラス
機能は以下の通り
処理予定支払方法のテーブル情報を保持します。
CCardDataIn() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のコンストラクタ
処理予定支払方法のテーブル情報を作成します。
CCardDataIn(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のコンストラクタ
処理予定支払方法のテーブル情報を作成します。
CGIEnvironment - class jp.co.intra_mart.foundation.http.CGIEnvironment.
このクラスは、サーブレットクラス内で CGI 環境変数を扱えるように 各パラメータを CGI 環境変数で定義されているキーワードにマップします。
CGIEnvironment(HttpServletRequest) - class jp.co.intra_mart.foundation.http.CGIEnvironment のコンストラクタ
HTTP リクエストヘッダおよび Web サーバ情報から CGI 環境変数情報を構築します。
CHILD_ROLE_ID - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel の static 変数
子ロールコード
CLIENT_TYPE - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の static 変数
クライアントタイプ
COLOR - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
表示色
COLOR_PATTERN_ID - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
ページカラーパターン
COLUMN_NAVIGATOR_ACTION_TYPE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_ANSWER - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_COMPANY_CD - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_DEPARTMENT_CD - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_DESCRIPTION - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_EVENT_FLOW_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
イベントフロー
COLUMN_NAVIGATOR_EVENT_ITEM_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
イベントアイテム
COLUMN_NAVIGATOR_EVENT_RESULT_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
ナビゲート結果
COLUMN_NAVIGATOR_IDENTIFICATION_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
タイトル情報
COLUMN_NAVIGATOR_LOCALE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_MAX_SORT_NUM - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_NEXT_ITEM_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_OPEN - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_PAGE_URL - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_PARAM_KEY - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
ページパラメータ
COLUMN_NAVIGATOR_PARAM_VALUE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_PERMISSION_CHECK_FLAG - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_POST_CD - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_PUBLIC_GROUP_CD - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_PUBLIC_GROUP_SET_CD - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_QUESTION - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
保存イベント履歴
COLUMN_NAVIGATOR_RECORD_DATE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_RECORD_USER - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
共通
COLUMN_NAVIGATOR_RESULT_PAGE_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
結果ページ
COLUMN_NAVIGATOR_ROLE_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
権限情報
COLUMN_NAVIGATOR_SELECT_ITEM_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
選択アイテム
COLUMN_NAVIGATOR_SORT_NUMBER - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_START_EVENT_ITEM_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_TITLE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_TYPE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_USER_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
保存ナビゲート結果
COMPANY_CD - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel の static 変数
会社CD
COMPANY_CD - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel の static 変数
会社CD
COMPANY_CD - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel の static 変数
会社CD
COMPANY_CD - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel の static 変数
会社CD
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel の static 変数
会社コード
CONFIG_FILE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

CONTENTS - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の static 変数
コンテンツの種類
CONTENT_TYPE_IN - class jp.co.intra_mart.foundation.security.menu.MenuItem の static 変数
メニューコンテンツの種類（内部URL）。
CONTENT_TYPE_OUT - class jp.co.intra_mart.foundation.security.menu.MenuItem の static 変数
メニューコンテンツの種類（外部URL）。
CONTINUE - interface jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener の static 変数
リスナー処理を続行し、メール送信を行います。
CONTROLLER_SUFFIX - class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator の static 変数

COOKIE_SEPARATOR - interface jp.co.intra_mart.foundation.security.SessionInfo の static 変数
セッション情報をクッキーに保管する際のセパレータ。
COUNTRY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
国コード
COUNTRY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
国コード
CP_COOKIE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
セッション情報をクッキーに保管するパラメータ名。
CRYPTION_CATEGORY_MOBILE_USER_AGENT - class jp.co.intra_mart.foundation.security.account.AccountManager の static 変数
暗号化アルゴリズムカテゴリ: モバイル端末個体識別番号用。
CR_ERROR - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
認証処理エラーの返却値。
CR_LOCKED - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
アカウントロック状態の返却値。
CR_NG - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインエラーの返却値。
CR_NO_GROUP - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログイングループ未登録状態の返却値。
CR_NO_LICENSE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ライセンスなし、または有効期間外状態の返却値。
CR_NO_PERMISSION - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
無許可ページへのアクセスの返却値。
CR_NO_USER - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ユーザ未登録状態の返却値。
CR_OK - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
認証成功の返却値。
CR_SESSION_INITIAL - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
セッション初期状態の返却値。
CR_SESSION_LOGON - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
セッションログオン状態の返却値。
CR_SESSION_TIMEOUT - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
セッションタイムアウト状態の返却値。
CR_SESSION_UNMATCH - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
セッション不整合状態の返却値。
CURRENCY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の static 変数
通貨コード
CUSTOMER_COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の static 変数
取引先会社コード
CUSTOMER_COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel の static 変数
取引先会社コード
CUSTOMER_COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel の static 変数
取引先会社コード
CUSTOMER_COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel の static 変数
取引先会社コード
CUSTOMER_COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel の static 変数
取引先会社コード
CUSTOMER_DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の static 変数
取引先組織コード
CUSTOMER_DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel の static 変数
取引先組織コード
CUSTOMER_DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel の static 変数
取引先組織コード
CUSTOMER_DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel の static 変数
取引先組織コード
CUSTOMER_DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel の static 変数
取引先組織コード
CalendarAccessor - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor.
カレンダーアクセッサインタフェース。
CalendarExporter - interface jp.co.intra_mart.foundation.security.calendar.CalendarExporter.
カレンダーバックアップインタフェースです。
CalendarImporter - interface jp.co.intra_mart.foundation.security.calendar.CalendarImporter.
カレンダーバックアップインタフェースです。
CalendarInfo - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo.
カレンダーデータ・モデルクラス
CalendarInfo() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のコンストラクタ
コンストラクタ。
CalendarInfo(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のコンストラクタ
コンストラクタ。
CalendarInfoBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel.
カレンダーが保有するデータの基本モデルです。
CalendarInfoInternationalModel - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoInternationalModel.
カレンダーが保有するデータの国際化モデルです。
CalendarInfoMapper - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper.
カレンダーが保有するデータに関連するマッパです。
CalendarManager - class jp.co.intra_mart.foundation.security.calendar.CalendarManager.
カレンダーマネージャクラス

カレンダー情報の操作を行います。
CalendarManager(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のコンストラクタ
コンストラクタ。
CalendarPlugin - interface jp.co.intra_mart.foundation.security.calendar.CalendarPlugin.
カレンダデータプラグインインターフェース。
CalendarPluginAutumnalEquinox - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox.
カレンダデータプラグインクラス。
CalendarPluginAutumnalEquinox() - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox のコンストラクタ

CalendarPluginEndOfTheMonth - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth.
カレンダデータプラグインクラス。
CalendarPluginEndOfTheMonth() - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth のコンストラクタ

CalendarPluginInfo - interface jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo.
カレンダーデータプラグイン情報のインターフェース。
CalendarPluginLastDayInTheMonth - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth.
カレンダデータプラグインクラス。
CalendarPluginLastDayInTheMonth() - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth のコンストラクタ

CalendarPluginMondayMakeupHoliday - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday.
カレンダデータプラグインクラス。
CalendarPluginMondayMakeupHoliday() - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday のコンストラクタ

CalendarPluginVernalEquinox - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox.
カレンダデータプラグインクラス。
CalendarPluginVernalEquinox() - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox のコンストラクタ

CalendarPostWriterListener - interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener.
カレンダー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
CalendarQueryWriterListener - interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener.
カレンダー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
CalendarReaderDecorator - interface jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator.
アカウント情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
CategorizedCalendarInfo - class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo.
カテゴライズカレンダーデータクラス。
CategorizedCalendarInfo(CalendarInfo[]) - class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo のコンストラクタ
コンストラクタ。
CategoryDetail - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail.
分類区分詳細の基本属性のデータを取り扱います。
CategoryDetail() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のコンストラクタ
分類区分詳細に関連する情報を新規に生成します。
CategoryDetail(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のコンストラクタ
分類区分詳細に関連する情報を新規に生成します。
CategoryDetailBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel.
分類区分詳細の基本モデルです。
CategoryDetailInternational - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational.
分類区分詳細の国際化属性のデータを取り扱います。
CategoryDetailInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational のコンストラクタ

CategoryDetailInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel.
分類区分詳細の国際化モデルです。
CategoryDetailMapper - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper.
分類区分詳細に関連するマッパです。
CategoryManager - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager.
分類に関連する情報を管理します。
CategoryManager() - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のコンストラクタ

CateogryClass - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass.
分類区分の基本属性のデータを取り扱います。
CateogryClass() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のコンストラクタ
分類区分に関連する情報を新規に生成します。
CateogryClass(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のコンストラクタ
分類区分に関連する情報を新規に生成します。
CateogryClassBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel.
分類区分の基本モデルです。
CateogryClassInternational - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational.
分類区分の国際化属性のデータを取り扱います。
CateogryClassInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational のコンストラクタ

CateogryClassInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel.
分類区分の国際化モデルです。
CateogryClassMapper - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper.
分類区分に関連するマッパです。
CfgsBlob - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob.
選定: BLOB 内部データ (SCE)情報クラス
機能は以下の通り
選定: BLOB 内部データ (SCE)情報を保持します。
CfgsBlob() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のコンストラクタ
選定: BLOB 内部データ (SCE)情報を作成します。
CfgsBlob(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のコンストラクタ
選定: BLOB 内部データ (SCE)情報を作成します。
CfgsInst - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst.
選定: インスタンス情報クラス
機能は以下の通り
選定: インスタンス情報を保持します。
CfgsInst() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のコンストラクタ
選定: インスタンス情報を作成します。
CfgsInst(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のコンストラクタ
選定: インスタンス情報を作成します。
CfgsPartOf - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf.
選定: 部分設定情報クラス
機能は以下の通り
選定: 部分設定情報を保持します。
CfgsPartOf() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のコンストラクタ
選定: 部分設定情報を作成します。
CfgsPartOf(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のコンストラクタ
選定: 部分設定情報を作成します。
CfgsRef - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef.
選定: 参照データ情報クラス
機能は以下の通り
選定: 参照データ情報を保持します。
CfgsRef() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のコンストラクタ
選定: 参照データ情報を作成します。
CfgsRef(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のコンストラクタ
選定: 参照データ情報を作成します。
CfgsRefInst - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst.
選定: 参照明細/インスタンス情報クラス
機能は以下の通り
選定: 参照明細/インスタンス情報を保持します。
CfgsRefInst() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のコンストラクタ
選定: 参照明細/インスタンス情報を作成します。
CfgsRefInst(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のコンストラクタ
選定: 参照明細/インスタンス情報を作成します。
CfgsValue - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue.
選定: 特性値情報クラス
機能は以下の通り
選定: 特性値情報を保持します。
CfgsValue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のコンストラクタ
選定: 特性値情報を作成します。
CfgsValue(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のコンストラクタ
選定: 特性値情報を作成します。
CfgsVk - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk.
選定: バリアント条件キー情報クラス
機能は以下の通り
選定: バリアント条件キー情報を保持します。
CfgsVk() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のコンストラクタ
選定: バリアント条件キー情報を作成します。
CfgsVk(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のコンストラクタ
選定: バリアント条件キー情報を作成します。
ChangedListenerException - exception jp.co.intra_mart.foundation.exception.ChangedListenerException.
更新リスナーの例外クラス。
ChangedListenerException() - class jp.co.intra_mart.foundation.exception.ChangedListenerException のコンストラクタ
コンストラクタ。
ChangedListenerException(String) - class jp.co.intra_mart.foundation.exception.ChangedListenerException のコンストラクタ
コンストラクタ。
ChangedListenerException(Throwable) - class jp.co.intra_mart.foundation.exception.ChangedListenerException のコンストラクタ
コンストラクタ。
ChangedListenerException(String, Throwable) - class jp.co.intra_mart.foundation.exception.ChangedListenerException のコンストラクタ
コンストラクタ。
CharacterEncoder - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder.
このクラスは、文字エンコードの機能を提供します。
CharacterEncoder(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のコンストラクタ
文字コード変換のためのエンコーダを作成します。
CharacterEncoder - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder クラスを使用してください。
CharacterEncoder(String) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のコンストラクタ
推奨されていません。 文字コード変換のためのエンコーダを作成します。
CharacterSetManager - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager.
このクラスは J2SE,v1.4 でサポートされているエンコーディングセットと、 IANAに登録されているキャラクタセット名とのマッピング情報を管理するオブジェクトです。
CharacterSetManager() - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager のコンストラクタ

CircleGraphDrawer - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer.
円グラフを描画します。
CircleGraphDrawer() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のコンストラクタ
ｙ軸の目盛値をint表現で円グラフを作成します。
CircleGraphObject - class jp.co.intra_mart.foundation.graph.CircleGraphObject.
CircleGraphDrawerクラスのデータを保存するオブジェクトです。
CircleGraphObject(double, Color) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のコンストラクタ
グラフ値と色を指定して、データオブジェクトを作成します。
CircleGraphObject(int, Color) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のコンストラクタ
グラフ値と色を指定して、データオブジェクトを作成します。
CircleGraphObject(double, Color, String) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のコンストラクタ
グラフ値と色とキャプションを指定して、データオブジェクトを作成します。
CircleGraphObject(int, Color, String) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のコンストラクタ
グラフ値と色とキャプションを指定して、データオブジェクトを作成します。
ClientData - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData.
品目データ (クライアントレベル)情報クラス
機能は以下の通り
品目データ (クライアントレベル)情報を保持します。
ClientData() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のコンストラクタ
品目データ (クライアントレベル)情報を作成します。
ClientDataList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList.
品目データ (クライアントレベル)情報クラス
機能は以下の通り
品目データ (クライアントレベル)情報をテーブル型で保持します。
ClientDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList のコンストラクタ
品目データ (クライアントレベル)情報を作成します。
ClientDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList のコンストラクタ
品目データ (クライアントレベル)情報を作成します。
ClientTypeInfo - interface jp.co.intra_mart.foundation.security.ClientTypeInfo.
クライアントタイプ情報インタフェース。
ColorPatternInfo - interface jp.co.intra_mart.foundation.security.ColorPatternInfo.
カラーパターン情報を取得するインタフェース。
Column - interface jp.co.intra_mart.foundation.datastore.common.config.Column.
属性に対応するカラムの型を定義します。
ColumnMapping - interface jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping.
分割されたテーブルに割り当てられるカラムを定義します。
CommandLineArgument - class jp.co.intra_mart.common.platform.vm.CommandLineArgument.
このクラスはコマンド実引数を解釈するための共通実装です。
CommandLineArgument(String[]) - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のコンストラクタ
Java-VM から最初に実行される public かつ static な void main(String[]) メソッドの引数を受け取り解析します。
CommonCenterGrpGetDetail - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail.
原価・利益センタグループ情報取得共通クラス
機能は以下の通り
原価・利益センタグループ情報を取得します。
CommonCenterGrpGetDetail(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のコンストラクタ
センタグループ情報を作成
CommonCenterGrpGetDetail(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のコンストラクタ

Company - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company.
会社の基本属性のデータを取り扱います。
Company() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のコンストラクタ
会社に関連する情報を新規に生成します。
Company(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のコンストラクタ
会社に関連する情報を新規に生成します。
Company(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のコンストラクタ
会社に関連する情報を新規に生成します。
Company(Locale, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のコンストラクタ
会社に関連する情報を新規に生成します。
Company - class jp.co.intra_mart.foundation.sap.module.accounting.Company.
会社情報クラス
機能は以下の通り
会社の情報を保持します。
Company() - class jp.co.intra_mart.foundation.sap.module.accounting.Company のコンストラクタ
会社情報を作成します。
CompanyBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel.
会社の基本モデルです。
CompanyCategory - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory.
会社組織分類の基本属性のデータを取り扱います。
CompanyCategory() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のコンストラクタ
会社組織分類に関連する情報を新規に生成します。
CompanyCategory(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のコンストラクタ
会社組織分類に関連する情報を新規に生成します。
CompanyCategoryBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel.
会社組織分類の基本モデルです。
CompanyCategoryMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper.
会社組織分類に関連するマッパです。
CompanyCategoryTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable.
会社組織分類の期間化属性のデータを取り扱います。
CompanyCategoryTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable のコンストラクタ

CompanyCategoryTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryTerminableModel.
会社組織分類の期間化モデルです。
CompanyChangedControllerListener - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener.
会社・組織・役職が削除された場合にアクセスコントローラに紐付く会社・組織・役職を削除するリスナークラスです。
CompanyChangedControllerListener() - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のコンストラクタ

CompanyChangedListener - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener.
会社・組織に関する情報の変更時のリスナーです。
CompanyChangedMenuListener - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener.
会社・組織に関する情報の変更時のリスナーです。
CompanyChangedMenuListener() - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のコンストラクタ

CompanyController - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController.
会社コントローラクラス
機能は以下の通り
会社の情報を取得します。
CompanyController() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のコンストラクタ
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
CompanyController(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のコンストラクタ
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
CompanyDataInfo - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo.
会社コード依存データ情報クラス
機能は以下の通り
会社コード依存データの情報を保持します。
CompanyDataInfo() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のコンストラクタ
会社コード依存データ情報を作成します。
CompanyExportManager - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager.
会社情報のエクスポートを行います。
CompanyExportManager() - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager のコンストラクタ
コンストラクタ 会社情報エクスポートマネージャーのインスタンスを生成します。
CompanyExportManagerClient - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient.
会社情報のエクスポートを行います。
CompanyExportManagerClient() - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient のコンストラクタ

CompanyImportManager - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager.
会社情報のインポートを行います。
CompanyImportManager() - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager のコンストラクタ
コンストラクタ 会社インポートマネージャーのインスタンスを生成します。
CompanyImportManagerClient - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient.
会社情報のインポートを行います。
CompanyImportManagerClient() - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient のコンストラクタ

CompanyImporter - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter.
会社のインポートのインターフェースです。
CompanyList - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList.
会社一覧クラス
機能は以下の通り
会社の情報を一覧形式で取得します。
CompanyList(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList のコンストラクタ
executeBapiを呼び出し会社一覧を作成します。
CompanyManager - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager.
会社や組織に関連する情報を管理します。
CompanyManager() - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のコンストラクタ

CompanyMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper.
会社に関連するマッパです。
CompanyPost - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost.
役職の基本属性のデータを取り扱います。
CompanyPost() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のコンストラクタ
役職に関連する情報を新規に生成します。
CompanyPost(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のコンストラクタ
役職に関連する情報を新規に生成します。
CompanyPost(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のコンストラクタ
役職に関連する情報を新規に生成します。
CompanyPost(Locale, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のコンストラクタ
役職に関連する情報を新規に生成します。
CompanyPostBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel.
役職の基本モデルです。
CompanyPostExportManager - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager.
会社役職情報のエクスポートを行います。
CompanyPostExportManager() - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager のコンストラクタ
コンストラクタ 会社役職エクスポートマネージャーのインスタンスを生成します。
CompanyPostExportManagerClient - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient.
会社役職情報のエクスポートを行います。
CompanyPostExportManagerClient() - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient のコンストラクタ

CompanyPostImportManager - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager.
会社役職情報のインポートを行います。
CompanyPostImportManager() - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager のコンストラクタ
コンストラクタ 会社役職インポートマネージャーのインスタンスを生成します。
CompanyPostImportManagerClient - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient.
会社役職情報のインポートを行います。
CompanyPostImportManagerClient() - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient のコンストラクタ

CompanyPostImporter - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter.
役職のインポートのインターフェースです。
CompanyPostMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper.
役職に関連するマッパです。
CompanyPostTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable.
役職の期間化属性のデータを取り扱います。
CompanyPostTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable のコンストラクタ

CompanyPostTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational.
役職の期間国際化属性のデータを取り扱います。
CompanyPostTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational のコンストラクタ

CompanyPostTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel.
役職の期間国際化モデルです。
CompanyPostTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel.
役職の期間化モデルです。
CompanyTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable.
会社の期間化属性のデータを取り扱います。
CompanyTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のコンストラクタ

CompanyTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational.
会社の期間国際化属性のデータを取り扱います。
CompanyTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のコンストラクタ

CompanyVersion - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion.
会社構成バージョンの基本属性のデータを取り扱います。
CompanyVersion() - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のコンストラクタ

CompanyVersionBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel.
会社構成バージョンの基本モデルです。
CompanyVersionMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper.
会社構成バージョンに関連するマッパです。
ComponentNameCreator - class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator.

ComponentNameCreator() - class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator のコンストラクタ

ComponentUtil - class jp.co.intra_mart.framework.extension.seasar.util.ComponentUtil.
イントラマート、Seasar2連携のユーティリティクラスです。
ConInfo - interface jp.co.intra_mart.foundation.database.ConInfo.

ConcreteHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler.
任意の HTTPActionEvent を実行するためのハンドラです。
ConcreteHTTPActionEventHandler(String) - class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler のコンストラクタ
指定のイベント名で表されるイベントを実行するためのハンドラを作成します。
Cond - class jp.co.intra_mart.foundation.sap.module.purchase.Cond.
条件情報クラス
機能は以下の通り
条件情報を保持します。
Cond() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のコンストラクタ
条件を作成します。
Cond(int) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のコンストラクタ
条件を作成します。
ConditionDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn.
処理予定条件のテーブル情報クラス
機能は以下の通り
処理予定条件のテーブル情報を保持します。
ConditionDataIn() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のコンストラクタ
処理予定条件のテーブル情報を作成します。
ConditionDataIn(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のコンストラクタ
処理予定条件のテーブル情報を作成します。
ConditionsIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn.
条件情報クラス
機能は以下の通り
条件情報を保持します。
ConditionsIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のコンストラクタ
条件情報を作成します。
ConditionsIn(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のコンストラクタ
条件情報を作成します。
ConditionsInX - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX.
受注における条件更新の通信項目情報クラス
機能は以下の通り
受注における条件更新の通信項目情報を保持します。
ConditionsInX() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のコンストラクタ
受注における条件更新の通信項目情報を作成します。
ConditionsInX(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のコンストラクタ
受注における条件更新の通信項目情報を作成します。
Config - class jp.co.intra_mart.framework.system.util.Config.
標準的な初期化情報です。
Config() - class jp.co.intra_mart.framework.system.util.Config のコンストラクタ

Configuration - interface jp.co.intra_mart.foundation.datastore.common.config.Configuration.
設定内容を取得します。
ConfigurationFactory - class jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory.
Configurationを生成します。
ConfigurationFactory() - class jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory のコンストラクタ

ConfigurationUserInfo - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo.
情報を自由に設定可能なUserInfoです。
ConfigurationUserInfo() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のコンストラクタ

ConnectionManager - class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager.
ConnectionManagerクラス。
ConnectionManager() - class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager のコンストラクタ
コンストラクタ。
ConnectionManager(SapClient) - class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager のコンストラクタ
受け取ったサップクライアントに格納されている接続情報を 用いて、SAPへの接続を行います。
ConnectorModel - class jp.co.intra_mart.framework.base.data.ConnectorModel.
コネクタ情報を管理するクラスです。
ConnectorModel() - class jp.co.intra_mart.framework.base.data.ConnectorModel のコンストラクタ

ContractLimits - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits.
外注基本契約制限情報クラス
機能は以下の通り
外注基本契約情報を保持します。
ContractLimits() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のコンストラクタ
外注基本契約を作成します。
ContractLimits(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のコンストラクタ
外注基本契約を作成します。
ContractService - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService.
外注サービス情報クラス
機能は以下の通り
外注サービス情報を保持します。
ContractService() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のコンストラクタ
外注サービスを作成します。
ContractService(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のコンストラクタ
外注サービスを作成します。
ContractServiceAccount - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount.
外注サービス勘定設定情報クラス
機能は以下の通り
外注サービス勘定設定情報を保持します。
ContractServiceAccount() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のコンストラクタ
外注サービス勘定設定を作成します。
ContractServiceAccount(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のコンストラクタ
外注サービス勘定設定を作成します。
ContractServiceText - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText.
外注サービステキスト情報クラス
機能は以下の通り
外注サービステキスト情報を保持します。
ContractServiceText() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のコンストラクタ
外注サービステキストを作成します。
ContractServiceText(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のコンストラクタ
外注サービステキストを作成します。
ControllerConverter - interface jp.co.intra_mart.framework.base.service.controller.ControllerConverter.
リクエストをコントローラオブジェクトに変換します。
ControllerConverterConfig - interface jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfig.
ControllerConverterの初期化情報です。
ControllerConverterConfigImpl - class jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfigImpl.
ControllerConverterの初期化情報です。
ControllerConverterConfigImpl() - class jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfigImpl のコンストラクタ

ControllerConverterException - exception jp.co.intra_mart.framework.base.service.controller.ControllerConverterException.
ControllerConverterに関連する例外です。
ControllerConverterException() - class jp.co.intra_mart.framework.base.service.controller.ControllerConverterException のコンストラクタ
詳細メッセージを指定しないで ForwardSelectorException を構築します。
ControllerConverterException(String) - class jp.co.intra_mart.framework.base.service.controller.ControllerConverterException のコンストラクタ
指定された詳細メッセージを持つ ForwardSelectorException を構築します。
ControllerConverterException(String, Throwable) - class jp.co.intra_mart.framework.base.service.controller.ControllerConverterException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ForwardSelectorException を構築します。
ControllerConverterModel - class jp.co.intra_mart.framework.base.service.ControllerConverterModel.
コントローラコンバータ情報を管理するクラスです。
ControllerConverterModel() - class jp.co.intra_mart.framework.base.service.ControllerConverterModel のコンストラクタ

ControllerObject - interface jp.co.intra_mart.framework.base.service.controller.ControllerObject.
コントローラオブジェクトのインタフェースです。
ControllingArea - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea.
管理領域情報クラス
機能は以下の通り
管理領域の情報を保持します。
ControllingArea() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のコンストラクタ
管理領域情報を作成します。
ControllingAreaController - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController.
管理領域コントローラクラス
機能は以下の通り
管理領域の情報を取得します。
ControllingAreaController() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のコンストラクタ
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
ControllingAreaController(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のコンストラクタ
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
ControllingAreaList - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList.
管理領域一覧クラス
機能は以下の通り
管理領域の情報を一覧形式で取得します。
ControllingAreaList(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList のコンストラクタ
executeBapiを呼び出し管理領域一覧を作成します。
Convertor - class jp.co.intra_mart.foundation.sap.common.util.data.Convertor.
Converterクラス
機能は以下の通り
SAPリアルタイム連携APIにて使用するデータ変換機能を提供します。
CoreAttributes - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes.
コア属性です。
CoreAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のコンストラクタ
CoreAttributesを新規に生成します。
CostCenter - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter.
原価センタ情報クラス
機能は以下の通り
原価センタの情報を保持します。
CostCenter() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のコンストラクタ
原価センタ情報を取得します。
CostCenterController - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController.
原価センタコントローラクラス
機能は以下の通り
原価センタの情報を取得します。
CostCenterController(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のコンストラクタ
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String, Date) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のコンストラクタ
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のコンストラクタ
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String, Date, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のコンストラクタ
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterGroupGetDetail - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail.
原価センタグループ情報取得クラス
機能は以下の通り
原価センタグループ情報を取得します。
CostCenterGroupGetDetail(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail のコンストラクタ
原価センタグループ情報を作成
CostCenterGroupGetDetail(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail のコンストラクタ

CostCenterGroupGetDetailController - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController.
原価センタグループコントローラクラス
機能は以下の通り
原価センタグループを取得します。
CostCenterGroupGetDetailController(String, String) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のコンストラクタ

CostCenterGroupGetDetailController(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のコンストラクタ

CostCenterGroupGetDetailController() - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のコンストラクタ
CostCenterGroupGetDetailControllerのコンストラクタを生成します。
CostCenterGroupGetDetailController(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のコンストラクタ
CostCenterGroupGetDetailControllerのコンストラクタを生成します。
CostCenterList - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList.
原価センタ一覧クラス
機能は以下の通り
原価センタの情報を一覧形式で取得します。
CostCenterList(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のコンストラクタ
executeBapiを呼び出し原価センタ一覧を作成します。
Counter - class jp.co.intra_mart.common.aid.jdk.util.Counter.
このクラスは、カウンター機能を提供します。
Counter() - class jp.co.intra_mart.common.aid.jdk.util.Counter のコンストラクタ
カウンターオブジェクトを作成します。
Counter(long) - class jp.co.intra_mart.common.aid.jdk.util.Counter のコンストラクタ
指定の初期値でカウンターオブジェクトを作成します。
Counter - class jp.co.intra_mart.foundation.utility.Counter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.Counter クラスを使用してください。
Counter() - class jp.co.intra_mart.foundation.utility.Counter のコンストラクタ
推奨されていません。 カウンターオブジェクトを作成します。
Counter(long) - class jp.co.intra_mart.foundation.utility.Counter のコンストラクタ
推奨されていません。 指定の初期値でカウンターオブジェクトを作成します。
CreatorDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn.
取り込まれる日付の順序情報クラス
機能は以下の通り
取り込まれる日付の順序情報を保持します。
CreatorDataIn() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn のコンストラクタ
取り込まれる日付の順序情報を作成します。
CreditorGetDetail - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail.
仕入先詳細情報取得クラス
機能は以下の通り
仕入先詳細情報を取得します。
CreditorGetDetail(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のコンストラクタ
仕入先詳細情報を作成
CreditorGetDetail(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のコンストラクタ

CreditorGetDetailController - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController.
仕入先詳細コントローラクラス
機能は以下の通り
仕入先詳細を取得します。
CreditorGetDetailController(String, String) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のコンストラクタ

CreditorGetDetailController(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のコンストラクタ

CreditorGetDetailController() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のコンストラクタ
DebtorGetDetailControllerのコンストラクタを生成します。
CreditorGetDetailController(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のコンストラクタ
DebtorGetDetailControllerのコンストラクタを生成します。
Cryption - interface jp.co.intra_mart.foundation.security.cryption.Cryption.
文字列の暗号化・復号化インタフェース。
CsvAccountBackup - class jp.co.intra_mart.foundation.security.account.CsvAccountBackup.
CSVアカウントバックアップクラスです。
CsvAccountBackup() - class jp.co.intra_mart.foundation.security.account.CsvAccountBackup のコンストラクタ

CurlFieldBean - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean.
CurlフィールドBeanクラス
機能は以下の通り
CurlのRecordFieldクラスの属性情報を格納するBean
CurlFieldBean() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のコンストラクタ

CurlRecordBeanIF - interface jp.co.intra_mart.foundation.im_curl.CurlRecordBeanIF.
CurlレコードBeanインタフェース
機能は以下の通り
CurlのRecordクラスの属性を格納するBean用のインタフェース
CurlXMLComposer - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer.
CurlXML生成クラス
機能は以下の通り
Curlで入力可能なXML(elaborate-recordsetで入力可能)を生成します。
CurlXMLComposer() - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer のコンストラクタ

CurlXMLParser - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser.
CurlXMLパーサクラス
機能は以下の通り
Curlで出力されたXML(recordset-to-xmlでの出力)をパースします。
CurlXMLParser(String, String) - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のコンストラクタ
このクラス自身をハンドラとしたSAXパーサを作成し、指定されたpathのXMLを パースします。
CurlXMLParser(InputStream, String) - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のコンストラクタ
このクラス自身をハンドラとしたSAXパーサを作成し、指定されたInputStreamから取得したXMLを パースします。
CurrencyAmount - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount.
明細通貨項目クラス
機能は以下の通り
明細通貨項目の情報を保持します。
CurrencyAmount(int) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のコンストラクタ
指定されたレコード番号でCurrencyAmountを作成します。
CurrencyManager - class jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager.
通貨情報を取り扱います。
CurrencyManager() - class jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager のコンストラクタ

canReport() - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter のメソッド
このストリームが書き込み可能かどうかをチェックします。
canReport() - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter のメソッド
推奨されていません。 このストリームが書き込み可能かどうかをチェックします。
capacity() - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
このマップに対してマップできるキーの最大個数を返します。
capacity() - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 このマップに対してマップできるキーの最大個数を返します。
categoryDetailRemoved(String, CompanyCategory) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
分類区分情報がデータストアから削除された後に呼び出されます。
categoryDetailRemoved(String, PublicGroupCategory) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
分類区分情報がデータストアから削除された後に呼び出されます。
categoryDetailRemoved(String, CompanyCategory) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
分類区分情報がデータストアから削除された後に呼び出されます。
categoryDetailRemoved(String, PublicGroupCategory) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
分類区分情報がデータストアから削除された後に呼び出されます。
categoryDetailRemoved(String, CompanyCategory) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
分類区分情報がデータストアから削除された後に呼び出されます。
categoryDetailRemoved(String, PublicGroupCategory) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
分類区分情報がデータストアから削除された後に呼び出されます。
categoryDetailSet(String, CompanyCategory) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
分類区分情報がデータストアに登録された後に呼び出されます。
categoryDetailSet(String, PublicGroupCategory) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
分類区分情報がデータストアに登録された後に呼び出されます。
categoryDetailSet(String, CompanyCategory) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
分類区分情報がデータストアに登録された後に呼び出されます。
categoryDetailSet(String, PublicGroupCategory) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
分類区分情報がデータストアに登録された後に呼び出されます。
categoryDetailSet(String, CompanyCategory) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
分類区分情報がデータストアに登録された後に呼び出されます。
categoryDetailSet(String, PublicGroupCategory) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
分類区分情報がデータストアに登録された後に呼び出されます。
certification(LoginInfo, Account, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.LDAPUserCertification のメソッド
ユーザを認証する。
certification(LoginInfo, SuperUser, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification のメソッド
管理者を認証します。
certification(LoginInfo, Account, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardUserCertification のメソッド
ユーザを認証します。
certification(LoginInfo, SuperUser, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.SuperCertification のメソッド
管理者を認証する。
certification(LoginInfo, SuperUser, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification のメソッド
管理者を認証します。
certification(LoginInfo, Account, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.UserCertification のメソッド
ユーザを認証する。
certification(LoginInfo, Account, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPUserCertification のメソッド
LDAPに対してユーザを認証します。
certify(String[], String[]) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール内包を認証します。
changeParam(String) - class jp.co.intra_mart.foundation.sap.common.util.data.ExtendedParamConverter の static メソッド
入力された項目名を変換します。
changeParam(String) - class jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter の static メソッド
入力された項目名を変換します。
changeToUpperParam(String, String, String) - class jp.co.intra_mart.foundation.sap.common.util.data.ExtendedParamConverter の static メソッド
入力された項目名をプロパティファイルの項目名に変換します。
changeToUpperParam(String) - class jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter の static メソッド
入力された項目名を変換します。
check() - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
入力内容をチェックします。
check() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
入力内容をチェックします。
checkByBaseProperty(Relationship[], BaseModel, BaseModel) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
基準項目によるリレーションシップの整合性制約をチェックします。
checkByBaseProperty(Relationship[], BaseModel, BaseModel) - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
基準項目によるリレーションシップの整合性制約をチェックします。
checkDigitOfNumber(Number, int, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
数値の整数部、小数部の桁数チェック。
checkDigitOfNumber(Number, Integer, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
数値の整数部、小数部の桁数チェック（引数がクラス版）。
checkDigitOfNumberString(String, int, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
数値（文字型）の整数部、小数部の桁数チェック
※数値かどうかのチェックも行う。
checkDigitOfNumberString(String, Integer, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
数値（文字型）の整数部、小数部の桁数チェック（引数がクラス版）

checkFlg(String) - class jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter の static メソッド
項目に値が入っているかチェックします。
checkLocale(String, String[]) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter のメソッド
ロケールチェック（共通）

checkLocale(String, String[]) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter のメソッド
ロケールチェック（共通）

checkMobile(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuAnalyzer のメソッド
モバイル端末の種別をチェックします。
checkMobile(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuHdmlAnalyzer のメソッド
推奨されていません。 モバイル端末の種別をチェックします。
checkMobile(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoAnalyzer のメソッド
モバイル端末の種別をチェックします。
checkMobile(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoMoveAnalyzer のメソッド
推奨されていません。 モバイル端末の種別をチェックします。
checkMobile(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginJphoneAnalyzer のメソッド
推奨されていません。 モバイル端末の種別をチェックします。
checkMobile(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginSoftBankAnalyzer のメソッド
モバイル端末の種別をチェックします。
checkMobile(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginVodafoneAnalyzer のメソッド
モバイル端末の種別をチェックします。
checkMobile(String, HttpServletRequest) - interface jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider のメソッド
モバイル端末の種別をチェックします。
checkNull(String) - class jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter の static メソッド
項目がnullかどうかチェックします。
checkPasswordHistory(String, String, String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
パスワードの入力チェック。
checkPasswordHistory(String, String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
パスワードの入力チェック。
checkPasswordHistory(String, String, String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
入力パスワードのチェック。
checkStrLength(String, int) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter のメソッド
文字列チェック（共通）

checkTitleInfo(NavigatorItem, String[], String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter のメソッド
タイトル情報のロケールマッチング（共通）

childDirectories() - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のメソッド
この抽象パス名が示すディレクトリにあるサブディレクトリの抽象パスを 繰り返し処理する反復子を作成します。
childDirectories() - class jp.co.intra_mart.foundation.utility.file.Directory のメソッド
推奨されていません。 この抽象パス名が示すディレクトリにあるサブディレクトリの抽象パスを 繰り返し処理する反復子を作成します。
childDirectory(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
childDirectory(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
childFile(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
childFile(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
childFiles() - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のメソッド
この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
childFiles() - class jp.co.intra_mart.foundation.utility.file.Directory のメソッド
推奨されていません。 この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
childPath(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
childPath(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
clean() - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor のメソッド
プール中のコネクションをすべて破棄します。
clean() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
プール中のコネクションをすべて破棄します。
clean() - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
システムのガベージコレクタを実行します。
clean() - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor のメソッド
推奨されていません。 プール中のコネクションをすべて破棄します。
clean() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 プール中のコネクションをすべて破棄します。
cleanUp() - interface jp.co.intra_mart.foundation.service.provider.GCConditioner のメソッド
gc を実行するかどうかを判断します。
clear() - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リストからすべての要素を削除します。
clear() - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
マップからマッピングをすべて削除します。
clear() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
すべてのデータを削除します。
clear() - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
すべての値を削除します。
clear() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
すべてのデータを削除します。
clear() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
すべてのデータを削除します。
clear() - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
すべての値を削除します。
clear() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
すべてのデータを削除します。
clear() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
すべてのデータを削除します。
clear() - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
すべての値を削除します。
clear() - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リストからすべての要素を削除します。
clear() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
セットしたパラメータ、ストラクチャ、テーブル、BAPIの実行結果をクリアします。
clear() - class jp.co.intra_mart.foundation.sap.common.util.PropertyDescriptorBox の static メソッド
キャッシュしたPropertyDescriptorをクリアします。
clear() - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
データを削除します。
clear() - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
データを削除します。
clear() - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
すべてのデータを削除します。
clear() - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
このオブジェクトのマップからマッピングをすべて削除します。
clear() - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 マップからマッピングをすべて削除します。
clear() - class jp.co.intra_mart.framework.base.session.HttpSessionObject のメソッド
推奨されていません。 セッション内に存在するすべてのオブジェクトを削除します。
clear() - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のメソッド
推奨されていません。 セッション内に存在するすべてのオブジェクトを削除します。
clear() - interface jp.co.intra_mart.framework.base.session.SessionObject のメソッド
セッション内に存在するすべてのオブジェクトを削除します。
clearError() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
このインスタンスのメソッド実行中に発生した例外をすべて破棄します。
clearError() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 このインスタンスのメソッド実行中に発生した例外をすべて破棄します。
clearInstance() - class jp.co.intra_mart.foundation.database.DatabaseExport の static メソッド
推奨されていません。 DatabaseExportインスタンスを開放します。
clearInstance() - class jp.co.intra_mart.foundation.security.AccessSecurityManager の static メソッド
アクセスセキュリティマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.SystemManager の static メソッド
システムマネージャのインスタンスを初期化を行います。
clearInstance() - class jp.co.intra_mart.foundation.security.access.AccessControllerManager の static メソッド
アクセスコントローラマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.account.AccountManager の static メソッド
アカウントマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.batch.BatchManager の static メソッド
バッチマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager の static メソッド
カレンダーマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.group.LoginGroupManager の static メソッド
ログイングループマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager の static メソッド
ログイングループマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.menu.MenuManager の static メソッド
メニューマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager の static メソッド

clearInstance() - class jp.co.intra_mart.foundation.security.shortcut.ShortCutManager の static メソッド

clearPasswordHistories(String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
パスワード履歴の消去。
clearPasswordHistories() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
パスワード履歴の消去。
clearPasswordHistories(String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
パスワード履歴の消去。
clearPasswordHistory(String, String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
指定ユーザのパスワード履歴の消去。
clearPasswordHistory(String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
指定ユーザのパスワード履歴の消去。
clearPasswordHistory(String, String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
指定ユーザのパスワード履歴の消去。
clearUrl() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ダイレクトＵＲＬを削除する。
clearWarnings() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection オブジェクトに関して通知されたすべての警告をクリアします。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream のメソッド
ストリームを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
入出力ストリームおよびソケットを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
入出力ストリームおよびソケットを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream のメソッド
ストリームを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream のメソッド
ストリームを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
このストリームを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のメソッド
ストリームを閉じてフラッシュします。
close() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
入出力ストリームおよびソケットを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter のメソッド
このオブジェクトを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のメソッド
このオブジェクトを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter のメソッド
このオブジェクトを閉じます。
close() - interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter のメソッド
このオブジェクトを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
このオブジェクトを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter のメソッド
このオブジェクトを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
ストリームを閉じてフラッシュします。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter のメソッド
ストリームを閉じます。
close() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
入力を閉じます。
close(Connection, PreparedStatement) - class jp.co.intra_mart.foundation.database.DatabaseExport の static メソッド
推奨されていません。
close() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 releaseメソッドと同等です。
close() - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
マッパーをクローズします。
close() - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
マッパーをクローズします。
close() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
ネットワークを切断します。
close() - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream のメソッド
推奨されていません。 ストリームを閉じます。
close() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 入出力ストリームおよびソケットを閉じます。
close() - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 入出力ストリームおよびソケットを閉じます。
close() - class jp.co.intra_mart.foundation.utility.io.HexInputStream のメソッド
推奨されていません。 ストリームを閉じます。
close() - class jp.co.intra_mart.foundation.utility.io.HexOutputStream のメソッド
推奨されていません。 ストリームを閉じます。
close() - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のメソッド
推奨されていません。 ストリームを閉じてフラッシュします。
close() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 入出力ストリームおよびソケットを閉じます。
close() - class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter のメソッド
推奨されていません。 このオブジェクトを閉じます。
close() - class jp.co.intra_mart.foundation.utility.report.FileReporter のメソッド
推奨されていません。 このオブジェクトを閉じます。
close() - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter のメソッド
推奨されていません。 このオブジェクトを閉じます。
close() - interface jp.co.intra_mart.foundation.utility.report.MessageReporter のメソッド
推奨されていません。 このオブジェクトを閉じます。
close() - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 このオブジェクトを閉じます。
close() - class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter のメソッド
推奨されていません。 このオブジェクトを閉じます。
close() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 ストリームを閉じてフラッシュします。
close() - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter のメソッド
推奨されていません。 ストリームを閉じます。
commit() - interface jp.co.intra_mart.foundation.database.DatabaseAccessor のメソッド
データベースのトランザクションをコミットします。
commit() - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
データベースのトランザクションをコミットします。
commit() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースアクセスの確定処理を行います。
commit() - class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager のメソッド
ＢＡＰＩ実行結果のCOMMIT処理を行います｡

実行後にコネクションが開放されます。
commit() - class jp.co.intra_mart.framework.base.data.DBConnector のメソッド
コミットします。
commit() - class jp.co.intra_mart.framework.base.data.DataAccessController のメソッド
すべてのデータコネクタをコミットします。
commit() - class jp.co.intra_mart.framework.base.data.DataConnector のメソッド
コミットします。
commit() - class jp.co.intra_mart.framework.base.data.DataSourceConnector のメソッド
コミットします。
commit() - class jp.co.intra_mart.framework.base.data.IntramartDBConnector のメソッド
推奨されていません。 コミットします。
commit() - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector のメソッド
コミットします。
commit() - class jp.co.intra_mart.framework.base.data.JDBCConnector のメソッド
推奨されていません。 コミットします。
commit() - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector のメソッド
コミットします。
commit() - class jp.co.intra_mart.framework.base.data.SystemDBConnector のメソッド
コミットします。
commit() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager のメソッド
ラップしたTransactionManagerのcommitを呼び出します。
commit() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction のメソッド
ラップしたUserTransactionのcommitを呼び出します。
companyAdded(String, Company) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
会社情報がデータストアに登録された後に呼び出されます。
companyAdded(String, Company) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
会社情報がデータストアに登録された後に呼び出されます。
companyAdded(String, Company) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
会社情報がデータストアに登録された後に呼び出されます。
companyDeleted(String, Company) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
会社情報がデータストアから削除された後に呼び出されます。
companyDeleted(String, Company) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
会社情報がデータストアから削除された後に呼び出されます。
companyDeleted(String, Company) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
会社情報がデータストアから削除された後に呼び出されます。
compare(Object, Object) - class jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator のメソッド
順序付けのために ２ つの引数を比較するメソッドです。
compare(Object, Object) - class jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator のメソッド
順序付けのために 2 つの引数を比較するメソッドです。
compare(Object, Object) - class jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator のメソッド
フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。
compare(Object, Object) - class jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator のメソッド
順序付けのために ２ つの引数を比較するメソッドです。
compare(Object, Object) - class jp.co.intra_mart.foundation.page.NodeNameComparator のメソッド
順序付けのために 2 つの引数を比較するメソッドです。
compare(Object, Object) - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
順序付けのために 2 つの引数を比較します。
compare(Object, Object) - class jp.co.intra_mart.foundation.utility.AbstractDualComparator のメソッド
推奨されていません。 順序付けのために ２ つの引数を比較するメソッドです。
compare(Object, Object) - class jp.co.intra_mart.foundation.utility.FilterComparator のメソッド
推奨されていません。 順序付けのために 2 つの引数を比較するメソッドです。
compare(Object, Object) - class jp.co.intra_mart.foundation.utility.ReverseComparator のメソッド
推奨されていません。 フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。
compare(Object, Object) - class jp.co.intra_mart.foundation.utility.SequenceComparator のメソッド
推奨されていません。 順序付けのために ２ つの引数を比較するメソッドです。
compareTo(Object) - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
この期間と指定された期間を比較します。
compileReader(Reader) - class jp.co.intra_mart.foundation.scenario.FunctionContainer のメソッド
スクリプトのソースをコンパイルします。
compileString(String) - class jp.co.intra_mart.foundation.scenario.FunctionContainer のメソッド
スクリプトのソースをコンパイルします。
connection() - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor のメソッド
コネクションの取得。
connection() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
コネクションの取得。
connection - class jp.co.intra_mart.foundation.sap.common.auth.SapClient の変数
JCOコネクション
connection() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.file.AbstractComponent のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.manager.ServerConnector のメソッド
サーバに接続するためのコネクションを取得します。
connection() - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor のメソッド
推奨されていません。 コネクションの取得。
connection() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 コネクションの取得。
connectionManager - class jp.co.intra_mart.foundation.sap.module.UpdateController の変数
コネクション(トランザクション)オブジェクト
connections - class jp.co.intra_mart.framework.base.data.IntramartDBConnector の変数
推奨されていません。 DbsConnectionの一覧
connections - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector の変数
リソース一覧
connections - class jp.co.intra_mart.framework.base.data.SystemDBConnector の変数
リソース一覧
contact(ConInfo) - class jp.co.intra_mart.foundation.database.DbManager の static メソッド
推奨されていません。 代替えメソッドはありません。
contact() - class jp.co.intra_mart.foundation.database.DbManager のメソッド
推奨されていません。 代替えメソッドはありません。
contains(Object) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リストに指定の要素がある場合に true を返します。
contains(String) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.contains(String)に置き換えられました。
contains(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.contains(String)に置き換えられました。
contains(Object) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リストに指定の要素がある場合に true を返します。
contains(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントの存在チェックを行います。
contains(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロールの存在チェックを行います。
containsAll(Collection) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
このコレクション内に、指定されたコレクションのすべての要素がある場合に true を返します。
containsAll(Collection) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 このコレクション内に、指定されたコレクションのすべての要素がある場合に true を返します。
containsCategory(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
カテゴリーの存在チェックをします。
containsDate(Date) - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
指定された日時が期間内に入っているかどうかを指定します。
containsHeader(String) - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity のメソッド
指定された文字列がヘッダの名称かどうかを判定します。
containsHeader(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。
containsHeader(HttpServletRequest, ExtendedHttpServletResponse, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。
containsHeader(HttpServletRequest, ExtendedHttpServletResponse, String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。
containsHeader(HttpServletRequest, ExtendedHttpServletResponse, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。
containsHeader(String) - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
推奨されていません。 指定された文字列がヘッダの名称かどうかを判定します。
containsKey(Object) - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
指定されたキーへのマッピングをこのマップが格納する場合に true を返します。
containsKey(Object) - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 指定されたキーへのマッピングをこのマップが格納する場合に true を返します。
convJCOdata(int, int, Object) - class jp.co.intra_mart.foundation.sap.common.util.data.Convertor の static メソッド
BAPIパラメータに設定する値でパラメータ属性が"JCO.TYPE_NUM"の場合は 0パディングした文字列を返します。
convert(String) - class jp.co.intra_mart.common.aid.jsdk.utility.BrowseString の static メソッド
HTML表示可能な文字列に変換します。
convert(RequestInfo) - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter のメソッド
リクエスト情報をもとに入力オブジェクトを生成します。
convert(RequestInfo) - class jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter のメソッド
リクエスト情報をもとに入力オブジェクトを生成します。
convert(RequestInfo) - interface jp.co.intra_mart.framework.base.service.controller.ControllerConverter のメソッド
リクエスト情報をもとに入力オブジェクトを生成します。
convert(RequestInfo) - class jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter のメソッド
リクエスト情報をもとに入力オブジェクトを生成します。
convertOnlyDate(long) - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
日付のみのjava.util.Dateに変換します。
convertOnlyDate(Date) - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
日付のみのjava.util.Dateに変換します。
convertOnlyDateTime(long) - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
日付と時刻のみのjava.util.Dateに変換します。
convertOnlyDateTime(Date) - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
日付と時刻のみのjava.util.Dateに変換します。
copyEventFlow(EventNavigatorManager, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
copyEventFlow(String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
copyEventFlow(EventNavigatorManager, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
copyVersion(String, String, String, Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の会社構成バージョンの内容をコピーします。
copyVersion(String, String, String, Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループセット構成バージョンの内容をコピーします。
count() - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.count()に置き換えられました。
count() - class jp.co.intra_mart.foundation.acssecurity.Logingp の static メソッド
推奨されていません。 LoginGroupManager.countLoginGroups()に置き換えられました。
count() - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.count()に置き換えられました。
count() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントの登録数を取得します。
count(String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
アクティブなすべてのセッション数を取得します。
count(String, String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたユーザのアクティブなすべてのセッション数を取得します。
count(String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。
count(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
アクティブなすべてのセッション数を取得します。
count(String, String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたユーザのアクティブなすべてのセッション数を取得します。
count(String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。
count(String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
アクティブなすべてのセッション数を取得します。
count(String, String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたユーザのアクティブなすべてのセッション数を取得します。
count(String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。
count() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール数を取得します。
countByCategory(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
カテゴリーに属するロール数を取得します。
countLoginGroups() - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループ数を取得します。
counter - class jp.co.intra_mart.foundation.page.EventScript の static 変数
このクラスからインスタンスが生成された回数。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
プライマリキーに該当する分類区分を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
プライマリキーに該当する分類区分詳細を生成します。
create(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
プライマリキーに該当する組織所属を生成します。
create(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
プライマリキーに該当する会社組織分類を生成します。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
プライマリキーに該当する会社を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
プライマリキーに該当する組織を生成します。
create(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
プライマリキーに該当する組織内包を生成します。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
プライマリキーに該当する主所属を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
プライマリキーに該当する役職を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
プライマリキーに該当する会社構成バージョンを生成します。
create(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper のメソッド
プライマリキーに該当する取扱を生成します。
create(String, String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper のメソッド
プライマリキーに該当する組織毎取扱パーミッションを生成します。
create(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper のメソッド
プライマリキーに該当する取扱詳細を生成します。
create(String, String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper のメソッド
プライマリキーに該当するパブリックグループ毎取扱パーミッションを生成します。
create(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper のメソッド
プライマリキーに該当するロール毎取扱パーミッションを生成します。
create(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper のメソッド
プライマリキーに該当する商品属性を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper のメソッド
プライマリキーに該当する商品カタログを生成します。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper のメソッド
プライマリキーに該当する商品を生成します。
create(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper のメソッド
プライマリキーに該当する商品分類を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper のメソッド
プライマリキーに該当する商品カテゴリを生成します。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper のメソッド
プライマリキーに該当する商品カテゴリ種別を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper のメソッド
プライマリキーに該当する商品属性テンプレート明細を生成します。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper のメソッド
プライマリキーに該当する商品属性テンプレートを生成します。
create(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライマリキーに該当するプライベートグループ所属を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライマリキーに該当するプライベートグループを生成します。
create(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
プライマリキーに該当するパブリックグループ所属を生成します。
create(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
プライマリキーに該当するパブリックグループ分類を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
プライマリキーに該当するパブリックグループを生成します。
create(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
プライマリキーに該当するパブリックグループ内包を生成します。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
プライマリキーに該当するパブリックグループセットを生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
プライマリキーに該当するパブリックグループ構成バージョンを生成します。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper のメソッド
プライマリキーに該当する単位を生成します。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
プライマリキーに該当するユーザを生成します。
create() - class jp.co.intra_mart.framework.base.data.container.factory.DataContainerFactory のメソッド
DataContainerを生成します。
create() - class jp.co.intra_mart.framework.base.data.container.factory.DefaultDataProvider のメソッド
DataContainerを生成します。
create(Event) - interface jp.co.intra_mart.framework.base.event.EventListenerFactory のメソッド
イベントリスナを生成します。
create() - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome のメソッド
リモートインタフェースGenericEJBEventListenerAgentを取得します。
create() - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocalHome のメソッド
ローカルインタフェース GenericEJBEventListenerAgentLocalを取得します。
create(Event) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory のメソッド
イベントリスナを生成します。
create(Event) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory のメソッド
イベントリスナを生成します。
create(Event) - class jp.co.intra_mart.framework.base.event.GenericEventListenerFactory のメソッド
イベントリスナを生成します。
create() - interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome のメソッド
StandardEJBEventListenerAgentと接続します。
create(Event) - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory のメソッド
イベントリスナを生成します。
create(Event) - class jp.co.intra_mart.framework.base.event.StandardEventListenerFactory のメソッド
イベントリスナを生成します。
create() - class jp.co.intra_mart.framework.base.event.container.factory.DefaultEventProvider のメソッド
EventContainerを生成します。
create() - class jp.co.intra_mart.framework.base.event.container.factory.EventContainerFactory のメソッド
EventContainerを生成します。
create() - class jp.co.intra_mart.framework.base.service.container.factory.DefaultServiceProvider のメソッド
ServiceContainerを生成します。
create() - class jp.co.intra_mart.framework.base.service.container.factory.ServiceContainerFactory のメソッド
ServiceContainerを生成します。
create(Event) - class jp.co.intra_mart.framework.extension.seasar.event.S2EventListenerFactory のメソッド
イベントリスナを生成します。
create() - interface jp.co.intra_mart.framework.system.container.factory.IMContainerFactory のメソッド

create() - interface jp.co.intra_mart.framework.system.container.factory.Provider のメソッド
IMContainerを生成します
create(String, String, String) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper のメソッド
プライマリキーに該当するアクセスコントローラの利用権限を保有する組織を生成します。
create(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper のメソッド
プライマリキーに該当するアクセスコントローラ情報を生成します。
create(String, String, String) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper のメソッド
プライマリキーに該当するアクセスコントローラの利用権限を保有する役職を生成します。
create(String, String, String) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper のメソッド
プライマリキーに該当するアクセスコントローラの利用権限を保有するパブリックグループを生成します。
create(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper のメソッド
プライマリキーに該当するアクセスコントローラの利用権限を保有するロールを生成します。
create(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper のメソッド
プライマリキーに該当するアカウントが保有する属性を生成します。
create(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountMapper のメソッド
プライマリキーに該当するアカウントを生成します。
create(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper のメソッド
プライマリキーに該当するアカウントが保有するロールを生成します。
create(String) - interface jp.co.intra_mart.system.security.datastore.inf.BatchMapper のメソッド
プライマリキーに該当するバッチ情報を生成します。
create(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper のメソッド
プライマリキーに該当するカレンダーが保有するデータを生成します。
create(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper のメソッド
プライマリキーに該当するアカウントが保有するメニューを生成します。
create(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper のメソッド
プライマリキーに該当するメニューの保有する引数を生成します。
create(String, String, String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper のメソッド
プライマリキーに該当するメニューの利用権限を保有する組織を生成します。
create(String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuMapper のメソッド
プライマリキーに該当するメニュー情報を生成します。
create(String, String, String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper のメソッド
プライマリキーに該当するメニューの利用権限を保有する役職を生成します。
create(String, String, String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper のメソッド
プライマリキーに該当するメニューの利用権限を保有するパブリックグループを生成します。
create(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper のメソッド
プライマリキーに該当するメニューの利用権限を保有するロールを生成します。
create(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper のメソッド
プライマリキーに該当するロール内包を生成します。
create(String) - interface jp.co.intra_mart.system.security.datastore.inf.RoleMapper のメソッド
プライマリキーに該当するロールを生成します。
create(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper のメソッド
プライマリキーに該当するロールサマリを生成します。
createBapiController(String) - class jp.co.intra_mart.foundation.sap.module.AbstractController のメソッド
引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。
createBapiController(String) - class jp.co.intra_mart.foundation.sap.module.UpdateController のメソッド
引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。
createBaseAccessor(Map) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
このマッパーに該当する基本アクセサを新規に生成します。
createBaseModel(Map) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
このマッパーに該当する基本モデルを新規に生成します。
createBaseModel(Map) - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
このマッパーに該当する基本モデルを新規に生成します。
createClient() - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
JCOコネクションの生成を行う為の抽象メソッドです。
createClient() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing のメソッド
JCOコネクションの生成を行います。
createClient() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
JCOコネクションの生成を行います。
createClient() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing のメソッド
JCOコネクションの生成を行います。
createConfiguration() - class jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory のメソッド
Configurationを生成します。
createController(HttpServletRequest, ExtendedHttpServletResponse, HttpServletResponseEventListener) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerBuilder のメソッド
コントローラを返します。
createController(HttpServletRequest, ExtendedHttpServletResponse, HttpServletResponseEventListener) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.StandardHttpServletResponseEventControllerBuilder のメソッド
コントローラを返します。
createControllerName(String, String) - class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator の static メソッド
サービスコントローラのコンポーネント名を返します。
createDaoName(String, String) - class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator の static メソッド
daoのコンポーネント名を返します。
createEvent(String, String, UserInfo) - class jp.co.intra_mart.framework.base.event.EventManager のメソッド
パラメータで指定された内容に該当するイベントを生成します。
createEvent(String, String, String, String) - class jp.co.intra_mart.framework.base.event.EventManager のメソッド
推奨されていません。 このメソッドではなくEventManager.createEvent(String, String, UserInfo)を使用してください。
createEvent(String, String) - interface jp.co.intra_mart.framework.base.event.container.EventContainer のメソッド
パラメータで指定された内容に該当するイベントを生成します。
createEvent(String, String) - class jp.co.intra_mart.framework.base.event.container.EventContainerImpl のメソッド
パラメータで指定された内容に該当するイベントを生成します。
createEvent(String, String) - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
アプリケーションIDとキーに対応するイベントを取得します。
createEvent(String, String) - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
アプリケーションIDとキーに対応するイベントを取得します。
createEvent(String, String, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils の static メソッド
アプリケーションIDとキーに対応するイベントを取得します。
createEvent(String, String) - class jp.co.intra_mart.framework.extension.seasar.event.S2EventContainer のメソッド

createEvent(String, String, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction のメソッド
アプリケーションIDとキーに対応するイベントを取得します。
createEventListenerName(String, String) - class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator の static メソッド
イベントリスナのコンポーネント名を返します。
createEventName(String, String) - class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator の static メソッド
イベントオブジェクトのコンポーネント名を返します。
createExtendedBaseAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap のメソッド
拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を生成します。
createExtendedBaseModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap のメソッド
拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
createExtendedBaseModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap のメソッド
拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
createExtendedInternationalAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap のメソッド
拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を生成します。
createExtendedInternationalModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap のメソッド
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
createExtendedInternationalModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap のメソッド
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
createExtendedTerminableAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap のメソッド
拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を生成します。
createExtendedTerminableInternationalAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap のメソッド
拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を生成します。
createExtendedTerminableInternationalModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap のメソッド
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
createExtendedTerminableInternationalModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap のメソッド
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
createExtendedTerminableModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap のメソッド
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
createExtendedTerminableModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap のメソッド
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
createField(Attributes) - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のメソッド
qNameがFieldの場合のパーサの動作を定義します。
createFilePath(String) - class jp.co.intra_mart.jssp.net.GenericURLBuilder のメソッド
指定のページパスからリンクの為のページパスを作成して返します。
createImage(Graphics) - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルを描画します。
createImage(Graphics) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
棒グラフを描画します。
createImage(Graphics) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
円グラフを描画します。
createImage(Graphics) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
折れ線グラフを描画します。
createImage(Graphics) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ポートフォリオを描画します。
createImage(Graphics) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
レーダーチャートを描画します。
createInternationalAccessor(Locale) - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap のメソッド
国際化アクセサを生成します。
createInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
国際化モデルを生成します。
createInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap のメソッド
国際化モデルを生成します。
createItem(String, String, boolean, String, Map) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItemFactory のメソッド
ヘッダ情報を含むFileItemを生成します。
createItem(String, String, boolean, String, Map) - interface jp.co.intra_mart.common.aid.javaee.http.fileupload.IMFileItemFactory のメソッド
ヘッダ情報を含むFileItemを生成します。
createItem(Map, boolean) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload のメソッド

createLoginRequestInfo(String) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ログイン情報を作成します。
createMapper(String, String, String, String) - class jp.co.intra_mart.foundation.datastore.common.model.MapperFactory のメソッド
マッパーを生成します。
createPassword(int) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
パスワードをランダムに生成。
createPassword(int) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド

createPassword(int) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
パスワードをランダムに生成。
createPool(SapClientPool) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
JCOコネクションプールを生成します。
createPool(SapClientPool) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolManager の static メソッド
コネクションプール方式を用いて、JCOコネクションの取得を行います。
createPool(SapClientPool) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing のメソッド
コネクションプールを生成します。
createPool(SapClientPool) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing のメソッド
コネクションプールを生成します。
createRecord(Attributes) - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のメソッド
qNameがRecordの場合のパーサの動作を定義します。
createRole(String, Role) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
ロール情報を新規追加します。
createRole(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
ロール情報を新規に追加する。
createSession(Properties) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
SMTPセッションを構築します。
createSessionObject(ServletRequest) - class jp.co.intra_mart.framework.base.session.HttpSessionFactory のメソッド
推奨されていません。 セッションオブジェクトを新規に生成します。
createSessionObject(ServletRequest) - class jp.co.intra_mart.framework.base.session.IntramartSessionFactory のメソッド
推奨されていません。 セッションオブジェクトを新規に生成します。
createSessionObject(ServletRequest) - interface jp.co.intra_mart.framework.base.session.SessionFactory のメソッド
セッションオブジェクトを新規に生成します。
createShortCut(String, ShortCutInfo) - interface jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor のメソッド
ショートカットIDを作成します。
createShortCut(ShortCutInfo) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutManager のメソッド
ショートカットＩＤ作成。
createShortCut(String, ShortCutInfo) - class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor のメソッド
ショートカットIDを作成します。
createSocket() - class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor のメソッド
新しいソケットを作成します。
createSocket() - class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor のメソッド
推奨されていません。 新しいソケットを作成します。
createSocketConnectionDistributor(String) - class jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory のメソッド
Server-Manager に接続するためのネットワークコネクション管理 オブジェクトを取得します。
createStatement() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 SQL 文をデータベースに送るための Statement オブジェクトを生成します。
createStatement(int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定されたタイプと並行処理で ResultSet オブジェクトを生成する Statement オブジェクトを生成します。
createStatement(int, int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された型、並行処理、および holdability で ResultSet オブジェクトを生成する Statement オブジェクトを生成します。
createTerminableAccessor(Term) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap のメソッド
指定した期間に期間化アクセサを生成します。
createTerminableInternationalAccessor(Locale) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap のメソッド
期間国際化アクセサを生成します。
createTerminableInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
期間国際化モデルを生成します。
createTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap のメソッド
期間国際化モデルを生成します。
createTerminableModel(Term) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
指定した期間を満たす期間化モデルを生成します。
createTerminableModel(Term) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap のメソッド
指定した期間を満たす期間化モデルを生成します。
createTransitionName(String, String) - class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator の static メソッド
トランジションのコンポーネント名を返します。
createURL(String, Collection) - class jp.co.intra_mart.framework.base.web.tag.TagWriter の static メソッド
推奨されていません。 このメソッドではなくTagWriter.createURL(String, Collection, String)を使用してください。
createURL(String, Collection, String) - class jp.co.intra_mart.framework.base.web.tag.TagWriter の static メソッド
複数のパラメータをURLに追加します。
createURL(String) - class jp.co.intra_mart.jssp.net.GenericURLBuilder のメソッド
現在のリクエストを元にして、指定の画面へリンクするための URL を作成します。
createURL(URL, String) - class jp.co.intra_mart.jssp.net.GenericURLBuilder のメソッド
指定の URL を仕様解析のコンテキストとして スクリプト開発モデルの画面への URL を解決した URL を返します。
createURLonSession(String) - class jp.co.intra_mart.jssp.net.URLBuilder のメソッド
HTTP セッションを維持したまま指定のスクリプト開発モデルの画面へ リンクするための URL を返します。
createURLonSession(URL, String) - class jp.co.intra_mart.jssp.net.URLBuilder のメソッド
HTTP セッションを維持したまま指定のスクリプト開発モデルの画面へ リンクするための URL を返します。
createUrlSignature(String, String, String) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ダイレクトＵＲＬ署名を作成します。
createUserInfo(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.util.UserInfoUtil の static メソッド
intra-martのセッション情報からUserInfoを新規に生成します。
createWriter() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
メッセージをファイルへ書き出すための出力ストリームを作成します。
createWriter(OutputStreamWriter) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter の static メソッド
推奨されていません。 AdvancedOutputStreamWriter のスーパークラス AdvancedOutputStreamWriter を作成します。
createWriter() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 メッセージをファイルへ書き出すための出力ストリームを作成します。
currentWriter() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
このオブジェクトが文字を書き出している基礎 Writer を返します。
currentWriter() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 このオブジェクトが文字を書き出している基礎 Writer を返します。

D

DAO - interface jp.co.intra_mart.framework.base.data.DAO.
データリソースにアクセスするインタフェースです。
DAOAdapter - class jp.co.intra_mart.framework.base.data.DAOAdapter.
DAOのすべてのメソッドを何もしないように実装したクラスです。
DAOAdapter() - class jp.co.intra_mart.framework.base.data.DAOAdapter のコンストラクタ
DAOAdapterを新規に生成します。
DAOException - exception jp.co.intra_mart.framework.base.data.DAOException.
リソースコネクタの情報取得時の例外です。
DAOException() - class jp.co.intra_mart.framework.base.data.DAOException のコンストラクタ
詳細メッセージを指定しないで DAOException を構築します。
DAOException(String) - class jp.co.intra_mart.framework.base.data.DAOException のコンストラクタ
指定された詳細メッセージを持つ DAOException を構築します。
DAOException(String, Throwable) - class jp.co.intra_mart.framework.base.data.DAOException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DAOException を構築します。
DAO_SUFFIX - class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator の static 変数

DATA_ID - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
データID
DATA_NAME - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
データ名称
DATA_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.base.data.DataManager の static 変数
データプロパティハンドラのキー
DATA_PROPERTY_HANDLER_KEY - interface jp.co.intra_mart.framework.base.data.container.DataContainer の static 変数
データプロパティハンドラのキー
DATA_TYPE - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel の static 変数
データ型
DATA_TYPE - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
データタイプ
DATA_TYPE_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel の static 変数
データ型が数値を表す定数
DATA_TYPE_STRING - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel の static 変数
データ型が文字列型を表す定数
DATE - class jp.co.intra_mart.foundation.datastore.common.config.AttributeType の static 変数
日時型
DAY - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
日
DAY_WEEK - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
曜日
DB2 - class jp.co.intra_mart.foundation.database.DbTypes の static 変数

DBConnector - class jp.co.intra_mart.framework.base.data.DBConnector.
データベースに対するコネクタです。
DBConnector() - class jp.co.intra_mart.framework.base.data.DBConnector のコンストラクタ
DBConnectorを新規に生成します。
DBDAO - class jp.co.intra_mart.framework.base.data.DBDAO.
データベースに特化したDAOです。
DBDAO() - class jp.co.intra_mart.framework.base.data.DBDAO のコンストラクタ
デフォルトのコンストラクタ
DBResultAdapter - interface jp.co.intra_mart.foundation.database.DBResultAdapter.
スクリプト開発用データベースカラム取得アダプタインタフェース。
DBResultArrayAdapter - class jp.co.intra_mart.foundation.database.DBResultArrayAdapter.
スクリプト開発用データベースARRAY型カラム取得アダプタ。
DBResultArrayAdapter() - class jp.co.intra_mart.foundation.database.DBResultArrayAdapter のコンストラクタ

DBResultBigDecimalAdapter - class jp.co.intra_mart.foundation.database.DBResultBigDecimalAdapter.
スクリプト開発用データベースDECIMAL,NUMERIC型カラム取得アダプタ。
DBResultBigDecimalAdapter() - class jp.co.intra_mart.foundation.database.DBResultBigDecimalAdapter のコンストラクタ

DBResultBigIntAdapter - class jp.co.intra_mart.foundation.database.DBResultBigIntAdapter.
スクリプト開発用データベースBIGINT型カラム取得アダプタ。
DBResultBigIntAdapter() - class jp.co.intra_mart.foundation.database.DBResultBigIntAdapter のコンストラクタ

DBResultBinaryAdapter - class jp.co.intra_mart.foundation.database.DBResultBinaryAdapter.
スクリプト開発用データベースBINARY,LONGVARBINARY,VARBINARY型カラム取得アダプタ。
DBResultBinaryAdapter() - class jp.co.intra_mart.foundation.database.DBResultBinaryAdapter のコンストラクタ

DBResultBlobAdapter - class jp.co.intra_mart.foundation.database.DBResultBlobAdapter.
スクリプト開発用データベースBLOB型カラム取得アダプタ。
DBResultBlobAdapter() - class jp.co.intra_mart.foundation.database.DBResultBlobAdapter のコンストラクタ

DBResultBooleanAdapter - class jp.co.intra_mart.foundation.database.DBResultBooleanAdapter.
スクリプト開発用データベースBOOLEAN,BIT型カラム取得アダプタ。
DBResultBooleanAdapter() - class jp.co.intra_mart.foundation.database.DBResultBooleanAdapter のコンストラクタ

DBResultByteAdapter - class jp.co.intra_mart.foundation.database.DBResultByteAdapter.
スクリプト開発用データベースBYTE型カラム取得アダプタ。
DBResultByteAdapter() - class jp.co.intra_mart.foundation.database.DBResultByteAdapter のコンストラクタ

DBResultClobAdapter - class jp.co.intra_mart.foundation.database.DBResultClobAdapter.
スクリプト開発用データベースCLOB型カラム取得アダプタ。
DBResultClobAdapter() - class jp.co.intra_mart.foundation.database.DBResultClobAdapter のコンストラクタ

DBResultDateAdapter - class jp.co.intra_mart.foundation.database.DBResultDateAdapter.
スクリプト開発用データベースDATE型カラム取得アダプタ。
DBResultDateAdapter() - class jp.co.intra_mart.foundation.database.DBResultDateAdapter のコンストラクタ

DBResultDoubleAdapter - class jp.co.intra_mart.foundation.database.DBResultDoubleAdapter.
スクリプト開発用データベースDOUBLE,FLOAT型カラム取得アダプタ。
DBResultDoubleAdapter() - class jp.co.intra_mart.foundation.database.DBResultDoubleAdapter のコンストラクタ

DBResultImTimestampAdapter - class jp.co.intra_mart.foundation.database.DBResultImTimestampAdapter.
スクリプト開発用データベースTIMESTAMP型カラム取得intra-mart拡張アダプタ。
DBResultImTimestampAdapter() - class jp.co.intra_mart.foundation.database.DBResultImTimestampAdapter のコンストラクタ

DBResultIntegerAdapter - class jp.co.intra_mart.foundation.database.DBResultIntegerAdapter.
スクリプト開発用データベースINTEGER型カラム取得アダプタ。
DBResultIntegerAdapter() - class jp.co.intra_mart.foundation.database.DBResultIntegerAdapter のコンストラクタ

DBResultNullAdapter - class jp.co.intra_mart.foundation.database.DBResultNullAdapter.
スクリプト開発用データベースNULL型カラム取得アダプタ。
DBResultNullAdapter() - class jp.co.intra_mart.foundation.database.DBResultNullAdapter のコンストラクタ

DBResultObjectAdapter - class jp.co.intra_mart.foundation.database.DBResultObjectAdapter.
スクリプト開発用データベースカラムをObject型として取得するアダプタ。
DBResultObjectAdapter() - class jp.co.intra_mart.foundation.database.DBResultObjectAdapter のコンストラクタ

DBResultRealAdapter - class jp.co.intra_mart.foundation.database.DBResultRealAdapter.
スクリプト開発用データベースREAL型カラム取得アダプタ。
DBResultRealAdapter() - class jp.co.intra_mart.foundation.database.DBResultRealAdapter のコンストラクタ

DBResultRefAdapter - class jp.co.intra_mart.foundation.database.DBResultRefAdapter.
スクリプト開発用データベースREF型カラム取得アダプタ。
DBResultRefAdapter() - class jp.co.intra_mart.foundation.database.DBResultRefAdapter のコンストラクタ

DBResultShortAdapter - class jp.co.intra_mart.foundation.database.DBResultShortAdapter.
スクリプト開発用データベースSMALLINT型カラム取得アダプタ。
DBResultShortAdapter() - class jp.co.intra_mart.foundation.database.DBResultShortAdapter のコンストラクタ

DBResultStringAdapter - class jp.co.intra_mart.foundation.database.DBResultStringAdapter.
スクリプト開発用データベースカラムを文字列型として取得するアダプタ。
DBResultStringAdapter() - class jp.co.intra_mart.foundation.database.DBResultStringAdapter のコンストラクタ

DBResultStructAdapter - class jp.co.intra_mart.foundation.database.DBResultStructAdapter.
スクリプト開発用データベースSTRUCT型カラム取得アダプタ。
DBResultStructAdapter() - class jp.co.intra_mart.foundation.database.DBResultStructAdapter のコンストラクタ

DBResultTimeAdapter - class jp.co.intra_mart.foundation.database.DBResultTimeAdapter.
スクリプト開発用データベースTIME型カラム取得アダプタ。
DBResultTimeAdapter() - class jp.co.intra_mart.foundation.database.DBResultTimeAdapter のコンストラクタ

DBResultTimestampAdapter - class jp.co.intra_mart.foundation.database.DBResultTimestampAdapter.
スクリプト開発用データベースTIMESTAMP型カラム取得アダプター。
DBResultTimestampAdapter() - class jp.co.intra_mart.foundation.database.DBResultTimestampAdapter のコンストラクタ

DBTYPE_DB2 - class jp.co.intra_mart.foundation.database.DatabaseExport の static 変数
推奨されていません。
DBTYPE_ORACLE - class jp.co.intra_mart.foundation.database.DatabaseExport の static 変数
推奨されていません。
DBTYPE_POSTGRESQL - class jp.co.intra_mart.foundation.database.DatabaseExport の static 変数
推奨されていません。
DBTYPE_SQLSERVER - class jp.co.intra_mart.foundation.database.DatabaseExport の static 変数
推奨されていません。
DB_DB2 - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

DB_ORACLE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

DB_POSTGRE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

DEAL_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の static 変数
取扱コード
DEAL_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel の static 変数
取扱コード
DEAL_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel の static 変数
取扱コード
DEAL_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel の static 変数
取扱コード
DEAL_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel の static 変数
取扱コード
DEAL_NAME - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の static 変数
取扱名
DEAL_TYPE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の static 変数
取扱種別
DEAL_TYPE_BUY - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の static 変数
取引種別が仕入れを表す定数
DEAL_TYPE_SELL - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の static 変数
取引種別が売り上げを表す定数
DECIMAL - class jp.co.intra_mart.foundation.datastore.common.config.AttributeType の static 変数
整数型
DEFAULT_ACCESSOR - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

DEFAULT_ACCESS_SECURITY_PAGE_PROVIDER_CLASS - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor の static 変数

DEFAULT_ACCESS_SECURITY_PAGE_PROVIDER_CLASS - class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor の static 変数

DEFAULT_ACTIVE_SESSION_ACCESSOR - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager の static 変数

DEFAULT_APPLICATION_PARAMETER - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler の static 変数
推奨されていません。 この実装は廃止されました。
DEFAULT_ATTR_INVALIDATE_OTHER_SESSIONS - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager の static 変数

DEFAULT_ATTR_REQUESTED_PAGE - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager の static 変数

DEFAULT_ATTR_REQUESTED_PAGE - class jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter の static 変数
遷移先の警告ページにリクエストURLを渡すために利用するリクエスト属性名のデフォルト名
DEFAULT_AUTH_COOKIE_NAME - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の static 変数

DEFAULT_BOTTOM_MARGIN - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準のグラフ領域の下部マージン
DEFAULT_BOTTOM_MARGIN - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準のグラフ領域の下部マージン
DEFAULT_BOTTOM_MARGIN - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準のグラフ領域の下部マージン
DEFAULT_BOTTOM_MARGIN - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準のグラフ領域の下部マージン
DEFAULT_BOTTOM_MARGIN - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準のグラフ領域の下部マージン
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler の static 変数
デフォルトのXMLファイル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler の static 変数
デフォルトのxmlファイルのプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler の static 変数
デフォルトのリソースバンドル名
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler の static 変数
デフォルトのxmlファイル名
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler の static 変数
デフォルトのリソースバンドル名
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler の static 変数
デフォルトのXMLファイル名
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler の static 変数
デフォルトのリソースバンドル名
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.system.property.DefaultPropertyManager の static 変数
デフォルトのリソースバンドル名
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.system.property.XmlPropertyManager の static 変数
デフォルトのリソースバンドル名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler の static 変数
XMLファイル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler の static 変数
xmlのパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler の static 変数
xmlファイル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler の static 変数
XMLファイル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_CAPTION_MARGIN - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準のキャプション表示位置のマージン
DEFAULT_CAPTION_MARGIN - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準のキャプション表示位置のマージン
DEFAULT_COMMENT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

DEFAULT_COMMENT - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor の static 変数
コメント
DEFAULT_CONFIG_PAGE_COUNT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
履歴表示件数 ：デフォルト件数
DEFAULT_DUPLICATE_LOGIN_ACCESSOR - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager の static 変数

DEFAULT_DUPLICATE_LOGIN_DETECT_ENABLE - class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor の static 変数

DEFAULT_ENCODING_ATTRIBUTE - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler の static 変数
ログインユーザのエンコーディングのデフォルトの属性名
DEFAULT_EXCEPTION_ATTRIBUTE - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler の static 変数
例外属性のデフォルトの属性名
DEFAULT_EXPORTER - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

DEFAULT_FAVORITE - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor の static 変数
保存ナビゲート結果（お気に入）
DEFAULT_GRAPH_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準のグラフ領域の背景色
DEFAULT_GRAPH_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準のグラフ領域の背景色
DEFAULT_GRAPH_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準のグラフ領域の背景色
DEFAULT_GRAPH_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準のグラフ領域のボーダー色
DEFAULT_GRAPH_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準のグラフ領域のボーダー色
DEFAULT_GRAPH_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準のグラフ領域のボーダー色
DEFAULT_GRAPH_FRAME_COLOR - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準のグラフ枠の線色
DEFAULT_HISTORY - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor の static 変数
保存ナビゲート結果（履歴）
DEFAULT_IGNORE_ERR_MSG_RETURN_TYPES - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController の static 変数
エラーメッセージを無視するRETURN-TYPEの設定。
DEFAULT_IMAGE_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準の画像ファイル背景色
DEFAULT_IMAGE_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準の画像ファイル背景色
DEFAULT_IMAGE_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準の画像ファイル背景色
DEFAULT_IMAGE_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準の画像ファイル背景色
DEFAULT_IMAGE_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準の画像ファイル背景色
DEFAULT_IMAGE_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準の画像ファイルのボーダ色
DEFAULT_IMAGE_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準の画像ファイルのボーダ色
DEFAULT_IMAGE_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準の画像ファイルのボーダ色
DEFAULT_IMAGE_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準の画像ファイルのボーダ色
DEFAULT_IMAGE_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準の画像ファイルのボーダ色
DEFAULT_IMPORTER - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

DEFAULT_INVALIDATABLE_BY_USER - class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor の static 変数

DEFAULT_LEFT_MARGIN - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準のグラフ領域の左側マージン
DEFAULT_LEFT_MARGIN - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準のグラフ領域の左側マージン
DEFAULT_LEFT_MARGIN - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準のグラフ領域の左側マージン
DEFAULT_LEFT_MARGIN - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準のグラフ領域の左側マージン
DEFAULT_LEFT_MARGIN - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準のグラフ領域の左側マージン
DEFAULT_LOCALE_ATTRIBUTE - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler の static 変数
ログインユーザのロケールのデフォルトの属性名
DEFAULT_LOGIN_KEY - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の static 変数

DEFAULT_MULTIPART_PROPERTIES - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle の static 変数
プロパティファイル名
DEFAULT_PAGE_LOCATION - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor の static 変数

DEFAULT_PAGE_LOCATION - class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor の static 変数

DEFAULT_RIGHT_MARGIN - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準のグラフ領域の右側マージン
DEFAULT_RIGHT_MARGIN - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準のグラフ領域の右側マージン
DEFAULT_RIGHT_MARGIN - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準のグラフ領域の右側マージン
DEFAULT_RIGHT_MARGIN - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準のグラフ領域の右側マージン
DEFAULT_RIGHT_MARGIN - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準のグラフ領域の右側マージン
DEFAULT_SERVICE_EXTENSION - class jp.co.intra_mart.framework.base.service.ServiceManager の static 変数
サービスフレームワークをコールするためのデフォルトの拡張子
DEFAULT_SERVICE_PARAMETER - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler の static 変数
推奨されていません。 この実装は廃止されました。
DEFAULT_SIZETHRESHOLD - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle の static 変数
useCommonsFileuploadがtrueの場合、一時ファイルを作成するデフォルトの閾値（単位：バイト）
DEFAULT_SORT_KEY - class jp.co.intra_mart.foundation.image.ImageIconInfo の static 変数
デフォルトソートキー
DEFAULT_SP_ACTIVE_SESSION_BINDING_LISTENER - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager の static 変数

DEFAULT_STROKE - class jp.co.intra_mart.foundation.graph.LineGraphObject の static 変数

DEFAULT_SYSTEM_MANAGER - class jp.co.intra_mart.framework.system.property.PropertyManager の static 変数
デフォルトのプロパティマネージャクラス
DEFAULT_TITLE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

DEFAULT_TITLE - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor の static 変数
タイトル
DEFAULT_TOP_MARGIN - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準のグラフ領域の上部マージン
DEFAULT_TOP_MARGIN - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準のグラフ領域の上部マージン
DEFAULT_TOP_MARGIN - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準のグラフ領域の上部マージン
DEFAULT_TOP_MARGIN - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準のグラフ領域の上部マージン
DEFAULT_TOP_MARGIN - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準のグラフ領域の上部マージン
DEPARTMENT_CD - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel の static 変数
組織CD
DEPARTMENT_CD - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel の static 変数
組織CD
DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
組織コード
DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の static 変数
組織コード
DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
組織コード
DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
組織コード
DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の static 変数
組織コード
DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel の static 変数
組織コード
DEPTH - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
階層レベル
DEPTH - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
階層レベル
DISPLAY_NAME - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
データ表示名
DISPLAY_NAME - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel の static 変数
メニュー表示名
DISPLAY_NAME - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の static 変数
メニュー表示名
DISPLAY_NAME - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel の static 変数
ロール表示名
DISPLAY_NONE - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet の static 変数
表示単位を指定しない状態
DISPLAY_PERCENT - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet の static 変数
表示単位パーセント
DISPLAY_PIXCEL - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet の static 変数
表示単位ピクセル
DaoModel - class jp.co.intra_mart.framework.base.data.DaoModel.
DaoModelを管理するクラスです。
DaoModel() - class jp.co.intra_mart.framework.base.data.DaoModel のコンストラクタ

DataAccessController - class jp.co.intra_mart.framework.base.data.DataAccessController.
データアクセスを制御します。
DataAccessController(DataPropertyHandler) - class jp.co.intra_mart.framework.base.data.DataAccessController のコンストラクタ
データアクセスコントローラを生成します。
DataAccessException - exception jp.co.intra_mart.framework.base.data.DataAccessException.
データアクセス時の例外です。
DataAccessException() - class jp.co.intra_mart.framework.base.data.DataAccessException のコンストラクタ
詳細メッセージを指定しないで DataAccessException を構築します。
DataAccessException(String) - class jp.co.intra_mart.framework.base.data.DataAccessException のコンストラクタ
指定された詳細メッセージを持つ DataAccessException を構築します。
DataAccessException(String, Throwable) - class jp.co.intra_mart.framework.base.data.DataAccessException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataAccessException を構築します。
DataConnectException - exception jp.co.intra_mart.framework.base.data.DataConnectException.
データ接続に関連する例外です。
DataConnectException() - class jp.co.intra_mart.framework.base.data.DataConnectException のコンストラクタ
詳細メッセージを指定しないで DataConnectException を構築します。
DataConnectException(String) - class jp.co.intra_mart.framework.base.data.DataConnectException のコンストラクタ
指定された詳細メッセージを持つ DataConnectException を構築します。
DataConnectException(String, Throwable) - class jp.co.intra_mart.framework.base.data.DataConnectException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataConnectException を構築します。
DataConnector - class jp.co.intra_mart.framework.base.data.DataConnector.
データストアに接続するコネクタです。
DataConnector() - class jp.co.intra_mart.framework.base.data.DataConnector のコンストラクタ
新規のDataConnectorを生成します。
DataConnectorException - exception jp.co.intra_mart.framework.base.data.DataConnectorException.
データコネクタ取得時の例外です。
DataConnectorException() - class jp.co.intra_mart.framework.base.data.DataConnectorException のコンストラクタ
詳細メッセージを指定しないで DataConnectorException を構築します。
DataConnectorException(String) - class jp.co.intra_mart.framework.base.data.DataConnectorException のコンストラクタ
指定された詳細メッセージを持つ DataConnectorException を構築します。
DataConnectorException(String, Throwable) - class jp.co.intra_mart.framework.base.data.DataConnectorException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataConnectorException を構築します。
DataContainer - interface jp.co.intra_mart.framework.base.data.container.DataContainer.
データコンテナのインターフェースです。
DataContainerException - exception jp.co.intra_mart.framework.base.data.container.DataContainerException.
データコンテナ設定時の例外です。
DataContainerException() - class jp.co.intra_mart.framework.base.data.container.DataContainerException のコンストラクタ
詳細メッセージを指定しないで DataContainerException を構築します。
DataContainerException(String) - class jp.co.intra_mart.framework.base.data.container.DataContainerException のコンストラクタ
指定された詳細メッセージを持つ DataContainerException を構築します。
DataContainerException(String, Throwable) - class jp.co.intra_mart.framework.base.data.container.DataContainerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataContainerException を構築します。
DataContainerFactory - class jp.co.intra_mart.framework.base.data.container.factory.DataContainerFactory.
DataContainerのファクトリクラスです。
DataContainerFactory() - class jp.co.intra_mart.framework.base.data.container.factory.DataContainerFactory のコンストラクタ

DataContainerImpl - class jp.co.intra_mart.framework.base.data.container.DataContainerImpl.
DataContainerの標準的な実装クラスです。
DataContainerImpl() - class jp.co.intra_mart.framework.base.data.container.DataContainerImpl のコンストラクタ
DataContainerImplを生成します。
DataManager - class jp.co.intra_mart.framework.base.data.DataManager.
データストアとの接続を管理します。
DataManager() - class jp.co.intra_mart.framework.base.data.DataManager のコンストラクタ
データマネージャを生成するコンストラクタです。
DataManagerException - exception jp.co.intra_mart.framework.base.data.DataManagerException.
データマネージャの設定時の例外です。
DataManagerException() - class jp.co.intra_mart.framework.base.data.DataManagerException のコンストラクタ
詳細メッセージを指定しないで DataManagerException を構築します。
DataManagerException(String) - class jp.co.intra_mart.framework.base.data.DataManagerException のコンストラクタ
指定された詳細メッセージを持つ DataManagerException を構築します。
DataManagerException(String, Throwable) - class jp.co.intra_mart.framework.base.data.DataManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataManagerException を構築します。
DataNotFoundException - exception jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException.
アクセサのプロパティ値の取得に関する例外クラス

指定されたプロパティに対する値が設定されていない場合にスローする。
DataNotFoundException() - class jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException のコンストラクタ
コンストラクタ
DataNotFoundException(String) - class jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException のコンストラクタ
コンストラクタ
DataNotFoundException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException のコンストラクタ
コンストラクタ
DataNotFoundException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException のコンストラクタ
コンストラクタ
DataPropertyException - exception jp.co.intra_mart.framework.base.data.DataPropertyException.
データプロパティ取得時の例外です。
DataPropertyException() - class jp.co.intra_mart.framework.base.data.DataPropertyException のコンストラクタ
詳細メッセージを指定しないで DataPropertyException を構築します。
DataPropertyException(String) - class jp.co.intra_mart.framework.base.data.DataPropertyException のコンストラクタ
指定された詳細メッセージを持つ DataPropertyException を構築します。
DataPropertyException(String, Throwable) - class jp.co.intra_mart.framework.base.data.DataPropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataPropertyException を構築します。
DataPropertyHandler - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler.
DAOの設定情報に接続するクラスです。
DataSourceConnector - class jp.co.intra_mart.framework.base.data.DataSourceConnector.
DataSourceに関連するデータコネクタです。
DataSourceConnector() - class jp.co.intra_mart.framework.base.data.DataSourceConnector のコンストラクタ
DataSourceConnectorを新規に生成します。
DataSourceProvider - interface jp.co.intra_mart.foundation.database.DataSourceProvider.
データソース設定情報取得プロバイダインタフェース。
DataStoreApplicationException - exception jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException.
アプリケーション共通マスタで発生するアプリケーション例外の基底クラス
DataStoreApplicationException() - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のコンストラクタ
コンストラクタ
DataStoreApplicationException(String) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のコンストラクタ
コンストラクタ
DataStoreApplicationException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のコンストラクタ
コンストラクタ
DataStoreApplicationException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のコンストラクタ
コンストラクタ
DataStoreConfigException - exception jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException.
アプリケーション共通マスタの設定に関する例外クラス

アプリケーション共通マスタの設定に不整合がある場合にスローする。
DataStoreConfigException() - class jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException のコンストラクタ
詳細メッセージを指定しないで DataStoreConfigException を構築します。
DataStoreConfigException(String) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException のコンストラクタ
指定された詳細メッセージを持つ DataStoreConfigException を構築します。
DataStoreConfigException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PresentationPropertyException を構築します。
DataStoreConfigException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException のコンストラクタ
この例外の発生原因となる例外を持つ PresentationPropertyException を構築します。
DataStoreConst - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst.
データストアの定数クラス
DataStoreSystemException - exception jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException.
アプリケーション共通マスタで発生するシステム例外の基底クラス
DataStoreSystemException() - class jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException のコンストラクタ
コンストラクタ
DataStoreSystemException(String) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException のコンストラクタ
コンストラクタ
DataStoreSystemException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException のコンストラクタ
コンストラクタ
DataStoreSystemException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException のコンストラクタ
コンストラクタ
DatabaseAccessor - interface jp.co.intra_mart.foundation.database.DatabaseAccessor.
データベース接続オブジェクト取得インターフェースを定義します。
DatabaseColumn - class jp.co.intra_mart.foundation.database.DatabaseColumn.

DatabaseColumn() - class jp.co.intra_mart.foundation.database.DatabaseColumn のコンストラクタ

DatabaseColumn(int) - class jp.co.intra_mart.foundation.database.DatabaseColumn のコンストラクタ

DatabaseColumn(int, int) - class jp.co.intra_mart.foundation.database.DatabaseColumn のコンストラクタ

DatabaseColumn(String, String, String, int, boolean) - class jp.co.intra_mart.foundation.database.DatabaseColumn のコンストラクタ

DatabaseExport - class jp.co.intra_mart.foundation.database.DatabaseExport.
推奨されていません。 システム内部で利用しているクラスです。
DatabaseExportException - exception jp.co.intra_mart.foundation.database.exception.DatabaseExportException.
推奨されていません。 システム内部で利用しているクラスです。
DatabaseExportException(int) - class jp.co.intra_mart.foundation.database.exception.DatabaseExportException のコンストラクタ
推奨されていません。
DatabaseExportException(String, int) - class jp.co.intra_mart.foundation.database.exception.DatabaseExportException のコンストラクタ
推奨されていません。
DatabaseManager - class jp.co.intra_mart.foundation.database.DatabaseManager.
データベースマネージャクラス。
DatabaseSQLException - exception jp.co.intra_mart.foundation.database.exception.DatabaseSQLException.
データベースSQL例外拡張クラス。
DatabaseSQLException(String) - class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException のコンストラクタ
コンストラクタ。
DatabaseSQLException(String, String) - class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException のコンストラクタ
コンストラクタ。
DatabaseSQLException(String, String, int) - class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException のコンストラクタ
コンストラクタ。
DatabaseSQLException(String, Throwable) - class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException のコンストラクタ
コンストラクタ。
DatabaseSQLException(String, String, Throwable) - class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException のコンストラクタ
コンストラクタ。
DatabaseSQLException(String, String, int, Throwable) - class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException のコンストラクタ
コンストラクタ。
DateHandler - class jp.co.intra_mart.foundation.sap.common.util.date.DateHandler.
DateHandlerクラス
機能は以下の通り
SAPリアルタイム連携APIにて使用する共通Date関連機能を提供します。
DateUtil - class jp.co.intra_mart.common.platform.util.DateUtil.
日付操作ユーティリティクラスです。
DayInfo - interface jp.co.intra_mart.foundation.security.calendar.DayInfo.
日付に対するカレンダーデータ情報の取得インターフェース。
DbManager - class jp.co.intra_mart.foundation.database.DbManager.
推奨されていません。 DatabaseManagerを使用してください。
DbManager(String) - class jp.co.intra_mart.foundation.database.DbManager のコンストラクタ
推奨されていません。 DatabaseManagerを使用してください。
DbTypes - class jp.co.intra_mart.foundation.database.DbTypes.

DbsConnection - interface jp.co.intra_mart.foundation.database.DbsConnection.
推奨されていません。 Connectionを利用してください。
Deal - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal.
取扱の基本属性のデータを取り扱います。
Deal() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のコンストラクタ
取扱に関連する情報を新規に生成します。
Deal(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のコンストラクタ
取扱に関連する情報を新規に生成します。
DealBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel.
取扱の基本モデルです。
DealDetail - class jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail.
取扱詳細の基本属性のデータを取り扱います。
DealDetail() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail のコンストラクタ

DealDetailBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel.
取扱詳細の基本モデルです。
DealDetailMapper - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper.
取扱詳細に関連するマッパです。
DealDetailTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailTerminableModel.
取扱詳細の期間化モデルです。
DealManager - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager.
取扱に関する情報を管理します。
DealManager() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のコンストラクタ

DealMapper - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper.
取扱に関連するマッパです。
DealPermissionManager - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager.
取扱情報に対するアクセス権を操作します。
DealPermissionManager() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager のコンストラクタ

DealTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable.
取扱の期間化属性のデータを取り扱います。
DealTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable のコンストラクタ

DealTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealTerminableModel.
取扱の期間化モデルです。
DealerDepartment - class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment.
組織毎取扱パーミッションの基本属性のデータを取り扱います。
DealerDepartment() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment のコンストラクタ

DealerDepartmentBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel.
組織毎取扱パーミッションの基本モデルです。
DealerDepartmentMapper - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper.
組織毎取扱パーミッションに関連するマッパです。
DealerPublicGroup - class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup.
パブリックグループ毎取扱パーミッションの基本属性のデータを取り扱います。
DealerPublicGroup() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup のコンストラクタ

DealerPublicGroupBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel.
パブリックグループ毎取扱パーミッションの基本モデルです。
DealerPublicGroupMapper - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper.
パブリックグループ毎取扱パーミッションに関連するマッパです。
DealerRole - class jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole.
ロール毎取扱パーミッションの基本属性のデータを取り扱います。
DealerRole() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole のコンストラクタ

DealerRoleBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel.
ロール毎取扱パーミッションの基本モデルです。
DealerRoleMapper - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper.
ロール毎取扱パーミッションに関連するマッパです。
DebtorGetDetail - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail.
得意先詳細情報取得クラス
機能は以下の通り
得意先詳細情報を取得します。
DebtorGetDetail(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のコンストラクタ
得意先詳細情報を作成
DebtorGetDetail(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のコンストラクタ

DebtorGetDetailController - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController.
得意先詳細コントローラクラス
機能は以下の通り
得意先詳細を取得します。
DebtorGetDetailController(String, String) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のコンストラクタ

DebtorGetDetailController(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のコンストラクタ

DebtorGetDetailController() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のコンストラクタ
DebtorGetDetailControllerのコンストラクタを生成します。
DebtorGetDetailController(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のコンストラクタ
DebtorGetDetailControllerのコンストラクタを生成します。
DefaultDataPropertyHandler - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler.
デフォルトのデータプロパティハンドラです。
DefaultDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のコンストラクタ
DefaultDataPropertyHandlerを新規に生成します。
DefaultDataProvider - class jp.co.intra_mart.framework.base.data.container.factory.DefaultDataProvider.
標準的なプロバイダーです。
DefaultDataProvider() - class jp.co.intra_mart.framework.base.data.container.factory.DefaultDataProvider のコンストラクタ
DefaultDataProviderを新規に生成します。
DefaultEventPropertyHandler - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler.
デフォルトのEventPropertyHandlerです。
DefaultEventPropertyHandler() - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のコンストラクタ
DefaultEventPropertyHandlerを新規に生成します。
DefaultEventProvider - class jp.co.intra_mart.framework.base.event.container.factory.DefaultEventProvider.
標準的なプロバイダーです。
DefaultEventProvider() - class jp.co.intra_mart.framework.base.event.container.factory.DefaultEventProvider のコンストラクタ
DefaultEventProviderを新規に生成します。
DefaultLogAgent - class jp.co.intra_mart.framework.system.log.DefaultLogAgent.
デフォルトのログエージェントです。
DefaultLogAgent() - class jp.co.intra_mart.framework.system.log.DefaultLogAgent のコンストラクタ

DefaultLogPropertyHandler - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler.
ログに関連するデフォルトのプロパティハンドラです。
DefaultLogPropertyHandler() - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler のコンストラクタ
DefaultLogPropertyHandlerを新規に生成します。
DefaultMKServiceResult - class jp.co.intra_mart.extension.maskat.service.DefaultMKServiceResult.
デフォルトのMKServiceResult実装です。
DefaultMKServiceResult(Document) - class jp.co.intra_mart.extension.maskat.service.DefaultMKServiceResult のコンストラクタ
ドキュメントから新規に処理結果を生成します。
DefaultMKServiceResult(String) - class jp.co.intra_mart.extension.maskat.service.DefaultMKServiceResult のコンストラクタ
XML文字列から新規に処理結果を生成します。
DefaultMessagePropertyHandler - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler.
メッセージの設定情報に接続するデフォルトのプロパティハンドラです。
DefaultMessagePropertyHandler() - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler のコンストラクタ
DefaultMessagePropertyHandlerを新規に生成します。
DefaultMessagePropertyHandler - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler.
デフォルトのメッセージプロパティハンドラです。
DefaultMessagePropertyHandler() - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler のコンストラクタ
DefaultMessagePropertyHandlerを新規に生成します。
DefaultPropertyManager - class jp.co.intra_mart.framework.system.property.DefaultPropertyManager.
デフォルトのプロパティマネージャです。
DefaultPropertyManager() - class jp.co.intra_mart.framework.system.property.DefaultPropertyManager のコンストラクタ
コンストラクタです。
DefaultServicePropertyHandler - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.
サービスの設定情報に接続するデフォルトのプロパティハンドラです。
DefaultServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のコンストラクタ
DefaultServicePropertyHandlerを新規に生成します。
DefaultServiceProvider - class jp.co.intra_mart.framework.base.service.container.factory.DefaultServiceProvider.
標準的なプロバイダーです。
DefaultServiceProvider() - class jp.co.intra_mart.framework.base.service.container.factory.DefaultServiceProvider のコンストラクタ
DefaultServiceProviderを新規に生成します。
DefaultSessionPropertyHandler - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler.
セッションに関連するデフォルトのプロパティハンドラです。
DefaultSessionPropertyHandler() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のコンストラクタ
DefaultSessionPropertyHandlerを新規に生成します。
DefaultTransition - class jp.co.intra_mart.framework.base.service.DefaultTransition.
デフォルトの画面遷移をします。
DefaultTransition() - class jp.co.intra_mart.framework.base.service.DefaultTransition のコンストラクタ
DefaultTransitionを新規に生成します。
Delete - interface jp.co.intra_mart.foundation.datastore.common.config.Delete.
削除時の整合性制約です。
DeleteType - class jp.co.intra_mart.foundation.datastore.common.config.DeleteType.
削除時の整合性制約のタイプです。
DeliveryAddress - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress.
入荷伝票アドレス情報クラス
機能は以下の通り
入荷伝票アドレス情報を保持します。
DeliveryAddress() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のコンストラクタ
入荷伝票アドレスを作成します。
DeliveryAddress(int) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のコンストラクタ
入荷伝票アドレスを作成します。
Department - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department.
組織の基本属性のデータを取り扱います。
Department() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のコンストラクタ
組織に関連する情報を新規に生成します。
Department(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のコンストラクタ
組織に関連する情報を新規に生成します。
Department(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のコンストラクタ
組織に関連する情報を新規に生成します。
Department(Locale, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のコンストラクタ
組織に関連する情報を新規に生成します。
DepartmentAttach - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach.
組織所属の基本属性のデータを取り扱います。
DepartmentAttach() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のコンストラクタ
組織所属に関連する情報を新規に生成します。
DepartmentAttach(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のコンストラクタ
組織所属に関連する情報を新規に生成します。
DepartmentAttachBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel.
組織所属の基本モデルです。
DepartmentAttachMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper.
組織所属に関連するマッパです。
DepartmentAttachTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable.
組織所属の期間化属性のデータを取り扱います。
DepartmentAttachTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable のコンストラクタ

DepartmentAttachTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel.
組織所属の期間化モデルです。
DepartmentBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel.
組織の基本モデルです。
DepartmentInclusionBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel.
組織内包の基本モデルです。
DepartmentInclusionMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper.
組織内包に関連するマッパです。
DepartmentInfo - class jp.co.intra_mart.foundation.security.DepartmentInfo.
組織情報クラス。
DepartmentInfo(String, String) - class jp.co.intra_mart.foundation.security.DepartmentInfo のコンストラクタ
コンストラクタ。
DepartmentMain - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain.
主所属の基本属性のデータを取り扱います。
DepartmentMain() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のコンストラクタ
主所属に関連する情報を新規に生成します。
DepartmentMain(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のコンストラクタ
主所属に関連する情報を新規に生成します。
DepartmentMainBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel.
主所属の基本モデルです。
DepartmentMainMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper.
主所属に関連するマッパです。
DepartmentMainTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable.
主所属の期間化属性のデータを取り扱います。
DepartmentMainTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable のコンストラクタ

DepartmentMainTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel.
主所属の期間化モデルです。
DepartmentMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper.
組織に関連するマッパです。
DepartmentStruct - interface jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct.
組織の階層です。
DepartmentTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable.
組織の期間化属性のデータを取り扱います。
DepartmentTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のコンストラクタ

DepartmentTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational.
組織の期間国際化属性のデータを取り扱います。
DepartmentTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のコンストラクタ

DepartmentTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel.
組織の期間国際化モデルです。
DepartmentTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel.
組織の期間化モデルです。
Directory - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory.
このクラスは、ディレクトリを扱う時に便利な機能を提供します。
Directory(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のコンストラクタ
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
Directory(File, String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のコンストラクタ
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
Directory(String, String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のコンストラクタ
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
Directory - class jp.co.intra_mart.foundation.utility.file.Directory.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。
Directory(String) - class jp.co.intra_mart.foundation.utility.file.Directory のコンストラクタ
推奨されていません。 指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
Directory(File, String) - class jp.co.intra_mart.foundation.utility.file.Directory のコンストラクタ
推奨されていません。 親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
Directory(String, String) - class jp.co.intra_mart.foundation.utility.file.Directory のコンストラクタ
推奨されていません。 親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
DistributesDataPropertyHandler - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler.
アプリケーション毎のプロパティハンドラを呼び出します。
DistributesDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のコンストラクタ
DefaultDataPropertyHandlerを新規に生成します。
DistributesEventPropertyHandler - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler.
アプリケーション毎のEventPropertyHandlerを呼び出します。
DistributesEventPropertyHandler() - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のコンストラクタ
DistributesEventPropertyHandlerを新規に生成します。
DistributesServicePropertyHandler - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.
アプリケーションごとに異なるサービスプロパティハンドラを使用するサービスプロパティハンドラです。
DistributesServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のコンストラクタ
DefaultServicePropertyHandlerを新規に生成します。
DistributionChannelSelection - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection.
流通チャネルの選択オプションクラス
機能は以下の通り
流通チャネルの選択オプションの情報を保持します。
DistributionChannelSelection() - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のコンストラクタ
流通チャネルの選択オプション情報を作成します。
DistributionChannelSelection(int) - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のコンストラクタ
流通チャネルの選択オプション情報を作成します。
DocumentHeader - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader.
伝票ヘッダクラス
機能は以下の通り
伝票ヘッダの情報を保持します。
DocumentHeader() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のコンストラクタ
伝票ヘッダ情報を作成します。
DualComparator - interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator.
２つのコンパレータを使用してソートを行うためのインターフェースです。
DualComparator - interface jp.co.intra_mart.foundation.utility.DualComparator.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.DualComparator クラスを使用してください。
DuplicateException - exception jp.co.intra_mart.foundation.security.exception.DuplicateException.
作成時重複例外クラス。
DuplicateException(String, String, String) - class jp.co.intra_mart.foundation.security.exception.DuplicateException のコンストラクタ
コンストラクタ。
DuplicateException(String, String) - class jp.co.intra_mart.foundation.security.exception.DuplicateException のコンストラクタ
コンストラクタ。
DuplicateException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.DuplicateException のコンストラクタ
コンストラクタ。
DuplicateException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.DuplicateException のコンストラクタ
コンストラクタ。
DuplicateImageIconCodeException - exception jp.co.intra_mart.foundation.image.DuplicateImageIconCodeException.
登録時重複例外クラス。
DuplicateImageIconCodeException() - class jp.co.intra_mart.foundation.image.DuplicateImageIconCodeException のコンストラクタ
コンストラクタ。
DuplicateImageIconCodeException(String, String) - class jp.co.intra_mart.foundation.image.DuplicateImageIconCodeException のコンストラクタ
コンストラクタ。
DuplicateImageIconCodeException(Throwable) - class jp.co.intra_mart.foundation.image.DuplicateImageIconCodeException のコンストラクタ
コンストラクタ。
DuplicateImageIconCodeException(String, String, Throwable) - class jp.co.intra_mart.foundation.image.DuplicateImageIconCodeException のコンストラクタ
コンストラクタ。
DuplicateImageIconSrcException - exception jp.co.intra_mart.foundation.image.DuplicateImageIconSrcException.
作成/更新時URLの重複例外クラス。
DuplicateImageIconSrcException() - class jp.co.intra_mart.foundation.image.DuplicateImageIconSrcException のコンストラクタ
コンストラクタ。
DuplicateImageIconSrcException(String, String) - class jp.co.intra_mart.foundation.image.DuplicateImageIconSrcException のコンストラクタ
コンストラクタ。
DuplicateImageIconSrcException(Throwable) - class jp.co.intra_mart.foundation.image.DuplicateImageIconSrcException のコンストラクタ
コンストラクタ。
DuplicateImageIconSrcException(String, String, Throwable) - class jp.co.intra_mart.foundation.image.DuplicateImageIconSrcException のコンストラクタ
コンストラクタ。
DuplicateLoginAccessor - interface jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor.
重複ログイン操作インターフェース。
DuplicateLoginDetectedException - exception jp.co.intra_mart.foundation.security.exception.DuplicateLoginDetectedException.
重複ログイン検出例外クラス

DuplicateLoginDetectedException(String) - class jp.co.intra_mart.foundation.security.exception.DuplicateLoginDetectedException のコンストラクタ
コンストラクタ。
DuplicateLoginDetectedException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.DuplicateLoginDetectedException のコンストラクタ
コンストラクタ。
DuplicateLoginDetectedException(Throwable) - class jp.co.intra_mart.foundation.security.exception.DuplicateLoginDetectedException のコンストラクタ
コンストラクタ。
DuplicateLoginDetectedException() - class jp.co.intra_mart.foundation.security.exception.DuplicateLoginDetectedException のコンストラクタ
コンストラクタ。
DuplicateLoginException - exception jp.co.intra_mart.foundation.security.exception.DuplicateLoginException.
重複ログイン制御例外の基本となる例外クラス。
DuplicateLoginException(String) - class jp.co.intra_mart.foundation.security.exception.DuplicateLoginException のコンストラクタ
コンストラクタ。
DuplicateLoginException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.DuplicateLoginException のコンストラクタ
コンストラクタ。
DuplicateLoginException(Throwable) - class jp.co.intra_mart.foundation.security.exception.DuplicateLoginException のコンストラクタ
コンストラクタ。
DuplicateLoginException() - class jp.co.intra_mart.foundation.security.exception.DuplicateLoginException のコンストラクタ
コンストラクタ。
DuplicateLoginHandlingFilter - class jp.co.intra_mart.foundation.security.filter.DuplicateLoginHandlingFilter.
重複ログインハンドリングフィルタ。
DuplicateLoginHandlingFilter() - class jp.co.intra_mart.foundation.security.filter.DuplicateLoginHandlingFilter のコンストラクタ

DuplicateLoginManager - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager.
重複ログイン管理マネージャクラス。
DuplicateLoginManager() - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager のコンストラクタ
コンストラクタ。
dateToString(Date) - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
データベース登録用文字列を取得します。
dateToString(Date) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
データベース登録用文字列を取得します。
dateToString(Date) - class jp.co.intra_mart.foundation.database.DbManager の static メソッド
推奨されていません。 DatabaseManager.dateToString(Date)を使用してください。
datumpoint - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter の変数
このリポーターがフィルタリングする基準レベル値
datumpoint - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter の変数
推奨されていません。 このリポーターがフィルタリングする基準レベル値
dbConsistChk(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
decode(String) - interface jp.co.intra_mart.foundation.portal.common.encode.EnCodeInterface のメソッド
復号化を行います。
decrement() - class jp.co.intra_mart.common.aid.jdk.util.Counter のメソッド
カウンターの値を１だけ減少させます。
decrement() - class jp.co.intra_mart.foundation.utility.Counter のメソッド
推奨されていません。 カウンターの値を１だけ減少させます。
decrypt(String) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
デフォルトの暗号化アルゴリズムカテゴリを利用して暗号化された文字列を復号します。
decrypt(String, String) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
指定された暗号化アルゴリズムカテゴリを利用して暗号化された文字列を復号します。
decrypt(String) - interface jp.co.intra_mart.foundation.security.cryption.Cryption のメソッド
暗号化された文字列を復号するe。
decrypt(String) - class jp.co.intra_mart.foundation.security.cryption.NoCryption のメソッド
暗号化された文字列を復号するe。
decrypt(String) - class jp.co.intra_mart.foundation.security.cryption.StandardCryption のメソッド
暗号化された文字列を復号するe。
defineInitializeTime(int, int, int) - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
バッチ初期化時間の設定。
definePath(String) - class jp.co.intra_mart.foundation.service.provider.HomeDirectory の static メソッド
推奨されていません。
del(String) - class jp.co.intra_mart.foundation.acssecurity.Logingp のメソッド
推奨されていません。 代替えメソッドはありません。
delAllAccount(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 AccountManager.deleteAccounts()に置き換えられました。
delAllLink(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
delAllMenu(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 MenuManager.deleteMenuItems()に置き換えられました。
delAllMessage(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
delAllRole(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 RoleManager.deleteRoles()に置き換えられました。
delAllSchedule(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 BatchManager.deleteBatches()に置き換えられました。
delData(String) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。
delData(String, boolean) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。
delData(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
delData(String, boolean) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
delete() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
一時ファイルを削除します。
delete(String) - interface jp.co.intra_mart.foundation.datastore.application.domain.item.ItemCatalogueMediaManager のメソッド
商品カタログの媒体情報を削除します。
delete(CateogryClassBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
分類区分の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
分類区分の基本モデルを複数削除します。
delete(CategoryDetailBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
分類区分詳細の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
分類区分詳細の基本モデルを複数削除します。
delete(DepartmentAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
組織所属の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
組織所属の基本モデルを複数削除します。
delete(CompanyCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
会社組織分類の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
会社組織分類の基本モデルを複数削除します。
delete(CompanyBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
会社の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
会社の基本モデルを複数削除します。
delete(DepartmentBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
組織の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
組織の基本モデルを複数削除します。
delete(DepartmentInclusionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
組織内包の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
組織内包の基本モデルを複数削除します。
delete(DepartmentMainBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
主所属の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
主所属の基本モデルを複数削除します。
delete(CompanyPostBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
役職の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
役職の基本モデルを複数削除します。
delete(CompanyVersionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
会社構成バージョンの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
会社構成バージョンの基本モデルを複数削除します。
delete(DealBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper のメソッド
取扱の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper のメソッド
取扱の基本モデルを複数削除します。
delete(DealerDepartmentBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper のメソッド
組織毎取扱パーミッションの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper のメソッド
組織毎取扱パーミッションの基本モデルを複数削除します。
delete(DealDetailBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper のメソッド
取扱詳細の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper のメソッド
取扱詳細の基本モデルを複数削除します。
delete(DealerPublicGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper のメソッド
パブリックグループ毎取扱パーミッションの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper のメソッド
パブリックグループ毎取扱パーミッションの基本モデルを複数削除します。
delete(DealerRoleBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper のメソッド
ロール毎取扱パーミッションの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper のメソッド
ロール毎取扱パーミッションの基本モデルを複数削除します。
delete(ItemAttributeBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper のメソッド
商品属性の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper のメソッド
商品属性の基本モデルを複数削除します。
delete(ItemCatalogueBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper のメソッド
商品カタログの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper のメソッド
商品カタログの基本モデルを複数削除します。
delete(ItemBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper のメソッド
商品の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper のメソッド
商品の基本モデルを複数削除します。
delete(ItemAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper のメソッド
商品分類の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper のメソッド
商品分類の基本モデルを複数削除します。
delete(ItemCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper のメソッド
商品カテゴリの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper のメソッド
商品カテゴリの基本モデルを複数削除します。
delete(ItemCategoryTypeBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper のメソッド
商品カテゴリ種別の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper のメソッド
商品カテゴリ種別の基本モデルを複数削除します。
delete(ItemTemplateDetailBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper のメソッド
商品属性テンプレート明細の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper のメソッド
商品属性テンプレート明細の基本モデルを複数削除します。
delete(ItemTemplateBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper のメソッド
商品属性テンプレートの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper のメソッド
商品属性テンプレートの基本モデルを複数削除します。
delete(PrivateGroupAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライベートグループ所属の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライベートグループ所属の基本モデルを複数削除します。
delete(PrivateGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライベートグループの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライベートグループの基本モデルを複数削除します。
delete(PublicGroupAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
パブリックグループ所属の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
パブリックグループ所属の基本モデルを複数削除します。
delete(PublicGroupCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
パブリックグループ分類の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
パブリックグループ分類の基本モデルを複数削除します。
delete(PublicGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
パブリックグループの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
パブリックグループの基本モデルを複数削除します。
delete(PublicGroupInclusionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
パブリックグループ内包の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
パブリックグループ内包の基本モデルを複数削除します。
delete(PublicGroupSetBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
パブリックグループセットの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
パブリックグループセットの基本モデルを複数削除します。
delete(PublicGroupVersionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
パブリックグループ構成バージョンの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
パブリックグループ構成バージョンの基本モデルを複数削除します。
delete(UnitBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper のメソッド
単位の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper のメソッド
単位の基本モデルを複数削除します。
delete(UserBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
ユーザの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
ユーザの基本モデルを複数削除します。
delete(BaseModel) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
基本モデルを1つだけ削除します。
delete(Collection) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
アクセサを複数削除します。
delete(String, String) - class jp.co.intra_mart.foundation.update.StandardUpdateAccessor のメソッド
キーを削除します。
delete(String, String) - interface jp.co.intra_mart.foundation.update.UpdateAccessor のメソッド
キーを削除します。
delete(AccessControllerDepartmentBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper のメソッド
アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper のメソッド
アクセスコントローラの利用権限を保有する組織の基本モデルを複数削除します。
delete(AccessControllerBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper のメソッド
アクセスコントローラ情報の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper のメソッド
アクセスコントローラ情報の基本モデルを複数削除します。
delete(AccessControllerPostBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper のメソッド
アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper のメソッド
アクセスコントローラの利用権限を保有する役職の基本モデルを複数削除します。
delete(AccessControllerPublicGroupBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper のメソッド
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper のメソッド
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを複数削除します。
delete(AccessControllerRoleBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper のメソッド
アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper のメソッド
アクセスコントローラの利用権限を保有するロールの基本モデルを複数削除します。
delete(AccountAttributeBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper のメソッド
アカウントが保有する属性の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper のメソッド
アカウントが保有する属性の基本モデルを複数削除します。
delete(AccountBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccountMapper のメソッド
アカウントの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccountMapper のメソッド
アカウントの基本モデルを複数削除します。
delete(AccountRoleBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper のメソッド
アカウントが保有するロールの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper のメソッド
アカウントが保有するロールの基本モデルを複数削除します。
delete(BatchBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.BatchMapper のメソッド
バッチ情報の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.BatchMapper のメソッド
バッチ情報の基本モデルを複数削除します。
delete(CalendarInfoBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper のメソッド
カレンダーが保有するデータの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper のメソッド
カレンダーが保有するデータの基本モデルを複数削除します。
delete(FavoriteMenuBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper のメソッド
アカウントが保有するメニューの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper のメソッド
アカウントが保有するメニューの基本モデルを複数削除します。
delete(MenuArgumentBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper のメソッド
メニューの保有する引数の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper のメソッド
メニューの保有する引数の基本モデルを複数削除します。
delete(MenuDepartmentBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper のメソッド
メニューの利用権限を保有する組織の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper のメソッド
メニューの利用権限を保有する組織の基本モデルを複数削除します。
delete(MenuBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuMapper のメソッド
メニュー情報の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuMapper のメソッド
メニュー情報の基本モデルを複数削除します。
delete(MenuPostBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper のメソッド
メニューの利用権限を保有する役職の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper のメソッド
メニューの利用権限を保有する役職の基本モデルを複数削除します。
delete(MenuPublicGroupBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper のメソッド
メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper のメソッド
メニューの利用権限を保有するパブリックグループの基本モデルを複数削除します。
delete(MenuRoleBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper のメソッド
メニューの利用権限を保有するロールの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper のメソッド
メニューの利用権限を保有するロールの基本モデルを複数削除します。
delete(RoleInclusionBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper のメソッド
ロール内包の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper のメソッド
ロール内包の基本モデルを複数削除します。
delete(RoleBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.RoleMapper のメソッド
ロールの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.RoleMapper のメソッド
ロールの基本モデルを複数削除します。
delete(RoleSummaryBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper のメソッド
ロールサマリの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper のメソッド
ロールサマリの基本モデルを複数削除します。
deleteAccount(String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウント情報を削除する。
deleteAccount(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント情報を削除する。
deleteAccount(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントを削除します。
deleteAccountLicense(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
指定されたユーザのライセンスを削除します。
deleteAccountRole(String, String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウントロール情報を削除する。
deleteAccountRole(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントロール情報を削除する。
deleteAccountRole(String, String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントロールを削除します。
deleteAccountRoles(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントロールをすべて削除します。
deleteAccounts() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントをすべて削除します。
deleteAll() - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のメソッド
このディレクトリパスを削除します。
deleteAll(String) - class jp.co.intra_mart.foundation.update.StandardUpdateAccessor のメソッド
すべてのキーを削除します。
deleteAll(String) - interface jp.co.intra_mart.foundation.update.UpdateAccessor のメソッド
すべてのキーを削除します。
deleteApplicationLicenseFromAccount(String, String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
アプリケーションライセンスをアカウントから削除します。
deleteAttribute(String, String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウント属性情報を削除する。
deleteAttribute(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント属性情報を削除する。
deleteAttribute(String, String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウント属性情報を削除する。
deleteBatch(String, String) - class jp.co.intra_mart.foundation.security.StandardBatchAccessor のメソッド
バッチを削除します。
deleteBatch(String, String) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
バッチ情報を削除します。
deleteBatch(String) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチ情報を削除します。
deleteBatches() - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
すべてのバッチ情報を削除します。
deleteCalendar(String, String) - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor のメソッド
カレンダーを削除します。
deleteCalendar(String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
カレンダーを削除します。
deleteCalendar(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーを削除します。
deleteCalendarInfo(String, String, String) - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor のメソッド
指定されたカレンダーデータを削除します。
deleteCalendarInfo(String, String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
指定されたカレンダーデータを削除します。
deleteCalendarInfo(String, String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータを削除します。
deleteCalendarInfos(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
すべてのカレンダーデータを削除します。
deleteCalendars() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
すべてのカレンダーを削除します。
deleteCatalogue(ItemCatalogue) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
商品カタログ情報を削除します。
deleteCategories() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
すべてのカテゴリーを削除します。
deleteCategory(ItemCategory) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のメソッド
商品カテゴリを削除します。
deleteCategory(String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
すべてのカテゴリを削除します。
deleteCategory(String, String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
カテゴリを削除します。
deleteCategory(String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
すべてのカテゴリを削除する。
deleteCategory(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
カテゴリを削除する。
deleteCategory(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
カテゴリーを削除します。
deleteCategoryDetail(CategoryDetail) - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のメソッド
登録済の分類区分詳細を削除します。
deleteChild(String) - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
子メニューを削除します。
deleteChilds() - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のメソッド
このディレクトリが持つファイルまたはサブディレクトリをすべて削除します。
deleteCompany(Company) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の会社を削除します。
deleteController(String, String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラを削除します。
deleteController(String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラを削除します。
deleteController(String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
アクセスコントローラを削除します。
deleteControllerDepartment(String, String, DepartmentInfo) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラ組織を削除します。
deleteControllerDepartment(String, String, DepartmentInfo) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラ組織を削除します。
deleteControllerDepartment(String, DepartmentInfo) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
組織の紐付けをアクセスコントローラから削除します。
deleteControllerDepartments(String, String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
すべてのアクセスコントローラ組織を削除します。
deleteControllerDepartments(String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
すべてのアクセスコントローラ組織を削除します。
deleteControllerDepartments(String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
組織の紐付けをアクセスコントローラからすべて削除します。
deleteControllerPost(String, String, PostInfo) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラ役職を削除します。
deleteControllerPost(String, String, PostInfo) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラ役職を削除します。
deleteControllerPost(String, PostInfo) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
役織の紐付けをアクセスコントローラから削除します。
deleteControllerPosts(String, String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
すべてのアクセスコントローラ役職を削除します。
deleteControllerPosts(String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
すべてのアクセスコントローラ役職を削除します。
deleteControllerPosts(String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
役織の紐付けをアクセスコントローラからすべて削除します。
deleteControllerPublicGroup(String, String, PublicGroupInfo) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラパブリックグループを削除します。
deleteControllerPublicGroup(String, String, PublicGroupInfo) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラパブリックグループを削除します。
deleteControllerPublicGroup(String, PublicGroupInfo) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
パブリックグループの紐付けをアクセスコントローラから削除します。
deleteControllerPublicGroups(String, String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
すべてのアクセスコントローラパブリックグループを削除します。
deleteControllerPublicGroups(String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
すべてのアクセスコントローラパブリックグループを削除します。
deleteControllerPublicGroups(String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
パブリックグループの紐付けをアクセスコントローラからすべて削除します。
deleteControllerRole(String, String, String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラロールを削除します。
deleteControllerRole(String, String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラロールを削除します。
deleteControllerRole(String, String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
ロールの紐付けをアクセスコントローラから削除します。
deleteControllerRoles(String, String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
すべてのアクセスコントローラロールを削除します。
deleteControllerRoles(String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
すべてのアクセスコントローラロールを削除します。
deleteControllerRoles(String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
ロールの紐付けをアクセスコントローラから削除します。
deleteControllers() - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
すべてのアクセスコントローラを削除します。
deleteDeal(Deal) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
取扱情報を削除します。
deleteDepartment(Department) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の組織情報を削除します。
deleteEventFlow(EventNavigatorManager, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
イベントフローの削除 イベントフローIDから、イベントフローを削除する。
deleteEventFlow(String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
イベントフローの削除 イベントフローIDから、イベントフローを削除する。
deleteEventFlow(EventNavigatorManager, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
イベントフローの削除 イベントフローIDから、イベントフローを削除する。
deleteFavoriteMenu(String, String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
マイメニュー情報を削除する。
deleteFavoriteMenu(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
マイメニュー情報を削除する。
deleteFavoriteMenu(String, String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
マイメニューを削除します。
deleteFavoriteMenus(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
マイメニューをすべて削除します。
deleteGroupImageIcons() - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
グループのイメージアイコン情報をすべて削除します。
deleteGroupSet(PublicGroupSet) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループセットを削除します。
deleteImageIcon(String) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
イメージアイコン情報を削除します。
deleteItem(Item) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
商品情報を削除します。
deleteLoginGroup(String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
ログイングループを削除します。
deleteLoginGroup(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループを削除します。
deleteMainPagePattern(String, String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
メインページパターンを削除します。
deleteMainPagePattern(String, String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンを削除します。
deleteMainPagePatterns(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンをすべて削除します。
deleteMember(DepartmentAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織から人員をはずします。
deleteMember(PrivateGroupAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
プライベートグループから人員をはずします。
deleteMember(PublicGroupAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループから人員をはずします。
deleteMenuDepartment(String, String, DepartmentInfo) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
メニュー組織を削除します。
deleteMenuDepartment(String, String, DepartmentInfo) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニュー組織を削除します。
deleteMenuDepartment(String, DepartmentInfo) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
組織の紐付けをメニューから削除します。
deleteMenuDepartments(String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
すべてのメニュー組織を削除します。
deleteMenuDepartments(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニュー組織を削除します。
deleteMenuDepartments(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
組織の紐付けをメニューからすべて削除します。
deleteMenuInclusion(String, MenuInclusion) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
メニュー構成を削除します。
deleteMenuInclusion(MenuInclusion) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
メニュー構成を削除します。
deleteMenuInclusion(String, MenuInclusion) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニュー構成を削除します。
deleteMenuItem(String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
引数で渡されたノードを削除します。
deleteMenuItem(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
引数で渡されたノードを削除します。
deleteMenuItem(String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニューを削除します。
deleteMenuItem(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
引数で渡されたノードを削除します。
deleteMenuItem(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューを削除します。
deleteMenuItems() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
すべてのメニューを削除します。
deleteMenuItems() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
すべてのメニューを削除します。
deleteMenuLoginGroup(String, String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
管理メニューに設定されているアクセス権を削除します。
deleteMenuLoginGroup(String, String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
指定したログイングループのアクセス権をメニューから削除します。
deleteMenuPost(String, String, PostInfo) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
メニュー役職を削除します。
deleteMenuPost(String, String, PostInfo) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニュー役職を削除します。
deleteMenuPost(String, PostInfo) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
役織の紐付けをメニューから削除します。
deleteMenuPosts(String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
すべてのメニュー役職を削除します。
deleteMenuPosts(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニュー役職を削除します。
deleteMenuPosts(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
役織の紐付けをメニューからすべて削除します。
deleteMenuPublicGroup(String, String, PublicGroupInfo) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
メニューパブリックグループを削除します。
deleteMenuPublicGroup(String, String, PublicGroupInfo) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニューパブリックグループを削除します。
deleteMenuPublicGroup(String, PublicGroupInfo) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
パブリックグループの紐付けをメニューから削除します。
deleteMenuPublicGroups(String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
すべてのメニューパブリックグループを削除します。
deleteMenuPublicGroups(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニューパブリックグループを削除します。
deleteMenuPublicGroups(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
パブリックグループの紐付けをメニューからすべて削除します。
deleteMenuRole(String, String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
メニューロールを削除します。
deleteMenuRole(String, String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニューロールを削除します。
deleteMenuRole(String, String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
ロールの紐付けをメニューから削除します。
deleteMenuRoles(String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
すべてのメニューロールを削除します。
deleteMenuRoles(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニューロールを削除します。
deleteMenuRoles(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
ロールの紐付けをメニューから削除します。
deletePortlet(Portlet) - class jp.co.intra_mart.foundation.portal.portlet.PortletManager のメソッド
ポートレット情報を削除します。
deletePost(CompanyPost) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の役職情報を削除します。
deletePrivateGroup(PrivateGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
登録済のプライベートグループ情報を削除します。
deletePublicGroup(PublicGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループ情報を削除します。
deleteRole(String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
すべてのロール情報を削除します。
deleteRole(String, String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
ロール情報を削除します。
deleteRole(String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
すべてのロール情報を削除する。
deleteRole(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
ロール情報を削除する。
deleteRole(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロールを削除します。
deleteRoles() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
すべてのロールを削除します。
deleteSaveResultHistory(EventNavigatorManager, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。
deleteSaveResultHistory(String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。
deleteSaveResultHistory(EventNavigatorManager, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。
deleteShortCut(String, String) - interface jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor のメソッド
ショートカットIDを削除します。
deleteShortCut(String) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutManager のメソッド
ショートカットＩＤ削除。
deleteShortCut(String, String) - class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor のメソッド
ショートカットIDを削除します。
deleteSubRole(String, String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
サブロールIDを削除します。
deleteSubRole(String, String, String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
指定したサブロールIDを削除します。
deleteSubRole(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
サブロールIDサマリを削除する。
deleteSubRole(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
指定したロールのサブロールIDサマリを全削除する。
deleteSubRole(String, String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
指定したサブロールIDを削除します。
deleteSubRoles(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
全てのサブロールIDを削除します。
deleteSuperUser(String) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor のメソッド
グループ管理者情報を削除します。
deleteSuperUser(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
グループ管理者情報を削除します。
deleteTemplate(ItemTemplate) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager のメソッド
商品属性テンプレート情報を削除します。
deleteTemplateDetail(ItemTemplateDetail) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager のメソッド
商品属性テンプレート明細情報を削除します。
deleteUnit(String) - class jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager のメソッド
単位を削除します。
deleteUser(User) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager のメソッド
登録済のユーザを削除します。
deleteUserImageIcons(String) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
ユーザのイメージアイコン情報をすべて削除します。
deleteVersion(CompanyVersion) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の会社構成バージョンを削除します。
deleteVersion(PublicGroupVersion) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループセット構成バージョンを削除します。
departmentAdded(String, Department) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織情報がデータストアに登録された後に呼び出されます。
departmentAdded(String, Department) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
組織情報がデータストアに登録された後に呼び出されます。
departmentAdded(String, Department) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織情報がデータストアに登録された後に呼び出されます。
departmentDeleted(String, Department) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織情報がデータストアに更新された後に呼び出されます。
departmentDeleted(String, Department) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
組織情報がデータストアに更新された後に呼び出されます。
departmentDeleted(String, Department) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織情報がデータストアに更新された後に呼び出されます。
departmentJoined(String, String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織構成がデータストアに登録された後に呼び出されます。
departmentJoined(String, String, String, String, String) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
組織構成がデータストアに登録された後に呼び出されます。
departmentJoined(String, String, String, String, String) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織構成がデータストアに登録された後に呼び出されます。
departmentLeft(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
departmentLeft(String, String, String, String) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
departmentLeft(String, String, String, String) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
departmentMoved(String, String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
departmentMoved(String, String, String, String, String) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
departmentMoved(String, String, String, String, String) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
departmentUpdated(String, Department) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織情報がデータストアから削除された後に呼び出されます。
departmentUpdated(String, Department) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
組織情報がデータストアから削除された後に呼び出されます。
departmentUpdated(String, Department) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織情報がデータストアから削除された後に呼び出されます。
destory(String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
アクティブなセッション情報をすべて破棄します。
destory(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
アクティブなセッション情報をすべて破棄します。
destory(String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
アクティブなセッション情報をすべて破棄します。
destroy() - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor のメソッド
このプールを破棄します。
destroy() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
このプールを破棄します。
destroy() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
フィルタの終了処理。
destroy() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder のメソッド
このオブジェクトの破棄処理をします。
destroy() - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter のメソッド
MKControllerConverterを破棄します。
destroy() - class jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter のメソッド
NodePathControllerConverterを破棄します。
destroy() - class jp.co.intra_mart.foundation.security.filter.SessionFilter のメソッド
破棄します。
destroy() - class jp.co.intra_mart.foundation.security.filter.URLAccessFilter のメソッド
破棄します。
destroy() - class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet のメソッド
サーブレットの放棄を行います。
destroy() - class jp.co.intra_mart.foundation.security.servlet.LogoutServlet のメソッド
サーブレットの放棄を行います。
destroy() - class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet のメソッド
サーブレットの放棄を行います。
destroy() - class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet のメソッド
サーブレットの放棄を行います。
destroy() - class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet のメソッド
サーブレットの放棄を行います。
destroy(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
グループデータを削除します。
destroy(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
グループデータを削除します。
destroy(String) - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
id によりアクセスできるセッションデータを破棄します。
destroy() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
このメソッドは、現在のセッションを破棄してしまいます。
destroy(String) - interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory のメソッド
グループデータを削除します。
destroy() - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 このイベントコントローラの破棄処理を行います。
destroy() - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor のメソッド
推奨されていません。 このプールを破棄します。
destroy() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 このプールを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.EncodingFilter のメソッド
フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.FileUploadFilter のメソッド
フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter のメソッド
推奨されていません。 フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter のメソッド
推奨されていません。 フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter のメソッド
フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.LocaleFilter のメソッド
フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter のメソッド
フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.ServiceServlet のメソッド
サーブレットを解放します。
destroy() - interface jp.co.intra_mart.framework.base.service.controller.ControllerConverter のメソッド
ControllerConverterを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter のメソッド
SimpleControllerConverterを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.validator.FormatValidator のメソッド
FormatValidatorを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.validator.LengthValidator のメソッド
LengthValidatorを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator のメソッド
NumericRangeValidatorを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.validator.NumericValidator のメソッド
NumericValidatorを破棄します。
destroy() - interface jp.co.intra_mart.framework.base.service.validator.Validator のメソッド
Validatorを破棄します。
destroy() - class jp.co.intra_mart.framework.base.session.SessionFilter のメソッド
フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter のメソッド
フィルタを破棄します。
directories() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ディレクトリ中のサブディレクトリの一覧を取得します。
discontinue() - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 現在実行中のエクスポート処理を中止します。
dispatch(Event) - class jp.co.intra_mart.framework.base.event.EventManager のメソッド
イベントに対する処理を実行します。
dispatch(Event, boolean) - class jp.co.intra_mart.framework.base.event.EventManager のメソッド
イベントに対する処理を実行します。
dispatch(Event, boolean) - interface jp.co.intra_mart.framework.base.event.container.EventContainer のメソッド
イベントに対する処理を実行します。
dispatch(Event, boolean) - class jp.co.intra_mart.framework.base.event.container.EventContainerImpl のメソッド
イベントに対する処理を実行します。
dispatch(Event, boolean) - class jp.co.intra_mart.framework.extension.seasar.event.S2EventContainer のメソッド

dispatchEvent(Event) - class jp.co.intra_mart.framework.base.event.EJBEventListener のメソッド
イベント処理を実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean のメソッド
イベント処理を実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.base.event.StandardEventListener のメソッド
イベント処理を実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
イベント処理を実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
イベント処理を実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils の static メソッド
イベントを実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction のメソッド
イベント処理を実行します。
distinctNavigator(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたユーザエージェント情報から判別してナビゲータ情報を取得します。
doCertification(int, LoginInfo, SuperUser, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.activesession.GroupActiveSessionRegister のメソッド
管理者の認証後にコールされるメソッドです。
doCertification(int, LoginInfo, Account, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.activesession.UserActiveSessionRegister のメソッド
ユーザの認証後にコールされるメソッドです。
doCertification(int, LoginInfo, SuperUser, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.SuperCertificationListener のメソッド
管理者の認証後にコールされるメソッドです。
doCertification(int, LoginInfo, Account, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.UserCertificationListener のメソッド
ユーザの認証後にコールされるメソッドです。
doChain() - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain のメソッド
チェーン内の次のフィルタまたはイベントを デフォルトのリクエストとレスポンスを利用して呼び出します。
doChain(HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain のメソッド
チェーン内の次のフィルタまたはイベントを 指定のリクエストとレスポンスを利用して呼び出します。
doDecoration(EventNavigatorManager, Object) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorReaderDecorator のメソッド
イベントナビゲータのオブジェクト情報をデータストアからの読み込み直後にコールされます。
doDecoration(String, AccessController) - interface jp.co.intra_mart.foundation.security.access.AccessControllerReaderDecorator のメソッド
アクセスコントローラデータストアからの読み込み直後にコールされます。
doDecoration(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountReaderDecorator のメソッド
アカウントをデータストアからの読み込み直後にコールされます。
doDecoration(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator のメソッド
システム管理者情報をデータストアからの読み込み直後にコールされます。
doDecoration(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator のメソッド
バッチをデータストアからの読み込み直後にコールされます。
doDecoration(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator のメソッド
カレンダーデータをデータストアからの読み込み直後にコールされます。
doDecoration(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator のメソッド
アカウントをデータストアからの読み込み直後にコールされます。
doDecoration(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator のメソッド
ログイングループをデータストアからの読み込み直後にコールされます。
doDecoration(MenuItem) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator のメソッド
メニューデータストアからの読み込み直後にコールされます。
doDecoration(String, MenuItem) - interface jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator のメソッド
メニューデータストアからの読み込み直後にコールされます。
doDecoration(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleReaderDecorator のメソッド
ロール情報をデータストアから読み込んだ直後にコールされます。
doEndTag() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
終了タグを検知したときにJSPエンジンから呼ばれます。
doEndTag() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
終了タグを検知したときにJSPエンジンから呼ばれます。
doEndTag() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
終了タグを検知したときにJSPエンジンから呼ばれます。
doEndTag() - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
終了タグを検知したときにJSPエンジンから呼ばれます。
doEndTag() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
終了タグを検知したときにJSPエンジンから呼ばれます。
doExport(EventNavigatorManager, OutputStream, boolean) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorExporter のメソッド
エクスポートを行います。
doExport(EventNavigatorManager, OutputStream, boolean) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter のメソッド
エクスポートを行います。
doExport(AccessControllerManager, OutputStream) - interface jp.co.intra_mart.foundation.security.access.AccessControllerExporter のメソッド
エクスポートを行います。
doExport(AccessControllerManager, OutputStream) - class jp.co.intra_mart.foundation.security.access.StandardAccessControllerBackup のメソッド

doExport(AccountManager, OutputStream) - interface jp.co.intra_mart.foundation.security.account.AccountExporter のメソッド
エクスポートを行います。
doExport(AccountManager, OutputStream) - class jp.co.intra_mart.foundation.security.account.CsvAccountBackup のメソッド
エクスポートを行います。
doExport(AccountManager, OutputStream) - class jp.co.intra_mart.foundation.security.account.StandardAccountBackup のメソッド
エクスポートを行います。
doExport(BatchManager, OutputStream) - interface jp.co.intra_mart.foundation.security.batch.BatchExporter のメソッド
エクスポートを行います。
doExport(BatchManager, OutputStream) - class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup のメソッド
エクスポートを行います。
doExport(CalendarManager, OutputStream) - interface jp.co.intra_mart.foundation.security.calendar.CalendarExporter のメソッド
エクスポートを行います。
doExport(CalendarManager, OutputStream) - class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup のメソッド
エクスポートを行います。
doExport(AdminMenuManager, OutputStream) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuExporter のメソッド
エクスポートを行います。
doExport(MenuManager, OutputStream) - interface jp.co.intra_mart.foundation.security.menu.MenuExporter のメソッド
エクスポートを行います。
doExport(AdminMenuManager, OutputStream) - class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup のメソッド
エクスポートを行います。
doExport(MenuManager, OutputStream) - class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup のメソッド
エクスポートを行います。
doExport(RoleManager, OutputStream) - interface jp.co.intra_mart.foundation.security.role.RoleExporter のメソッド
エクスポートを行います。
doExport(RoleManager, OutputStream) - class jp.co.intra_mart.foundation.security.role.StandardRoleBackup のメソッド
エクスポートを行います。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter のメソッド
フィルタ処理します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
フィルタとして動作するロジック。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter のメソッド
フィルタとして動作するロジック。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter のメソッド

doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilter のメソッド
フィルタとして動作するロジック。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter のメソッド

doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter のメソッド
フィルタとして動作するロジック。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter のメソッド
フィルタとして動作するロジック。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter のメソッド
レスポンスソースの Content-Type を 自動解決する HttpServletResponse を作成して、 次のフィルタチェーンを実行します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter のメソッド
フィルタとして動作するロジック。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.foundation.security.filter.ActiveSessionFilter のメソッド
フィルタを実行します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.foundation.security.filter.DuplicateLoginHandlingFilter のメソッド
フィルタを実行します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter のメソッド
フィルタを実行します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter のメソッド
リクエストの文字エンコードをアクセスセキュリティ情報を基にエンコーディングを設定して、 次のフィルタチェーンを実行します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter のメソッド
レスポンスソースの文字エンコードをアクセスセキュリティ情報を基にして 自動解決する HttpServletResponse を作成して、 次のフィルタチェーンを実行します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.foundation.security.filter.SessionFilter のメソッド
フィルタを実行します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.foundation.security.filter.URLAccessFilter のメソッド
フィルタを実行します。
doFilter(HTTPActionEventContext, HttpServletRequest, HttpServletResponse, FilterHTTPActionEventChain) - class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent のメソッド
イベントのフィルタ処理です。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.EncodingFilter のメソッド
リクエストのエンコードを設定します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.FileUploadFilter のメソッド
リクエストの内容がファイルアップロードを含むかどうかによってリクエストを選択します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter のメソッド
推奨されていません。 リクエストのパラメーターを設定後、次の処理に遷移します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter のメソッド
推奨されていません。 intra-martから来るリクエストをim-J2EE Frameworkで扱う形式に変換します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter のメソッド
リクエストのロケールを設定します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.LocaleFilter のメソッド
リクエストのロケールを設定します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter のメソッド
sessionに登録された情報と、parameterの情報を比較します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.session.SessionFilter のメソッド
リクエストのセッション管理をします。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter のメソッド
ロケールをセッションに登録し、次のフィルタに処理を移します。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet のメソッド
GETメソッドに対するサービスを行います。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.LogoutServlet のメソッド
GETメソッドに対するサービスを行います。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.MenuServlet のメソッド
GETメソッドです。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet のメソッド
GETメソッドに対するサービスを行います。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet のメソッド
GETメソッドに対するサービスを行います。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet のメソッド
GETメソッドに対するサービスを行います。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 GETメソッドに対応します。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceServlet のメソッド
GETメソッドに対するサービスを行います。
doImport(InputStream, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.item.ItemImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.StandardItemImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemAttachImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemAttachImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemCategoryImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.StandardItemTemplateImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter のメソッド
インポートを行います。
doImport(EventNavigatorManager, InputStream) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorImporter のメソッド
インポートを行います。
doImport(EventNavigatorManager, InputStream) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter のメソッド
インポートを行います。
doImport(String) - interface jp.co.intra_mart.foundation.security.ExtendsImport のメソッド
拡張インポート処理を行います。
doImport(String, String) - class jp.co.intra_mart.foundation.security.ExtendsImportManager のメソッド
拡張インポート処理を実行します。
doImport(InputStream, AccessControllerManager) - interface jp.co.intra_mart.foundation.security.access.AccessControllerImporter のメソッド
インポートを行います。
doImport(InputStream, AccessControllerManager) - class jp.co.intra_mart.foundation.security.access.StandardAccessControllerBackup のメソッド

doImport(InputStream, AccountManager) - interface jp.co.intra_mart.foundation.security.account.AccountImporter のメソッド
インポートを行います。
doImport(InputStream, AccountManager) - class jp.co.intra_mart.foundation.security.account.CsvAccountBackup のメソッド
インポートを行います。
doImport(InputStream, AccountManager) - class jp.co.intra_mart.foundation.security.account.StandardAccountBackup のメソッド
インポートを行います。
doImport(InputStream, BatchManager) - interface jp.co.intra_mart.foundation.security.batch.BatchImporter のメソッド
インポートを行います。
doImport(InputStream, BatchManager) - class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup のメソッド
インポートを行います。
doImport(InputStream, CalendarManager) - interface jp.co.intra_mart.foundation.security.calendar.CalendarImporter のメソッド
インポートを行います。
doImport(InputStream, CalendarManager) - class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup のメソッド
インポートを行います。
doImport(InputStream, AdminMenuManager) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuImporter のメソッド
インポートを行います。
doImport(InputStream, MenuManager) - interface jp.co.intra_mart.foundation.security.menu.MenuImporter のメソッド
インポートを行います。
doImport(InputStream, AdminMenuManager) - class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup のメソッド
インポートを行います。
doImport(InputStream, MenuManager) - class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup のメソッド
インポートを行います。
doImport(InputStream, RoleManager) - interface jp.co.intra_mart.foundation.security.role.RoleImporter のメソッド
インポートを行います。
doImport(InputStream, RoleManager) - class jp.co.intra_mart.foundation.security.role.StandardRoleBackup のメソッド
インポートを行います。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet のメソッド
POSTメソッドに対するサービスを行います。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.LogoutServlet のメソッド
POSTメソッドに対するサービスを行います。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.MenuServlet のメソッド
POSTメソッドです。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet のメソッド
POSTメソッドに対するサービスを行います。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet のメソッド
POSTメソッドに対するサービスを行います。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet のメソッド
POSTメソッドに対するサービスを行います。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 POSTメソッドに対応します。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceServlet のメソッド
POSTメソッドに対するサービスを行います。
doSelection(String, String[]) - class jp.co.intra_mart.foundation.navigator.EventNavigatorPermissionSelector のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doSelection(String, String[]) - class jp.co.intra_mart.foundation.security.permission.AccessControllerPermissionSelector のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doSelection(String, String[]) - class jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doSelection(String, String[]) - class jp.co.intra_mart.foundation.security.permission.AdminMenuPermissionSelector のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doSelection(String, String[]) - class jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doSelection(String, String[]) - class jp.co.intra_mart.foundation.security.permission.PermissionManager のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doSelection(String, String) - class jp.co.intra_mart.foundation.security.permission.PermissionManager のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doSelection(String, String[]) - interface jp.co.intra_mart.foundation.security.permission.PermissionSelector のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.MessageParamTag のメソッド
外側の一番近いMessageTagにパラメータを設定します。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.ParamTag のメソッド
外側の一番近いParameterSendableにパラメータを設定します。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doubleValue(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 浮動小数点数(double)表現された数値として取得します。
doubleValue(String, double) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 浮動小数点数(double)表現された数値として取得します。
doubleValue() - class jp.co.intra_mart.common.aid.jdk.util.Counter のメソッド
カウンターの現在の値を double 型として返します。
doubleValue() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値の数値表現を取得します。
doubleValue() - class jp.co.intra_mart.foundation.utility.Counter のメソッド
推奨されていません。 カウンターの現在の値を double 型として返します。
downloadCSV(String, String, int, int, String, boolean, boolean) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 CSVファイルをダウンロードします。
downloadCSV(PreparedStatement, String, boolean) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 CSVファイルをダウンロードします。
downloadCSV(PreparedStatement, String, int, int, boolean) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 CSVファイルをダウンロードします。

E

EJBEventListener - class jp.co.intra_mart.framework.base.event.EJBEventListener.
EJBを利用する場合のイベントリスナです。
EJBEventListener() - class jp.co.intra_mart.framework.base.event.EJBEventListener のコンストラクタ
EJBEventListenerを新規に生成します。
EJBEventListenerAgentBean - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean.
Session Beanを利用したイベントリスナの抽象クラスです。
EJBEventListenerAgentBean() - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean のコンストラクタ
EJBEventListenerAgentBeanを新規に生成します。
EJBEventListenerFactory - class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory.
EJBEventListenerFactoryを生成します。
EJBEventListenerFactory() - class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory のコンストラクタ
EJBEventListenerFactoryを新規に生成します。
EMAIL_ADDRESS1 - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
メールアドレス1
EMAIL_ADDRESS1 - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
メールアドレス１
EMAIL_ADDRESS2 - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
メールアドレス2
EMAIL_ADDRESS2 - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
メールアドレス２
ENCODING - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
エンコーディング
END_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
終了日
END_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
終了日
ENTITY_CONTROLLER_DEPARTMENT_NAME - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor の static 変数

ENTITY_CONTROLLER_NAME - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor の static 変数
エンティティ名
ENTITY_CONTROLLER_POST_NAME - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor の static 変数

ENTITY_CONTROLLER_PUBLIC_GROUP_NAME - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor の static 変数

ENTITY_CONTROLLER_ROLE_NAME - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor の static 変数

ENTITY_NAME - class jp.co.intra_mart.foundation.security.StandardBatchAccessor の static 変数
エンティティ名
ENTITY_NAME - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor の static 変数
エンティティ名
ENTITY_NAME_ACCOUNT - class jp.co.intra_mart.foundation.security.StandardAccountAccessor の static 変数
エンティティ名
ENTITY_NAME_ACCOUNT_ATTRIBUTE - class jp.co.intra_mart.foundation.security.StandardAccountAccessor の static 変数

ENTITY_NAME_ACCOUNT_ROLE - class jp.co.intra_mart.foundation.security.StandardAccountAccessor の static 変数

ENTITY_NAME_FAVORITE_MENU - class jp.co.intra_mart.foundation.security.StandardAccountAccessor の static 変数

ENTITY_NAME_MENU - class jp.co.intra_mart.foundation.security.StandardMenuAccessor の static 変数
メニュー エンティティ名
ENTITY_NAME_MENU_ARGUMENT - class jp.co.intra_mart.foundation.security.StandardMenuAccessor の static 変数
メニュー引数 エンティティ名
ENTITY_NAME_MENU_DEPARTMENT - class jp.co.intra_mart.foundation.security.StandardMenuAccessor の static 変数
メニュー組織 エンティティ名
ENTITY_NAME_MENU_POST - class jp.co.intra_mart.foundation.security.StandardMenuAccessor の static 変数
メニュー役職 エンティティ名
ENTITY_NAME_MENU_PUBLIC_GROUP - class jp.co.intra_mart.foundation.security.StandardMenuAccessor の static 変数
メニューパブリックグループ エンティティ名
ENTITY_NAME_MENU_ROLE - class jp.co.intra_mart.foundation.security.StandardMenuAccessor の static 変数
メニューロール エンティティ名
ENTITY_NAME_ROLE - class jp.co.intra_mart.foundation.security.StandardRoleAccessor の static 変数

ENTITY_NAME_ROLE_INCLUSION - class jp.co.intra_mart.foundation.security.StandardRoleAccessor の static 変数

ENTITY_NAME_ROLE_SUMMARY - class jp.co.intra_mart.foundation.security.StandardRoleAccessor の static 変数

ERRORS_NODE - class jp.co.intra_mart.extension.maskat.util.MKErrors の static 変数
errors要素のノード名
ERROR_CODE_NODE - class jp.co.intra_mart.extension.maskat.util.MKError の static 変数
errorCodeのノード名
ERROR_NODE - class jp.co.intra_mart.extension.maskat.util.MKError の static 変数
error要素のノード名
ESCAPE_LEFT_PARENTHESIS - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ESCAPE_PERCENTAGE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ESCAPE_RIGHT_PARENTHESIS - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ESCAPE_STRING - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
エスケープ文字
ESCAPE_UNDER_SCORE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

EVENT_LISTENER_SUFFIX - class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator の static 変数

EVENT_NAVIGATOR_PERMISSION_SELECTOR - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
アクセス権限チェッククラス取得用キー
EVENT_OBJECT_SUFFIX - class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator の static 変数

EVENT_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.base.event.EventManager の static 変数
イベントプロパティハンドラのキー
EVENT_PROPERTY_HANDLER_KEY - interface jp.co.intra_mart.framework.base.event.container.EventContainer の static 変数
イベントプロパティハンドラのキー
EXCEPTION - class jp.co.intra_mart.foundation.datastore.common.config.DeleteType の static 変数
例外 例外を発生させます。
EXCEPTION - class jp.co.intra_mart.foundation.datastore.common.config.LifetimeType の static 変数
例外 例外を発生させます。
EXTENSION_FAX_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
内線FAX番号
EXTENSION_FAX_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
内線FAX番号
EXTENSION_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
内線番号
EXTENSION_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
内線番号
ElementProperties - class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties.
DOM をベースとした不変のプロパティセットを表します。
ElementProperties(Element) - class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties のコンストラクタ
指定のエレメントの情報をプロパティズ化します。
ElementProperties(Element, Properties) - class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties のコンストラクタ
指定のエレメントの情報をプロパティズ化します。
EmptyEvent - class jp.co.intra_mart.framework.base.event.EmptyEvent.
情報を何も持たないイベントです。
EmptyEvent() - class jp.co.intra_mart.framework.base.event.EmptyEvent のコンストラクタ

EmptyParameterHttpServletRequestWrapper - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.EmptyParameterHttpServletRequestWrapper.
エンプティーリクエストパラメータサーブレットリクエストラッパー。
EmptyParameterHttpServletRequestWrapper(HttpServletRequest) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.EmptyParameterHttpServletRequestWrapper のコンストラクタ
コンストラクタ。
EmptyQueryException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException.
クエリがない場合にスローされる例外です。
EmptyQueryException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException のコンストラクタ
指定のメッセージを持つ例外を作成します。
EmptyQueryException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
EmptyQueryException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException のコンストラクタ
例外を作成します。
EmptyServiceResult - class jp.co.intra_mart.framework.base.service.EmptyServiceResult.
情報を何も持たないServiceResultの実装です。
EmptyServiceResult() - class jp.co.intra_mart.framework.base.service.EmptyServiceResult のコンストラクタ

EmptyUserInfo - class jp.co.intra_mart.framework.base.util.EmptyUserInfo.
情報を何も持たないUserInfoです。
EmptyUserInfo() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のコンストラクタ

EnCodeInterface - interface jp.co.intra_mart.foundation.portal.common.encode.EnCodeInterface.
簡易SSOのパスワードを暗号化するインタフェース。
EncodingFilter - class jp.co.intra_mart.framework.base.service.EncodingFilter.
リクエストのエンコードを設定します。
EncodingFilter() - class jp.co.intra_mart.framework.base.service.EncodingFilter のコンストラクタ

Entity - interface jp.co.intra_mart.foundation.datastore.common.config.Entity.
エンティティを定義します。
Environment - interface jp.co.intra_mart.foundation.service.provider.Environment.
このクラスは、 システムプロパティへアクセスするためのインターフェースです。
ErrorEvent - class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent.
例外をイベントとして扱うためのプロトコルです。
ErrorEvent(Throwable, Object) - class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent のコンストラクタ
エラーを通知するためのイベントを構築します。
ErrorEvent(Throwable, String, Object) - class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent のコンストラクタ
エラーを通知するためのイベントを構築します。
ErrorEvent - class jp.co.intra_mart.foundation.utility.ErrorEvent.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEvent クラスを使用してください。
ErrorEvent(Throwable, Object) - class jp.co.intra_mart.foundation.utility.ErrorEvent のコンストラクタ
推奨されていません。 エラーを通知するためのイベントを構築します。
ErrorEvent(Throwable, String, Object) - class jp.co.intra_mart.foundation.utility.ErrorEvent のコンストラクタ
推奨されていません。 エラーを通知するためのイベントを構築します。
ErrorEventListener - interface jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener.
例外をイベントとして扱うためのスケルトン実装を提供します。
ErrorEventListener - interface jp.co.intra_mart.foundation.utility.ErrorEventListener.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener クラスを使用してください。
ErrorHelperBean - class jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean.
例外ページで使用するHelperBeanです。
ErrorHelperBean() - class jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean のコンストラクタ
ErrorHelperBeanを新規に生成します。
ErrorPageProvider - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider.
エラーページプロバイダインタフェース。
Errors - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors.
前明細の不正処理に関する情報情報クラス
機能は以下の通り
前明細の不正処理に関する情報情報を保持します。
Errors() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のコンストラクタ
前明細の不正処理に関する情報情報を作成します。
Errors(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のコンストラクタ
前明細の不正処理に関する情報情報を作成します。
Event - class jp.co.intra_mart.framework.base.event.Event.
処理を実行するための情報です。
Event() - class jp.co.intra_mart.framework.base.event.Event のコンストラクタ
イベントを新規に生成します。
EventAccessInfo - class jp.co.intra_mart.foundation.navigator.EventAccessInfo.
アクセス権情報
EventAccessInfo() - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のコンストラクタ

EventContainer - interface jp.co.intra_mart.framework.base.event.container.EventContainer.
イベントコンテナのインターフェースです。
EventContainerException - exception jp.co.intra_mart.framework.base.event.container.EventContainerException.
イベントコンテナ設定時の例外です。
EventContainerException() - class jp.co.intra_mart.framework.base.event.container.EventContainerException のコンストラクタ
詳細メッセージを指定しないで EventContainerException を構築します。
EventContainerException(String) - class jp.co.intra_mart.framework.base.event.container.EventContainerException のコンストラクタ
指定された詳細メッセージを持つ EventContainerException を構築します。
EventContainerException(String, Throwable) - class jp.co.intra_mart.framework.base.event.container.EventContainerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventContainerException を構築します。
EventContainerFactory - class jp.co.intra_mart.framework.base.event.container.factory.EventContainerFactory.
EventContainerのファクトリクラスです。
EventContainerFactory() - class jp.co.intra_mart.framework.base.event.container.factory.EventContainerFactory のコンストラクタ

EventContainerImpl - class jp.co.intra_mart.framework.base.event.container.EventContainerImpl.
EventContainerの標準的な実装クラスです。
EventContainerImpl() - class jp.co.intra_mart.framework.base.event.container.EventContainerImpl のコンストラクタ
EventContainerImplを生成します。
EventException - exception jp.co.intra_mart.framework.base.event.EventException.
イベント生成時の例外です。
EventException() - class jp.co.intra_mart.framework.base.event.EventException のコンストラクタ
詳細メッセージを指定しないで EventException を構築します。
EventException(String) - class jp.co.intra_mart.framework.base.event.EventException のコンストラクタ
指定された詳細メッセージを持つ EventException を構築します。
EventException(String, Throwable) - class jp.co.intra_mart.framework.base.event.EventException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventException を構築します。
EventFactoryModel - class jp.co.intra_mart.framework.base.event.EventFactoryModel.
イベントリスナーファクトリー情報を管理するクラスです。
EventFactoryModel() - class jp.co.intra_mart.framework.base.event.EventFactoryModel のコンストラクタ

EventFlow - class jp.co.intra_mart.foundation.navigator.EventFlow.
イベントフロークラス
EventFlow() - class jp.co.intra_mart.foundation.navigator.EventFlow のコンストラクタ

EventFlowInfo - class jp.co.intra_mart.foundation.navigator.EventFlowInfo.
イベントフロー情報
EventFlowInfo() - class jp.co.intra_mart.foundation.navigator.EventFlowInfo のコンストラクタ

EventGroupModel - class jp.co.intra_mart.framework.base.event.EventGroupModel.
Event情報を管理するクラスです。
EventGroupModel() - class jp.co.intra_mart.framework.base.event.EventGroupModel のコンストラクタ

EventHistoryInfo - class jp.co.intra_mart.foundation.navigator.EventHistoryInfo.
イベント履歴情報
EventHistoryInfo() - class jp.co.intra_mart.foundation.navigator.EventHistoryInfo のコンストラクタ

EventItem - class jp.co.intra_mart.foundation.navigator.EventItem.
イベントアイテムクラス
EventItem() - class jp.co.intra_mart.foundation.navigator.EventItem のコンストラクタ

EventItemInfo - class jp.co.intra_mart.foundation.navigator.EventItemInfo.
イベントアイテム情報
EventItemInfo() - class jp.co.intra_mart.foundation.navigator.EventItemInfo のコンストラクタ

EventListener - interface jp.co.intra_mart.common.aid.jdk.util.EventListener.
このクラスは、イベントリスナーのインターフェースです。
EventListener - interface jp.co.intra_mart.foundation.utility.EventListener.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventListener クラスを使用してください。
EventListener - interface jp.co.intra_mart.framework.base.event.EventListener.
イベントリスナです。
EventListenerException - exception jp.co.intra_mart.framework.base.event.EventListenerException.
イベントリスナ生成時の例外です。
EventListenerException() - class jp.co.intra_mart.framework.base.event.EventListenerException のコンストラクタ
詳細メッセージを指定しないで EventListenerException を構築します。
EventListenerException(String) - class jp.co.intra_mart.framework.base.event.EventListenerException のコンストラクタ
指定された詳細メッセージを持つ EventListenerException を構築します。
EventListenerException(String, Throwable) - class jp.co.intra_mart.framework.base.event.EventListenerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventListenerException を構築します。
EventListenerFactory - interface jp.co.intra_mart.framework.base.event.EventListenerFactory.
イベントリスナを生成します。
EventListenerFactoryParam - class jp.co.intra_mart.framework.base.event.EventListenerFactoryParam.
イベントリスナファクトリの初期パラメータです。
EventListenerFactoryParam() - class jp.co.intra_mart.framework.base.event.EventListenerFactoryParam のコンストラクタ
EventListenerFactoryParamを新規に生成します。
EventManager - class jp.co.intra_mart.framework.base.event.EventManager.
イベントマネージャです。
EventManagerException - exception jp.co.intra_mart.framework.base.event.EventManagerException.
イベントマネージャ設定時の例外です。
EventManagerException() - class jp.co.intra_mart.framework.base.event.EventManagerException のコンストラクタ
詳細メッセージを指定しないで EventManagerException を構築します。
EventManagerException(String) - class jp.co.intra_mart.framework.base.event.EventManagerException のコンストラクタ
指定された詳細メッセージを持つ EventManagerException を構築します。
EventManagerException(String, Throwable) - class jp.co.intra_mart.framework.base.event.EventManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventManagerException を構築します。
EventModelProducer - class jp.co.intra_mart.framework.base.event.EventModelProducer.
イベント情報を作成するクラスです。
EventModelProducer() - class jp.co.intra_mart.framework.base.event.EventModelProducer のコンストラクタ

EventNavigatorAccessor - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor.
イベントナビゲーター管理アクセッサインタフェース。
EventNavigatorConst - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst.
イベントナビゲーターで使用する定数の一覧
EventNavigatorConst() - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst のコンストラクタ

EventNavigatorException - exception jp.co.intra_mart.foundation.navigator.EventNavigatorException.
イベントナビゲータマネージャに関する例外クラス

EventNavigatorException() - class jp.co.intra_mart.foundation.navigator.EventNavigatorException のコンストラクタ
コンストラクタ
EventNavigatorException(String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorException のコンストラクタ
コンストラクタ
EventNavigatorException(Throwable) - class jp.co.intra_mart.foundation.navigator.EventNavigatorException のコンストラクタ
コンストラクタ
EventNavigatorException(String, Throwable) - class jp.co.intra_mart.foundation.navigator.EventNavigatorException のコンストラクタ
コンストラクタ
EventNavigatorExporter - interface jp.co.intra_mart.foundation.navigator.EventNavigatorExporter.
イベントナビゲータバックアップインタフェースです。
EventNavigatorHandler - class jp.co.intra_mart.foundation.navigator.EventNavigatorHandler.

EventNavigatorHandler() - class jp.co.intra_mart.foundation.navigator.EventNavigatorHandler のコンストラクタ

EventNavigatorImporter - interface jp.co.intra_mart.foundation.navigator.EventNavigatorImporter.
イベントナビゲータバックアップインタフェースです。
EventNavigatorManager - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager.
イベントナビゲーター管理マネージャクラス。
EventNavigatorManager(String, String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のコンストラクタ
コンストラクタ。
EventNavigatorPermissionSelector - class jp.co.intra_mart.foundation.navigator.EventNavigatorPermissionSelector.
ユーザIDから有効なID一覧を取得するセレクタ。
EventNavigatorPermissionSelector() - class jp.co.intra_mart.foundation.navigator.EventNavigatorPermissionSelector のコンストラクタ
コンストラクタ。
EventNavigatorReaderDecorator - interface jp.co.intra_mart.foundation.navigator.EventNavigatorReaderDecorator.

EventPropertyException - exception jp.co.intra_mart.framework.base.event.EventPropertyException.
イベントプロパティ取得時の例外です。
EventPropertyException() - class jp.co.intra_mart.framework.base.event.EventPropertyException のコンストラクタ
詳細メッセージを指定しないで EventPropertyException を構築します。
EventPropertyException(String) - class jp.co.intra_mart.framework.base.event.EventPropertyException のコンストラクタ
指定された詳細メッセージを持つ EventPropertyException を構築します。
EventPropertyException(String, Throwable) - class jp.co.intra_mart.framework.base.event.EventPropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventPropertyException を構築します。
EventPropertyHandler - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler.
イベントの設定情報に接続するクラスです。
EventQueueController - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController.
このクラスは、イベントリスナーを実行するイベント機能を実装します。
EventQueueController() - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のコンストラクタ
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
EventQueueController(long) - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のコンストラクタ
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
EventQueueController - class jp.co.intra_mart.foundation.utility.EventQueueController.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventQueueController クラスを使用してください。
EventQueueController() - class jp.co.intra_mart.foundation.utility.EventQueueController のコンストラクタ
推奨されていません。 イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
EventQueueController(long) - class jp.co.intra_mart.foundation.utility.EventQueueController のコンストラクタ
推奨されていません。 イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
EventResult - interface jp.co.intra_mart.framework.base.event.EventResult.
イベント処理の結果です。
EventResultItem - class jp.co.intra_mart.foundation.navigator.EventResultItem.
ナビゲート結果クラス
EventResultItem() - class jp.co.intra_mart.foundation.navigator.EventResultItem のコンストラクタ

EventResultItemInfo - class jp.co.intra_mart.foundation.navigator.EventResultItemInfo.
ナビゲート結果情報
EventResultItemInfo() - class jp.co.intra_mart.foundation.navigator.EventResultItemInfo のコンストラクタ

EventScript - class jp.co.intra_mart.foundation.page.EventScript.
ブラウザでスクリプトの各変数に対する変更イベントを実装するための スクリプトコードを提供します。
EventScript(String) - class jp.co.intra_mart.foundation.page.EventScript のコンストラクタ
イベントスクリプトを作成するためのインスタンスを構築します。
EventTrigger - interface jp.co.intra_mart.framework.base.event.EventTrigger.
イベントトリガです。
EventTriggerAdapter - class jp.co.intra_mart.framework.base.event.EventTriggerAdapter.
DAOを取得するメソッドを持ったイベントトリガです。
EventTriggerAdapter() - class jp.co.intra_mart.framework.base.event.EventTriggerAdapter のコンストラクタ
EventTriggerAdapterを新規に生成します。
EventTriggerException - exception jp.co.intra_mart.framework.base.event.EventTriggerException.
イベントトリガ生成時の例外です。
EventTriggerException() - class jp.co.intra_mart.framework.base.event.EventTriggerException のコンストラクタ
詳細メッセージを指定しないで EventTriggerException を構築します。
EventTriggerException(String) - class jp.co.intra_mart.framework.base.event.EventTriggerException のコンストラクタ
指定された詳細メッセージを持つ EventTriggerException を構築します。
EventTriggerException(String, Throwable) - class jp.co.intra_mart.framework.base.event.EventTriggerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventTriggerException を構築します。
EventTriggerInfo - class jp.co.intra_mart.framework.base.event.EventTriggerInfo.
イベントトリガの情報です。
EventTriggerInfo() - class jp.co.intra_mart.framework.base.event.EventTriggerInfo のコンストラクタ
EventTriggerInfoを新規に生成します。
EventTriggerList - class jp.co.intra_mart.framework.base.event.EventTriggerList.
イベントトリガの集合を扱います。
EventTriggerList(String, String) - class jp.co.intra_mart.framework.base.event.EventTriggerList のコンストラクタ
EventTriggerListを新規に生成します。
EventTriggerList(String, String, boolean) - class jp.co.intra_mart.framework.base.event.EventTriggerList のコンストラクタ
EventTriggerListを新規に生成します。
EventsAttributes - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes.
ブラウザのイベントに関連するタグの属性情報です。
EventsAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のコンストラクタ
EventsAttributesを新規に生成します。
EverydayConditioner - class jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner.
このクラスは、時間によりリフレッシュイベントを 発生させるためのヘルパークラスです。
EverydayConditioner(int, int, TimeZone) - class jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner のコンストラクタ
毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
EverydayConditioner(int, int) - class jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner のコンストラクタ
毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
EverydayConditioner - class jp.co.intra_mart.foundation.utility.report.EverydayConditioner.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner クラスを使用してください。
EverydayConditioner(int, int, TimeZone) - class jp.co.intra_mart.foundation.utility.report.EverydayConditioner のコンストラクタ
推奨されていません。 毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
EverydayConditioner(int, int) - class jp.co.intra_mart.foundation.utility.report.EverydayConditioner のコンストラクタ
推奨されていません。 毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
ExceptionHandlingFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter.
サーブレットの実行例外をキャッチして、 指定のエラーページへフォワードするフィルタです。
ExceptionHandlingFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter のコンストラクタ
新しくフィルタオブジェクトを作成します。
ExcessiveQueryException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException.
クエリが Content-Length ヘッダで指定された量よりも過剰な場合に スローされる例外です。
ExcessiveQueryException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException のコンストラクタ
指定のメッセージを持つ例外を作成します。
ExcessiveQueryException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
ExcessiveQueryException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException のコンストラクタ
例外を作成します。
ExchRate - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate.
換算レート、係数 (通貨ペア)情報クラス 機能は以下の通り
換算レート、係数 (通貨ペア)情報を保持します。
ExchRate() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のコンストラクタ
換算レート、係数 (通貨ペア)を作成します。
ExchangeRateGetDetail - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail.
為替換算レート情報取得クラス
機能は以下の通り
為替換算レート情報を取得します。
ExchangeRateGetDetail(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のコンストラクタ
為替換算レート情報を作成
ExchangeRateGetDetail(String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のコンストラクタ

ExchangeRateGetDetailController - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController.
為替換算レートコントローラクラス
機能は以下の通り
為替換算レートを取得します。
ExchangeRateGetDetailController(String, String, String, String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のコンストラクタ

ExchangeRateGetDetailController(String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のコンストラクタ

ExchangeRateGetDetailController() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のコンストラクタ
ExchangeRateGetDetailControllerのコンストラクタを生成します。
ExchangeRateGetDetailController(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のコンストラクタ
ExchangeRateGetDetailControllerのコンストラクタを生成します。
ExpActivity - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity.
活動に関する詳細情報クラス 機能は以下の通り
活動に関する詳細情報を保持します。
ExpActivity() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のコンストラクタ
活動に関する詳細情報を作成します。
ExpMessage - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage.
詳細情報を読み込みエラー情報クラス 機能は以下の通り
詳細情報を読み込みエラー情報を保持します。
ExpMessage() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のコンストラクタ
詳細情報を読み込みエラー情報を作成します。
ExpWbsElement - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement.
WBS 要素についての詳細情報クラス
機能は以下の通り
WBS 要素についての詳細情報を保持します。
ExpWbsElement() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のコンストラクタ
WBS 要素についての詳細情報を作成します。
ExpWbsHierarchie - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie.
WBS 階層についての情報クラス 機能は以下の通り
WBS 階層についての情報を保持します。
ExpWbsHierarchie() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のコンストラクタ
WBS 階層についての情報を作成します。
ExpWbsMilestone - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone.
WBS マイルストーンに関する詳細情報クラス 機能は以下の通り
WBS マイルストーンに関する詳細情報を保持します。
ExpWbsMilestone() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のコンストラクタ
WBS マイルストーンに関する詳細情報を作成します。
ExpirationKey - interface jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey.
ライフタイム期間の有効終了日時を定義します。
ExportConfigurationReader - interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader.
エクスポート設定情報の読込みを行います。
ExportConfigurationReaderException - exception jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReaderException.
エクスポート設定の読み込みでエラーが発生したことを示すためにスローされます。
ExportConfigurationReaderException(String) - class jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReaderException のコンストラクタ
コンストラクタ
ExportConfigurationReaderException(Throwable) - class jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReaderException のコンストラクタ
コンストラクタ
ExportConfigurationReaderException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReaderException のコンストラクタ
コンストラクタ
ExportHeader - class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader.
貿易管理ヘッダ情報クラス
機能は以下の通り
貿易管理ヘッダ情報を保持します。
ExportHeader() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader のコンストラクタ
貿易管理明細を作成します。
ExportInitializeException - exception jp.co.intra_mart.foundation.datastore.exporter.ExportInitializeException.
エクスポートの初期化でエラーが発生したことを示すためにスローされます。
ExportInitializeException(String) - class jp.co.intra_mart.foundation.datastore.exporter.ExportInitializeException のコンストラクタ
コンストラクタ
ExportInitializeException(Throwable) - class jp.co.intra_mart.foundation.datastore.exporter.ExportInitializeException のコンストラクタ
コンストラクタ
ExportInitializeException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exporter.ExportInitializeException のコンストラクタ
コンストラクタ
ExportItem - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem.
貿易管理明細情報クラス
機能は以下の通り
貿易管理明細情報を保持します。
ExportItem() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のコンストラクタ
貿易管理明細を作成します。
ExportItem(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のコンストラクタ
貿易管理明細を作成します。
ExportManager - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager.
エクスポートを行います。
ExportManagerClient - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient.
エクスポートマネージャーの呼び出しを行うクライアントです。
ExportManagerImpl - class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl.
エクスポートマネージャーの汎用的な実装です。
ExportManagerImpl(String) - class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl のコンストラクタ
コンストラクタ
ExtendedBaseAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor.
拡張基本エンティティに対する情報操作用のインタフェースです。
ExtendedBaseAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap.
拡張基本アクセサのマッピング情報を持ちます。
ExtendedBaseModel - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseModel.
拡張基本モデルを定義します。
ExtendedBaseModel - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel.
拡張基本モデルの情報です。
ExtendedBaseModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap.
拡張基本モデルのマッピング情報を持ちます。
ExtendedBaseTable - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable.
拡張基本テーブルを定義します。
ExtendedClassLoader - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader.
このクラスは、拡張されたクラスローダーです。
ExtendedClassLoader() - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader のコンストラクタ
このクラスをロードした ClassLoader を親クラスローダとして使用し、 新しいクラスローダを作成します。
ExtendedClassLoader(ClassLoader) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader のコンストラクタ
指定された親クラスローダを使って、 委譲のために新しいクラスローダを作成します。
ExtendedDirectory - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory.
File インスタンスを作成するためのファクトリクラスです。
ExtendedDirectory(String, int) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のコンストラクタ
File オブジェクトを作成するためのファクトリオブジェクトを作成します。
ExtendedDirectory(File, String, int) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のコンストラクタ
File オブジェクトを作成するためのファクトリオブジェクトを作成します。
ExtendedDirectory - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。
ExtendedDirectory(String, int) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のコンストラクタ
推奨されていません。 File オブジェクトを作成するためのファクトリオブジェクトを作成します。
ExtendedDirectory(File, String, int) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のコンストラクタ
推奨されていません。 File オブジェクトを作成するためのファクトリオブジェクトを作成します。
ExtendedEntity - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity.
拡張エンティティを定義します。
ExtendedFile - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile.
このクラスは、ファイルを扱う時に便利な機能を提供します。
ExtendedFile(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のコンストラクタ
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
ExtendedFile(File, String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のコンストラクタ
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
ExtendedFile(String, String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のコンストラクタ
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
ExtendedFile - class jp.co.intra_mart.foundation.utility.file.ExtendedFile.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile クラスを使用してください。
ExtendedFile(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のコンストラクタ
推奨されていません。 指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
ExtendedFile(File, String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のコンストラクタ
推奨されていません。 親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
ExtendedFile(String, String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のコンストラクタ
推奨されていません。 親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
ExtendedGenericBaseModel - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel.
拡張基本モデルの汎用的な抽象クラスです。
ExtendedGenericBaseModel() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel のコンストラクタ

ExtendedGenericBaseModelMap - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap.
拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。
ExtendedGenericBaseModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap のコンストラクタ

ExtendedGenericInternationalModel - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel.
拡張国際化モデルの汎用的な抽象クラスです。
ExtendedGenericInternationalModel() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel のコンストラクタ

ExtendedGenericInternationalModelMap - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap.
拡張国際化モデルのマッピング情報を持つ汎用的な抽象クラスです。
ExtendedGenericInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap のコンストラクタ

ExtendedGenericTerminableInternationalModel - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel.
拡張期間国際化モデルの汎用的な抽象クラスです。
ExtendedGenericTerminableInternationalModel() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel のコンストラクタ

ExtendedGenericTerminableInternationalModelMap - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap.
拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。
ExtendedGenericTerminableInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap のコンストラクタ

ExtendedGenericTerminableModel - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel.
拡張期間化モデルの汎用的な抽象クラスです。
ExtendedGenericTerminableModel() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel のコンストラクタ

ExtendedGenericTerminableModelMap - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap.
拡張期間化モデルのマッピング情報を持つ汎用的な抽象クラスです。
ExtendedGenericTerminableModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap のコンストラクタ

ExtendedHttpServletResponse - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse.
このインタフェースは、HttpServletResponseを拡張したものです。
ExtendedHttpServletResponseWrapper - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper.
レスポンスのサプクラス化による拡張を可能とする ExtendedHttpServletResponse インタフェースの簡潔な実装方法を提供します。
ExtendedHttpServletResponseWrapper(ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のコンストラクタ
指定したレスポンスをラッピングしたレスポンス・アダプタを構築します。
ExtendedInputStream - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream.
このクラスは、標準の入力ストリームを拡張した機能を提供します。
ExtendedInputStream(InputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のコンストラクタ
入力ストリームを構築します。
ExtendedInputStream(InputStream, ErrorEventListener) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のコンストラクタ
入力ストリームを構築します。
ExtendedInputStream - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream クラスを使用してください。
ExtendedInputStream(InputStream) - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のコンストラクタ
推奨されていません。 入力ストリームを構築します。
ExtendedInputStream(InputStream, ErrorEventListener) - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のコンストラクタ
推奨されていません。 入力ストリームを構築します。
ExtendedInternationalAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor.
拡張国際化エンティティに対する情報操作用のインタフェースです。
ExtendedInternationalAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap.
拡張国際アクセサのマッピング情報を持ちます。
ExtendedInternationalModel - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalModel.
拡張国際化モデルを定義します。
ExtendedInternationalModel - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel.
拡張国際化モデルの情報です。
ExtendedInternationalModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap.
拡張国際化モデルのマッピング情報を持ちます。
ExtendedInternationalTable - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable.
拡張国際化テーブルを定義します。
ExtendedModel - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel.
拡張モデルを定義します。
ExtendedOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream.
このクラスは、標準の出力ストリームを拡張した機能を提供します。
ExtendedOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のコンストラクタ
出力ストリームを構築します。
ExtendedOutputStream(OutputStream, ErrorEventListener) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のコンストラクタ
出力ストリームを構築します。
ExtendedOutputStream - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream クラスを使用してください。
ExtendedOutputStream(OutputStream) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のコンストラクタ
推奨されていません。 出力ストリームを構築します。
ExtendedOutputStream(OutputStream, ErrorEventListener) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のコンストラクタ
推奨されていません。 出力ストリームを構築します。
ExtendedParamConverter - class jp.co.intra_mart.foundation.sap.common.util.data.ExtendedParamConverter.
共通APIのパラメータ変換クラス２。
ExtendedProperties - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties.
java.util.Properties を、より便利に利用するためのインタフェースを提供します。
ExtendedProperties() - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のコンストラクタ
デフォルト値を持たない空のプロパティリストを作成します。
ExtendedProperties(Properties) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のコンストラクタ
指定されたデフォルト値を持つ空のプロパティリストを作成します。
ExtendedServletException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException.
Servlet 例外の拡張モデルです。
ExtendedServletException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException のコンストラクタ
例外オブジェクトを作成します。
ExtendedServletException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException のコンストラクタ
指定されたメッセージを持つ例外を作成します。
ExtendedServletException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException のコンストラクタ
指定されたメッセージと根本原因となった例外を持つ例外を作成します。
ExtendedServletException(Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException のコンストラクタ
根本原因となった例外を持つ例外を作成します。
ExtendedServletResponse - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse.
このインタフェースは、ServletResponseを拡張したものです。
ExtendedSocket - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket.
このクラスは、ソケット通信用の入出力機能を提供します。
ExtendedSocket(String, int) - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のコンストラクタ
ソケットを構築します。
ExtendedSocket(Socket) - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のコンストラクタ
ソケットを構築します。
ExtendedSocket(ExtendedSocket) - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のコンストラクタ
ソケットを構築します。
ExtendedSocket - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket クラスを使用してください。
ExtendedSocket(String, int) - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のコンストラクタ
推奨されていません。 ソケットを構築します。
ExtendedSocket(Socket) - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のコンストラクタ
推奨されていません。 ソケットを構築します。
ExtendedSocket(ExtendedSocket) - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のコンストラクタ
推奨されていません。 ソケットを構築します。
ExtendedTable - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable.
拡張テーブルを定義します。
ExtendedTerminableAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor.
拡張期間化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap.
拡張期間化アクセサのマッピング情報を持ちます。
ExtendedTerminableInternationalAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor.
拡張期間国際化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableInternationalAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap.
拡張期間国際化アクセサのマッピング情報を持ちます。
ExtendedTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalModel.
拡張期間国際化モデルを定義します。
ExtendedTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel.
拡張期間国際化モデルの情報です。
ExtendedTerminableInternationalModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap.
拡張期間国際化モデルのマッピング情報を持ちます。
ExtendedTerminableInternationalTable - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable.
拡張期間国際化テーブルを定義します。
ExtendedTerminableModel - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableModel.
拡張期間化モデルを定義します。
ExtendedTerminableModel - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel.
拡張期間化モデルの情報です。
ExtendedTerminableModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap.
拡張期間化モデルのマッピング情報を持ちます。
ExtendedTerminableTable - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable.
拡張期間化テーブルを定義します。
ExtendedThread - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread.
To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates.
ExtendedThread() - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread(Runnable) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread(ThreadGroup, Runnable) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread(ThreadGroup, String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread(Runnable, String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread(ThreadGroup, Runnable, String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread - class jp.co.intra_mart.foundation.utility.ExtendedThread.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread クラスを使用してください。
ExtendedThread() - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(Runnable) - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(ThreadGroup, Runnable) - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(String) - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(ThreadGroup, String) - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(Runnable, String) - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(ThreadGroup, Runnable, String) - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendsImport - interface jp.co.intra_mart.foundation.security.ExtendsImport.
拡張インポート処理インターフェース。
ExtendsImportManager - class jp.co.intra_mart.foundation.security.ExtendsImportManager.
拡張インポートマネージャクラス。
Extension - class jp.co.intra_mart.foundation.sap.module.purchase.Extension.
拡張得意先項目情報クラス
機能は以下の通り
拡張得意先項目情報を保持します。
Extension() - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のコンストラクタ
拡張得意先項目を作成します。
Extension(int) - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のコンストラクタ
拡張得意先項目アドレスを作成します。
ExtensionIn - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn.
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報クラス
機能は以下の通り
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を保持します。
ExtensionIn() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のコンストラクタ
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。
ExtensionIn(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のコンストラクタ
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。
ExtensionIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn.
VBAK、VBAP、VBEP のカスタマ拡張情報クラス
機能は以下の通り
VBAK、VBAP、VBEP のカスタマ拡張情報を保持します。
ExtensionIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のコンストラクタ
VBAK、VBAP、VBEP のカスタマ拡張情報を作成します。
ExtensionIn(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のコンストラクタ
VBAK、VBAP、VBEP のカスタマ拡張情報を作成します。
ExtensionInX - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX.
拡張イン/拡張アウトのチェックボックス構造情報クラス
機能は以下の通り
拡張イン/拡張アウトのチェックボックス構造情報を保持します。
ExtensionInX() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のコンストラクタ
拡張イン/拡張アウトのチェックボックス構造情報を作成します。
ExtensionInX(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のコンストラクタ
拡張イン/拡張アウトのチェックボックス構造情報を作成します。
ExtensionOut - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut.
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報クラス
機能は以下の通り
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を保持します。
ExtensionOut() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のコンストラクタ
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。
ExtensionOut(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のコンストラクタ
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。
ExternalDirectory - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory.
共有データグループを管理するオブジェクトです。
ExternalDirectory(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
ExternalMemory - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory.
共有データを管理するオブジェクトです。
ExternalMemory(String, String) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
ExternalMemory(ExternalDirectory, String) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
ejbActivate() - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean のメソッド
"passive"状態の時にインスタンスが活性化される時に呼ばれるメソッドです。
ejbCreate() - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean のメソッド
ホームインタフェースの引数なしのcreate()メソッドに対応します。
ejbCreate() - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean のメソッド
ホームインタフェースの引数なしのcreate()メソッドに対応します。
ejbPassivate() - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean のメソッド
インスタンスが"passive"状態に移る前に呼ばれるメソッドです。
ejbRemove() - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean のメソッド
Session Beanのが終了する前にEJBコンテナが呼び出すメソッドです。
eject(SocketConnection) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
指定コネクションをこのプールの管理から切り離します。
eject(SocketConnection) - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 指定コネクションをこのプールの管理から切り離します。
encode(char) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
指定の文字を CharacterEncoder.getCharacterEncoding() で表される文字コードへ エンコードします。
encode(char[]) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
指定の文字を CharacterEncoder.getCharacterEncoding() で表される文字コードへ エンコードします。
encode(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
指定の文字列を CharacterEncoder.getCharacterEncoding() で表される文字コードへ エンコードします。
encode(String) - interface jp.co.intra_mart.foundation.portal.common.encode.EnCodeInterface のメソッド
暗号化を行います。
encode(char) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。
encode(char[]) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 指定の文字を CharacterEncoder.getCharacterEncoding() で表される文字コードへ エンコードします。
encode(String) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 指定の文字列を CharacterEncoder.getCharacterEncoding() で表される文字コードへ エンコードします。
encodeCaption(String) - class jp.co.intra_mart.framework.base.web.util.HTMLEncoder の static メソッド
キャプションを変換します。
encodeRedirectURL(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
AbstractHttpServletResponseEventController.sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。
encodeRedirectURL(HttpServletRequest, ExtendedHttpServletResponse, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
#sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。
encodeRedirectURL(HttpServletRequest, ExtendedHttpServletResponse, String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
#sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。
encodeRedirectURL(HttpServletRequest, ExtendedHttpServletResponse, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
#sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。
encodeURL(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
指定されたURLがセッションIDを含むようにエンコードします。
encodeURL(HttpServletRequest, ExtendedHttpServletResponse, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
指定されたURLがセッションIDを含むようにエンコードします。
encodeURL(HttpServletRequest, ExtendedHttpServletResponse, String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
指定されたURLがセッションIDを含むようにエンコードします。
encodeURL(HttpServletRequest, ExtendedHttpServletResponse, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
指定されたURLがセッションIDを含むようにエンコードします。
encodeURL(ServletRequest, ServletResponse, String) - class jp.co.intra_mart.framework.base.session.HttpSessionFactory のメソッド
推奨されていません。 セッションIDをエンコードしてURLに追加します。
encodeURL(ServletRequest, ServletResponse, String) - class jp.co.intra_mart.framework.base.session.IntramartSessionFactory のメソッド
推奨されていません。 セッションIDをエンコードしてURLに追加します。
encodeURL(ServletRequest, ServletResponse, String) - interface jp.co.intra_mart.framework.base.session.SessionFactory のメソッド
セッションIDをエンコードしてURLに追加します。
encodeUrl(String) - class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil の static メソッド
文字列をURLエンコードします。
encodeValue(String) - class jp.co.intra_mart.framework.base.web.util.HTMLEncoder の static メソッド
<TEXTAREA>タグまたはvalue属性に入る文字列を変換します。
encrypt(String) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
デフォルトの暗号化アルゴリズムカテゴリを利用して文字列を暗号化します。
encrypt(String, String) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
指定された暗号化アルゴリズムカテゴリを利用して文字列を暗号化します。
encrypt(String) - interface jp.co.intra_mart.foundation.security.cryption.Cryption のメソッド
文字列を暗号化する。
encrypt(String) - class jp.co.intra_mart.foundation.security.cryption.NoCryption のメソッド
文字列を暗号化する。
encrypt(String) - class jp.co.intra_mart.foundation.security.cryption.StandardCryption のメソッド
文字列を暗号化する。
end() - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
ロックを解除します。
endElement(String, String, String) - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のメソッド
DefaultHandlerのabstractメソッドをオーバーライドします。
ensureCapacity(int) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
必要に応じて、この ArrayList のインスタンスのサイズを拡大し、少なくとも最小サイズ引数で指定された数の要素を格納できるようにします。
ensureCapacity(int) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 必要に応じて、この ArrayList のインスタンスのサイズを拡大し、少なくとも最小サイズ引数で指定された数の要素を格納できるようにします。
entityDirectory() - class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory のメソッド
データファイルを保存しておくための ディレクトリを表すオブジェクトを取得します。
entries() - class jp.co.intra_mart.foundation.acssecurity.Logingp の static メソッド
推奨されていません。 LoginGroupManager.getLoginGroupIds()に置き換えられました。
entries() - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。
entries() - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。
entries() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
セッションＩＤ一覧を取得します。
entries() - interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory のメソッド
このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。
entry(EventListener) - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のメソッド
イベントリスナーの登録。
entry() - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のメソッド
モニターの取得。
entry(HttpServletRequest) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter の static メソッド
このフィルタによってＵＲＬの制御を行うことを定義します。
entry(HttpSession) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter の static メソッド
このフィルタによってＵＲＬの制御を行うことを定義します。
entry(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
空のグループを作成します。
entry(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
空のグループを作成します。
entry(String) - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
新しい空のセッションを作成します。
entry() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
新しい空のセッションを作成します。
entry(String) - interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory のメソッド
空のグループを作成します。
entry(EventListener) - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 イベントリスナーの登録。
entry() - class jp.co.intra_mart.foundation.utility.LockMonitor のメソッド
推奨されていません。 モニターの取得。
entryMap() - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
グループデータを取得します。
entryMap() - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
グループデータを取得します。
entryMap() - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
グループデータを取得します。
entryMap() - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
グループデータを取得します。
entrySet() - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
このマップに格納されているマッピングのセットビューを返します。
entrySet() - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 このマップに格納されているマッピングのセットビューを返します。
equals(Object) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
指定されたオブジェクトとリストが等しいかどうかを比較します。
equals(Object) - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
この有効期間と他の有効期間が等しいかどうかを示します。
equals(Object) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 指定されたオブジェクトとリストが等しいかどうかを比較します。
equals(Object) - class jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet のメソッド
このポートレットと別のオブジェクトとが等しいかどうかを比較します。
equals(Object) - class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet のメソッド
このポートレットと別のオブジェクトとが等しいかどうかを比較します。
equals(Object) - class jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet のメソッド
このポートレットと別のオブジェクトとが等しいかどうかを比較します。
equals(Object) - class jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet のメソッド
このポートレットと別のオブジェクトとが等しいかどうかを比較します。
equals(Object) - class jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet のメソッド
このポートレットと別のオブジェクトとが等しいかどうかを比較します。
equals(Object) - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet のメソッド
このポートレットと別のオブジェクトとが等しいかどうかを比較します。
equals(Object) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
オブジェクトを比較します。
equals(Object) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
オブジェクトの比較。
equals(Object) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
オブジェクトの比較。
equals(Object) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
このオブジェクトと他のオブジェクトが等しいかどうかを示します。
equals(Object) - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
このオブジェクトと他のオブジェクトが等しいかどうかを示します。
equals(Object) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
データモデルのチェック。
err - class jp.co.intra_mart.foundation.service.provider.Platform の static 変数
エラーログに対するメッセージ出力ストリームです。
errorIterator() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
このインスタンスのメソッド実行中に発生した例外を返します。
errorIterator() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 このインスタンスのメソッド実行中に発生した例外を返します。
errorPagePath - class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor の変数
クラス変数
eventGenerating() - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のメソッド
キューに登録されているイベントリスナーを一つ実行します。
eventGenerating() - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 キューに登録されているイベントリスナーを一つ実行します。
execute(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 任意のＳＱＬ文をデータベースに対してリクエストする

insert/update/delete文を実行する。
execute(String) - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(String) - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager のメソッド
エクスポートを実行します。
execute(OutputStream) - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager のメソッド
エクスポートを実行します。
execute(String) - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(InputStream) - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(String) - class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl のメソッド
エクスポートを実行します。
execute(OutputStream) - class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl のメソッド
エクスポートを実行します。
execute(String) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager のメソッド

execute(OutputStream) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager のメソッド

execute(String) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(String) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager のメソッド

execute(OutputStream) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager のメソッド

execute(String) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(String) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager のメソッド

execute(OutputStream) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager のメソッド

execute(String) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(String) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager のメソッド

execute(OutputStream) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager のメソッド

execute(String) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(String) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager のメソッド

execute(OutputStream) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager のメソッド

execute(String) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(String) - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
インポートマネージャーを呼び出します。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
インポートマネージャーを呼び出します。
execute(String[]) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManager のメソッド
インポートを実行します。
execute(InputStream) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManager のメソッド
インポートを実行します。
execute(String) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient のメソッド
指定された定義情報をもとにインポート処理を行います。
execute(InputStream) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient のメソッド
指定された定義情報をもとにインポート処理を行います。
execute(String[]) - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl のメソッド
インポートを実行します。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl のメソッド
インポートを実行します。
execute(String[]) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager のメソッド

execute(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager のメソッド

execute(String) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient のメソッド
指定された定義情報をもとにインポート処理を行います。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient のメソッド
指定された定義情報をもとにインポート処理を行います。
execute(String[]) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager のメソッド

execute(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager のメソッド

execute(String) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient のメソッド
指定された定義情報をもとにインポート処理を行います。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient のメソッド
指定された定義情報をもとにインポート処理を行います。
execute(String[]) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager のメソッド

execute(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager のメソッド

execute(String) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient のメソッド
指定された定義情報をもとにインポート処理を行います。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient のメソッド
指定された定義情報をもとにインポート処理を行います。
execute(String[]) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager のメソッド

execute(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager のメソッド

execute(String) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient のメソッド
指定された定義情報をもとにインポート処理を行います。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient のメソッド
指定された定義情報をもとにインポート処理を行います。
execute(String[]) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager のメソッド

execute(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager のメソッド

execute(String) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient のメソッド
指定された定義情報をもとにインポート処理を行います。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient のメソッド
指定された定義情報をもとにインポート処理を行います。
execute() - class jp.co.intra_mart.foundation.scenario.FunctionContainer のメソッド
スクリプトの実行。
execute(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.scenario.FunctionContainer のメソッド
スクリプトの実行。
execute(String) - class jp.co.intra_mart.foundation.scenario.PresentationPage のメソッド
プログラム実行。
execute(String, Object[]) - class jp.co.intra_mart.foundation.scenario.PresentationPage のメソッド
プログラム実行。
execute(Object) - class jp.co.intra_mart.foundation.service.client.NetworkAgent のメソッド
サーバに対して実行要求をします。
execute(ActionListener, Object) - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
サーバに対して実行要求をします。
execute(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
指定された URL に接続して、 イベントの実行を要求します。
execute(URL) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
指定された URL に接続して、 イベントの実行を要求します。
execute(HttpURLConnection) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
指定された URL コネクションを利用してにサーバに接続し、 イベントの実行を要求します。
execute(Properties) - class jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory のメソッド
推奨されていません。
execute(Properties) - interface jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent のメソッド
インタフェース ProcedureComponent を実装したオブジェクトの実行クラスを Application Runtime に登録することで、 Application Runtime はこのクラスをインスタンス化し、 execute() メソッドをバッチプログラムとして実行します。
execute(Event) - interface jp.co.intra_mart.framework.base.event.EventListener のメソッド
処理を実行します。
execute(Event) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListener のメソッド
処理を実行します。
execute(Event, String) - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent のメソッド
イベント処理を行います。
execute(Event, String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean のメソッド
イベント処理を実行します。
execute(Event, String) - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocal のメソッド
イベント処理を行います。
execute(Event) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal のメソッド
処理を実行します。
execute(Event) - class jp.co.intra_mart.framework.base.event.GenericEventListener のメソッド
処理を実行します。
execute(Event) - class jp.co.intra_mart.framework.base.event.StandardEJBEventListener のメソッド
処理を実行します。
execute(Event) - interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent のメソッド
イベント処理を実行します。
execute(Event) - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean のメソッド
イベント処理を実行します。
execute(Event) - class jp.co.intra_mart.framework.base.event.StandardEventListener のメソッド
処理を実行します。
execute(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 intra-martベースモジュールのメニューからのリクエストを受け付けます。
executeBapi() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
BAPIを実行します。
executeBapi(BapiController) - class jp.co.intra_mart.foundation.sap.module.AbstractController のメソッド
引数で指定された bapiController のexecuteBapiメソッドを実行します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
BapiControllerにより会計伝票を登録します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail のメソッド
BapiControllerにより原価センタグループ検索を検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
CostCenterGroupGetDetailのexecuteBapi()を呼び出し原価センタグループを取得します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
BapiControllerにより仕入先コードを検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
BapiControllerにより得意先コードを検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
BapiControllerにより為替換算レート情報を検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
ExchangeRateGetDetailのexecuteBapi()を呼び出し為替換算レートを取得します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
BapiControllerにより内部指図書詳細情報を検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
InternalOrderGetDetailのexecuteBapi()を呼び出し内部指図書詳細を取得します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
BapiControllerにより内部指図書（一覧）情報を検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
PurchaseOrderPayPostのexecuteBapi()を呼び出し内部指図書一覧を取得します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail のメソッド
BapiControllerにより利益センタグループ検索を検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
ProfitCenterGrpGetDetailのexecuteBapi()を呼び出し利益センタグループを取得します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
BapiControllerによりWBSの詳細情報の検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
ProjectGetInfoのexecuteBapi()を呼び出しWBSの詳細を取得します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController のメソッド
GoodsMvtCreateのexecuteBapi()を呼び出し品目コードを検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController のメソッド
GoodsMvtGetItemsのexecuteBapi()を呼び出し品目コードを検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController のメソッド
MaterialAvailabilityのexecuteBapi()を呼び出し品目コードを検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のメソッド
BapiControllerにより品目マスタ照会を行います。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController のメソッド
ReferenceControllerのexecuteBapi()を呼び出し品目コードを検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
BapiControllerにより品目マスタを更新します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
BapiControllerにより仕入先マスタ詳細を作成します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
PurchaseGetItemSrelのexecuteBapi()を呼び出し伝票承認対象一覧を取得します。
executeBapi(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
購買発注伝票の登録及び変更に共通で使用する項目に値をセットした後、 AbstractController#executeBapi()を実行します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController のメソッド
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を登録します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController のメソッド
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を変更します。
executeBapi(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
伝票承認取消処理を実行します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController のメソッド
伝票承認処理を実行します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController のメソッド
伝票承認取消処理を実行します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
BapiControllerにより仕入先マスタ詳細を作成します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のメソッド
BapiControllerにより仕入先コード存在チェックを作成します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のメソッド
SupplierExistenceCheckのexecuteBapi()を呼び出し仕入先コード存在チェックを行います。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
SupplierDetailのexecuteBapi()を呼び出し仕入先マスタ詳細情報を作成します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController のメソッド
BillingDocCreateMultipleのexecuteBapi()を呼び出し請求伝票を登録します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController のメソッド
BillingDocGetListのexecuteBapi()を呼び出し請求伝票一覧を検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller のメソッド
InquiryCreateFromData2のexecuteBapi()を呼び出し引合伝票を登録します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller のメソッド
QuotationCreateFromData2のexecuteBapi()を呼び出し見積伝票を登録します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller のメソッド
SalesOrderCreateFromDat2のexecuteBapi()を呼び出し販売伝票を登録します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController のメソッド
ReferenceControllerのexecuteBapi()を呼び出し販売伝票一覧を取得します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController のメソッド
SalesOrderGetStatusのexecuteBapi()を呼び出し販売伝票ステータス一覧を照会します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail のメソッド
BillingDocGetDetailのexecuteBapi()を呼び出し請求伝票を検索します。
executeBatchProgram(String, String) - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
バッチプログラムを実行します。
existGroupImageIconBySrc(String) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
URLをもつグループイメージアイコンの存在チェックをします。
existGroupImageIcons() - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
グループイメージアイコンの存在チェックをします。
existImageIcon(String) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
イメージアイコンの存在チェックをします。
existUserImageIconBySrc(String, String) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
URLをもつユーザイメージアイコンの存在チェックをします。
existUserImageIcons(String) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
ユーザイメージアイコンの存在チェックをします。
exists(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
指定された言語に該当する国際化モデルが存在するどうか判定します。
exists(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
指定された言語に該当する期間国際化モデルが存在するかどうか判定します。
exists(Date) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
指定された日時を含む期間化モデルが存在するかどうか判定します。
exists(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap のメソッド
指定された言語に該当する国際化モデルが存在するどうか判定します。
exists(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap のメソッド
指定された言語に該当する期間国際化モデルが存在するかどうか判定します。
exists(Date) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap のメソッド
指定された日付を含む期間化モデルが存在するかどうか判定します。
exists(String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたセッションIDのアクティブなセッション情報が存在するかどうか取得します。
exists(String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたセッションIDのアクティブなセッション情報が存在するかどうか取得します。
exists() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルが存在するかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner のメソッド
メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner のメソッド
メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner のメソッド
メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner のメソッド
メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner のメソッド
メッセージファイルを再作成する必要があるかどうかを判定します。
expiration() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
セッションの維持時間を取得します。
expiration(ReportFileWriter) - class jp.co.intra_mart.foundation.utility.report.EverydayConditioner のメソッド
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.foundation.utility.report.FileSizeConditioner のメソッド
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner のメソッド
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.foundation.utility.report.PeriodicConditioner のメソッド
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - interface jp.co.intra_mart.foundation.utility.report.ReportFileConditioner のメソッド
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
exportCSV(PreparedStatement, OutputStream, boolean) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 CSV形式のデータをストリームに出力します。
exportCSV(PreparedStatement, OutputStream, int, int, boolean) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 CSV形式のデータをストリームに出力します。
exportCSV(PreparedStatement, NetworkFile, boolean) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 CSVファイルをストレージに出力します。
exportCSV(PreparedStatement, NetworkFile, int, int, boolean) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 CSVファイルをストレージに出力します。
exportData(OutputStream, boolean) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
エクスポートを行います。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
アクセスコントローラ情報をエクスポートします。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウント情報をエクスポートします。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
エクスポートを行います。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
エクスポートを行います。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニュー情報・エクスポート。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニュー情報をエクスポートします。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール情報・エクスポート。

F

FAVORITE_MENU - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
アカウントが保有するメニュー
FAX_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
FAX番号
FAX_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
FAX番号
FLOAT - class jp.co.intra_mart.foundation.datastore.common.config.AttributeType の static 変数
浮動少数型
FavoriteMenu - class jp.co.intra_mart.foundation.security.account.FavoriteMenu.
マイメニューモデル。
FavoriteMenu(String, String, int) - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のコンストラクタ
コンストラクタ。
FavoriteMenu(String) - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のコンストラクタ
コンストラクタ。
FavoriteMenuBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel.
アカウントが保有するメニューの基本モデルです。
FavoriteMenuMapper - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper.
アカウントが保有するメニューに関連するマッパです。
FileReporter - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter.
メッセージのファイル出力機能を提供します。
FileReporter(ReportFileWriter) - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のコンストラクタ
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
FileReporter - class jp.co.intra_mart.foundation.utility.report.FileReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileReporter クラスを使用してください。
FileReporter(ReportFileWriter) - class jp.co.intra_mart.foundation.utility.report.FileReporter のコンストラクタ
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
FileSender - class jp.co.intra_mart.foundation.http.FileSender.
このクラスは、HTTP レスポンスに対して指定のバイトをストリームとして 出力します。
FileSender(HttpServletResponse) - class jp.co.intra_mart.foundation.http.FileSender のコンストラクタ
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSender(HttpServletResponse, MultipurposeInternetMailExtensions) - class jp.co.intra_mart.foundation.http.FileSender のコンストラクタ
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSender(HttpServletResponse, String) - class jp.co.intra_mart.foundation.http.FileSender のコンストラクタ
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSender(HttpServletResponse, MultipurposeInternetMailExtensions, String) - class jp.co.intra_mart.foundation.http.FileSender のコンストラクタ
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSizeConditioner - class jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner.
このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
FileSizeConditioner(long) - class jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner のコンストラクタ
メッセージファイルのサイズによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
FileSizeConditioner - class jp.co.intra_mart.foundation.utility.report.FileSizeConditioner.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner クラスを使用してください。
FileSizeConditioner(long) - class jp.co.intra_mart.foundation.utility.report.FileSizeConditioner のコンストラクタ
推奨されていません。 メッセージファイルのサイズによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
FileUploadFilter - class jp.co.intra_mart.framework.base.service.FileUploadFilter.
ファイルアップロード用にリクエストを変換するフィルタです。
FileUploadFilter() - class jp.co.intra_mart.framework.base.service.FileUploadFilter のコンストラクタ

Filter - class jp.co.intra_mart.foundation.datastore.exporter.Filter.
エクスポート対象のデータを絞り込むための情報を保持します。
Filter(String[]) - class jp.co.intra_mart.foundation.datastore.exporter.Filter のコンストラクタ
コンストラクタ
設定された値以外を抽出するフィルタを構築します。
Filter(String[], boolean) - class jp.co.intra_mart.foundation.datastore.exporter.Filter のコンストラクタ
コンストラクタ
設定された値に対するフィルタを構築します。
FilterComparator - class jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator.
コンパレータのフィルターとして機能する抽象クラスです。
FilterComparator(Comparator) - class jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator のコンストラクタ
指定されれたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
FilterComparator - class jp.co.intra_mart.foundation.utility.FilterComparator.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator クラスを使用してください。
FilterComparator(Comparator) - class jp.co.intra_mart.foundation.utility.FilterComparator のコンストラクタ
推奨されていません。 指定されれたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
FilterHTTPActionEvent - class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent.
Application Runtime で実行されるイベントのための フィルターイベントの抽象実装です。
FilterHTTPActionEvent() - class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent のコンストラクタ
指定のイベントをラップするためのフィルターを作成します。
FilterHTTPActionEventChain - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain.
FilterHTTPActionEventChain は、FilterHTTPActionEvent によって提供され、 FilterHTTPActionEvent へのフィルタリングされた要求のチェーンに対する ビューを提供します。
FilterMessageReporter - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter.
メッセージ出力ストリームをフィルタ処理するクラスのスーパークラスです。
FilterMessageReporter(MessageReporter) - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter のコンストラクタ
指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。
FilterMessageReporter - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter クラスを使用してください。
FilterMessageReporter(MessageReporter) - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter のコンストラクタ
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。
FilterServletInputStream - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream.
InputStream を ServletInputStream に変換するためのラッパです。
FilterServletInputStream(InputStream) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のコンストラクタ
指定の入力を基礎入力とするサーブレット入力ストリームを作成します。
FixedSizeMap - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap.
LRU(Least Recently Used) アルゴリズムによる Map インターフェースの実装を提供します。
FixedSizeMap(int) - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のコンストラクタ
指定されたサイズの領域を持つマップを構築します。
FixedSizeMap - class jp.co.intra_mart.foundation.utility.FixedSizeMap.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap クラスを使用してください。
FixedSizeMap(int) - class jp.co.intra_mart.foundation.utility.FixedSizeMap のコンストラクタ
推奨されていません。 指定されたサイズの領域を持つマップを構築します。
ForbiddenException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException.
アクセス権限がないことを通知する例外です。
ForbiddenException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException のコンストラクタ
指定のメッセージを持つ例外を作成します。
ForbiddenException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
ForbiddenException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException のコンストラクタ
例外を作成します。
ForecastParameters - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters.
予測パラメータ情報クラス
機能は以下の通り
予測パラメータ情報を保持します。
ForecastParameters() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のコンストラクタ
予測パラメータ情報を作成します。
ForecastParametersList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList.
需要予測パラメータ情報クラス
機能は以下の通り
需要予測パラメータ情報をテーブル型で保持します。
ForecastParametersList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList のコンストラクタ
需要予測パラメータ情報を作成します。
ForecastParametersList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList のコンストラクタ
需要予測パラメータ情報を作成します。
ForecastValues - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues.
需要予測値のデータ転送情報クラス
機能は以下の通り
需要予測値のデータ転送情報を保持します。
ForecastValues() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のコンストラクタ
需要予測値のデータ転送情報を作成します。
ForecastValues(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のコンストラクタ
需要予測値のデータ転送情報を作成します。
FormTEI - class jp.co.intra_mart.framework.base.web.tag.FormTEI.
Formタグの拡張情報です。
FormTEI() - class jp.co.intra_mart.framework.base.web.tag.FormTEI のコンストラクタ
FormTEIを新規に生成します。
FormTag - class jp.co.intra_mart.framework.base.web.tag.FormTag.
FORMタグです。
FormTag() - class jp.co.intra_mart.framework.base.web.tag.FormTag のコンストラクタ
FormTagを新規に生成します。
FormTagBeanInfo - class jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo.
FormTagのBeanInfoです。
FormTagBeanInfo() - class jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo のコンストラクタ
FormTagBeanInfoを新規に生成します。
FormatValidator - class jp.co.intra_mart.framework.base.service.validator.FormatValidator.
文字列の不正文字（フォーマット）チェックを行います。
FormatValidator() - class jp.co.intra_mart.framework.base.service.validator.FormatValidator のコンストラクタ

FoundationException - exception jp.co.intra_mart.foundation.exception.FoundationException.
システム基盤共通例外クラス。
FoundationException() - class jp.co.intra_mart.foundation.exception.FoundationException のコンストラクタ
コンストラクタ。
FoundationException(String) - class jp.co.intra_mart.foundation.exception.FoundationException のコンストラクタ
コンストラクタ。
FoundationException(Throwable) - class jp.co.intra_mart.foundation.exception.FoundationException のコンストラクタ
コンストラクタ。
FoundationException(String, Throwable) - class jp.co.intra_mart.foundation.exception.FoundationException のコンストラクタ
コンストラクタ。
FoundationRuntimeException - exception jp.co.intra_mart.foundation.exception.FoundationRuntimeException.
システム基盤共通ランタイム例外クラス。
FoundationRuntimeException() - class jp.co.intra_mart.foundation.exception.FoundationRuntimeException のコンストラクタ
コンストラクタ。
FoundationRuntimeException(String) - class jp.co.intra_mart.foundation.exception.FoundationRuntimeException のコンストラクタ
コンストラクタ。
FoundationRuntimeException(Throwable) - class jp.co.intra_mart.foundation.exception.FoundationRuntimeException のコンストラクタ
コンストラクタ。
FoundationRuntimeException(String, Throwable) - class jp.co.intra_mart.foundation.exception.FoundationRuntimeException のコンストラクタ
コンストラクタ。
FrameTEI - class jp.co.intra_mart.framework.base.web.tag.FrameTEI.
Frameタグの拡張情報です。
FrameTEI() - class jp.co.intra_mart.framework.base.web.tag.FrameTEI のコンストラクタ
FrameTEIを新規に生成します。
FrameTag - class jp.co.intra_mart.framework.base.web.tag.FrameTag.
FRAMEタグです。
FrameTag() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のコンストラクタ
FrameTagを新規に生成します。
FrameTagBeanInfo - class jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo.
FrameTagのBeanInfoです。
FrameTagBeanInfo() - class jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo のコンストラクタ
FrameTagBeanInfoを新規に生成します。
FrameworkException - exception jp.co.intra_mart.framework.system.exception.FrameworkException.
フレームワークに共通するの例外のスーパークラスです。
FrameworkException() - class jp.co.intra_mart.framework.system.exception.FrameworkException のコンストラクタ
詳細メッセージを指定しないで FrameworkException を構築します。
FrameworkException(String) - class jp.co.intra_mart.framework.system.exception.FrameworkException のコンストラクタ
指定された詳細メッセージを持つ FrameworkException を構築します。
FrameworkException(Throwable) - class jp.co.intra_mart.framework.system.exception.FrameworkException のコンストラクタ
この例外の発生原因となる例外を持つ FrameworkException を構築します。
FrameworkException(String, Throwable) - class jp.co.intra_mart.framework.system.exception.FrameworkException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkException を構築します。
FrameworkParameterSettingFilter - class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter.
推奨されていません。 このフィルタは下位互換のためのフィルタです。将来廃止される可能性があります。
FrameworkParameterSettingFilter() - class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter のコンストラクタ
推奨されていません。
FrameworkRuntimeException - exception jp.co.intra_mart.framework.system.exception.FrameworkRuntimeException.
フレームワーク内で発生したランタイム例外です。
FrameworkRuntimeException() - class jp.co.intra_mart.framework.system.exception.FrameworkRuntimeException のコンストラクタ
詳細メッセージを指定しないで FrameworkRuntimeException を構築します。
FrameworkRuntimeException(String) - class jp.co.intra_mart.framework.system.exception.FrameworkRuntimeException のコンストラクタ
指定された詳細メッセージを持つ FrameworkRuntimeException を構築します。
FrameworkRuntimeException(Throwable) - class jp.co.intra_mart.framework.system.exception.FrameworkRuntimeException のコンストラクタ
この例外の発生原因となる例外を持つ FrameworkRuntimeException を構築します。
FrameworkRuntimeException(String, Throwable) - class jp.co.intra_mart.framework.system.exception.FrameworkRuntimeException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkRuntimeException を構築します。
FrameworkTagException - exception jp.co.intra_mart.framework.base.web.tag.FrameworkTagException.
拡張タグの例外です。
FrameworkTagException() - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のコンストラクタ
詳細メッセージを指定しないで FrameworkTagException を構築します。
FrameworkTagException(String) - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のコンストラクタ
指定された詳細メッセージを持つ FrameworkTagException を構築します。
FrameworkTagException(String, Throwable) - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkTagException を構築します。
FrameworkTagException(Throwable) - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のコンストラクタ
この例外の発生原因となる例外を持つ FrameworkTagException を構築します。
FrameworkTagParam - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam.
タグに追加されるパラメータです。
FrameworkTagParam() - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam のコンストラクタ
FrameworkTagParamを新規に生成します。
FunctionContainer - class jp.co.intra_mart.foundation.scenario.FunctionContainer.
FunctionContainer クラスは、ファンクション・コンテナとなるスクリプトを コンパイルして実行可能な環境を提供します。
FunctionContainer() - class jp.co.intra_mart.foundation.scenario.FunctionContainer のコンストラクタ
新しいインスタンスを構築します。
FunctionContainer(Reader) - class jp.co.intra_mart.foundation.scenario.FunctionContainer のコンストラクタ
新しいインスタンスを構築します。
FunctionContainer(String) - class jp.co.intra_mart.foundation.scenario.FunctionContainer のコンストラクタ
新しいインスタンスを構築します。
FunctionContainerFile - class jp.co.intra_mart.foundation.scenario.FunctionContainerFile.
FunctionContainerFile クラスは、ファンクション・コンテナとなるファイルを コンパイルして実行可能な環境を提供します。
FunctionContainerFile(String, Locale) - class jp.co.intra_mart.foundation.scenario.FunctionContainerFile のコンストラクタ
ファンクション・コンテナをコンパイルします。
FunctionContainerFile(String) - class jp.co.intra_mart.foundation.scenario.FunctionContainerFile のコンストラクタ
ファンクション・コンテナをコンパイルします。
fetch(String, int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 SELECT文を発行してデータベースから指定範囲のデータを取得する

field - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser の変数
に対応するCurlFieldBean
fieldsList - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser の変数
に対応するCurlFieldBeanクラスのインスタンス格納用リスト
files(int) - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のメソッド
この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
files() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ディレクトリ中のファイルの一覧を取得します。
files(int) - class jp.co.intra_mart.foundation.utility.file.Directory のメソッド
推奨されていません。 この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
finalize() - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
このオブジェクトをクリーンアップします。
finalize() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
このオブジェクトへの参照はもうないとガーベージコレクションによって 判断されたときに、ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のメソッド
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のメソッド
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 このオブジェクトへの参照はもうないとガーベージコレクションによって 判断されたときに、ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.foundation.utility.report.FileReporter のメソッド
推奨されていません。 このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
findClass(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader のメソッド
指定されたクラスを探します。
findDirectory(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
findDirectory(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
findExtendedBaseAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap のメソッド
拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を取得します。
findExtendedBaseModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap のメソッド
拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。
findExtendedBaseModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap のメソッド
拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。
findExtendedInternationalAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap のメソッド
拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を取得します。
findExtendedInternationalModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap のメソッド
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
findExtendedInternationalModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap のメソッド
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
findExtendedTerminableAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap のメソッド
拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を取得します。
findExtendedTerminableInternationalAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap のメソッド
拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を取得します。
findExtendedTerminableInternationalModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap のメソッド
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
findExtendedTerminableInternationalModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap のメソッド
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
findExtendedTerminableModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap のメソッド
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
findExtendedTerminableModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap のメソッド
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
findFile(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
findFile(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
findInternationalAccessor(Locale) - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap のメソッド
指定された言語に該当する国際化アクセサを取得します。
findInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
指定された言語に該当する国際化モデルを取得します。
findInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap のメソッド
指定された言語に該当する国際化モデルを取得します。
findLibrary(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader のメソッド
ネイティブライブラリの絶対パス名を返します。
findLoginGroupDataSource() - class jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedDataSource のメソッド
セッション情報からログイングループに設定されているデータソースを取得します。
findLoginGroupDataSource() - class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource のメソッド
このオブジェクトがラップするデータソースを返します。
findPath(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
findPath() - class jp.co.intra_mart.foundation.service.provider.HomeDirectory の static メソッド
システムのホームディレクトリを返します。
findPath(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
findResource(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
指定された名前を持つリソースを探します。
findResources(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
指定された名前を持つすべてのリソースを表す URL の Enumeration を返します。
findTerminableAccessor(Date) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap のメソッド
指定された日付に該当する期間化アクセサを取得します。
findTerminableInternationalAccessor(Locale) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap のメソッド
指定された言語に該当する期間国際化アクセサを取得します。
findTerminableInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
指定された言語に該当する期間国際化モデルを取得します。
findTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap のメソッド
指定された言語に該当する期間国際化モデルを取得します。
findTerminableModel(Date) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
指定された日時に該当する期間化モデルを取得します。
findTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap のメソッド
指定された日付に該当する期間化モデルを取得します。
finish() - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream のメソッド
出力ストリームへのエンコードデータの書き込みを終了します。
finish() - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のメソッド
バッファに保存してあるデータを書き出します。
finish() - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream のメソッド
推奨されていません。 出力ストリームへのエンコードデータの書き込みを終了します。
finish() - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のメソッド
推奨されていません。 バッファに保存してあるデータを書き出します。
fire() - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のメソッド
スレッド実行されるロジック。
fire() - class jp.co.intra_mart.foundation.utility.ExtendedThread のメソッド
推奨されていません。 スレッド実行されるロジック。
fire(Event, DataAccessController) - interface jp.co.intra_mart.framework.base.event.EventTrigger のメソッド
イベントに対する処理を行います。
fire(Event, DataAccessController) - class jp.co.intra_mart.framework.base.event.EventTriggerAdapter のメソッド
イベントに対する処理を行います。
fire(Event) - class jp.co.intra_mart.framework.base.event.EventTriggerAdapter のメソッド
イベントに対する処理を行います。
fire(Event, DataAccessController) - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean のメソッド
イベントに対する処理です。
fire(Event) - class jp.co.intra_mart.framework.base.event.StandardEventListener のメソッド
イベントに対する処理です。
fireAll(Event, DataAccessController) - class jp.co.intra_mart.framework.base.event.EventTriggerList のメソッド
すべてのトリガに対してイベントの処理を行います。
floatValue(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 浮動小数点数(float)表現された数値として取得します。
floatValue(String, float) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 浮動小数点数(float)表現された数値として取得します。
floatValue() - class jp.co.intra_mart.common.aid.jdk.util.Counter のメソッド
カウンターの現在の値を float 型として返します。
floatValue() - class jp.co.intra_mart.foundation.utility.Counter のメソッド
推奨されていません。 カウンターの現在の値を float 型として返します。
flush() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
書き出しストリーム内のデータをすべて出力。
flush() - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
この出力ストリームをフラッシュします。
flush() - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のメソッド
ストリームをフラッシュします。
flush() - class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream のメソッド
この出力ストリームをフラッシュし、 バッファに入っている出力バイトをすべて強制的に書き込みます。
flush() - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のメソッド
キューに溜まっているすべてのイベントリスナーを実行します。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter のメソッド
このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のメソッド
このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter のメソッド
このオブジェクトのバッファの情報をすべて出力します。
flush() - interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter のメソッド
このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter のメソッド
このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
ストリームをフラッシュします。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter のメソッド
ストリームをフラッシュします。
flush() - interface jp.co.intra_mart.foundation.service.provider.SystemReporter のメソッド
ストリームをフラッシュします。
flush() - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 キューに溜まっているすべてのイベントリスナーを実行します。
flush() - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 書き出しストリーム内のデータをすべて出力。
flush() - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のメソッド
推奨されていません。 ストリームをフラッシュします。
flush() - class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter のメソッド
推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.foundation.utility.report.FileReporter のメソッド
推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter のメソッド
推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
flush() - interface jp.co.intra_mart.foundation.utility.report.MessageReporter のメソッド
推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter のメソッド
推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 ストリームをフラッシュします。
flush() - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter のメソッド
推奨されていません。 ストリームをフラッシュします。
flushBuffer() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
バッファリングされているコンテンツを強制的にクライアントに出力します。
flushBuffer(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
バッファリングされているコンテンツを強制的にクライアントに出力します。
flushBuffer(HttpServletRequest, ExtendedHttpServletResponse) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
バッファリングされているコンテンツを強制的にクライアントに出力します。
flushBuffer(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
バッファリングされているコンテンツを強制的にクライアントに出力します。
forceLogin(LoginRequestInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
強制ログイン処理を行います。
forceLogin(LoginRequestInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
強制ログイン処理を行います。
forward(HttpServletRequest, HttpServletResponse, String) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
指定したURLにフォワードします。
forward(String) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
指定したURLにフォワードします。
freeMemory() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
サーバシステムの空きメモリの量を返します。

G

GCConditioner - interface jp.co.intra_mart.foundation.service.provider.GCConditioner.
GarbageController クラスが gc を実行するかどうか判断するための インターフェースを提供します。
GET - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

GET_ENTIRETY - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

GET_ENTIRETY_KEY - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

GET_ITEM - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

GET_ITEM_KEY - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

GET_SUBSET - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

GO_OUT - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
外出フラグ
GarbageController - class jp.co.intra_mart.foundation.service.provider.GarbageController.
ガーベージコレクタを実行するクラスです。
GeneralDataInfo - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo.
一般データ情報クラス
機能は以下の通り
一般データの情報を保持します。
GeneralDataInfo() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のコンストラクタ
一般データ情報を作成します。
GenericAttributes - class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes.
汎用属性の集合です。
GenericAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes のコンストラクタ
GenericAttributesを新規に生成します。
GenericBaseModel - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel.
基本モデルの汎用的な抽象クラスです。
GenericBaseModel() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のコンストラクタ

GenericEJBEventListener - class jp.co.intra_mart.framework.base.event.GenericEJBEventListener.
EJBを利用する汎用的なイベントリスナです。
GenericEJBEventListener(GenericEJBEventListenerAgentHome, String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListener のコンストラクタ
GenericEJBEventListenerを新規に生成します。
GenericEJBEventListenerAgent - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent.
汎用的なEJB用のイベントリスナのリモートインタフェースです。
GenericEJBEventListenerAgentBean - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean.
EJBを利用する汎用的なイベントリスナーのBeanです。
GenericEJBEventListenerAgentBean() - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean のコンストラクタ
GenericEJBEventListenerAgentBeanを新規に生成します。
GenericEJBEventListenerAgentHome - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome.
リモートインタフェースGenericEJBEventListenerAgentを取得するホームインタフェースです。
GenericEJBEventListenerAgentLocal - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocal.
汎用的なEJB用のイベントリスナのローカルインタフェースです。
GenericEJBEventListenerAgentLocalHome - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocalHome.
ローカルインタフェースGenericEJBEventListenerAgentLocalを取得するホームインタフェースです。
GenericEJBEventListenerFactory - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory.
GenericEJBEventListenerを生成します。
GenericEJBEventListenerFactory() - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory のコンストラクタ
GenericEJBEventListenerFactoryを新規に生成します。
GenericEJBEventListenerLocal - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal.
ローカルEJBを利用する汎用的なイベントリスナです。
GenericEJBEventListenerLocal(GenericEJBEventListenerAgentLocalHome, String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal のコンストラクタ
GenericEJBEventListnerLocalを新規に生成します。
GenericEJBEventListenerLocalFactory - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory.
GenericEJBEventListnerLocalを新規に生成します。
GenericEJBEventListenerLocalFactory() - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory のコンストラクタ
GenericEJBEventListnerLocalFactoryを新規に生成します。
GenericEventListener - class jp.co.intra_mart.framework.base.event.GenericEventListener.
汎用的なイベントリスナです。
GenericEventListener() - class jp.co.intra_mart.framework.base.event.GenericEventListener のコンストラクタ
GenericEventListenerを新規に生成します。
GenericEventListenerFactory - class jp.co.intra_mart.framework.base.event.GenericEventListenerFactory.
GenericEventListenerを生成するイベントリスナファクトリです。
GenericEventListenerFactory() - class jp.co.intra_mart.framework.base.event.GenericEventListenerFactory のコンストラクタ
GenericEventListenerFactoryを新規に生成します。
GenericInternationalModel - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel.
国際化モデルの汎用的な抽象クラスです。
GenericInternationalModel() - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のコンストラクタ

GenericInternationalModelMap - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap.
国際化モデルマッピングの汎用的な抽象クラスです。
GenericInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のコンストラクタ

GenericTerminableInternationalModel - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel.
期間国際化モデルの汎用的な抽象クラスです。
GenericTerminableInternationalModel() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のコンストラクタ

GenericTerminableInternationalModelMap - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap.
期間国際化モデルマッピングの汎用的な抽象クラスです。
GenericTerminableInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のコンストラクタ

GenericTerminableModel - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel.
期間化モデルの汎用的な抽象クラスです。
GenericTerminableModel() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のコンストラクタ

GenericTerminableModelMap - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap.
期間化モデルマッピングの汎用的な抽象クラスです。
GenericTerminableModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のコンストラクタ

GenericURLBuilder - class jp.co.intra_mart.jssp.net.GenericURLBuilder.
スクリプト開発モデルの画面を呼び出すための URL を作成するビルダです。
GenericURLBuilder(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.jssp.net.GenericURLBuilder のコンストラクタ
新しいビルダを作成します。
GlAcc - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc.
勘定項目情報クラス
機能は以下の通り
勘定項目の情報を保持します。
GlAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のコンストラクタ
勘定項目情報を作成します。
GlAccController - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController.
勘定科目コントローラクラス
機能は以下の通り
勘定科目の情報を取得します。
GlAccController(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のコンストラクタ
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
GlAccController(String, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のコンストラクタ
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
GlAccList - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList.
勘定項目一覧クラス
機能は以下の通り
勘定項目の情報を一覧形式で取得します。
GlAccList(String, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList のコンストラクタ
executeBapiを呼び出し勘定項目一覧を作成します。
GoodsMvtCode - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode.
在庫移動に対するコードのトランザクションへの割当情報クラス
機能は以下の通り
在庫移動に対するコードのトランザクションへの割当情報を保持します。
GoodsMvtCode() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode のコンストラクタ
在庫移動に対するコードのトランザクションへの割当情報を作成します。
GoodsMvtCreate - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate.
入出庫伝票登録情報クラス
機能は以下の通り
入出庫伝票登録情報を保持します。
GoodsMvtCreate() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のコンストラクタ
コンストラクタ。
GoodsMvtCreate(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のコンストラクタ
コネクションマネージャーを引数に持つコンストラクタ。
GoodsMvtCreate(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のコンストラクタ
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
GoodsMvtCreateController - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController.
入庫伝票登録コントローラクラス
機能は以下の通り
入庫伝票を登録します。
GoodsMvtCreateController() - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController のコンストラクタ
GoodsMvtCreateControllerのコンストラクタを生成します。
GoodsMvtCreateController(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController のコンストラクタ
GoodsMvtCreateControllerのコンストラクタを生成します。
GoodsMvtCreateController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController のコンストラクタ
GoodsMvtCreateControllerのコンストラクタを生成します。
GoodsMvtGetItems - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems.
出庫確認一覧照会情報クラス
機能は以下の通り
出庫確認一覧照会情報を保持します。
GoodsMvtGetItems(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のコンストラクタ
出庫確認一覧照会情報を作成します。
GoodsMvtGetItemsController - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController.
入出庫伝票一覧取得コントローラクラス
機能は以下の通り
入出庫伝票の一覧を取得します。
GoodsMvtGetItemsController() - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController のコンストラクタ
コンストラクタ生成
GoodsMvtGetItemsController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController のコンストラクタ
コンストラクタ生成
GoodsMvtHeader - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader.
入出庫伝票ヘッダデータ情報クラス
機能は以下の通り
入出庫伝票ヘッダデータ情報を保持します。
GoodsMvtHeader() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のコンストラクタ
入出庫伝票ヘッダデータ情報を作成します。
GoodsMvtHeaderList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList.
入出庫伝票明細情報クラス
機能は以下の通り
入出庫伝票明細情報を保持します。
GoodsMvtHeaderList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList のコンストラクタ
入出庫伝票明細情報を作成します。
GoodsMvtHeaderList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList のコンストラクタ
入出庫伝票明細情報を作成します。
GoodsMvtHeadret - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret.
入出庫伝票番号/入出庫伝票会計年度情報クラス
機能は以下の通り
入出庫伝票番号/入出庫伝票会計年度情報を保持します。
GoodsMvtHeadret() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret のコンストラクタ
入出庫伝票番号/入出庫伝票会計年度情報を作成します。
GoodsMvtItem - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem.
入出庫伝票明細情報クラス
機能は以下の通り
入出庫伝票明細情報を保持します。
GoodsMvtItem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のコンストラクタ
入出庫伝票明細情報を作成します。
GoodsMvtItem(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のコンストラクタ
入出庫伝票明細情報を作成します。
GoodsMvtItems - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems.
入出庫伝票明細情報クラス
機能は以下の通り
入出庫伝票明細情報を保持します。
GoodsMvtItems() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のコンストラクタ
入出庫伝票明細情報を作成します。
GoodsMvtItems(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のコンストラクタ
入出庫伝票明細情報を作成します。
GoodsMvtSerialNumber - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber.
シリアル番号情報クラス
機能は以下の通り
シリアル番号情報を保持します。
GoodsMvtSerialNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のコンストラクタ
シリアル番号情報を作成します。
GoodsMvtSerialNumber(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のコンストラクタ
シリアル番号情報を作成します。
GroupActiveSessionRegister - class jp.co.intra_mart.foundation.security.activesession.GroupActiveSessionRegister.
管理者ログイン認証リスナー実装クラス。
GroupActiveSessionRegister() - class jp.co.intra_mart.foundation.security.activesession.GroupActiveSessionRegister のコンストラクタ

GroupSecurityHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler.
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
GroupSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler, String) - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler のコンストラクタ
ログイングループセッション環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
GroupSuperUserAccessor - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor.
グループ管理者アクセッサインタフェース。
GroupSuperUserInitialServlet - class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet.
グループ管理者初期アクセスサーブレット。
GroupSuperUserInitialServlet() - class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet のコンストラクタ

GroupSuperUserPostWriterListener - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener.
グループ管理者情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
GroupSuperUserQueryWriterListener - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener.
グループ管理者情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
GroupSuperUserReaderDecorator - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator.
管理者情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
get(int) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リスト内の指定された位置にある要素を返します。
get() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
ファイルの内容をバイト配列として取得します。
get(Object) - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
マップが、指定されたキーにマッピングしている値を返します。
get(String) - class jp.co.intra_mart.foundation.acssecurity.Logingp のメソッド
推奨されていません。 代替えメソッドはありません。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel のメソッド
指定の属性が保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel のメソッド
指定の属性が保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel のメソッド
指定の属性が保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel のメソッド
指定の属性が保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性が保持する値を取得します。
get(String, Date) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性が、指定の日時に保持している値を取得します。
get(String, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性が、指定の言語で保持している値を取得します。
get(String, Date, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性が、指定の日時、言語で保持している値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のメソッド
指定の属性が保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のメソッド
指定の属性が保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
指定の属性が保持する値を取得します。
get(String, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
指定の属性が指定の言語で保持する値を取得します。
get(int) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リスト内の指定された位置にある要素を返します。
get(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
データを取得します。
get() - class jp.co.intra_mart.foundation.service.client.information.Identifier のメソッド
一意性を保証されたＩＤを取得します。
get(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
データを取得します。
get(String) - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
データを取得します。
get(String) - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
データを取得します。
get(Object) - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 マップが、指定されたキーにマッピングしている値を返します。
getAbart() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
承認タイプを取得します。
getAbcId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ABC 区分を取得します。
getAbrli() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
内部納入日程番号を取得します。
getAcIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
レコード番号を取得します｡
getAccept() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性acceptの値を取得します。
getAcceptTime() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
イベント実行要求を受け付けたおよその時刻を返します。
getAcceptcharset() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性accept-charsetの値を取得します。
getAccessControllerId() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel のメソッド
アクセスコントローラIDを取得します。
getAccessControllerId() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel のメソッド
アクセスコントローラIDを取得します。
getAccessControllerId() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel のメソッド
アクセスコントローラIDを取得します。
getAccessControllerId() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel のメソッド
アクセスコントローラIDを取得します。
getAccessControllerId() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel のメソッド
アクセスコントローラIDを取得します。
getAccessControllerName() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel のメソッド
アクセスコントローラ名を取得します。
getAccessInfo() - class jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem のメソッド

getAccessKey(String, String) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil の static メソッド
かんたんログイン用のアクセスキーを取得します。
getAccessKeyWithRequestParameter(String, String) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil の static メソッド
かんたんログイン用のアクセスキーをリクエストパラメータの形式で取得します。
getAccessSeq() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
検索順序 - 検索番号を取得します。
getAccessSeq() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
検索順序 - 検索番号を取得します。
getAccesskey() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
accesskeyを取得します。
getAccesskey() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
accesskeyを取得します。
getAccntAsgn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先の勘定設定グループを取得します。
getAccntAsgn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAccntAsgn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先の勘定設定グループを取得します。
getAccntAsgn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAccount(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 AccountManager.exportData(String category, OutputStream outputStream)に置き換えられました。
getAccount(String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウント情報を取得する。
getAccount(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント情報を取得する。
getAccount(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
ユーザIDにマッチしたユーザデータを１件取得します。
getAccount() - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler のメソッド
設定されているアカウントＩＤを返します。
getAccountCount(String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウント数を取得する。
getAccountCount(String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント数を取得する。
getAccountFlag() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
アカウントフラグを取得します。
getAccountFlag() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
アカウントフラグを取得します。
getAccountGlList() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細一覧を取得します｡
getAccountKe() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
勘定キー 見越/引当を取得します。
getAccountMenuTree(String, String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定したアカウントのメニュー構成を取得します。
getAccountPayableList() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細一覧を取得します｡
getAccountRole(String, String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウントロール情報を取得する。
getAccountRole(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントロール情報を取得する。
getAccountRoleIds(String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウントロールIDをすべて取得する。
getAccountRoleIds(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントロールIDをすべて取得する。
getAccountRoleIds(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントロールIDをすべて取得します。
getAccountRoles(String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウントロール情報をすべて取得する。
getAccountRoles(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントロール情報をすべて取得する。
getAccountRoles(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントロールをすべて取得します。
getAccountRoles(String, Date) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
有効期間内のアカウントロールをすべて取得します。
getAccountTaxList() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
税明細一覧を取得します｡
getAccountView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
会計ビューを取得します。
getAccountView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
会計ビューを取得します。
getAccountView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
会計ビューを取得します。
getAccountkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
勘定キーを取得します。
getAccounts() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
ログイングループ内のすべてのユーザアカウントを取得します。
getAccountsByUserIds(String, String[]) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
指定されたユーザIDのアカウント情報をすべて取得する。
getAccountsByUserIds(String, String[]) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
指定されたユーザIDのアカウント情報をすべて取得する。
getAccountsByUserIds(String[]) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
ログイングループ内で引数指定したユーザIDのユーザアカウントをすべて取得します。
getAccruals() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
見越額関連条件 (運賃など)を取得します。
getAccruals() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
見越額関連条件 (運賃など)を取得します。
getAcctAssgt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目の勘定設定グループを取得します。
getAcctasgnmt() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目の勘定設定グループを取得します。
getAcctasscat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
勘定設定カテゴリを取得します。
getAcctstatus() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
会計への転記ステータスを取得します。
getAcknReqd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買発注請求書依頼を取得します。
getAcknowlNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買発注請書番号を取得します。
getActAtCus() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
得意先での自社勘定コードを取得します。
getActAtVen() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
仕入先での自社勘定コードを取得します。
getActivationDate() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
役職情報の有効開始日を取得します。
getActivationDate() - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
開始時間を取得します。
getActivationKey() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ソースエンティティのライフタイム期間の有効開始日時を取得します。
getActiveSessionBindingListenerSessionName() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
アクティブなセッション情報を登録・削除するために使用するセッション名を取得します。
getActiveSessionInfo(String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたセッションIDのアクティブなセッション情報を取得します。
getActiveSessionInfo(String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたセッションIDのアクティブなセッション情報を取得します。
getActiveSessionInfo(String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたセッションIDのアクティブなセッション情報を取得します。
getActiveSessionInfos(String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
アクティブなすべてのセッション情報を取得します。
getActiveSessionInfos(String, String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたユーザのアクティブなセッション情報を取得します。
getActiveSessionInfos(String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたログインタイプのアクティブなセッション情報を取得します。
getActiveSessionInfos(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
アクティブなすべてのセッション情報を取得します。
getActiveSessionInfos(String, String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたユーザのアクティブなセッション情報を取得します。
getActiveSessionInfos(String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたログインタイプのアクティブなセッション情報を取得します。
getActiveSessionInfos(String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
アクティブなすべてのセッション情報を取得します。
getActiveSessionInfos(String, String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたユーザのアクティブなセッション情報を取得します。
getActiveSessionInfos(String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたログインタイプのアクティブなセッション情報を取得します。
getActiveSessionInvalidatedPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたアクティブなセッション情報が無効化されたされていた場合の遷移先ページURLを取得します。
getActiveSessionInvalidatedPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたアクティブなセッション情報が無効化されたされていた場合の遷移先ページURLを取得します。
getActiveSessionInvalidatedPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたアクティブなセッション情報が無効化されたされていた場合の遷移先ページURLを取得します。
getActivity() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ネットワーク/標準ネットワークの活動番号を取得します。
getActivity() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
作業番号を取得します。
getActivity() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
処理タイプ - R/3 Enterprise で使用不可能を取得します。
getActivity() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
作業番号を取得します。
getActivity() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
作業番号を取得します。
getActivityCosts() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の原価を取得します。
getActtype() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動タイプを取得します。
getActtype() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
活動タイプを取得します。
getActtype() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
活動タイプを取得します。
getActtype() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
活動タイプを取得します。
getActualCost() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
実際原価を取得します。
getActualDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
実績日付(マイルストーン通過)を取得します。
getActualFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
実績終了日: 実行 (日付)を取得します。
getActualStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
実績開始日: 実行 (日付)を取得します。
getActualTime() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
実績日/時間(マイルストーン適合)を取得します。
getAddToStk() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
既存在庫への追加許可を取得します。
getAddValDy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
有効日からの日数を取得します。
getAddValDy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAddValDy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
有効日からの日数を取得します。
getAddValDy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAddrLink() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
住所コードへのリンクを取得します。
getAddrNo() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
アドレス番号を取得します。
getAddrNo() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
アドレス番号を取得します。
getAddrNo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
アドレス: アドレス番号を取得します。
getAddrNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
アドレス番号を取得します。
getAddrOrig() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
コピー元住所を取得します。
getAddrType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
アドレスタイプ (1=組織、2=個人、3=取引先担当者)を取得します。
getAddress() - class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor のメソッド
アドレスを返します。
getAddress() - class jp.co.intra_mart.common.aid.jdk.java.net.Localhost のメソッド
このコンピュータのＩＰアドレスを返します。
getAddress() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
住所を取得します。
getAddress(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
住所を取得します。
getAddress(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
住所を取得します。
getAddress(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
住所を取得します。
getAddress() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
住所を取得します。
getAddress() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を取得します。
getAddress(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を取得します。
getAddress(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を取得します。
getAddress(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を取得します。
getAddress() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
住所を取得します。
getAddress() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
住所を取得します。
getAddress(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
住所を取得します。
getAddress() - interface jp.co.intra_mart.foundation.mail.javamail.model.MailAddress のメソッド
メールアドレスを取得します。
getAddress() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
住所を取得します。
getAddress() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
住所を取得します。
getAddress() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
住所を取得します。
getAddress() - class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor のメソッド
推奨されていません。 アドレスを返します。
getAddress() - class jp.co.intra_mart.foundation.utility.net.Localhost のメソッド
推奨されていません。 このコンピュータのＩＰアドレスを返します。
getAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
住所1を取得します。
getAddress1(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
住所1を取得します。
getAddress1(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
住所1を取得します。
getAddress1(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
住所1を取得します。
getAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
住所1を取得します。
getAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
住所1を取得します。
getAddress1(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
住所1を取得します。
getAddress1(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
住所1を取得します。
getAddress1(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
住所1を取得します。
getAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
住所1を取得します。
getAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を取得します。
getAddress1(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を取得します。
getAddress1(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を取得します。
getAddress1(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を取得します。
getAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
住所1を取得します。
getAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所1を取得します。
getAddress1(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所1を取得します。
getAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
住所2を取得します。
getAddress2(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
住所2を取得します。
getAddress2(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
住所2を取得します。
getAddress2(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
住所2を取得します。
getAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
住所2を取得します。
getAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
住所2を取得します。
getAddress2(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
住所2を取得します。
getAddress2(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
住所2を取得します。
getAddress2(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
住所2を取得します。
getAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
住所2を取得します。
getAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を取得します。
getAddress2(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を取得します。
getAddress2(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を取得します。
getAddress2(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を取得します。
getAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
住所2を取得します。
getAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所2を取得します。
getAddress2(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所2を取得します。
getAdrNotes() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
住所注記を取得します。
getAdrNotes() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
住所注記を取得します。
getAdrNotes() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
住所注記を取得します。
getAgmtItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買契約の明細番号を取得します。
getAgreement() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買契約番号を取得します｡
getAgreement() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買契約番号を取得します。
getAllAccounts(String) - class jp.co.intra_mart.foundation.security.account.CsvAccountBackup のメソッド

getAllAccounts(String) - class jp.co.intra_mart.foundation.security.account.StandardAccountBackup のメソッド

getAllCategorizedItems(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のメソッド
商品カテゴリに分類されているすべての商品の情報を返します。
getAllContext() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager のメソッド
マネージャーが保持するすべての HTTP コンテキストを返します。
getAllIds() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager のメソッド
現在有効なすべての HttpSession のセッションＩＤを返します。
getAllIds() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager のメソッド
現在有効なすべての HttpSession のセッションＩＤを返します。
getAllParentRoleIds(String, String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
すべての親ロールの一覧を取得します。
getAllParentRoleIds(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
すべての親ロールの一覧を取得する。
getAllParentRoleIds(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
全ての親ロールIDを取得します。
getAllSubRoleIds(String, String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
すべてのサブロールの一覧を取得します。
getAllSubRoleIds(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
すべてのサブロールの一覧を取得する。
getAllSubRoleIds(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
全てのサブロールサマリを取得します。
getAllVersionsList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
全バージョン一覧を取得します｡
getAllocTbl() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
商品配分表番号を取得します。
getAllowedBusTractList() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
使用可能業務トランザクションのテーブルを取得します。
getAllowedBusTractList() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
使用可能業務トランザクションのテーブルを取得します。
getAllowedWt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
許容梱包重量を取得します。
getAllowsUsers() - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のメソッド
許可ユーザを取得します。
getAllwdVol() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
許容梱包容積を取得します。
getAlphaFact() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
アルファ係数使用による基本値の平滑化を取得します。
getAltBomId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
代替 BOM 選択の方法を取得します。
getAltPayee() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
代理受取人勘定コードを取得します。
getAltPayer() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
代理支払人の勘定コードを取得します。
getAltToItm() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
代替明細を取得します。
getAltToItm() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAltUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
在庫保管単位の代替数量単位を取得します。
getAltUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ISO コードによる在庫単位の代替数量単位を取得します。
getAlternBom() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
代替 BOMを取得します。
getAlternBom() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAlternat() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
代替明細を取得します。
getAlternativeBom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
代替 BOMを取得します。
getAlttaxCls() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
代替税分類を取得します。
getAlttaxCls() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAmount() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail のメソッド
数量を取得します。
getAmount() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
数量を取得します。
getAmount(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
数量を取得します。
getAmount() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailTerminableModel のメソッド
数量を取得します。
getAmountLc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
マニュアル入力による転記金額 (国内通貨)を取得します。
getAmountLc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
マニュアル入力による転記金額 (国内通貨)を取得します。
getAmountSv() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
外部入力による販売金額 (国内通貨)を取得します。
getAmountSv() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
外部入力による販売金額 (国内通貨)を取得します。
getAnswer() - class jp.co.intra_mart.foundation.navigator.EventHistoryInfo のメソッド
質問取得
getAnswer() - class jp.co.intra_mart.foundation.navigator.SaveEventHistoryInfo のメソッド
質問取得
getAppName() - class jp.co.intra_mart.foundation.security.activesession.NavigatorInfo のメソッド
ブラウザ名を取得します。
getAppdBRec() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: バッチ製造記録の承認必須を取得します。
getApplicBy() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積提出期限を取得します。
getApplicant() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請者を取得します。
getApplicantNo() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
申請者番号を取得します。
getApplicantNo() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
申請者番号を取得します。
getApplicantPhone() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請者の電話番号を取得します。
getApplicatio() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
アプリケーションを取得します。
getApplicatio() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
アプリケーションを取得します。
getApplication(String) - interface jp.co.intra_mart.foundation.datastore.common.config.Configuration のメソッド
指定された名前に該当するアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティを定義しているアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張エンティティを定義しているアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張モデルを定義しているアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張テーブルを定義しているアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
モデルを定義しているアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
リレーションシップが定義されているアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
テーブルを定義しているアプリケーションを取得します。
getApplication() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
アプリケーション名を取得します。
getApplication(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager の static メソッド
アプリケーション情報を取得します。
getApplication() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
設定されているアプリケーションＩＤを返します。
getApplication() - class jp.co.intra_mart.framework.base.event.Event のメソッド
アプリケーションを取得します。
getApplication(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
現在のリクエストに対するアプリケーションIDを取得します。
getApplication() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
アプリケーションIDを取得します。
getApplication() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性applicationの値を取得します。
getApplication() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
アプリケーションを取得します。
getApplication() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
アプリケーションを取得します。
getApplication() - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
applicationを取得します。
getApplication() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
アプリケーションを取得します。
getApplication() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性applicationの値を取得します。
getApplicationDate() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請日を取得します。
getApplicationId() - class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet のメソッド
アプリケーションIDを取得します。
getApplicationLicense(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager の static メソッド
アプリケーションの登録ユーザ数を取得します。
getApplicationName() - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
マッパーが定義されているアプリケーション名を取得します。
getApplicationParamName() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getApplicationParamName() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
アプリケーションIDに該当するパラメータ名を取得します。
getApplicationParamName() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getApplicationParamName() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getApplicationParamName() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getApplications() - class jp.co.intra_mart.foundation.security.license.LicenseManager の static メソッド
アプリケーション情報の一覧を取得します。
getApplobject() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
テキスト: アプリケーションオブジェクトを取得します。
getApplobject() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
テキスト: アプリケーションオブジェクトを取得します。
getApplobject() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
テキスト: アプリケーションオブジェクトを取得します。
getArgument(int) - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
指定されたすべてのコマンドライン引数の引数を返します。
getArgument() - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
引数文字列を取得します。
getArgument() - class jp.co.intra_mart.foundation.page.TreeLeaf のメソッド
引数文字列を取得します。
getArgument() - interface jp.co.intra_mart.foundation.page.TreeNode のメソッド
引数文字列を取得します。
getArgument() - class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet のメソッド
ページ引数を取得します。
getArgument() - class jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet のメソッド
ページ引数を取得します。
getArgument(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
引数を取得します。
getArgumentKeys() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
引数キーの一覧を取得します。
getArgumentName() - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel のメソッド
引数名を取得します。
getArgumentValue() - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel のメソッド
引数値を取得します。
getArguments() - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
指定されたすべてのコマンドライン引数の引数を返します。
getAshost() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing のメソッド
接続先アプリケーションサーバIPアドレスを取得します。
getAshost() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing のメソッド
接続先サーバIPアドレスを取得します。
getAshost() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 接続先サーバIPアドレスを取得します｡
getAssNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
割当番号を取得します。
getAssNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAssetNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
資産番号を取得します。
getAssetNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
資産番号を取得します。
getAssetNo() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
資産番号を取得します。
getAssortMod() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品揃モジュールを取得します。
getAssortMod() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAssyScrap() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
組立不良率を取得します。
getAtItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
割当テーブルの明細番号を取得します。
getAtRelev() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
適当テーブル関連を取得します。
getAtpWrkmod() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
ATP セッション: 結果取得/新規決定 APO-ATPを取得します。
getAttachedDepartments(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
現在、ユーザが所属している組織の一覧を取得します。
getAttachedDepartments(String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
指定された日付にユーザが所属している組織の一覧を取得します。
getAttachedPublicGroups(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
現在、ユーザが所属しているパブリックグループの一覧を取得します。
getAttachedPublicGroups(String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
指定された日付にユーザが所属しているパブリックグループの一覧を取得します。
getAttachment() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
添付ファイルを取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.ActivationKey のメソッド
ライフタイム期間の有効開始日時となる属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.Column のメソッド
カラムに対応付ける属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping のメソッド
カラムに割り当てる属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey のメソッド
ライフタイム期間の有効終了日時となる属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalKey のメソッド
国際化基準項目となる属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping のメソッド
プライマリーキーとなる属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.Property のメソッド
プロパティに対応付ける属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableKey のメソッド
期間化基準項目となる属性を取得します。
getAttribute(String) - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
セッションから指定した属性の値を取得します。
getAttribute(String, String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウント属性情報を取得する。
getAttribute(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント属性情報を取得する。
getAttribute(String, String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウント属性情報を取得する。
getAttribute(String, String, String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウント属性情報を取得する。
getAttribute(String) - class jp.co.intra_mart.framework.base.session.HttpSessionObject のメソッド
推奨されていません。 指定された名前に対応するオブジェクトを取得します。
getAttribute(String) - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のメソッド
推奨されていません。 指定された名前に対応するオブジェクトを取得します。
getAttribute(String) - interface jp.co.intra_mart.framework.base.session.SessionObject のメソッド
指定された名前に対応するオブジェクトを取得します。
getAttributeName() - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel のメソッド
属性キーを取得します。
getAttributeNames(String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウント属性名の一覧を取得する。
getAttributeNames(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント属性情報の名前の一覧を取得する。
getAttributeNames(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウント属性名の一覧を取得する。
getAttributeNames() - class jp.co.intra_mart.framework.base.session.HttpSessionObject のメソッド
推奨されていません。 セッション内に存在する名前の一覧を取得します。
getAttributeNames() - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のメソッド
推奨されていません。 セッション内に存在する名前の一覧を取得します。
getAttributeNames() - interface jp.co.intra_mart.framework.base.session.SessionObject のメソッド
セッション内に存在する名前の一覧を取得します。
getAttributeValue() - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel のメソッド
属性値を取得します。
getAttributes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
指定された商品の属性情報を取得します。
getAttributes() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティに含まれる属性をすべて取得します。
getAttributes() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張エンティティに含まれる属性をすべて取得します。
getAuthCcNo() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認番号を取得します。
getAuthDate() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 承認日を取得します。
getAuthDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認日を取得します。
getAuthFlag() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 振替権限を取得します。
getAuthFlag() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 振替権限を取得します。
getAuthRefno() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 決済代行会社の権限参照コードを取得します。
getAuthRefno() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 決済代行会社の権限参照コードを取得します。
getAuthTime() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 承認時刻を取得します。
getAuthTime() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認時刻を取得します。
getAuthamount() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 承認額を取得します。
getAuthamount() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認額を取得します。
getAuthor() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
報告書提案済を取得します。
getAuthor() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
報告書提案済を取得します。
getAuthor() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
報告書提案済を取得します。
getAuthoritygroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
権限グループを取得します。
getAutoCommit() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 現在の自動コミットの状態を取得します。
getAutoCommitConditions() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
推奨されていません。 BapiController.getIgnoreErrMsgReturnTypes()に置き換えられました。
getAutoPOrd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: "購買発注自動生成"を取得します。
getAutoReset() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
予測モデル自動リセットを取得します。
getAvQtyPlt() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
プラントレベル利用可能数量を取得します。
getAvailCheckAllProjSegments() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プロジェクト間品目区分を取得します。
getAvailablePageKind() - class jp.co.intra_mart.foundation.portal.portlet.PortletMapping のメソッド
利用可能なポートレット種別の一覧を取得します。
getAvailcheck() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
利用可能在庫確認の確認グループを取得します。
getBUomIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
ISO コードでの基本数量単位を取得します。
getBaList() - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
銀行一覧を取得します｡
getBackflush() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: バックフラッシュを取得します。
getBankAcct() - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
口座番号を取得します。
getBankCtry() - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
銀行国コードを取得します。
getBankDataInfoList() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
銀行データ情報一覧を取得します｡
getBankDataInfoList() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
銀行データ情報一覧を取得します｡
getBankDataInfoList() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
銀行データ情報一覧を取得します｡
getBankDataList() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
銀行データ情報を取得します。
getBankDataList() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
銀行データ情報を取得します。
getBankDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
銀行データ情報を取得します。
getBankKey() - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
銀行コードを取得します。
getBankKey() - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
銀行コードを取得します｡
getBankList() - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
銀行一覧を取得します。
getBankList() - class jp.co.intra_mart.foundation.sap.module.accounting.BankList のメソッド
銀行一覧を取得します｡
getBankName() - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
銀行名を取得します｡
getBankName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
銀行コードを指定して銀行名を取得します。
getBankRef() - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
銀行詳細の参照詳細を取得します。
getBapiHashList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
BapiHashの一覧を取得します。
getBapiReturnErrMessage() - class jp.co.intra_mart.foundation.sap.module.AbstractController のメソッド
ＢＡＰＩの実行結果のエラーメッセージを取得します。
getBapiReturnErrMessage() - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController のメソッド
ＢＡＰＩの実行結果のエラーメッセージを取得します。
getBapiReturnList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
BapiReturnの一覧を取得します｡
getBapiReturnMessage() - class jp.co.intra_mart.foundation.sap.module.AbstractController のメソッド
設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。
getBapiReturnMessage() - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController のメソッド
設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。
getBarCode() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
バーコードエントリを取得します。
getBaseAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor のメソッド
拡張元となる基本エンティティの基本アクセサを取得します。
getBaseAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor のメソッド
この国際化アクセサが所属する基本アクセサを取得します。
getBaseAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
この期間化アクセサが所属する基本アクセサを取得します。
getBaseAccessor() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel のメソッド
基本アクセサ BaseAccessor を取得します。
getBaseAccessor() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
基本アクセサを取得します。
getBaseAccessor() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
この基本モデルに割り当てられた基本アクセサを取得します。
getBaseDn() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
ベースDNを取得する。
getBaseModel() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
基本モデルを取得します。
getBaseName() - class jp.co.intra_mart.foundation.datastore.exception.MapperException のメソッド
メッセージを取得するためのリソースバンドルの基底名を返します。
getBaseQty() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
基本数量を取得します。
getBaseQtyPlan() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出荷の能力計画のための基本数量を取得します。
getBaseTable() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
基本テーブルを取得します。
getBaseUom() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
基本数量単位を取得します。
getBaseUom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
基本数量単位を取得します。
getBaseUom() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
基本数量単位を取得します。
getBaseUom() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
基本数量単位を取得します。
getBaseUomIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードでの基本数量単位を取得します。
getBasicLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
基本明細を取得します。
getBasicMatl() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
主構成物質を取得します。
getBasicValue() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
基準値を取得します。
getBasicValue1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
第二指図の基準値を取得します。
getBasicValue2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
第二指図の基準値を取得します。
getBasicValuePp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間の基準値を取得します。
getBasicValuePp1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間における第二指図の基準値を取得します。
getBasicValuePp2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間における第二指図の基準値を取得します。
getBasicView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
基本データビューを取得します。
getBaslineNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
代替: 基本明細参照を取得します。
getBatch() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ロット番号を取得します。
getBatch() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
ロット番号を取得します。
getBatch() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
ロット番号を取得します。
getBatch() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
ロットを取得します。
getBatch() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ロット番号を取得します。
getBatch() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBatch() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
ロット番号を取得します。
getBatch(String, String) - class jp.co.intra_mart.foundation.security.StandardBatchAccessor のメソッド
バッチを取得します。
getBatch(String, String) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
バッチ情報を取得します。
getBatch(String) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチ情報を取得します。
getBatchId() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチＩＤを取得します。
getBatchId() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
バッチIDを取得します。
getBatchIds(String) - class jp.co.intra_mart.foundation.security.StandardBatchAccessor のメソッド
バッチIDの一覧を取得します。
getBatchIds(String) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
すべてのバッチIDを取得します。
getBatchIds() - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチIDの一覧を取得します。
getBatchMgmt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ロット管理所要量区分を取得します。
getBatchMgmt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ロット管理所要量区分を取得します。
getBatchName() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
バッチ名を取得します。
getBatchRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
ロットの範囲を取得します。
getBatchentry() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造/プロセス指図でのロット入力設定を取得します。
getBatches(String) - class jp.co.intra_mart.foundation.security.StandardBatchAccessor のメソッド
バッチの一覧を取得します。
getBatches(String) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
すべてのバッチ情報を取得します。
getBatches() - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
すべてのバッチ情報を取得します。
getBatchesByIds(String, String[]) - class jp.co.intra_mart.foundation.security.StandardBatchAccessor のメソッド
引数に指定したバッチIDのバッチ情報をすべて取得します。
getBatchesByIds(String, String[]) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
引数に指定したバッチIDのバッチ情報をすべて取得します。
getBatchesByIds(String[]) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
ログイングループ内で引数指定したバッチIDのバッチ情報をすべて取得します。
getBcc() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Bccの一覧を取得します。
getBdcnt() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
5 文字数値 NUMCを取得します。
getBegdemPer() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
見越期間の提案開始日付を取得します。
getBegdemPer() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBegintime() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
開始時刻を取得します。
getBehaveWhenError() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
エラー処理を取得します。
getBehaveWhenError() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
エラー処理を取得します。
getBehaveWhenError() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
エラー処理を取得します。
getBetaFact() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
ベータ係数による傾向値平準化を取得します。
getBidder() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入札者の明細を取得します。
getBidinvNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積管理番号を取得します。
getBilForm() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求書式を取得します。
getBilForm() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBillBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売管理伝票の請求ブロックを取得します。
getBillBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBillBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ブロックを取得します。
getBillBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBillBlock() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売管理伝票の請求ブロックを取得します。
getBillDate() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
請求索引および印刷に対する請求日を取得します。
getBillDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
請求索引および印刷に対する請求日を取得します。
getBillDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBillDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求索引および印刷に対する請求日を取得します。
getBillDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBillDoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
請求伝票を取得します。
getBillDocItem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
請求伝票明細を取得します。
getBillOfLading() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入庫時に登録した B/L 番号を取得します。
getBillOfLadingLong() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入庫の船荷証券番号 (依存: テキスト (長) 参照)を取得します。
getBillPlan() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
請求計画番号を取得します。
getBillPlani() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
明細: 請求計画/支払計画/支払カードを取得します。
getBillRel() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求関連 (CRM)を取得します。
getBillRel() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBillSched() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
請求日程 (稼働日カレンダ指定)を取得します。
getBillSched() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBillSched() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求日程 (稼働日カレンダ指定)を取得します。
getBillSched() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBillTo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
請求先を取得します。
getBillType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
請求タイプを取得します。
getBillValue() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
請求金額: 請求計画に請求日付が指定されている場合を取得します。
getBillamount() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
請求金額: 請求計画に請求日付が指定されている場合を取得します。
getBillcateg() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
請求カテゴリを取得します。
getBillingDataInList() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
処理予定明細データのテーブルを取得します。
getBillingDocumentDetail() - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController のメソッド
請求伝票に関する詳細情報を取得します。
getBillingDocumentDetail() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail のメソッド
請求伝票に関する詳細情報を取得します。
getBillingDocumentDetailListList() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
後続請求伝票のテーブルを取得します。
getBillingdoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
請求伝票を取得します。
getBillingdocument() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail のメソッド
処理予定の請求伝票数を取得します。
getBinaryRelationshiptype() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
バイナリ関連タイプ (専用)を取得します。
getBinaryRelationshiptype() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
バイナリ関連タイプ (専用)を取得します。
getBinaryRelationshiptype() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
バイナリ関連タイプ (専用)を取得します。
getBindgPer() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積有効期間を取得します。
getBlanket() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
包括明細を取得します。
getBlockStge() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
平置保管域区分を取得します。
getBomUsage() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
BOM 用途を取得します。
getBomexplNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
BOM 展開番号を取得します。
getBomexplNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBonGrp1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
決済グループ1を取得します。
getBonGrp2() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
決済グループ 2 (リベート決済、購買)を取得します。
getBonGrp3() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
決済グループ 3 (リベート決済、購買)を取得します。
getBrasNbm() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
Brazilian NCM Codeを取得します。
getBudgetProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
予算プロファイルを取得します。
getBufferSize() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
このレスポンスに設定されている実バッファサイズを返します。
getBufferSize(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
このレスポンスに設定されている実バッファサイズを返します。
getBufferSize(HttpServletRequest, ExtendedHttpServletResponse) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
このレスポンスに設定されている実バッファサイズを返します。
getBufferSize(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
このレスポンスに設定されている実バッファサイズを返します。
getBuildLong() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
建物 (番号またはコード)を取得します。
getBuildLong() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
建物 (番号またはコード)を取得します。
getBuildLong() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
建物 (番号またはコード)を取得します。
getBuilding() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
旧: 建物 (番号または略称)を取得します。
getBuilding() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
旧: 建物 (番号または略称)を取得します。
getBuilding() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
旧: 建物 (番号または略称)を取得します。
getBulkMat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: バルク品目を取得します。
getBusArDes() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のメソッド
事業領域名を取得します｡
getBusArDes(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のメソッド
事業領域を指定して事業領域名を取得します。
getBusArea() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のメソッド
事業領域を取得します｡
getBusArea() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
事業領域を取得します。
getBusArea() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
事業領域を取得します。
getBusArea() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
事業領域を取得します。
getBusArea() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
事業領域を取得します。
getBusAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のメソッド
事業領域一覧を取得します｡
getBusTranst() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
貿易管理の取引タイプを取得します。
getBusTranst() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBusinessAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のメソッド
事業領域一覧を取得します。
getBusinessAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList のメソッド
事業領域一覧を取得します｡
getBusinessTransactionType() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
貿易管理の取引タイプを取得します。
getBuspartno() - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
取引先の仕入先マスタコードを取得します。
getBuyingGrp() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
購買グループの勘定コードを取得します。
getBwdCons() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費期間: 後方を取得します。
getBytes() - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity のメソッド
データ部をバイト配列として取得します。
getBytes() - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
この抽象パスが表すファイルからデータを読み込みます。
getBytes() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
推奨されていません。 データ部をバイト配列として取得します。
getBytes() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent のメソッド
サーバからレスポンスされたコンテンツのソースをバイト列として返します。
getBytes() - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 この抽象パスが表すファイルからデータを読み込みます。
getCCardDataInList() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
処理予定支払方法のテーブルを取得します。
getCOName() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
気付を取得します。
getCOName() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
気付を取得します。
getCOName() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
気付を取得します。
getCSVStrings(PreparedStatement, boolean) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 CSV形式のデータ取得します。
getCSVStrings(PreparedStatement, int, int, boolean) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 CSV形式のデータ取得します。
getCacheTime() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
キャッシュ時間を取得します。
getCadId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
CAD 区分を取得します。
getCalcMotive() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
計算区分を取得します。
getCalcMotive() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
計算区分を取得します。
getCalctypcon() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件計算タイプを取得します。
getCalctypcon() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件計算タイプを取得します。
getCalctype() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
価格設定タイプを取得します。
getCalendar() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
稼動日カレンダを取得します。
getCalendar() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
稼動日カレンダを取得します。
getCalendarId() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
カレンダーIDを取得します。
getCalendarIds(String) - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor のメソッド
すべてのカレンダーIDを取得します。
getCalendarIds(String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
すべてのカレンダーIDを取得します。
getCalendarIds() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
すべてのカレンダーIDを取得します。
getCalendarInfo(String, String, String) - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor のメソッド
カレンダーデータを取得します。
getCalendarInfo(String, String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
カレンダーデータを取得します。
getCalendarInfo(String, String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータを取得します。
getCalendarInfo() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
マッチしたカレンダーデータの一覧を取得します。
getCalendarInfoIds(String, String) - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor のメソッド
すべてのカレンダーデータIDを取得します。
getCalendarInfoIds(String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
すべてのカレンダーデータIDを取得します。
getCalendarInfoIds(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
すべてのカレンダーデータIDを取得します。
getCalendarInfos(String, String) - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor のメソッド
すべてのカレンダーデータを取得します。
getCalendarInfos(String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
すべてのカレンダーデータを取得します。
getCalendarInfos(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
すべてのカレンダーデータを取得します。
getCalendarInfosByIds(String, String, String[]) - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor のメソッド
指定されたカレンダーデータIDのカレンダー情報をすべて取得する。
getCalendarInfosByIds(String, String, String[]) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
指定されたカレンダIDのカレンダ情報をすべて取得する。
getCalendarInfosByIds(String, String[]) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
ログイングループ内で引数指定したカレンダーデータIDのカレンダーをすべて取得します。
getCampaign() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
総括プロジェクト計画: 外部 R/3 システムの GUIDを取得します。
getCampaign() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCampaign() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
総括プロジェクト計画: 外部 R/3 システムの GUIDを取得します。
getCampaign() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCancelled() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
中止区分を取得します。
getCapacity() - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager のメソッド
コネクション作成最大数の取得。
getCapacity() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
コネクション作成最大数の取得。
getCapacity() - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionManager のメソッド
推奨されていません。 コネクション作成最大数の取得。
getCapacity() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 コネクション作成最大数の取得。
getCaption() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
ｘ軸のキャプションを返します。
getCaption() - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
キャプション文字列を返します。
getCaption() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
ｘ軸のキャプションを返します。
getCaption() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
ｘ軸のキャプションを返します。
getCaption() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
キャプションを返します。
getCaptionColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
キャプションの文字色を返します。
getCaptionColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
キャプションの文字色を返します。
getCaptionColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
キャプションの文字色を返します。
getCaptionColor() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
キャプションの文字色を返します。
getCaptionMargin() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
キャプション表示位置のマージンを返します。
getCaptionMargin() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
キャプション表示位置のマージンを返します。
getCapyUsage() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
保管容量使用を取得します。
getCasNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
CAS 番号： 薬事品目 - 貿易を取得します。
getCashDisc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
現金値引区分を取得します。
getCashDisc1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
割引率 1を取得します。
getCashDisc2() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
割引率 2を取得します。
getCatalog() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 Connection の現在のカタログ名を返します。
getCatalogue(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
指定されたカタログ情報を返します。
getCatalogueMediaFileName(ItemCatalogue) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
商品カタログの媒体が保存されてるファイルパスを取得します。
getCatalogues(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
指定された商品のカタログ情報を返します。
getCategories(String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
カテゴリの一覧を取得します。
getCategories() - class jp.co.intra_mart.foundation.security.permission.PermissionManager のメソッド
設定XMLファイルで定義されているすべてのカテゴリ名を返却します。
getCategories(String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
カテゴリの一覧を取得する。
getCategories() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
カテゴリーの一覧を取得します。
getCategorizedCalendarInfos(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
すべてのカレンダーデータをデータタイプ別に分類して取得します。
getCategorizedItems(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のメソッド
商品カテゴリに分類されている商品の情報を返します。
getCategory(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のメソッド
指定されたカテゴリコードに対する商品カテゴリの情報を返します。
getCategory() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
新着情報のカテゴリ名を取得します。
getCategory() - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロールカテゴリを取得します。
getCategory() - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
カテゴリを取得します。
getCategoryClassCode() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
分類区分コードを取得します。
getCategoryClassCode() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
分類区分コードを取得します。
getCategoryClassCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
分類区分コードを取得します。
getCategoryClassCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
分類区分コードを取得します。
getCategoryClassCode() - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
分類区分コードを取得します。
getCategoryClassCode() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
分類区分コードを取得します。
getCategoryClassCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel のメソッド
分類区分コードを取得します。
getCategoryClassCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel のメソッド
分類区分コードを取得します。
getCategoryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
分類コードを取得します。
getCategoryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
分類コードを取得します。
getCategoryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
分類コードを取得します。
getCategoryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
分類コードを取得します。
getCategoryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel のメソッド
分類コードを取得します。
getCategoryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel のメソッド
分類コードを取得します。
getCategoryDetail(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のメソッド
登録済みの分類区分詳細情報を取得します。
getCategoryDetailInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
指定された言語に対する国際化情報を取得します。
getCategoryDetails() - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のメソッド
登録済みの分類区分詳細情報の一覧を取得します。
getCategoryDetails(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のメソッド
登録済みの分類区分詳細情報の一覧を取得します。
getCategoryManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager の static メソッド
CategoryManagerを取得します。
getCategoryStruct(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のメソッド
指定された商品カテゴリ種別のカテゴリ階層を取得します。
getCategoryTypes() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のメソッド
登録済の商品カテゴリ種別の一覧を返します。
getCateogryClassInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
指定された言語に対する国際化情報を取得します。
getCatprofile() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
カタログプロファイルを取得します。
getCbaseId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
インスタンス番号 (固定)を取得します。
getCbaseIdType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
インスタンス番号タイプ (固定)を取得します。
getCc() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Ccの一覧を取得します。
getCcAuthNo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 承認番号を取得します。
getCcFixed() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
循環棚卸区分固定を取得します。
getCcLocId() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: トランザクション (入庫時点)を取得します。
getCcName() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: カード所有者の氏名を取得します。
getCcName() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: カード所有者の氏名を取得します。
getCcNumber() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: カード番号を取得します。
getCcNumber() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: カード番号を取得します。
getCcPhInv() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
循環棚卸の実地棚卸区分を取得します。
getCcReAmount() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
BAPI インタフェースの通貨金額を取得します。
getCcReact() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 権限確認に対する応答を取得します。
getCcReactT() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 結果テキストを取得します。
getCcSeqNo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 支払カード - 接尾辞を取得します。
getCcSettled() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 決済終了を取得します。
getCcStatEx() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 外部システム呼出時のステータスを取得します。
getCcType() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カードタイプ: カードタイプを取得します。
getCcType() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カードタイプ: カードタイプを取得します。
getCcValidF() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 使用有効開始日付を取得します。
getCcValidT() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 有効終了日を取得します。
getCcValidT() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 有効終了日を取得します。
getCctrPosted() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
原価が実際に転記された原価センタを取得します。
getCdUntIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件数量単位 (ISO コード)を取得します。
getCdUntIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
条件数量単位 (ISO コード)を取得します。
getCdUntIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
条件数量単位 (ISO コード)を取得します。
getCenterPointX() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｘ軸の中心値を返します。
getCenterPointY() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｙ軸の中心値を返します。
getCertType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
証明書タイプを取得します。
getCertificationErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
認証失敗エラーページURLを取得する。
getCertificationErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
認証失敗エラーページURLを取得します。
getCfginfo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
CU: 選定の BLOB (SCE)を取得します。
getCfopCode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
CFOP code and extension (old 5 char version)を取得します。
getCfopCode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCfopLong() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
CFOP code and extensionを取得します。
getChangeId() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
変更タイプ(U、I、E、D)を取得します。
getChangeNo() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
変更番号を取得します。
getChangedBy() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
オブジェクトの変更者名を取得します。
getCharUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
特性の数量単位を取得します。
getCharUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
下位レベル数量単位 (ISO コード)を取得します。
getCharacterEncoding() - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のメソッド
このオブジェクトが対象としている文字エンコーディング名を返します。
getCharacterEncoding() - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
このオブジェクトが対象としている文字エンコーディング名を返します。
getCharacterEncoding() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。
getCharacterEncoding(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。
getCharacterEncoding(HttpServletRequest, ExtendedHttpServletResponse) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。
getCharacterEncoding(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。
getCharacterEncoding() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
パラメータを符号化するためのエンコーディング名を返します。
getCharacterEncoding() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
リクエストパラメータの文字エンコーディングを返します。
getCharacterEncoding() - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のメソッド
推奨されていません。 このオブジェクトが対象としている文字エンコーディング名を返します。
getCharacterEncoding() - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 このオブジェクトが対象としている文字エンコーディング名を返します。
getCharc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
特性名を取得します。
getCharcTxt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
言語依存特性テキストを取得します。
getCharset(Locale) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
キャラクターセットを取得します。
getCharset() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
charsetを取得します。
getChckstatus() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村ファイルテストステータスを取得します。
getChckstatus() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村ファイルテストステータスを取得します。
getChckstatus() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村ファイルテストステータスを取得します。
getCheckReturn() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のメソッド
結果を取得します｡
getCheckReturn() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のメソッド
結果情報を取得します｡
getCheckRule() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
確認規則を取得します。
getChildMenuId() - class jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion のメソッド
子メニューIDを取得します。
getChildMenuId() - class jp.co.intra_mart.foundation.security.menu.MenuInclusion のメソッド
子メニューIDを取得します。
getChildMenuIds(String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
引数で指定されたノードの直下の子メニューIDを配列で取得します。
getChildMenuIds(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
引数で指定されたノードの直下の子ノードを配列で取得します。
getChildMenuIds(String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
子メニューIDを取得します。
getChildMenuIds(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
引数で指定されたノードの直下の子ノードを配列で取得します。
getChildMenuIds(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
子メニューIDを取得します。
getChildNodes() - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
このノードの子ノードをすべて含む Collectionを返します。
getChildNodes() - interface jp.co.intra_mart.foundation.page.TreeNodeContainer のメソッド
このノードの子をすべて含む Collectionを返します。
getChildRoleId() - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel のメソッド
子ロールコードを取得します。
getChildren() - interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryStruct のメソッド
このカテゴリ構成の子供の構成を取得します。
getChildren() - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
子メニューの一覧を取得します。
getChkprtauth() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
取引先権限チェックを取得します。
getChkprtauth() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCity() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
市区町村を取得します。
getCity() - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
市区町村名を取得します｡
getCity(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
銀行コードを指定して市区町村名を取得します。
getCity() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村を取得します。
getCity() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
市区町村を取得します。
getCity() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村を取得します。
getCity() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
市区町村を取得します。
getCityCode() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
市区町村コードを取得します
getCityNo() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村/地名ファイルの市区町村コードを取得します。
getCityNo() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村/地名ファイルの市区町村コードを取得します。
getCityNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村/地名ファイルの市区町村コードを取得します。
getClIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
レコード番号を取得します｡
getClassArchives() - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
このクラスローダーに設定されているクラスアーカイブパスを返します。
getClassInstance(String) - class jp.co.intra_mart.foundation.commons.SourceProviderHandler のメソッド
ソースプロバイダクラスのインスタンスを取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.BaseModel のメソッド
基本モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseModel のメソッド
拡張基本モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalModel のメソッド
拡張国際化モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalModel のメソッド
拡張期間国際化モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableModel のメソッド
拡張期間化モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalModel のメソッド
国際化モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalModel のメソッド
期間国際化モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableModel のメソッド
期間化モデルのクラス名を取得します。
getClassPaths() - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
このクラスローダーに設定されているクラスパスを返します。
getClassType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
クラスタイプを取得します。
getClassType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
クラスタイプを取得します。
getClerk() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
記帳担当者を取得します。
getClient() - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
クライアントを取得します。
getClient() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 クライアントを取得します｡
getClientContext() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
イベントの実行を要求したクライアントに関する情報オブジェクトを返します。
getClientData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目データ (クライアントレベル)を取得します。
getClientDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
品目データ (クライアントレベル)が既に存在するかチェックします。
getClientDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目データ (クライアントレベル)を取得します。
getClientEncoding() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientEncoding() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientEncoding() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientEncoding() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientEncoding() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientLocale() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientLocale() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientLocale() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
クライアントのロケールを取得します。
getClientLocale() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
クライアントのロケールを取得します。
getClientLocale() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientType() - interface jp.co.intra_mart.foundation.security.ClientTypeInfo のメソッド
クライアントタイプを取得する。
getClientType() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
クライアントタイプを取得する。
getClientType(Locale, String) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
指定ロケールでクライアントタイプ情報を取得します。
getClientType() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
クライアントタイプを取得する。
getClientType() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
クライアントタイプを取得する。
getClientType() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
クライアントタイプを取します。
getClientType() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
クライアントタイプを取得する。
getClientType() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
クライアントタイプを取得する。
getClientType() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
クライアントタイプを取得する。
getClientType() - class jp.co.intra_mart.framework.base.util.UserInfoWrapper のメソッド
ラップされたUserInfoのgetClientType()を呼び出します。
getClientType() - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
クライアントタイプを取得します。
getClientTypeName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
クライアントタイプをセッションに保管するためのパラメータ名を取得する。
getClientTypes(Locale) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
指定ロケールでクライアントタイプ情報の一覧を取得します。
getCloseSocketEventListeners() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
このソケットに登録されているクローズ・イベント・リスナーを返します。
getCloseSocketEventListeners() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
このプールに登録されている ソケットをクローズしたイベントを通知するためのリスナーを 返します。
getCloseSocketEventListeners() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 このソケットに登録されているクローズ・イベント・リスナーを返します。
getCloseSocketEventListeners() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 このプールに登録されている ソケットをクローズしたイベントを通知するためのリスナーを 返します。
getClosedBox() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
完了した梱包材を取得します。
getCmRelevanceFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
構成管理関連を取得します。
getCmlqtyDat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
累積出荷数量日付を取得します。
getCmlqtyDat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCmmtItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
資金予算コードを取得します。
getCmmtItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
資金予算コードを取得します。
getCmmtItem() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
資金予算コードを取得します。
getCmmtItem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
資金予算コードを取得します。
getCmmtItemLong() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
資金予算コードを取得します。
getCmmtItemLong() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
資金予算コードを取得します。
getCmmtItemLong() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
資金予算コードを取得します。
getCmmtItemLong() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
資金予算コードを取得します。
getCntrlInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
購買伝票タイプに対する管理区分を取得します。
getCoArea() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のメソッド
管理領域を取得します｡
getCoArea() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
管理領域を取得します。
getCoArea() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
管理領域を取得します。
getCoArea() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
管理領域を取得します。
getCoBusproc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
業務プロセスを取得します。
getCoBusproc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
業務プロセスを取得します。
getCoBusproc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
業務プロセスを取得します。
getCoCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
会社コードを取得します。
getCoIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
レコード番号を取得します｡
getCoProduct() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: 連産品としても使用可能な品目を取得します。
getCoProduct() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 連産品としても使用可能な品目を取得します。
getCode() - class jp.co.intra_mart.foundation.acssecurity.AcssecurityException のメソッド

getCode() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
コードを取得します｡
getCoeffTheil() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
タイル係数を取得します。
getCollAuth() - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
フラグ: 回収権限を取得します。
getCollNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
一括番号を取得します。
getCollectNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
一括番号を取得します。
getCollectNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
一括番号を取得します。
getCollectNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getColor() - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
棒の色を返します。
getColor() - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
グラフの色を返します。
getColor() - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
線の色を返します。
getColor() - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
描画する点の色を返します。
getColor() - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
グラフ線の色を返します。
getColor() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
色を取得します。
getColor() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
背景色を取得します。
getColor() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
表示色を取得します。
getColorCode() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンコードを取得します。
getColorPattern(Locale, String) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
指定ロケールでカラーパターン情報を取得します。
getColorPatternID() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
カラーパターンIDを取得する。
getColorPatternID() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
カラーパターンIDを取得する。
getColorPatternID() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
カラーパターンIDを取得する。
getColorPatternID() - class jp.co.intra_mart.framework.base.util.UserInfoWrapper のメソッド
ラップされたUserInfoのgetColorPatternID()を呼び出します。
getColorPatternId() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンIDを取得します。
getColorPatternId() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
カラーパターンIDを取得する。
getColorPatternId() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
カラーパターンIDを取得します。
getColorPatternId() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
カラーパターンIDを取得します。
getColorPatternId() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
ページカラーパターンを取得します。
getColorPatternIdName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
カラーパターンIDをセッションに保管するためのパラメータ名を取得する。
getColorPatterns(Locale) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
指定ロケールでカラーパターン情報の一覧を取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.BaseTable のメソッド
基本テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable のメソッド
拡張基本テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable のメソッド
拡張国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable のメソッド
拡張期間国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable のメソッド
拡張期間化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable のメソッド
国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable のメソッド
期間国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable のメソッド
期間化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnName() - class jp.co.intra_mart.foundation.database.DatabaseColumn のメソッド

getColumnType() - class jp.co.intra_mart.foundation.database.DatabaseColumn のメソッド

getColumns() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張テーブルに含まれるカラムをすべて取得します。
getColumns() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
テーブルに含まれるカラムをすべて取得します。
getColumnsInfo() - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。
getComDate() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
確認日を取得します。
getComQty() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
確認数量を取得します。
getCommCoUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
物品コード (貿易) の数量単位を取得します。
getCommCoUnIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ISO コードによる物品コード (貿易管理) の数量単位を取得します。
getCommCode() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
貿易: 統計品目コード/輸入コード番号を取得します。
getCommCode() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
貿易: 統計品目コード/輸入コード番号を取得します。
getCommGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
手数料グループを取得します。
getCommType() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
通信方法 (キー) (アドレス管理)を取得します。
getCommType() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
通信方法 (キー) (アドレス管理)を取得します。
getCommType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
通信方法 (キー) (アドレス管理)を取得します。
getComment() - class jp.co.intra_mart.foundation.navigator.TitleInfo のメソッド
コメント取得
getCommitCount() - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader のメソッド
コミット間隔を取得します。
getCommprice1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
商法による評価額: レベル 1を取得します。
getCommprice2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
商法による評価額: レベル 2を取得します。
getCommprice3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
商法基準評価額: レベル 3を取得します。
getCompCdeB() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
請求対象会社コードを取得します。
getCompCdeB() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCompCode() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
会社コードを取得します。
getCompCode() - class jp.co.intra_mart.foundation.sap.module.accounting.Company のメソッド
会社コードを取得します｡
getCompCode() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
会社コードを取得します。
getCompCode() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
会社コードを取得します。
getCompCode() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
会社コードを取得します。
getCompCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
会社コードを取得します｡
getCompCode() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
会社コードを取得します｡
getCompCode() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のメソッド
会社コードを取得します｡
getCompCode() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のメソッド
会社コードを取得します｡
getCompList() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のメソッド
会社一覧を取得します｡
getCompName() - class jp.co.intra_mart.foundation.sap.module.accounting.Company のメソッド
会社名を取得します｡
getCompName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のメソッド
会社コードを指定して会社名を取得します。
getCompQuant() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
構成品目数量を取得します。
getCompQuant() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCompScrap() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
構成品目不良率を取得します。
getCompShip() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
出荷指示順守を取得します。
getCompShip() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷指示順守を取得します。
getCompanyCategoryTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
指定された期間に対する期間化情報を取得します。
getCompanyCategoryTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
指定された日時に対する期間化情報を取得します。
getCompanyCd() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel のメソッド
会社CDを取得します。
getCompanyCd() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel のメソッド
会社CDを取得します。
getCompanyCd() - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel のメソッド
会社CDを取得します。
getCompanyCd() - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel のメソッド
会社CDを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct のメソッド
会社コードを取得する。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
会社コードを取得します。
getCompanyCode(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
会社コードを取得します。
getCompanyCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
会社コードを取得します｡
getCompanyCode() - class jp.co.intra_mart.foundation.security.DepartmentInfo のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.security.PostInfo のメソッド
会社コードを取得します。
getCompanyDataInfo() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
会社コード依存データ情報を取得します｡
getCompanyDataInfo() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
会社コード依存データ情報を取得します｡
getCompanyDataInfo() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
会社コード依存データ情報を取得します｡
getCompanyDataInfo() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
会社コード依存データ情報を取得します｡
getCompanyDataInfo() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
会社コード依存データ情報を取得します｡
getCompanyDataInfo() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
会社コード依存データ情報を取得します｡
getCompanyList() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のメソッド
会社一覧を取得します。
getCompanyList() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList のメソッド
会社一覧を取得します｡
getCompanyManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager の static メソッド
CompanyManagerを取得します。
getCompanyPostTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
指定された期間に対する期間化情報を取得します。
getCompanyPostTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
指定された日時に対する期間化情報を取得します。
getCompanyPostTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getCompanyTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
指定された期間に対する期間化情報を取得します。
getCompanyTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
指定された日時に対する期間化情報を取得します。
getCompanyTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getCompanycode() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
会社コードを取得します｡
getCompanycode() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
会社コードを取得します｡
getCompanycode() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
会社コードを取得します｡
getCompanycode() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
会社コードを取得します｡
getCompanycode() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
会社コードを取得します。
getComparators() - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator のメソッド
設定されている全てのコンパレータを取得します。
getComparators() - class jp.co.intra_mart.foundation.utility.MultiComparator のメソッド
推奨されていません。 設定されている全てのコンパレータを取得します。
getCompetitor() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
競合会社を取得します。
getComplDlv() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
全購買発注に対する一括納入指定を取得します。
getComplDlv() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
一括納入区分を取得します。
getComplDlv() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getComplete() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最終確認の有効化を取得します。
getComplete() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
一般区分を取得します。
getComplete() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
一般区分を取得します。
getCompleted() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
ステータス "バージョン完了済"を取得します。
getCompleted() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
ステータス "バージョン完了済"を取得します。
getComponentId() - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject のメソッド
コンポーネントIDを取得します。
getConExist() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
基本契約明細の制限を取得します。
getConId() - interface jp.co.intra_mart.foundation.database.ConInfo のメソッド
接続参照名を取得します。
getConItem() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
明細番号、契約を取得します。
getConLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: 基本契約の計画外を取得します。
getConNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
基本契約番号を取得します。
getConPckg() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: 基本契約の計画外を取得します。
getConbaseval() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件基礎値を取得します。
getConbaseval() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件基礎値を取得します。
getCondCount() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件カウンタを取得します。
getCondCount() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件カウンタを取得します。
getCondCount() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
条件連続番号を取得します。
getCondCount() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
条件カウンタを取得します。
getCondCurr() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
条件通貨 (累積項目用)を取得します。
getCondDUnt() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
伝票の条件単位を取得します。
getCondGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先条件グループを取得します。
getCondHandl() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
選択: 条件行処理 (SD 伝票変更)を取得します。
getCondHeaderList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
条件ヘッダ一覧を取得します｡
getCondItemList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
条件明細一覧を取得します｡
getCondNo() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件レコード番号を取得します。
getCondNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件レコード番号を取得します。
getCondNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
伝票条件番号を取得します。
getCondPUnt() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
価格条件単位を取得します。
getCondPUnt() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
価格条件単位を取得します。
getCondPUnt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
価格条件単位を取得します。
getCondPUnt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCondPUnt() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
価格条件単位を取得します。
getCondPUnt() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
価格条件単位を取得します。
getCondStNo() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
ステップ番号を取得します。
getCondStNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
ステップ番号を取得します。
getCondStNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
ステップ番号を取得します。
getCondStNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
ステップ番号を取得します。
getCondType() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件タイプを取得します。
getCondType() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
条件タイプを取得します。
getCondType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件タイプを取得します。
getCondType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
条件タイプを取得します。
getCondType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
条件タイプを取得します。
getCondUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件単位を取得します。
getCondUnit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件単位を取得します。
getCondUnit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCondUnit() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
条件単位を取得します。
getCondUnit() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
条件単位を取得します。
getCondUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件数量単位 (ISO コード)を取得します。
getCondUpdat() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件更新を取得します。
getCondUpdat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件更新を取得します。
getCondValue() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件レートを取得します。
getCondValue() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
条件金額/率を取得します。
getCondValue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件レートを取得します。
getCondValue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCondchaman() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件 (マニュアル変更済)を取得します。
getCondchaman() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件 (マニュアル変更済)を取得します。
getCondclass() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件クラスを取得します。
getCondclass() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件クラスを取得します。
getCondcntrl() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件管理を取得します。
getCondcntrl() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件管理を取得します。
getCondcoinhd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件カウンタ (ヘッダ条件)を取得します。
getCondconfig() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
システム設定の条件を取得します。
getCondconfig() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
システム設定の条件を取得します。
getCondcount() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件連続番号を取得します。
getCondcount() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件連続番号を取得します。
getCondincomp() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
会社間請求の条件を取得します。
getCondincomp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
会社間請求の条件を取得します。
getCondisacti() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
無効条件を取得します。
getCondisacti() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
無効条件を取得します。
getConditemno() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
条件明細番号を取得します。
getConditionDataInList() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
処理予定条件のテーブルを取得します。
getConditionNo() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
伝票条件番号を取得します。
getCondorigin() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件生成区分を取得します。
getCondorigin() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件生成区分を取得します。
getCondtype() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件カテゴリ (例: 税、運賃、価格、原価)を取得します。
getCondtype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件カテゴリ (例: 税、運賃、価格、原価)を取得します。
getCondvalue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件金額を取得します。
getConexchrat() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
現地通貨への換算レートに対する条件を取得します。
getConexchrat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
現地通貨への換算レートに対する条件を取得します。
getConfCtrl() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
確認管理キーを取得します。
getConfMatl() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
プラント共通選定可能品目を取得します。
getConfigDayInfos() - class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo のメソッド
データタイプが名称であるカレンダーデータの一覧を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のメソッド
外部選定 ID (仮)を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
外部選定 ID (仮)を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
外部選定 ID (仮)を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
外部選定 ID (仮)を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
外部選定 ID (仮)を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
外部選定 ID (仮)を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
外部選定 ID (仮)を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
外部選定 ID (仮)を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getConfigPageCount(String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
履歴表示件数の取得。
getConfigurationReader(InputStream) - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
入力ストリームからエクスポート設定情報を取得します。
getConfigurationReader(InputStream) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient のメソッド

getConfigurationReader(InputStream) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient のメソッド

getConfigurationReader(InputStream) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient のメソッド

getConfigurationReader(InputStream) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient のメソッド

getConfigurationReader(InputStream) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient のメソッド

getConfigurationReader(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
入力ストリームからポート設定情報を取得します。
getConfigurationReader(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient のメソッド

getConfigurationReader(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient のメソッド

getConfigurationReader(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient のメソッド

getConfigurationReader(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient のメソッド

getConfigurationReader(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient のメソッド

getConfigured() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
選定可能品目を取得します。
getConinvolst() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
請求書一覧条件を取得します。
getConinvolst() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
請求書一覧条件を取得します。
getConnectIDs() - class jp.co.intra_mart.foundation.database.DbManager の static メソッド
推奨されていません。 DatabaseManager.getConnectIdsBySystem()を使用してください。
getConnectId() - class jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource のメソッド
システムデータソースの識別子を取得します。
getConnectIdsBySystem() - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
システムに紐付くシステム接続名の一覧を取得します。
getConnectInfo() - class jp.co.intra_mart.foundation.database.DbManager のメソッド
推奨されていません。 代替えメソッドはありません。
getConnectTimeout() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
接続タイムアウト時間を取得する。
getConnectTimeoutPropertyName() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
接続タイムアウトを設定するプロパティ名を取得する。
getConnection(ConInfo) - interface jp.co.intra_mart.foundation.database.DatabaseAccessor のメソッド
Connectionオブジェクトを取得します。
getConnection(String, boolean) - class jp.co.intra_mart.foundation.database.DatabaseExport の static メソッド
推奨されていません。 データベースコネクションを取得します。
getConnection() - class jp.co.intra_mart.foundation.database.DbManager のメソッド
推奨されていません。 DatabaseManager.getLoginGroupConnection(String) および DatabaseManager.getSystemConnection(String)を使用してください。
getConnection() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
接続に利用したコネクションを返します。
getConnection() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
接続に利用したコネクションを返します。
getConnection(String) - class jp.co.intra_mart.framework.base.data.DBConnector のメソッド
データベースへのコネクションを取得します。
getConnection() - class jp.co.intra_mart.framework.base.data.DBDAO のメソッド
このDAOに関連づけられたコネクションを取得します。
getConnection(String) - class jp.co.intra_mart.framework.base.data.IntramartDBConnector のメソッド
推奨されていません。 データベースへのコネクションを取得します。
getConnection() - class jp.co.intra_mart.framework.base.data.IntramartDBDAO のメソッド
推奨されていません。 イントラマートで設定されているDBへのコネクションを取得します。
getConnection(String) - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector のメソッド
データベースへのコネクションを取得します。
getConnection() - class jp.co.intra_mart.framework.base.data.LoginGroupDBDAO のメソッド
イントラマートで設定されているDBへのコネクションを取得します。
getConnection(String) - class jp.co.intra_mart.framework.base.data.SystemDBConnector のメソッド
データベースへのコネクションを取得します。
getConnection() - class jp.co.intra_mart.framework.base.data.SystemDBDAO のメソッド
イントラマートで設定されているDBへのコネクションを取得します。
getConnection() - class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource のメソッド
ラップされたデータソースのgetConnection()を呼び出します。
getConnection(String, String) - class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource のメソッド
ラップされたデータソースのgetConnection(String, String)を呼び出します。
getConnection() - class jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource のメソッド
ラップされたデータソースのgetConnection()を呼び出します。
getConnection(String, String) - class jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource のメソッド
ラップされたデータソースのgetConnection(String, String)を呼び出します。
getConnectionInfo() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベース設定情報を取得します。
getConnectionTimeout() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
コネクションのタイムアウト時間を取得します。
getConnectionTimeout() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 コネクションのタイムアウトを取得します｡
getConnectionType() - interface jp.co.intra_mart.foundation.database.ConInfo のメソッド
接続の種別を取得します。
getConnectorClassName(String) - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler のメソッド
データコネクタのクラス名を取得します。
getConnectorClassName(String) - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
データコネクタのクラス名を取得します。
getConnectorClassName(String) - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
データコネクタのクラス名を取得します。
getConnectorClassName(String) - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
データコネクタのクラス名を取得します。
getConnectorClassName(String) - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
データコネクタのクラス名を取得します。
getConnectorName(String, String, String) - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler のメソッド
DAOに対するデータコネクタ名を取得します。
getConnectorName(String, String, String) - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
DAOに対するデータコネクタ名を取得します。
getConnectorName(String, String, String) - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
DAOに対するデータコネクタ名を取得します。
getConnectorName(String, String, String) - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
DAOに対するデータコネクタ名を取得します。
getConnectorName(String, String, String) - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
DAOに対するデータコネクタ名を取得します。
getConnectorResource(String) - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler のメソッド
データコネクタのリソース名を取得します。
getConnectorResource(String) - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
データコネクタのリソース名を取得します。
getConnectorResource(String) - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
データコネクタのリソース名を取得します。
getConnectorResource(String) - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
データコネクタのリソース名を取得します。
getConnectorResource(String) - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
データコネクタのリソース名を取得します。
getConpricdat() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件価格設定日付を取得します。
getConpricdat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件価格設定日付を取得します。
getConsValue() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
消費量を取得します。
getConsValue() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
消費量を取得します。
getConsistent() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
一般区分を取得します。
getConsistent() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
一般区分を取得します。
getConstraintFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準終了日に対する制約を取得します。
getConstraintFinishDateFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予測終了日付を取得します。
getConstraintFinishTime() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準終了時間を取得します。
getConstraintFinishTimeFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の予測終了時間を取得します。
getConstraintStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準開始日に対する制約を取得します。
getConstraintStartDateFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の予測開始日を取得します。
getConstraintStartTime() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準開始時間の制約を取得します。
getConstraintStartTimeFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の需要予測開始時間を取得します。
getConstraintTypeFinish() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の終了日に対する制約を取得します。
getConstraintTypeFinishFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動終了の制約条件付き需要予測日付を取得します。
getConstraintTypeStart() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準開始日に対する制約を取得します。
getConstraintTypeStartFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動開始の制約条件付き需要予測日付を取得します。
getConsumctry() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
消費者の国キーを取得します。
getConsummode() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費モードを取得します。
getContPerc() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
価格決定率を取得します。
getContainer() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
容器条件を取得します。
getContent() - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity のメソッド
データ部を文字列表現として取得します。
getContent(String) - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity のメソッド
データ部を指定された文字コードで変換した結果を文字列表現として 取得します。
getContent() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
推奨されていません。 データ部を文字列表現として取得します。
getContent(String) - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
推奨されていません。 データ部を指定された文字コードで変換した結果を文字列表現として 取得します。
getContent() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL のメソッド
HTTPActionEventURL.getURL() によって表されるコンテンツのソースを取得します。
getContentLength() - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity のメソッド
データ部をバイト長を取得します。
getContentLength() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse のメソッド
レスポンスにセットされている メッセージボディ部の長さを返します。
getContentLength() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedServletResponse#getContentLength() メソッドをそのまま呼び出します。
getContentLength() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
レスポンスにセットされている メッセージボディ部の長さを返します。
getContentLength() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
推奨されていません。 データ部のバイト長を取得します。
getContentTransferEncoding(Locale) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
Content-Transfer-Encodingを取得します。
getContentType() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
コンテントタイプを取得します。
getContentType() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse のメソッド
レスポンスにセットされている クライアントに送り返されるレスポンスのコンテントタイプを 返します。
getContentType() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedServletResponse#getContentType() メソッドをそのまま呼び出します。
getContentType() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
レスポンスにセットされている クライアントに送り返されるレスポンスのコンテントタイプを 返します。
getContentType() - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルのフォーマットを返却します。
getContentType(String) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
コンテントタイプを取得します。
getContents() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
新着情報の内容を取得します。
getContents() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
コンテンツの種類を取得します。
getContents() - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
コンテンツの種類を取得します。
getContext() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のメソッド
CU: 選定の BLOB (SCE)を取得します。
getContextPath() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
getContextPath() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
getContextPath() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
getContextPath() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
getContextPath() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
getContextURL(HttpServletRequest) - class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil の static メソッド
引数で与えられたリクエストのコンテキストを示すURLを生成します。
getContextURL(HttpServletRequest, boolean) - class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil の static メソッド
引数で与えられたリクエストのコンテキストを示すURLを生成します。
getContractLimitsList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注基本契約制限一覧を取得します｡
getContractServiceAccountList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注サービス勘定設定一覧を取得します｡
getContractServiceList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注サービス一覧を取得します｡
getContractServiceTextList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注サービステキスト一覧を取得します｡
getControlKey() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
管理キーを取得します。
getControllAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のメソッド
管理領域一覧を取得します｡
getController(String, String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラ情報を取得します。
getController(String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラ情報を取得します。
getController(String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
指定されたアクセスコントローラIDに対応するアクセスコントローラを取得します。
getControllerConverterConfig(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド

getControllerConverterConfig(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド

getControllerConverterConfig(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
キーに該当するコントローラコンバータの初期パラメータを取得します。
getControllerConverterConfig(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド

getControllerConverterConfig(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
キーに該当するコントローラコンバータの初期パラメータを取得します。
getControllerConverterName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド

getControllerConverterName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド

getControllerConverterName(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
コントローラコンバータのクラス名を取得します。
getControllerConverterName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド

getControllerConverterName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
コントローラコンバータのクラス名を取得します。
getControllerDepartments(String, String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
すべてのアクセスコントローラ組織を取得します。
getControllerDepartments(String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
すべてのアクセスコントローラ組織を取得します。
getControllerDepartments(String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
アクセスコントローラに紐付いた組織の一覧を取得します。
getControllerId() - class jp.co.intra_mart.foundation.security.access.AccessController のメソッド
コントローラＩＤを取得します。
getControllerIds(String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
すべてのアクセスコントローラIDを取得します。
getControllerIds(String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
すべてのアクセスコントローラIDを取得します。
getControllerIds() - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
すべてのアクセスコントローラIDを取得します。
getControllerIdsByDepartment(String, DepartmentInfo[]) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
指定された組織を持つコントローラIDをすべて取得します。
getControllerIdsByDepartment(String, DepartmentInfo[]) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
指定された組織を持つコントローラIDをすべて取得します。
getControllerIdsByDepartment(DepartmentInfo[]) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
指定された組織を持つアクセスコントローラIDをすべて取得します。
getControllerIdsByPost(String, PostInfo[]) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
指定された役職を持つコントローラIDをすべて取得します。
getControllerIdsByPost(String, PostInfo[]) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
指定された役職を持つコントローラIDをすべて取得します。
getControllerIdsByPost(PostInfo[]) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
指定された役職を持つアクセスコントローラIDをすべて取得します。
getControllerIdsByPublicGroup(String, PublicGroupInfo[]) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
指定されたパブリックグループを持つコントローラIDをすべて取得します。
getControllerIdsByPublicGroup(String, PublicGroupInfo[]) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
指定されたパブリックグループを持つコントローラIDをすべて取得します。
getControllerIdsByPublicGroup(PublicGroupInfo[]) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
指定されたパブリックグループを持つアクセスコントローラIDをすべて取得します。
getControllerIdsByRole(String, String[]) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
指定されたロールIDを持つコントローラIDをすべて取得します。
getControllerIdsByRole(String, String[]) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
指定されたロールIDを持つコントローラIDをすべて取得します。
getControllerIdsByRole(String[]) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
指定されたロールIDを持つアクセスコントローラIDをすべて取得します。
getControllerIdsByUser(String, Date) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
指定されたユーザIDおよび日付で有効なアクセスコントローラIDをすべて取得します。
getControllerObject() - interface jp.co.intra_mart.framework.base.service.RequestInfo のメソッド
リクエストから生成されたコントローラオブジェクトを取得します。
getControllerObject() - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
コントローラオブジェクトを取得します。
getControllerObject() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
コントローラオブジェクトを取得します。
getControllerObject(String, String, Locale, RequestInfo) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
コントーラオブジェクトを取得します。
getControllerPosts(String, String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
すべてのアクセスコントローラ役職を取得します。
getControllerPosts(String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
すべてのアクセスコントローラ役職を取得します。
getControllerPosts(String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
アクセスコントローラに紐付いた役職の一覧を取得します。
getControllerPublicGroups(String, String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
すべてのアクセスコントローラパブリックグループを取得します。
getControllerPublicGroups(String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
すべてのアクセスコントローラパブリックグループを取得します。
getControllerPublicGroups(String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
アクセスコントローラに紐付いたパブリックグループの一覧を取得します。
getControllerRoles(String, String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
すべてのアクセスコントローラロールを取得します。
getControllerRoles(String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
すべてのアクセスコントローラロールを取得します。
getControllerRoles(String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
アクセスコントローラに紐付いたロールの一覧を取得します。
getControllers(String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
すべてのアクセスコントローラ情報を取得します。
getControllers(String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
すべてのアクセスコントローラ情報を取得します。
getControllers() - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
すべてのアクセスコントローラを取得します。
getControllingArea() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
管理領域を取得します｡
getControllingArea() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
管理領域コードを取得します｡
getControllingArea() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
管理領域を取得します。
getControllingArea() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
管理領域を取得します。
getControllingArea() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
管理領域を取得します。
getControllingAreaCurrency() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
通貨コードを取得します。
getControllingAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のメソッド
管理領域一覧を取得します。
getControllingAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList のメソッド
管理領域一覧を取得します｡
getControllingarea() - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
管理領域を取得します。
getControllingarea() - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
管理領域を取得します。
getControllingarea() - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
管理領域を取得します。
getConvDen1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買価格単位から購買発注単位への変換分母を取得します。
getConvNum1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買価格単位から購買発注単位への変換分子を取得します。
getConvert() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
変換: 取引先機能 + 受注伝票タイプを取得します。
getConvert() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
取引先機能/受注伝票タイプの変換を取得します。
getConvert() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
変換: 取引先機能 + 受注伝票タイプを取得します。
getConvfactor() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
計画品目用変換係数を取得します。
getCookieSessionInfo() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報のクッキーからintra-martセッション情報を取得します。
getCookieSessionInfo(HttpServletRequest) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
クッキーからintra-martセッション情報を取得します。
getCookies() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse のメソッド
このレスポンスにセットされたすべての Cookie を返します。
getCookies() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getCookies() メソッドをそのまま呼び出します。
getCookies() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このレスポンスにセットされたすべての Cookie を返します。
getCoords() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
coordsを取得します。
getCoords() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
coordsを取得します。
getCorrFact() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 修正係数を需要予測値計算に使用を取得します。
getCorrValue() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
需要予測に対する修正値を取得します。
getCorrValue() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
修正消費量を取得します。
getCorrValue() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
修正消費量を取得します。
getCostCentList() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタ一覧を取得します｡
getCostCenter() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
原価センタを取得します｡
getCostCenterList() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタ一覧を取得します。
getCostCenterList() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
原価センタ一覧を取得します｡
getCostElem() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
原価要素を取得します。
getCostObj() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
原価対象を取得します。
getCostObj() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
原価対象を取得します。
getCostView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算ビューを取得します。
getCostView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
原価計算ビューを取得します。
getCostView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
原価計算ビューを取得します。
getCostcenter() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
原価センタを取得します。
getCostcenter() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
原価センタを取得します。
getCostcenter() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
原価センタを取得します。
getCostcenter() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
原価センタを取得します。
getCostingSheet() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
原価計算表を取得します。
getCostobject() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
原価対象を取得します。
getCount() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager のメソッド
現在有効な HttpSession の数を返します。
getCount(String, String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定条件に該当する表内のデータ件数を取得する

getCountrIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
国キー (ISO コード)を取得します。
getCountry() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
国コードを取得します。
getCountry() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
国コードを取得します。
getCountry() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
出荷国 (商品発送国)を取得します。
getCountry() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
国コードを取得します。
getCountry() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
国コードを取得します。
getCountryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
国コードを取得します。
getCountryCode(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
国コードを取得します。
getCountryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
国コードを取得します。
getCountryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
国コードを取得します。
getCountryCode(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
国コードを取得します。
getCountryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
国コードを取得します。
getCountryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
国コードを取得します。
getCountryCode(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
国コードを取得します。
getCountryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
国コードを取得します。
getCountryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
国コードを取得します。
getCountryCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
国コードを取得します。
getCountryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
国コードを取得します。
getCountryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
国コードを取得します。
getCountryCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
国コードを取得します。
getCountryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
国コードを取得します。
getCountryiso() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
ISO 国コードを取得します。
getCountryiso() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
ISO 国コードを取得します。
getCountryiso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
ISO 国コードを取得します。
getCountryori() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
品目の原産国を取得します。
getCountryori() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目の原産国を取得します。
getCountryoriIso() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
ISO 国コードを取得します。
getCountryoriIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ISO コードでの品目原産国を取得します。
getCountycode() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
地域コードを取得します
getCovprofile() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
在庫日数プロファイルを取得します。
getCrOn() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
レコード登録日を取得します。
getCreatDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
レコード登録日を取得します。
getCreatDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
レコード登録日を取得します。
getCreateLoadRecs() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
区分: 生産資源/治工具の負荷レコード登録を取得します。
getCreateLoadRecs() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
区分: 生産資源/治工具の負荷レコード登録を取得します。
getCreateSocketEventListeners() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
このプールに登録されている ソケットを新規に作成したイベントを通知するためのリスナーを 返します。
getCreateSocketEventListeners() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 このプールに登録されている ソケットを新規に作成したイベントを通知するためのリスナーを 返します。
getCreatedBy() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
オブジェクト登録者名を取得します。
getCreatedBy() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
登録者名を取得します｡
getCreatedBy() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
オブジェクト登録者名を取得します。
getCreatedBy() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
オブジェクト登録者名を取得します。
getCreatedBy() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn のメソッド
オブジェクト登録者名を取得します。
getCreatedBy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
オブジェクト登録者名を取得します。
getCreatedBy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
オブジェクト登録者名を取得します。
getCreatedOn() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
レコード登録日を取得します。
getCreatedOn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
登録日付を取得します。
getCreatedOn() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn のメソッド
レコード登録日を取得します。
getCreationDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
レコード登録日を取得します。
getCreationDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
レコード登録日を取得します。
getCreationTime(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager のメソッド
指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。
getCreationTime(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager のメソッド
指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。
getCreationTime() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
登録時刻を取得します。
getCreationTime() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
登録時刻を取得します。
getCreatorDataIn() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
取り込まれる日付の順序を取得します。
getCreditorGetDetail() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
仕入先マスタ詳細情報を取得します｡
getCreditorid() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
仕入先コードを取得します｡
getCreditorid() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
仕入先コードを取得します｡
getCritPart() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 重要品目を取得します。
getCsIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
レコード番号を取得します｡
getCshBdgtProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
資金計画プロファイルを取得します。
getCssFile() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンのCSSファイルパスを取得します。
getCssFiles() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンのCSSファイルパスの一覧を取得します。
getCstcndgrp1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ１を取得します。
getCstcndgrp1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ１を取得します。
getCstcndgrp1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ２を取得します。
getCstcndgrp2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ２を取得します。
getCstcndgrp2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ３を取得します。
getCstcndgrp3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ３を取得します。
getCstcndgrp3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ４を取得します。
getCstcndgrp4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ４を取得します。
getCstcndgrp4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ５を取得します。
getCstcndgrp5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ５を取得します。
getCstcndgrp5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstgSheet() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
原価計算表を取得します。
getCstgSheet() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
原価計算表を取得します。
getCstgSheet() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCtValidF() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
有効開始日付 (販売契約/品目提案)を取得します。
getCtValidF() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCtValidT() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
有効終了日付 (販売契約/品目提案)を取得します。
getCtValidT() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCtrlCode() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
貿易: 消費税の管理コードを取得します。
getCtrlKey() - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
預金種別を取得します。
getCtrlKey() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
調達における品質管理の管理キーを取得します。
getCtrlKey() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
調達における品質管理の管理キーを取得します。
getCtrlKey() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具管理の管理キーを取得します。
getCtrlKey() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具管理の管理キーを取得します。
getCtrlKeyNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
管理キーは変更できませんを取得します。
getCtrlKeyNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
管理キーは変更できませんを取得します。
getCtrlQty() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
管理数量を取得します。
getCuAmtBase() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
課税基準額を取得します｡
getCuAmtDoccur() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
伝票通貨額を取得します｡
getCuCurrency() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
通貨コードを取得します｡
getCuIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
レコード番号を取得します｡
getCuItemnoAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
会計伝票明細番号を取得します｡
getCumCfQty() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
累積確認数量 (販売数量単位)を取得します。
getCurrIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
ISO コード通貨を取得します。
getCurrIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
ISO コード通貨を取得します。
getCurrIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ISO コード通貨を取得します。
getCurrIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
ISO コード通貨を取得します。
getCurrIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
ISO コード通貨を取得します。
getCurrIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
ISO コード通貨を取得します。
getCurrIso2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
ISO コード通貨を取得します。
getCurrPeriod() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
当期 (転記期間)を取得します。
getCurrPeriod() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
当期 (転記期間)を取得します。
getCurrPlanPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法基準評価額: レベル 2を取得します。
getCurrenckey() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
スケール通貨を取得します。
getCurrenckey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
スケール通貨を取得します。
getCurrenckeyIso() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
ISO コード通貨を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
購買発注通貨を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
通貨コードを取得します｡
getCurrency() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売伝票通貨を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
販売伝票通貨を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売伝票通貨を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売伝票通貨を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売伝票通貨を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
販売伝票通貨を取得します。
getCurrency2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
販売伝票通貨を取得します。
getCurrencyAmountList() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
明細通貨項目一覧を取得します｡
getCurrencyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
通貨コードを取得します。
getCurrencyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
通貨コードを取得します。
getCurrencyCodes() - class jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager のメソッド
通貨コードの一覧を返します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ISO 通貨コードを取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ISO 通貨コードを取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
ISO コード通貨を取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
ISO コード通貨を取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
ISO通貨コードを取得します｡
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
ISO 通貨コードを取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
ISO コード通貨を取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
ISO コード通貨を取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
ISO 通貨コードを取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
ISO コード通貨を取得します。
getCurrencyManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager の static メソッド
CurrencyManagerを取得します。
getCurrencyName(String, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager のメソッド
通貨コードに対する名称を指定された言語で返します。
getCurrencyName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager のメソッド
指定された通貨コードに対する名称を返します。
getCurreniso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
ISO コード通貨を取得します。
getCurrentContext() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager のメソッド
現在のスレッドに関連付けられた HTTP コンテキストを返します。
getCurrentRequest() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter の static メソッド
現在処理中のリクエストを返します。
getCurrentSession() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
このリクエストに関連づけられている現在のセッションを返します。
getCustGroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループを取得します。
getCustGroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustGroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先グループを取得します。
getCustGroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustGrp1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 1を取得します。
getCustGrp1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustGrp2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 2を取得します。
getCustGrp2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustGrp3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 3を取得します。
getCustGrp3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustGrp4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 4を取得します。
getCustGrp4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustGrp5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 5を取得します。
getCustGrp5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustMat22() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先品目コード (無効)を取得します。
getCustMat22() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustMat35() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先品目を取得します。
getCustMat35() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustUser() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
得意先担当者を取得します。
getCustomer() - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
得意先コードを取得します
getCustomer() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
得意先コードを取得します
getCustomer() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
得意先コードを取得します
getCustomer() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
得意先コード1を取得します｡
getCustomer() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
得意先コードを取得します。
getCustomer() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
得意先コードを取得します。
getCustomer() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
得意先コードを取得します。
getCustomer() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
得意先コードを取得します。
getCustomerCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
取引先会社コードを取得します。
getCustomerCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment のメソッド
取引先会社コードを取得します。
getCustomerCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup のメソッド
取引先会社コードを取得します。
getCustomerCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole のメソッド
取引先会社コードを取得します。
getCustomerCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
取引先会社コードを取得します。
getCustomerCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel のメソッド
取引先会社コードを取得します。
getCustomerCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
取引先会社コードを取得します。
getCustomerCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel のメソッド
取引先会社コードを取得します。
getCustomerCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel のメソッド
取引先会社コードを取得します。
getCustomerDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
取引先組織コードを取得します。
getCustomerDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment のメソッド
取引先組織コードを取得します。
getCustomerDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup のメソッド
取引先組織コードを取得します。
getCustomerDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole のメソッド
取引先組織コードを取得します。
getCustomerDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
取引先組織コードを取得します。
getCustomerDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel のメソッド
取引先組織コードを取得します。
getCustomerDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
取引先組織コードを取得します。
getCustomerDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel のメソッド
取引先組織コードを取得します。
getCustomerDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel のメソッド
取引先組織コードを取得します。
getCustomerNumber() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
得意先コードを取得します。
getCustoms() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader のメソッド
税関: 税関 (出国時)を取得します。
getCuvdClear() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
フラグ: 得意先と仕入先間の相殺決済を取得します。
getCvalueFxd() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
区分: 消費金額の確定を取得します。
getCycleTime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
タクトタイムを取得します。
getDAO(String, String, String) - class jp.co.intra_mart.framework.base.data.DataAccessController のメソッド
DAOを取得します。
getDAO(String, String, String) - class jp.co.intra_mart.framework.base.event.EventTriggerAdapter のメソッド
DAOを取得します。
getDAO(String, String, String) - class jp.co.intra_mart.framework.base.event.StandardEventListener のメソッド
DAOを取得します。
getDAO(String, String, String) - class jp.co.intra_mart.framework.extension.seasar.data.S2DataAccessController のメソッド
DAOを取得します。
getDAOName(String, String, String) - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler のメソッド
DAOのクラス名を取得します。
getDAOName(String, String, String) - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
DAOのクラス名を取得します。
getDAOName(String, String, String) - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
DAOのクラス名を取得します。
getDAOName(String, String, String) - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
DAOのクラス名を取得します。
getDAOName(String, String, String) - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
DAOのクラス名を取得します。
getDToRefM() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費データ参照の有効終了日を取得します。
getData(String) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getAccount(String)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.isRegisteredAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.model.user.UserMapperを利用して取得してください。

getData(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRole(String)に置き換えられました。
getData(int) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
リスト内の指定された位置にあるデータを返します。
getData(int) - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
指定された位置にある値を返します。
getData(int) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
リスト内の指定された位置にあるデータを返します。
getData() - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
グラフ値を返します。
getData(int) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
リスト内の指定された位置にあるデータを返します。
getData(int) - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
指定された位置にある値を返します。
getData(int) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
リスト内の指定された位置にあるデータを返します。
getData(int) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
リスト内の指定された位置にあるデータを返します。
getData(int) - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
指定された位置にある値を返します。
getDataAccessController() - class jp.co.intra_mart.framework.base.data.DataManager のメソッド
データアクセスコントローラを取得します。
getDataAccessController() - interface jp.co.intra_mart.framework.base.data.container.DataContainer のメソッド
データアクセスコントローラを取得します。
getDataAccessController() - class jp.co.intra_mart.framework.base.data.container.DataContainerImpl のメソッド
データアクセスコントローラを取得します。
getDataAccessController() - class jp.co.intra_mart.framework.base.event.StandardEventListener のメソッド
このイベントリスナで使用するデータアクセスコントローラです。
getDataAccessController() - class jp.co.intra_mart.framework.extension.seasar.data.S2DataContainer のメソッド
データアクセスコントローラを取得します。
getDataConnectors() - class jp.co.intra_mart.framework.base.data.DataAccessController のメソッド
DataAccessControllerがキャッシュしているDataConnectorの一覧を取得します。
getDataId() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
データＩＤを取得します。
getDataId() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
データIDを取得します。
getDataIndex() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
別の構成のテーブル入力へのポインタを取得します。
getDataManager() - class jp.co.intra_mart.framework.base.data.DataManager の static メソッド
データマネージャを取得します。
getDataName() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
データ名称を取得します。
getDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.DataAccessController のメソッド
データプロパティハンドラを取得します。
getDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.DataConnector のメソッド
データプロパティハンドラを取得します。
getDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.DataManager のメソッド
データプロパティハンドラを取得します。
getDataPropertyHandler() - interface jp.co.intra_mart.framework.base.data.container.DataContainer のメソッド
データプロパティハンドラを取得します。
getDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.container.DataContainerImpl のメソッド
データプロパティハンドラを取得します。
getDataPropertyHandler() - class jp.co.intra_mart.framework.extension.seasar.data.S2DataContainer のメソッド
データプロパティハンドラを取得します。
getDataSizeX() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｘ軸の中心値からのデータサイズを返します。
getDataSizeY() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｙ軸の中心値からのデータサイズを返します。
getDataSourceNameByLoginGroup(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
ログイングループIDからデータソース参照名を取得します。
getDataSourceNameBySystem(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
システム接続名からデータソース参照名を取得します。
getDataSourceRefName() - interface jp.co.intra_mart.foundation.database.ConInfo のメソッド
DataSourceへの参照名を取得します。
getDataType() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
データ型を取得します。
getDataType() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
データ型を取得します。
getDataType() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
データタイプを取得します。
getDataType() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
データタイプを取得します。
getDataX() - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
グラフのｘ値を返します。
getDataY() - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
グラフのｙ値を返します。
getDataorigin() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 入力モードを取得します。
getDate() - interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader のメソッド
日付を取得します。
getDate() - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader のメソッド
日付を取得します。
getDate() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
日付を取得します。
getDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
起算日を取得します。
getDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
起算日を取得します。
getDate() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
日付を取得します。
getDate() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
対象の日付を取得します。
getDate() - class jp.co.intra_mart.foundation.security.password.PasswordHistory のメソッド
日付を取得します。
getDateHeader(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse のメソッド
指定された名称でレスポンスヘッダに設定されている日付の値を返します。
getDateHeader(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getDateHeader(String) メソッドをそのまま呼び出します。
getDateHeader(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
指定された名称でレスポンスヘッダに設定されている日付の値を返します。
getDateHeaders(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse のメソッド
指定された名称でレスポンスヘッダに設定されている全ての日付の値を返します。
getDateHeaders(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getDateHeaders(String) メソッドをそのまま呼び出します。
getDateHeaders(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
指定された名称でレスポンスヘッダに設定されている全ての日付の値を返します。
getDateType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
提案日付タイプを取得します。
getDateType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDateType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
日付タイプ (日、週、月、期間)を取得します。
getDateType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDateValue(String) - class jp.co.intra_mart.foundation.sap.common.util.date.DateHandler の static メソッド
日付書式[YYYYMMDD]の文字列をDate型に変換します。
getDateWorkBegins() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
作業開始を取得します。
getDateWorkEnds() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
作業終了を取得します。
getDay() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
日を取得します。
getDay() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
日を取得します。
getDayInfo(CategorizedCalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
日付情報を取得します。
getDayWeek() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
曜日を取得します。
getDayWeek() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
曜日を取得します。
getDbName() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 このデータベース製品の名前を取得します。
getDbType(Connection) - class jp.co.intra_mart.foundation.database.DatabaseExport の static メソッド
推奨されていません。
getDbType(String) - class jp.co.intra_mart.foundation.database.DbTypes の static メソッド

getDbVersion() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 このデータベース製品のバージョンを取得します。
getDeIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
レコード番号を取得します｡
getDeal(String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
指定された取扱情報を返します。
getDealCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
取扱コードを取得します。
getDealCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment のメソッド
取扱コードを取得します。
getDealCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup のメソッド
取扱コードを取得します。
getDealCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole のメソッド
取扱コードを取得します。
getDealCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
取扱コードを取得します。
getDealCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel のメソッド
取扱コードを取得します。
getDealCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
取扱コードを取得します。
getDealCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel のメソッド
取扱コードを取得します。
getDealCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel のメソッド
取扱コードを取得します。
getDealManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager の static メソッド
DealManagerを取得します。
getDealName() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
取扱名を取得します。
getDealName() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
取扱名を取得します。
getDealPermissionManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager の static メソッド
DealPermissionManagerを取得します。
getDealTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
指定された期間に対する期間化情報を取得します。
getDealTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
指定された日時に対する期間化情報を取得します。
getDealType() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
取扱種別を取得します。
getDealType() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
取扱種別を取得します。
getDeals() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
現在、存在する取扱情報を返します。
getDeals(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
指定された日付に存在する取扱情報を返します。
getDealsByKey(String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
現在、存在する取扱情報の中で、商品と取引先から特定されるものを返します。
getDealsByKey(String, String, String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
指定された日時に存在する取扱情報の中で、商品と取引先から特定されるものを返します。
getDebtorGetDetail() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
得意先マスタ詳細情報を取得します｡
getDebtorid() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
得意先コードを取得します｡
getDebtorid() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
得意先コードを取得します｡
getDebugOption() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
JavaMailに設定するデバック設定の有無を取得します。
getDecForRounding() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
小数点位置 (その位置まで丸める)を取得します。
getDecForRoundingX() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDeclStatFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 仕入先申告ありを取得します。
getDefaultCalendarId() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
デフォルトカレンダーIDを取得します。
getDefaultClientType() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
システムのデフォルトクライアントタイプを取得します。
getDefaultColorPatternId() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
デフォルトカラーパターンIDを取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
デフォルトの日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
デフォルトの日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
デフォルトの日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
デフォルトの日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
デフォルトの日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
デフォルトの日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
デフォルトの日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
デフォルトの日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
デフォルトの日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
デフォルトの日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
デフォルトの日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
デフォルトの日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
デフォルトの日時を取得します。
getDefaultDate() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
デフォルト日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
モデル生成時に設定されたデフォルト日時を取得します。
getDefaultEncoding(Locale) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
ロケールに対応するデフォルトエンコーディングを取得します。
getDefaultImportPath() - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
インポートファイルのデフォルトパス情報を取得します。
getDefaultImportPath() - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient のメソッド

getDefaultImportPath() - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient のメソッド

getDefaultImportPath() - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient のメソッド

getDefaultImportPath() - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient のメソッド

getDefaultImportPath() - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient のメソッド

getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
デフォルトのロケールを取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
デフォルトのロケールを取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
デフォルトのロケールを取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
デフォルトのロケールを取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
デフォルトのロケールを取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
デフォルトのロケールを取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
デフォルトのロケールを取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
デフォルトのロケールを取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
デフォルトのロケールを取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
デフォルトのロケールを取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
デフォルトのロケールを取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
デフォルトのロケールを取得します。
getDefaultLocale() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
デフォルト言語を取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
モデル生成時に設定されたデフォルト言語を取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
モデル生成時に指定された言語を取得します。
getDefaultLocale() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
デフォルト言語を取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
デフォルトロケールを取得します。
getDefaultPath() - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
エクスポート情報の出力ファイルのデフォルトパス情報を取得します。
getDefaultPath() - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient のメソッド

getDefaultPath() - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient のメソッド

getDefaultPath() - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient のメソッド

getDefaultPath() - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient のメソッド

getDefaultPath() - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient のメソッド

getDefaultPrintStream() - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
このクラスがロードされた時点の、System.err を 返します。
getDefaultPrintStream() - class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の static メソッド
このクラスがロードされた時点の、System.out を 返します。
getDefault_value() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
デフォルト値を返します。
getDelDatcatExt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入期日カテゴリを取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
クライアントレベルでの品目削除フラグを取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
データレコード削除 (テーブル繰返し)を取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラントレベルでの品目削除フラグを取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
区分: 流通チャネルレベルでの品目削除フラグを取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所レベルでの品目削除フラグを取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
保管タイプに該当する全品目データ削除フラグを取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
データレコード削除 (テーブル繰返し)を取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価タイプに該当する全品目データ削除フラグを取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
WM 倉庫内の全品目データ削除フラグを取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
データレコード削除 (テーブル繰返し)を取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
データレコード削除 (テーブル繰返し)を取得します。
getDelete() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ターゲットエンティティのデータ削除時の整合性制約を取得します。
getDeleteInd() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買伝票の削除フラグを取得します。
getDeleteInd() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
削除フラグを取得します。
getDeleteInd() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
削除フラグを取得します。
getDeleteInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
削除フラグ: 購買伝票勘定設定を取得します。
getDeleteInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
削除フラグを取得します｡
getDeleteInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買伝票の削除フラグを取得します。
getDeleteInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買伝票の削除フラグを取得します。
getDeleteType() - interface jp.co.intra_mart.foundation.datastore.common.config.Delete のメソッド
ターゲットエンティティの削除時の整合性制約のタイプを取得します。
getDeletionFlag() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
削除フラグを取得します。
getDeletionFlag() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
削除フラグを取得します。
getDeletionFlag() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
削除フラグを取得します。
getDeletionFlag() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
削除フラグを取得します。
getDelivCompl() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
出荷完了 区分を取得します。
getDelivDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
納入期日を取得します。
getDelivDis() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
郵便配達地域を取得します。
getDelivDis() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
郵便配達地域を取得します。
getDelivDis() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
郵便配達地域を取得します。
getDelivItem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷明細を取得します。
getDelivItem() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷明細を取得します。
getDelivItemToSearch() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷明細を取得します。
getDelivNumb() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷伝票を取得します。
getDelivNumb() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷伝票を取得します。
getDelivNumbToSearch() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷伝票を取得します。
getDelivTime() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入期日における指定時間を取得します。
getDeliverryAddressList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
出荷伝票アドレス一覧を取得します｡
getDeliveryDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入期日を取得します。
getDelkz() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
MRP 要素区分を取得します。
getDeltaFact() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
デルタ係数使用による MAD (絶対平均偏差) 平準化を取得します。
getDelyUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
出荷単位を取得します。
getDelyUom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
出荷数量単位を取得します。
getDelyUomIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
ISO コードでの出荷単位の数量単位を取得します。
getDelygPlnt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
出荷プラントを取得します。
getDenominato() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件単位を基本単位へ変換する分母を取得します。
getDenominato() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件単位を基本単位へ変換する分母を取得します。
getDenominatr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
分母: 基本数量単位へ変換する場合を取得します。
getDepReqId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
個別所要量と包括所要量に対する従属所要量区分を取得します。
getDepartmNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
部門コードを取得します。
getDepartmNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDepartmNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
部門コードを取得します。
getDepartmNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDepartment(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の組織を取得します。
getDepartment(int) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

getDepartment() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
部署を取得します。
getDepartmentAttach(String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
ユーザの組織への所属情報を取得します。
getDepartmentAttachTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
指定された期間に対する期間化情報を取得します。
getDepartmentAttachTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
指定された日時に対する期間化情報を取得します。
getDepartmentCd() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel のメソッド
組織CDを取得します。
getDepartmentCd() - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel のメソッド
組織CDを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct のメソッド
組織コードを取得する。
getDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
組織コードを取得します。
getDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
組織コードを取得します。
getDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織コードを取得します。
getDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
組織コードを取得します。
getDepartmentCode(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
組織コードを取得します。
getDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable のメソッド
組織コードを取得します。
getDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
組織コードを取得します。
getDepartmentCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel のメソッド
組織コードを取得します。
getDepartmentCode() - class jp.co.intra_mart.foundation.security.DepartmentInfo のメソッド
組織コードを取得します。
getDepartmentMain(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
ユーザの主所属情報を取得します。
getDepartmentMainTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
指定された期間に対する期間化情報を取得します。
getDepartmentMainTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
指定された日時に対する期間化情報を取得します。
getDepartmentStructs(String, String, Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織の階層構造を取得します。
getDepartmentTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
指定された期間に対する期間化情報を取得します。
getDepartmentTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
指定された日時に対する期間化情報を取得します。
getDepartmentTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getDepartments(Deal) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager のメソッド
取扱情報を保有するアクセス権をもつ組織を返します。
getDepartments() - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

getDepcountry() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
出荷国 (商品発送国)を取得します。
getDepcountryIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
出荷国の ISO コードを取得します。
getDeployHoriz() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
供給分配期間の日数を取得します。
getDeprecPer() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ドキュメンタリクレジット処理に関する償却率 (%)を取得します。
getDeprecPer() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDepth() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
階層レベルを取得します。
getDepth() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
階層レベルを取得します。
getDescrHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のメソッド
終了品目テキストを取得します。
getDescrLow() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のメソッド
開始品目テキストを取得します。
getDescript() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
テキストを取得します｡
getDescript(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタを指定してテキストを取得します。
getDescript() - class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract のメソッド
テキスト (30 文字)を取得します。
getDescript() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
グループテキスト (短)を取得します。
getDescription() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
作業テキスト (短)を取得します。
getDescription() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
PS: テキスト(短)(第一テキスト行)を取得します。
getDescription() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
テキストを取得します。
getDescription() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
PS: テキスト(短)(第一テキスト行)を取得します。
getDescription() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンテキスト（長）を取得します。
getDescription() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
バージョンテキスト（長）を取得します。
getDescription() - class jp.co.intra_mart.foundation.security.access.AccessController のメソッド
説明を取得します。
getDescription() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
説明を取得します。
getDescription() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチ内容を取得します。
getDescription() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
データの説明を取得します。
getDescription() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
説明を取得します。
getDescription() - class jp.co.intra_mart.foundation.security.role.Role のメソッド
説明を取得します。
getDetail() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryResult のメソッド
詳細メッセージを取得します。
getDetails() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable のメソッド
取扱詳細の一覧を取得します。
getDetails() - class jp.co.intra_mart.framework.base.service.validator.ValidationExceptionDetail のメソッド
検証結果の詳細の一覧を取得します。
getDetermGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
在庫決定グループを取得します。
getDevalInd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
低価法: 評価減区分を取得します。
getDialogflag() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
区分 (X = 利用不可 /N = 確認なし)を取得します。
getDiffInv() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
仕入先と請求元が異なる場合の供給元のコードを取得します｡
getDir() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性dirの値を取得します。
getDir() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
dirを取得します。
getDir() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
dirを取得します。
getDir() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性dirの値を取得します。
getDir() - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes のメソッド
属性dirの値を取得します。
getDiscontinu() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
打切区分を取得します。
getDispQuan() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買発注数量: 表示目的全納入日程合計を取得します。
getDisplayName() - interface jp.co.intra_mart.foundation.security.ClientTypeInfo のメソッド
クライアントタイプ表示名を取得する。
getDisplayName() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターン表示名を取得します。
getDisplayName() - interface jp.co.intra_mart.foundation.security.LocaleInfo のメソッド
ロケ－ル表示名取得。
getDisplayName() - class jp.co.intra_mart.foundation.security.access.AccessController のメソッド
表示名を取得します。
getDisplayName() - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
マイメニュー表示名を取得します。
getDisplayName(Locale) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
表示名を取得します。
getDisplayName(Locale) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニュー名を取得します。
getDisplayName(Locale) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロール表示名を取得します。
getDisplayName() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
データ表示名を取得します。
getDisplayName(Locale) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
データ表示名を取得します。
getDisplayName() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoInternationalModel のメソッド
データ表示名を取得します。
getDisplayName() - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel のメソッド
メニュー表示名を取得します。
getDisplayName() - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
メニュー表示名を取得します。
getDisplayName(Locale) - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
メニュー表示名を取得します。
getDisplayName() - interface jp.co.intra_mart.system.security.datastore.inf.MenuInternationalModel のメソッド
メニュー表示名を取得します。
getDisplayName() - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
ロール表示名を取得します。
getDisplayName(Locale) - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
ロール表示名を取得します。
getDisplayName() - interface jp.co.intra_mart.system.security.datastore.inf.RoleInternationalModel のメソッド
ロール表示名を取得します。
getDistrChan() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
流通チャネルを取得します。
getDistrChan() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
流通チャネルを取得します。
getDistrChan() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
流通チャネルを取得します。
getDistrChan() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDistrChan() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
流通チャネルを取得します。
getDistrChanHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のメソッド
流通チャネルの範囲終了を取得します。
getDistrChanLow() - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のメソッド
流通チャネルの範囲開始を取得します。
getDistrPerc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
配賦率 % (複数勘定設定)を取得します。
getDistrProf() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
サイトの商品の物流プロファイルを取得します。
getDistrctNo() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村/地名ファイルの所在地コードを取得します。
getDistrctNo() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村/地名ファイルの所在地コードを取得します。
getDistrctNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村/地名ファイルの所在地コードを取得します。
getDistrib() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
複数勘定設定の配賦区分を取得します。
getDistrib() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
複数勘定設定の配賦区分を取得します。
getDistributingKey() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)を取得します。
getDistributionChannelSelectionList() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
流通チャネルの選択オプション一覧を取得します｡
getDistributionchannel() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
流通チャネルを取得します。
getDistrict() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
所在地を取得します。
getDistrict() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
所在地を取得します。
getDistrict() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
所在地を取得します。
getDistrict() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
所在地を取得します。
getDistrict() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
所在地を取得します。
getDivision() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製品部門を取得します。
getDivision() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
製品部門を取得します。
getDivision() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
製品部門を取得します。
getDivision() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDivision() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
製品部門を取得します。
getDivision() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDivision() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
製品部門を取得します。
getDliProfil() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
動的明細プロセッサプロファイルを取得します。
getDliProfil() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷ブロック (伝票ヘッダ)を取得します。
getDlvBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvBlock() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出荷ブロック (伝票ヘッダ)を取得します。
getDlvBlock() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷ブロック (伝票ヘッダ)を取得します。
getDlvDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程日付を取得します。
getDlvDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvGroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷グループ (明細一括出荷)を取得します。
getDlvGroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvPrio() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷優先順位を取得します。
getDlvPrio() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvQty() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出荷数量実績 (販売単位)を取得します。
getDlvQty() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷数量実績 (販売単位)を取得します。
getDlvStatH() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
全明細の出荷ステータスを取得します。
getDlvStatI() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
明細の全体出荷ステータスを取得します。
getDlvTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
契約出荷期間を取得します。
getDlvTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
契約出荷期間を取得します。
getDlvTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入時間を取得します。
getDlvTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvUnitIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
ISO コードでの出荷単位の数量単位を取得します。
getDlvschduse() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
用途区分を取得します。
getDlvschduse() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvschduse() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
用途区分を取得します。
getDlvschduse() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDocAcDocNo() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計伝票番号を取得します｡
getDocCat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
購買伝票カテゴリを取得します。
getDocChgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書変更番号 (文書管理システム外)を取得します。
getDocClass() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
リリースおよびトランザクション管理を備えた元システムを取得します。
getDocClass() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDocCompCode() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会社コードを取得します｡
getDocCond() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
伝票条件番号を取得します。
getDocDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買伝票日付を取得します｡
getDocDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
伝票の伝票日付を取得します。
getDocDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
伝票日付 (受信日/送信日)を取得します。
getDocDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDocDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
伝票日付 (受信日/送信日)を取得します。
getDocDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
伝票日付 (受信日/送信日)を取得します。
getDocDocDate() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票の伝票日付を取得します｡
getDocDocType() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票タイプを取得します｡
getDocFisPeriod() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計期間を取得します｡
getDocFiscYear() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計年度を取得します｡
getDocFormat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書のページ書式 (文書管理システムによらない)を取得します。
getDocHeaderTxt() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票ヘッダテキストを取得します｡
getDocNumFi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
ドキュメンタリクレジット処理: 内部番号を取得します。
getDocNumFi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDocNumFi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ドキュメンタリクレジット処理: 内部番号を取得します。
getDocNumFi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDocNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買管理におけるオブジェクト番号を取得します。
getDocNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
伝票番号を取得します。
getDocNumber() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売伝票を取得します。
getDocNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
販売管理伝票番号を取得します。
getDocNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
販売伝票を取得します。
getDocNumber() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
販売伝票を取得します。
getDocObjKey() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
オブジェクトキーを取得します｡
getDocObjType() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
参照処理を取得します｡
getDocPstngDate() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票の転記日付を取得します｡
getDocRefDocNo() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
参照伝票番号を取得します｡
getDocReqd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
文書必須フラグを取得します。
getDocStatus() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
伝票ステータスを取得します。
getDocType() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買伝票カテゴリを取得します。
getDocType() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
伝票タイプを取得します｡
getDocType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書タイプ (文書管理システムによらない)を取得します。
getDocType() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売伝票タイプを取得します。
getDocType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売伝票タイプを取得します。
getDocType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDocType() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売伝票タイプを取得します。
getDocUsername() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
ユーザ名を取得します｡
getDocVers() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書バージョン (文書管理システムによらない)を取得します。
getDocYear() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入出庫伝票年度を取得します。
getDocYear() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫伝票年度を取得します。
getDocYear() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret のメソッド
入出庫伝票年度を取得します。
getDocument() - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties のメソッド
設定ファイルのドキュメントノードを返します。
getDocument() - class jp.co.intra_mart.extension.maskat.util.MKErrors のメソッド
エラー要素群のドキュメントを取得します。
getDocument() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書番号 (文書管理システムによらない)を取得します。
getDocumentDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
登録日付を取得します。
getDocumentDateTo() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
入力日付 (以前/以降)を取得します。
getDocumentHeader() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダを取得します｡
getDocumentHeader() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
伝票ヘッダを取得します｡
getDomain() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
ドメインを返します。
getDontUseP() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱住所配達不可フラグを取得します。
getDontUseS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名住所配達不可フラグを取得します。
getDown() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を取得します。
getDscnt1To() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
現金割引日数1を取得します｡
getDscnt2To() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
現金割引日数2を取得します｡
getDscnt3To() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
現金割引日数3を取得します｡
getDsctPct1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
割引率 1を取得します。
getDsctPct2() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
割引率 2を取得します。
getDsnOffice() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
研究室/設計室を取得します。
getDunCount() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先商談回数を取得します。
getDunCount() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDunDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先との前回の商談日を取得します。
getDunDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDunnBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
督促処理保留を取得します。
getDunnBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDunnBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
督促処理保留を取得します。
getDunnBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDunnKey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
督促処理キーを取得します。
getDunnKey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDunnKey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
督促処理キーを取得します。
getDunnKey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDuplicateLoginDetectionPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor のメソッド
引数で指定されたアクティブなセッション情報が重複ログインした場合の遷移先ページURLを取得します。
getDuplicateLoginDetectionPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager のメソッド
引数で指定されたアクティブなセッション情報が重複ログインした場合の遷移先ページURLを取得します。
getDuplicateLoginDetectionPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor のメソッド
引数で指定されたアクティブなセッション情報が重複ログインした場合の遷移先ページURLを取得します。
getDurationConfirmFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
確認の予測活動期間を取得します。
getDurationConfirmFcUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
確認の予測期間単位を取得します。
getDurationConfirmFcUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getDurationMinimum() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最短活動期間を取得します。
getDurationMinimumFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の最小期間(需要予測より)を取得します。
getDurationMinimumFcUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予測最短期間の単位を取得します。
getDurationMinimumFcUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getDurationMinimumUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最短期間の単位を取得します。
getDurationMinimumUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getDurationNormal() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
標準活動期間を取得します。
getDurationNormalFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
標準活動期間 (予測)を取得します。
getDurationNormalFcUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
標準予測期間の単位を取得します。
getDurationNormalFcUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getDurationNormalUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
標準期間/単位を取得します。
getDurationNormalUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getDurationScheduled() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
処理時間を取得します。
getDurationScheduledFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
処理時間の長さ (予測値)を取得します。
getDurationScheduledUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
処理時間単位を取得します。
getDurationScheduledUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getEMail() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
電子メールアドレスを取得します。
getEMail() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
電子メールアドレスを取得します。
getEMail() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
電子メールアドレスを取得します。
getEanCat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
国際商品コード (EAN) のカテゴリを取得します。
getEanCat() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
国際商品コード (EAN) のカテゴリを取得します。
getEanCat() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
国際商品コード (EAN) のカテゴリを取得します。
getEanUpc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
国際商品コード (EAN/UPC)を取得します。
getEanUpc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
国際商品コード (EAN/UPC)を取得します。
getEanUpc() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
国際商品コード (EAN/UPC)を取得します。
getEanUpc() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
国際商品コード (EAN/UPC)を取得します。
getEanUpc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
国際商品コード (EAN/UPC)を取得します。
getEanUpc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getEarlyFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画終了: 実行 (日)を取得します。
getEarlyFinishDateFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画終了日 (予測)を取得します。
getEarlyFinishTime() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画終了: 実行 (時刻)を取得します。
getEarlyFinishTimeFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画終了時間(需要予測)を取得します。
getEarlyStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画開始: 実行 (日)を取得します。
getEarlyStartDateFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画開始日付(需要予測)を取得します。
getEarlyStartTime() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画開始: 作業実施(時間)を取得します。
getEarlyStartTimeFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画開始時間(需要予測)を取得します。
getEarnedValueIndicator() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
進捗分析関連のマイルストーンを取得します。
getEdition() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
サービスタイプのバージョンを取得します。
getEdition() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスタイプのバージョンを取得します。
getEffODay() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
有効終了日を取得します。
getEiIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
レコード番号を取得します｡
getElement() - class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties のメソッド
現在のプロパティズの元となったエレメントノードを返します。
getEmailAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
メールアドレス1を取得します。
getEmailAddress1(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
メールアドレス1を取得します。
getEmailAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
メールアドレス1を取得します。
getEmailAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
メールアドレス1を取得します。
getEmailAddress1(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
メールアドレス1を取得します。
getEmailAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
メールアドレス1を取得します。
getEmailAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
メールアドレス１を取得します。
getEmailAddress1(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
メールアドレス１を取得します。
getEmailAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
メールアドレス１を取得します。
getEmailAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス1を取得します。
getEmailAddress1(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス1を取得します。
getEmailAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
メールアドレス1を取得します。
getEmailAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス１を取得します。
getEmailAddress1(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス１を取得します。
getEmailAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
メールアドレス１を取得します。
getEmailAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
メールアドレス2を取得します。
getEmailAddress2(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
メールアドレス2を取得します。
getEmailAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
メールアドレス2を取得します。
getEmailAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
メールアドレス2を取得します。
getEmailAddress2(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
メールアドレス2を取得します。
getEmailAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
メールアドレス2を取得します。
getEmailAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
メールアドレス２を取得します。
getEmailAddress2(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
メールアドレス２を取得します。
getEmailAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
メールアドレス２を取得します。
getEmailAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス2を取得します。
getEmailAddress2(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス2を取得します。
getEmailAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
メールアドレス2を取得します。
getEmailAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス２を取得します。
getEmailAddress2(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス２を取得します。
getEmailAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
メールアドレス２を取得します。
getEmaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目コードを取得します。
getEmaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目コード（長）を取得します。
getEmaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目コードの外部GUIDを取得します。
getEmaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目コードのバージョン番号を取得します。
getEncoding() - interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader のメソッド
エクスポートデータのエンコーディング情報を取得します。
getEncoding() - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader のメソッド
インポートデータのエンコーディング情報を取得します。
getEncoding() - interface jp.co.intra_mart.foundation.security.LocaleInfo のメソッド
デフォルトエンコーディングの取得。
getEncoding() - interface jp.co.intra_mart.foundation.security.LocaleProvider のメソッド
エンコーディングを取得する。
getEncoding() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
エンコーディングを取得する。
getEncoding() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
エンコーディング情報を取得します。
getEncoding() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
エンコーディングの取得。
getEncoding() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
エンコーディングを取得する。
getEncoding() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
エンコーディングを取得する。
getEncoding() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
エンコーディングを取得します。
getEncoding(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
現在のリクエストに対するエンコーディングを取得します。
getEncoding() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
エンコーディングを取得する。
getEncoding() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
エンコーディングを取得する。
getEncoding() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
エンコーディングを取得する。
getEncoding() - class jp.co.intra_mart.framework.base.util.UserInfoWrapper のメソッド
ラップされたUserInfoのgetEncoding()を呼び出します。
getEncoding() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
エンコーディングを取得します。
getEncodingAttributeName() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
getEncodingAttributeName() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
getEncodingAttributeName() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
getEncodingAttributeName() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
getEncodingAttributeName() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
getEncodingName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
エンコーディングをセッションに保管するためのパラメータ名を取得する。
getEncodings() - interface jp.co.intra_mart.foundation.security.LocaleInfo のメソッド
ロケ－ルに対応しているエンコーディングの一覧の取得。
getEnctype() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性enctypeの値を取得します。
getEndDate() - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
終了日を取得します。
getEndDate() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
終了日を取得します。
getEndDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
終了日を取得します。
getEndDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
終了日を取得します。
getEndDateColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable のメソッド
期間の日時に該当するカラムのカラム名を取得します。
getEndOffset() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具用途の終了オフセットを取得します。
getEndOffset() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具用途の終了オフセットを取得します。
getEndOffsetNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
終了オフセットは変更できませんを取得します。
getEndOffsetNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
終了オフセットは変更できませんを取得します。
getEndOffsetUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用終了オフセット単位を取得します。
getEndOffsetUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用終了オフセット単位を取得します。
getEndOffsetUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
PRT 用途終了決定の間隔時間単位 (ISO)を取得します。
getEndOffsetUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
PRT 用途終了決定の間隔時間単位 (ISO)を取得します。
getEndRefDate() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用終了日の参照日付を取得します。
getEndRefDate() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用終了日の参照日付を取得します。
getEndRefDateNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
終了参照日付は変更できませんを取得します。
getEndRefDateNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
終了参照日付は変更できませんを取得します。
getEndleadtme() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
補充リードタイムの終了日付を取得します。
getEndtime() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
終了時刻を取得します。
getEntities(String) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
指定の名前を持つエンティティをすべて取得します。
getEntities() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義しているエンティティの一覧を取得します。
getEntities(String) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 指定の名前を持つエンティティをすべて取得します。
getEntity(int) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
指定のインデックスに該当するエンティティを取得します。
getEntity(String) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
指定の名前を持つエンティティを取得します。
getEntity() - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
アクセサの基となるエンティティを取得します。
getEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性が定義されているエンティティを取得します。
getEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張対象となるエンティティを取得します。
getEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
モデル定義の基となるエンティティを取得します。
getEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
テーブル定義の基となるエンティティを取得します。
getEntity(int) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 指定のインデックスに該当するエンティティを取得します。
getEntity(String) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 指定の名前を持つエンティティを取得します。
getEntity(String) - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
リクエストから指定された名前に該当するエンティティを取得します。
getEntity(String) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
リクエストから指定された名前に該当するエンティティを取得します。
getEntityName() - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
マッパーがアクセスするエンティティ名を取得します。
getEntryDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
会計伝票登録日を取得します。
getEntryQnt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入力単位での数量を取得します。
getEntryQnt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入力単位での数量を取得します。
getEntryTime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
登録時刻を取得します。
getEntryUom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入力単位を取得します。
getEntryUom() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入力単位を取得します。
getEntryUomIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
単位の ISO コードを取得します。
getEntryUomIso() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
単位の ISO コードを取得します。
getEnvironment() - class jp.co.intra_mart.foundation.service.provider.Platform の static メソッド
システムの設定値を持つオブジェクトを取得します。
getEnvironmentProperty(String) - class jp.co.intra_mart.foundation.service.provider.Platform の static メソッド
指定のキーに対応するシステムの設定値を取得します。
getEnvtRlvt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: 環境関連を取得します。
getEquipment() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
設備番号を取得します。
getEquityType() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
持分タイプを取得します。
getEquityType() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
持分タイプを取得します。
getErrCode() - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 メール送信時のエラーコードを返す。
getErrMessage() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
ＢＡＰＩの実行結果のエラーメッセージを取得します。
getErrMessage() - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 メール送信時のエラーメッセージを返す。
getErrorCode() - class jp.co.intra_mart.extension.maskat.util.MKError のメソッド
errorCodeを取得します。
getErrorPage(int) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報からエラーページＵＲＬを取得します。
getErrorPage(int, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
エラーページＵＲＬを取得します。
getErrorPage(String) - interface jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor のメソッド
エラーページのパスを取得します。
getErrorPage() - class jp.co.intra_mart.foundation.security.shortcut.ShortCutManager のメソッド
ショートカットエラーページ取得。
getErrorPage(String) - class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor のメソッド
エラーページのパスを取得します。
getErrorTotal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
エラー合計を取得します。
getErrorTotalPp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間のエラー合計を取得します。
getErrorType() - class jp.co.intra_mart.foundation.database.exception.DatabaseExportException のメソッド
推奨されていません。
getErrorsList() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
前明細の不正処理に関する情報を取得します。
getErs() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ERS（入庫/請求自動決済）を取得します。
getEscape() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 ワイルドカード文字をエスケープするのに使用できる文字列を取得します。
getEstPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
概算価格区分を取得します。
getEstimatedCosts() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
指図の見積原価合計を取得します。
getEuListNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
CAP: CAP 製品一覧番号を取得します。
getEuMatGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
EEC 農産物政策: CAP 生産品グループ - 貿易を取得します。
getEutriDeal() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
フラグ: EC 内三角取引を取得します。
getEutriDeal() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getEventFlow(EventNavigatorManager, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
getEventFlow(String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
getEventFlow(EventNavigatorManager, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
getEventFlowIds(EventNavigatorManager) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
すべてのイベントフローIDを取得します。
getEventFlowIds(EventNavigatorManager) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
すべてのイベントフローIDを取得します。
getEventFlowInfos(EventNavigatorManager, String, boolean, int) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
getEventFlowInfos(String, boolean, int) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
getEventFlowInfos(EventNavigatorManager, String, boolean, int) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
getEventFlows(EventNavigatorManager) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
すべてのイベントフローを取得します。
getEventFlows() - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
イベントフローの取得（全件） 全イベントフローを取得し、返却する。
getEventFlows(EventNavigatorManager) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
すべてのイベントフローを取得します。
getEventHistory() - class jp.co.intra_mart.foundation.navigator.EventItemInfo のメソッド
イベント履歴情報リスト取得
getEventHistory() - class jp.co.intra_mart.foundation.navigator.EventResultItemInfo のメソッド
イベント履歴情報リスト取得
getEventHistory() - class jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo のメソッド
イベント履歴情報リスト取得
getEventId() - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject のメソッド
イベントIDを取得します。
getEventItemInfo(EventNavigatorManager, String, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
getEventItemInfo(String, String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
getEventItemInfo(EventNavigatorManager, String, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
getEventListenerFactoryName(String, String) - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリのクラス名を取得します。
getEventListenerFactoryName(String, String) - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリのクラス名を取得します。
getEventListenerFactoryName(String, String) - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリのクラス名を取得します。
getEventListenerFactoryName(String, String) - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリのクラス名を取得します。
getEventListenerFactoryName(String, String) - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
アプリケーションIDとキーに該当するイベントリスナファクトリのクラス名を取得します。
getEventListenerFactoryParams(String, String) - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
getEventListenerFactoryParams(String, String) - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
getEventListenerFactoryParams(String, String) - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
getEventListenerFactoryParams(String, String) - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
getEventListenerFactoryParams(String, String) - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
アプリケーションIDとキーに該当するイベントリスナファクトリの初期パラメータを取得します。
getEventManager() - class jp.co.intra_mart.framework.base.event.EventManager の static メソッド
イベントマネージャを取得します。
getEventName(String, String) - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
キーに該当するイベントのクラス名を取得します。
getEventName(String, String) - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
キーに該当するイベントのクラス名を取得します。
getEventName(String, String) - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler のメソッド
キーに該当するイベントのクラス名を取得します。
getEventName(String, String) - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
キーに該当するイベントのクラス名を取得します。
getEventName(String, String) - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
アプリケーションIDとキーに該当するイベントのクラス名を取得します。
getEventPropertyHandler() - class jp.co.intra_mart.framework.base.event.EventManager のメソッド
イベントプロパティハンドラを取得します。
getEventPropertyHandler() - interface jp.co.intra_mart.framework.base.event.container.EventContainer のメソッド
イベントプロパティハンドラを取得します。
getEventPropertyHandler() - class jp.co.intra_mart.framework.base.event.container.EventContainerImpl のメソッド
イベントプロパティハンドラを取得します。
getEventPropertyHandler() - class jp.co.intra_mart.framework.extension.seasar.event.S2EventContainer のメソッド

getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventResultItemInfo(EventNavigatorManager, String, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
getEventResultItemInfo(String, String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
getEventResultItemInfo(EventNavigatorManager, String, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
getEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getEventTriggerInfos(String, String) - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
アプリケーションIDとキーに該当するイベントのイベントトリガ情報をすべて取得します。
getEventual() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
偶発的明細を取得します。
getExCertDt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
非該当証明書発行日を取得します。
getExCertId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
法令管理: 認定書区分を取得します。
getExCertNoNew() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
非該当証明書番号 - 法令管理を取得します。
getExIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
レコード番号を取得します｡
getExRateFi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
FI 転記の換算レート (直接相場)を取得します。
getExRateFi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getExRateFx() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
換算レート固定区分を取得します｡
getExceptList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
例外メッセージバーを取得します。
getException() - class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent のメソッド
通知されたエラーまたは例外を取得します。
getException() - class jp.co.intra_mart.foundation.utility.ErrorEvent のメソッド
推奨されていません。 通知されたエラーまたは例外を取得します。
getException() - class jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean のメソッド
例外を取得します。
getException() - class jp.co.intra_mart.framework.system.exception.FrameworkException のメソッド
この例外が発生した原因となる例外を取得します。
getExceptionAttributeName() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
getExceptionAttributeName() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
getExceptionAttributeName() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
getExceptionAttributeName() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
getExceptionAttributeName() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
getExchRate() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
直接呼び値換算レートを取得します。
getExchRate() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
換算レート、係数 (通貨ペア)を取得します。
getExchRate() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
換算レート、係数 (通貨ペア)を取得します。
getExchRate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
換算レートを取得します｡
getExchRateCm() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
間接呼び値換算レートを取得します。
getExchRateFiV() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
FI 転記の換算レート (間接相場)を取得します。
getExchRateFiV() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getExchRateFiV() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
FI 転記の換算レート (間接相場)を取得します。
getExchRateFiV() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getExchRateV() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
間接呼び値換算レートを取得します。
getExchangeRate() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
価格設定/統計用換算レートを取得します。
getExchgRate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格設定/統計の換算レート (直接引用)を取得します。
getExchgRate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getExchgRate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格設定/統計の換算レート (直接引用)を取得します。
getExchgRate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getExchgRate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
価格設定/統計の換算レート (直接引用)を取得します。
getExchgRateV() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格設定/統計の換算レート (間接引用)を取得します。
getExchgRateV() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getExchgRateV() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格設定/統計の換算レート (間接引用)を取得します。
getExchgRateV() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getExchgRateV() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
価格設定/統計の換算レート (間接引用)を取得します。
getExecuteUser() - interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader のメソッド
実行ユーザコードを取得します。
getExecuteUser() - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader のメソッド
実行ユーザコードを取得します。
getExecutingLineNumber() - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 現在エクスポート実行中の行番号を返します。
getExpActivityList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
活動に関する詳細情報を取得します。
getExpActivityList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
活動に関する詳細情報を取得します。
getExpExpList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(export(Export))の一覧を取得します｡
getExpMessageList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
詳細情報を読み込みエラーを取得します。
getExpMessageList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
詳細情報を読み込みエラーを取得します。
getExpStrList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(structure(Export))の一覧を取得します｡
getExpTblList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(table(Export))の一覧を取得します｡
getExpValue() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
見込金額を取得します。
getExpWbsElementList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
WBS 要素についての詳細情報を取得します。
getExpWbsElementList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
WBS 要素についての詳細情報を取得します。
getExpWbsHierarchieList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
WBS 階層についての情報を取得します。
getExpWbsHierarchieList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
WBS 階層についての情報を取得します。
getExpWbsMilestoneList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
WBS マイルストーンに関する詳細情報を取得します。
getExpWbsMilestoneList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
WBS マイルストーンに関する詳細情報を取得します。
getExpimpNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
貿易データ番号: MM/SD 伝票を取得します。
getExpimpgrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
輸出/輸入品目グループを取得します。
getExpirationDate() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
役職情報の有効終了日を取得します。
getExpirationDate() - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
終了時間を取得します。
getExpirationKey() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ソースエンティティのライフタイム期間の有効終了日時を取得します。
getExpireInterval() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
クライアントのアクセスとアクセスの間に、サーブレットコンテナがこのセッションを保ち続ける最大の時間間隔を秒数で返します。
getExpiredDate() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
試用期限の日付を取得します。
getExpirydate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
有効期間期限日を取得します。
getExpirydate() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
有効期間期限日を取得します。
getExplain() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
説明を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
アクセスコントローラエクスポート用のカテゴリの一覧を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントエクスポート用のカテゴリの一覧を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチエクスポート用のカテゴリの一覧を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーエクスポート用のカテゴリの一覧を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
管理メニューエクスポート用のカテゴリの一覧を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューエクスポート用のカテゴリの一覧を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロールエクスポート用のカテゴリの一覧を取得します。
getExportHeader() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
貿易管理ヘッダを取得します｡
getExportImportProcedure() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
貿易の輸出入手続を取得します。
getExportItemList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
貿易管理明細一覧を取得します｡
getExportManager() - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
エクスポートマネージャーのインスタンスを取得します。
getExportManager() - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient のメソッド

getExportManager() - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient のメソッド

getExportManager() - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient のメソッド

getExportManager() - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient のメソッド

getExportManager() - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient のメソッド

getExportNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
貿易データ番号: MM/SD 伝票を取得します。
getExportParam(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
export(Export)情報を返します。
getExpostPds() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
事後的需要予測に含む履歴値の数を取得します。
getExpostVal() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
事後的需要予測値を取得します。
getExrateFi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
FI 転記の換算レート (直接相場)を取得します。
getExrateFi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getExtLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
明細番号を取得します。
getExtOrdNo() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
外部指図番号を取得します。
getExtServ() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
仕入先のサービス番号を取得します。
getExtWms() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
外部倉庫管理の転記の制御を取得します。
getExtendedBaseAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
基本アクセサに関連する拡張基本アクセサのマップを取得します。
getExtendedBaseModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張基本モデルを取得します。
getExtendedBaseModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel のメソッド
拡張基本エンティティに対応する拡張基本モデルのマップを取得します。
getExtendedBaseModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
拡張基本モデルマップを取得します。
getExtendedBaseModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
拡張基本モデルのマップを取得します。
getExtendedBaseTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張基本テーブルを取得します。
getExtendedDepartment(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
指定された拡張情報を取得します。
getExtendedDepartmentTerminable(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
指定された拡張情報を取得します。
getExtendedDepartmentTerminableInternational(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
指定された拡張情報を取得します。
getExtendedDepartmentTerminableInternationals() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
この組織の基本情報に対する拡張情報をすべて取得します。
getExtendedDepartmentTerminables() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
この組織の期間化情報に対する拡張情報をすべて取得します。
getExtendedDepartments() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
この組織の基本情報に対する拡張情報をすべて取得します。
getExtendedEntities() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義している拡張エンティティの一覧を取得します。
getExtendedEntities() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
このエンティティを拡張している拡張エンティティをすべて取得します。
getExtendedEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性が定義されている拡張エンティティを取得します。
getExtendedEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張モデル定義の基となる拡張エンティティを取得します。
getExtendedEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張テーブル定義の基となる拡張エンティティを取得します。
getExtendedHttpServletResponse() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このオブジェクトにラップされているレスポンスを返します。
getExtendedInternationalAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor のメソッド
この国際化アクセサに対する拡張国際化アクセサのマップを取得します。
getExtendedInternationalModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張国際化モデルを取得します。
getExtendedInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のメソッド
拡張国際化モデルのマップを取得します。
getExtendedInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel のメソッド
拡張国際化エンティティに対応する拡張国際化モデルのマップを取得します。
getExtendedInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext のメソッド
拡張国際化モデルマップを取得します。
getExtendedInternationalTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張国際化テーブルを取得します。
getExtendedMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider のメソッド
拡張メインページURLを取得します。
getExtendedMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider のメソッド
拡張メインページURLを取得します。
getExtendedMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryUserPageProvider のメソッド

getExtendedModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseModel のメソッド
拡張基本モデルが定義されている拡張モデル定義を取得します。
getExtendedModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
この拡張エンティティを参照している拡張モデルを取得します。
getExtendedModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalModel のメソッド
拡張国際化モデルが定義されている拡張モデル定義を取得します。
getExtendedModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalModel のメソッド
拡張期間国際化モデルが定義されている拡張モデル定義を取得します。
getExtendedModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableModel のメソッド
拡張期間化モデルが定義されている拡張モデル定義を取得します。
getExtendedModels() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義している拡張モデル定義の一覧を取得します。
getExtendedTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable のメソッド
拡張基本テーブルが定義されている拡張テーブル定義を取得します。
getExtendedTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
この拡張エンティティを参照している拡張テーブルを取得します。
getExtendedTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable のメソッド
拡張国際化テーブルが定義されている拡張テーブル定義を取得します。
getExtendedTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable のメソッド
拡張期間国際化テーブルが定義されている拡張テーブル定義を取得します。
getExtendedTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable のメソッド
拡張期間化テーブルが定義されている拡張テーブル定義を取得します。
getExtendedTables() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義している拡張テーブル定義の一覧を取得します。
getExtendedTerminableAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
この期間化アクセサに対する拡張期間化アクセサのマップを取得します。
getExtendedTerminableInternationalAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor のメソッド
この期間国際化アクセサの拡張期間国際化アクセサのマップを取得します。
getExtendedTerminableInternationalModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張期間国際化モデルを取得します。
getExtendedTerminableInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のメソッド
拡張期間国際化モデルのマップを取得します。
getExtendedTerminableInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel のメソッド
拡張期間国際化エンティティに対応する拡張期間国際化モデルのマップを取得します。
getExtendedTerminableInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext のメソッド
拡張期間国際化モデルマップを取得します。
getExtendedTerminableInternationalTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張期間国際化テーブルを取得します。
getExtendedTerminableModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張期間化モデルを取得します。
getExtendedTerminableModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
拡張期間化モデルのマップを取得します。
getExtendedTerminableModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel のメソッド
拡張期間化エンティティに対応する拡張期間化モデルのマップを取得します。
getExtendedTerminableModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
拡張期間化モデルマップを取得します。
getExtendedTerminableTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張期間化テーブルを取得します。
getExtendedUser(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
指定された拡張情報を取得します。
getExtendedUserTerminable(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
指定された拡張情報を取得します。
getExtendedUserTerminableInternational(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
指定された拡張情報を取得します。
getExtendedUserTerminableInternationals() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
このユーザの基本情報に対する拡張情報をすべて取得します。
getExtendedUserTerminables() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
このユーザの期間化情報に対する拡張情報をすべて取得します。
getExtendedUsers() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
このユーザの基本情報に対する拡張情報をすべて取得します。
getExtensionFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
内線FAX番号を取得します。
getExtensionIn(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造が既に存在するか チェックします。
getExtensionInList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。
getExtensionInList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
VBAK、VBAP、VBEP のカスタマ拡張を取得します。
getExtensionInList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
VBAK、VBAP、VBEP のカスタマ拡張を取得します。
getExtensionInList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
VBAK、VBAP、VBEP のカスタマ拡張を取得します。
getExtensionInX(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
拡張イン/拡張アウトのチェックボックス構造が既に存在するかチェックします。
getExtensionInXList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
拡張イン/拡張アウトのチェックボックス構造を取得します。
getExtensionList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
拡張得意先項目一覧を取得します｡
getExtensionNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
内線番号を取得します。
getExtensionNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
内線番号を取得します。
getExtensionNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
内線番号を取得します。
getExtensionNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
内線番号を取得します。
getExtensionNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
内線番号を取得します。
getExtensionNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
内線番号を取得します。
getExtensionNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
内線番号を取得します。
getExtensionNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
内線番号を取得します。
getExtensionNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
内線番号を取得します。
getExtensionNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線番号を取得します。
getExtensionNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線番号を取得します。
getExtensionNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
内線番号を取得します。
getExtensionNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線番号を取得します。
getExtensionNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線番号を取得します。
getExtensionNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
内線番号を取得します。
getExtensionOut(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のメソッド
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造オブジェクトが既に 存在するかチェックします。
getExtensionOutList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。
getExtensionParameterNames() - interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader のメソッド
パラメータ名の一覧を取得します。
getExtensionParameterNames() - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader のメソッド
パラメータ名の一覧を取得します。
getExtensionParameterValue(String) - interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader のメソッド
指定されたキーに対するパラメータ値を取得します。
getExtensionParameterValue(String) - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader のメソッド
指定されたキーに対するパラメータ値を取得します。
getExternalObjectId() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
SAP 外部対象キーを取得します。
getExtesion() - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
サービスフレームワークを呼び出すための拡張子を取得します。
getExtmatlgrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
外部品目グループを取得します。
getExtpersNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
外部従業員番号を取得します。
getExtrefkey() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
サービスの外部参照キーを取得します。
getFactbasval() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件基礎値に対する要因を取得します。
getFactbasval() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件基礎値に対する要因を取得します。
getFactconbas() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件基準の係数 (期間)を取得します。
getFactor() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
バリアント条件の加重係数を取得します。
getFactoryCalendar() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
稼働日カレンダを取得します。
getFairShareRule() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
均等配賦ルールを取得します。
getFavoriteMenu(String, String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
マイメニュー情報を取得する。
getFavoriteMenu(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
マイメニュー情報を取得する。
getFavoriteMenuIds(String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
マイメニューIDをすべて取得する。
getFavoriteMenuIds(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
マイメニューIDをすべて取得する。
getFavoriteMenuIds(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
マイメニューIDをすべて取得します。
getFavoriteMenus(String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
マイメニュー情報をすべて取得する。
getFavoriteMenus(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
マイメニュー情報をすべて取得する。
getFavoriteMenus(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
マイメニューをすべて取得します。
getFax() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
得意先/仕入先の経理担当者のファックス No.を取得します。
getFax1() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
FAX 1を取得します｡
getFaxExtens() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
第一 FAX 番号: 内線を取得します。
getFaxExtens() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
第一 FAX 番号: 内線を取得します。
getFaxExtens() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
第一 FAX 番号: 内線を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
FAX番号を取得します。
getFaxNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
FAX番号を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
FAX番号を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
FAX番号を取得します。
getFaxNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
FAX番号を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
FAX番号を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
FAX番号を取得します。
getFaxNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
FAX番号を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
FAX番号を取得します。
getFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
FAX番号を取得します。
getFaxNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
FAX番号を取得します。
getFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
FAX番号を取得します。
getFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
FAX番号を取得します。
getFaxNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
FAX番号を取得します。
getFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
FAX番号を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
第一 FAX 番号: ダイヤルコード + 番号を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
第一 FAX 番号: ダイヤルコード + 番号を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
第一 FAX 番号: ダイヤルコード + 番号を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
FAX 番号を取得します。
getField() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
フィールドを取得します｡
getField() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
パラメータの項目を取得します。
getFieldName() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
フィールド名を取得します。
getFieldname() - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
項目名を取得します。
getFieldsList() - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のメソッド
パースした結果のフィールド一覧リストを返します。
getFijCurCostEst() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
当期標準原価見積の会計年度を取得します。
getFijFutCostEst() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
将来標準原価見積の会計年度を取得します。
getFijPreCostEst() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期標準原価見積の会計年度を取得します。
getFile() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
このオブジェクトが文字を書き出すファイルを取得します。
getFile() - interface jp.co.intra_mart.foundation.mail.javamail.model.AttachmentFile のメソッド
添付ファイルを取得します。
getFile(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
このオブジェクトの表すディレクトリにキー id でマップされた ExternalMemory インスタンスを取得します。
getFile(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
このオブジェクトの表すディレクトリにキー id でマップされた PermanentFile インスタンスを取得します。
getFile(String) - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
このオブジェクトの表すディレクトリにキー id でマップされた SessionMemory インスタンスを取得します。
getFile() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
現在有効なセッションを扱う SessionMemory インスタンスを取得します。
getFile(String) - interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory のメソッド
このオブジェクトの表すディレクトリにキー id でマップされた TreasureFile インスタンスを取得します。
getFile() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 このオブジェクトが文字を書き出すファイルを取得します。
getFileName() - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity のメソッド
アップロードされたファイルのファイル名を取得します。
getFileName(Map) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload のメソッド
ヘッダのContent-Dispositionに含まれるファイル名を返します。
getFileName() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
推奨されていません。 アップロードされたファイルのファイル名を取得します。
getFill() - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
描画されるグラフの塗りつぶし可否を返します。
getFillLevel() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
最大レベル (容積別)を取得します。
getFilter() - interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader のメソッド
エクスポートのフィルタ情報を取得します。
getFilterConfig() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
このフィルタの設定オブジェクトを返します。
getFilterParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このフィルタのパラメータを返します。
getFilterParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このハンドラによって実行されるフィルタイベントに対する 設定済みパラメータのマップを返します。
getFinalInv() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
請求書処理完了区分を取得します。
getFinish() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクトの計画終了日を取得します。
getFirstDay() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
値参照期間の第一日目を取得します。
getFirstDay() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
値参照期間の第一日目を取得します。
getFirstDay() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
値参照期間の第一日目を取得します。
getFirstMenuIds(String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
第一階層に属するメニューIDを配列で取得します。
getFirstMenuIds() - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
第一階層に属するノードを配列で取得します。
getFirstMenuIds() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
第一階層のメニューIDをすべて取得します。
getFirstMenuIds(String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
第一階層に属するノードを配列で取得します。
getFirstMenuIds() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
第一階層のメニューIDをすべて取得します。
getFiscYear() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
当会計年度を取得します。
getFiscYear() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
当会計年度を取得します。
getFixLotSize() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要供給の一致に対する固定ロットサイズを取得します。
getFixValDy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
有効日日付を取得します。
getFixValDy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getFixValDy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
有効日日付を取得します。
getFixValDy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getFixdatQty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
納期と出荷数量の固定を取得します。
getFixdatQty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getFixedLot() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
固定ロットサイズを取得します。
getFixedMilestoneDateBasic() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
固定マイルストーン日付(基準)を取得します。
getFixedMilestoneDateForecast() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン固定日付を取得します。
getFixedMilestoneTimeBasic() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
固定マイルストーン時間(基準)を取得します。
getFixedMilestoneTimeForecast() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン固定時間 (F)を取得します。
getFixedPds() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
固定期間を取得します。
getFixedQuan() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
数量固定区分を取得します。
getFixedQuan() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getFkkConacct() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
長さ 12 の文字項目を取得します。
getFkkConacct() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getFkkConacct() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
長さ 12 の文字項目を取得します。
getFkkConacct() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getFlagCadCall() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
CAD システムからコールを取得します。
getFlexibleDuration() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
区分: 可変期間を取得します。
getFloatFree() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
自由余裕を取得します。
getFloatFreeFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
自由余裕 (予測)を取得します。
getFloatTotal() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
余裕合計を取得します。
getFloatTotalFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
余裕合計 (予測)を取得します。
getFloor() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
建物の階を取得します。
getFloor() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
建物の階を取得します。
getFloor() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
建物の階を取得します。
getFollowUp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
フォローアップ品目を取得します。
getFollowUpExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)を取得します。
getFollowUpGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)を取得します。
getFollowUpVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 FOLLOW_UP のバージョン番号 (今後のリリースで開発)を取得します。
getFontColor() - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
キャプションの文字色を返します。
getFontSize() - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
キャプションの文字サイズを返します。
getForeDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
最終需要予測日を取得します。
getForeModel() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
予測モデルを取得します。
getForePds() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
需要予測期間を取得します。
getForeProf() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
需要予測プロファイルを取得します。
getForeValue() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
予測値を取得します。
getForecFlowCont() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
予測フロー管理を取得します。
getForecastFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予測終了日を取得します。
getForecastParameters() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
予測パラメータを取得します。
getForecastParametersList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
需要予測パラメータが既に存在するかチェックします。
getForecastParametersList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
需要予測パラメータを取得します。
getForecastValues(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
需要予測値のデータ転送が既に存在するかチェックします。
getForecastValuesList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
需要予測値のデータ転送を取得します。
getForecastView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要予測ビューを取得します。
getForecastView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
需要予測ビューを取得します。
getForeignKeys() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ソースエンティティの外部キーの集合を取得します。
getForm() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
ターゲットとなるフォーム名を取得します。
getFormVal1() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を取得します。
getFormVal2() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を取得します。
getFormVal3() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を取得します。
getFormVal4() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を取得します。
getFormVal5() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を取得します。
getFormat() - class jp.co.intra_mart.foundation.database.DatabaseColumn のメソッド

getFormat() - interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader のメソッド
エクスポートデータのフォーマットを取得します。
getFormat() - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader のメソッド
インポートデータのフォーマットを取得します。
getFormatCol() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のメソッド
タグ列を取得します。
getFormatCol() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
タグ列を取得します。
getFormatCol() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
タグ列を取得します。
getFormatCol() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
タグ列を取得します。
getFormatCol() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
タグ列を取得します。
getFormclass() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性classの値を取得します。
getFormofaddr() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
敬称を取得します。
getFormofaddr() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
敬称テキストを取得します。
getFormofaddr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
敬称テキストを取得します。
getFormula() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式番号を取得します。
getFormulaTotQty() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具の合計数量の計算式を取得します。
getFormulaTotQty() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具の合計数量の計算式を取得します。
getFormulaTotQtyNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
合計数量の計算式は変更できませんを取得します。
getFormulaTotQtyNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
合計数量の計算式は変更できませんを取得します。
getFormulaTotUsage() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具の総用途値の計算式を取得します。
getFormulaTotUsage() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具の総用途値の計算式を取得します。
getFormulaTotUsageNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
すべての用途値を計算する計算式は変更できませんを取得します。
getFormulaTotUsageNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
すべての用途値を計算する計算式は変更できませんを取得します。
getFrameClass() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
推奨されていません。 このメソッドではなくFrameTag.getFrameclass()メソッドを使用してください。
getFrameborder() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
frameborderを取得します。
getFrameclass() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
frameClassを取得します。
getFreeItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
無償明細を取得します。
getFreeLimit() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
自由制限を取得します。
getFrom() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Fromを取得します。
getFromCurr() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算前通貨を取得します。
getFromCurr() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
換算前通貨を取得します。
getFromCurr() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
換算前通貨を取得します。
getFromFactor() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算前 通貨単位の係数を取得します。
getFromFactorV() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算前 通貨単位の係数を取得します。
getFromLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
下限を取得します。
getFuncArea() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
機能領域を取得します。
getFuncArea() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
機能領域を取得します。
getFuncArea() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
機能領域を取得します。
getFuncArea() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
機能領域を取得します。
getFuncArea() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
機能領域を取得します。
getFuncArea() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
機能領域を取得します。
getFuncArea() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
機能領域を取得します。
getFuncArea() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
機能領域を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
機能領域を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
機能領域を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
機能領域を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
機能領域を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
機能領域を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
機能領域を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
機能領域を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
機能領域を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
機能を取得します。
getFunctionalLocation() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
機能場所を取得します。
getFund() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
会計区分を取得します。
getFund() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
会計区分を取得します。
getFund() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
会計区分を取得します。
getFund() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
会計区分を取得します。
getFundsCtr() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
予算センタを取得します。
getFundsCtr() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
予算センタを取得します。
getFundsCtr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
予算センタを取得します。
getFundsCtr() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
予算センタを取得します。
getFuturePr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
次期標準原価を取得します。
getFwdCons() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費期間: 前方を取得します。
getFxdPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
固定価格連産品を取得します。
getFyVariant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
会計年度バリアントを取得します。
getFyVariant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
会計年度バリアントを取得します。
getGammaFact() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
ガンマ係数使用の平滑化のための季節指数を取得します。
getGeneralDataInfo() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
一般データ情報を取得します｡
getGeneralDataInfo() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
一般データ情報を取得します｡
getGeneralDataInfo() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
一般データ情報を取得します｡
getGeneralDataInfo() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
一般データ情報を取得します｡
getGeneralDataInfo() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
一般データ情報を取得します｡
getGeneralDataInfo() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
一般データ情報を取得します｡
getGiDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
出庫日付を取得します。
getGiDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
出庫日付を取得します。
getGiDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getGiDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出庫日付を取得します。
getGiTime() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
出庫時刻 (現地時間 - プラント参照)を取得します。
getGiTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
出庫時刻 (現地時間 - プラント参照)を取得します。
getGiTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getGlAccList() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
勘定項目情報一覧を取得します。
getGlAccList() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList のメソッド
勘定項目情報一覧を取得します｡
getGlAccount() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
G/L勘定コードを取得します｡
getGlAccount() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
G/L 勘定コードを取得します。
getGlAccount() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
G/L 勘定コードを取得します。
getGlAccount() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
G/L 勘定コードを取得します。
getGlAllocNmbr() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
ソートキーを取得します｡
getGlBusArea() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
事業領域を取得します｡
getGlCompCode() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会社コードを取得します｡
getGlCostcenter() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
原価センタを取得します｡
getGlDocType() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
伝票タイプを取得します｡
getGlFiscYear() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会計年度を取得します｡
getGlGlAccount() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
総勘定元帳勘定を取得します｡
getGlIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
レコード番号を取得します｡
getGlIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
レコード番号を設定します｡
getGlItemText() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
明細テキストを取得します｡
getGlItemnoAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会計伝票明細番号を取得します｡
getGlList() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
勘定科目一覧を取得します｡
getGlOrderid() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
指図番号を取得します｡
getGlPstngDate() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
伝票の転記日付を取得します｡
getGlRefKey1() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
取引先参照キーを取得します｡
getGlTaxCode() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
消費税コードを取得します｡
getGlWbsElement() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
WBS 要素を取得します｡
getGmCode() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode のメソッド
BAPI 在庫移動トランザクションのコード割当を取得します。
getGoOut() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
外出フラグを取得します。
getGoodsMvtCode() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
在庫移動に対するコードのトランザクションへの割当を取得します。
getGoodsMvtHeader() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票ヘッダデータを取得します。
getGoodsMvtHeaderList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
リターン構造、入出庫伝票ヘッダを取得します。
getGoodsMvtHeadret() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票番号/入出庫伝票会計年度を取得します。
getGoodsMvtItemList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票明細を取得します。
getGoodsMvtItemsList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
リターン構造、入出庫伝票明細を取得します。
getGoodsMvtSerialNumberList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
シリアル番号を取得します。
getGrBasediv() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
入庫基準の請求書照合区分を取得します。
getGrGiSlipNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入出庫票番号を取得します。
getGrInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
入庫区分を取得します。
getGrMessage() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
入庫メッセージ区分を取得します｡
getGrNonVal() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
非評価入庫を取得します。
getGrNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫番号を取得します。
getGrPrTime() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
入庫処理日数を取得します。
getGrPrTime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
入庫処理日数を取得します。
getGrPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
基準額を取得します。
getGrRcpt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
受領者を取得します。
getGrRcpt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
受領者を取得します。
getGrRcpt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
受領者を取得します。
getGrRcptx() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
関連ユーザデータ項目の更新情報を取得します。
getGrToDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
納入最終期限を取得します。
getGrantNbr() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
補助金を取得します。
getGrantNbr() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
補助金を取得します。
getGrantNbr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
補助金を取得します。
getGrantNbr() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
補助金を取得します。
getGraphBackgroundColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
グラフ領域の背景色を返します。
getGraphBackgroundColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
グラフ領域の背景色を返します。
getGraphBackgroundColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
グラフ領域の背景色を返します。
getGraphBorderColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
グラフ領域のボーダーの色を返します。
getGraphBorderColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
グラフ領域のボーダーの色を返します。
getGraphBorderColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
グラフ領域のボーダーの色を返します。
getGraphFrameColor() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
グラフ枠の線色を返します。
getGroValueItem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
総額を取得します。
getGrossWght() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細の総重量を取得します。
getGrossWght() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getGrossWt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
総重量を取得します。
getGrossWt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
総重量を取得します。
getGroup() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing のメソッド
グループIDを取得します。
getGroup() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing のメソッド
グループIDを取得します。
getGroup() - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler のメソッド
設定されているグループＩＤを返します。
getGroupCode() - class jp.co.intra_mart.foundation.security.PublicGroupInfo のメソッド
グループコードを取得します。
getGroupDatabaseType(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
ログイングループデータソースおけるデータベースの種類を取得する。
getGroupErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
ログイングループエラーページURLを取得する。
getGroupErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
ログイングループエラーページURLを取得します。
getGroupId() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
ログイングループIDを取得する。
getGroupId() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド

getGroupId() - class jp.co.intra_mart.foundation.update.UpdateManager のメソッド
ログイングループIDを取得します。
getGroupImageIcons() - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
すべてのグループイメージアイコンを取得します。
getGroupSetCode() - class jp.co.intra_mart.foundation.security.PublicGroupInfo のメソッド
グループセットコードを取得します。
getGroupcond() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
グループ条件区分を取得します。
getGroupcond() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
グループ条件区分を取得します。
getGroupname() - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
グループ名を取得します。
getGroupname() - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
グループ名を取得します。
getGroupname() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
グループ名を取得します。
getGroupname() - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
グループ名を取得します。
getGrpKey1() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具のグループキー 1を取得します。
getGrpKey1() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具のグループキー 1を取得します。
getGrpKey2() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具のグループキー 2を取得します。
getGrpKey2() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具のグループキー 2を取得します。
getGrpReqmts() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 所要量グループ化を取得します。
getGtinVariant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
グローバルトレード明細番号バリアントを取得します。
getGtinVariant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
グローバルトレード明細番号バリアントを取得します。
getHCurr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
通貨コードを取得します。
getHCurr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getHCurrIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
ISO 通貨コードを取得します。
getHTML() - interface jp.co.intra_mart.foundation.portal.common.rss.RSSParserIF のメソッド
解析結果HTMLを返却します
getHandlerName(String) - class jp.co.intra_mart.foundation.commons.SourceProviderHandler のメソッド
ソースプロバイダクラス名を取得します。
getHandlgGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ワークロード計算のロジスティクス処理グループを取得します。
getHazMatNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
危険物コードを取得します。
getHazMatNoExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 HAZ_MAT_NO の品目コード (長) (今後のリリースで開発)を取得します。
getHazMatNoGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)を取得します。
getHazMatNoVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 HAZ_MAT_NO のバージョン番号 (今後のリリースで開発)を取得します。
getHazmatprof() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
危険物インジケータプロファイルを取得します。
getHdOffice() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
本店勘定コードを取得します。
getHeadData(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
管理情報設定ヘッダセグメントが既に存在するかチェックします。
getHeadDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
管理情報設定ヘッダセグメントを取得します。
getHeader(String) - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity のメソッド
ヘッダの取得。
getHeader(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
指定のヘッダの値を返します。
getHeader(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse のメソッド
指定された名称でレスポンスヘッダに設定されている値を返します。
getHeader(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getHeader(String) メソッドをそのまま呼び出します。
getHeader(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
指定された名称でレスポンスヘッダに設定されている値を返します。
getHeader(String) - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
推奨されていません。 ヘッダの取得。
getHeaderNames() - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity のメソッド
ヘッダ名称一覧の取得。
getHeaderNames() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
ヘッダ名称一覧を返します。
getHeaderNames() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
推奨されていません。 ヘッダ名称一覧の取得。
getHeaderTextList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
ヘッダテキスト一覧を取得します｡
getHeaderTxt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
伝票ヘッダテキストを取得します。
getHeaders() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
ヘッダ情報を取得します。
getHeaders(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse のメソッド
指定された名称でレスポンスヘッダに設定されている全ての値を返します。
getHeaders(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getHeaders(String) メソッドをそのまま呼び出します。
getHeaders(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
指定された名称でレスポンスヘッダに設定されている全ての値を返します。
getHeight() - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルの高さを返却します。
getHeight() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
表示単位に対する高さを取得します。
getHeight() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
高さを取得します。
getHelperclass() - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag のメソッド
クラス名を取得します。
getHgLvItem() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
BOM 構成の上位レベル明細を取得します。
getHgLvItem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
上位レベル明細を取得します。
getHgLvItem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getHiLineNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
上位階層明細番号を取得します。
getHierarchyNodesList() - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
階層ノード一覧を取得します。
getHierarchyNodesList() - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
階層ノード一覧を取得します。
getHierarchyNodesList() - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
階層ノード一覧を取得します。
getHierarchyValuesList() - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
階層値一覧を取得します。
getHierarchyValuesList() - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
階層値一覧を取得します。
getHierarchyValuesList() - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
階層値一覧を取得します。
getHierlevel() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
階層のエントリレベルを取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
ロット番号を取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
品目コードを取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
移動タイプ (在庫管理)を取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
プラントを取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
伝票の転記日付を取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
特殊在庫区分を取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
保管場所を取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
トランザクション/イベントタイプを取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
ユーザ名を取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
仕入先勘定コードを取得します。
getHighVisc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: 高粘性を取得します。
getHistVals() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
履歴値の数を取得します。
getHlItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買伝票中の上位明細を取得します。
getHodildayInfos() - class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo のメソッド
データタイプが休日であるカレンダーデータの一覧を取得します。
getHold() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
購買発注の不完全を取得します。
getHoldability() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection オブジェクトを使用して生成された ResultSet オブジェクトの現在の保持機能を取得します。
getHomeCity() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村 (郵便用市区町村と異なる場合)を取得します。
getHomecityno() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
別の市区町村 (市区町村/地名ファイル)を取得します。
getHomepage() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
URI 例: ホームページ、FTP アドレスを取得します。
getHost() - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
接続先IPアドレスを取得する為の抽象メソッド

getHost() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing のメソッド
接続先IPアドレスを取得します。
getHost() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing のメソッド
接続先IPアドレスを取得します。
getHost() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing のメソッド
接続先IPアドレスを取得します。
getHost() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing のメソッド
接続先IPアドレスを取得します。
getHostAddress() - class jp.co.intra_mart.common.aid.jdk.java.net.Localhost のメソッド
このコンピュータのアドレスを返します。
getHostAddress() - class jp.co.intra_mart.foundation.utility.net.Localhost のメソッド
推奨されていません。 このコンピュータのアドレスを返します。
getHostName() - class jp.co.intra_mart.common.aid.jdk.java.net.Localhost のメソッド
このコンピュータのホスト名を返します。
getHostName() - class jp.co.intra_mart.foundation.utility.net.Localhost のメソッド
推奨されていません。 このコンピュータのホスト名を返します。
getHouseNo() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
番地-号を取得します。
getHouseNo() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
番地-号を取得します。
getHouseNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
番地-号を取得します。
getHouseNo2() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
番地補足を取得します。
getHouseNo2() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
番地補足を取得します。
getHouseNo2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
番地補足を取得します。
getHouseNo3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
番地範囲を取得します。
getHreflang() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
hreflangを取得します。
getHttpServletRequest() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
リクエストを返します。
getHttpServletRequest() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
現在のイベントを要求したリクエストを返します。
getHttpServletResponse() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このオブジェクトにラップされているレスポンスを返します。
getHttpServletResponseEventConfig() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
このリスナに渡された設定オブジェクトを返します。
getHttpServletResponseEventListener() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
リスナを返します。
getIDs() - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getUserIds()に置き換えられました。
getIDs() - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRoleIds()に置き換えられました。
getId() - class jp.co.intra_mart.foundation.navigator.EventFlow のメソッド

getId() - class jp.co.intra_mart.foundation.navigator.EventFlowInfo のメソッド
イベントフローID取得
getId() - class jp.co.intra_mart.foundation.navigator.EventHistoryInfo のメソッド
イベントアイテムID取得
getId() - class jp.co.intra_mart.foundation.navigator.EventItemInfo のメソッド
イベントアイテムID取得
getId() - class jp.co.intra_mart.foundation.navigator.EventResultItemInfo のメソッド
ナビゲート結果ID取得
getId() - class jp.co.intra_mart.foundation.navigator.ResultPageItemInfo のメソッド
保存結果ページID取得
getId() - class jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo のメソッド
保存ナビゲート結果ID取得
getId() - class jp.co.intra_mart.foundation.navigator.SelectItemInfo のメソッド
選択アイテムID取得
getId() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ＩＤを取得します｡
getId() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージクラスを取得します。
getId() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージクラスを取得します。
getId() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニューIDを取得します。
getIdByName(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.searchRolesByName(String)に置き換えられました。
getIdentifier() - interface jp.co.intra_mart.foundation.database.ConInfo のメソッド
コネクションの識別子を取得します。
getIdentifier() - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
コネクションの識別子を取得します。
getIgnoreErrMsgReturnTypes() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
エラーメッセージを無視するRETURN-TYPEを取得します。
getImageBackgroundColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
画像ファイルの背景色を返します。
getImageBackgroundColor() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
画像ファイルの背景色を返します。
getImageBackgroundColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
画像ファイルの背景色を返します。
getImageBackgroundColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
画像ファイルの背景色を返します。
getImageBackgroundColor() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
画像ファイルの背景色を返します。
getImageBorderColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
画像ファイルのボーダ色を返します。
getImageBorderColor() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
画像ファイルのボーダ色を返します。
getImageBorderColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
画像ファイルのボーダ色を返します。
getImageBorderColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
画像ファイルのボーダ色を返します。
getImageBorderColor() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
画像ファイルのボーダ色を返します。
getImageFolder() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンのイメージファイルのフォルダを取得します。
getImageIcon(String) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
イメージアイコン情報を取得します。
getImageIconCd() - class jp.co.intra_mart.foundation.image.ImageIconInfo のメソッド
イメージアイコンコードを取得する。
getImagePath() - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
マイメニューイメージを取得します。
getImagePath() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニューイメージパスを取得します。
getImagePath() - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel のメソッド
イメージパスを取得します。
getImagePath() - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
イメージパスを取得します。
getImgaeBackgroundColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
推奨されていません。
getImgaeBackgroundColor() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
推奨されていません。
getImgaeBackgroundColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
推奨されていません。
getImgaeBackgroundColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
推奨されていません。
getImgaeBackgroundColor() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
推奨されていません。
getImgaeBorderColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
推奨されていません。
getImgaeBorderColor() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
推奨されていません。
getImgaeBorderColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
推奨されていません。
getImgaeBorderColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
推奨されていません。
getImgaeBorderColor() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
推奨されていません。
getImpExpType() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
入力／出力区分を取得します｡
getImpImpList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(import(Import))の一覧を取得します。
getImpStrList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(structure(Import))一覧を取得します。
getImpTblList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(table(Import))の一覧を取得します｡
getImpWbsElementList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
詳細情報を必要とする WBS 要素を取得します。
getImpWbsElementList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
詳細情報を必要とする WBS 要素を取得します。
getImplementedClasses(Class) - class jp.co.intra_mart.common.aid.jdk.java.lang.SearchableClassLoader のメソッド
指定されたクラスと代入互換のあるインスタンスを生成できるクラスを検索します。
getImportCategories() - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
アクセスコントローラインポート用のカテゴリの一覧を取得します。
getImportCategories() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントインポート用のカテゴリの一覧を取得します。
getImportCategories() - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチインポート用のカテゴリの一覧を取得します。
getImportCategories() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーインポート用のカテゴリの一覧を取得します。
getImportCategories() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
管理メニューインポート用のカテゴリの一覧を取得します。
getImportCategories() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューインポート用のカテゴリの一覧を取得します。
getImportCategories() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロールインポート用のカテゴリの一覧を取得します。
getImportFileSet(String) - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader のメソッド
インポートデータのファイルパスの一覧を取得します。
getImportManager() - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
インポートマネージャーのインスタンスを取得します。
getImportManager() - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient のメソッド

getImportManager() - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient のメソッド

getImportManager() - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient のメソッド

getImportManager() - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient のメソッド

getImportManager() - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient のメソッド

getInCharge() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
利益センタ責任者を取得します｡
getInCharge(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタを指定して利益センタ責任者を取得します。
getInHouse() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
内部生産を取得します。
getInHouse() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
内部生産を取得します。
getIncoterms1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
インコタームズ1を取得します｡
getIncoterms1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
インコタームズ (1)を取得します。
getIncoterms1() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
インコタームズ (1)を取得します。
getIncoterms1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
インコタームズ (1)を取得します。
getIncoterms1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getIncoterms1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
インコタームズ (1)を取得します。
getIncoterms1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getIncoterms2() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
インコタームズ2を取得します｡
getIncoterms2() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
インコタームズ 2を取得します。
getIncoterms2() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
インコタームズ (2)を取得します。
getIncoterms2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
インコタームズ 2を取得します。
getIncoterms2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getIncoterms2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
インコタームズ 2を取得します。
getIncoterms2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getIndPostToInspStock() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品質検査中在庫への転記を取得します。
getIndProposeQuanx() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
提案数量 (初期数量)を取得します。
getIndSector() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
産業コードを取得します。
getIndSector() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
産業コードを取得します。
getIndex() - class jp.co.intra_mart.foundation.database.DatabaseColumn のメソッド

getIndex() - class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
レコード番号を取得します｡
getIndex_type() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
インデックスタイプを返します。
getIndus3() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目 CFOP カテゴリを取得します。
getInfIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
インフレーション指数を取得します。
getInfo() - class jp.co.intra_mart.extension.maskat.util.MKError のメソッド
infoを取得します。
getInfoRec() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
購買情報番号を取得します。
getInfoRec() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買情報番号を取得します。
getInfoUpd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買情報更新区分を取得します。
getInform() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
情報行を取得します。
getInhseprodt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
内製日数を取得します。
getInitParameter(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventConfig のメソッド
指定した名前の初期化パラメータの値である String、 あるいはパラメータが存在しなければ null を返します。
getInitParameter(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventConfig のメソッド
指定した名前の初期化パラメータの値である String、 あるいはパラメータが存在しなければ null を返します。
getInitParameter(String) - interface jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfig のメソッド
ControllerConverterを初期化するときのパラメータを取得します。
getInitParameter(String) - interface jp.co.intra_mart.framework.base.service.validator.ValidatorConfig のメソッド
Validatorを初期化するときのパラメータを取得します。
getInitParameter(String) - class jp.co.intra_mart.framework.system.util.Config のメソッド
Validatorを初期化するときのパラメータを取得します。
getInitParameterNames() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventConfig のメソッド
初期化パラメータの名前である String オブジェクトの Enumeration を返します。
getInitParameterNames() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventConfig のメソッド
初期化パラメータの名前である String オブジェクトの Enumeration を返します。
getInitParameterNames() - interface jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfig のメソッド
初期化パラメータの名前の一覧を取得します。
getInitParameterNames() - interface jp.co.intra_mart.framework.base.service.validator.ValidatorConfig のメソッド
初期化パラメータの名前の一覧を取得します。
getInitParameterNames() - class jp.co.intra_mart.framework.system.util.Config のメソッド
初期化パラメータの名前の一覧を取得します。
getInitPds() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
初期化で使用する履歴値の数を取得します。
getInitalPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider のメソッド
初期ページURLを取得します。
getInitalPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider のメソッド
初期ページURLを取得する。
getInitalPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider のメソッド
初期ページURLを取得する。
getInitalPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider のメソッド
初期ページURLを取得します。
getInitalPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.UserPageProvider のメソッド
初期ページURLを取得する。
getInitialCertification(LoginRequestInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッドの情報から初期アクセス処理を行います。
getInitialCertification(LoginRequestInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
初期アクセス処理を行います。
getInitialPage() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報から初期アクセスページURLを取得します。
getInitialPage(SessionInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報から初期アクセスページURLを取得します。
getInitialPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
初期アクセスページURLを取得します。
getInitialUrl() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
初期ページURLを取得します。
getInitialUrl() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
初期アクセスURLを取得する。
getInitialUrlName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
初期ページURLをセッションに保管するためパラメータ名を取得する。
getInitialize() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
初期化区分を取得します。
getInpfldcheck() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
項目無効時の応答を取得します。
getInputErrorPage(RequestException) - class jp.co.intra_mart.framework.base.service.DefaultTransition のメソッド
入力エラーのページを取得します。
getInputErrorPage(RequestException) - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のメソッド
入力エラーのページを取得します。
getInputErrorPage(RequestException) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
入力エラーのページを取得します。
getInputErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
getInputErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
getInputErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
getInputErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
getInputErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
getInputErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
getInputErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
getInputErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
getInputErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale)を使用してください。
getInputErrorPagePath(String, String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, String, Locale)を使用してください。
getInputErrorPagePath(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, Locale)を使用してください。
getInputErrorPagePath(String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
getInputErrorPagePath(Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale)を使用してください。
getInputErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, String, Locale)を使用してください。
getInputErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, Locale)を使用してください。
getInputErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
getInputErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
getInputErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
getInputErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
getInputErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
getInputErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputStream() - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity のメソッド
データ部を入力ストリームとして取得します。
getInputStream() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
一時ファイルから取得したInputStreamを取得します。
getInputStream() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
入力ストリームの取得。
getInputStream() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
このオブジェクトがラップしている入力ストリームを返します。
getInputStream() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter の static メソッド
現在のリクエストのメッセージボディを返します。
getInputStream() - interface jp.co.intra_mart.foundation.database.DataSourceProvider のメソッド
データソース設定ファイルのストリームを取得します。
getInputStream() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
推奨されていません。 データ部を入力ストリームとして取得します。
getInputStream() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
サーバからの入力を受け付ける入力ストリームを返します。
getInputStream() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
サーバからの入力を受け付ける入力ストリームを返します。
getInputStream() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 入力ストリームの取得。
getInquiryCfgsBlobList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: BLOB 内部データ (SCE)を取得します。
getInquiryCfgsInstList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: インスタンスを取得します。
getInquiryCfgsPartOfList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: 部分設定を取得します。
getInquiryCfgsRefInstList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: 参照明細/インスタンスを取得します。
getInquiryCfgsRefList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: 参照データを取得します。
getInquiryCfgsValueList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: 特性値を取得します。
getInquiryCfgsVkList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: バリアント条件キーを取得します。
getInquiryConditionsInList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
条件を取得します。
getInquiryConditionsInXList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
受注における条件更新の通信項目を取得します。
getInquiryHeaderIn() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
引合伝票ヘッダデータを取得します。
getInquiryHeaderInX() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
ヘッダデータチェックボックスを取得します。
getInquiryItemsInList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
明細データを取得します。
getInquiryItemsInXList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
明細データチェックボックスを取得します。
getInquiryKeysList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
参照キーの出力テーブルを取得します。
getInquiryPartnersList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
伝票取引先を取得します。
getInquirySchedulesInList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
納入日程行を取得します。
getInquirySchedulesInXList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
納入日程行チェックボックスを取得します。
getInquiryTextList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
テキストを取得します。
getInspInt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
次回再検査までの間隔を取得します。
getInspSetupFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目/プラントに QM 検査データ設定を取得します。
getInstId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
選定におけるインスタンス番号を取得します。
getInstId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
選定におけるインスタンス番号を取得します。
getInstId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
選定におけるインスタンス番号を取得します。
getInstId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
選定におけるインスタンス番号を取得します。
getInstId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
選定におけるインスタンス番号を取得します。
getInstId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
選定におけるインスタンス番号を取得します。
getInstId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getInstallDate() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
インストールされた日付を取得します。
getInstance() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager の static メソッド
HTTP コンテキスト・マネージャのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory の static メソッド
インスタンスを返します。
getInstance() - class jp.co.intra_mart.foundation.commons.ParameterManager の static メソッド
インスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.commons.SourceProviderHandler の static メソッド
インスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.database.DatabaseExport の static メソッド
推奨されていません。 DatabaseExportインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.database.DatabaseManager の static メソッド
データべースマネージャインスタンスを生成します。
getInstance() - class jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory の static メソッド
ConfigurationFactoryのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler の static メソッド
JavaMailPropertyHandlerのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.portal.portlet.PortletMapping の static メソッド
インスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.security.AccessSecurityManager の static メソッド
セキュリティマネージャのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.security.ExtendsImportManager の static メソッド

getInstance() - class jp.co.intra_mart.foundation.security.SystemManager の static メソッド
システムマネージャインスタンスを生成します。
getInstance() - class jp.co.intra_mart.foundation.security.group.LoginGroupManager の static メソッド
ログイングループマネージャのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager の static メソッド
ログイングループマネージャのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.security.message.MessageManager の static メソッド
メッセージマネージャのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.service.client.file.AbstractComponent の static メソッド
このクラスの新しいインスタンスを取得します。
getInstance(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory の static メソッド
共有データを扱うためのオブジェクトを取得します。
getInstance(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory の static メソッド
共有データを扱うためのオブジェクトを取得します。
getIntHeader(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse のメソッド
指定された名称でレスポンスヘッダに設定されている数値を返します。
getIntHeader(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getIntHeader(String) メソッドをそのまま呼び出します。
getIntHeader(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
指定された名称でレスポンスヘッダに設定されている数値を返します。
getIntHeaders(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse のメソッド
指定された名称でレスポンスヘッダに設定されている全ての数値を返します。
getIntHeaders(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getIntHeaders(String) メソッドをそのまま呼び出します。
getIntHeaders(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
指定された名称でレスポンスヘッダに設定されている全ての数値を返します。
getIntNumberAssignment() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
明細番号内部採番を取得します。
getIntNumberAssignment() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
明細番号内部採番を取得します。
getIntNumberAssignment() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
明細番号内部採番を取得します。
getIntObjNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
選定 (内部オブジェクト番号)を取得します。
getIntProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
プロジェクト/指図金利計算の金利プロファイルを取得します。
getIntProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト/指図金利計算の金利プロファイルを取得します。
getInterestProf() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
プロジェクト/指図金利計算の金利プロファイルを取得します。
getInternalChar() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
内部特性を取得します。
getInternalObjectId() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
SAP 内部対象キーを取得します。
getInternationArticleNumbers(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のメソッド
EANオブジェクトが既に存在するかチェックします。
getInternationArticleNumbersList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
EANを取得します。
getInternationalAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor のメソッド
拡張もととなる国際化アクセサを取得します。
getInternationalAccessor() - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のメソッド
この国際化モデルに割り当てられた国際化アクセサを取得します。
getInternationalAccessor() - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext のメソッド
国際化アクセサを取得します。
getInternationalAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
基本アクセサに関連する国際化アクセサのマップを取得します。
getInternationalArtnos(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
国際商品コード (EAN)が既に存在するかチェックします。
getInternationalArtnosList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
国際商品コード (EAN)を取得します。
getInternationalKey() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ソースエンティティの国際化基準項目を取得します。
getInternationalModel() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
国際化モデルを取得します。
getInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel のメソッド
国際化モデルのマップを取得します。
getInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
国際化モデルマップを取得します。
getInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
国際化モデルのマップを取得します。
getInternationalTable() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
国際化テーブルを取得します。
getInternet() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
関係会社担当者のインターネットアドレスを取得します。
getInterop() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
移動時間を取得します。
getInvCorrFac() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
在庫修正係数を取得します。
getInvMatNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
会社固有 (内部) 在庫管理品目コードを取得します。
getInvMatNoExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 INV_MAT_NO の品目コード (長) (今後のリリースで開発)を取得します。
getInvMatNoGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)を取得します。
getInvMatNoVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 INV_MAT_NO のバージョン番号 (今後のリリースで開発)を取得します。
getInvalidateLoginType() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
無効化したユーザのログインタイプを取得する。
getInvalidateOtherSessionsAttributeName() - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager のメソッド
現在のセッション以外のアクティブなセッション情報を削除するために使用する属性名を取得します。
getInvalidateTime() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
無効化された時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を取得する。
getInvalidateUserId() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
無効化したユーザのログインユーザIDを取得する。
getInvalidatedActiveSessionInfo(String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
無効化されたアクティブなセッション情報を取得します。
getInvalidatedActiveSessionInfo(String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
無効化されたアクティブなセッション情報を取得します。
getInvalidatedActiveSessionInfo(String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
無効化されたアクティブなセッション情報を取得します。
getInvestProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
設備投資案件プロファイルを取得します。
getInvoSched() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
請求書一覧日程 (稼働日カレンダ指定)を取得します。
getInvoSched() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getInvoSched() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求書一覧日程 (稼働日カレンダ指定)を取得します。
getInvoSched() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getInvoicePercentage() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
請求金額率 (%)を取得します。
getIrInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
請求書受領区分を取得します。
getIsoUnit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
単位の ISO コードを取得します。
getIssStLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出庫保管場所を取得します。
getIssueUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出庫単位を取得します。
getIssueUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ISO コードでの出庫単位を取得します。
getItem(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
指定された商品コードに対する商品の情報を返します。
getItem() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
開始明細を取得します。
getItemAttributeInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
指定された言語に対する国際化情報を取得します。
getItemCaption() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
商品通称を取得します。
getItemCaption(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
商品通称を取得します。
getItemCaption(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
商品通称を取得します。
getItemCaption(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
商品通称を取得します。
getItemCaption() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminableInternational のメソッド
商品通称を取得します。
getItemCaption() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品通称を取得します。
getItemCaption(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品通称を取得します。
getItemCaption(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品通称を取得します。
getItemCaption(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品通称を取得します。
getItemCaption() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableInternationalModel のメソッド
商品通称を取得します。
getItemCaption() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
商品通称を取得します。
getItemCaption(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
商品通称を取得します。
getItemCat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買伝票の明細カテゴリを取得します。
getItemCat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
一般明細カテゴリグループを取得します。
getItemCat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目マスタの明細カテゴリグループを取得します。
getItemCatExt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買伝票の明細カテゴリを取得します。
getItemCatalogueCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のメソッド
商品カタログコードを取得します。
getItemCatalogueCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel のメソッド
商品カタログコードを取得します。
getItemCateg() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
明細カテゴリ (販売伝票)を取得します。
getItemCateg() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細カテゴリ (販売伝票)を取得します。
getItemCateg() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getItemCategoryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach のメソッド
商品カテゴリコードを取得します。
getItemCategoryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
商品カテゴリコードを取得します。
getItemCategoryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel のメソッド
商品カテゴリコードを取得します。
getItemCategoryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
商品カテゴリコードを取得します。
getItemCategoryInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
指定された言語に対する国際化情報を取得します。
getItemCategoryManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager の static メソッド
ItemCategoryManagerを取得します。
getItemCategoryName() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
商品カテゴリ名を取得します。
getItemCategoryName(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
商品カテゴリ名を取得します。
getItemCategoryName() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategoryInternational のメソッド
商品カテゴリ名を取得します。
getItemCategoryName() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
商品カテゴリ名を取得します。
getItemCategoryName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
商品カテゴリ名を取得します。
getItemCategoryName() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryInternationalModel のメソッド
商品カテゴリ名を取得します。
getItemCategoryTypeCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach のメソッド
商品カテゴリ種別コードを取得します。
getItemCategoryTypeCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
商品カテゴリ種別コードを取得します。
getItemCategoryTypeCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.type.ItemCategoryType のメソッド
商品カテゴリ種別コードを取得します。
getItemCategoryTypeCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel のメソッド
商品カテゴリ種別コードを取得します。
getItemCategoryTypeCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
商品カテゴリ種別コードを取得します。
getItemCategoryTypeCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel のメソッド
商品カテゴリ種別コードを取得します。
getItemCateogry() - interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryStruct のメソッド
商品カテゴリを取得します。
getItemCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail のメソッド
商品コードを取得します。
getItemCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
商品コードを取得します。
getItemCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のメソッド
商品コードを取得します。
getItemCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
商品コードを取得します。
getItemCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach のメソッド
商品コードを取得します。
getItemCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
商品コードを取得します。
getItemCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel のメソッド
商品コードを取得します。
getItemCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel のメソッド
商品コードを取得します。
getItemCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品コードを取得します。
getItemCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel のメソッド
商品コードを取得します。
getItemIntvl() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
明細番号間隔を取得します｡
getItemManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager の static メソッド
ItemManagerを取得します。
getItemName() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
商品名を取得します。
getItemName(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
商品名を取得します。
getItemName(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
商品名を取得します。
getItemName(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
商品名を取得します。
getItemName() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminableInternational のメソッド
商品名を取得します。
getItemName() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品名を取得します。
getItemName(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品名を取得します。
getItemName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品名を取得します。
getItemName(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品名を取得します。
getItemName() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableInternationalModel のメソッド
商品名を取得します。
getItemName() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
商品名を取得します。
getItemName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
商品名を取得します。
getItemNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買管理オブジェクト: 明細を取得します。
getItemTemplateDetailInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
指定された言語に対する国際化情報を取得します。
getItemTemplateManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager の static メソッド
ItemTemplateManagerを取得します。
getItemTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
指定された期間に対する期間化情報を取得します。
getItemTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
指定された日時に対する期間化情報を取得します。
getItemTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getItemText() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
明細テキストを取得します。
getItemText() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
明細テキストを取得します。
getItemTextList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
明細テキスト一覧を取得します｡
getItemUnitManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager の static メソッド
ItemUnitManagerを取得します。
getItemguidAtp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ATP: 暗号 - DELNR および DELPSを取得します。
getItemguidAtp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getItems() - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
現在、存在する商品の情報を返します。
getItems(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
指定された日付に存在する商品の情報を返します。
getItemsByKey(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
現在、条件に合致する商品の情報を返します。
getItemsByKey(String, String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
指定された日付に条件に合致する商品の情報を返します。
getItemsForRelease() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
区分: 承認待ち購買発注のみ照会を取得します。
getItemsForRelease() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
区分: 承認待ち購買発注のみ照会を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件明細番号を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
販売伝票明細を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
明細番号を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売伝票明細を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件明細番号を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
条件明細番号を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売伝票明細を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
販売伝票明細を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
販売伝票明細を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
明細番号 (販売管理伝票)を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
販売伝票明細を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
販売伝票明細を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
販売伝票明細を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
明細番号 (販売管理伝票)を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
販売伝票明細を取得します。
getItmTypeUsage() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細用途を取得します。
getItmTypeUsage() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getJCOClient() - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
JCOコネクションの取得を行います。
getJCORepository(SapClient) - class jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager の static メソッド
Repository情報を生成もしくは、取得します。
getJNDIName() - class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory のメソッド
EJBEventListenerAgentHomeのJNDI名を取得します。
getJdbcConnection(String, String, String, String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
JDBCからコネクションオブジェクトを取得します。
getJitRelvt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: JIT 納入日程の関連明細を取得します。
getJointVenture() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ジョイントベンチャを取得します。
getJointVenture() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ジョイントベンチャを取得します。
getJvJibClass() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
JIB/JIBE クラスを取得します。
getJvJibClass() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
JIB/JIBE クラスを取得します。
getJvJibSubClassA() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
JIB/JIBE サブクラスAを取得します。
getJvJibSubClassA() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
JIB/JIBE サブクラスAを取得します。
getJvObjectType() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ジョイントベンチャ対象タイプを取得します。
getJvObjectType() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ジョイントベンチャ対象タイプを取得します。
getKanbanInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
かんばん区分を取得します。
getKblanguage() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
システム設定の言語を取得します。
getKbname() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
ナレッジベースオブジェクトを取得します。
getKbprofile() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
ナレッジベースプロファイルを取得します。
getKbversion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
SCE ナレッジベースの実行時バージョンを取得します。
getKey() - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のメソッド
エラーメッセージを作成するための識別子を取得します。
getKey() - class jp.co.intra_mart.framework.base.event.Event のメソッド
イベントキーを取得します。
getKey() - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
keyを取得します。
getKeyString() - class jp.co.intra_mart.foundation.security.DepartmentInfo のメソッド
組織情報の識別子を取得します。
getKeyString() - class jp.co.intra_mart.foundation.security.PostInfo のメソッド
役職情報の識別子を取得します。
getKeyString() - class jp.co.intra_mart.foundation.security.PublicGroupInfo のメソッド
パブリックグループ情報の識別子を取得します。
getKeyString() - class jp.co.intra_mart.foundation.security.menu.MenuInclusion のメソッド
メニュー内包情報の識別子を取得します。
getKeys() - class jp.co.intra_mart.foundation.navigator.LinkPageInfo のメソッド
URLパラメータリストのキー配列取得
getKeys() - class jp.co.intra_mart.foundation.navigator.NavigatorItem のメソッド
タイトル情報リストのキー配列取得
getKeys(String) - class jp.co.intra_mart.foundation.update.StandardUpdateAccessor のメソッド
保存されているキーの一覧を取得します。
getKeys(String) - interface jp.co.intra_mart.foundation.update.UpdateAccessor のメソッド
保存されているキーの一覧を取得します。
getKeys() - class jp.co.intra_mart.foundation.update.UpdateManager のメソッド
保存されている更新管理キーの一覧を取得します。
getLEquip1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 1を取得します。
getLEquip2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 2を取得します。
getLEquip3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 3を取得します。
getLabelForm() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ラベル書式を取得します。
getLabelType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ラベルタイプを取得します。
getLang() - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
言語を取得します。
getLang() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 言語を取得します｡
getLang() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性langの値を取得します。
getLang() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
langを取得します。
getLang() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
langを取得します。
getLang() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性langの値を取得します。
getLang() - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes のメソッド
属性langの値を取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
言語キーを取得します。
getLanguCr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
アドレスレコード登録オリジナル言語を取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
ISO 639 準拠の言語を取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
ISO 639 準拠の言語を取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
言語キーの ISO コードを取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
ISO 639 準拠の言語を取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
ISO 639 準拠の言語を取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
ISO 639 準拠の言語を取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
ISO 639 準拠の言語を取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
ISO 639 準拠の言語を取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
ISO 639 準拠の言語を取得します。
getLanguage() - class jp.co.intra_mart.foundation.page.EventScript のメソッド
言語名を返します。
getLanguage() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
ステータスおよび業務トランザクションテキストの言語を取得します。
getLanguage() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
ステータスおよび業務トランザクションテキストの言語を取得します。
getLanguage() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
言語キーを取得します。
getLanguageVersion() - class jp.co.intra_mart.foundation.page.EventScript のメソッド
言語のバージョンを返します。
getLangucriso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
ISO 639 準拠の言語を取得します。
getLastAccessedTime(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager のメソッド
指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。
getLastAccessedTime(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager のメソッド
指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。
getLastChnge() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
最終変更日付を取得します。
getLastItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
最終明細番号を取得します。
getLastModified(String) - class jp.co.intra_mart.foundation.update.UpdateManager のメソッド
更新日付を取得します。
getLastResponseTime() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
最終応答時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を取得する。
getLatestDatesIndicator() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
区分: 最遅日を取得します。
getLatestFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画最遅終了: 作業(日付)を取得します。
getLatestFinishDateFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最遅計画済終了日付(需要予測)を取得します。
getLatestFinishTime() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画最遅終了: 作業(時間)を取得します。
getLatestFinishTimeFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最遅計画終了時間 (予測)を取得します。
getLatestPasswordHistory(String, String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
最新のパスワードと更新日付を取得。
getLatestPasswordHistory(String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
最新のパスワードと更新日付を取得。
getLatestPasswordHistory(String, String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
最新のパスワードと更新日付を取得。
getLatestStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画最遅開始: 作業(日付)を取得します。
getLatestStartDateFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最遅計画済開始日付(需要予測)を取得します。
getLatestStartTime() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画最遅開始: 作業(時間)を取得します。
getLatestStartTimeFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最遅計画済開始時間(需要予測)を取得します。
getLayoutId() - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject のメソッド
レイアウトIDを取得します。
getLeadinguom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
主要ロット特定数量単位を取得します。
getLeft() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を取得します。
getLength() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager のメソッド
マネージャーが保持する HTTP コンテキストの数を返します。
getLength() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager のメソッド
現在有効な HttpSession の数を返します。
getLength() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
長さを取得します。
getLeqUnit1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 1 の数量単位を取得します。
getLeqUnit1Iso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードによる積載装置数量 1 の数量単位を取得します。
getLeqUnit2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 2 の数量単位を取得します。
getLeqUnit2Iso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードによる積載装置数量 2 の数量単位を取得します。
getLeqUnit3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 3 の数量単位を取得します。
getLeqUnit3Iso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードによる積載装置数量 3 の数量単位を取得します。
getLiIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
レコード番号を取得します｡
getLicenceErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
ライセンスエラーページURLを取得する。
getLicenceErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
ライセンスエラーページURLを取得します。
getLicense(LoginInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
アカウントライセンスチェックを行います。
getLicense() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
アプリケーションライセンスが登録されているアカウント数を取得する。
getLicense() - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
グループ内で登録されているライセンス数を取得します。
getLicenseKeys() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
ライセンス・キーの取得
ライセンス・キーが登録されていない場合は、空の配列を返却します。
getLifetime() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ターゲットエンティティの期間削除時の整合性制約を取得します。
getLifetimeType() - interface jp.co.intra_mart.foundation.datastore.common.config.Lifetime のメソッド
ターゲットエンティティの期間削除時の整合性制約のタイプを取得します
getLifoFifo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
LIFO/FIFO 関連を取得します。
getLifoValuationData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
LIFO 関連品目データを取得します。
getLifoValuationLevel() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData のメソッド
LIFO 評価レベルを取得します。
getLifovaluationlevel() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
LIFO 評価レベルを取得します。
getLimit() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
全体制限を取得します。
getLimit() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
全体制限を取得します。
getLimitLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: 計画外、明細制限を取得します。
getLimitedDate() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
使用期限の日付を取得します。
getLimitsList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注制限一覧を取得します｡
getLineDepth() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
伝票での明細行階層レベルを取得します。
getLineDepth() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
伝票での明細行階層レベルを取得します。
getLineId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
伝票明細行の一意 IDを取得します。
getLineId() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
伝票明細行の一意 IDを取得します。
getLineNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
制限の内部明細番号を取得します。
getLineNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
内部明細番号を取得します。
getLineNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
明細行番号を取得します。
getLineNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のメソッド
内部明細番号を取得します。
getLink(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
getLinkClass() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
推奨されていません。 このメソッドではなくLinkTag.getLinkclass()メソッドを使用してください。
getLinkPageInfo(EventNavigatorManager, String, String, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
結果ページ情報を取得します。
getLinkPageInfo(String, String, String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
結果ページ情報を取得します。
getLinkPageInfo() - class jp.co.intra_mart.foundation.navigator.ResultPageItem のメソッド

getLinkPageInfo(EventNavigatorManager, String, String, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
結果ページ情報を取得します。
getLinkclass() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
linkClassを取得します。
getLinkclass() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
linkClassを取得します。
getListData(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getAllSubRoleIds(String)に置き換えられました。
getListenerClass() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext のメソッド
リスナーとなっている Servlet の実行時クラスを返します。
getListenerContext() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
イベントの実行要求を受け付けたリスナーに関する情報オブジェクトを返します。
getListenerName() - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory のメソッド
EJBEventListenerAgentBeanのクラス名を取得します。
getListenerName() - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory のメソッド
EJBEventListenerAgentBeanのクラス名を取得します。
getListeners() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventComponentBuilder のメソッド
リスナの配列を返します。
getListeners() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
メール送信リスナを取得します。
getLoadDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
積載日付を取得します。
getLoadDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
積載日付を取得します。
getLoadDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getLoadTime() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
積載時刻 (現地時間: 出荷ポイント)を取得します。
getLoadTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
積載時刻 (現地時間: 出荷ポイント)を取得します。
getLoadTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getLoadinggrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
積載グループを取得します。
getLocale() - class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties のメソッド
ResourceBundle の Locale を返します。
getLocale(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
レスポンスに設定されているロケールを返します。
getLocale(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
レスポンスに設定されているロケールを返します。
getLocale(HttpServletRequest, ExtendedHttpServletResponse) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
レスポンスに設定されているロケールを返します。
getLocale(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
レスポンスに設定されているロケールを返します。
getLocale() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
役職名の言語を取得します。
getLocale() - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor のメソッド
ロケールを取得します。
getLocale() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor のメソッド
ロケールを取得します。
getLocale() - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のメソッド
国際化モデルが保持する言語 Locale を取得します。
getLocale() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のメソッド
期間国際化モデルが保持する言語 Locale を取得します。
getLocale() - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel のメソッド
国際化モデルが保持する言語 Locale を取得します。
getLocale() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel のメソッド
期間国際化モデルが保持する言語 Locale を取得します。
getLocale() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
ロケールを取得します。
getLocale() - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
ロケールを取得します。
getLocale() - interface jp.co.intra_mart.foundation.security.LocaleInfo のメソッド
ロケ－ル取得。
getLocale() - interface jp.co.intra_mart.foundation.security.LocaleProvider のメソッド
ロケールを取得する。
getLocale() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ロケールを取得する。
getLocale(Locale, Locale) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
指定ロケールでロケール情報を取得します。
getLocale() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ロケールを取得します。
getLocale() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
ロケールの取得。
getLocale() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ロケールを取得する。
getLocale() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ロケールを取得する。
getLocale() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
ロケールを取得します。
getLocale() - class jp.co.intra_mart.foundation.utility.ResourceBundleProperties のメソッド
推奨されていません。 ResourceBundle の Locale を返します。
getLocale(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
現在のリクエストに対するロケールを取得します。
getLocale() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ユーザのロケールを取得する。
getLocale() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
ユーザのロケールを取得する。
getLocale() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
ユーザのロケールを取得する。
getLocale() - class jp.co.intra_mart.framework.base.util.UserInfoWrapper のメソッド
ラップされたUserInfoのgetLocale()を呼び出します。
getLocale() - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
localeを取得します。
getLocale() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
ロケールを取得します。
getLocaleAttributeName() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
getLocaleAttributeName() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
getLocaleAttributeName() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
getLocaleAttributeName() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
getLocaleAttributeName() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
getLocaleColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable のメソッド
ロケールに該当するカラムのカラム名を取得します。
getLocaleColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable のメソッド
ロケールに該当するカラムのカラム名を取得します。
getLocaleColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable のメソッド
ロケールに該当するカラムのカラム名を取得します。
getLocaleColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable のメソッド
ロケールに該当するカラムのカラム名を取得します。
getLocaleName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ロケールをセッションに保管するためのパラメータ名を取得する。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
この分類区分で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
この分類区分詳細で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
この会社で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
この組織で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable のメソッド
この役職で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
この商品属性で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable のメソッド
この商品で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
この商品カテゴリで管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
この商品属性テンプレート明細で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable のメソッド
このパブリックグループで管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable のメソッド
このパブリックグループセットで管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
このユーザで管理している言語（ロケール）をすべて取得します。
getLocales() - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap のメソッド
現在管理している言語の一覧を取得します。
getLocales() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap のメソッド
現在管理している言語の一覧を取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。
getLocales() - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap のメソッド
マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。
getLocales() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap のメソッド
マッピングされている期間国際化モデル TerminableInternationalModel の言語 Locale の一覧を取得します。
getLocales(Locale) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
指定ロケールでロケール情報の一覧を取得します。
getLocales() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
表示名として保管されているロケールの一覧を取得します。
getLocales() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニュー名として保管されているロケールの一覧を取得します。
getLocales() - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロケールの一覧を取得します。
getLocation() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
場所を取得します。
getLocation() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名 5を取得します。
getLocation() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名 5を取得します。
getLocation() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名 5を取得します。
getLocation() - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のメソッド
設定されている遷移先パスを返します。
getLockCount() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
アカウントをロックするログイン失敗回数を取得します。
getLockDate() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
アカウントロック日付を取得します。
getLockDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
アカウントロック日付を取得します。
getLockTerm() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
アカウントをロックする期間を取得します。
getLockedErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
ユーザロックエラーページURLを取得する。
getLockedErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
ユーザロックエラーページURLを取得します。
getLogAgent() - class jp.co.intra_mart.framework.system.log.LogManager のメソッド
ログエージェントを取得します。
getLogAgentName() - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler のメソッド
ログエージェントのクラス名を取得します。
getLogAgentName() - interface jp.co.intra_mart.framework.system.log.LogPropertyHandler のメソッド
ログエージェントのクラス名を取得します。
getLogAgentName() - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler のメソッド
ログエージェントのクラス名を取得します。
getLogAgentParams() - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler のメソッド
ログエージェントのパラメータを取得します。
getLogAgentParams() - interface jp.co.intra_mart.framework.system.log.LogPropertyHandler のメソッド
ログエージェントのパラメータを取得します。
getLogAgentParams() - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler のメソッド
ログエージェントのパラメータを取得します。
getLogManager() - class jp.co.intra_mart.framework.system.log.LogManager の static メソッド
ログマネージャを取得します。
getLogMsgNo() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ログメッセージナンバーを取得します｡
getLogMsgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
アプリケーションログ: メッセージシリアル番号を取得します。
getLogMsgNo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
アプリケーションログ: メッセージシリアル番号を取得します。
getLogNo() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ログナンバーを取得します｡
getLogNo() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
アプリケーションログ: ログ番号を取得します。
getLogNo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
アプリケーションログ: ログ番号を取得します。
getLogPropertyHandler() - class jp.co.intra_mart.framework.system.log.LogManager のメソッド
ログプロパティハンドラを取得します。
getLogSystem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender のメソッド
論理システムを取得します。
getLogSystemOwn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
論理システムを取得します。
getLogSystemOwn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getLogWriter() - class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource のメソッド
ラップされたデータソースのgetLogWriter()を呼び出します。
getLogWriter() - class jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource のメソッド
ラップされたデータソースのgetLogWriter()を呼び出します。
getLogicSwitch() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
内部制御パラメータを取得します。
getLogicSwitch() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
内部制御パラメータを取得します。
getLogicSwitch() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
内部制御パラメータを取得します。
getLoginCertification() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報からログイン処理を行います。
getLoginCertification(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ログイン処理を行います。
getLoginFailureCount() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ログイン失敗回数を取得します。
getLoginFailureCount() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
ログイン失敗回数を取得します。
getLoginGroup() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ログイングループIDを取得する。
getLoginGroup() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
ログイングループIDを取得する。
getLoginGroup() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ログイングループIDを取得する。
getLoginGroup() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログイングループIDを取得する。
getLoginGroup(String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
ログイングループ情報を取得します。
getLoginGroup(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループ情報を取得します。
getLoginGroup() - class jp.co.intra_mart.framework.base.event.Event のメソッド
推奨されていません。 このメソッドではなくEvent.getUserInfo()を使用してください。
getLoginGroupConnection(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
ログイングループIDからコネクションオブジェクトを取得します。
getLoginGroupID() - class jp.co.intra_mart.framework.base.event.Event のメソッド
推奨されていません。 このメソッドではなくEvent.getUserInfo()を使用してください。
getLoginGroupID() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
推奨されていません。 このメソッドではなくServiceControllerAdapter.getUserInfo()を使用してください。
getLoginGroupID() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログイングループIDを取得する。
getLoginGroupID() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
ログイングループIDを取得する。
getLoginGroupID() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
ログイングループIDを取得する。
getLoginGroupID() - class jp.co.intra_mart.framework.base.util.UserInfoWrapper のメソッド
ラップされたUserInfoのgetLoginGroupID()を呼び出します。
getLoginGroupID() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
推奨されていません。 このメソッドではなくHelperBean.getUserInfo()を使用してください。
getLoginGroupID(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils の static メソッド
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
getLoginGroupID(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction のメソッド
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
getLoginGroupIDKey() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
セッションに登録されているログイングループIDのキーを取得します。
getLoginGroupIDKey() - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler のメソッド
セッションに登録されているログイングループIDのキーを取得します。
getLoginGroupIDKey() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
セッションに登録されているログイングループIDのキーを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedDataSource のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource のメソッド
ログイングループIDを取得します。
getLoginGroupIds() - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
ログイングループIDの一覧を取得します。
getLoginGroupIds() - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループIDの一覧を取得します。
getLoginGroupName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ログイングループをセッションに保管するためのパラメータ名を取得する。
getLoginGroupParameterName() - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer のメソッド
ログイングループＩＤリクエストパラメータ名を取得する。
getLoginGroupParameterName() - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
ログイングループＩＤリクエストパラメータ名を取得する。
getLoginGroups() - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループの一覧を取得します。
getLoginTime() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ログインした時間を取得する。
getLoginTime() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
ログイン時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を取得する。
getLoginTime() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログインした時間を取得する。
getLoginTime() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
ログインした時間を取得する。
getLoginTime() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
ログインした時間を取得する。
getLoginTime() - class jp.co.intra_mart.framework.base.util.UserInfoWrapper のメソッド
ラップされたUserInfoのgetLoginTime()を呼び出します。
getLoginTimeName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ログイン時間をセッションに保管するためのパラメータ名を取得する。
getLoginTimeout() - class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource のメソッド
ラップされたデータソースのgetLoginTimeout()を呼び出します。
getLoginTimeout() - class jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource のメソッド
ラップされたデータソースのgetLoginTimeout()を呼び出します。
getLoginType() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ログインタイプを取得する。
getLoginType() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
ログインタイプを取得する。
getLoginType() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ログインタイプを取得する。
getLoginType() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインタイプを取得する。
getLoginType() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログインタイプを取得する。
getLoginType() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
ログインタイプを取得する。
getLoginType() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
ログインタイプを取得する。
getLoginType() - class jp.co.intra_mart.framework.base.util.UserInfoWrapper のメソッド
ラップされたUserInfoのgetLoginType()を呼び出します。
getLoginTypeName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ログインタイプをセッションに保管するためのパラメータ名を取得する。
getLoginUser() - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
ログインユーザを取得します。
getLoginUser() - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
ログインユーザを取得します。
getLoginUser() - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
ログインユーザを取得します。
getLoginUser() - class jp.co.intra_mart.foundation.security.StandardBatchAccessor のメソッド
ログインユーザを取得します。
getLoginUser() - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor のメソッド
ログインユーザを取得します。
getLoginUser() - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
ログインユーザを取得します。
getLoginUser() - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
ログインユーザを取得します。
getLoginUser() - class jp.co.intra_mart.framework.base.event.Event のメソッド
推奨されていません。 このメソッドではなくEvent.getUserInfo()を使用してください。
getLoginUserID() - class jp.co.intra_mart.framework.base.event.Event のメソッド
推奨されていません。 このメソッドではなくEvent.getUserInfo()を使用してください。
getLoginUserID() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
推奨されていません。 このメソッドではなくServiceControllerAdapter.getUserInfo()を使用してください。
getLoginUserID() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
推奨されていません。 このメソッドではなくHelperBean.getUserInfo()を使用してください。
getLoginUserID(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils の static メソッド
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
getLoginUserID(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction のメソッド
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
getLoginUserIDKey() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
セッションに登録されているログインユーザIDのキーを取得します。
getLoginUserIDKey() - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler のメソッド
セッションに登録されているログインユーザIDのキーを取得します。
getLoginUserIDKey() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
セッションに登録されているログインユーザIDのキーを取得します。
getLogsystem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
論理システムを取得します｡
getLongText() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
総勘定元帳勘定テキスト(長)を取得します｡
getLongText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
G/L勘定コードを指定して総勘定元帳勘定テキスト(長)を取得します。
getLongdesc() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
longdescを取得します。
getLooseorliq() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: バルク/液体を取得します。
getLotIncrement() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要と供給を一致させるためのロットサイズ増分を取得します。
getLotSize() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算ロットサイズを取得します。
getLotsizekey() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ロットサイズ (品目計画)を取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
ロット番号を取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
品目コードを取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
移動タイプ (在庫管理)を取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
プラントを取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
伝票の転記日付を取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
特殊在庫区分を取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
保管場所を取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
トランザクション/イベントタイプを取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
ユーザ名を取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
仕入先勘定コードを取得します。
getMail() - class jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent のメソッド
メールの属性を取得します。
getMailAddress() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
メールアドレス取得。
getMainEan() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
区分: 主要 EANを取得します。
getMainPage() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報からメインページURLを取得します。
getMainPage(SessionInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報からメインページURLを取得します。
getMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
メインページURLを取得します。
getMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider のメソッド
メインページURLを取得する。
getMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider のメソッド
メインページURLを取得する。
getMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider のメソッド
メインページURLを取得します。
getMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.UserPageProvider のメソッド
メインページURLを取得する。
getMainPage(String) - interface jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor のメソッド
ショートカット表示用のパスを取得します。
getMainPage() - class jp.co.intra_mart.foundation.security.shortcut.ShortCutManager のメソッド
ショートカットメインページ取得。
getMainPage(String) - class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor のメソッド
ショートカット表示用のパスを取得します。
getMainPagePattern(String, String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
メインページパターンを取得します。
getMainPagePattern(String, String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンを取得します。
getMainPagePatternId() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
メインページパターンIDを取得します。
getMainPagePatternId() - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo のメソッド
メインページパターンIDを取得する。
getMainPagePatternIds(String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
メインページパターンIDの一覧を取得します。
getMainPagePatternIds(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンIDの一覧を取得します。
getMainPagePatternImageUrl() - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo のメソッド
メインページパターンイメージURLを取得する。
getMainPagePatternUrl() - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo のメソッド
メインページパターンURLを取得する。
getMainPagePatterns(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンの一覧を取得します。
getMaintStat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
更新ステータスを取得します。
getMaintStat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
更新ステータスを取得します。
getMaintStat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
更新ステータスを取得します。
getMaintStat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
更新ステータスを取得します。
getManager() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory のメソッド
マネージャを返します。
getManuMat() - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のメソッド
製造者製品コードを取得します。
getManuMat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
製造者製品コードを取得します。
getManuMat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造者製品コードを取得します。
getManufProf() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
製造者製品プロファイルを取得します。
getManufProf() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造者製品プロファイルを取得します。
getManufacturerPartNumbList() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
製造業者と製造者製品コード一覧を取得します｡
getMapperClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
マッパのクラス名を取得します。
getMarginheight() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
marginheightを取得します。
getMarginwidth() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
marginwidthを取得します。
getMaskId() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
WBS 要素 ID(短)の選択マスクを取得します。
getMastCond() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
期間依存条件伝票を取得します。
getMastContr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
グループマスタ契約番号を取得します。
getMastContr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMasterData() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
指図のマスタデータ構造を取得します。
getMasterData() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
指図のマスタデータ構造を取得します。
getMatCfop() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目 CFOP カテゴリを取得します。
getMatDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入出庫伝票番号を取得します。
getMatDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫伝票番号を取得します。
getMatDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret のメソッド
入出庫伝票番号を取得します。
getMatEntrd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
入力品目を取得します。
getMatEntrd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMatExt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMatExt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMatExt() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMatGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
品目グループを取得します。
getMatGrpSm() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目グループ: 梱包材を取得します。
getMatGrpTrans() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
段取替えマトリクスに対する品目のグループを取得します。
getMatGuid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMatGuid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMatGuid() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMatOrigin() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目の原産地を取得します。
getMatOrigin() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目の原産地を取得します。
getMatPrGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目価格設定グループを取得します。
getMatPrGrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目価格設定グループを取得します。
getMatPrGrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMatStatus() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目更新完了ステータスを取得します。
getMatVers() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMatVers() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMatVers() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMatchCount() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
名称設定以外でマッチしたカレンダーデータの数を取得します。
getMatcmpllvl() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目完了レベルを取得します。
getMatdocItm() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫伝票の明細を取得します。
getMatdocItm() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のメソッド
入出庫伝票の明細を取得します。
getMatdocTrCancel() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取消予定の転送要求の入出庫伝票番号を取得します。
getMatdocumentyear() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票会計年度を取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
品目コードを取得します｡
getMaterial() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
品目コードを取得します。
getMaterialDescription(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のメソッド
品目テキストオブジェクトが既に存在するかチェックします。
getMaterialDescription(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
品目テキストが既に存在するかチェックします。
getMaterialDescriptionList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目テキストを取得します。
getMaterialDescriptionList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目テキストを取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コード（長）を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
項目 MATERIAL の品目コード (長)を取得します｡
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialFixed() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ロックされている品目を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コードの外部GUIDを取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
項目 MATERIAL の外部 GUIDを取得します｡
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialLongText(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
テキスト (長)が既に存在するかチェックします。
getMaterialLongTextList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
テキスト (長)を取得します。
getMaterialRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
品目コードの範囲を取得します。
getMaterialShortDescselList() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
品目テキストの選択オプション一覧を取得します｡
getMaterialText(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のメソッド
テキスト (長)オブジェクトが既に存在するかチェックします。
getMaterialTextList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
テキスト (長)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コードのバージョン番号を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
項目 MATERIAL のバージョン番号を取得します｡
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialdocument() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票番号を取得します。
getMatfrgtgrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目運賃グループを取得します。
getMatfrgtgrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目運賃グループを取得します。
getMatfrgtgrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMatitemTrCancel() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取消予定の転送数量入出庫伝票明細を取得します。
getMatlDesc() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
品目テキストを取得します。
getMatlDesc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
品目テキストを取得します。
getMatlGroup() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
品目グループを取得します。
getMatlGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
品目グループを取得します。
getMatlGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目グループを取得します。
getMatlGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目グループを取得します。
getMatlGroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループを取得します。
getMatlGroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMatlGrp1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 1を取得します。
getMatlGrp2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 2を取得します。
getMatlGrp3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 3を取得します。
getMatlGrp4() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 4を取得します。
getMatlGrp5() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 5を取得します。
getMatlStats() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目統計グループを取得します。
getMatlType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目タイプを取得します。
getMatlType() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
品目タイプを取得します。
getMatlUsage() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目の用途を取得します。
getMatlUsage() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目の用途を取得します。
getMatnrHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のメソッド
終了品目コードを取得します。
getMatnrListList() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
品目コードと品目テキストの一覧を取得します｡
getMatnrLow() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のメソッド
開始品目コードを取得します。
getMatnrSelectionList() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
品目コードの選択オプション一覧を取得します｡
getMatyearTrCancel() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取消予定の転送要求入出庫伝票年度を取得します。
getMax() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
ｙ軸の最大値を返します。
getMax() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
ｙ軸の最大値を返します。
getMax() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
ｙ軸の最大値を返します。
getMaxDate() - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
システムで許可されている最大日時を取得します。
getMaxDate() - class jp.co.intra_mart.foundation.datastore.common.structure.Term の static メソッド
システムで設定できる期間の最大日時を取得します。
getMaxDate() - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager の static メソッド
システムで設定できる期間の最大日時を取得します。
getMaxInactiveInterval(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager のメソッド
指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。
getMaxInactiveInterval(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager のメソッド
指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。
getMaxLicense() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
アプリケーションの最大登録可能なラインセンス数を取得します。
getMaxLicense() - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
ログイングループ内の最大登録可能ライセンス数を取得します。
getMaxLotSize() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要と供給を一致させるための最大ロットサイズを取得します。
getMaxPlDlv() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細ごとの分割納入可能な最大回数を取得します。
getMaxPlDlv() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMaxProcess() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
アプリケーションランタイムの最大使用可能なラインセンス数を取得します。
getMaxRows() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
選択予定品目の最大数を取得します｡
getMaxSbQty() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
最大棚番在庫数量を取得します。
getMaxStock() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最大在庫レベルを取得します。
getMaxdevDay() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
シフト所要日数を取得します。
getMaxdevDay() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMaxdevamnt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
数量に関する許容偏差 (絶対値)を取得します。
getMaxdevamnt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMaxdevper() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
数量に関する許容偏差 (%)を取得します。
getMaxdevper() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMaxlotsize() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最大ロットサイズを取得します。
getMeAnzSub() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
下位レベル数量単位数を取得します。
getMeanAbsolDev() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
絶対平均偏差 (MAD)を取得します。
getMeanAbsolDevPp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間の平均絶対偏差を取得します。
getMedia() - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のメソッド
媒体を取得します。
getMedia() - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel のメソッド
媒体を取得します。
getMediaCls() - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のメソッド
媒体種類を取得します。
getMediaCls() - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel のメソッド
媒体種類を取得します。
getMediaType() - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のメソッド
このオブジェクトが表す MIME タイプの Media Type を返します。
getMediaType() - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のメソッド
推奨されていません。 このオブジェクトが表す MIME タイプの Media Type を返します。
getMember(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
現在、組織に所属するる人員の一覧を取得します。
getMember(String, String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
指定された日付に組織に所属する人員の一覧を取得します。
getMember(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
ログインユーザが持つ指定されたプライベートグループに所属する人員を取得します。
getMember(String, String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
指定されたプライベートグループに所属する人員を取得します。
getMember(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
現在、パブリックグループに所属するる人員の一覧を取得します。
getMember(String, String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
指定された日付にパブリックグループに所属する人員の一覧を取得します。
getMemoryComplete() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
エラーがない場合に購買発注を保留にする区分を取得します｡
getMemoryUnComplete() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
エラーがある場合に購買発注を保留にする区分を取得します｡
getMenu(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 MenuManager.exportData(String category, OutputStream outputStream)に置き換えられました。
getMenuDepartments(String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
すべてのメニュー組織を取得します。
getMenuDepartments(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニュー組織を取得します。
getMenuDepartments(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューに紐付いた組織の一覧を取得します。
getMenuId() - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
メニューIDを取得します。
getMenuId() - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel のメソッド
メニューIDを取得します。
getMenuId() - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel のメソッド
メニューIDを取得します。
getMenuId() - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
メニューIDを取得します。
getMenuId() - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel のメソッド
メニューIDを取得します。
getMenuId() - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel のメソッド
メニューIDを取得します。
getMenuId() - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel のメソッド
メニューIDを取得します。
getMenuId() - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel のメソッド
メニューIDを取得します。
getMenuIds(String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
すべてのメニューIDを取得します。
getMenuIds() - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
すべてのメニューIDを取得します。
getMenuIds() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
すべてのメニューIDを取得します。
getMenuIds(String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニューIDを取得します。
getMenuIds() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
すべてのメニューIDを取得します。
getMenuIdsByDepartment(String, DepartmentInfo[]) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
指定された組織を持つメニューIDをすべて取得します。
getMenuIdsByDepartment(String, DepartmentInfo[]) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
指定された組織を持つメニューIDをすべて取得します。
getMenuIdsByDepartment(DepartmentInfo[]) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定された組織を持つメニューIDをすべて取得します。
getMenuIdsByLoginGroup(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
ログイングループがアクセス可能な管理メニューIDの一覧を取得します。
getMenuIdsByLoginGroup(String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
引き数に指定したログイングループが参照可能なメニューIDの一覧を取得します。
getMenuIdsByPost(String, PostInfo[]) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
指定された役職を持つメニューIDをすべて取得します。
getMenuIdsByPost(String, PostInfo[]) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
指定された役職を持つメニューIDをすべて取得します。
getMenuIdsByPost(PostInfo[]) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定された役職を持つメニューIDをすべて取得します。
getMenuIdsByPublicGroup(String, PublicGroupInfo[]) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
指定されたパブリックグループを持つメニューIDをすべて取得します。
getMenuIdsByPublicGroup(String, PublicGroupInfo[]) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
指定されたパブリックグループを持つメニューIDをすべて取得します。
getMenuIdsByPublicGroup(PublicGroupInfo[]) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定されたパブリックグループを持つメニューIDをすべて取得します。
getMenuIdsByRole(String, String[]) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
指定されたロールIDを持つメニューIDをすべて取得します。
getMenuIdsByRole(String, String[]) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
指定されたロールIDを持つメニューIDをすべて取得します。
getMenuIdsByRole(String[]) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定されたロールIDを持つメニューIDをすべて取得します。
getMenuInclusions(String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
すべてのメニュー構成を取得します。
getMenuInclusions() - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
すべてのメニュー構成を取得します。
getMenuInclusions(String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニュー構成を取得します。
getMenuItem(String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
指定されたメニューIDに対するノードを取得します。
getMenuItem(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
指定されたメニューIDに対するノードを取得します。
getMenuItem(String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
指定されたメニューIDに対応するメニューを取得します。
getMenuItem(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
指定されたメニューIDに対するノードを取得します。
getMenuItem(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定されたメニューIDに対応するメニューを取得します。
getMenuItem() - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
メニューを取得します。
getMenuItems(String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
すべてのノードを取得します。
getMenuItems() - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
すべてのノードを取得します。
getMenuItems() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
すべてのメニューを取得します。
getMenuItems(String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのノードを取得します。
getMenuItems() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
すべてのメニューを取得します。
getMenuItemsByIds(String, String[]) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
指定されたメニューIDのメニュー情報をすべて取得します。
getMenuItemsByIds(String[]) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
管理メニューIDの一覧からメニューアイテムを取得します。
getMenuItemsByIds(String[]) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
引き数に指定したメニューIDに一致するメニューアイテムの一覧を取得します。
getMenuItemsByIds(String, String[]) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
指定されたユーザIDのメニュー情報をすべて取得します。
getMenuItemsByIds(String[]) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
ログイングループ内で引数指定したメニューIDのメニュー情報をすべて取得します。
getMenuLinkSetCode() - class jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet のメソッド
メニューリンクセットコードを取得します。
getMenuLoginGroups(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
管理メニューにアクセス可能なログイングループの一覧を取得します。
getMenuLoginGroups(String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
引数に指定したメニューを参照可能なログイングループIDの一覧を取得します。
getMenuPosts(String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
すべてのメニュー役職を取得します。
getMenuPosts(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニュー役職を取得します。
getMenuPosts(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューに紐付いた役職の一覧を取得します。
getMenuPublicGroups(String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
すべてのメニューパブリックグループを取得します。
getMenuPublicGroups(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニューパブリックグループを取得します。
getMenuPublicGroups(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューに紐付いたパブリックグループの一覧を取得します。
getMenuRoles(String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
すべてのメニューロールを取得します。
getMenuRoles(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニューロールを取得します。
getMenuRoles(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューに紐付いたロールの一覧を取得します。
getMenuTree() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニュー構成を取得します。
getMenuTree(String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
引数に指定したログイングループのメニュー構成を取得します。
getMenuTree() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニュー構成を取得します。
getMenuTree(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定されたクライアントタイプのみのメニュー構成を取得します。
getMenuTree(String, String[], boolean) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定されたクライアントタイプと指定されたメニューIDのみのメニュー構成を取得します。
getMenuType() - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
メニュータイプを取得します。
getMerchidcl() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 決済代行会社のマーチャント IDを取得します。
getMerchidcl() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 決済代行会社のマーチャント IDを取得します。
getMessage() - class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent のメソッド
通知されたエラーメッセージを取得します。
getMessage() - class jp.co.intra_mart.extension.maskat.util.MKError のメソッド
messageを取得します。
getMessage(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
getMessage() - class jp.co.intra_mart.foundation.acssecurity.AcssecurityException のメソッド

getMessage(Locale, String) - class jp.co.intra_mart.foundation.image.ImageIconMessageBundle の static メソッド
イメージアイコンメッセージを取得します。
getMessage(Locale, String, String) - class jp.co.intra_mart.foundation.image.ImageIconMessageBundle の static メソッド
置換文字列を挿入したイメージアイコンメッセージを取得します。
getMessage(Locale, String, String, String) - class jp.co.intra_mart.foundation.image.ImageIconMessageBundle の static メソッド
置換文字列を挿入したイメージアイコンメッセージを取得します。
getMessage(Locale, String, String, String, String) - class jp.co.intra_mart.foundation.image.ImageIconMessageBundle の static メソッド
置換文字列を挿入したイメージアイコンメッセージを取得します。
getMessage(Locale, String, String[]) - class jp.co.intra_mart.foundation.image.ImageIconMessageBundle の static メソッド
置換文字列を挿入したイメージアイコンメッセージを取得します。
getMessage(String) - class jp.co.intra_mart.foundation.image.ImageIconMessageBundle の static メソッド
イメージアイコンメッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.foundation.image.ImageIconMessageBundle の static メソッド
置換文字列を挿入したイメージアイコンメッセージを取得します。
getMessage(String, String, String) - class jp.co.intra_mart.foundation.image.ImageIconMessageBundle の static メソッド
置換文字列を挿入したイメージアイコンメッセージを取得します。
getMessage(String, String, String, String) - class jp.co.intra_mart.foundation.image.ImageIconMessageBundle の static メソッド
置換文字列を挿入したイメージアイコンメッセージを取得します。
getMessage(String, String[]) - class jp.co.intra_mart.foundation.image.ImageIconMessageBundle の static メソッド
置換文字列を挿入したイメージアイコンメッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorHandler の static メソッド
メッセージの取得。
getMessage() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。
getMessage(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
引数に一致したType情報のメッセージ情報全て取得します。
getMessage() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージを取得します｡
getMessage(Locale, String) - class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle の static メソッド
SAPリアルタイム連携APIメッセージを取得します。
getMessage(Locale, String, String) - class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle の static メソッド
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
getMessage(Locale, String, String, String) - class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle の static メソッド
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
getMessage(Locale, String, String, String, String) - class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle の static メソッド
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
getMessage(Locale, String, String[]) - class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle の static メソッド
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
getMessage(String) - class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle の static メソッド
SAPリアルタイム連携APIメッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle の static メソッド
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
getMessage(String, String, String) - class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle の static メソッド
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
getMessage(String, String, String, String) - class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle の static メソッド
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
getMessage(String, String[]) - class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle の static メソッド
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
getMessage() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージテキストを取得します。
getMessage() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージテキストを取得します。
getMessage(Locale, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(Locale, String, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(Locale, String, String, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(Locale, String, String, String, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(Locale, String, String[]) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(String, String, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(String, String, String, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(String, String[]) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryResult のメソッド
メッセージを取得します。
getMessage() - class jp.co.intra_mart.foundation.utility.ErrorEvent のメソッド
推奨されていません。 通知されたエラーメッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler のメソッド
メッセージを取得します。
getMessage(String, String, Locale) - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler のメソッド
メッセージを取得します。
getMessage(String, String, Object[]) - class jp.co.intra_mart.framework.base.message.MessageManager のメソッド
ロケールを指定せず、キーに該当するメッセージを取得します。
getMessage(String, String, Object[], Locale) - class jp.co.intra_mart.framework.base.message.MessageManager のメソッド
ロケールを指定し、キーに該当するメッセージを取得します。
getMessage(String, String) - interface jp.co.intra_mart.framework.base.message.MessagePropertyHandler のメソッド
メッセージを取得します。
getMessage(String, String, Locale) - interface jp.co.intra_mart.framework.base.message.MessagePropertyHandler のメソッド
メッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler のメソッド
メッセージを取得します。
getMessage(String, String, Locale) - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler のメソッド
メッセージを取得します。
getMessage() - class jp.co.intra_mart.framework.base.service.validator.ValidationException のメソッド
例外メッセージを取得します。
getMessage() - class jp.co.intra_mart.framework.base.service.validator.ValidationExceptionDetail のメソッド
検証結果のメッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler のメソッド
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
DefaultMessagePropertyHandler.getMessage(String)を使用してください。
getMessage(String) - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler のメソッド
キーに該当するメッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler のメソッド
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
パラメータloginGroupは実際には使用しません。IntramartMessagePropertyHandler.getMessage(String)を使用してください。
getMessage(String) - class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler のメソッド
キーに該当するメッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.framework.system.message.MessageManager のメソッド
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
設定されているMessagePropertyHandlerによっては、 パラメータloginGroupは実際には使用しない可能性があります。MessageManager.getMessage(String)を使用してください。
getMessage(String) - class jp.co.intra_mart.framework.system.message.MessageManager のメソッド
キーに該当するメッセージを取得します。
getMessage(String, String) - interface jp.co.intra_mart.framework.system.message.MessagePropertyHandler のメソッド
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
MessagePropertyHandler.getMessage(String)を使用してください。
getMessage(String) - interface jp.co.intra_mart.framework.system.message.MessagePropertyHandler のメソッド
キーに該当するメッセージを取得します。
getMessageBody() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper のメソッド
リクエストのメッセージボディを返します。
getMessageCode() - class jp.co.intra_mart.extension.maskat.util.MKError のメソッド
messageCodeを取得します。
getMessageId() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
メッセージ IDを取得します。
getMessageManager() - class jp.co.intra_mart.framework.base.message.MessageManager の static メソッド
メッセージマネージャを取得します。
getMessageManager() - class jp.co.intra_mart.framework.system.message.MessageManager の static メソッド
MessageManagerを取得します。
getMessageNumber() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
システムメッセージ番号を取得します。
getMessagePropertyHandler() - class jp.co.intra_mart.framework.base.message.MessageManager のメソッド
メッセージプロパティハンドラを取得します。
getMessagePropertyHandler() - class jp.co.intra_mart.framework.system.message.MessageManager のメソッド
メッセージプロパティハンドラを取得します。
getMessageText() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
メッセージのテキスト行を取得します。
getMessageType() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
メッセージタイプを取得します。
getMessageV1() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ１を取得します｡
getMessageV1() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ変数を取得します。
getMessageV1() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ変数を取得します。
getMessageV2() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ２を取得します｡
getMessageV2() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ変数を取得します。
getMessageV2() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ変数を取得します。
getMessageV3() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ３を取得します｡
getMessageV3() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ変数を取得します。
getMessageV3() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ変数を取得します。
getMessageV4() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ４を取得します｡
getMessageV4() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ変数を取得します。
getMessageV4() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ変数を取得します。
getMetaData() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この接続のデータベースに関するメタデータを取得します。
getMethod() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
メソッドを取得します。
getMethod() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性methodの値を取得します。
getMfrNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のメソッド
製造者番号を取得します。
getMfrNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
製造者番号を取得します。
getMfrNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造者番号を取得します。
getMfrNoExt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
外部製造者コード名または番号を取得します。
getMilestone() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
用途を取得します。
getMilestoneNumber() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン番号を取得します。
getMilestoneUsage() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン用途を取得します。
getMilitId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ID: 武器を取得します。
getMimeEncoding(Locale) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
MIMEエンコードを取得します。
getMin() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
ｙ軸の最小値を返します。
getMin() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
ｙ軸の最小値を返します。
getMin() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
ｙ軸の最小値を返します。
getMinDate() - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
システムで許可されている最小日時を取得します。
getMinDate() - class jp.co.intra_mart.foundation.datastore.common.structure.Term の static メソッド
システムで設定できる期間の最小日時を取得します。
getMinDate() - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager の static メソッド
システムで設定できる期間の最小日時を取得します。
getMinDely() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
納品書処理時の最小納入数量を取得します。
getMinLotSize() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要と供給を一致させるための最小ロットサイズを取得します。
getMinMto() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
受注製造品最少受注数量を取得します。
getMinOrder() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
基本数量単位での最小受注数量を取得します。
getMinSafetyStk() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最小安全在庫を取得します。
getMinSbQty() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
最小棚番在庫数量を取得します。
getMinlotsize() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最小ロットサイズを取得します。
getMinremlife() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
最低有効期間残を取得します。
getMinremlife() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
最低有効期間残を取得します。
getMixedMrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
二重 MRP 区分を取得します。
getMlActive() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目レベルで有効な品目元帳を取得します。
getMlSettle() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目元帳決済: 管理を取得します。
getMnInvoice() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
マニュアル請求書更新を取得します。
getMnInvoice() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMnInvoice() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
マニュアル請求書更新を取得します。
getMnInvoice() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMobileEasyLoginURL(String, String) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil の static メソッド
かんたんログイン用のURLを取得します。
getMobileEasyLoginURL(HttpServletRequest, String, String) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil の static メソッド
かんたんログイン用のURLを取得します。
getMobileEmailAddress() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
携帯用メールを取得します。
getMobileEmailAddress(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
携帯用メールを取得します。
getMobileEmailAddress() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
携帯用メールを取得します。
getMobileEmailAddress() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯用メールを取得します。
getMobileEmailAddress(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯用メールを取得します。
getMobileEmailAddress() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
携帯用メールを取得します。
getMobileNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
携帯電話番号を取得します。
getMobileNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
携帯電話番号を取得します。
getMobileNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
携帯電話番号を取得します。
getMobileNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯電話番号を取得します。
getMobileNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯電話番号を取得します。
getMobileNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
携帯電話番号を取得します。
getMobilePassword() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
モバイル用パスワードを取得します。
getMobilePassword() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
モバイル用パスワードを取得します。
getMobileUserAgent(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
モバイル端末の固体識別番号を取得します。
getMobileUserAgent() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
モバイル端末の固体識別番号を取得します。
getModel() - interface jp.co.intra_mart.foundation.datastore.common.config.BaseModel のメソッド
基本モデルが定義されているモデル定義を取得します。
getModel() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
このエンティティを参照しているモデルを取得します。
getModel() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalModel のメソッド
国際化モデルが定義されているモデル定義を取得します。
getModel() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalModel のメソッド
期間国際化モデルが定義されているモデル定義を取得します。
getModel() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableModel のメソッド
期間化モデルが定義されているモデル定義を取得します。
getModelSi() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
モデル選択区分を取得します。
getModelSp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
モデル選択方式を取得します。
getModels() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義しているモデル定義の一覧を取得します。
getModifiable() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
変更可能の可否を返します。
getMonth() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
月を取得します。
getMonth() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
月を取得します。
getMonthInfos(CategorizedCalendarInfo, int, int) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
月情報を取得します。
getMovPrPp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期移動平均原価/期間平均原価を取得します。
getMovPrPy() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度の移動平均原価/期間単価を取得します。
getMoveBatch() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入庫/出庫ロットを取得します。
getMoveBatch() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫ロットを取得します。
getMoveMat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入庫/出庫品目を取得します。
getMoveMat() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫品目を取得します。
getMoveMatExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を取得します。
getMoveMatExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を取得します。
getMoveMatGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を取得します。
getMoveMatGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を取得します。
getMoveMatVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を取得します。
getMoveMatVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を取得します。
getMovePlant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入庫/出庫プラントを取得します。
getMovePlant() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫プラントを取得します。
getMoveReas() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
移動理由を取得します。
getMoveReas() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
移動理由を取得します。
getMoveStloc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入庫/出庫保管場所を取得します。
getMoveStloc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫保管場所を取得します。
getMoveType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
移動タイプ (在庫管理)を取得します。
getMoveType() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
移動タイプ (在庫管理)を取得します。
getMoveTypeRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
移動タイプの範囲を取得します。
getMoveValType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
転送ロットの評価タイプを取得します。
getMoveValType() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
転送ロットの評価タイプを取得します。
getMovingPr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
移動平均原価/期間単位価格を取得します。
getMrpAreaExists() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: MRP エリア登録済を取得します。
getMrpCtrler() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
MRP 管理者を取得します。
getMrpGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
MRP グループを取得します。
getMrpInd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所 MRP 区分を取得します。
getMrpRelevancyDepRequirements() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
従属所要量と MRP の関連性を取得します。
getMrpType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
MRP タイプを取得します。
getMrpView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
資材所要量計画 (MRP) ビューを取得します。
getMrpView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
資材所要量計画 (MRP) ビューを取得します。
getMrpView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
資材所要量計画 (MRP) ビューを取得します。
getMrpprofile() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目: MRP プロファイルを取得します。
getMsDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
品目利用可能日を取得します。
getMsDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
品目利用可能日を取得します。
getMsDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMsTime() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
品目供給ステージ (現地時刻: プラント参照)を取得します。
getMsTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
品目供給ステージ (現地時刻: プラント参照)を取得します。
getMsTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMsgToIm() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
区分: 在庫管理への出力を取得します。
getMshost() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing のメソッド
接続先メッセージサーバIPアドレスを取得します。
getMshost() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing のメソッド
接続先メッセージサーバIPアドレスを取得します。
getMultRefM() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費データ参照品目の乗数を取得します。
getMvtInd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
移動区分を取得します。
getMvtInd() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
移動区分を取得します。
getName() - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity のメソッド
フォームのコントロール名称の取得。
getName() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
ファイル名を取得します。
getName() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
パラメータ名を返します。
getName() - class jp.co.intra_mart.foundation.database.DbTypes のメソッド

getName() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
分類区分名を取得します。
getName(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
分類区分名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational のメソッド
分類区分名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
分類名を取得します。
getName(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
分類名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational のメソッド
分類名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct のメソッド
会社名または組織名を取得する。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
組織名を取得します。
getName(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
組織名を取得します。
getName(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
組織名を取得します。
getName(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
組織名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
組織名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織名を取得します。
getName(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織名を取得します。
getName(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織名を取得します。
getName(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
組織名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
役職名を取得します。
getName(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
役職名を取得します。
getName(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
役職名を取得します。
getName(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
役職名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational のメソッド
役職名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct のメソッド
グループ名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループ名を取得します。
getName(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループ名を取得します。
getName(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループ名を取得します。
getName(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループ名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のメソッド
グループ名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループ名を取得します。
getName(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループ名を取得します。
getName(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループ名を取得します。
getName(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループ名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のメソッド
グループ名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザ名を取得します。
getName(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザ名を取得します。
getName(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザ名を取得します。
getName(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザ名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
ユーザ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
分類区分名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
分類区分名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel のメソッド
分類区分名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
分類名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
分類名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel のメソッド
分類名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を取得します。
getName(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を取得します。
getName(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
組織名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を取得します。
getName(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を取得します。
getName(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel のメソッド
役職名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel のメソッド
役職名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel のメソッド
役職名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を取得します。
getName(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を取得します。
getName(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel のメソッド
グループ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を取得します。
getName(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を取得します。
getName(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
ユーザ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーション名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.BaseTable のメソッド
基本テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping のメソッド
カラム名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable のメソッド
拡張基本テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable のメソッド
拡張国際化テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable のメソッド
拡張期間国際化テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable のメソッド
拡張期間化テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable のメソッド
国際化テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping のメソッド
プライマリーキーとなるカラム名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
リレーションシップ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable のメソッド
期間国際化テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable のメソッド
期間化テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader のメソッド
エクスポート処理名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader のメソッド
インポート処理名を取得します。
getName() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
推奨されていません。 フォームのコントロール名称の取得。
getName() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
名前を返します。
getName() - interface jp.co.intra_mart.foundation.mail.javamail.model.AttachmentFile のメソッド
添付ファイルのファイル名を取得します。
getName() - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
項目の表示名称のを取得します。
getName() - class jp.co.intra_mart.foundation.page.TreeLeaf のメソッド
項目の表示名称のを取得します。
getName() - interface jp.co.intra_mart.foundation.page.TreeNode のメソッド
項目の表示名称のを取得します。
getName() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
名称 1を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のメソッド
管理領域名を取得します｡
getName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のメソッド
管理領域を指定して管理領域名を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
一般名称を取得します｡
getName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタを指定して一般名称を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
名称 1を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
名称 1を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
発注者名称を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
名称 1を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
名称 1を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
名称 1を取得します。
getName() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチ名を取得します。
getName() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
アプリケーション名を取得します。
getName() - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler のメソッド
推奨されていません。 フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
このオブジェクトの表すディレクトリ名称を取得します。
getName() - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
このインスタンスが表すグループＩＤを取得します。
getName() - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
このインスタンスの表すロックＩＤを返します。
getName() - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
このオブジェクトの表すディレクトリ名称を取得します。
getName() - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
このインスタンスが表すグループＩＤを取得します。
getName() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
このオブジェクトの表すディレクトリ名称を取得します。
getName() - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
このインスタンスが表すセッションＩＤを取得します。
getName() - interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory のメソッド
このオブジェクトの表す名称を取得します。
getName() - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
このオブジェクトの表す名称を取得します。
getName() - class jp.co.intra_mart.framework.base.event.EventTriggerInfo のメソッド
イベントトリガ名を取得します。
getName() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性nameの値を取得します。
getName() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
nameを取得します。
getName() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
nameを取得します。
getName() - class jp.co.intra_mart.framework.base.web.tag.ParamTag のメソッド
パラメータ名を取得します。
getName() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
nameを取得します。
getName() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性nameを取得します。
getName() - class jp.co.intra_mart.framework.system.property.PropertyParam のメソッド
パラメータ名を取得します。
getName() - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
ロール名を取得します。
getName2() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
名称 2を取得します。
getName2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
名称 2を取得します。
getName2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
名称 2を取得します。
getName3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
名称 3を取得します。
getName3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
名称 3を取得します。
getName4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
名称 4を取得します。
getName4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
名称 4を取得します。
getNameAsStream() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
パラメータの名称を返します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
組織名英字を取得します。
getNameEnglish(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
組織名英字を取得します。
getNameEnglish(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
組織名英字を取得します。
getNameEnglish(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
組織名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
組織名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織名英字を取得します。
getNameEnglish(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織名英字を取得します。
getNameEnglish(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織名英字を取得します。
getNameEnglish(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
組織名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループ名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループ名英字を取得します。
getNameEnglish(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループ名英字を取得します。
getNameEnglish(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループ名英字を取得します。
getNameEnglish(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループ名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のメソッド
グループ名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループ名英字を取得します。
getNameEnglish(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループ名英字を取得します。
getNameEnglish(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループ名英字を取得します。
getNameEnglish(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループ名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のメソッド
グループ名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザ名英字を取得します。
getNameEnglish(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザ名英字を取得します。
getNameEnglish(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザ名英字を取得します。
getNameEnglish(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザ名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
ユーザ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を取得します。
getNameEnglish(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を取得します。
getNameEnglish(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を取得します。
getNameEnglish(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
組織名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名英字を取得します。
getNameEnglish(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を取得します。
getNameEnglish(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を取得します。
getNameEnglish(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を取得します。
getNameEnglish(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel のメソッド
グループ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名英字を取得します。
getNameEnglish(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を取得します。
getNameEnglish(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を取得します。
getNameEnglish(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を取得します。
getNameEnglish(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
ユーザ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名英字を取得します。
getNameEnglish(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名英字を取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
組織名カナを取得します。
getNameSyllabary(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
組織名カナを取得します。
getNameSyllabary(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
組織名カナを取得します。
getNameSyllabary(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
組織名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
組織名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織名カナを取得します。
getNameSyllabary(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織名カナを取得します。
getNameSyllabary(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織名カナを取得します。
getNameSyllabary(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
組織名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループ名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループ名カナを取得します。
getNameSyllabary(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループ名カナを取得します。
getNameSyllabary(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループ名カナを取得します。
getNameSyllabary(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループ名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のメソッド
グループ名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループ名カナを取得します。
getNameSyllabary(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループ名カナを取得します。
getNameSyllabary(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループ名カナを取得します。
getNameSyllabary(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループ名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のメソッド
グループ名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザ名カナを取得します。
getNameSyllabary(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザ名カナを取得します。
getNameSyllabary(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザ名カナを取得します。
getNameSyllabary(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザ名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
ユーザ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを取得します。
getNameSyllabary(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを取得します。
getNameSyllabary(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを取得します。
getNameSyllabary(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
組織名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名カナを取得します。
getNameSyllabary(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを取得します。
getNameSyllabary(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを取得します。
getNameSyllabary(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを取得します。
getNameSyllabary(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel のメソッド
グループ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名カナを取得します。
getNameSyllabary(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを取得します。
getNameSyllabary(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを取得します。
getNameSyllabary(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを取得します。
getNameSyllabary(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
ユーザ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名カナを取得します。
getNameSyllabary(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名カナを取得します。
getName_2() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
名称 2を取得します。
getName_2() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
名称 2を取得します。
getName_3() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
名称 3を取得します。
getName_3() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
名称 3を取得します。
getName_4() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
名称 4を取得します。
getName_4() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
名称 4を取得します。
getNationalHodildayInfos() - class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo のメソッド
データタイプが祝祭日であるカレンダーデータの一覧を取得します。
getNativePaths() - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader のメソッド
このクラスローダーに設定されているネイティブライブラリパスを返します。
getNbSlips() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫票の印刷部数を取得します。
getNbSlipsx() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
関連ユーザデータ項目の更新情報を取得します。
getNegStocks() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラントにおけるマイナス在庫許可を取得します。
getNetPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
通貨額を取得します。
getNetPrice() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
正味価格を取得します。
getNetPrice() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
正味価格を取得します。
getNetValHd() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
受注正味額 (伝票通貨)を取得します。
getNetValue() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買発注通貨による正味発注額を取得します。
getNetValue() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
明細の正味額を取得します。
getNetValue() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
BAPI の通貨額 (小数点以下９桁)を取得します。
getNetValue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
正味金額を取得します。
getNetValue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
正味金額を取得します。
getNetValue() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
伝票通貨による正味額を取得します。
getNetValue() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
伝票通貨での受注明細正味額を取得します。
getNetValueItem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
正味金額を取得します。
getNetWeight() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
正味重量を取得します。
getNetWeight() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
正味重量を取得します。
getNetWeight() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
正味重量を取得します。
getNetWeight() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細の正味重量を取得します。
getNetWeight() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getNetwork() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ネットワーク番号を取得します。
getNetwork() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
勘定割当のネットワーク番号を取得します。
getNetwork() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
勘定割当のネットワーク番号を取得します。
getNetwork() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
勘定割当のネットワーク番号を取得します。
getNetworkAssignment() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ネットワーク割当を取得します。
getNetworkAssignment() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ネットワーク割当を取得します。
getNetworkFile(String) - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector のメソッド
Storageサービス上の指定されたパスのファイルにアクセスするNetworkFileを取得します。
getNetworkFile(String) - class jp.co.intra_mart.framework.base.data.IntramartFileServerDAO のメソッド
パスに該当するNetworkFileを取得します。
getNetworkProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ネットワークプロファイルを取得します。
getNewArrivedList(String) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager の static メソッド
汎用新着情報の一覧を取得します。
getNewArrivedList(String, String) - interface jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider のメソッド
新着情報を一覧を取得します。
getNewArrivedList(String, String) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider のメソッド
汎用新着情報を取得
getNewArrivedList(String, String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryNewArrivedProvider のメソッド
パスワード履歴管理の新着情報を一覧を取得します。
getNextEventItem() - class jp.co.intra_mart.foundation.navigator.SelectItem のメソッド

getNextEventResultItem() - class jp.co.intra_mart.foundation.navigator.SelectItem のメソッド

getNextItemId() - class jp.co.intra_mart.foundation.navigator.SelectItemInfo のメソッド
遷移先アイテムID取得
getNextPage() - class jp.co.intra_mart.framework.base.service.DefaultTransition のメソッド
次に遷移するページを取得します。
getNextPage() - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のメソッド
次に遷移するページを取得します。
getNextPage() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
次に遷移するページを取得します。
getNextPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
getNextPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
getNextPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
getNextPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
getNextPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getNextPagePath(String, String, Locale)を使用してください。
getNextPagePath(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getNextPagePath(String, String, String, Locale)を使用してください。
getNextPagePath(String, String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getNextPagePath(String, String, Locale)を使用してください。
getNextPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getNextPagePath(String, String, String, Locale)を使用してください。
getNextPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
このトランジションに設定されているアプリケーションIDとサービスIDに該当する次ページのパスを取得します。
getNextPagePath(String) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
このトランジションに設定されているアプリケーションIDとサービスIDと、指定されたキーに該当する次ページのパスを取得します。
getNextPagePath(String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
getNextPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
getNextPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPayee() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
次受取人を取得します。
getNextType() - class jp.co.intra_mart.foundation.navigator.SelectItem のメソッド

getNextType() - class jp.co.intra_mart.foundation.navigator.SelectItemInfo のメソッド
遷移先タイプ取得
getNoAuthority() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
権限チェックなし区分を取得します｡
getNoCosting() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算なしを取得します。
getNoDisct() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
現金値引対象外明細を取得します。
getNoFrlimit() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
制限なしを取得します。
getNoGrPost() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先が入庫を転記していませんを取得します。
getNoGrPost() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getNoLimit() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
制限なしを取得します。
getNoLimit() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
制限なしを取得します。
getNoMatmast() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目マスタ確認禁止を取得します。
getNoMessageReq() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
メッセージ不要区分を取得します｡
getNoMessaging() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
出力決定なし区分を取得します｡
getNoMoreGr() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
納入完了区分を取得します。
getNoMoreGr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
納入完了 区分を取得します。
getNoMoreGr() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
納入完了 区分を取得します。
getNoPermissionErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
無許可アクセスエラーページURLを取得する。
getNoPermissionErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
無許可アクセスエラーページURLを取得する。
getNoPriceFromPo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
最終伝票からの価格転送なし区分を取得します｡
getNoPstChgnt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
区分: 振替要求通知登録禁止を取得します。
getNoRounding() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買発注明細での非表示丸めを取得します。
getNoSheets() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書枚数 (文書管理システムによらない)を取得します。
getNoTransferReq() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
区分: 転送要求未登録を取得します。
getNoappllog() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
アプリケーションログ書込なしを取得します。
getNochangedoc() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
変更伝票書込なしを取得します。
getNodeSet() - interface jp.co.intra_mart.foundation.page.TreeNodeProvider のメソッド
ツリービュー内の「ホーム」以外の全てのノードが含まれるSetを返します。
getNodeSet() - class jp.co.intra_mart.foundation.page.TreeRoot のメソッド
ツリービュー内の「ホーム」以外の全てのノードが含まれるSetを返します。
getNondItax() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
BAPI の通貨額 (小数点以下９桁)を取得します。
getNoresize() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
noresizeを取得します。
getNostructure() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
チェックボックスを取得します。
getNotMrpApplicable() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
区分: MRP への入出庫予定の適用不可と購買依頼未登録を取得します。
getNote() - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
マウスポイント時に表示されるポップアップ文字列を取得します。
getNote() - class jp.co.intra_mart.foundation.page.TreeLeaf のメソッド
マウスポイント時に表示されるポップアップ文字列を取得します。
getNote() - interface jp.co.intra_mart.foundation.page.TreeNode のメソッド
マウスポイント時に表示されるポップアップ文字列を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel のメソッド
説明を取得します。
getNotes() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
説明を取得します。
getNotes() - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
説明を取得します。
getNotes() - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
備考を取得します。
getNotifNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
通知番号を取得します。
getNotifNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getNullKeys() - interface jp.co.intra_mart.foundation.datastore.common.config.Delete のメソッド
ターゲットエンティティのデータ削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。
getNullKeys() - interface jp.co.intra_mart.foundation.datastore.common.config.Lifetime のメソッド
ターゲットエンティティの期間削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。
getNullable() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
Null受付の可否を返します。
getNumber() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ナンバーを取得します｡
getNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ番号を取得します。
getNumber() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ番号を取得します。
getNumber() - class jp.co.intra_mart.framework.base.event.EventTriggerInfo のメソッド
ソート番号を取得します。
getNumberOfCapacities() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
所要能力数を取得します。
getNumberValue() - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
属性数値を取得します。
getNumberValue() - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel のメソッド
属性数値を取得します。
getNumconvert() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件単位を基本単位へ変換する分子を取得します。
getNumconvert() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件単位を基本単位へ変換する分子を取得します。
getNumerator() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
基本数量単位への換算分子を取得します。
getObjKey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
対象キーを取得します。
getObjKey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
対象キーを取得します。
getObjTxt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
言語依存対象テキストを取得します。
getObjType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
対象タイプを取得します。
getObjType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
対象タイプを取得します。
getObject() - class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent のメソッド
通知されたエラー発生オブジェクトを取得します。
getObject() - class jp.co.intra_mart.foundation.utility.ErrorEvent のメソッド
推奨されていません。 通知されたエラー発生オブジェクトを取得します。
getObjectGuid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
インスタンス用 TYPE_OF ステートメントの GUIDを取得します。
getObjectNo() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
対象番号を取得します。
getObjectNo() - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
対象番号を取得します。
getObjectType() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
オブジェクトタイプを取得します。
getObjectclass() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
オブジェクトクラス (言語非依存)を取得します。
getObjectclass() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
対象クラスを取得します。
getObjectclass() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
対象クラスを取得します。
getObjectclassExt() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
オブジェクトクラス、言語依存を取得します。
getObjectclassExt() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
オブジェクトクラス、言語依存を取得します。
getObjectclassExt() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
オブジェクトクラス、言語依存を取得します。
getOffsetMilestoneDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン日付のオフセットを取得します。
getOffsetMilestoneDateUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーンのオフセットのための時間単位を取得します。
getOffsetMilestoneDateUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
単位の ISO コードを取得します。
getOffsetPercentage() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
活動日に対するマイルストーンの百分率によるオフセットを取得します。
getOffsetStartEndIndicator() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
区分: オフセット用の参照（開始/終了活動日）を取得します。
getOldMatNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
旧品目コードを取得します。
getOnClick() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onClickの値を取得します。
getOnDblClick() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onDblClickの値を取得します。
getOnKeyDown() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyDownの値を取得します。
getOnKeyPress() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyPressの値を取得します。
getOnKeyUp() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyUpの値を取得します。
getOnMouseDown() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseDownの値を取得します。
getOnMouseMove() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseMoveの値を取得します。
getOnMouseOut() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseOutの値を取得します。
getOnMouseOver() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseOverの値を取得します。
getOnMouseUp() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseUpの値を取得します。
getOnblur() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
onblurを取得します。
getOnblur() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
onblurを取得します。
getOnblur() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onBlurを取得します。
getOnclick() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onClickの値を取得します。
getOnclick() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onClickの値を取得します。
getOnclick() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onClickの値を取得します。
getOnclick() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onClickの値を取得します。
getOndblclick() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onDblClickの値を取得します。
getOndblclick() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onDblClickの値を取得します。
getOndblclick() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onDblClickの値を取得します。
getOndblclick() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onDblClickの値を取得します。
getOnfocus() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
onfocusを取得します。
getOnfocus() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
onfocusを取得します。
getOnfocus() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onFocusを取得します。
getOnkeydown() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onKeyDownの値を取得します。
getOnkeydown() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onKeyDownの値を取得します。
getOnkeydown() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onKeyDownの値を取得します。
getOnkeydown() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onKeyDownの値を取得します。
getOnkeypress() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onKeyPressの値を取得します。
getOnkeypress() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onKeyPressの値を取得します。
getOnkeypress() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onKeyPressの値を取得します。
getOnkeypress() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onKeyPressの値を取得します。
getOnkeyup() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onKeyUpの値を取得します。
getOnkeyup() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onKeyUpの値を取得します。
getOnkeyup() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onKeyUpの値を取得します。
getOnkeyup() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onKeyUpの値を取得します。
getOnmousedown() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseDownの値を取得します。
getOnmousedown() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseDownの値を取得します。
getOnmousedown() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseDownの値を取得します。
getOnmousedown() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseDownの値を取得します。
getOnmousemove() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseMoveの値を取得します。
getOnmousemove() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseMoveの値を取得します。
getOnmousemove() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseMoveの値を取得します。
getOnmousemove() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseMoveの値を取得します。
getOnmouseout() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseOutの値を取得します。
getOnmouseout() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseOutの値を取得します。
getOnmouseout() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseOutの値を取得します。
getOnmouseout() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseOutの値を取得します。
getOnmouseover() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseOverの値を取得します。
getOnmouseover() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseOverの値を取得します。
getOnmouseover() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseOverの値を取得します。
getOnmouseover() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseOverの値を取得します。
getOnmouseup() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseUpの値を取得します。
getOnmouseup() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseUpの値を取得します。
getOnmouseup() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseUpの値を取得します。
getOnmouseup() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseUpの値を取得します。
getOnreset() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onResetの値を取得します。
getOnsubmit() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onSubmitの値を取得します。
getOpen() - class jp.co.intra_mart.foundation.navigator.EventFlow のメソッド

getOpen() - class jp.co.intra_mart.foundation.navigator.EventFlowInfo のメソッド
公開フラグ取得
getOpenQty() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
未処理数量のある明細を取得します。
getOperationMeasureUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動単位を取得します。
getOperationMeasureUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getOptimLev() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
最適化レベルを取得します。
getOption(String) - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
オプションの値を返します。
getOption(String, String) - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
オプションの値を返します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.Selection のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOptionNames() - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
指定されたすべてのオプションの名前を返します。
getOptions(String) - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
オプションの値を返します。
getOrdCosts() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
発注原価 (BAPI インタフェース)を取得します。
getOrdReason() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
受注理由 (取引理由)を取得します。
getOrdReason() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getOrdReason() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
受注理由 (取引理由)を取得します。
getOrdbilltyp() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
受注関連請求伝票に対する提案請求伝票タイプを取得します。
getOrdcombIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
受注結合出荷区分を取得します。
getOrdcombIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getOrdcompIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
受注結合出荷区分を取得します。
getOrdcompIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getOrder() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
指図番号 (個別値、または下限値)を取得します。
getOrder() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
指図番号 (個別値、または下限値)を取得します。
getOrder() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
指図番号を取得します。
getOrder() - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
指図番号を取得します。
getOrderCcardList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
クレジットカードデータを取得します。
getOrderCfgsBlobList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: BLOB 内部データ (SCE)を取得します。
getOrderCfgsInstList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: インスタンスを取得します。
getOrderCfgsPartOfList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: 部分設定を取得します。
getOrderCfgsRefInstList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: 参照明細/インスタンスを取得します。
getOrderCfgsRefList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: 参照データを取得します。
getOrderCfgsValueList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: 特性値を取得します。
getOrderCfgsVkList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: バリアント条件キーを取得します。
getOrderConditionsInList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
条件を取得します。
getOrderConditionsInXList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
条件チェックボックスを取得します。
getOrderExternalNo() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
外部指図番号 (個別値、または下限値)を取得します。
getOrderExternalNo() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
外部指図番号 (個別値、または下限値)を取得します。
getOrderExternalNoTo() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
外部指図番号 (上限値)を取得します。
getOrderExternalNoTo() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
外部指図番号 (上限値)を取得します。
getOrderHeaderIn() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
受注伝票ヘッダを取得します。
getOrderHeaderInX() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
受注伝票チェックリストを取得します。
getOrderItemsInList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
明細データを取得します。
getOrderItemsInXList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
明細データチェックボックスを取得します。
getOrderItno() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
指図明細番号を取得します。
getOrderItno() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
指図明細番号を取得します。
getOrderKeysList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
参照キーの出力テーブルを取得します。
getOrderListList() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
選択指図一覧を取得します。
getOrderListList() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
選択指図一覧を取得します。
getOrderName() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
テキストを取得します。
getOrderName() - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
テキストを取得します。
getOrderPartnersList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
伝票取引先を取得します。
getOrderProb() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細の受注可能性を取得します。
getOrderProb() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getOrderReason() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
発注理由を取得します。
getOrderSchedulesInList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
納入日程行データを取得します。
getOrderSchedulesInXList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
納入日程行データチェックボックスを取得します。
getOrderTextList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
テキストを取得します。
getOrderTo() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
指図番号 (上限値)を取得します。
getOrderTo() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
指図番号 (上限値)を取得します。
getOrderType() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
指図タイプを取得します。
getOrderType() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
指図タイプを取得します。
getOrderType() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
販売伝票タイプを取得します。
getOrderType() - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
販売伝票タイプを取得します。
getOrderid() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
指図番号を取得します。
getOrderid() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
指図番号を取得します。
getOrderid() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
指図番号を取得します。
getOrderid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
指図番号を取得します。
getOrderid() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
指図番号を取得します。
getOrderid() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
指図番号を取得します。
getOrderid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
指図番号を取得します。
getOrderid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getOrderprUn() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買発注価格単位を取得します。
getOrderprUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
購買発注価格単位 (購買管理)を取得します。
getOrderprUn() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
購買発注価格単位 (購買管理)を取得します。
getOrderprUnIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買発注価格のISOコードを取得します。
getOrderprUnIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
単位の ISO コードを取得します。
getOrderprUnIso() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
単位の ISO コードを取得します。
getOrigGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
発生源グループ (原価要素の下位区分)を取得します。
getOrigMat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目発生源を取得します。
getOriginalBatchFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
元ロット管理区分を取得します。
getOriginalBatchRefMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
元ロットの参照品目を取得します。
getOrigindoc() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
開始伝票を取得します。
getOurRef() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
社内参照番号を取得します｡
getOutlInd() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
区分: 出力行を取得します。
getOutlLevel() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
グループの階層レベルを取得します。
getOutlNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
アウトラインレベルを取得します。
getOutputPath() - interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader のメソッド
エクスポートデータを出力するファイルパスを取得します。
getOutputStream() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
ファイルの内容を保存するのに使用できるOutputStreamを取得します。
getOutputStream() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
出力ストリームの取得。
getOutputStream() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。
getOutputStream(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。
getOutputStream(HttpServletRequest, ExtendedHttpServletResponse) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。
getOutputStream(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。
getOutputStream() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 出力ストリームの取得。
getOutputStreamWriter() - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のメソッド
このオブジェクトの基礎出力となっている java.io.OutputStreamWriter を返します。
getOutputStreamWriter() - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のメソッド
推奨されていません。 このオブジェクトの基礎出力となっている java.io.OutputStreamWriter を返します。
getOverDlvTol() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
過剰納入許容範囲を取得します。
getOverTol() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
過剰納入許容範囲リミットを取得します。
getOverallprf() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
指図変更管理の全体プロファイルを取得します。
getOverdlvtol() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
過剰納入許容範囲を取得します。
getOverdlvtol() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getOverhdKey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
間接費キーを取得します。
getOverhdKey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getOverheadGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
原価計算間接費グループを取得します。
getOverheadKey() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
間接費キーを取得します。
getOverheadKey() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
間接費キーを取得します。
getOverlap(Term[], Term[]) - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager の static メソッド
2つの期間配列 term1 と term2 で重なっている期間を返します。
getOvfTol() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
超過許容値を取得します。
getOvfUnlim() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
契約外サービス制限なしを取得します。
getOwnerCode() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
所有者コードを取得します。
getOwnerCode() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
所有者コードを取得します。
getOwnerCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
所有者コードを取得します。
getOwnerCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
所有者コードを取得します。
getPMatExt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を取得します。
getPMatExt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPMatGuid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を取得します。
getPMatGuid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPMatVers() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を取得します。
getPMatVers() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPaAllocNmbr() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
ソートキーを取得します｡
getPaBlineDate() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
期日計算の支払基準日を取得します｡
getPaGlAccount() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
総勘定元帳勘定を取得します｡
getPaIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
レコード番号を取得します｡
getPaIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
レコード番号を取得します｡
getPaItemText() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
明細テキストを取得します｡
getPaItemnoAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
会計伝票明細番号を取得します｡
getPaPymtMeth() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
支払方法を取得します｡
getPaVendorNo() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
仕入先または債権者の勘定コードを取得します｡
getPackVoUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
容積単位 (許容梱包容積)を取得します。
getPackVoUnIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードでの容積単位 (許容梱包容積)を取得します。
getPackWtUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
重量単位 (許容梱包重量)を取得します。
getPackWtUnIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードでの重量単位 (許容梱包重量)を取得します。
getPackageVersion() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
パッケージバージョンを取得します。
getPageItem() - class jp.co.intra_mart.foundation.navigator.EventResultItem のメソッド

getPageKind() - class jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet のメソッド
ページ種別を取得します。
getPageKind() - class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet のメソッド
ページ種別を取得します。
getPageKind() - class jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet のメソッド
ページ種別を取得します。
getPageKind() - class jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet のメソッド
ページ種別を取得します。
getPageKind() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
ページ種別を取得します。
getPageKind() - class jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet のメソッド
ページ種別を取得します。
getPageKind() - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet のメソッド
ページ種別を取得します。
getPageNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書ページ番号 (文書管理システムによらない)を取得します。
getPagePath() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のメソッド
設定されているページパスを返します。
getPagePatternId() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
メインページパターンを取得します。
getPageformat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造メモのページ書式を取得します。
getParCompco() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
決済会社コードを取得します。
getParEff() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
有効性パラメータへの値割当/変更番号よりも優先を取得します。
getParamName() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
パラメタ名を取得します｡
getParamOpt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
パラメータ最適化用の区分を取得します。
getParamType() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
パラメタ属性を取得します｡
getParamValue(String) - class jp.co.intra_mart.foundation.navigator.LinkPageInfo のメソッド

getParameter(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.EmptyParameterHttpServletRequestWrapper のメソッド
パラメータの存在有無に関わらず、全てのパラメータの値を null として返します。
getParameter(String) - class jp.co.intra_mart.foundation.commons.ParameterManager のメソッド
パラメータの値を取得します。
getParameter() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
パラメーターを取得します｡
getParameter() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
パラメータ名を取得します。
getParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
設定したパラメータ値を取得します。
getParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
設定したパラメータ値を取得します。
getParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
設定したパラメータ値を取得します。
getParameterKeySet() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
現在、パラメータとして設定されているキーの一覧を返します。
getParameterKeySet() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
現在、パラメータとして設定されているキーの一覧を返します。
getParameterKeySet() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
現在、パラメータとして設定されているキーの一覧を返します。
getParameterMap() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.EmptyParameterHttpServletRequestWrapper のメソッド
この要求から取得できるパラメータの存在有無に関わらず、 空のjava.util.Map で返します。
getParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
設定済みパラメータのマップのコピーを返します。
getParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
設定済みパラメータのマップのコピーを返します。
getParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
設定済みパラメータのマップのコピーを返します。
getParameterNames() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.EmptyParameterHttpServletRequestWrapper のメソッド
この要求に含まれるパラメータの存在有無に関わらず、空のEnumerationを返します。
getParameterNames() - class jp.co.intra_mart.foundation.commons.ParameterManager のメソッド
パラメータ名の一覧を取得します。
getParameterValues(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.EmptyParameterHttpServletRequestWrapper のメソッド
指定された要求パラメータの存在有無に関わらずnullを返します。
getParameters() - interface jp.co.intra_mart.foundation.commons.ParameterSourceProvider のメソッド
パラメータの一覧を取得します。
getParams() - class jp.co.intra_mart.foundation.security.account.CsvAccountBackup のメソッド
パラメータを取得します。
getParent() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このオブジェクトがフィルタリングしているハンドラを返します。
getParent() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
ラップしている親オブジェクトを返します。
getParentComparator() - class jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator のメソッド
フィルター対象のコンパレータを返します。
getParentComparator() - class jp.co.intra_mart.foundation.utility.FilterComparator のメソッド
推奨されていません。 フィルター対象のコンパレータを返します。
getParentData(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getParentRoleIds(String)に置き換えられました。
getParentDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
親組織コードを取得します。
getParentId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
1 レベル上位の行 IDを取得します。
getParentId() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
1 レベル上位の行 IDを取得します。
getParentId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
選定におけるインスタンス番号を取得します。
getParentItemCategoryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
親商品カテゴリコードを取得します。
getParentItemCategoryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
親商品カテゴリコードを取得します。
getParentMenuId(String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
引数で指定されたノードの親ノードを取得します。
getParentMenuId(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
引数で指定されたノードの親ノードを取得します。
getParentMenuId() - class jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion のメソッド
親メニューIDを取得します。
getParentMenuId(String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
指定されたメニューの親メニューを取得します。
getParentMenuId(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
引数で指定されたノードの親ノードを取得します。
getParentMenuId() - class jp.co.intra_mart.foundation.security.menu.MenuInclusion のメソッド
親メニューIDを取得します。
getParentMenuId(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定されたメニューの親メニューを取得します。
getParentMenuId() - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
親メニューIDを取得します。
getParentName() - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
保存ディレクトリを取得します。
getParentPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
親グループコードを取得します。
getParentRoleId() - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel のメソッド
親ロールコードを取得します。
getParentRoleIds(String, String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
親ロールの一覧を取得します。
getParentRoleIds(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
親ロールの一覧を取得する。
getParentRoleIds(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
親ロールIDを取得します。
getParserKey() - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet のメソッド
RSS解析キーを取得します。
getPartAcct() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
取引先勘定コードを取得します。
getPartAcct() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
取引先勘定コードを取得します。
getPartAcct() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取引先勘定コードを取得します。
getPartDeliv() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
明細レベルでの分割納入 (在庫転送)を取得します。
getPartDlv() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細レベルの分納納入を取得します。
getPartDlv() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPartInv() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
一部請求区分を取得します。
getPartOfGuid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
インスタンス用 PART_OF ステートメントの GUIDを取得します。
getPartOfNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
Part_of 明細番号を取得します。
getPartnNumb() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
得意先コード 1を取得します。
getPartnRole() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
取引先機能を取得します。
getPartnerAddressesList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
アドレス (組織/会社) 用 BAPI 参照構造を取得します。
getPartnerAddressesList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
アドレス (組織/会社) 用 BAPI 参照構造を取得します。
getPartnerAddressesList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
アドレス (組織/会社) 用 BAPI 参照構造を取得します。
getPartnerBk() - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
取引先銀行タイプを取得します。
getPartnerList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
得意先一覧を取得します｡
getPartnerdesc() - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
言語別取引先機能テキストを取得します。
getPasswd() - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
パスワードを取得します。
getPasswd() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 パスワードを取得します｡
getPassword() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
パスワードを取得します。
getPassword() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
パスワード取得。
getPassword() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ログインパスワードを取得する。
getPassword() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインパスワードを取得する。
getPassword() - class jp.co.intra_mart.foundation.security.password.PasswordHistory のメソッド
パスワードを取得します。
getPassword() - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler のメソッド
設定されているパスワードを返します。
getPassword() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
パスワードを取得します。
getPasswordExpireLimit(String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
パスワード履歴数を取得。
getPasswordExpireLimit() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
設定したパスワードの有効期限を取得。
getPasswordExpireLimit(String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
設定したパスワードの有効期限を取得。
getPasswordHistories(String, String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
パスワード履歴を取得。
getPasswordHistories(String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
パスワード履歴を取得。
getPasswordHistories(String, String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
パスワード履歴を取得。
getPasswordHistoryCount(String, String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
パスワード履歴数を取得。
getPasswordHistoryCount(String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
パスワード履歴数を取得。
getPasswordHistoryCount(String, String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
パスワード履歴数を取得。
getPasswordHistoryManagedCount(String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
世代管理数を取得。
getPasswordHistoryManagedCount() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
世代管理数を取得。
getPasswordHistoryManagedCount(String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
世代管理数を取得。
getPasswordPage(String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
パスワード変更画面のＵＲＬを取得。
getPasswordPage() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
パスワード変更画面のＵＲＬを取得。
getPasswordPage(String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
パスワード変更画面のＵＲＬを取得。
getPath() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このオブジェクトが表すパスを返します。
getPathXML(Node, Node) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter のメソッド
このノードのフルパスを取得します。
getPayer() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
支払人を取得します。
getPaymentMethods() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
考慮される支払方法一覧を取得します。
getPaymentTerms() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
支払条件キーを取得します。
getPaytype() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払手段: 支払カード計画の明細分類を取得します。
getPboxcitNo() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村私書箱コード (市ファイル)を取得します。
getPboxcitNo() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村私書箱コード (市ファイル)を取得します。
getPboxcitNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村私書箱コード (市ファイル)を取得します。
getPckgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
パッケージ番号を取得します。
getPckgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
パッケージ番号を取得します。
getPckgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
パッケージ番号を取得します。
getPckgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のメソッド
パッケージ番号を取得します。
getPckgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
パッケージ番号を取得します。
getPckgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
パッケージ番号を取得します。
getPcode1Ext() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村郵便番号の拡張子 例: 郵便番号 +4+2を取得します。
getPcode2Ext() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱郵便番号拡張子 例: 郵便番号 +4+2を取得します。
getPcode3Ext() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
主要得意先郵便番号拡張子 例: 郵便番号 +4+2を取得します。
getPctrName() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
一般名称を取得します｡
getPctrName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタを指定して一般名称を取得します。
getPerCurCostEst() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
現行標準原価見積期間を取得します。
getPerFutCostEst() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
将来標準原価見積期間を取得します。
getPerPreCostEst() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前標準原価見積期間を取得します。
getPercentOfWork() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
作業の比率 (%)を取得します。
getPercentage() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
勘定設定金額配賦のパーセントを取得します。
getPercentageOfCompletion() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
進捗度 (%)を取得します。
getPeriodInd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
期間区分を取得します。
getPeriodInd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
期間区分を取得します。
getPeriodIndExpirationDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
有効期間期限日の期間区分を取得します。
getPeriodIndExpirationDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
有効期間期限日の期間区分を取得します。
getPeriodProfileSafetyTime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
安全時間の期間プロファイルを取得します。
getPermissionSelector(String) - class jp.co.intra_mart.foundation.security.permission.PermissionManager のメソッド
指定されたカテゴリについて、設定XMLファイルで定義されているPermissionSelectorを返します。
getPersNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
従業員番号を取得します。
getPersistId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
インスタンス番号 (固定)を取得します。
getPersistIdType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
インスタンス番号タイプ (固定)を取得します。
getPersonResp() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
責任者を取得します。
getPersonRespPhone() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
責任者の電話番号を取得します。
getPersonal() - interface jp.co.intra_mart.foundation.mail.javamail.model.MailAddress のメソッド
名前を取得します。
getPickArea() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
ピッキングエリアを取得します。
getPickgArea() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
簡易倉庫管理のピッキングエリアを取得します。
getPlRefMat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
梱包方法が同じ品目の参照品目を取得します。
getPlTiFnce() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
計画タイムフェンスを取得します。
getPlacement() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
在庫受入に対する保管域タイプ検索区分を取得します。
getPlanBasic() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト基準日付計画方法を取得します。
getPlanDel() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
予定納入日数を取得します。
getPlanFcst() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト予測日付の計画方法を取得します。
getPlanProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
計画プロファイルを取得します。
getPlanSchedType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程行タイプ EDIを取得します。
getPlanSchedType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPlanStrgp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
計画方針グループを取得します。
getPlanlistcnt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
グループカウンタを取得します。
getPlanlistgrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
タスクリストグループのキーを取得します。
getPlannedCost() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画原価を取得します。
getPlanningData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目マスタ/製品グループの変更伝票構造を取得します。
getPlanningDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
品目マスタ/製品グループの変更伝票構造が既に存在するかチェックします。
getPlanningDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目マスタ/製品グループの変更伝票構造を取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
プラントを取得します。
getPlantData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目データ (プラントレベル)を取得します。
getPlantDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
品目データ (プラントレベル)が既に存在するかチェックします。
getPlantDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目データ (プラントレベル)を取得します。
getPlantHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のメソッド
対象プラント 終了を取得します。
getPlantLow() - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のメソッド
対象プラント 開始を取得します。
getPlantRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
プラントの範囲を取得します。
getPlantSelectionList() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
プラントの選択オプション一覧を取得します｡
getPldlvshdin() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷計画に関する指示を取得します。
getPldlvshdin() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPldlvstyp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
MRP: 出荷計画タイプを取得します。
getPldlvstyp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPlnClose() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
計画終了日付を取得します。
getPlnCompletion() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
計画完了日を取得します。
getPlnLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: 計画梱包明細行を取得します。
getPlnPckg() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
パッケージ番号供給元一覧を取得します。
getPlnRelease() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
計画リリース日付を取得します。
getPlndDelry() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予定納入時間 (単位: 日)を取得します。
getPlndDelry() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
予定納入時間 (単位: 日)を取得します。
getPlndPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定計画原価を取得します。
getPlndprdate1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定原価 1 の有効開始日を取得します。
getPlndprdate2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定原価 2 の有効開始日を取得します。
getPlndprdate3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定原価 3 の有効開始日を取得します。
getPlndprice1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定計画原価 1を取得します。
getPlndprice2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定計画原価 2を取得します。
getPlndprice3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定計画原価 3を取得します。
getPlngCycle() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
計画サイクルを取得します。
getPlngMatl() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
計画品目を取得します。
getPlngMatlExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
項目 PLNG_MATL の品目コード (長) (今後のリリースで開発)を取得します。
getPlngMatlGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
項目 PLNG_MATL の外部 GUID (今後のリリースで開発)を取得します。
getPlngMatlVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
項目 PLNG_MATL のバージョン番号 (今後のリリースで開発)を取得します。
getPlngPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
計画プラントを取得します。
getPlordCtrl() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
アクション管理: 計画手配処理を取得します。
getPlugin() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
プラグインIDを取得します。
getPlugin(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータプラグインを取得します。
getPluginClass() - interface jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo のメソッド
カレンダーデータプラグインクラス名を取得します。
getPluginId() - interface jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo のメソッド
カレンダーデータプラグインIDを取得します。
getPluginIds() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータプラグインIDの一覧を取得します。
getPluginMethod() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
プラグイン関数を取得します。
getPmnttrms() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
支払条件キーを取得します。
getPmnttrms() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
支払条件キーを取得します｡
getPmnttrms() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
支払条件キーを取得します。
getPmnttrms() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPmnttrms() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
支払条件キーを取得します。
getPmnttrms() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPmtgarPro() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
支払保証決定表を取得します。
getPmtgarPro() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPmtgarPro() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
支払保証決定表を取得します。
getPmtgarPro() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoBox() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
私書箱を取得します。
getPoBox() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
私書箱を取得します。
getPoBox() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱を取得します。
getPoBox() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
私書箱を取得します。
getPoBoxCit() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
私書箱住所を取得します。
getPoBoxCit() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
私書箱住所を取得します。
getPoBoxCit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱住所を取得します。
getPoBoxReg() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱の地域 (国、都道府県、地域、...)を取得します。
getPoCtryiso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
ISO 国コードを取得します。
getPoDatS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先の出荷先発注日付を取得します。
getPoDatS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoDatS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先の出荷先発注日付を取得します。
getPoDatS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入日程の購買発注日付を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
購買伝票の明細番号を取得します。
getPoItmNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
元となる購買発注の明細番号を取得します。
getPoItmNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoItmNo() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
元となる購買発注の明細番号を取得します。
getPoMethS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先の出荷先発注タイプを取得します。
getPoMethS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoMethS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先の出荷先発注タイプを取得します。
getPoMethS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoMethod() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先発注タイプを取得します。
getPoMethod() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoMethod() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先発注タイプを取得します。
getPoMethod() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買伝票を取得します｡
getPoNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買伝票番号を取得します。
getPoNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
購買伝票番号を取得します｡
getPoNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
購買伝票番号を取得します。
getPoNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
購買伝票番号を取得します。
getPoNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
購買発注番号を取得します。
getPoNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
購買発注番号を取得します。
getPoPrQnt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
数量 (購買発注価格単位)を取得します。
getPoPrQnt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
数量 (購買発注価格単位)を取得します。
getPoPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
価格採用区分を取得します。
getPoRelCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
承認コードを取得します。
getPoRelInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
承認区分: 購買伝票を取得します。
getPoSupplem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先発注番号補足を取得します。
getPoSupplem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
発注単位を取得します。
getPoUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
発注単位を取得します。
getPoUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
ISOコードによる発注単位を取得します。
getPoUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードによる発注単位を取得します。
getPoWONo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
フラグ: 郵便私書箱 (番号なし)を取得します。
getPoboxCtry() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱の国指定を取得します。
getPobxCty() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
私書箱住所を取得します。
getPobxCty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
私書箱住所を取得します。
getPobxPcd() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
私書箱番号を取得します。
getPobxPcd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
私書箱番号を取得します。
getPointUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ポイント単位を取得します。
getPointUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ポイント単位の ISO コードを取得します。
getPoints() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
リベートポイント数を取得します。
getPoitmNoS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoitmNoS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
元となる購買発注の明細番号を取得します。
getPoitmNoS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoolName() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
プール名称を取得します。
getPoolName() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 プール名称を取得します｡
getPoolSize() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
プール内のコネクション数を取得します。
getPoolSize() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 プール内のコネクション数を取得します｡
getPoolnumber() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
LIFO 評価でのプール番号を取得します。
getPoolnumber() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData のメソッド
LIFO 評価でのプール番号を取得します。
getPort() - class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor のメソッド
ポートを返します。
getPort() - class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor のメソッド
推奨されていません。 ポートを返します。
getPortlet(String, String) - class jp.co.intra_mart.foundation.portal.portlet.PortletManager のメソッド
すでに登録済のポートレット情報を取得します。
getPortlet(String) - class jp.co.intra_mart.foundation.portal.portlet.PortletMapping のメソッド
指定されたページ種別に対応するポートレットモデルのインスタンスを取得します。
getPortletCode() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
ポートレットコードを取得します。
getPortletName() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
ポートレット名を取得します。
getPortlets() - class jp.co.intra_mart.foundation.portal.portlet.PortletManager のメソッド
すでに登録されているポートレット情報の一覧を取得します。
getPosex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
外部明細番号を取得します。
getPosex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
外部明細番号を取得します。
getPost(int) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

getPostCd() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel のメソッド
役職CDを取得します。
getPostCd() - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel のメソッド
役職CDを取得します。
getPostCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
役職CDを取得します。
getPostCode(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
役職CDを取得します。
getPostCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable のメソッド
役職CDを取得します。
getPostCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
役職コードを取得します。
getPostCode() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
役職コードを取得します。
getPostCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
役職CDを取得します。
getPostCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
役職CDを取得します。
getPostCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel のメソッド
役職CDを取得します。
getPostCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職コードを取得します。
getPostCode() - class jp.co.intra_mart.foundation.security.PostInfo のメソッド
役職コードを取得します。
getPostDate() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンの転記日付を取得します。
getPostDate() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
バージョンの転記日付を取得します。
getPostEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getPostEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getPostEventTriggerInfos(String, String) - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getPostEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getPostEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getPostName() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
役職名を取得します。
getPostlCod1() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村の郵便番号を取得します。
getPostlCod1() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村の郵便番号を取得します。
getPostlCod1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村の郵便番号を取得します。
getPostlCod2() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
私書箱郵便番号を取得します。
getPostlCod2() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
私書箱郵便番号を取得します。
getPostlCod2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱郵便番号を取得します。
getPostlCod3() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
会社郵便番号 (大規模なユーザ用)を取得します。
getPostlCod3() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
会社郵便番号 (大規模なユーザ用)を取得します。
getPostlCod3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
会社郵便番号 (大規模なユーザ用)を取得します。
getPostlCode() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
郵便番号を取得します。
getPostlCode() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
郵便番号を取得します。
getPostlCode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
郵便番号を取得します。
getPosts() - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

getPostsInCompany(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
会社に登録済の役職をすべて取得します。
getPostsInCompany(String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
会社に登録済の役職をすべて取得します。
getPostsInCompany(String, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
会社に登録済の役職をすべて取得します。
getPostsInCompany(String, Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
会社に登録済の役職をすべて取得します。
getPostsOfUser(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
ユーザに設定された役職をすべて取得します。
getPostsOfUser(String, String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
ユーザに設定された役職をすべて取得します。
getPostsOfUser(String, String, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
ユーザに設定された役職をすべて取得します。
getPostsOfUser(String, String, Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
ユーザに設定された役職をすべて取得します。
getPpSearch() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
品目提案検索条件を取得します。
getPpSearch() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPpcPlCal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
PPC 計画カレンダを取得します。
getPrClosed() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買依頼処理済を取得します。
getPrCtrlPp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期間の原価管理区分を取得します。
getPrCtrlPy() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度の原価管理区分を取得します。
getPrIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
レコード番号を取得します｡
getPrRefMat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
価格設定参照品目を取得します。
getPrRefMat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
価格設定参照品目を取得します。
getPrRefMat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格設定参照品目を取得します。
getPrRefMat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPrRefMatExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を取得します。
getPrRefMatGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を取得します。
getPrRefMatVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を取得します。
getPrUname() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
ユーザ名を取得します。
getPrUnitPp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期価格単位を取得します。
getPrUnitPy() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度価格単位を取得します。
getPrcGroup1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 1を取得します。
getPrcGroup1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPrcGroup2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 2を取得します。
getPrcGroup2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPrcGroup3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 3を取得します。
getPrcGroup3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPrcGroup4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 4を取得します。
getPrcGroup4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPrcGroup5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 5を取得します。
getPrcGroup5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPrcStatH() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
伝票の全処理ステータスを取得します。
getPreVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
製造元/販売元を取得します。
getPrefStatFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 特恵関税 - 輸出/輸入を取得します。
getPreqItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買依頼の明細番号を取得します。
getPreqItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買依頼の明細番号を取得します。
getPreqName() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買依頼者名/要求者名を取得します。
getPreqNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買依頼番号を取得します。
getPreqNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買依頼番号を取得します。
getPrevPlanPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法基準評価額: レベル 2を取得します。
getPrice() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
価格を取得します。
getPriceChg() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
入力シートの価格変更を取得します。
getPriceChg() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力シートの価格変更を取得します。
getPriceChg() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
入力シートの価格変更を取得します。
getPriceCtrl() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
原価管理区分を取得します。
getPriceDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
価格設定日を取得します。
getPriceDate() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
価格設定/外貨換算の実行日付を取得します。
getPriceDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格設定/外貨換算の実行日付を取得します。
getPriceDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPriceDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格設定/外貨換算の実行日付を取得します。
getPriceDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPriceGrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格グループ (得意先)を取得します。
getPriceGrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPriceGrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格グループ (得意先)を取得します。
getPriceGrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPriceList() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格表タイプを取得します。
getPriceList() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPriceList() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格表タイプを取得します。
getPriceList() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPriceUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
価格単位を取得します。
getPriceUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
価格単位を取得します。
getPriceUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
価格単位を取得します。
getPriceUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
価格単位を取得します。
getPricedate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
価格設定日カテゴリ (価格設定日管理)を取得します。
getPricing() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
価格設定タイプを取得します。
getPrimaryComparator() - interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator のメソッド
１番目コンパレータを取得します。
getPrimaryComparator() - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator のメソッド
第１コンパレータを返します。
getPrimaryComparator() - class jp.co.intra_mart.foundation.page.NodeTypeComparator のメソッド
第１コンパレータを取得します。
getPrimaryComparator() - interface jp.co.intra_mart.foundation.utility.DualComparator のメソッド
推奨されていません。 １番目コンパレータを取得します。
getPrimaryComparator() - class jp.co.intra_mart.foundation.utility.MultiComparator のメソッド
推奨されていません。 第１コンパレータを返します。
getPrimaryKeyMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable のメソッド
拡張基本テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。
getPrimaryKeyMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable のメソッド
拡張国際化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。
getPrimaryKeyMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable のメソッド
拡張期間国際化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。
getPrimaryKeyMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable のメソッド
拡張期間化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。
getPrimaryKeys() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティのプライマリキーとなる属性をすべて取得します。
getPrintStream() - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
メッセージを出力する出力ストリームを返します。
getPrintStream() - class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の static メソッド
メッセージを出力する出力ストリームを返します。
getPriority() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
優先度を取得します。
getPriority() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
優先度を取得します。
getPriority() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
優先度を取得します。
getPrivAddr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
自宅住所を取得します。
getPrivateGroup(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
登録済のプライベートグループを取得します。
getPrivateGroupCode() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
グループコードを取得します。
getPrivateGroupCode() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループコードを取得します。
getPrivateGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
グループコードを取得します。
getPrivateGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループコードを取得します。
getPrivateGroupManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager の static メソッド
PrivateGroupManagerを取得します。
getPrivateGroups(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
指定されたユーザが持つプライベートグループをすべて取得します。
getPrntPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
価格印刷を取得します。
getProcRule() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
調達規則を取得します。
getProcTime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
処理時間を取得します。
getProcType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
調達タイプを取得します。
getProcedure() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
決定表 (価格設定/出力管理/勘定設定/原価計算など)を取得します。
getProcessingGroup() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
処理グループを取得します。
getProcureUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
保管容量消費の数量単位を取得します。
getProcureUnIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードでの保管容量消費の数量単位を取得します。
getProdAlloc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製品割当決定手順を取得します。
getProdAtt1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
ID: 製品属性 1を取得します。
getProdAtt10() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 10 用 IDを取得します。
getProdAtt2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 2 用 IDを取得します。
getProdAtt3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 3 用 IDを取得します。
getProdAtt4() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 4 用 IDを取得します。
getProdAtt5() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 5 用 IDを取得します。
getProdAtt6() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 6 の IDを取得します。
getProdAtt7() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 7 用 IDを取得します。
getProdAtt8() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 8 用 IDを取得します。
getProdAtt9() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 9を取得します。
getProdCompositionOnPackaging() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: 梱包材にプリントされた生産構造を取得します。
getProdConvType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
生産値の変換タイプを取得します。
getProdDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
ロット製造日付を取得します。
getProdDate() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
ロット製造日付を取得します。
getProdHier() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目階層を取得します。
getProdHier() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目階層を取得します。
getProdHier() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目階層を取得します。
getProdHiera() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目階層を取得します。
getProdHiera() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getProdMemo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造/検査メモを取得します。
getProdUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造単位を取得します。
getProdUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造単位 (ISO コード)を取得します。
getProdcat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
製品カタログ番号を取得します。
getProdcat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getProdcomNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
生産統計: 貿易における PRODCOM コードを取得します。
getProdprof() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造計画プロファイルを取得します。
getProduct() - class jp.co.intra_mart.foundation.security.license.LicenseManager の static メソッド
システム情報を取得します。
getProductModelCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
製品型番を取得します。
getProductModelCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
製品型番を取得します。
getProductionResourceToolData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目マスタの生産資源/治工具 (PRT) 項目を取得します。
getProductionScheduler() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造計画担当を取得します。
getProdverscs() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算を行う製造バージョンを取得します。
getProfitCentList() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタ一覧を取得します｡
getProfitCenterList() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタ一覧を取得します。
getProfitCenterList() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList のメソッド
利益センタ一覧を取得します｡
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
利益センタを取得します｡
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getProfitSegmNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
収益性セグメント番号 (CO-PA)を取得します。
getProfitSegmNo() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
収益性セグメント番号 (CO-PA)を取得します。
getProfitSegmNo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
収益性セグメント番号 (CO-PA)を取得します。
getProfitSegmentList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
入出庫予定一覧を取得します｡
getProgramLanguage() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行プログラム言語を取得します。
getProgramLanguage() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行プログラム言語を取得します。
getProgramPath() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行プログラムパスを取得します。
getProgramPath() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行プログラムパスを取得します。
getProjType() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
プロジェクトタイプを取得します。
getProjectCurrency() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
WBS 通貨(プロジェクト定義)を取得します。
getProjectCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ISO 通貨コードを取得します。
getProjectDefinition() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
プロジェクト定義を取得します。
getProjectDefinition() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
プロジェクト定義を取得します。
getProjectDefinition() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
プロジェクト定義を取得します。
getProjectDefinition() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト定義を取得します。
getProjectDefinition() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
プロジェクト定義を識別するキーを取得します。
getProjectDefinition() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
プロジェクト定義を識別するキーを取得します。
getProjectDefinitionInfo() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
プロジェクトについての詳細情報を取得します。
getProjectDefinitionInfo() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
プロジェクトについての詳細情報を取得します。
getProjectProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクトプロファイルを取得します。
getProjectStock() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト在庫を取得します。
getProjectSummarization() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
区分: プロジェクト集計用に活動を考慮を取得します。
getPromotion() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
プロモーションを取得します。
getPromotion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPromotion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
プロモーションを取得します。
getPromotion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getProperties(String) - class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties のメソッド
指定のキーにマップされた値のリストを返します。
getProperties() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張モデルに含まれるプロパティをすべて取得します。
getProperties() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
モデルに含まれるプロパティをすべて取得します。
getProperties() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
JavaMailのSMTPセッションに渡す属性を初期化します。
getProperties() - class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile のメソッド
プロパティを取得します｡
getProperties(String) - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
インストール情報を取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor のメソッド
プロパティを取得します。
getProperty(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapAuthInfoBundle の static メソッド
引数で指定されたプロパティの値を返却します。
getProperty(String, String) - class jp.co.intra_mart.foundation.sap.common.auth.SapAuthInfoBundle の static メソッド
引数で指定されたプロパティの値を返却します。
getProperty() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティファイル情報を取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.scenario.VariableScope のメソッド
プロパティ値を取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンのプロパティ情報を取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
インストール情報を取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.service.provider.Environment のメソッド
指定されたキーによって示されるシステムプロパティを取得します。
getProperty(String, String) - interface jp.co.intra_mart.foundation.service.provider.Environment のメソッド
指定されたキーによって示されるシステムプロパティを取得します。
getPropertyDescriptor(String) - class jp.co.intra_mart.foundation.sap.common.util.PropertyDescriptorBox の static メソッド
引数JavaBeansクラス名からPropertyDescriptor[]を取得します。
getPropertyDescriptor(Object) - class jp.co.intra_mart.foundation.sap.common.util.PropertyDescriptorBox の static メソッド
引数JavaBeansオブジェクトのPropertyDescriptor[]を取得します。
getPropertyDescriptors() - class jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo のメソッド
PropertyDescriptorを取得します。
getPropertyDescriptors() - class jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo のメソッド
PropertyDescriptorを取得します。
getPropertyDescriptors() - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo のメソッド
PropertyDescriptorを取得します。
getPropertyDescriptors() - class jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo のメソッド
PropertyDescriptorを取得します。
getPropertyDescriptors() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo のメソッド
PropertyDescriptorを取得します。
getPropertyDescriptors() - class jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo のメソッド
PropertyDescriptorを取得します。
getPropertyHandler(String) - class jp.co.intra_mart.framework.system.property.PropertyManager のメソッド
キーで指定されたプロパティハンドラを取得します。
getPropertyHandlerName(String) - class jp.co.intra_mart.framework.system.property.DefaultPropertyManager のメソッド
キーで指定されたプロパティハンドラのクラス名を取得します。
getPropertyHandlerName(String) - class jp.co.intra_mart.framework.system.property.PropertyConfigModel のメソッド
指定されたキーのプロパティハンドラ名を取得します。
getPropertyHandlerName(String) - class jp.co.intra_mart.framework.system.property.PropertyManager のメソッド
キーで指定されたプロパティハンドラのクラス名を取得します。
getPropertyHandlerName(String) - class jp.co.intra_mart.framework.system.property.XmlPropertyManager のメソッド
キーで指定されたプロパティハンドラのクラス名を取得します。
getPropertyHandlerParams(String) - class jp.co.intra_mart.framework.system.property.DefaultPropertyManager のメソッド
キーで指定されたプロパティハンドラの初期化データを取得します。
getPropertyHandlerParams(String) - class jp.co.intra_mart.framework.system.property.PropertyManager のメソッド
キーで指定されたプロパティハンドラの初期化データを取得します。
getPropertyHandlerParams(String) - class jp.co.intra_mart.framework.system.property.XmlPropertyManager のメソッド
キーで指定されたプロパティハンドラの初期化データを取得します。
getPropertyKeyPart() - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のメソッド
プロパティのキーを取得します｡
getPropertyKeys() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンのプロパティ情報のキー一覧を取得します。
getPropertyManager() - class jp.co.intra_mart.framework.system.property.PropertyManager の static メソッド
プロパティマネージャを取得します。
getPropertyName() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティファイル名を取得します。
getPropertyParams(String) - class jp.co.intra_mart.framework.system.property.PropertyConfigModel のメソッド
指定されたキーのプロパティのパラメータを取得します。
getPropertyStreamAsClientType(Locale) - interface jp.co.intra_mart.foundation.security.SystemSourceProvider のメソッド
プロパティファイル(クライアントタイプ)の内容取得。
getPropertyStreamAsColor(Locale) - interface jp.co.intra_mart.foundation.security.SystemSourceProvider のメソッド
プロパティファイル(カラーパターン)の内容取得。
getPropertyStreamAsColorProperty(String, Locale) - interface jp.co.intra_mart.foundation.security.SystemSourceProvider のメソッド
プロパティファイル(カラーパターン)の内容取得。
getPropertyStreamAsLocale(Locale) - interface jp.co.intra_mart.foundation.security.SystemSourceProvider のメソッド
プロパティファイル(ロケール)の内容取得。
getPropertyValue() - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のメソッド
プロパティの値を取得します｡
getProvider() - class jp.co.intra_mart.framework.base.data.container.factory.DataContainerFactory のメソッド
プロバイダを返します。
getProvider() - class jp.co.intra_mart.framework.base.event.container.factory.EventContainerFactory のメソッド
プロバイダを返します。
getProvider() - class jp.co.intra_mart.framework.base.service.container.factory.ServiceContainerFactory のメソッド
プロバイダを返します。
getProvider() - interface jp.co.intra_mart.framework.system.container.factory.IMContainerFactory のメソッド

getProxyHost() - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet のメソッド
プロキシホスト名を取得します。
getProxyPort() - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet のメソッド
プロキシポート番号を取得します。
getPrtData(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
品目マスタの生産資源/治工具 (PRT) 項目が既に存在するかチェックします。
getPrtDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目マスタの生産資源/治工具 (PRT) 項目を取得します。
getPrtUsage() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具用途を取得します。
getPrtUsage() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具用途を取得します。
getPrtView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
生産資源/治工具 (PRT) ビューを取得します。
getPrtView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
生産資源/治工具 (PRT) ビューを取得します。
getPsConfMat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
選定可能品目を取得します。
getPstngDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
伝票の転記日付を取得します。
getPstngDateRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
登録日付の範囲を取得します。
getPublicGroup(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループを取得します。
getPublicGroup(int) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

getPublicGroupAttach(String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
ユーザのパブリックグループへの所属情報を取得します。
getPublicGroupAttachTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
指定された期間に対する期間化情報を取得します。
getPublicGroupAttachTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
指定された日時に対する期間化情報を取得します。
getPublicGroupCategoryTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
指定された期間に対する期間化情報を取得します。
getPublicGroupCategoryTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
指定された日時に対する期間化情報を取得します。
getPublicGroupCd() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel のメソッド
グルーピングCDを取得します。
getPublicGroupCd() - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel のメソッド
グルーピングCDを取得します。
getPublicGroupCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup のメソッド
グループコードを取得します。
getPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct のメソッド
グループコードを取得します。
getPublicGroupCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
グループコードを取得します。
getPublicGroupCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
グループコードを取得します。
getPublicGroupCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループコードを取得します。
getPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel のメソッド
グループコードを取得します。
getPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
グループコードを取得します。
getPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel のメソッド
グループコードを取得します。
getPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループコードを取得します。
getPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
グループコードを取得します。
getPublicGroupManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager の static メソッド
PublicGroupManagerを取得します。
getPublicGroupSetCd() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel のメソッド
グループセットCDを取得します。
getPublicGroupSetCd() - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel のメソッド
グループセットCDを取得します。
getPublicGroupSetCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
指定された期間に対する期間化情報を取得します。
getPublicGroupSetTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
指定された日時に対する期間化情報を取得します。
getPublicGroupSetTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getPublicGroupStructs(String, String, Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループの階層構造を取得します。
getPublicGroupTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
指定された期間に対する期間化情報を取得します。
getPublicGroupTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
指定された日時に対する期間化情報を取得します。
getPublicGroupTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getPublicGroups(Deal) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager のメソッド
取扱情報を保有するアクセス権をもつパブリックグループを返します。
getPublicGroups() - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

getPurGroup() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
購買グループを取得します。
getPurGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買グループを取得します｡
getPurGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
購買グループを取得します。
getPurMat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
品目コードを取得します。
getPurMatExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
項目 PURMAT の品目コード (長) (今後のリリースで開発)を取得します。
getPurMatGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
項目 PURMAT の外部 GUID (今後のリリースで開発)を取得します。
getPurMatVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
項目 PURMAT のバージョン番号 (今後のリリースで開発)を取得します。
getPurStatus() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
プラント共通品目ステータスを取得します。
getPurStatus() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラント特有品目ステータスを取得します。
getPurValkey() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
購買許容値キーを取得します。
getPurchDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先発注日付を取得します。
getPurchDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPurchDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先発注日付を取得します。
getPurchDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPurchNo() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
得意先発注番号を取得します。
getPurchNo() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
得意先発注番号を取得します。
getPurchNoC() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先発注番号を取得します。
getPurchNoC() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPurchNoC() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先発注番号を取得します。
getPurchNoC() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPurchNoC() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出荷先発注番号を取得します。
getPurchNoS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先の得意先発注番号を取得します。
getPurchNoS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPurchNoS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先の得意先発注番号を取得します。
getPurchNoS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPurchOrd() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
出荷先発注番号を取得します。
getPurchOrg() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
購買組織を取得します。
getPurchOrg() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買組織を取得します｡
getPurchView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
購買管理ビューを取得します。
getPurchaseAccountList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
勘定設定一覧を取得します｡
getPurchaseGetItemSrel() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
承認対象一覧情報を取得します｡
getPurchaseHeadersList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
伝票ヘッダ一覧を取得します｡
getPurchaseHeadersList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
伝票ヘッダ一覧を取得します。
getPurchaseItemPostList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
明細一覧を取得します｡
getPurchaseItemsList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
伝票明細一覧を取得します｡
getPurchaseItemsList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
伝票明細一覧を取得します。
getPurchaseOrder() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
得意先発注番号を取得します。
getPurchaseOrderNumber() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
得意先発注番号1を取得します。
getPurchaseScheduleList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
納入日程一覧を取得します｡
getPurchaseUnitPrice() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
仕入単価を取得します。
getPurchaseUnitPrice(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
仕入単価を取得します。
getPurchaseUnitPrice() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable のメソッド
仕入単価を取得します。
getPurchaseUnitPrice() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
仕入単価を取得します。
getPurchaseUnitPrice(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
仕入単価を取得します。
getPurchaseUnitPrice() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
仕入単価を取得します。
getPurchaseView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
購買管理ビューを取得します。
getPurchaseorder() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
購買発注番号を取得します。
getPushDistrib() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: プッシュ配賦を取得します。
getPvalidfrom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
プラント共通品目のステータス有効開始日付を取得します。
getPvalidfrom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラント品目ステータス有効期間開始日を取得します。
getPymtMeth() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
支払方法を取得します。
getPymtMeth() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPymtMeth() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
支払方法を取得します。
getPymtMeth() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getQmAuthgrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
QM における活動の品目権限グループを取得します。
getQmProcmnt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
調達における品質管理有効を取得します。
getQmRgmts() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
仕入先の必須 QM システムを取得します。
getQtValidF() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
見積/引合有効開始日を取得します。
getQtValidF() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getQtValidT() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
見積の有効終了日を取得します。
getQtValidT() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getQtyGrGi() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
数量: 印刷予定入出庫票数を取得します。
getQtyStruct() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
数量構成により原価計算を行う品目を取得します。
getQualDik() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
無償納入による割引対象品目を取得します。
getQualInsp() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
在庫タイプを取得します。
getQualityView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品質管理ビューを取得します。
getQualityView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
品質管理ビューを取得します。
getQuantity() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
+/- 記号あり/なし数量を取得します。
getQuantity() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
+/- 記号あり/なし数量を取得します。
getQuantity() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
数量を取得します。
getQuantity() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買発注数量を取得します。
getQuantity() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
計画数量を取得します。
getQuantity() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
数量を取得します。
getQuantity() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
インスタンス数量を取得します。
getQuantityUnit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
数量単位を取得します。
getQuery() - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
引数情報を取得します。
getQuery() - class jp.co.intra_mart.foundation.http.SessionQuery のメソッド
推奨されていません。 代替えメソッドはありません。
getQueryName() - class jp.co.intra_mart.foundation.http.SessionQuery のメソッド
推奨されていません。 代替えメソッドはありません。
getQueryString() - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
設定されているパラメータ情報からクエリ文字列を作成して返します。
getQueryValue() - class jp.co.intra_mart.foundation.http.SessionQuery のメソッド
推奨されていません。 GenericURLBuilder.createFilePath(String) に置き替えられました。
getQuestion() - class jp.co.intra_mart.foundation.navigator.EventHistoryInfo のメソッド
回答取得
getQuestion() - class jp.co.intra_mart.foundation.navigator.SaveEventHistoryInfo のメソッド
回答取得
getQuotDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
見積提出日を取得します｡
getQuotDead() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積提出期限を取得します。
getQuotation() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
見積番号を取得します｡
getQuotationCfgsBlobList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: BLOB 内部データ (SCE)を取得します。
getQuotationCfgsInstList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: インスタンスを取得します。
getQuotationCfgsPartOfList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: 部分設定を取得します。
getQuotationCfgsRefInstList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: 参照明細/インスタンスを取得します。
getQuotationCfgsRefList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: 参照データを取得します。
getQuotationCfgsValueList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: 特性値を取得します。
getQuotationCfgsVkList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: バリアント条件キーを取得します。
getQuotationConditionsInList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
条件を取得します。
getQuotationConditionsInXList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
受注における条件更新の通信項目を取得します。
getQuotationHeaderIn() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
伝票ヘッダデータを取得します。
getQuotationHeaderInX() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
伝票ヘッダチェックボックスを取得します。
getQuotationItemsInList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
明細データを取得します。
getQuotationItemsInXList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
明細データチェックボックスを取得します。
getQuotationKeysList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
参照キーの出力テーブルを取得します。
getQuotationPartnersList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
伝票取引先を取得します。
getQuotationSchedulesInList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
納入日程行データを取得します。
getQuotationSchedulesInXList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
納入日程行データチェックボックスを取得します。
getQuotationTextList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
テキストを取得します。
getQuotausage() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
供給量割当の使用を取得します。
getR3name() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing のメソッド
SAPシステム名称を取得します。
getR3name() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing のメソッド
SAPシステム名称を取得します。
getRPromo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
プロモーションを取得します。
getRateType() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算レートタイプを取得します。
getRateType() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
換算レートタイプを取得します。
getRateType() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
換算レートタイプを取得します。
getRcvgVend() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
未使用項目を取得します。
getReader() - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity のメソッド
推奨されていません。 MultipartFormData.Entity.getReader(String) に置き換えられました。
getReader(String) - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity のメソッド
データ部を Reader として取得します。
getReader() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
推奨されていません。 MultipartFormData.Entity.getReader(String) に置き換えられました。
getReader(String) - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
推奨されていません。 データ部を Reader として取得します。
getRealUserInfo() - class jp.co.intra_mart.framework.base.util.UserInfoWrapper のメソッド
このオブジェクトがラップしているUserInfoの実装を返します。
getRealUserInfo() - class jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedUserInfo のメソッド
このオブジェクトがラップしているUserInfoの実装を返します。
getReason() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
変更理由を取得します。
getReason() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
変更理由を取得します。
getReasonCancel() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
取消理由を取得します。
getReasonRej() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
見積および受注の拒否理由を取得します。
getReasonRej() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReasonRej() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
見積および受注の拒否理由を取得します。
getRebateGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
取引量リベートグループを取得します。
getRecInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
リカバリフラグを取得します。
getRecPoint() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
入荷ポイントを取得します。
getRecPoint() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRecPoint() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
入荷ポイントを取得します。
getRecPoint() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRecTime() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
登録時刻を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
レコード更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel のメソッド
最終更新日を取得します。
getRecordList() - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のメソッド
パースした結果のレコード一覧リストを返します。
getRecordNo() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
レコード番号を取得します｡
getRecordUserCd() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel のメソッド
最終更新者を取得します。
getRecordUserCd() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
最終更新者を取得します。
getRecordUserCd() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
レコード更新ユーザコードを取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel のメソッド
最終更新者を取得します。
getRecoveryInd() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
リカバリフラグを取得します。
getRecoveryInd() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
リカバリフラグを取得します。
getRef1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先/仕入先の内部参照コードを取得します。
getRef1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRef1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先/仕入先の内部参照コードを取得します。
getRef1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRef1S() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先文字を取得します。
getRef1S() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRef1S() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先文字を取得します。
getRef1S() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
決済の参照日付を取得します。
getRefDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
決済の参照日付を取得します。
getRefDate() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
決済の参照日付を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
参照伝票番号を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
参照伝票の伝票番号を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
参照伝票の伝票番号を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
参照伝票番号を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
参照伝票番号を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
参照伝票番号を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照伝票番号を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
参照伝票番号を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
参照伝票番号を取得します。
getRefDocCa() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
先行販売管理伝票の伝票カテゴリを取得します。
getRefDocCa() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
先行販売管理伝票の伝票カテゴリを取得します。
getRefDocCa() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefDocHigh() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
前伝票の終了伝票番号を取得します。
getRefDocIt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
参照伝票の明細番号を取得します。
getRefDocIt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
参照伝票の明細番号を取得します。
getRefDocIt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
参照明細番号を取得します。
getRefDocIt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefDocItem() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
参照明細番号を取得します。
getRefDocItem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
参照明細番号を取得します。
getRefDocL() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照伝票番号を取得します。
getRefDocL() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefDocLLong() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照伝票番号 (依存関係についてはテキスト (長) を参照)を取得します。
getRefDocLow() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
前伝票の開始伝票番号を取得します。
getRefDocNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
参照伝票番号を取得します。
getRefDocNoLong() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
参照伝票番号 (依存性についてはテキスト長参照)を取得します。
getRefDocRange() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
前伝票の範囲を取得します。
getRefDocYr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
参照伝票の会計年度を取得します。
getRefDocYr() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
参照伝票の会計年度を取得します。
getRefItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
参照伝票の明細を取得します。
getRefItem() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
参照明細番号を取得します。
getRefItem() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
参照明細番号を取得します。
getRefKeyNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
参照キーは変更できませんを取得します。
getRefKeyNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
参照キーは変更できませんを取得します。
getRefProc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照限定条件: 決定区分を取得します。
getRefProc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefQty() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
基本数量単位による参照数量を取得します。
getRefUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
品目マスタレコードの数量単位初期値を取得します。
getRef_1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
得意先/仕入先の内部参照コードを取得します｡
getRefdocCat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
先行販売管理伝票の伝票カテゴリを取得します。
getRefdocCat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefdoctype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照オブジェクトの伝票タイプを取得します。
getRefereRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.ActivationKey のメソッド
ソースエンティティから有効開始日時を持つエンティティまでのリレーションシップを取得します。
getRefereRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey のメソッド
ソースエンティティから有効終了日時を持つエンティティまでのリレーションシップを取得します。
getRefereRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalKey のメソッド
ソースエンティティから国際化基準項目を持つエンティティまでのリレーションシップを取得します。
getRefereRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableKey のメソッド
ソースエンティティから期間化基準項目を持つエンティティまでのリレーションシップを取得します。
getReferedRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
このエンティティの属性を、国際化基準項目や期間化基準項目などを使用して参照している全てのリレーションシップを取得します。
getReference() - class jp.co.intra_mart.foundation.database.DbManager の static メソッド
推奨されていません。 DatabaseManager.getConnectIdsBySystem()を使用してください。
getReferencePoint() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
BOM 転送の参照ポイントを取得します。
getReflogsys() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
論理システムを取得します。
getReflogsys() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
論理システムを取得します。
getReflogsys() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReflogsys() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
論理システムを取得します。
getReflogsys() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
論理システムを取得します。
getReflogsys() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
論理システムを取得します。
getRefmatcons() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費参照品目を取得します。
getRefmatconsExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 REFMATCONS の品目コード (長) (今後のリリースで開発)を取得します。
getRefmatconsGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 REFMATCONS の外部 GUID (今後のリリースで開発)を取得します。
getRefmatconsVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 REFMATCONS のバージョン番号 (今後のリリースで開発)を取得します。
getRefobject() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
オブジェクト名を取得します。
getRefobjkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
オブジェクトキーを取得します。
getRefobjkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
オブジェクトキーを取得します。
getRefobjkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
オブジェクトキーを取得します。
getRefobjkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefobjkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
オブジェクトキーを取得します。
getRefobjkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
オブジェクトキーを取得します。
getRefobjkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
オブジェクトキーを取得します。
getRefobjkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
オブジェクトキーを取得します。
getRefobjtyp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
オブジェクトタイプを取得します。
getRefobjtype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
オブジェクトタイプを取得します。
getRefobjtype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
オブジェクトタイプを取得します。
getRefobjtype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
オブジェクトタイプを取得します。
getRefobjtype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefobjtype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
オブジェクトタイプを取得します。
getRefobjtype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
オブジェクトタイプを取得します。
getRefobjtype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
オブジェクトタイプを取得します。
getRefpltcons() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費参照プラントを取得します。
getRegiogroup() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地域構造グループ化を取得します。
getRegiogroup() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地域構造グループ化を取得します。
getRegiogroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地域構造グループ化を取得します。
getRegion() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
地域 (都道府県)を取得します。
getRegion() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地域 (都道府県)を取得します。
getRegion() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
地域 (都道府県)を取得します。
getRegion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地域 (都道府県)を取得します。
getRegion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
地域 (都道府県)を取得します。
getRegionorig() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
品目の原産地 (非特恵対象地区の原産)を取得します。
getRegionorig() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目の原産地 (非特恵対象地区の原産)を取得します。
getRegisteredAccountLicenses() - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
ログイングループにライセンス登録されているすべてのユーザIDを返します。
getRegisteredApplicationLicensesToAccount(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
アカウントに登録されているアプリケーションライセンスの一覧を取得します。
getRejReason() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積および受注の拒否理由を取得します。
getRel() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
relを取得します。
getRelCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
承認コードを取得します。
getRelCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
承認コードを取得します。
getRelGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
承認グループを取得します。
getRelGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
承認グループを取得します。
getRelGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
承認グループを取得します。
getRelInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
承認区分: 購買伝票を取得します。
getRelIndicatorNew() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
返却規承認区分を取得します。
getRelStatus() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
承認状況を取得します｡
getRelStatusNew() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
返却承認状況を取得します。
getRelStrat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
承認方針を取得します。
getRelType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
承認タイプを取得します。
getRelType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義しているリレーションシップの一覧を取得します。
getReleaseDate() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
承認日を取得します。
getReleaseTime() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
承認時刻を取得します。
getReleasebyPur() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
承認購買担当者名を取得します。
getReleasedBy() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
承認者名を取得します。
getReleasedatePur() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買担当者承認日付を取得します。
getReleasetimePur() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買担当者承認時刻を取得します。
getReminder1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
第一回催促状/督促状の日数を取得します。
getReminder2() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
第二回催促状/督促状の日数を取得します。
getReminder3() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
第三回催促状/督促状の日数を取得します。
getRemoteAddr() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
リクエスト元のクライアントの IP(Internet Protocol) アドレスを取得する。
getRemoteHostAddress() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext のメソッド
イベント実行要求をしたクライアントのアドレスを返します。
getRemoteHostName() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext のメソッド
イベント実行要求をしたクライアントのホスト名を返します。
getReorderPt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
発注点を取得します。
getReorderPt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所 MRP に対する発注点を取得します。
getRepManuf() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 繰返生産許可を取得します。
getReplQty() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所 MRP に対する補充数量を取得します。
getReplacePt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
取替部品を取得します。
getReplenQty() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
補充数量を取得します。
getReplentime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
補充リードタイム合計 (稼動日数)を取得します。
getRepmanprof() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
繰返生産プロファイルを取得します。
getReporters() - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
セット内の要素についての反復子を返します。
getReporters() - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 セット内の要素についての反復子を返します。
getRepository() - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle の static メソッド
useCommonsFileuploadがtrueの場合、一時ファイルを作成するフォルダを取得します。
getReqBy() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
変更を依頼した従業員を取得します。
getReqBy() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
変更を依頼した従業員を取得します。
getReqByExt() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンの外部変更番号を取得します。
getReqByExt() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
バージョンの外部変更番号を取得します。
getReqDate() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
所要日付を取得します。
getReqDate() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
所要日付を取得します。
getReqDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程日付を取得します。
getReqDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReqDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
指定納期を取得します。
getReqDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
納入日程日付を取得します。
getReqDateH() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
指定納入期日を取得します。
getReqDateH() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReqDateH() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
指定納入期日を取得します。
getReqDlvBl() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
出荷ブロック中の納入日程行を取得します。
getReqDlvBl() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReqQty() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
利用可能在庫確認の所要量を取得します。
getReqQty() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
所要量を取得します。
getReqQty() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
累積受注数量 (販売単位)を取得します。
getReqQty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
販売単位による受注数量を取得します。
getReqQty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReqQty() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
累積受注数量 (販売単位)を取得します。
getReqQty() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
累積受注数量 (販売単位)を取得します。
getReqTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入時間を取得します。
getReqTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReqmtsTyp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
所要量タイプを取得します。
getReqmtsTyp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRequCompCode() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
会社コード要求を取得します。
getRequest() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
リクエストを返します。
getRequest() - class jp.co.intra_mart.foundation.database.DatabaseExport の static メソッド
推奨されていません。
getRequest() - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain のメソッド
チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのリクエストを 返します。
getRequest() - interface jp.co.intra_mart.framework.base.service.RequestInfo のメソッド
リクエストを取得します。
getRequest() - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
リクエストを取得します。
getRequest() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
リクエストを取得します。
getRequest() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
リクエストを取得します。
getRequest() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
リクエストを取得します。
getRequest() - class jp.co.intra_mart.jssp.net.GenericURLBuilder のメソッド
現在のリクエストを返します。
getRequestCctr() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
申請原価センタを取得します。
getRequestCctr() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請原価センタを取得します。
getRequestCctrControllingArea() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
依頼原価センタの管理領域を取得します。
getRequestCompCode() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
会社コード要求を取得します。
getRequestOrder() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請指図を取得します。
getRequestParameters() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper のメソッド
パラメータ情報を返します。
getRequestParameters() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter の static メソッド
現在のリクエストのパラメータを返します。
getRequestTime() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
イベントの実行を要求した時刻を返します。
getRequestURL() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent のメソッド
このコンテンツを取得するために使用した URL を返します。
getRequestedPageAttributeName() - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager のメソッド
リクエストされたページURLを保持するために使用する属性名を取得します。
getRequired() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
フォーカスの要求の有無を返します。
getResAnalKey() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
結果分析キーを取得します。
getResAnalKey() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
結果分析キーを取得します。
getResDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
用途指定予算の伝票番号を取得します。
getResItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
用途指定予算: 伝票明細を取得します。
getResItem() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫予定/従属所要量の明細番号を取得します。
getResItem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入出庫予定/従属所要量の明細番号を取得します。
getResType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
レコードタイプを取得します。
getResType() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
レコードタイプを取得します。
getResanalkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
結果分析キーを取得します。
getResanalkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReservNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫予定/従属所要量の番号を取得します。
getReservNo() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入出庫予定/従属所要量の番号を取得します。
getResource(String, String, String) - class jp.co.intra_mart.framework.base.data.DBConnector のメソッド
リソースを取得します。
getResource(String, String, String) - class jp.co.intra_mart.framework.base.data.DataConnector のメソッド
リソースを取得します。
getResource(String, String, String) - class jp.co.intra_mart.framework.base.data.IntramartDBConnector のメソッド
推奨されていません。 リソースを取得します。
getResource(String, String, String) - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector のメソッド
リソースを取得します。
getResource(String, String, String) - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector のメソッド
リソースを取得します。
getResource(String, String, String) - class jp.co.intra_mart.framework.base.data.SystemDBConnector のメソッド
リソースを取得します。
getResourceConnection(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
リソース参照名からコネクションオブジェクト取得を取得します。
getResourceParams(String) - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler のメソッド
リソースのパラメータを取得します。
getResourceParams(String) - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
リソースのパラメータを取得します。
getResourceParams(String) - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
リソースのパラメータを取得します。
getResourceParams(String) - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
リソースのパラメータを取得します。
getResourceParams(String) - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
リソースのパラメータを取得します。
getRespCostCenter() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
責任原価センタを取得します。
getRespCostCenter() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
責任原価センタを取得します。
getRespcctr() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
責任原価センタを取得します。
getResponse() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
レスポンスを返します。
getResponse() - class jp.co.intra_mart.foundation.database.DatabaseExport の static メソッド
推奨されていません。
getResponse() - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain のメソッド
チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのレスポンスを 返します。
getResponse() - interface jp.co.intra_mart.framework.base.service.RequestInfo のメソッド
レスポンスを取得します。
getResponse() - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
レスポンスを取得します。
getResponse() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
レスポンスを取得します。
getResponse() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
レスポンスを取得します。
getResponse() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
レスポンスを取得します。
getResponse() - class jp.co.intra_mart.jssp.net.GenericURLBuilder のメソッド
現在のレスポンスを返します。
getResponseCode() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
サーバからのHTTPレスポンスコードを返します。
getResponseCode() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
サーバからのHTTPレスポンスコードを返します。
getResponseMessage() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。
getResponseMessage() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。
getResponsibleNo() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
責任者番号 (プロジェクト責任者)を取得します。
getResponsibleNo() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
責任者番号 (プロジェクト責任者)を取得します。
getRespsblCctr() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
責任原価センタを取得します。
getRespsblCctrControllingArea() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
責任原価センタの管理領域を取得します。
getResult() - interface jp.co.intra_mart.framework.base.service.RequestInfo のメソッド
サービス処理結果を取得します。
getResult() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
サービス処理結果を取得します。
getResultPageItemInfos() - class jp.co.intra_mart.foundation.navigator.EventResultItemInfo のメソッド
結果ページ情報リスト取得
getResultPageItemInfos() - class jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo のメソッド
結果ページ情報リスト取得
getRetCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController のメソッド
リターン値、ABAP 命令後のリターン値を取得します。
getRetItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
返品明細を取得します。
getReturn() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
ＢＡＰＩ実行結果を取得します。
getReturnCodeTypes() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
BapiReturn のType情報を取得します。
getReturnList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
ＢＡＰＩ実行結果の一覧を取得します。
getReturnMessagesList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
リターンパラメータ BAPIRET2 の代替構造を取得します。
getRev() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
revを取得します。
getRevLev() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
改訂レベルを取得します。
getRevType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
収益承認カテゴリを取得します。
getRevType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRfqItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
見積依頼明細番号を取得します。
getRfqNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
見積依頼番号を取得します。
getRight() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を取得します。
getRlEstKey() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
不動産管理対象の内部キーを取得します。
getRlEstKey() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
不動産管理対象の内部キーを取得します。
getRlEstKey() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
不動産管理対象の内部キーを取得します。
getRnddlvQty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
丸め数量: 出荷を取得します。
getRnddlvQty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRole(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 RoleManager.exportData(String category, OutputStream outputStream)に置き換えられました。
getRole(int) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

getRole(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール情報を取得します。
getRoleData(String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
ロール情報を全件取得します。
getRoleData(String, String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
ロール情報を取得します。
getRoleData(String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
ロール情報を全件取得する。
getRoleData(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
ロール情報を取得する。
getRoleDataByCategory(String, String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
カテゴリからロール情報を取得します。
getRoleDataByCategory(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
カテゴリからロール情報を取得する。
getRoleId() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole のメソッド
ロールIDを取得します。
getRoleId() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel のメソッド
ロールIDを取得します。
getRoleId() - class jp.co.intra_mart.foundation.security.account.AccountRole のメソッド
ロールIDを取得します。
getRoleId() - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロールIDを取得します。
getRoleId() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel のメソッド
ロールCDを取得します。
getRoleId() - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel のメソッド
メニューIDを取得します。
getRoleId() - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel のメソッド
ロールCDを取得します。
getRoleId() - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
ロールIDを取得します。
getRoleId() - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel のメソッド
ロールIDを取得します。
getRoleIds(String, Date) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントに紐付く有効なロールIDをすべて取得します。
getRoleIds() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
すべてのロールIDを取得します。
getRoleName() - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロール名を取得します。
getRoleValidEndDate() - class jp.co.intra_mart.foundation.security.account.AccountRole のメソッド
ロール有効終了日を取得します。
getRoleValidStartDate() - class jp.co.intra_mart.foundation.security.account.AccountRole のメソッド
ロール有効開始日を取得します。
getRoles(Deal) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager のメソッド
取扱情報を保有するアクセス権をもつロールを返します。
getRoles() - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

getRoles() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
すべてのロール情報を取得します。
getRolesByCategory(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
カテゴリー検索によりロールを取得します。
getRolesByIds(String, String[]) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
指定されたロールIDのロール情報をすべて取得します。
getRolesByIds(String, String[]) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
指定されたロールIDのロール情報をすべて取得する。
getRolesByIds(String[]) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ログイングループ内で引数指定したロールIDのロール情報をすべて取得します。
getRoomNo() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
部屋/アパート番号を取得します。
getRoomNo() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
部屋/アパート番号を取得します。
getRoomNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
部屋/アパート番号を取得します。
getRootId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
選定におけるインスタンス番号を取得します。
getRotationDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算ビューを取得します。
getRoundProf() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
丸めプロファイルを取得します。
getRoundProf() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
丸めプロファイルを取得します。
getRoundQty() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
丸め数量を取得します。
getRoundUpRuleExpirationDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
有効期間期限日計算の丸め規則を取得します。
getRoundVal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
購買発注数量の丸め数量を取得します。
getRoundoffdi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
BAPI の通貨額 (小数点以下９桁)を取得します。
getRoute() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
輸送経路を取得します。
getRoute() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRoutesched() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
輸送経路計画を取得します。
getRow() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
行番号を取得します｡
getRow() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
パラメータの行を取得します。
getRssUrl() - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet のメソッド
URLを取得します。
getRunDay() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行日を取得します。
getRunDay() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行日を取得します。
getRunDayWeek() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行曜日を取得します。
getRunDayWeek() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行曜日を取得します。
getRunHour() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行時を取得します。
getRunHour() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行時を取得します。
getRunMinute() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行分を取得します。
getRunMinute() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行分を取得します。
getRunMonth() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行月を取得します。
getRunMonth() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行月を取得します。
getRunSecond() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行秒を取得します。
getRunSecond() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行秒を取得します。
getRunYear() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行年を取得します。
getRunYear() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行年を取得します。
getSMTPConnectionTimeout() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
SMTPサーバへのコネクションタイムアウト時間を取得します。
getSMTPPassword() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
SMTP認証のパスワードを取得します
getSMTPTimeout() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
SMTPサーバとの入出力タイムアウト時間を取得します。
getSMTPUser() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
SMTP認証のユーザを取得します
getSOrdItem() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
受注明細番号を取得します。
getSOrdItem() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
受注明細番号を取得します。
getSOrdItem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
受注明細番号を取得します。
getSProcInd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
特別処理区分を取得します。
getSProcInd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSProcInd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
特別処理区分を取得します。
getSProcInd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSUnitDlv() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷単位を取得します。
getSUnitIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
単位の ISO コードを取得します。
getSUnitIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
ISO コードによる販売単位を取得します。
getSUnitIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
ISO コードによる販売単位を取得します。
getSaIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
レコード番号を取得します｡
getSafetyStk() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
安全在庫を取得します。
getSafetytime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
安全時間 (稼動日数)を取得します。
getSaftyTId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
安全時間区分（安全リードタイムあり/なし)を取得します。
getSalStatus() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
流通チェーン間品目ステータスを取得します。
getSalStatus() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
販売ビューからの品目ステータスを取得します。
getSalesData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
販売データを取得します。
getSalesDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
販売データが既に存在するかチェックします。
getSalesDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
販売データを取得します。
getSalesDist() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売地域を取得します。
getSalesDist() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSalesDist() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売地域を取得します。
getSalesDist() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSalesDocDateInidicator() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
販売伝票の日付に関連するマイルストーンを取得します。
getSalesGrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
営業グループを取得します。
getSalesGrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSalesGrp() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
営業グループを取得します。
getSalesOff() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
営業所を取得します。
getSalesOff() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSalesOff() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
営業所を取得します。
getSalesOrd() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
受注伝票番号を取得します。
getSalesOrd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
受注伝票番号を取得します。
getSalesOrd() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
受注伝票番号を取得します。
getSalesOrdersList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
得意先受注テーブルを取得します。
getSalesOrg() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
販売組織を取得します。
getSalesOrg() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売組織を取得します。
getSalesOrg() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSalesOrg() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売組織を取得します。
getSalesOrganisationSelectionList() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
販売組織の選択オプション一覧を取得します｡
getSalesOrganization() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
販売組織を取得します。
getSalesPers() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
仕入先営業担当者を取得します｡
getSalesRelevant() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
この部品は販売に関連していますを取得します。
getSalesUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
販売単位を取得します。
getSalesUnit() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売単位を取得します。
getSalesUnit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売単位を取得します。
getSalesUnit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSalesUnit() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売単位を取得します。
getSalesUnit() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
販売単位を取得します。
getSalesUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
ISO コードによる販売単位を取得します。
getSalesUnitPrice() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
販売単価を取得します。
getSalesUnitPrice(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
販売単価を取得します。
getSalesUnitPrice() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable のメソッド
販売単価を取得します。
getSalesUnitPrice() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
販売単価を取得します。
getSalesUnitPrice(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
販売単価を取得します。
getSalesUnitPrice() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
販売単価を取得します。
getSalesView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
販売ビューを取得します。
getSalesView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
販売ビューを取得します。
getSalesdocument() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
販売伝票番号を取得します。
getSalesdocument() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
販売管理伝票番号を取得します。
getSalesdocument() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
生成された伝票の番号を取得します。
getSalesdocument() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のメソッド
販売管理伝票番号を取得します。
getSalesdocumentin() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
販売管理伝票番号を取得します。
getSalesdocumentin() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
見積伝票番号を取得します。
getSalesdocumentin() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
販売管理伝票番号を取得します。
getSalesorg() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売組織を取得します。
getSalesorgHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のメソッド
販売組織の範囲終了を取得します。
getSalesorgLow() - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のメソッド
販売組織の範囲開始を取得します。
getSalesorganisation() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
販売組織を取得します。
getSalqtyden() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売数量単位を SKU に換算するための分母 (除数)を取得します。
getSalqtyden() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSalqtynum() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売数量単位から基本数量単位への変換係数の分子を取得します。
getSalqtynum() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSapClient() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientManager の static メソッド
接続情報初期値を保持したSAPクライアントオブジェクトの取得を行います。
getSapClient(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientManager の static メソッド
引数にて受け取ったサーバータイプに紐付く接続情報初期値を保持した SAPクライアントオブジェクトを取得します。
getSaveDate() - class jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo のメソッド
保存日時取得
getSaveEventResultItemInfo(EventNavigatorManager, String, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
getSaveEventResultItemInfo(String, String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
getSaveEventResultItemInfo(EventNavigatorManager, String, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
getSaveEventResultItemInfos(EventNavigatorManager, String, String, String, String, int) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
getSaveEventResultItemInfos(String, String, String, String, int) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
getSaveEventResultItemInfos(EventNavigatorManager, String, String, String, String, int) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
getSaveEventResultItemInfosHistory(EventNavigatorManager, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
getSaveEventResultItemInfosHistory(String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
getSaveEventResultItemInfosHistory(EventNavigatorManager, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
getSaveLinkPageInfo(EventNavigatorManager, String, String, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
保存結果ページ情報を取得します。
getSaveLinkPageInfo(String, String, String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
保存結果ページ情報を取得します。
getSaveLinkPageInfo(EventNavigatorManager, String, String, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
保存結果ページ情報を取得します。
getScIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
レコード番号を取得します｡
getScVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
外注仕入先を取得します。
getScalbasval() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件のスケール基準値を取得します。
getScalbasval() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件のスケール基準値を取得します。
getScaleCount() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
ｙ軸の目盛間隔を返します。
getScaleCount() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
ｙ軸の目盛間隔を返します。
getScaleCount() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
ｙ軸の目盛間隔を返します。
getScaleCountX() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｘ軸の目盛間隔を返します。
getScaleCountY() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｙ軸の目盛間隔を返します。
getScalePosition() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｘ軸、ｙ軸の目盛りの表示位置を返します。
getScalebasin() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
スケール基準区分を取得します。
getScalebasin() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
スケール基準区分を取得します。
getScaletype() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
スケールタイプを取得します。
getScaletype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
スケールタイプを取得します。
getSce() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
CUX: 選定タイプを取得します。
getSchedInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
分納契約のリリース伝票区分を取得します。
getSchedLin() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
納入日程行を取得します。
getSchedLine() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
納入日程行を取得します。
getSchedLine() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入日程行を取得します。
getSchedLine() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
受注納入日程を取得します。
getSchedLine() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
受注納入日程を取得します。
getSchedLine() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程行を取得します。
getSchedLine() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
納入日程行を取得します。
getSchedMilestoneDateBasic() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン計画日(基準)を取得します。
getSchedMilestoneDateForecast() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン計画日(予測)を取得します。
getSchedMilestoneTimeBasic() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン計画時間(基準)を取得します。
getSchedMilestoneTimeForecast() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン計画時間(予測)を取得します。
getSchedType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程カテゴリを取得します。
getSchedType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSchedule(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 BatchManager.exportData(String category, OutputStream outputStream)に置き換えられました。
getScheduling() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
単一文字フラグを取得します。
getScript() - class jp.co.intra_mart.foundation.page.EventScript のメソッド
設定された情報からイベントのためのスクリプトを作成します。
getScrolling() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
scrollingを取得します。
getSdDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
販売管理伝票番号を取得します。
getSdDoc() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売管理伝票番号を取得します。
getSdDocCat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
販売管理伝票カテゴリを取得します。
getSdDocCat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売管理伝票カテゴリを取得します。
getSdDocCat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSdTaxcode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
を取得します。
getSdTaxcode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSeasIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
季節指数を取得します。
getSeason() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
季節カテゴリを取得します。
getSeason() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
季節カテゴリを取得します。
getSeasonPds() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
季節周期ごとの期間数を取得します。
getSeasonYr() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
シーズン年度を取得します。
getSecondaryComparator() - interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator のメソッド
２番目コンパレータを取得します。
getSecondaryComparator() - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator のメソッド
第２コンパレータを返します。
getSecondaryComparator() - class jp.co.intra_mart.foundation.page.NodeTypeComparator のメソッド
第２コンパレータを取得します。
getSecondaryComparator() - interface jp.co.intra_mart.foundation.utility.DualComparator のメソッド
推奨されていません。 ２番目コンパレータを取得します。
getSecondaryComparator() - class jp.co.intra_mart.foundation.utility.MultiComparator のメソッド
推奨されていません。 第２コンパレータを返します。
getSecurityExt() - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter のメソッド
推奨されていません。 セキュリティの拡張子を取得します。
getSelectItem() - class jp.co.intra_mart.foundation.navigator.EventItem のメソッド

getSelectItem(int) - class jp.co.intra_mart.foundation.navigator.EventItem のメソッド

getSelectItemInfos() - class jp.co.intra_mart.foundation.navigator.EventItemInfo のメソッド
選択アイテム情報リスト取得
getSelection() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
選択 ID (永続)を取得します。
getSelection() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSender() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
論理システム - 送信者を取得します。
getSender() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
論理システム - 送信者を取得します。
getSender() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
論理システム - 送信者を取得します。
getSeparateKey(int) - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のメソッド
指定された添字に該当するプロパティファイルのキー情報（配列）の要素を 返します。
getSeqNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
KANBAN/連続番号を取得します。
getSeqNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSerchFilter() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
検索フィルタを取得する。
getSerialNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
勘定設定の連続番号を取得します。
getSerialNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
勘定設定の連続番号を取得します。
getSerialNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
勘定設定の連続番号を取得します。
getSerialNumbers() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
シリアル番号の取得
ライセンス・キーが登録されていない場合は、空の配列を返却します。
getSerializationLevel() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
シリアル番号の指定レベルを取得します。
getSerialno() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のメソッド
シリアル番号を取得します。
getSerialnoAutoNumberassignment() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
シリアル番号の自動登録を取得します。
getSernoLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
勘定コード設定のシリアル番号、サービス明細を取得します。
getSernoProf() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
シリアル番号プロファイルを取得します。
getServDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
サービス提供日を取得します。
getServDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getServDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
サービス提供日を取得します。
getServDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getServLevel() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
サービスレベルを取得します。
getServType() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
サービスタイプのテキスト (短)を取得します。
getServType() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスタイプのテキスト (短)を取得します。
getServerType() - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
設定されているサーバータイプを取得します。
getServerType() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 サーバタイプを取得します｡
getService() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
活動番号を取得します。
getService() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
設定されているサービスＩＤを返します。
getService(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
現在のリクエストに対するサービスIDを取得します。
getService() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
サービスIDを取得します。
getService() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性serviceの値を取得します。
getService() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
サービスを取得します。
getService() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
サービスを取得します。
getService() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
サービスを取得します。
getService() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性serviceの値を取得します。
getServiceController(String, String) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
推奨されていません。 このメソッドではなくServiceManager.getServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
getServiceController(String, String, Locale) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
サービスコントローラを取得します。
getServiceController(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.container.ServiceContainer のメソッド
サービスコントローラを取得します。
getServiceController(String, String, Locale) - class jp.co.intra_mart.framework.base.service.container.ServiceContainerImpl のメソッド
サービスコントローラを取得します。
getServiceController(String, String, Locale) - class jp.co.intra_mart.framework.extension.seasar.service.S2ServiceContainer のメソッド

getServiceControllerName(String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
getServiceControllerName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
サービスコントローラのクラス名を取得します。
getServiceControllerName(String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
getServiceControllerName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
サービスコントローラのクラス名を取得します。
getServiceControllerName(String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceControllerName(String, String, Locale)を使用してください。
getServiceControllerName(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
サービスコントローラのクラス名を取得します。
getServiceControllerName(String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceControllerName(String, String, Locale)を使用してください。
getServiceControllerName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
サービスコントローラのクラス名を取得します。
getServiceControllerName(String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
getServiceControllerName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
サービスコントローラのクラス名を取得します。
getServiceErrorPage(Exception) - class jp.co.intra_mart.framework.base.service.DefaultTransition のメソッド
処理エラーのページを取得します。
getServiceErrorPage(Exception) - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のメソッド
処理エラーのページを取得します。
getServiceErrorPage(Exception) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
処理エラーのページを取得します。
getServiceErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
getServiceErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
getServiceErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
getServiceErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
getServiceErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
getServiceErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
getServiceErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
getServiceErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
getServiceErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale)を使用してください。
getServiceErrorPagePath(String, String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, String, Locale)を使用してください。
getServiceErrorPagePath(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, Locale)を使用してください。
getServiceErrorPagePath(String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(Locale)を使用してください。
getServiceErrorPagePath(Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale)を使用してください。
getServiceErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, String, Locale)を使用してください。
getServiceErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, Locale)を使用してください。
getServiceErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(Locale)を使用してください。
getServiceErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
getServiceErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
getServiceErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
getServiceErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
getServiceErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceId() - class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet のメソッド
サービスIDを取得します。
getServiceManager() - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 サービスマネージャを取得します。
getServiceManager() - class jp.co.intra_mart.framework.base.service.ServiceManager の static メソッド
サービスマネージャを取得します。
getServiceManager() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
サービスマネージャを取得します。
getServiceParamName() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getServiceParamName() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
サービスIDに該当するパラメータ名を取得します。
getServiceParamName() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getServiceParamName() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getServiceParamName() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 サービスプロパティハンドラを取得します。
getServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
サービスプロパティハンドラを取得します。
getServicePropertyHandler() - interface jp.co.intra_mart.framework.base.service.container.ServiceContainer のメソッド
サービスプロパティハンドラを取得します。
getServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.container.ServiceContainerImpl のメソッド
サービスプロパティハンドラを取得します。
getServicePropertyHandler() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
サービスプロパティハンドラを取得します。
getServicePropertyHandler() - class jp.co.intra_mart.framework.extension.seasar.service.S2ServiceContainer のメソッド

getServiceServletPath() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
サービスサーブレットのパスを取得します。
getServiceServletPath() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
サービスサーブレットのパスを取得します。
getServiceServletPath() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getServiceServletPath() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
サービスサーブレットのパスを取得します。
getServiceServletPath() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
サービスサーブレットのパスを取得します。
getServletConfig() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext のメソッド
イベントを制御したリスナー となっている Servlet が初期化された時に Servlet コンテナから渡された設定オブジェクトが返されます。
getServletContext() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
この Filter を実行している ServletContext への参照を返します。
getServletContext() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventConfig のメソッド
呼び出したコントローラを実行している ServletContext への参照を返します。
getServletContext() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
このリスナが実行されているサーブレットコンテキストを返します。
getServletContext() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventConfig のメソッド
呼び出したコントローラを実行している ServletContext への参照を返します。
getServletContext() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
サーブレットコンテキストを返します。
getSession() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
このリクエストに関連づけられている現在のセッションを返します。
getSession() - class jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent のメソッド
メール送信のセッションを取得します。
getSession() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
getSessionConfig() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
セッション情報保管パラメータを取得します。
getSessionCookieName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
クッキーにセッション情報を保管するためパラメータ名を取得する。
getSessionErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
セッションエラーページURLを取得する。
getSessionErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
セッションエラーページURLを取得する。
getSessionErrorPagePath() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
セッションエラーページのパスを取得します。
getSessionErrorPagePath() - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler のメソッド
セッションエラーページのパスを取得します。
getSessionErrorPagePath() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
セッションエラーページのパスを取得します。
getSessionFactory() - class jp.co.intra_mart.framework.base.session.SessionManager のメソッド
セッションファクトリを取得します。
getSessionFactoryName() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
getSessionFactoryName() - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler のメソッド
推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
getSessionFactoryName() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
getSessionID() - class jp.co.intra_mart.framework.base.session.HttpSessionObject のメソッド
推奨されていません。 セッションを一意に識別するIDを取得します。
getSessionID() - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のメソッド
推奨されていません。 セッションを一意に識別するIDを取得します。
getSessionID() - interface jp.co.intra_mart.framework.base.session.SessionObject のメソッド
セッションを一意に識別するIDを取得します。
getSessionId() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
セッションIDを取得する。
getSessionInfo() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報からintra-martセッション情報を取得します。
getSessionInfo(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
intra-martセッション情報を取得します。
getSessionManager() - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 セッションマネージャを取得します。
getSessionManager() - class jp.co.intra_mart.framework.base.session.SessionManager の static メソッド
セッションマネージャを取得します。
getSessionMode() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
intra-martセッションの状態を取得します。
getSessionMode(SessionInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
intra-martセッションの状態を取得します。
getSessionObject() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
getSessionObject(ServletRequest) - class jp.co.intra_mart.framework.base.session.SessionManager のメソッド
セッションオブジェクトを取得します。
getSessionObjectKey() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
推奨されていません。 HttpSessionを直接取得するようにしてください。
getSessionObjectKey() - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler のメソッド
推奨されていません。 HttpSessionを直接取得するようにしてください。
getSessionObjectKey() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
推奨されていません。 HttpSessionを直接取得するようにしてください。
getSessionParameter() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
getSessionParameter() - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler のメソッド
推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
getSessionParameter() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
getSessionPropertyHandler() - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 セッションプロパティハンドラを取得します。
getSessionPropertyHandler() - class jp.co.intra_mart.framework.base.session.SessionManager のメソッド
セッションプロパティハンドラを取得します。
getSessionTimeoutErrorPage(HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
セッションタイムアウトエラーページURLを取得する。
getSessionTimeoutErrorPage(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
セッションタイムアウトエラーページURLを取得する。
getSettItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
リベート (期末) 決済対象の明細を取得します。
getSetupTime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出荷準備時間を取得します。
getSetuptime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
段取時間と片付け時間を取得します。
getShMatTyp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
梱包材タイプを取得します。
getShape() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
shapeを取得します。
getShape() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
shapeを取得します。
getShelfLife() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
総有効期間を取得します。
getShipBlocked() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
SD 出荷伝票の明細ブロックを取得します。
getShipCond() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷条件を取得します。
getShipCond() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getShipPoint() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷ポイント/入荷ポイントを取得します。
getShipPoint() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getShipPoint() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出荷ポイント/入荷ポイントを取得します。
getShipProcTime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出荷処理時間を取得します。
getShipTo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
出荷先を取得します。
getShipType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷タイプを取得します。
getShipType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getShipType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷タイプを取得します。
getShipType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getShipping() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
出荷指示を取得します。
getShipping() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
出荷指示を取得します。
getShipping() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷指示を取得します。
getShippingCountry() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
貿易: 出荷国を取得します。
getShippingCountryIso() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
ISO 国コードを取得します。
getShortCutInfo(String, String) - interface jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor のメソッド
ショートカット情報を取得します。
getShortCutInfo(String) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutManager のメソッド
ショートカット情報取得。
getShortCutInfo(String, String) - class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor のメソッド
ショートカット情報を取得します。
getShortCutName() - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
ショートカット用ＵＲＬパラメータ名を取得する。
getShortId() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素 ショート IDを取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
G/L勘定コードテキスト(短)を取得します｡
getShortText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
G/L勘定コードを指定してG/L勘定コードテキスト(短)を取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
テキスト 1 (短)を取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
テキスト(短)を取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コードテキスト（短）を取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
テキスト (短): 受注明細を取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
テキスト (短): 受注明細を取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
テキスト (短): 受注明細を取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
テキスト (短): 受注明細を取得します。
getShortcutName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ショートカットＩＤをセッションに保管するためのパラメータ名を取得する。
getShutdownListeners() - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の static メソッド
現在登録されているリスナを返します。
getSiCat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
補助明細カテゴリ、購買伝票を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.Selection のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSignature() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ログイン署名を取得する。
getSignatureName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ログイン署名をセッションに保管するためのパラメータ名を取得する。
getSize() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
ファイルサイズを取得します。
getSize() - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager のメソッド
このプールが現在管理しているコネクション数です。
getSize() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
このプールが現在管理しているコネクション数です。
getSize() - interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader のメソッド
エクスポート単位のデータ数を取得します。
getSize() - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
描画する点のサイズを返します。
getSize() - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionManager のメソッド
推奨されていません。 このプールが現在管理しているコネクション数です。
getSize() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 このプールが現在管理しているコネクション数です。
getSizeDim() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
サイズ/寸法を取得します。
getSizeThreshold() - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle の static メソッド
useCommonsFileuploadがtrueの場合、一時ファイルを作成する閾値を取得します。
getSledBbd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
有効期限を取得します。
getSlocExprc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
外部調達の初期保管場所を取得します。
getSmKey() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
日程計画余裕キーを取得します。
getSocket() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
このオブジェクトの持つソケットオブジェクトを返します。
getSocket() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 このオブジェクトの持つソケットオブジェクトを返します。
getSocketConnectionDistributor() - class jp.co.intra_mart.foundation.service.client.manager.ServerConnector のメソッド
このオブジェクトが保持しているネットワークのコネクションプールを 返します。
getSoldTo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
受注先を取得します。
getSoldTo() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
受注先を取得します。
getSort1() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
検索条件 1を取得します。
getSort1() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
検索条件 1を取得します。
getSort1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
検索条件 1を取得します。
getSort2() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
検索条件 2を取得します。
getSort2() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
検索条件 2を取得します。
getSort2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
検索条件 2を取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.image.ImageIconInfo のメソッド
ソートキーを取得する。
getSortNumber() - class jp.co.intra_mart.foundation.navigator.EventFlow のメソッド

getSortNumber() - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
ソート番号を取得します。
getSortNumber() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
ソート番号を取得します。
getSortNumber() - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel のメソッド
ソート番号を取得します。
getSortNumber() - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
ソート番号を取得します。
getSourceEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.ActivationKey のメソッド
ライフタイム期間の有効開始日時の基点となるソースエンティティの情報を取得します。
getSourceEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey のメソッド
ライフタイム期間の有効終了日時の基点となるソースエンティティの情報を取得します。
getSourceEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalKey のメソッド
国際化基準項目の基点となるソースエンティティの情報を取得します。
getSourceEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ソースエンティティの情報を取得します。
getSourceEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableKey のメソッド
期間化基準項目の基点となるソースエンティティの情報を取得します。
getSourceRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
このエンティティをソースとしているリレーションシップをすべて取得します。
getSourcelist() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 供給元一覧必須を取得します。
getSpecMvmt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
倉庫管理の特殊移動区分を取得します。
getSpecMvmt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
倉庫管理の特殊移動区分を取得します。
getSpecProc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所レベルでの特殊調達タイプを取得します。
getSpecStock() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
特殊在庫区分を取得します。
getSpecStock() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
特殊在庫区分を取得します。
getSpecStockRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
特殊在庫区分の範囲を取得します。
getSpecprocty() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算の特殊調達タイプを取得します。
getSplitInd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
分割区分を取得します。
getSpproctype() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
特殊調達タイプを取得します。
getSrc() - class jp.co.intra_mart.foundation.image.ImageIconInfo のメソッド
イメージアイコンURLを取得する。
getSscExist() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスタイプの制限を取得します。
getSscItem() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
標準サービスカタログ: 明細を取得します。
getSscLim() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
標準サービスカタログ制限参照のサービス行を取得します。
getSscLimit() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスタイプの金額制限を取得します。
getSscNolim() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
標準サービスタイプの制限なしを取得します。
getSscPerc() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
価格決定率を取得します。
getSscPrschg() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
入力シートの価格変更を取得します。
getStRefDateNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
開始参照日付は変更できませんを取得します。
getStRefDateNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
開始参照日付は変更できませんを取得します。
getStUnQtyy1() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
代替数量単位での在庫受入予定保管単位別数量を取得します。
getStUnQtyy1Iso() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
単位の ISO コードを取得します。
getStUnQtyy2() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
代替数量単位での在庫受入予定保管単位別数量を取得します。
getStUnQtyy2Iso() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
単位の ISO コードを取得します。
getStackFact() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
山積係数を取得します。
getStart() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト計画開始日付を取得します。
getStartDate() - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
開始日を取得します。
getStartDate() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
開始日を取得します。
getStartDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
開始日を取得します。
getStartDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
開始日を取得します。
getStartDateColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable のメソッド
期間の開始日時に該当するカラムのカラム名を取得します。
getStartEventId() - class jp.co.intra_mart.foundation.navigator.EventFlowInfo のメソッド
スタートイベントアイテムID取得
getStartEventItem() - class jp.co.intra_mart.foundation.navigator.EventFlow のメソッド

getStartOffset() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用の開始オフセットを取得します。
getStartOffset() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用の開始オフセットを取得します。
getStartOffsetNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
開始オフセットは変更できませんを取得します。
getStartOffsetNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
開始オフセットは変更できませんを取得します。
getStartOffsetUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用開始のオフセット単位を取得します。
getStartOffsetUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用開始のオフセット単位を取得します。
getStartOffsetUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
PRT 用途開始決定の間隔時間単位 (ISO)を取得します。
getStartOffsetUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
PRT 用途開始決定の間隔時間単位 (ISO)を取得します。
getStartRefDate() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用開始の参照日付を取得します。
getStartRefDate() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用開始の参照日付を取得します。
getStatCon() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
統計に適用する条件を取得します。
getStatCon() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
統計に適用する条件を取得します。
getStatDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
統計的納入期日を取得します。
getStatGroup() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
統計グループを取得します。
getStatProf() - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
ステータスプロファイルを取得します。
getStatistical() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
統計 WBS 要素を取得します。
getStatistical() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
統計 WBS 要素を取得します。
getStatus() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse のメソッド
レスポンスにセットされている ステータスコードを返します。
getStatus() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse#getStatus(String) メソッドをそのまま呼び出します。
getStatus() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
レスポンスにセットされている ステータスコードを返します。
getStatus() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンステータスを取得します。
getStatus() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
伝票ステータスを取得します｡
getStatus() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
単一文字フラグを取得します。
getStatus() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager のメソッド
ラップしたTransactionManagerのgetStatusを呼び出します。
getStatus() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction のメソッド
ラップしたUserTransactionのgeｔStatusを呼び出します。
getStatusDocOld() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
このバージョンの前の旧処理状況 (購買伝票内)を取得します。
getStatusInfoList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のメソッド
ステータス情報を取得します。
getStckType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
在庫タイプを取得します。
getStckType() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫タイプを取得します。
getStdDescr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
標準テキスト (ANSI、ISO など)を取得します。
getStdMaterialGetIntNumberList() - class jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController のメソッド
品目コード割当済一覧(結果)を取得します。
getStdMaterialGetIntNumberList() - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList のメソッド
品目コード割当済一覧を取得します｡
getStdPrPp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期標準標準原価を取得します。
getStdPrPy() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度標準原価を取得します。
getStdPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
標準原価を取得します。
getStdTextKey() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具の標準テキストキーを取得します。
getStdTextKey() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具の標準テキストキーを取得します。
getStgeBin() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
棚番を取得します。
getStgeBin() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
棚番を取得します。
getStgeBin() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
棚番を取得します。
getStgeBinPc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫転送棚番を取得します。
getStgeBinSt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫転送棚番を取得します。
getStgeLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
保管場所を取得します。
getStgeLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
保管場所を取得します。
getStgeLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所を取得します。
getStgeLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
保管場所を取得します。
getStgeLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
保管場所を取得します。
getStgeLocRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
保管場所の範囲を取得します。
getStgePdUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最長保管期間の単位を取得します。
getStgePdUnIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ISO コードでの最長保管期間単位を取得します。
getStgeType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
保管域タイプを取得します。
getStgeType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
概略計画および詳細計画のピッキング保管域タイプを取得します。
getStgeType() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
保管域タイプを取得します。
getStgeTypePc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫転送の保管域タイプを取得します。
getStgeTypeSt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫転送の保管域タイプを取得します。
getStgeperiod() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最長保管期間を取得します。
getStgesector() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
保管区画区分を取得します。
getStlocHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のメソッド
終了保管場所を取得します。
getStlocLow() - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のメソッド
開始保管場所を取得します。
getStockInd() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
特殊在庫区分を取得します。
getStorConds() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
保管条件を取得します。
getStorCosts() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
保管経費区分を取得します。
getStorPct() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
残存有効期間割合 %を取得します。
getStorageLocationData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目データ (保管場所レベル)を取得します。
getStorageLocationDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
品目データ (保管場所レベル)が既に存在するかチェックします。
getStorageLocationDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目データ (保管場所レベル)を取得します。
getStorageLocationselectList() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
保管場所の選択オプション一覧を取得します｡
getStorageTypeData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
保管域タイプデータを取得します。
getStorageTypeDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
保管域タイプデータが既に存在するかチェックします。
getStorageTypeDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
保管域タイプデータを取得します。
getStorageView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
保管ビューを取得します。
getStorageView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管ビューを取得します。
getStorageView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
保管ビューを取得します。
getStoragelocation() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
保管場所を取得します。
getStoragetype() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
保管域タイプを取得します。
getStoreLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
保管場所を取得します。
getStoreLoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
保管場所を取得します。
getStoreLoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getStoreLoc() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
保管場所を取得します。
getStrAbbr() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名の略称 (例: スペイン)を取得します。
getStrAbbr() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名の略称 (例: スペイン)を取得します。
getStrAbbr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名の略称 (例: スペイン)を取得します。
getStrSuppl1() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名 2を取得します。
getStrSuppl1() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名 2を取得します。
getStrSuppl1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名 2を取得します。
getStrSuppl2() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名 3を取得します。
getStrSuppl2() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名 3を取得します。
getStrSuppl2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名 3を取得します。
getStrSuppl3() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名 4を取得します。
getStrSuppl3() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名 4を取得します。
getStrSuppl3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名 4を取得します。
getStream() - interface jp.co.intra_mart.foundation.security.SystemSourceProvider のメソッド
システム設定ファイルの内容取得。
getStreet() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
地名/番地-号を取得します。
getStreet() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名を取得します。
getStreet() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
地名/番地-号を取得します。
getStreet() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名を取得します。
getStreet() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
地名/番地-号を取得します。
getStreetLng() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名を取得します。
getStreetLng() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名を取得します。
getStreetLng() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名を取得します。
getStreetNo() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村/地名ファイルの地名コードを取得します。
getStreetNo() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村/地名ファイルの地名コードを取得します。
getStreetNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村/地名ファイルの地名コードを取得します。
getString() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
ファイルの内容をStringとして取得します。
getString(String) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
指定されたエンコードを使用してファイルの内容をStringとして取得します。
getStringDate(Date) - class jp.co.intra_mart.foundation.sap.common.util.date.DateHandler の static メソッド
Date型オブジェクトを日付書式[YYYYMMDD]の文字列に変換して返します。
getStringHeader(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse のメソッド
指定された名称でレスポンスヘッダに設定されている文字列の値を返します。
getStringHeader(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getStringHeader(String) メソッドをそのまま呼び出します。
getStringHeader(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
指定された名称でレスポンスヘッダに設定されている文字列の値を返します。
getStringHeaders(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse のメソッド
指定された名称でレスポンスヘッダに設定されている全ての文字列の値を返します。
getStringHeaders(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getStringHeaders(String) メソッドをそのまま呼び出します。
getStringHeaders(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
指定された名称でレスポンスヘッダに設定されている全ての文字列の値を返します。
getStringValue() - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
属性文字列を取得します。
getStringValue(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
属性文字列を取得します。
getStringValue() - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttributeInternational のメソッド
属性文字列を取得します。
getStringValue() - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel のメソッド
属性文字列を取得します。
getStringValue(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel のメソッド
属性文字列を取得します。
getStringValue() - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeInternationalModel のメソッド
属性文字列を取得します。
getStroke() - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
描画される線の描画属性を返します。
getStructcond() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
構造条件を取得します。
getStructure() - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI テーブル拡張の構造名を取得します。
getStructure() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI テーブル拡張の構造名を取得します。
getStructure() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI テーブル拡張の構造名を取得します。
getStructure() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI テーブル拡張の構造名を取得します。
getStructure() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI テーブル拡張の構造名を取得します。
getStructureParam(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
structure(Export)情報を返します。
getStyle() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性styleの値を取得します。
getStyle() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
styleを取得します。
getStyle() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
styleを取得します。
getStyle() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
styleを取得します。
getStyle() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性styleの値を取得します。
getStyle() - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性styleの値を取得します。
getSuPlStck1() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫受入予定の保管単位数を取得します。
getSuPlStck2() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫受入予定の保管単位数を取得します。
getSubNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
資産補助番号を取得します。
getSubNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
資産補助番号を取得します。
getSubNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
資産補助番号を取得します。
getSubRole(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
サブロール(一階層のみ)を取得します。
getSubRoleIds(String, String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
サブロールIDサマリを取得します。
getSubRoleIds(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
サブロールIDサマリを取得する。
getSubType() - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のメソッド
このオブジェクトが表す MIME タイプの subtype を返します。
getSubType() - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のメソッド
推奨されていません。 このオブジェクトが表す MIME タイプの subtype を返します。
getSubUom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
梱包階層の下位レベル数量単位を取得します。
getSubUomIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
下位レベル数量単位 (ISO コード)を取得します。
getSubitemint() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
副明細の明細間隔を取得します｡
getSubjToR() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
承認未完了を取得します。
getSubject() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Subjectを取得します。
getSubmitclass() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性classの値を取得します。
getSubpckgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
サブパッケージ番号を取得します。
getSuccessList() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
正常に処理された明細のテーブルを取得します。
getSuccessList() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
後続請求伝票の明細テーブルを取得します。
getSummaryRoleId() - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel のメソッド
サマリロールIDを取得します。
getSupSource() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
供給元を取得します。
getSupSource() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
供給元を取得します。
getSuperUser() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
システム管理者情報を取得します。
getSuperUser() - interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor のメソッド
システム管理者情報を取得します。
getSuperUser(String) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor のメソッド
グループ管理者情報を取得します。
getSuperUser(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
グループ管理者情報を取得します。
getSuppLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
補足明細を取得します。
getSuppVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
供給仕入先/仕入入庫を取得します。
getSupplPlnt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
在庫転送オーダーにおける供給(出庫)プラントを取得します｡
getSupplStloc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
出庫保管場所: 在庫転送オーダーを取得します。
getSupplVend() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
供給仕入先を取得します｡
getSupplVend() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
供給仕入先を取得します。
getSupplVend() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
供給仕入先を取得します。
getSupplierDetail() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
仕入先マスタ詳細情報を取得します｡
getSupplierExistenceCheck() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のメソッド
仕入先コードチェック情報を取得します｡
getSupplierInfo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
仕入先住所を取得します｡
getSupplyArea() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目マスタレコードで提案される供給場所を取得します。
getSvalidfrom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
流通チェーン間品目ステータスの有効開始日付を取得します。
getSyStDscr() - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus のメソッド
オブジェクトステータスを取得します。
getSyStText() - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus のメソッド
オブジェクトの個別ステータス (簡略形式)を取得します。
getSysStatus() - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus のメソッド
システムステータスを取得します。
getSysdate() - class jp.co.intra_mart.foundation.sap.common.util.date.DateHandler の static メソッド
システム日付を取得します。
getSysnr() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing のメソッド
システム番号を取得します。
getSysnr() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing のメソッド
システム番号を取得します。
getSysnr() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 システム番号を取得します｡
getSystem() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ＩＤを取得します｡
getSystem() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージが発行された論理システムを取得します。
getSystemConnection(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
システム接続名からコネクションオブジェクトを取得します。
getSystemCurrencyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager のメソッド
システム通貨コードを返します。
getSystemDatabaseType(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
システムデータソースにおけるデータベースの種類を取得する。
getSystemErrorMessage() - class jp.co.intra_mart.extension.maskat.util.MKError のメソッド
systemErrorMessageを取得します。
getSystemErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
認証処理エラーページURLを取得する。
getSystemErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
認証処理エラーページURLを取得する。
getSystemErrorPage(Exception) - class jp.co.intra_mart.framework.base.service.DefaultTransition のメソッド
システムエラーのページを取得します。
getSystemErrorPage(Exception) - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のメソッド
システムエラーのページを取得します。
getSystemErrorPage(Exception) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
システムエラーのページを取得します。
getSystemErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
getSystemErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
getSystemErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
getSystemErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
getSystemErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
getSystemErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
getSystemErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
getSystemErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
getSystemErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale)を使用してください。
getSystemErrorPagePath(String, String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, String, Locale)を使用してください。
getSystemErrorPagePath(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, Locale)を使用してください。
getSystemErrorPagePath(String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
getSystemErrorPagePath(Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale)を使用してください。
getSystemErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, String, Locale)を使用してください。
getSystemErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, Locale)を使用してください。
getSystemErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
getSystemErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
getSystemErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
getSystemErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
getSystemErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
getSystemErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemLicense() - class jp.co.intra_mart.foundation.security.license.LicenseManager の static メソッド
システム全体の登録ライセンス数。
getSystemMaxDate() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
最大の未来日を取得します。
getSystemMaxLicense() - class jp.co.intra_mart.foundation.security.license.LicenseManager の static メソッド
システム全体のライセンス数。
getSystemMenu() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
システムメニューを取得します。
getSystemMinDate() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
最大の過去日を取得します。
getSystemProperty(String) - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext のメソッド
クライアントの Java 実行環境のシステムプロパティの値を返します。
getSystemPropertyNameSet() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext のメソッド
クライアントの Java 実行環境のシステムプロパティの名前のセットを返します。
getSystemStatusList() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
システムステータステーブルを取得します。
getSystemStatusList() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
システムステータステーブルを取得します。
getSystemTemporaryDirectory() - class jp.co.intra_mart.foundation.service.provider.TemporaryDirectory の static メソッド
システムが使用する一時ファイル保存ディレクトリを表す オブジェクトを返します。
getTUnitIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
目標数量単位 (ISO コード)を取得します。
getTUnitIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaGlAccount() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
総勘定元帳勘定を取得します｡
getTaIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
レコード番号を取得します｡
getTaItemnoAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
会計伝票明細番号を取得します｡
getTaTaxCode() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
消費税コードを取得します｡
getTabindex() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
tabindexを取得します。
getTabindex() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
tabindexを取得します。
getTabindex() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
tabindexを取得します。
getTable() - interface jp.co.intra_mart.foundation.datastore.common.config.BaseTable のメソッド
基本テーブルが定義されているテーブル定義を取得します。
getTable() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
このエンティティを参照しているテーブルを取得します。
getTable() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable のメソッド
国際化テーブルが定義されているテーブル定義を取得します。
getTable() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable のメソッド
期間国際化テーブルが定義されているテーブル定義を取得します。
getTable() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable のメソッド
期間化テーブルが定義されているテーブル定義を取得します。
getTableParam(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
table(Export)情報を返します。
getTables() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義しているテーブル定義の一覧を取得します。
getTagClass() - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性classの値を取得します。
getTagWriter() - class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes のメソッド
TagWriterを取得します。
getTarget() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性targetの値を取得します。
getTarget() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
targetを取得します。
getTargetEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ターゲットエンティティの情報を取得します。
getTargetLocales() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
対象ロケールの取得。
getTargetQty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
目標数量（販売単位）を取得します。
getTargetQty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTargetQu() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
目標数量 (数量単位)を取得します。
getTargetQu() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTargetRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
このエンティティをターゲットとしているリレーションシップをすべて取得します。
getTargetVal() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
目標値を取得します。
getTargetVal() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
累積計画金額を取得します。
getTargetVal() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
BAPI の通貨額 (小数点以下９桁)を取得します。
getTargetVal() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaskListType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
タスクリストタイプを取得します。
getTaxClass1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先税分類 2を取得します。
getTaxClass2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先税分類 3を取得します。
getTaxClass3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 4を取得します。
getTaxClass4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 5を取得します。
getTaxClass5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass6() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 6を取得します。
getTaxClass6() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass6() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass6() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass7() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 7を取得します。
getTaxClass7() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass7() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass7() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass8() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 8を取得します。
getTaxClass8() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass8() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass8() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass9() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 9を取得します。
getTaxClass9() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass9() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass9() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClassifications(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のメソッド
制御デ－タオブジェクトが既に存在するかチェックします。
getTaxClassifications(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
制御デ－タが既に存在するかチェックします。
getTaxClassificationsList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
制御デ－タを取得します。
getTaxClassificationsList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
制御デ－タを取得します。
getTaxCmlUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法/商法にもとづく評価額価格単位を取得します。
getTaxCode() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
消費税コードを取得します。
getTaxCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
消費税コードを取得します。
getTaxCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
消費税コードを取得します。
getTaxCode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
消費税コードを取得します。
getTaxDepartCty() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
税出荷国を取得します。
getTaxDestCty() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
税仕向国を取得します。
getTaxInd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税区分: 品目 (購買管理)を取得します。
getTaxType1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxType2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxType3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxType4() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxType5() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxType6() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxType7() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxType8() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxType9() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxValue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
税額を取得します。
getTaxValue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
税額を取得します。
getTaxValueItem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
税額を取得します。
getTaxcl1Mat() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目の税分類を取得します。
getTaxclass1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxclass2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxclass3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxclass4() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxclass5() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxclass6() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxclass7() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxclass8() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxclass9() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxdepCty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
税出荷国を取得します。
getTaxdepCty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxdstCty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
税仕向国を取得します。
getTaxdstCty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxlawicms() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
税法: ICMSを取得します。
getTaxlawicms() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxlawipi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
税法: IPIを取得します。
getTaxlawipi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxprice1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法による評価額: レベル 1を取得します。
getTaxprice2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法による評価額: レベル 2を取得します。
getTaxprice3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法基準評価額: レベル 3を取得します。
getTaxrCntry() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
納税申告書の国を取得します。
getTeIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
レコード番号を取得します｡
getTel() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
取引先での記帳担当者電話番号を取得します。
getTel1Ext() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
第 1 電話番号: 内線を取得します。
getTel1Ext() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
第 1 電話番号: 内線を取得します。
getTel1Ext() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
第 1 電話番号: 内線を取得します。
getTel1Numbr() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
第一電話番号: ダイヤルコード + 番号を取得します。
getTel1Numbr() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
第一電話番号: ダイヤルコード + 番号を取得します。
getTel1Numbr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
第一電話番号: ダイヤルコード + 番号を取得します。
getTelNo() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
電話番号取得。
getTelebox() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
テレボックス番号を取得します。
getTelegram() - class jp.co.intra_mart.extension.maskat.service.DefaultMKServiceResult のメソッド
クライアントへ送信する電文を取得します。
getTelegram() - class jp.co.intra_mart.extension.maskat.service.MKErrorsResult のメソッド
クライアントへ送信するエラー電文を取得します。
getTelegram() - interface jp.co.intra_mart.extension.maskat.service.MKServiceResult のメソッド
クライアントへ送信する電文を取得します。
getTelegram() - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject のメソッド
電文を取得します。
getTelephone() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
電話番号 1を取得します。
getTelephone() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
仕入先電話番号を取得します｡
getTelephone() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
電話番号を取得します。
getTelephone() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTelephone() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
電話番号 1を取得します。
getTelephone2() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
電話番号 2を取得します。
getTelephone2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
電話番号 2を取得します。
getTelephoneNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
電話番号を取得します。
getTelephoneNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
電話番号を取得します。
getTelephoneNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
電話番号を取得します。
getTelephoneNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
電話番号を取得します。
getTelephoneNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
電話番号を取得します。
getTelephoneNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
電話番号を取得します。
getTelephoneNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
電話番号を取得します。
getTelephoneNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
電話番号を取得します。
getTelephoneNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
電話番号を取得します。
getTelephoneNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
電話番号を取得します。
getTelephoneNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
電話番号を取得します。
getTelephoneNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
電話番号を取得します。
getTelephoneNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
電話番号を取得します。
getTelephoneNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
電話番号を取得します。
getTelephoneNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
電話番号を取得します。
getTeletexNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
テレテクス番号を取得します。
getTelexNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
テレックス番号を取得します。
getTempConds() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
温度条件区分を取得します。
getTemplate(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager のメソッド
指定された商品属性テンプレート情報を返します。
getTemplateCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
テンプレートコードを取得します。
getTemplateCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
テンプレートコードを取得します。
getTemplateCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate のメソッド
テンプレートコードを取得します。
getTemplateCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel のメソッド
テンプレートコードを取得します。
getTemplateCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
テンプレートコードを取得します。
getTemplateCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel のメソッド
テンプレートコードを取得します。
getTemplateDetail(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager のメソッド
指定された商品属性テンプレートの明細情報を返します。
getTemplateDetailCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
テンプレート明細コードを取得します。
getTemplateDetailCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
テンプレート明細コードを取得します。
getTemplateDetailCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel のメソッド
テンプレート明細コードを取得します。
getTemplateDetailCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
テンプレート明細コードを取得します。
getTemplateDetailName() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
テンプレート明細名を取得します。
getTemplateDetailName(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
テンプレート明細名を取得します。
getTemplateDetailName() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetailInternational のメソッド
テンプレート明細名を取得します。
getTemplateDetailName() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
テンプレート明細名を取得します。
getTemplateDetailName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
テンプレート明細名を取得します。
getTemplateDetailName() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailInternationalModel のメソッド
テンプレート明細名を取得します。
getTemplateName() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate のメソッド
テンプレート名を取得します。
getTemplateName() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplateInternational のメソッド
テンプレート名を取得します。
getTemplateName() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel のメソッド
テンプレート名を取得します。
getTemplateName() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateInternationalModel のメソッド
テンプレート名を取得します。
getTemplates(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager のメソッド
指定された検索条件に該当する商品属性テンプレート情報を返します。
getTerm() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
期間を取得します。
getTerm() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
期間化モデルが保持する期間 Term を取得します。
getTerm() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel のメソッド
期間化モデルが保持する期間 Term を取得します。
getTermCode() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
期間CDを取得します。
getTermColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable のメソッド
期間CDに該当するカラムのカラム名を取得します。
getTermColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable のメソッド
期間CDに該当するカラムのカラム名を取得します。
getTermColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable のメソッド
期間CDに該当するカラムのカラム名を取得します。
getTermColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable のメソッド
期間CDに該当するカラムのカラム名を取得します。
getTerminableAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor のメソッド
拡張もととなる期間化アクセサを取得します。
getTerminableAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor のメソッド
この期間国際化アクセサが所属する期間化アクセサを取得します。
getTerminableAccessor() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
この期間化モデルに割り当てられた期間化アクセサを取得します。
getTerminableAccessor() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
期間化アクセサを取得します。
getTerminableAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
基本アクセサに関連する期間化アクセサのマップを取得します。
getTerminableInternationalAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor のメソッド
拡張もととなる期間国際化アクセサを取得します。
getTerminableInternationalAccessor() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のメソッド
この期間国際化モデルに割り当てられた期間国際化アクセサを取得します。
getTerminableInternationalAccessor() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext のメソッド
期間国際化アクセサを取得します。
getTerminableInternationalAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
この期間化アクセサに対する期間国際化アクセサのマップを取得します。
getTerminableInternationalModel() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
期間国際化モデルを取得します。
getTerminableInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
期間国際化モデルのマップを取得します。
getTerminableInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel のメソッド
期間国際化モデルを取得します。
getTerminableInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
期間国際化モデルマップを取得します。
getTerminableInternationalTable() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
期間国際化テーブルを取得します。
getTerminableKey() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ソースエンティティの期間化基準項目を取得します。
getTerminableModel() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
期間化モデルを取得します。
getTerminableModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel のメソッド
期間化モデルのマップを取得します。
getTerminableModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
期間化モデルマップを取得します。
getTerminableModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
期間化モデルのマップを取得します。
getTerminableTable() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
期間化テーブルを取得します。
getTerminal() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 端末を取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
この組織所属で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
この会社組織分類で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
この会社で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
この組織で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
この主所属で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
この役職で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
この取扱で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
この商品で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
このパブリックグループ所属で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
このパブリックグループ分類で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
このパブリックグループで管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
このパブリックグループセットで管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
このユーザで管理している期間をすべて取得します。
getTerms() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap のメソッド
現在管理している期間の一覧を取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。
getTerms() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap のメソッド
マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。
getTestRun() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
テスト区分を取得します｡
getTestrun() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
在庫移動シミュレーションを取得します。
getTestrun() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
書込 BAPI のシミュレーションセッションへの切替を取得します。
getTestrun() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
シミュレーション実行 ('X')、更新実行 (' ')を取得します。
getTestrun() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
テスト実行を取得します。
getTestrun() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
テスト実行を取得します。
getTestrun() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
テスト実行を取得します。
getText() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
本文を取得します。
getTextDataInList() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
請求インタフェースの通信構造テキストを取得します。
getTextForm() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
タグ列を取得します。
getTextId() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
テキスト IDを取得します。
getTextId() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
テキスト IDを取得します。
getTextId() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
テキスト IDを取得します。
getTextId() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
テキスト IDを取得します。
getTextId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
テキスト IDを取得します。
getTextLine() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
テキスト行を取得します。
getTextLine() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
テキスト行を取得します。
getTextLine() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
テキスト行を取得します。
getTextLine() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
テキスト行を取得します。
getTextLine() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
テキスト行を取得します。
getTextName() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
名称を取得します。
getTextName() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
名称を取得します。
getThrowable() - interface jp.co.intra_mart.framework.base.service.RequestInfo のメソッド
処理中に発生した例外を取得します。
getThrowablePrintListener() - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
現在の例外出力リスナを返します。
getTimeUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
時間計画単位を取得します。
getTimeUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
単位の ISO コードを取得します。
getTimeZone() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
アドレスタイムゾーンを取得します。
getTimeZone() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
アドレスタイムゾーンを取得します。
getTimeZone() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
アドレスタイムゾーンを取得します。
getTimeoutCheckPeriod() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
コネクションのタイムアウトのチェック間隔を取得します。
getTimeoutCheckPeriod() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 コネクションのタイムアウトのチェック間隔を取得します｡
getTimes() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
次を取得します。
getTimes() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
次を取得します。
getTindex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
数値項目: 長さ 6を取得します。
getTitle() - class jp.co.intra_mart.foundation.navigator.TitleInfo のメソッド
タイトル取得
getTitle() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
タイトル (敬称)を取得します。
getTitle() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
タイトル (敬称)を取得します。
getTitle() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
敬称を取得します。
getTitle() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
タイトル (敬称)を取得します。
getTitle() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
敬称を取得します。
getTitle() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性titleの値を取得します。
getTitle() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
titleを取得します。
getTitle() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
titleを取得します。
getTitle() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
titleを取得します。
getTitle() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性titleの値を取得します。
getTitle() - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性titleの値を取得します。
getTitleInfo(Locale) - class jp.co.intra_mart.foundation.navigator.NavigatorItem のメソッド

getTmpExist() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスパッケージの制限を取得します。
getTmpLimit() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
モデルサービス明細制限を取得します。
getTmpLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: モデル仕様からの計画外サービスを取得します。
getTmpNolim() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
モデル仕様の制限なしを取得します。
getTmpNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
モデルサービス明細セット番号を取得します。
getTmpPckg() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: モデル仕様からの計画外サービスを取得します。
getTmpPerc() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
価格決定率を取得します。
getTmpPrschg() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
入力シートの価格変更を取得します。
getTo() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Toの一覧を取得します。
getToCurrncy() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算後通貨を取得します。
getToCurrncy() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
換算後通貨を取得します。
getToCurrncy() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
換算後通貨を取得します。
getToFactor() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算後 通貨単位の係数を取得します。
getToFactorV() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算後 通貨単位の係数を取得します。
getToLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
上限を取得します。
getTotalConsumption(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
品目総消費量のデータ転送が既に存在するかチェックします。
getTotalConsumptionList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目総消費量のデータ転送を取得します。
getTpDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
輸送計画日付を取得します。
getTpDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
輸送計画日付を取得します。
getTpDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTpTime() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
輸送計画 - 時間 (現地時間/出荷ポイント参照)を取得します。
getTpTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
輸送計画 - 時間 (現地時間/出荷ポイント参照)を取得します。
getTpTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTrEvType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
トランザクション/イベントタイプを取得します。
getTrEvTypeRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
トランザクション/イベントタイプの範囲を取得します。
getTrPartBa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取引会社事業領域を取得します。
getTrackingno() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買依頼追跡番号を取得します。
getTracklimit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
警告限界を取得します。
getTrans() - class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract のメソッド
取引を取得します。
getTransGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
輸送グループを取得します。
getTransaction() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager のメソッド
ラップしたTransactionManagerのgetTransactionを呼び出します。
getTransactionGroup() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
一文字フラグを取得します。
getTransactionIsolation() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection の現在のトランザクション遮断レベルを取得します。
getTransition(String, String) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
推奨されていません。 このメソッドではなくServiceManager.getTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
getTransition(String, String, Locale) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
トランジションを取得します。
getTransition(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.container.ServiceContainer のメソッド
トランジションを取得します。
getTransition(String, String, Locale) - class jp.co.intra_mart.framework.base.service.container.ServiceContainerImpl のメソッド
トランジションを取得します。
getTransition(String, String, Locale) - class jp.co.intra_mart.framework.extension.seasar.service.S2ServiceContainer のメソッド

getTransitionName(String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
getTransitionName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
トランジションのクラス名を取得します。
getTransitionName(String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
getTransitionName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
トランジションのクラス名を取得します。
getTransitionName(String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getTransitionName(String, String, Locale)を使用してください。
getTransitionName(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
トランジションのクラス名を取得します。
getTransitionName(String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getTransitionName(String, String, Locale)を使用してください。
getTransitionName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
トランジションのクラス名を取得します。
getTransitionName(String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
getTransitionName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
トランジションのクラス名を取得します。
getTransportMode() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader のメソッド
貿易管理の輸送モードを取得します。
getTranspzone() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
商品の納入区域を取得します。
getTranspzone() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
商品の納入区域を取得します。
getTranspzone() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
商品の納入区域を取得します。
getTranspzone() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
商品の納入区域を取得します。
getTrendAnalysisIndicator() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
傾向分析の関連マイルストーンを取得します。
getTrendValue() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
傾向値を取得します。
getTrendValuePp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間の傾向値を取得します。
getTrgQtyNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売単位から基本単位への換算係数を取得します。
getTrgQtyNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTrgqtyDen() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売単位から基本単位への換算係数を取得します。
getTrgqtyDen() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTwoStepPick() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ツーステップピッキング適用品目を取得します。
getType() - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のメソッド
このオブジェクトが表す MIME タイプを返します。
getType() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性の型を取得します。
getType() - interface jp.co.intra_mart.foundation.datastore.common.config.Column のメソッド
カラムの型を取得します。
getType() - interface jp.co.intra_mart.foundation.datastore.common.config.Property のメソッド
プロパティの型を取得します。
getType() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
タイプを取得します｡
getType() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を取得します。
getType() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を取得します。
getType() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
アプリケーションタイプを取得します。
getType() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
ノードのタイプを取得します。
getType() - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のメソッド
推奨されていません。 このオブジェクトが表す MIME タイプを返します。
getType() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
typeを取得します。
getTypeMap() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この接続に関連した型マップオブジェクトを取得します。
getURL() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL のメソッド
サーバから返されたＵＲＬを返します。
getURL(HTTPActionEventHandler, String) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の static メソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(HTTPActionEventHandler, URL) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の static メソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(HTTPActionEventHandler, HttpURLConnection) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の static メソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(String) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(URL) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(HttpURLConnection) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getUnWork() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
作業単位を取得します。
getUnWorkIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getUnddlvTol() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
不足納入許容範囲リミットを取得します。
getUnddlvTol() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getUnderDlvTol() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
不足納入許容範囲リミットを取得します。
getUnderTol() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
不足納入許容範囲リミットを取得します。
getUnit() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
表示単位を取得します。
getUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
発注単位を取得します。
getUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
表示数量単位を取得します。
getUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
表示数量単位を取得します。
getUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
表示数量単位を取得します。
getUnitCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail のメソッド
単位コードを取得します。
getUnitCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager のメソッド
単位名に対する単位コードを取得します。
getUnitCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
単位コードを取得します。
getUnitCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
単位コードを取得します。
getUnitCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailTerminableModel のメソッド
単位コードを取得します。
getUnitCode() - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitBaseModel のメソッド
単位コードを取得します。
getUnitDim() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
寸法単位 (長さ/幅/高さ)を取得します。
getUnitDimIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ISO コードでの長さ、幅、高さの単位を取得します。
getUnitGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
数量単位グループを取得します。
getUnitGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
数量単位グループを取得します。
getUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
ISO コードでの表示数量単位を取得します。
getUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
ISO コードでの表示数量単位を取得します。
getUnitName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager のメソッド
単位コードに対する名称を返します。
getUnitName() - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitBaseModel のメソッド
単位名を取得します。
getUnitOfWt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
重量単位を取得します。
getUnitOfWt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
重量単位を取得します。
getUnitOfWtIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードでの重量単位を取得します。
getUnitOfWtIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ISO コードでの重量単位を取得します。
getUnitPrice() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
単価を取得します。
getUnitPrice(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
単価を取得します。
getUnitPrice() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable のメソッド
単価を取得します。
getUnitPrice() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail のメソッド
単価を取得します。
getUnitPrice() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
単価を取得します。
getUnitPrice(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
単価を取得します。
getUnitPrice() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealTerminableModel のメソッド
単価を取得します。
getUnitPrice() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
単価を取得します。
getUnitPrice(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
単価を取得します。
getUnitPrice() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailTerminableModel のメソッド
単価を取得します。
getUnitSofmeasure(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のメソッド
数量単位オブジェクトが既に存在するかチェックします。
getUnitSofmeasure(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
数量単位が既に存在するかチェックします。
getUnitSofmeasureList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
数量単位を取得します。
getUnitSofmeasureList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
数量単位を取得します。
getUnitmeasur() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件スケール単位を取得します。
getUnitmeasur() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件スケール単位を取得します。
getUnitmeasurIso() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
単位の ISO コードを取得します。
getUnits() - class jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager のメソッド
単位の一覧を取得します。
getUnittype1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
第１保管単位タイプを取得します。
getUnittype1() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
保管単位タイプを取得します。
getUnittype2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
第２保管単位タイプを取得します。
getUnittype2() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
保管単位タイプを取得します。
getUnittype3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
第３保管単位タイプを取得します。
getUnlimited() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 無制限過剰納入可能を取得します。
getUnlimitedDlv() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
区分: 無制限過剰納入可能を取得します。
getUnlmtDlv() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
区分: 無制限過剰納入可能を取得します。
getUnlmtDlv() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getUnloadPt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
荷渡ポイントを取得します。
getUnloadPt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
荷渡ポイントを取得します。
getUnloadPt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
荷渡ポイントを取得します。
getUnloadPt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
荷渡ポイントを取得します。
getUnloadPtx() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
関連ユーザデータ項目の更新情報を取得します。
getUnofWtiso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ISO コードでの重量単位を取得します。
getUnplndConsumption(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
計画外消費のデータ転送が既に存在するかチェックします。
getUnplndConsumptionList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
計画外消費のデータ転送を取得します。
getUntilDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
インフレーション指数日付を取得します。
getUntofWght() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
重量単位を取得します。
getUntofWght() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getUomIso() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
単位の ISO コードを取得します。
getUomsortnumber() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
数量単位ソート番号を取得します。
getUomusage() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
使用数量単位を取得します。
getUp() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を取得します。
getUpdateGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
統計更新の更新グループを取得します。
getUpdateInfo() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティの更新情報を取得します。
getUpdateTimestamp() - interface jp.co.intra_mart.foundation.datastore.common.config.UpdateInfo のメソッド
エンティティの更新日付となる属性を取得します。
getUpdateUser() - interface jp.co.intra_mart.foundation.datastore.common.config.UpdateInfo のメソッド
エンティティの更新ユーザとなる属性を取得します。
getUpdateflag() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
更新区分を取得します。
getUpdateflag() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
更新区分を取得します。
getUpdateflag() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
更新区分を取得します。
getUpdateflag() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
更新区分を取得します。
getUrl() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
URLを取得します。
getUrl(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
URLを取得します。
getUrl() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
URLを取得します。
getUrl() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
URLを取得します。
getUrl(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
URLを取得します。
getUrl() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
URLを取得します。
getUrl() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
URLを取得します。
getUrl(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
URLを取得します。
getUrl() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
URLを取得します。
getUrl() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
URLを取得します。
getUrl(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
URLを取得します。
getUrl() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
URLを取得します。
getUrl() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
URLを取得します。
getUrl(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
URLを取得します。
getUrl() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
URLを取得します。
getUrl() - class jp.co.intra_mart.foundation.navigator.LinkPageInfo のメソッド
URL取得
getUrl() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
リンク先のURLを取得します。
getUrl() - class jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet のメソッド
URLを取得します。
getUrl() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ダイレクトＵＲＬを取得する。
getUrl() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ダイレクトＵＲＬを取得する。
getUrl() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ダイレクトＵＲＬを取得する。
getUrl() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
URLを取得します。
getUrl() - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のメソッド
ＵＲＬを取得します。
getUrl() - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
URLを取得します。
getUrlName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ダイレクトＵＲＬをセッションに保管するためパラメータ名を取得する。
getUrlParam(String) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のメソッド
ＵＲＬ引数(Map)の値を取得します。
getUrlParamKeys() - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のメソッド
ＵＲＬ引数(MAP)のキーの一覧を取得します。
getUrlParameterName() - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer のメソッド
ダイレクトＵＲＬリクエストパラメータ名を取得する。
getUrlParameterName() - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
ダイレクトＵＲＬリクエストパラメータ名を取得する。
getUrlSignParameterName() - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer のメソッド
ダイレクトＵＲＬ署名リクエストパラメータ名を取得する。
getUrlSignParameterName() - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
ダイレクトＵＲＬ署名リクエストパラメータ名を取得する。
getUrlSignature() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ダイレクトＵＲＬ署名を取得する。
getUrlSignature() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ダイレクトＵＲＬ署名を取得する。
getUrlSignature() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ダイレクトＵＲＬ署名を取得する。
getUrlSignatureName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ダイレクトＵＲＬ署名をセッションに保管するためパラメータ名を取得する。
getUsStDscr() - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
オブジェクトステータスを取得します。
getUsStNumb() - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
ステータス番号を取得します。
getUsStText() - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
オブジェクトの個別ステータス (簡略形式)を取得します。
getUsageInd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
未使用 - 予約長 3を取得します。
getUsageInd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getUseExceptions() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
例外メッセージ設定とエラーメッセージ出力を取得します。
getUser(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager のメソッド
登録済のユーザを取得します。
getUser() - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
ユーザーを取得します。
getUser() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 ユーザを取得します｡
getUser() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ログインユーザIDを取得する。
getUser() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ログインユーザIDを取得する。
getUser() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインユーザIDを取得する。
getUserAgent() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
ブラウザ情報を取得する。
getUserAgent(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuAnalyzer のメソッド
モバイル端末固体識別番号を取得します。
getUserAgent(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuHdmlAnalyzer のメソッド
推奨されていません。 モバイル端末固体識別番号を取得します。
getUserAgent(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoAnalyzer のメソッド
モバイル端末固体識別番号を取得します。
getUserAgent(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoMoveAnalyzer のメソッド
推奨されていません。 モバイル端末固体識別番号を取得します。
getUserAgent(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginJphoneAnalyzer のメソッド
推奨されていません。 モバイル端末固体識別番号を取得します。
getUserAgent(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginSoftBankAnalyzer のメソッド
モバイル端末固体識別番号を取得します。
getUserAgent(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginVodafoneAnalyzer のメソッド
モバイル端末固体識別番号を取得します。
getUserAgent(String, HttpServletRequest) - interface jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider のメソッド
モバイル端末固体識別番号を取得します。
getUserCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
ユーザコードを取得します。
getUserCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
ユーザコードを取得します。
getUserCode() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
ユーザコードを取得します。
getUserCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
ユーザコードを取得します。
getUserCode() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザコードを取得します。
getUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
ユーザコードを取得します。
getUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
ユーザコードを取得します。
getUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
ユーザコードを取得します。
getUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
ユーザコードを取得します。
getUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザコードを取得します。
getUserFieldChar10_1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目 (10 文字)を取得します。
getUserFieldChar10_1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
10 桁の第 3 ユーザ項目 - WBS 要素を取得します。
getUserFieldChar10_2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目 (10 文字)を取得します。
getUserFieldChar10_2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
10 桁の第 4 ユーザ項目 - WBS 要素を取得します。
getUserFieldChar20_1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
20 文字のユーザ項目を取得します。
getUserFieldChar20_1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
20 文字の第 1 ユーザ項目 - WBS 要素 -を取得します。
getUserFieldChar20_2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
20 文字のユーザ項目を取得します。
getUserFieldChar20_2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
20 桁の第 2 ユーザ項目 - WBS 要素を取得します。
getUserFieldCuky1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ項目: 値項目の単位を取得します。
getUserFieldCuky1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
値項目単位の第１ユーザ定義項目 - WBS 要素を取得します。
getUserFieldCuky1Iso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ISO 通貨コードを取得します。
getUserFieldCuky1Iso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ISO 通貨コードを取得します。
getUserFieldCuky2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ項目: 値項目の単位を取得します。
getUserFieldCuky2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
値項目単位の第２ユーザ定義項目 - WBS 要素を取得します。
getUserFieldCuky2Iso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ISO 通貨コードを取得します。
getUserFieldCuky2Iso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ISO 通貨コードを取得します。
getUserFieldCurr1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
値のユーザ定義項目 (長さ 10,3)を取得します。
getUserFieldCurr1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。
getUserFieldCurr2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
値のユーザ定義項目 (長さ 10,3)を取得します。
getUserFieldCurr2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。
getUserFieldDate1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
日付のユーザ項目を取得します。
getUserFieldDate1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
日付の第 1 ユーザ項目 - WBS 要素を取得します。
getUserFieldDate2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
日付のユーザ項目を取得します。
getUserFieldDate2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
日付の第 2 ユーザ項目 - WBS 要素を取得します。
getUserFieldFlag1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目: レポート区分を取得します。
getUserFieldFlag1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
'評価区分' の第 1 ユーザ項目 - WBS 要素を取得します。
getUserFieldFlag2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目: レポート区分を取得します。
getUserFieldFlag2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
'評価区分' の第 2 ユーザ項目 - WBS 要素を取得します。
getUserFieldKey() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目のキーワード IDを取得します。
getUserFieldKey() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ユーザ定義項目のキーワード IDを取得します。
getUserFieldQuan1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
数量のユーザ項目 (長さ 10,3)を取得します。
getUserFieldQuan1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。
getUserFieldQuan2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
数量のユーザ項目 (長さ 10,3)を取得します。
getUserFieldQuan2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。
getUserFieldUnit1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ項目: 数量項目の単位を取得します。
getUserFieldUnit1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
数量項目単位の第１ユーザ定義項目 - WBS 要素を取得します。
getUserFieldUnit1Iso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getUserFieldUnit1Iso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを取得します。
getUserFieldUnit2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ項目: 数量項目の単位を取得します。
getUserFieldUnit2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
数量項目単位の第２ユーザ定義項目 - WBS 要素を取得します。
getUserFieldUnit2Iso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getUserFieldUnit2Iso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを取得します。
getUserID() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログインユーザIDを取得する。
getUserID() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
ログインユーザIDを取得する。
getUserID() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
ログインユーザIDを取得する。
getUserID() - class jp.co.intra_mart.framework.base.util.UserInfoWrapper のメソッド
ラップされたUserInfoのgetUserID()を呼び出します。
getUserId() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ユーザIDを取得します。
getUserId() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
ログインユーザIDを取得する。
getUserId() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
ユーザID取得。
getUserId() - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel のメソッド
ユーザIDを取得します。
getUserId() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
ユーザIDを取得します。
getUserId() - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel のメソッド
ユーザIDを取得します。
getUserId() - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel のメソッド
ユーザIDを取得します。
getUserIds(String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
ユーザIDの一覧を取得する。
getUserIds(String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
ユーザIDの一覧を取得する。
getUserIds() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
すべてのユーザIDを取得します。
getUserIdsByAccountRole(String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
getUserIdsByAccountRole(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
getUserIdsByAccountRole(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
getUserIdsByAttribute(String, String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウント属性情報の値と一致するユーザIDを取得する。
getUserIdsByAttribute(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント属性情報の値と一致するユーザIDを取得する。
getUserIdsByAttribute(String, String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウント属性情報の値と一致するユーザIDを取得します。
getUserIdsByRole(String, Date) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
有効なロールIDを持つすべてのユーザIDを取得します。
getUserIdsByRoles(String, String[], Date) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
getUserIdsByRoles(String, String[], Date) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
getUserIdsByRolesIn(String, String[], Date) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
getUserIdsByRolesPlural(String, String[], Date) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
getUserImageIcons(String) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
すべてのユーザイメージアイコンを取得します。
getUserInfo() - class jp.co.intra_mart.framework.base.event.Event のメソッド
ログインユーザの情報を取得します。
getUserInfo() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
ユーザ情報を取得します。
getUserInfo() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
ログインユーザ情報を取得します。
getUserInfo(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils の static メソッド
ユーザ情報を取得します。
getUserInfo(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction のメソッド
ユーザ情報を取得します。
getUserManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager の static メソッド
UserManagerを取得します。
getUserName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ユーザＩＤをセッションに保管するためのパラメータ名を取得する。
getUserNameRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
ユーザ名の範囲を取得します。
getUserParameterName() - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer のメソッド
ユーザＩＤリクエストパラメータ名を取得する。
getUserParameterName() - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
ユーザＩＤリクエストパラメータ名を取得する。
getUserStatusList() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
ユーザステータス/指図ステータステーブルを取得します。
getUserStatusList() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
ユーザステータス/指図ステータステーブルを取得します。
getUserTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
指定された期間に対する期間化情報を取得します。
getUserTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
指定された日時に対する期間化情報を取得します。
getUserTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getUserf1Num() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ユーザ定義項目を取得します。
getUserf1Txt() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ユーザ定義項目を取得します。
getUserf2Num() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ユーザ定義項目を取得します。
getUserf2Txt() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ユーザ定義項目を取得します。
getUsername() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
ユーザ名を取得します。
getUsersDeals(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
現在、ユーザがアクセスできる取扱情報を返します。
getUsersDeals(String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
指定された日付にユーザがアクセスできる取扱情報を返します。
getUsersDealsByKey(String, String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
現在、存在する取扱情報の中で、商品と取引先から特定されるものを返します。
getUsersDealsByKey(String, String, String, String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
指定された日時に存在する取扱情報の中で、商品と取引先から特定されるものを返します。
getUsrStatus() - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
ユーザステータスを取得します。
getValArea() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価レベルを取得します。
getValCat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価カテゴリを取得します。
getValClass() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価クラスを取得します。
getValConI() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
金額契約明細を取得します。
getValConI() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getValContr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
金額契約番号を取得します。
getValContr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getValRatio() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
元値に対する修正値の比率 (修正値: 元値)を取得します。
getValRatio() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
元値に対する修正値の比率 (修正値: 元値)を取得します。
getValRatio() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
元値に対する修正値の比率 (修正値: 元値)を取得します。
getValSOrdItem() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
評価受注在庫の受注明細を取得します。
getValSOrdItem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
評価受注在庫の受注明細を取得します。
getValSalesOrd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
評価受注在庫の受注番号を取得します。
getValSalesOrd() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
評価受注在庫の受注番号を取得します。
getValType() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
評価タイプを取得します。
getValType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
評価タイプを取得します。
getValType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価タイプを取得します。
getValType() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
評価タイプを取得します。
getValType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
評価タイプを取得します。
getValType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getValWbsElem() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
WBS 要素を取得します。
getValWbsElem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
WBS 要素を取得します。
getValcode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
値タイプ: 範囲制限 - 単一値を取得します。
getValcount() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
階層ノード内の値の値数を取得します。
getValfrom() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues のメソッド
原価センタ/利益センタを取得します。
getValidEndDate() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
有効終了日を取得します。
getValidEndDate() - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のメソッド
有効終了日を取得します。
getValidEndDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
有効終了日を取得します。
getValidEndDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel のメソッド
有効終了日を取得します。
getValidEndYear() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
有効終了年を取得します。
getValidEndYear() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
有効終了年を取得します。
getValidFlg() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
有効フラグを取得します。
getValidFrom() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
エントリの有効開始日を取得します。
getValidFrom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
流通チェーン別品目ステータスの有効期間開始日を取得します。
getValidFrom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
原価有効開始日を取得します。
getValidFrom() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
見積または基本契約の有効開始日を取得します。
getValidStartDate() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
有効開始日取得。
getValidStartDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
有効開始日を取得します。
getValidStartDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel のメソッド
有効開始日を取得します。
getValidStartYear() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
有効開始年を取得します。
getValidStartYear() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
有効開始年を取得します。
getValidTo() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
有効終了日を取得します｡
getValidTo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタを指定して有効終了日を取得します。
getValidTo() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
見積または基本契約有効終了日を取得します。
getValidationExceptionDetails() - class jp.co.intra_mart.framework.base.service.validator.ValidationException のメソッド
検証結果の詳細の一覧を取得します。
getValidatorClassName() - class jp.co.intra_mart.framework.base.service.ValidatorMapping のメソッド
バリデータ名を取得します。
getValidatorConfig() - class jp.co.intra_mart.framework.base.service.ValidatorMapping のメソッド
バリデータの初期化パラメータを取得します。
getValidatorMapping(String, String, Locale) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
バリデータを取得します。
getValidators() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventComponentBuilder のメソッド
バリデータの配列を返します。
getValidators(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド

getValidators(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド

getValidators(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
キーに該当するバリデータを取得します。
getValidators(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド

getValidators(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
キーに該当するバリデータを取得します。
getValto() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues のメソッド
原価センタ/利益センタを取得します。
getValuationData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
評価データを取得します。
getValuationDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
評価データが既に存在するかチェックします。
getValuationDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
評価データを取得します。
getValuationarea() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
評価レベルを取得します。
getValuationtype() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
評価タイプを取得します。
getValue() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
データ部を文字列表現として返します。
getValue(ResultSet, int) - interface jp.co.intra_mart.foundation.database.DBResultAdapter のメソッド
カラムからデータを取得します。
getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultArrayAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultBigDecimalAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultBigIntAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultBinaryAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultBlobAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultBooleanAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultByteAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultClobAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultDateAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultDoubleAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultImTimestampAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultIntegerAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultNullAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultObjectAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultRealAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultRefAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultShortAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultStringAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultStructAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultTimeAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultTimestampAdapter のメソッド

getValue() - class jp.co.intra_mart.foundation.datastore.exporter.Filter のメソッド
フィルタリングされる値の配列を返します。
getValue() - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
CO-PA 特性値を取得します。
getValue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
特性値を取得します。
getValue() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値を取得します。
getValue() - class jp.co.intra_mart.framework.base.web.tag.MessageParamTag のメソッド
パラメータの値を取得します。
getValue() - class jp.co.intra_mart.framework.base.web.tag.ParamTag のメソッド
パラメータの値を取得します。
getValue() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性valueを取得します。
getValue() - class jp.co.intra_mart.framework.system.property.PropertyParam のメソッド
パラメータの値を取得します。
getValueAsReader() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
推奨されていません。 RequestParameter.getValueAsReader(String) に置き換えられました。
getValueAsReader(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
データ部を Reader として取得します。
getValueAsStream() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
データ部を入力ストリームとして取得します。
getValueChanged() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンによる金額変更を取得します。
getValueLength() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
データ部のバイト長を返します。
getValueTo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
特性値を取得します。
getValueTxt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
特性値の言語依存テキストを取得します。
getValueduom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ロット特定数量単位での評価を取得します。
getValuepart1() - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart1() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart1() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart1() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart2() - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart2() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart2() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart2() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart3() - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart3() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart3() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart3() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart4() - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart4() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart4() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
長さ 229 の文字データのコンテナを取得します。
getValuepart4() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
長さ 229 の文字データのコンテナを取得します。
getValuepart4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValues() - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のメソッド
エラーメッセージで使用する置換用の文字列を取得します。
getVarOrdUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
可変購買発注単位有効を取得します。
getVarSalesUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
可変販売単位の使用不可を取得します。
getVarcond() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
バリアント条件を取得します。
getVarcond() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
バリアント条件を取得します。
getVariableInfo(TagData) - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI のメソッド
スクリプティング変数に関連付けたHelperBeanの情報を取得します。
getVarianceKey() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
差異キーを取得します。
getVatCntry() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
売上税 ID 番号国を取得します。
getVatCntryIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
消費税登録番号の ISO 国コードを取得します。
getVclassPp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期評価クラスを取得します。
getVclassPy() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度の評価クラスを取得します。
getVendMat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
仕入先が使用している品目コードを取得します。
getVendName() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
名称 1を取得します。
getVendPart() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先部門を取得します。
getVendUser() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
仕入先担当者を取得します。
getVendor() - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
仕入先または債権者の勘定コードを取得します。
getVendor() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
仕入先または債権者の勘定コードを取得します。
getVendor() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
仕入先または債権者の勘定コードを取得します。
getVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
仕入先勘定コードを取得します｡
getVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
仕入先コードを取得します｡
getVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のメソッド
仕入先コードを取得します｡
getVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のメソッド
仕入先コードを取得します｡
getVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
仕入先勘定コードを取得します。
getVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
仕入先勘定コードを取得します。
getVendorNo() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
仕入先または債権者の勘定コードを取得します。
getVendorRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
仕入先の範囲を取得します。
getVendrbatch() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先ロット番号を取得します。
getVendrbatch() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
仕入先ロット番号を取得します。
getVerGrGiSlip() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入出庫票の印刷バ－ジョンを取得します。
getVerGrGiSlipx() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
関連ユーザデータ項目の更新情報を取得します。
getVersion(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
現在の会社構成バージョン情報を取得します。
getVersion(String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
指定された日付の会社構成バージョン情報を取得します。
getVersion(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
現在のパブリックグループセット構成バージョン情報を取得します。
getVersion(String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
指定された日付のパブリックグループセット構成バージョン情報を取得します。
getVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買管理におけるバージョン番号を取得します。
getVersion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売伝票バージョン番号を取得します。
getVersion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getVersion() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
バージョンを取得します。
getVersionCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
バージョンコードを取得します。
getVersionCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
バージョンコードを取得します。
getVersionCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
バージョンコードを取得します。
getVersionCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
バージョンコードを取得します。
getVersionCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
バージョンコードを取得します。
getVersionCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
バージョンコードを取得します。
getVersionFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
バージョン区分を取得します。
getVersions() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
バージョン管理を取得します｡
getVirtCard() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
チェックボックスを取得します。
getVkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
バリアント条件名を取得します。
getVmPStock() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
プロジェクト在庫の評価クラスを取得します。
getVmSoStk() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
受注在庫の評価クラスを取得します。
getVolTolLt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
荷役単位の容積超過許容量を取得します。
getVolume() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
容積を取得します。
getVolume() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
容積を取得します。
getVolume() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細の総数量を取得します。
getVolume() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getVolumeunit() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
容積単位を取得します。
getVolumeunit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
容積単位を取得します。
getVolumeunitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ISO コードでの容積単位を取得します。
getVolumeunitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ISO コードでの容積単位を取得します。
getVolunit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
容積単位を取得します。
getVolunit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getVolunitiso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ISO コードでの容積単位を取得します。
getVperEnd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
有効期間終了日を取得します｡
getVperStart() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
有効期間開始日を取得します｡
getVwUepos() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
上位レベル明細用途 IDを取得します。
getVwUepos() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getWagetype() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ウェイジタイプを取得します。
getWaitTime() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
コネクション取得の待機時間を取得します。
getWaitTime() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 コネクション取得の待機時間を取得します｡
getWarDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
保証期間の開始日付を取得します。
getWarDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getWarehouseNumberData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
倉庫番号データを取得します。
getWarehouseNumberDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
倉庫番号データが既に存在するかチェックします。
getWarehouseNumberDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
倉庫番号データを取得します。
getWarehouseView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
倉庫管理ビューを取得します。
getWarehouseView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
倉庫管理ビューを取得します。
getWarehousenumber() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
倉庫番号/複合倉庫を取得します。
getWarnings() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection に関する呼び出しによって通知された最初の警告を返します。
getWarranty() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
保証日を取得します｡
getWbsAccountAssignmentElement() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
区分: 勘定設定要素を取得します。
getWbsActualDurUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
実績 WBS 要素日付の期間単位を取得します。
getWbsActualDurUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを取得します。
getWbsActualDuration() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の実績長(期間)を取得します。
getWbsActualFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の実績終了日を取得します。
getWbsActualStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の実績開始日付を取得します。
getWbsBasicDurUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
基準 WBS 要素日付の期間単位を取得します。
getWbsBasicDurUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを取得します。
getWbsBasicDuration() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の基準日の長さ(期間)を取得します。
getWbsBasicFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素: 基本終了日付を取得します。
getWbsBasicStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素: 基本開始日を取得します。
getWbsBillingElement() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
区分: 請求要素を取得します。
getWbsCctrPostedActual() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
原価が実際に転記される原価センタを取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
作業詳細項目要素 (WBS 要素)を取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
WBS 要素を取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
WBS 要素を取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
WBS 要素を取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
WBS 要素を取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
WBS 要素を取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
WBS 要素を取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getWbsElement() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
WBS 要素を取得します。
getWbsElement() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素を取得します。
getWbsElement() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を取得します。
getWbsElement() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
WBS 要素を取得します。
getWbsElement() - class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement のメソッド
WBS 要素を取得します。
getWbsElement() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
WBS 要素を取得します。
getWbsElementExt() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
WBS 要素を取得します。
getWbsForcastDurUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素計画日付の単位を取得します。
getWbsForecastDurUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを取得します。
getWbsForecastDuration() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の予測期間を取得します。
getWbsForecastFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の予測済終了日付を取得します。
getWbsForecastStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の予測開始日を取得します。
getWbsPlanningElement() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
区分: 計画要素を取得します。
getWbsScdActualFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の仮実績終了日を取得します。
getWbsScdActualStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の仮実績開始日を取得します。
getWbsScdBasicFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
最遅計画終了日 (基準)を取得します。
getWbsScdBasicStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
最早計画開始日 (基準)を取得します。
getWbsScdForecastFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
最遅計画終了日 (予測)を取得します。
getWbsScdForecastStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
計画開始日 (予測)を取得します。
getWbsSchedProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
WBS 日程計画のプロファイルを取得します。
getWeek() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
週を取得します。
getWeek() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
週を取得します。
getWeekdayInfos() - class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo のメソッド
データタイプが非休日であるカレンダーデータの一覧を取得します。
getWeightunit() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
重量単位を取得します。
getWeightunitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
重量単位のISOコードを取得します。
getWhseNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
倉庫番号/複合倉庫を取得します。
getWhseNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
倉庫番号/複合倉庫を取得します。
getWidth() - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルの幅を返却します。
getWidth() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
表示単位に対する幅を取得します。
getWidth() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
幅を取得します。
getWithActivities() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
従属活動を取得します。
getWithActivities() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
従属活動を取得します。
getWithMilestones() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
従属 WBS マイルストーンを取得します。
getWithMilestones() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
従属 WBS マイルストーンを取得します。
getWithSubtree() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
サブプロジェクトを取得します。
getWithSubtree() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
サブプロジェクトを取得します。
getWithdrawal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
在庫払出に対する保管域タイプ区分を取得します。
getWithdrawn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫予定に対する出庫完了を取得します。
getWithdrawn() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入出庫予定に対する出庫完了を取得します。
getWmUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
倉庫管理の数量単位を取得します。
getWmUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードでの倉庫管理単位を取得します。
getWmdvexList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
出力テーブル (日付および ATP 数量)を取得します。
getWmdvsxList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
入力テーブル (日付/数量)を取得します。
getWorkActivity() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動に含まれる作業を取得します。
getWorkActual() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
実績作業を取得します。
getWorkCntr() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
作業区を取得します。
getWorkForecast() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予測作業 (実績 + 残存)を取得します。
getWorkPermit() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
仕事許可済フラグを取得します。
getWorkSchedView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
作業計画ビューを取得します。
getWorkSchedView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
作業計画ビューを取得します。
getWriter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。
getWriter(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。
getWriter(HttpServletRequest, ExtendedHttpServletResponse) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。
getWriter(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。
getWtTolLt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
荷役単位の重量超過許容量を取得します。
getWtWithcd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
源泉徴収税コードを取得します。
getWtgGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
加重グループを取得します。
getXAutoCre() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
自動登録済み明細を取得します。
getXMLString(Document) - class jp.co.intra_mart.extension.maskat.util.XMLUtil の static メソッド
XML文字列を取得します。
getXMailerHeader() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
送信メールに付加するX-Mailerヘッダを取得します。
getXstob() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取消移動タイプ区分の使用を取得します。
getYear() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
年を取得します。
getYear() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
年を取得します。
getYline() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
内部テ－ブル処理の行索引を取得します。
getZipCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
郵便番号を取得します。
getZipCode(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
郵便番号を取得します。
getZipCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
郵便番号を取得します。
getZipCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
郵便番号を取得します。
getZipCode(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
郵便番号を取得します。
getZipCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
郵便番号を取得します。
getZipCode() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
郵便番号を取得します。
getZipCode(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
郵便番号を取得します。
getZipCode() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
郵便番号を取得します。
getZipCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
郵便番号を取得します。
getZipCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
郵便番号を取得します。
getZipCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
郵便番号を取得します。
getZipCode() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
郵便番号を取得します。
getZipCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
郵便番号を取得します。
getZipCode() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
郵便番号を取得します。
getenv(String) - class jp.co.intra_mart.foundation.http.CGIEnvironment のメソッド
値の取得。
groupSetAdded(String, PublicGroupSet) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
グループセットがデータストアに登録された後に呼び出されます。
groupSetAdded(String, PublicGroupSet) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
グループセットがデータストアに登録された後に呼び出されます。
groupSetAdded(String, PublicGroupSet) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
グループセットがデータストアに登録された後に呼び出されます。
groupSetDeleted(String, PublicGroupSet) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
グループセットがデータストアから削除された後に呼び出されます。
groupSetDeleted(String, PublicGroupSet) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
グループセットがデータストアから削除された後に呼び出されます。
groupSetDeleted(String, PublicGroupSet) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
グループセットがデータストアから削除された後に呼び出されます。

H

HOME_PARAM - class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory の static 変数
ホームインタフェースを取得するときのJNDI名のパラメータ名
HTMLEncoder - class jp.co.intra_mart.framework.base.web.util.HTMLEncoder.
文字列をHTML形式で表示するための変換を行うユーティリティクラスです。
HTMLEncoder() - class jp.co.intra_mart.framework.base.web.util.HTMLEncoder のコンストラクタ

HTTPActionEvent - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent.
Application Runtime で実行されるイベントのためのインターフェースです。
HTTPActionEventClientContext - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext.
Application Runtime で実行されるイベントの実行を要求した クライアントに関する情報インターフェースです。
HTTPActionEventContent - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent.
Web コンテンツを取得するための共通インターフェースです。
HTTPActionEventContext - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext.
Application Runtime で実行されるイベントに関する情報インターフェースです。
HTTPActionEventEntityHandler - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler.
HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventEntityHandler() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のコンストラクタ
新しいイベントハンドラを作成します。
HTTPActionEventException - exception jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException.
HTTPActionEvent に関するエラーを通知するための例外です。
HTTPActionEventException(String) - class jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventException(String, Throwable) - class jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
HTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler.
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
HTTPActionEventFilterHandler(HTTPActionEventHandler) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のコンストラクタ
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラを作成します。
HTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler.
HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のコンストラクタ
新しいイベントハンドラを作成します。
HTTPActionEventHandlerException - exception jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException.
HTTPActionEventHandler 内で発生したエラーを通知するための例外です。
HTTPActionEventHandlerException(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerException(String, Throwable) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerParameterException - exception jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException.
HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。
HTTPActionEventHandlerParameterException(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerParameterException(String, Throwable) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
HTTPActionEventListenerContext - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext.
Application Runtime でイベントの実行制御を行うリスナーに関する情報インターフェースです。
HTTPActionEventResult - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult.
HTTPActionEvent 実行要求の結果に関する共通インターフェースです。
HTTPActionEventResultWrapper - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper.
HTTPActionEventResult のラッパーオブジェクトです。
HTTPActionEventResultWrapper(HTTPActionEventResult) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のコンストラクタ
指定の結果オブジェクトをラップする新しい結果オブジェクトを作成します。
HTTPActionEventURL - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL.
Web コンテンツへのアクセスＵＲＬを取得するための共通インターフェースです。
HTTPContext - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext.
リクエスト、レスポンス、および サーブレットコンテキストへのアクセスを提供します。
HTTPContextHandlingFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter.
このフィルタを利用することにより、 HTTPContextManager経由で HTTPContextを取得できるようになります。
HTTPContextHandlingFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter のコンストラクタ
デフォルト・コンストラクタ
HTTPContextManager - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager.
HTTP コンテキスト・マネージャ
HTTPContextManager() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager のコンストラクタ
デフォルトコンストラクタ HTTPContextManager.getInstance()を利用してください。
HalfKanaTransrateListener - class jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener.
送信メールの件名と本文に含まれる半角カナ文字を、全角カナ文字に変換するリスナです。
HalfKanaTransrateListener() - class jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener のコンストラクタ
HalfKanaTransrateListenerを新規に生成します。
HeadData - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData.
管理情報設定ヘッダセグメント情報クラス
機能は以下の通り
管理情報設定ヘッダセグメント情報を保持します。
HeadData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のコンストラクタ
管理情報設定ヘッダセグメント情報を作成します。
HeadData(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のコンストラクタ
管理情報設定ヘッダセグメント情報を作成します。
HeaderIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn.
販売伝票ヘッダデータ情報クラス
機能は以下の通り
販売伝票ヘッダデータ情報を保持します。
HeaderIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のコンストラクタ
販売伝票ヘッダデータ情報を作成します。
HeaderInX - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX.
ヘッダデータチェックボックス情報クラス
機能は以下の通り
ヘッダデータチェックボックス情報を保持します。
HeaderInX() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のコンストラクタ
ヘッダデータチェックボックス情報を作成します。
HelperBean - class jp.co.intra_mart.framework.base.web.bean.HelperBean.
画面表示をする時のヘルパークラスです。
HelperBean() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のコンストラクタ
HelperBeanを新規に生成します。
HelperBeanException - exception jp.co.intra_mart.framework.base.web.bean.HelperBeanException.
HelperBean内で発生した例外です。
HelperBeanException() - class jp.co.intra_mart.framework.base.web.bean.HelperBeanException のコンストラクタ
詳細メッセージを指定しないで HelperBeanException を構築します。
HelperBeanException(String) - class jp.co.intra_mart.framework.base.web.bean.HelperBeanException のコンストラクタ
指定された詳細メッセージを持つ HelperBeanException を構築します。
HelperBeanException(String, Throwable) - class jp.co.intra_mart.framework.base.web.bean.HelperBeanException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ HelperBeanException を構築します。
HelperBeanTEI - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI.
HelperBeanタグの拡張情報です。
HelperBeanTEI() - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI のコンストラクタ
HelperBeanTEIを新規に生成します。
HelperBeanTag - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag.
HelperBeanタグです。
HelperBeanTag() - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag のコンストラクタ
HelperBeanTagを新規に生成します。
HelperBeanTagBeanInfo - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo.
HelperBeanTagのBeanInfoです。
HelperBeanTagBeanInfo() - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo のコンストラクタ
HelperBeanTagBeanInfoを新規に生成します。
HexInputStream - class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream.
このクラスは、16進数表現されたデータを読み込むための ストリームフィルタを実装します。
HexInputStream(InputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream のコンストラクタ
指定された InputStream から読み込む HexInputStream を作成します。
HexInputStream - class jp.co.intra_mart.foundation.utility.io.HexInputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream クラスを使用してください。
HexInputStream(InputStream) - class jp.co.intra_mart.foundation.utility.io.HexInputStream のコンストラクタ
推奨されていません。 指定された InputStream から読み込む HexInputStream を作成します。
HexOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream.
このクラスは、16進数表現されたデータを書き込むための ストリームフィルタを実装します。
HexOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream のコンストラクタ
指定された OutputStream に書き込む HexOutputStream を作成します。
HexOutputStream - class jp.co.intra_mart.foundation.utility.io.HexOutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream クラスを使用してください。
HexOutputStream(OutputStream) - class jp.co.intra_mart.foundation.utility.io.HexOutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に書き込む HexOutputStream を作成します。
HierarchyNodes - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes.
階層ノード情報クラス 機能は以下の通り
階層ノード情報を保持します。
HierarchyNodes() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のコンストラクタ
階層ノードを作成します。
HierarchyValues - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues.
階層値情報クラス 機能は以下の通り
階層値情報を保持します。
HierarchyValues() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues のコンストラクタ
階層値を作成します。
HomeDirectory - class jp.co.intra_mart.foundation.service.provider.HomeDirectory.
このクラスは、サーバ実行システムのホームディレクトリに関する機能を 提供します。
HttpServletRequestMessageBodyWrapper - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper.
HttpServletRequest を拡張したインタフェースです。
HttpServletRequestMessageBodyWrapperBuilder - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder.
HttpServletRequest を拡張したインタフェースです。
HttpServletResponseEventComponentBuilder - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventComponentBuilder.
レスポンスイベントに関わる各種コンポーネント（リスナやバリデータ）をを構築するビルダです。
HttpServletResponseEventConfig - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventConfig.
レスポンスの各メソッド呼び出しに対するイベントを 設定するためのオブジェクトです。
HttpServletResponseEventController - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController.
レスポンスイベントコントローラのインタフェース。
HttpServletResponseEventControllerBuilder - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerBuilder.
コントローラを構築するビルダです。
HttpServletResponseEventControllerException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerException.
コントローラに関わる処理中にエラーが発生した事を通知する例外です。
HttpServletResponseEventControllerException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerException のコンストラクタ
詳細メッセージを null にして、新規例外を構築します。
HttpServletResponseEventControllerException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventControllerException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventControllerException(Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerException のコンストラクタ
指定された原因を使用して新規例外を構築します。
HttpServletResponseEventException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException.
イベントに関わる処理中にエラーが発生した事を通知する例外です。
HttpServletResponseEventException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException のコンストラクタ
詳細メッセージを null にして、新規例外を構築します。
HttpServletResponseEventException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventException(Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException のコンストラクタ
指定された原因を使用して新規例外を構築します。
HttpServletResponseEventFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilter.
サーブレットレスポンスの各メソッド呼び出しに対するリスナを設定するフィルタ。
HttpServletResponseEventFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilter のコンストラクタ
新しいフィルタを作成します。
HttpServletResponseEventFilterException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilterException.
レスポンスイベントを定義するフィルタでエラーが発生した事を通知する例外です。
HttpServletResponseEventFilterException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilterException のコンストラクタ
詳細メッセージを null にして、新規例外を構築します。
HttpServletResponseEventFilterException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilterException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventFilterException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilterException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventFilterException(Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilterException のコンストラクタ
指定された原因を使用して新規例外を構築します。
HttpServletResponseEventListener - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener.
レスポンスの各メソッド呼び出しに対するイベントをフックするためのインタフェースです。
HttpServletResponseEventListenerException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListenerException.
レスポンスリスナに関わる処理中にエラーが発生した事を通知する例外です。
HttpServletResponseEventListenerException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListenerException のコンストラクタ
詳細メッセージを null にして、新規例外を構築します。
HttpServletResponseEventListenerException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListenerException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventListenerException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListenerException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventListenerException(Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListenerException のコンストラクタ
指定された原因を使用して新規例外を構築します。
HttpServletResponseEventValidator - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidator.
レスポンスイベントが有効か無効かを判定するバリデータ。
HttpServletResponseEventValidatorException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidatorException.
バリデータに関わる処理中にエラーが発生した事を通知する例外です。
HttpServletResponseEventValidatorException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidatorException のコンストラクタ
詳細メッセージを null にして、新規例外を構築します。
HttpServletResponseEventValidatorException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidatorException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventValidatorException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidatorException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventValidatorException(Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidatorException のコンストラクタ
指定された原因を使用して新規例外を構築します。
HttpSessionFactory - class jp.co.intra_mart.framework.base.session.HttpSessionFactory.
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
HttpSessionFactory() - class jp.co.intra_mart.framework.base.session.HttpSessionFactory のコンストラクタ
推奨されていません。 HttpSessionFactoryを新規に生成します。
HttpSessionManager - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager.
HttpSession に関する情報を提供するクラスの共通インタフェース定義です。
HttpSessionManagerFactory - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory.
HttpSessionManager を作成するファクトリクラスの抽象実装です。
HttpSessionManagerFactory() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory のコンストラクタ
新しい HttpSessionManagerFactory を構築します。
HttpSessionMonitoringFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter.
HttpSessionManagerFactory#instance() が返す、 HttpSessionManagerFactory および HttpSessionManager の 標準実装と連動するフィルタです。
HttpSessionMonitoringFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter のコンストラクタ
新しい HttpSessionMonitoringFilter を構築します。
HttpSessionMonitoringListener - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener.
HttpSessionManagerFactory#instance() が返す、 HttpSessionManagerFactory および HttpSessionManager の 標準実装と連動するセッションリスナです。
HttpSessionMonitoringListener() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener のコンストラクタ
新しいセッションリスナを構築します。
HttpSessionObject - class jp.co.intra_mart.framework.base.session.HttpSessionObject.
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
HttpSessionObject(HttpSession) - class jp.co.intra_mart.framework.base.session.HttpSessionObject のコンストラクタ
推奨されていません。 HttpSessionObjectを新規に生成します。
handleDestroy() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
フィルタの破棄処理。
handleDestroy() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter のメソッド

handleDestroy() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter のメソッド
フィルタの破棄処理。
handleDestroy() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter のメソッド
フィルタの破棄処理。
handleError(ErrorEvent) - interface jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener のメソッド
発生した例外を通知します。
handleEvent() - interface jp.co.intra_mart.common.aid.jdk.util.EventListener のメソッド
イベントが発生した時にコントローラから呼び出されます。
handleEvent() - interface jp.co.intra_mart.foundation.utility.EventListener のメソッド
推奨されていません。 イベントが発生した時にコントローラから呼び出されます。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
フィルタの初期化をします。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
このリスナを初期化します。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
このリスナを初期化します。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter のメソッド
フィルタの初期化をします。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter のメソッド

handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilter のメソッド
フィルタの初期化をします。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter のメソッド
フィルタの初期化をします。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter のメソッド
フィルタの初期化をします。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter のメソッド
このフィルタを初期化します。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter のメソッド
フィルタの初期化をします。
handleInit() - class jp.co.intra_mart.foundation.security.filter.ActiveSessionFilter のメソッド
初期化します。
handleInit() - class jp.co.intra_mart.foundation.security.filter.DuplicateLoginHandlingFilter のメソッド
初期化します。
handleInit() - class jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter のメソッド
初期化します。
handleInit() - class jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter のメソッド
このフィルタを初期化します。
handleShutdown() - interface jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownListener のメソッド
シャットダウンイベントが発生したときに実行されるメソッドです。
handleShutdown() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
シャットダウンイベントが発生したときに実行されるメソッドです。
handleSocketEvent(ExtendedSocket) - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener のメソッド
ソケットに関するイベント発生時に呼び出されるメソッド。
handleSocketEvent(ExtendedSocket) - interface jp.co.intra_mart.foundation.utility.net.SocketEventListener のメソッド
推奨されていません。 ソケットに関するイベント発生時に呼び出されるメソッド。
handleThreadStop() - interface jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener のメソッド
監視していたスレッドが終了したときに実行されるメソッドです。
handleThreadStop() - interface jp.co.intra_mart.foundation.utility.ThreadStopListener のメソッド
推奨されていません。 監視していたスレッドが終了したときに実行されるメソッドです。
hasActiveSessionInfo(String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたセッションIDのアクティブなセッション情報が存在するかチェックします。
hasArguments() - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
コマンドライン引数があるかどうか判定します。
hasBaseAttributes() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張エンティティが期間化も国際化もされていない従属属性を持つかどうか判定します。
hasChildNode(TreeNode) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
指定されたノード node を持っているか調べます。
hasChildNodes() - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
このノードが子ノードを持っているかどうかを判断します。
hasChildNodes() - interface jp.co.intra_mart.foundation.page.TreeNodeContainer のメソッド
このノードが子ノードを持っているかどうかを判断します。
hasChildren() - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
子メニューが存在するかどうかを取得します。
hasHeader(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
指定された文字列がヘッダの名称かどうかを判定します。
hasHeaders() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
このオブジェクトがヘッダ情報を持つかどうかを判定します。
hasInternationalAttributes() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張エンティティが国際化のみされている従属属性を持つかどうか判定します。
hasOption(String) - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
オプションが指定されているかどうか判定します。
hasParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
hasParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
hasParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
hasPool(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolManager の static メソッド
コネクションプール内に、引数にて渡されたJCOコネクション名が存在しているか判定します。
hasProperty(String) - interface jp.co.intra_mart.foundation.scenario.VariableScope のメソッド
プロパティが存在しているかをチェックします。
hasReporter(MessageReporter) - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。
hasReporter(MessageReporter) - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。
hasTerminableAttributes() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張エンティティが期間化のみされている従属属性を持つかどうか判定します。
hasTerminableInternationalAttributes() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張エンティティが期間国際化されている従属属性を持つかどうか判定します。
hashCode() - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
このリストのハッシュコード値を返します。
hashCode() - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
有効期間のハッシュコード値を返します。
hashCode() - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 このリストのハッシュコード値を返します。
hashCode() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
このオブジェクトに対するハッシュコード値を返します。
hashCode() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ハッシュコードを取得します。
hashCode() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
ハッシュコード値取得。
hashCode() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
ハッシュコードを取得します。
hashCode() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
ハッシュコードを取得します。
hashCode() - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
ハッシュコードを取得します。
hashCode() - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ハッシュコードを取得します。

I

I18nAttributes - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes.
国際化の属性です。
I18nAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes のコンストラクタ
I18nAttributesを新規に生成します。
ID - class jp.co.intra_mart.framework.base.data.ConnectorModel の static 変数

ID - class jp.co.intra_mart.framework.base.data.DaoModel の static 変数

ID - class jp.co.intra_mart.framework.base.data.ResourceModel の static 変数

ID - class jp.co.intra_mart.framework.base.event.EventFactoryModel の static 変数

ID - class jp.co.intra_mart.framework.base.event.EventGroupModel の static 変数

ID - class jp.co.intra_mart.framework.base.service.ControllerConverterModel の static 変数

ID - class jp.co.intra_mart.framework.base.service.ValidatorModel の static 変数

ID_CRYPTION_CLASS - class jp.co.intra_mart.foundation.security.StandardAccountAccessor の static 変数
暗号化クラス名
ID_CRYPTION_CLASS - class jp.co.intra_mart.foundation.security.account.CsvAccountBackup の static 変数
暗号化クラス名
ID_CRYPTION_CLASS - class jp.co.intra_mart.foundation.security.account.StandardAccountBackup の static 変数
暗号化クラス名
ID_NAVIGATOR_ACCESS_INFO - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
ACCESS INFO
ID_NAVIGATOR_COMMENT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_COMPANY_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_DEPARTMENT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_DEPARTMENT_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_EVENT_FLOW - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
EVENT FLOW
ID_NAVIGATOR_EVENT_FLOW_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_EVENT_FLOW_OPEN - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_EVENT_FLOW_SORT_NUMBER - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_EVENT_ITEM - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
EVENT ITEM
ID_NAVIGATOR_EVENT_ITEM_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_EVENT_RESULT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
EVENT RESULT
ID_NAVIGATOR_EVENT_RESULT_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_GROUP_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_GROUP_SET_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_ITEM_TYPE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_LINK_PAGE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
LINK PAGE
ID_NAVIGATOR_LOCALE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_PARAM - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_PARAM_KEY - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_PARAM_VALUE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_POST - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_POST_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_PUBLIC_GROUP - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_RESULT_PAGE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
RESULT PAGE
ID_NAVIGATOR_RESULT_PAGE_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_RESULT_PAGE_LIST - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_ROLE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_ROLE_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_SELECT_ITEM - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
SELECT ITEM
ID_NAVIGATOR_SELECT_ITEM_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_SELECT_ITEM_LIST - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_TITLE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_TITLE_INFO - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
TITLE INFO
ID_NAVIGATOR_URL - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_ROOT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_ROOT_NAVIGATOR - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_SECURITY_ACCOUNT - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler の static 変数

ID_SECURITY_GROUP - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler の static 変数

ID_SECURITY_PASSWORD - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler の static 変数

ID_SERVICE_SECURITY_FILTER - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter の static 変数
リクエストに登録するServiceServletFilterの属性名
IMAGE_PATH - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel の static 変数
イメージパス
IMAGE_PATH - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の static 変数
イメージパス
IMContainer - interface jp.co.intra_mart.framework.system.container.IMContainer.
イントラマートコンテナのインターフェースです。
IMContainerException - exception jp.co.intra_mart.framework.system.exception.IMContainerException.
イントラマートコンテナ内で発生した例外です。
IMContainerException() - class jp.co.intra_mart.framework.system.exception.IMContainerException のコンストラクタ
詳細メッセージを指定しないで IMContainerException を構築します。
IMContainerException(String) - class jp.co.intra_mart.framework.system.exception.IMContainerException のコンストラクタ
指定された詳細メッセージを持つ IMContainerException を構築します。
IMContainerException(Throwable) - class jp.co.intra_mart.framework.system.exception.IMContainerException のコンストラクタ
この例外の発生原因となる例外を持つ IMContainerException を構築します。
IMContainerException(String, Throwable) - class jp.co.intra_mart.framework.system.exception.IMContainerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IMContainerException を構築します。
IMContainerFactory - interface jp.co.intra_mart.framework.system.container.factory.IMContainerFactory.
ServiceContainerのクラスです。
IMDiskFileItem - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem.
ヘッダ情報を追加したFileItemの実装クラスです。
IMDiskFileItem(String, String, boolean, String, int, File, Map) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のコンストラクタ
コンストラクタ
IMDiskFileItemFactory - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItemFactory.
ヘッダ情報を含むFileItemを生成するFactoryです。
IMDiskFileItemFactory() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItemFactory のコンストラクタ
デフォルトコンストラクタ
IMDiskFileItemFactory(int, File) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItemFactory のコンストラクタ
コンストラクタ
IMFileItemFactory - interface jp.co.intra_mart.common.aid.javaee.http.fileupload.IMFileItemFactory.
ヘッダ情報を含むFileItemを生成するFactoryです。
IMMultipartStream - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMMultipartStream.
ヘッダの文字エンコーディングを変換しないMultipartStreamです。
IMMultipartStream() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMMultipartStream のコンストラクタ
デフォルトコンストラクタ
IMMultipartStream(InputStream, byte[]) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMMultipartStream のコンストラクタ
コンストラクタ。
IMServletFileUpload - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload.
ヘッダ情報を扱えるようにしたFileUploadクラスです。
IMServletFileUpload() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload のコンストラクタ
デフォルトコンストラクタ
IMServletFileUpload(FileItemFactory) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload のコンストラクタ
コンストラクタ
IM_AJAX_USER_AGENT_FIREFOX - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static 変数
「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Firefox
IM_AJAX_USER_AGENT_IE - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static 変数
「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Internet Explorer
IM_AJAX_USER_AGENT_NETSCAPE - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static 変数
「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Netscape
IM_AJAX_USER_AGENT_OPERA - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static 変数
「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Opera
IM_AJAX_USER_AGENT_SAFARI - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static 変数
「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Safari
INDEX_UNDEFINED - class jp.co.intra_mart.foundation.database.DatabaseColumn の static 変数

INFO_NODE - class jp.co.intra_mart.extension.maskat.util.MKError の static 変数
infoのノード名
INTRAMART_URL_NAME - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 セッションに登録するintra-martのサーブレットのURLの属性名
INTRAMART_URL_NAME - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.INTRAMART_URL_NAMEを使用してください。
INonTransaction - interface jp.co.intra_mart.foundation.security.INonTransaction.
分散トランザクション未対応のアクセッサに実装するインターフェース。
ITEM_CAPTION - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel の static 変数
商品通称
ITEM_CATALOGUE_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel の static 変数
商品カタログコード
ITEM_CATEGORY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel の static 変数
商品カテゴリコード
ITEM_CATEGORY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel の static 変数
商品カテゴリコード
ITEM_CATEGORY_NAME - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel の static 変数
商品カテゴリ名
ITEM_CATEGORY_TYPE_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel の static 変数
商品カテゴリ種別コード
ITEM_CATEGORY_TYPE_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel の static 変数
商品カテゴリ種別コード
ITEM_CATEGORY_TYPE_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel の static 変数
商品カテゴリ種別コード
ITEM_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel の static 変数
商品コード
ITEM_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel の static 変数
商品コード
ITEM_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel の static 変数
商品コード
ITEM_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel の static 変数
商品コード
ITEM_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel の static 変数
商品コード
ITEM_NAME - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel の static 変数
商品名
Identifier - class jp.co.intra_mart.foundation.service.client.information.Identifier.
ユニークなＩＤを生成する機能を提供します。
Identifier() - class jp.co.intra_mart.foundation.service.client.information.Identifier のコンストラクタ
唯一のコンストラクタ。
IllegalArgumentException - exception jp.co.intra_mart.foundation.security.exception.IllegalArgumentException.
引数が不正の例外クラス。
IllegalArgumentException(String, String) - class jp.co.intra_mart.foundation.security.exception.IllegalArgumentException のコンストラクタ
コンストラクタ。
IllegalArgumentException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.IllegalArgumentException のコンストラクタ
コンストラクタ。
IllegalExtensionException - exception jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException.
拡張アクセサに関する例外クラス

拡張アクセサに対して不正な操作が行われた場合にスローする。
IllegalExtensionException() - class jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException のコンストラクタ
コンストラクタ
IllegalExtensionException(String) - class jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException のコンストラクタ
コンストラクタ
IllegalExtensionException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException のコンストラクタ
コンストラクタ
IllegalExtensionException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException のコンストラクタ
コンストラクタ
IllegalLocaleException - exception jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException.
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
IllegalLocaleException() - class jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException のコンストラクタ
コンストラクタ
IllegalLocaleException(String) - class jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException のコンストラクタ
コンストラクタ
IllegalLocaleException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException のコンストラクタ
コンストラクタ
IllegalLocaleException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException のコンストラクタ
コンストラクタ
IllegalPasswordException - exception jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException.
パスワードが認証されなかったことを通知するための例外です。
IllegalPasswordException(String) - class jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException のコンストラクタ
指定のメッセージで例外を作成します。
IllegalRelationshipException - exception jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException.
リレーションシップに関する例外クラス

リレーションシップの整合性が正しくない場合にスローする。
IllegalRelationshipException() - class jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException のコンストラクタ
コンストラクタ
IllegalRelationshipException(String) - class jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException のコンストラクタ
コンストラクタ
IllegalRelationshipException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException のコンストラクタ
コンストラクタ
IllegalRelationshipException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException のコンストラクタ
コンストラクタ
IllegalSessionException - exception jp.co.intra_mart.framework.base.session.IllegalSessionException.
セッション情報取得の失敗や不正なセッションを検出した場合にスローされます。
IllegalSessionException() - class jp.co.intra_mart.framework.base.session.IllegalSessionException のコンストラクタ
詳細メッセージを指定しないで IllegalSessionException を構築します。
IllegalSessionException(String) - class jp.co.intra_mart.framework.base.session.IllegalSessionException のコンストラクタ
指定された詳細メッセージを持つ IllegalSessionException を構築します。
IllegalSessionException(String, Throwable) - class jp.co.intra_mart.framework.base.session.IllegalSessionException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IllegalSessionException を構築します。
IllegalSystemException - exception jp.co.intra_mart.framework.system.exception.IllegalSystemException.
想定外の例外が発生したときの例外です。
IllegalSystemException() - class jp.co.intra_mart.framework.system.exception.IllegalSystemException のコンストラクタ
詳細メッセージを指定しないで IllegalSystemException を構築します。
IllegalSystemException(String) - class jp.co.intra_mart.framework.system.exception.IllegalSystemException のコンストラクタ
指定された詳細メッセージを持つ IllegalSystemException を構築します。
IllegalSystemException(Throwable) - class jp.co.intra_mart.framework.system.exception.IllegalSystemException のコンストラクタ
この例外の発生原因となる例外を持つ IllegalSystemException を構築します。
IllegalSystemException(String, Throwable) - class jp.co.intra_mart.framework.system.exception.IllegalSystemException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IllegalSystemException を構築します。
IllegalTermException - exception jp.co.intra_mart.foundation.datastore.exception.IllegalTermException.
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
IllegalTermException() - class jp.co.intra_mart.foundation.datastore.exception.IllegalTermException のコンストラクタ
コンストラクタ
IllegalTermException(String) - class jp.co.intra_mart.foundation.datastore.exception.IllegalTermException のコンストラクタ
コンストラクタ
IllegalTermException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalTermException のコンストラクタ
コンストラクタ
IllegalTermException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalTermException のコンストラクタ
コンストラクタ
ImAjaxUtil - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil.
CSJSライブラリ「ImAjax」で通信を行う際に有用なサーバサイドのユーティリティクラスです。
ImAjaxUtil() - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil のコンストラクタ

ImageIconException - exception jp.co.intra_mart.foundation.image.ImageIconException.
イメージアイコンの例外クラス。
ImageIconException() - class jp.co.intra_mart.foundation.image.ImageIconException のコンストラクタ
コンストラクタ。
ImageIconException(String) - class jp.co.intra_mart.foundation.image.ImageIconException のコンストラクタ
コンストラクタ。
ImageIconException(Throwable) - class jp.co.intra_mart.foundation.image.ImageIconException のコンストラクタ
コンストラクタ。
ImageIconException(String, Throwable) - class jp.co.intra_mart.foundation.image.ImageIconException のコンストラクタ
コンストラクタ。
ImageIconInfo - class jp.co.intra_mart.foundation.image.ImageIconInfo.
イメージアイコン情報クラス。
ImageIconInfo(String) - class jp.co.intra_mart.foundation.image.ImageIconInfo のコンストラクタ
コンストラクタ。
ImageIconInfo(String, int) - class jp.co.intra_mart.foundation.image.ImageIconInfo のコンストラクタ
コンストラクタ。
ImageIconInfo(String, String, int) - class jp.co.intra_mart.foundation.image.ImageIconInfo のコンストラクタ
コンストラクタ。
ImageIconManager - class jp.co.intra_mart.foundation.image.ImageIconManager.
アイコンマネージャクラス。
ImageIconManager(String) - class jp.co.intra_mart.foundation.image.ImageIconManager のコンストラクタ

ImageIconMessageBundle - class jp.co.intra_mart.foundation.image.ImageIconMessageBundle.

ImageIconMessageBundle() - class jp.co.intra_mart.foundation.image.ImageIconMessageBundle のコンストラクタ

ImpWbsElement - class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement.
詳細情報を必要とする WBS 要素クラス 機能は以下の通り
詳細情報を必要とする WBS 要素を保持します。
ImpWbsElement() - class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement のコンストラクタ
詳細情報を必要とする WBS 要素を作成します。
ImpWbsElement(int) - class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement のコンストラクタ
詳細情報を必要とする WBS 要素を作成します。
ImportConfigurationReader - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader.
インポート設定情報の読込みを行います。
ImportConfigurationReaderException - exception jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReaderException.
インポート設定の読み込みでエラーが発生したことを示すためにスローされます。
ImportConfigurationReaderException(String) - class jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReaderException のコンストラクタ
コンストラクタ
ImportConfigurationReaderException(Throwable) - class jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReaderException のコンストラクタ
コンストラクタ
ImportConfigurationReaderException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReaderException のコンストラクタ
コンストラクタ
ImportException - exception jp.co.intra_mart.foundation.datastore.exception.ImportException.
アプリケーション共通マスタのインポートに関する例外クラス

ImportException() - class jp.co.intra_mart.foundation.datastore.exception.ImportException のコンストラクタ
コンストラクタ
ImportException(String) - class jp.co.intra_mart.foundation.datastore.exception.ImportException のコンストラクタ
コンストラクタ
ImportException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.ImportException のコンストラクタ
コンストラクタ
ImportException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.ImportException のコンストラクタ
コンストラクタ
ImportInitializeException - exception jp.co.intra_mart.foundation.datastore.importer.ImportInitializeException.
インポートの初期化で何らかのエラーが発生したことを示すためにスローされます。
ImportInitializeException(String) - class jp.co.intra_mart.foundation.datastore.importer.ImportInitializeException のコンストラクタ
コンストラクタ
ImportInitializeException(Throwable) - class jp.co.intra_mart.foundation.datastore.importer.ImportInitializeException のコンストラクタ
コンストラクタ
ImportInitializeException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.importer.ImportInitializeException のコンストラクタ
コンストラクタ
ImportManager - interface jp.co.intra_mart.foundation.datastore.importer.ImportManager.
インポートを行います。
ImportManagerClient - interface jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient.
設定ファイルを読込んで、インポートマネージャーをセットアップ、実行します。
ImportManagerImpl - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl.
インポートマネージャーの実装です。
ImportManagerImpl(String) - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl のコンストラクタ
コンストラクタ
InitialFile - class jp.co.intra_mart.foundation.service.client.information.InitialFile.
設定ファイル(*.ini)の内容を読み込むためのクラスです。
InitialFile(String) - class jp.co.intra_mart.foundation.service.client.information.InitialFile のコンストラクタ
リソースサービスが動作しているサーバのリソースディレクトリ内にある 指定の ini ファイルを読み込みます。
InitialPageSessionHandlingFilter - class jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter.
ログインしている状態にログイン画面を表示しようとした際に警告ページを表示するためのフィルタ。
InitialPageSessionHandlingFilter() - class jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter のコンストラクタ

InputCheck - class jp.co.intra_mart.foundation.commons.validation.InputCheck.
入力チェック関数ライブラリ
InputCheck() - class jp.co.intra_mart.foundation.commons.validation.InputCheck のコンストラクタ

InquiryCreateFromData2 - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2.
引合伝票登録情報クラス
機能は以下の通り
引合伝票登録情報を保持します。
InquiryCreateFromData2() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のコンストラクタ
コンストラクタ。
InquiryCreateFromData2(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のコンストラクタ
コネクションマネージャーを引数に持つコンストラクタ。
InquiryCreateFromData2(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のコンストラクタ
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
InquiryCreateFromData2Controller - class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller.
引合伝票登録コントローラクラス
機能は以下の通り
引合伝票を登録します。
InquiryCreateFromData2Controller() - class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller のコンストラクタ
InquiryCreateFromData2Controllerのコンストラクタを生成します。
InquiryCreateFromData2Controller(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller のコンストラクタ
InquiryCreateFromData2Controllerのコンストラクタを生成します。
InquiryCreateFromData2Controller(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller のコンストラクタ
InquiryCreateFromData2Controllerのコンストラクタを生成します。
InternalOrderGetDetail - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail.
内部指図書詳細情報取得クラス
機能は以下の通り
内部指図書詳細情報を取得します。
InternalOrderGetDetail(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のコンストラクタ
内部指図書詳細情報を作成します。
InternalOrderGetDetail(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のコンストラクタ

InternalOrderGetDetailController - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController.
内部指図書詳細コントローラクラス
機能は以下の通り
内部指図書詳細を取得します。
InternalOrderGetDetailController(String, String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のコンストラクタ

InternalOrderGetDetailController(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のコンストラクタ

InternalOrderGetDetailController() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のコンストラクタ
InternalOrderGetDetailControllerのコンストラクタを生成します。
InternalOrderGetDetailController(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のコンストラクタ
InternalOrderGetDetailControllerのコンストラクタを生成します。
InternalOrderGetList - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList.
内部指図書（一覧）情報取得クラス
機能は以下の通り
内部指図書（一覧）情報を取得します。
InternalOrderGetList(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のコンストラクタ
内部指図書（一覧）情報を作成します。
InternalOrderGetList(String, String, String, String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のコンストラクタ

InternalOrderGetListController - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController.
内部指図書一覧コントローラクラス
機能は以下の通り
内部指図書一覧を取得します。
InternalOrderGetListController(String, String, String, String, String, String, String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のコンストラクタ

InternalOrderGetListController(String, String, String, String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のコンストラクタ

InternalOrderGetListController() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のコンストラクタ
InternalOrderGetListControllerのコンストラクタを生成します。
InternalOrderGetListController(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のコンストラクタ
InternalOrderGetListControllerのコンストラクタを生成します。
InternationArticleNumbers - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers.
EAN情報クラス
機能は以下の通り
EAN情報を保持します。
InternationArticleNumbers() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のコンストラクタ
EAN情報を作成します。
InternationArticleNumbers(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のコンストラクタ
EAN情報を作成します。
InternationalAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor.
国際化エンティティに対する情報操作用のインタフェースです。
InternationalAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap.
国際化アクセサのマッピング情報を持ちます。
InternationalArtnos - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos.
国際商品コード (EAN)情報クラス
機能は以下の通り
国際商品コード (EAN)情報を保持します。
InternationalArtnos() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のコンストラクタ
国際商品コード (EAN)情報を作成します。
InternationalArtnos(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のコンストラクタ
国際商品コード (EAN)情報を作成します。
InternationalKey - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalKey.
国際化基準項目を定義します。
InternationalModel - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalModel.
国際化モデルを定義します。
InternationalModel - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel.
国際化モデルの情報です。
InternationalModelContext - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext.
国際化モデルの初期化に必要な設定を持ちます。
InternationalModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap.
国際化モデルのマッピング情報を持ちます。
InternationalTable - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable.
国際化テーブルを定義します。
InternetPortlet - class jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet.
ページ種別「インターネット」に対するポートレットのモデルです。
InternetPortlet() - class jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet のコンストラクタ

IntramartAction - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction.
ServiceControllerAdapterと似たメソッドを持つActionクラスです。
IntramartAction() - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction のコンストラクタ

IntramartConnectFilter - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter.
推奨されていません。 この機能は廃止されました。
IntramartConnectFilter() - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter のコンストラクタ
推奨されていません。
IntramartConnectServlet - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet.
推奨されていません。 この機能は廃止されました。
IntramartConnectServlet() - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のコンストラクタ
推奨されていません。 IntramartConnectServletを新規に生成します。
IntramartDBConnector - class jp.co.intra_mart.framework.base.data.IntramartDBConnector.
推奨されていません。 このクラスではなくLoginGroupDBConnectorまたは SystemDBConnectorを使用してください。
IntramartDBConnector() - class jp.co.intra_mart.framework.base.data.IntramartDBConnector のコンストラクタ
推奨されていません。 IntramartDBConnectorを新規に生成します。
IntramartDBDAO - class jp.co.intra_mart.framework.base.data.IntramartDBDAO.
推奨されていません。 このクラスではなくLoginGroupDBDAOまたは SystemDBDAOを使用してください。
IntramartDBDAO() - class jp.co.intra_mart.framework.base.data.IntramartDBDAO のコンストラクタ
推奨されていません。 IntramartDBDAOを新規に生成します。
IntramartDBMapper - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper.
intra-martで管理されるデータベースにアクセスするマッパーの汎用的な抽象クラスです。
IntramartDBMapper() - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のコンストラクタ

IntramartFileServerConnector - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector.
intra-martのStorageサービスに接続するデータコネクタです。
IntramartFileServerConnector() - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector のコンストラクタ
IntramartFileServerConnectorを新規に生成します。
IntramartFileServerDAO - class jp.co.intra_mart.framework.base.data.IntramartFileServerDAO.
intra-martのStorageサービスを使用する場合のDAOです。
IntramartFileServerDAO() - class jp.co.intra_mart.framework.base.data.IntramartFileServerDAO のコンストラクタ
IntramartFileServerDAOを新規に生成します。
IntramartLocaleFilter - class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter.
セッションにロケールを設定します。
IntramartLocaleFilter() - class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter のコンストラクタ

IntramartLogAgent - class jp.co.intra_mart.framework.system.log.IntramartLogAgent.
intra-mart で管理されているログに出力するログエージェントです。
IntramartLogAgent() - class jp.co.intra_mart.framework.system.log.IntramartLogAgent のコンストラクタ
IntramartLogAgentを新規に生成します。
IntramartMessagePropertyHandler - class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler.
イントラマートで設定されたメッセージにアクセスするメッセージプロパティハンドラです。
IntramartMessagePropertyHandler() - class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler のコンストラクタ
IntramartMessagePropertyHandlerを新規に生成します。
IntramartPageBaseTransition - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition.
ページベースの画面に遷移する場合に使用するトランジションです。
IntramartPageBaseTransition() - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のコンストラクタ
IntramartPageBaseTransitionを新規に生成します。
IntramartSessionFactory - class jp.co.intra_mart.framework.base.session.IntramartSessionFactory.
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
IntramartSessionFactory() - class jp.co.intra_mart.framework.base.session.IntramartSessionFactory のコンストラクタ
推奨されていません。 IntramartSessionFactoryを新規に生成します。
IntramartSessionObject - class jp.co.intra_mart.framework.base.session.IntramartSessionObject.
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
IntramartSessionObject(SessionMemory) - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のコンストラクタ
推奨されていません。 IntramartSessionObjectを生成します。
Item - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item.
商品の基本属性のデータを取り扱います。
Item() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のコンストラクタ
商品に関連する情報を新規に生成します。
Item(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のコンストラクタ
商品に関連する情報を新規に生成します。
Item(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のコンストラクタ
商品に関連する情報を新規に生成します。
Item(Locale, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のコンストラクタ
商品に関連する情報を新規に生成します。
ItemAttach - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach.
商品分類の基本属性のデータを取り扱います。
ItemAttach() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach のコンストラクタ

ItemAttachBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel.
商品分類の基本モデルです。
ItemAttachImporter - interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemAttachImporter.
商品分類のインポートのインターフェースです。
ItemAttachMapper - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper.
商品分類に関連するマッパです。
ItemAttribute - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute.
商品属性の基本属性のデータを取り扱います。
ItemAttribute() - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のコンストラクタ
商品属性に関連する情報を新規に生成します。
ItemAttribute(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のコンストラクタ
商品属性に関連する情報を新規に生成します。
ItemAttributeBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel.
商品属性の基本モデルです。
ItemAttributeInternational - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttributeInternational.
商品属性の国際化属性のデータを取り扱います。
ItemAttributeInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttributeInternational のコンストラクタ

ItemAttributeInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeInternationalModel.
商品属性の国際化モデルです。
ItemAttributeMapper - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper.
商品属性に関連するマッパです。
ItemBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel.
商品の基本モデルです。
ItemCatalogue - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue.
商品カタログの基本属性のデータを取り扱います。
ItemCatalogue() - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のコンストラクタ

ItemCatalogueBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel.
商品カタログの基本モデルです。
ItemCatalogueMapper - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper.
商品カタログに関連するマッパです。
ItemCatalogueMediaManager - interface jp.co.intra_mart.foundation.datastore.application.domain.item.ItemCatalogueMediaManager.
商品カタログの媒体情報を管理するクラスです。
ItemCategory - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory.
商品カテゴリの基本属性のデータを取り扱います。
ItemCategory() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のコンストラクタ
商品カテゴリに関連する情報を新規に生成します。
ItemCategory(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のコンストラクタ
商品カテゴリに関連する情報を新規に生成します。
ItemCategoryBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel.
商品カテゴリの基本モデルです。
ItemCategoryImporter - interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryImporter.
商品カテゴリのインポートのインターフェースです。
ItemCategoryInternational - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategoryInternational.
商品カテゴリの国際化属性のデータを取り扱います。
ItemCategoryInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategoryInternational のコンストラクタ

ItemCategoryInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryInternationalModel.
商品カテゴリの国際化モデルです。
ItemCategoryManager - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager.
商品カテゴリに関する情報を管理します。
ItemCategoryManager() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のコンストラクタ

ItemCategoryMapper - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper.
商品カテゴリに関連するマッパです。
ItemCategoryStruct - interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryStruct.
商品カテゴリのツリー構造の構成を表すクラスです。
ItemCategoryType - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.type.ItemCategoryType.
商品カテゴリ種別の基本属性のデータを取り扱います。
ItemCategoryType() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.type.ItemCategoryType のコンストラクタ

ItemCategoryTypeBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel.
商品カテゴリ種別の基本モデルです。
ItemCategoryTypeMapper - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper.
商品カテゴリ種別に関連するマッパです。
ItemImporter - interface jp.co.intra_mart.foundation.datastore.application.domain.item.ItemImporter.
商品のインポートのインターフェースです。
ItemManager - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager.
商品に関する情報を管理します。
ItemManager() - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のコンストラクタ

ItemMapper - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper.
商品に関連するマッパです。
ItemTemplate - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate.
商品属性テンプレートの基本属性のデータを取り扱います。
ItemTemplate() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate のコンストラクタ

ItemTemplateBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel.
商品属性テンプレートの基本モデルです。
ItemTemplateDetail - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail.
商品属性テンプレート明細の基本属性のデータを取り扱います。
ItemTemplateDetail() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のコンストラクタ
商品属性テンプレート明細に関連する情報を新規に生成します。
ItemTemplateDetail(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のコンストラクタ
商品属性テンプレート明細に関連する情報を新規に生成します。
ItemTemplateDetailBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel.
商品属性テンプレート明細の基本モデルです。
ItemTemplateDetailInternational - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetailInternational.
商品属性テンプレート明細の国際化属性のデータを取り扱います。
ItemTemplateDetailInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetailInternational のコンストラクタ

ItemTemplateDetailInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailInternationalModel.
商品属性テンプレート明細の国際化モデルです。
ItemTemplateDetailMapper - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper.
商品属性テンプレート明細に関連するマッパです。
ItemTemplateImporter - interface jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateImporter.
商品属性テンプレートのインポートのインターフェースです。
ItemTemplateInternational - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplateInternational.
商品属性テンプレートの国際化属性のデータを取り扱います。
ItemTemplateInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplateInternational のコンストラクタ

ItemTemplateInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateInternationalModel.
商品属性テンプレートの国際化モデルです。
ItemTemplateManager - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager.
商品属性テンプレートの情報を管理します。
ItemTemplateManager() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager のコンストラクタ

ItemTemplateMapper - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper.
商品属性テンプレートに関連するマッパです。
ItemTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable.
商品の期間化属性のデータを取り扱います。
ItemTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable のコンストラクタ

ItemTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminableInternational.
商品の期間国際化属性のデータを取り扱います。
ItemTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminableInternational のコンストラクタ

ItemTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableInternationalModel.
商品の期間国際化モデルです。
ItemTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel.
商品の期間化モデルです。
ItemUnitManager - class jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager.
商品の単位を取り扱います。
ItemUnitManager() - class jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager のコンストラクタ

ItemsIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn.
明細データ情報クラス
機能は以下の通り
明細データ情報を保持します。
ItemsIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のコンストラクタ
明細データ情報を作成します。
ItemsIn(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のコンストラクタ
明細データ情報を作成します。
ItemsInX - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX.
明細データチェックボックス情報クラス
機能は以下の通り
明細データチェックボックス情報を保持します。
ItemsInX() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のコンストラクタ
明細データチェックボックス情報を作成します。
ItemsInX(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のコンストラクタ
明細データチェックボックス情報を作成します。
importData(InputStream) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
インポートを行います。
importData(String, InputStream) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
/** アクセスコントローラ情報をインポートします。
importData(String, InputStream) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウント情報をインポートします。
importData(String, InputStream) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
インポートを行います。
importData(String, InputStream) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
インポートを行います。
importData(String, InputStream) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニュー情報・インポート。
importData(String, InputStream) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニュー情報をインポートします。
importData(String, InputStream) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール情報・インポート。
in - class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream の変数
フィルタ処理される入力ストリームです。
in - class jp.co.intra_mart.foundation.utility.io.HexInputStream の変数
推奨されていません。 フィルタ処理される入力ストリームです。
increaseLoginFailureCount() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ログイン失敗回数をカウントアップします。
increment() - class jp.co.intra_mart.common.aid.jdk.util.Counter のメソッド
カウンターの値を１だけ増加させます。
increment() - class jp.co.intra_mart.foundation.utility.Counter のメソッド
推奨されていません。 カウンターの値を１だけ増加させます。
indexOf(Object) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
equals メソッドを使って等しいかどうかを判定しながら、指定された引数と同じ内容の要素を先頭から検索します。
indexOf(Object) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 equals メソッドを使って等しいかどうかを判定しながら、指定された引数と同じ内容の要素を先頭から検索します。
init(FilterConfig) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
フィルタを初期化します。
init(HttpServletResponseEventConfig) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
このビルダを初期化します。
init(HttpServletResponseEventConfig) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
このビルダを初期化します。
init(FilterConfig) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder のメソッド
このオブジェクトを初期化します。
init(String, ServletContext) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventComponentBuilder のメソッド
ビルダを初期化します。
init(HttpServletResponseEventConfig) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController のメソッド
このビルダを初期化します。
init(String, ServletContext) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerBuilder のメソッド
ビルダを初期化します。
init(HttpServletResponseEventConfig) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
このビルダを初期化します。
init(HttpServletResponseEventConfig) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidator のメソッド
この Validator を初期化します。
init(String, ServletContext) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.StandardHttpServletResponseEventControllerBuilder のメソッド
ビルダを初期化します。
init(ControllerConverterConfig) - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter のメソッド
MKControllerConverterを初期化します。
init(ControllerConverterConfig) - class jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter のメソッド
NodePathControllerConverterを初期化します。
init(Node) - interface jp.co.intra_mart.foundation.database.DBResultAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultArrayAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultBigDecimalAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultBigIntAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultBinaryAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultBlobAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultBooleanAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultByteAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultClobAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultDateAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultDoubleAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultImTimestampAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultIntegerAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultNullAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultObjectAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultRealAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultRefAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultShortAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultStringAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultStructAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultTimeAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultTimestampAdapter のメソッド
初期化を行います。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のメソッド
CategoryManagerを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
会社リスナーの初期化を行います。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
CompanyManagerを初期化します。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager のメソッド
CurrencyManagerを初期化します。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
DealManagerを初期化します。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager のメソッド
DealPermissionManagerを初期化します。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
ItemManagerを初期化します。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のメソッド
ItemCategoryManagerを初期化します。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager のメソッド
ItemTemplateManagerを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
プライベートグループリスナーの初期化を行います。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
PrivateGroupManagerを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
アカウントリスナーの初期化を行います。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
PublicGroupManagerを初期化します。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager のメソッド
ItemUnitManagerを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener のメソッド
ユーザリスナーの初期化を行います。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager のメソッド
UserManagerを初期化します。
init(BaseModelContext) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel のメソッド
基本モデルを初期化します。
init(ExtendedBaseAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel のメソッド
拡張基本モデルを初期化します。
init(ExtendedBaseAccessor) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel のメソッド
拡張基本モデルを初期化します。
init(ExtendedBaseAccessorMap) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap のメソッド
初期化を行います。
init(ExtendedInternationalAccessor) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel のメソッド
拡張国際化モデルを初期化します。
init(ExtendedInternationalAccessorMap) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap のメソッド
初期化を行います。
init(ExtendedTerminableInternationalAccessor) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel のメソッド
拡張期間国際化モデルを初期化します。
init(ExtendedTerminableInternationalAccessorMap) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap のメソッド
初期化を行います。
init(ExtendedTerminableAccessor) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel のメソッド
拡張期間化モデルを初期化します。
init(ExtendedTerminableAccessorMap) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap のメソッド
初期化を行います。
init(ExtendedInternationalAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel のメソッド
拡張国際化モデルを初期化します。
init(ExtendedTerminableInternationalAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel のメソッド
拡張期間国際化モデルを初期化します。
init(ExtendedTerminableAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel のメソッド
拡張期間化モデルを初期化します。
init(BaseModelContext) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
基本モデルを初期化します。
init(InternationalModelContext) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のメソッド
国際化モデルを初期化します。
init(String, InternationalAccessorMap) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
初期化処理を行います。
init(TerminableInternationalModelContext) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のメソッド
期間国際化モデルを初期化します。
init(String, TerminableInternationalAccessorMap) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
初期化処理を行います。
init(TerminableModelContext) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
期間化モデルを初期化します。
init(String, String, TerminableAccessorMap, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
初期化処理を行います。
init(InternationalModelContext) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel のメソッド
国際化モデルを初期化します。
init(String, String) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
マッパーを初期化します。
init(String, String) - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
マッパーを初期化します。
init(TerminableInternationalModelContext) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel のメソッド
期間国際化モデルを初期化します。
init(TerminableModelContext) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel のメソッド
期間化モデルを初期化します。
init() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
StandardMailオブジェクトを初期化します。
init(String[]) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
イベントナビゲーター管理アクセッサの初期化。
init(String[]) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorExporter のメソッド
イベントナビゲータバックアップエクスポータの初期化。
init(String[]) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorImporter のメソッド
イベントナビゲータバックアップインポータの初期化。
init(Map) - class jp.co.intra_mart.foundation.navigator.EventNavigatorPermissionSelector のメソッド
インスタンスの初期化を行います。
init(String[]) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorReaderDecorator のメソッド
イベントナビゲータデコレータの初期化。
init(String[]) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
イベントナビゲーター管理アクセッサの初期化。
init(String[]) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter のメソッド

init(String[]) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter のメソッド
初期化。
init(Properties) - interface jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider のメソッド
初期化を行います。
init(Properties) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider のメソッド
初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラアクセッサの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウントアクセッサの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.StandardBatchAccessor のメソッド
初期化します。
init(Map) - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor のメソッド
カレンダーアクセッサの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
メニューアクセッサの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
ロールアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.access.AccessControllerExporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.access.AccessControllerImporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.access.AccessControllerPostWriterListener のメソッド
アクセスコントローラリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.access.AccessControllerQueryWriterListener のメソッド
アクセスコントローラリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.access.AccessControllerReaderDecorator のメソッド
アクセスコントローラデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
会社リスナーの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
アカウントリスナーの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener のメソッド
ロールリスナーの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.access.StandardAccessControllerBackup のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウントリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountExporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountImporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウントリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウントリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountReaderDecorator のメソッド
アカウントデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.account.CsvAccountBackup のメソッド
初期化。
init(Map) - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のメソッド
ロールリスナーの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.account.StandardAccountBackup のメソッド
初期化。
init(Node, Node) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
設定ファイルの情報を基に初期化します。
init(Map) - class jp.co.intra_mart.foundation.security.activesession.GroupActiveSessionRegister のメソッド
管理者ログイン認証リスナーの初期化を行います。
init(Node, Node) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
設定ファイル conf/active-session-config.xml の情報を基に初期化します。
init(Map) - class jp.co.intra_mart.foundation.security.activesession.UserActiveSessionRegister のメソッド
ユーザログイン認証リスナーの初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor のメソッド
システム管理者アクセッサを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener のメソッド
システム管理者リスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener のメソッド
システム管理者リスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator のメソッド
システム管理者デコレータの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
アクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.batch.BatchExporter のメソッド
バッチバックアップエクスポータの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.batch.BatchImporter のメソッド
バッチバックアップインポータの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener のメソッド
バッチリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener のメソッド
バッチリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator のメソッド
バッチデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup のメソッド
バッチバックアップの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
カレンダーアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.calendar.CalendarExporter のメソッド
カレンダーバックアップエクスポータの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.calendar.CalendarImporter のメソッド
カレンダーバックアップインポータの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener のメソッド
カレンダーリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener のメソッド
カレンダーリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator のメソッド
カレンダーデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup のメソッド
カレンダーバックアップの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
ページプロバイダの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.LDAPUserCertification のメソッド
ユーザログイン認証の初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider のメソッド
ページプロバイダの初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer のメソッド
ログインリクエストアナライザの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer のメソッド
ログインリクエストアナライザの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
ページプロバイダの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider のメソッド
ページプロバイダの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
ログインリクエストアナライザの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification のメソッド
管理者ログイン認証の初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider のメソッド
ページプロバイダの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardUserCertification のメソッド
ユーザログイン認証の初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider のメソッド
ページプロバイダの初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.certification.SuperCertification のメソッド
管理者ログイン認証の初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.certification.SuperCertificationListener のメソッド
管理者ログイン認証リスナーの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification のメソッド
管理者ログイン認証の初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.certification.UserCertification のメソッド
ユーザログイン認証の初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.certification.UserCertificationListener のメソッド
ユーザログイン認証リスナーの初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.certification.UserPageProvider のメソッド
ページプロバイダの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPUserCertification のメソッド
ユーザログイン認証の初期化を行います。
init(Node, Node) - interface jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor のメソッド
設定ファイルの情報を基に初期化します。
init(Node, Node) - class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor のメソッド
設定ファイル conf/duplicate-login.xml の情報を基に初期化します。
init(FilterConfig) - class jp.co.intra_mart.foundation.security.filter.SessionFilter のメソッド
初期化します。
init(FilterConfig) - class jp.co.intra_mart.foundation.security.filter.URLAccessFilter のメソッド
初期化します。
init(Map) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor のメソッド
グループ管理者アクセッサを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener のメソッド
グループ管理者リスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener のメソッド
グループ管理者リスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator のメソッド
管理者デコレータの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
ログイングアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
ログイングループ書き込み時（書き込み直前）のリスナの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
ログイングループ書き込み時（書き込み直前）のリスナの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator のメソッド
ログイングループデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
ログイングループ書き込み時（書き込み直前）のリスナの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
メニューアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuExporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuImporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
メニューリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
メニューリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator のメソッド
メニューデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
会社リスナーの初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニューアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.MenuExporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.MenuImporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener のメソッド
メニューリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener のメソッド
メニューリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator のメソッド
メニューデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
アカウントリスナーの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のメソッド
ロールリスナーの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup のメソッド
初期化。
init(Map) - class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup のメソッド
初期化。
init(Node) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuAnalyzer のメソッド
モバイル端末固体識別番号取得プロバイダの初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuHdmlAnalyzer のメソッド
推奨されていません。 モバイル端末固体識別番号取得プロバイダの初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoAnalyzer のメソッド
モバイル端末固体識別番号取得プロバイダの初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoMoveAnalyzer のメソッド
推奨されていません。 モバイル端末固体識別番号取得プロバイダの初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginJphoneAnalyzer のメソッド
推奨されていません。 モバイル端末固体識別番号取得プロバイダの初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginSoftBankAnalyzer のメソッド
モバイル端末固体識別番号取得プロバイダの初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginVodafoneAnalyzer のメソッド
モバイル端末固体識別番号取得プロバイダの初期化を行います。
init(Node) - interface jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider のメソッド
設定ファイルの情報を基に初期化します。
init(Map) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

init(Node, Node) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
パラメータを取得。
init(Map) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener のメソッド
アカウントリスナーの初期化。
init(Properties) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryNewArrivedProvider のメソッド
初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryUserPageProvider のメソッド

init(Node, Node) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
パラメータを取得。
init(Map) - class jp.co.intra_mart.foundation.security.permission.AccessControllerPermissionSelector のメソッド
インスタンスの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector のメソッド
インスタンスの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.permission.AdminMenuPermissionSelector のメソッド
インスタンスの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector のメソッド
インスタンスの初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.permission.PermissionSelector のメソッド
インスタンスの初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
ロールアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener のメソッド
ロールリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RoleExporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RoleImporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener のメソッド
ロールリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener のメソッド
ロールリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RoleReaderDecorator のメソッド
ロールデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.role.StandardRoleBackup のメソッド
初期化。
init() - class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet のメソッド
サーブレットの初期化を行います。
init() - class jp.co.intra_mart.foundation.security.servlet.LogoutServlet のメソッド
サーブレットの初期化を行います。
init() - class jp.co.intra_mart.foundation.security.servlet.MenuServlet のメソッド
メニューサーブレットの初期化を行います。
init() - class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet のメソッド
サーブレットの初期化を行います。
init() - class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet のメソッド
サーブレットの初期化を行います。
init() - class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet のメソッド
サーブレットの初期化を行います。
init(Node) - interface jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor のメソッド
ショートカットアクセッサを初期化します。
init(Node) - class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor のメソッド
ショートカットアクセッサを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
プロパティハンドラを初期化します。
init() - class jp.co.intra_mart.framework.base.data.container.DataContainerImpl のメソッド
DataContainerを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
プロパティハンドラを初期化します。
init() - class jp.co.intra_mart.framework.base.event.container.EventContainerImpl のメソッド
EventContainerを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.EncodingFilter のメソッド
エンコーディング用のフィルタを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.FileUploadFilter のメソッド
ファイルアップロード用のフィルタを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter のメソッド
推奨されていません。 フィルタを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter のメソッド
推奨されていません。 このフィルタを初期化します。
init(ServletConfig) - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 このサーブレットを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter のメソッド
ロケール用のフィルタを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.LocaleFilter のメソッド
ロケール用のフィルタを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter のメソッド
このフィルタを初期化します。
init(ServletConfig) - class jp.co.intra_mart.framework.base.service.ServiceServlet のメソッド
サーブレットを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
プロパティハンドラを初期化します。
init() - class jp.co.intra_mart.framework.base.service.container.ServiceContainerImpl のメソッド
ServiceContainerを初期化します。
init(ControllerConverterConfig) - interface jp.co.intra_mart.framework.base.service.controller.ControllerConverter のメソッド
ControllerConverterを初期化します。
init(ControllerConverterConfig) - class jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter のメソッド
SimpleControllerConverterを初期化します。
init(ValidatorConfig) - class jp.co.intra_mart.framework.base.service.validator.FormatValidator のメソッド
FormatValidatorを初期化します。
init(ValidatorConfig) - class jp.co.intra_mart.framework.base.service.validator.LengthValidator のメソッド
LengthValidatorを初期化します。
init(ValidatorConfig) - class jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator のメソッド
NumericRangeValidatorを初期化します。
init(ValidatorConfig) - class jp.co.intra_mart.framework.base.service.validator.NumericValidator のメソッド
NumericValidatorを初期化します。
init(ValidatorConfig) - interface jp.co.intra_mart.framework.base.service.validator.Validator のメソッド
Validatorを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.session.SessionFilter のメソッド
セッション用のフィルタを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
プロパティハンドラを初期化します。
init() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
HelperBeanを初期化します。
init() - class jp.co.intra_mart.framework.extension.seasar.data.S2DataContainer のメソッド
DataContainerを初期化します。
init() - class jp.co.intra_mart.framework.extension.seasar.event.S2EventContainer のメソッド

init() - class jp.co.intra_mart.framework.extension.seasar.service.S2ServiceContainer のメソッド
ServiceContainerを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter のメソッド
フィルタを初期化します。
init() - interface jp.co.intra_mart.framework.system.container.IMContainer のメソッド
IMContainerを初期化します。
init(LogAgentParam[]) - class jp.co.intra_mart.framework.system.log.DefaultLogAgent のメソッド
初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(LogAgentParam[]) - class jp.co.intra_mart.framework.system.log.IntramartLogAgent のメソッド
初期化します。
init(LogAgentParam[]) - interface jp.co.intra_mart.framework.system.log.LogAgent のメソッド
初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - interface jp.co.intra_mart.framework.system.property.PropertyHandler のメソッド
プロパティハンドラを初期化します。
initMaterialGetAll() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目マスタ照会情報を作成します。
initMaterialSaveReplica() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目マスタ更新情報の各種インスタンスを生成します。
initParam(String, String) - interface jp.co.intra_mart.framework.base.event.EventListenerFactory のメソッド
初期パラメータを設定します。
initParam(String, String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory のメソッド
初期パラメータを設定します。
initParam(String, String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory のメソッド
初期パラメータを設定します。
initParam(String, String) - class jp.co.intra_mart.framework.base.event.GenericEventListenerFactory のメソッド
初期パラメータを設定します。
initParam(String, String) - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory のメソッド
初期パラメータを設定します。
initParam(String, String) - class jp.co.intra_mart.framework.base.event.StandardEventListenerFactory のメソッド
初期パラメータを設定します。
initParam(String, String) - class jp.co.intra_mart.framework.extension.seasar.event.S2EventListenerFactory のメソッド
初期パラメータを設定します。
initialize(String) - interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader のメソッド
初期化を行います。
initialize(String) - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader のメソッド
初期化を行います。
initialize() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl のメソッド
初期化処理を行います。
initialize() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManagerInitializerImpl のメソッド
初期化処理を行います。
initializeTime() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
バッチ初期化時間の取得。
insert(String, Map) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースにデータを追加挿入するメソッド

データベースにインサート処理をする。
insert(CateogryClassBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
分類区分の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
分類区分の基本モデルを複数挿入します。
insert(CategoryDetailBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
分類区分詳細の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
分類区分詳細の基本モデルを複数挿入します。
insert(DepartmentAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
組織所属の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
組織所属の基本モデルを複数挿入します。
insert(CompanyCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
会社組織分類の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
会社組織分類の基本モデルを複数挿入します。
insert(CompanyBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
会社の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
会社の基本モデルを複数挿入します。
insert(DepartmentBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
組織の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
組織の基本モデルを複数挿入します。
insert(DepartmentInclusionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
組織内包の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
組織内包の基本モデルを複数挿入します。
insert(DepartmentMainBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
主所属の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
主所属の基本モデルを複数挿入します。
insert(CompanyPostBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
役職の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
役職の基本モデルを複数挿入します。
insert(CompanyVersionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
会社構成バージョンの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
会社構成バージョンの基本モデルを複数挿入します。
insert(DealBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper のメソッド
取扱の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper のメソッド
取扱の基本モデルを複数挿入します。
insert(DealerDepartmentBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper のメソッド
組織毎取扱パーミッションの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper のメソッド
組織毎取扱パーミッションの基本モデルを複数挿入します。
insert(DealDetailBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper のメソッド
取扱詳細の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper のメソッド
取扱詳細の基本モデルを複数挿入します。
insert(DealerPublicGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper のメソッド
パブリックグループ毎取扱パーミッションの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper のメソッド
パブリックグループ毎取扱パーミッションの基本モデルを複数挿入します。
insert(DealerRoleBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper のメソッド
ロール毎取扱パーミッションの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper のメソッド
ロール毎取扱パーミッションの基本モデルを複数挿入します。
insert(ItemAttributeBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper のメソッド
商品属性の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper のメソッド
商品属性の基本モデルを複数挿入します。
insert(ItemCatalogueBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper のメソッド
商品カタログの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper のメソッド
商品カタログの基本モデルを複数挿入します。
insert(ItemBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper のメソッド
商品の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper のメソッド
商品の基本モデルを複数挿入します。
insert(ItemAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper のメソッド
商品分類の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper のメソッド
商品分類の基本モデルを複数挿入します。
insert(ItemCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper のメソッド
商品カテゴリの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper のメソッド
商品カテゴリの基本モデルを複数挿入します。
insert(ItemCategoryTypeBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper のメソッド
商品カテゴリ種別の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper のメソッド
商品カテゴリ種別の基本モデルを複数挿入します。
insert(ItemTemplateDetailBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper のメソッド
商品属性テンプレート明細の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper のメソッド
商品属性テンプレート明細の基本モデルを複数挿入します。
insert(ItemTemplateBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper のメソッド
商品属性テンプレートの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper のメソッド
商品属性テンプレートの基本モデルを複数挿入します。
insert(PrivateGroupAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライベートグループ所属の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライベートグループ所属の基本モデルを複数挿入します。
insert(PrivateGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライベートグループの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライベートグループの基本モデルを複数挿入します。
insert(PublicGroupAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
パブリックグループ所属の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
パブリックグループ所属の基本モデルを複数挿入します。
insert(PublicGroupCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
パブリックグループ分類の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
パブリックグループ分類の基本モデルを複数挿入します。
insert(PublicGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
パブリックグループの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
パブリックグループの基本モデルを複数挿入します。
insert(PublicGroupInclusionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
パブリックグループ内包の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
パブリックグループ内包の基本モデルを複数挿入します。
insert(PublicGroupSetBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
パブリックグループセットの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
パブリックグループセットの基本モデルを複数挿入します。
insert(PublicGroupVersionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
パブリックグループ構成バージョンの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
パブリックグループ構成バージョンの基本モデルを複数挿入します。
insert(UnitBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper のメソッド
単位の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper のメソッド
単位の基本モデルを複数挿入します。
insert(UserBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
ユーザの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
ユーザの基本モデルを複数挿入します。
insert(BaseModel) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
基本モデルを1つだけ挿入します。
insert(Collection) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
基本モデルを複数挿入します。
insert(String, String, Date) - class jp.co.intra_mart.foundation.update.StandardUpdateAccessor のメソッド
キーを取得します。
insert(String, String, Date) - interface jp.co.intra_mart.foundation.update.UpdateAccessor のメソッド
キーを取得します。
insert(AccessControllerDepartmentBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper のメソッド
アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper のメソッド
アクセスコントローラの利用権限を保有する組織の基本モデルを複数挿入します。
insert(AccessControllerBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper のメソッド
アクセスコントローラ情報の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper のメソッド
アクセスコントローラ情報の基本モデルを複数挿入します。
insert(AccessControllerPostBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper のメソッド
アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper のメソッド
アクセスコントローラの利用権限を保有する役職の基本モデルを複数挿入します。
insert(AccessControllerPublicGroupBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper のメソッド
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper のメソッド
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを複数挿入します。
insert(AccessControllerRoleBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper のメソッド
アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper のメソッド
アクセスコントローラの利用権限を保有するロールの基本モデルを複数挿入します。
insert(AccountAttributeBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper のメソッド
アカウントが保有する属性の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper のメソッド
アカウントが保有する属性の基本モデルを複数挿入します。
insert(AccountBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccountMapper のメソッド
アカウントの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccountMapper のメソッド
アカウントの基本モデルを複数挿入します。
insert(AccountRoleBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper のメソッド
アカウントが保有するロールの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper のメソッド
アカウントが保有するロールの基本モデルを複数挿入します。
insert(BatchBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.BatchMapper のメソッド
バッチ情報の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.BatchMapper のメソッド
バッチ情報の基本モデルを複数挿入します。
insert(CalendarInfoBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper のメソッド
カレンダーが保有するデータの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper のメソッド
カレンダーが保有するデータの基本モデルを複数挿入します。
insert(FavoriteMenuBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper のメソッド
アカウントが保有するメニューの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper のメソッド
アカウントが保有するメニューの基本モデルを複数挿入します。
insert(MenuArgumentBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper のメソッド
メニューの保有する引数の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper のメソッド
メニューの保有する引数の基本モデルを複数挿入します。
insert(MenuDepartmentBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper のメソッド
メニューの利用権限を保有する組織の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper のメソッド
メニューの利用権限を保有する組織の基本モデルを複数挿入します。
insert(MenuBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuMapper のメソッド
メニュー情報の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuMapper のメソッド
メニュー情報の基本モデルを複数挿入します。
insert(MenuPostBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper のメソッド
メニューの利用権限を保有する役職の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper のメソッド
メニューの利用権限を保有する役職の基本モデルを複数挿入します。
insert(MenuPublicGroupBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper のメソッド
メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper のメソッド
メニューの利用権限を保有するパブリックグループの基本モデルを複数挿入します。
insert(MenuRoleBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper のメソッド
メニューの利用権限を保有するロールの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper のメソッド
メニューの利用権限を保有するロールの基本モデルを複数挿入します。
insert(RoleInclusionBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper のメソッド
ロール内包の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper のメソッド
ロール内包の基本モデルを複数挿入します。
insert(RoleBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.RoleMapper のメソッド
ロールの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.RoleMapper のメソッド
ロールの基本モデルを複数挿入します。
insert(RoleSummaryBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper のメソッド
ロールサマリの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper のメソッド
ロールサマリの基本モデルを複数挿入します。
insertAccessController(String, AccessController) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラを作成します。
insertAccessController(String, AccessController) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラを作成します。
insertAccount(String, Account) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウント情報を新規追加する。
insertAccount(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント情報を新規追加する。
insertAccountRole(String, String, AccountRole) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウントロール情報を新規追加する。
insertAccountRole(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントロール情報を新規追加する。
insertBatch(String, Batch) - class jp.co.intra_mart.foundation.security.StandardBatchAccessor のメソッド
バッチを登録します。
insertBatch(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
バッチ情報を新規に追加します。
insertCalendarInfo(String, String, CalendarInfo) - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor のメソッド
カレンダーデータを新規に作成します。
insertCalendarInfo(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
カレンダーデータを新規に作成します。
insertControllerDepartment(String, String, DepartmentInfo) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラ組織を新規に作成します。
insertControllerDepartment(String, String, DepartmentInfo) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラ組織を新規に作成します。
insertControllerPost(String, String, PostInfo) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラ役職を新規に作成します。
insertControllerPost(String, String, PostInfo) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラ役職を新規に作成します。
insertControllerPublicGroup(String, String, PublicGroupInfo) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラパブリックグループを新規に作成します。
insertControllerPublicGroup(String, String, PublicGroupInfo) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラパブリックグループを新規に作成します。
insertControllerRole(String, String, String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラロールを新規に作成します。
insertControllerRole(String, String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラロールを新規に作成します。
insertFavoriteMenu(String, String, FavoriteMenu) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
マイメニュー情報を新規追加する。
insertFavoriteMenu(String, String, FavoriteMenu) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
マイメニュー情報を新規追加する。
insertLoginGroup(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
ログイングループを新規追加します。
insertMainPagePattern(String, MainPagePatternInfo) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
メインページパターンを新規追加します。
insertMenuDepartment(String, String, DepartmentInfo) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
メニュー組織を新規に作成します。
insertMenuDepartment(String, String, DepartmentInfo) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニュー組織を新規に作成します。
insertMenuInclusion(String, MenuInclusion) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
メニュー構成を新規に作成します。
insertMenuInclusion(MenuInclusion) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
メニュー構成を新規に作成します。
insertMenuInclusion(String, MenuInclusion) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニュー構成を新規に作成します。
insertMenuItem(String, MenuItem, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
引数で渡されたノードを新規追加します。
insertMenuItem(MenuItem, String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
引数で渡されたノードを新規追加します。
insertMenuItem(String, MenuItem, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
引数で渡されたノードを新規追加します。
insertMenuPost(String, String, PostInfo) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
メニュー役職を新規に作成します。
insertMenuPost(String, String, PostInfo) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニュー役職を新規に作成します。
insertMenuPublicGroup(String, String, PublicGroupInfo) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
メニューパブリックグループを新規に作成します。
insertMenuPublicGroup(String, String, PublicGroupInfo) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニューパブリックグループを新規に作成します。
insertMenuRole(String, String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
メニューロールを新規に作成します。
insertMenuRole(String, String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニューロールを新規に作成します。
insertSubRole(String, String, String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
サブロールを作成します。
insertSubRole(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
サブロールを作成する。
insertSuperUser(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor のメソッド
システム管理者情報を新規追加します。
insertSuperUser(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor のメソッド
グループ管理者情報を新規追加します。
instance() - class jp.co.intra_mart.common.aid.jdk.java.net.Localhost の static メソッド
このクラスから生成される唯一のインスタンスを返します。
instance - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser の変数
に対応するJavaBeans
instance() - class jp.co.intra_mart.foundation.service.provider.HomeDirectory の static メソッド
ホームディレクトリを表すオブジェクトを取得します。
instance() - class jp.co.intra_mart.foundation.service.provider.TemporaryDirectory の static メソッド
一時ファイル保存用ディレクトリを表すオブジェクトを取得します。
instance() - class jp.co.intra_mart.foundation.service.provider.file.StorageDirectory の static メソッド
ファイルコンテンツの保存ディレクトリを表すオブジェクトを取得します。
instance() - class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory の static メソッド
データ保存ディレクトリを表すオブジェクトを取得します。
instance() - class jp.co.intra_mart.foundation.utility.net.Localhost の static メソッド
推奨されていません。 このクラスから生成される唯一のインスタンスを返します。
intValue(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 数値として取得します。
intValue(String, int) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 数値として取得します。
intValue() - class jp.co.intra_mart.common.aid.jdk.util.Counter のメソッド
カウンターの現在の値を int 型として返します。
intValue() - class jp.co.intra_mart.foundation.utility.Counter のメソッド
推奨されていません。 カウンターの現在の値を int 型として返します。
invalidate(String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
invalidate(String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
invalidate(String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
invalidateOtherSessions(ActiveSessionInfo) - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager のメソッド
引数で指定されたアクティブなセッション情報以外のセッション情報をすべて無効にします。
invoke(String, String) - interface jp.co.intra_mart.foundation.scenario.VariableScope のメソッド
指定関数を実行します。
invoke(String, Number) - interface jp.co.intra_mart.foundation.scenario.VariableScope のメソッド
指定関数を実行します。
invoke(String, Object[]) - interface jp.co.intra_mart.foundation.scenario.VariableScope のメソッド
指定関数を実行します。
ioInvoke(Object, String, String, PropertyDescriptor[]) - class jp.co.intra_mart.foundation.sap.common.util.data.ExtendedParamConverter の static メソッド
パラメータ名からsetterメソッドを取得し、値をセットします。
ioInvoke(Object, String, String, PropertyDescriptor[]) - class jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter の static メソッド
パラメータ名からsetterメソッドを取得し、値をセットします。
isAccessControlEnabled(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
メニューアイテムのアクセス権の有無を取得します。
isAccessControlEnabled(String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニューアイテムのアクセス権の有無を取得します。
isActive() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
現在の時刻と比較して、セッションが有効か無効か取得する。
isActive(long) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
引数で指定された時刻と比較して、セッションが有効か無効か取得する。
isAlive() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
スケジューラが動作しているかどうかをチェックします。
isAlive() - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 このイベントコントローラが有効かどうかチェックします。
isAttemptOnFailedAuthentication() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
LDAP認証失敗(ユーザIDまたはパスワードが不正)時に次のプロバイダURLに認証の試みを取得する。
isAuth() - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のメソッド
認証フラグを取得します。
isChangePasswordFirstLogin(String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
初回ログイン時にパスワード変更要求を行うかの判定。
isChangePasswordFirstLogin() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
初回ログイン時のパスワード変更要求を行うかの判定。
isChangePasswordFirstLogin(String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
初回ログイン時にパスワード変更要求を行うかの判定。
isClosed() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
この入出力ストリームが閉じられているかチェックします。
isClosed() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
この入出力ストリームが閉じられているかチェックします。
isClosed() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
このソケットが閉じられているかどうかをチェックします。
isClosed() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 Connection がクローズされているかどうかを判定します。
isClosed() - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
このアクセサがクローズされた状態かどうかを確認します。
isClosed() - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
マッパーがクローズされているかどうか確認します。
isClosed() - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
マッパーがクローズされているかどうか確認します。
isClosed() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 この入出力ストリームが閉じられているかチェックします。
isClosed() - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 この入出力ストリームが閉じられているかチェックします。
isClosed() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 このソケットが閉じられているかどうかをチェックします。
isColumn(String, String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースの表内に指定カラムが存在するか調べる

isCommitted() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
レスポンスがすでにコミットされたかどうかを示す boolean を返します。
isCommitted(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
レスポンスがすでにコミットされたかどうかを示す boolean を返します。
isCommitted(HttpServletRequest, ExtendedHttpServletResponse) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
レスポンスがすでにコミットされたかどうかを示す boolean を返します。
isCommitted(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
レスポンスがすでにコミットされたかどうかを示す boolean を返します。
isConnect() - class jp.co.intra_mart.foundation.database.DbManager のメソッド
推奨されていません。 代替えメソッドはありません。
isConnected() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
サーバとの接続状態をチェックします。
isDataSource() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 このコネクションがDataSourceかを返します。
isDateString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
日付文字列が日付フォーマット（YYYYMMDD）にそっているかチェックする。
isDateTimeString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
日時文字列がフォーマット（YYYY-MM-DD HH:MM:SS）にそっているかどうかをチェックする。
isDateTimeString(String, SimpleDateFormat) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
日時文字列が指定フォーマットにそっているかどうかをチェックする。
isDenyClientType(String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
クライアントタイプの判定

パラメータdeny-client-typesに記述があるクライアントタイプの判定を行う。
isDenyClientType(String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
クライアントタイプの判定

パラメータmobile-client-typesに記述があるクライアントタイプの判定を行う。
isDenyClientType(String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
クライアントタイプの判定

パラメータdeny-client-typesに記述があるクライアントタイプの判定を行う。
isDetectEnable(ActiveSessionInfo) - interface jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor のメソッド
検出処理が有効かどうか取得します。
isDetectEnable(String, String) - interface jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor のメソッド
検出処理が有効かどうか取得します。
isDetectEnable(ActiveSessionInfo) - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager のメソッド
検出処理が有効かどうか取得します。
isDetectEnable(String, String) - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager のメソッド
検出処理が有効かどうか取得します。
isDetectEnable(ActiveSessionInfo) - class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor のメソッド
検出処理が有効かどうか取得します。
isDetectEnable(String, String) - class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor のメソッド
重複ログイン検出処理が有効かどうか取得します。
isDirectory() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルがディレクトリであるかどうかを判定します。
isDoneCertification() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
認証が終了しているかどうかを取得する。
isDouble() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
ｙ軸の目盛値がdouble表現かどうかを判定します。
isDouble() - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
グラフ値がdouble表現かどうかを判定します。
isDouble() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
ｙ軸の目盛値がdouble表現かどうかを判定します。
isDouble() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｘ軸、ｙ軸の目盛値がdouble表現かどうかを判定します。
isDouble() - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
グラフ値がdouble表現かどうかを判定します。
isDouble() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
ｙ軸の目盛値がdouble表現かどうかを判定します。
isDuplicateLogined(ActiveSessionInfo) - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager のメソッド
引数で指定されたユーザが重複してログインしているかどうか判別します。
isDuplicateLogined(String, String, String, String) - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager のメソッド
引数で指定されたユーザが重複してログインしているかどうか判別します。
isDuplicateSrc() - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
イメージアイコンのURLの重複チェックの有効/無効を取得します。
isDynamic() - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - interface jp.co.intra_mart.framework.base.message.MessagePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
再設定可能かどうかをチェックします。
isDynamic() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isEMailAddress(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
入力文字列がメールアドレスの形式をとっているかのチェック。
isEmpty() - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リストに要素がないかどうかを判定します。
isEmpty(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
渡された文字列が、空文字列かまたはNULLかチェック。
isEmpty(Number) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
数値のNULLチェック。
isEmpty() - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リストに要素がないかどうかを判定します。
isEmpty() - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
このノードの下に子ノードがないか調べます。
isEmpty() - interface jp.co.intra_mart.foundation.page.TreeNodeContainer のメソッド
このノードが一つも子を持っていないときにtrueを返します。
isEnableSMTPAuth() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
SMTP認証の有効/無効を取得します。
isEncodeRequired() - class jp.co.intra_mart.framework.base.session.HttpSessionFactory のメソッド
推奨されていません。 セッション情報をURLに含めてエンコードする必要があるかどうか調べます。
isEncodeRequired() - class jp.co.intra_mart.framework.base.session.IntramartSessionFactory のメソッド
推奨されていません。 セッション情報をURLに含めてエンコードする必要があるかどうか調べます。
isEncodeRequired() - interface jp.co.intra_mart.framework.base.session.SessionFactory のメソッド
セッション情報をURLに含めてエンコードする必要があるかどうか調べます。
isEndCategory(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のメソッド
指定されたカテゴリコードに対する商品カテゴリが末端のカテゴリか調べます。
isError() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
処理要求が成功したかどうかを判定します。
isError() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
処理要求が成功したかどうかを判定します。
isExclusive() - class jp.co.intra_mart.foundation.datastore.exporter.Filter のメソッド
フィルタリング対象の値が除外されるかどうか
isExistString(String[], String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
配列内に指定した文字列が含まれているかどうかをチェックする。
isExpired() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
試用期限が切れているかどうかを判定します。
isFalse(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を真偽判定します。
isFile() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルが普通のファイルかどうかを判定します。
isFirstLogin(String, String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
初回ログインの判定

isFirstLogin(String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
初回ログインの判定

初回ログインかどうかを判定します。
isFirstLogin(String, String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
初回ログインの判定

isFormField() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
単純なフォームフィールドかどうかを取得します。
isForwardInitialPage(String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
パスワード変更後の画面遷移。
isForwardInitialPage() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
パスワード変更後の画面遷移。
isForwardInitialPage(String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
パスワード変更後の画面遷移。
isFree() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
ライセンスフリーであるかどうかを判定します。
isFunction() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値が関数かどうか判定します。
isGoOut() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
外出状態を取得します。
isGroup(String) - class jp.co.intra_mart.foundation.acssecurity.Logingp の static メソッド
推奨されていません。 代替えメソッドはありません。
isHoliday(String, CategorizedCalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
休日かどうか判定します。
isHoliday() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
休日設定にマッチしているかどうかを取得します。
isInMemory() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
ファイルの内容がメモリから読み込まれるかどうかを取得します。
isInput(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの空値チェック。
isInput(Number) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの空値チェック。
isInstance(Class) - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値が c が表すオブジェクトと代入互換の 関係にあるかどうか判定します。
isInternational() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性が国際化の対象であるかどうかを取得します。
isInternational() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティが国際化の対象であるかどうかを取得します。
isInvalidatableByUser(ActiveSessionInfo) - interface jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor のメソッド
ユーザ自身のセッションの無効化が可能か取得します。
isInvalidatableByUser(String, String) - interface jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor のメソッド
ユーザ自身のセッションの無効化が可能か取得します。
isInvalidatableByUser(ActiveSessionInfo) - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager のメソッド
ユーザ自身のセッションの無効化が可能か取得します。
isInvalidatableByUser(String, String) - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager のメソッド
ユーザ自身のセッションの無効化が可能か取得します。
isInvalidatableByUser(ActiveSessionInfo) - class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor のメソッド
ユーザ自身のセッションの無効化が可能か取得します。
isInvalidatableByUser(String, String) - class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor のメソッド
ユーザ自身のセッションの無効化が可能か取得します。
isKatakanaString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
文字列が半角カナ文字列かチェックする。
isKessaiDateString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
決済年月日(YYYYMMDD)として有効かをチェックする。
isLenEqual(String, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの入力バイト数チェック。
isLenEqual(String, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの入力バイト数チェック（引数がクラス版）。
isLenEqual(Number, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの入力桁数チェック。
isLenEqual(Number, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの入力桁数チェック（引数がクラス版）。
isLenLessThan(String, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムのバイト数が指定バイト数より小さいか(等号を含む)。
isLenLessThan(String, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムのバイト数が指定バイト数より小さいか(等号を含む)（引数がクラス版）。
isLenLessThan(Number, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの桁数が指定桁数より小さいか(等号を含む)。
isLenLessThan(Number, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの桁数が指定桁数より小さいか(等号を含む)（引数がクラス版）。
isLenMoreThan(String, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムのバイト数が指定バイト数より大きいか(等号を含まない)。
isLenMoreThan(String, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムのバイト数が指定バイト数より大きいか(等号を含まない)（引数がクラス版）。
isLenMoreThan(Number, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの桁数が指定桁数より大きいか(等号を含まない)。
isLenMoreThan(Number, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの桁数が指定桁数より大きいか(等号を含まない)（引数がクラス版）。
isLimited() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
期限付きライセンスであるかどうかを判定します。
isLoadBalancing() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
ロードバランサの有効・無効を設定を取得する。
isLock() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
アカウントロック状態を取得します。
isLocked() - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
ロックの状態を確認します。
isLogined(String, String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたユーザがログインしているかどうか判別します。
isNationalHoliday(CategorizedCalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
祝日かどうか判定します。
isNationalHoliday() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
祝祭日設定にマッチしているかどうかを取得します。。
isNengetsuString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
年月指定文字列が年月フォーマット（YYYYMM）にそっているかチェックする。
isNotNull(Object) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
not nullチェック not nullのとき true nullのとき false
isNull() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値が null かどうか判定します。
isNullAcceptable() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性にnullが設定可能であるかどうかを取得します。
isNumber() - class jp.co.intra_mart.foundation.database.DatabaseColumn のメソッド

isNumberString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
文字列が数値かどうかをチェックする。
isNumeralRange(String, Number, Number) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
指定した数値カラムが指定した数値の範囲なのかチェック
範囲最大値、または最小値と同じ値は範囲内に含まれる。
isObject() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値がオブジェクトかどうか判定します。
isObservable() - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
アクティブセッションの監視を行うかどうか取得します。
isObservable(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
アクティブセッションの監視を行うかどうか取得します。
isObservable() - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
アクティブセッションの監視を行うかどうか取得します。
isPasswordExpired(String, String, String, Date) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
パスワード変更要求の判定。
isPasswordExpired(String, String, Date) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
パスワード有効期限切れかどうかの判定。
isPasswordExpired(String, String, String, Date) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
パスワードが有効期限切れかどうかの判定。
isPasswordHistoryManaged(String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
履歴管理の有無。
isPasswordHistoryManaged() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
履歴管理の有無。
isPasswordHistoryManaged(String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
履歴管理の有無。
isPermissionCheck() - class jp.co.intra_mart.foundation.navigator.EventFlowInfo のメソッド
パーミッションチェックフラグ取得
isPermissionCheck() - class jp.co.intra_mart.foundation.navigator.ResultPageItemInfo のメソッド
パーミッションチェックフラグ取得
isPermissionCheck() - class jp.co.intra_mart.foundation.navigator.SelectItemInfo のメソッド
パーミッションチェックフラグ取得
isPopup() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
リンクへ参照時にポップアップを呼び出すかどうかを取得します。
isPrimaryKey() - class jp.co.intra_mart.foundation.database.DatabaseColumn のメソッド

isProcessing() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
クライアントのアクセスに対して処理中がどうか取得する。
isReadOnly() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 Connection が読み込み専用モードかどうかを判定します。
isRegisteredAccountLicense(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
指定されたユーザがライセンスに登録されているかどうかをチェックします。
isRegisteredApplicationLicenseToAccount(String, String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
アカウントにアプリケーションライセンスが登録されてるか検証します。
isRequiredCheck() - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド
権限チェック要否
isRetry() - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader のメソッド
インポート異常終了後の再実行時に、リトライ処理として実行するかどうか。
isShimebiString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
締め日(YYYYMMDD)として有効かをチェックする。
isShutdown() - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の static メソッド
シャットダウン中（またはシャットダウン処理終了）かどうかを判定。
isSuccess() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
ＢＡＰＩ実行が正常に行われたか判定します｡

ＢＡＰＩ実行結果であるBapiReturndのType情報が 正常(デフォルト値: "S" / "")であった場合"true"をそれ以外は"false"を返します｡ 正常と判断させる条件はプロパティファイル、 またはBapiController.setIgnoreErrMsgReturnTypes(List)、 BapiController.addIgnoreErrMsgReturnType(String)でカスタマイズできます。
isSuccess() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryResult のメソッド
パスワードチェックの成否を取得します。
isTerminable() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性が期間化の対象であるかどうかを取得します。
isTerminable() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティが期間化の対象であるかどうかを取得します。
isTerminableInternational() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティが期間国際化の対象であるかどうかを取得します。
isTitleBar() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
タイトルバーを表示するかどうかのステータスを取得します。
isTransaction() - interface jp.co.intra_mart.foundation.database.DatabaseAccessor のメソッド
データベースアクセスのトランザクション状態を取得します。
isTransaction() - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
データベースアクセスのトランザクション状態を取得します。
isTrial() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
試用版であるかどうかを判定します。
isTrue(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を真偽判定します。
isUndefined() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値が undefined かどうか判定します。
isUpDate(String, Date) - class jp.co.intra_mart.foundation.update.UpdateManager のメソッド
更新管理キーの更新日付が検証日付より新しいか検証します。
isUpdate(Date) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
アクセスコントローラが指定された日付よりも新しいかチェックします。
isUpdate(Date) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウント情報が指定された日付よりも新しいかチェックします。
isUpdate(Date) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチ情報が指定された日付よりも新しいかチェックします。
isUpdate(String, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータが指定された日付よりも新しいかチェックします。
isUpdate(Date) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニュー情報が指定された日付よりも新しいかチェックします。
isUpdate(Date) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール情報が指定された日付よりも新しいかチェックします。
isValid(HttpServletRequest, ExtendedHttpServletResponse) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidator のメソッド
イベントリスナを動作させるかどうかの意思決定をします。
isValid(String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
isValid() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
アクティブなセッション情報が有効かどうか取得します。
isValid(String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
isValid(String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
isValid(TagData) - class jp.co.intra_mart.framework.base.web.tag.FormTEI のメソッド
Formタグに指定された内容の正当性を検証します。
isValid(TagData) - class jp.co.intra_mart.framework.base.web.tag.FrameTEI のメソッド
Frameタグに指定された内容の正当性を検証します。
isValid(TagData) - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI のメソッド
HelperBeanタグに指定された内容の正当性を検証します。
isValid(TagData) - class jp.co.intra_mart.framework.base.web.tag.LinkTEI のメソッド
Linkタグに指定された内容の正当性を検証します。
isValid(TagData) - class jp.co.intra_mart.framework.base.web.tag.MessageTEI のメソッド
Messageタグに指定された内容の正当性を検証します。
isValid(TagData) - class jp.co.intra_mart.framework.base.web.tag.SubmitTEI のメソッド
Linkタグに指定された内容の正当性を検証します。
isValidDate(String, String, String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。
isValidate() - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader のメソッド
インポートデータに対してバリデーションを行うかどうか。
isValidate() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
有効・無効フラグを取得します。
isValueEqual(String, String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラム１の値とカラム２の値が同一かのチェック。
isValueEqual(Number, Number) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラム１の値とカラム２の値が同一かのチェック。
isValueLessThan(String, String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラム１の値がカラム２の値より小さいか(等号を含まず)のチェック。
isValueLessThan(Number, Number) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラム１の値がカラム２の値より小さいか(等号を含まず)のチェック。
isValueMoreThan(String, String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラム１の値がカラム２の値より大きいか(等号を含まず)のチェック。
isValueMoreThan(Number, Number) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラム１の値がカラム２の値より大きいか(等号を含まず)のチェック。
isWeekDate(String, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。
isWeekDate(String, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。
isWeekday(String, CategorizedCalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
平日かどうか判定します。
isWeekday() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
非休日設定にマッチしているかどうかを取得します。
iterator() - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
このリスト内の要素を適切な順序で繰り返し処理する反復子を返します。
iterator() - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 このリスト内の要素を適切な順序で繰り返し処理する反復子を返します。

J

J2eeFwPortlet - class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet.
ページ種別「J2EEフレームワーク」に対するポートレットのモデルです。
J2eeFwPortlet() - class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet のコンストラクタ

JDBCConnector - class jp.co.intra_mart.framework.base.data.JDBCConnector.
推奨されていません。 JDBCを直接扱わず、DataSourceを使用するようにしてください。
JDBCConnector() - class jp.co.intra_mart.framework.base.data.JDBCConnector のコンストラクタ
推奨されていません。 新規のJDBCConnectorを生成します。
JavaMailPropertyException - exception jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException.
JavaMailSenderの設定に関する情報を提供する例外です。
JavaMailPropertyException() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException のコンストラクタ
JavaMailPropertyExceptionを構築します。
JavaMailPropertyException(String) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException のコンストラクタ
指定された詳細メッセージを使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyException(String, Throwable) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException のコンストラクタ
指定された詳細メッセージおよび原因を使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyException(Throwable) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException のコンストラクタ
指定された原因を使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyHandler - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler.
JavaMailSenderの設定を保持します。
JavaMailPropertyHandlerInitializerImpl - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl.
JavaMailPropertyHandlerの初期化クラス。
JavaMailPropertyHandlerInitializerImpl() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl のコンストラクタ

JavaMailSender - class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender.
JavaMailをラップしたメール送信オブジェクトです。
JavaMailSender(StandardMail) - class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender のコンストラクタ
JavaMailSenderを新規に作成します。
JspPortlet - class jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet.
ページ種別「Servlet/JSP」に対するポートレットのモデルです。
JspPortlet() - class jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet のコンストラクタ

joinDepartment(String, String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織構成に組織を登録します。
joinPublicGroup(String, String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループ構成にパブリックグループを登録します。
jp.co.intra_mart.common.aid.javaee.http - package jp.co.intra_mart.common.aid.javaee.http
このパッケージには、ファイルをアップロードする際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.javaee.http.fileupload - package jp.co.intra_mart.common.aid.javaee.http.fileupload
このパッケージには、アップロードされたファイルを扱うクラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.io - package jp.co.intra_mart.common.aid.jdk.java.io
このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.io.file - package jp.co.intra_mart.common.aid.jdk.java.io.file
このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.lang - package jp.co.intra_mart.common.aid.jdk.java.lang
このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.net - package jp.co.intra_mart.common.aid.jdk.java.net
ソケットによるネットワーク対応機能を実装するためのクラスを提供します。
jp.co.intra_mart.common.aid.jdk.java.util - package jp.co.intra_mart.common.aid.jdk.java.util
このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.javax.xml - package jp.co.intra_mart.common.aid.jdk.javax.xml
このパッケージには、ＸＭＬを利用するためのクラスが含まれています。
jp.co.intra_mart.common.aid.jdk.org.w3c.dom - package jp.co.intra_mart.common.aid.jdk.org.w3c.dom
このパッケージには、ＤＯＭを利用するためのクラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util - package jp.co.intra_mart.common.aid.jdk.util
このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util.charset - package jp.co.intra_mart.common.aid.jdk.util.charset
このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util.report - package jp.co.intra_mart.common.aid.jdk.util.report
このパッケージには、ログ機能を実装するための汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet - package jp.co.intra_mart.common.aid.jsdk.javax.servlet
このパッケージには、サーブレットを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception - package jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter - package jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http - package jp.co.intra_mart.common.aid.jsdk.javax.servlet.http
このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session - package jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.utility - package jp.co.intra_mart.common.aid.jsdk.utility
このパッケージには、ＨＴＭＬの表示変換に 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.platform.util - package jp.co.intra_mart.common.platform.util
このパッケージには、プラットフォームを利用する際に 便利なユーティリティクラスが含まれています。
jp.co.intra_mart.common.platform.vm - package jp.co.intra_mart.common.platform.vm
このパッケージには、コマンド実引数を解釈するための共通クラスが含まれています。
jp.co.intra_mart.extension.maskat.exception - package jp.co.intra_mart.extension.maskat.exception

jp.co.intra_mart.extension.maskat.service - package jp.co.intra_mart.extension.maskat.service

jp.co.intra_mart.extension.maskat.service.controller - package jp.co.intra_mart.extension.maskat.service.controller

jp.co.intra_mart.extension.maskat.util - package jp.co.intra_mart.extension.maskat.util

jp.co.intra_mart.foundation.acssecurity - package jp.co.intra_mart.foundation.acssecurity
アクセスセキュリティモジュールを利用するためのクラスを提供します。
jp.co.intra_mart.foundation.commons - package jp.co.intra_mart.foundation.commons

jp.co.intra_mart.foundation.commons.validation - package jp.co.intra_mart.foundation.commons.validation
このパッケージは、入力チェック関数ライブラリを提供します。
jp.co.intra_mart.foundation.database - package jp.co.intra_mart.foundation.database
データベースへアクセスするためのクラスを提供します。
jp.co.intra_mart.foundation.database.exception - package jp.co.intra_mart.foundation.database.exception
データベースＳＱＬ例外クラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category - package jp.co.intra_mart.foundation.datastore.application.domain.category
分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class - package jp.co.intra_mart.foundation.datastore.application.domain.category.category_class
分類区分情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category.detail - package jp.co.intra_mart.foundation.datastore.application.domain.category.detail
分類詳細情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company - package jp.co.intra_mart.foundation.datastore.application.domain.company
会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.attach - package jp.co.intra_mart.foundation.datastore.application.domain.company.attach
組織所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.category - package jp.co.intra_mart.foundation.datastore.application.domain.company.category
会社分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.company - package jp.co.intra_mart.foundation.datastore.application.domain.company.company
会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.department - package jp.co.intra_mart.foundation.datastore.application.domain.company.department
組織情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.main - package jp.co.intra_mart.foundation.datastore.application.domain.company.main
主所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.post - package jp.co.intra_mart.foundation.datastore.application.domain.company.post
役職情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.version - package jp.co.intra_mart.foundation.datastore.application.domain.company.version
バーション情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.currency - package jp.co.intra_mart.foundation.datastore.application.domain.currency
通貨情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal - package jp.co.intra_mart.foundation.datastore.application.domain.deal
取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.deal - package jp.co.intra_mart.foundation.datastore.application.domain.deal.deal
取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.department - package jp.co.intra_mart.foundation.datastore.application.domain.deal.department
取扱組織権限情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.detail - package jp.co.intra_mart.foundation.datastore.application.domain.deal.detail
取扱詳細情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group - package jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group
取扱パブリックグループ権限情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.role - package jp.co.intra_mart.foundation.datastore.application.domain.deal.role
取扱ロール権限情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item - package jp.co.intra_mart.foundation.datastore.application.domain.item
商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item.attribute - package jp.co.intra_mart.foundation.datastore.application.domain.item.attribute
商品属性情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue - package jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue
商品カタログ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item.item - package jp.co.intra_mart.foundation.datastore.application.domain.item.item
商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category - package jp.co.intra_mart.foundation.datastore.application.domain.item_category
商品カテゴリ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach - package jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach
商品分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category.category - package jp.co.intra_mart.foundation.datastore.application.domain.item_category.category
商品カテゴリ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category.type - package jp.co.intra_mart.foundation.datastore.application.domain.item_category.type
商品カテゴリ種別情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_template - package jp.co.intra_mart.foundation.datastore.application.domain.item_template
商品テンプレート属性情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail - package jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail
商品テンプレート属性詳細情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_template.template - package jp.co.intra_mart.foundation.datastore.application.domain.item_template.template
商品テンプレート属性情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group - package jp.co.intra_mart.foundation.datastore.application.domain.private_group
プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach - package jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach
プライベートグループ所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group.group - package jp.co.intra_mart.foundation.datastore.application.domain.private_group.group
プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group - package jp.co.intra_mart.foundation.datastore.application.domain.public_group
パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach - package jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach
パブリックグループ所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category - package jp.co.intra_mart.foundation.datastore.application.domain.public_group.category
パブリックグループ分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group - package jp.co.intra_mart.foundation.datastore.application.domain.public_group.group
パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set - package jp.co.intra_mart.foundation.datastore.application.domain.public_group.set
パブリックグループセット情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.version - package jp.co.intra_mart.foundation.datastore.application.domain.public_group.version
パブリックグループバージョン情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.unit - package jp.co.intra_mart.foundation.datastore.application.domain.unit
商品単位情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user - package jp.co.intra_mart.foundation.datastore.application.domain.user
ユーザ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.category_class - package jp.co.intra_mart.foundation.datastore.application.model.category.category_class
分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail - package jp.co.intra_mart.foundation.datastore.application.model.category.detail
分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach - package jp.co.intra_mart.foundation.datastore.application.model.company.attach
組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category - package jp.co.intra_mart.foundation.datastore.application.model.company.category
会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company - package jp.co.intra_mart.foundation.datastore.application.model.company.company
会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department - package jp.co.intra_mart.foundation.datastore.application.model.company.department
組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion - package jp.co.intra_mart.foundation.datastore.application.model.company.inclusion
組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main - package jp.co.intra_mart.foundation.datastore.application.model.company.main
組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post - package jp.co.intra_mart.foundation.datastore.application.model.company.post
会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version - package jp.co.intra_mart.foundation.datastore.application.model.company.version
会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.deal - package jp.co.intra_mart.foundation.datastore.application.model.deal.deal
取扱情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.department - package jp.co.intra_mart.foundation.datastore.application.model.deal.department
取扱組織権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.detail - package jp.co.intra_mart.foundation.datastore.application.model.deal.detail
取扱詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group - package jp.co.intra_mart.foundation.datastore.application.model.deal.public_group
取扱パブリックグループ権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.role - package jp.co.intra_mart.foundation.datastore.application.model.deal.role
取扱ロール権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.attribute - package jp.co.intra_mart.foundation.datastore.application.model.item.attribute
商品属性情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue - package jp.co.intra_mart.foundation.datastore.application.model.item.catalogue
商品カタログ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.item - package jp.co.intra_mart.foundation.datastore.application.model.item.item
商品情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach - package jp.co.intra_mart.foundation.datastore.application.model.item_category.attach
商品分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.category - package jp.co.intra_mart.foundation.datastore.application.model.item_category.category
商品カテゴリ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.type - package jp.co.intra_mart.foundation.datastore.application.model.item_category.type
商品カテゴリ種別情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail - package jp.co.intra_mart.foundation.datastore.application.model.item_template.detail
商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.template - package jp.co.intra_mart.foundation.datastore.application.model.item_template.template
商品テンプレート情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach - package jp.co.intra_mart.foundation.datastore.application.model.private_group.attach
プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group - package jp.co.intra_mart.foundation.datastore.application.model.private_group.group
プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach - package jp.co.intra_mart.foundation.datastore.application.model.public_group.attach
パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category - package jp.co.intra_mart.foundation.datastore.application.model.public_group.category
パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group - package jp.co.intra_mart.foundation.datastore.application.model.public_group.group
パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion - package jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion
パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set - package jp.co.intra_mart.foundation.datastore.application.model.public_group.set
パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version - package jp.co.intra_mart.foundation.datastore.application.model.public_group.version
パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.unit - package jp.co.intra_mart.foundation.datastore.application.model.unit
単位情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user - package jp.co.intra_mart.foundation.datastore.application.model.user
ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.accessor - package jp.co.intra_mart.foundation.datastore.common.accessor
情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.config - package jp.co.intra_mart.foundation.datastore.common.config
アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。
jp.co.intra_mart.foundation.datastore.common.model - package jp.co.intra_mart.foundation.datastore.common.model
情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.foundation.datastore.common.structure - package jp.co.intra_mart.foundation.datastore.common.structure
期間情報などを扱うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exception - package jp.co.intra_mart.foundation.datastore.exception
アプリケーション共通マスタで発生する例外クラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter - package jp.co.intra_mart.foundation.datastore.exporter
アプリケーション共通マスタのエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.common.config - package jp.co.intra_mart.foundation.datastore.exporter.common.config
エクスポート設定の解釈を行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.company - package jp.co.intra_mart.foundation.datastore.exporter.company
会社・組織関連の情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.public_group - package jp.co.intra_mart.foundation.datastore.exporter.public_group
パブリックグループ情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.user - package jp.co.intra_mart.foundation.datastore.exporter.user
ユーザ関連の情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer - package jp.co.intra_mart.foundation.datastore.importer
アプリケーション共通マスタのインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.common.config - package jp.co.intra_mart.foundation.datastore.importer.common.config
インポート定義情報の解釈を行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.company - package jp.co.intra_mart.foundation.datastore.importer.company
会社・組織関連の情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.public_group - package jp.co.intra_mart.foundation.datastore.importer.public_group
パブリックグループ情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.user - package jp.co.intra_mart.foundation.datastore.importer.user
ユーザ関連の情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.drawer - package jp.co.intra_mart.foundation.drawer
画像ファイル出力用クラスを提供します。
jp.co.intra_mart.foundation.exception - package jp.co.intra_mart.foundation.exception
システムでスローされる例外クラスを提供します。
jp.co.intra_mart.foundation.graph - package jp.co.intra_mart.foundation.graph
グラフ描画に関するクラスを提供します。
jp.co.intra_mart.foundation.http - package jp.co.intra_mart.foundation.http
ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.http.ajax - package jp.co.intra_mart.foundation.http.ajax

jp.co.intra_mart.foundation.im_curl - package jp.co.intra_mart.foundation.im_curl
intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
jp.co.intra_mart.foundation.image - package jp.co.intra_mart.foundation.image

jp.co.intra_mart.foundation.log - package jp.co.intra_mart.foundation.log

jp.co.intra_mart.foundation.mail - package jp.co.intra_mart.foundation.mail
メール送信に関するクラスを提供します。
jp.co.intra_mart.foundation.mail.javamail - package jp.co.intra_mart.foundation.mail.javamail
メール送信クラスを提供します。
jp.co.intra_mart.foundation.mail.javamail.listener - package jp.co.intra_mart.foundation.mail.javamail.listener

jp.co.intra_mart.foundation.mail.javamail.listener.impl - package jp.co.intra_mart.foundation.mail.javamail.listener.impl

jp.co.intra_mart.foundation.mail.javamail.model - package jp.co.intra_mart.foundation.mail.javamail.model

jp.co.intra_mart.foundation.mail.javamail.property - package jp.co.intra_mart.foundation.mail.javamail.property

jp.co.intra_mart.foundation.navigator - package jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.page - package jp.co.intra_mart.foundation.page
ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.portal.common.encode - package jp.co.intra_mart.foundation.portal.common.encode

jp.co.intra_mart.foundation.portal.common.rss - package jp.co.intra_mart.foundation.portal.common.rss

jp.co.intra_mart.foundation.portal.general_purpose_portlet - package jp.co.intra_mart.foundation.portal.general_purpose_portlet

jp.co.intra_mart.foundation.portal.general_purpose_portlet.model - package jp.co.intra_mart.foundation.portal.general_purpose_portlet.model

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider - package jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider

jp.co.intra_mart.foundation.portal.portlet - package jp.co.intra_mart.foundation.portal.portlet

jp.co.intra_mart.foundation.portal.portlet.model - package jp.co.intra_mart.foundation.portal.portlet.model

jp.co.intra_mart.foundation.sap.common.auth - package jp.co.intra_mart.foundation.sap.common.auth
ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.auth.exception - package jp.co.intra_mart.foundation.sap.common.auth.exception
ＳＡＰ連携に関する例外クラスを提供します。
jp.co.intra_mart.foundation.sap.common.exception - package jp.co.intra_mart.foundation.sap.common.exception

jp.co.intra_mart.foundation.sap.common.general_purpose - package jp.co.intra_mart.foundation.sap.common.general_purpose
ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose.exception - package jp.co.intra_mart.foundation.sap.common.general_purpose.exception
ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.model - package jp.co.intra_mart.foundation.sap.common.model

jp.co.intra_mart.foundation.sap.common.util - package jp.co.intra_mart.foundation.sap.common.util

jp.co.intra_mart.foundation.sap.common.util.data - package jp.co.intra_mart.foundation.sap.common.util.data
ＳＡＰ連携にて使用するデータ変換クラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.date - package jp.co.intra_mart.foundation.sap.common.util.date
ＳＡＰ連携にて使用する日付操作クラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.file - package jp.co.intra_mart.foundation.sap.common.util.file
ＳＡＰ連携にて使用するプロパティを操作するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.message - package jp.co.intra_mart.foundation.sap.common.util.message

jp.co.intra_mart.foundation.sap.module - package jp.co.intra_mart.foundation.sap.module

jp.co.intra_mart.foundation.sap.module.accounting - package jp.co.intra_mart.foundation.sap.module.accounting
ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting.exception - package jp.co.intra_mart.foundation.sap.module.accounting.exception
ＳＡＰ連携財務会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.exception - package jp.co.intra_mart.foundation.sap.module.exception

jp.co.intra_mart.foundation.sap.module.financial - package jp.co.intra_mart.foundation.sap.module.financial
ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial.exception - package jp.co.intra_mart.foundation.sap.module.financial.exception
ＳＡＰ連携管理会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase - package jp.co.intra_mart.foundation.sap.module.purchase
ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.common.model - package jp.co.intra_mart.foundation.sap.module.purchase.common.model

jp.co.intra_mart.foundation.sap.module.purchase.exception - package jp.co.intra_mart.foundation.sap.module.purchase.exception
ＳＡＰ連携経費購買系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate - package jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems - package jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability - package jp.co.intra_mart.foundation.sap.module.purchase.materialavailability

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall - package jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica - package jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber - package jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber

jp.co.intra_mart.foundation.sap.module.sales - package jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple - package jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail - package jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist - package jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist

jp.co.intra_mart.foundation.sap.module.sales.common.model - package jp.co.intra_mart.foundation.sap.module.sales.common.model

jp.co.intra_mart.foundation.sap.module.sales.exception - package jp.co.intra_mart.foundation.sap.module.sales.exception

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 - package jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 - package jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 - package jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist - package jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus - package jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus

jp.co.intra_mart.foundation.scenario - package jp.co.intra_mart.foundation.scenario
スクリプト開発モデルのプログラムと連携するＡＰＩ。
jp.co.intra_mart.foundation.security - package jp.co.intra_mart.foundation.security
アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access - package jp.co.intra_mart.foundation.security.access

jp.co.intra_mart.foundation.security.account - package jp.co.intra_mart.foundation.security.account
アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession - package jp.co.intra_mart.foundation.security.activesession

jp.co.intra_mart.foundation.security.admin - package jp.co.intra_mart.foundation.security.admin
システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch - package jp.co.intra_mart.foundation.security.batch
バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar - package jp.co.intra_mart.foundation.security.calendar
カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification - package jp.co.intra_mart.foundation.security.certification
認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification.ldap.extension - package jp.co.intra_mart.foundation.security.certification.ldap.extension
ユーザログインLDAP認証クラス(複数OU対応版)の設定方法。
jp.co.intra_mart.foundation.security.cryption - package jp.co.intra_mart.foundation.security.cryption
暗号化に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.duplication - package jp.co.intra_mart.foundation.security.duplication

jp.co.intra_mart.foundation.security.exception - package jp.co.intra_mart.foundation.security.exception
アクセスセキュリティ例外に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.filter - package jp.co.intra_mart.foundation.security.filter
アクセスセキュリティのフィルタに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group - package jp.co.intra_mart.foundation.security.group
グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.license - package jp.co.intra_mart.foundation.security.license
ライセンスに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu - package jp.co.intra_mart.foundation.security.menu
メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.message - package jp.co.intra_mart.foundation.security.message
メッセージに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.mobile - package jp.co.intra_mart.foundation.security.mobile

jp.co.intra_mart.foundation.security.password - package jp.co.intra_mart.foundation.security.password

jp.co.intra_mart.foundation.security.permission - package jp.co.intra_mart.foundation.security.permission
権限に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role - package jp.co.intra_mart.foundation.security.role
ロールに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.servlet - package jp.co.intra_mart.foundation.security.servlet
サーブレットに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.shortcut - package jp.co.intra_mart.foundation.security.shortcut

jp.co.intra_mart.foundation.service.client - package jp.co.intra_mart.foundation.service.client
このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.client.application - package jp.co.intra_mart.foundation.service.client.application
このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content - package jp.co.intra_mart.foundation.service.client.application.content
このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.batch - package jp.co.intra_mart.foundation.service.client.batch
Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file - package jp.co.intra_mart.foundation.service.client.file
Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information - package jp.co.intra_mart.foundation.service.client.information
このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.manager - package jp.co.intra_mart.foundation.service.client.manager
このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.provider - package jp.co.intra_mart.foundation.service.provider
このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.service.provider.application - package jp.co.intra_mart.foundation.service.provider.application
このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。
jp.co.intra_mart.foundation.service.provider.batch - package jp.co.intra_mart.foundation.service.provider.batch
このパッケージには、スケジュール実行されるバッチプログラム機能を利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.provider.file - package jp.co.intra_mart.foundation.service.provider.file
このパッケージには、Storage Service 環境内で利用可能な機能を提供します。
jp.co.intra_mart.foundation.service.provider.information - package jp.co.intra_mart.foundation.service.provider.information
このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。
jp.co.intra_mart.foundation.smtp - package jp.co.intra_mart.foundation.smtp
メール連携モジュール。
jp.co.intra_mart.foundation.update - package jp.co.intra_mart.foundation.update

jp.co.intra_mart.foundation.utility - package jp.co.intra_mart.foundation.utility
このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.charset - package jp.co.intra_mart.foundation.utility.charset
このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.file - package jp.co.intra_mart.foundation.utility.file
このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.io - package jp.co.intra_mart.foundation.utility.io
このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.net - package jp.co.intra_mart.foundation.utility.net
ソケットによるネットワーク対応機能を実装するためのクラスを提供します。
jp.co.intra_mart.foundation.utility.report - package jp.co.intra_mart.foundation.utility.report
このパッケージには、ログ機能を実装するための汎用クラスが含まれています。
jp.co.intra_mart.framework.base.data - package jp.co.intra_mart.framework.base.data
データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.data.container - package jp.co.intra_mart.framework.base.data.container

jp.co.intra_mart.framework.base.data.container.factory - package jp.co.intra_mart.framework.base.data.container.factory

jp.co.intra_mart.framework.base.event - package jp.co.intra_mart.framework.base.event
イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event.container - package jp.co.intra_mart.framework.base.event.container

jp.co.intra_mart.framework.base.event.container.factory - package jp.co.intra_mart.framework.base.event.container.factory

jp.co.intra_mart.framework.base.message - package jp.co.intra_mart.framework.base.message
メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service - package jp.co.intra_mart.framework.base.service
サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.container - package jp.co.intra_mart.framework.base.service.container

jp.co.intra_mart.framework.base.service.container.factory - package jp.co.intra_mart.framework.base.service.container.factory

jp.co.intra_mart.framework.base.service.controller - package jp.co.intra_mart.framework.base.service.controller

jp.co.intra_mart.framework.base.service.validator - package jp.co.intra_mart.framework.base.service.validator

jp.co.intra_mart.framework.base.session - package jp.co.intra_mart.framework.base.session
セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util - package jp.co.intra_mart.framework.base.util

jp.co.intra_mart.framework.base.web.bean - package jp.co.intra_mart.framework.base.web.bean
JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.tag - package jp.co.intra_mart.framework.base.web.tag
J2EEフレームワークで使用する各種のタグのパッケージです。
jp.co.intra_mart.framework.base.web.tag.attribute - package jp.co.intra_mart.framework.base.web.tag.attribute
タグ属性のパッケージです。
jp.co.intra_mart.framework.base.web.util - package jp.co.intra_mart.framework.base.web.util
Web上で使用するユーティリティのパッケージです。
jp.co.intra_mart.framework.extension.common.util - package jp.co.intra_mart.framework.extension.common.util
im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.seasar.data - package jp.co.intra_mart.framework.extension.seasar.data

jp.co.intra_mart.framework.extension.seasar.event - package jp.co.intra_mart.framework.extension.seasar.event

jp.co.intra_mart.framework.extension.seasar.jta - package jp.co.intra_mart.framework.extension.seasar.jta

jp.co.intra_mart.framework.extension.seasar.service - package jp.co.intra_mart.framework.extension.seasar.service

jp.co.intra_mart.framework.extension.seasar.util - package jp.co.intra_mart.framework.extension.seasar.util

jp.co.intra_mart.framework.extension.struts.action - package jp.co.intra_mart.framework.extension.struts.action
im-J2EE FrameworkとStrutsを連携するためのユーティリティです。
jp.co.intra_mart.framework.system.container - package jp.co.intra_mart.framework.system.container

jp.co.intra_mart.framework.system.container.factory - package jp.co.intra_mart.framework.system.container.factory

jp.co.intra_mart.framework.system.exception - package jp.co.intra_mart.framework.system.exception
J2EEフレームワークの例外に関連するパッケージです。
jp.co.intra_mart.framework.system.log - package jp.co.intra_mart.framework.system.log
J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.message - package jp.co.intra_mart.framework.system.message
メッセージに関連するパッケージです。
jp.co.intra_mart.framework.system.property - package jp.co.intra_mart.framework.system.property
プロパティ取得に関連するパッケージです。
jp.co.intra_mart.framework.system.util - package jp.co.intra_mart.framework.system.util

jp.co.intra_mart.jssp.net - package jp.co.intra_mart.jssp.net

jp.co.intra_mart.system.security.datastore.inf - package jp.co.intra_mart.system.security.datastore.inf

K

KEY - class jp.co.intra_mart.framework.system.property.DefaultPropertyManager の static 変数
プロパティマネージャを指定するキー
KEY - class jp.co.intra_mart.framework.system.property.PropertyManager の static 変数
プロパティマネージャを指定するキー
KEY - class jp.co.intra_mart.framework.system.property.XmlPropertyManager の static 変数
プロパティマネージャを指定するキー
KEY_AUTH_COOKIE_NAME - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の static 変数

KEY_DRIVER - class jp.co.intra_mart.framework.base.data.JDBCConnector の static 変数
推奨されていません。 データベースドライバのキー
KEY_JNDI_NAME - class jp.co.intra_mart.framework.base.data.DataSourceConnector の static 変数
DataSourceのJNDI名のキー
KEY_LOGIN_KEY - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の static 変数

KEY_PASSWORD - class jp.co.intra_mart.framework.base.data.JDBCConnector の static 変数
推奨されていません。 データベース接続ユーザパスワードのキー
KEY_REPOSITORY - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle の static 変数
一時ファイルの保存先 のキー
KEY_SIZE_THRESHOLD - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle の static 変数
一時ファイルを作成するかどうかの閾値のキー
KEY_URL - class jp.co.intra_mart.framework.base.data.JDBCConnector の static 変数
推奨されていません。 データベースURLのキー
KEY_USERNAME - class jp.co.intra_mart.framework.base.data.JDBCConnector の static 変数
推奨されていません。 データベース接続ユーザ名のキー
KEY_USE_COMMONS_FILEUPLOAD - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle の static 変数
CommonsFileUploadを利用するかどうかのキー
KIND_NAVIGATOR - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
種別 イベントナビゲーター
KIND_NAVIGATOR - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor の static 変数
種別 ロール。
KIND_ROLE - class jp.co.intra_mart.foundation.security.StandardRoleAccessor の static 変数
種別 ロール。
KIND_ROLE - class jp.co.intra_mart.foundation.security.exception.AccessSecurityException の static 変数
種別 ロール。
KIND_ROLE - class jp.co.intra_mart.foundation.security.role.StandardRoleBackup の static 変数
種別 ロール。
KIND_ROLE_SUB - class jp.co.intra_mart.foundation.security.StandardRoleAccessor の static 変数
種別 サブロール(ロール)。
KIND_ROLE_SUB - class jp.co.intra_mart.foundation.security.exception.AccessSecurityException の static 変数
種別 サブロール(ロール)。
Keys - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys.
参照キーの出力テーブル情報クラス
機能は以下の通り
参照キーの出力テーブル情報を保持します。
Keys() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のコンストラクタ
参照キーの出力テーブル情報を作成します。
Keys(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のコンストラクタ
参照キーの出力テーブル情報を作成します。
keyList() - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
キー一覧を取得します。
keyList() - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
キー一覧を取得します。
keyList() - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
キー一覧を取得します。
keyList() - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
キー一覧を取得します。
keys() - interface jp.co.intra_mart.foundation.scenario.VariableScope のメソッド
プロパティの名称一覧を取得します。

L

LANG_JAVA - class jp.co.intra_mart.foundation.security.batch.Batch の static 変数
プログラム言語(JAVA)。
LANG_JAVA_SCRIPT - class jp.co.intra_mart.foundation.security.batch.Batch の static 変数
プログラム言語(JavaScript)。
LDAPContextInfoBuilder - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoBuilder.
ログイングループ毎の設定情報モデルを作成するビルドクラス。
LDAPContextInfoBuilder() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoBuilder のコンストラクタ

LDAPContextInfoModel - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel.
ユーザログインLDAP認証で認証情報モデルクラス(複数OU対応版)。
LDAPContextInfoModel() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のコンストラクタ

LDAPUserCertification - class jp.co.intra_mart.foundation.security.certification.LDAPUserCertification.
ユーザログインLDAP認証クラス。
LDAPUserCertification() - class jp.co.intra_mart.foundation.security.certification.LDAPUserCertification のコンストラクタ

LDAPUserCertification - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPUserCertification.
ユーザログインLDAP認証クラス(複数OU対応版)。
LDAPUserCertification() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPUserCertification のコンストラクタ

LEVEL_DEBUG - interface jp.co.intra_mart.framework.system.log.LogConstant の static 変数
DEBUG時に出力するレベルです。
LEVEL_ERROR - interface jp.co.intra_mart.framework.system.log.LogConstant の static 変数
例外を出力するレベルです。
LEVEL_INFO - interface jp.co.intra_mart.framework.system.log.LogConstant の static 変数
情報を出力するレベルです。
LEVEL_WARNNING - interface jp.co.intra_mart.framework.system.log.LogConstant の static 変数
警告を出力するレベルです。
LISTENER_PARAM - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory の static 変数
イベントリスナーのクラス名のパラメータ名
LISTENER_PARAM - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory の static 変数
イベントリスナーのクラス名のパラメータ名
LOCALE - class jp.co.intra_mart.foundation.datastore.common.config.AttributeType の static 変数
ロケール
LOCALE - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
ロケール
LOCK_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
アカウントロック日付
LOGIN_FAILURE_COUNT - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
ログイン失敗回数
LOG_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.system.log.LogManager の static 変数
ログプロパティハンドラのキー
LT_GROUP - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
グループマネージャー（ログインタイプ）。
LT_GROUP - class jp.co.intra_mart.framework.base.util.UserInfoUtil の static 変数
グループマネージャ
LT_SUPER - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
スーパーユーザ（ログインタイプ）。
LT_SUPER - class jp.co.intra_mart.framework.base.util.UserInfoUtil の static 変数
スーパーユーザ
LT_USER - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ユーザ（ログインタイプ）。
LT_USER - class jp.co.intra_mart.framework.base.util.UserInfoUtil の static 変数
ユーザ
LengthRequiredException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException.
Content-Length 指定がないためにリクエストを正常に処理できないことを 通知するための例外です。
LengthRequiredException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException のコンストラクタ
指定のメッセージを持つ例外を作成します。
LengthRequiredException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
LengthRequiredException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException のコンストラクタ
例外を作成します。
LengthValidator - class jp.co.intra_mart.framework.base.service.validator.LengthValidator.
文字列の長さをチェックします。
LengthValidator() - class jp.co.intra_mart.framework.base.service.validator.LengthValidator のコンストラクタ

LicenseManager - class jp.co.intra_mart.foundation.security.license.LicenseManager.
ライセンス・マネージャクラス。
LicenseManager(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のコンストラクタ
コンストラクタ。
Lifetime - interface jp.co.intra_mart.foundation.datastore.common.config.Lifetime.
期間削除時の整合性制約です。
LifetimeType - class jp.co.intra_mart.foundation.datastore.common.config.LifetimeType.
期間削除時の整合性制約のタイプです。
LifoValuationData - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData.
LIFO 関連品目データ情報クラス
機能は以下の通り
LIFO 関連品目データ情報を保持します。
LifoValuationData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData のコンストラクタ
LIFO 関連品目データ情報を作成します。
LimitedSessionHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler.
セッションを一時利用のみに限定するためのフィルタです。
LimitedSessionHTTPActionEventFilterHandler(HTTPActionEventHandler) - class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler のコンストラクタ
セッションを一時利用に限定するためのフィルタハンドラを作成します。
Limits - class jp.co.intra_mart.foundation.sap.module.purchase.Limits.
外注制限情報クラス
機能は以下の通り
外注制限情報を保持します。
Limits() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のコンストラクタ
外注制限を作成します。
Limits(int) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のコンストラクタ
外注制限を作成します。
LineGraphDrawer - class jp.co.intra_mart.foundation.graph.LineGraphDrawer.
折れ線グラフを描画します。
LineGraphDrawer(int, int, int) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のコンストラクタ
ｙ軸の目盛値をint表現で折れ線グラフを作成します。
LineGraphDrawer(double, double, double) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のコンストラクタ
ｙ軸の目盛値をdouble表現で折れ線グラフを作成します。
LineGraphObject - class jp.co.intra_mart.foundation.graph.LineGraphObject.
LineGraphDrawerクラスのデータを保存するオブジェクトです。
LineGraphObject() - class jp.co.intra_mart.foundation.graph.LineGraphObject のコンストラクタ
デフォルトのデータオブジェクトを作成します。
LineGraphObject(Color) - class jp.co.intra_mart.foundation.graph.LineGraphObject のコンストラクタ
線の色を指定して、データオブジェクトを作成します。
LineGraphObject(Stroke) - class jp.co.intra_mart.foundation.graph.LineGraphObject のコンストラクタ
線の描画属性を指定して、データオブジェクトを作成します。
LineGraphObject(Color, Stroke) - class jp.co.intra_mart.foundation.graph.LineGraphObject のコンストラクタ
線の色と描画属性を指定して、データオブジェクトを作成します。
LineProperty - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty.
LinePropertyクラス
機能は以下の通り
Propertyファイル１行ごとの情報を保持します｡
上記のインスタンス変数の設定と取得のためにアクセサ・メソッドを提供します。
LineProperty(String, String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のコンストラクタ
指定されたプロパティファイルのキー情報と値でLinePropertyオブジェクト を生成します。
LineReportFilter - class jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter.
メッセージを行出力するためのフィルタークラスです。
LineReportFilter(MessageReporter) - class jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter のコンストラクタ
指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。
LineReportFilter - class jp.co.intra_mart.foundation.utility.report.LineReportFilter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter クラスを使用してください。
LineReportFilter(MessageReporter) - class jp.co.intra_mart.foundation.utility.report.LineReportFilter のコンストラクタ
推奨されていません。 指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。
LinkPageInfo - class jp.co.intra_mart.foundation.navigator.LinkPageInfo.
リンク情報
LinkPageInfo() - class jp.co.intra_mart.foundation.navigator.LinkPageInfo のコンストラクタ

LinkTEI - class jp.co.intra_mart.framework.base.web.tag.LinkTEI.
Linkタグの拡張情報です。
LinkTEI() - class jp.co.intra_mart.framework.base.web.tag.LinkTEI のコンストラクタ
LinkTEIを新規に生成します。
LinkTag - class jp.co.intra_mart.framework.base.web.tag.LinkTag.
LINKタグです。
LinkTag() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のコンストラクタ
LinkTagを新規に生成します。
LinkTagBeanInfo - class jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo.
LinkTagのBeanInfoです。
LinkTagBeanInfo() - class jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo のコンストラクタ
LinkTagBeanInfoを新規に生成します。
LocaleFilter - class jp.co.intra_mart.framework.base.service.LocaleFilter.
リクエストのロケールを設定します。
LocaleFilter() - class jp.co.intra_mart.framework.base.service.LocaleFilter のコンストラクタ

LocaleInfo - interface jp.co.intra_mart.foundation.security.LocaleInfo.
ロケｰル情報・モデルインタフェース。
LocaleProvider - interface jp.co.intra_mart.foundation.security.LocaleProvider.
ロケール取得プロバイダーインタフェース。
Localhost - class jp.co.intra_mart.common.aid.jdk.java.net.Localhost.
このクラスは、サーバプロセスの基礎情報を管理します。
Localhost - class jp.co.intra_mart.foundation.utility.net.Localhost.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.Localhost クラスを使用してください。
Lock - class jp.co.intra_mart.foundation.service.client.information.Lock.
アプリケーションロックをするための機能を提供します。
Lock(String) - class jp.co.intra_mart.foundation.service.client.information.Lock のコンストラクタ
ロックをするためのインスタンスを作ります。
LockMonitor - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor.
このクラスはモニター機能を提供します。
LockMonitor(int) - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のコンストラクタ
モニターを構築します。
LockMonitor - class jp.co.intra_mart.foundation.utility.LockMonitor.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.LockMonitor クラスを使用してください。
LockMonitor(int) - class jp.co.intra_mart.foundation.utility.LockMonitor のコンストラクタ
推奨されていません。 モニターを構築します。
LogAgent - interface jp.co.intra_mart.framework.system.log.LogAgent.
ログに出力するエージェントです。
LogAgentParam - class jp.co.intra_mart.framework.system.log.LogAgentParam.
ログエージェントの初期パラメータです。
LogAgentParam() - class jp.co.intra_mart.framework.system.log.LogAgentParam のコンストラクタ
LogAgentParamを新規に生成します。
LogConstant - interface jp.co.intra_mart.framework.system.log.LogConstant.
ログフレームワークで使用される定数値です。
LogConstraint - interface jp.co.intra_mart.foundation.log.LogConstraint.
ログ定数インタフェース。
LogManager - class jp.co.intra_mart.framework.system.log.LogManager.
ログマネージャです。
LogPropertyException - exception jp.co.intra_mart.framework.system.log.LogPropertyException.
ログプロパティ取得時の例外です。
LogPropertyException() - class jp.co.intra_mart.framework.system.log.LogPropertyException のコンストラクタ
詳細メッセージを指定しないで LogPropertyException を構築します。
LogPropertyException(String) - class jp.co.intra_mart.framework.system.log.LogPropertyException のコンストラクタ
指定された詳細メッセージを持つ LogPropertyException を構築します。
LogPropertyException(String, Throwable) - class jp.co.intra_mart.framework.system.log.LogPropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ LogPropertyException を構築します。
LogPropertyHandler - interface jp.co.intra_mart.framework.system.log.LogPropertyHandler.
ログフレームワークで使用するプロパティハンドラです。
LoggingTransactionManager - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager.
TransactionManagerをラップし、以下のメソッドの呼び出し時にintra-mart データベースログを出力します。
LoggingTransactionManager() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager のコンストラクタ

LoggingTransactionManager(TransactionManager) - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager のコンストラクタ
TransactionManagerをラップし、新規にDBLogTransactionManagerを生成します。
LoggingUserTransaction - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction.
UserTransactionをラップし、以下のメソッドの呼び出し時にintra-mart データベースログを出力します。
LoggingUserTransaction() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction のコンストラクタ

LoggingUserTransaction(UserTransaction) - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction のコンストラクタ
UserTransactionをラップし、新規にDBLogUserTransactionを生成します。
LogicSwitch - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch.
内部制御パラメータ情報クラス
機能は以下の通り
内部制御パラメータ情報を保持します。
LogicSwitch() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のコンストラクタ
内部制御パラメータ情報を作成します。
LoginGroup - class jp.co.intra_mart.foundation.security.group.LoginGroup.
ログイングループ・モデル。
LoginGroup() - class jp.co.intra_mart.foundation.security.group.LoginGroup のコンストラクタ
コンストラクタ。
LoginGroup(String) - class jp.co.intra_mart.foundation.security.group.LoginGroup のコンストラクタ
コンストラクタ。
LoginGroupAccessor - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor.
ログイングループアクセッサインタフェース。
LoginGroupDBConnector - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector.
イントラマートで設定されているDBコネクションです。
LoginGroupDBConnector() - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector のコンストラクタ
LoginGroupDBConnectorを新規に生成します。
LoginGroupDBDAO - class jp.co.intra_mart.framework.base.data.LoginGroupDBDAO.
イントラマートで設定されたDBへアクセスするDAOです。
LoginGroupDBDAO() - class jp.co.intra_mart.framework.base.data.LoginGroupDBDAO のコンストラクタ
IntramartDBDAOを新規に生成します。
LoginGroupDataSource - class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource.
ログイングループに設定されたデータソースをラップします。
LoginGroupDataSource() - class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource のコンストラクタ

LoginGroupDataSource(InitialContext, String) - class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource のコンストラクタ
指定したログイングループに設定されたデータソースをラップします。
LoginGroupManager - class jp.co.intra_mart.foundation.security.group.LoginGroupManager.
ログイングループマネージャクラス。
LoginGroupPostWriterListener - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener.
ログイングループ情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
LoginGroupQueryWriterListener - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener.
ログイングループ情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
LoginGroupReaderDecorator - interface jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator.
ログイングループ情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
LoginInfo - interface jp.co.intra_mart.foundation.security.certification.LoginInfo.
intra-martログイン情報操作インタフェース。
LoginRequestInfo - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo.
intra-martログイン情報操作インタフェース。
Logingp - class jp.co.intra_mart.foundation.acssecurity.Logingp.
推奨されていません。
Logingp(String) - class jp.co.intra_mart.foundation.acssecurity.Logingp のコンストラクタ
推奨されていません。 LoginGroupManagerに置き換えられました。
LogoutInitialUrlValidator - interface jp.co.intra_mart.foundation.security.servlet.LogoutInitialUrlValidator.
ログアウト後に遷移するURL検証インタフェース ログアウト後に遷移するURLを検証するためのインタフェースです。
LogoutServlet - class jp.co.intra_mart.foundation.security.servlet.LogoutServlet.
ログアウトサーブレット。
LogoutServlet() - class jp.co.intra_mart.foundation.security.servlet.LogoutServlet のコンストラクタ

LuxuryResponseWriterFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter.

LuxuryResponseWriterFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter のコンストラクタ
デフォルトコンストラクタ
lastError() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
このインスタンスのメソッド中で最後に発生した例外を返します。
lastError() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 このインスタンスのメソッド中で最後に発生した例外を返します。
lastIndexOf(Object) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
指定されたオブジェクトがリスト内で最後に現れるインデックスを返します。
lastIndexOf(Object) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 指定されたオブジェクトがリスト内で最後に現れるインデックスを返します。
lastModified() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルが最後に変更された時刻を返します。
leave(HttpServletRequest) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter の static メソッド
指定のセッションに関する、このフィルタの処理を停止します。
leave(HttpSession) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter の static メソッド
指定のセッションに関する、このフィルタの処理を停止します。
leaveDepartment(String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織構成から組織情報を離脱させます。
leavePublicGroup(String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループ構成からパブリックグループ情報を離脱させます。
length() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
このライターの出力文字数を取得します。
length() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルの長さを返します。
length() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 このライターの出力文字数を取得します。
listIterator() - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
このリスト内の要素を適切な順序で繰り返し処理する反復子を返します。
listIterator(int) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リスト内の要素を適切な順序で繰り返し処理する、リスト内の指定された位置から開始する反復子を返します。
listIterator() - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 このリスト内の要素を適切な順序で繰り返し処理する反復子を返します。
listIterator(int) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リスト内の要素を適切な順序で繰り返し処理する、リスト内の指定された位置から開始する反復子を返します。
lists() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ディレクトリ中のファイルの一覧を取得します。
load() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ファイルの内容を取得します。
log(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
Servlet ログファイルに指定されたメッセージを出力します。
log(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
与えられた Throwable 例外の説明となるメッセージとスタックトレースを Servlet のログファイルに出力します。
log(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
Servlet ログファイルに指定されたメッセージを出力します。
log(String, Throwable) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
与えられた Throwable 例外の説明となるメッセージとスタックトレースを Servlet のログファイルに出力します。
login(LoginRequestInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ログイン処理を行います。
login(LoginRequestInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ログイン処理を行います。
logout() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ログアウト処理を行います。
logout(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ログアウト処理を行います。
longValue(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 長整数として取得します。
longValue(String, long) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 長整数として取得します。
longValue() - class jp.co.intra_mart.common.aid.jdk.util.Counter のメソッド
カウンターの現在の値を long 型として返します。
longValue() - class jp.co.intra_mart.foundation.utility.Counter のメソッド
推奨されていません。 カウンターの現在の値を long 型として返します。

M

MAPPING_FILE_PATH - class jp.co.intra_mart.foundation.portal.portlet.PortletMapping の static 変数
ポートレットマッピングの設定ファイルのパス情報
MASKAT_COMPONENT_ID_HEAD - class jp.co.intra_mart.extension.maskat.util.MKConst の static 変数
マスカット・コンポーネントIDのヘッダ属性
MASKAT_DEFAULT_COMPONENT_ID - class jp.co.intra_mart.extension.maskat.util.MKConst の static 変数
デフォルトのコンポーネントID
MASKAT_EVENT_ID_HEAD - class jp.co.intra_mart.extension.maskat.util.MKConst の static 変数
マスカット・イベントIDのヘッダ属性
MASKAT_LAYOUT_ID_HEAD - class jp.co.intra_mart.extension.maskat.util.MKConst の static 変数
マスカット・レイアウトIDのヘッダ属性
MAX_VALUE - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の static 変数
レベル値として使用可能な最大値 この値は、java.lang.Integer.MAX_VALUE と同じです。
MAX_VALUE - interface jp.co.intra_mart.foundation.utility.report.ReportLevel の static 変数
推奨されていません。 レベル値として使用可能な最大値 この値は、java.lang.Integer.MAX_VALUE と同じです。
MEDIA - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel の static 変数
媒体
MEDIA_CLS - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel の static 変数
媒体種類
MEDIA_CLS_FILE - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel の static 変数
媒体種類がFileを表す定数
MEDIA_CLS_URL - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel の static 変数
媒体種類がURLを表す定数
MENU - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
メニュー情報
MENU_ARGUMENT - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
メニューの保有する引数
MENU_DEPARTMENT - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
メニューの利用権限を保有する組織
MENU_ID - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel の static 変数
メニューID
MENU_ID - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel の static 変数
メニューID
MENU_ID - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の static 変数
メニューID
MENU_ID - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel の static 変数
メニューID
MENU_ID - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel の static 変数
メニューID
MENU_ID - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel の static 変数
メニューID
MENU_ID - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel の static 変数
メニューID
MENU_POST - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
メニューの利用権限を保有する役職
MENU_PUBLIC_GROUP - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
メニューの利用権限を保有するパブリックグループ
MENU_ROLE - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
メニューの利用権限を保有するロール
MENU_TYPE - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の static 変数
メニュータイプ
MENU_TYPE_FOLDER - class jp.co.intra_mart.foundation.security.menu.MenuItem の static 変数
メニュータイプ（フォルダ）。
MENU_TYPE_ITEM - class jp.co.intra_mart.foundation.security.menu.MenuItem の static 変数
メニュータイプ（アイテム）。
MESSAGE_CODE_NODE - class jp.co.intra_mart.extension.maskat.util.MKError の static 変数
messageCodeのノード名
MESSAGE_NODE - class jp.co.intra_mart.extension.maskat.util.MKError の static 変数
messageのノード名
MESSAGE_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.base.message.MessageManager の static 変数
メッセージプロパティハンドラのキー
MESSAGE_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.system.message.MessageManager の static 変数
メッセージプロパティハンドラのキー
MIN_VALUE - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の static 変数
レベル値として使用可能な最小値 この値は、java.lang.Integer.MIN_VALUE と同じです。
MIN_VALUE - interface jp.co.intra_mart.foundation.utility.report.ReportLevel の static 変数
推奨されていません。 レベル値として使用可能な最小値 この値は、java.lang.Integer.MIN_VALUE と同じです。
MKConst - class jp.co.intra_mart.extension.maskat.util.MKConst.
マスカット連携に使用される定数値です。
MKConst() - class jp.co.intra_mart.extension.maskat.util.MKConst のコンストラクタ

MKControllerConverter - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter.
マスカット連携時に使用する汎用的なコントローラコンバータです。
MKControllerConverter() - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter のコンストラクタ

MKControllerObject - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject.
マスカット連携時に使用する汎用的なコントローラオブジェクトです。
MKControllerObject() - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject のコンストラクタ
MKControllerObjectを新規に生成します。
MKError - class jp.co.intra_mart.extension.maskat.util.MKError.
マスカットのエラー情報を保持します。
MKError() - class jp.co.intra_mart.extension.maskat.util.MKError のコンストラクタ
MKErrorを新規に生成します。
MKErrors - class jp.co.intra_mart.extension.maskat.util.MKErrors.
マスカットのエラー要素群を保持します。
MKErrors() - class jp.co.intra_mart.extension.maskat.util.MKErrors のコンストラクタ
空のMKErrorsを新規に生成します。
MKErrors(MKError) - class jp.co.intra_mart.extension.maskat.util.MKErrors のコンストラクタ
エラー要素を設定してMKErrorsを新規に生成します。
MKErrorsResult - class jp.co.intra_mart.extension.maskat.service.MKErrorsResult.
マスカットにエラーを返すサービス処理結果です。
MKErrorsResult() - class jp.co.intra_mart.extension.maskat.service.MKErrorsResult のコンストラクタ
空のErrorsResultを新規に生成します。
MKErrorsResult(MKError) - class jp.co.intra_mart.extension.maskat.service.MKErrorsResult のコンストラクタ
エラー要素を設定してErrorsResultを新規に生成します。
MKRuntimeException - exception jp.co.intra_mart.extension.maskat.exception.MKRuntimeException.
マスカットアプリケーション実行時に出力されるランタイム例外です。
MKRuntimeException() - class jp.co.intra_mart.extension.maskat.exception.MKRuntimeException のコンストラクタ
詳細メッセージを指定しないで MKRuntimeException を構築します。
MKRuntimeException(String) - class jp.co.intra_mart.extension.maskat.exception.MKRuntimeException のコンストラクタ
指定された詳細メッセージを持つ MKRuntimeException を構築します。
MKRuntimeException(Throwable) - class jp.co.intra_mart.extension.maskat.exception.MKRuntimeException のコンストラクタ
この例外の発生原因となる例外を持つ MKRuntimeException を構築します。
MKRuntimeException(String, Throwable) - class jp.co.intra_mart.extension.maskat.exception.MKRuntimeException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MKRuntimeException を構築します。
MKServiceResult - interface jp.co.intra_mart.extension.maskat.service.MKServiceResult.
マスカット連携を行う処理結果です。
MKSystemException - exception jp.co.intra_mart.extension.maskat.exception.MKSystemException.
マスカットアプリケーション実行時に出力される例外です。
MKSystemException() - class jp.co.intra_mart.extension.maskat.exception.MKSystemException のコンストラクタ
詳細メッセージを指定しないで MKSystemException を構築します。
MKSystemException(String) - class jp.co.intra_mart.extension.maskat.exception.MKSystemException のコンストラクタ
指定された詳細メッセージを持つ MKSystemException を構築します。
MKSystemException(Throwable) - class jp.co.intra_mart.extension.maskat.exception.MKSystemException のコンストラクタ
この例外の発生原因となる例外を持つ MKSystemException を構築します。
MKSystemException(String, Throwable) - class jp.co.intra_mart.extension.maskat.exception.MKSystemException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MKSystemException を構築します。
MKTransition - class jp.co.intra_mart.extension.maskat.service.MKTransition.
マスカットに電文を送信するトランジションです。
MKTransition() - class jp.co.intra_mart.extension.maskat.service.MKTransition のコンストラクタ

MOBILE_EMAIL_ADDRESS - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
携帯用メール
MOBILE_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
携帯電話番号
MOBILE_PASSWORD - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
モバイル用パスワード
MONTH - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
月
MOVE - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

MOVE_ENTIRETY - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

MOVE_ITEM - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

MYSQL - class jp.co.intra_mart.foundation.database.DbTypes の static 変数

Mail - class jp.co.intra_mart.foundation.smtp.Mail.
推奨されていません。 MailSenderに置き換えられました。
Mail(String, int) - class jp.co.intra_mart.foundation.smtp.Mail のコンストラクタ
推奨されていません。 メール送信オブジェクトの生成。
Mail(String) - class jp.co.intra_mart.foundation.smtp.Mail のコンストラクタ
推奨されていません。 メール送信オブジェクトの生成。
Mail() - class jp.co.intra_mart.foundation.smtp.Mail のコンストラクタ
推奨されていません。 メール送信オブジェクトの生成。
MailAddress - interface jp.co.intra_mart.foundation.mail.javamail.model.MailAddress.
メールアドレスのモデルです。
MailSendEvent - class jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent.
メール送信イベントです。
MailSendEvent() - class jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent のコンストラクタ
SendMailEventを新規に生成します。
MailSendListener - interface jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener.
メール送信イベントのListenerインタフェースです。
MailSender - interface jp.co.intra_mart.foundation.mail.MailSender.
メールを送信するためのインターフェースです。
MailSenderException - exception jp.co.intra_mart.foundation.mail.MailSenderException.
メール送信時またはその他の不正な処理に関する情報を提供する例外です。
MailSenderException() - class jp.co.intra_mart.foundation.mail.MailSenderException のコンストラクタ
MailSenderExceptionを構築します。
MailSenderException(String) - class jp.co.intra_mart.foundation.mail.MailSenderException のコンストラクタ
指定された詳細メッセージを使用してMailSenderExceptionを構築します。
MailSenderException(String, Throwable) - class jp.co.intra_mart.foundation.mail.MailSenderException のコンストラクタ
指定された詳細メッセージおよび原因を使用してMailSenderExceptionを構築します。
MailSenderException(Throwable) - class jp.co.intra_mart.foundation.mail.MailSenderException のコンストラクタ
指定された原因を使用してMailSenderExceptionを構築します。
MainPageImportLoginGroupPostWriterListener - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener.
ログイングループ作成時にメインページパターンを設定するリスナークラス。
MainPageImportLoginGroupPostWriterListener() - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のコンストラクタ
コンストラクタ。
MainPagePatternInfo - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo.
メインページパターン情報クラス。
MainPagePatternInfo(String) - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo のコンストラクタ
コンストラクタ。
ManagerException - exception jp.co.intra_mart.foundation.datastore.exception.ManagerException.
マネージャに関する例外クラス

ManagerException() - class jp.co.intra_mart.foundation.datastore.exception.ManagerException のコンストラクタ
コンストラクタ
ManagerException(String) - class jp.co.intra_mart.foundation.datastore.exception.ManagerException のコンストラクタ
コンストラクタ
ManagerException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.ManagerException のコンストラクタ
コンストラクタ
ManagerException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.ManagerException のコンストラクタ
コンストラクタ
ManufacturerPartNumb - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb.
製造業者と製造者製品コードクラス
機能は以下の通り
製造業者と製造者製品コードの情報を保持します。
ManufacturerPartNumb() - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のコンストラクタ
製造業者と製造者製品コード情報を作成します。
ManufacturerPartNumb(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のコンストラクタ
製造業者と製造者製品コード情報を作成します。
Mapper - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper.
エンティティの情報のマッパーです。
MapperDAOException - exception jp.co.intra_mart.foundation.datastore.exception.MapperDAOException.
マッパーのデータベース接続に関する例外クラス

マッパーがデータベース接続で問題が発生した場合にスローする。
MapperDAOException() - class jp.co.intra_mart.foundation.datastore.exception.MapperDAOException のコンストラクタ
コンストラクタ
MapperDAOException(String) - class jp.co.intra_mart.foundation.datastore.exception.MapperDAOException のコンストラクタ
コンストラクタ
MapperDAOException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.MapperDAOException のコンストラクタ
コンストラクタ
MapperDAOException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.MapperDAOException のコンストラクタ
コンストラクタ
MapperException - exception jp.co.intra_mart.foundation.datastore.exception.MapperException.
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。
MapperException() - class jp.co.intra_mart.foundation.datastore.exception.MapperException のコンストラクタ
コンストラクタ
MapperException(String) - class jp.co.intra_mart.foundation.datastore.exception.MapperException のコンストラクタ
コンストラクタ
MapperException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.MapperException のコンストラクタ
コンストラクタ
MapperException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.MapperException のコンストラクタ
コンストラクタ
MapperFactory - class jp.co.intra_mart.foundation.datastore.common.model.MapperFactory.
マッパーを生成します。
MapperFactory() - class jp.co.intra_mart.foundation.datastore.common.model.MapperFactory のコンストラクタ

MasterData - class jp.co.intra_mart.foundation.sap.module.financial.MasterData.
指図のマスタデータ構造情報クラス 機能は以下の通り
指図のマスタデータ構造情報を保持します。
MasterData() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のコンストラクタ
指図のマスタデータ構造を作成します。
MaterialAvailability - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability.
品目在庫確認情報クラス
機能は以下の通り
品目在庫確認情報を保持します。
MaterialAvailability(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のコンストラクタ
品目在庫確認情報を作成します。
MaterialAvailabilityController - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController.
品目在庫確認コントローラクラス
機能は以下の通り
在庫情報を取得します。
MaterialAvailabilityController() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController のコンストラクタ
コンストラクタ生成
MaterialAvailabilityController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController のコンストラクタ
コンストラクタ生成
MaterialDescription - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription.
品目テキスト情報クラス
機能は以下の通り
品目テキスト情報を保持します。
MaterialDescription() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のコンストラクタ
品目テキスト情報を作成します。
MaterialDescription(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のコンストラクタ
品目テキスト情報を作成します。
MaterialGetAll - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll.
品目マスタ照会情報クラス
機能は以下の通り
品目マスタ照会情報を保持します。
MaterialGetAll(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のコンストラクタ
品目マスタ照会情報を作成します。
MaterialGetAll(String, String, String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のコンストラクタ
品目マスタ照会情報を作成します。
MaterialGetAllController - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController.
品目マスタ照会コントローラクラス
機能は以下の通り
品目マスタの情報を取得します。
MaterialGetAllController() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のコンストラクタ
コンストラクタ生成
MaterialGetAllController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のコンストラクタ
コンストラクタ生成
MaterialGetAllController(String, String, String, String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のコンストラクタ
MaterialGetallのコンストラクタを呼び出し品目マスタ照会情報を取得します。
MaterialGetAllController(String, String, String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のコンストラクタ
MaterialGetallのコンストラクタを呼び出し品目マスタ照会情報を取得します。
MaterialGetList - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList.
品目コード検索クラス
機能は以下の通り
品目コード、テキストを検索します。
MaterialGetList(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のコンストラクタ
品目コードの選択オプション一覧、品目テキストの選択オプション一覧、 製造業者と製造者製品コード一覧、プラントの選択オプション一覧、 保管場所の選択オプション一覧、販売組織の選択オプション一覧、 流通チャネルの選択オプション一覧、品目コードと品目テキスト一覧を作成します｡
MaterialGetListController - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController.
品目コード検索コントローラクラス
機能は以下の通り
品目コード、テキストを検索します。
MaterialGetListController() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController のコンストラクタ
MaterialGetListのコンストラクタを生成します。
MaterialGetListController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController のコンストラクタ
MaterialGetListのコンストラクタを生成します。
MaterialLongText - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText.
テキスト (長)情報クラス
機能は以下の通り
テキスト (長)情報を保持します。
MaterialLongText() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のコンストラクタ
テキスト (長)情報を作成します。
MaterialLongText(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のコンストラクタ
テキスト (長)情報を作成します。
MaterialRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa.
品目コードの範囲情報クラス
機能は以下の通り
品目コードの範囲情報を保持します。
MaterialRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のコンストラクタ
品目コードの範囲情報を作成します。
MaterialRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のコンストラクタ
品目コードの範囲情報を作成します。
MaterialSaveReplica - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica.
品目マスタ更新情報クラス
機能は以下の通り
品目マスタ更新情報を保持します。
MaterialSaveReplica() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のコンストラクタ
品目マスタ更新情報を作成します。
MaterialSaveReplica(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のコンストラクタ
品目マスタ更新情報を作成します。
MaterialSaveReplica(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のコンストラクタ
品目マスタ更新情報を作成します。
MaterialSaveReplicaController - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController.
品目マスタ更新コントローラクラス
機能は以下の通り
品目マスタを更新します。
MaterialSaveReplicaController() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のコンストラクタ
コンストラクタ生成
MaterialSaveReplicaController(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のコンストラクタ
コンストラクタ生成
MaterialSaveReplicaController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のコンストラクタ
コンストラクタ生成
MaterialShortDescsel - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel.
品目テキストの選択オプションクラス
機能は以下の通り
品目テキストの選択オプションの情報を保持します。
MaterialShortDescsel() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のコンストラクタ
品目テキストの選択オプション情報を作成します。
MaterialShortDescsel(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のコンストラクタ
品目テキストの選択オプション情報を作成します。
MaterialText - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText.
テキスト (長)情報クラス
機能は以下の通り
テキスト (長)情報を保持します。
MaterialText() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のコンストラクタ
テキスト (長)情報を作成します。
MaterialText(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のコンストラクタ
テキスト (長)情報を作成します。
MatnrList - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList.
品目コードと品目テキストの一覧クラス
機能は以下の通り
品目コードと品目テキストの一覧の情報を保持します。
MatnrList() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のコンストラクタ
品目コードと品目テキストの一覧情報を作成します。
MatnrSelection - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection.
品目コードの選択オプションクラス
機能は以下の通り
品目コードの選択オプションの情報を保持します。
MatnrSelection() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のコンストラクタ
品目コードの選択オプション情報を作成します。
MatnrSelection(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のコンストラクタ
品目コードの選択オプション情報を作成します。
MenuAccessor - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor.
メニューアクセッサインタフェース。
MenuArgumentBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel.
メニューの保有する引数の基本モデルです。
MenuArgumentMapper - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper.
メニューの保有する引数に関連するマッパです。
MenuBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel.
メニュー情報の基本モデルです。
MenuDepartmentBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel.
メニューの利用権限を保有する組織の基本モデルです。
MenuDepartmentMapper - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper.
メニューの利用権限を保有する組織に関連するマッパです。
MenuExporter - interface jp.co.intra_mart.foundation.security.menu.MenuExporter.
メニューエクスポートインタフェースです。
MenuImporter - interface jp.co.intra_mart.foundation.security.menu.MenuImporter.
メニューインポートインタフェースです。
MenuInclusion - class jp.co.intra_mart.foundation.security.menu.MenuInclusion.
メニュー内包情報クラス。
MenuInclusion(String, String) - class jp.co.intra_mart.foundation.security.menu.MenuInclusion のコンストラクタ
コンストラクタ。
MenuInternationalModel - interface jp.co.intra_mart.system.security.datastore.inf.MenuInternationalModel.
メニュー情報の国際化モデルです。
MenuItem - class jp.co.intra_mart.foundation.security.menu.MenuItem.
メニュー・モデルクラス。
MenuItem() - class jp.co.intra_mart.foundation.security.menu.MenuItem のコンストラクタ
コンストラクタ。
MenuItem(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のコンストラクタ
コンストラクタ。
MenuLinkSetPortlet - class jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet.
ページ種別「メニューリンクセット」に対するポートレットのモデルです。
MenuLinkSetPortlet() - class jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet のコンストラクタ
コンストラクタ
MenuManager - class jp.co.intra_mart.foundation.security.menu.MenuManager.
メニューマネージャクラス。
MenuManager(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のコンストラクタ
コンストラクタ。
MenuMapper - interface jp.co.intra_mart.system.security.datastore.inf.MenuMapper.
メニュー情報に関連するマッパです。
MenuPermissionSelector - class jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector.
ユーザIDから有効なメニューのID一覧を取得するセレクタ。
MenuPermissionSelector() - class jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector のコンストラクタ
コンストラクタ。
MenuPostBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel.
メニューの利用権限を保有する役職の基本モデルです。
MenuPostMapper - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper.
メニューの利用権限を保有する役職に関連するマッパです。
MenuPostWriterListener - interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener.
メニュー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
MenuPublicGroupBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel.
メニューの利用権限を保有するパブリックグループの基本モデルです。
MenuPublicGroupMapper - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper.
メニューの利用権限を保有するパブリックグループに関連するマッパです。
MenuQueryWriterListener - interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener.
メニュー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
MenuReaderDecorator - interface jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator.
メニュー情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
MenuRoleBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel.
メニューの利用権限を保有するロールの基本モデルです。
MenuRoleMapper - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper.
メニューの利用権限を保有するロールに関連するマッパです。
MenuServlet - class jp.co.intra_mart.foundation.security.servlet.MenuServlet.
メニュー連携サーブレットクラス。
MenuServlet() - class jp.co.intra_mart.foundation.security.servlet.MenuServlet のコンストラクタ
コンストラクタ。
MenuTree - class jp.co.intra_mart.foundation.security.menu.MenuTree.
メニューツリークラス。
MenuTree(MenuItem) - class jp.co.intra_mart.foundation.security.menu.MenuTree のコンストラクタ
コンストラクタ。
MessageManager - class jp.co.intra_mart.foundation.security.message.MessageManager.
メッセージマネージャクラス。
MessageManager - class jp.co.intra_mart.framework.base.message.MessageManager.
メッセージマネージャです。
MessageManager - class jp.co.intra_mart.framework.system.message.MessageManager.
メッセージを制御します。
MessageManagerException - exception jp.co.intra_mart.framework.base.message.MessageManagerException.
サービスマネージャ設定時の例外です。
MessageManagerException() - class jp.co.intra_mart.framework.base.message.MessageManagerException のコンストラクタ
詳細メッセージを指定しないで MessageManagerException を構築します。
MessageManagerException(String) - class jp.co.intra_mart.framework.base.message.MessageManagerException のコンストラクタ
指定された詳細メッセージを持つ MessageManagerException を構築します。
MessageManagerException(String, Throwable) - class jp.co.intra_mart.framework.base.message.MessageManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessageManagerException を構築します。
MessageManagerException - exception jp.co.intra_mart.framework.system.message.MessageManagerException.
メッセージマネージャに関連する例外です。
MessageManagerException() - class jp.co.intra_mart.framework.system.message.MessageManagerException のコンストラクタ
詳細メッセージを指定しないで MessageManagerException を構築します。
MessageManagerException(String) - class jp.co.intra_mart.framework.system.message.MessageManagerException のコンストラクタ
指定された詳細メッセージを持つ MessageManagerException を構築します。
MessageManagerException(String, Throwable) - class jp.co.intra_mart.framework.system.message.MessageManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessageManagerException を構築します。
MessageParamTag - class jp.co.intra_mart.framework.base.web.tag.MessageParamTag.
メッセージの生成で使用するパラメータを設定します。
MessageParamTag() - class jp.co.intra_mart.framework.base.web.tag.MessageParamTag のコンストラクタ
ParamTagを新規に生成します。
MessagePropertyException - exception jp.co.intra_mart.framework.base.message.MessagePropertyException.
メッセージプロパティ取得時の例外です。
MessagePropertyException() - class jp.co.intra_mart.framework.base.message.MessagePropertyException のコンストラクタ
詳細メッセージを指定しないで MessagePropertyException を構築します。
MessagePropertyException(String) - class jp.co.intra_mart.framework.base.message.MessagePropertyException のコンストラクタ
指定された詳細メッセージを持つ MessagePropertyException を構築します。
MessagePropertyException(String, Throwable) - class jp.co.intra_mart.framework.base.message.MessagePropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessagePropertyException を構築します。
MessagePropertyException - exception jp.co.intra_mart.framework.system.message.MessagePropertyException.
メッセージプロパティハンドラに関連する例外です。
MessagePropertyException() - class jp.co.intra_mart.framework.system.message.MessagePropertyException のコンストラクタ
詳細メッセージを指定しないで MessagePropertyException を構築します。
MessagePropertyException(String) - class jp.co.intra_mart.framework.system.message.MessagePropertyException のコンストラクタ
指定された詳細メッセージを持つ MessagePropertyException を構築します。
MessagePropertyException(String, Throwable) - class jp.co.intra_mart.framework.system.message.MessagePropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessagePropertyException を構築します。
MessagePropertyHandler - interface jp.co.intra_mart.framework.base.message.MessagePropertyHandler.
メッセージの設定情報に接続するクラスです。
MessagePropertyHandler - interface jp.co.intra_mart.framework.system.message.MessagePropertyHandler.
メッセージに関連するプロパティを取得します。
MessagePropertyParam - class jp.co.intra_mart.framework.system.message.MessagePropertyParam.
メッセージプロパティハンドラの初期パラメータです。
MessagePropertyParam() - class jp.co.intra_mart.framework.system.message.MessagePropertyParam のコンストラクタ
MessagePropertyParamを新規に生成します。
MessageReporter - interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter.
メッセージ出力のためのインターフェースです。
MessageReporter - interface jp.co.intra_mart.foundation.utility.report.MessageReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter クラスを使用してください。
MessageTEI - class jp.co.intra_mart.framework.base.web.tag.MessageTEI.
Messageタグの拡張情報です。
MessageTEI() - class jp.co.intra_mart.framework.base.web.tag.MessageTEI のコンストラクタ

MessageTag - class jp.co.intra_mart.framework.base.web.tag.MessageTag.
Messageタグです。
MessageTag() - class jp.co.intra_mart.framework.base.web.tag.MessageTag のコンストラクタ
MessageTagを新規に生成します。
MobileEasyLoginAuAnalyzer - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuAnalyzer.
モバイル端末固体識別番号取得プロバイダクラス Au用(WAP2.0)
MobileEasyLoginAuAnalyzer() - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuAnalyzer のコンストラクタ

MobileEasyLoginAuHdmlAnalyzer - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuHdmlAnalyzer.
推奨されていません。
MobileEasyLoginAuHdmlAnalyzer() - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuHdmlAnalyzer のコンストラクタ
推奨されていません。
MobileEasyLoginDocomoAnalyzer - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoAnalyzer.
モバイル端末固体識別番号取得プロバイダクラス NTT DoCoMo用(FOMA)
MobileEasyLoginDocomoAnalyzer() - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoAnalyzer のコンストラクタ

MobileEasyLoginDocomoMoveAnalyzer - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoMoveAnalyzer.
推奨されていません。
MobileEasyLoginDocomoMoveAnalyzer() - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoMoveAnalyzer のコンストラクタ
推奨されていません。
MobileEasyLoginJphoneAnalyzer - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginJphoneAnalyzer.
推奨されていません。
MobileEasyLoginJphoneAnalyzer() - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginJphoneAnalyzer のコンストラクタ
推奨されていません。
MobileEasyLoginSoftBankAnalyzer - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginSoftBankAnalyzer.
モバイル端末固体識別番号取得プロバイダクラス SoftBank用(3GC型)
MobileEasyLoginSoftBankAnalyzer() - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginSoftBankAnalyzer のコンストラクタ

MobileEasyLoginUtil - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil.
かんたんログイン機能のユーティリティクラスです。
MobileEasyLoginUtil() - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil のコンストラクタ

MobileEasyLoginVodafoneAnalyzer - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginVodafoneAnalyzer.
モバイル端末固体識別番号取得プロバイダクラス Vodafone用(3GC型)
MobileEasyLoginVodafoneAnalyzer() - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginVodafoneAnalyzer のコンストラクタ

MobileUserAgentProvider - interface jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider.
モバイル端末固体識別番号取得プロバイダインタフェース。
Model - interface jp.co.intra_mart.foundation.datastore.common.config.Model.
モデルを定義します。
MoveTypeRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa.
移動タイプの範囲情報クラス
機能は以下の通り
移動タイプの範囲情報を保持します。
MoveTypeRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のコンストラクタ
移動タイプの範囲情報を作成します。
MoveTypeRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のコンストラクタ
移動タイプの範囲情報を作成します。
MultiCastReporter - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter.
メッセージを複数のストリームに出力するためのフィルタークラスです。
MultiCastReporter() - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のコンストラクタ
唯一のコンストラクタ。
MultiCastReporter - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter クラスを使用してください。
MultiCastReporter() - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のコンストラクタ
推奨されていません。 唯一のコンストラクタ。
MultiComparator - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator.
複数のコンパレータを使用してソートを行うためにクラスです。
MultiComparator(Comparator, Comparator) - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator のコンストラクタ
第１コンパレータ 、第２コンパレータを指定して、新しいオブジェクトを生成します。
MultiComparator - class jp.co.intra_mart.foundation.utility.MultiComparator.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator クラスを使用してください。
MultiComparator(Comparator, Comparator) - class jp.co.intra_mart.foundation.utility.MultiComparator のコンストラクタ
推奨されていません。 第１コンパレータ 、第２コンパレータを指定して、新しいオブジェクトを生成します。
MultipartFormData - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.
フォームから enctype が multipart/form-data で送信されてきた情報を 解析するオブジェクトです。
MultipartFormData(ServletRequest) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のコンストラクタ
リクエストされた情報を解析して、新しいオブジェクトを構築します。
MultipartFormData(ServletRequest, IMFileItemFactory) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のコンストラクタ
リクエストされた情報を解析して、新しいオブジェクトを構築します。
MultipartFormData - class jp.co.intra_mart.foundation.http.MultipartFormData.
推奨されていません。 jp.co.intra_mart.common.aid.javaee.http.MultipartFormData クラスを使用してください。
MultipartFormData(ServletRequest) - class jp.co.intra_mart.foundation.http.MultipartFormData のコンストラクタ
推奨されていません。 リクエストされた情報を解析して、新しいオブジェクトを構築します。
MultipartFormData.Entity - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity.
フォームデータのエンティティです。
MultipartFormData.Entity - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity.
推奨されていません。 jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity インタフェースを使用してください。
MultipartFormDataResourceBundle - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle.
MultipartFormDataの設定情報を扱うクラスです。
MultipartFormDataResourceBundle() - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle のコンストラクタ

MultipleOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream.
複数の出力ストリームにバイトを書き出すためのフィルタ実装です。
MultipleOutputStream() - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のコンストラクタ
唯一のコンストラクタ
MultipurposeInternetMailExtensions - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions.
MIME タイプを持つオブジェクトです。
MultipurposeInternetMailExtensions(String) - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のコンストラクタ
MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(File) - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のコンストラクタ
MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(String, String) - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のコンストラクタ
指定のMIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions クラスを使用してください。
MultipurposeInternetMailExtensions(String) - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のコンストラクタ
推奨されていません。 MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(File) - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のコンストラクタ
推奨されていません。 MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(String, String) - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のコンストラクタ
推奨されていません。 指定のMIMEタイプを表すオブジェクトを構築します。
mainPagePath - class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor の変数

mainRemoved(String, DepartmentMain) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
主所属情報がデータストアから削除された後に呼び出されます。
mainRemoved(String, DepartmentMain) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
主所属情報がデータストアから削除された後に呼び出されます。
mainRemoved(String, DepartmentMain) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
主所属情報がデータストアから削除された後に呼び出されます。
mainSet(String, DepartmentMain) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
主所属情報がデータストアに登録された後に呼び出されます。
mainSet(String, DepartmentMain) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
主所属情報がデータストアに登録された後に呼び出されます。
mainSet(String, DepartmentMain) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
主所属情報がデータストアに登録された後に呼び出されます。
make() - class jp.co.intra_mart.foundation.service.client.information.Identifier の static メソッド

makeCertifyEnvironment(Hashtable, String, String, String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
LDAP認証用の設定情報を作成する。
makeDirectories() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すディレクトリを生成します。
makeSearchControls() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
検索用のサーチコントローラーを作成する。
makeSerchEnvironments() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
LDAP上のユーザを検索する為の設定情報を作成する。
mark(int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
入力ストリームの現在位置にマークを設定します。
markSupported() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
入力ストリームが mark および reset メソッドをサポートしているかどうかを 判定します。
matchDbType(String) - class jp.co.intra_mart.foundation.database.DbTypes の static メソッド

matchSysLocales(Locale[], String[]) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter のメソッド
ロケールマッチング（共通）

memberDeleted(String, DepartmentAttach) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織からの人員の割当がデータストアから削除された後に呼び出されます。
memberDeleted(String, PrivateGroupAttach) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
プライベートグループ所属情報がデータストアから削除された後に呼び出されます。
memberDeleted(String, PublicGroupAttach) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
memberDeleted(String, DepartmentAttach) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
組織からの人員の割当がデータストアから削除された後に呼び出されます。
memberDeleted(String, PublicGroupAttach) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
memberDeleted(String, DepartmentAttach) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織からの人員の割当がデータストアから削除された後に呼び出されます。
memberDeleted(String, PublicGroupAttach) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
memberSet(String, DepartmentAttach) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織への人員の割当がデータストアに登録された後に呼び出されます。
memberSet(String, PrivateGroupAttach) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
プライベートグループ所属情報がデータストアに登録された後に呼び出されます。
memberSet(String, PublicGroupAttach) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
memberSet(String, DepartmentAttach) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
組織への人員の割当がデータストアに登録された後に呼び出されます。
memberSet(String, PublicGroupAttach) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
memberSet(String, DepartmentAttach) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織への人員の割当がデータストアに登録された後に呼び出されます。
memberSet(String, PublicGroupAttach) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
modify(String) - class jp.co.intra_mart.foundation.update.UpdateManager のメソッド
対象となる更新管理キーの更新日付を更新します。
move(String) - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルの名前を変更します。
move(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
グループキーを変更します。
moveCategory(String, String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
カテゴリーを更新します。
moveDepartment(String, String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織構成に登録済の組織情報を移動します。
moveMenuItem(MenuInclusion) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニューを移動します。
moveMenuItem(MenuInclusion) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューを移動します。
movePublicGroup(String, String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループ構成に登録済のパブリックグループ情報を移動します。

N

NAME - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の static 変数
分類区分名
NAME - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の static 変数
分類名
NAME - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
組織名
NAME - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
役職名
NAME - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
グループ名
NAME - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
グループ名
NAME - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ユーザ名
NAME - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel の static 変数
ロール名
NAME_ENGLISH - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
組織名英字
NAME_ENGLISH - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
グループ名英字
NAME_ENGLISH - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
グループ名英字
NAME_ENGLISH - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ユーザ名英字
NAME_SYLLABARY - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
組織名カナ
NAME_SYLLABARY - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
グループ名カナ
NAME_SYLLABARY - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
グループ名カナ
NAME_SYLLABARY - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ユーザ名カナ
NODE_PATH_PREFIX - class jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter の static 変数
Pathを記述するフィールドのプレフィックス
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel の static 変数
説明
NOTES - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
説明
NOTES - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の static 変数
説明
NOTES - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel の static 変数
備考
NULL - class jp.co.intra_mart.foundation.datastore.common.config.DeleteType の static 変数
Null ターゲットエンティティのデータを参照しているソースエンティティの外部キーをnullにします。
NULL - class jp.co.intra_mart.foundation.datastore.common.config.LifetimeType の static 変数
Null ターゲットエンティティの期間を参照しているソースエンティティの外部キーをnullにします。
NULL_DATA - class jp.co.intra_mart.foundation.service.client.NetworkAgent の static 変数
NULL を表します。
NUMBER_VALUE - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel の static 変数
属性数値
NavigatorAuthenticateItem - class jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem.
選択アイテムクラス
NavigatorAuthenticateItem() - class jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem のコンストラクタ

NavigatorInfo - class jp.co.intra_mart.foundation.security.activesession.NavigatorInfo.
ナビゲータ情報クラス。
NavigatorInfo() - class jp.co.intra_mart.foundation.security.activesession.NavigatorInfo のコンストラクタ
コンストラクタ。
NavigatorItem - class jp.co.intra_mart.foundation.navigator.NavigatorItem.
イベントナビゲータアイテムクラス
NavigatorItem() - class jp.co.intra_mart.foundation.navigator.NavigatorItem のコンストラクタ

NetworkAgent - class jp.co.intra_mart.foundation.service.client.NetworkAgent.
このクラスは、他のサーバで実行されるロジックを実装する ためのスケルトンを提供します。
NetworkAgent() - class jp.co.intra_mart.foundation.service.client.NetworkAgent のコンストラクタ
唯一のコンストラクタ。
NetworkConnector - class jp.co.intra_mart.foundation.service.client.NetworkConnector.
このクラスは、他のサーバで実行されるロジックを転送する ためのスケルトンを提供します。
NetworkConnector() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のコンストラクタ
唯一のコンストラクタ。
NetworkFile - class jp.co.intra_mart.foundation.service.client.file.NetworkFile.
Storage Service のファイルを扱う事の出来るオブジェクトです。
NetworkFile(String) - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のコンストラクタ
新しいオブジェクトを構築します。
NewArrived - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived.
汎用新着情報を保持します。
NewArrived() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のコンストラクタ

NewArrivedManager - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager.
汎用新着情報の取得処理を行うクラスです。
NewArrivedManager() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager のコンストラクタ

NewArrivedProvider - interface jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider.
汎用新着情報のプロバイダのインターフェースです。
NoCacheFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter.
ブラウザのキャッシュを無効にするフィルタ。
NoCacheFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter のコンストラクタ

NoCryption - class jp.co.intra_mart.foundation.security.cryption.NoCryption.
暗号化処理を行わない実装クラス。
NoCryption() - class jp.co.intra_mart.foundation.security.cryption.NoCryption のコンストラクタ
コンストラクタ。
NoFilterException - exception jp.co.intra_mart.foundation.security.exception.NoFilterException.
HTTPリクエスト・レスポンス取得例外クラス。
NoFilterException(String) - class jp.co.intra_mart.foundation.security.exception.NoFilterException のコンストラクタ
コンストラクタ。
NoFilterException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.NoFilterException のコンストラクタ
コンストラクタ。
NoFilterException(Throwable) - class jp.co.intra_mart.foundation.security.exception.NoFilterException のコンストラクタ
コンストラクタ。
NoFilterException() - class jp.co.intra_mart.foundation.security.exception.NoFilterException のコンストラクタ
コンストラクタ。
NoSessionCookieException - exception jp.co.intra_mart.foundation.security.exception.NoSessionCookieException.
セッション情報クッキー取得例外クラス。
NoSessionCookieException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.NoSessionCookieException のコンストラクタ
コンストラクタ。
NoSessionCookieException(String) - class jp.co.intra_mart.foundation.security.exception.NoSessionCookieException のコンストラクタ
コンストラクタ。
NoSessionException - exception jp.co.intra_mart.foundation.security.exception.NoSessionException.
セッション取得例外クラス。
NoSessionException(String) - class jp.co.intra_mart.foundation.security.exception.NoSessionException のコンストラクタ
コンストラクタ。
NoSessionException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.NoSessionException のコンストラクタ
コンストラクタ。
NoSessionException(Throwable) - class jp.co.intra_mart.foundation.security.exception.NoSessionException のコンストラクタ
コンストラクタ。
NoSessionException() - class jp.co.intra_mart.foundation.security.exception.NoSessionException のコンストラクタ
コンストラクタ。
NoSuchPropertyException - exception jp.co.intra_mart.foundation.scenario.NoSuchPropertyException.
NoSuchPropertyException クラスは、指定されたプロパティがオブジェクトには ないことを通知します。
NoSuchPropertyException(String) - class jp.co.intra_mart.foundation.scenario.NoSuchPropertyException のコンストラクタ
詳細メッセージを指定して NoSuchPropertyException を構築します。
NoSuchSessionException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException.
特定のＨＴＴＰセッションが見つからない場合にスローされます。
NoSuchSessionException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException のコンストラクタ
詳細メッセージを持たない NoSuchSessionException を構築します。
NoSuchSessionException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException のコンストラクタ
詳細メッセージを持つ NoSuchSessionException を構築します。
NoSuchSessionException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新しい NoSuchSessionException を構築します。
NoSuchSessionException(Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException のコンストラクタ
指定された原因を使用して新しい NoSuchSessionException を構築します。
NodeNameComparator - class jp.co.intra_mart.foundation.page.NodeNameComparator.
ツリービューのノードを名前順にソートするためのコンパレータです。
NodeNameComparator() - class jp.co.intra_mart.foundation.page.NodeNameComparator のコンストラクタ

NodePathControllerConverter - class jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter.
コントローラオブジェクトに「PATH_フィールド名」となる名前の静的フィールドを定義し、 代入されるノードのパスを指定することにより、ノードの値をコントローラオブジェクトに代入します。
NodePathControllerConverter() - class jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter のコンストラクタ

NodeTypeComparator - class jp.co.intra_mart.foundation.page.NodeTypeComparator.
ツリービューのノードを種類順にソートするためのコンパレータです。
NodeTypeComparator(Comparator) - class jp.co.intra_mart.foundation.page.NodeTypeComparator のコンストラクタ
第２コンパレータ secondaryComparatorを指定して、新たなオブジェクトを生成します。
NonceResetListener4MobileEasyLogin - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin.
かんたんログイン用のNonceを再設定する為のリスナーです。
NonceResetListener4MobileEasyLogin() - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のコンストラクタ

NotExistException - exception jp.co.intra_mart.foundation.security.exception.NotExistException.
アクセスセキュリティ情報が存在しなかった場合の例外クラス。
NotExistException(String, String, String) - class jp.co.intra_mart.foundation.security.exception.NotExistException のコンストラクタ
コンストラクタ。
NotExistException(String, String) - class jp.co.intra_mart.foundation.security.exception.NotExistException のコンストラクタ
コンストラクタ。
NotExistException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.NotExistException のコンストラクタ
コンストラクタ。
NotExistException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.NotExistException のコンストラクタ
コンストラクタ。
NotExistImageIconException - exception jp.co.intra_mart.foundation.image.NotExistImageIconException.
イメージアイコンが存在しなかった場合の例外クラス。
NotExistImageIconException() - class jp.co.intra_mart.foundation.image.NotExistImageIconException のコンストラクタ
コンストラクタ。
NotExistImageIconException(String, String) - class jp.co.intra_mart.foundation.image.NotExistImageIconException のコンストラクタ
コンストラクタ。
NotExistImageIconException(Throwable) - class jp.co.intra_mart.foundation.image.NotExistImageIconException のコンストラクタ
コンストラクタ。
NotExistImageIconException(String, String, Throwable) - class jp.co.intra_mart.foundation.image.NotExistImageIconException のコンストラクタ
コンストラクタ。
NotFoundDataSourceException - exception jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException.
データソースの参照名未解決例外クラス。
NotFoundDataSourceException(String, String) - class jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException のコンストラクタ
コンストラクタ。
NotFoundDataSourceException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException のコンストラクタ
コンストラクタ。
NotFoundException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException.
指定されたコンテンツが見つからないことを通知するための例外です。
NotFoundException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException のコンストラクタ
指定のメッセージを持つ例外を作成します。
NotFoundException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
NotFoundException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException のコンストラクタ
例外を作成します。
NotSupportMethodException - exception jp.co.intra_mart.foundation.security.exception.NotSupportMethodException.
アクセスセキュリティのマネージャでサポートされないメソッドがコールされた場合の例外クラス。
NotSupportMethodException(Throwable) - class jp.co.intra_mart.foundation.security.exception.NotSupportMethodException のコンストラクタ
コンストラクタ。
NotSupportMethodException() - class jp.co.intra_mart.foundation.security.exception.NotSupportMethodException のコンストラクタ
コンストラクタ。
NumericRangeValidator - class jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator.
数値の範囲をチェックします。
NumericRangeValidator() - class jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator のコンストラクタ

NumericValidator - class jp.co.intra_mart.framework.base.service.validator.NumericValidator.
数値（整数）として妥当であるかどうかをチェックします。
NumericValidator() - class jp.co.intra_mart.framework.base.service.validator.NumericValidator のコンストラクタ

nativeSQL(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された SQL 文をシステムの本来の SQL 文法に変換します。
newExtendedBaseModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap のメソッド
初期化されていない拡張基本モデルのインスタンスを取得します。
newExtendedInternationalModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap のメソッド
初期化されていない拡張国際化モデルのインスタンスを取得します。
newExtendedTerminableInternationalModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap のメソッド
初期化されていない拡張期間国際化モデルのインスタンスを取得します。
newExtendedTerminableModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap のメソッド
初期化されてていない拡張期間化モデルのインスタンスを取得します。
newIdentifier() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
新しいセッションＩＤを生成します。
newInstance() - class jp.co.intra_mart.foundation.datastore.common.model.MapperFactory の static メソッド
マッパーファクトリを取得します。
newInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
初期化されていない国際化モデルのインスタンスを取得します。
newString(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
CharacterEncoder.getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
newString(char[]) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
CharacterEncoder.getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
newString(String) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 CharacterEncoder.getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
newString(char[]) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 CharacterEncoder.getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
newTerminableInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
初期化されていない期間国際化モデルのインスタンスを取得します。
newTerminableModel(Term) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
初期化されていない期間化モデルのインスタンスを取得します。
notifyDelete(Relationship, BaseModel) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
notifyDelete(Relationship, BaseModel) - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
notifyUpdate(Relationship, BaseModel) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
notifyUpdate(Relationship, BaseModel) - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
リレーションシップで定義された参照先基本モデルが更新されたことを通知します。

O

OBJECT_PARAM_NAME - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter の static 変数
コントローラオブジェクトのクラス名を設定するパラメータ名
OBJECT_PARAM_NAME - class jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter の static 変数
コントローラオブジェクトのクラス名を設定するパラメータ名
OBJECT_PARAM_NAME - class jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter の static 変数
コントローラオブジェクトのクラス名を設定するパラメータ名
OPEN_FLG_CLOSE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
公開フラグ：非公開
OPEN_FLG_EDIT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
公開フラグ：編集中
OPEN_FLG_OPEN - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
公開フラグ：公開
ORACLE - class jp.co.intra_mart.foundation.database.DbTypes の static 変数

OTHER - class jp.co.intra_mart.foundation.database.DbTypes の static 変数

OWNER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の static 変数
所有者コード
OWNER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
所有者コード
OrderCcard - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard.
クレジットカードデータ情報クラス
機能は以下の通り
クレジットカードデータ情報を保持します。
OrderCcard() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のコンストラクタ
クレジットカードデータ情報を作成します。
OrderCcard(int) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のコンストラクタ
クレジットカードデータ情報を作成します。
OrderList - class jp.co.intra_mart.foundation.sap.module.financial.OrderList.
選択指図一覧情報クラス 機能は以下の通り
選択指図一覧情報を保持します。
OrderList() - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のコンストラクタ
選択指図一覧を作成します。
OutputSizeConditioner - class jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner.
このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
OutputSizeConditioner(long) - class jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner のコンストラクタ
メッセージファイルへのデータ出力量によりリフレッシュイベントを 発生させるためのヘルパーオブジェクトを構築します。
OutputSizeConditioner - class jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner クラスを使用してください。
OutputSizeConditioner(long) - class jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner のコンストラクタ
推奨されていません。 メッセージファイルへのデータ出力量によりリフレッシュイベントを 発生させるためのヘルパーオブジェクトを構築します。
onSendMail(MailSendEvent) - interface jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener のメソッド
メール送信が行われたことを通知します。
onSendMail(MailSendEvent) - class jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener のメソッド
メール送信が行われたことを通知します。
out - class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream の変数
フィルタ処理される基礎出力ストリームです。
out - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter の変数
基礎出力ストリームです。
out - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter の変数
基礎出力ストリームです。
out - class jp.co.intra_mart.foundation.service.provider.Platform の static 変数
システムログに対するメッセージ出力ストリームです。
out - class jp.co.intra_mart.foundation.utility.io.HexOutputStream の変数
推奨されていません。 フィルタ処理される基礎出力ストリームです。
out - class jp.co.intra_mart.foundation.utility.report.FileReporter の変数
推奨されていません。 基礎出力ストリームです。
out - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter の変数
推奨されていません。 基礎出力ストリームです。

P

PAGE_KIND - class jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet の static 変数
ページ種別
PAGE_KIND - class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet の static 変数
ページ種別
PAGE_KIND - class jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet の static 変数
ページ種別
PAGE_KIND - class jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet の static 変数
ページ種別
PAGE_KIND - class jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet の static 変数
ページ種別
PAGE_KIND - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet の static 変数
ページ種別
PAGE_PATH - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider の static 変数
ページベースプログラム名を特定するキー
PAGE_PATTERN_ID - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
メインページパターン
PARAM_APPLICATION - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルのアプリケーションのパラメータ名
PARAM_APPLICATION - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
アプリケーション
PARAM_APPLICATION - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
アプリケーション
PARAM_APPLICATION_CLASS - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルのクラスのパラメータ名
PARAM_APPLICATION_CLASS - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
クラス
PARAM_APPLICATION_CLASS - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
クラス
PARAM_APPLICATION_PARAM - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルのパラメータのパラメータ名
PARAM_APPLICATION_PARAM - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
パラメータ
PARAM_APPLICATION_PARAM - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
パラメータ
PARAM_ARGUMENT - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 ページ引数のリクエストパラメータ名
PARAM_ARGUMENT - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENTを使用してください。
PARAM_ARGUMENT_DELIMITER - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 ページ引数のデリミタ
PARAM_ARGUMENT_DELIMITER - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_DELIMITERを使用してください。
PARAM_ARGUMENT_OPERATOR - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 ページ引数の演算子
PARAM_ARGUMENT_OPERATOR - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_OPERATORを使用してください。
PARAM_BUNDLE - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルのバンドルのパラメータ名
PARAM_BUNDLE - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
プロパティファイルのバンドルのパラメータ名
PARAM_BUNDLE - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
プロパティファイルのバンドルのパラメータ名
PARAM_DEFAULT - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルのデフォルトのパラメータ名
PARAM_DEFAULT - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
デフォルト
PARAM_DEFAULT - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
デフォルト
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_ERROR_PAGE - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter の static 変数
エラーページパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_LOGIN_GROUP_ID - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 ログイングループIDのリクエストパラメータ名
PARAM_LOGIN_GROUP_ID - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_GROUP_IDを使用してください。
PARAM_LOGIN_USER_ID - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 ログインユーザIDのリクエストパラメータ名
PARAM_LOGIN_USER_ID - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_USER_IDを使用してください。
PARAM_MAX - class jp.co.intra_mart.framework.base.service.validator.LengthValidator の static 変数
文字列長の最大値が設定されているパラメータ名
PARAM_MAX - class jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator の static 変数
数値の最大値が設定されているパラメータ名
PARAM_MESSAGE - class jp.co.intra_mart.framework.base.service.validator.FormatValidator の static 変数
不正文字列である場合のメッセージが設定されているパラメータ名
PARAM_MESSAGE - class jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator の static 変数
数値が範囲外の場合のメッセージが設定されているパラメータ名
PARAM_MESSAGE - class jp.co.intra_mart.framework.base.service.validator.NumericValidator の static 変数
数値として妥当ではない場合のメッセージが設定されているパラメータ名
PARAM_MESSAGE_LONG - class jp.co.intra_mart.framework.base.service.validator.LengthValidator の static 変数
文字列長が長い場合のメッセージが設定されているパラメータ名
PARAM_MESSAGE_SHORT - class jp.co.intra_mart.framework.base.service.validator.LengthValidator の static 変数
文字列長が短い場合のメッセージが設定されているパラメータ名
PARAM_MIN - class jp.co.intra_mart.framework.base.service.validator.LengthValidator の static 変数
文字列長の最小値が設定されているパラメータ名
PARAM_MIN - class jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator の static 変数
数値の最小値が設定されているパラメータ名
PARAM_PROPERTY - class jp.co.intra_mart.framework.base.service.validator.FormatValidator の static 変数
検証対象となるコントローラオブジェクトのプロパティ名を示すパラメータ名
PARAM_PROPERTY - class jp.co.intra_mart.framework.base.service.validator.LengthValidator の static 変数
検証対象のプロパティ名が設定されているパラメータ名
PARAM_PROPERTY - class jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator の static 変数
検証対象のプロパティ名が設定されているパラメータ名
PARAM_PROPERTY - class jp.co.intra_mart.framework.base.service.validator.NumericValidator の static 変数
検証対象のプロパティ名が設定されているパラメータ名
PARAM_REFERER - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 参照元URLのリクエストパラメータ名
PARAM_REFERER - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_REFERERを使用してください。
PARAM_REGEX - class jp.co.intra_mart.framework.base.service.validator.FormatValidator の static 変数
正規表現によるフォーマットが設定されているパラメータ名
PARAM_SECURITY_EXT - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 セキュリティの拡張子
PARENT_DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
親組織コード
PARENT_ITEM_CATEGORY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel の static 変数
親商品カテゴリコード
PARENT_MENU_ID - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の static 変数
親メニューID
PARENT_PUBLIC_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
親グループコード
PARENT_ROLE_ID - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel の static 変数
親ロールコード
PASSWORD - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
パスワード
PLUGIN_METHOD - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
プラグイン関数
POSTGRESQL - class jp.co.intra_mart.foundation.database.DbTypes の static 変数

POST_CD - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel の static 変数
役職CD
POST_CD - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel の static 変数
役職CD
POST_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
役職CD
POST_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
役職コード
PRIVATE_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の static 変数
グループコード
PRIVATE_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
グループコード
PROCESS_BUSY - class jp.co.intra_mart.foundation.database.exception.DatabaseExportException の static 変数
推奨されていません。
PRODUCT_MODEL_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel の static 変数
製品型番
PROGRAM_LANGUAGE - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
実行プログラム言語
PROGRAM_PATH - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
実行プログラムパス
PUBLIC_GROUP_CD - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel の static 変数
グルーピングCD
PUBLIC_GROUP_CD - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel の static 変数
グルーピングCD
PUBLIC_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel の static 変数
グループコード
PUBLIC_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の static 変数
グループコード
PUBLIC_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の static 変数
グループコード
PUBLIC_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
グループコード
PUBLIC_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
グループコード
PUBLIC_GROUP_SET_CD - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel の static 変数
グループセットCD
PUBLIC_GROUP_SET_CD - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel の static 変数
グループセットCD
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel の static 変数
グループセットコード
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の static 変数
グループセットコード
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の static 変数
グループセットコード
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
グループセットコード
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
グループセットコード
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel の static 変数
グループセットコード
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
グループセットコード
PURCHASE_UNIT_PRICE - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel の static 変数
仕入単価
P_ID_CONNECTOR_CLASS - class jp.co.intra_mart.framework.base.data.ConnectorModel の static 変数

P_ID_CONNECTOR_NAME - class jp.co.intra_mart.framework.base.data.ConnectorModel の static 変数

P_ID_CONNECT_NAME - class jp.co.intra_mart.framework.base.data.DaoModel の static 変数

P_ID_CONVERTER_CLASS - class jp.co.intra_mart.framework.base.service.ControllerConverterModel の static 変数

P_ID_CONVERTER_PARAM - class jp.co.intra_mart.framework.base.service.ControllerConverterModel の static 変数

P_ID_DAO_CLASS - class jp.co.intra_mart.framework.base.data.DaoModel の static 変数

P_ID_DAO_CONNECTOR_NAME - class jp.co.intra_mart.framework.base.data.DaoModel の static 変数

P_ID_EVENT_KEY - class jp.co.intra_mart.framework.base.event.EventGroupModel の static 変数

P_ID_EVENT_NAME - class jp.co.intra_mart.framework.base.event.EventGroupModel の static 変数

P_ID_FACTORY_CLASS - class jp.co.intra_mart.framework.base.event.EventFactoryModel の static 変数

P_ID_FACTORY_PARAM - class jp.co.intra_mart.framework.base.event.EventFactoryModel の static 変数

P_ID_PARAM_NAME - class jp.co.intra_mart.framework.base.data.ResourceModel の static 変数

P_ID_PARAM_NAME - class jp.co.intra_mart.framework.base.event.EventFactoryModel の static 変数

P_ID_PARAM_NAME - class jp.co.intra_mart.framework.base.service.ControllerConverterModel の static 変数

P_ID_PARAM_NAME - class jp.co.intra_mart.framework.base.service.ValidatorModel の static 変数

P_ID_PARAM_VALUE - class jp.co.intra_mart.framework.base.data.ResourceModel の static 変数

P_ID_PARAM_VALUE - class jp.co.intra_mart.framework.base.event.EventFactoryModel の static 変数

P_ID_PARAM_VALUE - class jp.co.intra_mart.framework.base.service.ControllerConverterModel の static 変数

P_ID_PARAM_VALUE - class jp.co.intra_mart.framework.base.service.ValidatorModel の static 変数

P_ID_POST_TRIGGER - class jp.co.intra_mart.framework.base.event.EventGroupModel の static 変数

P_ID_PRE_TRIGGER - class jp.co.intra_mart.framework.base.event.EventGroupModel の static 変数

P_ID_RESOURCE_NAME - class jp.co.intra_mart.framework.base.data.ConnectorModel の static 変数

P_ID_RESOURCE_NAME - class jp.co.intra_mart.framework.base.data.ResourceModel の static 変数

P_ID_RESOURCE_PARAM - class jp.co.intra_mart.framework.base.data.ResourceModel の static 変数

P_ID_TRIGGER_CLASS - class jp.co.intra_mart.framework.base.event.EventGroupModel の static 変数

P_ID_VALIDATOR_CLASS - class jp.co.intra_mart.framework.base.service.ValidatorModel の static 変数

P_ID_VALIDATOR_PARAM - class jp.co.intra_mart.framework.base.service.ValidatorModel の static 変数

PageBaseCallProvider - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider.
NewArrivedProvider インターフェースの実装です。
PageBaseCallProvider() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider のコンストラクタ

ParamAllVersions - class jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions.
全バージョンパラメータ設定クラス
機能は以下の通り
全バージョンのパラメータを設定します。
ParamBatchRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa.
ロットの範囲パラメータ設定クラス
機能は以下の通り
ロットの範囲のパラメータを設定します。
ParamBillingDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn.
処理予定明細データのテーブルパラメータ設定クラス
機能は以下の通り
処理予定明細データのテーブルパラメータを設定します。
ParamBillingDocumentDetailList - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList.
後続請求伝票のテーブルパラメータ設定クラス
機能は以下の通り
後続請求伝票のテーブルのパラメータを設定します。
ParamCCardDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn.
処理予定支払方法のテーブルパラメータ設定クラス
機能は以下の通り
処理予定支払方法のテーブルパラメータを設定します。
ParamCfgsBlob - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob.
選定: BLOB 内部データ (SCE)パラメータ設定クラス
機能は以下の通り
選定: BLOB 内部データ (SCE)のパラメータを設定します。
ParamCfgsInst - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst.
選定: インスタンスパラメータ設定クラス
機能は以下の通り
選定: インスタンスのパラメータを設定します。
ParamCfgsPartOf - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf.
選定: 部分設定パラメータ設定クラス
機能は以下の通り
選定: 部分設定のパラメータを設定します。
ParamCfgsRef - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef.
選定: 参照データパラメータ設定クラス
機能は以下の通り
選定: 参照データのパラメータを設定します。
ParamCfgsRefInst - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst.
選定: 参照明細/インスタンスパラメータ設定クラス
機能は以下の通り
選定: 参照明細/インスタンスのパラメータを設定します。
ParamCfgsValue - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue.
選定: 特性値パラメータ設定クラス
機能は以下の通り
選定: 特性値のパラメータを設定します。
ParamCfgsVk - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk.
選定: バリアント条件キーパラメータ設定クラス
機能は以下の通り
選定: バリアント条件キーのパラメータを設定します。
ParamClientDataList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList.
品目データ (クライアントレベル)パラメータ設定クラス
機能は以下の通り
品目データ (クライアントレベル)パラメータを設定します。
ParamCondHeader - class jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader.
条件ヘッダパラメータ設定クラス
機能は以下の通り
条件ヘッダのパラメータを設定します。
ParamCondItem - class jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem.
条件明細パラメータ設定ラクラス
機能は以下の通り
条件明細のパラメータを設定します。
ParamConditionDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn.
処理予定条件のテーブルパラメータ設定クラス
機能は以下の通り
処理予定条件のテーブルのパラメータを設定します。
ParamConditionsIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn.
条件パラメータ設定クラス
機能は以下の通り
条件のパラメータを設定します。
ParamConditionsInX - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX.
受注における条件更新の通信項目パラメータ設定クラス
機能は以下の通り
受注における条件更新の通信項目のパラメータを設定します。
ParamContractLimits - class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits.
外注基本契約制限パラメータ設定クラス
機能は以下の通り
外注基本契約制限のパラメータを設定します。
ParamContractService - class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService.
外注サービスパラメータ設定クラス
機能は以下の通り
外注サービスのパラメータを設定します。
ParamContractServiceAccount - class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount.
外注サービス勘定設定パラメータ設定クラス
機能は以下の通り
外注サービス勘定設定のパラメータを設定します。
ParamContractServiceText - class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText.
外注サービステキストパラメータ設定クラス
機能は以下の通り
外注サービステキストのパラメータを設定します。
ParamConverter - class jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter.
パラメータ変換クラス
機能は以下の通り
パラメータの項目、値を変換します。
ParamConverter() - class jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter のコンストラクタ
ParamConvertorのコンストラクタを呼び出し
ParamCreatorDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn.
取り込まれる日付の順序パラメータ設定クラス
機能は以下の通り
取り込まれる日付の順序のパラメータを設定します。
ParamDeliveryAddress - class jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress.
入荷伝票アドレスパラメータ設定ラクラス
機能は以下の通り
入荷伝票アドレスのパラメータを設定します。
ParamErrors - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors.
前明細の不正処理に関する情報パラメータ設定クラス
機能は以下の通り
前明細の不正処理に関する情報のパラメータを設定します。
ParamExportHeader - class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader.
貿易管理ヘッダパラメータ設定ラクラス
機能は以下の通り
貿易管理ヘッダのパラメータを設定します。
ParamExportItem - class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem.
貿易管理明細インポートパラメータ設定クラス
機能は以下の通り
貿易管理明細のパラメータを設定します。
ParamExtension - class jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension.
拡張得意先項目パラメータ設定クラス
機能は以下の通り
拡張得意先項目のパラメータを設定します。
ParamExtensionIn - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn.
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造パラメータ設定クラス
機能は以下の通り
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造のパラメータを設定します。
ParamExtensionIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn.
VBAK、VBAP、VBEP のカスタマ拡張パラメータ設定クラス
機能は以下の通り
VBAK、VBAP、VBEP のカスタマ拡張のパラメータを設定します。
ParamExtensionInX - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX.
拡張イン/拡張アウトのチェックボックス構造パラメータ設定クラス
機能は以下の通り
拡張イン/拡張アウトのチェックボックス構造のパラメータを設定します。
ParamForecastParametersList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList.
需要予測パラメータ設定クラス
機能は以下の通り
需要予測パラメータのパラメータを設定します。
ParamForecastValues - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues.
需要予測値のデータ転送パラメータ設定クラス
機能は以下の通り
需要予測値のデータ転送のパラメータを設定します。
ParamGoodsMvtCode - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode.
在庫移動に対するコードのトランザクションへの割当パラメータ設定クラス
機能は以下の通り
在庫移動に対するコードのトランザクションへの割当のパラメータを設定します。
ParamGoodsMvtHeader - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader.
入出庫伝票ヘッダデータ設定クラス
機能は以下の通り
入出庫伝票ヘッダデータのパラメータを設定します。
ParamGoodsMvtHeaderList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList.
リターン構造、入出庫伝票ヘッダパラメータ設定クラス
機能は以下の通り
リターン構造、入出庫伝票ヘッダのパラメータを設定します。
ParamGoodsMvtHeadret - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret.
入出庫伝票ヘッダデータパラメータ設定クラス
機能は以下の通り
入出庫伝票ヘッダデータのパラメータを設定します。
ParamGoodsMvtItem - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem.
リターン構造、入出庫伝票明細パラメータ設定クラス
機能は以下の通り
リターン構造、入出庫伝票明細のパラメータを設定します。
ParamGoodsMvtItems - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems.
リターン構造、入出庫伝票明細パラメータ設定クラス
機能は以下の通り
リターン構造、入出庫伝票明細のパラメータを設定します。
ParamGoodsMvtSerialNumber - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber.
シリアル番号パラメータ設定クラス
機能は以下の通り
シリアル番号のパラメータを設定します。
ParamHeadData - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData.
管理情報設定ヘッダセグメントパラメータ設定クラス
機能は以下の通り
管理情報設定ヘッダセグメントのパラメータを設定します。
ParamHeader - class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader.
伝票ヘッダパラメータ設定クラス
機能は以下の通り
伝票ヘッダのインポートパラメータを設定します。
ParamHeaderIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn.
販売伝票ヘッダデータセグメントパラメータ設定クラス
機能は以下の通り
販売伝票ヘッダデータのパラメータを設定します。
ParamHeaderInX - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX.
ヘッダデータチェックボックスパラメータ設定クラス
機能は以下の通り
ヘッダデータチェックボックスのパラメータを設定します。
ParamHeaderText - class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText.
ヘッダテキストパラメータ設定クラス
機能は以下の通り
ヘッダテキストのパラメータを設定します。
ParamInternationalArtnos - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos.
国際商品コード (EAN)パラメータ設定クラス
機能は以下の通り
国際商品コード (EAN)のパラメータを設定します。
ParamItem - class jp.co.intra_mart.foundation.sap.module.purchase.ParamItem.
明細パラメータ設定クラス
機能は以下の通り
明細のパラメータを設定します。
ParamItemText - class jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText.
明細テキストパラメータ設定クラス
機能は以下の通り
明細テキストのパラメータを設定します。
ParamItemsIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn.
明細データパラメータ設定クラス
機能は以下の通り
明細データのパラメータを設定します。
ParamItemsInX - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX.
明細データチェックボックス のパラメータ設定クラス
機能は以下の通り
明細データチェックボックスのパラメータを設定します。
ParamKeys - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys.
参照キーパラメータ設定クラス
機能は以下の通り
参照キーのパラメータを設定します。
ParamLimits - class jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits.
外注制限パラメータ設定クラス
機能は以下の通り
外注制限のパラメータを設定します。
ParamLogicSwitch - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch.
内部制御パラメータパラメータ設定クラス
機能は以下の通り
内部制御パラメータのパラメータを設定します。
ParamMaterialDescription - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription.
品目テキストパラメータ設定クラス
機能は以下の通り
品目テキストのパラメータを設定します。
ParamMaterialLongText - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText.
テキスト (長)パラメータ設定クラス
機能は以下の通り
テキスト (長)のパラメータを設定します。
ParamMaterialRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa.
品目コードの範囲パラメータ設定クラス
機能は以下の通り
品目コードの範囲のパラメータを設定します。
ParamMoveTypeRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa.
移動タイプの範囲パラメータ設定クラス
機能は以下の通り
移動タイプの範囲のパラメータを設定します。
ParamOrderCcard - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard.
クレジットカードデータ情報パラメータ設定クラス
機能は以下の通り
クレジットカードデータ情報のパラメータを設定します。
ParamPartner - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner.
得意先インポートパラメータ設定クラス
機能は以下の通り
得意先のパラメータを設定します。
ParamPartnerAddresses - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses.
アドレス (組織/会社) 用 BAPI 参照構造パラメータ設定クラス
機能は以下の通り
アドレス (組織/会社) 用 BAPI 参照構造のパラメータを設定します。
ParamPartners - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners.
伝票取引先パラメータ設定クラス
機能は以下の通り
伝票取引先のパラメータを設定します。
ParamPlanningDataList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList.
品目マスタ/製品グループの変更伝票構造パラメータ設定クラス
機能は以下の通り
品目マスタ/製品グループの変更伝票構造のパラメータを設定します。
ParamPlantDataList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList.
品目データ (プラントレベル)パラメータ設定クラス
機能は以下の通り
品目データ (プラントレベル)のパラメータを設定します。
ParamPlantRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa.
プラントの範囲パラメータ設定クラス
機能は以下の通り
プラントの範囲のパラメータを設定します。
ParamProfitSegment - class jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment.
入出庫予定パラメータ設定クラス
機能は以下の通り
入出庫予定のパラメータを設定します。
ParamPrtData - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData.
品目マスタの生産資源/治工具 (PRT) 項目パラメータ設定クラス
機能は以下の通り
品目マスタの生産資源/治工具 (PRT) 項目のパラメータを設定します。
ParamPstngDateRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa.
登録日付の範囲パラメータ設定クラス
機能は以下の通り
登録日付の範囲のパラメータを設定します。
ParamPurchaseAccount - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount.
勘定設定パラメータ設定クラス
機能は以下の通り
勘定設定のパラメータを設定します。
ParamPurchaseSchedule - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule.
納入日程パラメータ設定クラス
機能は以下の通り
納入日程のパラメータを設定します。
ParamRefDocRange - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange.
前伝票の範囲パラメータ設定クラス
機能は以下の通り
前伝票の範囲のパラメータを設定します。
ParamReturnMessages - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages.
リターンパラメータ BAPIRET2 の代替構造項目パラメータ設定クラス
機能は以下の通り
リターンパラメータ BAPIRET2 の代替構造項目のパラメータをセットします。
ParamSalesDataList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList.
倉庫番号データパラメータ設定クラス
機能は以下の通り
倉庫番号データのパラメータを設定します。
ParamSalesOrders - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders.
得意先受注テーブル情報パラメータ設定クラス
機能は以下の通り
得意先受注テーブル情報のパラメータを設定します。
ParamSchedulesIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn.
納入日程行パラメータ設定クラス
機能は以下の通り
納入日程行のパラメータを設定します。
ParamSchedulesInX - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX.
納入日程行チェックボックスパラメータ設定クラス
機能は以下の通り
納入日程行チェックボックスのパラメータを設定します。
ParamSender - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender.
論理システム - 送信者セグメントパラメータ設定クラス
機能は以下の通り
論理システム - 送信者のパラメータを設定します。
ParamSpecStockRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa.
特殊在庫区分の範囲パラメータ設定クラス
機能は以下の通り
特殊在庫区分の範囲のパラメータを設定します。
ParamStatusInfo - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo.
ステータス情報パラメータ設定クラス
機能は以下の通り
ステータス情報のパラメータを設定します。
ParamStgeLocRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa.
保管場所の範囲パラメータ設定クラス
機能は以下の通り
保管場所の範囲のパラメータを設定します。
ParamStorageLocationDataList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList.
品目データ (保管場所レベル)パラメータ設定クラス
機能は以下の通り
品目データ (保管場所レベル)のパラメータを設定します。
ParamStorageTypeDataList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList.
品目データ (保管場所レベル)パラメータ設定クラス
機能は以下の通り
品目データ (保管場所レベル)のパラメータを設定します。
ParamSuccess - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess.
後続請求伝票の明細テーブルパラメータ設定クラス
機能は以下の通り
後続請求伝票の明細テーブルのパラメータを設定します。
ParamTag - class jp.co.intra_mart.framework.base.web.tag.ParamTag.
リンク先、遷移先に渡すパラメータを設定します。
ParamTag() - class jp.co.intra_mart.framework.base.web.tag.ParamTag のコンストラクタ
ParamTagを新規に生成します。
ParamTaxClassifications - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications.
制御デ－タパラメータ設定クラス
機能は以下の通り
制御デ－タのパラメータを設定します。
ParamText - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText.
テキストパラメータ設定クラス
機能は以下の通り
テキストのパラメータを設定します。
ParamTextDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn.
請求インタフェースの通信構造テキストパラメータ設定クラス
機能は以下の通り
請求インタフェースの通信構造テキストのパラメータを設定します。
ParamTotalConsumption - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption.
品目総消費量のデータ転送パラメータ設定クラス
機能は以下の通り
品目総消費量のデータ転送のパラメータを設定します。
ParamTrEvTypeRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa.
トランザクション/イベントタイプの範囲パラメータ設定クラス。
ParamUnitSofmeasure - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure.
数量単位パラメータ設定クラス
機能は以下の通り
数量単位のパラメータを設定します。
ParamUnplndConsumption - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption.
計画外消費のデータ転送パラメータ設定クラス
機能は以下の通り
計画外消費のデータ転送のパラメータを設定します。
ParamUserNameRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa.
ユーザ名の範囲パラメータ設定クラス
機能は以下の通り
ユーザ名の範囲のパラメータを設定します。
ParamValuationDataList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList.
評価データパラメータ設定クラス
機能は以下の通り
評価データのパラメータを設定します。
ParamVendorAddress - class jp.co.intra_mart.foundation.sap.module.purchase.ParamVendorAddress.
仕入先住所パラメータ設定クラス
機能は以下の通り
仕入先住所のパラメータを設定します。
ParamVendorRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa.
仕入先の範囲パラメータ設定クラス
機能は以下の通り
仕入先の範囲のパラメータを設定します。
ParamVersions - class jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions.
バージョン管理パラメータ設定ラクラス
機能は以下の通り
バージョン管理のパラメータを設定します。
ParamWarehouseNumberDataList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList.
倉庫番号データパラメータ設定クラス
機能は以下の通り
倉庫番号データのパラメータを設定します。
ParamWmdvex - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex.
出力テーブル (日付および ATP 数量)パラメータ設定クラス
機能は以下の通り
出力テーブル (日付および ATP 数量)のパラメータを設定します。
ParamWmdvsx - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx.
入力テーブル (日付/数量)パラメータ設定クラス
機能は以下の通り
入力テーブル (日付/数量)のパラメータを設定します。
ParameterManager - class jp.co.intra_mart.foundation.commons.ParameterManager.
システム共通パラメータ情報の取得を行うクラスです。
ParameterSendable - interface jp.co.intra_mart.framework.base.web.tag.ParameterSendable.
パラメータを渡すことができるタグです。
ParameterSourceProvider - interface jp.co.intra_mart.foundation.commons.ParameterSourceProvider.
アプリケーション共通マスタのパラメータの管理するプロバイダーです。
Partner - class jp.co.intra_mart.foundation.sap.module.purchase.Partner.
取引先情報クラス
機能は以下の通り
取引先情報を保持します。
Partner() - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のコンストラクタ
取引先を作成します。
Partner(int) - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のコンストラクタ
取引先を作成します。
PartnerAddresses - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses.
アドレス (組織/会社) 用 BAPI 参照構造情報クラス
機能は以下の通り
アドレス (組織/会社) 用 BAPI 参照構造情報を保持します。
PartnerAddresses() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のコンストラクタ
アドレス (組織/会社) 用 BAPI 参照構造情報を作成します。
PartnerAddresses(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のコンストラクタ
アドレス (組織/会社) 用 BAPI 参照構造情報を作成します。
Partners - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners.
伝票取引先情報クラス
機能は以下の通り
伝票取引先情報を保持します。
Partners() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のコンストラクタ
伝票取引先情報を作成します。
Partners(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のコンストラクタ
伝票取引先情報を作成します。
PasswordHistory - class jp.co.intra_mart.foundation.security.password.PasswordHistory.
パスワード履歴管理情報クラス

PasswordHistory() - class jp.co.intra_mart.foundation.security.password.PasswordHistory のコンストラクタ

PasswordHistoryAccessor - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor.
パスワード履歴管理アクセッサインターフェース。
PasswordHistoryAccountChangedListener - class jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener.
アカウント情報変更リスナー(パスワード履歴管理)。
PasswordHistoryAccountChangedListener() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener のコンストラクタ

PasswordHistoryException - exception jp.co.intra_mart.foundation.security.password.PasswordHistoryException.
イメージアイコンの例外クラス。
PasswordHistoryException() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryException のコンストラクタ
コンストラクタ。
PasswordHistoryException(String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryException のコンストラクタ
コンストラクタ。
PasswordHistoryException(Throwable) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryException のコンストラクタ
コンストラクタ。
PasswordHistoryException(String, Throwable) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryException のコンストラクタ
コンストラクタ。
PasswordHistoryManager - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager.
パスワード履歴管理マネージャクラス

ServerManager/conf/password-history.xmlからパスワード履歴管理に関するパラメータを取得します。
PasswordHistoryManager(String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のコンストラクタ

PasswordHistoryManagerInitializerImpl - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManagerInitializerImpl.
パスワード履歴管理マネージャの初期化クラス。
PasswordHistoryManagerInitializerImpl() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManagerInitializerImpl のコンストラクタ

PasswordHistoryNewArrivedProvider - class jp.co.intra_mart.foundation.security.password.PasswordHistoryNewArrivedProvider.
パスワード履歴管理汎用新着情報のプロバイダ。
PasswordHistoryNewArrivedProvider() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryNewArrivedProvider のコンストラクタ

PasswordHistoryResult - class jp.co.intra_mart.foundation.security.password.PasswordHistoryResult.
パスワード履歴管理リザルトクラス。
PasswordHistoryResult() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryResult のコンストラクタ

PasswordHistoryResult(String, String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryResult のコンストラクタ

PasswordHistoryUserPageProvider - class jp.co.intra_mart.foundation.security.password.PasswordHistoryUserPageProvider.
パスワード履歴管理スタンダードユーザページプロバイダクラス。
PasswordHistoryUserPageProvider() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryUserPageProvider のコンストラクタ

PasswordSecurityHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler.
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
PasswordSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler, String, String, String) - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler のコンストラクタ
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
PeriodicConditioner - class jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner.
このクラスは、タイマーによりリフレッシュイベントを 発生させるためのヘルパークラスです。
PeriodicConditioner(long) - class jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner のコンストラクタ
タイマーによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
PeriodicConditioner - class jp.co.intra_mart.foundation.utility.report.PeriodicConditioner.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner クラスを使用してください。
PeriodicConditioner(long) - class jp.co.intra_mart.foundation.utility.report.PeriodicConditioner のコンストラクタ
推奨されていません。 タイマーによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
PermanentDataArchiveFactory - class jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory.
推奨されていません。
PermanentDataArchiveFactory() - class jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory のコンストラクタ
推奨されていません。 バッチプログラム実行環境からインスタンス化されるためのコンストラクタ。
PermanentDataDirectory - class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory.
Permanent-data を保存するディレクトリを表すオブジェクトです。
PermanentDirectory - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory.
ファイルベースでデータを保存します。
PermanentDirectory(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
PermanentFile - class jp.co.intra_mart.foundation.service.client.information.PermanentFile.
ファイルベースでデータを保存します。
PermanentFile(String, String) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
PermanentFile(PermanentDirectory, String) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
PermissionManager - class jp.co.intra_mart.foundation.security.permission.PermissionManager.
パーミッション・マネージャクラス。
PermissionManager(String) - class jp.co.intra_mart.foundation.security.permission.PermissionManager のコンストラクタ
コンストラクタ。
PermissionSelector - interface jp.co.intra_mart.foundation.security.permission.PermissionSelector.
パーミッション・作成クラスインタフェース。
PlainCompanyPost - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost.
役職データを扱います。
PlanningData - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData.
品目マスタ/製品グループの変更伝票構造情報クラス
機能は以下の通り
品目マスタ/製品グループの変更伝票構造情報を保持します。
PlanningData() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のコンストラクタ
品目マスタ/製品グループの変更伝票構造情報を作成します。
PlanningDataList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList.
品目マスタ/製品グループの変更伝票構造情報クラス
機能は以下の通り
品目マスタ/製品グループの変更伝票構造情報を保持します。
PlanningDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList のコンストラクタ
品目マスタ/製品グループの変更伝票構造情報を作成します。
PlanningDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList のコンストラクタ
品目マスタ/製品グループの変更伝票構造情報を作成します。
PlantData - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData.
品目データ (プラントレベル)情報クラス
機能は以下の通り
品目データ (プラントレベル)情報を保持します。
PlantData() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のコンストラクタ
品目データ (プラントレベル)情報を作成します。
PlantDataList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList.
品目データ (プラントレベル)情報クラス
機能は以下の通り
品目データ (プラントレベル)情報をテーブル型で保持します。
PlantDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList のコンストラクタ
品目データ (プラントレベル)情報を作成します。
PlantDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList のコンストラクタ
品目データ (プラントレベル)情報を作成します。
PlantRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa.
プラントの範囲情報クラス
機能は以下の通り
プラントの範囲情報を保持します。
PlantRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のコンストラクタ
プラントの範囲情報を作成します。
PlantRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のコンストラクタ
プラントの範囲情報を作成します。
PlantSelection - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection.
プラントの選択オプションクラス
機能は以下の通り
プラントの選択オプションの情報を保持します。
PlantSelection() - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のコンストラクタ
プラントの選択オプション情報を作成します。
PlantSelection(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のコンストラクタ
Sプラントの選択オプション情報を作成します。
Platform - class jp.co.intra_mart.foundation.service.provider.Platform.
Platform クラスには、システム動作に関わる有用な情報を持つ フィールドおよびメソッドがあります。
PortFolioDrawer - class jp.co.intra_mart.foundation.graph.PortFolioDrawer.
ポートフォリオを描画します。
PortFolioDrawer(int, int, int, int, int, int) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のコンストラクタ
ｘ軸、ｙ軸の目盛値をint表現でポートフォリオを作成します。
PortFolioDrawer(double, double, double, double, double, double) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のコンストラクタ
ｘ軸、ｙ軸の目盛値をdouble表現でポートフォリオを作成します。
PortFolioObject - class jp.co.intra_mart.foundation.graph.PortFolioObject.
PortFolioDrawerクラスのデータを保存するオブジェクトです。
PortFolioObject(double, double) - class jp.co.intra_mart.foundation.graph.PortFolioObject のコンストラクタ
グラフのｘ値、ｙ値を指定して、データオブジェクトを作成します。
PortFolioObject(int, int) - class jp.co.intra_mart.foundation.graph.PortFolioObject のコンストラクタ
グラフのｘ値、ｙ値を指定して、データオブジェクトを作成します。
PortFolioObject(double, double, Color, int) - class jp.co.intra_mart.foundation.graph.PortFolioObject のコンストラクタ
グラフのｘ値、ｙ値と描画する点の色とサイズを指定して、データオブジェクトを作成します。
PortFolioObject(int, int, Color, int) - class jp.co.intra_mart.foundation.graph.PortFolioObject のコンストラクタ
グラフのｘ値、ｙ値と描画する点の色とサイズを指定して、データオブジェクトを作成します。
PortalStandardUserPageProvider - class jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider.
ポータルユーザページプロバイダクラス。
PortalStandardUserPageProvider() - class jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider のコンストラクタ
コンストラクタ。
Portlet - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet.
すべてのポートレットの基底となる抽象クラスです。
Portlet() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のコンストラクタ

PortletManager - class jp.co.intra_mart.foundation.portal.portlet.PortletManager.
ポートレット情報の登録・参照を行うマネージャクラスです。
PortletManager(String) - class jp.co.intra_mart.foundation.portal.portlet.PortletManager のコンストラクタ
コンストラクタ
PortletManagerException - exception jp.co.intra_mart.foundation.portal.portlet.PortletManagerException.
ポートレットマネージャー操作時に発生するすべての例外のクラスです。
PortletManagerException() - class jp.co.intra_mart.foundation.portal.portlet.PortletManagerException のコンストラクタ
コンストラクタ
PortletManagerException(String) - class jp.co.intra_mart.foundation.portal.portlet.PortletManagerException のコンストラクタ
コンストラクタ
PortletManagerException(Throwable) - class jp.co.intra_mart.foundation.portal.portlet.PortletManagerException のコンストラクタ
コンストラクタ
PortletManagerException(String, Throwable) - class jp.co.intra_mart.foundation.portal.portlet.PortletManagerException のコンストラクタ
コンストラクタ
PortletMapping - class jp.co.intra_mart.foundation.portal.portlet.PortletMapping.
ポートレットの種別とモデルのマッピングを管理します。
PostInfo - class jp.co.intra_mart.foundation.security.PostInfo.
役職情報クラス。
PostInfo(String, String) - class jp.co.intra_mart.foundation.security.PostInfo のコンストラクタ
コンストラクタ。
PresentationPage - class jp.co.intra_mart.foundation.scenario.PresentationPage.
PresentationPage クラスは、プレゼンテーション・ページとなるスクリプトを コンパイルして実行可能な環境を提供します。
PresentationPage() - class jp.co.intra_mart.foundation.scenario.PresentationPage のコンストラクタ
セッションを持たないページ作成用オブジェクトを作成します。
PresentationPage(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.scenario.PresentationPage のコンストラクタ
任意のセッションを持つページ作成オブジェクトを構築します。
PresentationPageHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler.
スクリプト開発モデルのプレゼンテーションページを実行するためのハンドラです。
PresentationPageHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のコンストラクタ
ハンドラを作成します。
PresentationPageHTTPActionEventHandler(String) - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のコンストラクタ
ハンドラを作成します。
PresentationPagePortlet - class jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet.
ページ種別「プレゼンテーションページ」に対するポートレットのモデルです。
PresentationPagePortlet() - class jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet のコンストラクタ

PrimaryKeyMapping - interface jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping.
分割されたテーブルに割り当てられるプライマリーキーとなるカラムを定義します。
PrintStreamReporter - class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter.
メッセージ出力用クラスです。
PrintStreamReporter(PrintStream) - class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter のコンストラクタ
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
PrintStreamReporter - class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter クラスを使用してください。
PrintStreamReporter(PrintStream) - class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter のコンストラクタ
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
PrivateGroup - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup.
プライベートグループの基本属性のデータを取り扱います。
PrivateGroup() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のコンストラクタ

PrivateGroupAttach - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach.
プライベートグループ所属の基本属性のデータを取り扱います。
PrivateGroupAttach() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のコンストラクタ

PrivateGroupAttachBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel.
プライベートグループ所属の基本モデルです。
PrivateGroupAttachMapper - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper.
プライベートグループ所属に関連するマッパです。
PrivateGroupBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel.
プライベートグループの基本モデルです。
PrivateGroupChangedListener - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener.
プライベートグループに関する情報の更新時のリスナーです。
PrivateGroupManager - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager.
プライベートグループに関連する情報を管理します。
PrivateGroupManager() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のコンストラクタ

PrivateGroupMapper - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper.
プライベートグループに関連するマッパです。
ProcedureComponent - interface jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent.
スケジュール実行されるバッチプログラムのためのインターフェースを定義します。
ProductionResourceToolData - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData.
品目マスタの生産資源/治工具 (PRT) 項目情報クラス
機能は以下の通り
品目マスタの生産資源/治工具 (PRT) 項目情報を保持します。
ProductionResourceToolData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のコンストラクタ
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。
ProfitCenter - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter.
利益センタ情報クラス
機能は以下の通り
利益センタの情報を保持します。
ProfitCenter() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のコンストラクタ
利益センタ情報を作成します。
ProfitCenterController - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController.
利益センタコントローラクラス
機能は以下の通り
利益センタの情報を取得します。
ProfitCenterController(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のコンストラクタ
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String, Date) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のコンストラクタ
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のコンストラクタ
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String, Date, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のコンストラクタ
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterGrpGetDetail - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail.
利益センタグループ情報取得クラス
機能は以下の通り
利益センタグループ情報を取得します。
ProfitCenterGrpGetDetail(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail のコンストラクタ
利益センタグループ情報を作成します。
ProfitCenterGrpGetDetail(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail のコンストラクタ

ProfitCenterGrpGetDetailController - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController.
利益センタグループコントローラクラス
機能は以下の通り
利益センタグループを取得します。
ProfitCenterGrpGetDetailController(String, String) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のコンストラクタ

ProfitCenterGrpGetDetailController(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のコンストラクタ

ProfitCenterGrpGetDetailController() - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のコンストラクタ
ProfitCenterGrpGetDetailControllerのコンストラクタを生成します。
ProfitCenterGrpGetDetailController(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のコンストラクタ
ProfitCenterGrpGetDetailControllerのコンストラクタを生成します。
ProfitCenterList - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList.
利益センタ一覧クラス

機能は以下の通り
利益センタの情報を一覧形式で取得します。
ProfitCenterList(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList のコンストラクタ
executeBapiを呼び出し利益センタ一覧を作成します。
ProfitSegment - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment.
入出庫予定情報クラス
機能は以下の通り
入出庫予定情報を保持します。
ProfitSegment() - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のコンストラクタ
入出庫予定を作成します。
ProfitSegment(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のコンストラクタ
入出庫予定を作成します。
ProjectDefinition - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition.
プロジェクトについての詳細情報クラス 機能は以下の通り
プロジェクトについての詳細情報を保持します。
ProjectDefinition() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のコンストラクタ
プロジェクトについての詳細情報を作成します。
ProjectGetInfo - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo.
WBS情報取得クラス
機能は以下の通り
WBS情報を取得します。
ProjectGetInfo(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のコンストラクタ
WBS情報を作成します。
ProjectGetInfoController - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController.
WBSの詳細コントローラクラス
機能は以下の通り
WBSの詳細を取得します。
ProjectGetInfoController() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のコンストラクタ
ProjectGetInfoControllerのコンストラクタを生成します。
ProjectGetInfoController(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のコンストラクタ
ProjectGetInfoControllerのコンストラクタを生成します。
PropertiesFile - class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile.
プロパティファイルクラス
機能は以下の通り
ファイル名を指定してプロパティファイルを呼び出します。
PropertiesFile(String) - class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile のコンストラクタ
ファイル名を指定してプロパティファイルを取得します。
Property - interface jp.co.intra_mart.foundation.datastore.common.config.Property.
プロパティを定義します。
PropertyConfigModel - class jp.co.intra_mart.framework.system.property.PropertyConfigModel.
データモデルクラスです。
PropertyConfigModel() - class jp.co.intra_mart.framework.system.property.PropertyConfigModel のコンストラクタ

PropertyDescriptorBox - class jp.co.intra_mart.foundation.sap.common.util.PropertyDescriptorBox.
JavaBeansクラスから取得するPropertyDescriptorをキャッシュするためのクラスです。
PropertyHandler - interface jp.co.intra_mart.framework.system.property.PropertyHandler.
プロパティにアクセスするインタフェースです。
PropertyHandlerException - exception jp.co.intra_mart.framework.system.property.PropertyHandlerException.
プロパティハンドラの情報取得時の例外です。
PropertyHandlerException() - class jp.co.intra_mart.framework.system.property.PropertyHandlerException のコンストラクタ
詳細メッセージを指定しないで PropertyHandlerException を構築します。
PropertyHandlerException(String) - class jp.co.intra_mart.framework.system.property.PropertyHandlerException のコンストラクタ
指定された詳細メッセージを持つ PropertyHandlerException を構築します。
PropertyHandlerException(String, Throwable) - class jp.co.intra_mart.framework.system.property.PropertyHandlerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PropertyHandlerException を構築します。
PropertyHandlerParam - class jp.co.intra_mart.framework.system.property.PropertyHandlerParam.
プロパティハンドラを生成する時の初期パラメータです。
PropertyHandlerParam() - class jp.co.intra_mart.framework.system.property.PropertyHandlerParam のコンストラクタ
PropertyHandlerParamを新規に生成します。
PropertyManager - class jp.co.intra_mart.framework.system.property.PropertyManager.
システム設定の情報を管理します。
PropertyManager() - class jp.co.intra_mart.framework.system.property.PropertyManager のコンストラクタ
プロパティマネージャのコンストラクタです。
PropertyManagerException - exception jp.co.intra_mart.framework.system.property.PropertyManagerException.
プロパティマネージャの設定時の例外です。
PropertyManagerException() - class jp.co.intra_mart.framework.system.property.PropertyManagerException のコンストラクタ
詳細メッセージを指定しないで PropertyManagerException を構築します。
PropertyManagerException(String) - class jp.co.intra_mart.framework.system.property.PropertyManagerException のコンストラクタ
指定された詳細メッセージを持つ PropertyManagerException を構築します。
PropertyManagerException(String, Throwable) - class jp.co.intra_mart.framework.system.property.PropertyManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PropertyManagerException を構築します。
PropertyModel - class jp.co.intra_mart.framework.system.property.PropertyModel.
プロパティモデルクラスです。
PropertyModel() - class jp.co.intra_mart.framework.system.property.PropertyModel のコンストラクタ

PropertyParam - class jp.co.intra_mart.framework.system.property.PropertyParam.
プロパティのパラメータを表現する汎用的なクラスです。
PropertyParam() - class jp.co.intra_mart.framework.system.property.PropertyParam のコンストラクタ
PropertyParamを新規に生成します。
Provider - interface jp.co.intra_mart.framework.system.container.factory.Provider.
IMContainerのファクトリクラスです。
PrtData - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData.
品目マスタの生産資源/治工具 (PRT) 項目情報クラス
機能は以下の通り
品目マスタの生産資源/治工具 (PRT) 項目情報を保持します。
PrtData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のコンストラクタ
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。
PrtData(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のコンストラクタ
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。
PstngDateRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa.
登録日付の範囲情報クラス
機能は以下の通り
登録日付の範囲情報を保持します。
PstngDateRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のコンストラクタ
登録日付の範囲情報を作成します。
PstngDateRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のコンストラクタ
登録日付の範囲情報を作成します。
PublicGroup - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup.
パブリックグループの基本属性のデータを取り扱います。
PublicGroup() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のコンストラクタ
パブリックグループに関連する情報を新規に生成します。
PublicGroup(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のコンストラクタ
パブリックグループに関連する情報を新規に生成します。
PublicGroup(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のコンストラクタ
パブリックグループに関連する情報を新規に生成します。
PublicGroup(Locale, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のコンストラクタ
パブリックグループに関連する情報を新規に生成します。
PublicGroupAttach - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach.
パブリックグループ所属の基本属性のデータを取り扱います。
PublicGroupAttach() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のコンストラクタ
パブリックグループ所属に関連する情報を新規に生成します。
PublicGroupAttach(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のコンストラクタ
パブリックグループ所属に関連する情報を新規に生成します。
PublicGroupAttachBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel.
パブリックグループ所属の基本モデルです。
PublicGroupAttachMapper - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper.
パブリックグループ所属に関連するマッパです。
PublicGroupAttachTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable.
パブリックグループ所属の期間化属性のデータを取り扱います。
PublicGroupAttachTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable のコンストラクタ

PublicGroupAttachTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachTerminableModel.
パブリックグループ所属の期間化モデルです。
PublicGroupBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel.
パブリックグループの基本モデルです。
PublicGroupCategory - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory.
パブリックグループ分類の基本属性のデータを取り扱います。
PublicGroupCategory() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のコンストラクタ
パブリックグループ分類に関連する情報を新規に生成します。
PublicGroupCategory(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のコンストラクタ
パブリックグループ分類に関連する情報を新規に生成します。
PublicGroupCategoryBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel.
パブリックグループ分類の基本モデルです。
PublicGroupCategoryMapper - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper.
パブリックグループ分類に関連するマッパです。
PublicGroupCategoryTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable.
パブリックグループ分類の期間化属性のデータを取り扱います。
PublicGroupCategoryTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable のコンストラクタ

PublicGroupCategoryTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryTerminableModel.
パブリックグループ分類の期間化モデルです。
PublicGroupChangedControllerListener - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener.
パブリックグループが削除された場合にアクセスコントローラに紐付くパブリックグループを削除するリスナークラスです。
PublicGroupChangedControllerListener() - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のコンストラクタ

PublicGroupChangedListener - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener.
パブリックグループに関する情報の更新時のリスナーです。
PublicGroupChangedMenuListener - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener.
パブリックグループに関する情報の変更時のリスナーです。
PublicGroupChangedMenuListener() - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のコンストラクタ

PublicGroupExportManager - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager.
パブリックグループ情報のエクスポートを行います。
PublicGroupExportManager() - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager のコンストラクタ
コンストラクタ パブリックグループ情報エクスポートマネージャーのインスタンスを生成します。
PublicGroupExportManagerClient - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient.
パブリックグループ情報のエクスポートを行います。
PublicGroupExportManagerClient() - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient のコンストラクタ

PublicGroupImportManager - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager.
パブリックグループ情報のインポートを行います。
PublicGroupImportManager() - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager のコンストラクタ
コンストラクタ パブリックグループインポートマネージャーのインスタンスを生成します。
PublicGroupImportManagerClient - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient.
パブリックグループ情報のインポートを行います。
PublicGroupImportManagerClient() - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient のコンストラクタ

PublicGroupImporter - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter.
パブリックグループのインポートのインターフェースです
PublicGroupInclusionBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel.
パブリックグループ内包の基本モデルです。
PublicGroupInclusionMapper - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper.
パブリックグループ内包に関連するマッパです。
PublicGroupInfo - class jp.co.intra_mart.foundation.security.PublicGroupInfo.
パブリックグループ情報クラス。
PublicGroupInfo(String, String) - class jp.co.intra_mart.foundation.security.PublicGroupInfo のコンストラクタ
コンストラクタ。
PublicGroupManager - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager.
パブリックグループに関連する情報を管理します。
PublicGroupManager() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のコンストラクタ

PublicGroupMapper - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper.
パブリックグループに関連するマッパです。
PublicGroupSet - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet.
パブリックグループセットの基本属性のデータを取り扱います。
PublicGroupSet() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のコンストラクタ
パブリックグループセットに関連する情報を新規に生成します。
PublicGroupSet(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のコンストラクタ
パブリックグループセットに関連する情報を新規に生成します。
PublicGroupSet(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のコンストラクタ
パブリックグループセットに関連する情報を新規に生成します。
PublicGroupSet(Locale, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のコンストラクタ
パブリックグループセットに関連する情報を新規に生成します。
PublicGroupSetBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel.
パブリックグループセットの基本モデルです。
PublicGroupSetMapper - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper.
パブリックグループセットに関連するマッパです。
PublicGroupSetTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable.
パブリックグループセットの期間化属性のデータを取り扱います。
PublicGroupSetTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable のコンストラクタ

PublicGroupSetTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational.
パブリックグループセットの期間国際化属性のデータを取り扱います。
PublicGroupSetTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のコンストラクタ

PublicGroupStruct - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct.
組織の階層です。
PublicGroupTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable.
パブリックグループの期間化属性のデータを取り扱います。
PublicGroupTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable のコンストラクタ

PublicGroupTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational.
パブリックグループの期間国際化属性のデータを取り扱います。
PublicGroupTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のコンストラクタ

PublicGroupTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel.
パブリックグループの期間国際化モデルです。
PublicGroupTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel.
パブリックグループの期間化モデルです。
PublicGroupVersion - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion.
パブリックグループ構成バージョンの基本属性のデータを取り扱います。
PublicGroupVersion() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のコンストラクタ

PublicGroupVersionBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel.
パブリックグループ構成バージョンの基本モデルです。
PublicGroupVersionMapper - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper.
パブリックグループ構成バージョンに関連するマッパです。
PurchaseAccount - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount.
購買発注伝票勘定情報クラス
機能は以下の通り
購買発注伝票勘定情報を保持します。
PurchaseAccount() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のコンストラクタ
購買発注伝票明細を作成します。
PurchaseAccount(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のコンストラクタ
購買発注伝票明細を作成します。
PurchaseGetItemSrel - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel.
伝票承認対象一覧情報クラス
機能は以下の通り
伝票承認対象一覧を取得します。
PurchaseGetItemSrel(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のコンストラクタ
コンストラクタ生成
PurchaseGetItemSrel(String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のコンストラクタ
承認対象一覧を作成します。
PurchaseGetItemSrelController - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController.
伝票の承認対象一覧取得コントローラクラス
機能は以下の通り
伝票の承認対象一覧を取得します。
PurchaseGetItemSrelController() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のコンストラクタ
コンストラクタ生成
PurchaseGetItemSrelController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のコンストラクタ
コンストラクタ生成
PurchaseGetItemSrelController(String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のコンストラクタ
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrelController(String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のコンストラクタ
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseHeader - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader.
購買発注ヘッダ情報スーパークラス
機能は以下の通り
購買発注のヘッダ情報を保持します。
PurchaseHeader() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のコンストラクタ
購買発注伝票ヘッダを作成します。
PurchaseHeaderPost - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost.
購買発注伝票ヘッダ情報クラス
機能は以下の通り
購買発注伝票ヘッダの情報を保持します。
PurchaseHeaderPost() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のコンストラクタ
購買発注伝票ヘッダを作成します。
PurchaseHeaders - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders.
伝票の承認対象一覧ヘッダ情報クラス
機能は以下の通り
伝票の承認対象一覧ヘッダの情報を保持します。
PurchaseHeaders() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のコンストラクタ
伝票の承認対象一覧ヘッダを作成します。
PurchaseItem - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem.
購買発注明細情報スーパークラス
機能は以下の通り
購買発注の明細情報を保持します。
PurchaseItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のコンストラクタ
購買発注伝票明細を作成します。
PurchaseItemPost - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost.
購買発注伝票明細情報クラス
機能は以下の通り
購買発注伝票明細情報を保持します。
PurchaseItemPost() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のコンストラクタ
購買発注伝票明細を作成します。
PurchaseItemPost(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のコンストラクタ
購買発注伝票明細を作成します。
PurchaseItems - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems.
伝票の承認対象明細情報クラス
機能は以下の通り
伝票の承認対象明細情報を保持します。
PurchaseItems() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のコンストラクタ
伝票の承認対象明細を作成します。
PurchaseOrderPayPost - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost.
伝票登録クラス
機能は以下の通り
伝票を登録します。
PurchaseOrderPayPost() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のコンストラクタ
コンストラクタ。
PurchaseOrderPayPost(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のコンストラクタ
コネクションマネージャーを引数に持つコンストラクタ。
PurchaseOrderPayPost(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のコンストラクタ
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
PurchaseOrderPayPostController - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController.
伝票登録コントローラクラス
機能は以下の通り
伝票を登録します。
PurchaseOrderPayPostController() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController のコンストラクタ
PurchaseOrderPayPostControllerのコンストラクタを生成します。
PurchaseOrderPayPostController(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController のコンストラクタ
PurchaseOrderPayPostControllerのコンストラクタを生成します。
PurchaseOrderPayPostController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController のコンストラクタ
PurchaseOrderPayPostControllerのコンストラクタを生成します。
PurchaseOrderPostChangeController - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController.
伝票登録変更コントローラクラス
機能は以下の通り
伝票を変更します。
PurchaseOrderPostChangeController() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController のコンストラクタ
PurchaseOrderPostChangeControllerのコンストラクタを生成します。
PurchaseOrderPostChangeController(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController のコンストラクタ
PurchaseOrderPostChangeControllerのコンストラクタを生成します。
PurchaseOrderPostChangeController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController のコンストラクタ
PurchaseOrderPostChangeControllerのコンストラクタを生成します。
PurchaseRelease - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease.
承認情報スーパークラス
機能は以下の通り
承認情報を保持します。
PurchaseRelease() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のコンストラクタ
伝票承認を作成します。
PurchaseRelease(String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のコンストラクタ
コンストラクタ生成。
PurchaseRelease(String, String, String, ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のコンストラクタ
コンストラクタ生成。
PurchaseRelease(String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のコンストラクタ
コンストラクタ生成。
PurchaseReleaseController - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController.
伝票承認コントローラクラス
機能は以下の通り
伝票を承認します。
PurchaseReleaseController(String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController のコンストラクタ
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
PurchaseReleaseController(String, String, String, ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController のコンストラクタ
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
PurchaseReleaseController(String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController のコンストラクタ
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
PurchaseResetReleaseController - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController.
伝票承認取消コントローラクラス
機能は以下の通り
伝票の承認取消します。
PurchaseResetReleaseController(String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController のコンストラクタ
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。
PurchaseResetReleaseController(String, String, String, ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController のコンストラクタ
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。
PurchaseResetReleaseController(String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController のコンストラクタ
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。
PurchaseSchedule - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule.
購買発注伝票納入日程情報クラス
機能は以下の通り
購買発注伝票納入日程情報を保持します。
PurchaseSchedule() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のコンストラクタ
購買発注伝票納入日程を作成します。
PurchaseSchedule(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のコンストラクタ
購買発注伝票納入日程を作成します。
PurchaseText - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText.
購買発注伝票テキストクラス
機能は以下の通り
購買発注伝テキストを保持します。
PurchaseText() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のコンストラクタ
購買発注伝票テキストを作成します。
PurchaseText(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のコンストラクタ
購買発注伝票テキストを作成します。
parameters - class jp.co.intra_mart.framework.system.util.Config の変数
パラメータの集合
parseHeaders(String) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload のメソッド
CommonsFileuploadのFileuploadBaseにヘッダ情報のキーをtoLowerCaseしないヘッダ情報 を追加したメソッドです。
parseInt(String, int) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
2 番目の引数に指定された基数を元にして、 指定されたキーによって示されるプロパティ値を 符号付き整数として解析します。
parseLong(String, int) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
2 番目の引数に指定された基数を元にして、 指定されたキーによって示されるプロパティ値を 符号付き長整数として解析します。
parseRequest(RequestContext) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload のメソッド
CommonsFileuploadのFileuploadBase#parRequestのヘッダをパースするインスタンスを IMMultipartStreamに変更したメソッドです。
parseRequest(LoginRequestInfo, HttpServletRequest) - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer のメソッド
リクエストパラメータの解析。
parseRequest(LoginRequestInfo, HttpServletRequest) - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer のメソッド
リクエストパラメータの解析。
parseRequest(LoginRequestInfo, HttpServletRequest) - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
リクエストパラメータの解析。
paths(int) - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のメソッド
この抽象パス名が示すディレクトリにあるファイルおよびディレクトリの 抽象パスを繰り返し処理する反復子を作成します。
paths(int) - class jp.co.intra_mart.foundation.utility.file.Directory のメソッド
推奨されていません。 この抽象パス名が示すディレクトリにあるファイルおよびディレクトリの 抽象パスを繰り返し処理する反復子を作成します。
postAddMenuLoginGroup(String, String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
アクセスを許可するログイングループを追加する直後にコールされます。
postAdded(String, CompanyPost) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
役職情報がデータストアに登録された後に呼び出されます。
postAdded(String, CompanyPost) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
役職情報がデータストアに登録された後に呼び出されます。
postAdded(String, CompanyPost) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
役職情報がデータストアに登録された後に呼び出されます。
postCreate(String, AccessController) - interface jp.co.intra_mart.foundation.security.access.AccessControllerPostWriterListener のメソッド
アクセスコントローラ情報をデータストアに作成した直後にコールされます。
postCreate(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener のメソッド
システム管理者情報をデータストアに作成した直後にコールされます。
postCreate(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener のメソッド
バッチ情報をデータストアに作成した直後にコールされます。
postCreate(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener のメソッド
グループ管理者情報をデータストアに作成した直後にコールされます。
postCreate(MenuItem) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
メニュー情報をデータストアに作成した直後にコールされます。
postCreate(String, MenuItem) - interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener のメソッド
メニュー情報をデータストアに作成した直後にコールされます。
postCreateAccount(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウント情報をデータストアに作成した直後にコールされます。
postCreateAccount(String, Account) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

postCreateAccountRole(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウントロール情報をデータストアに作成した直後にコールされます。
postCreateAccountRole(String, String, AccountRole) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

postCreateCalendarInfo(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener のメソッド
カレンダーデータをデータストアに作成した直後にコールされます。
postCreateFavoriteMenu(String, String, FavoriteMenu) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
マイメニュー情報をデータストアに作成した直後にコールされます。
postCreateFavoriteMenu(String, String, FavoriteMenu) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

postCreateLoginGroup(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
ログイングループ情報をデータストアに作成した直後にコールされます。
postCreateLoginGroup(LoginGroup) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
ログイングループ情報をデータストアに作成した直後にコールされます。
postCreateMainPagePattern(String, MainPagePatternInfo) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
メインページパターン情報をデータストアに作成した直後にコールされます。
postCreateMainPagePattern(String, MainPagePatternInfo) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
メインページパターン情報をデータストアに作成した直後にコールされます。
postCreateRole(String, Role) - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener のメソッド
ロール情報をデータストアに作成した直後にコールされます。
postCreateSubRole(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener のメソッド
ロールにサブロールを追加した直後にコールされます。
postCreateSubRole(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener のメソッド
ロールにサブロールを追加する直前にコールされます。
postDelete(String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerPostWriterListener のメソッド
アクセスコントローラ情報をデータストアから削除した直後にコールされます。
postDelete(String, String) - interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener のメソッド
バッチ情報をデータストアから削除した直後にコールされます。
postDelete(String) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener のメソッド
グループ管理者情報をデータストアから削除した直後にコールされます。
postDelete(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
メニュー情報をデータストアから削除した直後にコールされます。
postDelete(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener のメソッド
メニュー情報をデータストアから削除した直後にコールされます。
postDeleteAccount(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウント情報をデータストアから削除した直後にコールされます。
postDeleteAccount(String, String) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

postDeleteAccountRole(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウントロール情報をデータストアから削除した直後にコールされます。
postDeleteAccountRole(String, String, String) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

postDeleteCalendarInfo(String, String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener のメソッド
カレンダーデータをデータストアから削除した直後にコールされます。
postDeleteFavoriteMenu(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
マイメニュー情報をデータストアから削除した直後にコールされます。
postDeleteFavoriteMenu(String, String, String) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

postDeleteLoginGroup(String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
ログイングループ情報をデータストアから削除した直後にコールされます。
postDeleteLoginGroup(String) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
ログイングループ情報をデータストアから削除した直後にコールされます。
postDeleteMainPagePattern(String, String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
メインページパターン情報をデータストアから削除した直後にコールされます。
postDeleteMainPagePattern(String, String) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
メインページパターン情報をデータストアから削除した直後にコールされます。
postDeleteMenuLoginGroup(String, String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
アクセスを許可するログイングループを削除する直後にコールされます。
postDeleteRole(String, String) - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener のメソッド
ロール情報をデータストアから削除した直後にコールされます。
postDeleteSubRole(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener のメソッド
ロールからサブロールを削除した直後にコールされます。
postDeleteSubRole(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener のメソッド
ロールからサブロールを削除する直前にコールされます。
postDeleted(String, CompanyPost) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
役職情報がデータストアから削除された後に呼び出されます。
postDeleted(String, CompanyPost) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
役職情報がデータストアから削除された後に呼び出されます。
postDeleted(String, CompanyPost) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
役職情報がデータストアから削除された後に呼び出されます。
postMove(String, String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
メニューの親子関係を更新した直後にコールされます。
postMove(String, String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener のメソッド
メニューの親子関係を更新した直後にコールされます。
postSetAccessControlEnabled(String, boolean) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
アクセス権限を設定する直前にコールされます。
postUpdate(String, AccessController) - interface jp.co.intra_mart.foundation.security.access.AccessControllerPostWriterListener のメソッド
アクセスコントローラ情報をデータストアに更新した直後にコールされます。
postUpdate(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener のメソッド
システム管理者情報をデータストアに更新した直後にコールされます。
postUpdate(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener のメソッド
バッチ情報をデータストアに更新した直後にコールされます。
postUpdate(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener のメソッド
グループ管理者情報をデータストアに更新した直後にコールされます。
postUpdate(MenuItem) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
メニュー情報をデータストアに更新した直後にコールされます。
postUpdate(String, MenuItem) - interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener のメソッド
メニュー情報をデータストアに更新した直後にコールされます。
postUpdateAccount(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウント情報をデータストアに更新した直後にコールされます。
postUpdateAccount(String, Account) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

postUpdateAccountRole(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウントロール情報をデータストアに更新した直後にコールされます。
postUpdateAccountRole(String, String, AccountRole) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

postUpdateCalendarInfo(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener のメソッド
カレンダーデータをデータストアに更新した直後にコールされます。
postUpdateFavoriteMenu(String, String, FavoriteMenu) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
マイメニュー情報をデータストアに更新した直後にコールされます。
postUpdateFavoriteMenu(String, String, FavoriteMenu) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

postUpdateLoginGroup(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
ログイングループ情報をデータストアに更新した直後にコールされます。
postUpdateLoginGroup(LoginGroup) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
ログイングループ情報をデータストアに更新した直後にコールされます。
postUpdateMainPagePattern(String, MainPagePatternInfo) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
メインページパターン情報をデータストアに更新した直後にコールされます。
postUpdateMainPagePattern(String, MainPagePatternInfo) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
メインページパターン情報をデータストアに更新した直後にコールされます。
postUpdateRole(String, Role) - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener のメソッド
ロール情報をデータストアに更新した直後にコールされます。
postUpdated(String, CompanyPost) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
役職情報がデータストアに更新された後に呼び出されます。
postUpdated(String, CompanyPost) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
役職情報がデータストアに更新された後に呼び出されます。
postUpdated(String, CompanyPost) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
役職情報がデータストアに更新された後に呼び出されます。
prepareCall(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースのストアドプロシージャを呼び出すための CallableStatement オブジェクトを生成します。
prepareCall(String, int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定されたタイプと並行処理で ResultSet オブジェクトを生成する CallableStatement オブジェクトを生成します。
prepareCall(String, int, int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された型と並行処理で ResultSet オブジェクトを生成する CallableStatement オブジェクトを生成します。
prepareMimeMessage(MimeMessage) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
MIMEメッセージに対して操作を行います。
prepareSession(Session) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
SMTPセッションに対して操作を行います。
prepareStatement(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 パラメータ付き SQL 文をデータベースに送るための PreparedStatement オブジェクトを作成します。
prepareStatement(String, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 自動生成キーを取得する機能を持つデフォルトの PreparedStatement オブジェクトを生成します。
prepareStatement(String, int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定されたタイプと並行処理で ResultSet オブジェクトを生成する PreparedStatementオブジェクトを生成します。
prepareStatement(String, int, int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された型、並行処理、および保持機能で ResultSet オブジェクトを生成する PreparedStatement オブジェクトを生成します。
prepareStatement(String, int[]) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された配列によって指定された自動生成キーを返す機能を持つデフォルトの PreparedStatement オブジェクトを生成します。
prepareStatement(String, String[]) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された配列によって指定された自動生成キーを返す機能を持つデフォルトの PreparedStatement オブジェクトを生成します。
printAttribute(String, String) - class jp.co.intra_mart.framework.base.web.tag.TagWriter のメソッド
属性を出力します。
printAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性の内容を表示します。
printAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性の内容を表示します。
printAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes のメソッド
属性の内容を表示します。
printAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes のメソッド
属性の内容を表示します。
printMessage(Throwable) - interface jp.co.intra_mart.common.aid.jdk.java.lang.ThrowablePrintListener のメソッド
例外のメッセージを出力します。
printOnClick() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onClickを出力します。
printOnDblClick() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onDblClickを出力します。
printOnKeyDown() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyDownを出力します。
printOnKeyPress() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyPressを出力します。
printOnKeyUp() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyUpを出力します。
printOnMouseDown() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseDownを出力します。
printOnMouseMove() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseMoveを出力します。
printOnMouseOut() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseOutを出力します。
printOnMouseOver() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseOverを出力します。
printOnMouseUp() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseUpを出力します。
printStackTrace(Throwable) - interface jp.co.intra_mart.common.aid.jdk.java.lang.ThrowablePrintListener のメソッド
例外のスタックトレースを出力します。
printStackTrace() - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のメソッド

printStackTrace(PrintStream) - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のメソッド

printStackTrace(PrintWriter) - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のメソッド

printStackTrace() - class jp.co.intra_mart.framework.system.exception.FrameworkException のメソッド

printStackTrace(PrintStream) - class jp.co.intra_mart.framework.system.exception.FrameworkException のメソッド

printStackTrace(PrintWriter) - class jp.co.intra_mart.framework.system.exception.FrameworkException のメソッド

printURL(String) - class jp.co.intra_mart.framework.base.web.tag.TagWriter のメソッド
URLを出力します。
privateGroupAdded(String, PrivateGroup) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
プライベートグループがデータストアに登録された後に呼び出されます。
privateGroupDeleted(String, PrivateGroup) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
プライベートグループがデータストアから削除された後に呼び出されます。
privateGroupUpdated(String, PrivateGroup) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
プライベートグループがデータストアに更新された後に呼び出されます。
propertyNames() - interface jp.co.intra_mart.foundation.service.provider.Environment のメソッド
システムプロパティリストにあるすべてのキーのリストを返します。
provider - class jp.co.intra_mart.framework.base.data.container.factory.DataContainerFactory の static 変数

provider - class jp.co.intra_mart.framework.base.event.container.factory.EventContainerFactory の static 変数

provider - class jp.co.intra_mart.framework.base.service.container.factory.ServiceContainerFactory の変数

publicGroupAdded(String, PublicGroup) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループがデータストアに登録された後に呼び出されます。
publicGroupAdded(String, PublicGroup) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
パブリックグループがデータストアに登録された後に呼び出されます。
publicGroupAdded(String, PublicGroup) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループがデータストアに登録された後に呼び出されます。
publicGroupDeleted(String, PublicGroup) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループがデータストアから削除された後に呼び出されます。
publicGroupDeleted(String, PublicGroup) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
パブリックグループがデータストアから削除された後に呼び出されます。
publicGroupDeleted(String, PublicGroup) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループがデータストアから削除された後に呼び出されます。
publicGroupJoined(String, String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
publicGroupJoined(String, String, String, String, String) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
publicGroupJoined(String, String, String, String, String) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
publicGroupLeft(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
publicGroupLeft(String, String, String, String) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
publicGroupLeft(String, String, String, String) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
publicGroupMoved(String, String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
publicGroupMoved(String, String, String, String, String) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
publicGroupMoved(String, String, String, String, String) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
publicGroupUpdated(String, PublicGroup) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループがデータストアに更新された後に呼び出されます。
publicGroupUpdated(String, PublicGroup) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
パブリックグループがデータストアに更新された後に呼び出されます。
publicGroupUpdated(String, PublicGroup) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループがデータストアに更新された後に呼び出されます。
put(Object, Object) - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
指定された値を、マップ内の指定されたキーに関連付けます 。
put(String, Object) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
データを保存します。
put(String, Object) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
データを保存します。
put(String, Object) - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
データを保存します。
put(String, Object) - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
データを保存します。
put(Object, Object) - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 指定された値を、マップ内の指定されたキーに関連付けます 。
putAll(Map) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
データを保存します。
putAll(Map) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
データを保存します。
putAll(Map) - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
データを保存します。
putAll(Map) - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
データを保存します。
putCompanyCategoryTerminable(Term, CompanyCategoryTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
指定された期間に対する期間化情報を設定します。
putCompanyPostTerminable(Term, CompanyPostTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
指定された期間に対する期間化情報を設定します。
putCompanyPostTerminableInternational(Locale, CompanyPostTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。
putCompanyTerminable(Term, CompanyTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
指定された期間に対する期間化情報を設定します。
putCompanyTerminableInternational(Locale, CompanyTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。
putDealTerminable(Term, DealTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
指定された期間に対する期間化情報を設定します。
putDepartmentAttachTerminable(Term, DepartmentAttachTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
指定された期間に対する期間化情報を設定します。
putDepartmentMainTerminable(Term, DepartmentMainTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
指定された期間に対する期間化情報を設定します。
putDepartmentTerminable(Term, DepartmentTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
指定された期間に対する期間化情報を設定します。
putDepartmentTerminableInternational(Locale, DepartmentTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。
putExtendedDepartment(String, Map) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
指定された拡張情報を追加します。
putExtendedDepartmentTerminable(String, Map) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
指定された拡張情報を追加します。
putExtendedDepartmentTerminableInternational(String, Map) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
指定された拡張情報を追加します。
putExtendedUser(String, Map) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
指定された拡張情報を追加します。
putExtendedUserTerminable(String, Map) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
指定された拡張情報を追加します。
putExtendedUserTerminableInternational(String, Map) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
指定された拡張情報を追加します。
putImage(OutputStream) - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
指定のストリームにファイルを出力します。
putImportParam(String, String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="import")を生成し､一覧に格納します｡
putInternational(Locale, CateogryClassInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
指定された言語に対する国際化情報を設定します。
putInternational(Locale, CategoryDetailInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
指定された言語に対する国際化情報を設定します。
putInternational(Locale, ItemAttributeInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
指定された言語に対する国際化情報を設定します。
putInternational(Locale, ItemCategoryInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
指定された言語に対する国際化情報を設定します。
putInternational(Locale, ItemTemplateDetailInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
指定された言語に対する国際化情報を設定します。
putItemTerminable(Term, ItemTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
指定された期間に対する期間化情報を設定します。
putItemTerminableInternational(Locale, ItemTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。
putPublicGroupAttachTerminable(Term, PublicGroupAttachTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
指定された期間に対する期間化情報を設定します。
putPublicGroupCategoryTerminable(Term, PublicGroupCategoryTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
指定された期間に対する期間化情報を設定します。
putPublicGroupSetTerminable(Term, PublicGroupSetTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
指定された期間に対する期間化情報を設定します。
putPublicGroupSetTerminableInternational(Locale, PublicGroupSetTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。
putPublicGroupTerminable(Term, PublicGroupTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
指定された期間に対する期間化情報を設定します。
putPublicGroupTerminableInternational(Locale, PublicGroupTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。
putResource(String, ResourceParam[]) - class jp.co.intra_mart.framework.base.data.DBConnector のメソッド
接続先のリソースを追加します。
putResource(String, ResourceParam[]) - class jp.co.intra_mart.framework.base.data.DataSourceConnector のメソッド
接続先のリソースを追加します。
putResource(String, ResourceParam[]) - class jp.co.intra_mart.framework.base.data.JDBCConnector のメソッド
推奨されていません。 接続先のリソースを追加します。
putStructParam(String, String, String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="structure",パラメタ名=第３引数)を生成し､一覧に格納します｡
putTableParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="table",パラメタ名=第３引数,レコード番号=第４引数)を生成し､ 一覧に格納します｡
putUserTerminable(Term, UserTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
指定された期間に対する期間化情報を設定します。
putUserTerminableInternational(Locale, UserTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。

Q

QuotationCreateFromData2 - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2.
見積伝票登録情報クラス
機能は以下の通り
見積伝票登録情報を保持します。
QuotationCreateFromData2() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のコンストラクタ
コンストラクタ。
QuotationCreateFromData2(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のコンストラクタ
コネクションマネージャーを引数に持つコンストラクタ。
QuotationCreateFromData2(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のコンストラクタ
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
QuotationCreateFromData2Controller - class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller.
見積伝票登録情報コントローラクラス
機能は以下の通り
見積伝票登録情報を保持します。
QuotationCreateFromData2Controller() - class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller のコンストラクタ
QuotationCreateFromData2Controllerのコンストラクタを生成します。
QuotationCreateFromData2Controller(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller のコンストラクタ
QuotationCreateFromData2Controllerのコンストラクタを生成します。
QuotationCreateFromData2Controller(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller のコンストラクタ
QuotationCreateFromData2Controllerのコンストラクタを生成します。
queryAddMenuLoginGroup(String, String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
アクセスを許可するログイングループを追加する直前にコールされます。
queryCreate(String, AccessController) - interface jp.co.intra_mart.foundation.security.access.AccessControllerQueryWriterListener のメソッド
アクセスコントローラ情報をデータストアに作成する直前にコールされます。
queryCreate(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener のメソッド
システム管理者情報をデータストアに作成する直前にコールされます。
queryCreate(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener のメソッド
バッチ情報をデータストアに作成する直前にコールされます。
queryCreate(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener のメソッド
グループ管理者情報をデータストアに作成する直前にコールされます。
queryCreate(MenuItem) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
メニュー情報をデータストアに作成する直前にコールされます。
queryCreate(String, MenuItem) - interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener のメソッド
メニュー情報をデータストアに作成する直前にコールされます。
queryCreateAccount(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウント情報をデータストアに作成する直前にコールされます。
queryCreateAccount(String, Account) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

queryCreateAccountRole(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウントロール情報をデータストアに作成した直後にコールされます。
queryCreateAccountRole(String, String, AccountRole) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

queryCreateCalendarInfo(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener のメソッド
カレンダーデータをデータストアに作成する直前にコールされます。
queryCreateFavoriteMenu(String, String, FavoriteMenu) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
マイメニュー情報をデータストアに作成する直前にコールされます。
queryCreateFavoriteMenu(String, String, FavoriteMenu) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

queryCreateLoginGroup(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
ログイングループ情報をデータストアに作成する直前にコールされます。
queryCreateMainPagePattern(String, MainPagePatternInfo) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
メインページパターン情報をデータストアに作成する前にコールされます。
queryCreateRole(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener のメソッド
ロール情報をデータストアに作成する直前にコールされます。
queryDelete(String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerQueryWriterListener のメソッド
アクセスコントローラ情報をデータストアから削除する直前にコールされます。
queryDelete(String, String) - interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener のメソッド
バッチ情報をデータストアから削除する直前にコールされます。
queryDelete(String) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener のメソッド
グループ管理者情報をデータストアから削除する直前にコールされます。
queryDelete(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
メニュー情報をデータストアから削除する直前にコールされます。
queryDelete(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener のメソッド
メニュー情報をデータストアから削除する直前にコールされます。
queryDeleteAccount(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウント情報をデータストアから削除する直前にコールされます。
queryDeleteAccount(String, String) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

queryDeleteAccountRole(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウントロール情報をデータストアから削除する直前にコールされます。
queryDeleteAccountRole(String, String, String) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

queryDeleteCalendarInfo(String, String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener のメソッド
カレンダーデータをデータストアから削除する直前にコールされます。
queryDeleteFavoriteMenu(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
マイメニュー情報をデータストアから削除する直前にコールされます。
queryDeleteFavoriteMenu(String, String, String) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

queryDeleteLoginGroup(String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
ログイングループ情報をデータストアから削除する直前にコールされます。
queryDeleteMainPagePattern(String, String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
メインページパターン情報をデータストアから削除する前にコールされます。
queryDeleteMenuLoginGroup(String, String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
アクセスを許可するログイングループを削除する直前にコールされます。
queryDeleteRole(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener のメソッド
ロール情報をデータストアから削除する直前にコールされます。
queryMove(String, String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
メニューの親子関係を更新する直前にコールされます。
queryMove(String, String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener のメソッド
メニューの親子関係を更新する直前にコールされます。
querySetAccessControlEnabled(String, boolean) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
アクセス権限を設定する直前にコールされます。
queryUpdate(String, AccessController) - interface jp.co.intra_mart.foundation.security.access.AccessControllerQueryWriterListener のメソッド
アクセスコントローラ情報をデータストアに更新する直前にコールされます。
queryUpdate(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener のメソッド
システム管理者情報をデータストアに更新する直前にコールされます。
queryUpdate(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener のメソッド
バッチ情報をデータストアに更新する直前にコールされます。
queryUpdate(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener のメソッド
グループ管理者情報をデータストアに更新する直前にコールされます。
queryUpdate(MenuItem) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
メニュー情報をデータストアに更新する直前にコールされます。
queryUpdate(String, MenuItem) - interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener のメソッド
メニュー情報をデータストアに更新する直前にコールされます。
queryUpdateAccount(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウント情報をデータストアに更新する直前にコールされます。
queryUpdateAccount(String, Account) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

queryUpdateAccountRole(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウントロール情報をデータストアに更新する直前にコールされます。
queryUpdateAccountRole(String, String, AccountRole) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

queryUpdateCalendarInfo(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener のメソッド
カレンダーデータをデータストアに更新する直前にコールされます。
queryUpdateFavoriteMenu(String, String, FavoriteMenu) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
マイメニュー情報をデータストアに更新する直前にコールされます。
queryUpdateFavoriteMenu(String, String, FavoriteMenu) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

queryUpdateLoginGroup(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
ログイングループ情報をデータストアに更新する直前にコールされます。
queryUpdateMainPagePattern(String, MainPagePatternInfo) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
メインページパターン情報をデータストアに更新する前にコールされます。
queryUpdateRole(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener のメソッド
ロール情報をデータストアに更新する直前にコールされます。
queue() - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のメソッド
モニターを取得するための待ち行列に入っているスレッドの数です。
queue() - class jp.co.intra_mart.foundation.utility.LockMonitor のメソッド
推奨されていません。 モニターを取得するための待ち行列に入っているスレッドの数です。

R

RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel の static 変数
最終更新日
RECORD_USER_CD - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel の static 変数
最終更新者
RECORD_USER_CD - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel の static 変数
最終更新者
RECORD_USER_CD - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel の static 変数
最終更新者
REMOVE - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

REMOVE_ENTIRETY - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

REMOVE_ITEM - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

REQUEST_HEADER_NAME_IM_AJAX_REQUEST - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static 変数
ImAjaxからの通信だということを判定可能にするためのリクエスト・ヘッダ名。
REQUEST_HEADER_NAME_IM_AJAX_USER_AGENT - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static 変数
ブラウザの種類を判定可能にするためのリクエスト・ヘッダ名。
REQUEST_INFO_ATTRIBUTE - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler の static 変数
リクエスト情報の属性地
REQUEST_PARAM_NAME_4_EASYLOGIN_ACCESS_KEY - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil の static 変数
かんたんログインのアクセスキー用リクエストパラメータ名。
REQUEST_SEPARATOR - class jp.co.intra_mart.framework.base.service.ServiceServlet の static 変数
リクエストの情報を分割するセパレータ
RESPONSE_HEADER_NAME_IM_AJAX_ERROR_CODE - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static 変数
ImAjaxへエラーコードを通知するためのレスポンス・ヘッダ名。
RESPONSE_HEADER_NAME_IM_AJAX_ERROR_MESSAGE - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static 変数
ImAjaxへエラーメッセージを通知するためのレスポンス・ヘッダ名。
RESPONSE_HEADER_NAME_NEXT_PAGE_TITLE - interface jp.co.intra_mart.foundation.log.LogConstraint の static 変数
遷移先画面タイトルをレスポンスヘッダに登録するためのレスポンスヘッダ名。
ROLE - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
ロール
ROLE_ID - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel の static 変数
ロールID
ROLE_ID - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel の static 変数
ロールCD
ROLE_ID - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel の static 変数
メニューID
ROLE_ID - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel の static 変数
ロールCD
ROLE_ID - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel の static 変数
ロールID
ROLE_ID - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel の static 変数
ロールID
ROLE_INCLUSION - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
ロール内包
ROLE_SUMMARY - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
ロールサマリ
ROOT_FOLDER - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

RP_CLIENT_TYPE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
クライアントタイプのデフォルトＵＲＬ引数名。
RP_ENCODING - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインエンコーディングのデフォルトＵＲＬ引数名。
RP_INITIAL_URL - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
初期ＵＲＬのデフォルトＵＲＬ引数名。
RP_LOCALE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインロケールのデフォルトＵＲＬ引数名。
RP_LOGIN_GROUP - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログイングループIDのデフォルトＵＲＬ引数名。
RP_LOGIN_TYPE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインタイプのデフォルトＵＲＬ引数名。
RP_PASSWORD - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
パスワードのデフォルトＵＲＬ引数名。
RP_SHORTCUT - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ショートカットＵＲＬパラメータのデフォルト値
RP_URL - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ダイレクトＵＲＬのデフォルトＵＲＬ引数名。
RP_URL_SIGN - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ダイレクトＵＲＬ署名のデフォルトＵＲＬ引数名。
RP_USER - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインユーザＩＤのデフォルトＵＲＬ引数名。
RSSParserIF - interface jp.co.intra_mart.foundation.portal.common.rss.RSSParserIF.
RSS解析用の共通インタフェース
RSSポートレットで、取得したRSSデータを処理するためのパーサーです。
RUN_DAY - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
実行日
RUN_DAY_WEEK - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
実行曜日
RUN_HOUR - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
実行時
RUN_MINUTE - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
実行分
RUN_MONTH - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
実行月
RUN_SECOND - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
実行秒
RUN_YEAR - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
実行年
RadarChartDrawer - class jp.co.intra_mart.foundation.graph.RadarChartDrawer.
レーダーチャートを描画します。
RadarChartDrawer(int, int, int) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のコンストラクタ
ｙ軸の目盛値をint表現でレーダーチャートを作成します。
RadarChartDrawer(double, double, double) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のコンストラクタ
ｙ軸の目盛値をdouble表現でレーダーチャートを作成します。
RadarChartObject - class jp.co.intra_mart.foundation.graph.RadarChartObject.
RadarChartDrawerクラスのデータを保存するオブジェクトです。
RadarChartObject() - class jp.co.intra_mart.foundation.graph.RadarChartObject のコンストラクタ
デフォルトのデータオブジェクトを作成します。
RadarChartObject(Color) - class jp.co.intra_mart.foundation.graph.RadarChartObject のコンストラクタ
グラフ線の色を指定して、データオブジェクトを作成します。
RadarChartObject(boolean) - class jp.co.intra_mart.foundation.graph.RadarChartObject のコンストラクタ
塗りつぶしの可否を指定して、データオブジェクトを作成します。
RadarChartObject(Color, boolean) - class jp.co.intra_mart.foundation.graph.RadarChartObject のコンストラクタ
グラフの色と塗りつぶしの可否を指定して、データオブジェクトを作成します。
RefDocRange - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange.
前伝票の範囲情報クラス
機能は以下の通り
前伝票の範囲情報を保持します。
RefDocRange() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のコンストラクタ
前伝票の範囲情報を作成します。
ReferenceController - class jp.co.intra_mart.foundation.sap.module.ReferenceController.
参照系モジュール共通コントローラ親クラス。
ReferenceController() - class jp.co.intra_mart.foundation.sap.module.ReferenceController のコンストラクタ
コンストラクタ。
ReferenceController(SapClient) - class jp.co.intra_mart.foundation.sap.module.ReferenceController のコンストラクタ
コンストラクタ。
Relationship - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship.
リレーションシップを定義します。
ReplaceWriter - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter.
このクラスは、部分文字列を別な部分文字列へ置換しながら ストリームに文字列を書き込むためのストリームフィルタを実装します。
ReplaceWriter(Writer, char[]) - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のコンストラクタ
文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer, String) - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のコンストラクタ
文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer, char[], char[]) - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のコンストラクタ
文字列置換のためのストリームフィルタを作成します。
ReplaceWriter(Writer, String, String) - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のコンストラクタ
文字列置換のためのストリームフィルタを作成します。
ReplaceWriter - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter クラスを使用してください。
ReplaceWriter(Writer, char[]) - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のコンストラクタ
推奨されていません。 文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer, String) - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のコンストラクタ
推奨されていません。 文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer, char[], char[]) - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のコンストラクタ
推奨されていません。 文字列置換のためのストリームフィルタを作成します。
ReplaceWriter(Writer, String, String) - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のコンストラクタ
推奨されていません。 文字列置換のためのストリームフィルタを作成します。
ReportFileConditioner - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner.
このクラスは、ReportFileWriter の初期化チェックのインターフェースです。
ReportFileConditioner - interface jp.co.intra_mart.foundation.utility.report.ReportFileConditioner.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner クラスを使用してください。
ReportFileWriter - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter.
メッセージをファイルに出力するストリームクラスです。
ReportFileWriter(File) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のコンストラクタ
ファイルへメッセージを書き出すためのライターオブジェクトを作成します。
ReportFileWriter - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter クラスを使用してください。
ReportFileWriter(File) - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のコンストラクタ
推奨されていません。 ファイルへメッセージを書き出すためのライターオブジェクトを作成します。
ReportLevel - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel.
メッセージレベルのインターフェースです。
ReportLevel - interface jp.co.intra_mart.foundation.utility.report.ReportLevel.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel クラスを使用してください。
ReportLevelFilter - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter.
メッセージの出力制御を行うためのフィルタークラスです。
ReportLevelFilter(MessageReporter, int) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter のコンストラクタ
指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。
ReportLevelFilter - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter クラスを使用してください。
ReportLevelFilter(MessageReporter, int) - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter のコンストラクタ
推奨されていません。 指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。
RepresentativeReporter - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter.
メッセージ出力をイベント処理するためのフィルタークラスです。
RepresentativeReporter(MessageReporter, EventQueueController) - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter のコンストラクタ
指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。
RepresentativeReporter - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter クラスを使用してください。
RepresentativeReporter(MessageReporter, EventQueueController) - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter のコンストラクタ
推奨されていません。 指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。
RequestAnalyzer - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer.
リクエストアナライザインタフェース。
RequestCharacterEncodingFilter - class jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter.
リクエストに対するエンコードは SessionInfo.getEncoding()が 返す値をになります。
RequestCharacterEncodingFilter() - class jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter のコンストラクタ

RequestEntityTooLargeException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException.
処理可能量より大きいリクエストを受け付けたことを通知するための例外です。
RequestEntityTooLargeException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException のコンストラクタ
指定のメッセージを持つ例外を作成します。
RequestEntityTooLargeException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
RequestEntityTooLargeException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException のコンストラクタ
例外を作成します。
RequestException - exception jp.co.intra_mart.framework.base.service.RequestException.
リクエストの内容に関連する間違いがある場合の例外です。
RequestException() - class jp.co.intra_mart.framework.base.service.RequestException のコンストラクタ
詳細メッセージを指定しないで RequestException を構築します。
RequestException(String) - class jp.co.intra_mart.framework.base.service.RequestException のコンストラクタ
指定された詳細メッセージを持つ RequestException を構築します。
RequestException(String, Throwable) - class jp.co.intra_mart.framework.base.service.RequestException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestException を構築します。
RequestFormatException - exception jp.co.intra_mart.framework.base.service.controller.RequestFormatException.
フォーマットが不正であるときの例外です。
RequestFormatException() - class jp.co.intra_mart.framework.base.service.controller.RequestFormatException のコンストラクタ
詳細メッセージを指定しないで RequestFormatException を構築します。
RequestFormatException(String) - class jp.co.intra_mart.framework.base.service.controller.RequestFormatException のコンストラクタ
指定された詳細メッセージを持つ RequestFormatException を構築します。
RequestFormatException(String, Throwable) - class jp.co.intra_mart.framework.base.service.controller.RequestFormatException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestFormatException を構築します。
RequestInfo - interface jp.co.intra_mart.framework.base.service.RequestInfo.
リクエストに対する情報を取得します。
RequestMessageBodyFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter.
リクエストをラップするフィルタです。
RequestMessageBodyFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter のコンストラクタ
フィルタを作成します。
RequestParameter - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter.
１つのリクエストパラメータを保持するオブジェクトの共通インターフェース。
ResourceBundleProperties - class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties.
このクラスは、java.util.Properties クラスのインターフェースを実装した、 プロパティ管理クラスです。
ResourceBundleProperties(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties のコンストラクタ
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String, Locale) - class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties のコンストラクタ
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String, Locale, ClassLoader) - class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties のコンストラクタ
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties - class jp.co.intra_mart.foundation.utility.ResourceBundleProperties.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties クラスを使用してください。
ResourceBundleProperties(String) - class jp.co.intra_mart.foundation.utility.ResourceBundleProperties のコンストラクタ
推奨されていません。 リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String, Locale) - class jp.co.intra_mart.foundation.utility.ResourceBundleProperties のコンストラクタ
推奨されていません。 リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String, Locale, ClassLoader) - class jp.co.intra_mart.foundation.utility.ResourceBundleProperties のコンストラクタ
推奨されていません。 リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceFormatException - exception jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException.
リソースの内容が不適切であることを通知する例外です。
ResourceFormatException(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceFormatException(String, Throwable) - class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
ResourceFormatException - exception jp.co.intra_mart.foundation.utility.charset.ResourceFormatException.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException クラスを使用してください。
ResourceFormatException(String) - class jp.co.intra_mart.foundation.utility.charset.ResourceFormatException のコンストラクタ
推奨されていません。 指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceFormatException(String, Throwable) - class jp.co.intra_mart.foundation.utility.charset.ResourceFormatException のコンストラクタ
推奨されていません。 指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
ResourceLoader - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader.
このクラスは、ローカルファイルシステムからリソースファイルを検索するクラスローダーの拡張実装です。
ResourceLoader() - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のコンストラクタ
このクラスをロードした ClassLoader を親クラスローダとして使用し、 新しいクラスローダを作成します。
ResourceLoader(ClassLoader) - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のコンストラクタ
指定された親クラスローダを使って、 委譲のために新しいクラスローダを作成します。
ResourceModel - class jp.co.intra_mart.framework.base.data.ResourceModel.
Resource情報を管理するクラスです。
ResourceModel() - class jp.co.intra_mart.framework.base.data.ResourceModel のコンストラクタ

ResourceNotFoundException - exception jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException.
リソースがないことを通知する例外です。
ResourceNotFoundException(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceNotFoundException(String, Throwable) - class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
ResourceNotFoundException - exception jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException クラスを使用してください。
ResourceNotFoundException(String) - class jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException のコンストラクタ
推奨されていません。 指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceNotFoundException(String, Throwable) - class jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException のコンストラクタ
推奨されていません。 指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
ResourceParam - class jp.co.intra_mart.framework.base.data.ResourceParam.
データコネクタの初期パラメータです。
ResourceParam() - class jp.co.intra_mart.framework.base.data.ResourceParam のコンストラクタ
ResourceParamを新規に生成します。
ResponseCharacterEncodingFilter - class jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter.
レスポンスの文字エンコーディングを自動解決するフィルタです。
ResponseCharacterEncodingFilter() - class jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter のコンストラクタ
新しくフィルタを作成します。
ResponseContentTypeManagementFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter.
レスポンスの Content-Type を自動解決するフィルタです。
ResponseContentTypeManagementFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter のコンストラクタ
新しくフィルタを作成します。
ResultPageItem - class jp.co.intra_mart.foundation.navigator.ResultPageItem.
結果ページクラス
ResultPageItem() - class jp.co.intra_mart.foundation.navigator.ResultPageItem のコンストラクタ

ResultPageItemInfo - class jp.co.intra_mart.foundation.navigator.ResultPageItemInfo.
結果ページ情報
ResultPageItemInfo() - class jp.co.intra_mart.foundation.navigator.ResultPageItemInfo のコンストラクタ

ReturnMessages - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages.
リターンパラメータ BAPIRET2 の代替構造情報クラス
機能は以下の通り
リターンパラメータ BAPIRET2 の代替構造情報を保持します。
ReturnMessages() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のコンストラクタ
リターンパラメータ BAPIRET2 の代替構造情報を作成します。
ReturnMessages(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のコンストラクタ
リターンパラメータ BAPIRET2 の代替構造情報を作成します。
ReverseComparator - class jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator.
コンパレータのフィルタとして機能します。
ReverseComparator(Comparator) - class jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator のコンストラクタ
指定されたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
ReverseComparator - class jp.co.intra_mart.foundation.utility.ReverseComparator.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator クラスを使用してください。
ReverseComparator(Comparator) - class jp.co.intra_mart.foundation.utility.ReverseComparator のコンストラクタ
推奨されていません。 指定されたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
Role - class jp.co.intra_mart.foundation.security.role.Role.
ロール・モデルインタフェース。
Role() - class jp.co.intra_mart.foundation.security.role.Role のコンストラクタ
コンストラクタ。
Role(String) - class jp.co.intra_mart.foundation.security.role.Role のコンストラクタ
コンストラクタ。
Role(String, String) - class jp.co.intra_mart.foundation.security.role.Role のコンストラクタ
コンストラクタ。
RoleAccessor - interface jp.co.intra_mart.foundation.security.role.RoleAccessor.
ロールアクセッサインタフェース。
RoleBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel.
ロールの基本モデルです。
RoleChangedAccountListener - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener.
ロールが削除された場合にアカウントに紐付くロールを削除するリスナークラス。
RoleChangedAccountListener() - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のコンストラクタ
コンストラクタ。
RoleChangedControllerListener - class jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener.
ロールが削除された場合にアクセスコントローラに紐付くロールを削除するリスナークラスです。
RoleChangedControllerListener() - class jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener のコンストラクタ
コンストラクタ。
RoleChangedListener - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener.
ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
RoleChangedMenuListener - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener.
ロールが削除された場合にメニューに紐付くロールを削除するリスナークラス。
RoleChangedMenuListener() - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のコンストラクタ
コンストラクタ。
RoleExporter - interface jp.co.intra_mart.foundation.security.role.RoleExporter.
ロールエクスポートインタフェースです。
RoleImporter - interface jp.co.intra_mart.foundation.security.role.RoleImporter.
ロールインポートインタフェースです。
RoleInclusionBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel.
ロール内包の基本モデルです。
RoleInclusionMapper - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper.
ロール内包に関連するマッパです。
RoleInternationalModel - interface jp.co.intra_mart.system.security.datastore.inf.RoleInternationalModel.
ロールの国際化モデルです。
RoleManager - class jp.co.intra_mart.foundation.acssecurity.RoleManager.
推奨されていません。
RoleManager(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のコンストラクタ
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManagerに置き換えられました。
RoleManager - class jp.co.intra_mart.foundation.security.role.RoleManager.
ロールマネージャクラス。
RoleManager(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のコンストラクタ
コンストラクタ。
RoleMapper - interface jp.co.intra_mart.system.security.datastore.inf.RoleMapper.
ロールに関連するマッパです。
RolePostWriterListener - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener.
ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
RoleQueryWriterListener - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener.
ロール情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
RoleReaderDecorator - interface jp.co.intra_mart.foundation.security.role.RoleReaderDecorator.
ロール情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
RoleSummaryBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel.
ロールサマリの基本モデルです。
RoleSummaryMapper - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper.
ロールサマリに関連するマッパです。
RssPortlet - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet.
ページ種別「RSS」に対するポートレットのモデルです。
RssPortlet() - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet のコンストラクタ
コンストラクタ
reGenerateNonce(String, String) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil の static メソッド
かんたんログイン用のNonceを新たに生成し、アカウント属性情報として保存します。
read() - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream のメソッド
デコードデータのバイトを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream のメソッド
入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
read() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
データ取得。
read(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
データ取得。
read() - class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream のメソッド
デコードデータのバイトを読み込みます。
read() - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader のメソッド
単一の文字を読み込みます。
read(char[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader のメソッド
配列の一部に文字を読み込みます。
read() - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream のメソッド
デコードデータのバイトを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream のメソッド
入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
read() - class jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream のメソッド
デコードデータのバイトを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream のメソッド
入力ストリームからバイト配列へ最大 len バイトのデータを読み込みます。
read() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
基礎入力から１バイト読み込みます。
read(byte[]) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
基礎入力から指定のバイト配列にデータを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
基礎入力から指定のバイト配列にデータを読み込みます。
read() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ファイルの内容を取得します。
read() - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream のメソッド
推奨されていません。 デコードデータのバイトを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream のメソッド
推奨されていません。 入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
read() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 データ取得。
read(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 データ取得。
read() - class jp.co.intra_mart.foundation.utility.io.HexInputStream のメソッド
推奨されていません。 デコードデータのバイトを読み込みます。
read() - class jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream のメソッド
推奨されていません。 デコードデータのバイトを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream のメソッド
推奨されていません。 入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
read() - class jp.co.intra_mart.foundation.utility.io.XORInputStream のメソッド
推奨されていません。 デコードデータのバイトを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.XORInputStream のメソッド
推奨されていません。 入力ストリームからバイト配列へ最大 len バイトのデータを読み込みます。
readBoolean() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
boolean 型データ取得。
readBoolean() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 boolean 型データ取得。
readHeaders() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMMultipartStream のメソッド
リクエストエンコーディングへのエンコーディング変換を行わずにヘッダ部を読み込みます。
readInt() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
int 型データ取得。
readInt() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 int 型データ取得。
readLines() - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
ファイルの行を繰り返し処理する反復子を作成します。
readLines(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
ファイルの行を繰り返し処理する反復子を作成します。
readLines() - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 ファイルの行を繰り返し処理する反復子を作成します。
readLines(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 ファイルの行を繰り返し処理する反復子を作成します。
readLong() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
long 型データ取得。
readLong() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 long 型データ取得。
readObject() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
Object の取得。
readObject() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 Object の取得。
readString() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
文字列の取得。
readString() - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
readString(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
readString() - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
readString(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
readString() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 文字列の取得。
readXML(InputStream) - class jp.co.intra_mart.extension.maskat.util.XMLUtil の static メソッド
ストリームからXMLを読み込み、ドキュメントを生成します。
reconstruction() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
現在使用中の Writer をリセットします。
reconstruction() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 現在使用中の Writer をリセットします。
recordList - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser の変数
に対応するクラスのインスタンス格納用リスト
registEventFlow(EventNavigatorManager, EventFlow) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
registEventFlow(EventFlow) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
registEventFlow(EventNavigatorManager, EventFlow) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
イベントフローを更新します。
register(S2Container, Class, String, InstanceDef) - class jp.co.intra_mart.framework.extension.seasar.util.ComponentUtil の static メソッド
指定したキーでS2Containerにコンポーネントを登録します。
registerAccountLicense(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
ライセンス登録します。
registerApplicationLicenseToAccount(String, String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
アプリケーションライセンスをアカウントに登録します。
release() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection のメソッド
ソケットおよび入出力ストリームの利用を中止します。
release() - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のメソッド
モニターの開放。
release() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースコネクションを解放します。
release() - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
JCOコネクションの開放を行います。
release() - class jp.co.intra_mart.foundation.utility.LockMonitor のメソッド
推奨されていません。 モニターの開放。
release() - class jp.co.intra_mart.foundation.utility.net.SocketConnection のメソッド
推奨されていません。 ソケットおよび入出力ストリームの利用を中止します。
release() - class jp.co.intra_mart.framework.base.data.DBConnector のメソッド
データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.DataAccessController のメソッド
すべてのデータストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.DataConnector のメソッド
データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.DataSourceConnector のメソッド
データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.IntramartDBConnector のメソッド
推奨されていません。 データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector のメソッド
データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.JDBCConnector のメソッド
推奨されていません。 データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector のメソッド
データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.SystemDBConnector のメソッド
データストアの資源を解放します。
releaseConnection() - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
JCOコネクションの開放をを行う為の抽象メソッドです。
releaseConnection() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing のメソッド
取得したJCOコネクションの開放を行います。
releaseConnection() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
JCOコネクションの開放を行います。
releaseConnection() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing のメソッド
取得したJCOコネクションの開放を行います。
releaseConnection(JCO.Client) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector の static メソッド
推奨されていません。 コネクションをリリースします。
releaseCurrentThread() - class jp.co.intra_mart.foundation.service.client.information.Lock の static メソッド
現在のスレッドに紐付いたロックを全て解除します。
releaseRequestScope() - class jp.co.intra_mart.foundation.service.client.information.Lock の static メソッド
推奨されていません。 このメソッドは、RequestScopeLockReleaseFilter 専用です。
releaseSavepoint(Savepoint) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 現在のトランザクションから指定された Savepoint オブジェクトを削除します。
remove(int) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リスト内の指定された位置から要素を削除します。
remove(Object) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
指定された要素のインスタンスがこのコレクションにあれば、そのインスタンスをコレクションから 1 つ削除します。
remove(Object) - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
このキーにマッピングがある場合に、そのマッピングをマップから削除します。
remove(String, String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースにデータを削除するメソッド

データベースのデータを削除(デリート)する。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap のメソッド
拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap のメソッド
拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap のメソッド
拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap のメソッド
拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を削除します。
remove(Locale) - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap のメソッド
指定された言語に該当するデータを削除します。
remove(Term) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap のメソッド
指定された期間に該当するデータを削除します。
remove(Locale) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap のメソッド
指定された言語に該当するデータを削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap のメソッド
拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。
remove(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap のメソッド
拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。
remove(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap のメソッド
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。
remove(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap のメソッド
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。
remove(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap のメソッド
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap のメソッド
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap のメソッド
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap のメソッド
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。
remove(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
指定された言語に該当するデータを削除します。
remove(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
指定された言語に該当するデータを削除します。
remove(Term) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
指定された期間に該当するデータを削除します。
remove(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap のメソッド
指定された言語に該当するデータを削除します。
remove(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap のメソッド
指定された言語に該当するデータを削除します。
remove(Term) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap のメソッド
指定された期間に該当するデータを削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
指定された位置のデータを削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
指定された位置の値を削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
指定された位置のデータを削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
指定された位置のデータを削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
指定された位置の値を削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
指定された位置のデータを削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
指定された位置のデータを削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
指定された位置の値を削除します。
remove(int) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リスト内の指定された位置から要素を削除します。
remove(Object) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 指定された要素のインスタンスがこのコレクションにあれば、そのインスタンスをコレクションから 1 つ削除します。
remove() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルまたはディレクトリを削除します。
remove(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
データを削除します。
remove(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
データを削除します。
remove(String) - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
データを削除します。
remove(String) - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
データを削除します。
remove(String) - class jp.co.intra_mart.foundation.update.UpdateManager のメソッド
更新管理キーを削除します。
remove(Object) - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 このキーにマッピングがある場合に、そのマッピングをマップから削除します。
removeActiveSessionInfo(String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたセッションIDのアクティブなセッション情報を削除します。
removeActiveSessionInfo(String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたセッションIDのアクティブなセッション情報を削除します。
removeActiveSessionInfo(String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたセッションIDのアクティブなセッション情報を削除します。
removeAll(Collection) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
このコレクションから、指定されたコレクションに含まれる要素をすべて削除します。
removeAll(Collection) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 このコレクションから、指定されたコレクションに含まれる要素をすべて削除します。
removeAll() - class jp.co.intra_mart.foundation.update.UpdateManager のメソッド
すべての更新管理キーを削除します。
removeArgument(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
引数を削除します。
removeAttribute(ItemAttribute) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
指定された商品属性情報を削除します。
removeAttribute(String) - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
セッションから指定された属性を削除します。
removeAttribute(String) - class jp.co.intra_mart.framework.base.session.HttpSessionObject のメソッド
推奨されていません。 指定された名前に対応するオブジェクトを削除します。
removeAttribute(String) - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のメソッド
推奨されていません。 指定された名前に対応するオブジェクトを削除します。
removeAttribute(String) - interface jp.co.intra_mart.framework.base.session.SessionObject のメソッド
指定された名前に対応するオブジェクトを削除します。
removeCategoryDetail(CompanyCategory) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織に対して指定された分類区分情報を削除します。
removeCategoryDetail(PublicGroupCategory) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループに対して指定された分類区分情報を削除します。
removeChildNode(TreeNode) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
指定されたノード　node をこのノードの子から削除します。
removeChildNodes() - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
子ノードを全て削除します。
removeCompanyCategoryTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
指定された期間に対する期間化情報を削除します。
removeCompanyPostTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
指定された期間に対する期間化情報を削除します。
removeCompanyTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
指定された期間に対する期間化情報を削除します。
removeComparator(Comparator) - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator のメソッド
指定されたコンパレータ comparatorを削除します。
removeComparator(Comparator) - class jp.co.intra_mart.foundation.utility.MultiComparator のメソッド
推奨されていません。 指定されたコンパレータ comparatorを削除します。
removeConditioner(ReportFileConditioner) - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のメソッド
ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。
removeConditioner(GCConditioner) - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
推奨されていません。
removeConditioner(ReportFileConditioner) - class jp.co.intra_mart.foundation.utility.report.FileReporter のメソッド
推奨されていません。 ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。
removeDealTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
指定された期間に対する期間化情報を削除します。
removeDepartmentAttachTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
指定された期間に対する期間化情報を削除します。
removeDepartmentMainTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
指定された期間に対する期間化情報を削除します。
removeDepartmentTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
指定された期間に対する期間化情報を削除します。
removeDetail(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable のメソッド
商品コードに一致する取扱詳細を削除します。
removeDisplayName(Locale) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
ロケールに対応した表示名を削除します。
removeDisplayName(Locale) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
ロケールに対応したメニュー名を削除します。
removeDisplayName(Locale) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロケールに対応したロール表示名を削除します。
removeFilterParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このフィルタのパラメータを削除します。
removeInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
指定された言語に対する国際化情報を削除します。
removeInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
指定された言語に対する国際化情報を削除します。
removeInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
指定された言語に対する国際化情報を削除します。
removeInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
指定された言語に対する国際化情報を削除します。
removeInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
指定された言語に対する国際化情報を削除します。
removeItem(ItemAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のメソッド
商品カテゴリから商品を外します。
removeItemTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
指定された期間に対する期間化情報を削除します。
removeListener(ShutdownListener) - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の static メソッド
シャットダウンリスナーを削除します。
removeListener(EventListener) - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
指定されたリスナーを削除します。
removeMain(DepartmentMain) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
指定されたユーザの主所属を削除します。
removeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
メッセージの出力先を削除します。
removeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
メッセージの出力先を削除します。
removeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の static メソッド
メッセージの出力先を削除します。
removeParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
指定のキーのマップを削除します。
removeParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
指定のキーのマップを削除します。
removeParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
指定のキーのマップを削除します。
removePermissionFromDepartment(DealerDepartment) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager のメソッド
組織からアクセス権を削除します。
removePermissionFromPublicGroup(DealerPublicGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager のメソッド
パブリックグループからアクセス権を削除します。
removePermissionFromRole(DealerRole) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager のメソッド
ロールからアクセス権を削除します。
removePublicGroupAttachTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
指定された期間に対する期間化情報を削除します。
removePublicGroupCategoryTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
指定された期間に対する期間化情報を削除します。
removePublicGroupSetTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
指定された期間に対する期間化情報を削除します。
removePublicGroupTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
指定された期間に対する期間化情報を削除します。
removeReporter(MessageReporter) - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。
removeReporter(MessageReporter) - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。
removeSaveEventResultItemInfo(EventNavigatorManager, String, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。
removeSaveEventResultItemInfo(String, String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。
removeSaveEventResultItemInfo(EventNavigatorManager, String, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。
removeTitleInfo(Locale) - class jp.co.intra_mart.foundation.navigator.NavigatorItem のメソッド

removeUrlParam(String) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のメソッド
ＵＲＬ引数(Map)を削除します。
removeUserTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
指定された期間に対する期間化情報を削除します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter のメソッド
メッセージを出力します。
report(Object) - class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter のメソッド
data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のメソッド
メッセージを出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter のメソッド
基礎出力ストリームに対してメッセージを出力します。
report(Object) - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter のメソッド
基礎出力ストリームに対してメッセージを出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter のメソッド
メッセージを出力します。
report(Object) - class jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter のメソッド
基礎出力ストリームに対してメッセージを出力します。
report(String) - interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter のメソッド
メッセージを出力します。
report(Object) - interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter のメソッド
data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
メッセージを出力します。
report(Object) - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter のメソッド
メッセージを出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter のメソッド
メッセージを出力します。
report(String, int) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter のメソッド
指定のメッセージレベルが基準値以上のメッセージを出力します。
report(Object) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter のメソッド
data をメッセージとして出力します。
report(Object, int) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter のメソッド
指定のメッセージレベルが基準値以上のメッセージを出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter のメソッド
メッセージを出力します。
report(Object) - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter のメソッド
data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter のメソッド
推奨されていません。 メッセージを出力します。
report(Object) - class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter のメソッド
推奨されていません。 data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.FileReporter のメソッド
推奨されていません。 メッセージを出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter のメソッド
推奨されていません。 基礎出力ストリームに対してメッセージを出力します。
report(Object) - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter のメソッド
推奨されていません。 基礎出力ストリームに対してメッセージを出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.LineReportFilter のメソッド
推奨されていません。 メッセージを出力します。
report(Object) - class jp.co.intra_mart.foundation.utility.report.LineReportFilter のメソッド
推奨されていません。 基礎出力ストリームに対してメッセージを出力します。
report(String) - interface jp.co.intra_mart.foundation.utility.report.MessageReporter のメソッド
推奨されていません。 メッセージを出力します。
report(Object) - interface jp.co.intra_mart.foundation.utility.report.MessageReporter のメソッド
推奨されていません。 data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 メッセージを出力します。
report(Object) - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter のメソッド
推奨されていません。 メッセージを出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter のメソッド
推奨されていません。 メッセージを出力します。
report(String, int) - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter のメソッド
推奨されていません。 指定のメッセージレベルが基準値以上のメッセージを出力します。
report(Object) - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter のメソッド
推奨されていません。 data をメッセージとして出力します。
report(Object, int) - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter のメソッド
推奨されていません。 指定のメッセージレベルが基準値以上のメッセージを出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter のメソッド
推奨されていません。 メッセージを出力します。
report(Object) - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter のメソッド
推奨されていません。 data をメッセージとして出力します。
reportError(ErrorEvent) - interface jp.co.intra_mart.foundation.utility.ErrorEventListener のメソッド
推奨されていません。 発生した例外を通知します。
reset() - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
キャッシュ領域をクリアします。
reset(Writer) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
文字の出力ストリームをリセットします。
reset() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
このストリームの位置を、 入力ストリームで最後に mark メソッドが呼び出されたときのマーク位置に 再設定します。
reset() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。
reset(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。
reset(HttpServletRequest, ExtendedHttpServletResponse) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。
reset(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。
reset() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このメソッドは、スーパークラスの ServletResponseWrapper.reset() メソッドをそのまま呼び出します。
reset() - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 キャッシュ領域をクリアします。
reset(Writer) - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 文字の出力ストリームをリセットします。
resetBuffer() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。
resetBuffer(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。
resetBuffer(HttpServletRequest, ExtendedHttpServletResponse) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。
resetBuffer(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。
resetLock() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
アカウントロックをリセットします。
resources - class jp.co.intra_mart.framework.base.data.DBConnector の変数
リソース一覧
resources - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector の変数
リソース一覧
restart() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
スケジューラの再開通知。
resume(Transaction) - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager のメソッド
ラップしたTransactionManagerのresumeを呼び出します。
retainAll(Collection) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
このコレクションにおいて、指定されたコレクションに格納されている要素だけを保持します。
retainAll(Collection) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 このコレクションにおいて、指定されたコレクションに格納されている要素だけを保持します。
roleAdded(String, Role) - class jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener のメソッド
ロール情報をデータストアに作成した直後にコールされます。
roleAdded(String, Role) - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のメソッド
ロール情報をデータストアに作成した直後にコールされます。
roleAdded(String, Role) - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のメソッド
ロール情報をデータストアに作成した直後にコールされます。
roleAdded(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener のメソッド
ロール情報をデータストアに作成した直後にコールされます。
roleDeleted(String, String) - class jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener のメソッド
ロール情報をデータストアから削除した直後にコールされます。
roleDeleted(String, String) - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のメソッド
ロール情報をデータストアから削除した直後にコールされます。
roleDeleted(String, String) - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のメソッド
ロール情報をデータストアから削除した直後にコールされます。
roleDeleted(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener のメソッド
ロール情報をデータストアから削除した直後にコールされます。
roleUpdated(String, Role) - class jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener のメソッド
ロール情報をデータストアに更新した直後にコールされます。
roleUpdated(String, Role) - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のメソッド
ロール情報をデータストアに更新した直後にコールされます。
roleUpdated(String, Role) - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のメソッド
ロール情報をデータストアに更新した直後にコールされます。
roleUpdated(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener のメソッド
ロール情報をデータストアに更新した直後にコールされます。
rollback() - interface jp.co.intra_mart.foundation.database.DatabaseAccessor のメソッド
データベースのトランザクションをロールバックします。
rollback() - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
データベースのトランザクションをロールバックします。
rollback() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースアクセスの取り消し処理をする

トランザクションを終了(rollback)させる。
rollback(Savepoint) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された Savepoint オブジェクトが設定されたあとに行われたすべての変更を元に戻します。
rollback() - class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager のメソッド
ＢＡＰＩ実行結果のROLLBACK処理を行います｡

実行後にコネクションが開放されます。
rollback() - class jp.co.intra_mart.framework.base.data.DBConnector のメソッド
ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.DataAccessController のメソッド
すべてのデータコネクタをロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.DataConnector のメソッド
ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.DataSourceConnector のメソッド
ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.IntramartDBConnector のメソッド
推奨されていません。 ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector のメソッド
ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.JDBCConnector のメソッド
推奨されていません。 ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector のメソッド
ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.SystemDBConnector のメソッド
ロールバックします。
rollback() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager のメソッド
ラップしたTransactionManagerのrollbackを呼び出します。
rollback() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction のメソッド
ラップしたUserTransactionのrollbackを呼び出します。
run() - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のメソッド
このオブジェクトのスレッド実行ロジックです。
run() - class jp.co.intra_mart.foundation.utility.ExtendedThread のメソッド
推奨されていません。 このオブジェクトのスレッド実行ロジックです。

S

S2DataAccessController - class jp.co.intra_mart.framework.extension.seasar.data.S2DataAccessController.
S2DataAccessControllerはSeasar2　と連携しdaoを生成します。
S2DataAccessController(DataPropertyHandler) - class jp.co.intra_mart.framework.extension.seasar.data.S2DataAccessController のコンストラクタ
データアクセスコントローラを生成します。
S2DataContainer - class jp.co.intra_mart.framework.extension.seasar.data.S2DataContainer.
S2DataContainer　は　Seasar2　と連携するためのDataContainer実装です。
S2DataContainer() - class jp.co.intra_mart.framework.extension.seasar.data.S2DataContainer のコンストラクタ
S2DataContainerを生成します。
S2EventContainer - class jp.co.intra_mart.framework.extension.seasar.event.S2EventContainer.
S2EventContainer　は　Seasar2　と連携しオブジェクトを生成します。
S2EventContainer() - class jp.co.intra_mart.framework.extension.seasar.event.S2EventContainer のコンストラクタ

S2EventListenerFactory - class jp.co.intra_mart.framework.extension.seasar.event.S2EventListenerFactory.
S2EventListenerFactoryはEventListener生成時にS2Containerから取得します。
S2EventListenerFactory() - class jp.co.intra_mart.framework.extension.seasar.event.S2EventListenerFactory のコンストラクタ
S2EventListenerFactoryを新規に生成します。
S2ServiceContainer - class jp.co.intra_mart.framework.extension.seasar.service.S2ServiceContainer.
S2ServiceContainer　は　Seasar2　と連携しオブジェクトを生成します。
S2ServiceContainer() - class jp.co.intra_mart.framework.extension.seasar.service.S2ServiceContainer のコンストラクタ
S2ServiceContainerを生成します。
SALES_UNIT_PRICE - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel の static 変数
販売単価
SAPAccountingAppException - exception jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException.
p 会計系APIアプリケーション例外クラス
SAPAccountingAppException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException のコンストラクタ
会計系APIアプリケーション例外
SAPAccountingAppException(String) - class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException のコンストラクタ
会計系APIアプリケーション例外
SAPAccountingSystemException - exception jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException.
会計系APIシステム例外クラス
SAPAccountingSystemException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException のコンストラクタ
会計系APIシステム例外
SAPAuthAppException - exception jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException.
認証系APIアプリケーション例外クラス
SAPAuthAppException(String, Throwable) - class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException のコンストラクタ
認証系APIアプリケーション例外
SAPAuthAppException(String) - class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException のコンストラクタ
認証系APIアプリケーション例外
SAPAuthSystemException - exception jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException.
認証系APIシステム例外クラス
SAPAuthSystemException(String) - class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException のコンストラクタ
認証系APIシステム例外
SAPAuthSystemException(String, Throwable) - class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException のコンストラクタ
認証系APIシステム例外
SAPBapiReturnErrMessageExistException - exception jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException.
BAPI実行結果例外クラス
SAPBapiReturnErrMessageExistException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException のコンストラクタ
BAPI実行結果例外
SAPBapiReturnErrMessageExistException(String) - class jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException のコンストラクタ
BAPI実行結果例外
SAPConnectorMessageBundle - class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle.
SAPリアルタイム連携APIメッセージリソースクラス
SAPException - exception jp.co.intra_mart.foundation.sap.common.exception.SAPException.
SAP連携モジュールの基本となる例外クラス。
SAPException() - class jp.co.intra_mart.foundation.sap.common.exception.SAPException のコンストラクタ
SAP連携モジュール基本例外
SAPException(String) - class jp.co.intra_mart.foundation.sap.common.exception.SAPException のコンストラクタ
SAP連携モジュール基本例外
SAPException(String, Throwable) - class jp.co.intra_mart.foundation.sap.common.exception.SAPException のコンストラクタ
SAP連携モジュール基本例外
SAPException(Throwable) - class jp.co.intra_mart.foundation.sap.common.exception.SAPException のコンストラクタ
SAP連携モジュール基本例外
SAPFinancialAppException - exception jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException.
会計系APIアプリケーション例外クラス
SAPFinancialAppException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException のコンストラクタ
会計系APIアプリケーション例外
SAPFinancialAppException(String) - class jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException のコンストラクタ
会計系APIアプリケーション例外
SAPFinancialSystemException - exception jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialSystemException.
会計系APIシステム例外クラス
SAPFinancialSystemException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialSystemException のコンストラクタ
会計系APIシステム例外
SAPGeneralAppException - exception jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException.
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralAppException(String, Throwable) - class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException のコンストラクタ
共通API/汎用データ取得・追加・更新APIアプリケーション例外
SAPGeneralAppException(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException のコンストラクタ
共通API/汎用データ取得・追加・更新APIアプリケーション例外
SAPGeneralSystemException - exception jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException.
共通API/汎用データ取得・追加・更新APIシステム例外クラス
SAPGeneralSystemException(String, Throwable) - class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException のコンストラクタ
共通API/汎用データ取得・追加・更新APIシステム例外
SAPGeneralSystemException(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException のコンストラクタ
共通API/汎用データ取得・追加・更新APIシステム例外
SAPModuleAppException - exception jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException.
モジュール用データ取得・追加・更新APIアプリケーション例外クラス
SAPModuleAppException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException のコンストラクタ
モジュール用データ取得・追加・更新APIアプリケーション例外
SAPModuleAppException(String) - class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException のコンストラクタ
モジュール用データ取得・追加・更新APIアプリケーション例外
SAPModuleSystemException - exception jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException.
モジュール用データ取得・追加・更新APIシステム例外クラス
SAPModuleSystemException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException のコンストラクタ
モジュール用データ取得・追加・更新APIシステム例外
SAPModuleSystemException(String) - class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException のコンストラクタ
モジュール用データ取得・追加・更新APIシステム例外
SAPPurchaseAppException - exception jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException.
購買系APIアプリケーション例外クラス
SAPPurchaseAppException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException のコンストラクタ
購買系APIアプリケーション例外
SAPPurchaseAppException(String) - class jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException のコンストラクタ
購買系APIアプリケーション例外
SAPPurchaseSystemException - exception jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseSystemException.
購買系APIシステム例外クラス
SAPPurchaseSystemException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseSystemException のコンストラクタ
購買系APIシステム例外
SAPRuntimeException - exception jp.co.intra_mart.foundation.sap.common.exception.SAPRuntimeException.
SAP連携モジュールの基本となるランタイム例外クラス。
SAPRuntimeException() - class jp.co.intra_mart.foundation.sap.common.exception.SAPRuntimeException のコンストラクタ
SAP連携モジュール基本ランタイム例外
SAPRuntimeException(String) - class jp.co.intra_mart.foundation.sap.common.exception.SAPRuntimeException のコンストラクタ
SAP連携モジュール基本ランタイム例外
SAPRuntimeException(String, Throwable) - class jp.co.intra_mart.foundation.sap.common.exception.SAPRuntimeException のコンストラクタ
SAP連携モジュール基本ランタイム例外
SAPRuntimeException(Throwable) - class jp.co.intra_mart.foundation.sap.common.exception.SAPRuntimeException のコンストラクタ
SAP連携モジュール基本ランタイム例外
SAPSalesAppException - exception jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException.
販売管理系APIアプリケーション例外クラス
SAPSalesAppException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException のコンストラクタ
販売管理系APIアプリケーション例外
SAPSalesAppException(String) - class jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException のコンストラクタ
販売管理系APIアプリケーション例外
SAPSalesSystemException - exception jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesSystemException.
販売管理系APIシステム例外クラス
SAPSalesSystemException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesSystemException のコンストラクタ
販売管理系APIシステム例外
SAVE_TYPE_FAVORITE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
ナビゲート結果保存タイプ：お気に入り
SAVE_TYPE_HISTORY - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
ナビゲート結果保存タイプ：履歴
SCALE_POSITION_CENTER - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
ｘ軸、ｙ軸の目盛りの表示位置を「グラフの中心」に設定
SCALE_POSITION_SIDE - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
ｘ軸、ｙ軸の目盛りの表示位置を「グラフの枠」に設定
SERVICE_EXTENSION_KEY - class jp.co.intra_mart.framework.base.service.ServiceManager の static 変数
拡張子を指定するキー
SERVICE_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.base.service.ServiceManager の static 変数
サービスプロパティハンドラのキー
SERVICE_PROPERTY_HANDLER_KEY - interface jp.co.intra_mart.framework.base.service.container.ServiceContainer の static 変数
サービスプロパティハンドラのキー
SESSION_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.base.session.SessionManager の static 変数
セッションプロパティハンドラのキー
SESSION_TIMEOUT_HEADER_KEY - class jp.co.intra_mart.foundation.security.filter.SessionFilter の static 変数
セッションタイムアウトレスポンスヘッダーキー。
SET - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

SET_ENTIRETY - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

SET_ITEM - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

SKIP_LISTENER - interface jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener の static 変数
リスナー処理を中止し、メール送信を行います。
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ソートキー
SORT_NUMBER - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel の static 変数
ソート番号
SORT_NUMBER - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の static 変数
ソート番号
SP_CLIENT_TYPE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
クライアントタイプをセッションに保管するパラメータ名。
SP_COLOR_PATTERN_ID - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
カラーパターンIDをセッションに保管するパラメータ名。
SP_ENCODING - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインエンコーディングをセッションに保管するパラメータ名。
SP_INITIAL_URL - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
初期ページURLを属性に保管するパラメータ名。
SP_LOCALE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインロケールをセッションに保管するパラメータ名。
SP_LOGIN_GROUP - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログイングループIDをセッションに保管するパラメータ名。
SP_LOGIN_TIME - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインした時間をセッションに保管するパラメータ名。
SP_LOGIN_TYPE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインタイプをセッションに保管するパラメータ名。
SP_SHORTCUT - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ショートカットIDをセッションに保管するパラメータ名
SP_SIGNATURE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログイン署名をセッションに保管するパラメータ名。
SP_URL - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
認証後表示するメインページをセッションに保管するパラメータ名。
SP_URL_SIGN - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ダイレクトＵＲＬの署名をセッションに保管するパラメータ名。
SP_USER - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインユーザＩＤをセッションに保管するパラメータ名。
SQLSERVER - class jp.co.intra_mart.foundation.database.DbTypes の static 変数

SSORequestAnalyzer - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer.
SSOのログインリクエスト解析クラス。
SSORequestAnalyzer() - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer のコンストラクタ

SSO_LOGOUT_URL - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の static 変数

START_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
開始日
START_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
開始日
STOP_MAILSEND - interface jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener の static 変数
リスナー処理を中止し、メール送信を中止します。
STRING - class jp.co.intra_mart.foundation.datastore.common.config.AttributeType の static 変数
文字列型
STRING_VALUE - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel の static 変数
属性文字列
SUMMARY_ROLE_ID - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel の static 変数
サマリロールID
SYSTEM_ERROR_MESSAGE_NODE - class jp.co.intra_mart.extension.maskat.util.MKError の static 変数
systemErrorMessageのノード名
SalesData - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData.
販売データ情報クラス
機能は以下の通り
販売データ情報を保持します。
SalesData() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のコンストラクタ
販売データ情報を作成します。
SalesDataList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList.
販売データ情報クラス
機能は以下の通り
販売データ情報をテーブル型で保持します。
SalesDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList のコンストラクタ
販売データ情報を作成します。
SalesDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList のコンストラクタ
販売データ情報を作成します。
SalesOrderCreateFromDat2 - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2.
受注伝票登録情報クラス
機能は以下の通り
受注伝票登録情報を保持します。
SalesOrderCreateFromDat2() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のコンストラクタ
コンストラクタ。
SalesOrderCreateFromDat2(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のコンストラクタ
コネクションマネージャーを引数に持つコンストラクタ。
SalesOrderCreateFromDat2(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のコンストラクタ
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
SalesOrderCreateFromDat2Controller - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller.
受注伝票登録コントローラクラス
機能は以下の通り
受注伝票を登録します。
SalesOrderCreateFromDat2Controller() - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller のコンストラクタ
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。
SalesOrderCreateFromDat2Controller(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller のコンストラクタ
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。
SalesOrderCreateFromDat2Controller(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller のコンストラクタ
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。
SalesOrderGetList - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList.
販売伝票一覧照会情報クラス
機能は以下の通り
販売伝票一覧照会情報を保持します。
SalesOrderGetList(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のコンストラクタ
販売伝票一覧照会情報を作成します。
SalesOrderGetList(String, String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のコンストラクタ
販売伝票一覧照会情報を作成します。
SalesOrderGetListController - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController.
販売伝票一覧照会コントローラクラス
機能は以下の通り
販売伝票一覧の情報を取得します。
SalesOrderGetListController() - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController のコンストラクタ
コンストラクタ生成
SalesOrderGetListController(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController のコンストラクタ
コンストラクタ生成
SalesOrderGetListController(String, String, String, String, String) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController のコンストラクタ
コンストラクタ生成
SalesOrderGetListController(String, String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController のコンストラクタ
コンストラクタ生成
SalesOrderGetStatus - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus.
販売伝票ステータス一覧照会情報クラス
機能は以下の通り
販売伝票ステータス一覧照会情報を保持します。
SalesOrderGetStatus(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のコンストラクタ
販売伝票ステータス一覧照会情報を作成します。
SalesOrderGetStatus(String, SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のコンストラクタ
販売伝票ステータス一覧照会情報を作成します。
SalesOrderGetStatusController - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController.
販売伝票ステータス一覧照会コントローラクラス
機能は以下の通り
販売伝票ステータス一覧の情報を取得します。
SalesOrderGetStatusController() - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController のコンストラクタ
コンストラクタ生成
SalesOrderGetStatusController(String) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController のコンストラクタ
コンストラクタ生成
SalesOrderGetStatusController(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController のコンストラクタ
コンストラクタ生成
SalesOrderGetStatusController(String, SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController のコンストラクタ
コンストラクタ生成
SalesOrders - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders.
得意先受注テーブル情報クラス
機能は以下の通り
得意先受注テーブル情報を保持します。
SalesOrders() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のコンストラクタ
得意先受注テーブル情報を作成します。
SalesOrders(int) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のコンストラクタ
得意先受注テーブル情報を作成します。
SalesOrganisationSelection - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection.
販売組織の選択オプションクラス
機能は以下の通り
販売組織の選択オプションの情報を保持します。
SalesOrganisationSelection() - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のコンストラクタ
販売組織の選択オプション情報を作成します。
SalesOrganisationSelection(int) - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のコンストラクタ
販売組織の選択オプション情報を作成します。
SapAuthInfoBundle - class jp.co.intra_mart.foundation.sap.common.auth.SapAuthInfoBundle.
接続情報初期値取得クラス。
SapClient - class jp.co.intra_mart.foundation.sap.common.auth.SapClient.
SAPクライアント抽象クラス。
SapClient(String, String, String, String, String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のコンストラクタ
引数にて受け取った接続情報を属性にセットします。
SapClientManager - class jp.co.intra_mart.foundation.sap.common.auth.SapClientManager.
SAPクライアントマネージャークラス。
SapClientNoLoadBalancing - class jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing.
SapClientNoLoadBalancingクラス。
SapClientNoLoadBalancing(String, String, String, String, String, String, String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing のコンストラクタ
引数にて受け取った接続情報を属性にセットします。
SapClientPool - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool.
SAPClientPoolクラス。
SapClientPool(String, String, String, String, String, String, int, long, long, long) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のコンストラクタ
引数にて受け取った接続情報を属性にセットします。
SapClientPoolManager - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolManager.
SAPクライアントプールマネージャークラス。
SapClientPoolNoLoadBalancing - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing.
SAPClientPoolクラス。
SapClientPoolNoLoadBalancing(String, String, String, String, String, String, String, String, int, long, long, long) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing のコンストラクタ
引数にて受け取った接続情報を属性にセットします。
SapClientPoolWithLoadBalancing - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing.
SAPClientPoolクラス。
SapClientPoolWithLoadBalancing(String, String, String, String, String, String, String, String, String, int, long, long, long) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing のコンストラクタ
引数にて受け取った接続情報を属性にセットします。
SapClientWithLoadBalancing - class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing.
SAPClientPoolクラス。
SapClientWithLoadBalancing(String, String, String, String, String, String, String, String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing のコンストラクタ
引数にて受け取った接続情報を属性にセットします。
SapConnector - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector.
推奨されていません。 本クラスは現在、標準では使用されておりません。
本機能はクラス SapClientManager に置き換えられました。
SapConnector() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のコンストラクタ
推奨されていません。 プロパティファイルを読込み属性に値をセットします。
SapConnector(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のコンストラクタ
推奨されていません。 プロパティファイルを読込み属性に値をセットします。
SapRepositoryManager - class jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager.
JCO.Repository を管理クラス。
SaveEventHistoryInfo - class jp.co.intra_mart.foundation.navigator.SaveEventHistoryInfo.
保存イベント履歴情報クラス
SaveEventHistoryInfo() - class jp.co.intra_mart.foundation.navigator.SaveEventHistoryInfo のコンストラクタ

SaveEventResultItemInfo - class jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo.
保存ナビゲート結果情報
SaveEventResultItemInfo() - class jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo のコンストラクタ

Scheduler - class jp.co.intra_mart.foundation.service.client.batch.Scheduler.
Schedule Service の制御をするオブジェクトです。
Scheduler() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のコンストラクタ
新しいオブジェクトを構築します。
SchedulesIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn.
納入日程行情報クラス
機能は以下の通り
納入日程行情報を保持します。
SchedulesIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のコンストラクタ
納入日程行情報を作成します。
SchedulesIn(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のコンストラクタ
納入日程行情報を作成します。
SchedulesInX - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX.
納入日程行チェックボックス情報クラス
機能は以下の通り
納入日程行チェックボックス情報を保持します。
SchedulesInX() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のコンストラクタ
納入日程行チェックボックス情報を作成します。
SchedulesInX(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のコンストラクタ
納入日程行チェックボックス情報を作成します。
ScriptCompileException - exception jp.co.intra_mart.foundation.scenario.ScriptCompileException.
ScriptCompileException クラスは、スクリプトのコンパイル時にエラーが発生 場合にスローされる例外です。
ScriptCompileException(String) - class jp.co.intra_mart.foundation.scenario.ScriptCompileException のコンストラクタ
詳細メッセージを指定して ScriptCompileException を構築します。
ScriptCompileException(String, Throwable) - class jp.co.intra_mart.foundation.scenario.ScriptCompileException のコンストラクタ
詳細メッセージを指定して ScriptCompileException を構築します。
ScriptRuntimeException - exception jp.co.intra_mart.foundation.scenario.ScriptRuntimeException.
ScriptRuntimeException クラスは、スクリプトの実行時にエラーが発生 場合にスローされる例外です。
ScriptRuntimeException(String) - class jp.co.intra_mart.foundation.scenario.ScriptRuntimeException のコンストラクタ
詳細メッセージを指定して ScriptRuntimeException を構築します。
ScriptRuntimeException(String, Throwable) - class jp.co.intra_mart.foundation.scenario.ScriptRuntimeException のコンストラクタ
詳細メッセージを指定して ScriptRuntimeException を構築します。
ScriptValue - interface jp.co.intra_mart.foundation.scenario.ScriptValue.
スクリプトの値を保持するオブジェクトです。
SearchableClassLoader - class jp.co.intra_mart.common.aid.jdk.java.lang.SearchableClassLoader.
ユーティリティ的な実装を提供するクラスローダです。
SearchableClassLoader() - class jp.co.intra_mart.common.aid.jdk.java.lang.SearchableClassLoader のコンストラクタ
新しいクラスローダを生成します。
SearchableClassLoader(ClassLoader) - class jp.co.intra_mart.common.aid.jdk.java.lang.SearchableClassLoader のコンストラクタ
指定された親クラスローダを使って、委譲のために新しいクラスローダを作成します。
SearchableHttpServletResponseWrapper - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper.
HttpServletResponseWrapperの拡張実装を提供します。
SearchableHttpServletResponseWrapper(HttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のコンストラクタ
指定したレスポンスをラッピングしたレスポンス・アダプタを構築します。
SecurityConstraint - interface jp.co.intra_mart.foundation.security.SecurityConstraint.
アクセスセキュリティ定数インタフェース。
SelectItem - class jp.co.intra_mart.foundation.navigator.SelectItem.
選択アイテムクラス
SelectItem() - class jp.co.intra_mart.foundation.navigator.SelectItem のコンストラクタ

SelectItemInfo - class jp.co.intra_mart.foundation.navigator.SelectItemInfo.
選択アイテム情報
SelectItemInfo() - class jp.co.intra_mart.foundation.navigator.SelectItemInfo のコンストラクタ

Selection - class jp.co.intra_mart.foundation.sap.module.purchase.Selection.
選択オプションクラス
機能は以下の通り
選択オプションの情報を保持します。
Selection() - class jp.co.intra_mart.foundation.sap.module.purchase.Selection のコンストラクタ
選択オプション情報を作成します。
Sender - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender.
論理システム - 送信者情報クラス
機能は以下の通り
論理システム - 送信者情報を保持します。
Sender() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender のコンストラクタ
論理システム - 送信者情報を作成します。
SequenceComparator - class jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator.
挿入順にソートするためのコンパレータです。
SequenceComparator() - class jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator のコンストラクタ
新しいオブジェクトを生成します。
SequenceComparator - class jp.co.intra_mart.foundation.utility.SequenceComparator.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator クラスを使用してください。
SequenceComparator() - class jp.co.intra_mart.foundation.utility.SequenceComparator のコンストラクタ
推奨されていません。 新しいオブジェクトを生成します。
ServerConnector - class jp.co.intra_mart.foundation.service.client.manager.ServerConnector.
このクラスは、Server-Manager にリクエストを送信して 処理を要求するためのオブジェクトです。
ServerConnector(SocketConnectionDistributor) - class jp.co.intra_mart.foundation.service.client.manager.ServerConnector のコンストラクタ
オブジェクトを作成します。
ServiceContainer - interface jp.co.intra_mart.framework.base.service.container.ServiceContainer.
サービスコンテナのインターフェースです。
ServiceContainerException - exception jp.co.intra_mart.framework.base.service.container.ServiceContainerException.
サービスコンテナ設定時の例外です。
ServiceContainerException() - class jp.co.intra_mart.framework.base.service.container.ServiceContainerException のコンストラクタ
詳細メッセージを指定しないで ServiceContainerException を構築します。
ServiceContainerException(String) - class jp.co.intra_mart.framework.base.service.container.ServiceContainerException のコンストラクタ
指定された詳細メッセージを持つ ServiceContainerException を構築します。
ServiceContainerException(String, Throwable) - class jp.co.intra_mart.framework.base.service.container.ServiceContainerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceContainerException を構築します。
ServiceContainerFactory - class jp.co.intra_mart.framework.base.service.container.factory.ServiceContainerFactory.
ServiceContainerのファクトリクラスです。
ServiceContainerFactory() - class jp.co.intra_mart.framework.base.service.container.factory.ServiceContainerFactory のコンストラクタ

ServiceContainerImpl - class jp.co.intra_mart.framework.base.service.container.ServiceContainerImpl.
ServiceContainerの標準的な実装クラスです。
ServiceContainerImpl() - class jp.co.intra_mart.framework.base.service.container.ServiceContainerImpl のコンストラクタ
ServiceContainerImplを生成します。
ServiceController - interface jp.co.intra_mart.framework.base.service.ServiceController.
クライアントからの入力に対する処理を行います。
ServiceControllerAdapter - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter.
いくつかのユーティリティメソッドと空のメソッドを実装したサービスコントローラです。
ServiceControllerAdapter() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のコンストラクタ
ServiceControllerAdapterを新規に生成します。
ServiceControllerException - exception jp.co.intra_mart.framework.base.service.ServiceControllerException.
サービスコントローラに関連する例外です。
ServiceControllerException() - class jp.co.intra_mart.framework.base.service.ServiceControllerException のコンストラクタ
詳細メッセージを指定しないで ServiceControllerException を構築します。
ServiceControllerException(String) - class jp.co.intra_mart.framework.base.service.ServiceControllerException のコンストラクタ
指定された詳細メッセージを持つ ServiceControllerException を構築します。
ServiceControllerException(String, Throwable) - class jp.co.intra_mart.framework.base.service.ServiceControllerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceControllerException を構築します。
ServiceFrameworkHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler.
im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。
ServiceFrameworkHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のコンストラクタ
サービスフレームワークを実行するためのハンドラを作成します。
ServiceFrameworkHTTPActionEventHandler(String, String) - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のコンストラクタ
サービスフレームワークを実行するためのハンドラを作成します。
ServiceManager - class jp.co.intra_mart.framework.base.service.ServiceManager.
サービスマネージャです。
ServiceManagerException - exception jp.co.intra_mart.framework.base.service.ServiceManagerException.
サービスマネージャ設定時の例外です。
ServiceManagerException() - class jp.co.intra_mart.framework.base.service.ServiceManagerException のコンストラクタ
詳細メッセージを指定しないで ServiceManagerException を構築します。
ServiceManagerException(String) - class jp.co.intra_mart.framework.base.service.ServiceManagerException のコンストラクタ
指定された詳細メッセージを持つ ServiceManagerException を構築します。
ServiceManagerException(String, Throwable) - class jp.co.intra_mart.framework.base.service.ServiceManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceManagerException を構築します。
ServicePropertyException - exception jp.co.intra_mart.framework.base.service.ServicePropertyException.
サービスプロパティ取得時の例外です。
ServicePropertyException() - class jp.co.intra_mart.framework.base.service.ServicePropertyException のコンストラクタ
詳細メッセージを指定しないで ServicePropertyException を構築します。
ServicePropertyException(String) - class jp.co.intra_mart.framework.base.service.ServicePropertyException のコンストラクタ
指定された詳細メッセージを持つ ServicePropertyException を構築します。
ServicePropertyException(String, Throwable) - class jp.co.intra_mart.framework.base.service.ServicePropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServicePropertyException を構築します。
ServicePropertyHandler - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler.
サービスの設定情報に接続するクラスです。
ServiceResult - interface jp.co.intra_mart.framework.base.service.ServiceResult.
サービスの処理結果です。
ServiceSecurityFilter - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter.
intra-mart画面を表示するURLの詐称をチェックするためのフィルタです。
ServiceSecurityFilter() - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter のコンストラクタ

ServiceServlet - class jp.co.intra_mart.framework.base.service.ServiceServlet.
サービスを振り分けるサーブレットです。
ServiceServlet() - class jp.co.intra_mart.framework.base.service.ServiceServlet のコンストラクタ
ServiceServletを新規に生成します。
ServiceServletException - exception jp.co.intra_mart.framework.base.service.ServiceServletException.
サービスに関連する例外です。
ServiceServletException() - class jp.co.intra_mart.framework.base.service.ServiceServletException のコンストラクタ
詳細メッセージを指定しないで ServiceServletException を構築します。
ServiceServletException(String) - class jp.co.intra_mart.framework.base.service.ServiceServletException のコンストラクタ
指定された詳細メッセージを持つ ServiceServletException を構築します。
ServiceServletException(String, Throwable) - class jp.co.intra_mart.framework.base.service.ServiceServletException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceServletException を構築します。
ServiceUnavailableException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException.
サーバの都合により一時的にリクエストを処理できないことを 通知するための例外です。
ServiceUnavailableException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException のコンストラクタ
指定のメッセージを持つ例外を作成します。
ServiceUnavailableException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
ServiceUnavailableException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException のコンストラクタ
例外を作成します。
ServiceUtils - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils.
im-J2EE Frameworkのサービスフレームワークに連携するためのユーティリティです。
ServiceUtils() - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils のコンストラクタ

ServletHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler.
Web-Application を実行するためのイベントハンドラです。
ServletHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のコンストラクタ
Web-Application をイベント実行するためのハンドラを作成します。
ServletHTTPActionEventHandler(String) - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のコンストラクタ
指定のパスで表される Web-Application をイベント実行するためのハンドラを作成します。
SessionConfig - interface jp.co.intra_mart.foundation.security.SessionConfig.
セッションに関する設定情報を取得するインタフェース。
SessionFactory - class jp.co.intra_mart.foundation.service.client.information.SessionFactory.
共有データグループを管理するオブジェクトです。
SessionFactory(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
SessionFactory - interface jp.co.intra_mart.framework.base.session.SessionFactory.
セッションに関連するファクトリクラスとなるインタフェースです。
SessionFactoryException - exception jp.co.intra_mart.framework.base.session.SessionFactoryException.
セッションファクトリ内の例外です。
SessionFactoryException() - class jp.co.intra_mart.framework.base.session.SessionFactoryException のコンストラクタ
詳細メッセージを指定しないで SessionFactoryException を構築します。
SessionFactoryException(String) - class jp.co.intra_mart.framework.base.session.SessionFactoryException のコンストラクタ
指定された詳細メッセージを持つ SessionFactoryException を構築します。
SessionFactoryException(String, Throwable) - class jp.co.intra_mart.framework.base.session.SessionFactoryException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionFactoryException を構築します。
SessionFilter - class jp.co.intra_mart.foundation.security.filter.SessionFilter.
セッションフィルタ。
SessionFilter() - class jp.co.intra_mart.foundation.security.filter.SessionFilter のコンストラクタ

SessionFilter - class jp.co.intra_mart.framework.base.session.SessionFilter.
セッション管理をします。
SessionFilter() - class jp.co.intra_mart.framework.base.session.SessionFilter のコンストラクタ

SessionInfo - interface jp.co.intra_mart.foundation.security.SessionInfo.
intra-martセッション情報参照インタフェース。
SessionManager - class jp.co.intra_mart.framework.base.session.SessionManager.
セッションマネージャです。
SessionManagerException - exception jp.co.intra_mart.framework.base.session.SessionManagerException.
セッションマネージャ内の例外です。
SessionManagerException() - class jp.co.intra_mart.framework.base.session.SessionManagerException のコンストラクタ
詳細メッセージを指定しないで SessionManagerException を構築します。
SessionManagerException(String) - class jp.co.intra_mart.framework.base.session.SessionManagerException のコンストラクタ
指定された詳細メッセージを持つ SessionManagerException を構築します。
SessionManagerException(String, Throwable) - class jp.co.intra_mart.framework.base.session.SessionManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionManagerException を構築します。
SessionMemory - class jp.co.intra_mart.foundation.service.client.information.SessionMemory.
共有データを管理するオブジェクトです。
SessionMemory(HttpSession) - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
SessionObject - interface jp.co.intra_mart.framework.base.session.SessionObject.
セッションに関連する情報を持つオブジェクトです。
SessionObjectException - exception jp.co.intra_mart.framework.base.session.SessionObjectException.
セッションオブジェクト内の例外です。
SessionObjectException() - class jp.co.intra_mart.framework.base.session.SessionObjectException のコンストラクタ
詳細メッセージを指定しないで SessionObjectException を構築します。
SessionObjectException(String) - class jp.co.intra_mart.framework.base.session.SessionObjectException のコンストラクタ
指定された詳細メッセージを持つ SessionObjectException を構築します。
SessionObjectException(String, Throwable) - class jp.co.intra_mart.framework.base.session.SessionObjectException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionObjectException を構築します。
SessionPropertyException - exception jp.co.intra_mart.framework.base.session.SessionPropertyException.
セッションプロパティ取得時の例外です。
SessionPropertyException() - class jp.co.intra_mart.framework.base.session.SessionPropertyException のコンストラクタ
詳細メッセージを指定しないで SessionPropertyException を構築します。
SessionPropertyException(String) - class jp.co.intra_mart.framework.base.session.SessionPropertyException のコンストラクタ
指定された詳細メッセージを持つ SessionPropertyException を構築します。
SessionPropertyException(String, Throwable) - class jp.co.intra_mart.framework.base.session.SessionPropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionPropertyException を構築します。
SessionPropertyHandler - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler.
セッションに関連するプロパティを取得します。
SessionQuery - class jp.co.intra_mart.foundation.http.SessionQuery.
推奨されていません。 GenericURLBuilder および URLBuilder に置き替えられました。
SessionQuery(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.http.SessionQuery のコンストラクタ
推奨されていません。 GenericURLBuilder および URLBuilder に置き替えられました。
ShortCutAccessor - interface jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor.
ショートカットアクセッサインタフェース。
ShortCutInfo - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo.
ショートカット情報クラス。
ShortCutInfo() - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のコンストラクタ

ShortCutManager - class jp.co.intra_mart.foundation.security.shortcut.ShortCutManager.
ショートカットマネージャクラス

ServerManager/conf/short-cut-config.xmlからショートカット情報に関するパラメータを取得します。
ShortCutManager(String) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutManager のコンストラクタ

ShutdownEventController - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController.
このクラスは、サーバプロセスの基礎ロジック。
ShutdownListener - interface jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownListener.
シャットダウンイベント時に実行する任意のロジックを実装するためのインターフェースです。
SimpleControllerConverter - class jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter.
リクエストの内容をコントローラオブジェクトにマッピングする単純なコントローラコンバータです。
SimpleControllerConverter() - class jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter のコンストラクタ

SimpleHttpServletResponseEventListener - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener.
レスポンスの各メソッド呼び出しに対するイベントをフックするためのコンポーネント実装です。
SimpleHttpServletResponseEventListener() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のコンストラクタ
新しいリスナを作成します。
SocketConnection - class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection.
ソケットプール用のスケルトン実装を提供します。
SocketConnection(String, int) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection のコンストラクタ
ソケット入出力インスタンスを構築します。
SocketConnection(Socket) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection のコンストラクタ
ソケット入出力インスタンスを構築します。
SocketConnection(ExtendedSocket) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection のコンストラクタ
ソケット入出力インスタンスを構築します。
SocketConnection - class jp.co.intra_mart.foundation.utility.net.SocketConnection.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。
SocketConnection(String, int) - class jp.co.intra_mart.foundation.utility.net.SocketConnection のコンストラクタ
推奨されていません。 ソケット入出力インスタンスを構築します。
SocketConnection(Socket) - class jp.co.intra_mart.foundation.utility.net.SocketConnection のコンストラクタ
推奨されていません。 ソケット入出力インスタンスを構築します。
SocketConnection(ExtendedSocket) - class jp.co.intra_mart.foundation.utility.net.SocketConnection のコンストラクタ
推奨されていません。 ソケット入出力インスタンスを構築します。
SocketConnectionDistributor - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor.
このクラスは、通信ソケットをプールする機能を提供します。
SocketConnectionDistributor - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor クラスを使用してください。
SocketConnectionDistributorFactory - class jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory.
このクラスは、Server-Manager に接続するための ネットワークコネクション管理オブジェクトを作成するためのクラスです。
SocketConnectionDistributorFactory(String, int) - class jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory のコンストラクタ
オブジェクトを作成します。
SocketConnectionDistributorFactory(String, int, int) - class jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory のコンストラクタ
オブジェクトを作成します。
SocketConnectionManager - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager.
通信ソケットをプールする機能のインターフェースです。
SocketConnectionManager - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionManager.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager クラスを使用してください。
SocketEventListener - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener.
通信ソケットに関するイベント発生を受け取るためのスケルトン実装です。
SocketEventListener - interface jp.co.intra_mart.foundation.utility.net.SocketEventListener.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener クラスを使用してください。
SocketPool - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool.
このクラスは、通信ソケットをプールする機能を提供します。
SocketPool(String, int) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のコンストラクタ
ソケットプールを構築します。
SocketPool(String, int, int) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のコンストラクタ
ソケットプールを構築します。
SocketPool - class jp.co.intra_mart.foundation.utility.net.SocketPool.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketPool クラスを使用してください。
SocketPool(String, int) - class jp.co.intra_mart.foundation.utility.net.SocketPool のコンストラクタ
推奨されていません。 ソケットプールを構築します。
SocketPool(String, int, int) - class jp.co.intra_mart.foundation.utility.net.SocketPool のコンストラクタ
推奨されていません。 ソケットプールを構築します。
SourceProviderHandler - class jp.co.intra_mart.foundation.commons.SourceProviderHandler.

SourceProviderHandler() - class jp.co.intra_mart.foundation.commons.SourceProviderHandler のコンストラクタ
コンストラクタ。
SpecStockRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa.
特殊在庫区分の範囲情報クラス
機能は以下の通り
特殊在庫区分の範囲情報を保持します。
SpecStockRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のコンストラクタ
特殊在庫区分の範囲情報を作成します。
SpecStockRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のコンストラクタ
特殊在庫区分の範囲情報を作成します。
StandardAccessControllerAccessor - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor.

StandardAccessControllerAccessor() - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のコンストラクタ

StandardAccessControllerBackup - class jp.co.intra_mart.foundation.security.access.StandardAccessControllerBackup.

StandardAccessControllerBackup() - class jp.co.intra_mart.foundation.security.access.StandardAccessControllerBackup のコンストラクタ

StandardAccountAccessor - class jp.co.intra_mart.foundation.security.StandardAccountAccessor.
アカウントアクセッサクラス。
StandardAccountAccessor() - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のコンストラクタ
コンストラクタ。
StandardAccountBackup - class jp.co.intra_mart.foundation.security.account.StandardAccountBackup.
アカウント情報をインポート・エクスポートするクラス。
StandardAccountBackup() - class jp.co.intra_mart.foundation.security.account.StandardAccountBackup のコンストラクタ

StandardActiveSessionAccessor - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor.
アクティブなセッション情報操作実装クラス。
StandardActiveSessionAccessor() - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のコンストラクタ

StandardAdminMenuBackup - class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup.
メニューバックアップクラスです。
StandardAdminMenuBackup() - class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup のコンストラクタ

StandardBatchAccessor - class jp.co.intra_mart.foundation.security.StandardBatchAccessor.
バッチアクセッサクラス。
StandardBatchAccessor() - class jp.co.intra_mart.foundation.security.StandardBatchAccessor のコンストラクタ
コンストラクタ。
StandardBatchBackup - class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup.
バッチバックアップクラスです。
StandardBatchBackup() - class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup のコンストラクタ

StandardCalendarAccessor - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor.
カレンダーアクセッサクラス。
StandardCalendarAccessor() - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor のコンストラクタ
コンストラクタ。
StandardCalendarBackup - class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup.
カレンダーバックアップクラスです。
StandardCalendarBackup() - class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup のコンストラクタ

StandardCompanyImporter - class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter.
会社のインポートを行います。
StandardCompanyImporter() - class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter のコンストラクタ

StandardCompanyPostImporter - class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter.
役職のインポートを行います。
StandardCompanyPostImporter() - class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter のコンストラクタ

StandardCryption - class jp.co.intra_mart.foundation.security.cryption.StandardCryption.
文字列の暗号化・復号化を行う標準の実装クラスです。
StandardCryption() - class jp.co.intra_mart.foundation.security.cryption.StandardCryption のコンストラクタ
コンストラクタ。
StandardDuplicateLoginAccessor - class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor.
重複ログイン操作インターフェース。
StandardDuplicateLoginAccessor() - class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor のコンストラクタ

StandardEJBEventListener - class jp.co.intra_mart.framework.base.event.StandardEJBEventListener.
StandardEJBEventListenerAgentに接続するイベントリスナです。
StandardEJBEventListener(StandardEJBEventListenerAgentHome) - class jp.co.intra_mart.framework.base.event.StandardEJBEventListener のコンストラクタ
StandardEJBEventListenerを新規に生成します。
StandardEJBEventListenerAgent - interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent.
EJBを利用するときのイベントリスナのリモートインタフェースです。
StandardEJBEventListenerAgentBean - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean.
EJBを利用する場合の抽象的なイベントリスナです。
StandardEJBEventListenerAgentBean() - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean のコンストラクタ
StandardEJBEventListenerAgentBeanを新規に生成します。
StandardEJBEventListenerAgentHome - interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome.
StandardEJBEventListenerAgentのホームインタフェースです。
StandardEJBEventListenerFactory - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory.
標準的なEJB用のイベントリスナファクトリです。
StandardEJBEventListenerFactory() - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory のコンストラクタ
StandardEJBEventListenerFactoryを新規に生成します。
StandardErrorPageProvider - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider.
標準のエラーページプロバイダクラス。
StandardErrorPageProvider() - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のコンストラクタ
デフォルトコンストラクタ

StandardEventListener - class jp.co.intra_mart.framework.base.event.StandardEventListener.
汎用的なビジネスロジック用のクラスです。
StandardEventListener() - class jp.co.intra_mart.framework.base.event.StandardEventListener のコンストラクタ

StandardEventListenerFactory - class jp.co.intra_mart.framework.base.event.StandardEventListenerFactory.
通常のJavaクラスのイベントリスナを生成します。
StandardEventListenerFactory() - class jp.co.intra_mart.framework.base.event.StandardEventListenerFactory のコンストラクタ
StandardEventListenerFactoryを新規に生成します。
StandardEventNavigatorAccessor - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor.
イベントナビゲーター管理アクセッサクラス。
StandardEventNavigatorAccessor() - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のコンストラクタ
コンストラクタ

StandardEventNavigatorExporter - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter.

StandardEventNavigatorExporter() - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter のコンストラクタ

StandardEventNavigatorImporter - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter.
イベントナビゲーターのインポートクラス。
StandardEventNavigatorImporter() - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter のコンストラクタ

StandardGroupSuperUserPageProvider - class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider.
標準のログイングループ管理者用ページプロバイダクラス。
StandardGroupSuperUserPageProvider() - class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider のコンストラクタ
デフォルトコンストラクタ

StandardHttpServletResponseEventControllerBuilder - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.StandardHttpServletResponseEventControllerBuilder.
標準的なコントローラを構築するビルダです。
StandardHttpServletResponseEventControllerBuilder() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.StandardHttpServletResponseEventControllerBuilder のコンストラクタ
新しいビルダを構築します。
StandardItemAttachImporter - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemAttachImporter.
商品分類のインポートを行います。
StandardItemAttachImporter() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemAttachImporter のコンストラクタ

StandardItemCategoryImporter - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemCategoryImporter.
商品カテゴリのインポートを行います。
StandardItemCategoryImporter() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemCategoryImporter のコンストラクタ

StandardItemImporter - class jp.co.intra_mart.foundation.datastore.application.domain.item.StandardItemImporter.
商品のインポートを行います。
StandardItemImporter() - class jp.co.intra_mart.foundation.datastore.application.domain.item.StandardItemImporter のコンストラクタ

StandardItemTemplateImporter - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.StandardItemTemplateImporter.
商品テンプレートのインポートを行います。
StandardItemTemplateImporter() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.StandardItemTemplateImporter のコンストラクタ

StandardMail - class jp.co.intra_mart.foundation.mail.javamail.StandardMail.
送信するメールの属性を保管します。
StandardMail() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のコンストラクタ
システムのロケールからメール属性オブジェクトを新規に作成します。
StandardMail(Locale) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のコンストラクタ
ロケールを指定してメール属性オブジェクトを新規に作成します。
StandardMenuAccessor - class jp.co.intra_mart.foundation.security.StandardMenuAccessor.
メニューアクセッサクラス。
StandardMenuAccessor() - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のコンストラクタ
コンストラクタ。
StandardMenuBackup - class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup.
メニューバックアップクラスです。
StandardMenuBackup() - class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup のコンストラクタ

StandardPasswordHistoryAccessor - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor.
パスワード履歴管理アクセッサクラス。
StandardPasswordHistoryAccessor() - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のコンストラクタ

StandardPortlet - class jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet.
標準ポートレットに対するモデルの抽象クラスです。
StandardPortlet() - class jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet のコンストラクタ

StandardPublicGroupImporter - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter.
パブリックグループのインポートを行います。
StandardPublicGroupImporter() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter のコンストラクタ

StandardRequestAnalyzer - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer.
標準のログインリクエスト解析クラス。
StandardRequestAnalyzer() - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のコンストラクタ
デフォルトコンストラクタ。
StandardRoleAccessor - class jp.co.intra_mart.foundation.security.StandardRoleAccessor.
ロールアクセッサクラス。
StandardRoleAccessor() - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のコンストラクタ
コンストラクタ

StandardRoleBackup - class jp.co.intra_mart.foundation.security.role.StandardRoleBackup.
ロールバックアップクラスです。
StandardRoleBackup() - class jp.co.intra_mart.foundation.security.role.StandardRoleBackup のコンストラクタ

StandardShortCutAccessor - class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor.
ショートカットアクセッサクラス。
StandardShortCutAccessor() - class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor のコンストラクタ

StandardSuperUserCertification - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification.
管理者ログイン認証の実装クラス。
StandardSuperUserCertification() - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification のコンストラクタ
デフォルトコンストラクタ

StandardSuperUserPageProvider - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider.
標準のシステム管理者用のユーザページプロバイダクラス。
StandardSuperUserPageProvider() - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider のコンストラクタ
デフォルトコンストラクタ

StandardUpdateAccessor - class jp.co.intra_mart.foundation.update.StandardUpdateAccessor.
情報更新管理アクセッサ標準実装クラス。
StandardUpdateAccessor() - class jp.co.intra_mart.foundation.update.StandardUpdateAccessor のコンストラクタ

StandardUserCertification - class jp.co.intra_mart.foundation.security.certification.StandardUserCertification.
ユーザログイン認証クラス。
StandardUserCertification() - class jp.co.intra_mart.foundation.security.certification.StandardUserCertification のコンストラクタ
デフォルトコンストラクタ。
StandardUserImporter - class jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter.
ユーザプロファイルのインポートを行います。
StandardUserImporter() - class jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter のコンストラクタ

StandardUserPageProvider - class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider.
標準のユーザページプロバイダクラス。
StandardUserPageProvider() - class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider のコンストラクタ
デフォルトコンストラクタ

StatusInfo - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo.
ステータス情報情報クラス
機能は以下の通り
ステータス情報情報を保持します。
StatusInfo() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のコンストラクタ
ステータス情報情報を作成します。
StatusInfo(int) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のコンストラクタ
ステータス情報情報を作成します。
StdErr - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr.
このクラスは、エラーメッセージ出力用です。
StdMaterialGetIntNumber - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber.
品目コード割当済情報クラス
機能は以下の通り
品目コード割当済の情報を保持します。
StdMaterialGetIntNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のコンストラクタ
品目コード割当済情報を作成します。
StdMaterialGetIntNumberController - class jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController.
品目コード割当済照会コントローラクラス。
StdMaterialGetIntNumberController(String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController のコンストラクタ
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
StdMaterialGetIntNumberController(String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController のコンストラクタ
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
StdMaterialGetIntNumberList - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList.
品目コード割当済一覧クラス
機能は以下の通り
品目コード割当済の情報を一覧形式で取得します。
StdMaterialGetIntNumberList(String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList のコンストラクタ
executeBapiを呼び出し品目コード割当済一覧を作成します。
StdOut - class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut.
このクラスは、システムメッセージ出力用です。
StgeLocRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa.
保管場所の範囲情報クラス
機能は以下の通り
保管場所の範囲情報を保持します。
StgeLocRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のコンストラクタ
保管場所の範囲情報を作成します。
StgeLocRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のコンストラクタ
保管場所の範囲情報を作成します。
StorageDirectory - class jp.co.intra_mart.foundation.service.provider.file.StorageDirectory.
Storage Service の基準ディレクトリを表すクラスです。
StorageLocationData - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData.
品目データ (保管場所レベル)情報クラス
機能は以下の通り
品目データ (保管場所レベル)情報を保持します。
StorageLocationData() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のコンストラクタ
品目データ (保管場所レベル)情報を作成します。
StorageLocationDataList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList.
品目データ (保管場所レベル)情報クラス
機能は以下の通り
品目データ (保管場所レベル)情報をテーブル型で保持します。
StorageLocationDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList のコンストラクタ
品目データ (保管場所レベル)情報を作成します。
StorageLocationDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList のコンストラクタ
品目データ (保管場所レベル)情報を作成します。
StorageLocationSelect - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect.
保管場所の選択オプションクラス
機能は以下の通り
保管場所の選択オプションの情報を保持します。
StorageLocationSelect() - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のコンストラクタ
保管場所の選択オプション情報を作成します。
StorageLocationSelect(int) - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のコンストラクタ
保管場所の選択オプション情報を作成します。
StorageTypeData - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData.
保管域タイプデータ情報クラス
機能は以下の通り
保管域タイプデータ情報を保持します。
StorageTypeData() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のコンストラクタ
保管域タイプデータ情報を作成します。
StorageTypeDataList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList.
保管域タイプデータ情報クラス
機能は以下の通り
保管域タイプデータ情報をテーブル型で保持します。
StorageTypeDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList のコンストラクタ
保管域タイプデータ情報を作成します。
StorageTypeDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList のコンストラクタ
保管域タイプデータ情報を作成します。
StrutsConnectFilter - class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter.
intra-martのメニューからStrutsに接続するフィルターです。
StrutsConnectFilter() - class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter のコンストラクタ

SubmitLinkTag - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag.
サブミット専用のLINKタグです。
SubmitLinkTag() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のコンストラクタ
SubmitLinkTagを新規に生成します。
SubmitLinkTagBeanInfo - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo.
SubmitLinkTagのBeanInfoです。
SubmitLinkTagBeanInfo() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo のコンストラクタ
SubmitLinkTagBeanInfoを新規に生成します。
SubmitTEI - class jp.co.intra_mart.framework.base.web.tag.SubmitTEI.
Submitタグの拡張情報です。
SubmitTEI() - class jp.co.intra_mart.framework.base.web.tag.SubmitTEI のコンストラクタ
SubmitTEIを新規に生成します。
SubmitTag - class jp.co.intra_mart.framework.base.web.tag.SubmitTag.
Submitタグです。
SubmitTag() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のコンストラクタ
SubmitTagを新規に生成します。
SubmitTagBeanInfo - class jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo.
SubmitTagのBeanInfoです。
SubmitTagBeanInfo() - class jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo のコンストラクタ
SubmitTagBeanInfoを新規に生成します。
Success - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success.
正常に処理された明細のテーブル情報クラス
機能は以下の通り
正常に処理された明細のテーブル情報を保持します。
Success() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のコンストラクタ
正常に処理された明細のテーブル情報を作成します。
Success(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のコンストラクタ
正常に処理された明細のテーブル情報を作成します。
SuperCertification - interface jp.co.intra_mart.foundation.security.certification.SuperCertification.
管理者ログイン認証インタフェース。
SuperCertificationListener - interface jp.co.intra_mart.foundation.security.certification.SuperCertificationListener.
管理者ログイン認証リスナーインタフェース。
SuperUser - class jp.co.intra_mart.foundation.security.admin.SuperUser.
スーパーユーザ・モデルインタフェース。
SuperUser() - class jp.co.intra_mart.foundation.security.admin.SuperUser のコンストラクタ
コンストラクタ。
SuperUser(String) - class jp.co.intra_mart.foundation.security.admin.SuperUser のコンストラクタ
コンストラクタ。
SuperUserAccessor - interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor.
システム管理者アクセッサインタフェース。
SuperUserInitialServlet - class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet.
システム管理者初期アクセスサーブレット。
SuperUserInitialServlet() - class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet のコンストラクタ

SuperUserNoCertification - class jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification.
システム管理者ログイン時に強制認証を行う実装クラスです。
SuperUserNoCertification() - class jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification のコンストラクタ
デフォルトコンストラクタ

SuperUserPostWriterListener - interface jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener.
システム管理者情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
SuperUserQueryWriterListener - interface jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener.
システム管理者情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
SuperUserReaderDecorator - interface jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator.
システム管理者情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
SupplierDetail - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail.
仕入先マスタ詳細情報クラス
機能は以下の通り
仕入先マスタの詳細情報を取得します。
SupplierDetail(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のコンストラクタ
仕入先詳細情報クラスを取得します
SupplierDetail(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のコンストラクタ
executeBapiを呼び出し仕入先マスタ詳細を作成します。
SupplierExistenceCheck - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck.
仕入先コード存在チェッククラス
機能は以下の通り
仕入先コード存在チェック結果を取得します。
SupplierExistenceCheck(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のコンストラクタ
仕入先詳細情報クラスを取得します
SupplierExistenceCheck(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のコンストラクタ
executeBapiを呼び出し仕入先コード存在チェックを作成します。
SupplierExistenceCheckController - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController.
仕入先コード存在チェックコントローラ
機能は以下の通り
仕入先コード存在チェックを行います。
SupplierExistenceCheckController() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のコンストラクタ
コンストラクタ生成
SupplierExistenceCheckController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のコンストラクタ
コンストラクタ生成
SupplierExistenceCheckController(String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のコンストラクタ
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheckController(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のコンストラクタ
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierGetDetailController - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController.
仕入先マスタの詳細情報取得コントローラ
機能は以下の通り
仕入先マスタの詳細情報を取得します。
SupplierGetDetailController() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のコンストラクタ
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のコンストラクタ
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のコンストラクタ
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のコンストラクタ
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SystemConfigException - exception jp.co.intra_mart.foundation.security.exception.SystemConfigException.
システム設定に関する例外クラス。
SystemConfigException() - class jp.co.intra_mart.foundation.security.exception.SystemConfigException のコンストラクタ
コンストラクタ。
SystemConfigException(String) - class jp.co.intra_mart.foundation.security.exception.SystemConfigException のコンストラクタ
コンストラクタ。
SystemConfigException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.SystemConfigException のコンストラクタ
コンストラクタ。
SystemConfigException(Throwable) - class jp.co.intra_mart.foundation.security.exception.SystemConfigException のコンストラクタ
コンストラクタ。
SystemDBConnector - class jp.co.intra_mart.framework.base.data.SystemDBConnector.
イントラマートで設定されているDBコネクションです。
SystemDBConnector() - class jp.co.intra_mart.framework.base.data.SystemDBConnector のコンストラクタ
SystemDBConnectorを新規に生成します。
SystemDBDAO - class jp.co.intra_mart.framework.base.data.SystemDBDAO.
イントラマートで設定されたDBへアクセスするDAOです。
SystemDBDAO() - class jp.co.intra_mart.framework.base.data.SystemDBDAO のコンストラクタ
IntramartDBDAOを新規に生成します。
SystemDataSource - class jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource.
システムに設定されたデータソースをラップします。
SystemDataSource() - class jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource のコンストラクタ

SystemDataSource(InitialContext, String) - class jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource のコンストラクタ
指定した識別子に設定されたデータソースをラップします。
SystemErrorReporter - interface jp.co.intra_mart.foundation.service.provider.SystemErrorReporter.
エラーログ出力用のインターフェースです。
SystemException - exception jp.co.intra_mart.framework.system.exception.SystemException.
フレームワーク内で発生したシステム例外です。
SystemException() - class jp.co.intra_mart.framework.system.exception.SystemException のコンストラクタ
詳細メッセージを指定しないで SystemException を構築します。
SystemException(String) - class jp.co.intra_mart.framework.system.exception.SystemException のコンストラクタ
指定された詳細メッセージを持つ SystemException を構築します。
SystemException(Throwable) - class jp.co.intra_mart.framework.system.exception.SystemException のコンストラクタ
この例外の発生原因となる例外を持つ SystemException を構築します。
SystemException(String, Throwable) - class jp.co.intra_mart.framework.system.exception.SystemException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SystemException を構築します。
SystemManager - class jp.co.intra_mart.foundation.security.SystemManager.
システムマネージャクラス。
SystemReporter - interface jp.co.intra_mart.foundation.service.provider.SystemReporter.
システムログの共通インターフェースです。
SystemSourceProvider - interface jp.co.intra_mart.foundation.security.SystemSourceProvider.
ロケール情報取得インターフェース。
SystemStatus - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus.
システムステータステーブル情報クラス 機能は以下の通り
システムステータステーブル情報を保持します。
SystemStatus() - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus のコンストラクタ
システムステータステーブルを作成します。
sapClient - class jp.co.intra_mart.foundation.sap.module.AbstractController の変数
SAPクライアント
save(String, byte[]) - interface jp.co.intra_mart.foundation.datastore.application.domain.item.ItemCatalogueMediaManager のメソッド
商品カタログの媒体情報を保存します。
save(byte[]) - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ファイルにバイトを出力します。
searchAccounts(String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウント情報の読み込みます。
searchAccounts(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント情報の読み込みます。
searchAccounts(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
ユーザIDを検索してマッチしたアカウントを配列で返します。
searchActiveSessionInfosByUserId(String, String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたユーザ条件からアクティブなセッション情報を検索します。
searchActiveSessionInfosByUserId(String, String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたユーザ条件からアクティブなセッション情報を検索します。
searchActiveSessionInfosByUserId(String, String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたユーザ条件からアクティブなセッション情報を検索します。
searchRolesById(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロールID検索によりロールを取得します。
searchRolesByName(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール名称検索によりロールを取得します。
secureRedirect(HttpServletRequest, HttpServletResponse, String, Map) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。
secureRedirect(String, Map) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。
select(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 SELECT文を発行してデータベースからデータを取得する

select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
プライマリーキーで特定される分類区分の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
プライマリーキーで特定される分類区分詳細の基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
プライマリーキーで特定される組織所属の基本モデルを取得します。
select(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
プライマリーキーで特定される会社組織分類の基本モデルを取得します。
select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
プライマリーキーで特定される会社の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
プライマリーキーで特定される組織の基本モデルを取得します。
select(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
プライマリーキーで特定される組織内包の基本モデルを取得します。
select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
プライマリーキーで特定される主所属の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
プライマリーキーで特定される役職の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
プライマリーキーで特定される会社構成バージョンの基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper のメソッド
プライマリーキーで特定される取扱の基本モデルを取得します。
select(String, String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper のメソッド
プライマリーキーで特定される組織毎取扱パーミッションの基本モデルを取得します。
select(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper のメソッド
プライマリーキーで特定される取扱詳細の基本モデルを取得します。
select(String, String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper のメソッド
プライマリーキーで特定されるパブリックグループ毎取扱パーミッションの基本モデルを取得します。
select(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper のメソッド
プライマリーキーで特定されるロール毎取扱パーミッションの基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper のメソッド
プライマリーキーで特定される商品属性の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper のメソッド
プライマリーキーで特定される商品カタログの基本モデルを取得します。
select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper のメソッド
プライマリーキーで特定される商品の基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper のメソッド
プライマリーキーで特定される商品分類の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper のメソッド
プライマリーキーで特定される商品カテゴリの基本モデルを取得します。
select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper のメソッド
プライマリーキーで特定される商品カテゴリ種別の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper のメソッド
プライマリーキーで特定される商品属性テンプレート明細の基本モデルを取得します。
select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper のメソッド
プライマリーキーで特定される商品属性テンプレートの基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライマリーキーで特定されるプライベートグループ所属の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライマリーキーで特定されるプライベートグループの基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
プライマリーキーで特定されるパブリックグループ所属の基本モデルを取得します。
select(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
プライマリーキーで特定されるパブリックグループ分類の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
プライマリーキーで特定されるパブリックグループの基本モデルを取得します。
select(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
プライマリーキーで特定されるパブリックグループ内包の基本モデルを取得します。
select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
プライマリーキーで特定されるパブリックグループセットの基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
プライマリーキーで特定されるパブリックグループ構成バージョンの基本モデルを取得します。
select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper のメソッド
プライマリーキーで特定される単位の基本モデルを取得します。
select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
プライマリーキーで特定されるユーザの基本モデルを取得します。
select(Map) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
プライマリーキーで特定される基本モデルを取得します。
select(Relationship, Map) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
外部キーで特定される基本モデルをすべて取得します。
select(Map) - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
プライマリーキーで特定される基本モデルを取得します。
select(String, String) - class jp.co.intra_mart.foundation.update.StandardUpdateAccessor のメソッド
更新日付を取得します。
select(String, String) - interface jp.co.intra_mart.foundation.update.UpdateAccessor のメソッド
更新日付を取得します。
select(String, String, String) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper のメソッド
プライマリーキーで特定されるアクセスコントローラの利用権限を保有する組織の基本モデルを取得します。
select(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper のメソッド
プライマリーキーで特定されるアクセスコントローラ情報の基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper のメソッド
プライマリーキーで特定されるアクセスコントローラの利用権限を保有する役職の基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper のメソッド
プライマリーキーで特定されるアクセスコントローラの利用権限を保有するパブリックグループの基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper のメソッド
プライマリーキーで特定されるアクセスコントローラの利用権限を保有するロールの基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper のメソッド
プライマリーキーで特定されるアカウントが保有する属性の基本モデルを取得します。
select(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountMapper のメソッド
プライマリーキーで特定されるアカウントの基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper のメソッド
プライマリーキーで特定されるアカウントが保有するロールの基本モデルを取得します。
select(String) - interface jp.co.intra_mart.system.security.datastore.inf.BatchMapper のメソッド
プライマリーキーで特定されるバッチ情報の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper のメソッド
プライマリーキーで特定されるカレンダーが保有するデータの基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper のメソッド
プライマリーキーで特定されるアカウントが保有するメニューの基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper のメソッド
プライマリーキーで特定されるメニューの保有する引数の基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper のメソッド
プライマリーキーで特定されるメニューの利用権限を保有する組織の基本モデルを取得します。
select(String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuMapper のメソッド
プライマリーキーで特定されるメニュー情報の基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper のメソッド
プライマリーキーで特定されるメニューの利用権限を保有する役職の基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper のメソッド
プライマリーキーで特定されるメニューの利用権限を保有するパブリックグループの基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper のメソッド
プライマリーキーで特定されるメニューの利用権限を保有するロールの基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper のメソッド
プライマリーキーで特定されるロール内包の基本モデルを取得します。
select(String) - interface jp.co.intra_mart.system.security.datastore.inf.RoleMapper のメソッド
プライマリーキーで特定されるロールの基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper のメソッド
プライマリーキーで特定されるロールサマリの基本モデルを取得します。
selectCalendarInfoInternationalModel(Locale) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
指定された言語に該当するカレンダーが保有するデータの国際化モデルを取得します。
selectCategoryDetailInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
指定された言語に該当する分類区分詳細の国際化モデルを取得します。
selectCateogryClassInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
指定された言語に該当する分類区分の国際化モデルを取得します。
selectCompanyPostTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel のメソッド
指定された言語に該当する役職の期間国際化モデルを取得します。
selectCompanyPostTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
指定された日付に該当する役職の期間化モデルを取得します。
selectDealDetailTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
指定された日付に該当する取扱詳細の期間化モデルを取得します。
selectDealTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
指定された日付に該当する取扱の期間化モデルを取得します。
selectDepartmentAttachTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
指定された日付に該当する組織所属の期間化モデルを取得します。
selectDepartmentMainTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
指定された日付に該当する主所属の期間化モデルを取得します。
selectDepartmentTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
指定された言語に該当する組織の期間国際化モデルを取得します。
selectDepartmentTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
指定された日付に該当する組織の期間化モデルを取得します。
selectInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定された言語に該当する国際化モデルを取得します。
selectItemAttributeInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel のメソッド
指定された言語に該当する商品属性の国際化モデルを取得します。
selectItemCategoryInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
指定された言語に該当する商品カテゴリの国際化モデルを取得します。
selectItemTemplateDetailInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
指定された言語に該当する商品属性テンプレート明細の国際化モデルを取得します。
selectItemTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
指定された言語に該当する商品の期間国際化モデルを取得します。
selectItemTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
指定された日付に該当する商品の期間化モデルを取得します。
selectMenuInternationalModel(Locale) - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
指定された言語に該当するメニュー情報の国際化モデルを取得します。
selectPublicGroupTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
指定された言語に該当するパブリックグループの期間国際化モデルを取得します。
selectPublicGroupTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
指定された日付に該当するパブリックグループの期間化モデルを取得します。
selectRoleInternationalModel(Locale) - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
指定された言語に該当するロールの国際化モデルを取得します。
selectTerminableInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
指定された言語に該当する期間国際化モデルを取得します。
selectTerminableModel(Date) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定された日時に該当する期間化モデルを取得します。
selectUserTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
指定された言語に該当するユーザの期間国際化モデルを取得します。
selectUserTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
指定された日付に該当するユーザの期間化モデルを取得します。
send() - interface jp.co.intra_mart.foundation.mail.MailSender のメソッド
メールを送信します。
send() - class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender のメソッド
メールを送信します。
send() - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 指定されたSMTPサーバへメールを送信する。
sendError(int, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
sendError(int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
sendError(HttpServletRequest, ExtendedHttpServletResponse, int, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
sendError(HttpServletRequest, ExtendedHttpServletResponse, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
sendError(HttpServletRequest, ExtendedHttpServletResponse, int, String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
sendError(HttpServletRequest, ExtendedHttpServletResponse, int) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
sendError(HttpServletRequest, ExtendedHttpServletResponse, int, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
sendError(HttpServletRequest, ExtendedHttpServletResponse, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
sendError(int, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このメソッドは、スーパークラスの HttpServletResponseWrapper.sendError(int, java.lang.String) メソッドをそのまま呼び出します。
sendError(int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このメソッドは、スーパークラスの HttpServletResponseWrapper.sendError(int) メソッドをそのまま呼び出します。
sendMessage(String, String, String) - class jp.co.intra_mart.framework.system.log.DefaultLogAgent のメソッド
メッセージを出力します。
sendMessage(String, String, String, Object) - class jp.co.intra_mart.framework.system.log.DefaultLogAgent のメソッド
メッセージを出力します。
sendMessage(String, String, String) - class jp.co.intra_mart.framework.system.log.IntramartLogAgent のメソッド
メッセージを出力します。
sendMessage(String, String, String, Object) - class jp.co.intra_mart.framework.system.log.IntramartLogAgent のメソッド
メッセージを出力します。
sendMessage(String, String, String) - interface jp.co.intra_mart.framework.system.log.LogAgent のメソッド
メッセージを出力します。
sendMessage(String, String, String, Object) - interface jp.co.intra_mart.framework.system.log.LogAgent のメソッド
メッセージを出力します。
sendRedirect(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。
sendRedirect(HttpServletRequest, ExtendedHttpServletResponse, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。
sendRedirect(HttpServletRequest, ExtendedHttpServletResponse, String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。
sendRedirect(HttpServletRequest, ExtendedHttpServletResponse, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。
sendRedirect(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このメソッドは、スーパークラスの HttpServletResponseWrapper.sendRedirect(java.lang.String) メソッドをそのまま呼び出します。
serverTime() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
サーバのミリ秒で表される現在の時間を返します。
service() - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
入力に対する処理を実行します。
service() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
入力に対する処理を実行します。
sessionContext - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean の変数
セッションコンテキスト
sessionCreated(HttpSessionEvent) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener のメソッド
セッションが作成されたことを通知します。
sessionDestroyed(HttpSessionEvent) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener のメソッド
セッションが無効になったことを通知します。
set(int, Object) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リストの指定された位置にある要素を、指定された要素で置き換えます。
set(String, Number) - class jp.co.intra_mart.foundation.acssecurity.Logingp のメソッド
推奨されていません。 代替えメソッドはありません。
set(String, String) - class jp.co.intra_mart.foundation.acssecurity.Logingp のメソッド
推奨されていません。 代替えメソッドはありません。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel のメソッド
指定の属性に値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel のメソッド
指定の属性に値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel のメソッド
指定の属性に値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel のメソッド
指定の属性に値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性に値を設定します。
set(String, Object, Date) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性に、指定の日時で値を設定します。
set(String, Object, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性に、指定の言語で値を設定します。
set(String, Object, Date, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性に、指定の日時、言語で値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のメソッド
指定の属性に値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のメソッド
指定の属性に値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
指定の属性に値を設定します。
set(String, Object, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
指定の属性に値を設定します。
set(int, Object) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リストの指定された位置にある要素を、指定された要素で置き換えます。
setAbart(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
承認タイプを設定します。
setAbcId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ABC 区分を設定します。
setAbrli(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
内部納入日程番号を設定します。
setAcIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
レコード番号を設定します｡
setAccept(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性acceptの値を設定します。
setAcceptcharset(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性accept-charsetの値を設定します。
setAccessControlEnabled(String, boolean) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
メニューアイテムに対するアクセス権を設定します。
setAccessControlEnabled(String, boolean) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニューアイテムに対するアクセス権を設定します。
setAccessControllerId(String) - class jp.co.intra_mart.foundation.security.access.AccessController のメソッド
コントローラＩＤを設定します。
setAccessControllerName(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel のメソッド
アクセスコントローラ名を設定します。
setAccessInfo(EventAccessInfo) - class jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem のメソッド

setAccessSeq(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
検索順序 - 検索番号を設定します。
setAccessSeq(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
検索順序 - 検索番号を設定します。
setAccesskey(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
accesskeyを設定します。
setAccesskey(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
accesskeyを設定します。
setAccntAsgn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先の勘定設定グループを設定します。
setAccntAsgn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAccntAsgn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先の勘定設定グループを設定します。
setAccntAsgn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAccount(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 AccountManager.importData(String category, InputStream inputStream)に置き換えられました。
setAccount(String) - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler のメソッド
アカウントＩＤを設定します。
setAccountFlag(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
このメソッドはシステム内で使用されます。
setAccountFlag(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
アカウントフラグを設定します。
setAccountGlList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細一覧を設定します｡
setAccountKe(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
勘定キー 見越/引当を設定します。
setAccountPayableList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細一覧を設定します｡
setAccountTaxList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
税明細一覧を設定します｡
setAccountView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
会計ビューを設定します。
setAccountView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
会計ビューを設定します。
setAccountView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
会計ビューを設定します。
setAccountkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
勘定キーを設定します。
setAccruals(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
見越額関連条件 (運賃など)を設定します。
setAccruals(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
見越額関連条件 (運賃など)を設定します。
setAcctAssgt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目の勘定設定グループを設定します。
setAcctasgnmt(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目の勘定設定グループを設定します。
setAcctasscat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
勘定設定カテゴリを設定します。
setAcctstatus(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
会計への転記ステータスを設定します。
setAcknReqd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買発注請求書依頼を設定します。
setAcknowlNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買発注請書番号を設定します。
setActAtCus(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
得意先での自社勘定コードを設定します。
setActAtVen(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
仕入先での自社勘定コードを設定します。
setActivity(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ネットワーク/標準ネットワークの活動番号を設定します。
setActivity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
作業番号を設定します。
setActivity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
処理タイプ - R/3 Enterprise で使用不可能を設定します。
setActivity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
作業番号を設定します。
setActivity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
作業番号を設定します。
setActivityCosts(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の原価を設定します。
setActtype(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動タイプを設定します。
setActtype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
活動タイプを設定します。
setActtype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
活動タイプを設定します。
setActtype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
活動タイプを設定します。
setActualCost(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
実際原価を設定します。
setActualDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
実績日付(マイルストーン通過)を設定します。
setActualFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
実績終了日: 実行 (日付)を設定します。
setActualStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
実績開始日: 実行 (日付)を設定します。
setActualTime(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
実績日/時間(マイルストーン適合)を設定します。
setAddToStk(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
既存在庫への追加許可を設定します。
setAddValDy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
有効日からの日数を設定します。
setAddValDy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAddValDy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
有効日からの日数を設定します。
setAddValDy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAddrLink(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
住所コードへのリンクを設定します。
setAddrNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
アドレス番号を設定します。
setAddrNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
アドレス番号を設定します。
setAddrNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
アドレス: アドレス番号を設定します。
setAddrNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
アドレス番号を設定します。
setAddrOrig(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
コピー元住所を設定します。
setAddrType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
アドレスタイプ (1=組織、2=個人、3=取引先担当者)を設定します。
setAddress(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
住所を設定します。
setAddress(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を設定します。
setAddress(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を設定します。
setAddress(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を設定します。
setAddress(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を設定します。
setAddress(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
住所を設定します。
setAddress(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
住所を設定します。
setAddress(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
住所を設定します。
setAddress(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
住所を設定します。
setAddress(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
住所を設定します。
setAddress(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
住所を設定します。
setAddress1(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
住所1を設定します。
setAddress1(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
住所1を設定します。
setAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を設定します。
setAddress1(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を設定します。
setAddress1(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を設定します。
setAddress1(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を設定します。
setAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
住所1を設定します。
setAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所1を設定します。
setAddress1(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所1を設定します。
setAddress2(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
住所2を設定します。
setAddress2(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
住所2を設定します。
setAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を設定します。
setAddress2(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を設定します。
setAddress2(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を設定します。
setAddress2(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を設定します。
setAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
住所2を設定します。
setAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所2を設定します。
setAddress2(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所2を設定します。
setAdrNotes(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
住所注記を設定します。
setAdrNotes(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
住所注記を設定します。
setAdrNotes(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
住所注記を設定します。
setAgmtItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買契約の明細番号を設定します。
setAgreement(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買契約番号を設定します｡
setAgreement(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買契約番号を設定します。
setAll(TreeBranch) - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
指定された branch 内の表示名称、ポップアップ文字列、引数文字列をこのオブジェクトに設定します。
setAllVersionsList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
全バージョン一覧を設定します｡
setAllocTbl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
商品配分表番号を設定します。
setAllowedBusTractList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
使用可能業務トランザクションのテーブルを設定します。
setAllowedBusTractList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
使用可能業務トランザクションのテーブルを設定します。
setAllowedWt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
許容梱包重量を設定します。
setAllowsUsers(String[]) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のメソッド
許可ユーザを設定します。
setAllwdVol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
許容梱包容積を設定します。
setAlphaFact(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
アルファ係数使用による基本値の平滑化を設定します。
setAltBomId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
代替 BOM 選択の方法を設定します。
setAltPayee(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
代理受取人勘定コードを設定します。
setAltPayer(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
代理支払人の勘定コードを設定します。
setAltToItm(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
代替明細を設定します。
setAltToItm(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAltUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
在庫保管単位の代替数量単位を設定します。
setAltUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ISO コードによる在庫単位の代替数量単位を設定します。
setAlternBom(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
代替 BOMを設定します。
setAlternBom(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAlternat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
代替明細を設定します。
setAlternativeBom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
代替 BOMを設定します。
setAlttaxCls(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
代替税分類を設定します。
setAlttaxCls(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAmount(int) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail のメソッド
数量を設定します。
setAmount(int) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
数量を設定します。
setAmount(int, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
数量を設定します。
setAmount(int) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailTerminableModel のメソッド
数量を設定します。
setAmountLc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
マニュアル入力による転記金額 (国内通貨)を設定します。
setAmountLc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
マニュアル入力による転記金額 (国内通貨)を設定します。
setAmountSv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
外部入力による販売金額 (国内通貨)を設定します。
setAmountSv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
外部入力による販売金額 (国内通貨)を設定します。
setAnswer(String) - class jp.co.intra_mart.foundation.navigator.EventHistoryInfo のメソッド
質問設定
setAnswer(String) - class jp.co.intra_mart.foundation.navigator.SaveEventHistoryInfo のメソッド
質問設定
setAppName(String) - class jp.co.intra_mart.foundation.security.activesession.NavigatorInfo のメソッド
ブラウザ名を取得します。
setAppdBRec(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: バッチ製造記録の承認必須を設定します。
setApplicBy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積提出期限を設定します。
setApplicant(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請者を設定します。
setApplicantNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
申請者番号を設定します。
setApplicantNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
申請者番号を設定します。
setApplicantPhone(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請者の電話番号を設定します。
setApplicatio(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
アプリケーションを設定します。
setApplicatio(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
アプリケーションを設定します。
setApplication(String) - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
アプリケーション名を設定します。
setApplication(String) - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
実行するフレームワークのアプリケーションＩＤを設定します。
setApplication(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性applicationの値を設定します。
setApplication(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
アプリケーションを設定します。
setApplication(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
アプリケーションを設定します。
setApplication(String) - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
applicationを設定します。
setApplication(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
アプリケーションを設定します。
setApplication(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性applicationの値を設定します。
setApplicationDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請日を設定します。
setApplicationId(String) - class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet のメソッド
アプリケーションIDを設定します。
setApplobject(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
テキスト: アプリケーションオブジェクトを設定します。
setApplobject(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
テキスト: アプリケーションオブジェクトを設定します。
setApplobject(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
テキスト: アプリケーションオブジェクトを設定します。
setArgument(String) - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
引数文字列を設定します。
setArgument(String) - class jp.co.intra_mart.foundation.page.TreeLeaf のメソッド
マウスクリックイベント発生時に実行される任意の Client Side JavaScript 関数に渡される引数文字列を設定します。
setArgument(String) - class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet のメソッド
ページ引数を設定します。
setArgument(String) - class jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet のメソッド
ページ引数を設定します。
setArgument(String, String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
引数を設定します。
setArgumentValue(String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel のメソッド
引数値を設定します。
setAshost(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing のメソッド
接続先アプリケーションサーバIPアドレスを設定します。
setAshost(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 接続先サーバIPアドレスを設定します｡
setAssNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
割当番号を設定します。
setAssNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAssetNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
資産番号を設定します。
setAssetNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
資産番号を設定します。
setAssetNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
資産番号を設定します。
setAssortMod(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品揃モジュールを設定します。
setAssortMod(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAssyScrap(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
組立不良率を設定します。
setAtItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
割当テーブルの明細番号を設定します。
setAtRelev(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
適当テーブル関連を設定します。
setAtpWrkmod(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
ATP セッション: 結果取得/新規決定 APO-ATPを設定します。
setAttemptOnFailedAuthentication(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
LDAP認証失敗(ユーザIDまたはパスワードが不正)時に次のプロバイダURLに認証の試みを設定する。
setAttribute(ItemAttribute) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
商品属性情報を設定します。
setAttribute(String, Object) - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
セッションから指定した属性に値を保管します。
setAttribute(String, String, String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウント属性情報を設定する。
setAttribute(String, String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント属性情報を設定する。
setAttribute(String, String, String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウント属性情報を設定する。
setAttribute(String, Object) - class jp.co.intra_mart.framework.base.session.HttpSessionObject のメソッド
推奨されていません。 指定された名前に対応するオブジェクトを追加します。
setAttribute(String, Object) - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のメソッド
推奨されていません。 指定された名前に対応するオブジェクトを追加します。
setAttribute(String, Object) - interface jp.co.intra_mart.framework.base.session.SessionObject のメソッド
指定された名前に対応するオブジェクトを追加します。
setAttributeValue(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel のメソッド
属性値を設定します。
setAuthCcNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認番号を設定します。
setAuthDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 承認日を設定します。
setAuthDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認日を設定します。
setAuthFlag(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 振替権限を設定します。
setAuthFlag(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 振替権限を設定します。
setAuthRefno(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 決済代行会社の権限参照コードを設定します。
setAuthRefno(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 決済代行会社の権限参照コードを設定します。
setAuthTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 承認時刻を設定します。
setAuthTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認時刻を設定します。
setAuthamount(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 承認額を設定します。
setAuthamount(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認額を設定します。
setAuthor(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
報告書提案済を設定します。
setAuthor(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
報告書提案済を設定します。
setAuthor(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
報告書提案済を設定します。
setAuthoritygroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
権限グループを設定します。
setAutoCommit(boolean) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。
setAutoCommitConditions(List) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
推奨されていません。 BapiController.setIgnoreErrMsgReturnTypes(java.util.List)に置き換えられました。
setAutoPOrd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: "購買発注自動生成"を設定します。
setAutoReset(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
予測モデル自動リセットを設定します。
setAvQtyPlt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
プラントレベル利用可能数量を設定します。
setAvailCheckAllProjSegments(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プロジェクト間品目区分を設定します。
setAvailcheck(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
利用可能在庫確認の確認グループを設定します。
setBUomIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
ISO コードでの基本数量単位を設定します。
setBaList(BankList) - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
銀行一覧を設定します｡
setBackflush(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: バックフラッシュを設定します。
setBankAcct(String) - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
口座番号を設定します。
setBankCtry(String) - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
銀行国コードを設定します。
setBankDataInfoList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
銀行データ情報を設定します｡
setBankDataInfoList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
銀行データ情報を設定します｡
setBankDataInfoList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
銀行データ情報を設定します｡
setBankDataInfoList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
銀行データ情報を設定します｡
setBankDataInfoList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
銀行データ情報を設定します｡
setBankDataInfoList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
銀行データ情報を設定します｡
setBankKey(String) - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
銀行コードを設定します。
setBankKey(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
銀行コードを設定します｡
setBankList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.BankList のメソッド
銀行一覧を設定します｡
setBankName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
銀行名を設定します｡
setBankRef(String) - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
銀行詳細の参照詳細を設定します。
setBapiHashList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
BapiHashの一覧を設定します｡
setBapiReturnList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
BapiReturnの一覧を設定します｡
setBarCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
バーコードエントリを設定します。
setBaseAccessor(BaseAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
基本アクセサを設定します。
setBaseDn(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
ベースDNを設定する。
setBaseName(String) - class jp.co.intra_mart.foundation.datastore.exception.MapperException の static メソッド
リソースバンドルの基底名を設定します。
setBaseQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
基本数量を設定します。
setBaseQtyPlan(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出荷の能力計画のための基本数量を設定します。
setBaseUom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
基本数量単位を設定します。
setBaseUom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
基本数量単位を設定します。
setBaseUom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
基本数量単位を設定します。
setBaseUom(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
基本数量単位を設定します。
setBaseUomIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードでの基本数量単位を設定します。
setBasicLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
基本明細を設定します。
setBasicMatl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
主構成物質を設定します。
setBasicValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
基準値を設定します。
setBasicValue1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
第二指図の基準値を設定します。
setBasicValue2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
第二指図の基準値を設定します。
setBasicValuePp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間の基準値を設定します。
setBasicValuePp1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間における第二指図の基準値を設定します。
setBasicValuePp2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間における第二指図の基準値を設定します。
setBasicView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
基本データビューを設定します。
setBaslineNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
代替: 基本明細参照を設定します。
setBatch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ロット番号を設定します。
setBatch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
ロット番号を設定します。
setBatch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
ロット番号を設定します。
setBatch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
ロットを設定します。
setBatch(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ロット番号を設定します。
setBatch(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBatch(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
ロット番号を設定します。
setBatchId(String) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチＩＤを設定します。
setBatchMgmt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ロット管理所要量区分を設定します。
setBatchMgmt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ロット管理所要量区分を設定します。
setBatchName(String) - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
バッチ名を設定します。
setBatchRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
ロットの範囲を設定します。
setBatchentry(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造/プロセス指図でのロット入力設定を設定します。
setBcc(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 Bccをセットする。
setBcc(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 Bccをセットする。
setBdcnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
5 文字数値 NUMCを設定します。
setBegdemPer(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
見越期間の提案開始日付を設定します。
setBegdemPer(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBegintime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
開始時刻を設定します。
setBehaveWhenError(String) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
エラー処理を設定します。
setBehaveWhenError(String) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
エラー処理を設定します。
setBehaveWhenError(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
エラー処理を設定します。
setBetaFact(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
ベータ係数による傾向値平準化を設定します。
setBidder(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入札者の明細を設定します。
setBidinvNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積管理番号を設定します。
setBilForm(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求書式を設定します。
setBilForm(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBillBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売管理伝票の請求ブロックを設定します。
setBillBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBillBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ブロックを設定します。
setBillBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBillBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売管理伝票の請求ブロックを設定します。
setBillDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
請求索引および印刷に対する請求日を設定します。
setBillDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
請求索引および印刷に対する請求日を設定します。
setBillDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBillDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求索引および印刷に対する請求日を設定します。
setBillDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBillDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
請求伝票を設定します。
setBillDocItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
請求伝票明細を設定します。
setBillOfLading(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入庫時に登録した B/L 番号を設定します。
setBillOfLadingLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入庫の船荷証券番号 (依存: テキスト (長) 参照)を設定します。
setBillPlan(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
請求計画番号を設定します。
setBillPlani(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
明細: 請求計画/支払計画/支払カードを設定します。
setBillRel(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求関連 (CRM)を設定します。
setBillRel(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBillSched(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
請求日程 (稼働日カレンダ指定)を設定します。
setBillSched(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBillSched(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求日程 (稼働日カレンダ指定)を設定します。
setBillSched(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBillTo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
請求先を設定します。
setBillType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
請求タイプを設定します。
setBillValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
請求金額: 請求計画に請求日付が指定されている場合を設定します。
setBillamount(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
請求金額: 請求計画に請求日付が指定されている場合を設定します。
setBillcateg(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
請求カテゴリを設定します。
setBillingDataInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
処理予定明細データのテーブルを設定します。
setBillingDocumentDetail(BillingDocumentDetail) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController のメソッド
請求伝票に関する詳細情報を設定します。
setBillingDocumentDetail(BillingDocumentDetail) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail のメソッド
請求伝票に関する詳細情報を設定します。
setBillingDocumentDetailListList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
後続請求伝票のテーブルを設定します。
setBillingdoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
請求伝票を設定します。
setBillingdocument(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail のメソッド
処理予定の請求伝票数を設定します。
setBinaryRelationshiptype(String) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
バイナリ関連タイプ (専用)を設定します。
setBinaryRelationshiptype(String) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
バイナリ関連タイプ (専用)を設定します。
setBinaryRelationshiptype(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
バイナリ関連タイプ (専用)を設定します。
setBindgPer(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積有効期間を設定します。
setBlanket(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
包括明細を設定します。
setBlockStge(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
平置保管域区分を設定します。
setBody(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 本文をセットする。
setBomUsage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
BOM 用途を設定します。
setBomexplNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
BOM 展開番号を設定します。
setBomexplNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBonGrp1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
決済グループ1を設定します。
setBonGrp2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
決済グループ 2 (リベート決済、購買)を設定します。
setBonGrp3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
決済グループ 3 (リベート決済、購買)を設定します。
setBrasNbm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
Brazilian NCM Codeを設定します。
setBudgetProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
予算プロファイルを設定します。
setBufferSize(int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。
setBufferSize(HttpServletRequest, ExtendedHttpServletResponse, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。
setBufferSize(HttpServletRequest, ExtendedHttpServletResponse, int) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。
setBufferSize(HttpServletRequest, ExtendedHttpServletResponse, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。
setBuildLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
建物 (番号またはコード)を設定します。
setBuildLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
建物 (番号またはコード)を設定します。
setBuildLong(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
建物 (番号またはコード)を設定します。
setBuilding(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
旧: 建物 (番号または略称)を設定します。
setBuilding(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
旧: 建物 (番号または略称)を設定します。
setBuilding(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
旧: 建物 (番号または略称)を設定します。
setBulkMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: バルク品目を設定します。
setBusArDes(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のメソッド
事業領域名を設定します｡
setBusArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のメソッド
事業領域を設定します｡
setBusArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
事業領域を設定します。
setBusArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
事業領域を設定します。
setBusArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
事業領域を設定します。
setBusArea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
事業領域を設定します。
setBusAreaList(BusinessAreaList) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のメソッド
事業領域一覧を設定します｡
setBusTranst(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
貿易管理の取引タイプを設定します。
setBusTranst(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBusinessAreaList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList のメソッド
事業領域一覧を設定します｡
setBusinessTransactionType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
貿易管理の取引タイプを設定します。
setBuspartno(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
取引先の仕入先マスタコードを設定します。
setBuyingGrp(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
購買グループの勘定コードを設定します。
setBwdCons(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費期間: 後方を設定します。
setCCardDataInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
処理予定支払方法のテーブルを設定します。
setCOName(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
気付を設定します。
setCOName(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
気付を設定します。
setCOName(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
気付を設定します。
setCacheConfig(int) - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
キャッシュ時間を設定します。
setCadId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
CAD 区分を設定します。
setCalcMotive(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
計算区分を設定します。
setCalcMotive(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
計算区分を設定します。
setCalctypcon(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件計算タイプを設定します。
setCalctypcon(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件計算タイプを設定します。
setCalctype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
価格設定タイプを設定します。
setCalendar(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
稼動日カレンダを設定します。
setCalendar(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
稼動日カレンダを設定します。
setCampaign(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
総括プロジェクト計画: 外部 R/3 システムの GUIDを設定します。
setCampaign(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCampaign(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
総括プロジェクト計画: 外部 R/3 システムの GUIDを設定します。
setCampaign(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCancelled(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
中止区分を設定します。
setCapacity(int) - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のメソッド
キューの容量を変更します。
setCapacity(int) - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 キューの容量を変更します。
setCaption(String[]) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
ｘ軸のキャプションを設定します。
setCaption(String) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
キャプション文字列を返します。
setCaption(String[]) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
ｘ軸のキャプションを設定します。
setCaption(String[]) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
ｘ軸のキャプションを設定します。
setCaption(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
キャプションを格納します。
setCaptionColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
キャプションの文字色を設定します。
setCaptionColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
キャプションの文字色を設定します。
setCaptionColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
キャプションの文字色を設定します。
setCaptionColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
キャプションの文字色を設定します。
setCaptionMargin(int) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
キャプション表示位置のマージンを設定します。
setCaptionMargin(int) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
キャプション表示位置のマージンを設定します。
setCapyUsage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
保管容量使用を設定します。
setCasNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
CAS 番号： 薬事品目 - 貿易を設定します。
setCashDisc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
現金値引区分を設定します。
setCashDisc1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
割引率 1を設定します。
setCashDisc2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
割引率 2を設定します。
setCatalog(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection のデータベースに作業のためのサブスペースを選択するために、カタログ名を設定します。
setCatalogue(ItemCatalogue) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
商品カタログ情報を設定します。
setCatalogue(ItemCatalogue, byte[]) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
商品カタログ情報を設定します。
setCategory(String) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
新着情報のカテゴリ名を設定します。
setCategory(String) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロールカテゴリを設定します。
setCategory(String) - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
カテゴリを設定します。
setCategoryClassCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
分類区分コードを設定します。
setCategoryClassCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
分類区分コードを設定します。
setCategoryClassCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
分類区分コードを設定します。
setCategoryClassCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
分類区分コードを設定します。
setCategoryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
分類コードを設定します。
setCategoryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
分類コードを設定します。
setCategoryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
分類コードを設定します。
setCategoryDetail(CompanyCategory) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織に対して指定された分類区分情報を設定します。
setCategoryDetail(PublicGroupCategory) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループに対して指定された分類区分情報を設定します。
setCatprofile(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
カタログプロファイルを設定します。
setCbaseId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
インスタンス番号 (固定)を設定します。
setCbaseIdType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
インスタンス番号タイプ (固定)を設定します。
setCc(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 Ccをセットする。
setCc(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 Ccをセットする。
setCcAuthNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 承認番号を設定します。
setCcFixed(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
循環棚卸区分固定を設定します。
setCcLocId(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: トランザクション (入庫時点)を設定します。
setCcName(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: カード所有者の氏名を設定します。
setCcName(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: カード所有者の氏名を設定します。
setCcNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: カード番号を設定します。
setCcNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: カード番号を設定します。
setCcPhInv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
循環棚卸の実地棚卸区分を設定します。
setCcReAmount(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
BAPI インタフェースの通貨金額を設定します。
setCcReact(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 権限確認に対する応答を設定します。
setCcReactT(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 結果テキストを設定します。
setCcSeqNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 支払カード - 接尾辞を設定します。
setCcSettled(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 決済終了を設定します。
setCcStatEx(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 外部システム呼出時のステータスを設定します。
setCcType(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カードタイプ: カードタイプを設定します。
setCcType(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カードタイプ: カードタイプを設定します。
setCcValidF(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 使用有効開始日付を設定します。
setCcValidT(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 有効終了日を設定します。
setCcValidT(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 有効終了日を設定します。
setCctrPosted(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
原価が実際に転記された原価センタを設定します。
setCdUntIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件数量単位 (ISO コード)を設定します。
setCdUntIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
条件数量単位 (ISO コード)を設定します。
setCdUntIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
条件数量単位 (ISO コード)を設定します。
setCertType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
証明書タイプを設定します。
setCfginfo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
CU: 選定の BLOB (SCE)を設定します。
setCfopCode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
CFOP code and extension (old 5 char version)を設定します。
setCfopCode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCfopLong(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
CFOP code and extensionを設定します。
setChangeId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
変更タイプ(U、I、E、D)を設定します。
setChangeNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
変更番号を設定します。
setChangedBy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
オブジェクトの変更者名を設定します。
setCharUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
特性の数量単位を設定します。
setCharUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
下位レベル数量単位 (ISO コード)を設定します。
setCharacterEncoding(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
このオブジェクトが対象とする文字エンコーディングを設定します。
setCharacterEncoding(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
パラメータを符号化するためのエンコーディング名を指定します。
setCharacterEncoding(String) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 このオブジェクトが対象とする文字エンコーディングを設定します。
setCharc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
特性名を設定します。
setCharcTxt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
言語依存特性テキストを設定します。
setCharset(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
charsetを設定します。
setChckstatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村ファイルテストステータスを設定します。
setChckstatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村ファイルテストステータスを設定します。
setChckstatus(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村ファイルテストステータスを設定します。
setCheckReturn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のメソッド
結果を設定します｡
setCheckReturn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController の static メソッド
結果を設定します｡
setCheckRule(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
確認規則を設定します。
setChkprtauth(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
取引先権限チェックを設定します。
setChkprtauth(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCity(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
市区町村を設定します。
setCity(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
市区町村名を設定します｡
setCity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村を設定します。
setCity(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
市区町村を設定します。
setCity(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村を設定します。
setCity(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
市区町村を設定します。
setCityCode(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
市区町村コードを設定します
setCityNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村/地名ファイルの市区町村コードを設定します。
setCityNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村/地名ファイルの市区町村コードを設定します。
setCityNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村/地名ファイルの市区町村コードを設定します。
setClIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
レコード番号を設定します｡
setClass(String) - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag のメソッド
推奨されていません。 このメソッドではなくHelperBeanTag.setHelperclass(java.lang.String)メソッドを使用してください。
setClassType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
クラスタイプを設定します。
setClassType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
クラスタイプを設定します。
setClerk(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
記帳担当者を設定します。
setClient(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
クライアントを設定します。
setClient(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
クライアントを設定します。
setClient(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 クライアントを設定します｡
setClientData(ClientData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目データ (クライアントレベル)を設定します。
setClientDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目データ (クライアントレベル)を設定します。
setClientType(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
クライアントタイプを設定する。
setClientType(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
クライアントタイプを設定します。
setClientType(String) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
クライアントタイプを設定する。
setClientType(String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
クライアントタイプを設定します。
setClosed() - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
このアクセサをクローズします。
setClosedBox(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
完了した梱包材を設定します。
setCmRelevanceFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
構成管理関連を設定します。
setCmlqtyDat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
累積出荷数量日付を設定します。
setCmlqtyDat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCmmtItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
資金予算コードを設定します。
setCmmtItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
資金予算コードを設定します。
setCmmtItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
資金予算コードを設定します。
setCmmtItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
資金予算コードを設定します。
setCmmtItemLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
資金予算コードを設定します。
setCmmtItemLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
資金予算コードを設定します。
setCmmtItemLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
資金予算コードを設定します。
setCmmtItemLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
資金予算コードを設定します。
setCntrlInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
購買伝票タイプに対する管理区分を設定します。
setCoArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のメソッド
管理領域を設定します｡
setCoArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
管理領域を設定します。
setCoArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
管理領域を設定します。
setCoArea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
管理領域を設定します。
setCoBusproc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
業務プロセスを設定します。
setCoBusproc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
業務プロセスを設定します。
setCoBusproc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
業務プロセスを設定します。
setCoCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
会社コードを設定します。
setCoIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
レコード番号を設定します｡
setCoProduct(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: 連産品としても使用可能な品目を設定します。
setCoProduct(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 連産品としても使用可能な品目を設定します。
setCode(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
コードを設定します｡
setCoeffTheil(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
タイル係数を設定します。
setCollAuth(String) - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
フラグ: 回収権限を設定します。
setCollNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
一括番号を設定します。
setCollectNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
一括番号を設定します。
setCollectNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
一括番号を設定します。
setCollectNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
棒の色を設定します。
setColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
線の色を設定します。
setColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
描画する点の色を設定します。
setColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
グラフ線の色を設定します。
setColor(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
色を設定します。
setColor(String) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
表示色を設定します。
setColorPatternID(String) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
カラーパターンIDを設定する。
setColorPatternId(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
カラーパターンIDを設定します。
setColorPatternId(String) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
カラーパターンIDを設定します。
setColorPatternId(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
ページカラーパターンを設定します。
setColumnName(String) - class jp.co.intra_mart.foundation.database.DatabaseColumn のメソッド

setColumnType(int) - class jp.co.intra_mart.foundation.database.DatabaseColumn のメソッド

setColumnsInfo(DatabaseColumn[]) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。
setComDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
確認日を設定します。
setComQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
確認数量を設定します。
setCommCoUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
物品コード (貿易) の数量単位を設定します。
setCommCoUnIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ISO コードによる物品コード (貿易管理) の数量単位を設定します。
setCommCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
貿易: 統計品目コード/輸入コード番号を設定します。
setCommCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
貿易: 統計品目コード/輸入コード番号を設定します。
setCommGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
手数料グループを設定します。
setCommType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
通信方法 (キー) (アドレス管理)を設定します。
setCommType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
通信方法 (キー) (アドレス管理)を設定します。
setCommType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
通信方法 (キー) (アドレス管理)を設定します。
setComment(String) - class jp.co.intra_mart.foundation.navigator.TitleInfo のメソッド
コメント設定
setCommitCount(ImportManager, ImportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
インポート設定に定義されたインポートデータのコミット間隔をマネージャーに設定します。
setCommitCount(int) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManager のメソッド
コミット間隔を設定します。
setCommitCount(int) - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl のメソッド
コミット間隔を設定します。
setCommitCount(int) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager のメソッド

setCommitCount(int) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager のメソッド

setCommitCount(int) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager のメソッド

setCommitCount(int) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager のメソッド

setCommitCount(int) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager のメソッド

setCommprice1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
商法による評価額: レベル 1を設定します。
setCommprice2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
商法による評価額: レベル 2を設定します。
setCommprice3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
商法基準評価額: レベル 3を設定します。
setCompCdeB(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
請求対象会社コードを設定します。
setCompCdeB(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCompCode(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
会社コードを設定します。
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Company のメソッド
会社コードを設定します｡
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
会社コードを設定します。
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
会社コードを設定します。
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
会社コードを設定します。
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
会社コードを設定します｡
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
会社コードを設定します｡
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のメソッド
会社コードを設定します｡
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のメソッド
会社コードを設定します｡
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
会社コードを設定します｡
setCompList(CompanyList) - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のメソッド
会社一覧を設定します｡
setCompName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Company のメソッド
会社名を設定します｡
setCompQuant(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
構成品目数量を設定します。
setCompQuant(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCompScrap(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
構成品目不良率を設定します。
setCompShip(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
出荷指示順守を設定します。
setCompShip(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷指示順守を設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment のメソッド
会社コードを設定します。
setCompanyCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
会社コードを設定します。
setCompanyCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
会社コードを設定します。
setCompanyCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
会社コードを設定します｡
setCompanyDataInfo(CompanyDataInfo) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
会社依存データ情報を設定します｡
setCompanyDataInfo(CompanyDataInfo) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
会社依存データ情報を設定します｡
setCompanyDataInfo(CompanyDataInfo) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
会社依存データ情報を設定します｡
setCompanyDataInfo(CompanyDataInfo) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
会社依存データ情報を設定します｡
setCompanyDataInfo(CompanyDataInfo) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
会社依存データ情報を設定します｡
setCompanyDataInfo(CompanyDataInfo) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
会社依存データ情報を設定します｡
setCompanyList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList のメソッド
会社一覧を設定します｡
setCompanycode(String) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
会社コードを設定します｡
setCompanycode(String) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
会社コードを設定します｡
setCompanycode(String) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
会社コードを設定します｡
setCompanycode(String) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
会社コードを設定します｡
setCompanycode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
会社コードを設定します。
setCompetitor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
競合会社を設定します。
setComplDlv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
全購買発注に対する一括納入指定を設定します。
setComplDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
一括納入区分を設定します。
setComplDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setComplete(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最終確認の有効化を設定します。
setComplete(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
一般区分を設定します。
setComplete(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
一般区分を設定します。
setCompleted(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
ステータス "バージョン完了済"を設定します。
setCompleted(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
ステータス "バージョン完了済"を設定します。
setComponentId(String) - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject のメソッド
コンポーネントIDを設定します。
setConExist(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
基本契約明細の制限を設定します。
setConItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
明細番号、契約を設定します。
setConLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: 基本契約の計画外を設定します。
setConNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
基本契約番号を設定します。
setConPckg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: 基本契約の計画外を設定します。
setConbaseval(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件基礎値を設定します。
setConbaseval(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件基礎値を設定します。
setCondCount(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件カウンタを設定します。
setCondCount(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件カウンタを設定します。
setCondCount(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
条件連続番号を設定します。
setCondCount(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
条件カウンタを設定します。
setCondCurr(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
条件通貨 (累積項目用)を設定します。
setCondDUnt(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
伝票の条件単位を設定します。
setCondGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先条件グループを設定します。
setCondHandl(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
選択: 条件行処理 (SD 伝票変更)を設定します。
setCondHeaderList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
条件ヘッダ一覧を設定します｡
setCondItemList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
条件明細一覧を設定します｡
setCondNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件レコード番号を設定します。
setCondNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件レコード番号を設定します。
setCondNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
伝票条件番号を設定します。
setCondPUnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
価格条件単位を設定します。
setCondPUnt(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
価格条件単位を設定します。
setCondPUnt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
価格条件単位を設定します。
setCondPUnt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCondPUnt(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
価格条件単位を設定します。
setCondPUnt(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
価格条件単位を設定します。
setCondStNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
ステップ番号を設定します。
setCondStNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
ステップ番号を設定します。
setCondStNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
ステップ番号を設定します。
setCondStNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
ステップ番号を設定します。
setCondType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件タイプを設定します。
setCondType(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
条件タイプを設定します。
setCondType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件タイプを設定します。
setCondType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
条件タイプを設定します。
setCondType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
条件タイプを設定します。
setCondUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件単位を設定します。
setCondUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件単位を設定します。
setCondUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCondUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
条件単位を設定します。
setCondUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
条件単位を設定します。
setCondUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件数量単位 (ISO コード)を設定します。
setCondUpdat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件更新を設定します。
setCondUpdat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件更新を設定します。
setCondValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件レートを設定します。
setCondValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
条件金額/率を設定します。
setCondValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件レートを設定します。
setCondValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCondchaman(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件 (マニュアル変更済)を設定します。
setCondchaman(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件 (マニュアル変更済)を設定します。
setCondclass(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件クラスを設定します。
setCondclass(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件クラスを設定します。
setCondcntrl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件管理を設定します。
setCondcntrl(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件管理を設定します。
setCondcoinhd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件カウンタ (ヘッダ条件)を設定します。
setCondconfig(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
システム設定の条件を設定します。
setCondconfig(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
システム設定の条件を設定します。
setCondcount(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件連続番号を設定します。
setCondcount(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件連続番号を設定します。
setCondincomp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
会社間請求の条件を設定します。
setCondincomp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
会社間請求の条件を設定します。
setCondisacti(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
無効条件を設定します。
setCondisacti(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
無効条件を設定します。
setConditemno(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
条件明細番号を設定します。
setConditionDataInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
処理予定条件のテーブルを設定します。
setConditionNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
伝票条件番号を設定します。
setCondorigin(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件生成区分を設定します。
setCondorigin(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件生成区分を設定します。
setCondtype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件カテゴリ (例: 税、運賃、価格、原価)を設定します。
setCondtype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件カテゴリ (例: 税、運賃、価格、原価)を設定します。
setCondvalue(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件金額を設定します。
setConexchrat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
現地通貨への換算レートに対する条件を設定します。
setConexchrat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
現地通貨への換算レートに対する条件を設定します。
setConfCtrl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
確認管理キーを設定します。
setConfMatl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
プラント共通選定可能品目を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のメソッド
外部選定 ID (仮)を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
外部選定 ID (仮)を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
外部選定 ID (仮)を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
外部選定 ID (仮)を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
外部選定 ID (仮)を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
外部選定 ID (仮)を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
外部選定 ID (仮)を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
外部選定 ID (仮)を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setConfigPageCount(String, int) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
履歴表示件数の設定。
setConfigured(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
選定可能品目を設定します。
setConinvolst(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
請求書一覧条件を設定します。
setConinvolst(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
請求書一覧条件を設定します。
setConnectInfo(DataConnector, String, String, String) - interface jp.co.intra_mart.framework.base.data.DAO のメソッド
データリソースに接続する時の情報を設定します。
setConnectInfo(DataConnector, String, String, String) - class jp.co.intra_mart.framework.base.data.DAOAdapter のメソッド
データリソースに接続する時の情報を設定します。
setConnectInfo(DataConnector, String, String, String) - class jp.co.intra_mart.framework.base.data.DBDAO のメソッド
データリソースに接続する時の情報を設定します。
setConnectInfo(DataConnector, String, String, String) - class jp.co.intra_mart.framework.base.data.IntramartDBDAO のメソッド
推奨されていません。 データリソースに接続する時の情報を設定します。
setConnectInfo(DataConnector, String, String, String) - class jp.co.intra_mart.framework.base.data.IntramartFileServerDAO のメソッド
データリソースに接続する時の情報を設定します。
setConnectInfo(DataConnector, String, String, String) - class jp.co.intra_mart.framework.base.data.LoginGroupDBDAO のメソッド
データリソースに接続する時の情報を設定します。
setConnectInfo(DataConnector, String, String, String) - class jp.co.intra_mart.framework.base.data.SystemDBDAO のメソッド
データリソースに接続する時の情報を設定します。
setConnectTimeout(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
接続タイムアウト時間を設定する。
setConnectTimeoutPropertyName(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
接続タイムアウトを設定するプロパティ名を設定する。
setConnectionTimeout(long) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 コネクションのタイムアウトを設定します｡
setConpricdat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件価格設定日付を設定します。
setConpricdat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件価格設定日付を設定します。
setConsValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
消費量を設定します。
setConsValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
消費量を設定します。
setConsistent(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
一般区分を設定します。
setConsistent(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
一般区分を設定します。
setConstraintFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準終了日に対する制約を設定します。
setConstraintFinishDateFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予測終了日付を設定します。
setConstraintFinishTime(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準終了時間を設定します。
setConstraintFinishTimeFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の予測終了時間を設定します。
setConstraintStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準開始日に対する制約を設定します。
setConstraintStartDateFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の予測開始日を設定します。
setConstraintStartTime(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準開始時間の制約を設定します。
setConstraintStartTimeFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の需要予測開始時間を設定します。
setConstraintTypeFinish(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の終了日に対する制約を設定します。
setConstraintTypeFinishFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動終了の制約条件付き需要予測日付を設定します。
setConstraintTypeStart(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準開始日に対する制約を設定します。
setConstraintTypeStartFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動開始の制約条件付き需要予測日付を設定します。
setConsumctry(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
消費者の国キーを設定します。
setConsummode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費モードを設定します。
setContPerc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
価格決定率を設定します。
setContainer(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
容器条件を設定します。
setContentLength(int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
レスポンスのメッセージボディ部分の長さをセットします。
setContentLength(HttpServletRequest, ExtendedHttpServletResponse, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
レスポンスのメッセージボディ部分の長さをセットします。
setContentLength(HttpServletRequest, ExtendedHttpServletResponse, int) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
レスポンスのメッセージボディ部分の長さをセットします。
setContentLength(HttpServletRequest, ExtendedHttpServletResponse, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
レスポンスのメッセージボディ部分の長さをセットします。
setContentLength(int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
レスポンスのメッセージボディ部分の長さをセットします。
setContentType(ContentType) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse のメソッド
レスポンスに Content-Type をセットします。
setContentType(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
クライアントに送り返されるレスポンスのコンテントタイプをセットします。
setContentType(HttpServletRequest, ExtendedHttpServletResponse, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
クライアントに送り返されるレスポンスのコンテントタイプをセットします。
setContentType(HttpServletRequest, ExtendedHttpServletResponse, String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
クライアントに送り返されるレスポンスのコンテントタイプをセットします。
setContentType(HttpServletRequest, ExtendedHttpServletResponse, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
クライアントに送り返されるレスポンスのコンテントタイプをセットします。
setContentType(ContentType) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedServletResponse#setContentType(ContentType) メソッドをそのまま呼び出します。
setContentType(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
クライアントに送り返されるレスポンスのコンテントタイプをセットします。
setContentType(ContentType) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このメソッドは、 type の ContentType.toString() が返す値を ラップしている ServletResponse にセットします。
setContentType(String) - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルのフォーマットを設定します。
setContents(String) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
新着情報の内容を設定します。
setContents(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
コンテンツの種類を設定します。
setContents(String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
コンテンツの種類を設定します。
setContext(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のメソッド
CU: 選定の BLOB (SCE)を設定します。
setContextFactory(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
コンテキストファクトリを設定する。
setContractLimitsList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注基本契約制限一覧を設定します｡
setContractServiceAccountList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注サービス勘定設定一覧を設定します｡
setContractServiceList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注サービス一覧を設定します｡
setContractServiceTextList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注サービステキスト一覧を設定します｡
setControlKey(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
管理キーを設定します。
setControllAreaList(ControllingAreaList) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のメソッド
管理領域一覧を設定します｡
setControllerObject(ControllerObject) - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
コントローラオブジェクトを設定します。
setControllerObject(ControllerObject) - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
コントローラオブジェクトを設定します。
setControllingArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
管理領域を設定します｡
setControllingArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
管理領域を設定します｡
setControllingArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
管理領域を設定します。
setControllingArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
管理領域を設定します。
setControllingArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
管理領域を設定します。
setControllingAreaCurrency(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
通貨コードを設定します。
setControllingAreaList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList のメソッド
管理領域一覧を設定します｡
setControllingarea(String) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
管理領域を設定します。
setControllingarea(String) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
管理領域を設定します。
setControllingarea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
管理領域を設定します。
setConvDen1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買価格単位から購買発注単位への変換分母を設定します。
setConvNum1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買価格単位から購買発注単位への変換分子を設定します。
setConvert(String) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
変換: 取引先機能 + 受注伝票タイプを設定します。
setConvert(String) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
取引先機能/受注伝票タイプの変換を設定します。
setConvert(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
変換: 取引先機能 + 受注伝票タイプを設定します。
setConvfactor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
計画品目用変換係数を設定します。
setCoords(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
coordsを設定します。
setCoords(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
coordsを設定します。
setCorrFact(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 修正係数を需要予測値計算に使用を設定します。
setCorrValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
需要予測に対する修正値を設定します。
setCorrValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
修正消費量を設定します。
setCorrValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
修正消費量を設定します。
setCostCentList(CostCenterList) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタ一覧を設定します｡
setCostCenter(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
原価センタを設定します｡
setCostCenterList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
原価センタ一覧を設定します｡
setCostElem(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
原価要素を設定します。
setCostObj(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
原価対象を設定します。
setCostObj(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
原価対象を設定します。
setCostView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算ビューを設定します。
setCostView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
原価計算ビューを設定します。
setCostView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
原価計算ビューを設定します。
setCostcenter(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
原価センタを設定します。
setCostcenter(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
原価センタを設定します。
setCostcenter(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
原価センタを設定します。
setCostcenter(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
原価センタを設定します。
setCostingSheet(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
原価計算表を設定します。
setCostobject(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
原価対象を設定します。
setCountLimit(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
最大検索数を設定する。
setCountrIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
国キー (ISO コード)を設定します。
setCountry(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
国コードを設定します。
setCountry(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
国コードを設定します。
setCountry(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
出荷国 (商品発送国)を設定します。
setCountry(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
国コードを設定します。
setCountry(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
国コードを設定します。
setCountryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
国コードを設定します。
setCountryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
国コードを設定します。
setCountryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
国コードを設定します。
setCountryCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
国コードを設定します。
setCountryCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
国コードを設定します。
setCountryCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
国コードを設定します。
setCountryCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
国コードを設定します。
setCountryCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
国コードを設定します。
setCountryCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
国コードを設定します。
setCountryiso(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
ISO 国コードを設定します。
setCountryiso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
ISO 国コードを設定します。
setCountryiso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
ISO 国コードを設定します。
setCountryori(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
品目の原産国を設定します。
setCountryori(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目の原産国を設定します。
setCountryoriIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
ISO 国コードを設定します。
setCountryoriIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ISO コードでの品目原産国を設定します。
setCountycode(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
地域コードを設定します
setCovprofile(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
在庫日数プロファイルを設定します。
setCrOn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
レコード登録日を設定します。
setCreatDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
レコード登録日を設定します。
setCreatDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
レコード登録日を設定します。
setCreateLoadRecs(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
区分: 生産資源/治工具の負荷レコード登録を設定します。
setCreateLoadRecs(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
区分: 生産資源/治工具の負荷レコード登録を設定します。
setCreatedBy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
オブジェクト登録者名を設定します。
setCreatedBy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
登録者名を設定します｡
setCreatedBy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
オブジェクト登録者名を設定します。
setCreatedBy(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
オブジェクト登録者名を設定します。
setCreatedBy(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn のメソッド
オブジェクト登録者名を設定します。
setCreatedBy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
オブジェクト登録者名を設定します。
setCreatedBy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
オブジェクト登録者名を設定します。
setCreatedOn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
レコード登録日を設定します。
setCreatedOn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
登録日付を設定します。
setCreatedOn(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn のメソッド
レコード登録日を設定します。
setCreationDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
レコード登録日を設定します。
setCreationDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
レコード登録日を設定します。
setCreationTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
登録時刻を設定します。
setCreationTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
登録時刻を設定します。
setCreatorDataIn(CreatorDataIn) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
取り込まれる日付の順序を設定します。
setCreditorid(String) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
仕入先コードを設定します｡
setCritPart(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 重要品目を設定します。
setCsIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
レコード番号を設定します｡
setCshBdgtProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
資金計画プロファイルを設定します。
setCstcndgrp1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ１を設定します。
setCstcndgrp1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ１を設定します。
setCstcndgrp1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ２を設定します。
setCstcndgrp2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ２を設定します。
setCstcndgrp2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ３を設定します。
setCstcndgrp3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ３を設定します。
setCstcndgrp3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ４を設定します。
setCstcndgrp4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ４を設定します。
setCstcndgrp4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ５を設定します。
setCstcndgrp5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ５を設定します。
setCstcndgrp5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstgSheet(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
原価計算表を設定します。
setCstgSheet(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
原価計算表を設定します。
setCstgSheet(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCtValidF(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
有効開始日付 (販売契約/品目提案)を設定します。
setCtValidF(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCtValidT(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
有効終了日付 (販売契約/品目提案)を設定します。
setCtValidT(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCtrlCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
貿易: 消費税の管理コードを設定します。
setCtrlKey(String) - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
預金種別を設定します。
setCtrlKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
調達における品質管理の管理キーを設定します。
setCtrlKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
調達における品質管理の管理キーを設定します。
setCtrlKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具管理の管理キーを設定します。
setCtrlKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具管理の管理キーを設定します。
setCtrlKeyNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
管理キーは変更できませんを設定します。
setCtrlKeyNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
管理キーは変更できませんを設定します。
setCtrlQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
管理数量を設定します。
setCuAmtBase(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
明細通貨項目の課税基準額に値を設定します。
setCuAmtBase(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
課税基準額を設定します｡
setCuAmtDoccur(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
明細通貨項目の伝票通貨額に値を設定します。
setCuAmtDoccur(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
伝票通貨額設定します｡
setCuCurrency(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
明細通貨項目の通貨コードに値を設定します。
setCuCurrency(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
通貨コードを設定します｡
setCuIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
レコード番号を設定します｡
setCuItemnoAcc(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
明細通貨項目の会計伝票明細番号に値を設定します。
setCuItemnoAcc(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
会計伝票明細番号コードを設定します｡
setCumCfQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
累積確認数量 (販売数量単位)を設定します。
setCurrIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
ISO コード通貨を設定します。
setCurrIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
ISO コード通貨を設定します。
setCurrIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ISO コード通貨を設定します。
setCurrIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
ISO コード通貨を設定します。
setCurrIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
ISO コード通貨を設定します。
setCurrIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
ISO コード通貨を設定します。
setCurrIso2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
ISO コード通貨を設定します。
setCurrPeriod(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
当期 (転記期間)を設定します。
setCurrPeriod(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
当期 (転記期間)を設定します。
setCurrPlanPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法基準評価額: レベル 2を設定します。
setCurrenckey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
スケール通貨を設定します。
setCurrenckey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
スケール通貨を設定します。
setCurrenckeyIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
ISO コード通貨を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
購買発注通貨を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
通貨コードを設定します｡
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売伝票通貨を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
販売伝票通貨を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売伝票通貨を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売伝票通貨を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売伝票通貨を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
販売伝票通貨を設定します。
setCurrency2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
販売伝票通貨を設定します。
setCurrencyAmountList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
明細通貨項目一覧を設定します｡
setCurrencyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
通貨コードを設定します。
setCurrencyCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
通貨コードを設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ISO 通貨コードを設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ISO 通貨コードを設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
ISO コード通貨を設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
ISO コード通貨を設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
ISO通貨コードを設定します｡
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
ISO 通貨コードを設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
ISO コード通貨を設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
ISO コード通貨を設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
ISO 通貨コードを設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
ISO コード通貨を設定します。
setCurreniso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
ISO コード通貨を設定します。
setCustGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループを設定します。
setCustGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先グループを設定します。
setCustGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustGrp1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 1を設定します。
setCustGrp1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustGrp2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 2を設定します。
setCustGrp2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustGrp3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 3を設定します。
setCustGrp3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustGrp4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 4を設定します。
setCustGrp4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustGrp5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 5を設定します。
setCustGrp5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustMat22(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先品目コード (無効)を設定します。
setCustMat22(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustMat35(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先品目を設定します。
setCustMat35(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustUser(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
得意先担当者を設定します。
setCustomer(String) - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
得意先コードを設定します
setCustomer(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
得意先コードを設定します
setCustomer(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
得意先コードを設定します
setCustomer(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
得意先コード1を設定します｡
setCustomer(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
得意先コードを設定します。
setCustomer(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
得意先コードを設定します。
setCustomer(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
得意先コードを設定します。
setCustomer(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
得意先コードを設定します。
setCustomerCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
取引先会社コードを設定します。
setCustomerCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment のメソッド
取引先会社コードを設定します。
setCustomerCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup のメソッド
取引先会社コードを設定します。
setCustomerCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole のメソッド
取引先会社コードを設定します。
setCustomerDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
取引先組織コードを設定します。
setCustomerDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment のメソッド
取引先組織コードを設定します。
setCustomerDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup のメソッド
取引先組織コードを設定します。
setCustomerDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole のメソッド
取引先組織コードを設定します。
setCustomerNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
得意先コードを設定します。
setCustoms(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader のメソッド
税関: 税関 (出国時)を設定します。
setCuvdClear(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
フラグ: 得意先と仕入先間の相殺決済を設定します。
setCvalueFxd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
区分: 消費金額の確定を設定します。
setCycleTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
タクトタイムを設定します。
setDToRefM(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費データ参照の有効終了日を設定します。
setData(Map) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.addAcount(Account) およびupdateAccount(Account)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.registerAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.domain.user.UserManagerを利用して、更新してください。

setData(Map, boolean) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。
setData(Map) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
setData(Map, boolean) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
setDataId(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
データIDを設定します。
setDataIndex(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
別の構成のテーブル入力へのポインタを設定します。
setDataName(String) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
データ名称を設定します。
setDataPropertyHandler(DataPropertyHandler) - class jp.co.intra_mart.framework.base.data.DataConnector のメソッド
データプロパティハンドラを設定します。
setDataSourceRefName(String) - interface jp.co.intra_mart.foundation.database.ConInfo のメソッド
DataSourceへの参照名を設定します。
setDataType(int) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
データ型を設定します。
setDataType(int) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
データ型を設定します。
setDataType(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
データタイプを設定します。
setDataType(String) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
データタイプを設定します。
setDatabaseAccessor(DatabaseAccessor) - class jp.co.intra_mart.foundation.database.DatabaseManager の static メソッド
データベースアクセッサを設定します。
setDataorigin(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 入力モードを設定します。
setDate(ExportManager, ExportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
エクスポート設定に定義された日付をマネージャーに設定します。
setDate(Date) - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager のメソッド
日付を設定します。
setDate(Date) - class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl のメソッド
日付を設定します。
setDate(Date) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager のメソッド

setDate(Date) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager のメソッド

setDate(Date) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager のメソッド

setDate(Date) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager のメソッド

setDate(Date) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager のメソッド

setDate(ImportManager, ImportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
インポート設定に定義された日付をマネージャーに設定します。
setDate(Date) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManager のメソッド
日付を設定します。
setDate(Date) - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl のメソッド
日付を設定します。
setDate(Date) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager のメソッド

setDate(Date) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager のメソッド

setDate(Date) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager のメソッド

setDate(Date) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager のメソッド

setDate(Date) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager のメソッド

setDate(String) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
日付を設定します。
setDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
起算日を設定します。
setDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
起算日を設定します。
setDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
日付を設定します。
setDate(Date) - class jp.co.intra_mart.foundation.security.password.PasswordHistory のメソッド
日付を設定します。
setDateHeader(String, long) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。
setDateHeader(HttpServletRequest, ExtendedHttpServletResponse, String, long) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。
setDateHeader(HttpServletRequest, ExtendedHttpServletResponse, String, long) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。
setDateHeader(HttpServletRequest, ExtendedHttpServletResponse, String, long) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。
setDateHeader(String, long) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このメソッドは、スーパークラスの HttpServletResponseWrapper.setDateHeader(java.lang.String name, long date) メソッドをそのまま呼び出します。
setDateType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
提案日付タイプを設定します。
setDateType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDateType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
日付タイプ (日、週、月、期間)を設定します。
setDateType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDateWorkBegins(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
作業開始を設定します。
setDateWorkEnds(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
作業終了を設定します。
setDay(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
日を設定します。
setDay(int) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
日を設定します。
setDayWeek(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
曜日を設定します。
setDayWeek(int) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
曜日を設定します。
setDeIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
レコード番号を設定します｡
setDealCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
取扱コードを設定します。
setDealCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment のメソッド
取扱コードを設定します。
setDealCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup のメソッド
取扱コードを設定します。
setDealCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole のメソッド
取扱コードを設定します。
setDealName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
取扱名を設定します。
setDealName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
取扱名を設定します。
setDealType(int) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
取扱種別を設定します。
setDealType(int) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
取扱種別を設定します。
setDebtorid(String) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
仕入先コードを設定します｡
setDebtorid(String) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
得意先コードを設定します｡
setDebtorid(String) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
得意先コードを設定します｡
setDecForRounding(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
小数点位置 (その位置まで丸める)を設定します。
setDecForRoundingX(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDeclStatFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 仕入先申告ありを設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
デフォルト日時を設定します。
setDefaultLocale(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
デフォルトのロケールを設定します。
setDefaultLocale(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
デフォルトのロケールを設定します。
setDefaultLocale(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
デフォルトのロケールを設定します。
setDefaultLocale(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
デフォルトのロケールを設定します。
setDefaultLocale(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
デフォルトのロケールを設定します。
setDefaultLocale(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
デフォルトのロケールを設定します。
setDefaultLocale(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
デフォルトのロケールを設定します。
setDefaultLocale(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
デフォルトのロケールを設定します。
setDefaultLocale(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
デフォルトのロケールを設定します。
setDefaultLocale(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
デフォルトのロケールを設定します。
setDefaultLocale(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
デフォルトのロケールを設定します。
setDefaultLocale(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
デフォルトのロケールを設定します。
setDefaultLocale(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
デフォルト言語を設定します。
setDefaultLocale(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
デフォルト言語を設定します。
setDefault_value(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
デフォルト値を格納します。
setDelDatcatExt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入期日カテゴリを設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
クライアントレベルでの品目削除フラグを設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
データレコード削除 (テーブル繰返し)を設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラントレベルでの品目削除フラグを設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
区分: 流通チャネルレベルでの品目削除フラグを設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所レベルでの品目削除フラグを設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
保管タイプに該当する全品目データ削除フラグを設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
データレコード削除 (テーブル繰返し)を設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価タイプに該当する全品目データ削除フラグを設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
WM 倉庫内の全品目データ削除フラグを設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
データレコード削除 (テーブル繰返し)を設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
データレコード削除 (テーブル繰返し)を設定します。
setDeleteInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買伝票の削除フラグを設定します。
setDeleteInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
削除フラグを設定します。
setDeleteInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
削除フラグを設定します。
setDeleteInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
削除フラグ: 購買伝票勘定設定を設定します。
setDeleteInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
削除フラグを設定します｡
setDeleteInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買伝票の削除フラグを設定します。
setDeleteInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買伝票の削除フラグを設定します。
setDeletionFlag(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
削除フラグを設定します。
setDeletionFlag(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
削除フラグを設定します。
setDeletionFlag(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
削除フラグを設定します。
setDeletionFlag(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
削除フラグを設定します。
setDelivCompl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
出荷完了 区分を設定します。
setDelivDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
納入期日を設定します。
setDelivDis(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
郵便配達地域を設定します。
setDelivDis(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
郵便配達地域を設定します。
setDelivDis(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
郵便配達地域を設定します。
setDelivItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷明細を設定します。
setDelivItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷明細を設定します。
setDelivItemToSearch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷明細を設定します。
setDelivNumb(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷伝票を設定します。
setDelivNumb(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷伝票を設定します。
setDelivNumbToSearch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷伝票を設定します。
setDelivTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入期日における指定時間を設定します。
setDeliveryAddressList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
入荷伝票アドレス一覧を設定します｡
setDeliveryDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入期日を設定します。
setDelkz(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
MRP 要素区分を設定します。
setDeltaFact(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
デルタ係数使用による MAD (絶対平均偏差) 平準化を設定します。
setDelyUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
出荷単位を設定します。
setDelyUom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
出荷数量単位を設定します。
setDelyUomIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
ISO コードでの出荷単位の数量単位を設定します。
setDelygPlnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
出荷プラントを設定します。
setDenominato(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件単位を基本単位へ変換する分母を設定します。
setDenominato(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件単位を基本単位へ変換する分母を設定します。
setDenominatr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
分母: 基本数量単位へ変換する場合を設定します。
setDepReqId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
個別所要量と包括所要量に対する従属所要量区分を設定します。
setDepartmNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
部門コードを設定します。
setDepartmNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDepartmNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
部門コードを設定します。
setDepartmNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDepartment(int, DepartmentInfo) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

setDepartment(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
部署を設定します。
setDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
組織コードを設定します。
setDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
組織コードを設定します。
setDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織コードを設定します。
setDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable のメソッド
組織コードを設定します。
setDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment のメソッド
組織コードを設定します。
setDepartmentCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
組織コードを設定します。
setDepartmentCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
組織コードを設定します。
setDepartmentCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel のメソッド
組織コードを設定します。
setDepartments(DepartmentInfo[]) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

setDepcountry(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
出荷国 (商品発送国)を設定します。
setDepcountryIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
出荷国の ISO コードを設定します。
setDeployHoriz(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
供給分配期間の日数を設定します。
setDeprecPer(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ドキュメンタリクレジット処理に関する償却率 (%)を設定します。
setDeprecPer(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDepth(int) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
階層レベルを設定します。
setDepth(int) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
階層レベルを設定します。
setDerefLinf(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
間接参照の有無を設定する。
setDescrHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のメソッド
終了品目テキストを設定します。
setDescrLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のメソッド
開始品目テキストを設定します。
setDescript(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
テキストを設定します｡
setDescript(String) - class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract のメソッド
テキスト (30 文字)を設定します。
setDescript(String) - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
グループテキスト (短)を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
作業テキスト (短)を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
PS: テキスト(短)(第一テキスト行)を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
テキストを設定します。
setDescription(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
PS: テキスト(短)(第一テキスト行)を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンテキスト（長）を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
バージョンテキスト（長）を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.security.access.AccessController のメソッド
説明を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
説明を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチ内容を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
データの説明を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
説明を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
説明を設定します。
setDetectionTimeOut(Integer) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 書き込みタイムアウト時間を設定します。
setDetermGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
在庫決定グループを設定します。
setDevalInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
低価法: 評価減区分を設定します。
setDialogflag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
区分 (X = 利用不可 /N = 確認なし)を設定します。
setDiffInv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
仕入先と請求元が異なる場合の請求元コードを設定します｡
setDir(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性dirの値を設定します。
setDir(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
dirを設定します。
setDir(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
dirを設定します。
setDir(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性dirの値を設定します。
setDir(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes のメソッド
属性dirの値を取得します。
setDiscontinu(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
打切区分を設定します。
setDispQuan(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買発注数量: 表示目的全納入日程合計を設定します。
setDisplayName(String) - class jp.co.intra_mart.foundation.security.access.AccessController のメソッド
表示名を設定します。
setDisplayName(String) - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
マイメニュー表示名を設定する。
setDisplayName(Locale, String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
表示名を設定します。
setDisplayName(Locale, String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニュー名を設定します。
setDisplayName(Locale, String) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロール表示名を設定します。
setDisplayName(String) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
データ表示名を設定します。
setDisplayName(String, Locale) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
データ表示名を設定します。
setDisplayName(String) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoInternationalModel のメソッド
データ表示名を設定します。
setDisplayName(String) - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel のメソッド
メニュー表示名を設定します。
setDisplayName(String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
メニュー表示名を設定します。
setDisplayName(String, Locale) - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
メニュー表示名を設定します。
setDisplayName(String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuInternationalModel のメソッド
メニュー表示名を設定します。
setDisplayName(String) - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
ロール表示名を設定します。
setDisplayName(String, Locale) - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
ロール表示名を設定します。
setDisplayName(String) - interface jp.co.intra_mart.system.security.datastore.inf.RoleInternationalModel のメソッド
ロール表示名を設定します。
setDistrChan(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
流通チャネルを設定します。
setDistrChan(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
流通チャネルを設定します。
setDistrChan(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
流通チャネルを設定します。
setDistrChan(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDistrChan(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
流通チャネルを設定します。
setDistrChanHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のメソッド
流通チャネルの範囲終了を設定します。
setDistrChanLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のメソッド
流通チャネルの範囲開始を設定します。
setDistrPerc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
配賦率 % (複数勘定設定)を設定します。
setDistrProf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
サイトの商品の物流プロファイルを設定します。
setDistrctNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村/地名ファイルの所在地コードを設定します。
setDistrctNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村/地名ファイルの所在地コードを設定します。
setDistrctNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村/地名ファイルの所在地コードを設定します。
setDistrib(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
複数勘定設定の配賦区分を設定します。
setDistrib(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
複数勘定設定の配賦区分を設定します。
setDistributingKey(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)を設定します。
setDistributionChannelSelectionList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
流通チャネルの選択オプション一覧を設定します｡
setDistributionchannel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
流通チャネルを設定します。
setDistrict(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
所在地を設定します。
setDistrict(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
所在地を設定します。
setDistrict(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
所在地を設定します。
setDistrict(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
所在地を設定します。
setDistrict(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
所在地を設定します。
setDivision(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製品部門を設定します。
setDivision(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
製品部門を設定します。
setDivision(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
製品部門を設定します。
setDivision(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDivision(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
製品部門を設定します。
setDivision(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDivision(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
製品部門を設定します。
setDliProfil(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
動的明細プロセッサプロファイルを設定します。
setDliProfil(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷ブロック (伝票ヘッダ)を設定します。
setDlvBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出荷ブロック (伝票ヘッダ)を設定します。
setDlvBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷ブロック (伝票ヘッダ)を設定します。
setDlvDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程日付を設定します。
setDlvDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷グループ (明細一括出荷)を設定します。
setDlvGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvPrio(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷優先順位を設定します。
setDlvPrio(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出荷数量実績 (販売単位)を設定します。
setDlvQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷数量実績 (販売単位)を設定します。
setDlvStatH(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
全明細の出荷ステータスを設定します。
setDlvStatI(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
明細の全体出荷ステータスを設定します。
setDlvTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
契約出荷期間を設定します。
setDlvTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
契約出荷期間を設定します。
setDlvTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入時間を設定します。
setDlvTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
ISO コードでの出荷単位の数量単位を設定します。
setDlvschduse(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
用途区分を設定します。
setDlvschduse(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvschduse(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
用途区分を設定します。
setDlvschduse(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDocAcDocNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの会計伝票番号に値を設定します。
setDocAcDocNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計伝票番号コードを設定します｡
setDocCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
購買伝票カテゴリを設定します。
setDocChgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書変更番号 (文書管理システム外)を設定します。
setDocClass(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
リリースおよびトランザクション管理を備えた元システムを設定します。
setDocClass(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDocCompCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの会社コードに値を設定します。
setDocCompCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会社コードコードを設定します｡
setDocCond(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
伝票条件番号を設定します。
setDocDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買伝票日付を設定します｡
setDocDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
伝票の伝票日付を設定します。
setDocDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
伝票日付 (受信日/送信日)を設定します。
setDocDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDocDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
伝票日付 (受信日/送信日)を設定します。
setDocDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
伝票日付 (受信日/送信日)を設定します。
setDocDocDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの伝票の伝票日付に値を設定します。
setDocDocDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票の伝票日付コードを設定します｡
setDocDocType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの伝票タイプに値を設定します。
setDocDocType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票タイプコードを設定します｡
setDocFisPeriod(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの会計期間に値を設定します。
setDocFisPeriod(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計期間コードを設定します｡
setDocFiscYear(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの会計年度に値を設定します。
setDocFiscYear(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計年度コードを設定します｡
setDocFormat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書のページ書式 (文書管理システムによらない)を設定します。
setDocHeaderTxt(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの伝票ヘッダテキストに値を設定します。
setDocHeaderTxt(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票ヘッダテキストコードを設定します｡
setDocNumFi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
ドキュメンタリクレジット処理: 内部番号を設定します。
setDocNumFi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDocNumFi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ドキュメンタリクレジット処理: 内部番号を設定します。
setDocNumFi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDocNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買管理におけるオブジェクト番号を設定します。
setDocNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
伝票番号を設定します。
setDocNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売伝票を設定します。
setDocNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
販売管理伝票番号を設定します。
setDocNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
販売伝票を設定します。
setDocNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
販売伝票を設定します。
setDocObjKey(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダのオブジェクトキーに値を設定します。
setDocObjKey(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
オブジェクトキーコードを設定します｡
setDocObjType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの参照処理に値を設定します。
setDocObjType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
参照処理コードを設定します｡
setDocPstngDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの伝票の転記日付に値を設定します。
setDocPstngDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票の転記日付コードを設定します｡
setDocRefDocNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの参照伝票番号に値を設定します。
setDocRefDocNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
参照伝票番号コードを設定します｡
setDocReqd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
文書必須フラグを設定します。
setDocStatus(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
伝票ステータスを設定します。
setDocType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買伝票カテゴリを設定します。
setDocType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
伝票タイプを設定します｡
setDocType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書タイプ (文書管理システムによらない)を設定します。
setDocType(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売伝票タイプを設定します。
setDocType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売伝票タイプを設定します。
setDocType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDocType(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売伝票タイプを設定します。
setDocUsername(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダのユーザ名に値を設定します。
setDocUsername(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
ユーザ名コードを設定します｡
setDocVers(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書バージョン (文書管理システムによらない)を設定します。
setDocYear(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入出庫伝票年度を設定します。
setDocYear(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫伝票年度を設定します。
setDocYear(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret のメソッド
入出庫伝票年度を設定します。
setDocument(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書番号 (文書管理システムによらない)を設定します。
setDocumentDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
登録日付を設定します。
setDocumentDateTo(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
入力日付 (以前/以降)を設定します。
setDocumentHeader(DocumentHeader) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダを設定します｡
setDocumentHeader(PurchaseHeaderPost) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
伝票ヘッダを設定します｡
setDomain(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
ドメインを格納します。
setDoneCertification(boolean) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
認証が終了しているかどうかを設定する。
setDontUseP(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱住所配達不可フラグを設定します。
setDontUseS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名住所配達不可フラグを設定します。
setDown(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を設定します。
setDscnt1To(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
現金割引日数1を設定します｡
setDscnt2To(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
現金割引日数2を設定します｡
setDscnt3To(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
現金割引日数3を設定します｡
setDsctPct1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
割引率 1を設定します。
setDsctPct2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
割引率 2を設定します。
setDsnOffice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
研究室/設計室を設定します。
setDunCount(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先商談回数を設定します。
setDunCount(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDunDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先との前回の商談日を設定します。
setDunDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDunnBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
督促処理保留を設定します。
setDunnBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDunnBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
督促処理保留を設定します。
setDunnBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDunnKey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
督促処理キーを設定します。
setDunnKey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDunnKey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
督促処理キーを設定します。
setDunnKey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDuplicateSrc(boolean) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
イメージアイコンのURLの重複チェックの有効/無効を設定します。
setDurationConfirmFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
確認の予測活動期間を設定します。
setDurationConfirmFcUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
確認の予測期間単位を設定します。
setDurationConfirmFcUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setDurationMinimum(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最短活動期間を設定します。
setDurationMinimumFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の最小期間(需要予測より)を設定します。
setDurationMinimumFcUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予測最短期間の単位を設定します。
setDurationMinimumFcUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setDurationMinimumUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最短期間の単位を設定します。
setDurationMinimumUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setDurationNormal(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
標準活動期間を設定します。
setDurationNormalFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
標準活動期間 (予測)を設定します。
setDurationNormalFcUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
標準予測期間の単位を設定します。
setDurationNormalFcUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setDurationNormalUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
標準期間/単位を設定します。
setDurationNormalUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setDurationScheduled(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
処理時間を設定します。
setDurationScheduledFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
処理時間の長さ (予測値)を設定します。
setDurationScheduledUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
処理時間単位を設定します。
setDurationScheduledUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setEMail(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
電子メールアドレスを設定します。
setEMail(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
電子メールアドレスを設定します。
setEMail(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
電子メールアドレスを設定します。
setEanCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
国際商品コード (EAN) のカテゴリを設定します。
setEanCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
国際商品コード (EAN) のカテゴリを設定します。
setEanCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
国際商品コード (EAN) のカテゴリを設定します。
setEanUpc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
国際商品コード (EAN/UPC)を設定します。
setEanUpc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
国際商品コード (EAN/UPC)を設定します。
setEanUpc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
国際商品コード (EAN/UPC)を設定します。
setEanUpc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
国際商品コード (EAN/UPC)を設定します。
setEanUpc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
国際商品コード (EAN/UPC)を設定します。
setEanUpc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setEarlyFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画終了: 実行 (日)を設定します。
setEarlyFinishDateFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画終了日 (予測)を設定します。
setEarlyFinishTime(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画終了: 実行 (時刻)を設定します。
setEarlyFinishTimeFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画終了時間(需要予測)を設定します。
setEarlyStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画開始: 実行 (日)を設定します。
setEarlyStartDateFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画開始日付(需要予測)を設定します。
setEarlyStartTime(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画開始: 作業実施(時間)を設定します。
setEarlyStartTimeFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画開始時間(需要予測)を設定します。
setEarnedValueIndicator(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
進捗分析関連のマイルストーンを設定します。
setEdition(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
サービスタイプのバージョンを設定します。
setEdition(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスタイプのバージョンを設定します。
setEffODay(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
有効終了日を設定します。
setEiIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
レコード番号を設定します｡
setEmailAddress1(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
メールアドレス1を設定します。
setEmailAddress1(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
メールアドレス1を設定します。
setEmailAddress1(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
メールアドレス１を設定します。
setEmailAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス1を設定します。
setEmailAddress1(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス1を設定します。
setEmailAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
メールアドレス1を設定します。
setEmailAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス１を設定します。
setEmailAddress1(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス１を設定します。
setEmailAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
メールアドレス１を設定します。
setEmailAddress2(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
メールアドレス2を設定します。
setEmailAddress2(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
メールアドレス2を設定します。
setEmailAddress2(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
メールアドレス２を設定します。
setEmailAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス2を設定します。
setEmailAddress2(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス2を設定します。
setEmailAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
メールアドレス2を設定します。
setEmailAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス２を設定します。
setEmailAddress2(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス２を設定します。
setEmailAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
メールアドレス２を設定します。
setEmaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目コードを設定します。
setEmaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目コード（長）を設定します。
setEmaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目コードの外部GUIDを設定します。
setEmaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目コードのバージョン番号を設定します。
setEncoding(ExportManager, ExportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
エクスポート設定に定義されたエクスポートデータのエンコーディング情報をマネージャーに設定します。
setEncoding(String) - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager のメソッド
エクスポートデータのエンコーディングを設定します。
setEncoding(String) - class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl のメソッド
エクスポートファイルのエンコーディングを設定します。
setEncoding(String) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager のメソッド

setEncoding(String) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager のメソッド

setEncoding(String) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager のメソッド

setEncoding(String) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager のメソッド

setEncoding(String) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager のメソッド

setEncoding(ImportManager, ImportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
インポート設定に定義されたインポートファイルのエンコーディング情報をマネージャーに設定します。
setEncoding(String) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManager のメソッド
インポートファイルのエンコーディングを設定します。
setEncoding(String) - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl のメソッド
インポートファイルのエンコーディングを設定します。
setEncoding(String) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager のメソッド

setEncoding(String) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager のメソッド

setEncoding(String) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager のメソッド

setEncoding(String) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager のメソッド

setEncoding(String) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager のメソッド

setEncoding(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
エンコーディング情報を設定します。
setEncoding(String) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
エンコーディングの設定。
setEncoding(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインエンコーディングを設定する。
setEncoding(String) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
エンコーディングを設定します。
setEncoding(String) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
エンコーディングを設定する。
setEncoding(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
エンコーディングを設定します。
setEnctype(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性enctypeの値を設定します。
setEndDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
終了日を設定します。
setEndDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
終了日を設定します。
setEndDate(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
終了日を設定します。
setEndDate(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
終了日を設定します。
setEndOffset(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具用途の終了オフセットを設定します。
setEndOffset(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具用途の終了オフセットを設定します。
setEndOffsetNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
終了オフセットは変更できませんを設定します。
setEndOffsetNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
終了オフセットは変更できませんを設定します。
setEndOffsetUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用終了オフセット単位を設定します。
setEndOffsetUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用終了オフセット単位を設定します。
setEndOffsetUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
PRT 用途終了決定の間隔時間単位 (ISO)を設定します。
setEndOffsetUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
PRT 用途終了決定の間隔時間単位 (ISO)を設定します。
setEndRefDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用終了日の参照日付を設定します。
setEndRefDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用終了日の参照日付を設定します。
setEndRefDateNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
終了参照日付は変更できませんを設定します。
setEndRefDateNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
終了参照日付は変更できませんを設定します。
setEndleadtme(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
補充リードタイムの終了日付を設定します。
setEndtime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
終了時刻を設定します。
setEntryDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
会計伝票登録日を設定します。
setEntryQnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入力単位での数量を設定します。
setEntryQnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入力単位での数量を設定します。
setEntryTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
登録時刻を設定します。
setEntryUom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入力単位を設定します。
setEntryUom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入力単位を設定します。
setEntryUomIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
単位の ISO コードを設定します。
setEntryUomIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
単位の ISO コードを設定します。
setEnvtRlvt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: 環境関連を設定します。
setEquipment(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
設備番号を設定します。
setEquityType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
持分タイプを設定します。
setEquityType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
持分タイプを設定します。
setErrorCode(String) - class jp.co.intra_mart.extension.maskat.util.MKError のメソッド
errorCodeを設定します。
setErrorResponseHeaders(String) - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static メソッド
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
setErrorResponseHeaders(String, String) - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static メソッド
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
setErrorResponseHeaders(String, String, String) - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static メソッド
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
setErrorResponseHeaders(String, String, String, String) - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static メソッド
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
setErrorResponseHeaders(String, String[]) - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static メソッド
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
setErrorResponseHeaders(HttpServletResponse, String) - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static メソッド
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
setErrorResponseHeaders(HttpServletResponse, String, String) - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static メソッド
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
setErrorResponseHeaders(HttpServletResponse, String, String, String) - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static メソッド
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
setErrorResponseHeaders(HttpServletResponse, String, String, String, String) - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static メソッド
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
setErrorResponseHeaders(HttpServletResponse, String, String[]) - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static メソッド
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
setErrorTotal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
エラー合計を設定します。
setErrorTotalPp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間のエラー合計を設定します。
setErrorsList(List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
前明細の不正処理に関する情報を設定します。
setErs(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ERS（入庫/請求自動決済）を設定します。
setEstPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
概算価格区分を設定します。
setEstimatedCosts(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
指図の見積原価合計を設定します。
setEuListNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
CAP: CAP 製品一覧番号を設定します。
setEuMatGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
EEC 農産物政策: CAP 生産品グループ - 貿易を設定します。
setEutriDeal(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
フラグ: EC 内三角取引を設定します。
setEutriDeal(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setEventHistory(EventHistoryInfo[]) - class jp.co.intra_mart.foundation.navigator.EventItemInfo のメソッド
イベント履歴情報リスト設定
setEventHistory(EventHistoryInfo[]) - class jp.co.intra_mart.foundation.navigator.EventResultItemInfo のメソッド
イベント履歴情報リスト設定
setEventHistory(SaveEventHistoryInfo[]) - class jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo のメソッド
イベント履歴情報リスト設定
setEventId(String) - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject のメソッド
イベントIDを設定します。
setEventual(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
偶発的明細を設定します。
setExCertDt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
非該当証明書発行日を設定します。
setExCertId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
法令管理: 認定書区分を設定します。
setExCertNoNew(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
非該当証明書番号 - 法令管理を設定します。
setExIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
レコード番号を設定します｡
setExRateFi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
FI 転記の換算レート (直接相場)を設定します。
setExRateFi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setExRateFx(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
換算レート固定区分を設定します｡
setExceptList(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
例外メッセージバーを設定します。
setExchRate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
直接呼び値換算レートを設定します。
setExchRate(ExchRate) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
換算レート、係数 (通貨ペア)を設定します。
setExchRate(ExchRate) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
換算レート、係数 (通貨ペア)を設定します。
setExchRate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
換算レートを設定します｡
setExchRateCm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
間接呼び値換算レートを設定します。
setExchRateFiV(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
FI 転記の換算レート (間接相場)を設定します。
setExchRateFiV(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setExchRateFiV(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
FI 転記の換算レート (間接相場)を設定します。
setExchRateFiV(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setExchRateV(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
間接呼び値換算レートを設定します。
setExchangeRate(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
価格設定/統計用換算レートを設定します。
setExchgRate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格設定/統計の換算レート (直接引用)を設定します。
setExchgRate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setExchgRate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格設定/統計の換算レート (直接引用)を設定します。
setExchgRate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setExchgRate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
価格設定/統計の換算レート (直接引用)を設定します。
setExchgRateV(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格設定/統計の換算レート (間接引用)を設定します。
setExchgRateV(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setExchgRateV(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格設定/統計の換算レート (間接引用)を設定します。
setExchgRateV(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setExchgRateV(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
価格設定/統計の換算レート (間接引用)を設定します。
setExecuteUser(ExportManager, ExportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
エクスポート設定に定義された実行ユーザコードをマネージャーに設定します。
setExecuteUser(String) - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager のメソッド
実行ユーザコードを設定します。
setExecuteUser(String) - class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl のメソッド
実行ユーザを設定します。
setExecuteUser(String) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager のメソッド

setExecuteUser(String) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager のメソッド

setExecuteUser(String) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager のメソッド

setExecuteUser(String) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager のメソッド

setExecuteUser(String) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager のメソッド

setExecuteUser(ImportManager, ImportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
インポート設定に定義された実行ユーザをマネージャーに設定します。
setExecuteUser(String) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManager のメソッド
実行ユーザを設定します。
setExecuteUser(String) - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl のメソッド
実行ユーザを設定します。
setExecuteUser(String) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager のメソッド

setExecuteUser(String) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager のメソッド

setExecuteUser(String) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager のメソッド

setExecuteUser(String) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager のメソッド

setExecuteUser(String) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager のメソッド

setExpActivityList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
活動に関する詳細情報を設定します。
setExpActivityList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
活動に関する詳細情報を設定します。
setExpClientData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から品目データ (クライアントレベル) を設定します。
setExpExpList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(export(Export))の一覧を設定します｡
setExpExtensionOut(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
table(Export)情報からBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造 を設定します。
setExpForecastParameters(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から予測データを設定します。
setExpInternationArticleNumbers(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
table(Export)情報からEANを設定します。
setExpLifoValuationData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報からLIFO 関連品目データを設定します。
setExpMaterialDescription(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
table(Export)情報から品目テキストを設定します。
setExpMaterialText(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
table(Export)情報からテキスト (長) を設定します。
setExpMessageList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
詳細情報を読み込みエラーを設定します。
setExpMessageList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
詳細情報を読み込みエラーを設定します。
setExpPlanningData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から品目マスタ/製品グループの変更伝票構造を設定します。
setExpPlantData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から品目データ (プラントレベル) を設定します。
setExpProductionResourceToolData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から品目マスタの生産資源/治工具 (PRT) 項目を設定します。
setExpSalesData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から販売データを設定します。
setExpStorageLocationData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から品目データ (保管場所レベル)を設定します。
setExpStorageTypeData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から保管域タイプデータを設定します。
setExpStrList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(structure(Export))の一覧を設定します｡
setExpTaxClassifications(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
table(Export)情報から制御データを設定します。
setExpTblList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(table(Export))の一覧を設定します｡
setExpUnitSofmeasure(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
table(Export)情報から数量単位を設定します。
setExpValuationData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から評価データを設定します。
setExpValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
見込金額を設定します。
setExpWarehouseNumberData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から倉庫番号データを設定します。
setExpWbsElementList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
WBS 要素についての詳細情報を設定します。
setExpWbsElementList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
WBS 要素についての詳細情報を設定します。
setExpWbsHierarchieList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
WBS 階層についての情報を設定します。
setExpWbsHierarchieList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
WBS 階層についての情報を設定します。
setExpWbsMilestoneList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
WBS マイルストーンに関する詳細情報を設定します。
setExpWbsMilestoneList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
WBS マイルストーンに関する詳細情報を設定します。
setExpimpNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
貿易データ番号: MM/SD 伝票を設定します。
setExpimpgrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
輸出/輸入品目グループを設定します。
setExpireInterval(int) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
最終応答時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を設定する。
setExpirydate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
有効期間期限日を設定します。
setExpirydate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
有効期間期限日を設定します。
setExplain(String) - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
説明を設定します。
setExportEncoding(String) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。
setExportHeader(ExportHeader) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
貿易管理ヘッダを設定します｡
setExportImportProcedure(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
貿易の輸出入手続を設定します。
setExportItemList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
貿易管理明細を設定します｡
setExportNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
貿易データ番号: MM/SD 伝票を設定します。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
センタグループ情報ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
仕入先コードの詳細情報ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
得意先コードの詳細情報ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
為替換算レート情報ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
内部指図書詳細情報ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
内部指図書（一覧）情報ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
登録された情報ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
伝票に登録された情報ををセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions の static メソッド
全バージョンに値をセットします。
setExportParam(BapiController, ExportHeader) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader の static メソッド
貿易管理ヘッダに値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension の static メソッド
拡張得意先項目に値をセットします。
setExportParam(BapiController, PurchaseHeaderPost) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader の static メソッド
伝票ヘッダに値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
伝票に登録された情報ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
実行結果を取得します。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader の static メソッド
table(Export)情報から入出庫伝票ヘッダデータの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList の static メソッド
table(Export)情報から入出庫伝票ヘッダデータの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems の static メソッド
table(Export)情報からリターン構造、入出庫伝票明細の値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
伝票に登録された情報ををセットします。
setExportParam(BapiController, GoodsMvtHeadret) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret の static メソッド
入出庫伝票ヘッダデータの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem の static メソッド
table(Export)情報から返却されたリターン構造、入出庫伝票明細の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber の static メソッド
table(Export)情報からシリアル番号の値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
返却された入出庫伝票照会情報をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa の static メソッド
table(Export)情報からロットの範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa の static メソッド
table(Export)情報から品目コードの範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa の static メソッド
table(Export)情報から移動タイプの範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa の static メソッド
table(Export)情報からプラントの範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa の static メソッド
table(Export)情報から登録日付の範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa の static メソッド
table(Export)情報から特殊在庫区分の範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa の static メソッド
table(Export)情報から保管場所の範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa の static メソッド
table(Export)情報からトランザクション/イベントタイプの範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa の static メソッド
table(Export)情報からユーザ名の範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa の static メソッド
table(Export)情報から仕入先の範囲の値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
取得した品目在庫確認情報をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex の static メソッド
table(Export)情報から出力テーブル (日付および ATP 数量)の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx の static メソッド
table(Export)情報から入力テーブル (日付/数量)の値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
返却された品目マスタ照会情報をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目マスタに登録する値ををセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList の static メソッド
table(Export)情報から品目データ (クライアントレベル)の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn の static メソッド
table(Export)情報からBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造 の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX の static メソッド
実行結果の拡張イン/拡張アウトのチェックボックス構造をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList の static メソッド
table(Export)情報から需要予測パラメータの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues の static メソッド
table(Export)情報から需要予測値のデータ転送の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData の static メソッド
table(Export)情報から管理情報設定ヘッダセグメントの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos の static メソッド
table(Export)情報から国際商品コード (EAN)の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription の static メソッド
table(Export)情報から品目テキストを設定します。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText の static メソッド
table(Export)情報からテキスト (長)の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList の static メソッド
table(Export)情報から品目マスタ/製品グループの変更伝票構造の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList の static メソッド
table(Export)情報から品目データ (プラントレベル)の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData の static メソッド
table(Export)情報から品目マスタの生産資源/治工具 (PRT) 項目の値を セットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages の static メソッド
品目マスタ更新結果をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList の static メソッド
table(Export)情報から販売データの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList の static メソッド
table(Export)情報から品目データ (保管場所レベル)の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList の static メソッド
table(Export)情報から保管域タイプデータの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications の static メソッド
table(Export)情報から制御データを設定します。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption の static メソッド
table(Export)情報から品目総消費量のデータ転送の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure の static メソッド
table(Export)情報から数量単位を設定します。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption の static メソッド
table(Export)情報から計画外消費のデータ転送の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList の static メソッド
table(Export)情報から評価データの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList の static メソッド
table(Export)情報から倉庫番号データを設定します。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
請求伝票に登録する値ををセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn の static メソッド
table(Export)情報から処理予定明細データのテーブルの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn の static メソッド
table(Export)情報から理予定支払方法のテーブルの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn の static メソッド
table(Export)情報から処理予定条件のテーブルの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors の static メソッド
table(Export)情報から前明細の不正処理に関する情報の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn の static メソッド
table(Export)情報から請求インタフェースの通信構造テキストの値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail のメソッド
返却された請求伝票詳細照会情報をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
取得した請求伝票一覧照会情報をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList の static メソッド
table(Export)情報から請求伝票詳細の値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob の static メソッド
table(Export)情報から選定: BLOB 内部データ (SCE)の値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst の static メソッド
table(Export)情報から選定: インスタンスの値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf の static メソッド
table(Export)情報から選定: 部分設定の値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef の static メソッド
table(Export)情報から選定: 参照データの値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst の static メソッド
table(Export)情報から選定: 参照明細/インスタンスの値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue の static メソッド
table(Export)情報から選定: 特性値の値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk の static メソッド
table(Export)情報から明細データの値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn の static メソッド
table(Export)情報から条件の値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX の static メソッド
table(Export)情報から受注における条件更新の通信項目の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn の static メソッド
table(Export)情報からVBAK、VBAP、VBEP のカスタマ拡張の値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn の static メソッド
table(Export)情報から明細データの値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX の static メソッド
table(Export)情報から明細データチェックボックスの値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys の static メソッド
table(Export)情報から参照キーの出力テーブルの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses の static メソッド
table(Export)情報からアドレス (組織/会社) 用 BAPI 参照構造の値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners の static メソッド
table(Export)情報から伝票取引先の値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn の static メソッド
table(Export)情報から明細データの値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX の static メソッド
table(Export)情報から納入日程行チェックボックスの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess の static メソッド
table(Export)情報から後続請求伝票の明細テーブルの値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText の static メソッド
table(Export)情報からテキストの値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
引合伝票に登録する値ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
見積伝票に登録する値ををセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard の static メソッド
table(Export)情報からクレジットカードデータの値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
見積伝票に登録する値ををセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders の static メソッド
table(Export)情報から得意先受注テーブル情報の値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
返却された販売伝票一覧照会情報をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo の static メソッド
table(Export)情報からステータス情報の値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のメソッド
返却された販売伝票ステータス一覧照会情報をセットします。
setExpostPds(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
事後的需要予測に含む履歴値の数を設定します。
setExpostVal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
事後的需要予測値を設定します。
setExrateFi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
FI 転記の換算レート (直接相場)を設定します。
setExrateFi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setExtLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
明細番号を設定します。
setExtOrdNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
外部指図番号を設定します。
setExtServ(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
仕入先のサービス番号を設定します。
setExtWms(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
外部倉庫管理の転記の制御を設定します。
setExtendedBaseModelMap(ExtendedBaseModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
拡張基本モデルマップを設定します。
setExtendedInternationalModelMap(ExtendedInternationalModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext のメソッド
拡張国際化モデルマップを設定します。
setExtendedTerminableInternationalModelMap(ExtendedTerminableInternationalModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext のメソッド
拡張期間国際化モデルマップを設定します。
setExtendedTerminableModelMap(ExtendedTerminableModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
拡張期間化モデルマップを設定します。
setExtensionFaxNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
内線FAX番号を設定します。
setExtensionInList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を設定します。
setExtensionInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
VBAK、VBAP、VBEP のカスタマ拡張を設定します。
setExtensionInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
VBAK、VBAP、VBEP のカスタマ拡張を設定します。
setExtensionInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
VBAK、VBAP、VBEP のカスタマ拡張を設定します。
setExtensionInXList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
拡張イン/拡張アウトのチェックボックス構造を設定します。
setExtensionList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
拡張得意先項目を設定します｡
setExtensionNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
内線番号を設定します。
setExtensionNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
内線番号を設定します。
setExtensionNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
内線番号を設定します。
setExtensionNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線番号を設定します。
setExtensionNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線番号を設定します。
setExtensionNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
内線番号を設定します。
setExtensionNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線番号を設定します。
setExtensionNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線番号を設定します。
setExtensionNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
内線番号を設定します。
setExtensionOutList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を設定します。
setExternalObjectId(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
SAP 外部対象キーを設定します。
setExtmatlgrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
外部品目グループを設定します。
setExtpersNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
外部従業員番号を設定します。
setExtrefkey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
サービスの外部参照キーを設定します。
setFactbasval(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件基礎値に対する要因を設定します。
setFactbasval(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件基礎値に対する要因を設定します。
setFactconbas(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件基準の係数 (期間)を設定します。
setFactor(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
バリアント条件の加重係数を設定します。
setFactoryCalendar(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
稼働日カレンダを設定します。
setFairShareRule(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
均等配賦ルールを設定します。
setFax(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
得意先/仕入先の経理担当者のファックス No.を設定します。
setFax1(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
FAX 1を設定します｡
setFaxExtens(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
第一 FAX 番号: 内線を設定します。
setFaxExtens(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
第一 FAX 番号: 内線を設定します。
setFaxExtens(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
第一 FAX 番号: 内線を設定します。
setFaxNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
FAX番号を設定します。
setFaxNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
FAX番号を設定します。
setFaxNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
FAX番号を設定します。
setFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
FAX番号を設定します。
setFaxNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
FAX番号を設定します。
setFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
FAX番号を設定します。
setFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
FAX番号を設定します。
setFaxNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
FAX番号を設定します。
setFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
FAX番号を設定します。
setFaxNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
第一 FAX 番号: ダイヤルコード + 番号を設定します。
setFaxNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
第一 FAX 番号: ダイヤルコード + 番号を設定します。
setFaxNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
第一 FAX 番号: ダイヤルコード + 番号を設定します。
setFaxNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
FAX 番号を設定します。
setField(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
フィールドを設定します｡
setField(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
パラメータの項目を設定します。
setFieldList(ArrayList) - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer のメソッド
フィールド一覧リストをセットします。
setFieldName(String) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
ファイルを参照するためのフィールド名をセットします。
setFieldNames(String[]) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。
setFieldname(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
項目名を設定します。
setFijCurCostEst(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
当期標準原価見積の会計年度を設定します。
setFijFutCostEst(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
将来標準原価見積の会計年度を設定します。
setFijPreCostEst(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期標準原価見積の会計年度を設定します。
setFill(boolean) - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
描画されるグラフの塗りつぶし可否を設定します。
setFillLevel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
最大レベル (容積別)を設定します。
setFilter(ExportManager, ExportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
エクスポート設定に定義されたフィルタの情報をマネージャーに設定します。
setFilter(Filter) - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager のメソッド
エクスポート対象を絞り込むためのフィルタを設定します。
setFilter(Filter) - class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl のメソッド
エクスポートフィルタを設定します。
setFilter(Filter) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager のメソッド

setFilter(Filter) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager のメソッド

setFilter(Filter) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager のメソッド

setFilter(Filter) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager のメソッド

setFilter(Filter) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager のメソッド

setFilterParameter(String, String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このフィルタのパラメータを設定します。
setFinalInv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
請求書処理完了区分を設定します。
setFinish(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクトの計画終了日を設定します。
setFirstDay(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
値参照期間の第一日目を設定します。
setFirstDay(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
値参照期間の第一日目を設定します。
setFirstDay(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
値参照期間の第一日目を設定します。
setFiscYear(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
当会計年度を設定します。
setFiscYear(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
当会計年度を設定します。
setFixLotSize(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要供給の一致に対する固定ロットサイズを設定します。
setFixValDy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
有効日日付を設定します。
setFixValDy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setFixValDy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
有効日日付を設定します。
setFixValDy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setFixdatQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
納期と出荷数量の固定を設定します。
setFixdatQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setFixedLot(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
固定ロットサイズを設定します。
setFixedMilestoneDateBasic(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
固定マイルストーン日付(基準)を設定します。
setFixedMilestoneDateForecast(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン固定日付を設定します。
setFixedMilestoneTimeBasic(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
固定マイルストーン時間(基準)を設定します。
setFixedMilestoneTimeForecast(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン固定時間 (F)を設定します。
setFixedPds(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
固定期間を設定します。
setFixedQuan(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
数量固定区分を設定します。
setFixedQuan(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setFkkConacct(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
長さ 12 の文字項目を設定します。
setFkkConacct(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setFkkConacct(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
長さ 12 の文字項目を設定します。
setFkkConacct(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setFlagCadCall(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
CAD システムからコールを設定します。
setFlexibleDuration(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
区分: 可変期間を設定します。
setFloatFree(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
自由余裕を設定します。
setFloatFreeFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
自由余裕 (予測)を設定します。
setFloatTotal(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
余裕合計を設定します。
setFloatTotalFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
余裕合計 (予測)を設定します。
setFloor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
建物の階を設定します。
setFloor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
建物の階を設定します。
setFloor(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
建物の階を設定します。
setFocus(String) - class jp.co.intra_mart.foundation.page.EventScript のメソッド
イベントとして監視する変数名を指定します。
setFollowUp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
フォローアップ品目を設定します。
setFollowUpExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)を設定します。
setFollowUpGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)を設定します。
setFollowUpVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 FOLLOW_UP のバージョン番号 (今後のリリースで開発)を設定します。
setFontColor(Color) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
キャプションの文字色を設定します。
setFontSize(int) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
キャプションの文字サイズを設定します。
setForeDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
最終需要予測日を設定します。
setForeModel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
予測モデルを設定します。
setForePds(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
需要予測期間を設定します。
setForeProf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
需要予測プロファイルを設定します。
setForeValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
予測値を設定します。
setForecFlowCont(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
予測フロー管理を設定します。
setForecastFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予測終了日を設定します。
setForecastParameters(ForecastParameters) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
予測パラメータを設定します。
setForecastParametersList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
需要予測パラメータを設定します。
setForecastValuesList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
需要予測値のデータ転送を設定します。
setForecastView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要予測ビューを設定します。
setForecastView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
需要予測ビューを設定します。
setForm(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
ターゲットとなるフォーム名を設定します。
setFormField(boolean) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
単純なフォームフィールドかどうかを指定します。
setFormVal1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を設定します。
setFormVal2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を設定します。
setFormVal3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を設定します。
setFormVal4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を設定します。
setFormVal5(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を設定します。
setFormat(String) - class jp.co.intra_mart.foundation.database.DatabaseColumn のメソッド

setFormat(ExportManager, ExportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
エクスポート設定に定義されたエクスポートデータのフォーマットをマネージャーに設定します。
setFormat(String) - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager のメソッド
エクスポートデータのフォーマットを設定します。
setFormat(String) - class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl のメソッド
エクスポートファイルのフォーマットを設定します。
setFormat(String) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager のメソッド

setFormat(String) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager のメソッド

setFormat(String) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager のメソッド

setFormat(String) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager のメソッド

setFormat(String) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager のメソッド

setFormat(ImportManager, ImportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
インポート設定に定義されたインポートファイルのフォーマットをマネージャーに設定します。
setFormat(String) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManager のメソッド
インポートファイルのフォーマットを設定します。
setFormat(String) - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl のメソッド
インポートファイルのフォーマットを設定します。
setFormat(String) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager のメソッド

setFormat(String) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager のメソッド

setFormat(String) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager のメソッド

setFormat(String) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager のメソッド

setFormat(String) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager のメソッド

setFormatCol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のメソッド
タグ列を設定します。
setFormatCol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
タグ列を設定します。
setFormatCol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
タグ列を設定します。
setFormatCol(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
タグ列を設定します。
setFormatCol(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
タグ列を設定します。
setFormclass(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性classの値を設定します。
setFormofaddr(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
敬称を設定します。
setFormofaddr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
敬称テキストを設定します。
setFormofaddr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
敬称テキストを設定します。
setFormula(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式番号を設定します。
setFormulaTotQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具の合計数量の計算式を設定します。
setFormulaTotQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具の合計数量の計算式を設定します。
setFormulaTotQtyNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
合計数量の計算式は変更できませんを設定します。
setFormulaTotQtyNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
合計数量の計算式は変更できませんを設定します。
setFormulaTotUsage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具の総用途値の計算式を設定します。
setFormulaTotUsage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具の総用途値の計算式を設定します。
setFormulaTotUsageNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
すべての用途値を計算する計算式は変更できませんを設定します。
setFormulaTotUsageNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
すべての用途値を計算する計算式は変更できませんを設定します。
setFrameClass(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
推奨されていません。 このメソッドではなくFrameTag.setFrameclass(String)メソッドを使用してください。
setFrameborder(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
frameborderを設定します。
setFrameclass(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
frameClassを設定します。
setFreeItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
無償明細を設定します。
setFreeLimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
自由制限を設定します。
setFrom(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Fromを設定します。
setFrom(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Fromを設定します。
setFrom(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 Fromをセットする。
setFrom(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 Fromをセットする。
setFromCurr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算前通貨を設定します。
setFromCurr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
換算前通貨を設定します。
setFromCurr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
換算前通貨を設定します。
setFromFactor(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算前 通貨単位の係数を設定します。
setFromFactorV(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算前 通貨単位の係数を設定します。
setFromLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
下限を設定します。
setFuncArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
機能領域を設定します。
setFuncArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
機能領域を設定します。
setFuncArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
機能領域を設定します。
setFuncArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
機能領域を設定します。
setFuncArea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
機能領域を設定します。
setFuncArea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
機能領域を設定します。
setFuncArea(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
機能領域を設定します。
setFuncArea(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
機能領域を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
機能領域を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
機能領域を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
機能領域を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
機能領域を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
機能領域を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
機能領域を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
機能領域を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
機能領域を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
機能を設定します。
setFunctionalLocation(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
機能場所を設定します。
setFund(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
会計区分を設定します。
setFund(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
会計区分を設定します。
setFund(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
会計区分を設定します。
setFund(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
会計区分を設定します。
setFundsCtr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
予算センタを設定します。
setFundsCtr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
予算センタを設定します。
setFundsCtr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
予算センタを設定します。
setFundsCtr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
予算センタを設定します。
setFuturePr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
次期標準原価を設定します。
setFwdCons(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費期間: 前方を設定します。
setFxdPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
固定価格連産品を設定します。
setFyVariant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
会計年度バリアントを設定します。
setFyVariant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
会計年度バリアントを設定します。
setGammaFact(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
ガンマ係数使用の平滑化のための季節指数を設定します。
setGeneralDataInfo(GeneralDataInfo) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
一般データ情報を設定します｡
setGeneralDataInfo(GeneralDataInfo) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
一般データ情報を設定します｡
setGeneralDataInfo(GeneralDataInfo) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
一般データ情報を設定します｡
setGeneralDataInfo(GeneralDataInfo) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
一般データ情報を設定します｡
setGeneralDataInfo(GeneralDataInfo) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
一般データ情報を設定します｡
setGeneralDataInfo(GeneralDataInfo) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
一般データ情報を設定します｡
setGiDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
出庫日付を設定します。
setGiDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
出庫日付を設定します。
setGiDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setGiDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出庫日付を設定します。
setGiTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
出庫時刻 (現地時間 - プラント参照)を設定します。
setGiTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
出庫時刻 (現地時間 - プラント参照)を設定します。
setGiTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setGlAccList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList のメソッド
勘定項目一覧を設定します｡
setGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
G/L勘定コードを設定します｡
setGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
G/L 勘定コードを設定します。
setGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
G/L 勘定コードを設定します。
setGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
G/L 勘定コードを設定します。
setGlAllocNmbr(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細のソートキーに値を設定します。
setGlAllocNmbr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
ソートキーコードを設定します｡
setGlBusArea(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の事業領域に値を設定します。
setGlBusArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
事業領域コードを設定します｡
setGlCompCode(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の会社コードに値を設定します。
setGlCompCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会社コードコードを設定します｡
setGlCostcenter(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の原価センタに値を設定します。
setGlCostcenter(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
原価センタコードを設定します｡
setGlDocType(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の伝票タイプに値を設定します。
setGlDocType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
伝票タイプコードを設定します｡
setGlFiscYear(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の会計年度に値を設定します。
setGlFiscYear(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会計年度コードを設定します｡
setGlGlAccount(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の総勘定元帳勘定に値を設定します。
setGlGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
総勘定元帳勘定コードを設定します｡
setGlIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
レコード番号を設定します｡
setGlIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
レコード番号を設定します｡
setGlItemText(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の明細テキストに値を設定します。
setGlItemText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
明細テキストコードを設定します｡
setGlItemnoAcc(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の会計伝票明細番号に値を設定します。
setGlItemnoAcc(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会計伝票明細番号コードを設定します｡
setGlList(GlAccList) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
勘定科目一覧を設定します｡
setGlOrderid(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の指図番号に値を設定します。
setGlOrderid(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
指図番号コードを設定します｡
setGlPstngDate(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の伝票の転記日付に値を設定します。
setGlPstngDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
伝票の転記日付コードを設定します｡
setGlRefKey1(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の取引先参照キーに値を設定します。
setGlRefKey1(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
取引先参照キーコードを設定します｡
setGlTaxCode(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の消費税コードに値を設定します。
setGlTaxCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
消費税コードコードを設定します｡
setGlWbsElement(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細のWBS 要素に値を設定します。
setGlWbsElement(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
WBS 要素コードを設定します｡
setGmCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode のメソッド
BAPI 在庫移動トランザクションのコード割当を設定します。
setGoOut(boolean) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
外出状態を設定します。
setGoOut(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
外出フラグを設定します。
setGoodsMvtCode(GoodsMvtCode) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
在庫移動に対するコードのトランザクションへの割当を設定します。
setGoodsMvtHeader(GoodsMvtHeader) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票ヘッダデータを設定します。
setGoodsMvtHeaderList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
リターン構造、入出庫伝票ヘッダを設定します。
setGoodsMvtHeadret(GoodsMvtHeadret) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票番号/入出庫伝票会計年度を設定します。
setGoodsMvtItemList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票明細を設定します。
setGoodsMvtItemsList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
リターン構造、入出庫伝票明細を設定します。
setGoodsMvtSerialNumberList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
シリアル番号を設定します。
setGrBasediv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
入庫基準の請求書照合区分を設定します。
setGrGiSlipNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入出庫票番号を設定します。
setGrInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
入庫区分を設定します。
setGrMessage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
入庫メッセージ区分を設定します｡
setGrNonVal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
非評価入庫を設定します。
setGrNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫番号を設定します。
setGrPrTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
入庫処理日数を設定します。
setGrPrTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
入庫処理日数を設定します。
setGrPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
基準額を設定します。
setGrRcpt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
受領者を設定します。
setGrRcpt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
受領者を設定します。
setGrRcpt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
受領者を設定します。
setGrRcptx(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
関連ユーザデータ項目の更新情報を設定します。
setGrToDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
納入最終期限を設定します。
setGrantNbr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
補助金を設定します。
setGrantNbr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
補助金を設定します。
setGrantNbr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
補助金を設定します。
setGrantNbr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
補助金を設定します。
setGraphBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
グラフ領域の背景色を設定します。
setGraphBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
グラフ領域の背景色を設定します。
setGraphBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
グラフ領域の背景色を設定します。
setGraphBorderColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
グラフ領域のボーダーの色を設定します。
setGraphBorderColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
グラフ領域のボーダーの色を設定します。
setGraphBorderColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
グラフ領域のボーダーの色を設定します。
setGraphFrameColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
グラフ枠の線色を設定します。
setGroValueItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
総額を設定します。
setGrossWght(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細の総重量を設定します。
setGrossWght(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setGrossWt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
総重量を設定します。
setGrossWt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
総重量を設定します。
setGroup(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing のメソッド
グループIDを設定します。
setGroup(String) - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler のメソッド
グループＩＤを設定します。
setGroupId(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
ログイングループIDを設定する。
setGroupcond(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
グループ条件区分を設定します。
setGroupcond(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
グループ条件区分を設定します。
setGroupname(String) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
グループ名を設定します。
setGroupname(String) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
グループ名を設定します。
setGroupname(String) - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
グループ名を設定します。
setGroupname(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
グループ名を設定します。
setGrpKey1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具のグループキー 1を設定します。
setGrpKey1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具のグループキー 1を設定します。
setGrpKey2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具のグループキー 2を設定します。
setGrpKey2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具のグループキー 2を設定します。
setGrpReqmts(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 所要量グループ化を設定します。
setGtinVariant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
グローバルトレード明細番号バリアントを設定します。
setGtinVariant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
グローバルトレード明細番号バリアントを設定します。
setHCurr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
通貨コードを設定します。
setHCurr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setHCurrIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
ISO 通貨コードを設定します。
setHandlgGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ワークロード計算のロジスティクス処理グループを設定します。
setHazMatNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
危険物コードを設定します。
setHazMatNoExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 HAZ_MAT_NO の品目コード (長) (今後のリリースで開発)を設定します。
setHazMatNoGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)を設定します。
setHazMatNoVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 HAZ_MAT_NO のバージョン番号 (今後のリリースで開発)を設定します。
setHazmatprof(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
危険物インジケータプロファイルを設定します。
setHdOffice(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
本店勘定コードを設定します。
setHeadDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
管理情報設定ヘッダセグメントを設定します。
setHeader(String, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
指定された名称で指定された値を持つレスポンスヘッダを設定します。
setHeader(HttpServletRequest, ExtendedHttpServletResponse, String, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
指定された名称で指定された値を持つレスポンスヘッダを設定します。
setHeader(HttpServletRequest, ExtendedHttpServletResponse, String, String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
指定された名称で指定された値を持つレスポンスヘッダを設定します。
setHeader(HttpServletRequest, ExtendedHttpServletResponse, String, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
指定された名称で指定された値を持つレスポンスヘッダを設定します。
setHeader(String, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このメソッドは、スーパークラスの HttpServletResponseWrapper.setHeader(java.lang.String name, java.lang.String value) メソッドをそのまま呼び出します。
setHeader(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 メールヘッダを設定する。
setHeaderTextList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
ヘッダテキスト一覧を設定します｡
setHeaderTxt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
伝票ヘッダテキストを設定します。
setHeight(int) - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルの高さを設定します。
setHeight(int) - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
表示単位に対する高さを設定します。
setHeight(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
高さを設定します。
setHelperclass(String) - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag のメソッド
クラス名を設定します。
setHgLvItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
BOM 構成の上位レベル明細を設定します。
setHgLvItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
上位レベル明細を設定します。
setHgLvItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setHiLineNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
上位階層明細番号を設定します。
setHierarchyNodesList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
階層ノード一覧を設定します。
setHierarchyNodesList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
階層ノード一覧を設定します。
setHierarchyNodesList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
階層ノード一覧を設定します。
setHierarchyValuesList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
階層値一覧を設定します。
setHierarchyValuesList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
階層値一覧を設定します。
setHierarchyValuesList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
階層値一覧を設定します。
setHierlevel(String) - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
階層のエントリレベルを設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
ロット番号を設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
品目コードを設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
移動タイプ (在庫管理)を設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
プラントを設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
伝票の転記日付を設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
特殊在庫区分を設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
保管場所を設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
トランザクション/イベントタイプを設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
ユーザ名を設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
仕入先勘定コードを設定します。
setHighVisc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: 高粘性を設定します。
setHistVals(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
履歴値の数を設定します。
setHlItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買伝票中の上位明細を設定します。
setHold(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
購買発注の不完全を設定します。
setHoldability(int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection オブジェクトを使用して生成された ResultSet オブジェクトの保持機能を指定された保持機能へ変更します。
setHomeCity(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村 (郵便用市区町村と異なる場合)を設定します。
setHomecityno(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
別の市区町村 (市区町村/地名ファイル)を設定します。
setHomepage(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
URI 例: ホームページ、FTP アドレスを設定します。
setHostnameVerifier(HostnameVerifier) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の HostnameVerifier を設定します。
setHouseNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
番地-号を設定します。
setHouseNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
番地-号を設定します。
setHouseNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
番地-号を設定します。
setHouseNo2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
番地補足を設定します。
setHouseNo2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
番地補足を設定します。
setHouseNo2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
番地補足を設定します。
setHouseNo3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
番地範囲を設定します。
setHreflang(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
hreflangを設定します。
setId(String) - class jp.co.intra_mart.foundation.navigator.EventFlow のメソッド

setId(String) - class jp.co.intra_mart.foundation.navigator.EventFlowInfo のメソッド
イベントフローID設定
setId(String) - class jp.co.intra_mart.foundation.navigator.EventHistoryInfo のメソッド
イベントアイテムID設定
setId(String) - class jp.co.intra_mart.foundation.navigator.EventItemInfo のメソッド
イベントアイテムID設定
setId(String) - class jp.co.intra_mart.foundation.navigator.EventResultItemInfo のメソッド
ナビゲート結果ID設定
setId(String) - class jp.co.intra_mart.foundation.navigator.ResultPageItemInfo のメソッド
保存結果ページID設定
setId(String) - class jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo のメソッド
保存ナビゲート結果ID設定
setId(String) - class jp.co.intra_mart.foundation.navigator.SelectItemInfo のメソッド
選択アイテムID設定
setId(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ＩＤを設定します｡
setId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージクラスを設定します。
setId(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージクラスを設定します。
setId(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニューIDを設定します。
setIgnoreErrMsgReturnTypes(List) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
エラーメッセージを無視するRETURN-TYPEを設定します。
setImageBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
画像ファイルの背景色を設定します。
setImageBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
画像ファイルの背景色を設定します。
setImageBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
画像ファイルの背景色を設定します。
setImageBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
画像ファイルの背景色を設定します。
setImageBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
画像ファイルの背景色を設定します。
setImageBorderColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
画像ファイルのボーダ色を設定します。
setImageBorderColor(Color) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
画像ファイルのボーダ色を設定します。
setImageBorderColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
画像ファイルのボーダ色を設定します。
setImageBorderColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
画像ファイルのボーダ色を設定します。
setImageBorderColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
画像ファイルのボーダ色を設定します。
setImageIconCd(String) - class jp.co.intra_mart.foundation.image.ImageIconInfo のメソッド
イメージアイコンコードを設定する。
setImagePath(String) - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
マイメニューイメージパスを設定します。
setImagePath(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニューイメージパスを設定します。
setImagePath(String) - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel のメソッド
イメージパスを設定します。
setImagePath(String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
イメージパスを設定します。
setImgaeBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
推奨されていません。
setImgaeBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
推奨されていません。
setImgaeBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
推奨されていません。
setImgaeBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
推奨されていません。
setImgaeBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
推奨されていません。
setImgaeBorderColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
推奨されていません。
setImgaeBorderColor(Color) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
推奨されていません。
setImgaeBorderColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
推奨されていません。
setImgaeBorderColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
推奨されていません。
setImgaeBorderColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
推奨されていません。
setImpExpType(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
入力／出力区分を設定します｡
setImpExtensionOut(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造からインポート情報を 設定します。
setImpImpList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(import(Import))の一覧を設定します｡
setImpInternationArticleNumbers(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
EANからインポート情報を設定します。
setImpMaterialDescription(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目テキストからインポート情報を設定します。
setImpMaterialText(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
テキスト (長) からインポート情報を設定します。
setImpStrList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(structure(Import))の一覧を設定します｡
setImpTaxClassifications(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
制御データからインポート情報を設定します。
setImpTblList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(table(Import))の一覧を設定します｡
setImpUnitSofmeasure(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
数量単位からインポート情報を設定します。
setImpWbsElementList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
詳細情報を必要とする WBS 要素を設定します。
setImpWbsElementList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
詳細情報を必要とする WBS 要素を設定します。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
センタグループを検索する条件ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
仕入先コードの詳細情報を検索する条件ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
得意先コードの詳細情報を検索する条件ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
為替換算レート情報を検索する条件ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
内部指図書詳細情報を検索する条件ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
内部指図書（一覧）情報を検索する条件ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
WEBの詳細情報を検索する条件ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
品目コードを検索する条件ををセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader の static メソッド
条件ヘッダに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem の static メソッド
条件明細に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits の static メソッド
外注基本契約制限に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService の static メソッド
外注サービスに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount の static メソッド
外注サービス勘定設定に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText の static メソッド
外注サービステキストに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress の static メソッド
入荷伝票アドレスヘッダに値をセットします。
setImportParam(BapiController, ExportHeader) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader の static メソッド
貿易管理ヘッダに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem の static メソッド
貿易管理明細に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension の static メソッド
拡張得意先項目に値をセットします。
setImportParam(BapiController, PurchaseHeaderPost) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader の static メソッド
伝票ヘッダに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText の static メソッド
ヘッダテキストに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText の static メソッド
明細テキストに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits の static メソッド
外注制限に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner の static メソッド
得意先に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment の static メソッド
入出庫予定ヘッダに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount の static メソッド
勘定設定に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule の static メソッド
納入日程に値をセットします。
setImportParam(BapiController, Versions) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions の static メソッド
バージョン管理に値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
伝票に登録する値ををセットします。
setImportParam(BapiController, GoodsMvtHeader) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader の static メソッド
入出庫伝票ヘッダデータに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList の static メソッド
リターン構造、入出庫伝票ヘッダに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems の static メソッド
リターン構造、入出庫伝票明細に値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
伝票に登録する値ををセットします。
setImportParam(BapiController, GoodsMvtCode) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode の static メソッド
在庫移動に対するコードのトランザクションへの割当の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem の static メソッド
リターン構造、入出庫伝票明細の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber の static メソッド
シリアル番号の値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
入出庫伝票一覧照会する情報をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa の static メソッド
ロットの範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa の static メソッド
品目コードの範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa の static メソッド
移動タイプの範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa の static メソッド
プラントの範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa の static メソッド
登録日付の範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa の static メソッド
特殊在庫区分の範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa の static メソッド
保管場所の範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa の static メソッド
ParamTrEvTypeRaの値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa の static メソッド
ユーザ名の範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa の static メソッド
仕入先の範囲の値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
品目在庫確認情報を取得する為の条件をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex の static メソッド
出力テーブル (日付および ATP 数量)の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx の static メソッド
入力テーブル (日付/数量)の値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目マスタ照会条件ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目マスタに登録する値ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
請求伝票に登録する値ををセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn の static メソッド
処理予定明細データのテーブルの値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn の static メソッド
処理予定支払方法のテーブルの値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn の static メソッド
処理予定条件のテーブルの値をセットします。
setImportParam(BapiController, CreatorDataIn) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn の static メソッド
取り込まれる日付の順序の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors の static メソッド
前明細の不正処理に関する情報の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn の static メソッド
請求インタフェースの通信構造テキストの値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
請求伝票一覧照会情報を、取得する為に必要な情報をセットします。
setImportParam(BapiController, RefDocRange) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange の static メソッド
前伝票の範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList の static メソッド
請求伝票詳細に値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob の static メソッド
選定: BLOB 内部データ (SCE)に値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst の static メソッド
選定: インスタンスに値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf の static メソッド
選定: 部分設定に値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef の static メソッド
選定: 参照データに値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst の static メソッド
選定: 参照明細/インスタンスに値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue の static メソッド
選定: 特性値に値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk の static メソッド
選定: バリアント条件キーに値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn の static メソッド
条件に値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX の static メソッド
受注における条件更新の通信項目に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn の static メソッド
VBAK、VBAP、VBEP のカスタマ拡張に値をセットします。
setImportParam(BapiController, HeaderIn, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn の static メソッド
販売伝票ヘッダデータに値をセットします。
setImportParam(BapiController, HeaderInX, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX の static メソッド
ヘッダデータチェックボックスに値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn の static メソッド
明細データに値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX の static メソッド
明細データに値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys の static メソッド
参照キーの出力テーブルに値をセットします。
setImportParam(BapiController, LogicSwitch) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch の static メソッド
内部制御パラメータに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses の static メソッド
アドレス (組織/会社) 用 BAPI 参照構造に値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners の static メソッド
伝票取引先に値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn の static メソッド
納入日程行に値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX の static メソッド
納入日程行チェックボックスに値をセットします。
setImportParam(BapiController, Sender) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender の static メソッド
論理システム - 送信者に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess の static メソッド
後続請求伝票の明細テーブルに値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText の static メソッド
テキストに値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
引合伝票に登録する値ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
見積伝票に登録する値ををセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard の static メソッド
クレジットカードデータに値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
見積伝票に登録する値ををセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders の static メソッド
得意先受注テーブル情報の値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
販売伝票一覧の検索条件をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo の static メソッド
ステータス情報の値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のメソッド
販売伝票ステータス一覧の検索条件をセットします。
setInCharge(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
利益センタ責任者を設定します｡
setInHouse(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
内部生産を設定します。
setInHouse(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
内部生産を設定します。
setInTransaction(boolean) - class jp.co.intra_mart.framework.base.event.EJBEventListener のメソッド
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
setInTransaction(boolean) - interface jp.co.intra_mart.framework.base.event.EventListener のメソッド
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
setInTransaction(boolean) - class jp.co.intra_mart.framework.base.event.GenericEventListener のメソッド
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
setInTransaction(boolean) - class jp.co.intra_mart.framework.base.event.StandardEventListener のメソッド
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
setIncoterms1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
インコタームズ1を設定します｡
setIncoterms1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
インコタームズ (1)を設定します。
setIncoterms1(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
インコタームズ (1)を設定します。
setIncoterms1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
インコタームズ (1)を設定します。
setIncoterms1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setIncoterms1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
インコタームズ (1)を設定します。
setIncoterms1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setIncoterms2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
インコタームズ2を設定します｡
setIncoterms2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
インコタームズ 2を設定します。
setIncoterms2(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
インコタームズ (2)を設定します。
setIncoterms2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
インコタームズ 2を設定します。
setIncoterms2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setIncoterms2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
インコタームズ 2を設定します。
setIncoterms2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setIndPostToInspStock(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品質検査中在庫への転記を設定します。
setIndProposeQuanx(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
提案数量 (初期数量)を設定します。
setIndSector(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
産業コードを設定します。
setIndSector(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
産業コードを設定します。
setIndex(int) - class jp.co.intra_mart.foundation.database.DatabaseColumn のメソッド

setIndex(int) - class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
レコード番号を設定します｡
setIndex_type(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
インデックスタイプを格納します。
setIndus3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目 CFOP カテゴリを設定します。
setInfIndex(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
インフレーション指数を設定します。
setInfo(String) - class jp.co.intra_mart.extension.maskat.util.MKError のメソッド
infoを設定します。
setInfoRec(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
購買情報番号を設定します。
setInfoRec(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買情報番号を設定します。
setInfoUpd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買情報更新区分を設定します。
setInform(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
情報行を設定します。
setInformation() - class jp.co.intra_mart.framework.base.service.DefaultTransition のメソッド
次の遷移先に渡す情報を設定します。
setInformation() - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のメソッド
次の遷移先に渡す情報を設定します。
setInformation() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
次の遷移先に渡す情報を設定します。
setInhseprodt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
内製日数を設定します。
setInitParameter(String, String) - class jp.co.intra_mart.framework.system.util.Config のメソッド
Validatorを初期化するときのパラメータを設定します。
setInitPds(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
初期化で使用する履歴値の数を設定します。
setInitialUrl(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
初期アクセスURLを設定する。
setInitialize(String) - class jp.co.intra_mart.foundation.page.EventScript のメソッド
イベントの初期値を指定します。
setInitialize(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
初期化区分を設定します。
setInpfldcheck(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
項目無効時の応答を設定します。
setInquiryCfgsBlobList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: BLOB 内部データ (SCE)を設定します。
setInquiryCfgsInstList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: インスタンスを設定します。
setInquiryCfgsPartOfList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: 部分設定を設定します。
setInquiryCfgsRefInstList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: 参照明細/インスタンスを設定します。
setInquiryCfgsRefList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: 参照データを設定します。
setInquiryCfgsValueList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: 特性値を設定します。
setInquiryCfgsVkList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: バリアント条件キーを設定します。
setInquiryConditionsInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
条件を設定します。
setInquiryConditionsInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
受注における条件更新の通信項目を設定します。
setInquiryHeaderIn(HeaderIn) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
引合伝票ヘッダデータを設定します。
setInquiryHeaderInX(HeaderInX) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
ヘッダデータチェックボックスを設定します。
setInquiryItemsInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
明細データを設定します。
setInquiryItemsInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
明細データチェックボックスを設定します。
setInquiryKeysList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
参照キーの出力テーブルを設定します。
setInquiryPartnersList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
伝票取引先を設定します。
setInquirySchedulesInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
納入日程行を設定します。
setInquirySchedulesInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
納入日程行チェックボックスを設定します。
setInquiryTextList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
テキストを設定します。
setInspInt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
次回再検査までの間隔を設定します。
setInspSetupFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目/プラントに QM 検査データ設定を設定します。
setInstId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
選定におけるインスタンス番号を設定します。
setInstId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
選定におけるインスタンス番号を設定します。
setInstId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
選定におけるインスタンス番号を設定します。
setInstId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
選定におけるインスタンス番号を設定します。
setInstId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
選定におけるインスタンス番号を設定します。
setInstId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
選定におけるインスタンス番号を設定します。
setInstId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setIntHeader(String, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
指定された名称で指定された整数値を持つレスポンスヘッダを設定します。
setIntHeader(HttpServletRequest, ExtendedHttpServletResponse, String, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
指定された名称で指定された整数値を持つレスポンスヘッダを設定します。
setIntHeader(HttpServletRequest, ExtendedHttpServletResponse, String, int) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
指定された名称で指定された整数値を持つレスポンスヘッダを設定します。
setIntHeader(HttpServletRequest, ExtendedHttpServletResponse, String, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
指定された名称で指定された整数値を持つレスポンスヘッダを設定します。
setIntHeader(String, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このメソッドは、スーパークラスの HttpServletResponseWrapper.setIntHeader(java.lang.String name, int value) メソッドをそのまま呼び出します。
setIntNumberAssignment(String) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
明細番号内部採番を設定します。
setIntNumberAssignment(String) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
明細番号内部採番を設定します。
setIntNumberAssignment(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
明細番号内部採番を設定します。
setIntObjNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
選定 (内部オブジェクト番号)を設定します。
setIntProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
プロジェクト/指図金利計算の金利プロファイルを設定します。
setIntProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト/指図金利計算の金利プロファイルを設定します。
setInterestProf(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
プロジェクト/指図金利計算の金利プロファイルを設定します。
setInternalChar(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
内部特性を設定します。
setInternalObjectId(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
SAP 内部対象キーを設定します。
setInternationArticleNumbersList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
EANを設定します。
setInternationalAccessor(InternationalAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext のメソッド
国際化アクセサを設定します。
setInternationalArtnosList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
国際商品コード (EAN)を設定します。
setInternationalModelMap(InternationalModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
国際化モデルマップを設定します。
setInternet(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
関係会社担当者のインターネットアドレスを設定します。
setInterop(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
移動時間を設定します。
setInvCorrFac(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
在庫修正係数を設定します。
setInvMatNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
会社固有 (内部) 在庫管理品目コードを設定します。
setInvMatNoExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 INV_MAT_NO の品目コード (長) (今後のリリースで開発)を設定します。
setInvMatNoGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)を設定します。
setInvMatNoVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 INV_MAT_NO のバージョン番号 (今後のリリースで開発)を設定します。
setInvalidateLoginType(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
無効化したユーザのログインタイプを設定する。
setInvalidateTime(long) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
無効化された時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を設定する。
setInvalidateUserId(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
無効化したユーザのログインユーザIDを設定する。
setInvestProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
設備投資案件プロファイルを設定します。
setInvoSched(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
請求書一覧日程 (稼働日カレンダ指定)を設定します。
setInvoSched(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setInvoSched(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求書一覧日程 (稼働日カレンダ指定)を設定します。
setInvoSched(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setInvoicePercentage(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
請求金額率 (%)を設定します。
setIrInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
請求書受領区分を設定します。
setIsAuth(boolean) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のメソッド
認証フラグを設定します。
setIsoUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
単位の ISO コードを設定します。
setIssStLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出庫保管場所を設定します。
setIssueUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出庫単位を設定します。
setIssueUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ISO コードでの出庫単位を設定します。
setItem(ItemAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のメソッド
商品カテゴリに商品を設定します。
setItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
開始明細を設定します。
setItemCaption(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminableInternational のメソッド
商品通称を設定します。
setItemCaption(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品通称を設定します。
setItemCaption(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品通称を設定します。
setItemCaption(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品通称を設定します。
setItemCaption(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品通称を設定します。
setItemCaption(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableInternationalModel のメソッド
商品通称を設定します。
setItemCaption(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
商品通称を設定します。
setItemCaption(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
商品通称を設定します。
setItemCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買伝票の明細カテゴリを設定します。
setItemCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
一般明細カテゴリグループを設定します。
setItemCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目マスタの明細カテゴリグループを設定します。
setItemCatExt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買伝票の明細カテゴリを設定します。
setItemCatalogueCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のメソッド
商品カタログコードを設定します。
setItemCatalogueMediaManager(ItemCatalogueMediaManager) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
商品カタログの媒体のマネジャーを設定します。
setItemCateg(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
明細カテゴリ (販売伝票)を設定します。
setItemCateg(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細カテゴリ (販売伝票)を設定します。
setItemCateg(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setItemCategoryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach のメソッド
商品カテゴリコードを設定します。
setItemCategoryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
商品カテゴリコードを設定します。
setItemCategoryName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategoryInternational のメソッド
商品カテゴリ名を設定します。
setItemCategoryName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
商品カテゴリ名を設定します。
setItemCategoryName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
商品カテゴリ名を設定します。
setItemCategoryName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryInternationalModel のメソッド
商品カテゴリ名を設定します。
setItemCategoryTypeCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach のメソッド
商品カテゴリ種別コードを設定します。
setItemCategoryTypeCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
商品カテゴリ種別コードを設定します。
setItemCategoryTypeCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.type.ItemCategoryType のメソッド
商品カテゴリ種別コードを設定します。
setItemCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail のメソッド
商品コードを設定します。
setItemCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
商品コードを設定します。
setItemCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のメソッド
商品コードを設定します。
setItemCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
商品コードを設定します。
setItemCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach のメソッド
商品コードを設定します。
setItemIntvl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
明細番号間隔を設定します｡
setItemName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminableInternational のメソッド
商品名を設定します。
setItemName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品名を設定します。
setItemName(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品名を設定します。
setItemName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品名を設定します。
setItemName(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品名を設定します。
setItemName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableInternationalModel のメソッド
商品名を設定します。
setItemName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
商品名を設定します。
setItemName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
商品名を設定します。
setItemNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買管理オブジェクト: 明細を設定します。
setItemText(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
明細テキストを設定します。
setItemText(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
明細テキストを設定します。
setItemTextList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
明細テキスト一覧を設定します｡
setItemguidAtp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ATP: 暗号 - DELNR および DELPSを設定します。
setItemguidAtp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setItemsForRelease(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
区分: 承認待ち購買発注のみ照会を設定します。
setItemsForRelease(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
区分: 承認待ち購買発注のみ照会を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件明細番号を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
販売伝票明細を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
明細番号を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売伝票明細を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件明細番号を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
条件明細番号を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売伝票明細を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
販売伝票明細を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
販売伝票明細を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
明細番号 (販売管理伝票)を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
販売伝票明細を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
販売伝票明細を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
販売伝票明細を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
明細番号 (販売管理伝票)を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
販売伝票明細を設定します。
setItmTypeUsage(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細用途を設定します。
setItmTypeUsage(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setJNDIName(String) - class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory のメソッド
EJBEventListenerAgentHomeのJNDI名を設定します。
setJitRelvt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: JIT 納入日程の関連明細を設定します。
setJointVenture(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ジョイントベンチャを設定します。
setJointVenture(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ジョイントベンチャを設定します。
setJvJibClass(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
JIB/JIBE クラスを設定します。
setJvJibClass(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
JIB/JIBE クラスを設定します。
setJvJibSubClassA(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
JIB/JIBE サブクラスAを設定します。
setJvJibSubClassA(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
JIB/JIBE サブクラスAを設定します。
setJvObjectType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ジョイントベンチャ対象タイプを設定します。
setJvObjectType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ジョイントベンチャ対象タイプを設定します。
setKanbanInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
かんばん区分を設定します。
setKblanguage(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
システム設定の言語を設定します。
setKbname(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
ナレッジベースオブジェクトを設定します。
setKbprofile(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
ナレッジベースプロファイルを設定します。
setKbversion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
SCE ナレッジベースの実行時バージョンを設定します。
setKey(String) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のメソッド
エラーメッセージを作成するためのキーを取得します。
setKey(String) - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
keyを設定します。
setLEquip1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 1を設定します。
setLEquip2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 2を設定します。
setLEquip3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 3を設定します。
setLabelForm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ラベル書式を設定します。
setLabelType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ラベルタイプを設定します。
setLang(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
言語を設定します。
setLang(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
言語を設定します。
setLang(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 言語を設定します｡
setLang(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性langの値を設定します。
setLang(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
langを設定します。
setLang(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
langを設定します。
setLang(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性langの値を設定します。
setLang(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes のメソッド
属性langの値を設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
言語キーを設定します。
setLanguCr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
アドレスレコード登録オリジナル言語を設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
ISO 639 準拠の言語を設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
ISO 639 準拠の言語を設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
言語キーの ISO コードを設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
ISO 639 準拠の言語を設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
ISO 639 準拠の言語を設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
ISO 639 準拠の言語を設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
ISO 639 準拠の言語を設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
ISO 639 準拠の言語を設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
ISO 639 準拠の言語を設定します。
setLanguage(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
ステータスおよび業務トランザクションテキストの言語を設定します。
setLanguage(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
ステータスおよび業務トランザクションテキストの言語を設定します。
setLanguage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
言語キーを設定します。
setLangucriso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
ISO 639 準拠の言語を設定します。
setLastChnge(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
最終変更日付を設定します。
setLastItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
最終明細番号を設定します。
setLastResponseTime(long) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
最終応答時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を設定する。
setLatestDatesIndicator(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
区分: 最遅日を設定します。
setLatestFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画最遅終了: 作業(日付)を設定します。
setLatestFinishDateFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最遅計画済終了日付(需要予測)を設定します。
setLatestFinishTime(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画最遅終了: 作業(時間)を設定します。
setLatestFinishTimeFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最遅計画終了時間 (予測)を設定します。
setLatestStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画最遅開始: 作業(日付)を設定します。
setLatestStartDateFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最遅計画済開始日付(需要予測)を設定します。
setLatestStartTime(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画最遅開始: 作業(時間)を設定します。
setLatestStartTimeFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最遅計画済開始時間(需要予測)を設定します。
setLayoutId(String) - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject のメソッド
レイアウトIDを設定します。
setLeadinguom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
主要ロット特定数量単位を設定します。
setLeft(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を設定します。
setLength(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
長さを設定します。
setLeqUnit1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 1 の数量単位を設定します。
setLeqUnit1Iso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードによる積載装置数量 1 の数量単位を設定します。
setLeqUnit2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 2 の数量単位を設定します。
setLeqUnit2Iso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードによる積載装置数量 2 の数量単位を設定します。
setLeqUnit3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 3 の数量単位を設定します。
setLeqUnit3Iso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードによる積載装置数量 3 の数量単位を設定します。
setLiIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
レコード番号を設定します｡
setLifoFifo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
LIFO/FIFO 関連を設定します。
setLifoValuationData(LifoValuationData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
LIFO 関連品目データを設定します。
setLifoValuationLevel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData のメソッド
LIFO 評価レベルを設定します。
setLifovaluationlevel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
LIFO 評価レベルを設定します。
setLimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
全体制限を設定します。
setLimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
全体制限を設定します。
setLimitLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: 計画外、明細制限を設定します。
setLimitsList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注制限一覧を設定します｡
setLineDepth(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
伝票での明細行階層レベルを設定します。
setLineDepth(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
伝票での明細行階層レベルを設定します。
setLineId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
伝票明細行の一意 IDを設定します。
setLineId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
伝票明細行の一意 IDを設定します。
setLineNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
制限の内部明細番号を設定します。
setLineNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
内部明細番号を設定します。
setLineNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
明細行番号を設定します。
setLineNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のメソッド
内部明細番号を設定します。
setLink(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
setLinkClass(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
推奨されていません。 このメソッドではなくLinkTag.setLinkclass(String)メソッドを使用してください。
setLinkPageInfo(LinkPageInfo) - class jp.co.intra_mart.foundation.navigator.ResultPageItem のメソッド

setLinkclass(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
linkClassを設定します。
setLinkclass(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
linkClassを設定します。
setListener(StandardEventListener) - class jp.co.intra_mart.framework.base.event.GenericEventListener のメソッド
イベント処理クラスを設定します。
setListenerName(String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory のメソッド
EJBEventListenerAgentBeanのクラス名を設定します。
setListenerName(String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory のメソッド
EJBEventListenerAgentBeanのクラス名を設定します。
setLoadBalancing(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
ロードバランサの有効・無効を設定する。
setLoadDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
積載日付を設定します。
setLoadDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
積載日付を設定します。
setLoadDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setLoadTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
積載時刻 (現地時間: 出荷ポイント)を設定します。
setLoadTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
積載時刻 (現地時間: 出荷ポイント)を設定します。
setLoadTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setLoadinggrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
積載グループを設定します。
setLocale(Locale) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。
setLocale(HttpServletRequest, ExtendedHttpServletResponse, Locale) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。
setLocale(HttpServletRequest, ExtendedHttpServletResponse, Locale) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。
setLocale(HttpServletRequest, ExtendedHttpServletResponse, Locale) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。
setLocale(Locale) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ロケールを設定します。
setLocale(Locale) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
ロケールの設定。
setLocale(Locale) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインロケールを設定する。
setLocale(Locale) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
ロケールを設定します。
setLocale(Locale) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ユーザのロケールを設定する。
setLocale(String) - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
localeを設定します。
setLocale(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
ロケールを設定します。
setLocation(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
場所を設定します。
setLocation(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名 5を設定します。
setLocation(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名 5を設定します。
setLocation(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名 5を設定します。
setLocation(String) - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のメソッド
遷移先のページパスを設定します。
setLockCount(int) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
アカウントをロックするログイン失敗回数を設定します。
setLockDate(Date) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
アカウントロック日付を設定します。
setLockDate(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
アカウントロック日付を設定します。
setLockTerm(int) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
アカウントをロックする期間を設定します。
setLogMsgNo(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ログメッセージナンバーを設定します｡
setLogMsgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
アプリケーションログ: メッセージシリアル番号を設定します。
setLogMsgNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
アプリケーションログ: メッセージシリアル番号を設定します。
setLogNo(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ログナンバーを設定します｡
setLogNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
アプリケーションログ: ログ番号を設定します。
setLogNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
アプリケーションログ: ログ番号を設定します。
setLogSystem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender のメソッド
論理システムを設定します。
setLogSystemOwn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
論理システムを設定します。
setLogSystemOwn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setLogWriter(PrintWriter) - class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource のメソッド
ラップされたデータソースのsetLogWriter(PrintWriter)を呼び出します。
setLogWriter(PrintWriter) - class jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource のメソッド
ラップされたデータソースのsetLogWriter(PrintWriter)を呼び出します。
setLogicSwitch(LogicSwitch) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
内部制御パラメータを設定します。
setLogicSwitch(LogicSwitch) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
内部制御パラメータを設定します。
setLogicSwitch(LogicSwitch) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
内部制御パラメータを設定します。
setLoginFailureCount(int) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ログイン失敗回数を設定します。
setLoginFailureCount(int) - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
ログイン失敗回数を設定します。
setLoginGroup(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
ログイングループIDを設定する。
setLoginGroup(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログイングループIDを設定する。
setLoginGroupID(String) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログイングループIDを設定する。
setLoginGroupId(String) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
ログイングループIDを設定します。
setLoginTime(long) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
ログイン時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を設定する。
setLoginTime(Date) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログインした時間を設定する。
setLoginTimeout(int) - class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource のメソッド
ラップされたデータソースのsetLoginTimeout(int)を呼び出します。
setLoginTimeout(int) - class jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource のメソッド
ラップされたデータソースのsetLoginTimeout(int)を呼び出します。
setLoginType(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
ログインタイプを設定する。
setLoginType(String) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログインタイプを設定する。
setLogsystem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
論理システムを設定します｡
setLongText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
総勘定元帳勘定テキスト(長)を設定します｡
setLongdesc(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
longdescを設定します。
setLooseorliq(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: バルク/液体を設定します。
setLotIncrement(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要と供給を一致させるためのロットサイズ増分を設定します。
setLotSize(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算ロットサイズを設定します。
setLotsizekey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ロットサイズ (品目計画)を設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
ロット番号を設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
品目コードを設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
移動タイプ (在庫管理)を設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
プラントを設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
伝票の転記日付を設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
特殊在庫区分を設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
保管場所を設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
トランザクション/イベントタイプを設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
ユーザ名を設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
仕入先勘定コードを設定します。
setMail(StandardMail) - class jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent のメソッド
メールの属性を設定します。
setMailAddress(String) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
メールアドレス設定。
setMain(DepartmentMain) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
ユーザが主所属する組織を設定します。
setMainEan(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
区分: 主要 EANを設定します。
setMainPagePatternId(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
メインページパターンIDを設定する。
setMainPagePatternImageUrl(String) - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo のメソッド
メインページパターンイメージURLを設定する。
setMainPagePatternUrl(String) - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo のメソッド
メインページパターンURLを設定する。
setMaintStat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
更新ステータスを設定します。
setMaintStat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
更新ステータスを設定します。
setMaintStat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
更新ステータスを設定します。
setMaintStat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
更新ステータスを設定します。
setManuMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のメソッド
製造者製品コードを設定します。
setManuMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
製造者製品コードを設定します。
setManuMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造者製品コードを設定します。
setManufProf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
製造者製品プロファイルを設定します。
setManufProf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造者製品プロファイルを設定します。
setManufacturerPartNumbList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
製造業者と製造者製品コード一覧を設定します｡
setMargin(int, int, int, int) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
グラフ領域のマージンを設定します。
setMargin(int, int, int, int) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
グラフ領域のマージンを設定します。
setMargin(int, int, int, int) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
グラフ領域のマージンを設定します。
setMargin(int, int, int, int) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
グラフ領域のマージンを設定します。
setMargin(int, int, int, int) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
グラフ領域のマージンを設定します。
setMarginheight(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
marginheightを設定します。
setMarginwidth(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
marginwidthを設定します。
setMaskId(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
WBS 要素 ID(短)の選択マスクを設定します。
setMastCond(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
期間依存条件伝票を設定します。
setMastContr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
グループマスタ契約番号を設定します。
setMastContr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMasterData(MasterData) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
指図のマスタデータ構造を設定します。
setMasterData(MasterData) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
指図のマスタデータ構造を設定します。
setMatCfop(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目 CFOP カテゴリを設定します。
setMatDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入出庫伝票番号を設定します。
setMatDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫伝票番号を設定します。
setMatDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret のメソッド
入出庫伝票番号を設定します。
setMatEntrd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
入力品目を設定します。
setMatEntrd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMatExt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMatExt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMatExt(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMatGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
品目グループを設定します。
setMatGrpSm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目グループ: 梱包材を設定します。
setMatGrpTrans(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
段取替えマトリクスに対する品目のグループを設定します。
setMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMatOrigin(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目の原産地を設定します。
setMatOrigin(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目の原産地を設定します。
setMatPrGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目価格設定グループを設定します。
setMatPrGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目価格設定グループを設定します。
setMatPrGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMatStatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目更新完了ステータスを設定します。
setMatVers(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMatVers(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMatVers(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMatcmpllvl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目完了レベルを設定します。
setMatdocItm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫伝票の明細を設定します。
setMatdocItm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のメソッド
入出庫伝票の明細を設定します。
setMatdocTrCancel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取消予定の転送要求の入出庫伝票番号を設定します。
setMatdocumentyear(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票会計年度を設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
品目コードを設定します｡
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
品目コードを設定します。
setMaterialDescriptionList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目テキストを設定します。
setMaterialDescriptionList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目テキストを設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コード（長）を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
項目 MATERIAL の品目コード (長)を設定します｡
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialFixed(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ロックされている品目を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コードの外部GUIDを設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
項目 MATERIAL の外部 GUIDを設定します｡
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialLongTextList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
テキスト (長)を設定します。
setMaterialRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
品目コードの範囲を設定します。
setMaterialShortDescselList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
品目テキストの選択オプション一覧を設定します。
setMaterialTextList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
テキスト (長)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コードのバージョン番号を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
項目 MATERIAL のバージョン番号を設定します｡
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialdocument(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票番号を設定します。
setMatfrgtgrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目運賃グループを設定します。
setMatfrgtgrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目運賃グループを設定します。
setMatfrgtgrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMatitemTrCancel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取消予定の転送数量入出庫伝票明細を設定します。
setMatlDesc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
品目テキストを設定します。
setMatlDesc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
品目テキストを設定します。
setMatlGroup(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
品目グループを設定します。
setMatlGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
品目グループを設定します。
setMatlGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目グループを設定します。
setMatlGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目グループを設定します。
setMatlGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループを設定します。
setMatlGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMatlGrp1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 1を設定します。
setMatlGrp2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 2を設定します。
setMatlGrp3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 3を設定します。
setMatlGrp4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 4を設定します。
setMatlGrp5(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 5を設定します。
setMatlStats(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目統計グループを設定します。
setMatlType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目タイプを設定します。
setMatlType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
品目タイプを設定します。
setMatlUsage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目の用途を設定します。
setMatlUsage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目の用途を設定します。
setMatnrHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のメソッド
終了品目コードを設定します。
setMatnrListList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
品目コードと品目テキスト一覧を設定します｡
setMatnrLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のメソッド
開始品目コードを設定します。
setMatnrSelectionList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
品目コードの選択オプション一覧を設定します。
setMatyearTrCancel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取消予定の転送要求入出庫伝票年度を設定します。
setMaxLicense(double) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
ログイングループ内の最大登録可能ライセンス数を設定します。
setMaxLotSize(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要と供給を一致させるための最大ロットサイズを設定します。
setMaxPlDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細ごとの分割納入可能な最大回数を設定します。
setMaxPlDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMaxRows(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
選択予定品目の最大数を設定します。
setMaxSbQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
最大棚番在庫数量を設定します。
setMaxStock(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最大在庫レベルを設定します。
setMaxdevDay(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
シフト所要日数を設定します。
setMaxdevDay(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMaxdevamnt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
数量に関する許容偏差 (絶対値)を設定します。
setMaxdevamnt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMaxdevper(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
数量に関する許容偏差 (%)を設定します。
setMaxdevper(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMaxlotsize(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最大ロットサイズを設定します。
setMeAnzSub(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
下位レベル数量単位数を設定します。
setMeanAbsolDev(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
絶対平均偏差 (MAD)を設定します。
setMeanAbsolDevPp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間の平均絶対偏差を設定します。
setMedia(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のメソッド
媒体を設定します。
setMedia(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel のメソッド
媒体を設定します。
setMediaCls(int) - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のメソッド
媒体種類を設定します。
setMediaCls(int) - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel のメソッド
媒体種類を設定します。
setMember(DepartmentAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織に人員を割り当てます。
setMember(PrivateGroupAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
プライベートグループに人員を割り当てます。
setMember(PublicGroupAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループに人員を割り当てます。
setMemoryComplete(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
エラーがない場合に購買発注を保留する区分を設定します｡
setMemoryUnComplete(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
エラーがある場合に購買発注を保留する区分を設定します｡
setMenu(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 MenuManager.importData(String category, InputStream inputStream)に置き換えられました。
setMenuId(String) - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
メニューIDを設定します。
setMenuLinkSetCode(String) - class jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet のメソッド
メニューリンクセットコードを設定します。
setMenuType(String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
メニュータイプを設定します。
setMerchidcl(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 決済代行会社のマーチャント IDを設定します。
setMerchidcl(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 決済代行会社のマーチャント IDを設定します。
setMessage(String) - class jp.co.intra_mart.extension.maskat.util.MKError のメソッド
messageを設定します。
setMessage(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
setMessage(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージを設定します｡
setMessage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージテキストを設定します。
setMessage(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージテキストを設定します。
setMessage(String) - class jp.co.intra_mart.framework.base.service.validator.ValidationExceptionDetail のメソッド
検証結果のメッセージを設定します。
setMessageCode(String) - class jp.co.intra_mart.extension.maskat.util.MKError のメソッド
messageCodeを設定します。
setMessageId(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
メッセージ IDを設定します。
setMessageNumber(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
システムメッセージ番号を設定します。
setMessageText(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
メッセージのテキスト行を設定します。
setMessageType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
メッセージタイプを設定します。
setMessageV1(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ１を設定します｡
setMessageV1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ変数を設定します。
setMessageV1(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ変数を設定します。
setMessageV2(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ２を設定します｡
setMessageV2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ変数を設定します。
setMessageV2(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ変数を設定します。
setMessageV3(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ３を設定します｡
setMessageV3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ変数を設定します。
setMessageV3(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ変数を設定します。
setMessageV4(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ４を設定します｡
setMessageV4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ変数を設定します。
setMessageV4(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ変数を設定します。
setMethod(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
メソッドを設定します。
setMethod(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性methodの値を設定します。
setMfrNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のメソッド
製造者番号を設定します。
setMfrNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
製造者番号を設定します。
setMfrNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造者番号を設定します。
setMfrNoExt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
外部製造者コード名または番号を設定します。
setMilestone(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
用途を設定します。
setMilestoneNumber(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン番号を設定します。
setMilestoneUsage(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン用途を設定します。
setMilitId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ID: 武器を設定します。
setMinDely(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
納品書処理時の最小納入数量を設定します。
setMinLotSize(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要と供給を一致させるための最小ロットサイズを設定します。
setMinMto(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
受注製造品最少受注数量を設定します。
setMinOrder(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
基本数量単位での最小受注数量を設定します。
setMinSafetyStk(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最小安全在庫を設定します。
setMinSbQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
最小棚番在庫数量を設定します。
setMinlotsize(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最小ロットサイズを設定します。
setMinremlife(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
最低有効期間残を設定します。
setMinremlife(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
最低有効期間残を設定します。
setMixedMrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
二重 MRP 区分を設定します。
setMlActive(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目レベルで有効な品目元帳を設定します。
setMlSettle(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目元帳決済: 管理を設定します。
setMnInvoice(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
マニュアル請求書更新を設定します。
setMnInvoice(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMnInvoice(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
マニュアル請求書更新を設定します。
setMnInvoice(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMobileEmailAddress(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
携帯用メールを設定します。
setMobileEmailAddress(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯用メールを設定します。
setMobileEmailAddress(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯用メールを設定します。
setMobileEmailAddress(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
携帯用メールを設定します。
setMobileNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
携帯電話番号を設定します。
setMobileNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯電話番号を設定します。
setMobileNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯電話番号を設定します。
setMobileNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
携帯電話番号を設定します。
setMobilePassword(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
モバイル用パスワードを設定します。
setMobilePassword(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
モバイル用パスワードを設定します。
setModelSi(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
モデル選択区分を設定します。
setModelSp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
モデル選択方式を設定します。
setModifiable(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
変更可能の可否を格納します。
setMonth(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
月を設定します。
setMonth(int) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
月を設定します。
setMovPrPp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期移動平均原価/期間平均原価を設定します。
setMovPrPy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度の移動平均原価/期間単価を設定します。
setMoveBatch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入庫/出庫ロットを設定します。
setMoveBatch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫ロットを設定します。
setMoveMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入庫/出庫品目を設定します。
setMoveMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫品目を設定します。
setMoveMatExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を設定します。
setMoveMatExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を設定します。
setMoveMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を設定します。
setMoveMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を設定します。
setMoveMatVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を設定します。
setMoveMatVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を設定します。
setMovePlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入庫/出庫プラントを設定します。
setMovePlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫プラントを設定します。
setMoveReas(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
移動理由を設定します。
setMoveReas(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
移動理由を設定します。
setMoveStloc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入庫/出庫保管場所を設定します。
setMoveStloc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫保管場所を設定します。
setMoveType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
移動タイプ (在庫管理)を設定します。
setMoveType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
移動タイプ (在庫管理)を設定します。
setMoveTypeRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
移動タイプの範囲を設定します。
setMoveValType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
転送ロットの評価タイプを設定します。
setMoveValType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
転送ロットの評価タイプを設定します。
setMovingPr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
移動平均原価/期間単位価格を設定します。
setMrpAreaExists(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: MRP エリア登録済を設定します。
setMrpCtrler(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
MRP 管理者を設定します。
setMrpGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
MRP グループを設定します。
setMrpInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所 MRP 区分を設定します。
setMrpRelevancyDepRequirements(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
従属所要量と MRP の関連性を設定します。
setMrpType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
MRP タイプを設定します。
setMrpView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
資材所要量計画 (MRP) ビューを設定します。
setMrpView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
資材所要量計画 (MRP) ビューを設定します。
setMrpView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
資材所要量計画 (MRP) ビューを設定します。
setMrpprofile(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目: MRP プロファイルを設定します。
setMsDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
品目利用可能日を設定します。
setMsDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
品目利用可能日を設定します。
setMsDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMsTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
品目供給ステージ (現地時刻: プラント参照)を設定します。
setMsTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
品目供給ステージ (現地時刻: プラント参照)を設定します。
setMsTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMsgToIm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
区分: 在庫管理への出力を設定します。
setMshost(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing のメソッド
接続先メッセージサーバIPアドレスを設定します。
setMultRefM(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費データ参照品目の乗数を設定します。
setMvtInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
移動区分を設定します。
setMvtInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
移動区分を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational のメソッド
分類区分名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational のメソッド
分類名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
組織名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
組織名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational のメソッド
役職名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループ名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のメソッド
グループ名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のメソッド
グループ名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
ユーザ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
分類区分名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
分類区分名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel のメソッド
分類区分名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
分類名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
分類名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel のメソッド
分類名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を設定します。
setName(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を設定します。
setName(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
組織名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を設定します。
setName(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を設定します。
setName(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel のメソッド
役職名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel のメソッド
役職名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel のメソッド
役職名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を設定します。
setName(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を設定します。
setName(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel のメソッド
グループ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を設定します。
setName(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を設定します。
setName(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
ユーザ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名を設定します。
setName(ExportManager, ExportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
エクスポート設定に定義された処理名をマネージャーに設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager のメソッド
エクスポート処理名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl のメソッド
エクスポート処理名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager のメソッド

setName(String) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager のメソッド

setName(String) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager のメソッド

setName(String) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager のメソッド

setName(String) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager のメソッド

setName(ImportManager, ImportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
インポート設定に定義された処理名をマネージャーに設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManager のメソッド
インポート処理名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl のメソッド
インポート処理名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager のメソッド

setName(String) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager のメソッド

setName(String) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager のメソッド

setName(String) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager のメソッド

setName(String) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager のメソッド

setName(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
名前を格納します。
setName(String) - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
項目の表示名称のを設定します。
setName(String) - class jp.co.intra_mart.foundation.page.TreeLeaf のメソッド
項目の表示名称を設定します。
setName(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
名称 1を設定します。
setName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のメソッド
管理領域名を設定します｡
setName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
一般名称を設定します｡
setName(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
名称 1を設定します。
setName(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
名称 1を設定します。
setName(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
発注者名称を設定します。
setName(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setName(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
名称 1を設定します。
setName(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
名称 1を設定します。
setName(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
名称 1を設定します。
setName(String) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチ名を設定します。
setName(String) - class jp.co.intra_mart.framework.base.event.EventTriggerInfo のメソッド
イベントトリガ名を設定します。
setName(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性nameの値を設定します。
setName(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
nameを設定します。
setName(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
nameを設定します。
setName(String) - class jp.co.intra_mart.framework.base.web.tag.ParamTag のメソッド
パラメータ名を設定します。
setName(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
nameを設定します。
setName(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性nameを設定します。
setName(String) - class jp.co.intra_mart.framework.system.property.PropertyParam のメソッド
パラメータ名を設定します。
setName(String) - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
ロール名を設定します。
setName2(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
名称 2を設定します。
setName2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
名称 2を設定します。
setName2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
名称 2を設定します。
setName3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
名称 3を設定します。
setName3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
名称 3を設定します。
setName4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
名称 4を設定します。
setName4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
名称 4を設定します。
setNameEnglish(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
組織名英字を設定します。
setNameEnglish(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
組織名英字を設定します。
setNameEnglish(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループ名英字を設定します。
setNameEnglish(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のメソッド
グループ名英字を設定します。
setNameEnglish(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のメソッド
グループ名英字を設定します。
setNameEnglish(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
ユーザ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を設定します。
setNameEnglish(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を設定します。
setNameEnglish(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を設定します。
setNameEnglish(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
組織名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名英字を設定します。
setNameEnglish(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を設定します。
setNameEnglish(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を設定します。
setNameEnglish(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を設定します。
setNameEnglish(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel のメソッド
グループ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名英字を設定します。
setNameEnglish(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を設定します。
setNameEnglish(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を設定します。
setNameEnglish(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を設定します。
setNameEnglish(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
ユーザ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名英字を設定します。
setNameEnglish(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名英字を設定します。
setNameSyllabary(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
組織名カナを設定します。
setNameSyllabary(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
組織名カナを設定します。
setNameSyllabary(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを設定します。
setNameSyllabary(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを設定します。
setNameSyllabary(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを設定します。
setNameSyllabary(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
組織名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名カナを設定します。
setNameSyllabary(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名カナを設定します。
setName_2(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
名称 2を設定します。
setName_2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
名称 2を設定します。
setName_3(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
名称 3を設定します。
setName_3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
名称 3を設定します。
setName_4(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
名称 4を設定します。
setName_4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
名称 4を設定します。
setNbSlips(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫票の印刷部数を設定します。
setNbSlipsx(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
関連ユーザデータ項目の更新情報を設定します。
setNegStocks(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラントにおけるマイナス在庫許可を設定します。
setNetPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
通貨額を設定します。
setNetPrice(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
正味価格を設定します。
setNetPrice(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
正味価格を設定します。
setNetValHd(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
受注正味額 (伝票通貨)を設定します。
setNetValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買発注通貨による正味発注額を設定します。
setNetValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
明細の正味額を設定します。
setNetValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
BAPI の通貨額 (小数点以下９桁)を設定します。
setNetValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
正味金額を設定します。
setNetValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
正味金額を設定します。
setNetValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
伝票通貨による正味額を設定します。
setNetValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
伝票通貨での受注明細正味額を設定します。
setNetValueItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
正味金額を設定します。
setNetWeight(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
正味重量を設定します。
setNetWeight(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
正味重量を設定します。
setNetWeight(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
正味重量を設定します。
setNetWeight(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細の正味重量を設定します。
setNetWeight(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setNetwork(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ネットワーク番号を設定します。
setNetwork(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
勘定割当のネットワーク番号を設定します。
setNetwork(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
勘定割当のネットワーク番号を設定します。
setNetwork(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
勘定割当のネットワーク番号を設定します。
setNetworkAssignment(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ネットワーク割当を設定します。
setNetworkAssignment(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ネットワーク割当を設定します。
setNetworkProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ネットワークプロファイルを設定します。
setNextEventItem(EventItem) - class jp.co.intra_mart.foundation.navigator.SelectItem のメソッド

setNextEventResultItem(EventResultItem) - class jp.co.intra_mart.foundation.navigator.SelectItem のメソッド

setNextItemId(String) - class jp.co.intra_mart.foundation.navigator.SelectItemInfo のメソッド
遷移先アイテムID設定
setNextPayee(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
次受取人を設定します。
setNextType(String) - class jp.co.intra_mart.foundation.navigator.SelectItemInfo のメソッド
遷移先タイプ設定
setNoAuthority(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
権限チェックなし区分に購買発注を保留する区分を設定します｡
setNoCosting(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算なしを設定します。
setNoDisct(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
現金値引対象外明細を設定します。
setNoFrlimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
制限なしを設定します。
setNoGrPost(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先が入庫を転記していませんを設定します。
setNoGrPost(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setNoLimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
制限なしを設定します。
setNoLimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
制限なしを設定します。
setNoMatmast(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目マスタ確認禁止を設定します。
setNoMessage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
出力決定なし区分に購買発注を保留する区分を設定します｡
setNoMessageReq(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
メッセージ不要区分を設定します｡
setNoMoreGr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
納入完了区分を設定します。
setNoMoreGr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
納入完了 区分を設定します。
setNoMoreGr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
納入完了 区分を設定します。
setNoPriceFromPo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
最終伝票からの価格転送なし区分を設定します｡
setNoPstChgnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
区分: 振替要求通知登録禁止を設定します。
setNoRounding(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買発注明細での非表示丸めを設定します。
setNoSheets(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書枚数 (文書管理システムによらない)を設定します。
setNoTransferReq(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
区分: 転送要求未登録を設定します。
setNoappllog(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
アプリケーションログ書込なしを設定します。
setNochangedoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
変更伝票書込なしを設定します。
setNondItax(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
BAPI の通貨額 (小数点以下９桁)を設定します。
setNoresize(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
noresizeを設定します。
setNostructure(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
チェックボックスを設定します。
setNotMrpApplicable(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
区分: MRP への入出庫予定の適用不可と購買依頼未登録を設定します。
setNote(String) - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
マウスポイント時に表示されるポップアップ文字列を設定します。
setNote(String) - class jp.co.intra_mart.foundation.page.TreeLeaf のメソッド
マウスポイント時に表示されるポップアップ文字列を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel のメソッド
説明を設定します。
setNotes(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
説明を設定します。
setNotes(String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
説明を設定します。
setNotes(String) - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
備考を設定します。
setNotifNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
通知番号を設定します。
setNotifNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setNullValue(String) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 データベースから取得されたデータがnullの場合の代替文字列を設定します。
setNullable(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
Null受付の可否を格納します。
setNumber(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ナンバーを設定します｡
setNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ番号を設定します。
setNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ番号を設定します。
setNumber(int) - class jp.co.intra_mart.framework.base.event.EventTriggerInfo のメソッド
ソート番号を設定します。
setNumberOfCapacities(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
所要能力数を設定します。
setNumberValue(double) - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
属性数値を設定します。
setNumberValue(double) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel のメソッド
属性数値を設定します。
setNumconvert(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件単位を基本単位へ変換する分子を設定します。
setNumconvert(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件単位を基本単位へ変換する分子を設定します。
setNumerator(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
基本数量単位への換算分子を設定します。
setObjKey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
対象キーを設定します。
setObjKey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
対象キーを設定します。
setObjTxt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
言語依存対象テキストを設定します。
setObjType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
対象タイプを設定します。
setObjType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
対象タイプを設定します。
setObjectGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
インスタンス用 TYPE_OF ステートメントの GUIDを設定します。
setObjectNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
対象番号を設定します。
setObjectNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
対象番号を設定します。
setObjectType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
オブジェクトタイプを設定します。
setObjectclass(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
オブジェクトクラス (言語非依存)を設定します。
setObjectclass(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
対象クラスを設定します。
setObjectclass(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
対象クラスを設定します。
setObjectclassExt(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
オブジェクトクラス、言語依存を設定します。
setObjectclassExt(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
オブジェクトクラス、言語依存を設定します。
setObjectclassExt(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
オブジェクトクラス、言語依存を設定します。
setOffsetMilestoneDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン日付のオフセットを設定します。
setOffsetMilestoneDateUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーンのオフセットのための時間単位を設定します。
setOffsetMilestoneDateUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
単位の ISO コードを設定します。
setOffsetPercentage(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
活動日に対するマイルストーンの百分率によるオフセットを設定します。
setOffsetStartEndIndicator(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
区分: オフセット用の参照（開始/終了活動日）を設定します。
setOldMatNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
旧品目コードを設定します。
setOnChange(String) - class jp.co.intra_mart.foundation.page.EventScript のメソッド
監視している値に変更があった場合に実行するスクリプトを指定します。
setOnClick(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onClickの値を設定します。
setOnDblClick(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性obDblClickの値を設定します。
setOnKeyDown(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyDownの値を設定します。
setOnKeyPress(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyPressの値を設定します。
setOnKeyUp(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyUpの値を設定します。
setOnMouseDown(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseDownの値を設定します。
setOnMouseMove(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseMoveの値を設定します。
setOnMouseOut(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseOutの値を設定します。
setOnMouseOver(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseOverの値を設定します。
setOnMouseUp(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseUpの値を設定します。
setOnblur(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
onblurを設定します。
setOnblur(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
onblurを設定します。
setOnblur(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onBlurを設定します。
setOnclick(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onClickの値を設定します。
setOnclick(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onClickの値を設定します。
setOnclick(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onClickの値を設定します。
setOnclick(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onClickの値を設定します。
setOndblclick(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性obDblClickの値を設定します。
setOndblclick(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性obDblClickの値を設定します。
setOndblclick(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性obDblClickの値を設定します。
setOndblclick(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性obDblClickの値を設定します。
setOnfocus(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
onfocusを設定します。
setOnfocus(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
onfocusを設定します。
setOnfocus(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onFocusを設定します。
setOnkeydown(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onKeyDownの値を設定します。
setOnkeydown(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onKeyDownの値を設定します。
setOnkeydown(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onKeyDownの値を設定します。
setOnkeydown(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onKeyDownの値を設定します。
setOnkeypress(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onKeyPressの値を設定します。
setOnkeypress(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onKeyPressの値を設定します。
setOnkeypress(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onKeyPressの値を設定します。
setOnkeypress(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onKeyPressの値を設定します。
setOnkeyup(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onKeyUpの値を設定します。
setOnkeyup(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onKeyUpの値を設定します。
setOnkeyup(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onKeyUpの値を設定します。
setOnkeyup(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onKeyUpの値を設定します。
setOnmousedown(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseDownの値を設定します。
setOnmousedown(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseDownの値を設定します。
setOnmousedown(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseDownの値を設定します。
setOnmousedown(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseDownの値を設定します。
setOnmousemove(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseMoveの値を設定します。
setOnmousemove(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseMoveの値を設定します。
setOnmousemove(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseMoveの値を設定します。
setOnmousemove(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseMoveの値を設定します。
setOnmouseout(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseOutの値を設定します。
setOnmouseout(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseOutの値を設定します。
setOnmouseout(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseOutの値を設定します。
setOnmouseout(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseOutの値を設定します。
setOnmouseover(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseOverの値を設定します。
setOnmouseover(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseOverの値を設定します。
setOnmouseover(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseOverの値を設定します。
setOnmouseover(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseOverの値を設定します。
setOnmouseup(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseUpの値を設定します。
setOnmouseup(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseUpの値を設定します。
setOnmouseup(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseUpの値を設定します。
setOnmouseup(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseUpの値を設定します。
setOnreset(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onResetの値を設定します。
setOnsubmit(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onSubmitの値を設定します。
setOpen(String) - class jp.co.intra_mart.foundation.navigator.EventFlow のメソッド

setOpen(String) - class jp.co.intra_mart.foundation.navigator.EventFlowInfo のメソッド
公開フラグ設定
setOpenQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
未処理数量のある明細を設定します。
setOperationMeasureUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動単位を設定します。
setOperationMeasureUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setOptimLev(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
最適化レベルを設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Selection のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOrdCosts(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
発注原価 (BAPI インタフェース)を設定します。
setOrdReason(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
受注理由 (取引理由)を設定します。
setOrdReason(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setOrdReason(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
受注理由 (取引理由)を設定します。
setOrdbilltyp(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
受注関連請求伝票に対する提案請求伝票タイプを設定します。
setOrdcombIn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
受注結合出荷区分を設定します。
setOrdcombIn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setOrdcompIn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
受注結合出荷区分を設定します。
setOrdcompIn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setOrder(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
指図番号 (個別値、または下限値)を設定します。
setOrder(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
指図番号 (個別値、または下限値)を設定します。
setOrder(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
指図番号を設定します。
setOrder(String) - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
指図番号を設定します。
setOrderCcardList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
クレジットカードデータを設定します。
setOrderCfgsBlobList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: BLOB 内部データ (SCE)を設定します。
setOrderCfgsInstList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: インスタンスを設定します。
setOrderCfgsPartOfList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: 部分設定を設定します。
setOrderCfgsRefInstList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: 参照明細/インスタンスを設定します。
setOrderCfgsRefList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: 参照データを設定します。
setOrderCfgsValueList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: 特性値を設定します。
setOrderCfgsVkList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: バリアント条件キーを設定します。
setOrderConditionsInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
条件を設定します。
setOrderConditionsInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
条件チェックボックスを設定します。
setOrderExternalNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
外部指図番号 (個別値、または下限値)を設定します。
setOrderExternalNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
外部指図番号 (個別値、または下限値)を設定します。
setOrderExternalNoTo(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
外部指図番号 (上限値)を設定します。
setOrderExternalNoTo(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
外部指図番号 (上限値)を設定します。
setOrderHeaderIn(HeaderIn) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
受注伝票ヘッダを設定します。
setOrderHeaderInX(HeaderInX) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
受注伝票チェックリストを設定します。
setOrderItemsInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
明細データを設定します。
setOrderItemsInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
明細データチェックボックスを設定します。
setOrderItno(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
指図明細番号を設定します。
setOrderItno(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
指図明細番号を設定します。
setOrderKeysList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
参照キーの出力テーブルを設定します。
setOrderListList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
選択指図一覧を設定します。
setOrderListList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
選択指図一覧を設定します。
setOrderName(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
テキストを設定します。
setOrderName(String) - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
テキストを設定します。
setOrderPartnersList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
伝票取引先を設定します。
setOrderProb(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細の受注可能性を設定します。
setOrderProb(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setOrderReason(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
発注理由を設定します。
setOrderSchedulesInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
納入日程行データを設定します。
setOrderSchedulesInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
納入日程行データチェックボックスを設定します。
setOrderSortNum(EventNavigatorManager, EventFlowInfo[]) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
setOrderSortNum(EventFlowInfo[]) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
setOrderSortNum(EventNavigatorManager, EventFlowInfo[]) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
setOrderTextList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
テキストを設定します。
setOrderTo(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
指図番号 (上限値)を設定します。
setOrderTo(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
指図番号 (上限値)を設定します。
setOrderType(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
指図タイプを設定します。
setOrderType(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
指図タイプを設定します。
setOrderType(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
販売伝票タイプを設定します。
setOrderType(String) - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
販売伝票タイプを設定します。
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
指図番号を設定します。
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
指図番号を設定します。
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
指図番号を設定します。
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
指図番号を設定します。
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
指図番号を設定します。
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
指図番号を設定します。
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
指図番号を設定します。
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setOrderprUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買発注価格単位を設定します。
setOrderprUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
購買発注価格単位 (購買管理)を設定します。
setOrderprUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
購買発注価格単位 (購買管理)を設定します。
setOrderprUnIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買発注価格のISOコードを設定します。
setOrderprUnIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
単位の ISO コードを設定します。
setOrderprUnIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
単位の ISO コードを設定します。
setOrigGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
発生源グループ (原価要素の下位区分)を設定します。
setOrigMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目発生源を設定します。
setOriginalBatchFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
元ロット管理区分を設定します。
setOriginalBatchRefMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
元ロットの参照品目を設定します。
setOrigindoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
開始伝票を設定します。
setOurRef(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
社内参照番号を設定します｡
setOutlInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
区分: 出力行を設定します。
setOutlLevel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
グループの階層レベルを設定します。
setOutlNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
アウトラインレベルを設定します。
setOverDlvTol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
過剰納入許容範囲を設定します。
setOverTol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
過剰納入許容範囲リミットを設定します。
setOverallprf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
指図変更管理の全体プロファイルを設定します。
setOverdlvtol(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
過剰納入許容範囲を設定します。
setOverdlvtol(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setOverhdKey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
間接費キーを設定します。
setOverhdKey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setOverheadGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
原価計算間接費グループを設定します。
setOverheadKey(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
間接費キーを設定します。
setOverheadKey(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
間接費キーを設定します。
setOvfTol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
超過許容値を設定します。
setOvfUnlim(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
契約外サービス制限なしを設定します。
setOwnerCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
所有者コードを設定します。
setOwnerCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
所有者コードを設定します。
setPMatExt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を設定します。
setPMatExt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を設定します。
setPMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPMatVers(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を設定します。
setPMatVers(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPaAllocNmbr(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細のソートキーに値を設定します。
setPaAllocNmbr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
ソートキーコードを設定します｡
setPaBlineDate(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細の期日計算の支払基準日に値を設定します。
setPaBlineDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
期日計算の支払基準日コードを設定します｡
setPaGlAccount(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細の総勘定元帳勘定に値を設定します。
setPaGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
総勘定元帳勘定コードを設定します｡
setPaIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
レコード番号を設定します｡
setPaIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
レコード番号を設定します｡
setPaItemText(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細の明細テキストに値を設定します。
setPaItemText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
明細テキストコードを設定します｡
setPaItemnoAcc(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細の会計伝票明細番号に値を設定します。
setPaItemnoAcc(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
会計伝票明細番号コードを設定します｡
setPaPymtMeth(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細の支払方法に値を設定します。
setPaPymtMeth(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
支払方法を設定します｡
setPaVendorNo(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細の仕入先または債権者の勘定コードに値を設定します。
setPaVendorNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
仕入先または債権者の勘定コードコードを設定します｡
setPackVoUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
容積単位 (許容梱包容積)を設定します。
setPackVoUnIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードでの容積単位 (許容梱包容積)を設定します。
setPackWtUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
重量単位 (許容梱包重量)を設定します。
setPackWtUnIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードでの重量単位 (許容梱包重量)を設定します。
setPageItem(ResultPageItem[]) - class jp.co.intra_mart.foundation.navigator.EventResultItem のメソッド

setPageNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書ページ番号 (文書管理システムによらない)を設定します。
setPagePath(String) - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のメソッド
実行するスクリプト開発モデルのページパスを設定します。
setPagePatternId(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
メインページパターンを設定します。
setPageformat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造メモのページ書式を設定します。
setParCompco(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
決済会社コードを設定します。
setParEff(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
有効性パラメータへの値割当/変更番号よりも優先を設定します。
setParamName(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
パラメタ名を設定します｡
setParamOpt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
パラメータ最適化用の区分を設定します。
setParamType(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
パラメタ属性を設定します｡
setParamValue(String, String) - class jp.co.intra_mart.foundation.navigator.LinkPageInfo のメソッド

setParameter(String, Object) - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager のメソッド
パラメータを設定します。
setParameter(String, Object) - class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl のメソッド
パラメータを設定します。
setParameter(String, Object) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager のメソッド

setParameter(String, Object) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager のメソッド

setParameter(String, Object) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager のメソッド

setParameter(String, Object) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager のメソッド

setParameter(String, Object) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager のメソッド

setParameter(String, Object) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManager のメソッド
パラメータを設定します。
setParameter(String, Object) - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl のメソッド
パラメータを設定します。
setParameter(String, Object) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager のメソッド

setParameter(String, Object) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager のメソッド

setParameter(String, Object) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager のメソッド

setParameter(String, Object) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager のメソッド

setParameter(String, Object) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager のメソッド

setParameter(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
パラメーターを設定します｡
setParameter(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
パラメータ名を設定します。
setParameter(String, String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
イベントへのパラメータを設定します。
setParameter(String, String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
イベントへのパラメータを設定します。
setParameter(String, String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
イベントへのパラメータを設定します。
setParameters(ExportManager, ExportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
エクスポート設定に定義されたパラメータ情報をマネージャーに設定します。
setParameters(ImportManager, ImportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
エクスポート設定に定義されたパラメータ情報をマネージャーに設定します。
setParentId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
1 レベル上位の行 IDを設定します。
setParentId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
1 レベル上位の行 IDを設定します。
setParentId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
選定におけるインスタンス番号を設定します。
setParentItemCategoryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
親商品カテゴリコードを設定します。
setParentItemCategoryCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
親商品カテゴリコードを設定します。
setParentMenuId(String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
親メニューIDを設定します。
setParserKey(String) - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet のメソッド
RSS解析キーを設定します。
setPartAcct(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
取引先勘定コードを設定します。
setPartAcct(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
取引先勘定コードを設定します。
setPartAcct(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取引先勘定コードを設定します。
setPartDeliv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
明細レベルでの分割納入 (在庫転送)を設定します。
setPartDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細レベルの分納納入を設定します。
setPartDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPartInv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
一部請求区分を設定します。
setPartOfGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
インスタンス用 PART_OF ステートメントの GUIDを設定します。
setPartOfNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
Part_of 明細番号を設定します。
setPartnNumb(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
得意先コード 1を設定します。
setPartnRole(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
取引先機能を設定します。
setPartnerAddressesList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
アドレス (組織/会社) 用 BAPI 参照構造を設定します。
setPartnerAddressesList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
アドレス (組織/会社) 用 BAPI 参照構造を設定します。
setPartnerAddressesList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
アドレス (組織/会社) 用 BAPI 参照構造を設定します。
setPartnerBk(String) - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
取引先銀行タイプを設定します。
setPartnerList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
取引先一覧を設定します｡
setPartnerdesc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
言語別取引先機能テキストを設定します。
setPasswd(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
パスワードを設定します。
setPasswd(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
パスワードを設定します。
setPasswd(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 パスワードを設定します｡
setPassword(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
パスワードを設定します。
setPassword(String) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
パスワード設定。
setPassword(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインパスワードを設定する。
setPassword(String) - class jp.co.intra_mart.foundation.security.password.PasswordHistory のメソッド
パスワードを設定します。
setPassword(String) - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler のメソッド
パスワードを設定します。
setPassword(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
パスワードを設定します。
setPayer(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
支払人を設定します。
setPaymentMethods(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
考慮される支払方法一覧を設定します。
setPaymentTerms(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
支払条件キーを設定します。
setPaytype(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払手段: 支払カード計画の明細分類を設定します。
setPboxcitNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村私書箱コード (市ファイル)を設定します。
setPboxcitNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村私書箱コード (市ファイル)を設定します。
setPboxcitNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村私書箱コード (市ファイル)を設定します。
setPckgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
パッケージ番号を設定します。
setPckgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
パッケージ番号を設定します。
setPckgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
パッケージ番号を設定します。
setPckgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のメソッド
パッケージ番号を設定します。
setPckgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
パッケージ番号を設定します。
setPckgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
パッケージ番号を設定します。
setPcode1Ext(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村郵便番号の拡張子 例: 郵便番号 +4+2を設定します。
setPcode2Ext(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱郵便番号拡張子 例: 郵便番号 +4+2を設定します。
setPcode3Ext(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
主要得意先郵便番号拡張子 例: 郵便番号 +4+2を設定します。
setPctrName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
一般名称を設定します｡
setPerCurCostEst(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
現行標準原価見積期間を設定します。
setPerFutCostEst(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
将来標準原価見積期間を設定します。
setPerPreCostEst(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前標準原価見積期間を設定します。
setPercentOfWork(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
作業の比率 (%)を設定します。
setPercentage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
勘定設定金額配賦のパーセントを設定します。
setPercentageOfCompletion(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
進捗度 (%)を設定します。
setPeriodInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
期間区分を設定します。
setPeriodInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
期間区分を設定します。
setPeriodIndExpirationDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
有効期間期限日の期間区分を設定します。
setPeriodIndExpirationDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
有効期間期限日の期間区分を設定します。
setPeriodProfileSafetyTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
安全時間の期間プロファイルを設定します。
setPermissionCheck(boolean) - class jp.co.intra_mart.foundation.navigator.EventFlowInfo のメソッド
パーミッションチェックフラグ設定
setPermissionCheck(boolean) - class jp.co.intra_mart.foundation.navigator.ResultPageItemInfo のメソッド
パーミッションチェックフラグ設定
setPermissionCheck(boolean) - class jp.co.intra_mart.foundation.navigator.SelectItemInfo のメソッド
パーミッションチェックフラグ設定
setPermissionToDepartment(DealerDepartment) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager のメソッド
組織に対してアクセス権を設定します。
setPermissionToPublicGroup(DealerPublicGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager のメソッド
パブリックグループに対してアクセス権を設定します。
setPermissionToRole(DealerRole) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager のメソッド
ロールに対してアクセス権を設定します。
setPersNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
従業員番号を設定します。
setPersistId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
インスタンス番号 (固定)を設定します。
setPersistIdType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
インスタンス番号タイプ (固定)を設定します。
setPersonResp(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
責任者を設定します。
setPersonRespPhone(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
責任者の電話番号を設定します。
setPickArea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
ピッキングエリアを設定します。
setPickgArea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
簡易倉庫管理のピッキングエリアを設定します。
setPlRefMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
梱包方法が同じ品目の参照品目を設定します。
setPlTiFnce(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
計画タイムフェンスを設定します。
setPlacement(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
在庫受入に対する保管域タイプ検索区分を設定します。
setPlanBasic(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト基準日付計画方法を設定します。
setPlanDel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
予定納入日数を設定します。
setPlanFcst(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト予測日付の計画方法を設定します。
setPlanProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
計画プロファイルを設定します。
setPlanSchedType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程行タイプ EDIを設定します。
setPlanSchedType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPlanStrgp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
計画方針グループを設定します。
setPlanlistcnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
グループカウンタを設定します。
setPlanlistgrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
タスクリストグループのキーを設定します。
setPlannedCost(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画原価を設定します。
setPlanningData(PlanningData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目マスタ/製品グループの変更伝票構造を設定します。
setPlanningDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目マスタ/製品グループの変更伝票構造を設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
プラントを設定します。
setPlantData(PlantData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目データ (プラントレベル)を設定します。
setPlantDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目データ (プラントレベル)を設定します。
setPlantHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のメソッド
対象プラント 終了を設定します。
setPlantLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のメソッド
対象プラント 開始を設定します。
setPlantRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
プラントの範囲を設定します。
setPlantSelectionList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
プラントの選択オプション一覧を設定します｡
setPldlvshdin(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷計画に関する指示を設定します。
setPldlvshdin(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPldlvstyp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
MRP: 出荷計画タイプを設定します。
setPldlvstyp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPlnClose(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
計画終了日付を設定します。
setPlnCompletion(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
計画完了日を設定します。
setPlnLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: 計画梱包明細行を設定します。
setPlnPckg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
パッケージ番号供給元一覧を設定します。
setPlnRelease(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
計画リリース日付を設定します。
setPlndDelry(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予定納入時間 (単位: 日)を設定します。
setPlndDelry(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
予定納入時間 (単位: 日)を設定します。
setPlndPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定計画原価を設定します。
setPlndprdate1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定原価 1 の有効開始日を設定します。
setPlndprdate2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定原価 2 の有効開始日を設定します。
setPlndprdate3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定原価 3 の有効開始日を設定します。
setPlndprice1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定計画原価 1を設定します。
setPlndprice2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定計画原価 2を設定します。
setPlndprice3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定計画原価 3を設定します。
setPlngCycle(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
計画サイクルを設定します。
setPlngMatl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
計画品目を設定します。
setPlngMatlExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
項目 PLNG_MATL の品目コード (長) (今後のリリースで開発)を設定します。
setPlngMatlGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
項目 PLNG_MATL の外部 GUID (今後のリリースで開発)を設定します。
setPlngMatlVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
項目 PLNG_MATL のバージョン番号 (今後のリリースで開発)を設定します。
setPlngPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
計画プラントを設定します。
setPlordCtrl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
アクション管理: 計画手配処理を設定します。
setPlugin(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
プラグインIDを設定します。
setPluginMethod(String) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
プラグイン関数を設定します。
setPmnttrms(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
支払条件キーを設定します。
setPmnttrms(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
支払条件キーを設定します｡
setPmnttrms(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
支払条件キーを設定します。
setPmnttrms(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPmnttrms(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
支払条件キーを設定します。
setPmnttrms(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPmtgarPro(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
支払保証決定表を設定します。
setPmtgarPro(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPmtgarPro(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
支払保証決定表を設定します。
setPmtgarPro(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoBox(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
私書箱を設定します。
setPoBox(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
私書箱を設定します。
setPoBox(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱を設定します。
setPoBox(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
私書箱を設定します。
setPoBoxCit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
私書箱住所を設定します。
setPoBoxCit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
私書箱住所を設定します。
setPoBoxCit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱住所を設定します。
setPoBoxReg(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱の地域 (国、都道府県、地域、...)を設定します。
setPoCtryiso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
ISO 国コードを設定します。
setPoDatS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先の出荷先発注日付を設定します。
setPoDatS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoDatS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先の出荷先発注日付を設定します。
setPoDatS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入日程の購買発注日付を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
購買伝票の明細番号を設定します。
setPoItmNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
元となる購買発注の明細番号を設定します。
setPoItmNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoItmNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
元となる購買発注の明細番号を設定します。
setPoMethS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先の出荷先発注タイプを設定します。
setPoMethS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoMethS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先の出荷先発注タイプを設定します。
setPoMethS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoMethod(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先発注タイプを設定します。
setPoMethod(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoMethod(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先発注タイプを設定します。
setPoMethod(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買伝票番号を設定します｡
setPoNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買伝票番号を設定します。
setPoNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
購買伝票番号に値を設定します。
setPoNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
購買伝票番号を設定します。
setPoNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
購買伝票番号を設定します。
setPoNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
購買発注番号を設定します。
setPoNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
購買発注番号を設定します。
setPoPrQnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
数量 (購買発注価格単位)を設定します。
setPoPrQnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
数量 (購買発注価格単位)を設定します。
setPoPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
価格採用区分を設定します。
setPoRelCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
承認コードを設定します。
setPoRelInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
承認区分: 購買伝票を設定します。
setPoSupplem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先発注番号補足を設定します。
setPoSupplem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
発注単位を設定します。
setPoUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
発注単位を設定します。
setPoUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
ISOコードによる発注単位を設定します。
setPoUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードによる発注単位を設定します。
setPoWONo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
フラグ: 郵便私書箱 (番号なし)を設定します。
setPoboxCtry(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱の国指定を設定します。
setPobxCty(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
私書箱住所を設定します。
setPobxCty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
私書箱住所を設定します。
setPobxPcd(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
私書箱番号を設定します。
setPobxPcd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
私書箱番号を設定します。
setPointUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ポイント単位を設定します。
setPointUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ポイント単位の ISO コードを設定します。
setPoints(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
リベートポイント数を設定します。
setPoitmNoS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoitmNoS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
元となる購買発注の明細番号を設定します。
setPoitmNoS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoolName(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 プール名称を設定します｡
setPoolSize(int) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 プール内のコネクション数を設定します｡
setPoolnumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
LIFO 評価でのプール番号を設定します。
setPoolnumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData のメソッド
LIFO 評価でのプール番号を設定します。
setPopup(boolean) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
リンクへ参照時にポップアップを呼び出すかどうかを設定します。
setPortlet(Portlet) - class jp.co.intra_mart.foundation.portal.portlet.PortletManager のメソッド
ポートレット情報を登録します。
setPortletCode(String) - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
ポートレットコードを設定します。
setPortletName(String) - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
ポートレット名を設定します。
setPosex(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
外部明細番号を設定します。
setPosex(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
外部明細番号を設定します。
setPost(int, PostInfo) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

setPostCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable のメソッド
役職CDを設定します。
setPostCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
役職コードを設定します。
setPostCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
役職CDを設定します。
setPostCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
役職CDを設定します。
setPostCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel のメソッド
役職CDを設定します。
setPostDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンの転記日付を設定します。
setPostDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
バージョンの転記日付を設定します。
setPostlCod1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村の郵便番号を設定します。
setPostlCod1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村の郵便番号を設定します。
setPostlCod1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村の郵便番号を設定します。
setPostlCod2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
私書箱郵便番号を設定します。
setPostlCod2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
私書箱郵便番号を設定します。
setPostlCod2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱郵便番号を設定します。
setPostlCod3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
会社郵便番号 (大規模なユーザ用)を設定します。
setPostlCod3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
会社郵便番号 (大規模なユーザ用)を設定します。
setPostlCod3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
会社郵便番号 (大規模なユーザ用)を設定します。
setPostlCode(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
郵便番号を設定します。
setPostlCode(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
郵便番号を設定します。
setPostlCode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
郵便番号を設定します。
setPosts(PostInfo[]) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

setPpSearch(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
品目提案検索条件を設定します。
setPpSearch(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPpcPlCal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
PPC 計画カレンダを設定します。
setPrClosed(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買依頼処理済を設定します。
setPrCtrlPp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期間の原価管理区分を設定します。
setPrCtrlPy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度の原価管理区分を設定します。
setPrIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
レコード番号を設定します｡
setPrRefMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
価格設定参照品目を設定します。
setPrRefMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
価格設定参照品目を設定します。
setPrRefMat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格設定参照品目を設定します。
setPrRefMat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPrRefMatExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を設定します。
setPrRefMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を設定します。
setPrRefMatVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を設定します。
setPrUname(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
ユーザ名を設定します。
setPrUnitPp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期価格単位を設定します。
setPrUnitPy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度価格単位を設定します。
setPrcGroup1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 1を設定します。
setPrcGroup1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPrcGroup2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 2を設定します。
setPrcGroup2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPrcGroup3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 3を設定します。
setPrcGroup3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPrcGroup4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 4を設定します。
setPrcGroup4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPrcGroup5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 5を設定します。
setPrcGroup5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPrcStatH(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
伝票の全処理ステータスを設定します。
setPreVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
製造元/販売元を設定します。
setPrefStatFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 特恵関税 - 輸出/輸入を設定します。
setPreqItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買依頼の明細番号を設定します。
setPreqItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買依頼の明細番号を設定します。
setPreqName(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買依頼者名/要求者名を設定します。
setPreqNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買依頼番号を設定します。
setPreqNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買依頼番号を設定します。
setPrevPlanPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法基準評価額: レベル 2を設定します。
setPrice(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
価格を設定します。
setPriceChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
入力シートの価格変更を設定します。
setPriceChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力シートの価格変更を設定します。
setPriceChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
入力シートの価格変更を設定します。
setPriceCtrl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
原価管理区分を設定します。
setPriceDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
価格設定日を設定します。
setPriceDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
価格設定/外貨換算の実行日付を設定します。
setPriceDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格設定/外貨換算の実行日付を設定します。
setPriceDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPriceDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格設定/外貨換算の実行日付を設定します。
setPriceDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPriceGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格グループ (得意先)を設定します。
setPriceGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPriceGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格グループ (得意先)を設定します。
setPriceGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPriceList(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格表タイプを設定します。
setPriceList(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPriceList(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格表タイプを設定します。
setPriceList(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPriceUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
価格単位を設定します。
setPriceUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
価格単位を設定します。
setPriceUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
価格単位を設定します。
setPriceUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
価格単位を設定します。
setPricedate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
価格設定日カテゴリ (価格設定日管理)を設定します。
setPricing(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
価格設定タイプを設定します。
setPriority(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
優先度を設定します。
setPriority(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
優先度を設定します。
setPrivAddr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
自宅住所を設定します。
setPrivateGroupCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
グループコードを設定します。
setPrivateGroupCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループコードを設定します。
setPrntPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
価格印刷を設定します。
setProcRule(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
調達規則を設定します。
setProcTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
処理時間を設定します。
setProcType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
調達タイプを設定します。
setProcedure(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
決定表 (価格設定/出力管理/勘定設定/原価計算など)を設定します。
setProcessing(boolean) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
クライアントのアクセスに対して処理中がどうか設定する。
setProcessingGroup(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
処理グループを設定します。
setProcureUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
保管容量消費の数量単位を設定します。
setProcureUnIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードでの保管容量消費の数量単位を設定します。
setProdAlloc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製品割当決定手順を設定します。
setProdAtt1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
ID: 製品属性 1を設定します。
setProdAtt10(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 10 用 IDを設定します。
setProdAtt2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 2 用 IDを設定します。
setProdAtt3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 3 用 IDを設定します。
setProdAtt4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 4 用 IDを設定します。
setProdAtt5(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 5 用 IDを設定します。
setProdAtt6(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 6 の IDを設定します。
setProdAtt7(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 7 用 IDを設定します。
setProdAtt8(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 8 用 IDを設定します。
setProdAtt9(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 9を設定します。
setProdCompositionOnPackaging(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: 梱包材にプリントされた生産構造を設定します。
setProdConvType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
生産値の変換タイプを設定します。
setProdDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
ロット製造日付を設定します。
setProdDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
ロット製造日付を設定します。
setProdHier(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目階層を設定します。
setProdHier(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目階層を設定します。
setProdHier(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目階層を設定します。
setProdHiera(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目階層を設定します。
setProdHiera(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setProdMemo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造/検査メモを設定します。
setProdUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造単位を設定します。
setProdUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造単位 (ISO コード)を設定します。
setProdcat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
製品カタログ番号を設定します。
setProdcat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setProdcomNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
生産統計: 貿易における PRODCOM コードを設定します。
setProdprof(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造計画プロファイルを設定します。
setProductModelCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
製品型番を設定します。
setProductModelCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
製品型番を設定します。
setProductionResourceToolData(ProductionResourceToolData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目マスタの生産資源/治工具 (PRT) 項目を設定します。
setProductionScheduler(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造計画担当を設定します。
setProdverscs(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算を行う製造バージョンを設定します。
setProfitCentList(ProfitCenterList) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタ一覧を設定します｡
setProfitCenterList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList のメソッド
利益センタ一覧を設定します｡
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
利益センタを設定します｡
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setProfitSegmNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
収益性セグメント番号 (CO-PA)を設定します。
setProfitSegmNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
収益性セグメント番号 (CO-PA)を設定します。
setProfitSegmNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
収益性セグメント番号 (CO-PA)を設定します。
setProfitSegmentList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
入出庫予定一覧を設定します｡
setProgramLanguage(String) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行プログラム言語の種類を設定します。
setProgramLanguage(String) - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行プログラム言語を設定します。
setProgramPath(String) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行プログラムパスを設定します。
setProgramPath(String) - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行プログラムパスを設定します。
setProjType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
プロジェクトタイプを設定します。
setProjectCurrency(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
WBS 通貨(プロジェクト定義)を設定します。
setProjectCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ISO 通貨コードを設定します。
setProjectDefinition(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
プロジェクト定義を設定します。
setProjectDefinition(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
プロジェクト定義を設定します。
setProjectDefinition(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
プロジェクト定義を設定します。
setProjectDefinition(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト定義を設定します。
setProjectDefinition(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
プロジェクト定義を識別するキーを設定します。
setProjectDefinition(ProjectDefinition) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
プロジェクトについての詳細情報を設定します。
setProjectDefinition(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
プロジェクト定義を識別するキーを設定します。
setProjectDefinition(ProjectDefinition) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
プロジェクトについての詳細情報を設定します。
setProjectProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクトプロファイルを設定します。
setProjectStock(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト在庫を設定します。
setProjectSummarization(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
区分: プロジェクト集計用に活動を考慮を設定します。
setPromotion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
プロモーションを設定します。
setPromotion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPromotion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
プロモーションを設定します。
setPromotion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setProperties(Map) - class jp.co.intra_mart.framework.system.property.PropertyConfigModel のメソッド
パラメータを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor のメソッド
プロパティを設定します。
setProperty(Properties) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティファイル情報を設定します｡
setPropertyKeyPart(String[]) - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のメソッド
プロパティのキーを設定します｡
setPropertyName(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティファイル名を設定します｡
setPropertyValue(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のメソッド
プロパティの値を設定します｡
setPropeties(Properties) - class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile のメソッド
プロパティを設定します｡
setProvider(Provider) - class jp.co.intra_mart.framework.base.data.container.factory.DataContainerFactory のメソッド
プロバイダを設定します。
setProvider(Provider) - class jp.co.intra_mart.framework.base.event.container.factory.EventContainerFactory のメソッド
プロバイダを設定します。
setProvider(Provider) - class jp.co.intra_mart.framework.base.service.container.factory.ServiceContainerFactory のメソッド
プロバイダを設定します。
setProvider(Provider) - interface jp.co.intra_mart.framework.system.container.factory.IMContainerFactory のメソッド

setProviderUrl(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
プロパイダーURLを設定する。
setProxyHost(String) - interface jp.co.intra_mart.foundation.portal.common.rss.RSSParserIF のメソッド
Proxyホスト名をセットします
setProxyHost(String) - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet のメソッド
プロキシホスト名を設定します。
setProxyPort(String) - interface jp.co.intra_mart.foundation.portal.common.rss.RSSParserIF のメソッド
Proxyポート番号をセットします
setProxyPort(int) - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet のメソッド
プロキシポート番号を設定します。
setPrtDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目マスタの生産資源/治工具 (PRT) 項目を設定します。
setPrtUsage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具用途を設定します。
setPrtUsage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具用途を設定します。
setPrtView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
生産資源/治工具 (PRT) ビューを設定します。
setPrtView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
生産資源/治工具 (PRT) ビューを設定します。
setPsConfMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
選定可能品目を設定します。
setPstngDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
伝票の転記日付を設定します。
setPstngDateRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
登録日付の範囲を設定します。
setPublicGroup(int, PublicGroupInfo) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

setPublicGroupCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup のメソッド
グループコードを設定します。
setPublicGroupCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
グループコードを設定します。
setPublicGroupCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
グループコードを設定します。
setPublicGroupCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループコードを設定します。
setPublicGroupSetCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup のメソッド
グループセットコードを設定します。
setPublicGroupSetCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
グループセットコードを設定します。
setPublicGroupSetCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
グループセットコードを設定します。
setPublicGroupSetCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループセットコードを設定します。
setPublicGroupSetCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループセットコードを設定します。
setPublicGroupSetCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
グループセットコードを設定します。
setPublicGroups(PublicGroupInfo[]) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

setPurGroup(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
購買グループを設定します。
setPurGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買グループを設定します｡
setPurGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
購買グループを設定します。
setPurMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
品目コードを設定します。
setPurMatExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
項目 PURMAT の品目コード (長) (今後のリリースで開発)を設定します。
setPurMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
項目 PURMAT の外部 GUID (今後のリリースで開発)を設定します。
setPurMatVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
項目 PURMAT のバージョン番号 (今後のリリースで開発)を設定します。
setPurStatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
プラント共通品目ステータスを設定します。
setPurStatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラント特有品目ステータスを設定します。
setPurValkey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
購買許容値キーを設定します。
setPurchDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先発注日付を設定します。
setPurchDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPurchDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先発注日付を設定します。
setPurchDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPurchNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
得意先発注番号を設定します。
setPurchNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
得意先発注番号を設定します。
setPurchNoC(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先発注番号を設定します。
setPurchNoC(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPurchNoC(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先発注番号を設定します。
setPurchNoC(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPurchNoC(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出荷先発注番号を設定します。
setPurchNoS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先の得意先発注番号を設定します。
setPurchNoS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPurchNoS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先の得意先発注番号を設定します。
setPurchNoS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPurchOrd(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
出荷先発注番号を設定します。
setPurchOrg(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
購買組織を設定します。
setPurchOrg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買組織を設定します｡
setPurchView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
購買管理ビューを設定します。
setPurchaseAccountList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
勘定設定一覧を設定します｡
setPurchaseHeadersList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
伝票ヘッダ一覧を取得します｡を設定します。
setPurchaseHeadersList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
伝票ヘッダ一覧を設定します。
setPurchaseItemPostList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
明細一覧を設定します｡
setPurchaseItemsList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
伝票明細一覧を取得します｡を設定します。
setPurchaseItemsList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
伝票明細一覧を設定します。
setPurchaseOrder(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
得意先発注番号を設定します。
setPurchaseOrderNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
得意先発注番号1を設定します。
setPurchaseScheduleList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
納入日程一覧を設定します｡
setPurchaseUnitPrice(double) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable のメソッド
仕入単価を設定します。
setPurchaseUnitPrice(double) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
仕入単価を設定します。
setPurchaseUnitPrice(double, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
仕入単価を設定します。
setPurchaseUnitPrice(double) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
仕入単価を設定します。
setPurchaseView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
購買管理ビューを設定します。
setPurchaseorder(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
購買発注番号を設定します。
setPushDistrib(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: プッシュ配賦を設定します。
setPvalidfrom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
プラント共通品目のステータス有効開始日付を設定します。
setPvalidfrom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラント品目ステータス有効期間開始日を設定します。
setPymtMeth(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
支払方法を設定します。
setPymtMeth(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPymtMeth(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
支払方法を設定します。
setPymtMeth(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setQmAuthgrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
QM における活動の品目権限グループを設定します。
setQmProcmnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
調達における品質管理有効を設定します。
setQmRgmts(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
仕入先の必須 QM システムを設定します。
setQtValidF(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
見積/引合有効開始日を設定します。
setQtValidF(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setQtValidT(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
見積の有効終了日を設定します。
setQtValidT(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setQtyGrGi(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
数量: 印刷予定入出庫票数を設定します。
setQtyStruct(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
数量構成により原価計算を行う品目を設定します。
setQualDik(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
無償納入による割引対象品目を設定します。
setQualInsp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
在庫タイプを設定します。
setQualityView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品質管理ビューを設定します。
setQualityView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
品質管理ビューを設定します。
setQuantity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
+/- 記号あり/なし数量を設定します。
setQuantity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
+/- 記号あり/なし数量を設定します。
setQuantity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
数量を設定します。
setQuantity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買発注数量を設定します。
setQuantity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
計画数量を設定します。
setQuantity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
数量を設定します。
setQuantity(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
インスタンス数量を設定します。
setQuantityUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
数量単位を設定します。
setQuestion(String) - class jp.co.intra_mart.foundation.navigator.EventHistoryInfo のメソッド
回答設定
setQuestion(String) - class jp.co.intra_mart.foundation.navigator.SaveEventHistoryInfo のメソッド
回答設定
setQuotDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
見積提出日を設定します｡
setQuotDead(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積提出期限を設定します。
setQuotation(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
見積番号を設定します｡
setQuotationCfgsBlobList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: BLOB 内部データ (SCE)を設定します。
setQuotationCfgsInstList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: インスタンスを設定します。
setQuotationCfgsPartOfList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: 部分設定を設定します。
setQuotationCfgsRefInstList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: 参照明細/インスタンスを設定します。
setQuotationCfgsRefList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: 参照データを設定します。
setQuotationCfgsValueList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: 特性値を設定します。
setQuotationCfgsVkList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: バリアント条件キーを設定します。
setQuotationConditionsInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
条件を設定します。
setQuotationConditionsInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
受注における条件更新の通信項目を設定します。
setQuotationHeaderIn(HeaderIn) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
伝票ヘッダデータを設定します。
setQuotationHeaderInX(HeaderInX) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
伝票ヘッダチェックボックスを設定します。
setQuotationItemsInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
明細データを設定します。
setQuotationItemsInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
明細データチェックボックスを設定します。
setQuotationKeysList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
参照キーの出力テーブルを設定します。
setQuotationPartnersList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
伝票取引先を設定します。
setQuotationSchedulesInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
納入日程行データを設定します。
setQuotationSchedulesInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
納入日程行データチェックボックスを設定します。
setQuotationTextList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
テキストを設定します。
setQuotausage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
供給量割当の使用を設定します。
setR3name(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing のメソッド
SAPシステム名称を設定します。
setRPromo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
プロモーションを設定します。
setRateType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算レートタイプを設定します。
setRateType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
換算レートタイプを設定します。
setRateType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
換算レートタイプを設定します。
setRcvgVend(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
未使用項目を設定します。
setReadOnly(boolean) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection を読み込み専用モードに設定して、データベース最適化を実行するヒントとします。
setRealUserInfo(UserInfo) - class jp.co.intra_mart.framework.base.util.UserInfoWrapper のメソッド
このオブジェクトがラップするUserInfoの実装を設定します。
setReason(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
変更理由を設定します。
setReason(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
変更理由を設定します。
setReasonCancel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
取消理由を設定します。
setReasonRej(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
見積および受注の拒否理由を設定します。
setReasonRej(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReasonRej(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
見積および受注の拒否理由を設定します。
setRebateGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
取引量リベートグループを設定します。
setRecInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
リカバリフラグを設定します。
setRecPoint(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
入荷ポイントを設定します。
setRecPoint(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRecPoint(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
入荷ポイントを設定します。
setRecPoint(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRecTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
登録時刻を設定します。
setReceive(String) - class jp.co.intra_mart.foundation.page.EventScript のメソッド
イベントから値を受け取る変数名を指定します。
setRecordDate(Date) - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
レコード更新日を設定します。
setRecordList(ArrayList) - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer のメソッド
レコード一覧リストをセットします。
setRecordNo(int) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
レコード番号を設定します｡
setRecordUserCode(String) - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
レコード更新ユーザコードを設定します。
setRecoveryInd(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
リカバリフラグを設定します。
setRecoveryInd(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
リカバリフラグを設定します。
setRef1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先/仕入先の内部参照コードを設定します。
setRef1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRef1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先/仕入先の内部参照コードを設定します。
setRef1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRef1S(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先文字を設定します。
setRef1S(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRef1S(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先文字を設定します。
setRef1S(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
決済の参照日付を設定します。
setRefDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
決済の参照日付を設定します。
setRefDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
決済の参照日付を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
参照伝票番号を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
参照伝票の伝票番号を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
参照伝票の伝票番号を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
参照伝票番号を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
参照伝票番号を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
参照伝票番号を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照伝票番号を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
参照伝票番号を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
参照伝票番号を設定します。
setRefDocCa(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
先行販売管理伝票の伝票カテゴリを設定します。
setRefDocCa(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
先行販売管理伝票の伝票カテゴリを設定します。
setRefDocCa(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefDocHigh(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
前伝票の終了伝票番号を設定します。
setRefDocIt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
参照伝票の明細番号を設定します。
setRefDocIt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
参照伝票の明細番号を設定します。
setRefDocIt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
参照明細番号を設定します。
setRefDocIt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefDocItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
参照明細番号を設定します。
setRefDocItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
参照明細番号を設定します。
setRefDocL(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照伝票番号を設定します。
setRefDocL(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefDocLLong(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照伝票番号 (依存関係についてはテキスト (長) を参照)を設定します。
setRefDocLow(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
前伝票の開始伝票番号を設定します。
setRefDocNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
参照伝票番号を設定します。
setRefDocNoLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
参照伝票番号 (依存性についてはテキスト長参照)を設定します。
setRefDocRange(RefDocRange) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
前伝票の範囲を設定します。
setRefDocYr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
参照伝票の会計年度を設定します。
setRefDocYr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
参照伝票の会計年度を設定します。
setRefItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
参照伝票の明細を設定します。
setRefItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
参照明細番号を設定します。
setRefItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
参照明細番号を設定します。
setRefKeyNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
参照キーは変更できませんを設定します。
setRefKeyNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
参照キーは変更できませんを設定します。
setRefProc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照限定条件: 決定区分を設定します。
setRefProc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
基本数量単位による参照数量を設定します。
setRefUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
品目マスタレコードの数量単位初期値を設定します。
setRef_1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
得意先/仕入先の内部参照コードを設定します｡
setRefdocCat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
先行販売管理伝票の伝票カテゴリを設定します。
setRefdocCat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefdoctype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照オブジェクトの伝票タイプを設定します。
setReferencePoint(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
BOM 転送の参照ポイントを設定します。
setReflogsys(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
論理システムを設定します。
setReflogsys(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
論理システムを設定します。
setReflogsys(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReflogsys(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
論理システムを設定します。
setReflogsys(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
論理システムを設定します。
setReflogsys(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
論理システムを設定します。
setRefmatcons(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費参照品目を設定します。
setRefmatconsExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 REFMATCONS の品目コード (長) (今後のリリースで開発)を設定します。
setRefmatconsGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 REFMATCONS の外部 GUID (今後のリリースで開発)を設定します。
setRefmatconsVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 REFMATCONS のバージョン番号 (今後のリリースで開発)を設定します。
setRefobject(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
オブジェクト名を設定します。
setRefobjkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
オブジェクトキーを設定します。
setRefobjkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
オブジェクトキーを設定します。
setRefobjkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
オブジェクトキーを設定します。
setRefobjkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefobjkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
オブジェクトキーを設定します。
setRefobjkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
オブジェクトキーを設定します。
setRefobjkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
オブジェクトキーを設定します。
setRefobjkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
オブジェクトキーを設定します。
setRefobjtyp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
オブジェクトタイプを設定します。
setRefobjtype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
オブジェクトタイプを設定します。
setRefobjtype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
オブジェクトタイプを設定します。
setRefobjtype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
オブジェクトタイプを設定します。
setRefobjtype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefobjtype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
オブジェクトタイプを設定します。
setRefobjtype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
オブジェクトタイプを設定します。
setRefobjtype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
オブジェクトタイプを設定します。
setRefpltcons(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費参照プラントを設定します。
setRegiogroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地域構造グループ化を設定します。
setRegiogroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地域構造グループ化を設定します。
setRegiogroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地域構造グループ化を設定します。
setRegion(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
地域 (都道府県)を設定します。
setRegion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地域 (都道府県)を設定します。
setRegion(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
地域 (都道府県)を設定します。
setRegion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地域 (都道府県)を設定します。
setRegion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
地域 (都道府県)を設定します。
setRegionorig(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
品目の原産地 (非特恵対象地区の原産)を設定します。
setRegionorig(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目の原産地 (非特恵対象地区の原産)を設定します。
setRejReason(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積および受注の拒否理由を設定します。
setRel(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
relを設定します。
setRelCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
承認コードを設定します。
setRelCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
承認コードを設定します。
setRelGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
承認グループを設定します。
setRelGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
承認グループを設定します。
setRelGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
承認グループを設定します。
setRelInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
承認区分: 購買伝票を設定します。
setRelIndicatorNew(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
返却承認区分を設定します。
setRelStatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
承認状況を設定します｡
setRelStatusNew(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
返却承認状況を設定します。
setRelStrat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
承認方針を設定します。
setRelType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
承認タイプを設定します。
setRelType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReleaseDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
承認日を設定します。
setReleaseTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
承認時刻を設定します。
setReleasebyPur(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
承認購買担当者名を設定します。
setReleasedBy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
承認者名を設定します。
setReleasedatePur(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買担当者承認日付を設定します。
setReleasetimePur(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買担当者承認時刻を設定します。
setReminder1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
第一回催促状/督促状の日数を設定します。
setReminder2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
第二回催促状/督促状の日数を設定します。
setReminder3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
第三回催促状/督促状の日数を設定します。
setRemoteAddr(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
リクエスト元のクライアントの IP(Internet Protocol) アドレスを設定する。
setReorderPt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
発注点を設定します。
setReorderPt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所 MRP に対する発注点を設定します。
setRepManuf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 繰返生産許可を設定します。
setReplQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所 MRP に対する補充数量を設定します。
setReplacePt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
取替部品を設定します。
setReplenQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
補充数量を設定します。
setReplentime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
補充リードタイム合計 (稼動日数)を設定します。
setReplyTo(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 リプライをセットする。
setReplyTo(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 リプライをセットする。
setRepmanprof(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
繰返生産プロファイルを設定します。
setReqBy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
変更を依頼した従業員を設定します。
setReqBy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
変更を依頼した従業員を設定します。
setReqByExt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンの外部変更番号を設定します。
setReqByExt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
バージョンの外部変更番号を設定します。
setReqDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
所要日付を設定します。
setReqDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
所要日付を設定します。
setReqDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程日付を設定します。
setReqDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReqDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
指定納期を設定します。
setReqDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
納入日程日付を設定します。
setReqDateH(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
指定納入期日を設定します。
setReqDateH(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReqDateH(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
指定納入期日を設定します。
setReqDlvBl(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
出荷ブロック中の納入日程行を設定します。
setReqDlvBl(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReqQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
利用可能在庫確認の所要量を設定します。
setReqQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
所要量を設定します。
setReqQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
累積受注数量 (販売単位)を設定します。
setReqQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
販売単位による受注数量を設定します。
setReqQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReqQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
累積受注数量 (販売単位)を設定します。
setReqQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
累積受注数量 (販売単位)を設定します。
setReqTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入時間を設定します。
setReqTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReqmtsTyp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
所要量タイプを設定します。
setReqmtsTyp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRequCompCode(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
会社コード要求を設定します。
setRequest(HttpServletRequest) - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
リクエストを設定します。
setRequest(HttpServletRequest) - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
リクエストを設定します。
setRequest(HttpServletRequest) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
リクエストを設定します。
setRequest(HttpServletRequest) - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
リクエストを設定します。
setRequestCctr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
申請原価センタを設定します。
setRequestCctr(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請原価センタを設定します。
setRequestCctrControllingArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
依頼原価センタの管理領域を設定します。
setRequestCompCode(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
会社コード要求を設定します。
setRequestOrder(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請指図を設定します。
setRequired(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
フォーカスの要求の有無を格納します。
setResAnalKey(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
結果分析キーを設定します。
setResAnalKey(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
結果分析キーを設定します。
setResDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
用途指定予算の伝票番号を設定します。
setResItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
用途指定予算: 伝票明細を設定します。
setResItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫予定/従属所要量の明細番号を設定します。
setResItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入出庫予定/従属所要量の明細番号を設定します。
setResType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
レコードタイプを設定します。
setResType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
レコードタイプを設定します。
setResanalkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
結果分析キーを設定します。
setResanalkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReservNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫予定/従属所要量の番号を設定します。
setReservNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入出庫予定/従属所要量の番号を設定します。
setRespCostCenter(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
責任原価センタを設定します。
setRespCostCenter(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
責任原価センタを設定します。
setRespcctr(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
責任原価センタを設定します。
setResponse(HttpServletResponse) - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
レスポンスを設定します。
setResponse(HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
レスポンスを設定します。
setResponse(HttpServletResponse) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
レスポンスを設定します。
setResponse(HttpServletResponse) - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
レスポンスを設定します。
setResponsibleNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
責任者番号 (プロジェクト責任者)を設定します。
setResponsibleNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
責任者番号 (プロジェクト責任者)を設定します。
setRespsblCctr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
責任原価センタを設定します。
setRespsblCctrControllingArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
責任原価センタの管理領域を設定します。
setResult(ServiceResult) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
サービス処理結果を設定します。
setResultPageItemInfos(ResultPageItemInfo[]) - class jp.co.intra_mart.foundation.navigator.EventResultItemInfo のメソッド
結果ページ情報リスト設定
setResultPageItemInfos(ResultPageItemInfo[]) - class jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo のメソッド
結果ページ情報リスト設定
setRetCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController のメソッド
リターン値、ABAP 命令後のリターン値を設定します。
setRetItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
返品明細を設定します。
setRetry(ImportManager, ImportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
インポート設定に定義されたリトライステータスをマネージャーに設定します。
setRetry(boolean) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManager のメソッド
インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
setRetry(boolean) - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl のメソッド
インポート異常終了後の再実行時に、リトライとして実行するかどうかを設定します。
setRetry(boolean) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager のメソッド

setRetry(boolean) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager のメソッド

setRetry(boolean) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager のメソッド

setRetry(boolean) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager のメソッド

setRetry(boolean) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager のメソッド

setReturnMessagesList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
リターンパラメータ BAPIRET2 の代替構造を設定します。
setReturningAttributes(String, String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
結果属性指定を設定する。
setReturningObj(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
結果としてオブジェクト許可を設定する。
setRev(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
relを設定します。
setRevLev(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
改訂レベルを設定します。
setRevType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
収益承認カテゴリを設定します。
setRevType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRfqItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
見積依頼明細番号を設定します。
setRfqNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
見積依頼番号を設定します。
setRight(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を設定します。
setRlEstKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
不動産管理対象の内部キーを設定します。
setRlEstKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
不動産管理対象の内部キーを設定します。
setRlEstKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
不動産管理対象の内部キーを設定します。
setRnddlvQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
丸め数量: 出荷を設定します。
setRnddlvQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRole(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 RoleManager.importData(String category, InputStream inputStream)に置き換えられました。
setRole(int, Role) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

setRoleId(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole のメソッド
ロールIDを設定します。
setRoleId(String) - class jp.co.intra_mart.foundation.security.account.AccountRole のメソッド
ロールIDを設定します。
setRoleId(String) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロールIDを設定します。
setRoleName(String) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロール名を設定します。
setRoleValidEndDate(Date) - class jp.co.intra_mart.foundation.security.account.AccountRole のメソッド
ロール有効終了日を設定します。
setRoleValidStartDate(Date) - class jp.co.intra_mart.foundation.security.account.AccountRole のメソッド
ロール有効開始日を設定します。
setRoles(Role[]) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

setRollbackOnly() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager のメソッド
ラップしたTransactionManagerのsetRollbackOnlyを呼び出します。
setRollbackOnly() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction のメソッド
ラップしたUserTransactionのsetRollbackOnlyを呼び出します。
setRoomNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
部屋/アパート番号を設定します。
setRoomNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
部屋/アパート番号を設定します。
setRoomNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
部屋/アパート番号を設定します。
setRootId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
選定におけるインスタンス番号を設定します。
setRotationDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算ビューを設定します。
setRoundProf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
丸めプロファイルを設定します。
setRoundProf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
丸めプロファイルを設定します。
setRoundQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
丸め数量を設定します。
setRoundUpRuleExpirationDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
有効期間期限日計算の丸め規則を設定します。
setRoundVal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
購買発注数量の丸め数量を設定します。
setRoundoffdi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
BAPI の通貨額 (小数点以下９桁)を設定します。
setRoute(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
輸送経路を設定します。
setRoute(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRoutesched(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
輸送経路計画を設定します。
setRow(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
行番号を設定します｡
setRow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
パラメータの行を設定します。
setRssUrl(String) - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet のメソッド
URLを設定します。
setRunDay(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行日を設定します。
setRunDay(int) - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行日を設定します。
setRunDayWeek(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行曜日を設定します。
setRunDayWeek(int) - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行曜日を設定します。
setRunHour(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行時を設定します。
setRunHour(int) - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行時を設定します。
setRunMinute(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行分を設定します。
setRunMinute(int) - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行分を設定します。
setRunMonth(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行月を設定します。
setRunMonth(int) - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行月を設定します。
setRunSecond(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行秒を設定します。
setRunSecond(int) - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行秒を設定します。
setRunYear(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行年を設定します。
setRunYear(int) - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行年を設定します。
setSOrdItem(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
受注明細番号を設定します。
setSOrdItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
受注明細番号を設定します。
setSOrdItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
受注明細番号を設定します。
setSProcInd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
特別処理区分を設定します。
setSProcInd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSProcInd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
特別処理区分を設定します。
setSProcInd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSSLContext(SSLContext) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の SSLSocketFactory を生成する SSLContextを設定します。
setSUnitDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷単位を設定します。
setSUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
単位の ISO コードを設定します。
setSUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
ISO コードによる販売単位を設定します。
setSUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
ISO コードによる販売単位を設定します。
setSaIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
レコード番号を設定します｡
setSafetyStk(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
安全在庫を設定します。
setSafetytime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
安全時間 (稼動日数)を設定します。
setSaftyTId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
安全時間区分（安全リードタイムあり/なし)を設定します。
setSalStatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
流通チェーン間品目ステータスを設定します。
setSalStatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
販売ビューからの品目ステータスを設定します。
setSalesData(SalesData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
販売データを設定します。
setSalesDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
販売データを設定します。
setSalesDist(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売地域を設定します。
setSalesDist(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSalesDist(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売地域を設定します。
setSalesDist(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSalesDocDateInidicator(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
販売伝票の日付に関連するマイルストーンを設定します。
setSalesGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
営業グループを設定します。
setSalesGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSalesGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
営業グループを設定します。
setSalesOff(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
営業所を設定します。
setSalesOff(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSalesOff(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
営業所を設定します。
setSalesOrd(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
受注伝票番号を設定します。
setSalesOrd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
受注伝票番号を設定します。
setSalesOrd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
受注伝票番号を設定します。
setSalesOrdersList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
得意先受注テーブルを設定します。
setSalesOrg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
販売組織を設定します。
setSalesOrg(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売組織を設定します。
setSalesOrg(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSalesOrg(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売組織を設定します。
setSalesOrganisationSelectionList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
販売組織の選択オプション一覧を設定します｡
setSalesOrganization(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
販売組織を設定します。
setSalesPers(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
仕入先営業担当者を設定します｡
setSalesRelevant(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
この部品は販売に関連していますを設定します。
setSalesUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
販売単位を設定します。
setSalesUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売単位を設定します。
setSalesUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売単位を設定します。
setSalesUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSalesUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売単位を設定します。
setSalesUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
販売単位を設定します。
setSalesUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
ISO コードによる販売単位を設定します。
setSalesUnitPrice(double) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable のメソッド
販売単価を設定します。
setSalesUnitPrice(double) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
販売単価を設定します。
setSalesUnitPrice(double, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
販売単価を設定します。
setSalesUnitPrice(double) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
販売単価を設定します。
setSalesView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
販売ビューを設定します。
setSalesView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
販売ビューを設定します。
setSalesdocument(String) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
販売伝票番号を設定します。
setSalesdocument(String) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
販売管理伝票番号を設定します。
setSalesdocument(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
生成された伝票の番号を設定します。
setSalesdocument(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のメソッド
販売管理伝票番号を設定します。
setSalesdocumentin(String) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
販売管理伝票番号を設定します。
setSalesdocumentin(String) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
見積伝票番号を設定します。
setSalesdocumentin(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
販売管理伝票番号を設定します。
setSalesorg(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売組織を設定します。
setSalesorgHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のメソッド
販売組織の範囲終了を設定します。
setSalesorgLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のメソッド
販売組織の範囲開始を設定します。
setSalesorganisation(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
販売組織を設定します。
setSalqtyden(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売数量単位を SKU に換算するための分母 (除数)を設定します。
setSalqtyden(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSalqtynum(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売数量単位から基本数量単位への変換係数の分子を設定します。
setSalqtynum(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSaveDate(Date) - class jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo のメソッド
保存日時設定
setSavepoint() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 現在のトランザクションで名前のないセーブポイントを作成し、それを表す新しい Savepoint オブジェクトを返します。
setSavepoint(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 現在のトランザクションで指定された名前のセーブポイントを作成し、それを表す新しい Savepoint オブジェクトを返します。
setScIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
レコード番号を設定します｡
setScVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
外注仕入先を設定します。
setScalbasval(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件のスケール基準値を設定します。
setScalbasval(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件のスケール基準値を設定します。
setScalePosition(String) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｘ軸、ｙ軸の目盛りの表示位置を設定します。
setScalebasin(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
スケール基準区分を設定します。
setScalebasin(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
スケール基準区分を設定します。
setScaletype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
スケールタイプを設定します。
setScaletype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
スケールタイプを設定します。
setSce(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
CUX: 選定タイプを設定します。
setSchedInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
分納契約のリリース伝票区分を設定します。
setSchedLin(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
納入日程行を設定します。
setSchedLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
納入日程行を設定します。
setSchedLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入日程行を設定します。
setSchedLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
受注納入日程を設定します。
setSchedLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
受注納入日程を設定します。
setSchedLine(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程行を設定します。
setSchedLine(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
納入日程行を設定します。
setSchedMilestoneDateBasic(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン計画日(基準)を設定します。
setSchedMilestoneDateForecast(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン計画日(予測)を設定します。
setSchedMilestoneTimeBasic(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン計画時間(基準)を設定します。
setSchedMilestoneTimeForecast(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン計画時間(予測)を設定します。
setSchedType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程カテゴリを設定します。
setSchedType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSchedule(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 BatchManager.importData(String category, InputStream inputStream)に置き換えられました。
setScheduling(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
単一文字フラグを設定します。
setScrolling(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
scrollingを設定します。
setSdDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
販売管理伝票番号を設定します。
setSdDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売管理伝票番号を設定します。
setSdDocCat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
販売管理伝票カテゴリを設定します。
setSdDocCat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売管理伝票カテゴリを設定します。
setSdDocCat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSdTaxcode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
0を設定します。
setSdTaxcode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSeasIndex(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
季節指数を設定します。
setSeason(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
季節カテゴリを設定します。
setSeason(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
季節カテゴリを設定します。
setSeasonPds(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
季節周期ごとの期間数を設定します。
setSeasonYr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
シーズン年度を設定します。
setSecurityExt(String) - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter のメソッド
推奨されていません。 セキュリティの拡張子を設定します。
setSelectItem(SelectItem[]) - class jp.co.intra_mart.foundation.navigator.EventItem のメソッド

setSelectItemInfos(SelectItemInfo[]) - class jp.co.intra_mart.foundation.navigator.EventItemInfo のメソッド
選択アイテム情報リスト設定
setSelection(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
選択 ID (永続)を設定します。
setSelection(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSender(Sender) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
論理システム - 送信者を設定します。
setSender(Sender) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
論理システム - 送信者を設定します。
setSender(Sender) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
論理システム - 送信者を設定します。
setSeqNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
KANBAN/連続番号を設定します。
setSeqNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSerchFilter(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
検索フィルタを設定する。
setSerchingDn(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
検索用ユーザDNを設定する。
setSerchingPw(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
検索用ユーザパスワードを設定する。
setSerialNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
勘定設定の連続番号を設定します。
setSerialNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
勘定設定の連続番号を設定します。
setSerialNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
勘定設定の連続番号を設定します。
setSerializationLevel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
シリアル番号の指定レベルを設定します。
setSerialno(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のメソッド
シリアル番号を設定します。
setSerialnoAutoNumberassignment(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
シリアル番号の自動登録を設定します。
setSernoLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
勘定コード設定のシリアル番号、サービス明細を設定します。
setSernoProf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
シリアル番号プロファイルを設定します。
setServDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
サービス提供日を設定します。
setServDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setServDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
サービス提供日を設定します。
setServDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setServLevel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
サービスレベルを設定します。
setServType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
サービスタイプのテキスト (短)を設定します。
setServType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスタイプのテキスト (短)を設定します。
setServerType(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 サーバタイプを設定します｡
setService(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
活動番号を設定します。
setService(String) - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
実行するフレームワークのサービスＩＤを設定します。
setService(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性serviceの値を設定します。
setService(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
serviceを設定します。
setService(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
serviceを設定します。
setService(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
サービスを設定します。
setService(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性serviceの値を設定します。
setServiceId(String) - class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet のメソッド
サービスIDを設定します。
setServiceManager(ServiceManager) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
サービスマネージャを設定します。
setSession(Session) - class jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent のメソッド
メール送信のセッションを設定します。
setSessionContext(SessionContext) - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean のメソッド
関連するSessionContextを設定します。
setSessionId(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
セッションIDを設定する。
setSettItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
リベート (期末) 決済対象の明細を設定します。
setSetupTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出荷準備時間を設定します。
setSetuptime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
段取時間と片付け時間を設定します。
setShMatTyp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
梱包材タイプを設定します。
setShape(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
shapeを設定します。
setShape(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
shapeを設定します。
setShelfLife(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
総有効期間を設定します。
setShipBlocked(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
SD 出荷伝票の明細ブロックを設定します。
setShipCond(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷条件を設定します。
setShipCond(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setShipPoint(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷ポイント/入荷ポイントを設定します。
setShipPoint(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setShipPoint(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出荷ポイント/入荷ポイントを設定します。
setShipProcTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出荷処理時間を設定します。
setShipTo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
出荷先を設定します。
setShipType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷タイプを設定します。
setShipType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setShipType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷タイプを設定します。
setShipType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setShipping(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
出荷指示を設定します。
setShipping(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
出荷指示を設定します。
setShipping(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷指示を設定します。
setShippingCountry(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
貿易: 出荷国を設定します。
setShippingCountryIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
ISO 国コードを設定します。
setShortId(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素 ショート IDを設定します。
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
G/L勘定コードテキスト(短)を設定します｡
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
テキスト 1 (短)を設定します。
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
テキスト(短)を設定します。
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コードテキスト（短）を設定します。
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
テキスト (短): 受注明細を設定します。
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
テキスト (短): 受注明細を設定します。
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
テキスト (短): 受注明細を設定します。
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
テキスト (短): 受注明細を設定します。
setSiCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
補助明細カテゴリ、購買伝票を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Selection のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSize(ExportManager, ExportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
エクスポート設定に定義されたエクスポート単位のデータ数をマネージャーに設定します。
setSize(int) - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager のメソッド
エクスポート単位のデータ数を設定します。
setSize(int) - class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl のメソッド
エクスポート単位のデータ数を設定します。
setSize(int) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager のメソッド

setSize(int) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager のメソッド

setSize(int) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager のメソッド

setSize(int) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager のメソッド

setSize(int) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager のメソッド

setSize(int) - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
描画する点のサイズを設定します。
setSizeDim(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
サイズ/寸法を設定します。
setSledBbd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
有効期限を設定します。
setSleepInterval(int, int) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 指定された行数のレコードを書き出すごとに
スレッドを一定時間スリープさせます。
setSlocExprc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
外部調達の初期保管場所を設定します。
setSmKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
日程計画余裕キーを設定します。
setSoldTo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
受注先を設定します。
setSoldTo(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
受注先を設定します。
setSort1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
検索条件 1を設定します。
setSort1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
検索条件 1を設定します。
setSort1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
検索条件 1を設定します。
setSort2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
検索条件 2を設定します。
setSort2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
検索条件 2を設定します。
setSort2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
検索条件 2を設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.image.ImageIconInfo のメソッド
ソートキーを設定する。
setSortNumber(int) - class jp.co.intra_mart.foundation.navigator.EventFlow のメソッド

setSortNumber(int) - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
ソート番号を設定します。
setSortNumber(int) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
ソート番号を設定します。
setSortNumber(int) - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel のメソッド
ソート番号を設定します。
setSortNumber(int) - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
ソート番号を設定します。
setSorucePovider(SystemSourceProvider) - class jp.co.intra_mart.foundation.security.SystemManager の static メソッド
ソースプロバイダを設定します。
setSourceProvider(DataSourceProvider) - class jp.co.intra_mart.foundation.database.DatabaseManager の static メソッド
ソースプロバイダを設定します。
setSourcelist(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 供給元一覧必須を設定します。
setSpecMvmt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
倉庫管理の特殊移動区分を設定します。
setSpecMvmt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
倉庫管理の特殊移動区分を設定します。
setSpecProc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所レベルでの特殊調達タイプを設定します。
setSpecStock(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
特殊在庫区分を設定します。
setSpecStock(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
特殊在庫区分を設定します。
setSpecStockRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
特殊在庫区分の範囲を設定します。
setSpecprocty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算の特殊調達タイプを設定します。
setSplitInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
分割区分を設定します。
setSpproctype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
特殊調達タイプを設定します。
setSrc(String) - class jp.co.intra_mart.foundation.image.ImageIconInfo のメソッド
イメージアイコンURLを設定する。
setSscExist(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスタイプの制限を設定します。
setSscItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
標準サービスカタログ: 明細を設定します。
setSscLim(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
標準サービスカタログ制限参照のサービス行を設定します。
setSscLimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスタイプの金額制限を設定します。
setSscNolim(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
標準サービスタイプの制限なしを設定します。
setSscPerc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
価格決定率を設定します。
setSscPrschg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
入力シートの価格変更を設定します。
setStRefDateNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
開始参照日付は変更できませんを設定します。
setStRefDateNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
開始参照日付は変更できませんを設定します。
setStUnQtyy1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
代替数量単位での在庫受入予定保管単位別数量を設定します。
setStUnQtyy1Iso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
単位の ISO コードを設定します。
setStUnQtyy2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
代替数量単位での在庫受入予定保管単位別数量を設定します。
setStUnQtyy2Iso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
単位の ISO コードを設定します。
setStackFact(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
山積係数を設定します。
setStart(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト計画開始日付を設定します。
setStartDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
開始日を設定します。
setStartDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
開始日を設定します。
setStartDate(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
開始日を設定します。
setStartDate(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
開始日を設定します。
setStartEventId(String) - class jp.co.intra_mart.foundation.navigator.EventFlowInfo のメソッド
スタートイベントアイテムID設定
setStartEventItem(EventItem) - class jp.co.intra_mart.foundation.navigator.EventFlow のメソッド

setStartOffset(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用の開始オフセットを設定します。
setStartOffset(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用の開始オフセットを設定します。
setStartOffsetNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
開始オフセットは変更できませんを設定します。
setStartOffsetNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
開始オフセットは変更できませんを設定します。
setStartOffsetUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用開始のオフセット単位を設定します。
setStartOffsetUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用開始のオフセット単位を設定します。
setStartOffsetUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
PRT 用途開始決定の間隔時間単位 (ISO)を設定します。
setStartOffsetUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
PRT 用途開始決定の間隔時間単位 (ISO)を設定します。
setStartRefDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用開始の参照日付を設定します。
setStartRefDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用開始の参照日付を設定します。
setStatCon(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
統計に適用する条件を設定します。
setStatCon(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
統計に適用する条件を設定します。
setStatDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
統計的納入期日を設定します。
setStatGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
統計グループを設定します。
setStatProf(String) - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
ステータスプロファイルを設定します。
setStatistical(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
統計 WBS 要素を設定します。
setStatistical(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
統計 WBS 要素を設定します。
setStatus(int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
このレスポンスのステータスコードを設定します。
setStatus(HttpServletRequest, ExtendedHttpServletResponse, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
このレスポンスのステータスコードを設定します。
setStatus(HttpServletRequest, ExtendedHttpServletResponse, int) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
このレスポンスのステータスコードを設定します。
setStatus(HttpServletRequest, ExtendedHttpServletResponse, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
このレスポンスのステータスコードを設定します。
setStatus(int, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
推奨されていません。
setStatus(int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このレスポンスのステータスコードを設定します。
setStatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンステータスを設定します。
setStatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
ステータスを設定します｡
setStatus(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
単一文字フラグを設定します。
setStatusDocOld(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
このバージョンの前の旧処理状況 (購買伝票内)を設定します。
setStatusInfoList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のメソッド
ステータス情報を設定します。
setStckType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
在庫タイプを設定します。
setStckType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫タイプを設定します。
setStdDescr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
標準テキスト (ANSI、ISO など)を設定します。
setStdMaterialGetIntNumberList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList のメソッド
品目コード割当済一覧を設定します｡
setStdPrPp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期標準標準原価を設定します。
setStdPrPy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度標準原価を設定します。
setStdPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
標準原価を設定します。
setStdTextKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具の標準テキストキーを設定します。
setStdTextKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具の標準テキストキーを設定します。
setStgeBin(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
棚番を設定します。
setStgeBin(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
棚番を設定します。
setStgeBin(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
棚番を設定します。
setStgeBinPc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫転送棚番を設定します。
setStgeBinSt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫転送棚番を設定します。
setStgeLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
保管場所を設定します。
setStgeLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
保管場所を設定します。
setStgeLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所を設定します。
setStgeLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
保管場所を設定します。
setStgeLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
保管場所を設定します。
setStgeLocRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
保管場所の範囲を設定します。
setStgePdUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最長保管期間の単位を設定します。
setStgePdUnIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ISO コードでの最長保管期間単位を設定します。
setStgeType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
保管域タイプを設定します。
setStgeType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
概略計画および詳細計画のピッキング保管域タイプを設定します。
setStgeType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
保管域タイプを設定します。
setStgeTypePc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫転送の保管域タイプを設定します。
setStgeTypeSt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫転送の保管域タイプを設定します。
setStgeperiod(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最長保管期間を設定します。
setStgesector(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
保管区画区分を設定します。
setStlocHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のメソッド
終了保管場所を設定します。
setStlocLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のメソッド
開始保管場所を設定します。
setStockInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
特殊在庫区分を設定します。
setStorConds(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
保管条件を設定します。
setStorCosts(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
保管経費区分を設定します。
setStorPct(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
残存有効期間割合 %を設定します。
setStorageLocationData(StorageLocationData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目データ (保管場所レベル)を設定します。
setStorageLocationDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目データ (保管場所レベル)を設定します。
setStorageTypeData(StorageTypeData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
保管域タイプデータを設定します。
setStorageTypeDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
保管域タイプデータを設定します。
setStorageView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
保管ビューを設定します。
setStorageView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管ビューを設定します。
setStorageView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
保管ビューを設定します。
setStoragelocation(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
保管場所を設定します。
setStoragelocationselectList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
保管場所の選択オプション一覧を設定します｡
setStoragetype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
保管域タイプを設定します。
setStoreLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
保管場所を設定します。
setStoreLoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
保管場所を設定します。
setStoreLoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setStoreLoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
保管場所を設定します。
setStrAbbr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名の略称 (例: スペイン)を設定します。
setStrAbbr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名の略称 (例: スペイン)を設定します。
setStrAbbr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名の略称 (例: スペイン)を設定します。
setStrParam(String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController のメソッド
構造型の項目に値をセットします。
setStrParam(String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
構造型の項目に値をセットします。
setStrParam(String, String, String) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController のメソッド
構造型の項目に値をセットします。
setStrParam(String, String, String) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController のメソッド
構造型の項目に値をセットします。
setStrParam(String, String, String) - class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller のメソッド
構造体型の項目に値をセットします。
setStrParam(String, String, String) - class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller のメソッド
構造体型の項目に値をセットします。
setStrParam(String, String, String) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller のメソッド
構造体型の項目に値をセットします。
setStrSuppl1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名 2を設定します。
setStrSuppl1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名 2を設定します。
setStrSuppl1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名 2を設定します。
setStrSuppl2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名 3を設定します。
setStrSuppl2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名 3を設定します。
setStrSuppl2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名 3を設定します。
setStrSuppl3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名 4を設定します。
setStrSuppl3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名 4を設定します。
setStrSuppl3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名 4を設定します。
setStreet(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
地名/番地-号を設定します。
setStreet(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名を設定します。
setStreet(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
地名/番地-号を設定します。
setStreet(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名を設定します。
setStreet(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
地名/番地-号を設定します。
setStreetLng(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名を設定します。
setStreetLng(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名を設定します。
setStreetLng(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名を設定します。
setStreetNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村/地名ファイルの地名コードを設定します。
setStreetNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村/地名ファイルの地名コードを設定します。
setStreetNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村/地名ファイルの地名コードを設定します。
setStringValue(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttributeInternational のメソッド
属性文字列を設定します。
setStringValue(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel のメソッド
属性文字列を設定します。
setStringValue(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel のメソッド
属性文字列を設定します。
setStringValue(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeInternationalModel のメソッド
属性文字列を設定します。
setStroke(Stroke) - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
描画される線の描画属性を設定します。
setStructcond(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
構造条件を設定します。
setStructure(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI テーブル拡張の構造名を設定します。
setStructure(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI テーブル拡張の構造名を設定します。
setStructure(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI テーブル拡張の構造名を設定します。
setStructure(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI テーブル拡張の構造名を設定します。
setStructure(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI テーブル拡張の構造名を設定します。
setStyle(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性styleの値を設定します。
setStyle(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
styleを設定します。
setStyle(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
styleを設定します。
setStyle(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
styleを設定します。
setStyle(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性styleの値を設定します。
setStyle(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性styleの値を設定します。
setSuPlStck1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫受入予定の保管単位数を設定します。
setSuPlStck2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫受入予定の保管単位数を設定します。
setSubNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
資産補助番号を設定します。
setSubNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
資産補助番号を設定します。
setSubNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
資産補助番号を設定します。
setSubUom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
梱包階層の下位レベル数量単位を設定します。
setSubUomIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
下位レベル数量単位 (ISO コード)を設定します。
setSubitemint(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
副明細の明細間隔を設定します｡
setSubjToR(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
承認未完了を設定します。
setSubject(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Subjectを設定します。
setSubject(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 タイトルをセットする。
setSubmitclass(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性classの値を設定します。
setSubpckgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
サブパッケージ番号を設定します。
setSuccessList(List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
正常に処理された明細のテーブルを設定します。
setSuccessList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
後続請求伝票の明細テーブルを設定します。
setSupSource(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
供給元を設定します。
setSupSource(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
供給元を設定します。
setSuppLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
補足明細を設定します。
setSuppVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
供給仕入先/仕入入庫を設定します。
setSupplPlnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
在庫転送オーダーにおける供給(出庫)プラントを設定します｡
setSupplStloc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
出庫保管場所: 在庫転送オーダーを設定します。
setSupplVend(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
供給仕入先を設定します｡
setSupplVend(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
供給仕入先を設定します。
setSupplVend(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
供給仕入先を設定します。
setSupplierInfo(VendorAddress) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
仕入先住所を設定します｡
setSupplyArea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目マスタレコードで提案される供給場所を設定します。
setSvalidfrom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
流通チェーン間品目ステータスの有効開始日付を設定します。
setSyStDscr(String) - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus のメソッド
オブジェクトステータスを設定します。
setSyStText(String) - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus のメソッド
オブジェクトの個別ステータス (簡略形式)を設定します。
setSysStatus(String) - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus のメソッド
システムステータスを設定します。
setSysnr(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing のメソッド
システム番号を設定します。
setSysnr(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 システム番号を設定します｡
setSystem(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
システムを設定します｡
setSystem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージが発行された論理システムを設定します。
setSystemErrorMessage(String) - class jp.co.intra_mart.extension.maskat.util.MKError のメソッド
systemErrorMessageを設定します。
setSystemStatusList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
システムステータステーブルを設定します。
setSystemStatusList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
システムステータステーブルを設定します。
setTUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
目標数量単位 (ISO コード)を設定します。
setTUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaGlAccount(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
税明細の総勘定元帳勘定に値を設定します。
setTaGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
総勘定元帳勘定コードを設定します｡
setTaIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
レコード番号を設定します｡
setTaItemnoAcc(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
税明細の会計伝票明細番号に値を設定します。
setTaItemnoAcc(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
会計伝票明細番号コードを設定します｡
setTaTaxCode(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
税明細の消費税コードに値を設定します。
setTaTaxCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
消費税コードコードを設定します｡
setTabindex(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
tabindexを設定します。
setTabindex(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
tabindexを設定します。
setTabindex(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
tabindexを設定します。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList の static メソッド
品目データ (クライアントレベル)の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn の static メソッド
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX の static メソッド
拡張イン/拡張アウトのチェックボックス構造の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList の static メソッド
需要予測パラメータの値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues の static メソッド
需要予測値のデータ転送の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData の static メソッド
管理情報設定ヘッダセグメントの値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos の static メソッド
国際商品コード (EAN)の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription の static メソッド
品目テキストの値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText の static メソッド
テキスト (長)の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList の static メソッド
品目マスタ/製品グループの変更伝票構造の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList の static メソッド
品目データ (プラントレベル)の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData の static メソッド
品目マスタの生産資源/治工具 (PRT) 項目の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList の static メソッド
販売データの値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList の static メソッド
品目データ (保管場所レベル)の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList の static メソッド
保管域タイプデータの値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications の static メソッド
制御デ－タの値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption の static メソッド
品目総消費量のデータ転送の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure の static メソッド
数量単位の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption の static メソッド
計画外消費のデータ転送の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList の static メソッド
評価データの値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList の static メソッド
倉庫番号データの値をセットします。
setTagClass(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性classの値を設定します。
setTagWriter(TagWriter) - class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes のメソッド
TagWriterを設定します。
setTarget(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性targetの値を設定します。
setTarget(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
targetを設定します。
setTargetQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
目標数量（販売単位）を設定します。
setTargetQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTargetQu(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
目標数量 (数量単位)を設定します。
setTargetQu(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTargetVal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
目標値を設定します。
setTargetVal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
累積計画金額を設定します。
setTargetVal(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
BAPI の通貨額 (小数点以下９桁)を設定します。
setTargetVal(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaskListType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
タスクリストタイプを設定します。
setTaxClass1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先税分類 2を設定します。
setTaxClass2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先税分類 3を設定します。
setTaxClass3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 4を設定します。
setTaxClass4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 5を設定します。
setTaxClass5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass6(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 6を設定します。
setTaxClass6(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass6(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass6(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass7(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 7を設定します。
setTaxClass7(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass7(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass7(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass8(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 8を設定します。
setTaxClass8(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass8(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass8(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass9(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 9を設定します。
setTaxClass9(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass9(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass9(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClassificationsList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
制御デ－タを設定します。
setTaxClassificationsList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
制御デ－タを設定します。
setTaxCmlUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法/商法にもとづく評価額価格単位を設定します。
setTaxCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
消費税コードを設定します。
setTaxCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
消費税コードを設定します。
setTaxCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
消費税コードを設定します。
setTaxCode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
消費税コードを設定します。
setTaxDepartCty(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
税出荷国を設定します。
setTaxDestCty(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
税仕向国を設定します。
setTaxInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税区分: 品目 (購買管理)を設定します。
setTaxType1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxType2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxType3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxType4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxType5(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxType6(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxType7(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxType8(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxType9(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
税額を設定します。
setTaxValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
税額を設定します。
setTaxValueItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
税額を設定します。
setTaxcl1Mat(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目の税分類を設定します。
setTaxclass1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxclass2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxclass3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxclass4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxclass5(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxclass6(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxclass7(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxclass8(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxclass9(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxdepCty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
税出荷国を設定します。
setTaxdepCty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxdstCty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
税仕向国を設定します。
setTaxdstCty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxlawicms(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
税法: ICMSを設定します。
setTaxlawicms(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxlawipi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
税法: IPIを設定します。
setTaxlawipi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxprice1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法による評価額: レベル 1を設定します。
setTaxprice2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法による評価額: レベル 2を設定します。
setTaxprice3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法基準評価額: レベル 3を設定します。
setTaxrCntry(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
納税申告書の国を設定します。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController のメソッド
テーブル型の項目に値をセットします。
setTeIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
レコード番号を設定します｡
setTel(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
取引先での記帳担当者電話番号を設定します。
setTel1Ext(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
第 1 電話番号: 内線を設定します。
setTel1Ext(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
第 1 電話番号: 内線を設定します。
setTel1Ext(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
第 1 電話番号: 内線を設定します。
setTel1Numbr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
第一電話番号: ダイヤルコード + 番号を設定します。
setTel1Numbr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
第一電話番号: ダイヤルコード + 番号を設定します。
setTel1Numbr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
第一電話番号: ダイヤルコード + 番号を設定します。
setTelNo(String) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
電話番号設定。
setTelebox(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
テレボックス番号を設定します。
setTelegram(Document) - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject のメソッド
電文を設定します。
setTelephone(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
電話番号 1を設定します。
setTelephone(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
仕入先電話番号を設定します｡
setTelephone(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
電話番号を設定します。
setTelephone(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTelephone(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
電話番号 1を設定します。
setTelephone2(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
電話番号 2を設定します。
setTelephone2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
電話番号 2を設定します。
setTelephoneNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
電話番号を設定します。
setTelephoneNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
電話番号を設定します。
setTelephoneNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
電話番号を設定します。
setTelephoneNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
電話番号を設定します。
setTelephoneNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
電話番号を設定します。
setTelephoneNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
電話番号を設定します。
setTelephoneNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
電話番号を設定します。
setTelephoneNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
電話番号を設定します。
setTelephoneNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
電話番号を設定します。
setTeletexNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
テレテクス番号を設定します。
setTelexNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
テレックス番号を設定します。
setTempConds(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
温度条件区分を設定します。
setTemplateCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
テンプレートコードを設定します。
setTemplateCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
テンプレートコードを設定します。
setTemplateCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate のメソッド
テンプレートコードを設定します。
setTemplateDetail(ItemTemplateDetail) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager のメソッド
商品属性テンプレート明細情報を設定します。
setTemplateDetailCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
テンプレート明細コードを設定します。
setTemplateDetailCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
テンプレート明細コードを設定します。
setTemplateDetailName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetailInternational のメソッド
テンプレート明細名を設定します。
setTemplateDetailName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
テンプレート明細名を設定します。
setTemplateDetailName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
テンプレート明細名を設定します。
setTemplateDetailName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailInternationalModel のメソッド
テンプレート明細名を設定します。
setTemplateName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate のメソッド
テンプレート名を設定します。
setTemplateName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplateInternational のメソッド
テンプレート名を設定します。
setTemplateName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel のメソッド
テンプレート名を設定します。
setTemplateName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateInternationalModel のメソッド
テンプレート名を設定します。
setTerminableAccessor(TerminableAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
期間化アクセサを設定します。
setTerminableInternationalAccessor(TerminableInternationalAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext のメソッド
期間国際化アクセサを設定します。
setTerminableInternationalModelMap(TerminableInternationalModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
期間国際化モデルマップを設定します。
setTerminableModelMap(TerminableModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
期間化モデルマップを設定します。
setTerminal(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 端末を設定します。
setTestRun(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
テスト区分を設定します｡
setTestrun(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
在庫移動シミュレーションを設定します。
setTestrun(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
書込 BAPI のシミュレーションセッションへの切替を設定します。
setTestrun(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
シミュレーション実行 ('X')、更新実行 (' ')を設定します。
setTestrun(String) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
テスト実行を設定します。
setTestrun(String) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
テスト実行を設定します。
setTestrun(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
テスト実行を設定します。
setText(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
本文を設定します。
setTextDataInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
請求インタフェースの通信構造テキストを設定します。
setTextForm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
タグ列を設定します。
setTextId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
テキスト IDを設定します。
setTextId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
テキスト IDを設定します。
setTextId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
テキスト IDを設定します。
setTextId(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
テキスト IDを設定します。
setTextId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
テキスト IDを設定します。
setTextLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
テキスト行を設定します。
setTextLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
テキスト行を設定します。
setTextLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
テキスト行を設定します。
setTextLine(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
テキスト行を設定します。
setTextLine(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
テキスト行を設定します。
setTextName(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
名称を設定します。
setTextName(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
名称を設定します。
setThrowablePrintListener(ThrowablePrintListener) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
指定の例外出力リスナを割り当て直します。
setTimeLimit(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
時間制限を設定する。
setTimeUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
時間計画単位を設定します。
setTimeUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
単位の ISO コードを設定します。
setTimeZone(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
アドレスタイムゾーンを設定します。
setTimeZone(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
アドレスタイムゾーンを設定します。
setTimeZone(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
アドレスタイムゾーンを設定します。
setTimeoutCheckPeriod(long) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 コネクションのタイムアウトのチェック間隔を設定します｡
setTimer(boolean) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 トランザクション自動切断機能のタイマーをセットする（デフォルトtrue）

setTimer(int) - class jp.co.intra_mart.foundation.page.EventScript のメソッド
イベントの監視間隔を設定します。
setTimes(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
第ｎ～曜日を設定します。
setTimes(int) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
次を設定します。
setTindex(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
数値項目: 長さ 6を設定します。
setTitle(String) - class jp.co.intra_mart.foundation.navigator.TitleInfo のメソッド
タイトル設定
setTitle(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
タイトル (敬称)を設定します。
setTitle(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
タイトル (敬称)を設定します。
setTitle(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
敬称を設定します。
setTitle(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
タイトル (敬称)を設定します。
setTitle(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
敬称を設定します。
setTitle(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性titleの値を設定します。
setTitle(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
titleを設定します。
setTitle(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
titleを設定します。
setTitle(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
titleを設定します。
setTitle(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性titleの値を設定します。
setTitle(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性titleの値を設定します。
setTitleBar(boolean) - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
タイトルバーを表示するかどうかのステータスを設定します。
setTitleInfo(Locale, TitleInfo) - class jp.co.intra_mart.foundation.navigator.NavigatorItem のメソッド

setTmpExist(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスパッケージの制限を設定します。
setTmpLimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
モデルサービス明細制限を設定します。
setTmpLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: モデル仕様からの計画外サービスを設定します。
setTmpNolim(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
モデル仕様の制限なしを設定します。
setTmpNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
モデルサービス明細セット番号を設定します。
setTmpPckg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: モデル仕様からの計画外サービスを設定します。
setTmpPerc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
価格決定率を設定します。
setTmpPrschg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
入力シートの価格変更を設定します。
setTo(String) - class jp.co.intra_mart.foundation.http.SessionQuery のメソッド
推奨されていません。 代替えメソッドはありません。
setTo(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 To(宛先)をセットする。
setTo(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 To(宛先)をセットする。
setToCurrncy(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算後通貨を設定します。
setToCurrncy(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
換算後通貨を設定します。
setToCurrncy(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
換算後通貨を設定します。
setToFactor(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算後 通貨単位の係数を設定します。
setToFactorV(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算後 通貨単位の係数を設定します。
setToLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
上限を設定します。
setTotalConsumptionList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目総消費量のデータ転送を設定します。
setTpDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
輸送計画日付を設定します。
setTpDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
輸送計画日付を設定します。
setTpDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTpTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
輸送計画 - 時間 (現地時間/出荷ポイント参照)を設定します。
setTpTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
輸送計画 - 時間 (現地時間/出荷ポイント参照)を設定します。
setTpTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTrEvType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
トランザクション/イベントタイプを設定します。
setTrEvTypeRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
トランザクション/イベントタイプの範囲を設定します。
setTrPartBa(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取引会社事業領域を設定します。
setTrackingno(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買依頼追跡番号を設定します。
setTracklimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
警告限界を設定します。
setTrans(String) - class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract のメソッド
取引を設定します。
setTransGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
輸送グループを設定します。
setTransactionGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
一文字フラグを設定します。
setTransactionIsolation(int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 トランザクション遮断レベルを指定されたものに変更することを試みます。
setTransactionTimeout(int) - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager のメソッド
ラップしたTransactionManagerのsetTransactionTimeoutを呼び出します。
setTransactionTimeout(int) - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction のメソッド
ラップしたUserTransactionのsetTransactionTimeoutを呼び出します。
setTransportMode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader のメソッド
貿易管理の輸送モードを設定します。
setTranspzone(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
商品の納入区域を設定します。
setTranspzone(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
商品の納入区域を設定します。
setTranspzone(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
商品の納入区域を設定します。
setTranspzone(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
商品の納入区域を設定します。
setTrendAnalysisIndicator(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
傾向分析の関連マイルストーンを設定します。
setTrendValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
傾向値を設定します。
setTrendValuePp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間の傾向値を設定します。
setTrgQtyNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売単位から基本単位への換算係数を設定します。
setTrgQtyNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTrgqtyDen(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売単位から基本単位への換算係数を設定します。
setTrgqtyDen(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTwoStepPick(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ツーステップピッキング適用品目を設定します。
setType(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
タイプを設定します｡
setType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を設定します。
setType(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を設定します。
setType(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
ノードのタイプを設定します。
setType(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
typeを設定します。
setTypeMap(Map) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この接続の型マップとして指定された型マップをインストールします。
setURL(String) - interface jp.co.intra_mart.foundation.portal.common.rss.RSSParserIF のメソッド
RSSのURLをセットします
setUesrId(String) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
ログインユーザIDを設定します。
setUesrId(String) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
ログインユーザIDを設定します。
setUesrId(String) - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener のメソッド
ログインユーザIDを設定します。
setUesrId(String) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
ログインユーザIDを設定します。
setUesrId(String) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
ログインユーザIDを設定します。
setUnWork(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
作業単位を設定します。
setUnWorkIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setUnddlvTol(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
不足納入許容範囲リミットを設定します。
setUnddlvTol(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setUnderDlvTol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
不足納入許容範囲リミットを設定します。
setUnderTol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
不足納入許容範囲リミットを設定します。
setUnit(String) - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
表示単位を設定します。
setUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
発注単位を設定します。
setUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
表示数量単位を設定します。
setUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
表示数量単位を設定します。
setUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
表示数量単位を設定します。
setUnitCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail のメソッド
単位コードを設定します。
setUnitCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
単位コードを設定します。
setUnitCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
単位コードを設定します。
setUnitCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailTerminableModel のメソッド
単位コードを設定します。
setUnitDim(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
寸法単位 (長さ/幅/高さ)を設定します。
setUnitDimIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ISO コードでの長さ、幅、高さの単位を設定します。
setUnitGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
数量単位グループを設定します。
setUnitGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
数量単位グループを設定します。
setUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
ISO コードでの表示数量単位を設定します。
setUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
ISO コードでの表示数量単位を設定します。
setUnitName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitBaseModel のメソッド
単位名を設定します。
setUnitOfWt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
重量単位を設定します。
setUnitOfWt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
重量単位を設定します。
setUnitOfWtIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードでの重量単位を設定します。
setUnitOfWtIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ISO コードでの重量単位を設定します。
setUnitPrice(double) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable のメソッド
単価を設定します。
setUnitPrice(double) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail のメソッド
単価を設定します。
setUnitPrice(double) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
単価を設定します。
setUnitPrice(double, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
単価を設定します。
setUnitPrice(double) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealTerminableModel のメソッド
単価を設定します。
setUnitPrice(double) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
単価を設定します。
setUnitPrice(double, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
単価を設定します。
setUnitPrice(double) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailTerminableModel のメソッド
単価を設定します。
setUnitSofmeasureList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
数量単位を設定します。
setUnitSofmeasureList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
数量単位を設定します。
setUnitmeasur(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件スケール単位を設定します。
setUnitmeasur(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件スケール単位を設定します。
setUnitmeasurIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
単位の ISO コードを設定します。
setUnittype1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
第１保管単位タイプを設定します。
setUnittype1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
保管単位タイプを設定します。
setUnittype2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
第２保管単位タイプを設定します。
setUnittype2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
保管単位タイプを設定します。
setUnittype3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
第３保管単位タイプを設定します。
setUnlimited(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 無制限過剰納入可能を設定します。
setUnlimitedDlv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
区分: 無制限過剰納入可能を設定します。
setUnlmtDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
区分: 無制限過剰納入可能を設定します。
setUnlmtDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setUnloadPt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
荷渡ポイントを設定します。
setUnloadPt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
荷渡ポイントを設定します。
setUnloadPt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
荷渡ポイントを設定します。
setUnloadPt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
荷渡ポイントを設定します。
setUnloadPtx(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
関連ユーザデータ項目の更新情報を設定します。
setUnofWtiso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ISO コードでの重量単位を設定します。
setUnplndConsumptionList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
計画外消費のデータ転送を設定します。
setUntilDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
インフレーション指数日付を設定します。
setUntofWght(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
重量単位を設定します。
setUntofWght(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setUomIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
単位の ISO コードを設定します。
setUomsortnumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
数量単位ソート番号を設定します。
setUomusage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
使用数量単位を設定します。
setUp(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を設定します。
setUpdateGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
統計更新の更新グループを設定します。
setUpdateflag(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
更新区分を設定します。
setUpdateflag(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
更新区分を設定します。
setUpdateflag(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
更新区分を設定します。
setUpdateflag(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
更新区分を設定します。
setUrl(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
URLを設定します。
setUrl(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
URLを設定します。
setUrl(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
URLを設定します。
setUrl(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
URLを設定します。
setUrl(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
URLを設定します。
setUrl(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
URLを設定します。
setUrl(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
URLを設定します。
setUrl(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
URLを設定します。
setUrl(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
URLを設定します。
setUrl(String) - class jp.co.intra_mart.foundation.navigator.LinkPageInfo のメソッド
URL設定
setUrl(String) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
リンク先のURLを設定します。
setUrl(String) - class jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet のメソッド
URLを設定します。
setUrl(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ダイレクトＵＲＬを設定する。
setUrl(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
URLを設定します。
setUrl(String) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のメソッド
ＵＲＬを設定します。
setUrl(String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
URLを設定します。
setUrlParam(String, String) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のメソッド
ＵＲＬ引数(MAP)をセットする。
setUrlSignature(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ダイレクトＵＲＬ署名を設定する。
setUsStDscr(String) - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
オブジェクトステータスを設定します。
setUsStNumb(String) - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
ステータス番号を設定します。
setUsStText(String) - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
オブジェクトの個別ステータス (簡略形式)を設定します。
setUsageInd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
未使用 - 予約長 3を設定します。
setUsageInd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setUseExceptions(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
例外メッセージ設定とエラーメッセージ出力を設定します。
setUser(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
ユーザーを設定します。
setUser(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
ユーザーを設定します。
setUser(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 ユーザを設定します｡
setUser(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインユーザIDを設定する。
setUserAgent(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
ブラウザ情報を設定する。
setUserCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
ユーザコードを設定します。
setUserCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
ユーザコードを設定します。
setUserCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
ユーザコードを設定します。
setUserCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
ユーザコードを設定します。
setUserCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザコードを設定します。
setUserFieldChar10_1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目 (10 文字)を設定します。
setUserFieldChar10_1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
10 桁の第 3 ユーザ項目 - WBS 要素を設定します。
setUserFieldChar10_2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目 (10 文字)を設定します。
setUserFieldChar10_2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
10 桁の第 4 ユーザ項目 - WBS 要素を設定します。
setUserFieldChar20_1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
20 文字のユーザ項目を設定します。
setUserFieldChar20_1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
20 文字の第 1 ユーザ項目 - WBS 要素 -を設定します。
setUserFieldChar20_2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
20 文字のユーザ項目を設定します。
setUserFieldChar20_2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
20 桁の第 2 ユーザ項目 - WBS 要素を設定します。
setUserFieldCuky1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ項目: 値項目の単位を設定します。
setUserFieldCuky1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
値項目単位の第１ユーザ定義項目 - WBS 要素を設定します。
setUserFieldCuky1Iso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ISO 通貨コードを設定します。
setUserFieldCuky1Iso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ISO 通貨コードを設定します。
setUserFieldCuky2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ項目: 値項目の単位を設定します。
setUserFieldCuky2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
値項目単位の第２ユーザ定義項目 - WBS 要素を設定します。
setUserFieldCuky2Iso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ISO 通貨コードを設定します。
setUserFieldCuky2Iso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ISO 通貨コードを設定します。
setUserFieldCurr1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
値のユーザ定義項目 (長さ 10,3)を設定します。
setUserFieldCurr1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。
setUserFieldCurr2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
値のユーザ定義項目 (長さ 10,3)を設定します。
setUserFieldCurr2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。
setUserFieldDate1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
日付のユーザ項目を設定します。
setUserFieldDate1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
日付の第 1 ユーザ項目 - WBS 要素を設定します。
setUserFieldDate2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
日付のユーザ項目を設定します。
setUserFieldDate2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
日付の第 2 ユーザ項目 - WBS 要素を設定します。
setUserFieldFlag1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目: レポート区分を設定します。
setUserFieldFlag1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
'評価区分' の第 1 ユーザ項目 - WBS 要素を設定します。
setUserFieldFlag2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目: レポート区分を設定します。
setUserFieldFlag2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
'評価区分' の第 2 ユーザ項目 - WBS 要素を設定します。
setUserFieldKey(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目のキーワード IDを設定します。
setUserFieldKey(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ユーザ定義項目のキーワード IDを設定します。
setUserFieldQuan1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
数量のユーザ項目 (長さ 10,3)を設定します。
setUserFieldQuan1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。
setUserFieldQuan2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
数量のユーザ項目 (長さ 10,3)を設定します。
setUserFieldQuan2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。
setUserFieldUnit1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ項目: 数量項目の単位を設定します。
setUserFieldUnit1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
数量項目単位の第１ユーザ定義項目 - WBS 要素を設定します。
setUserFieldUnit1Iso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setUserFieldUnit1Iso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを設定します。
setUserFieldUnit2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ項目: 数量項目の単位を設定します。
setUserFieldUnit2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
数量項目単位の第２ユーザ定義項目 - WBS 要素を設定します。
setUserFieldUnit2Iso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setUserFieldUnit2Iso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを設定します。
setUserID(String) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログインユーザIDを設定する。
setUserId(String) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
ログインユーザIDを設定します。
setUserId(String) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
ログインユーザIDを設定します。
setUserId(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ユーザIDを設定します。
setUserId(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
ログインユーザIDを設定する。
setUserId(String) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
ユーザID設定。
setUserId(String) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
ログインユーザIDを設定します。
setUserNameRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
ユーザ名の範囲を設定します。
setUserStatusList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
ユーザステータス/指図ステータステーブルを設定します。
setUserStatusList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
ユーザステータス/指図ステータステーブルを設定します。
setUserf1Num(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ユーザ定義項目を設定します。
setUserf1Txt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ユーザ定義項目を設定します。
setUserf2Num(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ユーザ定義項目を設定します。
setUserf2Txt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ユーザ定義項目を設定します。
setUsername(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
ユーザ名を設定します。
setUsrStatus(String) - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
ユーザステータスを設定します。
setValArea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価レベルを設定します。
setValCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価カテゴリを設定します。
setValClass(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価クラスを設定します。
setValConI(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
金額契約明細を設定します。
setValConI(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setValContr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
金額契約番号を設定します。
setValContr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setValRatio(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
元値に対する修正値の比率 (修正値: 元値)を設定します。
setValRatio(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
元値に対する修正値の比率 (修正値: 元値)を設定します。
setValRatio(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
元値に対する修正値の比率 (修正値: 元値)を設定します。
setValSOrdItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
評価受注在庫の受注明細を設定します。
setValSOrdItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
評価受注在庫の受注明細を設定します。
setValSalesOrd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
評価受注在庫の受注番号を設定します。
setValSalesOrd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
評価受注在庫の受注番号を設定します。
setValType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
評価タイプを設定します。
setValType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
評価タイプを設定します。
setValType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価タイプを設定します。
setValType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
評価タイプを設定します。
setValType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
評価タイプを設定します。
setValType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setValWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
WBS 要素を設定します。
setValWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
WBS 要素を設定します。
setValcode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
値タイプ: 範囲制限 - 単一値を設定します。
setValcount(String) - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
階層ノード内の値の値数を設定します。
setValfrom(String) - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues のメソッド
原価センタ/利益センタを設定します。
setValid(boolean) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
アクティブなセッション情報を有効・無効化します。
setValidEndDate(Date) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
有効終了日を設定します。
setValidEndDate(Date) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のメソッド
有効終了日を設定します。
setValidEndDate(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
有効終了日を設定します。
setValidEndDate(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel のメソッド
有効終了日を設定します。
setValidEndYear(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
有効終了年を設定します。
setValidEndYear(int) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
有効終了年を設定します。
setValidFlg(String) - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
有効フラグを設定します。
setValidFrom(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
エントリの有効開始日を設定します。
setValidFrom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
流通チェーン別品目ステータスの有効期間開始日を設定します。
setValidFrom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
原価有効開始日を設定します。
setValidFrom(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
見積または基本契約の有効開始日を設定します。
setValidStartDate(Date) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
有効開始日を設定します。
setValidStartDate(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
有効開始日を設定します。
setValidStartDate(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel のメソッド
有効開始日を設定します。
setValidStartYear(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
有効開始年を設定します。
setValidStartYear(int) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
有効開始年を設定します。
setValidTo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
有効終了日を設定します｡
setValidTo(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
見積または基本契約有効終了日を設定します。
setValidate(ImportManager, ImportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
インポート設定に定義されたバリデーションステータスをマネージャーに設定します。
setValidate(boolean) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManager のメソッド
インポートデータに対してバリデーションを行うかどうか設定します。
setValidate(boolean) - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl のメソッド
インポートデータに対してバリデーションを行うかどうか設定します。
setValidate(boolean) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager のメソッド

setValidate(boolean) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager のメソッド

setValidate(boolean) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager のメソッド

setValidate(boolean) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager のメソッド

setValidate(boolean) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager のメソッド

setValidate(boolean) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチの有効・無効を設定します。
setValidationExceptionDetails(Collection) - class jp.co.intra_mart.framework.base.service.validator.ValidationException のメソッド
検証結果の詳細を設定します。
setValidatorClassName(String) - class jp.co.intra_mart.framework.base.service.ValidatorMapping のメソッド
バリデータ名を設定します。
setValidatorConfig(ValidatorConfig) - class jp.co.intra_mart.framework.base.service.ValidatorMapping のメソッド
バリデータの初期化パラメータを設定します。
setValto(String) - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues のメソッド
原価センタ/利益センタを設定します。
setValuationData(ValuationData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
評価データを設定します。
setValuationDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
評価データを設定します。
setValuationarea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
評価レベルを設定します。
setValuationtype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
評価タイプを設定します。
setValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
CO-PA 特性値を設定します。
setValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
特性値を設定します。
setValue(Object) - class jp.co.intra_mart.framework.base.web.tag.MessageParamTag のメソッド
パラメータの値を設定します。
setValue(String) - class jp.co.intra_mart.framework.base.web.tag.ParamTag のメソッド
パラメータの値を設定します。
setValue(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性valueを設定します。
setValue(String) - class jp.co.intra_mart.framework.system.property.PropertyParam のメソッド
パラメータの値を設定します。
setValueChanged(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンによる金額変更を設定します。
setValueTo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
特性値を設定します。
setValueTxt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
特性値の言語依存テキストを設定します。
setValueduom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ロット特定数量単位での評価を設定します。
setValuepart1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
長さ 229 の文字データのコンテナを設定します。
setValuepart4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
長さ 229 の文字データのコンテナを設定します。
setValuepart4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValues(String[]) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のメソッド
エラーメッセージで使用する置換用の文字列を設定します。
setVarOrdUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
可変購買発注単位有効を設定します。
setVarSalesUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
可変販売単位の使用不可を設定します。
setVarcond(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
バリアント条件を設定します。
setVarcond(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
バリアント条件を設定します。
setVarianceKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
差異キーを設定します。
setVatCntry(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
売上税 ID 番号国を設定します。
setVatCntryIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
消費税登録番号の ISO 国コードを設定します。
setVclassPp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期評価クラスを設定します。
setVclassPy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度の評価クラスを設定します。
setVendMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
仕入先が使用している品目コードを設定します。
setVendName(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
名称 1を設定します。
setVendPart(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先部門を設定します。
setVendUser(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
仕入先担当者を設定します。
setVendor(String) - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
仕入先または債権者の勘定コードを設定します。
setVendor(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
仕入先または債権者の勘定コードを設定します。
setVendor(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
仕入先または債権者の勘定コードを設定します。
setVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
仕入先勘定コードを設定します｡
setVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
仕入先コードを設定します｡
setVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のメソッド
仕入先コードを設定します｡
setVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のメソッド
仕入先コードを設定します｡
setVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
仕入先コードを設定します｡
setVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
仕入先勘定コードを設定します。
setVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
仕入先勘定コードを設定します。
setVendorNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
仕入先または債権者の勘定コードを設定します。
setVendorRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
仕入先の範囲を設定します。
setVendrbatch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先ロット番号を設定します。
setVendrbatch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
仕入先ロット番号を設定します。
setVerGrGiSlip(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入出庫票の印刷バ－ジョンを設定します。
setVerGrGiSlipx(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
関連ユーザデータ項目の更新情報を設定します。
setVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買管理におけるバージョン番号を設定します。
setVersion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売伝票バージョン番号を設定します。
setVersion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setVersionCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
バージョンコードを設定します。
setVersionCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
バージョンコードを設定します。
setVersionFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
バージョン区分を設定します。
setVersions(Versions) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
バージョン管理ヘッダを設定します｡
setViewOpen(EventNavigatorManager, String, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
表示設定 イベントフロー情報に表示／非表示を設定する。
setViewOpen(String, String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
表示設定 イベントフロー情報に表示／非表示を設定する。
setViewOpen(EventNavigatorManager, String, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
表示設定 イベントフロー情報に表示／非表示を設定する。
setVirtCard(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
チェックボックスを設定します。
setVkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
バリアント条件名を設定します。
setVmPStock(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
プロジェクト在庫の評価クラスを設定します。
setVmSoStk(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
受注在庫の評価クラスを設定します。
setVolTolLt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
荷役単位の容積超過許容量を設定します。
setVolume(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
容積を設定します。
setVolume(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
容積を設定します。
setVolume(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細の総数量を設定します。
setVolume(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setVolumeunit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
容積単位を設定します。
setVolumeunit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
容積単位を設定します。
setVolumeunitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ISO コードでの容積単位を設定します。
setVolumeunitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ISO コードでの容積単位を設定します。
setVolunit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
容積単位を設定します。
setVolunit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setVolunitiso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ISO コードでの容積単位を設定します。
setVperEnd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
有効期間終了日を設定します｡
setVperStart(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
有効期間開始日を設定します｡
setVwUepos(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
上位レベル明細用途 IDを設定します。
setVwUepos(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setWagetype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ウェイジタイプを設定します。
setWaitTime(long) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 コネクション取得の待機時間を設定します｡
setWarDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
保証期間の開始日付を設定します。
setWarDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setWarehouseNumberData(WarehouseNumberData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
倉庫番号データを設定します。
setWarehouseNumberDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
倉庫番号データを設定します。
setWarehouseView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
倉庫管理ビューを設定します。
setWarehouseView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
倉庫管理ビューを設定します。
setWarehousenumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
倉庫番号/複合倉庫を設定します。
setWarranty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
保証日を設定します｡
setWbsAccountAssignmentElement(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
区分: 勘定設定要素を設定します。
setWbsActualDurUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
実績 WBS 要素日付の期間単位を設定します。
setWbsActualDurUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを設定します。
setWbsActualDuration(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の実績長(期間)を設定します。
setWbsActualFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の実績終了日を設定します。
setWbsActualStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の実績開始日付を設定します。
setWbsBasicDurUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
基準 WBS 要素日付の期間単位を設定します。
setWbsBasicDurUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを設定します。
setWbsBasicDuration(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の基準日の長さ(期間)を設定します。
setWbsBasicFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素: 基本終了日付を設定します。
setWbsBasicStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素: 基本開始日を設定します。
setWbsBillingElement(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
区分: 請求要素を設定します。
setWbsCctrPostedActual(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
原価が実際に転記される原価センタを設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
作業詳細項目要素 (WBS 要素)を設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
WBS 要素を設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
WBS 要素を設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
WBS 要素を設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
WBS 要素を設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
WBS 要素を設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
WBS 要素を設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setWbsElement(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
WBS 要素を設定します。
setWbsElement(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素を設定します。
setWbsElement(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を設定します。
setWbsElement(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
WBS 要素を設定します。
setWbsElement(String) - class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement のメソッド
WBS 要素を設定します。
setWbsElement(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
WBS 要素を設定します。
setWbsElementExt(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
WBS 要素を設定します。
setWbsForcastDurUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素計画日付の単位を設定します。
setWbsForecastDurUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを設定します。
setWbsForecastDuration(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の予測期間を設定します。
setWbsForecastFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の予測済終了日付を設定します。
setWbsForecastStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の予測開始日を設定します。
setWbsPlanningElement(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
区分: 計画要素を設定します。
setWbsScdActualFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の仮実績終了日を設定します。
setWbsScdActualStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の仮実績開始日を設定します。
setWbsScdBasicFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
最遅計画終了日 (基準)を設定します。
setWbsScdBasicStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
最早計画開始日 (基準)を設定します。
setWbsScdForecastFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
最遅計画終了日 (予測)を設定します。
setWbsScdForecastStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
計画開始日 (予測)を設定します。
setWbsSchedProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
WBS 日程計画のプロファイルを設定します。
setWeek(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
第ｎ週目を設定します。
setWeek(int) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
週を設定します。
setWeightunit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
重量単位を設定します。
setWeightunitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
重量単位のISOコードを設定します。
setWhseNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
倉庫番号/複合倉庫を設定します。
setWhseNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
倉庫番号/複合倉庫を設定します。
setWidth(int) - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルの幅を設定します。
setWidth(int) - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
表示単位に対する幅設定します。
setWidth(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
幅を設定します。
setWithActivities(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
従属活動を設定します。
setWithActivities(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
従属活動を設定します。
setWithMilestones(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
従属 WBS マイルストーンを設定します。
setWithMilestones(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
従属 WBS マイルストーンを設定します。
setWithSubtree(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
サブプロジェクトを設定します。
setWithSubtree(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
サブプロジェクトを設定します。
setWithdrawal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
在庫払出に対する保管域タイプ区分を設定します。
setWithdrawn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫予定に対する出庫完了を設定します。
setWithdrawn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入出庫予定に対する出庫完了を設定します。
setWmUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
倉庫管理の数量単位を設定します。
setWmUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードでの倉庫管理単位を設定します。
setWmdvexList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
出力テーブル (日付および ATP 数量)を設定します。
setWmdvsxList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
入力テーブル (日付/数量)を設定します。
setWorkActivity(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動に含まれる作業を設定します。
setWorkActual(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
実績作業を設定します。
setWorkCntr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
作業区を設定します。
setWorkForecast(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予測作業 (実績 + 残存)を設定します。
setWorkPermit(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
仕事許可済フラグを設定します。
setWorkSchedView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
作業計画ビューを設定します。
setWorkSchedView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
作業計画ビューを設定します。
setWtTolLt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
荷役単位の重量超過許容量を設定します。
setWtWithcd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
源泉徴収税コードを設定します。
setWtgGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
加重グループを設定します。
setXAutoCre(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
自動登録済み明細を設定します。
setXSLT(String) - interface jp.co.intra_mart.foundation.portal.common.rss.RSSParserIF のメソッド
RSSのXMLをフォーマットするXSLスタイルシートのファイルパスをセットします
setXstob(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取消移動タイプ区分の使用を設定します。
setYear(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
年を設定します。
setYear(int) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
年を設定します。
setYline(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
内部テ－ブル処理の行索引を設定します。
setZipCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
郵便番号を設定します。
setZipCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
郵便番号を設定します。
setZipCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
郵便番号を設定します。
setZipCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
郵便番号を設定します。
setZipCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
郵便番号を設定します。
setZipCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
郵便番号を設定します。
setZipCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
郵便番号を設定します。
setZipCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
郵便番号を設定します。
setZipCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
郵便番号を設定します。
shutdown() - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の static メソッド
このプロセスを終了します。
shutdown(int) - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の static メソッド
このプロセスを終了します。
size() - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リスト内にある要素の数を返します。
size() - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のメソッド
このオブジェクトの管理するモニターの数を取得します。
size() - class jp.co.intra_mart.extension.maskat.util.MKErrors のメソッド
errorの個数を取得します。
size() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
データの数を返します。
size() - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
値の数を返します。
size() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
データの数を返します。
size() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
データの数を返します。
size() - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
値の数を返します。
size() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
データの数を返します。
size() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
データの数を返します。
size() - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
値の数を返します。
size() - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リスト内にある要素の数を返します。
size() - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
このノードが持つ子ノードの数を返します。
size() - interface jp.co.intra_mart.foundation.page.TreeNodeContainer のメソッド
このノードが持つ子ノードの数を返します。
size() - class jp.co.intra_mart.foundation.utility.LockMonitor のメソッド
推奨されていません。 このオブジェクトの管理するモニターの数を取得します。
skip(long) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
指定のバイト数だけ入力をスキップします。
sort(Comparator) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
指定されたコンパレータに従って、子ノードをソートします。
sortAll(Comparator) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
このノードの下にある、全ての子ノードを指定されたコンパレータに従ってソートします。
sourceName() - class jp.co.intra_mart.foundation.scenario.FunctionContainer のメソッド
ソース名称の取得。
sourceName() - class jp.co.intra_mart.foundation.scenario.FunctionContainerFile のメソッド
スクリプトのファイルパス名を返します。
start() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
スケジューラの開始通知。
startAutomaticExecution(long) - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
推奨されていません。 gc によるシステム停止や監視スレッドを停止処理しないことによるメモリリークなどの問題を引き起こす危険性があります。
startElement(String, String, String, Attributes) - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のメソッド
DefaultHandlerのabstractメソッドをオーバーライドします。
stop() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
スケジューラの停止通知。
stopAutomaticExecution() - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
推奨されていません。
stringToDate(String) - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
データベース登録用文字列からjava.util.Dateを取得します。
stringToDate(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
データベース登録用文字列からjava.util.Dateを取得します。
stringToDate(String) - class jp.co.intra_mart.foundation.database.DbManager の static メソッド
推奨されていません。 DatabaseManager.stringToDate(String)を使用してください。
subList(int, int) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
このリストの、fromIndex (これを含む) から toIndex (これを含まない) の範囲の部分のビューを返します。
subList(int, int) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 このリストの、fromIndex (これを含む) から toIndex (これを含まない) の範囲の部分のビューを返します。
subMap(String[]) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
データを取得します。
subMap(String[]) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
データを取得します。
subMap(String[]) - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
データを取得します。
subMap(String[]) - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
データを取得します。
subRoleAdded(String, String, String) - class jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener のメソッド
ロールにサブロールを追加した直後にコールされます。
subRoleAdded(String, String, String) - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のメソッド
ロールにサブロールを追加した直後にコールされます。
subRoleAdded(String, String, String) - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のメソッド
ロールにサブロールを追加した直後にコールされます。
subRoleAdded(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener のメソッド
ロールにサブロールを追加した直後にコールされます。
subRoleDeleted(String, String, String) - class jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener のメソッド
ロールからサブロールを削除した直後にコールされます。
subRoleDeleted(String, String, String) - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のメソッド
ロールからサブロールを削除した直後にコールされます。
subRoleDeleted(String, String, String) - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のメソッド
ロールからサブロールを削除した直後にコールされます。
subRoleDeleted(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener のメソッド
ロールからサブロールを削除した直後にコールされます。
subtract(Term[], Term[]) - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager の static メソッド
期間配列 term1 から 期間配列 term2 を差し引いた期間を返します。
suspend() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager のメソッド
ラップしたTransactionManagerのsuspendを呼び出します。

T

TABLE_B_M_EVENT_DEPARTMENT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

TABLE_B_M_EVENT_FLOW - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

TABLE_B_M_EVENT_ITEM - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

TABLE_B_M_EVENT_PAGE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

TABLE_B_M_EVENT_PAGE_PARAM - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

TABLE_B_M_EVENT_POST - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

TABLE_B_M_EVENT_PUBLIC_GROUP - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

TABLE_B_M_EVENT_RESULT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

TABLE_B_M_EVENT_ROLE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

TABLE_B_M_EVENT_SAVE_RESULT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

TABLE_B_M_EVENT_SELECT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

TABLE_B_M_EVENT_TITLE_INFO - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

TELEPHONE_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
電話番号
TELEPHONE_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
電話番号
TEMPLATE_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel の static 変数
テンプレートコード
TEMPLATE_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel の static 変数
テンプレートコード
TEMPLATE_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel の static 変数
テンプレートコード
TEMPLATE_DETAIL_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel の static 変数
テンプレート明細コード
TEMPLATE_DETAIL_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel の static 変数
テンプレート明細コード
TEMPLATE_DETAIL_NAME - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel の static 変数
テンプレート明細名
TEMPLATE_NAME - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel の static 変数
テンプレート名
TIMES - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
次
TRANSITION_SUFFIX - class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator の static 変数

TYPE_CONFIG - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo の static 変数
名称（データタイプの定数）。
TYPE_DATA_SOURCE - interface jp.co.intra_mart.foundation.database.ConInfo の static 変数

TYPE_DATE - class jp.co.intra_mart.foundation.database.DatabaseColumn の static 変数

TYPE_DB - class jp.co.intra_mart.framework.system.log.IntramartLogAgent の static 変数
データベースログに出力する場合のカテゴリの種類
TYPE_DEBUG - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の static 変数
デバッグレベル。
TYPE_DEBUG - interface jp.co.intra_mart.foundation.utility.report.ReportLevel の static 変数
推奨されていません。 デバッグレベル。
TYPE_ERROR - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の static 変数
エラーレベル。
TYPE_ERROR - interface jp.co.intra_mart.foundation.utility.report.ReportLevel の static 変数
推奨されていません。 エラーレベル。
TYPE_EVENT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
遷移先タイプ：イベントアイテム
TYPE_GROUP - interface jp.co.intra_mart.foundation.database.ConInfo の static 変数

TYPE_HOLIDAY - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo の static 変数
休日（データタイプの定数）。
TYPE_JDBC - interface jp.co.intra_mart.foundation.database.ConInfo の static 変数

TYPE_NATIONAL_HOLDAY - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo の static 変数
祝祭日（データタイプの定数）。
TYPE_NUMBER - class jp.co.intra_mart.foundation.database.DatabaseColumn の static 変数

TYPE_REPORT - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の static 変数
通常の情報レベル。
TYPE_REPORT - interface jp.co.intra_mart.foundation.utility.report.ReportLevel の static 変数
推奨されていません。 通常の情報レベル。
TYPE_RESULT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
遷移先タイプ：ナビゲート結果
TYPE_STRING - class jp.co.intra_mart.foundation.database.DatabaseColumn の static 変数

TYPE_SYSTEM - interface jp.co.intra_mart.foundation.database.ConInfo の static 変数

TYPE_UNDEFINED - class jp.co.intra_mart.foundation.database.DatabaseColumn の static 変数

TYPE_WARNING - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の static 変数
警告レベル。
TYPE_WARNING - interface jp.co.intra_mart.foundation.utility.report.ReportLevel の static 変数
推奨されていません。 警告レベル。
TYPE_WEEKDAY - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo の static 変数
非休日（データタイプの定数）。
Table - interface jp.co.intra_mart.foundation.datastore.common.config.Table.
テーブルを定義します。
TagWriter - class jp.co.intra_mart.framework.base.web.tag.TagWriter.
タグの出力を行います。
TagWriter(JspWriter) - class jp.co.intra_mart.framework.base.web.tag.TagWriter のコンストラクタ
TagWriterを新規に生成します。
TaxClassifications - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications.
制御デ－タ情報クラス
機能は以下の通り
制御デ－タ情報を保持します。
TaxClassifications() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のコンストラクタ
制御デ－タ情報を作成します。
TaxClassifications(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のコンストラクタ
制御デ－タ情報を作成します。
TemporaryDirectory - class jp.co.intra_mart.foundation.service.provider.TemporaryDirectory.
このクラスは、一時ファイル保存用ディレクトリに関する機能を 提供します。
TemporaryFile - class jp.co.intra_mart.foundation.service.provider.TemporaryFile.
このクラスは、一時ファイルに関する機能を提供します。
TemporaryFile() - class jp.co.intra_mart.foundation.service.provider.TemporaryFile のコンストラクタ
一時ファイルのパスを作成します。
Term - class jp.co.intra_mart.foundation.datastore.common.structure.Term.
有効期間を表します。
Term() - class jp.co.intra_mart.foundation.datastore.common.structure.Term のコンストラクタ
開始時間、終了時間とも指定されていない有効期間を生成します。
Term(Date) - class jp.co.intra_mart.foundation.datastore.common.structure.Term のコンストラクタ
開始時間のみが指定された有効期間を生成します。
Term(Date, Date) - class jp.co.intra_mart.foundation.datastore.common.structure.Term のコンストラクタ
開始時間と終了時間がともに指定された有効期間を生成します。
TermManager - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager.
期間 Term を取り扱うマネージャクラスです。
TermManagerException - exception jp.co.intra_mart.foundation.datastore.exception.TermManagerException.
期間に関する例外クラス

TermManagerException() - class jp.co.intra_mart.foundation.datastore.exception.TermManagerException のコンストラクタ
コンストラクタ
TermManagerException(String) - class jp.co.intra_mart.foundation.datastore.exception.TermManagerException のコンストラクタ
コンストラクタ
TermManagerException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.TermManagerException のコンストラクタ
コンストラクタ
TermManagerException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.TermManagerException のコンストラクタ
コンストラクタ
TerminableAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor.
期間化エンティティに対する情報操作用のインタフェースです。
TerminableAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap.
期間化アクセサのマッピング情報を持ちます。
TerminableInternationalAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor.
期間国際化エンティティに対する情報操作用のインタフェースです。
TerminableInternationalAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap.
期間国際化アクセサのマッピング情報を持ちます。
TerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalModel.
期間国際化モデルを定義します。
TerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel.
期間国際化モデルの情報です。
TerminableInternationalModelContext - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext.
期間国際化モデルの初期化に必要な設定を持ちます。
TerminableInternationalModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap.
期間国際化モデルのマッピング情報を持ちます。
TerminableInternationalTable - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable.
期間国際化テーブルを定義します。
TerminableKey - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableKey.
期間化基準項目を定義します。
TerminableModel - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableModel.
期間化モデルを定義します。
TerminableModel - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel.
期間化モデルの情報です。
TerminableModelContext - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext.
期間化化モデルの初期化に必要な設定を持ちます。
TerminableModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap.
期間化モデルのマッピング情報を持ちます。
TerminableTable - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable.
期間化テーブルを定義します。
Text - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text.
テキスト情報クラス
機能は以下の通り
テキスト情報を保持します。
Text() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のコンストラクタ
テキスト情報を作成します。
Text(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のコンストラクタ
テキスト情報を作成します。
TextDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn.
請求インタフェースの通信構造テキスト情報クラス
機能は以下の通り
請求インタフェースの通信構造テキスト情報を保持します。
TextDataIn() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のコンストラクタ
請求インタフェースの通信構造テキスト情報を作成します。
TextDataIn(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のコンストラクタ
請求インタフェースの通信構造テキスト情報を作成します。
TextFileDataPropertyHandler - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler.
指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
TextFileDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のコンストラクタ
TextFileDataPropertyHandlerを新規に生成します。
TextFileEventPropertyHandler - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler.
指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
TextFileEventPropertyHandler() - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のコンストラクタ
TextFileEventPropertyHandlerを新規に生成します。
TextFileMessagePropertyHandler - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler.
指定されたファイルからプロパティ情報を取得するメッセージプロパティハンドラです。
TextFileMessagePropertyHandler() - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler のコンストラクタ

TextFileServicePropertyHandler - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.
指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
TextFileServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のコンストラクタ
TextFileServicePropertyHandlerを新規に生成します。
ThreadStopListener - interface jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener.
To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates.
ThreadStopListener - interface jp.co.intra_mart.foundation.utility.ThreadStopListener.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener クラスを使用してください。
ThrowablePrintListener - interface jp.co.intra_mart.common.aid.jdk.java.lang.ThrowablePrintListener.
このインタフェースは、例外情報を出力するためのものです。
TitleInfo - class jp.co.intra_mart.foundation.navigator.TitleInfo.
タイトル情報
TitleInfo() - class jp.co.intra_mart.foundation.navigator.TitleInfo のコンストラクタ

TotalConsumption - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption.
品目総消費量のデータ転送情報クラス
機能は以下の通り
品目総消費量のデータ転送情報を保持します。
TotalConsumption() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のコンストラクタ
品目総消費量のデータ転送情報を作成します。
TotalConsumption(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のコンストラクタ
品目総消費量のデータ転送情報を作成します。
TrEvTypeRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa.
トランザクション/イベントタイプの範囲情報クラス
機能は以下の通り
トランザクション/イベントタイプの範囲情報を保持します。
TrEvTypeRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のコンストラクタ
トランザクション/イベントタイプの範囲情報を作成します。
TrEvTypeRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のコンストラクタ
トランザクション/イベントタイプの範囲情報を作成します。
Transition - class jp.co.intra_mart.framework.base.service.Transition.
画面遷移に関連するクラスのインタフェースです。
Transition() - class jp.co.intra_mart.framework.base.service.Transition のコンストラクタ
Transitionを新規に生成します。
TransitionException - exception jp.co.intra_mart.framework.base.service.TransitionException.
トランジションに関連する例外です。
TransitionException() - class jp.co.intra_mart.framework.base.service.TransitionException のコンストラクタ
詳細メッセージを指定しないで TransitionException を構築します。
TransitionException(String) - class jp.co.intra_mart.framework.base.service.TransitionException のコンストラクタ
指定された詳細メッセージを持つ TransitionException を構築します。
TransitionException(String, Throwable) - class jp.co.intra_mart.framework.base.service.TransitionException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ TransitionException を構築します。
TreasureDirectory - interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory.
情報データベースのディレクトリを操作するためのインターフェースを定義します。
TreasureFile - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile.
情報データベースのファイルを操作するためのインターフェースを定義します。
TreeBranch - class jp.co.intra_mart.foundation.page.TreeBranch.
ツリービュー内の「フォルダ」をあらわすクラスです。
TreeBranch() - class jp.co.intra_mart.foundation.page.TreeBranch のコンストラクタ
新しいTreeBranchオブジェクトを生成します。
TreeBranch(Comparator) - class jp.co.intra_mart.foundation.page.TreeBranch のコンストラクタ
指定されたコンパレータに従って子ノードをソートする、新しいTreeBranchオブジェクトを生成します。
TreeLeaf - class jp.co.intra_mart.foundation.page.TreeLeaf.
ツリービュー内の「ページ」をあらわすクラスです。
TreeLeaf() - class jp.co.intra_mart.foundation.page.TreeLeaf のコンストラクタ
新しくTreeLeafオブジェクトを生成します。
TreeLeaf(String) - class jp.co.intra_mart.foundation.page.TreeLeaf のコンストラクタ
新しくTreeLeafオブジェクトを生成し、表示名称を設定します。
TreeLeaf(String, String) - class jp.co.intra_mart.foundation.page.TreeLeaf のコンストラクタ
新しくTreeLeafオブジェクトを生成し、表示名称と、ポップアップ文字列を設定します。
TreeNode - interface jp.co.intra_mart.foundation.page.TreeNode.
ツリービュー内の単一のノードを表すインターフェースです。
TreeNodeContainer - interface jp.co.intra_mart.foundation.page.TreeNodeContainer.
子ノードを参照するためのメソッドが定義されたインターフェースです。
TreeNodeProvider - interface jp.co.intra_mart.foundation.page.TreeNodeProvider.
ツリービューの「ホーム」をあらわすインターフェースです。
TreeRoot - class jp.co.intra_mart.foundation.page.TreeRoot.
ツリービュー内の「ホーム」をあらわすクラスです。
TreeRoot() - class jp.co.intra_mart.foundation.page.TreeRoot のコンストラクタ
新しいTreeRootオブジェクトを生成します。
TreeRoot(Comparator) - class jp.co.intra_mart.foundation.page.TreeRoot のコンストラクタ
指定されたコンパレータに従って子ノードをソートする、新しいTreeRootオブジェクトを生成します。
TrimmedFilterReader - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader.
このクラスは、基礎となる java.io.Reader をフィルタリングした Writer 機能を提供します。
TrimmedFilterReader(Reader) - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader のコンストラクタ
Reader をフィルタリングする新しい TrimmedFilterReader を作成します。
TrimmedFilterWriter - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter.
このクラスは、基礎となる java.io.Writer をフィルタリングした Writer 機能を提供します。
TrimmedFilterWriter(Writer) - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter のコンストラクタ
Writer をフィルタリングする新しい TrimmedFilterWriter を作成します。
temporaryDirectory() - class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory のメソッド
削除対象のデータファイルを一時的に保存しておくための ディレクトリを表すオブジェクトを取得します。
toArray() - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リスト内のすべての要素が正しい順序で格納されている配列を返します。
toArray(Object[]) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リスト内のすべての要素が正しい順序で格納されている配列を返します。
toArray() - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リスト内のすべての要素が正しい順序で格納されている配列を返します。
toArray(Object[]) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リスト内のすべての要素が正しい順序で格納されている配列を返します。
toIANAName(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager の static メソッド
指定されたエンコーディングセット名に対応する IANAに登録されている キャラクタセット名 を返却します。
toJDKName(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager の static メソッド
指定されたキャラクタセット名 に対応する J2SEでサポートされているエンコーディングセット名を返却します。
toString() - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のメソッド
このオブジェクトの文字列表現を返します。
toString() - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
オブジェクトの文字列表現を返します。
toString() - class jp.co.intra_mart.foundation.datastore.exporter.Filter のメソッド
フィルタの文字列表現を返します。
toString() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
オブジェクトを文字列に変換します。
toString() - class jp.co.intra_mart.foundation.image.ImageIconInfo のメソッド
この ImageIconInfo の値を表す String オブジェクトを返します。
toString() - class jp.co.intra_mart.foundation.page.EventScript のメソッド
このオブジェクトの文字列表現を返します。
toString() - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.BankList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.Company のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.Selection のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
デバッグ用のメソッドです。
toString() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値の文字列表現を取得します。
toString() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
設定情報モデルの内容を返す。
toString() - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のメソッド
推奨されていません。 このオブジェクトの文字列表現を返します。
toXML() - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer のメソッド
指定されたフィールド定義、レコードからCurlで入力可能なXML(elaborate-xmlで 入力可能)を生成します。
toXMLNode() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
このインスタンスのXMLノードとしての文字列を返します。
toXMLNode() - interface jp.co.intra_mart.foundation.im_curl.CurlRecordBeanIF のメソッド
保持しているデータをXMLノードの文字列に変換します。
total() - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のメソッド
モニターを利用中、または利用しようとしているスレッドの数です。
total() - class jp.co.intra_mart.foundation.utility.LockMonitor のメソッド
推奨されていません。 モニターを利用中、または利用しようとしているスレッドの数です。
totalMemory() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
サーバプロセスの Java Virtual Machine のメモリの総容量を返します。
transaction() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースアクセスのトランザクションを開始する

トランザクションを開始させる。
transfer() - class jp.co.intra_mart.extension.maskat.service.MKTransition のメソッド
サービス処理結果に格納されたドキュメントをレスポンスとして送信します。
transfer() - class jp.co.intra_mart.framework.base.service.DefaultTransition のメソッド
次のページに遷移します。
transfer() - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のメソッド
ページベースの画面に遷移します。
transfer() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
次のページに遷移します。
transliterate(String) - class jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener のメソッド
指定した文字列のに含まれる半角カナ文字を全角カナ文字に変化して返します。
trimToSize() - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
この ArrayList のインスタンスのサイズをリストの現在のサイズに縮小します。
trimToSize() - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 この ArrayList のインスタンスのサイズをリストの現在のサイズに縮小します。

U

UNAVALIABLE_LOGIN_USER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ログイン出来ないアカウントを表す定数
UNIT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel の static 変数
単位コード
UNIT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitBaseModel の static 変数
単位コード
UNIT_NAME - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitBaseModel の static 変数
単位名
UNIT_PRICE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の static 変数
単価
UNIT_PRICE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel の static 変数
単価
URL - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
URL
URL - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
URL
URL - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の static 変数
URL
URLAccessFilter - class jp.co.intra_mart.foundation.security.filter.URLAccessFilter.
URLアクセスフィルタ。
URLAccessFilter() - class jp.co.intra_mart.foundation.security.filter.URLAccessFilter のコンストラクタ

URLBuilder - class jp.co.intra_mart.jssp.net.URLBuilder.
スクリプト開発モデルの画面を呼び出すための URL を作成するビルダです。
URLBuilder(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.jssp.net.URLBuilder のコンストラクタ
新しいビルダを作成します。
URLDecodeInputStream - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream.
このクラスは、URL デコードされたデータを読み込むための ストリームフィルタを実装します。
URLDecodeInputStream(InputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream のコンストラクタ
指定された InputStream から URL デコードしながらバイトを読み込む 入力ストリームを作成します。
URLDecodeInputStream - class jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream クラスを使用してください。
URLDecodeInputStream(InputStream) - class jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream のコンストラクタ
推奨されていません。 指定された InputStream から URL デコードしながらバイトを読み込む 入力ストリームを作成します。
URLDecodeOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream.
このクラスは、URL デコードされたデータを書き込むための ストリームフィルタを実装します。
URLDecodeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream のコンストラクタ
指定された OutputStream に書き込む URLデコーダーを作成します。
URLDecodeOutputStream - class jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream クラスを使用してください。
URLDecodeOutputStream(OutputStream) - class jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に書き込む BASE64デコーダーを作成します。
URLEncodeOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream.
このクラスは、URL エンコードされたデータを書き込むための ストリームフィルタを実装します。
URLEncodeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream のコンストラクタ
指定された OutputStream に書き込む BASE64デコーダーを作成します。
URLEncodeOutputStream - class jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream クラスを使用してください。
URLEncodeOutputStream(OutputStream) - class jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に書き込む BASE64デコーダーを作成します。
URLUtil - class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil.
URL関連のユーティリティクラス。
URLUtil() - class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil のコンストラクタ

USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
ユーザコード
USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の static 変数
ユーザコード
USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の static 変数
ユーザコード
USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の static 変数
ユーザコード
USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ユーザコード
USER_ID - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel の static 変数
ユーザID
USER_ID - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
ユーザID
USER_ID - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel の static 変数
ユーザID
USER_ID - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel の static 変数
ユーザID
UnauthorizedException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException.
リクエストを受け付けるためには認証が必要であることを通知するための例外です。
UnauthorizedException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException のコンストラクタ
指定のメッセージを持つ例外を作成します。
UnauthorizedException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
UnauthorizedException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException のコンストラクタ
例外を作成します。
UnitBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitBaseModel.
単位の基本モデルです。
UnitMapper - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper.
単位に関連するマッパです。
UnitSofmeasure - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure.
数量単位情報クラス
機能は以下の通り
数量単位情報を保持します。
UnitSofmeasure() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のコンストラクタ
数量単位情報を作成します。
UnitSofmeasure(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のコンストラクタ
数量単位情報を作成します。
UnlimitedBufferedOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream.
出力データを一時的にバッファリングする出力ストリームの実装です。
UnlimitedBufferedOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream のコンストラクタ
出力データをバッファリングするためのフィルター出力ストリームを 新しく作成します。
UnplndConsumption - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption.
計画外消費のデータ転送情報クラス
機能は以下の通り
計画外消費のデータ転送情報を保持します。
UnplndConsumption() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のコンストラクタ
計画外消費のデータ転送情報を作成します。
UnplndConsumption(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のコンストラクタ
計画外消費のデータ転送情報を作成します。
UnripeQueryException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException.
クエリが Content-Lnegth ヘッダで指定された量に満たない場合に スローされる例外です。
UnripeQueryException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException のコンストラクタ
指定のメッセージを持つ例外を作成します。
UnripeQueryException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
UnripeQueryException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException のコンストラクタ
例外を作成します。
UnsupportedNetworkConnectException - exception jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException.
To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates.
UnsupportedNetworkConnectException() - class jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException のコンストラクタ
Constructor for UnsupportedNetworkConnectException.
UnsupportedNetworkConnectException(String) - class jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException のコンストラクタ
Constructor for UnsupportedNetworkConnectException.
UnsupportedNetworkConnectException - exception jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException クラスを使用してください。
UnsupportedNetworkConnectException() - class jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException のコンストラクタ
推奨されていません。 Constructor for UnsupportedNetworkConnectException.
UnsupportedNetworkConnectException(String) - class jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException のコンストラクタ
推奨されていません。 Constructor for UnsupportedNetworkConnectException.
UnsupportedProductEditionException - exception jp.co.intra_mart.foundation.sap.common.exception.UnsupportedProductEditionException.
SAPリアルタイム連携APIがサポートされていないintra-mart製品で使用された場合にスローされる例外クラス
UnsupportedProductEditionException() - class jp.co.intra_mart.foundation.sap.common.exception.UnsupportedProductEditionException のコンストラクタ
コンストラクタ。
UpdateAccessor - interface jp.co.intra_mart.foundation.update.UpdateAccessor.
情報更新管理アクセッサインタフェース。
UpdateController - class jp.co.intra_mart.foundation.sap.module.UpdateController.
登録・更新系モジュール共通コントローラ親クラス。
UpdateController() - class jp.co.intra_mart.foundation.sap.module.UpdateController のコンストラクタ
コンストラクタ。
UpdateController(SapClient) - class jp.co.intra_mart.foundation.sap.module.UpdateController のコンストラクタ
コンストラクタ。
UpdateController(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.UpdateController のコンストラクタ
コンストラクタ。
UpdateInfo - interface jp.co.intra_mart.foundation.datastore.common.config.UpdateInfo.
エンティティの更新情報です。
UpdateManager - class jp.co.intra_mart.foundation.update.UpdateManager.
情報更新管理マネージャ。
UpdateManager(String) - class jp.co.intra_mart.foundation.update.UpdateManager のコンストラクタ
コンストラクタ。
User - class jp.co.intra_mart.foundation.datastore.application.domain.user.User.
ユーザの基本属性のデータを取り扱います。
User() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のコンストラクタ
ユーザに関連する情報を新規に生成します。
User(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のコンストラクタ
ユーザに関連する情報を新規に生成します。
User(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のコンストラクタ
ユーザに関連する情報を新規に生成します。
User(Locale, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のコンストラクタ
ユーザに関連する情報を新規に生成します。
UserActiveSessionRegister - class jp.co.intra_mart.foundation.security.activesession.UserActiveSessionRegister.
ユーザログイン認証リスナー実装クラス。
UserActiveSessionRegister() - class jp.co.intra_mart.foundation.security.activesession.UserActiveSessionRegister のコンストラクタ

UserAttachExportManager - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager.
ユーザ所属情報のエクスポートを行います。
UserAttachExportManager() - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager のコンストラクタ
コンストラクタ ユーザ所属情報エクスポートマネージャーのインスタンスを生成します。
UserAttachExportManagerClient - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient.
ユーザ所属情報のエクスポートを行います。
UserAttachExportManagerClient() - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient のコンストラクタ

UserAttachImportManager - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager.
ユーザ所属情報のインポートを行います。
UserAttachImportManager() - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager のコンストラクタ
コンストラクタ ユーザ所属情報インポートマネージャーのインスタンスを生成します。
UserAttachImportManagerClient - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient.
ユーザ所属情報のインポートを行います。
UserAttachImportManagerClient() - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient のコンストラクタ

UserBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel.
ユーザの基本モデルです。
UserCertification - interface jp.co.intra_mart.foundation.security.certification.UserCertification.
ユーザログイン認証インタフェース。
UserCertificationListener - interface jp.co.intra_mart.foundation.security.certification.UserCertificationListener.
ユーザログイン認証リスナーインタフェース。
UserCertificationServlet - class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet.
ユーザ認証サーブレット。
UserCertificationServlet() - class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet のコンストラクタ

UserChangedListener - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener.
ユーザに関する情報の変更時のリスナーです。
UserImporter - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter.
ユーザインポーターのインタフェースです。
UserInfo - interface jp.co.intra_mart.framework.base.util.UserInfo.
ログインユーザの情報を管理します。
UserInfoException - exception jp.co.intra_mart.framework.base.util.UserInfoException.
ユーザ情報に関連する例外です。
UserInfoException() - class jp.co.intra_mart.framework.base.util.UserInfoException のコンストラクタ
詳細メッセージを指定しないで UserInfoException を構築します。
UserInfoException(String) - class jp.co.intra_mart.framework.base.util.UserInfoException のコンストラクタ
指定された詳細メッセージを持つ UserInfoException を構築します。
UserInfoException(String, Throwable) - class jp.co.intra_mart.framework.base.util.UserInfoException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ UserInfoException を構築します。
UserInfoUtil - class jp.co.intra_mart.framework.base.util.UserInfoUtil.
ログインユーザの情報に関するユーティリティクラスです。
UserInfoWrapper - class jp.co.intra_mart.framework.base.util.UserInfoWrapper.
UserInfoを拡張するための実装です。
UserInfoWrapper() - class jp.co.intra_mart.framework.base.util.UserInfoWrapper のコンストラクタ
UserInfoWrapperを新規に生成します。
UserInitialServlet - class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet.
ユーザ初期アクセスサーブレット。
UserInitialServlet() - class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet のコンストラクタ

UserManager - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager.
ユーザに関連する情報を管理します。
UserManager() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager のコンストラクタ

UserMapper - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper.
ユーザに関連するマッパです。
UserNameRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa.
ユーザ名の範囲情報クラス
機能は以下の通り
ユーザ名の範囲情報を保持します。
UserNameRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のコンストラクタ
ユーザ名の範囲情報を作成します。
UserNameRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のコンストラクタ
ユーザ名の範囲情報を作成します。
UserPageProvider - interface jp.co.intra_mart.foundation.security.certification.UserPageProvider.
ユーザページプロバイダインタフェース。
UserProfileExportManager - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager.
ユーザ情報のエクスポートを行います。
UserProfileExportManager() - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager のコンストラクタ
コンストラクタ ユーザ情報エクスポートマネージャーのインスタンスを生成します。
UserProfileExportManagerClient - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient.
ユーザ情報のエクスポートを行います。
UserProfileExportManagerClient() - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient のコンストラクタ

UserProfileImportManager - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager.
ユーザ情報のインポートを行います。
UserProfileImportManager() - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager のコンストラクタ
コンストラクタ ユーザ情報インポートマネージャーのインスタンスを生成します。
UserProfileImportManagerClient - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient.
ユーザ情報のインポートを行います。
UserProfileImportManagerClient() - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient のコンストラクタ

UserStatus - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus.
ユーザステータス/指図ステータステーブル情報クラス 機能は以下の通り
ユーザステータス/指図ステータステーブル情報を保持します。
UserStatus() - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のコンストラクタ
ユーザステータス/指図ステータステーブルを作成します。
UserTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable.
ユーザの期間化属性のデータを取り扱います。
UserTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のコンストラクタ

UserTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational.
ユーザの期間国際化属性のデータを取り扱います。
UserTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のコンストラクタ

UserTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel.
ユーザの期間国際化モデルです。
UserTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel.
ユーザの期間化モデルです。
update(String, String, Map) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースにデータを更新するメソッド

データベースのデータを更新(アップデート)する。
update(CateogryClassBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
分類区分の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
分類区分の基本モデルを複数更新します。
update(CategoryDetailBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
分類区分詳細の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
分類区分詳細の基本モデルを複数更新します。
update(DepartmentAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
組織所属の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
組織所属の基本モデルを複数更新します。
update(CompanyCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
会社組織分類の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
会社組織分類の基本モデルを複数更新します。
update(CompanyBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
会社の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
会社の基本モデルを複数更新します。
update(DepartmentBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
組織の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
組織の基本モデルを複数更新します。
update(DepartmentInclusionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
組織内包の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
組織内包の基本モデルを複数更新します。
update(DepartmentMainBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
主所属の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
主所属の基本モデルを複数更新します。
update(CompanyPostBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
役職の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
役職の基本モデルを複数更新します。
update(CompanyVersionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
会社構成バージョンの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
会社構成バージョンの基本モデルを複数更新します。
update(DealBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper のメソッド
取扱の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper のメソッド
取扱の基本モデルを複数更新します。
update(DealerDepartmentBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper のメソッド
組織毎取扱パーミッションの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper のメソッド
組織毎取扱パーミッションの基本モデルを複数更新します。
update(DealDetailBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper のメソッド
取扱詳細の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper のメソッド
取扱詳細の基本モデルを複数更新します。
update(DealerPublicGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper のメソッド
パブリックグループ毎取扱パーミッションの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper のメソッド
パブリックグループ毎取扱パーミッションの基本モデルを複数更新します。
update(DealerRoleBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper のメソッド
ロール毎取扱パーミッションの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper のメソッド
ロール毎取扱パーミッションの基本モデルを複数更新します。
update(ItemAttributeBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper のメソッド
商品属性の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper のメソッド
商品属性の基本モデルを複数更新します。
update(ItemCatalogueBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper のメソッド
商品カタログの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper のメソッド
商品カタログの基本モデルを複数更新します。
update(ItemBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper のメソッド
商品の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper のメソッド
商品の基本モデルを複数更新します。
update(ItemAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper のメソッド
商品分類の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper のメソッド
商品分類の基本モデルを複数更新します。
update(ItemCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper のメソッド
商品カテゴリの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper のメソッド
商品カテゴリの基本モデルを複数更新します。
update(ItemCategoryTypeBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper のメソッド
商品カテゴリ種別の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper のメソッド
商品カテゴリ種別の基本モデルを複数更新します。
update(ItemTemplateDetailBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper のメソッド
商品属性テンプレート明細の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper のメソッド
商品属性テンプレート明細の基本モデルを複数更新します。
update(ItemTemplateBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper のメソッド
商品属性テンプレートの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper のメソッド
商品属性テンプレートの基本モデルを複数更新します。
update(PrivateGroupAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライベートグループ所属の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライベートグループ所属の基本モデルを複数更新します。
update(PrivateGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライベートグループの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライベートグループの基本モデルを複数更新します。
update(PublicGroupAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
パブリックグループ所属の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
パブリックグループ所属の基本モデルを複数更新します。
update(PublicGroupCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
パブリックグループ分類の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
パブリックグループ分類の基本モデルを複数更新します。
update(PublicGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
パブリックグループの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
パブリックグループの基本モデルを複数更新します。
update(PublicGroupInclusionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
パブリックグループ内包の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
パブリックグループ内包の基本モデルを複数更新します。
update(PublicGroupSetBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
パブリックグループセットの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
パブリックグループセットの基本モデルを複数更新します。
update(PublicGroupVersionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
パブリックグループ構成バージョンの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
パブリックグループ構成バージョンの基本モデルを複数更新します。
update(UnitBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper のメソッド
単位の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper のメソッド
単位の基本モデルを複数更新します。
update(UserBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
ユーザの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
ユーザの基本モデルを複数更新します。
update(BaseModel) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
基本モデルを1つだけ更新します。
update(Collection) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
基本モデルを複数更新します。
update(String, String, Date) - class jp.co.intra_mart.foundation.update.StandardUpdateAccessor のメソッド
キーの更新日付を更新します。
update(String, String, Date) - interface jp.co.intra_mart.foundation.update.UpdateAccessor のメソッド
キーの更新日付を更新します。
update(AccessControllerDepartmentBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper のメソッド
アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper のメソッド
アクセスコントローラの利用権限を保有する組織の基本モデルを複数更新します。
update(AccessControllerBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper のメソッド
アクセスコントローラ情報の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper のメソッド
アクセスコントローラ情報の基本モデルを複数更新します。
update(AccessControllerPostBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper のメソッド
アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper のメソッド
アクセスコントローラの利用権限を保有する役職の基本モデルを複数更新します。
update(AccessControllerPublicGroupBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper のメソッド
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper のメソッド
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを複数更新します。
update(AccessControllerRoleBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper のメソッド
アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper のメソッド
アクセスコントローラの利用権限を保有するロールの基本モデルを複数更新します。
update(AccountAttributeBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper のメソッド
アカウントが保有する属性の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper のメソッド
アカウントが保有する属性の基本モデルを複数更新します。
update(AccountBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccountMapper のメソッド
アカウントの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccountMapper のメソッド
アカウントの基本モデルを複数更新します。
update(AccountRoleBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper のメソッド
アカウントが保有するロールの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper のメソッド
アカウントが保有するロールの基本モデルを複数更新します。
update(BatchBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.BatchMapper のメソッド
バッチ情報の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.BatchMapper のメソッド
バッチ情報の基本モデルを複数更新します。
update(CalendarInfoBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper のメソッド
カレンダーが保有するデータの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper のメソッド
カレンダーが保有するデータの基本モデルを複数更新します。
update(FavoriteMenuBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper のメソッド
アカウントが保有するメニューの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper のメソッド
アカウントが保有するメニューの基本モデルを複数更新します。
update(MenuArgumentBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper のメソッド
メニューの保有する引数の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper のメソッド
メニューの保有する引数の基本モデルを複数更新します。
update(MenuDepartmentBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper のメソッド
メニューの利用権限を保有する組織の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper のメソッド
メニューの利用権限を保有する組織の基本モデルを複数更新します。
update(MenuBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuMapper のメソッド
メニュー情報の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuMapper のメソッド
メニュー情報の基本モデルを複数更新します。
update(MenuPostBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper のメソッド
メニューの利用権限を保有する役職の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper のメソッド
メニューの利用権限を保有する役職の基本モデルを複数更新します。
update(MenuPublicGroupBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper のメソッド
メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper のメソッド
メニューの利用権限を保有するパブリックグループの基本モデルを複数更新します。
update(MenuRoleBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper のメソッド
メニューの利用権限を保有するロールの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper のメソッド
メニューの利用権限を保有するロールの基本モデルを複数更新します。
update(RoleInclusionBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper のメソッド
ロール内包の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper のメソッド
ロール内包の基本モデルを複数更新します。
update(RoleBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.RoleMapper のメソッド
ロールの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.RoleMapper のメソッド
ロールの基本モデルを複数更新します。
update(RoleSummaryBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper のメソッド
ロールサマリの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper のメソッド
ロールサマリの基本モデルを複数更新します。
updateAccount(String, Account) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウント情報を更新する。
updateAccount(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント情報を更新する。
updateAccount(Account) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントを更新します。
updateAccountRole(String, String, AccountRole) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウントロール情報を更新する。
updateAccountRole(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントロール情報を更新する。
updateAccountRole(String, AccountRole) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントロールを更新します。
updateBatch(String, Batch) - class jp.co.intra_mart.foundation.security.StandardBatchAccessor のメソッド
バッチを更新します。
updateBatch(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
バッチ情報を更新します。
updateBatch(Batch) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチ情報を更新します。
updateCalendarInfo(String, String, CalendarInfo) - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor のメソッド
カレンダーデータを更新します。
updateCalendarInfo(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
カレンダーデータを更新します。
updateCalendarInfo(String, CalendarInfo) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータを更新します。
updateCategory(ItemCategory) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のメソッド
商品カテゴリを更新します。
updateCategory(String, String, String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
カテゴリを更新します。
updateCategory(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
カテゴリを更新する。
updateCategoryDetail(CategoryDetail) - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のメソッド
登録済の分類区分詳細を更新します。
updateController(String, AccessController) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラを更新します。
updateController(String, AccessController) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラを更新します。
updateController(AccessController) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
アクセスコントローラを更新します。
updateDeal(Deal) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
取扱情報を更新します。
updateDepartment(Department) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の組織情報を更新します。
updateEventFlow(EventNavigatorManager, EventFlow) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
イベントフローの更新 イベントフロー情報をDB更新する。
updateEventFlow(EventFlow) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
イベントフローの更新 イベントフロー情報をDB更新する。
updateEventFlow(EventNavigatorManager, EventFlow) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
updateEventResultItemInfo(EventNavigatorManager, String, SaveEventResultItemInfo) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
updateEventResultItemInfo(String, SaveEventResultItemInfo) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
updateEventResultItemInfo(EventNavigatorManager, String, SaveEventResultItemInfo) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
updateEventResultItemInfoTitle(EventNavigatorManager, String, SaveEventResultItemInfo) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
updateEventResultItemInfoTitle(String, SaveEventResultItemInfo) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
updateEventResultItemInfoTitle(EventNavigatorManager, String, SaveEventResultItemInfo) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
updateFavoriteMenu(String, String, FavoriteMenu) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
マイメニュー情報を更新する。
updateFavoriteMenu(String, String, FavoriteMenu) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
マイメニュー情報を更新する。
updateFavoriteMenu(String, FavoriteMenu) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
マイメニューを更新します。
updateGroupImageIcon(ImageIconInfo) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
グループのイメージアイコン情報を更新します。
updateItem(Item) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
商品情報を更新します。
updateLastResponseTime(String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。
updateLastResponseTime(String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。
updateLastResponseTime(String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。
updateLoginGroup(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
ログイングループを更新します。
updateLoginGroup(LoginGroup) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループ情報を更新します。
updateMainPagePattern(String, MainPagePatternInfo) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
メインページパターンを更新します。
updateMainPagePattern(String, MainPagePatternInfo) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンを更新します。
updateMenuItem(String, MenuItem) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
引数で渡されたノードを更新します。
updateMenuItem(MenuItem) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
引数で渡されたノードを更新します。
updateMenuItem(MenuItem) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニューを更新します。
updateMenuItem(String, MenuItem) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
引数で渡されたノードを更新します。
updateMenuItem(MenuItem) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューを更新します。
updatePost(CompanyPost) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の役職情報を更新します。
updatePrivateGroup(PrivateGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
登録済のプライベートグループ情報を更新します。
updatePublicGroup(PublicGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループ情報を更新します。
updateRole(String, Role) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
ロール情報を更新します。
updateRole(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
ロール情報を更新する。
updateRole(Role) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール情報を更新します。
updateSuperUser(SuperUser) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
システム管理者情報を更新します。
updateSuperUser(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor のメソッド
システム管理者情報を更新します。
updateSuperUser(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor のメソッド
グループ管理者情報を更新します。
updateSuperUser(String, SuperUser) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
グループ管理者情報を更新します。
updateTemplate(ItemTemplate) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager のメソッド
商品属性テンプレート情報を更新します。
updateToProcessing(String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたアクティブなセッション情報を処理中に更新します。
updateToProcessing(String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたアクティブなセッション情報を処理中に更新します。
updateToProcessing(String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたアクティブなセッション情報を処理中に更新します。
updateUnit(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager のメソッド
単位を更新します。
updateUser(User) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager のメソッド
登録済のユーザを更新します。
updateUserImageIcon(ImageIconInfo, String) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
ユーザのイメージアイコン情報を更新します。
updateVersion(CompanyVersion) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の会社構成バージョンを更新します。
updateVersion(PublicGroupVersion) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループセット構成バージョンを更新します。
usableConnection() - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager のメソッド
現在待機中のコネクションをです。
usableConnection() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
現在待機中のコネクションをです。
usableConnection() - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionManager のメソッド
推奨されていません。 現在待機中のコネクションをです。
usableConnection() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 現在待機中のコネクションをです。
useCommonsFileupload() - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle の static メソッド
アップロードされたファイルをメモリ上で扱う実装と一時ファイルに書き出す実装のどちらを利用ように設定したかを取得します。
useConnection() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 コネクションを生成します。
userAdded(String, User) - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener のメソッド
ユーザ情報がデータストアに登録された後に呼び出されます。
userDeleted(String, User) - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener のメソッド
ユーザ情報がデータストアから削除された後に呼び出されます。
userUpdated(String, User) - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener のメソッド
ユーザ情報がデータストアに対して更新された後に呼び出されます。

V

VALID_END_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
有効終了日
VALID_END_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel の static 変数
有効終了日
VALID_END_YEAR - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
有効終了年
VALID_FLG - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
有効フラグ
VALID_START_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
有効開始日
VALID_START_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel の static 変数
有効開始日
VALID_START_YEAR - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
有効開始年
VERSION_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
バージョンコード
VERSION_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
バージョンコード
VERSION_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
バージョンコード
VERSION_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
バージョンコード
ValidationException - exception jp.co.intra_mart.framework.base.service.validator.ValidationException.
検証結果が不正であるときの例外です。
ValidationException() - class jp.co.intra_mart.framework.base.service.validator.ValidationException のコンストラクタ
詳細メッセージを指定しないで ValidationException を構築します。
ValidationException(String) - class jp.co.intra_mart.framework.base.service.validator.ValidationException のコンストラクタ
指定された詳細メッセージを持つ ValidationException を構築します。
ValidationException(String, Throwable) - class jp.co.intra_mart.framework.base.service.validator.ValidationException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestFormatException を構築します。
ValidationExceptionDetail - class jp.co.intra_mart.framework.base.service.validator.ValidationExceptionDetail.
検証結果の詳細情報です。
ValidationExceptionDetail() - class jp.co.intra_mart.framework.base.service.validator.ValidationExceptionDetail のコンストラクタ
メッセージなしのValidatorExceptionDetailを生成します。
ValidationExceptionDetail(String) - class jp.co.intra_mart.framework.base.service.validator.ValidationExceptionDetail のコンストラクタ
メッセージ付きのValidatorExceptionDetailを生成します。
Validator - interface jp.co.intra_mart.framework.base.service.validator.Validator.
リクエスト内容の検証をします。
ValidatorConfig - interface jp.co.intra_mart.framework.base.service.validator.ValidatorConfig.
Validatorの初期化情報です。
ValidatorConfigImpl - class jp.co.intra_mart.framework.base.service.validator.ValidatorConfigImpl.
ValidatorConfigの実装です。
ValidatorConfigImpl() - class jp.co.intra_mart.framework.base.service.validator.ValidatorConfigImpl のコンストラクタ

ValidatorException - exception jp.co.intra_mart.framework.base.service.validator.ValidatorException.
Validatorに関連する例外です。
ValidatorException() - class jp.co.intra_mart.framework.base.service.validator.ValidatorException のコンストラクタ
詳細メッセージを指定しないで ValidatorException を構築します。
ValidatorException(String) - class jp.co.intra_mart.framework.base.service.validator.ValidatorException のコンストラクタ
指定された詳細メッセージを持つ ValidatorException を構築します。
ValidatorException(String, Throwable) - class jp.co.intra_mart.framework.base.service.validator.ValidatorException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ValidatorException を構築します。
ValidatorMapping - class jp.co.intra_mart.framework.base.service.ValidatorMapping.
バリデータの設定を保持します。
ValidatorMapping() - class jp.co.intra_mart.framework.base.service.ValidatorMapping のコンストラクタ
ValidatorMappingを新規に生成します。
ValidatorModel - class jp.co.intra_mart.framework.base.service.ValidatorModel.
バリデータ情報を管理するクラスです。
ValidatorModel() - class jp.co.intra_mart.framework.base.service.ValidatorModel のコンストラクタ

ValuationData - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData.
評価データ情報クラス
機能は以下の通り
評価データ情報を保持します。
ValuationData() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のコンストラクタ
評価データ情報を作成します。
ValuationDataList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList.
評価データ情報クラス
機能は以下の通り
評価データ情報をテーブル型で保持します。
ValuationDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList のコンストラクタ
評価データ情報を作成します。
ValuationDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList のコンストラクタ
評価データ情報を作成します。
VariableScope - interface jp.co.intra_mart.foundation.scenario.VariableScope.
スクリプトのスコープを表すオブジェクトです。
VendorAddress - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress.
仕入先住所情報クラス
機能は以下の通り
仕入先住所を保持します。
VendorAddress() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のコンストラクタ
入出庫予定を作成します。
VendorRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa.
仕入先の範囲情報クラス
機能は以下の通り
仕入先の範囲情報を保持します。
VendorRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のコンストラクタ
仕入先の範囲情報を作成します。
VendorRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のコンストラクタ
仕入先の範囲情報を作成します。
Versions - class jp.co.intra_mart.foundation.sap.module.purchase.Versions.
バージョン管理情報クラス
機能は以下の通り
バージョン管理情報を保持します。
Versions() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のコンストラクタ
バージョン管理を作成します。
validate(CalendarManager, CategorizedCalendarInfo, CalendarInfo, Date) - interface jp.co.intra_mart.foundation.security.calendar.CalendarPlugin のメソッド
カレンダーデータが有効かどうか検証します。
validate(CalendarManager, CategorizedCalendarInfo, CalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox のメソッド
カレンダーデータが有効かどうか検証します。
validate(CalendarManager, CategorizedCalendarInfo, CalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth のメソッド
カレンダーデータが有効かどうか検証します。
validate(CalendarManager, CategorizedCalendarInfo, CalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth のメソッド
カレンダーデータが有効かどうか検証します。
validate(CalendarManager, CategorizedCalendarInfo, CalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday のメソッド
カレンダーデータが有効かどうか検証します。
validate(CalendarManager, CategorizedCalendarInfo, CalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox のメソッド
カレンダーデータが有効かどうか検証します。
validate(RequestInfo) - class jp.co.intra_mart.framework.base.service.validator.FormatValidator のメソッド
文字列の不正文字（フォーマット）を検証します。
validate(RequestInfo) - class jp.co.intra_mart.framework.base.service.validator.LengthValidator のメソッド
文字列の長さを検証します。
validate(RequestInfo) - class jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator のメソッド
数値の範囲を検証します。
validate(RequestInfo) - class jp.co.intra_mart.framework.base.service.validator.NumericValidator のメソッド
数値の検証をします。
validate(RequestInfo) - interface jp.co.intra_mart.framework.base.service.validator.Validator のメソッド
リクエスト内容の検証をします。
validateTerm(Date, Date) - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager の static メソッド
指定された2つの日時が有効な期間を構成するかどうか調べます。
validateTerms(Term[]) - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager の static メソッド
指定された期間配列が有効かどうかを調べます。
validation(String) - interface jp.co.intra_mart.foundation.security.servlet.LogoutInitialUrlValidator のメソッド
ログアウト後に遷移しようとするURLを検証します。
valueBound(HttpSessionBindingEvent) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionBindingListener のメソッド
このオブジェクトがセッションに結びつけられた時に呼び出されます。
valueUnbound(HttpSessionBindingEvent) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionBindingListener のメソッド
このオブジェクトがセッションから取り外された時に呼び出されます。
values() - class jp.co.intra_mart.foundation.database.DbTypes の static メソッド

verifyPasswordHistory(String, String, int) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
ユーザのパスワードを消去。
verifyPasswordHistory(String, int) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
ユーザのパスワード履歴を消去。
verifyPasswordHistory(String, String, int) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
ユーザのパスワードを消去。
verifyShortCut(String, Date) - interface jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor のメソッド
ショートカットIDを検証します。
verifyShortCut(Date) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutManager のメソッド
ショートカット検証。
verifyShortCut(String, Date) - class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor のメソッド
ショートカットIDを検証します。
versionAdded(String, CompanyVersion) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
会社構成バージョンがデータストアに登録された後に呼び出されます。
versionAdded(String, PublicGroupVersion) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
versionAdded(String, CompanyVersion) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
会社構成バージョンがデータストアに登録された後に呼び出されます。
versionAdded(String, PublicGroupVersion) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
versionAdded(String, CompanyVersion) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
会社構成バージョンがデータストアに登録された後に呼び出されます。
versionAdded(String, PublicGroupVersion) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
versionCopied(String, String, String, String, Term) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
versionCopied(String, String, String, String, Term) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
versionCopied(String, String, String, String, Term) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
versionCopied(String, String, String, String, Term) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
versionCopied(String, String, String, String, Term) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
versionCopied(String, String, String, String, Term) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
versionDeleted(String, CompanyVersion) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
会社構成バージョンがデータストアから削除された後に呼び出されます。
versionDeleted(String, PublicGroupVersion) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
versionDeleted(String, CompanyVersion) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
会社構成バージョンがデータストアから削除された後に呼び出されます。
versionDeleted(String, PublicGroupVersion) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
versionDeleted(String, CompanyVersion) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
会社構成バージョンがデータストアから削除された後に呼び出されます。
versionDeleted(String, PublicGroupVersion) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
versionUpdated(String, CompanyVersion) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
会社構成バージョンがデータストアに更新された後に呼び出されます。
versionUpdated(String, PublicGroupVersion) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
versionUpdated(String, CompanyVersion) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
会社構成バージョンがデータストアに更新された後に呼び出されます。
versionUpdated(String, PublicGroupVersion) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
versionUpdated(String, CompanyVersion) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
会社構成バージョンがデータストアに更新された後に呼び出されます。
versionUpdated(String, PublicGroupVersion) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。

W

WEEK - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
週
WRITE_TIMEOUT - class jp.co.intra_mart.foundation.database.exception.DatabaseExportException の static 変数
推奨されていません。
WarehouseNumberData - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData.
倉庫番号データ情報クラス
機能は以下の通り
倉庫番号データ情報を保持します。
WarehouseNumberData() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のコンストラクタ
倉庫番号データ情報を作成します。
WarehouseNumberDataList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList.
倉庫番号データ情報クラス
機能は以下の通り
倉庫番号データ情報をテーブル型で保持します。
WarehouseNumberDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList のコンストラクタ
倉庫番号データ情報を作成します。
WarehouseNumberDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList のコンストラクタ
倉庫番号データ情報を作成します。
WebApplicationHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler.
フレームワークを実行するためのイベントハンドラの抽象実装です。
WebApplicationHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のコンストラクタ
Web-Application をイベント実行するためのハンドラを作成します。
Wmdvex - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex.
出力テーブル (日付および ATP 数量)情報クラス
機能は以下の通り
出力テーブル (日付および ATP 数量)情報を保持します。
Wmdvex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のコンストラクタ
出力テーブル (日付および ATP 数量)情報を作成します。
Wmdvex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のコンストラクタ
出力テーブル (日付および ATP 数量)情報を作成します。
Wmdvsx - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx.
入力テーブル (日付/数量)情報クラス
機能は以下の通り
入力テーブル (日付/数量)情報を保持します。
Wmdvsx() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のコンストラクタ
入力テーブル (日付/数量)情報を作成します。
Wmdvsx(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のコンストラクタ
入力テーブル (日付/数量)情報を作成します。
write(File) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
指定されたFileにアップロードされたファイルを書き出します。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream のメソッド
バイトをデコードして出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream のメソッド
バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream のメソッド
バイトをエンコード出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream のメソッド
バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
指定されたバイトを書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
オフセット off から始まる指定のバイト配列から この出力ストリームに len バイトを書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream のメソッド
バイトをエンコード出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream のメソッド
バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
指定のバイトを 設定されている各出力先へ書き出します。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
指定のバイトを 設定されている各出力先へ書き出します。
write(byte[]) - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
指定のバイトを 設定されている各出力先へ書き出します。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のメソッド
単一文字を書き込みます。
write(char[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のメソッド
文字列の一部を基礎ストリームに書き込みます。
write(String, int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter のメソッド
文字列の一部を書き込みます。
write(char[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter のメソッド
文字の配列の一部を書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter のメソッド
指定された文字が Java 空白文字でない場合に 単一文字を文字出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream のメソッド
バイトをデコードして出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream のメソッド
バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream のメソッド
バイトをデコードして出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream のメソッド
バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream のメソッド
指定のバイトを出力します。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream のメソッド
指定された byte 配列の、オフセット位置 off から始まる len バイトを出力ストリームに書き込みます。
write(byte[]) - class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream のメソッド
b.length バイトのデータを出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream のメソッド
バイトをエンコード出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream のメソッド
バイト列をエンコード出力ストリームに書き込みます。
write(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
write(String, String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
write(byte[]) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
write(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
指定のメッセージを標準エラー出力および指定の出力先に書き出します。
write(String, Throwable) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
指定のメッセージを標準エラー出力および指定の出力先に書き出します。
write(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の static メソッド
指定のメッセージを標準出力および指定の出力先に書き出します。
write(char[], int, int) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のメソッド
文字の配列の一部を書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のメソッド
単一の文字を書き込みます。
write(String, int, int) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のメソッド
文字列の一部を書き込みます。
write(char[], int, int) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
基礎ストリームに文字を出力します。
write(byte) - class jp.co.intra_mart.foundation.http.FileSender のメソッド
バイトの出力。
write(byte[]) - class jp.co.intra_mart.foundation.http.FileSender のメソッド
バイトの出力。
write(byte[], int, int) - class jp.co.intra_mart.foundation.http.FileSender のメソッド
バイトの出力。
write(String) - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ファイルにテキストを出力します。
write(String, Throwable) - interface jp.co.intra_mart.foundation.service.provider.SystemErrorReporter のメソッド
メッセージをログに書き込みます。
write(String) - interface jp.co.intra_mart.foundation.service.provider.SystemReporter のメソッド
メッセージをログに書き込みます。
write(char[], int, int) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のメソッド
推奨されていません。 文字の配列の一部を書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のメソッド
推奨されていません。 単一の文字を書き込みます。
write(String, int, int) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のメソッド
推奨されていません。 文字列の一部を書き込みます。
write(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
write(String, String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
write(byte[]) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream のメソッド
推奨されていません。 バイトをデコードして出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream のメソッド
推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream のメソッド
推奨されていません。 バイトをエンコード出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream のメソッド
推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 指定されたバイトを書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 オフセット off から始まる指定のバイト配列から この出力ストリームに len バイトを書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.HexOutputStream のメソッド
推奨されていません。 バイトをエンコード出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.HexOutputStream のメソッド
推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のメソッド
推奨されていません。 単一文字を書き込みます。
write(char[], int, int) - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のメソッド
推奨されていません。 文字列の一部を基礎ストリームに書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream のメソッド
推奨されていません。 バイトをデコードして出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream のメソッド
推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream のメソッド
推奨されていません。 バイトをデコードして出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream のメソッド
推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.XOROutputStream のメソッド
推奨されていません。 バイトをエンコード出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.XOROutputStream のメソッド
推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
write(char[], int, int) - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 基礎ストリームに文字を出力します。
writeBoolean(boolean) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
boolean 型データの送信。
writeBoolean(boolean) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 boolean 型データの送信。
writeInt(int) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
int 型データの送信。
writeInt(int) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 int 型データの送信。
writeLong(long) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
long 型データの送信。
writeLong(long) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 long 型データの送信。
writeObject(Object) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
オブジェクトの送信。
writeObject(Object) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 オブジェクトの送信。
writeString(String) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
文字列の送信。
writeString(String) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 文字列の送信。
writeXML(Document, OutputStream) - class jp.co.intra_mart.extension.maskat.util.XMLUtil の static メソッド
ドキュメントをストリームに出力します。

X

XMLProperties - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties.
XML をベースとした不変のプロパティセットを表します。
XMLProperties(File) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties のコンストラクタ
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputStream) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties のコンストラクタ
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputSource) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties のコンストラクタ
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputStream, Properties) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties のコンストラクタ
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputSource, Properties) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties のコンストラクタ
指定データを持つ新しいプロパティセットを作成します。
XMLUtil - class jp.co.intra_mart.extension.maskat.util.XMLUtil.
XMLのユーティリティクラスです。
XMLUtil() - class jp.co.intra_mart.extension.maskat.util.XMLUtil のコンストラクタ

XORInputStream - class jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream.
このクラスは、指定されたバイトとの排他論理和計算された結果の データを読み込むためのストリームフィルタを実装します。
XORInputStream(InputStream, int) - class jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream のコンストラクタ
指定された InputStream から指定されたバイトとの排他論理和を 取りながら読み込む XORInputStream を作成します。
XORInputStream - class jp.co.intra_mart.foundation.utility.io.XORInputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream クラスを使用してください。
XORInputStream(InputStream, int) - class jp.co.intra_mart.foundation.utility.io.XORInputStream のコンストラクタ
推奨されていません。 指定された InputStream から指定されたバイトとの排他論理和を 取りながら読み込む XORInputStream を作成します。
XOROutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream.
このクラスは、指定のバイトデータとの排他論理和を計算した結果の バイトデータを書き込むためのストリームフィルタを実装します。
XOROutputStream(OutputStream, int) - class jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream のコンストラクタ
指定された OutputStream に対して b との排他論理和を取ったバイトデータを書き込む XOROutputStream を作成します。
XOROutputStream - class jp.co.intra_mart.foundation.utility.io.XOROutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream クラスを使用してください。
XOROutputStream(OutputStream, int) - class jp.co.intra_mart.foundation.utility.io.XOROutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に対して b との排他論理和を取ったバイトデータを書き込む XOROutputStream を作成します。
XmlDataPropertyHandler - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler.
XMLのデータプロパティハンドラです。
XmlDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のコンストラクタ
コンストラクタです。
XmlEventPropertyHandler - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler.
XMLのEventPropertyHandlerです。
XmlEventPropertyHandler() - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のコンストラクタ
DefaultEventPropertyHandlerを新規に生成します。
XmlLogPropertyHandler - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler.
リソースからログプロパティ情報を取得するプロパティハンドラです。
XmlLogPropertyHandler() - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler のコンストラクタ
XMLLogPropertyHandlerを新規に生成します。
XmlPropertyManager - class jp.co.intra_mart.framework.system.property.XmlPropertyManager.
xmlのプロパティマネージャです。
XmlPropertyManager() - class jp.co.intra_mart.framework.system.property.XmlPropertyManager のコンストラクタ
コンストラクタです。
XmlServicePropertyHandler - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.
サービスの設定情報に接続するプロパティハンドラです。
XmlServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のコンストラクタ
XmlServicePropertyHandlerを新規に生成します。
XmlSessionPropertyHandler - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler.
セッションに関連するXMLのプロパティハンドラです。
XmlSessionPropertyHandler() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のコンストラクタ

Y

YEAR - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
年

Z

ZIP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
郵便番号
ZIP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
郵便番号
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

概要

パッケージ

クラス

使用

階層ツリー

非推奨 API

索引

ヘルプ

intra-mart 6.1.14

前 次

フレームあり フレームなし


javadoc_entire 6.1.14 API

フレーム関連の警告

このドキュメントはフレーム機能を使って表示するように作られています。フレームを表示できない Web クライアントの場合にこのメッセージが表示されます。
リンク先フレームなしのバージョン


概要 (javadoc_entire 6.1.14 API)

すべてのクラス

パッケージ
jp.co.intra_mart.common.aid.javaee.http
jp.co.intra_mart.common.aid.javaee.http.fileupload
jp.co.intra_mart.common.aid.jdk.java.io
jp.co.intra_mart.common.aid.jdk.java.io.file
jp.co.intra_mart.common.aid.jdk.java.lang
jp.co.intra_mart.common.aid.jdk.java.net
jp.co.intra_mart.common.aid.jdk.java.util
jp.co.intra_mart.common.aid.jdk.javax.xml
jp.co.intra_mart.common.aid.jdk.org.w3c.dom
jp.co.intra_mart.common.aid.jdk.util
jp.co.intra_mart.common.aid.jdk.util.charset
jp.co.intra_mart.common.aid.jdk.util.report
jp.co.intra_mart.common.aid.jsdk.javax.servlet
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
jp.co.intra_mart.common.aid.jsdk.utility
jp.co.intra_mart.common.platform.util
jp.co.intra_mart.common.platform.vm
jp.co.intra_mart.extension.maskat.exception
jp.co.intra_mart.extension.maskat.service
jp.co.intra_mart.extension.maskat.service.controller
jp.co.intra_mart.extension.maskat.util
jp.co.intra_mart.foundation.acssecurity
jp.co.intra_mart.foundation.commons
jp.co.intra_mart.foundation.commons.validation
jp.co.intra_mart.foundation.database
jp.co.intra_mart.foundation.database.exception
jp.co.intra_mart.foundation.datastore.application.domain.category
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class
jp.co.intra_mart.foundation.datastore.application.domain.category.detail
jp.co.intra_mart.foundation.datastore.application.domain.company
jp.co.intra_mart.foundation.datastore.application.domain.company.attach
jp.co.intra_mart.foundation.datastore.application.domain.company.category
jp.co.intra_mart.foundation.datastore.application.domain.company.company
jp.co.intra_mart.foundation.datastore.application.domain.company.department
jp.co.intra_mart.foundation.datastore.application.domain.company.main
jp.co.intra_mart.foundation.datastore.application.domain.company.post
jp.co.intra_mart.foundation.datastore.application.domain.company.version
jp.co.intra_mart.foundation.datastore.application.domain.currency
jp.co.intra_mart.foundation.datastore.application.domain.deal
jp.co.intra_mart.foundation.datastore.application.domain.deal.deal
jp.co.intra_mart.foundation.datastore.application.domain.deal.department
jp.co.intra_mart.foundation.datastore.application.domain.deal.detail
jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group
jp.co.intra_mart.foundation.datastore.application.domain.deal.role
jp.co.intra_mart.foundation.datastore.application.domain.item
jp.co.intra_mart.foundation.datastore.application.domain.item_category
jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach
jp.co.intra_mart.foundation.datastore.application.domain.item_category.category
jp.co.intra_mart.foundation.datastore.application.domain.item_category.type
jp.co.intra_mart.foundation.datastore.application.domain.item_template
jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail
jp.co.intra_mart.foundation.datastore.application.domain.item_template.template
jp.co.intra_mart.foundation.datastore.application.domain.item.attribute
jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue
jp.co.intra_mart.foundation.datastore.application.domain.item.item
jp.co.intra_mart.foundation.datastore.application.domain.private_group
jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach
jp.co.intra_mart.foundation.datastore.application.domain.private_group.group
jp.co.intra_mart.foundation.datastore.application.domain.public_group
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set
jp.co.intra_mart.foundation.datastore.application.domain.public_group.version
jp.co.intra_mart.foundation.datastore.application.domain.unit
jp.co.intra_mart.foundation.datastore.application.domain.user
jp.co.intra_mart.foundation.datastore.application.model.category.category_class
jp.co.intra_mart.foundation.datastore.application.model.category.detail
jp.co.intra_mart.foundation.datastore.application.model.company.attach
jp.co.intra_mart.foundation.datastore.application.model.company.category
jp.co.intra_mart.foundation.datastore.application.model.company.company
jp.co.intra_mart.foundation.datastore.application.model.company.department
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion
jp.co.intra_mart.foundation.datastore.application.model.company.main
jp.co.intra_mart.foundation.datastore.application.model.company.post
jp.co.intra_mart.foundation.datastore.application.model.company.version
jp.co.intra_mart.foundation.datastore.application.model.deal.deal
jp.co.intra_mart.foundation.datastore.application.model.deal.department
jp.co.intra_mart.foundation.datastore.application.model.deal.detail
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group
jp.co.intra_mart.foundation.datastore.application.model.deal.role
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach
jp.co.intra_mart.foundation.datastore.application.model.item_category.category
jp.co.intra_mart.foundation.datastore.application.model.item_category.type
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail
jp.co.intra_mart.foundation.datastore.application.model.item_template.template
jp.co.intra_mart.foundation.datastore.application.model.item.attribute
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue
jp.co.intra_mart.foundation.datastore.application.model.item.item
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach
jp.co.intra_mart.foundation.datastore.application.model.private_group.group
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach
jp.co.intra_mart.foundation.datastore.application.model.public_group.category
jp.co.intra_mart.foundation.datastore.application.model.public_group.group
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion
jp.co.intra_mart.foundation.datastore.application.model.public_group.set
jp.co.intra_mart.foundation.datastore.application.model.public_group.version
jp.co.intra_mart.foundation.datastore.application.model.unit
jp.co.intra_mart.foundation.datastore.application.model.user
jp.co.intra_mart.foundation.datastore.common.accessor
jp.co.intra_mart.foundation.datastore.common.config
jp.co.intra_mart.foundation.datastore.common.model
jp.co.intra_mart.foundation.datastore.common.structure
jp.co.intra_mart.foundation.datastore.exception
jp.co.intra_mart.foundation.datastore.exporter
jp.co.intra_mart.foundation.datastore.exporter.common.config
jp.co.intra_mart.foundation.datastore.exporter.company
jp.co.intra_mart.foundation.datastore.exporter.public_group
jp.co.intra_mart.foundation.datastore.exporter.user
jp.co.intra_mart.foundation.datastore.importer
jp.co.intra_mart.foundation.datastore.importer.common.config
jp.co.intra_mart.foundation.datastore.importer.company
jp.co.intra_mart.foundation.datastore.importer.public_group
jp.co.intra_mart.foundation.datastore.importer.user
jp.co.intra_mart.foundation.drawer
jp.co.intra_mart.foundation.exception
jp.co.intra_mart.foundation.graph
jp.co.intra_mart.foundation.http
jp.co.intra_mart.foundation.http.ajax
jp.co.intra_mart.foundation.im_curl
jp.co.intra_mart.foundation.image
jp.co.intra_mart.foundation.log
jp.co.intra_mart.foundation.mail
jp.co.intra_mart.foundation.mail.javamail
jp.co.intra_mart.foundation.mail.javamail.listener
jp.co.intra_mart.foundation.mail.javamail.listener.impl
jp.co.intra_mart.foundation.mail.javamail.model
jp.co.intra_mart.foundation.mail.javamail.property
jp.co.intra_mart.foundation.navigator
jp.co.intra_mart.foundation.page
jp.co.intra_mart.foundation.portal.common.encode
jp.co.intra_mart.foundation.portal.common.rss
jp.co.intra_mart.foundation.portal.general_purpose_portlet
jp.co.intra_mart.foundation.portal.general_purpose_portlet.model
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider
jp.co.intra_mart.foundation.portal.portlet
jp.co.intra_mart.foundation.portal.portlet.model
jp.co.intra_mart.foundation.sap.common.auth
jp.co.intra_mart.foundation.sap.common.auth.exception
jp.co.intra_mart.foundation.sap.common.exception
jp.co.intra_mart.foundation.sap.common.general_purpose
jp.co.intra_mart.foundation.sap.common.general_purpose.exception
jp.co.intra_mart.foundation.sap.common.model
jp.co.intra_mart.foundation.sap.common.util
jp.co.intra_mart.foundation.sap.common.util.data
jp.co.intra_mart.foundation.sap.common.util.date
jp.co.intra_mart.foundation.sap.common.util.file
jp.co.intra_mart.foundation.sap.common.util.message
jp.co.intra_mart.foundation.sap.module
jp.co.intra_mart.foundation.sap.module.accounting
jp.co.intra_mart.foundation.sap.module.accounting.exception
jp.co.intra_mart.foundation.sap.module.exception
jp.co.intra_mart.foundation.sap.module.financial
jp.co.intra_mart.foundation.sap.module.financial.exception
jp.co.intra_mart.foundation.sap.module.purchase
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.exception
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber
jp.co.intra_mart.foundation.sap.module.sales
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist
jp.co.intra_mart.foundation.sap.module.sales.common.model
jp.co.intra_mart.foundation.sap.module.sales.exception
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus
jp.co.intra_mart.foundation.scenario
jp.co.intra_mart.foundation.security
jp.co.intra_mart.foundation.security.access
jp.co.intra_mart.foundation.security.account
jp.co.intra_mart.foundation.security.activesession
jp.co.intra_mart.foundation.security.admin
jp.co.intra_mart.foundation.security.batch
jp.co.intra_mart.foundation.security.calendar
jp.co.intra_mart.foundation.security.certification
jp.co.intra_mart.foundation.security.certification.ldap.extension
jp.co.intra_mart.foundation.security.cryption
jp.co.intra_mart.foundation.security.duplication
jp.co.intra_mart.foundation.security.exception
jp.co.intra_mart.foundation.security.filter
jp.co.intra_mart.foundation.security.group
jp.co.intra_mart.foundation.security.license
jp.co.intra_mart.foundation.security.menu
jp.co.intra_mart.foundation.security.message
jp.co.intra_mart.foundation.security.mobile
jp.co.intra_mart.foundation.security.password
jp.co.intra_mart.foundation.security.permission
jp.co.intra_mart.foundation.security.role
jp.co.intra_mart.foundation.security.servlet
jp.co.intra_mart.foundation.security.shortcut
jp.co.intra_mart.foundation.service.client
jp.co.intra_mart.foundation.service.client.application
jp.co.intra_mart.foundation.service.client.application.content
jp.co.intra_mart.foundation.service.client.batch
jp.co.intra_mart.foundation.service.client.file
jp.co.intra_mart.foundation.service.client.information
jp.co.intra_mart.foundation.service.client.manager
jp.co.intra_mart.foundation.service.provider
jp.co.intra_mart.foundation.service.provider.application
jp.co.intra_mart.foundation.service.provider.batch
jp.co.intra_mart.foundation.service.provider.file
jp.co.intra_mart.foundation.service.provider.information
jp.co.intra_mart.foundation.smtp
jp.co.intra_mart.foundation.update
jp.co.intra_mart.foundation.utility
jp.co.intra_mart.foundation.utility.charset
jp.co.intra_mart.foundation.utility.file
jp.co.intra_mart.foundation.utility.io
jp.co.intra_mart.foundation.utility.net
jp.co.intra_mart.foundation.utility.report
jp.co.intra_mart.framework.base.data
jp.co.intra_mart.framework.base.data.container
jp.co.intra_mart.framework.base.data.container.factory
jp.co.intra_mart.framework.base.event
jp.co.intra_mart.framework.base.event.container
jp.co.intra_mart.framework.base.event.container.factory
jp.co.intra_mart.framework.base.message
jp.co.intra_mart.framework.base.service
jp.co.intra_mart.framework.base.service.container
jp.co.intra_mart.framework.base.service.container.factory
jp.co.intra_mart.framework.base.service.controller
jp.co.intra_mart.framework.base.service.validator
jp.co.intra_mart.framework.base.session
jp.co.intra_mart.framework.base.util
jp.co.intra_mart.framework.base.web.bean
jp.co.intra_mart.framework.base.web.tag
jp.co.intra_mart.framework.base.web.tag.attribute
jp.co.intra_mart.framework.base.web.util
jp.co.intra_mart.framework.extension.common.util
jp.co.intra_mart.framework.extension.seasar.data
jp.co.intra_mart.framework.extension.seasar.event
jp.co.intra_mart.framework.extension.seasar.jta
jp.co.intra_mart.framework.extension.seasar.service
jp.co.intra_mart.framework.extension.seasar.util
jp.co.intra_mart.framework.extension.struts.action
jp.co.intra_mart.framework.system.container
jp.co.intra_mart.framework.system.container.factory
jp.co.intra_mart.framework.system.exception
jp.co.intra_mart.framework.system.log
jp.co.intra_mart.framework.system.message
jp.co.intra_mart.framework.system.property
jp.co.intra_mart.framework.system.util
jp.co.intra_mart.jssp.net
jp.co.intra_mart.system.security.datastore.inf


概要 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

intra-mart 6.1.14 JavaEE-Base Programing Model API Specifications (Entire)

パッケージ
jp.co.intra_mart.common.aid.javaee.http | このパッケージには、ファイルをアップロードする際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.javaee.http.fileupload | このパッケージには、アップロードされたファイルを扱うクラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.io | このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.io.file | このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.lang | このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.net | ソケットによるネットワーク対応機能を実装するためのクラスを提供します。
jp.co.intra_mart.common.aid.jdk.java.util | このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.javax.xml | このパッケージには、ＸＭＬを利用するためのクラスが含まれています。
jp.co.intra_mart.common.aid.jdk.org.w3c.dom | このパッケージには、ＤＯＭを利用するためのクラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util | このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util.charset | このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util.report | このパッケージには、ログ機能を実装するための汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet | このパッケージには、サーブレットを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception | このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter | このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http | このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session | このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.utility | このパッケージには、ＨＴＭＬの表示変換に 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.platform.util | このパッケージには、プラットフォームを利用する際に 便利なユーティリティクラスが含まれています。
jp.co.intra_mart.common.platform.vm | このパッケージには、コマンド実引数を解釈するための共通クラスが含まれています。
jp.co.intra_mart.extension.maskat.exception |
jp.co.intra_mart.extension.maskat.service |
jp.co.intra_mart.extension.maskat.service.controller |
jp.co.intra_mart.extension.maskat.util |
jp.co.intra_mart.foundation.acssecurity | アクセスセキュリティモジュールを利用するためのクラスを提供します。
jp.co.intra_mart.foundation.commons |
jp.co.intra_mart.foundation.commons.validation | このパッケージは、入力チェック関数ライブラリを提供します。
jp.co.intra_mart.foundation.database | データベースへアクセスするためのクラスを提供します。
jp.co.intra_mart.foundation.database.exception | データベースＳＱＬ例外クラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category | 分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class | 分類区分情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category.detail | 分類詳細情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.attach | 組織所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.category | 会社分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.department | 組織情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.main | 主所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.post | 役職情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.version | バーション情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.currency | 通貨情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.department | 取扱組織権限情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.detail | 取扱詳細情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group | 取扱パブリックグループ権限情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.role | 取扱ロール権限情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item | 商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category | 商品カテゴリ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach | 商品分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category.category | 商品カテゴリ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category.type | 商品カテゴリ種別情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_template | 商品テンプレート属性情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail | 商品テンプレート属性詳細情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_template.template | 商品テンプレート属性情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item.attribute | 商品属性情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue | 商品カタログ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item.item | 商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group | プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach | プライベートグループ所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group.group | プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach | パブリックグループ所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category | パブリックグループ分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set | パブリックグループセット情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.version | パブリックグループバージョン情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.unit | 商品単位情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category | 会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company | 会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion | 組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version | 会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.deal | 取扱情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.department | 取扱組織権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.detail | 取扱詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group | 取扱パブリックグループ権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.role | 取扱ロール権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach | 商品分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.category | 商品カテゴリ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.type | 商品カテゴリ種別情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail | 商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.template | 商品テンプレート情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.attribute | 商品属性情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue | 商品カタログ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.item | 商品情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach | プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group | プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach | パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category | パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion | パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set | パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version | パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.unit | 単位情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.config | アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.foundation.datastore.common.structure | 期間情報などを扱うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter | アプリケーション共通マスタのエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.common.config | エクスポート設定の解釈を行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.company | 会社・組織関連の情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.public_group | パブリックグループ情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.user | ユーザ関連の情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer | アプリケーション共通マスタのインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.common.config | インポート定義情報の解釈を行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.company | 会社・組織関連の情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.public_group | パブリックグループ情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.user | ユーザ関連の情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.drawer | 画像ファイル出力用クラスを提供します。
jp.co.intra_mart.foundation.exception | システムでスローされる例外クラスを提供します。
jp.co.intra_mart.foundation.graph | グラフ描画に関するクラスを提供します。
jp.co.intra_mart.foundation.http | ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.http.ajax |
jp.co.intra_mart.foundation.im_curl | intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
jp.co.intra_mart.foundation.image |
jp.co.intra_mart.foundation.log |
jp.co.intra_mart.foundation.mail | メール送信に関するクラスを提供します。
jp.co.intra_mart.foundation.mail.javamail | メール送信クラスを提供します。
jp.co.intra_mart.foundation.mail.javamail.listener |
jp.co.intra_mart.foundation.mail.javamail.listener.impl |
jp.co.intra_mart.foundation.mail.javamail.model |
jp.co.intra_mart.foundation.mail.javamail.property |
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.page | ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.portal.common.encode |
jp.co.intra_mart.foundation.portal.common.rss |
jp.co.intra_mart.foundation.portal.general_purpose_portlet |
jp.co.intra_mart.foundation.portal.general_purpose_portlet.model |
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider |
jp.co.intra_mart.foundation.portal.portlet |
jp.co.intra_mart.foundation.portal.portlet.model |
jp.co.intra_mart.foundation.sap.common.auth | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.auth.exception | ＳＡＰ連携に関する例外クラスを提供します。
jp.co.intra_mart.foundation.sap.common.exception |
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose.exception | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.model |
jp.co.intra_mart.foundation.sap.common.util |
jp.co.intra_mart.foundation.sap.common.util.data | ＳＡＰ連携にて使用するデータ変換クラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.date | ＳＡＰ連携にて使用する日付操作クラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.file | ＳＡＰ連携にて使用するプロパティを操作するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.message |
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting.exception | ＳＡＰ連携財務会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.exception |
jp.co.intra_mart.foundation.sap.module.financial | ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial.exception | ＳＡＰ連携管理会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.common.model |
jp.co.intra_mart.foundation.sap.module.purchase.exception | ＳＡＰ連携経費購買系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems |
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability |
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall |
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica |
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist |
jp.co.intra_mart.foundation.sap.module.sales.common.model |
jp.co.intra_mart.foundation.sap.module.sales.exception |
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus |
jp.co.intra_mart.foundation.scenario | スクリプト開発モデルのプログラムと連携するＡＰＩ。
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession |
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification.ldap.extension | ユーザログインLDAP認証クラス(複数OU対応版)の設定方法。
jp.co.intra_mart.foundation.security.cryption | 暗号化に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.duplication |
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.filter | アクセスセキュリティのフィルタに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.license | ライセンスに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.message | メッセージに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.mobile |
jp.co.intra_mart.foundation.security.password |
jp.co.intra_mart.foundation.security.permission | 権限に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.servlet | サーブレットに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.shortcut |
jp.co.intra_mart.foundation.service.client | このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.batch | Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file | Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.manager | このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.service.provider.application | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。
jp.co.intra_mart.foundation.service.provider.batch | このパッケージには、スケジュール実行されるバッチプログラム機能を利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.provider.file | このパッケージには、Storage Service 環境内で利用可能な機能を提供します。
jp.co.intra_mart.foundation.service.provider.information | このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。
jp.co.intra_mart.foundation.smtp | メール連携モジュール。
jp.co.intra_mart.foundation.update |
jp.co.intra_mart.foundation.utility | このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.charset | このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.file | このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.io | このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.net | ソケットによるネットワーク対応機能を実装するためのクラスを提供します。
jp.co.intra_mart.foundation.utility.report | このパッケージには、ログ機能を実装するための汎用クラスが含まれています。
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.data.container |
jp.co.intra_mart.framework.base.data.container.factory |
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event.container |
jp.co.intra_mart.framework.base.event.container.factory |
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.container |
jp.co.intra_mart.framework.base.service.container.factory |
jp.co.intra_mart.framework.base.service.controller |
jp.co.intra_mart.framework.base.service.validator |
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.tag | J2EEフレームワークで使用する各種のタグのパッケージです。
jp.co.intra_mart.framework.base.web.tag.attribute | タグ属性のパッケージです。
jp.co.intra_mart.framework.base.web.util | Web上で使用するユーティリティのパッケージです。
jp.co.intra_mart.framework.extension.common.util | im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.seasar.data |
jp.co.intra_mart.framework.extension.seasar.event |
jp.co.intra_mart.framework.extension.seasar.jta |
jp.co.intra_mart.framework.extension.seasar.service |
jp.co.intra_mart.framework.extension.seasar.util |
jp.co.intra_mart.framework.extension.struts.action | im-J2EE FrameworkとStrutsを連携するためのユーティリティです。
jp.co.intra_mart.framework.system.container |
jp.co.intra_mart.framework.system.container.factory |
jp.co.intra_mart.framework.system.exception | J2EEフレームワークの例外に関連するパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.message | メッセージに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。
jp.co.intra_mart.framework.system.util |
jp.co.intra_mart.jssp.net |
jp.co.intra_mart.system.security.datastore.inf |

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.common.aid.javaee.http, jp.co.intra_mart.common.aid.javaee.http.fileupload, jp.co.intra_mart.common.aid.jdk.java.io, jp.co.intra_mart.common.aid.jdk.java.io.file, jp.co.intra_mart.common.aid.jdk.java.lang, jp.co.intra_mart.common.aid.jdk.java.net, jp.co.intra_mart.common.aid.jdk.java.util, jp.co.intra_mart.common.aid.jdk.javax.xml, jp.co.intra_mart.common.aid.jdk.org.w3c.dom, jp.co.intra_mart.common.aid.jdk.util, jp.co.intra_mart.common.aid.jdk.util.charset, jp.co.intra_mart.common.aid.jdk.util.report, jp.co.intra_mart.common.aid.jsdk.javax.servlet, jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception, jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter, jp.co.intra_mart.common.aid.jsdk.javax.servlet.http, jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session, jp.co.intra_mart.common.aid.jsdk.utility, jp.co.intra_mart.common.platform.util, jp.co.intra_mart.common.platform.vm, jp.co.intra_mart.extension.maskat.exception, jp.co.intra_mart.extension.maskat.service, jp.co.intra_mart.extension.maskat.service.controller, jp.co.intra_mart.extension.maskat.util, jp.co.intra_mart.foundation.acssecurity, jp.co.intra_mart.foundation.commons, jp.co.intra_mart.foundation.commons.validation, jp.co.intra_mart.foundation.database, jp.co.intra_mart.foundation.database.exception, jp.co.intra_mart.foundation.datastore.application.domain.category, jp.co.intra_mart.foundation.datastore.application.domain.category.category_class, jp.co.intra_mart.foundation.datastore.application.domain.category.detail, jp.co.intra_mart.foundation.datastore.application.domain.company, jp.co.intra_mart.foundation.datastore.application.domain.company.attach, jp.co.intra_mart.foundation.datastore.application.domain.company.category, jp.co.intra_mart.foundation.datastore.application.domain.company.company, jp.co.intra_mart.foundation.datastore.application.domain.company.department, jp.co.intra_mart.foundation.datastore.application.domain.company.main, jp.co.intra_mart.foundation.datastore.application.domain.company.post, jp.co.intra_mart.foundation.datastore.application.domain.company.version, jp.co.intra_mart.foundation.datastore.application.domain.currency, jp.co.intra_mart.foundation.datastore.application.domain.deal, jp.co.intra_mart.foundation.datastore.application.domain.deal.deal, jp.co.intra_mart.foundation.datastore.application.domain.deal.department, jp.co.intra_mart.foundation.datastore.application.domain.deal.detail, jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group, jp.co.intra_mart.foundation.datastore.application.domain.deal.role, jp.co.intra_mart.foundation.datastore.application.domain.item, jp.co.intra_mart.foundation.datastore.application.domain.item_category, jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach, jp.co.intra_mart.foundation.datastore.application.domain.item_category.category, jp.co.intra_mart.foundation.datastore.application.domain.item_category.type, jp.co.intra_mart.foundation.datastore.application.domain.item_template, jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail, jp.co.intra_mart.foundation.datastore.application.domain.item_template.template, jp.co.intra_mart.foundation.datastore.application.domain.item.attribute, jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue, jp.co.intra_mart.foundation.datastore.application.domain.item.item, jp.co.intra_mart.foundation.datastore.application.domain.private_group, jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach, jp.co.intra_mart.foundation.datastore.application.domain.private_group.group, jp.co.intra_mart.foundation.datastore.application.domain.public_group, jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach, jp.co.intra_mart.foundation.datastore.application.domain.public_group.category, jp.co.intra_mart.foundation.datastore.application.domain.public_group.group, jp.co.intra_mart.foundation.datastore.application.domain.public_group.set, jp.co.intra_mart.foundation.datastore.application.domain.public_group.version, jp.co.intra_mart.foundation.datastore.application.domain.unit, jp.co.intra_mart.foundation.datastore.application.domain.user, jp.co.intra_mart.foundation.datastore.application.model.category.category_class, jp.co.intra_mart.foundation.datastore.application.model.category.detail, jp.co.intra_mart.foundation.datastore.application.model.company.attach, jp.co.intra_mart.foundation.datastore.application.model.company.category, jp.co.intra_mart.foundation.datastore.application.model.company.company, jp.co.intra_mart.foundation.datastore.application.model.company.department, jp.co.intra_mart.foundation.datastore.application.model.company.inclusion, jp.co.intra_mart.foundation.datastore.application.model.company.main, jp.co.intra_mart.foundation.datastore.application.model.company.post, jp.co.intra_mart.foundation.datastore.application.model.company.version, jp.co.intra_mart.foundation.datastore.application.model.deal.deal, jp.co.intra_mart.foundation.datastore.application.model.deal.department, jp.co.intra_mart.foundation.datastore.application.model.deal.detail, jp.co.intra_mart.foundation.datastore.application.model.deal.public_group, jp.co.intra_mart.foundation.datastore.application.model.deal.role, jp.co.intra_mart.foundation.datastore.application.model.item_category.attach, jp.co.intra_mart.foundation.datastore.application.model.item_category.category, jp.co.intra_mart.foundation.datastore.application.model.item_category.type, jp.co.intra_mart.foundation.datastore.application.model.item_template.detail, jp.co.intra_mart.foundation.datastore.application.model.item_template.template, jp.co.intra_mart.foundation.datastore.application.model.item.attribute, jp.co.intra_mart.foundation.datastore.application.model.item.catalogue, jp.co.intra_mart.foundation.datastore.application.model.item.item, jp.co.intra_mart.foundation.datastore.application.model.private_group.attach, jp.co.intra_mart.foundation.datastore.application.model.private_group.group, jp.co.intra_mart.foundation.datastore.application.model.public_group.attach, jp.co.intra_mart.foundation.datastore.application.model.public_group.category, jp.co.intra_mart.foundation.datastore.application.model.public_group.group, jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion, jp.co.intra_mart.foundation.datastore.application.model.public_group.set, jp.co.intra_mart.foundation.datastore.application.model.public_group.version, jp.co.intra_mart.foundation.datastore.application.model.unit, jp.co.intra_mart.foundation.datastore.application.model.user, jp.co.intra_mart.foundation.datastore.common.accessor, jp.co.intra_mart.foundation.datastore.common.config, jp.co.intra_mart.foundation.datastore.common.model, jp.co.intra_mart.foundation.datastore.common.structure, jp.co.intra_mart.foundation.datastore.exception, jp.co.intra_mart.foundation.datastore.exporter, jp.co.intra_mart.foundation.datastore.exporter.common.config, jp.co.intra_mart.foundation.datastore.exporter.company, jp.co.intra_mart.foundation.datastore.exporter.public_group, jp.co.intra_mart.foundation.datastore.exporter.user, jp.co.intra_mart.foundation.datastore.importer, jp.co.intra_mart.foundation.datastore.importer.common.config, jp.co.intra_mart.foundation.datastore.importer.company, jp.co.intra_mart.foundation.datastore.importer.public_group, jp.co.intra_mart.foundation.datastore.importer.user, jp.co.intra_mart.foundation.drawer, jp.co.intra_mart.foundation.exception, jp.co.intra_mart.foundation.graph, jp.co.intra_mart.foundation.http, jp.co.intra_mart.foundation.http.ajax, jp.co.intra_mart.foundation.im_curl, jp.co.intra_mart.foundation.image, jp.co.intra_mart.foundation.log, jp.co.intra_mart.foundation.mail, jp.co.intra_mart.foundation.mail.javamail, jp.co.intra_mart.foundation.mail.javamail.listener, jp.co.intra_mart.foundation.mail.javamail.listener.impl, jp.co.intra_mart.foundation.mail.javamail.model, jp.co.intra_mart.foundation.mail.javamail.property, jp.co.intra_mart.foundation.navigator, jp.co.intra_mart.foundation.page, jp.co.intra_mart.foundation.portal.common.encode, jp.co.intra_mart.foundation.portal.common.rss, jp.co.intra_mart.foundation.portal.general_purpose_portlet, jp.co.intra_mart.foundation.portal.general_purpose_portlet.model, jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider, jp.co.intra_mart.foundation.portal.portlet, jp.co.intra_mart.foundation.portal.portlet.model, jp.co.intra_mart.foundation.sap.common.auth, jp.co.intra_mart.foundation.sap.common.auth.exception, jp.co.intra_mart.foundation.sap.common.exception, jp.co.intra_mart.foundation.sap.common.general_purpose, jp.co.intra_mart.foundation.sap.common.general_purpose.exception, jp.co.intra_mart.foundation.sap.common.model, jp.co.intra_mart.foundation.sap.common.util, jp.co.intra_mart.foundation.sap.common.util.data, jp.co.intra_mart.foundation.sap.common.util.date, jp.co.intra_mart.foundation.sap.common.util.file, jp.co.intra_mart.foundation.sap.common.util.message, jp.co.intra_mart.foundation.sap.module, jp.co.intra_mart.foundation.sap.module.accounting, jp.co.intra_mart.foundation.sap.module.accounting.exception, jp.co.intra_mart.foundation.sap.module.exception, jp.co.intra_mart.foundation.sap.module.financial, jp.co.intra_mart.foundation.sap.module.financial.exception, jp.co.intra_mart.foundation.sap.module.purchase, jp.co.intra_mart.foundation.sap.module.purchase.common.model, jp.co.intra_mart.foundation.sap.module.purchase.exception, jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate, jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems, jp.co.intra_mart.foundation.sap.module.purchase.materialavailability, jp.co.intra_mart.foundation.sap.module.purchase.materialgetall, jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica, jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber, jp.co.intra_mart.foundation.sap.module.sales, jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple, jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail, jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist, jp.co.intra_mart.foundation.sap.module.sales.common.model, jp.co.intra_mart.foundation.sap.module.sales.exception, jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2, jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2, jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2, jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist, jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus, jp.co.intra_mart.foundation.scenario, jp.co.intra_mart.foundation.security, jp.co.intra_mart.foundation.security.access, jp.co.intra_mart.foundation.security.account, jp.co.intra_mart.foundation.security.activesession, jp.co.intra_mart.foundation.security.admin, jp.co.intra_mart.foundation.security.batch, jp.co.intra_mart.foundation.security.calendar, jp.co.intra_mart.foundation.security.certification, jp.co.intra_mart.foundation.security.certification.ldap.extension, jp.co.intra_mart.foundation.security.cryption, jp.co.intra_mart.foundation.security.duplication, jp.co.intra_mart.foundation.security.exception, jp.co.intra_mart.foundation.security.filter, jp.co.intra_mart.foundation.security.group, jp.co.intra_mart.foundation.security.license, jp.co.intra_mart.foundation.security.menu, jp.co.intra_mart.foundation.security.message, jp.co.intra_mart.foundation.security.mobile, jp.co.intra_mart.foundation.security.password, jp.co.intra_mart.foundation.security.permission, jp.co.intra_mart.foundation.security.role, jp.co.intra_mart.foundation.security.servlet, jp.co.intra_mart.foundation.security.shortcut, jp.co.intra_mart.foundation.service.client, jp.co.intra_mart.foundation.service.client.application, jp.co.intra_mart.foundation.service.client.application.content, jp.co.intra_mart.foundation.service.client.batch, jp.co.intra_mart.foundation.service.client.file, jp.co.intra_mart.foundation.service.client.information, jp.co.intra_mart.foundation.service.client.manager, jp.co.intra_mart.foundation.service.provider, jp.co.intra_mart.foundation.service.provider.application, jp.co.intra_mart.foundation.service.provider.batch, jp.co.intra_mart.foundation.service.provider.file, jp.co.intra_mart.foundation.service.provider.information, jp.co.intra_mart.foundation.smtp, jp.co.intra_mart.foundation.update, jp.co.intra_mart.foundation.utility, jp.co.intra_mart.foundation.utility.charset, jp.co.intra_mart.foundation.utility.file, jp.co.intra_mart.foundation.utility.io, jp.co.intra_mart.foundation.utility.net, jp.co.intra_mart.foundation.utility.report, jp.co.intra_mart.framework.base.data, jp.co.intra_mart.framework.base.data.container, jp.co.intra_mart.framework.base.data.container.factory, jp.co.intra_mart.framework.base.event, jp.co.intra_mart.framework.base.event.container, jp.co.intra_mart.framework.base.event.container.factory, jp.co.intra_mart.framework.base.message, jp.co.intra_mart.framework.base.service, jp.co.intra_mart.framework.base.service.container, jp.co.intra_mart.framework.base.service.container.factory, jp.co.intra_mart.framework.base.service.controller, jp.co.intra_mart.framework.base.service.validator, jp.co.intra_mart.framework.base.session, jp.co.intra_mart.framework.base.util, jp.co.intra_mart.framework.base.web.bean, jp.co.intra_mart.framework.base.web.tag, jp.co.intra_mart.framework.base.web.tag.attribute, jp.co.intra_mart.framework.base.web.util, jp.co.intra_mart.framework.extension.common.util, jp.co.intra_mart.framework.extension.seasar.data, jp.co.intra_mart.framework.extension.seasar.event, jp.co.intra_mart.framework.extension.seasar.jta, jp.co.intra_mart.framework.extension.seasar.service, jp.co.intra_mart.framework.extension.seasar.util, jp.co.intra_mart.framework.extension.struts.action, jp.co.intra_mart.framework.system.container, jp.co.intra_mart.framework.system.container.factory, jp.co.intra_mart.framework.system.exception, jp.co.intra_mart.framework.system.log, jp.co.intra_mart.framework.system.message, jp.co.intra_mart.framework.system.property, jp.co.intra_mart.framework.system.util, jp.co.intra_mart.jssp.net, jp.co.intra_mart.system.security.datastore.inf

クラス階層

  • class java.lang.Object
    • class java.util.AbstractCollection (implements java.util.Collection)
      • class java.util.AbstractList (implements java.util.List)
        • class java.util.ArrayList (implements java.lang.Cloneable, java.util.List, java.util.RandomAccess, java.io.Serializable)
          • class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData
          • class jp.co.intra_mart.foundation.http.MultipartFormData
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.BankList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.drawer.AbstractDrawer (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.graph.BarGraphDrawer
      • class jp.co.intra_mart.foundation.graph.CircleGraphDrawer
      • class jp.co.intra_mart.foundation.graph.LineGraphDrawer
      • class jp.co.intra_mart.foundation.graph.PortFolioDrawer
      • class jp.co.intra_mart.foundation.graph.RadarChartDrawer
    • class jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator (implements jp.co.intra_mart.common.aid.jdk.java.util.DualComparator)
      • class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator
    • class jp.co.intra_mart.foundation.utility.AbstractDualComparator (implements jp.co.intra_mart.foundation.utility.DualComparator)
      • class jp.co.intra_mart.foundation.utility.MultiComparator
      • class jp.co.intra_mart.foundation.page.NodeTypeComparator
    • class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter (implements javax.servlet.Filter)
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter
      • class jp.co.intra_mart.foundation.security.filter.ActiveSessionFilter
      • class jp.co.intra_mart.foundation.security.filter.DuplicateLoginHandlingFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter
      • class jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter
      • class jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter
      • class jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventConfig (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventConfig)
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener)
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager)
    • class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
    • class java.util.AbstractMap (implements java.util.Map)
      • class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap
      • class jp.co.intra_mart.foundation.utility.FixedSizeMap
      • class java.util.HashMap (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.http.CGIEnvironment
    • class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter (implements jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter)
      • class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter
      • class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter
      • class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter
    • class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter (implements jp.co.intra_mart.foundation.utility.report.MessageReporter)
      • class jp.co.intra_mart.foundation.utility.report.FileReporter
      • class jp.co.intra_mart.foundation.utility.report.MultiCastReporter
      • class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter
    • class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor (implements jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor)
      • class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool (implements jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager)
    • class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor (implements jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor)
      • class jp.co.intra_mart.foundation.utility.net.SocketPool (implements jp.co.intra_mart.foundation.utility.net.SocketConnectionManager)
    • class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer (implements jp.co.intra_mart.foundation.page.TreeNodeContainer)
      • class jp.co.intra_mart.foundation.page.TreeBranch (implements jp.co.intra_mart.foundation.page.TreeNode)
      • class jp.co.intra_mart.foundation.page.TreeRoot (implements jp.co.intra_mart.foundation.page.TreeNodeProvider)
    • class jp.co.intra_mart.foundation.security.access.AccessController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.access.AccessControllerManager
    • class jp.co.intra_mart.foundation.security.permission.AccessControllerPermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.foundation.security.AccessSecurityManager
    • class jp.co.intra_mart.foundation.security.account.Account (implements jp.co.intra_mart.foundation.security.LocaleProvider, java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.acssecurity.AccountManager
    • class jp.co.intra_mart.foundation.security.account.AccountManager
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.account.AccountRole (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.acssecurity.AcsData
    • class org.apache.struts.action.Action
      • class jp.co.intra_mart.framework.extension.struts.action.IntramartAction
    • class jp.co.intra_mart.foundation.security.activesession.ActiveSessionBindingListener (implements javax.servlet.http.HttpSessionBindingListener, java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager
    • class jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.AdminMenuManager
    • class jp.co.intra_mart.foundation.security.permission.AdminMenuPermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.common.config.AttributeType (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.Bank (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BankController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.graph.BarGraphObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.batch.Batch (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.batch.BatchManager
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList (implements java.io.Serializable)
    • class jp.co.intra_mart.common.aid.jsdk.utility.BrowseString
    • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarManager
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk (implements java.io.Serializable)
    • class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder
    • class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder
    • class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager
    • class jp.co.intra_mart.foundation.graph.CircleGraphObject (implements java.io.Serializable)
    • class java.lang.ClassLoader
      • class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader
        • class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader
          • class jp.co.intra_mart.common.aid.jdk.java.lang.SearchableClassLoader
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.common.platform.vm.CommandLineArgument
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.Company (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener)
    • class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManager)
    • class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager (implements jp.co.intra_mart.foundation.datastore.importer.ImportManager)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManager)
    • class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager (implements jp.co.intra_mart.foundation.datastore.importer.ImportManager)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator
    • class jp.co.intra_mart.framework.extension.seasar.util.ComponentUtil
    • class jp.co.intra_mart.foundation.sap.module.purchase.Cond (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.system.util.Config
      • class jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfigImpl (implements jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfig)
      • class jp.co.intra_mart.framework.base.service.validator.ValidatorConfigImpl (implements jp.co.intra_mart.framework.base.service.validator.ValidatorConfig)
    • class jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory
    • class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo (implements java.io.Serializable, jp.co.intra_mart.framework.base.util.UserInfo)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.base.data.ConnectorModel
    • class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ContractService (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.base.service.ControllerConverterModel
    • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.util.data.Convertor (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.account.CsvAccountBackup (implements jp.co.intra_mart.foundation.security.account.AccountExporter, jp.co.intra_mart.foundation.security.account.AccountImporter)
    • class jp.co.intra_mart.foundation.im_curl.CurlFieldBean
    • class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer
    • class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager
    • class jp.co.intra_mart.framework.base.data.DAOAdapter (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.DaoModel
    • class jp.co.intra_mart.framework.base.data.DataAccessController
      • class jp.co.intra_mart.framework.extension.seasar.data.S2DataAccessController
    • class jp.co.intra_mart.foundation.database.DatabaseColumn
    • class jp.co.intra_mart.foundation.database.DatabaseExport
    • class jp.co.intra_mart.foundation.database.DatabaseManager
    • class jp.co.intra_mart.framework.base.data.DataConnector
      • class jp.co.intra_mart.framework.base.data.DBConnector
        • class jp.co.intra_mart.framework.base.data.DataSourceConnector
        • class jp.co.intra_mart.framework.base.data.JDBCConnector
      • class jp.co.intra_mart.framework.base.data.IntramartDBConnector
      • class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector
      • class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector
      • class jp.co.intra_mart.framework.base.data.SystemDBConnector
    • class jp.co.intra_mart.framework.base.data.container.factory.DataContainerFactory (implements jp.co.intra_mart.framework.system.container.factory.IMContainerFactory)
    • class jp.co.intra_mart.framework.base.data.container.DataContainerImpl (implements jp.co.intra_mart.framework.base.data.container.DataContainer)
    • class jp.co.intra_mart.framework.base.data.DataManager
    • class jp.co.intra_mart.foundation.sap.common.util.date.DateHandler (implements java.io.Serializable)
    • class jp.co.intra_mart.common.platform.util.DateUtil
    • class jp.co.intra_mart.framework.base.data.DBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.foundation.database.DbManager
    • class jp.co.intra_mart.foundation.database.DBResultArrayAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultBigDecimalAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultBigIntAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultBinaryAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultBlobAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultBooleanAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultByteAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultClobAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultDateAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultDoubleAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultImTimestampAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultIntegerAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultNullAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultObjectAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultRealAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultRefAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultShortAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultStringAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultStructAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultTimeAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultTimestampAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DbTypes
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class jp.co.intra_mart.framework.base.data.container.factory.DefaultDataProvider (implements jp.co.intra_mart.framework.system.container.factory.Provider)
    • class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class jp.co.intra_mart.framework.base.event.container.factory.DefaultEventProvider (implements jp.co.intra_mart.framework.system.container.factory.Provider)
    • class org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • class jp.co.intra_mart.foundation.im_curl.CurlXMLParser
    • class jp.co.intra_mart.framework.system.log.DefaultLogAgent (implements jp.co.intra_mart.framework.system.log.LogAgent)
    • class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler (implements jp.co.intra_mart.framework.system.log.LogPropertyHandler)
    • class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler (implements jp.co.intra_mart.framework.base.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler (implements jp.co.intra_mart.framework.system.message.MessagePropertyHandler)
    • class jp.co.intra_mart.extension.maskat.service.DefaultMKServiceResult (implements jp.co.intra_mart.extension.maskat.service.MKServiceResult)
    • class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class jp.co.intra_mart.framework.base.service.container.factory.DefaultServiceProvider (implements jp.co.intra_mart.framework.system.container.factory.Provider)
    • class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler (implements jp.co.intra_mart.framework.base.session.SessionPropertyHandler)
    • class jp.co.intra_mart.foundation.datastore.common.config.DeleteType (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.DepartmentInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational (implements java.io.Serializable)
    • class java.util.Dictionary
      • class java.util.Hashtable (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class java.util.Properties
          • class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties
            • class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties
              • class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties
          • class jp.co.intra_mart.foundation.service.client.information.InitialFile
          • class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties
          • class jp.co.intra_mart.foundation.utility.ResourceBundleProperties
    • class DiskFileItemFactory
      • class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItemFactory (implements jp.co.intra_mart.common.aid.javaee.http.fileupload.IMFileItemFactory)
    • class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager
    • class jp.co.intra_mart.framework.base.event.EJBEventListener (implements jp.co.intra_mart.framework.base.event.EventListener)
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListener
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal
      • class jp.co.intra_mart.framework.base.event.StandardEJBEventListener
    • class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean (implements javax.ejb.SessionBean)
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean
      • class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean
    • class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory
      • class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory
    • class jp.co.intra_mart.framework.base.service.EmptyServiceResult (implements jp.co.intra_mart.framework.base.service.ServiceResult)
    • class jp.co.intra_mart.framework.base.util.EmptyUserInfo (implements java.io.Serializable, jp.co.intra_mart.framework.base.util.UserInfo)
    • class jp.co.intra_mart.framework.base.service.EncodingFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent
    • class jp.co.intra_mart.foundation.utility.ErrorEvent
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.base.event.Event (implements java.io.Serializable)
      • class jp.co.intra_mart.framework.base.event.EmptyEvent
    • class jp.co.intra_mart.foundation.navigator.EventAccessInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.base.event.container.factory.EventContainerFactory (implements jp.co.intra_mart.framework.system.container.factory.IMContainerFactory)
    • class jp.co.intra_mart.framework.base.event.container.EventContainerImpl (implements jp.co.intra_mart.framework.base.event.container.EventContainer)
    • class jp.co.intra_mart.framework.base.event.EventFactoryModel
    • class jp.co.intra_mart.framework.base.event.EventGroupModel
    • class jp.co.intra_mart.foundation.navigator.EventHistoryInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.base.event.EventManager
    • class jp.co.intra_mart.framework.base.event.EventModelProducer
    • class jp.co.intra_mart.foundation.navigator.EventNavigatorConst
    • class jp.co.intra_mart.foundation.navigator.EventNavigatorHandler
    • class jp.co.intra_mart.foundation.navigator.EventNavigatorManager
    • class jp.co.intra_mart.foundation.navigator.EventNavigatorPermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.common.aid.jdk.util.EventQueueController
    • class jp.co.intra_mart.foundation.utility.EventQueueController
    • class jp.co.intra_mart.foundation.page.EventScript
    • class jp.co.intra_mart.framework.base.event.EventTriggerAdapter (implements jp.co.intra_mart.framework.base.event.EventTrigger)
    • class jp.co.intra_mart.framework.base.event.EventTriggerInfo
    • class jp.co.intra_mart.framework.base.event.EventTriggerList
    • class jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.utility.report.EverydayConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExchRate (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManager)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap)
    • class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket
      • class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection
    • class jp.co.intra_mart.foundation.utility.net.ExtendedSocket
      • class jp.co.intra_mart.foundation.utility.net.SocketConnection
    • class jp.co.intra_mart.foundation.security.ExtendsImportManager
    • class jp.co.intra_mart.foundation.sap.module.purchase.Extension (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.account.FavoriteMenu (implements java.io.Serializable)
    • class java.io.File (implements java.lang.Comparable, java.io.Serializable)
      • class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory
        • class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory
          • class jp.co.intra_mart.foundation.service.provider.HomeDirectory
      • class jp.co.intra_mart.foundation.utility.file.Directory
        • class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
          • class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory
          • class jp.co.intra_mart.foundation.service.provider.file.StorageDirectory
          • class jp.co.intra_mart.foundation.service.provider.TemporaryDirectory
      • class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile
      • class jp.co.intra_mart.foundation.utility.file.ExtendedFile
        • class jp.co.intra_mart.foundation.service.provider.TemporaryFile
    • class jp.co.intra_mart.foundation.http.FileSender
    • class jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.utility.report.FileSizeConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class jp.co.intra_mart.framework.base.service.FileUploadFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.foundation.datastore.exporter.Filter (implements java.io.Serializable)
    • class jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator (implements java.util.Comparator, java.io.Serializable)
      • class jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator
    • class jp.co.intra_mart.foundation.utility.FilterComparator (implements java.util.Comparator, java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.ReverseComparator
    • class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent (implements jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent)
    • class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter (implements jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter)
      • class jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter
      • class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel)
      • class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter
    • class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter (implements jp.co.intra_mart.foundation.utility.report.MessageReporter)
      • class jp.co.intra_mart.foundation.utility.report.LineReportFilter
      • class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter (implements jp.co.intra_mart.foundation.utility.report.ReportLevel)
      • class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.base.service.validator.FormatValidator (implements jp.co.intra_mart.framework.base.service.validator.Validator)
    • class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.foundation.scenario.FunctionContainer
      • class jp.co.intra_mart.foundation.scenario.FunctionContainerFile
    • class jp.co.intra_mart.foundation.service.provider.GarbageController
    • class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress
    • class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes
      • class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes
      • class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes
      • class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel (implements jp.co.intra_mart.foundation.datastore.common.model.BaseModel)
    • class jp.co.intra_mart.framework.base.event.GenericEventListener (implements jp.co.intra_mart.framework.base.event.EventListener)
    • class jp.co.intra_mart.framework.base.event.GenericEventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.InternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap)
    • class javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • class javax.servlet.http.HttpServlet (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet
        • class jp.co.intra_mart.framework.base.service.IntramartConnectServlet
        • class jp.co.intra_mart.foundation.security.servlet.LogoutServlet
        • class jp.co.intra_mart.foundation.security.servlet.MenuServlet
        • class jp.co.intra_mart.framework.base.service.ServiceServlet
        • class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet
        • class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet
        • class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap)
    • class jp.co.intra_mart.jssp.net.GenericURLBuilder
      • class jp.co.intra_mart.jssp.net.URLBuilder
    • class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.activesession.GroupActiveSessionRegister (implements jp.co.intra_mart.foundation.security.certification.SuperCertificationListener)
    • class jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener (implements jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.base.web.bean.HelperBean (implements java.io.Serializable)
      • class jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean
    • class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.base.web.util.HTMLEncoder
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
        • class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler
        • class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler
            • class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
          • class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
            • class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper (implements jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult)
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager
    • class jp.co.intra_mart.framework.base.session.HttpSessionFactory (implements jp.co.intra_mart.framework.base.session.SessionFactory)
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener (implements javax.servlet.http.HttpSessionListener)
    • class jp.co.intra_mart.framework.base.session.HttpSessionObject (implements jp.co.intra_mart.framework.base.session.SessionObject)
    • class jp.co.intra_mart.foundation.service.client.information.Identifier
    • class jp.co.intra_mart.foundation.image.ImageIconInfo
    • class jp.co.intra_mart.foundation.image.ImageIconManager
    • class jp.co.intra_mart.foundation.image.ImageIconMessageBundle
    • class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil
    • class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem (implements org.apache.commons.fileupload.FileItem)
    • class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl (implements jp.co.intra_mart.foundation.datastore.importer.ImportManager)
    • class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement (implements java.io.Serializable)
    • class jp.co.intra_mart.system.mail.smtp.InetMail (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.smtp.Mail (implements jp.co.intra_mart.system.javascript.imapi.MailSendErrDef, java.io.Serializable)
    • class jp.co.intra_mart.foundation.commons.validation.InputCheck
    • class java.io.InputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream
      • class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream
      • class java.io.FilterInputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream
        • class jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream
        • class jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream
        • class jp.co.intra_mart.foundation.utility.io.XORInputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream
      • class jp.co.intra_mart.foundation.utility.io.HexInputStream
      • class javax.servlet.ServletInputStream
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream
    • class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.base.service.IntramartConnectFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.data.IntramartDBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper (implements jp.co.intra_mart.foundation.datastore.common.model.Mapper)
    • class jp.co.intra_mart.framework.base.data.IntramartFileServerDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.system.log.IntramartLogAgent (implements jp.co.intra_mart.framework.system.log.LogAgent)
    • class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler (implements jp.co.intra_mart.framework.system.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.base.session.IntramartSessionFactory (implements jp.co.intra_mart.framework.base.session.SessionFactory)
    • class jp.co.intra_mart.framework.base.session.IntramartSessionObject (implements jp.co.intra_mart.framework.base.session.SessionObject)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttributeInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategoryInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.type.ItemCategoryType (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetailInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplateInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminableInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager
    • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler
    • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl (implements jp.co.intra_mart.system.service.ApplicationInitializer)
    • class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender (implements jp.co.intra_mart.foundation.mail.MailSender)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoBuilder
    • class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel
    • class jp.co.intra_mart.framework.base.service.validator.LengthValidator (implements jp.co.intra_mart.framework.base.service.validator.Validator)
    • class jp.co.intra_mart.foundation.security.license.LicenseManager
    • class jp.co.intra_mart.foundation.datastore.common.config.LifetimeType
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Limits (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.graph.LineGraphObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.base.service.LocaleFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.common.aid.jdk.java.net.Localhost (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.utility.net.Localhost (implements java.io.Serializable)
    • class jp.co.intra_mart.common.aid.jdk.util.LockMonitor
    • class jp.co.intra_mart.foundation.utility.LockMonitor
    • class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager (implements javax.transaction.TransactionManager)
    • class jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction (implements javax.transaction.UserTransaction)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.acssecurity.Logingp
    • class jp.co.intra_mart.foundation.security.group.LoginGroup (implements jp.co.intra_mart.foundation.security.LocaleProvider, java.io.Serializable)
    • class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource (implements javax.sql.DataSource)
      • class jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedDataSource
    • class jp.co.intra_mart.framework.base.data.LoginGroupDBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.foundation.security.group.LoginGroupManager
    • class jp.co.intra_mart.framework.system.log.LogManager
    • class jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent
    • class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener (implements jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener)
    • class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.common.model.MapperFactory
    • class jp.co.intra_mart.foundation.sap.module.financial.MasterData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.MenuInclusion (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.MenuItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.MenuManager
    • class jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.foundation.security.menu.MenuTree (implements java.util.Comparator)
    • class jp.co.intra_mart.foundation.security.message.MessageManager
    • class jp.co.intra_mart.framework.base.message.MessageManager
    • class jp.co.intra_mart.framework.system.message.MessageManager
    • class jp.co.intra_mart.extension.maskat.util.MKConst
    • class jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter (implements jp.co.intra_mart.framework.base.service.controller.ControllerConverter)
    • class jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject (implements jp.co.intra_mart.framework.base.service.controller.ControllerObject)
    • class jp.co.intra_mart.extension.maskat.util.MKError
    • class jp.co.intra_mart.extension.maskat.util.MKErrors
      • class jp.co.intra_mart.extension.maskat.service.MKErrorsResult (implements jp.co.intra_mart.extension.maskat.service.MKServiceResult)
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuHdmlAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoMoveAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginJphoneAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginSoftBankAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginVodafoneAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa (implements java.io.Serializable)
    • class jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle
    • class org.apache.commons.fileupload.MultipartStream
      • class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMMultipartStream
    • class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions
    • class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions
    • class jp.co.intra_mart.foundation.security.activesession.NavigatorInfo
    • class jp.co.intra_mart.foundation.navigator.NavigatorItem (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.navigator.EventItem
      • class jp.co.intra_mart.foundation.navigator.EventResultItem
      • class jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem
        • class jp.co.intra_mart.foundation.navigator.EventFlow
        • class jp.co.intra_mart.foundation.navigator.ResultPageItem
        • class jp.co.intra_mart.foundation.navigator.SelectItem
    • class jp.co.intra_mart.foundation.service.client.NetworkConnector (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.service.client.NetworkAgent (implements jp.co.intra_mart.foundation.service.client.ActionListener)
        • class jp.co.intra_mart.foundation.service.client.file.AbstractComponent (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.service.client.file.NetworkFile (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureDirectory)
        • class jp.co.intra_mart.foundation.service.client.information.ExternalMemory (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureFile)
        • class jp.co.intra_mart.foundation.service.client.information.Lock (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureDirectory)
        • class jp.co.intra_mart.foundation.service.client.information.PermanentFile (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureFile)
        • class jp.co.intra_mart.foundation.service.client.batch.Scheduler (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.service.client.manager.ServerConnector (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager
    • class jp.co.intra_mart.foundation.security.cryption.NoCryption (implements jp.co.intra_mart.foundation.security.cryption.Cryption)
    • class jp.co.intra_mart.foundation.page.NodeNameComparator (implements java.util.Comparator, java.io.Serializable)
    • class jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter (implements jp.co.intra_mart.framework.base.service.controller.ControllerConverter)
    • class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin (implements jp.co.intra_mart.foundation.security.account.AccountPostWriterListener, jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener)
    • class java.lang.Number (implements java.io.Serializable)
      • class jp.co.intra_mart.common.aid.jdk.util.Counter (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.Counter (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator (implements jp.co.intra_mart.framework.base.service.validator.Validator)
    • class jp.co.intra_mart.framework.base.service.validator.NumericValidator (implements jp.co.intra_mart.framework.base.service.validator.Validator)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.OrderList (implements java.io.Serializable)
    • class jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class java.io.OutputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream
      • class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream
      • class java.io.FilterOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream
        • class jp.co.intra_mart.foundation.utility.io.XOROutputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream
      • class jp.co.intra_mart.foundation.utility.io.HexOutputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream
    • class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider (implements jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.common.util.data.ExtendedParamConverter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.commons.ParameterManager
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamVendorAddress (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Partner (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.password.PasswordHistory
    • class jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener (implements jp.co.intra_mart.foundation.security.account.AccountChangedListener)
    • class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager
    • class jp.co.intra_mart.foundation.security.password.PasswordHistoryManagerInitializerImpl (implements jp.co.intra_mart.system.service.ApplicationInitializer)
    • class jp.co.intra_mart.foundation.security.password.PasswordHistoryNewArrivedProvider (implements jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider)
    • class jp.co.intra_mart.foundation.security.password.PasswordHistoryResult
    • class jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.utility.report.PeriodicConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory (implements jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent)
    • class jp.co.intra_mart.foundation.security.permission.PermissionManager
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.service.provider.Platform
    • class jp.co.intra_mart.foundation.graph.PortFolioObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.portal.portlet.model.Portlet (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet
        • class jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet
        • class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet
      • class jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet
        • class jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet
        • class jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet
        • class jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet
    • class jp.co.intra_mart.foundation.portal.portlet.PortletManager
    • class jp.co.intra_mart.foundation.portal.portlet.PortletMapping
    • class jp.co.intra_mart.foundation.security.PostInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.scenario.PresentationPage
    • class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.system.property.PropertyConfigModel
    • class jp.co.intra_mart.foundation.sap.common.util.PropertyDescriptorBox
    • class jp.co.intra_mart.framework.system.property.PropertyManager
      • class jp.co.intra_mart.framework.system.property.DefaultPropertyManager
      • class jp.co.intra_mart.framework.system.property.XmlPropertyManager
    • class jp.co.intra_mart.framework.system.property.PropertyModel
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.base.event.EventListenerFactoryParam
      • class jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam
      • class jp.co.intra_mart.framework.system.log.LogAgentParam
      • class jp.co.intra_mart.framework.system.message.MessagePropertyParam
      • class jp.co.intra_mart.framework.system.property.PropertyHandlerParam
      • class jp.co.intra_mart.framework.base.data.ResourceParam
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener (implements jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener)
    • class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener (implements jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener)
    • class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManager)
    • class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager (implements jp.co.intra_mart.foundation.datastore.importer.ImportManager)
    • class jp.co.intra_mart.foundation.security.PublicGroupInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText
    • class jp.co.intra_mart.foundation.graph.RadarChartObject (implements java.io.Serializable)
    • class java.io.Reader
      • class java.io.FilterReader
        • class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.base.data.ResourceModel
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.role.Role (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener (implements jp.co.intra_mart.foundation.security.role.RoleChangedListener)
    • class jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener (implements jp.co.intra_mart.foundation.security.role.RoleChangedListener)
    • class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener (implements jp.co.intra_mart.foundation.security.role.RoleChangedListener)
    • class jp.co.intra_mart.foundation.acssecurity.RoleManager
    • class jp.co.intra_mart.foundation.security.role.RoleManager
    • class jp.co.intra_mart.framework.extension.seasar.data.S2DataContainer (implements jp.co.intra_mart.framework.base.data.container.DataContainer)
    • class jp.co.intra_mart.framework.extension.seasar.event.S2EventContainer (implements jp.co.intra_mart.framework.base.event.container.EventContainer)
    • class jp.co.intra_mart.framework.extension.seasar.event.S2EventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
    • class jp.co.intra_mart.framework.extension.seasar.service.S2ServiceContainer (implements jp.co.intra_mart.framework.base.service.container.ServiceContainer)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.auth.SapAuthInfoBundle
    • class jp.co.intra_mart.foundation.sap.common.auth.SapClient
      • class jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing
      • class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool
        • class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing
        • class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing
      • class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing
    • class jp.co.intra_mart.foundation.sap.common.auth.SapClientManager
    • class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolManager
    • class jp.co.intra_mart.foundation.sap.common.auth.SapConnector (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle
    • class jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager
    • class jp.co.intra_mart.foundation.navigator.SaveEventHistoryInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Selection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender (implements java.io.Serializable)
    • class jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator (implements java.util.Comparator, java.io.Serializable)
    • class jp.co.intra_mart.foundation.utility.SequenceComparator (implements java.util.Comparator, java.io.Serializable)
    • class jp.co.intra_mart.framework.base.service.container.factory.ServiceContainerFactory (implements jp.co.intra_mart.framework.system.container.factory.IMContainerFactory)
    • class jp.co.intra_mart.framework.base.service.container.ServiceContainerImpl (implements jp.co.intra_mart.framework.base.service.container.ServiceContainer)
    • class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter (implements jp.co.intra_mart.framework.base.service.ServiceController)
    • class jp.co.intra_mart.framework.base.service.ServiceManager
    • class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.extension.common.util.ServiceUtils
    • class ServletFileUpload
      • class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload
    • class javax.servlet.ServletRequestWrapper (implements javax.servlet.ServletRequest)
      • class javax.servlet.http.HttpServletRequestWrapper (implements javax.servlet.http.HttpServletRequest)
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.EmptyParameterHttpServletRequestWrapper
    • class javax.servlet.ServletResponseWrapper (implements javax.servlet.ServletResponse)
      • class javax.servlet.http.HttpServletResponseWrapper (implements javax.servlet.http.HttpServletResponse)
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse)
          • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController)
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse)
    • class jp.co.intra_mart.foundation.service.client.information.SessionFactory (implements jp.co.intra_mart.foundation.service.client.information.TreasureDirectory)
    • class jp.co.intra_mart.foundation.security.filter.SessionFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.session.SessionFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.session.SessionManager
    • class jp.co.intra_mart.foundation.service.client.information.SessionMemory (implements jp.co.intra_mart.foundation.service.client.information.TreasureFile)
    • class jp.co.intra_mart.foundation.http.SessionQuery
    • class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.shortcut.ShortCutManager
    • class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController
    • class java.beans.SimpleBeanInfo (implements java.beans.BeanInfo)
      • class jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo
    • class jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter (implements jp.co.intra_mart.framework.base.service.controller.ControllerConverter)
    • class jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory
    • class jp.co.intra_mart.foundation.commons.SourceProviderHandler
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor (implements jp.co.intra_mart.foundation.security.access.AccessControllerAccessor)
    • class jp.co.intra_mart.foundation.security.access.StandardAccessControllerBackup (implements jp.co.intra_mart.foundation.security.access.AccessControllerExporter, jp.co.intra_mart.foundation.security.access.AccessControllerImporter)
    • class jp.co.intra_mart.foundation.security.StandardAccountAccessor (implements jp.co.intra_mart.foundation.security.account.AccountAccessor)
    • class jp.co.intra_mart.foundation.security.account.StandardAccountBackup (implements jp.co.intra_mart.foundation.security.account.AccountExporter, jp.co.intra_mart.foundation.security.account.AccountImporter)
    • class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor (implements jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor)
    • class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup (implements jp.co.intra_mart.foundation.security.menu.AdminMenuExporter, jp.co.intra_mart.foundation.security.menu.AdminMenuImporter)
    • class jp.co.intra_mart.foundation.security.StandardBatchAccessor (implements jp.co.intra_mart.foundation.security.batch.BatchAccessor)
    • class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup (implements jp.co.intra_mart.foundation.security.batch.BatchExporter, jp.co.intra_mart.foundation.security.batch.BatchImporter)
    • class jp.co.intra_mart.foundation.security.StandardCalendarAccessor (implements jp.co.intra_mart.foundation.security.calendar.CalendarAccessor)
    • class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup (implements jp.co.intra_mart.foundation.security.calendar.CalendarExporter, jp.co.intra_mart.foundation.security.calendar.CalendarImporter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter)
    • class jp.co.intra_mart.foundation.security.cryption.StandardCryption (implements jp.co.intra_mart.foundation.security.cryption.Cryption)
    • class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor (implements jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor)
    • class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider (implements jp.co.intra_mart.foundation.security.certification.ErrorPageProvider)
    • class jp.co.intra_mart.framework.base.event.StandardEventListener (implements jp.co.intra_mart.framework.base.event.EventListener)
    • class jp.co.intra_mart.framework.base.event.StandardEventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
    • class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor (implements jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor)
    • class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter (implements jp.co.intra_mart.foundation.navigator.EventNavigatorExporter)
    • class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter (implements jp.co.intra_mart.foundation.navigator.EventNavigatorImporter)
    • class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider (implements jp.co.intra_mart.foundation.security.certification.UserPageProvider)
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.StandardHttpServletResponseEventControllerBuilder (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerBuilder)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemAttachImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemAttachImporter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemCategoryImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryImporter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.StandardItemImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.item.ItemImporter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_template.StandardItemTemplateImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateImporter)
    • class jp.co.intra_mart.foundation.mail.javamail.StandardMail
    • class jp.co.intra_mart.foundation.security.StandardMenuAccessor (implements jp.co.intra_mart.foundation.security.menu.MenuAccessor)
    • class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup (implements jp.co.intra_mart.foundation.security.menu.MenuExporter, jp.co.intra_mart.foundation.security.menu.MenuImporter)
    • class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor (implements jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter)
    • class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer (implements jp.co.intra_mart.foundation.security.certification.RequestAnalyzer)
      • class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer
    • class jp.co.intra_mart.foundation.security.StandardRoleAccessor (implements jp.co.intra_mart.foundation.security.role.RoleAccessor)
    • class jp.co.intra_mart.foundation.security.role.StandardRoleBackup (implements jp.co.intra_mart.foundation.security.role.RoleExporter, jp.co.intra_mart.foundation.security.role.RoleImporter)
    • class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor (implements jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor)
    • class jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification (implements jp.co.intra_mart.foundation.security.certification.SuperCertification)
    • class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider (implements jp.co.intra_mart.foundation.security.certification.UserPageProvider)
    • class jp.co.intra_mart.foundation.update.StandardUpdateAccessor (implements jp.co.intra_mart.foundation.update.UpdateAccessor)
    • class jp.co.intra_mart.foundation.security.certification.StandardUserCertification (implements jp.co.intra_mart.foundation.security.certification.UserCertification)
      • class jp.co.intra_mart.foundation.security.certification.LDAPUserCertification
      • class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPUserCertification
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter)
    • class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider (implements jp.co.intra_mart.foundation.security.certification.UserPageProvider)
      • class jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider
        • class jp.co.intra_mart.foundation.security.password.PasswordHistoryUserPageProvider
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr
    • class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController (implements java.io.Serializable)
    • class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.admin.SuperUser (implements jp.co.intra_mart.foundation.security.LocaleProvider, java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification (implements jp.co.intra_mart.foundation.security.certification.SuperCertification)
    • class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource (implements javax.sql.DataSource)
    • class jp.co.intra_mart.framework.base.data.SystemDBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.foundation.security.SystemManager
    • class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus (implements java.io.Serializable)
    • class javax.servlet.jsp.tagext.TagExtraInfo
      • class jp.co.intra_mart.framework.base.web.tag.FormTEI
      • class jp.co.intra_mart.framework.base.web.tag.FrameTEI
      • class jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI
      • class jp.co.intra_mart.framework.base.web.tag.LinkTEI
      • class jp.co.intra_mart.framework.base.web.tag.MessageTEI
      • class jp.co.intra_mart.framework.base.web.tag.SubmitTEI
    • class javax.servlet.jsp.tagext.TagSupport (implements javax.servlet.jsp.tagext.IterationTag, java.io.Serializable)
      • class javax.servlet.jsp.tagext.BodyTagSupport (implements javax.servlet.jsp.tagext.BodyTag)
        • class jp.co.intra_mart.framework.base.web.tag.FormTag
        • class jp.co.intra_mart.framework.base.web.tag.FrameTag (implements jp.co.intra_mart.framework.base.web.tag.ParameterSendable)
        • class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag
        • class jp.co.intra_mart.framework.base.web.tag.LinkTag (implements jp.co.intra_mart.framework.base.web.tag.ParameterSendable)
        • class jp.co.intra_mart.framework.base.web.tag.MessageParamTag
        • class jp.co.intra_mart.framework.base.web.tag.MessageTag
        • class jp.co.intra_mart.framework.base.web.tag.ParamTag
        • class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag
        • class jp.co.intra_mart.framework.base.web.tag.SubmitTag
    • class jp.co.intra_mart.framework.base.web.tag.TagWriter
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.common.structure.Term (implements java.lang.Comparable, java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.common.structure.TermManager
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler (implements jp.co.intra_mart.framework.base.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class java.lang.Thread (implements java.lang.Runnable)
      • class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread
      • class jp.co.intra_mart.foundation.utility.ExtendedThread
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.acssecurity.AcssecurityException
        • class jp.co.intra_mart.foundation.database.exception.DatabaseExportException
        • class jp.co.intra_mart.foundation.exception.FoundationException
          • class jp.co.intra_mart.foundation.security.exception.AccessSecurityException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException
              • class jp.co.intra_mart.foundation.security.exception.DuplicateException
              • class jp.co.intra_mart.foundation.security.exception.NotExistException
              • class jp.co.intra_mart.foundation.security.exception.NotSupportMethodException
            • class jp.co.intra_mart.foundation.security.exception.ActiveSessionException
              • class jp.co.intra_mart.foundation.security.exception.ActiveSessionInvalidatedByForceException
              • class jp.co.intra_mart.foundation.security.exception.ActiveSessionNotExistException
            • class jp.co.intra_mart.foundation.security.exception.DuplicateLoginException
              • class jp.co.intra_mart.foundation.security.exception.DuplicateLoginDetectedException
            • class jp.co.intra_mart.foundation.security.exception.IllegalArgumentException
            • class jp.co.intra_mart.foundation.security.exception.NoFilterException
            • class jp.co.intra_mart.foundation.security.exception.NoSessionCookieException
            • class jp.co.intra_mart.foundation.security.exception.NoSessionException
            • class jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException
          • class jp.co.intra_mart.foundation.exception.ChangedListenerException
          • class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
            • class jp.co.intra_mart.foundation.datastore.exception.AccessorException
              • class jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException
              • class jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException
              • class jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException
                • class jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException
                • class jp.co.intra_mart.foundation.datastore.exception.IllegalTermException
              • class jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException
            • class jp.co.intra_mart.foundation.navigator.EventNavigatorException
            • class jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException
            • class jp.co.intra_mart.foundation.datastore.exception.ManagerException
            • class jp.co.intra_mart.foundation.datastore.exception.MapperException
            • class jp.co.intra_mart.foundation.datastore.exception.TermManagerException
          • class jp.co.intra_mart.foundation.image.ImageIconException
            • class jp.co.intra_mart.foundation.image.DuplicateImageIconCodeException
            • class jp.co.intra_mart.foundation.image.DuplicateImageIconSrcException
            • class jp.co.intra_mart.foundation.image.NotExistImageIconException
          • class jp.co.intra_mart.foundation.security.password.PasswordHistoryException
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.ApplicationException
            • class jp.co.intra_mart.framework.base.service.RequestException
              • class jp.co.intra_mart.framework.base.service.validator.ValidationException
          • class jp.co.intra_mart.framework.system.property.PropertyHandlerException
          • class jp.co.intra_mart.framework.system.property.PropertyManagerException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.service.controller.ControllerConverterException
            • class jp.co.intra_mart.framework.base.data.DAOException
            • class jp.co.intra_mart.framework.base.data.DataAccessException
            • class jp.co.intra_mart.framework.base.data.DataConnectException
            • class jp.co.intra_mart.framework.base.data.DataConnectorException
            • class jp.co.intra_mart.framework.base.data.container.DataContainerException
            • class jp.co.intra_mart.framework.base.data.DataManagerException
            • class jp.co.intra_mart.framework.base.data.DataPropertyException
            • class jp.co.intra_mart.framework.base.event.container.EventContainerException
            • class jp.co.intra_mart.framework.base.event.EventException
            • class jp.co.intra_mart.framework.base.event.EventListenerException
            • class jp.co.intra_mart.framework.base.event.EventManagerException
            • class jp.co.intra_mart.framework.base.event.EventPropertyException
            • class jp.co.intra_mart.framework.base.event.EventTriggerException
            • class jp.co.intra_mart.framework.base.web.bean.HelperBeanException
            • class jp.co.intra_mart.framework.base.session.IllegalSessionException
            • class jp.co.intra_mart.framework.system.exception.IllegalSystemException
            • class jp.co.intra_mart.framework.system.exception.IMContainerException
            • class jp.co.intra_mart.framework.system.log.LogPropertyException
            • class jp.co.intra_mart.framework.base.message.MessageManagerException
            • class jp.co.intra_mart.framework.system.message.MessageManagerException
            • class jp.co.intra_mart.framework.base.message.MessagePropertyException
            • class jp.co.intra_mart.framework.system.message.MessagePropertyException
            • class jp.co.intra_mart.extension.maskat.exception.MKSystemException
            • class jp.co.intra_mart.framework.base.service.controller.RequestFormatException
            • class jp.co.intra_mart.framework.base.service.container.ServiceContainerException
            • class jp.co.intra_mart.framework.base.service.ServiceControllerException
            • class jp.co.intra_mart.framework.base.service.ServiceManagerException
            • class jp.co.intra_mart.framework.base.service.ServicePropertyException
            • class jp.co.intra_mart.framework.base.service.ServiceServletException
            • class jp.co.intra_mart.framework.base.session.SessionFactoryException
            • class jp.co.intra_mart.framework.base.session.SessionManagerException
            • class jp.co.intra_mart.framework.base.session.SessionObjectException
            • class jp.co.intra_mart.framework.base.session.SessionPropertyException
            • class jp.co.intra_mart.framework.base.service.TransitionException
            • class jp.co.intra_mart.framework.base.util.UserInfoException
            • class jp.co.intra_mart.framework.base.service.validator.ValidatorException
        • class jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException
        • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException
          • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException
        • class jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException
        • class jp.co.intra_mart.foundation.datastore.exception.ImportException
        • class java.io.IOException
          • class jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException
          • class jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException
        • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException
        • class javax.servlet.jsp.JspException
          • class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException
        • class jp.co.intra_mart.foundation.mail.MailSenderException
        • class jp.co.intra_mart.foundation.scenario.NoSuchPropertyException
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException
        • class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException
          • class jp.co.intra_mart.foundation.utility.charset.ResourceFormatException
        • class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException
          • class jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.datastore.exception.BatchProcessException
            • class jp.co.intra_mart.foundation.datastore.exporter.ExportInitializeException
              • class jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReaderException
            • class jp.co.intra_mart.foundation.datastore.importer.ImportInitializeException
              • class jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReaderException
          • class jp.co.intra_mart.foundation.datastore.exception.BatchSystemException
          • class jp.co.intra_mart.foundation.exception.FoundationRuntimeException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException
              • class jp.co.intra_mart.foundation.security.exception.SystemConfigException
            • class jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException
              • class jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException
              • class jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException
              • class jp.co.intra_mart.foundation.datastore.exception.MapperDAOException
          • class jp.co.intra_mart.framework.system.exception.FrameworkRuntimeException
          • class jp.co.intra_mart.extension.maskat.exception.MKRuntimeException
          • class jp.co.intra_mart.foundation.portal.portlet.PortletManagerException
          • class jp.co.intra_mart.foundation.sap.common.exception.SAPRuntimeException
            • class jp.co.intra_mart.foundation.sap.common.exception.UnsupportedProductEditionException
        • class jp.co.intra_mart.foundation.sap.common.exception.SAPException
          • class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException
          • class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException
          • class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException
          • class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
            • class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException
            • class jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException
            • class jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException
            • class jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
            • class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException
            • class jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialSystemException
            • class jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseSystemException
            • class jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesSystemException
        • class jp.co.intra_mart.foundation.scenario.ScriptCompileException
        • class jp.co.intra_mart.foundation.scenario.ScriptRuntimeException
        • class javax.servlet.ServletException
          • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException
                • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilterException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListenerException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidatorException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException
        • class java.sql.SQLException
          • class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException
    • class jp.co.intra_mart.foundation.navigator.TitleInfo (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.navigator.EventFlowInfo
      • class jp.co.intra_mart.foundation.navigator.EventItemInfo
      • class jp.co.intra_mart.foundation.navigator.EventResultItemInfo
      • class jp.co.intra_mart.foundation.navigator.LinkPageInfo
      • class jp.co.intra_mart.foundation.navigator.ResultPageItemInfo
      • class jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo
      • class jp.co.intra_mart.foundation.navigator.SelectItemInfo
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.base.service.Transition
      • class jp.co.intra_mart.framework.base.service.DefaultTransition
        • class jp.co.intra_mart.extension.maskat.service.MKTransition
      • class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition
    • class jp.co.intra_mart.foundation.page.TreeLeaf (implements jp.co.intra_mart.foundation.page.TreeNode)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.update.UpdateManager
    • class jp.co.intra_mart.foundation.security.filter.URLAccessFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.User (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.activesession.UserActiveSessionRegister (implements jp.co.intra_mart.foundation.security.certification.UserCertificationListener)
    • class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManager)
    • class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager (implements jp.co.intra_mart.foundation.datastore.importer.ImportManager)
    • class jp.co.intra_mart.framework.base.util.UserInfoUtil
    • class jp.co.intra_mart.framework.base.util.UserInfoWrapper (implements jp.co.intra_mart.framework.base.util.UserInfo)
      • class jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedUserInfo
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManager)
    • class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager (implements jp.co.intra_mart.foundation.datastore.importer.ImportManager)
    • class jp.co.intra_mart.foundation.sap.module.financial.UserStatus (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.base.service.validator.ValidationExceptionDetail
    • class jp.co.intra_mart.framework.base.service.ValidatorMapping
    • class jp.co.intra_mart.framework.base.service.ValidatorModel
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Versions (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx (implements java.io.Serializable)
    • class java.io.Writer
      • class java.io.FilterWriter
        • class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter
        • class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter
        • class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter
      • class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter
      • class jp.co.intra_mart.foundation.utility.io.ReplaceWriter
      • class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter
      • class jp.co.intra_mart.foundation.utility.report.ReportFileWriter
    • class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler (implements jp.co.intra_mart.framework.system.log.LogPropertyHandler)
    • class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler (implements jp.co.intra_mart.framework.base.session.SessionPropertyHandler)
    • class jp.co.intra_mart.extension.maskat.util.XMLUtil

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor
  • interface jp.co.intra_mart.foundation.security.access.AccessControllerExporter
  • interface jp.co.intra_mart.foundation.security.access.AccessControllerImporter
  • interface jp.co.intra_mart.foundation.security.access.AccessControllerPostWriterListener
  • interface jp.co.intra_mart.foundation.security.access.AccessControllerQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.access.AccessControllerReaderDecorator
  • interface jp.co.intra_mart.foundation.security.account.AccountAccessor
  • interface jp.co.intra_mart.foundation.security.account.AccountChangedListener
  • interface jp.co.intra_mart.foundation.security.account.AccountExporter
  • interface jp.co.intra_mart.foundation.security.account.AccountImporter
  • interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener
  • interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.account.AccountReaderDecorator
  • interface jp.co.intra_mart.foundation.datastore.common.config.ActivationKey
  • interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuExporter
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuImporter
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator
  • interface jp.co.intra_mart.foundation.datastore.common.config.Application
  • interface jp.co.intra_mart.foundation.security.license.ApplicationInfo
  • interface jp.co.intra_mart.foundation.mail.javamail.model.AttachmentFile
  • interface jp.co.intra_mart.foundation.datastore.common.config.Attribute
  • interface jp.co.intra_mart.foundation.datastore.common.config.BaseModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext
  • interface jp.co.intra_mart.foundation.datastore.common.config.BaseTable
  • interface jp.co.intra_mart.foundation.security.batch.BatchAccessor
  • interface jp.co.intra_mart.foundation.security.batch.BatchExporter
  • interface jp.co.intra_mart.foundation.security.batch.BatchImporter
  • interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener
  • interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarExporter
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarImporter
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarPlugin
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator
  • interface jp.co.intra_mart.foundation.security.ClientTypeInfo
  • interface jp.co.intra_mart.foundation.security.ColorPatternInfo
  • interface jp.co.intra_mart.foundation.datastore.common.config.Column
  • interface jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping
  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener
  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter
  • interface java.util.Comparator
    • interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator (同様に extends java.io.Serializable)
    • interface jp.co.intra_mart.foundation.utility.DualComparator (同様に extends java.io.Serializable)
  • interface jp.co.intra_mart.foundation.datastore.common.config.Configuration
  • interface jp.co.intra_mart.foundation.database.ConInfo
  • interface java.sql.Connection
    • interface jp.co.intra_mart.foundation.database.DbsConnection
  • interface jp.co.intra_mart.framework.base.service.controller.ControllerConverter
  • interface jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfig
  • interface jp.co.intra_mart.foundation.security.cryption.Cryption
  • interface jp.co.intra_mart.foundation.im_curl.CurlRecordBeanIF
  • interface jp.co.intra_mart.framework.base.data.DAO
  • interface jp.co.intra_mart.foundation.database.DatabaseAccessor
  • interface jp.co.intra_mart.foundation.database.DataSourceProvider
  • interface jp.co.intra_mart.foundation.security.calendar.DayInfo
  • interface jp.co.intra_mart.foundation.database.DBResultAdapter
  • interface jp.co.intra_mart.foundation.datastore.common.config.Delete
  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct
  • interface jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor
  • interface javax.ejb.EJBLocalHome
    • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocalHome
  • interface javax.ejb.EJBLocalObject
    • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocal
  • interface jp.co.intra_mart.foundation.portal.common.encode.EnCodeInterface
  • interface jp.co.intra_mart.foundation.datastore.common.config.Entity
  • interface jp.co.intra_mart.foundation.service.provider.Environment
  • interface jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener
  • interface jp.co.intra_mart.foundation.utility.ErrorEventListener
  • interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider
  • interface jp.co.intra_mart.common.aid.jdk.util.EventListener
  • interface jp.co.intra_mart.foundation.utility.EventListener
  • interface jp.co.intra_mart.framework.base.event.EventListener
  • interface jp.co.intra_mart.framework.base.event.EventListenerFactory
  • interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor
  • interface jp.co.intra_mart.foundation.navigator.EventNavigatorExporter
  • interface jp.co.intra_mart.foundation.navigator.EventNavigatorImporter
  • interface jp.co.intra_mart.foundation.navigator.EventNavigatorReaderDecorator
  • interface jp.co.intra_mart.framework.base.event.EventTrigger
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey
  • interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader
  • interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager
  • interface jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable
  • interface jp.co.intra_mart.foundation.security.ExtendsImport
  • interface org.apache.commons.fileupload.FileItemFactory
    • interface jp.co.intra_mart.common.aid.javaee.http.fileupload.IMFileItemFactory
  • interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain
  • interface jp.co.intra_mart.foundation.service.provider.GCConditioner
  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor
  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener
  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext
  • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult
    • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent
    • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventComponentBuilder
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventConfig
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerBuilder
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidator
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager
  • interface jp.co.intra_mart.framework.system.container.IMContainer
    • interface jp.co.intra_mart.framework.base.data.container.DataContainer
    • interface jp.co.intra_mart.framework.base.event.container.EventContainer
    • interface jp.co.intra_mart.framework.base.service.container.ServiceContainer
  • interface jp.co.intra_mart.framework.system.container.factory.IMContainerFactory
  • interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader
  • interface jp.co.intra_mart.foundation.datastore.importer.ImportManager
  • interface jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient
  • interface jp.co.intra_mart.foundation.security.INonTransaction
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.InternationalKey
  • interface jp.co.intra_mart.foundation.datastore.common.config.InternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext
  • interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable
  • interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemAttachImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.item.ItemCatalogueMediaManager
  • interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryStruct
  • interface jp.co.intra_mart.foundation.datastore.application.domain.item.ItemImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateImporter
  • interface jp.co.intra_mart.foundation.datastore.common.config.Lifetime
  • interface jp.co.intra_mart.foundation.security.LocaleProvider
    • interface jp.co.intra_mart.foundation.security.LocaleInfo
    • interface jp.co.intra_mart.foundation.security.certification.LoginInfo
      • interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo
    • interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo
    • interface jp.co.intra_mart.foundation.security.SessionInfo
  • interface jp.co.intra_mart.framework.system.log.LogAgent
  • interface jp.co.intra_mart.framework.system.log.LogConstant
  • interface jp.co.intra_mart.foundation.log.LogConstraint
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator
  • interface jp.co.intra_mart.foundation.security.servlet.LogoutInitialUrlValidator
  • interface jp.co.intra_mart.foundation.mail.javamail.model.MailAddress
  • interface jp.co.intra_mart.foundation.mail.MailSender
  • interface jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener
  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccountMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.BatchMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.RoleMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper
  • interface jp.co.intra_mart.foundation.security.menu.MenuAccessor
  • interface jp.co.intra_mart.foundation.security.menu.MenuExporter
  • interface jp.co.intra_mart.foundation.security.menu.MenuImporter
  • interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator
  • interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter
  • interface jp.co.intra_mart.foundation.utility.report.MessageReporter
  • interface jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider
  • interface jp.co.intra_mart.foundation.datastore.common.config.Model
  • interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity
  • interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity
  • interface jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider
  • interface jp.co.intra_mart.framework.base.web.tag.ParameterSendable
  • interface jp.co.intra_mart.foundation.commons.ParameterSourceProvider
  • interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor
  • interface jp.co.intra_mart.foundation.security.permission.PermissionSelector
  • interface jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping
  • interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener
  • interface jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent
  • interface jp.co.intra_mart.foundation.datastore.common.config.Property
  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.base.data.DataPropertyHandler
    • interface jp.co.intra_mart.framework.base.event.EventPropertyHandler
    • interface jp.co.intra_mart.framework.system.log.LogPropertyHandler
    • interface jp.co.intra_mart.framework.base.message.MessagePropertyHandler
    • interface jp.co.intra_mart.framework.system.message.MessagePropertyHandler
    • interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler
    • interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler
  • interface jp.co.intra_mart.framework.system.container.factory.Provider
  • interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener
  • interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct
  • interface jp.co.intra_mart.foundation.datastore.common.config.Relationship
  • interface java.rmi.Remote
    • interface javax.ejb.EJBHome
      • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome
      • interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome
    • interface javax.ejb.EJBObject
      • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent
      • interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent
    • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent
    • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome
    • interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent
    • interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome
  • interface jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner
  • interface jp.co.intra_mart.foundation.utility.report.ReportFileConditioner
  • interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel
  • interface jp.co.intra_mart.foundation.utility.report.ReportLevel
  • interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer
  • interface jp.co.intra_mart.framework.base.service.RequestInfo
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter
  • interface jp.co.intra_mart.foundation.security.role.RoleAccessor
  • interface jp.co.intra_mart.foundation.security.role.RoleChangedListener
  • interface jp.co.intra_mart.foundation.security.role.RoleExporter
  • interface jp.co.intra_mart.foundation.security.role.RoleImporter
  • interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener
  • interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.role.RoleReaderDecorator
  • interface jp.co.intra_mart.foundation.portal.common.rss.RSSParserIF
  • interface jp.co.intra_mart.foundation.scenario.ScriptValue
    • interface jp.co.intra_mart.foundation.scenario.VariableScope
  • interface jp.co.intra_mart.foundation.security.SecurityConstraint
  • interface java.io.Serializable
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel
    • interface jp.co.intra_mart.foundation.service.client.ActionListener
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel
    • interface jp.co.intra_mart.framework.base.service.controller.ControllerObject
    • interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel
    • interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator (同様に extends java.util.Comparator)
    • interface jp.co.intra_mart.foundation.utility.DualComparator (同様に extends java.util.Comparator)
    • interface jp.co.intra_mart.framework.base.event.EventResult
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel
    • interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel
      • interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateInternationalModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuInternationalModel
      • interface jp.co.intra_mart.system.security.datastore.inf.RoleInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuInternationalModel
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost
    • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.RoleInternationalModel
    • interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap
    • interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel
    • interface jp.co.intra_mart.framework.base.util.UserInfo
    • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel
  • interface jp.co.intra_mart.framework.base.service.ServiceController
  • interface jp.co.intra_mart.framework.base.service.ServiceResult
    • interface jp.co.intra_mart.extension.maskat.service.MKServiceResult
  • interface javax.servlet.ServletRequest
    • interface javax.servlet.http.HttpServletRequest
      • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper
    • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper
  • interface javax.servlet.ServletResponse
    • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse (同様に extends jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse, javax.servlet.http.HttpServletResponse)
      • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController
    • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse
      • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse (同様に extends javax.servlet.http.HttpServletResponse)
        • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController
      • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController
    • interface javax.servlet.http.HttpServletResponse
      • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse (同様に extends jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse)
        • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController
      • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController
    • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController
  • interface jp.co.intra_mart.foundation.security.SessionConfig
  • interface jp.co.intra_mart.framework.base.session.SessionFactory
  • interface jp.co.intra_mart.framework.base.session.SessionObject
  • interface jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor
  • interface jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownListener
  • interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor
    • interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager
  • interface jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor
    • interface jp.co.intra_mart.foundation.utility.net.SocketConnectionManager
  • interface jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener
  • interface jp.co.intra_mart.foundation.utility.net.SocketEventListener
  • interface jp.co.intra_mart.foundation.security.certification.SuperCertification
  • interface jp.co.intra_mart.foundation.security.certification.SuperCertificationListener
  • interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor
  • interface jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener
  • interface jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator
  • interface jp.co.intra_mart.foundation.service.provider.SystemReporter
    • interface jp.co.intra_mart.foundation.service.provider.SystemErrorReporter
  • interface jp.co.intra_mart.foundation.security.SystemSourceProvider
  • interface jp.co.intra_mart.foundation.datastore.common.config.Table
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableKey
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable
  • interface jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener
  • interface jp.co.intra_mart.foundation.utility.ThreadStopListener
  • interface jp.co.intra_mart.common.aid.jdk.java.lang.ThrowablePrintListener
  • interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory
  • interface jp.co.intra_mart.foundation.service.client.information.TreasureFile
  • interface jp.co.intra_mart.foundation.page.TreeNode
  • interface jp.co.intra_mart.foundation.page.TreeNodeContainer
    • interface jp.co.intra_mart.foundation.page.TreeNodeProvider
  • interface jp.co.intra_mart.foundation.update.UpdateAccessor
  • interface jp.co.intra_mart.foundation.datastore.common.config.UpdateInfo
  • interface jp.co.intra_mart.foundation.security.certification.UserCertification
  • interface jp.co.intra_mart.foundation.security.certification.UserCertificationListener
  • interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener
  • interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter
  • interface jp.co.intra_mart.foundation.security.certification.UserPageProvider
  • interface jp.co.intra_mart.framework.base.service.validator.Validator
  • interface jp.co.intra_mart.framework.base.service.validator.ValidatorConfig
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


(javadoc_entire 6.1.14 API)

フロントページが変更されました。次を参照してください:
フレームありのバージョン
フレームなしのバージョン


直列化された形式 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.common.aid.javaee.http.fileupload

クラス jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem は Object を拡張し、Serializable を実装しています

serialVersionUID: 4784522703387130736l

直列化されたフィールド

item

DiskFileItem item
Commons Fileupload のFileItemのインスタンス

headers

Map headers
ヘッダ情報

クラス jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItemFactory は DiskFileItemFactory を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload は ServletFileUpload を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.common.aid.javaee.http

クラス jp.co.intra_mart.common.aid.javaee.http.MultipartFormData は ArrayList を拡張し、Serializable を実装しています

直列化されたフィールド

instance

jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.MultipartHandler instance

パッケージ jp.co.intra_mart.common.aid.jdk.java.io.file

クラス jp.co.intra_mart.common.aid.jdk.java.io.file.Directory は File を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory は Directory を拡張し、Serializable を実装しています

直列化されたフィールド

POOL

FixedSizeMap POOL
このディレクトリを親とするファイルオブジェクトのキャッシュ領域

クラス jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile は File を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.common.aid.jdk.java.net

クラス jp.co.intra_mart.common.aid.jdk.java.net.Localhost は Object を拡張し、Serializable を実装しています

直列化されたフィールド

localhostIPAddress

byte[] localhostIPAddress

localhostAddress

String localhostAddress

localhostName

String localhostName

クラス jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException は IOException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.common.aid.jdk.java.util

クラス jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties は Properties を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator は Object を拡張し、Serializable を実装しています

直列化されたフィールド

parent

Comparator parent

クラス jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator は AbstractDualComparator を拡張し、Serializable を実装しています

直列化されたフィールド

primaryComparator

Comparator primaryComparator
第１コンパレータ

secondaryComparator

MultiComparator secondaryComparator
第２コンパレータ

クラス jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties は Properties を拡張し、Serializable を実装しています

直列化されたフィールド

currentLocale

Locale currentLocale

クラス jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator は FilterComparator を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator は Object を拡張し、Serializable を実装しています

直列化されたフィールド

map

WeakHashMap map
map

count

long count
挿入順番

パッケージ jp.co.intra_mart.common.aid.jdk.javax.xml

クラス jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties は ElementProperties を拡張し、Serializable を実装しています

直列化されたフィールド

domDocument

Document domDocument
このプロパティセットの元データとなった DOM

propertyList

Map propertyList
プロパティのリスト

パッケージ jp.co.intra_mart.common.aid.jdk.org.w3c.dom

クラス jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties は ExtendedProperties を拡張し、Serializable を実装しています

直列化されたフィールド

propertyList

Map propertyList
プロパティのリスト

element

Element element
このオブジェクトがラップするエレメントノード

パッケージ jp.co.intra_mart.common.aid.jdk.util.charset

クラス jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException は Exception を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.common.aid.jdk.util

クラス jp.co.intra_mart.common.aid.jdk.util.Counter は Number を拡張し、Serializable を実装しています

直列化されたフィールド

currentValue

long currentValue
カウンターの値

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException は UnripeQueryException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException は BadRequestException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException は ServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException は BadRequestException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException は BadRequestException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerException は HttpServletResponseEventException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilterException は HttpServletResponseEventException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListenerException は HttpServletResponseEventException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidatorException は HttpServletResponseEventException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException は Exception を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.extension.maskat.exception

クラス jp.co.intra_mart.extension.maskat.exception.MKRuntimeException は RuntimeException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.extension.maskat.exception.MKSystemException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.extension.maskat.service.controller

クラス jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject は Object を拡張し、Serializable を実装しています

直列化されたフィールド

document

Document document

layoutId

String layoutId

componentId

String componentId

eventId

String eventId

パッケージ jp.co.intra_mart.foundation.acssecurity

クラス jp.co.intra_mart.foundation.acssecurity.AcssecurityException は Exception を拡張し、Serializable を実装しています

直列化されたフィールド

message

String message

code

int code

パッケージ jp.co.intra_mart.foundation.database.exception

クラス jp.co.intra_mart.foundation.database.exception.DatabaseExportException は Exception を拡張し、Serializable を実装しています

直列化されたフィールド

errorType

int errorType
推奨されていません。

クラス jp.co.intra_mart.foundation.database.exception.DatabaseSQLException は SQLException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.category_class

クラス jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass は Object を拡張し、Serializable を実装しています

直列化されたフィールド

categoryClassCode

String categoryClassCode
分類区分コード

notes

String notes
備考

defaultLocale

Locale defaultLocale
デフォルトのロケール

internationals

Map internationals
分類区分の国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
分類区分名

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.detail

クラス jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail は Object を拡張し、Serializable を実装しています

直列化されたフィールド

categoryClassCode

String categoryClassCode
分類区分コード

categoryCode

String categoryCode
分類コード

notes

String notes
備考

defaultLocale

Locale defaultLocale
デフォルトのロケール

internationals

Map internationals
分類区分詳細の国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
分類名

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.attach

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach は Object を拡張し、Serializable を実装しています

直列化されたフィールド

userCode

String userCode
ユーザコード

companyCode

String companyCode
会社コード

departmentCode

String departmentCode
組織コード

sortKey

int sortKey
ソートキー

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
組織所属の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

postCode

String postCode
役職CD

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.category

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

departmentCode

String departmentCode
組織コード

categoryClassCode

String categoryClassCode
分類区分コード

categoryCode

String categoryCode
分類コード

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
会社組織分類の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.company

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

notes

String notes
備考

sortKey

int sortKey
ソートキー

defaultLocale

Locale defaultLocale
デフォルトのロケール

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
会社の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

telephoneNumber

String telephoneNumber
電話番号

faxNumber

String faxNumber
FAX番号

extensionNumber

String extensionNumber
内線番号

extensionFaxNumber

String extensionFaxNumber
内線FAX番号

countryCode

String countryCode
国コード

zipCode

String zipCode
郵便番号

emailAddress1

String emailAddress1
メールアドレス1

emailAddress2

String emailAddress2
メールアドレス2

url

String url
URL

terminableInternationals

Map terminableInternationals
会社の期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
組織名

nameSyllabary

String nameSyllabary
組織名カナ

nameEnglish

String nameEnglish
組織名英字

address1

String address1
住所1

address2

String address2
住所2

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.department

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

departmentCode

String departmentCode
組織コード

notes

String notes
備考

sortKey

int sortKey
ソートキー

defaultLocale

Locale defaultLocale
デフォルトのロケール

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
組織の期間化に関連する情報のマップ

extendedDtos

Map extendedDtos
組織の基本情報に対する拡張情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

telephoneNumber

String telephoneNumber
電話番号

faxNumber

String faxNumber
FAX番号

extensionNumber

String extensionNumber
内線番号

extensionFaxNumber

String extensionFaxNumber
内線FAX番号

countryCode

String countryCode
国コード

zipCode

String zipCode
郵便番号

emailAddress1

String emailAddress1
メールアドレス1

emailAddress2

String emailAddress2
メールアドレス2

url

String url
URL

extendedDtos

Map extendedDtos
組織の期間化情報に対する拡張情報のマップ

terminableInternationals

Map terminableInternationals
組織の期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
組織名

nameSyllabary

String nameSyllabary
組織名カナ

nameEnglish

String nameEnglish
組織名英字

address1

String address1
住所1

address2

String address2
住所2

extendedDtos

Map extendedDtos
組織の期間国際化情報に対する拡張情報のマップ

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.main

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain は Object を拡張し、Serializable を実装しています

直列化されたフィールド

userCode

String userCode
ユーザコード

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
主所属の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

departmentCode

String departmentCode
組織コード

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.post

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

postCode

String postCode
役職コード

notes

String notes
備考

sortKey

int sortKey
ソートキー

defaultLocale

Locale defaultLocale
デフォルトのロケール

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
役職の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

terminableInternationals

Map terminableInternationals
役職の期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
役職名

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.version

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

versionCode

String versionCode
バージョンコード

startDate

Date startDate
開始日

endDate

Date endDate
終了日

notes

String notes
備考

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.deal

クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal は Object を拡張し、Serializable を実装しています

直列化されたフィールド

customerCompanyCode

String customerCompanyCode
取引先会社コード

customerDepartmentCode

String customerDepartmentCode
取引先組織コード

dealCode

String dealCode
取扱コード

dealName

String dealName
取扱名

dealType

int dealType
取扱種別

currencyCode

String currencyCode
通貨コード

notes

String notes
備考

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
取扱の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

unitPrice

double unitPrice
単価

detailMap

Map detailMap
詳細の集合

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.department

クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment は Object を拡張し、Serializable を実装しています

直列化されたフィールド

customerCompanyCode

String customerCompanyCode
取引先会社コード

customerDepartmentCode

String customerDepartmentCode
取引先組織コード

dealCode

String dealCode
取扱コード

companyCode

String companyCode
会社コード

departmentCode

String departmentCode
組織コード

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.detail

クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itemCode

String itemCode
商品コード

unitCode

String unitCode
単位コード

amount

int amount
数量

unitPrice

double unitPrice
単価

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group

クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup は Object を拡張し、Serializable を実装しています

直列化されたフィールド

customerCompanyCode

String customerCompanyCode
取引先会社コード

customerDepartmentCode

String customerDepartmentCode
取引先組織コード

dealCode

String dealCode
取扱コード

publicGroupSetCode

String publicGroupSetCode
グループセットコード

publicGroupCode

String publicGroupCode
グループコード

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.role

クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole は Object を拡張し、Serializable を実装しています

直列化されたフィールド

customerCompanyCode

String customerCompanyCode
取引先会社コード

customerDepartmentCode

String customerDepartmentCode
取引先組織コード

dealCode

String dealCode
取扱コード

roleId

String roleId
ロールID

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.attribute

クラス jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itemCode

String itemCode
商品コード

templateCode

String templateCode
テンプレートコード

templateDetailCode

String templateDetailCode
テンプレート明細コード

numberValue

double numberValue
属性数値

defaultLocale

Locale defaultLocale
デフォルトのロケール

internationals

Map internationals
商品属性の国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttributeInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

stringValue

String stringValue
属性文字列

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue

クラス jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itemCode

String itemCode
商品コード

itemCatalogueCode

String itemCatalogueCode
商品カタログコード

mediaCls

int mediaCls
媒体種類

media

String media
媒体

notes

String notes
備考

sortKey

int sortKey
ソートキー

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.item

クラス jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itemCode

String itemCode
商品コード

productModelCode

String productModelCode
製品型番

notes

String notes
備考

defaultLocale

Locale defaultLocale
デフォルトのロケール

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
商品の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

salesUnitPrice

double salesUnitPrice
販売単価

purchaseUnitPrice

double purchaseUnitPrice
仕入単価

terminableInternationals

Map terminableInternationals
商品の期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itemName

String itemName
商品名

itemCaption

String itemCaption
商品通称

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach

クラス jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itemCategoryTypeCode

String itemCategoryTypeCode
商品カテゴリ種別コード

itemCategoryCode

String itemCategoryCode
商品カテゴリコード

itemCode

String itemCode
商品コード

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.category

クラス jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itemCategoryTypeCode

String itemCategoryTypeCode
商品カテゴリ種別コード

itemCategoryCode

String itemCategoryCode
商品カテゴリコード

parentItemCategoryCode

String parentItemCategoryCode
親商品カテゴリコード

notes

String notes
備考

sortKey

int sortKey
ソートキー

defaultLocale

Locale defaultLocale
デフォルトのロケール

internationals

Map internationals
商品カテゴリの国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategoryInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itemCategoryName

String itemCategoryName
商品カテゴリ名

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.type

クラス jp.co.intra_mart.foundation.datastore.application.domain.item_category.type.ItemCategoryType は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itemCategoryTypeCode

String itemCategoryTypeCode
商品カテゴリ種別コード

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail

クラス jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail は Object を拡張し、Serializable を実装しています

直列化されたフィールド

templateCode

String templateCode
テンプレートコード

templateDetailCode

String templateDetailCode
テンプレート明細コード

dataType

int dataType
データ型

sortKey

int sortKey
ソートキー

notes

String notes
備考

defaultLocale

Locale defaultLocale
デフォルトのロケール

internationals

Map internationals
商品属性テンプレート明細の国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetailInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

templateDetailName

String templateDetailName
テンプレート明細名

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template.template

クラス jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate は Object を拡張し、Serializable を実装しています

直列化されたフィールド

templateCode

String templateCode
テンプレートコード

templateName

String templateName
テンプレート名

notes

String notes
備考

クラス jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplateInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

templateName

String templateName
テンプレート名

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach

クラス jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach は Object を拡張し、Serializable を実装しています

直列化されたフィールド

ownerCode

String ownerCode
所有者コード

privateGroupCode

String privateGroupCode
グループコード

userCode

String userCode
ユーザコード

sortKey

int sortKey
ソートキー

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.group

クラス jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup は Object を拡張し、Serializable を実装しています

直列化されたフィールド

ownerCode

String ownerCode
所有者コード

privateGroupCode

String privateGroupCode
グループコード

name

String name
グループ名

nameSyllabary

String nameSyllabary
グループ名カナ

nameEnglish

String nameEnglish
グループ名英字

notes

String notes
備考

sortKey

int sortKey
ソートキー

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach は Object を拡張し、Serializable を実装しています

直列化されたフィールド

userCode

String userCode
ユーザコード

publicGroupSetCode

String publicGroupSetCode
グループセットコード

publicGroupCode

String publicGroupCode
グループコード

sortKey

int sortKey
ソートキー

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
パブリックグループ所属の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.category

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory は Object を拡張し、Serializable を実装しています

直列化されたフィールド

publicGroupSetCode

String publicGroupSetCode
グループセットコード

publicGroupCode

String publicGroupCode
グループコード

categoryClassCode

String categoryClassCode
分類区分コード

categoryCode

String categoryCode
分類コード

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
パブリックグループ分類の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.group

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup は Object を拡張し、Serializable を実装しています

直列化されたフィールド

publicGroupSetCode

String publicGroupSetCode
グループセットコード

publicGroupCode

String publicGroupCode
グループコード

notes

String notes
備考

sortKey

int sortKey
ソートキー

defaultLocale

Locale defaultLocale
デフォルトのロケール

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
パブリックグループの期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

terminableInternationals

Map terminableInternationals
パブリックグループの期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
グループ名

nameSyllabary

String nameSyllabary
グループ名カナ

nameEnglish

String nameEnglish
グループ名英字

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.set

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet は Object を拡張し、Serializable を実装しています

直列化されたフィールド

publicGroupSetCode

String publicGroupSetCode
グループセットコード

notes

String notes
備考

sortKey

int sortKey
ソートキー

defaultLocale

Locale defaultLocale
デフォルトのロケール

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
パブリックグループセットの期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

terminableInternationals

Map terminableInternationals
パブリックグループセットの期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
グループ名

nameSyllabary

String nameSyllabary
グループ名カナ

nameEnglish

String nameEnglish
グループ名英字

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.version

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion は Object を拡張し、Serializable を実装しています

直列化されたフィールド

publicGroupSetCode

String publicGroupSetCode
グループセットコード

versionCode

String versionCode
バージョンコード

startDate

Date startDate
開始日

endDate

Date endDate
終了日

notes

String notes
備考

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.user

クラス jp.co.intra_mart.foundation.datastore.application.domain.user.User は Object を拡張し、Serializable を実装しています

直列化されたフィールド

userCode

String userCode
ユーザコード

accountFlag

String accountFlag
アカウントフラグ

notes

String notes
備考

sortKey

int sortKey
ソートキー

defaultLocale

Locale defaultLocale
デフォルトのロケール

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
ユーザの期間化に関連する情報のマップ

extendedDtos

Map extendedDtos
ユーザの基本情報に対する拡張情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

telephoneNumber

String telephoneNumber
電話番号

mobileNumber

String mobileNumber
携帯電話番号

faxNumber

String faxNumber
FAX番号

extensionNumber

String extensionNumber
内線番号

extensionFaxNumber

String extensionFaxNumber
内線FAX番号

countryCode

String countryCode
国コード

zipCode

String zipCode
郵便番号

emailAddress1

String emailAddress1
メールアドレス１

emailAddress2

String emailAddress2
メールアドレス２

mobileEmailAddress

String mobileEmailAddress
携帯用メール

url

String url
URL

extendedDtos

Map extendedDtos
ユーザの期間化情報に対する拡張情報のマップ

terminableInternationals

Map terminableInternationals
ユーザの期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
ユーザ名

nameSyllabary

String nameSyllabary
ユーザ名カナ

nameEnglish

String nameEnglish
ユーザ名英字

address

String address
住所

extendedDtos

Map extendedDtos
ユーザの期間国際化情報に対する拡張情報のマップ

パッケージ jp.co.intra_mart.foundation.datastore.common.config

クラス jp.co.intra_mart.foundation.datastore.common.config.AttributeType は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.common.config.DeleteType は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.datastore.common.model

クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

accessor

ExtendedBaseAccessor accessor
拡張基本アクセサ

クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

accessor

ExtendedInternationalAccessor accessor
拡張国際化アクセサ

クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

accessor

ExtendedTerminableInternationalAccessor accessor
拡張期間国際化アクセサ

クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

accessor

ExtendedTerminableAccessor accessor
拡張期間化アクセサ

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

context

BaseModelContext context
コンテキスト

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

context

InternationalModelContext context
コンテキスト

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap は Object を拡張し、Serializable を実装しています

直列化されたフィールド

models

Map models
国際化モデルを管理するマップ

modelName

String modelName
国際化モデルのクラス名

accessorMap

InternationalAccessorMap accessorMap
国際化アクセサマッピング

key

String key
メッセージキー

関連項目:
定数フィールド値

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

context

TerminableInternationalModelContext context
コンテキスト

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap は Object を拡張し、Serializable を実装しています

直列化されたフィールド

models

Map models
期間国際化モデルを管理するマップ

modelName

String modelName
期間国際化モデル名

accessorMap

TerminableInternationalAccessorMap accessorMap
国際化アクセサマッピング

key

String key
メッセージキー

関連項目:
定数フィールド値

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

context

TerminableModelContext context
コンテキスト

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap は Object を拡張し、Serializable を実装しています

直列化されたフィールド

models

Map models
期間化モデルを管理するマップ

terminableName

String terminableName
期間化モデルのクラス名

terminableInternationalName

String terminableInternationalName
期間国際化モデルのクラス名

accessorMap

TerminableAccessorMap accessorMap
期間化アクセサマッピング

defaultLocale

Locale defaultLocale
デフォルト言語

helper

jp.co.intra_mart.system.datastore.common.model.GenericTerminableModelMapHelper helper
期間化モデルマッピングヘルパー

key

String key
メッセージキー

関連項目:
定数フィールド値

パッケージ jp.co.intra_mart.foundation.datastore.common.structure

クラス jp.co.intra_mart.foundation.datastore.common.structure.Term は Object を拡張し、Serializable を実装しています

直列化されたフィールド

activationCal

Calendar activationCal
有効開始時間

expirationCal

Calendar expirationCal
有効終了時間

termByString

String termByString
期間の文字列表現

パッケージ jp.co.intra_mart.foundation.datastore.exception

クラス jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException は AccessorException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.AccessorException は DataStoreApplicationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException は AccessorException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException は DataStoreSystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.BatchProcessException は RuntimeException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.BatchSystemException は RuntimeException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException は AccessorException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException は FoundationException を拡張し、Serializable を実装しています

直列化されたフィールド

key

String key
メッセージキー

values

String[] values
置換用文字列

クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException は DataStoreSystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException は FoundationRuntimeException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException は AccessorException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException は DataNotFoundException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException は DataStoreApplicationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.IllegalTermException は DataNotFoundException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.ImportException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.ManagerException は DataStoreApplicationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.MapperDAOException は DataStoreSystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.MapperException は DataStoreApplicationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.TermManagerException は DataStoreApplicationException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.datastore.exporter

クラス jp.co.intra_mart.foundation.datastore.exporter.ExportInitializeException は BatchProcessException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exporter.Filter は Object を拡張し、Serializable を実装しています

直列化されたフィールド

value

String[] value

exclusive

boolean exclusive

パッケージ jp.co.intra_mart.foundation.datastore.exporter.common.config

クラス jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReaderException は ExportInitializeException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.datastore.importer

クラス jp.co.intra_mart.foundation.datastore.importer.ImportInitializeException は BatchProcessException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.datastore.importer.common.config

クラス jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReaderException は ImportInitializeException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.drawer

クラス jp.co.intra_mart.foundation.drawer.AbstractDrawer は Object を拡張し、Serializable を実装しています

直列化されたフィールド

width

int width

height

int height

type

String type

パッケージ jp.co.intra_mart.foundation.exception

クラス jp.co.intra_mart.foundation.exception.ChangedListenerException は FoundationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.exception.FoundationException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.exception.FoundationRuntimeException は RuntimeException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.graph

クラス jp.co.intra_mart.foundation.graph.BarGraphDrawer は AbstractDrawer を拡張し、Serializable を実装しています

直列化されたフィールド

image_background_color

Color image_background_color

image_border_color

Color image_border_color

graph_background_color

Color graph_background_color

graph_border_color

Color graph_border_color

caption_color

Color caption_color

top_margin

int top_margin

right_margin

int right_margin

bottom_margin

int bottom_margin

left_margin

int left_margin

caption

String[] caption

data

ArrayList data

max

Number max

min

Number min

count

Number count

isDouble

boolean isDouble

クラス jp.co.intra_mart.foundation.graph.BarGraphObject は Object を拡張し、Serializable を実装しています

直列化されたフィールド

color

Color color

data

ArrayList data

クラス jp.co.intra_mart.foundation.graph.CircleGraphDrawer は AbstractDrawer を拡張し、Serializable を実装しています

直列化されたフィールド

image_background_color

Color image_background_color

image_border_color

Color image_border_color

top_margin

int top_margin

right_margin

int right_margin

bottom_margin

int bottom_margin

left_margin

int left_margin

caption_margin

int caption_margin

data

ArrayList data

クラス jp.co.intra_mart.foundation.graph.CircleGraphObject は Object を拡張し、Serializable を実装しています

直列化されたフィールド

data

double data

color

Color color

caption

String caption

font_color

Color font_color

font_size

int font_size

isDouble

boolean isDouble

クラス jp.co.intra_mart.foundation.graph.LineGraphDrawer は AbstractDrawer を拡張し、Serializable を実装しています

直列化されたフィールド

image_background_color

Color image_background_color

image_border_color

Color image_border_color

graph_background_color

Color graph_background_color

graph_border_color

Color graph_border_color

caption_color

Color caption_color

top_margin

int top_margin

right_margin

int right_margin

bottom_margin

int bottom_margin

left_margin

int left_margin

caption

String[] caption

data

ArrayList data

max

Number max

min

Number min

count

Number count

isDouble

boolean isDouble

クラス jp.co.intra_mart.foundation.graph.LineGraphObject は Object を拡張し、Serializable を実装しています

直列化されたフィールド

color

Color color

data

ArrayList data

クラス jp.co.intra_mart.foundation.graph.PortFolioDrawer は AbstractDrawer を拡張し、Serializable を実装しています

直列化されたフィールド

image_background_color

Color image_background_color

image_border_color

Color image_border_color

graph_background_color

Color graph_background_color

graph_border_color

Color graph_border_color

caption_color

Color caption_color

top_margin

int top_margin

right_margin

int right_margin

bottom_margin

int bottom_margin

left_margin

int left_margin

data

ArrayList data

x_max

Number x_max

x_min

Number x_min

y_max

Number y_max

y_min

Number y_min

isDouble

boolean isDouble

x_center

Number x_center

x_size

Number x_size

x_count

Number x_count

y_center

Number y_center

y_size

Number y_size

y_count

Number y_count

scale_position

String scale_position

クラス jp.co.intra_mart.foundation.graph.PortFolioObject は Object を拡張し、Serializable を実装しています

直列化されたフィールド

x_data

double x_data

y_data

double y_data

color

Color color

size

int size

isDouble

boolean isDouble

クラス jp.co.intra_mart.foundation.graph.RadarChartDrawer は AbstractDrawer を拡張し、Serializable を実装しています

直列化されたフィールド

image_background_color

Color image_background_color

image_border_color

Color image_border_color

graph_frame_color

Color graph_frame_color

caption_color

Color caption_color

top_margin

int top_margin

right_margin

int right_margin

bottom_margin

int bottom_margin

left_margin

int left_margin

caption_margin

int caption_margin

caption

String[] caption

data

ArrayList data

max

Number max

min

Number min

count

Number count

isDouble

boolean isDouble

クラス jp.co.intra_mart.foundation.graph.RadarChartObject は Object を拡張し、Serializable を実装しています

直列化されたフィールド

color

Color color

fill

boolean fill

data

ArrayList data

パッケージ jp.co.intra_mart.foundation.http

クラス jp.co.intra_mart.foundation.http.CGIEnvironment は HashMap を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.http.MultipartFormData は ArrayList を拡張し、Serializable を実装しています

直列化されたフィールド

instance

MultipartFormData instance
推奨されていません。

list

ArrayList list
推奨されていません。

パッケージ jp.co.intra_mart.foundation.image

クラス jp.co.intra_mart.foundation.image.DuplicateImageIconCodeException は ImageIconException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.image.DuplicateImageIconSrcException は ImageIconException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.image.ImageIconException は FoundationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.image.NotExistImageIconException は ImageIconException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.mail.javamail.property

クラス jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException は Exception を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.mail

クラス jp.co.intra_mart.foundation.mail.MailSenderException は Exception を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.navigator

クラス jp.co.intra_mart.foundation.navigator.EventAccessInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

roles

List roles
ロール

departments

List departments
組織

posts

List posts
役職

publicGroups

List publicGroups
パブリックグループ

クラス jp.co.intra_mart.foundation.navigator.EventFlow は NavigatorAuthenticateItem を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id
イベントフローID

open

String open
公開フラグ

startEventItem

EventItem startEventItem
スタートイベント

sortNumber

int sortNumber
ソート番号

クラス jp.co.intra_mart.foundation.navigator.EventFlowInfo は TitleInfo を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

open

String open

startEventId

String startEventId

permissionCheck

boolean permissionCheck

クラス jp.co.intra_mart.foundation.navigator.EventHistoryInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

question

String question

answer

String answer

クラス jp.co.intra_mart.foundation.navigator.EventItem は NavigatorItem を拡張し、Serializable を実装しています

直列化されたフィールド

selectItem

SelectItem[] selectItem
選択アイテムリスト

クラス jp.co.intra_mart.foundation.navigator.EventItemInfo は TitleInfo を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

selectItemInfos

SelectItemInfo[] selectItemInfos

eventHistory

EventHistoryInfo[] eventHistory

クラス jp.co.intra_mart.foundation.navigator.EventNavigatorException は DataStoreApplicationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.navigator.EventResultItem は NavigatorItem を拡張し、Serializable を実装しています

直列化されたフィールド

pageItem

ResultPageItem[] pageItem
結果ページのリスト

クラス jp.co.intra_mart.foundation.navigator.EventResultItemInfo は TitleInfo を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

resultPageItemInfos

ResultPageItemInfo[] resultPageItemInfos

eventHistory

EventHistoryInfo[] eventHistory

クラス jp.co.intra_mart.foundation.navigator.LinkPageInfo は TitleInfo を拡張し、Serializable を実装しています

直列化されたフィールド

url

String url

param

Map param

クラス jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem は NavigatorItem を拡張し、Serializable を実装しています

直列化されたフィールド

accessInfo

EventAccessInfo accessInfo
アクセス権

クラス jp.co.intra_mart.foundation.navigator.NavigatorItem は Object を拡張し、Serializable を実装しています

直列化されたフィールド

titleInfo

Map titleInfo
タイトル情報

クラス jp.co.intra_mart.foundation.navigator.ResultPageItem は NavigatorAuthenticateItem を拡張し、Serializable を実装しています

直列化されたフィールド

linkPageInfo

LinkPageInfo linkPageInfo
リンク情報

クラス jp.co.intra_mart.foundation.navigator.ResultPageItemInfo は TitleInfo を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

permissionCheck

boolean permissionCheck

クラス jp.co.intra_mart.foundation.navigator.SaveEventHistoryInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

question

String question

answer

String answer

クラス jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo は TitleInfo を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

saveDate

Date saveDate

resultPageItemInfos

ResultPageItemInfo[] resultPageItemInfos

eventHistory

SaveEventHistoryInfo[] eventHistory

クラス jp.co.intra_mart.foundation.navigator.SelectItem は NavigatorAuthenticateItem を拡張し、Serializable を実装しています

直列化されたフィールド

nextEventItem

EventItem nextEventItem
遷移先イベントアイテム

nextEventResultItem

EventResultItem nextEventResultItem
遷移先ナビゲート結果

nextType

String nextType
遷移先タイプ

クラス jp.co.intra_mart.foundation.navigator.SelectItemInfo は TitleInfo を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

nextItemId

String nextItemId

nextType

String nextType

permissionCheck

boolean permissionCheck

クラス jp.co.intra_mart.foundation.navigator.TitleInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

title

String title

comment

String comment

パッケージ jp.co.intra_mart.foundation.page

クラス jp.co.intra_mart.foundation.page.NodeNameComparator は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.page.NodeTypeComparator は AbstractDualComparator を拡張し、Serializable を実装しています

直列化されたフィールド

primaryComparator

Comparator primaryComparator

secondaryComparator

Comparator secondaryComparator

パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet.model

クラス jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived は Object を拡張し、Serializable を実装しています

直列化されたフィールド

category

String category
カテゴリ名

contents

String contents
内容

date

String date
日付

url

String url
リンク先のURL

popup

boolean popup
リンク先をポップアップ画面で呼び出すかどうか

パッケージ jp.co.intra_mart.foundation.portal.portlet.model

クラス jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet は StandardPortlet を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet は Portlet を拡張し、Serializable を実装しています

直列化されたフィールド

applicationId

String applicationId
アプリケーションID

serviceId

String serviceId
サービスID

argument

String argument
ページ引数

クラス jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet は StandardPortlet を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet は J2eeFwPortlet を拡張し、Serializable を実装しています

直列化されたフィールド

menuLinkSetCode

String menuLinkSetCode
メニューリンクセットコード

クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet は Object を拡張し、Serializable を実装しています

直列化されたフィールド

portletCode

String portletCode
ポートレットコード

application

String application
アプリケーション名

portletName

String portletName
ポートレット名

titleBar

boolean titleBar
タイトルバーを表示するかどうか

cacheTime

int cacheTime
キャッシュ時間

explain

String explain
説明

unit

String unit
表示単位

width

int width
表示幅

height

int height
表示高さ

recordUserCode

String recordUserCode
最終更新ユーザコード

recordDate

Date recordDate
最終更新日

クラス jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet は StandardPortlet を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet は J2eeFwPortlet を拡張し、Serializable を実装しています

直列化されたフィールド

rssUrl

String rssUrl
URL

proxyHost

String proxyHost
プロキシホスト名

proxyPort

int proxyPort
プロキシポート番号

parserKey

String parserKey
RSS解析バージョンのキー情報

クラス jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet は Portlet を拡張し、Serializable を実装しています

直列化されたフィールド

url

String url
URL

argument

String argument
ページ引数

パッケージ jp.co.intra_mart.foundation.portal.portlet

クラス jp.co.intra_mart.foundation.portal.portlet.PortletManagerException は RuntimeException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.common.auth.exception

クラス jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException は SAPException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException は SAPException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.common.auth

クラス jp.co.intra_mart.foundation.sap.common.auth.SapConnector は Object を拡張し、Serializable を実装しています

直列化されたフィールド

serverType

String serverType
推奨されていません。
サーバタイプ

client

String client
推奨されていません。
クライアント

user

String user
推奨されていません。
ユーザ

passwd

String passwd
推奨されていません。
パスワード

lang

String lang
推奨されていません。
言語

sysnr

String sysnr
推奨されていません。
システム番号

ashost

String ashost
推奨されていません。
接続先サーバIPアドレス

poolName

String poolName
推奨されていません。
プール名称

poolSize

int poolSize
推奨されていません。
プール内のコネクション数

waitTime

long waitTime
推奨されていません。
コネクション取得の待機時間

connectionTimeout

long connectionTimeout
推奨されていません。
コネクションのタイムアウト

timeoutCheckPeriod

long timeoutCheckPeriod
推奨されていません。
コネクションのタイムアウトのチェック間隔

パッケージ jp.co.intra_mart.foundation.sap.common.exception

クラス jp.co.intra_mart.foundation.sap.common.exception.SAPException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.common.exception.SAPRuntimeException は RuntimeException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.common.exception.UnsupportedProductEditionException は SAPRuntimeException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

propertyName

String propertyName
プロパティファイル名

property

Properties property
プロパティファイル

bapiHashList

ArrayList bapiHashList
BapiHashオブジェクトの一覧

impImpList

ArrayList impImpList
プロパティ情報(import(Import))一覧

impStrList

ArrayList impStrList
プロパティ情報(structure(Import))一覧

impTblList

ArrayList impTblList
プロパティ情報(table(Import))一覧

expExpList

ArrayList expExpList
プロパティ情報(export(Export))一覧

expStrList

ArrayList expStrList
プロパティ情報(structure(Export))一覧

expTblList

ArrayList expTblList
プロパティ情報(table(Export))一覧

bapiReturnList

ArrayList bapiReturnList
ＢＡＰＩ処理実行結果

hasTransaction

boolean hasTransaction
コネクション(トランザクション)保持フラグ

connectionManager

ConnectionManager connectionManager
コネクション(トランザクション)オブジェクト

ignoreErrMsgReturnTypes

List ignoreErrMsgReturnTypes
エラーメッセージを無視するRETURN-TYPE

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash は HashMap を拡張し、Serializable を実装しています

直列化されたフィールド

impExpType

String impExpType
入力／出力区分

paramType

String paramType
パラメタ属性

paramName

String paramName
パラメタ名

recordNo

int recordNo
レコード番号

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

type

String type
TYPE

id

String id
ID

code

String code
Code

number

String number
NUMBER

message

String message
MESSAGE

logNo

String logNo
LOG NO

logMsgNo

String logMsgNo
LOG MSG NO

messageV1

String messageV1
MESSAGE V1

messageV2

String messageV2
MESSAGE V2

messageV3

String messageV3
MESSAGE V3

messageV4

String messageV4
MESSAGE V4

parameter

String parameter
PARAMETER

row

String row
ROW

field

String field
FIELD

system

String system
SYSTEM

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sapClient

SapClient sapClient
SAPへのクライアント

hasSapClient

boolean hasSapClient
SapClientオブジェクト保持フラグ

serverType

String serverType
使用したサーバータイプ退避用変数

commitOnServerTypeSwitch

boolean commitOnServerTypeSwitch
同一サーバータイプにおける各APIにて保持しているcommitプロパティ

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty は Object を拡張し、Serializable を実装しています

直列化されたフィールド

propertyValue

String propertyValue
プロパティの値

propertyKeyPart

String[] propertyKeyPart
プロパティのキー

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose.exception

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException は SAPException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException は SAPException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.common.model

クラス jp.co.intra_mart.foundation.sap.common.model.BankDataInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strVendor

String strVendor
仕入先または債権者の勘定コード

strCustomer

String strCustomer
得意先または債権者の勘定コード

strBankCtry

String strBankCtry
銀行国コード

strBankKey

String strBankKey
銀行コード

strBankAcct

String strBankAcct
口座番号

strCtrlKey

String strCtrlKey
預金種別

strPartnerBk

String strPartnerBk
取引先銀行タイプ

strCollAuth

String strCollAuth
フラグ: 回収権限

strBankRef

String strBankRef
銀行詳細の参照詳細

クラス jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strVendor

String strVendor
仕入先または債権者の勘定コード

strCustomer

String strCustomer
得意先または債権者の勘定コード

strCompCode

String strCompCode
会社コード

strClerk

String strClerk
記帳担当者

strHdOffice

String strHdOffice
本店勘定コード

strAltPayee

String strAltPayee
代理受取人勘定コード

strAltPayer

String strAltPayer
代理支払人勘定コード

strCuvdClear

String strCuvdClear
フラグ: 得意先と仕入先間の相殺決済

strPmnttrms

String strPmnttrms
支払条件キー

strActAtVen

String strActAtVen
仕入先での自社勘定コード

strActAtCus

String strActAtCus
得意先での自社勘定コード

strVendUser

String strVendUser
仕入先担当者

strCustUser

String strCustUser
得意先担当者

strNextPayee

String strNextPayee
次受取人

strBuyingGrp

String strBuyingGrp
購買グループの勘定コード

strInternet

String strInternet
関係会社担当者のインターネットアドレス

strFax

String strFax
得意先/仕入先の経理担当者のファックス No.

strPaymentMethods

String strPaymentMethods
考慮される支払方法一覧

strTel

String strTel
取引先での記帳担当者電話番号

クラス jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strVendor

String strVendor
仕入先または債権者の勘定コード

strCustomer

String strCustomer
得意先または債権者の勘定コード

strName

String strName
名称 1

strName2

String strName2
名称 2

strName3

String strName3
名称 3

strName4

String strName4
名称 4

strCity

String strCity
市区町村

strDistrict

String strDistrict
所在地

strPoBox

String strPoBox
私書箱

strPobxPcd

String strPobxPcd
私書箱番号

strPostlCode

String strPostlCode
郵便番号

strRegion

String strRegion
地域 (都道府県)

strCountycode

String strCountycode
地域コード

strCityCode

String strCityCode
市区町村コード

strStreet

String strStreet
地名/番地-号

strCountry

String strCountry
国コード

strCountryiso

String strCountryiso
ISO 国コード

strPobxCty

String strPobxCty
私書箱住所

strLangu

String strLangu
言語キー

strLanguIso

String strLanguIso
ISO 639 準拠の言語

strTelephone

String strTelephone
電話番号 1

strFormofaddr

String strFormofaddr
敬称

strTelephone2

String strTelephone2
電話番号 2

strFax1

String strFax1
FAX1

パッケージ jp.co.intra_mart.foundation.sap.common.util.data

クラス jp.co.intra_mart.foundation.sap.common.util.data.Convertor は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.common.util.data.ExtendedParamConverter は ParamConverter を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.common.util.date

クラス jp.co.intra_mart.foundation.sap.common.util.date.DateHandler は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.common.util.file

クラス jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile は Object を拡張し、Serializable を実装しています

直列化されたフィールド

properties

Properties properties
プロパティ

パッケージ jp.co.intra_mart.foundation.sap.module

クラス jp.co.intra_mart.foundation.sap.module.AbstractController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sapClient

SapClient sapClient
SAPクライアント

bapiReturnErrMessage

String bapiReturnErrMessage
BAPI実行エラーメッセージ

bapiReturnMessage

String bapiReturnMessage
BAPI実行結果メッセージ

クラス jp.co.intra_mart.foundation.sap.module.ReferenceController は AbstractController を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.UpdateController は AbstractController を拡張し、Serializable を実装しています

直列化されたフィールド

connectionManager

ConnectionManager connectionManager
コネクション(トランザクション)オブジェクト

パッケージ jp.co.intra_mart.foundation.sap.module.accounting

クラス jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

documentHeader

DocumentHeader documentHeader
伝票ヘッダ

accountPayableList

ArrayList accountPayableList
仕入先明細一覧

accountGlList

ArrayList accountGlList
G/L 勘定明細一覧

accountTaxList

ArrayList accountTaxList
税明細一覧

currencyAmountList

ArrayList currencyAmountList
明細通貨項目一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountGl は Object を拡張し、Serializable を実装しています

直列化されたフィールド

glItemnoAcc

String glItemnoAcc
会計伝票明細番号

glGlAccount

String glGlAccount
総勘定元帳勘定

glCompCode

String glCompCode
会社コード

glPstngDate

String glPstngDate
伝票の転記日付

glDocType

String glDocType
伝票タイプ

glFiscYear

String glFiscYear
会計年度

glRefKey1

String glRefKey1
取引先参照キー

glItemText

String glItemText
明細テキスト

glTaxCode

String glTaxCode
消費税コード

glAllocNmbr

String glAllocNmbr
ソートキー

glBusArea

String glBusArea
事業領域

glCostcenter

String glCostcenter
原価センタ

glOrderid

String glOrderid
指図番号

glWbsElement

String glWbsElement
WBS 要素

glIndex

int glIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

paItemnoAcc

String paItemnoAcc
会計伝票明細番号

paVendorNo

String paVendorNo
仕入先または債権者の勘定コード

paGlAccount

String paGlAccount
総勘定元帳勘定

paBlineDate

String paBlineDate
期日計算の支払基準日

paPymtMeth

String paPymtMeth
支払方法

paAllocNmbr

String paAllocNmbr
ソートキー

paItemText

String paItemText
明細テキスト

paIndex

int paIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountTax は Object を拡張し、Serializable を実装しています

直列化されたフィールド

taItemnoAcc

String taItemnoAcc
会計伝票明細番号

taGlAccount

String taGlAccount
総勘定元帳勘定

taTaxCode

String taTaxCode
消費税コード

taIndex

int taIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.Bank は Object を拡張し、Serializable を実装しています

直列化されたフィールド

bankKey

String bankKey
銀行コード

bankName

String bankName
銀行名

city

String city
市区町村名

クラス jp.co.intra_mart.foundation.sap.module.accounting.BankController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

baList

BankList baList
銀行一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.BankList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

bankList

ArrayList bankList
銀行一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea は Object を拡張し、Serializable を実装しています

直列化されたフィールド

busArea

String busArea
事業領域

busArDes

String busArDes
事業領域名

クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

busAreaList

BusinessAreaList busAreaList
事業領域一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

businessAreaList

ArrayList businessAreaList
事業領域一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.Company は Object を拡張し、Serializable を実装しています

直列化されたフィールド

compCode

String compCode
会社コード

compName

String compName
会社名

クラス jp.co.intra_mart.foundation.sap.module.accounting.CompanyController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

compList

CompanyList compList
会社一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.CompanyList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

companyList

ArrayList companyList
会社一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea は Object を拡張し、Serializable を実装しています

直列化されたフィールド

coArea

String coArea
管理領域

name

String name
管理領域名

クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

controllAreaList

ControllingAreaList controllAreaList
管理領域一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

controllingAreaList

ArrayList controllingAreaList
管理領域一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenter は Object を拡張し、Serializable を実装しています

直列化されたフィールド

controllingArea

String controllingArea
管理領域

costCenter

String costCenter
原価センタ

name

String name
一般名称

descript

String descript
テキスト

クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

costCentList

CostCenterList costCentList
原価センタ一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

costCenterList

ArrayList costCenterList
原価センタ一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount は Object を拡張し、Serializable を実装しています

直列化されたフィールド

cuItemnoAcc

String cuItemnoAcc
会計伝票明細番号

cuCurrency

String cuCurrency
通貨コード

cuAmtDoccur

String cuAmtDoccur
伝票通貨額

cuAmtBase

String cuAmtBase
課税基準額

cuIndex

int cuIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader は Object を拡張し、Serializable を実装しています

直列化されたフィールド

docObjType

String docObjType
参照処理

docObjKey

String docObjKey
オブジェクトキー

docUsername

String docUsername
ユーザ名

docHeaderTxt

String docHeaderTxt
伝票ヘッダテキスト

docCompCode

String docCompCode
会社コード

docAcDocNo

String docAcDocNo
会計伝票番号

docFiscYear

String docFiscYear
会計年度

docDocDate

String docDocDate
伝票の伝票日付

docPstngDate

String docPstngDate
伝票の転記日付

docFisPeriod

String docFisPeriod
会計期間

docDocType

String docDocType
伝票タイプ

docRefDocNo

String docRefDocNo
参照伝票番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAcc は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

glAccount

String glAccount
G/L勘定コード

shortText

String shortText
G/L勘定コードテキスト(短)

longText

String longText
総勘定元帳勘定テキスト(長)

クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAccController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

glList

GlAccList glList
勘定科目一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAccList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

glAccList

ArrayList glAccList
勘定項目一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter は Object を拡張し、Serializable を実装しています

直列化されたフィールド

controllingArea

String controllingArea
管理領域

profitCtr

String profitCtr
利益センタ

validTo

String validTo
有効終了日

pctrName

String pctrName
一般名称

inCharge

String inCharge
利益センタ責任者

クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

profitCentList

ProfitCenterList profitCentList
利益センタ一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

profitCenterList

ArrayList profitCenterList
利益センタ一覧

パッケージ jp.co.intra_mart.foundation.sap.module.accounting.exception

クラス jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException は SAPModuleAppException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException は SAPModuleSystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.module.exception

クラス jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException は SAPException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException は SAPException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException は SAPException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.module.financial

クラス jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strTrans

String strTrans
取引

strDescript

String strDescript
テキスト (30 文字)

クラス jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strControllingarea

String strControllingarea
管理領域

strGroupname

String strGroupname
グループ名

hierarchyNodesList

ArrayList hierarchyNodesList
階層ノード一覧

hierarchyValuesList

ArrayList hierarchyValuesList
階層値一覧

クラス jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail は CommonCenterGrpGetDetail を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

costCenterGroupGetDetail

CostCenterGroupGetDetail costCenterGroupGetDetail
原価センタグループ情報クラス

クラス jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strCreditorid

String strCreditorid
仕入先コード

strCompanycode

String strCompanycode
会社コード

generalDataInfo

GeneralDataInfo generalDataInfo
一般データ情報

companyDataInfo

CompanyDataInfo companyDataInfo
会社コード依存データ情報

bankDataInfoList

ArrayList bankDataInfoList
銀行データ情報

クラス jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

creditorGetDetail

CreditorGetDetail creditorGetDetail
仕入先コード詳細情報

クラス jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strDebtorid

String strDebtorid
得意先コード

strCompanycode

String strCompanycode
会社コード

generalDataInfo

GeneralDataInfo generalDataInfo
一般データ情報

companyDataInfo

CompanyDataInfo companyDataInfo
会社コード依存データ情報

bankDataInfoList

ArrayList bankDataInfoList
銀行データ情報

クラス jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

debtorGetDetail

DebtorGetDetail debtorGetDetail
得意先コード詳細情報

クラス jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strRateType

String strRateType
換算レートタイプ

strFromCurr

String strFromCurr
換算前通貨

strToCurrncy

String strToCurrncy
換算後通貨

strDate

String strDate
起算日

exchRate

ExchRate exchRate
換算レート、係数 (通貨ペア)

クラス jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

exchangeRateGetDetail

ExchangeRateGetDetail exchangeRateGetDetail
為替換算レート情報クラス

クラス jp.co.intra_mart.foundation.sap.module.financial.ExchRate は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strRateType

String strRateType
換算レートタイプ

strFromCurr

String strFromCurr
換算前通貨

strToCurrncy

String strToCurrncy
換算後通貨

strValidFrom

String strValidFrom
エントリの有効開始日

strExchRate

String strExchRate
直接呼び値換算レート

strFromFactor

String strFromFactor
換算前 通貨単位の係数

strToFactor

String strToFactor
換算後 通貨単位の係数

strExchRateV

String strExchRateV
間接呼び値換算レート

strFromFactorV

String strFromFactorV
換算前 通貨単位の係数

strToFactorV

String strToFactorV
換算後 通貨単位の係数

クラス jp.co.intra_mart.foundation.sap.module.financial.ExpActivity は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strNetwork

String strNetwork
ネットワーク番号

strActivity

String strActivity
ネットワーク/標準ネットワークの活動番号

strControlKey

String strControlKey
管理キー

strWorkCntr

String strWorkCntr
作業区

strPlant

String strPlant
プラント

strDescription

String strDescription
作業テキスト (短)

strVendorNo

String strVendorNo
仕入先または債権者の勘定コード

strPrice

String strPrice
価格

strPriceUnit

String strPriceUnit
価格単位

strCostElem

String strCostElem
原価要素

strCurrency

String strCurrency
通貨コード

strCurrencyIso

String strCurrencyIso
ISO 通貨コード

strInfoRec

String strInfoRec
購買情報番号

strPurchOrg

String strPurchOrg
購買組織

strPurGroup

String strPurGroup
購買グループ

strMatlGroup

String strMatlGroup
品目グループ

strFlexibleDuration

String strFlexibleDuration
区分: 可変期間

strNumberOfCapacities

String strNumberOfCapacities
所要能力数

strPercentOfWork

String strPercentOfWork
作業の比率 (%)

strMilestone

String strMilestone
用途

strActtype

String strActtype
活動タイプ

strActivityCosts

String strActivityCosts
活動の原価

strProjectDefinition

String strProjectDefinition
プロジェクト定義

strWbsElement

String strWbsElement
WBS 要素

strFactoryCalendar

String strFactoryCalendar
稼働日カレンダ

strDistributingKey

String strDistributingKey
能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)

strPriority

String strPriority
優先度

strTaxjurcode

String strTaxjurcode
税計算管轄コード - 税管轄コード

strObjectclass

String strObjectclass
オブジェクトクラス (言語非依存)

strProfitCtr

String strProfitCtr
利益センタ

strNotMrpApplicable

String strNotMrpApplicable
区分: MRP への入出庫予定の適用不可と購買依頼未登録

strProjectSummarization

String strProjectSummarization
区分: プロジェクト集計用に活動を考慮

strOperationMeasureUnit

String strOperationMeasureUnit
活動単位

strOperationMeasureUnitIso

String strOperationMeasureUnitIso
単位の ISO コード

strPlndDelry

String strPlndDelry
予定納入時間 (単位: 日)

strDurationNormal

String strDurationNormal
標準活動期間

strDurationNormalUnit

String strDurationNormalUnit
標準期間/単位

strDurationNormalUnitIso

String strDurationNormalUnitIso
単位の ISO コード

strDurationMinimum

String strDurationMinimum
最短活動期間

strDurationMinimumUnit

String strDurationMinimumUnit
最短期間の単位

strDurationMinimumUnitIso

String strDurationMinimumUnitIso
単位の ISO コード

strConstraintTypeStart

String strConstraintTypeStart
活動の基準開始日に対する制約

strConstraintTypeFinish

String strConstraintTypeFinish
活動の終了日に対する制約

strWorkActivity

String strWorkActivity
活動に含まれる作業

strUnWork

String strUnWork
作業単位

strUnWorkIso

String strUnWorkIso
単位の ISO コード

strEarlyStartDate

String strEarlyStartDate
最早計画開始: 実行 (日)

strEarlyStartTime

String strEarlyStartTime
最早計画開始: 作業実施(時間)

strEarlyFinishDate

String strEarlyFinishDate
最早計画終了: 実行 (日)

strEarlyFinishTime

String strEarlyFinishTime
最早計画終了: 実行 (時刻)

strLatestStartDate

String strLatestStartDate
計画最遅開始: 作業(日付)

strLatestStartTime

String strLatestStartTime
計画最遅開始: 作業(時間)

strLatestFinishDate

String strLatestFinishDate
計画最遅終了: 作業(日付)

strLatestFinishTime

String strLatestFinishTime
計画最遅終了: 作業(時間)

strFloatFree

String strFloatFree
自由余裕

strFloatTotal

String strFloatTotal
余裕合計

strConstraintStartDate

String strConstraintStartDate
活動の基準開始日に対する制約

strConstraintStartTime

String strConstraintStartTime
活動の基準開始時間の制約

strConstraintFinishDate

String strConstraintFinishDate
活動の基準終了日に対する制約

strConstraintFinishTime

String strConstraintFinishTime
活動の基準終了時間

strUserFieldKey

String strUserFieldKey
ユーザ定義項目のキーワード ID

strUserFieldChar201

String strUserFieldChar201
20 文字のユーザ項目

strUserFieldChar202

String strUserFieldChar202
20 文字のユーザ項目

strUserFieldChar101

String strUserFieldChar101
ユーザ定義項目 (10 文字)

strUserFieldChar102

String strUserFieldChar102
ユーザ定義項目 (10 文字)

strUserFieldQuan1

String strUserFieldQuan1
数量のユーザ項目 (長さ 10,3)

strUserFieldUnit1

String strUserFieldUnit1
ユーザ項目: 数量項目の単位

strUserFieldUnit1Iso

String strUserFieldUnit1Iso
単位の ISO コード

strUserFieldQuan2

String strUserFieldQuan2
数量のユーザ項目 (長さ 10,3)

strUserFieldUnit2

String strUserFieldUnit2
ユーザ項目: 数量項目の単位

strUserFieldUnit2Iso

String strUserFieldUnit2Iso
単位の ISO コード

strUserFieldCurr1

String strUserFieldCurr1
値のユーザ定義項目 (長さ 10,3)

strUserFieldCuky1

String strUserFieldCuky1
ユーザ項目: 値項目の単位

strUserFieldCuky1Iso

String strUserFieldCuky1Iso
ISO 通貨コード

strUserFieldCurr2

String strUserFieldCurr2
値のユーザ定義項目 (長さ 10,3)

strUserFieldCuky2

String strUserFieldCuky2
ユーザ項目: 値項目の単位

strUserFieldCuky2Iso

String strUserFieldCuky2Iso
ISO 通貨コード

strUserFieldDate1

String strUserFieldDate1
日付のユーザ項目

strUserFieldDate2

String strUserFieldDate2
日付のユーザ項目

strUserFieldFlag1

String strUserFieldFlag1
ユーザ定義項目: レポート区分

strUserFieldFlag2

String strUserFieldFlag2
ユーザ定義項目: レポート区分

strDeletionFlag

String strDeletionFlag
削除フラグ

strDurationNormalFc

String strDurationNormalFc
標準活動期間 (予測)

strDurationNormalFcUnit

String strDurationNormalFcUnit
標準予測期間の単位

strDurationNormalFcUnitIso

String strDurationNormalFcUnitIso
単位の ISO コード

strDurationMinimumFc

String strDurationMinimumFc
活動の最小期間(需要予測より)

strDurationMinimumFcUnit

String strDurationMinimumFcUnit
予測最短期間の単位

strDurationMinimumFcUnitIso

String strDurationMinimumFcUnitIso
単位の ISO コード

strConstraintTypeFinishFc

String strConstraintTypeFinishFc
活動終了の制約条件付き需要予測日付

strConstraintTypeStartFc

String strConstraintTypeStartFc
活動開始の制約条件付き需要予測日付

strConstraintStartDateFc

String strConstraintStartDateFc
活動の予測開始日

strConstraintStartTimeFc

String strConstraintStartTimeFc
活動の需要予測開始時間

strConstraintFinishDateFc

String strConstraintFinishDateFc
予測終了日付

strConstraintFinishTimeFc

String strConstraintFinishTimeFc
活動の予測終了時間

strEarlyStartDateFc

String strEarlyStartDateFc
最早計画開始日付(需要予測)

strEarlyStartTimeFc

String strEarlyStartTimeFc
最早計画開始時間(需要予測)

strEarlyFinishDateFc

String strEarlyFinishDateFc
最早計画終了日 (予測)

strEarlyFinishTimeFc

String strEarlyFinishTimeFc
最早計画終了時間(需要予測)

strLatestStartDateFc

String strLatestStartDateFc
最遅計画済開始日付(需要予測)

strLatestStartTimeFc

String strLatestStartTimeFc
最遅計画済開始時間(需要予測)

strLatestFinishDateFc

String strLatestFinishDateFc
最遅計画済終了日付(需要予測)

strLatestFinishTimeFc

String strLatestFinishTimeFc
最遅計画終了時間 (予測)

strFloatFreeFc

String strFloatFreeFc
自由余裕 (予測)

strFloatTotalFc

String strFloatTotalFc
余裕合計 (予測)

strWorkForecast

String strWorkForecast
予測作業 (実績 + 残存)

strWorkActual

String strWorkActual
実績作業

strDurationScheduled

String strDurationScheduled
処理時間

strDurationScheduledFc

String strDurationScheduledFc
処理時間の長さ (予測値)

strDurationScheduledUnit

String strDurationScheduledUnit
処理時間単位

strDurationScheduledUnitIso

String strDurationScheduledUnitIso
単位の ISO コード

strDurationConfirmFc

String strDurationConfirmFc
確認の予測活動期間

strDurationConfirmFcUnit

String strDurationConfirmFcUnit
確認の予測期間単位

strDurationConfirmFcUnitIso

String strDurationConfirmFcUnitIso
単位の ISO コード

strObjectclassExt

String strObjectclassExt
オブジェクトクラス、言語依存

strFuncArea

String strFuncArea
機能領域

strFuncAreaLong

String strFuncAreaLong
機能領域

strPlannedCost

String strPlannedCost
計画原価

strActualCost

String strActualCost
実際原価

strControllingAreaCurrency

String strControllingAreaCurrency
通貨コード

strActualStartDate

String strActualStartDate
実績開始日: 実行 (日付)

strActualFinishDate

String strActualFinishDate
実績終了日: 実行 (日付)

strForecastFinishDate

String strForecastFinishDate
予測終了日

strComplete

String strComplete
最終確認の有効化

strReferencePoint

String strReferencePoint
BOM 転送の参照ポイント

クラス jp.co.intra_mart.foundation.sap.module.financial.ExpMessage は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strMethod

String strMethod
メソッド

strObjectType

String strObjectType
オブジェクトタイプ

strInternalObjectId

String strInternalObjectId
SAP 内部対象キー

strExternalObjectId

String strExternalObjectId
SAP 外部対象キー

strMessageId

String strMessageId
メッセージ ID

strMessageNumber

String strMessageNumber
システムメッセージ番号

strMessageType

String strMessageType
メッセージタイプ

strMessageText

String strMessageText
メッセージのテキスト行

クラス jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strWbsElement

String strWbsElement
WBS 要素

strProjectDefinition

String strProjectDefinition
プロジェクト定義

strDescription

String strDescription
PS: テキスト(短)(第一テキスト行)

strShortId

String strShortId
WBS 要素 ショート ID

strResponsibleNo

String strResponsibleNo
責任者番号 (プロジェクト責任者)

strApplicantNo

String strApplicantNo
申請者番号

strCompCode

String strCompCode
会社コード

strBusArea

String strBusArea
事業領域

strCoArea

String strCoArea
管理領域

strProfitCtr

String strProfitCtr
利益センタ

strProjType

String strProjType
プロジェクトタイプ

strNetworkAssignment

String strNetworkAssignment
ネットワーク割当

strCostingSheet

String strCostingSheet
原価計算表

strOverheadKey

String strOverheadKey
間接費キー

strCalendar

String strCalendar
稼動日カレンダ

strPriority

String strPriority
優先度

strEquipment

String strEquipment
設備番号

strFunctionalLocation

String strFunctionalLocation
機能場所

strCurrency

String strCurrency
通貨コード

strCurrencyIso

String strCurrencyIso
ISO 通貨コード

strPlant

String strPlant
プラント

strUserFieldKey

String strUserFieldKey
ユーザ定義項目のキーワード ID

strUserFieldChar201

String strUserFieldChar201
20 文字の第 1 ユーザ項目 - WBS 要素 -

strUserFieldChar202

String strUserFieldChar202
20 桁の第 2 ユーザ項目 - WBS 要素

strUserFieldChar101

String strUserFieldChar101
10 桁の第 3 ユーザ項目 - WBS 要素

strUserFieldChar102

String strUserFieldChar102
10 桁の第 4 ユーザ項目 - WBS 要素

strUserFieldQuan1

String strUserFieldQuan1
数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素

strUserFieldUnit1

String strUserFieldUnit1
数量項目単位の第１ユーザ定義項目 - WBS 要素

strUserFieldUnit1Iso

String strUserFieldUnit1Iso
単位の ISO コード

strUserFieldQuan2

String strUserFieldQuan2
数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素

strUserFieldUnit2

String strUserFieldUnit2
数量項目単位の第２ユーザ定義項目 - WBS 要素

strUserFieldUnit2Iso

String strUserFieldUnit2Iso
単位の ISO コード

strUserFieldCurr1

String strUserFieldCurr1
値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素

strUserFieldCuky1

String strUserFieldCuky1
値項目単位の第１ユーザ定義項目 - WBS 要素

strUserFieldCuky1Iso

String strUserFieldCuky1Iso
ISO 通貨コード

strUserFieldCurr2

String strUserFieldCurr2
値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素

strUserFieldCuky2

String strUserFieldCuky2
値項目単位の第２ユーザ定義項目 - WBS 要素

strUserFieldCuky2Iso

String strUserFieldCuky2Iso
ISO 通貨コード

strUserFieldDate1

String strUserFieldDate1
日付の第 1 ユーザ項目 - WBS 要素

strUserFieldDate2

String strUserFieldDate2
日付の第 2 ユーザ項目 - WBS 要素

strUserFieldFlag1

String strUserFieldFlag1
'評価区分' の第 1 ユーザ項目 - WBS 要素

strUserFieldFlag2

String strUserFieldFlag2
'評価区分' の第 2 ユーザ項目 - WBS 要素

strObjectclass

String strObjectclass
対象クラス

strStatistical

String strStatistical
統計 WBS 要素

strTaxjurcode

String strTaxjurcode
税計算管轄コード - 税管轄コード

strIntProfile

String strIntProfile
プロジェクト/指図金利計算の金利プロファイル

strJointVenture

String strJointVenture
ジョイントベンチャ

strRecoveryInd

String strRecoveryInd
リカバリフラグ

strEquityType

String strEquityType
持分タイプ

strJvObjectType

String strJvObjectType
ジョイントベンチャ対象タイプ

strJvJibClass

String strJvJibClass
JIB/JIBE クラス

strJvJibSubClassA

String strJvJibSubClassA
JIB/JIBE サブクラスA

strDeletionFlag

String strDeletionFlag
削除フラグ

strObjectclassExt

String strObjectclassExt
オブジェクトクラス、言語依存

strWbsPlanningElement

String strWbsPlanningElement
区分: 計画要素

strWbsAccountAssignmentElement

String strWbsAccountAssignmentElement
区分: 勘定設定要素

strWbsBillingElement

String strWbsBillingElement
区分: 請求要素

strRespsblCctr

String strRespsblCctr
責任原価センタ

strRespsblCctrControllingArea

String strRespsblCctrControllingArea
責任原価センタの管理領域

strRequestCctr

String strRequestCctr
申請原価センタ

strRequestCompCode

String strRequestCompCode
会社コード要求

strRequestCctrControllingArea

String strRequestCctrControllingArea
依頼原価センタの管理領域

strLocation

String strLocation
場所

strChangeNo

String strChangeNo
変更番号

strInvestProfile

String strInvestProfile
設備投資案件プロファイル

strResAnalKey

String strResAnalKey
結果分析キー

strWbsCctrPostedActual

String strWbsCctrPostedActual
原価が実際に転記される原価センタ

strWbsBasicStartDate

String strWbsBasicStartDate
WBS 要素: 基本開始日

strWbsBasicFinishDate

String strWbsBasicFinishDate
WBS 要素: 基本終了日付

strWbsForecastStartDate

String strWbsForecastStartDate
WBS 要素の予測開始日

strWbsForecastFinishDate

String strWbsForecastFinishDate
WBS 要素の予測済終了日付

strWbsActualStartDate

String strWbsActualStartDate
WBS 要素の実績開始日付

strWbsActualFinishDate

String strWbsActualFinishDate
WBS 要素の実績終了日

strWbsBasicDuration

String strWbsBasicDuration
WBS 要素の基準日の長さ(期間)

strWbsBasicDurUnit

String strWbsBasicDurUnit
基準 WBS 要素日付の期間単位

strWbsBasicDurUnitIso

String strWbsBasicDurUnitIso
単位の ISO コード

strWbsForecastDuration

String strWbsForecastDuration
WBS 要素の予測期間

strWbsForcastDurUnit

String strWbsForcastDurUnit
WBS 要素計画日付の単位

strWbsForecastDurUnitIso

String strWbsForecastDurUnitIso
単位の ISO コード

strWbsActualDuration

String strWbsActualDuration
WBS 要素の実績長(期間)

strWbsActualDurUnit

String strWbsActualDurUnit
実績 WBS 要素日付の期間単位

strWbsActualDurUnitIso

String strWbsActualDurUnitIso
単位の ISO コード

strWbsScdBasicStartDate

String strWbsScdBasicStartDate
最早計画開始日 (基準)

strWbsScdBasicFinishDate

String strWbsScdBasicFinishDate
最遅計画終了日 (基準)

strWbsScdForecastStartDate

String strWbsScdForecastStartDate
計画開始日 (予測)

strWbsScdForecastFinishDate

String strWbsScdForecastFinishDate
最遅計画終了日 (予測)

strWbsScdActualStartDate

String strWbsScdActualStartDate
WBS 要素の仮実績開始日

strWbsScdActualFinishDate

String strWbsScdActualFinishDate
WBS 要素の仮実績終了日

strFuncArea

String strFuncArea
機能領域

strFuncAreaLong

String strFuncAreaLong
機能領域

クラス jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strWbsElement

String strWbsElement
WBS 要素

strProjectDefinition

String strProjectDefinition
プロジェクト定義

strUp

String strUp
WBS 要素

strDown

String strDown
WBS 要素

strLeft

String strLeft
WBS 要素

strRight

String strRight
WBS 要素

クラス jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strMilestoneNumber

String strMilestoneNumber
マイルストーン番号

strWbsElement

String strWbsElement
WBS 要素

strMilestoneUsage

String strMilestoneUsage
マイルストーン用途

strDescription

String strDescription
テキスト

strSchedMilestoneDateBasic

String strSchedMilestoneDateBasic
マイルストーン計画日(基準)

strSchedMilestoneTimeBasic

String strSchedMilestoneTimeBasic
マイルストーン計画時間(基準)

strSchedMilestoneDateForecast

String strSchedMilestoneDateForecast
マイルストーン計画日(予測)

strSchedMilestoneTimeForecast

String strSchedMilestoneTimeForecast
マイルストーン計画時間(予測)

strFixedMilestoneDateBasic

String strFixedMilestoneDateBasic
固定マイルストーン日付(基準)

strFixedMilestoneTimeBasic

String strFixedMilestoneTimeBasic
固定マイルストーン時間(基準)

strFixedMilestoneDateForecast

String strFixedMilestoneDateForecast
マイルストーン固定日付

strFixedMilestoneTimeForecast

String strFixedMilestoneTimeForecast
マイルストーン固定時間 (F)

strActualDate

String strActualDate
実績日付(マイルストーン通過)

strActualTime

String strActualTime
実績日/時間(マイルストーン適合)

strLatestDatesIndicator

String strLatestDatesIndicator
区分: 最遅日

strOffsetStartEndIndicator

String strOffsetStartEndIndicator
区分: オフセット用の参照（開始/終了活動日）

strOffsetMilestoneDate

String strOffsetMilestoneDate
マイルストーン日付のオフセット

strOffsetMilestoneDateUnit

String strOffsetMilestoneDateUnit
マイルストーンのオフセットのための時間単位

strOffsetMilestoneDateUnitIso

String strOffsetMilestoneDateUnitIso
単位の ISO コード

strOffsetPercentage

String strOffsetPercentage
活動日に対するマイルストーンの百分率によるオフセット

strTrendAnalysisIndicator

String strTrendAnalysisIndicator
傾向分析の関連マイルストーン

strEarnedValueIndicator

String strEarnedValueIndicator
進捗分析関連のマイルストーン

strPercentageOfCompletion

String strPercentageOfCompletion
進捗度 (%)

strSalesDocDateInidicator

String strSalesDocDateInidicator
販売伝票の日付に関連するマイルストーン

strInvoicePercentage

String strInvoicePercentage
請求金額率 (%)

strDeletionFlag

String strDeletionFlag
削除フラグ

クラス jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strGroupname

String strGroupname
グループ名

strHierlevel

String strHierlevel
階層のエントリレベル

strValcount

String strValcount
階層ノード内の値の値数

strDescript

String strDescript
グループテキスト (短)

クラス jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strValfrom

String strValfrom
原価センタ/利益センタ

strValto

String strValto
原価センタ/利益センタ

クラス jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strWbsElement

String strWbsElement
WBS 要素

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strOrderid

String strOrderid
指図番号

strLanguage

String strLanguage
ステータスおよび業務トランザクションテキストの言語

masterData

MasterData masterData
指図のマスタデータ構造

systemStatusList

ArrayList systemStatusList
システムステータステーブル

userStatusList

ArrayList userStatusList
ユーザステータス/指図ステータステーブル

allowedBusTractList

ArrayList allowedBusTractList
使用可能業務トランザクションのテーブル

クラス jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

internalOrderGetDetail

InternalOrderGetDetail internalOrderGetDetail
内部指図書詳細情報クラス

クラス jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strControllingArea

String strControllingArea
管理領域

strRespCostCenter

String strRespCostCenter
責任原価センタ

strOrderType

String strOrderType
指図タイプ

strOrder

String strOrder
指図番号 (個別値、または下限値)

strOrderTo

String strOrderTo
指図番号 (上限値)

strOrderExternalNo

String strOrderExternalNo
外部指図番号 (個別値、または下限値)

strOrderExternalNoTo

String strOrderExternalNoTo
外部指図番号 (上限値)

orderListList

ArrayList orderListList
選択指図一覧

クラス jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

internalOrderGetList

InternalOrderGetList internalOrderGetList
内部指図書一覧情報クラス

クラス jp.co.intra_mart.foundation.sap.module.financial.MasterData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strOrder

String strOrder
指図番号

strOrderType

String strOrderType
販売伝票タイプ

strOrderName

String strOrderName
テキスト

strExtOrdNo

String strExtOrdNo
外部指図番号

strObjectNo

String strObjectNo
対象番号

strCoArea

String strCoArea
管理領域

strCompCode

String strCompCode
会社コード

strBusArea

String strBusArea
事業領域

strPlant

String strPlant
プラント

strProfitCtr

String strProfitCtr
利益センタ

strRespcctr

String strRespcctr
責任原価センタ

strWbsElem

String strWbsElem
作業詳細項目要素 (WBS 要素)

strWbsElementExt

String strWbsElementExt
WBS 要素

strRequestCctr

String strRequestCctr
申請原価センタ

strRequCompCode

String strRequCompCode
会社コード要求

strSalesOrd

String strSalesOrd
受注伝票番号

strSOrdItem

String strSOrdItem
受注明細番号

strTaxjurcode

String strTaxjurcode
税計算管轄コード - 税管轄コード

strCctrPosted

String strCctrPosted
原価が実際に転記された原価センタ

strCurrency

String strCurrency
購買発注通貨

strCstgSheet

String strCstgSheet
原価計算表

strOverheadKey

String strOverheadKey
間接費キー

strResAnalKey

String strResAnalKey
結果分析キー

strInterestProf

String strInterestProf
プロジェクト/指図金利計算の金利プロファイル

strApplicant

String strApplicant
申請者

strApplicantPhone

String strApplicantPhone
申請者の電話番号

strPersonResp

String strPersonResp
責任者

strPersonRespPhone

String strPersonRespPhone
責任者の電話番号

strEstimatedCosts

String strEstimatedCosts
指図の見積原価合計

strApplicationDate

String strApplicationDate
申請日

strDepartment

String strDepartment
部署

strDateWorkBegins

String strDateWorkBegins
作業開始

strDateWorkEnds

String strDateWorkEnds
作業終了

strWorkPermit

String strWorkPermit
仕事許可済フラグ

strProcessingGroup

String strProcessingGroup
処理グループ

strPlnRelease

String strPlnRelease
計画リリース日付

strPlnCompletion

String strPlnCompletion
計画完了日

strPlnClose

String strPlnClose
計画終了日付

strRequestOrder

String strRequestOrder
申請指図

strFuncArea

String strFuncArea
機能領域

strFuncAreaLong

String strFuncAreaLong
機能領域

クラス jp.co.intra_mart.foundation.sap.module.financial.OrderList は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strOrder

String strOrder
指図番号

strObjectNo

String strObjectNo
対象番号

strOrderType

String strOrderType
販売伝票タイプ

strOrderName

String strOrderName
テキスト

クラス jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail は CommonCenterGrpGetDetail を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

profitCenterGrpGetDetail

ProfitCenterGrpGetDetail profitCenterGrpGetDetail
利益センタグループ情報クラス

クラス jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strProjectDefinition

String strProjectDefinition
プロジェクト定義

strDescription

String strDescription
PS: テキスト(短)(第一テキスト行)

strMaskId

String strMaskId
WBS 要素 ID(短)の選択マスク

strResponsibleNo

String strResponsibleNo
責任者番号 (プロジェクト責任者)

strApplicantNo

String strApplicantNo
申請者番号

strCompCode

String strCompCode
会社コード

strBusArea

String strBusArea
事業領域

strControllingArea

String strControllingArea
管理領域

strProfitCtr

String strProfitCtr
利益センタ

strProjectCurrency

String strProjectCurrency
WBS 通貨(プロジェクト定義)

strProjectCurrencyIso

String strProjectCurrencyIso
ISO 通貨コード

strNetworkAssignment

String strNetworkAssignment
ネットワーク割当

strStart

String strStart
プロジェクト計画開始日付

strFinish

String strFinish
プロジェクトの計画終了日

strPlant

String strPlant
プラント

strCalendar

String strCalendar
稼動日カレンダ

strPlanBasic

String strPlanBasic
プロジェクト基準日付計画方法

strPlanFcst

String strPlanFcst
プロジェクト予測日付の計画方法

strTimeUnit

String strTimeUnit
時間計画単位

strTimeUnitIso

String strTimeUnitIso
単位の ISO コード

strNetworkProfile

String strNetworkProfile
ネットワークプロファイル

strProjectProfile

String strProjectProfile
プロジェクトプロファイル

strBudgetProfile

String strBudgetProfile
予算プロファイル

strProjectStock

String strProjectStock
プロジェクト在庫

strObjectclass

String strObjectclass
対象クラス

strStatistical

String strStatistical
統計 WBS 要素

strTaxjurcode

String strTaxjurcode
税計算管轄コード - 税管轄コード

strIntProfile

String strIntProfile
プロジェクト/指図金利計算の金利プロファイル

strWbsSchedProfile

String strWbsSchedProfile
WBS 日程計画のプロファイル

strCshBdgtProfile

String strCshBdgtProfile
資金計画プロファイル

strPlanProfile

String strPlanProfile
計画プロファイル

strJointVenture

String strJointVenture
ジョイントベンチャ

strRecoveryInd

String strRecoveryInd
リカバリフラグ

strEquityType

String strEquityType
持分タイプ

strJvObjectType

String strJvObjectType
ジョイントベンチャ対象タイプ

strJvJibClass

String strJvJibClass
JIB/JIBE クラス

strJvJibSubClassA

String strJvJibSubClassA
JIB/JIBE サブクラスA

strDeletionFlag

String strDeletionFlag
削除フラグ

strObjectclassExt

String strObjectclassExt
オブジェクトクラス、言語依存

strFuncArea

String strFuncArea
機能領域

strFuncAreaLong

String strFuncAreaLong
機能領域

クラス jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strProjectDefinition

String strProjectDefinition
プロジェクト定義

strWithActivities

String strWithActivities
区分: 活動があるプロジェクト

strWithMilestones

String strWithMilestones
マイルストーンがあるプロジェクトの出力

strWithSubtree

String strWithSubtree
WBS 要素サブツリーの出力

impWbsElementList

ArrayList impWbsElementList
WBS 要素

projectDefinition

ProjectDefinition projectDefinition
プロジェクトについての詳細情報

expWbsElementList

ArrayList expWbsElementList
WBS 要素についての詳細情報

expWbsMilestoneList

ArrayList expWbsMilestoneList
WBS マイルストーンに関する詳細情報

expWbsHierarchieList

ArrayList expWbsHierarchieList
WBS 階層についての情報

expActivityList

ArrayList expActivityList
活動に関する詳細情報

expMessageList

ArrayList expMessageList
詳細情報を読み込みエラー

クラス jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

projectGetInfo

ProjectGetInfo projectGetInfo
WBSの詳細情報クラス

クラス jp.co.intra_mart.foundation.sap.module.financial.SystemStatus は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strSysStatus

String strSysStatus
システムステータス

strSyStText

String strSyStText
オブジェクトの個別ステータス (簡略形式)

strSyStDscr

String strSyStDscr
オブジェクトステータス

クラス jp.co.intra_mart.foundation.sap.module.financial.UserStatus は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strStatProf

String strStatProf
ステータスプロファイル

strUsrStatus

String strUsrStatus
ユーザステータス

strUsStNumb

String strUsStNumb
ステータス番号

strUsStText

String strUsStText
オブジェクトの個別ステータス (簡略形式)

strUsStDscr

String strUsStDscr
オブジェクトステータス

パッケージ jp.co.intra_mart.foundation.sap.module.financial.exception

クラス jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException は SAPModuleAppException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialSystemException は SAPModuleSystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.module.purchase

クラス jp.co.intra_mart.foundation.sap.module.purchase.AllVersions は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strDocType

String strDocType
購買伝票カテゴリ

strDocNumber

String strDocNumber
購買管理におけるオブジェクト番号

strItemNumber

String strItemNumber
購買管理オブジェクト: 明細

strVersion

String strVersion
購買管理におけるバージョン番号

strCreatedBy

String strCreatedBy
オブジェクト登録者名

strCrOn

String strCrOn
レコード登録日

strRecTime

String strRecTime
登録時刻

strReleasedBy

String strReleasedBy
承認者名

strReleaseDate

String strReleaseDate
承認日

strReleaseTime

String strReleaseTime
承認時刻

strReleasebyPur

String strReleasebyPur
承認購買担当者名

strReleasedatePur

String strReleasedatePur
購買担当者承認日付

strReleasetimePur

String strReleasetimePur
購買担当者承認時刻

strReason

String strReason
変更理由

strDescription

String strDescription
バージョンテキスト（長）

strReqByExt

String strReqByExt
バージョンの外部変更番号

strReqBy

String strReqBy
変更を依頼した従業員

strNetValue

String strNetValue
購買発注通貨による正味発注額

strValueChanged

String strValueChanged
バージョンによる金額変更

strCurrency

String strCurrency
通貨コード

strCurrencyIso

String strCurrencyIso
ISO コード通貨

strPostDate

String strPostDate
バージョンの転記日付

strCompleted

String strCompleted
ステータス "バージョン完了済"

strStatus

String strStatus
バージョンステータス

strDeleteInd

String strDeleteInd
購買伝票の削除フラグ

strStatusDocOld

String strStatusDocOld
このバージョンの前の旧処理状況 (購買伝票内)

クラス jp.co.intra_mart.foundation.sap.module.purchase.Cond は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strConditionNo

String strConditionNo
伝票条件番号

strItmNumber

String strItmNumber
条件明細番号

strCondStNo

String strCondStNo
ステップ番号

strCondCount

String strCondCount
条件カウンタ

strCondType

String strCondType
条件タイプ

strCondValue

String strCondValue
条件レート

strCurrency

String strCurrency
通貨コード

strCurrencyIso

String strCurrencyIso
ISO コード通貨

strCondUnit

String strCondUnit
条件単位

strCondUnitIso

String strCondUnitIso
条件数量単位 (ISO コード)

strCondPUnt

String strCondPUnt
価格条件単位

strApplicatio

String strApplicatio
アプリケーション

strConpricdat

String strConpricdat
条件価格設定日付

strCalctypcon

String strCalctypcon
条件計算タイプ

strConbaseval

String strConbaseval
条件基礎値

strConexchrat

String strConexchrat
現地通貨への換算レートに対する条件

strNumconvert

String strNumconvert
条件単位を基本単位へ変換する分子

strDenominato

String strDenominato
条件単位を基本単位へ変換する分母

strCondtype

String strCondtype
条件カテゴリ (例: 税、運賃、価格、原価)

strStatCon

String strStatCon
統計に適用する条件

strScaletype

String strScaletype
スケールタイプ

strAccruals

String strAccruals
見越額関連条件 (運賃など)

strConinvolst

String strConinvolst
請求書一覧条件

strCondorigin

String strCondorigin
条件生成区分

strGroupcond

String strGroupcond
グループ条件区分

strCondUpdat

String strCondUpdat
条件更新

strAccessSeq

String strAccessSeq
検索順序 - 検索番号

strCondcount

String strCondcount
条件連続番号

strCondcntrl

String strCondcntrl
条件管理

strCondisacti

String strCondisacti
無効条件

strCondclass

String strCondclass
条件クラス

strFactbasval

String strFactbasval
条件基礎値に対する要因

strScalebasin

String strScalebasin
スケール基準区分

strScalbasval

String strScalbasval
条件のスケール基準値

strUnitmeasur

String strUnitmeasur
条件スケール単位

strUnitmeasurIso

String strUnitmeasurIso
単位の ISO コード

strCurrenckey

String strCurrenckey
スケール通貨

strCurrenckeyIso

String strCurrenckeyIso
ISO コード通貨

strCondincomp

String strCondincomp
会社間請求の条件

strCondconfig

String strCondconfig
システム設定の条件

strCondchaman

String strCondchaman
条件 (マニュアル変更済)

strCondNo

String strCondNo
条件レコード番号

strChangeId

String strChangeId
変更タイプ(U、I、E、D)

coIndex

int coIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPckgNo

String strPckgNo
パッケージ番号

strLineNo

String strLineNo
制限の内部明細番号

strConNumber

String strConNumber
基本契約番号

strConItem

String strConItem
明細番号、契約

strLimit

String strLimit
全体制限

strNoLimit

String strNoLimit
制限なし

strPriceChg

String strPriceChg
入力シートの価格変更

strShortText

String strShortText
テキスト 1 (短)

strDeleteInd

String strDeleteInd
削除フラグ

clIndex

int clIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.ContractService は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPckgNo

String strPckgNo
パッケージ番号

strLineNo

String strLineNo
内部明細番号

strExtLine

String strExtLine
明細番号

strOutlLevel

String strOutlLevel
グループの階層レベル

strOutlNo

String strOutlNo
アウトラインレベル

strOutlInd

String strOutlInd
区分: 出力行

strSubpckgNo

String strSubpckgNo
サブパッケージ番号

strService

String strService
活動番号

strServType

String strServType
サービスタイプのテキスト (短)

strEdition

String strEdition
サービスタイプのバージョン

strSscItem

String strSscItem
標準サービスカタログ: 明細

strExtServ

String strExtServ
仕入先のサービス番号

strQuantity

String strQuantity
+/- 記号あり/なし数量

strBaseUom

String strBaseUom
基本数量単位

strUomIso

String strUomIso
単位の ISO コード

strOvfTol

String strOvfTol
超過許容値

strOvfUnlim

String strOvfUnlim
契約外サービス制限なし

strPriceUnit

String strPriceUnit
価格単位

strGrPrice

String strGrPrice
基準額

strFromLine

String strFromLine
下限

strToLine

String strToLine
上限

strShortText

String strShortText
テキスト(短)

strDistrib

String strDistrib
複数勘定設定の配賦区分

strPersNo

String strPersNo
従業員番号

strWagetype

String strWagetype
ウェイジタイプ

strPlnPckg

String strPlnPckg
パッケージ番号供給元一覧

strPlnLine

String strPlnLine
入力: 計画梱包明細行

strConPckg

String strConPckg
入力: 基本契約の計画外

strConLine

String strConLine
入力: 基本契約の計画外

strTmpPckg

String strTmpPckg
入力: モデル仕様からの計画外サービス

strTmpLine

String strTmpLine
入力: モデル仕様からの計画外サービス

strSscLim

String strSscLim
標準サービスカタログ制限参照のサービス行

strLimitLine

String strLimitLine
入力: 計画外、明細制限

strTargetVal

String strTargetVal
目標値

strBaslineNo

String strBaslineNo
代替: 基本明細参照

strBasicLine

String strBasicLine
基本明細

strAlternat

String strAlternat
代替明細

strBidder

String strBidder
入札者の明細

strSuppLine

String strSuppLine
補足明細

strOpenQty

String strOpenQty
未処理数量のある明細

strInform

String strInform
情報行

strBlanket

String strBlanket
包括明細

strEventual

String strEventual
偶発的明細

strTaxCode

String strTaxCode
消費税コード

strTaxjurcode

String strTaxjurcode
税計算管轄コード - 税管轄コード

strPriceChg

String strPriceChg
入力シートの価格変更

strMatlGroup

String strMatlGroup
品目グループ

strDate

String strDate
日付

strBegintime

String strBegintime
開始時刻

strEndtime

String strEndtime
終了時刻

strExtpersNo

String strExtpersNo
外部従業員番号

strFormula

String strFormula
計算式番号

strFormVal1

String strFormVal1
計算式値

strFormVal2

String strFormVal2
計算式値

strFormVal3

String strFormVal3
計算式値

strFormVal4

String strFormVal4
計算式値

strFormVal5

String strFormVal5
計算式値

strUserf1Num

String strUserf1Num
ユーザ定義項目

strUserf2Num

String strUserf2Num
ユーザ定義項目

strUserf1Txt

String strUserf1Txt
ユーザ定義項目

strUserf2Txt

String strUserf2Txt
ユーザ定義項目

strHiLineNo

String strHiLineNo
上位階層明細番号

strExtrefkey

String strExtrefkey
サービスの外部参照キー

strDeleteInd

String strDeleteInd
削除フラグ

csIndex

int csIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPckgNo

String strPckgNo
パッケージ番号

strLineNo

String strLineNo
明細行番号

strSernoLine

String strSernoLine
勘定コード設定のシリアル番号、サービス明細

strPercentage

String strPercentage
勘定設定金額配賦のパーセント

strSerialNo

String strSerialNo
勘定設定の連続番号

strQuantity

String strQuantity
+/- 記号あり/なし数量

strNetValue

String strNetValue
明細の正味額

saIndex

int saIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText は PurchaseText を拡張し、Serializable を実装しています

直列化されたフィールド

strPckgNo

String strPckgNo
パッケージ番号

strLineNo

String strLineNo
内部明細番号

strFormatCol

String strFormatCol
タグ列

クラス jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoItem

String strPoItem
購買伝票の明細番号

strAddrNo

String strAddrNo
アドレス番号

strFormofaddr

String strFormofaddr
敬称テキスト

strName

String strName
名称 1

strName2

String strName2
名称 2

strName3

String strName3
名称 3

strName4

String strName4
名称 4

strCOName

String strCOName
気付

strCity

String strCity
市区町村

strDistrict

String strDistrict
所在地

strCityNo

String strCityNo
市区町村/地名ファイルの市区町村コード

strPostlCod1

String strPostlCod1
市区町村の郵便番号

strPostlCod2

String strPostlCod2
私書箱郵便番号

strPostlCod3

String strPostlCod3
会社郵便番号 (大規模なユーザ用)

strPoBox

String strPoBox
私書箱

strPoBoxCit

String strPoBoxCit
私書箱住所

strDelivDis

String strDelivDis
郵便配達地域

strStreet

String strStreet
地名

strStreetNo

String strStreetNo
市区町村/地名ファイルの地名コード

strStrAbbr

String strStrAbbr
地名の略称 (例: スペイン)

strHouseNo

String strHouseNo
番地-号

strStrSuppl1

String strStrSuppl1
地名 2

strStrSuppl2

String strStrSuppl2
地名 3

strLocation

String strLocation
地名 5

strBuilding

String strBuilding
旧: 建物 (番号または略称)

strFloor

String strFloor
建物の階

strRoomNo

String strRoomNo
部屋/アパート番号

strCountry

String strCountry
国コード

strLangu

String strLangu
言語キー

strRegion

String strRegion
地域 (都道府県)

strSort1

String strSort1
検索条件 1

strSort2

String strSort2
検索条件 2

strTimeZone

String strTimeZone
アドレスタイムゾーン

strTaxjurcode

String strTaxjurcode
税管轄コード

strAdrNotes

String strAdrNotes
住所注記

strCommType

String strCommType
通信方法 (キー) (アドレス管理)

strTel1Numbr

String strTel1Numbr
第一電話番号: ダイヤルコード + 番号

strTel1Ext

String strTel1Ext
第 1 電話番号: 内線

strFaxNumber

String strFaxNumber
第一 FAX 番号: ダイヤルコード + 番号

strFaxExtens

String strFaxExtens
第一 FAX 番号: 内線

strStreetLng

String strStreetLng
地名

strDistrctNo

String strDistrctNo
市区町村/地名ファイルの所在地コード

strChckstatus

String strChckstatus
市区町村ファイルテストステータス

strPboxcitNo

String strPboxcitNo
市区町村私書箱コード (市ファイル)

strTranspzone

String strTranspzone
商品の納入区域

strHouseNo2

String strHouseNo2
番地補足

strEMail

String strEMail
電子メールアドレス

strStrSuppl3

String strStrSuppl3
地名 4

strTitle

String strTitle
タイトル (敬称)

strCountryiso

String strCountryiso
ISO 国コード

strLanguIso

String strLanguIso
ISO 639 準拠の言語

strBuildLong

String strBuildLong
建物 (番号またはコード)

strRegiogroup

String strRegiogroup
地域構造グループ化

deIndex

int deIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection は Selection を拡張し、Serializable を実装しています

直列化されたフィールド

strDistrChanLow

String strDistrChanLow
流通チャネルの範囲開始

strDistrChanHigh

String strDistrChanHigh
流通チャネルの範囲終了

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strTransportMode

String strTransportMode
貿易管理の輸送モード

strCustoms

String strCustoms
税関: 税関 (出国時)

クラス jp.co.intra_mart.foundation.sap.module.purchase.ExportItem は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoItem

String strPoItem
購買伝票の明細番号

strBusinessTransactionType

String strBusinessTransactionType
貿易管理の取引タイプ

strExportImportProcedure

String strExportImportProcedure
貿易の輸出入手続

strCountryori

String strCountryori
品目の原産国

strCountryoriIso

String strCountryoriIso
ISO 国コード

strRegionorig

String strRegionorig
品目の原産地 (非特恵対象地区の原産)

strCommCode

String strCommCode
貿易: 統計品目コード/輸入コード番号

strShippingCountry

String strShippingCountry
貿易: 出荷国

strShippingCountryIso

String strShippingCountryIso
ISO 国コード

eiIndex

int eiIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.Extension は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strStructure

String strStructure
BAPI テーブル拡張の構造名

strValuepart1

String strValuepart1
BAPI 拡張パラメータのデータ部分

strValuepart2

String strValuepart2
BAPI 拡張パラメータのデータ部分

strValuepart3

String strValuepart3
BAPI 拡張パラメータのデータ部分

strValuepart4

String strValuepart4
BAPI 拡張パラメータのデータ部分

exIndex

int exIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController は GoodsMvtCreate を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController は GoodsMvtGetItems を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.Limits は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPckgNo

String strPckgNo
パッケージ番号

strLimit

String strLimit
全体制限

strNoLimit

String strNoLimit
制限なし

strExpValue

String strExpValue
見込金額

strSscExist

String strSscExist
サービスタイプの制限

strConExist

String strConExist
基本契約明細の制限

strTmpExist

String strTmpExist
サービスパッケージの制限

strPriceChg

String strPriceChg
入力シートの価格変更

strFreeLimit

String strFreeLimit
自由制限

strNoFrlimit

String strNoFrlimit
制限なし

strServType

String strServType
サービスタイプのテキスト (短)

strEdition

String strEdition
サービスタイプのバージョン

strSscLimit

String strSscLimit
サービスタイプの金額制限

strSscNolim

String strSscNolim
標準サービスタイプの制限なし

strSscPrschg

String strSscPrschg
入力シートの価格変更

strSscPerc

String strSscPerc
価格決定率

strTmpNumber

String strTmpNumber
モデルサービス明細セット番号

strTmpLimit

String strTmpLimit
モデルサービス明細制限

strTmpNolim

String strTmpNolim
モデル仕様の制限なし

strTmpPrschg

String strTmpPrschg
入力シートの価格変更

strTmpPerc

String strTmpPerc
価格決定率

strContPerc

String strContPerc
価格決定率

liIndex

int liIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strManuMat

String strManuMat
製造者製品コード

strMfrNo

String strMfrNo
製造者番号

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController は MaterialAvailability を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController は MaterialGetAll を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strMaxRows

String strMaxRows
選択予定品目の最大数

matnrSelectionList

ArrayList matnrSelectionList
品目コードの選択オプション一覧

materialShortDescselList

ArrayList materialShortDescselList
品目テキストの選択オプション一覧

manufacturerPartNumbList

ArrayList manufacturerPartNumbList
製造業者と製造者製品コード一覧

plantSelectionList

ArrayList plantSelectionList
プラントの選択オプション一覧

storageLocationselectList

ArrayList storageLocationselectList
保管場所の選択オプション一覧

salesOrganisationSelectionList

ArrayList salesOrganisationSelectionList
販売組織の選択オプション一覧

distributionChannelSelectionList

ArrayList distributionChannelSelectionList
流通チャネルの選択オプション一覧

matnrListList

ArrayList matnrListList
品目コードと品目テキスト一覧

クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController は MaterialGetList を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController は MaterialSaveReplica を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel は Selection を拡張し、Serializable を実装しています

直列化されたフィールド

strDescrLow

String strDescrLow
開始品目テキスト

strDescrHigh

String strDescrHigh
品目テキスト

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.MatnrList は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strMaterial

String strMaterial
品目コード

strMatlDesc

String strMatlDesc
品目テキスト

strMaterialExternal

String strMaterialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

strMaterialGuid

String strMaterialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

strMaterialVersion

String strMaterialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

クラス jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection は Selection を拡張し、Serializable を実装しています

直列化されたフィールド

strMatnrLow

String strMatnrLow
開始品目コード

strMatnrHigh

String strMatnrHigh
終了品目コード

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamItem は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamVendorAddress は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.Partner は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPartnerdesc

String strPartnerdesc
言語別取引先機能テキスト

strLangu

String strLangu
言語キー

strBuspartno

String strBuspartno
取引先の仕入先マスタコード

paIndex

int paIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection は Selection を拡張し、Serializable を実装しています

直列化されたフィールド

strPlantLow

String strPlantLow
対象プラント 開始

strPlantHigh

String strPlantHigh
対象プラント 終了

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoItem

String strPoItem
購買伝票の明細番号

strSerialNo

String strSerialNo
勘定設定の連続番号

strFieldname

String strFieldname
項目名

strValue

String strValue
CO-PA 特性値

prIndex

int prIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoItem

String strPoItem
購買伝票の明細番号

strSerialNo

String strSerialNo
勘定設定の連続番号

strDeleteInd

String strDeleteInd
削除フラグ: 購買伝票勘定設定

strCreatDate

String strCreatDate
レコード登録日

strQuantity

String strQuantity
数量

strDistrPerc

String strDistrPerc
配賦率 % (複数勘定設定)

strNetValue

String strNetValue
BAPI の通貨額 (小数点以下９桁)

strGlAccount

String strGlAccount
G/L 勘定コード

strBusArea

String strBusArea
事業領域

strCostcenter

String strCostcenter
原価センタ

strSdDoc

String strSdDoc
販売管理伝票番号

strItmNumber

String strItmNumber
販売伝票明細

strSchedLine

String strSchedLine
納入日程行

strAssetNo

String strAssetNo
資産番号

strSubNumber

String strSubNumber
資産補助番号

strOrderid

String strOrderid
指図番号

strGrRcpt

String strGrRcpt
受領者

strUnloadPt

String strUnloadPt
荷渡ポイント

strCoArea

String strCoArea
管理領域

strCostobject

String strCostobject
原価対象

strProfitCtr

String strProfitCtr
利益センタ

strWbsElement

String strWbsElement
WBS 要素

strNetwork

String strNetwork
勘定割当のネットワーク番号

strRlEstKey

String strRlEstKey
不動産管理対象の内部キー

strPartAcct

String strPartAcct
取引先勘定コード

strCmmtItem

String strCmmtItem
資金予算コード

strRecInd

String strRecInd
リカバリフラグ

strFundsCtr

String strFundsCtr
予算センタ

strFund

String strFund
会計区分

strFuncArea

String strFuncArea
機能領域

strRefDate

String strRefDate
決済の参照日付

strTaxCode

String strTaxCode
消費税コード

strTaxjurcode

String strTaxjurcode
税計算管轄コード - 税管轄コード

strNondItax

String strNondItax
BAPI の通貨額 (小数点以下９桁)

strActtype

String strActtype
活動タイプ

strCoBusproc

String strCoBusproc
業務プロセス

strResDoc

String strResDoc
用途指定予算の伝票番号

strResItem

String strResItem
用途指定予算: 伝票明細

strActivity

String strActivity
作業番号

strGrantNbr

String strGrantNbr
補助金

strCmmtItemLong

String strCmmtItemLong
資金予算コード

strFuncAreaLong

String strFuncAreaLong
機能領域

acIndex

int acIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strRelGroup

String strRelGroup
承認グループ

strRelCode

String strRelCode
承認コード

strItemsForRelease

String strItemsForRelease
区分: 承認待ち購買発注のみ照会

purchaseHeadersList

ArrayList purchaseHeadersList
ヘッダ一覧

purchaseItemsList

ArrayList purchaseItemsList
明細一覧

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

purchaseGetItemSrel

PurchaseGetItemSrel purchaseGetItemSrel
購買承認対象一覧情報クラス

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoNumber

String strPoNumber
購買伝票番号

strDocType

String strDocType
伝票タイプ

strDeleteInd

String strDeleteInd
削除フラグ

strStatus

String strStatus
ステータス

strCreatedBy

String strCreatedBy
登録者名

strItemIntvl

String strItemIntvl
明細番号間隔

strVendor

String strVendor
仕入先勘定コード

strPmnttrms

String strPmnttrms
支払条件キー

strDscnt1To

String strDscnt1To
現金割引日数1

strDscnt2To

String strDscnt2To
現金割引日数2

strDscnt3To

String strDscnt3To
現金割引日数3

strPurchOrg

String strPurchOrg
購買組織

strPurGroup

String strPurGroup
購買グループ

strCurrency

String strCurrency
通貨コード

strCurrencyIso

String strCurrencyIso
ISO通貨コード

strExchRate

String strExchRate
換算レート

strExRateFx

String strExRateFx
換算レート固定区分

strDocDate

String strDocDate
購買伝票日付

strVperStart

String strVperStart
有効期間開始日

strVperEnd

String strVperEnd
有効期間終了日

strWarranty

String strWarranty
保証日

strQuotation

String strQuotation
見積番号

strQuotDate

String strQuotDate
見積提出日

strRef1

String strRef1
得意先/仕入先の内部参照コード

strSalesPers

String strSalesPers
仕入先営業担当者

strTelephone

String strTelephone
仕入先電話番号

strSupplVend

String strSupplVend
供給仕入先

strCustomer

String strCustomer
得意先コード1

strAgreement

String strAgreement
購買契約番号

strGrMessage

String strGrMessage
入庫メッセージ区分

strSupplPlnt

String strSupplPlnt
在庫転送オーダーにおける供給(出庫)プラント

strIncoterms1

String strIncoterms1
インコタームズ1

strIncoterms2

String strIncoterms2
インコタームズ2

strDiffInv

String strDiffInv
仕入先と請求元が異なる場合の請求書元コード

strOurRef

String strOurRef
社内参照番号

strLogsystem

String strLogsystem
論理システム

strSubitemint

String strSubitemint
副明細の明細間隔

strRelStatus

String strRelStatus
承認状況

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost は PurchaseHeader を拡張し、Serializable を実装しています

直列化されたフィールド

strCompCode

String strCompCode
会社コード

strCreatDate

String strCreatDate
レコード登録日

strLangu

String strLangu
言語キー

strLanguIso

String strLanguIso
言語キーの ISO コード

strDsctPct1

String strDsctPct1
割引率 1

strDsctPct2

String strDsctPct2
割引率 2

strCollectNo

String strCollectNo
一括番号

strPoRelInd

String strPoRelInd
承認区分: 購買伝票

strVatCntry

String strVatCntry
売上税 ID 番号国

strVatCntryIso

String strVatCntryIso
消費税登録番号の ISO 国コード

strReasonCancel

String strReasonCancel
取消理由

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders は PurchaseHeader を拡張し、Serializable を実装しています

直列化されたフィールド

strCoCode

String strCoCode
会社コード

strDocCat

String strDocCat
購買伝票カテゴリ

strCntrlInd

String strCntrlInd
購買伝票タイプに対する管理区分

strCreatedOn

String strCreatedOn
レコード登録日

strLastItem

String strLastItem
最終明細番号

strLanguage

String strLanguage
言語キー

strCashDisc1

String strCashDisc1
割引率 1

strCashDisc2

String strCashDisc2
割引率 2

strApplicBy

String strApplicBy
見積提出期限

strQuotDead

String strQuotDead
見積提出期限

strBindgPer

String strBindgPer
見積有効期間

strBidinvNo

String strBidinvNo
見積管理番号

strRejReason

String strRejReason
見積および受注の拒否理由

strComplDlv

String strComplDlv
全購買発注に対する一括納入指定

strRcvgVend

String strRcvgVend
未使用項目

strTargetVal

String strTargetVal
累積計画金額

strCollNo

String strCollNo
一括番号

strDocCond

String strDocCond
伝票条件番号

strProcedure

String strProcedure
決定表 (価格設定/出力管理/勘定設定/原価計算など)

strUpdateGrp

String strUpdateGrp
統計更新の更新グループ

strExportNo

String strExportNo
貿易データ番号: MM/SD 伝票

strMastCond

String strMastCond
期間依存条件伝票

strRelGroup

String strRelGroup
承認グループ

strRelStrat

String strRelStrat
承認方針

strRelInd

String strRelInd
承認区分: 購買伝票

strSubjToR

String strSubjToR
承認未完了

strTaxrCntry

String strTaxrCntry
納税申告書の国

strSchedInd

String strSchedInd
分納契約のリリース伝票区分

strVendName

String strVendName
名称 1

strExchRateCm

String strExchRateCm
間接呼び値換算レート

strHold

String strHold
購買発注の不完全

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoItem

String strPoItem
明細番号

strDeleteInd

String strDeleteInd
購買伝票の削除フラグ

strShortText

String strShortText
品目コードテキスト（短）

strMaterial

String strMaterial
品目コード

strMaterialExternal

String strMaterialExternal
品目コード（長）

strMaterialGuid

String strMaterialGuid
品目コードの外部GUID

strMaterialVersion

String strMaterialVersion
品目コードのバージョン番号

strPlant

String strPlant
プラント

strTrackingno

String strTrackingno
購買依頼追跡番号

strInfoRec

String strInfoRec
購買情報番号

strVendMat

String strVendMat
仕入先が使用している品目コード

strPoUnitIso

String strPoUnitIso
ISOコードによる発注単位

strOrderprUn

String strOrderprUn
購買発注価格単位

strOrderprUnIso

String strOrderprUnIso
購買発注価格のISOコード

strConvNum1

String strConvNum1
購買価格単位から購買発注単位への変換分子

strConvDen1

String strConvDen1
購買価格単位から購買発注単位への変換分母

strNetPrice

String strNetPrice
通貨額

strPriceUnit

String strPriceUnit
価格単位

strTaxCode

String strTaxCode
消費税コード

strQualInsp

String strQualInsp
在庫タイプ

strValType

String strValType
評価タイプ

strNoMoreGr

String strNoMoreGr
納入完了区分

strItemCat

String strItemCat
購買伝票の明細カテゴリ

strAcctasscat

String strAcctasscat
勘定設定カテゴリ

strDistrib

String strDistrib
複数勘定設定の配賦区分

strPartInv

String strPartInv
一部請求区分

strAcknReqd

String strAcknReqd
購買発注請求書依頼

strAgreement

String strAgreement
購買契約番号

strAgmtItem

String strAgmtItem
購買契約の明細番号

strShipping

String strShipping
出荷指示

strPlanDel

String strPlanDel
予定納入日数

strKanbanInd

String strKanbanInd
かんばん区分

strRetItem

String strRetItem
返品明細

strAtRelev

String strAtRelev
適当テーブル関連

strPreqName

String strPreqName
購買依頼者名/要求者名

strPckgNo

String strPckgNo
パッケージ番号

strNoRounding

String strNoRounding
購買発注明細での非表示丸め

strPoPrice

String strPoPrice
価格採用区分

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost は PurchaseItem を拡張し、Serializable を実装しています

直列化されたフィールド

strEmaterial

String strEmaterial
品目コード

strEmaterialExternal

String strEmaterialExternal
品目コード（長）

strEmaterialGuid

String strEmaterialGuid
品目コードの外部GUID

strEmaterialVersion

String strEmaterialVersion
品目コードのバージョン番号

strStgeLoc

String strStgeLoc
保管場所

strMatlGroup

String strMatlGroup
品目グループ

strQuantity

String strQuantity
購買発注数量

strPoUnit

String strPoUnit
発注単位

strGrPrTime

String strGrPrTime
入庫処理日数

strBonGrp1

String strBonGrp1
決済グループ1

strInfoUpd

String strInfoUpd
購買情報更新区分

strPrntPrice

String strPrntPrice
価格印刷

strEstPrice

String strEstPrice
概算価格区分

strReminder1

String strReminder1
第一回催促状/督促状の日数

strReminder2

String strReminder2
第二回催促状/督促状の日数

strReminder3

String strReminder3
第三回催促状/督促状の日数

strOverDlvTol

String strOverDlvTol
過剰納入許容範囲

strUnlimitedDlv

String strUnlimitedDlv
区分: 無制限過剰納入可能

strUnderDlvTol

String strUnderDlvTol
不足納入許容範囲リミット

strFinalInv

String strFinalInv
請求書処理完了区分

strGrInd

String strGrInd
入庫区分

strGrNonVal

String strGrNonVal
非評価入庫

strIrInd

String strIrInd
請求書受領区分

strFreeItem

String strFreeItem
無償明細

strGrBasediv

String strGrBasediv
入庫基準の請求書照合区分

strAcknowlNo

String strAcknowlNo
購買発注請書番号

strCustomer

String strCustomer
得意先コード

strCondGroup

String strCondGroup
仕入先条件グループ

strNoDisct

String strNoDisct
現金値引対象外明細

strNetWeight

String strNetWeight
正味重量

strWeightunit

String strWeightunit
重量単位

strWeightunitIso

String strWeightunitIso
重量単位のISOコード

strTaxjurcode

String strTaxjurcode
税計算管轄コード - 税管轄コード

strCtrlKey

String strCtrlKey
調達における品質管理の管理キー

strConfCtrl

String strConfCtrl
確認管理キー

strRevLev

String strRevLev
改訂レベル

strFund

String strFund
会計区分

strFundsCtr

String strFundsCtr
予算センタ

strCmmtItem

String strCmmtItem
資金予算コード

strPricedate

String strPricedate
価格設定日カテゴリ (価格設定日管理)

strPriceDate

String strPriceDate
価格設定日

strGrossWt

String strGrossWt
総重量

strVolume

String strVolume
容積

strVolumeunit

String strVolumeunit
容積単位

strVolumeunitIso

String strVolumeunitIso
ISO コードでの容積単位

strIncoterms1

String strIncoterms1
インコタームズ (1)

strIncoterms2

String strIncoterms2
インコタームズ 2

strPreVendor

String strPreVendor
製造元/販売元

strVendPart

String strVendPart
仕入先部門

strHlItem

String strHlItem
購買伝票中の上位明細

strGrToDate

String strGrToDate
納入最終期限

strSuppVendor

String strSuppVendor
供給仕入先/仕入入庫

strScVendor

String strScVendor
外注仕入先

strErs

String strErs
ERS（入庫/請求自動決済）

strRPromo

String strRPromo
プロモーション

strPoints

String strPoints
リベートポイント数

strPointUnit

String strPointUnit
ポイント単位

strPointUnitIso

String strPointUnitIso
ポイント単位の ISO コード

strSeason

String strSeason
季節カテゴリ

strSeasonYr

String strSeasonYr
シーズン年度

strBonGrp2

String strBonGrp2
決済グループ 2 (リベート決済、購買)

strBonGrp3

String strBonGrp3
決済グループ 3 (リベート決済、購買)

strSettItem

String strSettItem
リベート (期末) 決済対象の明細

strMinremlife

String strMinremlife
最低有効期間残

strRfqNo

String strRfqNo
見積依頼番号

strRfqItem

String strRfqItem
見積依頼明細番号

strPreqNo

String strPreqNo
購買依頼番号

strPreqItem

String strPreqItem
購買依頼の明細番号

strRefDoc

String strRefDoc
参照伝票番号

strRefItem

String strRefItem
参照伝票の明細

strSiCat

String strSiCat
補助明細カテゴリ、購買伝票

strOrderReason

String strOrderReason
発注理由

strBrasNbm

String strBrasNbm
Brazilian NCM Code

strMatlUsage

String strMatlUsage
品目の用途

strMatOrigin

String strMatOrigin
品目の原産地

strInHouse

String strInHouse
内部生産

strIndus3

String strIndus3
品目 CFOP カテゴリ

strInfIndex

String strInfIndex
インフレーション指数

strUntilDate

String strUntilDate
インフレーション指数日付

strDelivCompl

String strDelivCompl
出荷完了 区分

strPartDeliv

String strPartDeliv
明細レベルでの分割納入 (在庫転送)

strShipBlocked

String strShipBlocked
SD 出荷伝票の明細ブロック

strPeriodIndExpirationDate

String strPeriodIndExpirationDate
有効期間期限日の期間区分

strIntObjNo

String strIntObjNo
選定 (内部オブジェクト番号)

strBatch

String strBatch
ロット番号

strVendrbatch

String strVendrbatch
仕入先ロット番号

strCalctype

String strCalctype
価格設定タイプ

strGrantNbr

String strGrantNbr
補助金

strCmmtItemLong

String strCmmtItemLong
資金予算コード

strFuncAreaLong

String strFuncAreaLong
機能領域

strSupplStloc

String strSupplStloc
出庫保管場所: 在庫転送オーダー

glIndex

int glIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems は PurchaseItem を拡張し、Serializable を実装しています

直列化されたフィールド

strPoNumber

String strPoNumber
購買伝票番号

strAddress

String strAddress
住所

strPurMat

String strPurMat
品目コード

strStoreLoc

String strStoreLoc
保管場所

strMatGrp

String strMatGrp
品目グループ

strAllocTbl

String strAllocTbl
商品配分表番号

strAtItem

String strAtItem
割当テーブルの明細番号

strUnit

String strUnit
発注単位

strPromotion

String strPromotion
プロモーション

strManufProf

String strManufProf
製造者製品プロファイル

strManuMat

String strManuMat
製造者製品コード

strMfrNo

String strMfrNo
製造者番号

strMfrNoExt

String strMfrNoExt
外部製造者コード名または番号

strItemCatExt

String strItemCatExt
購買伝票の明細カテゴリ

strDispQuan

String strDispQuan
購買発注数量: 表示目的全納入日程合計

strPurMatExternal

String strPurMatExternal
項目 PURMAT の品目コード (長) (今後のリリースで開発)

strPurMatGuid

String strPurMatGuid
項目 PURMAT の外部 GUID (今後のリリースで開発)

strPurMatVersion

String strPurMatVersion
項目 PURMAT のバージョン番号 (今後のリリースで開発)

strPrClosed

String strPrClosed
購買依頼処理済

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

poNumber

String poNumber
購買伝票番号

testRun

String testRun
テスト区分

memoryUnComplete

String memoryUnComplete
エラーがある場合に購買発注を保留する区分

memoryComplete

String memoryComplete
エラーがない場合に購買発注を保留する区分

noMessaging

String noMessaging
出力決定なし区分

noMessageReq

String noMessageReq
メッセージ不要区分

noAuthority

String noAuthority
権限チェックなし区分

noPriceFromPo

String noPriceFromPo
最終伝票からの価格転送なし区分

documentHeader

PurchaseHeaderPost documentHeader
伝票ヘッダ

supplierInfo

VendorAddress supplierInfo
仕入先住所

exportHeader

ExportHeader exportHeader
貿易管理ヘッダ

versions

Versions versions
バージョン管理

purchaseItemPostList

ArrayList purchaseItemPostList
明細一覧

deliveryAddressList

ArrayList deliveryAddressList
入荷伝票アドレス一覧

purchaseScheduleList

ArrayList purchaseScheduleList
納入日程一覧

purchaseAccountList

ArrayList purchaseAccountList
勘定設定一覧

profitSegmentList

ArrayList profitSegmentList
入出庫予定一覧

condHeaderList

ArrayList condHeaderList
条件ヘッダ一覧

condItemList

ArrayList condItemList
条件明細一覧

limitsList

ArrayList limitsList
外注制限一覧

contractLimitsList

ArrayList contractLimitsList
外注基本契約制限一覧

contractServiceList

ArrayList contractServiceList
外注サービス一覧

contractServiceAccountList

ArrayList contractServiceAccountList
外注サービス勘定設定一覧

contractServiceTextList

ArrayList contractServiceTextList
外注サービステキスト一覧

extensionList

ArrayList extensionList
拡張得意先項目一覧

exportItemList

ArrayList exportItemList
貿易管理明細一覧

headerTextList

ArrayList headerTextList
ヘッダテキスト一覧

itemTextList

ArrayList itemTextList
明細テキスト一覧

partnerList

ArrayList partnerList
取引先一覧

allVersionsList

ArrayList allVersionsList
全バージョン一覧

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController は PurchaseOrderPayPost を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController は PurchaseOrderPayPost を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

strPurchaseorder

String strPurchaseorder
購買発注番号

strPoRelCode

String strPoRelCode
承認コード

strUseExceptions

String strUseExceptions
例外メッセージ設定とエラーメッセージ出力

strRelStatusNew

String strRelStatusNew
返却承認状況

strRelIndicatorNew

String strRelIndicatorNew
返却規承認区分

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController は PurchaseRelease を拡張し、Serializable を実装しています

直列化されたフィールド

strRetCode

String strRetCode
リターン値、ABAP 命令後のリターン値

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController は PurchaseRelease を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoItem

String strPoItem
購買伝票の明細番号

strSchedLine

String strSchedLine
納入日程行

strDelDatcatExt

String strDelDatcatExt
納入期日カテゴリ

strDeliveryDate

String strDeliveryDate
納入期日

strQuantity

String strQuantity
計画数量

strDelivTime

String strDelivTime
納入期日における指定時間

strStatDate

String strStatDate
統計的納入期日

strPreqNo

String strPreqNo
購買依頼番号

strPreqItem

String strPreqItem
購買依頼の明細番号

strPoDate

String strPoDate
納入日程の購買発注日付

strRoutesched

String strRoutesched
輸送経路計画

strMsDate

String strMsDate
品目利用可能日

strMsTime

String strMsTime
品目供給ステージ (現地時刻: プラント参照)

strLoadDate

String strLoadDate
積載日付

strLoadTime

String strLoadTime
積載時刻 (現地時間: 出荷ポイント)

strTpDate

String strTpDate
輸送計画日付

strTpTime

String strTpTime
輸送計画 - 時間 (現地時間/出荷ポイント参照)

strGiDate

String strGiDate
出庫日付

strGiTime

String strGiTime
出庫時刻 (現地時間 - プラント参照)

strDeleteInd

String strDeleteInd
購買伝票の削除フラグ

scIndex

int scIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoNumber

String strPoNumber
購買伝票番号

strPoItem

String strPoItem
購買伝票の明細番号

strTextId

String strTextId
テキスト ID

strTextForm

String strTextForm
タグ列

strTextLine

String strTextLine
テキスト行

teIndex

int teIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection は Selection を拡張し、Serializable を実装しています

直列化されたフィールド

strSalesorgLow

String strSalesorgLow
販売組織の範囲開始

strSalesorgHigh

String strSalesorgHigh
販売組織の範囲終了

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.Selection は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strSign

String strSign
選択演算子 SIGN (テーブル範囲)

strOption

String strOption
選択演算子 OPTION (範囲テーブル)

クラス jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

stdIntNumList

StdMaterialGetIntNumberList stdIntNumList
品目コード割当済一覧

クラス jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect は Selection を拡張し、Serializable を実装しています

直列化されたフィールド

strStlocLow

String strStlocLow
開始保管場所

strStlocHigh

String strStlocHigh
終了保管場所

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strVendor

String strVendor
実行パラメータ(仕入先コード)

strCompode

String strCompode
実行パラメータ(会社コード)

generalDataInfo

GeneralDataInfo generalDataInfo
一般データ情報

companyDataInfo

CompanyDataInfo companyDataInfo
会社コード依存データ情報

bankDataInfoList

ArrayList bankDataInfoList
銀行データ情報

クラス jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strVendor

String strVendor
実行パラメータ(仕入先コード)

strCompCode

String strCompCode
実行パラメータ(会社コード)

checkReturn

String checkReturn
返却値

クラス jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

supplierDetail

SupplierDetail supplierDetail
仕入先マスタ詳細情報

クラス jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress は GeneralDataInfo を拡張し、Serializable を実装しています

直列化されたフィールド

strPoNumber

String strPoNumber
購買伝票番号

strAddrNo

String strAddrNo
アドレス番号

strCOName

String strCOName
気付

strCityNo

String strCityNo
市区町村/地名ファイルの市区町村コード

strPostlCod1

String strPostlCod1
市区町村の郵便番号

strPostlCod2

String strPostlCod2
私書箱郵便番号

strPostlCod3

String strPostlCod3
会社郵便番号 (大規模なユーザ用)

strPoBoxCit

String strPoBoxCit
私書箱住所

strDelivDis

String strDelivDis
郵便配達地域

strStreetNo

String strStreetNo
市区町村/地名ファイルの地名コード

strStrAbbr

String strStrAbbr
地名の略称 (例: スペイン)

strHouseNo

String strHouseNo
番地-号

strStrSuppl1

String strStrSuppl1
地名 2

strStrSuppl2

String strStrSuppl2
地名 3

strLocation

String strLocation
地名 5

strBuilding

String strBuilding
旧: 建物 (番号または略称)

strFloor

String strFloor
建物の階

strRoomNo

String strRoomNo
部屋/アパート番号

strSort1

String strSort1
検索条件 1

strSort2

String strSort2
検索条件 2

strTimeZone

String strTimeZone
アドレスタイムゾーン

strTaxjurcode

String strTaxjurcode
税管轄コード

strAdrNotes

String strAdrNotes
住所注記

strCommType

String strCommType
通信方法 (キー) (アドレス管理)

strTel1Numbr

String strTel1Numbr
第一電話番号: ダイヤルコード + 番号

strTel1Ext

String strTel1Ext
第 1 電話番号: 内線

strFaxNumber

String strFaxNumber
第一 FAX 番号: ダイヤルコード + 番号

strFaxExtens

String strFaxExtens
第一 FAX 番号: 内線

strStreetLng

String strStreetLng
地名

strDistrctNo

String strDistrctNo
市区町村/地名ファイルの所在地コード

strChckstatus

String strChckstatus
市区町村ファイルテストステータス

strPboxcitNo

String strPboxcitNo
市区町村私書箱コード (市ファイル)

strTranspzone

String strTranspzone
商品の納入区域

strHouseNo2

String strHouseNo2
番地補足

strEMail

String strEMail
電子メールアドレス

strStrSuppl3

String strStrSuppl3
地名 4

strTitle

String strTitle
タイトル (敬称)

strBuildLong

String strBuildLong
建物 (番号またはコード)

strRegiogroup

String strRegiogroup
地域構造グループ化

クラス jp.co.intra_mart.foundation.sap.module.purchase.Versions は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPostDate

String strPostDate
バージョンの転記日付

strCompleted

String strCompleted
ステータス "バージョン完了済"

strReason

String strReason
変更理由

strDescription

String strDescription
バージョンテキスト（長）

strReqBy

String strReqBy
変更を依頼した従業員

strReqByExt

String strReqByExt
バージョンの外部変更番号

strActivity

String strActivity
処理タイプ - R/3 Enterprise で使用不可能

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.common.model

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

indSector

String indSector
産業コード

matlType

String matlType
品目タイプ

createdOn

String createdOn
登録日付

createdBy

String createdBy
オブジェクト登録者名

lastChnge

String lastChnge
最終変更日付

changedBy

String changedBy
オブジェクトの変更者名

matStatus

String matStatus
品目更新完了ステータス

maintStat

String maintStat
更新ステータス

delFlag

String delFlag
クライアントレベルでの品目削除フラグ

matlGroup

String matlGroup
品目グループ

oldMatNo

String oldMatNo
旧品目コード

baseUom

String baseUom
基本数量単位

baseUomIso

String baseUomIso
ISO コードでの基本数量単位

poUnit

String poUnit
発注単位

poUnitIso

String poUnitIso
ISO コードによる発注単位

document

String document
文書番号 (文書管理システムによらない)

docType

String docType
文書タイプ (文書管理システムによらない)

docVers

String docVers
文書バージョン (文書管理システムによらない)

docFormat

String docFormat
文書のページ書式 (文書管理システムによらない)

docChgNo

String docChgNo
文書変更番号 (文書管理システム外)

pageNo

String pageNo
文書ページ番号 (文書管理システムによらない)

noSheets

String noSheets
文書枚数 (文書管理システムによらない)

prodMemo

String prodMemo
製造/検査メモ

pageformat

String pageformat
製造メモのページ書式

sizeDim

String sizeDim
サイズ/寸法

basicMatl

String basicMatl
主構成物質

stdDescr

String stdDescr
標準テキスト (ANSI、ISO など)

dsnOffice

String dsnOffice
研究室/設計室

purValkey

String purValkey
購買許容値キー

netWeight

String netWeight
正味重量

unitOfWt

String unitOfWt
重量単位

unitOfWtIso

String unitOfWtIso
ISO コードでの重量単位

container

String container
容器条件

storConds

String storConds
保管条件

tempConds

String tempConds
温度条件区分

transGrp

String transGrp
輸送グループ

hazMatNo

String hazMatNo
危険物コード

division

String division
製品部門

competitor

String competitor
競合会社

qtyGrGi

String qtyGrGi
数量: 印刷予定入出庫票数

procRule

String procRule
調達規則

supSource

String supSource
供給元

season

String season
季節カテゴリ

labelType

String labelType
ラベルタイプ

labelForm

String labelForm
ラベル書式

prodHier

String prodHier
品目階層

cadId

String cadId
CAD 区分

allowedWt

String allowedWt
許容梱包重量

packWtUn

String packWtUn
重量単位 (許容梱包重量)

packWtUnIso

String packWtUnIso
ISO コードでの重量単位 (許容梱包重量)

allwdVol

String allwdVol
許容梱包容積

packVoUn

String packVoUn
容積単位 (許容梱包容積)

packVoUnIso

String packVoUnIso
ISO コードでの容積単位 (許容梱包容積)

wtTolLt

String wtTolLt
荷役単位の重量超過許容量

volTolLt

String volTolLt
荷役単位の容積超過許容量

varOrdUn

String varOrdUn
可変購買発注単位有効

configured

String configured
選定可能品目

batchMgmt

String batchMgmt
ロット管理所要量区分

shMatTyp

String shMatTyp
梱包材タイプ

fillLevel

String fillLevel
最大レベル (容積別)

stackFact

String stackFact
山積係数

matGrpSm

String matGrpSm
品目グループ: 梱包材

authoritygroup

String authoritygroup
権限グループ

qmProcmnt

String qmProcmnt
調達における品質管理有効

catprofile

String catprofile
カタログプロファイル

minremlife

String minremlife
最低有効期間残

shelfLife

String shelfLife
総有効期間

storPct

String storPct
残存有効期間割合 %

confMatl

String confMatl
プラント共通選定可能品目

coProduct

String coProduct
区分: 連産品としても使用可能な品目

prRefMat

String prRefMat
価格設定参照品目

purStatus

String purStatus
プラント共通品目ステータス

salStatus

String salStatus
流通チェーン間品目ステータス

pvalidfrom

String pvalidfrom
プラント共通品目のステータス有効開始日付

svalidfrom

String svalidfrom
流通チェーン間品目ステータスの有効開始日付

envtRlvt

String envtRlvt
区分: 環境関連

prodAlloc

String prodAlloc
製品割当決定手順

qualDik

String qualDik
無償納入による割引対象品目

manuMat

String manuMat
製造者製品コード

mfrNo

String mfrNo
製造者番号

invMatNo

String invMatNo
会社固有 (内部) 在庫管理品目コード

manufProf

String manufProf
製造者製品プロファイル

hazmatprof

String hazmatprof
危険物インジケータプロファイル

highVisc

String highVisc
区分: 高粘性

looseorliq

String looseorliq
区分: バルク/液体

closedBox

String closedBox
完了した梱包材

appdBRec

String appdBRec
区分: バッチ製造記録の承認必須

matcmpllvl

String matcmpllvl
品目完了レベル

parEff

String parEff
有効性パラメータへの値割当/変更番号よりも優先

roundUpRuleExpirationDate

String roundUpRuleExpirationDate
有効期間期限日計算の丸め規則

periodIndExpirationDate

String periodIndExpirationDate
有効期間期限日の期間区分

prodCompositionOnPackaging

String prodCompositionOnPackaging
区分: 梱包材にプリントされた生産構造

itemCat

String itemCat
一般明細カテゴリグループ

hazMatNoExternal

String hazMatNoExternal
項目 HAZ_MAT_NO の品目コード (長) (今後のリリースで開発)

hazMatNoGuid

String hazMatNoGuid
項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)

hazMatNoVersion

String hazMatNoVersion
項目 HAZ_MAT_NO のバージョン番号 (今後のリリースで開発)

invMatNoExternal

String invMatNoExternal
項目 INV_MAT_NO の品目コード (長) (今後のリリースで開発)

invMatNoGuid

String invMatNoGuid
項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)

invMatNoVersion

String invMatNoVersion
項目 INV_MAT_NO のバージョン番号 (今後のリリースで開発)

materialFixed

String materialFixed
ロックされている品目

cmRelevanceFlag

String cmRelevanceFlag
構成管理関連

sledBbd

String sledBbd
有効期限

gtinVariant

String gtinVariant
グローバルトレード明細番号バリアント

serializationLevel

String serializationLevel
シリアル番号の指定レベル

plRefMat

String plRefMat
梱包方法が同じ品目の参照品目

extmatlgrp

String extmatlgrp
外部品目グループ

uomusage

String uomusage
使用数量単位

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList は ClientData を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

plant

String plant
プラント

foreProf

String foreProf
需要予測プロファイル

modelSi

String modelSi
モデル選択区分

modelSp

String modelSp
モデル選択方式

paramOpt

String paramOpt
パラメータ最適化用の区分

optimLev

String optimLev
最適化レベル

initialize

String initialize
初期化区分

foreModel

String foreModel
予測モデル

alphaFact

String alphaFact
アルファ係数使用による基本値の平滑化

betaFact

String betaFact
ベータ係数による傾向値平準化

gammaFact

String gammaFact
ガンマ係数使用の平滑化のための季節指数

deltaFact

String deltaFact
デルタ係数使用による MAD (絶対平均偏差) 平準化

tracklimit

String tracklimit
警告限界

foreDate

String foreDate
最終需要予測日

histVals

String histVals
履歴値の数

initPds

String initPds
初期化で使用する履歴値の数

seasonPds

String seasonPds
季節周期ごとの期間数

expostPds

String expostPds
事後的需要予測に含む履歴値の数

forePds

String forePds
需要予測期間

fixedPds

String fixedPds
固定期間

basicValue

String basicValue
基準値

basicValue1

String basicValue1
第二指図の基準値

basicValue2

String basicValue2
第二指図の基準値

basicValuePp

String basicValuePp
前期間の基準値

basicValuePp1

String basicValuePp1
前期間における第二指図の基準値

basicValuePp2

String basicValuePp2
前期間における第二指図の基準値

trendValue

String trendValue
傾向値

trendValuePp

String trendValuePp
前期間の傾向値

meanAbsolDev

String meanAbsolDev
絶対平均偏差 (MAD)

meanAbsolDevPp

String meanAbsolDevPp
前期間の平均絶対偏差

errorTotal

String errorTotal
エラー合計

errorTotalPp

String errorTotalPp
前期間のエラー合計

wtgGroup

String wtgGroup
加重グループ

coeffTheil

String coeffTheil
タイル係数

exceptList

String exceptList
例外メッセージバー

forecFlowCont

String forecFlowCont
予測フロー管理

periodInd

String periodInd
期間区分

fyVariant

String fyVariant
会計年度バリアント

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList は ForecastParameters を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader は Object を拡張し、Serializable を実装しています

直列化されたフィールド

docDate

String docDate
伝票の伝票日付

headerTxt

String headerTxt
伝票ヘッダテキスト

pstngDate

String pstngDate
伝票の転記日付

refDocNo

String refDocNo
参照伝票番号

refDocNoLong

String refDocNoLong
参照伝票番号 (依存性についてはテキスト長参照)

verGrGiSlip

String verGrGiSlip
入出庫票の印刷バ－ジョン

billOfLading

String billOfLading
入庫時に登録した B/L 番号

grGiSlipNo

String grGiSlipNo
入出庫票番号

prUname

String prUname
ユーザ名

verGrGiSlipx

String verGrGiSlipx
関連ユーザデータ項目の更新情報

extWms

String extWms
外部倉庫管理の転記の制御

billOfLadingLong

String billOfLadingLong
入庫の船荷証券番号 (依存: テキスト (長) 参照)

barCode

String barCode
バーコードエントリ

matDoc

String matDoc
入出庫伝票番号

docYear

String docYear
入出庫伝票年度

trEvType

String trEvType
トランザクション/イベントタイプ

entryDate

String entryDate
会計伝票登録日

entryTime

String entryTime
登録時刻

username

String username
ユーザ名

expimpNo

String expimpNo
貿易データ番号: MM/SD 伝票

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList は GoodsMvtHeader を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems は Object を拡張し、Serializable を実装しています

直列化されたフィールド

activity

String activity
作業番号

acttype

String acttype
活動タイプ

amountLc

String amountLc
マニュアル入力による転記金額 (国内通貨)

amountSv

String amountSv
外部入力による販売金額 (国内通貨)

assetNo

String assetNo
資産番号

batch

String batch
ロット番号

calcMotive

String calcMotive
計算区分

cmmtItem

String cmmtItem
資金予算コード

cmmtItemLong

String cmmtItemLong
資金予算コード

coBusproc

String coBusproc
業務プロセス

compShip

String compShip
出荷指示順守

costObj

String costObj
原価対象

costcenter

String costcenter
原価センタ

currency

String currency
通貨コード

currencyIso

String currencyIso
ISO 通貨コード

customer

String customer
得意先コード

docYear

String docYear
入出庫伝票年度

entryQnt

String entryQnt
入力単位での数量

entryUom

String entryUom
入力単位

entryUomIso

String entryUomIso
単位の ISO コード

expirydate

String expirydate
有効期間期限日

funcAreaLong

String funcAreaLong
機能領域

fund

String fund
会計区分

fundsCtr

String fundsCtr
予算センタ

grRcpt

String grRcpt
受領者

grantNbr

String grantNbr
補助金

itemText

String itemText
明細テキスト

lineDepth

String lineDepth
伝票での明細行階層レベル

lineId

String lineId
伝票明細行の一意 ID

matDoc

String matDoc
入出庫伝票番号

matdocItm

String matdocItm
入出庫伝票の明細

material

String material
品目コード

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

moveBatch

String moveBatch
入庫/出庫ロット

moveMat

String moveMat
入庫/出庫品目

moveMatExternal

String moveMatExternal
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)

moveMatGuid

String moveMatGuid
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)

moveMatVersion

String moveMatVersion
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)

movePlant

String movePlant
入庫/出庫プラント

moveReas

String moveReas
移動理由

moveStloc

String moveStloc
入庫/出庫保管場所

moveType

String moveType
移動タイプ (在庫管理)

moveValType

String moveValType
転送ロットの評価タイプ

mvtInd

String mvtInd
移動区分

network

String network
勘定割当のネットワーク番号

noMoreGr

String noMoreGr
納入完了 区分

orderItno

String orderItno
指図明細番号

orderid

String orderid
指図番号

orderprUn

String orderprUn
購買発注価格単位 (購買管理)

orderprUnIso

String orderprUnIso
単位の ISO コード

parentId

String parentId
1 レベル上位の行 ID

partAcct

String partAcct
取引先勘定コード

plant

String plant
プラント

poItem

String poItem
購買伝票の明細番号

poNumber

String poNumber
購買発注番号

poPrQnt

String poPrQnt
数量 (購買発注価格単位)

prodDate

String prodDate
ロット製造日付

profitCtr

String profitCtr
利益センタ

profitSegmNo

String profitSegmNo
収益性セグメント番号 (CO-PA)

refDate

String refDate
決済の参照日付

refDoc

String refDoc
参照伝票の伝票番号

refDocIt

String refDocIt
参照伝票の明細番号

refDocYr

String refDocYr
参照伝票の会計年度

resItem

String resItem
入出庫予定/従属所要量の明細番号

resType

String resType
レコードタイプ

reservNo

String reservNo
入出庫予定/従属所要量の番号

rlEstKey

String rlEstKey
不動産管理対象の内部キー

sOrdItem

String sOrdItem
受注明細番号

salesOrd

String salesOrd
受注伝票番号

schedLine

String schedLine
受注納入日程

shipping

String shipping
出荷指示

specStock

String specStock
特殊在庫区分

stckType

String stckType
在庫タイプ

stgeLoc

String stgeLoc
保管場所

subNumber

String subNumber
資産補助番号

supplVend

String supplVend
供給仕入先

unloadPt

String unloadPt
荷渡ポイント

valSOrdItem

String valSOrdItem
評価受注在庫の受注明細

valSalesOrd

String valSalesOrd
評価受注在庫の受注番号

valType

String valType
評価タイプ

valWbsElem

String valWbsElem
WBS 要素

vendor

String vendor
仕入先勘定コード

wbsElem

String wbsElem
WBS 要素

withdrawn

String withdrawn
入出庫予定に対する出庫完了

xAutoCre

String xAutoCre
自動登録済み明細

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

langu

String langu
言語キー

languIso

String languIso
ISO 639 準拠の言語

matlDesc

String matlDesc
品目テキスト

delFlag

String delFlag
データレコード削除 (テーブル繰返し)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

plant

String plant
プラント

plngMatl

String plngMatl
計画品目

plngPlant

String plngPlant
計画プラント

convfactor

String convfactor
計画品目用変換係数

plngMatlExternal

String plngMatlExternal
項目 PLNG_MATL の品目コード (長) (今後のリリースで開発)

plngMatlGuid

String plngMatlGuid
項目 PLNG_MATL の外部 GUID (今後のリリースで開発)

plngMatlVersion

String plngMatlVersion
項目 PLNG_MATL のバージョン番号 (今後のリリースで開発)

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList は PlanningData を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

plant

String plant
プラント

maintStat

String maintStat
更新ステータス

delFlag

String delFlag
プラントレベルでの品目削除フラグ

abcId

String abcId
ABC 区分

critPart

String critPart
区分: 重要品目

purGroup

String purGroup
購買グループ

issueUnit

String issueUnit
出庫単位

issueUnitIso

String issueUnitIso
ISO コードでの出庫単位

mrpprofile

String mrpprofile
品目: MRP プロファイル

mrpType

String mrpType
MRP タイプ

mrpCtrler

String mrpCtrler
MRP 管理者

plndDelry

String plndDelry
予定納入時間 (単位: 日)

grPrTime

String grPrTime
入庫処理日数

periodInd

String periodInd
期間区分

assyScrap

String assyScrap
組立不良率

lotsizekey

String lotsizekey
ロットサイズ (品目計画)

procType

String procType
調達タイプ

spproctype

String spproctype
特殊調達タイプ

reorderPt

String reorderPt
発注点

safetyStk

String safetyStk
安全在庫

minlotsize

String minlotsize
最小ロットサイズ

maxlotsize

String maxlotsize
最大ロットサイズ

fixedLot

String fixedLot
固定ロットサイズ

roundVal

String roundVal
購買発注数量の丸め数量

maxStock

String maxStock
最大在庫レベル

ordCosts

String ordCosts
発注原価 (BAPI インタフェース)

depReqId

String depReqId
個別所要量と包括所要量に対する従属所要量区分

storCosts

String storCosts
保管経費区分

altBomId

String altBomId
代替 BOM 選択の方法

discontinu

String discontinu
打切区分

effODay

String effODay
有効終了日

followUp

String followUp
フォローアップ品目

grpReqmts

String grpReqmts
区分: 所要量グループ化

mixedMrp

String mixedMrp
二重 MRP 区分

smKey

String smKey
日程計画余裕キー

backflush

String backflush
区分: バックフラッシュ

productionScheduler

String productionScheduler
製造計画担当

procTime

String procTime
処理時間

setuptime

String setuptime
段取時間と片付け時間

interop

String interop
移動時間

baseQty

String baseQty
基本数量

inhseprodt

String inhseprodt
内製日数

stgeperiod

String stgeperiod
最長保管期間

stgePdUn

String stgePdUn
最長保管期間の単位

stgePdUnIso

String stgePdUnIso
ISO コードでの最長保管期間単位

overTol

String overTol
過剰納入許容範囲リミット

unlimited

String unlimited
区分: 無制限過剰納入可能

underTol

String underTol
不足納入許容範囲リミット

replentime

String replentime
補充リードタイム合計 (稼動日数)

replacePt

String replacePt
取替部品

indPostToInspStock

String indPostToInspStock
品質検査中在庫への転記

ctrlKey

String ctrlKey
調達における品質管理の管理キー

docReqd

String docReqd
文書必須フラグ

loadinggrp

String loadinggrp
積載グループ

batchMgmt

String batchMgmt
ロット管理所要量区分

quotausage

String quotausage
供給量割当の使用

servLevel

String servLevel
サービスレベル

splitInd

String splitInd
分割区分

availcheck

String availcheck
利用可能在庫確認の確認グループ

fyVariant

String fyVariant
会計年度バリアント

corrFact

String corrFact
区分: 修正係数を需要予測値計算に使用

setupTime

String setupTime
出荷準備時間

baseQtyPlan

String baseQtyPlan
出荷の能力計画のための基本数量

shipProcTime

String shipProcTime
出荷処理時間

supSource

String supSource
供給元

autoPOrd

String autoPOrd
区分: "購買発注自動生成"

sourcelist

String sourcelist
区分: 供給元一覧必須

commCode

String commCode
貿易: 統計品目コード/輸入コード番号

countryori

String countryori
品目の原産国

countryoriIso

String countryoriIso
ISO コードでの品目原産国

regionorig

String regionorig
品目の原産地 (非特恵対象地区の原産)

commCoUn

String commCoUn
物品コード (貿易) の数量単位

commCoUnIso

String commCoUnIso
ISO コードによる物品コード (貿易管理) の数量単位

expimpgrp

String expimpgrp
輸出/輸入品目グループ

profitCtr

String profitCtr
利益センタ

ppcPlCal

String ppcPlCal
PPC 計画カレンダ

repManuf

String repManuf
区分: 繰返生産許可

plTiFnce

String plTiFnce
計画タイムフェンス

consummode

String consummode
消費モード

bwdCons

String bwdCons
消費期間: 後方

fwdCons

String fwdCons
消費期間: 前方

versionFlag

String versionFlag
バージョン区分

alternativeBom

String alternativeBom
代替 BOM

bomUsage

String bomUsage
BOM 用途

planlistgrp

String planlistgrp
タスクリストグループのキー

planlistcnt

String planlistcnt
グループカウンタ

lotSize

String lotSize
原価計算ロットサイズ

specprocty

String specprocty
原価計算の特殊調達タイプ

prodUnit

String prodUnit
製造単位

prodUnitIso

String prodUnitIso
製造単位 (ISO コード)

issStLoc

String issStLoc
出庫保管場所

mrpGroup

String mrpGroup
MRP グループ

compScrap

String compScrap
構成品目不良率

certType

String certType
証明書タイプ

cycleTime

String cycleTime
タクトタイム

inspSetupFlag

String inspSetupFlag
品目/プラントに QM 検査データ設定

covprofile

String covprofile
在庫日数プロファイル

ccPhInv

String ccPhInv
循環棚卸の実地棚卸区分

varianceKey

String varianceKey
差異キー

sernoProf

String sernoProf
シリアル番号プロファイル

psConfMat

String psConfMat
選定可能品目

repmanprof

String repmanprof
繰返生産プロファイル

negStocks

String negStocks
プラントにおけるマイナス在庫許可

qmRgmts

String qmRgmts
仕入先の必須 QM システム

plngCycle

String plngCycle
計画サイクル

roundProf

String roundProf
丸めプロファイル

refmatcons

String refmatcons
消費参照品目

refpltcons

String refpltcons
消費参照プラント

dToRefM

String dToRefM
消費データ参照の有効終了日

multRefM

String multRefM
消費データ参照品目の乗数

autoReset

String autoReset
予測モデル自動リセット

prefStatFlag

String prefStatFlag
区分: 特恵関税 - 輸出/輸入

exCertId

String exCertId
法令管理: 認定書区分

exCertNoNew

String exCertNoNew
非該当証明書番号 - 法令管理

exCertDt

String exCertDt
非該当証明書発行日

declStatFlag

String declStatFlag
区分: 仕入先申告あり

militId

String militId
ID: 武器

inspInt

String inspInt
次回再検査までの間隔

coProduct

String coProduct
区分: 連産品としても使用可能な品目

planStrgp

String planStrgp
計画方針グループ

slocExprc

String slocExprc
外部調達の初期保管場所

bulkMat

String bulkMat
区分: バルク品目

ccFixed

String ccFixed
循環棚卸区分固定

determGrp

String determGrp
在庫決定グループ

qmAuthgrp

String qmAuthgrp
QM における活動の品目権限グループ

taskListType

String taskListType
タスクリストタイプ

purStatus

String purStatus
プラント特有品目ステータス

prodprof

String prodprof
製造計画プロファイル

saftyTId

String saftyTId
安全時間区分（安全リードタイムあり/なし)

safetytime

String safetytime
安全時間 (稼動日数)

plordCtrl

String plordCtrl
アクション管理: 計画手配処理

batchentry

String batchentry
製造/プロセス指図でのロット入力設定

pvalidfrom

String pvalidfrom
プラント品目ステータス有効期間開始日

matfrgtgrp

String matfrgtgrp
品目運賃グループ

prodverscs

String prodverscs
原価計算を行う製造バージョン

matCfop

String matCfop
品目 CFOP カテゴリ

euListNo

String euListNo
CAP: CAP 製品一覧番号

euMatGrp

String euMatGrp
EEC 農産物政策: CAP 生産品グループ - 貿易

casNo

String casNo
CAS 番号： 薬事品目 - 貿易

prodcomNo

String prodcomNo
生産統計: 貿易における PRODCOM コード

ctrlCode

String ctrlCode
貿易: 消費税の管理コード

jitRelvt

String jitRelvt
区分: JIT 納入日程の関連明細

matGrpTrans

String matGrpTrans
段取替えマトリクスに対する品目のグループ

handlgGrp

String handlgGrp
ワークロード計算のロジスティクス処理グループ

supplyArea

String supplyArea
品目マスタレコードで提案される供給場所

fairShareRule

String fairShareRule
均等配賦ルール

pushDistrib

String pushDistrib
区分: プッシュ配賦

deployHoriz

String deployHoriz
供給分配期間の日数

minLotSize

String minLotSize
需要と供給を一致させるための最小ロットサイズ

maxLotSize

String maxLotSize
需要と供給を一致させるための最大ロットサイズ

fixLotSize

String fixLotSize
需要供給の一致に対する固定ロットサイズ

lotIncrement

String lotIncrement
需要と供給を一致させるためのロットサイズ増分

prodConvType

String prodConvType
生産値の変換タイプ

distrProf

String distrProf
サイトの商品の物流プロファイル

periodProfileSafetyTime

String periodProfileSafetyTime
安全時間の期間プロファイル

fxdPrice

String fxdPrice
固定価格連産品

availCheckAllProjSegments

String availCheckAllProjSegments
プロジェクト間品目区分

overallprf

String overallprf
指図変更管理の全体プロファイル

mrpRelevancyDepRequirements

String mrpRelevancyDepRequirements
従属所要量と MRP の関連性

mrpAreaExists

String mrpAreaExists
区分: MRP エリア登録済

minSafetyStk

String minSafetyStk
最小安全在庫

noCosting

String noCosting
原価計算なし

unitGroup

String unitGroup
数量単位グループ

followUpExternal

String followUpExternal
項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)

followUpGuid

String followUpGuid
項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)

followUpVersion

String followUpVersion
項目 FOLLOW_UP のバージョン番号 (今後のリリースで開発)

refmatconsExternal

String refmatconsExternal
項目 REFMATCONS の品目コード (長) (今後のリリースで開発)

refmatconsGuid

String refmatconsGuid
項目 REFMATCONS の外部 GUID (今後のリリースで開発)

refmatconsVersion

String refmatconsVersion
項目 REFMATCONS のバージョン番号 (今後のリリースで開発)

salesView

String salesView
販売ビュー

purchView

String purchView
購買管理ビュー

mrpView

String mrpView
資材所要量計画 (MRP) ビュー

forecastView

String forecastView
需要予測ビュー

workSchedView

String workSchedView
作業計画ビュー

prtView

String prtView
生産資源/治工具 (PRT) ビュー

storageView

String storageView
保管ビュー

warehouseView

String warehouseView
倉庫管理ビュー

qualityView

String qualityView
品質管理ビュー

accountView

String accountView
会計ビュー

costView

String costView
原価計算ビュー

rotationDate

String rotationDate
原価計算ビュー

originalBatchFlag

String originalBatchFlag
元ロット管理区分

originalBatchRefMaterial

String originalBatchRefMaterial
元ロットの参照品目

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList は PlantData を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

salesOrg

String salesOrg
販売組織

distrChan

String distrChan
流通チャネル

delFlag

String delFlag
区分: 流通チャネルレベルでの品目削除フラグ

matlStats

String matlStats
品目統計グループ

rebateGrp

String rebateGrp
取引量リベートグループ

commGroup

String commGroup
手数料グループ

cashDisc

String cashDisc
現金値引区分

salStatus

String salStatus
販売ビューからの品目ステータス

validFrom

String validFrom
流通チェーン別品目ステータスの有効期間開始日

minOrder

String minOrder
基本数量単位での最小受注数量

minDely

String minDely
納品書処理時の最小納入数量

minMto

String minMto
受注製造品最少受注数量

delyUnit

String delyUnit
出荷単位

delyUom

String delyUom
出荷数量単位

delyUomIso

String delyUomIso
ISO コードでの出荷単位の数量単位

salesUnit

String salesUnit
販売単位

salesUnitIso

String salesUnitIso
ISO コードによる販売単位

itemCat

String itemCat
品目マスタの明細カテゴリグループ

delygPlnt

String delygPlnt
出荷プラント

prodHier

String prodHier
品目階層

prRefMat

String prRefMat
価格設定参照品目

matPrGrp

String matPrGrp
品目価格設定グループ

acctAssgt

String acctAssgt
品目の勘定設定グループ

matlGrp1

String matlGrp1
品目グループ 1

matlGrp2

String matlGrp2
品目グループ 2

matlGrp3

String matlGrp3
品目グループ 3

matlGrp4

String matlGrp4
品目グループ 4

matlGrp5

String matlGrp5
品目グループ 5

prodAtt1

String prodAtt1
ID: 製品属性 1

prodAtt2

String prodAtt2
品目属性 2 用 ID

prodAtt3

String prodAtt3
品目属性 3 用 ID

prodAtt4

String prodAtt4
品目属性 4 用 ID

prodAtt5

String prodAtt5
品目属性 5 用 ID

prodAtt6

String prodAtt6
品目属性 6 の ID

prodAtt7

String prodAtt7
品目属性 7 用 ID

prodAtt8

String prodAtt8
品目属性 8 用 ID

prodAtt9

String prodAtt9
品目属性 9

prodAtt10

String prodAtt10
品目属性 10 用 ID

roundProf

String roundProf
丸めプロファイル

varSalesUn

String varSalesUn
可変販売単位の使用不可

unitGroup

String unitGroup
数量単位グループ

prRefMatExternal

String prRefMatExternal
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)

prRefMatGuid

String prRefMatGuid
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)

prRefMatVersion

String prRefMatVersion
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList は SalesData を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

plant

String plant
プラント

stgeLoc

String stgeLoc
保管場所

maintStat

String maintStat
更新ステータス

delFlag

String delFlag
保管場所レベルでの品目削除フラグ

fiscYear

String fiscYear
当会計年度

currPeriod

String currPeriod
当期 (転記期間)

mrpInd

String mrpInd
保管場所 MRP 区分

specProc

String specProc
保管場所レベルでの特殊調達タイプ

reorderPt

String reorderPt
保管場所 MRP に対する発注点

replQty

String replQty
保管場所 MRP に対する補充数量

stgeBin

String stgeBin
棚番

pickgArea

String pickgArea
簡易倉庫管理のピッキングエリア

invCorrFac

String invCorrFac
在庫修正係数

mrpView

String mrpView
資材所要量計画 (MRP) ビュー

storageView

String storageView
保管ビュー

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList は StorageLocationData を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

whseNo

String whseNo
倉庫番号/複合倉庫

stgeType

String stgeType
保管域タイプ

delFlag

String delFlag
保管タイプに該当する全品目データ削除フラグ

stgeBin

String stgeBin
棚番

maxSbQty

String maxSbQty
最大棚番在庫数量

minSbQty

String minSbQty
最小棚番在庫数量

ctrlQty

String ctrlQty
管理数量

replenQty

String replenQty
補充数量

pickArea

String pickArea
ピッキングエリア

roundQty

String roundQty
丸め数量

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList は StorageTypeData を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

depcountry

String depcountry
出荷国 (商品発送国)

depcountryIso

String depcountryIso
出荷国の ISO コード

taxType1

String taxType1
税カテゴリ (消費税等)

taxclass1

String taxclass1
品目の税分類

taxType2

String taxType2
税カテゴリ (消費税等)

taxclass2

String taxclass2
品目の税分類

taxType3

String taxType3
税カテゴリ (消費税等)

taxclass3

String taxclass3
品目の税分類

taxType4

String taxType4
税カテゴリ (消費税等)

taxclass4

String taxclass4
品目の税分類

taxType5

String taxType5
税カテゴリ (消費税等)

taxclass5

String taxclass5
品目の税分類

taxType6

String taxType6
税カテゴリ (消費税等)

taxclass6

String taxclass6
品目の税分類

taxType7

String taxType7
税カテゴリ (消費税等)

taxclass7

String taxclass7
品目の税分類

taxType8

String taxType8
税カテゴリ (消費税等)

taxclass8

String taxclass8
品目の税分類

taxType9

String taxType9
税カテゴリ (消費税等)

taxclass9

String taxclass9
品目の税分類

taxInd

String taxInd
税区分: 品目 (購買管理)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

altUnit

String altUnit
在庫保管単位の代替数量単位

altUnitIso

String altUnitIso
ISO コードによる在庫単位の代替数量単位

numerator

String numerator
基本数量単位への換算分子

denominatr

String denominatr
分母: 基本数量単位へ変換する場合

eanUpc

String eanUpc
国際商品コード (EAN/UPC)

eanCat

String eanCat
国際商品コード (EAN) のカテゴリ

length

String length
長さ

width

String width
幅

height

String height
高さ

unitDim

String unitDim
寸法単位 (長さ/幅/高さ)

unitDimIso

String unitDimIso
ISO コードでの長さ、幅、高さの単位

volume

String volume
容積

volumeunit

String volumeunit
容積単位

volumeunitIso

String volumeunitIso
ISO コードでの容積単位

grossWt

String grossWt
総重量

unitOfWt

String unitOfWt
重量単位

unitOfWtIso

String unitOfWtIso
ISO コードでの重量単位

delFlag

String delFlag
データレコード削除 (テーブル繰返し)

subUom

String subUom
梱包階層の下位レベル数量単位

subUomIso

String subUomIso
下位レベル数量単位 (ISO コード)

internalChar

String internalChar
内部特性

uomsortnumber

String uomsortnumber
数量単位ソート番号

leadinguom

String leadinguom
主要ロット特定数量単位

valueduom

String valueduom
ロット特定数量単位での評価

charUnit

String charUnit
特性の数量単位

charUnitIso

String charUnitIso
下位レベル数量単位 (ISO コード)

gtinVariant

String gtinVariant
グローバルトレード明細番号バリアント

netWeight

String netWeight
正味重量

meAnzSub

String meAnzSub
下位レベル数量単位数

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

valArea

String valArea
評価レベル

valType

String valType
評価タイプ

maintStat

String maintStat
更新ステータス

delFlag

String delFlag
評価タイプに該当する全品目データ削除フラグ

priceCtrl

String priceCtrl
原価管理区分

movingPr

String movingPr
移動平均原価/期間単位価格

stdPrice

String stdPrice
標準原価

priceUnit

String priceUnit
価格単位

valClass

String valClass
評価クラス

prCtrlPp

String prCtrlPp
前期間の原価管理区分

movPrPp

String movPrPp
前期移動平均原価/期間平均原価

stdPrPp

String stdPrPp
前期標準標準原価

prUnitPp

String prUnitPp
前期価格単位

vclassPp

String vclassPp
前期評価クラス

prCtrlPy

String prCtrlPy
前年度の原価管理区分

movPrPy

String movPrPy
前年度の移動平均原価/期間単価

stdPrPy

String stdPrPy
前年度標準原価

vclassPy

String vclassPy
前年度の評価クラス

prUnitPy

String prUnitPy
前年度価格単位

fiscYear

String fiscYear
当会計年度

currPeriod

String currPeriod
当期 (転記期間)

valCat

String valCat
評価カテゴリ

futurePr

String futurePr
次期標準原価

validFrom

String validFrom
原価有効開始日

taxprice1

String taxprice1
税法による評価額: レベル 1

commprice1

String commprice1
商法による評価額: レベル 1

taxprice3

String taxprice3
税法基準評価額: レベル 3

commprice3

String commprice3
商法基準評価額: レベル 3

plndPrice

String plndPrice
予定計画原価

plndprice1

String plndprice1
予定計画原価 1

plndprice2

String plndprice2
予定計画原価 2

plndprice3

String plndprice3
予定計画原価 3

plndprdate1

String plndprdate1
予定原価 1 の有効開始日

plndprdate2

String plndprdate2
予定原価 2 の有効開始日

plndprdate3

String plndprdate3
予定原価 3 の有効開始日

lifoFifo

String lifoFifo
LIFO/FIFO 関連

poolnumber

String poolnumber
LIFO 評価でのプール番号

taxprice2

String taxprice2
税法による評価額: レベル 2

commprice2

String commprice2
商法による評価額: レベル 2

devalInd

String devalInd
低価法: 評価減区分

origGroup

String origGroup
発生源グループ (原価要素の下位区分)

overheadGrp

String overheadGrp
原価計算間接費グループ

perFutCostEst

String perFutCostEst
将来標準原価見積期間

perCurCostEst

String perCurCostEst
現行標準原価見積期間

perPreCostEst

String perPreCostEst
前標準原価見積期間

fijFutCostEst

String fijFutCostEst
将来標準原価見積の会計年度

fijCurCostEst

String fijCurCostEst
当期標準原価見積の会計年度

fijPreCostEst

String fijPreCostEst
前期標準原価見積の会計年度

qtyStruct

String qtyStruct
数量構成により原価計算を行う品目

prevPlanPrice

String prevPlanPrice
税法基準評価額: レベル 2

mlActive

String mlActive
品目レベルで有効な品目元帳

mlSettle

String mlSettle
品目元帳決済: 管理

currPlanPrice

String currPlanPrice
税法基準評価額: レベル 2

origMat

String origMat
品目発生源

vmSoStk

String vmSoStk
受注在庫の評価クラス

vmPStock

String vmPStock
プロジェクト在庫の評価クラス

matlUsage

String matlUsage
品目の用途

matOrigin

String matOrigin
品目の原産地

inHouse

String inHouse
内部生産

taxCmlUn

String taxCmlUn
税法/商法にもとづく評価額価格単位

currency

String currency
通貨コード

currencyIso

String currencyIso
ISO コード通貨

accountView

String accountView
会計ビュー

costView

String costView
原価計算ビュー

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList は ValuationData を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

whseNo

String whseNo
倉庫番号/複合倉庫

delFlag

String delFlag
WM 倉庫内の全品目データ削除フラグ

stgesector

String stgesector
保管区画区分

placement

String placement
在庫受入に対する保管域タイプ検索区分

withdrawal

String withdrawal
在庫払出に対する保管域タイプ区分

lEquip1

String lEquip1
積載装置数量 1

lEquip2

String lEquip2
積載装置数量 2

lEquip3

String lEquip3
積載装置数量 3

leqUnit1

String leqUnit1
積載装置数量 1 の数量単位

leqUnit1Iso

String leqUnit1Iso
ISO コードによる積載装置数量 1 の数量単位

leqUnit2

String leqUnit2
積載装置数量 2 の数量単位

leqUnit2Iso

String leqUnit2Iso
ISO コードによる積載装置数量 2 の数量単位

leqUnit3

String leqUnit3
積載装置数量 3 の数量単位

leqUnit3Iso

String leqUnit3Iso
ISO コードによる積載装置数量 3 の数量単位

unittype1

String unittype1
第１保管単位タイプ

unittype2

String unittype2
第２保管単位タイプ

unittype3

String unittype3
第３保管単位タイプ

wmUnit

String wmUnit
倉庫管理の数量単位

wmUnitIso

String wmUnitIso
ISO コードでの倉庫管理単位

addToStk

String addToStk
既存在庫への追加許可

blockStge

String blockStge
平置保管域区分

msgToIm

String msgToIm
区分: 在庫管理への出力

specMvmt

String specMvmt
倉庫管理の特殊移動区分

capyUsage

String capyUsage
保管容量使用

procureUn

String procureUn
保管容量消費の数量単位

procureUnIso

String procureUnIso
ISO コードでの保管容量消費の数量単位

stgeType

String stgeType
概略計画および詳細計画のピッキング保管域タイプ

refUnit

String refUnit
品目マスタレコードの数量単位初期値

twoStepPick

String twoStepPick
ツーステップピッキング適用品目

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList は WarehouseNumberData を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.exception

クラス jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException は SAPModuleAppException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseSystemException は SAPModuleSystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode は Object を拡張し、Serializable を実装しています

直列化されたフィールド

gmCode

String gmCode
BAPI 在庫移動トランザクションのコード割当

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

testrun

String testrun
在庫移動シミュレーション

matdocumentyear

String matdocumentyear
入出庫伝票会計年度

materialdocument

String materialdocument
入出庫伝票番号

goodsMvtCode

GoodsMvtCode goodsMvtCode
在庫移動に対するコードのトランザクションへの割当

goodsMvtHeader

GoodsMvtHeader goodsMvtHeader
入出庫伝票ヘッダデータ

goodsMvtHeadret

GoodsMvtHeadret goodsMvtHeadret
入出庫伝票番号/入出庫伝票会計年度

goodsMvtItemList

List goodsMvtItemList
入出庫伝票明細

goodsMvtSerialNumberList

List goodsMvtSerialNumberList
シリアル番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret は Object を拡張し、Serializable を実装しています

直列化されたフィールド

matDoc

String matDoc
入出庫伝票番号

docYear

String docYear
入出庫伝票年度

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem は Object を拡張し、Serializable を実装しています

直列化されたフィールド

material

String material
品目コード

plant

String plant
プラント

stgeLoc

String stgeLoc
保管場所

batch

String batch
ロット番号

moveType

String moveType
移動タイプ (在庫管理)

stckType

String stckType
在庫タイプ

specStock

String specStock
特殊在庫区分

vendor

String vendor
仕入先勘定コード

customer

String customer
得意先コード

salesOrd

String salesOrd
受注伝票番号

sOrdItem

String sOrdItem
受注明細番号

schedLine

String schedLine
受注納入日程

valType

String valType
評価タイプ

entryQnt

String entryQnt
入力単位での数量

entryUom

String entryUom
入力単位

entryUomIso

String entryUomIso
単位の ISO コード

poPrQnt

String poPrQnt
数量 (購買発注価格単位)

orderprUn

String orderprUn
購買発注価格単位 (購買管理)

orderprUnIso

String orderprUnIso
単位の ISO コード

poNumber

String poNumber
購買発注番号

poItem

String poItem
購買伝票の明細番号

shipping

String shipping
出荷指示

compShip

String compShip
出荷指示順守

noMoreGr

String noMoreGr
納入完了 区分

itemText

String itemText
明細テキスト

grRcpt

String grRcpt
受領者

unloadPt

String unloadPt
荷渡ポイント

costcenter

String costcenter
原価センタ

orderid

String orderid
指図番号

orderItno

String orderItno
指図明細番号

calcMotive

String calcMotive
計算区分

assetNo

String assetNo
資産番号

subNumber

String subNumber
資産補助番号

reservNo

String reservNo
入出庫予定/従属所要量の番号

resItem

String resItem
入出庫予定/従属所要量の明細番号

resType

String resType
レコードタイプ

withdrawn

String withdrawn
入出庫予定に対する出庫完了

moveMat

String moveMat
入庫/出庫品目

movePlant

String movePlant
入庫/出庫プラント

moveStloc

String moveStloc
入庫/出庫保管場所

moveBatch

String moveBatch
入庫/出庫ロット

moveValType

String moveValType
転送ロットの評価タイプ

mvtInd

String mvtInd
移動区分

moveReas

String moveReas
移動理由

rlEstKey

String rlEstKey
不動産管理対象の内部キー

refDate

String refDate
決済の参照日付

costObj

String costObj
原価対象

profitSegmNo

String profitSegmNo
収益性セグメント番号 (CO-PA)

profitCtr

String profitCtr
利益センタ

wbsElem

String wbsElem
WBS 要素

network

String network
勘定割当のネットワーク番号

activity

String activity
作業番号

partAcct

String partAcct
取引先勘定コード

amountLc

String amountLc
マニュアル入力による転記金額 (国内通貨)

amountSv

String amountSv
外部入力による販売金額 (国内通貨)

refDocYr

String refDocYr
参照伝票の会計年度

refDoc

String refDoc
参照伝票の伝票番号

refDocIt

String refDocIt
参照伝票の明細番号

expirydate

String expirydate
有効期間期限日

prodDate

String prodDate
ロット製造日付

fund

String fund
会計区分

fundsCtr

String fundsCtr
予算センタ

cmmtItem

String cmmtItem
資金予算コード

valSalesOrd

String valSalesOrd
評価受注在庫の受注番号

valSOrdItem

String valSOrdItem
評価受注在庫の受注明細

valWbsElem

String valWbsElem
WBS 要素

glAccount

String glAccount
G/L 勘定コード

indProposeQuanx

String indProposeQuanx
提案数量 (初期数量)

xstob

String xstob
取消移動タイプ区分の使用

eanUpc

String eanUpc
国際商品コード (EAN/UPC)

delivNumbToSearch

String delivNumbToSearch
出荷伝票

delivItemToSearch

String delivItemToSearch
出荷明細

serialnoAutoNumberassignment

String serialnoAutoNumberassignment
シリアル番号の自動登録

vendrbatch

String vendrbatch
仕入先ロット番号

stgeType

String stgeType
保管域タイプ

stgeBin

String stgeBin
棚番

suPlStck1

String suPlStck1
在庫受入予定の保管単位数

stUnQtyy1

String stUnQtyy1
代替数量単位での在庫受入予定保管単位別数量

stUnQtyy1Iso

String stUnQtyy1Iso
単位の ISO コード

unittype1

String unittype1
保管単位タイプ

suPlStck2

String suPlStck2
在庫受入予定の保管単位数

stUnQtyy2

String stUnQtyy2
代替数量単位での在庫受入予定保管単位別数量

stUnQtyy2Iso

String stUnQtyy2Iso
単位の ISO コード

unittype2

String unittype2
保管単位タイプ

stgeTypePc

String stgeTypePc
在庫転送の保管域タイプ

stgeBinPc

String stgeBinPc
在庫転送棚番

noPstChgnt

String noPstChgnt
区分: 振替要求通知登録禁止

grNumber

String grNumber
入庫番号

stgeTypeSt

String stgeTypeSt
在庫転送の保管域タイプ

stgeBinSt

String stgeBinSt
在庫転送棚番

matdocTrCancel

String matdocTrCancel
取消予定の転送要求の入出庫伝票番号

matitemTrCancel

String matitemTrCancel
取消予定の転送数量入出庫伝票明細

matyearTrCancel

String matyearTrCancel
取消予定の転送要求入出庫伝票年度

noTransferReq

String noTransferReq
区分: 転送要求未登録

coBusproc

String coBusproc
業務プロセス

acttype

String acttype
活動タイプ

supplVend

String supplVend
供給仕入先

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

moveMatExternal

String moveMatExternal
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)

moveMatGuid

String moveMatGuid
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)

moveMatVersion

String moveMatVersion
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)

funcArea

String funcArea
機能領域

trPartBa

String trPartBa
取引会社事業領域

parCompco

String parCompco
決済会社コード

delivNumb

String delivNumb
出荷伝票

delivItem

String delivItem
出荷明細

nbSlips

String nbSlips
入庫/出庫票の印刷部数

nbSlipsx

String nbSlipsx
関連ユーザデータ項目の更新情報

grRcptx

String grRcptx
関連ユーザデータ項目の更新情報

unloadPtx

String unloadPtx
関連ユーザデータ項目の更新情報

specMvmt

String specMvmt
倉庫管理の特殊移動区分

grantNbr

String grantNbr
補助金

cmmtItemLong

String cmmtItemLong
資金予算コード

funcAreaLong

String funcAreaLong
機能領域

lineId

String lineId
伝票明細行の一意 ID

parentId

String parentId
1 レベル上位の行 ID

lineDepth

String lineDepth
伝票での明細行階層レベル

quantity

String quantity
数量

baseUom

String baseUom
基本数量単位

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber は Object を拡張し、Serializable を実装しています

直列化されたフィールド

matdocItm

String matdocItm
入出庫伝票の明細

serialno

String serialno
シリアル番号

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
ロット番号

high

String high
ロット番号

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

vendorRaList

List vendorRaList
仕入先の範囲

userNameRaList

List userNameRaList
ユーザ名の範囲

trEvTypeRaList

List trEvTypeRaList
トランザクション/イベントタイプの範囲

stgeLocRaList

List stgeLocRaList
保管場所の範囲

specStockRaList

List specStockRaList
特殊在庫区分の範囲

pstngDateRaList

List pstngDateRaList
登録日付の範囲

plantRaList

List plantRaList
プラントの範囲

moveTypeRaList

List moveTypeRaList
移動タイプの範囲

materialRaList

List materialRaList
品目コードの範囲

goodsMvtItemsList

List goodsMvtItemsList
リターン構造、入出庫伝票明細

goodsMvtHeaderList

List goodsMvtHeaderList
リターン構造、入出庫伝票ヘッダ

batchRaList

List batchRaList
ロットの範囲

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
品目コード

high

String high
品目コード

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
移動タイプ (在庫管理)

high

String high
移動タイプ (在庫管理)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
プラント

high

String high
プラント

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
伝票の転記日付

high

String high
伝票の転記日付

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
特殊在庫区分

high

String high
特殊在庫区分

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
保管場所

high

String high
保管場所

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
トランザクション/イベントタイプ

high

String high
トランザクション/イベントタイプ

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
ユーザ名

high

String high
ユーザ名

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
仕入先勘定コード

high

String high
仕入先勘定コード

index

int index
レコード番号

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialavailability

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

wbsElem

String wbsElem
WBS 要素

unit

String unit
表示数量単位

stockInd

String stockInd
特殊在庫区分

stgeLoc

String stgeLoc
保管場所

plant

String plant
プラント

material

String material
品目コード

itmNumber

String itmNumber
明細番号

docNumber

String docNumber
伝票番号

decForRoundingX

String decForRoundingX
関連ユーザデータ項目の更新情報

decForRounding

String decForRounding
小数点位置 (その位置まで丸める)

customer

String customer
得意先コード

checkRule

String checkRule
確認規則

batch

String batch
ロット

endleadtme

String endleadtme
補充リードタイムの終了日付

dialogflag

String dialogflag
区分 (X = 利用不可 /N = 確認なし)

avQtyPlt

String avQtyPlt
プラントレベル利用可能数量

wmdvexList

List wmdvexList
出力テーブル (日付および ATP 数量)

wmdvsxList

List wmdvsxList
入力テーブル (日付/数量)

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex は Object を拡張し、Serializable を実装しています

直列化されたフィールド

bdcnt

String bdcnt
5 文字数値 NUMC

reqDate

String reqDate
所要日付

reqQty

String reqQty
利用可能在庫確認の所要量

comDate

String comDate
確認日

comQty

String comQty
確認数量

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx は Object を拡張し、Serializable を実装しています

直列化されたフィールド

reqDate

String reqDate
所要日付

reqQty

String reqQty
所要量

delkz

String delkz
MRP 要素区分

yline

String yline
内部テ－ブル処理の行索引

index

int index
レコード番号

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut は Object を拡張し、Serializable を実装しています

直列化されたフィールド

structure

String structure
BAPI テーブル拡張の構造名

valuepart1

String valuepart1
BAPI 拡張パラメータのデータ部分

valuepart2

String valuepart2
BAPI 拡張パラメータのデータ部分

valuepart3

String valuepart3
BAPI 拡張パラメータのデータ部分

valuepart4

String valuepart4
BAPI 拡張パラメータのデータ部分

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers は Object を拡張し、Serializable を実装しています

直列化されたフィールド

unit

String unit
表示数量単位

unitIso

String unitIso
ISO コードでの表示数量単位

eanUpc

String eanUpc
国際商品コード (EAN/UPC)

eanCat

String eanCat
国際商品コード (EAN) のカテゴリ

mainEan

String mainEan
区分: 主要 EAN

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

lifoValuationLevel

String lifoValuationLevel
LIFO 評価レベル

poolnumber

String poolnumber
LIFO 評価でのプール番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

material

String material
品目コード

companycode

String companycode
会社コード

valuationarea

String valuationarea
評価レベル

valuationtype

String valuationtype
評価タイプ

plant

String plant
プラント

storagelocation

String storagelocation
保管場所

salesorganisation

String salesorganisation
販売組織

distributionchannel

String distributionchannel
流通チャネル

warehousenumber

String warehousenumber
倉庫番号/複合倉庫

storagetype

String storagetype
保管域タイプ

lifovaluationlevel

String lifovaluationlevel
LIFO 評価レベル

clientData

ClientData clientData
品目データ (クライアントレベル)

plantData

PlantData plantData
品目データ (プラントレベル)

forecastParameters

ForecastParameters forecastParameters
予測パラメータ

planningData

PlanningData planningData
品目マスタ/製品グループの変更伝票構造

storageLocationData

StorageLocationData storageLocationData
品目データ (保管場所レベル)

valuationData

ValuationData valuationData
評価データ

warehouseNumberData

WarehouseNumberData warehouseNumberData
倉庫番号データ

salesData

SalesData salesData
販売データ

storageTypeData

StorageTypeData storageTypeData
保管域タイプデータ

productionResourceToolData

ProductionResourceToolData productionResourceToolData
品目マスタの生産資源/治工具 (PRT) 項目

lifoValuationData

LifoValuationData lifoValuationData
LIFO 関連品目データ

materialDescriptionList

List materialDescriptionList
品目テキスト

unitSofmeasureList

List unitSofmeasureList
数量単位

internationArticleNumbersList

List internationArticleNumbersList
EAN

materialTextList

List materialTextList
テキスト (長)

taxClassificationsList

List taxClassificationsList
制御デ－タ

extensionOutList

List extensionOutList
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText は Object を拡張し、Serializable を実装しています

直列化されたフィールド

applobject

String applobject
テキスト: アプリケーションオブジェクト

textName

String textName
名称

textId

String textId
テキスト ID

langu

String langu
言語キー

languIso

String languIso
ISO 639 準拠の言語

formatCol

String formatCol
タグ列

textLine

String textLine
テキスト行

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

plant

String plant
プラント

createLoadRecs

String createLoadRecs
区分: 生産資源/治工具の負荷レコード登録

ctrlKey

String ctrlKey
生産資源/治工具管理の管理キー

ctrlKeyNoChg

String ctrlKeyNoChg
管理キーは変更できません

grpKey1

String grpKey1
生産資源/治工具のグループキー 1

grpKey2

String grpKey2
生産資源/治工具のグループキー 2

prtUsage

String prtUsage
生産資源/治工具用途

stdTextKey

String stdTextKey
生産資源/治工具の標準テキストキー

refKeyNoChg

String refKeyNoChg
参照キーは変更できません

startRefDate

String startRefDate
生産資源/治工具使用開始の参照日付

stRefDateNoChg

String stRefDateNoChg
開始参照日付は変更できません

startOffset

String startOffset
生産資源/治工具使用の開始オフセット

startOffsetUnit

String startOffsetUnit
生産資源/治工具使用開始のオフセット単位

startOffsetUnitIso

String startOffsetUnitIso
PRT 用途開始決定の間隔時間単位 (ISO)

startOffsetNoChg

String startOffsetNoChg
開始オフセットは変更できません

endRefDate

String endRefDate
生産資源/治工具使用終了日の参照日付

endRefDateNoChg

String endRefDateNoChg
終了参照日付は変更できません

endOffset

String endOffset
生産資源/治工具用途の終了オフセット

endOffsetUnit

String endOffsetUnit
生産資源/治工具使用終了オフセット単位

endOffsetUnitIso

String endOffsetUnitIso
PRT 用途終了決定の間隔時間単位 (ISO)

endOffsetNoChg

String endOffsetNoChg
終了オフセットは変更できません

formulaTotQty

String formulaTotQty
生産資源/治工具の合計数量の計算式

formulaTotQtyNoChg

String formulaTotQtyNoChg
合計数量の計算式は変更できません

formulaTotUsage

String formulaTotUsage
生産資源/治工具の総用途値の計算式

formulaTotUsageNoChg

String formulaTotUsageNoChg
すべての用途値を計算する計算式は変更できません

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

structure

String structure
BAPI テーブル拡張の構造名

valuepart1

String valuepart1
BAPI 拡張パラメータのデータ部分

valuepart2

String valuepart2
BAPI 拡張パラメータのデータ部分

valuepart3

String valuepart3
BAPI 拡張パラメータのデータ部分

valuepart4

String valuepart4
長さ 229 の文字データのコンテナ

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

structure

String structure
BAPI テーブル拡張の構造名

valuepart1

String valuepart1
BAPI 拡張パラメータのデータ部分

valuepart2

String valuepart2
BAPI 拡張パラメータのデータ部分

valuepart3

String valuepart3
BAPI 拡張パラメータのデータ部分

valuepart4

String valuepart4
長さ 229 の文字データのコンテナ

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

plant

String plant
プラント

firstDay

String firstDay
値参照期間の第一日目

foreValue

String foreValue
予測値

corrValue

String corrValue
需要予測に対する修正値

seasIndex

String seasIndex
季節指数

cvalueFxd

String cvalueFxd
区分: 消費金額の確定

expostVal

String expostVal
事後的需要予測値

valRatio

String valRatio
元値に対する修正値の比率 (修正値: 元値)

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

indSector

String indSector
産業コード

matlType

String matlType
品目タイプ

basicView

String basicView
基本データビュー

salesView

String salesView
販売ビュー

purchaseView

String purchaseView
購買管理ビュー

mrpView

String mrpView
資材所要量計画 (MRP) ビュー

forecastView

String forecastView
需要予測ビュー

workSchedView

String workSchedView
作業計画ビュー

prtView

String prtView
生産資源/治工具 (PRT) ビュー

storageView

String storageView
保管ビュー

warehouseView

String warehouseView
倉庫管理ビュー

qualityView

String qualityView
品質管理ビュー

accountView

String accountView
会計ビュー

costView

String costView
原価計算ビュー

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

unit

String unit
表示数量単位

unitIso

String unitIso
ISO コードでの表示数量単位

eanUpc

String eanUpc
国際商品コード (EAN/UPC)

eanCat

String eanCat
国際商品コード (EAN) のカテゴリ

delFlag

String delFlag
データレコード削除 (テーブル繰返し)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

applobject

String applobject
テキスト: アプリケーションオブジェクト

textName

String textName
名称

textId

String textId
テキスト ID

langu

String langu
言語キー

languIso

String languIso
ISO 639 準拠の言語

formatCol

String formatCol
タグ列

textLine

String textLine
テキスト行

delFlag

String delFlag
データレコード削除 (テーブル繰返し)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

nochangedoc

String nochangedoc
変更伝票書込なし

noappllog

String noappllog
アプリケーションログ書込なし

testrun

String testrun
書込 BAPI のシミュレーションセッションへの切替

inpfldcheck

String inpfldcheck
項目無効時の応答

flagCadCall

String flagCadCall
CAD システムからコール

headDataList

List headDataList
管理情報設定ヘッダセグメント

clientDataList

List clientDataList
品目データ (クライアントレベル)

plantDataList

List plantDataList
品目データ (プラントレベル)

forecastParametersList

List forecastParametersList
需要予測パラメータ

planningDataList

List planningDataList
品目マスタ/製品グループの変更伝票構造

storageLocationDataList

List storageLocationDataList
品目データ (保管場所レベル)

valuationDataList

List valuationDataList
評価データ

warehouseNumberDataList

List warehouseNumberDataList
倉庫番号データ

salesDataList

List salesDataList
販売データ

storageTypeDataList

List storageTypeDataList
保管域タイプデータ

materialDescriptionList

List materialDescriptionList
品目テキスト

unitSofmeasureList

List unitSofmeasureList
数量単位

internationalArtnosList

List internationalArtnosList
国際商品コード (EAN)

materialLongTextList

List materialLongTextList
テキスト (長)

taxClassificationsList

List taxClassificationsList
制御デ－タ

prtDataList

List prtDataList
品目マスタの生産資源/治工具 (PRT) 項目

extensionInList

List extensionInList
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造

extensionInXList

List extensionInXList
拡張イン/拡張アウトのチェックボックス構造

forecastValuesList

List forecastValuesList
需要予測値のデータ転送

unplndConsumptionList

List unplndConsumptionList
計画外消費のデータ転送

totalConsumptionList

List totalConsumptionList
品目総消費量のデータ転送

returnMessagesList

List returnMessagesList
リターンパラメータ BAPIRET2 の代替構造

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

plant

String plant
プラント

createLoadRecs

String createLoadRecs
区分: 生産資源/治工具の負荷レコード登録

ctrlKey

String ctrlKey
生産資源/治工具管理の管理キー

ctrlKeyNoChg

String ctrlKeyNoChg
管理キーは変更できません

grpKey1

String grpKey1
生産資源/治工具のグループキー 1

grpKey2

String grpKey2
生産資源/治工具のグループキー 2

prtUsage

String prtUsage
生産資源/治工具用途

stdTextKey

String stdTextKey
生産資源/治工具の標準テキストキー

refKeyNoChg

String refKeyNoChg
参照キーは変更できません

startRefDate

String startRefDate
生産資源/治工具使用開始の参照日付

stRefDateNoChg

String stRefDateNoChg
開始参照日付は変更できません

startOffset

String startOffset
生産資源/治工具使用の開始オフセット

startOffsetUnit

String startOffsetUnit
生産資源/治工具使用開始のオフセット単位

startOffsetUnitIso

String startOffsetUnitIso
PRT 用途開始決定の間隔時間単位 (ISO)

startOffsetNoChg

String startOffsetNoChg
開始オフセットは変更できません

endRefDate

String endRefDate
生産資源/治工具使用終了日の参照日付

endRefDateNoChg

String endRefDateNoChg
終了参照日付は変更できません

endOffset

String endOffset
生産資源/治工具用途の終了オフセット

endOffsetUnit

String endOffsetUnit
生産資源/治工具使用終了オフセット単位

endOffsetUnitIso

String endOffsetUnitIso
PRT 用途終了決定の間隔時間単位 (ISO)

endOffsetNoChg

String endOffsetNoChg
終了オフセットは変更できません

formulaTotQty

String formulaTotQty
生産資源/治工具の合計数量の計算式

formulaTotQtyNoChg

String formulaTotQtyNoChg
合計数量の計算式は変更できません

formulaTotUsage

String formulaTotUsage
生産資源/治工具の総用途値の計算式

formulaTotUsageNoChg

String formulaTotUsageNoChg
すべての用途値を計算する計算式は変更できません

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages は Object を拡張し、Serializable を実装しています

直列化されたフィールド

type

String type
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了

id

String id
メッセージ、メッセージクラス

number

String number
メッセージ、メッセージ番号

message

String message
メッセージテキスト

logNo

String logNo
アプリケーションログ: ログ番号

logMsgNo

String logMsgNo
アプリケーションログ: メッセージシリアル番号

messageV1

String messageV1
メッセージ、メッセージ変数

messageV2

String messageV2
メッセージ、メッセージ変数

messageV3

String messageV3
メッセージ、メッセージ変数

messageV4

String messageV4
メッセージ、メッセージ変数

parameter

String parameter
パラメータ名

row

String row
パラメータの行

field

String field
パラメータの項目

system

String system
メッセージが発行された論理システム

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

plant

String plant
プラント

firstDay

String firstDay
値参照期間の第一日目

consValue

String consValue
消費量

corrValue

String corrValue
修正消費量

valRatio

String valRatio
元値に対する修正値の比率 (修正値: 元値)

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

plant

String plant
プラント

firstDay

String firstDay
値参照期間の第一日目

consValue

String consValue
消費量

corrValue

String corrValue
修正消費量

valRatio

String valRatio
元値に対する修正値の比率 (修正値: 元値)

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

index

int index
レコード番号

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber

クラス jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber は Object を拡張し、Serializable を実装しています

直列化されたフィールド

material

String material
品目コード

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

stdMaterialGetIntNumberList

List stdMaterialGetIntNumberList
品目コード割当済一覧

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

salesorg

String salesorg
販売組織

distrChan

String distrChan
流通チャネル

division

String division
製品部門

docType

String docType
販売伝票タイプ

ordbilltyp

String ordbilltyp
受注関連請求伝票に対する提案請求伝票タイプ

billDate

String billDate
請求索引および印刷に対する請求日

soldTo

String soldTo
受注先

itemCateg

String itemCateg
明細カテゴリ (販売伝票)

acctasgnmt

String acctasgnmt
品目の勘定設定グループ

priceDate

String priceDate
価格設定/外貨換算の実行日付

country

String country
出荷国 (商品発送国)

plant

String plant
プラント

billTo

String billTo
請求先

payer

String payer
支払人

shipTo

String shipTo
出荷先

refDoc

String refDoc
参照伝票番号

material

String material
品目コード

reqQty

String reqQty
累積受注数量 (販売単位)

currency

String currency
販売伝票通貨

shortText

String shortText
テキスト (短): 受注明細

taxcl1Mat

String taxcl1Mat
品目の税分類

refItem

String refItem
参照明細番号

statGroup

String statGroup
統計グループ

noMatmast

String noMatmast
品目マスタ確認禁止

addrNo

String addrNo
アドレス: アドレス番号

title

String title
敬称

name

String name
名称 1

name2

String name2
名称 2

postlCode

String postlCode
郵便番号

consumctry

String consumctry
消費者の国キー

city

String city
市区町村

district

String district
所在地

street

String street
地名/番地-号

region

String region
地域 (都道府県)

prodHier

String prodHier
品目階層

salesUnit

String salesUnit
販売単位

profitCtr

String profitCtr
利益センタ

taxjurcode

String taxjurcode
税計算管轄コード - 税管轄コード

purchOrd

String purchOrd
出荷先発注番号

docNumber

String docNumber
販売伝票

itmNumber

String itmNumber
販売伝票明細

origindoc

String origindoc
開始伝票

item

String item
開始明細

createdBy

String createdBy
オブジェクト登録者名

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

incoterms1

String incoterms1
インコタームズ (1)

incoterms2

String incoterms2
インコタームズ (2)

exchangeRate

String exchangeRate
価格設定/統計用換算レート

paymentTerms

String paymentTerms
支払条件キー

hgLvItem

String hgLvItem
BOM 構成の上位レベル明細

refDocCa

String refDocCa
先行販売管理伝票の伝票カテゴリ

orderid

String orderid
指図番号

profitSegmNo

String profitSegmNo
収益性セグメント番号 (CO-PA)

costcenter

String costcenter
原価センタ

wbsElem

String wbsElem
WBS 要素

taxDepartCty

String taxDepartCty
税出荷国

taxDestCty

String taxDestCty
税仕向国

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

testrun

String testrun
シミュレーション実行 ('X')、更新実行 (' ')

creatorDataIn

CreatorDataIn creatorDataIn
取り込まれる日付の順序

billingDataInList

List billingDataInList
処理予定明細データのテーブル

cCardDataInList

List cCardDataInList
処理予定支払方法のテーブル

conditionDataInList

List conditionDataInList
処理予定条件のテーブル

errorsList

List errorsList
前明細の不正処理に関する情報

successList

List successList
正常に処理された明細のテーブル

textDataInList

List textDataInList
請求インタフェースの通信構造テキスト

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

paytype

String paytype
支払手段: 支払カード計画の明細分類

ccType

String ccType
支払カードタイプ: カードタイプ

ccNumber

String ccNumber
支払カード: カード番号

ccSeqNo

String ccSeqNo
支払カード: 支払カード - 接尾辞

ccValidF

String ccValidF
支払カード: 使用有効開始日付

ccValidT

String ccValidT
支払カード: 有効終了日

ccName

String ccName
支払カード: カード所有者の氏名

authamount

String authamount
支払カード: 承認額

currency

String currency
通貨コード

currencyIso

String currencyIso
ISO コード通貨

authFlag

String authFlag
支払カード: 振替権限

authDate

String authDate
支払カード: 承認日

authTime

String authTime
支払カード: 承認時刻

ccAuthNo

String ccAuthNo
支払カード: 承認番号

authRefno

String authRefno
支払カード: 決済代行会社の権限参照コード

merchidcl

String merchidcl
支払カード: 決済代行会社のマーチャント ID

terminal

String terminal
支払カード: 端末

dataorigin

String dataorigin
支払カード: 入力モード

ccSettled

String ccSettled
支払カード: 決済終了

ccLocId

String ccLocId
支払カード: トランザクション (入庫時点)

billPlan

String billPlan
請求計画番号

billPlani

String billPlani
明細: 請求計画/支払計画/支払カード

billValue

String billValue
請求金額: 請求計画に請求日付が指定されている場合

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

dataIndex

String dataIndex
別の構成のテーブル入力へのポインタ

condType

String condType
条件タイプ

condValue

String condValue
条件金額/率

condCurr

String condCurr
条件通貨 (累積項目用)

condPUnt

String condPUnt
価格条件単位

condDUnt

String condDUnt
伝票の条件単位

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

createdBy

String createdBy
オブジェクト登録者名

createdOn

String createdOn
レコード登録日

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors は Object を拡張し、Serializable を実装しています

直列化されたフィールド

refDoc

String refDoc
参照伝票番号

refDocItem

String refDocItem
参照明細番号

type

String type
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了

id

String id
メッセージ、メッセージクラス

number

String number
メッセージ、メッセージ番号

message

String message
メッセージテキスト

logNo

String logNo
アプリケーションログ: ログ番号

logMsgNo

String logMsgNo
アプリケーションログ: メッセージシリアル番号

messageV1

String messageV1
メッセージ、メッセージ変数

messageV2

String messageV2
メッセージ、メッセージ変数

messageV3

String messageV3
メッセージ、メッセージ変数

messageV4

String messageV4
メッセージ、メッセージ変数

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

refDoc

String refDoc
参照伝票番号

refItem

String refItem
参照明細番号

applobject

String applobject
テキスト: アプリケーションオブジェクト

textId

String textId
テキスト ID

langu

String langu
言語キー

formatCol

String formatCol
タグ列

textLine

String textLine
テキスト行

index

int index
レコード番号

パッケージ jp.co.intra_mart.foundation.sap.module.sales

クラス jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController は BillingDocCreateMultiple を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

billingDocGetDetail

BillingDocGetDetail billingDocGetDetail
請求伝票詳細照会情報クラス

クラス jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController は BillingDocGetList を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller は InquiryCreateFromData2 を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller は QuotationCreateFromData2 を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller は SalesOrderCreateFromDat2 を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController は SalesOrderGetList を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController は SalesOrderGetStatus を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

billingdocument

String billingdocument
処理予定の請求伝票数

billingDocumentDetail

BillingDocumentDetail billingDocumentDetail
請求伝票に関する詳細情報

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

refDocRange

RefDocRange refDocRange
前伝票の範囲

billingDocumentDetailListList

List billingDocumentDetailListList
後続請求伝票のテーブル

successList

List successList
後続請求伝票の明細テーブル

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

refDocLow

String refDocLow
前伝票の開始伝票番号

refDocHigh

String refDocHigh
前伝票の終了伝票番号

パッケージ jp.co.intra_mart.foundation.sap.module.sales.common.model

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail は Object を拡張し、Serializable を実装しています

直列化されたフィールド

billingdoc

String billingdoc
請求伝票

billType

String billType
請求タイプ

billcateg

String billcateg
請求カテゴリ

sdDocCat

String sdDocCat
販売管理伝票カテゴリ

currency

String currency
販売伝票通貨

currencyIso

String currencyIso
ISO 通貨コード

acctstatus

String acctstatus
会計への転記ステータス

netValue

String netValue
正味金額

taxValue

String taxValue
税額

cancelled

String cancelled
中止区分

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList は BillingDocumentDetail を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob は Object を拡張し、Serializable を実装しています

直列化されたフィールド

configId

String configId
外部選定 ID (仮)

context

String context
CU: 選定の BLOB (SCE)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst は Object を拡張し、Serializable を実装しています

直列化されたフィールド

configId

String configId
外部選定 ID (仮)

instId

String instId
選定におけるインスタンス番号

objType

String objType
対象タイプ

classType

String classType
クラスタイプ

objKey

String objKey
対象キー

objTxt

String objTxt
言語依存対象テキスト

quantity

String quantity
インスタンス数量

author

String author
報告書提案済

quantityUnit

String quantityUnit
数量単位

complete

String complete
一般区分

consistent

String consistent
一般区分

objectGuid

String objectGuid
インスタンス用 TYPE_OF ステートメントの GUID

persistId

String persistId
インスタンス番号 (固定)

persistIdType

String persistIdType
インスタンス番号タイプ (固定)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf は Object を拡張し、Serializable を実装しています

直列化されたフィールド

configId

String configId
外部選定 ID (仮)

parentId

String parentId
選定におけるインスタンス番号

instId

String instId
選定におけるインスタンス番号

partOfNo

String partOfNo
Part_of 明細番号

objType

String objType
対象タイプ

classType

String classType
クラスタイプ

objKey

String objKey
対象キー

author

String author
報告書提案済

salesRelevant

String salesRelevant
この部品は販売に関連しています

partOfGuid

String partOfGuid
インスタンス用 PART_OF ステートメントの GUID

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef は Object を拡張し、Serializable を実装しています

直列化されたフィールド

posex

String posex
外部明細番号

configId

String configId
外部選定 ID (仮)

rootId

String rootId
選定におけるインスタンス番号

sce

String sce
CUX: 選定タイプ

kbname

String kbname
ナレッジベースオブジェクト

kbversion

String kbversion
SCE ナレッジベースの実行時バージョン

complete

String complete
一般区分

consistent

String consistent
一般区分

cfginfo

String cfginfo
CU: 選定の BLOB (SCE)

kbprofile

String kbprofile
ナレッジベースプロファイル

kblanguage

String kblanguage
システム設定の言語

cbaseId

String cbaseId
インスタンス番号 (固定)

cbaseIdType

String cbaseIdType
インスタンス番号タイプ (固定)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst は Object を拡張し、Serializable を実装しています

直列化されたフィールド

posex

String posex
外部明細番号

configId

String configId
外部選定 ID (仮)

instId

String instId
選定におけるインスタンス番号

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue は Object を拡張し、Serializable を実装しています

直列化されたフィールド

configId

String configId
外部選定 ID (仮)

instId

String instId
選定におけるインスタンス番号

charc

String charc
特性名

charcTxt

String charcTxt
言語依存特性テキスト

value

String value
特性値

valueTxt

String valueTxt
特性値の言語依存テキスト

author

String author
報告書提案済

valueTo

String valueTo
特性値

valcode

String valcode
値タイプ: 範囲制限 - 単一値

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk は Object を拡張し、Serializable を実装しています

直列化されたフィールド

configId

String configId
外部選定 ID (仮)

instId

String instId
選定におけるインスタンス番号

vkey

String vkey
バリアント条件名

factor

String factor
バリアント条件の加重係数

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itmNumber

String itmNumber
条件明細番号

condStNo

String condStNo
ステップ番号

condCount

String condCount
条件カウンタ

condType

String condType
条件タイプ

condValue

String condValue
条件レート

currency

String currency
通貨コード

condUnit

String condUnit
条件単位

condPUnt

String condPUnt
価格条件単位

currIso

String currIso
ISO コード通貨

cdUntIso

String cdUntIso
条件数量単位 (ISO コード)

refobjtype

String refobjtype
オブジェクトタイプ

refobjkey

String refobjkey
オブジェクトキー

reflogsys

String reflogsys
論理システム

applicatio

String applicatio
アプリケーション

conpricdat

String conpricdat
条件価格設定日付

calctypcon

String calctypcon
条件計算タイプ

conbaseval

String conbaseval
条件基礎値

conexchrat

String conexchrat
現地通貨への換算レートに対する条件

numconvert

String numconvert
条件単位を基本単位へ変換する分子

denominato

String denominato
条件単位を基本単位へ変換する分母

condtype

String condtype
条件カテゴリ (例: 税、運賃、価格、原価)

statCon

String statCon
統計に適用する条件

scaletype

String scaletype
スケールタイプ

accruals

String accruals
見越額関連条件 (運賃など)

coninvolst

String coninvolst
請求書一覧条件

condorigin

String condorigin
条件生成区分

groupcond

String groupcond
グループ条件区分

condUpdat

String condUpdat
条件更新

accessSeq

String accessSeq
検索順序 - 検索番号

condcount

String condcount
条件連続番号

roundoffdi

String roundoffdi
BAPI の通貨額 (小数点以下９桁)

condvalue

String condvalue
条件金額

currency2

String currency2
販売伝票通貨

currIso2

String currIso2
ISO コード通貨

condcntrl

String condcntrl
条件管理

condisacti

String condisacti
無効条件

condclass

String condclass
条件クラス

factbasval

String factbasval
条件基礎値に対する要因

scalebasin

String scalebasin
スケール基準区分

scalbasval

String scalbasval
条件のスケール基準値

unitmeasur

String unitmeasur
条件スケール単位

isoUnit

String isoUnit
単位の ISO コード

currenckey

String currenckey
スケール通貨

curreniso

String curreniso
ISO コード通貨

condincomp

String condincomp
会社間請求の条件

condconfig

String condconfig
システム設定の条件

condchaman

String condchaman
条件 (マニュアル変更済)

condNo

String condNo
条件レコード番号

taxCode

String taxCode
消費税コード

varcond

String varcond
バリアント条件

accountkey

String accountkey
勘定キー

accountKe

String accountKe
勘定キー 見越/引当

wtWithcd

String wtWithcd
源泉徴収税コード

structcond

String structcond
構造条件

factconbas

String factconbas
条件基準の係数 (期間)

condcoinhd

String condcoinhd
条件カウンタ (ヘッダ条件)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itmNumber

String itmNumber
条件明細番号

condStNo

String condStNo
ステップ番号

condCount

String condCount
条件連続番号

condType

String condType
条件タイプ

updateflag

String updateflag
更新区分

condValue

String condValue
関連ユーザデータ項目の更新情報

currency

String currency
関連ユーザデータ項目の更新情報

condUnit

String condUnit
関連ユーザデータ項目の更新情報

condPUnt

String condPUnt
関連ユーザデータ項目の更新情報

varcond

String varcond
バリアント条件

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

structure

String structure
BAPI テーブル拡張の構造名

valuepart1

String valuepart1
BAPI 拡張パラメータのデータ部分

valuepart2

String valuepart2
BAPI 拡張パラメータのデータ部分

valuepart3

String valuepart3
BAPI 拡張パラメータのデータ部分

valuepart4

String valuepart4
BAPI 拡張パラメータのデータ部分

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

refobjtype

String refobjtype
オブジェクトタイプ

refobjkey

String refobjkey
オブジェクトキー

refdoctype

String refdoctype
参照オブジェクトの伝票タイプ

docType

String docType
販売伝票タイプ

collectNo

String collectNo
一括番号

salesOrg

String salesOrg
販売組織

distrChan

String distrChan
流通チャネル

division

String division
製品部門

salesGrp

String salesGrp
営業グループ

salesOff

String salesOff
営業所

reqDateH

String reqDateH
指定納入期日

dateType

String dateType
提案日付タイプ

purchDate

String purchDate
得意先発注日付

poMethod

String poMethod
得意先発注タイプ

poSupplem

String poSupplem
得意先発注番号補足

ref1

String ref1
得意先/仕入先の内部参照コード

name

String name
発注者名称

telephone

String telephone
電話番号

priceGrp

String priceGrp
価格グループ (得意先)

custGroup

String custGroup
得意先グループ

salesDist

String salesDist
販売地域

priceList

String priceList
価格表タイプ

incoterms1

String incoterms1
インコタームズ (1)

incoterms2

String incoterms2
インコタームズ 2

pmnttrms

String pmnttrms
支払条件キー

dlvBlock

String dlvBlock
出荷ブロック (伝票ヘッダ)

billBlock

String billBlock
販売管理伝票の請求ブロック

ordReason

String ordReason
受注理由 (取引理由)

complDlv

String complDlv
一括納入区分

priceDate

String priceDate
価格設定/外貨換算の実行日付

qtValidF

String qtValidF
見積/引合有効開始日

qtValidT

String qtValidT
見積の有効終了日

ctValidF

String ctValidF
有効開始日付 (販売契約/品目提案)

ctValidT

String ctValidT
有効終了日付 (販売契約/品目提案)

custGrp1

String custGrp1
得意先グループ 1

custGrp2

String custGrp2
得意先グループ 2

custGrp3

String custGrp3
得意先グループ 3

custGrp4

String custGrp4
得意先グループ 4

custGrp5

String custGrp5
得意先グループ 5

purchNoC

String purchNoC
出荷先発注番号

purchNoS

String purchNoS
出荷先の得意先発注番号

poDatS

String poDatS
出荷先の出荷先発注日付

poMethS

String poMethS
出荷先の出荷先発注タイプ

ref1S

String ref1S
出荷先文字

sdDocCat

String sdDocCat
販売管理伝票カテゴリ

docDate

String docDate
伝票日付 (受信日/送信日)

warDate

String warDate
保証期間の開始日付

shipCond

String shipCond
出荷条件

ppSearch

String ppSearch
品目提案検索条件

dunCount

String dunCount
得意先商談回数

dunDate

String dunDate
得意先との前回の商談日

dlvschduse

String dlvschduse
用途区分

pldlvstyp

String pldlvstyp
MRP: 出荷計画タイプ

refDoc

String refDoc
参照伝票番号

compCdeB

String compCdeB
請求対象会社コード

alttaxCls

String alttaxCls
代替税分類

taxClass2

String taxClass2
得意先税分類 2

taxClass3

String taxClass3
得意先税分類 3

taxClass4

String taxClass4
得意先に対する税クラス 4

taxClass5

String taxClass5
得意先に対する税クラス 5

taxClass6

String taxClass6
得意先に対する税クラス 6

taxClass7

String taxClass7
得意先に対する税クラス 7

taxClass8

String taxClass8
得意先に対する税クラス 8

taxClass9

String taxClass9
得意先に対する税クラス 9

refDocL

String refDocL
参照伝票番号

assNumber

String assNumber
割当番号

refdocCat

String refdocCat
先行販売管理伝票の伝票カテゴリ

ordcombIn

String ordcombIn
受注結合出荷区分

billSched

String billSched
請求日程 (稼働日カレンダ指定)

invoSched

String invoSched
請求書一覧日程 (稼働日カレンダ指定)

mnInvoice

String mnInvoice
マニュアル請求書更新

exrateFi

String exrateFi
FI 転記の換算レート (直接相場)

addValDy

String addValDy
有効日からの日数

fixValDy

String fixValDy
有効日日付

pymtMeth

String pymtMeth
支払方法

accntAsgn

String accntAsgn
得意先の勘定設定グループ

exchgRate

String exchgRate
価格設定/統計の換算レート (直接引用)

billDate

String billDate
請求索引および印刷に対する請求日

servDate

String servDate
サービス提供日

dunnKey

String dunnKey
督促処理キー

dunnBlock

String dunnBlock
督促処理保留

pmtgarPro

String pmtgarPro
支払保証決定表

departmNo

String departmNo
部門コード

recPoint

String recPoint
入荷ポイント

docNumFi

String docNumFi
ドキュメンタリクレジット処理: 内部番号

cstcndgrp1

String cstcndgrp1
得意先条件グループ１

cstcndgrp2

String cstcndgrp2
得意先条件グループ２

cstcndgrp3

String cstcndgrp3
得意先条件グループ３

cstcndgrp4

String cstcndgrp4
得意先条件グループ４

cstcndgrp5

String cstcndgrp5
得意先条件グループ５

dlvTime

String dlvTime
契約出荷期間

currency

String currency
販売伝票通貨

currIso

String currIso
ISO コード通貨

createdBy

String createdBy
オブジェクト登録者名

taxdepCty

String taxdepCty
税出荷国

taxdstCty

String taxdstCty
税仕向国

eutriDeal

String eutriDeal
フラグ: EC 内三角取引

mastContr

String mastContr
グループマスタ契約番号

refProc

String refProc
参照限定条件: 決定区分

chkprtauth

String chkprtauth
取引先権限チェック

cmlqtyDat

String cmlqtyDat
累積出荷数量日付

version

String version
販売伝票バージョン番号

notifNo

String notifNo
通知番号

wbsElem

String wbsElem
WBS 要素

exchRateFiV

String exchRateFiV
FI 転記の換算レート (間接相場)

exchgRateV

String exchgRateV
価格設定/統計の換算レート (間接引用)

fkkConacct

String fkkConacct
長さ 12 の文字項目

campaign

String campaign
総括プロジェクト計画: 外部 R/3 システムの GUID

docClass

String docClass
リリースおよびトランザクション管理を備えた元システム

hCurr

String hCurr
通貨コード

hCurrIso

String hCurrIso
ISO 通貨コード

shipType

String shipType
出荷タイプ

sProcInd

String sProcInd
特別処理区分

refDocLLong

String refDocLLong
参照伝票番号 (依存関係についてはテキスト (長) を参照)

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX は Object を拡張し、Serializable を実装しています

直列化されたフィールド

updateflag

String updateflag
更新区分

docType

String docType
関連ユーザデータ項目の更新情報

collectNo

String collectNo
関連ユーザデータ項目の更新情報

salesOrg

String salesOrg
関連ユーザデータ項目の更新情報

distrChan

String distrChan
関連ユーザデータ項目の更新情報

division

String division
関連ユーザデータ項目の更新情報

salesGrp

String salesGrp
関連ユーザデータ項目の更新情報

salesOff

String salesOff
関連ユーザデータ項目の更新情報

reqDateH

String reqDateH
関連ユーザデータ項目の更新情報

dateType

String dateType
関連ユーザデータ項目の更新情報

purchDate

String purchDate
関連ユーザデータ項目の更新情報

poMethod

String poMethod
関連ユーザデータ項目の更新情報

poSupplem

String poSupplem
関連ユーザデータ項目の更新情報

ref1

String ref1
関連ユーザデータ項目の更新情報

name

String name
関連ユーザデータ項目の更新情報

telephone

String telephone
関連ユーザデータ項目の更新情報

priceGrp

String priceGrp
関連ユーザデータ項目の更新情報

custGroup

String custGroup
関連ユーザデータ項目の更新情報

salesDist

String salesDist
関連ユーザデータ項目の更新情報

priceList

String priceList
関連ユーザデータ項目の更新情報

incoterms1

String incoterms1
関連ユーザデータ項目の更新情報

incoterms2

String incoterms2
関連ユーザデータ項目の更新情報

pmnttrms

String pmnttrms
関連ユーザデータ項目の更新情報

dlvBlock

String dlvBlock
関連ユーザデータ項目の更新情報

billBlock

String billBlock
関連ユーザデータ項目の更新情報

ordReason

String ordReason
関連ユーザデータ項目の更新情報

complDlv

String complDlv
関連ユーザデータ項目の更新情報

priceDate

String priceDate
関連ユーザデータ項目の更新情報

qtValidF

String qtValidF
関連ユーザデータ項目の更新情報

qtValidT

String qtValidT
関連ユーザデータ項目の更新情報

ctValidF

String ctValidF
関連ユーザデータ項目の更新情報

ctValidT

String ctValidT
関連ユーザデータ項目の更新情報

custGrp1

String custGrp1
関連ユーザデータ項目の更新情報

custGrp2

String custGrp2
関連ユーザデータ項目の更新情報

custGrp3

String custGrp3
関連ユーザデータ項目の更新情報

custGrp4

String custGrp4
関連ユーザデータ項目の更新情報

custGrp5

String custGrp5
関連ユーザデータ項目の更新情報

purchNoC

String purchNoC
関連ユーザデータ項目の更新情報

purchNoS

String purchNoS
関連ユーザデータ項目の更新情報

poDatS

String poDatS
関連ユーザデータ項目の更新情報

poMethS

String poMethS
関連ユーザデータ項目の更新情報

ref1S

String ref1S
関連ユーザデータ項目の更新情報

sdDocCat

String sdDocCat
関連ユーザデータ項目の更新情報

docDate

String docDate
関連ユーザデータ項目の更新情報

warDate

String warDate
関連ユーザデータ項目の更新情報

shipCond

String shipCond
関連ユーザデータ項目の更新情報

ppSearch

String ppSearch
関連ユーザデータ項目の更新情報

dunCount

String dunCount
関連ユーザデータ項目の更新情報

dunDate

String dunDate
関連ユーザデータ項目の更新情報

dlvschduse

String dlvschduse
関連ユーザデータ項目の更新情報

pldlvstyp

String pldlvstyp
関連ユーザデータ項目の更新情報

refDoc

String refDoc
関連ユーザデータ項目の更新情報

compCdeB

String compCdeB
関連ユーザデータ項目の更新情報

alttaxCls

String alttaxCls
関連ユーザデータ項目の更新情報

taxClass2

String taxClass2
関連ユーザデータ項目の更新情報

taxClass3

String taxClass3
関連ユーザデータ項目の更新情報

taxClass4

String taxClass4
関連ユーザデータ項目の更新情報

taxClass5

String taxClass5
関連ユーザデータ項目の更新情報

taxClass6

String taxClass6
関連ユーザデータ項目の更新情報

taxClass7

String taxClass7
関連ユーザデータ項目の更新情報

taxClass8

String taxClass8
関連ユーザデータ項目の更新情報

taxClass9

String taxClass9
関連ユーザデータ項目の更新情報

refDocL

String refDocL
関連ユーザデータ項目の更新情報

assNumber

String assNumber
関連ユーザデータ項目の更新情報

refdocCat

String refdocCat
関連ユーザデータ項目の更新情報

ordcombIn

String ordcombIn
関連ユーザデータ項目の更新情報

billSched

String billSched
関連ユーザデータ項目の更新情報

invoSched

String invoSched
関連ユーザデータ項目の更新情報

mnInvoice

String mnInvoice
関連ユーザデータ項目の更新情報

exrateFi

String exrateFi
関連ユーザデータ項目の更新情報

addValDy

String addValDy
関連ユーザデータ項目の更新情報

fixValDy

String fixValDy
関連ユーザデータ項目の更新情報

pymtMeth

String pymtMeth
関連ユーザデータ項目の更新情報

accntAsgn

String accntAsgn
関連ユーザデータ項目の更新情報

exchgRate

String exchgRate
関連ユーザデータ項目の更新情報

billDate

String billDate
関連ユーザデータ項目の更新情報

servDate

String servDate
関連ユーザデータ項目の更新情報

dunnKey

String dunnKey
関連ユーザデータ項目の更新情報

dunnBlock

String dunnBlock
関連ユーザデータ項目の更新情報

promotion

String promotion
関連ユーザデータ項目の更新情報

pmtgarPro

String pmtgarPro
関連ユーザデータ項目の更新情報

departmNo

String departmNo
関連ユーザデータ項目の更新情報

recPoint

String recPoint
関連ユーザデータ項目の更新情報

poitmNoS

String poitmNoS
関連ユーザデータ項目の更新情報

docNumFi

String docNumFi
関連ユーザデータ項目の更新情報

cstcndgrp1

String cstcndgrp1
関連ユーザデータ項目の更新情報

cstcndgrp2

String cstcndgrp2
関連ユーザデータ項目の更新情報

cstcndgrp3

String cstcndgrp3
関連ユーザデータ項目の更新情報

cstcndgrp4

String cstcndgrp4
関連ユーザデータ項目の更新情報

cstcndgrp5

String cstcndgrp5
関連ユーザデータ項目の更新情報

dlvTime

String dlvTime
関連ユーザデータ項目の更新情報

currency

String currency
関連ユーザデータ項目の更新情報

taxdepCty

String taxdepCty
関連ユーザデータ項目の更新情報

taxdstCty

String taxdstCty
関連ユーザデータ項目の更新情報

eutriDeal

String eutriDeal
関連ユーザデータ項目の更新情報

mastContr

String mastContr
関連ユーザデータ項目の更新情報

refProc

String refProc
関連ユーザデータ項目の更新情報

chkprtauth

String chkprtauth
関連ユーザデータ項目の更新情報

cmlqtyDat

String cmlqtyDat
関連ユーザデータ項目の更新情報

version

String version
関連ユーザデータ項目の更新情報

notifNo

String notifNo
関連ユーザデータ項目の更新情報

wbsElem

String wbsElem
関連ユーザデータ項目の更新情報

exchRateFiV

String exchRateFiV
関連ユーザデータ項目の更新情報

exchgRateV

String exchgRateV
関連ユーザデータ項目の更新情報

fkkConacct

String fkkConacct
関連ユーザデータ項目の更新情報

campaign

String campaign
関連ユーザデータ項目の更新情報

docClass

String docClass
関連ユーザデータ項目の更新情報

hCurr

String hCurr
関連ユーザデータ項目の更新情報

shipType

String shipType
関連ユーザデータ項目の更新情報

sProcInd

String sProcInd
関連ユーザデータ項目の更新情報

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itmNumber

String itmNumber
販売伝票明細

hgLvItem

String hgLvItem
上位レベル明細

poItmNo

String poItmNo
元となる購買発注の明細番号

material

String material
品目コード

altToItm

String altToItm
代替明細

custMat22

String custMat22
得意先品目コード (無効)

batch

String batch
ロット番号

dlvGroup

String dlvGroup
出荷グループ (明細一括出荷)

partDlv

String partDlv
明細レベルの分納納入

reasonRej

String reasonRej
見積および受注の拒否理由

billBlock

String billBlock
ブロック

billDate

String billDate
請求索引および印刷に対する請求日

plant

String plant
プラント

storeLoc

String storeLoc
保管場所

targetQty

String targetQty
目標数量（販売単位）

targetQu

String targetQu
目標数量 (数量単位)

tUnitIso

String tUnitIso
目標数量単位 (ISO コード)

itemCateg

String itemCateg
明細カテゴリ (販売伝票)

shortText

String shortText
テキスト (短): 受注明細

prcGroup1

String prcGroup1
品目グループ 1

prcGroup2

String prcGroup2
品目グループ 2

prcGroup3

String prcGroup3
品目グループ 3

prcGroup4

String prcGroup4
品目グループ 4

prcGroup5

String prcGroup5
品目グループ 5

prodHiera

String prodHiera
品目階層

matlGroup

String matlGroup
品目グループ

purchNoC

String purchNoC
出荷先発注番号

purchDate

String purchDate
得意先発注日付

poMethod

String poMethod
得意先発注タイプ

ref1

String ref1
得意先/仕入先の内部参照コード

purchNoS

String purchNoS
出荷先の得意先発注番号

poDatS

String poDatS
出荷先の出荷先発注日付

poMethS

String poMethS
出荷先の出荷先発注タイプ

ref1S

String ref1S
出荷先文字

poitmNoS

String poitmNoS
元となる購買発注の明細番号

priceGrp

String priceGrp
価格グループ (得意先)

custGroup

String custGroup
得意先グループ

salesDist

String salesDist
販売地域

priceList

String priceList
価格表タイプ

incoterms1

String incoterms1
インコタームズ (1)

incoterms2

String incoterms2
インコタームズ 2

ordcompIn

String ordcompIn
受注結合出荷区分

billSched

String billSched
請求日程 (稼働日カレンダ指定)

invoSched

String invoSched
請求書一覧日程 (稼働日カレンダ指定)

mnInvoice

String mnInvoice
マニュアル請求書更新

exRateFi

String exRateFi
FI 転記の換算レート (直接相場)

addValDy

String addValDy
有効日からの日数

fixValDy

String fixValDy
有効日日付

pmnttrms

String pmnttrms
支払条件キー

pymtMeth

String pymtMeth
支払方法

accntAsgn

String accntAsgn
得意先の勘定設定グループ

exchgRate

String exchgRate
価格設定/統計の換算レート (直接引用)

priceDate

String priceDate
価格設定/外貨換算の実行日付

servDate

String servDate
サービス提供日

dunnKey

String dunnKey
督促処理キー

dunnBlock

String dunnBlock
督促処理保留

promotion

String promotion
プロモーション

pmtgarPro

String pmtgarPro
支払保証決定表

docNumFi

String docNumFi
ドキュメンタリクレジット処理: 内部番号

departmNo

String departmNo
部門コード

recPoint

String recPoint
入荷ポイント

cstcndgrp1

String cstcndgrp1
得意先条件グループ１

cstcndgrp2

String cstcndgrp2
得意先条件グループ２

cstcndgrp3

String cstcndgrp3
得意先条件グループ３

cstcndgrp4

String cstcndgrp4
得意先条件グループ４

cstcndgrp5

String cstcndgrp5
得意先条件グループ５

dlvTime

String dlvTime
契約出荷期間

salesUnit

String salesUnit
販売単位

sUnitIso

String sUnitIso
単位の ISO コード

trgQtyNo

String trgQtyNo
販売単位から基本単位への換算係数

trgqtyDen

String trgqtyDen
販売単位から基本単位への換算係数

rnddlvQty

String rnddlvQty
丸め数量: 出荷

maxdevamnt

String maxdevamnt
数量に関する許容偏差 (絶対値)

maxdevper

String maxdevper
数量に関する許容偏差 (%)

maxdevDay

String maxdevDay
シフト所要日数

usageInd

String usageInd
未使用 - 予約長 3

fixedQuan

String fixedQuan
数量固定区分

unlmtDlv

String unlmtDlv
区分: 無制限過剰納入可能

overdlvtol

String overdlvtol
過剰納入許容範囲

unddlvTol

String unddlvTol
不足納入許容範囲リミット

division

String division
製品部門

salqtynum

String salqtynum
販売数量単位から基本数量単位への変換係数の分子

salqtyden

String salqtyden
販売数量単位を SKU に換算するための分母 (除数)

grossWght

String grossWght
明細の総重量

netWeight

String netWeight
明細の正味重量

untofWght

String untofWght
重量単位

unofWtiso

String unofWtiso
ISO コードでの重量単位

volume

String volume
明細の総数量

volunit

String volunit
容積単位

volunitiso

String volunitiso
ISO コードでの容積単位

dlvPrio

String dlvPrio
出荷優先順位

shipPoint

String shipPoint
出荷ポイント/入荷ポイント

route

String route
輸送経路

createdBy

String createdBy
オブジェクト登録者名

taxClass1

String taxClass1
品目の税分類

taxClass2

String taxClass2
品目の税分類

taxClass3

String taxClass3
品目の税分類

taxClass4

String taxClass4
品目の税分類

taxClass5

String taxClass5
品目の税分類

taxClass6

String taxClass6
品目の税分類

taxClass7

String taxClass7
品目の税分類

taxClass8

String taxClass8
品目の税分類

taxClass9

String taxClass9
品目の税分類

matPrGrp

String matPrGrp
品目価格設定グループ

valType

String valType
評価タイプ

fixdatQty

String fixdatQty
納期と出荷数量の固定

bomexplNo

String bomexplNo
BOM 展開番号

resanalkey

String resanalkey
結果分析キー

reqmtsTyp

String reqmtsTyp
所要量タイプ

noGrPost

String noGrPost
得意先が入庫を転記していません

busTranst

String busTranst
貿易管理の取引タイプ

overhdKey

String overhdKey
間接費キー

cstgSheet

String cstgSheet
原価計算表

matfrgtgrp

String matfrgtgrp
品目運賃グループ

pldlvshdin

String pldlvshdin
出荷計画に関する指示

seqNo

String seqNo
KANBAN/連続番号

bilForm

String bilForm
請求書式

dliProfil

String dliProfil
動的明細プロセッサプロファイル

revType

String revType
収益承認カテゴリ

begdemPer

String begdemPer
見越期間の提案開始日付

prRefMat

String prRefMat
価格設定参照品目

refobjtype

String refobjtype
オブジェクトタイプ

refobjkey

String refobjkey
オブジェクトキー

reflogsys

String reflogsys
論理システム

orderProb

String orderProb
明細の受注可能性

maxPlDlv

String maxPlDlv
明細ごとの分割納入可能な最大回数

cfopCode

String cfopCode
CFOP code and extension (old 5 char version)

taxlawicms

String taxlawicms
税法: ICMS

taxlawipi

String taxlawipi
税法: IPI

sdTaxcode

String sdTaxcode
0

assortMod

String assortMod
品揃モジュール

compQuant

String compQuant
構成品目数量

targetVal

String targetVal
BAPI の通貨額 (小数点以下９桁)

currency

String currency
販売伝票通貨

currIso

String currIso
ISO コード通貨

profitCtr

String profitCtr
利益センタ

orderid

String orderid
指図番号

wbsElem

String wbsElem
WBS 要素

deprecPer

String deprecPer
ドキュメンタリクレジット処理に関する償却率 (%)

refDoc

String refDoc
参照伝票番号

refDocIt

String refDocIt
参照明細番号

refDocCa

String refDocCa
先行販売管理伝票の伝票カテゴリ

custMat35

String custMat35
得意先品目

exchRateFiV

String exchRateFiV
FI 転記の換算レート (間接相場)

exchgRateV

String exchgRateV
価格設定/統計の換算レート (間接引用)

itemguidAtp

String itemguidAtp
ATP: 暗号 - DELNR および DELPS

valContr

String valContr
金額契約番号

valConI

String valConI
金額契約明細

configId

String configId
外部選定 ID (仮)

instId

String instId
選定におけるインスタンス番号

matExt

String matExt
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

matGuid

String matGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

matVers

String matVers
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

pMatExt

String pMatExt
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)

pMatGuid

String pMatGuid
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)

pMatVers

String pMatVers
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)

funcArea

String funcArea
機能領域

alternBom

String alternBom
代替 BOM

fkkConacct

String fkkConacct
長さ 12 の文字項目

eanUpc

String eanUpc
国際商品コード (EAN/UPC)

prodcat

String prodcat
製品カタログ番号

shipType

String shipType
出荷タイプ

sProcInd

String sProcInd
特別処理区分

funcAreaLong

String funcAreaLong
機能領域

billRel

String billRel
請求関連 (CRM)

vwUepos

String vwUepos
上位レベル明細用途 ID

campaign

String campaign
総括プロジェクト計画: 外部 R/3 システムの GUID

dlvschduse

String dlvschduse
用途区分

cfopLong

String cfopLong
CFOP code and extension

selection

String selection
選択 ID (永続)

matEntrd

String matEntrd
入力品目

logSystemOwn

String logSystemOwn
論理システム

itmTypeUsage

String itmTypeUsage
明細用途

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itmNumber

String itmNumber
販売伝票明細

updateflag

String updateflag
更新区分

hgLvItem

String hgLvItem
関連ユーザデータ項目の更新情報

poItmNo

String poItmNo
関連ユーザデータ項目の更新情報

material

String material
関連ユーザデータ項目の更新情報

altToItm

String altToItm
関連ユーザデータ項目の更新情報

custMat22

String custMat22
関連ユーザデータ項目の更新情報

batch

String batch
関連ユーザデータ項目の更新情報

dlvGroup

String dlvGroup
関連ユーザデータ項目の更新情報

partDlv

String partDlv
関連ユーザデータ項目の更新情報

reasonRej

String reasonRej
関連ユーザデータ項目の更新情報

billBlock

String billBlock
関連ユーザデータ項目の更新情報

billDate

String billDate
関連ユーザデータ項目の更新情報

plant

String plant
関連ユーザデータ項目の更新情報

storeLoc

String storeLoc
関連ユーザデータ項目の更新情報

targetQty

String targetQty
関連ユーザデータ項目の更新情報

targetQu

String targetQu
関連ユーザデータ項目の更新情報

tUnitIso

String tUnitIso
関連ユーザデータ項目の更新情報

itemCateg

String itemCateg
関連ユーザデータ項目の更新情報

shortText

String shortText
関連ユーザデータ項目の更新情報

prcGroup1

String prcGroup1
関連ユーザデータ項目の更新情報

prcGroup2

String prcGroup2
関連ユーザデータ項目の更新情報

prcGroup3

String prcGroup3
関連ユーザデータ項目の更新情報

prcGroup4

String prcGroup4
関連ユーザデータ項目の更新情報

prcGroup5

String prcGroup5
関連ユーザデータ項目の更新情報

prodHiera

String prodHiera
関連ユーザデータ項目の更新情報

matlGroup

String matlGroup
関連ユーザデータ項目の更新情報

purchNoC

String purchNoC
関連ユーザデータ項目の更新情報

purchDate

String purchDate
関連ユーザデータ項目の更新情報

poMethod

String poMethod
関連ユーザデータ項目の更新情報

ref1

String ref1
関連ユーザデータ項目の更新情報

purchNoS

String purchNoS
関連ユーザデータ項目の更新情報

poDatS

String poDatS
関連ユーザデータ項目の更新情報

poMethS

String poMethS
関連ユーザデータ項目の更新情報

ref1S

String ref1S
関連ユーザデータ項目の更新情報

poitmNoS

String poitmNoS
関連ユーザデータ項目の更新情報

priceGrp

String priceGrp
関連ユーザデータ項目の更新情報

custGroup

String custGroup
関連ユーザデータ項目の更新情報

salesDist

String salesDist
関連ユーザデータ項目の更新情報

priceList

String priceList
関連ユーザデータ項目の更新情報

incoterms1

String incoterms1
関連ユーザデータ項目の更新情報

incoterms2

String incoterms2
関連ユーザデータ項目の更新情報

ordcompIn

String ordcompIn
関連ユーザデータ項目の更新情報

billSched

String billSched
関連ユーザデータ項目の更新情報

invoSched

String invoSched
関連ユーザデータ項目の更新情報

mnInvoice

String mnInvoice
関連ユーザデータ項目の更新情報

exRateFi

String exRateFi
関連ユーザデータ項目の更新情報

addValDy

String addValDy
関連ユーザデータ項目の更新情報

fixValDy

String fixValDy
関連ユーザデータ項目の更新情報

pmnttrms

String pmnttrms
関連ユーザデータ項目の更新情報

pymtMeth

String pymtMeth
関連ユーザデータ項目の更新情報

accntAsgn

String accntAsgn
関連ユーザデータ項目の更新情報

exchgRate

String exchgRate
関連ユーザデータ項目の更新情報

priceDate

String priceDate
関連ユーザデータ項目の更新情報

servDate

String servDate
関連ユーザデータ項目の更新情報

dunnKey

String dunnKey
関連ユーザデータ項目の更新情報

dunnBlock

String dunnBlock
関連ユーザデータ項目の更新情報

promotion

String promotion
関連ユーザデータ項目の更新情報

pmtgarPro

String pmtgarPro
関連ユーザデータ項目の更新情報

docNumFi

String docNumFi
関連ユーザデータ項目の更新情報

departmNo

String departmNo
関連ユーザデータ項目の更新情報

recPoint

String recPoint
関連ユーザデータ項目の更新情報

cstcndgrp1

String cstcndgrp1
関連ユーザデータ項目の更新情報

cstcndgrp2

String cstcndgrp2
関連ユーザデータ項目の更新情報

cstcndgrp3

String cstcndgrp3
関連ユーザデータ項目の更新情報

cstcndgrp4

String cstcndgrp4
関連ユーザデータ項目の更新情報

cstcndgrp5

String cstcndgrp5
関連ユーザデータ項目の更新情報

dlvTime

String dlvTime
関連ユーザデータ項目の更新情報

salesUnit

String salesUnit
関連ユーザデータ項目の更新情報

trgQtyNo

String trgQtyNo
関連ユーザデータ項目の更新情報

trgqtyDen

String trgqtyDen
関連ユーザデータ項目の更新情報

rnddlvQty

String rnddlvQty
関連ユーザデータ項目の更新情報

maxdevamnt

String maxdevamnt
関連ユーザデータ項目の更新情報

maxdevper

String maxdevper
関連ユーザデータ項目の更新情報

maxdevDay

String maxdevDay
関連ユーザデータ項目の更新情報

usageInd

String usageInd
関連ユーザデータ項目の更新情報

fixedQuan

String fixedQuan
関連ユーザデータ項目の更新情報

unlmtDlv

String unlmtDlv
関連ユーザデータ項目の更新情報

overdlvtol

String overdlvtol
関連ユーザデータ項目の更新情報

unddlvTol

String unddlvTol
関連ユーザデータ項目の更新情報

division

String division
関連ユーザデータ項目の更新情報

salqtynum

String salqtynum
関連ユーザデータ項目の更新情報

salqtyden

String salqtyden
関連ユーザデータ項目の更新情報

grossWght

String grossWght
関連ユーザデータ項目の更新情報

netWeight

String netWeight
関連ユーザデータ項目の更新情報

untofWght

String untofWght
関連ユーザデータ項目の更新情報

volume

String volume
関連ユーザデータ項目の更新情報

volunit

String volunit
関連ユーザデータ項目の更新情報

dlvPrio

String dlvPrio
関連ユーザデータ項目の更新情報

shipPoint

String shipPoint
関連ユーザデータ項目の更新情報

route

String route
関連ユーザデータ項目の更新情報

taxClass1

String taxClass1
関連ユーザデータ項目の更新情報

taxClass2

String taxClass2
関連ユーザデータ項目の更新情報

taxClass3

String taxClass3
関連ユーザデータ項目の更新情報

taxClass4

String taxClass4
関連ユーザデータ項目の更新情報

taxClass5

String taxClass5
関連ユーザデータ項目の更新情報

taxClass6

String taxClass6
関連ユーザデータ項目の更新情報

taxClass7

String taxClass7
関連ユーザデータ項目の更新情報

taxClass8

String taxClass8
関連ユーザデータ項目の更新情報

taxClass9

String taxClass9
関連ユーザデータ項目の更新情報

matPrGrp

String matPrGrp
関連ユーザデータ項目の更新情報

valType

String valType
関連ユーザデータ項目の更新情報

fixdatQty

String fixdatQty
関連ユーザデータ項目の更新情報

bomexplNo

String bomexplNo
関連ユーザデータ項目の更新情報

resanalkey

String resanalkey
関連ユーザデータ項目の更新情報

reqmtsTyp

String reqmtsTyp
関連ユーザデータ項目の更新情報

noGrPost

String noGrPost
関連ユーザデータ項目の更新情報

busTranst

String busTranst
関連ユーザデータ項目の更新情報

overhdKey

String overhdKey
関連ユーザデータ項目の更新情報

cstgSheet

String cstgSheet
関連ユーザデータ項目の更新情報

matfrgtgrp

String matfrgtgrp
関連ユーザデータ項目の更新情報

pldlvshdin

String pldlvshdin
関連ユーザデータ項目の更新情報

seqNo

String seqNo
関連ユーザデータ項目の更新情報

bilForm

String bilForm
関連ユーザデータ項目の更新情報

dliProfil

String dliProfil
関連ユーザデータ項目の更新情報

revType

String revType
関連ユーザデータ項目の更新情報

begdemPer

String begdemPer
関連ユーザデータ項目の更新情報

prRefMat

String prRefMat
関連ユーザデータ項目の更新情報

refobjtype

String refobjtype
関連ユーザデータ項目の更新情報

refobjkey

String refobjkey
関連ユーザデータ項目の更新情報

reflogsys

String reflogsys
関連ユーザデータ項目の更新情報

orderProb

String orderProb
関連ユーザデータ項目の更新情報

maxPlDlv

String maxPlDlv
関連ユーザデータ項目の更新情報

cfopCode

String cfopCode
関連ユーザデータ項目の更新情報

taxlawicms

String taxlawicms
関連ユーザデータ項目の更新情報

taxlawipi

String taxlawipi
関連ユーザデータ項目の更新情報

sdTaxcode

String sdTaxcode
関連ユーザデータ項目の更新情報

assortMod

String assortMod
関連ユーザデータ項目の更新情報

compQuant

String compQuant
関連ユーザデータ項目の更新情報

targetVal

String targetVal
関連ユーザデータ項目の更新情報

profitCtr

String profitCtr
関連ユーザデータ項目の更新情報

orderid

String orderid
関連ユーザデータ項目の更新情報

wbsElem

String wbsElem
関連ユーザデータ項目の更新情報

deprecPer

String deprecPer
関連ユーザデータ項目の更新情報

refDoc

String refDoc
関連ユーザデータ項目の更新情報

refDocIt

String refDocIt
関連ユーザデータ項目の更新情報

refDocCa

String refDocCa
関連ユーザデータ項目の更新情報

custMat35

String custMat35
関連ユーザデータ項目の更新情報

exchRateFiV

String exchRateFiV
関連ユーザデータ項目の更新情報

exchgRateV

String exchgRateV
関連ユーザデータ項目の更新情報

itemguidAtp

String itemguidAtp
関連ユーザデータ項目の更新情報

valContr

String valContr
関連ユーザデータ項目の更新情報

valConI

String valConI
関連ユーザデータ項目の更新情報

configId

String configId
関連ユーザデータ項目の更新情報

instId

String instId
関連ユーザデータ項目の更新情報

matExt

String matExt
関連ユーザデータ項目の更新情報

matGuid

String matGuid
関連ユーザデータ項目の更新情報

matVers

String matVers
関連ユーザデータ項目の更新情報

pMatExt

String pMatExt
関連ユーザデータ項目の更新情報

pMatGuid

String pMatGuid
関連ユーザデータ項目の更新情報

pMatVers

String pMatVers
関連ユーザデータ項目の更新情報

funcArea

String funcArea
関連ユーザデータ項目の更新情報

alternBom

String alternBom
関連ユーザデータ項目の更新情報

fkkConacct

String fkkConacct
関連ユーザデータ項目の更新情報

eanUpc

String eanUpc
関連ユーザデータ項目の更新情報

prodcat

String prodcat
関連ユーザデータ項目の更新情報

shipType

String shipType
関連ユーザデータ項目の更新情報

sProcInd

String sProcInd
関連ユーザデータ項目の更新情報

billRel

String billRel
関連ユーザデータ項目の更新情報

vwUepos

String vwUepos
関連ユーザデータ項目の更新情報

campaign

String campaign
関連ユーザデータ項目の更新情報

dlvschduse

String dlvschduse
関連ユーザデータ項目の更新情報

selection

String selection
関連ユーザデータ項目の更新情報

matEntrd

String matEntrd
関連ユーザデータ項目の更新情報

logSystemOwn

String logSystemOwn
関連ユーザデータ項目の更新情報

itmTypeUsage

String itmTypeUsage
関連ユーザデータ項目の更新情報

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys は Object を拡張し、Serializable を実装しています

直列化されたフィールド

refobjtyp

String refobjtyp
オブジェクトタイプ

refobject

String refobject
オブジェクト名

refobjkey

String refobjkey
オブジェクトキー

reflogsys

String reflogsys
論理システム

docNumber

String docNumber
販売管理伝票番号

itmNumber

String itmNumber
販売伝票明細

schedLin

String schedLin
納入日程行

condNo

String condNo
伝票条件番号

conditemno

String conditemno
条件明細番号

condStNo

String condStNo
ステップ番号

condCount

String condCount
条件カウンタ

condType

String condType
条件タイプ

status

String status
単一文字フラグ

tindex

String tindex
数値項目: 長さ 6

address

String address
住所

abrli

String abrli
内部納入日程番号

abart

String abart
承認タイプ

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch は Object を拡張し、Serializable を実装しています

直列化されたフィールド

pricing

String pricing
価格設定タイプ

atpWrkmod

String atpWrkmod
ATP セッション: 結果取得/新規決定 APO-ATP

scheduling

String scheduling
単一文字フラグ

nostructure

String nostructure
チェックボックス

condHandl

String condHandl
選択: 条件行処理 (SD 伝票変更)

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses は Object を拡張し、Serializable を実装しています

直列化されたフィールド

addrNo

String addrNo
アドレス番号

formofaddr

String formofaddr
敬称テキスト

name

String name
名称 1

name2

String name2
名称 2

name3

String name3
名称 3

name4

String name4
名称 4

cOName

String cOName
気付

city

String city
市区町村

district

String district
所在地

cityNo

String cityNo
市区町村/地名ファイルの市区町村コード

postlCod1

String postlCod1
市区町村の郵便番号

postlCod2

String postlCod2
私書箱郵便番号

postlCod3

String postlCod3
会社郵便番号 (大規模なユーザ用)

poBox

String poBox
私書箱

poBoxCit

String poBoxCit
私書箱住所

delivDis

String delivDis
郵便配達地域

street

String street
地名

streetNo

String streetNo
市区町村/地名ファイルの地名コード

strAbbr

String strAbbr
地名の略称 (例: スペイン)

houseNo

String houseNo
番地-号

strSuppl1

String strSuppl1
地名 2

strSuppl2

String strSuppl2
地名 3

location

String location
地名 5

building

String building
旧: 建物 (番号または略称)

floor

String floor
建物の階

roomNo

String roomNo
部屋/アパート番号

country

String country
国コード

langu

String langu
言語キー

region

String region
地域 (都道府県)

sort1

String sort1
検索条件 1

sort2

String sort2
検索条件 2

timeZone

String timeZone
アドレスタイムゾーン

taxjurcode

String taxjurcode
税管轄コード

adrNotes

String adrNotes
住所注記

commType

String commType
通信方法 (キー) (アドレス管理)

tel1Numbr

String tel1Numbr
第一電話番号: ダイヤルコード + 番号

tel1Ext

String tel1Ext
第 1 電話番号: 内線

faxNumber

String faxNumber
第一 FAX 番号: ダイヤルコード + 番号

faxExtens

String faxExtens
第一 FAX 番号: 内線

streetLng

String streetLng
地名

distrctNo

String distrctNo
市区町村/地名ファイルの所在地コード

chckstatus

String chckstatus
市区町村ファイルテストステータス

pboxcitNo

String pboxcitNo
市区町村私書箱コード (市ファイル)

transpzone

String transpzone
商品の納入区域

houseNo2

String houseNo2
番地補足

eMail

String eMail
電子メールアドレス

strSuppl3

String strSuppl3
地名 4

title

String title
タイトル (敬称)

countryiso

String countryiso
ISO 国コード

languIso

String languIso
ISO 639 準拠の言語

buildLong

String buildLong
建物 (番号またはコード)

regiogroup

String regiogroup
地域構造グループ化

homeCity

String homeCity
市区町村 (郵便用市区町村と異なる場合)

homecityno

String homecityno
別の市区町村 (市区町村/地名ファイル)

pcode1Ext

String pcode1Ext
市区町村郵便番号の拡張子 例: 郵便番号 +4+2

pcode2Ext

String pcode2Ext
私書箱郵便番号拡張子 例: 郵便番号 +4+2

pcode3Ext

String pcode3Ext
主要得意先郵便番号拡張子 例: 郵便番号 +4+2

poWONo

String poWONo
フラグ: 郵便私書箱 (番号なし)

poBoxReg

String poBoxReg
私書箱の地域 (国、都道府県、地域、...)

poboxCtry

String poboxCtry
私書箱の国指定

poCtryiso

String poCtryiso
ISO 国コード

homepage

String homepage
URI 例: ホームページ、FTP アドレス

dontUseS

String dontUseS
地名住所配達不可フラグ

dontUseP

String dontUseP
私書箱住所配達不可フラグ

houseNo3

String houseNo3
番地範囲

languCr

String languCr
アドレスレコード登録オリジナル言語

langucriso

String langucriso
ISO 639 準拠の言語

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners は Object を拡張し、Serializable を実装しています

直列化されたフィールド

partnRole

String partnRole
取引先機能

partnNumb

String partnNumb
得意先コード 1

itmNumber

String itmNumber
明細番号 (販売管理伝票)

title

String title
敬称

name

String name
名称 1

name2

String name2
名称 2

name3

String name3
名称 3

name4

String name4
名称 4

street

String street
地名/番地-号

country

String country
国コード

countrIso

String countrIso
国キー (ISO コード)

postlCode

String postlCode
郵便番号

pobxPcd

String pobxPcd
私書箱番号

pobxCty

String pobxCty
私書箱住所

city

String city
市区町村

district

String district
所在地

region

String region
地域 (都道府県)

poBox

String poBox
私書箱

telephone

String telephone
電話番号 1

telephone2

String telephone2
電話番号 2

telebox

String telebox
テレボックス番号

faxNumber

String faxNumber
FAX 番号

teletexNo

String teletexNo
テレテクス番号

telexNo

String telexNo
テレックス番号

langu

String langu
言語キー

languIso

String languIso
ISO 639 準拠の言語

unloadPt

String unloadPt
荷渡ポイント

transpzone

String transpzone
商品の納入区域

taxjurcode

String taxjurcode
税計算管轄コード - 税管轄コード

address

String address
住所

privAddr

String privAddr
自宅住所

addrType

String addrType
アドレスタイプ (1=組織、2=個人、3=取引先担当者)

addrOrig

String addrOrig
コピー元住所

addrLink

String addrLink
住所コードへのリンク

refobjtype

String refobjtype
オブジェクトタイプ

refobjkey

String refobjkey
オブジェクトキー

reflogsys

String reflogsys
論理システム

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itmNumber

String itmNumber
販売伝票明細

schedLine

String schedLine
納入日程行

reqDate

String reqDate
納入日程日付

dateType

String dateType
日付タイプ (日、週、月、期間)

reqTime

String reqTime
納入時間

reqQty

String reqQty
販売単位による受注数量

reqDlvBl

String reqDlvBl
出荷ブロック中の納入日程行

schedType

String schedType
納入日程カテゴリ

tpDate

String tpDate
輸送計画日付

msDate

String msDate
品目利用可能日

loadDate

String loadDate
積載日付

giDate

String giDate
出庫日付

tpTime

String tpTime
輸送計画 - 時間 (現地時間/出荷ポイント参照)

msTime

String msTime
品目供給ステージ (現地時刻: プラント参照)

loadTime

String loadTime
積載時刻 (現地時間: 出荷ポイント)

giTime

String giTime
出庫時刻 (現地時間 - プラント参照)

refobjtype

String refobjtype
オブジェクトタイプ

refobjkey

String refobjkey
オブジェクトキー

reflogsys

String reflogsys
論理システム

dlvDate

String dlvDate
納入日程日付

dlvTime

String dlvTime
納入時間

relType

String relType
承認タイプ

planSchedType

String planSchedType
納入日程行タイプ EDI

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itmNumber

String itmNumber
販売伝票明細

schedLine

String schedLine
納入日程行

updateflag

String updateflag
更新区分

reqDate

String reqDate
関連ユーザデータ項目の更新情報

dateType

String dateType
関連ユーザデータ項目の更新情報

reqTime

String reqTime
関連ユーザデータ項目の更新情報

reqQty

String reqQty
関連ユーザデータ項目の更新情報

reqDlvBl

String reqDlvBl
関連ユーザデータ項目の更新情報

schedType

String schedType
関連ユーザデータ項目の更新情報

tpDate

String tpDate
関連ユーザデータ項目の更新情報

msDate

String msDate
関連ユーザデータ項目の更新情報

loadDate

String loadDate
関連ユーザデータ項目の更新情報

giDate

String giDate
関連ユーザデータ項目の更新情報

tpTime

String tpTime
関連ユーザデータ項目の更新情報

msTime

String msTime
関連ユーザデータ項目の更新情報

loadTime

String loadTime
関連ユーザデータ項目の更新情報

giTime

String giTime
関連ユーザデータ項目の更新情報

refobjtype

String refobjtype
オブジェクトタイプ

refobjkey

String refobjkey
オブジェクトキー

dlvDate

String dlvDate
関連ユーザデータ項目の更新情報

dlvTime

String dlvTime
関連ユーザデータ項目の更新情報

relType

String relType
関連ユーザデータ項目の更新情報

planSchedType

String planSchedType
関連ユーザデータ項目の更新情報

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender は Object を拡張し、Serializable を実装しています

直列化されたフィールド

logSystem

String logSystem
論理システム

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Success は Object を拡張し、Serializable を実装しています

直列化されたフィールド

refDoc

String refDoc
参照伝票番号

refDocItem

String refDocItem
参照明細番号

billDoc

String billDoc
請求伝票

billDocItem

String billDocItem
請求伝票明細

netValue

String netValue
正味金額

taxValue

String taxValue
税額

currency

String currency
通貨コード

currencyIso

String currencyIso
ISO コード通貨

netValueItem

String netValueItem
正味金額

taxValueItem

String taxValueItem
税額

groValueItem

String groValueItem
総額

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Text は Object を拡張し、Serializable を実装しています

直列化されたフィールド

docNumber

String docNumber
販売伝票

itmNumber

String itmNumber
販売伝票明細

textId

String textId
テキスト ID

langu

String langu
言語キー

languIso

String languIso
ISO 639 準拠の言語

formatCol

String formatCol
タグ列

textLine

String textLine
テキスト行

function

String function
機能

index

int index
レコード番号

パッケージ jp.co.intra_mart.foundation.sap.module.sales.exception

クラス jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException は SAPModuleAppException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesSystemException は SAPModuleSystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2

クラス jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

testrun

String testrun
テスト実行

salesdocumentin

String salesdocumentin
販売管理伝票番号

intNumberAssignment

String intNumberAssignment
明細番号内部採番

behaveWhenError

String behaveWhenError
エラー処理

binaryRelationshiptype

String binaryRelationshiptype
バイナリ関連タイプ (専用)

convert

String convert
変換: 取引先機能 + 受注伝票タイプ

salesdocument

String salesdocument
販売伝票番号

sender

Sender sender
論理システム - 送信者

logicSwitch

LogicSwitch logicSwitch
内部制御パラメータ

inquiryHeaderInX

HeaderInX inquiryHeaderInX
ヘッダデータチェックボックス

inquiryHeaderIn

HeaderIn inquiryHeaderIn
引合伝票ヘッダデータ

partnerAddressesList

List partnerAddressesList
アドレス (組織/会社) 用 BAPI 参照構造

extensionInList

List extensionInList
VBAK、VBAP、VBEP のカスタマ拡張

inquiryCfgsBlobList

List inquiryCfgsBlobList
選定: BLOB 内部データ (SCE)

inquiryTextList

List inquiryTextList
テキスト

inquirySchedulesInXList

List inquirySchedulesInXList
納入日程行チェックボックス

inquirySchedulesInList

List inquirySchedulesInList
納入日程行

inquiryPartnersList

List inquiryPartnersList
伝票取引先

inquiryKeysList

List inquiryKeysList
参照キーの出力テーブル

inquiryItemsInXList

List inquiryItemsInXList
明細データチェックボックス

inquiryItemsInList

List inquiryItemsInList
明細データ

inquiryCfgsInstList

List inquiryCfgsInstList
選定: インスタンス

inquiryCfgsPartOfList

List inquiryCfgsPartOfList
選定: 部分設定

inquiryConditionsInXList

List inquiryConditionsInXList
受注における条件更新の通信項目

inquiryConditionsInList

List inquiryConditionsInList
条件

inquiryCfgsVkList

List inquiryCfgsVkList
選定: バリアント条件キー

inquiryCfgsValueList

List inquiryCfgsValueList
選定: 特性値

inquiryCfgsRefInstList

List inquiryCfgsRefInstList
選定: 参照明細/インスタンス

inquiryCfgsRefList

List inquiryCfgsRefList
選定: 参照データ

パッケージ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2

クラス jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

behaveWhenError

String behaveWhenError
エラー処理

binaryRelationshiptype

String binaryRelationshiptype
バイナリ関連タイプ (専用)

convert

String convert
取引先機能/受注伝票タイプの変換

testrun

String testrun
テスト実行

intNumberAssignment

String intNumberAssignment
明細番号内部採番

salesdocumentin

String salesdocumentin
見積伝票番号

salesdocument

String salesdocument
販売管理伝票番号

logicSwitch

LogicSwitch logicSwitch
内部制御パラメータ

sender

Sender sender
論理システム - 送信者

quotationHeaderInX

HeaderInX quotationHeaderInX
伝票ヘッダチェックボックス

quotationHeaderIn

HeaderIn quotationHeaderIn
伝票ヘッダデータ

quotationTextList

List quotationTextList
テキスト

quotationSchedulesInXList

List quotationSchedulesInXList
納入日程行データチェックボックス

quotationSchedulesInList

List quotationSchedulesInList
納入日程行データ

quotationPartnersList

List quotationPartnersList
伝票取引先

quotationKeysList

List quotationKeysList
参照キーの出力テーブル

quotationItemsInXList

List quotationItemsInXList
明細データチェックボックス

quotationItemsInList

List quotationItemsInList
明細データ

quotationConditionsInXList

List quotationConditionsInXList
受注における条件更新の通信項目

quotationConditionsInList

List quotationConditionsInList
条件

quotationCfgsVkList

List quotationCfgsVkList
選定: バリアント条件キー

quotationCfgsValueList

List quotationCfgsValueList
選定: 特性値

quotationCfgsRefInstList

List quotationCfgsRefInstList
選定: 参照明細/インスタンス

quotationCfgsRefList

List quotationCfgsRefList
選定: 参照データ

quotationCfgsPartOfList

List quotationCfgsPartOfList
選定: 部分設定

quotationCfgsInstList

List quotationCfgsInstList
選定: インスタンス

quotationCfgsBlobList

List quotationCfgsBlobList
選定: BLOB 内部データ (SCE)

partnerAddressesList

List partnerAddressesList
アドレス (組織/会社) 用 BAPI 参照構造

extensionInList

List extensionInList
VBAK、VBAP、VBEP のカスタマ拡張

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard は Object を拡張し、Serializable を実装しています

直列化されたフィールド

ccType

String ccType
支払カードタイプ: カードタイプ

ccNumber

String ccNumber
支払カード: カード番号

ccValidT

String ccValidT
支払カード: 有効終了日

ccName

String ccName
支払カード: カード所有者の氏名

billamount

String billamount
請求金額: 請求計画に請求日付が指定されている場合

authFlag

String authFlag
支払カード: 振替権限

authamount

String authamount
支払カード: 承認額

currency

String currency
通貨コード

currIso

String currIso
ISO コード通貨

authDate

String authDate
支払カード: 承認日

authTime

String authTime
支払カード: 承認時刻

authCcNo

String authCcNo
支払カード: 承認番号

authRefno

String authRefno
支払カード: 決済代行会社の権限参照コード

ccReact

String ccReact
支払カード: 権限確認に対する応答

ccReAmount

String ccReAmount
BAPI インタフェースの通貨金額

glAccount

String glAccount
G/L 勘定コード

ccStatEx

String ccStatEx
支払カード: 外部システム呼出時のステータス

ccReactT

String ccReactT
支払カード: 結果テキスト

virtCard

String virtCard
チェックボックス

merchidcl

String merchidcl
支払カード: 決済代行会社のマーチャント ID

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

salesdocumentin

String salesdocumentin
販売管理伝票番号

intNumberAssignment

String intNumberAssignment
明細番号内部採番

testrun

String testrun
テスト実行

convert

String convert
変換: 取引先機能 + 受注伝票タイプ

binaryRelationshiptype

String binaryRelationshiptype
バイナリ関連タイプ (専用)

behaveWhenError

String behaveWhenError
エラー処理

salesdocument

String salesdocument
生成された伝票の番号

orderHeaderIn

HeaderIn orderHeaderIn
受注伝票ヘッダ

orderHeaderInX

HeaderInX orderHeaderInX
受注伝票チェックリスト

sender

Sender sender
論理システム - 送信者

logicSwitch

LogicSwitch logicSwitch
内部制御パラメータ

orderItemsInXList

List orderItemsInXList
明細データチェックボックス

orderKeysList

List orderKeysList
参照キーの出力テーブル

orderPartnersList

List orderPartnersList
伝票取引先

orderSchedulesInList

List orderSchedulesInList
納入日程行データ

orderSchedulesInXList

List orderSchedulesInXList
納入日程行データチェックボックス

orderTextList

List orderTextList
テキスト

partnerAddressesList

List partnerAddressesList
アドレス (組織/会社) 用 BAPI 参照構造

extensionInList

List extensionInList
VBAK、VBAP、VBEP のカスタマ拡張

orderCcardList

List orderCcardList
クレジットカードデータ

orderCfgsBlobList

List orderCfgsBlobList
選定: BLOB 内部データ (SCE)

orderCfgsInstList

List orderCfgsInstList
選定: インスタンス

orderCfgsPartOfList

List orderCfgsPartOfList
選定: 部分設定

orderCfgsRefList

List orderCfgsRefList
選定: 参照データ

orderCfgsRefInstList

List orderCfgsRefInstList
選定: 参照明細/インスタンス

orderCfgsValueList

List orderCfgsValueList
選定: 特性値

orderCfgsVkList

List orderCfgsVkList
選定: バリアント条件キー

orderConditionsInList

List orderConditionsInList
条件

orderConditionsInXList

List orderConditionsInXList
条件チェックボックス

orderItemsInList

List orderItemsInList
明細データ

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

customerNumber

String customerNumber
得意先コード

documentDate

String documentDate
登録日付

documentDateTo

String documentDateTo
入力日付 (以前/以降)

material

String material
品目コード

purchaseOrder

String purchaseOrder
得意先発注番号

purchaseOrderNumber

String purchaseOrderNumber
得意先発注番号1

salesOrganization

String salesOrganization
販売組織

transactionGroup

String transactionGroup
一文字フラグ

salesOrdersList

List salesOrdersList
得意先受注テーブル

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sdDoc

String sdDoc
販売管理伝票番号

itmNumber

String itmNumber
明細番号 (販売管理伝票)

material

String material
品目コード

shortText

String shortText
テキスト (短): 受注明細

docType

String docType
販売伝票タイプ

docDate

String docDate
伝票日付 (受信日/送信日)

reqQty

String reqQty
累積受注数量 (販売単位)

reqDate

String reqDate
指定納期

purchNo

String purchNo
得意先発注番号

batch

String batch
ロット番号

validFrom

String validFrom
見積または基本契約の有効開始日

validTo

String validTo
見積または基本契約有効終了日

billBlock

String billBlock
販売管理伝票の請求ブロック

dlvBlock

String dlvBlock
出荷ブロック (伝票ヘッダ)

soldTo

String soldTo
受注先

name

String name
名称 1

exchgRate

String exchgRate
価格設定/統計の換算レート (直接引用)

dlvQty

String dlvQty
出荷数量実績 (販売単位)

baseUom

String baseUom
基本数量単位

netPrice

String netPrice
正味価格

condPUnt

String condPUnt
価格条件単位

condUnit

String condUnit
条件単位

netValHd

String netValHd
受注正味額 (伝票通貨)

netValue

String netValue
伝票通貨による正味額

division

String division
製品部門

docStatus

String docStatus
伝票ステータス

salesGrp

String salesGrp
営業グループ

salesOff

String salesOff
営業所

salesOrg

String salesOrg
販売組織

salesUnit

String salesUnit
販売単位

shipPoint

String shipPoint
出荷ポイント/入荷ポイント

distrChan

String distrChan
流通チャネル

giDate

String giDate
出庫日付

currency

String currency
販売伝票通貨

plant

String plant
プラント

storeLoc

String storeLoc
保管場所

ordReason

String ordReason
受注理由 (取引理由)

reasonRej

String reasonRej
見積および受注の拒否理由

bUomIso

String bUomIso
ISO コードでの基本数量単位

cdUntIso

String cdUntIso
条件数量単位 (ISO コード)

sUnitIso

String sUnitIso
ISO コードによる販売単位

currIso

String currIso
ISO コード通貨

purchNoC

String purchNoC
出荷先発注番号

exchgRateV

String exchgRateV
価格設定/統計の換算レート (間接引用)

matExt

String matExt
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

matGuid

String matGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

matVers

String matVers
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

creationDate

String creationDate
レコード登録日

creationTime

String creationTime
登録時刻

index

int index
レコード番号

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

salesdocument

String salesdocument
販売管理伝票番号

statusInfoList

ArrayList statusInfoList
ステータス情報

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

docNumber

String docNumber
販売伝票

docDate

String docDate
伝票日付 (受信日/送信日)

purchNo

String purchNo
得意先発注番号

prcStatH

String prcStatH
伝票の全処理ステータス

dlvStatH

String dlvStatH
全明細の出荷ステータス

reqDateH

String reqDateH
指定納入期日

dlvBlock

String dlvBlock
出荷ブロック (伝票ヘッダ)

itmNumber

String itmNumber
販売伝票明細

material

String material
品目コード

shortText

String shortText
テキスト (短): 受注明細

reqDate

String reqDate
納入日程日付

reqQty

String reqQty
累積受注数量 (販売単位)

cumCfQty

String cumCfQty
累積確認数量 (販売数量単位)

salesUnit

String salesUnit
販売単位

netValue

String netValue
伝票通貨での受注明細正味額

currency

String currency
販売伝票通貨

netPrice

String netPrice
正味価格

condPUnt

String condPUnt
価格条件単位

condUnit

String condUnit
条件単位

dlvStatI

String dlvStatI
明細の全体出荷ステータス

delivNumb

String delivNumb
出荷伝票

delivItem

String delivItem
出荷明細

delivDate

String delivDate
納入期日

dlvQty

String dlvQty
出荷数量実績 (販売単位)

refQty

String refQty
基本数量単位による参照数量

sUnitIso

String sUnitIso
ISO コードによる販売単位

cdUntIso

String cdUntIso
条件数量単位 (ISO コード)

currIso

String currIso
ISO コード通貨

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

poItmNo

String poItmNo
元となる購買発注の明細番号

creationDate

String creationDate
レコード登録日

creationTime

String creationTime
登録時刻

sUnitDlv

String sUnitDlv
出荷単位

dlvUnitIso

String dlvUnitIso
ISO コードでの出荷単位の数量単位

index

int index
レコード番号

パッケージ jp.co.intra_mart.foundation.scenario

クラス jp.co.intra_mart.foundation.scenario.NoSuchPropertyException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.scenario.ScriptCompileException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.scenario.ScriptRuntimeException は Exception を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.security.access

クラス jp.co.intra_mart.foundation.security.access.AccessController は Object を拡張し、Serializable を実装しています

serialVersionUID: 318454472512899294l

直列化されたフィールド

controllerId

String controllerId

displayName

String displayName

description

String description

パッケージ jp.co.intra_mart.foundation.security

クラス jp.co.intra_mart.foundation.security.DepartmentInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード。

departmentCode

String departmentCode
組織コード。

クラス jp.co.intra_mart.foundation.security.PostInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード。

postCode

String postCode
役職コード。

クラス jp.co.intra_mart.foundation.security.PublicGroupInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

groupSetCode

String groupSetCode
グループセットコード。

groupCode

String groupCode
グループコード。

パッケージ jp.co.intra_mart.foundation.security.account

クラス jp.co.intra_mart.foundation.security.account.Account は Object を拡張し、Serializable を実装しています

直列化されたフィールド

encoding

String encoding
エンコーディング

goOut

boolean goOut
外出フラグ

locale

Locale locale
ロケール

lockdate

Date lockdate
アカウントロック日付

loginFailureCount

int loginFailureCount
ログイン失敗回数

mainPagePatternId

String mainPagePatternId
メインページパターンID

mobilePassword

String mobilePassword
モバイル用パスワード

description

String description
説明

colorPatternId

String colorPatternId
カラーパターンID

password

String password
パスワード

userId

String userId
ユーザID

validEndDate

Date validEndDate
有効終了日

validStartDate

Date validStartDate
有効開始日

クラス jp.co.intra_mart.foundation.security.account.AccountRole は Object を拡張し、Serializable を実装しています

直列化されたフィールド

roleId

String roleId
ロールID

roleValidEndDate

Date roleValidEndDate
ロール有効終了日

roleValidStartDate

Date roleValidStartDate
ロール有効開始日

クラス jp.co.intra_mart.foundation.security.account.FavoriteMenu は Object を拡張し、Serializable を実装しています

直列化されたフィールド

displayName

String displayName
マイメニュー表示名

menuId

String menuId
メニューID

imagePath

String imagePath
イメージパス

sortNumber

int sortNumber
ソート番号

パッケージ jp.co.intra_mart.foundation.security.activesession

クラス jp.co.intra_mart.foundation.security.activesession.ActiveSessionBindingListener は Object を拡張し、Serializable を実装しています

serialVersionUID: -1231301228756970262l

直列化されたフィールド

activeSessionInfo

ActiveSessionInfo activeSessionInfo

クラス jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo は Object を拡張し、Serializable を実装しています

serialVersionUID: -5974203619452886484l

直列化されたフィールド

sessionId

String sessionId
セッションID

loginType

String loginType
ログインタイプ

loginGroup

String loginGroup
ログイングループ(ID)

userId

String userId
ユーザID

loginTime

long loginTime
ログイン時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)

remoteAddr

String remoteAddr
クライアントの IP アドレス

userAgent

String userAgent
ブラウザ情報

lastResponseTime

long lastResponseTime
最終応答時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)

expireInterval

int expireInterval
セッションを保ち続ける最大の時間間隔(秒数)

processing

boolean processing
処理中フラグ

valid

boolean valid
セッションの有効性フラグ

invalidateLoginType

String invalidateLoginType
無効化したユーザのログインタイプ

invalidateUserId

String invalidateUserId
無効化したユーザのユーザID

invalidateTime

long invalidateTime
無効化した時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)

パッケージ jp.co.intra_mart.foundation.security.admin

クラス jp.co.intra_mart.foundation.security.admin.SuperUser は Object を拡張し、Serializable を実装しています

直列化されたフィールド

encoding

String encoding
エンコーディング

locale

Locale locale
ロケール

mailAddress

String mailAddress
メールアドレス

password

String password
パスワード

telNo

String telNo
電話番号

userId

String userId
ユーザーID

パッケージ jp.co.intra_mart.foundation.security.batch

クラス jp.co.intra_mart.foundation.security.batch.Batch は Object を拡張し、Serializable を実装しています

直列化されたフィールド

batchId

String batchId
バッチＩＤ

description

String description
バッチ内容

name

String name
バッチ名

programLanguage

String programLanguage
実行プログラム言語

programPath

String programPath
実行プログラムパス

runDay

int runDay
実行日

runDayWeek

int runDayWeek
実行曜日

runHour

int runHour
実行時

runMinute

int runMinute
実行分

runMonth

int runMonth
実行月

runSecond

int runSecond
実行秒

runYear

int runYear
実行年

validate

boolean validate
有効・無効フラグ

パッケージ jp.co.intra_mart.foundation.security.calendar

クラス jp.co.intra_mart.foundation.security.calendar.CalendarInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

color

String color
表示色

dataId

String dataId
データＩＤ（入力必須）

dataType

String dataType
データタイプ

day

int day
日

dayWeek

int dayWeek
曜日

description

String description
カレンダーデータの説明

displayName

Map displayName
表示名

month

int month
月

plugin

String plugin
プラグインID

times

int times
第ｎ～曜日

validEndYear

int validEndYear
有効終了年

validStartYear

int validStartYear
有効開始年

week

int week
第ｎ週目

year

int year
年

regExpPattern

Pattern regExpPattern
検証パターン(正規表現)

priority

int priority
優先度

パッケージ jp.co.intra_mart.foundation.security.exception

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException は AccessSecurityRuntimeException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException は AccessSecurityWriteException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException は AccessSecurityWriteException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException は FoundationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException は FoundationRuntimeException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException は AccessSecurityWriteException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.ActiveSessionException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.ActiveSessionInvalidatedByForceException は ActiveSessionException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.ActiveSessionNotExistException は ActiveSessionException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.DuplicateException は AccessSecurityWriteException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.DuplicateLoginDetectedException は DuplicateLoginException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.DuplicateLoginException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.IllegalArgumentException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.NoFilterException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.NoSessionCookieException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.NoSessionException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.NotExistException は AccessSecurityWriteException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.NotSupportMethodException は AccessSecurityWriteException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.SystemConfigException は AccessSecurityRuntimeException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.security.group

クラス jp.co.intra_mart.foundation.security.group.LoginGroup は Object を拡張し、Serializable を実装しています

直列化されたフィールド

encoding

String encoding
エンコーディング

locale

Locale locale
ロケール

lockCount

int lockCount
アカウントロックカウント

lockTerm

int lockTerm
アカウントロック時間（分）

loginGroupId

String loginGroupId
ログイングループID

colorPatternId

String colorPatternId
カラーパターンID

クラス jp.co.intra_mart.foundation.security.group.MainPagePatternInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

mainPagePatternId

String mainPagePatternId
メインページパターンID。

mainPagePatternImageUrl

String mainPagePatternImageUrl
メインページパターンイメージURL。

mainPagePatternUrl

String mainPagePatternUrl
メインページパターンURL。

パッケージ jp.co.intra_mart.foundation.security.menu

クラス jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion は Object を拡張し、Serializable を実装しています

直列化されたフィールド

childMenuId

String childMenuId
子メニューID。

parentMenuId

String parentMenuId
親メニューID。

クラス jp.co.intra_mart.foundation.security.menu.MenuInclusion は Object を拡張し、Serializable を実装しています

直列化されたフィールド

childMenuId

String childMenuId
子メニューID。

parentMenuId

String parentMenuId
親メニューID。

クラス jp.co.intra_mart.foundation.security.menu.MenuItem は Object を拡張し、Serializable を実装しています

直列化されたフィールド

arguments

Map arguments
引数

clientType

String clientType
クライアントタイプ

contents

String contents
コンテンツの種類

description

String description
説明

displayNames

Map displayNames
メニュー名 (多言語化対応、 key:ロケール、value メニュー名)

id

String id
メニューID

sortNumber

int sortNumber
ソート番号

type

String type
ノードタイプ

url

String url
URL

imagePath

String imagePath
メニューイメージパス。

パッケージ jp.co.intra_mart.foundation.security.password

クラス jp.co.intra_mart.foundation.security.password.PasswordHistoryException は FoundationException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.security.role

クラス jp.co.intra_mart.foundation.security.role.Role は Object を拡張し、Serializable を実装しています

直列化されたフィールド

category

String category
ロールカテゴリ。

description

String description
ロールの詳細。

displayName

Map displayName
ロールの表示名 (key:ロケール、value:ロール表示名)。

roleId

String roleId
ロールID。

roleName

String roleName
ロール名。

パッケージ jp.co.intra_mart.foundation.security.servlet

クラス jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

redilectClientTypes

Set redilectClientTypes
メインページをリダイレクトで返却するクライアントタイプ。

clientType

String clientType
クライアントタイプ。

クラス jp.co.intra_mart.foundation.security.servlet.LogoutServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

validator

LogoutInitialUrlValidator validator

クラス jp.co.intra_mart.foundation.security.servlet.MenuServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

redilectClientTypes

Set redilectClientTypes
メインページをリダイレクトで返却するクライアントタイプ。

クラス jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

redilectClientTypes

Set redilectClientTypes
メインページをリダイレクトで返却するクライアントタイプ。

clientType

String clientType
クライアントタイプ。

クラス jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

redilectClientTypes

Set redilectClientTypes
メインページをリダイレクトで返却するクライアントタイプ。

クラス jp.co.intra_mart.foundation.security.servlet.UserInitialServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

redilectClientTypes

Set redilectClientTypes
メインページをリダイレクトで返却するクライアントタイプ。

clientType

String clientType
クライアントタイプ。

パッケージ jp.co.intra_mart.foundation.security.shortcut

クラス jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

url

String url
ＵＲＬ。

urlParams

Map urlParams
ＵＲＬ引数。

allowsUsers

String[] allowsUsers
許可ユーザ

isAuth

boolean isAuth
認証フラグ

validEndDate

Date validEndDate
有効終了日

パッケージ jp.co.intra_mart.foundation.service.client

クラス jp.co.intra_mart.foundation.service.client.NetworkAgent は NetworkConnector を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.client.NetworkConnector は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.client.application

クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException は HTTPActionEventHandlerException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.client.batch

クラス jp.co.intra_mart.foundation.service.client.batch.Scheduler は NetworkAgent を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.client.file

クラス jp.co.intra_mart.foundation.service.client.file.AbstractComponent は NetworkAgent を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.client.file.NetworkFile は AbstractComponent を拡張し、Serializable を実装しています

直列化されたフィールド

path

String path

パッケージ jp.co.intra_mart.foundation.service.client.information

クラス jp.co.intra_mart.foundation.service.client.information.ExternalDirectory は NetworkAgent を拡張し、Serializable を実装しています

直列化されたフィールド

dir

String dir

クラス jp.co.intra_mart.foundation.service.client.information.ExternalMemory は NetworkAgent を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

parent

String parent

クラス jp.co.intra_mart.foundation.service.client.information.InitialFile は Properties を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.client.information.Lock は NetworkAgent を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

クラス jp.co.intra_mart.foundation.service.client.information.PermanentDirectory は NetworkAgent を拡張し、Serializable を実装しています

直列化されたフィールド

dir

String dir

クラス jp.co.intra_mart.foundation.service.client.information.PermanentFile は NetworkAgent を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

parent

String parent

パッケージ jp.co.intra_mart.foundation.service.client.manager

クラス jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.client.manager.ServerConnector は NetworkConnector を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.provider.application

クラス jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException は Exception を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.provider

クラス jp.co.intra_mart.foundation.service.provider.HomeDirectory は ExtendedDirectory を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.provider.TemporaryDirectory は ExtendedDirectory を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.provider.TemporaryFile は ExtendedFile を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.provider.file

クラス jp.co.intra_mart.foundation.service.provider.file.StorageDirectory は ExtendedDirectory を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.provider.information

クラス jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory は ExtendedDirectory を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.smtp

クラス jp.co.intra_mart.foundation.smtp.Mail は jp.co.intra_mart.system.mail.smtp.InetMail を拡張し、Serializable を実装しています

直列化されたフィールド

tempSmtpsvr

String tempSmtpsvr
推奨されていません。

badAdrs

ArrayList badAdrs
推奨されていません。

errCode

int errCode
推奨されていません。

errMsg

String errMsg
推奨されていません。

toFlg

boolean toFlg
推奨されていません。

fromFlg

boolean fromFlg
推奨されていません。

replyFlg

boolean replyFlg
推奨されていません。

パッケージ jp.co.intra_mart.foundation.utility

クラス jp.co.intra_mart.foundation.utility.AbstractDualComparator は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.utility.Counter は Number を拡張し、Serializable を実装しています

直列化されたフィールド

currentValue

long currentValue
推奨されていません。
カウンターの値

クラス jp.co.intra_mart.foundation.utility.FilterComparator は Object を拡張し、Serializable を実装しています

直列化されたフィールド

parent

Comparator parent
推奨されていません。

クラス jp.co.intra_mart.foundation.utility.MultiComparator は AbstractDualComparator を拡張し、Serializable を実装しています

直列化されたフィールド

primaryComparator

Comparator primaryComparator
推奨されていません。
第１コンパレータ

secondaryComparator

MultiComparator secondaryComparator
推奨されていません。
第２コンパレータ

クラス jp.co.intra_mart.foundation.utility.ResourceBundleProperties は Properties を拡張し、Serializable を実装しています

直列化されたフィールド

currentLocale

Locale currentLocale
推奨されていません。

クラス jp.co.intra_mart.foundation.utility.ReverseComparator は FilterComparator を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.utility.SequenceComparator は Object を拡張し、Serializable を実装しています

直列化されたフィールド

map

WeakHashMap map
推奨されていません。
map

count

long count
推奨されていません。
挿入順番

パッケージ jp.co.intra_mart.foundation.utility.charset

クラス jp.co.intra_mart.foundation.utility.charset.ResourceFormatException は ResourceFormatException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException は ResourceNotFoundException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.utility.file

クラス jp.co.intra_mart.foundation.utility.file.Directory は File を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.utility.file.ExtendedDirectory は Directory を拡張し、Serializable を実装しています

直列化されたフィールド

POOL

FixedSizeMap POOL
推奨されていません。
このディレクトリを親とするファイルオブジェクトのキャッシュ領域

クラス jp.co.intra_mart.foundation.utility.file.ExtendedFile は File を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.utility.net

クラス jp.co.intra_mart.foundation.utility.net.Localhost は Object を拡張し、Serializable を実装しています

直列化されたフィールド

localhostIPAddress

byte[] localhostIPAddress
推奨されていません。

localhostAddress

String localhostAddress
推奨されていません。

localhostName

String localhostName
推奨されていません。

クラス jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException は IOException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.data

クラス jp.co.intra_mart.framework.base.data.DAOException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.data.DataAccessException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.data.DataConnectException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.data.DataConnectorException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.data.DataManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.data.DataPropertyException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.data.container

クラス jp.co.intra_mart.framework.base.data.container.DataContainerException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.event.container

クラス jp.co.intra_mart.framework.base.event.container.EventContainerException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.event

クラス jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sessionContext

SessionContext sessionContext
セッションコンテキスト

クラス jp.co.intra_mart.framework.base.event.EmptyEvent は Event を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.Event は Object を拡張し、Serializable を実装しています

直列化されたフィールド

application

String application
アプリケーション

key

String key
イベントキー

loginUserID

String loginUserID
ログインユーザ

loginGroupID

String loginGroupID
ログイングループ

info

UserInfo info
ユーザ情報

クラス jp.co.intra_mart.framework.base.event.EventException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.EventListenerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.EventManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.EventPropertyException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.EventTriggerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean は EJBEventListenerAgentBean を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean は EJBEventListenerAgentBean を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.message

クラス jp.co.intra_mart.framework.base.message.MessageManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.message.MessagePropertyException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.service

クラス jp.co.intra_mart.framework.base.service.IntramartConnectServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

serviceManager

ServiceManager serviceManager
推奨されていません。
サービスマネージャ

serviceHandler

ServicePropertyHandler serviceHandler
推奨されていません。
サービスプロパティハンドラ

sessionManager

SessionManager sessionManager
推奨されていません。
セッションマネージャ

sessionHandler

SessionPropertyHandler sessionHandler
推奨されていません。
セッションプロパティハンドラ

referrerFormatShort

boolean referrerFormatShort
推奨されていません。
referrerのフォーマット

導入されたバージョン:
4.1.5

クラス jp.co.intra_mart.framework.base.service.RequestException は ApplicationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.service.ServiceControllerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.service.ServiceManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.service.ServicePropertyException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.service.ServiceServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

manager

ServiceManager manager
サービスマネージャ

handler

ServicePropertyHandler handler
サービスプロパティハンドラ

クラス jp.co.intra_mart.framework.base.service.ServiceServletException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.service.TransitionException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.service.container

クラス jp.co.intra_mart.framework.base.service.container.ServiceContainerException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.service.controller

クラス jp.co.intra_mart.framework.base.service.controller.ControllerConverterException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.service.controller.RequestFormatException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.service.validator

クラス jp.co.intra_mart.framework.base.service.validator.ValidationException は RequestException を拡張し、Serializable を実装しています

直列化されたフィールド

validationExceptionDetails

Collection validationExceptionDetails
検証例外の詳細

クラス jp.co.intra_mart.framework.base.service.validator.ValidatorException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.session

クラス jp.co.intra_mart.framework.base.session.IllegalSessionException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.session.SessionFactoryException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.session.SessionManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.session.SessionObjectException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.session.SessionPropertyException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.util

クラス jp.co.intra_mart.framework.base.util.ConfigurationUserInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

clientType

String clientType

colorPatternID

String colorPatternID

encoding

String encoding

language

String language

country

String country

variant

String variant

loginGroupID

String loginGroupID

loginTime

Date loginTime

loginType

String loginType

userID

String userID

クラス jp.co.intra_mart.framework.base.util.EmptyUserInfo は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.util.UserInfoException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.util.UserInfoWrapper は Object を拡張し、Serializable を実装しています

直列化されたフィールド

userInfo

UserInfo userInfo

パッケージ jp.co.intra_mart.framework.base.web.bean

クラス jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean は HelperBean を拡張し、Serializable を実装しています

直列化されたフィールド

exception

Throwable exception
例外

クラス jp.co.intra_mart.framework.base.web.bean.HelperBean は Object を拡張し、Serializable を実装しています

直列化されたフィールド

eventManager

EventManager eventManager
イベントマネージャ

serviceHandler

ServicePropertyHandler serviceHandler
サービスプロパティハンドラ

sessionHandler

SessionPropertyHandler sessionHandler
セッションプロパティハンドラ

request

HttpServletRequest request
リクエスト

response

HttpServletResponse response
レスポンス

userInfo

UserInfo userInfo
ユーザ情報

クラス jp.co.intra_mart.framework.base.web.bean.HelperBeanException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.web.tag

クラス jp.co.intra_mart.framework.base.web.tag.FormTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

sessionManager

SessionManager sessionManager
セッションマネージャ

sessionHandler

SessionPropertyHandler sessionHandler
セッションプロパティハンドラ

serviceManager

ServiceManager serviceManager
サービスマネージャ

serviceHandler

ServicePropertyHandler serviceHandler
サービスプロパティハンドラ

coreAttrs

CoreAttributes coreAttrs
コア属性

i18n

I18nAttributes i18n
国際化属性

events

EventsAttributes events
イベント属性

application

String application
アプリケーション

service

String service
サービス

method

String method
method

enctype

String enctype
enctype

accept

String accept
accept

name

String name
name

onSubmit

String onSubmit
onSubmit

onReset

String onReset
onReset

acceptCharset

String acceptCharset
accept-charset

target

String target
target

クラス jp.co.intra_mart.framework.base.web.tag.FrameTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

sessionManager

SessionManager sessionManager
セッションマネージャ

sessionHandler

SessionPropertyHandler sessionHandler
セッションプロパティハンドラ

serviceManager

ServiceManager serviceManager
サービスマネージャ

serviceHandler

ServicePropertyHandler serviceHandler
サービスプロパティハンドラ

coreAttrs

CoreAttributes coreAttrs
コア属性

params

Collection params
パラメータの集合

application

String application
アプリケーション

service

String service
サービス

longdesc

String longdesc
longdesc

name

String name
name

frameborder

String frameborder
frameborder

marginwidth

String marginwidth
marginwidth

marginheight

String marginheight
marginheight

noresize

String noresize
noresize

scrolling

String scrolling
scrolling

クラス jp.co.intra_mart.framework.base.web.tag.FrameworkTagException は JspException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.web.tag.HelperBeanTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

helperclass

String helperclass
クラス名

クラス jp.co.intra_mart.framework.base.web.tag.LinkTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

sessionManager

SessionManager sessionManager
セッションマネージャ

sessionHandler

SessionPropertyHandler sessionHandler
セッションプロパティハンドラ

serviceManager

ServiceManager serviceManager
サービスマネージャ

serviceHandler

ServicePropertyHandler serviceHandler
サービスプロパティハンドラ

coreAttrs

CoreAttributes coreAttrs
コア属性

i18n

I18nAttributes i18n
国際化属性

events

EventsAttributes events
イベント属性

params

Collection params
パラメータの集合

application

String application
アプリケーション

service

String service
サービス

charset

String charset
charset

type

String type
type

name

String name
name

hreflang

String hreflang
hreflang

rel

String rel
rel

rev

String rev
rev

accesskey

String accesskey
accesskey

shape

String shape
shape

coords

String coords
coords

target

String target
target

導入されたバージョン:
3.2

tabindex

String tabindex
tabindex

onfocus

String onfocus
onfocus

onblur

String onblur
onblur

クラス jp.co.intra_mart.framework.base.web.tag.MessageParamTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

value

Object value
パラメータの値

クラス jp.co.intra_mart.framework.base.web.tag.MessageTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

messageManager

MessageManager messageManager
MessageManager

serviceManager

ServiceManager serviceManager
ServiceManager

params

Vector params
パラメータの集合

application

String application
アプリケーション

key

String key
キー

locale

String locale
ロケール

クラス jp.co.intra_mart.framework.base.web.tag.ParamTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
パラメータ名

value

String value
パラメータの値

クラス jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

serviceHandler

ServicePropertyHandler serviceHandler
サービスプロパティハンドラ

coreAttrs

CoreAttributes coreAttrs
コア属性

i18n

I18nAttributes i18n
国際化属性

events

jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag.SubmitLinkEventsAttributes events
イベント属性

application

String application
アプリケーション

service

String service
サービス

form

String form
フォーム名

name

String name
name

accesskey

String accesskey
accesskey

shape

String shape
shape

coords

String coords
coords

tabindex

String tabindex
tabindex

onfocus

String onfocus
onfocus

onblur

String onblur
onblur

serviceManager

ServiceManager serviceManager
サービスマネージャ

導入されたバージョン:
4.3

sessionManager

SessionManager sessionManager
セッションマネージャ

導入されたバージョン:
4.3

クラス jp.co.intra_mart.framework.base.web.tag.SubmitTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

serviceHandler

ServicePropertyHandler serviceHandler
サービスプロパティハンドラ

coreAttrs

CoreAttributes coreAttrs
コア属性

i18n

I18nAttributes i18n
国際化属性

events

jp.co.intra_mart.framework.base.web.tag.SubmitTag.SubmitEventsAttributes events
イベント属性

application

String application
アプリケーション

service

String service
サービス

name

String name
name

value

String value
value

tabindex

String tabindex
tabindex

onFocus

String onFocus
onFocus

onBlur

String onBlur
onBlur

serviceManager

ServiceManager serviceManager
サービスマネージャ

導入されたバージョン:
4.3

sessionManager

SessionManager sessionManager
セッションマネージャ

導入されたバージョン:
4.3

sessionHandler

SessionPropertyHandler sessionHandler
セッションプロパティハンドラ

導入されたバージョン:
4.3

パッケージ jp.co.intra_mart.framework.extension.seasar.util

クラス jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedUserInfo は UserInfoWrapper を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.system.exception

クラス jp.co.intra_mart.framework.system.exception.ApplicationException は FrameworkException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.system.exception.FrameworkException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.system.exception.FrameworkRuntimeException は RuntimeException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.system.exception.IllegalSystemException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.system.exception.IMContainerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.system.exception.SystemException は FrameworkException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.system.log

クラス jp.co.intra_mart.framework.system.log.LogPropertyException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.system.message

クラス jp.co.intra_mart.framework.system.message.MessageManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.system.message.MessagePropertyException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.system.property

クラス jp.co.intra_mart.framework.system.property.PropertyHandlerException は FrameworkException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.system.property.PropertyManagerException は FrameworkException を拡張し、Serializable を実装しています

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.acssecurity.AccountManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.acssecurity.AccountManager の使用

jp.co.intra_mart.foundation.acssecurity.AccountManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.acssecurity.AcsData の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.acssecurity.AcsData の使用

jp.co.intra_mart.foundation.acssecurity.AcsData はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.acssecurity.AcssecurityException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.acssecurity.AcssecurityException の使用

AcssecurityException を使用しているパッケージ
jp.co.intra_mart.foundation.acssecurity アクセスセキュリティモジュールを利用するためのクラスを提供します。

jp.co.intra_mart.foundation.acssecurity での AcssecurityException の使用

AcssecurityException をスローする jp.co.intra_mart.foundation.acssecurity のメソッド
 void RoleManager.setData(Map datas)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
 void RoleManager.setData(Map datas, boolean isTransaction)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
 boolean RoleManager.contains(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.contains(String)に置き換えられました。
 int RoleManager.count()
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.count()に置き換えられました。
 Vector RoleManager.getIDs()
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRoleIds()に置き換えられました。
 Map RoleManager.getData(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRole(String)に置き換えられました。
 void RoleManager.delData(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
 void RoleManager.delData(String roleId, boolean isTransaction)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
 String RoleManager.getIdByName(String roleName)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.searchRolesByName(String)に置き換えられました。
 String[] RoleManager.getListData(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getAllSubRoleIds(String)に置き換えられました。
 String[] RoleManager.getParentData(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getParentRoleIds(String)に置き換えられました。
 void AccountManager.setData(Map datas)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.addAcount(Account) およびupdateAccount(Account)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.registerAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.domain.user.UserManagerを利用して、更新してください。
 void AccountManager.setData(Map datas, boolean isTransaction)
推奨されていません。
 boolean AccountManager.contains(String userId)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.contains(String)に置き換えられました。
 int AccountManager.count()
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.count()に置き換えられました。
 Vector AccountManager.getIDs()
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getUserIds()に置き換えられました。
 Map AccountManager.getData(String userId)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getAccount(String)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.isRegisteredAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.model.user.UserMapperを利用して取得してください。
 void AccountManager.delData(String uid)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。
 void AccountManager.delData(String uid, boolean isTransaction)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.acssecurity.Logingp の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.acssecurity.Logingp の使用

jp.co.intra_mart.foundation.acssecurity.Logingp はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.acssecurity.RoleManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.acssecurity.RoleManager の使用

jp.co.intra_mart.foundation.acssecurity.RoleManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AccountManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.acssecurity
クラス AccountManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.acssecurity.AccountManager
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManagerに置き換えられました。

public class AccountManager
extends Object

ログインユーザ情報を操作します。

コンストラクタの概要
AccountManager(String login_grp)
推奨されていません。
メソッドの概要
 boolean contains(String userId)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.contains(String)に置き換えられました。
 int count()
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.count()に置き換えられました。
 void delData(String uid)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。
 void delData(String uid, boolean isTransaction)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。
 Map getData(String userId)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getAccount(String)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.isRegisteredAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.model.user.UserMapperを利用して取得してください。
 Vector getIDs()
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getUserIds()に置き換えられました。
 void setData(Map datas)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.addAcount(Account) およびupdateAccount(Account)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.registerAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.domain.user.UserManagerを利用して、更新してください。
 void setData(Map datas, boolean isTransaction)
推奨されていません。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AccountManager

public AccountManager(String login_grp)
推奨されていません。

コンストラクタ

パラメータ:
login_grp - ログイングループID
メソッドの詳細

setData

public void setData(Map datas)
             throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.addAcount(Account) およびupdateAccount(Account)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.registerAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.domain.user.UserManagerを利用して、更新してください。

ユーザデータを登録する

DBを使用する場合,このメソッドは内部でDBトランザクションを発行します。 このメソッドをDBトランザクション内で使用しないで下さい。

パラメータ:
datas - ユーザデータ

例外:
AcssecurityException -

引数 datas(Map)の内容
      (key == value)

         以下、IMISに登録されるデータ。
         DBを使用する場合,（＊）印のデータはIMISとDBの同期をとる。

         id      = ユーザID(String)[必須]（＊）
         pwd     = パスワード(String)
         mpwd    = モバイル用パスワード(String)
         name    = ユーザ名(String)[必須]（＊）
         madrs   = メールアドレス(String)（＊）
         mbladrs = モバイル用メールアドレス(String)（＊）
         explan  = 説明(String)
         vldDate = 有効期限(Double(ミリ秒))
         roles   = ロールIDの配列(String[])
         license = ライセンス(Boolean あり true/なし false)
         apps    = アプリケーションロール(String[]) （V4.0.0以上）

         以下、DBにのみ登録されるデータ。
                    (get()メソッドでは取得できない)
         kana    = ユーザ名カナ(String)
         eng     = ユーザ名英字(String)
         tel     = 電話番号(String)
         hndy    = 携帯電話番号(String)
         fax     = FAX番号(String)
         extens  = 内線電話番号(String)
         exFax   = 内線FAX(String)
         cntry_cd =  国コード(String)
         zip     = 郵便番号(String)
         adrs    = 住所(String)
         madrs2  = メールアドレス２(String)
         url     = URL(String)
         note    = 備考(String)
         mainGp  = 主所属グループCD(String)
         groups  = 所属グループCDの配列(String[])
         その他 各アプリに依存(String or Double or Boolean)

        引数に指定したユーザIDが既に存在していた場合、上書き(前のデータはなくなり、引数データを追加)する。

setData

public void setData(Map datas,
                    boolean isTransaction)
             throws AcssecurityException
推奨されていません。

ユーザデータを登録する

パラメータ:
datas - ユーザデータ

isTransaction - DBトランザクションフラグ（true このメソッドの中でDBトランザクションを張る。／false このメソッドの中でDBトランザクションを張らない。）

例外:
AcssecurityException -

     引数 datas(Map)の内容

      (key == value)

         以下、IMISに登録されるデータ。
         DBを使用する場合,（＊）印のデータはIMISとDBの同期をとる。

         id      = ユーザID(String)[必須]（＊）
         pwd     = パスワード(String)
         mpwd    = モバイル用パスワード(String)
         name    = ユーザ名(String)[必須]（＊）
         madrs   = メールアドレス(String)（＊）
         mbladrs = モバイル用メールアドレス(String)（＊）
         explan  = 説明(String)
         vldDate = 有効期限(Double(ミリ秒))
         roles   = ロールIDの配列(String[])
         license = ライセンス(Boolean あり true/なし false)
         apps    = アプリケーションロール(String[]) （V4.0.0以上）

         以下、DBにのみ登録されるデータ。
                    (get()メソッドでは取得できない)
         kana    = ユーザ名カナ(String)
         eng     = ユーザ名英字(String)
         tel     = 電話番号(String)
         hndy    = 携帯電話番号(String)
         fax     = FAX番号(String)
         extens  = 内線電話番号(String)
         exFax   = 内線FAX(String)
         cntry_cd =  国コード(String)
         zip     = 郵便番号(String)
         adrs    = 住所(String)
         madrs2  = メールアドレス２(String)
         url     = URL(String)
         note    = 備考(String)
         mainGp  = 主所属グループCD(String)
         groups  = 所属グループCDの配列(String[])
         その他 各アプリに依存(String or Double or Boolean)

        引数に指定したユーザIDが既に存在していた場合、上書きする。

contains

public boolean contains(String userId)
                 throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.contains(String)に置き換えられました。

ユーザデータの存在チェック

パラメータ:
userId - ユーザID
戻り値:
ある true / ない false
例外:
AcssecurityException

count

public int count()
          throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.count()に置き換えられました。

ユーザデータの登録数を取得

戻り値:
登録ユーザ数
例外:
AcssecurityException

getIDs

public Vector getIDs()
              throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getUserIds()に置き換えられました。

ユーザIDをすべて取得する

戻り値:
ユーザIDの配列(データがない場合は空の配列)
例外:
AcssecurityException

getData

public Map getData(String userId)
            throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getAccount(String)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.isRegisteredAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.model.user.UserMapperを利用して取得してください。

ユーザデータの取得

パラメータ:
userId - ユーザID
戻り値:
ユーザ情報（ユーザ情報がなければnull）

     戻り値 (Map)の内容

      (key == value)

         id      = ユーザID(String)
         pwd     = パスワード(String)
         mpwd    = モバイル用パスワード(String)
         name    = ユーザ名(String)[必須]
         madrs   = メールアドレス(String)
         mbladrs = モバイル用メールアドレス(String)
         explan  = 説明(String)
         vldDate = 有効期限(Double(ミリ秒))
         roles   = ロールIDの配列(String[])
         license = ライセンス(Boolean あり true/なし false)
         apps    = アプリケーションロール(String[]) （V4.0.0以上）
例外:
AcssecurityException

delData

public void delData(String uid)
             throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。

ユーザデータを削除する

DBを使用する場合,このメソッドは内部でDBトランザクションを発行します。 このメソッドをDBトランザクション内で使用しないで下さい。

例外:
AcssecurityException

delData

public void delData(String uid,
                    boolean isTransaction)
             throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。

ユーザデータを削除する

パラメータ:
isTransaction - DBトランザクションフラグ（true このメソッドの中でDBトランザクションを張る。／false このメソッドの中でDBトランザクションを張らない。）

例外:
AcssecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AcsData (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.acssecurity
クラス AcsData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.acssecurity.AcsData

public class AcsData
extends Object

ロール、メニュー、メッセージ、アカウント、バッチ、リンク データをインポート／エクスポートします。

※インポート／エクスポート のフォーマットは、system/config/data/format_readme.txtを参照して下さい。

コンストラクタの概要
AcsData()
推奨されていません。
メソッドの概要
static Number acntFromDBToIS(String login_grp)
推奨されていません。 代替えメソッドはありません。
static Number acntFromISToDB(String login_grp)
推奨されていません。 代替えメソッドはありません。
static Number dbConsistChk(String login_grp)
推奨されていません。 代替えメソッドはありません。
static Number delAllAccount(String login_grp)
推奨されていません。 AccountManager.deleteAccounts()に置き換えられました。
static Number delAllLink(String login_grp)
推奨されていません。 代替えメソッドはありません。
static Number delAllMenu(String login_grp)
推奨されていません。 MenuManager.deleteMenuItems()に置き換えられました。
static Number delAllMessage(String login_grp)
推奨されていません。 代替えメソッドはありません。
static Number delAllRole(String login_grp)
推奨されていません。 RoleManager.deleteRoles()に置き換えられました。
static Number delAllSchedule(String login_grp)
推奨されていません。 BatchManager.deleteBatches()に置き換えられました。
static Number getAccount(String login_grp, String path)
推奨されていません。 AccountManager.exportData(String category, OutputStream outputStream)に置き換えられました。
static Number getLink(String login_grp, String path)
推奨されていません。 代替えメソッドはありません。
static Number getMenu(String login_grp, String path)
推奨されていません。 MenuManager.exportData(String category, OutputStream outputStream)に置き換えられました。
static Number getMessage(String login_grp, String path)
推奨されていません。 代替えメソッドはありません。
static Number getRole(String login_grp, String path)
推奨されていません。 RoleManager.exportData(String category, OutputStream outputStream)に置き換えられました。
static Number getSchedule(String login_grp, String path)
推奨されていません。 BatchManager.exportData(String category, OutputStream outputStream)に置き換えられました。
static Number setAccount(String login_grp, String path)
推奨されていません。 AccountManager.importData(String category, InputStream inputStream)に置き換えられました。
static Number setLink(String login_grp, String path)
推奨されていません。 代替えメソッドはありません。
static Number setMenu(String login_grp, String path)
推奨されていません。 MenuManager.importData(String category, InputStream inputStream)に置き換えられました。
static Number setMessage(String login_grp, String path)
推奨されていません。 代替えメソッドはありません。
static Number setRole(String login_grp, String path)
推奨されていません。 RoleManager.importData(String category, InputStream inputStream)に置き換えられました。
static Number setSchedule(String login_grp, String path)
推奨されていません。 BatchManager.importData(String category, InputStream inputStream)に置き換えられました。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AcsData

public AcsData()
推奨されていません。
メソッドの詳細

setRole

public static Number setRole(String login_grp,
                             String path)
推奨されていません。 RoleManager.importData(String category, InputStream inputStream)に置き換えられました。

ロールデータをインポートする

このメソッドは同期をとりません。複数のリクエストから同時に 実行されるような場所には使用しないで下さい。 指定のファイル内のロールデータを Infomation Server へ登録します。 データは第1引数で指定したログイングループに登録されます。 ファイルは File Server 上にある必要があります。 第2引数のデータファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（imart_error.log）に出力されます。 (指定のフォーマットにそぐわないデータがある場合、処理が遅くなります。) 既に同一のロールIDがシステムに登録されている場合、上書きされます。

パラメータ:
login_grp - ログイングループID
path - データファイルパス
戻り値:
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正
3： システムエラー
6： パスがディレクトリである

setMenu

public static Number setMenu(String login_grp,
                             String path)
推奨されていません。 MenuManager.importData(String category, InputStream inputStream)に置き換えられました。

メニューデータをインポートする

このメソッドは同期をとりません。複数のリクエストから同時に 実行されるような場所には使用しないで下さい。 指定のファイル内のロールデータを Infomation Server へ登録します。 データは第1引数で指定したログイングループに登録されます。 ファイルは File Server 上にある必要があります。 第2引数のデータファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（imart_error.log）に出力されます。 (指定のフォーマットにそぐわないデータがある場合、処理が遅くなります。) 既に同一のロールIDがシステムに登録されている場合、上書きされます。

パラメータ:
login_grp - ログイングループID
path - データファイルパス
戻り値:
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正
3：システムエラー
6：パスがディレクトリである

setMessage

public static Number setMessage(String login_grp,
                                String path)
推奨されていません。 代替えメソッドはありません。

メッセージデータをインポートする

このメソッドは同期をとりません。複数のリクエストから同時に 実行されるような場所には使用しないで下さい。 指定のファイル内のロールデータを Infomation Server へ登録します。 データは第1引数で指定したログイングループに登録されます。 ファイルは File Server 上にある必要があります。 第2引数のデータファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（imart_error.log）に出力されます。 (指定のフォーマットにそぐわないデータがある場合、処理が遅くなります。) 既に同一のロールIDがシステムに登録されている場合、上書きされます。

パラメータ:
login_grp - ログイングループID
path - データファイルパス
戻り値:
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正

setAccount

public static Number setAccount(String login_grp,
                                String path)
推奨されていません。 AccountManager.importData(String category, InputStream inputStream)に置き換えられました。

アカウントデータをインポートする

このメソッドは同期をとりません。複数のリクエストから同時に 実行されるような場所には使用しないで下さい。 指定のファイル内のロールデータを Infomation Server へ登録します。 データは第1引数で指定したログイングループに登録されます。 ファイルは File Server 上にある必要があります。 第2引数のデータファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（imart_error.log）に出力されます。 (指定のフォーマットにそぐわないデータがある場合、処理が遅くなります。) 既に同一のロールIDがシステムに登録されている場合、上書きされます。

パラメータ:
login_grp - ログイングループID
path - データファイルパス
戻り値:
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正
3：システムエラー
6：パスがディレクトリである

setSchedule

public static Number setSchedule(String login_grp,
                                 String path)
推奨されていません。 BatchManager.importData(String category, InputStream inputStream)に置き換えられました。

バッチデータをインポートする

このメソッドは同期をとりません。複数のリクエストから同時に 実行されるような場所には使用しないで下さい。 指定のファイル内のロールデータを Infomation Server へ登録します。 データは第1引数で指定したログイングループに登録されます。 ファイルは File Server 上にある必要があります。 第2引数のデータファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（imart_error.log）に出力されます。 (指定のフォーマットにそぐわないデータがある場合、処理が遅くなります。) 既に同一のロールIDがシステムに登録されている場合、上書きされます。

パラメータ:
login_grp - ログイングループID
path - データファイルパス
戻り値:
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正
3：システムエラー
6：パスがディレクトリである

setLink

public static Number setLink(String login_grp,
                             String path)
推奨されていません。 代替えメソッドはありません。

リンクデータをインポートする

このメソッドは同期をとりません。複数のリクエストから同時に 実行されるような場所には使用しないで下さい。 指定のファイル内のロールデータを Infomation Server へ登録します。 データは第1引数で指定したログイングループに登録されます。 ファイルは File Server 上にある必要があります。 第2引数のデータファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（imart_error.log）に出力されます。 (指定のフォーマットにそぐわないデータがある場合、処理が遅くなります。) 既に同一のロールIDがシステムに登録されている場合、上書きされます。

パラメータ:
login_grp - ログイングループID
path - データファイルパス
戻り値:
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正

getRole

public static Number getRole(String login_grp,
                             String path)
推奨されていません。 RoleManager.exportData(String category, OutputStream outputStream)に置き換えられました。

ロール情報をエクスポートする

指定のログイングループ内のロールデータを ファイルへ出力します。 ファイルは File Server 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。

パラメータ:
login_grp - ログイングループID
path - 出力ファイルパス
戻り値:
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
3：エクスポートするデータがない
4：ファイルへの書き込みに失敗
5：引数が不正
6：パスがディレクトリである。

getMenu

public static Number getMenu(String login_grp,
                             String path)
推奨されていません。 MenuManager.exportData(String category, OutputStream outputStream)に置き換えられました。

メニュー情報をエクスポートする

指定のログイングループ内のロールデータを ファイルへ出力します。 ファイルは File Server 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。

パラメータ:
login_grp - ログイングループID
path - 出力ファイルパス
戻り値:
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
3：エクスポートするデータがない
4：ファイルへの書き込みに失敗
5：引数が不正
6：パスがディレクトリである。

getMessage

public static Number getMessage(String login_grp,
                                String path)
推奨されていません。 代替えメソッドはありません。

メッセージ情報をエクスポートする

指定のログイングループ内のロールデータを ファイルへ出力します。 ファイルは File Server 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。

パラメータ:
login_grp - ログイングループID
path - 出力ファイルパス
戻り値:
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
3：エクスポートするデータがない
4：ファイルへの書き込みに失敗
5：引数が不正
6：パスがディレクトリである。

getAccount

public static Number getAccount(String login_grp,
                                String path)
推奨されていません。 AccountManager.exportData(String category, OutputStream outputStream)に置き換えられました。

アカウント情報をエクスポートする

指定のログイングループ内のロールデータを ファイルへ出力します。 ファイルは File Server 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。

パラメータ:
login_grp - ログイングループID
path - 出力ファイルパス
戻り値:
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
3：エクスポートするデータがない
4：ファイルへの書き込みに失敗
5：引数が不正
6：パスがディレクトリである。

getSchedule

public static Number getSchedule(String login_grp,
                                 String path)
推奨されていません。 BatchManager.exportData(String category, OutputStream outputStream)に置き換えられました。

バッチ情報をエクスポートする

指定のログイングループ内のロールデータを ファイルへ出力します。 ファイルは File Server 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。

パラメータ:
login_grp - ログイングループID
path - 出力ファイルパス
戻り値:
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
3：エクスポートするデータがない
4：ファイルへの書き込みに失敗
5：引数が不正
6：パスがディレクトリである。

getLink

public static Number getLink(String login_grp,
                             String path)
推奨されていません。 代替えメソッドはありません。

リンク情報をエクスポートする

指定のログイングループ内のロールデータを ファイルへ出力します。 ファイルは File Server 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。

パラメータ:
login_grp - ログイングループID
path - 出力ファイルパス
戻り値:
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
3：エクスポートするデータがない
4：ファイルへの書き込みに失敗
5：引数が不正

delAllRole

public static Number delAllRole(String login_grp)
推奨されていません。 RoleManager.deleteRoles()に置き換えられました。

ロール情報を全て削除する

指定のログイングループ内のロールデータを 全て削除します。

パラメータ:
login_grp - ログイングループID
戻り値:
0：削除成功
2：引数が不正
3: システムエラー

delAllMenu

public static Number delAllMenu(String login_grp)
推奨されていません。 MenuManager.deleteMenuItems()に置き換えられました。

メニュー情報を全て削除する

指定のログイングループ内のロールデータを 全て削除します。

パラメータ:
login_grp - ログイングループID
戻り値:
0：削除成功
2：引数が不正
3: システムエラー

delAllMessage

public static Number delAllMessage(String login_grp)
推奨されていません。 代替えメソッドはありません。

メッセージ情報を全て削除する

指定のログイングループ内のロールデータを 全て削除します。

パラメータ:
login_grp - ログイングループID
戻り値:
0：削除成功
2：引数が不正

delAllAccount

public static Number delAllAccount(String login_grp)
推奨されていません。 AccountManager.deleteAccounts()に置き換えられました。

アカウント情報を全て削除する

指定のログイングループ内のロールデータを 全て削除します。

パラメータ:
login_grp - ログイングループID
戻り値:
0：削除成功
2：引数が不正

delAllSchedule

public static Number delAllSchedule(String login_grp)
推奨されていません。 BatchManager.deleteBatches()に置き換えられました。

バッチ情報を全て削除する

指定のログイングループ内のロールデータを 全て削除します。

パラメータ:
login_grp - ログイングループID
戻り値:
0：削除成功
2：引数が不正

delAllLink

public static Number delAllLink(String login_grp)
推奨されていません。 代替えメソッドはありません。

リンク情報を全て削除する

指定のログイングループ内のロールデータを 全て削除します。

パラメータ:
login_grp - ログイングループID
戻り値:
0：削除成功
2：引数が不正

dbConsistChk

public static Number dbConsistChk(String login_grp)
推奨されていません。 代替えメソッドはありません。

DBとInfomationサーバとのアカウント情報整合性チェック

DBとInfomationサーバのアカウントデータの数があっているかチェックします。

パラメータ:
login_grp - ログイングループID
戻り値:
0：不整合なし
1：ＤＢにデータが不足している
2：ＤＢのデータが多い
3：DBに接続できない。またはDBにテーブル(b_m_user)がない。
4：引数が不正

acntFromISToDB

public static Number acntFromISToDB(String login_grp)
推奨されていません。 代替えメソッドはありません。

Infomationサーバのアカウント情報をDBへ入れる

このメソッドは同期をとりません。複数のリクエストから同時に 実行されるような場所には使用しないで下さい。 このメソッドは内部でDBトランザクションを発行しています。このメソッドを トランザクション内で使用しないで下さい。 このメソッドは登録しているユーザ数に処理時間が依存します。サーバ環境にも よりますが、数分から数十分処理時間がかかる場合があります。 Infomationサーバのアカウント情報をDBのユーザ管理テーブルへ入れます。 既にDBに登録してあるユーザは処理しません。 （Infomationサーバに存在し、DBにないユーザだけをDBに 追加します。DBの既存データの更新は行いません。）

パラメータ:
login_grp - ログイングループID
戻り値:
0：登録成功
1：DBに接続できない。またはDBにテーブル(b_m_user)がない。
2：引数が不正

acntFromDBToIS

public static Number acntFromDBToIS(String login_grp)
推奨されていません。 代替えメソッドはありません。

DBのアカウント情報をInfomationサーバへ入れる

このメソッドは同期をとりません。複数のリクエストから同時に 実行されるような場所には使用しないで下さい。 このメソッドは登録しているユーザ数に処理時間が依存します。サーバ環境にも よりますが、数分から数十分処理時間がかかる場合があります。 DBのユーザ管理テーブルのアカウント情報をInfomationサーバへ入れます。 既にInfomationサーバに登録してあるユーザは処理しません。 （DBに存在し、InfomationサーバにないユーザだけをInfomationサーバに 追加します。Infomationサーバの既存データの更新は行いません。） ユーザIDをパスワードとして登録します。 そのとき、ユーザIDが14桁を越えている場合は15桁目以降をカットします。 i-modeパスワードは登録しません。 ライセンスなしで登録します。 有効期限は無期限で登録します。 ロール情報は登録しません。

パラメータ:
login_grp - ログイングループID
戻り値:
0：登録成功
1：DBに接続できない。またはDBにテーブル(b_m_user)がない。
2：引数が不正
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AcssecurityException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.acssecurity
クラス AcssecurityException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.acssecurity.AcssecurityException
すべての実装インタフェース:
Serializable
public class AcssecurityException
extends Exception

アクセスセキュリティ情報操作時にエラーが発生した場合にスローされます。

関連項目:
直列化された形式

メソッドの概要
int | getCode()
String | getMessage()
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

メソッドの詳細

getMessage

public String getMessage()

getCode

public int getCode()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Logingp (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.acssecurity
クラス Logingp

java.lang.Object
    拡張 jp.co.intra_mart.foundation.acssecurity.Logingp

public class Logingp
extends Object

ログイングループ情報を操作します。

コンストラクタの概要
Logingp(String login_grp)
推奨されていません。 LoginGroupManagerに置き換えられました。
メソッドの概要
static Number count()
推奨されていません。 LoginGroupManager.countLoginGroups()に置き換えられました。
 Boolean del(String key)
推奨されていません。 代替えメソッドはありません。
static List entries()
推奨されていません。 LoginGroupManager.getLoginGroupIds()に置き換えられました。
 Object get(String key)
推奨されていません。 代替えメソッドはありません。
static Boolean isGroup(String login_grp)
推奨されていません。 代替えメソッドはありません。
 Boolean set(String key, Number value)
推奨されていません。 代替えメソッドはありません。
 Boolean set(String key, String value)
推奨されていません。 代替えメソッドはありません。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Logingp

public Logingp(String login_grp)
推奨されていません。 LoginGroupManagerに置き換えられました。

コンストラクタ

パラメータ:
login_grp - ログイングループID
メソッドの詳細

count

public static Number count()
推奨されていません。 LoginGroupManager.countLoginGroups()に置き換えられました。

登録されているログイングループ数を返す

戻り値:
ログイングループ数

entries

public static List entries()
推奨されていません。 LoginGroupManager.getLoginGroupIds()に置き換えられました。

登録されているログイングループIDの配列を取得する。

戻り値:
ログイングループIDの配列
(データがないときnull)

isGroup

public static Boolean isGroup(String login_grp)
推奨されていません。 代替えメソッドはありません。

指定のログイングループの存在チェック

パラメータ:
login_grp - ログイングループID
戻り値:
ある true/ない false

del

public Boolean del(String key)
推奨されていません。 代替えメソッドはありません。

ログイングループ付随情報を削除する。

set()メソッドで登録した値を削除する。

パラメータ:
key - データのキー

戻り値:
成功 true/失敗 false

get

public Object get(String key)
推奨されていません。 代替えメソッドはありません。

ログイングループ付随情報を取得する。

set()メソッドで登録した値を取得する。

パラメータ:
key - データのキー

戻り値:
set()メソッドで登録した値(String、Number)

set

public Boolean set(String key,
                   Number value)
推奨されていません。 代替えメソッドはありません。

ログイングループ付随情報をセットする。

パラメータ:
key - データのキー
value - データ
戻り値:
成功 true/失敗 false

set

public Boolean set(String key,
                   String value)
推奨されていません。 代替えメソッドはありません。

ログイングループ付随情報をセットする。

パラメータ:
key - データのキー
value - データ
戻り値:
成功 true/失敗 false
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.acssecurity (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.acssecurity
クラス
AccountManager
AcsData
Logingp
RoleManager
例外
AcssecurityException


jp.co.intra_mart.foundation.acssecurity (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.acssecurity

アクセスセキュリティモジュールを利用するためのクラスを提供します。

参照:
説明

クラスの概要
AccountManager | 推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManagerに置き換えられました。
AcsData | 推奨されていません。
Logingp | 推奨されていません。
RoleManager | 推奨されていません。

例外の概要
AcssecurityException アクセスセキュリティ情報操作時にエラーが発生した場合にスローされます。

パッケージ jp.co.intra_mart.foundation.acssecurity の説明

アクセスセキュリティモジュールを利用するためのクラスを提供します。 このパッケージのクラスを利用することで、アクセスセキュリティ機能の持つ 以下の情報に対してアクセスすることができます。

  • アカウント
  • ログイングループ
  • ロール
  • メニュー
  • メッセージ
  • バッチ
  • リンク

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.foundation.acssecurity クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.acssecurity の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.acssecurity.AccountManager
    • class jp.co.intra_mart.foundation.acssecurity.AcsData
    • class jp.co.intra_mart.foundation.acssecurity.Logingp
    • class jp.co.intra_mart.foundation.acssecurity.RoleManager
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.acssecurity.AcssecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.acssecurity の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.acssecurity の使用

jp.co.intra_mart.foundation.acssecurity を使用しているパッケージ
jp.co.intra_mart.foundation.acssecurity アクセスセキュリティモジュールを利用するためのクラスを提供します。

jp.co.intra_mart.foundation.acssecurity により使用される jp.co.intra_mart.foundation.acssecurity のクラス
AcssecurityException
アクセスセキュリティ情報操作時にエラーが発生した場合にスローされます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


RoleManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.acssecurity
クラス RoleManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.acssecurity.RoleManager

public class RoleManager
extends Object

ロール情報を操作します。

コンストラクタの概要
RoleManager(String login_grp)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManagerに置き換えられました。
メソッドの概要
 boolean contains(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.contains(String)に置き換えられました。
 int count()
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.count()に置き換えられました。
 void delData(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
 void delData(String roleId, boolean isTransaction)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
 Map getData(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRole(String)に置き換えられました。
 String getIdByName(String roleName)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.searchRolesByName(String)に置き換えられました。
 Vector getIDs()
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRoleIds()に置き換えられました。
 String[] getListData(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getAllSubRoleIds(String)に置き換えられました。
 String[] getParentData(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getParentRoleIds(String)に置き換えられました。
 void setData(Map datas)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
 void setData(Map datas, boolean isTransaction)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RoleManager

public RoleManager(String login_grp)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManagerに置き換えられました。

コンストラクタ

パラメータ:
login_grp - ログイングループID
メソッドの詳細

setData

public void setData(Map datas)
             throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。

ロールデータを登録する

DBを使用する場合,このメソッドは内部でDBトランザクションを発行します。 このメソッドをDBトランザクション内で使用しないで下さい。

パラメータ:
datas - ロールデータ

例外:
AcssecurityException -

引数 datas(Map)の内容
(key == value)
id      = ロールID(String)[必須]
         name    = ロール名(String)[必須]
         explan  = 説明(String)
         detail  = 詳細(String)
         roles   = ロールIDの配列(String[])
         search_key = 検索キー(String)

        引数に指定したロールIDが既に存在していた場合、上書きする。

setData

public void setData(Map datas,
                    boolean isTransaction)
             throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。

ロールデータを登録する

パラメータ:
datas - ロールデータ

isTransaction - DBトランザクションフラグ（true このメソッドの中でDBトランザクションを張る。／false このメソッドの中でDBトランザクションを張らない。）

例外:
AcssecurityException -

引数 datas(Map)の内容
(key == value)
id      = ロールID(String)[必須]
         name    = ロール名(String)[必須]
         explan  = 説明(String)
         detail  = 詳細(String)
         roles   = ロールIDの配列(String[])
         search_key = 検索キー(String)

        引数に指定したロールIDが既に存在していた場合、上書きする。

contains

public boolean contains(String roleId)
                 throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.contains(String)に置き換えられました。

ロールデータの存在チェック

パラメータ:
roleId - ロールID
戻り値:
ある true / ない false
例外:
AcssecurityException

count

public int count()
          throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.count()に置き換えられました。

ロールデータの登録数を取得

戻り値:
登録ロール数
例外:
AcssecurityException

getIDs

public Vector getIDs()
              throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRoleIds()に置き換えられました。

ロールIDをすべて取得する

戻り値:
ロールIDの配列(データがない場合は空の配列)
例外:
AcssecurityException

getData

public Map getData(String roleId)
            throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRole(String)に置き換えられました。

ロールデータの取得

パラメータ:
roleId - ロールID
戻り値:
ユーザ情報（ユーザ情報がなければnull）

戻り値 (Map)の内容
(key == value)
id      = ロールID(String)
         name    = ロール名(String)
         explan  = 説明(String)
         detail  = 詳細(String)
         roles   = ロールIDの配列(String[])
         search_key = 検索キー(String)
例外:
AcssecurityException

delData

public void delData(String roleId)
             throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。

ロールデータを削除する

DBを使用する場合,このメソッドは内部でDBトランザクションを発行します。 このメソッドをDBトランザクション内で使用しないで下さい。

パラメータ:
roleId - ロールID
例外:
AcssecurityException

delData

public void delData(String roleId,
                    boolean isTransaction)
             throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。

ロールデータを削除する

パラメータ:
roleId - ロールID
isTransaction - DBトランザクションフラグ（true このメソッドの中でDBトランザクションを張る。／false このメソッドの中でDBトランザクションを張らない。）

例外:
AcssecurityException

getIdByName

public String getIdByName(String roleName)
                   throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.searchRolesByName(String)に置き換えられました。

ロール名からロールIDを取得する

パラメータ:
roleName - ロール名
戻り値:
ロールID(データがない場合はnull)
２つ以上あった場合は先に見つかったほうを返す。
例外:
AcssecurityException

getListData

public String[] getListData(String roleId)
                     throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getAllSubRoleIds(String)に置き換えられました。

サブロールデータの取得(子ロールも含めたロールデータをすべて取得する)

パラメータ:
roleId - ロールID
戻り値:
ロールID配列
例外:
AcssecurityException

getParentData

public String[] getParentData(String roleId)
                       throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getParentRoleIds(String)に置き換えられました。

直接の親（一階層上）ロールIDを取得する

パラメータ:
roleId - ロールID
戻り値:
ロールID配列
例外:
AcssecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.commons.ParameterManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.commons.ParameterManager の使用

ParameterManager を使用しているパッケージ
jp.co.intra_mart.foundation.commons

jp.co.intra_mart.foundation.commons での ParameterManager の使用

ParameterManager を返す jp.co.intra_mart.foundation.commons のメソッド
static ParameterManager ParameterManager.getInstance()
インスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.commons.ParameterSourceProvider の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.commons.ParameterSourceProvider の使用

jp.co.intra_mart.foundation.commons.ParameterSourceProvider はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.commons.SourceProviderHandler の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.commons.SourceProviderHandler の使用

SourceProviderHandler を使用しているパッケージ
jp.co.intra_mart.foundation.commons

jp.co.intra_mart.foundation.commons での SourceProviderHandler の使用

SourceProviderHandler を返す jp.co.intra_mart.foundation.commons のメソッド
static SourceProviderHandler SourceProviderHandler.getInstance()
インスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.commons.validation.InputCheck の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.commons.validation.InputCheck の使用

jp.co.intra_mart.foundation.commons.validation.InputCheck はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


InputCheck (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.commons.validation
クラス InputCheck

java.lang.Object
    拡張 jp.co.intra_mart.foundation.commons.validation.InputCheck
public class InputCheck
extends Object

入力チェック関数ライブラリ

導入されたバージョン:
4.2

コンストラクタの概要
InputCheck()
メソッドの概要
static int | checkDigitOfNumber(Number value, Integer integerDigit, Integer floatDigit) 数値の整数部、小数部の桁数チェック（引数がクラス版）。
static int | checkDigitOfNumber(Number value, int integerDigit, int floatDigit) 数値の整数部、小数部の桁数チェック。
static int | checkDigitOfNumberString(String value, Integer integerDigit, Integer floatDigit) 数値（文字型）の整数部、小数部の桁数チェック（引数がクラス版）
static int | checkDigitOfNumberString(String value, int integerDigit, int floatDigit) 数値（文字型）の整数部、小数部の桁数チェック ※数値かどうかのチェックも行う。
static boolean | isDateString(String dateString) 日付文字列が日付フォーマット（YYYYMMDD）にそっているかチェックする。
static boolean | isDateTimeString(String dateTimeString) 日時文字列がフォーマット（YYYY-MM-DD HH:MM:SS）にそっているかどうかをチェックする。
static boolean | isDateTimeString(String dateTimeString, SimpleDateFormat df) 日時文字列が指定フォーマットにそっているかどうかをチェックする。
static boolean | isEMailAddress(String str) 入力文字列がメールアドレスの形式をとっているかのチェック。
static boolean | isEmpty(Number value) 数値のNULLチェック。
static boolean | isEmpty(String str) 渡された文字列が、空文字列かまたはNULLかチェック。
static boolean | isExistString(String[] strAry, String str) 配列内に指定した文字列が含まれているかどうかをチェックする。
static boolean | isInput(Number column) カラムの空値チェック。
static boolean | isInput(String column) カラムの空値チェック。
static boolean | isKatakanaString(String str) 文字列が半角カナ文字列かチェックする。
static boolean | isKessaiDateString(String kessaiDateString) 決済年月日(YYYYMMDD)として有効かをチェックする。
static boolean | isLenEqual(Number column, int length) カラムの入力桁数チェック。
static boolean | isLenEqual(Number column, Integer length) カラムの入力桁数チェック（引数がクラス版）。
static boolean | isLenEqual(String column, int byteLength) カラムの入力バイト数チェック。
static boolean | isLenEqual(String column, Integer byteLength) カラムの入力バイト数チェック（引数がクラス版）。
static boolean | isLenLessThan(Number column, int length) カラムの桁数が指定桁数より小さいか(等号を含む)。
static boolean | isLenLessThan(Number column, Integer length) カラムの桁数が指定桁数より小さいか(等号を含む)（引数がクラス版）。
static boolean | isLenLessThan(String column, int byteLength) カラムのバイト数が指定バイト数より小さいか(等号を含む)。
static boolean | isLenLessThan(String column, Integer byteLength) カラムのバイト数が指定バイト数より小さいか(等号を含む)（引数がクラス版）。
static boolean | isLenMoreThan(Number column, int length) カラムの桁数が指定桁数より大きいか(等号を含まない)。
static boolean | isLenMoreThan(Number column, Integer length) カラムの桁数が指定桁数より大きいか(等号を含まない)（引数がクラス版）。
static boolean | isLenMoreThan(String column, int byteLength) カラムのバイト数が指定バイト数より大きいか(等号を含まない)。
static boolean | isLenMoreThan(String column, Integer byteLength) カラムのバイト数が指定バイト数より大きいか(等号を含まない)（引数がクラス版）。
static boolean | isNengetsuString(String nengetsuString) 年月指定文字列が年月フォーマット（YYYYMM）にそっているかチェックする。
static boolean | isNotNull(Object obj) not nullチェック not nullのとき true nullのとき false
static boolean | isNumberString(String value) 文字列が数値かどうかをチェックする。
static boolean | isNumeralRange(String column, Number min, Number max) 指定した数値カラムが指定した数値の範囲なのかチェック 範囲最大値、または最小値と同じ値は範囲内に含まれる。
static boolean | isShimebiString(String shimebiString) 締め日(YYYYMMDD)として有効かをチェックする。
static boolean | isValidDate(String year, String month, String day) 推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。
static boolean | isValueEqual(Number column1, Number column2) カラム１の値とカラム２の値が同一かのチェック。
static boolean | isValueEqual(String column1, String column2) カラム１の値とカラム２の値が同一かのチェック。
static boolean | isValueLessThan(Number column1, Number column2) カラム１の値がカラム２の値より小さいか(等号を含まず)のチェック。
static boolean | isValueLessThan(String column1, String column2) カラム１の値がカラム２の値より小さいか(等号を含まず)のチェック。
static boolean | isValueMoreThan(Number column1, Number column2) カラム１の値がカラム２の値より大きいか(等号を含まず)のチェック。
static boolean | isValueMoreThan(String column1, String column2) カラム１の値がカラム２の値より大きいか(等号を含まず)のチェック。
static boolean | isWeekDate(String dateColumn, int dateFlag) 推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。
static boolean | isWeekDate(String dateColumn, Integer dateFlag) 推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

InputCheck

public InputCheck()
メソッドの詳細

isInput

public static boolean isInput(String column)
カラムの空値チェック。

nullのとき空値
空文字列のときは空値
値が入っているときは空値ではありません
（参照）isEmpty(java.lang.String)

パラメータ:
column - カラム入力文字列
戻り値:
true:空値ではない false:空値

isInput

public static boolean isInput(Number column)
カラムの空値チェック。

nullのとき空値
0のときは空値ではない
NaN,無限大が入っているときは空値ではありません
値が入っているときは空値ではありません
（参照）isEmpty(java.lang.Number)

パラメータ:
column - カラム入力数値
戻り値:
true:空値ではない false:空値

isLenEqual

public static boolean isLenEqual(String column,
                                 int byteLength)
カラムの入力バイト数チェック。

カラムがnullまたは空文字列のときは常にFalseを返す
0バイト指定はFalseを返す

パラメータ:
column - カラム入力文字列
byteLength - カラムのバイト数
戻り値:
true:バイト数が一致 false:バイト数が一致しない

isLenEqual

public static boolean isLenEqual(String column,
                                 Integer byteLength)
カラムの入力バイト数チェック（引数がクラス版）。

パラメータ:
column - カラム入力文字列
byteLength - カラムのバイト数
戻り値:
true:バイト数が一致 false:バイト数が一致しない

isLenEqual

public static boolean isLenEqual(Number column,
                                 int length)
カラムの入力桁数チェック。

カラムがnullのときは常にFalseを返す
カラムに入力された数値を文字列に変換して桁数を比較する
NaN、無限大などの問題は考慮していません
0桁指定はfalseを返す

パラメータ:
column - カラム入力数値
length - 桁数
戻り値:
true:桁数が一致 false:桁数が一致しない

isLenEqual

public static boolean isLenEqual(Number column,
                                 Integer length)
カラムの入力桁数チェック（引数がクラス版）。

パラメータ:
column - カラム入力数値
length - 桁数
戻り値:
true:桁数が一致 false:桁数が一致しない

isLenLessThan

public static boolean isLenLessThan(String column,
                                    int byteLength)
カラムのバイト数が指定バイト数より小さいか(等号を含む)。

カラムがnullまたは空文字列のときは常にFalseを返す
0バイト指定はFalseを返す

パラメータ:
column - カラム入力文字列
byteLength - カラムのバイト数
戻り値:
true:バイト数が指定のものより短いか同じ false:バイト数が指定のものより長い

isLenLessThan

public static boolean isLenLessThan(String column,
                                    Integer byteLength)
カラムのバイト数が指定バイト数より小さいか(等号を含む)（引数がクラス版）。

パラメータ:
column - カラム入力文字列
byteLength - カラムのバイト数
戻り値:
true:バイト数が指定のものより短いか同じ false:バイト数が指定のものより長い

isLenLessThan

public static boolean isLenLessThan(Number column,
                                    int length)
カラムの桁数が指定桁数より小さいか(等号を含む)。

カラムがnullのときは常にFalseを返す
カラムに入力された数値を文字列に変換して桁数を比較する
NaN、無限大などの問題は考慮していません
0桁指定はfalseを返す

パラメータ:
column - カラム入力数値
length - 桁数
戻り値:
true:桁数が指定のものより短いか同じ false:桁数が指定のものより長い

isLenLessThan

public static boolean isLenLessThan(Number column,
                                    Integer length)
カラムの桁数が指定桁数より小さいか(等号を含む)（引数がクラス版）。

パラメータ:
column - カラム入力数値
length - 桁数
戻り値:
true:桁数が指定のものより短いか同じ false:桁数が指定のものより長い

isLenMoreThan

public static boolean isLenMoreThan(String column,
                                    int byteLength)
カラムのバイト数が指定バイト数より大きいか(等号を含まない)。

カラムがnullまたは空文字列のときは常にFalseを返す
0バイト指定はFalseを返す

パラメータ:
column - カラム入力文字列
byteLength - カラムのバイト数
戻り値:
true:バイト数が指定のものより長い false:バイト数が指定のものと同じか短い

isLenMoreThan

public static boolean isLenMoreThan(String column,
                                    Integer byteLength)
カラムのバイト数が指定バイト数より大きいか(等号を含まない)（引数がクラス版）。

パラメータ:
column - カラム入力文字列
byteLength - カラムのバイト数
戻り値:
true:バイト数が指定のものより長い false:バイト数が指定のものと同じか短い

isLenMoreThan

public static boolean isLenMoreThan(Number column,
                                    int length)
カラムの桁数が指定桁数より大きいか(等号を含まない)。

カラムがnullのときは常にFalseを返す
カラムに入力された数値を文字列に変換して桁数を比較する
NaN、無限大などの問題は考慮していません
0桁指定はfalseを返す

パラメータ:
column - カラム入力数値
length - 桁数
戻り値:
true:桁数が指定のものより長い false:桁数が指定のものと同じか短い

isLenMoreThan

public static boolean isLenMoreThan(Number column,
                                    Integer length)
カラムの桁数が指定桁数より大きいか(等号を含まない)（引数がクラス版）。

パラメータ:
column - カラム入力数値
length - 桁数
戻り値:
true:桁数が指定のものより長い false:桁数が指定のものと同じか短い

isValueEqual

public static boolean isValueEqual(String column1,
                                   String column2)
カラム１の値とカラム２の値が同一かのチェック。

大文字、小文字および半角、全角の違う文字は違う文字として扱う
両方null値、または空文字列の場合はtrueを返す
一方がnull値、または空文字列でもう一方が一般の文字列の場合はfalseを返す
nullと空値を比較した場合はtrueを返す

パラメータ:
column1 - 対象文字列１
column2 - 対象文字列２
戻り値:
true:同一文字列 false:異なる文字列

isValueEqual

public static boolean isValueEqual(Number column1,
                                   Number column2)
カラム１の値とカラム２の値が同一かのチェック。

型が違うものが渡された場合はfalseを返す
両方null値の場合はtrueを返す
一方がnull値の場合はfalseを返す

パラメータ:
column1 - 対象値１
column2 - 対象値２
戻り値:
true:同一値 false:異なる値

isValueLessThan

public static boolean isValueLessThan(String column1,
                                      String column2)
カラム１の値がカラム２の値より小さいか(等号を含まず)のチェック。

半角、全角などが混ざってもUnicode順で判断する
一方がnull値、または空文字列の場合は無条件でfalseを返す

パラメータ:
column1 - 対象文字列１
column2 - 対象文字列２
戻り値:
true:カラム１の値がカラム２の値よりも小さい
false:カラム１の値がカラム２の値よりも大きい、または同一値

isValueLessThan

public static boolean isValueLessThan(Number column1,
                                      Number column2)
カラム１の値がカラム２の値より小さいか(等号を含まず)のチェック。

型が違うものが渡された場合はfalseを返す
どちらか一方でもnull値だった場合はfalseを返す
(使用できる型を限定: Integer,Byte,Short,Long,Float,Double)

パラメータ:
column1 - 対象値１
column2 - 対象値２
戻り値:
true:カラム１の値がカラム２の値よりも小さい
false:カラム１の値がカラム２の値よりも大きい、または同一値

isValueMoreThan

public static boolean isValueMoreThan(String column1,
                                      String column2)
カラム１の値がカラム２の値より大きいか(等号を含まず)のチェック。

半角、全角などが混ざってもUnicode順で判断する
一方がnull値、または空文字列の場合は無条件でfalseを返す

パラメータ:
column1 - 対象文字列１
column2 - 対象文字列２
戻り値:
true:カラム１の値がカラム２の値よりも大きい
false:カラム１の値がカラム２の値より小さい、または同一値

isValueMoreThan

public static boolean isValueMoreThan(Number column1,
                                      Number column2)
カラム１の値がカラム２の値より大きいか(等号を含まず)のチェック。

型が違うものが渡された場合はfalseを返す
どちらか一方でもnull値だった場合はfalseを返す
(使用できる型を限定: Integer,Byte,Short,Long,Float,Double)

パラメータ:
column1 - 対象値１
column2 - 対象値２
戻り値:
true:カラム１の値がカラム２の値よりも大きい
false:カラム１の値がカラム２の値よりも小さい、または同一値

isValidDate

public static boolean isValidDate(String year,
                                  String month,
                                  String day)
推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。

日付カラムが有効な範囲なのかチェック

パラメータ:
year - 年
month - 月
day - 日
戻り値:
true:正当な日付 false:不正な日付

isWeekDate

public static boolean isWeekDate(String dateColumn,
                                 int dateFlag)
推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。

日付カラムが銀行営業日なのかチェック。

パラメータ:
dateColumn - 日付文字列
dateFlag - 判定する日付のタイプを示すフラグ 0:営業日判定 1:休日判定
戻り値:
判定条件を満たせばtrue,条件に合わなかったらfalse

isWeekDate

public static boolean isWeekDate(String dateColumn,
                                 Integer dateFlag)
推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。

日付カラムが銀行営業日なのかチェック（引数がクラス版）。

パラメータ:
dateColumn - 日付文字列
dateFlag - 判定する日付のタイプを示すフラグ 0:営業日判定 1:休日判定
戻り値:
判定条件を満たせばtrue,条件に合わなかったらfalse

isNumeralRange

public static boolean isNumeralRange(String column,
                                     Number min,
                                     Number max)
指定した数値カラムが指定した数値の範囲なのかチェック
範囲最大値、または最小値と同じ値は範囲内に含まれる。

数値カラムがnullまたは空文字列の場合はfalseを返す
範囲値の指定のどちらか一方がnullの場合はfalseを返す
範囲値の指定の型が異なる場合はfalseを返す
数値カラムの値を範囲指定のクラスの型に変更して判断を行う
(使用できる型を限定: Integer,Byte,Short,Long,Float,Double)

パラメータ:
column - 数値を示す文字列
min - 範囲最小値
max - 範囲最大値
戻り値:
true:範囲内 false:範囲外

checkDigitOfNumber

public static int checkDigitOfNumber(Number value,
                                     int integerDigit,
                                     int floatDigit)
数値の整数部、小数部の桁数チェック。

Double型の値は有効桁数１６桁
Float型の値は有効桁数７桁
(使用できる型を限定: Integer,Byte,Short,Long,Float,Double)
数値を文字列に変換してcheckDigitOfNumberStringを使用して判断する
（参照）checkDigitOfNumberString(java.lang.String, int, int)

パラメータ:
value - 数値
integerDigit - 整数部桁数
floatDigit - 小数部桁数
戻り値:
0:チェック成功 1:整数部桁数オーバー 2:小数部桁数オーバー 3:整数部、小数部ともに桁数オーバー -1:渡された数値が不正 -2:渡された桁数情報が不正 -3:有効桁数を超えて桁数判断を行おうとしている -4:この関数では扱えない型

checkDigitOfNumber

public static int checkDigitOfNumber(Number value,
                                     Integer integerDigit,
                                     Integer floatDigit)
数値の整数部、小数部の桁数チェック（引数がクラス版）。

パラメータ:
value - 数値
integerDigit - 整数部桁数
floatDigit - 小数部桁数
戻り値:
0:チェック成功 1:整数部桁数オーバー 2:小数部桁数オーバー 3:整数部、小数部ともに桁数オーバー -1:渡された数値が不正 -2:渡された桁数情報が不正 -3:有効桁数を超えて桁数判断を行おうとしている -4:この関数では扱えない型

checkDigitOfNumberString

public static int checkDigitOfNumberString(String value,
                                           int integerDigit,
                                           int floatDigit)
数値（文字型）の整数部、小数部の桁数チェック
※数値かどうかのチェックも行う。

扱える数値文字列は指数表現の入らないものだけとする
(例) 1234567890.0987654321は扱える
12345.67E89といった表現は扱えない
符号も１桁としてカウントする

パラメータ:
value - 数値文字列
integerDigit - 整数部桁数
floatDigit - 小数部桁数
戻り値:
0:チェック成功 1:整数部桁数オーバー 2:小数部桁数オーバー 3:整数部、小数部ともに桁数オーバー -1:渡された文字列が数値ではない -2:渡された桁数情報が不正

checkDigitOfNumberString

public static int checkDigitOfNumberString(String value,
                                           Integer integerDigit,
                                           Integer floatDigit)
数値（文字型）の整数部、小数部の桁数チェック（引数がクラス版）

パラメータ:
value - 数値文字列
integerDigit - 整数部桁数
floatDigit - 小数部桁数
戻り値:
0:チェック成功 1:整数部桁数オーバー 2:小数部桁数オーバー 3:整数部、小数部ともに桁数オーバー -1:渡された文字列が数値ではない -2:渡された桁数情報が不正

isEmpty

public static boolean isEmpty(String str)
渡された文字列が、空文字列かまたはNULLかチェック。

nullのときtrue
空文字列のときtrue
値が入っているときはfalse
（参照）isInput(java.lang.String)

パラメータ:
str - 文字列
戻り値:
true:空文字列またはNULL false:空値

isEmpty

public static boolean isEmpty(Number value)
数値のNULLチェック。

nullのときtrueを返す
0のときはfalseを返す
NaN,無限大が入っているときはfalseを返す
値が入っているときはfalseを返す
（参照）isInput(java.lang.Number)

パラメータ:
value - 数値
戻り値:
true:null false:nullではない

isNumberString

public static boolean isNumberString(String value)
文字列が数値かどうかをチェックする。

パラメータが数字文字列または"1.0f"などのfloat値、"1.0d"などのdouble値を表す場合にtrueが返されます。

パラメータ:
value - 数値文字列
戻り値:
true:数値文字列である false:数値文字列ではない

isDateString

public static boolean isDateString(String dateString)
日付文字列が日付フォーマット（YYYYMMDD）にそっているかチェックする。

パラメータ:
dateString - 日付文字列
戻り値:
true:フォーマットに従っている false:従っていない

isShimebiString

public static boolean isShimebiString(String shimebiString)
締め日(YYYYMMDD)として有効かをチェックする。

（日付として有効かどうかだけをチェックする）

パラメータ:
shimebiString - 日付文字列
戻り値:
true:フォーマットに従っている false:従っていない

isKessaiDateString

public static boolean isKessaiDateString(String kessaiDateString)
決済年月日(YYYYMMDD)として有効かをチェックする。

（営業日として有効かどうかだけをチェックする）

パラメータ:
kessaiDateString - 日付文字列
戻り値:
true:フォーマットに従っている false:従っていない

isNengetsuString

public static boolean isNengetsuString(String nengetsuString)
年月指定文字列が年月フォーマット（YYYYMM）にそっているかチェックする。

パラメータ:
nengetsuString - 年月指定文字列
戻り値:
true:フォーマットに従っている false:従っていない

isDateTimeString

public static boolean isDateTimeString(String dateTimeString)
日時文字列がフォーマット（YYYY-MM-DD HH:MM:SS）にそっているかどうかをチェックする。

パラメータ:
dateTimeString - 日時文字列
戻り値:
true:フォーマットに従っている false:従っていない

isDateTimeString

public static boolean isDateTimeString(String dateTimeString,
                                       SimpleDateFormat df)
日時文字列が指定フォーマットにそっているかどうかをチェックする。

パラメータ:
dateTimeString - 日時文字列
df - 指定フォーマット
戻り値:
true:フォーマットに従っている false:従っていない

isKatakanaString

public static boolean isKatakanaString(String str)
文字列が半角カナ文字列かチェックする。

半角カナ文字と半角スペースだけを許可する

パラメータ:
str - 半角カナ文字列
戻り値:
true:半角カナ文字だけで構成 false:違う種類の文字が含まれる

isExistString

public static boolean isExistString(String[] strAry,
                                    String str)
配列内に指定した文字列が含まれているかどうかをチェックする。

配列の要素のうち、どれか一つの要素が対象文字列を含むならばtrueを返す
対象文字列にnullか空文字列を指定された場合にはfalseを返す

パラメータ:
strAry - 文字列が含まれる配列
str - 対象文字列
戻り値:
true:対象文字列が含まれる false:対象文字列が含まれない

isEMailAddress

public static boolean isEMailAddress(String str)
入力文字列がメールアドレスの形式をとっているかのチェック。

（以下の形式の文字列をエラーとして判定します
☆@がない場合
☆.で始まるユーザ名・ドメイン名
☆.で終わるユーザ名・ドメイン名
☆ドメインに.が無い場合
☆ユーザ名の文字数が3文字未満の場合
☆ユーザ名に.が2文字以上含まれている場合
☆.を含んだドメイン名の文字数が4文字未満の場合
☆ユーザ名に含まれる文字に . _ - 以外の記号が入っている場合
☆ドメイン名に含まれる文字に . - 以外の記号が入っている場合
☆ドメインのピリオドが出現した後に続けてピリオドが出現する
☆最後の.の後、アルファベットが２文字未満しかない
（ＲＦＣ８２２で許可されている記号は!#$%&'*+-/=?^_`{|}~であるがより制限を厳しくする）

パラメータ:
str - メールアドレス
戻り値:
true:メールアドレス形式に合致 false:メールアドレス形式に適合しない

isNotNull

public static boolean isNotNull(Object obj)
not nullチェック not nullのとき true nullのとき false

パラメータ:
obj - チェック対象オブジェクト
戻り値:
true:null以外のとき false:nullのとき
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.commons.validation (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.commons.validation
クラス
InputCheck


jp.co.intra_mart.foundation.commons.validation (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.commons.validation

このパッケージは、入力チェック関数ライブラリを提供します。

参照:
説明

クラスの概要
InputCheck 入力チェック関数ライブラリ

パッケージ jp.co.intra_mart.foundation.commons.validation の説明

このパッケージは、入力チェック関数ライブラリを提供します。


jp.co.intra_mart.foundation.commons.validation クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.commons.validation の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.commons.validation.InputCheck


パッケージ jp.co.intra_mart.foundation.commons.validation の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.commons.validation の使用

jp.co.intra_mart.foundation.commons.validation はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.commons (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.commons
インタフェース
ParameterSourceProvider
クラス
ParameterManager
SourceProviderHandler


jp.co.intra_mart.foundation.commons (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.commons

インタフェースの概要
ParameterSourceProvider アプリケーション共通マスタのパラメータの管理するプロバイダーです。

クラスの概要
ParameterManager | システム共通パラメータ情報の取得を行うクラスです。
SourceProviderHandler |


jp.co.intra_mart.foundation.commons クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.commons の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.commons.ParameterManager
    • class jp.co.intra_mart.foundation.commons.SourceProviderHandler

インタフェース階層

  • interface jp.co.intra_mart.foundation.commons.ParameterSourceProvider


パッケージ jp.co.intra_mart.foundation.commons の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.commons の使用

jp.co.intra_mart.foundation.commons を使用しているパッケージ
jp.co.intra_mart.foundation.commons

jp.co.intra_mart.foundation.commons により使用される jp.co.intra_mart.foundation.commons のクラス
ParameterManager
システム共通パラメータ情報の取得を行うクラスです。
SourceProviderHandler

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParameterManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.commons
クラス ParameterManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.commons.ParameterManager
public class ParameterManager
extends Object

システム共通パラメータ情報の取得を行うクラスです。

導入されたバージョン:
5.1

メソッドの概要
static ParameterManager | getInstance() インスタンスを取得します。
String | getParameter(String paramName) パラメータの値を取得します。
String[] | getParameterNames() パラメータ名の一覧を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getInstance

public static ParameterManager getInstance()
インスタンスを取得します。

戻り値:
インスタンス

getParameter

public String getParameter(String paramName)
パラメータの値を取得します。
指定されたパラメータ名に一致するパラメータが存在しない場合は、null を返します。

パラメータ:
paramName - パラメータ名
戻り値:
パラメータの値

getParameterNames

public String[] getParameterNames()
パラメータ名の一覧を取得します。
パラメータが定義されていない場合は空の配列を返します。

戻り値:
パラメータ名の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ParameterSourceProvider (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.commons
インタフェース ParameterSourceProvider

public interface ParameterSourceProvider

アプリケーション共通マスタのパラメータの管理するプロバイダーです。

導入されたバージョン:
5.1

メソッドの概要
 Map getParameters()
パラメータの一覧を取得します。

メソッドの詳細

getParameters

public Map getParameters()
パラメータの一覧を取得します。

戻り値:
パラメータの一覧を取得します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SourceProviderHandler (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.commons
クラス SourceProviderHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.commons.SourceProviderHandler
public class SourceProviderHandler
extends Object

導入されたバージョン:
5.1

コンストラクタの概要
protected SourceProviderHandler()
コンストラクタ。
メソッドの概要
Object | getClassInstance(String key) ソースプロバイダクラスのインスタンスを取得します。
String | getHandlerName(String key) ソースプロバイダクラス名を取得します。
static SourceProviderHandler | getInstance() インスタンスを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SourceProviderHandler

protected SourceProviderHandler()
コンストラクタ。

例外:
SAXException
IOException
メソッドの詳細

getInstance

public static SourceProviderHandler getInstance()
インスタンスを取得します。

戻り値:
インスタンス

getHandlerName

public String getHandlerName(String key)
ソースプロバイダクラス名を取得します。

識別キーの該当するソースプロバイダクラス名が存在しなかった場合は、空文字列を返却します。

パラメータ:
key - 識別キー
戻り値:
ソースプロバイダクラス名

getClassInstance

public Object getClassInstance(String key)
ソースプロバイダクラスのインスタンスを取得します。

識別キーの該当するソースプロバイダクラス名が存在しなかった場合は、nullを返却します。

パラメータ:
key - 識別キー
戻り値:
ソースプロバイダクラスのインスタンス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.database.ConInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.database.ConInfo の使用

ConInfo を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database での ConInfo の使用

ConInfo を返す jp.co.intra_mart.foundation.database のメソッド
ConInfo | DbsConnection.getConnectionInfo() 推奨されていません。 データベース設定情報を取得します。
ConInfo | DbManager.getConnectInfo() 推奨されていません。 代替えメソッドはありません。

ConInfo 型のパラメータを持つ jp.co.intra_mart.foundation.database のメソッド
static boolean | DbManager.contact(ConInfo dio) 推奨されていません。 代替えメソッドはありません。
Connection | DatabaseAccessor.getConnection(ConInfo conInfo) Connectionオブジェクトを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.database.DatabaseAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.database.DatabaseAccessor の使用

DatabaseAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database での DatabaseAccessor の使用

DatabaseAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.database のメソッド
static void DatabaseManager.setDatabaseAccessor(DatabaseAccessor databaseAccessor)
データベースアクセッサを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DatabaseColumn の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DatabaseColumn の使用

DatabaseColumn を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database での DatabaseColumn の使用

DatabaseColumn を返す jp.co.intra_mart.foundation.database のメソッド
 DatabaseColumn[] DatabaseExport.getColumnsInfo()
推奨されていません。

DatabaseColumn 型のパラメータを持つ jp.co.intra_mart.foundation.database のメソッド
 void DatabaseExport.setColumnsInfo(DatabaseColumn[] columns)
推奨されていません。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DatabaseExport の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DatabaseExport の使用

DatabaseExport を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database での DatabaseExport の使用

DatabaseExport を返す jp.co.intra_mart.foundation.database のメソッド
static DatabaseExport DatabaseExport.getInstance()
推奨されていません。 DatabaseExportインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DatabaseManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DatabaseManager の使用

DatabaseManager を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database での DatabaseManager の使用

DatabaseManager を返す jp.co.intra_mart.foundation.database のメソッド
static DatabaseManager DatabaseManager.getInstance()
データべースマネージャインスタンスを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.database.DataSourceProvider の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.database.DataSourceProvider の使用

DataSourceProvider を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database での DataSourceProvider の使用

DataSourceProvider 型のパラメータを持つ jp.co.intra_mart.foundation.database のメソッド
static void DatabaseManager.setSourceProvider(DataSourceProvider provider)
ソースプロバイダを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DbManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DbManager の使用

jp.co.intra_mart.foundation.database.DbManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.database.DbsConnection の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.database.DbsConnection の使用

DbsConnection を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database での DbsConnection の使用

DbsConnection を返す jp.co.intra_mart.foundation.database のメソッド
 DbsConnection DbManager.getConnection()
推奨されていません。 DatabaseManager.getLoginGroupConnection(String) および DatabaseManager.getSystemConnection(String)を使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.exception.DatabaseExportException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.exception.DatabaseExportException の使用

DatabaseExportException を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database での DatabaseExportException の使用

DatabaseExportException をスローする jp.co.intra_mart.foundation.database のメソッド
void | DatabaseExport.downloadCSV(String sql, String fileName, int startIndex, int maxRow, String connectId, boolean isGroup, boolean isTitle) 推奨されていません。 CSVファイルをダウンロードします。
void | DatabaseExport.downloadCSV(PreparedStatement stmt, String fileName, boolean isTitle) 推奨されていません。 CSVファイルをダウンロードします。
void | DatabaseExport.downloadCSV(PreparedStatement stmt, String fileName, int startIndex, int maxRow, boolean isTitle) 推奨されていません。 CSVファイルをダウンロードします。
int | DatabaseExport.exportCSV(PreparedStatement stmt, OutputStream out, boolean isTitle) 推奨されていません。 CSV形式のデータをストリームに出力します。
int | DatabaseExport.exportCSV(PreparedStatement stmt, OutputStream out, int startIndex, int maxRow, boolean isTitle) 推奨されていません。 CSV形式のデータをストリームに出力します。
int | DatabaseExport.exportCSV(PreparedStatement stmt, NetworkFile file, boolean isTitle) 推奨されていません。 CSVファイルをストレージに出力します。
int | DatabaseExport.exportCSV(PreparedStatement stmt, NetworkFile file, int startIndex, int maxRow, boolean isTitle) 推奨されていません。 CSVファイルをストレージに出力します。
String[] | DatabaseExport.getCSVStrings(PreparedStatement stmt, boolean isTitle) 推奨されていません。 CSV形式のデータ取得します。
String[] | DatabaseExport.getCSVStrings(PreparedStatement stmt, int startIndex, int maxRow, boolean isTitle) 推奨されていません。 CSV形式のデータ取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.exception.DatabaseSQLException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.exception.DatabaseSQLException の使用

jp.co.intra_mart.foundation.database.exception.DatabaseSQLException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DatabaseExportException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database.exception
クラス DatabaseExportException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.database.exception.DatabaseExportException
すべての実装インタフェース:
Serializable
推奨されていません。 システム内部で利用しているクラスです。

public class DatabaseExportException
extends Exception

関連項目:
直列化された形式

フィールドの概要
static int | PROCESS_BUSY 推奨されていません。
static int | WRITE_TIMEOUT 推奨されていません。
コンストラクタの概要
DatabaseExportException(int type)
推奨されていません。
DatabaseExportException(String value, int type)
推奨されていません。
メソッドの概要
 int getErrorType()
推奨されていません。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

フィールドの詳細

PROCESS_BUSY

public static final int PROCESS_BUSY
推奨されていません。
関連項目:
定数フィールド値

WRITE_TIMEOUT

public static final int WRITE_TIMEOUT
推奨されていません。
関連項目:
定数フィールド値
コンストラクタの詳細

DatabaseExportException

public DatabaseExportException(int type)
推奨されていません。

DatabaseExportException

public DatabaseExportException(String value,
                               int type)
推奨されていません。
メソッドの詳細

getErrorType

public int getErrorType()
推奨されていません。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DatabaseSQLException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database.exception
クラス DatabaseSQLException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.sql.SQLException
                拡張 jp.co.intra_mart.foundation.database.exception.DatabaseSQLException
すべての実装インタフェース:
Serializable
public class DatabaseSQLException
extends SQLException

データベースSQL例外拡張クラス。

SQL例外に原因となる例外を渡せるようにした拡張版例外クラス。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DatabaseSQLException(String reason)
コンストラクタ。
DatabaseSQLException(String reason, String SQLState)
コンストラクタ。
DatabaseSQLException(String reason, String SQLState, int vendorCode)
コンストラクタ。
DatabaseSQLException(String reason, String SQLState, int vendorCode, Throwable cause)
コンストラクタ。
DatabaseSQLException(String reason, String SQLState, Throwable cause)
コンストラクタ。
DatabaseSQLException(String reason, Throwable cause)
コンストラクタ。
クラス java.sql.SQLException から継承したメソッド
getErrorCode, getNextException, getSQLState, setNextException
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DatabaseSQLException

public DatabaseSQLException(String reason)
コンストラクタ。

パラメータ:
reason - 理由

DatabaseSQLException

public DatabaseSQLException(String reason,
                            String SQLState)
コンストラクタ。

パラメータ:
reason - 理由
SQLState - SQLステータス

DatabaseSQLException

public DatabaseSQLException(String reason,
                            String SQLState,
                            int vendorCode)
コンストラクタ。

パラメータ:
reason - 理由
SQLState - SQLステータス
vendorCode - ベンダーコード

DatabaseSQLException

public DatabaseSQLException(String reason,
                            Throwable cause)
コンストラクタ。

パラメータ:
reason - 理由
cause - 原因となる例外

DatabaseSQLException

public DatabaseSQLException(String reason,
                            String SQLState,
                            Throwable cause)
コンストラクタ。

パラメータ:
reason - 理由
SQLState - SQLステータス
cause - 原因となる例外

DatabaseSQLException

public DatabaseSQLException(String reason,
                            String SQLState,
                            int vendorCode,
                            Throwable cause)
コンストラクタ。

パラメータ:
reason - 理由
SQLState - SQLステータス
vendorCode - ベンダーコード
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.database.exception (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.database.exception
例外
DatabaseExportException
DatabaseSQLException


jp.co.intra_mart.foundation.database.exception (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.database.exception

データベースＳＱＬ例外クラスを提供します。

参照:
説明

例外の概要
DatabaseExportException | 推奨されていません。 システム内部で利用しているクラスです。
DatabaseSQLException | データベースSQL例外拡張クラス。

パッケージ jp.co.intra_mart.foundation.database.exception の説明

データベースＳＱＬ例外クラスを提供します。


jp.co.intra_mart.foundation.database.exception クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.database.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.database.exception.DatabaseExportException
        • class java.sql.SQLException
          • class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException


パッケージ jp.co.intra_mart.foundation.database.exception の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.database.exception の使用

jp.co.intra_mart.foundation.database.exception を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database により使用される jp.co.intra_mart.foundation.database.exception のクラス
DatabaseExportException
推奨されていません。 システム内部で利用しているクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ConInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
インタフェース ConInfo

public interface ConInfo

フィールドの概要
static String | TYPE_DATA_SOURCE
static String | TYPE_GROUP
static String | TYPE_JDBC
static String | TYPE_SYSTEM
メソッドの概要
String | getConId() 接続参照名を取得します。
String | getConnectionType() 接続の種別を取得します。
String | getDataSourceRefName() DataSourceへの参照名を取得します。
String | getIdentifier() コネクションの識別子を取得します。
void | setDataSourceRefName(String dsRefName) DataSourceへの参照名を設定します。

フィールドの詳細

TYPE_SYSTEM

public static final String TYPE_SYSTEM
関連項目:
定数フィールド値

TYPE_GROUP

public static final String TYPE_GROUP
関連項目:
定数フィールド値

TYPE_DATA_SOURCE

public static final String TYPE_DATA_SOURCE
関連項目:
定数フィールド値

TYPE_JDBC

public static final String TYPE_JDBC
関連項目:
定数フィールド値
メソッドの詳細

setDataSourceRefName

public void setDataSourceRefName(String dsRefName)
DataSourceへの参照名を設定します。

パラメータ:
dsRefName - DataSourceへの参照名

getDataSourceRefName

public String getDataSourceRefName()
DataSourceへの参照名を取得します。

戻り値:
DataSourceへの参照名

getConId

public String getConId()
接続参照名を取得します。

戻り値:
接続参照名

getConnectionType

public String getConnectionType()
接続の種別を取得します。

戻り値:
接続の種別

getIdentifier

public String getIdentifier()
コネクションの識別子を取得します。

戻り値:
コネクションの識別子
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DatabaseAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
インタフェース DatabaseAccessor

public interface DatabaseAccessor

データベース接続オブジェクト取得インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
DatabaseAccessorImpl

メソッドの概要
void | beginTransaction() データベースアクセスのトランザクションを開始します。
void | commit() データベースのトランザクションをコミットします。
Connection | getConnection(ConInfo conInfo) Connectionオブジェクトを取得します。
boolean | isTransaction() データベースアクセスのトランザクション状態を取得します。
void | rollback() データベースのトランザクションをロールバックします。

メソッドの詳細

getConnection

public Connection getConnection(ConInfo conInfo)
                         throws SQLException,
                                NamingException
Connectionオブジェクトを取得します。

パラメータ:
conInfo - データベース接続情報
戻り値:
データベース接続オブジェクト
例外:
SQLException
NamingException

beginTransaction

public void beginTransaction()
                      throws NamingException,
                             NotSupportedException,
                             SystemException
データベースアクセスのトランザクションを開始します。

例外:
NamingException - Context および DirContext インタフェースでの操作によってスローされるすべての例外のスーパークラスです。
SystemException - SystemException は、トランザクションマネージャによってスローされ、トランザクションサービスの処理をこれ以上続行できないような予想外のエラー状態が検出されたことを示します。
NotSupportedException - NotSupportedException 例外は、操作がサポートされていない機能であるために、要求が実行できないことを示します。

isTransaction

public boolean isTransaction()
                      throws NamingException,
                             NotSupportedException,
                             SystemException
データベースアクセスのトランザクション状態を取得します。

戻り値:
true : トランザクション中 / false : トランザクション外
例外:
NamingException - Context および DirContext インタフェースでの操作によってスローされるすべての例外のスーパークラスです。
SystemException - SystemException は、トランザクションマネージャによってスローされ、トランザクションサービスの処理をこれ以上続行できないような予想外のエラー状態が検出されたことを示します。
NotSupportedException - NotSupportedException 例外は、操作がサポートされていない機能であるために、要求が実行できないことを示します。

commit

public void commit()
            throws NamingException,
                   IllegalStateException,
                   SecurityException,
                   RollbackException,
                   HeuristicMixedException,
                   HeuristicRollbackException,
                   SystemException
データベースのトランザクションをコミットします。

例外:
NamingException - Context および DirContext インタフェースでの操作によってスローされるすべての例外のスーパークラスです。
SystemException - SystemException は、トランザクションマネージャによってスローされ、トランザクションサービスの処理をこれ以上続行できないような予想外のエラー状態が検出されたことを示します。
HeuristicRollbackException - この例外は、コミット操作によってスローされ、ヒューリスティックな決定が行われて、それに関連するすべての更新がロールバックされたことを報告します。
HeuristicMixedException - この例外は、ヒューリスティックな決定が行われて、それに関連する一部の更新がコミットされ、残りの更新がロールバックされたことを報告するためにスローされます。
RollbackException - RollbackException 例外は、トランザクションがロールバック専用としてマークされたか、コミットの代わりにロールバックされた場合にスローされます。
SecurityException - セキュリティマネージャによってスローされ、セキュリティ違反を示します。
IllegalStateException - 不正または不適切なときにメソッドが呼び出されたことを示します。

rollback

public void rollback()
              throws NamingException,
                     IllegalStateException,
                     SecurityException,
                     SystemException
データベースのトランザクションをロールバックします。

例外:
NamingException - Context および DirContext インタフェースでの操作によってスローされるすべての例外のスーパークラスです。
SystemException - SystemException は、トランザクションマネージャによってスローされ、トランザクションサービスの処理をこれ以上続行できないような予想外のエラー状態が検出されたことを示します。
SecurityException - セキュリティマネージャによってスローされ、セキュリティ違反を示します。
IllegalStateException - 不正または不適切なときにメソッドが呼び出されたことを示します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DatabaseColumn (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DatabaseColumn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DatabaseColumn
public class DatabaseColumn
extends Object

フィールドの概要
static int | INDEX_UNDEFINED
static int | TYPE_DATE
static int | TYPE_NUMBER
static int | TYPE_STRING
static int | TYPE_UNDEFINED
コンストラクタの概要
DatabaseColumn()
DatabaseColumn(int columnType)
DatabaseColumn(int columnType, int index)
DatabaseColumn(String tableName, String columnName, String dataType, int index, boolean primaryKey)
メソッドの概要
String | getColumnName()
int | getColumnType()
String | getFormat()
int | getIndex()
boolean | isNumber()
boolean | isPrimaryKey()
void | setColumnName(String columnName)
void | setColumnType(int columnType)
void | setFormat(String format)
void | setIndex(int index)
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

INDEX_UNDEFINED

public static final int INDEX_UNDEFINED
関連項目:
定数フィールド値

TYPE_UNDEFINED

public static final int TYPE_UNDEFINED
関連項目:
定数フィールド値

TYPE_STRING

public static final int TYPE_STRING
関連項目:
定数フィールド値

TYPE_NUMBER

public static final int TYPE_NUMBER
関連項目:
定数フィールド値

TYPE_DATE

public static final int TYPE_DATE
関連項目:
定数フィールド値
コンストラクタの詳細

DatabaseColumn

public DatabaseColumn()

DatabaseColumn

public DatabaseColumn(int columnType)

DatabaseColumn

public DatabaseColumn(int columnType,
                      int index)

DatabaseColumn

public DatabaseColumn(String tableName,
                      String columnName,
                      String dataType,
                      int index,
                      boolean primaryKey)
メソッドの詳細

setColumnType

public void setColumnType(int columnType)

setFormat

public void setFormat(String format)

getColumnType

public int getColumnType()

getFormat

public String getFormat()

setIndex

public void setIndex(int index)

getIndex

public int getIndex()

isNumber

public boolean isNumber()

setColumnName

public void setColumnName(String columnName)

getColumnName

public String getColumnName()

isPrimaryKey

public boolean isPrimaryKey()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DatabaseExport (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DatabaseExport

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DatabaseExport
推奨されていません。 システム内部で利用しているクラスです。

public class DatabaseExport
extends Object

フィールドの概要
static int | DBTYPE_DB2 推奨されていません。
static int | DBTYPE_ORACLE 推奨されていません。
static int | DBTYPE_POSTGRESQL 推奨されていません。
static int | DBTYPE_SQLSERVER 推奨されていません。
メソッドの概要
void | addCSVHeaderText(String value) 推奨されていません。 出力するCSVのヘッダ部分をセットします。
static void | clearInstance() 推奨されていません。 DatabaseExportインスタンスを開放します。
static void | close(Connection con, PreparedStatement stmt) 推奨されていません。
void | discontinue() 推奨されていません。 現在実行中のエクスポート処理を中止します。
void | downloadCSV(PreparedStatement stmt, String fileName, boolean isTitle) 推奨されていません。 CSVファイルをダウンロードします。
void | downloadCSV(PreparedStatement stmt, String fileName, int startIndex, int maxRow, boolean isTitle) 推奨されていません。 CSVファイルをダウンロードします。
void | downloadCSV(String sql, String fileName, int startIndex, int maxRow, String connectId, boolean isGroup, boolean isTitle) 推奨されていません。 CSVファイルをダウンロードします。
int | exportCSV(PreparedStatement stmt, NetworkFile file, boolean isTitle) 推奨されていません。 CSVファイルをストレージに出力します。
int | exportCSV(PreparedStatement stmt, NetworkFile file, int startIndex, int maxRow, boolean isTitle) 推奨されていません。 CSVファイルをストレージに出力します。
int | exportCSV(PreparedStatement stmt, OutputStream out, boolean isTitle) 推奨されていません。 CSV形式のデータをストリームに出力します。
int | exportCSV(PreparedStatement stmt, OutputStream out, int startIndex, int maxRow, boolean isTitle) 推奨されていません。 CSV形式のデータをストリームに出力します。
DatabaseColumn[] | getColumnsInfo() 推奨されていません。
static Connection | getConnection(String connectId, boolean isGroup) 推奨されていません。 データベースコネクションを取得します。
String[] | getCSVStrings(PreparedStatement stmt, boolean isTitle) 推奨されていません。 CSV形式のデータ取得します。
String[] | getCSVStrings(PreparedStatement stmt, int startIndex, int maxRow, boolean isTitle) 推奨されていません。 CSV形式のデータ取得します。
static int | getDbType(Connection con) 推奨されていません。
int | getExecutingLineNumber() 推奨されていません。 現在エクスポート実行中の行番号を返します。
static DatabaseExport | getInstance() 推奨されていません。 DatabaseExportインスタンスを取得します。
static HttpServletRequest | getRequest() 推奨されていません。
static HttpServletResponse | getResponse() 推奨されていません。
void | setColumnsInfo(DatabaseColumn[] columns) 推奨されていません。
void | setDetectionTimeOut(Integer detectionTimeOutSecond) 推奨されていません。 書き込みタイムアウト時間を設定します。
void | setExportEncoding(String encoding) 推奨されていません。
void | setFieldNames(String[] fieldNames) 推奨されていません。
void | setNullValue(String nullValue) 推奨されていません。 データベースから取得されたデータがnullの場合の代替文字列を設定します。
void | setSleepInterval(int sleepRecordCount, int sleepTime) 推奨されていません。 指定された行数のレコードを書き出すごとに スレッドを一定時間スリープさせます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DBTYPE_ORACLE

public static final int DBTYPE_ORACLE
推奨されていません。
関連項目:
定数フィールド値

DBTYPE_DB2

public static final int DBTYPE_DB2
推奨されていません。
関連項目:
定数フィールド値

DBTYPE_POSTGRESQL

public static final int DBTYPE_POSTGRESQL
推奨されていません。
関連項目:
定数フィールド値

DBTYPE_SQLSERVER

public static final int DBTYPE_SQLSERVER
推奨されていません。
関連項目:
定数フィールド値
メソッドの詳細

setSleepInterval

public void setSleepInterval(int sleepRecordCount,
                             int sleepTime)
推奨されていません。
指定された行数のレコードを書き出すごとに
スレッドを一定時間スリープさせます。
0を設定された場合は、スリープを行いません。

パラメータ:
sleepRecordCount -
sleepTime -

setNullValue

public void setNullValue(String nullValue)
推奨されていません。
データベースから取得されたデータがnullの場合の代替文字列を設定します。

パラメータ:
nullValue - 代替文字列

setDetectionTimeOut

public void setDetectionTimeOut(Integer detectionTimeOutSecond)
推奨されていません。
書き込みタイムアウト時間を設定します。
0が設定された場合はタイムアウト監視を行いません。

パラメータ:
detectionTimeOutSecond -

setExportEncoding

public void setExportEncoding(String encoding)
推奨されていません。

getExecutingLineNumber

public int getExecutingLineNumber()
推奨されていません。
現在エクスポート実行中の行番号を返します。

戻り値:
行番号

discontinue

public void discontinue()
推奨されていません。
現在実行中のエクスポート処理を中止します。

getInstance

public static DatabaseExport getInstance()
推奨されていません。
DatabaseExportインスタンスを取得します。
１ユーザに１つインスタンスを割り当てます。

戻り値:

clearInstance

public static void clearInstance()
推奨されていません。
DatabaseExportインスタンスを開放します。

downloadCSV

public void downloadCSV(String sql,
                        String fileName,
                        int startIndex,
                        int maxRow,
                        String connectId,
                        boolean isGroup,
                        boolean isTitle)
                 throws IOException,
                        SQLException,
                        ServletException,
                        DatabaseExportException
推奨されていません。
CSVファイルをダウンロードします。

パラメータ:
sql -
fileName -
startIndex -
maxRow -
connectId -
isGroup -
例外:
NamingException
AccessSecurityException
NotExistException
ServletException
DatabaseExportException
IOException
SQLException

downloadCSV

public void downloadCSV(PreparedStatement stmt,
                        String fileName,
                        boolean isTitle)
                 throws IOException,
                        SQLException,
                        ServletException,
                        DatabaseExportException
推奨されていません。
CSVファイルをダウンロードします。

パラメータ:
stmt -
fileName -
例外:
ServletException
DatabaseExportException
IOException
SQLException

downloadCSV

public void downloadCSV(PreparedStatement stmt,
                        String fileName,
                        int startIndex,
                        int maxRow,
                        boolean isTitle)
                 throws IOException,
                        SQLException,
                        ServletException,
                        DatabaseExportException
推奨されていません。
CSVファイルをダウンロードします。

パラメータ:
stmt -
fileName -
startIndex -
maxRow -
例外:
ServletException
DatabaseExportException
IOException
SQLException

addCSVHeaderText

public void addCSVHeaderText(String value)
推奨されていません。
出力するCSVのヘッダ部分をセットします。

パラメータ:
value -

setFieldNames

public void setFieldNames(String[] fieldNames)
推奨されていません。

setColumnsInfo

public void setColumnsInfo(DatabaseColumn[] columns)
推奨されていません。

getColumnsInfo

public DatabaseColumn[] getColumnsInfo()
推奨されていません。

exportCSV

public int exportCSV(PreparedStatement stmt,
                     OutputStream out,
                     boolean isTitle)
              throws IOException,
                     SQLException,
                     DatabaseExportException
推奨されていません。
CSV形式のデータをストリームに出力します。

パラメータ:
stmt -
out -
例外:
DatabaseExportException
IOException
SQLException

exportCSV

public int exportCSV(PreparedStatement stmt,
                     OutputStream out,
                     int startIndex,
                     int maxRow,
                     boolean isTitle)
              throws IOException,
                     SQLException,
                     DatabaseExportException
推奨されていません。
CSV形式のデータをストリームに出力します。

パラメータ:
stmt -
out -
startIndex -
maxRow -
例外:
DatabaseExportException
IOException
SQLException

exportCSV

public int exportCSV(PreparedStatement stmt,
                     NetworkFile file,
                     boolean isTitle)
              throws IOException,
                     SQLException,
                     DatabaseExportException
推奨されていません。
CSVファイルをストレージに出力します。

パラメータ:
stmt -
file -
isTitle -
戻り値:
例外:
IOException
SQLException
DatabaseExportException

exportCSV

public int exportCSV(PreparedStatement stmt,
                     NetworkFile file,
                     int startIndex,
                     int maxRow,
                     boolean isTitle)
              throws IOException,
                     SQLException,
                     DatabaseExportException
推奨されていません。
CSVファイルをストレージに出力します。

パラメータ:
stmt -
file -
startIndex -
maxRow -
isTitle -
戻り値:
例外:
IOException
SQLException
DatabaseExportException

getCSVStrings

public String[] getCSVStrings(PreparedStatement stmt,
                              boolean isTitle)
                       throws IOException,
                              SQLException,
                              DatabaseExportException
推奨されていません。
CSV形式のデータ取得します。

パラメータ:
stmt - ステートメント
戻り値:
例外:
DatabaseExportException
IOException
SQLException

getCSVStrings

public String[] getCSVStrings(PreparedStatement stmt,
                              int startIndex,
                              int maxRow,
                              boolean isTitle)
                       throws IOException,
                              SQLException,
                              DatabaseExportException
推奨されていません。
CSV形式のデータ取得します。

パラメータ:
stmt - ステートメント
startIndex - 取得開始行番号
maxRow - 取得レコード件数
戻り値:
取得されたCSVデータ
例外:
DatabaseExportException
IOException
SQLException

getConnection

public static Connection getConnection(String connectId,
                                       boolean isGroup)
                                throws SQLException
推奨されていません。
データベースコネクションを取得します。

パラメータ:
connectId - 接続ID
isGroup - ログイングループかどうかを示します true/false
戻り値:
コネクションオブジェクト
例外:
SQLException

close

public static void close(Connection con,
                         PreparedStatement stmt)
推奨されていません。

getRequest

public static HttpServletRequest getRequest()
推奨されていません。

getResponse

public static HttpServletResponse getResponse()
推奨されていません。

getDbType

public static int getDbType(Connection con)
                     throws SQLException
推奨されていません。
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DatabaseManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DatabaseManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DatabaseManager
public class DatabaseManager
extends Object

データベースマネージャクラス。

コネクションオブジェクトを管理するマネージャです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | beginTransaction() データベースアクセスのトランザクションを開始します。
void | commit() データベースのトランザクションをコミットします。
String | dateToString(Date date) データベース登録用文字列を取得します。
String[] | getConnectIdsBySystem() システムに紐付くシステム接続名の一覧を取得します。
String | getDataSourceNameByLoginGroup(String groupId) ログイングループIDからデータソース参照名を取得します。
String | getDataSourceNameBySystem(String connectId) システム接続名からデータソース参照名を取得します。
DbTypes | getGroupDatabaseType(String groupId) ログイングループデータソースおけるデータベースの種類を取得する。
static DatabaseManager | getInstance() データべースマネージャインスタンスを生成します。
Connection | getJdbcConnection(String driver, String connectURL, String user, String password) JDBCからコネクションオブジェクトを取得します。
Connection | getLoginGroupConnection(String groupId) ログイングループIDからコネクションオブジェクトを取得します。
Connection | getResourceConnection(String resourceRef) リソース参照名からコネクションオブジェクト取得を取得します。
Connection | getSystemConnection(String connectId) システム接続名からコネクションオブジェクトを取得します。
DbTypes | getSystemDatabaseType(String connectId) システムデータソースにおけるデータベースの種類を取得する。
boolean | isTransaction() データベースアクセスのトランザクション状態を取得します。
void | rollback() データベースのトランザクションをロールバックします。
static void | setDatabaseAccessor(DatabaseAccessor databaseAccessor) データベースアクセッサを設定します。
static void | setSourceProvider(DataSourceProvider provider) ソースプロバイダを設定します。
Date | stringToDate(String dateString) データベース登録用文字列からjava.util.Dateを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getInstance

public static DatabaseManager getInstance()
データべースマネージャインスタンスを生成します。

戻り値:
データべースマネージャインスタンス

setDatabaseAccessor

public static void setDatabaseAccessor(DatabaseAccessor databaseAccessor)
データベースアクセッサを設定します。

実際にデータベースコネクションを取得するアクセッサを設定します。

通常、このメソッドを使用する必要はありません。

パラメータ:
databaseAccessor - データベースアクセッサ

setSourceProvider

public static void setSourceProvider(DataSourceProvider provider)
ソースプロバイダを設定します。

データソース設定ファイルを提供するプロバイダを設定します。

通常、このメソッドを使用する必要はありません。

パラメータ:
provider - ソースプロバイダ

getSystemDatabaseType

public DbTypes getSystemDatabaseType(String connectId)
システムデータソースにおけるデータベースの種類を取得する。 指定された接続参照名に一致する、データベースの種類を取得する。

パラメータ:
connectId - 接続参照名
戻り値:
データベースの種類
導入されたバージョン:
6.1.11

getGroupDatabaseType

public DbTypes getGroupDatabaseType(String groupId)
ログイングループデータソースおけるデータベースの種類を取得する。
指定されたログイングループIDに一致する、データベースの種類を取得する。

パラメータ:
groupId - ログイングループID
戻り値:
データベースの種類
導入されたバージョン:
6.1.11

beginTransaction

public void beginTransaction()
                      throws NamingException,
                             NotSupportedException,
                             SystemException
データベースアクセスのトランザクションを開始します。

例外:
NamingException - Context および DirContext インタフェースでの操作によってスローされるすべての例外のスーパークラスです。
SystemException - SystemException は、トランザクションマネージャによってスローされ、トランザクションサービスの処理をこれ以上続行できないような予想外のエラー状態が検出されたことを示します。
NotSupportedException - NotSupportedException 例外は、操作がサポートされていない機能であるために、要求が実行できないことを示します。

isTransaction

public boolean isTransaction()
                      throws NamingException,
                             NotSupportedException,
                             SystemException
データベースアクセスのトランザクション状態を取得します。

戻り値:
true : トランザクション中 / false : トランザクション外
例外:
NamingException - Context および DirContext インタフェースでの操作によってスローされるすべての例外のスーパークラスです。
SystemException - SystemException は、トランザクションマネージャによってスローされ、トランザクションサービスの処理をこれ以上続行できないような予想外のエラー状態が検出されたことを示します。
NotSupportedException - NotSupportedException 例外は、操作がサポートされていない機能であるために、要求が実行できないことを示します。

commit

public void commit()
            throws NamingException,
                   IllegalStateException,
                   SecurityException,
                   RollbackException,
                   HeuristicMixedException,
                   HeuristicRollbackException,
                   SystemException
データベースのトランザクションをコミットします。

例外:
NamingException - Context および DirContext インタフェースでの操作によってスローされるすべての例外のスーパークラスです。
SystemException - SystemException は、トランザクションマネージャによってスローされ、トランザクションサービスの処理をこれ以上続行できないような予想外のエラー状態が検出されたことを示します。
HeuristicRollbackException - この例外は、コミット操作によってスローされ、ヒューリスティックな決定が行われて、それに関連するすべての更新がロールバックされたことを報告します。
HeuristicMixedException - この例外は、ヒューリスティックな決定が行われて、それに関連する一部の更新がコミットされ、残りの更新がロールバックされたことを報告するためにスローされます。
RollbackException - RollbackException 例外は、トランザクションがロールバック専用としてマークされたか、コミットの代わりにロールバックされた場合にスローされます。
SecurityException - セキュリティマネージャによってスローされ、セキュリティ違反を示します。
IllegalStateException - 不正または不適切なときにメソッドが呼び出されたことを示します。

dateToString

public String dateToString(Date date)
データベース登録用文字列を取得します。

パラメータ:
date - 変換元のDateオブジェクト
戻り値:
データベース登録用文字列(yyyy/MM/dd|hh:mm:ss)

getConnectIdsBySystem

public String[] getConnectIdsBySystem()
システムに紐付くシステム接続名の一覧を取得します。

戻り値:
接続名の配列

getDataSourceNameByLoginGroup

public String getDataSourceNameByLoginGroup(String groupId)
ログイングループIDからデータソース参照名を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
データソース参照名

getDataSourceNameBySystem

public String getDataSourceNameBySystem(String connectId)
システム接続名からデータソース参照名を取得します。

パラメータ:
connectId - システム接続名
戻り値:
データソース参照名

getJdbcConnection

public Connection getJdbcConnection(String driver,
                                    String connectURL,
                                    String user,
                                    String password)
                             throws SQLException
JDBCからコネクションオブジェクトを取得します。

パラメータ:
driver - ドライバ名
connectURL - 接続URL
user - DBユーザ
password - DBパスワード
戻り値:
コネクションオブジェクト
例外:
SQLException - データベースの例外が発生した場合にスローされます。

getLoginGroupConnection

public Connection getLoginGroupConnection(String groupId)
                                   throws NamingException,
                                          SQLException,
                                          NotExistException,
                                          AccessSecurityException
ログイングループIDからコネクションオブジェクトを取得します。
ログイングループに紐付いたコネクションオブジェクトを取得します。

パラメータ:
groupId - ログイングループID
戻り値:
コネクションオブジェクト
例外:
NamingException - データベースリソース参照名が解決できなかった場合にスローされます。
SQLException - データベースの例外が発生した場合にスローされます。
NotFoundDataSourceException - システム接続名に対応するデータベース設定情報が存在しなかった場合にスローされます。
AccessSecurityException - データベース設定情報が取得できなかった場合にスローされます。
NotExistException

getResourceConnection

public Connection getResourceConnection(String resourceRef)
                                 throws NamingException,
                                        SQLException
リソース参照名からコネクションオブジェクト取得を取得します。

パラメータ:
resourceRef - リソース参照名
戻り値:
コネクションオブジェクト
例外:
NamingException - データベースリソース参照名が解決できなかった場合にスローされます。
SQLException - データベースの例外が発生した場合にスローされます。

getSystemConnection

public Connection getSystemConnection(String connectId)
                               throws NamingException,
                                      SQLException,
                                      NotExistException,
                                      AccessSecurityException
システム接続名からコネクションオブジェクトを取得します。
システムに紐付いたコネクションオブジェクトを取得します。

パラメータ:
connectId - システム接続名
戻り値:
コネクションオブジェクト
例外:
NamingException - データベースリソース参照名が解決できなかった場合にスローされます。
SQLException - データベースの例外が発生した場合にスローされます。
NotFoundDataSourceException - システム接続名に対応するデータベース設定情報が存在しなかった場合にスローされます。
AccessSecurityException - データベース設定情報が取得できなかった場合にスローされます。
NotExistException

rollback

public void rollback()
              throws NamingException,
                     IllegalStateException,
                     SecurityException,
                     SystemException
データベースのトランザクションをロールバックします。

例外:
NamingException - Context および DirContext インタフェースでの操作によってスローされるすべての例外のスーパークラスです。
SystemException - SystemException は、トランザクションマネージャによってスローされ、トランザクションサービスの処理をこれ以上続行できないような予想外のエラー状態が検出されたことを示します。
SecurityException - セキュリティマネージャによってスローされ、セキュリティ違反を示します。
IllegalStateException - 不正または不適切なときにメソッドが呼び出されたことを示します。

stringToDate

public Date stringToDate(String dateString)
データベース登録用文字列からjava.util.Dateを取得します。

パラメータ:
dateString - 変換元のデータベース登録用文字列(yyyy/MM/dd|hh:mm:ss)
戻り値:
Dateオブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataSourceProvider (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
インタフェース DataSourceProvider

public interface DataSourceProvider

データソース設定情報取得プロバイダインタフェース。

データソース設定情報を取得するためのプロバイダインタフェースです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
 InputStream getInputStream()
データソース設定ファイルのストリームを取得します。

メソッドの詳細

getInputStream

public InputStream getInputStream()
データソース設定ファイルのストリームを取得します。

戻り値:
データソース設定ファイルのストリーム
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DbManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DbManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DbManager
推奨されていません。 DatabaseManagerを使用してください。

public class DbManager
extends Object

データベース操作APIです。

データベース操作を行います。

導入されたバージョン:
3.0
バージョン:
2.0

コンストラクタの概要
DbManager(String connectID)
推奨されていません。 DatabaseManagerを使用してください。
メソッドの概要
 boolean contact()
推奨されていません。 代替えメソッドはありません。
static boolean contact(ConInfo dio)
推奨されていません。 代替えメソッドはありません。
static String dateToString(Date date)
推奨されていません。 DatabaseManager.dateToString(Date)を使用してください。
static String[] getConnectIDs()
推奨されていません。 DatabaseManager.getConnectIdsBySystem()を使用してください。
 ConInfo getConnectInfo()
推奨されていません。 代替えメソッドはありません。
 DbsConnection getConnection()
推奨されていません。 DatabaseManager.getLoginGroupConnection(String) および DatabaseManager.getSystemConnection(String)を使用してください。
static String[] getReference()
推奨されていません。 DatabaseManager.getConnectIdsBySystem()を使用してください。
 boolean isConnect()
推奨されていません。 代替えメソッドはありません。
static Date stringToDate(String dateString)
推奨されていません。 DatabaseManager.stringToDate(String)を使用してください。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DbManager

public DbManager(String connectID)
推奨されていません。 DatabaseManagerを使用してください。

コンストラクタ

パラメータ:
connectID - 接続参照名
メソッドの詳細

contact

public static boolean contact(ConInfo dio)
推奨されていません。 代替えメソッドはありません。

データベース接続を試みます。

パラメータ:
dio - データベース接続情報オブジェクト
戻り値:
成功 ture／失敗 false

dateToString

public static String dateToString(Date date)
推奨されていません。 DatabaseManager.dateToString(Date)を使用してください。

データベース登録用文字列を取得します。

パラメータ:
date - java.util.Date
戻り値:
データベース登録用文字列(YYYY/MM/DD|hh:mm:ss)
導入されたバージョン:
Version 4.0

getConnectIDs

public static String[] getConnectIDs()
推奨されていません。 DatabaseManager.getConnectIdsBySystem()を使用してください。

データベース接続参照名一覧を取得する。

戻り値:
データベース接続参照名配列

getReference

public static String[] getReference()
推奨されていません。 DatabaseManager.getConnectIdsBySystem()を使用してください。

データベース接続設定参照名を取得する。

戻り値:
データベース接続設定参照名配列

stringToDate

public static Date stringToDate(String dateString)
推奨されていません。 DatabaseManager.stringToDate(String)を使用してください。

データベース登録用文字列からjava.util.Date取得します。

パラメータ:
dateString - データベース登録用文字列(YYYY/MM/DD|hh:mm:ss)
戻り値:
java.util.Date
導入されたバージョン:
Version 4.0

contact

public boolean contact()
推奨されていません。 代替えメソッドはありません。

データベース接続を試みます。

戻り値:
成功 ture／失敗 false

getConnectInfo

public ConInfo getConnectInfo()
推奨されていません。 代替えメソッドはありません。

データベース接続情報を取得します。

指定の接続参照名のデータベース接続情報を取得します。

戻り値:
ConInfo データベース接続情報オブジェクト

getConnection

public DbsConnection getConnection()
                            throws SQLException
推奨されていません。 DatabaseManager.getLoginGroupConnection(String) および DatabaseManager.getSystemConnection(String)を使用してください。

データベースコネクションを取得します。

このメソッドで取得したコネクションを使用後は、そのコネクションの releaseメソッドを必ず 呼び出すこと。
releaseメソッドを呼び出さずにこのメソッドを実行した場合、 コネクションの取得に失敗し、nullが 返ります。

戻り値:
データベースコネクションオブジェクト
例外:
SQLException

isConnect

public boolean isConnect()
推奨されていません。 代替えメソッドはありません。

データベース接続の状態を確認します。

戻り値:
接続されている ture／接続されていない false
一度接続されると、途中、何らかの理由でデータベースとの接続が切断されてもtrueを返し続ける。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DbsConnection (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
インタフェース DbsConnection

すべてのスーパーインタフェース:
Connection
推奨されていません。 Connectionを利用してください。

public interface DbsConnection
extends Connection

特定のデータベースとの接続 (セッション) を表現します。
Connection のコンテキスト内で SQL 文が実行され結果が返されます。

このコネクションを使用後は必ずreleaseメソッドを呼び出し、解放して下さい。

フィールドの概要
インタフェース java.sql.Connection から継承したフィールド
TRANSACTION_NONE, TRANSACTION_READ_COMMITTED, TRANSACTION_READ_UNCOMMITTED, TRANSACTION_REPEATABLE_READ, TRANSACTION_SERIALIZABLE
メソッドの概要
void | clearWarnings() 推奨されていません。 この Connection オブジェクトに関して通知されたすべての警告をクリアします。
void | close() 推奨されていません。 releaseメソッドと同等です。
void | commit() 推奨されていません。 データベースアクセスの確定処理を行います。
Statement | createStatement() 推奨されていません。 SQL 文をデータベースに送るための Statement オブジェクトを生成します。
Statement | createStatement(int resultSetType, int resultSetConcurrency) 推奨されていません。 指定されたタイプと並行処理で ResultSet オブジェクトを生成する Statement オブジェクトを生成します。
Statement | createStatement(int resultSetType, int resultSetConcurrency, int resultSetHoldability) 推奨されていません。 指定された型、並行処理、および holdability で ResultSet オブジェクトを生成する Statement オブジェクトを生成します。
int | execute(String sql) 推奨されていません。 任意のＳＱＬ文をデータベースに対してリクエストする insert/update/delete文を実行する。
List | fetch(String sql, int startRow, int endRow) 推奨されていません。 SELECT文を発行してデータベースから指定範囲のデータを取得する
boolean | getAutoCommit() 推奨されていません。 現在の自動コミットの状態を取得します。
String | getCatalog() 推奨されていません。 Connection の現在のカタログ名を返します。
ConInfo | getConnectionInfo() 推奨されていません。 データベース設定情報を取得します。
int | getCount(String tablename, String where) 推奨されていません。 指定条件に該当する表内のデータ件数を取得する
String | getDbName() 推奨されていません。 このデータベース製品の名前を取得します。
String | getDbVersion() 推奨されていません。 このデータベース製品のバージョンを取得します。
String | getEscape() 推奨されていません。 ワイルドカード文字をエスケープするのに使用できる文字列を取得します。
int | getHoldability() 推奨されていません。 この Connection オブジェクトを使用して生成された ResultSet オブジェクトの現在の保持機能を取得します。
DatabaseMetaData | getMetaData() 推奨されていません。 この接続のデータベースに関するメタデータを取得します。
int | getTransactionIsolation() 推奨されていません。 この Connection の現在のトランザクション遮断レベルを取得します。
Map | getTypeMap() 推奨されていません。 この接続に関連した型マップオブジェクトを取得します。
SQLWarning | getWarnings() 推奨されていません。 この Connection に関する呼び出しによって通知された最初の警告を返します。
int | insert(String table, Map datas) 推奨されていません。 データベースにデータを追加挿入するメソッド データベースにインサート処理をする。
boolean | isClosed() 推奨されていません。 Connection がクローズされているかどうかを判定します。
boolean | isColumn(String clmnname, String tblname) 推奨されていません。 データベースの表内に指定カラムが存在するか調べる
boolean | isDataSource() 推奨されていません。 このコネクションがDataSourceかを返します。
boolean | isReadOnly() 推奨されていません。 Connection が読み込み専用モードかどうかを判定します。
String | nativeSQL(String sql) 推奨されていません。 指定された SQL 文をシステムの本来の SQL 文法に変換します。
CallableStatement | prepareCall(String sql) 推奨されていません。 データベースのストアドプロシージャを呼び出すための CallableStatement オブジェクトを生成します。
CallableStatement | prepareCall(String sql, int resultSetType, int resultSetConcurrency) 推奨されていません。 指定されたタイプと並行処理で ResultSet オブジェクトを生成する CallableStatement オブジェクトを生成します。
CallableStatement | prepareCall(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability) 推奨されていません。 指定された型と並行処理で ResultSet オブジェクトを生成する CallableStatement オブジェクトを生成します。
PreparedStatement | prepareStatement(String sql) 推奨されていません。 パラメータ付き SQL 文をデータベースに送るための PreparedStatement オブジェクトを作成します。
PreparedStatement | prepareStatement(String sql, int autoGeneratedKeys) 推奨されていません。 自動生成キーを取得する機能を持つデフォルトの PreparedStatement オブジェクトを生成します。
PreparedStatement | prepareStatement(String sql, int[] columnIndexes) 推奨されていません。 指定された配列によって指定された自動生成キーを返す機能を持つデフォルトの PreparedStatement オブジェクトを生成します。
PreparedStatement | prepareStatement(String sql, int resultSetType, int resultSetConcurrency) 推奨されていません。 指定されたタイプと並行処理で ResultSet オブジェクトを生成する PreparedStatementオブジェクトを生成します。
PreparedStatement | prepareStatement(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability) 推奨されていません。 指定された型、並行処理、および保持機能で ResultSet オブジェクトを生成する PreparedStatement オブジェクトを生成します。
PreparedStatement | prepareStatement(String sql, String[] columnNames) 推奨されていません。 指定された配列によって指定された自動生成キーを返す機能を持つデフォルトの PreparedStatement オブジェクトを生成します。
void | release() 推奨されていません。 データベースコネクションを解放します。
void | releaseSavepoint(Savepoint savepoint) 推奨されていません。 現在のトランザクションから指定された Savepoint オブジェクトを削除します。
int | remove(String table, String where) 推奨されていません。 データベースにデータを削除するメソッド データベースのデータを削除(デリート)する。
void | rollback() 推奨されていません。 データベースアクセスの取り消し処理をする トランザクションを終了(rollback)させる。
void | rollback(Savepoint savepoint) 推奨されていません。 指定された Savepoint オブジェクトが設定されたあとに行われたすべての変更を元に戻します。
List | select(String sql) 推奨されていません。 SELECT文を発行してデータベースからデータを取得する
void | setAutoCommit(boolean autoCommit) 推奨されていません。
void | setCatalog(String catalog) 推奨されていません。 この Connection のデータベースに作業のためのサブスペースを選択するために、カタログ名を設定します。
void | setHoldability(int holdability) 推奨されていません。 この Connection オブジェクトを使用して生成された ResultSet オブジェクトの保持機能を指定された保持機能へ変更します。
void | setReadOnly(boolean readOnly) 推奨されていません。 この Connection を読み込み専用モードに設定して、データベース最適化を実行するヒントとします。
Savepoint | setSavepoint() 推奨されていません。 現在のトランザクションで名前のないセーブポイントを作成し、それを表す新しい Savepoint オブジェクトを返します。
Savepoint | setSavepoint(String name) 推奨されていません。 現在のトランザクションで指定された名前のセーブポイントを作成し、それを表す新しい Savepoint オブジェクトを返します。
void | setTimer(boolean autoRelease) 推奨されていません。 トランザクション自動切断機能のタイマーをセットする（デフォルトtrue）
void | setTransactionIsolation(int level) 推奨されていません。 トランザクション遮断レベルを指定されたものに変更することを試みます。
void | setTypeMap(Map map) 推奨されていません。 この接続の型マップとして指定された型マップをインストールします。
void | transaction() 推奨されていません。 データベースアクセスのトランザクションを開始する トランザクションを開始させる。
int | update(String table, String where, Map datas) 推奨されていません。 データベースにデータを更新するメソッド データベースのデータを更新(アップデート)する。

メソッドの詳細

clearWarnings

public void clearWarnings()
                   throws SQLException
推奨されていません。
この Connection オブジェクトに関して通知されたすべての警告をクリアします。

このメソッドを呼び出したあと、Connection に対する新しい警告が通知されるまで、getWarnings は null を返します。

定義:
インタフェース Connection 内の clearWarnings
例外:
SQLException - データベースアクセスエラーが発生した場合

close

public void close()
           throws SQLException
推奨されていません。
releaseメソッドと同等です。

定義:
インタフェース Connection 内の close
例外:
SQLException - データベースアクセスエラーが発生した場合

commit

public void commit()
            throws SQLException
推奨されていません。
データベースアクセスの確定処理を行います。

トランザクションを終了(commit)させる。

定義:
インタフェース Connection 内の commit
例外:
SQLException - データベースアクセスエラーが発生した場合

createStatement

public Statement createStatement()
                          throws SQLException
推奨されていません。
SQL 文をデータベースに送るための Statement オブジェクトを生成します。

パラメータなしの SQL 文は通常、Statement オブジェクトを使用して実行されます。同じ SQL 文が多 数回実行される場合は、PreparedStatement オブジェクトを使用する方が効率的です。 返される Statement オブジェクトを使って作成された結果セットは、デフォルトでは、順方 向専用タイプで、読み取り専用の並行処理ができます。

定義:
インタフェース Connection 内の createStatement
戻り値:
新しい Statement オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合

createStatement

public Statement createStatement(int resultSetType,
                                 int resultSetConcurrency)
                          throws SQLException
推奨されていません。
指定されたタイプと並行処理で ResultSet オブジェクトを生成する Statement オブジェクトを生成します。

このメソッドは上記の createStatement メソッドと同じですが、デフォルト の結果セットのタイプおよび結果セットの並行処理の種類をオーバーライドできます。

定義:
インタフェース Connection 内の createStatement
パラメータ:
resultSetType - 結果セットのタイプ。ResultSet.TYPE_XXX を参照
resultSetConcurrency - 並行処理の種類。ResultSet.CONCUR_XXX を参照
戻り値:
新しい Statement オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合

createStatement

public Statement createStatement(int resultSetType,
                                 int resultSetConcurrency,
                                 int resultSetHoldability)
                          throws SQLException
推奨されていません。
指定された型、並行処理、および holdability で ResultSet オブジェクトを生成する Statement オブジェクトを生成します。 このメソッドは上記の createStatement メソッドと同じですが、デフォルトの結果セットの型、並行処理、および保持機能をオーバーライドできます。

定義:
インタフェース Connection 内の createStatement
パラメータ:
resultSetType - ResultSet 定数。ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE、または ResultSet.TYPE_SCROLL_SENSITIVE のうちの 1 つ
resultSetConcurrency - ResultSet 定数。ResultSet.CONCUR_READ_ONLY または ResultSet.CONCUR_UPDATABLE
resultSetHoldability - ResultSet 定数。ResultSet.HOLD_CURSORS_OVER_COMMIT または ResultSet.CLOSE_CURSORS_AT_COMMIT
戻り値:
指定された型、並行処理、および保持機能で ResultSet オブジェクトを生成する新しい Statement オブジェクト
例外:
データベースアクセスエラーが発生した場合、または指定されたパラメータが型、並行処理、および保持機能を示す - ResultSet 定数でない場合
SQLException

execute

public int execute(String sql)
            throws SQLException
推奨されていません。
任意のＳＱＬ文をデータベースに対してリクエストする

insert/update/delete文を実行する。

パラメータ:
sql - insert/update/delete文（引数のSQL文にはステートメント末判定文字(";"や"/"など)は付けない。）
戻り値:
処理行数
例外:
SQLException - データベースアクセスエラーが発生した場合

fetch

public List fetch(String sql,
                  int startRow,
                  int endRow)
           throws SQLException
推奨されていません。
SELECT文を発行してデータベースから指定範囲のデータを取得する

パラメータ:
sql - SQL文（SELECT文）
引数のSQL文にはステートメント末判定文字(";"や"/"など)は付けない。
startRow - 取得するデータの開始レコード位置 (1以上を指定)
endRow - 取得するデータの総件数 (1以上を指定)
戻り値:
Listの各要素はHashtable。カラム名(全て小文字に変換)＝値 で格納される。

取得できるデータはjp.co.intra_mart.foundation.database.DbsConnection.selectメソッドの戻り値と同様に変換されます。

例外:
SQLException - データベースアクセスエラーが発生した場合

getAutoCommit

public boolean getAutoCommit()
                      throws SQLException
推奨されていません。
現在の自動コミットの状態を取得します。

定義:
インタフェース Connection 内の getAutoCommit
戻り値:
現在の自動コミットモードの状態
例外:
SQLException - データベースアクセスエラーが発生した場合

getCatalog

public String getCatalog()
                  throws SQLException
推奨されていません。
Connection の現在のカタログ名を返します。

定義:
インタフェース Connection 内の getCatalog
戻り値:
現在のカタログ名または null
例外:
SQLException - データベースアクセスエラーが発生した場合

getConnectionInfo

public ConInfo getConnectionInfo()
推奨されていません。
データベース設定情報を取得します。

戻り値:
データベース設定情報

getCount

public int getCount(String tablename,
                    String where)
             throws SQLException
推奨されていません。
指定条件に該当する表内のデータ件数を取得する

パラメータ:
tablename - テーブル名
戻り値:
件数。
例外:
SQLException - データベースアクセスエラーが発生した場合

getDbName

public String getDbName()
                 throws SQLException
推奨されていません。
このデータベース製品の名前を取得します。

戻り値:
データベース製品の名前
例外:
SQLException - データベースアクセスエラーが発生した場合

getDbVersion

public String getDbVersion()
                    throws SQLException
推奨されていません。
このデータベース製品のバージョンを取得します。

戻り値:
データベースのバージョン
例外:
SQLException - データベースアクセスエラーが発生した場合

getEscape

public String getEscape()
                 throws SQLException
推奨されていません。
ワイルドカード文字をエスケープするのに使用できる文字列を取得します。

これは、文字列パターンスタイルカタログ検索パラメータで '_' や '%' をエスケープするのに使用できる 文字列です。 '_' 文字は任意の 1 文字を表します。 '%' 文字は 0 文字以上のシーケンスを表します。

戻り値:
ワイルドカード文字をエスケープするのに使用できる文字列
例外:
SQLException - データベースアクセスエラーが発生した場合

getHoldability

public int getHoldability()
                   throws SQLException
推奨されていません。
この Connection オブジェクトを使用して生成された ResultSet オブジェクトの現在の保持機能を取得します。

定義:
インタフェース Connection 内の getHoldability
戻り値:
保持機能。ResultSet.HOLD_CURSORS_OVER_COMMIT または ResultSet.CLOSE_CURSORS_AT_COMMIT
例外:
データベースアクセスエラーが発生した場合
SQLException

getMetaData

public DatabaseMetaData getMetaData()
                             throws SQLException
推奨されていません。
この接続のデータベースに関するメタデータを取得します。

Connection のデータベースは、テーブル、サポートしている SQL 文法、ストアドプロシージャ、 およびこの接続の能力などを記述する情報を提供します。この情報は、DatabaseMetaData オブジェクトから 取得します。

定義:
インタフェース Connection 内の getMetaData
戻り値:
この Connection に対する DatabaseMetaData オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合

getTransactionIsolation

public int getTransactionIsolation()
                            throws SQLException
推奨されていません。
この Connection の現在のトランザクション遮断レベルを取得します。

定義:
インタフェース Connection 内の getTransactionIsolation
戻り値:
現在の TRANSACTION_* モード値
例外:
SQLException - データベースアクセスエラーが発生した場合

getTypeMap

public Map getTypeMap()
               throws SQLException
推奨されていません。
この接続に関連した型マップオブジェクトを取得します。

アプリケーションが型マップにエントリを追加していない限り、空のマップが返されます。

定義:
インタフェース Connection 内の getTypeMap
戻り値:
この Connection オブジェクトに関連した java.util.Map オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合

getWarnings

public SQLWarning getWarnings()
                       throws SQLException
推奨されていません。
この Connection に関する呼び出しによって通知された最初の警告を返します。

注: 引き続く警告は、この SQLWarning にチェーンされます。

定義:
インタフェース Connection 内の getWarnings
戻り値:
最初の SQLWarning または null
例外:
SQLException - データベースアクセスエラーが発生した場合

insert

public int insert(String table,
                  Map datas)
           throws SQLException
推奨されていません。
データベースにデータを追加挿入するメソッド

データベースにインサート処理をする。 挿入データはオブジェクト(Map)形式のデータをセット。 なお、オブジェクトのプロパティ名称は、挿入したい データベースのカラム名称に等しく作成し、そのプロパティに 対して挿入したいデータをセットする。

パラメータ:
table - 処理対象のデータベース表名
datas - 挿入データ 引数 datas(Map)の内容
(key == value)
カラム名 = 値 ここでセットできるデータ型（値）は、String,Numberのみです。
戻り値:
処理行数
例外:
SQLException - データベースアクセスエラーが発生した場合

isClosed

public boolean isClosed()
                 throws SQLException
推奨されていません。
Connection がクローズされているかどうかを判定します。

定義:
インタフェース Connection 内の isClosed
戻り値:
Connection がクローズされている場合は true、まだオープンの状態の場合は false
例外:
SQLException - データベースアクセスエラーが発生した場合

isColumn

public boolean isColumn(String clmnname,
                        String tblname)
                 throws SQLException
推奨されていません。
データベースの表内に指定カラムが存在するか調べる

パラメータ:
clmnname - 存在の有無をチェックしたいカラム名称 （カラム名の大文字小文字は区別しない）
tblname - 定義情報をチェックしたい表名
戻り値:
指定のカラムは存在する ture／指定のカラムは存在しない false
例外:
SQLException - データベースアクセスエラーが発生した場合

isDataSource

public boolean isDataSource()
推奨されていません。
このコネクションがDataSourceかを返します。

戻り値:
DataSourceの場合 true／DataSourceではないの場合 false
例外:
SQLException - データベースアクセスエラーが発生した場合

isReadOnly

public boolean isReadOnly()
                   throws SQLException
推奨されていません。
Connection が読み込み専用モードかどうかを判定します。

定義:
インタフェース Connection 内の isReadOnly
戻り値:
Connection が読み込み専用モードの場合は true、そうでない場合は false
例外:
SQLException - データベースアクセスエラーが発生した場合

nativeSQL

public String nativeSQL(String sql)
                 throws SQLException
推奨されていません。
指定された SQL 文をシステムの本来の SQL 文法に変換します。

ドライバは、送信前にJDBC SQL 文法をシステムの本来の SQL 文法に変換できます。 このメソッドは、ドライバが送る文のシステム本来の形のフォームを返します。

定義:
インタフェース Connection 内の nativeSQL
パラメータ:
sql - 1 つ以上の '?' パラメータプレースホルダーを含めることができる SQL 文
戻り値:
この文の元のフォーム
例外:
SQLException - データベースアクセスエラーが発生した場合

prepareCall

public CallableStatement prepareCall(String sql)
                              throws SQLException
推奨されていません。
データベースのストアドプロシージャを呼び出すための CallableStatement オブジェクトを生成します。

CallableStatement オブジェクトは、その IN と OUT パラメータを設定するメ ソッドとストアドプロシージャの呼び出しを実行するメソッドを提供します。
注: このメソッドは、ストアドプロシージャ呼び出し文を処理するために最適化されていま す。ドライバによっては、prepareCall メソッドが実行されるときにデータベースに呼び出し 文を送るものがあります。その他のドライバは、CallableStatement オブジェクトが実行さ れるまで待ちます。これはユーザに直接的な影響はありませんが、どのメソッドが、どの SQLException をスローしたかに関して影響があります。 返される CallableStatement を 使って作成された結果セットは、デフォルトでは、順方向専用タイプで、読み取り専用の 並行処理ができます。

ストアドプロシジャーの実行例

 以下のようなストアドプロシジャーを実行する場合。
  // ストアドプロシジャー CREATE OR REPLACE PROCEDURE spTest ( retNo IN OUT
 NUMBER,errMsg IN OUT VARCHAR2 ) IS BEGIN retNo := retNo + 1; errMsg :=
 errMsg || 'A'; END; /

 public void execStoredProc(){ DbManager dbmgr = new DbManager("DEFAULT");
 DbsConnection dbsc = dbmgr.getConnection();

 String stmt = new String("{call spTest (?,?)}"); CallableStatement
 clblstmt = dbsc.prepareCall(stmt);
  // パラメータセット clblstmt.setInt(1,2);
 clblstmt.registerOutParameter(1,java.sql.Types.DECIMAL);
 clblstmt.setString(2,"TEST");
 clblstmt.registerOutParameter(2,java.sql.Types.VARCHAR);

 //実行 clblstmt.execute();

 System.out.println(clblstmt.getInt(1));
 System.out.println(clblstmt.getString(2));

 //終了処理 clblstmt.close(); dbsc.release(); }
  <<結果>>3 TESTA

 ストアドファンクションの実行例

 以下のようなストアドファンクションを実行する場合。
  // ストアドファンクション CREATE OR REPLACE FUNCTION fcTest ( retNo IN OUT
 NUMBER,errMsg IN OUT VARCHAR2 ) RETURN number IS retValue number(2);
 BEGIN retNo := retNo + 1; errMsg := errMsg || 'A';

 retValue := 19; return retValue; END; /

 public void execStoredFunc(){ DbManager dbmgr = new DbManager("DEFAULT");
 DbsConnection dbsc = dbmgr.getConnection();

 String stmt = new String("{? = call fcTest (?,?)}");
 CallableStatement clblstmt = dbsc.prepareCall(stmt);
  // 戻り値セット clblstmt.registerOutParameter(1,java.sql.Types.DECIMAL); //
 パラメータセット clblstmt.setInt(1,2);
 clblstmt.registerOutParameter(2,java.sql.Types.DECIMAL);
 clblstmt.setString(2,"TEST");
 clblstmt.registerOutParameter(3,java.sql.Types.VARCHAR);

 //実行 clblstmt.execute();

 System.out.println(clblstmt.getInt(1));
 System.out.println(clblstmt.getInt(2));
 System.out.println(clblstmt.getString(3));

 //終了処理 clblstmt.close(); dbsc.release(); }
  <<結果>>19 3 TESTA

 詳しくはjava.sql.CallableStatementの説明をご覧ください。

定義:
インタフェース Connection 内の prepareCall

パラメータ:
sql - 1 つ以上の '?' パラメータプレースホルダーを含めることができる SQL 文。通 常この文は、JBDC
            関数呼び出しのエスケープ文字列である

戻り値:
プリコンパイルされた SQL 文を含む新しい CallableStatement オブジェクト

例外:

SQLException - データベースアクセスエラーが発生した場合

prepareCall

public CallableStatement prepareCall(String sql,
                                     int resultSetType,
                                     int resultSetConcurrency)
                              throws SQLException
推奨されていません。
指定されたタイプと並行処理で ResultSet オブジェクトを生成する CallableStatement オブジェクトを生成します。

このメソッドは上記の prepareCall メソッドと同じ様ですが、デフ ォルトの結果セットのタイプおよび結果セットの並行処理の種類をオーバーライドできま す。

定義:
インタフェース Connection 内の prepareCall
パラメータ:
resultSetType - 結果セットのタイプ。ResultSet.TYPE_XXX を参照
resultSetConcurrency - 並行処理の種類。ResultSet.CONCUR_XXX を参照
戻り値:
プリコンパイルされた SQL 文を含む新しい CallableStatement オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合

prepareCall

public CallableStatement prepareCall(String sql,
                                     int resultSetType,
                                     int resultSetConcurrency,
                                     int resultSetHoldability)
                              throws SQLException
推奨されていません。
指定された型と並行処理で ResultSet オブジェクトを生成する CallableStatement オブジェクトを生成します。 このメソッドは上記の prepareCall メソッドと同じですが、デフォルトの結果セットの型、結果セットの並行処理の種類、および保持機能をオーバーライドできます。

定義:
インタフェース Connection 内の prepareCall
パラメータ:
sql - SQL 文がデータベースへ送られる String オブジェクト。1 つ以上の ? パラメータを含めることができる
resultSetType - ResultSet 定数。ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE、または ResultSet.TYPE_SCROLL_SENSITIVE のうちの 1 つ
resultSetConcurrency - ResultSet 定数。ResultSet.CONCUR_READ_ONLY または ResultSet.CONCUR_UPDATABLE
resultSetHoldability - ResultSet 定数。ResultSet.HOLD_CURSORS_OVER_COMMIT または ResultSet.CLOSE_CURSORS_AT_COMMIT
戻り値:
プリコンパイルされた SQL 文を含む新しい CallableStatement オブジェクト。指定された型、並行処理、および保持機能で ResultSet オブジェクトを生成する
例外:
データベースアクセスエラーが発生した場合、または指定されたパラメータが型、並行処理、および保持機能を示す - ResultSet 定数でない場合
SQLException

prepareStatement

public PreparedStatement prepareStatement(String sql)
                                   throws SQLException
推奨されていません。
パラメータ付き SQL 文をデータベースに送るための PreparedStatement オブジェクトを作成します。

IN パラメータ付きまたは IN パラメータなしの SQL 文は、プリコンパイルし て、PreparedStatement オブジェクトに格納できます。したがって、このオブジェクトは、こ の文を複数回、効率的に実行するのに使用できます。 注: このメソッドは、プリコンパイルが効果のある、パラメータ付き SQL 文を処理するた めに最適化されています。ドライバが、プリコンパイルをサポートしている場合、 prepareStatement メソッドは、その文をプリコンパイル用としてデータベースに送ります。 ドライバによっては、プリコンパイルをサポートしていないものがあります。この場合、 PreparedStatement が実行されるまで、文はデータベースに送られません。これはユー ザに直接的な影響はありませんが、どのメソッドが、どの SQLException をスローしたか に関して影響があります。 返される PreparedStatement を使って生成された結果セット は、デフォルトでは、順方向専用タイプで、読み取り専用の並行処理ができます。

定義:
インタフェース Connection 内の prepareStatement
パラメータ:
sql - 1 つ以上の '?' IN パラメータプレースホルダーを含めることができる SQL 文
戻り値:
プリコンパイルされた文を含む新しい PreparedStatement オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合

prepareStatement

public PreparedStatement prepareStatement(String sql,
                                          int autoGeneratedKeys)
                                   throws SQLException
推奨されていません。
自動生成キーを取得する機能を持つデフォルトの PreparedStatement オブジェクトを生成します。 指定された定数によって、ドライバが自動生成キーを取得可能にするかどうかが指定されます。 SQL 文が INSERT 文でない場合、このパラメータは無視されます。

注 : このメソッドは、プリコンパイルが効果のある、パラメータ付き SQL 文を処理するために最適化されています。 ドライバが、プリコンパイルをサポートしている場合、prepareStatement メソッドは、その文をプリコンパイル用としてデータベースに送ります。 ドライバによっては、プリコンパイルをサポートしていないものがあります。 この場合、PreparedStatement が実行されるまで、文はデータベースに送られません。 これはユーザに直接的な影響はありませんが、どのメソッドが、どの SQLException をスローしたかに関して影響があります。

返される PreparedStatement オブジェクトを使って作成された結果セットは、デフォルトでは、TYPE_FORWARD_ONLY の型で、CONCUR_READ_ONLY の並行処理レベルを持ちます。

定義:
インタフェース Connection 内の prepareStatement
パラメータ:
sql - 1 つ以上の '?' IN パラメータプレースホルダーを含めることができる SQL 文
autoGeneratedKeys - 自動生成キーを返すかどうかを示すフラグ。次の Statement 定数のうちの 1 つ
戻り値:
プリコンパイルされた SQL 文を含む新しい PreparedStatement オブジェクト。自動生成キーを返す機能を持つ
例外:
データベースアクセスエラーが発生した場合、または指定されたパラメータが自動生成キーを返すかどうかを示す - Statement 定数でない場合
SQLException

prepareStatement

public PreparedStatement prepareStatement(String sql,
                                          int resultSetType,
                                          int resultSetConcurrency)
                                   throws SQLException
推奨されていません。
指定されたタイプと並行処理で ResultSet オブジェクトを生成する PreparedStatementオブジェクトを生成します。

このメソッドは上記の prepareStatement メソッドと同じです が、デフォルトの結果セットのタイプおよび結果セットの並行処理の種類をオーバーライド できます。

定義:
インタフェース Connection 内の prepareStatement
パラメータ:
resultSetType - 結果セットのタイプ。ResultSet.TYPE_XXX を参照
resultSetConcurrency - 並行処理の種類。ResultSet.CONCUR_XXX を参照
戻り値:
プリコンパイルされた SQL 文を含む新しい PreparedStatement オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合

prepareStatement

public PreparedStatement prepareStatement(String sql,
                                          int resultSetType,
                                          int resultSetConcurrency,
                                          int resultSetHoldability)
                                   throws SQLException
推奨されていません。
指定された型、並行処理、および保持機能で ResultSet オブジェクトを生成する PreparedStatement オブジェクトを生成します。

このメソッドは上記の prepareStatement メソッドと同じですが、デフォルトの結果セットの型、並行処理、および保持機能をオーバーライドできます。

定義:
インタフェース Connection 内の prepareStatement
パラメータ:
sql - SQL 文がデータベースへ送られる String オブジェクト。1 つ以上の ? IN パラメータを含めることができる
resultSetType - ResultSet 定数。ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE、または ResultSet.TYPE_SCROLL_SENSITIVE のうちの 1 つ
resultSetConcurrency - ResultSet 定数。ResultSet.CONCUR_READ_ONLY または ResultSet.CONCUR_UPDATABLE
resultSetHoldability - ResultSet 定数。ResultSet.HOLD_CURSORS_OVER_COMMIT または ResultSet.CLOSE_CURSORS_AT_COMMIT
戻り値:
プリコンパイルされた SQL 文を含む新しい PreparedStatement オブジェクト。指定された型、並行処理、および保持機能で ResultSet オブジェクトを生成する
例外:
SQLException - データベースアクセスエラーが発生した場合、または指定されたパラメータが型、並行処理、および保持機能を示す ResultSet 定数でない場合

prepareStatement

public PreparedStatement prepareStatement(String sql,
                                          int[] columnIndexes)
                                   throws SQLException
推奨されていません。
指定された配列によって指定された自動生成キーを返す機能を持つデフォルトの PreparedStatement オブジェクトを生成します。この配列は、 使用可能にされる自動生成キーを含むターゲットテーブルの列のインデックスを含みます。 SQL 文が INSERT 文でない場合、この配列は無視されます。

IN パラメータ付きまたは IN パラメータなしの SQL 文は、プリコンパイルして、PreparedStatement オブジェクトに格納できます。 したがって、このオブジェクトは、この文を複数回、効率的に実行するのに使用できます。

注 : このメソッドは、プリコンパイルが効果のある、パラメータ付き SQL 文を処理するために最適化されています。 ドライバが、プリコンパイルをサポートしている場合、prepareStatement メソッドは、その文をプリコンパイル用としてデータベースに送ります。 ドライバによっては、プリコンパイルをサポートしていないものがあります。この場合、PreparedStatement が実行されるまで、文はデータベースに送られません。 これはユーザに直接的な影響はありませんが、どのメソッドが、どの SQLException をスローしたかに関して影響があります。

返される PreparedStatement オブジェクトを使って作成された結果セットは、デフォルトでは、TYPE_FORWARD_ONLY の型で、CONCUR_READ_ONLY の並行処理レベルを持ちます。

定義:
インタフェース Connection 内の prepareStatement
パラメータ:
sql - 1 つ以上の '?' IN パラメータプレースホルダーを含めることができる SQL 文
columnIndexes - 挿入された行から返される列を示す列インデックスの配列
戻り値:
プリコンパイルされた文を含む新しい PreparedStatement オブジェクト。指定された列インデックスの配列によって指定される自動生成キーを返す機能を持つ
例外:
データベースアクセスエラーが発生した場合
SQLException

prepareStatement

public PreparedStatement prepareStatement(String sql,
                                          String[] columnNames)
                                   throws SQLException
推奨されていません。
指定された配列によって指定された自動生成キーを返す機能を持つデフォルトの PreparedStatement オブジェクトを生成します。 この配列は、返される自動生成キーを含むターゲットテーブルの列の名前を含みます。 SQL 文が INSERT 文でない場合、この配列は無視されます。

IN パラメータ付きまたは IN パラメータなしの SQL 文は、プリコンパイルして、PreparedStatement オブジェクトに格納できます。 したがって、このオブジェクトは、この文を複数回、効率的に実行するのに使用できます。

注 : このメソッドは、プリコンパイルが効果のある、パラメータ付き SQL 文を処理するために最適化されています。 ドライバが、プリコンパイルをサポートしている場合、prepareStatement メソッドは、その文をプリコンパイル用としてデータベースに送ります。 ドライバによっては、プリコンパイルをサポートしていないものがあります。 この場合、PreparedStatement が実行されるまで、文はデータベースに送られません。 これはユーザに直接的な影響はありませんが、どのメソッドが、どの SQLException をスローしたかに関して影響があります。

返される PreparedStatement オブジェクトを使って作成された結果セットは、デフォルトでは、TYPE_FORWARD_ONLY の型で、CONCUR_READ_ONLY の並行処理レベルを持ちます。

定義:
インタフェース Connection 内の prepareStatement
パラメータ:
sql - 1 つ以上の '?' IN パラメータプレースホルダーを含めることができる SQL 文
columnNames - 挿入された行から返される列を示す列名の配列
戻り値:
プリコンパイルされた文を含む新しい PreparedStatement オブジェクト。指定された列名の配列によって指定される自動生成キーを返す機能を持つ
例外:
データベースアクセスエラーが発生した場合
SQLException

release

public void release()
             throws SQLException
推奨されていません。
データベースコネクションを解放します。

現在使用しているデータベースコネクションをシステムに返します。 このコネクションを使用後、必ず一回呼び出して下さい。

例外:
SQLException - データベースアクセスエラーが発生した場合

releaseSavepoint

public void releaseSavepoint(Savepoint savepoint)
                      throws SQLException
推奨されていません。
現在のトランザクションから指定された Savepoint オブジェクトを削除します。削除されたあとでセーブポイントを参照すると SQLException がスローされます。

定義:
インタフェース Connection 内の releaseSavepoint
パラメータ:
savepoint - 削除される Savepoint オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合、または指定された Savepoint オブジェクトが現在のトランザクションで有効なセーブポイントでない場合

remove

public int remove(String table,
                  String where)
           throws SQLException
推奨されていません。
データベースにデータを削除するメソッド

データベースのデータを削除(デリート)する。 条件を設定すると、条件に合致したすべてのレコードを削除する。

パラメータ:
table - 処理対象のデータベース表名
where - 更新部分検索条件(WHERE 句)
戻り値:
処理行数
例外:
SQLException - データベースアクセスエラーが発生した場合

rollback

public void rollback()
              throws SQLException
推奨されていません。
データベースアクセスの取り消し処理をする

トランザクションを終了(rollback)させる。

定義:
インタフェース Connection 内の rollback
例外:
SQLException - データベースアクセスエラーが発生した場合

rollback

public void rollback(Savepoint savepoint)
              throws SQLException
推奨されていません。
指定された Savepoint オブジェクトが設定されたあとに行われたすべての変更を元に戻します。

定義:
インタフェース Connection 内の rollback
パラメータ:
savepoint - ロールバックする Savepoint オブジェクト
例外:
データベースアクセスエラーが発生した場合、Savepoint - オブジェクトが有効でなくなった場合、または現在この Connection オブジェクトが自動コミットモードである場合
SQLException

select

public List select(String sql)
            throws SQLException
推奨されていません。
SELECT文を発行してデータベースからデータを取得する

パラメータ:
sql - SQL文（SELECT文）
引数のSQL文にはステートメント末判定文字(";"や"/"など)は付けない。
戻り値:
Listの各要素はHashtable。カラム名(全て小文字に変換)＝値 で格納される。 取得できるデータは以下のように変換されます。

JDBCドライバによっては以下の表の通りに取得できない場合もあります。
java.sql.Types.CHAR | java.lang.String
java.sql.Types.CLOB(※１)
java.sql.Types.LONGVARCHAR
java.sql.Types.VARCHAR
java.sql.Types.TIMESTAMP
java.sql.Types.OTHER(※１)
java.sql.Types.BIT | java.lang.Double
java.sql.Types.BIGINT
java.sql.Types.DECIMAL
java.sql.Types.DOUBLE
java.sql.Types.FLOAT
java.sql.Types.INTEGER
java.sql.Types.NUMERIC
java.sql.Types.REAL
java.sql.Types.SMALLINT
java.sql.Types.TINYINT
java.sql.Types.DATE | java.util.Date
java.sql.Types.TIME
java.sql.Types.BINARY(※１) | java.lang.String（エンコードしないString(バイナリ形式)）
java.sql.Types.LONGVARBINARY(※１)
java.sql.Types.VARBINARY(※１)
java.sql.Types.NULL | 取得しない
java.sql.Types.REF(※１) | java.lang.Object(java.sql.ResultSet.getObject()で取得した値)
java.sql.Types.JAVA_OBJECT(※１)
java.sql.Types.STRUCT(※１)
java.sql.Types.ARRAY(※１)
java.sql.Types.DISTINCT(※１)
(※１)推奨されません。動作未検証です。
例外:
SQLException - データベースアクセスエラーが発生した場合

setAutoCommit

public void setAutoCommit(boolean autoCommit)
                   throws SQLException
推奨されていません。

定義:
インタフェース Connection 内の setAutoCommit
例外:
SQLException

setCatalog

public void setCatalog(String catalog)
                throws SQLException
推奨されていません。
この Connection のデータベースに作業のためのサブスペースを選択するために、カタログ名を設定します。

ドライバがカタログをサポートしていない場合は、この要求を無視しま す。

定義:
インタフェース Connection 内の setCatalog
例外:
SQLException - データベースアクセスエラーが発生した場合

setHoldability

public void setHoldability(int holdability)
                    throws SQLException
推奨されていません。
この Connection オブジェクトを使用して生成された ResultSet オブジェクトの保持機能を指定された保持機能へ変更します。

定義:
インタフェース Connection 内の setHoldability
パラメータ:
holdability - ResultSet の保持機能定数。ResultSet.HOLD_CURSORS_OVER_COMMIT または ResultSet.CLOSE_CURSORS_AT_COMMIT
例外:
データベースアクセスエラーが発生した場合、指定されたパラメータが保持機能を示す - ResultSet 定数でない場合、または指定された保持機能がサポートされていない場合
SQLException

setReadOnly

public void setReadOnly(boolean readOnly)
                 throws SQLException
推奨されていません。
この Connection を読み込み専用モードに設定して、データベース最適化を実行するヒントとします。

注: トランザクションの途中では、このメソッドを呼び出すことはできません。

定義:
インタフェース Connection 内の setReadOnly
パラメータ:
readOnly - true の場合は読み込み専用モードが有効、false の場合は読み込み専用モードが無効
例外:
SQLException - データベースアクセスエラーが発生した場合

setSavepoint

public Savepoint setSavepoint()
                       throws SQLException
推奨されていません。
現在のトランザクションで名前のないセーブポイントを作成し、それを表す新しい Savepoint オブジェクトを返します。

定義:
インタフェース Connection 内の setSavepoint
戻り値:
新しい Savepoint オブジェクト
例外:
データベースアクセスエラーが発生した場合、または現在この - Connection オブジェクトが自動コミットモードである場合
SQLException

setSavepoint

public Savepoint setSavepoint(String name)
                       throws SQLException
推奨されていません。
現在のトランザクションで指定された名前のセーブポイントを作成し、それを表す新しい Savepoint オブジェクトを返します。

定義:
インタフェース Connection 内の setSavepoint
パラメータ:
name - セーブポイントの名前を格納する String
戻り値:
新しい Savepoint オブジェクト
例外:
データベースアクセスエラーが発生した場合、または現在この - Connection オブジェクトが自動コミットモードである場合
SQLException

setTimer

public void setTimer(boolean autoRelease)
              throws SQLException
推奨されていません。
トランザクション自動切断機能のタイマーをセットする（デフォルトtrue）

パラメータ:
autoRelease - タイマーストップ false ／スタート true
例外:
SQLException

setTransactionIsolation

public void setTransactionIsolation(int level)
                             throws SQLException
推奨されていません。
トランザクション遮断レベルを指定されたものに変更することを試みます。

指定できるトランザクション遮断レベルの定数は、Connection インタフェースで定義されています。
注: トランザクションの途中では、このメソッドを呼び出すことはできません。

定義:
インタフェース Connection 内の setTransactionIsolation
パラメータ:
level - TRANSACTION_NONE を除く TRANSACTION_* 遮断値の 1 つ。データベースによっては、ほかの値をサポートしないものがある
例外:
SQLException - データベースアクセスエラーが発生した場合

setTypeMap

public void setTypeMap(Map map)
                throws SQLException
推奨されていません。
この接続の型マップとして指定された型マップをインストールします。

型マップは、SQL 構造化型および個別の型のカスタムマッピングに使用されます。

定義:
インタフェース Connection 内の setTypeMap
パラメータ:
map - この Connection オブジェクトのデフォルトの型マップの代わりとしてインスト ールする java.util.Map オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合

transaction

public void transaction()
                 throws SQLException
推奨されていません。
データベースアクセスのトランザクションを開始する

トランザクションを開始させる。

例外:
SQLException - データベースアクセスエラーが発生した場合

update

public int update(String table,
                  String where,
                  Map datas)
           throws SQLException
推奨されていません。
データベースにデータを更新するメソッド

データベースのデータを更新(アップデート)する。 更新データはオブジェクト(Map)形式のデータをセット。 なお、オブジェクトのプロパティ名称は、更新したい データベースのカラム名称に等しく作成し、そのプロパティに 対して挿入したいデータをセットする。

パラメータ:
table - 処理対象のデータベース表名
where - 更新部分検索条件(WHERE 句)
datas - 更新データ 引数 datas(Map)の内容
(key == value)
カラム名 = 値 ここでセットできるデータ型（値）は、String,Numberのみです。
戻り値:
処理行数
例外:
SQLException - データベースアクセスエラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.database (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.database
インタフェース
ConInfo
DatabaseAccessor
DataSourceProvider
DBResultAdapter
DbsConnection
クラス
DatabaseColumn
DatabaseExport
DatabaseManager
DbManager
DBResultArrayAdapter
DBResultBigDecimalAdapter
DBResultBigIntAdapter
DBResultBinaryAdapter
DBResultBlobAdapter
DBResultBooleanAdapter
DBResultByteAdapter
DBResultClobAdapter
DBResultDateAdapter
DBResultDoubleAdapter
DBResultImTimestampAdapter
DBResultIntegerAdapter
DBResultNullAdapter
DBResultObjectAdapter
DBResultRealAdapter
DBResultRefAdapter
DBResultShortAdapter
DBResultStringAdapter
DBResultStructAdapter
DBResultTimeAdapter
DBResultTimestampAdapter
DbTypes


jp.co.intra_mart.foundation.database (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.database

データベースへアクセスするためのクラスを提供します。

参照:
説明

インタフェースの概要
ConInfo |
DatabaseAccessor | データベース接続オブジェクト取得インターフェースを定義します。
DataSourceProvider | データソース設定情報取得プロバイダインタフェース。
DBResultAdapter | スクリプト開発用データベースカラム取得アダプタインタフェース。
DbsConnection | 推奨されていません。 Connectionを利用してください。

クラスの概要
DatabaseColumn |
DatabaseExport | 推奨されていません。 システム内部で利用しているクラスです。
DatabaseManager | データベースマネージャクラス。
DbManager | 推奨されていません。 DatabaseManagerを使用してください。
DBResultArrayAdapter | スクリプト開発用データベースARRAY型カラム取得アダプタ。
DBResultBigDecimalAdapter | スクリプト開発用データベースDECIMAL,NUMERIC型カラム取得アダプタ。
DBResultBigIntAdapter | スクリプト開発用データベースBIGINT型カラム取得アダプタ。
DBResultBinaryAdapter | スクリプト開発用データベースBINARY,LONGVARBINARY,VARBINARY型カラム取得アダプタ。
DBResultBlobAdapter | スクリプト開発用データベースBLOB型カラム取得アダプタ。
DBResultBooleanAdapter | スクリプト開発用データベースBOOLEAN,BIT型カラム取得アダプタ。
DBResultByteAdapter | スクリプト開発用データベースBYTE型カラム取得アダプタ。
DBResultClobAdapter | スクリプト開発用データベースCLOB型カラム取得アダプタ。
DBResultDateAdapter | スクリプト開発用データベースDATE型カラム取得アダプタ。
DBResultDoubleAdapter | スクリプト開発用データベースDOUBLE,FLOAT型カラム取得アダプタ。
DBResultImTimestampAdapter | スクリプト開発用データベースTIMESTAMP型カラム取得intra-mart拡張アダプタ。
DBResultIntegerAdapter | スクリプト開発用データベースINTEGER型カラム取得アダプタ。
DBResultNullAdapter | スクリプト開発用データベースNULL型カラム取得アダプタ。
DBResultObjectAdapter | スクリプト開発用データベースカラムをObject型として取得するアダプタ。
DBResultRealAdapter | スクリプト開発用データベースREAL型カラム取得アダプタ。
DBResultRefAdapter | スクリプト開発用データベースREF型カラム取得アダプタ。
DBResultShortAdapter | スクリプト開発用データベースSMALLINT型カラム取得アダプタ。
DBResultStringAdapter | スクリプト開発用データベースカラムを文字列型として取得するアダプタ。
DBResultStructAdapter | スクリプト開発用データベースSTRUCT型カラム取得アダプタ。
DBResultTimeAdapter | スクリプト開発用データベースTIME型カラム取得アダプタ。
DBResultTimestampAdapter | スクリプト開発用データベースTIMESTAMP型カラム取得アダプター。
DbTypes |

パッケージ jp.co.intra_mart.foundation.database の説明

データベースへアクセスするためのクラスを提供します。


jp.co.intra_mart.foundation.database クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.database の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.database.DatabaseColumn
    • class jp.co.intra_mart.foundation.database.DatabaseExport
    • class jp.co.intra_mart.foundation.database.DatabaseManager
    • class jp.co.intra_mart.foundation.database.DbManager
    • class jp.co.intra_mart.foundation.database.DBResultArrayAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultBigDecimalAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultBigIntAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultBinaryAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultBlobAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultBooleanAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultByteAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultClobAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultDateAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultDoubleAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultImTimestampAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultIntegerAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultNullAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultObjectAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultRealAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultRefAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultShortAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultStringAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultStructAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultTimeAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultTimestampAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DbTypes

インタフェース階層

  • interface jp.co.intra_mart.foundation.database.ConInfo
  • interface java.sql.Connection
    • interface jp.co.intra_mart.foundation.database.DbsConnection
  • interface jp.co.intra_mart.foundation.database.DatabaseAccessor
  • interface jp.co.intra_mart.foundation.database.DataSourceProvider
  • interface jp.co.intra_mart.foundation.database.DBResultAdapter


パッケージ jp.co.intra_mart.foundation.database の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.database の使用

jp.co.intra_mart.foundation.database を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database により使用される jp.co.intra_mart.foundation.database のクラス
ConInfo
DatabaseAccessor
データベース接続オブジェクト取得インターフェースを定義します。
DatabaseColumn
DatabaseExport
推奨されていません。 システム内部で利用しているクラスです。
DatabaseManager
データベースマネージャクラス。
DataSourceProvider
データソース設定情報取得プロバイダインタフェース。
DBResultAdapter
スクリプト開発用データベースカラム取得アダプタインタフェース。
DbsConnection
推奨されていません。 Connectionを利用してください。
DbTypes

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass の使用

jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational の使用

CateogryClassInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class 分類区分情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.category.category_class での CateogryClassInternational の使用

CateogryClassInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.category.category_class のメソッド
 CateogryClassInternational CateogryClass.getCateogryClassInternational(Locale locale)
指定された言語に対する国際化情報を取得します。

CateogryClassInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.category.category_class のメソッド
 void CateogryClass.putInternational(Locale locale, CateogryClassInternational data)
指定された言語に対する国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CateogryClass (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.category.category_class
クラス CateogryClass

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass
すべての実装インタフェース:
Serializable
public class CateogryClass
extends Object
implements Serializable

分類区分の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CateogryClass()
分類区分に関連する情報を新規に生成します。
CateogryClass(Locale locale)
分類区分に関連する情報を新規に生成します。
メソッドの概要
String | getCategoryClassCode() 分類区分コードを取得します。
CateogryClassInternational | getCateogryClassInternational(Locale locale) 指定された言語に対する国際化情報を取得します。
Locale | getDefaultLocale() デフォルトのロケールを取得します。
Locale[] | getLocales() この分類区分で管理している言語（ロケール）をすべて取得します。
String | getName() 分類区分名を取得します。
String | getName(Locale locale) 分類区分名を取得します。
String | getNotes() 備考を取得します。
void | putInternational(Locale locale, CateogryClassInternational data) 指定された言語に対する国際化情報を設定します。
void | removeInternational(Locale locale) 指定された言語に対する国際化情報を削除します。
void | setCategoryClassCode(String categoryClassCode) 分類区分コードを設定します。
void | setDefaultLocale(Locale defaultLocale) デフォルトのロケールを設定します。
void | setNotes(String notes) 備考を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CateogryClass

public CateogryClass()
分類区分に関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値の言語だけのロケールが割り当てられます。

CateogryClass

public CateogryClass(Locale locale)
分類区分に関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられます。

パラメータ:
locale - デフォルトの言語
メソッドの詳細

getDefaultLocale

public Locale getDefaultLocale()
デフォルトのロケールを取得します。

戻り値:
デフォルトのロケール

setDefaultLocale

public void setDefaultLocale(Locale defaultLocale)
デフォルトのロケールを設定します。

パラメータ:
defaultLocale - デフォルトのロケール

getLocales

public Locale[] getLocales()
この分類区分で管理している言語（ロケール）をすべて取得します。

戻り値:
この分類区分で管理している言語（ロケール）

getCateogryClassInternational

public CateogryClassInternational getCateogryClassInternational(Locale locale)
指定された言語に対する国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
国際化情報

putInternational

public void putInternational(Locale locale,
                             CateogryClassInternational data)
指定された言語に対する国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 国際化情報

removeInternational

public void removeInternational(Locale locale)
指定された言語に対する国際化情報を削除します。

パラメータ:
locale - 言語（ロケール）

getCategoryClassCode

public String getCategoryClassCode()
分類区分コードを取得します。

戻り値:
分類区分コード

setCategoryClassCode

public void setCategoryClassCode(String categoryClassCode)
分類区分コードを設定します。

パラメータ:
categoryClassCode - 分類区分コード

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getName

public String getName()
分類区分名を取得します。

戻り値:
分類区分名

getName

public String getName(Locale locale)
分類区分名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
分類区分名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CateogryClassInternational (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.category.category_class
クラス CateogryClassInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational
すべての実装インタフェース:
Serializable
public class CateogryClassInternational
extends Object
implements Serializable

分類区分の国際化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CateogryClassInternational()
メソッドの概要
String | getName() 分類区分名を取得します。
void | setName(String name) 分類区分名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CateogryClassInternational

public CateogryClassInternational()
メソッドの詳細

getName

public String getName()
分類区分名を取得します。

戻り値:
分類区分名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
分類区分名を設定します。

パラメータ:
name - 分類区分名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.category.category_class (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.category.category_class
クラス
CateogryClass
CateogryClassInternational


jp.co.intra_mart.foundation.datastore.application.domain.category.category_class (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.category_class

分類区分情報を操作するクラスを提供します。

参照:
説明

クラスの概要
CateogryClass | 分類区分の基本属性のデータを取り扱います。
CateogryClassInternational | 分類区分の国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.category_class の説明

分類区分情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.category.category_class クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.category_class の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.category_class の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class の使用

jp.co.intra_mart.foundation.datastore.application.domain.category.category_class を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class 分類区分情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.category.category_class により使用される jp.co.intra_mart.foundation.datastore.application.domain.category.category_class のクラス
CateogryClassInternational
分類区分の国際化属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager の使用

CategoryManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category 分類情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.category での CategoryManager の使用

CategoryManager を返す jp.co.intra_mart.foundation.datastore.application.domain.category のメソッド
static CategoryManager CategoryManager.getCategoryManager(String user, String group)
CategoryManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail の使用

CategoryDetail を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category 分類情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.category での CategoryDetail の使用

CategoryDetail を返す jp.co.intra_mart.foundation.datastore.application.domain.category のメソッド
abstract CategoryDetail[] | CategoryManager.getCategoryDetails() 登録済みの分類区分詳細情報の一覧を取得します。
abstract CategoryDetail[] | CategoryManager.getCategoryDetails(String categoryClassCode) 登録済みの分類区分詳細情報の一覧を取得します。
abstract CategoryDetail | CategoryManager.getCategoryDetail(String categoryClassCode, String categoryCode) 登録済みの分類区分詳細情報を取得します。

CategoryDetail 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.category のメソッド
abstract void | CategoryManager.addCategoryDetail(CategoryDetail categoryDetail) 分類区分詳細を登録します。
abstract void | CategoryManager.updateCategoryDetail(CategoryDetail categoryDetail) 登録済の分類区分詳細を更新します。
abstract void | CategoryManager.deleteCategoryDetail(CategoryDetail categoryDetail) 登録済の分類区分詳細を削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational の使用

CategoryDetailInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category.detail 分類詳細情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.category.detail での CategoryDetailInternational の使用

CategoryDetailInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.category.detail のメソッド
 CategoryDetailInternational CategoryDetail.getCategoryDetailInternational(Locale locale)
指定された言語に対する国際化情報を取得します。

CategoryDetailInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.category.detail のメソッド
 void CategoryDetail.putInternational(Locale locale, CategoryDetailInternational data)
指定された言語に対する国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CategoryDetail (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.category.detail
クラス CategoryDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail
すべての実装インタフェース:
Serializable
public class CategoryDetail
extends Object
implements Serializable

分類区分詳細の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CategoryDetail()
分類区分詳細に関連する情報を新規に生成します。
CategoryDetail(Locale locale)
分類区分詳細に関連する情報を新規に生成します。
メソッドの概要
String | getCategoryClassCode() 分類区分コードを取得します。
String | getCategoryCode() 分類コードを取得します。
CategoryDetailInternational | getCategoryDetailInternational(Locale locale) 指定された言語に対する国際化情報を取得します。
Locale | getDefaultLocale() デフォルトのロケールを取得します。
Locale[] | getLocales() この分類区分詳細で管理している言語（ロケール）をすべて取得します。
String | getName() 分類名を取得します。
String | getName(Locale locale) 分類名を取得します。
String | getNotes() 備考を取得します。
void | putInternational(Locale locale, CategoryDetailInternational data) 指定された言語に対する国際化情報を設定します。
void | removeInternational(Locale locale) 指定された言語に対する国際化情報を削除します。
void | setCategoryClassCode(String categoryClassCode) 分類区分コードを設定します。
void | setCategoryCode(String categoryCode) 分類コードを設定します。
void | setDefaultLocale(Locale defaultLocale) デフォルトのロケールを設定します。
void | setNotes(String notes) 備考を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CategoryDetail

public CategoryDetail()
分類区分詳細に関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値の言語だけのロケールが割り当てられます。

CategoryDetail

public CategoryDetail(Locale locale)
分類区分詳細に関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられます。

パラメータ:
locale - デフォルトの言語
メソッドの詳細

getDefaultLocale

public Locale getDefaultLocale()
デフォルトのロケールを取得します。

戻り値:
デフォルトのロケール

setDefaultLocale

public void setDefaultLocale(Locale defaultLocale)
デフォルトのロケールを設定します。

パラメータ:
defaultLocale - デフォルトのロケール

getLocales

public Locale[] getLocales()
この分類区分詳細で管理している言語（ロケール）をすべて取得します。

戻り値:
この分類区分詳細で管理している言語（ロケール）

getCategoryDetailInternational

public CategoryDetailInternational getCategoryDetailInternational(Locale locale)
指定された言語に対する国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
国際化情報

putInternational

public void putInternational(Locale locale,
                             CategoryDetailInternational data)
指定された言語に対する国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 国際化情報

removeInternational

public void removeInternational(Locale locale)
指定された言語に対する国際化情報を削除します。

パラメータ:
locale - 言語（ロケール）

getCategoryClassCode

public String getCategoryClassCode()
分類区分コードを取得します。

戻り値:
分類区分コード

setCategoryClassCode

public void setCategoryClassCode(String categoryClassCode)
分類区分コードを設定します。

パラメータ:
categoryClassCode - 分類区分コード

getCategoryCode

public String getCategoryCode()
分類コードを取得します。

戻り値:
分類コード

setCategoryCode

public void setCategoryCode(String categoryCode)
分類コードを設定します。

パラメータ:
categoryCode - 分類コード

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getName

public String getName()
分類名を取得します。

戻り値:
分類名

getName

public String getName(Locale locale)
分類名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
分類名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CategoryDetailInternational (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.category.detail
クラス CategoryDetailInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational
すべての実装インタフェース:
Serializable
public class CategoryDetailInternational
extends Object
implements Serializable

分類区分詳細の国際化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CategoryDetailInternational()
メソッドの概要
String | getName() 分類名を取得します。
void | setName(String name) 分類名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CategoryDetailInternational

public CategoryDetailInternational()
メソッドの詳細

getName

public String getName()
分類名を取得します。

戻り値:
分類名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
分類名を設定します。

パラメータ:
name - 分類名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.category.detail (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.category.detail
クラス
CategoryDetail
CategoryDetailInternational


jp.co.intra_mart.foundation.datastore.application.domain.category.detail (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.detail

分類詳細情報を操作するクラスを提供します。

参照:
説明

クラスの概要
CategoryDetail | 分類区分詳細の基本属性のデータを取り扱います。
CategoryDetailInternational | 分類区分詳細の国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.detail の説明

分類詳細情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.category.detail クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.detail の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.detail の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category.detail の使用

jp.co.intra_mart.foundation.datastore.application.domain.category.detail を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category | 分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category.detail | 分類詳細情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.category により使用される jp.co.intra_mart.foundation.datastore.application.domain.category.detail のクラス
CategoryDetail
分類区分詳細の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.category.detail により使用される jp.co.intra_mart.foundation.datastore.application.domain.category.detail のクラス
CategoryDetailInternational
分類区分詳細の国際化属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CategoryManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.category
クラス CategoryManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager
public abstract class CategoryManager
extends Object

分類に関連する情報を管理します。 このクラスのインスタンスは必ず getCategoryManager(String,String) で取得してください。

導入されたバージョン:
5.0

コンストラクタの概要
CategoryManager()
メソッドの概要
abstract void | addCategoryDetail(CategoryDetail categoryDetail) 分類区分詳細を登録します。
abstract void | deleteCategoryDetail(CategoryDetail categoryDetail) 登録済の分類区分詳細を削除します。
abstract CategoryDetail | getCategoryDetail(String categoryClassCode, String categoryCode) 登録済みの分類区分詳細情報を取得します。
abstract CategoryDetail[] | getCategoryDetails() 登録済みの分類区分詳細情報の一覧を取得します。
abstract CategoryDetail[] | getCategoryDetails(String categoryClassCode) 登録済みの分類区分詳細情報の一覧を取得します。
static CategoryManager | getCategoryManager(String user, String group) CategoryManagerを取得します。
protected abstract void | init(String user, String group) CategoryManagerを初期化します。
abstract void | updateCategoryDetail(CategoryDetail categoryDetail) 登録済の分類区分詳細を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CategoryManager

public CategoryManager()
メソッドの詳細

getCategoryManager

public static CategoryManager getCategoryManager(String user,
                                                 String group)
                                          throws ManagerException
CategoryManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するCategoryManager
例外:
ManagerException - CategoryManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
CategoryManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - CategoryManagerの初期化に失敗

addCategoryDetail

public abstract void addCategoryDetail(CategoryDetail categoryDetail)
                                throws ManagerException
分類区分詳細を登録します。

パラメータ:
categoryDetail - 分類区分詳細情報
例外:
ManagerException - 分類区分詳細の登録に失敗

updateCategoryDetail

public abstract void updateCategoryDetail(CategoryDetail categoryDetail)
                                   throws ManagerException
登録済の分類区分詳細を更新します。

パラメータ:
categoryDetail - 分類区分詳細情報
例外:
ManagerException - 分類区分詳細の更新に失敗

deleteCategoryDetail

public abstract void deleteCategoryDetail(CategoryDetail categoryDetail)
                                   throws ManagerException
登録済の分類区分詳細を削除します。
指定された分類区分詳細の情報が存在しない場合は ManagerException がスローされます。

パラメータ:
categoryDetail - 分類区分詳細情報
例外:
ManagerException - 分類区分詳細の削除に失敗

getCategoryDetails

public abstract CategoryDetail[] getCategoryDetails()
                                             throws ManagerException
登録済みの分類区分詳細情報の一覧を取得します。
分類詳細情報が1件も存在しない場合は空の配列を返します。
取得される分類区分詳細情報の国際化情報には、ログインユーザのデフォルト言語の情報のみが設定されます。

戻り値:
分類区分詳細情報の一覧
例外:
ManagerException - 分類区分詳細情報の一覧の取得に失敗
導入されたバージョン:
6.1

getCategoryDetails

public abstract CategoryDetail[] getCategoryDetails(String categoryClassCode)
                                             throws ManagerException
登録済みの分類区分詳細情報の一覧を取得します。
指定された分類区分コードに対する詳細情報が存在しない場合は空の配列を返します。
取得される分類区分詳細情報の国際化情報には、ログインユーザのデフォルト言語の情報のみが設定されます。

パラメータ:
categoryClassCode - 分類区分コード
戻り値:
分類区分詳細情報の一覧
例外:
ManagerException - 分類区分詳細情報の一覧の取得に失敗
導入されたバージョン:
6.1

getCategoryDetail

public abstract CategoryDetail getCategoryDetail(String categoryClassCode,
                                                 String categoryCode)
                                          throws ManagerException
登録済みの分類区分詳細情報を取得します。
指定された分類区分コード、分類コードに対する詳細情報が存在しない場合は nullを返します。

パラメータ:
categoryClassCode - 分類区分コード
categoryCode - 分類コード
戻り値:
分類区分詳細情報
例外:
ManagerException - 分類区分詳細情報の取得に失敗
導入されたバージョン:
6.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.category (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.category
クラス
CategoryManager


jp.co.intra_mart.foundation.datastore.application.domain.category (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category

分類情報を操作するクラスを提供します。

参照:
説明

クラスの概要
CategoryManager 分類に関連する情報を管理します。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category の説明

分類情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.category クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category の使用

jp.co.intra_mart.foundation.datastore.application.domain.category を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category 分類情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.category により使用される jp.co.intra_mart.foundation.datastore.application.domain.category のクラス
CategoryManager
分類に関連する情報を管理します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach の使用

DepartmentAttach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での DepartmentAttach の使用

DepartmentAttach を返す jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract  DepartmentAttach CompanyManager.getDepartmentAttach(String user, String company, String department)
ユーザの組織への所属情報を取得します。

DepartmentAttach 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract void | CompanyManager.setMember(DepartmentAttach attach) 組織に人員を割り当てます。
abstract void | CompanyManager.deleteMember(DepartmentAttach attach) 組織から人員をはずします。
void | CompanyChangedListener.memberSet(String groupId, DepartmentAttach attach) 組織への人員の割当がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.memberDeleted(String groupId, DepartmentAttach attach) 組織からの人員の割当がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.access での DepartmentAttach の使用

DepartmentAttach 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | CompanyChangedControllerListener.memberSet(String groupId, DepartmentAttach attach) 組織への人員の割当がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.memberDeleted(String groupId, DepartmentAttach attach) 組織からの人員の割当がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での DepartmentAttach の使用

DepartmentAttach 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | CompanyChangedMenuListener.memberSet(String groupId, DepartmentAttach attach) 組織への人員の割当がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.memberDeleted(String groupId, DepartmentAttach attach) 組織からの人員の割当がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable の使用

DepartmentAttachTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.attach 組織所属情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.attach での DepartmentAttachTerminable の使用

DepartmentAttachTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.company.attach のメソッド
DepartmentAttachTerminable | DepartmentAttach.getDepartmentAttachTerminable(Term term) 指定された期間に対する期間化情報を取得します。
DepartmentAttachTerminable | DepartmentAttach.getDepartmentAttachTerminable(Date date) 指定された日時に対する期間化情報を取得します。

DepartmentAttachTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.attach のメソッド
 void DepartmentAttach.putDepartmentAttachTerminable(Term term, DepartmentAttachTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DepartmentAttach (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.attach
クラス DepartmentAttach

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach
すべての実装インタフェース:
Serializable
public class DepartmentAttach
extends Object
implements Serializable

組織所属の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DepartmentAttach()
組織所属に関連する情報を新規に生成します。
DepartmentAttach(Date date)
組織所属に関連する情報を新規に生成します。
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
Date | getDefaultDate() デフォルトの日時を取得します。
DepartmentAttachTerminable | getDepartmentAttachTerminable(Date date) 指定された日時に対する期間化情報を取得します。
DepartmentAttachTerminable | getDepartmentAttachTerminable(Term term) 指定された期間に対する期間化情報を取得します。
String | getDepartmentCode() 組織コードを取得します。
String | getPostCode() 役職CDを取得します。
String | getPostCode(Date date) 役職CDを取得します。
int | getSortKey() ソートキーを取得します。
Term[] | getTerms() この組織所属で管理している期間をすべて取得します。
String | getUserCode() ユーザコードを取得します。
void | putDepartmentAttachTerminable(Term term, DepartmentAttachTerminable data) 指定された期間に対する期間化情報を設定します。
void | removeDepartmentAttachTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setDepartmentCode(String departmentCode) 組織コードを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
void | setUserCode(String userCode) ユーザコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DepartmentAttach

public DepartmentAttach()
組織所属に関連する情報を新規に生成します。 デフォルトの日時には現在のシステム日時が割り当てられます。

DepartmentAttach

public DepartmentAttach(Date date)
組織所属に関連する情報を新規に生成します。 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時
メソッドの詳細

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
この組織所属で管理している期間をすべて取得します。

戻り値:
この組織所属で管理している期間

getDepartmentAttachTerminable

public DepartmentAttachTerminable getDepartmentAttachTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getDepartmentAttachTerminable

public DepartmentAttachTerminable getDepartmentAttachTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putDepartmentAttachTerminable

public void putDepartmentAttachTerminable(Term term,
                                          DepartmentAttachTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removeDepartmentAttachTerminable

public void removeDepartmentAttachTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getUserCode

public String getUserCode()
ユーザコードを取得します。

戻り値:
ユーザコード

setUserCode

public void setUserCode(String userCode)
ユーザコードを設定します。

パラメータ:
userCode - ユーザコード

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します。

パラメータ:
companyCode - 会社コード

getDepartmentCode

public String getDepartmentCode()
組織コードを取得します。

戻り値:
組織コード

setDepartmentCode

public void setDepartmentCode(String departmentCode)
組織コードを設定します。

パラメータ:
departmentCode - 組織コード

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー

getPostCode

public String getPostCode()
役職CDを取得します。

戻り値:
役職CD

getPostCode

public String getPostCode(Date date)
役職CDを取得します。

パラメータ:
date - 日時
戻り値:
役職CD
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DepartmentAttachTerminable (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.attach
クラス DepartmentAttachTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable
すべての実装インタフェース:
Serializable
public class DepartmentAttachTerminable
extends Object
implements Serializable

組織所属の期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DepartmentAttachTerminable()
メソッドの概要
String | getPostCode() 役職CDを取得します。
void | setPostCode(String postCode) 役職CDを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DepartmentAttachTerminable

public DepartmentAttachTerminable()
メソッドの詳細

getPostCode

public String getPostCode()
役職CDを取得します。

戻り値:
役職CD

setPostCode

public void setPostCode(String postCode)
役職CDを設定します。

パラメータ:
postCode - 役職CD
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.company.attach (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.company.attach
クラス
DepartmentAttach
DepartmentAttachTerminable


jp.co.intra_mart.foundation.datastore.application.domain.company.attach (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.attach

組織所属情報を操作するクラスを提供します。

参照:
説明

クラスの概要
DepartmentAttach | 組織所属の基本属性のデータを取り扱います。
DepartmentAttachTerminable | 組織所属の期間化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.attach の説明

組織所属情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.company.attach クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.attach の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.attach の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.attach の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.attach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.attach | 組織所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.attach のクラス
DepartmentAttach
組織所属の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.company.attach により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.attach のクラス
DepartmentAttachTerminable
組織所属の期間化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.attach のクラス
DepartmentAttach
組織所属の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.attach のクラス
DepartmentAttach
組織所属の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory の使用

CompanyCategory を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での CompanyCategory の使用

CompanyCategory 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract void | CompanyManager.setCategoryDetail(CompanyCategory category) 組織に対して指定された分類区分情報を設定します。
abstract void | CompanyManager.removeCategoryDetail(CompanyCategory category) 組織に対して指定された分類区分情報を削除します。
void | CompanyChangedListener.categoryDetailSet(String groupId, CompanyCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.categoryDetailRemoved(String groupId, CompanyCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.access での CompanyCategory の使用

CompanyCategory 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | CompanyChangedControllerListener.categoryDetailSet(String groupId, CompanyCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.categoryDetailRemoved(String groupId, CompanyCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での CompanyCategory の使用

CompanyCategory 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | CompanyChangedMenuListener.categoryDetailSet(String groupId, CompanyCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.categoryDetailRemoved(String groupId, CompanyCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable の使用

CompanyCategoryTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.category 会社分類情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.category での CompanyCategoryTerminable の使用

CompanyCategoryTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.company.category のメソッド
CompanyCategoryTerminable | CompanyCategory.getCompanyCategoryTerminable(Term term) 指定された期間に対する期間化情報を取得します。
CompanyCategoryTerminable | CompanyCategory.getCompanyCategoryTerminable(Date date) 指定された日時に対する期間化情報を取得します。

CompanyCategoryTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.category のメソッド
 void CompanyCategory.putCompanyCategoryTerminable(Term term, CompanyCategoryTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CompanyCategory (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.category
クラス CompanyCategory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory
すべての実装インタフェース:
Serializable
public class CompanyCategory
extends Object
implements Serializable

会社組織分類の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CompanyCategory()
会社組織分類に関連する情報を新規に生成します。
CompanyCategory(Date date)
会社組織分類に関連する情報を新規に生成します。
メソッドの概要
String | getCategoryClassCode() 分類区分コードを取得します。
String | getCategoryCode() 分類コードを取得します。
CompanyCategoryTerminable | getCompanyCategoryTerminable(Date date) 指定された日時に対する期間化情報を取得します。
CompanyCategoryTerminable | getCompanyCategoryTerminable(Term term) 指定された期間に対する期間化情報を取得します。
String | getCompanyCode() 会社コードを取得します。
Date | getDefaultDate() デフォルトの日時を取得します。
String | getDepartmentCode() 組織コードを取得します。
Term[] | getTerms() この会社組織分類で管理している期間をすべて取得します。
void | putCompanyCategoryTerminable(Term term, CompanyCategoryTerminable data) 指定された期間に対する期間化情報を設定します。
void | removeCompanyCategoryTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setCategoryClassCode(String categoryClassCode) 分類区分コードを設定します。
void | setCategoryCode(String categoryCode) 分類コードを設定します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setDepartmentCode(String departmentCode) 組織コードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyCategory

public CompanyCategory()
会社組織分類に関連する情報を新規に生成します。 デフォルトの日時には現在のシステム日時が割り当てられます。

CompanyCategory

public CompanyCategory(Date date)
会社組織分類に関連する情報を新規に生成します。 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時
メソッドの詳細

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
この会社組織分類で管理している期間をすべて取得します。

戻り値:
この会社組織分類で管理している期間

getCompanyCategoryTerminable

public CompanyCategoryTerminable getCompanyCategoryTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getCompanyCategoryTerminable

public CompanyCategoryTerminable getCompanyCategoryTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putCompanyCategoryTerminable

public void putCompanyCategoryTerminable(Term term,
                                         CompanyCategoryTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removeCompanyCategoryTerminable

public void removeCompanyCategoryTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します。

パラメータ:
companyCode - 会社コード

getDepartmentCode

public String getDepartmentCode()
組織コードを取得します。

戻り値:
組織コード

setDepartmentCode

public void setDepartmentCode(String departmentCode)
組織コードを設定します。

パラメータ:
departmentCode - 組織コード

getCategoryClassCode

public String getCategoryClassCode()
分類区分コードを取得します。

戻り値:
分類区分コード

setCategoryClassCode

public void setCategoryClassCode(String categoryClassCode)
分類区分コードを設定します。

パラメータ:
categoryClassCode - 分類区分コード

getCategoryCode

public String getCategoryCode()
分類コードを取得します。

戻り値:
分類コード

setCategoryCode

public void setCategoryCode(String categoryCode)
分類コードを設定します。

パラメータ:
categoryCode - 分類コード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyCategoryTerminable (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.category
クラス CompanyCategoryTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable
すべての実装インタフェース:
Serializable
public class CompanyCategoryTerminable
extends Object
implements Serializable

会社組織分類の期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CompanyCategoryTerminable()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyCategoryTerminable

public CompanyCategoryTerminable()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.company.category (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.company.category
クラス
CompanyCategory
CompanyCategoryTerminable


jp.co.intra_mart.foundation.datastore.application.domain.company.category (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.category

会社分類情報を操作するクラスを提供します。

参照:
説明

クラスの概要
CompanyCategory | 会社組織分類の基本属性のデータを取り扱います。
CompanyCategoryTerminable | 会社組織分類の期間化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.category の説明

会社分類情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.company.category クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.category の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.category の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.category の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.category を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.category | 会社分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.category のクラス
CompanyCategory
会社組織分類の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.company.category により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.category のクラス
CompanyCategoryTerminable
会社組織分類の期間化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.category のクラス
CompanyCategory
会社組織分類の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.category のクラス
CompanyCategory
会社組織分類の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener の使用

CompanyChangedListener を使用しているパッケージ
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.access での CompanyChangedListener の使用

CompanyChangedListener を実装している jp.co.intra_mart.foundation.security.access のクラス
 class CompanyChangedControllerListener
会社・組織・役職が削除された場合にアクセスコントローラに紐付く会社・組織・役職を削除するリスナークラスです。

jp.co.intra_mart.foundation.security.menu での CompanyChangedListener の使用

CompanyChangedListener を実装している jp.co.intra_mart.foundation.security.menu のクラス
 class CompanyChangedMenuListener
会社・組織に関する情報の変更時のリスナーです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter の使用

CompanyImporter を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company 会社情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での CompanyImporter の使用

CompanyImporter を実装している jp.co.intra_mart.foundation.datastore.application.domain.company のクラス
 class StandardCompanyImporter
会社のインポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager の使用

CompanyManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company 会社情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での CompanyManager の使用

CompanyManager を返す jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
static CompanyManager CompanyManager.getCompanyManager(String user, String group)
CompanyManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter の使用

CompanyPostImporter を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company 会社情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での CompanyPostImporter の使用

CompanyPostImporter を実装している jp.co.intra_mart.foundation.datastore.application.domain.company のクラス
 class StandardCompanyPostImporter
役職のインポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct の使用

DepartmentStruct を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company 会社情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での DepartmentStruct の使用

DepartmentStruct を返す jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract  DepartmentStruct[] CompanyManager.getDepartmentStructs(String company, String department, Date date, Locale locale)
組織の階層構造を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company の使用

Company を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での Company の使用

Company 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract void | CompanyManager.addCompany(Company company) 会社を登録します。
abstract void | CompanyManager.deleteCompany(Company company) 登録済の会社を削除します。
void | CompanyChangedListener.companyAdded(String groupId, Company company) 会社情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.companyDeleted(String groupId, Company company) 会社情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.access での Company の使用

Company 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | CompanyChangedControllerListener.companyAdded(String groupId, Company company) 会社情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.companyDeleted(String groupId, Company company) 会社情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での Company の使用

Company 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | CompanyChangedMenuListener.companyAdded(String groupId, Company company) 会社情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.companyDeleted(String groupId, Company company) 会社情報がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable の使用

CompanyTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.company 会社情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.company での CompanyTerminable の使用

CompanyTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.company.company のメソッド
CompanyTerminable | Company.getCompanyTerminable(Term term) 指定された期間に対する期間化情報を取得します。
CompanyTerminable | Company.getCompanyTerminable(Date date) 指定された日時に対する期間化情報を取得します。

CompanyTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.company のメソッド
 void Company.putCompanyTerminable(Term term, CompanyTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational の使用

CompanyTerminableInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.company 会社情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.company での CompanyTerminableInternational の使用

CompanyTerminableInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.company.company のメソッド
 CompanyTerminableInternational CompanyTerminable.getCompanyTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。

CompanyTerminableInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.company のメソッド
 void CompanyTerminable.putCompanyTerminableInternational(Locale locale, CompanyTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Company (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.company
クラス Company

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company
すべての実装インタフェース:
Serializable
public class Company
extends Object
implements Serializable

会社の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
Company()
会社に関連する情報を新規に生成します。
Company(Date date)
会社に関連する情報を新規に生成します。
Company(Locale locale)
会社に関連する情報を新規に生成します。
Company(Locale locale, Date date)
会社に関連する情報を新規に生成します。
メソッドの概要
String | getAddress1() 住所1を取得します。
String | getAddress1(Date date) 住所1を取得します。
String | getAddress1(Date date, Locale locale) 住所1を取得します。
String | getAddress1(Locale locale) 住所1を取得します。
String | getAddress2() 住所2を取得します。
String | getAddress2(Date date) 住所2を取得します。
String | getAddress2(Date date, Locale locale) 住所2を取得します。
String | getAddress2(Locale locale) 住所2を取得します。
String | getCompanyCode() 会社コードを取得します。
CompanyTerminable | getCompanyTerminable(Date date) 指定された日時に対する期間化情報を取得します。
CompanyTerminable | getCompanyTerminable(Term term) 指定された期間に対する期間化情報を取得します。
String | getCountryCode() 国コードを取得します。
String | getCountryCode(Date date) 国コードを取得します。
Date | getDefaultDate() デフォルトの日時を取得します。
Locale | getDefaultLocale() デフォルトのロケールを取得します。
String | getEmailAddress1() メールアドレス1を取得します。
String | getEmailAddress1(Date date) メールアドレス1を取得します。
String | getEmailAddress2() メールアドレス2を取得します。
String | getEmailAddress2(Date date) メールアドレス2を取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionFaxNumber(Date date) 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getExtensionNumber(Date date) 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
String | getFaxNumber(Date date) FAX番号を取得します。
String | getName() 組織名を取得します。
String | getName(Date date) 組織名を取得します。
String | getName(Date date, Locale locale) 組織名を取得します。
String | getName(Locale locale) 組織名を取得します。
String | getNameEnglish() 組織名英字を取得します。
String | getNameEnglish(Date date) 組織名英字を取得します。
String | getNameEnglish(Date date, Locale locale) 組織名英字を取得します。
String | getNameEnglish(Locale locale) 組織名英字を取得します。
String | getNameSyllabary() 組織名カナを取得します。
String | getNameSyllabary(Date date) 組織名カナを取得します。
String | getNameSyllabary(Date date, Locale locale) 組織名カナを取得します。
String | getNameSyllabary(Locale locale) 組織名カナを取得します。
String | getNotes() 備考を取得します。
int | getSortKey() ソートキーを取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getTelephoneNumber(Date date) 電話番号を取得します。
Term[] | getTerms() この会社で管理している期間をすべて取得します。
String | getUrl() URLを取得します。
String | getUrl(Date date) URLを取得します。
String | getZipCode() 郵便番号を取得します。
String | getZipCode(Date date) 郵便番号を取得します。
void | putCompanyTerminable(Term term, CompanyTerminable data) 指定された期間に対する期間化情報を設定します。
void | removeCompanyTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setDefaultLocale(Locale defaultLocale) デフォルトのロケールを設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Company

public Company()
会社に関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

Company

public Company(Locale locale)
会社に関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

パラメータ:
locale - デフォルトの言語

Company

public Company(Date date)
会社に関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時

Company

public Company(Locale locale,
               Date date)
会社に関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
locale - デフォルトの言語
date - デフォルトの日時
メソッドの詳細

getDefaultLocale

public Locale getDefaultLocale()
デフォルトのロケールを取得します。

戻り値:
デフォルトのロケール

setDefaultLocale

public void setDefaultLocale(Locale defaultLocale)
デフォルトのロケールを設定します。

パラメータ:
defaultLocale - デフォルトのロケール

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
この会社で管理している期間をすべて取得します。

戻り値:
この会社で管理している期間

getCompanyTerminable

public CompanyTerminable getCompanyTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getCompanyTerminable

public CompanyTerminable getCompanyTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putCompanyTerminable

public void putCompanyTerminable(Term term,
                                 CompanyTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removeCompanyTerminable

public void removeCompanyTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します。

パラメータ:
companyCode - 会社コード

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー

getTelephoneNumber

public String getTelephoneNumber()
電話番号を取得します。

戻り値:
電話番号

getTelephoneNumber

public String getTelephoneNumber(Date date)
電話番号を取得します。

パラメータ:
date - 日時
戻り値:
電話番号

getFaxNumber

public String getFaxNumber()
FAX番号を取得します。

戻り値:
FAX番号

getFaxNumber

public String getFaxNumber(Date date)
FAX番号を取得します。

パラメータ:
date - 日時
戻り値:
FAX番号

getExtensionNumber

public String getExtensionNumber()
内線番号を取得します。

戻り値:
内線番号

getExtensionNumber

public String getExtensionNumber(Date date)
内線番号を取得します。

パラメータ:
date - 日時
戻り値:
内線番号

getExtensionFaxNumber

public String getExtensionFaxNumber()
内線FAX番号を取得します。

戻り値:
内線FAX番号

getExtensionFaxNumber

public String getExtensionFaxNumber(Date date)
内線FAX番号を取得します。

パラメータ:
date - 日時
戻り値:
内線FAX番号

getCountryCode

public String getCountryCode()
国コードを取得します。

戻り値:
国コード

getCountryCode

public String getCountryCode(Date date)
国コードを取得します。

パラメータ:
date - 日時
戻り値:
国コード

getZipCode

public String getZipCode()
郵便番号を取得します。

戻り値:
郵便番号

getZipCode

public String getZipCode(Date date)
郵便番号を取得します。

パラメータ:
date - 日時
戻り値:
郵便番号

getEmailAddress1

public String getEmailAddress1()
メールアドレス1を取得します。

戻り値:
メールアドレス1

getEmailAddress1

public String getEmailAddress1(Date date)
メールアドレス1を取得します。

パラメータ:
date - 日時
戻り値:
メールアドレス1

getEmailAddress2

public String getEmailAddress2()
メールアドレス2を取得します。

戻り値:
メールアドレス2

getEmailAddress2

public String getEmailAddress2(Date date)
メールアドレス2を取得します。

パラメータ:
date - 日時
戻り値:
メールアドレス2

getUrl

public String getUrl()
URLを取得します。

戻り値:
URL

getUrl

public String getUrl(Date date)
URLを取得します。

パラメータ:
date - 日時
戻り値:
URL

getName

public String getName()
組織名を取得します。

戻り値:
組織名

getName

public String getName(Date date)
組織名を取得します。

パラメータ:
date - 日時
戻り値:
組織名

getName

public String getName(Locale locale)
組織名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名

getName

public String getName(Date date,
                      Locale locale)
組織名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
組織名

getNameSyllabary

public String getNameSyllabary()
組織名カナを取得します。

戻り値:
組織名カナ

getNameSyllabary

public String getNameSyllabary(Date date)
組織名カナを取得します。

パラメータ:
date - 日時
戻り値:
組織名カナ

getNameSyllabary

public String getNameSyllabary(Locale locale)
組織名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名カナ

getNameSyllabary

public String getNameSyllabary(Date date,
                               Locale locale)
組織名カナを取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
組織名カナ

getNameEnglish

public String getNameEnglish()
組織名英字を取得します。

戻り値:
組織名英字

getNameEnglish

public String getNameEnglish(Date date)
組織名英字を取得します。

パラメータ:
date - 日時
戻り値:
組織名英字

getNameEnglish

public String getNameEnglish(Locale locale)
組織名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名英字

getNameEnglish

public String getNameEnglish(Date date,
                             Locale locale)
組織名英字を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
組織名英字

getAddress1

public String getAddress1()
住所1を取得します。

戻り値:
住所1

getAddress1

public String getAddress1(Date date)
住所1を取得します。

パラメータ:
date - 日時
戻り値:
住所1

getAddress1

public String getAddress1(Locale locale)
住所1を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所1

getAddress1

public String getAddress1(Date date,
                          Locale locale)
住所1を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
住所1

getAddress2

public String getAddress2()
住所2を取得します。

戻り値:
住所2

getAddress2

public String getAddress2(Date date)
住所2を取得します。

パラメータ:
date - 日時
戻り値:
住所2

getAddress2

public String getAddress2(Locale locale)
住所2を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所2

getAddress2

public String getAddress2(Date date,
                          Locale locale)
住所2を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
住所2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyTerminable (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.company
クラス CompanyTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable
すべての実装インタフェース:
Serializable
public class CompanyTerminable
extends Object
implements Serializable

会社の期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CompanyTerminable()
メソッドの概要
CompanyTerminableInternational | getCompanyTerminableInternational(Locale locale) 指定された言語に対する期間国際化情報を取得します。
String | getCountryCode() 国コードを取得します。
String | getEmailAddress1() メールアドレス1を取得します。
String | getEmailAddress2() メールアドレス2を取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
Locale[] | getLocales() この会社で管理している言語（ロケール）をすべて取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getUrl() URLを取得します。
String | getZipCode() 郵便番号を取得します。
void | putCompanyTerminableInternational(Locale locale, CompanyTerminableInternational data) 指定された言語に対する期間国際化情報を設定します。
void | setCountryCode(String countryCode) 国コードを設定します。
void | setEmailAddress1(String emailAddress1) メールアドレス1を設定します。
void | setEmailAddress2(String emailAddress2) メールアドレス2を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | setFaxNumber(String faxNumber) FAX番号を設定します。
void | setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | setUrl(String url) URLを設定します。
void | setZipCode(String zipCode) 郵便番号を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyTerminable

public CompanyTerminable()
メソッドの詳細

getLocales

public Locale[] getLocales()
この会社で管理している言語（ロケール）をすべて取得します。

戻り値:
この会社で管理している言語（ロケール）

getCompanyTerminableInternational

public CompanyTerminableInternational getCompanyTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
期間国際化情報

putCompanyTerminableInternational

public void putCompanyTerminableInternational(Locale locale,
                                              CompanyTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 期間国際化情報

getTelephoneNumber

public String getTelephoneNumber()
電話番号を取得します。

戻り値:
電話番号

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber)
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号

getFaxNumber

public String getFaxNumber()
FAX番号を取得します。

戻り値:
FAX番号

setFaxNumber

public void setFaxNumber(String faxNumber)
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号

getExtensionNumber

public String getExtensionNumber()
内線番号を取得します。

戻り値:
内線番号

setExtensionNumber

public void setExtensionNumber(String extensionNumber)
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号

getExtensionFaxNumber

public String getExtensionFaxNumber()
内線FAX番号を取得します。

戻り値:
内線FAX番号

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber)
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号

getCountryCode

public String getCountryCode()
国コードを取得します。

戻り値:
国コード

setCountryCode

public void setCountryCode(String countryCode)
国コードを設定します。

パラメータ:
countryCode - 国コード

getZipCode

public String getZipCode()
郵便番号を取得します。

戻り値:
郵便番号

setZipCode

public void setZipCode(String zipCode)
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号

getEmailAddress1

public String getEmailAddress1()
メールアドレス1を取得します。

戻り値:
メールアドレス1

setEmailAddress1

public void setEmailAddress1(String emailAddress1)
メールアドレス1を設定します。

パラメータ:
emailAddress1 - メールアドレス1

getEmailAddress2

public String getEmailAddress2()
メールアドレス2を取得します。

戻り値:
メールアドレス2

setEmailAddress2

public void setEmailAddress2(String emailAddress2)
メールアドレス2を設定します。

パラメータ:
emailAddress2 - メールアドレス2

getUrl

public String getUrl()
URLを取得します。

戻り値:
URL

setUrl

public void setUrl(String url)
URLを設定します。

パラメータ:
url - URL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyTerminableInternational (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.company
クラス CompanyTerminableInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational
すべての実装インタフェース:
Serializable
public class CompanyTerminableInternational
extends Object
implements Serializable

会社の期間国際化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CompanyTerminableInternational()
メソッドの概要
String | getAddress1() 住所1を取得します。
String | getAddress2() 住所2を取得します。
String | getName() 組織名を取得します。
String | getNameEnglish() 組織名英字を取得します。
String | getNameSyllabary() 組織名カナを取得します。
void | setAddress1(String address1) 住所1を設定します。
void | setAddress2(String address2) 住所2を設定します。
void | setName(String name) 組織名を設定します。
void | setNameEnglish(String nameEnglish) 組織名英字を設定します。
void | setNameSyllabary(String nameSyllabary) 組織名カナを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyTerminableInternational

public CompanyTerminableInternational()
メソッドの詳細

getName

public String getName()
組織名を取得します。

戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
組織名を設定します。

パラメータ:
name - 組織名

getNameSyllabary

public String getNameSyllabary()
組織名カナを取得します。

戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ

getNameEnglish

public String getNameEnglish()
組織名英字を取得します。

戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字

getAddress1

public String getAddress1()
住所1を取得します。

戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

setAddress1

public void setAddress1(String address1)
住所1を設定します。

パラメータ:
address1 - 住所1

getAddress2

public String getAddress2()
住所2を取得します。

戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

setAddress2

public void setAddress2(String address2)
住所2を設定します。

パラメータ:
address2 - 住所2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.company.company (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.company.company
クラス
Company
CompanyTerminable
CompanyTerminableInternational


jp.co.intra_mart.foundation.datastore.application.domain.company.company (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.company

会社情報を操作するクラスを提供します。

参照:
説明

クラスの概要
Company | 会社の基本属性のデータを取り扱います。
CompanyTerminable | 会社の期間化属性のデータを取り扱います。
CompanyTerminableInternational | 会社の期間国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.company の説明

会社情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.company.company クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.company の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.company の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.company の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.company を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.company のクラス
Company
会社の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.company.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.company のクラス
CompanyTerminable
会社の期間化属性のデータを取り扱います。
CompanyTerminableInternational
会社の期間国際化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.company のクラス
Company
会社の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.company のクラス
Company
会社の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department の使用

Department を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での Department の使用

Department を返す jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract Department | CompanyManager.getDepartment(String company, String department) 登録済の組織を取得します。
abstract Department[] | CompanyManager.getAttachedDepartments(String user) 現在、ユーザが所属している組織の一覧を取得します。
abstract Department[] | CompanyManager.getAttachedDepartments(String user, Date date) 指定された日付にユーザが所属している組織の一覧を取得します。

Department 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract void | CompanyManager.addDepartment(Department department) 組織を登録します。
abstract void | CompanyManager.updateDepartment(Department department) 登録済の組織情報を更新します。
abstract void | CompanyManager.deleteDepartment(Department department) 登録済の組織情報を削除します。
void | CompanyChangedListener.departmentAdded(String groupId, Department department) 組織情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.departmentUpdated(String groupId, Department department) 組織情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedListener.departmentDeleted(String groupId, Department department) 組織情報がデータストアに更新された後に呼び出されます。

jp.co.intra_mart.foundation.datastore.application.domain.deal での Department の使用

Department を返す jp.co.intra_mart.foundation.datastore.application.domain.deal のメソッド
abstract  Department[] DealPermissionManager.getDepartments(Deal deal)
取扱情報を保有するアクセス権をもつ組織を返します。

jp.co.intra_mart.foundation.security.access での Department の使用

Department 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | CompanyChangedControllerListener.departmentAdded(String groupId, Department department) 組織情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.departmentUpdated(String groupId, Department department) 組織情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedControllerListener.departmentDeleted(String groupId, Department department) 組織情報がデータストアに更新された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での Department の使用

Department 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | CompanyChangedMenuListener.departmentAdded(String groupId, Department department) 組織情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.departmentUpdated(String groupId, Department department) 組織情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedMenuListener.departmentDeleted(String groupId, Department department) 組織情報がデータストアに更新された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable の使用

DepartmentTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.department 組織情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.department での DepartmentTerminable の使用

DepartmentTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.company.department のメソッド
DepartmentTerminable | Department.getDepartmentTerminable(Term term) 指定された期間に対する期間化情報を取得します。
DepartmentTerminable | Department.getDepartmentTerminable(Date date) 指定された日時に対する期間化情報を取得します。

DepartmentTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.department のメソッド
 void Department.putDepartmentTerminable(Term term, DepartmentTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational の使用

DepartmentTerminableInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.department 組織情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.department での DepartmentTerminableInternational の使用

DepartmentTerminableInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.company.department のメソッド
 DepartmentTerminableInternational DepartmentTerminable.getDepartmentTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。

DepartmentTerminableInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.department のメソッド
 void DepartmentTerminable.putDepartmentTerminableInternational(Locale locale, DepartmentTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Department (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.department
クラス Department

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department
すべての実装インタフェース:
Serializable
public class Department
extends Object
implements Serializable

組織の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
Department()
組織に関連する情報を新規に生成します。
Department(Date date)
組織に関連する情報を新規に生成します。
Department(Locale locale)
組織に関連する情報を新規に生成します。
Department(Locale locale, Date date)
組織に関連する情報を新規に生成します。
メソッドの概要
String | getAddress1() 住所1を取得します。
String | getAddress1(Date date) 住所1を取得します。
String | getAddress1(Date date, Locale locale) 住所1を取得します。
String | getAddress1(Locale locale) 住所1を取得します。
String | getAddress2() 住所2を取得します。
String | getAddress2(Date date) 住所2を取得します。
String | getAddress2(Date date, Locale locale) 住所2を取得します。
String | getAddress2(Locale locale) 住所2を取得します。
String | getCompanyCode() 会社コードを取得します。
String | getCountryCode() 国コードを取得します。
String | getCountryCode(Date date) 国コードを取得します。
Date | getDefaultDate() デフォルトの日時を取得します。
Locale | getDefaultLocale() デフォルトのロケールを取得します。
String | getDepartmentCode() 組織コードを取得します。
DepartmentTerminable | getDepartmentTerminable(Date date) 指定された日時に対する期間化情報を取得します。
DepartmentTerminable | getDepartmentTerminable(Term term) 指定された期間に対する期間化情報を取得します。
String | getEmailAddress1() メールアドレス1を取得します。
String | getEmailAddress1(Date date) メールアドレス1を取得します。
String | getEmailAddress2() メールアドレス2を取得します。
String | getEmailAddress2(Date date) メールアドレス2を取得します。
Map | getExtendedDepartment(String name) 指定された拡張情報を取得します。
Map | getExtendedDepartments() この組織の基本情報に対する拡張情報をすべて取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionFaxNumber(Date date) 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getExtensionNumber(Date date) 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
String | getFaxNumber(Date date) FAX番号を取得します。
String | getName() 組織名を取得します。
String | getName(Date date) 組織名を取得します。
String | getName(Date date, Locale locale) 組織名を取得します。
String | getName(Locale locale) 組織名を取得します。
String | getNameEnglish() 組織名英字を取得します。
String | getNameEnglish(Date date) 組織名英字を取得します。
String | getNameEnglish(Date date, Locale locale) 組織名英字を取得します。
String | getNameEnglish(Locale locale) 組織名英字を取得します。
String | getNameSyllabary() 組織名カナを取得します。
String | getNameSyllabary(Date date) 組織名カナを取得します。
String | getNameSyllabary(Date date, Locale locale) 組織名カナを取得します。
String | getNameSyllabary(Locale locale) 組織名カナを取得します。
String | getNotes() 備考を取得します。
int | getSortKey() ソートキーを取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getTelephoneNumber(Date date) 電話番号を取得します。
Term[] | getTerms() この組織で管理している期間をすべて取得します。
String | getUrl() URLを取得します。
String | getUrl(Date date) URLを取得します。
String | getZipCode() 郵便番号を取得します。
String | getZipCode(Date date) 郵便番号を取得します。
void | putDepartmentTerminable(Term term, DepartmentTerminable data) 指定された期間に対する期間化情報を設定します。
void | putExtendedDepartment(String name, Map data) 指定された拡張情報を追加します。
void | removeDepartmentTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setDefaultLocale(Locale defaultLocale) デフォルトのロケールを設定します。
void | setDepartmentCode(String departmentCode) 組織コードを設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Department

public Department()
組織に関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

Department

public Department(Locale locale)
組織に関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

パラメータ:
locale - デフォルトの言語

Department

public Department(Date date)
組織に関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時

Department

public Department(Locale locale,
                  Date date)
組織に関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
locale - デフォルトの言語
date - デフォルトの日時
メソッドの詳細

getDefaultLocale

public Locale getDefaultLocale()
デフォルトのロケールを取得します。

戻り値:
デフォルトのロケール

setDefaultLocale

public void setDefaultLocale(Locale defaultLocale)
デフォルトのロケールを設定します。

パラメータ:
defaultLocale - デフォルトのロケール

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
この組織で管理している期間をすべて取得します。

戻り値:
この組織で管理している期間

getDepartmentTerminable

public DepartmentTerminable getDepartmentTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getDepartmentTerminable

public DepartmentTerminable getDepartmentTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putDepartmentTerminable

public void putDepartmentTerminable(Term term,
                                    DepartmentTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removeDepartmentTerminable

public void removeDepartmentTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getExtendedDepartments

public Map getExtendedDepartments()
この組織の基本情報に対する拡張情報をすべて取得します。 返される値は拡張名をキー、 拡張情報を値とした Mapです。

戻り値:
基本情報に対するすべての拡張情報
導入されたバージョン:
5.1.5

getExtendedDepartment

public Map getExtendedDepartment(String name)
指定された拡張情報を取得します。

パラメータ:
name - 拡張名
戻り値:
基本情報に対する拡張情報
導入されたバージョン:
5.1.5

putExtendedDepartment

public void putExtendedDepartment(String name,
                                  Map data)
指定された拡張情報を追加します。 返される値は属性名をキー、 属性値を値とした Mapです。

パラメータ:
name - 拡張名
data - 基本情報に対する拡張情報
導入されたバージョン:
5.1.5

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します。

パラメータ:
companyCode - 会社コード

getDepartmentCode

public String getDepartmentCode()
組織コードを取得します。

戻り値:
組織コード

setDepartmentCode

public void setDepartmentCode(String departmentCode)
組織コードを設定します。

パラメータ:
departmentCode - 組織コード

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー

getTelephoneNumber

public String getTelephoneNumber()
電話番号を取得します。

戻り値:
電話番号

getTelephoneNumber

public String getTelephoneNumber(Date date)
電話番号を取得します。

パラメータ:
date - 日時
戻り値:
電話番号

getFaxNumber

public String getFaxNumber()
FAX番号を取得します。

戻り値:
FAX番号

getFaxNumber

public String getFaxNumber(Date date)
FAX番号を取得します。

パラメータ:
date - 日時
戻り値:
FAX番号

getExtensionNumber

public String getExtensionNumber()
内線番号を取得します。

戻り値:
内線番号

getExtensionNumber

public String getExtensionNumber(Date date)
内線番号を取得します。

パラメータ:
date - 日時
戻り値:
内線番号

getExtensionFaxNumber

public String getExtensionFaxNumber()
内線FAX番号を取得します。

戻り値:
内線FAX番号

getExtensionFaxNumber

public String getExtensionFaxNumber(Date date)
内線FAX番号を取得します。

パラメータ:
date - 日時
戻り値:
内線FAX番号

getCountryCode

public String getCountryCode()
国コードを取得します。

戻り値:
国コード

getCountryCode

public String getCountryCode(Date date)
国コードを取得します。

パラメータ:
date - 日時
戻り値:
国コード

getZipCode

public String getZipCode()
郵便番号を取得します。

戻り値:
郵便番号

getZipCode

public String getZipCode(Date date)
郵便番号を取得します。

パラメータ:
date - 日時
戻り値:
郵便番号

getEmailAddress1

public String getEmailAddress1()
メールアドレス1を取得します。

戻り値:
メールアドレス1

getEmailAddress1

public String getEmailAddress1(Date date)
メールアドレス1を取得します。

パラメータ:
date - 日時
戻り値:
メールアドレス1

getEmailAddress2

public String getEmailAddress2()
メールアドレス2を取得します。

戻り値:
メールアドレス2

getEmailAddress2

public String getEmailAddress2(Date date)
メールアドレス2を取得します。

パラメータ:
date - 日時
戻り値:
メールアドレス2

getUrl

public String getUrl()
URLを取得します。

戻り値:
URL

getUrl

public String getUrl(Date date)
URLを取得します。

パラメータ:
date - 日時
戻り値:
URL

getName

public String getName()
組織名を取得します。

戻り値:
組織名

getName

public String getName(Date date)
組織名を取得します。

パラメータ:
date - 日時
戻り値:
組織名

getName

public String getName(Locale locale)
組織名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名

getName

public String getName(Date date,
                      Locale locale)
組織名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
組織名

getNameSyllabary

public String getNameSyllabary()
組織名カナを取得します。

戻り値:
組織名カナ

getNameSyllabary

public String getNameSyllabary(Date date)
組織名カナを取得します。

パラメータ:
date - 日時
戻り値:
組織名カナ

getNameSyllabary

public String getNameSyllabary(Locale locale)
組織名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名カナ

getNameSyllabary

public String getNameSyllabary(Date date,
                               Locale locale)
組織名カナを取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
組織名カナ

getNameEnglish

public String getNameEnglish()
組織名英字を取得します。

戻り値:
組織名英字

getNameEnglish

public String getNameEnglish(Date date)
組織名英字を取得します。

パラメータ:
date - 日時
戻り値:
組織名英字

getNameEnglish

public String getNameEnglish(Locale locale)
組織名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名英字

getNameEnglish

public String getNameEnglish(Date date,
                             Locale locale)
組織名英字を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
組織名英字

getAddress1

public String getAddress1()
住所1を取得します。

戻り値:
住所1

getAddress1

public String getAddress1(Date date)
住所1を取得します。

パラメータ:
date - 日時
戻り値:
住所1

getAddress1

public String getAddress1(Locale locale)
住所1を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所1

getAddress1

public String getAddress1(Date date,
                          Locale locale)
住所1を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
住所1

getAddress2

public String getAddress2()
住所2を取得します。

戻り値:
住所2

getAddress2

public String getAddress2(Date date)
住所2を取得します。

パラメータ:
date - 日時
戻り値:
住所2

getAddress2

public String getAddress2(Locale locale)
住所2を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所2

getAddress2

public String getAddress2(Date date,
                          Locale locale)
住所2を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
住所2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DepartmentTerminable (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.department
クラス DepartmentTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable
すべての実装インタフェース:
Serializable
public class DepartmentTerminable
extends Object
implements Serializable

組織の期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DepartmentTerminable()
メソッドの概要
String | getCountryCode() 国コードを取得します。
DepartmentTerminableInternational | getDepartmentTerminableInternational(Locale locale) 指定された言語に対する期間国際化情報を取得します。
String | getEmailAddress1() メールアドレス1を取得します。
String | getEmailAddress2() メールアドレス2を取得します。
Map | getExtendedDepartmentTerminable(String name) 指定された拡張情報を取得します。
Map | getExtendedDepartmentTerminables() この組織の期間化情報に対する拡張情報をすべて取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
Locale[] | getLocales() この組織で管理している言語（ロケール）をすべて取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getUrl() URLを取得します。
String | getZipCode() 郵便番号を取得します。
void | putDepartmentTerminableInternational(Locale locale, DepartmentTerminableInternational data) 指定された言語に対する期間国際化情報を設定します。
void | putExtendedDepartmentTerminable(String name, Map data) 指定された拡張情報を追加します。
void | setCountryCode(String countryCode) 国コードを設定します。
void | setEmailAddress1(String emailAddress1) メールアドレス1を設定します。
void | setEmailAddress2(String emailAddress2) メールアドレス2を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | setFaxNumber(String faxNumber) FAX番号を設定します。
void | setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | setUrl(String url) URLを設定します。
void | setZipCode(String zipCode) 郵便番号を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DepartmentTerminable

public DepartmentTerminable()
メソッドの詳細

getLocales

public Locale[] getLocales()
この組織で管理している言語（ロケール）をすべて取得します。

戻り値:
この組織で管理している言語（ロケール）

getDepartmentTerminableInternational

public DepartmentTerminableInternational getDepartmentTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
期間国際化情報

putDepartmentTerminableInternational

public void putDepartmentTerminableInternational(Locale locale,
                                                 DepartmentTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 期間国際化情報

getExtendedDepartmentTerminables

public Map getExtendedDepartmentTerminables()
この組織の期間化情報に対する拡張情報をすべて取得します。 返される値は拡張名をキー、 拡張情報を値とした Mapです。

戻り値:
期間化情報に対するすべての拡張情報
導入されたバージョン:
5.1.5

getExtendedDepartmentTerminable

public Map getExtendedDepartmentTerminable(String name)
指定された拡張情報を取得します。 返される値は属性名をキー、 属性値を値とした Mapです。

パラメータ:
name - 拡張名
戻り値:
期間化情報に対する拡張情報
導入されたバージョン:
5.1.5

putExtendedDepartmentTerminable

public void putExtendedDepartmentTerminable(String name,
                                            Map data)
指定された拡張情報を追加します。

パラメータ:
name - 拡張名
data - 期間化情報に対する拡張情報
導入されたバージョン:
5.1.5

getTelephoneNumber

public String getTelephoneNumber()
電話番号を取得します。

戻り値:
電話番号

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber)
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号

getFaxNumber

public String getFaxNumber()
FAX番号を取得します。

戻り値:
FAX番号

setFaxNumber

public void setFaxNumber(String faxNumber)
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号

getExtensionNumber

public String getExtensionNumber()
内線番号を取得します。

戻り値:
内線番号

setExtensionNumber

public void setExtensionNumber(String extensionNumber)
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号

getExtensionFaxNumber

public String getExtensionFaxNumber()
内線FAX番号を取得します。

戻り値:
内線FAX番号

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber)
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号

getCountryCode

public String getCountryCode()
国コードを取得します。

戻り値:
国コード

setCountryCode

public void setCountryCode(String countryCode)
国コードを設定します。

パラメータ:
countryCode - 国コード

getZipCode

public String getZipCode()
郵便番号を取得します。

戻り値:
郵便番号

setZipCode

public void setZipCode(String zipCode)
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号

getEmailAddress1

public String getEmailAddress1()
メールアドレス1を取得します。

戻り値:
メールアドレス1

setEmailAddress1

public void setEmailAddress1(String emailAddress1)
メールアドレス1を設定します。

パラメータ:
emailAddress1 - メールアドレス1

getEmailAddress2

public String getEmailAddress2()
メールアドレス2を取得します。

戻り値:
メールアドレス2

setEmailAddress2

public void setEmailAddress2(String emailAddress2)
メールアドレス2を設定します。

パラメータ:
emailAddress2 - メールアドレス2

getUrl

public String getUrl()
URLを取得します。

戻り値:
URL

setUrl

public void setUrl(String url)
URLを設定します。

パラメータ:
url - URL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DepartmentTerminableInternational (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.department
クラス DepartmentTerminableInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational
すべての実装インタフェース:
Serializable
public class DepartmentTerminableInternational
extends Object
implements Serializable

組織の期間国際化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DepartmentTerminableInternational()
メソッドの概要
String | getAddress1() 住所1を取得します。
String | getAddress2() 住所2を取得します。
Map | getExtendedDepartmentTerminableInternational(String name) 指定された拡張情報を取得します。
Map | getExtendedDepartmentTerminableInternationals() この組織の基本情報に対する拡張情報をすべて取得します。
String | getName() 組織名を取得します。
String | getNameEnglish() 組織名英字を取得します。
String | getNameSyllabary() 組織名カナを取得します。
void | putExtendedDepartmentTerminableInternational(String name, Map data) 指定された拡張情報を追加します。
void | setAddress1(String address1) 住所1を設定します。
void | setAddress2(String address2) 住所2を設定します。
void | setName(String name) 組織名を設定します。
void | setNameEnglish(String nameEnglish) 組織名英字を設定します。
void | setNameSyllabary(String nameSyllabary) 組織名カナを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DepartmentTerminableInternational

public DepartmentTerminableInternational()
メソッドの詳細

getExtendedDepartmentTerminableInternationals

public Map getExtendedDepartmentTerminableInternationals()
この組織の基本情報に対する拡張情報をすべて取得します。 返される値は拡張名をキー、 拡張情報を値とした Mapです。

戻り値:
期間国際化情報に対するすべての拡張情報
導入されたバージョン:
5.1.5

getExtendedDepartmentTerminableInternational

public Map getExtendedDepartmentTerminableInternational(String name)
指定された拡張情報を取得します。 返される値は属性名をキー、 属性値を値とした Mapです。

パラメータ:
name - 拡張名
戻り値:
期間国際化情報に対する拡張情報
導入されたバージョン:
5.1.5

putExtendedDepartmentTerminableInternational

public void putExtendedDepartmentTerminableInternational(String name,
                                                         Map data)
指定された拡張情報を追加します。

パラメータ:
name - 拡張名
data - 期間国際化情報に対する拡張情報
導入されたバージョン:
5.1.5

getName

public String getName()
組織名を取得します。

戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
組織名を設定します。

パラメータ:
name - 組織名

getNameSyllabary

public String getNameSyllabary()
組織名カナを取得します。

戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ

getNameEnglish

public String getNameEnglish()
組織名英字を取得します。

戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字

getAddress1

public String getAddress1()
住所1を取得します。

戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

setAddress1

public void setAddress1(String address1)
住所1を設定します。

パラメータ:
address1 - 住所1

getAddress2

public String getAddress2()
住所2を取得します。

戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

setAddress2

public void setAddress2(String address2)
住所2を設定します。

パラメータ:
address2 - 住所2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.company.department (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.company.department
クラス
Department
DepartmentTerminable
DepartmentTerminableInternational


jp.co.intra_mart.foundation.datastore.application.domain.company.department (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.department

組織情報を操作するクラスを提供します。

参照:
説明

クラスの概要
Department | 組織の基本属性のデータを取り扱います。
DepartmentTerminable | 組織の期間化属性のデータを取り扱います。
DepartmentTerminableInternational | 組織の期間国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.department の説明

組織情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.company.department クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.department の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.department の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.department の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.department を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.department | 組織情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.department のクラス
Department
組織の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.company.department により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.department のクラス
DepartmentTerminable
組織の期間化属性のデータを取り扱います。
DepartmentTerminableInternational
組織の期間国際化属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.deal により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.department のクラス
Department
組織の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.department のクラス
Department
組織の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.department のクラス
Department
組織の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain の使用

DepartmentMain を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での DepartmentMain の使用

DepartmentMain を返す jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract  DepartmentMain CompanyManager.getDepartmentMain(String user)
ユーザの主所属情報を取得します。

DepartmentMain 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract void | CompanyManager.setMain(DepartmentMain main) ユーザが主所属する組織を設定します。
abstract void | CompanyManager.removeMain(DepartmentMain main) 指定されたユーザの主所属を削除します。
void | CompanyChangedListener.mainSet(String groupId, DepartmentMain main) 主所属情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.mainRemoved(String groupId, DepartmentMain main) 主所属情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.access での DepartmentMain の使用

DepartmentMain 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | CompanyChangedControllerListener.mainSet(String groupId, DepartmentMain main) 主所属情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.mainRemoved(String groupId, DepartmentMain main) 主所属情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での DepartmentMain の使用

DepartmentMain 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | CompanyChangedMenuListener.mainSet(String groupId, DepartmentMain main) 主所属情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.mainRemoved(String groupId, DepartmentMain main) 主所属情報がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable の使用

DepartmentMainTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.main 主所属情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.main での DepartmentMainTerminable の使用

DepartmentMainTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.company.main のメソッド
DepartmentMainTerminable | DepartmentMain.getDepartmentMainTerminable(Term term) 指定された期間に対する期間化情報を取得します。
DepartmentMainTerminable | DepartmentMain.getDepartmentMainTerminable(Date date) 指定された日時に対する期間化情報を取得します。

DepartmentMainTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.main のメソッド
 void DepartmentMain.putDepartmentMainTerminable(Term term, DepartmentMainTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DepartmentMain (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.main
クラス DepartmentMain

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain
すべての実装インタフェース:
Serializable
public class DepartmentMain
extends Object
implements Serializable

主所属の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DepartmentMain()
主所属に関連する情報を新規に生成します。
DepartmentMain(Date date)
主所属に関連する情報を新規に生成します。
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getCompanyCode(Date date) 会社コードを取得します。
Date | getDefaultDate() デフォルトの日時を取得します。
String | getDepartmentCode() 組織コードを取得します。
String | getDepartmentCode(Date date) 組織コードを取得します。
DepartmentMainTerminable | getDepartmentMainTerminable(Date date) 指定された日時に対する期間化情報を取得します。
DepartmentMainTerminable | getDepartmentMainTerminable(Term term) 指定された期間に対する期間化情報を取得します。
Term[] | getTerms() この主所属で管理している期間をすべて取得します。
String | getUserCode() ユーザコードを取得します。
void | putDepartmentMainTerminable(Term term, DepartmentMainTerminable data) 指定された期間に対する期間化情報を設定します。
void | removeDepartmentMainTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setUserCode(String userCode) ユーザコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DepartmentMain

public DepartmentMain()
主所属に関連する情報を新規に生成します。 デフォルトの日時には現在のシステム日時が割り当てられます。

DepartmentMain

public DepartmentMain(Date date)
主所属に関連する情報を新規に生成します。 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時
メソッドの詳細

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
この主所属で管理している期間をすべて取得します。

戻り値:
この主所属で管理している期間

getDepartmentMainTerminable

public DepartmentMainTerminable getDepartmentMainTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getDepartmentMainTerminable

public DepartmentMainTerminable getDepartmentMainTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putDepartmentMainTerminable

public void putDepartmentMainTerminable(Term term,
                                        DepartmentMainTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removeDepartmentMainTerminable

public void removeDepartmentMainTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getUserCode

public String getUserCode()
ユーザコードを取得します。

戻り値:
ユーザコード

setUserCode

public void setUserCode(String userCode)
ユーザコードを設定します。

パラメータ:
userCode - ユーザコード

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

getCompanyCode

public String getCompanyCode(Date date)
会社コードを取得します。

パラメータ:
date - 日時
戻り値:
会社コード

getDepartmentCode

public String getDepartmentCode()
組織コードを取得します。

戻り値:
組織コード

getDepartmentCode

public String getDepartmentCode(Date date)
組織コードを取得します。

パラメータ:
date - 日時
戻り値:
組織コード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DepartmentMainTerminable (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.main
クラス DepartmentMainTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable
すべての実装インタフェース:
Serializable
public class DepartmentMainTerminable
extends Object
implements Serializable

主所属の期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DepartmentMainTerminable()
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setDepartmentCode(String departmentCode) 組織コードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DepartmentMainTerminable

public DepartmentMainTerminable()
メソッドの詳細

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します。

パラメータ:
companyCode - 会社コード

getDepartmentCode

public String getDepartmentCode()
組織コードを取得します。

戻り値:
組織コード

setDepartmentCode

public void setDepartmentCode(String departmentCode)
組織コードを設定します。

パラメータ:
departmentCode - 組織コード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.company.main (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.company.main
クラス
DepartmentMain
DepartmentMainTerminable


jp.co.intra_mart.foundation.datastore.application.domain.company.main (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.main

主所属情報を操作するクラスを提供します。

参照:
説明

クラスの概要
DepartmentMain | 主所属の基本属性のデータを取り扱います。
DepartmentMainTerminable | 主所属の期間化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.main の説明

主所属情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.company.main クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.main の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.main の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.main の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.main を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.main | 主所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.main のクラス
DepartmentMain
主所属の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.company.main により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.main のクラス
DepartmentMainTerminable
主所属の期間化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.main のクラス
DepartmentMain
主所属の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.main のクラス
DepartmentMain
主所属の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost の使用

CompanyPost を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での CompanyPost の使用

CompanyPost 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract void | CompanyManager.addPost(CompanyPost post) 役職を登録します。
abstract void | CompanyManager.updatePost(CompanyPost post) 登録済の役職情報を更新します。
abstract void | CompanyManager.deletePost(CompanyPost post) 登録済の役職情報を削除します。
void | CompanyChangedListener.postAdded(String groupId, CompanyPost post) 役職情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.postUpdated(String groupId, CompanyPost post) 役職情報がデータストアに更新された後に呼び出されます。
void | CompanyChangedListener.postDeleted(String groupId, CompanyPost post) 役職情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.access での CompanyPost の使用

CompanyPost 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | CompanyChangedControllerListener.postAdded(String groupId, CompanyPost post) 役職情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.postUpdated(String groupId, CompanyPost post) 役職情報がデータストアに更新された後に呼び出されます。
void | CompanyChangedControllerListener.postDeleted(String groupId, CompanyPost post) 役職情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での CompanyPost の使用

CompanyPost 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | CompanyChangedMenuListener.postAdded(String groupId, CompanyPost post) 役職情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.postUpdated(String groupId, CompanyPost post) 役職情報がデータストアに更新された後に呼び出されます。
void | CompanyChangedMenuListener.postDeleted(String groupId, CompanyPost post) 役職情報がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable の使用

CompanyPostTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.post 役職情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.post での CompanyPostTerminable の使用

CompanyPostTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.company.post のメソッド
CompanyPostTerminable | CompanyPost.getCompanyPostTerminable(Term term) 指定された期間に対する期間化情報を取得します。
CompanyPostTerminable | CompanyPost.getCompanyPostTerminable(Date date) 指定された日時に対する期間化情報を取得します。

CompanyPostTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.post のメソッド
 void CompanyPost.putCompanyPostTerminable(Term term, CompanyPostTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational の使用

CompanyPostTerminableInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.post 役職情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.post での CompanyPostTerminableInternational の使用

CompanyPostTerminableInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.company.post のメソッド
 CompanyPostTerminableInternational CompanyPostTerminable.getCompanyPostTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。

CompanyPostTerminableInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.post のメソッド
 void CompanyPostTerminable.putCompanyPostTerminableInternational(Locale locale, CompanyPostTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost の使用

PlainCompanyPost を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company 会社情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での PlainCompanyPost の使用

PlainCompanyPost を返す jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract PlainCompanyPost[] | CompanyManager.getPostsInCompany(String company) 会社に登録済の役職をすべて取得します。
abstract PlainCompanyPost[] | CompanyManager.getPostsInCompany(String company, Date date) 会社に登録済の役職をすべて取得します。
abstract PlainCompanyPost[] | CompanyManager.getPostsInCompany(String company, Locale locale) 会社に登録済の役職をすべて取得します。
abstract PlainCompanyPost[] | CompanyManager.getPostsInCompany(String company, Date date, Locale locale) 会社に登録済の役職をすべて取得します。
abstract PlainCompanyPost[] | CompanyManager.getPostsOfUser(String company, String user) ユーザに設定された役職をすべて取得します。
abstract PlainCompanyPost[] | CompanyManager.getPostsOfUser(String company, String user, Date date) ユーザに設定された役職をすべて取得します。
abstract PlainCompanyPost[] | CompanyManager.getPostsOfUser(String company, String user, Locale locale) ユーザに設定された役職をすべて取得します。
abstract PlainCompanyPost[] | CompanyManager.getPostsOfUser(String company, String user, Date date, Locale locale) ユーザに設定された役職をすべて取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CompanyPost (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.post
クラス CompanyPost

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost
すべての実装インタフェース:
Serializable
public class CompanyPost
extends Object
implements Serializable

役職の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CompanyPost()
役職に関連する情報を新規に生成します。
CompanyPost(Date date)
役職に関連する情報を新規に生成します。
CompanyPost(Locale locale)
役職に関連する情報を新規に生成します。
CompanyPost(Locale locale, Date date)
役職に関連する情報を新規に生成します。
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
CompanyPostTerminable | getCompanyPostTerminable(Date date) 指定された日時に対する期間化情報を取得します。
CompanyPostTerminable | getCompanyPostTerminable(Term term) 指定された期間に対する期間化情報を取得します。
Date | getDefaultDate() デフォルトの日時を取得します。
Locale | getDefaultLocale() デフォルトのロケールを取得します。
String | getName() 役職名を取得します。
String | getName(Date date) 役職名を取得します。
String | getName(Date date, Locale locale) 役職名を取得します。
String | getName(Locale locale) 役職名を取得します。
String | getNotes() 備考を取得します。
String | getPostCode() 役職コードを取得します。
int | getSortKey() ソートキーを取得します。
Term[] | getTerms() この役職で管理している期間をすべて取得します。
void | putCompanyPostTerminable(Term term, CompanyPostTerminable data) 指定された期間に対する期間化情報を設定します。
void | removeCompanyPostTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setDefaultLocale(Locale defaultLocale) デフォルトのロケールを設定します。
void | setNotes(String notes) 備考を設定します。
void | setPostCode(String postCode) 役職コードを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyPost

public CompanyPost()
役職に関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

CompanyPost

public CompanyPost(Locale locale)
役職に関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

パラメータ:
locale - デフォルトの言語

CompanyPost

public CompanyPost(Date date)
役職に関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時

CompanyPost

public CompanyPost(Locale locale,
                   Date date)
役職に関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
locale - デフォルトの言語
date - デフォルトの日時
メソッドの詳細

getDefaultLocale

public Locale getDefaultLocale()
デフォルトのロケールを取得します。

戻り値:
デフォルトのロケール

setDefaultLocale

public void setDefaultLocale(Locale defaultLocale)
デフォルトのロケールを設定します。

パラメータ:
defaultLocale - デフォルトのロケール

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
この役職で管理している期間をすべて取得します。

戻り値:
この役職で管理している期間

getCompanyPostTerminable

public CompanyPostTerminable getCompanyPostTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getCompanyPostTerminable

public CompanyPostTerminable getCompanyPostTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putCompanyPostTerminable

public void putCompanyPostTerminable(Term term,
                                     CompanyPostTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removeCompanyPostTerminable

public void removeCompanyPostTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します。

パラメータ:
companyCode - 会社コード

getPostCode

public String getPostCode()
役職コードを取得します。

戻り値:
役職コード

setPostCode

public void setPostCode(String postCode)
役職コードを設定します。

パラメータ:
postCode - 役職コード

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー

getName

public String getName()
役職名を取得します。

戻り値:
役職名

getName

public String getName(Date date)
役職名を取得します。

パラメータ:
date - 日時
戻り値:
役職名

getName

public String getName(Locale locale)
役職名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
役職名

getName

public String getName(Date date,
                      Locale locale)
役職名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
役職名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyPostTerminable (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.post
クラス CompanyPostTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable
すべての実装インタフェース:
Serializable
public class CompanyPostTerminable
extends Object
implements Serializable

役職の期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CompanyPostTerminable()
メソッドの概要
CompanyPostTerminableInternational | getCompanyPostTerminableInternational(Locale locale) 指定された言語に対する期間国際化情報を取得します。
Locale[] | getLocales() この役職で管理している言語（ロケール）をすべて取得します。
void | putCompanyPostTerminableInternational(Locale locale, CompanyPostTerminableInternational data) 指定された言語に対する期間国際化情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyPostTerminable

public CompanyPostTerminable()
メソッドの詳細

getLocales

public Locale[] getLocales()
この役職で管理している言語（ロケール）をすべて取得します。

戻り値:
この役職で管理している言語（ロケール）

getCompanyPostTerminableInternational

public CompanyPostTerminableInternational getCompanyPostTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
期間国際化情報

putCompanyPostTerminableInternational

public void putCompanyPostTerminableInternational(Locale locale,
                                                  CompanyPostTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 期間国際化情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyPostTerminableInternational (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.post
クラス CompanyPostTerminableInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational
すべての実装インタフェース:
Serializable
public class CompanyPostTerminableInternational
extends Object
implements Serializable

役職の期間国際化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CompanyPostTerminableInternational()
メソッドの概要
String | getName() 役職名を取得します。
void | setName(String name) 役職名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyPostTerminableInternational

public CompanyPostTerminableInternational()
メソッドの詳細

getName

public String getName()
役職名を取得します。

戻り値:
役職名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
役職名を設定します。

パラメータ:
name - 役職名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.company.post (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.company.post
インタフェース
PlainCompanyPost
クラス
CompanyPost
CompanyPostTerminable
CompanyPostTerminableInternational


jp.co.intra_mart.foundation.datastore.application.domain.company.post (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.post

役職情報を操作するクラスを提供します。

参照:
説明

インタフェースの概要
PlainCompanyPost 役職データを扱います。

クラスの概要
CompanyPost | 役職の基本属性のデータを取り扱います。
CompanyPostTerminable | 役職の期間化属性のデータを取り扱います。
CompanyPostTerminableInternational | 役職の期間国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.post の説明

役職情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.company.post クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.post の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational (implements java.io.Serializable)

インタフェース階層

  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.post の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.post の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.post を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.post | 役職情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.post のクラス
CompanyPost
役職の基本属性のデータを取り扱います。
PlainCompanyPost
役職データを扱います。

jp.co.intra_mart.foundation.datastore.application.domain.company.post により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.post のクラス
CompanyPostTerminable
役職の期間化属性のデータを取り扱います。
CompanyPostTerminableInternational
役職の期間国際化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.post のクラス
CompanyPost
役職の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.post のクラス
CompanyPost
役職の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PlainCompanyPost (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.post
インタフェース PlainCompanyPost

すべてのスーパーインタフェース:
Serializable
public interface PlainCompanyPost
extends Serializable

役職データを扱います。

導入されたバージョン:
5.0

メソッドの概要
Date | getActivationDate() 役職情報の有効開始日を取得します。
String | getCompanyCode() 会社コードを取得します。
Date | getExpirationDate() 役職情報の有効終了日を取得します。
Locale | getLocale() 役職名の言語を取得します。
String | getNotes() 備考を取得します。
String | getPostCode() 役職コードを取得します。
String | getPostName() 役職名を取得します。
int | getSortKey() ソートキーを取得します。

メソッドの詳細

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

getPostCode

public String getPostCode()
役職コードを取得します。

戻り値:
役職コード

getPostName

public String getPostName()
役職名を取得します。

戻り値:
役職名

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

getActivationDate

public Date getActivationDate()
役職情報の有効開始日を取得します。

戻り値:
有効開始日

getExpirationDate

public Date getExpirationDate()
役職情報の有効終了日を取得します。

戻り値:
有効終了日

getLocale

public Locale getLocale()
役職名の言語を取得します。

戻り値:
言語
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion の使用

CompanyVersion を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での CompanyVersion の使用

CompanyVersion を返す jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract CompanyVersion | CompanyManager.getVersion(String company) 現在の会社構成バージョン情報を取得します。
abstract CompanyVersion | CompanyManager.getVersion(String company, Date date) 指定された日付の会社構成バージョン情報を取得します。

CompanyVersion 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract void | CompanyManager.addVersion(CompanyVersion version) 会社構成バージョンを新規に登録します。
abstract void | CompanyManager.updateVersion(CompanyVersion version) 登録済の会社構成バージョンを更新します。
abstract void | CompanyManager.deleteVersion(CompanyVersion version) 登録済の会社構成バージョンを削除します。
void | CompanyChangedListener.versionAdded(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.versionUpdated(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに更新された後に呼び出されます。
void | CompanyChangedListener.versionDeleted(String groupId, CompanyVersion version) 会社構成バージョンがデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.access での CompanyVersion の使用

CompanyVersion 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | CompanyChangedControllerListener.versionAdded(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.versionUpdated(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに更新された後に呼び出されます。
void | CompanyChangedControllerListener.versionDeleted(String groupId, CompanyVersion version) 会社構成バージョンがデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での CompanyVersion の使用

CompanyVersion 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | CompanyChangedMenuListener.versionAdded(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.versionUpdated(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに更新された後に呼び出されます。
void | CompanyChangedMenuListener.versionDeleted(String groupId, CompanyVersion version) 会社構成バージョンがデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CompanyVersion (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.version
クラス CompanyVersion

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion
すべての実装インタフェース:
Serializable
public class CompanyVersion
extends Object
implements Serializable

会社構成バージョンの基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CompanyVersion()
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
Date | getEndDate() 終了日を取得します。
String | getNotes() 備考を取得します。
Date | getStartDate() 開始日を取得します。
String | getVersionCode() バージョンコードを取得します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setEndDate(Date endDate) 終了日を設定します。
void | setNotes(String notes) 備考を設定します。
void | setStartDate(Date startDate) 開始日を設定します。
void | setVersionCode(String versionCode) バージョンコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyVersion

public CompanyVersion()
メソッドの詳細

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します。

パラメータ:
companyCode - 会社コード

getVersionCode

public String getVersionCode()
バージョンコードを取得します。

戻り値:
バージョンコード

setVersionCode

public void setVersionCode(String versionCode)
バージョンコードを設定します。

パラメータ:
versionCode - バージョンコード

getStartDate

public Date getStartDate()
開始日を取得します。

戻り値:
開始日

setStartDate

public void setStartDate(Date startDate)
開始日を設定します。

パラメータ:
startDate - 開始日

getEndDate

public Date getEndDate()
終了日を取得します。

戻り値:
終了日

setEndDate

public void setEndDate(Date endDate)
終了日を設定します。

パラメータ:
endDate - 終了日

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.company.version (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.company.version
クラス
CompanyVersion


jp.co.intra_mart.foundation.datastore.application.domain.company.version (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.version

バーション情報を操作するクラスを提供します。

参照:
説明

クラスの概要
CompanyVersion 会社構成バージョンの基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.version の説明

バーション情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.company.version クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.version の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.version の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.version の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.version を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.version のクラス
CompanyVersion
会社構成バージョンの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.version のクラス
CompanyVersion
会社構成バージョンの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.version のクラス
CompanyVersion
会社構成バージョンの基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CompanyChangedListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company
インタフェース CompanyChangedListener

既知の実装クラスの一覧:
CompanyChangedControllerListener, CompanyChangedMenuListener
public interface CompanyChangedListener

会社・組織に関する情報の変更時のリスナーです。

導入されたバージョン:
5.0

メソッドの概要
void | categoryDetailRemoved(String groupId, CompanyCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | categoryDetailSet(String groupId, CompanyCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | companyAdded(String groupId, Company company) 会社情報がデータストアに登録された後に呼び出されます。
void | companyDeleted(String groupId, Company company) 会社情報がデータストアから削除された後に呼び出されます。
void | departmentAdded(String groupId, Department department) 組織情報がデータストアに登録された後に呼び出されます。
void | departmentDeleted(String groupId, Department department) 組織情報がデータストアに更新された後に呼び出されます。
void | departmentJoined(String groupId, String company, String parentDepartment, String department, String version) 組織構成がデータストアに登録された後に呼び出されます。
void | departmentLeft(String groupId, String company, String department, String version) 組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
void | departmentMoved(String groupId, String company, String parentDepartment, String department, String version) 組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
void | departmentUpdated(String groupId, Department department) 組織情報がデータストアから削除された後に呼び出されます。
void | init(Map params) 会社リスナーの初期化を行います。
void | mainRemoved(String groupId, DepartmentMain main) 主所属情報がデータストアから削除された後に呼び出されます。
void | mainSet(String groupId, DepartmentMain main) 主所属情報がデータストアに登録された後に呼び出されます。
void | memberDeleted(String groupId, DepartmentAttach attach) 組織からの人員の割当がデータストアから削除された後に呼び出されます。
void | memberSet(String groupId, DepartmentAttach attach) 組織への人員の割当がデータストアに登録された後に呼び出されます。
void | postAdded(String groupId, CompanyPost post) 役職情報がデータストアに登録された後に呼び出されます。
void | postDeleted(String groupId, CompanyPost post) 役職情報がデータストアから削除された後に呼び出されます。
void | postUpdated(String groupId, CompanyPost post) 役職情報がデータストアに更新された後に呼び出されます。
void | setUserId(String userId) ログインユーザIDを設定します。
void | versionAdded(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに登録された後に呼び出されます。
void | versionCopied(String groupId, String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
void | versionDeleted(String groupId, CompanyVersion version) 会社構成バージョンがデータストアから削除された後に呼び出されます。
void | versionUpdated(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに更新された後に呼び出されます。

メソッドの詳細

init

public void init(Map params)
会社リスナーの初期化を行います。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

パラメータ:
params - 初期化パラメータのマップ(Map)

setUserId

public void setUserId(String userId)
ログインユーザIDを設定します。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

パラメータ:
userId - ログインユーザID

companyAdded

public void companyAdded(String groupId,
                         Company company)
                  throws ChangedListenerException
会社情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
company - 会社情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

companyDeleted

public void companyDeleted(String groupId,
                           Company company)
                    throws ChangedListenerException
会社情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
company - 会社情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentAdded

public void departmentAdded(String groupId,
                            Department department)
                     throws ChangedListenerException
組織情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentUpdated

public void departmentUpdated(String groupId,
                              Department department)
                       throws ChangedListenerException
組織情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentDeleted

public void departmentDeleted(String groupId,
                              Department department)
                       throws ChangedListenerException
組織情報がデータストアに更新された後に呼び出されます。

パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentJoined

public void departmentJoined(String groupId,
                             String company,
                             String parentDepartment,
                             String department,
                             String version)
                      throws ChangedListenerException
組織構成がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
company - 会社コード
parentDepartment - 新規登録する組織の上位となる組織の組織コード（または会社の会社コード）
department - 組織情報（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentMoved

public void departmentMoved(String groupId,
                            String company,
                            String parentDepartment,
                            String department,
                            String version)
                     throws ChangedListenerException
組織構成からの組織の移動がデータストアに反映された後に呼び出されます。

パラメータ:
groupId - ログイングループID
company - 上位組織と移動対象の組織が所属する会社の会社コード
parentDepartment - 上位組織の組織コード（または会社の会社コード）
department - 移動する組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentLeft

public void departmentLeft(String groupId,
                           String company,
                           String department,
                           String version)
                    throws ChangedListenerException
組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。

パラメータ:
groupId - ログイングループID
company - 会社コード
department - 離脱させる組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailSet

public void categoryDetailSet(String groupId,
                              CompanyCategory category)
                       throws ChangedListenerException
分類区分情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
category - 登録された分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailRemoved

public void categoryDetailRemoved(String groupId,
                                  CompanyCategory category)
                           throws ChangedListenerException
分類区分情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
category - 削除された分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberSet

public void memberSet(String groupId,
                      DepartmentAttach attach)
               throws ChangedListenerException
組織への人員の割当がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
attach - 割当られた人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberDeleted

public void memberDeleted(String groupId,
                          DepartmentAttach attach)
                   throws ChangedListenerException
組織からの人員の割当がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
attach - 組織から外された人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

mainSet

public void mainSet(String groupId,
                    DepartmentMain main)
             throws ChangedListenerException
主所属情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
main - 主所属情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

mainRemoved

public void mainRemoved(String groupId,
                        DepartmentMain main)
                 throws ChangedListenerException
主所属情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
main - 主所属情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionAdded

public void versionAdded(String groupId,
                         CompanyVersion version)
                  throws ChangedListenerException
会社構成バージョンがデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionUpdated

public void versionUpdated(String groupId,
                           CompanyVersion version)
                    throws ChangedListenerException
会社構成バージョンがデータストアに更新された後に呼び出されます。

パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionDeleted

public void versionDeleted(String groupId,
                           CompanyVersion version)
                    throws ChangedListenerException
会社構成バージョンがデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionCopied

public void versionCopied(String groupId,
                          String company,
                          String srcVersion,
                          String destVersion,
                          Term term)
                   throws ChangedListenerException
登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
company - コピー元、コピー先の会社構成バージョンの会社コード
srcVersion - コピー元の会社構成バージョンのバージョンコード
destVersion - コピー先の会社構成バージョンのバージョンコード
term - コピー先の会社構成バージョンの期間
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

postAdded

public void postAdded(String groupId,
                      CompanyPost post)
               throws ChangedListenerException
役職情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

postUpdated

public void postUpdated(String groupId,
                        CompanyPost post)
                 throws ChangedListenerException
役職情報がデータストアに更新された後に呼び出されます。

パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

postDeleted

public void postDeleted(String groupId,
                        CompanyPost post)
                 throws ChangedListenerException
役職情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyImporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company
インタフェース CompanyImporter

既知の実装クラスの一覧:
StandardCompanyImporter
public interface CompanyImporter

会社のインポートのインターフェースです。

導入されたバージョン:
5.0

メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。

メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company
クラス CompanyManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager
public abstract class CompanyManager
extends Object

会社や組織に関連する情報を管理します。 このクラスのインスタンスは必ず getCompanyManager(String,String) で取得してください。

導入されたバージョン:
5.0

コンストラクタの概要
CompanyManager()
メソッドの概要
abstract void | addCompany(Company company) 会社を登録します。
abstract void | addDepartment(Department department) 組織を登録します。
abstract void | addPost(CompanyPost post) 役職を登録します。
abstract void | addVersion(CompanyVersion version) 会社構成バージョンを新規に登録します。
abstract void | copyVersion(String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンの内容をコピーします。
abstract void | deleteCompany(Company company) 登録済の会社を削除します。
abstract void | deleteDepartment(Department department) 登録済の組織情報を削除します。
abstract void | deleteMember(DepartmentAttach attach) 組織から人員をはずします。
abstract void | deletePost(CompanyPost post) 登録済の役職情報を削除します。
abstract void | deleteVersion(CompanyVersion version) 登録済の会社構成バージョンを削除します。
abstract Department[] | getAttachedDepartments(String user) 現在、ユーザが所属している組織の一覧を取得します。
abstract Department[] | getAttachedDepartments(String user, Date date) 指定された日付にユーザが所属している組織の一覧を取得します。
static CompanyManager | getCompanyManager(String user, String group) CompanyManagerを取得します。
abstract Department | getDepartment(String company, String department) 登録済の組織を取得します。
abstract DepartmentAttach | getDepartmentAttach(String user, String company, String department) ユーザの組織への所属情報を取得します。
abstract DepartmentMain | getDepartmentMain(String user) ユーザの主所属情報を取得します。
abstract DepartmentStruct[] | getDepartmentStructs(String company, String department, Date date, Locale locale) 組織の階層構造を取得します。
abstract User[] | getMember(String company, String department) 現在、組織に所属するる人員の一覧を取得します。
abstract User[] | getMember(String company, String department, Date date) 指定された日付に組織に所属する人員の一覧を取得します。
abstract PlainCompanyPost[] | getPostsInCompany(String company) 会社に登録済の役職をすべて取得します。
abstract PlainCompanyPost[] | getPostsInCompany(String company, Date date) 会社に登録済の役職をすべて取得します。
abstract PlainCompanyPost[] | getPostsInCompany(String company, Date date, Locale locale) 会社に登録済の役職をすべて取得します。
abstract PlainCompanyPost[] | getPostsInCompany(String company, Locale locale) 会社に登録済の役職をすべて取得します。
abstract PlainCompanyPost[] | getPostsOfUser(String company, String user) ユーザに設定された役職をすべて取得します。
abstract PlainCompanyPost[] | getPostsOfUser(String company, String user, Date date) ユーザに設定された役職をすべて取得します。
abstract PlainCompanyPost[] | getPostsOfUser(String company, String user, Date date, Locale locale) ユーザに設定された役職をすべて取得します。
abstract PlainCompanyPost[] | getPostsOfUser(String company, String user, Locale locale) ユーザに設定された役職をすべて取得します。
abstract CompanyVersion | getVersion(String company) 現在の会社構成バージョン情報を取得します。
abstract CompanyVersion | getVersion(String company, Date date) 指定された日付の会社構成バージョン情報を取得します。
protected abstract void | init(String user, String group) CompanyManagerを初期化します。
abstract void | joinDepartment(String company, String parentDepartment, String department, String version) 組織構成に組織を登録します。
abstract void | leaveDepartment(String company, String department, String version) 組織構成から組織情報を離脱させます。
abstract void | moveDepartment(String company, String parentDepartment, String department, String version) 組織構成に登録済の組織情報を移動します。
abstract void | removeCategoryDetail(CompanyCategory category) 組織に対して指定された分類区分情報を削除します。
abstract void | removeMain(DepartmentMain main) 指定されたユーザの主所属を削除します。
abstract void | setCategoryDetail(CompanyCategory category) 組織に対して指定された分類区分情報を設定します。
abstract void | setMain(DepartmentMain main) ユーザが主所属する組織を設定します。
abstract void | setMember(DepartmentAttach attach) 組織に人員を割り当てます。
abstract void | updateDepartment(Department department) 登録済の組織情報を更新します。
abstract void | updatePost(CompanyPost post) 登録済の役職情報を更新します。
abstract void | updateVersion(CompanyVersion version) 登録済の会社構成バージョンを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyManager

public CompanyManager()
メソッドの詳細

getCompanyManager

public static CompanyManager getCompanyManager(String user,
                                               String group)
                                        throws ManagerException
CompanyManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するCompanyManager
例外:
ManagerException - CompanyManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
CompanyManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - 初期化に失敗

getDepartment

public abstract Department getDepartment(String company,
                                         String department)
                                  throws ManagerException
登録済の組織を取得します。
会社コード、組織コードに一致する組織情報が存在しない場合は nullを返します。

パラメータ:
company - 会社コード
department - 組織コード
戻り値:
組織情報
例外:
ManagerException - 組織情報の取得に失敗
導入されたバージョン:
5.1

addCompany

public abstract void addCompany(Company company)
                         throws ManagerException
会社を登録します。 このメソッドを実行すると下記のような動作が行われます。
  1. 会社を新規登録する。
  2. 会社に対応する組織を新規登録する。

パラメータ:
company - 会社情報
例外:
ManagerException - 会社の新規登録に失敗

deleteCompany

public abstract void deleteCompany(Company company)
                            throws ManagerException
登録済の会社を削除します。 このメソッドを実行すると指定された会社に関連する全ての情報が削除されます。
指定された会社の情報が存在しない場合は ManagerException がスローされます。

パラメータ:
company - 会社
例外:
ManagerException - 会社の削除に失敗

addDepartment

public abstract void addDepartment(Department department)
                            throws ManagerException
組織を登録します。
このメソッドを実行しただけではまだ会社の組織構成には追加されていません。
組織構成に追加したい場合は joinDepartment(String, String, String, String) を使用してください。

パラメータ:
department - 組織情報
例外:
ManagerException - 組織の登録に失敗

updateDepartment

public abstract void updateDepartment(Department department)
                               throws ManagerException
登録済の組織情報を更新します。

パラメータ:
department - 組織情報
例外:
ManagerException - 組織情報の更新に失敗

deleteDepartment

public abstract void deleteDepartment(Department department)
                               throws ManagerException
登録済の組織情報を削除します。
指定された組織情報が存在しない場合は ManagerException がスローされます。

パラメータ:
department - 組織情報
例外:
ManagerException - 組織情報の削除に失敗

joinDepartment

public abstract void joinDepartment(String company,
                                    String parentDepartment,
                                    String department,
                                    String version)
                             throws ManagerException
組織構成に組織を登録します。
新しく親となる組織と登録対象の組織は同一の会社に所属している必要があります。
バージョンコードは登録済みのものを指定する必要があります。
選択された組織が対象のバージョンにおいて既に登録されているときはこのメソッドは使用できません。

パラメータ:
company - 会社コード
parentDepartment - 新規登録する組織の上位となる組織の組織コード（または会社の会社コード）
department - 新規登録する組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ManagerException - 組織構成に組織の登録の失敗

moveDepartment

public abstract void moveDepartment(String company,
                                    String parentDepartment,
                                    String department,
                                    String version)
                             throws ManagerException
組織構成に登録済の組織情報を移動します。
新しく上位となる組織と移動対象の組織は同一の会社に所属している必要があります。

また、組織構成が循環するような移動はできません。
バージョンコードは登録済みのものを指定する必要があります。

パラメータ:
company - 上位組織と移動対象の組織が所属する会社の会社コード
parentDepartment - 上位組織の組織コード（または会社の会社コード）
department - 移動する組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ManagerException - 組織の移動の失敗

leaveDepartment

public abstract void leaveDepartment(String company,
                                     String department,
                                     String version)
                              throws ManagerException
組織構成から組織情報を離脱させます。
このメソッドを実行すると、組織を対象バージョンから離脱させることができます。
指定された組織が子組織を持っていた場合、それらの組織も再帰的にこのバージョンから削除されます。
このメソッドを実行しても組織情報そのものは残ります。
指定された組織が組織構成に登録されていない場合は ManagerException がスローされます。

パラメータ:
company - 会社コード
department - 離脱させる組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ManagerException - 組織構成から組織情報の離脱の失敗

setCategoryDetail

public abstract void setCategoryDetail(CompanyCategory category)
                                throws ManagerException
組織に対して指定された分類区分情報を設定します。

パラメータ:
category - 設定する分類区分詳細詳細情報
例外:
ManagerException - 分類区分情報の設定に失敗

removeCategoryDetail

public abstract void removeCategoryDetail(CompanyCategory category)
                                   throws ManagerException
組織に対して指定された分類区分情報を削除します。
指定された分類区分情報が存在しない場合は ManagerException がスローされます。

パラメータ:
category - 削除する分類区分詳細詳細情報
例外:
ManagerException - 分類区分情報の削除に失敗

setMember

public abstract void setMember(DepartmentAttach attach)
                        throws ManagerException
組織に人員を割り当てます。
人員の割当情報はパラメータで渡された情報で完全に上書きされます。

パラメータ:
attach - 割当人員の情報
例外:
ManagerException - 人員の割当に失敗

deleteMember

public abstract void deleteMember(DepartmentAttach attach)
                           throws ManagerException
組織から人員をはずします。
指定された人員が組織に割り当てられていない場合は ManagerException がスローされます。

パラメータ:
attach - 組織から外す人員の情報
例外:
ManagerException - 人員の削除に失敗

getMember

public abstract User[] getMember(String company,
                                 String department)
                          throws ManagerException
現在、組織に所属するる人員の一覧を取得します。
指定された組織に人員が所属していない場合は空の配列を返します。

取得されるユーザの期間化情報には、システム日付を含む期間の情報のみが設定されます。
また期間国際化情報には、ログインユーザのデフォルト言語の情報のみが設定されます。

パラメータ:
company - 会社コード
department - 組織コード
戻り値:
ユーザ情報
例外:
ManagerException - 所属する人員の取得に失敗
導入されたバージョン:
5.1

getMember

public abstract User[] getMember(String company,
                                 String department,
                                 Date date)
                          throws ManagerException
指定された日付に組織に所属する人員の一覧を取得します。
指定された組織に人員が所属していない場合は空の配列を返します。

取得されるユーザの期間化情報には、指定された日付を含む期間の情報のみが設定されます。
また期間国際化情報には、ログインユーザのデフォルト言語の情報のみが設定されます。

パラメータ:
company - 会社コード
department - 組織コード
date - 日付
戻り値:
ユーザ情報
例外:
ManagerException - 所属する人員の取得に失敗
導入されたバージョン:
5.1

setMain

public abstract void setMain(DepartmentMain main)
                      throws ManagerException
ユーザが主所属する組織を設定します。
既存の主所属情報は新しい情報で上書きされます。

パラメータ:
main - 主所属情報
例外:
ManagerException - 主所属する組織の設定に失敗

removeMain

public abstract void removeMain(DepartmentMain main)
                         throws ManagerException
指定されたユーザの主所属を削除します。
指定されたユーザの主所属の情報が存在しない場合は ManagerException がスローされます。

パラメータ:
main - 主所属情報
例外:
ManagerException - 主所属の削除の失敗

addVersion

public abstract void addVersion(CompanyVersion version)
                         throws ManagerException
会社構成バージョンを新規に登録します。
追加された構成バージョンのトップレベルには、会社に該当する組織が追加されます。

パラメータ:
version - バージョン情報
例外:
ManagerException - 会社構成バージョンの新規登録に失敗

updateVersion

public abstract void updateVersion(CompanyVersion version)
                            throws ManagerException
登録済の会社構成バージョンを更新します。

パラメータ:
version - バージョン情報
例外:
ManagerException - 会社構成バージョンの更新に失敗

deleteVersion

public abstract void deleteVersion(CompanyVersion version)
                            throws ManagerException
登録済の会社構成バージョンを削除します。
指定された会社構成バージョンの情報が存在しない場合は ManagerException がスローされます。

パラメータ:
version - バージョン情報
例外:
ManagerException - 会社構成バージョンの削除に失敗

copyVersion

public abstract void copyVersion(String company,
                                 String srcVersion,
                                 String destVersion,
                                 Term term)
                          throws ManagerException
登録済の会社構成バージョンの内容をコピーします。
コピー元の会社構成バージョンに関連する、全ての組織内包がコピー先の会社構成バージョンに関連づくようにコピーされます。
コピー元のバージョンコードは登録済みのものを選択してください
コピー先のバージョンコードは登録されていないものを選択してください

パラメータ:
company - コピー元、コピー先の会社構成バージョンの会社コード
srcVersion - コピー元の会社構成バージョンのバージョンコード
destVersion - コピー先の会社構成バージョンのバージョンコード
term - コピー先の会社構成バージョンの期間
例外:
ManagerException - 会社構成バージョンのコピーに失敗

getDepartmentStructs

public abstract DepartmentStruct[] getDepartmentStructs(String company,
                                                        String department,
                                                        Date date,
                                                        Locale locale)
                                                 throws ManagerException
組織の階層構造を取得します。
指定された日付に該当する会社構成バージョンが存在しない場合は、ManagerException がスローされます。
また、会社構成バージョンは存在するが該当する組織情報が存在しない場合は空の配列を返します。

パラメータ:
company - 会社コード
department - 組織コード
date - 日付
locale - 言語(ロケール)
戻り値:
組織の階層構造
例外:
ManagerException - 組織の階層構造の取得に失敗

getAttachedDepartments

public abstract Department[] getAttachedDepartments(String user)
                                             throws ManagerException
現在、ユーザが所属している組織の一覧を取得します。
ユーザがどの組織にも所属していない場合は空の配列を返します。

取得される組織の期間化情報には、システム日付を含む期間の情報のみが設定されます。
また期間国際化情報には、ログインユーザのデフォルト言語の情報のみが設定されます。

パラメータ:
user - ユーザコード
例外:
ManagerException - 組織情報の取得に失敗
導入されたバージョン:
5.1

getAttachedDepartments

public abstract Department[] getAttachedDepartments(String user,
                                                    Date date)
                                             throws ManagerException
指定された日付にユーザが所属している組織の一覧を取得します。
ユーザがどの組織にも所属していない場合は空の配列を返します。

取得される組織の期間化情報には、指定された日付を含む期間の情報のみが設定されます。
また期間国際化情報には、ログインユーザのデフォルト言語の情報のみが設定されます。

パラメータ:
user - ユーザコード
date - 日付
例外:
ManagerException - 組織情報の取得に失敗
導入されたバージョン:
5.1

getDepartmentAttach

public abstract DepartmentAttach getDepartmentAttach(String user,
                                                     String company,
                                                     String department)
                                              throws ManagerException
ユーザの組織への所属情報を取得します。
該当する組織所属が存在しない場合は nullを返します。

パラメータ:
user - ユーザコード
company - 会社コード
department - 組織コード
戻り値:
組織所属情報
例外:
ManagerException - 組織所属情報の取得に失敗
導入されたバージョン:
5.1

getDepartmentMain

public abstract DepartmentMain getDepartmentMain(String user)
                                          throws ManagerException
ユーザの主所属情報を取得します。

パラメータ:
user - ユーザコード
戻り値:
主所属情報
例外:
ManagerException - 主所属情報の取得に失敗
導入されたバージョン:
5.1

getPostsInCompany

public abstract PlainCompanyPost[] getPostsInCompany(String company)
会社に登録済の役職をすべて取得します。
役職を特定するためにシステム日付、ログインユーザのデフォルト言語を使用します。

パラメータ:
company - 会社コード
戻り値:
会社に登録済の役職
例外:
ManagerException - 役職情報の取得に失敗

getPostsInCompany

public abstract PlainCompanyPost[] getPostsInCompany(String company,
                                                     Date date)
会社に登録済の役職をすべて取得します。
役職を特定するためにログインユーザのデフォルト言語を使用します。

パラメータ:
company - 会社コード
date - 役職情報を特定するための日付
戻り値:
会社に登録済の役職
例外:
ManagerException - 役職情報の取得に失敗

getPostsInCompany

public abstract PlainCompanyPost[] getPostsInCompany(String company,
                                                     Locale locale)
会社に登録済の役職をすべて取得します。
役職を特定するためにシステム日付を使用します。

パラメータ:
company - 会社コード
locale - 役職情報を特定するための言語
戻り値:
会社に登録済の役職
例外:
ManagerException - 役職情報の取得に失敗

getPostsInCompany

public abstract PlainCompanyPost[] getPostsInCompany(String company,
                                                     Date date,
                                                     Locale locale)
会社に登録済の役職をすべて取得します。

パラメータ:
company - 会社コード
date - 役職情報を特定するための日付
locale - 役職情報を特定するための言語
戻り値:
会社に登録済の役職
例外:
ManagerException - 役職情報の取得に失敗

getPostsOfUser

public abstract PlainCompanyPost[] getPostsOfUser(String company,
                                                  String user)
ユーザに設定された役職をすべて取得します。
役職を特定するためにシステム日付、ログインユーザのデフォルト言語を使用します。

パラメータ:
company - 会社コード
user - ユーザコード
戻り値:
会社に登録済の役職
例外:
ManagerException - 役職情報の取得に失敗

getPostsOfUser

public abstract PlainCompanyPost[] getPostsOfUser(String company,
                                                  String user,
                                                  Date date)
ユーザに設定された役職をすべて取得します。
役職を特定するためにログインユーザのデフォルト言語を使用します。

パラメータ:
company - 会社コード
user - ユーザコード
date - 役職情報を特定するための日付
戻り値:
会社に登録済の役職
例外:
ManagerException - 役職情報の取得に失敗

getPostsOfUser

public abstract PlainCompanyPost[] getPostsOfUser(String company,
                                                  String user,
                                                  Locale locale)
ユーザに設定された役職をすべて取得します。
役職を特定するためにシステム日付を使用します。

パラメータ:
company - 会社コード
user - ユーザコード
locale - 役職情報を特定するための言語
戻り値:
会社に登録済の役職
例外:
ManagerException - 役職情報の取得に失敗

getPostsOfUser

public abstract PlainCompanyPost[] getPostsOfUser(String company,
                                                  String user,
                                                  Date date,
                                                  Locale locale)
ユーザに設定された役職をすべて取得します。

パラメータ:
company - 会社コード
user - ユーザコード
date - 役職情報を特定するための日付
locale - 役職情報を特定するための言語
戻り値:
会社に登録済の役職
例外:
ManagerException - 役職情報の取得に失敗

addPost

public abstract void addPost(CompanyPost post)
                      throws ManagerException
役職を登録します。

パラメータ:
post - 役職情報
例外:
ManagerException - 役職の登録に失敗

updatePost

public abstract void updatePost(CompanyPost post)
                         throws ManagerException
登録済の役職情報を更新します。

パラメータ:
post - 役職情報
例外:
ManagerException - 役職の更新に失敗

deletePost

public abstract void deletePost(CompanyPost post)
                         throws ManagerException
登録済の役職情報を削除します。
指定された役職情報が存在しない場合は ManagerException がスローされます。

パラメータ:
post - 役職情報
例外:
ManagerException - 役職の削除に失敗

getVersion

public abstract CompanyVersion getVersion(String company)
                                   throws ManagerException
現在の会社構成バージョン情報を取得します。
該当する会社構成バージョン情報が存在しない場合は null を返します。

パラメータ:
company - 会社コード
戻り値:
会社構成バージョン情報
例外:
ManagerException
導入されたバージョン:
5.1

getVersion

public abstract CompanyVersion getVersion(String company,
                                          Date date)
                                   throws ManagerException
指定された日付の会社構成バージョン情報を取得します。
該当する会社構成バージョン情報が存在しない場合は null を返します。

パラメータ:
company - 会社コード
date - バージョンを特定する日付
戻り値:
会社構成バージョン情報
例外:
ManagerException
導入されたバージョン:
5.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyPostImporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company
インタフェース CompanyPostImporter

既知の実装クラスの一覧:
StandardCompanyPostImporter
public interface CompanyPostImporter

役職のインポートのインターフェースです。

導入されたバージョン:
5.0

メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。

メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException - インポート時に例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DepartmentStruct (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company
インタフェース DepartmentStruct

public interface DepartmentStruct

組織の階層です。

導入されたバージョン:
5.0

メソッドの概要
String | getCompanyCode() 会社コードを取得する。
String | getDepartmentCode() 組織コードを取得する。
String | getName() 会社名または組織名を取得する。

メソッドの詳細

getCompanyCode

public String getCompanyCode()
会社コードを取得する。

戻り値:
会社コード

getDepartmentCode

public String getDepartmentCode()
組織コードを取得する。

戻り値:
組織コード

getName

public String getName()
会社名または組織名を取得する。

戻り値:
会社名または組織名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.company (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.company
インタフェース
CompanyChangedListener
CompanyImporter
CompanyPostImporter
DepartmentStruct
クラス
CompanyManager
StandardCompanyImporter
StandardCompanyPostImporter


jp.co.intra_mart.foundation.datastore.application.domain.company (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company

会社情報を操作するクラスを提供します。

参照:
説明

インタフェースの概要
CompanyChangedListener | 会社・組織に関する情報の変更時のリスナーです。
CompanyImporter | 会社のインポートのインターフェースです。
CompanyPostImporter | 役職のインポートのインターフェースです。
DepartmentStruct | 組織の階層です。

クラスの概要
CompanyManager | 会社や組織に関連する情報を管理します。
StandardCompanyImporter | 会社のインポートを行います。
StandardCompanyPostImporter | 役職のインポートを行います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company の説明

会社情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.company クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener
  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company の使用

jp.co.intra_mart.foundation.datastore.application.domain.company を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company のクラス
CompanyImporter
会社のインポートのインターフェースです。
CompanyManager
会社や組織に関連する情報を管理します。
CompanyPostImporter
役職のインポートのインターフェースです。
DepartmentStruct
組織の階層です。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.company のクラス
CompanyChangedListener
会社・組織に関する情報の変更時のリスナーです。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.company のクラス
CompanyChangedListener
会社・組織に関する情報の変更時のリスナーです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardCompanyImporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company
クラス StandardCompanyImporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter
すべての実装インタフェース:
CompanyImporter
public class StandardCompanyImporter
extends Object
implements CompanyImporter

会社のインポートを行います。

導入されたバージョン:
5.0

コンストラクタの概要
StandardCompanyImporter()
メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardCompanyImporter

public StandardCompanyImporter()
メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

定義:
インタフェース CompanyImporter 内の doImport
パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardCompanyPostImporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company
クラス StandardCompanyPostImporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter
すべての実装インタフェース:
CompanyPostImporter
public class StandardCompanyPostImporter
extends Object
implements CompanyPostImporter

役職のインポートを行います。

導入されたバージョン:
5.0

コンストラクタの概要
StandardCompanyPostImporter()
メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardCompanyPostImporter

public StandardCompanyPostImporter()
メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

定義:
インタフェース CompanyPostImporter 内の doImport
パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager の使用

CurrencyManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.currency 通貨情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.currency での CurrencyManager の使用

CurrencyManager を返す jp.co.intra_mart.foundation.datastore.application.domain.currency のメソッド
static CurrencyManager CurrencyManager.getCurrencyManager(String user, String group)
CurrencyManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CurrencyManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.currency
クラス CurrencyManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager
public abstract class CurrencyManager
extends Object

通貨情報を取り扱います。

導入されたバージョン:
5.1

コンストラクタの概要
CurrencyManager()
メソッドの概要
abstract String[] | getCurrencyCodes() 通貨コードの一覧を返します。
static CurrencyManager | getCurrencyManager(String user, String group) CurrencyManagerを取得します。
abstract Map | getCurrencyName(String currencyCode) 指定された通貨コードに対する名称を返します。
abstract String | getCurrencyName(String currencyCode, Locale locale) 通貨コードに対する名称を指定された言語で返します。
abstract String | getSystemCurrencyCode() システム通貨コードを返します。
protected abstract void | init(String user, String group) CurrencyManagerを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CurrencyManager

public CurrencyManager()
メソッドの詳細

getCurrencyManager

public static CurrencyManager getCurrencyManager(String user,
                                                 String group)
                                          throws ManagerException
CurrencyManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するCurrencyManager
例外:
ManagerException - CurrencyManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
CurrencyManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - 初期化に失敗

getSystemCurrencyCode

public abstract String getSystemCurrencyCode()
                                      throws ManagerException
システム通貨コードを返します。

戻り値:
通貨コード
例外:
ManagerException

getCurrencyCodes

public abstract String[] getCurrencyCodes()
                                   throws ManagerException
通貨コードの一覧を返します。

戻り値:
通貨コードの一覧
例外:
ManagerException

getCurrencyName

public abstract String getCurrencyName(String currencyCode,
                                       Locale locale)
                                throws ManagerException
通貨コードに対する名称を指定された言語で返します。
通貨コードが存在しない場合は、ManagerExceptionを発生させます。

null を返します。

パラメータ:
currencyCode - 通貨コード
locale - 言語
戻り値:
通貨名
例外:
ManagerException

getCurrencyName

public abstract Map getCurrencyName(String currencyCode)
                             throws ManagerException
指定された通貨コードに対する名称を返します。

返却されるマップ Map のキーには言語 Locale、値には通貨名が設定されます。

通貨コードが存在しない場合は、システム例外を発生させます。

通貨コードに対する名称が存在しない場合は、空のMapを返します。

返されるマップMapは変更することができません。

パラメータ:
currencyCode - 通貨コード
戻り値:
通貨名
例外:
ManagerException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.currency (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.currency
クラス
CurrencyManager


jp.co.intra_mart.foundation.datastore.application.domain.currency (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.currency

通貨情報を操作するクラスを提供します。

参照:
説明

クラスの概要
CurrencyManager 通貨情報を取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.currency の説明

通貨情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.currency クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.currency の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.currency の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.currency の使用

jp.co.intra_mart.foundation.datastore.application.domain.currency を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.currency 通貨情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.currency により使用される jp.co.intra_mart.foundation.datastore.application.domain.currency のクラス
CurrencyManager
通貨情報を取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager の使用

DealManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal での DealManager の使用

DealManager を返す jp.co.intra_mart.foundation.datastore.application.domain.deal のメソッド
static DealManager DealManager.getDealManager(String user, String group)
DealManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager の使用

DealPermissionManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal での DealPermissionManager の使用

DealPermissionManager を返す jp.co.intra_mart.foundation.datastore.application.domain.deal のメソッド
static DealPermissionManager DealPermissionManager.getDealPermissionManager(String user, String group)
DealPermissionManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal の使用

Deal を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal での Deal の使用

Deal を返す jp.co.intra_mart.foundation.datastore.application.domain.deal のメソッド
abstract Deal | DealManager.getDeal(String customerCompanyCode, String customerDepartmentCode, String dealCode) 指定された取扱情報を返します。
abstract Deal[] | DealManager.getDeals() 現在、存在する取扱情報を返します。
abstract Deal[] | DealManager.getDeals(Date date) 指定された日付に存在する取扱情報を返します。
abstract Deal[] | DealManager.getDealsByKey(String itemCode, String companyCode, String departmentCode) 現在、存在する取扱情報の中で、商品と取引先から特定されるものを返します。
abstract Deal[] | DealManager.getDealsByKey(String itemCode, String companyCode, String departmentCode, Date date) 指定された日時に存在する取扱情報の中で、商品と取引先から特定されるものを返します。
abstract Deal[] | DealManager.getUsersDeals(String userCode) 現在、ユーザがアクセスできる取扱情報を返します。
abstract Deal[] | DealManager.getUsersDeals(String userCode, Date date) 指定された日付にユーザがアクセスできる取扱情報を返します。
abstract Deal[] | DealManager.getUsersDealsByKey(String userCode, String itemCode, String companyCode, String departmentCode) 現在、存在する取扱情報の中で、商品と取引先から特定されるものを返します。
abstract Deal[] | DealManager.getUsersDealsByKey(String userCode, String itemCode, String companyCode, String departmentCode, Date date) 指定された日時に存在する取扱情報の中で、商品と取引先から特定されるものを返します。

Deal 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.deal のメソッド
abstract Department[] | DealPermissionManager.getDepartments(Deal deal) 取扱情報を保有するアクセス権をもつ組織を返します。
abstract PublicGroup[] | DealPermissionManager.getPublicGroups(Deal deal) 取扱情報を保有するアクセス権をもつパブリックグループを返します。
abstract Role[] | DealPermissionManager.getRoles(Deal deal) 取扱情報を保有するアクセス権をもつロールを返します。
abstract void | DealManager.addDeal(Deal deal) 取扱情報を新規登録します。
abstract void | DealManager.updateDeal(Deal deal) 取扱情報を更新します。
abstract void | DealManager.deleteDeal(Deal deal) 取扱情報を削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable の使用

DealTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal.deal での DealTerminable の使用

DealTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.deal.deal のメソッド
DealTerminable | Deal.getDealTerminable(Term term) 指定された期間に対する期間化情報を取得します。
DealTerminable | Deal.getDealTerminable(Date date) 指定された日時に対する期間化情報を取得します。

DealTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.deal.deal のメソッド
 void Deal.putDealTerminable(Term term, DealTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Deal (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.deal.deal
クラス Deal

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal
すべての実装インタフェース:
Serializable
public class Deal
extends Object
implements Serializable

取扱の基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
Deal()
取扱に関連する情報を新規に生成します。
Deal(Date date)
取扱に関連する情報を新規に生成します。
メソッドの概要
String | getCurrencyCode() 通貨コードを取得します。
String | getCustomerCompanyCode() 取引先会社コードを取得します。
String | getCustomerDepartmentCode() 取引先組織コードを取得します。
String | getDealCode() 取扱コードを取得します。
String | getDealName() 取扱名を取得します。
DealTerminable | getDealTerminable(Date date) 指定された日時に対する期間化情報を取得します。
DealTerminable | getDealTerminable(Term term) 指定された期間に対する期間化情報を取得します。
int | getDealType() 取扱種別を取得します。
Date | getDefaultDate() デフォルトの日時を取得します。
String | getNotes() 備考を取得します。
Term[] | getTerms() この取扱で管理している期間をすべて取得します。
double | getUnitPrice() 単価を取得します。
double | getUnitPrice(Date date) 単価を取得します。
void | putDealTerminable(Term term, DealTerminable data) 指定された期間に対する期間化情報を設定します。
void | removeDealTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setCurrencyCode(String currencyCode) 通貨コードを設定します。
void | setCustomerCompanyCode(String customerCompanyCode) 取引先会社コードを設定します。
void | setCustomerDepartmentCode(String customerDepartmentCode) 取引先組織コードを設定します。
void | setDealCode(String dealCode) 取扱コードを設定します。
void | setDealName(String dealName) 取扱名を設定します。
void | setDealType(int dealType) 取扱種別を設定します。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setNotes(String notes) 備考を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Deal

public Deal()
取扱に関連する情報を新規に生成します。 デフォルトの日時には現在のシステム日時が割り当てられます。

Deal

public Deal(Date date)
取扱に関連する情報を新規に生成します。 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時
メソッドの詳細

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
この取扱で管理している期間をすべて取得します。

戻り値:
この取扱で管理している期間

getDealTerminable

public DealTerminable getDealTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getDealTerminable

public DealTerminable getDealTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putDealTerminable

public void putDealTerminable(Term term,
                              DealTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removeDealTerminable

public void removeDealTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getCustomerCompanyCode

public String getCustomerCompanyCode()
取引先会社コードを取得します。

戻り値:
取引先会社コード

setCustomerCompanyCode

public void setCustomerCompanyCode(String customerCompanyCode)
取引先会社コードを設定します。

パラメータ:
customerCompanyCode - 取引先会社コード

getCustomerDepartmentCode

public String getCustomerDepartmentCode()
取引先組織コードを取得します。

戻り値:
取引先組織コード

setCustomerDepartmentCode

public void setCustomerDepartmentCode(String customerDepartmentCode)
取引先組織コードを設定します。

パラメータ:
customerDepartmentCode - 取引先組織コード

getDealCode

public String getDealCode()
取扱コードを取得します。

戻り値:
取扱コード

setDealCode

public void setDealCode(String dealCode)
取扱コードを設定します。

パラメータ:
dealCode - 取扱コード

getDealName

public String getDealName()
取扱名を取得します。

戻り値:
取扱名

setDealName

public void setDealName(String dealName)
取扱名を設定します。

パラメータ:
dealName - 取扱名

getDealType

public int getDealType()
取扱種別を取得します。

戻り値:
取扱種別

setDealType

public void setDealType(int dealType)
取扱種別を設定します。

パラメータ:
dealType - 取扱種別

getCurrencyCode

public String getCurrencyCode()
通貨コードを取得します。

戻り値:
通貨コード

setCurrencyCode

public void setCurrencyCode(String currencyCode)
通貨コードを設定します。

パラメータ:
currencyCode - 通貨コード

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getUnitPrice

public double getUnitPrice()
単価を取得します。

戻り値:
単価

getUnitPrice

public double getUnitPrice(Date date)
単価を取得します。

パラメータ:
date - 日時
戻り値:
単価
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DealTerminable (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.deal.deal
クラス DealTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable
すべての実装インタフェース:
Serializable
public class DealTerminable
extends Object
implements Serializable

取扱の期間化属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
DealTerminable()
メソッドの概要
void | addDetail(DealDetail detail) 取扱詳細を追加します。
DealDetail[] | getDetails() 取扱詳細の一覧を取得します。
double | getUnitPrice() 単価を取得します。
void | removeDetail(String itemCode) 商品コードに一致する取扱詳細を削除します。
void | setUnitPrice(double unitPrice) 単価を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DealTerminable

public DealTerminable()
メソッドの詳細

getUnitPrice

public double getUnitPrice()
単価を取得します。

戻り値:
単価

setUnitPrice

public void setUnitPrice(double unitPrice)
単価を設定します。

パラメータ:
unitPrice - 単価

addDetail

public void addDetail(DealDetail detail)
取扱詳細を追加します。

同じ商品コードを持つものがすでに、存在するときは上書きされます。

パラメータ:
detail - 取扱詳細

removeDetail

public void removeDetail(String itemCode)
商品コードに一致する取扱詳細を削除します。

パラメータ:
itemCode - 商品コード

getDetails

public DealDetail[] getDetails()
取扱詳細の一覧を取得します。

戻り値:
取扱詳細の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.deal.deal (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.deal.deal
クラス
Deal
DealTerminable


jp.co.intra_mart.foundation.datastore.application.domain.deal.deal (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.deal

取扱情報を操作するクラスを提供します。

参照:
説明

クラスの概要
Deal | 取扱の基本属性のデータを取り扱います。
DealTerminable | 取扱の期間化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.deal の説明

取扱情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.deal.deal クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.deal の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.deal の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal.deal の使用

jp.co.intra_mart.foundation.datastore.application.domain.deal.deal を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.deal | 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal により使用される jp.co.intra_mart.foundation.datastore.application.domain.deal.deal のクラス
Deal
取扱の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.deal.deal により使用される jp.co.intra_mart.foundation.datastore.application.domain.deal.deal のクラス
DealTerminable
取扱の期間化属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment の使用

DealerDepartment を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal での DealerDepartment の使用

DealerDepartment 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.deal のメソッド
abstract void | DealPermissionManager.setPermissionToDepartment(DealerDepartment dealer) 組織に対してアクセス権を設定します。
abstract void | DealPermissionManager.removePermissionFromDepartment(DealerDepartment dealer) 組織からアクセス権を削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DealerDepartment (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.deal.department
クラス DealerDepartment

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment
すべての実装インタフェース:
Serializable
public class DealerDepartment
extends Object
implements Serializable

組織毎取扱パーミッションの基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
DealerDepartment()
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getCustomerCompanyCode() 取引先会社コードを取得します。
String | getCustomerDepartmentCode() 取引先組織コードを取得します。
String | getDealCode() 取扱コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setCustomerCompanyCode(String customerCompanyCode) 取引先会社コードを設定します。
void | setCustomerDepartmentCode(String customerDepartmentCode) 取引先組織コードを設定します。
void | setDealCode(String dealCode) 取扱コードを設定します。
void | setDepartmentCode(String departmentCode) 組織コードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DealerDepartment

public DealerDepartment()
メソッドの詳細

getCustomerCompanyCode

public String getCustomerCompanyCode()
取引先会社コードを取得します。

戻り値:
取引先会社コード

setCustomerCompanyCode

public void setCustomerCompanyCode(String customerCompanyCode)
取引先会社コードを設定します。

パラメータ:
customerCompanyCode - 取引先会社コード

getCustomerDepartmentCode

public String getCustomerDepartmentCode()
取引先組織コードを取得します。

戻り値:
取引先組織コード

setCustomerDepartmentCode

public void setCustomerDepartmentCode(String customerDepartmentCode)
取引先組織コードを設定します。

パラメータ:
customerDepartmentCode - 取引先組織コード

getDealCode

public String getDealCode()
取扱コードを取得します。

戻り値:
取扱コード

setDealCode

public void setDealCode(String dealCode)
取扱コードを設定します。

パラメータ:
dealCode - 取扱コード

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します。

パラメータ:
companyCode - 会社コード

getDepartmentCode

public String getDepartmentCode()
組織コードを取得します。

戻り値:
組織コード

setDepartmentCode

public void setDepartmentCode(String departmentCode)
組織コードを設定します。

パラメータ:
departmentCode - 組織コード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.deal.department (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.deal.department
クラス
DealerDepartment


jp.co.intra_mart.foundation.datastore.application.domain.deal.department (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.department

取扱組織権限情報を操作するクラスを提供します。

参照:
説明

クラスの概要
DealerDepartment 組織毎取扱パーミッションの基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.department の説明

取扱組織権限情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.deal.department クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.department の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.department の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal.department の使用

jp.co.intra_mart.foundation.datastore.application.domain.deal.department を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal により使用される jp.co.intra_mart.foundation.datastore.application.domain.deal.department のクラス
DealerDepartment
組織毎取扱パーミッションの基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail の使用

DealDetail を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal.deal での DealDetail の使用

DealDetail を返す jp.co.intra_mart.foundation.datastore.application.domain.deal.deal のメソッド
 DealDetail[] DealTerminable.getDetails()
取扱詳細の一覧を取得します。

DealDetail 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.deal.deal のメソッド
 void DealTerminable.addDetail(DealDetail detail)
取扱詳細を追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DealDetail (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.deal.detail
クラス DealDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail
すべての実装インタフェース:
Serializable
public class DealDetail
extends Object
implements Serializable

取扱詳細の基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
DealDetail()
メソッドの概要
int | getAmount() 数量を取得します。
String | getItemCode() 商品コードを取得します。
String | getUnitCode() 単位コードを取得します。
double | getUnitPrice() 単価を取得します。
void | setAmount(int amount) 数量を設定します。
void | setItemCode(String itemCode) 商品コードを設定します。
void | setUnitCode(String unitCode) 単位コードを設定します。
void | setUnitPrice(double unitPrice) 単価を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DealDetail

public DealDetail()
メソッドの詳細

getItemCode

public String getItemCode()
商品コードを取得します。

戻り値:
商品コード

setItemCode

public void setItemCode(String itemCode)
商品コードを設定します。

パラメータ:
itemCode - 商品コード

getUnitCode

public String getUnitCode()
単位コードを取得します。

戻り値:
単位コード

getAmount

public int getAmount()
数量を取得します。

戻り値:
数量

getUnitPrice

public double getUnitPrice()
単価を取得します。

戻り値:
単価

setAmount

public void setAmount(int amount)
数量を設定します。

パラメータ:
amount - 数量

setUnitCode

public void setUnitCode(String unitCode)
単位コードを設定します。

パラメータ:
unitCode - 単位コード

setUnitPrice

public void setUnitPrice(double unitPrice)
単価を設定します。

パラメータ:
unitPrice - 単価
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.deal.detail (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.deal.detail
クラス
DealDetail


jp.co.intra_mart.foundation.datastore.application.domain.deal.detail (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.detail

取扱詳細情報を操作するクラスを提供します。

参照:
説明

クラスの概要
DealDetail 取扱詳細の基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.detail の説明

取扱詳細情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.deal.detail クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.detail の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.detail の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal.detail の使用

jp.co.intra_mart.foundation.datastore.application.domain.deal.detail を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal.deal により使用される jp.co.intra_mart.foundation.datastore.application.domain.deal.detail のクラス
DealDetail
取扱詳細の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup の使用

DealerPublicGroup を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal での DealerPublicGroup の使用

DealerPublicGroup 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.deal のメソッド
abstract void | DealPermissionManager.setPermissionToPublicGroup(DealerPublicGroup dealer) パブリックグループに対してアクセス権を設定します。
abstract void | DealPermissionManager.removePermissionFromPublicGroup(DealerPublicGroup dealer) パブリックグループからアクセス権を削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DealerPublicGroup (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group
クラス DealerPublicGroup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup
すべての実装インタフェース:
Serializable
public class DealerPublicGroup
extends Object
implements Serializable

パブリックグループ毎取扱パーミッションの基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
DealerPublicGroup()
メソッドの概要
String | getCustomerCompanyCode() 取引先会社コードを取得します。
String | getCustomerDepartmentCode() 取引先組織コードを取得します。
String | getDealCode() 取扱コードを取得します。
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
void | setCustomerCompanyCode(String customerCompanyCode) 取引先会社コードを設定します。
void | setCustomerDepartmentCode(String customerDepartmentCode) 取引先組織コードを設定します。
void | setDealCode(String dealCode) 取扱コードを設定します。
void | setPublicGroupCode(String publicGroupCode) グループコードを設定します。
void | setPublicGroupSetCode(String publicGroupSetCode) グループセットコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DealerPublicGroup

public DealerPublicGroup()
メソッドの詳細

getCustomerCompanyCode

public String getCustomerCompanyCode()
取引先会社コードを取得します。

戻り値:
取引先会社コード

setCustomerCompanyCode

public void setCustomerCompanyCode(String customerCompanyCode)
取引先会社コードを設定します。

パラメータ:
customerCompanyCode - 取引先会社コード

getCustomerDepartmentCode

public String getCustomerDepartmentCode()
取引先組織コードを取得します。

戻り値:
取引先組織コード

setCustomerDepartmentCode

public void setCustomerDepartmentCode(String customerDepartmentCode)
取引先組織コードを設定します。

パラメータ:
customerDepartmentCode - 取引先組織コード

getDealCode

public String getDealCode()
取扱コードを取得します。

戻り値:
取扱コード

setDealCode

public void setDealCode(String dealCode)
取扱コードを設定します。

パラメータ:
dealCode - 取扱コード

getPublicGroupSetCode

public String getPublicGroupSetCode()
グループセットコードを取得します。

戻り値:
グループセットコード

setPublicGroupSetCode

public void setPublicGroupSetCode(String publicGroupSetCode)
グループセットコードを設定します。

パラメータ:
publicGroupSetCode - グループセットコード

getPublicGroupCode

public String getPublicGroupCode()
グループコードを取得します。

戻り値:
グループコード

setPublicGroupCode

public void setPublicGroupCode(String publicGroupCode)
グループコードを設定します。

パラメータ:
publicGroupCode - グループコード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group
クラス
DealerPublicGroup


jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group

取扱パブリックグループ権限情報を操作するクラスを提供します。

参照:
説明

クラスの概要
DealerPublicGroup パブリックグループ毎取扱パーミッションの基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group の説明

取扱パブリックグループ権限情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group の使用

jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal により使用される jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group のクラス
DealerPublicGroup
パブリックグループ毎取扱パーミッションの基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole の使用

DealerRole を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal での DealerRole の使用

DealerRole 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.deal のメソッド
abstract void | DealPermissionManager.setPermissionToRole(DealerRole dealer) ロールに対してアクセス権を設定します。
abstract void | DealPermissionManager.removePermissionFromRole(DealerRole dealer) ロールからアクセス権を削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DealerRole (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.deal.role
クラス DealerRole

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole
すべての実装インタフェース:
Serializable
public class DealerRole
extends Object
implements Serializable

ロール毎取扱パーミッションの基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
DealerRole()
メソッドの概要
String | getCustomerCompanyCode() 取引先会社コードを取得します。
String | getCustomerDepartmentCode() 取引先組織コードを取得します。
String | getDealCode() 取扱コードを取得します。
String | getRoleId() ロールIDを取得します。
void | setCustomerCompanyCode(String customerCompanyCode) 取引先会社コードを設定します。
void | setCustomerDepartmentCode(String customerDepartmentCode) 取引先組織コードを設定します。
void | setDealCode(String dealCode) 取扱コードを設定します。
void | setRoleId(String roleId) ロールIDを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DealerRole

public DealerRole()
メソッドの詳細

getCustomerCompanyCode

public String getCustomerCompanyCode()
取引先会社コードを取得します。

戻り値:
取引先会社コード

setCustomerCompanyCode

public void setCustomerCompanyCode(String customerCompanyCode)
取引先会社コードを設定します。

パラメータ:
customerCompanyCode - 取引先会社コード

getCustomerDepartmentCode

public String getCustomerDepartmentCode()
取引先組織コードを取得します。

戻り値:
取引先組織コード

setCustomerDepartmentCode

public void setCustomerDepartmentCode(String customerDepartmentCode)
取引先組織コードを設定します。

パラメータ:
customerDepartmentCode - 取引先組織コード

getDealCode

public String getDealCode()
取扱コードを取得します。

戻り値:
取扱コード

setDealCode

public void setDealCode(String dealCode)
取扱コードを設定します。

パラメータ:
dealCode - 取扱コード

getRoleId

public String getRoleId()
ロールIDを取得します。

戻り値:
ロールID

setRoleId

public void setRoleId(String roleId)
ロールIDを設定します。

パラメータ:
roleId - ロールID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.deal.role (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.deal.role
クラス
DealerRole


jp.co.intra_mart.foundation.datastore.application.domain.deal.role (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.role

取扱ロール権限情報を操作するクラスを提供します。

参照:
説明

クラスの概要
DealerRole ロール毎取扱パーミッションの基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.role の説明

取扱ロール権限情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.deal.role クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.role の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.role の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal.role の使用

jp.co.intra_mart.foundation.datastore.application.domain.deal.role を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal により使用される jp.co.intra_mart.foundation.datastore.application.domain.deal.role のクラス
DealerRole
ロール毎取扱パーミッションの基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DealManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.deal
クラス DealManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager
public abstract class DealManager
extends Object

取扱に関する情報を管理します。

導入されたバージョン:
5.1

コンストラクタの概要
DealManager()
メソッドの概要
abstract void | addDeal(Deal deal) 取扱情報を新規登録します。
abstract void | deleteDeal(Deal deal) 取扱情報を削除します。
abstract Deal | getDeal(String customerCompanyCode, String customerDepartmentCode, String dealCode) 指定された取扱情報を返します。
static DealManager | getDealManager(String user, String group) DealManagerを取得します。
abstract Deal[] | getDeals() 現在、存在する取扱情報を返します。
abstract Deal[] | getDeals(Date date) 指定された日付に存在する取扱情報を返します。
abstract Deal[] | getDealsByKey(String itemCode, String companyCode, String departmentCode) 現在、存在する取扱情報の中で、商品と取引先から特定されるものを返します。
abstract Deal[] | getDealsByKey(String itemCode, String companyCode, String departmentCode, Date date) 指定された日時に存在する取扱情報の中で、商品と取引先から特定されるものを返します。
abstract Deal[] | getUsersDeals(String userCode) 現在、ユーザがアクセスできる取扱情報を返します。
abstract Deal[] | getUsersDeals(String userCode, Date date) 指定された日付にユーザがアクセスできる取扱情報を返します。
abstract Deal[] | getUsersDealsByKey(String userCode, String itemCode, String companyCode, String departmentCode) 現在、存在する取扱情報の中で、商品と取引先から特定されるものを返します。
abstract Deal[] | getUsersDealsByKey(String userCode, String itemCode, String companyCode, String departmentCode, Date date) 指定された日時に存在する取扱情報の中で、商品と取引先から特定されるものを返します。
protected abstract void | init(String user, String group) DealManagerを初期化します。
abstract void | updateDeal(Deal deal) 取扱情報を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DealManager

public DealManager()
メソッドの詳細

getDealManager

public static DealManager getDealManager(String user,
                                         String group)
                                  throws ManagerException
DealManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するDealManager
例外:
ManagerException - DealManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
DealManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - 初期化に失敗

addDeal

public abstract void addDeal(Deal deal)
                      throws ManagerException
取扱情報を新規登録します。

パラメータ:
deal - 取扱情報
例外:
ManagerException - 取扱情報の登録に失敗した場合

updateDeal

public abstract void updateDeal(Deal deal)
                         throws ManagerException
取扱情報を更新します。

パラメータ:
deal - 取扱情報
例外:
ManagerException - 取扱情報の更新に失敗した場合

deleteDeal

public abstract void deleteDeal(Deal deal)
                         throws ManagerException
取扱情報を削除します。
指定された取扱情報が存在しない場合は ManagerException がスローされます。

パラメータ:
deal - 取扱情報
例外:
ManagerException - 取扱情報の削除に失敗した場合

getDeal

public abstract Deal getDeal(String customerCompanyCode,
                             String customerDepartmentCode,
                             String dealCode)
指定された取扱情報を返します。

戻り値:
取扱情報
例外:
ManagerException - 取扱情報の取得に失敗した場合

getDeals

public abstract Deal[] getDeals()
                         throws ManagerException
現在、存在する取扱情報を返します。

戻り値:
取扱情報
例外:
ManagerException - 取扱情報の取得に失敗した場合

getDeals

public abstract Deal[] getDeals(Date date)
                         throws ManagerException
指定された日付に存在する取扱情報を返します。

パラメータ:
date - 日付
戻り値:
取扱情報
例外:
ManagerException - 取扱情報の取得に失敗した場合

getDealsByKey

public abstract Deal[] getDealsByKey(String itemCode,
                                     String companyCode,
                                     String departmentCode)
                              throws ManagerException
現在、存在する取扱情報の中で、商品と取引先から特定されるものを返します。

パラメータ:
itemCode - 商品コード
companyCode - 会社コード
departmentCode - 組織コード
戻り値:
取扱情報
例外:
ManagerException - 取扱情報の取得に失敗した場合

getDealsByKey

public abstract Deal[] getDealsByKey(String itemCode,
                                     String companyCode,
                                     String departmentCode,
                                     Date date)
                              throws ManagerException
指定された日時に存在する取扱情報の中で、商品と取引先から特定されるものを返します。

パラメータ:
itemCode - 商品コード
companyCode - 会社コード
departmentCode - 組織コード
date - 日付
戻り値:
取扱情報
例外:
ManagerException - 取扱情報の取得に失敗した場合

getUsersDeals

public abstract Deal[] getUsersDeals(String userCode)
                              throws ManagerException
現在、ユーザがアクセスできる取扱情報を返します。

パラメータ:
userCode - ユーザコード
戻り値:
取扱情報
例外:
ManagerException - 取扱情報の取得に失敗した場合

getUsersDeals

public abstract Deal[] getUsersDeals(String userCode,
                                     Date date)
                              throws ManagerException
指定された日付にユーザがアクセスできる取扱情報を返します。

パラメータ:
userCode - ユーザコード
date - 日付
戻り値:
取扱情報
例外:
ManagerException - 取扱情報の取得に失敗した場合

getUsersDealsByKey

public abstract Deal[] getUsersDealsByKey(String userCode,
                                          String itemCode,
                                          String companyCode,
                                          String departmentCode)
                                   throws ManagerException
現在、存在する取扱情報の中で、商品と取引先から特定されるものを返します。

パラメータ:
userCode - ユーザコード
itemCode - 商品コード
companyCode - 会社コード
departmentCode - 組織コード
戻り値:
取扱情報
例外:
ManagerException - 取扱情報の取得に失敗した場合

getUsersDealsByKey

public abstract Deal[] getUsersDealsByKey(String userCode,
                                          String itemCode,
                                          String companyCode,
                                          String departmentCode,
                                          Date date)
                                   throws ManagerException
指定された日時に存在する取扱情報の中で、商品と取引先から特定されるものを返します。

パラメータ:
userCode - ユーザコード
itemCode - 商品コード
companyCode - 会社コード
departmentCode - 組織コード
date - 日付
戻り値:
取扱情報
例外:
ManagerException - 取扱情報の取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DealPermissionManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.deal
クラス DealPermissionManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager
public abstract class DealPermissionManager
extends Object

取扱情報に対するアクセス権を操作します。

導入されたバージョン:
5.1

コンストラクタの概要
DealPermissionManager()
メソッドの概要
static DealPermissionManager | getDealPermissionManager(String user, String group) DealPermissionManagerを取得します。
abstract Department[] | getDepartments(Deal deal) 取扱情報を保有するアクセス権をもつ組織を返します。
abstract PublicGroup[] | getPublicGroups(Deal deal) 取扱情報を保有するアクセス権をもつパブリックグループを返します。
abstract Role[] | getRoles(Deal deal) 取扱情報を保有するアクセス権をもつロールを返します。
protected abstract void | init(String user, String group) DealPermissionManagerを初期化します。
abstract void | removePermissionFromDepartment(DealerDepartment dealer) 組織からアクセス権を削除します。
abstract void | removePermissionFromPublicGroup(DealerPublicGroup dealer) パブリックグループからアクセス権を削除します。
abstract void | removePermissionFromRole(DealerRole dealer) ロールからアクセス権を削除します。
abstract void | setPermissionToDepartment(DealerDepartment dealer) 組織に対してアクセス権を設定します。
abstract void | setPermissionToPublicGroup(DealerPublicGroup dealer) パブリックグループに対してアクセス権を設定します。
abstract void | setPermissionToRole(DealerRole dealer) ロールに対してアクセス権を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DealPermissionManager

public DealPermissionManager()
メソッドの詳細

getDealPermissionManager

public static DealPermissionManager getDealPermissionManager(String user,
                                                             String group)
                                                      throws ManagerException
DealPermissionManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するDealPermissionManager
例外:
ManagerException - DealPermissionManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
DealPermissionManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - 初期化に失敗

setPermissionToDepartment

public abstract void setPermissionToDepartment(DealerDepartment dealer)
                                        throws ManagerException
組織に対してアクセス権を設定します。

パラメータ:
dealer - 組織アクセス権設定情報
例外:
ManagerException - アクセス権の設定に失敗した場合

setPermissionToPublicGroup

public abstract void setPermissionToPublicGroup(DealerPublicGroup dealer)
                                         throws ManagerException
パブリックグループに対してアクセス権を設定します。

パラメータ:
dealer - パブリックグループアクセス権設定情報
例外:
ManagerException - アクセス権の設定に失敗した場合

setPermissionToRole

public abstract void setPermissionToRole(DealerRole dealer)
                                  throws ManagerException
ロールに対してアクセス権を設定します。

パラメータ:
dealer - ロールアクセス権設定情報
例外:
ManagerException - アクセス権の設定に失敗した場合

removePermissionFromDepartment

public abstract void removePermissionFromDepartment(DealerDepartment dealer)
                                             throws ManagerException
組織からアクセス権を削除します。
指定されたアクセス権が存在しない場合は ManagerException がスローされます。

パラメータ:
dealer - 組織アクセス件設定情報
例外:
ManagerException - アクセス権の削除に失敗した場合

removePermissionFromPublicGroup

public abstract void removePermissionFromPublicGroup(DealerPublicGroup dealer)
                                              throws ManagerException
パブリックグループからアクセス権を削除します。
指定されたアクセス権が存在しない場合は ManagerException がスローされます。

パラメータ:
dealer - パブリックグループアクセス権設定情報
例外:
ManagerException - アクセス権の削除に失敗した場合

removePermissionFromRole

public abstract void removePermissionFromRole(DealerRole dealer)
                                       throws ManagerException
ロールからアクセス権を削除します。
指定されたアクセス権が存在しない場合は ManagerException がスローされます。

パラメータ:
dealer - ロールアクセス権設定情報
例外:
ManagerException - アクセス権の削除に失敗した場合

getDepartments

public abstract Department[] getDepartments(Deal deal)
                                     throws ManagerException
取扱情報を保有するアクセス権をもつ組織を返します。

パラメータ:
deal - 取扱情報
戻り値:
組織情報
例外:
ManagerException - 組織情報の取得に失敗した場合

getPublicGroups

public abstract PublicGroup[] getPublicGroups(Deal deal)
                                       throws ManagerException
取扱情報を保有するアクセス権をもつパブリックグループを返します。

パラメータ:
deal - 取扱情報
戻り値:
パブリックグループ情報
例外:
ManagerException - パブリックグループ情報の取得に失敗した場合

getRoles

public abstract Role[] getRoles(Deal deal)
                         throws ManagerException
取扱情報を保有するアクセス権をもつロールを返します。

パラメータ:
deal - 取扱情報
戻り値:
ロール情報
例外:
ManagerException - ロール情報の取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.deal (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.deal
クラス
DealManager
DealPermissionManager


jp.co.intra_mart.foundation.datastore.application.domain.deal (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal

取扱情報を操作するクラスを提供します。

参照:
説明

クラスの概要
DealManager | 取扱に関する情報を管理します。
DealPermissionManager | 取扱情報に対するアクセス権を操作します。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal の説明

取扱情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.deal クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal の使用

jp.co.intra_mart.foundation.datastore.application.domain.deal を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal 取扱情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal により使用される jp.co.intra_mart.foundation.datastore.application.domain.deal のクラス
DealManager
取扱に関する情報を管理します。
DealPermissionManager
取扱情報に対するアクセス権を操作します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute の使用

ItemAttribute を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item 商品情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item での ItemAttribute の使用

ItemAttribute を返す jp.co.intra_mart.foundation.datastore.application.domain.item のメソッド
abstract  ItemAttribute[] ItemManager.getAttributes(String itemCode)
指定された商品の属性情報を取得します。

ItemAttribute 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item のメソッド
abstract void | ItemManager.setAttribute(ItemAttribute attribute) 商品属性情報を設定します。
abstract void | ItemManager.removeAttribute(ItemAttribute attribute) 指定された商品属性情報を削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttributeInternational の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttributeInternational の使用

ItemAttributeInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item.attribute 商品属性情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item.attribute での ItemAttributeInternational の使用

ItemAttributeInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.item.attribute のメソッド
 ItemAttributeInternational ItemAttribute.getItemAttributeInternational(Locale locale)
指定された言語に対する国際化情報を取得します。

ItemAttributeInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item.attribute のメソッド
 void ItemAttribute.putInternational(Locale locale, ItemAttributeInternational data)
指定された言語に対する国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemAttribute (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item.attribute
クラス ItemAttribute

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute
すべての実装インタフェース:
Serializable
public class ItemAttribute
extends Object
implements Serializable

商品属性の基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemAttribute()
商品属性に関連する情報を新規に生成します。
ItemAttribute(Locale locale)
商品属性に関連する情報を新規に生成します。
メソッドの概要
Locale | getDefaultLocale() デフォルトのロケールを取得します。
ItemAttributeInternational | getItemAttributeInternational(Locale locale) 指定された言語に対する国際化情報を取得します。
String | getItemCode() 商品コードを取得します。
Locale[] | getLocales() この商品属性で管理している言語（ロケール）をすべて取得します。
double | getNumberValue() 属性数値を取得します。
String | getStringValue() 属性文字列を取得します。
String | getStringValue(Locale locale) 属性文字列を取得します。
String | getTemplateCode() テンプレートコードを取得します。
String | getTemplateDetailCode() テンプレート明細コードを取得します。
void | putInternational(Locale locale, ItemAttributeInternational data) 指定された言語に対する国際化情報を設定します。
void | removeInternational(Locale locale) 指定された言語に対する国際化情報を削除します。
void | setDefaultLocale(Locale defaultLocale) デフォルトのロケールを設定します。
void | setItemCode(String itemCode) 商品コードを設定します。
void | setNumberValue(double numberValue) 属性数値を設定します。
void | setTemplateCode(String templateCode) テンプレートコードを設定します。
void | setTemplateDetailCode(String templateDetailCode) テンプレート明細コードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemAttribute

public ItemAttribute()
商品属性に関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値の言語だけのロケールが割り当てられます。

ItemAttribute

public ItemAttribute(Locale locale)
商品属性に関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられます。

パラメータ:
locale - デフォルトの言語
メソッドの詳細

getDefaultLocale

public Locale getDefaultLocale()
デフォルトのロケールを取得します。

戻り値:
デフォルトのロケール

setDefaultLocale

public void setDefaultLocale(Locale defaultLocale)
デフォルトのロケールを設定します。

パラメータ:
defaultLocale - デフォルトのロケール

getLocales

public Locale[] getLocales()
この商品属性で管理している言語（ロケール）をすべて取得します。

戻り値:
この商品属性で管理している言語（ロケール）

getItemAttributeInternational

public ItemAttributeInternational getItemAttributeInternational(Locale locale)
指定された言語に対する国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
国際化情報

putInternational

public void putInternational(Locale locale,
                             ItemAttributeInternational data)
指定された言語に対する国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 国際化情報

removeInternational

public void removeInternational(Locale locale)
指定された言語に対する国際化情報を削除します。

パラメータ:
locale - 言語（ロケール）

getItemCode

public String getItemCode()
商品コードを取得します。

戻り値:
商品コード

setItemCode

public void setItemCode(String itemCode)
商品コードを設定します。

パラメータ:
itemCode - 商品コード

getTemplateCode

public String getTemplateCode()
テンプレートコードを取得します。

戻り値:
テンプレートコード

setTemplateCode

public void setTemplateCode(String templateCode)
テンプレートコードを設定します。

パラメータ:
templateCode - テンプレートコード

getTemplateDetailCode

public String getTemplateDetailCode()
テンプレート明細コードを取得します。

戻り値:
テンプレート明細コード

setTemplateDetailCode

public void setTemplateDetailCode(String templateDetailCode)
テンプレート明細コードを設定します。

パラメータ:
templateDetailCode - テンプレート明細コード

getNumberValue

public double getNumberValue()
属性数値を取得します。

戻り値:
属性数値

setNumberValue

public void setNumberValue(double numberValue)
属性数値を設定します。

パラメータ:
numberValue - 属性数値

getStringValue

public String getStringValue()
属性文字列を取得します。

戻り値:
属性文字列

getStringValue

public String getStringValue(Locale locale)
属性文字列を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
属性文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemAttributeInternational (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item.attribute
クラス ItemAttributeInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttributeInternational
すべての実装インタフェース:
Serializable
public class ItemAttributeInternational
extends Object
implements Serializable

商品属性の国際化属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemAttributeInternational()
メソッドの概要
String | getStringValue() 属性文字列を取得します。
void | setStringValue(String stringValue) 属性文字列を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemAttributeInternational

public ItemAttributeInternational()
メソッドの詳細

getStringValue

public String getStringValue()
属性文字列を取得します。

戻り値:
属性文字列
例外:
AccessorException - データの取得に失敗した場合

setStringValue

public void setStringValue(String stringValue)
属性文字列を設定します。

パラメータ:
stringValue - 属性文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.item.attribute (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.item.attribute
クラス
ItemAttribute
ItemAttributeInternational


jp.co.intra_mart.foundation.datastore.application.domain.item.attribute (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.attribute

商品属性情報を操作するクラスを提供します。

参照:
説明

クラスの概要
ItemAttribute | 商品属性の基本属性のデータを取り扱います。
ItemAttributeInternational | 商品属性の国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.attribute の説明

商品属性情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.item.attribute クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.attribute の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttributeInternational (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.attribute の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item.attribute の使用

jp.co.intra_mart.foundation.datastore.application.domain.item.attribute を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item | 商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item.attribute | 商品属性情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item により使用される jp.co.intra_mart.foundation.datastore.application.domain.item.attribute のクラス
ItemAttribute
商品属性の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.item.attribute により使用される jp.co.intra_mart.foundation.datastore.application.domain.item.attribute のクラス
ItemAttributeInternational
商品属性の国際化属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue の使用

ItemCatalogue を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item 商品情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item での ItemCatalogue の使用

ItemCatalogue を返す jp.co.intra_mart.foundation.datastore.application.domain.item のメソッド
abstract ItemCatalogue | ItemManager.getCatalogue(String itemCode, String catalogueCode) 指定されたカタログ情報を返します。
abstract ItemCatalogue[] | ItemManager.getCatalogues(String itemCode) 指定された商品のカタログ情報を返します。

ItemCatalogue 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item のメソッド
abstract void | ItemManager.setCatalogue(ItemCatalogue catalogue) 商品カタログ情報を設定します。
abstract void | ItemManager.setCatalogue(ItemCatalogue catalogue, byte[] byteStream) 商品カタログ情報を設定します。
abstract void | ItemManager.deleteCatalogue(ItemCatalogue catalogue) 商品カタログ情報を削除します。
abstract String | ItemManager.getCatalogueMediaFileName(ItemCatalogue catalogue) 商品カタログの媒体が保存されてるファイルパスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemCatalogue (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue
クラス ItemCatalogue

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue
すべての実装インタフェース:
Serializable
public class ItemCatalogue
extends Object
implements Serializable

商品カタログの基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemCatalogue()
メソッドの概要
String | getItemCatalogueCode() 商品カタログコードを取得します。
String | getItemCode() 商品コードを取得します。
String | getMedia() 媒体を取得します。
int | getMediaCls() 媒体種類を取得します。
String | getNotes() 備考を取得します。
int | getSortKey() ソートキーを取得します。
void | setItemCatalogueCode(String itemCatalogueCode) 商品カタログコードを設定します。
void | setItemCode(String itemCode) 商品コードを設定します。
void | setMedia(String media) 媒体を設定します。
void | setMediaCls(int mediaCls) 媒体種類を設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemCatalogue

public ItemCatalogue()
メソッドの詳細

getItemCode

public String getItemCode()
商品コードを取得します。

戻り値:
商品コード

setItemCode

public void setItemCode(String itemCode)
商品コードを設定します。

パラメータ:
itemCode - 商品コード

getItemCatalogueCode

public String getItemCatalogueCode()
商品カタログコードを取得します。

戻り値:
商品カタログコード

setItemCatalogueCode

public void setItemCatalogueCode(String itemCatalogueCode)
商品カタログコードを設定します。

パラメータ:
itemCatalogueCode - 商品カタログコード

getMediaCls

public int getMediaCls()
媒体種類を取得します。

戻り値:
媒体種類

setMediaCls

public void setMediaCls(int mediaCls)
媒体種類を設定します。

パラメータ:
mediaCls - 媒体種類

getMedia

public String getMedia()
媒体を取得します。

戻り値:
媒体

setMedia

public void setMedia(String media)
媒体を設定します。

パラメータ:
media - 媒体

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue
クラス
ItemCatalogue


jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue

商品カタログ情報を操作するクラスを提供します。

参照:
説明

クラスの概要
ItemCatalogue 商品カタログの基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue の説明

商品カタログ情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue の使用

jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item 商品情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item により使用される jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue のクラス
ItemCatalogue
商品カタログの基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.item.ItemCatalogueMediaManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.item.ItemCatalogueMediaManager の使用

ItemCatalogueMediaManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item 商品情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item での ItemCatalogueMediaManager の使用

ItemCatalogueMediaManager 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item のメソッド
abstract  void ItemManager.setItemCatalogueMediaManager(ItemCatalogueMediaManager catalogueMediaManager)
商品カタログの媒体のマネジャーを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.item.ItemImporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.item.ItemImporter の使用

ItemImporter を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item 商品情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item での ItemImporter の使用

ItemImporter を実装している jp.co.intra_mart.foundation.datastore.application.domain.item のクラス
 class StandardItemImporter
商品のインポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager の使用

ItemManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item 商品情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item での ItemManager の使用

ItemManager を返す jp.co.intra_mart.foundation.datastore.application.domain.item のメソッド
static ItemManager ItemManager.getItemManager(String user, String group)
ItemManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item.StandardItemImporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item.StandardItemImporter の使用

jp.co.intra_mart.foundation.datastore.application.domain.item.StandardItemImporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item の使用

Item を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item | 商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category | 商品カテゴリ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item での Item の使用

Item を返す jp.co.intra_mart.foundation.datastore.application.domain.item のメソッド
abstract Item[] | ItemManager.getItems() 現在、存在する商品の情報を返します。
abstract Item[] | ItemManager.getItems(Date date) 指定された日付に存在する商品の情報を返します。
abstract Item | ItemManager.getItem(String itemCode) 指定された商品コードに対する商品の情報を返します。
abstract Item[] | ItemManager.getItemsByKey(String code, String name) 現在、条件に合致する商品の情報を返します。
abstract Item[] | ItemManager.getItemsByKey(String code, String name, Date date) 指定された日付に条件に合致する商品の情報を返します。

Item 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item のメソッド
abstract void | ItemManager.addItem(Item item) 商品情報を新規登録します。
abstract void | ItemManager.updateItem(Item item) 商品情報を更新します。
abstract void | ItemManager.deleteItem(Item item) 商品情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.item_category での Item の使用

Item を返す jp.co.intra_mart.foundation.datastore.application.domain.item_category のメソッド
abstract Item[] | ItemCategoryManager.getCategorizedItems(String categoryTypeCode, String categoryCode) 商品カテゴリに分類されている商品の情報を返します。
abstract Item[] | ItemCategoryManager.getAllCategorizedItems(String categoryTypeCode, String categoryCode) 商品カテゴリに分類されているすべての商品の情報を返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable の使用

ItemTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item.item 商品情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item.item での ItemTerminable の使用

ItemTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.item.item のメソッド
ItemTerminable | Item.getItemTerminable(Term term) 指定された期間に対する期間化情報を取得します。
ItemTerminable | Item.getItemTerminable(Date date) 指定された日時に対する期間化情報を取得します。

ItemTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item.item のメソッド
 void Item.putItemTerminable(Term term, ItemTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminableInternational の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminableInternational の使用

ItemTerminableInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item.item 商品情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item.item での ItemTerminableInternational の使用

ItemTerminableInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.item.item のメソッド
 ItemTerminableInternational ItemTerminable.getItemTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。

ItemTerminableInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item.item のメソッド
 void ItemTerminable.putItemTerminableInternational(Locale locale, ItemTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Item (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item.item
クラス Item

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item
すべての実装インタフェース:
Serializable
public class Item
extends Object
implements Serializable

商品の基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
Item()
商品に関連する情報を新規に生成します。
Item(Date date)
商品に関連する情報を新規に生成します。
Item(Locale locale)
商品に関連する情報を新規に生成します。
Item(Locale locale, Date date)
商品に関連する情報を新規に生成します。
メソッドの概要
Date | getDefaultDate() デフォルトの日時を取得します。
Locale | getDefaultLocale() デフォルトのロケールを取得します。
String | getItemCaption() 商品通称を取得します。
String | getItemCaption(Date date) 商品通称を取得します。
String | getItemCaption(Date date, Locale locale) 商品通称を取得します。
String | getItemCaption(Locale locale) 商品通称を取得します。
String | getItemCode() 商品コードを取得します。
String | getItemName() 商品名を取得します。
String | getItemName(Date date) 商品名を取得します。
String | getItemName(Date date, Locale locale) 商品名を取得します。
String | getItemName(Locale locale) 商品名を取得します。
ItemTerminable | getItemTerminable(Date date) 指定された日時に対する期間化情報を取得します。
ItemTerminable | getItemTerminable(Term term) 指定された期間に対する期間化情報を取得します。
String | getNotes() 備考を取得します。
String | getProductModelCode() 製品型番を取得します。
double | getPurchaseUnitPrice() 仕入単価を取得します。
double | getPurchaseUnitPrice(Date date) 仕入単価を取得します。
double | getSalesUnitPrice() 販売単価を取得します。
double | getSalesUnitPrice(Date date) 販売単価を取得します。
Term[] | getTerms() この商品で管理している期間をすべて取得します。
void | putItemTerminable(Term term, ItemTerminable data) 指定された期間に対する期間化情報を設定します。
void | removeItemTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setDefaultLocale(Locale defaultLocale) デフォルトのロケールを設定します。
void | setItemCode(String itemCode) 商品コードを設定します。
void | setNotes(String notes) 備考を設定します。
void | setProductModelCode(String productModelCode) 製品型番を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Item

public Item()
商品に関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

Item

public Item(Locale locale)
商品に関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

パラメータ:
locale - デフォルトの言語

Item

public Item(Date date)
商品に関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時

Item

public Item(Locale locale,
            Date date)
商品に関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
locale - デフォルトの言語
date - デフォルトの日時
メソッドの詳細

getDefaultLocale

public Locale getDefaultLocale()
デフォルトのロケールを取得します。

戻り値:
デフォルトのロケール

setDefaultLocale

public void setDefaultLocale(Locale defaultLocale)
デフォルトのロケールを設定します。

パラメータ:
defaultLocale - デフォルトのロケール

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
この商品で管理している期間をすべて取得します。

戻り値:
この商品で管理している期間

getItemTerminable

public ItemTerminable getItemTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getItemTerminable

public ItemTerminable getItemTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putItemTerminable

public void putItemTerminable(Term term,
                              ItemTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removeItemTerminable

public void removeItemTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getItemCode

public String getItemCode()
商品コードを取得します。

戻り値:
商品コード

setItemCode

public void setItemCode(String itemCode)
商品コードを設定します。

パラメータ:
itemCode - 商品コード

getProductModelCode

public String getProductModelCode()
製品型番を取得します。

戻り値:
製品型番

setProductModelCode

public void setProductModelCode(String productModelCode)
製品型番を設定します。

パラメータ:
productModelCode - 製品型番

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSalesUnitPrice

public double getSalesUnitPrice()
販売単価を取得します。

戻り値:
販売単価

getSalesUnitPrice

public double getSalesUnitPrice(Date date)
販売単価を取得します。

パラメータ:
date - 日時
戻り値:
販売単価

getPurchaseUnitPrice

public double getPurchaseUnitPrice()
仕入単価を取得します。

戻り値:
仕入単価

getPurchaseUnitPrice

public double getPurchaseUnitPrice(Date date)
仕入単価を取得します。

パラメータ:
date - 日時
戻り値:
仕入単価

getItemName

public String getItemName()
商品名を取得します。

戻り値:
商品名

getItemName

public String getItemName(Date date)
商品名を取得します。

パラメータ:
date - 日時
戻り値:
商品名

getItemName

public String getItemName(Locale locale)
商品名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
商品名

getItemName

public String getItemName(Date date,
                          Locale locale)
商品名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
商品名

getItemCaption

public String getItemCaption()
商品通称を取得します。

戻り値:
商品通称

getItemCaption

public String getItemCaption(Date date)
商品通称を取得します。

パラメータ:
date - 日時
戻り値:
商品通称

getItemCaption

public String getItemCaption(Locale locale)
商品通称を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
商品通称

getItemCaption

public String getItemCaption(Date date,
                             Locale locale)
商品通称を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
商品通称
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemTerminable (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item.item
クラス ItemTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable
すべての実装インタフェース:
Serializable
public class ItemTerminable
extends Object
implements Serializable

商品の期間化属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemTerminable()
メソッドの概要
ItemTerminableInternational | getItemTerminableInternational(Locale locale) 指定された言語に対する期間国際化情報を取得します。
Locale[] | getLocales() この商品で管理している言語（ロケール）をすべて取得します。
double | getPurchaseUnitPrice() 仕入単価を取得します。
double | getSalesUnitPrice() 販売単価を取得します。
void | putItemTerminableInternational(Locale locale, ItemTerminableInternational data) 指定された言語に対する期間国際化情報を設定します。
void | setPurchaseUnitPrice(double purchaseUnitPrice) 仕入単価を設定します。
void | setSalesUnitPrice(double salesUnitPrice) 販売単価を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemTerminable

public ItemTerminable()
メソッドの詳細

getLocales

public Locale[] getLocales()
この商品で管理している言語（ロケール）をすべて取得します。

戻り値:
この商品で管理している言語（ロケール）

getItemTerminableInternational

public ItemTerminableInternational getItemTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
期間国際化情報

putItemTerminableInternational

public void putItemTerminableInternational(Locale locale,
                                           ItemTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 期間国際化情報

getSalesUnitPrice

public double getSalesUnitPrice()
販売単価を取得します。

戻り値:
販売単価

setSalesUnitPrice

public void setSalesUnitPrice(double salesUnitPrice)
販売単価を設定します。

パラメータ:
salesUnitPrice - 販売単価

getPurchaseUnitPrice

public double getPurchaseUnitPrice()
仕入単価を取得します。

戻り値:
仕入単価

setPurchaseUnitPrice

public void setPurchaseUnitPrice(double purchaseUnitPrice)
仕入単価を設定します。

パラメータ:
purchaseUnitPrice - 仕入単価
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ItemTerminableInternational (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item.item
クラス ItemTerminableInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminableInternational
すべての実装インタフェース:
Serializable
public class ItemTerminableInternational
extends Object
implements Serializable

商品の期間国際化属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemTerminableInternational()
メソッドの概要
String | getItemCaption() 商品通称を取得します。
String | getItemName() 商品名を取得します。
void | setItemCaption(String itemCaption) 商品通称を設定します。
void | setItemName(String itemName) 商品名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemTerminableInternational

public ItemTerminableInternational()
メソッドの詳細

getItemName

public String getItemName()
商品名を取得します。

戻り値:
商品名
例外:
AccessorException - データの取得に失敗した場合

setItemName

public void setItemName(String itemName)
商品名を設定します。

パラメータ:
itemName - 商品名

getItemCaption

public String getItemCaption()
商品通称を取得します。

戻り値:
商品通称
例外:
AccessorException - データの取得に失敗した場合

setItemCaption

public void setItemCaption(String itemCaption)
商品通称を設定します。

パラメータ:
itemCaption - 商品通称
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.item.item (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.item.item
クラス
Item
ItemTerminable
ItemTerminableInternational


jp.co.intra_mart.foundation.datastore.application.domain.item.item (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.item

商品情報を操作するクラスを提供します。

参照:
説明

クラスの概要
Item | 商品の基本属性のデータを取り扱います。
ItemTerminable | 商品の期間化属性のデータを取り扱います。
ItemTerminableInternational | 商品の期間国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.item の説明

商品情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.item.item クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.item の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminableInternational (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.item の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item.item の使用

jp.co.intra_mart.foundation.datastore.application.domain.item.item を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item | 商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item.item | 商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category | 商品カテゴリ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item により使用される jp.co.intra_mart.foundation.datastore.application.domain.item.item のクラス
Item
商品の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.item.item により使用される jp.co.intra_mart.foundation.datastore.application.domain.item.item のクラス
ItemTerminable
商品の期間化属性のデータを取り扱います。
ItemTerminableInternational
商品の期間国際化属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.item_category により使用される jp.co.intra_mart.foundation.datastore.application.domain.item.item のクラス
Item
商品の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemCatalogueMediaManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item
インタフェース ItemCatalogueMediaManager

public interface ItemCatalogueMediaManager

商品カタログの媒体情報を管理するクラスです。

導入されたバージョン:
5.1

メソッドの概要
void | delete(String filePath) 商品カタログの媒体情報を削除します。
void | save(String filePath, byte[] byteString) 商品カタログの媒体情報を保存します。

メソッドの詳細

save

public void save(String filePath,
                 byte[] byteString)
          throws ManagerException
商品カタログの媒体情報を保存します。

パラメータ:
filePath - 媒体情報を保存するファイルパス
byteString - 媒体情報のバイト配列
例外:
ManagerException - 媒体情報の保存に失敗した場合

delete

public void delete(String filePath)
            throws ManagerException
商品カタログの媒体情報を削除します。

指定されたファイルが存在しないときは、何もしません。

パラメータ:
filePath - 削除する媒体のファイルのパス
例外:
ManagerException - 媒体情報の削除に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemImporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item
インタフェース ItemImporter

既知の実装クラスの一覧:
StandardItemImporter
public interface ItemImporter

商品のインポートのインターフェースです。

導入されたバージョン:
5.1

メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。

メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item
クラス ItemManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager
public abstract class ItemManager
extends Object

商品に関する情報を管理します。 このクラスのインスタンスは必ず getItemManager(String, String) で取得してください。

導入されたバージョン:
5.1

コンストラクタの概要
ItemManager()
メソッドの概要
abstract void | addItem(Item item) 商品情報を新規登録します。
abstract void | deleteCatalogue(ItemCatalogue catalogue) 商品カタログ情報を削除します。
abstract void | deleteItem(Item item) 商品情報を削除します。
abstract ItemAttribute[] | getAttributes(String itemCode) 指定された商品の属性情報を取得します。
abstract ItemCatalogue | getCatalogue(String itemCode, String catalogueCode) 指定されたカタログ情報を返します。
abstract String | getCatalogueMediaFileName(ItemCatalogue catalogue) 商品カタログの媒体が保存されてるファイルパスを取得します。
abstract ItemCatalogue[] | getCatalogues(String itemCode) 指定された商品のカタログ情報を返します。
abstract Item | getItem(String itemCode) 指定された商品コードに対する商品の情報を返します。
static ItemManager | getItemManager(String user, String group) ItemManagerを取得します。
abstract Item[] | getItems() 現在、存在する商品の情報を返します。
abstract Item[] | getItems(Date date) 指定された日付に存在する商品の情報を返します。
abstract Item[] | getItemsByKey(String code, String name) 現在、条件に合致する商品の情報を返します。
abstract Item[] | getItemsByKey(String code, String name, Date date) 指定された日付に条件に合致する商品の情報を返します。
protected abstract void | init(String user, String group) ItemManagerを初期化します。
abstract void | removeAttribute(ItemAttribute attribute) 指定された商品属性情報を削除します。
abstract void | setAttribute(ItemAttribute attribute) 商品属性情報を設定します。
abstract void | setCatalogue(ItemCatalogue catalogue) 商品カタログ情報を設定します。
abstract void | setCatalogue(ItemCatalogue catalogue, byte[] byteStream) 商品カタログ情報を設定します。
abstract void | setItemCatalogueMediaManager(ItemCatalogueMediaManager catalogueMediaManager) 商品カタログの媒体のマネジャーを設定します。
abstract void | updateItem(Item item) 商品情報を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemManager

public ItemManager()
メソッドの詳細

getItemManager

public static ItemManager getItemManager(String user,
                                         String group)
                                  throws ManagerException
ItemManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するItemManager
例外:
ManagerException - ItemManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
ItemManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - 初期化に失敗

addItem

public abstract void addItem(Item item)
                      throws ManagerException
商品情報を新規登録します。
商品情報には、期間情報と期間国際化情報を設定してください。
もし設定されてないものがある場合は、 ManagerException をスローします。

商品の期間は、途切れることができません。
期間に途切れがある場合は、 ManagerException をスローします。

パラメータ:
item - 商品情報
例外:
ManagerException - 商品情報の登録に失敗した場合

updateItem

public abstract void updateItem(Item item)
                         throws ManagerException
商品情報を更新します。
商品情報には、期間情報と期間国際化情報を設定してください。
もし設定されてないものがある場合は、 ManagerException をスローします。

商品の期間は、途切れることができません。
期間に途切れがある場合は、 ManagerException をスローします。

パラメータ:
item - 商品情報
例外:
ManagerException - 商品情報の更新に失敗した場合

deleteItem

public abstract void deleteItem(Item item)
                         throws ManagerException
商品情報を削除します。
指定された商品情報が存在しない場合は ManagerException がスローされます。

パラメータ:
item - 商品情報
例外:
ManagerException - 商品情報の削除に失敗した場合

setCatalogue

public abstract void setCatalogue(ItemCatalogue catalogue)
                           throws ManagerException
商品カタログ情報を設定します。

パラメータ:
catalogue - 商品カタログ情報
例外:
ManagerException - 商品カタログ情報の設定に失敗した場合

setCatalogue

public abstract void setCatalogue(ItemCatalogue catalogue,
                                  byte[] byteStream)
                           throws ManagerException
商品カタログ情報を設定します。 ItemCatalogue.getMediaCls() の値が "file" の時に、バイト配列を ItemCatalogue.getMedia() をファイルに出力します。
バイト配列がnullの時は空のファイルを作成します。
媒体種類がURLの時は、バイトを配列を無視します。
媒体種類がファイルからURLに変更される時は、ストレージ上にあるファイルは削除されます。

パラメータ:
catalogue - 商品カタログ情報
byteStream - 出力するバイト配列
例外:
ManagerException - 商品カタログ情報の設定に失敗した場合

deleteCatalogue

public abstract void deleteCatalogue(ItemCatalogue catalogue)
                              throws ManagerException
商品カタログ情報を削除します。
指定されたカタログ情報が存在しない場合は ManagerException がスローされます。

パラメータ:
catalogue - 商品カタログ情報
例外:
ManagerException - 商品カタログ情報の削除に失敗した場合

getCatalogueMediaFileName

public abstract String getCatalogueMediaFileName(ItemCatalogue catalogue)
                                          throws ManagerException
商品カタログの媒体が保存されてるファイルパスを取得します。

商品カタログの媒体種類がファイルの時のみ有効です。
ファイルパスの区切りは'/'です。
媒体種類がファイル以外の時はnullを返します。

パラメータ:
catalogue - 商品カタログ
戻り値:
商品カタログの媒体が保存されているファイルパス
例外:
ManagerException - ファイルパスの取得に失敗した場合

setItemCatalogueMediaManager

public abstract void setItemCatalogueMediaManager(ItemCatalogueMediaManager catalogueMediaManager)
                                           throws ManagerException
商品カタログの媒体のマネジャーを設定します。

パラメータ:
catalogueMediaManager - 商品カタログの媒体マネジャー
例外:
ManagerException - 媒体の設定に失敗した場合

getItems

public abstract Item[] getItems()
                         throws ManagerException
現在、存在する商品の情報を返します。

指定された商品の情報が存在しない場合は、空の配列を返します。

戻り値:
商品情報
例外:
商品情報の取得に失敗した場合
ManagerException

getItems

public abstract Item[] getItems(Date date)
                         throws ManagerException
指定された日付に存在する商品の情報を返します。

指定された商品の情報が存在しない場合は、空の配列を返します。

パラメータ:
date - 日付
戻り値:
商品情報
例外:
商品情報の取得に失敗した場合
ManagerException

getItem

public abstract Item getItem(String itemCode)
                      throws ManagerException
指定された商品コードに対する商品の情報を返します。

パラメータ:
itemCode - 商品コード
戻り値:
商品情報
例外:
商品情報の取得に失敗した場合
ManagerException

getItemsByKey

public abstract Item[] getItemsByKey(String code,
                                     String name)
                              throws ManagerException
現在、条件に合致する商品の情報を返します。

検索キーは、コードは商品コード、製品型番に対して使用されます。名称は商品名、商品略称に対して使用されます。
指定された商品の情報が存在しない場合は、空の配列を返します。

パラメータ:
code - コードの検索キー
name - 名称の検索キー
戻り値:
商品情報
例外:
商品情報の取得に失敗した場合
ManagerException

getItemsByKey

public abstract Item[] getItemsByKey(String code,
                                     String name,
                                     Date date)
                              throws ManagerException
指定された日付に条件に合致する商品の情報を返します。

検索キーは、コードは商品コード、製品型番に対して使用されます。名称は商品名、商品略称に対して使用されます。
指定された商品の情報が存在しない場合は、空の配列を返します。

パラメータ:
code - コードの検索キー
name - 名称の検索キー
戻り値:
商品情報
例外:
商品情報の取得に失敗した場合
ManagerException

getCatalogue

public abstract ItemCatalogue getCatalogue(String itemCode,
                                           String catalogueCode)
                                    throws ManagerException
指定されたカタログ情報を返します。
カタログ情報が存在しない場合はnullを返します。

パラメータ:
itemCode - 商品コード
catalogueCode - カタログコード
戻り値:
カタログ情報
例外:
商品カタログ情報の取得に失敗した場合
ManagerException

getCatalogues

public abstract ItemCatalogue[] getCatalogues(String itemCode)
                                       throws ManagerException
指定された商品のカタログ情報を返します。
カタログ情報が見つからない場合は空の配列を返します。

パラメータ:
itemCode - 商品コード
戻り値:
カタログ情報
例外:
商品カタログ情報の取得に失敗した場合
ManagerException

setAttribute

public abstract void setAttribute(ItemAttribute attribute)
                           throws ManagerException
商品属性情報を設定します。

指定された商品属性情報が存在しない場合は新規登録します。商品属性情報すでに存在する場合は更新を行います。

このメソッドでは、複数の商品属性テンプレートの属性情報を設定することはできません。 もし登録済みのものとは異なる商品属性テンプレートの属性情報が指定された場合は、 ManagerException をスローします。

パラメータ:
attribute - 商品属性情報
例外:
商品属性情報の設定に失敗した場合
ManagerException

removeAttribute

public abstract void removeAttribute(ItemAttribute attribute)
                              throws ManagerException
指定された商品属性情報を削除します。
指定された属性情報が存在しない場合は ManagerException がスローされます。

パラメータ:
attribute - 商品属性情報
例外:
商品属性情報の削除に失敗した場合
ManagerException

getAttributes

public abstract ItemAttribute[] getAttributes(String itemCode)
                                       throws ManagerException
指定された商品の属性情報を取得します。

パラメータ:
itemCode - 商品コード
戻り値:
商品属性情報の一覧
例外:
商品属性情報の取得に失敗した場合
ManagerException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.item (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.item
インタフェース
ItemCatalogueMediaManager
ItemImporter
クラス
ItemManager
StandardItemImporter


jp.co.intra_mart.foundation.datastore.application.domain.item (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item

商品情報を操作するクラスを提供します。

参照:
説明

インタフェースの概要
ItemCatalogueMediaManager | 商品カタログの媒体情報を管理するクラスです。
ItemImporter | 商品のインポートのインターフェースです。

クラスの概要
ItemManager | 商品に関する情報を管理します。
StandardItemImporter | 商品のインポートを行います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item の説明

商品情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.item クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.StandardItemImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.item.ItemImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.application.domain.item.ItemCatalogueMediaManager
  • interface jp.co.intra_mart.foundation.datastore.application.domain.item.ItemImporter


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item の使用

jp.co.intra_mart.foundation.datastore.application.domain.item を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item 商品情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item により使用される jp.co.intra_mart.foundation.datastore.application.domain.item のクラス
ItemCatalogueMediaManager
商品カタログの媒体情報を管理するクラスです。
ItemImporter
商品のインポートのインターフェースです。
ItemManager
商品に関する情報を管理します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardItemImporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item
クラス StandardItemImporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item.StandardItemImporter
すべての実装インタフェース:
ItemImporter
public class StandardItemImporter
extends Object
implements ItemImporter

商品のインポートを行います。

導入されたバージョン:
5.1

コンストラクタの概要
StandardItemImporter()
メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardItemImporter

public StandardItemImporter()
メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

定義:
インタフェース ItemImporter 内の doImport
パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach の使用

ItemAttach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category 商品カテゴリ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_category での ItemAttach の使用

ItemAttach 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item_category のメソッド
abstract void | ItemCategoryManager.setItem(ItemAttach attach) 商品カテゴリに商品を設定します。
abstract void | ItemCategoryManager.removeItem(ItemAttach attach) 商品カテゴリから商品を外します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemAttach (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach
クラス ItemAttach

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach
すべての実装インタフェース:
Serializable
public class ItemAttach
extends Object
implements Serializable

商品分類の基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemAttach()
メソッドの概要
String | getItemCategoryCode() 商品カテゴリコードを取得します。
String | getItemCategoryTypeCode() 商品カテゴリ種別コードを取得します。
String | getItemCode() 商品コードを取得します。
void | setItemCategoryCode(String itemCategoryCode) 商品カテゴリコードを設定します。
void | setItemCategoryTypeCode(String itemCategoryTypeCode) 商品カテゴリ種別コードを設定します。
void | setItemCode(String itemCode) 商品コードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemAttach

public ItemAttach()
メソッドの詳細

getItemCategoryTypeCode

public String getItemCategoryTypeCode()
商品カテゴリ種別コードを取得します。

戻り値:
商品カテゴリ種別コード

setItemCategoryTypeCode

public void setItemCategoryTypeCode(String itemCategoryTypeCode)
商品カテゴリ種別コードを設定します。

パラメータ:
itemCategoryTypeCode - 商品カテゴリ種別コード

getItemCategoryCode

public String getItemCategoryCode()
商品カテゴリコードを取得します。

戻り値:
商品カテゴリコード

setItemCategoryCode

public void setItemCategoryCode(String itemCategoryCode)
商品カテゴリコードを設定します。

パラメータ:
itemCategoryCode - 商品カテゴリコード

getItemCode

public String getItemCode()
商品コードを取得します。

戻り値:
商品コード

setItemCode

public void setItemCode(String itemCode)
商品コードを設定します。

パラメータ:
itemCode - 商品コード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach
クラス
ItemAttach


jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach

商品分類情報を操作するクラスを提供します。

参照:
説明

クラスの概要
ItemAttach 商品分類の基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach の説明

商品分類情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach の使用

jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category 商品カテゴリ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_category により使用される jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach のクラス
ItemAttach
商品分類の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory の使用

ItemCategory を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category 商品カテゴリ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_category での ItemCategory の使用

ItemCategory を返す jp.co.intra_mart.foundation.datastore.application.domain.item_category のメソッド
ItemCategory | ItemCategoryStruct.getItemCateogry() 商品カテゴリを取得します。
abstract ItemCategory[] | ItemCategoryManager.getCategoryTypes() 登録済の商品カテゴリ種別の一覧を返します。
abstract ItemCategory | ItemCategoryManager.getCategory(String categoryTypeCode, String categoryCode) 指定されたカテゴリコードに対する商品カテゴリの情報を返します。

ItemCategory 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item_category のメソッド
abstract void | ItemCategoryManager.addCategory(ItemCategory category) 商品カテゴリを新規登録します。
abstract void | ItemCategoryManager.updateCategory(ItemCategory category) 商品カテゴリを更新します。
abstract void | ItemCategoryManager.deleteCategory(ItemCategory category) 商品カテゴリを削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategoryInternational の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategoryInternational の使用

ItemCategoryInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category.category 商品カテゴリ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_category.category での ItemCategoryInternational の使用

ItemCategoryInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.item_category.category のメソッド
 ItemCategoryInternational ItemCategory.getItemCategoryInternational(Locale locale)
指定された言語に対する国際化情報を取得します。

ItemCategoryInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item_category.category のメソッド
 void ItemCategory.putInternational(Locale locale, ItemCategoryInternational data)
指定された言語に対する国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemCategory (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_category.category
クラス ItemCategory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory
すべての実装インタフェース:
Serializable
public class ItemCategory
extends Object
implements Serializable

商品カテゴリの基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemCategory()
商品カテゴリに関連する情報を新規に生成します。
ItemCategory(Locale locale)
商品カテゴリに関連する情報を新規に生成します。
メソッドの概要
Locale | getDefaultLocale() デフォルトのロケールを取得します。
String | getItemCategoryCode() 商品カテゴリコードを取得します。
ItemCategoryInternational | getItemCategoryInternational(Locale locale) 指定された言語に対する国際化情報を取得します。
String | getItemCategoryName() 商品カテゴリ名を取得します。
String | getItemCategoryName(Locale locale) 商品カテゴリ名を取得します。
String | getItemCategoryTypeCode() 商品カテゴリ種別コードを取得します。
Locale[] | getLocales() この商品カテゴリで管理している言語（ロケール）をすべて取得します。
String | getNotes() 備考を取得します。
String | getParentItemCategoryCode() 親商品カテゴリコードを取得します。
int | getSortKey() ソートキーを取得します。
void | putInternational(Locale locale, ItemCategoryInternational data) 指定された言語に対する国際化情報を設定します。
void | removeInternational(Locale locale) 指定された言語に対する国際化情報を削除します。
void | setDefaultLocale(Locale defaultLocale) デフォルトのロケールを設定します。
void | setItemCategoryCode(String itemCategoryCode) 商品カテゴリコードを設定します。
void | setItemCategoryTypeCode(String itemCategoryTypeCode) 商品カテゴリ種別コードを設定します。
void | setNotes(String notes) 備考を設定します。
void | setParentItemCategoryCode(String parentItemCategoryCode) 親商品カテゴリコードを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemCategory

public ItemCategory()
商品カテゴリに関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値の言語だけのロケールが割り当てられます。

ItemCategory

public ItemCategory(Locale locale)
商品カテゴリに関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられます。

パラメータ:
locale - デフォルトの言語
メソッドの詳細

getDefaultLocale

public Locale getDefaultLocale()
デフォルトのロケールを取得します。

戻り値:
デフォルトのロケール

setDefaultLocale

public void setDefaultLocale(Locale defaultLocale)
デフォルトのロケールを設定します。

パラメータ:
defaultLocale - デフォルトのロケール

getLocales

public Locale[] getLocales()
この商品カテゴリで管理している言語（ロケール）をすべて取得します。

戻り値:
この商品カテゴリで管理している言語（ロケール）

getItemCategoryInternational

public ItemCategoryInternational getItemCategoryInternational(Locale locale)
指定された言語に対する国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
国際化情報

putInternational

public void putInternational(Locale locale,
                             ItemCategoryInternational data)
指定された言語に対する国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 国際化情報

removeInternational

public void removeInternational(Locale locale)
指定された言語に対する国際化情報を削除します。

パラメータ:
locale - 言語（ロケール）

getItemCategoryTypeCode

public String getItemCategoryTypeCode()
商品カテゴリ種別コードを取得します。

戻り値:
商品カテゴリ種別コード

setItemCategoryTypeCode

public void setItemCategoryTypeCode(String itemCategoryTypeCode)
商品カテゴリ種別コードを設定します。

パラメータ:
itemCategoryTypeCode - 商品カテゴリ種別コード

getItemCategoryCode

public String getItemCategoryCode()
商品カテゴリコードを取得します。

戻り値:
商品カテゴリコード

setItemCategoryCode

public void setItemCategoryCode(String itemCategoryCode)
商品カテゴリコードを設定します。

パラメータ:
itemCategoryCode - 商品カテゴリコード

getParentItemCategoryCode

public String getParentItemCategoryCode()
親商品カテゴリコードを取得します。

戻り値:
親商品カテゴリコード

setParentItemCategoryCode

public void setParentItemCategoryCode(String parentItemCategoryCode)
親商品カテゴリコードを設定します。

パラメータ:
parentItemCategoryCode - 親商品カテゴリコード

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー

getItemCategoryName

public String getItemCategoryName()
商品カテゴリ名を取得します。

戻り値:
商品カテゴリ名

getItemCategoryName

public String getItemCategoryName(Locale locale)
商品カテゴリ名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
商品カテゴリ名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemCategoryInternational (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_category.category
クラス ItemCategoryInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategoryInternational
すべての実装インタフェース:
Serializable
public class ItemCategoryInternational
extends Object
implements Serializable

商品カテゴリの国際化属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemCategoryInternational()
メソッドの概要
String | getItemCategoryName() 商品カテゴリ名を取得します。
void | setItemCategoryName(String itemCategoryName) 商品カテゴリ名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemCategoryInternational

public ItemCategoryInternational()
メソッドの詳細

getItemCategoryName

public String getItemCategoryName()
商品カテゴリ名を取得します。

戻り値:
商品カテゴリ名
例外:
AccessorException - データの取得に失敗した場合

setItemCategoryName

public void setItemCategoryName(String itemCategoryName)
商品カテゴリ名を設定します。

パラメータ:
itemCategoryName - 商品カテゴリ名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.item_category.category (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.item_category.category
クラス
ItemCategory
ItemCategoryInternational


jp.co.intra_mart.foundation.datastore.application.domain.item_category.category (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.category

商品カテゴリ情報を操作するクラスを提供します。

参照:
説明

クラスの概要
ItemCategory | 商品カテゴリの基本属性のデータを取り扱います。
ItemCategoryInternational | 商品カテゴリの国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.category の説明

商品カテゴリ情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.item_category.category クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.category の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategoryInternational (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.category の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category.category の使用

jp.co.intra_mart.foundation.datastore.application.domain.item_category.category を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category | 商品カテゴリ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category.category | 商品カテゴリ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_category により使用される jp.co.intra_mart.foundation.datastore.application.domain.item_category.category のクラス
ItemCategory
商品カテゴリの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.item_category.category により使用される jp.co.intra_mart.foundation.datastore.application.domain.item_category.category のクラス
ItemCategoryInternational
商品カテゴリの国際化属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemAttachImporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemAttachImporter の使用

ItemAttachImporter を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category 商品カテゴリ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_category での ItemAttachImporter の使用

ItemAttachImporter を実装している jp.co.intra_mart.foundation.datastore.application.domain.item_category のクラス
 class StandardItemAttachImporter
商品分類のインポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryImporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryImporter の使用

ItemCategoryImporter を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category 商品カテゴリ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_category での ItemCategoryImporter の使用

ItemCategoryImporter を実装している jp.co.intra_mart.foundation.datastore.application.domain.item_category のクラス
 class StandardItemCategoryImporter
商品カテゴリのインポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager の使用

ItemCategoryManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category 商品カテゴリ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_category での ItemCategoryManager の使用

ItemCategoryManager を返す jp.co.intra_mart.foundation.datastore.application.domain.item_category のメソッド
static ItemCategoryManager ItemCategoryManager.getItemCategoryManager(String user, String group)
ItemCategoryManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryStruct の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryStruct の使用

ItemCategoryStruct を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category 商品カテゴリ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_category での ItemCategoryStruct の使用

ItemCategoryStruct を返す jp.co.intra_mart.foundation.datastore.application.domain.item_category のメソッド
ItemCategoryStruct[] | ItemCategoryStruct.getChildren() このカテゴリ構成の子供の構成を取得します。
abstract ItemCategoryStruct | ItemCategoryManager.getCategoryStruct(String categoryTypeCode) 指定された商品カテゴリ種別のカテゴリ階層を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemAttachImporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemAttachImporter の使用

jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemAttachImporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemCategoryImporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemCategoryImporter の使用

jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemCategoryImporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_category.type.ItemCategoryType の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_category.type.ItemCategoryType の使用

jp.co.intra_mart.foundation.datastore.application.domain.item_category.type.ItemCategoryType はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemCategoryType (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_category.type
クラス ItemCategoryType

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_category.type.ItemCategoryType
すべての実装インタフェース:
Serializable
public class ItemCategoryType
extends Object
implements Serializable

商品カテゴリ種別の基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemCategoryType()
メソッドの概要
String | getItemCategoryTypeCode() 商品カテゴリ種別コードを取得します。
void | setItemCategoryTypeCode(String itemCategoryTypeCode) 商品カテゴリ種別コードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemCategoryType

public ItemCategoryType()
メソッドの詳細

getItemCategoryTypeCode

public String getItemCategoryTypeCode()
商品カテゴリ種別コードを取得します。

戻り値:
商品カテゴリ種別コード

setItemCategoryTypeCode

public void setItemCategoryTypeCode(String itemCategoryTypeCode)
商品カテゴリ種別コードを設定します。

パラメータ:
itemCategoryTypeCode - 商品カテゴリ種別コード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.item_category.type (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.item_category.type
クラス
ItemCategoryType


jp.co.intra_mart.foundation.datastore.application.domain.item_category.type (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.type

商品カテゴリ種別情報を操作するクラスを提供します。

参照:
説明

クラスの概要
ItemCategoryType 商品カテゴリ種別の基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.type の説明

商品カテゴリ種別情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.item_category.type クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.type の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.type.ItemCategoryType (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.type の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category.type の使用

jp.co.intra_mart.foundation.datastore.application.domain.item_category.type はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemAttachImporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_category
インタフェース ItemAttachImporter

既知の実装クラスの一覧:
StandardItemAttachImporter
public interface ItemAttachImporter

商品分類のインポートのインターフェースです。

導入されたバージョン:
5.1

メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。

メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemCategoryImporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_category
インタフェース ItemCategoryImporter

既知の実装クラスの一覧:
StandardItemCategoryImporter
public interface ItemCategoryImporter

商品カテゴリのインポートのインターフェースです。

導入されたバージョン:
5.1

メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。

メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ItemCategoryManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_category
クラス ItemCategoryManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager
public abstract class ItemCategoryManager
extends Object

商品カテゴリに関する情報を管理します。 このクラスのインスタンスは必ず getItemCategoryManager(String, String) で取得してください。

導入されたバージョン:
5.1

コンストラクタの概要
ItemCategoryManager()
メソッドの概要
abstract void | addCategory(ItemCategory category) 商品カテゴリを新規登録します。
abstract void | deleteCategory(ItemCategory category) 商品カテゴリを削除します。
abstract Item[] | getAllCategorizedItems(String categoryTypeCode, String categoryCode) 商品カテゴリに分類されているすべての商品の情報を返します。
abstract Item[] | getCategorizedItems(String categoryTypeCode, String categoryCode) 商品カテゴリに分類されている商品の情報を返します。
abstract ItemCategory | getCategory(String categoryTypeCode, String categoryCode) 指定されたカテゴリコードに対する商品カテゴリの情報を返します。
abstract ItemCategoryStruct | getCategoryStruct(String categoryTypeCode) 指定された商品カテゴリ種別のカテゴリ階層を取得します。
abstract ItemCategory[] | getCategoryTypes() 登録済の商品カテゴリ種別の一覧を返します。
static ItemCategoryManager | getItemCategoryManager(String user, String group) ItemCategoryManagerを取得します。
protected abstract void | init(String user, String group) ItemCategoryManagerを初期化します。
abstract boolean | isEndCategory(String categoryTypeCode, String categoryCode) 指定されたカテゴリコードに対する商品カテゴリが末端のカテゴリか調べます。
abstract void | removeItem(ItemAttach attach) 商品カテゴリから商品を外します。
abstract void | setItem(ItemAttach attach) 商品カテゴリに商品を設定します。
abstract void | updateCategory(ItemCategory category) 商品カテゴリを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemCategoryManager

public ItemCategoryManager()
メソッドの詳細

getItemCategoryManager

public static ItemCategoryManager getItemCategoryManager(String user,
                                                         String group)
                                                  throws ManagerException
ItemCategoryManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するItemCategoryManager
例外:
ManagerException - ItemCategoryManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
ItemCategoryManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - 初期化に失敗

addCategory

public abstract void addCategory(ItemCategory category)
                          throws ManagerException
商品カテゴリを新規登録します。

ルートとなる商品カテゴリを登録するときは、商品カテゴリ種別コードと商品カテゴリコードに同じ値を設定してください。
ルートとなる商品カテゴリが、商品種別となります。
また、ルートの商品カテゴリ登録時は、親商品カテゴリコードに必ずnullが設定されます。

ルートではない商品カテゴリを登録するときは、親商品カテゴリコードを必ず設定してください。
親カテゴリコードが設定されていないときは、ManagerExceptionを発生させます。

パラメータ:
category - 商品カテゴリ情報
例外:
ManagerException - 商品カテゴリ情報の新規登録に失敗した場合

updateCategory

public abstract void updateCategory(ItemCategory category)
                             throws ManagerException
商品カテゴリを更新します。

商品カテゴリの属性情報および商品カテゴリの階層構造を更新する場合に、このメソッドを使用します。 商品カテゴリの階層構造の更新時に、階層構造が循環するような設定が行われた場合は、ManagerException が投げられます。

パラメータ:
category - 商品カテゴリ情報
例外:
ManagerException - 商品カテゴリ情報の更新に失敗した場合

deleteCategory

public abstract void deleteCategory(ItemCategory category)
                             throws ManagerException
商品カテゴリを削除します。
指定された商品カテゴリが存在しない場合は ManagerException がスローされます。

パラメータ:
category - 商品カテゴリ情報
例外:
ManagerException - 商品カテゴリ情報の削除に失敗した場合

setItem

public abstract void setItem(ItemAttach attach)
                      throws ManagerException
商品カテゴリに商品を設定します。

商品が設定できるのは、商品カテゴリ階層の末端のカテゴリだけです。 それ以外の商品カテゴリに商品を設定した場合は、ManagerException が投げられます。

パラメータ:
attach - 商品設定情報
例外:
ManagerException - 商品カテゴリ設定情報の設定に失敗した場合

removeItem

public abstract void removeItem(ItemAttach attach)
                         throws ManagerException
商品カテゴリから商品を外します。
指定された商品設定情報が存在しない場合は ManagerException がスローされます。

パラメータ:
attach - 商品設定情報
例外:
ManagerException - 商品カテゴリ設定情報の削除に失敗した場合

getCategoryTypes

public abstract ItemCategory[] getCategoryTypes()
                                         throws ManagerException
登録済の商品カテゴリ種別の一覧を返します。

指定された商品カテゴリ種別の情報が存在しない場合は、空の配列を返します。

戻り値:
商品カテゴリ情報
例外:
ManagerException - 商品カテゴリ設定情報の取得に失敗した場合

getCategoryStruct

public abstract ItemCategoryStruct getCategoryStruct(String categoryTypeCode)
                                              throws ManagerException
指定された商品カテゴリ種別のカテゴリ階層を取得します。

パラメータ:
categoryTypeCode - 商品カテゴリ種別コード
戻り値:
カテゴリ階層
例外:
ManagerException - カテゴリ階層情報の取得に失敗した場合

getCategory

public abstract ItemCategory getCategory(String categoryTypeCode,
                                         String categoryCode)
                                  throws ManagerException
指定されたカテゴリコードに対する商品カテゴリの情報を返します。

パラメータ:
categoryTypeCode - 商品カテゴリ種別コード
categoryCode - 商品カテゴリコード
戻り値:
商品カテゴリ情報
例外:
ManagerException - 商品カテゴリ情報の取得に失敗した場合

getCategorizedItems

public abstract Item[] getCategorizedItems(String categoryTypeCode,
                                           String categoryCode)
                                    throws ManagerException
商品カテゴリに分類されている商品の情報を返します。返される商品情報は、現在存在するもののみです。

指定された商品カテゴリがカテゴリ階層の末端のカテゴリでない場合、指定されたカテゴリ以下のすべてのカテゴリに分類されている商品情報を返します。
指定された商品カテゴリがカテゴリ階層の末端のカテゴリに商品が分類されていない場合は、空の配列を返します。

パラメータ:
categoryTypeCode - 商品カテゴリ種別コード
categoryCode - 商品カテゴリコード
戻り値:
商品情報
例外:
ManagerException - 商品情報の取得に失敗した場合

getAllCategorizedItems

public abstract Item[] getAllCategorizedItems(String categoryTypeCode,
                                              String categoryCode)
                                       throws ManagerException
商品カテゴリに分類されているすべての商品の情報を返します。

指定された商品カテゴリがカテゴリ階層の末端のカテゴリでない場合、指定されたカテゴリ以下のすべてのカテゴリに分類されている商品情報を返します。
指定された商品カテゴリがカテゴリ階層の末端のカテゴリに商品が分類されていない場合は、空の配列を返します。

パラメータ:
categoryTypeCode - 商品カテゴリ種別コード
categoryCode - 商品カテゴリコード
戻り値:
商品情報
例外:
ManagerException - 商品情報の取得に失敗した場合

isEndCategory

public abstract boolean isEndCategory(String categoryTypeCode,
                                      String categoryCode)
                               throws ManagerException
指定されたカテゴリコードに対する商品カテゴリが末端のカテゴリか調べます。
末端のカテゴリの時はtrueを返します。

パラメータ:
categoryTypeCode - 商品カテゴリ種別コード
categoryCode - 商品カテゴリコード
戻り値:
末端のカテゴリの時はtrue、末端のカテゴリでないときはfalseを返す。
例外:
ManagerException - 判定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemCategoryStruct (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_category
インタフェース ItemCategoryStruct

public interface ItemCategoryStruct

商品カテゴリのツリー構造の構成を表すクラスです。

メソッドの概要
ItemCategoryStruct[] | getChildren() このカテゴリ構成の子供の構成を取得します。
ItemCategory | getItemCateogry() 商品カテゴリを取得します。

メソッドの詳細

getItemCateogry

public ItemCategory getItemCateogry()
商品カテゴリを取得します。

戻り値:
商品カテゴリ

getChildren

public ItemCategoryStruct[] getChildren()
このカテゴリ構成の子供の構成を取得します。

戻り値:
カテゴリ構成の子供の構成
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.item_category (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.item_category
インタフェース
ItemAttachImporter
ItemCategoryImporter
ItemCategoryStruct
クラス
ItemCategoryManager
StandardItemAttachImporter
StandardItemCategoryImporter


jp.co.intra_mart.foundation.datastore.application.domain.item_category (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category

商品カテゴリ情報を操作するクラスを提供します。

参照:
説明

インタフェースの概要
ItemAttachImporter | 商品分類のインポートのインターフェースです。
ItemCategoryImporter | 商品カテゴリのインポートのインターフェースです。
ItemCategoryStruct | 商品カテゴリのツリー構造の構成を表すクラスです。

クラスの概要
ItemCategoryManager | 商品カテゴリに関する情報を管理します。
StandardItemAttachImporter | 商品分類のインポートを行います。
StandardItemCategoryImporter | 商品カテゴリのインポートを行います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category の説明

商品カテゴリ情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.item_category クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemAttachImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemAttachImporter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemCategoryImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemAttachImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryStruct


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category の使用

jp.co.intra_mart.foundation.datastore.application.domain.item_category を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_category 商品カテゴリ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_category により使用される jp.co.intra_mart.foundation.datastore.application.domain.item_category のクラス
ItemAttachImporter
商品分類のインポートのインターフェースです。
ItemCategoryImporter
商品カテゴリのインポートのインターフェースです。
ItemCategoryManager
商品カテゴリに関する情報を管理します。
ItemCategoryStruct
商品カテゴリのツリー構造の構成を表すクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardItemAttachImporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_category
クラス StandardItemAttachImporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemAttachImporter
すべての実装インタフェース:
ItemAttachImporter
public class StandardItemAttachImporter
extends Object
implements ItemAttachImporter

商品分類のインポートを行います。

導入されたバージョン:
5.1

コンストラクタの概要
StandardItemAttachImporter()
メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardItemAttachImporter

public StandardItemAttachImporter()
メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

定義:
インタフェース ItemAttachImporter 内の doImport
パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardItemCategoryImporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_category
クラス StandardItemCategoryImporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemCategoryImporter
すべての実装インタフェース:
ItemCategoryImporter
public class StandardItemCategoryImporter
extends Object
implements ItemCategoryImporter

商品カテゴリのインポートを行います。

導入されたバージョン:
5.1

コンストラクタの概要
StandardItemCategoryImporter()
メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardItemCategoryImporter

public StandardItemCategoryImporter()
メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

定義:
インタフェース ItemCategoryImporter 内の doImport
パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateImporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateImporter の使用

ItemTemplateImporter を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_template 商品テンプレート属性情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_template での ItemTemplateImporter の使用

ItemTemplateImporter を実装している jp.co.intra_mart.foundation.datastore.application.domain.item_template のクラス
 class StandardItemTemplateImporter
商品テンプレートのインポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager の使用

ItemTemplateManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_template 商品テンプレート属性情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_template での ItemTemplateManager の使用

ItemTemplateManager を返す jp.co.intra_mart.foundation.datastore.application.domain.item_template のメソッド
static ItemTemplateManager ItemTemplateManager.getItemTemplateManager(String user, String group)
ItemTemplateManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_template.StandardItemTemplateImporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_template.StandardItemTemplateImporter の使用

jp.co.intra_mart.foundation.datastore.application.domain.item_template.StandardItemTemplateImporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail の使用

ItemTemplateDetail を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_template 商品テンプレート属性情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_template での ItemTemplateDetail の使用

ItemTemplateDetail を返す jp.co.intra_mart.foundation.datastore.application.domain.item_template のメソッド
abstract  ItemTemplateDetail[] ItemTemplateManager.getTemplateDetail(String templateCode)
指定された商品属性テンプレートの明細情報を返します。

ItemTemplateDetail 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item_template のメソッド
abstract void | ItemTemplateManager.setTemplateDetail(ItemTemplateDetail detail) 商品属性テンプレート明細情報を設定します。
abstract void | ItemTemplateManager.deleteTemplateDetail(ItemTemplateDetail detail) 商品属性テンプレート明細情報を削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetailInternational の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetailInternational の使用

ItemTemplateDetailInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail 商品テンプレート属性詳細情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail での ItemTemplateDetailInternational の使用

ItemTemplateDetailInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail のメソッド
 ItemTemplateDetailInternational ItemTemplateDetail.getItemTemplateDetailInternational(Locale locale)
指定された言語に対する国際化情報を取得します。

ItemTemplateDetailInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail のメソッド
 void ItemTemplateDetail.putInternational(Locale locale, ItemTemplateDetailInternational data)
指定された言語に対する国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemTemplateDetail (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail
クラス ItemTemplateDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail
すべての実装インタフェース:
Serializable
public class ItemTemplateDetail
extends Object
implements Serializable

商品属性テンプレート明細の基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemTemplateDetail()
商品属性テンプレート明細に関連する情報を新規に生成します。
ItemTemplateDetail(Locale locale)
商品属性テンプレート明細に関連する情報を新規に生成します。
メソッドの概要
int | getDataType() データ型を取得します。
Locale | getDefaultLocale() デフォルトのロケールを取得します。
ItemTemplateDetailInternational | getItemTemplateDetailInternational(Locale locale) 指定された言語に対する国際化情報を取得します。
Locale[] | getLocales() この商品属性テンプレート明細で管理している言語（ロケール）をすべて取得します。
String | getNotes() 備考を取得します。
int | getSortKey() ソートキーを取得します。
String | getTemplateCode() テンプレートコードを取得します。
String | getTemplateDetailCode() テンプレート明細コードを取得します。
String | getTemplateDetailName() テンプレート明細名を取得します。
String | getTemplateDetailName(Locale locale) テンプレート明細名を取得します。
void | putInternational(Locale locale, ItemTemplateDetailInternational data) 指定された言語に対する国際化情報を設定します。
void | removeInternational(Locale locale) 指定された言語に対する国際化情報を削除します。
void | setDataType(int dataType) データ型を設定します。
void | setDefaultLocale(Locale defaultLocale) デフォルトのロケールを設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
void | setTemplateCode(String templateCode) テンプレートコードを設定します。
void | setTemplateDetailCode(String templateDetailCode) テンプレート明細コードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemTemplateDetail

public ItemTemplateDetail()
商品属性テンプレート明細に関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値の言語だけのロケールが割り当てられます。

ItemTemplateDetail

public ItemTemplateDetail(Locale locale)
商品属性テンプレート明細に関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられます。

パラメータ:
locale - デフォルトの言語
メソッドの詳細

getDefaultLocale

public Locale getDefaultLocale()
デフォルトのロケールを取得します。

戻り値:
デフォルトのロケール

setDefaultLocale

public void setDefaultLocale(Locale defaultLocale)
デフォルトのロケールを設定します。

パラメータ:
defaultLocale - デフォルトのロケール

getLocales

public Locale[] getLocales()
この商品属性テンプレート明細で管理している言語（ロケール）をすべて取得します。

戻り値:
この商品属性テンプレート明細で管理している言語（ロケール）

getItemTemplateDetailInternational

public ItemTemplateDetailInternational getItemTemplateDetailInternational(Locale locale)
指定された言語に対する国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
国際化情報

putInternational

public void putInternational(Locale locale,
                             ItemTemplateDetailInternational data)
指定された言語に対する国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 国際化情報

removeInternational

public void removeInternational(Locale locale)
指定された言語に対する国際化情報を削除します。

パラメータ:
locale - 言語（ロケール）

getTemplateCode

public String getTemplateCode()
テンプレートコードを取得します。

戻り値:
テンプレートコード

setTemplateCode

public void setTemplateCode(String templateCode)
テンプレートコードを設定します。

パラメータ:
templateCode - テンプレートコード

getTemplateDetailCode

public String getTemplateDetailCode()
テンプレート明細コードを取得します。

戻り値:
テンプレート明細コード

setTemplateDetailCode

public void setTemplateDetailCode(String templateDetailCode)
テンプレート明細コードを設定します。

パラメータ:
templateDetailCode - テンプレート明細コード

getDataType

public int getDataType()
データ型を取得します。

戻り値:
データ型

setDataType

public void setDataType(int dataType)
データ型を設定します。

パラメータ:
dataType - データ型

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getTemplateDetailName

public String getTemplateDetailName()
テンプレート明細名を取得します。

戻り値:
テンプレート明細名

getTemplateDetailName

public String getTemplateDetailName(Locale locale)
テンプレート明細名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
テンプレート明細名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemTemplateDetailInternational (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail
クラス ItemTemplateDetailInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetailInternational
すべての実装インタフェース:
Serializable
public class ItemTemplateDetailInternational
extends Object
implements Serializable

商品属性テンプレート明細の国際化属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemTemplateDetailInternational()
メソッドの概要
String | getTemplateDetailName() テンプレート明細名を取得します。
void | setTemplateDetailName(String templateDetailName) テンプレート明細名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemTemplateDetailInternational

public ItemTemplateDetailInternational()
メソッドの詳細

getTemplateDetailName

public String getTemplateDetailName()
テンプレート明細名を取得します。

戻り値:
テンプレート明細名
例外:
AccessorException - データの取得に失敗した場合

setTemplateDetailName

public void setTemplateDetailName(String templateDetailName)
テンプレート明細名を設定します。

パラメータ:
templateDetailName - テンプレート明細名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail
クラス
ItemTemplateDetail
ItemTemplateDetailInternational


jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail

商品テンプレート属性詳細情報を操作するクラスを提供します。

参照:
説明

クラスの概要
ItemTemplateDetail | 商品属性テンプレート明細の基本属性のデータを取り扱います。
ItemTemplateDetailInternational | 商品属性テンプレート明細の国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail の説明

商品テンプレート属性詳細情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetailInternational (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail の使用

jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_template | 商品テンプレート属性情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail | 商品テンプレート属性詳細情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_template により使用される jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail のクラス
ItemTemplateDetail
商品属性テンプレート明細の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail により使用される jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail のクラス
ItemTemplateDetailInternational
商品属性テンプレート明細の国際化属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate の使用

ItemTemplate を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_template 商品テンプレート属性情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_template での ItemTemplate の使用

ItemTemplate を返す jp.co.intra_mart.foundation.datastore.application.domain.item_template のメソッド
abstract ItemTemplate[] | ItemTemplateManager.getTemplates(String key) 指定された検索条件に該当する商品属性テンプレート情報を返します。
abstract ItemTemplate | ItemTemplateManager.getTemplate(String templateCode) 指定された商品属性テンプレート情報を返します。

ItemTemplate 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item_template のメソッド
abstract void | ItemTemplateManager.addTemplate(ItemTemplate template) 商品属性テンプレート情報を新規登録します。
abstract void | ItemTemplateManager.updateTemplate(ItemTemplate template) 商品属性テンプレート情報を更新します。
abstract void | ItemTemplateManager.deleteTemplate(ItemTemplate template) 商品属性テンプレート情報を削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplateInternational の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplateInternational の使用

jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplateInternational はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemTemplate (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_template.template
クラス ItemTemplate

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate
すべての実装インタフェース:
Serializable
public class ItemTemplate
extends Object
implements Serializable

商品属性テンプレートの基本属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemTemplate()
メソッドの概要
String | getNotes() 備考を取得します。
String | getTemplateCode() テンプレートコードを取得します。
String | getTemplateName() テンプレート名を取得します。
void | setNotes(String notes) 備考を設定します。
void | setTemplateCode(String templateCode) テンプレートコードを設定します。
void | setTemplateName(String templateName) テンプレート名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemTemplate

public ItemTemplate()
メソッドの詳細

getTemplateCode

public String getTemplateCode()
テンプレートコードを取得します。

戻り値:
テンプレートコード

setTemplateCode

public void setTemplateCode(String templateCode)
テンプレートコードを設定します。

パラメータ:
templateCode - テンプレートコード

getTemplateName

public String getTemplateName()
テンプレート名を取得します。

戻り値:
テンプレート名

setTemplateName

public void setTemplateName(String templateName)
テンプレート名を設定します。

パラメータ:
templateName - テンプレート名

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemTemplateInternational (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_template.template
クラス ItemTemplateInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplateInternational
すべての実装インタフェース:
Serializable
public class ItemTemplateInternational
extends Object
implements Serializable

商品属性テンプレートの国際化属性のデータを取り扱います。

導入されたバージョン:
5.1
関連項目:
直列化された形式

コンストラクタの概要
ItemTemplateInternational()
メソッドの概要
String | getTemplateName() テンプレート名を取得します。
void | setTemplateName(String templateName) テンプレート名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemTemplateInternational

public ItemTemplateInternational()
メソッドの詳細

getTemplateName

public String getTemplateName()
テンプレート名を取得します。

戻り値:
テンプレート名
例外:
AccessorException - データの取得に失敗した場合

setTemplateName

public void setTemplateName(String templateName)
テンプレート名を設定します。

パラメータ:
templateName - テンプレート名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.item_template.template (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.item_template.template
クラス
ItemTemplate
ItemTemplateInternational


jp.co.intra_mart.foundation.datastore.application.domain.item_template.template (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template.template

商品テンプレート属性情報を操作するクラスを提供します。

参照:
説明

クラスの概要
ItemTemplate | 商品属性テンプレートの基本属性のデータを取り扱います。
ItemTemplateInternational | 商品属性テンプレートの国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template.template の説明

商品テンプレート属性情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.item_template.template クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template.template の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplateInternational (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template.template の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_template.template の使用

jp.co.intra_mart.foundation.datastore.application.domain.item_template.template を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_template 商品テンプレート属性情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_template により使用される jp.co.intra_mart.foundation.datastore.application.domain.item_template.template のクラス
ItemTemplate
商品属性テンプレートの基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemTemplateImporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_template
インタフェース ItemTemplateImporter

既知の実装クラスの一覧:
StandardItemTemplateImporter
public interface ItemTemplateImporter

商品属性テンプレートのインポートのインターフェースです。

導入されたバージョン:
5.1

メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。

メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemTemplateManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_template
クラス ItemTemplateManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager
public abstract class ItemTemplateManager
extends Object

商品属性テンプレートの情報を管理します。

導入されたバージョン:
5.1

コンストラクタの概要
ItemTemplateManager()
メソッドの概要
abstract void | addTemplate(ItemTemplate template) 商品属性テンプレート情報を新規登録します。
abstract void | deleteTemplate(ItemTemplate template) 商品属性テンプレート情報を削除します。
abstract void | deleteTemplateDetail(ItemTemplateDetail detail) 商品属性テンプレート明細情報を削除します。
static ItemTemplateManager | getItemTemplateManager(String user, String group) ItemTemplateManagerを取得します。
abstract ItemTemplate | getTemplate(String templateCode) 指定された商品属性テンプレート情報を返します。
abstract ItemTemplateDetail[] | getTemplateDetail(String templateCode) 指定された商品属性テンプレートの明細情報を返します。
abstract ItemTemplate[] | getTemplates(String key) 指定された検索条件に該当する商品属性テンプレート情報を返します。
protected abstract void | init(String user, String group) ItemTemplateManagerを初期化します。
abstract void | setTemplateDetail(ItemTemplateDetail detail) 商品属性テンプレート明細情報を設定します。
abstract void | updateTemplate(ItemTemplate template) 商品属性テンプレート情報を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemTemplateManager

public ItemTemplateManager()
メソッドの詳細

getItemTemplateManager

public static ItemTemplateManager getItemTemplateManager(String user,
                                                         String group)
                                                  throws ManagerException
ItemTemplateManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するItemTemplateManager
例外:
ManagerException - ItemTemplateManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
ItemTemplateManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - 初期化に失敗

addTemplate

public abstract void addTemplate(ItemTemplate template)
                          throws ManagerException
商品属性テンプレート情報を新規登録します。

パラメータ:
template - 商品属性テンプレート情報
例外:
ManagerException - 商品テンプレート情報の新規登録に失敗した場合

updateTemplate

public abstract void updateTemplate(ItemTemplate template)
                             throws ManagerException
商品属性テンプレート情報を更新します。

パラメータ:
template - 商品属性テンプレート情報
例外:
ManagerException - 商品テンプレート情報の更新に失敗した場合

deleteTemplate

public abstract void deleteTemplate(ItemTemplate template)
                             throws ManagerException
商品属性テンプレート情報を削除します。
指定された商品属性テンプレート情報が存在しない場合は ManagerException がスローされます。

パラメータ:
template - 商品属性テンプレート情報
例外:
ManagerException - 商品テンプレート情報の削除に失敗した場合

setTemplateDetail

public abstract void setTemplateDetail(ItemTemplateDetail detail)
                                throws ManagerException
商品属性テンプレート明細情報を設定します。

指定された商品属性テンプレート情報が存在しない場合は新規登録します。 商品属性テンプレート情報がすでに存在する場合は更新を行います。

パラメータ:
detail - 商品属性テンプレート明細情報
例外:
ManagerException - 商品テンプレート情報の設定に失敗した場合

deleteTemplateDetail

public abstract void deleteTemplateDetail(ItemTemplateDetail detail)
                                   throws ManagerException
商品属性テンプレート明細情報を削除します。
指定された商品属性テンプレート明細情報が存在しない場合は ManagerException がスローされます。

パラメータ:
detail - 商品属性テンプレート明細情報
例外:
ManagerException - 商品テンプレート情報の削除に失敗した場合

getTemplates

public abstract ItemTemplate[] getTemplates(String key)
                                     throws ManagerException
指定された検索条件に該当する商品属性テンプレート情報を返します。

検索条件に前方および後方一致する商品属性テンプレート情報が返されます。

パラメータ:
key - 検索条件（商品属性テンプレートコードまたは商品属性テンプレート名）
戻り値:
商品属性テンプレート情報
例外:
ManagerException - 商品テンプレート情報の取得に失敗した場合

getTemplate

public abstract ItemTemplate getTemplate(String templateCode)
                                  throws ManagerException
指定された商品属性テンプレート情報を返します。

パラメータ:
templateCode - テンプレートコード
戻り値:
商品属性テンプレート情報
例外:
ManagerException - 商品テンプレート情報の取得に失敗した場合

getTemplateDetail

public abstract ItemTemplateDetail[] getTemplateDetail(String templateCode)
                                                throws ManagerException
指定された商品属性テンプレートの明細情報を返します。

パラメータ:
templateCode - テンプレートコード
戻り値:
商品属性テンプレート明細情報
例外:
ManagerException - 商品テンプレート情報の取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.item_template (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.item_template
インタフェース
ItemTemplateImporter
クラス
ItemTemplateManager
StandardItemTemplateImporter


jp.co.intra_mart.foundation.datastore.application.domain.item_template (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template

商品テンプレート属性情報を操作するクラスを提供します。

参照:
説明

インタフェースの概要
ItemTemplateImporter 商品属性テンプレートのインポートのインターフェースです。

クラスの概要
ItemTemplateManager | 商品属性テンプレートの情報を管理します。
StandardItemTemplateImporter | 商品テンプレートのインポートを行います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template の説明

商品テンプレート属性情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.item_template クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_template.StandardItemTemplateImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateImporter


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_template の使用

jp.co.intra_mart.foundation.datastore.application.domain.item_template を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.item_template 商品テンプレート属性情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.item_template により使用される jp.co.intra_mart.foundation.datastore.application.domain.item_template のクラス
ItemTemplateImporter
商品属性テンプレートのインポートのインターフェースです。
ItemTemplateManager
商品属性テンプレートの情報を管理します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardItemTemplateImporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.item_template
クラス StandardItemTemplateImporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.item_template.StandardItemTemplateImporter
すべての実装インタフェース:
ItemTemplateImporter
public class StandardItemTemplateImporter
extends Object
implements ItemTemplateImporter

商品テンプレートのインポートを行います。

導入されたバージョン:
5.1

コンストラクタの概要
StandardItemTemplateImporter()
メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardItemTemplateImporter

public StandardItemTemplateImporter()
メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

定義:
インタフェース ItemTemplateImporter 内の doImport
パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach の使用

PrivateGroupAttach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group プライベートグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.private_group での PrivateGroupAttach の使用

PrivateGroupAttach 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.private_group のメソッド
abstract void | PrivateGroupManager.setMember(PrivateGroupAttach member) プライベートグループに人員を割り当てます。
abstract void | PrivateGroupManager.deleteMember(PrivateGroupAttach member) プライベートグループから人員をはずします。
void | PrivateGroupChangedListener.memberSet(String groupId, PrivateGroupAttach member) プライベートグループ所属情報がデータストアに登録された後に呼び出されます。
void | PrivateGroupChangedListener.memberDeleted(String groupId, PrivateGroupAttach member) プライベートグループ所属情報がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach
クラス
PrivateGroupAttach


jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach

プライベートグループ所属情報を操作するクラスを提供します。

参照:
説明

クラスの概要
PrivateGroupAttach プライベートグループ所属の基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach の説明

プライベートグループ所属情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach の使用

jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group プライベートグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.private_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach のクラス
PrivateGroupAttach
プライベートグループ所属の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PrivateGroupAttach (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach
クラス PrivateGroupAttach

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach
すべての実装インタフェース:
Serializable
public class PrivateGroupAttach
extends Object
implements Serializable

プライベートグループ所属の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PrivateGroupAttach()
メソッドの概要
String | getOwnerCode() 所有者コードを取得します。
String | getPrivateGroupCode() グループコードを取得します。
int | getSortKey() ソートキーを取得します。
String | getUserCode() ユーザコードを取得します。
void | setOwnerCode(String ownerCode) 所有者コードを設定します。
void | setPrivateGroupCode(String privateGroupCode) グループコードを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
void | setUserCode(String userCode) ユーザコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PrivateGroupAttach

public PrivateGroupAttach()
メソッドの詳細

getOwnerCode

public String getOwnerCode()
所有者コードを取得します。

戻り値:
所有者コード

setOwnerCode

public void setOwnerCode(String ownerCode)
所有者コードを設定します。

パラメータ:
ownerCode - 所有者コード

getPrivateGroupCode

public String getPrivateGroupCode()
グループコードを取得します。

戻り値:
グループコード

setPrivateGroupCode

public void setPrivateGroupCode(String privateGroupCode)
グループコードを設定します。

パラメータ:
privateGroupCode - グループコード

getUserCode

public String getUserCode()
ユーザコードを取得します。

戻り値:
ユーザコード

setUserCode

public void setUserCode(String userCode)
ユーザコードを設定します。

パラメータ:
userCode - ユーザコード

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener の使用

jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager の使用

PrivateGroupManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group プライベートグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.private_group での PrivateGroupManager の使用

PrivateGroupManager を返す jp.co.intra_mart.foundation.datastore.application.domain.private_group のメソッド
static PrivateGroupManager PrivateGroupManager.getPrivateGroupManager(String user, String group)
PrivateGroupManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup の使用

PrivateGroup を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group プライベートグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.private_group での PrivateGroup の使用

PrivateGroup を返す jp.co.intra_mart.foundation.datastore.application.domain.private_group のメソッド
abstract PrivateGroup | PrivateGroupManager.getPrivateGroup(String owner, String group) 登録済のプライベートグループを取得します。
abstract PrivateGroup[] | PrivateGroupManager.getPrivateGroups(String owner) 指定されたユーザが持つプライベートグループをすべて取得します。

PrivateGroup 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.private_group のメソッド
abstract void | PrivateGroupManager.addPrivateGroup(PrivateGroup group) プライベートグループを登録します。
abstract void | PrivateGroupManager.updatePrivateGroup(PrivateGroup group) 登録済のプライベートグループ情報を更新します。
abstract void | PrivateGroupManager.deletePrivateGroup(PrivateGroup group) 登録済のプライベートグループ情報を削除します。
void | PrivateGroupChangedListener.privateGroupAdded(String groupId, PrivateGroup group) プライベートグループがデータストアに登録された後に呼び出されます。
void | PrivateGroupChangedListener.privateGroupUpdated(String groupId, PrivateGroup group) プライベートグループがデータストアに更新された後に呼び出されます。
void | PrivateGroupChangedListener.privateGroupDeleted(String groupId, PrivateGroup group) プライベートグループがデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.domain.private_group.group (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.private_group.group
クラス
PrivateGroup


jp.co.intra_mart.foundation.datastore.application.domain.private_group.group (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.group

プライベートグループ情報を操作するクラスを提供します。

参照:
説明

クラスの概要
PrivateGroup プライベートグループの基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.group の説明

プライベートグループ情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.private_group.group クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.group の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.group の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group.group の使用

jp.co.intra_mart.foundation.datastore.application.domain.private_group.group を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group プライベートグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.private_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.private_group.group のクラス
PrivateGroup
プライベートグループの基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PrivateGroup (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.private_group.group
クラス PrivateGroup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup
すべての実装インタフェース:
Serializable
public class PrivateGroup
extends Object
implements Serializable

プライベートグループの基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PrivateGroup()
メソッドの概要
String | getName() グループ名を取得します。
String | getNameEnglish() グループ名英字を取得します。
String | getNameSyllabary() グループ名カナを取得します。
String | getNotes() 備考を取得します。
String | getOwnerCode() 所有者コードを取得します。
String | getPrivateGroupCode() グループコードを取得します。
int | getSortKey() ソートキーを取得します。
void | setName(String name) グループ名を設定します。
void | setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
void | setNotes(String notes) 備考を設定します。
void | setOwnerCode(String ownerCode) 所有者コードを設定します。
void | setPrivateGroupCode(String privateGroupCode) グループコードを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PrivateGroup

public PrivateGroup()
メソッドの詳細

getOwnerCode

public String getOwnerCode()
所有者コードを取得します。

戻り値:
所有者コード

setOwnerCode

public void setOwnerCode(String ownerCode)
所有者コードを設定します。

パラメータ:
ownerCode - 所有者コード

getPrivateGroupCode

public String getPrivateGroupCode()
グループコードを取得します。

戻り値:
グループコード

setPrivateGroupCode

public void setPrivateGroupCode(String privateGroupCode)
グループコードを設定します。

パラメータ:
privateGroupCode - グループコード

getName

public String getName()
グループ名を取得します。

戻り値:
グループ名

setName

public void setName(String name)
グループ名を設定します。

パラメータ:
name - グループ名

getNameSyllabary

public String getNameSyllabary()
グループ名カナを取得します。

戻り値:
グループ名カナ

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ

getNameEnglish

public String getNameEnglish()
グループ名英字を取得します。

戻り値:
グループ名英字

setNameEnglish

public void setNameEnglish(String nameEnglish)
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.private_group (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.private_group
インタフェース
PrivateGroupChangedListener
クラス
PrivateGroupManager


jp.co.intra_mart.foundation.datastore.application.domain.private_group (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group

プライベートグループ情報を操作するクラスを提供します。

参照:
説明

インタフェースの概要
PrivateGroupChangedListener プライベートグループに関する情報の更新時のリスナーです。

クラスの概要
PrivateGroupManager プライベートグループに関連する情報を管理します。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group の説明

プライベートグループ情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.private_group クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group の使用

jp.co.intra_mart.foundation.datastore.application.domain.private_group を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group プライベートグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.private_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.private_group のクラス
PrivateGroupManager
プライベートグループに関連する情報を管理します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PrivateGroupChangedListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.private_group
インタフェース PrivateGroupChangedListener

public interface PrivateGroupChangedListener

プライベートグループに関する情報の更新時のリスナーです。

導入されたバージョン:
5.0

メソッドの概要
void | init(Map params) プライベートグループリスナーの初期化を行います。
void | memberDeleted(String groupId, PrivateGroupAttach member) プライベートグループ所属情報がデータストアから削除された後に呼び出されます。
void | memberSet(String groupId, PrivateGroupAttach member) プライベートグループ所属情報がデータストアに登録された後に呼び出されます。
void | privateGroupAdded(String groupId, PrivateGroup group) プライベートグループがデータストアに登録された後に呼び出されます。
void | privateGroupDeleted(String groupId, PrivateGroup group) プライベートグループがデータストアから削除された後に呼び出されます。
void | privateGroupUpdated(String groupId, PrivateGroup group) プライベートグループがデータストアに更新された後に呼び出されます。
void | setUesrId(String userid) ログインユーザIDを設定します。

メソッドの詳細

init

public void init(Map params)
プライベートグループリスナーの初期化を行います。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

パラメータ:
params - 初期化パラメータのマップ(Map)

setUesrId

public void setUesrId(String userid)
ログインユーザIDを設定します。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

パラメータ:
userid - ログインユーザID

privateGroupAdded

public void privateGroupAdded(String groupId,
                              PrivateGroup group)
                       throws ChangedListenerException
プライベートグループがデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
group - プライベートグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

privateGroupUpdated

public void privateGroupUpdated(String groupId,
                                PrivateGroup group)
                         throws ChangedListenerException
プライベートグループがデータストアに更新された後に呼び出されます。

パラメータ:
groupId - ログイングループID
group - プライベートグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

privateGroupDeleted

public void privateGroupDeleted(String groupId,
                                PrivateGroup group)
                         throws ChangedListenerException
プライベートグループがデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
group - プライベートグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberSet

public void memberSet(String groupId,
                      PrivateGroupAttach member)
               throws ChangedListenerException
プライベートグループ所属情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
member - プライベートグループ所属情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberDeleted

public void memberDeleted(String groupId,
                          PrivateGroupAttach member)
                   throws ChangedListenerException
プライベートグループ所属情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
member - プライベート所属情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PrivateGroupManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.private_group
クラス PrivateGroupManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager
public abstract class PrivateGroupManager
extends Object

プライベートグループに関連する情報を管理します。 このクラスのインスタンスは必ず getPrivateGroupManager(String, String) で取得してください。コンストラクタによる明示的な生成はできません。

導入されたバージョン:
5.0

コンストラクタの概要
PrivateGroupManager()
メソッドの概要
abstract void | addPrivateGroup(PrivateGroup group) プライベートグループを登録します。
abstract void | deleteMember(PrivateGroupAttach member) プライベートグループから人員をはずします。
abstract void | deletePrivateGroup(PrivateGroup group) 登録済のプライベートグループ情報を削除します。
abstract User[] | getMember(String owner, String group) ログインユーザが持つ指定されたプライベートグループに所属する人員を取得します。
abstract User[] | getMember(String owner, String group, Date date) 指定されたプライベートグループに所属する人員を取得します。
abstract PrivateGroup | getPrivateGroup(String owner, String group) 登録済のプライベートグループを取得します。
static PrivateGroupManager | getPrivateGroupManager(String user, String group) PrivateGroupManagerを取得します。
abstract PrivateGroup[] | getPrivateGroups(String owner) 指定されたユーザが持つプライベートグループをすべて取得します。
protected abstract void | init(String user, String group) PrivateGroupManagerを初期化します。
abstract void | setMember(PrivateGroupAttach member) プライベートグループに人員を割り当てます。
abstract void | updatePrivateGroup(PrivateGroup group) 登録済のプライベートグループ情報を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PrivateGroupManager

public PrivateGroupManager()
メソッドの詳細

getPrivateGroupManager

public static PrivateGroupManager getPrivateGroupManager(String user,
                                                         String group)
                                                  throws ManagerException
PrivateGroupManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するPrivateGroupManager
例外:
ManagerException - PrivateGroupManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
PrivateGroupManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - 初期化に失敗

getPrivateGroup

public abstract PrivateGroup getPrivateGroup(String owner,
                                             String group)
                                      throws ManagerException
登録済のプライベートグループを取得します。
該当するプライベートグループ情報が存在しない場合は nullを返します。

パラメータ:
owner - 所有者となるユーザのユーザコード
group - プライベートグループコード
戻り値:
プライベートグループ情報
例外:
ManagerException - プライベートグループの取得に失敗
導入されたバージョン:
6.1

getPrivateGroups

public abstract PrivateGroup[] getPrivateGroups(String owner)
                                         throws ManagerException
指定されたユーザが持つプライベートグループをすべて取得します。
該当するプライベートグループ情報が存在しない場合は空の配列を返します。

パラメータ:
owner - 所有者となるユーザのユーザコード
戻り値:
所有者が持つプライベートグループ情報の配列
例外:
ManagerException - プライベートグループの取得に失敗
導入されたバージョン:
6.1

addPrivateGroup

public abstract void addPrivateGroup(PrivateGroup group)
                              throws ManagerException
プライベートグループを登録します。

パラメータ:
group - プライベートグループ情報
例外:
ManagerException - プライベートグループの登録に失敗

updatePrivateGroup

public abstract void updatePrivateGroup(PrivateGroup group)
                                 throws ManagerException
登録済のプライベートグループ情報を更新します。

パラメータ:
group - プライベートグループ情報
例外:
ManagerException - プライベートグループの更新に失敗

deletePrivateGroup

public abstract void deletePrivateGroup(PrivateGroup group)
                                 throws ManagerException
登録済のプライベートグループ情報を削除します。
指定されたプライベートグループ情報が存在しない場合は ManagerException がスローされます。

パラメータ:
group - プライベートグループ情報
例外:
ManagerException - プライベートグループの削除に失敗

setMember

public abstract void setMember(PrivateGroupAttach member)
                        throws ManagerException
プライベートグループに人員を割り当てます。

パラメータ:
member - プライベートグループに割り当てる人員の情報
例外:
ManagerException - プライベートグループへの人員の割り当てに失敗

deleteMember

public abstract void deleteMember(PrivateGroupAttach member)
                           throws ManagerException
プライベートグループから人員をはずします。
指定された人員がプライベートグループに割り当てられていない場合は ManagerException がスローされます。

パラメータ:
member - プライベートグループから削除する人員の情報
例外:
ManagerException - プライベートグループからの人員の削除に失敗

getMember

public abstract User[] getMember(String owner,
                                 String group)
                          throws ManagerException
ログインユーザが持つ指定されたプライベートグループに所属する人員を取得します。
ユーザ情報はシステム日付で有効なユーザのみを取得します。
指定されたプライベートグループに有効な人員が所属していない場合は空の配列を返します。

パラメータ:
group - プライベートグループコード
戻り値:
ユーザ情報
例外:
ManagerException - プライベートグループに所属する人員の取得に失敗
導入されたバージョン:
6.1

getMember

public abstract User[] getMember(String owner,
                                 String group,
                                 Date date)
                          throws ManagerException
指定されたプライベートグループに所属する人員を取得します。
ユーザ情報は指定された日付で有効なユーザのみを取得します。
指定されたプライベートグループに有効な人員が所属していない場合は空の配列を返します。

パラメータ:
owner - 所有者となるユーザのユーザコード
group - プライベートグループコード
date - 日付
戻り値:
ユーザ情報
例外:
ManagerException - プライベートグループに所属する人員の取得に失敗
導入されたバージョン:
6.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach の使用

PublicGroupAttach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での PublicGroupAttach の使用

PublicGroupAttach を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract  PublicGroupAttach PublicGroupManager.getPublicGroupAttach(String user, String groupSet, String publicGroup)
ユーザのパブリックグループへの所属情報を取得します。

PublicGroupAttach 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract void | PublicGroupManager.setMember(PublicGroupAttach attach) パブリックグループに人員を割り当てます。
abstract void | PublicGroupManager.deleteMember(PublicGroupAttach attach) パブリックグループから人員をはずします。
void | PublicGroupChangedListener.memberSet(String groupId, PublicGroupAttach attach) パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.memberDeleted(String groupId, PublicGroupAttach attach) パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.access での PublicGroupAttach の使用

PublicGroupAttach 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | PublicGroupChangedControllerListener.memberSet(String groupId, PublicGroupAttach attach) パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedControllerListener.memberDeleted(String groupId, PublicGroupAttach attach) パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での PublicGroupAttach の使用

PublicGroupAttach 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | PublicGroupChangedMenuListener.memberSet(String groupId, PublicGroupAttach attach) パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.memberDeleted(String groupId, PublicGroupAttach attach) パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable の使用

PublicGroupAttachTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach パブリックグループ所属情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach での PublicGroupAttachTerminable の使用

PublicGroupAttachTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach のメソッド
PublicGroupAttachTerminable | PublicGroupAttach.getPublicGroupAttachTerminable(Term term) 指定された期間に対する期間化情報を取得します。
PublicGroupAttachTerminable | PublicGroupAttach.getPublicGroupAttachTerminable(Date date) 指定された日時に対する期間化情報を取得します。

PublicGroupAttachTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach のメソッド
 void PublicGroupAttach.putPublicGroupAttachTerminable(Term term, PublicGroupAttachTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach
クラス
PublicGroupAttach
PublicGroupAttachTerminable


jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach

パブリックグループ所属情報を操作するクラスを提供します。

参照:
説明

クラスの概要
PublicGroupAttach | パブリックグループ所属の基本属性のデータを取り扱います。
PublicGroupAttachTerminable | パブリックグループ所属の期間化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach の説明

パブリックグループ所属情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach の使用

jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach | パブリックグループ所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach のクラス
PublicGroupAttach
パブリックグループ所属の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach のクラス
PublicGroupAttachTerminable
パブリックグループ所属の期間化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach のクラス
PublicGroupAttach
パブリックグループ所属の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach のクラス
PublicGroupAttach
パブリックグループ所属の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupAttach (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach
クラス PublicGroupAttach

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach
すべての実装インタフェース:
Serializable
public class PublicGroupAttach
extends Object
implements Serializable

パブリックグループ所属の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupAttach()
パブリックグループ所属に関連する情報を新規に生成します。
PublicGroupAttach(Date date)
パブリックグループ所属に関連する情報を新規に生成します。
メソッドの概要
Date | getDefaultDate() デフォルトの日時を取得します。
PublicGroupAttachTerminable | getPublicGroupAttachTerminable(Date date) 指定された日時に対する期間化情報を取得します。
PublicGroupAttachTerminable | getPublicGroupAttachTerminable(Term term) 指定された期間に対する期間化情報を取得します。
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
int | getSortKey() ソートキーを取得します。
Term[] | getTerms() このパブリックグループ所属で管理している期間をすべて取得します。
String | getUserCode() ユーザコードを取得します。
void | putPublicGroupAttachTerminable(Term term, PublicGroupAttachTerminable data) 指定された期間に対する期間化情報を設定します。
void | removePublicGroupAttachTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setPublicGroupCode(String publicGroupCode) グループコードを設定します。
void | setPublicGroupSetCode(String publicGroupSetCode) グループセットコードを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
void | setUserCode(String userCode) ユーザコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupAttach

public PublicGroupAttach()
パブリックグループ所属に関連する情報を新規に生成します。 デフォルトの日時には現在のシステム日時が割り当てられます。

PublicGroupAttach

public PublicGroupAttach(Date date)
パブリックグループ所属に関連する情報を新規に生成します。 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時
メソッドの詳細

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
このパブリックグループ所属で管理している期間をすべて取得します。

戻り値:
このパブリックグループ所属で管理している期間

getPublicGroupAttachTerminable

public PublicGroupAttachTerminable getPublicGroupAttachTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getPublicGroupAttachTerminable

public PublicGroupAttachTerminable getPublicGroupAttachTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putPublicGroupAttachTerminable

public void putPublicGroupAttachTerminable(Term term,
                                           PublicGroupAttachTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removePublicGroupAttachTerminable

public void removePublicGroupAttachTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getUserCode

public String getUserCode()
ユーザコードを取得します。

戻り値:
ユーザコード

setUserCode

public void setUserCode(String userCode)
ユーザコードを設定します。

パラメータ:
userCode - ユーザコード

getPublicGroupSetCode

public String getPublicGroupSetCode()
グループセットコードを取得します。

戻り値:
グループセットコード

setPublicGroupSetCode

public void setPublicGroupSetCode(String publicGroupSetCode)
グループセットコードを設定します。

パラメータ:
publicGroupSetCode - グループセットコード

getPublicGroupCode

public String getPublicGroupCode()
グループコードを取得します。

戻り値:
グループコード

setPublicGroupCode

public void setPublicGroupCode(String publicGroupCode)
グループコードを設定します。

パラメータ:
publicGroupCode - グループコード

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupAttachTerminable (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach
クラス PublicGroupAttachTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable
すべての実装インタフェース:
Serializable
public class PublicGroupAttachTerminable
extends Object
implements Serializable

パブリックグループ所属の期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupAttachTerminable()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupAttachTerminable

public PublicGroupAttachTerminable()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory の使用

PublicGroupCategory を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での PublicGroupCategory の使用

PublicGroupCategory 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract void | PublicGroupManager.setCategoryDetail(PublicGroupCategory category) パブリックグループに対して指定された分類区分情報を設定します。
abstract void | PublicGroupManager.removeCategoryDetail(PublicGroupCategory category) パブリックグループに対して指定された分類区分情報を削除します。
void | PublicGroupChangedListener.categoryDetailSet(String groupId, PublicGroupCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.categoryDetailRemoved(String groupId, PublicGroupCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.access での PublicGroupCategory の使用

PublicGroupCategory 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | PublicGroupChangedControllerListener.categoryDetailSet(String groupId, PublicGroupCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedControllerListener.categoryDetailRemoved(String groupId, PublicGroupCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での PublicGroupCategory の使用

PublicGroupCategory 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | PublicGroupChangedMenuListener.categoryDetailSet(String groupId, PublicGroupCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.categoryDetailRemoved(String groupId, PublicGroupCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable の使用

PublicGroupCategoryTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category パブリックグループ分類情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.category での PublicGroupCategoryTerminable の使用

PublicGroupCategoryTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.category のメソッド
PublicGroupCategoryTerminable | PublicGroupCategory.getPublicGroupCategoryTerminable(Term term) 指定された期間に対する期間化情報を取得します。
PublicGroupCategoryTerminable | PublicGroupCategory.getPublicGroupCategoryTerminable(Date date) 指定された日時に対する期間化情報を取得します。

PublicGroupCategoryTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.category のメソッド
 void PublicGroupCategory.putPublicGroupCategoryTerminable(Term term, PublicGroupCategoryTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.domain.public_group.category (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.public_group.category
クラス
PublicGroupCategory
PublicGroupCategoryTerminable


jp.co.intra_mart.foundation.datastore.application.domain.public_group.category (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.category

パブリックグループ分類情報を操作するクラスを提供します。

参照:
説明

クラスの概要
PublicGroupCategory | パブリックグループ分類の基本属性のデータを取り扱います。
PublicGroupCategoryTerminable | パブリックグループ分類の期間化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.category の説明

パブリックグループ分類情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.public_group.category クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.category の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.category の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category の使用

jp.co.intra_mart.foundation.datastore.application.domain.public_group.category を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category | パブリックグループ分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.category のクラス
PublicGroupCategory
パブリックグループ分類の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.category により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.category のクラス
PublicGroupCategoryTerminable
パブリックグループ分類の期間化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.category のクラス
PublicGroupCategory
パブリックグループ分類の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.category のクラス
PublicGroupCategory
パブリックグループ分類の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupCategory (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.category
クラス PublicGroupCategory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory
すべての実装インタフェース:
Serializable
public class PublicGroupCategory
extends Object
implements Serializable

パブリックグループ分類の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupCategory()
パブリックグループ分類に関連する情報を新規に生成します。
PublicGroupCategory(Date date)
パブリックグループ分類に関連する情報を新規に生成します。
メソッドの概要
String | getCategoryClassCode() 分類区分コードを取得します。
String | getCategoryCode() 分類コードを取得します。
Date | getDefaultDate() デフォルトの日時を取得します。
PublicGroupCategoryTerminable | getPublicGroupCategoryTerminable(Date date) 指定された日時に対する期間化情報を取得します。
PublicGroupCategoryTerminable | getPublicGroupCategoryTerminable(Term term) 指定された期間に対する期間化情報を取得します。
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
Term[] | getTerms() このパブリックグループ分類で管理している期間をすべて取得します。
void | putPublicGroupCategoryTerminable(Term term, PublicGroupCategoryTerminable data) 指定された期間に対する期間化情報を設定します。
void | removePublicGroupCategoryTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setCategoryClassCode(String categoryClassCode) 分類区分コードを設定します。
void | setCategoryCode(String categoryCode) 分類コードを設定します。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setPublicGroupCode(String publicGroupCode) グループコードを設定します。
void | setPublicGroupSetCode(String publicGroupSetCode) グループセットコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupCategory

public PublicGroupCategory()
パブリックグループ分類に関連する情報を新規に生成します。 デフォルトの日時には現在のシステム日時が割り当てられます。

PublicGroupCategory

public PublicGroupCategory(Date date)
パブリックグループ分類に関連する情報を新規に生成します。 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時
メソッドの詳細

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
このパブリックグループ分類で管理している期間をすべて取得します。

戻り値:
このパブリックグループ分類で管理している期間

getPublicGroupCategoryTerminable

public PublicGroupCategoryTerminable getPublicGroupCategoryTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getPublicGroupCategoryTerminable

public PublicGroupCategoryTerminable getPublicGroupCategoryTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putPublicGroupCategoryTerminable

public void putPublicGroupCategoryTerminable(Term term,
                                             PublicGroupCategoryTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removePublicGroupCategoryTerminable

public void removePublicGroupCategoryTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getPublicGroupSetCode

public String getPublicGroupSetCode()
グループセットコードを取得します。

戻り値:
グループセットコード

setPublicGroupSetCode

public void setPublicGroupSetCode(String publicGroupSetCode)
グループセットコードを設定します。

パラメータ:
publicGroupSetCode - グループセットコード

getPublicGroupCode

public String getPublicGroupCode()
グループコードを取得します。

戻り値:
グループコード

setPublicGroupCode

public void setPublicGroupCode(String publicGroupCode)
グループコードを設定します。

パラメータ:
publicGroupCode - グループコード

getCategoryClassCode

public String getCategoryClassCode()
分類区分コードを取得します。

戻り値:
分類区分コード

setCategoryClassCode

public void setCategoryClassCode(String categoryClassCode)
分類区分コードを設定します。

パラメータ:
categoryClassCode - 分類区分コード

getCategoryCode

public String getCategoryCode()
分類コードを取得します。

戻り値:
分類コード

setCategoryCode

public void setCategoryCode(String categoryCode)
分類コードを設定します。

パラメータ:
categoryCode - 分類コード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupCategoryTerminable (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.category
クラス PublicGroupCategoryTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable
すべての実装インタフェース:
Serializable
public class PublicGroupCategoryTerminable
extends Object
implements Serializable

パブリックグループ分類の期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupCategoryTerminable()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupCategoryTerminable

public PublicGroupCategoryTerminable()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener の使用

PublicGroupChangedListener を使用しているパッケージ
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.access での PublicGroupChangedListener の使用

PublicGroupChangedListener を実装している jp.co.intra_mart.foundation.security.access のクラス
 class PublicGroupChangedControllerListener
パブリックグループが削除された場合にアクセスコントローラに紐付くパブリックグループを削除するリスナークラスです。

jp.co.intra_mart.foundation.security.menu での PublicGroupChangedListener の使用

PublicGroupChangedListener を実装している jp.co.intra_mart.foundation.security.menu のクラス
 class PublicGroupChangedMenuListener
パブリックグループに関する情報の変更時のリスナーです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter の使用

PublicGroupImporter を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group パブリックグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での PublicGroupImporter の使用

PublicGroupImporter を実装している jp.co.intra_mart.foundation.datastore.application.domain.public_group のクラス
 class StandardPublicGroupImporter
パブリックグループのインポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager の使用

PublicGroupManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group パブリックグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での PublicGroupManager の使用

PublicGroupManager を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
static PublicGroupManager PublicGroupManager.getPublicGroupManager(String user, String group)
PublicGroupManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct の使用

PublicGroupStruct を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group パブリックグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での PublicGroupStruct の使用

PublicGroupStruct を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract  PublicGroupStruct[] PublicGroupManager.getPublicGroupStructs(String groupSet, String publicGroup, Date date, Locale locale)
パブリックグループの階層構造を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter の使用

jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup の使用

PublicGroup を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal での PublicGroup の使用

PublicGroup を返す jp.co.intra_mart.foundation.datastore.application.domain.deal のメソッド
abstract  PublicGroup[] DealPermissionManager.getPublicGroups(Deal deal)
取扱情報を保有するアクセス権をもつパブリックグループを返します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での PublicGroup の使用

PublicGroup を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract PublicGroup | PublicGroupManager.getPublicGroup(String groupSet, String publicGroup) 登録済のパブリックグループを取得します。
abstract PublicGroup[] | PublicGroupManager.getAttachedPublicGroups(String user) 現在、ユーザが所属しているパブリックグループの一覧を取得します。
abstract PublicGroup[] | PublicGroupManager.getAttachedPublicGroups(String user, Date date) 指定された日付にユーザが所属しているパブリックグループの一覧を取得します。

PublicGroup 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract void | PublicGroupManager.addPublicGroup(PublicGroup publicGroup) パブリックグループを登録します。
abstract void | PublicGroupManager.updatePublicGroup(PublicGroup publicGroup) 登録済のパブリックグループ情報を更新します。
abstract void | PublicGroupManager.deletePublicGroup(PublicGroup publicGroup) 登録済のパブリックグループ情報を削除します。
void | PublicGroupChangedListener.publicGroupAdded(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.publicGroupUpdated(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedListener.publicGroupDeleted(String groupId, PublicGroup publicGroup) パブリックグループがデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.access での PublicGroup の使用

PublicGroup 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | PublicGroupChangedControllerListener.publicGroupAdded(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedControllerListener.publicGroupUpdated(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedControllerListener.publicGroupDeleted(String groupId, PublicGroup publicGroup) パブリックグループがデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での PublicGroup の使用

PublicGroup 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | PublicGroupChangedMenuListener.publicGroupAdded(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.publicGroupUpdated(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedMenuListener.publicGroupDeleted(String groupId, PublicGroup publicGroup) パブリックグループがデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable の使用

PublicGroupTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group パブリックグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group での PublicGroupTerminable の使用

PublicGroupTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のメソッド
PublicGroupTerminable | PublicGroup.getPublicGroupTerminable(Term term) 指定された期間に対する期間化情報を取得します。
PublicGroupTerminable | PublicGroup.getPublicGroupTerminable(Date date) 指定された日時に対する期間化情報を取得します。

PublicGroupTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のメソッド
 void PublicGroup.putPublicGroupTerminable(Term term, PublicGroupTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational の使用

PublicGroupTerminableInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group パブリックグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group での PublicGroupTerminableInternational の使用

PublicGroupTerminableInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のメソッド
 PublicGroupTerminableInternational PublicGroupTerminable.getPublicGroupTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。

PublicGroupTerminableInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のメソッド
 void PublicGroupTerminable.putPublicGroupTerminableInternational(Locale locale, PublicGroupTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.domain.public_group.group (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.public_group.group
クラス
PublicGroup
PublicGroupTerminable
PublicGroupTerminableInternational


jp.co.intra_mart.foundation.datastore.application.domain.public_group.group (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.group

パブリックグループ情報を操作するクラスを提供します。

参照:
説明

クラスの概要
PublicGroup | パブリックグループの基本属性のデータを取り扱います。
PublicGroupTerminable | パブリックグループの期間化属性のデータを取り扱います。
PublicGroupTerminableInternational | パブリックグループの期間国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.group の説明

パブリックグループ情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.public_group.group クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.group の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.group の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group の使用

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のクラス
PublicGroup
パブリックグループの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のクラス
PublicGroup
パブリックグループの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のクラス
PublicGroupTerminable
パブリックグループの期間化属性のデータを取り扱います。
PublicGroupTerminableInternational
パブリックグループの期間国際化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のクラス
PublicGroup
パブリックグループの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のクラス
PublicGroup
パブリックグループの基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroup (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group
クラス PublicGroup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup
すべての実装インタフェース:
Serializable
public class PublicGroup
extends Object
implements Serializable

パブリックグループの基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroup()
パブリックグループに関連する情報を新規に生成します。
PublicGroup(Date date)
パブリックグループに関連する情報を新規に生成します。
PublicGroup(Locale locale)
パブリックグループに関連する情報を新規に生成します。
PublicGroup(Locale locale, Date date)
パブリックグループに関連する情報を新規に生成します。
メソッドの概要
Date | getDefaultDate() デフォルトの日時を取得します。
Locale | getDefaultLocale() デフォルトのロケールを取得します。
String | getName() グループ名を取得します。
String | getName(Date date) グループ名を取得します。
String | getName(Date date, Locale locale) グループ名を取得します。
String | getName(Locale locale) グループ名を取得します。
String | getNameEnglish() グループ名英字を取得します。
String | getNameEnglish(Date date) グループ名英字を取得します。
String | getNameEnglish(Date date, Locale locale) グループ名英字を取得します。
String | getNameEnglish(Locale locale) グループ名英字を取得します。
String | getNameSyllabary() グループ名カナを取得します。
String | getNameSyllabary(Date date) グループ名カナを取得します。
String | getNameSyllabary(Date date, Locale locale) グループ名カナを取得します。
String | getNameSyllabary(Locale locale) グループ名カナを取得します。
String | getNotes() 備考を取得します。
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
PublicGroupTerminable | getPublicGroupTerminable(Date date) 指定された日時に対する期間化情報を取得します。
PublicGroupTerminable | getPublicGroupTerminable(Term term) 指定された期間に対する期間化情報を取得します。
int | getSortKey() ソートキーを取得します。
Term[] | getTerms() このパブリックグループで管理している期間をすべて取得します。
void | putPublicGroupTerminable(Term term, PublicGroupTerminable data) 指定された期間に対する期間化情報を設定します。
void | removePublicGroupTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setDefaultLocale(Locale defaultLocale) デフォルトのロケールを設定します。
void | setNotes(String notes) 備考を設定します。
void | setPublicGroupCode(String publicGroupCode) グループコードを設定します。
void | setPublicGroupSetCode(String publicGroupSetCode) グループセットコードを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroup

public PublicGroup()
パブリックグループに関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

PublicGroup

public PublicGroup(Locale locale)
パブリックグループに関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

パラメータ:
locale - デフォルトの言語

PublicGroup

public PublicGroup(Date date)
パブリックグループに関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時

PublicGroup

public PublicGroup(Locale locale,
                   Date date)
パブリックグループに関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
locale - デフォルトの言語
date - デフォルトの日時
メソッドの詳細

getDefaultLocale

public Locale getDefaultLocale()
デフォルトのロケールを取得します。

戻り値:
デフォルトのロケール

setDefaultLocale

public void setDefaultLocale(Locale defaultLocale)
デフォルトのロケールを設定します。

パラメータ:
defaultLocale - デフォルトのロケール

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
このパブリックグループで管理している期間をすべて取得します。

戻り値:
このパブリックグループで管理している期間

getPublicGroupTerminable

public PublicGroupTerminable getPublicGroupTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getPublicGroupTerminable

public PublicGroupTerminable getPublicGroupTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putPublicGroupTerminable

public void putPublicGroupTerminable(Term term,
                                     PublicGroupTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removePublicGroupTerminable

public void removePublicGroupTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getPublicGroupSetCode

public String getPublicGroupSetCode()
グループセットコードを取得します。

戻り値:
グループセットコード

setPublicGroupSetCode

public void setPublicGroupSetCode(String publicGroupSetCode)
グループセットコードを設定します。

パラメータ:
publicGroupSetCode - グループセットコード

getPublicGroupCode

public String getPublicGroupCode()
グループコードを取得します。

戻り値:
グループコード

setPublicGroupCode

public void setPublicGroupCode(String publicGroupCode)
グループコードを設定します。

パラメータ:
publicGroupCode - グループコード

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー

getName

public String getName()
グループ名を取得します。

戻り値:
グループ名

getName

public String getName(Date date)
グループ名を取得します。

パラメータ:
date - 日時
戻り値:
グループ名

getName

public String getName(Locale locale)
グループ名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名

getName

public String getName(Date date,
                      Locale locale)
グループ名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
グループ名

getNameSyllabary

public String getNameSyllabary()
グループ名カナを取得します。

戻り値:
グループ名カナ

getNameSyllabary

public String getNameSyllabary(Date date)
グループ名カナを取得します。

パラメータ:
date - 日時
戻り値:
グループ名カナ

getNameSyllabary

public String getNameSyllabary(Locale locale)
グループ名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名カナ

getNameSyllabary

public String getNameSyllabary(Date date,
                               Locale locale)
グループ名カナを取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
グループ名カナ

getNameEnglish

public String getNameEnglish()
グループ名英字を取得します。

戻り値:
グループ名英字

getNameEnglish

public String getNameEnglish(Date date)
グループ名英字を取得します。

パラメータ:
date - 日時
戻り値:
グループ名英字

getNameEnglish

public String getNameEnglish(Locale locale)
グループ名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名英字

getNameEnglish

public String getNameEnglish(Date date,
                             Locale locale)
グループ名英字を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
グループ名英字
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupTerminable (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group
クラス PublicGroupTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable
すべての実装インタフェース:
Serializable
public class PublicGroupTerminable
extends Object
implements Serializable

パブリックグループの期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupTerminable()
メソッドの概要
Locale[] | getLocales() このパブリックグループで管理している言語（ロケール）をすべて取得します。
PublicGroupTerminableInternational | getPublicGroupTerminableInternational(Locale locale) 指定された言語に対する期間国際化情報を取得します。
void | putPublicGroupTerminableInternational(Locale locale, PublicGroupTerminableInternational data) 指定された言語に対する期間国際化情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupTerminable

public PublicGroupTerminable()
メソッドの詳細

getLocales

public Locale[] getLocales()
このパブリックグループで管理している言語（ロケール）をすべて取得します。

戻り値:
このパブリックグループで管理している言語（ロケール）

getPublicGroupTerminableInternational

public PublicGroupTerminableInternational getPublicGroupTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
期間国際化情報

putPublicGroupTerminableInternational

public void putPublicGroupTerminableInternational(Locale locale,
                                                  PublicGroupTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 期間国際化情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PublicGroupTerminableInternational (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group
クラス PublicGroupTerminableInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational
すべての実装インタフェース:
Serializable
public class PublicGroupTerminableInternational
extends Object
implements Serializable

パブリックグループの期間国際化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupTerminableInternational()
メソッドの概要
String | getName() グループ名を取得します。
String | getNameEnglish() グループ名英字を取得します。
String | getNameSyllabary() グループ名カナを取得します。
void | setName(String name) グループ名を設定します。
void | setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupTerminableInternational

public PublicGroupTerminableInternational()
メソッドの詳細

getName

public String getName()
グループ名を取得します。

戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
グループ名を設定します。

パラメータ:
name - グループ名

getNameSyllabary

public String getNameSyllabary()
グループ名カナを取得します。

戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ

getNameEnglish

public String getNameEnglish()
グループ名英字を取得します。

戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet の使用

PublicGroupSet を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での PublicGroupSet の使用

PublicGroupSet 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract void | PublicGroupManager.addGroupSet(PublicGroupSet groupSet) パブリックグループセットを登録します。
abstract void | PublicGroupManager.deleteGroupSet(PublicGroupSet groupSet) 登録済のパブリックグループセットを削除します。
void | PublicGroupChangedListener.groupSetAdded(String groupId, PublicGroupSet groupSet) グループセットがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.groupSetDeleted(String groupId, PublicGroupSet groupSet) グループセットがデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.access での PublicGroupSet の使用

PublicGroupSet 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | PublicGroupChangedControllerListener.groupSetAdded(String groupId, PublicGroupSet groupSet) グループセットがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedControllerListener.groupSetDeleted(String groupId, PublicGroupSet groupSet) グループセットがデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での PublicGroupSet の使用

PublicGroupSet 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | PublicGroupChangedMenuListener.groupSetAdded(String groupId, PublicGroupSet groupSet) グループセットがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.groupSetDeleted(String groupId, PublicGroupSet groupSet) グループセットがデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable の使用

PublicGroupSetTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set パブリックグループセット情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set での PublicGroupSetTerminable の使用

PublicGroupSetTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のメソッド
PublicGroupSetTerminable | PublicGroupSet.getPublicGroupSetTerminable(Term term) 指定された期間に対する期間化情報を取得します。
PublicGroupSetTerminable | PublicGroupSet.getPublicGroupSetTerminable(Date date) 指定された日時に対する期間化情報を取得します。

PublicGroupSetTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のメソッド
 void PublicGroupSet.putPublicGroupSetTerminable(Term term, PublicGroupSetTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational の使用

PublicGroupSetTerminableInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set パブリックグループセット情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set での PublicGroupSetTerminableInternational の使用

PublicGroupSetTerminableInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のメソッド
 PublicGroupSetTerminableInternational PublicGroupSetTerminable.getPublicGroupSetTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。

PublicGroupSetTerminableInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のメソッド
 void PublicGroupSetTerminable.putPublicGroupSetTerminableInternational(Locale locale, PublicGroupSetTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.domain.public_group.set (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.public_group.set
クラス
PublicGroupSet
PublicGroupSetTerminable
PublicGroupSetTerminableInternational


jp.co.intra_mart.foundation.datastore.application.domain.public_group.set (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.set

パブリックグループセット情報を操作するクラスを提供します。

参照:
説明

クラスの概要
PublicGroupSet | パブリックグループセットの基本属性のデータを取り扱います。
PublicGroupSetTerminable | パブリックグループセットの期間化属性のデータを取り扱います。
PublicGroupSetTerminableInternational | パブリックグループセットの期間国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.set の説明

パブリックグループセット情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.public_group.set クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.set の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.set の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set の使用

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set | パブリックグループセット情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のクラス
PublicGroupSet
パブリックグループセットの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のクラス
PublicGroupSetTerminable
パブリックグループセットの期間化属性のデータを取り扱います。
PublicGroupSetTerminableInternational
パブリックグループセットの期間国際化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のクラス
PublicGroupSet
パブリックグループセットの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のクラス
PublicGroupSet
パブリックグループセットの基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupSet (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set
クラス PublicGroupSet

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet
すべての実装インタフェース:
Serializable
public class PublicGroupSet
extends Object
implements Serializable

パブリックグループセットの基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupSet()
パブリックグループセットに関連する情報を新規に生成します。
PublicGroupSet(Date date)
パブリックグループセットに関連する情報を新規に生成します。
PublicGroupSet(Locale locale)
パブリックグループセットに関連する情報を新規に生成します。
PublicGroupSet(Locale locale, Date date)
パブリックグループセットに関連する情報を新規に生成します。
メソッドの概要
Date | getDefaultDate() デフォルトの日時を取得します。
Locale | getDefaultLocale() デフォルトのロケールを取得します。
String | getName() グループ名を取得します。
String | getName(Date date) グループ名を取得します。
String | getName(Date date, Locale locale) グループ名を取得します。
String | getName(Locale locale) グループ名を取得します。
String | getNameEnglish() グループ名英字を取得します。
String | getNameEnglish(Date date) グループ名英字を取得します。
String | getNameEnglish(Date date, Locale locale) グループ名英字を取得します。
String | getNameEnglish(Locale locale) グループ名英字を取得します。
String | getNameSyllabary() グループ名カナを取得します。
String | getNameSyllabary(Date date) グループ名カナを取得します。
String | getNameSyllabary(Date date, Locale locale) グループ名カナを取得します。
String | getNameSyllabary(Locale locale) グループ名カナを取得します。
String | getNotes() 備考を取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
PublicGroupSetTerminable | getPublicGroupSetTerminable(Date date) 指定された日時に対する期間化情報を取得します。
PublicGroupSetTerminable | getPublicGroupSetTerminable(Term term) 指定された期間に対する期間化情報を取得します。
int | getSortKey() ソートキーを取得します。
Term[] | getTerms() このパブリックグループセットで管理している期間をすべて取得します。
void | putPublicGroupSetTerminable(Term term, PublicGroupSetTerminable data) 指定された期間に対する期間化情報を設定します。
void | removePublicGroupSetTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setDefaultLocale(Locale defaultLocale) デフォルトのロケールを設定します。
void | setNotes(String notes) 備考を設定します。
void | setPublicGroupSetCode(String publicGroupSetCode) グループセットコードを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupSet

public PublicGroupSet()
パブリックグループセットに関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

PublicGroupSet

public PublicGroupSet(Locale locale)
パブリックグループセットに関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

パラメータ:
locale - デフォルトの言語

PublicGroupSet

public PublicGroupSet(Date date)
パブリックグループセットに関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時

PublicGroupSet

public PublicGroupSet(Locale locale,
                      Date date)
パブリックグループセットに関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
locale - デフォルトの言語
date - デフォルトの日時
メソッドの詳細

getDefaultLocale

public Locale getDefaultLocale()
デフォルトのロケールを取得します。

戻り値:
デフォルトのロケール

setDefaultLocale

public void setDefaultLocale(Locale defaultLocale)
デフォルトのロケールを設定します。

パラメータ:
defaultLocale - デフォルトのロケール

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
このパブリックグループセットで管理している期間をすべて取得します。

戻り値:
このパブリックグループセットで管理している期間

getPublicGroupSetTerminable

public PublicGroupSetTerminable getPublicGroupSetTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getPublicGroupSetTerminable

public PublicGroupSetTerminable getPublicGroupSetTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putPublicGroupSetTerminable

public void putPublicGroupSetTerminable(Term term,
                                        PublicGroupSetTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removePublicGroupSetTerminable

public void removePublicGroupSetTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getPublicGroupSetCode

public String getPublicGroupSetCode()
グループセットコードを取得します。

戻り値:
グループセットコード

setPublicGroupSetCode

public void setPublicGroupSetCode(String publicGroupSetCode)
グループセットコードを設定します。

パラメータ:
publicGroupSetCode - グループセットコード

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー

getName

public String getName()
グループ名を取得します。

戻り値:
グループ名

getName

public String getName(Date date)
グループ名を取得します。

パラメータ:
date - 日時
戻り値:
グループ名

getName

public String getName(Locale locale)
グループ名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名

getName

public String getName(Date date,
                      Locale locale)
グループ名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
グループ名

getNameSyllabary

public String getNameSyllabary()
グループ名カナを取得します。

戻り値:
グループ名カナ

getNameSyllabary

public String getNameSyllabary(Date date)
グループ名カナを取得します。

パラメータ:
date - 日時
戻り値:
グループ名カナ

getNameSyllabary

public String getNameSyllabary(Locale locale)
グループ名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名カナ

getNameSyllabary

public String getNameSyllabary(Date date,
                               Locale locale)
グループ名カナを取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
グループ名カナ

getNameEnglish

public String getNameEnglish()
グループ名英字を取得します。

戻り値:
グループ名英字

getNameEnglish

public String getNameEnglish(Date date)
グループ名英字を取得します。

パラメータ:
date - 日時
戻り値:
グループ名英字

getNameEnglish

public String getNameEnglish(Locale locale)
グループ名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名英字

getNameEnglish

public String getNameEnglish(Date date,
                             Locale locale)
グループ名英字を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
グループ名英字
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupSetTerminable (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set
クラス PublicGroupSetTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable
すべての実装インタフェース:
Serializable
public class PublicGroupSetTerminable
extends Object
implements Serializable

パブリックグループセットの期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupSetTerminable()
メソッドの概要
Locale[] | getLocales() このパブリックグループセットで管理している言語（ロケール）をすべて取得します。
PublicGroupSetTerminableInternational | getPublicGroupSetTerminableInternational(Locale locale) 指定された言語に対する期間国際化情報を取得します。
void | putPublicGroupSetTerminableInternational(Locale locale, PublicGroupSetTerminableInternational data) 指定された言語に対する期間国際化情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupSetTerminable

public PublicGroupSetTerminable()
メソッドの詳細

getLocales

public Locale[] getLocales()
このパブリックグループセットで管理している言語（ロケール）をすべて取得します。

戻り値:
このパブリックグループセットで管理している言語（ロケール）

getPublicGroupSetTerminableInternational

public PublicGroupSetTerminableInternational getPublicGroupSetTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
期間国際化情報

putPublicGroupSetTerminableInternational

public void putPublicGroupSetTerminableInternational(Locale locale,
                                                     PublicGroupSetTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 期間国際化情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PublicGroupSetTerminableInternational (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set
クラス PublicGroupSetTerminableInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational
すべての実装インタフェース:
Serializable
public class PublicGroupSetTerminableInternational
extends Object
implements Serializable

パブリックグループセットの期間国際化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupSetTerminableInternational()
メソッドの概要
String | getName() グループ名を取得します。
String | getNameEnglish() グループ名英字を取得します。
String | getNameSyllabary() グループ名カナを取得します。
void | setName(String name) グループ名を設定します。
void | setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupSetTerminableInternational

public PublicGroupSetTerminableInternational()
メソッドの詳細

getName

public String getName()
グループ名を取得します。

戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
グループ名を設定します。

パラメータ:
name - グループ名

getNameSyllabary

public String getNameSyllabary()
グループ名カナを取得します。

戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ

getNameEnglish

public String getNameEnglish()
グループ名英字を取得します。

戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion の使用

PublicGroupVersion を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での PublicGroupVersion の使用

PublicGroupVersion を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract PublicGroupVersion | PublicGroupManager.getVersion(String groupSet) 現在のパブリックグループセット構成バージョン情報を取得します。
abstract PublicGroupVersion | PublicGroupManager.getVersion(String groupSet, Date date) 指定された日付のパブリックグループセット構成バージョン情報を取得します。

PublicGroupVersion 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract void | PublicGroupManager.addVersion(PublicGroupVersion version) パブリックグループセット構成バージョンを新規に登録します。
abstract void | PublicGroupManager.updateVersion(PublicGroupVersion version) 登録済のパブリックグループセット構成バージョンを更新します。
abstract void | PublicGroupManager.deleteVersion(PublicGroupVersion version) 登録済のパブリックグループセット構成バージョンを削除します。
void | PublicGroupChangedListener.versionAdded(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.versionUpdated(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedListener.versionDeleted(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.access での PublicGroupVersion の使用

PublicGroupVersion 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | PublicGroupChangedControllerListener.versionAdded(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedControllerListener.versionUpdated(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedControllerListener.versionDeleted(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での PublicGroupVersion の使用

PublicGroupVersion 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | PublicGroupChangedMenuListener.versionAdded(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.versionUpdated(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedMenuListener.versionDeleted(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.domain.public_group.version (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.public_group.version
クラス
PublicGroupVersion


jp.co.intra_mart.foundation.datastore.application.domain.public_group.version (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.version

パブリックグループバージョン情報を操作するクラスを提供します。

参照:
説明

クラスの概要
PublicGroupVersion パブリックグループ構成バージョンの基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.version の説明

パブリックグループバージョン情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.public_group.version クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.version の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.version の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.version の使用

jp.co.intra_mart.foundation.datastore.application.domain.public_group.version を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.version のクラス
PublicGroupVersion
パブリックグループ構成バージョンの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.version のクラス
PublicGroupVersion
パブリックグループ構成バージョンの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.version のクラス
PublicGroupVersion
パブリックグループ構成バージョンの基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupVersion (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.version
クラス PublicGroupVersion

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion
すべての実装インタフェース:
Serializable
public class PublicGroupVersion
extends Object
implements Serializable

パブリックグループ構成バージョンの基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupVersion()
メソッドの概要
Date | getEndDate() 終了日を取得します。
String | getNotes() 備考を取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
Date | getStartDate() 開始日を取得します。
String | getVersionCode() バージョンコードを取得します。
void | setEndDate(Date endDate) 終了日を設定します。
void | setNotes(String notes) 備考を設定します。
void | setPublicGroupSetCode(String publicGroupSetCode) グループセットコードを設定します。
void | setStartDate(Date startDate) 開始日を設定します。
void | setVersionCode(String versionCode) バージョンコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupVersion

public PublicGroupVersion()
メソッドの詳細

getPublicGroupSetCode

public String getPublicGroupSetCode()
グループセットコードを取得します。

戻り値:
グループセットコード

setPublicGroupSetCode

public void setPublicGroupSetCode(String publicGroupSetCode)
グループセットコードを設定します。

パラメータ:
publicGroupSetCode - グループセットコード

getVersionCode

public String getVersionCode()
バージョンコードを取得します。

戻り値:
バージョンコード

setVersionCode

public void setVersionCode(String versionCode)
バージョンコードを設定します。

パラメータ:
versionCode - バージョンコード

getStartDate

public Date getStartDate()
開始日を取得します。

戻り値:
開始日

setStartDate

public void setStartDate(Date startDate)
開始日を設定します。

パラメータ:
startDate - 開始日

getEndDate

public Date getEndDate()
終了日を取得します。

戻り値:
終了日

setEndDate

public void setEndDate(Date endDate)
終了日を設定します。

パラメータ:
endDate - 終了日

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.public_group (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.public_group
インタフェース
PublicGroupChangedListener
PublicGroupImporter
PublicGroupStruct
クラス
PublicGroupManager
StandardPublicGroupImporter


jp.co.intra_mart.foundation.datastore.application.domain.public_group (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group

パブリックグループ情報を操作するクラスを提供します。

参照:
説明

インタフェースの概要
PublicGroupChangedListener | パブリックグループに関する情報の更新時のリスナーです。
PublicGroupImporter | パブリックグループのインポートのインターフェースです
PublicGroupStruct | 組織の階層です。

クラスの概要
PublicGroupManager | パブリックグループに関連する情報を管理します。
StandardPublicGroupImporter | パブリックグループのインポートを行います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group の説明

パブリックグループ情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.public_group クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener
  • interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group の使用

jp.co.intra_mart.foundation.datastore.application.domain.public_group を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group のクラス
PublicGroupImporter
パブリックグループのインポートのインターフェースです
PublicGroupManager
パブリックグループに関連する情報を管理します。
PublicGroupStruct
組織の階層です。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group のクラス
PublicGroupChangedListener
パブリックグループに関する情報の更新時のリスナーです。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group のクラス
PublicGroupChangedListener
パブリックグループに関する情報の更新時のリスナーです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupChangedListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group
インタフェース PublicGroupChangedListener

既知の実装クラスの一覧:
PublicGroupChangedControllerListener, PublicGroupChangedMenuListener
public interface PublicGroupChangedListener

パブリックグループに関する情報の更新時のリスナーです。

導入されたバージョン:
5.0

メソッドの概要
void | categoryDetailRemoved(String groupId, PublicGroupCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | categoryDetailSet(String groupId, PublicGroupCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | groupSetAdded(String groupId, PublicGroupSet groupSet) グループセットがデータストアに登録された後に呼び出されます。
void | groupSetDeleted(String groupId, PublicGroupSet groupSet) グループセットがデータストアから削除された後に呼び出されます。
void | init(Map params) アカウントリスナーの初期化を行います。
void | memberDeleted(String groupId, PublicGroupAttach attach) パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
void | memberSet(String groupId, PublicGroupAttach attach) パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
void | publicGroupAdded(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに登録された後に呼び出されます。
void | publicGroupDeleted(String groupId, PublicGroup publicGroup) パブリックグループがデータストアから削除された後に呼び出されます。
void | publicGroupJoined(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
void | publicGroupLeft(String groupId, String groupSet, String publicGroup, String version) パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
void | publicGroupMoved(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
void | publicGroupUpdated(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに更新された後に呼び出されます。
void | setUesrId(String userid) ログインユーザIDを設定します。
void | versionAdded(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
void | versionCopied(String groupId, String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
void | versionDeleted(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
void | versionUpdated(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。

メソッドの詳細

init

public void init(Map params)
アカウントリスナーの初期化を行います。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

パラメータ:
params - 初期化パラメータのマップ(Map)

setUesrId

public void setUesrId(String userid)
ログインユーザIDを設定します。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

パラメータ:
userid - ログインユーザID

groupSetAdded

public void groupSetAdded(String groupId,
                          PublicGroupSet groupSet)
                   throws ChangedListenerException
グループセットがデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
groupSet - グループセット
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

groupSetDeleted

public void groupSetDeleted(String groupId,
                            PublicGroupSet groupSet)
                     throws ChangedListenerException
グループセットがデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
groupSet - グループセット
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupAdded

public void publicGroupAdded(String groupId,
                             PublicGroup publicGroup)
                      throws ChangedListenerException
パブリックグループがデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupUpdated

public void publicGroupUpdated(String groupId,
                               PublicGroup publicGroup)
                        throws ChangedListenerException
パブリックグループがデータストアに更新された後に呼び出されます。

パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupDeleted

public void publicGroupDeleted(String groupId,
                               PublicGroup publicGroup)
                        throws ChangedListenerException
パブリックグループがデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupJoined

public void publicGroupJoined(String groupId,
                              String groupSet,
                              String parentGroup,
                              String publicGroup,
                              String version)
                       throws ChangedListenerException
パブリックグループ構成情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
groupSet - 上位パブリックグループと新規登録されるパブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup - 新規登録するパブリックグループの上位となるパブリックグループのグループコード（またはパブリックグループセットのグループセットコード）
publicGroup - パブリックグループ情報（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupMoved

public void publicGroupMoved(String groupId,
                             String groupSet,
                             String parentGroup,
                             String publicGroup,
                             String version)
                      throws ChangedListenerException
パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。

パラメータ:
groupId - ログイングループID
groupSet - 上位パブリックグループと移動対象のパブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup - 上位パブリックグループのグループコード（またはパブリックグループセットのグループセットコード）
publicGroup - 移動するパブリックグループのグループコード（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupLeft

public void publicGroupLeft(String groupId,
                            String groupSet,
                            String publicGroup,
                            String version)
                     throws ChangedListenerException
パブリックグループ構成情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
groupSet - グループセットコード
publicGroup - 離脱させるパブリックグループのグループコード（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailSet

public void categoryDetailSet(String groupId,
                              PublicGroupCategory category)
                       throws ChangedListenerException
分類区分情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
category - 分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailRemoved

public void categoryDetailRemoved(String groupId,
                                  PublicGroupCategory category)
                           throws ChangedListenerException
分類区分情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
category - 分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberSet

public void memberSet(String groupId,
                      PublicGroupAttach attach)
               throws ChangedListenerException
パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
attach - 割当られた人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberDeleted

public void memberDeleted(String groupId,
                          PublicGroupAttach attach)
                   throws ChangedListenerException
パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
attach - パブリックグループから外された人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionAdded

public void versionAdded(String groupId,
                         PublicGroupVersion version)
                  throws ChangedListenerException
パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
version - パブリックグループ構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionUpdated

public void versionUpdated(String groupId,
                           PublicGroupVersion version)
                    throws ChangedListenerException
パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。

パラメータ:
groupId - ログイングループID
version - パブリックグループセット構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionDeleted

public void versionDeleted(String groupId,
                           PublicGroupVersion version)
                    throws ChangedListenerException
パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
version - パブリックグループセット構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionCopied

public void versionCopied(String groupId,
                          String groupSet,
                          String srcVersion,
                          String destVersion,
                          Term term)
                   throws ChangedListenerException
登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
groupSet - コピー元、コピー先のパブリックグループセット構成バージョンのパブリックグループコード
srcVersion - コピー元のパブリックグループセット構成バージョンのバージョンコード
destVersion - コピー先のパブリックグループセット構成バージョンのバージョンコード
term - コピー先のパブリックグループセット構成バージョンの期間
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupImporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group
インタフェース PublicGroupImporter

既知の実装クラスの一覧:
StandardPublicGroupImporter
public interface PublicGroupImporter

パブリックグループのインポートのインターフェースです

導入されたバージョン:
5.0

メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。

メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PublicGroupManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group
クラス PublicGroupManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager
public abstract class PublicGroupManager
extends Object

パブリックグループに関連する情報を管理します。 このクラスのインスタンスは必ず getPublicGroupManager(String, String) で取得してください。

導入されたバージョン:
5.0

コンストラクタの概要
PublicGroupManager()
メソッドの概要
abstract void | addGroupSet(PublicGroupSet groupSet) パブリックグループセットを登録します。
abstract void | addPublicGroup(PublicGroup publicGroup) パブリックグループを登録します。
abstract void | addVersion(PublicGroupVersion version) パブリックグループセット構成バージョンを新規に登録します。
abstract void | copyVersion(String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーします。
abstract void | deleteGroupSet(PublicGroupSet groupSet) 登録済のパブリックグループセットを削除します。
abstract void | deleteMember(PublicGroupAttach attach) パブリックグループから人員をはずします。
abstract void | deletePublicGroup(PublicGroup publicGroup) 登録済のパブリックグループ情報を削除します。
abstract void | deleteVersion(PublicGroupVersion version) 登録済のパブリックグループセット構成バージョンを削除します。
abstract PublicGroup[] | getAttachedPublicGroups(String user) 現在、ユーザが所属しているパブリックグループの一覧を取得します。
abstract PublicGroup[] | getAttachedPublicGroups(String user, Date date) 指定された日付にユーザが所属しているパブリックグループの一覧を取得します。
abstract User[] | getMember(String groupSet, String publicGroup) 現在、パブリックグループに所属するる人員の一覧を取得します。
abstract User[] | getMember(String groupSet, String publicGroup, Date date) 指定された日付にパブリックグループに所属する人員の一覧を取得します。
abstract PublicGroup | getPublicGroup(String groupSet, String publicGroup) 登録済のパブリックグループを取得します。
abstract PublicGroupAttach | getPublicGroupAttach(String user, String groupSet, String publicGroup) ユーザのパブリックグループへの所属情報を取得します。
static PublicGroupManager | getPublicGroupManager(String user, String group) PublicGroupManagerを取得します。
abstract PublicGroupStruct[] | getPublicGroupStructs(String groupSet, String publicGroup, Date date, Locale locale) パブリックグループの階層構造を取得します。
abstract PublicGroupVersion | getVersion(String groupSet) 現在のパブリックグループセット構成バージョン情報を取得します。
abstract PublicGroupVersion | getVersion(String groupSet, Date date) 指定された日付のパブリックグループセット構成バージョン情報を取得します。
protected abstract void | init(String user, String group) PublicGroupManagerを初期化します。
abstract void | joinPublicGroup(String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成にパブリックグループを登録します。
abstract void | leavePublicGroup(String groupSet, String publicGroup, String version) パブリックグループ構成からパブリックグループ情報を離脱させます。
abstract void | movePublicGroup(String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成に登録済のパブリックグループ情報を移動します。
abstract void | removeCategoryDetail(PublicGroupCategory category) パブリックグループに対して指定された分類区分情報を削除します。
abstract void | setCategoryDetail(PublicGroupCategory category) パブリックグループに対して指定された分類区分情報を設定します。
abstract void | setMember(PublicGroupAttach attach) パブリックグループに人員を割り当てます。
abstract void | updatePublicGroup(PublicGroup publicGroup) 登録済のパブリックグループ情報を更新します。
abstract void | updateVersion(PublicGroupVersion version) 登録済のパブリックグループセット構成バージョンを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupManager

public PublicGroupManager()
メソッドの詳細

getPublicGroupManager

public static PublicGroupManager getPublicGroupManager(String user,
                                                       String group)
                                                throws ManagerException
PublicGroupManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するCompanyManager
例外:
ManagerException - PublicGroupManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
PublicGroupManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - 初期化に失敗

getPublicGroup

public abstract PublicGroup getPublicGroup(String groupSet,
                                           String publicGroup)
                                    throws ManagerException
登録済のパブリックグループを取得します。
グループセットコード、グループコードに一致するパブリックグループ情報が存在しない場合は nullを返します。

パラメータ:
groupSet - グループセットコード
publicGroup - グループコード
戻り値:
パブリックグループ情報
例外:
ManagerException - パブリックグループの取得に失敗
導入されたバージョン:
6.1

addGroupSet

public abstract void addGroupSet(PublicGroupSet groupSet)
                          throws ManagerException
パブリックグループセットを登録します。 このメソッドを実行すると下記のような動作が行われます。
  1. パブリックグループセットを新規登録する。
  2. パブリックグループセットに対応するパブリックグループを新規登録する。

パラメータ:
groupSet - パブリックグループセット情報
例外:
MapperException - パブリックグループセットの登録に失敗
ManagerException

deleteGroupSet

public abstract void deleteGroupSet(PublicGroupSet groupSet)
                             throws ManagerException
登録済のパブリックグループセットを削除します。 このメソッドを実行すると指定されたパブリックグループセットに関連する全ての情報が削除されます。
指定されたパブリックグループセットの情報が存在しない場合は ManagerException がスローされます。

パラメータ:
groupSet - パブリックグループセット情報
例外:
ManagerException - パブリックグループセットの削除に失敗

addPublicGroup

public abstract void addPublicGroup(PublicGroup publicGroup)
                             throws ManagerException
パブリックグループを登録します。 このメソッドを実行しただけではまだパブリックグループセットのパブリックグループ構成には追加されていません。 パブリックグループ構成に追加したい場合は joinPublicGroup(String, String, String, String)を使用してください。

パラメータ:
publicGroup - パブリックグループ情報
例外:
ManagerException - パブリックグループの登録に失敗

updatePublicGroup

public abstract void updatePublicGroup(PublicGroup publicGroup)
                                throws ManagerException
登録済のパブリックグループ情報を更新します。

パラメータ:
publicGroup - パブリックグループ情報
例外:
ManagerException - パブリックグループの更新に失敗

deletePublicGroup

public abstract void deletePublicGroup(PublicGroup publicGroup)
                                throws ManagerException
登録済のパブリックグループ情報を削除します。
指定されたパブリックグループの情報が存在しない場合は ManagerException がスローされます。

パラメータ:
publicGroup - パブリックグループ情報
例外:
ManagerException - パブリックグループの削除に失敗

joinPublicGroup

public abstract void joinPublicGroup(String groupSet,
                                     String parentGroup,
                                     String publicGroup,
                                     String version)
                              throws ManagerException
パブリックグループ構成にパブリックグループを登録します。 新しく親となるパブリックグループと登録対象のパブリックグループは同一のパブリックグループセットに所属している必要があります。
バージョンコードは登録済みのものを指定する必要があります。 親となるパブリックグループは、パブリックグループ内包に登録済みのものを指定する必要があります
指定されたパブリックグループが対象のバージョンにおいて既に登録されているときはこのメソッドは使用できません。

パラメータ:
groupSet - 上位パブリックグループと新規登録されるパブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup - 新規登録するパブリックグループの上位となるパブリックグループのグループコード（またはパブリックグループセットのグループセットコード）
publicGroup - パブリックグループ情報（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ManagerException - パブリックグループ構成にパブリックグループの登録に失敗

movePublicGroup

public abstract void movePublicGroup(String groupSet,
                                     String parentGroup,
                                     String publicGroup,
                                     String version)
                              throws ManagerException
パブリックグループ構成に登録済のパブリックグループ情報を移動します。 新しく上位となるパブリックグループと移動対象のパブリックグループは同一のパブリックグループセットに所属している必要があります。
また、パブリックグループ構成が循環するような移動はできません。 バージョンコードは登録済みのものを指定する必要があります

パラメータ:
groupSet - 上位パブリックグループと移動対象のパブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup - 上位パブリックグループのグループコード（またはパブリックグループセットのグループセットコード）
publicGroup - 移動するパブリックグループのグループコード（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ManagerException - パブリックグループの移動に失敗

leavePublicGroup

public abstract void leavePublicGroup(String groupSet,
                                      String publicGroup,
                                      String version)
                               throws ManagerException
パブリックグループ構成からパブリックグループ情報を離脱させます。 このメソッドを実行すると、指定されたパブリックグループを指定されたバージョンから削除します。 指定されたパブリックグループが子パブリックグループを持っていた場合、それらのパブリックグループも再帰的にこのバージョンから削除されます。 このメソッドを実行してもパブリックグループ情報そのものは残ります。
指定されたパブリックグループがグループ構成に登録されていない場合は ManagerException がスローされます。

パラメータ:
groupSet - グループセットコード
publicGroup - 離脱させるパブリックグループのグループコード（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ManagerException - パブリックグループ構成からパブリックグループの離脱の失敗

setCategoryDetail

public abstract void setCategoryDetail(PublicGroupCategory category)
                                throws ManagerException
パブリックグループに対して指定された分類区分情報を設定します。

パラメータ:
category - 設定する分類区分詳細情報
例外:
ManagerException - 分類区分情報の設定に失敗

removeCategoryDetail

public abstract void removeCategoryDetail(PublicGroupCategory category)
                                   throws ManagerException
パブリックグループに対して指定された分類区分情報を削除します。 指定された分類区分情報が存在しない場合は ManagerException がスローされます。

パラメータ:
category - 削除する分類区分詳細詳細情報
例外:
ManagerException - パブリックグループに対して指定された分類区分情報の削除に失敗

setMember

public abstract void setMember(PublicGroupAttach attach)
                        throws ManagerException
パブリックグループに人員を割り当てます。 人員の割当情報はパラメータで渡された情報で完全に上書きされます。

パラメータ:
attach - 割当人員の情報
例外:
ManagerException - 人員の割当に失敗

deleteMember

public abstract void deleteMember(PublicGroupAttach attach)
                           throws ManagerException
パブリックグループから人員をはずします。 削除対象となる期間は無限の過去から無限の未来となります。
指定された人員がパブリックグループに割り当てられていない場合は ManagerException がスローされます。

パラメータ:
attach - パブリックグループから外す人員の情報
例外:
ManagerException - パブリックグループから人員を外すことに失敗

getMember

public abstract User[] getMember(String groupSet,
                                 String publicGroup)
                          throws ManagerException
現在、パブリックグループに所属するる人員の一覧を取得します。
指定されたパブリックグループに人員が所属していない場合は空の配列を返します。

取得されるユーザの期間化情報には、システム日付を含む期間の情報のみが設定されます。
また期間国際化情報には、ログインユーザのデフォルト言語の情報のみが設定されます。

パラメータ:
groupSet - グループセットコード
publicGroup - グループコード
戻り値:
ユーザ情報
例外:
ManagerException - パブリックグループに所属する人員の取得に失敗
導入されたバージョン:
6.1

getMember

public abstract User[] getMember(String groupSet,
                                 String publicGroup,
                                 Date date)
                          throws ManagerException
指定された日付にパブリックグループに所属する人員の一覧を取得します。
指定されたパブリックグループに人員が所属していない場合は空の配列を返します。

取得されるユーザの期間化情報には、指定された日付を含む期間の情報のみが設定されます。
また期間国際化情報には、ログインユーザのデフォルト言語の情報のみが設定されます。

パラメータ:
groupSet - グループセットコード
publicGroup - グループコード
date - 日付
戻り値:
ユーザ情報
例外:
ManagerException - パブリックグループに所属する人員の取得に失敗
導入されたバージョン:
6.1

addVersion

public abstract void addVersion(PublicGroupVersion version)
                         throws ManagerException
パブリックグループセット構成バージョンを新規に登録します。 追加された構成バージョンのトップレベルには、パブリックグループセットが自動的に追加されます。

パラメータ:
version - バージョン情報
例外:
ManagerException - パブリックグループセット構成バージョンの登録に失敗

updateVersion

public abstract void updateVersion(PublicGroupVersion version)
                            throws ManagerException
登録済のパブリックグループセット構成バージョンを更新します。

パラメータ:
version - バージョン情報
例外:
ManagerException - パブリックグループセット構成バージョンの更新に失敗

deleteVersion

public abstract void deleteVersion(PublicGroupVersion version)
                            throws ManagerException
登録済のパブリックグループセット構成バージョンを削除します。
指定されたパブリックグループセット構成バージョンが存在しない場合は ManagerException がスローされます。

パラメータ:
version - バージョン情報
例外:
ManagerException - パブリックグループセット構成バージョンの削除に失敗

copyVersion

public abstract void copyVersion(String groupSet,
                                 String srcVersion,
                                 String destVersion,
                                 Term term)
                          throws ManagerException
登録済のパブリックグループセット構成バージョンの内容をコピーします。 コピー元のバージョンコードは登録済みのものを選択してください コピー先のバージョンコードは登録されていないものを選択してください

パラメータ:
groupSet - コピー元、コピー先のパブリックグループセット構成バージョンのグループセットコード
srcVersion - コピー元のパブリックグループセット構成バージョンのバージョンコード
destVersion - コピー先のパブリックグループセット構成バージョンのバージョンコード
term - コピー先のパブリックグループセット構成バージョンの期間
例外:
ManagerException - パブリックグループセット構成バージョンのコピーに失敗

getPublicGroupStructs

public abstract PublicGroupStruct[] getPublicGroupStructs(String groupSet,
                                                          String publicGroup,
                                                          Date date,
                                                          Locale locale)
                                                   throws ManagerException
パブリックグループの階層構造を取得します。 指定された日付に該当する、パブリックグループ構成バージョンがない時はエラーとなります。

パラメータ:
groupSet - グループセットコード
publicGroup - グループコード
date - 日付
locale - 言語(ロケール)
戻り値:
パブリックグループの階層構造
例外:
ManagerException - パブリックグループの階層構造の取得に失敗

getAttachedPublicGroups

public abstract PublicGroup[] getAttachedPublicGroups(String user)
                                               throws ManagerException
現在、ユーザが所属しているパブリックグループの一覧を取得します。
ユーザがどのパブリックグループにも所属していない場合は空の配列を返します。

取得されるパブリックグループの期間化情報には、システム日付を含む期間の情報のみが設定されます。
また期間国際化情報には、ログインユーザのデフォルト言語の情報のみが設定されます。

パラメータ:
user - ユーザコード
戻り値:
パブリックグループ情報
例外:
ManagerException - 指定されたユーザが所属しているパブリックグループの取得に失敗
導入されたバージョン:
6.1

getAttachedPublicGroups

public abstract PublicGroup[] getAttachedPublicGroups(String user,
                                                      Date date)
                                               throws ManagerException
指定された日付にユーザが所属しているパブリックグループの一覧を取得します。
ユーザがどのパブリックグループにも所属していない場合は空の配列を返します。

取得されるパブリックグループの期間化情報には、指定された日付を含む期間の情報のみが設定されます。
また期間国際化情報には、ログインユーザのデフォルト言語の情報のみが設定されます。

パラメータ:
user - ユーザコード
date - 日付
戻り値:
パブリックグループ情報
例外:
ManagerException - 指定されたユーザが所属しているパブリックグループの取得に失敗
導入されたバージョン:
6.1

getPublicGroupAttach

public abstract PublicGroupAttach getPublicGroupAttach(String user,
                                                       String groupSet,
                                                       String publicGroup)
                                                throws ManagerException
ユーザのパブリックグループへの所属情報を取得します。
該当するパブリックグループ所属が存在しない場合は nullを返します。

パラメータ:
user - ユーザコード
groupSet - パブリックグループセットコード
publicGroup - パブリックグループコード
戻り値:
パブリックグループ所属情報
例外:
ManagerException - パブリックグループ所属情報の取得に失敗
導入されたバージョン:
6.1

getVersion

public abstract PublicGroupVersion getVersion(String groupSet)
                                       throws ManagerException
現在のパブリックグループセット構成バージョン情報を取得します。
該当するパブリックグループセット構成バージョン情報が存在しない場合は null を返します。

パラメータ:
groupSet - パブリックグループセットコード
戻り値:
パブリックグループセット構成バージョン情報
例外:
ManagerException
導入されたバージョン:
6.1

getVersion

public abstract PublicGroupVersion getVersion(String groupSet,
                                              Date date)
                                       throws ManagerException
指定された日付のパブリックグループセット構成バージョン情報を取得します。
該当するパブリックグループセット構成バージョン情報が存在しない場合は null を返します。

パラメータ:
groupSet - パブリックグループセットコード
date - バージョンを特定する日付
戻り値:
パブリックグループセット構成バージョン情報
例外:
ManagerException
導入されたバージョン:
6.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupStruct (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group
インタフェース PublicGroupStruct

public interface PublicGroupStruct

組織の階層です。

導入されたバージョン:
5.0

メソッドの概要
String | getName() グループ名を取得します。
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。

メソッドの詳細

getPublicGroupSetCode

public String getPublicGroupSetCode()
グループセットコードを取得します。

戻り値:
グループセットコード

getPublicGroupCode

public String getPublicGroupCode()
グループコードを取得します。

戻り値:
グループコード

getName

public String getName()
グループ名を取得します。

戻り値:
グループ名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


StandardPublicGroupImporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group
クラス StandardPublicGroupImporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter
すべての実装インタフェース:
PublicGroupImporter
public class StandardPublicGroupImporter
extends Object
implements PublicGroupImporter

パブリックグループのインポートを行います。

導入されたバージョン:
5.0

コンストラクタの概要
StandardPublicGroupImporter()
メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardPublicGroupImporter

public StandardPublicGroupImporter()
メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

定義:
インタフェース PublicGroupImporter 内の doImport
パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager の使用

ItemUnitManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.unit 商品単位情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.unit での ItemUnitManager の使用

ItemUnitManager を返す jp.co.intra_mart.foundation.datastore.application.domain.unit のメソッド
static ItemUnitManager ItemUnitManager.getItemUnitManager(String user, String group)
ItemUnitManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemUnitManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.unit
クラス ItemUnitManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager
public abstract class ItemUnitManager
extends Object

商品の単位を取り扱います。

導入されたバージョン:
5.1

コンストラクタの概要
ItemUnitManager()
メソッドの概要
abstract boolean | addUnit(String unitCode, String unitName) 単位を追加します。
abstract void | deleteUnit(String unitCode) 単位を削除します。
static ItemUnitManager | getItemUnitManager(String user, String group) ItemUnitManagerを取得します。
abstract String | getUnitCode(String unitName) 単位名に対する単位コードを取得します。
abstract String | getUnitName(String unitCode) 単位コードに対する名称を返します。
abstract Map | getUnits() 単位の一覧を取得します。
protected abstract void | init(String user, String group) ItemUnitManagerを初期化します。
abstract boolean | updateUnit(String unitCode, String unitName) 単位を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ItemUnitManager

public ItemUnitManager()
メソッドの詳細

getItemUnitManager

public static ItemUnitManager getItemUnitManager(String user,
                                                 String group)
                                          throws ManagerException
ItemUnitManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するItemUnitManager
例外:
ManagerException - ItemUnitManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
ItemUnitManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - 初期化に失敗

getUnits

public abstract Map getUnits()
                      throws ManagerException
単位の一覧を取得します。 返却されるマップ Mapのキーには単位コード、値には単位名が設定されます。

戻り値:
単位コードの一覧
例外:
ManagerException - 単位の取得に失敗した場合

getUnitName

public abstract String getUnitName(String unitCode)
                            throws ManagerException
単位コードに対する名称を返します。 単位コードに対する名称が存在しない場合は、nullを返します。

パラメータ:
unitCode - 単位コード
戻り値:
単位名
例外:
ManagerException - 単位名の取得に失敗した場合

getUnitCode

public abstract String getUnitCode(String unitName)
                            throws ManagerException
単位名に対する単位コードを取得します。 単位名に対する単位コードが存在しない場合は、nullを返します。

パラメータ:
unitName - 単位名
戻り値:
単位コード
例外:
ManagerException - 単位コードの取得に失敗した場合

addUnit

public abstract boolean addUnit(String unitCode,
                                String unitName)
                         throws ManagerException
単位を追加します。

すでに同一の単位名のものが存在している場合は、登録を行いません。
その場合はfalseを返します。

パラメータ:
unitCode - 単位コード
unitName - 単位名
戻り値:
単位の登録を行った場合はtrue、行わなかった場合はfalse
例外:
ManagerException - 単位の追加に失敗した場合

updateUnit

public abstract boolean updateUnit(String unitCode,
                                   String unitName)
                            throws ManagerException
単位を更新します。 すでに同一の単位名のものが存在している場合は、更新を行いません。
その場合はfalseを返します。

パラメータ:
unitCode - 単位コード
unitName - 単位名
戻り値:
単位の更新を行った場合はtrue、行わなかった場合はfalse
例外:
ManagerException - 単位の更新に失敗した場合

deleteUnit

public abstract void deleteUnit(String unitCode)
                         throws ManagerException
単位を削除します。
指定された単位情報が存在しない場合は ManagerException がスローされます。

パラメータ:
unitCode - 単位コード
例外:
ManagerException - 単位の削除に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.unit (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.unit
クラス
ItemUnitManager


jp.co.intra_mart.foundation.datastore.application.domain.unit (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.unit

商品単位情報を操作するクラスを提供します。

参照:
説明

クラスの概要
ItemUnitManager 商品の単位を取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.unit の説明

商品単位情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.unit クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.unit の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.unit の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.unit の使用

jp.co.intra_mart.foundation.datastore.application.domain.unit を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.unit 商品単位情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.unit により使用される jp.co.intra_mart.foundation.datastore.application.domain.unit のクラス
ItemUnitManager
商品の単位を取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter の使用

jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.user.User の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.user.User の使用

User を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group | プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での User の使用

User を返す jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract User[] | CompanyManager.getMember(String company, String department) 現在、組織に所属するる人員の一覧を取得します。
abstract User[] | CompanyManager.getMember(String company, String department, Date date) 指定された日付に組織に所属する人員の一覧を取得します。

jp.co.intra_mart.foundation.datastore.application.domain.private_group での User の使用

User を返す jp.co.intra_mart.foundation.datastore.application.domain.private_group のメソッド
abstract User[] | PrivateGroupManager.getMember(String owner, String group) ログインユーザが持つ指定されたプライベートグループに所属する人員を取得します。
abstract User[] | PrivateGroupManager.getMember(String owner, String group, Date date) 指定されたプライベートグループに所属する人員を取得します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での User の使用

User を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract User[] | PublicGroupManager.getMember(String groupSet, String publicGroup) 現在、パブリックグループに所属するる人員の一覧を取得します。
abstract User[] | PublicGroupManager.getMember(String groupSet, String publicGroup, Date date) 指定された日付にパブリックグループに所属する人員の一覧を取得します。

jp.co.intra_mart.foundation.datastore.application.domain.user での User の使用

User を返す jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
abstract  User UserManager.getUser(String userCode)
登録済のユーザを取得します。

User 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
abstract void | UserManager.addUser(User user) ユーザを登録します。
abstract void | UserManager.updateUser(User user) 登録済のユーザを更新します。
abstract void | UserManager.deleteUser(User user) 登録済のユーザを削除します。
void | UserChangedListener.userAdded(String groupId, User user) ユーザ情報がデータストアに登録された後に呼び出されます。
void | UserChangedListener.userUpdated(String groupId, User user) ユーザ情報がデータストアに対して更新された後に呼び出されます。
void | UserChangedListener.userDeleted(String groupId, User user) ユーザ情報がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener の使用

jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter の使用

UserImporter を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.user ユーザ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.user での UserImporter の使用

UserImporter を実装している jp.co.intra_mart.foundation.datastore.application.domain.user のクラス
 class StandardUserImporter
ユーザプロファイルのインポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager の使用

UserManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.user ユーザ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.user での UserManager の使用

UserManager を返す jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
static UserManager UserManager.getUserManager(String user, String group)
UserManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable の使用

UserTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.user ユーザ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.user での UserTerminable の使用

UserTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
UserTerminable | User.getUserTerminable(Term term) 指定された期間に対する期間化情報を取得します。
UserTerminable | User.getUserTerminable(Date date) 指定された日時に対する期間化情報を取得します。

UserTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
 void User.putUserTerminable(Term term, UserTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational の使用

UserTerminableInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.user ユーザ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.user での UserTerminableInternational の使用

UserTerminableInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
 UserTerminableInternational UserTerminable.getUserTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。

UserTerminableInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
 void UserTerminable.putUserTerminableInternational(Locale locale, UserTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.domain.user (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.domain.user
インタフェース
UserChangedListener
UserImporter
クラス
StandardUserImporter
User
UserManager
UserTerminable
UserTerminableInternational


jp.co.intra_mart.foundation.datastore.application.domain.user (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.user

ユーザ情報を操作するクラスを提供します。

参照:
説明

インタフェースの概要
UserChangedListener | ユーザに関する情報の変更時のリスナーです。
UserImporter | ユーザインポーターのインタフェースです。

クラスの概要
StandardUserImporter | ユーザプロファイルのインポートを行います。
User | ユーザの基本属性のデータを取り扱います。
UserManager | ユーザに関連する情報を管理します。
UserTerminable | ユーザの期間化属性のデータを取り扱います。
UserTerminableInternational | ユーザの期間国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.user の説明

ユーザ情報を操作するクラスを提供します。


jp.co.intra_mart.foundation.datastore.application.domain.user クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.user の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.User (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational (implements java.io.Serializable)

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener
  • interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.user の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.user の使用

jp.co.intra_mart.foundation.datastore.application.domain.user を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group | プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.user のクラス
User
ユーザの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.private_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.user のクラス
User
ユーザの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.user のクラス
User
ユーザの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.user により使用される jp.co.intra_mart.foundation.datastore.application.domain.user のクラス
User
ユーザの基本属性のデータを取り扱います。
UserImporter
ユーザインポーターのインタフェースです。
UserManager
ユーザに関連する情報を管理します。
UserTerminable
ユーザの期間化属性のデータを取り扱います。
UserTerminableInternational
ユーザの期間国際化属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardUserImporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.user
クラス StandardUserImporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter
すべての実装インタフェース:
UserImporter
public class StandardUserImporter
extends Object
implements UserImporter

ユーザプロファイルのインポートを行います。

導入されたバージョン:
5.0

コンストラクタの概要
StandardUserImporter()
メソッドの概要
 void doImport(InputStream inputStream, String user, String group)
インポートを行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardUserImporter

public StandardUserImporter()
メソッドの詳細

doImport

public void doImport(InputStream inputStream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

定義:
インタフェース UserImporter 内の doImport
パラメータ:
inputStream - 入力ストリーム
user - ログインユーザ
group - ログイングループ
例外:
ImportException - インポートに失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


User (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.user
クラス User

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.user.User
すべての実装インタフェース:
Serializable
public class User
extends Object
implements Serializable

ユーザの基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
User()
ユーザに関連する情報を新規に生成します。
User(Date date)
ユーザに関連する情報を新規に生成します。
User(Locale locale)
ユーザに関連する情報を新規に生成します。
User(Locale locale, Date date)
ユーザに関連する情報を新規に生成します。
メソッドの概要
String | getAccountFlag() アカウントフラグを取得します。
String | getAddress() 住所を取得します。
String | getAddress(Date date) 住所を取得します。
String | getAddress(Date date, Locale locale) 住所を取得します。
String | getAddress(Locale locale) 住所を取得します。
String | getCountryCode() 国コードを取得します。
String | getCountryCode(Date date) 国コードを取得します。
Date | getDefaultDate() デフォルトの日時を取得します。
Locale | getDefaultLocale() デフォルトのロケールを取得します。
String | getEmailAddress1() メールアドレス１を取得します。
String | getEmailAddress1(Date date) メールアドレス１を取得します。
String | getEmailAddress2() メールアドレス２を取得します。
String | getEmailAddress2(Date date) メールアドレス２を取得します。
Map | getExtendedUser(String name) 指定された拡張情報を取得します。
Map | getExtendedUsers() このユーザの基本情報に対する拡張情報をすべて取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionFaxNumber(Date date) 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getExtensionNumber(Date date) 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
String | getFaxNumber(Date date) FAX番号を取得します。
String | getMobileEmailAddress() 携帯用メールを取得します。
String | getMobileEmailAddress(Date date) 携帯用メールを取得します。
String | getMobileNumber() 携帯電話番号を取得します。
String | getMobileNumber(Date date) 携帯電話番号を取得します。
String | getName() ユーザ名を取得します。
String | getName(Date date) ユーザ名を取得します。
String | getName(Date date, Locale locale) ユーザ名を取得します。
String | getName(Locale locale) ユーザ名を取得します。
String | getNameEnglish() ユーザ名英字を取得します。
String | getNameEnglish(Date date) ユーザ名英字を取得します。
String | getNameEnglish(Date date, Locale locale) ユーザ名英字を取得します。
String | getNameEnglish(Locale locale) ユーザ名英字を取得します。
String | getNameSyllabary() ユーザ名カナを取得します。
String | getNameSyllabary(Date date) ユーザ名カナを取得します。
String | getNameSyllabary(Date date, Locale locale) ユーザ名カナを取得します。
String | getNameSyllabary(Locale locale) ユーザ名カナを取得します。
String | getNotes() 備考を取得します。
int | getSortKey() ソートキーを取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getTelephoneNumber(Date date) 電話番号を取得します。
Term[] | getTerms() このユーザで管理している期間をすべて取得します。
String | getUrl() URLを取得します。
String | getUrl(Date date) URLを取得します。
String | getUserCode() ユーザコードを取得します。
UserTerminable | getUserTerminable(Date date) 指定された日時に対する期間化情報を取得します。
UserTerminable | getUserTerminable(Term term) 指定された期間に対する期間化情報を取得します。
String | getZipCode() 郵便番号を取得します。
String | getZipCode(Date date) 郵便番号を取得します。
void | putExtendedUser(String name, Map data) 指定された拡張情報を追加します。
void | putUserTerminable(Term term, UserTerminable data) 指定された期間に対する期間化情報を設定します。
void | removeUserTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setAccountFlag(String accountFlag) このメソッドはシステム内で使用されます。
void | setDefaultDate(Date defaultDate) デフォルトの日時を設定します。
void | setDefaultLocale(Locale defaultLocale) デフォルトのロケールを設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
void | setUserCode(String userCode) ユーザコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

User

public User()
ユーザに関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

User

public User(Locale locale)
ユーザに関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には現在のシステム日時が割り当てられます。

パラメータ:
locale - デフォルトの言語

User

public User(Date date)
ユーザに関連する情報を新規に生成します。 デフォルトの言語には Locale.getDefault()で取得される値が割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
date - デフォルトの日時

User

public User(Locale locale,
            Date date)
ユーザに関連する情報を新規に生成します。 デフォルトの言語には locale で設定されるロケールが割り当てられ、 デフォルトの日時には date で指定された日時が割り当てられます。

パラメータ:
locale - デフォルトの言語
date - デフォルトの日時
メソッドの詳細

getDefaultLocale

public Locale getDefaultLocale()
デフォルトのロケールを取得します。

戻り値:
デフォルトのロケール

setDefaultLocale

public void setDefaultLocale(Locale defaultLocale)
デフォルトのロケールを設定します。

パラメータ:
defaultLocale - デフォルトのロケール

getDefaultDate

public Date getDefaultDate()
デフォルトの日時を取得します。

戻り値:
デフォルトの日時

setDefaultDate

public void setDefaultDate(Date defaultDate)
デフォルトの日時を設定します。

パラメータ:
defaultDate - デフォルトの日時

getTerms

public Term[] getTerms()
このユーザで管理している期間をすべて取得します。

戻り値:
このユーザで管理している期間

getUserTerminable

public UserTerminable getUserTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getUserTerminable

public UserTerminable getUserTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putUserTerminable

public void putUserTerminable(Term term,
                              UserTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removeUserTerminable

public void removeUserTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getExtendedUsers

public Map getExtendedUsers()
このユーザの基本情報に対する拡張情報をすべて取得します。 返される値は拡張名をキー、 拡張情報を値とした Mapです。

戻り値:
基本情報に対するすべての拡張情報
導入されたバージョン:
5.1.5

getExtendedUser

public Map getExtendedUser(String name)
指定された拡張情報を取得します。

パラメータ:
name - 拡張名
戻り値:
基本情報に対する拡張情報
導入されたバージョン:
5.1.5

putExtendedUser

public void putExtendedUser(String name,
                            Map data)
指定された拡張情報を追加します。 返される値は属性名をキー、 属性値を値とした Mapです。

パラメータ:
name - 拡張名
data - 基本情報に対する拡張情報
導入されたバージョン:
5.1.5

getUserCode

public String getUserCode()
ユーザコードを取得します。

戻り値:
ユーザコード

setUserCode

public void setUserCode(String userCode)
ユーザコードを設定します。

パラメータ:
userCode - ユーザコード

getAccountFlag

public String getAccountFlag()
アカウントフラグを取得します。

戻り値:
アカウントフラグ

setAccountFlag

public void setAccountFlag(String accountFlag)
このメソッドはシステム内で使用されます。明示的に使用しないでください。

パラメータ:
accountFlag - アカウントフラグ

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー

getTelephoneNumber

public String getTelephoneNumber()
電話番号を取得します。

戻り値:
電話番号

getTelephoneNumber

public String getTelephoneNumber(Date date)
電話番号を取得します。

パラメータ:
date - 日時
戻り値:
電話番号

getMobileNumber

public String getMobileNumber()
携帯電話番号を取得します。

戻り値:
携帯電話番号

getMobileNumber

public String getMobileNumber(Date date)
携帯電話番号を取得します。

パラメータ:
date - 日時
戻り値:
携帯電話番号

getFaxNumber

public String getFaxNumber()
FAX番号を取得します。

戻り値:
FAX番号

getFaxNumber

public String getFaxNumber(Date date)
FAX番号を取得します。

パラメータ:
date - 日時
戻り値:
FAX番号

getExtensionNumber

public String getExtensionNumber()
内線番号を取得します。

戻り値:
内線番号

getExtensionNumber

public String getExtensionNumber(Date date)
内線番号を取得します。

パラメータ:
date - 日時
戻り値:
内線番号

getExtensionFaxNumber

public String getExtensionFaxNumber()
内線FAX番号を取得します。

戻り値:
内線FAX番号

getExtensionFaxNumber

public String getExtensionFaxNumber(Date date)
内線FAX番号を取得します。

パラメータ:
date - 日時
戻り値:
内線FAX番号

getCountryCode

public String getCountryCode()
国コードを取得します。

戻り値:
国コード

getCountryCode

public String getCountryCode(Date date)
国コードを取得します。

パラメータ:
date - 日時
戻り値:
国コード

getZipCode

public String getZipCode()
郵便番号を取得します。

戻り値:
郵便番号

getZipCode

public String getZipCode(Date date)
郵便番号を取得します。

パラメータ:
date - 日時
戻り値:
郵便番号

getEmailAddress1

public String getEmailAddress1()
メールアドレス１を取得します。

戻り値:
メールアドレス１

getEmailAddress1

public String getEmailAddress1(Date date)
メールアドレス１を取得します。

パラメータ:
date - 日時
戻り値:
メールアドレス１

getEmailAddress2

public String getEmailAddress2()
メールアドレス２を取得します。

戻り値:
メールアドレス２

getEmailAddress2

public String getEmailAddress2(Date date)
メールアドレス２を取得します。

パラメータ:
date - 日時
戻り値:
メールアドレス２

getMobileEmailAddress

public String getMobileEmailAddress()
携帯用メールを取得します。

戻り値:
携帯用メール

getMobileEmailAddress

public String getMobileEmailAddress(Date date)
携帯用メールを取得します。

パラメータ:
date - 日時
戻り値:
携帯用メール

getUrl

public String getUrl()
URLを取得します。

戻り値:
URL

getUrl

public String getUrl(Date date)
URLを取得します。

パラメータ:
date - 日時
戻り値:
URL

getName

public String getName()
ユーザ名を取得します。

戻り値:
ユーザ名

getName

public String getName(Date date)
ユーザ名を取得します。

パラメータ:
date - 日時
戻り値:
ユーザ名

getName

public String getName(Locale locale)
ユーザ名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザ名

getName

public String getName(Date date,
                      Locale locale)
ユーザ名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
ユーザ名

getNameSyllabary

public String getNameSyllabary()
ユーザ名カナを取得します。

戻り値:
ユーザ名カナ

getNameSyllabary

public String getNameSyllabary(Date date)
ユーザ名カナを取得します。

パラメータ:
date - 日時
戻り値:
ユーザ名カナ

getNameSyllabary

public String getNameSyllabary(Locale locale)
ユーザ名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザ名カナ

getNameSyllabary

public String getNameSyllabary(Date date,
                               Locale locale)
ユーザ名カナを取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
ユーザ名カナ

getNameEnglish

public String getNameEnglish()
ユーザ名英字を取得します。

戻り値:
ユーザ名英字

getNameEnglish

public String getNameEnglish(Date date)
ユーザ名英字を取得します。

パラメータ:
date - 日時
戻り値:
ユーザ名英字

getNameEnglish

public String getNameEnglish(Locale locale)
ユーザ名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザ名英字

getNameEnglish

public String getNameEnglish(Date date,
                             Locale locale)
ユーザ名英字を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
ユーザ名英字

getAddress

public String getAddress()
住所を取得します。

戻り値:
住所

getAddress

public String getAddress(Date date)
住所を取得します。

パラメータ:
date - 日時
戻り値:
住所

getAddress

public String getAddress(Locale locale)
住所を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所

getAddress

public String getAddress(Date date,
                         Locale locale)
住所を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
住所
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserChangedListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.user
インタフェース UserChangedListener

public interface UserChangedListener

ユーザに関する情報の変更時のリスナーです。

導入されたバージョン:
5.0

メソッドの概要
void | init(Map params) ユーザリスナーの初期化を行います。
void | setUesrId(String userid) ログインユーザIDを設定します。
void | userAdded(String groupId, User user) ユーザ情報がデータストアに登録された後に呼び出されます。
void | userDeleted(String groupId, User user) ユーザ情報がデータストアから削除された後に呼び出されます。
void | userUpdated(String groupId, User user) ユーザ情報がデータストアに対して更新された後に呼び出されます。

メソッドの詳細

init

public void init(Map params)
ユーザリスナーの初期化を行います。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

パラメータ:
params - 初期化パラメータのマップ(Map)

setUesrId

public void setUesrId(String userid)
ログインユーザIDを設定します。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

パラメータ:
userid - ログインユーザID

userAdded

public void userAdded(String groupId,
                      User user)
               throws ChangedListenerException
ユーザ情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
user - ユーザ情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

userUpdated

public void userUpdated(String groupId,
                        User user)
                 throws ChangedListenerException
ユーザ情報がデータストアに対して更新された後に呼び出されます。

パラメータ:
groupId - ログイングループID
user - ユーザ情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

userDeleted

public void userDeleted(String groupId,
                        User user)
                 throws ChangedListenerException
ユーザ情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
user - ユーザ情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UserImporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.user
インタフェース UserImporter

既知の実装クラスの一覧:
StandardUserImporter
public interface UserImporter

ユーザインポーターのインタフェースです。

導入されたバージョン:
5.0

メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。

メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

パラメータ:
inputstream - 入力ストリーム
user - ログインユーザ
group - ログイングループ
例外:
ImportException - インポートに失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UserManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.user
クラス UserManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager
public abstract class UserManager
extends Object

ユーザに関連する情報を管理します。 このクラスのインスタンスは必ず getUserManager(String,String) で取得してください。

導入されたバージョン:
5.0

コンストラクタの概要
UserManager()
メソッドの概要
abstract void | addUser(User user) ユーザを登録します。
abstract void | deleteUser(User user) 登録済のユーザを削除します。
abstract User | getUser(String userCode) 登録済のユーザを取得します。
static UserManager | getUserManager(String user, String group) UserManagerを取得します。
protected abstract void | init(String user, String group) UserManagerを初期化します。
abstract void | updateUser(User user) 登録済のユーザを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserManager

public UserManager()
メソッドの詳細

getUserManager

public static UserManager getUserManager(String user,
                                         String group)
                                  throws ManagerException
UserManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するUserManager
例外:
ManagerException - UserManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
UserManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - UserManagerの初期化に失敗

getUser

public abstract User getUser(String userCode)
                      throws ManagerException
登録済のユーザを取得します。
指定されたユーザコードに一致するユーザ情報が存在しない場合は null を返します。

パラメータ:
userCode - ユーザコード
戻り値:
ユーザ情報
例外:
ManagerException - ユーザ情報の取得に失敗
導入されたバージョン:
5.1

addUser

public abstract void addUser(User user)
                      throws ManagerException
ユーザを登録します。

パラメータ:
user - ユーザ情報
例外:
ManagerException - UserManagerのユーザ情報の登録に失敗

updateUser

public abstract void updateUser(User user)
                         throws ManagerException
登録済のユーザを更新します。

パラメータ:
user - ユーザ情報
例外:
ManagerException - UserManagerのユーザ情報の更新に失敗

deleteUser

public abstract void deleteUser(User user)
                         throws ManagerException
登録済のユーザを削除します。
指定されたユーザの情報が存在しない場合は ManagerException がスローされます。

パラメータ:
user - ユーザ情報
例外:
ManagerException - UserManagerのユーザ情報の削除に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserTerminable (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.user
クラス UserTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable
すべての実装インタフェース:
Serializable
public class UserTerminable
extends Object
implements Serializable

ユーザの期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
UserTerminable()
メソッドの概要
String | getCountryCode() 国コードを取得します。
String | getEmailAddress1() メールアドレス１を取得します。
String | getEmailAddress2() メールアドレス２を取得します。
Map | getExtendedUserTerminable(String name) 指定された拡張情報を取得します。
Map | getExtendedUserTerminables() このユーザの期間化情報に対する拡張情報をすべて取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
Locale[] | getLocales() このユーザで管理している言語（ロケール）をすべて取得します。
String | getMobileEmailAddress() 携帯用メールを取得します。
String | getMobileNumber() 携帯電話番号を取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getUrl() URLを取得します。
UserTerminableInternational | getUserTerminableInternational(Locale locale) 指定された言語に対する期間国際化情報を取得します。
String | getZipCode() 郵便番号を取得します。
void | putExtendedUserTerminable(String name, Map data) 指定された拡張情報を追加します。
void | putUserTerminableInternational(Locale locale, UserTerminableInternational data) 指定された言語に対する期間国際化情報を設定します。
void | setCountryCode(String countryCode) 国コードを設定します。
void | setEmailAddress1(String emailAddress1) メールアドレス１を設定します。
void | setEmailAddress2(String emailAddress2) メールアドレス２を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | setFaxNumber(String faxNumber) FAX番号を設定します。
void | setMobileEmailAddress(String mobileEmailAddress) 携帯用メールを設定します。
void | setMobileNumber(String mobileNumber) 携帯電話番号を設定します。
void | setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | setUrl(String url) URLを設定します。
void | setZipCode(String zipCode) 郵便番号を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserTerminable

public UserTerminable()
メソッドの詳細

getLocales

public Locale[] getLocales()
このユーザで管理している言語（ロケール）をすべて取得します。

戻り値:
このユーザで管理している言語（ロケール）

getUserTerminableInternational

public UserTerminableInternational getUserTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
期間国際化情報

putUserTerminableInternational

public void putUserTerminableInternational(Locale locale,
                                           UserTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 期間国際化情報

getExtendedUserTerminables

public Map getExtendedUserTerminables()
このユーザの期間化情報に対する拡張情報をすべて取得します。 返される値は拡張名をキー、 拡張情報を値とした Mapです。

戻り値:
期間化情報に対するすべての拡張情報
導入されたバージョン:
5.1.5

getExtendedUserTerminable

public Map getExtendedUserTerminable(String name)
指定された拡張情報を取得します。 返される値は属性名をキー、 属性値を値とした Mapです。

パラメータ:
name - 拡張名
戻り値:
期間化情報に対する拡張情報
導入されたバージョン:
5.1.5

putExtendedUserTerminable

public void putExtendedUserTerminable(String name,
                                      Map data)
指定された拡張情報を追加します。

パラメータ:
name - 拡張名
data - 期間化情報に対する拡張情報
導入されたバージョン:
5.1.5

getTelephoneNumber

public String getTelephoneNumber()
電話番号を取得します。

戻り値:
電話番号

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber)
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号

getMobileNumber

public String getMobileNumber()
携帯電話番号を取得します。

戻り値:
携帯電話番号

setMobileNumber

public void setMobileNumber(String mobileNumber)
携帯電話番号を設定します。

パラメータ:
mobileNumber - 携帯電話番号

getFaxNumber

public String getFaxNumber()
FAX番号を取得します。

戻り値:
FAX番号

setFaxNumber

public void setFaxNumber(String faxNumber)
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号

getExtensionNumber

public String getExtensionNumber()
内線番号を取得します。

戻り値:
内線番号

setExtensionNumber

public void setExtensionNumber(String extensionNumber)
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号

getExtensionFaxNumber

public String getExtensionFaxNumber()
内線FAX番号を取得します。

戻り値:
内線FAX番号

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber)
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号

getCountryCode

public String getCountryCode()
国コードを取得します。

戻り値:
国コード

setCountryCode

public void setCountryCode(String countryCode)
国コードを設定します。

パラメータ:
countryCode - 国コード

getZipCode

public String getZipCode()
郵便番号を取得します。

戻り値:
郵便番号

setZipCode

public void setZipCode(String zipCode)
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号

getEmailAddress1

public String getEmailAddress1()
メールアドレス１を取得します。

戻り値:
メールアドレス１

setEmailAddress1

public void setEmailAddress1(String emailAddress1)
メールアドレス１を設定します。

パラメータ:
emailAddress1 - メールアドレス１

getEmailAddress2

public String getEmailAddress2()
メールアドレス２を取得します。

戻り値:
メールアドレス２

setEmailAddress2

public void setEmailAddress2(String emailAddress2)
メールアドレス２を設定します。

パラメータ:
emailAddress2 - メールアドレス２

getMobileEmailAddress

public String getMobileEmailAddress()
携帯用メールを取得します。

戻り値:
携帯用メール

setMobileEmailAddress

public void setMobileEmailAddress(String mobileEmailAddress)
携帯用メールを設定します。

パラメータ:
mobileEmailAddress - 携帯用メール

getUrl

public String getUrl()
URLを取得します。

戻り値:
URL

setUrl

public void setUrl(String url)
URLを設定します。

パラメータ:
url - URL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserTerminableInternational (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.user
クラス UserTerminableInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational
すべての実装インタフェース:
Serializable
public class UserTerminableInternational
extends Object
implements Serializable

ユーザの期間国際化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
UserTerminableInternational()
メソッドの概要
String | getAddress() 住所を取得します。
Map | getExtendedUserTerminableInternational(String name) 指定された拡張情報を取得します。
Map | getExtendedUserTerminableInternationals() このユーザの基本情報に対する拡張情報をすべて取得します。
String | getName() ユーザ名を取得します。
String | getNameEnglish() ユーザ名英字を取得します。
String | getNameSyllabary() ユーザ名カナを取得します。
void | putExtendedUserTerminableInternational(String name, Map data) 指定された拡張情報を追加します。
void | setAddress(String address) 住所を設定します。
void | setName(String name) ユーザ名を設定します。
void | setNameEnglish(String nameEnglish) ユーザ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) ユーザ名カナを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserTerminableInternational

public UserTerminableInternational()
メソッドの詳細

getExtendedUserTerminableInternationals

public Map getExtendedUserTerminableInternationals()
このユーザの基本情報に対する拡張情報をすべて取得します。 返される値は拡張名をキー、 拡張情報を値とした Mapです。

戻り値:
期間国際化情報に対するすべての拡張情報
導入されたバージョン:
5.1.5

getExtendedUserTerminableInternational

public Map getExtendedUserTerminableInternational(String name)
指定された拡張情報を取得します。 返される値は属性名をキー、 属性値を値とした Mapです。

パラメータ:
name - 拡張名
戻り値:
期間国際化情報に対する拡張情報
導入されたバージョン:
5.1.5

putExtendedUserTerminableInternational

public void putExtendedUserTerminableInternational(String name,
                                                   Map data)
指定された拡張情報を追加します。

パラメータ:
name - 拡張名
data - 期間国際化情報に対する拡張情報
導入されたバージョン:
5.1.5

getName

public String getName()
ユーザ名を取得します。

戻り値:
ユーザ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
ユーザ名を設定します。

パラメータ:
name - ユーザ名

getNameSyllabary

public String getNameSyllabary()
ユーザ名カナを取得します。

戻り値:
ユーザ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
ユーザ名カナを設定します。

パラメータ:
nameSyllabary - ユーザ名カナ

getNameEnglish

public String getNameEnglish()
ユーザ名英字を取得します。

戻り値:
ユーザ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
ユーザ名英字を設定します。

パラメータ:
nameEnglish - ユーザ名英字

getAddress

public String getAddress()
住所を取得します。

戻り値:
住所
例外:
AccessorException - データの取得に失敗した場合

setAddress

public void setAddress(String address)
住所を設定します。

パラメータ:
address - 住所
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の使用

CateogryClassBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class 分類区分情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での CateogryClassBaseModel の使用

CateogryClassBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.category.category_class のメソッド
CateogryClassBaseModel | CateogryClassMapper.create(String categoryClassCode) プライマリキーに該当する分類区分を生成します。
CateogryClassBaseModel | CateogryClassMapper.select(String categoryClassCode) プライマリーキーで特定される分類区分の基本モデルを取得します。

CateogryClassBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.category.category_class のメソッド
void | CateogryClassMapper.insert(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ挿入します。
void | CateogryClassMapper.update(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ更新します。
void | CateogryClassMapper.delete(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel の使用

CateogryClassInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class 分類区分情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での CateogryClassInternationalModel の使用

CateogryClassInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.category.category_class のメソッド
 CateogryClassInternationalModel CateogryClassBaseModel.selectCateogryClassInternationalModel(Locale locale)
指定された言語に該当する分類区分の国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CateogryClassBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.category.category_class
インタフェース CateogryClassBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface CateogryClassBaseModel
extends BaseModel

分類区分の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | CATEGORY_CLASS_CODE 分類区分コード
static String | NAME 分類区分名
static String | NOTES 備考
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getCategoryClassCode() 分類区分コードを取得します。
String | getName() 分類区分名を取得します。
String | getName(Locale locale) 分類区分名を取得します。
String | getNotes() 備考を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
CateogryClassInternationalModel | selectCateogryClassInternationalModel(Locale locale) 指定された言語に該当する分類区分の国際化モデルを取得します。
void | setName(String name) 分類区分名を設定します。
void | setName(String name, Locale locale) 分類区分名を設定します。
void | setNotes(String notes) 備考を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

CATEGORY_CLASS_CODE

public static final String CATEGORY_CLASS_CODE
分類区分コード

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

NAME

public static final String NAME
分類区分名

関連項目:
定数フィールド値
メソッドの詳細

getCategoryClassCode

public String getCategoryClassCode()
                            throws AccessorException
分類区分コードを取得します。

戻り値:
分類区分コード
例外:
AccessorException - データの取得に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName()
               throws AccessorException
分類区分名を取得します。

戻り値:
分類区分名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
分類区分名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
分類区分名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
分類区分名を設定します。

パラメータ:
name - 分類区分名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
分類区分名を設定します。

パラメータ:
name - 分類区分名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectCateogryClassInternationalModel

public CateogryClassInternationalModel selectCateogryClassInternationalModel(Locale locale)
                                                                      throws IllegalLocaleException
指定された言語に該当する分類区分の国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
分類区分の国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CateogryClassInternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.category.category_class
インタフェース CateogryClassInternationalModel

すべてのスーパーインタフェース:
InternationalModel, Serializable
public interface CateogryClassInternationalModel
extends InternationalModel

分類区分の国際化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getName() 分類区分名を取得します。
void | setName(String name) 分類区分名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModel から継承したメソッド
getExtendedInternationalModelMap, getLocale, init

メソッドの詳細

getName

public String getName()
               throws AccessorException
分類区分名を取得します。

戻り値:
分類区分名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
分類区分名を設定します。

パラメータ:
name - 分類区分名
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CateogryClassMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.category.category_class
インタフェース CateogryClassMapper

すべてのスーパーインタフェース:
Mapper
public interface CateogryClassMapper
extends Mapper

分類区分に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
CateogryClassBaseModel | create(String categoryClassCode) プライマリキーに該当する分類区分を生成します。
void | delete(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ削除します。
void | delete(Collection models) 分類区分の基本モデルを複数削除します。
void | insert(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ挿入します。
void | insert(Collection models) 分類区分の基本モデルを複数挿入します。
CateogryClassBaseModel | select(String categoryClassCode) プライマリーキーで特定される分類区分の基本モデルを取得します。
void | update(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ更新します。
void | update(Collection models) 分類区分の基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public CateogryClassBaseModel create(String categoryClassCode)
                              throws MapperException
プライマリキーに該当する分類区分を生成します。

パラメータ:
categoryClassCode - 分類区分コード
戻り値:
プライマリキーに該当する分類区分の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public CateogryClassBaseModel select(String categoryClassCode)
                              throws MapperException
プライマリーキーで特定される分類区分の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
categoryClassCode - 分類区分コード
戻り値:
分類区分の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(CateogryClassBaseModel model)
            throws MapperException
分類区分の基本モデルを1つだけ挿入します。 引数に指定する分類区分の基本モデルは同一の CateogryClassMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入する分類区分の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
分類区分の基本モデルを複数挿入します。 引数に指定するものは同一の CateogryClassMapperの create(String) で生成された分類区分の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する分類区分の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(CateogryClassBaseModel model)
            throws MapperException
分類区分の基本モデルを1つだけ更新します。 引数に指定する分類区分の基本モデルは同一の CateogryClassMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する分類区分の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
分類区分の基本モデルを複数更新します。 引数に指定するものは同一の CateogryClassMapperの select 系メソッド から取得されたものかで生成された分類区分の基本モデルの集合である必要があります。

パラメータ:
models - 更新する分類区分の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(CateogryClassBaseModel model)
            throws MapperException
分類区分の基本モデルを1つだけ削除します。 引数で指定された分類区分の基本モデルに該当するデータのすべての情報を削除します。引数に指定する分類区分の基本モデルは同一の CateogryClassMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する分類区分の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
分類区分の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する分類区分の基本モデルは同一の CateogryClassMapperの select 系メソッド から取得された分類区分の基本モデルの集合である必要があります。

パラメータ:
models - 削除する分類区分の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.category.category_class (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.category.category_class
インタフェース
CateogryClassBaseModel
CateogryClassInternationalModel
CateogryClassMapper


jp.co.intra_mart.foundation.datastore.application.model.category.category_class (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.category.category_class

分類区分情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
CateogryClassBaseModel | 分類区分の基本モデルです。
CateogryClassInternationalModel | 分類区分の国際化モデルです。
CateogryClassMapper | 分類区分に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.category.category_class の説明

分類区分情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.category.category_class クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.category.category_class の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.category.category_class の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class の使用

jp.co.intra_mart.foundation.datastore.application.model.category.category_class を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class 分類区分情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.category.category_class により使用される jp.co.intra_mart.foundation.datastore.application.model.category.category_class のクラス
CateogryClassBaseModel
分類区分の基本モデルです。
CateogryClassInternationalModel
分類区分の国際化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の使用

CategoryDetailBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.detail 分類詳細情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.category.detail での CategoryDetailBaseModel の使用

CategoryDetailBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.category.detail のメソッド
CategoryDetailBaseModel | CategoryDetailMapper.create(String categoryClassCode, String categoryCode) プライマリキーに該当する分類区分詳細を生成します。
CategoryDetailBaseModel | CategoryDetailMapper.select(String categoryClassCode, String categoryCode) プライマリーキーで特定される分類区分詳細の基本モデルを取得します。

CategoryDetailBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.category.detail のメソッド
void | CategoryDetailMapper.insert(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ挿入します。
void | CategoryDetailMapper.update(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ更新します。
void | CategoryDetailMapper.delete(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel の使用

CategoryDetailInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.detail 分類詳細情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.category.detail での CategoryDetailInternationalModel の使用

CategoryDetailInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.category.detail のメソッド
 CategoryDetailInternationalModel CategoryDetailBaseModel.selectCategoryDetailInternationalModel(Locale locale)
指定された言語に該当する分類区分詳細の国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CategoryDetailBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.category.detail
インタフェース CategoryDetailBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface CategoryDetailBaseModel
extends BaseModel

分類区分詳細の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | CATEGORY_CLASS_CODE 分類区分コード
static String | CATEGORY_CODE 分類コード
static String | NAME 分類名
static String | NOTES 備考
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getCategoryClassCode() 分類区分コードを取得します。
String | getCategoryCode() 分類コードを取得します。
String | getName() 分類名を取得します。
String | getName(Locale locale) 分類名を取得します。
String | getNotes() 備考を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
CategoryDetailInternationalModel | selectCategoryDetailInternationalModel(Locale locale) 指定された言語に該当する分類区分詳細の国際化モデルを取得します。
void | setName(String name) 分類名を設定します。
void | setName(String name, Locale locale) 分類名を設定します。
void | setNotes(String notes) 備考を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

CATEGORY_CLASS_CODE

public static final String CATEGORY_CLASS_CODE
分類区分コード

関連項目:
定数フィールド値

CATEGORY_CODE

public static final String CATEGORY_CODE
分類コード

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

NAME

public static final String NAME
分類名

関連項目:
定数フィールド値
メソッドの詳細

getCategoryClassCode

public String getCategoryClassCode()
                            throws AccessorException
分類区分コードを取得します。

戻り値:
分類区分コード
例外:
AccessorException - データの取得に失敗した場合

getCategoryCode

public String getCategoryCode()
                       throws AccessorException
分類コードを取得します。

戻り値:
分類コード
例外:
AccessorException - データの取得に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName()
               throws AccessorException
分類名を取得します。

戻り値:
分類名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
分類名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
分類名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
分類名を設定します。

パラメータ:
name - 分類名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
分類名を設定します。

パラメータ:
name - 分類名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectCategoryDetailInternationalModel

public CategoryDetailInternationalModel selectCategoryDetailInternationalModel(Locale locale)
                                                                        throws IllegalLocaleException
指定された言語に該当する分類区分詳細の国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
分類区分詳細の国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CategoryDetailInternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.category.detail
インタフェース CategoryDetailInternationalModel

すべてのスーパーインタフェース:
InternationalModel, Serializable
public interface CategoryDetailInternationalModel
extends InternationalModel

分類区分詳細の国際化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getName() 分類名を取得します。
void | setName(String name) 分類名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModel から継承したメソッド
getExtendedInternationalModelMap, getLocale, init

メソッドの詳細

getName

public String getName()
               throws AccessorException
分類名を取得します。

戻り値:
分類名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
分類名を設定します。

パラメータ:
name - 分類名
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CategoryDetailMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.category.detail
インタフェース CategoryDetailMapper

すべてのスーパーインタフェース:
Mapper
public interface CategoryDetailMapper
extends Mapper

分類区分詳細に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
CategoryDetailBaseModel | create(String categoryClassCode, String categoryCode) プライマリキーに該当する分類区分詳細を生成します。
void | delete(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ削除します。
void | delete(Collection models) 分類区分詳細の基本モデルを複数削除します。
void | insert(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ挿入します。
void | insert(Collection models) 分類区分詳細の基本モデルを複数挿入します。
CategoryDetailBaseModel | select(String categoryClassCode, String categoryCode) プライマリーキーで特定される分類区分詳細の基本モデルを取得します。
void | update(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ更新します。
void | update(Collection models) 分類区分詳細の基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public CategoryDetailBaseModel create(String categoryClassCode,
                                      String categoryCode)
                               throws MapperException
プライマリキーに該当する分類区分詳細を生成します。

パラメータ:
categoryClassCode - 分類区分コード
categoryCode - 分類コード
戻り値:
プライマリキーに該当する分類区分詳細の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public CategoryDetailBaseModel select(String categoryClassCode,
                                      String categoryCode)
                               throws MapperException
プライマリーキーで特定される分類区分詳細の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
categoryClassCode - 分類区分コード
categoryCode - 分類コード
戻り値:
分類区分詳細の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(CategoryDetailBaseModel model)
            throws MapperException
分類区分詳細の基本モデルを1つだけ挿入します。 引数に指定する分類区分詳細の基本モデルは同一の CategoryDetailMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する分類区分詳細の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
分類区分詳細の基本モデルを複数挿入します。 引数に指定するものは同一の CategoryDetailMapperの create(String,String) で生成された分類区分詳細の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する分類区分詳細の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(CategoryDetailBaseModel model)
            throws MapperException
分類区分詳細の基本モデルを1つだけ更新します。 引数に指定する分類区分詳細の基本モデルは同一の CategoryDetailMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する分類区分詳細の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
分類区分詳細の基本モデルを複数更新します。 引数に指定するものは同一の CategoryDetailMapperの select 系メソッド から取得されたものかで生成された分類区分詳細の基本モデルの集合である必要があります。

パラメータ:
models - 更新する分類区分詳細の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(CategoryDetailBaseModel model)
            throws MapperException
分類区分詳細の基本モデルを1つだけ削除します。 引数で指定された分類区分詳細の基本モデルに該当するデータのすべての情報を削除します。引数に指定する分類区分詳細の基本モデルは同一の CategoryDetailMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する分類区分詳細の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
分類区分詳細の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する分類区分詳細の基本モデルは同一の CategoryDetailMapperの select 系メソッド から取得された分類区分詳細の基本モデルの集合である必要があります。

パラメータ:
models - 削除する分類区分詳細の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.category.detail (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.category.detail
インタフェース
CategoryDetailBaseModel
CategoryDetailInternationalModel
CategoryDetailMapper


jp.co.intra_mart.foundation.datastore.application.model.category.detail (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.category.detail

分類詳細情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
CategoryDetailBaseModel | 分類区分詳細の基本モデルです。
CategoryDetailInternationalModel | 分類区分詳細の国際化モデルです。
CategoryDetailMapper | 分類区分詳細に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.category.detail の説明

分類詳細情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.category.detail クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.category.detail の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.category.detail の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.detail の使用

jp.co.intra_mart.foundation.datastore.application.model.category.detail を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.detail 分類詳細情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.category.detail により使用される jp.co.intra_mart.foundation.datastore.application.model.category.detail のクラス
CategoryDetailBaseModel
分類区分詳細の基本モデルです。
CategoryDetailInternationalModel
分類区分詳細の国際化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の使用

DepartmentAttachBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.attach 組織所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.attach での DepartmentAttachBaseModel の使用

DepartmentAttachBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.attach のメソッド
DepartmentAttachBaseModel | DepartmentAttachMapper.create(String userCode, String companyCode, String departmentCode) プライマリキーに該当する組織所属を生成します。
DepartmentAttachBaseModel | DepartmentAttachMapper.select(String userCode, String companyCode, String departmentCode) プライマリーキーで特定される組織所属の基本モデルを取得します。

DepartmentAttachBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.company.attach のメソッド
void | DepartmentAttachMapper.insert(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ挿入します。
void | DepartmentAttachMapper.update(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ更新します。
void | DepartmentAttachMapper.delete(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel の使用

DepartmentAttachTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.attach 組織所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.attach での DepartmentAttachTerminableModel の使用

DepartmentAttachTerminableModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.attach のメソッド
 DepartmentAttachTerminableModel DepartmentAttachBaseModel.selectDepartmentAttachTerminableModel(Date date)
指定された日付に該当する組織所属の期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DepartmentAttachBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.attach
インタフェース DepartmentAttachBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface DepartmentAttachBaseModel
extends BaseModel

組織所属の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | COMPANY_CODE 会社コード
static String | DEPARTMENT_CODE 組織コード
static String | POST_CODE 役職CD
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
static String | USER_CODE ユーザコード
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
String | getPostCode() 役職CDを取得します。
String | getPostCode(Date date) 役職CDを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
String | getUserCode() ユーザコードを取得します。
DepartmentAttachTerminableModel | selectDepartmentAttachTerminableModel(Date date) 指定された日付に該当する組織所属の期間化モデルを取得します。
void | setPostCode(String postCode) 役職CDを設定します。
void | setPostCode(String postCode, Date date) 役職CDを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

USER_CODE

public static final String USER_CODE
ユーザコード

関連項目:
定数フィールド値

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

DEPARTMENT_CODE

public static final String DEPARTMENT_CODE
組織コード

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

POST_CODE

public static final String POST_CODE
役職CD

関連項目:
定数フィールド値
メソッドの詳細

getUserCode

public String getUserCode()
                   throws AccessorException
ユーザコードを取得します。

戻り値:
ユーザコード
例外:
AccessorException - データの取得に失敗した場合

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getDepartmentCode

public String getDepartmentCode()
                         throws AccessorException
組織コードを取得します。

戻り値:
組織コード
例外:
AccessorException - データの取得に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getPostCode

public String getPostCode()
                   throws AccessorException
役職CDを取得します。

戻り値:
役職CD
例外:
AccessorException - データの取得に失敗した場合

getPostCode

public String getPostCode(Date date)
                   throws AccessorException
役職CDを取得します。

パラメータ:
date - 日時
戻り値:
役職CD
例外:
AccessorException - データの取得に失敗した場合

setPostCode

public void setPostCode(String postCode)
                 throws AccessorException
役職CDを設定します。

パラメータ:
postCode - 役職CD
例外:
AccessorException - データの設定に失敗した場合

setPostCode

public void setPostCode(String postCode,
                        Date date)
                 throws AccessorException
役職CDを設定します。

パラメータ:
postCode - 役職CD
date - 日時
例外:
AccessorException - データの設定に失敗した場合

selectDepartmentAttachTerminableModel

public DepartmentAttachTerminableModel selectDepartmentAttachTerminableModel(Date date)
                                                                      throws IllegalTermException
指定された日付に該当する組織所属の期間化モデルを取得します。

パラメータ:
date - 指定日付
戻り値:
組織所属の期間化モデル
例外:
IllegalTermException - 指定された日付に該当する期間が定義されていない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DepartmentAttachMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.attach
インタフェース DepartmentAttachMapper

すべてのスーパーインタフェース:
Mapper
public interface DepartmentAttachMapper
extends Mapper

組織所属に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
DepartmentAttachBaseModel | create(String userCode, String companyCode, String departmentCode) プライマリキーに該当する組織所属を生成します。
void | delete(Collection models) 組織所属の基本モデルを複数削除します。
void | delete(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ削除します。
void | insert(Collection models) 組織所属の基本モデルを複数挿入します。
void | insert(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ挿入します。
DepartmentAttachBaseModel | select(String userCode, String companyCode, String departmentCode) プライマリーキーで特定される組織所属の基本モデルを取得します。
void | update(Collection models) 組織所属の基本モデルを複数更新します。
void | update(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public DepartmentAttachBaseModel create(String userCode,
                                        String companyCode,
                                        String departmentCode)
                                 throws MapperException
プライマリキーに該当する組織所属を生成します。

パラメータ:
userCode - ユーザコード
companyCode - 会社コード
departmentCode - 組織コード
戻り値:
プライマリキーに該当する組織所属の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public DepartmentAttachBaseModel select(String userCode,
                                        String companyCode,
                                        String departmentCode)
                                 throws MapperException
プライマリーキーで特定される組織所属の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
userCode - ユーザコード
companyCode - 会社コード
departmentCode - 組織コード
戻り値:
組織所属の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(DepartmentAttachBaseModel model)
            throws MapperException
組織所属の基本モデルを1つだけ挿入します。 引数に指定する組織所属の基本モデルは同一の DepartmentAttachMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する組織所属の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
組織所属の基本モデルを複数挿入します。 引数に指定するものは同一の DepartmentAttachMapperの create(String,String,String) で生成された組織所属の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する組織所属の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(DepartmentAttachBaseModel model)
            throws MapperException
組織所属の基本モデルを1つだけ更新します。 引数に指定する組織所属の基本モデルは同一の DepartmentAttachMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する組織所属の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
組織所属の基本モデルを複数更新します。 引数に指定するものは同一の DepartmentAttachMapperの select 系メソッド から取得されたものかで生成された組織所属の基本モデルの集合である必要があります。

パラメータ:
models - 更新する組織所属の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(DepartmentAttachBaseModel model)
            throws MapperException
組織所属の基本モデルを1つだけ削除します。 引数で指定された組織所属の基本モデルに該当するデータのすべての情報を削除します。引数に指定する組織所属の基本モデルは同一の DepartmentAttachMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する組織所属の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
組織所属の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する組織所属の基本モデルは同一の DepartmentAttachMapperの select 系メソッド から取得された組織所属の基本モデルの集合である必要があります。

パラメータ:
models - 削除する組織所属の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DepartmentAttachTerminableModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.attach
インタフェース DepartmentAttachTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface DepartmentAttachTerminableModel
extends TerminableModel

組織所属の期間化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getPostCode() 役職CDを取得します。
void | setPostCode(String postCode) 役職CDを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

メソッドの詳細

getPostCode

public String getPostCode()
                   throws AccessorException
役職CDを取得します。

戻り値:
役職CD
例外:
AccessorException - データの取得に失敗した場合

setPostCode

public void setPostCode(String postCode)
                 throws AccessorException
役職CDを設定します。

パラメータ:
postCode - 役職CD
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.company.attach (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.company.attach
インタフェース
DepartmentAttachBaseModel
DepartmentAttachMapper
DepartmentAttachTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.company.attach (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.attach

組織所属情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
DepartmentAttachBaseModel | 組織所属の基本モデルです。
DepartmentAttachMapper | 組織所属に関連するマッパです。
DepartmentAttachTerminableModel | 組織所属の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.attach の説明

組織所属情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.company.attach クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.attach の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.attach の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.attach の使用

jp.co.intra_mart.foundation.datastore.application.model.company.attach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.attach 組織所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.attach により使用される jp.co.intra_mart.foundation.datastore.application.model.company.attach のクラス
DepartmentAttachBaseModel
組織所属の基本モデルです。
DepartmentAttachTerminableModel
組織所属の期間化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の使用

CompanyCategoryBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.category 会社分類情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.category での CompanyCategoryBaseModel の使用

CompanyCategoryBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.category のメソッド
CompanyCategoryBaseModel | CompanyCategoryMapper.create(String companyCode, String departmentCode, String categoryClassCode, String categoryCode) プライマリキーに該当する会社組織分類を生成します。
CompanyCategoryBaseModel | CompanyCategoryMapper.select(String companyCode, String departmentCode, String categoryClassCode, String categoryCode) プライマリーキーで特定される会社組織分類の基本モデルを取得します。

CompanyCategoryBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.company.category のメソッド
void | CompanyCategoryMapper.insert(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ挿入します。
void | CompanyCategoryMapper.update(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ更新します。
void | CompanyCategoryMapper.delete(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryTerminableModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryTerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryTerminableModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CompanyCategoryBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.category
インタフェース CompanyCategoryBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface CompanyCategoryBaseModel
extends BaseModel

会社組織分類の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | CATEGORY_CLASS_CODE 分類区分コード
static String | CATEGORY_CODE 分類コード
static String | COMPANY_CODE 会社コード
static String | DEPARTMENT_CODE 組織コード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getCategoryClassCode() 分類区分コードを取得します。
String | getCategoryCode() 分類コードを取得します。
String | getCompanyCode() 会社コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

DEPARTMENT_CODE

public static final String DEPARTMENT_CODE
組織コード

関連項目:
定数フィールド値

CATEGORY_CLASS_CODE

public static final String CATEGORY_CLASS_CODE
分類区分コード

関連項目:
定数フィールド値

CATEGORY_CODE

public static final String CATEGORY_CODE
分類コード

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getDepartmentCode

public String getDepartmentCode()
                         throws AccessorException
組織コードを取得します。

戻り値:
組織コード
例外:
AccessorException - データの取得に失敗した場合

getCategoryClassCode

public String getCategoryClassCode()
                            throws AccessorException
分類区分コードを取得します。

戻り値:
分類区分コード
例外:
AccessorException - データの取得に失敗した場合

getCategoryCode

public String getCategoryCode()
                       throws AccessorException
分類コードを取得します。

戻り値:
分類コード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyCategoryMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.category
インタフェース CompanyCategoryMapper

すべてのスーパーインタフェース:
Mapper
public interface CompanyCategoryMapper
extends Mapper

会社組織分類に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
CompanyCategoryBaseModel | create(String companyCode, String departmentCode, String categoryClassCode, String categoryCode) プライマリキーに該当する会社組織分類を生成します。
void | delete(Collection models) 会社組織分類の基本モデルを複数削除します。
void | delete(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ削除します。
void | insert(Collection models) 会社組織分類の基本モデルを複数挿入します。
void | insert(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ挿入します。
CompanyCategoryBaseModel | select(String companyCode, String departmentCode, String categoryClassCode, String categoryCode) プライマリーキーで特定される会社組織分類の基本モデルを取得します。
void | update(Collection models) 会社組織分類の基本モデルを複数更新します。
void | update(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public CompanyCategoryBaseModel create(String companyCode,
                                       String departmentCode,
                                       String categoryClassCode,
                                       String categoryCode)
                                throws MapperException
プライマリキーに該当する会社組織分類を生成します。

パラメータ:
companyCode - 会社コード
departmentCode - 組織コード
categoryClassCode - 分類区分コード
categoryCode - 分類コード
戻り値:
プライマリキーに該当する会社組織分類の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public CompanyCategoryBaseModel select(String companyCode,
                                       String departmentCode,
                                       String categoryClassCode,
                                       String categoryCode)
                                throws MapperException
プライマリーキーで特定される会社組織分類の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
companyCode - 会社コード
departmentCode - 組織コード
categoryClassCode - 分類区分コード
categoryCode - 分類コード
戻り値:
会社組織分類の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(CompanyCategoryBaseModel model)
            throws MapperException
会社組織分類の基本モデルを1つだけ挿入します。 引数に指定する会社組織分類の基本モデルは同一の CompanyCategoryMapperの create(String,String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する会社組織分類の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
会社組織分類の基本モデルを複数挿入します。 引数に指定するものは同一の CompanyCategoryMapperの create(String,String,String,String) で生成された会社組織分類の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する会社組織分類の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(CompanyCategoryBaseModel model)
            throws MapperException
会社組織分類の基本モデルを1つだけ更新します。 引数に指定する会社組織分類の基本モデルは同一の CompanyCategoryMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する会社組織分類の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
会社組織分類の基本モデルを複数更新します。 引数に指定するものは同一の CompanyCategoryMapperの select 系メソッド から取得されたものかで生成された会社組織分類の基本モデルの集合である必要があります。

パラメータ:
models - 更新する会社組織分類の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(CompanyCategoryBaseModel model)
            throws MapperException
会社組織分類の基本モデルを1つだけ削除します。 引数で指定された会社組織分類の基本モデルに該当するデータのすべての情報を削除します。引数に指定する会社組織分類の基本モデルは同一の CompanyCategoryMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する会社組織分類の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
会社組織分類の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する会社組織分類の基本モデルは同一の CompanyCategoryMapperの select 系メソッド から取得された会社組織分類の基本モデルの集合である必要があります。

パラメータ:
models - 削除する会社組織分類の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyCategoryTerminableModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.category
インタフェース CompanyCategoryTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface CompanyCategoryTerminableModel
extends TerminableModel

会社組織分類の期間化モデルです。

導入されたバージョン:
5.0

インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.company.category (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.company.category
インタフェース
CompanyCategoryBaseModel
CompanyCategoryMapper
CompanyCategoryTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.company.category (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.category

会社分類情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
CompanyCategoryBaseModel | 会社組織分類の基本モデルです。
CompanyCategoryMapper | 会社組織分類に関連するマッパです。
CompanyCategoryTerminableModel | 会社組織分類の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.category の説明

会社分類情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.company.category クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.category の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryTerminableModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.category の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.category の使用

jp.co.intra_mart.foundation.datastore.application.model.company.category を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.category 会社分類情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.category により使用される jp.co.intra_mart.foundation.datastore.application.model.company.category のクラス
CompanyCategoryBaseModel
会社組織分類の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel の使用

CompanyBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.company 会社情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.company での CompanyBaseModel の使用

CompanyBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.company のメソッド
CompanyBaseModel | CompanyMapper.create(String companyCode) プライマリキーに該当する会社を生成します。
CompanyBaseModel | CompanyMapper.select(String companyCode) プライマリーキーで特定される会社の基本モデルを取得します。

CompanyBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.company.company のメソッド
void | CompanyMapper.insert(CompanyBaseModel model) 会社の基本モデルを1つだけ挿入します。
void | CompanyMapper.update(CompanyBaseModel model) 会社の基本モデルを1つだけ更新します。
void | CompanyMapper.delete(CompanyBaseModel model) 会社の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CompanyBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.company
インタフェース CompanyBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface CompanyBaseModel
extends BaseModel

会社の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | COMPANY_CODE 会社コード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.company
インタフェース CompanyMapper

すべてのスーパーインタフェース:
Mapper
public interface CompanyMapper
extends Mapper

会社に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
CompanyBaseModel | create(String companyCode) プライマリキーに該当する会社を生成します。
void | delete(Collection models) 会社の基本モデルを複数削除します。
void | delete(CompanyBaseModel model) 会社の基本モデルを1つだけ削除します。
void | insert(Collection models) 会社の基本モデルを複数挿入します。
void | insert(CompanyBaseModel model) 会社の基本モデルを1つだけ挿入します。
CompanyBaseModel | select(String companyCode) プライマリーキーで特定される会社の基本モデルを取得します。
void | update(Collection models) 会社の基本モデルを複数更新します。
void | update(CompanyBaseModel model) 会社の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public CompanyBaseModel create(String companyCode)
                        throws MapperException
プライマリキーに該当する会社を生成します。

パラメータ:
companyCode - 会社コード
戻り値:
プライマリキーに該当する会社の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public CompanyBaseModel select(String companyCode)
                        throws MapperException
プライマリーキーで特定される会社の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
companyCode - 会社コード
戻り値:
会社の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(CompanyBaseModel model)
            throws MapperException
会社の基本モデルを1つだけ挿入します。 引数に指定する会社の基本モデルは同一の CompanyMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入する会社の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
会社の基本モデルを複数挿入します。 引数に指定するものは同一の CompanyMapperの create(String) で生成された会社の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する会社の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(CompanyBaseModel model)
            throws MapperException
会社の基本モデルを1つだけ更新します。 引数に指定する会社の基本モデルは同一の CompanyMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する会社の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
会社の基本モデルを複数更新します。 引数に指定するものは同一の CompanyMapperの select 系メソッド から取得されたものかで生成された会社の基本モデルの集合である必要があります。

パラメータ:
models - 更新する会社の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(CompanyBaseModel model)
            throws MapperException
会社の基本モデルを1つだけ削除します。 引数で指定された会社の基本モデルに該当するデータのすべての情報を削除します。引数に指定する会社の基本モデルは同一の CompanyMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する会社の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
会社の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する会社の基本モデルは同一の CompanyMapperの select 系メソッド から取得された会社の基本モデルの集合である必要があります。

パラメータ:
models - 削除する会社の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.company.company (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.company.company
インタフェース
CompanyBaseModel
CompanyMapper


jp.co.intra_mart.foundation.datastore.application.model.company.company (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.company

会社情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
CompanyBaseModel | 会社の基本モデルです。
CompanyMapper | 会社に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.company の説明

会社情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.company.company クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.company の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.company の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.company の使用

jp.co.intra_mart.foundation.datastore.application.model.company.company を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.company 会社情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.company により使用される jp.co.intra_mart.foundation.datastore.application.model.company.company のクラス
CompanyBaseModel
会社の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の使用

DepartmentBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.department 組織情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.department での DepartmentBaseModel の使用

DepartmentBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.department のメソッド
DepartmentBaseModel | DepartmentMapper.create(String companyCode, String departmentCode) プライマリキーに該当する組織を生成します。
DepartmentBaseModel | DepartmentMapper.select(String companyCode, String departmentCode) プライマリーキーで特定される組織の基本モデルを取得します。

DepartmentBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.company.department のメソッド
void | DepartmentMapper.insert(DepartmentBaseModel model) 組織の基本モデルを1つだけ挿入します。
void | DepartmentMapper.update(DepartmentBaseModel model) 組織の基本モデルを1つだけ更新します。
void | DepartmentMapper.delete(DepartmentBaseModel model) 組織の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel の使用

DepartmentTerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.department 組織情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.department での DepartmentTerminableInternationalModel の使用

DepartmentTerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.department のメソッド
 DepartmentTerminableInternationalModel DepartmentTerminableModel.selectDepartmentTerminableInternationalModel(Locale locale)
指定された言語に該当する組織の期間国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel の使用

DepartmentTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.department 組織情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.department での DepartmentTerminableModel の使用

DepartmentTerminableModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.department のメソッド
 DepartmentTerminableModel DepartmentBaseModel.selectDepartmentTerminableModel(Date date)
指定された日付に該当する組織の期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DepartmentBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.department
インタフェース DepartmentBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface DepartmentBaseModel
extends BaseModel

組織の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | ADDRESS1 住所1
static String | ADDRESS2 住所2
static String | COMPANY_CODE 会社コード
static String | COUNTRY_CODE 国コード
static String | DEPARTMENT_CODE 組織コード
static String | EMAIL_ADDRESS1 メールアドレス1
static String | EMAIL_ADDRESS2 メールアドレス2
static String | EXTENSION_FAX_NUMBER 内線FAX番号
static String | EXTENSION_NUMBER 内線番号
static String | FAX_NUMBER FAX番号
static String | NAME 組織名
static String | NAME_ENGLISH 組織名英字
static String | NAME_SYLLABARY 組織名カナ
static String | NOTES 備考
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
static String | TELEPHONE_NUMBER 電話番号
static String | URL URL
static String | ZIP_CODE 郵便番号
メソッドの概要
String | getAddress1() 住所1を取得します。
String | getAddress1(Date date) 住所1を取得します。
String | getAddress1(Date date, Locale locale) 住所1を取得します。
String | getAddress1(Locale locale) 住所1を取得します。
String | getAddress2() 住所2を取得します。
String | getAddress2(Date date) 住所2を取得します。
String | getAddress2(Date date, Locale locale) 住所2を取得します。
String | getAddress2(Locale locale) 住所2を取得します。
String | getCompanyCode() 会社コードを取得します。
String | getCountryCode() 国コードを取得します。
String | getCountryCode(Date date) 国コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
String | getEmailAddress1() メールアドレス1を取得します。
String | getEmailAddress1(Date date) メールアドレス1を取得します。
String | getEmailAddress2() メールアドレス2を取得します。
String | getEmailAddress2(Date date) メールアドレス2を取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionFaxNumber(Date date) 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getExtensionNumber(Date date) 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
String | getFaxNumber(Date date) FAX番号を取得します。
String | getName() 組織名を取得します。
String | getName(Date date) 組織名を取得します。
String | getName(Date date, Locale locale) 組織名を取得します。
String | getName(Locale locale) 組織名を取得します。
String | getNameEnglish() 組織名英字を取得します。
String | getNameEnglish(Date date) 組織名英字を取得します。
String | getNameEnglish(Date date, Locale locale) 組織名英字を取得します。
String | getNameEnglish(Locale locale) 組織名英字を取得します。
String | getNameSyllabary() 組織名カナを取得します。
String | getNameSyllabary(Date date) 組織名カナを取得します。
String | getNameSyllabary(Date date, Locale locale) 組織名カナを取得します。
String | getNameSyllabary(Locale locale) 組織名カナを取得します。
String | getNotes() 備考を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getTelephoneNumber(Date date) 電話番号を取得します。
String | getUrl() URLを取得します。
String | getUrl(Date date) URLを取得します。
String | getZipCode() 郵便番号を取得します。
String | getZipCode(Date date) 郵便番号を取得します。
DepartmentTerminableModel | selectDepartmentTerminableModel(Date date) 指定された日付に該当する組織の期間化モデルを取得します。
void | setAddress1(String address1) 住所1を設定します。
void | setAddress1(String address1, Date date) 住所1を設定します。
void | setAddress1(String address1, Date date, Locale locale) 住所1を設定します。
void | setAddress1(String address1, Locale locale) 住所1を設定します。
void | setAddress2(String address2) 住所2を設定します。
void | setAddress2(String address2, Date date) 住所2を設定します。
void | setAddress2(String address2, Date date, Locale locale) 住所2を設定します。
void | setAddress2(String address2, Locale locale) 住所2を設定します。
void | setCountryCode(String countryCode) 国コードを設定します。
void | setCountryCode(String countryCode, Date date) 国コードを設定します。
void | setEmailAddress1(String emailAddress1) メールアドレス1を設定します。
void | setEmailAddress1(String emailAddress1, Date date) メールアドレス1を設定します。
void | setEmailAddress2(String emailAddress2) メールアドレス2を設定します。
void | setEmailAddress2(String emailAddress2, Date date) メールアドレス2を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber, Date date) 内線FAX番号を設定します。
void | setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | setExtensionNumber(String extensionNumber, Date date) 内線番号を設定します。
void | setFaxNumber(String faxNumber) FAX番号を設定します。
void | setFaxNumber(String faxNumber, Date date) FAX番号を設定します。
void | setName(String name) 組織名を設定します。
void | setName(String name, Date date) 組織名を設定します。
void | setName(String name, Date date, Locale locale) 組織名を設定します。
void | setName(String name, Locale locale) 組織名を設定します。
void | setNameEnglish(String nameEnglish) 組織名英字を設定します。
void | setNameEnglish(String nameEnglish, Date date) 組織名英字を設定します。
void | setNameEnglish(String nameEnglish, Date date, Locale locale) 組織名英字を設定します。
void | setNameEnglish(String nameEnglish, Locale locale) 組織名英字を設定します。
void | setNameSyllabary(String nameSyllabary) 組織名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Date date) 組織名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Date date, Locale locale) 組織名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Locale locale) 組織名カナを設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
void | setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | setTelephoneNumber(String telephoneNumber, Date date) 電話番号を設定します。
void | setUrl(String url) URLを設定します。
void | setUrl(String url, Date date) URLを設定します。
void | setZipCode(String zipCode) 郵便番号を設定します。
void | setZipCode(String zipCode, Date date) 郵便番号を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

DEPARTMENT_CODE

public static final String DEPARTMENT_CODE
組織コード

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

TELEPHONE_NUMBER

public static final String TELEPHONE_NUMBER
電話番号

関連項目:
定数フィールド値

FAX_NUMBER

public static final String FAX_NUMBER
FAX番号

関連項目:
定数フィールド値

EXTENSION_NUMBER

public static final String EXTENSION_NUMBER
内線番号

関連項目:
定数フィールド値

EXTENSION_FAX_NUMBER

public static final String EXTENSION_FAX_NUMBER
内線FAX番号

関連項目:
定数フィールド値

COUNTRY_CODE

public static final String COUNTRY_CODE
国コード

関連項目:
定数フィールド値

ZIP_CODE

public static final String ZIP_CODE
郵便番号

関連項目:
定数フィールド値

EMAIL_ADDRESS1

public static final String EMAIL_ADDRESS1
メールアドレス1

関連項目:
定数フィールド値

EMAIL_ADDRESS2

public static final String EMAIL_ADDRESS2
メールアドレス2

関連項目:
定数フィールド値

URL

public static final String URL
URL

関連項目:
定数フィールド値

NAME

public static final String NAME
組織名

関連項目:
定数フィールド値

NAME_SYLLABARY

public static final String NAME_SYLLABARY
組織名カナ

関連項目:
定数フィールド値

NAME_ENGLISH

public static final String NAME_ENGLISH
組織名英字

関連項目:
定数フィールド値

ADDRESS1

public static final String ADDRESS1
住所1

関連項目:
定数フィールド値

ADDRESS2

public static final String ADDRESS2
住所2

関連項目:
定数フィールド値
メソッドの詳細

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getDepartmentCode

public String getDepartmentCode()
                         throws AccessorException
組織コードを取得します。

戻り値:
組織コード
例外:
AccessorException - データの取得に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getTelephoneNumber

public String getTelephoneNumber()
                          throws AccessorException
電話番号を取得します。

戻り値:
電話番号
例外:
AccessorException - データの取得に失敗した場合

getTelephoneNumber

public String getTelephoneNumber(Date date)
                          throws AccessorException
電話番号を取得します。

パラメータ:
date - 日時
戻り値:
電話番号
例外:
AccessorException - データの取得に失敗した場合

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber)
                        throws AccessorException
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号
例外:
AccessorException - データの設定に失敗した場合

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber,
                               Date date)
                        throws AccessorException
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getFaxNumber

public String getFaxNumber()
                    throws AccessorException
FAX番号を取得します。

戻り値:
FAX番号
例外:
AccessorException - データの取得に失敗した場合

getFaxNumber

public String getFaxNumber(Date date)
                    throws AccessorException
FAX番号を取得します。

パラメータ:
date - 日時
戻り値:
FAX番号
例外:
AccessorException - データの取得に失敗した場合

setFaxNumber

public void setFaxNumber(String faxNumber)
                  throws AccessorException
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号
例外:
AccessorException - データの設定に失敗した場合

setFaxNumber

public void setFaxNumber(String faxNumber,
                         Date date)
                  throws AccessorException
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getExtensionNumber

public String getExtensionNumber()
                          throws AccessorException
内線番号を取得します。

戻り値:
内線番号
例外:
AccessorException - データの取得に失敗した場合

getExtensionNumber

public String getExtensionNumber(Date date)
                          throws AccessorException
内線番号を取得します。

パラメータ:
date - 日時
戻り値:
内線番号
例外:
AccessorException - データの取得に失敗した場合

setExtensionNumber

public void setExtensionNumber(String extensionNumber)
                        throws AccessorException
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号
例外:
AccessorException - データの設定に失敗した場合

setExtensionNumber

public void setExtensionNumber(String extensionNumber,
                               Date date)
                        throws AccessorException
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getExtensionFaxNumber

public String getExtensionFaxNumber()
                             throws AccessorException
内線FAX番号を取得します。

戻り値:
内線FAX番号
例外:
AccessorException - データの取得に失敗した場合

getExtensionFaxNumber

public String getExtensionFaxNumber(Date date)
                             throws AccessorException
内線FAX番号を取得します。

パラメータ:
date - 日時
戻り値:
内線FAX番号
例外:
AccessorException - データの取得に失敗した場合

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber)
                           throws AccessorException
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号
例外:
AccessorException - データの設定に失敗した場合

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber,
                                  Date date)
                           throws AccessorException
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getCountryCode

public String getCountryCode()
                      throws AccessorException
国コードを取得します。

戻り値:
国コード
例外:
AccessorException - データの取得に失敗した場合

getCountryCode

public String getCountryCode(Date date)
                      throws AccessorException
国コードを取得します。

パラメータ:
date - 日時
戻り値:
国コード
例外:
AccessorException - データの取得に失敗した場合

setCountryCode

public void setCountryCode(String countryCode)
                    throws AccessorException
国コードを設定します。

パラメータ:
countryCode - 国コード
例外:
AccessorException - データの設定に失敗した場合

setCountryCode

public void setCountryCode(String countryCode,
                           Date date)
                    throws AccessorException
国コードを設定します。

パラメータ:
countryCode - 国コード
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getZipCode

public String getZipCode()
                  throws AccessorException
郵便番号を取得します。

戻り値:
郵便番号
例外:
AccessorException - データの取得に失敗した場合

getZipCode

public String getZipCode(Date date)
                  throws AccessorException
郵便番号を取得します。

パラメータ:
date - 日時
戻り値:
郵便番号
例外:
AccessorException - データの取得に失敗した場合

setZipCode

public void setZipCode(String zipCode)
                throws AccessorException
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号
例外:
AccessorException - データの設定に失敗した場合

setZipCode

public void setZipCode(String zipCode,
                       Date date)
                throws AccessorException
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getEmailAddress1

public String getEmailAddress1()
                        throws AccessorException
メールアドレス1を取得します。

戻り値:
メールアドレス1
例外:
AccessorException - データの取得に失敗した場合

getEmailAddress1

public String getEmailAddress1(Date date)
                        throws AccessorException
メールアドレス1を取得します。

パラメータ:
date - 日時
戻り値:
メールアドレス1
例外:
AccessorException - データの取得に失敗した場合

setEmailAddress1

public void setEmailAddress1(String emailAddress1)
                      throws AccessorException
メールアドレス1を設定します。

パラメータ:
emailAddress1 - メールアドレス1
例外:
AccessorException - データの設定に失敗した場合

setEmailAddress1

public void setEmailAddress1(String emailAddress1,
                             Date date)
                      throws AccessorException
メールアドレス1を設定します。

パラメータ:
emailAddress1 - メールアドレス1
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getEmailAddress2

public String getEmailAddress2()
                        throws AccessorException
メールアドレス2を取得します。

戻り値:
メールアドレス2
例外:
AccessorException - データの取得に失敗した場合

getEmailAddress2

public String getEmailAddress2(Date date)
                        throws AccessorException
メールアドレス2を取得します。

パラメータ:
date - 日時
戻り値:
メールアドレス2
例外:
AccessorException - データの取得に失敗した場合

setEmailAddress2

public void setEmailAddress2(String emailAddress2)
                      throws AccessorException
メールアドレス2を設定します。

パラメータ:
emailAddress2 - メールアドレス2
例外:
AccessorException - データの設定に失敗した場合

setEmailAddress2

public void setEmailAddress2(String emailAddress2,
                             Date date)
                      throws AccessorException
メールアドレス2を設定します。

パラメータ:
emailAddress2 - メールアドレス2
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getUrl

public String getUrl()
              throws AccessorException
URLを取得します。

戻り値:
URL
例外:
AccessorException - データの取得に失敗した場合

getUrl

public String getUrl(Date date)
              throws AccessorException
URLを取得します。

パラメータ:
date - 日時
戻り値:
URL
例外:
AccessorException - データの取得に失敗した場合

setUrl

public void setUrl(String url)
            throws AccessorException
URLを設定します。

パラメータ:
url - URL
例外:
AccessorException - データの設定に失敗した場合

setUrl

public void setUrl(String url,
                   Date date)
            throws AccessorException
URLを設定します。

パラメータ:
url - URL
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getName

public String getName()
               throws AccessorException
組織名を取得します。

戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Date date)
               throws AccessorException
組織名を取得します。

パラメータ:
date - 日時
戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
組織名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Date date,
                      Locale locale)
               throws AccessorException
組織名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
組織名を設定します。

パラメータ:
name - 組織名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Date date)
             throws AccessorException
組織名を設定します。

パラメータ:
name - 組織名
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
組織名を設定します。

パラメータ:
name - 組織名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Date date,
                    Locale locale)
             throws AccessorException
組織名を設定します。

パラメータ:
name - 組織名
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
組織名カナを取得します。

戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Date date)
                        throws AccessorException
組織名カナを取得します。

パラメータ:
date - 日時
戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Locale locale)
                        throws AccessorException
組織名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Date date,
                               Locale locale)
                        throws AccessorException
組織名カナを取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Date date)
                      throws AccessorException
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Locale locale)
                      throws AccessorException
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Date date,
                             Locale locale)
                      throws AccessorException
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
組織名英字を取得します。

戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Date date)
                      throws AccessorException
組織名英字を取得します。

パラメータ:
date - 日時
戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Locale locale)
                      throws AccessorException
組織名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Date date,
                             Locale locale)
                      throws AccessorException
組織名英字を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Date date)
                    throws AccessorException
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Locale locale)
                    throws AccessorException
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Date date,
                           Locale locale)
                    throws AccessorException
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getAddress1

public String getAddress1()
                   throws AccessorException
住所1を取得します。

戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

getAddress1

public String getAddress1(Date date)
                   throws AccessorException
住所1を取得します。

パラメータ:
date - 日時
戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

getAddress1

public String getAddress1(Locale locale)
                   throws AccessorException
住所1を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

getAddress1

public String getAddress1(Date date,
                          Locale locale)
                   throws AccessorException
住所1を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

setAddress1

public void setAddress1(String address1)
                 throws AccessorException
住所1を設定します。

パラメータ:
address1 - 住所1
例外:
AccessorException - データの設定に失敗した場合

setAddress1

public void setAddress1(String address1,
                        Date date)
                 throws AccessorException
住所1を設定します。

パラメータ:
address1 - 住所1
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setAddress1

public void setAddress1(String address1,
                        Locale locale)
                 throws AccessorException
住所1を設定します。

パラメータ:
address1 - 住所1
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setAddress1

public void setAddress1(String address1,
                        Date date,
                        Locale locale)
                 throws AccessorException
住所1を設定します。

パラメータ:
address1 - 住所1
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getAddress2

public String getAddress2()
                   throws AccessorException
住所2を取得します。

戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

getAddress2

public String getAddress2(Date date)
                   throws AccessorException
住所2を取得します。

パラメータ:
date - 日時
戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

getAddress2

public String getAddress2(Locale locale)
                   throws AccessorException
住所2を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

getAddress2

public String getAddress2(Date date,
                          Locale locale)
                   throws AccessorException
住所2を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

setAddress2

public void setAddress2(String address2)
                 throws AccessorException
住所2を設定します。

パラメータ:
address2 - 住所2
例外:
AccessorException - データの設定に失敗した場合

setAddress2

public void setAddress2(String address2,
                        Date date)
                 throws AccessorException
住所2を設定します。

パラメータ:
address2 - 住所2
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setAddress2

public void setAddress2(String address2,
                        Locale locale)
                 throws AccessorException
住所2を設定します。

パラメータ:
address2 - 住所2
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setAddress2

public void setAddress2(String address2,
                        Date date,
                        Locale locale)
                 throws AccessorException
住所2を設定します。

パラメータ:
address2 - 住所2
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectDepartmentTerminableModel

public DepartmentTerminableModel selectDepartmentTerminableModel(Date date)
                                                          throws IllegalTermException
指定された日付に該当する組織の期間化モデルを取得します。

パラメータ:
date - 指定日付
戻り値:
組織の期間化モデル
例外:
IllegalTermException - 指定された日付に該当する期間が定義されていない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DepartmentMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.department
インタフェース DepartmentMapper

すべてのスーパーインタフェース:
Mapper
public interface DepartmentMapper
extends Mapper

組織に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
DepartmentBaseModel | create(String companyCode, String departmentCode) プライマリキーに該当する組織を生成します。
void | delete(Collection models) 組織の基本モデルを複数削除します。
void | delete(DepartmentBaseModel model) 組織の基本モデルを1つだけ削除します。
void | insert(Collection models) 組織の基本モデルを複数挿入します。
void | insert(DepartmentBaseModel model) 組織の基本モデルを1つだけ挿入します。
DepartmentBaseModel | select(String companyCode, String departmentCode) プライマリーキーで特定される組織の基本モデルを取得します。
void | update(Collection models) 組織の基本モデルを複数更新します。
void | update(DepartmentBaseModel model) 組織の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public DepartmentBaseModel create(String companyCode,
                                  String departmentCode)
                           throws MapperException
プライマリキーに該当する組織を生成します。

パラメータ:
companyCode - 会社コード
departmentCode - 組織コード
戻り値:
プライマリキーに該当する組織の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public DepartmentBaseModel select(String companyCode,
                                  String departmentCode)
                           throws MapperException
プライマリーキーで特定される組織の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
companyCode - 会社コード
departmentCode - 組織コード
戻り値:
組織の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(DepartmentBaseModel model)
            throws MapperException
組織の基本モデルを1つだけ挿入します。 引数に指定する組織の基本モデルは同一の DepartmentMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する組織の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
組織の基本モデルを複数挿入します。 引数に指定するものは同一の DepartmentMapperの create(String,String) で生成された組織の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する組織の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(DepartmentBaseModel model)
            throws MapperException
組織の基本モデルを1つだけ更新します。 引数に指定する組織の基本モデルは同一の DepartmentMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する組織の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
組織の基本モデルを複数更新します。 引数に指定するものは同一の DepartmentMapperの select 系メソッド から取得されたものかで生成された組織の基本モデルの集合である必要があります。

パラメータ:
models - 更新する組織の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(DepartmentBaseModel model)
            throws MapperException
組織の基本モデルを1つだけ削除します。 引数で指定された組織の基本モデルに該当するデータのすべての情報を削除します。引数に指定する組織の基本モデルは同一の DepartmentMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する組織の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
組織の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する組織の基本モデルは同一の DepartmentMapperの select 系メソッド から取得された組織の基本モデルの集合である必要があります。

パラメータ:
models - 削除する組織の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DepartmentTerminableInternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.department
インタフェース DepartmentTerminableInternationalModel

すべてのスーパーインタフェース:
Serializable, TerminableInternationalModel
public interface DepartmentTerminableInternationalModel
extends TerminableInternationalModel

組織の期間国際化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getAddress1() 住所1を取得します。
String | getAddress2() 住所2を取得します。
String | getName() 組織名を取得します。
String | getNameEnglish() 組織名英字を取得します。
String | getNameSyllabary() 組織名カナを取得します。
void | setAddress1(String address1) 住所1を設定します。
void | setAddress2(String address2) 住所2を設定します。
void | setName(String name) 組織名を設定します。
void | setNameEnglish(String nameEnglish) 組織名英字を設定します。
void | setNameSyllabary(String nameSyllabary) 組織名カナを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel から継承したメソッド
getExtendedTerminableInternationalModelMap, getLocale, init

メソッドの詳細

getName

public String getName()
               throws AccessorException
組織名を取得します。

戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
組織名を設定します。

パラメータ:
name - 組織名
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
組織名カナを取得します。

戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
組織名英字を取得します。

戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字
例外:
AccessorException - データの設定に失敗した場合

getAddress1

public String getAddress1()
                   throws AccessorException
住所1を取得します。

戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

setAddress1

public void setAddress1(String address1)
                 throws AccessorException
住所1を設定します。

パラメータ:
address1 - 住所1
例外:
AccessorException - データの設定に失敗した場合

getAddress2

public String getAddress2()
                   throws AccessorException
住所2を取得します。

戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

setAddress2

public void setAddress2(String address2)
                 throws AccessorException
住所2を設定します。

パラメータ:
address2 - 住所2
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DepartmentTerminableModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.department
インタフェース DepartmentTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface DepartmentTerminableModel
extends TerminableModel

組織の期間化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getAddress1() 住所1を取得します。
String | getAddress1(Locale locale) 住所1を取得します。
String | getAddress2() 住所2を取得します。
String | getAddress2(Locale locale) 住所2を取得します。
String | getCountryCode() 国コードを取得します。
String | getEmailAddress1() メールアドレス1を取得します。
String | getEmailAddress2() メールアドレス2を取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
String | getName() 組織名を取得します。
String | getName(Locale locale) 組織名を取得します。
String | getNameEnglish() 組織名英字を取得します。
String | getNameEnglish(Locale locale) 組織名英字を取得します。
String | getNameSyllabary() 組織名カナを取得します。
String | getNameSyllabary(Locale locale) 組織名カナを取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getUrl() URLを取得します。
String | getZipCode() 郵便番号を取得します。
DepartmentTerminableInternationalModel | selectDepartmentTerminableInternationalModel(Locale locale) 指定された言語に該当する組織の期間国際化モデルを取得します。
void | setAddress1(String address1) 住所1を設定します。
void | setAddress1(String address1, Locale locale) 住所1を設定します。
void | setAddress2(String address2) 住所2を設定します。
void | setAddress2(String address2, Locale locale) 住所2を設定します。
void | setCountryCode(String countryCode) 国コードを設定します。
void | setEmailAddress1(String emailAddress1) メールアドレス1を設定します。
void | setEmailAddress2(String emailAddress2) メールアドレス2を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | setFaxNumber(String faxNumber) FAX番号を設定します。
void | setName(String name) 組織名を設定します。
void | setName(String name, Locale locale) 組織名を設定します。
void | setNameEnglish(String nameEnglish) 組織名英字を設定します。
void | setNameEnglish(String nameEnglish, Locale locale) 組織名英字を設定します。
void | setNameSyllabary(String nameSyllabary) 組織名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Locale locale) 組織名カナを設定します。
void | setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | setUrl(String url) URLを設定します。
void | setZipCode(String zipCode) 郵便番号を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

メソッドの詳細

getTelephoneNumber

public String getTelephoneNumber()
                          throws AccessorException
電話番号を取得します。

戻り値:
電話番号
例外:
AccessorException - データの取得に失敗した場合

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber)
                        throws AccessorException
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号
例外:
AccessorException - データの設定に失敗した場合

getFaxNumber

public String getFaxNumber()
                    throws AccessorException
FAX番号を取得します。

戻り値:
FAX番号
例外:
AccessorException - データの取得に失敗した場合

setFaxNumber

public void setFaxNumber(String faxNumber)
                  throws AccessorException
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号
例外:
AccessorException - データの設定に失敗した場合

getExtensionNumber

public String getExtensionNumber()
                          throws AccessorException
内線番号を取得します。

戻り値:
内線番号
例外:
AccessorException - データの取得に失敗した場合

setExtensionNumber

public void setExtensionNumber(String extensionNumber)
                        throws AccessorException
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号
例外:
AccessorException - データの設定に失敗した場合

getExtensionFaxNumber

public String getExtensionFaxNumber()
                             throws AccessorException
内線FAX番号を取得します。

戻り値:
内線FAX番号
例外:
AccessorException - データの取得に失敗した場合

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber)
                           throws AccessorException
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号
例外:
AccessorException - データの設定に失敗した場合

getCountryCode

public String getCountryCode()
                      throws AccessorException
国コードを取得します。

戻り値:
国コード
例外:
AccessorException - データの取得に失敗した場合

setCountryCode

public void setCountryCode(String countryCode)
                    throws AccessorException
国コードを設定します。

パラメータ:
countryCode - 国コード
例外:
AccessorException - データの設定に失敗した場合

getZipCode

public String getZipCode()
                  throws AccessorException
郵便番号を取得します。

戻り値:
郵便番号
例外:
AccessorException - データの取得に失敗した場合

setZipCode

public void setZipCode(String zipCode)
                throws AccessorException
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号
例外:
AccessorException - データの設定に失敗した場合

getEmailAddress1

public String getEmailAddress1()
                        throws AccessorException
メールアドレス1を取得します。

戻り値:
メールアドレス1
例外:
AccessorException - データの取得に失敗した場合

setEmailAddress1

public void setEmailAddress1(String emailAddress1)
                      throws AccessorException
メールアドレス1を設定します。

パラメータ:
emailAddress1 - メールアドレス1
例外:
AccessorException - データの設定に失敗した場合

getEmailAddress2

public String getEmailAddress2()
                        throws AccessorException
メールアドレス2を取得します。

戻り値:
メールアドレス2
例外:
AccessorException - データの取得に失敗した場合

setEmailAddress2

public void setEmailAddress2(String emailAddress2)
                      throws AccessorException
メールアドレス2を設定します。

パラメータ:
emailAddress2 - メールアドレス2
例外:
AccessorException - データの設定に失敗した場合

getUrl

public String getUrl()
              throws AccessorException
URLを取得します。

戻り値:
URL
例外:
AccessorException - データの取得に失敗した場合

setUrl

public void setUrl(String url)
            throws AccessorException
URLを設定します。

パラメータ:
url - URL
例外:
AccessorException - データの設定に失敗した場合

getName

public String getName()
               throws AccessorException
組織名を取得します。

戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
組織名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
組織名を設定します。

パラメータ:
name - 組織名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
組織名を設定します。

パラメータ:
name - 組織名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
組織名カナを取得します。

戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Locale locale)
                        throws AccessorException
組織名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Locale locale)
                      throws AccessorException
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
組織名英字を取得します。

戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Locale locale)
                      throws AccessorException
組織名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Locale locale)
                    throws AccessorException
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getAddress1

public String getAddress1()
                   throws AccessorException
住所1を取得します。

戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

getAddress1

public String getAddress1(Locale locale)
                   throws AccessorException
住所1を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

setAddress1

public void setAddress1(String address1)
                 throws AccessorException
住所1を設定します。

パラメータ:
address1 - 住所1
例外:
AccessorException - データの設定に失敗した場合

setAddress1

public void setAddress1(String address1,
                        Locale locale)
                 throws AccessorException
住所1を設定します。

パラメータ:
address1 - 住所1
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getAddress2

public String getAddress2()
                   throws AccessorException
住所2を取得します。

戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

getAddress2

public String getAddress2(Locale locale)
                   throws AccessorException
住所2を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

setAddress2

public void setAddress2(String address2)
                 throws AccessorException
住所2を設定します。

パラメータ:
address2 - 住所2
例外:
AccessorException - データの設定に失敗した場合

setAddress2

public void setAddress2(String address2,
                        Locale locale)
                 throws AccessorException
住所2を設定します。

パラメータ:
address2 - 住所2
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectDepartmentTerminableInternationalModel

public DepartmentTerminableInternationalModel selectDepartmentTerminableInternationalModel(Locale locale)
                                                                                throws IllegalLocaleException
指定された言語に該当する組織の期間国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織の期間国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.company.department (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.company.department
インタフェース
DepartmentBaseModel
DepartmentMapper
DepartmentTerminableInternationalModel
DepartmentTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.company.department (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.department

組織情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
DepartmentBaseModel | 組織の基本モデルです。
DepartmentMapper | 組織に関連するマッパです。
DepartmentTerminableInternationalModel | 組織の期間国際化モデルです。
DepartmentTerminableModel | 組織の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.department の説明

組織情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.company.department クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.department の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.department の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.department の使用

jp.co.intra_mart.foundation.datastore.application.model.company.department を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.department 組織情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.department により使用される jp.co.intra_mart.foundation.datastore.application.model.company.department のクラス
DepartmentBaseModel
組織の基本モデルです。
DepartmentTerminableInternationalModel
組織の期間国際化モデルです。
DepartmentTerminableModel
組織の期間化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の使用

DepartmentInclusionBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion 組織内包情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion での DepartmentInclusionBaseModel の使用

DepartmentInclusionBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.inclusion のメソッド
DepartmentInclusionBaseModel | DepartmentInclusionMapper.create(String companyCode, String versionCode, String parentDepartmentCode, String departmentCode) プライマリキーに該当する組織内包を生成します。
DepartmentInclusionBaseModel | DepartmentInclusionMapper.select(String companyCode, String versionCode, String parentDepartmentCode, String departmentCode) プライマリーキーで特定される組織内包の基本モデルを取得します。

DepartmentInclusionBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.company.inclusion のメソッド
void | DepartmentInclusionMapper.insert(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ挿入します。
void | DepartmentInclusionMapper.update(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ更新します。
void | DepartmentInclusionMapper.delete(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DepartmentInclusionBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion
インタフェース DepartmentInclusionBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface DepartmentInclusionBaseModel
extends BaseModel

組織内包の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | COMPANY_CODE 会社コード
static String | DEPARTMENT_CODE 組織コード
static String | DEPTH 階層レベル
static String | PARENT_DEPARTMENT_CODE 親組織コード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | VERSION_CODE バージョンコード
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
int | getDepth() 階層レベルを取得します。
String | getParentDepartmentCode() 親組織コードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getVersionCode() バージョンコードを取得します。
void | setDepth(int depth) 階層レベルを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

VERSION_CODE

public static final String VERSION_CODE
バージョンコード

関連項目:
定数フィールド値

PARENT_DEPARTMENT_CODE

public static final String PARENT_DEPARTMENT_CODE
親組織コード

関連項目:
定数フィールド値

DEPARTMENT_CODE

public static final String DEPARTMENT_CODE
組織コード

関連項目:
定数フィールド値

DEPTH

public static final String DEPTH
階層レベル

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getVersionCode

public String getVersionCode()
                      throws AccessorException
バージョンコードを取得します。

戻り値:
バージョンコード
例外:
AccessorException - データの取得に失敗した場合

getParentDepartmentCode

public String getParentDepartmentCode()
                               throws AccessorException
親組織コードを取得します。

戻り値:
親組織コード
例外:
AccessorException - データの取得に失敗した場合

getDepartmentCode

public String getDepartmentCode()
                         throws AccessorException
組織コードを取得します。

戻り値:
組織コード
例外:
AccessorException - データの取得に失敗した場合

getDepth

public int getDepth()
             throws AccessorException
階層レベルを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
階層レベル
例外:
AccessorException - データの取得に失敗した場合

setDepth

public void setDepth(int depth)
              throws AccessorException
階層レベルを設定します。

パラメータ:
depth - 階層レベル
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DepartmentInclusionMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion
インタフェース DepartmentInclusionMapper

すべてのスーパーインタフェース:
Mapper
public interface DepartmentInclusionMapper
extends Mapper

組織内包に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
DepartmentInclusionBaseModel | create(String companyCode, String versionCode, String parentDepartmentCode, String departmentCode) プライマリキーに該当する組織内包を生成します。
void | delete(Collection models) 組織内包の基本モデルを複数削除します。
void | delete(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ削除します。
void | insert(Collection models) 組織内包の基本モデルを複数挿入します。
void | insert(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ挿入します。
DepartmentInclusionBaseModel | select(String companyCode, String versionCode, String parentDepartmentCode, String departmentCode) プライマリーキーで特定される組織内包の基本モデルを取得します。
void | update(Collection models) 組織内包の基本モデルを複数更新します。
void | update(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public DepartmentInclusionBaseModel create(String companyCode,
                                           String versionCode,
                                           String parentDepartmentCode,
                                           String departmentCode)
                                    throws MapperException
プライマリキーに該当する組織内包を生成します。

パラメータ:
companyCode - 会社コード
versionCode - バージョンコード
parentDepartmentCode - 親組織コード
departmentCode - 組織コード
戻り値:
プライマリキーに該当する組織内包の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public DepartmentInclusionBaseModel select(String companyCode,
                                           String versionCode,
                                           String parentDepartmentCode,
                                           String departmentCode)
                                    throws MapperException
プライマリーキーで特定される組織内包の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
companyCode - 会社コード
versionCode - バージョンコード
parentDepartmentCode - 親組織コード
departmentCode - 組織コード
戻り値:
組織内包の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(DepartmentInclusionBaseModel model)
            throws MapperException
組織内包の基本モデルを1つだけ挿入します。 引数に指定する組織内包の基本モデルは同一の DepartmentInclusionMapperの create(String,String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する組織内包の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
組織内包の基本モデルを複数挿入します。 引数に指定するものは同一の DepartmentInclusionMapperの create(String,String,String,String) で生成された組織内包の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する組織内包の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(DepartmentInclusionBaseModel model)
            throws MapperException
組織内包の基本モデルを1つだけ更新します。 引数に指定する組織内包の基本モデルは同一の DepartmentInclusionMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する組織内包の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
組織内包の基本モデルを複数更新します。 引数に指定するものは同一の DepartmentInclusionMapperの select 系メソッド から取得されたものかで生成された組織内包の基本モデルの集合である必要があります。

パラメータ:
models - 更新する組織内包の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(DepartmentInclusionBaseModel model)
            throws MapperException
組織内包の基本モデルを1つだけ削除します。 引数で指定された組織内包の基本モデルに該当するデータのすべての情報を削除します。引数に指定する組織内包の基本モデルは同一の DepartmentInclusionMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する組織内包の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
組織内包の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する組織内包の基本モデルは同一の DepartmentInclusionMapperの select 系メソッド から取得された組織内包の基本モデルの集合である必要があります。

パラメータ:
models - 削除する組織内包の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.company.inclusion (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.company.inclusion
インタフェース
DepartmentInclusionBaseModel
DepartmentInclusionMapper


jp.co.intra_mart.foundation.datastore.application.model.company.inclusion (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.inclusion

組織内包情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
DepartmentInclusionBaseModel | 組織内包の基本モデルです。
DepartmentInclusionMapper | 組織内包に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.inclusion の説明

組織内包情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.company.inclusion クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.inclusion の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.inclusion の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion の使用

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion 組織内包情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion により使用される jp.co.intra_mart.foundation.datastore.application.model.company.inclusion のクラス
DepartmentInclusionBaseModel
組織内包の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の使用

DepartmentMainBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.main 組織主所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.main での DepartmentMainBaseModel の使用

DepartmentMainBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.main のメソッド
DepartmentMainBaseModel | DepartmentMainMapper.create(String userCode) プライマリキーに該当する主所属を生成します。
DepartmentMainBaseModel | DepartmentMainMapper.select(String userCode) プライマリーキーで特定される主所属の基本モデルを取得します。

DepartmentMainBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.company.main のメソッド
void | DepartmentMainMapper.insert(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ挿入します。
void | DepartmentMainMapper.update(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ更新します。
void | DepartmentMainMapper.delete(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel の使用

DepartmentMainTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.main 組織主所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.main での DepartmentMainTerminableModel の使用

DepartmentMainTerminableModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.main のメソッド
 DepartmentMainTerminableModel DepartmentMainBaseModel.selectDepartmentMainTerminableModel(Date date)
指定された日付に該当する主所属の期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DepartmentMainBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.main
インタフェース DepartmentMainBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface DepartmentMainBaseModel
extends BaseModel

主所属の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | COMPANY_CODE 会社コード
static String | DEPARTMENT_CODE 組織コード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | USER_CODE ユーザコード
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getCompanyCode(Date date) 会社コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
String | getDepartmentCode(Date date) 組織コードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getUserCode() ユーザコードを取得します。
DepartmentMainTerminableModel | selectDepartmentMainTerminableModel(Date date) 指定された日付に該当する主所属の期間化モデルを取得します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setCompanyCode(String companyCode, Date date) 会社コードを設定します。
void | setDepartmentCode(String departmentCode) 組織コードを設定します。
void | setDepartmentCode(String departmentCode, Date date) 組織コードを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

USER_CODE

public static final String USER_CODE
ユーザコード

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

DEPARTMENT_CODE

public static final String DEPARTMENT_CODE
組織コード

関連項目:
定数フィールド値
メソッドの詳細

getUserCode

public String getUserCode()
                   throws AccessorException
ユーザコードを取得します。

戻り値:
ユーザコード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getCompanyCode

public String getCompanyCode(Date date)
                      throws AccessorException
会社コードを取得します。

パラメータ:
date - 日時
戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

setCompanyCode

public void setCompanyCode(String companyCode)
                    throws AccessorException
会社コードを設定します。

パラメータ:
companyCode - 会社コード
例外:
AccessorException - データの設定に失敗した場合

setCompanyCode

public void setCompanyCode(String companyCode,
                           Date date)
                    throws AccessorException
会社コードを設定します。

パラメータ:
companyCode - 会社コード
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getDepartmentCode

public String getDepartmentCode()
                         throws AccessorException
組織コードを取得します。

戻り値:
組織コード
例外:
AccessorException - データの取得に失敗した場合

getDepartmentCode

public String getDepartmentCode(Date date)
                         throws AccessorException
組織コードを取得します。

パラメータ:
date - 日時
戻り値:
組織コード
例外:
AccessorException - データの取得に失敗した場合

setDepartmentCode

public void setDepartmentCode(String departmentCode)
                       throws AccessorException
組織コードを設定します。

パラメータ:
departmentCode - 組織コード
例外:
AccessorException - データの設定に失敗した場合

setDepartmentCode

public void setDepartmentCode(String departmentCode,
                              Date date)
                       throws AccessorException
組織コードを設定します。

パラメータ:
departmentCode - 組織コード
date - 日時
例外:
AccessorException - データの設定に失敗した場合

selectDepartmentMainTerminableModel

public DepartmentMainTerminableModel selectDepartmentMainTerminableModel(Date date)
                                                                  throws IllegalTermException
指定された日付に該当する主所属の期間化モデルを取得します。

パラメータ:
date - 指定日付
戻り値:
主所属の期間化モデル
例外:
IllegalTermException - 指定された日付に該当する期間が定義されていない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DepartmentMainMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.main
インタフェース DepartmentMainMapper

すべてのスーパーインタフェース:
Mapper
public interface DepartmentMainMapper
extends Mapper

主所属に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
DepartmentMainBaseModel | create(String userCode) プライマリキーに該当する主所属を生成します。
void | delete(Collection models) 主所属の基本モデルを複数削除します。
void | delete(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ削除します。
void | insert(Collection models) 主所属の基本モデルを複数挿入します。
void | insert(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ挿入します。
DepartmentMainBaseModel | select(String userCode) プライマリーキーで特定される主所属の基本モデルを取得します。
void | update(Collection models) 主所属の基本モデルを複数更新します。
void | update(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public DepartmentMainBaseModel create(String userCode)
                               throws MapperException
プライマリキーに該当する主所属を生成します。

パラメータ:
userCode - ユーザコード
戻り値:
プライマリキーに該当する主所属の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public DepartmentMainBaseModel select(String userCode)
                               throws MapperException
プライマリーキーで特定される主所属の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
userCode - ユーザコード
戻り値:
主所属の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(DepartmentMainBaseModel model)
            throws MapperException
主所属の基本モデルを1つだけ挿入します。 引数に指定する主所属の基本モデルは同一の DepartmentMainMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入する主所属の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
主所属の基本モデルを複数挿入します。 引数に指定するものは同一の DepartmentMainMapperの create(String) で生成された主所属の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する主所属の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(DepartmentMainBaseModel model)
            throws MapperException
主所属の基本モデルを1つだけ更新します。 引数に指定する主所属の基本モデルは同一の DepartmentMainMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する主所属の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
主所属の基本モデルを複数更新します。 引数に指定するものは同一の DepartmentMainMapperの select 系メソッド から取得されたものかで生成された主所属の基本モデルの集合である必要があります。

パラメータ:
models - 更新する主所属の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(DepartmentMainBaseModel model)
            throws MapperException
主所属の基本モデルを1つだけ削除します。 引数で指定された主所属の基本モデルに該当するデータのすべての情報を削除します。引数に指定する主所属の基本モデルは同一の DepartmentMainMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する主所属の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
主所属の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する主所属の基本モデルは同一の DepartmentMainMapperの select 系メソッド から取得された主所属の基本モデルの集合である必要があります。

パラメータ:
models - 削除する主所属の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DepartmentMainTerminableModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.main
インタフェース DepartmentMainTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface DepartmentMainTerminableModel
extends TerminableModel

主所属の期間化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setDepartmentCode(String departmentCode) 組織コードを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

メソッドの詳細

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

setCompanyCode

public void setCompanyCode(String companyCode)
                    throws AccessorException
会社コードを設定します。

パラメータ:
companyCode - 会社コード
例外:
AccessorException - データの設定に失敗した場合

getDepartmentCode

public String getDepartmentCode()
                         throws AccessorException
組織コードを取得します。

戻り値:
組織コード
例外:
AccessorException - データの取得に失敗した場合

setDepartmentCode

public void setDepartmentCode(String departmentCode)
                       throws AccessorException
組織コードを設定します。

パラメータ:
departmentCode - 組織コード
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.company.main (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.company.main
インタフェース
DepartmentMainBaseModel
DepartmentMainMapper
DepartmentMainTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.company.main (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.main

組織主所属情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
DepartmentMainBaseModel | 主所属の基本モデルです。
DepartmentMainMapper | 主所属に関連するマッパです。
DepartmentMainTerminableModel | 主所属の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.main の説明

組織主所属情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.company.main クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.main の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.main の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.main の使用

jp.co.intra_mart.foundation.datastore.application.model.company.main を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.main 組織主所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.main により使用される jp.co.intra_mart.foundation.datastore.application.model.company.main のクラス
DepartmentMainBaseModel
主所属の基本モデルです。
DepartmentMainTerminableModel
主所属の期間化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の使用

CompanyPostBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.post 会社役職情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.post での CompanyPostBaseModel の使用

CompanyPostBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.post のメソッド
CompanyPostBaseModel | CompanyPostMapper.create(String companyCode, String postCode) プライマリキーに該当する役職を生成します。
CompanyPostBaseModel | CompanyPostMapper.select(String companyCode, String postCode) プライマリーキーで特定される役職の基本モデルを取得します。

CompanyPostBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.company.post のメソッド
void | CompanyPostMapper.insert(CompanyPostBaseModel model) 役職の基本モデルを1つだけ挿入します。
void | CompanyPostMapper.update(CompanyPostBaseModel model) 役職の基本モデルを1つだけ更新します。
void | CompanyPostMapper.delete(CompanyPostBaseModel model) 役職の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel の使用

CompanyPostTerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.post 会社役職情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.post での CompanyPostTerminableInternationalModel の使用

CompanyPostTerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.post のメソッド
 CompanyPostTerminableInternationalModel CompanyPostTerminableModel.selectCompanyPostTerminableInternationalModel(Locale locale)
指定された言語に該当する役職の期間国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel の使用

CompanyPostTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.post 会社役職情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.post での CompanyPostTerminableModel の使用

CompanyPostTerminableModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.post のメソッド
 CompanyPostTerminableModel CompanyPostBaseModel.selectCompanyPostTerminableModel(Date date)
指定された日付に該当する役職の期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CompanyPostBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.post
インタフェース CompanyPostBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface CompanyPostBaseModel
extends BaseModel

役職の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | COMPANY_CODE 会社コード
static String | NAME 役職名
static String | NOTES 備考
static String | POST_CODE 役職コード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getName() 役職名を取得します。
String | getName(Date date) 役職名を取得します。
String | getName(Date date, Locale locale) 役職名を取得します。
String | getName(Locale locale) 役職名を取得します。
String | getNotes() 備考を取得します。
String | getPostCode() 役職コードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
CompanyPostTerminableModel | selectCompanyPostTerminableModel(Date date) 指定された日付に該当する役職の期間化モデルを取得します。
void | setName(String name) 役職名を設定します。
void | setName(String name, Date date) 役職名を設定します。
void | setName(String name, Date date, Locale locale) 役職名を設定します。
void | setName(String name, Locale locale) 役職名を設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

POST_CODE

public static final String POST_CODE
役職コード

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

NAME

public static final String NAME
役職名

関連項目:
定数フィールド値
メソッドの詳細

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getPostCode

public String getPostCode()
                   throws AccessorException
役職コードを取得します。

戻り値:
役職コード
例外:
AccessorException - データの取得に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName()
               throws AccessorException
役職名を取得します。

戻り値:
役職名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Date date)
               throws AccessorException
役職名を取得します。

パラメータ:
date - 日時
戻り値:
役職名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
役職名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
役職名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Date date,
                      Locale locale)
               throws AccessorException
役職名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
役職名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
役職名を設定します。

パラメータ:
name - 役職名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Date date)
             throws AccessorException
役職名を設定します。

パラメータ:
name - 役職名
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
役職名を設定します。

パラメータ:
name - 役職名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Date date,
                    Locale locale)
             throws AccessorException
役職名を設定します。

パラメータ:
name - 役職名
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectCompanyPostTerminableModel

public CompanyPostTerminableModel selectCompanyPostTerminableModel(Date date)
                                                            throws IllegalTermException
指定された日付に該当する役職の期間化モデルを取得します。

パラメータ:
date - 指定日付
戻り値:
役職の期間化モデル
例外:
IllegalTermException - 指定された日付に該当する期間が定義されていない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyPostMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.post
インタフェース CompanyPostMapper

すべてのスーパーインタフェース:
Mapper
public interface CompanyPostMapper
extends Mapper

役職に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
CompanyPostBaseModel | create(String companyCode, String postCode) プライマリキーに該当する役職を生成します。
void | delete(Collection models) 役職の基本モデルを複数削除します。
void | delete(CompanyPostBaseModel model) 役職の基本モデルを1つだけ削除します。
void | insert(Collection models) 役職の基本モデルを複数挿入します。
void | insert(CompanyPostBaseModel model) 役職の基本モデルを1つだけ挿入します。
CompanyPostBaseModel | select(String companyCode, String postCode) プライマリーキーで特定される役職の基本モデルを取得します。
void | update(Collection models) 役職の基本モデルを複数更新します。
void | update(CompanyPostBaseModel model) 役職の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public CompanyPostBaseModel create(String companyCode,
                                   String postCode)
                            throws MapperException
プライマリキーに該当する役職を生成します。

パラメータ:
companyCode - 会社コード
postCode - 役職コード
戻り値:
プライマリキーに該当する役職の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public CompanyPostBaseModel select(String companyCode,
                                   String postCode)
                            throws MapperException
プライマリーキーで特定される役職の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
companyCode - 会社コード
postCode - 役職コード
戻り値:
役職の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(CompanyPostBaseModel model)
            throws MapperException
役職の基本モデルを1つだけ挿入します。 引数に指定する役職の基本モデルは同一の CompanyPostMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する役職の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
役職の基本モデルを複数挿入します。 引数に指定するものは同一の CompanyPostMapperの create(String,String) で生成された役職の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する役職の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(CompanyPostBaseModel model)
            throws MapperException
役職の基本モデルを1つだけ更新します。 引数に指定する役職の基本モデルは同一の CompanyPostMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する役職の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
役職の基本モデルを複数更新します。 引数に指定するものは同一の CompanyPostMapperの select 系メソッド から取得されたものかで生成された役職の基本モデルの集合である必要があります。

パラメータ:
models - 更新する役職の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(CompanyPostBaseModel model)
            throws MapperException
役職の基本モデルを1つだけ削除します。 引数で指定された役職の基本モデルに該当するデータのすべての情報を削除します。引数に指定する役職の基本モデルは同一の CompanyPostMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する役職の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
役職の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する役職の基本モデルは同一の CompanyPostMapperの select 系メソッド から取得された役職の基本モデルの集合である必要があります。

パラメータ:
models - 削除する役職の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyPostTerminableInternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.post
インタフェース CompanyPostTerminableInternationalModel

すべてのスーパーインタフェース:
Serializable, TerminableInternationalModel
public interface CompanyPostTerminableInternationalModel
extends TerminableInternationalModel

役職の期間国際化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getName() 役職名を取得します。
void | setName(String name) 役職名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel から継承したメソッド
getExtendedTerminableInternationalModelMap, getLocale, init

メソッドの詳細

getName

public String getName()
               throws AccessorException
役職名を取得します。

戻り値:
役職名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
役職名を設定します。

パラメータ:
name - 役職名
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyPostTerminableModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.post
インタフェース CompanyPostTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface CompanyPostTerminableModel
extends TerminableModel

役職の期間化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getName() 役職名を取得します。
String | getName(Locale locale) 役職名を取得します。
CompanyPostTerminableInternationalModel | selectCompanyPostTerminableInternationalModel(Locale locale) 指定された言語に該当する役職の期間国際化モデルを取得します。
void | setName(String name) 役職名を設定します。
void | setName(String name, Locale locale) 役職名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

メソッドの詳細

getName

public String getName()
               throws AccessorException
役職名を取得します。

戻り値:
役職名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
役職名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
役職名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
役職名を設定します。

パラメータ:
name - 役職名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
役職名を設定します。

パラメータ:
name - 役職名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectCompanyPostTerminableInternationalModel

public CompanyPostTerminableInternationalModel selectCompanyPostTerminableInternationalModel(Locale locale)
                                                                                throws IllegalLocaleException
指定された言語に該当する役職の期間国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
役職の期間国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.company.post (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.company.post
インタフェース
CompanyPostBaseModel
CompanyPostMapper
CompanyPostTerminableInternationalModel
CompanyPostTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.company.post (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.post

会社役職情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
CompanyPostBaseModel | 役職の基本モデルです。
CompanyPostMapper | 役職に関連するマッパです。
CompanyPostTerminableInternationalModel | 役職の期間国際化モデルです。
CompanyPostTerminableModel | 役職の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.post の説明

会社役職情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.company.post クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.post の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.post の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.post の使用

jp.co.intra_mart.foundation.datastore.application.model.company.post を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.post 会社役職情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.post により使用される jp.co.intra_mart.foundation.datastore.application.model.company.post のクラス
CompanyPostBaseModel
役職の基本モデルです。
CompanyPostTerminableInternationalModel
役職の期間国際化モデルです。
CompanyPostTerminableModel
役職の期間化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の使用

CompanyVersionBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.version 会社バージョン情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.version での CompanyVersionBaseModel の使用

CompanyVersionBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.version のメソッド
CompanyVersionBaseModel | CompanyVersionMapper.create(String companyCode, String versionCode) プライマリキーに該当する会社構成バージョンを生成します。
CompanyVersionBaseModel | CompanyVersionMapper.select(String companyCode, String versionCode) プライマリーキーで特定される会社構成バージョンの基本モデルを取得します。

CompanyVersionBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.company.version のメソッド
void | CompanyVersionMapper.insert(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ挿入します。
void | CompanyVersionMapper.update(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ更新します。
void | CompanyVersionMapper.delete(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CompanyVersionBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.version
インタフェース CompanyVersionBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface CompanyVersionBaseModel
extends BaseModel

会社構成バージョンの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | COMPANY_CODE 会社コード
static String | END_DATE 終了日
static String | NOTES 備考
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | START_DATE 開始日
static String | VERSION_CODE バージョンコード
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
Date | getEndDate() 終了日を取得します。
String | getNotes() 備考を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
Date | getStartDate() 開始日を取得します。
String | getVersionCode() バージョンコードを取得します。
void | setEndDate(Date endDate) 終了日を設定します。
void | setNotes(String notes) 備考を設定します。
void | setStartDate(Date startDate) 開始日を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

VERSION_CODE

public static final String VERSION_CODE
バージョンコード

関連項目:
定数フィールド値

START_DATE

public static final String START_DATE
開始日

関連項目:
定数フィールド値

END_DATE

public static final String END_DATE
終了日

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getVersionCode

public String getVersionCode()
                      throws AccessorException
バージョンコードを取得します。

戻り値:
バージョンコード
例外:
AccessorException - データの取得に失敗した場合

getStartDate

public Date getStartDate()
                  throws AccessorException
開始日を取得します。

戻り値:
開始日
例外:
AccessorException - データの取得に失敗した場合

setStartDate

public void setStartDate(Date startDate)
                  throws AccessorException
開始日を設定します。

パラメータ:
startDate - 開始日
例外:
AccessorException - データの設定に失敗した場合

getEndDate

public Date getEndDate()
                throws AccessorException
終了日を取得します。

戻り値:
終了日
例外:
AccessorException - データの取得に失敗した場合

setEndDate

public void setEndDate(Date endDate)
                throws AccessorException
終了日を設定します。

パラメータ:
endDate - 終了日
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyVersionMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.version
インタフェース CompanyVersionMapper

すべてのスーパーインタフェース:
Mapper
public interface CompanyVersionMapper
extends Mapper

会社構成バージョンに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
CompanyVersionBaseModel | create(String companyCode, String versionCode) プライマリキーに該当する会社構成バージョンを生成します。
void | delete(Collection models) 会社構成バージョンの基本モデルを複数削除します。
void | delete(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ削除します。
void | insert(Collection models) 会社構成バージョンの基本モデルを複数挿入します。
void | insert(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ挿入します。
CompanyVersionBaseModel | select(String companyCode, String versionCode) プライマリーキーで特定される会社構成バージョンの基本モデルを取得します。
void | update(Collection models) 会社構成バージョンの基本モデルを複数更新します。
void | update(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public CompanyVersionBaseModel create(String companyCode,
                                      String versionCode)
                               throws MapperException
プライマリキーに該当する会社構成バージョンを生成します。

パラメータ:
companyCode - 会社コード
versionCode - バージョンコード
戻り値:
プライマリキーに該当する会社構成バージョンの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public CompanyVersionBaseModel select(String companyCode,
                                      String versionCode)
                               throws MapperException
プライマリーキーで特定される会社構成バージョンの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
companyCode - 会社コード
versionCode - バージョンコード
戻り値:
会社構成バージョンの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(CompanyVersionBaseModel model)
            throws MapperException
会社構成バージョンの基本モデルを1つだけ挿入します。 引数に指定する会社構成バージョンの基本モデルは同一の CompanyVersionMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する会社構成バージョンの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
会社構成バージョンの基本モデルを複数挿入します。 引数に指定するものは同一の CompanyVersionMapperの create(String,String) で生成された会社構成バージョンの基本モデルの集合である必要があります。

パラメータ:
models - 挿入する会社構成バージョンの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(CompanyVersionBaseModel model)
            throws MapperException
会社構成バージョンの基本モデルを1つだけ更新します。 引数に指定する会社構成バージョンの基本モデルは同一の CompanyVersionMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する会社構成バージョンの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
会社構成バージョンの基本モデルを複数更新します。 引数に指定するものは同一の CompanyVersionMapperの select 系メソッド から取得されたものかで生成された会社構成バージョンの基本モデルの集合である必要があります。

パラメータ:
models - 更新する会社構成バージョンの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(CompanyVersionBaseModel model)
            throws MapperException
会社構成バージョンの基本モデルを1つだけ削除します。 引数で指定された会社構成バージョンの基本モデルに該当するデータのすべての情報を削除します。引数に指定する会社構成バージョンの基本モデルは同一の CompanyVersionMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する会社構成バージョンの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
会社構成バージョンの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する会社構成バージョンの基本モデルは同一の CompanyVersionMapperの select 系メソッド から取得された会社構成バージョンの基本モデルの集合である必要があります。

パラメータ:
models - 削除する会社構成バージョンの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.company.version (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.company.version
インタフェース
CompanyVersionBaseModel
CompanyVersionMapper


jp.co.intra_mart.foundation.datastore.application.model.company.version (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.version

会社バージョン情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
CompanyVersionBaseModel | 会社構成バージョンの基本モデルです。
CompanyVersionMapper | 会社構成バージョンに関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.version の説明

会社バージョン情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.company.version クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.version の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.version の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.version の使用

jp.co.intra_mart.foundation.datastore.application.model.company.version を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.version 会社バージョン情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.version により使用される jp.co.intra_mart.foundation.datastore.application.model.company.version のクラス
CompanyVersionBaseModel
会社構成バージョンの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の使用

DealBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.deal 取扱情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.deal.deal での DealBaseModel の使用

DealBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.deal.deal のメソッド
DealBaseModel | DealMapper.create(String customerCompanyCode, String customerDepartmentCode, String dealCode) プライマリキーに該当する取扱を生成します。
DealBaseModel | DealMapper.select(String customerCompanyCode, String customerDepartmentCode, String dealCode) プライマリーキーで特定される取扱の基本モデルを取得します。

DealBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.deal.deal のメソッド
void | DealMapper.insert(DealBaseModel model) 取扱の基本モデルを1つだけ挿入します。
void | DealMapper.update(DealBaseModel model) 取扱の基本モデルを1つだけ更新します。
void | DealMapper.delete(DealBaseModel model) 取扱の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealTerminableModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealTerminableModel の使用

DealTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.deal 取扱情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.deal.deal での DealTerminableModel の使用

DealTerminableModel を返す jp.co.intra_mart.foundation.datastore.application.model.deal.deal のメソッド
 DealTerminableModel DealBaseModel.selectDealTerminableModel(Date date)
指定された日付に該当する取扱の期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DealBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.deal.deal
インタフェース DealBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface DealBaseModel
extends BaseModel

取扱の基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | CURRENCY_CODE 通貨コード
static String | CUSTOMER_COMPANY_CODE 取引先会社コード
static String | CUSTOMER_DEPARTMENT_CODE 取引先組織コード
static String | DEAL_CODE 取扱コード
static String | DEAL_NAME 取扱名
static String | DEAL_TYPE 取扱種別
static int | DEAL_TYPE_BUY 取引種別が仕入れを表す定数
static int | DEAL_TYPE_SELL 取引種別が売り上げを表す定数
static String | NOTES 備考
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | UNIT_PRICE 単価
メソッドの概要
String | getCurrencyCode() 通貨コードを取得します。
String | getCustomerCompanyCode() 取引先会社コードを取得します。
String | getCustomerDepartmentCode() 取引先組織コードを取得します。
String | getDealCode() 取扱コードを取得します。
String | getDealName() 取扱名を取得します。
int | getDealType() 取扱種別を取得します。
String | getNotes() 備考を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
double | getUnitPrice() 単価を取得します。
double | getUnitPrice(Date date) 単価を取得します。
DealTerminableModel | selectDealTerminableModel(Date date) 指定された日付に該当する取扱の期間化モデルを取得します。
void | setCurrencyCode(String currencyCode) 通貨コードを設定します。
void | setDealName(String dealName) 取扱名を設定します。
void | setDealType(int dealType) 取扱種別を設定します。
void | setNotes(String notes) 備考を設定します。
void | setUnitPrice(double unitPrice) 単価を設定します。
void | setUnitPrice(double unitPrice, Date date) 単価を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

CUSTOMER_COMPANY_CODE

public static final String CUSTOMER_COMPANY_CODE
取引先会社コード

関連項目:
定数フィールド値

CUSTOMER_DEPARTMENT_CODE

public static final String CUSTOMER_DEPARTMENT_CODE
取引先組織コード

関連項目:
定数フィールド値

DEAL_CODE

public static final String DEAL_CODE
取扱コード

関連項目:
定数フィールド値

DEAL_NAME

public static final String DEAL_NAME
取扱名

関連項目:
定数フィールド値

DEAL_TYPE

public static final String DEAL_TYPE
取扱種別

関連項目:
定数フィールド値

CURRENCY_CODE

public static final String CURRENCY_CODE
通貨コード

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

UNIT_PRICE

public static final String UNIT_PRICE
単価

関連項目:
定数フィールド値

DEAL_TYPE_BUY

public static final int DEAL_TYPE_BUY
取引種別が仕入れを表す定数

関連項目:
定数フィールド値

DEAL_TYPE_SELL

public static final int DEAL_TYPE_SELL
取引種別が売り上げを表す定数

関連項目:
定数フィールド値
メソッドの詳細

getCustomerCompanyCode

public String getCustomerCompanyCode()
                              throws AccessorException
取引先会社コードを取得します。

戻り値:
取引先会社コード
例外:
AccessorException - データの取得に失敗した場合

getCustomerDepartmentCode

public String getCustomerDepartmentCode()
                                 throws AccessorException
取引先組織コードを取得します。

戻り値:
取引先組織コード
例外:
AccessorException - データの取得に失敗した場合

getDealCode

public String getDealCode()
                   throws AccessorException
取扱コードを取得します。

戻り値:
取扱コード
例外:
AccessorException - データの取得に失敗した場合

getDealName

public String getDealName()
                   throws AccessorException
取扱名を取得します。

戻り値:
取扱名
例外:
AccessorException - データの取得に失敗した場合

setDealName

public void setDealName(String dealName)
                 throws AccessorException
取扱名を設定します。

パラメータ:
dealName - 取扱名
例外:
AccessorException - データの設定に失敗した場合

getDealType

public int getDealType()
                throws AccessorException
取扱種別を取得します。

戻り値:
取扱種別
例外:
AccessorException - データの取得に失敗した場合

setDealType

public void setDealType(int dealType)
                 throws AccessorException
取扱種別を設定します。

パラメータ:
dealType - 取扱種別
例外:
AccessorException - データの設定に失敗した場合

getCurrencyCode

public String getCurrencyCode()
                       throws AccessorException
通貨コードを取得します。

戻り値:
通貨コード
例外:
AccessorException - データの取得に失敗した場合

setCurrencyCode

public void setCurrencyCode(String currencyCode)
                     throws AccessorException
通貨コードを設定します。

パラメータ:
currencyCode - 通貨コード
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getUnitPrice

public double getUnitPrice()
                    throws AccessorException
単価を取得します。

戻り値:
単価
例外:
AccessorException - データの取得に失敗した場合

getUnitPrice

public double getUnitPrice(Date date)
                    throws AccessorException
単価を取得します。

パラメータ:
date - 日時
戻り値:
単価
例外:
AccessorException - データの取得に失敗した場合

setUnitPrice

public void setUnitPrice(double unitPrice)
                  throws AccessorException
単価を設定します。

パラメータ:
unitPrice - 単価
例外:
AccessorException - データの設定に失敗した場合

setUnitPrice

public void setUnitPrice(double unitPrice,
                         Date date)
                  throws AccessorException
単価を設定します。

パラメータ:
unitPrice - 単価
date - 日時
例外:
AccessorException - データの設定に失敗した場合

selectDealTerminableModel

public DealTerminableModel selectDealTerminableModel(Date date)
                                              throws IllegalTermException
指定された日付に該当する取扱の期間化モデルを取得します。

パラメータ:
date - 指定日付
戻り値:
取扱の期間化モデル
例外:
IllegalTermException - 指定された日付に該当する期間が定義されていない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DealMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.deal.deal
インタフェース DealMapper

すべてのスーパーインタフェース:
Mapper
public interface DealMapper
extends Mapper

取扱に関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
DealBaseModel | create(String customerCompanyCode, String customerDepartmentCode, String dealCode) プライマリキーに該当する取扱を生成します。
void | delete(Collection models) 取扱の基本モデルを複数削除します。
void | delete(DealBaseModel model) 取扱の基本モデルを1つだけ削除します。
void | insert(Collection models) 取扱の基本モデルを複数挿入します。
void | insert(DealBaseModel model) 取扱の基本モデルを1つだけ挿入します。
DealBaseModel | select(String customerCompanyCode, String customerDepartmentCode, String dealCode) プライマリーキーで特定される取扱の基本モデルを取得します。
void | update(Collection models) 取扱の基本モデルを複数更新します。
void | update(DealBaseModel model) 取扱の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public DealBaseModel create(String customerCompanyCode,
                            String customerDepartmentCode,
                            String dealCode)
                     throws MapperException
プライマリキーに該当する取扱を生成します。

パラメータ:
customerCompanyCode - 取引先会社コード
customerDepartmentCode - 取引先組織コード
dealCode - 取扱コード
戻り値:
プライマリキーに該当する取扱の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public DealBaseModel select(String customerCompanyCode,
                            String customerDepartmentCode,
                            String dealCode)
                     throws MapperException
プライマリーキーで特定される取扱の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
customerCompanyCode - 取引先会社コード
customerDepartmentCode - 取引先組織コード
dealCode - 取扱コード
戻り値:
取扱の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(DealBaseModel model)
            throws MapperException
取扱の基本モデルを1つだけ挿入します。 引数に指定する取扱の基本モデルは同一の DealMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する取扱の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
取扱の基本モデルを複数挿入します。 引数に指定するものは同一の DealMapperの create(String,String,String) で生成された取扱の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する取扱の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(DealBaseModel model)
            throws MapperException
取扱の基本モデルを1つだけ更新します。 引数に指定する取扱の基本モデルは同一の DealMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する取扱の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
取扱の基本モデルを複数更新します。 引数に指定するものは同一の DealMapperの select 系メソッド から取得されたものかで生成された取扱の基本モデルの集合である必要があります。

パラメータ:
models - 更新する取扱の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(DealBaseModel model)
            throws MapperException
取扱の基本モデルを1つだけ削除します。 引数で指定された取扱の基本モデルに該当するデータのすべての情報を削除します。引数に指定する取扱の基本モデルは同一の DealMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する取扱の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
取扱の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する取扱の基本モデルは同一の DealMapperの select 系メソッド から取得された取扱の基本モデルの集合である必要があります。

パラメータ:
models - 削除する取扱の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DealTerminableModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.deal.deal
インタフェース DealTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface DealTerminableModel
extends TerminableModel

取扱の期間化モデルです。

導入されたバージョン:
5.1

メソッドの概要
double | getUnitPrice() 単価を取得します。
void | setUnitPrice(double unitPrice) 単価を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

メソッドの詳細

getUnitPrice

public double getUnitPrice()
                    throws AccessorException
単価を取得します。

戻り値:
単価
例外:
AccessorException - データの取得に失敗した場合

setUnitPrice

public void setUnitPrice(double unitPrice)
                  throws AccessorException
単価を設定します。

パラメータ:
unitPrice - 単価
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.deal.deal (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.deal.deal
インタフェース
DealBaseModel
DealMapper
DealTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.deal.deal (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.deal

取扱情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
DealBaseModel | 取扱の基本モデルです。
DealMapper | 取扱に関連するマッパです。
DealTerminableModel | 取扱の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.deal の説明

取扱情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.deal.deal クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.deal の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealTerminableModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.deal の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.deal の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.deal を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.deal 取扱情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.deal.deal により使用される jp.co.intra_mart.foundation.datastore.application.model.deal.deal のクラス
DealBaseModel
取扱の基本モデルです。
DealTerminableModel
取扱の期間化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel の使用

DealerDepartmentBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.department 取扱組織権限情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.deal.department での DealerDepartmentBaseModel の使用

DealerDepartmentBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.deal.department のメソッド
DealerDepartmentBaseModel | DealerDepartmentMapper.create(String customerCompanyCode, String customerDepartmentCode, String dealCode, String companyCode, String departmentCode) プライマリキーに該当する組織毎取扱パーミッションを生成します。
DealerDepartmentBaseModel | DealerDepartmentMapper.select(String customerCompanyCode, String customerDepartmentCode, String dealCode, String companyCode, String departmentCode) プライマリーキーで特定される組織毎取扱パーミッションの基本モデルを取得します。

DealerDepartmentBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.deal.department のメソッド
void | DealerDepartmentMapper.insert(DealerDepartmentBaseModel model) 組織毎取扱パーミッションの基本モデルを1つだけ挿入します。
void | DealerDepartmentMapper.update(DealerDepartmentBaseModel model) 組織毎取扱パーミッションの基本モデルを1つだけ更新します。
void | DealerDepartmentMapper.delete(DealerDepartmentBaseModel model) 組織毎取扱パーミッションの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DealerDepartmentBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.deal.department
インタフェース DealerDepartmentBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface DealerDepartmentBaseModel
extends BaseModel

組織毎取扱パーミッションの基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | COMPANY_CODE 会社コード
static String | CUSTOMER_COMPANY_CODE 取引先会社コード
static String | CUSTOMER_DEPARTMENT_CODE 取引先組織コード
static String | DEAL_CODE 取扱コード
static String | DEPARTMENT_CODE 組織コード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getCustomerCompanyCode() 取引先会社コードを取得します。
String | getCustomerDepartmentCode() 取引先組織コードを取得します。
String | getDealCode() 取扱コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

CUSTOMER_COMPANY_CODE

public static final String CUSTOMER_COMPANY_CODE
取引先会社コード

関連項目:
定数フィールド値

CUSTOMER_DEPARTMENT_CODE

public static final String CUSTOMER_DEPARTMENT_CODE
取引先組織コード

関連項目:
定数フィールド値

DEAL_CODE

public static final String DEAL_CODE
取扱コード

関連項目:
定数フィールド値

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

DEPARTMENT_CODE

public static final String DEPARTMENT_CODE
組織コード

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getCustomerCompanyCode

public String getCustomerCompanyCode()
                              throws AccessorException
取引先会社コードを取得します。

戻り値:
取引先会社コード
例外:
AccessorException - データの取得に失敗した場合

getCustomerDepartmentCode

public String getCustomerDepartmentCode()
                                 throws AccessorException
取引先組織コードを取得します。

戻り値:
取引先組織コード
例外:
AccessorException - データの取得に失敗した場合

getDealCode

public String getDealCode()
                   throws AccessorException
取扱コードを取得します。

戻り値:
取扱コード
例外:
AccessorException - データの取得に失敗した場合

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getDepartmentCode

public String getDepartmentCode()
                         throws AccessorException
組織コードを取得します。

戻り値:
組織コード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DealerDepartmentMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.deal.department
インタフェース DealerDepartmentMapper

すべてのスーパーインタフェース:
Mapper
public interface DealerDepartmentMapper
extends Mapper

組織毎取扱パーミッションに関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
DealerDepartmentBaseModel | create(String customerCompanyCode, String customerDepartmentCode, String dealCode, String companyCode, String departmentCode) プライマリキーに該当する組織毎取扱パーミッションを生成します。
void | delete(Collection models) 組織毎取扱パーミッションの基本モデルを複数削除します。
void | delete(DealerDepartmentBaseModel model) 組織毎取扱パーミッションの基本モデルを1つだけ削除します。
void | insert(Collection models) 組織毎取扱パーミッションの基本モデルを複数挿入します。
void | insert(DealerDepartmentBaseModel model) 組織毎取扱パーミッションの基本モデルを1つだけ挿入します。
DealerDepartmentBaseModel | select(String customerCompanyCode, String customerDepartmentCode, String dealCode, String companyCode, String departmentCode) プライマリーキーで特定される組織毎取扱パーミッションの基本モデルを取得します。
void | update(Collection models) 組織毎取扱パーミッションの基本モデルを複数更新します。
void | update(DealerDepartmentBaseModel model) 組織毎取扱パーミッションの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public DealerDepartmentBaseModel create(String customerCompanyCode,
                                        String customerDepartmentCode,
                                        String dealCode,
                                        String companyCode,
                                        String departmentCode)
                                 throws MapperException
プライマリキーに該当する組織毎取扱パーミッションを生成します。

パラメータ:
customerCompanyCode - 取引先会社コード
customerDepartmentCode - 取引先組織コード
dealCode - 取扱コード
companyCode - 会社コード
departmentCode - 組織コード
戻り値:
プライマリキーに該当する組織毎取扱パーミッションの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public DealerDepartmentBaseModel select(String customerCompanyCode,
                                        String customerDepartmentCode,
                                        String dealCode,
                                        String companyCode,
                                        String departmentCode)
                                 throws MapperException
プライマリーキーで特定される組織毎取扱パーミッションの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
customerCompanyCode - 取引先会社コード
customerDepartmentCode - 取引先組織コード
dealCode - 取扱コード
companyCode - 会社コード
departmentCode - 組織コード
戻り値:
組織毎取扱パーミッションの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(DealerDepartmentBaseModel model)
            throws MapperException
組織毎取扱パーミッションの基本モデルを1つだけ挿入します。 引数に指定する組織毎取扱パーミッションの基本モデルは同一の DealerDepartmentMapperの create(String,String,String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する組織毎取扱パーミッションの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
組織毎取扱パーミッションの基本モデルを複数挿入します。 引数に指定するものは同一の DealerDepartmentMapperの create(String,String,String,String,String) で生成された組織毎取扱パーミッションの基本モデルの集合である必要があります。

パラメータ:
models - 挿入する組織毎取扱パーミッションの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(DealerDepartmentBaseModel model)
            throws MapperException
組織毎取扱パーミッションの基本モデルを1つだけ更新します。 引数に指定する組織毎取扱パーミッションの基本モデルは同一の DealerDepartmentMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する組織毎取扱パーミッションの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
組織毎取扱パーミッションの基本モデルを複数更新します。 引数に指定するものは同一の DealerDepartmentMapperの select 系メソッド から取得されたものかで生成された組織毎取扱パーミッションの基本モデルの集合である必要があります。

パラメータ:
models - 更新する組織毎取扱パーミッションの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(DealerDepartmentBaseModel model)
            throws MapperException
組織毎取扱パーミッションの基本モデルを1つだけ削除します。 引数で指定された組織毎取扱パーミッションの基本モデルに該当するデータのすべての情報を削除します。引数に指定する組織毎取扱パーミッションの基本モデルは同一の DealerDepartmentMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する組織毎取扱パーミッションの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
組織毎取扱パーミッションの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する組織毎取扱パーミッションの基本モデルは同一の DealerDepartmentMapperの select 系メソッド から取得された組織毎取扱パーミッションの基本モデルの集合である必要があります。

パラメータ:
models - 削除する組織毎取扱パーミッションの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.deal.department (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.deal.department
インタフェース
DealerDepartmentBaseModel
DealerDepartmentMapper


jp.co.intra_mart.foundation.datastore.application.model.deal.department (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.department

取扱組織権限情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
DealerDepartmentBaseModel | 組織毎取扱パーミッションの基本モデルです。
DealerDepartmentMapper | 組織毎取扱パーミッションに関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.department の説明

取扱組織権限情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.deal.department クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.department の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.department の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.department の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.department を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.department 取扱組織権限情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.deal.department により使用される jp.co.intra_mart.foundation.datastore.application.model.deal.department のクラス
DealerDepartmentBaseModel
組織毎取扱パーミッションの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel の使用

DealDetailBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.detail 取扱詳細情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.deal.detail での DealDetailBaseModel の使用

DealDetailBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.deal.detail のメソッド
DealDetailBaseModel | DealDetailMapper.create(String customerCompanyCode, String customerDepartmentCode, String dealCode, String itemCode) プライマリキーに該当する取扱詳細を生成します。
DealDetailBaseModel | DealDetailMapper.select(String customerCompanyCode, String customerDepartmentCode, String dealCode, String itemCode) プライマリーキーで特定される取扱詳細の基本モデルを取得します。

DealDetailBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.deal.detail のメソッド
void | DealDetailMapper.insert(DealDetailBaseModel model) 取扱詳細の基本モデルを1つだけ挿入します。
void | DealDetailMapper.update(DealDetailBaseModel model) 取扱詳細の基本モデルを1つだけ更新します。
void | DealDetailMapper.delete(DealDetailBaseModel model) 取扱詳細の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailTerminableModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailTerminableModel の使用

DealDetailTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.detail 取扱詳細情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.deal.detail での DealDetailTerminableModel の使用

DealDetailTerminableModel を返す jp.co.intra_mart.foundation.datastore.application.model.deal.detail のメソッド
 DealDetailTerminableModel DealDetailBaseModel.selectDealDetailTerminableModel(Date date)
指定された日付に該当する取扱詳細の期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DealDetailBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.deal.detail
インタフェース DealDetailBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface DealDetailBaseModel
extends BaseModel

取扱詳細の基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | AMOUNT 数量
static String | CUSTOMER_COMPANY_CODE 取引先会社コード
static String | CUSTOMER_DEPARTMENT_CODE 取引先組織コード
static String | DEAL_CODE 取扱コード
static String | ITEM_CODE 商品コード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | UNIT_CODE 単位コード
static String | UNIT_PRICE 単価
メソッドの概要
int | getAmount() 数量を取得します。
int | getAmount(Date date) 数量を取得します。
String | getCustomerCompanyCode() 取引先会社コードを取得します。
String | getCustomerDepartmentCode() 取引先組織コードを取得します。
String | getDealCode() 取扱コードを取得します。
String | getItemCode() 商品コードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getUnitCode() 単位コードを取得します。
String | getUnitCode(Date date) 単位コードを取得します。
double | getUnitPrice() 単価を取得します。
double | getUnitPrice(Date date) 単価を取得します。
DealDetailTerminableModel | selectDealDetailTerminableModel(Date date) 指定された日付に該当する取扱詳細の期間化モデルを取得します。
void | setAmount(int amount) 数量を設定します。
void | setAmount(int amount, Date date) 数量を設定します。
void | setUnitCode(String unitCode) 単位コードを設定します。
void | setUnitCode(String unitCode, Date date) 単位コードを設定します。
void | setUnitPrice(double unitPrice) 単価を設定します。
void | setUnitPrice(double unitPrice, Date date) 単価を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

CUSTOMER_COMPANY_CODE

public static final String CUSTOMER_COMPANY_CODE
取引先会社コード

関連項目:
定数フィールド値

CUSTOMER_DEPARTMENT_CODE

public static final String CUSTOMER_DEPARTMENT_CODE
取引先組織コード

関連項目:
定数フィールド値

DEAL_CODE

public static final String DEAL_CODE
取扱コード

関連項目:
定数フィールド値

ITEM_CODE

public static final String ITEM_CODE
商品コード

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

UNIT_CODE

public static final String UNIT_CODE
単位コード

関連項目:
定数フィールド値

AMOUNT

public static final String AMOUNT
数量

関連項目:
定数フィールド値

UNIT_PRICE

public static final String UNIT_PRICE
単価

関連項目:
定数フィールド値
メソッドの詳細

getCustomerCompanyCode

public String getCustomerCompanyCode()
                              throws AccessorException
取引先会社コードを取得します。

戻り値:
取引先会社コード
例外:
AccessorException - データの取得に失敗した場合

getCustomerDepartmentCode

public String getCustomerDepartmentCode()
                                 throws AccessorException
取引先組織コードを取得します。

戻り値:
取引先組織コード
例外:
AccessorException - データの取得に失敗した場合

getDealCode

public String getDealCode()
                   throws AccessorException
取扱コードを取得します。

戻り値:
取扱コード
例外:
AccessorException - データの取得に失敗した場合

getItemCode

public String getItemCode()
                   throws AccessorException
商品コードを取得します。

戻り値:
商品コード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getUnitCode

public String getUnitCode()
                   throws AccessorException
単位コードを取得します。

戻り値:
単位コード
例外:
AccessorException - データの取得に失敗した場合

getUnitCode

public String getUnitCode(Date date)
                   throws AccessorException
単位コードを取得します。

パラメータ:
date - 日時
戻り値:
単位コード
例外:
AccessorException - データの取得に失敗した場合

setUnitCode

public void setUnitCode(String unitCode)
                 throws AccessorException
単位コードを設定します。

パラメータ:
unitCode - 単位コード
例外:
AccessorException - データの設定に失敗した場合

setUnitCode

public void setUnitCode(String unitCode,
                        Date date)
                 throws AccessorException
単位コードを設定します。

パラメータ:
unitCode - 単位コード
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getAmount

public int getAmount()
              throws AccessorException
数量を取得します。

戻り値:
数量
例外:
AccessorException - データの取得に失敗した場合

getAmount

public int getAmount(Date date)
              throws AccessorException
数量を取得します。

パラメータ:
date - 日時
戻り値:
数量
例外:
AccessorException - データの取得に失敗した場合

setAmount

public void setAmount(int amount)
               throws AccessorException
数量を設定します。

パラメータ:
amount - 数量
例外:
AccessorException - データの設定に失敗した場合

setAmount

public void setAmount(int amount,
                      Date date)
               throws AccessorException
数量を設定します。

パラメータ:
amount - 数量
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getUnitPrice

public double getUnitPrice()
                    throws AccessorException
単価を取得します。

戻り値:
単価
例外:
AccessorException - データの取得に失敗した場合

getUnitPrice

public double getUnitPrice(Date date)
                    throws AccessorException
単価を取得します。

パラメータ:
date - 日時
戻り値:
単価
例外:
AccessorException - データの取得に失敗した場合

setUnitPrice

public void setUnitPrice(double unitPrice)
                  throws AccessorException
単価を設定します。

パラメータ:
unitPrice - 単価
例外:
AccessorException - データの設定に失敗した場合

setUnitPrice

public void setUnitPrice(double unitPrice,
                         Date date)
                  throws AccessorException
単価を設定します。

パラメータ:
unitPrice - 単価
date - 日時
例外:
AccessorException - データの設定に失敗した場合

selectDealDetailTerminableModel

public DealDetailTerminableModel selectDealDetailTerminableModel(Date date)
                                                          throws IllegalTermException
指定された日付に該当する取扱詳細の期間化モデルを取得します。

パラメータ:
date - 指定日付
戻り値:
取扱詳細の期間化モデル
例外:
IllegalTermException - 指定された日付に該当する期間が定義されていない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DealDetailMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.deal.detail
インタフェース DealDetailMapper

すべてのスーパーインタフェース:
Mapper
public interface DealDetailMapper
extends Mapper

取扱詳細に関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
DealDetailBaseModel | create(String customerCompanyCode, String customerDepartmentCode, String dealCode, String itemCode) プライマリキーに該当する取扱詳細を生成します。
void | delete(Collection models) 取扱詳細の基本モデルを複数削除します。
void | delete(DealDetailBaseModel model) 取扱詳細の基本モデルを1つだけ削除します。
void | insert(Collection models) 取扱詳細の基本モデルを複数挿入します。
void | insert(DealDetailBaseModel model) 取扱詳細の基本モデルを1つだけ挿入します。
DealDetailBaseModel | select(String customerCompanyCode, String customerDepartmentCode, String dealCode, String itemCode) プライマリーキーで特定される取扱詳細の基本モデルを取得します。
void | update(Collection models) 取扱詳細の基本モデルを複数更新します。
void | update(DealDetailBaseModel model) 取扱詳細の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public DealDetailBaseModel create(String customerCompanyCode,
                                  String customerDepartmentCode,
                                  String dealCode,
                                  String itemCode)
                           throws MapperException
プライマリキーに該当する取扱詳細を生成します。

パラメータ:
customerCompanyCode - 取引先会社コード
customerDepartmentCode - 取引先組織コード
dealCode - 取扱コード
itemCode - 商品コード
戻り値:
プライマリキーに該当する取扱詳細の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public DealDetailBaseModel select(String customerCompanyCode,
                                  String customerDepartmentCode,
                                  String dealCode,
                                  String itemCode)
                           throws MapperException
プライマリーキーで特定される取扱詳細の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
customerCompanyCode - 取引先会社コード
customerDepartmentCode - 取引先組織コード
dealCode - 取扱コード
itemCode - 商品コード
戻り値:
取扱詳細の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(DealDetailBaseModel model)
            throws MapperException
取扱詳細の基本モデルを1つだけ挿入します。 引数に指定する取扱詳細の基本モデルは同一の DealDetailMapperの create(String,String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する取扱詳細の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
取扱詳細の基本モデルを複数挿入します。 引数に指定するものは同一の DealDetailMapperの create(String,String,String,String) で生成された取扱詳細の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する取扱詳細の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(DealDetailBaseModel model)
            throws MapperException
取扱詳細の基本モデルを1つだけ更新します。 引数に指定する取扱詳細の基本モデルは同一の DealDetailMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する取扱詳細の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
取扱詳細の基本モデルを複数更新します。 引数に指定するものは同一の DealDetailMapperの select 系メソッド から取得されたものかで生成された取扱詳細の基本モデルの集合である必要があります。

パラメータ:
models - 更新する取扱詳細の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(DealDetailBaseModel model)
            throws MapperException
取扱詳細の基本モデルを1つだけ削除します。 引数で指定された取扱詳細の基本モデルに該当するデータのすべての情報を削除します。引数に指定する取扱詳細の基本モデルは同一の DealDetailMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する取扱詳細の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
取扱詳細の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する取扱詳細の基本モデルは同一の DealDetailMapperの select 系メソッド から取得された取扱詳細の基本モデルの集合である必要があります。

パラメータ:
models - 削除する取扱詳細の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DealDetailTerminableModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.deal.detail
インタフェース DealDetailTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface DealDetailTerminableModel
extends TerminableModel

取扱詳細の期間化モデルです。

導入されたバージョン:
5.1

メソッドの概要
int | getAmount() 数量を取得します。
String | getUnitCode() 単位コードを取得します。
double | getUnitPrice() 単価を取得します。
void | setAmount(int amount) 数量を設定します。
void | setUnitCode(String unitCode) 単位コードを設定します。
void | setUnitPrice(double unitPrice) 単価を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

メソッドの詳細

getUnitCode

public String getUnitCode()
                   throws AccessorException
単位コードを取得します。

戻り値:
単位コード
例外:
AccessorException - データの取得に失敗した場合

setUnitCode

public void setUnitCode(String unitCode)
                 throws AccessorException
単位コードを設定します。

パラメータ:
unitCode - 単位コード
例外:
AccessorException - データの設定に失敗した場合

getAmount

public int getAmount()
              throws AccessorException
数量を取得します。

戻り値:
数量
例外:
AccessorException - データの取得に失敗した場合

setAmount

public void setAmount(int amount)
               throws AccessorException
数量を設定します。

パラメータ:
amount - 数量
例外:
AccessorException - データの設定に失敗した場合

getUnitPrice

public double getUnitPrice()
                    throws AccessorException
単価を取得します。

戻り値:
単価
例外:
AccessorException - データの取得に失敗した場合

setUnitPrice

public void setUnitPrice(double unitPrice)
                  throws AccessorException
単価を設定します。

パラメータ:
unitPrice - 単価
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.deal.detail (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.deal.detail
インタフェース
DealDetailBaseModel
DealDetailMapper
DealDetailTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.deal.detail (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.detail

取扱詳細情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
DealDetailBaseModel | 取扱詳細の基本モデルです。
DealDetailMapper | 取扱詳細に関連するマッパです。
DealDetailTerminableModel | 取扱詳細の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.detail の説明

取扱詳細情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.deal.detail クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.detail の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailTerminableModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.detail の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.detail の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.detail を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.detail 取扱詳細情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.deal.detail により使用される jp.co.intra_mart.foundation.datastore.application.model.deal.detail のクラス
DealDetailBaseModel
取扱詳細の基本モデルです。
DealDetailTerminableModel
取扱詳細の期間化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel の使用

DealerPublicGroupBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group 取扱パブリックグループ権限情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group での DealerPublicGroupBaseModel の使用

DealerPublicGroupBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.deal.public_group のメソッド
DealerPublicGroupBaseModel | DealerPublicGroupMapper.create(String customerCompanyCode, String customerDepartmentCode, String dealCode, String publicGroupSetCode, String publicGroupCode) プライマリキーに該当するパブリックグループ毎取扱パーミッションを生成します。
DealerPublicGroupBaseModel | DealerPublicGroupMapper.select(String customerCompanyCode, String customerDepartmentCode, String dealCode, String publicGroupSetCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループ毎取扱パーミッションの基本モデルを取得します。

DealerPublicGroupBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.deal.public_group のメソッド
void | DealerPublicGroupMapper.insert(DealerPublicGroupBaseModel model) パブリックグループ毎取扱パーミッションの基本モデルを1つだけ挿入します。
void | DealerPublicGroupMapper.update(DealerPublicGroupBaseModel model) パブリックグループ毎取扱パーミッションの基本モデルを1つだけ更新します。
void | DealerPublicGroupMapper.delete(DealerPublicGroupBaseModel model) パブリックグループ毎取扱パーミッションの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DealerPublicGroupBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group
インタフェース DealerPublicGroupBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface DealerPublicGroupBaseModel
extends BaseModel

パブリックグループ毎取扱パーミッションの基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | CUSTOMER_COMPANY_CODE 取引先会社コード
static String | CUSTOMER_DEPARTMENT_CODE 取引先組織コード
static String | DEAL_CODE 取扱コード
static String | PUBLIC_GROUP_CODE グループコード
static String | PUBLIC_GROUP_SET_CODE グループセットコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getCustomerCompanyCode() 取引先会社コードを取得します。
String | getCustomerDepartmentCode() 取引先組織コードを取得します。
String | getDealCode() 取扱コードを取得します。
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

CUSTOMER_COMPANY_CODE

public static final String CUSTOMER_COMPANY_CODE
取引先会社コード

関連項目:
定数フィールド値

CUSTOMER_DEPARTMENT_CODE

public static final String CUSTOMER_DEPARTMENT_CODE
取引先組織コード

関連項目:
定数フィールド値

DEAL_CODE

public static final String DEAL_CODE
取扱コード

関連項目:
定数フィールド値

PUBLIC_GROUP_SET_CODE

public static final String PUBLIC_GROUP_SET_CODE
グループセットコード

関連項目:
定数フィールド値

PUBLIC_GROUP_CODE

public static final String PUBLIC_GROUP_CODE
グループコード

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getCustomerCompanyCode

public String getCustomerCompanyCode()
                              throws AccessorException
取引先会社コードを取得します。

戻り値:
取引先会社コード
例外:
AccessorException - データの取得に失敗した場合

getCustomerDepartmentCode

public String getCustomerDepartmentCode()
                                 throws AccessorException
取引先組織コードを取得します。

戻り値:
取引先組織コード
例外:
AccessorException - データの取得に失敗した場合

getDealCode

public String getDealCode()
                   throws AccessorException
取扱コードを取得します。

戻り値:
取扱コード
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupSetCode

public String getPublicGroupSetCode()
                             throws AccessorException
グループセットコードを取得します。

戻り値:
グループセットコード
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupCode

public String getPublicGroupCode()
                          throws AccessorException
グループコードを取得します。

戻り値:
グループコード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DealerPublicGroupMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group
インタフェース DealerPublicGroupMapper

すべてのスーパーインタフェース:
Mapper
public interface DealerPublicGroupMapper
extends Mapper

パブリックグループ毎取扱パーミッションに関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
DealerPublicGroupBaseModel | create(String customerCompanyCode, String customerDepartmentCode, String dealCode, String publicGroupSetCode, String publicGroupCode) プライマリキーに該当するパブリックグループ毎取扱パーミッションを生成します。
void | delete(Collection models) パブリックグループ毎取扱パーミッションの基本モデルを複数削除します。
void | delete(DealerPublicGroupBaseModel model) パブリックグループ毎取扱パーミッションの基本モデルを1つだけ削除します。
void | insert(Collection models) パブリックグループ毎取扱パーミッションの基本モデルを複数挿入します。
void | insert(DealerPublicGroupBaseModel model) パブリックグループ毎取扱パーミッションの基本モデルを1つだけ挿入します。
DealerPublicGroupBaseModel | select(String customerCompanyCode, String customerDepartmentCode, String dealCode, String publicGroupSetCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループ毎取扱パーミッションの基本モデルを取得します。
void | update(Collection models) パブリックグループ毎取扱パーミッションの基本モデルを複数更新します。
void | update(DealerPublicGroupBaseModel model) パブリックグループ毎取扱パーミッションの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public DealerPublicGroupBaseModel create(String customerCompanyCode,
                                         String customerDepartmentCode,
                                         String dealCode,
                                         String publicGroupSetCode,
                                         String publicGroupCode)
                                  throws MapperException
プライマリキーに該当するパブリックグループ毎取扱パーミッションを生成します。

パラメータ:
customerCompanyCode - 取引先会社コード
customerDepartmentCode - 取引先組織コード
dealCode - 取扱コード
publicGroupSetCode - グループセットコード
publicGroupCode - グループコード
戻り値:
プライマリキーに該当するパブリックグループ毎取扱パーミッションの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public DealerPublicGroupBaseModel select(String customerCompanyCode,
                                         String customerDepartmentCode,
                                         String dealCode,
                                         String publicGroupSetCode,
                                         String publicGroupCode)
                                  throws MapperException
プライマリーキーで特定されるパブリックグループ毎取扱パーミッションの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
customerCompanyCode - 取引先会社コード
customerDepartmentCode - 取引先組織コード
dealCode - 取扱コード
publicGroupSetCode - グループセットコード
publicGroupCode - グループコード
戻り値:
パブリックグループ毎取扱パーミッションの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(DealerPublicGroupBaseModel model)
            throws MapperException
パブリックグループ毎取扱パーミッションの基本モデルを1つだけ挿入します。 引数に指定するパブリックグループ毎取扱パーミッションの基本モデルは同一の DealerPublicGroupMapperの create(String,String,String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するパブリックグループ毎取扱パーミッションの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
パブリックグループ毎取扱パーミッションの基本モデルを複数挿入します。 引数に指定するものは同一の DealerPublicGroupMapperの create(String,String,String,String,String) で生成されたパブリックグループ毎取扱パーミッションの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するパブリックグループ毎取扱パーミッションの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(DealerPublicGroupBaseModel model)
            throws MapperException
パブリックグループ毎取扱パーミッションの基本モデルを1つだけ更新します。 引数に指定するパブリックグループ毎取扱パーミッションの基本モデルは同一の DealerPublicGroupMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するパブリックグループ毎取扱パーミッションの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
パブリックグループ毎取扱パーミッションの基本モデルを複数更新します。 引数に指定するものは同一の DealerPublicGroupMapperの select 系メソッド から取得されたものかで生成されたパブリックグループ毎取扱パーミッションの基本モデルの集合である必要があります。

パラメータ:
models - 更新するパブリックグループ毎取扱パーミッションの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(DealerPublicGroupBaseModel model)
            throws MapperException
パブリックグループ毎取扱パーミッションの基本モデルを1つだけ削除します。 引数で指定されたパブリックグループ毎取扱パーミッションの基本モデルに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ毎取扱パーミッションの基本モデルは同一の DealerPublicGroupMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するパブリックグループ毎取扱パーミッションの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
パブリックグループ毎取扱パーミッションの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ毎取扱パーミッションの基本モデルは同一の DealerPublicGroupMapperの select 系メソッド から取得されたパブリックグループ毎取扱パーミッションの基本モデルの集合である必要があります。

パラメータ:
models - 削除するパブリックグループ毎取扱パーミッションの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.deal.public_group (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.deal.public_group
インタフェース
DealerPublicGroupBaseModel
DealerPublicGroupMapper


jp.co.intra_mart.foundation.datastore.application.model.deal.public_group (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.public_group

取扱パブリックグループ権限情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
DealerPublicGroupBaseModel | パブリックグループ毎取扱パーミッションの基本モデルです。
DealerPublicGroupMapper | パブリックグループ毎取扱パーミッションに関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.public_group の説明

取扱パブリックグループ権限情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.deal.public_group クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.public_group の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.public_group の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group 取扱パブリックグループ権限情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group により使用される jp.co.intra_mart.foundation.datastore.application.model.deal.public_group のクラス
DealerPublicGroupBaseModel
パブリックグループ毎取扱パーミッションの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel の使用

DealerRoleBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.role 取扱ロール権限情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.deal.role での DealerRoleBaseModel の使用

DealerRoleBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.deal.role のメソッド
DealerRoleBaseModel | DealerRoleMapper.create(String customerCompanyCode, String customerDepartmentCode, String dealCode, String roleId) プライマリキーに該当するロール毎取扱パーミッションを生成します。
DealerRoleBaseModel | DealerRoleMapper.select(String customerCompanyCode, String customerDepartmentCode, String dealCode, String roleId) プライマリーキーで特定されるロール毎取扱パーミッションの基本モデルを取得します。

DealerRoleBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.deal.role のメソッド
void | DealerRoleMapper.insert(DealerRoleBaseModel model) ロール毎取扱パーミッションの基本モデルを1つだけ挿入します。
void | DealerRoleMapper.update(DealerRoleBaseModel model) ロール毎取扱パーミッションの基本モデルを1つだけ更新します。
void | DealerRoleMapper.delete(DealerRoleBaseModel model) ロール毎取扱パーミッションの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DealerRoleBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.deal.role
インタフェース DealerRoleBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface DealerRoleBaseModel
extends BaseModel

ロール毎取扱パーミッションの基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | CUSTOMER_COMPANY_CODE 取引先会社コード
static String | CUSTOMER_DEPARTMENT_CODE 取引先組織コード
static String | DEAL_CODE 取扱コード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | ROLE_ID ロールID
メソッドの概要
String | getCustomerCompanyCode() 取引先会社コードを取得します。
String | getCustomerDepartmentCode() 取引先組織コードを取得します。
String | getDealCode() 取扱コードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getRoleId() ロールIDを取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

CUSTOMER_COMPANY_CODE

public static final String CUSTOMER_COMPANY_CODE
取引先会社コード

関連項目:
定数フィールド値

CUSTOMER_DEPARTMENT_CODE

public static final String CUSTOMER_DEPARTMENT_CODE
取引先組織コード

関連項目:
定数フィールド値

DEAL_CODE

public static final String DEAL_CODE
取扱コード

関連項目:
定数フィールド値

ROLE_ID

public static final String ROLE_ID
ロールID

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getCustomerCompanyCode

public String getCustomerCompanyCode()
                              throws AccessorException
取引先会社コードを取得します。

戻り値:
取引先会社コード
例外:
AccessorException - データの取得に失敗した場合

getCustomerDepartmentCode

public String getCustomerDepartmentCode()
                                 throws AccessorException
取引先組織コードを取得します。

戻り値:
取引先組織コード
例外:
AccessorException - データの取得に失敗した場合

getDealCode

public String getDealCode()
                   throws AccessorException
取扱コードを取得します。

戻り値:
取扱コード
例外:
AccessorException - データの取得に失敗した場合

getRoleId

public String getRoleId()
                 throws AccessorException
ロールIDを取得します。

戻り値:
ロールID
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DealerRoleMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.deal.role
インタフェース DealerRoleMapper

すべてのスーパーインタフェース:
Mapper
public interface DealerRoleMapper
extends Mapper

ロール毎取扱パーミッションに関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
DealerRoleBaseModel | create(String customerCompanyCode, String customerDepartmentCode, String dealCode, String roleId) プライマリキーに該当するロール毎取扱パーミッションを生成します。
void | delete(Collection models) ロール毎取扱パーミッションの基本モデルを複数削除します。
void | delete(DealerRoleBaseModel model) ロール毎取扱パーミッションの基本モデルを1つだけ削除します。
void | insert(Collection models) ロール毎取扱パーミッションの基本モデルを複数挿入します。
void | insert(DealerRoleBaseModel model) ロール毎取扱パーミッションの基本モデルを1つだけ挿入します。
DealerRoleBaseModel | select(String customerCompanyCode, String customerDepartmentCode, String dealCode, String roleId) プライマリーキーで特定されるロール毎取扱パーミッションの基本モデルを取得します。
void | update(Collection models) ロール毎取扱パーミッションの基本モデルを複数更新します。
void | update(DealerRoleBaseModel model) ロール毎取扱パーミッションの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public DealerRoleBaseModel create(String customerCompanyCode,
                                  String customerDepartmentCode,
                                  String dealCode,
                                  String roleId)
                           throws MapperException
プライマリキーに該当するロール毎取扱パーミッションを生成します。

パラメータ:
customerCompanyCode - 取引先会社コード
customerDepartmentCode - 取引先組織コード
dealCode - 取扱コード
roleId - ロールID
戻り値:
プライマリキーに該当するロール毎取扱パーミッションの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public DealerRoleBaseModel select(String customerCompanyCode,
                                  String customerDepartmentCode,
                                  String dealCode,
                                  String roleId)
                           throws MapperException
プライマリーキーで特定されるロール毎取扱パーミッションの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
customerCompanyCode - 取引先会社コード
customerDepartmentCode - 取引先組織コード
dealCode - 取扱コード
roleId - ロールID
戻り値:
ロール毎取扱パーミッションの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(DealerRoleBaseModel model)
            throws MapperException
ロール毎取扱パーミッションの基本モデルを1つだけ挿入します。 引数に指定するロール毎取扱パーミッションの基本モデルは同一の DealerRoleMapperの create(String,String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するロール毎取扱パーミッションの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
ロール毎取扱パーミッションの基本モデルを複数挿入します。 引数に指定するものは同一の DealerRoleMapperの create(String,String,String,String) で生成されたロール毎取扱パーミッションの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するロール毎取扱パーミッションの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(DealerRoleBaseModel model)
            throws MapperException
ロール毎取扱パーミッションの基本モデルを1つだけ更新します。 引数に指定するロール毎取扱パーミッションの基本モデルは同一の DealerRoleMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するロール毎取扱パーミッションの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
ロール毎取扱パーミッションの基本モデルを複数更新します。 引数に指定するものは同一の DealerRoleMapperの select 系メソッド から取得されたものかで生成されたロール毎取扱パーミッションの基本モデルの集合である必要があります。

パラメータ:
models - 更新するロール毎取扱パーミッションの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(DealerRoleBaseModel model)
            throws MapperException
ロール毎取扱パーミッションの基本モデルを1つだけ削除します。 引数で指定されたロール毎取扱パーミッションの基本モデルに該当するデータのすべての情報を削除します。引数に指定するロール毎取扱パーミッションの基本モデルは同一の DealerRoleMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するロール毎取扱パーミッションの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
ロール毎取扱パーミッションの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するロール毎取扱パーミッションの基本モデルは同一の DealerRoleMapperの select 系メソッド から取得されたロール毎取扱パーミッションの基本モデルの集合である必要があります。

パラメータ:
models - 削除するロール毎取扱パーミッションの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.deal.role (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.deal.role
インタフェース
DealerRoleBaseModel
DealerRoleMapper


jp.co.intra_mart.foundation.datastore.application.model.deal.role (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.role

取扱ロール権限情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
DealerRoleBaseModel | ロール毎取扱パーミッションの基本モデルです。
DealerRoleMapper | ロール毎取扱パーミッションに関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.role の説明

取扱ロール権限情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.deal.role クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.role の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.deal.role の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.role の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.role を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.deal.role 取扱ロール権限情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.deal.role により使用される jp.co.intra_mart.foundation.datastore.application.model.deal.role のクラス
DealerRoleBaseModel
ロール毎取扱パーミッションの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel の使用

ItemAttributeBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item.attribute 商品属性情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item.attribute での ItemAttributeBaseModel の使用

ItemAttributeBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.item.attribute のメソッド
ItemAttributeBaseModel | ItemAttributeMapper.create(String itemCode, String templateCode, String templateDetailCode) プライマリキーに該当する商品属性を生成します。
ItemAttributeBaseModel | ItemAttributeMapper.select(String itemCode, String templateCode, String templateDetailCode) プライマリーキーで特定される商品属性の基本モデルを取得します。

ItemAttributeBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.item.attribute のメソッド
void | ItemAttributeMapper.insert(ItemAttributeBaseModel model) 商品属性の基本モデルを1つだけ挿入します。
void | ItemAttributeMapper.update(ItemAttributeBaseModel model) 商品属性の基本モデルを1つだけ更新します。
void | ItemAttributeMapper.delete(ItemAttributeBaseModel model) 商品属性の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeInternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeInternationalModel の使用

ItemAttributeInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item.attribute 商品属性情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item.attribute での ItemAttributeInternationalModel の使用

ItemAttributeInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.item.attribute のメソッド
 ItemAttributeInternationalModel ItemAttributeBaseModel.selectItemAttributeInternationalModel(Locale locale)
指定された言語に該当する商品属性の国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemAttributeBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item.attribute
インタフェース ItemAttributeBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface ItemAttributeBaseModel
extends BaseModel

商品属性の基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | ITEM_CODE 商品コード
static String | NUMBER_VALUE 属性数値
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | STRING_VALUE 属性文字列
static String | TEMPLATE_CODE テンプレートコード
static String | TEMPLATE_DETAIL_CODE テンプレート明細コード
メソッドの概要
String | getItemCode() 商品コードを取得します。
double | getNumberValue() 属性数値を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getStringValue() 属性文字列を取得します。
String | getStringValue(Locale locale) 属性文字列を取得します。
String | getTemplateCode() テンプレートコードを取得します。
String | getTemplateDetailCode() テンプレート明細コードを取得します。
ItemAttributeInternationalModel | selectItemAttributeInternationalModel(Locale locale) 指定された言語に該当する商品属性の国際化モデルを取得します。
void | setNumberValue(double numberValue) 属性数値を設定します。
void | setStringValue(String stringValue) 属性文字列を設定します。
void | setStringValue(String stringValue, Locale locale) 属性文字列を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ITEM_CODE

public static final String ITEM_CODE
商品コード

関連項目:
定数フィールド値

TEMPLATE_CODE

public static final String TEMPLATE_CODE
テンプレートコード

関連項目:
定数フィールド値

TEMPLATE_DETAIL_CODE

public static final String TEMPLATE_DETAIL_CODE
テンプレート明細コード

関連項目:
定数フィールド値

NUMBER_VALUE

public static final String NUMBER_VALUE
属性数値

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

STRING_VALUE

public static final String STRING_VALUE
属性文字列

関連項目:
定数フィールド値
メソッドの詳細

getItemCode

public String getItemCode()
                   throws AccessorException
商品コードを取得します。

戻り値:
商品コード
例外:
AccessorException - データの取得に失敗した場合

getTemplateCode

public String getTemplateCode()
                       throws AccessorException
テンプレートコードを取得します。

戻り値:
テンプレートコード
例外:
AccessorException - データの取得に失敗した場合

getTemplateDetailCode

public String getTemplateDetailCode()
                             throws AccessorException
テンプレート明細コードを取得します。

戻り値:
テンプレート明細コード
例外:
AccessorException - データの取得に失敗した場合

getNumberValue

public double getNumberValue()
                      throws AccessorException
属性数値を取得します。

戻り値:
属性数値
例外:
AccessorException - データの取得に失敗した場合

setNumberValue

public void setNumberValue(double numberValue)
                    throws AccessorException
属性数値を設定します。

パラメータ:
numberValue - 属性数値
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getStringValue

public String getStringValue()
                      throws AccessorException
属性文字列を取得します。

戻り値:
属性文字列
例外:
AccessorException - データの取得に失敗した場合

getStringValue

public String getStringValue(Locale locale)
                      throws AccessorException
属性文字列を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
属性文字列
例外:
AccessorException - データの取得に失敗した場合

setStringValue

public void setStringValue(String stringValue)
                    throws AccessorException
属性文字列を設定します。

パラメータ:
stringValue - 属性文字列
例外:
AccessorException - データの設定に失敗した場合

setStringValue

public void setStringValue(String stringValue,
                           Locale locale)
                    throws AccessorException
属性文字列を設定します。

パラメータ:
stringValue - 属性文字列
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectItemAttributeInternationalModel

public ItemAttributeInternationalModel selectItemAttributeInternationalModel(Locale locale)
                                                                      throws IllegalLocaleException
指定された言語に該当する商品属性の国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
商品属性の国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemAttributeInternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item.attribute
インタフェース ItemAttributeInternationalModel

すべてのスーパーインタフェース:
InternationalModel, Serializable
public interface ItemAttributeInternationalModel
extends InternationalModel

商品属性の国際化モデルです。

導入されたバージョン:
5.1

メソッドの概要
String | getStringValue() 属性文字列を取得します。
void | setStringValue(String stringValue) 属性文字列を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModel から継承したメソッド
getExtendedInternationalModelMap, getLocale, init

メソッドの詳細

getStringValue

public String getStringValue()
                      throws AccessorException
属性文字列を取得します。

戻り値:
属性文字列
例外:
AccessorException - データの取得に失敗した場合

setStringValue

public void setStringValue(String stringValue)
                    throws AccessorException
属性文字列を設定します。

パラメータ:
stringValue - 属性文字列
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ItemAttributeMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item.attribute
インタフェース ItemAttributeMapper

すべてのスーパーインタフェース:
Mapper
public interface ItemAttributeMapper
extends Mapper

商品属性に関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
ItemAttributeBaseModel | create(String itemCode, String templateCode, String templateDetailCode) プライマリキーに該当する商品属性を生成します。
void | delete(Collection models) 商品属性の基本モデルを複数削除します。
void | delete(ItemAttributeBaseModel model) 商品属性の基本モデルを1つだけ削除します。
void | insert(Collection models) 商品属性の基本モデルを複数挿入します。
void | insert(ItemAttributeBaseModel model) 商品属性の基本モデルを1つだけ挿入します。
ItemAttributeBaseModel | select(String itemCode, String templateCode, String templateDetailCode) プライマリーキーで特定される商品属性の基本モデルを取得します。
void | update(Collection models) 商品属性の基本モデルを複数更新します。
void | update(ItemAttributeBaseModel model) 商品属性の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public ItemAttributeBaseModel create(String itemCode,
                                     String templateCode,
                                     String templateDetailCode)
                              throws MapperException
プライマリキーに該当する商品属性を生成します。

パラメータ:
itemCode - 商品コード
templateCode - テンプレートコード
templateDetailCode - テンプレート明細コード
戻り値:
プライマリキーに該当する商品属性の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public ItemAttributeBaseModel select(String itemCode,
                                     String templateCode,
                                     String templateDetailCode)
                              throws MapperException
プライマリーキーで特定される商品属性の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
itemCode - 商品コード
templateCode - テンプレートコード
templateDetailCode - テンプレート明細コード
戻り値:
商品属性の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(ItemAttributeBaseModel model)
            throws MapperException
商品属性の基本モデルを1つだけ挿入します。 引数に指定する商品属性の基本モデルは同一の ItemAttributeMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する商品属性の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
商品属性の基本モデルを複数挿入します。 引数に指定するものは同一の ItemAttributeMapperの create(String,String,String) で生成された商品属性の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する商品属性の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(ItemAttributeBaseModel model)
            throws MapperException
商品属性の基本モデルを1つだけ更新します。 引数に指定する商品属性の基本モデルは同一の ItemAttributeMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する商品属性の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
商品属性の基本モデルを複数更新します。 引数に指定するものは同一の ItemAttributeMapperの select 系メソッド から取得されたものかで生成された商品属性の基本モデルの集合である必要があります。

パラメータ:
models - 更新する商品属性の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(ItemAttributeBaseModel model)
            throws MapperException
商品属性の基本モデルを1つだけ削除します。 引数で指定された商品属性の基本モデルに該当するデータのすべての情報を削除します。引数に指定する商品属性の基本モデルは同一の ItemAttributeMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する商品属性の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
商品属性の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する商品属性の基本モデルは同一の ItemAttributeMapperの select 系メソッド から取得された商品属性の基本モデルの集合である必要があります。

パラメータ:
models - 削除する商品属性の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.item.attribute (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.item.attribute
インタフェース
ItemAttributeBaseModel
ItemAttributeInternationalModel
ItemAttributeMapper


jp.co.intra_mart.foundation.datastore.application.model.item.attribute (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item.attribute

商品属性情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
ItemAttributeBaseModel | 商品属性の基本モデルです。
ItemAttributeInternationalModel | 商品属性の国際化モデルです。
ItemAttributeMapper | 商品属性に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item.attribute の説明

商品属性情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.item.attribute クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item.attribute の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeInternationalModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.item.attribute の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.item.attribute の使用

jp.co.intra_mart.foundation.datastore.application.model.item.attribute を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item.attribute 商品属性情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item.attribute により使用される jp.co.intra_mart.foundation.datastore.application.model.item.attribute のクラス
ItemAttributeBaseModel
商品属性の基本モデルです。
ItemAttributeInternationalModel
商品属性の国際化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel の使用

ItemCatalogueBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue 商品カタログ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue での ItemCatalogueBaseModel の使用

ItemCatalogueBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.item.catalogue のメソッド
ItemCatalogueBaseModel | ItemCatalogueMapper.create(String itemCode, String itemCatalogueCode) プライマリキーに該当する商品カタログを生成します。
ItemCatalogueBaseModel | ItemCatalogueMapper.select(String itemCode, String itemCatalogueCode) プライマリーキーで特定される商品カタログの基本モデルを取得します。

ItemCatalogueBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.item.catalogue のメソッド
void | ItemCatalogueMapper.insert(ItemCatalogueBaseModel model) 商品カタログの基本モデルを1つだけ挿入します。
void | ItemCatalogueMapper.update(ItemCatalogueBaseModel model) 商品カタログの基本モデルを1つだけ更新します。
void | ItemCatalogueMapper.delete(ItemCatalogueBaseModel model) 商品カタログの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemCatalogueBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue
インタフェース ItemCatalogueBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface ItemCatalogueBaseModel
extends BaseModel

商品カタログの基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | ITEM_CATALOGUE_CODE 商品カタログコード
static String | ITEM_CODE 商品コード
static String | MEDIA 媒体
static String | MEDIA_CLS 媒体種類
static int | MEDIA_CLS_FILE 媒体種類がFileを表す定数
static int | MEDIA_CLS_URL 媒体種類がURLを表す定数
static String | NOTES 備考
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
メソッドの概要
String | getItemCatalogueCode() 商品カタログコードを取得します。
String | getItemCode() 商品コードを取得します。
String | getMedia() 媒体を取得します。
int | getMediaCls() 媒体種類を取得します。
String | getNotes() 備考を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
void | setMedia(String media) 媒体を設定します。
void | setMediaCls(int mediaCls) 媒体種類を設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ITEM_CODE

public static final String ITEM_CODE
商品コード

関連項目:
定数フィールド値

ITEM_CATALOGUE_CODE

public static final String ITEM_CATALOGUE_CODE
商品カタログコード

関連項目:
定数フィールド値

MEDIA_CLS

public static final String MEDIA_CLS
媒体種類

関連項目:
定数フィールド値

MEDIA

public static final String MEDIA
媒体

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

MEDIA_CLS_FILE

public static final int MEDIA_CLS_FILE
媒体種類がFileを表す定数

関連項目:
定数フィールド値

MEDIA_CLS_URL

public static final int MEDIA_CLS_URL
媒体種類がURLを表す定数

関連項目:
定数フィールド値
メソッドの詳細

getItemCode

public String getItemCode()
                   throws AccessorException
商品コードを取得します。

戻り値:
商品コード
例外:
AccessorException - データの取得に失敗した場合

getItemCatalogueCode

public String getItemCatalogueCode()
                            throws AccessorException
商品カタログコードを取得します。

戻り値:
商品カタログコード
例外:
AccessorException - データの取得に失敗した場合

getMediaCls

public int getMediaCls()
                throws AccessorException
媒体種類を取得します。

戻り値:
媒体種類
例外:
AccessorException - データの取得に失敗した場合

setMediaCls

public void setMediaCls(int mediaCls)
                 throws AccessorException
媒体種類を設定します。

パラメータ:
mediaCls - 媒体種類
例外:
AccessorException - データの設定に失敗した場合

getMedia

public String getMedia()
                throws AccessorException
媒体を取得します。

戻り値:
媒体
例外:
AccessorException - データの取得に失敗した場合

setMedia

public void setMedia(String media)
              throws AccessorException
媒体を設定します。

パラメータ:
media - 媒体
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemCatalogueMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue
インタフェース ItemCatalogueMapper

すべてのスーパーインタフェース:
Mapper
public interface ItemCatalogueMapper
extends Mapper

商品カタログに関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
ItemCatalogueBaseModel | create(String itemCode, String itemCatalogueCode) プライマリキーに該当する商品カタログを生成します。
void | delete(Collection models) 商品カタログの基本モデルを複数削除します。
void | delete(ItemCatalogueBaseModel model) 商品カタログの基本モデルを1つだけ削除します。
void | insert(Collection models) 商品カタログの基本モデルを複数挿入します。
void | insert(ItemCatalogueBaseModel model) 商品カタログの基本モデルを1つだけ挿入します。
ItemCatalogueBaseModel | select(String itemCode, String itemCatalogueCode) プライマリーキーで特定される商品カタログの基本モデルを取得します。
void | update(Collection models) 商品カタログの基本モデルを複数更新します。
void | update(ItemCatalogueBaseModel model) 商品カタログの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public ItemCatalogueBaseModel create(String itemCode,
                                     String itemCatalogueCode)
                              throws MapperException
プライマリキーに該当する商品カタログを生成します。

パラメータ:
itemCode - 商品コード
itemCatalogueCode - 商品カタログコード
戻り値:
プライマリキーに該当する商品カタログの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public ItemCatalogueBaseModel select(String itemCode,
                                     String itemCatalogueCode)
                              throws MapperException
プライマリーキーで特定される商品カタログの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
itemCode - 商品コード
itemCatalogueCode - 商品カタログコード
戻り値:
商品カタログの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(ItemCatalogueBaseModel model)
            throws MapperException
商品カタログの基本モデルを1つだけ挿入します。 引数に指定する商品カタログの基本モデルは同一の ItemCatalogueMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する商品カタログの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
商品カタログの基本モデルを複数挿入します。 引数に指定するものは同一の ItemCatalogueMapperの create(String,String) で生成された商品カタログの基本モデルの集合である必要があります。

パラメータ:
models - 挿入する商品カタログの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(ItemCatalogueBaseModel model)
            throws MapperException
商品カタログの基本モデルを1つだけ更新します。 引数に指定する商品カタログの基本モデルは同一の ItemCatalogueMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する商品カタログの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
商品カタログの基本モデルを複数更新します。 引数に指定するものは同一の ItemCatalogueMapperの select 系メソッド から取得されたものかで生成された商品カタログの基本モデルの集合である必要があります。

パラメータ:
models - 更新する商品カタログの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(ItemCatalogueBaseModel model)
            throws MapperException
商品カタログの基本モデルを1つだけ削除します。 引数で指定された商品カタログの基本モデルに該当するデータのすべての情報を削除します。引数に指定する商品カタログの基本モデルは同一の ItemCatalogueMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する商品カタログの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
商品カタログの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する商品カタログの基本モデルは同一の ItemCatalogueMapperの select 系メソッド から取得された商品カタログの基本モデルの集合である必要があります。

パラメータ:
models - 削除する商品カタログの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.item.catalogue (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.item.catalogue
インタフェース
ItemCatalogueBaseModel
ItemCatalogueMapper


jp.co.intra_mart.foundation.datastore.application.model.item.catalogue (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item.catalogue

商品カタログ情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
ItemCatalogueBaseModel | 商品カタログの基本モデルです。
ItemCatalogueMapper | 商品カタログに関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item.catalogue の説明

商品カタログ情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.item.catalogue クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item.catalogue の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.item.catalogue の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue の使用

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue 商品カタログ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue により使用される jp.co.intra_mart.foundation.datastore.application.model.item.catalogue のクラス
ItemCatalogueBaseModel
商品カタログの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel の使用

ItemBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item.item 商品情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item.item での ItemBaseModel の使用

ItemBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.item.item のメソッド
ItemBaseModel | ItemMapper.create(String itemCode) プライマリキーに該当する商品を生成します。
ItemBaseModel | ItemMapper.select(String itemCode) プライマリーキーで特定される商品の基本モデルを取得します。

ItemBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.item.item のメソッド
void | ItemMapper.insert(ItemBaseModel model) 商品の基本モデルを1つだけ挿入します。
void | ItemMapper.update(ItemBaseModel model) 商品の基本モデルを1つだけ更新します。
void | ItemMapper.delete(ItemBaseModel model) 商品の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableInternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableInternationalModel の使用

ItemTerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item.item 商品情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item.item での ItemTerminableInternationalModel の使用

ItemTerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.item.item のメソッド
 ItemTerminableInternationalModel ItemTerminableModel.selectItemTerminableInternationalModel(Locale locale)
指定された言語に該当する商品の期間国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel の使用

ItemTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item.item 商品情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item.item での ItemTerminableModel の使用

ItemTerminableModel を返す jp.co.intra_mart.foundation.datastore.application.model.item.item のメソッド
 ItemTerminableModel ItemBaseModel.selectItemTerminableModel(Date date)
指定された日付に該当する商品の期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item.item
インタフェース ItemBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface ItemBaseModel
extends BaseModel

商品の基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | ITEM_CAPTION 商品通称
static String | ITEM_CODE 商品コード
static String | ITEM_NAME 商品名
static String | NOTES 備考
static String | PRODUCT_MODEL_CODE 製品型番
static String | PURCHASE_UNIT_PRICE 仕入単価
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SALES_UNIT_PRICE 販売単価
メソッドの概要
String | getItemCaption() 商品通称を取得します。
String | getItemCaption(Date date) 商品通称を取得します。
String | getItemCaption(Date date, Locale locale) 商品通称を取得します。
String | getItemCaption(Locale locale) 商品通称を取得します。
String | getItemCode() 商品コードを取得します。
String | getItemName() 商品名を取得します。
String | getItemName(Date date) 商品名を取得します。
String | getItemName(Date date, Locale locale) 商品名を取得します。
String | getItemName(Locale locale) 商品名を取得します。
String | getNotes() 備考を取得します。
String | getProductModelCode() 製品型番を取得します。
double | getPurchaseUnitPrice() 仕入単価を取得します。
double | getPurchaseUnitPrice(Date date) 仕入単価を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
double | getSalesUnitPrice() 販売単価を取得します。
double | getSalesUnitPrice(Date date) 販売単価を取得します。
ItemTerminableModel | selectItemTerminableModel(Date date) 指定された日付に該当する商品の期間化モデルを取得します。
void | setItemCaption(String itemCaption) 商品通称を設定します。
void | setItemCaption(String itemCaption, Date date) 商品通称を設定します。
void | setItemCaption(String itemCaption, Date date, Locale locale) 商品通称を設定します。
void | setItemCaption(String itemCaption, Locale locale) 商品通称を設定します。
void | setItemName(String itemName) 商品名を設定します。
void | setItemName(String itemName, Date date) 商品名を設定します。
void | setItemName(String itemName, Date date, Locale locale) 商品名を設定します。
void | setItemName(String itemName, Locale locale) 商品名を設定します。
void | setNotes(String notes) 備考を設定します。
void | setProductModelCode(String productModelCode) 製品型番を設定します。
void | setPurchaseUnitPrice(double purchaseUnitPrice) 仕入単価を設定します。
void | setPurchaseUnitPrice(double purchaseUnitPrice, Date date) 仕入単価を設定します。
void | setSalesUnitPrice(double salesUnitPrice) 販売単価を設定します。
void | setSalesUnitPrice(double salesUnitPrice, Date date) 販売単価を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ITEM_CODE

public static final String ITEM_CODE
商品コード

関連項目:
定数フィールド値

PRODUCT_MODEL_CODE

public static final String PRODUCT_MODEL_CODE
製品型番

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

SALES_UNIT_PRICE

public static final String SALES_UNIT_PRICE
販売単価

関連項目:
定数フィールド値

PURCHASE_UNIT_PRICE

public static final String PURCHASE_UNIT_PRICE
仕入単価

関連項目:
定数フィールド値

ITEM_NAME

public static final String ITEM_NAME
商品名

関連項目:
定数フィールド値

ITEM_CAPTION

public static final String ITEM_CAPTION
商品通称

関連項目:
定数フィールド値
メソッドの詳細

getItemCode

public String getItemCode()
                   throws AccessorException
商品コードを取得します。

戻り値:
商品コード
例外:
AccessorException - データの取得に失敗した場合

getProductModelCode

public String getProductModelCode()
                           throws AccessorException
製品型番を取得します。

戻り値:
製品型番
例外:
AccessorException - データの取得に失敗した場合

setProductModelCode

public void setProductModelCode(String productModelCode)
                         throws AccessorException
製品型番を設定します。

パラメータ:
productModelCode - 製品型番
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getSalesUnitPrice

public double getSalesUnitPrice()
                         throws AccessorException
販売単価を取得します。

戻り値:
販売単価
例外:
AccessorException - データの取得に失敗した場合

getSalesUnitPrice

public double getSalesUnitPrice(Date date)
                         throws AccessorException
販売単価を取得します。

パラメータ:
date - 日時
戻り値:
販売単価
例外:
AccessorException - データの取得に失敗した場合

setSalesUnitPrice

public void setSalesUnitPrice(double salesUnitPrice)
                       throws AccessorException
販売単価を設定します。

パラメータ:
salesUnitPrice - 販売単価
例外:
AccessorException - データの設定に失敗した場合

setSalesUnitPrice

public void setSalesUnitPrice(double salesUnitPrice,
                              Date date)
                       throws AccessorException
販売単価を設定します。

パラメータ:
salesUnitPrice - 販売単価
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getPurchaseUnitPrice

public double getPurchaseUnitPrice()
                            throws AccessorException
仕入単価を取得します。

戻り値:
仕入単価
例外:
AccessorException - データの取得に失敗した場合

getPurchaseUnitPrice

public double getPurchaseUnitPrice(Date date)
                            throws AccessorException
仕入単価を取得します。

パラメータ:
date - 日時
戻り値:
仕入単価
例外:
AccessorException - データの取得に失敗した場合

setPurchaseUnitPrice

public void setPurchaseUnitPrice(double purchaseUnitPrice)
                          throws AccessorException
仕入単価を設定します。

パラメータ:
purchaseUnitPrice - 仕入単価
例外:
AccessorException - データの設定に失敗した場合

setPurchaseUnitPrice

public void setPurchaseUnitPrice(double purchaseUnitPrice,
                                 Date date)
                          throws AccessorException
仕入単価を設定します。

パラメータ:
purchaseUnitPrice - 仕入単価
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getItemName

public String getItemName()
                   throws AccessorException
商品名を取得します。

戻り値:
商品名
例外:
AccessorException - データの取得に失敗した場合

getItemName

public String getItemName(Date date)
                   throws AccessorException
商品名を取得します。

パラメータ:
date - 日時
戻り値:
商品名
例外:
AccessorException - データの取得に失敗した場合

getItemName

public String getItemName(Locale locale)
                   throws AccessorException
商品名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
商品名
例外:
AccessorException - データの取得に失敗した場合

getItemName

public String getItemName(Date date,
                          Locale locale)
                   throws AccessorException
商品名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
商品名
例外:
AccessorException - データの取得に失敗した場合

setItemName

public void setItemName(String itemName)
                 throws AccessorException
商品名を設定します。

パラメータ:
itemName - 商品名
例外:
AccessorException - データの設定に失敗した場合

setItemName

public void setItemName(String itemName,
                        Date date)
                 throws AccessorException
商品名を設定します。

パラメータ:
itemName - 商品名
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setItemName

public void setItemName(String itemName,
                        Locale locale)
                 throws AccessorException
商品名を設定します。

パラメータ:
itemName - 商品名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setItemName

public void setItemName(String itemName,
                        Date date,
                        Locale locale)
                 throws AccessorException
商品名を設定します。

パラメータ:
itemName - 商品名
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getItemCaption

public String getItemCaption()
                      throws AccessorException
商品通称を取得します。

戻り値:
商品通称
例外:
AccessorException - データの取得に失敗した場合

getItemCaption

public String getItemCaption(Date date)
                      throws AccessorException
商品通称を取得します。

パラメータ:
date - 日時
戻り値:
商品通称
例外:
AccessorException - データの取得に失敗した場合

getItemCaption

public String getItemCaption(Locale locale)
                      throws AccessorException
商品通称を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
商品通称
例外:
AccessorException - データの取得に失敗した場合

getItemCaption

public String getItemCaption(Date date,
                             Locale locale)
                      throws AccessorException
商品通称を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
商品通称
例外:
AccessorException - データの取得に失敗した場合

setItemCaption

public void setItemCaption(String itemCaption)
                    throws AccessorException
商品通称を設定します。

パラメータ:
itemCaption - 商品通称
例外:
AccessorException - データの設定に失敗した場合

setItemCaption

public void setItemCaption(String itemCaption,
                           Date date)
                    throws AccessorException
商品通称を設定します。

パラメータ:
itemCaption - 商品通称
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setItemCaption

public void setItemCaption(String itemCaption,
                           Locale locale)
                    throws AccessorException
商品通称を設定します。

パラメータ:
itemCaption - 商品通称
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setItemCaption

public void setItemCaption(String itemCaption,
                           Date date,
                           Locale locale)
                    throws AccessorException
商品通称を設定します。

パラメータ:
itemCaption - 商品通称
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectItemTerminableModel

public ItemTerminableModel selectItemTerminableModel(Date date)
                                              throws IllegalTermException
指定された日付に該当する商品の期間化モデルを取得します。

パラメータ:
date - 指定日付
戻り値:
商品の期間化モデル
例外:
IllegalTermException - 指定された日付に該当する期間が定義されていない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item.item
インタフェース ItemMapper

すべてのスーパーインタフェース:
Mapper
public interface ItemMapper
extends Mapper

商品に関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
ItemBaseModel | create(String itemCode) プライマリキーに該当する商品を生成します。
void | delete(Collection models) 商品の基本モデルを複数削除します。
void | delete(ItemBaseModel model) 商品の基本モデルを1つだけ削除します。
void | insert(Collection models) 商品の基本モデルを複数挿入します。
void | insert(ItemBaseModel model) 商品の基本モデルを1つだけ挿入します。
ItemBaseModel | select(String itemCode) プライマリーキーで特定される商品の基本モデルを取得します。
void | update(Collection models) 商品の基本モデルを複数更新します。
void | update(ItemBaseModel model) 商品の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public ItemBaseModel create(String itemCode)
                     throws MapperException
プライマリキーに該当する商品を生成します。

パラメータ:
itemCode - 商品コード
戻り値:
プライマリキーに該当する商品の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public ItemBaseModel select(String itemCode)
                     throws MapperException
プライマリーキーで特定される商品の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
itemCode - 商品コード
戻り値:
商品の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(ItemBaseModel model)
            throws MapperException
商品の基本モデルを1つだけ挿入します。 引数に指定する商品の基本モデルは同一の ItemMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入する商品の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
商品の基本モデルを複数挿入します。 引数に指定するものは同一の ItemMapperの create(String) で生成された商品の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する商品の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(ItemBaseModel model)
            throws MapperException
商品の基本モデルを1つだけ更新します。 引数に指定する商品の基本モデルは同一の ItemMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する商品の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
商品の基本モデルを複数更新します。 引数に指定するものは同一の ItemMapperの select 系メソッド から取得されたものかで生成された商品の基本モデルの集合である必要があります。

パラメータ:
models - 更新する商品の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(ItemBaseModel model)
            throws MapperException
商品の基本モデルを1つだけ削除します。 引数で指定された商品の基本モデルに該当するデータのすべての情報を削除します。引数に指定する商品の基本モデルは同一の ItemMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する商品の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
商品の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する商品の基本モデルは同一の ItemMapperの select 系メソッド から取得された商品の基本モデルの集合である必要があります。

パラメータ:
models - 削除する商品の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ItemTerminableInternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item.item
インタフェース ItemTerminableInternationalModel

すべてのスーパーインタフェース:
Serializable, TerminableInternationalModel
public interface ItemTerminableInternationalModel
extends TerminableInternationalModel

商品の期間国際化モデルです。

導入されたバージョン:
5.1

メソッドの概要
String | getItemCaption() 商品通称を取得します。
String | getItemName() 商品名を取得します。
void | setItemCaption(String itemCaption) 商品通称を設定します。
void | setItemName(String itemName) 商品名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel から継承したメソッド
getExtendedTerminableInternationalModelMap, getLocale, init

メソッドの詳細

getItemName

public String getItemName()
                   throws AccessorException
商品名を取得します。

戻り値:
商品名
例外:
AccessorException - データの取得に失敗した場合

setItemName

public void setItemName(String itemName)
                 throws AccessorException
商品名を設定します。

パラメータ:
itemName - 商品名
例外:
AccessorException - データの設定に失敗した場合

getItemCaption

public String getItemCaption()
                      throws AccessorException
商品通称を取得します。

戻り値:
商品通称
例外:
AccessorException - データの取得に失敗した場合

setItemCaption

public void setItemCaption(String itemCaption)
                    throws AccessorException
商品通称を設定します。

パラメータ:
itemCaption - 商品通称
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ItemTerminableModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item.item
インタフェース ItemTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface ItemTerminableModel
extends TerminableModel

商品の期間化モデルです。

導入されたバージョン:
5.1

メソッドの概要
String | getItemCaption() 商品通称を取得します。
String | getItemCaption(Locale locale) 商品通称を取得します。
String | getItemName() 商品名を取得します。
String | getItemName(Locale locale) 商品名を取得します。
double | getPurchaseUnitPrice() 仕入単価を取得します。
double | getSalesUnitPrice() 販売単価を取得します。
ItemTerminableInternationalModel | selectItemTerminableInternationalModel(Locale locale) 指定された言語に該当する商品の期間国際化モデルを取得します。
void | setItemCaption(String itemCaption) 商品通称を設定します。
void | setItemCaption(String itemCaption, Locale locale) 商品通称を設定します。
void | setItemName(String itemName) 商品名を設定します。
void | setItemName(String itemName, Locale locale) 商品名を設定します。
void | setPurchaseUnitPrice(double purchaseUnitPrice) 仕入単価を設定します。
void | setSalesUnitPrice(double salesUnitPrice) 販売単価を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

メソッドの詳細

getSalesUnitPrice

public double getSalesUnitPrice()
                         throws AccessorException
販売単価を取得します。

戻り値:
販売単価
例外:
AccessorException - データの取得に失敗した場合

setSalesUnitPrice

public void setSalesUnitPrice(double salesUnitPrice)
                       throws AccessorException
販売単価を設定します。

パラメータ:
salesUnitPrice - 販売単価
例外:
AccessorException - データの設定に失敗した場合

getPurchaseUnitPrice

public double getPurchaseUnitPrice()
                            throws AccessorException
仕入単価を取得します。

戻り値:
仕入単価
例外:
AccessorException - データの取得に失敗した場合

setPurchaseUnitPrice

public void setPurchaseUnitPrice(double purchaseUnitPrice)
                          throws AccessorException
仕入単価を設定します。

パラメータ:
purchaseUnitPrice - 仕入単価
例外:
AccessorException - データの設定に失敗した場合

getItemName

public String getItemName()
                   throws AccessorException
商品名を取得します。

戻り値:
商品名
例外:
AccessorException - データの取得に失敗した場合

getItemName

public String getItemName(Locale locale)
                   throws AccessorException
商品名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
商品名
例外:
AccessorException - データの取得に失敗した場合

setItemName

public void setItemName(String itemName)
                 throws AccessorException
商品名を設定します。

パラメータ:
itemName - 商品名
例外:
AccessorException - データの設定に失敗した場合

setItemName

public void setItemName(String itemName,
                        Locale locale)
                 throws AccessorException
商品名を設定します。

パラメータ:
itemName - 商品名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getItemCaption

public String getItemCaption()
                      throws AccessorException
商品通称を取得します。

戻り値:
商品通称
例外:
AccessorException - データの取得に失敗した場合

getItemCaption

public String getItemCaption(Locale locale)
                      throws AccessorException
商品通称を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
商品通称
例外:
AccessorException - データの取得に失敗した場合

setItemCaption

public void setItemCaption(String itemCaption)
                    throws AccessorException
商品通称を設定します。

パラメータ:
itemCaption - 商品通称
例外:
AccessorException - データの設定に失敗した場合

setItemCaption

public void setItemCaption(String itemCaption,
                           Locale locale)
                    throws AccessorException
商品通称を設定します。

パラメータ:
itemCaption - 商品通称
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectItemTerminableInternationalModel

public ItemTerminableInternationalModel selectItemTerminableInternationalModel(Locale locale)
                                                                        throws IllegalLocaleException
指定された言語に該当する商品の期間国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
商品の期間国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.item.item (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.item.item
インタフェース
ItemBaseModel
ItemMapper
ItemTerminableInternationalModel
ItemTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.item.item (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item.item

商品情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
ItemBaseModel | 商品の基本モデルです。
ItemMapper | 商品に関連するマッパです。
ItemTerminableInternationalModel | 商品の期間国際化モデルです。
ItemTerminableModel | 商品の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item.item の説明

商品情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.item.item クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item.item の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.item.item の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.item.item の使用

jp.co.intra_mart.foundation.datastore.application.model.item.item を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item.item 商品情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item.item により使用される jp.co.intra_mart.foundation.datastore.application.model.item.item のクラス
ItemBaseModel
商品の基本モデルです。
ItemTerminableInternationalModel
商品の期間国際化モデルです。
ItemTerminableModel
商品の期間化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel の使用

ItemAttachBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach 商品分類情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach での ItemAttachBaseModel の使用

ItemAttachBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.item_category.attach のメソッド
ItemAttachBaseModel | ItemAttachMapper.create(String itemCategoryTypeCode, String itemCategoryCode, String itemCode) プライマリキーに該当する商品分類を生成します。
ItemAttachBaseModel | ItemAttachMapper.select(String itemCategoryTypeCode, String itemCategoryCode, String itemCode) プライマリーキーで特定される商品分類の基本モデルを取得します。

ItemAttachBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.item_category.attach のメソッド
void | ItemAttachMapper.insert(ItemAttachBaseModel model) 商品分類の基本モデルを1つだけ挿入します。
void | ItemAttachMapper.update(ItemAttachBaseModel model) 商品分類の基本モデルを1つだけ更新します。
void | ItemAttachMapper.delete(ItemAttachBaseModel model) 商品分類の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemAttachBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach
インタフェース ItemAttachBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface ItemAttachBaseModel
extends BaseModel

商品分類の基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | ITEM_CATEGORY_CODE 商品カテゴリコード
static String | ITEM_CATEGORY_TYPE_CODE 商品カテゴリ種別コード
static String | ITEM_CODE 商品コード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CD 最終更新者
メソッドの概要
String | getItemCategoryCode() 商品カテゴリコードを取得します。
String | getItemCategoryTypeCode() 商品カテゴリ種別コードを取得します。
String | getItemCode() 商品コードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCd() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ITEM_CATEGORY_TYPE_CODE

public static final String ITEM_CATEGORY_TYPE_CODE
商品カテゴリ種別コード

関連項目:
定数フィールド値

ITEM_CATEGORY_CODE

public static final String ITEM_CATEGORY_CODE
商品カテゴリコード

関連項目:
定数フィールド値

ITEM_CODE

public static final String ITEM_CODE
商品コード

関連項目:
定数フィールド値

RECORD_USER_CD

public static final String RECORD_USER_CD
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getItemCategoryTypeCode

public String getItemCategoryTypeCode()
                               throws AccessorException
商品カテゴリ種別コードを取得します。

戻り値:
商品カテゴリ種別コード
例外:
AccessorException - データの取得に失敗した場合

getItemCategoryCode

public String getItemCategoryCode()
                           throws AccessorException
商品カテゴリコードを取得します。

戻り値:
商品カテゴリコード
例外:
AccessorException - データの取得に失敗した場合

getItemCode

public String getItemCode()
                   throws AccessorException
商品コードを取得します。

戻り値:
商品コード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCd

public String getRecordUserCd()
                       throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemAttachMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach
インタフェース ItemAttachMapper

すべてのスーパーインタフェース:
Mapper
public interface ItemAttachMapper
extends Mapper

商品分類に関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
ItemAttachBaseModel | create(String itemCategoryTypeCode, String itemCategoryCode, String itemCode) プライマリキーに該当する商品分類を生成します。
void | delete(Collection models) 商品分類の基本モデルを複数削除します。
void | delete(ItemAttachBaseModel model) 商品分類の基本モデルを1つだけ削除します。
void | insert(Collection models) 商品分類の基本モデルを複数挿入します。
void | insert(ItemAttachBaseModel model) 商品分類の基本モデルを1つだけ挿入します。
ItemAttachBaseModel | select(String itemCategoryTypeCode, String itemCategoryCode, String itemCode) プライマリーキーで特定される商品分類の基本モデルを取得します。
void | update(Collection models) 商品分類の基本モデルを複数更新します。
void | update(ItemAttachBaseModel model) 商品分類の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public ItemAttachBaseModel create(String itemCategoryTypeCode,
                                  String itemCategoryCode,
                                  String itemCode)
                           throws MapperException
プライマリキーに該当する商品分類を生成します。

パラメータ:
itemCategoryTypeCode - 商品カテゴリ種別コード
itemCategoryCode - 商品カテゴリコード
itemCode - 商品コード
戻り値:
プライマリキーに該当する商品分類の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public ItemAttachBaseModel select(String itemCategoryTypeCode,
                                  String itemCategoryCode,
                                  String itemCode)
                           throws MapperException
プライマリーキーで特定される商品分類の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
itemCategoryTypeCode - 商品カテゴリ種別コード
itemCategoryCode - 商品カテゴリコード
itemCode - 商品コード
戻り値:
商品分類の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(ItemAttachBaseModel model)
            throws MapperException
商品分類の基本モデルを1つだけ挿入します。 引数に指定する商品分類の基本モデルは同一の ItemAttachMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する商品分類の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
商品分類の基本モデルを複数挿入します。 引数に指定するものは同一の ItemAttachMapperの create(String,String,String) で生成された商品分類の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する商品分類の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(ItemAttachBaseModel model)
            throws MapperException
商品分類の基本モデルを1つだけ更新します。 引数に指定する商品分類の基本モデルは同一の ItemAttachMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する商品分類の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
商品分類の基本モデルを複数更新します。 引数に指定するものは同一の ItemAttachMapperの select 系メソッド から取得されたものかで生成された商品分類の基本モデルの集合である必要があります。

パラメータ:
models - 更新する商品分類の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(ItemAttachBaseModel model)
            throws MapperException
商品分類の基本モデルを1つだけ削除します。 引数で指定された商品分類の基本モデルに該当するデータのすべての情報を削除します。引数に指定する商品分類の基本モデルは同一の ItemAttachMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する商品分類の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
商品分類の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する商品分類の基本モデルは同一の ItemAttachMapperの select 系メソッド から取得された商品分類の基本モデルの集合である必要があります。

パラメータ:
models - 削除する商品分類の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.item_category.attach (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.item_category.attach
インタフェース
ItemAttachBaseModel
ItemAttachMapper


jp.co.intra_mart.foundation.datastore.application.model.item_category.attach (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_category.attach

商品分類情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
ItemAttachBaseModel | 商品分類の基本モデルです。
ItemAttachMapper | 商品分類に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_category.attach の説明

商品分類情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.item_category.attach クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_category.attach の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_category.attach の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach 商品分類情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach により使用される jp.co.intra_mart.foundation.datastore.application.model.item_category.attach のクラス
ItemAttachBaseModel
商品分類の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel の使用

ItemCategoryBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_category.category 商品カテゴリ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.category での ItemCategoryBaseModel の使用

ItemCategoryBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.item_category.category のメソッド
ItemCategoryBaseModel | ItemCategoryMapper.create(String itemCategoryTypeCode, String itemCategoryCode) プライマリキーに該当する商品カテゴリを生成します。
ItemCategoryBaseModel | ItemCategoryMapper.select(String itemCategoryTypeCode, String itemCategoryCode) プライマリーキーで特定される商品カテゴリの基本モデルを取得します。

ItemCategoryBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.item_category.category のメソッド
void | ItemCategoryMapper.insert(ItemCategoryBaseModel model) 商品カテゴリの基本モデルを1つだけ挿入します。
void | ItemCategoryMapper.update(ItemCategoryBaseModel model) 商品カテゴリの基本モデルを1つだけ更新します。
void | ItemCategoryMapper.delete(ItemCategoryBaseModel model) 商品カテゴリの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryInternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryInternationalModel の使用

ItemCategoryInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_category.category 商品カテゴリ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.category での ItemCategoryInternationalModel の使用

ItemCategoryInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.item_category.category のメソッド
 ItemCategoryInternationalModel ItemCategoryBaseModel.selectItemCategoryInternationalModel(Locale locale)
指定された言語に該当する商品カテゴリの国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemCategoryBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_category.category
インタフェース ItemCategoryBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface ItemCategoryBaseModel
extends BaseModel

商品カテゴリの基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | ITEM_CATEGORY_CODE 商品カテゴリコード
static String | ITEM_CATEGORY_NAME 商品カテゴリ名
static String | ITEM_CATEGORY_TYPE_CODE 商品カテゴリ種別コード
static String | NOTES 備考
static String | PARENT_ITEM_CATEGORY_CODE 親商品カテゴリコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
メソッドの概要
String | getItemCategoryCode() 商品カテゴリコードを取得します。
String | getItemCategoryName() 商品カテゴリ名を取得します。
String | getItemCategoryName(Locale locale) 商品カテゴリ名を取得します。
String | getItemCategoryTypeCode() 商品カテゴリ種別コードを取得します。
String | getNotes() 備考を取得します。
String | getParentItemCategoryCode() 親商品カテゴリコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
ItemCategoryInternationalModel | selectItemCategoryInternationalModel(Locale locale) 指定された言語に該当する商品カテゴリの国際化モデルを取得します。
void | setItemCategoryName(String itemCategoryName) 商品カテゴリ名を設定します。
void | setItemCategoryName(String itemCategoryName, Locale locale) 商品カテゴリ名を設定します。
void | setNotes(String notes) 備考を設定します。
void | setParentItemCategoryCode(String parentItemCategoryCode) 親商品カテゴリコードを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ITEM_CATEGORY_TYPE_CODE

public static final String ITEM_CATEGORY_TYPE_CODE
商品カテゴリ種別コード

関連項目:
定数フィールド値

ITEM_CATEGORY_CODE

public static final String ITEM_CATEGORY_CODE
商品カテゴリコード

関連項目:
定数フィールド値

PARENT_ITEM_CATEGORY_CODE

public static final String PARENT_ITEM_CATEGORY_CODE
親商品カテゴリコード

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

ITEM_CATEGORY_NAME

public static final String ITEM_CATEGORY_NAME
商品カテゴリ名

関連項目:
定数フィールド値
メソッドの詳細

getItemCategoryTypeCode

public String getItemCategoryTypeCode()
                               throws AccessorException
商品カテゴリ種別コードを取得します。

戻り値:
商品カテゴリ種別コード
例外:
AccessorException - データの取得に失敗した場合

getItemCategoryCode

public String getItemCategoryCode()
                           throws AccessorException
商品カテゴリコードを取得します。

戻り値:
商品カテゴリコード
例外:
AccessorException - データの取得に失敗した場合

getParentItemCategoryCode

public String getParentItemCategoryCode()
                                 throws AccessorException
親商品カテゴリコードを取得します。

戻り値:
親商品カテゴリコード
例外:
AccessorException - データの取得に失敗した場合

setParentItemCategoryCode

public void setParentItemCategoryCode(String parentItemCategoryCode)
                               throws AccessorException
親商品カテゴリコードを設定します。

パラメータ:
parentItemCategoryCode - 親商品カテゴリコード
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getItemCategoryName

public String getItemCategoryName()
                           throws AccessorException
商品カテゴリ名を取得します。

戻り値:
商品カテゴリ名
例外:
AccessorException - データの取得に失敗した場合

getItemCategoryName

public String getItemCategoryName(Locale locale)
                           throws AccessorException
商品カテゴリ名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
商品カテゴリ名
例外:
AccessorException - データの取得に失敗した場合

setItemCategoryName

public void setItemCategoryName(String itemCategoryName)
                         throws AccessorException
商品カテゴリ名を設定します。

パラメータ:
itemCategoryName - 商品カテゴリ名
例外:
AccessorException - データの設定に失敗した場合

setItemCategoryName

public void setItemCategoryName(String itemCategoryName,
                                Locale locale)
                         throws AccessorException
商品カテゴリ名を設定します。

パラメータ:
itemCategoryName - 商品カテゴリ名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectItemCategoryInternationalModel

public ItemCategoryInternationalModel selectItemCategoryInternationalModel(Locale locale)
                                                                    throws IllegalLocaleException
指定された言語に該当する商品カテゴリの国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
商品カテゴリの国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemCategoryInternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_category.category
インタフェース ItemCategoryInternationalModel

すべてのスーパーインタフェース:
InternationalModel, Serializable
public interface ItemCategoryInternationalModel
extends InternationalModel

商品カテゴリの国際化モデルです。

導入されたバージョン:
5.1

メソッドの概要
String | getItemCategoryName() 商品カテゴリ名を取得します。
void | setItemCategoryName(String itemCategoryName) 商品カテゴリ名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModel から継承したメソッド
getExtendedInternationalModelMap, getLocale, init

メソッドの詳細

getItemCategoryName

public String getItemCategoryName()
                           throws AccessorException
商品カテゴリ名を取得します。

戻り値:
商品カテゴリ名
例外:
AccessorException - データの取得に失敗した場合

setItemCategoryName

public void setItemCategoryName(String itemCategoryName)
                         throws AccessorException
商品カテゴリ名を設定します。

パラメータ:
itemCategoryName - 商品カテゴリ名
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ItemCategoryMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_category.category
インタフェース ItemCategoryMapper

すべてのスーパーインタフェース:
Mapper
public interface ItemCategoryMapper
extends Mapper

商品カテゴリに関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
ItemCategoryBaseModel | create(String itemCategoryTypeCode, String itemCategoryCode) プライマリキーに該当する商品カテゴリを生成します。
void | delete(Collection models) 商品カテゴリの基本モデルを複数削除します。
void | delete(ItemCategoryBaseModel model) 商品カテゴリの基本モデルを1つだけ削除します。
void | insert(Collection models) 商品カテゴリの基本モデルを複数挿入します。
void | insert(ItemCategoryBaseModel model) 商品カテゴリの基本モデルを1つだけ挿入します。
ItemCategoryBaseModel | select(String itemCategoryTypeCode, String itemCategoryCode) プライマリーキーで特定される商品カテゴリの基本モデルを取得します。
void | update(Collection models) 商品カテゴリの基本モデルを複数更新します。
void | update(ItemCategoryBaseModel model) 商品カテゴリの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public ItemCategoryBaseModel create(String itemCategoryTypeCode,
                                    String itemCategoryCode)
                             throws MapperException
プライマリキーに該当する商品カテゴリを生成します。

パラメータ:
itemCategoryTypeCode - 商品カテゴリ種別コード
itemCategoryCode - 商品カテゴリコード
戻り値:
プライマリキーに該当する商品カテゴリの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public ItemCategoryBaseModel select(String itemCategoryTypeCode,
                                    String itemCategoryCode)
                             throws MapperException
プライマリーキーで特定される商品カテゴリの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
itemCategoryTypeCode - 商品カテゴリ種別コード
itemCategoryCode - 商品カテゴリコード
戻り値:
商品カテゴリの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(ItemCategoryBaseModel model)
            throws MapperException
商品カテゴリの基本モデルを1つだけ挿入します。 引数に指定する商品カテゴリの基本モデルは同一の ItemCategoryMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する商品カテゴリの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
商品カテゴリの基本モデルを複数挿入します。 引数に指定するものは同一の ItemCategoryMapperの create(String,String) で生成された商品カテゴリの基本モデルの集合である必要があります。

パラメータ:
models - 挿入する商品カテゴリの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(ItemCategoryBaseModel model)
            throws MapperException
商品カテゴリの基本モデルを1つだけ更新します。 引数に指定する商品カテゴリの基本モデルは同一の ItemCategoryMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する商品カテゴリの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
商品カテゴリの基本モデルを複数更新します。 引数に指定するものは同一の ItemCategoryMapperの select 系メソッド から取得されたものかで生成された商品カテゴリの基本モデルの集合である必要があります。

パラメータ:
models - 更新する商品カテゴリの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(ItemCategoryBaseModel model)
            throws MapperException
商品カテゴリの基本モデルを1つだけ削除します。 引数で指定された商品カテゴリの基本モデルに該当するデータのすべての情報を削除します。引数に指定する商品カテゴリの基本モデルは同一の ItemCategoryMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する商品カテゴリの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
商品カテゴリの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する商品カテゴリの基本モデルは同一の ItemCategoryMapperの select 系メソッド から取得された商品カテゴリの基本モデルの集合である必要があります。

パラメータ:
models - 削除する商品カテゴリの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.item_category.category (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.item_category.category
インタフェース
ItemCategoryBaseModel
ItemCategoryInternationalModel
ItemCategoryMapper


jp.co.intra_mart.foundation.datastore.application.model.item_category.category (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_category.category

商品カテゴリ情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
ItemCategoryBaseModel | 商品カテゴリの基本モデルです。
ItemCategoryInternationalModel | 商品カテゴリの国際化モデルです。
ItemCategoryMapper | 商品カテゴリに関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_category.category の説明

商品カテゴリ情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.item_category.category クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_category.category の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryInternationalModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_category.category の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_category.category の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.category を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_category.category 商品カテゴリ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.category により使用される jp.co.intra_mart.foundation.datastore.application.model.item_category.category のクラス
ItemCategoryBaseModel
商品カテゴリの基本モデルです。
ItemCategoryInternationalModel
商品カテゴリの国際化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel の使用

ItemCategoryTypeBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_category.type 商品カテゴリ種別情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.type での ItemCategoryTypeBaseModel の使用

ItemCategoryTypeBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.item_category.type のメソッド
ItemCategoryTypeBaseModel | ItemCategoryTypeMapper.create(String itemCategoryTypeCode) プライマリキーに該当する商品カテゴリ種別を生成します。
ItemCategoryTypeBaseModel | ItemCategoryTypeMapper.select(String itemCategoryTypeCode) プライマリーキーで特定される商品カテゴリ種別の基本モデルを取得します。

ItemCategoryTypeBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.item_category.type のメソッド
void | ItemCategoryTypeMapper.insert(ItemCategoryTypeBaseModel model) 商品カテゴリ種別の基本モデルを1つだけ挿入します。
void | ItemCategoryTypeMapper.update(ItemCategoryTypeBaseModel model) 商品カテゴリ種別の基本モデルを1つだけ更新します。
void | ItemCategoryTypeMapper.delete(ItemCategoryTypeBaseModel model) 商品カテゴリ種別の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemCategoryTypeBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_category.type
インタフェース ItemCategoryTypeBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface ItemCategoryTypeBaseModel
extends BaseModel

商品カテゴリ種別の基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | ITEM_CATEGORY_TYPE_CODE 商品カテゴリ種別コード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getItemCategoryTypeCode() 商品カテゴリ種別コードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ITEM_CATEGORY_TYPE_CODE

public static final String ITEM_CATEGORY_TYPE_CODE
商品カテゴリ種別コード

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getItemCategoryTypeCode

public String getItemCategoryTypeCode()
                               throws AccessorException
商品カテゴリ種別コードを取得します。

戻り値:
商品カテゴリ種別コード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemCategoryTypeMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_category.type
インタフェース ItemCategoryTypeMapper

すべてのスーパーインタフェース:
Mapper
public interface ItemCategoryTypeMapper
extends Mapper

商品カテゴリ種別に関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
ItemCategoryTypeBaseModel | create(String itemCategoryTypeCode) プライマリキーに該当する商品カテゴリ種別を生成します。
void | delete(Collection models) 商品カテゴリ種別の基本モデルを複数削除します。
void | delete(ItemCategoryTypeBaseModel model) 商品カテゴリ種別の基本モデルを1つだけ削除します。
void | insert(Collection models) 商品カテゴリ種別の基本モデルを複数挿入します。
void | insert(ItemCategoryTypeBaseModel model) 商品カテゴリ種別の基本モデルを1つだけ挿入します。
ItemCategoryTypeBaseModel | select(String itemCategoryTypeCode) プライマリーキーで特定される商品カテゴリ種別の基本モデルを取得します。
void | update(Collection models) 商品カテゴリ種別の基本モデルを複数更新します。
void | update(ItemCategoryTypeBaseModel model) 商品カテゴリ種別の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public ItemCategoryTypeBaseModel create(String itemCategoryTypeCode)
                                 throws MapperException
プライマリキーに該当する商品カテゴリ種別を生成します。

パラメータ:
itemCategoryTypeCode - 商品カテゴリ種別コード
戻り値:
プライマリキーに該当する商品カテゴリ種別の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public ItemCategoryTypeBaseModel select(String itemCategoryTypeCode)
                                 throws MapperException
プライマリーキーで特定される商品カテゴリ種別の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
itemCategoryTypeCode - 商品カテゴリ種別コード
戻り値:
商品カテゴリ種別の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(ItemCategoryTypeBaseModel model)
            throws MapperException
商品カテゴリ種別の基本モデルを1つだけ挿入します。 引数に指定する商品カテゴリ種別の基本モデルは同一の ItemCategoryTypeMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入する商品カテゴリ種別の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
商品カテゴリ種別の基本モデルを複数挿入します。 引数に指定するものは同一の ItemCategoryTypeMapperの create(String) で生成された商品カテゴリ種別の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する商品カテゴリ種別の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(ItemCategoryTypeBaseModel model)
            throws MapperException
商品カテゴリ種別の基本モデルを1つだけ更新します。 引数に指定する商品カテゴリ種別の基本モデルは同一の ItemCategoryTypeMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する商品カテゴリ種別の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
商品カテゴリ種別の基本モデルを複数更新します。 引数に指定するものは同一の ItemCategoryTypeMapperの select 系メソッド から取得されたものかで生成された商品カテゴリ種別の基本モデルの集合である必要があります。

パラメータ:
models - 更新する商品カテゴリ種別の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(ItemCategoryTypeBaseModel model)
            throws MapperException
商品カテゴリ種別の基本モデルを1つだけ削除します。 引数で指定された商品カテゴリ種別の基本モデルに該当するデータのすべての情報を削除します。引数に指定する商品カテゴリ種別の基本モデルは同一の ItemCategoryTypeMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する商品カテゴリ種別の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
商品カテゴリ種別の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する商品カテゴリ種別の基本モデルは同一の ItemCategoryTypeMapperの select 系メソッド から取得された商品カテゴリ種別の基本モデルの集合である必要があります。

パラメータ:
models - 削除する商品カテゴリ種別の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.item_category.type (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.item_category.type
インタフェース
ItemCategoryTypeBaseModel
ItemCategoryTypeMapper


jp.co.intra_mart.foundation.datastore.application.model.item_category.type (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_category.type

商品カテゴリ種別情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
ItemCategoryTypeBaseModel | 商品カテゴリ種別の基本モデルです。
ItemCategoryTypeMapper | 商品カテゴリ種別に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_category.type の説明

商品カテゴリ種別情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.item_category.type クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_category.type の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_category.type の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_category.type の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.type を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_category.type 商品カテゴリ種別情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.type により使用される jp.co.intra_mart.foundation.datastore.application.model.item_category.type のクラス
ItemCategoryTypeBaseModel
商品カテゴリ種別の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel の使用

ItemTemplateDetailBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail 商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail での ItemTemplateDetailBaseModel の使用

ItemTemplateDetailBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.item_template.detail のメソッド
ItemTemplateDetailBaseModel | ItemTemplateDetailMapper.create(String templateCode, String templateDetailCode) プライマリキーに該当する商品属性テンプレート明細を生成します。
ItemTemplateDetailBaseModel | ItemTemplateDetailMapper.select(String templateCode, String templateDetailCode) プライマリーキーで特定される商品属性テンプレート明細の基本モデルを取得します。

ItemTemplateDetailBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.item_template.detail のメソッド
void | ItemTemplateDetailMapper.insert(ItemTemplateDetailBaseModel model) 商品属性テンプレート明細の基本モデルを1つだけ挿入します。
void | ItemTemplateDetailMapper.update(ItemTemplateDetailBaseModel model) 商品属性テンプレート明細の基本モデルを1つだけ更新します。
void | ItemTemplateDetailMapper.delete(ItemTemplateDetailBaseModel model) 商品属性テンプレート明細の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailInternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailInternationalModel の使用

ItemTemplateDetailInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail 商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail での ItemTemplateDetailInternationalModel の使用

ItemTemplateDetailInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.item_template.detail のメソッド
 ItemTemplateDetailInternationalModel ItemTemplateDetailBaseModel.selectItemTemplateDetailInternationalModel(Locale locale)
指定された言語に該当する商品属性テンプレート明細の国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemTemplateDetailBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail
インタフェース ItemTemplateDetailBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface ItemTemplateDetailBaseModel
extends BaseModel

商品属性テンプレート明細の基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | DATA_TYPE データ型
static int | DATA_TYPE_NUMBER データ型が数値を表す定数
static int | DATA_TYPE_STRING データ型が文字列型を表す定数
static String | NOTES 備考
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CD 最終更新者
static String | SORT_KEY ソートキー
static String | TEMPLATE_CODE テンプレートコード
static String | TEMPLATE_DETAIL_CODE テンプレート明細コード
static String | TEMPLATE_DETAIL_NAME テンプレート明細名
メソッドの概要
int | getDataType() データ型を取得します。
String | getNotes() 備考を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCd() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
String | getTemplateCode() テンプレートコードを取得します。
String | getTemplateDetailCode() テンプレート明細コードを取得します。
String | getTemplateDetailName() テンプレート明細名を取得します。
String | getTemplateDetailName(Locale locale) テンプレート明細名を取得します。
ItemTemplateDetailInternationalModel | selectItemTemplateDetailInternationalModel(Locale locale) 指定された言語に該当する商品属性テンプレート明細の国際化モデルを取得します。
void | setDataType(int dataType) データ型を設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
void | setTemplateDetailName(String templateDetailName) テンプレート明細名を設定します。
void | setTemplateDetailName(String templateDetailName, Locale locale) テンプレート明細名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

TEMPLATE_CODE

public static final String TEMPLATE_CODE
テンプレートコード

関連項目:
定数フィールド値

TEMPLATE_DETAIL_CODE

public static final String TEMPLATE_DETAIL_CODE
テンプレート明細コード

関連項目:
定数フィールド値

DATA_TYPE

public static final String DATA_TYPE
データ型

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

RECORD_USER_CD

public static final String RECORD_USER_CD
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

TEMPLATE_DETAIL_NAME

public static final String TEMPLATE_DETAIL_NAME
テンプレート明細名

関連項目:
定数フィールド値

DATA_TYPE_NUMBER

public static final int DATA_TYPE_NUMBER
データ型が数値を表す定数

関連項目:
定数フィールド値

DATA_TYPE_STRING

public static final int DATA_TYPE_STRING
データ型が文字列型を表す定数

関連項目:
定数フィールド値
メソッドの詳細

getTemplateCode

public String getTemplateCode()
                       throws AccessorException
テンプレートコードを取得します。

戻り値:
テンプレートコード
例外:
AccessorException - データの取得に失敗した場合

getTemplateDetailCode

public String getTemplateDetailCode()
                             throws AccessorException
テンプレート明細コードを取得します。

戻り値:
テンプレート明細コード
例外:
AccessorException - データの取得に失敗した場合

getDataType

public int getDataType()
                throws AccessorException
データ型を取得します。

戻り値:
データ型
例外:
AccessorException - データの取得に失敗した場合

setDataType

public void setDataType(int dataType)
                 throws AccessorException
データ型を設定します。

パラメータ:
dataType - データ型
例外:
AccessorException - データの設定に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCd

public String getRecordUserCd()
                       throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getTemplateDetailName

public String getTemplateDetailName()
                             throws AccessorException
テンプレート明細名を取得します。

戻り値:
テンプレート明細名
例外:
AccessorException - データの取得に失敗した場合

getTemplateDetailName

public String getTemplateDetailName(Locale locale)
                             throws AccessorException
テンプレート明細名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
テンプレート明細名
例外:
AccessorException - データの取得に失敗した場合

setTemplateDetailName

public void setTemplateDetailName(String templateDetailName)
                           throws AccessorException
テンプレート明細名を設定します。

パラメータ:
templateDetailName - テンプレート明細名
例外:
AccessorException - データの設定に失敗した場合

setTemplateDetailName

public void setTemplateDetailName(String templateDetailName,
                                  Locale locale)
                           throws AccessorException
テンプレート明細名を設定します。

パラメータ:
templateDetailName - テンプレート明細名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectItemTemplateDetailInternationalModel

public ItemTemplateDetailInternationalModel selectItemTemplateDetailInternationalModel(Locale locale)
                                                                                throws IllegalLocaleException
指定された言語に該当する商品属性テンプレート明細の国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
商品属性テンプレート明細の国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemTemplateDetailInternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail
インタフェース ItemTemplateDetailInternationalModel

すべてのスーパーインタフェース:
InternationalModel, Serializable
public interface ItemTemplateDetailInternationalModel
extends InternationalModel

商品属性テンプレート明細の国際化モデルです。

導入されたバージョン:
5.1

メソッドの概要
String | getTemplateDetailName() テンプレート明細名を取得します。
void | setTemplateDetailName(String templateDetailName) テンプレート明細名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModel から継承したメソッド
getExtendedInternationalModelMap, getLocale, init

メソッドの詳細

getTemplateDetailName

public String getTemplateDetailName()
                             throws AccessorException
テンプレート明細名を取得します。

戻り値:
テンプレート明細名
例外:
AccessorException - データの取得に失敗した場合

setTemplateDetailName

public void setTemplateDetailName(String templateDetailName)
                           throws AccessorException
テンプレート明細名を設定します。

パラメータ:
templateDetailName - テンプレート明細名
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ItemTemplateDetailMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail
インタフェース ItemTemplateDetailMapper

すべてのスーパーインタフェース:
Mapper
public interface ItemTemplateDetailMapper
extends Mapper

商品属性テンプレート明細に関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
ItemTemplateDetailBaseModel | create(String templateCode, String templateDetailCode) プライマリキーに該当する商品属性テンプレート明細を生成します。
void | delete(Collection models) 商品属性テンプレート明細の基本モデルを複数削除します。
void | delete(ItemTemplateDetailBaseModel model) 商品属性テンプレート明細の基本モデルを1つだけ削除します。
void | insert(Collection models) 商品属性テンプレート明細の基本モデルを複数挿入します。
void | insert(ItemTemplateDetailBaseModel model) 商品属性テンプレート明細の基本モデルを1つだけ挿入します。
ItemTemplateDetailBaseModel | select(String templateCode, String templateDetailCode) プライマリーキーで特定される商品属性テンプレート明細の基本モデルを取得します。
void | update(Collection models) 商品属性テンプレート明細の基本モデルを複数更新します。
void | update(ItemTemplateDetailBaseModel model) 商品属性テンプレート明細の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public ItemTemplateDetailBaseModel create(String templateCode,
                                          String templateDetailCode)
                                   throws MapperException
プライマリキーに該当する商品属性テンプレート明細を生成します。

パラメータ:
templateCode - テンプレートコード
templateDetailCode - テンプレート明細コード
戻り値:
プライマリキーに該当する商品属性テンプレート明細の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public ItemTemplateDetailBaseModel select(String templateCode,
                                          String templateDetailCode)
                                   throws MapperException
プライマリーキーで特定される商品属性テンプレート明細の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
templateCode - テンプレートコード
templateDetailCode - テンプレート明細コード
戻り値:
商品属性テンプレート明細の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(ItemTemplateDetailBaseModel model)
            throws MapperException
商品属性テンプレート明細の基本モデルを1つだけ挿入します。 引数に指定する商品属性テンプレート明細の基本モデルは同一の ItemTemplateDetailMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する商品属性テンプレート明細の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
商品属性テンプレート明細の基本モデルを複数挿入します。 引数に指定するものは同一の ItemTemplateDetailMapperの create(String,String) で生成された商品属性テンプレート明細の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する商品属性テンプレート明細の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(ItemTemplateDetailBaseModel model)
            throws MapperException
商品属性テンプレート明細の基本モデルを1つだけ更新します。 引数に指定する商品属性テンプレート明細の基本モデルは同一の ItemTemplateDetailMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する商品属性テンプレート明細の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
商品属性テンプレート明細の基本モデルを複数更新します。 引数に指定するものは同一の ItemTemplateDetailMapperの select 系メソッド から取得されたものかで生成された商品属性テンプレート明細の基本モデルの集合である必要があります。

パラメータ:
models - 更新する商品属性テンプレート明細の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(ItemTemplateDetailBaseModel model)
            throws MapperException
商品属性テンプレート明細の基本モデルを1つだけ削除します。 引数で指定された商品属性テンプレート明細の基本モデルに該当するデータのすべての情報を削除します。引数に指定する商品属性テンプレート明細の基本モデルは同一の ItemTemplateDetailMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する商品属性テンプレート明細の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
商品属性テンプレート明細の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する商品属性テンプレート明細の基本モデルは同一の ItemTemplateDetailMapperの select 系メソッド から取得された商品属性テンプレート明細の基本モデルの集合である必要があります。

パラメータ:
models - 削除する商品属性テンプレート明細の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.item_template.detail (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.item_template.detail
インタフェース
ItemTemplateDetailBaseModel
ItemTemplateDetailInternationalModel
ItemTemplateDetailMapper


jp.co.intra_mart.foundation.datastore.application.model.item_template.detail (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_template.detail

商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
ItemTemplateDetailBaseModel | 商品属性テンプレート明細の基本モデルです。
ItemTemplateDetailInternationalModel | 商品属性テンプレート明細の国際化モデルです。
ItemTemplateDetailMapper | 商品属性テンプレート明細に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_template.detail の説明

商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.item_template.detail クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_template.detail の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailInternationalModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_template.detail の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail の使用

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail 商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail により使用される jp.co.intra_mart.foundation.datastore.application.model.item_template.detail のクラス
ItemTemplateDetailBaseModel
商品属性テンプレート明細の基本モデルです。
ItemTemplateDetailInternationalModel
商品属性テンプレート明細の国際化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel の使用

ItemTemplateBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_template.template 商品テンプレート情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item_template.template での ItemTemplateBaseModel の使用

ItemTemplateBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.item_template.template のメソッド
ItemTemplateBaseModel | ItemTemplateMapper.create(String templateCode) プライマリキーに該当する商品属性テンプレートを生成します。
ItemTemplateBaseModel | ItemTemplateMapper.select(String templateCode) プライマリーキーで特定される商品属性テンプレートの基本モデルを取得します。

ItemTemplateBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.item_template.template のメソッド
void | ItemTemplateMapper.insert(ItemTemplateBaseModel model) 商品属性テンプレートの基本モデルを1つだけ挿入します。
void | ItemTemplateMapper.update(ItemTemplateBaseModel model) 商品属性テンプレートの基本モデルを1つだけ更新します。
void | ItemTemplateMapper.delete(ItemTemplateBaseModel model) 商品属性テンプレートの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateInternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateInternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateInternationalModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ItemTemplateBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_template.template
インタフェース ItemTemplateBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface ItemTemplateBaseModel
extends BaseModel

商品属性テンプレートの基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | NOTES 備考
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CD 最終更新者
static String | TEMPLATE_CODE テンプレートコード
static String | TEMPLATE_NAME テンプレート名
メソッドの概要
String | getNotes() 備考を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCd() 最終更新者を取得します。
String | getTemplateCode() テンプレートコードを取得します。
String | getTemplateName() テンプレート名を取得します。
void | setNotes(String notes) 備考を設定します。
void | setTemplateName(String templateName) テンプレート名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

TEMPLATE_CODE

public static final String TEMPLATE_CODE
テンプレートコード

関連項目:
定数フィールド値

TEMPLATE_NAME

public static final String TEMPLATE_NAME
テンプレート名

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

RECORD_USER_CD

public static final String RECORD_USER_CD
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getTemplateCode

public String getTemplateCode()
                       throws AccessorException
テンプレートコードを取得します。

戻り値:
テンプレートコード
例外:
AccessorException - データの取得に失敗した場合

getTemplateName

public String getTemplateName()
                       throws AccessorException
テンプレート名を取得します。

戻り値:
テンプレート名
例外:
AccessorException - データの取得に失敗した場合

setTemplateName

public void setTemplateName(String templateName)
                     throws AccessorException
テンプレート名を設定します。

パラメータ:
templateName - テンプレート名
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCd

public String getRecordUserCd()
                       throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ItemTemplateInternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_template.template
インタフェース ItemTemplateInternationalModel

すべてのスーパーインタフェース:
InternationalModel, Serializable
public interface ItemTemplateInternationalModel
extends InternationalModel

商品属性テンプレートの国際化モデルです。

導入されたバージョン:
5.1

メソッドの概要
String | getTemplateName() テンプレート名を取得します。
void | setTemplateName(String templateName) テンプレート名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModel から継承したメソッド
getExtendedInternationalModelMap, getLocale, init

メソッドの詳細

getTemplateName

public String getTemplateName()
                       throws AccessorException
テンプレート名を取得します。

戻り値:
テンプレート名
例外:
AccessorException - データの取得に失敗した場合

setTemplateName

public void setTemplateName(String templateName)
                     throws AccessorException
テンプレート名を設定します。

パラメータ:
templateName - テンプレート名
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ItemTemplateMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.item_template.template
インタフェース ItemTemplateMapper

すべてのスーパーインタフェース:
Mapper
public interface ItemTemplateMapper
extends Mapper

商品属性テンプレートに関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
ItemTemplateBaseModel | create(String templateCode) プライマリキーに該当する商品属性テンプレートを生成します。
void | delete(Collection models) 商品属性テンプレートの基本モデルを複数削除します。
void | delete(ItemTemplateBaseModel model) 商品属性テンプレートの基本モデルを1つだけ削除します。
void | insert(Collection models) 商品属性テンプレートの基本モデルを複数挿入します。
void | insert(ItemTemplateBaseModel model) 商品属性テンプレートの基本モデルを1つだけ挿入します。
ItemTemplateBaseModel | select(String templateCode) プライマリーキーで特定される商品属性テンプレートの基本モデルを取得します。
void | update(Collection models) 商品属性テンプレートの基本モデルを複数更新します。
void | update(ItemTemplateBaseModel model) 商品属性テンプレートの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public ItemTemplateBaseModel create(String templateCode)
                             throws MapperException
プライマリキーに該当する商品属性テンプレートを生成します。

パラメータ:
templateCode - テンプレートコード
戻り値:
プライマリキーに該当する商品属性テンプレートの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public ItemTemplateBaseModel select(String templateCode)
                             throws MapperException
プライマリーキーで特定される商品属性テンプレートの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
templateCode - テンプレートコード
戻り値:
商品属性テンプレートの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(ItemTemplateBaseModel model)
            throws MapperException
商品属性テンプレートの基本モデルを1つだけ挿入します。 引数に指定する商品属性テンプレートの基本モデルは同一の ItemTemplateMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入する商品属性テンプレートの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
商品属性テンプレートの基本モデルを複数挿入します。 引数に指定するものは同一の ItemTemplateMapperの create(String) で生成された商品属性テンプレートの基本モデルの集合である必要があります。

パラメータ:
models - 挿入する商品属性テンプレートの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(ItemTemplateBaseModel model)
            throws MapperException
商品属性テンプレートの基本モデルを1つだけ更新します。 引数に指定する商品属性テンプレートの基本モデルは同一の ItemTemplateMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する商品属性テンプレートの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
商品属性テンプレートの基本モデルを複数更新します。 引数に指定するものは同一の ItemTemplateMapperの select 系メソッド から取得されたものかで生成された商品属性テンプレートの基本モデルの集合である必要があります。

パラメータ:
models - 更新する商品属性テンプレートの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(ItemTemplateBaseModel model)
            throws MapperException
商品属性テンプレートの基本モデルを1つだけ削除します。 引数で指定された商品属性テンプレートの基本モデルに該当するデータのすべての情報を削除します。引数に指定する商品属性テンプレートの基本モデルは同一の ItemTemplateMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する商品属性テンプレートの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
商品属性テンプレートの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する商品属性テンプレートの基本モデルは同一の ItemTemplateMapperの select 系メソッド から取得された商品属性テンプレートの基本モデルの集合である必要があります。

パラメータ:
models - 削除する商品属性テンプレートの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.item_template.template (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.item_template.template
インタフェース
ItemTemplateBaseModel
ItemTemplateInternationalModel
ItemTemplateMapper


jp.co.intra_mart.foundation.datastore.application.model.item_template.template (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_template.template

商品テンプレート情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
ItemTemplateBaseModel | 商品属性テンプレートの基本モデルです。
ItemTemplateInternationalModel | 商品属性テンプレートの国際化モデルです。
ItemTemplateMapper | 商品属性テンプレートに関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_template.template の説明

商品テンプレート情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.item_template.template クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_template.template の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateInternationalModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.item_template.template の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_template.template の使用

jp.co.intra_mart.foundation.datastore.application.model.item_template.template を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.item_template.template 商品テンプレート情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.item_template.template により使用される jp.co.intra_mart.foundation.datastore.application.model.item_template.template のクラス
ItemTemplateBaseModel
商品属性テンプレートの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の使用

PrivateGroupAttachBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach プライベートグループ所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach での PrivateGroupAttachBaseModel の使用

PrivateGroupAttachBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.private_group.attach のメソッド
PrivateGroupAttachBaseModel | PrivateGroupAttachMapper.create(String ownerCode, String privateGroupCode, String userCode) プライマリキーに該当するプライベートグループ所属を生成します。
PrivateGroupAttachBaseModel | PrivateGroupAttachMapper.select(String ownerCode, String privateGroupCode, String userCode) プライマリーキーで特定されるプライベートグループ所属の基本モデルを取得します。

PrivateGroupAttachBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.private_group.attach のメソッド
void | PrivateGroupAttachMapper.insert(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ挿入します。
void | PrivateGroupAttachMapper.update(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ更新します。
void | PrivateGroupAttachMapper.delete(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.private_group.attach (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.private_group.attach
インタフェース
PrivateGroupAttachBaseModel
PrivateGroupAttachMapper


jp.co.intra_mart.foundation.datastore.application.model.private_group.attach (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.private_group.attach

プライベートグループ所属情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
PrivateGroupAttachBaseModel | プライベートグループ所属の基本モデルです。
PrivateGroupAttachMapper | プライベートグループ所属に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.private_group.attach の説明

プライベートグループ所属情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.private_group.attach クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.private_group.attach の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.private_group.attach の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach の使用

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach プライベートグループ所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach により使用される jp.co.intra_mart.foundation.datastore.application.model.private_group.attach のクラス
PrivateGroupAttachBaseModel
プライベートグループ所属の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PrivateGroupAttachBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach
インタフェース PrivateGroupAttachBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface PrivateGroupAttachBaseModel
extends BaseModel

プライベートグループ所属の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | OWNER_CODE 所有者コード
static String | PRIVATE_GROUP_CODE グループコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
static String | USER_CODE ユーザコード
メソッドの概要
String | getOwnerCode() 所有者コードを取得します。
String | getPrivateGroupCode() グループコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
String | getUserCode() ユーザコードを取得します。
void | setSortKey(int sortKey) ソートキーを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

OWNER_CODE

public static final String OWNER_CODE
所有者コード

関連項目:
定数フィールド値

PRIVATE_GROUP_CODE

public static final String PRIVATE_GROUP_CODE
グループコード

関連項目:
定数フィールド値

USER_CODE

public static final String USER_CODE
ユーザコード

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getOwnerCode

public String getOwnerCode()
                    throws AccessorException
所有者コードを取得します。

戻り値:
所有者コード
例外:
AccessorException - データの取得に失敗した場合

getPrivateGroupCode

public String getPrivateGroupCode()
                           throws AccessorException
グループコードを取得します。

戻り値:
グループコード
例外:
AccessorException - データの取得に失敗した場合

getUserCode

public String getUserCode()
                   throws AccessorException
ユーザコードを取得します。

戻り値:
ユーザコード
例外:
AccessorException - データの取得に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PrivateGroupAttachMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach
インタフェース PrivateGroupAttachMapper

すべてのスーパーインタフェース:
Mapper
public interface PrivateGroupAttachMapper
extends Mapper

プライベートグループ所属に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
PrivateGroupAttachBaseModel | create(String ownerCode, String privateGroupCode, String userCode) プライマリキーに該当するプライベートグループ所属を生成します。
void | delete(Collection models) プライベートグループ所属の基本モデルを複数削除します。
void | delete(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ削除します。
void | insert(Collection models) プライベートグループ所属の基本モデルを複数挿入します。
void | insert(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ挿入します。
PrivateGroupAttachBaseModel | select(String ownerCode, String privateGroupCode, String userCode) プライマリーキーで特定されるプライベートグループ所属の基本モデルを取得します。
void | update(Collection models) プライベートグループ所属の基本モデルを複数更新します。
void | update(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public PrivateGroupAttachBaseModel create(String ownerCode,
                                          String privateGroupCode,
                                          String userCode)
                                   throws MapperException
プライマリキーに該当するプライベートグループ所属を生成します。

パラメータ:
ownerCode - 所有者コード
privateGroupCode - グループコード
userCode - ユーザコード
戻り値:
プライマリキーに該当するプライベートグループ所属の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public PrivateGroupAttachBaseModel select(String ownerCode,
                                          String privateGroupCode,
                                          String userCode)
                                   throws MapperException
プライマリーキーで特定されるプライベートグループ所属の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
ownerCode - 所有者コード
privateGroupCode - グループコード
userCode - ユーザコード
戻り値:
プライベートグループ所属の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(PrivateGroupAttachBaseModel model)
            throws MapperException
プライベートグループ所属の基本モデルを1つだけ挿入します。 引数に指定するプライベートグループ所属の基本モデルは同一の PrivateGroupAttachMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するプライベートグループ所属の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
プライベートグループ所属の基本モデルを複数挿入します。 引数に指定するものは同一の PrivateGroupAttachMapperの create(String,String,String) で生成されたプライベートグループ所属の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するプライベートグループ所属の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(PrivateGroupAttachBaseModel model)
            throws MapperException
プライベートグループ所属の基本モデルを1つだけ更新します。 引数に指定するプライベートグループ所属の基本モデルは同一の PrivateGroupAttachMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するプライベートグループ所属の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
プライベートグループ所属の基本モデルを複数更新します。 引数に指定するものは同一の PrivateGroupAttachMapperの select 系メソッド から取得されたものかで生成されたプライベートグループ所属の基本モデルの集合である必要があります。

パラメータ:
models - 更新するプライベートグループ所属の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(PrivateGroupAttachBaseModel model)
            throws MapperException
プライベートグループ所属の基本モデルを1つだけ削除します。 引数で指定されたプライベートグループ所属の基本モデルに該当するデータのすべての情報を削除します。引数に指定するプライベートグループ所属の基本モデルは同一の PrivateGroupAttachMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するプライベートグループ所属の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
プライベートグループ所属の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するプライベートグループ所属の基本モデルは同一の PrivateGroupAttachMapperの select 系メソッド から取得されたプライベートグループ所属の基本モデルの集合である必要があります。

パラメータ:
models - 削除するプライベートグループ所属の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の使用

PrivateGroupBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.private_group.group プライベートグループ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.private_group.group での PrivateGroupBaseModel の使用

PrivateGroupBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.private_group.group のメソッド
PrivateGroupBaseModel | PrivateGroupMapper.create(String ownerCode, String privateGroupCode) プライマリキーに該当するプライベートグループを生成します。
PrivateGroupBaseModel | PrivateGroupMapper.select(String ownerCode, String privateGroupCode) プライマリーキーで特定されるプライベートグループの基本モデルを取得します。

PrivateGroupBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.private_group.group のメソッド
void | PrivateGroupMapper.insert(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ挿入します。
void | PrivateGroupMapper.update(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ更新します。
void | PrivateGroupMapper.delete(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.private_group.group (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.private_group.group
インタフェース
PrivateGroupBaseModel
PrivateGroupMapper


jp.co.intra_mart.foundation.datastore.application.model.private_group.group (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.private_group.group

プライベートグループ情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
PrivateGroupBaseModel | プライベートグループの基本モデルです。
PrivateGroupMapper | プライベートグループに関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.private_group.group の説明

プライベートグループ情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.private_group.group クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.private_group.group の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.private_group.group の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.private_group.group の使用

jp.co.intra_mart.foundation.datastore.application.model.private_group.group を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.private_group.group プライベートグループ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.private_group.group により使用される jp.co.intra_mart.foundation.datastore.application.model.private_group.group のクラス
PrivateGroupBaseModel
プライベートグループの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PrivateGroupBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.private_group.group
インタフェース PrivateGroupBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface PrivateGroupBaseModel
extends BaseModel

プライベートグループの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | NAME グループ名
static String | NAME_ENGLISH グループ名英字
static String | NAME_SYLLABARY グループ名カナ
static String | NOTES 備考
static String | OWNER_CODE 所有者コード
static String | PRIVATE_GROUP_CODE グループコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
メソッドの概要
String | getName() グループ名を取得します。
String | getNameEnglish() グループ名英字を取得します。
String | getNameSyllabary() グループ名カナを取得します。
String | getNotes() 備考を取得します。
String | getOwnerCode() 所有者コードを取得します。
String | getPrivateGroupCode() グループコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
void | setName(String name) グループ名を設定します。
void | setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

OWNER_CODE

public static final String OWNER_CODE
所有者コード

関連項目:
定数フィールド値

PRIVATE_GROUP_CODE

public static final String PRIVATE_GROUP_CODE
グループコード

関連項目:
定数フィールド値

NAME

public static final String NAME
グループ名

関連項目:
定数フィールド値

NAME_SYLLABARY

public static final String NAME_SYLLABARY
グループ名カナ

関連項目:
定数フィールド値

NAME_ENGLISH

public static final String NAME_ENGLISH
グループ名英字

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getOwnerCode

public String getOwnerCode()
                    throws AccessorException
所有者コードを取得します。

戻り値:
所有者コード
例外:
AccessorException - データの取得に失敗した場合

getPrivateGroupCode

public String getPrivateGroupCode()
                           throws AccessorException
グループコードを取得します。

戻り値:
グループコード
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName()
               throws AccessorException
グループ名を取得します。

戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
グループ名を設定します。

パラメータ:
name - グループ名
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
グループ名カナを取得します。

戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
グループ名英字を取得します。

戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PrivateGroupMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.private_group.group
インタフェース PrivateGroupMapper

すべてのスーパーインタフェース:
Mapper
public interface PrivateGroupMapper
extends Mapper

プライベートグループに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
PrivateGroupBaseModel | create(String ownerCode, String privateGroupCode) プライマリキーに該当するプライベートグループを生成します。
void | delete(Collection models) プライベートグループの基本モデルを複数削除します。
void | delete(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ削除します。
void | insert(Collection models) プライベートグループの基本モデルを複数挿入します。
void | insert(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ挿入します。
PrivateGroupBaseModel | select(String ownerCode, String privateGroupCode) プライマリーキーで特定されるプライベートグループの基本モデルを取得します。
void | update(Collection models) プライベートグループの基本モデルを複数更新します。
void | update(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public PrivateGroupBaseModel create(String ownerCode,
                                    String privateGroupCode)
                             throws MapperException
プライマリキーに該当するプライベートグループを生成します。

パラメータ:
ownerCode - 所有者コード
privateGroupCode - グループコード
戻り値:
プライマリキーに該当するプライベートグループの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public PrivateGroupBaseModel select(String ownerCode,
                                    String privateGroupCode)
                             throws MapperException
プライマリーキーで特定されるプライベートグループの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
ownerCode - 所有者コード
privateGroupCode - グループコード
戻り値:
プライベートグループの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(PrivateGroupBaseModel model)
            throws MapperException
プライベートグループの基本モデルを1つだけ挿入します。 引数に指定するプライベートグループの基本モデルは同一の PrivateGroupMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するプライベートグループの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
プライベートグループの基本モデルを複数挿入します。 引数に指定するものは同一の PrivateGroupMapperの create(String,String) で生成されたプライベートグループの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するプライベートグループの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(PrivateGroupBaseModel model)
            throws MapperException
プライベートグループの基本モデルを1つだけ更新します。 引数に指定するプライベートグループの基本モデルは同一の PrivateGroupMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するプライベートグループの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
プライベートグループの基本モデルを複数更新します。 引数に指定するものは同一の PrivateGroupMapperの select 系メソッド から取得されたものかで生成されたプライベートグループの基本モデルの集合である必要があります。

パラメータ:
models - 更新するプライベートグループの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(PrivateGroupBaseModel model)
            throws MapperException
プライベートグループの基本モデルを1つだけ削除します。 引数で指定されたプライベートグループの基本モデルに該当するデータのすべての情報を削除します。引数に指定するプライベートグループの基本モデルは同一の PrivateGroupMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するプライベートグループの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
プライベートグループの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するプライベートグループの基本モデルは同一の PrivateGroupMapperの select 系メソッド から取得されたプライベートグループの基本モデルの集合である必要があります。

パラメータ:
models - 削除するプライベートグループの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の使用

PublicGroupAttachBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach パブリックグループ所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での PublicGroupAttachBaseModel の使用

PublicGroupAttachBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.public_group.attach のメソッド
PublicGroupAttachBaseModel | PublicGroupAttachMapper.create(String userCode, String publicGroupSetCode, String publicGroupCode) プライマリキーに該当するパブリックグループ所属を生成します。
PublicGroupAttachBaseModel | PublicGroupAttachMapper.select(String userCode, String publicGroupSetCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループ所属の基本モデルを取得します。

PublicGroupAttachBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.public_group.attach のメソッド
void | PublicGroupAttachMapper.insert(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ挿入します。
void | PublicGroupAttachMapper.update(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ更新します。
void | PublicGroupAttachMapper.delete(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachTerminableModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachTerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachTerminableModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.public_group.attach (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.public_group.attach
インタフェース
PublicGroupAttachBaseModel
PublicGroupAttachMapper
PublicGroupAttachTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.public_group.attach (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.attach

パブリックグループ所属情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
PublicGroupAttachBaseModel | パブリックグループ所属の基本モデルです。
PublicGroupAttachMapper | パブリックグループ所属に関連するマッパです。
PublicGroupAttachTerminableModel | パブリックグループ所属の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.attach の説明

パブリックグループ所属情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.public_group.attach クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.attach の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachTerminableModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.attach の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach パブリックグループ所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach により使用される jp.co.intra_mart.foundation.datastore.application.model.public_group.attach のクラス
PublicGroupAttachBaseModel
パブリックグループ所属の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupAttachBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach
インタフェース PublicGroupAttachBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface PublicGroupAttachBaseModel
extends BaseModel

パブリックグループ所属の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | PUBLIC_GROUP_CODE グループコード
static String | PUBLIC_GROUP_SET_CODE グループセットコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
static String | USER_CODE ユーザコード
メソッドの概要
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
String | getUserCode() ユーザコードを取得します。
void | setSortKey(int sortKey) ソートキーを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

USER_CODE

public static final String USER_CODE
ユーザコード

関連項目:
定数フィールド値

PUBLIC_GROUP_SET_CODE

public static final String PUBLIC_GROUP_SET_CODE
グループセットコード

関連項目:
定数フィールド値

PUBLIC_GROUP_CODE

public static final String PUBLIC_GROUP_CODE
グループコード

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getUserCode

public String getUserCode()
                   throws AccessorException
ユーザコードを取得します。

戻り値:
ユーザコード
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupSetCode

public String getPublicGroupSetCode()
                             throws AccessorException
グループセットコードを取得します。

戻り値:
グループセットコード
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupCode

public String getPublicGroupCode()
                          throws AccessorException
グループコードを取得します。

戻り値:
グループコード
例外:
AccessorException - データの取得に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupAttachMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach
インタフェース PublicGroupAttachMapper

すべてのスーパーインタフェース:
Mapper
public interface PublicGroupAttachMapper
extends Mapper

パブリックグループ所属に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
PublicGroupAttachBaseModel | create(String userCode, String publicGroupSetCode, String publicGroupCode) プライマリキーに該当するパブリックグループ所属を生成します。
void | delete(Collection models) パブリックグループ所属の基本モデルを複数削除します。
void | delete(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ削除します。
void | insert(Collection models) パブリックグループ所属の基本モデルを複数挿入します。
void | insert(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ挿入します。
PublicGroupAttachBaseModel | select(String userCode, String publicGroupSetCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループ所属の基本モデルを取得します。
void | update(Collection models) パブリックグループ所属の基本モデルを複数更新します。
void | update(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public PublicGroupAttachBaseModel create(String userCode,
                                         String publicGroupSetCode,
                                         String publicGroupCode)
                                  throws MapperException
プライマリキーに該当するパブリックグループ所属を生成します。

パラメータ:
userCode - ユーザコード
publicGroupSetCode - グループセットコード
publicGroupCode - グループコード
戻り値:
プライマリキーに該当するパブリックグループ所属の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public PublicGroupAttachBaseModel select(String userCode,
                                         String publicGroupSetCode,
                                         String publicGroupCode)
                                  throws MapperException
プライマリーキーで特定されるパブリックグループ所属の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
userCode - ユーザコード
publicGroupSetCode - グループセットコード
publicGroupCode - グループコード
戻り値:
パブリックグループ所属の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(PublicGroupAttachBaseModel model)
            throws MapperException
パブリックグループ所属の基本モデルを1つだけ挿入します。 引数に指定するパブリックグループ所属の基本モデルは同一の PublicGroupAttachMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するパブリックグループ所属の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
パブリックグループ所属の基本モデルを複数挿入します。 引数に指定するものは同一の PublicGroupAttachMapperの create(String,String,String) で生成されたパブリックグループ所属の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するパブリックグループ所属の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(PublicGroupAttachBaseModel model)
            throws MapperException
パブリックグループ所属の基本モデルを1つだけ更新します。 引数に指定するパブリックグループ所属の基本モデルは同一の PublicGroupAttachMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するパブリックグループ所属の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
パブリックグループ所属の基本モデルを複数更新します。 引数に指定するものは同一の PublicGroupAttachMapperの select 系メソッド から取得されたものかで生成されたパブリックグループ所属の基本モデルの集合である必要があります。

パラメータ:
models - 更新するパブリックグループ所属の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(PublicGroupAttachBaseModel model)
            throws MapperException
パブリックグループ所属の基本モデルを1つだけ削除します。 引数で指定されたパブリックグループ所属の基本モデルに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ所属の基本モデルは同一の PublicGroupAttachMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するパブリックグループ所属の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
パブリックグループ所属の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ所属の基本モデルは同一の PublicGroupAttachMapperの select 系メソッド から取得されたパブリックグループ所属の基本モデルの集合である必要があります。

パラメータ:
models - 削除するパブリックグループ所属の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PublicGroupAttachTerminableModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach
インタフェース PublicGroupAttachTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface PublicGroupAttachTerminableModel
extends TerminableModel

パブリックグループ所属の期間化モデルです。

導入されたバージョン:
5.0

インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の使用

PublicGroupCategoryBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.category パブリックグループ分類情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での PublicGroupCategoryBaseModel の使用

PublicGroupCategoryBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.public_group.category のメソッド
PublicGroupCategoryBaseModel | PublicGroupCategoryMapper.create(String publicGroupSetCode, String publicGroupCode, String categoryClassCode, String categoryCode) プライマリキーに該当するパブリックグループ分類を生成します。
PublicGroupCategoryBaseModel | PublicGroupCategoryMapper.select(String publicGroupSetCode, String publicGroupCode, String categoryClassCode, String categoryCode) プライマリーキーで特定されるパブリックグループ分類の基本モデルを取得します。

PublicGroupCategoryBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.public_group.category のメソッド
void | PublicGroupCategoryMapper.insert(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ挿入します。
void | PublicGroupCategoryMapper.update(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ更新します。
void | PublicGroupCategoryMapper.delete(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryTerminableModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryTerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryTerminableModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.public_group.category (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.public_group.category
インタフェース
PublicGroupCategoryBaseModel
PublicGroupCategoryMapper
PublicGroupCategoryTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.public_group.category (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.category

パブリックグループ分類情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
PublicGroupCategoryBaseModel | パブリックグループ分類の基本モデルです。
PublicGroupCategoryMapper | パブリックグループ分類に関連するマッパです。
PublicGroupCategoryTerminableModel | パブリックグループ分類の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.category の説明

パブリックグループ分類情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.public_group.category クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.category の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryTerminableModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.category の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.category の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.category を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.category パブリックグループ分類情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category により使用される jp.co.intra_mart.foundation.datastore.application.model.public_group.category のクラス
PublicGroupCategoryBaseModel
パブリックグループ分類の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupCategoryBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.category
インタフェース PublicGroupCategoryBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface PublicGroupCategoryBaseModel
extends BaseModel

パブリックグループ分類の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | CATEGORY_CLASS_CODE 分類区分コード
static String | CATEGORY_CODE 分類コード
static String | PUBLIC_GROUP_CODE グループコード
static String | PUBLIC_GROUP_SET_CODE グループセットコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getCategoryClassCode() 分類区分コードを取得します。
String | getCategoryCode() 分類コードを取得します。
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

PUBLIC_GROUP_SET_CODE

public static final String PUBLIC_GROUP_SET_CODE
グループセットコード

関連項目:
定数フィールド値

PUBLIC_GROUP_CODE

public static final String PUBLIC_GROUP_CODE
グループコード

関連項目:
定数フィールド値

CATEGORY_CLASS_CODE

public static final String CATEGORY_CLASS_CODE
分類区分コード

関連項目:
定数フィールド値

CATEGORY_CODE

public static final String CATEGORY_CODE
分類コード

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getPublicGroupSetCode

public String getPublicGroupSetCode()
                             throws AccessorException
グループセットコードを取得します。

戻り値:
グループセットコード
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupCode

public String getPublicGroupCode()
                          throws AccessorException
グループコードを取得します。

戻り値:
グループコード
例外:
AccessorException - データの取得に失敗した場合

getCategoryClassCode

public String getCategoryClassCode()
                            throws AccessorException
分類区分コードを取得します。

戻り値:
分類区分コード
例外:
AccessorException - データの取得に失敗した場合

getCategoryCode

public String getCategoryCode()
                       throws AccessorException
分類コードを取得します。

戻り値:
分類コード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupCategoryMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.category
インタフェース PublicGroupCategoryMapper

すべてのスーパーインタフェース:
Mapper
public interface PublicGroupCategoryMapper
extends Mapper

パブリックグループ分類に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
PublicGroupCategoryBaseModel | create(String publicGroupSetCode, String publicGroupCode, String categoryClassCode, String categoryCode) プライマリキーに該当するパブリックグループ分類を生成します。
void | delete(Collection models) パブリックグループ分類の基本モデルを複数削除します。
void | delete(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ削除します。
void | insert(Collection models) パブリックグループ分類の基本モデルを複数挿入します。
void | insert(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ挿入します。
PublicGroupCategoryBaseModel | select(String publicGroupSetCode, String publicGroupCode, String categoryClassCode, String categoryCode) プライマリーキーで特定されるパブリックグループ分類の基本モデルを取得します。
void | update(Collection models) パブリックグループ分類の基本モデルを複数更新します。
void | update(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public PublicGroupCategoryBaseModel create(String publicGroupSetCode,
                                           String publicGroupCode,
                                           String categoryClassCode,
                                           String categoryCode)
                                    throws MapperException
プライマリキーに該当するパブリックグループ分類を生成します。

パラメータ:
publicGroupSetCode - グループセットコード
publicGroupCode - グループコード
categoryClassCode - 分類区分コード
categoryCode - 分類コード
戻り値:
プライマリキーに該当するパブリックグループ分類の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public PublicGroupCategoryBaseModel select(String publicGroupSetCode,
                                           String publicGroupCode,
                                           String categoryClassCode,
                                           String categoryCode)
                                    throws MapperException
プライマリーキーで特定されるパブリックグループ分類の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
publicGroupSetCode - グループセットコード
publicGroupCode - グループコード
categoryClassCode - 分類区分コード
categoryCode - 分類コード
戻り値:
パブリックグループ分類の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(PublicGroupCategoryBaseModel model)
            throws MapperException
パブリックグループ分類の基本モデルを1つだけ挿入します。 引数に指定するパブリックグループ分類の基本モデルは同一の PublicGroupCategoryMapperの create(String,String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するパブリックグループ分類の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
パブリックグループ分類の基本モデルを複数挿入します。 引数に指定するものは同一の PublicGroupCategoryMapperの create(String,String,String,String) で生成されたパブリックグループ分類の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するパブリックグループ分類の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(PublicGroupCategoryBaseModel model)
            throws MapperException
パブリックグループ分類の基本モデルを1つだけ更新します。 引数に指定するパブリックグループ分類の基本モデルは同一の PublicGroupCategoryMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するパブリックグループ分類の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
パブリックグループ分類の基本モデルを複数更新します。 引数に指定するものは同一の PublicGroupCategoryMapperの select 系メソッド から取得されたものかで生成されたパブリックグループ分類の基本モデルの集合である必要があります。

パラメータ:
models - 更新するパブリックグループ分類の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(PublicGroupCategoryBaseModel model)
            throws MapperException
パブリックグループ分類の基本モデルを1つだけ削除します。 引数で指定されたパブリックグループ分類の基本モデルに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ分類の基本モデルは同一の PublicGroupCategoryMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するパブリックグループ分類の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
パブリックグループ分類の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ分類の基本モデルは同一の PublicGroupCategoryMapperの select 系メソッド から取得されたパブリックグループ分類の基本モデルの集合である必要があります。

パラメータ:
models - 削除するパブリックグループ分類の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PublicGroupCategoryTerminableModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.category
インタフェース PublicGroupCategoryTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface PublicGroupCategoryTerminableModel
extends TerminableModel

パブリックグループ分類の期間化モデルです。

導入されたバージョン:
5.0

インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の使用

PublicGroupBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.group パブリックグループ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での PublicGroupBaseModel の使用

PublicGroupBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.public_group.group のメソッド
PublicGroupBaseModel | PublicGroupMapper.create(String publicGroupSetCode, String publicGroupCode) プライマリキーに該当するパブリックグループを生成します。
PublicGroupBaseModel | PublicGroupMapper.select(String publicGroupSetCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループの基本モデルを取得します。

PublicGroupBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.public_group.group のメソッド
void | PublicGroupMapper.insert(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ挿入します。
void | PublicGroupMapper.update(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ更新します。
void | PublicGroupMapper.delete(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel の使用

PublicGroupTerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.group パブリックグループ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での PublicGroupTerminableInternationalModel の使用

PublicGroupTerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.public_group.group のメソッド
 PublicGroupTerminableInternationalModel PublicGroupTerminableModel.selectPublicGroupTerminableInternationalModel(Locale locale)
指定された言語に該当するパブリックグループの期間国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel の使用

PublicGroupTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.group パブリックグループ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での PublicGroupTerminableModel の使用

PublicGroupTerminableModel を返す jp.co.intra_mart.foundation.datastore.application.model.public_group.group のメソッド
 PublicGroupTerminableModel PublicGroupBaseModel.selectPublicGroupTerminableModel(Date date)
指定された日付に該当するパブリックグループの期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.public_group.group (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.public_group.group
インタフェース
PublicGroupBaseModel
PublicGroupMapper
PublicGroupTerminableInternationalModel
PublicGroupTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.public_group.group (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.group

パブリックグループ情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
PublicGroupBaseModel | パブリックグループの基本モデルです。
PublicGroupMapper | パブリックグループに関連するマッパです。
PublicGroupTerminableInternationalModel | パブリックグループの期間国際化モデルです。
PublicGroupTerminableModel | パブリックグループの期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.group の説明

パブリックグループ情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.public_group.group クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.group の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.group の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.group の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.group を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.group パブリックグループ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group により使用される jp.co.intra_mart.foundation.datastore.application.model.public_group.group のクラス
PublicGroupBaseModel
パブリックグループの基本モデルです。
PublicGroupTerminableInternationalModel
パブリックグループの期間国際化モデルです。
PublicGroupTerminableModel
パブリックグループの期間化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.group
インタフェース PublicGroupBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface PublicGroupBaseModel
extends BaseModel

パブリックグループの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | NAME グループ名
static String | NAME_ENGLISH グループ名英字
static String | NAME_SYLLABARY グループ名カナ
static String | NOTES 備考
static String | PUBLIC_GROUP_CODE グループコード
static String | PUBLIC_GROUP_SET_CODE グループセットコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
メソッドの概要
String | getName() グループ名を取得します。
String | getName(Date date) グループ名を取得します。
String | getName(Date date, Locale locale) グループ名を取得します。
String | getName(Locale locale) グループ名を取得します。
String | getNameEnglish() グループ名英字を取得します。
String | getNameEnglish(Date date) グループ名英字を取得します。
String | getNameEnglish(Date date, Locale locale) グループ名英字を取得します。
String | getNameEnglish(Locale locale) グループ名英字を取得します。
String | getNameSyllabary() グループ名カナを取得します。
String | getNameSyllabary(Date date) グループ名カナを取得します。
String | getNameSyllabary(Date date, Locale locale) グループ名カナを取得します。
String | getNameSyllabary(Locale locale) グループ名カナを取得します。
String | getNotes() 備考を取得します。
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
PublicGroupTerminableModel | selectPublicGroupTerminableModel(Date date) 指定された日付に該当するパブリックグループの期間化モデルを取得します。
void | setName(String name) グループ名を設定します。
void | setName(String name, Date date) グループ名を設定します。
void | setName(String name, Date date, Locale locale) グループ名を設定します。
void | setName(String name, Locale locale) グループ名を設定します。
void | setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | setNameEnglish(String nameEnglish, Date date) グループ名英字を設定します。
void | setNameEnglish(String nameEnglish, Date date, Locale locale) グループ名英字を設定します。
void | setNameEnglish(String nameEnglish, Locale locale) グループ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Date date) グループ名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Date date, Locale locale) グループ名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Locale locale) グループ名カナを設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

PUBLIC_GROUP_SET_CODE

public static final String PUBLIC_GROUP_SET_CODE
グループセットコード

関連項目:
定数フィールド値

PUBLIC_GROUP_CODE

public static final String PUBLIC_GROUP_CODE
グループコード

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

NAME

public static final String NAME
グループ名

関連項目:
定数フィールド値

NAME_SYLLABARY

public static final String NAME_SYLLABARY
グループ名カナ

関連項目:
定数フィールド値

NAME_ENGLISH

public static final String NAME_ENGLISH
グループ名英字

関連項目:
定数フィールド値
メソッドの詳細

getPublicGroupSetCode

public String getPublicGroupSetCode()
                             throws AccessorException
グループセットコードを取得します。

戻り値:
グループセットコード
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupCode

public String getPublicGroupCode()
                          throws AccessorException
グループコードを取得します。

戻り値:
グループコード
例外:
AccessorException - データの取得に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName()
               throws AccessorException
グループ名を取得します。

戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Date date)
               throws AccessorException
グループ名を取得します。

パラメータ:
date - 日時
戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
グループ名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Date date,
                      Locale locale)
               throws AccessorException
グループ名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
グループ名を設定します。

パラメータ:
name - グループ名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Date date)
             throws AccessorException
グループ名を設定します。

パラメータ:
name - グループ名
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
グループ名を設定します。

パラメータ:
name - グループ名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Date date,
                    Locale locale)
             throws AccessorException
グループ名を設定します。

パラメータ:
name - グループ名
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
グループ名カナを取得します。

戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Date date)
                        throws AccessorException
グループ名カナを取得します。

パラメータ:
date - 日時
戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Locale locale)
                        throws AccessorException
グループ名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Date date,
                               Locale locale)
                        throws AccessorException
グループ名カナを取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Date date)
                      throws AccessorException
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Locale locale)
                      throws AccessorException
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Date date,
                             Locale locale)
                      throws AccessorException
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
グループ名英字を取得します。

戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Date date)
                      throws AccessorException
グループ名英字を取得します。

パラメータ:
date - 日時
戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Locale locale)
                      throws AccessorException
グループ名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Date date,
                             Locale locale)
                      throws AccessorException
グループ名英字を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Date date)
                    throws AccessorException
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Locale locale)
                    throws AccessorException
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Date date,
                           Locale locale)
                    throws AccessorException
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectPublicGroupTerminableModel

public PublicGroupTerminableModel selectPublicGroupTerminableModel(Date date)
                                                            throws IllegalTermException
指定された日付に該当するパブリックグループの期間化モデルを取得します。

パラメータ:
date - 指定日付
戻り値:
パブリックグループの期間化モデル
例外:
IllegalTermException - 指定された日付に該当する期間が定義されていない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.group
インタフェース PublicGroupMapper

すべてのスーパーインタフェース:
Mapper
public interface PublicGroupMapper
extends Mapper

パブリックグループに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
PublicGroupBaseModel | create(String publicGroupSetCode, String publicGroupCode) プライマリキーに該当するパブリックグループを生成します。
void | delete(Collection models) パブリックグループの基本モデルを複数削除します。
void | delete(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ削除します。
void | insert(Collection models) パブリックグループの基本モデルを複数挿入します。
void | insert(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ挿入します。
PublicGroupBaseModel | select(String publicGroupSetCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループの基本モデルを取得します。
void | update(Collection models) パブリックグループの基本モデルを複数更新します。
void | update(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public PublicGroupBaseModel create(String publicGroupSetCode,
                                   String publicGroupCode)
                            throws MapperException
プライマリキーに該当するパブリックグループを生成します。

パラメータ:
publicGroupSetCode - グループセットコード
publicGroupCode - グループコード
戻り値:
プライマリキーに該当するパブリックグループの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public PublicGroupBaseModel select(String publicGroupSetCode,
                                   String publicGroupCode)
                            throws MapperException
プライマリーキーで特定されるパブリックグループの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
publicGroupSetCode - グループセットコード
publicGroupCode - グループコード
戻り値:
パブリックグループの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(PublicGroupBaseModel model)
            throws MapperException
パブリックグループの基本モデルを1つだけ挿入します。 引数に指定するパブリックグループの基本モデルは同一の PublicGroupMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するパブリックグループの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
パブリックグループの基本モデルを複数挿入します。 引数に指定するものは同一の PublicGroupMapperの create(String,String) で生成されたパブリックグループの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するパブリックグループの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(PublicGroupBaseModel model)
            throws MapperException
パブリックグループの基本モデルを1つだけ更新します。 引数に指定するパブリックグループの基本モデルは同一の PublicGroupMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するパブリックグループの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
パブリックグループの基本モデルを複数更新します。 引数に指定するものは同一の PublicGroupMapperの select 系メソッド から取得されたものかで生成されたパブリックグループの基本モデルの集合である必要があります。

パラメータ:
models - 更新するパブリックグループの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(PublicGroupBaseModel model)
            throws MapperException
パブリックグループの基本モデルを1つだけ削除します。 引数で指定されたパブリックグループの基本モデルに該当するデータのすべての情報を削除します。引数に指定するパブリックグループの基本モデルは同一の PublicGroupMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するパブリックグループの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
パブリックグループの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するパブリックグループの基本モデルは同一の PublicGroupMapperの select 系メソッド から取得されたパブリックグループの基本モデルの集合である必要があります。

パラメータ:
models - 削除するパブリックグループの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PublicGroupTerminableInternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.group
インタフェース PublicGroupTerminableInternationalModel

すべてのスーパーインタフェース:
Serializable, TerminableInternationalModel
public interface PublicGroupTerminableInternationalModel
extends TerminableInternationalModel

パブリックグループの期間国際化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getName() グループ名を取得します。
String | getNameEnglish() グループ名英字を取得します。
String | getNameSyllabary() グループ名カナを取得します。
void | setName(String name) グループ名を設定します。
void | setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel から継承したメソッド
getExtendedTerminableInternationalModelMap, getLocale, init

メソッドの詳細

getName

public String getName()
               throws AccessorException
グループ名を取得します。

戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
グループ名を設定します。

パラメータ:
name - グループ名
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
グループ名カナを取得します。

戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
グループ名英字を取得します。

戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PublicGroupTerminableModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.group
インタフェース PublicGroupTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface PublicGroupTerminableModel
extends TerminableModel

パブリックグループの期間化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getName() グループ名を取得します。
String | getName(Locale locale) グループ名を取得します。
String | getNameEnglish() グループ名英字を取得します。
String | getNameEnglish(Locale locale) グループ名英字を取得します。
String | getNameSyllabary() グループ名カナを取得します。
String | getNameSyllabary(Locale locale) グループ名カナを取得します。
PublicGroupTerminableInternationalModel | selectPublicGroupTerminableInternationalModel(Locale locale) 指定された言語に該当するパブリックグループの期間国際化モデルを取得します。
void | setName(String name) グループ名を設定します。
void | setName(String name, Locale locale) グループ名を設定します。
void | setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | setNameEnglish(String nameEnglish, Locale locale) グループ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Locale locale) グループ名カナを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

メソッドの詳細

getName

public String getName()
               throws AccessorException
グループ名を取得します。

戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
グループ名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
グループ名を設定します。

パラメータ:
name - グループ名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
グループ名を設定します。

パラメータ:
name - グループ名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
グループ名カナを取得します。

戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Locale locale)
                        throws AccessorException
グループ名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Locale locale)
                      throws AccessorException
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
グループ名英字を取得します。

戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Locale locale)
                      throws AccessorException
グループ名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Locale locale)
                    throws AccessorException
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectPublicGroupTerminableInternationalModel

public PublicGroupTerminableInternationalModel selectPublicGroupTerminableInternationalModel(Locale locale)
                                                                                throws IllegalLocaleException
指定された言語に該当するパブリックグループの期間国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
パブリックグループの期間国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の使用

PublicGroupInclusionBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion パブリックグループ内包情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion での PublicGroupInclusionBaseModel の使用

PublicGroupInclusionBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion のメソッド
PublicGroupInclusionBaseModel | PublicGroupInclusionMapper.create(String publicGroupSetCode, String versionCode, String parentPublicGroupCode, String publicGroupCode) プライマリキーに該当するパブリックグループ内包を生成します。
PublicGroupInclusionBaseModel | PublicGroupInclusionMapper.select(String publicGroupSetCode, String versionCode, String parentPublicGroupCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループ内包の基本モデルを取得します。

PublicGroupInclusionBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion のメソッド
void | PublicGroupInclusionMapper.insert(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ挿入します。
void | PublicGroupInclusionMapper.update(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ更新します。
void | PublicGroupInclusionMapper.delete(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion
インタフェース
PublicGroupInclusionBaseModel
PublicGroupInclusionMapper


jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion

パブリックグループ内包情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
PublicGroupInclusionBaseModel | パブリックグループ内包の基本モデルです。
PublicGroupInclusionMapper | パブリックグループ内包に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion の説明

パブリックグループ内包情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion パブリックグループ内包情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion により使用される jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion のクラス
PublicGroupInclusionBaseModel
パブリックグループ内包の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupInclusionBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion
インタフェース PublicGroupInclusionBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface PublicGroupInclusionBaseModel
extends BaseModel

パブリックグループ内包の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | DEPTH 階層レベル
static String | PARENT_PUBLIC_GROUP_CODE 親グループコード
static String | PUBLIC_GROUP_CODE グループコード
static String | PUBLIC_GROUP_SET_CODE グループセットコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | VERSION_CODE バージョンコード
メソッドの概要
int | getDepth() 階層レベルを取得します。
String | getParentPublicGroupCode() 親グループコードを取得します。
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getVersionCode() バージョンコードを取得します。
void | setDepth(int depth) 階層レベルを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

PUBLIC_GROUP_SET_CODE

public static final String PUBLIC_GROUP_SET_CODE
グループセットコード

関連項目:
定数フィールド値

VERSION_CODE

public static final String VERSION_CODE
バージョンコード

関連項目:
定数フィールド値

PARENT_PUBLIC_GROUP_CODE

public static final String PARENT_PUBLIC_GROUP_CODE
親グループコード

関連項目:
定数フィールド値

PUBLIC_GROUP_CODE

public static final String PUBLIC_GROUP_CODE
グループコード

関連項目:
定数フィールド値

DEPTH

public static final String DEPTH
階層レベル

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getPublicGroupSetCode

public String getPublicGroupSetCode()
                             throws AccessorException
グループセットコードを取得します。

戻り値:
グループセットコード
例外:
AccessorException - データの取得に失敗した場合

getVersionCode

public String getVersionCode()
                      throws AccessorException
バージョンコードを取得します。

戻り値:
バージョンコード
例外:
AccessorException - データの取得に失敗した場合

getParentPublicGroupCode

public String getParentPublicGroupCode()
                                throws AccessorException
親グループコードを取得します。

戻り値:
親グループコード
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupCode

public String getPublicGroupCode()
                          throws AccessorException
グループコードを取得します。

戻り値:
グループコード
例外:
AccessorException - データの取得に失敗した場合

getDepth

public int getDepth()
             throws AccessorException
階層レベルを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
階層レベル
例外:
AccessorException - データの取得に失敗した場合

setDepth

public void setDepth(int depth)
              throws AccessorException
階層レベルを設定します。

パラメータ:
depth - 階層レベル
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupInclusionMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion
インタフェース PublicGroupInclusionMapper

すべてのスーパーインタフェース:
Mapper
public interface PublicGroupInclusionMapper
extends Mapper

パブリックグループ内包に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
PublicGroupInclusionBaseModel | create(String publicGroupSetCode, String versionCode, String parentPublicGroupCode, String publicGroupCode) プライマリキーに該当するパブリックグループ内包を生成します。
void | delete(Collection models) パブリックグループ内包の基本モデルを複数削除します。
void | delete(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ削除します。
void | insert(Collection models) パブリックグループ内包の基本モデルを複数挿入します。
void | insert(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ挿入します。
PublicGroupInclusionBaseModel | select(String publicGroupSetCode, String versionCode, String parentPublicGroupCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループ内包の基本モデルを取得します。
void | update(Collection models) パブリックグループ内包の基本モデルを複数更新します。
void | update(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public PublicGroupInclusionBaseModel create(String publicGroupSetCode,
                                            String versionCode,
                                            String parentPublicGroupCode,
                                            String publicGroupCode)
                                     throws MapperException
プライマリキーに該当するパブリックグループ内包を生成します。

パラメータ:
publicGroupSetCode - グループセットコード
versionCode - バージョンコード
parentPublicGroupCode - 親グループコード
publicGroupCode - グループコード
戻り値:
プライマリキーに該当するパブリックグループ内包の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public PublicGroupInclusionBaseModel select(String publicGroupSetCode,
                                            String versionCode,
                                            String parentPublicGroupCode,
                                            String publicGroupCode)
                                     throws MapperException
プライマリーキーで特定されるパブリックグループ内包の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
publicGroupSetCode - グループセットコード
versionCode - バージョンコード
parentPublicGroupCode - 親グループコード
publicGroupCode - グループコード
戻り値:
パブリックグループ内包の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(PublicGroupInclusionBaseModel model)
            throws MapperException
パブリックグループ内包の基本モデルを1つだけ挿入します。 引数に指定するパブリックグループ内包の基本モデルは同一の PublicGroupInclusionMapperの create(String,String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するパブリックグループ内包の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
パブリックグループ内包の基本モデルを複数挿入します。 引数に指定するものは同一の PublicGroupInclusionMapperの create(String,String,String,String) で生成されたパブリックグループ内包の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するパブリックグループ内包の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(PublicGroupInclusionBaseModel model)
            throws MapperException
パブリックグループ内包の基本モデルを1つだけ更新します。 引数に指定するパブリックグループ内包の基本モデルは同一の PublicGroupInclusionMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するパブリックグループ内包の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
パブリックグループ内包の基本モデルを複数更新します。 引数に指定するものは同一の PublicGroupInclusionMapperの select 系メソッド から取得されたものかで生成されたパブリックグループ内包の基本モデルの集合である必要があります。

パラメータ:
models - 更新するパブリックグループ内包の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(PublicGroupInclusionBaseModel model)
            throws MapperException
パブリックグループ内包の基本モデルを1つだけ削除します。 引数で指定されたパブリックグループ内包の基本モデルに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ内包の基本モデルは同一の PublicGroupInclusionMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するパブリックグループ内包の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
パブリックグループ内包の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ内包の基本モデルは同一の PublicGroupInclusionMapperの select 系メソッド から取得されたパブリックグループ内包の基本モデルの集合である必要があります。

パラメータ:
models - 削除するパブリックグループ内包の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel の使用

PublicGroupSetBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.set パブリックグループセット情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.set での PublicGroupSetBaseModel の使用

PublicGroupSetBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.public_group.set のメソッド
PublicGroupSetBaseModel | PublicGroupSetMapper.create(String publicGroupSetCode) プライマリキーに該当するパブリックグループセットを生成します。
PublicGroupSetBaseModel | PublicGroupSetMapper.select(String publicGroupSetCode) プライマリーキーで特定されるパブリックグループセットの基本モデルを取得します。

PublicGroupSetBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.public_group.set のメソッド
void | PublicGroupSetMapper.insert(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ挿入します。
void | PublicGroupSetMapper.update(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ更新します。
void | PublicGroupSetMapper.delete(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.public_group.set (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.public_group.set
インタフェース
PublicGroupSetBaseModel
PublicGroupSetMapper


jp.co.intra_mart.foundation.datastore.application.model.public_group.set (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.set

パブリックグループセット情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
PublicGroupSetBaseModel | パブリックグループセットの基本モデルです。
PublicGroupSetMapper | パブリックグループセットに関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.set の説明

パブリックグループセット情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.public_group.set クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.set の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.set の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.set の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.set を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.set パブリックグループセット情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.set により使用される jp.co.intra_mart.foundation.datastore.application.model.public_group.set のクラス
PublicGroupSetBaseModel
パブリックグループセットの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupSetBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.set
インタフェース PublicGroupSetBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface PublicGroupSetBaseModel
extends BaseModel

パブリックグループセットの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | PUBLIC_GROUP_SET_CODE グループセットコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getPublicGroupSetCode() グループセットコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

PUBLIC_GROUP_SET_CODE

public static final String PUBLIC_GROUP_SET_CODE
グループセットコード

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getPublicGroupSetCode

public String getPublicGroupSetCode()
                             throws AccessorException
グループセットコードを取得します。

戻り値:
グループセットコード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupSetMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.set
インタフェース PublicGroupSetMapper

すべてのスーパーインタフェース:
Mapper
public interface PublicGroupSetMapper
extends Mapper

パブリックグループセットに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
PublicGroupSetBaseModel | create(String publicGroupSetCode) プライマリキーに該当するパブリックグループセットを生成します。
void | delete(Collection models) パブリックグループセットの基本モデルを複数削除します。
void | delete(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ削除します。
void | insert(Collection models) パブリックグループセットの基本モデルを複数挿入します。
void | insert(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ挿入します。
PublicGroupSetBaseModel | select(String publicGroupSetCode) プライマリーキーで特定されるパブリックグループセットの基本モデルを取得します。
void | update(Collection models) パブリックグループセットの基本モデルを複数更新します。
void | update(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public PublicGroupSetBaseModel create(String publicGroupSetCode)
                               throws MapperException
プライマリキーに該当するパブリックグループセットを生成します。

パラメータ:
publicGroupSetCode - グループセットコード
戻り値:
プライマリキーに該当するパブリックグループセットの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public PublicGroupSetBaseModel select(String publicGroupSetCode)
                               throws MapperException
プライマリーキーで特定されるパブリックグループセットの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
publicGroupSetCode - グループセットコード
戻り値:
パブリックグループセットの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(PublicGroupSetBaseModel model)
            throws MapperException
パブリックグループセットの基本モデルを1つだけ挿入します。 引数に指定するパブリックグループセットの基本モデルは同一の PublicGroupSetMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入するパブリックグループセットの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
パブリックグループセットの基本モデルを複数挿入します。 引数に指定するものは同一の PublicGroupSetMapperの create(String) で生成されたパブリックグループセットの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するパブリックグループセットの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(PublicGroupSetBaseModel model)
            throws MapperException
パブリックグループセットの基本モデルを1つだけ更新します。 引数に指定するパブリックグループセットの基本モデルは同一の PublicGroupSetMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するパブリックグループセットの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
パブリックグループセットの基本モデルを複数更新します。 引数に指定するものは同一の PublicGroupSetMapperの select 系メソッド から取得されたものかで生成されたパブリックグループセットの基本モデルの集合である必要があります。

パラメータ:
models - 更新するパブリックグループセットの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(PublicGroupSetBaseModel model)
            throws MapperException
パブリックグループセットの基本モデルを1つだけ削除します。 引数で指定されたパブリックグループセットの基本モデルに該当するデータのすべての情報を削除します。引数に指定するパブリックグループセットの基本モデルは同一の PublicGroupSetMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するパブリックグループセットの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
パブリックグループセットの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するパブリックグループセットの基本モデルは同一の PublicGroupSetMapperの select 系メソッド から取得されたパブリックグループセットの基本モデルの集合である必要があります。

パラメータ:
models - 削除するパブリックグループセットの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の使用

PublicGroupVersionBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.version パブリックグループバーション情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.version での PublicGroupVersionBaseModel の使用

PublicGroupVersionBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.public_group.version のメソッド
PublicGroupVersionBaseModel | PublicGroupVersionMapper.create(String publicGroupSetCode, String versionCode) プライマリキーに該当するパブリックグループ構成バージョンを生成します。
PublicGroupVersionBaseModel | PublicGroupVersionMapper.select(String publicGroupSetCode, String versionCode) プライマリーキーで特定されるパブリックグループ構成バージョンの基本モデルを取得します。

PublicGroupVersionBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.public_group.version のメソッド
void | PublicGroupVersionMapper.insert(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ挿入します。
void | PublicGroupVersionMapper.update(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ更新します。
void | PublicGroupVersionMapper.delete(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.public_group.version (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.public_group.version
インタフェース
PublicGroupVersionBaseModel
PublicGroupVersionMapper


jp.co.intra_mart.foundation.datastore.application.model.public_group.version (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.version

パブリックグループバーション情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
PublicGroupVersionBaseModel | パブリックグループ構成バージョンの基本モデルです。
PublicGroupVersionMapper | パブリックグループ構成バージョンに関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.version の説明

パブリックグループバーション情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.public_group.version クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.version の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.version の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.version の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.version を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.version パブリックグループバーション情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.version により使用される jp.co.intra_mart.foundation.datastore.application.model.public_group.version のクラス
PublicGroupVersionBaseModel
パブリックグループ構成バージョンの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupVersionBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.version
インタフェース PublicGroupVersionBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface PublicGroupVersionBaseModel
extends BaseModel

パブリックグループ構成バージョンの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | END_DATE 終了日
static String | NOTES 備考
static String | PUBLIC_GROUP_SET_CODE グループセットコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | START_DATE 開始日
static String | VERSION_CODE バージョンコード
メソッドの概要
Date | getEndDate() 終了日を取得します。
String | getNotes() 備考を取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
Date | getStartDate() 開始日を取得します。
String | getVersionCode() バージョンコードを取得します。
void | setEndDate(Date endDate) 終了日を設定します。
void | setNotes(String notes) 備考を設定します。
void | setStartDate(Date startDate) 開始日を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

PUBLIC_GROUP_SET_CODE

public static final String PUBLIC_GROUP_SET_CODE
グループセットコード

関連項目:
定数フィールド値

VERSION_CODE

public static final String VERSION_CODE
バージョンコード

関連項目:
定数フィールド値

START_DATE

public static final String START_DATE
開始日

関連項目:
定数フィールド値

END_DATE

public static final String END_DATE
終了日

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getPublicGroupSetCode

public String getPublicGroupSetCode()
                             throws AccessorException
グループセットコードを取得します。

戻り値:
グループセットコード
例外:
AccessorException - データの取得に失敗した場合

getVersionCode

public String getVersionCode()
                      throws AccessorException
バージョンコードを取得します。

戻り値:
バージョンコード
例外:
AccessorException - データの取得に失敗した場合

getStartDate

public Date getStartDate()
                  throws AccessorException
開始日を取得します。

戻り値:
開始日
例外:
AccessorException - データの取得に失敗した場合

setStartDate

public void setStartDate(Date startDate)
                  throws AccessorException
開始日を設定します。

パラメータ:
startDate - 開始日
例外:
AccessorException - データの設定に失敗した場合

getEndDate

public Date getEndDate()
                throws AccessorException
終了日を取得します。

戻り値:
終了日
例外:
AccessorException - データの取得に失敗した場合

setEndDate

public void setEndDate(Date endDate)
                throws AccessorException
終了日を設定します。

パラメータ:
endDate - 終了日
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupVersionMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.version
インタフェース PublicGroupVersionMapper

すべてのスーパーインタフェース:
Mapper
public interface PublicGroupVersionMapper
extends Mapper

パブリックグループ構成バージョンに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
PublicGroupVersionBaseModel | create(String publicGroupSetCode, String versionCode) プライマリキーに該当するパブリックグループ構成バージョンを生成します。
void | delete(Collection models) パブリックグループ構成バージョンの基本モデルを複数削除します。
void | delete(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ削除します。
void | insert(Collection models) パブリックグループ構成バージョンの基本モデルを複数挿入します。
void | insert(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ挿入します。
PublicGroupVersionBaseModel | select(String publicGroupSetCode, String versionCode) プライマリーキーで特定されるパブリックグループ構成バージョンの基本モデルを取得します。
void | update(Collection models) パブリックグループ構成バージョンの基本モデルを複数更新します。
void | update(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public PublicGroupVersionBaseModel create(String publicGroupSetCode,
                                          String versionCode)
                                   throws MapperException
プライマリキーに該当するパブリックグループ構成バージョンを生成します。

パラメータ:
publicGroupSetCode - グループセットコード
versionCode - バージョンコード
戻り値:
プライマリキーに該当するパブリックグループ構成バージョンの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public PublicGroupVersionBaseModel select(String publicGroupSetCode,
                                          String versionCode)
                                   throws MapperException
プライマリーキーで特定されるパブリックグループ構成バージョンの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
publicGroupSetCode - グループセットコード
versionCode - バージョンコード
戻り値:
パブリックグループ構成バージョンの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(PublicGroupVersionBaseModel model)
            throws MapperException
パブリックグループ構成バージョンの基本モデルを1つだけ挿入します。 引数に指定するパブリックグループ構成バージョンの基本モデルは同一の PublicGroupVersionMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するパブリックグループ構成バージョンの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
パブリックグループ構成バージョンの基本モデルを複数挿入します。 引数に指定するものは同一の PublicGroupVersionMapperの create(String,String) で生成されたパブリックグループ構成バージョンの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するパブリックグループ構成バージョンの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(PublicGroupVersionBaseModel model)
            throws MapperException
パブリックグループ構成バージョンの基本モデルを1つだけ更新します。 引数に指定するパブリックグループ構成バージョンの基本モデルは同一の PublicGroupVersionMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するパブリックグループ構成バージョンの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
パブリックグループ構成バージョンの基本モデルを複数更新します。 引数に指定するものは同一の PublicGroupVersionMapperの select 系メソッド から取得されたものかで生成されたパブリックグループ構成バージョンの基本モデルの集合である必要があります。

パラメータ:
models - 更新するパブリックグループ構成バージョンの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(PublicGroupVersionBaseModel model)
            throws MapperException
パブリックグループ構成バージョンの基本モデルを1つだけ削除します。 引数で指定されたパブリックグループ構成バージョンの基本モデルに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ構成バージョンの基本モデルは同一の PublicGroupVersionMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するパブリックグループ構成バージョンの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
パブリックグループ構成バージョンの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ構成バージョンの基本モデルは同一の PublicGroupVersionMapperの select 系メソッド から取得されたパブリックグループ構成バージョンの基本モデルの集合である必要があります。

パラメータ:
models - 削除するパブリックグループ構成バージョンの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.unit.UnitBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.unit.UnitBaseModel の使用

UnitBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.unit 単位情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.unit での UnitBaseModel の使用

UnitBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.unit のメソッド
UnitBaseModel | UnitMapper.create(String unitCode) プライマリキーに該当する単位を生成します。
UnitBaseModel | UnitMapper.select(String unitCode) プライマリーキーで特定される単位の基本モデルを取得します。

UnitBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.unit のメソッド
void | UnitMapper.insert(UnitBaseModel model) 単位の基本モデルを1つだけ挿入します。
void | UnitMapper.update(UnitBaseModel model) 単位の基本モデルを1つだけ更新します。
void | UnitMapper.delete(UnitBaseModel model) 単位の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.unit (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.unit
インタフェース
UnitBaseModel
UnitMapper


jp.co.intra_mart.foundation.datastore.application.model.unit (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.unit

単位情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
UnitBaseModel | 単位の基本モデルです。
UnitMapper | 単位に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.unit の説明

単位情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.unit クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.unit の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitBaseModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.unit の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.unit の使用

jp.co.intra_mart.foundation.datastore.application.model.unit を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.unit 単位情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.unit により使用される jp.co.intra_mart.foundation.datastore.application.model.unit のクラス
UnitBaseModel
単位の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


UnitBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.unit
インタフェース UnitBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface UnitBaseModel
extends BaseModel

単位の基本モデルです。

導入されたバージョン:
5.1

フィールドの概要
static String | UNIT_CODE 単位コード
static String | UNIT_NAME 単位名
メソッドの概要
String | getUnitCode() 単位コードを取得します。
String | getUnitName() 単位名を取得します。
void | setUnitName(String unitName) 単位名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

UNIT_CODE

public static final String UNIT_CODE
単位コード

関連項目:
定数フィールド値

UNIT_NAME

public static final String UNIT_NAME
単位名

関連項目:
定数フィールド値
メソッドの詳細

getUnitCode

public String getUnitCode()
                   throws AccessorException
単位コードを取得します。

戻り値:
単位コード
例外:
AccessorException - データの取得に失敗した場合

getUnitName

public String getUnitName()
                   throws AccessorException
単位名を取得します。

戻り値:
単位名
例外:
AccessorException - データの取得に失敗した場合

setUnitName

public void setUnitName(String unitName)
                 throws AccessorException
単位名を設定します。

パラメータ:
unitName - 単位名
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UnitMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.unit
インタフェース UnitMapper

すべてのスーパーインタフェース:
Mapper
public interface UnitMapper
extends Mapper

単位に関連するマッパです。

導入されたバージョン:
5.1

メソッドの概要
UnitBaseModel | create(String unitCode) プライマリキーに該当する単位を生成します。
void | delete(Collection models) 単位の基本モデルを複数削除します。
void | delete(UnitBaseModel model) 単位の基本モデルを1つだけ削除します。
void | insert(Collection models) 単位の基本モデルを複数挿入します。
void | insert(UnitBaseModel model) 単位の基本モデルを1つだけ挿入します。
UnitBaseModel | select(String unitCode) プライマリーキーで特定される単位の基本モデルを取得します。
void | update(Collection models) 単位の基本モデルを複数更新します。
void | update(UnitBaseModel model) 単位の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public UnitBaseModel create(String unitCode)
                     throws MapperException
プライマリキーに該当する単位を生成します。

パラメータ:
unitCode - 単位コード
戻り値:
プライマリキーに該当する単位の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public UnitBaseModel select(String unitCode)
                     throws MapperException
プライマリーキーで特定される単位の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
unitCode - 単位コード
戻り値:
単位の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(UnitBaseModel model)
            throws MapperException
単位の基本モデルを1つだけ挿入します。 引数に指定する単位の基本モデルは同一の UnitMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入する単位の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
単位の基本モデルを複数挿入します。 引数に指定するものは同一の UnitMapperの create(String) で生成された単位の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する単位の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(UnitBaseModel model)
            throws MapperException
単位の基本モデルを1つだけ更新します。 引数に指定する単位の基本モデルは同一の UnitMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する単位の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
単位の基本モデルを複数更新します。 引数に指定するものは同一の UnitMapperの select 系メソッド から取得されたものかで生成された単位の基本モデルの集合である必要があります。

パラメータ:
models - 更新する単位の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(UnitBaseModel model)
            throws MapperException
単位の基本モデルを1つだけ削除します。 引数で指定された単位の基本モデルに該当するデータのすべての情報を削除します。引数に指定する単位の基本モデルは同一の UnitMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する単位の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
単位の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する単位の基本モデルは同一の UnitMapperの select 系メソッド から取得された単位の基本モデルの集合である必要があります。

パラメータ:
models - 削除する単位の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の使用

UserBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.user ユーザ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.user での UserBaseModel の使用

UserBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.user のメソッド
UserBaseModel | UserMapper.create(String userCode) プライマリキーに該当するユーザを生成します。
UserBaseModel | UserMapper.select(String userCode) プライマリーキーで特定されるユーザの基本モデルを取得します。

UserBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.user のメソッド
void | UserMapper.insert(UserBaseModel model) ユーザの基本モデルを1つだけ挿入します。
void | UserMapper.update(UserBaseModel model) ユーザの基本モデルを1つだけ更新します。
void | UserMapper.delete(UserBaseModel model) ユーザの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel の使用

UserTerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.user ユーザ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.user での UserTerminableInternationalModel の使用

UserTerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.user のメソッド
 UserTerminableInternationalModel UserTerminableModel.selectUserTerminableInternationalModel(Locale locale)
指定された言語に該当するユーザの期間国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel の使用

UserTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.user ユーザ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.user での UserTerminableModel の使用

UserTerminableModel を返す jp.co.intra_mart.foundation.datastore.application.model.user のメソッド
 UserTerminableModel UserBaseModel.selectUserTerminableModel(Date date)
指定された日付に該当するユーザの期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.user (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.application.model.user
インタフェース
UserBaseModel
UserMapper
UserTerminableInternationalModel
UserTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.user (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.user

ユーザ情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
UserBaseModel | ユーザの基本モデルです。
UserMapper | ユーザに関連するマッパです。
UserTerminableInternationalModel | ユーザの期間国際化モデルです。
UserTerminableModel | ユーザの期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.user の説明

ユーザ情報を操作するマッパーとモデルを提供します。


jp.co.intra_mart.foundation.datastore.application.model.user クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.user の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel


パッケージ jp.co.intra_mart.foundation.datastore.application.model.user の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.user の使用

jp.co.intra_mart.foundation.datastore.application.model.user を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.user ユーザ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.user により使用される jp.co.intra_mart.foundation.datastore.application.model.user のクラス
UserBaseModel
ユーザの基本モデルです。
UserTerminableInternationalModel
ユーザの期間国際化モデルです。
UserTerminableModel
ユーザの期間化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


UserBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.user
インタフェース UserBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface UserBaseModel
extends BaseModel

ユーザの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | ACCOUNT_FLAG アカウントフラグ
static String | ADDRESS 住所
static String | AVALIABLE_LOGIN_USER ログインできるアカウントを表す定数
static String | COUNTRY_CODE 国コード
static String | EMAIL_ADDRESS1 メールアドレス１
static String | EMAIL_ADDRESS2 メールアドレス２
static String | EXTENSION_FAX_NUMBER 内線FAX番号
static String | EXTENSION_NUMBER 内線番号
static String | FAX_NUMBER FAX番号
static String | MOBILE_EMAIL_ADDRESS 携帯用メール
static String | MOBILE_NUMBER 携帯電話番号
static String | NAME ユーザ名
static String | NAME_ENGLISH ユーザ名英字
static String | NAME_SYLLABARY ユーザ名カナ
static String | NOTES 備考
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
static String | TELEPHONE_NUMBER 電話番号
static String | UNAVALIABLE_LOGIN_USER ログイン出来ないアカウントを表す定数
static String | URL URL
static String | USER_CODE ユーザコード
static String | ZIP_CODE 郵便番号
メソッドの概要
String | getAccountFlag() アカウントフラグを取得します。
String | getAddress() 住所を取得します。
String | getAddress(Date date) 住所を取得します。
String | getAddress(Date date, Locale locale) 住所を取得します。
String | getAddress(Locale locale) 住所を取得します。
String | getCountryCode() 国コードを取得します。
String | getCountryCode(Date date) 国コードを取得します。
String | getEmailAddress1() メールアドレス１を取得します。
String | getEmailAddress1(Date date) メールアドレス１を取得します。
String | getEmailAddress2() メールアドレス２を取得します。
String | getEmailAddress2(Date date) メールアドレス２を取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionFaxNumber(Date date) 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getExtensionNumber(Date date) 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
String | getFaxNumber(Date date) FAX番号を取得します。
String | getMobileEmailAddress() 携帯用メールを取得します。
String | getMobileEmailAddress(Date date) 携帯用メールを取得します。
String | getMobileNumber() 携帯電話番号を取得します。
String | getMobileNumber(Date date) 携帯電話番号を取得します。
String | getName() ユーザ名を取得します。
String | getName(Date date) ユーザ名を取得します。
String | getName(Date date, Locale locale) ユーザ名を取得します。
String | getName(Locale locale) ユーザ名を取得します。
String | getNameEnglish() ユーザ名英字を取得します。
String | getNameEnglish(Date date) ユーザ名英字を取得します。
String | getNameEnglish(Date date, Locale locale) ユーザ名英字を取得します。
String | getNameEnglish(Locale locale) ユーザ名英字を取得します。
String | getNameSyllabary() ユーザ名カナを取得します。
String | getNameSyllabary(Date date) ユーザ名カナを取得します。
String | getNameSyllabary(Date date, Locale locale) ユーザ名カナを取得します。
String | getNameSyllabary(Locale locale) ユーザ名カナを取得します。
String | getNotes() 備考を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getTelephoneNumber(Date date) 電話番号を取得します。
String | getUrl() URLを取得します。
String | getUrl(Date date) URLを取得します。
String | getUserCode() ユーザコードを取得します。
String | getZipCode() 郵便番号を取得します。
String | getZipCode(Date date) 郵便番号を取得します。
UserTerminableModel | selectUserTerminableModel(Date date) 指定された日付に該当するユーザの期間化モデルを取得します。
void | setAccountFlag(String accountFlag) アカウントフラグを設定します。
void | setAddress(String address) 住所を設定します。
void | setAddress(String address, Date date) 住所を設定します。
void | setAddress(String address, Date date, Locale locale) 住所を設定します。
void | setAddress(String address, Locale locale) 住所を設定します。
void | setCountryCode(String countryCode) 国コードを設定します。
void | setCountryCode(String countryCode, Date date) 国コードを設定します。
void | setEmailAddress1(String emailAddress1) メールアドレス１を設定します。
void | setEmailAddress1(String emailAddress1, Date date) メールアドレス１を設定します。
void | setEmailAddress2(String emailAddress2) メールアドレス２を設定します。
void | setEmailAddress2(String emailAddress2, Date date) メールアドレス２を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber, Date date) 内線FAX番号を設定します。
void | setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | setExtensionNumber(String extensionNumber, Date date) 内線番号を設定します。
void | setFaxNumber(String faxNumber) FAX番号を設定します。
void | setFaxNumber(String faxNumber, Date date) FAX番号を設定します。
void | setMobileEmailAddress(String mobileEmailAddress) 携帯用メールを設定します。
void | setMobileEmailAddress(String mobileEmailAddress, Date date) 携帯用メールを設定します。
void | setMobileNumber(String mobileNumber) 携帯電話番号を設定します。
void | setMobileNumber(String mobileNumber, Date date) 携帯電話番号を設定します。
void | setName(String name) ユーザ名を設定します。
void | setName(String name, Date date) ユーザ名を設定します。
void | setName(String name, Date date, Locale locale) ユーザ名を設定します。
void | setName(String name, Locale locale) ユーザ名を設定します。
void | setNameEnglish(String nameEnglish) ユーザ名英字を設定します。
void | setNameEnglish(String nameEnglish, Date date) ユーザ名英字を設定します。
void | setNameEnglish(String nameEnglish, Date date, Locale locale) ユーザ名英字を設定します。
void | setNameEnglish(String nameEnglish, Locale locale) ユーザ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) ユーザ名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Date date) ユーザ名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Date date, Locale locale) ユーザ名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Locale locale) ユーザ名カナを設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
void | setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | setTelephoneNumber(String telephoneNumber, Date date) 電話番号を設定します。
void | setUrl(String url) URLを設定します。
void | setUrl(String url, Date date) URLを設定します。
void | setZipCode(String zipCode) 郵便番号を設定します。
void | setZipCode(String zipCode, Date date) 郵便番号を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

USER_CODE

public static final String USER_CODE
ユーザコード

関連項目:
定数フィールド値

ACCOUNT_FLAG

public static final String ACCOUNT_FLAG
アカウントフラグ

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

TELEPHONE_NUMBER

public static final String TELEPHONE_NUMBER
電話番号

関連項目:
定数フィールド値

MOBILE_NUMBER

public static final String MOBILE_NUMBER
携帯電話番号

関連項目:
定数フィールド値

FAX_NUMBER

public static final String FAX_NUMBER
FAX番号

関連項目:
定数フィールド値

EXTENSION_NUMBER

public static final String EXTENSION_NUMBER
内線番号

関連項目:
定数フィールド値

EXTENSION_FAX_NUMBER

public static final String EXTENSION_FAX_NUMBER
内線FAX番号

関連項目:
定数フィールド値

COUNTRY_CODE

public static final String COUNTRY_CODE
国コード

関連項目:
定数フィールド値

ZIP_CODE

public static final String ZIP_CODE
郵便番号

関連項目:
定数フィールド値

EMAIL_ADDRESS1

public static final String EMAIL_ADDRESS1
メールアドレス１

関連項目:
定数フィールド値

EMAIL_ADDRESS2

public static final String EMAIL_ADDRESS2
メールアドレス２

関連項目:
定数フィールド値

MOBILE_EMAIL_ADDRESS

public static final String MOBILE_EMAIL_ADDRESS
携帯用メール

関連項目:
定数フィールド値

URL

public static final String URL
URL

関連項目:
定数フィールド値

NAME

public static final String NAME
ユーザ名

関連項目:
定数フィールド値

NAME_SYLLABARY

public static final String NAME_SYLLABARY
ユーザ名カナ

関連項目:
定数フィールド値

NAME_ENGLISH

public static final String NAME_ENGLISH
ユーザ名英字

関連項目:
定数フィールド値

ADDRESS

public static final String ADDRESS
住所

関連項目:
定数フィールド値

UNAVALIABLE_LOGIN_USER

public static final String UNAVALIABLE_LOGIN_USER
ログイン出来ないアカウントを表す定数

関連項目:
定数フィールド値

AVALIABLE_LOGIN_USER

public static final String AVALIABLE_LOGIN_USER
ログインできるアカウントを表す定数

関連項目:
定数フィールド値
メソッドの詳細

getUserCode

public String getUserCode()
                   throws AccessorException
ユーザコードを取得します。

戻り値:
ユーザコード
例外:
AccessorException - データの取得に失敗した場合

getAccountFlag

public String getAccountFlag()
                      throws AccessorException
アカウントフラグを取得します。

戻り値:
アカウントフラグ
例外:
AccessorException - データの取得に失敗した場合

setAccountFlag

public void setAccountFlag(String accountFlag)
                    throws AccessorException
アカウントフラグを設定します。

パラメータ:
accountFlag - アカウントフラグ
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getTelephoneNumber

public String getTelephoneNumber()
                          throws AccessorException
電話番号を取得します。

戻り値:
電話番号
例外:
AccessorException - データの取得に失敗した場合

getTelephoneNumber

public String getTelephoneNumber(Date date)
                          throws AccessorException
電話番号を取得します。

パラメータ:
date - 日時
戻り値:
電話番号
例外:
AccessorException - データの取得に失敗した場合

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber)
                        throws AccessorException
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号
例外:
AccessorException - データの設定に失敗した場合

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber,
                               Date date)
                        throws AccessorException
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getMobileNumber

public String getMobileNumber()
                       throws AccessorException
携帯電話番号を取得します。

戻り値:
携帯電話番号
例外:
AccessorException - データの取得に失敗した場合

getMobileNumber

public String getMobileNumber(Date date)
                       throws AccessorException
携帯電話番号を取得します。

パラメータ:
date - 日時
戻り値:
携帯電話番号
例外:
AccessorException - データの取得に失敗した場合

setMobileNumber

public void setMobileNumber(String mobileNumber)
                     throws AccessorException
携帯電話番号を設定します。

パラメータ:
mobileNumber - 携帯電話番号
例外:
AccessorException - データの設定に失敗した場合

setMobileNumber

public void setMobileNumber(String mobileNumber,
                            Date date)
                     throws AccessorException
携帯電話番号を設定します。

パラメータ:
mobileNumber - 携帯電話番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getFaxNumber

public String getFaxNumber()
                    throws AccessorException
FAX番号を取得します。

戻り値:
FAX番号
例外:
AccessorException - データの取得に失敗した場合

getFaxNumber

public String getFaxNumber(Date date)
                    throws AccessorException
FAX番号を取得します。

パラメータ:
date - 日時
戻り値:
FAX番号
例外:
AccessorException - データの取得に失敗した場合

setFaxNumber

public void setFaxNumber(String faxNumber)
                  throws AccessorException
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号
例外:
AccessorException - データの設定に失敗した場合

setFaxNumber

public void setFaxNumber(String faxNumber,
                         Date date)
                  throws AccessorException
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getExtensionNumber

public String getExtensionNumber()
                          throws AccessorException
内線番号を取得します。

戻り値:
内線番号
例外:
AccessorException - データの取得に失敗した場合

getExtensionNumber

public String getExtensionNumber(Date date)
                          throws AccessorException
内線番号を取得します。

パラメータ:
date - 日時
戻り値:
内線番号
例外:
AccessorException - データの取得に失敗した場合

setExtensionNumber

public void setExtensionNumber(String extensionNumber)
                        throws AccessorException
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号
例外:
AccessorException - データの設定に失敗した場合

setExtensionNumber

public void setExtensionNumber(String extensionNumber,
                               Date date)
                        throws AccessorException
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getExtensionFaxNumber

public String getExtensionFaxNumber()
                             throws AccessorException
内線FAX番号を取得します。

戻り値:
内線FAX番号
例外:
AccessorException - データの取得に失敗した場合

getExtensionFaxNumber

public String getExtensionFaxNumber(Date date)
                             throws AccessorException
内線FAX番号を取得します。

パラメータ:
date - 日時
戻り値:
内線FAX番号
例外:
AccessorException - データの取得に失敗した場合

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber)
                           throws AccessorException
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号
例外:
AccessorException - データの設定に失敗した場合

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber,
                                  Date date)
                           throws AccessorException
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getCountryCode

public String getCountryCode()
                      throws AccessorException
国コードを取得します。

戻り値:
国コード
例外:
AccessorException - データの取得に失敗した場合

getCountryCode

public String getCountryCode(Date date)
                      throws AccessorException
国コードを取得します。

パラメータ:
date - 日時
戻り値:
国コード
例外:
AccessorException - データの取得に失敗した場合

setCountryCode

public void setCountryCode(String countryCode)
                    throws AccessorException
国コードを設定します。

パラメータ:
countryCode - 国コード
例外:
AccessorException - データの設定に失敗した場合

setCountryCode

public void setCountryCode(String countryCode,
                           Date date)
                    throws AccessorException
国コードを設定します。

パラメータ:
countryCode - 国コード
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getZipCode

public String getZipCode()
                  throws AccessorException
郵便番号を取得します。

戻り値:
郵便番号
例外:
AccessorException - データの取得に失敗した場合

getZipCode

public String getZipCode(Date date)
                  throws AccessorException
郵便番号を取得します。

パラメータ:
date - 日時
戻り値:
郵便番号
例外:
AccessorException - データの取得に失敗した場合

setZipCode

public void setZipCode(String zipCode)
                throws AccessorException
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号
例外:
AccessorException - データの設定に失敗した場合

setZipCode

public void setZipCode(String zipCode,
                       Date date)
                throws AccessorException
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getEmailAddress1

public String getEmailAddress1()
                        throws AccessorException
メールアドレス１を取得します。

戻り値:
メールアドレス１
例外:
AccessorException - データの取得に失敗した場合

getEmailAddress1

public String getEmailAddress1(Date date)
                        throws AccessorException
メールアドレス１を取得します。

パラメータ:
date - 日時
戻り値:
メールアドレス１
例外:
AccessorException - データの取得に失敗した場合

setEmailAddress1

public void setEmailAddress1(String emailAddress1)
                      throws AccessorException
メールアドレス１を設定します。

パラメータ:
emailAddress1 - メールアドレス１
例外:
AccessorException - データの設定に失敗した場合

setEmailAddress1

public void setEmailAddress1(String emailAddress1,
                             Date date)
                      throws AccessorException
メールアドレス１を設定します。

パラメータ:
emailAddress1 - メールアドレス１
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getEmailAddress2

public String getEmailAddress2()
                        throws AccessorException
メールアドレス２を取得します。

戻り値:
メールアドレス２
例外:
AccessorException - データの取得に失敗した場合

getEmailAddress2

public String getEmailAddress2(Date date)
                        throws AccessorException
メールアドレス２を取得します。

パラメータ:
date - 日時
戻り値:
メールアドレス２
例外:
AccessorException - データの取得に失敗した場合

setEmailAddress2

public void setEmailAddress2(String emailAddress2)
                      throws AccessorException
メールアドレス２を設定します。

パラメータ:
emailAddress2 - メールアドレス２
例外:
AccessorException - データの設定に失敗した場合

setEmailAddress2

public void setEmailAddress2(String emailAddress2,
                             Date date)
                      throws AccessorException
メールアドレス２を設定します。

パラメータ:
emailAddress2 - メールアドレス２
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getMobileEmailAddress

public String getMobileEmailAddress()
                             throws AccessorException
携帯用メールを取得します。

戻り値:
携帯用メール
例外:
AccessorException - データの取得に失敗した場合

getMobileEmailAddress

public String getMobileEmailAddress(Date date)
                             throws AccessorException
携帯用メールを取得します。

パラメータ:
date - 日時
戻り値:
携帯用メール
例外:
AccessorException - データの取得に失敗した場合

setMobileEmailAddress

public void setMobileEmailAddress(String mobileEmailAddress)
                           throws AccessorException
携帯用メールを設定します。

パラメータ:
mobileEmailAddress - 携帯用メール
例外:
AccessorException - データの設定に失敗した場合

setMobileEmailAddress

public void setMobileEmailAddress(String mobileEmailAddress,
                                  Date date)
                           throws AccessorException
携帯用メールを設定します。

パラメータ:
mobileEmailAddress - 携帯用メール
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getUrl

public String getUrl()
              throws AccessorException
URLを取得します。

戻り値:
URL
例外:
AccessorException - データの取得に失敗した場合

getUrl

public String getUrl(Date date)
              throws AccessorException
URLを取得します。

パラメータ:
date - 日時
戻り値:
URL
例外:
AccessorException - データの取得に失敗した場合

setUrl

public void setUrl(String url)
            throws AccessorException
URLを設定します。

パラメータ:
url - URL
例外:
AccessorException - データの設定に失敗した場合

setUrl

public void setUrl(String url,
                   Date date)
            throws AccessorException
URLを設定します。

パラメータ:
url - URL
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getName

public String getName()
               throws AccessorException
ユーザ名を取得します。

戻り値:
ユーザ名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Date date)
               throws AccessorException
ユーザ名を取得します。

パラメータ:
date - 日時
戻り値:
ユーザ名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
ユーザ名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザ名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Date date,
                      Locale locale)
               throws AccessorException
ユーザ名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
ユーザ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
ユーザ名を設定します。

パラメータ:
name - ユーザ名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Date date)
             throws AccessorException
ユーザ名を設定します。

パラメータ:
name - ユーザ名
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
ユーザ名を設定します。

パラメータ:
name - ユーザ名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Date date,
                    Locale locale)
             throws AccessorException
ユーザ名を設定します。

パラメータ:
name - ユーザ名
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
ユーザ名カナを取得します。

戻り値:
ユーザ名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Date date)
                        throws AccessorException
ユーザ名カナを取得します。

パラメータ:
date - 日時
戻り値:
ユーザ名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Locale locale)
                        throws AccessorException
ユーザ名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザ名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Date date,
                               Locale locale)
                        throws AccessorException
ユーザ名カナを取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
ユーザ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
ユーザ名カナを設定します。

パラメータ:
nameSyllabary - ユーザ名カナ
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Date date)
                      throws AccessorException
ユーザ名カナを設定します。

パラメータ:
nameSyllabary - ユーザ名カナ
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Locale locale)
                      throws AccessorException
ユーザ名カナを設定します。

パラメータ:
nameSyllabary - ユーザ名カナ
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Date date,
                             Locale locale)
                      throws AccessorException
ユーザ名カナを設定します。

パラメータ:
nameSyllabary - ユーザ名カナ
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
ユーザ名英字を取得します。

戻り値:
ユーザ名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Date date)
                      throws AccessorException
ユーザ名英字を取得します。

パラメータ:
date - 日時
戻り値:
ユーザ名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Locale locale)
                      throws AccessorException
ユーザ名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザ名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Date date,
                             Locale locale)
                      throws AccessorException
ユーザ名英字を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
ユーザ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
ユーザ名英字を設定します。

パラメータ:
nameEnglish - ユーザ名英字
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Date date)
                    throws AccessorException
ユーザ名英字を設定します。

パラメータ:
nameEnglish - ユーザ名英字
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Locale locale)
                    throws AccessorException
ユーザ名英字を設定します。

パラメータ:
nameEnglish - ユーザ名英字
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Date date,
                           Locale locale)
                    throws AccessorException
ユーザ名英字を設定します。

パラメータ:
nameEnglish - ユーザ名英字
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getAddress

public String getAddress()
                  throws AccessorException
住所を取得します。

戻り値:
住所
例外:
AccessorException - データの取得に失敗した場合

getAddress

public String getAddress(Date date)
                  throws AccessorException
住所を取得します。

パラメータ:
date - 日時
戻り値:
住所
例外:
AccessorException - データの取得に失敗した場合

getAddress

public String getAddress(Locale locale)
                  throws AccessorException
住所を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所
例外:
AccessorException - データの取得に失敗した場合

getAddress

public String getAddress(Date date,
                         Locale locale)
                  throws AccessorException
住所を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
住所
例外:
AccessorException - データの取得に失敗した場合

setAddress

public void setAddress(String address)
                throws AccessorException
住所を設定します。

パラメータ:
address - 住所
例外:
AccessorException - データの設定に失敗した場合

setAddress

public void setAddress(String address,
                       Date date)
                throws AccessorException
住所を設定します。

パラメータ:
address - 住所
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setAddress

public void setAddress(String address,
                       Locale locale)
                throws AccessorException
住所を設定します。

パラメータ:
address - 住所
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setAddress

public void setAddress(String address,
                       Date date,
                       Locale locale)
                throws AccessorException
住所を設定します。

パラメータ:
address - 住所
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectUserTerminableModel

public UserTerminableModel selectUserTerminableModel(Date date)
                                              throws IllegalTermException
指定された日付に該当するユーザの期間化モデルを取得します。

パラメータ:
date - 指定日付
戻り値:
ユーザの期間化モデル
例外:
IllegalTermException - 指定された日付に該当する期間が定義されていない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UserMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.user
インタフェース UserMapper

すべてのスーパーインタフェース:
Mapper
public interface UserMapper
extends Mapper

ユーザに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
UserBaseModel | create(String userCode) プライマリキーに該当するユーザを生成します。
void | delete(Collection models) ユーザの基本モデルを複数削除します。
void | delete(UserBaseModel model) ユーザの基本モデルを1つだけ削除します。
void | insert(Collection models) ユーザの基本モデルを複数挿入します。
void | insert(UserBaseModel model) ユーザの基本モデルを1つだけ挿入します。
UserBaseModel | select(String userCode) プライマリーキーで特定されるユーザの基本モデルを取得します。
void | update(Collection models) ユーザの基本モデルを複数更新します。
void | update(UserBaseModel model) ユーザの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public UserBaseModel create(String userCode)
                     throws MapperException
プライマリキーに該当するユーザを生成します。

パラメータ:
userCode - ユーザコード
戻り値:
プライマリキーに該当するユーザの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public UserBaseModel select(String userCode)
                     throws MapperException
プライマリーキーで特定されるユーザの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
userCode - ユーザコード
戻り値:
ユーザの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(UserBaseModel model)
            throws MapperException
ユーザの基本モデルを1つだけ挿入します。 引数に指定するユーザの基本モデルは同一の UserMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入するユーザの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
ユーザの基本モデルを複数挿入します。 引数に指定するものは同一の UserMapperの create(String) で生成されたユーザの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するユーザの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(UserBaseModel model)
            throws MapperException
ユーザの基本モデルを1つだけ更新します。 引数に指定するユーザの基本モデルは同一の UserMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するユーザの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
ユーザの基本モデルを複数更新します。 引数に指定するものは同一の UserMapperの select 系メソッド から取得されたものかで生成されたユーザの基本モデルの集合である必要があります。

パラメータ:
models - 更新するユーザの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(UserBaseModel model)
            throws MapperException
ユーザの基本モデルを1つだけ削除します。 引数で指定されたユーザの基本モデルに該当するデータのすべての情報を削除します。引数に指定するユーザの基本モデルは同一の UserMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するユーザの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
ユーザの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するユーザの基本モデルは同一の UserMapperの select 系メソッド から取得されたユーザの基本モデルの集合である必要があります。

パラメータ:
models - 削除するユーザの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserTerminableInternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.user
インタフェース UserTerminableInternationalModel

すべてのスーパーインタフェース:
Serializable, TerminableInternationalModel
public interface UserTerminableInternationalModel
extends TerminableInternationalModel

ユーザの期間国際化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getAddress() 住所を取得します。
String | getName() ユーザ名を取得します。
String | getNameEnglish() ユーザ名英字を取得します。
String | getNameSyllabary() ユーザ名カナを取得します。
void | setAddress(String address) 住所を設定します。
void | setName(String name) ユーザ名を設定します。
void | setNameEnglish(String nameEnglish) ユーザ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) ユーザ名カナを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel から継承したメソッド
getExtendedTerminableInternationalModelMap, getLocale, init

メソッドの詳細

getName

public String getName()
               throws AccessorException
ユーザ名を取得します。

戻り値:
ユーザ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
ユーザ名を設定します。

パラメータ:
name - ユーザ名
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
ユーザ名カナを取得します。

戻り値:
ユーザ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
ユーザ名カナを設定します。

パラメータ:
nameSyllabary - ユーザ名カナ
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
ユーザ名英字を取得します。

戻り値:
ユーザ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
ユーザ名英字を設定します。

パラメータ:
nameEnglish - ユーザ名英字
例外:
AccessorException - データの設定に失敗した場合

getAddress

public String getAddress()
                  throws AccessorException
住所を取得します。

戻り値:
住所
例外:
AccessorException - データの取得に失敗した場合

setAddress

public void setAddress(String address)
                throws AccessorException
住所を設定します。

パラメータ:
address - 住所
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserTerminableModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.user
インタフェース UserTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface UserTerminableModel
extends TerminableModel

ユーザの期間化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getAddress() 住所を取得します。
String | getAddress(Locale locale) 住所を取得します。
String | getCountryCode() 国コードを取得します。
String | getEmailAddress1() メールアドレス１を取得します。
String | getEmailAddress2() メールアドレス２を取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
String | getMobileEmailAddress() 携帯用メールを取得します。
String | getMobileNumber() 携帯電話番号を取得します。
String | getName() ユーザ名を取得します。
String | getName(Locale locale) ユーザ名を取得します。
String | getNameEnglish() ユーザ名英字を取得します。
String | getNameEnglish(Locale locale) ユーザ名英字を取得します。
String | getNameSyllabary() ユーザ名カナを取得します。
String | getNameSyllabary(Locale locale) ユーザ名カナを取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getUrl() URLを取得します。
String | getZipCode() 郵便番号を取得します。
UserTerminableInternationalModel | selectUserTerminableInternationalModel(Locale locale) 指定された言語に該当するユーザの期間国際化モデルを取得します。
void | setAddress(String address) 住所を設定します。
void | setAddress(String address, Locale locale) 住所を設定します。
void | setCountryCode(String countryCode) 国コードを設定します。
void | setEmailAddress1(String emailAddress1) メールアドレス１を設定します。
void | setEmailAddress2(String emailAddress2) メールアドレス２を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | setFaxNumber(String faxNumber) FAX番号を設定します。
void | setMobileEmailAddress(String mobileEmailAddress) 携帯用メールを設定します。
void | setMobileNumber(String mobileNumber) 携帯電話番号を設定します。
void | setName(String name) ユーザ名を設定します。
void | setName(String name, Locale locale) ユーザ名を設定します。
void | setNameEnglish(String nameEnglish) ユーザ名英字を設定します。
void | setNameEnglish(String nameEnglish, Locale locale) ユーザ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) ユーザ名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Locale locale) ユーザ名カナを設定します。
void | setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | setUrl(String url) URLを設定します。
void | setZipCode(String zipCode) 郵便番号を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

メソッドの詳細

getTelephoneNumber

public String getTelephoneNumber()
                          throws AccessorException
電話番号を取得します。

戻り値:
電話番号
例外:
AccessorException - データの取得に失敗した場合

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber)
                        throws AccessorException
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号
例外:
AccessorException - データの設定に失敗した場合

getMobileNumber

public String getMobileNumber()
                       throws AccessorException
携帯電話番号を取得します。

戻り値:
携帯電話番号
例外:
AccessorException - データの取得に失敗した場合

setMobileNumber

public void setMobileNumber(String mobileNumber)
                     throws AccessorException
携帯電話番号を設定します。

パラメータ:
mobileNumber - 携帯電話番号
例外:
AccessorException - データの設定に失敗した場合

getFaxNumber

public String getFaxNumber()
                    throws AccessorException
FAX番号を取得します。

戻り値:
FAX番号
例外:
AccessorException - データの取得に失敗した場合

setFaxNumber

public void setFaxNumber(String faxNumber)
                  throws AccessorException
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号
例外:
AccessorException - データの設定に失敗した場合

getExtensionNumber

public String getExtensionNumber()
                          throws AccessorException
内線番号を取得します。

戻り値:
内線番号
例外:
AccessorException - データの取得に失敗した場合

setExtensionNumber

public void setExtensionNumber(String extensionNumber)
                        throws AccessorException
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号
例外:
AccessorException - データの設定に失敗した場合

getExtensionFaxNumber

public String getExtensionFaxNumber()
                             throws AccessorException
内線FAX番号を取得します。

戻り値:
内線FAX番号
例外:
AccessorException - データの取得に失敗した場合

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber)
                           throws AccessorException
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号
例外:
AccessorException - データの設定に失敗した場合

getCountryCode

public String getCountryCode()
                      throws AccessorException
国コードを取得します。

戻り値:
国コード
例外:
AccessorException - データの取得に失敗した場合

setCountryCode

public void setCountryCode(String countryCode)
                    throws AccessorException
国コードを設定します。

パラメータ:
countryCode - 国コード
例外:
AccessorException - データの設定に失敗した場合

getZipCode

public String getZipCode()
                  throws AccessorException
郵便番号を取得します。

戻り値:
郵便番号
例外:
AccessorException - データの取得に失敗した場合

setZipCode

public void setZipCode(String zipCode)
                throws AccessorException
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号
例外:
AccessorException - データの設定に失敗した場合

getEmailAddress1

public String getEmailAddress1()
                        throws AccessorException
メールアドレス１を取得します。

戻り値:
メールアドレス１
例外:
AccessorException - データの取得に失敗した場合

setEmailAddress1

public void setEmailAddress1(String emailAddress1)
                      throws AccessorException
メールアドレス１を設定します。

パラメータ:
emailAddress1 - メールアドレス１
例外:
AccessorException - データの設定に失敗した場合

getEmailAddress2

public String getEmailAddress2()
                        throws AccessorException
メールアドレス２を取得します。

戻り値:
メールアドレス２
例外:
AccessorException - データの取得に失敗した場合

setEmailAddress2

public void setEmailAddress2(String emailAddress2)
                      throws AccessorException
メールアドレス２を設定します。

パラメータ:
emailAddress2 - メールアドレス２
例外:
AccessorException - データの設定に失敗した場合

getMobileEmailAddress

public String getMobileEmailAddress()
                             throws AccessorException
携帯用メールを取得します。

戻り値:
携帯用メール
例外:
AccessorException - データの取得に失敗した場合

setMobileEmailAddress

public void setMobileEmailAddress(String mobileEmailAddress)
                           throws AccessorException
携帯用メールを設定します。

パラメータ:
mobileEmailAddress - 携帯用メール
例外:
AccessorException - データの設定に失敗した場合

getUrl

public String getUrl()
              throws AccessorException
URLを取得します。

戻り値:
URL
例外:
AccessorException - データの取得に失敗した場合

setUrl

public void setUrl(String url)
            throws AccessorException
URLを設定します。

パラメータ:
url - URL
例外:
AccessorException - データの設定に失敗した場合

getName

public String getName()
               throws AccessorException
ユーザ名を取得します。

戻り値:
ユーザ名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
ユーザ名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
ユーザ名を設定します。

パラメータ:
name - ユーザ名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
ユーザ名を設定します。

パラメータ:
name - ユーザ名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
ユーザ名カナを取得します。

戻り値:
ユーザ名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Locale locale)
                        throws AccessorException
ユーザ名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
ユーザ名カナを設定します。

パラメータ:
nameSyllabary - ユーザ名カナ
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Locale locale)
                      throws AccessorException
ユーザ名カナを設定します。

パラメータ:
nameSyllabary - ユーザ名カナ
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
ユーザ名英字を取得します。

戻り値:
ユーザ名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Locale locale)
                      throws AccessorException
ユーザ名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
ユーザ名英字を設定します。

パラメータ:
nameEnglish - ユーザ名英字
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Locale locale)
                    throws AccessorException
ユーザ名英字を設定します。

パラメータ:
nameEnglish - ユーザ名英字
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getAddress

public String getAddress()
                  throws AccessorException
住所を取得します。

戻り値:
住所
例外:
AccessorException - データの取得に失敗した場合

getAddress

public String getAddress(Locale locale)
                  throws AccessorException
住所を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所
例外:
AccessorException - データの取得に失敗した場合

setAddress

public void setAddress(String address)
                throws AccessorException
住所を設定します。

パラメータ:
address - 住所
例外:
AccessorException - データの設定に失敗した場合

setAddress

public void setAddress(String address,
                       Locale locale)
                throws AccessorException
住所を設定します。

パラメータ:
address - 住所
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectUserTerminableInternationalModel

public UserTerminableInternationalModel selectUserTerminableInternationalModel(Locale locale)
                                                                        throws IllegalLocaleException
指定された言語に該当するユーザの期間国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザの期間国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor の使用

BaseAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での BaseAccessor の使用

BaseAccessor を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
BaseAccessor | TerminableAccessor.getBaseAccessor() この期間化アクセサが所属する基本アクセサを取得します。
BaseAccessor | InternationalAccessor.getBaseAccessor() この国際化アクセサが所属する基本アクセサを取得します。
BaseAccessor | ExtendedBaseAccessor.getBaseAccessor() 拡張元となる基本エンティティの基本アクセサを取得します。

jp.co.intra_mart.foundation.datastore.common.model での BaseAccessor の使用

BaseAccessor を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
protected BaseAccessor | IntramartDBMapper.createBaseAccessor(Map primary) このマッパーに該当する基本アクセサを新規に生成します。
BaseAccessor | GenericBaseModel.getBaseAccessor() この基本モデルに割り当てられた基本アクセサを取得します。
BaseAccessor | BaseModelContext.getBaseAccessor() 基本アクセサを取得します。
BaseAccessor | BaseModel.getBaseAccessor() 基本アクセサ BaseAccessor を取得します。

BaseAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void BaseModelContext.setBaseAccessor(BaseAccessor accessor)
基本アクセサを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor の使用

ExtendedBaseAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での ExtendedBaseAccessor の使用

ExtendedBaseAccessor を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
ExtendedBaseAccessor | ExtendedBaseAccessorMap.createExtendedBaseAccessor(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を生成します。
ExtendedBaseAccessor | ExtendedBaseAccessorMap.findExtendedBaseAccessor(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を取得します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedBaseAccessor の使用

ExtendedBaseAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | ExtendedGenericBaseModel.init(ExtendedBaseAccessor accessor) 拡張基本モデルを初期化します。
void | ExtendedBaseModel.init(ExtendedBaseAccessor accessor) 拡張基本モデルを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap の使用

ExtendedBaseAccessorMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での ExtendedBaseAccessorMap の使用

ExtendedBaseAccessorMap を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 ExtendedBaseAccessorMap BaseAccessor.getExtendedBaseAccessorMap()
基本アクセサに関連する拡張基本アクセサのマップを取得します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedBaseAccessorMap の使用

ExtendedBaseAccessorMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void ExtendedGenericBaseModelMap.init(ExtendedBaseAccessorMap accessorMap)
初期化を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor の使用

ExtendedInternationalAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での ExtendedInternationalAccessor の使用

ExtendedInternationalAccessor を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
ExtendedInternationalAccessor | ExtendedInternationalAccessorMap.createExtendedInternationalAccessor(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を生成します。
ExtendedInternationalAccessor | ExtendedInternationalAccessorMap.findExtendedInternationalAccessor(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を取得します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedInternationalAccessor の使用

ExtendedInternationalAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | ExtendedInternationalModel.init(ExtendedInternationalAccessor accessor) 拡張国際化モデルを初期化します。
void | ExtendedGenericInternationalModel.init(ExtendedInternationalAccessor accessor) 拡張国際化モデルを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap の使用

ExtendedInternationalAccessorMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での ExtendedInternationalAccessorMap の使用

ExtendedInternationalAccessorMap を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 ExtendedInternationalAccessorMap InternationalAccessor.getExtendedInternationalAccessorMap()
この国際化アクセサに対する拡張国際化アクセサのマップを取得します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedInternationalAccessorMap の使用

ExtendedInternationalAccessorMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void ExtendedGenericInternationalModelMap.init(ExtendedInternationalAccessorMap accessorMap)
初期化を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor の使用

ExtendedTerminableAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での ExtendedTerminableAccessor の使用

ExtendedTerminableAccessor を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
ExtendedTerminableAccessor | ExtendedTerminableAccessorMap.createExtendedTerminableAccessor(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を生成します。
ExtendedTerminableAccessor | ExtendedTerminableAccessorMap.findExtendedTerminableAccessor(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を取得します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedTerminableAccessor の使用

ExtendedTerminableAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | ExtendedTerminableModel.init(ExtendedTerminableAccessor accessor) 拡張期間化モデルを初期化します。
void | ExtendedGenericTerminableModel.init(ExtendedTerminableAccessor accessor) 拡張期間化モデルを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap の使用

ExtendedTerminableAccessorMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での ExtendedTerminableAccessorMap の使用

ExtendedTerminableAccessorMap を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 ExtendedTerminableAccessorMap TerminableAccessor.getExtendedTerminableAccessorMap()
この期間化アクセサに対する拡張期間化アクセサのマップを取得します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedTerminableAccessorMap の使用

ExtendedTerminableAccessorMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void ExtendedGenericTerminableModelMap.init(ExtendedTerminableAccessorMap accessorMap)
初期化を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor の使用

ExtendedTerminableInternationalAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での ExtendedTerminableInternationalAccessor の使用

ExtendedTerminableInternationalAccessor を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
ExtendedTerminableInternationalAccessor | ExtendedTerminableInternationalAccessorMap.createExtendedTerminableInternationalAccessor(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を生成します。
ExtendedTerminableInternationalAccessor | ExtendedTerminableInternationalAccessorMap.findExtendedTerminableInternationalAccessor(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を取得します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedTerminableInternationalAccessor の使用

ExtendedTerminableInternationalAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | ExtendedTerminableInternationalModel.init(ExtendedTerminableInternationalAccessor accessor) 拡張期間国際化モデルを初期化します。
void | ExtendedGenericTerminableInternationalModel.init(ExtendedTerminableInternationalAccessor accessor) 拡張期間国際化モデルを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap の使用

ExtendedTerminableInternationalAccessorMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での ExtendedTerminableInternationalAccessorMap の使用

ExtendedTerminableInternationalAccessorMap を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 ExtendedTerminableInternationalAccessorMap TerminableInternationalAccessor.getExtendedTerminableInternationalAccessorMap()
この期間国際化アクセサの拡張期間国際化アクセサのマップを取得します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedTerminableInternationalAccessorMap の使用

ExtendedTerminableInternationalAccessorMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void ExtendedGenericTerminableInternationalModelMap.init(ExtendedTerminableInternationalAccessorMap accessorMap)
初期化を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor の使用

InternationalAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での InternationalAccessor の使用

InternationalAccessor を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
InternationalAccessor | InternationalAccessorMap.createInternationalAccessor(Locale locale) 国際化アクセサを生成します。
InternationalAccessor | InternationalAccessorMap.findInternationalAccessor(Locale locale) 指定された言語に該当する国際化アクセサを取得します。
InternationalAccessor | ExtendedInternationalAccessor.getInternationalAccessor() 拡張もととなる国際化アクセサを取得します。

jp.co.intra_mart.foundation.datastore.common.model での InternationalAccessor の使用

InternationalAccessor を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
InternationalAccessor | InternationalModelContext.getInternationalAccessor() 国際化アクセサを取得します。
protected InternationalAccessor | GenericInternationalModel.getInternationalAccessor() この国際化モデルに割り当てられた国際化アクセサを取得します。

InternationalAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void InternationalModelContext.setInternationalAccessor(InternationalAccessor accessor)
国際化アクセサを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap の使用

InternationalAccessorMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での InternationalAccessorMap の使用

InternationalAccessorMap を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 InternationalAccessorMap BaseAccessor.getInternationalAccessorMap()
基本アクセサに関連する国際化アクセサのマップを取得します。

jp.co.intra_mart.foundation.datastore.common.model での InternationalAccessorMap の使用

InternationalAccessorMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void GenericInternationalModelMap.init(String modelName, InternationalAccessorMap accessorMap)
初期化処理を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor の使用

TerminableAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での TerminableAccessor の使用

TerminableAccessor を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
TerminableAccessor | TerminableInternationalAccessor.getTerminableAccessor() この期間国際化アクセサが所属する期間化アクセサを取得します。
TerminableAccessor | TerminableAccessorMap.createTerminableAccessor(Term term) 指定した期間に期間化アクセサを生成します。
TerminableAccessor | TerminableAccessorMap.findTerminableAccessor(Date date) 指定された日付に該当する期間化アクセサを取得します。
TerminableAccessor | ExtendedTerminableAccessor.getTerminableAccessor() 拡張もととなる期間化アクセサを取得します。

jp.co.intra_mart.foundation.datastore.common.model での TerminableAccessor の使用

TerminableAccessor を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableAccessor | TerminableModelContext.getTerminableAccessor() 期間化アクセサを取得します。
protected TerminableAccessor | GenericTerminableModel.getTerminableAccessor() この期間化モデルに割り当てられた期間化アクセサを取得します。

TerminableAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void TerminableModelContext.setTerminableAccessor(TerminableAccessor accessor)
期間化アクセサを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap の使用

TerminableAccessorMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での TerminableAccessorMap の使用

TerminableAccessorMap を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 TerminableAccessorMap BaseAccessor.getTerminableAccessorMap()
基本アクセサに関連する期間化アクセサのマップを取得します。

jp.co.intra_mart.foundation.datastore.common.model での TerminableAccessorMap の使用

TerminableAccessorMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void GenericTerminableModelMap.init(String terminableName, String terminableInternationalName, TerminableAccessorMap accessorMap, Locale defaultLocale)
初期化処理を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor の使用

TerminableInternationalAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での TerminableInternationalAccessor の使用

TerminableInternationalAccessor を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
TerminableInternationalAccessor | TerminableInternationalAccessorMap.createTerminableInternationalAccessor(Locale locale) 期間国際化アクセサを生成します。
TerminableInternationalAccessor | TerminableInternationalAccessorMap.findTerminableInternationalAccessor(Locale locale) 指定された言語に該当する期間国際化アクセサを取得します。
TerminableInternationalAccessor | ExtendedTerminableInternationalAccessor.getTerminableInternationalAccessor() 拡張もととなる期間国際化アクセサを取得します。

jp.co.intra_mart.foundation.datastore.common.model での TerminableInternationalAccessor の使用

TerminableInternationalAccessor を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableInternationalAccessor | TerminableInternationalModelContext.getTerminableInternationalAccessor() 期間国際化アクセサを取得します。
protected TerminableInternationalAccessor | GenericTerminableInternationalModel.getTerminableInternationalAccessor() この期間国際化モデルに割り当てられた期間国際化アクセサを取得します。

TerminableInternationalAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void TerminableInternationalModelContext.setTerminableInternationalAccessor(TerminableInternationalAccessor accessor)
期間国際化アクセサを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap の使用

TerminableInternationalAccessorMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での TerminableInternationalAccessorMap の使用

TerminableInternationalAccessorMap を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 TerminableInternationalAccessorMap TerminableAccessor.getTerminableInternationalAccessorMap()
この期間化アクセサに対する期間国際化アクセサのマップを取得します。

jp.co.intra_mart.foundation.datastore.common.model での TerminableInternationalAccessorMap の使用

TerminableInternationalAccessorMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void GenericTerminableInternationalModelMap.init(String modelName, TerminableInternationalAccessorMap accessorMap)
初期化処理を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BaseAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース BaseAccessor

すべてのスーパーインタフェース:
Serializable
public interface BaseAccessor
extends Serializable

基本エンティティに対する情報操作用のインタフェースです。 このクラスを通じて実際の基本エンティティに反映されます。

クローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • setProperty(String, Object)

導入されたバージョン:
5.0

メソッドの概要
Entity | getEntity() アクセサの基となるエンティティを取得します。
ExtendedBaseAccessorMap | getExtendedBaseAccessorMap() 基本アクセサに関連する拡張基本アクセサのマップを取得します。
InternationalAccessorMap | getInternationalAccessorMap() 基本アクセサに関連する国際化アクセサのマップを取得します。
Object | getProperty(String prop) プロパティを取得します。
TerminableAccessorMap | getTerminableAccessorMap() 基本アクセサに関連する期間化アクセサのマップを取得します。
boolean | isClosed() このアクセサがクローズされた状態かどうかを確認します。
void | setClosed() このアクセサをクローズします。
void | setProperty(String prop, Object value) プロパティを設定します。

メソッドの詳細

getEntity

public Entity getEntity()
アクセサの基となるエンティティを取得します。

戻り値:
アクセサの基となるエンティティ

getInternationalAccessorMap

public InternationalAccessorMap getInternationalAccessorMap()
基本アクセサに関連する国際化アクセサのマップを取得します。

戻り値:
国際化アクセサのマップ

getTerminableAccessorMap

public TerminableAccessorMap getTerminableAccessorMap()
基本アクセサに関連する期間化アクセサのマップを取得します。

戻り値:
期間化アクセサのマップ

getExtendedBaseAccessorMap

public ExtendedBaseAccessorMap getExtendedBaseAccessorMap()
基本アクセサに関連する拡張基本アクセサのマップを取得します。

戻り値:
拡張基本アクセサのマップ

getProperty

public Object getProperty(String prop)
                   throws DataNotFoundException
プロパティを取得します。

パラメータ:
prop - プロパティ名
戻り値:
プロパティの値
例外:
DataNotFoundException - 検索時に取得していないプロパティが指定された場合

setProperty

public void setProperty(String prop,
                        Object value)
                 throws AccessorClosedException,
                        AccessorIllegalPropertyValueException
プロパティを設定します。

パラメータ:
prop - プロパティ名
value - プロパティの値
例外:
AccessorIllegalPropertyValueException - プロパティの値が不正な場合
AccessorClosedException - アクセサがすでにクローズされている場合

isClosed

public boolean isClosed()
このアクセサがクローズされた状態かどうかを確認します。 アクセサが一度クローズされている場合、以下のメソッドを使用してデータを設定することはできません。
  • setProperty(String, Object)

戻り値:
クローズされている場合 true 、そうでなければ false
関連項目:
setClosed()

setClosed

public void setClosed()
このアクセサをクローズします。

関連項目:
isClosed()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedBaseAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース ExtendedBaseAccessor

すべてのスーパーインタフェース:
Serializable
public interface ExtendedBaseAccessor
extends Serializable

拡張基本エンティティに対する情報操作用のインタフェースです。 このクラスを通じて実際の拡張基本エンティティに反映されます。

拡張元となる基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • setProperty(String, Object)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
BaseAccessor | getBaseAccessor() 拡張元となる基本エンティティの基本アクセサを取得します。
Object | getProperty(String prop) プロパティを取得します。
void | setProperty(String prop, Object value) プロパティを設定します。

メソッドの詳細

getBaseAccessor

public BaseAccessor getBaseAccessor()
拡張元となる基本エンティティの基本アクセサを取得します。

戻り値:
基本アクセサ

getProperty

public Object getProperty(String prop)
                   throws DataNotFoundException
プロパティを取得します。

パラメータ:
prop - プロパティ情報
戻り値:
プロパティの値
例外:
DataNotFoundException - 検索時に取得していないプロパティが指定された場合

setProperty

public void setProperty(String prop,
                        Object value)
                 throws AccessorClosedException,
                        AccessorIllegalPropertyValueException
プロパティを設定します。

パラメータ:
prop - プロパティ情報
value - プロパティの値
例外:
AccessorIllegalPropertyValueException - プロパティの値が不正な場合
AccessorClosedException - アクセサがすでにクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedBaseAccessorMap (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース ExtendedBaseAccessorMap

public interface ExtendedBaseAccessorMap

拡張基本アクセサのマッピング情報を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedBaseAccessor | createExtendedBaseAccessor(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を生成します。
ExtendedBaseAccessor | findExtendedBaseAccessor(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を取得します。
void | remove(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を削除します。

メソッドの詳細

createExtendedBaseAccessor

public ExtendedBaseAccessor createExtendedBaseAccessor(String name)
                                                throws IllegalExtensionException,
                                                       AccessorClosedException
拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を生成します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

パラメータ:
name - 拡張名
戻り値:
拡張基本アクセサ
例外:
IllegalExtensionException - 存在しない拡張名、または基本属性を持たない拡張名が指定された場合
AccessorClosedException - 基本アクセサがクローズされている場合

findExtendedBaseAccessor

public ExtendedBaseAccessor findExtendedBaseAccessor(String name)
                                              throws IllegalExtensionException
拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を取得します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張アクセサが生成されていない場合は null を返します。

パラメータ:
name - 拡張名
戻り値:
拡張基本アクセサ
例外:
IllegalExtensionException - 存在しない拡張名、または基本属性を持たない拡張名が指定された場合

remove

public void remove(String name)
            throws AccessorClosedException
拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を削除します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張アクセサが生成されていない場合は何もしません。

パラメータ:
name - 拡張名
例外:
AccessorClosedException - 基本アクセサがクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedInternationalAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース ExtendedInternationalAccessor

すべてのスーパーインタフェース:
Serializable
public interface ExtendedInternationalAccessor
extends Serializable

拡張国際化エンティティに対する情報操作用のインタフェースです。 このクラスを通じて実際の拡張国際化エンティティに反映されます。

拡張もととなる基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • setProperty(String, Object)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
InternationalAccessor | getInternationalAccessor() 拡張もととなる国際化アクセサを取得します。
Object | getProperty(String prop) プロパティを取得します。
void | setProperty(String prop, Object value) プロパティを設定します。

メソッドの詳細

getInternationalAccessor

public InternationalAccessor getInternationalAccessor()
拡張もととなる国際化アクセサを取得します。

戻り値:
国際化アクセサ

getProperty

public Object getProperty(String prop)
                   throws DataNotFoundException
プロパティを取得します。

パラメータ:
prop - プロパティ情報
戻り値:
プロパティの値
例外:
DataNotFoundException - 検索時に取得していないプロパティが指定された場合

setProperty

public void setProperty(String prop,
                        Object value)
                 throws AccessorClosedException,
                        AccessorIllegalPropertyValueException
プロパティを設定します。

パラメータ:
prop - プロパティ情報
value - プロパティの値
例外:
AccessorIllegalPropertyValueException - プロパティの値が不正な場合
AccessorClosedException - アクセサがすでにクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedInternationalAccessorMap (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース ExtendedInternationalAccessorMap

public interface ExtendedInternationalAccessorMap

拡張国際アクセサのマッピング情報を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedInternationalAccessor | createExtendedInternationalAccessor(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を生成します。
ExtendedInternationalAccessor | findExtendedInternationalAccessor(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を取得します。
void | remove(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を削除します。

メソッドの詳細

createExtendedInternationalAccessor

public ExtendedInternationalAccessor createExtendedInternationalAccessor(String name)
                                                                  throws IllegalExtensionException,
                                                                         AccessorClosedException
拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を生成します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

パラメータ:
name - 拡張名
戻り値:
拡張国際化アクセサ
例外:
IllegalExtensionException - 存在しない拡張名、国際化属性を持たない拡張名が指定された場合
AccessorClosedException - 基本アクセサがクローズされている場合

findExtendedInternationalAccessor

public ExtendedInternationalAccessor findExtendedInternationalAccessor(String name)
                                                                throws IllegalExtensionException
拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を取得します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張アクセサが生成されていない場合は null を返します。

パラメータ:
name - 拡張名
戻り値:
拡張国際化アクセサ
例外:
IllegalExtensionException - 存在しない拡張名、国際化属性を持たない拡張名が指定された場合

remove

public void remove(String name)
            throws AccessorClosedException
拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を削除します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張アクセサが生成されていない場合は何もしません。

パラメータ:
name - 拡張名
例外:
AccessorClosedException - 基本アクセサがクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース ExtendedTerminableAccessor

すべてのスーパーインタフェース:
Serializable
public interface ExtendedTerminableAccessor
extends Serializable

拡張期間化エンティティに対する情報操作用のインタフェースです。 このクラスを通じて実際の拡張期間化エンティティに反映されます。

拡張もととなる基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • setProperty(String, Object)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
Object | getProperty(String prop) プロパティを取得します。
TerminableAccessor | getTerminableAccessor() 拡張もととなる期間化アクセサを取得します。
void | setProperty(String prop, Object value) プロパティを設定します。

メソッドの詳細

getTerminableAccessor

public TerminableAccessor getTerminableAccessor()
拡張もととなる期間化アクセサを取得します。

戻り値:
期間化アクセサ

getProperty

public Object getProperty(String prop)
                   throws DataNotFoundException
プロパティを取得します。

パラメータ:
prop - プロパティ情報
戻り値:
プロパティの値
例外:
DataNotFoundException - 検索時に取得していないプロパティが指定された場合

setProperty

public void setProperty(String prop,
                        Object value)
                 throws AccessorClosedException,
                        AccessorIllegalPropertyValueException
プロパティを設定します。

パラメータ:
prop - プロパティ情報
value - プロパティの値
例外:
AccessorIllegalPropertyValueException - プロパティの値が不正な場合
AccessorClosedException - アクセサがすでにクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableAccessorMap (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース ExtendedTerminableAccessorMap

public interface ExtendedTerminableAccessorMap

拡張期間化アクセサのマッピング情報を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedTerminableAccessor | createExtendedTerminableAccessor(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を生成します。
ExtendedTerminableAccessor | findExtendedTerminableAccessor(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を取得します。
void | remove(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を削除します。

メソッドの詳細

createExtendedTerminableAccessor

public ExtendedTerminableAccessor createExtendedTerminableAccessor(String name)
                                                            throws IllegalExtensionException,
                                                                   AccessorClosedException
拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を生成します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

パラメータ:
name - 拡張名
戻り値:
拡張期間化アクセサ
例外:
IllegalExtensionException - 存在しない拡張名、または期間化属性を持たない拡張名が指定された場合
AccessorClosedException - 基本アクセサがクローズされている場合

findExtendedTerminableAccessor

public ExtendedTerminableAccessor findExtendedTerminableAccessor(String name)
                                                          throws IllegalExtensionException
拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を取得します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張アクセサが生成されていない場合は null を返します。

パラメータ:
name - 拡張名
戻り値:
拡張期間化アクセサ
例外:
IllegalExtensionException - 存在しない拡張名、または期間化属性を持たない拡張名が指定された場合

remove

public void remove(String name)
            throws AccessorClosedException
拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を削除します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張アクセサが生成されていない場合は何もしません。

パラメータ:
name - 拡張名
例外:
AccessorClosedException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableInternationalAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース ExtendedTerminableInternationalAccessor

public interface ExtendedTerminableInternationalAccessor

拡張期間国際化エンティティに対する情報操作用のインタフェースです。 このクラスを通じて実際の拡張期間国際化エンティティに反映されます。

拡張もととなる基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • setProperty(String, Object)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
Object | getProperty(String prop) プロパティを取得します。
TerminableInternationalAccessor | getTerminableInternationalAccessor() 拡張もととなる期間国際化アクセサを取得します。
void | setProperty(String prop, Object value) プロパティを設定します。

メソッドの詳細

getTerminableInternationalAccessor

public TerminableInternationalAccessor getTerminableInternationalAccessor()
拡張もととなる期間国際化アクセサを取得します。

戻り値:
期間国際化アクセサ

getProperty

public Object getProperty(String prop)
                   throws DataNotFoundException
プロパティを取得します。

パラメータ:
prop - プロパティ情報
戻り値:
プロパティの値
例外:
DataNotFoundException - 検索時に取得していないプロパティが指定された場合

setProperty

public void setProperty(String prop,
                        Object value)
                 throws AccessorClosedException,
                        AccessorIllegalPropertyValueException
プロパティを設定します。

パラメータ:
prop - プロパティ情報
value - プロパティの値
例外:
AccessorIllegalPropertyValueException - プロパティの値が不正な場合
AccessorClosedException - アクセサがすでにクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableInternationalAccessorMap (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース ExtendedTerminableInternationalAccessorMap

public interface ExtendedTerminableInternationalAccessorMap

拡張期間国際化アクセサのマッピング情報を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedTerminableInternationalAccessor | createExtendedTerminableInternationalAccessor(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を生成します。
ExtendedTerminableInternationalAccessor | findExtendedTerminableInternationalAccessor(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を取得します。
void | remove(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を削除します。

メソッドの詳細

createExtendedTerminableInternationalAccessor

public ExtendedTerminableInternationalAccessor createExtendedTerminableInternationalAccessor(String name)
                                                                                throws IllegalExtensionException,
                                                                                AccessorClosedException
拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を生成します。 拡張アクセサを指定するための拡張名には、「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

パラメータ:
name - 拡張名
戻り値:
拡張期間国際化アクセサ
例外:
IllegalExtensionException - 存在しない拡張名、期間国際化属性を持たない拡張名が指定された場合
AccessorClosedException - 基本アクセサがクローズされている場合

findExtendedTerminableInternationalAccessor

public ExtendedTerminableInternationalAccessor findExtendedTerminableInternationalAccessor(String name)
                                                                                throws IllegalExtensionException
拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を取得します。 拡張アクセサを指定するための拡張名には、「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張アクセサが生成されていない場合は null を返します。

パラメータ:
name - 拡張名
戻り値:
拡張期間国際化アクセサ
例外:
IllegalExtensionException - 存在しない拡張名、期間国際化属性を持たない拡張名が指定された場合

remove

public void remove(String name)
            throws AccessorClosedException
拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を削除します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張アクセサが生成されていない場合は何もしません。

パラメータ:
name - 拡張名
例外:
AccessorClosedException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース InternationalAccessor

すべてのスーパーインタフェース:
Serializable
public interface InternationalAccessor
extends Serializable

国際化エンティティに対する情報操作用のインタフェースです。 このクラスを通じて実際の国際化エンティティに反映されます。

基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • setProperty(String, Object)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
BaseAccessor | getBaseAccessor() この国際化アクセサが所属する基本アクセサを取得します。
ExtendedInternationalAccessorMap | getExtendedInternationalAccessorMap() この国際化アクセサに対する拡張国際化アクセサのマップを取得します。
Locale | getLocale() ロケールを取得します。
Object | getProperty(String prop) プロパティを取得します。
void | setProperty(String prop, Object value) プロパティを設定します。

メソッドの詳細

getBaseAccessor

public BaseAccessor getBaseAccessor()
この国際化アクセサが所属する基本アクセサを取得します。

戻り値:
基本アクセサ

getLocale

public Locale getLocale()
ロケールを取得します。

戻り値:
ロケール

getExtendedInternationalAccessorMap

public ExtendedInternationalAccessorMap getExtendedInternationalAccessorMap()
この国際化アクセサに対する拡張国際化アクセサのマップを取得します。

戻り値:
拡張国際化アクセサのマップ

getProperty

public Object getProperty(String prop)
                   throws DataNotFoundException
プロパティを取得します。

パラメータ:
prop - プロパティ名
戻り値:
プロパティの値
例外:
DataNotFoundException - 検索時に取得していないプロパティが指定された場合

setProperty

public void setProperty(String prop,
                        Object value)
                 throws AccessorClosedException,
                        AccessorIllegalPropertyValueException
プロパティを設定します。

パラメータ:
prop - プロパティ名
value - プロパティの値
例外:
AccessorIllegalPropertyValueException - プロパティの値が不正な場合
AccessorClosedException - アクセサがすでにクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalAccessorMap (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース InternationalAccessorMap

public interface InternationalAccessorMap

国際化アクセサのマッピング情報を持ちます。 システムで定義された言語に対応する情報のみを持ちます。 所属する基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • createInternationalAccessor(Locale)
  • remove(Locale)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
InternationalAccessor | createInternationalAccessor(Locale locale) 国際化アクセサを生成します。
InternationalAccessor | findInternationalAccessor(Locale locale) 指定された言語に該当する国際化アクセサを取得します。
Locale[] | getLocales() 現在管理している言語の一覧を取得します。
void | remove(Locale locale) 指定された言語に該当するデータを削除します。

メソッドの詳細

createInternationalAccessor

public InternationalAccessor createInternationalAccessor(Locale locale)
                                                  throws IllegalLocaleException,
                                                         AccessorClosedException
国際化アクセサを生成します。 引数で指定された言語に該当する既存の情報は新しい情報で上書きされます。 システムで取り扱う言語のみが対象となります。

パラメータ:
locale - 言語
戻り値:
国際化アクセサ
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
AccessorClosedException - 基本アクセサがクローズされている場合、例外を返す

findInternationalAccessor

public InternationalAccessor findInternationalAccessor(Locale locale)
                                                throws IllegalLocaleException
指定された言語に該当する国際化アクセサを取得します。 引数 locale で指定された言語に該当する InternationalAccessor を取得します。該当するものが存在しない場合、 null が返されます。

パラメータ:
locale - 対象となる言語
戻り値:
対象となる期間化アクセサ（存在しない場合は null）
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合

remove

public void remove(Locale locale)
            throws IllegalLocaleException,
                   AccessorClosedException
指定された言語に該当するデータを削除します。

パラメータ:
locale - 削除対象の言語
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
AccessorClosedException - 基本アクセサがクローズされている場合、例外を返す

getLocales

public Locale[] getLocales()
現在管理している言語の一覧を取得します。 もし、管理している言語がない時は空の配列を返します。

戻り値:
管理している言語の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.common.accessor (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース
BaseAccessor
ExtendedBaseAccessor
ExtendedBaseAccessorMap
ExtendedInternationalAccessor
ExtendedInternationalAccessorMap
ExtendedTerminableAccessor
ExtendedTerminableAccessorMap
ExtendedTerminableInternationalAccessor
ExtendedTerminableInternationalAccessorMap
InternationalAccessor
InternationalAccessorMap
TerminableAccessor
TerminableAccessorMap
TerminableInternationalAccessor
TerminableInternationalAccessorMap


jp.co.intra_mart.foundation.datastore.common.accessor (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.common.accessor

情報を扱うためのアクセサを提供します。

参照:
説明

インタフェースの概要
BaseAccessor | 基本エンティティに対する情報操作用のインタフェースです。
ExtendedBaseAccessor | 拡張基本エンティティに対する情報操作用のインタフェースです。
ExtendedBaseAccessorMap | 拡張基本アクセサのマッピング情報を持ちます。
ExtendedInternationalAccessor | 拡張国際化エンティティに対する情報操作用のインタフェースです。
ExtendedInternationalAccessorMap | 拡張国際アクセサのマッピング情報を持ちます。
ExtendedTerminableAccessor | 拡張期間化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableAccessorMap | 拡張期間化アクセサのマッピング情報を持ちます。
ExtendedTerminableInternationalAccessor | 拡張期間国際化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableInternationalAccessorMap | 拡張期間国際化アクセサのマッピング情報を持ちます。
InternationalAccessor | 国際化エンティティに対する情報操作用のインタフェースです。
InternationalAccessorMap | 国際化アクセサのマッピング情報を持ちます。
TerminableAccessor | 期間化エンティティに対する情報操作用のインタフェースです。
TerminableAccessorMap | 期間化アクセサのマッピング情報を持ちます。
TerminableInternationalAccessor | 期間国際化エンティティに対する情報操作用のインタフェースです。
TerminableInternationalAccessorMap | 期間国際化アクセサのマッピング情報を持ちます。

パッケージ jp.co.intra_mart.foundation.datastore.common.accessor の説明

情報を扱うためのアクセサを提供します。


jp.co.intra_mart.foundation.datastore.common.accessor クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.common.accessor の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap


パッケージ jp.co.intra_mart.foundation.datastore.common.accessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.common.accessor の使用

jp.co.intra_mart.foundation.datastore.common.accessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor により使用される jp.co.intra_mart.foundation.datastore.common.accessor のクラス
BaseAccessor
基本エンティティに対する情報操作用のインタフェースです。
ExtendedBaseAccessor
拡張基本エンティティに対する情報操作用のインタフェースです。
ExtendedBaseAccessorMap
拡張基本アクセサのマッピング情報を持ちます。
ExtendedInternationalAccessor
拡張国際化エンティティに対する情報操作用のインタフェースです。
ExtendedInternationalAccessorMap
拡張国際アクセサのマッピング情報を持ちます。
ExtendedTerminableAccessor
拡張期間化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableAccessorMap
拡張期間化アクセサのマッピング情報を持ちます。
ExtendedTerminableInternationalAccessor
拡張期間国際化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableInternationalAccessorMap
拡張期間国際化アクセサのマッピング情報を持ちます。
InternationalAccessor
国際化エンティティに対する情報操作用のインタフェースです。
InternationalAccessorMap
国際化アクセサのマッピング情報を持ちます。
TerminableAccessor
期間化エンティティに対する情報操作用のインタフェースです。
TerminableAccessorMap
期間化アクセサのマッピング情報を持ちます。
TerminableInternationalAccessor
期間国際化エンティティに対する情報操作用のインタフェースです。
TerminableInternationalAccessorMap
期間国際化アクセサのマッピング情報を持ちます。

jp.co.intra_mart.foundation.datastore.common.model により使用される jp.co.intra_mart.foundation.datastore.common.accessor のクラス
BaseAccessor
基本エンティティに対する情報操作用のインタフェースです。
ExtendedBaseAccessor
拡張基本エンティティに対する情報操作用のインタフェースです。
ExtendedBaseAccessorMap
拡張基本アクセサのマッピング情報を持ちます。
ExtendedInternationalAccessor
拡張国際化エンティティに対する情報操作用のインタフェースです。
ExtendedInternationalAccessorMap
拡張国際アクセサのマッピング情報を持ちます。
ExtendedTerminableAccessor
拡張期間化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableAccessorMap
拡張期間化アクセサのマッピング情報を持ちます。
ExtendedTerminableInternationalAccessor
拡張期間国際化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableInternationalAccessorMap
拡張期間国際化アクセサのマッピング情報を持ちます。
InternationalAccessor
国際化エンティティに対する情報操作用のインタフェースです。
InternationalAccessorMap
国際化アクセサのマッピング情報を持ちます。
TerminableAccessor
期間化エンティティに対する情報操作用のインタフェースです。
TerminableAccessorMap
期間化アクセサのマッピング情報を持ちます。
TerminableInternationalAccessor
期間国際化エンティティに対する情報操作用のインタフェースです。
TerminableInternationalAccessorMap
期間国際化アクセサのマッピング情報を持ちます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


TerminableAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース TerminableAccessor

すべてのスーパーインタフェース:
Serializable
public interface TerminableAccessor
extends Serializable

期間化エンティティに対する情報操作用のインタフェースです。 このクラスを通じて実際の期間化エンティティに反映されます。

基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • setProperty(String, Object)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
BaseAccessor | getBaseAccessor() この期間化アクセサが所属する基本アクセサを取得します。
ExtendedTerminableAccessorMap | getExtendedTerminableAccessorMap() この期間化アクセサに対する拡張期間化アクセサのマップを取得します。
Object | getProperty(String prop) プロパティを取得します。
Term | getTerm() 期間を取得します。
String | getTermCode() 期間CDを取得します。
TerminableInternationalAccessorMap | getTerminableInternationalAccessorMap() この期間化アクセサに対する期間国際化アクセサのマップを取得します。
void | setProperty(String prop, Object value) プロパティを設定します。

メソッドの詳細

getBaseAccessor

public BaseAccessor getBaseAccessor()
この期間化アクセサが所属する基本アクセサを取得します。

戻り値:
基本アクセサ

getTerm

public Term getTerm()
期間を取得します。

戻り値:
期間

getTermCode

public String getTermCode()
期間CDを取得します。

戻り値:
期間CD

getTerminableInternationalAccessorMap

public TerminableInternationalAccessorMap getTerminableInternationalAccessorMap()
この期間化アクセサに対する期間国際化アクセサのマップを取得します。

戻り値:
期間国際化アクセサのマップ

getExtendedTerminableAccessorMap

public ExtendedTerminableAccessorMap getExtendedTerminableAccessorMap()
この期間化アクセサに対する拡張期間化アクセサのマップを取得します。

戻り値:
拡張期間化アクセサのマップ

getProperty

public Object getProperty(String prop)
                   throws DataNotFoundException
プロパティを取得します。

パラメータ:
prop - プロパティ名
戻り値:
プロパティの値
例外:
DataNotFoundException - 検索時に取得していないプロパティが指定された場合

setProperty

public void setProperty(String prop,
                        Object value)
                 throws AccessorClosedException,
                        AccessorIllegalPropertyValueException
プロパティを設定します。

パラメータ:
prop - プロパティ名
value - プロパティの値
例外:
AccessorIllegalPropertyValueException - プロパティの値が不正な場合
AccessorClosedException - アクセサがすでにクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableAccessorMap (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース TerminableAccessorMap

public interface TerminableAccessorMap

期間化アクセサのマッピング情報を持ちます。 所属する基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • createTerminableAccessor(Term)
  • remove(Term)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
TerminableAccessor | createTerminableAccessor(Term term) 指定した期間に期間化アクセサを生成します。
TerminableAccessor | findTerminableAccessor(Date date) 指定された日付に該当する期間化アクセサを取得します。
Term[] | getTerms() 現在管理している期間の一覧を取得します。
Map | remove(Term term) 指定された期間に該当するデータを削除します。

メソッドの詳細

createTerminableAccessor

public TerminableAccessor createTerminableAccessor(Term term)
                                            throws IllegalTermException,
                                                   AccessorClosedException
指定した期間に期間化アクセサを生成します。 生成した期間化アクセサによって重複する期間が発生する場合、例外を返す

パラメータ:
term - 期間
戻り値:
期間アクセサ
例外:
IllegalTermException - 生成した期間化アクセサによって重複する期間が発生する場合、例外を返す
AccessorClosedException - 基本アクセサがクローズされている場合、例外を返す

findTerminableAccessor

public TerminableAccessor findTerminableAccessor(Date date)
指定された日付に該当する期間化アクセサを取得します。 引数 date で指定された日付を期間内に含む TerminableAccessor を取得します。該当するものが存在しない場合、 null が返されます。

パラメータ:
date - 対象となる日付
戻り値:
対象となる期間化アクセサ（存在しない場合は null）

remove

public Map remove(Term term)
           throws AccessorClosedException
指定された期間に該当するデータを削除します。 削除対象の期間に該当するデータがなくなるよう、既存のデータの有効開始日時や有効終了日時は調整されます。
削除対象の期間に該当するデータを持つ TerminableAccessorがキー、 削除に伴い新たに作成された期間に該当するデータを持つ TerminableAccessorの Collection が値のマップを返します。 （新規に作成された TerminableAccessorがない時は、値には 空の Collection）

パラメータ:
term - 削除対象の期間
戻り値:
map 削除された TerminableAccessorをキー、削除に伴って新規に作成された TerminableAccessorを値とするマップを返す
例外:
AccessorClosedException - 基本アクセサがクローズされている場合、例外を返す

getTerms

public Term[] getTerms()
現在管理している期間の一覧を取得します。 返される期間は期間の早い物から遅い物の順位並んでいる必要があります。 もし、管理している期間の管理がない時は空の配列を返します。

戻り値:
現在管理している期間の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableInternationalAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース TerminableInternationalAccessor

すべてのスーパーインタフェース:
Serializable
public interface TerminableInternationalAccessor
extends Serializable

期間国際化エンティティに対する情報操作用のインタフェースです。 このクラスを通じて実際の期間国際化エンティティに反映されます。

基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • setProperty(String, Object)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
ExtendedTerminableInternationalAccessorMap | getExtendedTerminableInternationalAccessorMap() この期間国際化アクセサの拡張期間国際化アクセサのマップを取得します。
Locale | getLocale() ロケールを取得します。
Object | getProperty(String prop) プロパティを取得します。
TerminableAccessor | getTerminableAccessor() この期間国際化アクセサが所属する期間化アクセサを取得します。
void | setProperty(String prop, Object value) プロパティを設定します。

メソッドの詳細

getLocale

public Locale getLocale()
ロケールを取得します。

戻り値:
ロケール

getTerminableAccessor

public TerminableAccessor getTerminableAccessor()
この期間国際化アクセサが所属する期間化アクセサを取得します。

戻り値:
期間化アクセサ

getExtendedTerminableInternationalAccessorMap

public ExtendedTerminableInternationalAccessorMap getExtendedTerminableInternationalAccessorMap()
この期間国際化アクセサの拡張期間国際化アクセサのマップを取得します。

戻り値:
拡張期間化アクセサのマップ

getProperty

public Object getProperty(String prop)
                   throws DataNotFoundException
プロパティを取得します。

パラメータ:
prop - プロパティ名
戻り値:
プロパティの値
例外:
DataNotFoundException - 検索時に取得していないプロパティが指定された場合

setProperty

public void setProperty(String prop,
                        Object value)
                 throws AccessorClosedException,
                        AccessorIllegalPropertyValueException
プロパティを設定します。

パラメータ:
prop - プロパティ名
value - プロパティの値
例外:
AccessorIllegalPropertyValueException - プロパティの値が不正な場合
AccessorClosedException - アクセサがすでにクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableInternationalAccessorMap (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース TerminableInternationalAccessorMap

public interface TerminableInternationalAccessorMap

期間国際化アクセサのマッピング情報を持ちます。 システムで定義された言語に対応する情報のみを持ちます。 所属する基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • createTerminableInternationalAccessor(Locale)
  • remove(Locale)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
TerminableInternationalAccessor | createTerminableInternationalAccessor(Locale locale) 期間国際化アクセサを生成します。
TerminableInternationalAccessor | findTerminableInternationalAccessor(Locale locale) 指定された言語に該当する期間国際化アクセサを取得します。
Locale[] | getLocales() 現在管理している言語の一覧を取得します。
void | remove(Locale locale) 指定された言語に該当するデータを削除します。

メソッドの詳細

createTerminableInternationalAccessor

public TerminableInternationalAccessor createTerminableInternationalAccessor(Locale locale)
                                                                      throws IllegalLocaleException,
                                                                             AccessorClosedException
期間国際化アクセサを生成します。 引数で指定された言語に該当する既存の情報は新しい情報で上書きされます。 システムで取り扱う言語のみが対象となります。

パラメータ:
locale - 言語
戻り値:
期間国際化アクセサ
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
AccessorClosedException - 基本アクセサがクローズされている場合、例外を返す

findTerminableInternationalAccessor

public TerminableInternationalAccessor findTerminableInternationalAccessor(Locale locale)
                                                                    throws IllegalLocaleException
指定された言語に該当する期間国際化アクセサを取得します。 引数 locale で指定された言語に該当する TerminableInternationalAccessorを取得します。該当するものが存在しない場合、 null が返されます。

パラメータ:
locale - 対象となる言語
戻り値:
対象となる期間国際化アクセサ（存在しない場合は null）
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合

remove

public void remove(Locale locale)
            throws IllegalLocaleException,
                   AccessorClosedException
指定された言語に該当するデータを削除します。

パラメータ:
locale - 削除対象の言語
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
AccessorClosedException - 基本アクセサがクローズされている場合、例外を返す

getLocales

public Locale[] getLocales()
現在管理している言語の一覧を取得します。 管理している言語がない時は、空の配列を返します。

戻り値:
現在管理している言語の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ActivationKey の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ActivationKey の使用

ActivationKey を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ActivationKey の使用

ActivationKey を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ActivationKey Relationship.getActivationKey()
ソースエンティティのライフタイム期間の有効開始日時を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Application の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Application の使用

Application を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での Application の使用

Application を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
Application | Table.getApplication() テーブルを定義しているアプリケーションを取得します。
Application | Relationship.getApplication() リレーションシップが定義されているアプリケーションを取得します。
Application | Model.getApplication() モデルを定義しているアプリケーションを取得します。
Application | ExtendedTable.getApplication() 拡張テーブルを定義しているアプリケーションを取得します。
Application | ExtendedModel.getApplication() 拡張モデルを定義しているアプリケーションを取得します。
Application | ExtendedEntity.getApplication() 拡張エンティティを定義しているアプリケーションを取得します。
Application | Entity.getApplication() エンティティを定義しているアプリケーションを取得します。
Application | Configuration.getApplication(String name) 指定された名前に該当するアプリケーションを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Attribute の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Attribute の使用

Attribute を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での Attribute の使用

Attribute を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
Attribute | UpdateInfo.getUpdateUser() エンティティの更新ユーザとなる属性を取得します。
Attribute | UpdateInfo.getUpdateTimestamp() エンティティの更新日付となる属性を取得します。
Attribute | TerminableKey.getAttribute() 期間化基準項目となる属性を取得します。
Attribute[] | Relationship.getForeignKeys() ソースエンティティの外部キーの集合を取得します。
Attribute | Property.getAttribute() プロパティに対応付ける属性を取得します。
Attribute | PrimaryKeyMapping.getAttribute() プライマリーキーとなる属性を取得します。
Attribute[] | Lifetime.getNullKeys() ターゲットエンティティの期間削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。
Attribute | InternationalKey.getAttribute() 国際化基準項目となる属性を取得します。
Attribute | ExpirationKey.getAttribute() ライフタイム期間の有効終了日時となる属性を取得します。
Attribute[] | Entity.getPrimaryKeys() エンティティのプライマリキーとなる属性をすべて取得します。
Attribute[] | Delete.getNullKeys() ターゲットエンティティのデータ削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。
Attribute | ColumnMapping.getAttribute() カラムに割り当てる属性を取得します。
Attribute | Column.getAttribute() カラムに対応付ける属性を取得します。
Attribute | ActivationKey.getAttribute() ライフタイム期間の有効開始日時となる属性を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.config.AttributeType の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.config.AttributeType の使用

AttributeType を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での AttributeType の使用

AttributeType として宣言されている jp.co.intra_mart.foundation.datastore.common.config のフィールド
static AttributeType | AttributeType.STRING 文字列型
static AttributeType | AttributeType.DECIMAL 整数型
static AttributeType | AttributeType.DATE 日時型
static AttributeType | AttributeType.FLOAT 浮動少数型
static AttributeType | AttributeType.LOCALE ロケール

AttributeType を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 AttributeType Attribute.getType()
属性の型を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.BaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.BaseModel の使用

BaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での BaseModel の使用

BaseModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 BaseModel Model.getBaseModel()
基本モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.BaseTable の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.BaseTable の使用

BaseTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での BaseTable の使用

BaseTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 BaseTable Table.getBaseTable()
基本テーブルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Column の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Column の使用

jp.co.intra_mart.foundation.datastore.common.config.Column はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping の使用

jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Configuration の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Configuration の使用

Configuration を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での Configuration の使用

Configuration を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
abstract  Configuration ConfigurationFactory.createConfiguration()
Configurationを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory の使用

ConfigurationFactory を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ConfigurationFactory の使用

ConfigurationFactory を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
static ConfigurationFactory ConfigurationFactory.getInstance()
ConfigurationFactoryのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Delete の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Delete の使用

Delete を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での Delete の使用

Delete を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 Delete Relationship.getDelete()
ターゲットエンティティのデータ削除時の整合性制約を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.config.DeleteType の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.config.DeleteType の使用

DeleteType を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での DeleteType の使用

DeleteType として宣言されている jp.co.intra_mart.foundation.datastore.common.config のフィールド
static DeleteType | DeleteType.CASCADE 削除 ターゲットエンティティのデータを参照しているソースエンティティのデータを削除します。
static DeleteType | DeleteType.NULL Null ターゲットエンティティのデータを参照しているソースエンティティの外部キーをnullにします。
static DeleteType | DeleteType.EXCEPTION 例外 例外を発生させます。

DeleteType を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 DeleteType Delete.getDeleteType()
ターゲットエンティティの削除時の整合性制約のタイプを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Entity の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Entity の使用

Entity を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.config | アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での Entity の使用

Entity を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 Entity BaseAccessor.getEntity()
アクセサの基となるエンティティを取得します。

jp.co.intra_mart.foundation.datastore.common.config での Entity の使用

Entity を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
Entity | TerminableKey.getSourceEntity() 期間化基準項目の基点となるソースエンティティの情報を取得します。
Entity | Table.getEntity() テーブル定義の基となるエンティティを取得します。
Entity | Relationship.getSourceEntity() ソースエンティティの情報を取得します。
Entity | Relationship.getTargetEntity() ターゲットエンティティの情報を取得します。
Entity | Model.getEntity() モデル定義の基となるエンティティを取得します。
Entity | InternationalKey.getSourceEntity() 国際化基準項目の基点となるソースエンティティの情報を取得します。
Entity | ExtendedEntity.getEntity() 拡張対象となるエンティティを取得します。
Entity | ExpirationKey.getSourceEntity() ライフタイム期間の有効終了日時の基点となるソースエンティティの情報を取得します。
Entity | Attribute.getEntity() 属性が定義されているエンティティを取得します。
Entity | ActivationKey.getSourceEntity() ライフタイム期間の有効開始日時の基点となるソースエンティティの情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey の使用

ExpirationKey を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExpirationKey の使用

ExpirationKey を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExpirationKey Relationship.getExpirationKey()
ソースエンティティのライフタイム期間の有効終了日時を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseModel の使用

ExtendedBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedBaseModel の使用

ExtendedBaseModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExtendedBaseModel ExtendedModel.getExtendedBaseModel()
拡張基本モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable の使用

ExtendedBaseTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedBaseTable の使用

ExtendedBaseTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExtendedBaseTable ExtendedTable.getExtendedBaseTable()
拡張基本テーブルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity の使用

ExtendedEntity を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedEntity の使用

ExtendedEntity を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
ExtendedEntity | ExtendedTable.getExtendedEntity() 拡張テーブル定義の基となる拡張エンティティを取得します。
ExtendedEntity | ExtendedModel.getExtendedEntity() 拡張モデル定義の基となる拡張エンティティを取得します。
ExtendedEntity | Attribute.getExtendedEntity() 属性が定義されている拡張エンティティを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalModel の使用

ExtendedInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedInternationalModel の使用

ExtendedInternationalModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExtendedInternationalModel ExtendedModel.getExtendedInternationalModel()
拡張国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable の使用

ExtendedInternationalTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedInternationalTable の使用

ExtendedInternationalTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExtendedInternationalTable ExtendedTable.getExtendedInternationalTable()
拡張国際化テーブルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel の使用

ExtendedModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedModel の使用

ExtendedModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
ExtendedModel | ExtendedTerminableModel.getExtendedModel() 拡張期間化モデルが定義されている拡張モデル定義を取得します。
ExtendedModel | ExtendedTerminableInternationalModel.getExtendedModel() 拡張期間国際化モデルが定義されている拡張モデル定義を取得します。
ExtendedModel | ExtendedInternationalModel.getExtendedModel() 拡張国際化モデルが定義されている拡張モデル定義を取得します。
ExtendedModel | ExtendedEntity.getExtendedModel() この拡張エンティティを参照している拡張モデルを取得します。
ExtendedModel | ExtendedBaseModel.getExtendedModel() 拡張基本モデルが定義されている拡張モデル定義を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable の使用

ExtendedTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedTable の使用

ExtendedTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
ExtendedTable | ExtendedTerminableTable.getExtendedTable() 拡張期間化テーブルが定義されている拡張テーブル定義を取得します。
ExtendedTable | ExtendedTerminableInternationalTable.getExtendedTable() 拡張期間国際化テーブルが定義されている拡張テーブル定義を取得します。
ExtendedTable | ExtendedInternationalTable.getExtendedTable() 拡張国際化テーブルが定義されている拡張テーブル定義を取得します。
ExtendedTable | ExtendedEntity.getExtendedTable() この拡張エンティティを参照している拡張テーブルを取得します。
ExtendedTable | ExtendedBaseTable.getExtendedTable() 拡張基本テーブルが定義されている拡張テーブル定義を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalModel の使用

ExtendedTerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedTerminableInternationalModel の使用

ExtendedTerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExtendedTerminableInternationalModel ExtendedModel.getExtendedTerminableInternationalModel()
拡張期間国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable の使用

ExtendedTerminableInternationalTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedTerminableInternationalTable の使用

ExtendedTerminableInternationalTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExtendedTerminableInternationalTable ExtendedTable.getExtendedTerminableInternationalTable()
拡張期間国際化テーブルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableModel の使用

ExtendedTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedTerminableModel の使用

ExtendedTerminableModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExtendedTerminableModel ExtendedModel.getExtendedTerminableModel()
拡張期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable の使用

ExtendedTerminableTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedTerminableTable の使用

ExtendedTerminableTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExtendedTerminableTable ExtendedTable.getExtendedTerminableTable()
拡張期間化テーブルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.InternationalKey の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.InternationalKey の使用

InternationalKey を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での InternationalKey の使用

InternationalKey を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 InternationalKey Relationship.getInternationalKey()
ソースエンティティの国際化基準項目を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.InternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.InternationalModel の使用

InternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での InternationalModel の使用

InternationalModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 InternationalModel Model.getInternationalModel()
国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.InternationalTable の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.InternationalTable の使用

InternationalTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での InternationalTable の使用

InternationalTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 InternationalTable Table.getInternationalTable()
国際化テーブルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Lifetime の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Lifetime の使用

Lifetime を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での Lifetime の使用

Lifetime を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 Lifetime Relationship.getLifetime()
ターゲットエンティティの期間削除時の整合性制約を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.config.LifetimeType の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.config.LifetimeType の使用

LifetimeType を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での LifetimeType の使用

LifetimeType として宣言されている jp.co.intra_mart.foundation.datastore.common.config のフィールド
static LifetimeType | LifetimeType.CASCADE 削除 ターゲットエンティティの期間を参照しているソースエンティティのデータを削除します。
static LifetimeType | LifetimeType.NULL Null ターゲットエンティティの期間を参照しているソースエンティティの外部キーをnullにします。
static LifetimeType | LifetimeType.EXCEPTION 例外 例外を発生させます。

LifetimeType を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 LifetimeType Lifetime.getLifetimeType()
ターゲットエンティティの期間削除時の整合性制約のタイプを取得します

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Model の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Model の使用

Model を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での Model の使用

Model を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
Model | TerminableModel.getModel() 期間化モデルが定義されているモデル定義を取得します。
Model | TerminableInternationalModel.getModel() 期間国際化モデルが定義されているモデル定義を取得します。
Model | InternationalModel.getModel() 国際化モデルが定義されているモデル定義を取得します。
Model | Entity.getModel() このエンティティを参照しているモデルを取得します。
Model | BaseModel.getModel() 基本モデルが定義されているモデル定義を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping の使用

jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Property の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Property の使用

jp.co.intra_mart.foundation.datastore.common.config.Property はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Relationship の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Relationship の使用

Relationship を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config | アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.config での Relationship の使用

Relationship を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
Relationship[] | TerminableKey.getRefereRelationships() ソースエンティティから期間化基準項目を持つエンティティまでのリレーションシップを取得します。
Relationship[] | InternationalKey.getRefereRelationships() ソースエンティティから国際化基準項目を持つエンティティまでのリレーションシップを取得します。
Relationship[] | ExpirationKey.getRefereRelationships() ソースエンティティから有効終了日時を持つエンティティまでのリレーションシップを取得します。
Relationship[] | ActivationKey.getRefereRelationships() ソースエンティティから有効開始日時を持つエンティティまでのリレーションシップを取得します。

jp.co.intra_mart.foundation.datastore.common.model での Relationship の使用

Relationship 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | Mapper.notifyUpdate(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
void | Mapper.notifyDelete(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
void | Mapper.checkByBaseProperty(Relationship[] relationships, BaseModel target, BaseModel base) 基準項目によるリレーションシップの整合性制約をチェックします。
protected Collection | IntramartDBMapper.select(Relationship relationship, Map keys) 外部キーで特定される基本モデルをすべて取得します。
void | IntramartDBMapper.notifyUpdate(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
void | IntramartDBMapper.notifyDelete(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
void | IntramartDBMapper.checkByBaseProperty(Relationship[] relationships, BaseModel target, BaseModel base) 基準項目によるリレーションシップの整合性制約をチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Table の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Table の使用

Table を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での Table の使用

Table を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
Table | TerminableTable.getTable() 期間化テーブルが定義されているテーブル定義を取得します。
Table | TerminableInternationalTable.getTable() 期間国際化テーブルが定義されているテーブル定義を取得します。
Table | InternationalTable.getTable() 国際化テーブルが定義されているテーブル定義を取得します。
Table | Entity.getTable() このエンティティを参照しているテーブルを取得します。
Table | BaseTable.getTable() 基本テーブルが定義されているテーブル定義を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalModel の使用

TerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での TerminableInternationalModel の使用

TerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 TerminableInternationalModel Model.getTerminableInternationalModel()
期間国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable の使用

TerminableInternationalTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での TerminableInternationalTable の使用

TerminableInternationalTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 TerminableInternationalTable Table.getTerminableInternationalTable()
期間国際化テーブルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.TerminableKey の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.TerminableKey の使用

TerminableKey を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での TerminableKey の使用

TerminableKey を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 TerminableKey Relationship.getTerminableKey()
ソースエンティティの期間化基準項目を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.TerminableModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.TerminableModel の使用

TerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での TerminableModel の使用

TerminableModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 TerminableModel Model.getTerminableModel()
期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.TerminableTable の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.TerminableTable の使用

TerminableTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での TerminableTable の使用

TerminableTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 TerminableTable Table.getTerminableTable()
期間化テーブルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.UpdateInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.UpdateInfo の使用

UpdateInfo を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での UpdateInfo の使用

UpdateInfo を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 UpdateInfo Entity.getUpdateInfo()
エンティティの更新情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ActivationKey (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ActivationKey

public interface ActivationKey

ライフタイム期間の有効開始日時を定義します。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getAttribute() ライフタイム期間の有効開始日時となる属性を取得します。
Relationship[] | getRefereRelationships() ソースエンティティから有効開始日時を持つエンティティまでのリレーションシップを取得します。
Entity | getSourceEntity() ライフタイム期間の有効開始日時の基点となるソースエンティティの情報を取得します。

メソッドの詳細

getSourceEntity

public Entity getSourceEntity()
ライフタイム期間の有効開始日時の基点となるソースエンティティの情報を取得します。

戻り値:
ソースエンティティの情報

getRefereRelationships

public Relationship[] getRefereRelationships()
ソースエンティティから有効開始日時を持つエンティティまでのリレーションシップを取得します。

戻り値:
ソースエンティティから有効開始日時を持つエンティティまでのリレーションシップ

getAttribute

public Attribute getAttribute()
ライフタイム期間の有効開始日時となる属性を取得します。

戻り値:
ライフタイム期間の有効開始日時となる属性
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Application (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Application

public interface Application

アプリケーションを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getEntities() アプリケーションで定義しているエンティティの一覧を取得します。
Map | getExtendedEntities() アプリケーションで定義している拡張エンティティの一覧を取得します。
Map | getExtendedModels() アプリケーションで定義している拡張モデル定義の一覧を取得します。
Map | getExtendedTables() アプリケーションで定義している拡張テーブル定義の一覧を取得します。
Map | getModels() アプリケーションで定義しているモデル定義の一覧を取得します。
String | getName() アプリケーション名を取得します。
Map | getRelationships() アプリケーションで定義しているリレーションシップの一覧を取得します。
Map | getTables() アプリケーションで定義しているテーブル定義の一覧を取得します。

メソッドの詳細

getName

public String getName()
アプリケーション名を取得します。

戻り値:
アプリケーション名

getEntities

public Map getEntities()
アプリケーションで定義しているエンティティの一覧を取得します。 エンティティ名をキー、 Entityを値としたマップを返します。

戻り値:
エンティティの一覧

getExtendedEntities

public Map getExtendedEntities()
アプリケーションで定義している拡張エンティティの一覧を取得します。 拡張名をキー、 ExtendedEntityを値としたマップを返します。

戻り値:
拡張エンティティの一覧

getRelationships

public Map getRelationships()
アプリケーションで定義しているリレーションシップの一覧を取得します。 リレーションシップ名をキー、 Relationshipを値としたマップを返します。

戻り値:
リレーションシップの一覧

getTables

public Map getTables()
アプリケーションで定義しているテーブル定義の一覧を取得します。 「テーブルの定義基となるエンティティが定義されているアプリケーション名　+ . + エンティティ名」 をキー、 Tableを値としたマップを返します。

例
エンティティが定義されているアプリケーション名：jp.co.intra_mart
エンティティ名：Entity
上記のようなときは「jp.co.intra_mart.Entity」がキーとなります。

戻り値:
テーブル定義の一覧

getExtendedTables

public Map getExtendedTables()
アプリケーションで定義している拡張テーブル定義の一覧を取得します。 「拡張テーブルの定義基となる拡張エンティティが定義されているアプリケーション名　+ . + 拡張名」 をキー、 ExtendedTableを値としたマップを返します。

例
拡張エンティティが定義されているアプリケーション名：jp.co.intra_mart
拡張名：ExtendedEntity
上記のようなときは「jp.co.intra_mart.ExtendedEntity」がキーとなります。

戻り値:
拡張テーブル定義の一覧

getModels

public Map getModels()
アプリケーションで定義しているモデル定義の一覧を取得します。 「モデルの定義基となるエンティティが定義されているアプリケーション名　+ . + エンティティ名」、 Modelを値としたマップを返します。

例
エンティティが定義されているアプリケーション名：jp.co.intra_mart
エンティティ名：Entity
上記のようなときは「jp.co.intra_mart.Entity」がキーとなります。

戻り値:
拡張テーブル定義の一覧

getExtendedModels

public Map getExtendedModels()
アプリケーションで定義している拡張モデル定義の一覧を取得します。 「拡張モデルの定義基となる拡張エンティティが定義されているアプリケーション名　+ . + 拡張名」 をキー、 ExtendedModelを値としたマップを返します。

例
拡張エンティティが定義されているアプリケーション名：jp.co.intra_mart
拡張名：ExtendedEntity
上記のようなときは「jp.co.intra_mart.ExtendedEntity」がキーとなります。

戻り値:
拡張モデル定義の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Attribute (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Attribute

public interface Attribute

属性を定義します。

導入されたバージョン:
5.0

メソッドの概要
Entity | getEntity() 属性が定義されているエンティティを取得します。
ExtendedEntity | getExtendedEntity() 属性が定義されている拡張エンティティを取得します。
String | getName() 属性名を取得します。
AttributeType | getType() 属性の型を取得します。
boolean | isInternational() 属性が国際化の対象であるかどうかを取得します。
boolean | isNullAcceptable() 属性にnullが設定可能であるかどうかを取得します。
boolean | isTerminable() 属性が期間化の対象であるかどうかを取得します。

メソッドの詳細

getName

public String getName()
属性名を取得します。

戻り値:
属性名

getType

public AttributeType getType()
属性の型を取得します。

戻り値:
属性の型

isTerminable

public boolean isTerminable()
属性が期間化の対象であるかどうかを取得します。

戻り値:
属性が期間化の対象である場合 true 、そうでない場合 false

isInternational

public boolean isInternational()
属性が国際化の対象であるかどうかを取得します。

戻り値:
属性が国際化の対象である場合 true 、そうでない場合 false

isNullAcceptable

public boolean isNullAcceptable()
属性にnullが設定可能であるかどうかを取得します。

戻り値:
属性にnullが設定が可能である場合 true 、そうでない場合 false

getEntity

public Entity getEntity()
属性が定義されているエンティティを取得します。

戻り値:
属性が定義されているエンティティ

getExtendedEntity

public ExtendedEntity getExtendedEntity()
属性が定義されている拡張エンティティを取得します。 属性が拡張エンティティに定義されていないとき null を返します。

戻り値:
属性が定義されている拡張エンティティ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AttributeType (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
クラス AttributeType

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.config.AttributeType
すべての実装インタフェース:
Serializable
public class AttributeType
extends Object
implements Serializable

属性で指定できる型です。

導入されたバージョン:
5.0
関連項目:
直列化された形式

フィールドの概要
static AttributeType | DATE 日時型
static AttributeType | DECIMAL 整数型
static AttributeType | FLOAT 浮動少数型
static AttributeType | LOCALE ロケール
static AttributeType | STRING 文字列型
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

STRING

public static final AttributeType STRING
文字列型

DECIMAL

public static final AttributeType DECIMAL
整数型

DATE

public static final AttributeType DATE
日時型

FLOAT

public static final AttributeType FLOAT
浮動少数型

LOCALE

public static final AttributeType LOCALE
ロケール

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース BaseModel

public interface BaseModel

基本モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
String | getClassName() 基本モデルのクラス名を取得します。
Model | getModel() 基本モデルが定義されているモデル定義を取得します。

メソッドの詳細

getModel

public Model getModel()
基本モデルが定義されているモデル定義を取得します。

戻り値:
基本モデルが定義されているモデル定義

getClassName

public String getClassName()
基本モデルのクラス名を取得します。

戻り値:
基本モデルのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BaseTable (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース BaseTable

public interface BaseTable

基本テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getColumnMappings() 基本テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
String | getName() 基本テーブルのテーブル名を取得します。
Table | getTable() 基本テーブルが定義されているテーブル定義を取得します。

メソッドの詳細

getTable

public Table getTable()
基本テーブルが定義されているテーブル定義を取得します。

戻り値:
基本テーブルが定義されているテーブル定義

getName

public String getName()
基本テーブルのテーブル名を取得します。

戻り値:
基本テーブルのテーブル名

getColumnMappings

public Map getColumnMappings()
基本テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。 属性名をキー、 ColumnMappingを値としたマップを返します。

戻り値:
基本テーブルに含まれるカラムマッピング
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Column (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Column

public interface Column

属性に対応するカラムの型を定義します。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getAttribute() カラムに対応付ける属性を取得します。
String | getType() カラムの型を取得します。

メソッドの詳細

getAttribute

public Attribute getAttribute()
カラムに対応付ける属性を取得します。

戻り値:
カラムに対応付ける属性

getType

public String getType()
カラムの型を取得します。

戻り値:
カラムの型
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ColumnMapping (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ColumnMapping

public interface ColumnMapping

分割されたテーブルに割り当てられるカラムを定義します。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getAttribute() カラムに割り当てる属性を取得します。
String | getName() カラム名を取得します。

メソッドの詳細

getAttribute

public Attribute getAttribute()
カラムに割り当てる属性を取得します。

戻り値:
カラムに割り当てる属性

getName

public String getName()
カラム名を取得します。

戻り値:
カラム名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Configuration (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Configuration

public interface Configuration

設定内容を取得します。

導入されたバージョン:
5.0

メソッドの概要
 Application getApplication(String name)
指定された名前に該当するアプリケーションを取得します。

メソッドの詳細

getApplication

public Application getApplication(String name)
指定された名前に該当するアプリケーションを取得します。

パラメータ:
name - アプリケーション名
戻り値:
指定された名前に該当するアプリケーション
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ConfigurationFactory (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
クラス ConfigurationFactory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory
public abstract class ConfigurationFactory
extends Object

Configurationを生成します。

導入されたバージョン:
5.0

コンストラクタの概要
ConfigurationFactory()
メソッドの概要
abstract Configuration | createConfiguration() Configurationを生成します。
static ConfigurationFactory | getInstance() ConfigurationFactoryのインスタンスを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ConfigurationFactory

public ConfigurationFactory()
メソッドの詳細

getInstance

public static ConfigurationFactory getInstance()
ConfigurationFactoryのインスタンスを取得します。

戻り値:
ConfigurationFactory

createConfiguration

public abstract Configuration createConfiguration()
Configurationを生成します。

戻り値:
Configuration
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Delete (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Delete

public interface Delete

削除時の整合性制約です。 ターゲットエンティティの情報変更による整合性制約の内容です。

導入されたバージョン:
5.0

メソッドの概要
DeleteType | getDeleteType() ターゲットエンティティの削除時の整合性制約のタイプを取得します。
Attribute[] | getNullKeys() ターゲットエンティティのデータ削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。

メソッドの詳細

getDeleteType

public DeleteType getDeleteType()
ターゲットエンティティの削除時の整合性制約のタイプを取得します。

戻り値:
削除時の整合性制約のタイプ

getNullKeys

public Attribute[] getNullKeys()
ターゲットエンティティのデータ削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。

戻り値:
データ削除時の整合性制約の対象となる外部キー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DeleteType (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
クラス DeleteType

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.config.DeleteType
すべての実装インタフェース:
Serializable
public class DeleteType
extends Object
implements Serializable

削除時の整合性制約のタイプです。 ターゲットエンティティの情報変更による整合性制約のタイプです。

導入されたバージョン:
5.0
関連項目:
直列化された形式

フィールドの概要
static DeleteType | CASCADE 削除 ターゲットエンティティのデータを参照しているソースエンティティのデータを削除します。
static DeleteType | EXCEPTION 例外 例外を発生させます。
static DeleteType | NULL Null ターゲットエンティティのデータを参照しているソースエンティティの外部キーをnullにします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

CASCADE

public static final DeleteType CASCADE
削除 ターゲットエンティティのデータを参照しているソースエンティティのデータを削除します。

NULL

public static final DeleteType NULL
Null ターゲットエンティティのデータを参照しているソースエンティティの外部キーをnullにします。

EXCEPTION

public static final DeleteType EXCEPTION
例外 例外を発生させます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Entity (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Entity

public interface Entity

エンティティを定義します。

導入されたバージョン:
5.0

メソッドの概要
Application | getApplication() エンティティを定義しているアプリケーションを取得します。
Map | getAttributes() エンティティに含まれる属性をすべて取得します。
Map | getExtendedEntities() このエンティティを拡張している拡張エンティティをすべて取得します。
Model | getModel() このエンティティを参照しているモデルを取得します。
String | getName() エンティティ名を取得します。
Attribute[] | getPrimaryKeys() エンティティのプライマリキーとなる属性をすべて取得します。
Map | getReferedRelationships() このエンティティの属性を、国際化基準項目や期間化基準項目などを使用して参照している全てのリレーションシップを取得します。
Map | getSourceRelationships() このエンティティをソースとしているリレーションシップをすべて取得します。
Table | getTable() このエンティティを参照しているテーブルを取得します。
Map | getTargetRelationships() このエンティティをターゲットとしているリレーションシップをすべて取得します。
UpdateInfo | getUpdateInfo() エンティティの更新情報を取得します。
boolean | isInternational() エンティティが国際化の対象であるかどうかを取得します。
boolean | isTerminable() エンティティが期間化の対象であるかどうかを取得します。
boolean | isTerminableInternational() エンティティが期間国際化の対象であるかどうかを取得します。

メソッドの詳細

getApplication

public Application getApplication()
エンティティを定義しているアプリケーションを取得します。

戻り値:
エンティティを定義しているアプリケーション

getAttributes

public Map getAttributes()
エンティティに含まれる属性をすべて取得します。 属性名をキー、 Attributeを値としたマップを返します。

戻り値:
エンティティに含まれる属性

getName

public String getName()
エンティティ名を取得します。

戻り値:
エンティティ名

getPrimaryKeys

public Attribute[] getPrimaryKeys()
エンティティのプライマリキーとなる属性をすべて取得します。 ここで取得される属性は、 getAttributes()で取得される配列の部分集合になります。 また、配列の順番はプライマリキーとして定義された順番になります。

戻り値:
プライマリキーとなる属性

getUpdateInfo

public UpdateInfo getUpdateInfo()
エンティティの更新情報を取得します。 存在しない場合はnullを返します。

戻り値:
エンティティの更新情報

isTerminable

public boolean isTerminable()
エンティティが期間化の対象であるかどうかを取得します。

戻り値:
属性が期間化の対象である場合 true 、そうでない場合 false

isInternational

public boolean isInternational()
エンティティが国際化の対象であるかどうかを取得します。

戻り値:
属性が国際化の対象である場合 true 、そうでない場合 false

isTerminableInternational

public boolean isTerminableInternational()
エンティティが期間国際化の対象であるかどうかを取得します。

戻り値:
エンティティが期間国際化の対象である場合 true 、そうでない場合 false

getExtendedEntities

public Map getExtendedEntities()
このエンティティを拡張している拡張エンティティをすべて取得します。 「拡張エンティティが定義されているアプリケーション名 + . + 拡張名」 をキー、 ExtendedEntity を値としたマップを返します。

例
拡張エンティティが定義されているアプリケーション名：jp.co.intra_mart
拡張名：ExtendedEntity
上記のようなときは「jp.co.intra_mart.ExtendedEntity」がキーとなります。

戻り値:
拡張エンティティ一覧

getTable

public Table getTable()
このエンティティを参照しているテーブルを取得します。
このエンティティを参照しているテーブルが存在しないときは null を返します。

戻り値:
このエンティティを参照しているテーブル

getModel

public Model getModel()
このエンティティを参照しているモデルを取得します。

戻り値:
このエンティティを参照しているモデル

getSourceRelationships

public Map getSourceRelationships()
このエンティティをソースとしているリレーションシップをすべて取得します。 「リレーションシップが定義されているアプリケーション名 + . + リレーションシップ名」 をキー、 Relationship を値としたマップを返します。

例
リレーションシップが定義されているアプリケーション名：jp.co.intra_mart
リレーションシップ名：Relationship1
上記のようなときは「jp.co.intra_mart.Relationship1」がキーとなります。

戻り値:
このエンティティをソースとしているリレーションシップ

getTargetRelationships

public Map getTargetRelationships()
このエンティティをターゲットとしているリレーションシップをすべて取得します。 「リレーションシップが定義されているアプリケーション名 + . + リレーションシップ名」 をキー、 Relationship を値としたマップを返します。

例
リレーションシップが定義されているアプリケーション名：jp.co.intra_mart
リレーションシップ名：Relationship1
上記のようなときは「jp.co.intra_mart.Relationship1」がキーとなります。

戻り値:
このエンティティをターゲットとしているリレーションシップをすべて取得します。

getReferedRelationships

public Map getReferedRelationships()
このエンティティの属性を、国際化基準項目や期間化基準項目などを使用して参照している全てのリレーションシップを取得します。
ただし、このエンティティがソースとなるリレーションシップは取得対象となりません。 「リレーションシップが定義されているアプリケーション名 + . + リレーションシップ名」 をキー、 Relationship を値としたマップを返します。

例
リレーションシップが定義されているアプリケーション名：jp.co.intra_mart
リレーションシップ名：Relationship1
上記のようなときは「jp.co.intra_mart.Relationship1」がキーとなります。

戻り値:
このエンティティの属性を、国際化基準項目や期間化基準項目などを使用して参照している全てのリレーションシップを取得します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExpirationKey (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExpirationKey

public interface ExpirationKey

ライフタイム期間の有効終了日時を定義します。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getAttribute() ライフタイム期間の有効終了日時となる属性を取得します。
Relationship[] | getRefereRelationships() ソースエンティティから有効終了日時を持つエンティティまでのリレーションシップを取得します。
Entity | getSourceEntity() ライフタイム期間の有効終了日時の基点となるソースエンティティの情報を取得します。

メソッドの詳細

getSourceEntity

public Entity getSourceEntity()
ライフタイム期間の有効終了日時の基点となるソースエンティティの情報を取得します。

戻り値:
ソースエンティティの情報

getRefereRelationships

public Relationship[] getRefereRelationships()
ソースエンティティから有効終了日時を持つエンティティまでのリレーションシップを取得します。

戻り値:
ソースエンティティから有効終了日時を持つエンティティまでのリレーションシップ

getAttribute

public Attribute getAttribute()
ライフタイム期間の有効終了日時となる属性を取得します。

戻り値:
ライフタイム期間の有効終了日時となる属性
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedBaseModel

public interface ExtendedBaseModel

拡張基本モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
String | getClassName() 拡張基本モデルのクラス名を取得します。
ExtendedModel | getExtendedModel() 拡張基本モデルが定義されている拡張モデル定義を取得します。

メソッドの詳細

getExtendedModel

public ExtendedModel getExtendedModel()
拡張基本モデルが定義されている拡張モデル定義を取得します。

戻り値:
拡張基本モデルが定義されている拡張モデル定義

getClassName

public String getClassName()
拡張基本モデルのクラス名を取得します。

戻り値:
拡張基本モデルのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedBaseTable (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedBaseTable

public interface ExtendedBaseTable

拡張基本テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getColumnMappings() 拡張基本テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
ExtendedTable | getExtendedTable() 拡張基本テーブルが定義されている拡張テーブル定義を取得します。
String | getName() 拡張基本テーブルのテーブル名を取得します。
Map | getPrimaryKeyMappings() 拡張基本テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。

メソッドの詳細

getExtendedTable

public ExtendedTable getExtendedTable()
拡張基本テーブルが定義されている拡張テーブル定義を取得します。

戻り値:
拡張基本テーブルが定義されている拡張テーブル定義

getName

public String getName()
拡張基本テーブルのテーブル名を取得します。

戻り値:
拡張基本テーブルのテーブル名

getColumnMappings

public Map getColumnMappings()
拡張基本テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。 属性名をキー、 ColumnMappingを値としたマップを返します。

戻り値:
拡張基本テーブルに含まれるカラムマッピング

getPrimaryKeyMappings

public Map getPrimaryKeyMappings()
拡張基本テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。 属性名をキー、 PrimaryKeyMappingを値としたマップを返します。

戻り値:
拡張基本テーブルに含まれるプライマリキーマッピング
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedEntity (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedEntity

public interface ExtendedEntity

拡張エンティティを定義します。

導入されたバージョン:
5.0

メソッドの概要
Application | getApplication() 拡張エンティティを定義しているアプリケーションを取得します。
Map | getAttributes() 拡張エンティティに含まれる属性をすべて取得します。
Entity | getEntity() 拡張対象となるエンティティを取得します。
ExtendedModel | getExtendedModel() この拡張エンティティを参照している拡張モデルを取得します。
ExtendedTable | getExtendedTable() この拡張エンティティを参照している拡張テーブルを取得します。
String | getName() 拡張名を取得します。
boolean | hasBaseAttributes() 拡張エンティティが期間化も国際化もされていない従属属性を持つかどうか判定します。
boolean | hasInternationalAttributes() 拡張エンティティが国際化のみされている従属属性を持つかどうか判定します。
boolean | hasTerminableAttributes() 拡張エンティティが期間化のみされている従属属性を持つかどうか判定します。
boolean | hasTerminableInternationalAttributes() 拡張エンティティが期間国際化されている従属属性を持つかどうか判定します。

メソッドの詳細

getApplication

public Application getApplication()
拡張エンティティを定義しているアプリケーションを取得します。

戻り値:
拡張エンティティを定義しているアプリケーション

getAttributes

public Map getAttributes()
拡張エンティティに含まれる属性をすべて取得します。 属性名をキー、 Attributeを値としたマップを返します。

戻り値:
拡張エンティティに含まれる属性

getName

public String getName()
拡張名を取得します。

戻り値:
拡張名

getEntity

public Entity getEntity()
拡張対象となるエンティティを取得します。

戻り値:
拡張対象となるエンティティ

getExtendedTable

public ExtendedTable getExtendedTable()
この拡張エンティティを参照している拡張テーブルを取得します。
この拡張エンティティを参照している拡張テーブルが存在しないときは null を返します。

戻り値:
この拡張エンティティを参照している拡張テーブル

getExtendedModel

public ExtendedModel getExtendedModel()
この拡張エンティティを参照している拡張モデルを取得します。
この拡張エンティティを参照している拡張モデルが存在しないときは null を返します。

戻り値:
この拡張エンティティを参照している拡張モデル

hasBaseAttributes

public boolean hasBaseAttributes()
拡張エンティティが期間化も国際化もされていない従属属性を持つかどうか判定します。

戻り値:
期間化も国際化もされていない従属属性を持つときは、 true 、そうでない場合 false

hasTerminableAttributes

public boolean hasTerminableAttributes()
拡張エンティティが期間化のみされている従属属性を持つかどうか判定します。

戻り値:
期間化のみされている従属属性を持つ場合は true 、そうでない場合 false

hasInternationalAttributes

public boolean hasInternationalAttributes()
拡張エンティティが国際化のみされている従属属性を持つかどうか判定します。

戻り値:
国際化のみされている従属属性を持つ場合は true 、そうでない場合 false

hasTerminableInternationalAttributes

public boolean hasTerminableInternationalAttributes()
拡張エンティティが期間国際化されている従属属性を持つかどうか判定します。

戻り値:
期間国際化されている従属属性を持つ場合は true 、そうでない場合 false
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedInternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedInternationalModel

public interface ExtendedInternationalModel

拡張国際化モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
String | getClassName() 拡張国際化モデルのクラス名を取得します。
ExtendedModel | getExtendedModel() 拡張国際化モデルが定義されている拡張モデル定義を取得します。

メソッドの詳細

getExtendedModel

public ExtendedModel getExtendedModel()
拡張国際化モデルが定義されている拡張モデル定義を取得します。

戻り値:
拡張国際化モデルが定義されている拡張モデル定義

getClassName

public String getClassName()
拡張国際化モデルのクラス名を取得します。

戻り値:
拡張国際化モデルのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedInternationalTable (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedInternationalTable

public interface ExtendedInternationalTable

拡張国際化テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getColumnMappings() 拡張国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
ExtendedTable | getExtendedTable() 拡張国際化テーブルが定義されている拡張テーブル定義を取得します。
String | getLocaleColumnName() ロケールに該当するカラムのカラム名を取得します。
String | getName() 拡張国際化テーブルのテーブル名を取得します。
Map | getPrimaryKeyMappings() 拡張国際化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。

メソッドの詳細

getExtendedTable

public ExtendedTable getExtendedTable()
拡張国際化テーブルが定義されている拡張テーブル定義を取得します。

戻り値:
拡張国際化テーブルが定義されている拡張テーブル定義

getName

public String getName()
拡張国際化テーブルのテーブル名を取得します。

戻り値:
拡張国際化テーブルのテーブル名

getColumnMappings

public Map getColumnMappings()
拡張国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。 属性名をキー、 ColumnMappingを値としたマップを返します。

戻り値:
拡張国際化テーブルに含まれるカラムマッピング

getLocaleColumnName

public String getLocaleColumnName()
ロケールに該当するカラムのカラム名を取得します。

戻り値:
カラム名

getPrimaryKeyMappings

public Map getPrimaryKeyMappings()
拡張国際化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。 属性名をキー、 PrimaryKeyMappingを値としたマップを返します。

戻り値:
拡張国際化テーブルに含まれるプライマリキーマッピング
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedModel

public interface ExtendedModel

拡張モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Application | getApplication() 拡張モデルを定義しているアプリケーションを取得します。
ExtendedBaseModel | getExtendedBaseModel() 拡張基本モデルを取得します。
ExtendedEntity | getExtendedEntity() 拡張モデル定義の基となる拡張エンティティを取得します。
ExtendedInternationalModel | getExtendedInternationalModel() 拡張国際化モデルを取得します。
ExtendedTerminableInternationalModel | getExtendedTerminableInternationalModel() 拡張期間国際化モデルを取得します。
ExtendedTerminableModel | getExtendedTerminableModel() 拡張期間化モデルを取得します。
Map | getProperties() 拡張モデルに含まれるプロパティをすべて取得します。

メソッドの詳細

getApplication

public Application getApplication()
拡張モデルを定義しているアプリケーションを取得します。

戻り値:
拡張モデルを定義しているアプリケーション

getExtendedEntity

public ExtendedEntity getExtendedEntity()
拡張モデル定義の基となる拡張エンティティを取得します。

戻り値:
拡張モデル定義の基となる拡張エンティティ

getProperties

public Map getProperties()
拡張モデルに含まれるプロパティをすべて取得します。 属性名をキー、 Propertyを値としたマップを返します。

戻り値:
拡張モデルに含まれるプロパティ

getExtendedBaseModel

public ExtendedBaseModel getExtendedBaseModel()
拡張基本モデルを取得します。 拡張基本モデルが使用されない場合、 null が返されます。

戻り値:
拡張基本モデル

getExtendedInternationalModel

public ExtendedInternationalModel getExtendedInternationalModel()
拡張国際化モデルを取得します。 拡張国際化モデルが使用されない場合、 null が返されます。

戻り値:
拡張国際化モデル

getExtendedTerminableModel

public ExtendedTerminableModel getExtendedTerminableModel()
拡張期間化モデルを取得します。 拡張期間化モデルが使用されない場合、 null が返されます。

戻り値:
拡張期間化モデル

getExtendedTerminableInternationalModel

public ExtendedTerminableInternationalModel getExtendedTerminableInternationalModel()
拡張期間国際化モデルを取得します。 拡張期間国際化モデルが使用されない場合、 null が返されます。

戻り値:
拡張期間国際化モデル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTable (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedTable

public interface ExtendedTable

拡張テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Application | getApplication() 拡張テーブルを定義しているアプリケーションを取得します。
Map | getColumns() 拡張テーブルに含まれるカラムをすべて取得します。
ExtendedBaseTable | getExtendedBaseTable() 拡張基本テーブルを取得します。
ExtendedEntity | getExtendedEntity() 拡張テーブル定義の基となる拡張エンティティを取得します。
ExtendedInternationalTable | getExtendedInternationalTable() 拡張国際化テーブルを取得します。
ExtendedTerminableInternationalTable | getExtendedTerminableInternationalTable() 拡張期間国際化テーブルを取得します。
ExtendedTerminableTable | getExtendedTerminableTable() 拡張期間化テーブルを取得します。

メソッドの詳細

getApplication

public Application getApplication()
拡張テーブルを定義しているアプリケーションを取得します。

戻り値:
拡張テーブルを定義しているアプリケーション

getExtendedEntity

public ExtendedEntity getExtendedEntity()
拡張テーブル定義の基となる拡張エンティティを取得します。

戻り値:
拡張テーブル定義の基となる拡張エンティティ

getColumns

public Map getColumns()
拡張テーブルに含まれるカラムをすべて取得します。 属性名をキー、 Columnを値としたマップを返します。

戻り値:
拡張テーブルに含まれるカラム

getExtendedBaseTable

public ExtendedBaseTable getExtendedBaseTable()
拡張基本テーブルを取得します。 拡張基本テーブルが定義されていない場合、 null が返されます。

戻り値:
拡張基本テーブル

getExtendedInternationalTable

public ExtendedInternationalTable getExtendedInternationalTable()
拡張国際化テーブルを取得します。 拡張国際化テーブルが定義されていない場合、 null が返されます。

戻り値:
拡張国際化テーブル

getExtendedTerminableTable

public ExtendedTerminableTable getExtendedTerminableTable()
拡張期間化テーブルを取得します。 拡張期間化テーブルが定義されていない場合、 null が返されます。

戻り値:
拡張期間化テーブル

getExtendedTerminableInternationalTable

public ExtendedTerminableInternationalTable getExtendedTerminableInternationalTable()
拡張期間国際化テーブルを取得します。 拡張期間国際化テーブルが定義されていない場合、 null が返されます。

戻り値:
拡張期間国際化テーブル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableInternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedTerminableInternationalModel

public interface ExtendedTerminableInternationalModel

拡張期間国際化モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
String | getClassName() 拡張期間国際化モデルのクラス名を取得します。
ExtendedModel | getExtendedModel() 拡張期間国際化モデルが定義されている拡張モデル定義を取得します。

メソッドの詳細

getExtendedModel

public ExtendedModel getExtendedModel()
拡張期間国際化モデルが定義されている拡張モデル定義を取得します。

戻り値:
拡張期間国際化モデルが定義されている拡張モデル定義

getClassName

public String getClassName()
拡張期間国際化モデルのクラス名を取得します。

戻り値:
拡張期間国際化モデルのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableInternationalTable (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedTerminableInternationalTable

public interface ExtendedTerminableInternationalTable

拡張期間国際化テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getColumnMappings() 拡張期間国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
ExtendedTable | getExtendedTable() 拡張期間国際化テーブルが定義されている拡張テーブル定義を取得します。
String | getLocaleColumnName() ロケールに該当するカラムのカラム名を取得します。
String | getName() 拡張期間国際化テーブルのテーブル名を取得します。
Map | getPrimaryKeyMappings() 拡張期間国際化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。
String | getTermColumnName() 期間CDに該当するカラムのカラム名を取得します。

メソッドの詳細

getExtendedTable

public ExtendedTable getExtendedTable()
拡張期間国際化テーブルが定義されている拡張テーブル定義を取得します。

戻り値:
拡張期間国際化テーブルが定義されている拡張テーブル定義

getName

public String getName()
拡張期間国際化テーブルのテーブル名を取得します。

戻り値:
拡張期間国際化テーブルのテーブル名

getColumnMappings

public Map getColumnMappings()
拡張期間国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。 属性名をキー、 ColumnMappingを値としたマップを返します。

戻り値:
拡張期間国際化テーブルに含まれるカラムマッピング

getTermColumnName

public String getTermColumnName()
期間CDに該当するカラムのカラム名を取得します。

戻り値:
カラム名

getLocaleColumnName

public String getLocaleColumnName()
ロケールに該当するカラムのカラム名を取得します。

戻り値:
カラム名

getPrimaryKeyMappings

public Map getPrimaryKeyMappings()
拡張期間国際化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。 属性名をキー、 PrimaryKeyMappingを値としたマップを返します。

戻り値:
拡張期間国際化テーブルに含まれるプライマリキーマッピング
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedTerminableModel

public interface ExtendedTerminableModel

拡張期間化モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
String | getClassName() 拡張期間化モデルのクラス名を取得します。
ExtendedModel | getExtendedModel() 拡張期間化モデルが定義されている拡張モデル定義を取得します。

メソッドの詳細

getExtendedModel

public ExtendedModel getExtendedModel()
拡張期間化モデルが定義されている拡張モデル定義を取得します。

戻り値:
拡張期間化モデルが定義されている拡張モデル定義

getClassName

public String getClassName()
拡張期間化モデルのクラス名を取得します。

戻り値:
拡張期間化モデルのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableTable (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedTerminableTable

public interface ExtendedTerminableTable

拡張期間化テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getColumnMappings() 拡張期間化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
ExtendedTable | getExtendedTable() 拡張期間化テーブルが定義されている拡張テーブル定義を取得します。
String | getName() 拡張期間化テーブルのテーブル名を取得します。
Map | getPrimaryKeyMappings() 拡張期間化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。
String | getTermColumnName() 期間CDに該当するカラムのカラム名を取得します。

メソッドの詳細

getExtendedTable

public ExtendedTable getExtendedTable()
拡張期間化テーブルが定義されている拡張テーブル定義を取得します。

戻り値:
拡張期間化テーブルが定義されている拡張テーブル定義

getName

public String getName()
拡張期間化テーブルのテーブル名を取得します。

戻り値:
拡張期間化テーブルのテーブル名

getColumnMappings

public Map getColumnMappings()
拡張期間化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。 属性名をキー、 ColumnMappingを値としたマップを返します。

戻り値:
拡張期間化テーブルに含まれるカラムマッピング

getTermColumnName

public String getTermColumnName()
期間CDに該当するカラムのカラム名を取得します。

戻り値:
カラム名

getPrimaryKeyMappings

public Map getPrimaryKeyMappings()
拡張期間化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。 属性名をキー、 PrimaryKeyMappingを値としたマップを返します。

戻り値:
拡張期間化テーブルに含まれるプライマリキーマッピング
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalKey (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース InternationalKey

public interface InternationalKey

国際化基準項目を定義します。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getAttribute() 国際化基準項目となる属性を取得します。
Relationship[] | getRefereRelationships() ソースエンティティから国際化基準項目を持つエンティティまでのリレーションシップを取得します。
Entity | getSourceEntity() 国際化基準項目の基点となるソースエンティティの情報を取得します。

メソッドの詳細

getSourceEntity

public Entity getSourceEntity()
国際化基準項目の基点となるソースエンティティの情報を取得します。

戻り値:
ソースエンティティの情報

getRefereRelationships

public Relationship[] getRefereRelationships()
ソースエンティティから国際化基準項目を持つエンティティまでのリレーションシップを取得します。

戻り値:
ソースエンティティから国際化基準項目を持つエンティティまでのリレーションシップ

getAttribute

public Attribute getAttribute()
国際化基準項目となる属性を取得します。

戻り値:
国際化基準項目となる属性
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース InternationalModel

public interface InternationalModel

国際化モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
String | getClassName() 国際化モデルのクラス名を取得します。
Model | getModel() 国際化モデルが定義されているモデル定義を取得します。

メソッドの詳細

getModel

public Model getModel()
国際化モデルが定義されているモデル定義を取得します。

戻り値:
国際化モデルが定義されているモデル定義

getClassName

public String getClassName()
国際化モデルのクラス名を取得します。

戻り値:
国際化モデルのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalTable (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース InternationalTable

public interface InternationalTable

国際化テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getColumnMappings() 国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
String | getLocaleColumnName() ロケールに該当するカラムのカラム名を取得します。
String | getName() 国際化テーブルのテーブル名を取得します。
Table | getTable() 国際化テーブルが定義されているテーブル定義を取得します。

メソッドの詳細

getTable

public Table getTable()
国際化テーブルが定義されているテーブル定義を取得します。

戻り値:
国際化テーブルが定義されているテーブル定義

getName

public String getName()
国際化テーブルのテーブル名を取得します。

戻り値:
国際化テーブルのテーブル名

getColumnMappings

public Map getColumnMappings()
国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。 属性名をキー、 ColumnMappingを値としたマップを返します。

戻り値:
国際化テーブルに含まれるカラムマッピング

getLocaleColumnName

public String getLocaleColumnName()
ロケールに該当するカラムのカラム名を取得します。

戻り値:
カラム名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Lifetime (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Lifetime

public interface Lifetime

期間削除時の整合性制約です。 ターゲットエンティティの期間（またはその一部）が削除された場合の整合性制約です。

導入されたバージョン:
5.0

メソッドの概要
LifetimeType | getLifetimeType() ターゲットエンティティの期間削除時の整合性制約のタイプを取得します
Attribute[] | getNullKeys() ターゲットエンティティの期間削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。

メソッドの詳細

getLifetimeType

public LifetimeType getLifetimeType()
ターゲットエンティティの期間削除時の整合性制約のタイプを取得します

戻り値:
期間削除時の整合性制約のタイプ

getNullKeys

public Attribute[] getNullKeys()
ターゲットエンティティの期間削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。

戻り値:
期間削除時の整合性制約の対象となる外部キー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LifetimeType (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
クラス LifetimeType

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.config.LifetimeType
public class LifetimeType
extends Object

期間削除時の整合性制約のタイプです。 ターゲットエンティティの期間（またはその一部）が削除された場合の整合性制約のタイプです。

導入されたバージョン:
5.0

フィールドの概要
static LifetimeType | CASCADE 削除 ターゲットエンティティの期間を参照しているソースエンティティのデータを削除します。
static LifetimeType | EXCEPTION 例外 例外を発生させます。
static LifetimeType | NULL Null ターゲットエンティティの期間を参照しているソースエンティティの外部キーをnullにします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

CASCADE

public static final LifetimeType CASCADE
削除 ターゲットエンティティの期間を参照しているソースエンティティのデータを削除します。

NULL

public static final LifetimeType NULL
Null ターゲットエンティティの期間を参照しているソースエンティティの外部キーをnullにします。

EXCEPTION

public static final LifetimeType EXCEPTION
例外 例外を発生させます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Model (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Model

public interface Model

モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Application | getApplication() モデルを定義しているアプリケーションを取得します。
BaseModel | getBaseModel() 基本モデルを取得します。
Entity | getEntity() モデル定義の基となるエンティティを取得します。
InternationalModel | getInternationalModel() 国際化モデルを取得します。
String | getMapperClassName() マッパのクラス名を取得します。
Map | getProperties() モデルに含まれるプロパティをすべて取得します。
TerminableInternationalModel | getTerminableInternationalModel() 期間国際化モデルを取得します。
TerminableModel | getTerminableModel() 期間化モデルを取得します。

メソッドの詳細

getApplication

public Application getApplication()
モデルを定義しているアプリケーションを取得します。

戻り値:
モデルを定義しているアプリケーション

getEntity

public Entity getEntity()
モデル定義の基となるエンティティを取得します。

戻り値:
モデル定義の基となるエンティティ

getProperties

public Map getProperties()
モデルに含まれるプロパティをすべて取得します。 属性名をキー、 Propertyを値としたマップを返します。

戻り値:
モデルに含まれるプロパティ

getMapperClassName

public String getMapperClassName()
マッパのクラス名を取得します。

戻り値:
マッパのクラス名

getBaseModel

public BaseModel getBaseModel()
基本モデルを取得します。

戻り値:
基本モデル

getInternationalModel

public InternationalModel getInternationalModel()
国際化モデルを取得します。 国際化モデルが使用されない場合、 null が返されます。

戻り値:
国際化モデル

getTerminableModel

public TerminableModel getTerminableModel()
期間化モデルを取得します。 期間化モデルが使用されない場合、 null が返されます。

戻り値:
期間化モデル

getTerminableInternationalModel

public TerminableInternationalModel getTerminableInternationalModel()
期間国際化モデルを取得します。 期間国際化モデルが使用されない場合、 null が返されます。

戻り値:
期間国際化モデル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.common.config (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.common.config
インタフェース
ActivationKey
Application
Attribute
BaseModel
BaseTable
Column
ColumnMapping
Configuration
Delete
Entity
ExpirationKey
ExtendedBaseModel
ExtendedBaseTable
ExtendedEntity
ExtendedInternationalModel
ExtendedInternationalTable
ExtendedModel
ExtendedTable
ExtendedTerminableInternationalModel
ExtendedTerminableInternationalTable
ExtendedTerminableModel
ExtendedTerminableTable
InternationalKey
InternationalModel
InternationalTable
Lifetime
Model
PrimaryKeyMapping
Property
Relationship
Table
TerminableInternationalModel
TerminableInternationalTable
TerminableKey
TerminableModel
TerminableTable
UpdateInfo
クラス
AttributeType
ConfigurationFactory
DeleteType
LifetimeType


jp.co.intra_mart.foundation.datastore.common.config (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.common.config

アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

参照:
説明

インタフェースの概要
ActivationKey | ライフタイム期間の有効開始日時を定義します。
Application | アプリケーションを定義します。
Attribute | 属性を定義します。
BaseModel | 基本モデルを定義します。
BaseTable | 基本テーブルを定義します。
Column | 属性に対応するカラムの型を定義します。
ColumnMapping | 分割されたテーブルに割り当てられるカラムを定義します。
Configuration | 設定内容を取得します。
Delete | 削除時の整合性制約です。
Entity | エンティティを定義します。
ExpirationKey | ライフタイム期間の有効終了日時を定義します。
ExtendedBaseModel | 拡張基本モデルを定義します。
ExtendedBaseTable | 拡張基本テーブルを定義します。
ExtendedEntity | 拡張エンティティを定義します。
ExtendedInternationalModel | 拡張国際化モデルを定義します。
ExtendedInternationalTable | 拡張国際化テーブルを定義します。
ExtendedModel | 拡張モデルを定義します。
ExtendedTable | 拡張テーブルを定義します。
ExtendedTerminableInternationalModel | 拡張期間国際化モデルを定義します。
ExtendedTerminableInternationalTable | 拡張期間国際化テーブルを定義します。
ExtendedTerminableModel | 拡張期間化モデルを定義します。
ExtendedTerminableTable | 拡張期間化テーブルを定義します。
InternationalKey | 国際化基準項目を定義します。
InternationalModel | 国際化モデルを定義します。
InternationalTable | 国際化テーブルを定義します。
Lifetime | 期間削除時の整合性制約です。
Model | モデルを定義します。
PrimaryKeyMapping | 分割されたテーブルに割り当てられるプライマリーキーとなるカラムを定義します。
Property | プロパティを定義します。
Relationship | リレーションシップを定義します。
Table | テーブルを定義します。
TerminableInternationalModel | 期間国際化モデルを定義します。
TerminableInternationalTable | 期間国際化テーブルを定義します。
TerminableKey | 期間化基準項目を定義します。
TerminableModel | 期間化モデルを定義します。
TerminableTable | 期間化テーブルを定義します。
UpdateInfo | エンティティの更新情報です。

クラスの概要
AttributeType | 属性で指定できる型です。
ConfigurationFactory | Configurationを生成します。
DeleteType | 削除時の整合性制約のタイプです。
LifetimeType | 期間削除時の整合性制約のタイプです。

パッケージ jp.co.intra_mart.foundation.datastore.common.config の説明

アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。


jp.co.intra_mart.foundation.datastore.common.config クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.common.config の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.common.config.AttributeType (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory
    • class jp.co.intra_mart.foundation.datastore.common.config.DeleteType (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.common.config.LifetimeType

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.config.ActivationKey
  • interface jp.co.intra_mart.foundation.datastore.common.config.Application
  • interface jp.co.intra_mart.foundation.datastore.common.config.Attribute
  • interface jp.co.intra_mart.foundation.datastore.common.config.BaseModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.BaseTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.Column
  • interface jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping
  • interface jp.co.intra_mart.foundation.datastore.common.config.Configuration
  • interface jp.co.intra_mart.foundation.datastore.common.config.Delete
  • interface jp.co.intra_mart.foundation.datastore.common.config.Entity
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.InternationalKey
  • interface jp.co.intra_mart.foundation.datastore.common.config.InternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.Lifetime
  • interface jp.co.intra_mart.foundation.datastore.common.config.Model
  • interface jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping
  • interface jp.co.intra_mart.foundation.datastore.common.config.Property
  • interface jp.co.intra_mart.foundation.datastore.common.config.Relationship
  • interface jp.co.intra_mart.foundation.datastore.common.config.Table
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableKey
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.UpdateInfo


パッケージ jp.co.intra_mart.foundation.datastore.common.config の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.common.config の使用

jp.co.intra_mart.foundation.datastore.common.config を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.config | アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor により使用される jp.co.intra_mart.foundation.datastore.common.config のクラス
Entity
エンティティを定義します。

jp.co.intra_mart.foundation.datastore.common.config により使用される jp.co.intra_mart.foundation.datastore.common.config のクラス
ActivationKey
ライフタイム期間の有効開始日時を定義します。
Application
アプリケーションを定義します。
Attribute
属性を定義します。
AttributeType
属性で指定できる型です。
BaseModel
基本モデルを定義します。
BaseTable
基本テーブルを定義します。
Configuration
設定内容を取得します。
ConfigurationFactory
Configurationを生成します。
Delete
削除時の整合性制約です。
DeleteType
削除時の整合性制約のタイプです。
Entity
エンティティを定義します。
ExpirationKey
ライフタイム期間の有効終了日時を定義します。
ExtendedBaseModel
拡張基本モデルを定義します。
ExtendedBaseTable
拡張基本テーブルを定義します。
ExtendedEntity
拡張エンティティを定義します。
ExtendedInternationalModel
拡張国際化モデルを定義します。
ExtendedInternationalTable
拡張国際化テーブルを定義します。
ExtendedModel
拡張モデルを定義します。
ExtendedTable
拡張テーブルを定義します。
ExtendedTerminableInternationalModel
拡張期間国際化モデルを定義します。
ExtendedTerminableInternationalTable
拡張期間国際化テーブルを定義します。
ExtendedTerminableModel
拡張期間化モデルを定義します。
ExtendedTerminableTable
拡張期間化テーブルを定義します。
InternationalKey
国際化基準項目を定義します。
InternationalModel
国際化モデルを定義します。
InternationalTable
国際化テーブルを定義します。
Lifetime
期間削除時の整合性制約です。
LifetimeType
期間削除時の整合性制約のタイプです。
Model
モデルを定義します。
Relationship
リレーションシップを定義します。
Table
テーブルを定義します。
TerminableInternationalModel
期間国際化モデルを定義します。
TerminableInternationalTable
期間国際化テーブルを定義します。
TerminableKey
期間化基準項目を定義します。
TerminableModel
期間化モデルを定義します。
TerminableTable
期間化テーブルを定義します。
UpdateInfo
エンティティの更新情報です。

jp.co.intra_mart.foundation.datastore.common.model により使用される jp.co.intra_mart.foundation.datastore.common.config のクラス
Relationship
リレーションシップを定義します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PrimaryKeyMapping (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース PrimaryKeyMapping

public interface PrimaryKeyMapping

分割されたテーブルに割り当てられるプライマリーキーとなるカラムを定義します。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getAttribute() プライマリーキーとなる属性を取得します。
String | getName() プライマリーキーとなるカラム名を取得します。

メソッドの詳細

getAttribute

public Attribute getAttribute()
プライマリーキーとなる属性を取得します。

戻り値:
カラムに割り当てる属性

getName

public String getName()
プライマリーキーとなるカラム名を取得します。

戻り値:
カラム名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Property (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Property

public interface Property

プロパティを定義します。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getAttribute() プロパティに対応付ける属性を取得します。
String | getType() プロパティの型を取得します。

メソッドの詳細

getAttribute

public Attribute getAttribute()
プロパティに対応付ける属性を取得します。

戻り値:
プロパティに対応付ける属性

getType

public String getType()
プロパティの型を取得します。

戻り値:
プロパティの型
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Relationship (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Relationship

public interface Relationship

リレーションシップを定義します。

導入されたバージョン:
5.0

メソッドの概要
ActivationKey | getActivationKey() ソースエンティティのライフタイム期間の有効開始日時を取得します。
Application | getApplication() リレーションシップが定義されているアプリケーションを取得します。
Delete | getDelete() ターゲットエンティティのデータ削除時の整合性制約を取得します。
ExpirationKey | getExpirationKey() ソースエンティティのライフタイム期間の有効終了日時を取得します。
Attribute[] | getForeignKeys() ソースエンティティの外部キーの集合を取得します。
InternationalKey | getInternationalKey() ソースエンティティの国際化基準項目を取得します。
Lifetime | getLifetime() ターゲットエンティティの期間削除時の整合性制約を取得します。
String | getName() リレーションシップ名を取得します。
Entity | getSourceEntity() ソースエンティティの情報を取得します。
Entity | getTargetEntity() ターゲットエンティティの情報を取得します。
TerminableKey | getTerminableKey() ソースエンティティの期間化基準項目を取得します。

メソッドの詳細

getApplication

public Application getApplication()
リレーションシップが定義されているアプリケーションを取得します。

戻り値:
リレーションシップが定義されているアプリケーション

getName

public String getName()
リレーションシップ名を取得します。

戻り値:
リレーションシップ名

getSourceEntity

public Entity getSourceEntity()
ソースエンティティの情報を取得します。

戻り値:
ソースエンティティの情報

getTargetEntity

public Entity getTargetEntity()
ターゲットエンティティの情報を取得します。

戻り値:
ターゲットエンティティの情報

getForeignKeys

public Attribute[] getForeignKeys()
ソースエンティティの外部キーの集合を取得します。 ターゲットエンティティのプライマリキーの順番と一致している必要があります。

戻り値:
ソースエンティティの外部キーの集合

getTerminableKey

public TerminableKey getTerminableKey()
ソースエンティティの期間化基準項目を取得します。

戻り値:
期間化基準項目となる属性

getInternationalKey

public InternationalKey getInternationalKey()
ソースエンティティの国際化基準項目を取得します。

戻り値:
国際化基準項目となる属性

getActivationKey

public ActivationKey getActivationKey()
ソースエンティティのライフタイム期間の有効開始日時を取得します。

戻り値:
ライフタイム期間の有効開始日時となる属性

getExpirationKey

public ExpirationKey getExpirationKey()
ソースエンティティのライフタイム期間の有効終了日時を取得します。

戻り値:
ライフタイム期間の有効終了日時となる属性

getDelete

public Delete getDelete()
ターゲットエンティティのデータ削除時の整合性制約を取得します。

戻り値:
データ削除時の整合性制約

getLifetime

public Lifetime getLifetime()
ターゲットエンティティの期間削除時の整合性制約を取得します。

戻り値:
期間削除時の整合性制約
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Table (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Table

public interface Table

テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Application | getApplication() テーブルを定義しているアプリケーションを取得します。
BaseTable | getBaseTable() 基本テーブルを取得します。
Map | getColumns() テーブルに含まれるカラムをすべて取得します。
Entity | getEntity() テーブル定義の基となるエンティティを取得します。
InternationalTable | getInternationalTable() 国際化テーブルを取得します。
TerminableInternationalTable | getTerminableInternationalTable() 期間国際化テーブルを取得します。
TerminableTable | getTerminableTable() 期間化テーブルを取得します。

メソッドの詳細

getApplication

public Application getApplication()
テーブルを定義しているアプリケーションを取得します。

戻り値:
テーブルを定義しているアプリケーション

getEntity

public Entity getEntity()
テーブル定義の基となるエンティティを取得します。

戻り値:
テーブル定義の基となるエンティティ

getColumns

public Map getColumns()
テーブルに含まれるカラムをすべて取得します。 属性名をキー、 Columnを値としたマップを返します。

戻り値:
テーブルに含まれるカラム

getBaseTable

public BaseTable getBaseTable()
基本テーブルを取得します。

戻り値:
基本テーブル

getInternationalTable

public InternationalTable getInternationalTable()
国際化テーブルを取得します。 国際化テーブルが定義されていない場合、 null が返されます。

戻り値:
国際化テーブル

getTerminableTable

public TerminableTable getTerminableTable()
期間化テーブルを取得します。 期間化テーブルが定義されていない場合、 null が返されます。

戻り値:
期間化テーブル

getTerminableInternationalTable

public TerminableInternationalTable getTerminableInternationalTable()
期間国際化テーブルを取得します。 期間国際化テーブルが定義されていない場合、 null が返されます。

戻り値:
期間国際化テーブル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableInternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース TerminableInternationalModel

public interface TerminableInternationalModel

期間国際化モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
String | getClassName() 期間国際化モデルのクラス名を取得します。
Model | getModel() 期間国際化モデルが定義されているモデル定義を取得します。

メソッドの詳細

getModel

public Model getModel()
期間国際化モデルが定義されているモデル定義を取得します。

戻り値:
期間国際化モデルが定義されているモデル定義

getClassName

public String getClassName()
期間国際化モデルのクラス名を取得します。

戻り値:
期間国際化モデルのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableInternationalTable (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース TerminableInternationalTable

public interface TerminableInternationalTable

期間国際化テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getColumnMappings() 期間国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
String | getLocaleColumnName() ロケールに該当するカラムのカラム名を取得します。
String | getName() 期間国際化テーブルのテーブル名を取得します。
Table | getTable() 期間国際化テーブルが定義されているテーブル定義を取得します。
String | getTermColumnName() 期間CDに該当するカラムのカラム名を取得します。

メソッドの詳細

getTable

public Table getTable()
期間国際化テーブルが定義されているテーブル定義を取得します。

戻り値:
期間国際化テーブルが定義されているテーブル定義

getName

public String getName()
期間国際化テーブルのテーブル名を取得します。

戻り値:
期間国際化テーブルのテーブル名

getColumnMappings

public Map getColumnMappings()
期間国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。 属性名をキー、 ColumnMappingを値としたマップを返します。

戻り値:
期間国際化テーブルに含まれるカラムマッピング

getTermColumnName

public String getTermColumnName()
期間CDに該当するカラムのカラム名を取得します。

戻り値:
カラム名

getLocaleColumnName

public String getLocaleColumnName()
ロケールに該当するカラムのカラム名を取得します。

戻り値:
カラム名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableKey (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース TerminableKey

public interface TerminableKey

期間化基準項目を定義します。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getAttribute() 期間化基準項目となる属性を取得します。
Relationship[] | getRefereRelationships() ソースエンティティから期間化基準項目を持つエンティティまでのリレーションシップを取得します。
Entity | getSourceEntity() 期間化基準項目の基点となるソースエンティティの情報を取得します。

メソッドの詳細

getSourceEntity

public Entity getSourceEntity()
期間化基準項目の基点となるソースエンティティの情報を取得します。

戻り値:
ソースエンティティの情報

getRefereRelationships

public Relationship[] getRefereRelationships()
ソースエンティティから期間化基準項目を持つエンティティまでのリレーションシップを取得します。

戻り値:
ソースエンティティから期間化基準項目を持つエンティティまでのリレーションシップ

getAttribute

public Attribute getAttribute()
期間化基準項目となる属性を取得します。

戻り値:
期間化基準項目となる属性
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース TerminableModel

public interface TerminableModel

期間化モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
String | getClassName() 期間化モデルのクラス名を取得します。
Model | getModel() 期間化モデルが定義されているモデル定義を取得します。

メソッドの詳細

getModel

public Model getModel()
期間化モデルが定義されているモデル定義を取得します。

戻り値:
期間化モデルが定義されているモデル定義

getClassName

public String getClassName()
期間化モデルのクラス名を取得します。

戻り値:
期間化モデルのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableTable (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース TerminableTable

public interface TerminableTable

期間化テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getColumnMappings() 期間化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
String | getEndDateColumnName() 期間の日時に該当するカラムのカラム名を取得します。
String | getName() 期間化テーブルのテーブル名を取得します。
String | getStartDateColumnName() 期間の開始日時に該当するカラムのカラム名を取得します。
Table | getTable() 期間化テーブルが定義されているテーブル定義を取得します。
String | getTermColumnName() 期間CDに該当するカラムのカラム名を取得します。

メソッドの詳細

getTable

public Table getTable()
期間化テーブルが定義されているテーブル定義を取得します。

戻り値:
期間化テーブルが定義されているテーブル定義

getName

public String getName()
期間化テーブルのテーブル名を取得します。

戻り値:
期間化テーブルのテーブル名

getColumnMappings

public Map getColumnMappings()
期間化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。 属性名をキー、 ColumnMappingを値としたマップを返します。

戻り値:
期間化テーブルに含まれるカラムマッピング

getTermColumnName

public String getTermColumnName()
期間CDに該当するカラムのカラム名を取得します。

戻り値:
カラム名

getStartDateColumnName

public String getStartDateColumnName()
期間の開始日時に該当するカラムのカラム名を取得します。

戻り値:
カラム名

getEndDateColumnName

public String getEndDateColumnName()
期間の日時に該当するカラムのカラム名を取得します。

戻り値:
カラム名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UpdateInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース UpdateInfo

public interface UpdateInfo

エンティティの更新情報です。 エンティティの更新ユーザ、更新日時となる属性を持ちます。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getUpdateTimestamp() エンティティの更新日付となる属性を取得します。
Attribute | getUpdateUser() エンティティの更新ユーザとなる属性を取得します。

メソッドの詳細

getUpdateUser

public Attribute getUpdateUser()
エンティティの更新ユーザとなる属性を取得します。

戻り値:
エンティティの更新ユーザとなる属性

getUpdateTimestamp

public Attribute getUpdateTimestamp()
エンティティの更新日付となる属性を取得します。

戻り値:
エンティティの更新ユーザとなる属性
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.BaseModel の使用

BaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category | 会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company | 会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion | 組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version | 会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.deal | 取扱情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.department | 取扱組織権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.detail | 取扱詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group | 取扱パブリックグループ権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.role | 取扱ロール権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach | 商品分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.category | 商品カテゴリ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.type | 商品カテゴリ種別情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail | 商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.template | 商品テンプレート情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.attribute | 商品属性情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue | 商品カタログ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.item | 商品情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach | プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group | プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach | パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category | パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion | パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set | パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version | パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.unit | 単位情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.system.security.datastore.inf |

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での BaseModel のサブインタフェース
 interface CateogryClassBaseModel
分類区分の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.category.detail での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.category.detail での BaseModel のサブインタフェース
 interface CategoryDetailBaseModel
分類区分詳細の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.attach での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.attach での BaseModel のサブインタフェース
 interface DepartmentAttachBaseModel
組織所属の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.category での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.category での BaseModel のサブインタフェース
 interface CompanyCategoryBaseModel
会社組織分類の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.company での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.company での BaseModel のサブインタフェース
 interface CompanyBaseModel
会社の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.department での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.department での BaseModel のサブインタフェース
 interface DepartmentBaseModel
組織の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion での BaseModel のサブインタフェース
 interface DepartmentInclusionBaseModel
組織内包の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.main での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.main での BaseModel のサブインタフェース
 interface DepartmentMainBaseModel
主所属の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.post での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.post での BaseModel のサブインタフェース
 interface CompanyPostBaseModel
役職の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.version での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.version での BaseModel のサブインタフェース
 interface CompanyVersionBaseModel
会社構成バージョンの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.deal.deal での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.deal での BaseModel のサブインタフェース
 interface DealBaseModel
取扱の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.deal.department での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.department での BaseModel のサブインタフェース
 interface DealerDepartmentBaseModel
組織毎取扱パーミッションの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.deal.detail での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.detail での BaseModel のサブインタフェース
 interface DealDetailBaseModel
取扱詳細の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group での BaseModel のサブインタフェース
 interface DealerPublicGroupBaseModel
パブリックグループ毎取扱パーミッションの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.deal.role での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.role での BaseModel のサブインタフェース
 interface DealerRoleBaseModel
ロール毎取扱パーミッションの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach での BaseModel のサブインタフェース
 interface ItemAttachBaseModel
商品分類の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item_category.category での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.category での BaseModel のサブインタフェース
 interface ItemCategoryBaseModel
商品カテゴリの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item_category.type での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.type での BaseModel のサブインタフェース
 interface ItemCategoryTypeBaseModel
商品カテゴリ種別の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail での BaseModel のサブインタフェース
 interface ItemTemplateDetailBaseModel
商品属性テンプレート明細の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item_template.template での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item_template.template での BaseModel のサブインタフェース
 interface ItemTemplateBaseModel
商品属性テンプレートの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item.attribute での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item.attribute での BaseModel のサブインタフェース
 interface ItemAttributeBaseModel
商品属性の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue での BaseModel のサブインタフェース
 interface ItemCatalogueBaseModel
商品カタログの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item.item での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item.item での BaseModel のサブインタフェース
 interface ItemBaseModel
商品の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach での BaseModel のサブインタフェース
 interface PrivateGroupAttachBaseModel
プライベートグループ所属の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.private_group.group での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.private_group.group での BaseModel のサブインタフェース
 interface PrivateGroupBaseModel
プライベートグループの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での BaseModel のサブインタフェース
 interface PublicGroupAttachBaseModel
パブリックグループ所属の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での BaseModel のサブインタフェース
 interface PublicGroupCategoryBaseModel
パブリックグループ分類の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での BaseModel のサブインタフェース
 interface PublicGroupBaseModel
パブリックグループの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion での BaseModel のサブインタフェース
 interface PublicGroupInclusionBaseModel
パブリックグループ内包の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.set での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.set での BaseModel のサブインタフェース
 interface PublicGroupSetBaseModel
パブリックグループセットの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.version での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.version での BaseModel のサブインタフェース
 interface PublicGroupVersionBaseModel
パブリックグループ構成バージョンの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.unit での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.unit での BaseModel のサブインタフェース
 interface UnitBaseModel
単位の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.user での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.user での BaseModel のサブインタフェース
 interface UserBaseModel
ユーザの基本モデルです。

jp.co.intra_mart.foundation.datastore.common.model での BaseModel の使用

BaseModel を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class GenericBaseModel
基本モデルの汎用的な抽象クラスです。

BaseModel を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
BaseModel | Mapper.createBaseModel(Map keys) このマッパーに該当する基本モデルを新規に生成します。
BaseModel | Mapper.select(Map keys) プライマリーキーで特定される基本モデルを取得します。
BaseModel | IntramartDBMapper.createBaseModel(Map keys) このマッパーに該当する基本モデルを新規に生成します。
BaseModel | IntramartDBMapper.select(Map keys) プライマリーキーで特定される基本モデルを取得します。

BaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | Mapper.notifyUpdate(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
void | Mapper.notifyDelete(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
void | Mapper.checkByBaseProperty(Relationship[] relationships, BaseModel target, BaseModel base) 基準項目によるリレーションシップの整合性制約をチェックします。
protected void | IntramartDBMapper.insert(BaseModel model) 基本モデルを1つだけ挿入します。
protected void | IntramartDBMapper.update(BaseModel model) 基本モデルを1つだけ更新します。
protected void | IntramartDBMapper.delete(BaseModel model) 基本モデルを1つだけ削除します。
void | IntramartDBMapper.notifyUpdate(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
void | IntramartDBMapper.notifyDelete(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
void | IntramartDBMapper.checkByBaseProperty(Relationship[] relationships, BaseModel target, BaseModel base) 基準項目によるリレーションシップの整合性制約をチェックします。

jp.co.intra_mart.system.security.datastore.inf での BaseModel の使用

jp.co.intra_mart.system.security.datastore.inf での BaseModel のサブインタフェース
interface | AccessControllerBaseModel アクセスコントローラ情報の基本モデルです。
interface | AccessControllerDepartmentBaseModel アクセスコントローラの利用権限を保有する組織の基本モデルです。
interface | AccessControllerPostBaseModel アクセスコントローラの利用権限を保有する役職の基本モデルです。
interface | AccessControllerPublicGroupBaseModel アクセスコントローラの利用権限を保有するパブリックグループの基本モデルです。
interface | AccessControllerRoleBaseModel アクセスコントローラの利用権限を保有するロールの基本モデルです。
interface | AccountAttributeBaseModel アカウントが保有する属性の基本モデルです。
interface | AccountBaseModel アカウントの基本モデルです。
interface | AccountRoleBaseModel アカウントが保有するロールの基本モデルです。
interface | BatchBaseModel バッチ情報の基本モデルです。
interface | CalendarInfoBaseModel カレンダーが保有するデータの基本モデルです。
interface | FavoriteMenuBaseModel アカウントが保有するメニューの基本モデルです。
interface | MenuArgumentBaseModel メニューの保有する引数の基本モデルです。
interface | MenuBaseModel メニュー情報の基本モデルです。
interface | MenuDepartmentBaseModel メニューの利用権限を保有する組織の基本モデルです。
interface | MenuPostBaseModel メニューの利用権限を保有する役職の基本モデルです。
interface | MenuPublicGroupBaseModel メニューの利用権限を保有するパブリックグループの基本モデルです。
interface | MenuRoleBaseModel メニューの利用権限を保有するロールの基本モデルです。
interface | RoleBaseModel ロールの基本モデルです。
interface | RoleInclusionBaseModel ロール内包の基本モデルです。
interface | RoleSummaryBaseModel ロールサマリの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext の使用

BaseModelContext を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での BaseModelContext の使用

BaseModelContext 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | GenericBaseModel.init(BaseModelContext context) 基本モデルを初期化します。
void | BaseModel.init(BaseModelContext context) 基本モデルを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel の使用

ExtendedBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedBaseModel の使用

ExtendedBaseModel を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class ExtendedGenericBaseModel
拡張基本モデルの汎用的な抽象クラスです。

ExtendedBaseModel を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedBaseModel | ExtendedGenericBaseModelMap.createExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
ExtendedBaseModel | ExtendedGenericBaseModelMap.findExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。
ExtendedBaseModel | ExtendedGenericBaseModelMap.newExtendedBaseModel(String name) 初期化されていない拡張基本モデルのインスタンスを取得します。
ExtendedBaseModel | ExtendedBaseModelMap.createExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
ExtendedBaseModel | ExtendedBaseModelMap.findExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap の使用

ExtendedBaseModelMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedBaseModelMap の使用

ExtendedBaseModelMap を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class ExtendedGenericBaseModelMap
拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。

ExtendedBaseModelMap を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedBaseModelMap | GenericBaseModel.getExtendedBaseModelMap() 拡張基本モデルのマップを取得します。
ExtendedBaseModelMap | BaseModelContext.getExtendedBaseModelMap() 拡張基本モデルマップを取得します。
ExtendedBaseModelMap | BaseModel.getExtendedBaseModelMap() 拡張基本エンティティに対応する拡張基本モデルのマップを取得します。

ExtendedBaseModelMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void BaseModelContext.setExtendedBaseModelMap(ExtendedBaseModelMap extendedMap)
拡張基本モデルマップを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel の使用

jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap の使用

jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel の使用

jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap の使用

jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel の使用

jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap の使用

jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel の使用

jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap の使用

jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel の使用

ExtendedInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedInternationalModel の使用

ExtendedInternationalModel を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class ExtendedGenericInternationalModel
拡張国際化モデルの汎用的な抽象クラスです。

ExtendedInternationalModel を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedInternationalModel | ExtendedInternationalModelMap.createExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
ExtendedInternationalModel | ExtendedInternationalModelMap.findExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
ExtendedInternationalModel | ExtendedGenericInternationalModelMap.createExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
ExtendedInternationalModel | ExtendedGenericInternationalModelMap.findExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
ExtendedInternationalModel | ExtendedGenericInternationalModelMap.newExtendedInternationalModel(String name) 初期化されていない拡張国際化モデルのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap の使用

ExtendedInternationalModelMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedInternationalModelMap の使用

ExtendedInternationalModelMap を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class ExtendedGenericInternationalModelMap
拡張国際化モデルのマッピング情報を持つ汎用的な抽象クラスです。

ExtendedInternationalModelMap を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedInternationalModelMap | InternationalModelContext.getExtendedInternationalModelMap() 拡張国際化モデルマップを取得します。
ExtendedInternationalModelMap | InternationalModel.getExtendedInternationalModelMap() 拡張国際化エンティティに対応する拡張国際化モデルのマップを取得します。
ExtendedInternationalModelMap | GenericInternationalModel.getExtendedInternationalModelMap() 拡張国際化モデルのマップを取得します。

ExtendedInternationalModelMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void InternationalModelContext.setExtendedInternationalModelMap(ExtendedInternationalModelMap extendedMap)
拡張国際化モデルマップを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel の使用

ExtendedTerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedTerminableInternationalModel の使用

ExtendedTerminableInternationalModel を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class ExtendedGenericTerminableInternationalModel
拡張期間国際化モデルの汎用的な抽象クラスです。

ExtendedTerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedTerminableInternationalModel | ExtendedTerminableInternationalModelMap.createExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
ExtendedTerminableInternationalModel | ExtendedTerminableInternationalModelMap.findExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
ExtendedTerminableInternationalModel | ExtendedGenericTerminableInternationalModelMap.createExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
ExtendedTerminableInternationalModel | ExtendedGenericTerminableInternationalModelMap.findExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
ExtendedTerminableInternationalModel | ExtendedGenericTerminableInternationalModelMap.newExtendedTerminableInternationalModel(String name) 初期化されていない拡張期間国際化モデルのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap の使用

ExtendedTerminableInternationalModelMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedTerminableInternationalModelMap の使用

ExtendedTerminableInternationalModelMap を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class ExtendedGenericTerminableInternationalModelMap
拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。

ExtendedTerminableInternationalModelMap を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedTerminableInternationalModelMap | TerminableInternationalModelContext.getExtendedTerminableInternationalModelMap() 拡張期間国際化モデルマップを取得します。
ExtendedTerminableInternationalModelMap | TerminableInternationalModel.getExtendedTerminableInternationalModelMap() 拡張期間国際化エンティティに対応する拡張期間国際化モデルのマップを取得します。
ExtendedTerminableInternationalModelMap | GenericTerminableInternationalModel.getExtendedTerminableInternationalModelMap() 拡張期間国際化モデルのマップを取得します。

ExtendedTerminableInternationalModelMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void TerminableInternationalModelContext.setExtendedTerminableInternationalModelMap(ExtendedTerminableInternationalModelMap extendedMap)
拡張期間国際化モデルマップを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel の使用

ExtendedTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedTerminableModel の使用

ExtendedTerminableModel を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class ExtendedGenericTerminableModel
拡張期間化モデルの汎用的な抽象クラスです。

ExtendedTerminableModel を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedTerminableModel | ExtendedTerminableModelMap.createExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
ExtendedTerminableModel | ExtendedTerminableModelMap.findExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
ExtendedTerminableModel | ExtendedGenericTerminableModelMap.createExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
ExtendedTerminableModel | ExtendedGenericTerminableModelMap.findExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
ExtendedTerminableModel | ExtendedGenericTerminableModelMap.newExtendedTerminableModel(String name) 初期化されてていない拡張期間化モデルのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap の使用

ExtendedTerminableModelMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedTerminableModelMap の使用

ExtendedTerminableModelMap を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class ExtendedGenericTerminableModelMap
拡張期間化モデルのマッピング情報を持つ汎用的な抽象クラスです。

ExtendedTerminableModelMap を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedTerminableModelMap | TerminableModelContext.getExtendedTerminableModelMap() 拡張期間化モデルマップを取得します。
ExtendedTerminableModelMap | TerminableModel.getExtendedTerminableModelMap() 拡張期間化エンティティに対応する拡張期間化モデルのマップを取得します。
ExtendedTerminableModelMap | GenericTerminableModel.getExtendedTerminableModelMap() 拡張期間化モデルのマップを取得します。

ExtendedTerminableModelMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void TerminableModelContext.setExtendedTerminableModelMap(ExtendedTerminableModelMap extendedMap)
拡張期間化モデルマップを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel の使用

jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel の使用

jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap の使用

jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel の使用

jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap の使用

jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel の使用

jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap の使用

jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.InternationalModel の使用

InternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.category | 商品カテゴリ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail | 商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.template | 商品テンプレート情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.attribute | 商品属性情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.system.security.datastore.inf |

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での InternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での InternationalModel のサブインタフェース
 interface CateogryClassInternationalModel
分類区分の国際化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.category.detail での InternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.category.detail での InternationalModel のサブインタフェース
 interface CategoryDetailInternationalModel
分類区分詳細の国際化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item_category.category での InternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.category での InternationalModel のサブインタフェース
 interface ItemCategoryInternationalModel
商品カテゴリの国際化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail での InternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail での InternationalModel のサブインタフェース
 interface ItemTemplateDetailInternationalModel
商品属性テンプレート明細の国際化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item_template.template での InternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item_template.template での InternationalModel のサブインタフェース
 interface ItemTemplateInternationalModel
商品属性テンプレートの国際化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item.attribute での InternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item.attribute での InternationalModel のサブインタフェース
 interface ItemAttributeInternationalModel
商品属性の国際化モデルです。

jp.co.intra_mart.foundation.datastore.common.model での InternationalModel の使用

InternationalModel を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class GenericInternationalModel
国際化モデルの汎用的な抽象クラスです。

InternationalModel を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
InternationalModel | InternationalModelMap.createInternationalModel(Locale locale) 国際化モデルを生成します。
InternationalModel | InternationalModelMap.findInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。
InternationalModel | GenericInternationalModelMap.createInternationalModel(Locale locale) 国際化モデルを生成します。
InternationalModel | GenericInternationalModelMap.findInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。
InternationalModel | GenericInternationalModelMap.newInternationalModel(Locale locale) 初期化されていない国際化モデルのインスタンスを取得します。
protected InternationalModel | GenericBaseModel.selectInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。

jp.co.intra_mart.system.security.datastore.inf での InternationalModel の使用

jp.co.intra_mart.system.security.datastore.inf での InternationalModel のサブインタフェース
interface | CalendarInfoInternationalModel カレンダーが保有するデータの国際化モデルです。
interface | MenuInternationalModel メニュー情報の国際化モデルです。
interface | RoleInternationalModel ロールの国際化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext の使用

InternationalModelContext を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での InternationalModelContext の使用

InternationalModelContext 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | InternationalModel.init(InternationalModelContext context) 国際化モデルを初期化します。
void | GenericInternationalModel.init(InternationalModelContext context) 国際化モデルを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap の使用

InternationalModelMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での InternationalModelMap の使用

InternationalModelMap を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class GenericInternationalModelMap
国際化モデルマッピングの汎用的な抽象クラスです。

InternationalModelMap を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
InternationalModelMap | GenericBaseModel.getInternationalModelMap() 国際化モデルのマップを取得します。
InternationalModelMap | BaseModelContext.getInternationalModelMap() 国際化モデルマップを取得します。
InternationalModelMap | BaseModel.getInternationalModelMap() 国際化モデルのマップを取得します。

InternationalModelMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void BaseModelContext.setInternationalModelMap(InternationalModelMap internationalMap)
国際化モデルマップを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper の使用

jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.Mapper の使用

Mapper を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category | 会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company | 会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion | 組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version | 会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.deal | 取扱情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.department | 取扱組織権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.detail | 取扱詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group | 取扱パブリックグループ権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.role | 取扱ロール権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach | 商品分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.category | 商品カテゴリ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.type | 商品カテゴリ種別情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail | 商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.template | 商品テンプレート情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.attribute | 商品属性情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue | 商品カタログ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.item | 商品情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach | プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group | プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach | パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category | パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion | パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set | パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version | パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.unit | 単位情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.system.security.datastore.inf |

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での Mapper のサブインタフェース
 interface CateogryClassMapper
分類区分に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.category.detail での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.category.detail での Mapper のサブインタフェース
 interface CategoryDetailMapper
分類区分詳細に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.company.attach での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.attach での Mapper のサブインタフェース
 interface DepartmentAttachMapper
組織所属に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.company.category での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.category での Mapper のサブインタフェース
 interface CompanyCategoryMapper
会社組織分類に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.company.company での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.company での Mapper のサブインタフェース
 interface CompanyMapper
会社に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.company.department での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.department での Mapper のサブインタフェース
 interface DepartmentMapper
組織に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion での Mapper のサブインタフェース
 interface DepartmentInclusionMapper
組織内包に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.company.main での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.main での Mapper のサブインタフェース
 interface DepartmentMainMapper
主所属に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.company.post での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.post での Mapper のサブインタフェース
 interface CompanyPostMapper
役職に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.company.version での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.version での Mapper のサブインタフェース
 interface CompanyVersionMapper
会社構成バージョンに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.deal.deal での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.deal での Mapper のサブインタフェース
 interface DealMapper
取扱に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.deal.department での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.department での Mapper のサブインタフェース
 interface DealerDepartmentMapper
組織毎取扱パーミッションに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.deal.detail での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.detail での Mapper のサブインタフェース
 interface DealDetailMapper
取扱詳細に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group での Mapper のサブインタフェース
 interface DealerPublicGroupMapper
パブリックグループ毎取扱パーミッションに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.deal.role での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.role での Mapper のサブインタフェース
 interface DealerRoleMapper
ロール毎取扱パーミッションに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach での Mapper のサブインタフェース
 interface ItemAttachMapper
商品分類に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.item_category.category での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.category での Mapper のサブインタフェース
 interface ItemCategoryMapper
商品カテゴリに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.item_category.type での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item_category.type での Mapper のサブインタフェース
 interface ItemCategoryTypeMapper
商品カテゴリ種別に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail での Mapper のサブインタフェース
 interface ItemTemplateDetailMapper
商品属性テンプレート明細に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.item_template.template での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item_template.template での Mapper のサブインタフェース
 interface ItemTemplateMapper
商品属性テンプレートに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.item.attribute での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item.attribute での Mapper のサブインタフェース
 interface ItemAttributeMapper
商品属性に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue での Mapper のサブインタフェース
 interface ItemCatalogueMapper
商品カタログに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.item.item での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.item.item での Mapper のサブインタフェース
 interface ItemMapper
商品に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach での Mapper のサブインタフェース
 interface PrivateGroupAttachMapper
プライベートグループ所属に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.private_group.group での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.private_group.group での Mapper のサブインタフェース
 interface PrivateGroupMapper
プライベートグループに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での Mapper のサブインタフェース
 interface PublicGroupAttachMapper
パブリックグループ所属に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での Mapper のサブインタフェース
 interface PublicGroupCategoryMapper
パブリックグループ分類に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での Mapper のサブインタフェース
 interface PublicGroupMapper
パブリックグループに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion での Mapper のサブインタフェース
 interface PublicGroupInclusionMapper
パブリックグループ内包に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.set での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.set での Mapper のサブインタフェース
 interface PublicGroupSetMapper
パブリックグループセットに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.version での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.version での Mapper のサブインタフェース
 interface PublicGroupVersionMapper
パブリックグループ構成バージョンに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.unit での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.unit での Mapper のサブインタフェース
 interface UnitMapper
単位に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.user での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.user での Mapper のサブインタフェース
 interface UserMapper
ユーザに関連するマッパです。

jp.co.intra_mart.foundation.datastore.common.model での Mapper の使用

Mapper を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class IntramartDBMapper
intra-martで管理されるデータベースにアクセスするマッパーの汎用的な抽象クラスです。

Mapper を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
abstract  Mapper MapperFactory.createMapper(String application, String entity, String group, String user)
マッパーを生成します。

jp.co.intra_mart.system.security.datastore.inf での Mapper の使用

jp.co.intra_mart.system.security.datastore.inf での Mapper のサブインタフェース
interface | AccessControllerDepartmentMapper アクセスコントローラの利用権限を保有する組織に関連するマッパです。
interface | AccessControllerMapper アクセスコントローラ情報に関連するマッパです。
interface | AccessControllerPostMapper アクセスコントローラの利用権限を保有する役職に関連するマッパです。
interface | AccessControllerPublicGroupMapper アクセスコントローラの利用権限を保有するパブリックグループに関連するマッパです。
interface | AccessControllerRoleMapper アクセスコントローラの利用権限を保有するロールに関連するマッパです。
interface | AccountAttributeMapper アカウントが保有する属性に関連するマッパです。
interface | AccountMapper アカウントに関連するマッパです。
interface | AccountRoleMapper アカウントが保有するロールに関連するマッパです。
interface | BatchMapper バッチ情報に関連するマッパです。
interface | CalendarInfoMapper カレンダーが保有するデータに関連するマッパです。
interface | FavoriteMenuMapper アカウントが保有するメニューに関連するマッパです。
interface | MenuArgumentMapper メニューの保有する引数に関連するマッパです。
interface | MenuDepartmentMapper メニューの利用権限を保有する組織に関連するマッパです。
interface | MenuMapper メニュー情報に関連するマッパです。
interface | MenuPostMapper メニューの利用権限を保有する役職に関連するマッパです。
interface | MenuPublicGroupMapper メニューの利用権限を保有するパブリックグループに関連するマッパです。
interface | MenuRoleMapper メニューの利用権限を保有するロールに関連するマッパです。
interface | RoleInclusionMapper ロール内包に関連するマッパです。
interface | RoleMapper ロールに関連するマッパです。
interface | RoleSummaryMapper ロールサマリに関連するマッパです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.MapperFactory の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.MapperFactory の使用

MapperFactory を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での MapperFactory の使用

MapperFactory を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
static MapperFactory MapperFactory.newInstance()
マッパーファクトリを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel の使用

TerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.item | 商品情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.department での TerminableInternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.department での TerminableInternationalModel のサブインタフェース
 interface DepartmentTerminableInternationalModel
組織の期間国際化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.post での TerminableInternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.post での TerminableInternationalModel のサブインタフェース
 interface CompanyPostTerminableInternationalModel
役職の期間国際化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item.item での TerminableInternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item.item での TerminableInternationalModel のサブインタフェース
 interface ItemTerminableInternationalModel
商品の期間国際化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での TerminableInternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での TerminableInternationalModel のサブインタフェース
 interface PublicGroupTerminableInternationalModel
パブリックグループの期間国際化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.user での TerminableInternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.user での TerminableInternationalModel のサブインタフェース
 interface UserTerminableInternationalModel
ユーザの期間国際化モデルです。

jp.co.intra_mart.foundation.datastore.common.model での TerminableInternationalModel の使用

TerminableInternationalModel を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class GenericTerminableInternationalModel
期間国際化モデルの汎用的な抽象クラスです。

TerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableInternationalModel | TerminableInternationalModelMap.createTerminableInternationalModel(Locale locale) 期間国際化モデルを生成します。
TerminableInternationalModel | TerminableInternationalModelMap.findTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
protected TerminableInternationalModel | GenericTerminableModel.selectTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
TerminableInternationalModel | GenericTerminableInternationalModelMap.createTerminableInternationalModel(Locale locale) 期間国際化モデルを生成します。
TerminableInternationalModel | GenericTerminableInternationalModelMap.findTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
TerminableInternationalModel | GenericTerminableInternationalModelMap.newTerminableInternationalModel(Locale locale) 初期化されていない期間国際化モデルのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext の使用

TerminableInternationalModelContext を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での TerminableInternationalModelContext の使用

TerminableInternationalModelContext 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | TerminableInternationalModel.init(TerminableInternationalModelContext context) 期間国際化モデルを初期化します。
void | GenericTerminableInternationalModel.init(TerminableInternationalModelContext context) 期間国際化モデルを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap の使用

TerminableInternationalModelMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での TerminableInternationalModelMap の使用

TerminableInternationalModelMap を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class GenericTerminableInternationalModelMap
期間国際化モデルマッピングの汎用的な抽象クラスです。

TerminableInternationalModelMap を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableInternationalModelMap | TerminableModelContext.getTerminableInternationalModelMap() 期間国際化モデルマップを取得します。
TerminableInternationalModelMap | TerminableModel.getTerminableInternationalModelMap() 期間国際化モデルを取得します。
TerminableInternationalModelMap | GenericTerminableModel.getTerminableInternationalModelMap() 期間国際化モデルのマップを取得します。

TerminableInternationalModelMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void TerminableModelContext.setTerminableInternationalModelMap(TerminableInternationalModelMap terminableInternationalMap)
期間国際化モデルマップを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.TerminableModel の使用

TerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category | 会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.deal | 取扱情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.detail | 取扱詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.item | 商品情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach | パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category | パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.attach での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.attach での TerminableModel のサブインタフェース
 interface DepartmentAttachTerminableModel
組織所属の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.category での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.category での TerminableModel のサブインタフェース
 interface CompanyCategoryTerminableModel
会社組織分類の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.department での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.department での TerminableModel のサブインタフェース
 interface DepartmentTerminableModel
組織の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.main での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.main での TerminableModel のサブインタフェース
 interface DepartmentMainTerminableModel
主所属の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.post での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.post での TerminableModel のサブインタフェース
 interface CompanyPostTerminableModel
役職の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.deal.deal での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.deal での TerminableModel のサブインタフェース
 interface DealTerminableModel
取扱の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.deal.detail での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.deal.detail での TerminableModel のサブインタフェース
 interface DealDetailTerminableModel
取扱詳細の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.item.item での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.item.item での TerminableModel のサブインタフェース
 interface ItemTerminableModel
商品の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での TerminableModel のサブインタフェース
 interface PublicGroupAttachTerminableModel
パブリックグループ所属の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での TerminableModel のサブインタフェース
 interface PublicGroupCategoryTerminableModel
パブリックグループ分類の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での TerminableModel のサブインタフェース
 interface PublicGroupTerminableModel
パブリックグループの期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.user での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.user での TerminableModel のサブインタフェース
 interface UserTerminableModel
ユーザの期間化モデルです。

jp.co.intra_mart.foundation.datastore.common.model での TerminableModel の使用

TerminableModel を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class GenericTerminableModel
期間化モデルの汎用的な抽象クラスです。

TerminableModel を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableModel | TerminableModelMap.createTerminableModel(Term term) 指定した期間を満たす期間化モデルを生成します。
TerminableModel | TerminableModelMap.findTerminableModel(Date date) 指定された日付に該当する期間化モデルを取得します。
TerminableModel | GenericTerminableModelMap.createTerminableModel(Term term) 指定した期間を満たす期間化モデルを生成します。
TerminableModel | GenericTerminableModelMap.findTerminableModel(Date date) 指定された日時に該当する期間化モデルを取得します。
TerminableModel | GenericTerminableModelMap.newTerminableModel(Term term) 初期化されていない期間化モデルのインスタンスを取得します。
protected TerminableModel | GenericBaseModel.selectTerminableModel(Date date) 指定された日時に該当する期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext の使用

TerminableModelContext を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での TerminableModelContext の使用

TerminableModelContext 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | TerminableModel.init(TerminableModelContext context) 期間化モデルを初期化します。
void | GenericTerminableModel.init(TerminableModelContext context) 期間化モデルを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap の使用

TerminableModelMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での TerminableModelMap の使用

TerminableModelMap を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class GenericTerminableModelMap
期間化モデルマッピングの汎用的な抽象クラスです。

TerminableModelMap を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableModelMap | GenericBaseModel.getTerminableModelMap() 期間化モデルのマップを取得します。
TerminableModelMap | BaseModelContext.getTerminableModelMap() 期間化モデルマップを取得します。
TerminableModelMap | BaseModel.getTerminableModelMap() 期間化モデルのマップを取得します。

TerminableModelMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void BaseModelContext.setTerminableModelMap(TerminableModelMap terminableMap)
期間化モデルマップを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース BaseModel

すべてのスーパーインタフェース:
Serializable
既知のサブインタフェースの一覧:
AccessControllerBaseModel, AccessControllerDepartmentBaseModel, AccessControllerPostBaseModel, AccessControllerPublicGroupBaseModel, AccessControllerRoleBaseModel, AccountAttributeBaseModel, AccountBaseModel, AccountRoleBaseModel, BatchBaseModel, CalendarInfoBaseModel, CategoryDetailBaseModel, CateogryClassBaseModel, CompanyBaseModel, CompanyCategoryBaseModel, CompanyPostBaseModel, CompanyVersionBaseModel, DealBaseModel, DealDetailBaseModel, DealerDepartmentBaseModel, DealerPublicGroupBaseModel, DealerRoleBaseModel, DepartmentAttachBaseModel, DepartmentBaseModel, DepartmentInclusionBaseModel, DepartmentMainBaseModel, FavoriteMenuBaseModel, ItemAttachBaseModel, ItemAttributeBaseModel, ItemBaseModel, ItemCatalogueBaseModel, ItemCategoryBaseModel, ItemCategoryTypeBaseModel, ItemTemplateBaseModel, ItemTemplateDetailBaseModel, MenuArgumentBaseModel, MenuBaseModel, MenuDepartmentBaseModel, MenuPostBaseModel, MenuPublicGroupBaseModel, MenuRoleBaseModel, PrivateGroupAttachBaseModel, PrivateGroupBaseModel, PublicGroupAttachBaseModel, PublicGroupBaseModel, PublicGroupCategoryBaseModel, PublicGroupInclusionBaseModel, PublicGroupSetBaseModel, PublicGroupVersionBaseModel, RoleBaseModel, RoleInclusionBaseModel, RoleSummaryBaseModel, UnitBaseModel, UserBaseModel
既知の実装クラスの一覧:
GenericBaseModel
public interface BaseModel
extends Serializable

基本モデルの情報です。 基本エンティティの1データが基本モデルの1インスタンスに対応します。

導入されたバージョン:
5.0

メソッドの概要
BaseAccessor | getBaseAccessor() 基本アクセサ BaseAccessor を取得します。
ExtendedBaseModelMap | getExtendedBaseModelMap() 拡張基本エンティティに対応する拡張基本モデルのマップを取得します。
InternationalModelMap | getInternationalModelMap() 国際化モデルのマップを取得します。
TerminableModelMap | getTerminableModelMap() 期間化モデルのマップを取得します。
void | init(BaseModelContext context) 基本モデルを初期化します。

メソッドの詳細

init

public void init(BaseModelContext context)
基本モデルを初期化します。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

パラメータ:
context - 基本モデルコンテキスト

getInternationalModelMap

public InternationalModelMap getInternationalModelMap()
国際化モデルのマップを取得します。 この基本モデルに関連する国際化モデルのマップを取得します。

戻り値:
国際化モデルのマップ

getTerminableModelMap

public TerminableModelMap getTerminableModelMap()
期間化モデルのマップを取得します。 この基本モデルに関連する期間化モデルのマップを取得します。

戻り値:
期間化モデルのマップ

getExtendedBaseModelMap

public ExtendedBaseModelMap getExtendedBaseModelMap()
拡張基本エンティティに対応する拡張基本モデルのマップを取得します。

戻り値:
拡張基本モデルマップ

getBaseAccessor

public BaseAccessor getBaseAccessor()
基本アクセサ BaseAccessor を取得します。 このメソッドはシステム内で使用されます。明示的に使用しないでください。

戻り値:
基本アクセサ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BaseModelContext (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース BaseModelContext

public interface BaseModelContext

基本モデルの初期化に必要な設定を持ちます。

導入されたバージョン:
5.0

メソッドの概要
BaseAccessor | getBaseAccessor() 基本アクセサを取得します。
Date | getDefaultDate() デフォルト日時を取得します。
Locale | getDefaultLocale() デフォルト言語を取得します。
ExtendedBaseModelMap | getExtendedBaseModelMap() 拡張基本モデルマップを取得します。
InternationalModelMap | getInternationalModelMap() 国際化モデルマップを取得します。
TerminableModelMap | getTerminableModelMap() 期間化モデルマップを取得します。
void | setBaseAccessor(BaseAccessor accessor) 基本アクセサを設定します。
void | setDefaultDate(Date date) デフォルト日時を設定します。
void | setDefaultLocale(Locale locale) デフォルト言語を設定します。
void | setExtendedBaseModelMap(ExtendedBaseModelMap extendedMap) 拡張基本モデルマップを設定します。
void | setInternationalModelMap(InternationalModelMap internationalMap) 国際化モデルマップを設定します。
void | setTerminableModelMap(TerminableModelMap terminableMap) 期間化モデルマップを設定します。

メソッドの詳細

setBaseAccessor

public void setBaseAccessor(BaseAccessor accessor)
基本アクセサを設定します。

パラメータ:
accessor - 基本アクセサ

getBaseAccessor

public BaseAccessor getBaseAccessor()
基本アクセサを取得します。

戻り値:
基本アクセサ

setDefaultDate

public void setDefaultDate(Date date)
デフォルト日時を設定します。

パラメータ:
date - 日時

getDefaultDate

public Date getDefaultDate()
デフォルト日時を取得します。

戻り値:
日時

setDefaultLocale

public void setDefaultLocale(Locale locale)
デフォルト言語を設定します。

パラメータ:
locale - 言語

getDefaultLocale

public Locale getDefaultLocale()
デフォルト言語を取得します。

戻り値:
言語

setInternationalModelMap

public void setInternationalModelMap(InternationalModelMap internationalMap)
国際化モデルマップを設定します。

パラメータ:
internationalMap - 国際化モデルマップ

getInternationalModelMap

public InternationalModelMap getInternationalModelMap()
国際化モデルマップを取得します。

戻り値:
国際化モデルマップ

setTerminableModelMap

public void setTerminableModelMap(TerminableModelMap terminableMap)
期間化モデルマップを設定します。

パラメータ:
terminableMap - 期間化モデルマップ

getTerminableModelMap

public TerminableModelMap getTerminableModelMap()
期間化モデルマップを取得します。

戻り値:
期間化モデルマップ

setExtendedBaseModelMap

public void setExtendedBaseModelMap(ExtendedBaseModelMap extendedMap)
拡張基本モデルマップを設定します。

パラメータ:
extendedMap - 拡張基本モデルマップ

getExtendedBaseModelMap

public ExtendedBaseModelMap getExtendedBaseModelMap()
拡張基本モデルマップを取得します。

戻り値:
拡張基本モデルマップ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース ExtendedBaseModel

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
ExtendedGenericBaseModel
public interface ExtendedBaseModel
extends Serializable

拡張基本モデルの情報です。 基本エンティティの拡張部分に対応するモデル情報です。拡張基本エンティティの1データが拡張基本モデルの1インスタンスに対応します。

導入されたバージョン:
5.0

メソッドの概要
 void init(ExtendedBaseAccessor accessor)
拡張基本モデルを初期化します。

メソッドの詳細

init

public void init(ExtendedBaseAccessor accessor)
拡張基本モデルを初期化します。

パラメータ:
accessor - 拡張基本アクセサ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedBaseModelMap (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース ExtendedBaseModelMap

既知の実装クラスの一覧:
ExtendedGenericBaseModelMap
public interface ExtendedBaseModelMap

拡張基本モデルのマッピング情報を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedBaseModel | createExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
ExtendedBaseModel | findExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。
void | remove(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。

メソッドの詳細

createExtendedBaseModel

public ExtendedBaseModel createExtendedBaseModel(String name)
                                          throws AccessorException
拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

パラメータ:
name - 拡張名
戻り値:
拡張基本モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

findExtendedBaseModel

public ExtendedBaseModel findExtendedBaseModel(String name)
                                        throws AccessorException
拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は null を返します。

パラメータ:
name - 拡張名
戻り値:
拡張基本モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

remove

public void remove(String name)
            throws AccessorException
拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は何もしません。

パラメータ:
name - 拡張名
例外:
AccessorException - アクセサで例外が何らかの発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedGenericBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス ExtendedGenericBaseModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel
すべての実装インタフェース:
ExtendedBaseModel, Serializable
public abstract class ExtendedGenericBaseModel
extends Object
implements ExtendedBaseModel

拡張基本モデルの汎用的な抽象クラスです。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
ExtendedGenericBaseModel()
メソッドの概要
protected Object | get(String name) 指定の属性が保持する値を取得します。
void | init(ExtendedBaseAccessor accessor) 拡張基本モデルを初期化します。
protected void | set(String name, Object value) 指定の属性に値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedGenericBaseModel

public ExtendedGenericBaseModel()
メソッドの詳細

init

public void init(ExtendedBaseAccessor accessor)
拡張基本モデルを初期化します。

定義:
インタフェース ExtendedBaseModel 内の init
パラメータ:
accessor - 拡張基本アクセサ

get

protected Object get(String name)
              throws AccessorException
指定の属性が保持する値を取得します。

パラメータ:
name - 属性名
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
AccessorException - アクセサで例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedGenericBaseModelMap (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス ExtendedGenericBaseModelMap

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap
すべての実装インタフェース:
ExtendedBaseModelMap
public abstract class ExtendedGenericBaseModelMap
extends Object
implements ExtendedBaseModelMap

拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。

導入されたバージョン:
5.0

コンストラクタの概要
ExtendedGenericBaseModelMap()
メソッドの概要
ExtendedBaseModel | createExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
ExtendedBaseModel | findExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。
void | init(ExtendedBaseAccessorMap accessorMap) 初期化を行います。
ExtendedBaseModel | newExtendedBaseModel(String name) 初期化されていない拡張基本モデルのインスタンスを取得します。
void | remove(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedGenericBaseModelMap

public ExtendedGenericBaseModelMap()
メソッドの詳細

init

public void init(ExtendedBaseAccessorMap accessorMap)
初期化を行います。

パラメータ:
accessorMap - 拡張基本アクセサマップ

createExtendedBaseModel

public ExtendedBaseModel createExtendedBaseModel(String name)
                                          throws AccessorException
拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

定義:
インタフェース ExtendedBaseModelMap 内の createExtendedBaseModel
パラメータ:
name - 拡張名
戻り値:
拡張基本モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

findExtendedBaseModel

public ExtendedBaseModel findExtendedBaseModel(String name)
                                        throws AccessorException
拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は null を返します。

定義:
インタフェース ExtendedBaseModelMap 内の findExtendedBaseModel
パラメータ:
name - 拡張名
戻り値:
拡張基本モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

remove

public void remove(String name)
            throws AccessorException
拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は何もしません。

定義:
インタフェース ExtendedBaseModelMap 内の remove
パラメータ:
name - 拡張名
例外:
AccessorException - アクセサで例外が何らかの発生した場合

newExtendedBaseModel

public ExtendedBaseModel newExtendedBaseModel(String name)
                                       throws IllegalExtensionException
初期化されていない拡張基本モデルのインスタンスを取得します。 このメソッドはシステム内で使用されます。明示的に使用しないでください。

パラメータ:
name - 拡張名
戻り値:
拡張基本モデルのインスタンス
例外:
IllegalExtensionException - 存在しない拡張名、または基本属性を持たない拡張名が指定された場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedGenericInternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス ExtendedGenericInternationalModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel
すべての実装インタフェース:
ExtendedInternationalModel, Serializable
public abstract class ExtendedGenericInternationalModel
extends Object
implements ExtendedInternationalModel

拡張国際化モデルの汎用的な抽象クラスです。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
ExtendedGenericInternationalModel()
メソッドの概要
protected Object | get(String name) 指定の属性が保持する値を取得します。
void | init(ExtendedInternationalAccessor accessor) 拡張国際化モデルを初期化します。
protected void | set(String name, Object value) 指定の属性に値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedGenericInternationalModel

public ExtendedGenericInternationalModel()
メソッドの詳細

init

public void init(ExtendedInternationalAccessor accessor)
拡張国際化モデルを初期化します。

定義:
インタフェース ExtendedInternationalModel 内の init
パラメータ:
accessor - 拡張国際化アクセサ

get

protected Object get(String name)
              throws AccessorException
指定の属性が保持する値を取得します。

パラメータ:
name - 属性名
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
AccessorException - アクセサで例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedGenericInternationalModelMap (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス ExtendedGenericInternationalModelMap

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap
すべての実装インタフェース:
ExtendedInternationalModelMap
public abstract class ExtendedGenericInternationalModelMap
extends Object
implements ExtendedInternationalModelMap

拡張国際化モデルのマッピング情報を持つ汎用的な抽象クラスです。

導入されたバージョン:
5.0

コンストラクタの概要
ExtendedGenericInternationalModelMap()
メソッドの概要
ExtendedInternationalModel | createExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
ExtendedInternationalModel | findExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
void | init(ExtendedInternationalAccessorMap accessorMap) 初期化を行います。
ExtendedInternationalModel | newExtendedInternationalModel(String name) 初期化されていない拡張国際化モデルのインスタンスを取得します。
void | remove(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedGenericInternationalModelMap

public ExtendedGenericInternationalModelMap()
メソッドの詳細

init

public void init(ExtendedInternationalAccessorMap accessorMap)
初期化を行います。

パラメータ:
accessorMap - 拡張国際化アクセサマップ

createExtendedInternationalModel

public ExtendedInternationalModel createExtendedInternationalModel(String name)
                                                            throws AccessorException
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

定義:
インタフェース ExtendedInternationalModelMap 内の createExtendedInternationalModel
パラメータ:
name - 拡張名
戻り値:
拡張基本モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

findExtendedInternationalModel

public ExtendedInternationalModel findExtendedInternationalModel(String name)
                                                          throws AccessorException
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は null を返します。

定義:
インタフェース ExtendedInternationalModelMap 内の findExtendedInternationalModel
パラメータ:
name - 拡張名
戻り値:
拡張基本モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

remove

public void remove(String name)
            throws AccessorException
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は何もしません。

定義:
インタフェース ExtendedInternationalModelMap 内の remove
パラメータ:
name - 拡張名
例外:
AccessorException - アクセサで例外が何らかの発生した場合

newExtendedInternationalModel

public ExtendedInternationalModel newExtendedInternationalModel(String name)
初期化されていない拡張国際化モデルのインスタンスを取得します。 このメソッドはシステム内で使用されます。明示的に使用しないでください。

パラメータ:
name - 拡張名
戻り値:
拡張国際化モデルのインスタンス
例外:
ModelCreateException - 拡張モデルのインスタンスの生成に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedGenericTerminableInternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス ExtendedGenericTerminableInternationalModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel
すべての実装インタフェース:
ExtendedTerminableInternationalModel, Serializable
public abstract class ExtendedGenericTerminableInternationalModel
extends Object
implements ExtendedTerminableInternationalModel

拡張期間国際化モデルの汎用的な抽象クラスです。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
ExtendedGenericTerminableInternationalModel()
メソッドの概要
protected Object | get(String name) 指定の属性が保持する値を取得します。
void | init(ExtendedTerminableInternationalAccessor accessor) 拡張期間国際化モデルを初期化します。
protected void | set(String name, Object value) 指定の属性に値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedGenericTerminableInternationalModel

public ExtendedGenericTerminableInternationalModel()
メソッドの詳細

init

public void init(ExtendedTerminableInternationalAccessor accessor)
拡張期間国際化モデルを初期化します。

定義:
インタフェース ExtendedTerminableInternationalModel 内の init
パラメータ:
accessor - 拡張期間国際化アクセサ

get

protected Object get(String name)
              throws AccessorException
指定の属性が保持する値を取得します。

パラメータ:
name - 属性名
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
AccessorException - アクセサで例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedGenericTerminableInternationalModelMap (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス ExtendedGenericTerminableInternationalModelMap

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap
すべての実装インタフェース:
ExtendedTerminableInternationalModelMap
public abstract class ExtendedGenericTerminableInternationalModelMap
extends Object
implements ExtendedTerminableInternationalModelMap

拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。

導入されたバージョン:
5.0

コンストラクタの概要
ExtendedGenericTerminableInternationalModelMap()
メソッドの概要
ExtendedTerminableInternationalModel | createExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
ExtendedTerminableInternationalModel | findExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
void | init(ExtendedTerminableInternationalAccessorMap accessorMap) 初期化を行います。
ExtendedTerminableInternationalModel | newExtendedTerminableInternationalModel(String name) 初期化されていない拡張期間国際化モデルのインスタンスを取得します。
void | remove(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedGenericTerminableInternationalModelMap

public ExtendedGenericTerminableInternationalModelMap()
メソッドの詳細

init

public void init(ExtendedTerminableInternationalAccessorMap accessorMap)
初期化を行います。

パラメータ:
accessorMap - 拡張期間国際化アクセサマップ

createExtendedTerminableInternationalModel

public ExtendedTerminableInternationalModel createExtendedTerminableInternationalModel(String name)
                                                                                throws AccessorException
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

定義:
インタフェース ExtendedTerminableInternationalModelMap 内の createExtendedTerminableInternationalModel
パラメータ:
name - 拡張名
戻り値:
拡張期間国際化モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

findExtendedTerminableInternationalModel

public ExtendedTerminableInternationalModel findExtendedTerminableInternationalModel(String name)
                                                                              throws AccessorException
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は null を返します。

定義:
インタフェース ExtendedTerminableInternationalModelMap 内の findExtendedTerminableInternationalModel
パラメータ:
name - 拡張名
戻り値:
拡張期間国際化モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

remove

public void remove(String name)
            throws AccessorException
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は何もしません。

定義:
インタフェース ExtendedTerminableInternationalModelMap 内の remove
パラメータ:
name - 拡張名
例外:
AccessorException - アクセサで例外が何らかの発生した場合

newExtendedTerminableInternationalModel

public ExtendedTerminableInternationalModel newExtendedTerminableInternationalModel(String name)
                                                                             throws IllegalExtensionException
初期化されていない拡張期間国際化モデルのインスタンスを取得します。 このメソッドはシステム内で使用されます。明示的に使用しないでください。

パラメータ:
name - 拡張名
戻り値:
拡張期間国際化モデルのインスタンス
例外:
IllegalExtensionException - 存在しない拡張名、または期間国際化属性を持たない拡張名が指定された場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedGenericTerminableModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス ExtendedGenericTerminableModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel
すべての実装インタフェース:
ExtendedTerminableModel, Serializable
public abstract class ExtendedGenericTerminableModel
extends Object
implements ExtendedTerminableModel

拡張期間化モデルの汎用的な抽象クラスです。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
ExtendedGenericTerminableModel()
メソッドの概要
protected Object | get(String name) 指定の属性が保持する値を取得します。
void | init(ExtendedTerminableAccessor accessor) 拡張期間化モデルを初期化します。
protected void | set(String name, Object value) 指定の属性に値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedGenericTerminableModel

public ExtendedGenericTerminableModel()
メソッドの詳細

init

public void init(ExtendedTerminableAccessor accessor)
拡張期間化モデルを初期化します。

定義:
インタフェース ExtendedTerminableModel 内の init
パラメータ:
accessor - 拡張期間化アクセサ

get

protected Object get(String name)
              throws AccessorException
指定の属性が保持する値を取得します。

パラメータ:
name - 属性名
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
AccessorException - アクセサで例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedGenericTerminableModelMap (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス ExtendedGenericTerminableModelMap

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap
すべての実装インタフェース:
ExtendedTerminableModelMap
public abstract class ExtendedGenericTerminableModelMap
extends Object
implements ExtendedTerminableModelMap

拡張期間化モデルのマッピング情報を持つ汎用的な抽象クラスです。

導入されたバージョン:
5.0

コンストラクタの概要
ExtendedGenericTerminableModelMap()
メソッドの概要
ExtendedTerminableModel | createExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
ExtendedTerminableModel | findExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
void | init(ExtendedTerminableAccessorMap accessorMap) 初期化を行います。
ExtendedTerminableModel | newExtendedTerminableModel(String name) 初期化されてていない拡張期間化モデルのインスタンスを取得します。
void | remove(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedGenericTerminableModelMap

public ExtendedGenericTerminableModelMap()
メソッドの詳細

init

public void init(ExtendedTerminableAccessorMap accessorMap)
初期化を行います。

パラメータ:
accessorMap - 拡張期間化アクセサマップ

createExtendedTerminableModel

public ExtendedTerminableModel createExtendedTerminableModel(String name)
                                                      throws AccessorException
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

定義:
インタフェース ExtendedTerminableModelMap 内の createExtendedTerminableModel
パラメータ:
name - 拡張名
戻り値:
拡張期間化モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

findExtendedTerminableModel

public ExtendedTerminableModel findExtendedTerminableModel(String name)
                                                    throws AccessorException
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は null を返します。

定義:
インタフェース ExtendedTerminableModelMap 内の findExtendedTerminableModel
パラメータ:
name - 拡張名
戻り値:
拡張期間化モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

remove

public void remove(String name)
            throws AccessorException
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は何もしません。

定義:
インタフェース ExtendedTerminableModelMap 内の remove
パラメータ:
name - 拡張名
例外:
AccessorException - アクセサで例外が何らかの発生した場合

newExtendedTerminableModel

public ExtendedTerminableModel newExtendedTerminableModel(String name)
                                                   throws IllegalExtensionException
初期化されてていない拡張期間化モデルのインスタンスを取得します。 このメソッドはシステム内で使用されます。明示的に使用しないでください。

パラメータ:
name - 拡張名
戻り値:
拡張期間化モデルのインスタンス
例外:
IllegalExtensionException - 存在しない拡張名、または期間化属性を持たない拡張名が指定された場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedInternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース ExtendedInternationalModel

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
ExtendedGenericInternationalModel
public interface ExtendedInternationalModel
extends Serializable

拡張国際化モデルの情報です。 国際化エンティティの拡張部分に対応するモデル情報です。拡張国際化エンティティの1データが拡張国際化モデルの1インスタンスに対応します。

導入されたバージョン:
5.0

メソッドの概要
 void init(ExtendedInternationalAccessor accessor)
拡張国際化モデルを初期化します。

メソッドの詳細

init

public void init(ExtendedInternationalAccessor accessor)
拡張国際化モデルを初期化します。

パラメータ:
accessor - 拡張国際化アクセサ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedInternationalModelMap (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース ExtendedInternationalModelMap

既知の実装クラスの一覧:
ExtendedGenericInternationalModelMap
public interface ExtendedInternationalModelMap

拡張国際化モデルのマッピング情報を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedInternationalModel | createExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
ExtendedInternationalModel | findExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
void | remove(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。

メソッドの詳細

createExtendedInternationalModel

public ExtendedInternationalModel createExtendedInternationalModel(String name)
                                                            throws AccessorException
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

パラメータ:
name - 拡張名
戻り値:
拡張基本モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

findExtendedInternationalModel

public ExtendedInternationalModel findExtendedInternationalModel(String name)
                                                          throws AccessorException
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は null を返します。

パラメータ:
name - 拡張名
戻り値:
拡張基本モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

remove

public void remove(String name)
            throws AccessorException
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は何もしません。

パラメータ:
name - 拡張名
例外:
AccessorException - アクセサで例外が何らかの発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableInternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース ExtendedTerminableInternationalModel

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
ExtendedGenericTerminableInternationalModel
public interface ExtendedTerminableInternationalModel
extends Serializable

拡張期間国際化モデルの情報です。 期間国際化エンティティの拡張部分に対応するモデル情報です。拡張期間国際化エンティティの1データが拡張期間国際化モデルの1インスタンスに対応します。

導入されたバージョン:
5.0

メソッドの概要
 void init(ExtendedTerminableInternationalAccessor accessor)
拡張期間国際化モデルを初期化します。

メソッドの詳細

init

public void init(ExtendedTerminableInternationalAccessor accessor)
拡張期間国際化モデルを初期化します。

パラメータ:
accessor - 拡張期間国際化アクセサ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableInternationalModelMap (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース ExtendedTerminableInternationalModelMap

既知の実装クラスの一覧:
ExtendedGenericTerminableInternationalModelMap
public interface ExtendedTerminableInternationalModelMap

拡張期間国際化モデルのマッピング情報を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedTerminableInternationalModel | createExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
ExtendedTerminableInternationalModel | findExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
void | remove(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。

メソッドの詳細

createExtendedTerminableInternationalModel

public ExtendedTerminableInternationalModel createExtendedTerminableInternationalModel(String name)
                                                                                throws AccessorException
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

パラメータ:
name - 拡張名
戻り値:
拡張期間国際化モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

findExtendedTerminableInternationalModel

public ExtendedTerminableInternationalModel findExtendedTerminableInternationalModel(String name)
                                                                              throws AccessorException
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は null を返します。

パラメータ:
name - 拡張名
戻り値:
拡張期間国際化モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

remove

public void remove(String name)
            throws AccessorException
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は何もしません。

パラメータ:
name - 拡張名
例外:
AccessorException - アクセサで例外が何らかの発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース ExtendedTerminableModel

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
ExtendedGenericTerminableModel
public interface ExtendedTerminableModel
extends Serializable

拡張期間化モデルの情報です。 期間化エンティティの拡張部分に対応するモデル情報です。拡張期間化エンティティの1データが拡張期間化モデルの1インスタンスに対応します。

導入されたバージョン:
5.0

メソッドの概要
 void init(ExtendedTerminableAccessor accessor)
拡張期間化モデルを初期化します。

メソッドの詳細

init

public void init(ExtendedTerminableAccessor accessor)
拡張期間化モデルを初期化します。

パラメータ:
accessor - 拡張期間化アクセサ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableModelMap (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース ExtendedTerminableModelMap

既知の実装クラスの一覧:
ExtendedGenericTerminableModelMap
public interface ExtendedTerminableModelMap

拡張期間化モデルのマッピング情報を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedTerminableModel | createExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
ExtendedTerminableModel | findExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
void | remove(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。

メソッドの詳細

createExtendedTerminableModel

public ExtendedTerminableModel createExtendedTerminableModel(String name)
                                                      throws AccessorException
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

パラメータ:
name - 拡張名
戻り値:
拡張期間化モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

findExtendedTerminableModel

public ExtendedTerminableModel findExtendedTerminableModel(String name)
                                                    throws AccessorException
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は null を返します。

パラメータ:
name - 拡張名
戻り値:
拡張期間化モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

remove

public void remove(String name)
            throws AccessorException
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は何もしません。

パラメータ:
name - 拡張名
例外:
AccessorException - アクセサで例外が何らかの発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス GenericBaseModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel
すべての実装インタフェース:
BaseModel, Serializable
public abstract class GenericBaseModel
extends Object
implements BaseModel

基本モデルの汎用的な抽象クラスです。 このクラスでは、 init(BaseModelContext)で設定された基本アクセサを getBaseAccessor() で取得することができます。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
GenericBaseModel()
メソッドの概要
protected Object | get(String name) 指定の属性が保持する値を取得します。
protected Object | get(String name, Date date) 指定の属性が、指定の日時に保持している値を取得します。
protected Object | get(String name, Date date, Locale locale) 指定の属性が、指定の日時、言語で保持している値を取得します。
protected Object | get(String name, Locale locale) 指定の属性が、指定の言語で保持している値を取得します。
BaseAccessor | getBaseAccessor() この基本モデルに割り当てられた基本アクセサを取得します。
protected Date | getDefaultDate() モデル生成時に設定されたデフォルト日時を取得します。
protected Locale | getDefaultLocale() モデル生成時に設定されたデフォルト言語を取得します。
ExtendedBaseModelMap | getExtendedBaseModelMap() 拡張基本モデルのマップを取得します。
InternationalModelMap | getInternationalModelMap() 国際化モデルのマップを取得します。
TerminableModelMap | getTerminableModelMap() 期間化モデルのマップを取得します。
void | init(BaseModelContext context) 基本モデルを初期化します。
protected InternationalModel | selectInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。
protected TerminableModel | selectTerminableModel(Date date) 指定された日時に該当する期間化モデルを取得します。
protected void | set(String name, Object value) 指定の属性に値を設定します。
protected void | set(String name, Object value, Date date) 指定の属性に、指定の日時で値を設定します。
protected void | set(String name, Object value, Date date, Locale locale) 指定の属性に、指定の日時、言語で値を設定します。
protected void | set(String name, Object value, Locale locale) 指定の属性に、指定の言語で値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericBaseModel

public GenericBaseModel()
メソッドの詳細

init

public void init(BaseModelContext context)
基本モデルを初期化します。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

定義:
インタフェース BaseModel 内の init
パラメータ:
context - 基本モデルコンテキスト

getBaseAccessor

public BaseAccessor getBaseAccessor()
この基本モデルに割り当てられた基本アクセサを取得します。

定義:
インタフェース BaseModel 内の getBaseAccessor
戻り値:
基本アクセサ

getInternationalModelMap

public InternationalModelMap getInternationalModelMap()
国際化モデルのマップを取得します。 この基本モデルに関連する国際化モデルのマップを取得します。

定義:
インタフェース BaseModel 内の getInternationalModelMap
戻り値:
国際化モデルマップ

selectInternationalModel

protected InternationalModel selectInternationalModel(Locale locale)
                                               throws IllegalLocaleException
指定された言語に該当する国際化モデルを取得します。

パラメータ:
locale - 言語
戻り値:
国際化モデル
例外:
IllegalLocaleException - 言語に関する例外が発生した場合

getTerminableModelMap

public TerminableModelMap getTerminableModelMap()
期間化モデルのマップを取得します。 この基本モデルに関連する期間化モデルのマップを取得します。

定義:
インタフェース BaseModel 内の getTerminableModelMap
戻り値:
期間化モデルマップ

selectTerminableModel

protected TerminableModel selectTerminableModel(Date date)
                                         throws IllegalTermException
指定された日時に該当する期間化モデルを取得します。

パラメータ:
date - 日時
戻り値:
期間化モデル
例外:
IllegalTermException - 期間に関する例外が発生した場合

getExtendedBaseModelMap

public ExtendedBaseModelMap getExtendedBaseModelMap()
拡張基本モデルのマップを取得します。 この基本モデルに関連する拡張基本モデルのマップを取得します。

定義:
インタフェース BaseModel 内の getExtendedBaseModelMap
戻り値:
拡張基本モデルマップ

getDefaultDate

protected Date getDefaultDate()
モデル生成時に設定されたデフォルト日時を取得します。

戻り値:
デフォルト日時

getDefaultLocale

protected Locale getDefaultLocale()
モデル生成時に設定されたデフォルト言語を取得します。

戻り値:
デフォルト言語

get

protected Object get(String name)
              throws AccessorException
指定の属性が保持する値を取得します。

パラメータ:
name - 属性名
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

get

protected Object get(String name,
                     Date date)
              throws AccessorException
指定の属性が、指定の日時に保持している値を取得します。

パラメータ:
name - 属性名
date - 日時
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

get

protected Object get(String name,
                     Locale locale)
              throws AccessorException
指定の属性が、指定の言語で保持している値を取得します。

パラメータ:
name - 属性名
locale - 言語
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

get

protected Object get(String name,
                     Date date,
                     Locale locale)
              throws AccessorException
指定の属性が、指定の日時、言語で保持している値を取得します。

パラメータ:
name - 属性名
date - 日時
locale - 言語
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value,
                   Date date)
            throws AccessorException
指定の属性に、指定の日時で値を設定します。

パラメータ:
name - 属性名
value - 値
date - 日時
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value,
                   Locale locale)
            throws AccessorException
指定の属性に、指定の言語で値を設定します。

パラメータ:
name - 属性名
value - 値
locale - 言語
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value,
                   Date date,
                   Locale locale)
            throws AccessorException
指定の属性に、指定の日時、言語で値を設定します。

パラメータ:
name - 属性名
value - 値
date - 日時
locale - 言語
例外:
AccessorException - アクセサで例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericInternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス GenericInternationalModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel
すべての実装インタフェース:
InternationalModel, Serializable
public abstract class GenericInternationalModel
extends Object
implements InternationalModel

国際化モデルの汎用的な抽象クラスです。 このクラスでは、 init(InternationalModelContext)で設定された国際化アクセサを getInternationalAccessor()で取得することができます。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
GenericInternationalModel()
メソッドの概要
protected Object | get(String name) 指定の属性が保持する値を取得します。
ExtendedInternationalModelMap | getExtendedInternationalModelMap() 拡張国際化モデルのマップを取得します。
protected InternationalAccessor | getInternationalAccessor() この国際化モデルに割り当てられた国際化アクセサを取得します。
Locale | getLocale() 国際化モデルが保持する言語 Locale を取得します。
void | init(InternationalModelContext context) 国際化モデルを初期化します。
protected void | set(String name, Object value) 指定の属性に値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericInternationalModel

public GenericInternationalModel()
メソッドの詳細

init

public void init(InternationalModelContext context)
国際化モデルを初期化します。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

定義:
インタフェース InternationalModel 内の init
パラメータ:
context - 国際化モデルコンテキスト

getInternationalAccessor

protected InternationalAccessor getInternationalAccessor()
この国際化モデルに割り当てられた国際化アクセサを取得します。

戻り値:
国際化アクセサ

getExtendedInternationalModelMap

public ExtendedInternationalModelMap getExtendedInternationalModelMap()
拡張国際化モデルのマップを取得します。 この国際化モデルに関連する拡張国際化モデルのマップを取得します。

定義:
インタフェース InternationalModel 内の getExtendedInternationalModelMap
戻り値:
拡張国際化モデルマップ

get

protected Object get(String name)
              throws AccessorException
指定の属性が保持する値を取得します。

パラメータ:
name - 属性名
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
AccessorException - アクセサで例外が発生した場合

getLocale

public Locale getLocale()
国際化モデルが保持する言語 Locale を取得します。 このメソッドをオーバーライドすると言語を取得することが出来なくなります。

定義:
インタフェース InternationalModel 内の getLocale
戻り値:
言語
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericInternationalModelMap (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス GenericInternationalModelMap

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap
すべての実装インタフェース:
InternationalModelMap, Serializable
public abstract class GenericInternationalModelMap
extends Object
implements InternationalModelMap

国際化モデルマッピングの汎用的な抽象クラスです。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
GenericInternationalModelMap()
メソッドの概要
InternationalModel | createInternationalModel(Locale locale) 国際化モデルを生成します。
boolean | exists(Locale locale) 指定された言語に該当する国際化モデルが存在するどうか判定します。
InternationalModel | findInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。
Locale[] | getLocales() マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。
void | init(String modelName, InternationalAccessorMap accessorMap) 初期化処理を行います。
InternationalModel | newInternationalModel(Locale locale) 初期化されていない国際化モデルのインスタンスを取得します。
void | remove(Locale locale) 指定された言語に該当するデータを削除します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericInternationalModelMap

public GenericInternationalModelMap()
メソッドの詳細

init

public void init(String modelName,
                 InternationalAccessorMap accessorMap)
初期化処理を行います。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

パラメータ:
modelName - モデル名
accessorMap - 国際化アクセサマップ

createInternationalModel

public InternationalModel createInternationalModel(Locale locale)
                                            throws AccessorException
国際化モデルを生成します。 引数で指定された言語に該当する既存の情報は新しい情報で上書きされます。 システムで取り扱う言語のみが対象となります。

定義:
インタフェース InternationalModelMap 内の createInternationalModel
パラメータ:
locale - 言語
戻り値:
国際化モデル
例外:
AccessorException - システムで使用することができない言語が指定された場合

exists

public boolean exists(Locale locale)
指定された言語に該当する国際化モデルが存在するどうか判定します。

定義:
インタフェース InternationalModelMap 内の exists
パラメータ:
locale - 言語
戻り値:
指定された言語に該当する国際化モデルが存在する場合は true、それ以外は false

findInternationalModel

public InternationalModel findInternationalModel(Locale locale)
                                          throws IllegalLocaleException
指定された言語に該当する国際化モデルを取得します。 引数 locale で指定された言語に該当する　TerminableModel を取得します。該当するものが存在しない場合、 null が返されます。

定義:
インタフェース InternationalModelMap 内の findInternationalModel
パラメータ:
locale - 対象となる言語
戻り値:
対象となる国際化モデル（存在しない場合は null）
例外:
IllegalLocaleException - 対象のlocale が見つからない場合

remove

public void remove(Locale locale)
            throws AccessorException
指定された言語に該当するデータを削除します。

定義:
インタフェース InternationalModelMap 内の remove
パラメータ:
locale - 削除対象の言語
例外:
AccessorException - アクセサで例外が発生した場合

newInternationalModel

public InternationalModel newInternationalModel(Locale locale)
                                         throws IllegalLocaleException
初期化されていない国際化モデルのインスタンスを取得します。 このメソッドはシステム内で使用されます。明示的に使用しないでください。

パラメータ:
locale - 言語
戻り値:
国際化モデルのインスタンス
例外:
IllegalLocaleException - 言語に関する例外が発生した場合

getLocales

public Locale[] getLocales()
マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。

定義:
インタフェース InternationalModelMap 内の getLocales
戻り値:
言語の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericTerminableInternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス GenericTerminableInternationalModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel
すべての実装インタフェース:
Serializable, TerminableInternationalModel
public abstract class GenericTerminableInternationalModel
extends Object
implements TerminableInternationalModel

期間国際化モデルの汎用的な抽象クラスです。 このクラスでは、 init(TerminableInternationalModelContext)で設定された期間国際化アクセサを getTerminableInternationalAccessor()で取得することができます。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
GenericTerminableInternationalModel()
メソッドの概要
protected Object | get(String name) 指定の属性が保持する値を取得します。
ExtendedTerminableInternationalModelMap | getExtendedTerminableInternationalModelMap() 拡張期間国際化モデルのマップを取得します。
Locale | getLocale() 期間国際化モデルが保持する言語 Locale を取得します。
protected TerminableInternationalAccessor | getTerminableInternationalAccessor() この期間国際化モデルに割り当てられた期間国際化アクセサを取得します。
void | init(TerminableInternationalModelContext context) 期間国際化モデルを初期化します。
protected void | set(String name, Object value) 指定の属性に値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericTerminableInternationalModel

public GenericTerminableInternationalModel()
メソッドの詳細

init

public void init(TerminableInternationalModelContext context)
期間国際化モデルを初期化します。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

定義:
インタフェース TerminableInternationalModel 内の init
パラメータ:
context - 期間国際化モデルコンテキスト

getTerminableInternationalAccessor

protected TerminableInternationalAccessor getTerminableInternationalAccessor()
この期間国際化モデルに割り当てられた期間国際化アクセサを取得します。

戻り値:
期間国際化アクセサ

getExtendedTerminableInternationalModelMap

public ExtendedTerminableInternationalModelMap getExtendedTerminableInternationalModelMap()
拡張期間国際化モデルのマップを取得します。 この期間国際化モデルに関連する拡張期間国際化モデルのマップを取得します。

定義:
インタフェース TerminableInternationalModel 内の getExtendedTerminableInternationalModelMap
戻り値:
拡張期間国際化モデルマップ

get

protected Object get(String name)
              throws AccessorException
指定の属性が保持する値を取得します。

パラメータ:
name - 属性名
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
AccessorException - アクセサで例外が発生した場合

getLocale

public Locale getLocale()
期間国際化モデルが保持する言語 Locale を取得します。 このメソッドをオーバーライドすると言語を取得することが出来なくなります。

定義:
インタフェース TerminableInternationalModel 内の getLocale
戻り値:
言語
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericTerminableInternationalModelMap (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス GenericTerminableInternationalModelMap

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap
すべての実装インタフェース:
Serializable, TerminableInternationalModelMap
public abstract class GenericTerminableInternationalModelMap
extends Object
implements TerminableInternationalModelMap

期間国際化モデルマッピングの汎用的な抽象クラスです。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
GenericTerminableInternationalModelMap()
メソッドの概要
TerminableInternationalModel | createTerminableInternationalModel(Locale locale) 期間国際化モデルを生成します。
boolean | exists(Locale locale) 指定された言語に該当する期間国際化モデルが存在するかどうか判定します。
TerminableInternationalModel | findTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
Locale[] | getLocales() マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。
void | init(String modelName, TerminableInternationalAccessorMap accessorMap) 初期化処理を行います。
TerminableInternationalModel | newTerminableInternationalModel(Locale locale) 初期化されていない期間国際化モデルのインスタンスを取得します。
void | remove(Locale locale) 指定された言語に該当するデータを削除します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericTerminableInternationalModelMap

public GenericTerminableInternationalModelMap()
メソッドの詳細

init

public void init(String modelName,
                 TerminableInternationalAccessorMap accessorMap)
初期化処理を行います。

パラメータ:
modelName - 期間国際化モデルのクラス名
accessorMap - 期間国際化アクセサマップ

createTerminableInternationalModel

public TerminableInternationalModel createTerminableInternationalModel(Locale locale)
                                                                throws AccessorException
期間国際化モデルを生成します。 引数で指定された言語に該当する既存の情報は新しい情報で上書きされます。 システムで取り扱う言語のみが対象となります。

定義:
インタフェース TerminableInternationalModelMap 内の createTerminableInternationalModel
パラメータ:
locale - 言語
戻り値:
期間国際化モデル
例外:
AccessorException - システムで使用することができない言語が指定された場合

exists

public boolean exists(Locale locale)
指定された言語に該当する期間国際化モデルが存在するかどうか判定します。

定義:
インタフェース TerminableInternationalModelMap 内の exists
パラメータ:
locale - 言語
戻り値:
対象となる期間国際化モデルが存在する場合 true、それ以外は false

findTerminableInternationalModel

public TerminableInternationalModel findTerminableInternationalModel(Locale locale)
                                                              throws IllegalLocaleException
指定された言語に該当する期間国際化モデルを取得します。 引数 locale で指定された言語に該当する TerminableInternationalModelを取得します。該当するものが存在しない場合、 null が返されます。

定義:
インタフェース TerminableInternationalModelMap 内の findTerminableInternationalModel
パラメータ:
locale - 対象となる言語
戻り値:
対象となる期間国際化モデル（存在しない場合は null）
例外:
IllegalLocaleException - 対象の言語が見つからない場合

remove

public void remove(Locale locale)
            throws AccessorException
指定された言語に該当するデータを削除します。

定義:
インタフェース TerminableInternationalModelMap 内の remove
パラメータ:
locale - 削除対象の言語
例外:
AccessorException - アクセサで例外が発生した場合

newTerminableInternationalModel

public TerminableInternationalModel newTerminableInternationalModel(Locale locale)
                                                             throws IllegalLocaleException
初期化されていない期間国際化モデルのインスタンスを取得します。 このメソッドはシステム内で使用されます。明示的に使用しないでください。

パラメータ:
locale - 言語
戻り値:
期間国際化モデルのインスタンス
例外:
IllegalLocaleException - 言語に関する例外が発生した場合

getLocales

public Locale[] getLocales()
マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。

定義:
インタフェース TerminableInternationalModelMap 内の getLocales
戻り値:
言語の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericTerminableModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス GenericTerminableModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel
すべての実装インタフェース:
Serializable, TerminableModel
public abstract class GenericTerminableModel
extends Object
implements TerminableModel

期間化モデルの汎用的な抽象クラスです。 このクラスでは、 init(TerminableModelContext)で設定された期間化アクセサを getTerminableAccessor()で取得することができます。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
GenericTerminableModel()
メソッドの概要
protected Object | get(String name) 指定の属性が保持する値を取得します。
protected Object | get(String name, Locale locale) 指定の属性が指定の言語で保持する値を取得します。
protected Locale | getDefaultLocale() モデル生成時に指定された言語を取得します。
ExtendedTerminableModelMap | getExtendedTerminableModelMap() 拡張期間化モデルのマップを取得します。
Term | getTerm() 期間化モデルが保持する期間 Term を取得します。
protected TerminableAccessor | getTerminableAccessor() この期間化モデルに割り当てられた期間化アクセサを取得します。
TerminableInternationalModelMap | getTerminableInternationalModelMap() 期間国際化モデルのマップを取得します。
void | init(TerminableModelContext context) 期間化モデルを初期化します。
protected TerminableInternationalModel | selectTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
protected void | set(String name, Object value) 指定の属性に値を設定します。
protected void | set(String name, Object value, Locale locale) 指定の属性に値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericTerminableModel

public GenericTerminableModel()
メソッドの詳細

init

public void init(TerminableModelContext context)
期間化モデルを初期化します。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

定義:
インタフェース TerminableModel 内の init
パラメータ:
context - 期間化モデルコンテキスト

getTerminableAccessor

protected TerminableAccessor getTerminableAccessor()
この期間化モデルに割り当てられた期間化アクセサを取得します。

戻り値:
期間化アクセサ

getTerminableInternationalModelMap

public TerminableInternationalModelMap getTerminableInternationalModelMap()
期間国際化モデルのマップを取得します。 この期間化モデルに関連する期間国際化モデルのマップを取得します。

定義:
インタフェース TerminableModel 内の getTerminableInternationalModelMap
戻り値:
期間国際化モデルマップ

selectTerminableInternationalModel

protected TerminableInternationalModel selectTerminableInternationalModel(Locale locale)
                                                                   throws IllegalLocaleException
指定された言語に該当する期間国際化モデルを取得します。

パラメータ:
locale - 言語
戻り値:
期間国際化モデル
例外:
IllegalLocaleException - 言語に関する問題が発生した場合

getExtendedTerminableModelMap

public ExtendedTerminableModelMap getExtendedTerminableModelMap()
拡張期間化モデルのマップを取得します。 この期間化モデルに関連する拡張期間化モデルのマップを取得します。

定義:
インタフェース TerminableModel 内の getExtendedTerminableModelMap
戻り値:
拡張期間化モデルマップ

getDefaultLocale

protected Locale getDefaultLocale()
モデル生成時に指定された言語を取得します。

戻り値:
モデル生成時のlocale

get

protected Object get(String name)
              throws AccessorException
指定の属性が保持する値を取得します。

パラメータ:
name - 属性名
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

get

protected Object get(String name,
                     Locale locale)
              throws AccessorException
指定の属性が指定の言語で保持する値を取得します。

パラメータ:
name - 属性名
locale - 言語
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value,
                   Locale locale)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
IllegalLocaleException - 言語に関する例外が発生した場合
AccessorException - アクセサで例外が発生した場合

getTerm

public Term getTerm()
期間化モデルが保持する期間 Term を取得します。 このメソッドをオーバーライドすると期間を取得できなくなります。

定義:
インタフェース TerminableModel 内の getTerm
戻り値:
期間
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericTerminableModelMap (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス GenericTerminableModelMap

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap
すべての実装インタフェース:
Serializable, TerminableModelMap
public abstract class GenericTerminableModelMap
extends Object
implements TerminableModelMap

期間化モデルマッピングの汎用的な抽象クラスです。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
GenericTerminableModelMap()
メソッドの概要
TerminableModel | createTerminableModel(Term term) 指定した期間を満たす期間化モデルを生成します。
boolean | exists(Date date) 指定された日時を含む期間化モデルが存在するかどうか判定します。
TerminableModel | findTerminableModel(Date date) 指定された日時に該当する期間化モデルを取得します。
Term[] | getTerms() マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。
void | init(String terminableName, String terminableInternationalName, TerminableAccessorMap accessorMap, Locale defaultLocale) 初期化処理を行います。
TerminableModel | newTerminableModel(Term term) 初期化されていない期間化モデルのインスタンスを取得します。
void | remove(Term term) 指定された期間に該当するデータを削除します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericTerminableModelMap

public GenericTerminableModelMap()
メソッドの詳細

init

public void init(String terminableName,
                 String terminableInternationalName,
                 TerminableAccessorMap accessorMap,
                 Locale defaultLocale)
初期化処理を行います。

パラメータ:
terminableName - 期間化モデルのクラス名
terminableInternationalName - 期間国際化モデルのクラス名
accessorMap - 期間化アクセサマップ
defaultLocale - デフォルト言語

createTerminableModel

public TerminableModel createTerminableModel(Term term)
                                      throws AccessorException
指定した期間を満たす期間化モデルを生成します。 設定した期間化モデルによって重複する期間が発生する場合、例外が発生します。

定義:
インタフェース TerminableModelMap 内の createTerminableModel
パラメータ:
term - 期間 　　 *
戻り値:
期間化モデル
例外:
AccessorException - アクセサで何らかの例外が発生した場合

exists

public boolean exists(Date date)
指定された日時を含む期間化モデルが存在するかどうか判定します。

定義:
インタフェース TerminableModelMap 内の exists
パラメータ:
date - 日時
戻り値:
指定された日時を含む期間化モデルが存在する場合は true、それ以外は false

findTerminableModel

public TerminableModel findTerminableModel(Date date)
                                    throws IllegalTermException
指定された日時に該当する期間化モデルを取得します。 引数 date で指定された日時を期間内に含む TerminableModelを取得します。
指定された日時に該当する期間化モデルが存在しない場合は例外を返します。

定義:
インタフェース TerminableModelMap 内の findTerminableModel
パラメータ:
date - 対象となる日時
戻り値:
対象となる期間化モデル
例外:
IllegalTermException - 該当するものが存在しない場合

remove

public void remove(Term term)
            throws AccessorException
指定された期間に該当するデータを削除します。 削除対象の期間に該当するデータがなくなるよう、既存のデータの有効開始日時や有効終了日時は調整されます。

定義:
インタフェース TerminableModelMap 内の remove
パラメータ:
term - 削除対象の期間
例外:
AccessorException - アクセサで何らかの例外が発生した場合

newTerminableModel

public TerminableModel newTerminableModel(Term term)
                                   throws DataStoreSystemException
初期化されていない期間化モデルのインスタンスを取得します。 このメソッドはシステム内で使用されます。明示的に使用しないでください。

パラメータ:
term - 期間
戻り値:
期間化モデルのインスタンス
例外:
DataStoreSystemException

getTerms

public Term[] getTerms()
マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。 取得される期間は時系列でソートされています。

定義:
インタフェース TerminableModelMap 内の getTerms
戻り値:
期間の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース InternationalModel

すべてのスーパーインタフェース:
Serializable
既知のサブインタフェースの一覧:
CalendarInfoInternationalModel, CategoryDetailInternationalModel, CateogryClassInternationalModel, ItemAttributeInternationalModel, ItemCategoryInternationalModel, ItemTemplateDetailInternationalModel, ItemTemplateInternationalModel, MenuInternationalModel, RoleInternationalModel
既知の実装クラスの一覧:
GenericInternationalModel
public interface InternationalModel
extends Serializable

国際化モデルの情報です。 国際化エンティティの1データが国際化モデルの1インスタンスに対応します。

導入されたバージョン:
5.0

メソッドの概要
ExtendedInternationalModelMap | getExtendedInternationalModelMap() 拡張国際化エンティティに対応する拡張国際化モデルのマップを取得します。
Locale | getLocale() 国際化モデルが保持する言語 Locale を取得します。
void | init(InternationalModelContext context) 国際化モデルを初期化します。

メソッドの詳細

init

public void init(InternationalModelContext context)
国際化モデルを初期化します。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

パラメータ:
context - 国際化モデルコンテキスト

getExtendedInternationalModelMap

public ExtendedInternationalModelMap getExtendedInternationalModelMap()
拡張国際化エンティティに対応する拡張国際化モデルのマップを取得します。

戻り値:
拡張国際化モデルマップ

getLocale

public Locale getLocale()
国際化モデルが保持する言語 Locale を取得します。 このメソッドをオーバーライドすると言語を取得することが出来なくなります。

戻り値:
言語
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalModelContext (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース InternationalModelContext

public interface InternationalModelContext

国際化モデルの初期化に必要な設定を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedInternationalModelMap | getExtendedInternationalModelMap() 拡張国際化モデルマップを取得します。
InternationalAccessor | getInternationalAccessor() 国際化アクセサを取得します。
void | setExtendedInternationalModelMap(ExtendedInternationalModelMap extendedMap) 拡張国際化モデルマップを設定します。
void | setInternationalAccessor(InternationalAccessor accessor) 国際化アクセサを設定します。

メソッドの詳細

setInternationalAccessor

public void setInternationalAccessor(InternationalAccessor accessor)
国際化アクセサを設定します。

パラメータ:
accessor - 国際化アクセサ

getInternationalAccessor

public InternationalAccessor getInternationalAccessor()
国際化アクセサを取得します。

戻り値:
国際化アクセサ

setExtendedInternationalModelMap

public void setExtendedInternationalModelMap(ExtendedInternationalModelMap extendedMap)
拡張国際化モデルマップを設定します。

パラメータ:
extendedMap - 拡張国際化モデルマップ

getExtendedInternationalModelMap

public ExtendedInternationalModelMap getExtendedInternationalModelMap()
拡張国際化モデルマップを取得します。

戻り値:
拡張国際化モデルマップ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalModelMap (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース InternationalModelMap

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
GenericInternationalModelMap
public interface InternationalModelMap
extends Serializable

国際化モデルのマッピング情報を持ちます。 システムで定義された言語に対応する情報のみを持ちます。

導入されたバージョン:
5.0

メソッドの概要
InternationalModel | createInternationalModel(Locale locale) 国際化モデルを生成します。
boolean | exists(Locale locale) 指定された言語に該当する国際化モデルが存在するどうか判定します。
InternationalModel | findInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。
Locale[] | getLocales() マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。
void | remove(Locale locale) 指定された言語に該当するデータを削除します。

メソッドの詳細

createInternationalModel

public InternationalModel createInternationalModel(Locale locale)
                                            throws AccessorException
国際化モデルを生成します。 引数で指定された言語に該当する既存の情報は新しい情報で上書きされます。 システムで取り扱う言語のみが対象となります。

パラメータ:
locale - 言語
戻り値:
国際化モデル
例外:
AccessorException - システムで使用することができない言語が指定された場合

exists

public boolean exists(Locale locale)
指定された言語に該当する国際化モデルが存在するどうか判定します。

パラメータ:
locale - 言語
戻り値:
指定された言語に該当する国際化モデルが存在する場合は true、それ以外は false

findInternationalModel

public InternationalModel findInternationalModel(Locale locale)
                                          throws IllegalLocaleException
指定された言語に該当する国際化モデルを取得します。 引数 locale で指定された言語に該当する InternationalModel を取得します。該当するものが存在しない場合、 null が返されます。

パラメータ:
locale - 対象となる言語
戻り値:
対象となる期間化モデル（存在しない場合は null）
例外:
IllegalLocaleException - 言語に関する例外が発生した場合

getLocales

public Locale[] getLocales()
マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。

戻り値:
言語の一覧

remove

public void remove(Locale locale)
            throws AccessorException
指定された言語に該当するデータを削除します。

パラメータ:
locale - 削除対象の言語
例外:
AccessorException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartDBMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス IntramartDBMapper

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper
すべての実装インタフェース:
Mapper
public abstract class IntramartDBMapper
extends Object
implements Mapper

intra-martで管理されるデータベースにアクセスするマッパーの汎用的な抽象クラスです。

導入されたバージョン:
5.0

コンストラクタの概要
IntramartDBMapper()
メソッドの概要
void | checkByBaseProperty(Relationship[] relationships, BaseModel target, BaseModel base) 基準項目によるリレーションシップの整合性制約をチェックします。
void | close() マッパーをクローズします。
protected BaseAccessor | createBaseAccessor(Map primary) このマッパーに該当する基本アクセサを新規に生成します。
BaseModel | createBaseModel(Map keys) このマッパーに該当する基本モデルを新規に生成します。
protected void | delete(BaseModel model) 基本モデルを1つだけ削除します。
protected void | delete(Collection models) アクセサを複数削除します。
protected abstract String | getApplicationName() マッパーが定義されているアプリケーション名を取得します。
protected abstract String | getEntityName() マッパーがアクセスするエンティティ名を取得します。
void | init(String user, String group) マッパーを初期化します。
protected void | insert(BaseModel model) 基本モデルを1つだけ挿入します。
protected void | insert(Collection models) 基本モデルを複数挿入します。
boolean | isClosed() マッパーがクローズされているかどうか確認します。
void | notifyDelete(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
void | notifyUpdate(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
BaseModel | select(Map keys) プライマリーキーで特定される基本モデルを取得します。
protected Collection | select(Relationship relationship, Map keys) 外部キーで特定される基本モデルをすべて取得します。
protected void | update(BaseModel model) 基本モデルを1つだけ更新します。
protected void | update(Collection models) 基本モデルを複数更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartDBMapper

public IntramartDBMapper()
メソッドの詳細

init

public void init(String user,
                 String group)
          throws MapperException
マッパーを初期化します。 マッパーを生成する場合は、このメソッドを必ず呼び出して下さい。

定義:
インタフェース Mapper 内の init
パラメータ:
user - ログインユーザID
group - ログイングループID
例外:
MapperException - マッパーの初期化に失敗した場合

createBaseAccessor

protected BaseAccessor createBaseAccessor(Map primary)
                                   throws MapperException
このマッパーに該当する基本アクセサを新規に生成します。 アクセサはコンストラクタではなくこの新規生成系メソッドでのみ生成します。このメソッドで生成されたアクセサは次の状態です。
  • 指定された（または自動的に割り当てられた）プライマリキーが設定済
  • 国際化モデルが1つだけ存在
    • ロケールはデフォルトロケール
  • 期間化アクセサが1つだけ存在
    • 有効開始日は期間の最小日時 (1582/10/15|00:00:00)
    • 有効終了日は期間の最大日時 (9999/12/31|23:59:59)
  • 期間国際化アクセサが1つだけ存在
    • ロケールはデフォルトロケール
    • 有効開始日は期間の最小日時 (1582/10/15|00:00:00)
    • 有効終了日は期間の最大日時 (9999/12/31|23:59:59)

パラメータ:
primary - 基本アクセサのプライマリキー
戻り値:
基本アクセサ
例外:
MapperException

createBaseModel

public BaseModel createBaseModel(Map keys)
                          throws MapperException
このマッパーに該当する基本モデルを新規に生成します。 モデルを新規に生成することができるのはこのメソッドだけです。このメソッドで生成されたモデルは次の状態になります。
  • 指定されたプライマリキーが設定済
  • 該当するエンティティが国際化されている場合は、国際化モデルが1つだけ存在
    • ロケールはデフォルトロケール
  • 該当するエンティティが期間化されている場合は、期間化モデルが1つだけ存在
    • 有効開始日は期間の最小日時 (1582/10/15|00:00:00)
    • 有効終了日は期間の最大日時 (9999/12/31|23:59:59)
  • 該当するエンティティが期間国際化されている場合は、期間国際化モデルが1つだけ存在
    • ロケールはデフォルトロケール
    • 有効開始日は期間の最小日時 (1582/10/15|00:00:00)
    • 有効終了日は期間の最大日時 (9999/12/31|23:59:59)
    このメソッドで生成されたモデルはまだデータベースには反映されていません。データベースに反映するためには以下のデータ更新系のAPIを使用します。
    • insert(BaseModel)
    • insert(Collection)
    • update(BaseModel)
    • update(Collection)
    • delete(BaseModel)
    • delete(Collection)

    定義:
    インタフェース Mapper 内の createBaseModel
    パラメータ:
    keys - 項目名とその値を持つプライマリキーのマップ
    戻り値:
    プライマリキーが設定された基本モデル
    例外:
    MapperException - モデルの生成に失敗した場合

select

public BaseModel select(Map keys)
                 throws MapperException
プライマリーキーで特定される基本モデルを取得します。 取得される基本モデルには、国際化されている場合にはすべての言語情報、期間化されている場合にはすべての期間情報が設定されます。 また、基本モデル BaseModel、国際化モデル InternationalModel、期間化モデル TerminableModel、 期間国際化モデル TerminableInternationalModel にはすべてのプロパティが設定されます。
プライマリーキーに一致するデータが存在しない場合は、null を返します。

定義:
インタフェース Mapper 内の select
パラメータ:
keys - 項目名とその値を持つプライマリキーのマップ
戻り値:
基本モデル
例外:
MapperException - モデルの取得に失敗した場合

select

protected Collection select(Relationship relationship,
                            Map keys)
                     throws MapperException
外部キーで特定される基本モデルをすべて取得します。 外部キーによる検索条件に一致する基本モデル BaseModel のコレクション Collection が取得されます。
検索条件に一致するデータが存在しない場合は、空のコレクションを返します。

パラメータ:
relationship - 検索する基本モデルの外部キー項目を定義したリレーションシップ
keys - 検索条件
戻り値:
基本モデルのコレクション
例外:
MapperException - 基本モデルの取得に失敗した場合

insert

protected void insert(BaseModel model)
               throws MapperException
基本モデルを1つだけ挿入します。 引数に指定する基本モデルは同一の Mapperの createBaseAccessor(Map) で生成されたものである必要があります。

パラメータ:
model - 挿入するモデル
例外:
MapperException - 基本モデルの挿入に失敗した場合

insert

protected void insert(Collection models)
               throws MapperException
基本モデルを複数挿入します。 引数に指定するものは同一の Mapperの createBaseAccessor(Map) で生成されたアクセサの集合である必要があります。

パラメータ:
models - 挿入する基本モデルの集合
例外:
MapperException - 基本モデルの挿入に失敗した場合

update

protected void update(BaseModel model)
               throws MapperException
基本モデルを1つだけ更新します。 引数に指定するアクセサは同一の Mapperの select 系メソッドから取得されたものか createBaseAccessor(Map) で生成されたものである必要があります。期間が重複するデータが存在する場合、指定したアクセサが最優先されるように期間が調節された上で上書きします。

パラメータ:
model - 更新する基本モデル
例外:
MapperException - 基本モデルの更新に失敗した場合

update

protected void update(Collection models)
               throws MapperException
基本モデルを複数更新します。 引数に指定するものは同一の Mapperの select 系メソッドから取得されたものか createBaseAccessor(Map) で生成された基本モデルの集合である必要があります。

パラメータ:
models - 更新する基本モデルの集合
例外:
MapperException - 基本モデルの更新に失敗した場合

delete

protected void delete(BaseModel model)
               throws MapperException
基本モデルを1つだけ削除します。 引数で指定された基本モデルに該当するデータのすべての期間の情報を削除します。引数に指定する基本モデルは同一の Mapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するアクセサ
例外:
MapperException - 基本モデルの削除に失敗した場合

delete

protected void delete(Collection models)
               throws MapperException
アクセサを複数削除します。 引数で指定されたものに該当するデータのすべての期間の情報を削除します。引数に指定するアクセサは同一の Mapperの select 系メソッド から取得されたアクセサの集合である必要があります。

パラメータ:
models - 削除するアクセサ
例外:
MapperException - 基本モデルの削除に失敗した場合

notifyUpdate

public void notifyUpdate(Relationship relationship,
                         BaseModel model)
                  throws MapperException
リレーションシップで定義された参照先基本モデルが更新されたことを通知します。 引数で指定されたリレーションシップ Relationship の参照先基本モデル BaseModel が更新された場合に、このメソッドを呼び出してその内容を通知します。 マッパー Mapper は参照先モデルの更新内容と整合性をとるために、それを参照する基本モデルの内容を更新します。

定義:
インタフェース Mapper 内の notifyUpdate
パラメータ:
relationship - リレーションシップ
model - 参照先基本モデル
例外:
MapperException - 更新通知先で何らかの例外が発生した場合

notifyDelete

public void notifyDelete(Relationship relationship,
                         BaseModel model)
                  throws MapperException
リレーションシップで定義された参照先基本モデルが削除されたことを通知します。 引数で指定されたリレーションシップ Relationship の参照先基本モデル BaseModel が削除された場合にその内容を通知します。 マッパー Mapper は削除されたモデルを参照する基本モデルに対して、整合性を守るための更新を行います。

定義:
インタフェース Mapper 内の notifyDelete
パラメータ:
relationship - リレーションシップ
model - 参照先基本モデル
例外:
MapperException - 更新通知先で何らかの例外が発生した場合

checkByBaseProperty

public void checkByBaseProperty(Relationship[] relationships,
                                BaseModel target,
                                BaseModel base)
                         throws MapperException
基準項目によるリレーションシップの整合性制約をチェックします。 整合性制約違反が存在する場合は、MapperException をスローします。 リレーションシップ Relationship には、基準項目を参照するリレーションシップを参照元とするエンティティ Entity まで たどるためのリレーションシップの集合を設定します。

定義:
インタフェース Mapper 内の checkByBaseProperty
パラメータ:
relationships - リレーションシップの集合
target - 参照先基本モデル
base - 基準項目をもつ基本モデル
例外:
MapperException - 基準項目によるチェックで制約違反があった場合

close

public void close()
           throws MapperException
マッパーをクローズします。 このメソッドはトランザクションが終了される前に必ず呼び出される必要があります。 このメソッドが呼ばれると、マッパーは再利用できなくなります。 また、このマッパーから取得されたモデルの更新もできなくなります。

定義:
インタフェース Mapper 内の close
例外:
MapperException - マッパーがすでにクローズされている場合

getApplicationName

protected abstract String getApplicationName()
マッパーが定義されているアプリケーション名を取得します。

戻り値:
アプリケーション名

getEntityName

protected abstract String getEntityName()
マッパーがアクセスするエンティティ名を取得します。

戻り値:
エンティティ名

isClosed

public boolean isClosed()
マッパーがクローズされているかどうか確認します。

定義:
インタフェース Mapper 内の isClosed
戻り値:
クローズされている場合 true 、そうでなければ false
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Mapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース Mapper

既知のサブインタフェースの一覧:
AccessControllerDepartmentMapper, AccessControllerMapper, AccessControllerPostMapper, AccessControllerPublicGroupMapper, AccessControllerRoleMapper, AccountAttributeMapper, AccountMapper, AccountRoleMapper, BatchMapper, CalendarInfoMapper, CategoryDetailMapper, CateogryClassMapper, CompanyCategoryMapper, CompanyMapper, CompanyPostMapper, CompanyVersionMapper, DealDetailMapper, DealerDepartmentMapper, DealerPublicGroupMapper, DealerRoleMapper, DealMapper, DepartmentAttachMapper, DepartmentInclusionMapper, DepartmentMainMapper, DepartmentMapper, FavoriteMenuMapper, ItemAttachMapper, ItemAttributeMapper, ItemCatalogueMapper, ItemCategoryMapper, ItemCategoryTypeMapper, ItemMapper, ItemTemplateDetailMapper, ItemTemplateMapper, MenuArgumentMapper, MenuDepartmentMapper, MenuMapper, MenuPostMapper, MenuPublicGroupMapper, MenuRoleMapper, PrivateGroupAttachMapper, PrivateGroupMapper, PublicGroupAttachMapper, PublicGroupCategoryMapper, PublicGroupInclusionMapper, PublicGroupMapper, PublicGroupSetMapper, PublicGroupVersionMapper, RoleInclusionMapper, RoleMapper, RoleSummaryMapper, UnitMapper, UserMapper
既知の実装クラスの一覧:
IntramartDBMapper
public interface Mapper

エンティティの情報のマッパーです。 実際に永続化されるデータとJavaのクラスを対応付けます。 一度close()メソッドが呼ばれると、isClosed()以外のメソッドはすべて例外をthrowします。

導入されたバージョン:
5.0

メソッドの概要
void | checkByBaseProperty(Relationship[] relationships, BaseModel target, BaseModel base) 基準項目によるリレーションシップの整合性制約をチェックします。
void | close() マッパーをクローズします。
BaseModel | createBaseModel(Map keys) このマッパーに該当する基本モデルを新規に生成します。
void | init(String user, String group) マッパーを初期化します。
boolean | isClosed() マッパーがクローズされているかどうか確認します。
void | notifyDelete(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
void | notifyUpdate(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
BaseModel | select(Map keys) プライマリーキーで特定される基本モデルを取得します。

メソッドの詳細

init

public void init(String user,
                 String group)
          throws MapperException
マッパーを初期化します。 マッパーを生成する場合は、このメソッドを必ず呼び出して下さい。

パラメータ:
user - ログインユーザ
group - ログイングループ名
例外:
MapperException - マッパーの初期化に失敗した場合

createBaseModel

public BaseModel createBaseModel(Map keys)
                          throws MapperException
このマッパーに該当する基本モデルを新規に生成します。 モデルを新規に生成することができるのはこのメソッドだけです。このメソッドで生成されたモデルは次の状態になります。
  • 指定されたプライマリキーが設定済
  • 該当するエンティティが国際化されている場合は、国際化モデルが1つだけ存在
    • ロケールはデフォルトロケール
  • 該当するエンティティが期間化されている場合は、期間化モデルが1つだけ存在
    • 有効開始日は期間の最小日時 (1582/10/15)
    • 有効終了日は期間の最大日時 (9999/12/31)
  • 該当するエンティティが期間国際化されている場合は、期間国際化モデルが1つだけ存在
    • ロケールはデフォルトロケール
    • 有効開始日は期間の最小日時 (1582/10/15)
    • 有効終了日は期間の最大日時 (9999/12/31)

    パラメータ:
    keys - 項目名とその値を持つプライマリキーのマップ
    戻り値:
    プライマリキーが設定された基本モデル
    例外:
    MapperException - モデルの生成に失敗した場合

select

public BaseModel select(Map keys)
                 throws MapperException
プライマリーキーで特定される基本モデルを取得します。 取得される基本モデルには、国際化されている場合にはすべての言語情報、期間化されている場合にはすべての期間情報が設定されます。 また、基本モデル BaseModel、国際化モデル InternationalModel、期間化モデル TerminableModel、 期間国際化モデル TerminableInternationalModel にはすべてのプロパティが設定されます。

パラメータ:
keys - 項目名とその値を持つプライマリキーのマップ
戻り値:
基本モデル
例外:
MapperException - 検索で例外が発生した場合

notifyUpdate

public void notifyUpdate(Relationship relationship,
                         BaseModel model)
                  throws MapperException
リレーションシップで定義された参照先基本モデルが更新されたことを通知します。 引数で指定されたリレーションシップ Relationship の参照先基本モデル BaseModel が更新された場合に、このメソッドを呼び出してその内容を通知します。 マッパー Mapper は参照先モデルの更新内容と整合性をとるために、それを参照する基本モデルの内容を更新します。

パラメータ:
relationship - リレーションシップ
model - 参照先基本モデル
例外:
MapperException - 更新通知先で何らかの例外が発生した場合

notifyDelete

public void notifyDelete(Relationship relationship,
                         BaseModel model)
                  throws MapperException
リレーションシップで定義された参照先基本モデルが削除されたことを通知します。 引数で指定されたリレーションシップ Relationship の参照先基本モデル BaseModel が削除された場合にその内容を通知します。 マッパー Mapper は削除されたモデルを参照する基本モデルに対して、整合性を守るための更新を行います。

パラメータ:
relationship - リレーションシップ
model - 参照先基本モデル
例外:
MapperException - 更新通知先で何らかの例外が発生した場合

checkByBaseProperty

public void checkByBaseProperty(Relationship[] relationships,
                                BaseModel target,
                                BaseModel base)
                         throws MapperException
基準項目によるリレーションシップの整合性制約をチェックします。 リレーションシップ Relationship には、基準項目を参照するリレーションシップを参照元とするエンティティ Entity まで たどるためのリレーションシップの集合を設定します。 基本モデル BaseModel は、基準項目をプロパティにもつ基本モデルを設定します。

パラメータ:
relationships - リレーションシップの集合
target - 参照先基本モデル
base - 基準項目をもつ基本モデル
例外:
MapperException - 基準項目によるチェックで何らかの例外が発生した場合

close

public void close()
           throws MapperException
マッパーをクローズします。 このメソッドはトランザクションが終了される前に必ず呼び出される必要があります。 このメソッドが呼ばれると、マッパーは再利用できなくなります。 また、このマッパーから取得されたモデルの更新もできなくなります。

例外:
MapperException - マッパーがすでにクローズされている場合

isClosed

public boolean isClosed()
マッパーがクローズされているかどうか確認します。

戻り値:
クローズされている場合 true 、そうでなければ false
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MapperFactory (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス MapperFactory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.MapperFactory
public abstract class MapperFactory
extends Object

マッパーを生成します。

導入されたバージョン:
5.0

コンストラクタの概要
MapperFactory()
メソッドの概要
abstract Mapper | createMapper(String application, String entity, String group, String user) マッパーを生成します。
static MapperFactory | newInstance() マッパーファクトリを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MapperFactory

public MapperFactory()
メソッドの詳細

newInstance

public static MapperFactory newInstance()
                                 throws MapperException
マッパーファクトリを取得します。

戻り値:
マッパーファクトリ
例外:
MapperException

createMapper

public abstract Mapper createMapper(String application,
                                    String entity,
                                    String group,
                                    String user)
                             throws MapperException
マッパーを生成します。

パラメータ:
application - マッパーを定義するアプリケーション名
entity - マッパーを定義するエンティティ名
group - ログイングループ名
user - ログインユーザコード
戻り値:
マッパー
例外:
MapperException - マッパーの生成に失敗した時
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.common.model (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.common.model
インタフェース
BaseModel
BaseModelContext
ExtendedBaseModel
ExtendedBaseModelMap
ExtendedInternationalModel
ExtendedInternationalModelMap
ExtendedTerminableInternationalModel
ExtendedTerminableInternationalModelMap
ExtendedTerminableModel
ExtendedTerminableModelMap
InternationalModel
InternationalModelContext
InternationalModelMap
Mapper
TerminableInternationalModel
TerminableInternationalModelContext
TerminableInternationalModelMap
TerminableModel
TerminableModelContext
TerminableModelMap
クラス
ExtendedGenericBaseModel
ExtendedGenericBaseModelMap
ExtendedGenericInternationalModel
ExtendedGenericInternationalModelMap
ExtendedGenericTerminableInternationalModel
ExtendedGenericTerminableInternationalModelMap
ExtendedGenericTerminableModel
ExtendedGenericTerminableModelMap
GenericBaseModel
GenericInternationalModel
GenericInternationalModelMap
GenericTerminableInternationalModel
GenericTerminableInternationalModelMap
GenericTerminableModel
GenericTerminableModelMap
IntramartDBMapper
MapperFactory


jp.co.intra_mart.foundation.datastore.common.model (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.common.model

情報を扱うための、モデルやマッパーを提供します。

参照:
説明

インタフェースの概要
BaseModel | 基本モデルの情報です。
BaseModelContext | 基本モデルの初期化に必要な設定を持ちます。
ExtendedBaseModel | 拡張基本モデルの情報です。
ExtendedBaseModelMap | 拡張基本モデルのマッピング情報を持ちます。
ExtendedInternationalModel | 拡張国際化モデルの情報です。
ExtendedInternationalModelMap | 拡張国際化モデルのマッピング情報を持ちます。
ExtendedTerminableInternationalModel | 拡張期間国際化モデルの情報です。
ExtendedTerminableInternationalModelMap | 拡張期間国際化モデルのマッピング情報を持ちます。
ExtendedTerminableModel | 拡張期間化モデルの情報です。
ExtendedTerminableModelMap | 拡張期間化モデルのマッピング情報を持ちます。
InternationalModel | 国際化モデルの情報です。
InternationalModelContext | 国際化モデルの初期化に必要な設定を持ちます。
InternationalModelMap | 国際化モデルのマッピング情報を持ちます。
Mapper | エンティティの情報のマッパーです。
TerminableInternationalModel | 期間国際化モデルの情報です。
TerminableInternationalModelContext | 期間国際化モデルの初期化に必要な設定を持ちます。
TerminableInternationalModelMap | 期間国際化モデルのマッピング情報を持ちます。
TerminableModel | 期間化モデルの情報です。
TerminableModelContext | 期間化化モデルの初期化に必要な設定を持ちます。
TerminableModelMap | 期間化モデルのマッピング情報を持ちます。

クラスの概要
ExtendedGenericBaseModel | 拡張基本モデルの汎用的な抽象クラスです。
ExtendedGenericBaseModelMap | 拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。
ExtendedGenericInternationalModel | 拡張国際化モデルの汎用的な抽象クラスです。
ExtendedGenericInternationalModelMap | 拡張国際化モデルのマッピング情報を持つ汎用的な抽象クラスです。
ExtendedGenericTerminableInternationalModel | 拡張期間国際化モデルの汎用的な抽象クラスです。
ExtendedGenericTerminableInternationalModelMap | 拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。
ExtendedGenericTerminableModel | 拡張期間化モデルの汎用的な抽象クラスです。
ExtendedGenericTerminableModelMap | 拡張期間化モデルのマッピング情報を持つ汎用的な抽象クラスです。
GenericBaseModel | 基本モデルの汎用的な抽象クラスです。
GenericInternationalModel | 国際化モデルの汎用的な抽象クラスです。
GenericInternationalModelMap | 国際化モデルマッピングの汎用的な抽象クラスです。
GenericTerminableInternationalModel | 期間国際化モデルの汎用的な抽象クラスです。
GenericTerminableInternationalModelMap | 期間国際化モデルマッピングの汎用的な抽象クラスです。
GenericTerminableModel | 期間化モデルの汎用的な抽象クラスです。
GenericTerminableModelMap | 期間化モデルマッピングの汎用的な抽象クラスです。
IntramartDBMapper | intra-martで管理されるデータベースにアクセスするマッパーの汎用的な抽象クラスです。
MapperFactory | マッパーを生成します。

パッケージ jp.co.intra_mart.foundation.datastore.common.model の説明

情報を扱うための、モデルやマッパーを提供します。


jp.co.intra_mart.foundation.datastore.common.model クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.common.model の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel (implements jp.co.intra_mart.foundation.datastore.common.model.BaseModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.InternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper (implements jp.co.intra_mart.foundation.datastore.common.model.Mapper)
    • class jp.co.intra_mart.foundation.datastore.common.model.MapperFactory

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext
  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext
  • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext


パッケージ jp.co.intra_mart.foundation.datastore.common.model の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.common.model の使用

jp.co.intra_mart.foundation.datastore.common.model を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category | 会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company | 会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion | 組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version | 会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.deal | 取扱情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.department | 取扱組織権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.detail | 取扱詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group | 取扱パブリックグループ権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.role | 取扱ロール権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.attribute | 商品属性情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue | 商品カタログ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.item | 商品情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach | 商品分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.category | 商品カテゴリ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.type | 商品カテゴリ種別情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail | 商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.template | 商品テンプレート情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach | プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group | プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach | パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category | パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion | パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set | パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version | パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.unit | 単位情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.system.security.datastore.inf |

jp.co.intra_mart.foundation.datastore.application.model.category.category_class により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
InternationalModel
国際化モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.category.detail により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
InternationalModel
国際化モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.company.attach により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.company.category により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.company.company により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.company.department により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableInternationalModel
期間国際化モデルの情報です。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.company.main により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.company.post により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableInternationalModel
期間国際化モデルの情報です。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.company.version により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.deal.deal により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.deal.department により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.deal.detail により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.deal.role により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.item.attribute により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
InternationalModel
国際化モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.item.item により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableInternationalModel
期間国際化モデルの情報です。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.item_category.category により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
InternationalModel
国際化モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.item_category.type により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
InternationalModel
国際化モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.item_template.template により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
InternationalModel
国際化モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.private_group.group により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableInternationalModel
期間国際化モデルの情報です。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.set により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.version により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.unit により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.user により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableInternationalModel
期間国際化モデルの情報です。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.common.model により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
BaseModelContext
基本モデルの初期化に必要な設定を持ちます。
ExtendedBaseModel
拡張基本モデルの情報です。
ExtendedBaseModelMap
拡張基本モデルのマッピング情報を持ちます。
ExtendedInternationalModel
拡張国際化モデルの情報です。
ExtendedInternationalModelMap
拡張国際化モデルのマッピング情報を持ちます。
ExtendedTerminableInternationalModel
拡張期間国際化モデルの情報です。
ExtendedTerminableInternationalModelMap
拡張期間国際化モデルのマッピング情報を持ちます。
ExtendedTerminableModel
拡張期間化モデルの情報です。
ExtendedTerminableModelMap
拡張期間化モデルのマッピング情報を持ちます。
InternationalModel
国際化モデルの情報です。
InternationalModelContext
国際化モデルの初期化に必要な設定を持ちます。
InternationalModelMap
国際化モデルのマッピング情報を持ちます。
Mapper
エンティティの情報のマッパーです。
MapperFactory
マッパーを生成します。
TerminableInternationalModel
期間国際化モデルの情報です。
TerminableInternationalModelContext
期間国際化モデルの初期化に必要な設定を持ちます。
TerminableInternationalModelMap
期間国際化モデルのマッピング情報を持ちます。
TerminableModel
期間化モデルの情報です。
TerminableModelContext
期間化化モデルの初期化に必要な設定を持ちます。
TerminableModelMap
期間化モデルのマッピング情報を持ちます。

jp.co.intra_mart.system.security.datastore.inf により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
InternationalModel
国際化モデルの情報です。
Mapper
エンティティの情報のマッパーです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


TerminableInternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース TerminableInternationalModel

すべてのスーパーインタフェース:
Serializable
既知のサブインタフェースの一覧:
CompanyPostTerminableInternationalModel, DepartmentTerminableInternationalModel, ItemTerminableInternationalModel, PublicGroupTerminableInternationalModel, UserTerminableInternationalModel
既知の実装クラスの一覧:
GenericTerminableInternationalModel
public interface TerminableInternationalModel
extends Serializable

期間国際化モデルの情報です。 期間国際化エンティティの1データが期間国際化モデルの1インスタンスに対応します。

導入されたバージョン:
5.0

メソッドの概要
ExtendedTerminableInternationalModelMap | getExtendedTerminableInternationalModelMap() 拡張期間国際化エンティティに対応する拡張期間国際化モデルのマップを取得します。
Locale | getLocale() 期間国際化モデルが保持する言語 Locale を取得します。
void | init(TerminableInternationalModelContext context) 期間国際化モデルを初期化します。

メソッドの詳細

init

public void init(TerminableInternationalModelContext context)
期間国際化モデルを初期化します。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

パラメータ:
context - 期間国際化モデルコンテキスト

getExtendedTerminableInternationalModelMap

public ExtendedTerminableInternationalModelMap getExtendedTerminableInternationalModelMap()
拡張期間国際化エンティティに対応する拡張期間国際化モデルのマップを取得します。

戻り値:
拡張期間国際化モデルマップ

getLocale

public Locale getLocale()
期間国際化モデルが保持する言語 Locale を取得します。 このメソッドをオーバーライドすると言語を取得することが出来なくなります。

戻り値:
言語
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableInternationalModelContext (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース TerminableInternationalModelContext

public interface TerminableInternationalModelContext

期間国際化モデルの初期化に必要な設定を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedTerminableInternationalModelMap | getExtendedTerminableInternationalModelMap() 拡張期間国際化モデルマップを取得します。
TerminableInternationalAccessor | getTerminableInternationalAccessor() 期間国際化アクセサを取得します。
void | setExtendedTerminableInternationalModelMap(ExtendedTerminableInternationalModelMap extendedMap) 拡張期間国際化モデルマップを設定します。
void | setTerminableInternationalAccessor(TerminableInternationalAccessor accessor) 期間国際化アクセサを設定します。

メソッドの詳細

setTerminableInternationalAccessor

public void setTerminableInternationalAccessor(TerminableInternationalAccessor accessor)
期間国際化アクセサを設定します。

パラメータ:
accessor - 期間国際化アクセサ

getTerminableInternationalAccessor

public TerminableInternationalAccessor getTerminableInternationalAccessor()
期間国際化アクセサを取得します。

戻り値:
期間国際化アクセサ

setExtendedTerminableInternationalModelMap

public void setExtendedTerminableInternationalModelMap(ExtendedTerminableInternationalModelMap extendedMap)
拡張期間国際化モデルマップを設定します。

パラメータ:
extendedMap - 拡張期間国際化モデルマップ

getExtendedTerminableInternationalModelMap

public ExtendedTerminableInternationalModelMap getExtendedTerminableInternationalModelMap()
拡張期間国際化モデルマップを取得します。

戻り値:
拡張期間国際化モデルマップ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableInternationalModelMap (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース TerminableInternationalModelMap

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
GenericTerminableInternationalModelMap
public interface TerminableInternationalModelMap
extends Serializable

期間国際化モデルのマッピング情報を持ちます。 システムで定義された言語に対応する情報のみを持ちます。

導入されたバージョン:
5.0

メソッドの概要
TerminableInternationalModel | createTerminableInternationalModel(Locale locale) 期間国際化モデルを生成します。
boolean | exists(Locale locale) 指定された言語に該当する期間国際化モデルが存在するかどうか判定します。
TerminableInternationalModel | findTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
Locale[] | getLocales() マッピングされている期間国際化モデル TerminableInternationalModel の言語 Locale の一覧を取得します。
void | remove(Locale locale) 指定された言語に該当するデータを削除します。

メソッドの詳細

createTerminableInternationalModel

public TerminableInternationalModel createTerminableInternationalModel(Locale locale)
                                                                throws AccessorException
期間国際化モデルを生成します。 引数で指定された言語に該当する既存の情報は新しい情報で上書きされます。 システムで取り扱う言語のみが対象となります。

パラメータ:
locale - 言語
戻り値:
期間国際化モデル
例外:
AccessorException - システムで使用することができない言語が指定された場合

exists

public boolean exists(Locale locale)
指定された言語に該当する期間国際化モデルが存在するかどうか判定します。

パラメータ:
locale - 言語
戻り値:
対象となる期間国際化モデルが存在する場合 true、それ以外は false

findTerminableInternationalModel

public TerminableInternationalModel findTerminableInternationalModel(Locale locale)
                                                              throws IllegalLocaleException
指定された言語に該当する期間国際化モデルを取得します。 引数 locale で指定された言語に該当する TerminableInternationalModelを取得します。該当するものが存在しない場合、 null が返されます。

パラメータ:
locale - 対象となる言語
戻り値:
対象となる期間国際化モデル（存在しない場合は null）
例外:
IllegalLocaleException - 言語に関する例外が発生した場合

getLocales

public Locale[] getLocales()
マッピングされている期間国際化モデル TerminableInternationalModel の言語 Locale の一覧を取得します。

戻り値:
言語の一覧

remove

public void remove(Locale locale)
            throws AccessorException
指定された言語に該当するデータを削除します。

パラメータ:
locale - 削除対象の言語
例外:
AccessorException - アクセサで何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース TerminableModel

すべてのスーパーインタフェース:
Serializable
既知のサブインタフェースの一覧:
CompanyCategoryTerminableModel, CompanyPostTerminableModel, DealDetailTerminableModel, DealTerminableModel, DepartmentAttachTerminableModel, DepartmentMainTerminableModel, DepartmentTerminableModel, ItemTerminableModel, PublicGroupAttachTerminableModel, PublicGroupCategoryTerminableModel, PublicGroupTerminableModel, UserTerminableModel
既知の実装クラスの一覧:
GenericTerminableModel
public interface TerminableModel
extends Serializable

期間化モデルの情報です。 期間化エンティティの1データが期間化モデルの1インスタンスに対応します。

導入されたバージョン:
5.0

メソッドの概要
ExtendedTerminableModelMap | getExtendedTerminableModelMap() 拡張期間化エンティティに対応する拡張期間化モデルのマップを取得します。
Term | getTerm() 期間化モデルが保持する期間 Term を取得します。
TerminableInternationalModelMap | getTerminableInternationalModelMap() 期間国際化モデルを取得します。
void | init(TerminableModelContext context) 期間化モデルを初期化します。

メソッドの詳細

init

public void init(TerminableModelContext context)
期間化モデルを初期化します。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

パラメータ:
context - 期間化モデルコンテキスト

getTerminableInternationalModelMap

public TerminableInternationalModelMap getTerminableInternationalModelMap()
期間国際化モデルを取得します。 この期間モデルに関連する期間国際化モデルの集合を取得します。

戻り値:
期間国際化モデルの集合

getExtendedTerminableModelMap

public ExtendedTerminableModelMap getExtendedTerminableModelMap()
拡張期間化エンティティに対応する拡張期間化モデルのマップを取得します。

戻り値:
拡張期間化モデルマップ

getTerm

public Term getTerm()
期間化モデルが保持する期間 Term を取得します。 このメソッドをオーバーライドすると期間を取得できなくなります。

戻り値:
期間
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableModelContext (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース TerminableModelContext

public interface TerminableModelContext

期間化化モデルの初期化に必要な設定を持ちます。

導入されたバージョン:
5.0

メソッドの概要
Locale | getDefaultLocale() デフォルト言語を取得します。
ExtendedTerminableModelMap | getExtendedTerminableModelMap() 拡張期間化モデルマップを取得します。
TerminableAccessor | getTerminableAccessor() 期間化アクセサを取得します。
TerminableInternationalModelMap | getTerminableInternationalModelMap() 期間国際化モデルマップを取得します。
void | setDefaultLocale(Locale locale) デフォルト言語を設定します。
void | setExtendedTerminableModelMap(ExtendedTerminableModelMap extendedMap) 拡張期間化モデルマップを設定します。
void | setTerminableAccessor(TerminableAccessor accessor) 期間化アクセサを設定します。
void | setTerminableInternationalModelMap(TerminableInternationalModelMap terminableInternationalMap) 期間国際化モデルマップを設定します。

メソッドの詳細

setTerminableAccessor

public void setTerminableAccessor(TerminableAccessor accessor)
期間化アクセサを設定します。

パラメータ:
accessor - 期間化アクセサ

getTerminableAccessor

public TerminableAccessor getTerminableAccessor()
期間化アクセサを取得します。

戻り値:
期間化アクセサ

setDefaultLocale

public void setDefaultLocale(Locale locale)
デフォルト言語を設定します。

パラメータ:
locale - 言語

getDefaultLocale

public Locale getDefaultLocale()
デフォルト言語を取得します。

戻り値:
言語

setTerminableInternationalModelMap

public void setTerminableInternationalModelMap(TerminableInternationalModelMap terminableInternationalMap)
期間国際化モデルマップを設定します。

パラメータ:
terminableInternationalMap - 期間国際化モデルマップ

getTerminableInternationalModelMap

public TerminableInternationalModelMap getTerminableInternationalModelMap()
期間国際化モデルマップを取得します。

戻り値:
期間国際化モデルマップ

setExtendedTerminableModelMap

public void setExtendedTerminableModelMap(ExtendedTerminableModelMap extendedMap)
拡張期間化モデルマップを設定します。

パラメータ:
extendedMap - 拡張期間化モデルマップ

getExtendedTerminableModelMap

public ExtendedTerminableModelMap getExtendedTerminableModelMap()
拡張期間化モデルマップを取得します。

戻り値:
拡張期間化モデルマップ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableModelMap (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース TerminableModelMap

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
GenericTerminableModelMap
public interface TerminableModelMap
extends Serializable

期間化モデルのマッピング情報を持ちます。 期間が変更された場合などは自動的に期間情報が重複しないように調整されます。

導入されたバージョン:
5.0

メソッドの概要
TerminableModel | createTerminableModel(Term term) 指定した期間を満たす期間化モデルを生成します。
boolean | exists(Date date) 指定された日付を含む期間化モデルが存在するかどうか判定します。
TerminableModel | findTerminableModel(Date date) 指定された日付に該当する期間化モデルを取得します。
Term[] | getTerms() マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。
void | remove(Term term) 指定された期間に該当するデータを削除します。

メソッドの詳細

createTerminableModel

public TerminableModel createTerminableModel(Term term)
                                      throws AccessorException
指定した期間を満たす期間化モデルを生成します。 指定した期間に期間化アクセサを生成します。 生成した期間化アクセサによって重複する期間が発生する場合、例外を返す

パラメータ:
term - 期間
戻り値:
期間化モデル
例外:
AccessorException - アクセサで何らかの例外が発生した場合

exists

public boolean exists(Date date)
指定された日付を含む期間化モデルが存在するかどうか判定します。

パラメータ:
date - 日付
戻り値:
指定された日付を含む期間化モデルが存在する場合は true、それ以外は false

findTerminableModel

public TerminableModel findTerminableModel(Date date)
                                    throws IllegalTermException
指定された日付に該当する期間化モデルを取得します。 引数 date で指定された日付を期間内に含む TerminableModel を取得します。該当するものが存在しない場合、例外を返します

パラメータ:
date - 対象となる日付
戻り値:
対象となる期間化モデル
例外:
IllegalTermException - 指定された日時に該当するモデルが存在しない場合

remove

public void remove(Term term)
            throws AccessorException
指定された期間に該当するデータを削除します。 削除対象の期間に該当するデータがなくなるよう、既存のデータの有効開始日時や有効終了日時は調整されます。

パラメータ:
term - 削除対象の期間
例外:
AccessorException - アクセサで何らかの例外が発生した場合

getTerms

public Term[] getTerms()
マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。 取得される期間は時系列でソートされています。

戻り値:
期間の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.common.structure.Term の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.structure.Term の使用

Term を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.attach | 組織所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.category | 会社分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.department | 組織情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.main | 主所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.post | 役職情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item.item | 商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach | パブリックグループ所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category | パブリックグループ分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set | パブリックグループセット情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.foundation.datastore.common.structure | 期間情報などを扱うクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での Term の使用

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract void | CompanyManager.copyVersion(String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンの内容をコピーします。
void | CompanyChangedListener.versionCopied(String groupId, String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。

jp.co.intra_mart.foundation.datastore.application.domain.company.attach での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.company.attach のメソッド
 Term[] DepartmentAttach.getTerms()
この組織所属で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.attach のメソッド
DepartmentAttachTerminable | DepartmentAttach.getDepartmentAttachTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | DepartmentAttach.putDepartmentAttachTerminable(Term term, DepartmentAttachTerminable data) 指定された期間に対する期間化情報を設定します。
void | DepartmentAttach.removeDepartmentAttachTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.company.category での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.company.category のメソッド
 Term[] CompanyCategory.getTerms()
この会社組織分類で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.category のメソッド
CompanyCategoryTerminable | CompanyCategory.getCompanyCategoryTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | CompanyCategory.putCompanyCategoryTerminable(Term term, CompanyCategoryTerminable data) 指定された期間に対する期間化情報を設定します。
void | CompanyCategory.removeCompanyCategoryTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.company.company での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.company.company のメソッド
 Term[] Company.getTerms()
この会社で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.company のメソッド
CompanyTerminable | Company.getCompanyTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | Company.putCompanyTerminable(Term term, CompanyTerminable data) 指定された期間に対する期間化情報を設定します。
void | Company.removeCompanyTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.company.department での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.company.department のメソッド
 Term[] Department.getTerms()
この組織で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.department のメソッド
DepartmentTerminable | Department.getDepartmentTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | Department.putDepartmentTerminable(Term term, DepartmentTerminable data) 指定された期間に対する期間化情報を設定します。
void | Department.removeDepartmentTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.company.main での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.company.main のメソッド
 Term[] DepartmentMain.getTerms()
この主所属で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.main のメソッド
DepartmentMainTerminable | DepartmentMain.getDepartmentMainTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | DepartmentMain.putDepartmentMainTerminable(Term term, DepartmentMainTerminable data) 指定された期間に対する期間化情報を設定します。
void | DepartmentMain.removeDepartmentMainTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.company.post での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.company.post のメソッド
 Term[] CompanyPost.getTerms()
この役職で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.post のメソッド
CompanyPostTerminable | CompanyPost.getCompanyPostTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | CompanyPost.putCompanyPostTerminable(Term term, CompanyPostTerminable data) 指定された期間に対する期間化情報を設定します。
void | CompanyPost.removeCompanyPostTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.deal.deal での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.deal.deal のメソッド
 Term[] Deal.getTerms()
この取扱で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.deal.deal のメソッド
DealTerminable | Deal.getDealTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | Deal.putDealTerminable(Term term, DealTerminable data) 指定された期間に対する期間化情報を設定します。
void | Deal.removeDealTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.item.item での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.item.item のメソッド
 Term[] Item.getTerms()
この商品で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.item.item のメソッド
ItemTerminable | Item.getItemTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | Item.putItemTerminable(Term term, ItemTerminable data) 指定された期間に対する期間化情報を設定します。
void | Item.removeItemTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での Term の使用

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract void | PublicGroupManager.copyVersion(String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーします。
void | PublicGroupChangedListener.versionCopied(String groupId, String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach のメソッド
 Term[] PublicGroupAttach.getTerms()
このパブリックグループ所属で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach のメソッド
PublicGroupAttachTerminable | PublicGroupAttach.getPublicGroupAttachTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | PublicGroupAttach.putPublicGroupAttachTerminable(Term term, PublicGroupAttachTerminable data) 指定された期間に対する期間化情報を設定します。
void | PublicGroupAttach.removePublicGroupAttachTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.category での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.category のメソッド
 Term[] PublicGroupCategory.getTerms()
このパブリックグループ分類で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.category のメソッド
PublicGroupCategoryTerminable | PublicGroupCategory.getPublicGroupCategoryTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | PublicGroupCategory.putPublicGroupCategoryTerminable(Term term, PublicGroupCategoryTerminable data) 指定された期間に対する期間化情報を設定します。
void | PublicGroupCategory.removePublicGroupCategoryTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のメソッド
 Term[] PublicGroup.getTerms()
このパブリックグループで管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のメソッド
PublicGroupTerminable | PublicGroup.getPublicGroupTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | PublicGroup.putPublicGroupTerminable(Term term, PublicGroupTerminable data) 指定された期間に対する期間化情報を設定します。
void | PublicGroup.removePublicGroupTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のメソッド
 Term[] PublicGroupSet.getTerms()
このパブリックグループセットで管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のメソッド
PublicGroupSetTerminable | PublicGroupSet.getPublicGroupSetTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | PublicGroupSet.putPublicGroupSetTerminable(Term term, PublicGroupSetTerminable data) 指定された期間に対する期間化情報を設定します。
void | PublicGroupSet.removePublicGroupSetTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.user での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
 Term[] User.getTerms()
このユーザで管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
UserTerminable | User.getUserTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | User.putUserTerminable(Term term, UserTerminable data) 指定された期間に対する期間化情報を設定します。
void | User.removeUserTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.common.accessor での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
Term[] | TerminableAccessorMap.getTerms() 現在管理している期間の一覧を取得します。
Term | TerminableAccessor.getTerm() 期間を取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
TerminableAccessor | TerminableAccessorMap.createTerminableAccessor(Term term) 指定した期間に期間化アクセサを生成します。
Map | TerminableAccessorMap.remove(Term term) 指定された期間に該当するデータを削除します。

jp.co.intra_mart.foundation.datastore.common.model での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
Term[] | TerminableModelMap.getTerms() マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。
Term | TerminableModel.getTerm() 期間化モデルが保持する期間 Term を取得します。
Term[] | GenericTerminableModelMap.getTerms() マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。
Term | GenericTerminableModel.getTerm() 期間化モデルが保持する期間 Term を取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableModel | TerminableModelMap.createTerminableModel(Term term) 指定した期間を満たす期間化モデルを生成します。
void | TerminableModelMap.remove(Term term) 指定された期間に該当するデータを削除します。
TerminableModel | GenericTerminableModelMap.createTerminableModel(Term term) 指定した期間を満たす期間化モデルを生成します。
void | GenericTerminableModelMap.remove(Term term) 指定された期間に該当するデータを削除します。
TerminableModel | GenericTerminableModelMap.newTerminableModel(Term term) 初期化されていない期間化モデルのインスタンスを取得します。

jp.co.intra_mart.foundation.datastore.common.structure での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.common.structure のメソッド
static Term[] | TermManager.subtract(Term[] term1, Term[] term2) 期間配列 term1 から 期間配列 term2 を差し引いた期間を返します。
static Term[] | TermManager.getOverlap(Term[] term1, Term[] term2) 2つの期間配列 term1 と term2 で重なっている期間を返します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.structure のメソッド
static void | TermManager.validateTerms(Term[] terms) 指定された期間配列が有効かどうかを調べます。
static Term[] | TermManager.subtract(Term[] term1, Term[] term2) 期間配列 term1 から 期間配列 term2 を差し引いた期間を返します。
static Term[] | TermManager.getOverlap(Term[] term1, Term[] term2) 2つの期間配列 term1 と term2 で重なっている期間を返します。

jp.co.intra_mart.foundation.security.access での Term の使用

Term 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | PublicGroupChangedControllerListener.versionCopied(String groupId, String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.versionCopied(String groupId, String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での Term の使用

Term 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | PublicGroupChangedMenuListener.versionCopied(String groupId, String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.versionCopied(String groupId, String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.structure.TermManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.structure.TermManager の使用

jp.co.intra_mart.foundation.datastore.common.structure.TermManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.common.structure (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.common.structure
クラス
Term
TermManager


jp.co.intra_mart.foundation.datastore.common.structure (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.common.structure

期間情報などを扱うクラスを提供します。

参照:
説明

クラスの概要
Term | 有効期間を表します。
TermManager | 期間 Term を取り扱うマネージャクラスです。

パッケージ jp.co.intra_mart.foundation.datastore.common.structure の説明

期間情報などを扱うクラスを提供します。


jp.co.intra_mart.foundation.datastore.common.structure クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.common.structure の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.common.structure.Term (implements java.lang.Comparable, java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.common.structure.TermManager


パッケージ jp.co.intra_mart.foundation.datastore.common.structure の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.common.structure の使用

jp.co.intra_mart.foundation.datastore.common.structure を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.attach | 組織所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.category | 会社分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.department | 組織情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.main | 主所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.post | 役職情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item.item | 商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach | パブリックグループ所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category | パブリックグループ分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set | パブリックグループセット情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.foundation.datastore.common.structure | 期間情報などを扱うクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.company.attach により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.company.category により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.company.company により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.company.department により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.company.main により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.company.post により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.deal.deal により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.item.item により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.category により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.user により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.common.accessor により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.common.model により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.common.structure により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Term (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.structure
クラス Term

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.structure.Term
すべての実装インタフェース:
Comparable, Serializable
public class Term
extends Object
implements Comparable, Serializable

有効期間を表します。 有効期間は開始時間と終了時間から構成されます。次の式を満たす範囲が有効期間として認められます。

開始時間 ≤ 有効期間 < 終了時間

また、開始時間と終了時間は常に次の関係である必要があります。

開始時間 < 終了時間

設定された開始時間および終了時間の時刻は、00:00:00 に切り捨てられます。
ただし、終了時刻に有効最大日時 (9999/12/31|23:59:59) が設定された場合は切り捨ては行いません。

なお、システムで有効な最小日時は以下のAPIで取得することができます。
  • getMinDate()
  • DateUtil.getMinDate()
システムで有効な最大日時は以下のAPIで取得することができます。
  • getMaxDate()
  • DateUtil.getMaxDate()

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
Term()
開始時間、終了時間とも指定されていない有効期間を生成します。
Term(Date activation)
開始時間のみが指定された有効期間を生成します。
Term(Date activation, Date expiration)
開始時間と終了時間がともに指定された有効期間を生成します。
メソッドの概要
int | compareTo(Object o) この期間と指定された期間を比較します。
boolean | containsDate(Date date) 指定された日時が期間内に入っているかどうかを指定します。
boolean | equals(Object obj) この有効期間と他の有効期間が等しいかどうかを示します。
Date | getActivationDate() 開始時間を取得します。
Date | getExpirationDate() 終了時間を取得します。
static Date | getMaxDate() システムで設定できる期間の最大日時を取得します。
static Date | getMinDate() システムで設定できる期間の最小日時を取得します。
int | hashCode() 有効期間のハッシュコード値を返します。
String | toString() オブジェクトの文字列表現を返します。
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Term

public Term()
開始時間、終了時間とも指定されていない有効期間を生成します。 このコンストラクタで指定された有効期間は常に有効であることを意味します。

Term

public Term(Date activation)
開始時間のみが指定された有効期間を生成します。 終了時間が定義されていないため、終了日時には期間の最大日付が設定されます

パラメータ:
activation - 有効開始時間
例外:
IllegalArgumentException - 指定された開始時間が期間の最小日時、最大日時に含まれる日付でないとき発生する
NullPointerException - 有効開始時間が null

Term

public Term(Date activation,
            Date expiration)
     throws IllegalArgumentException
開始時間と終了時間がともに指定された有効期間を生成します。 開始時間と終了時間をともに設定する場合、以下の式を満たす必要があります。

開始時間 ≤ 終了時間

パラメータ:
activation - 有効期間の開始時間
expiration - 有効期間の終了時間
例外:
IllegalArgumentException - 開始時間が終了時間よりも後
NullPointerException - 有効開始時間または有効終了時間が null
メソッドの詳細

getActivationDate

public Date getActivationDate()
開始時間を取得します。

戻り値:
開始時間

getExpirationDate

public Date getExpirationDate()
終了時間を取得します。

戻り値:
終了時間

getMinDate

public static Date getMinDate()
システムで設定できる期間の最小日時を取得します。

戻り値:
期間の最小日時

getMaxDate

public static Date getMaxDate()
システムで設定できる期間の最大日時を取得します。

戻り値:
期間の最大日時

containsDate

public boolean containsDate(Date date)
                     throws NullPointerException,
                            IllegalArgumentException
指定された日時が期間内に入っているかどうかを指定します。

パラメータ:
date - 日時
戻り値:
指定された日時が期間内に入っている場合は true 、そうでなければ false
例外:
NullPointerException - 指定された日付が null
IllegalArgumentException - 不正な日付が設定された場合

compareTo

public int compareTo(Object o)
              throws ClassCastException,
                     IllegalArgumentException
この期間と指定された期間を比較します。 比較する期間どうしは完全に一致するか、少しも重なっていないかのいずれかである必要があります。期間の一部のみが重なっていたり、一方が他方の期間を包含している場合は例外が発生します。

定義:
インタフェース Comparable 内の compareTo
パラメータ:
o - 比較対照の期間（ Term）
戻り値:
この期間が引数で指定された期間より過去である場合は負の整数、等しい場合はゼロ、この期間が引数で指定された期間より未来である場合は正の整数
例外:
ClassCastException - 指定された期間が Termではない
IllegalArgumentException - 指定された期間の一部が重なっている、または一方が他方を包含している

equals

public boolean equals(Object obj)
この有効期間と他の有効期間が等しいかどうかを示します。 開始時間と終了時間がそれぞれの有効期間において完全に一致している場合、有効期間が等しいとみなされます。

パラメータ:
obj - 比較対象の有効期間
戻り値:
obj 引数に指定された有効期間とこの有効期間が等しい場合は true 、そうでない場合は false

hashCode

public int hashCode()
有効期間のハッシュコード値を返します。

戻り値:
有効期間のハッシュコード値

toString

public String toString()
オブジェクトの文字列表現を返します。
有効開始時間と有効終了時間をそれぞれ DateUtil.dateToString(Date) で変換した String を、半角ハイフン(-)で連結した文字列を返します。 つまり、このメソッドは次の値と等しい文字列を返します。

DateUtil.dateToString(getActivationDate()) + " - " + DateUtil.dateToString(getExpirationDate())

戻り値:
このオブジェクトの文字列表現
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


TermManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.structure
クラス TermManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.structure.TermManager
public class TermManager
extends Object

期間 Term を取り扱うマネージャクラスです。

導入されたバージョン:
5.0

メソッドの概要
static Date | getMaxDate() システムで設定できる期間の最大日時を取得します。
static Date | getMinDate() システムで設定できる期間の最小日時を取得します。
static Term[] | getOverlap(Term[] term1, Term[] term2) 2つの期間配列 term1 と term2 で重なっている期間を返します。
static Term[] | subtract(Term[] term1, Term[] term2) 期間配列 term1 から 期間配列 term2 を差し引いた期間を返します。
static void | validateTerm(Date activation, Date expiration) 指定された2つの日時が有効な期間を構成するかどうか調べます。
static void | validateTerms(Term[] terms) 指定された期間配列が有効かどうかを調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

validateTerm

public static void validateTerm(Date activation,
                                Date expiration)
                         throws TermManagerException
指定された2つの日時が有効な期間を構成するかどうか調べます。
指定された日時が有効な期間を構成しない場合は TermManagerException 例外をスローします。

パラメータ:
activation - 有効開始日時
expiration - 有効終了日時
例外:
TermManagerException - 指定された日時が有効な期間を構成しない場合

validateTerms

public static void validateTerms(Term[] terms)
                          throws TermManagerException
指定された期間配列が有効かどうかを調べます。
指定された期間配列が有効ではない場合はTermManagerException 例外をスローします。
期間配列は以下の場合に有効でないと判定されます。
  • 期間配列にnullの要素が含まれている場合
  • 期間が互いに重なる要素が含まれている場合

パラメータ:
terms - 期間の配列
例外:
TermManagerException - 指定された期間配列が有効でない場合

getMinDate

public static Date getMinDate()
システムで設定できる期間の最小日時を取得します。 取得される値は Term.getMinDate() で取得される値と同じです。

戻り値:
期間の最小日時

getMaxDate

public static Date getMaxDate()
システムで設定できる期間の最大日時を取得します。 取得される値は Term.getMaxDate() で取得される値と同じです。

戻り値:
期間の最大日時

subtract

public static Term[] subtract(Term[] term1,
                              Term[] term2)
                       throws TermManagerException
期間配列 term1 から 期間配列 term2 を差し引いた期間を返します。
差し引かれる期間が存在しない場合は空の配列を返します。
期間配列 term1 または term2 が null の場合も、空の配列を返します。

パラメータ:
term1 - 期間
term2 - 期間
戻り値:
term1 と term2 の差分となる期間
例外:
TermManagerException - 指定された期間配列内に期間に重複が存在する場合

getOverlap

public static Term[] getOverlap(Term[] term1,
                                Term[] term2)
                         throws TermManagerException
2つの期間配列 term1 と term2 で重なっている期間を返します。
期間に重なりが存在しない場合は空の配列を返します。
期間配列 term1 または term2 が null の場合も、空の配列を返します。

パラメータ:
term1 - 期間
term2 - 期間
戻り値:
互いに重なっている期間
例外:
TermManagerException - 指定された期間配列内に期間に重複が存在する場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException の使用

AccessorClosedException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor 情報を扱うためのアクセサを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での AccessorClosedException の使用

AccessorClosedException をスローする jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
TerminableInternationalAccessor | TerminableInternationalAccessorMap.createTerminableInternationalAccessor(Locale locale) 期間国際化アクセサを生成します。
void | TerminableInternationalAccessorMap.remove(Locale locale) 指定された言語に該当するデータを削除します。
void | TerminableInternationalAccessor.setProperty(String prop, Object value) プロパティを設定します。
TerminableAccessor | TerminableAccessorMap.createTerminableAccessor(Term term) 指定した期間に期間化アクセサを生成します。
Map | TerminableAccessorMap.remove(Term term) 指定された期間に該当するデータを削除します。
void | TerminableAccessor.setProperty(String prop, Object value) プロパティを設定します。
InternationalAccessor | InternationalAccessorMap.createInternationalAccessor(Locale locale) 国際化アクセサを生成します。
void | InternationalAccessorMap.remove(Locale locale) 指定された言語に該当するデータを削除します。
void | InternationalAccessor.setProperty(String prop, Object value) プロパティを設定します。
ExtendedTerminableInternationalAccessor | ExtendedTerminableInternationalAccessorMap.createExtendedTerminableInternationalAccessor(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を生成します。
void | ExtendedTerminableInternationalAccessorMap.remove(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を削除します。
void | ExtendedTerminableInternationalAccessor.setProperty(String prop, Object value) プロパティを設定します。
ExtendedTerminableAccessor | ExtendedTerminableAccessorMap.createExtendedTerminableAccessor(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を生成します。
void | ExtendedTerminableAccessorMap.remove(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を削除します。
void | ExtendedTerminableAccessor.setProperty(String prop, Object value) プロパティを設定します。
ExtendedInternationalAccessor | ExtendedInternationalAccessorMap.createExtendedInternationalAccessor(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を生成します。
void | ExtendedInternationalAccessorMap.remove(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を削除します。
void | ExtendedInternationalAccessor.setProperty(String prop, Object value) プロパティを設定します。
ExtendedBaseAccessor | ExtendedBaseAccessorMap.createExtendedBaseAccessor(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を生成します。
void | ExtendedBaseAccessorMap.remove(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を削除します。
void | ExtendedBaseAccessor.setProperty(String prop, Object value) プロパティを設定します。
void | BaseAccessor.setProperty(String prop, Object value) プロパティを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.AccessorException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.AccessorException の使用

AccessorException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category | 会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company | 会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion | 組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version | 会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.deal | 取扱情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.department | 取扱組織権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.detail | 取扱詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group | 取扱パブリックグループ権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.role | 取扱ロール権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach | 商品分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.category | 商品カテゴリ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.type | 商品カテゴリ種別情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail | 商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.template | 商品テンプレート情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.attribute | 商品属性情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue | 商品カタログ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.item | 商品情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach | プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group | プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach | パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category | パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion | パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set | パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version | パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.unit | 単位情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。
jp.co.intra_mart.system.security.datastore.inf |

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.category.category_class のメソッド
String | CateogryClassInternationalModel.getName() 分類区分名を取得します。
void | CateogryClassInternationalModel.setName(String name) 分類区分名を設定します。
String | CateogryClassBaseModel.getCategoryClassCode() 分類区分コードを取得します。
String | CateogryClassBaseModel.getNotes() 備考を取得します。
void | CateogryClassBaseModel.setNotes(String notes) 備考を設定します。
String | CateogryClassBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | CateogryClassBaseModel.getRecordDate() 最終更新日を取得します。
String | CateogryClassBaseModel.getName() 分類区分名を取得します。
String | CateogryClassBaseModel.getName(Locale locale) 分類区分名を取得します。
void | CateogryClassBaseModel.setName(String name) 分類区分名を設定します。
void | CateogryClassBaseModel.setName(String name, Locale locale) 分類区分名を設定します。

jp.co.intra_mart.foundation.datastore.application.model.category.detail での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.category.detail のメソッド
String | CategoryDetailInternationalModel.getName() 分類名を取得します。
void | CategoryDetailInternationalModel.setName(String name) 分類名を設定します。
String | CategoryDetailBaseModel.getCategoryClassCode() 分類区分コードを取得します。
String | CategoryDetailBaseModel.getCategoryCode() 分類コードを取得します。
String | CategoryDetailBaseModel.getNotes() 備考を取得します。
void | CategoryDetailBaseModel.setNotes(String notes) 備考を設定します。
String | CategoryDetailBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | CategoryDetailBaseModel.getRecordDate() 最終更新日を取得します。
String | CategoryDetailBaseModel.getName() 分類名を取得します。
String | CategoryDetailBaseModel.getName(Locale locale) 分類名を取得します。
void | CategoryDetailBaseModel.setName(String name) 分類名を設定します。
void | CategoryDetailBaseModel.setName(String name, Locale locale) 分類名を設定します。

jp.co.intra_mart.foundation.datastore.application.model.company.attach での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.attach のメソッド
String | DepartmentAttachTerminableModel.getPostCode() 役職CDを取得します。
void | DepartmentAttachTerminableModel.setPostCode(String postCode) 役職CDを設定します。
String | DepartmentAttachBaseModel.getUserCode() ユーザコードを取得します。
String | DepartmentAttachBaseModel.getCompanyCode() 会社コードを取得します。
String | DepartmentAttachBaseModel.getDepartmentCode() 組織コードを取得します。
int | DepartmentAttachBaseModel.getSortKey() ソートキーを取得します。
void | DepartmentAttachBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | DepartmentAttachBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | DepartmentAttachBaseModel.getRecordDate() 最終更新日を取得します。
String | DepartmentAttachBaseModel.getPostCode() 役職CDを取得します。
String | DepartmentAttachBaseModel.getPostCode(Date date) 役職CDを取得します。
void | DepartmentAttachBaseModel.setPostCode(String postCode) 役職CDを設定します。
void | DepartmentAttachBaseModel.setPostCode(String postCode, Date date) 役職CDを設定します。

jp.co.intra_mart.foundation.datastore.application.model.company.category での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.category のメソッド
String | CompanyCategoryBaseModel.getCompanyCode() 会社コードを取得します。
String | CompanyCategoryBaseModel.getDepartmentCode() 組織コードを取得します。
String | CompanyCategoryBaseModel.getCategoryClassCode() 分類区分コードを取得します。
String | CompanyCategoryBaseModel.getCategoryCode() 分類コードを取得します。
String | CompanyCategoryBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | CompanyCategoryBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.company.company での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.company のメソッド
String | CompanyBaseModel.getCompanyCode() 会社コードを取得します。
String | CompanyBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | CompanyBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.company.department での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.department のメソッド
String | DepartmentTerminableModel.getTelephoneNumber() 電話番号を取得します。
void | DepartmentTerminableModel.setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
String | DepartmentTerminableModel.getFaxNumber() FAX番号を取得します。
void | DepartmentTerminableModel.setFaxNumber(String faxNumber) FAX番号を設定します。
String | DepartmentTerminableModel.getExtensionNumber() 内線番号を取得します。
void | DepartmentTerminableModel.setExtensionNumber(String extensionNumber) 内線番号を設定します。
String | DepartmentTerminableModel.getExtensionFaxNumber() 内線FAX番号を取得します。
void | DepartmentTerminableModel.setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
String | DepartmentTerminableModel.getCountryCode() 国コードを取得します。
void | DepartmentTerminableModel.setCountryCode(String countryCode) 国コードを設定します。
String | DepartmentTerminableModel.getZipCode() 郵便番号を取得します。
void | DepartmentTerminableModel.setZipCode(String zipCode) 郵便番号を設定します。
String | DepartmentTerminableModel.getEmailAddress1() メールアドレス1を取得します。
void | DepartmentTerminableModel.setEmailAddress1(String emailAddress1) メールアドレス1を設定します。
String | DepartmentTerminableModel.getEmailAddress2() メールアドレス2を取得します。
void | DepartmentTerminableModel.setEmailAddress2(String emailAddress2) メールアドレス2を設定します。
String | DepartmentTerminableModel.getUrl() URLを取得します。
void | DepartmentTerminableModel.setUrl(String url) URLを設定します。
String | DepartmentTerminableModel.getName() 組織名を取得します。
String | DepartmentTerminableModel.getName(Locale locale) 組織名を取得します。
void | DepartmentTerminableModel.setName(String name) 組織名を設定します。
void | DepartmentTerminableModel.setName(String name, Locale locale) 組織名を設定します。
String | DepartmentTerminableModel.getNameSyllabary() 組織名カナを取得します。
String | DepartmentTerminableModel.getNameSyllabary(Locale locale) 組織名カナを取得します。
void | DepartmentTerminableModel.setNameSyllabary(String nameSyllabary) 組織名カナを設定します。
void | DepartmentTerminableModel.setNameSyllabary(String nameSyllabary, Locale locale) 組織名カナを設定します。
String | DepartmentTerminableModel.getNameEnglish() 組織名英字を取得します。
String | DepartmentTerminableModel.getNameEnglish(Locale locale) 組織名英字を取得します。
void | DepartmentTerminableModel.setNameEnglish(String nameEnglish) 組織名英字を設定します。
void | DepartmentTerminableModel.setNameEnglish(String nameEnglish, Locale locale) 組織名英字を設定します。
String | DepartmentTerminableModel.getAddress1() 住所1を取得します。
String | DepartmentTerminableModel.getAddress1(Locale locale) 住所1を取得します。
void | DepartmentTerminableModel.setAddress1(String address1) 住所1を設定します。
void | DepartmentTerminableModel.setAddress1(String address1, Locale locale) 住所1を設定します。
String | DepartmentTerminableModel.getAddress2() 住所2を取得します。
String | DepartmentTerminableModel.getAddress2(Locale locale) 住所2を取得します。
void | DepartmentTerminableModel.setAddress2(String address2) 住所2を設定します。
void | DepartmentTerminableModel.setAddress2(String address2, Locale locale) 住所2を設定します。
String | DepartmentTerminableInternationalModel.getName() 組織名を取得します。
void | DepartmentTerminableInternationalModel.setName(String name) 組織名を設定します。
String | DepartmentTerminableInternationalModel.getNameSyllabary() 組織名カナを取得します。
void | DepartmentTerminableInternationalModel.setNameSyllabary(String nameSyllabary) 組織名カナを設定します。
String | DepartmentTerminableInternationalModel.getNameEnglish() 組織名英字を取得します。
void | DepartmentTerminableInternationalModel.setNameEnglish(String nameEnglish) 組織名英字を設定します。
String | DepartmentTerminableInternationalModel.getAddress1() 住所1を取得します。
void | DepartmentTerminableInternationalModel.setAddress1(String address1) 住所1を設定します。
String | DepartmentTerminableInternationalModel.getAddress2() 住所2を取得します。
void | DepartmentTerminableInternationalModel.setAddress2(String address2) 住所2を設定します。
String | DepartmentBaseModel.getCompanyCode() 会社コードを取得します。
String | DepartmentBaseModel.getDepartmentCode() 組織コードを取得します。
String | DepartmentBaseModel.getNotes() 備考を取得します。
void | DepartmentBaseModel.setNotes(String notes) 備考を設定します。
int | DepartmentBaseModel.getSortKey() ソートキーを取得します。
void | DepartmentBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | DepartmentBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | DepartmentBaseModel.getRecordDate() 最終更新日を取得します。
String | DepartmentBaseModel.getTelephoneNumber() 電話番号を取得します。
String | DepartmentBaseModel.getTelephoneNumber(Date date) 電話番号を取得します。
void | DepartmentBaseModel.setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | DepartmentBaseModel.setTelephoneNumber(String telephoneNumber, Date date) 電話番号を設定します。
String | DepartmentBaseModel.getFaxNumber() FAX番号を取得します。
String | DepartmentBaseModel.getFaxNumber(Date date) FAX番号を取得します。
void | DepartmentBaseModel.setFaxNumber(String faxNumber) FAX番号を設定します。
void | DepartmentBaseModel.setFaxNumber(String faxNumber, Date date) FAX番号を設定します。
String | DepartmentBaseModel.getExtensionNumber() 内線番号を取得します。
String | DepartmentBaseModel.getExtensionNumber(Date date) 内線番号を取得します。
void | DepartmentBaseModel.setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | DepartmentBaseModel.setExtensionNumber(String extensionNumber, Date date) 内線番号を設定します。
String | DepartmentBaseModel.getExtensionFaxNumber() 内線FAX番号を取得します。
String | DepartmentBaseModel.getExtensionFaxNumber(Date date) 内線FAX番号を取得します。
void | DepartmentBaseModel.setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | DepartmentBaseModel.setExtensionFaxNumber(String extensionFaxNumber, Date date) 内線FAX番号を設定します。
String | DepartmentBaseModel.getCountryCode() 国コードを取得します。
String | DepartmentBaseModel.getCountryCode(Date date) 国コードを取得します。
void | DepartmentBaseModel.setCountryCode(String countryCode) 国コードを設定します。
void | DepartmentBaseModel.setCountryCode(String countryCode, Date date) 国コードを設定します。
String | DepartmentBaseModel.getZipCode() 郵便番号を取得します。
String | DepartmentBaseModel.getZipCode(Date date) 郵便番号を取得します。
void | DepartmentBaseModel.setZipCode(String zipCode) 郵便番号を設定します。
void | DepartmentBaseModel.setZipCode(String zipCode, Date date) 郵便番号を設定します。
String | DepartmentBaseModel.getEmailAddress1() メールアドレス1を取得します。
String | DepartmentBaseModel.getEmailAddress1(Date date) メールアドレス1を取得します。
void | DepartmentBaseModel.setEmailAddress1(String emailAddress1) メールアドレス1を設定します。
void | DepartmentBaseModel.setEmailAddress1(String emailAddress1, Date date) メールアドレス1を設定します。
String | DepartmentBaseModel.getEmailAddress2() メールアドレス2を取得します。
String | DepartmentBaseModel.getEmailAddress2(Date date) メールアドレス2を取得します。
void | DepartmentBaseModel.setEmailAddress2(String emailAddress2) メールアドレス2を設定します。
void | DepartmentBaseModel.setEmailAddress2(String emailAddress2, Date date) メールアドレス2を設定します。
String | DepartmentBaseModel.getUrl() URLを取得します。
String | DepartmentBaseModel.getUrl(Date date) URLを取得します。
void | DepartmentBaseModel.setUrl(String url) URLを設定します。
void | DepartmentBaseModel.setUrl(String url, Date date) URLを設定します。
String | DepartmentBaseModel.getName() 組織名を取得します。
String | DepartmentBaseModel.getName(Date date) 組織名を取得します。
String | DepartmentBaseModel.getName(Locale locale) 組織名を取得します。
String | DepartmentBaseModel.getName(Date date, Locale locale) 組織名を取得します。
void | DepartmentBaseModel.setName(String name) 組織名を設定します。
void | DepartmentBaseModel.setName(String name, Date date) 組織名を設定します。
void | DepartmentBaseModel.setName(String name, Locale locale) 組織名を設定します。
void | DepartmentBaseModel.setName(String name, Date date, Locale locale) 組織名を設定します。
String | DepartmentBaseModel.getNameSyllabary() 組織名カナを取得します。
String | DepartmentBaseModel.getNameSyllabary(Date date) 組織名カナを取得します。
String | DepartmentBaseModel.getNameSyllabary(Locale locale) 組織名カナを取得します。
String | DepartmentBaseModel.getNameSyllabary(Date date, Locale locale) 組織名カナを取得します。
void | DepartmentBaseModel.setNameSyllabary(String nameSyllabary) 組織名カナを設定します。
void | DepartmentBaseModel.setNameSyllabary(String nameSyllabary, Date date) 組織名カナを設定します。
void | DepartmentBaseModel.setNameSyllabary(String nameSyllabary, Locale locale) 組織名カナを設定します。
void | DepartmentBaseModel.setNameSyllabary(String nameSyllabary, Date date, Locale locale) 組織名カナを設定します。
String | DepartmentBaseModel.getNameEnglish() 組織名英字を取得します。
String | DepartmentBaseModel.getNameEnglish(Date date) 組織名英字を取得します。
String | DepartmentBaseModel.getNameEnglish(Locale locale) 組織名英字を取得します。
String | DepartmentBaseModel.getNameEnglish(Date date, Locale locale) 組織名英字を取得します。
void | DepartmentBaseModel.setNameEnglish(String nameEnglish) 組織名英字を設定します。
void | DepartmentBaseModel.setNameEnglish(String nameEnglish, Date date) 組織名英字を設定します。
void | DepartmentBaseModel.setNameEnglish(String nameEnglish, Locale locale) 組織名英字を設定します。
void | DepartmentBaseModel.setNameEnglish(String nameEnglish, Date date, Locale locale) 組織名英字を設定します。
String | DepartmentBaseModel.getAddress1() 住所1を取得します。
String | DepartmentBaseModel.getAddress1(Date date) 住所1を取得します。
String | DepartmentBaseModel.getAddress1(Locale locale) 住所1を取得します。
String | DepartmentBaseModel.getAddress1(Date date, Locale locale) 住所1を取得します。
void | DepartmentBaseModel.setAddress1(String address1) 住所1を設定します。
void | DepartmentBaseModel.setAddress1(String address1, Date date) 住所1を設定します。
void | DepartmentBaseModel.setAddress1(String address1, Locale locale) 住所1を設定します。
void | DepartmentBaseModel.setAddress1(String address1, Date date, Locale locale) 住所1を設定します。
String | DepartmentBaseModel.getAddress2() 住所2を取得します。
String | DepartmentBaseModel.getAddress2(Date date) 住所2を取得します。
String | DepartmentBaseModel.getAddress2(Locale locale) 住所2を取得します。
String | DepartmentBaseModel.getAddress2(Date date, Locale locale) 住所2を取得します。
void | DepartmentBaseModel.setAddress2(String address2) 住所2を設定します。
void | DepartmentBaseModel.setAddress2(String address2, Date date) 住所2を設定します。
void | DepartmentBaseModel.setAddress2(String address2, Locale locale) 住所2を設定します。
void | DepartmentBaseModel.setAddress2(String address2, Date date, Locale locale) 住所2を設定します。

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.inclusion のメソッド
String | DepartmentInclusionBaseModel.getCompanyCode() 会社コードを取得します。
String | DepartmentInclusionBaseModel.getVersionCode() バージョンコードを取得します。
String | DepartmentInclusionBaseModel.getParentDepartmentCode() 親組織コードを取得します。
String | DepartmentInclusionBaseModel.getDepartmentCode() 組織コードを取得します。
int | DepartmentInclusionBaseModel.getDepth() 階層レベルを取得します。
void | DepartmentInclusionBaseModel.setDepth(int depth) 階層レベルを設定します。
String | DepartmentInclusionBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | DepartmentInclusionBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.company.main での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.main のメソッド
String | DepartmentMainTerminableModel.getCompanyCode() 会社コードを取得します。
void | DepartmentMainTerminableModel.setCompanyCode(String companyCode) 会社コードを設定します。
String | DepartmentMainTerminableModel.getDepartmentCode() 組織コードを取得します。
void | DepartmentMainTerminableModel.setDepartmentCode(String departmentCode) 組織コードを設定します。
String | DepartmentMainBaseModel.getUserCode() ユーザコードを取得します。
String | DepartmentMainBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | DepartmentMainBaseModel.getRecordDate() 最終更新日を取得します。
String | DepartmentMainBaseModel.getCompanyCode() 会社コードを取得します。
String | DepartmentMainBaseModel.getCompanyCode(Date date) 会社コードを取得します。
void | DepartmentMainBaseModel.setCompanyCode(String companyCode) 会社コードを設定します。
void | DepartmentMainBaseModel.setCompanyCode(String companyCode, Date date) 会社コードを設定します。
String | DepartmentMainBaseModel.getDepartmentCode() 組織コードを取得します。
String | DepartmentMainBaseModel.getDepartmentCode(Date date) 組織コードを取得します。
void | DepartmentMainBaseModel.setDepartmentCode(String departmentCode) 組織コードを設定します。
void | DepartmentMainBaseModel.setDepartmentCode(String departmentCode, Date date) 組織コードを設定します。

jp.co.intra_mart.foundation.datastore.application.model.company.post での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.post のメソッド
String | CompanyPostTerminableModel.getName() 役職名を取得します。
String | CompanyPostTerminableModel.getName(Locale locale) 役職名を取得します。
void | CompanyPostTerminableModel.setName(String name) 役職名を設定します。
void | CompanyPostTerminableModel.setName(String name, Locale locale) 役職名を設定します。
String | CompanyPostTerminableInternationalModel.getName() 役職名を取得します。
void | CompanyPostTerminableInternationalModel.setName(String name) 役職名を設定します。
String | CompanyPostBaseModel.getCompanyCode() 会社コードを取得します。
String | CompanyPostBaseModel.getPostCode() 役職コードを取得します。
String | CompanyPostBaseModel.getNotes() 備考を取得します。
void | CompanyPostBaseModel.setNotes(String notes) 備考を設定します。
int | CompanyPostBaseModel.getSortKey() ソートキーを取得します。
void | CompanyPostBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | CompanyPostBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | CompanyPostBaseModel.getRecordDate() 最終更新日を取得します。
String | CompanyPostBaseModel.getName() 役職名を取得します。
String | CompanyPostBaseModel.getName(Date date) 役職名を取得します。
String | CompanyPostBaseModel.getName(Locale locale) 役職名を取得します。
String | CompanyPostBaseModel.getName(Date date, Locale locale) 役職名を取得します。
void | CompanyPostBaseModel.setName(String name) 役職名を設定します。
void | CompanyPostBaseModel.setName(String name, Date date) 役職名を設定します。
void | CompanyPostBaseModel.setName(String name, Locale locale) 役職名を設定します。
void | CompanyPostBaseModel.setName(String name, Date date, Locale locale) 役職名を設定します。

jp.co.intra_mart.foundation.datastore.application.model.company.version での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.version のメソッド
String | CompanyVersionBaseModel.getCompanyCode() 会社コードを取得します。
String | CompanyVersionBaseModel.getVersionCode() バージョンコードを取得します。
Date | CompanyVersionBaseModel.getStartDate() 開始日を取得します。
void | CompanyVersionBaseModel.setStartDate(Date startDate) 開始日を設定します。
Date | CompanyVersionBaseModel.getEndDate() 終了日を取得します。
void | CompanyVersionBaseModel.setEndDate(Date endDate) 終了日を設定します。
String | CompanyVersionBaseModel.getNotes() 備考を取得します。
void | CompanyVersionBaseModel.setNotes(String notes) 備考を設定します。
String | CompanyVersionBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | CompanyVersionBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.deal.deal での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.deal.deal のメソッド
double | DealTerminableModel.getUnitPrice() 単価を取得します。
void | DealTerminableModel.setUnitPrice(double unitPrice) 単価を設定します。
String | DealBaseModel.getCustomerCompanyCode() 取引先会社コードを取得します。
String | DealBaseModel.getCustomerDepartmentCode() 取引先組織コードを取得します。
String | DealBaseModel.getDealCode() 取扱コードを取得します。
String | DealBaseModel.getDealName() 取扱名を取得します。
void | DealBaseModel.setDealName(String dealName) 取扱名を設定します。
int | DealBaseModel.getDealType() 取扱種別を取得します。
void | DealBaseModel.setDealType(int dealType) 取扱種別を設定します。
String | DealBaseModel.getCurrencyCode() 通貨コードを取得します。
void | DealBaseModel.setCurrencyCode(String currencyCode) 通貨コードを設定します。
String | DealBaseModel.getNotes() 備考を取得します。
void | DealBaseModel.setNotes(String notes) 備考を設定します。
String | DealBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | DealBaseModel.getRecordDate() 最終更新日を取得します。
double | DealBaseModel.getUnitPrice() 単価を取得します。
double | DealBaseModel.getUnitPrice(Date date) 単価を取得します。
void | DealBaseModel.setUnitPrice(double unitPrice) 単価を設定します。
void | DealBaseModel.setUnitPrice(double unitPrice, Date date) 単価を設定します。

jp.co.intra_mart.foundation.datastore.application.model.deal.department での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.deal.department のメソッド
String | DealerDepartmentBaseModel.getCustomerCompanyCode() 取引先会社コードを取得します。
String | DealerDepartmentBaseModel.getCustomerDepartmentCode() 取引先組織コードを取得します。
String | DealerDepartmentBaseModel.getDealCode() 取扱コードを取得します。
String | DealerDepartmentBaseModel.getCompanyCode() 会社コードを取得します。
String | DealerDepartmentBaseModel.getDepartmentCode() 組織コードを取得します。
String | DealerDepartmentBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | DealerDepartmentBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.deal.detail での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.deal.detail のメソッド
String | DealDetailTerminableModel.getUnitCode() 単位コードを取得します。
void | DealDetailTerminableModel.setUnitCode(String unitCode) 単位コードを設定します。
int | DealDetailTerminableModel.getAmount() 数量を取得します。
void | DealDetailTerminableModel.setAmount(int amount) 数量を設定します。
double | DealDetailTerminableModel.getUnitPrice() 単価を取得します。
void | DealDetailTerminableModel.setUnitPrice(double unitPrice) 単価を設定します。
String | DealDetailBaseModel.getCustomerCompanyCode() 取引先会社コードを取得します。
String | DealDetailBaseModel.getCustomerDepartmentCode() 取引先組織コードを取得します。
String | DealDetailBaseModel.getDealCode() 取扱コードを取得します。
String | DealDetailBaseModel.getItemCode() 商品コードを取得します。
String | DealDetailBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | DealDetailBaseModel.getRecordDate() 最終更新日を取得します。
String | DealDetailBaseModel.getUnitCode() 単位コードを取得します。
String | DealDetailBaseModel.getUnitCode(Date date) 単位コードを取得します。
void | DealDetailBaseModel.setUnitCode(String unitCode) 単位コードを設定します。
void | DealDetailBaseModel.setUnitCode(String unitCode, Date date) 単位コードを設定します。
int | DealDetailBaseModel.getAmount() 数量を取得します。
int | DealDetailBaseModel.getAmount(Date date) 数量を取得します。
void | DealDetailBaseModel.setAmount(int amount) 数量を設定します。
void | DealDetailBaseModel.setAmount(int amount, Date date) 数量を設定します。
double | DealDetailBaseModel.getUnitPrice() 単価を取得します。
double | DealDetailBaseModel.getUnitPrice(Date date) 単価を取得します。
void | DealDetailBaseModel.setUnitPrice(double unitPrice) 単価を設定します。
void | DealDetailBaseModel.setUnitPrice(double unitPrice, Date date) 単価を設定します。

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.deal.public_group のメソッド
String | DealerPublicGroupBaseModel.getCustomerCompanyCode() 取引先会社コードを取得します。
String | DealerPublicGroupBaseModel.getCustomerDepartmentCode() 取引先組織コードを取得します。
String | DealerPublicGroupBaseModel.getDealCode() 取扱コードを取得します。
String | DealerPublicGroupBaseModel.getPublicGroupSetCode() グループセットコードを取得します。
String | DealerPublicGroupBaseModel.getPublicGroupCode() グループコードを取得します。
String | DealerPublicGroupBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | DealerPublicGroupBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.deal.role での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.deal.role のメソッド
String | DealerRoleBaseModel.getCustomerCompanyCode() 取引先会社コードを取得します。
String | DealerRoleBaseModel.getCustomerDepartmentCode() 取引先組織コードを取得します。
String | DealerRoleBaseModel.getDealCode() 取扱コードを取得します。
String | DealerRoleBaseModel.getRoleId() ロールIDを取得します。
String | DealerRoleBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | DealerRoleBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.item_category.attach のメソッド
String | ItemAttachBaseModel.getItemCategoryTypeCode() 商品カテゴリ種別コードを取得します。
String | ItemAttachBaseModel.getItemCategoryCode() 商品カテゴリコードを取得します。
String | ItemAttachBaseModel.getItemCode() 商品コードを取得します。
String | ItemAttachBaseModel.getRecordUserCd() 最終更新者を取得します。
Date | ItemAttachBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.category での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.item_category.category のメソッド
String | ItemCategoryInternationalModel.getItemCategoryName() 商品カテゴリ名を取得します。
void | ItemCategoryInternationalModel.setItemCategoryName(String itemCategoryName) 商品カテゴリ名を設定します。
String | ItemCategoryBaseModel.getItemCategoryTypeCode() 商品カテゴリ種別コードを取得します。
String | ItemCategoryBaseModel.getItemCategoryCode() 商品カテゴリコードを取得します。
String | ItemCategoryBaseModel.getParentItemCategoryCode() 親商品カテゴリコードを取得します。
void | ItemCategoryBaseModel.setParentItemCategoryCode(String parentItemCategoryCode) 親商品カテゴリコードを設定します。
String | ItemCategoryBaseModel.getNotes() 備考を取得します。
void | ItemCategoryBaseModel.setNotes(String notes) 備考を設定します。
int | ItemCategoryBaseModel.getSortKey() ソートキーを取得します。
void | ItemCategoryBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | ItemCategoryBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | ItemCategoryBaseModel.getRecordDate() 最終更新日を取得します。
String | ItemCategoryBaseModel.getItemCategoryName() 商品カテゴリ名を取得します。
String | ItemCategoryBaseModel.getItemCategoryName(Locale locale) 商品カテゴリ名を取得します。
void | ItemCategoryBaseModel.setItemCategoryName(String itemCategoryName) 商品カテゴリ名を設定します。
void | ItemCategoryBaseModel.setItemCategoryName(String itemCategoryName, Locale locale) 商品カテゴリ名を設定します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.type での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.item_category.type のメソッド
String | ItemCategoryTypeBaseModel.getItemCategoryTypeCode() 商品カテゴリ種別コードを取得します。
String | ItemCategoryTypeBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | ItemCategoryTypeBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.item_template.detail のメソッド
String | ItemTemplateDetailInternationalModel.getTemplateDetailName() テンプレート明細名を取得します。
void | ItemTemplateDetailInternationalModel.setTemplateDetailName(String templateDetailName) テンプレート明細名を設定します。
String | ItemTemplateDetailBaseModel.getTemplateCode() テンプレートコードを取得します。
String | ItemTemplateDetailBaseModel.getTemplateDetailCode() テンプレート明細コードを取得します。
int | ItemTemplateDetailBaseModel.getDataType() データ型を取得します。
void | ItemTemplateDetailBaseModel.setDataType(int dataType) データ型を設定します。
int | ItemTemplateDetailBaseModel.getSortKey() ソートキーを取得します。
void | ItemTemplateDetailBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | ItemTemplateDetailBaseModel.getNotes() 備考を取得します。
void | ItemTemplateDetailBaseModel.setNotes(String notes) 備考を設定します。
String | ItemTemplateDetailBaseModel.getRecordUserCd() 最終更新者を取得します。
Date | ItemTemplateDetailBaseModel.getRecordDate() 最終更新日を取得します。
String | ItemTemplateDetailBaseModel.getTemplateDetailName() テンプレート明細名を取得します。
String | ItemTemplateDetailBaseModel.getTemplateDetailName(Locale locale) テンプレート明細名を取得します。
void | ItemTemplateDetailBaseModel.setTemplateDetailName(String templateDetailName) テンプレート明細名を設定します。
void | ItemTemplateDetailBaseModel.setTemplateDetailName(String templateDetailName, Locale locale) テンプレート明細名を設定します。

jp.co.intra_mart.foundation.datastore.application.model.item_template.template での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.item_template.template のメソッド
String | ItemTemplateInternationalModel.getTemplateName() テンプレート名を取得します。
void | ItemTemplateInternationalModel.setTemplateName(String templateName) テンプレート名を設定します。
String | ItemTemplateBaseModel.getTemplateCode() テンプレートコードを取得します。
String | ItemTemplateBaseModel.getTemplateName() テンプレート名を取得します。
void | ItemTemplateBaseModel.setTemplateName(String templateName) テンプレート名を設定します。
String | ItemTemplateBaseModel.getNotes() 備考を取得します。
void | ItemTemplateBaseModel.setNotes(String notes) 備考を設定します。
String | ItemTemplateBaseModel.getRecordUserCd() 最終更新者を取得します。
Date | ItemTemplateBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.item.attribute での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.item.attribute のメソッド
String | ItemAttributeInternationalModel.getStringValue() 属性文字列を取得します。
void | ItemAttributeInternationalModel.setStringValue(String stringValue) 属性文字列を設定します。
String | ItemAttributeBaseModel.getItemCode() 商品コードを取得します。
String | ItemAttributeBaseModel.getTemplateCode() テンプレートコードを取得します。
String | ItemAttributeBaseModel.getTemplateDetailCode() テンプレート明細コードを取得します。
double | ItemAttributeBaseModel.getNumberValue() 属性数値を取得します。
void | ItemAttributeBaseModel.setNumberValue(double numberValue) 属性数値を設定します。
String | ItemAttributeBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | ItemAttributeBaseModel.getRecordDate() 最終更新日を取得します。
String | ItemAttributeBaseModel.getStringValue() 属性文字列を取得します。
String | ItemAttributeBaseModel.getStringValue(Locale locale) 属性文字列を取得します。
void | ItemAttributeBaseModel.setStringValue(String stringValue) 属性文字列を設定します。
void | ItemAttributeBaseModel.setStringValue(String stringValue, Locale locale) 属性文字列を設定します。

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.item.catalogue のメソッド
String | ItemCatalogueBaseModel.getItemCode() 商品コードを取得します。
String | ItemCatalogueBaseModel.getItemCatalogueCode() 商品カタログコードを取得します。
int | ItemCatalogueBaseModel.getMediaCls() 媒体種類を取得します。
void | ItemCatalogueBaseModel.setMediaCls(int mediaCls) 媒体種類を設定します。
String | ItemCatalogueBaseModel.getMedia() 媒体を取得します。
void | ItemCatalogueBaseModel.setMedia(String media) 媒体を設定します。
String | ItemCatalogueBaseModel.getNotes() 備考を取得します。
void | ItemCatalogueBaseModel.setNotes(String notes) 備考を設定します。
int | ItemCatalogueBaseModel.getSortKey() ソートキーを取得します。
void | ItemCatalogueBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | ItemCatalogueBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | ItemCatalogueBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.item.item での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.item.item のメソッド
double | ItemTerminableModel.getSalesUnitPrice() 販売単価を取得します。
void | ItemTerminableModel.setSalesUnitPrice(double salesUnitPrice) 販売単価を設定します。
double | ItemTerminableModel.getPurchaseUnitPrice() 仕入単価を取得します。
void | ItemTerminableModel.setPurchaseUnitPrice(double purchaseUnitPrice) 仕入単価を設定します。
String | ItemTerminableModel.getItemName() 商品名を取得します。
String | ItemTerminableModel.getItemName(Locale locale) 商品名を取得します。
void | ItemTerminableModel.setItemName(String itemName) 商品名を設定します。
void | ItemTerminableModel.setItemName(String itemName, Locale locale) 商品名を設定します。
String | ItemTerminableModel.getItemCaption() 商品通称を取得します。
String | ItemTerminableModel.getItemCaption(Locale locale) 商品通称を取得します。
void | ItemTerminableModel.setItemCaption(String itemCaption) 商品通称を設定します。
void | ItemTerminableModel.setItemCaption(String itemCaption, Locale locale) 商品通称を設定します。
String | ItemTerminableInternationalModel.getItemName() 商品名を取得します。
void | ItemTerminableInternationalModel.setItemName(String itemName) 商品名を設定します。
String | ItemTerminableInternationalModel.getItemCaption() 商品通称を取得します。
void | ItemTerminableInternationalModel.setItemCaption(String itemCaption) 商品通称を設定します。
String | ItemBaseModel.getItemCode() 商品コードを取得します。
String | ItemBaseModel.getProductModelCode() 製品型番を取得します。
void | ItemBaseModel.setProductModelCode(String productModelCode) 製品型番を設定します。
String | ItemBaseModel.getNotes() 備考を取得します。
void | ItemBaseModel.setNotes(String notes) 備考を設定します。
String | ItemBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | ItemBaseModel.getRecordDate() 最終更新日を取得します。
double | ItemBaseModel.getSalesUnitPrice() 販売単価を取得します。
double | ItemBaseModel.getSalesUnitPrice(Date date) 販売単価を取得します。
void | ItemBaseModel.setSalesUnitPrice(double salesUnitPrice) 販売単価を設定します。
void | ItemBaseModel.setSalesUnitPrice(double salesUnitPrice, Date date) 販売単価を設定します。
double | ItemBaseModel.getPurchaseUnitPrice() 仕入単価を取得します。
double | ItemBaseModel.getPurchaseUnitPrice(Date date) 仕入単価を取得します。
void | ItemBaseModel.setPurchaseUnitPrice(double purchaseUnitPrice) 仕入単価を設定します。
void | ItemBaseModel.setPurchaseUnitPrice(double purchaseUnitPrice, Date date) 仕入単価を設定します。
String | ItemBaseModel.getItemName() 商品名を取得します。
String | ItemBaseModel.getItemName(Date date) 商品名を取得します。
String | ItemBaseModel.getItemName(Locale locale) 商品名を取得します。
String | ItemBaseModel.getItemName(Date date, Locale locale) 商品名を取得します。
void | ItemBaseModel.setItemName(String itemName) 商品名を設定します。
void | ItemBaseModel.setItemName(String itemName, Date date) 商品名を設定します。
void | ItemBaseModel.setItemName(String itemName, Locale locale) 商品名を設定します。
void | ItemBaseModel.setItemName(String itemName, Date date, Locale locale) 商品名を設定します。
String | ItemBaseModel.getItemCaption() 商品通称を取得します。
String | ItemBaseModel.getItemCaption(Date date) 商品通称を取得します。
String | ItemBaseModel.getItemCaption(Locale locale) 商品通称を取得します。
String | ItemBaseModel.getItemCaption(Date date, Locale locale) 商品通称を取得します。
void | ItemBaseModel.setItemCaption(String itemCaption) 商品通称を設定します。
void | ItemBaseModel.setItemCaption(String itemCaption, Date date) 商品通称を設定します。
void | ItemBaseModel.setItemCaption(String itemCaption, Locale locale) 商品通称を設定します。
void | ItemBaseModel.setItemCaption(String itemCaption, Date date, Locale locale) 商品通称を設定します。

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.private_group.attach のメソッド
String | PrivateGroupAttachBaseModel.getOwnerCode() 所有者コードを取得します。
String | PrivateGroupAttachBaseModel.getPrivateGroupCode() グループコードを取得します。
String | PrivateGroupAttachBaseModel.getUserCode() ユーザコードを取得します。
int | PrivateGroupAttachBaseModel.getSortKey() ソートキーを取得します。
void | PrivateGroupAttachBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | PrivateGroupAttachBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | PrivateGroupAttachBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.private_group.group での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.private_group.group のメソッド
String | PrivateGroupBaseModel.getOwnerCode() 所有者コードを取得します。
String | PrivateGroupBaseModel.getPrivateGroupCode() グループコードを取得します。
String | PrivateGroupBaseModel.getName() グループ名を取得します。
void | PrivateGroupBaseModel.setName(String name) グループ名を設定します。
String | PrivateGroupBaseModel.getNameSyllabary() グループ名カナを取得します。
void | PrivateGroupBaseModel.setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
String | PrivateGroupBaseModel.getNameEnglish() グループ名英字を取得します。
void | PrivateGroupBaseModel.setNameEnglish(String nameEnglish) グループ名英字を設定します。
String | PrivateGroupBaseModel.getNotes() 備考を取得します。
void | PrivateGroupBaseModel.setNotes(String notes) 備考を設定します。
int | PrivateGroupBaseModel.getSortKey() ソートキーを取得します。
void | PrivateGroupBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | PrivateGroupBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | PrivateGroupBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.attach のメソッド
String | PublicGroupAttachBaseModel.getUserCode() ユーザコードを取得します。
String | PublicGroupAttachBaseModel.getPublicGroupSetCode() グループセットコードを取得します。
String | PublicGroupAttachBaseModel.getPublicGroupCode() グループコードを取得します。
int | PublicGroupAttachBaseModel.getSortKey() ソートキーを取得します。
void | PublicGroupAttachBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | PublicGroupAttachBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | PublicGroupAttachBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.category のメソッド
String | PublicGroupCategoryBaseModel.getPublicGroupSetCode() グループセットコードを取得します。
String | PublicGroupCategoryBaseModel.getPublicGroupCode() グループコードを取得します。
String | PublicGroupCategoryBaseModel.getCategoryClassCode() 分類区分コードを取得します。
String | PublicGroupCategoryBaseModel.getCategoryCode() 分類コードを取得します。
String | PublicGroupCategoryBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | PublicGroupCategoryBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.group のメソッド
String | PublicGroupTerminableModel.getName() グループ名を取得します。
String | PublicGroupTerminableModel.getName(Locale locale) グループ名を取得します。
void | PublicGroupTerminableModel.setName(String name) グループ名を設定します。
void | PublicGroupTerminableModel.setName(String name, Locale locale) グループ名を設定します。
String | PublicGroupTerminableModel.getNameSyllabary() グループ名カナを取得します。
String | PublicGroupTerminableModel.getNameSyllabary(Locale locale) グループ名カナを取得します。
void | PublicGroupTerminableModel.setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
void | PublicGroupTerminableModel.setNameSyllabary(String nameSyllabary, Locale locale) グループ名カナを設定します。
String | PublicGroupTerminableModel.getNameEnglish() グループ名英字を取得します。
String | PublicGroupTerminableModel.getNameEnglish(Locale locale) グループ名英字を取得します。
void | PublicGroupTerminableModel.setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | PublicGroupTerminableModel.setNameEnglish(String nameEnglish, Locale locale) グループ名英字を設定します。
String | PublicGroupTerminableInternationalModel.getName() グループ名を取得します。
void | PublicGroupTerminableInternationalModel.setName(String name) グループ名を設定します。
String | PublicGroupTerminableInternationalModel.getNameSyllabary() グループ名カナを取得します。
void | PublicGroupTerminableInternationalModel.setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
String | PublicGroupTerminableInternationalModel.getNameEnglish() グループ名英字を取得します。
void | PublicGroupTerminableInternationalModel.setNameEnglish(String nameEnglish) グループ名英字を設定します。
String | PublicGroupBaseModel.getPublicGroupSetCode() グループセットコードを取得します。
String | PublicGroupBaseModel.getPublicGroupCode() グループコードを取得します。
String | PublicGroupBaseModel.getNotes() 備考を取得します。
void | PublicGroupBaseModel.setNotes(String notes) 備考を設定します。
int | PublicGroupBaseModel.getSortKey() ソートキーを取得します。
void | PublicGroupBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | PublicGroupBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | PublicGroupBaseModel.getRecordDate() 最終更新日を取得します。
String | PublicGroupBaseModel.getName() グループ名を取得します。
String | PublicGroupBaseModel.getName(Date date) グループ名を取得します。
String | PublicGroupBaseModel.getName(Locale locale) グループ名を取得します。
String | PublicGroupBaseModel.getName(Date date, Locale locale) グループ名を取得します。
void | PublicGroupBaseModel.setName(String name) グループ名を設定します。
void | PublicGroupBaseModel.setName(String name, Date date) グループ名を設定します。
void | PublicGroupBaseModel.setName(String name, Locale locale) グループ名を設定します。
void | PublicGroupBaseModel.setName(String name, Date date, Locale locale) グループ名を設定します。
String | PublicGroupBaseModel.getNameSyllabary() グループ名カナを取得します。
String | PublicGroupBaseModel.getNameSyllabary(Date date) グループ名カナを取得します。
String | PublicGroupBaseModel.getNameSyllabary(Locale locale) グループ名カナを取得します。
String | PublicGroupBaseModel.getNameSyllabary(Date date, Locale locale) グループ名カナを取得します。
void | PublicGroupBaseModel.setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
void | PublicGroupBaseModel.setNameSyllabary(String nameSyllabary, Date date) グループ名カナを設定します。
void | PublicGroupBaseModel.setNameSyllabary(String nameSyllabary, Locale locale) グループ名カナを設定します。
void | PublicGroupBaseModel.setNameSyllabary(String nameSyllabary, Date date, Locale locale) グループ名カナを設定します。
String | PublicGroupBaseModel.getNameEnglish() グループ名英字を取得します。
String | PublicGroupBaseModel.getNameEnglish(Date date) グループ名英字を取得します。
String | PublicGroupBaseModel.getNameEnglish(Locale locale) グループ名英字を取得します。
String | PublicGroupBaseModel.getNameEnglish(Date date, Locale locale) グループ名英字を取得します。
void | PublicGroupBaseModel.setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | PublicGroupBaseModel.setNameEnglish(String nameEnglish, Date date) グループ名英字を設定します。
void | PublicGroupBaseModel.setNameEnglish(String nameEnglish, Locale locale) グループ名英字を設定します。
void | PublicGroupBaseModel.setNameEnglish(String nameEnglish, Date date, Locale locale) グループ名英字を設定します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion のメソッド
String | PublicGroupInclusionBaseModel.getPublicGroupSetCode() グループセットコードを取得します。
String | PublicGroupInclusionBaseModel.getVersionCode() バージョンコードを取得します。
String | PublicGroupInclusionBaseModel.getParentPublicGroupCode() 親グループコードを取得します。
String | PublicGroupInclusionBaseModel.getPublicGroupCode() グループコードを取得します。
int | PublicGroupInclusionBaseModel.getDepth() 階層レベルを取得します。
void | PublicGroupInclusionBaseModel.setDepth(int depth) 階層レベルを設定します。
String | PublicGroupInclusionBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | PublicGroupInclusionBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.set での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.set のメソッド
String | PublicGroupSetBaseModel.getPublicGroupSetCode() グループセットコードを取得します。
String | PublicGroupSetBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | PublicGroupSetBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.version での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.version のメソッド
String | PublicGroupVersionBaseModel.getPublicGroupSetCode() グループセットコードを取得します。
String | PublicGroupVersionBaseModel.getVersionCode() バージョンコードを取得します。
Date | PublicGroupVersionBaseModel.getStartDate() 開始日を取得します。
void | PublicGroupVersionBaseModel.setStartDate(Date startDate) 開始日を設定します。
Date | PublicGroupVersionBaseModel.getEndDate() 終了日を取得します。
void | PublicGroupVersionBaseModel.setEndDate(Date endDate) 終了日を設定します。
String | PublicGroupVersionBaseModel.getNotes() 備考を取得します。
void | PublicGroupVersionBaseModel.setNotes(String notes) 備考を設定します。
String | PublicGroupVersionBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | PublicGroupVersionBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.unit での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.unit のメソッド
String | UnitBaseModel.getUnitCode() 単位コードを取得します。
String | UnitBaseModel.getUnitName() 単位名を取得します。
void | UnitBaseModel.setUnitName(String unitName) 単位名を設定します。

jp.co.intra_mart.foundation.datastore.application.model.user での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.user のメソッド
String | UserTerminableModel.getTelephoneNumber() 電話番号を取得します。
void | UserTerminableModel.setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
String | UserTerminableModel.getMobileNumber() 携帯電話番号を取得します。
void | UserTerminableModel.setMobileNumber(String mobileNumber) 携帯電話番号を設定します。
String | UserTerminableModel.getFaxNumber() FAX番号を取得します。
void | UserTerminableModel.setFaxNumber(String faxNumber) FAX番号を設定します。
String | UserTerminableModel.getExtensionNumber() 内線番号を取得します。
void | UserTerminableModel.setExtensionNumber(String extensionNumber) 内線番号を設定します。
String | UserTerminableModel.getExtensionFaxNumber() 内線FAX番号を取得します。
void | UserTerminableModel.setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
String | UserTerminableModel.getCountryCode() 国コードを取得します。
void | UserTerminableModel.setCountryCode(String countryCode) 国コードを設定します。
String | UserTerminableModel.getZipCode() 郵便番号を取得します。
void | UserTerminableModel.setZipCode(String zipCode) 郵便番号を設定します。
String | UserTerminableModel.getEmailAddress1() メールアドレス１を取得します。
void | UserTerminableModel.setEmailAddress1(String emailAddress1) メールアドレス１を設定します。
String | UserTerminableModel.getEmailAddress2() メールアドレス２を取得します。
void | UserTerminableModel.setEmailAddress2(String emailAddress2) メールアドレス２を設定します。
String | UserTerminableModel.getMobileEmailAddress() 携帯用メールを取得します。
void | UserTerminableModel.setMobileEmailAddress(String mobileEmailAddress) 携帯用メールを設定します。
String | UserTerminableModel.getUrl() URLを取得します。
void | UserTerminableModel.setUrl(String url) URLを設定します。
String | UserTerminableModel.getName() ユーザ名を取得します。
String | UserTerminableModel.getName(Locale locale) ユーザ名を取得します。
void | UserTerminableModel.setName(String name) ユーザ名を設定します。
void | UserTerminableModel.setName(String name, Locale locale) ユーザ名を設定します。
String | UserTerminableModel.getNameSyllabary() ユーザ名カナを取得します。
String | UserTerminableModel.getNameSyllabary(Locale locale) ユーザ名カナを取得します。
void | UserTerminableModel.setNameSyllabary(String nameSyllabary) ユーザ名カナを設定します。
void | UserTerminableModel.setNameSyllabary(String nameSyllabary, Locale locale) ユーザ名カナを設定します。
String | UserTerminableModel.getNameEnglish() ユーザ名英字を取得します。
String | UserTerminableModel.getNameEnglish(Locale locale) ユーザ名英字を取得します。
void | UserTerminableModel.setNameEnglish(String nameEnglish) ユーザ名英字を設定します。
void | UserTerminableModel.setNameEnglish(String nameEnglish, Locale locale) ユーザ名英字を設定します。
String | UserTerminableModel.getAddress() 住所を取得します。
String | UserTerminableModel.getAddress(Locale locale) 住所を取得します。
void | UserTerminableModel.setAddress(String address) 住所を設定します。
void | UserTerminableModel.setAddress(String address, Locale locale) 住所を設定します。
String | UserTerminableInternationalModel.getName() ユーザ名を取得します。
void | UserTerminableInternationalModel.setName(String name) ユーザ名を設定します。
String | UserTerminableInternationalModel.getNameSyllabary() ユーザ名カナを取得します。
void | UserTerminableInternationalModel.setNameSyllabary(String nameSyllabary) ユーザ名カナを設定します。
String | UserTerminableInternationalModel.getNameEnglish() ユーザ名英字を取得します。
void | UserTerminableInternationalModel.setNameEnglish(String nameEnglish) ユーザ名英字を設定します。
String | UserTerminableInternationalModel.getAddress() 住所を取得します。
void | UserTerminableInternationalModel.setAddress(String address) 住所を設定します。
String | UserBaseModel.getUserCode() ユーザコードを取得します。
String | UserBaseModel.getAccountFlag() アカウントフラグを取得します。
void | UserBaseModel.setAccountFlag(String accountFlag) アカウントフラグを設定します。
String | UserBaseModel.getNotes() 備考を取得します。
void | UserBaseModel.setNotes(String notes) 備考を設定します。
int | UserBaseModel.getSortKey() ソートキーを取得します。
void | UserBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | UserBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | UserBaseModel.getRecordDate() 最終更新日を取得します。
String | UserBaseModel.getTelephoneNumber() 電話番号を取得します。
String | UserBaseModel.getTelephoneNumber(Date date) 電話番号を取得します。
void | UserBaseModel.setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | UserBaseModel.setTelephoneNumber(String telephoneNumber, Date date) 電話番号を設定します。
String | UserBaseModel.getMobileNumber() 携帯電話番号を取得します。
String | UserBaseModel.getMobileNumber(Date date) 携帯電話番号を取得します。
void | UserBaseModel.setMobileNumber(String mobileNumber) 携帯電話番号を設定します。
void | UserBaseModel.setMobileNumber(String mobileNumber, Date date) 携帯電話番号を設定します。
String | UserBaseModel.getFaxNumber() FAX番号を取得します。
String | UserBaseModel.getFaxNumber(Date date) FAX番号を取得します。
void | UserBaseModel.setFaxNumber(String faxNumber) FAX番号を設定します。
void | UserBaseModel.setFaxNumber(String faxNumber, Date date) FAX番号を設定します。
String | UserBaseModel.getExtensionNumber() 内線番号を取得します。
String | UserBaseModel.getExtensionNumber(Date date) 内線番号を取得します。
void | UserBaseModel.setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | UserBaseModel.setExtensionNumber(String extensionNumber, Date date) 内線番号を設定します。
String | UserBaseModel.getExtensionFaxNumber() 内線FAX番号を取得します。
String | UserBaseModel.getExtensionFaxNumber(Date date) 内線FAX番号を取得します。
void | UserBaseModel.setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | UserBaseModel.setExtensionFaxNumber(String extensionFaxNumber, Date date) 内線FAX番号を設定します。
String | UserBaseModel.getCountryCode() 国コードを取得します。
String | UserBaseModel.getCountryCode(Date date) 国コードを取得します。
void | UserBaseModel.setCountryCode(String countryCode) 国コードを設定します。
void | UserBaseModel.setCountryCode(String countryCode, Date date) 国コードを設定します。
String | UserBaseModel.getZipCode() 郵便番号を取得します。
String | UserBaseModel.getZipCode(Date date) 郵便番号を取得します。
void | UserBaseModel.setZipCode(String zipCode) 郵便番号を設定します。
void | UserBaseModel.setZipCode(String zipCode, Date date) 郵便番号を設定します。
String | UserBaseModel.getEmailAddress1() メールアドレス１を取得します。
String | UserBaseModel.getEmailAddress1(Date date) メールアドレス１を取得します。
void | UserBaseModel.setEmailAddress1(String emailAddress1) メールアドレス１を設定します。
void | UserBaseModel.setEmailAddress1(String emailAddress1, Date date) メールアドレス１を設定します。
String | UserBaseModel.getEmailAddress2() メールアドレス２を取得します。
String | UserBaseModel.getEmailAddress2(Date date) メールアドレス２を取得します。
void | UserBaseModel.setEmailAddress2(String emailAddress2) メールアドレス２を設定します。
void | UserBaseModel.setEmailAddress2(String emailAddress2, Date date) メールアドレス２を設定します。
String | UserBaseModel.getMobileEmailAddress() 携帯用メールを取得します。
String | UserBaseModel.getMobileEmailAddress(Date date) 携帯用メールを取得します。
void | UserBaseModel.setMobileEmailAddress(String mobileEmailAddress) 携帯用メールを設定します。
void | UserBaseModel.setMobileEmailAddress(String mobileEmailAddress, Date date) 携帯用メールを設定します。
String | UserBaseModel.getUrl() URLを取得します。
String | UserBaseModel.getUrl(Date date) URLを取得します。
void | UserBaseModel.setUrl(String url) URLを設定します。
void | UserBaseModel.setUrl(String url, Date date) URLを設定します。
String | UserBaseModel.getName() ユーザ名を取得します。
String | UserBaseModel.getName(Date date) ユーザ名を取得します。
String | UserBaseModel.getName(Locale locale) ユーザ名を取得します。
String | UserBaseModel.getName(Date date, Locale locale) ユーザ名を取得します。
void | UserBaseModel.setName(String name) ユーザ名を設定します。
void | UserBaseModel.setName(String name, Date date) ユーザ名を設定します。
void | UserBaseModel.setName(String name, Locale locale) ユーザ名を設定します。
void | UserBaseModel.setName(String name, Date date, Locale locale) ユーザ名を設定します。
String | UserBaseModel.getNameSyllabary() ユーザ名カナを取得します。
String | UserBaseModel.getNameSyllabary(Date date) ユーザ名カナを取得します。
String | UserBaseModel.getNameSyllabary(Locale locale) ユーザ名カナを取得します。
String | UserBaseModel.getNameSyllabary(Date date, Locale locale) ユーザ名カナを取得します。
void | UserBaseModel.setNameSyllabary(String nameSyllabary) ユーザ名カナを設定します。
void | UserBaseModel.setNameSyllabary(String nameSyllabary, Date date) ユーザ名カナを設定します。
void | UserBaseModel.setNameSyllabary(String nameSyllabary, Locale locale) ユーザ名カナを設定します。
void | UserBaseModel.setNameSyllabary(String nameSyllabary, Date date, Locale locale) ユーザ名カナを設定します。
String | UserBaseModel.getNameEnglish() ユーザ名英字を取得します。
String | UserBaseModel.getNameEnglish(Date date) ユーザ名英字を取得します。
String | UserBaseModel.getNameEnglish(Locale locale) ユーザ名英字を取得します。
String | UserBaseModel.getNameEnglish(Date date, Locale locale) ユーザ名英字を取得します。
void | UserBaseModel.setNameEnglish(String nameEnglish) ユーザ名英字を設定します。
void | UserBaseModel.setNameEnglish(String nameEnglish, Date date) ユーザ名英字を設定します。
void | UserBaseModel.setNameEnglish(String nameEnglish, Locale locale) ユーザ名英字を設定します。
void | UserBaseModel.setNameEnglish(String nameEnglish, Date date, Locale locale) ユーザ名英字を設定します。
String | UserBaseModel.getAddress() 住所を取得します。
String | UserBaseModel.getAddress(Date date) 住所を取得します。
String | UserBaseModel.getAddress(Locale locale) 住所を取得します。
String | UserBaseModel.getAddress(Date date, Locale locale) 住所を取得します。
void | UserBaseModel.setAddress(String address) 住所を設定します。
void | UserBaseModel.setAddress(String address, Date date) 住所を設定します。
void | UserBaseModel.setAddress(String address, Locale locale) 住所を設定します。
void | UserBaseModel.setAddress(String address, Date date, Locale locale) 住所を設定します。

jp.co.intra_mart.foundation.datastore.common.model での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableModel | TerminableModelMap.createTerminableModel(Term term) 指定した期間を満たす期間化モデルを生成します。
void | TerminableModelMap.remove(Term term) 指定された期間に該当するデータを削除します。
TerminableInternationalModel | TerminableInternationalModelMap.createTerminableInternationalModel(Locale locale) 期間国際化モデルを生成します。
void | TerminableInternationalModelMap.remove(Locale locale) 指定された言語に該当するデータを削除します。
InternationalModel | InternationalModelMap.createInternationalModel(Locale locale) 国際化モデルを生成します。
void | InternationalModelMap.remove(Locale locale) 指定された言語に該当するデータを削除します。
TerminableModel | GenericTerminableModelMap.createTerminableModel(Term term) 指定した期間を満たす期間化モデルを生成します。
void | GenericTerminableModelMap.remove(Term term) 指定された期間に該当するデータを削除します。
protected Object | GenericTerminableModel.get(String name) 指定の属性が保持する値を取得します。
protected Object | GenericTerminableModel.get(String name, Locale locale) 指定の属性が指定の言語で保持する値を取得します。
protected void | GenericTerminableModel.set(String name, Object value) 指定の属性に値を設定します。
protected void | GenericTerminableModel.set(String name, Object value, Locale locale) 指定の属性に値を設定します。
TerminableInternationalModel | GenericTerminableInternationalModelMap.createTerminableInternationalModel(Locale locale) 期間国際化モデルを生成します。
void | GenericTerminableInternationalModelMap.remove(Locale locale) 指定された言語に該当するデータを削除します。
protected Object | GenericTerminableInternationalModel.get(String name) 指定の属性が保持する値を取得します。
protected void | GenericTerminableInternationalModel.set(String name, Object value) 指定の属性に値を設定します。
InternationalModel | GenericInternationalModelMap.createInternationalModel(Locale locale) 国際化モデルを生成します。
void | GenericInternationalModelMap.remove(Locale locale) 指定された言語に該当するデータを削除します。
protected Object | GenericInternationalModel.get(String name) 指定の属性が保持する値を取得します。
protected void | GenericInternationalModel.set(String name, Object value) 指定の属性に値を設定します。
protected Object | GenericBaseModel.get(String name) 指定の属性が保持する値を取得します。
protected Object | GenericBaseModel.get(String name, Date date) 指定の属性が、指定の日時に保持している値を取得します。
protected Object | GenericBaseModel.get(String name, Locale locale) 指定の属性が、指定の言語で保持している値を取得します。
protected Object | GenericBaseModel.get(String name, Date date, Locale locale) 指定の属性が、指定の日時、言語で保持している値を取得します。
protected void | GenericBaseModel.set(String name, Object value) 指定の属性に値を設定します。
protected void | GenericBaseModel.set(String name, Object value, Date date) 指定の属性に、指定の日時で値を設定します。
protected void | GenericBaseModel.set(String name, Object value, Locale locale) 指定の属性に、指定の言語で値を設定します。
protected void | GenericBaseModel.set(String name, Object value, Date date, Locale locale) 指定の属性に、指定の日時、言語で値を設定します。
ExtendedTerminableModel | ExtendedTerminableModelMap.createExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
ExtendedTerminableModel | ExtendedTerminableModelMap.findExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
void | ExtendedTerminableModelMap.remove(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。
ExtendedTerminableInternationalModel | ExtendedTerminableInternationalModelMap.createExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
ExtendedTerminableInternationalModel | ExtendedTerminableInternationalModelMap.findExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
void | ExtendedTerminableInternationalModelMap.remove(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。
ExtendedInternationalModel | ExtendedInternationalModelMap.createExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
ExtendedInternationalModel | ExtendedInternationalModelMap.findExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
void | ExtendedInternationalModelMap.remove(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。
ExtendedTerminableModel | ExtendedGenericTerminableModelMap.createExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
ExtendedTerminableModel | ExtendedGenericTerminableModelMap.findExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
void | ExtendedGenericTerminableModelMap.remove(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。
protected Object | ExtendedGenericTerminableModel.get(String name) 指定の属性が保持する値を取得します。
protected void | ExtendedGenericTerminableModel.set(String name, Object value) 指定の属性に値を設定します。
ExtendedTerminableInternationalModel | ExtendedGenericTerminableInternationalModelMap.createExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
ExtendedTerminableInternationalModel | ExtendedGenericTerminableInternationalModelMap.findExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
void | ExtendedGenericTerminableInternationalModelMap.remove(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。
protected Object | ExtendedGenericTerminableInternationalModel.get(String name) 指定の属性が保持する値を取得します。
protected void | ExtendedGenericTerminableInternationalModel.set(String name, Object value) 指定の属性に値を設定します。
ExtendedInternationalModel | ExtendedGenericInternationalModelMap.createExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
ExtendedInternationalModel | ExtendedGenericInternationalModelMap.findExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
void | ExtendedGenericInternationalModelMap.remove(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。
protected Object | ExtendedGenericInternationalModel.get(String name) 指定の属性が保持する値を取得します。
protected void | ExtendedGenericInternationalModel.set(String name, Object value) 指定の属性に値を設定します。
ExtendedBaseModel | ExtendedGenericBaseModelMap.createExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
ExtendedBaseModel | ExtendedGenericBaseModelMap.findExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。
void | ExtendedGenericBaseModelMap.remove(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。
protected Object | ExtendedGenericBaseModel.get(String name) 指定の属性が保持する値を取得します。
protected void | ExtendedGenericBaseModel.set(String name, Object value) 指定の属性に値を設定します。
ExtendedBaseModel | ExtendedBaseModelMap.createExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
ExtendedBaseModel | ExtendedBaseModelMap.findExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。
void | ExtendedBaseModelMap.remove(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。

jp.co.intra_mart.foundation.datastore.exception での AccessorException の使用

jp.co.intra_mart.foundation.datastore.exception での AccessorException のサブクラス
class | AccessorClosedException アクセサのクローズ時に発生する例外クラス アクセサがクローズされている場合に、以下のメソッドを呼び出された時にスローする。
class | AccessorIllegalPropertyValueException アクセサのプロパティ設定に関する例外クラス アクセサに不正な値が設定された場合にスローする。
class | DataNotFoundException アクセサのプロパティ値の取得に関する例外クラス 指定されたプロパティに対する値が設定されていない場合にスローする。
class | IllegalExtensionException 拡張アクセサに関する例外クラス 拡張アクセサに対して不正な操作が行われた場合にスローする。
class | IllegalLocaleException アクセサが保持する言語に関する例外クラス アクセサが保持していない言語を要求された場合にスローする。
class | IllegalTermException アクセサが保持する期間に関する例外クラス アクセサが保持しない日時または期間が指定されたときにスローする。

jp.co.intra_mart.system.security.datastore.inf での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.system.security.datastore.inf のメソッド
String | RoleSummaryBaseModel.getRoleId() ロールIDを取得します。
String | RoleSummaryBaseModel.getSummaryRoleId() サマリロールIDを取得します。
String | RoleSummaryBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | RoleSummaryBaseModel.getRecordDate() 最終更新日を取得します。
String | RoleInternationalModel.getDisplayName() ロール表示名を取得します。
void | RoleInternationalModel.setDisplayName(String displayName) ロール表示名を設定します。
String | RoleInclusionBaseModel.getParentRoleId() 親ロールコードを取得します。
String | RoleInclusionBaseModel.getChildRoleId() 子ロールコードを取得します。
String | RoleInclusionBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | RoleInclusionBaseModel.getRecordDate() 最終更新日を取得します。
String | RoleBaseModel.getRoleId() ロールIDを取得します。
String | RoleBaseModel.getName() ロール名を取得します。
void | RoleBaseModel.setName(String name) ロール名を設定します。
String | RoleBaseModel.getCategory() カテゴリを取得します。
void | RoleBaseModel.setCategory(String category) カテゴリを設定します。
String | RoleBaseModel.getNotes() 備考を取得します。
void | RoleBaseModel.setNotes(String notes) 備考を設定します。
String | RoleBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | RoleBaseModel.getRecordDate() 最終更新日を取得します。
String | RoleBaseModel.getDisplayName() ロール表示名を取得します。
String | RoleBaseModel.getDisplayName(Locale locale) ロール表示名を取得します。
void | RoleBaseModel.setDisplayName(String displayName) ロール表示名を設定します。
void | RoleBaseModel.setDisplayName(String displayName, Locale locale) ロール表示名を設定します。
String | MenuRoleBaseModel.getMenuId() メニューIDを取得します。
String | MenuRoleBaseModel.getRoleId() ロールCDを取得します。
String | MenuRoleBaseModel.getRecordUserCode() 最終更新者を取得します。
String | MenuRoleBaseModel.getRecordDate() 最終更新日を取得します。
String | MenuPublicGroupBaseModel.getMenuId() メニューIDを取得します。
String | MenuPublicGroupBaseModel.getPublicGroupSetCd() グループセットCDを取得します。
String | MenuPublicGroupBaseModel.getPublicGroupCd() グルーピングCDを取得します。
String | MenuPublicGroupBaseModel.getRecordUserCode() 最終更新者を取得します。
String | MenuPublicGroupBaseModel.getRecordDate() 最終更新日を取得します。
String | MenuPostBaseModel.getMenuId() メニューIDを取得します。
String | MenuPostBaseModel.getCompanyCd() 会社CDを取得します。
String | MenuPostBaseModel.getPostCd() 役職CDを取得します。
String | MenuPostBaseModel.getRecordUserCode() 最終更新者を取得します。
String | MenuPostBaseModel.getRecordDate() 最終更新日を取得します。
String | MenuInternationalModel.getDisplayName() メニュー表示名を取得します。
void | MenuInternationalModel.setDisplayName(String displayName) メニュー表示名を設定します。
String | MenuDepartmentBaseModel.getMenuId() メニューIDを取得します。
String | MenuDepartmentBaseModel.getCompanyCd() 会社CDを取得します。
String | MenuDepartmentBaseModel.getDepartmentCd() 組織CDを取得します。
String | MenuDepartmentBaseModel.getRecordUserCode() 最終更新者を取得します。
String | MenuDepartmentBaseModel.getRecordDate() 最終更新日を取得します。
String | MenuBaseModel.getMenuId() メニューIDを取得します。
String | MenuBaseModel.getMenuType() メニュータイプを取得します。
void | MenuBaseModel.setMenuType(String menuType) メニュータイプを設定します。
String | MenuBaseModel.getNotes() 説明を取得します。
void | MenuBaseModel.setNotes(String notes) 説明を設定します。
int | MenuBaseModel.getSortNumber() ソート番号を取得します。
void | MenuBaseModel.setSortNumber(int sortNumber) ソート番号を設定します。
String | MenuBaseModel.getClientType() クライアントタイプを取得します。
void | MenuBaseModel.setClientType(String clientType) クライアントタイプを設定します。
String | MenuBaseModel.getContents() コンテンツの種類を取得します。
void | MenuBaseModel.setContents(String contents) コンテンツの種類を設定します。
String | MenuBaseModel.getUrl() URLを取得します。
void | MenuBaseModel.setUrl(String url) URLを設定します。
String | MenuBaseModel.getParentMenuId() 親メニューIDを取得します。
void | MenuBaseModel.setParentMenuId(String parentMenuId) 親メニューIDを設定します。
String | MenuBaseModel.getImagePath() イメージパスを取得します。
void | MenuBaseModel.setImagePath(String imagePath) イメージパスを設定します。
String | MenuBaseModel.getRecordUserCode() 最終更新者を取得します。
String | MenuBaseModel.getRecordDate() 最終更新日を取得します。
String | MenuBaseModel.getDisplayName() メニュー表示名を取得します。
String | MenuBaseModel.getDisplayName(Locale locale) メニュー表示名を取得します。
void | MenuBaseModel.setDisplayName(String displayName) メニュー表示名を設定します。
void | MenuBaseModel.setDisplayName(String displayName, Locale locale) メニュー表示名を設定します。
String | MenuArgumentBaseModel.getMenuId() メニューIDを取得します。
String | MenuArgumentBaseModel.getArgumentName() 引数名を取得します。
String | MenuArgumentBaseModel.getArgumentValue() 引数値を取得します。
void | MenuArgumentBaseModel.setArgumentValue(String argumentValue) 引数値を設定します。
String | MenuArgumentBaseModel.getRecordUserCode() 最終更新者を取得します。
String | MenuArgumentBaseModel.getRecordDate() 最終更新日を取得します。
String | FavoriteMenuBaseModel.getUserId() ユーザIDを取得します。
String | FavoriteMenuBaseModel.getMenuId() メニューIDを取得します。
String | FavoriteMenuBaseModel.getDisplayName() メニュー表示名を取得します。
void | FavoriteMenuBaseModel.setDisplayName(String displayName) メニュー表示名を設定します。
String | FavoriteMenuBaseModel.getImagePath() イメージパスを取得します。
void | FavoriteMenuBaseModel.setImagePath(String imagePath) イメージパスを設定します。
int | FavoriteMenuBaseModel.getSortNumber() ソート番号を取得します。
void | FavoriteMenuBaseModel.setSortNumber(int sortNumber) ソート番号を設定します。
String | FavoriteMenuBaseModel.getRecordUserCode() 最終更新者を取得します。
String | FavoriteMenuBaseModel.getRecordDate() 最終更新日を取得します。
String | CalendarInfoInternationalModel.getDisplayName() データ表示名を取得します。
void | CalendarInfoInternationalModel.setDisplayName(String displayName) データ表示名を設定します。
String | CalendarInfoBaseModel.getCalendarId() カレンダーIDを取得します。
String | CalendarInfoBaseModel.getDataId() データIDを取得します。
String | CalendarInfoBaseModel.getDataType() データタイプを取得します。
void | CalendarInfoBaseModel.setDataType(String dataType) データタイプを設定します。
String | CalendarInfoBaseModel.getDataName() データ名称を取得します。
void | CalendarInfoBaseModel.setDataName(String dataName) データ名称を設定します。
int | CalendarInfoBaseModel.getYear() 年を取得します。
void | CalendarInfoBaseModel.setYear(int year) 年を設定します。
int | CalendarInfoBaseModel.getMonth() 月を取得します。
void | CalendarInfoBaseModel.setMonth(int month) 月を設定します。
int | CalendarInfoBaseModel.getDay() 日を取得します。
void | CalendarInfoBaseModel.setDay(int day) 日を設定します。
int | CalendarInfoBaseModel.getWeek() 週を取得します。
void | CalendarInfoBaseModel.setWeek(int week) 週を設定します。
int | CalendarInfoBaseModel.getTimes() 次を取得します。
void | CalendarInfoBaseModel.setTimes(int times) 次を設定します。
int | CalendarInfoBaseModel.getDayWeek() 曜日を取得します。
void | CalendarInfoBaseModel.setDayWeek(int dayWeek) 曜日を設定します。
int | CalendarInfoBaseModel.getValidStartYear() 有効開始年を取得します。
void | CalendarInfoBaseModel.setValidStartYear(int validStartYear) 有効開始年を設定します。
int | CalendarInfoBaseModel.getValidEndYear() 有効終了年を取得します。
void | CalendarInfoBaseModel.setValidEndYear(int validEndYear) 有効終了年を設定します。
String | CalendarInfoBaseModel.getPluginMethod() プラグイン関数を取得します。
void | CalendarInfoBaseModel.setPluginMethod(String pluginMethod) プラグイン関数を設定します。
String | CalendarInfoBaseModel.getColor() 表示色を取得します。
void | CalendarInfoBaseModel.setColor(String color) 表示色を設定します。
String | CalendarInfoBaseModel.getRecordUserCode() 最終更新者を取得します。
String | CalendarInfoBaseModel.getRecordDate() 最終更新日を取得します。
String | CalendarInfoBaseModel.getDisplayName() データ表示名を取得します。
String | CalendarInfoBaseModel.getDisplayName(Locale locale) データ表示名を取得します。
void | CalendarInfoBaseModel.setDisplayName(String displayName) データ表示名を設定します。
void | CalendarInfoBaseModel.setDisplayName(String displayName, Locale locale) データ表示名を設定します。
String | BatchBaseModel.getBatchId() バッチIDを取得します。
String | BatchBaseModel.getBatchName() バッチ名を取得します。
void | BatchBaseModel.setBatchName(String batchName) バッチ名を設定します。
String | BatchBaseModel.getProgramLanguage() 実行プログラム言語を取得します。
void | BatchBaseModel.setProgramLanguage(String programLanguage) 実行プログラム言語を設定します。
String | BatchBaseModel.getProgramPath() 実行プログラムパスを取得します。
void | BatchBaseModel.setProgramPath(String programPath) 実行プログラムパスを設定します。
int | BatchBaseModel.getRunYear() 実行年を取得します。
void | BatchBaseModel.setRunYear(int runYear) 実行年を設定します。
int | BatchBaseModel.getRunMonth() 実行月を取得します。
void | BatchBaseModel.setRunMonth(int runMonth) 実行月を設定します。
int | BatchBaseModel.getRunDay() 実行日を取得します。
void | BatchBaseModel.setRunDay(int runDay) 実行日を設定します。
int | BatchBaseModel.getRunDayWeek() 実行曜日を取得します。
void | BatchBaseModel.setRunDayWeek(int runDayWeek) 実行曜日を設定します。
int | BatchBaseModel.getRunHour() 実行時を取得します。
void | BatchBaseModel.setRunHour(int runHour) 実行時を設定します。
int | BatchBaseModel.getRunMinute() 実行分を取得します。
void | BatchBaseModel.setRunMinute(int runMinute) 実行分を設定します。
int | BatchBaseModel.getRunSecond() 実行秒を取得します。
void | BatchBaseModel.setRunSecond(int runSecond) 実行秒を設定します。
String | BatchBaseModel.getValidFlg() 有効フラグを取得します。
void | BatchBaseModel.setValidFlg(String validFlg) 有効フラグを設定します。
String | BatchBaseModel.getRecordUserCode() 最終更新者を取得します。
String | BatchBaseModel.getRecordDate() 最終更新日を取得します。
String | AccountRoleBaseModel.getUserId() ユーザIDを取得します。
String | AccountRoleBaseModel.getRoleId() メニューIDを取得します。
String | AccountRoleBaseModel.getValidStartDate() 有効開始日を取得します。
void | AccountRoleBaseModel.setValidStartDate(String validStartDate) 有効開始日を設定します。
String | AccountRoleBaseModel.getValidEndDate() 有効終了日を取得します。
void | AccountRoleBaseModel.setValidEndDate(String validEndDate) 有効終了日を設定します。
String | AccountRoleBaseModel.getRecordUserCode() 最終更新者を取得します。
String | AccountRoleBaseModel.getRecordDate() 最終更新日を取得します。
String | AccountBaseModel.getUserId() ユーザIDを取得します。
String | AccountBaseModel.getLocale() ロケールを取得します。
void | AccountBaseModel.setLocale(String locale) ロケールを設定します。
String | AccountBaseModel.getEncoding() エンコーディングを取得します。
void | AccountBaseModel.setEncoding(String encoding) エンコーディングを設定します。
String | AccountBaseModel.getPassword() パスワードを取得します。
void | AccountBaseModel.setPassword(String password) パスワードを設定します。
String | AccountBaseModel.getMobilePassword() モバイル用パスワードを取得します。
void | AccountBaseModel.setMobilePassword(String mobilePassword) モバイル用パスワードを設定します。
String | AccountBaseModel.getNotes() 説明を取得します。
void | AccountBaseModel.setNotes(String notes) 説明を設定します。
String | AccountBaseModel.getValidStartDate() 有効開始日を取得します。
void | AccountBaseModel.setValidStartDate(String validStartDate) 有効開始日を設定します。
String | AccountBaseModel.getValidEndDate() 有効終了日を取得します。
void | AccountBaseModel.setValidEndDate(String validEndDate) 有効終了日を設定します。
String | AccountBaseModel.getGoOut() 外出フラグを取得します。
void | AccountBaseModel.setGoOut(String goOut) 外出フラグを設定します。
String | AccountBaseModel.getLockDate() アカウントロック日付を取得します。
void | AccountBaseModel.setLockDate(String lockDate) アカウントロック日付を設定します。
int | AccountBaseModel.getLoginFailureCount() ログイン失敗回数を取得します。
void | AccountBaseModel.setLoginFailureCount(int loginFailureCount) ログイン失敗回数を設定します。
String | AccountBaseModel.getPagePatternId() メインページパターンを取得します。
void | AccountBaseModel.setPagePatternId(String pagePatternId) メインページパターンを設定します。
String | AccountBaseModel.getColorPatternId() ページカラーパターンを取得します。
void | AccountBaseModel.setColorPatternId(String colorPatternId) ページカラーパターンを設定します。
String | AccountBaseModel.getRecordUserCode() 最終更新者を取得します。
String | AccountBaseModel.getRecordDate() 最終更新日を取得します。
String | AccountAttributeBaseModel.getUserId() ユーザIDを取得します。
String | AccountAttributeBaseModel.getAttributeName() 属性キーを取得します。
String | AccountAttributeBaseModel.getAttributeValue() 属性値を取得します。
void | AccountAttributeBaseModel.setAttributeValue(String attributeValue) 属性値を設定します。
String | AccountAttributeBaseModel.getRecordUserCode() 最終更新者を取得します。
String | AccountAttributeBaseModel.getRecordDate() 最終更新日を取得します。
String | AccessControllerRoleBaseModel.getAccessControllerId() アクセスコントローラIDを取得します。
String | AccessControllerRoleBaseModel.getRoleId() ロールCDを取得します。
String | AccessControllerRoleBaseModel.getRecordUserCode() 最終更新者を取得します。
String | AccessControllerRoleBaseModel.getRecordDate() 最終更新日を取得します。
String | AccessControllerPublicGroupBaseModel.getAccessControllerId() アクセスコントローラIDを取得します。
String | AccessControllerPublicGroupBaseModel.getPublicGroupSetCd() グループセットCDを取得します。
String | AccessControllerPublicGroupBaseModel.getPublicGroupCd() グルーピングCDを取得します。
String | AccessControllerPublicGroupBaseModel.getRecordUserCode() 最終更新者を取得します。
String | AccessControllerPublicGroupBaseModel.getRecordDate() 最終更新日を取得します。
String | AccessControllerPostBaseModel.getAccessControllerId() アクセスコントローラIDを取得します。
String | AccessControllerPostBaseModel.getCompanyCd() 会社CDを取得します。
String | AccessControllerPostBaseModel.getPostCd() 役職CDを取得します。
String | AccessControllerPostBaseModel.getRecordUserCode() 最終更新者を取得します。
String | AccessControllerPostBaseModel.getRecordDate() 最終更新日を取得します。
String | AccessControllerDepartmentBaseModel.getAccessControllerId() アクセスコントローラIDを取得します。
String | AccessControllerDepartmentBaseModel.getCompanyCd() 会社CDを取得します。
String | AccessControllerDepartmentBaseModel.getDepartmentCd() 組織CDを取得します。
String | AccessControllerDepartmentBaseModel.getRecordUserCode() 最終更新者を取得します。
String | AccessControllerDepartmentBaseModel.getRecordDate() 最終更新日を取得します。
String | AccessControllerBaseModel.getAccessControllerId() アクセスコントローラIDを取得します。
String | AccessControllerBaseModel.getAccessControllerName() アクセスコントローラ名を取得します。
void | AccessControllerBaseModel.setAccessControllerName(String accessControllerName) アクセスコントローラ名を設定します。
String | AccessControllerBaseModel.getNotes() 説明を取得します。
void | AccessControllerBaseModel.setNotes(String notes) 説明を設定します。
String | AccessControllerBaseModel.getRecordUserCode() 最終更新者を取得します。
String | AccessControllerBaseModel.getRecordDate() 最終更新日を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException の使用

AccessorIllegalPropertyValueException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor 情報を扱うためのアクセサを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での AccessorIllegalPropertyValueException の使用

AccessorIllegalPropertyValueException をスローする jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
void | TerminableInternationalAccessor.setProperty(String prop, Object value) プロパティを設定します。
void | TerminableAccessor.setProperty(String prop, Object value) プロパティを設定します。
void | InternationalAccessor.setProperty(String prop, Object value) プロパティを設定します。
void | ExtendedTerminableInternationalAccessor.setProperty(String prop, Object value) プロパティを設定します。
void | ExtendedTerminableAccessor.setProperty(String prop, Object value) プロパティを設定します。
void | ExtendedInternationalAccessor.setProperty(String prop, Object value) プロパティを設定します。
void | ExtendedBaseAccessor.setProperty(String prop, Object value) プロパティを設定します。
void | BaseAccessor.setProperty(String prop, Object value) プロパティを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException の使用

jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.BatchProcessException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.BatchProcessException の使用

BatchProcessException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exporter | アプリケーション共通マスタのエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.common.config | エクスポート設定の解釈を行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer | アプリケーション共通マスタのインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.common.config | インポート定義情報の解釈を行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.exporter での BatchProcessException の使用

jp.co.intra_mart.foundation.datastore.exporter での BatchProcessException のサブクラス
 class ExportInitializeException
エクスポートの初期化でエラーが発生したことを示すためにスローされます。

jp.co.intra_mart.foundation.datastore.exporter.common.config での BatchProcessException の使用

jp.co.intra_mart.foundation.datastore.exporter.common.config での BatchProcessException のサブクラス
 class ExportConfigurationReaderException
エクスポート設定の読み込みでエラーが発生したことを示すためにスローされます。

jp.co.intra_mart.foundation.datastore.importer での BatchProcessException の使用

jp.co.intra_mart.foundation.datastore.importer での BatchProcessException のサブクラス
 class ImportInitializeException
インポートの初期化で何らかのエラーが発生したことを示すためにスローされます。

jp.co.intra_mart.foundation.datastore.importer.common.config での BatchProcessException の使用

jp.co.intra_mart.foundation.datastore.importer.common.config での BatchProcessException のサブクラス
 class ImportConfigurationReaderException
インポート設定の読み込みでエラーが発生したことを示すためにスローされます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.BatchSystemException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.BatchSystemException の使用

jp.co.intra_mart.foundation.datastore.exception.BatchSystemException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException の使用

DataNotFoundException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での DataNotFoundException の使用

DataNotFoundException をスローする jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
Object | TerminableInternationalAccessor.getProperty(String prop) プロパティを取得します。
Object | TerminableAccessor.getProperty(String prop) プロパティを取得します。
Object | InternationalAccessor.getProperty(String prop) プロパティを取得します。
Object | ExtendedTerminableInternationalAccessor.getProperty(String prop) プロパティを取得します。
Object | ExtendedTerminableAccessor.getProperty(String prop) プロパティを取得します。
Object | ExtendedInternationalAccessor.getProperty(String prop) プロパティを取得します。
Object | ExtendedBaseAccessor.getProperty(String prop) プロパティを取得します。
Object | BaseAccessor.getProperty(String prop) プロパティを取得します。

jp.co.intra_mart.foundation.datastore.exception での DataNotFoundException の使用

jp.co.intra_mart.foundation.datastore.exception での DataNotFoundException のサブクラス
class | IllegalLocaleException アクセサが保持する言語に関する例外クラス アクセサが保持していない言語を要求された場合にスローする。
class | IllegalTermException アクセサが保持する期間に関する例外クラス アクセサが保持しない日時または期間が指定されたときにスローする。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException の使用

DataStoreApplicationException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。
jp.co.intra_mart.foundation.navigator |

jp.co.intra_mart.foundation.datastore.exception での DataStoreApplicationException の使用

jp.co.intra_mart.foundation.datastore.exception での DataStoreApplicationException のサブクラス
class | AccessorClosedException アクセサのクローズ時に発生する例外クラス アクセサがクローズされている場合に、以下のメソッドを呼び出された時にスローする。
class | AccessorException アクセサで発生する例外の基底クラス
class | AccessorIllegalPropertyValueException アクセサのプロパティ設定に関する例外クラス アクセサに不正な値が設定された場合にスローする。
class | DataNotFoundException アクセサのプロパティ値の取得に関する例外クラス 指定されたプロパティに対する値が設定されていない場合にスローする。
class | IllegalExtensionException 拡張アクセサに関する例外クラス 拡張アクセサに対して不正な操作が行われた場合にスローする。
class | IllegalLocaleException アクセサが保持する言語に関する例外クラス アクセサが保持していない言語を要求された場合にスローする。
class | IllegalRelationshipException リレーションシップに関する例外クラス リレーションシップの整合性が正しくない場合にスローする。
class | IllegalTermException アクセサが保持する期間に関する例外クラス アクセサが保持しない日時または期間が指定されたときにスローする。
class | ManagerException マネージャに関する例外クラス
class | MapperException マッパーに関する例外クラス マッパーの処理中に問題が発生した場合にスローする。
class | TermManagerException 期間に関する例外クラス

jp.co.intra_mart.foundation.navigator での DataStoreApplicationException の使用

jp.co.intra_mart.foundation.navigator での DataStoreApplicationException のサブクラス
 class EventNavigatorException
イベントナビゲータマネージャに関する例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException の使用

jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException の使用

DataStoreSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。

jp.co.intra_mart.foundation.datastore.common.model での DataStoreSystemException の使用

DataStoreSystemException をスローする jp.co.intra_mart.foundation.datastore.common.model のメソッド
 TerminableModel GenericTerminableModelMap.newTerminableModel(Term term)
初期化されていない期間化モデルのインスタンスを取得します。

jp.co.intra_mart.foundation.datastore.exception での DataStoreSystemException の使用

jp.co.intra_mart.foundation.datastore.exception での DataStoreSystemException のサブクラス
class | AccessorSystemException アクセサのプロパティに関する例外クラス 指定されたプロパティがアクセサに存在しない場合にスローする。
class | DataStoreConfigException アプリケーション共通マスタの設定に関する例外クラス アプリケーション共通マスタの設定に不整合がある場合にスローする。
class | MapperDAOException マッパーのデータベース接続に関する例外クラス マッパーがデータベース接続で問題が発生した場合にスローする。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException の使用

IllegalExtensionException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での IllegalExtensionException の使用

IllegalExtensionException をスローする jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
ExtendedTerminableInternationalAccessor | ExtendedTerminableInternationalAccessorMap.createExtendedTerminableInternationalAccessor(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を生成します。
ExtendedTerminableInternationalAccessor | ExtendedTerminableInternationalAccessorMap.findExtendedTerminableInternationalAccessor(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を取得します。
ExtendedTerminableAccessor | ExtendedTerminableAccessorMap.createExtendedTerminableAccessor(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を生成します。
ExtendedTerminableAccessor | ExtendedTerminableAccessorMap.findExtendedTerminableAccessor(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を取得します。
ExtendedInternationalAccessor | ExtendedInternationalAccessorMap.createExtendedInternationalAccessor(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を生成します。
ExtendedInternationalAccessor | ExtendedInternationalAccessorMap.findExtendedInternationalAccessor(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を取得します。
ExtendedBaseAccessor | ExtendedBaseAccessorMap.createExtendedBaseAccessor(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を生成します。
ExtendedBaseAccessor | ExtendedBaseAccessorMap.findExtendedBaseAccessor(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を取得します。

jp.co.intra_mart.foundation.datastore.common.model での IllegalExtensionException の使用

IllegalExtensionException をスローする jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedTerminableModel | ExtendedGenericTerminableModelMap.newExtendedTerminableModel(String name) 初期化されてていない拡張期間化モデルのインスタンスを取得します。
ExtendedTerminableInternationalModel | ExtendedGenericTerminableInternationalModelMap.newExtendedTerminableInternationalModel(String name) 初期化されていない拡張期間国際化モデルのインスタンスを取得します。
ExtendedBaseModel | ExtendedGenericBaseModelMap.newExtendedBaseModel(String name) 初期化されていない拡張基本モデルのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException の使用

IllegalLocaleException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.category | 商品カテゴリ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail | 商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.attribute | 商品属性情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.item | 商品情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.system.security.datastore.inf |

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.category.category_class のメソッド
 CateogryClassInternationalModel CateogryClassBaseModel.selectCateogryClassInternationalModel(Locale locale)
指定された言語に該当する分類区分の国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.category.detail での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.category.detail のメソッド
 CategoryDetailInternationalModel CategoryDetailBaseModel.selectCategoryDetailInternationalModel(Locale locale)
指定された言語に該当する分類区分詳細の国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.company.department での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.department のメソッド
 DepartmentTerminableInternationalModel DepartmentTerminableModel.selectDepartmentTerminableInternationalModel(Locale locale)
指定された言語に該当する組織の期間国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.company.post での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.post のメソッド
 CompanyPostTerminableInternationalModel CompanyPostTerminableModel.selectCompanyPostTerminableInternationalModel(Locale locale)
指定された言語に該当する役職の期間国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.category での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.item_category.category のメソッド
 ItemCategoryInternationalModel ItemCategoryBaseModel.selectItemCategoryInternationalModel(Locale locale)
指定された言語に該当する商品カテゴリの国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.item_template.detail のメソッド
 ItemTemplateDetailInternationalModel ItemTemplateDetailBaseModel.selectItemTemplateDetailInternationalModel(Locale locale)
指定された言語に該当する商品属性テンプレート明細の国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.item.attribute での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.item.attribute のメソッド
 ItemAttributeInternationalModel ItemAttributeBaseModel.selectItemAttributeInternationalModel(Locale locale)
指定された言語に該当する商品属性の国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.item.item での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.item.item のメソッド
 ItemTerminableInternationalModel ItemTerminableModel.selectItemTerminableInternationalModel(Locale locale)
指定された言語に該当する商品の期間国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.group のメソッド
 PublicGroupTerminableInternationalModel PublicGroupTerminableModel.selectPublicGroupTerminableInternationalModel(Locale locale)
指定された言語に該当するパブリックグループの期間国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.user での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.user のメソッド
 UserTerminableInternationalModel UserTerminableModel.selectUserTerminableInternationalModel(Locale locale)
指定された言語に該当するユーザの期間国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.common.accessor での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
TerminableInternationalAccessor | TerminableInternationalAccessorMap.createTerminableInternationalAccessor(Locale locale) 期間国際化アクセサを生成します。
TerminableInternationalAccessor | TerminableInternationalAccessorMap.findTerminableInternationalAccessor(Locale locale) 指定された言語に該当する期間国際化アクセサを取得します。
void | TerminableInternationalAccessorMap.remove(Locale locale) 指定された言語に該当するデータを削除します。
InternationalAccessor | InternationalAccessorMap.createInternationalAccessor(Locale locale) 国際化アクセサを生成します。
InternationalAccessor | InternationalAccessorMap.findInternationalAccessor(Locale locale) 指定された言語に該当する国際化アクセサを取得します。
void | InternationalAccessorMap.remove(Locale locale) 指定された言語に該当するデータを削除します。

jp.co.intra_mart.foundation.datastore.common.model での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableInternationalModel | TerminableInternationalModelMap.findTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
InternationalModel | InternationalModelMap.findInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。
protected TerminableInternationalModel | GenericTerminableModel.selectTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
TerminableInternationalModel | GenericTerminableInternationalModelMap.findTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
TerminableInternationalModel | GenericTerminableInternationalModelMap.newTerminableInternationalModel(Locale locale) 初期化されていない期間国際化モデルのインスタンスを取得します。
InternationalModel | GenericInternationalModelMap.findInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。
InternationalModel | GenericInternationalModelMap.newInternationalModel(Locale locale) 初期化されていない国際化モデルのインスタンスを取得します。
protected InternationalModel | GenericBaseModel.selectInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。

jp.co.intra_mart.system.security.datastore.inf での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.system.security.datastore.inf のメソッド
RoleInternationalModel | RoleBaseModel.selectRoleInternationalModel(Locale locale) 指定された言語に該当するロールの国際化モデルを取得します。
MenuInternationalModel | MenuBaseModel.selectMenuInternationalModel(Locale locale) 指定された言語に該当するメニュー情報の国際化モデルを取得します。
CalendarInfoInternationalModel | CalendarInfoBaseModel.selectCalendarInfoInternationalModel(Locale locale) 指定された言語に該当するカレンダーが保有するデータの国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException の使用

jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.IllegalTermException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.IllegalTermException の使用

IllegalTermException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.deal | 取扱情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.detail | 取扱詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.item | 商品情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.attach での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.attach のメソッド
 DepartmentAttachTerminableModel DepartmentAttachBaseModel.selectDepartmentAttachTerminableModel(Date date)
指定された日付に該当する組織所属の期間化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.company.department での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.department のメソッド
 DepartmentTerminableModel DepartmentBaseModel.selectDepartmentTerminableModel(Date date)
指定された日付に該当する組織の期間化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.company.main での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.main のメソッド
 DepartmentMainTerminableModel DepartmentMainBaseModel.selectDepartmentMainTerminableModel(Date date)
指定された日付に該当する主所属の期間化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.company.post での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.post のメソッド
 CompanyPostTerminableModel CompanyPostBaseModel.selectCompanyPostTerminableModel(Date date)
指定された日付に該当する役職の期間化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.deal.deal での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.application.model.deal.deal のメソッド
 DealTerminableModel DealBaseModel.selectDealTerminableModel(Date date)
指定された日付に該当する取扱の期間化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.deal.detail での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.application.model.deal.detail のメソッド
 DealDetailTerminableModel DealDetailBaseModel.selectDealDetailTerminableModel(Date date)
指定された日付に該当する取扱詳細の期間化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.item.item での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.application.model.item.item のメソッド
 ItemTerminableModel ItemBaseModel.selectItemTerminableModel(Date date)
指定された日付に該当する商品の期間化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.group のメソッド
 PublicGroupTerminableModel PublicGroupBaseModel.selectPublicGroupTerminableModel(Date date)
指定された日付に該当するパブリックグループの期間化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.user での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.application.model.user のメソッド
 UserTerminableModel UserBaseModel.selectUserTerminableModel(Date date)
指定された日付に該当するユーザの期間化モデルを取得します。

jp.co.intra_mart.foundation.datastore.common.accessor での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 TerminableAccessor TerminableAccessorMap.createTerminableAccessor(Term term)
指定した期間に期間化アクセサを生成します。

jp.co.intra_mart.foundation.datastore.common.model での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableModel | TerminableModelMap.findTerminableModel(Date date) 指定された日付に該当する期間化モデルを取得します。
TerminableModel | GenericTerminableModelMap.findTerminableModel(Date date) 指定された日時に該当する期間化モデルを取得します。
protected TerminableModel | GenericBaseModel.selectTerminableModel(Date date) 指定された日時に該当する期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.ImportException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.ImportException の使用

ImportException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item | 商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category | 商品カテゴリ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_template | 商品テンプレート属性情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での ImportException の使用

ImportException をスローする jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
void | StandardCompanyPostImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。
void | StandardCompanyImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。
void | CompanyPostImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。
void | CompanyImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。

jp.co.intra_mart.foundation.datastore.application.domain.item での ImportException の使用

ImportException をスローする jp.co.intra_mart.foundation.datastore.application.domain.item のメソッド
void | StandardItemImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。
void | ItemImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。

jp.co.intra_mart.foundation.datastore.application.domain.item_category での ImportException の使用

ImportException をスローする jp.co.intra_mart.foundation.datastore.application.domain.item_category のメソッド
void | StandardItemCategoryImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。
void | StandardItemAttachImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。
void | ItemCategoryImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。
void | ItemAttachImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。

jp.co.intra_mart.foundation.datastore.application.domain.item_template での ImportException の使用

ImportException をスローする jp.co.intra_mart.foundation.datastore.application.domain.item_template のメソッド
void | StandardItemTemplateImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。
void | ItemTemplateImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での ImportException の使用

ImportException をスローする jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
void | StandardPublicGroupImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。
void | PublicGroupImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。

jp.co.intra_mart.foundation.datastore.application.domain.user での ImportException の使用

ImportException をスローする jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
void | UserImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。
void | StandardUserImporter.doImport(InputStream inputStream, String user, String group) インポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.ManagerException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.ManagerException の使用

ManagerException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category | 分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.currency | 通貨情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item | 商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category | 商品カテゴリ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_template | 商品テンプレート属性情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group | プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.unit | 商品単位情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.category での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.category のメソッド
static CategoryManager | CategoryManager.getCategoryManager(String user, String group) CategoryManagerを取得します。
protected abstract void | CategoryManager.init(String user, String group) CategoryManagerを初期化します。
abstract void | CategoryManager.addCategoryDetail(CategoryDetail categoryDetail) 分類区分詳細を登録します。
abstract void | CategoryManager.updateCategoryDetail(CategoryDetail categoryDetail) 登録済の分類区分詳細を更新します。
abstract void | CategoryManager.deleteCategoryDetail(CategoryDetail categoryDetail) 登録済の分類区分詳細を削除します。
abstract CategoryDetail[] | CategoryManager.getCategoryDetails() 登録済みの分類区分詳細情報の一覧を取得します。
abstract CategoryDetail[] | CategoryManager.getCategoryDetails(String categoryClassCode) 登録済みの分類区分詳細情報の一覧を取得します。
abstract CategoryDetail | CategoryManager.getCategoryDetail(String categoryClassCode, String categoryCode) 登録済みの分類区分詳細情報を取得します。

jp.co.intra_mart.foundation.datastore.application.domain.company での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
static CompanyManager | CompanyManager.getCompanyManager(String user, String group) CompanyManagerを取得します。
protected abstract void | CompanyManager.init(String user, String group) CompanyManagerを初期化します。
abstract Department | CompanyManager.getDepartment(String company, String department) 登録済の組織を取得します。
abstract void | CompanyManager.addCompany(Company company) 会社を登録します。
abstract void | CompanyManager.deleteCompany(Company company) 登録済の会社を削除します。
abstract void | CompanyManager.addDepartment(Department department) 組織を登録します。
abstract void | CompanyManager.updateDepartment(Department department) 登録済の組織情報を更新します。
abstract void | CompanyManager.deleteDepartment(Department department) 登録済の組織情報を削除します。
abstract void | CompanyManager.joinDepartment(String company, String parentDepartment, String department, String version) 組織構成に組織を登録します。
abstract void | CompanyManager.moveDepartment(String company, String parentDepartment, String department, String version) 組織構成に登録済の組織情報を移動します。
abstract void | CompanyManager.leaveDepartment(String company, String department, String version) 組織構成から組織情報を離脱させます。
abstract void | CompanyManager.setCategoryDetail(CompanyCategory category) 組織に対して指定された分類区分情報を設定します。
abstract void | CompanyManager.removeCategoryDetail(CompanyCategory category) 組織に対して指定された分類区分情報を削除します。
abstract void | CompanyManager.setMember(DepartmentAttach attach) 組織に人員を割り当てます。
abstract void | CompanyManager.deleteMember(DepartmentAttach attach) 組織から人員をはずします。
abstract User[] | CompanyManager.getMember(String company, String department) 現在、組織に所属するる人員の一覧を取得します。
abstract User[] | CompanyManager.getMember(String company, String department, Date date) 指定された日付に組織に所属する人員の一覧を取得します。
abstract void | CompanyManager.setMain(DepartmentMain main) ユーザが主所属する組織を設定します。
abstract void | CompanyManager.removeMain(DepartmentMain main) 指定されたユーザの主所属を削除します。
abstract void | CompanyManager.addVersion(CompanyVersion version) 会社構成バージョンを新規に登録します。
abstract void | CompanyManager.updateVersion(CompanyVersion version) 登録済の会社構成バージョンを更新します。
abstract void | CompanyManager.deleteVersion(CompanyVersion version) 登録済の会社構成バージョンを削除します。
abstract void | CompanyManager.copyVersion(String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンの内容をコピーします。
abstract DepartmentStruct[] | CompanyManager.getDepartmentStructs(String company, String department, Date date, Locale locale) 組織の階層構造を取得します。
abstract Department[] | CompanyManager.getAttachedDepartments(String user) 現在、ユーザが所属している組織の一覧を取得します。
abstract Department[] | CompanyManager.getAttachedDepartments(String user, Date date) 指定された日付にユーザが所属している組織の一覧を取得します。
abstract DepartmentAttach | CompanyManager.getDepartmentAttach(String user, String company, String department) ユーザの組織への所属情報を取得します。
abstract DepartmentMain | CompanyManager.getDepartmentMain(String user) ユーザの主所属情報を取得します。
abstract void | CompanyManager.addPost(CompanyPost post) 役職を登録します。
abstract void | CompanyManager.updatePost(CompanyPost post) 登録済の役職情報を更新します。
abstract void | CompanyManager.deletePost(CompanyPost post) 登録済の役職情報を削除します。
abstract CompanyVersion | CompanyManager.getVersion(String company) 現在の会社構成バージョン情報を取得します。
abstract CompanyVersion | CompanyManager.getVersion(String company, Date date) 指定された日付の会社構成バージョン情報を取得します。

jp.co.intra_mart.foundation.datastore.application.domain.currency での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.currency のメソッド
static CurrencyManager | CurrencyManager.getCurrencyManager(String user, String group) CurrencyManagerを取得します。
protected abstract void | CurrencyManager.init(String user, String group) CurrencyManagerを初期化します。
abstract String | CurrencyManager.getSystemCurrencyCode() システム通貨コードを返します。
abstract String[] | CurrencyManager.getCurrencyCodes() 通貨コードの一覧を返します。
abstract String | CurrencyManager.getCurrencyName(String currencyCode, Locale locale) 通貨コードに対する名称を指定された言語で返します。
abstract Map | CurrencyManager.getCurrencyName(String currencyCode) 指定された通貨コードに対する名称を返します。

jp.co.intra_mart.foundation.datastore.application.domain.deal での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.deal のメソッド
static DealPermissionManager | DealPermissionManager.getDealPermissionManager(String user, String group) DealPermissionManagerを取得します。
protected abstract void | DealPermissionManager.init(String user, String group) DealPermissionManagerを初期化します。
abstract void | DealPermissionManager.setPermissionToDepartment(DealerDepartment dealer) 組織に対してアクセス権を設定します。
abstract void | DealPermissionManager.setPermissionToPublicGroup(DealerPublicGroup dealer) パブリックグループに対してアクセス権を設定します。
abstract void | DealPermissionManager.setPermissionToRole(DealerRole dealer) ロールに対してアクセス権を設定します。
abstract void | DealPermissionManager.removePermissionFromDepartment(DealerDepartment dealer) 組織からアクセス権を削除します。
abstract void | DealPermissionManager.removePermissionFromPublicGroup(DealerPublicGroup dealer) パブリックグループからアクセス権を削除します。
abstract void | DealPermissionManager.removePermissionFromRole(DealerRole dealer) ロールからアクセス権を削除します。
abstract Department[] | DealPermissionManager.getDepartments(Deal deal) 取扱情報を保有するアクセス権をもつ組織を返します。
abstract PublicGroup[] | DealPermissionManager.getPublicGroups(Deal deal) 取扱情報を保有するアクセス権をもつパブリックグループを返します。
abstract Role[] | DealPermissionManager.getRoles(Deal deal) 取扱情報を保有するアクセス権をもつロールを返します。
static DealManager | DealManager.getDealManager(String user, String group) DealManagerを取得します。
protected abstract void | DealManager.init(String user, String group) DealManagerを初期化します。
abstract void | DealManager.addDeal(Deal deal) 取扱情報を新規登録します。
abstract void | DealManager.updateDeal(Deal deal) 取扱情報を更新します。
abstract void | DealManager.deleteDeal(Deal deal) 取扱情報を削除します。
abstract Deal[] | DealManager.getDeals() 現在、存在する取扱情報を返します。
abstract Deal[] | DealManager.getDeals(Date date) 指定された日付に存在する取扱情報を返します。
abstract Deal[] | DealManager.getDealsByKey(String itemCode, String companyCode, String departmentCode) 現在、存在する取扱情報の中で、商品と取引先から特定されるものを返します。
abstract Deal[] | DealManager.getDealsByKey(String itemCode, String companyCode, String departmentCode, Date date) 指定された日時に存在する取扱情報の中で、商品と取引先から特定されるものを返します。
abstract Deal[] | DealManager.getUsersDeals(String userCode) 現在、ユーザがアクセスできる取扱情報を返します。
abstract Deal[] | DealManager.getUsersDeals(String userCode, Date date) 指定された日付にユーザがアクセスできる取扱情報を返します。
abstract Deal[] | DealManager.getUsersDealsByKey(String userCode, String itemCode, String companyCode, String departmentCode) 現在、存在する取扱情報の中で、商品と取引先から特定されるものを返します。
abstract Deal[] | DealManager.getUsersDealsByKey(String userCode, String itemCode, String companyCode, String departmentCode, Date date) 指定された日時に存在する取扱情報の中で、商品と取引先から特定されるものを返します。

jp.co.intra_mart.foundation.datastore.application.domain.item での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.item のメソッド
static ItemManager | ItemManager.getItemManager(String user, String group) ItemManagerを取得します。
protected abstract void | ItemManager.init(String user, String group) ItemManagerを初期化します。
abstract void | ItemManager.addItem(Item item) 商品情報を新規登録します。
abstract void | ItemManager.updateItem(Item item) 商品情報を更新します。
abstract void | ItemManager.deleteItem(Item item) 商品情報を削除します。
abstract void | ItemManager.setCatalogue(ItemCatalogue catalogue) 商品カタログ情報を設定します。
abstract void | ItemManager.setCatalogue(ItemCatalogue catalogue, byte[] byteStream) 商品カタログ情報を設定します。
abstract void | ItemManager.deleteCatalogue(ItemCatalogue catalogue) 商品カタログ情報を削除します。
abstract String | ItemManager.getCatalogueMediaFileName(ItemCatalogue catalogue) 商品カタログの媒体が保存されてるファイルパスを取得します。
abstract void | ItemManager.setItemCatalogueMediaManager(ItemCatalogueMediaManager catalogueMediaManager) 商品カタログの媒体のマネジャーを設定します。
abstract Item[] | ItemManager.getItems() 現在、存在する商品の情報を返します。
abstract Item[] | ItemManager.getItems(Date date) 指定された日付に存在する商品の情報を返します。
abstract Item | ItemManager.getItem(String itemCode) 指定された商品コードに対する商品の情報を返します。
abstract Item[] | ItemManager.getItemsByKey(String code, String name) 現在、条件に合致する商品の情報を返します。
abstract Item[] | ItemManager.getItemsByKey(String code, String name, Date date) 指定された日付に条件に合致する商品の情報を返します。
abstract ItemCatalogue | ItemManager.getCatalogue(String itemCode, String catalogueCode) 指定されたカタログ情報を返します。
abstract ItemCatalogue[] | ItemManager.getCatalogues(String itemCode) 指定された商品のカタログ情報を返します。
abstract void | ItemManager.setAttribute(ItemAttribute attribute) 商品属性情報を設定します。
abstract void | ItemManager.removeAttribute(ItemAttribute attribute) 指定された商品属性情報を削除します。
abstract ItemAttribute[] | ItemManager.getAttributes(String itemCode) 指定された商品の属性情報を取得します。
void | ItemCatalogueMediaManager.save(String filePath, byte[] byteString) 商品カタログの媒体情報を保存します。
void | ItemCatalogueMediaManager.delete(String filePath) 商品カタログの媒体情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.item_category での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.item_category のメソッド
static ItemCategoryManager | ItemCategoryManager.getItemCategoryManager(String user, String group) ItemCategoryManagerを取得します。
protected abstract void | ItemCategoryManager.init(String user, String group) ItemCategoryManagerを初期化します。
abstract void | ItemCategoryManager.addCategory(ItemCategory category) 商品カテゴリを新規登録します。
abstract void | ItemCategoryManager.updateCategory(ItemCategory category) 商品カテゴリを更新します。
abstract void | ItemCategoryManager.deleteCategory(ItemCategory category) 商品カテゴリを削除します。
abstract void | ItemCategoryManager.setItem(ItemAttach attach) 商品カテゴリに商品を設定します。
abstract void | ItemCategoryManager.removeItem(ItemAttach attach) 商品カテゴリから商品を外します。
abstract ItemCategory[] | ItemCategoryManager.getCategoryTypes() 登録済の商品カテゴリ種別の一覧を返します。
abstract ItemCategoryStruct | ItemCategoryManager.getCategoryStruct(String categoryTypeCode) 指定された商品カテゴリ種別のカテゴリ階層を取得します。
abstract ItemCategory | ItemCategoryManager.getCategory(String categoryTypeCode, String categoryCode) 指定されたカテゴリコードに対する商品カテゴリの情報を返します。
abstract Item[] | ItemCategoryManager.getCategorizedItems(String categoryTypeCode, String categoryCode) 商品カテゴリに分類されている商品の情報を返します。
abstract Item[] | ItemCategoryManager.getAllCategorizedItems(String categoryTypeCode, String categoryCode) 商品カテゴリに分類されているすべての商品の情報を返します。
abstract boolean | ItemCategoryManager.isEndCategory(String categoryTypeCode, String categoryCode) 指定されたカテゴリコードに対する商品カテゴリが末端のカテゴリか調べます。

jp.co.intra_mart.foundation.datastore.application.domain.item_template での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.item_template のメソッド
static ItemTemplateManager | ItemTemplateManager.getItemTemplateManager(String user, String group) ItemTemplateManagerを取得します。
protected abstract void | ItemTemplateManager.init(String user, String group) ItemTemplateManagerを初期化します。
abstract void | ItemTemplateManager.addTemplate(ItemTemplate template) 商品属性テンプレート情報を新規登録します。
abstract void | ItemTemplateManager.updateTemplate(ItemTemplate template) 商品属性テンプレート情報を更新します。
abstract void | ItemTemplateManager.deleteTemplate(ItemTemplate template) 商品属性テンプレート情報を削除します。
abstract void | ItemTemplateManager.setTemplateDetail(ItemTemplateDetail detail) 商品属性テンプレート明細情報を設定します。
abstract void | ItemTemplateManager.deleteTemplateDetail(ItemTemplateDetail detail) 商品属性テンプレート明細情報を削除します。
abstract ItemTemplate[] | ItemTemplateManager.getTemplates(String key) 指定された検索条件に該当する商品属性テンプレート情報を返します。
abstract ItemTemplate | ItemTemplateManager.getTemplate(String templateCode) 指定された商品属性テンプレート情報を返します。
abstract ItemTemplateDetail[] | ItemTemplateManager.getTemplateDetail(String templateCode) 指定された商品属性テンプレートの明細情報を返します。

jp.co.intra_mart.foundation.datastore.application.domain.private_group での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.private_group のメソッド
static PrivateGroupManager | PrivateGroupManager.getPrivateGroupManager(String user, String group) PrivateGroupManagerを取得します。
protected abstract void | PrivateGroupManager.init(String user, String group) PrivateGroupManagerを初期化します。
abstract PrivateGroup | PrivateGroupManager.getPrivateGroup(String owner, String group) 登録済のプライベートグループを取得します。
abstract PrivateGroup[] | PrivateGroupManager.getPrivateGroups(String owner) 指定されたユーザが持つプライベートグループをすべて取得します。
abstract void | PrivateGroupManager.addPrivateGroup(PrivateGroup group) プライベートグループを登録します。
abstract void | PrivateGroupManager.updatePrivateGroup(PrivateGroup group) 登録済のプライベートグループ情報を更新します。
abstract void | PrivateGroupManager.deletePrivateGroup(PrivateGroup group) 登録済のプライベートグループ情報を削除します。
abstract void | PrivateGroupManager.setMember(PrivateGroupAttach member) プライベートグループに人員を割り当てます。
abstract void | PrivateGroupManager.deleteMember(PrivateGroupAttach member) プライベートグループから人員をはずします。
abstract User[] | PrivateGroupManager.getMember(String owner, String group) ログインユーザが持つ指定されたプライベートグループに所属する人員を取得します。
abstract User[] | PrivateGroupManager.getMember(String owner, String group, Date date) 指定されたプライベートグループに所属する人員を取得します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
static PublicGroupManager | PublicGroupManager.getPublicGroupManager(String user, String group) PublicGroupManagerを取得します。
protected abstract void | PublicGroupManager.init(String user, String group) PublicGroupManagerを初期化します。
abstract PublicGroup | PublicGroupManager.getPublicGroup(String groupSet, String publicGroup) 登録済のパブリックグループを取得します。
abstract void | PublicGroupManager.addGroupSet(PublicGroupSet groupSet) パブリックグループセットを登録します。
abstract void | PublicGroupManager.deleteGroupSet(PublicGroupSet groupSet) 登録済のパブリックグループセットを削除します。
abstract void | PublicGroupManager.addPublicGroup(PublicGroup publicGroup) パブリックグループを登録します。
abstract void | PublicGroupManager.updatePublicGroup(PublicGroup publicGroup) 登録済のパブリックグループ情報を更新します。
abstract void | PublicGroupManager.deletePublicGroup(PublicGroup publicGroup) 登録済のパブリックグループ情報を削除します。
abstract void | PublicGroupManager.joinPublicGroup(String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成にパブリックグループを登録します。
abstract void | PublicGroupManager.movePublicGroup(String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成に登録済のパブリックグループ情報を移動します。
abstract void | PublicGroupManager.leavePublicGroup(String groupSet, String publicGroup, String version) パブリックグループ構成からパブリックグループ情報を離脱させます。
abstract void | PublicGroupManager.setCategoryDetail(PublicGroupCategory category) パブリックグループに対して指定された分類区分情報を設定します。
abstract void | PublicGroupManager.removeCategoryDetail(PublicGroupCategory category) パブリックグループに対して指定された分類区分情報を削除します。
abstract void | PublicGroupManager.setMember(PublicGroupAttach attach) パブリックグループに人員を割り当てます。
abstract void | PublicGroupManager.deleteMember(PublicGroupAttach attach) パブリックグループから人員をはずします。
abstract User[] | PublicGroupManager.getMember(String groupSet, String publicGroup) 現在、パブリックグループに所属するる人員の一覧を取得します。
abstract User[] | PublicGroupManager.getMember(String groupSet, String publicGroup, Date date) 指定された日付にパブリックグループに所属する人員の一覧を取得します。
abstract void | PublicGroupManager.addVersion(PublicGroupVersion version) パブリックグループセット構成バージョンを新規に登録します。
abstract void | PublicGroupManager.updateVersion(PublicGroupVersion version) 登録済のパブリックグループセット構成バージョンを更新します。
abstract void | PublicGroupManager.deleteVersion(PublicGroupVersion version) 登録済のパブリックグループセット構成バージョンを削除します。
abstract void | PublicGroupManager.copyVersion(String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーします。
abstract PublicGroupStruct[] | PublicGroupManager.getPublicGroupStructs(String groupSet, String publicGroup, Date date, Locale locale) パブリックグループの階層構造を取得します。
abstract PublicGroup[] | PublicGroupManager.getAttachedPublicGroups(String user) 現在、ユーザが所属しているパブリックグループの一覧を取得します。
abstract PublicGroup[] | PublicGroupManager.getAttachedPublicGroups(String user, Date date) 指定された日付にユーザが所属しているパブリックグループの一覧を取得します。
abstract PublicGroupAttach | PublicGroupManager.getPublicGroupAttach(String user, String groupSet, String publicGroup) ユーザのパブリックグループへの所属情報を取得します。
abstract PublicGroupVersion | PublicGroupManager.getVersion(String groupSet) 現在のパブリックグループセット構成バージョン情報を取得します。
abstract PublicGroupVersion | PublicGroupManager.getVersion(String groupSet, Date date) 指定された日付のパブリックグループセット構成バージョン情報を取得します。

jp.co.intra_mart.foundation.datastore.application.domain.unit での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.unit のメソッド
static ItemUnitManager | ItemUnitManager.getItemUnitManager(String user, String group) ItemUnitManagerを取得します。
protected abstract void | ItemUnitManager.init(String user, String group) ItemUnitManagerを初期化します。
abstract Map | ItemUnitManager.getUnits() 単位の一覧を取得します。
abstract String | ItemUnitManager.getUnitName(String unitCode) 単位コードに対する名称を返します。
abstract String | ItemUnitManager.getUnitCode(String unitName) 単位名に対する単位コードを取得します。
abstract boolean | ItemUnitManager.addUnit(String unitCode, String unitName) 単位を追加します。
abstract boolean | ItemUnitManager.updateUnit(String unitCode, String unitName) 単位を更新します。
abstract void | ItemUnitManager.deleteUnit(String unitCode) 単位を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.user での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
static UserManager | UserManager.getUserManager(String user, String group) UserManagerを取得します。
protected abstract void | UserManager.init(String user, String group) UserManagerを初期化します。
abstract User | UserManager.getUser(String userCode) 登録済のユーザを取得します。
abstract void | UserManager.addUser(User user) ユーザを登録します。
abstract void | UserManager.updateUser(User user) 登録済のユーザを更新します。
abstract void | UserManager.deleteUser(User user) 登録済のユーザを削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.MapperDAOException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.MapperDAOException の使用

jp.co.intra_mart.foundation.datastore.exception.MapperDAOException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.MapperException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.MapperException の使用

MapperException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category | 会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company | 会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion | 組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version | 会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.deal | 取扱情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.department | 取扱組織権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.detail | 取扱詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group | 取扱パブリックグループ権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.role | 取扱ロール権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach | 商品分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.category | 商品カテゴリ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.type | 商品カテゴリ種別情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail | 商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.template | 商品テンプレート情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.attribute | 商品属性情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue | 商品カタログ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.item | 商品情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach | プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group | プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach | パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category | パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion | パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set | パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version | パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.unit | 単位情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.system.security.datastore.inf |

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.category.category_class のメソッド
CateogryClassBaseModel | CateogryClassMapper.create(String categoryClassCode) プライマリキーに該当する分類区分を生成します。
CateogryClassBaseModel | CateogryClassMapper.select(String categoryClassCode) プライマリーキーで特定される分類区分の基本モデルを取得します。
void | CateogryClassMapper.insert(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ挿入します。
void | CateogryClassMapper.insert(Collection models) 分類区分の基本モデルを複数挿入します。
void | CateogryClassMapper.update(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ更新します。
void | CateogryClassMapper.update(Collection models) 分類区分の基本モデルを複数更新します。
void | CateogryClassMapper.delete(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ削除します。
void | CateogryClassMapper.delete(Collection models) 分類区分の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.category.detail での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.category.detail のメソッド
CategoryDetailBaseModel | CategoryDetailMapper.create(String categoryClassCode, String categoryCode) プライマリキーに該当する分類区分詳細を生成します。
CategoryDetailBaseModel | CategoryDetailMapper.select(String categoryClassCode, String categoryCode) プライマリーキーで特定される分類区分詳細の基本モデルを取得します。
void | CategoryDetailMapper.insert(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ挿入します。
void | CategoryDetailMapper.insert(Collection models) 分類区分詳細の基本モデルを複数挿入します。
void | CategoryDetailMapper.update(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ更新します。
void | CategoryDetailMapper.update(Collection models) 分類区分詳細の基本モデルを複数更新します。
void | CategoryDetailMapper.delete(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ削除します。
void | CategoryDetailMapper.delete(Collection models) 分類区分詳細の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.company.attach での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.attach のメソッド
DepartmentAttachBaseModel | DepartmentAttachMapper.create(String userCode, String companyCode, String departmentCode) プライマリキーに該当する組織所属を生成します。
DepartmentAttachBaseModel | DepartmentAttachMapper.select(String userCode, String companyCode, String departmentCode) プライマリーキーで特定される組織所属の基本モデルを取得します。
void | DepartmentAttachMapper.insert(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ挿入します。
void | DepartmentAttachMapper.insert(Collection models) 組織所属の基本モデルを複数挿入します。
void | DepartmentAttachMapper.update(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ更新します。
void | DepartmentAttachMapper.update(Collection models) 組織所属の基本モデルを複数更新します。
void | DepartmentAttachMapper.delete(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ削除します。
void | DepartmentAttachMapper.delete(Collection models) 組織所属の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.company.category での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.category のメソッド
CompanyCategoryBaseModel | CompanyCategoryMapper.create(String companyCode, String departmentCode, String categoryClassCode, String categoryCode) プライマリキーに該当する会社組織分類を生成します。
CompanyCategoryBaseModel | CompanyCategoryMapper.select(String companyCode, String departmentCode, String categoryClassCode, String categoryCode) プライマリーキーで特定される会社組織分類の基本モデルを取得します。
void | CompanyCategoryMapper.insert(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ挿入します。
void | CompanyCategoryMapper.insert(Collection models) 会社組織分類の基本モデルを複数挿入します。
void | CompanyCategoryMapper.update(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ更新します。
void | CompanyCategoryMapper.update(Collection models) 会社組織分類の基本モデルを複数更新します。
void | CompanyCategoryMapper.delete(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ削除します。
void | CompanyCategoryMapper.delete(Collection models) 会社組織分類の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.company.company での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.company のメソッド
CompanyBaseModel | CompanyMapper.create(String companyCode) プライマリキーに該当する会社を生成します。
CompanyBaseModel | CompanyMapper.select(String companyCode) プライマリーキーで特定される会社の基本モデルを取得します。
void | CompanyMapper.insert(CompanyBaseModel model) 会社の基本モデルを1つだけ挿入します。
void | CompanyMapper.insert(Collection models) 会社の基本モデルを複数挿入します。
void | CompanyMapper.update(CompanyBaseModel model) 会社の基本モデルを1つだけ更新します。
void | CompanyMapper.update(Collection models) 会社の基本モデルを複数更新します。
void | CompanyMapper.delete(CompanyBaseModel model) 会社の基本モデルを1つだけ削除します。
void | CompanyMapper.delete(Collection models) 会社の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.company.department での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.department のメソッド
DepartmentBaseModel | DepartmentMapper.create(String companyCode, String departmentCode) プライマリキーに該当する組織を生成します。
DepartmentBaseModel | DepartmentMapper.select(String companyCode, String departmentCode) プライマリーキーで特定される組織の基本モデルを取得します。
void | DepartmentMapper.insert(DepartmentBaseModel model) 組織の基本モデルを1つだけ挿入します。
void | DepartmentMapper.insert(Collection models) 組織の基本モデルを複数挿入します。
void | DepartmentMapper.update(DepartmentBaseModel model) 組織の基本モデルを1つだけ更新します。
void | DepartmentMapper.update(Collection models) 組織の基本モデルを複数更新します。
void | DepartmentMapper.delete(DepartmentBaseModel model) 組織の基本モデルを1つだけ削除します。
void | DepartmentMapper.delete(Collection models) 組織の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.inclusion のメソッド
DepartmentInclusionBaseModel | DepartmentInclusionMapper.create(String companyCode, String versionCode, String parentDepartmentCode, String departmentCode) プライマリキーに該当する組織内包を生成します。
DepartmentInclusionBaseModel | DepartmentInclusionMapper.select(String companyCode, String versionCode, String parentDepartmentCode, String departmentCode) プライマリーキーで特定される組織内包の基本モデルを取得します。
void | DepartmentInclusionMapper.insert(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ挿入します。
void | DepartmentInclusionMapper.insert(Collection models) 組織内包の基本モデルを複数挿入します。
void | DepartmentInclusionMapper.update(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ更新します。
void | DepartmentInclusionMapper.update(Collection models) 組織内包の基本モデルを複数更新します。
void | DepartmentInclusionMapper.delete(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ削除します。
void | DepartmentInclusionMapper.delete(Collection models) 組織内包の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.company.main での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.main のメソッド
DepartmentMainBaseModel | DepartmentMainMapper.create(String userCode) プライマリキーに該当する主所属を生成します。
DepartmentMainBaseModel | DepartmentMainMapper.select(String userCode) プライマリーキーで特定される主所属の基本モデルを取得します。
void | DepartmentMainMapper.insert(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ挿入します。
void | DepartmentMainMapper.insert(Collection models) 主所属の基本モデルを複数挿入します。
void | DepartmentMainMapper.update(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ更新します。
void | DepartmentMainMapper.update(Collection models) 主所属の基本モデルを複数更新します。
void | DepartmentMainMapper.delete(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ削除します。
void | DepartmentMainMapper.delete(Collection models) 主所属の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.company.post での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.post のメソッド
CompanyPostBaseModel | CompanyPostMapper.create(String companyCode, String postCode) プライマリキーに該当する役職を生成します。
CompanyPostBaseModel | CompanyPostMapper.select(String companyCode, String postCode) プライマリーキーで特定される役職の基本モデルを取得します。
void | CompanyPostMapper.insert(CompanyPostBaseModel model) 役職の基本モデルを1つだけ挿入します。
void | CompanyPostMapper.insert(Collection models) 役職の基本モデルを複数挿入します。
void | CompanyPostMapper.update(CompanyPostBaseModel model) 役職の基本モデルを1つだけ更新します。
void | CompanyPostMapper.update(Collection models) 役職の基本モデルを複数更新します。
void | CompanyPostMapper.delete(CompanyPostBaseModel model) 役職の基本モデルを1つだけ削除します。
void | CompanyPostMapper.delete(Collection models) 役職の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.company.version での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.version のメソッド
CompanyVersionBaseModel | CompanyVersionMapper.create(String companyCode, String versionCode) プライマリキーに該当する会社構成バージョンを生成します。
CompanyVersionBaseModel | CompanyVersionMapper.select(String companyCode, String versionCode) プライマリーキーで特定される会社構成バージョンの基本モデルを取得します。
void | CompanyVersionMapper.insert(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ挿入します。
void | CompanyVersionMapper.insert(Collection models) 会社構成バージョンの基本モデルを複数挿入します。
void | CompanyVersionMapper.update(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ更新します。
void | CompanyVersionMapper.update(Collection models) 会社構成バージョンの基本モデルを複数更新します。
void | CompanyVersionMapper.delete(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ削除します。
void | CompanyVersionMapper.delete(Collection models) 会社構成バージョンの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.deal.deal での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.deal.deal のメソッド
DealBaseModel | DealMapper.create(String customerCompanyCode, String customerDepartmentCode, String dealCode) プライマリキーに該当する取扱を生成します。
DealBaseModel | DealMapper.select(String customerCompanyCode, String customerDepartmentCode, String dealCode) プライマリーキーで特定される取扱の基本モデルを取得します。
void | DealMapper.insert(DealBaseModel model) 取扱の基本モデルを1つだけ挿入します。
void | DealMapper.insert(Collection models) 取扱の基本モデルを複数挿入します。
void | DealMapper.update(DealBaseModel model) 取扱の基本モデルを1つだけ更新します。
void | DealMapper.update(Collection models) 取扱の基本モデルを複数更新します。
void | DealMapper.delete(DealBaseModel model) 取扱の基本モデルを1つだけ削除します。
void | DealMapper.delete(Collection models) 取扱の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.deal.department での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.deal.department のメソッド
DealerDepartmentBaseModel | DealerDepartmentMapper.create(String customerCompanyCode, String customerDepartmentCode, String dealCode, String companyCode, String departmentCode) プライマリキーに該当する組織毎取扱パーミッションを生成します。
DealerDepartmentBaseModel | DealerDepartmentMapper.select(String customerCompanyCode, String customerDepartmentCode, String dealCode, String companyCode, String departmentCode) プライマリーキーで特定される組織毎取扱パーミッションの基本モデルを取得します。
void | DealerDepartmentMapper.insert(DealerDepartmentBaseModel model) 組織毎取扱パーミッションの基本モデルを1つだけ挿入します。
void | DealerDepartmentMapper.insert(Collection models) 組織毎取扱パーミッションの基本モデルを複数挿入します。
void | DealerDepartmentMapper.update(DealerDepartmentBaseModel model) 組織毎取扱パーミッションの基本モデルを1つだけ更新します。
void | DealerDepartmentMapper.update(Collection models) 組織毎取扱パーミッションの基本モデルを複数更新します。
void | DealerDepartmentMapper.delete(DealerDepartmentBaseModel model) 組織毎取扱パーミッションの基本モデルを1つだけ削除します。
void | DealerDepartmentMapper.delete(Collection models) 組織毎取扱パーミッションの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.deal.detail での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.deal.detail のメソッド
DealDetailBaseModel | DealDetailMapper.create(String customerCompanyCode, String customerDepartmentCode, String dealCode, String itemCode) プライマリキーに該当する取扱詳細を生成します。
DealDetailBaseModel | DealDetailMapper.select(String customerCompanyCode, String customerDepartmentCode, String dealCode, String itemCode) プライマリーキーで特定される取扱詳細の基本モデルを取得します。
void | DealDetailMapper.insert(DealDetailBaseModel model) 取扱詳細の基本モデルを1つだけ挿入します。
void | DealDetailMapper.insert(Collection models) 取扱詳細の基本モデルを複数挿入します。
void | DealDetailMapper.update(DealDetailBaseModel model) 取扱詳細の基本モデルを1つだけ更新します。
void | DealDetailMapper.update(Collection models) 取扱詳細の基本モデルを複数更新します。
void | DealDetailMapper.delete(DealDetailBaseModel model) 取扱詳細の基本モデルを1つだけ削除します。
void | DealDetailMapper.delete(Collection models) 取扱詳細の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.deal.public_group のメソッド
DealerPublicGroupBaseModel | DealerPublicGroupMapper.create(String customerCompanyCode, String customerDepartmentCode, String dealCode, String publicGroupSetCode, String publicGroupCode) プライマリキーに該当するパブリックグループ毎取扱パーミッションを生成します。
DealerPublicGroupBaseModel | DealerPublicGroupMapper.select(String customerCompanyCode, String customerDepartmentCode, String dealCode, String publicGroupSetCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループ毎取扱パーミッションの基本モデルを取得します。
void | DealerPublicGroupMapper.insert(DealerPublicGroupBaseModel model) パブリックグループ毎取扱パーミッションの基本モデルを1つだけ挿入します。
void | DealerPublicGroupMapper.insert(Collection models) パブリックグループ毎取扱パーミッションの基本モデルを複数挿入します。
void | DealerPublicGroupMapper.update(DealerPublicGroupBaseModel model) パブリックグループ毎取扱パーミッションの基本モデルを1つだけ更新します。
void | DealerPublicGroupMapper.update(Collection models) パブリックグループ毎取扱パーミッションの基本モデルを複数更新します。
void | DealerPublicGroupMapper.delete(DealerPublicGroupBaseModel model) パブリックグループ毎取扱パーミッションの基本モデルを1つだけ削除します。
void | DealerPublicGroupMapper.delete(Collection models) パブリックグループ毎取扱パーミッションの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.deal.role での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.deal.role のメソッド
DealerRoleBaseModel | DealerRoleMapper.create(String customerCompanyCode, String customerDepartmentCode, String dealCode, String roleId) プライマリキーに該当するロール毎取扱パーミッションを生成します。
DealerRoleBaseModel | DealerRoleMapper.select(String customerCompanyCode, String customerDepartmentCode, String dealCode, String roleId) プライマリーキーで特定されるロール毎取扱パーミッションの基本モデルを取得します。
void | DealerRoleMapper.insert(DealerRoleBaseModel model) ロール毎取扱パーミッションの基本モデルを1つだけ挿入します。
void | DealerRoleMapper.insert(Collection models) ロール毎取扱パーミッションの基本モデルを複数挿入します。
void | DealerRoleMapper.update(DealerRoleBaseModel model) ロール毎取扱パーミッションの基本モデルを1つだけ更新します。
void | DealerRoleMapper.update(Collection models) ロール毎取扱パーミッションの基本モデルを複数更新します。
void | DealerRoleMapper.delete(DealerRoleBaseModel model) ロール毎取扱パーミッションの基本モデルを1つだけ削除します。
void | DealerRoleMapper.delete(Collection models) ロール毎取扱パーミッションの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.item_category.attach のメソッド
ItemAttachBaseModel | ItemAttachMapper.create(String itemCategoryTypeCode, String itemCategoryCode, String itemCode) プライマリキーに該当する商品分類を生成します。
ItemAttachBaseModel | ItemAttachMapper.select(String itemCategoryTypeCode, String itemCategoryCode, String itemCode) プライマリーキーで特定される商品分類の基本モデルを取得します。
void | ItemAttachMapper.insert(ItemAttachBaseModel model) 商品分類の基本モデルを1つだけ挿入します。
void | ItemAttachMapper.insert(Collection models) 商品分類の基本モデルを複数挿入します。
void | ItemAttachMapper.update(ItemAttachBaseModel model) 商品分類の基本モデルを1つだけ更新します。
void | ItemAttachMapper.update(Collection models) 商品分類の基本モデルを複数更新します。
void | ItemAttachMapper.delete(ItemAttachBaseModel model) 商品分類の基本モデルを1つだけ削除します。
void | ItemAttachMapper.delete(Collection models) 商品分類の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.category での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.item_category.category のメソッド
ItemCategoryBaseModel | ItemCategoryMapper.create(String itemCategoryTypeCode, String itemCategoryCode) プライマリキーに該当する商品カテゴリを生成します。
ItemCategoryBaseModel | ItemCategoryMapper.select(String itemCategoryTypeCode, String itemCategoryCode) プライマリーキーで特定される商品カテゴリの基本モデルを取得します。
void | ItemCategoryMapper.insert(ItemCategoryBaseModel model) 商品カテゴリの基本モデルを1つだけ挿入します。
void | ItemCategoryMapper.insert(Collection models) 商品カテゴリの基本モデルを複数挿入します。
void | ItemCategoryMapper.update(ItemCategoryBaseModel model) 商品カテゴリの基本モデルを1つだけ更新します。
void | ItemCategoryMapper.update(Collection models) 商品カテゴリの基本モデルを複数更新します。
void | ItemCategoryMapper.delete(ItemCategoryBaseModel model) 商品カテゴリの基本モデルを1つだけ削除します。
void | ItemCategoryMapper.delete(Collection models) 商品カテゴリの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.item_category.type での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.item_category.type のメソッド
ItemCategoryTypeBaseModel | ItemCategoryTypeMapper.create(String itemCategoryTypeCode) プライマリキーに該当する商品カテゴリ種別を生成します。
ItemCategoryTypeBaseModel | ItemCategoryTypeMapper.select(String itemCategoryTypeCode) プライマリーキーで特定される商品カテゴリ種別の基本モデルを取得します。
void | ItemCategoryTypeMapper.insert(ItemCategoryTypeBaseModel model) 商品カテゴリ種別の基本モデルを1つだけ挿入します。
void | ItemCategoryTypeMapper.insert(Collection models) 商品カテゴリ種別の基本モデルを複数挿入します。
void | ItemCategoryTypeMapper.update(ItemCategoryTypeBaseModel model) 商品カテゴリ種別の基本モデルを1つだけ更新します。
void | ItemCategoryTypeMapper.update(Collection models) 商品カテゴリ種別の基本モデルを複数更新します。
void | ItemCategoryTypeMapper.delete(ItemCategoryTypeBaseModel model) 商品カテゴリ種別の基本モデルを1つだけ削除します。
void | ItemCategoryTypeMapper.delete(Collection models) 商品カテゴリ種別の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.item_template.detail のメソッド
ItemTemplateDetailBaseModel | ItemTemplateDetailMapper.create(String templateCode, String templateDetailCode) プライマリキーに該当する商品属性テンプレート明細を生成します。
ItemTemplateDetailBaseModel | ItemTemplateDetailMapper.select(String templateCode, String templateDetailCode) プライマリーキーで特定される商品属性テンプレート明細の基本モデルを取得します。
void | ItemTemplateDetailMapper.insert(ItemTemplateDetailBaseModel model) 商品属性テンプレート明細の基本モデルを1つだけ挿入します。
void | ItemTemplateDetailMapper.insert(Collection models) 商品属性テンプレート明細の基本モデルを複数挿入します。
void | ItemTemplateDetailMapper.update(ItemTemplateDetailBaseModel model) 商品属性テンプレート明細の基本モデルを1つだけ更新します。
void | ItemTemplateDetailMapper.update(Collection models) 商品属性テンプレート明細の基本モデルを複数更新します。
void | ItemTemplateDetailMapper.delete(ItemTemplateDetailBaseModel model) 商品属性テンプレート明細の基本モデルを1つだけ削除します。
void | ItemTemplateDetailMapper.delete(Collection models) 商品属性テンプレート明細の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.item_template.template での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.item_template.template のメソッド
ItemTemplateBaseModel | ItemTemplateMapper.create(String templateCode) プライマリキーに該当する商品属性テンプレートを生成します。
ItemTemplateBaseModel | ItemTemplateMapper.select(String templateCode) プライマリーキーで特定される商品属性テンプレートの基本モデルを取得します。
void | ItemTemplateMapper.insert(ItemTemplateBaseModel model) 商品属性テンプレートの基本モデルを1つだけ挿入します。
void | ItemTemplateMapper.insert(Collection models) 商品属性テンプレートの基本モデルを複数挿入します。
void | ItemTemplateMapper.update(ItemTemplateBaseModel model) 商品属性テンプレートの基本モデルを1つだけ更新します。
void | ItemTemplateMapper.update(Collection models) 商品属性テンプレートの基本モデルを複数更新します。
void | ItemTemplateMapper.delete(ItemTemplateBaseModel model) 商品属性テンプレートの基本モデルを1つだけ削除します。
void | ItemTemplateMapper.delete(Collection models) 商品属性テンプレートの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.item.attribute での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.item.attribute のメソッド
ItemAttributeBaseModel | ItemAttributeMapper.create(String itemCode, String templateCode, String templateDetailCode) プライマリキーに該当する商品属性を生成します。
ItemAttributeBaseModel | ItemAttributeMapper.select(String itemCode, String templateCode, String templateDetailCode) プライマリーキーで特定される商品属性の基本モデルを取得します。
void | ItemAttributeMapper.insert(ItemAttributeBaseModel model) 商品属性の基本モデルを1つだけ挿入します。
void | ItemAttributeMapper.insert(Collection models) 商品属性の基本モデルを複数挿入します。
void | ItemAttributeMapper.update(ItemAttributeBaseModel model) 商品属性の基本モデルを1つだけ更新します。
void | ItemAttributeMapper.update(Collection models) 商品属性の基本モデルを複数更新します。
void | ItemAttributeMapper.delete(ItemAttributeBaseModel model) 商品属性の基本モデルを1つだけ削除します。
void | ItemAttributeMapper.delete(Collection models) 商品属性の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.item.catalogue のメソッド
ItemCatalogueBaseModel | ItemCatalogueMapper.create(String itemCode, String itemCatalogueCode) プライマリキーに該当する商品カタログを生成します。
ItemCatalogueBaseModel | ItemCatalogueMapper.select(String itemCode, String itemCatalogueCode) プライマリーキーで特定される商品カタログの基本モデルを取得します。
void | ItemCatalogueMapper.insert(ItemCatalogueBaseModel model) 商品カタログの基本モデルを1つだけ挿入します。
void | ItemCatalogueMapper.insert(Collection models) 商品カタログの基本モデルを複数挿入します。
void | ItemCatalogueMapper.update(ItemCatalogueBaseModel model) 商品カタログの基本モデルを1つだけ更新します。
void | ItemCatalogueMapper.update(Collection models) 商品カタログの基本モデルを複数更新します。
void | ItemCatalogueMapper.delete(ItemCatalogueBaseModel model) 商品カタログの基本モデルを1つだけ削除します。
void | ItemCatalogueMapper.delete(Collection models) 商品カタログの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.item.item での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.item.item のメソッド
ItemBaseModel | ItemMapper.create(String itemCode) プライマリキーに該当する商品を生成します。
ItemBaseModel | ItemMapper.select(String itemCode) プライマリーキーで特定される商品の基本モデルを取得します。
void | ItemMapper.insert(ItemBaseModel model) 商品の基本モデルを1つだけ挿入します。
void | ItemMapper.insert(Collection models) 商品の基本モデルを複数挿入します。
void | ItemMapper.update(ItemBaseModel model) 商品の基本モデルを1つだけ更新します。
void | ItemMapper.update(Collection models) 商品の基本モデルを複数更新します。
void | ItemMapper.delete(ItemBaseModel model) 商品の基本モデルを1つだけ削除します。
void | ItemMapper.delete(Collection models) 商品の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.private_group.attach のメソッド
PrivateGroupAttachBaseModel | PrivateGroupAttachMapper.create(String ownerCode, String privateGroupCode, String userCode) プライマリキーに該当するプライベートグループ所属を生成します。
PrivateGroupAttachBaseModel | PrivateGroupAttachMapper.select(String ownerCode, String privateGroupCode, String userCode) プライマリーキーで特定されるプライベートグループ所属の基本モデルを取得します。
void | PrivateGroupAttachMapper.insert(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ挿入します。
void | PrivateGroupAttachMapper.insert(Collection models) プライベートグループ所属の基本モデルを複数挿入します。
void | PrivateGroupAttachMapper.update(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ更新します。
void | PrivateGroupAttachMapper.update(Collection models) プライベートグループ所属の基本モデルを複数更新します。
void | PrivateGroupAttachMapper.delete(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ削除します。
void | PrivateGroupAttachMapper.delete(Collection models) プライベートグループ所属の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.private_group.group での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.private_group.group のメソッド
PrivateGroupBaseModel | PrivateGroupMapper.create(String ownerCode, String privateGroupCode) プライマリキーに該当するプライベートグループを生成します。
PrivateGroupBaseModel | PrivateGroupMapper.select(String ownerCode, String privateGroupCode) プライマリーキーで特定されるプライベートグループの基本モデルを取得します。
void | PrivateGroupMapper.insert(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ挿入します。
void | PrivateGroupMapper.insert(Collection models) プライベートグループの基本モデルを複数挿入します。
void | PrivateGroupMapper.update(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ更新します。
void | PrivateGroupMapper.update(Collection models) プライベートグループの基本モデルを複数更新します。
void | PrivateGroupMapper.delete(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ削除します。
void | PrivateGroupMapper.delete(Collection models) プライベートグループの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.attach のメソッド
PublicGroupAttachBaseModel | PublicGroupAttachMapper.create(String userCode, String publicGroupSetCode, String publicGroupCode) プライマリキーに該当するパブリックグループ所属を生成します。
PublicGroupAttachBaseModel | PublicGroupAttachMapper.select(String userCode, String publicGroupSetCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループ所属の基本モデルを取得します。
void | PublicGroupAttachMapper.insert(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ挿入します。
void | PublicGroupAttachMapper.insert(Collection models) パブリックグループ所属の基本モデルを複数挿入します。
void | PublicGroupAttachMapper.update(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ更新します。
void | PublicGroupAttachMapper.update(Collection models) パブリックグループ所属の基本モデルを複数更新します。
void | PublicGroupAttachMapper.delete(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ削除します。
void | PublicGroupAttachMapper.delete(Collection models) パブリックグループ所属の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.category のメソッド
PublicGroupCategoryBaseModel | PublicGroupCategoryMapper.create(String publicGroupSetCode, String publicGroupCode, String categoryClassCode, String categoryCode) プライマリキーに該当するパブリックグループ分類を生成します。
PublicGroupCategoryBaseModel | PublicGroupCategoryMapper.select(String publicGroupSetCode, String publicGroupCode, String categoryClassCode, String categoryCode) プライマリーキーで特定されるパブリックグループ分類の基本モデルを取得します。
void | PublicGroupCategoryMapper.insert(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ挿入します。
void | PublicGroupCategoryMapper.insert(Collection models) パブリックグループ分類の基本モデルを複数挿入します。
void | PublicGroupCategoryMapper.update(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ更新します。
void | PublicGroupCategoryMapper.update(Collection models) パブリックグループ分類の基本モデルを複数更新します。
void | PublicGroupCategoryMapper.delete(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ削除します。
void | PublicGroupCategoryMapper.delete(Collection models) パブリックグループ分類の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.group のメソッド
PublicGroupBaseModel | PublicGroupMapper.create(String publicGroupSetCode, String publicGroupCode) プライマリキーに該当するパブリックグループを生成します。
PublicGroupBaseModel | PublicGroupMapper.select(String publicGroupSetCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループの基本モデルを取得します。
void | PublicGroupMapper.insert(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ挿入します。
void | PublicGroupMapper.insert(Collection models) パブリックグループの基本モデルを複数挿入します。
void | PublicGroupMapper.update(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ更新します。
void | PublicGroupMapper.update(Collection models) パブリックグループの基本モデルを複数更新します。
void | PublicGroupMapper.delete(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ削除します。
void | PublicGroupMapper.delete(Collection models) パブリックグループの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion のメソッド
PublicGroupInclusionBaseModel | PublicGroupInclusionMapper.create(String publicGroupSetCode, String versionCode, String parentPublicGroupCode, String publicGroupCode) プライマリキーに該当するパブリックグループ内包を生成します。
PublicGroupInclusionBaseModel | PublicGroupInclusionMapper.select(String publicGroupSetCode, String versionCode, String parentPublicGroupCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループ内包の基本モデルを取得します。
void | PublicGroupInclusionMapper.insert(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ挿入します。
void | PublicGroupInclusionMapper.insert(Collection models) パブリックグループ内包の基本モデルを複数挿入します。
void | PublicGroupInclusionMapper.update(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ更新します。
void | PublicGroupInclusionMapper.update(Collection models) パブリックグループ内包の基本モデルを複数更新します。
void | PublicGroupInclusionMapper.delete(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ削除します。
void | PublicGroupInclusionMapper.delete(Collection models) パブリックグループ内包の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.set での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.set のメソッド
PublicGroupSetBaseModel | PublicGroupSetMapper.create(String publicGroupSetCode) プライマリキーに該当するパブリックグループセットを生成します。
PublicGroupSetBaseModel | PublicGroupSetMapper.select(String publicGroupSetCode) プライマリーキーで特定されるパブリックグループセットの基本モデルを取得します。
void | PublicGroupSetMapper.insert(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ挿入します。
void | PublicGroupSetMapper.insert(Collection models) パブリックグループセットの基本モデルを複数挿入します。
void | PublicGroupSetMapper.update(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ更新します。
void | PublicGroupSetMapper.update(Collection models) パブリックグループセットの基本モデルを複数更新します。
void | PublicGroupSetMapper.delete(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ削除します。
void | PublicGroupSetMapper.delete(Collection models) パブリックグループセットの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.version での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.version のメソッド
PublicGroupVersionBaseModel | PublicGroupVersionMapper.create(String publicGroupSetCode, String versionCode) プライマリキーに該当するパブリックグループ構成バージョンを生成します。
PublicGroupVersionBaseModel | PublicGroupVersionMapper.select(String publicGroupSetCode, String versionCode) プライマリーキーで特定されるパブリックグループ構成バージョンの基本モデルを取得します。
void | PublicGroupVersionMapper.insert(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ挿入します。
void | PublicGroupVersionMapper.insert(Collection models) パブリックグループ構成バージョンの基本モデルを複数挿入します。
void | PublicGroupVersionMapper.update(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ更新します。
void | PublicGroupVersionMapper.update(Collection models) パブリックグループ構成バージョンの基本モデルを複数更新します。
void | PublicGroupVersionMapper.delete(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ削除します。
void | PublicGroupVersionMapper.delete(Collection models) パブリックグループ構成バージョンの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.unit での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.unit のメソッド
UnitBaseModel | UnitMapper.create(String unitCode) プライマリキーに該当する単位を生成します。
UnitBaseModel | UnitMapper.select(String unitCode) プライマリーキーで特定される単位の基本モデルを取得します。
void | UnitMapper.insert(UnitBaseModel model) 単位の基本モデルを1つだけ挿入します。
void | UnitMapper.insert(Collection models) 単位の基本モデルを複数挿入します。
void | UnitMapper.update(UnitBaseModel model) 単位の基本モデルを1つだけ更新します。
void | UnitMapper.update(Collection models) 単位の基本モデルを複数更新します。
void | UnitMapper.delete(UnitBaseModel model) 単位の基本モデルを1つだけ削除します。
void | UnitMapper.delete(Collection models) 単位の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.user での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.user のメソッド
UserBaseModel | UserMapper.create(String userCode) プライマリキーに該当するユーザを生成します。
UserBaseModel | UserMapper.select(String userCode) プライマリーキーで特定されるユーザの基本モデルを取得します。
void | UserMapper.insert(UserBaseModel model) ユーザの基本モデルを1つだけ挿入します。
void | UserMapper.insert(Collection models) ユーザの基本モデルを複数挿入します。
void | UserMapper.update(UserBaseModel model) ユーザの基本モデルを1つだけ更新します。
void | UserMapper.update(Collection models) ユーザの基本モデルを複数更新します。
void | UserMapper.delete(UserBaseModel model) ユーザの基本モデルを1つだけ削除します。
void | UserMapper.delete(Collection models) ユーザの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.common.model での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.common.model のメソッド
static MapperFactory | MapperFactory.newInstance() マッパーファクトリを取得します。
abstract Mapper | MapperFactory.createMapper(String application, String entity, String group, String user) マッパーを生成します。
void | Mapper.init(String user, String group) マッパーを初期化します。
BaseModel | Mapper.createBaseModel(Map keys) このマッパーに該当する基本モデルを新規に生成します。
BaseModel | Mapper.select(Map keys) プライマリーキーで特定される基本モデルを取得します。
void | Mapper.notifyUpdate(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
void | Mapper.notifyDelete(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
void | Mapper.checkByBaseProperty(Relationship[] relationships, BaseModel target, BaseModel base) 基準項目によるリレーションシップの整合性制約をチェックします。
void | Mapper.close() マッパーをクローズします。
void | IntramartDBMapper.init(String user, String group) マッパーを初期化します。
protected BaseAccessor | IntramartDBMapper.createBaseAccessor(Map primary) このマッパーに該当する基本アクセサを新規に生成します。
BaseModel | IntramartDBMapper.createBaseModel(Map keys) このマッパーに該当する基本モデルを新規に生成します。
BaseModel | IntramartDBMapper.select(Map keys) プライマリーキーで特定される基本モデルを取得します。
protected Collection | IntramartDBMapper.select(Relationship relationship, Map keys) 外部キーで特定される基本モデルをすべて取得します。
protected void | IntramartDBMapper.insert(BaseModel model) 基本モデルを1つだけ挿入します。
protected void | IntramartDBMapper.insert(Collection models) 基本モデルを複数挿入します。
protected void | IntramartDBMapper.update(BaseModel model) 基本モデルを1つだけ更新します。
protected void | IntramartDBMapper.update(Collection models) 基本モデルを複数更新します。
protected void | IntramartDBMapper.delete(BaseModel model) 基本モデルを1つだけ削除します。
protected void | IntramartDBMapper.delete(Collection models) アクセサを複数削除します。
void | IntramartDBMapper.notifyUpdate(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
void | IntramartDBMapper.notifyDelete(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
void | IntramartDBMapper.checkByBaseProperty(Relationship[] relationships, BaseModel target, BaseModel base) 基準項目によるリレーションシップの整合性制約をチェックします。
void | IntramartDBMapper.close() マッパーをクローズします。

jp.co.intra_mart.system.security.datastore.inf での MapperException の使用

MapperException をスローする jp.co.intra_mart.system.security.datastore.inf のメソッド
RoleSummaryBaseModel | RoleSummaryMapper.create(String roleId, String summaryRoleId) プライマリキーに該当するロールサマリを生成します。
RoleSummaryBaseModel | RoleSummaryMapper.select(String roleId, String summaryRoleId) プライマリーキーで特定されるロールサマリの基本モデルを取得します。
void | RoleSummaryMapper.insert(RoleSummaryBaseModel model) ロールサマリの基本モデルを1つだけ挿入します。
void | RoleSummaryMapper.insert(Collection models) ロールサマリの基本モデルを複数挿入します。
void | RoleSummaryMapper.update(RoleSummaryBaseModel model) ロールサマリの基本モデルを1つだけ更新します。
void | RoleSummaryMapper.update(Collection models) ロールサマリの基本モデルを複数更新します。
void | RoleSummaryMapper.delete(RoleSummaryBaseModel model) ロールサマリの基本モデルを1つだけ削除します。
void | RoleSummaryMapper.delete(Collection models) ロールサマリの基本モデルを複数削除します。
RoleBaseModel | RoleMapper.create(String roleId) プライマリキーに該当するロールを生成します。
RoleBaseModel | RoleMapper.select(String roleId) プライマリーキーで特定されるロールの基本モデルを取得します。
void | RoleMapper.insert(RoleBaseModel model) ロールの基本モデルを1つだけ挿入します。
void | RoleMapper.insert(Collection models) ロールの基本モデルを複数挿入します。
void | RoleMapper.update(RoleBaseModel model) ロールの基本モデルを1つだけ更新します。
void | RoleMapper.update(Collection models) ロールの基本モデルを複数更新します。
void | RoleMapper.delete(RoleBaseModel model) ロールの基本モデルを1つだけ削除します。
void | RoleMapper.delete(Collection models) ロールの基本モデルを複数削除します。
RoleInclusionBaseModel | RoleInclusionMapper.create(String parentRoleId, String childRoleId) プライマリキーに該当するロール内包を生成します。
RoleInclusionBaseModel | RoleInclusionMapper.select(String parentRoleId, String childRoleId) プライマリーキーで特定されるロール内包の基本モデルを取得します。
void | RoleInclusionMapper.insert(RoleInclusionBaseModel model) ロール内包の基本モデルを1つだけ挿入します。
void | RoleInclusionMapper.insert(Collection models) ロール内包の基本モデルを複数挿入します。
void | RoleInclusionMapper.update(RoleInclusionBaseModel model) ロール内包の基本モデルを1つだけ更新します。
void | RoleInclusionMapper.update(Collection models) ロール内包の基本モデルを複数更新します。
void | RoleInclusionMapper.delete(RoleInclusionBaseModel model) ロール内包の基本モデルを1つだけ削除します。
void | RoleInclusionMapper.delete(Collection models) ロール内包の基本モデルを複数削除します。
MenuRoleBaseModel | MenuRoleMapper.create(String menuId, String roleId) プライマリキーに該当するメニューの利用権限を保有するロールを生成します。
MenuRoleBaseModel | MenuRoleMapper.select(String menuId, String roleId) プライマリーキーで特定されるメニューの利用権限を保有するロールの基本モデルを取得します。
void | MenuRoleMapper.insert(MenuRoleBaseModel model) メニューの利用権限を保有するロールの基本モデルを1つだけ挿入します。
void | MenuRoleMapper.insert(Collection models) メニューの利用権限を保有するロールの基本モデルを複数挿入します。
void | MenuRoleMapper.update(MenuRoleBaseModel model) メニューの利用権限を保有するロールの基本モデルを1つだけ更新します。
void | MenuRoleMapper.update(Collection models) メニューの利用権限を保有するロールの基本モデルを複数更新します。
void | MenuRoleMapper.delete(MenuRoleBaseModel model) メニューの利用権限を保有するロールの基本モデルを1つだけ削除します。
void | MenuRoleMapper.delete(Collection models) メニューの利用権限を保有するロールの基本モデルを複数削除します。
MenuPublicGroupBaseModel | MenuPublicGroupMapper.create(String menuId, String publicGroupSetCd, String publicGroupCd) プライマリキーに該当するメニューの利用権限を保有するパブリックグループを生成します。
MenuPublicGroupBaseModel | MenuPublicGroupMapper.select(String menuId, String publicGroupSetCd, String publicGroupCd) プライマリーキーで特定されるメニューの利用権限を保有するパブリックグループの基本モデルを取得します。
void | MenuPublicGroupMapper.insert(MenuPublicGroupBaseModel model) メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ挿入します。
void | MenuPublicGroupMapper.insert(Collection models) メニューの利用権限を保有するパブリックグループの基本モデルを複数挿入します。
void | MenuPublicGroupMapper.update(MenuPublicGroupBaseModel model) メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ更新します。
void | MenuPublicGroupMapper.update(Collection models) メニューの利用権限を保有するパブリックグループの基本モデルを複数更新します。
void | MenuPublicGroupMapper.delete(MenuPublicGroupBaseModel model) メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ削除します。
void | MenuPublicGroupMapper.delete(Collection models) メニューの利用権限を保有するパブリックグループの基本モデルを複数削除します。
MenuPostBaseModel | MenuPostMapper.create(String menuId, String companyCd, String postCd) プライマリキーに該当するメニューの利用権限を保有する役職を生成します。
MenuPostBaseModel | MenuPostMapper.select(String menuId, String companyCd, String postCd) プライマリーキーで特定されるメニューの利用権限を保有する役職の基本モデルを取得します。
void | MenuPostMapper.insert(MenuPostBaseModel model) メニューの利用権限を保有する役職の基本モデルを1つだけ挿入します。
void | MenuPostMapper.insert(Collection models) メニューの利用権限を保有する役職の基本モデルを複数挿入します。
void | MenuPostMapper.update(MenuPostBaseModel model) メニューの利用権限を保有する役職の基本モデルを1つだけ更新します。
void | MenuPostMapper.update(Collection models) メニューの利用権限を保有する役職の基本モデルを複数更新します。
void | MenuPostMapper.delete(MenuPostBaseModel model) メニューの利用権限を保有する役職の基本モデルを1つだけ削除します。
void | MenuPostMapper.delete(Collection models) メニューの利用権限を保有する役職の基本モデルを複数削除します。
MenuBaseModel | MenuMapper.create(String menuId) プライマリキーに該当するメニュー情報を生成します。
MenuBaseModel | MenuMapper.select(String menuId) プライマリーキーで特定されるメニュー情報の基本モデルを取得します。
void | MenuMapper.insert(MenuBaseModel model) メニュー情報の基本モデルを1つだけ挿入します。
void | MenuMapper.insert(Collection models) メニュー情報の基本モデルを複数挿入します。
void | MenuMapper.update(MenuBaseModel model) メニュー情報の基本モデルを1つだけ更新します。
void | MenuMapper.update(Collection models) メニュー情報の基本モデルを複数更新します。
void | MenuMapper.delete(MenuBaseModel model) メニュー情報の基本モデルを1つだけ削除します。
void | MenuMapper.delete(Collection models) メニュー情報の基本モデルを複数削除します。
MenuDepartmentBaseModel | MenuDepartmentMapper.create(String menuId, String companyCd, String departmentCd) プライマリキーに該当するメニューの利用権限を保有する組織を生成します。
MenuDepartmentBaseModel | MenuDepartmentMapper.select(String menuId, String companyCd, String departmentCd) プライマリーキーで特定されるメニューの利用権限を保有する組織の基本モデルを取得します。
void | MenuDepartmentMapper.insert(MenuDepartmentBaseModel model) メニューの利用権限を保有する組織の基本モデルを1つだけ挿入します。
void | MenuDepartmentMapper.insert(Collection models) メニューの利用権限を保有する組織の基本モデルを複数挿入します。
void | MenuDepartmentMapper.update(MenuDepartmentBaseModel model) メニューの利用権限を保有する組織の基本モデルを1つだけ更新します。
void | MenuDepartmentMapper.update(Collection models) メニューの利用権限を保有する組織の基本モデルを複数更新します。
void | MenuDepartmentMapper.delete(MenuDepartmentBaseModel model) メニューの利用権限を保有する組織の基本モデルを1つだけ削除します。
void | MenuDepartmentMapper.delete(Collection models) メニューの利用権限を保有する組織の基本モデルを複数削除します。
MenuArgumentBaseModel | MenuArgumentMapper.create(String menuId, String argumentName) プライマリキーに該当するメニューの保有する引数を生成します。
MenuArgumentBaseModel | MenuArgumentMapper.select(String menuId, String argumentName) プライマリーキーで特定されるメニューの保有する引数の基本モデルを取得します。
void | MenuArgumentMapper.insert(MenuArgumentBaseModel model) メニューの保有する引数の基本モデルを1つだけ挿入します。
void | MenuArgumentMapper.insert(Collection models) メニューの保有する引数の基本モデルを複数挿入します。
void | MenuArgumentMapper.update(MenuArgumentBaseModel model) メニューの保有する引数の基本モデルを1つだけ更新します。
void | MenuArgumentMapper.update(Collection models) メニューの保有する引数の基本モデルを複数更新します。
void | MenuArgumentMapper.delete(MenuArgumentBaseModel model) メニューの保有する引数の基本モデルを1つだけ削除します。
void | MenuArgumentMapper.delete(Collection models) メニューの保有する引数の基本モデルを複数削除します。
FavoriteMenuBaseModel | FavoriteMenuMapper.create(String userId, String menuId) プライマリキーに該当するアカウントが保有するメニューを生成します。
FavoriteMenuBaseModel | FavoriteMenuMapper.select(String userId, String menuId) プライマリーキーで特定されるアカウントが保有するメニューの基本モデルを取得します。
void | FavoriteMenuMapper.insert(FavoriteMenuBaseModel model) アカウントが保有するメニューの基本モデルを1つだけ挿入します。
void | FavoriteMenuMapper.insert(Collection models) アカウントが保有するメニューの基本モデルを複数挿入します。
void | FavoriteMenuMapper.update(FavoriteMenuBaseModel model) アカウントが保有するメニューの基本モデルを1つだけ更新します。
void | FavoriteMenuMapper.update(Collection models) アカウントが保有するメニューの基本モデルを複数更新します。
void | FavoriteMenuMapper.delete(FavoriteMenuBaseModel model) アカウントが保有するメニューの基本モデルを1つだけ削除します。
void | FavoriteMenuMapper.delete(Collection models) アカウントが保有するメニューの基本モデルを複数削除します。
CalendarInfoBaseModel | CalendarInfoMapper.create(String calendarId, String dataId) プライマリキーに該当するカレンダーが保有するデータを生成します。
CalendarInfoBaseModel | CalendarInfoMapper.select(String calendarId, String dataId) プライマリーキーで特定されるカレンダーが保有するデータの基本モデルを取得します。
void | CalendarInfoMapper.insert(CalendarInfoBaseModel model) カレンダーが保有するデータの基本モデルを1つだけ挿入します。
void | CalendarInfoMapper.insert(Collection models) カレンダーが保有するデータの基本モデルを複数挿入します。
void | CalendarInfoMapper.update(CalendarInfoBaseModel model) カレンダーが保有するデータの基本モデルを1つだけ更新します。
void | CalendarInfoMapper.update(Collection models) カレンダーが保有するデータの基本モデルを複数更新します。
void | CalendarInfoMapper.delete(CalendarInfoBaseModel model) カレンダーが保有するデータの基本モデルを1つだけ削除します。
void | CalendarInfoMapper.delete(Collection models) カレンダーが保有するデータの基本モデルを複数削除します。
BatchBaseModel | BatchMapper.create(String batchId) プライマリキーに該当するバッチ情報を生成します。
BatchBaseModel | BatchMapper.select(String batchId) プライマリーキーで特定されるバッチ情報の基本モデルを取得します。
void | BatchMapper.insert(BatchBaseModel model) バッチ情報の基本モデルを1つだけ挿入します。
void | BatchMapper.insert(Collection models) バッチ情報の基本モデルを複数挿入します。
void | BatchMapper.update(BatchBaseModel model) バッチ情報の基本モデルを1つだけ更新します。
void | BatchMapper.update(Collection models) バッチ情報の基本モデルを複数更新します。
void | BatchMapper.delete(BatchBaseModel model) バッチ情報の基本モデルを1つだけ削除します。
void | BatchMapper.delete(Collection models) バッチ情報の基本モデルを複数削除します。
AccountRoleBaseModel | AccountRoleMapper.create(String userId, String roleId) プライマリキーに該当するアカウントが保有するロールを生成します。
AccountRoleBaseModel | AccountRoleMapper.select(String userId, String roleId) プライマリーキーで特定されるアカウントが保有するロールの基本モデルを取得します。
void | AccountRoleMapper.insert(AccountRoleBaseModel model) アカウントが保有するロールの基本モデルを1つだけ挿入します。
void | AccountRoleMapper.insert(Collection models) アカウントが保有するロールの基本モデルを複数挿入します。
void | AccountRoleMapper.update(AccountRoleBaseModel model) アカウントが保有するロールの基本モデルを1つだけ更新します。
void | AccountRoleMapper.update(Collection models) アカウントが保有するロールの基本モデルを複数更新します。
void | AccountRoleMapper.delete(AccountRoleBaseModel model) アカウントが保有するロールの基本モデルを1つだけ削除します。
void | AccountRoleMapper.delete(Collection models) アカウントが保有するロールの基本モデルを複数削除します。
AccountBaseModel | AccountMapper.create(String userId) プライマリキーに該当するアカウントを生成します。
AccountBaseModel | AccountMapper.select(String userId) プライマリーキーで特定されるアカウントの基本モデルを取得します。
void | AccountMapper.insert(AccountBaseModel model) アカウントの基本モデルを1つだけ挿入します。
void | AccountMapper.insert(Collection models) アカウントの基本モデルを複数挿入します。
void | AccountMapper.update(AccountBaseModel model) アカウントの基本モデルを1つだけ更新します。
void | AccountMapper.update(Collection models) アカウントの基本モデルを複数更新します。
void | AccountMapper.delete(AccountBaseModel model) アカウントの基本モデルを1つだけ削除します。
void | AccountMapper.delete(Collection models) アカウントの基本モデルを複数削除します。
AccountAttributeBaseModel | AccountAttributeMapper.create(String userId, String attributeName) プライマリキーに該当するアカウントが保有する属性を生成します。
AccountAttributeBaseModel | AccountAttributeMapper.select(String userId, String attributeName) プライマリーキーで特定されるアカウントが保有する属性の基本モデルを取得します。
void | AccountAttributeMapper.insert(AccountAttributeBaseModel model) アカウントが保有する属性の基本モデルを1つだけ挿入します。
void | AccountAttributeMapper.insert(Collection models) アカウントが保有する属性の基本モデルを複数挿入します。
void | AccountAttributeMapper.update(AccountAttributeBaseModel model) アカウントが保有する属性の基本モデルを1つだけ更新します。
void | AccountAttributeMapper.update(Collection models) アカウントが保有する属性の基本モデルを複数更新します。
void | AccountAttributeMapper.delete(AccountAttributeBaseModel model) アカウントが保有する属性の基本モデルを1つだけ削除します。
void | AccountAttributeMapper.delete(Collection models) アカウントが保有する属性の基本モデルを複数削除します。
AccessControllerRoleBaseModel | AccessControllerRoleMapper.create(String accessControllerId, String roleId) プライマリキーに該当するアクセスコントローラの利用権限を保有するロールを生成します。
AccessControllerRoleBaseModel | AccessControllerRoleMapper.select(String accessControllerId, String roleId) プライマリーキーで特定されるアクセスコントローラの利用権限を保有するロールの基本モデルを取得します。
void | AccessControllerRoleMapper.insert(AccessControllerRoleBaseModel model) アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ挿入します。
void | AccessControllerRoleMapper.insert(Collection models) アクセスコントローラの利用権限を保有するロールの基本モデルを複数挿入します。
void | AccessControllerRoleMapper.update(AccessControllerRoleBaseModel model) アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ更新します。
void | AccessControllerRoleMapper.update(Collection models) アクセスコントローラの利用権限を保有するロールの基本モデルを複数更新します。
void | AccessControllerRoleMapper.delete(AccessControllerRoleBaseModel model) アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ削除します。
void | AccessControllerRoleMapper.delete(Collection models) アクセスコントローラの利用権限を保有するロールの基本モデルを複数削除します。
AccessControllerPublicGroupBaseModel | AccessControllerPublicGroupMapper.create(String accessControllerId, String publicGroupSetCd, String publicGroupCd) プライマリキーに該当するアクセスコントローラの利用権限を保有するパブリックグループを生成します。
AccessControllerPublicGroupBaseModel | AccessControllerPublicGroupMapper.select(String accessControllerId, String publicGroupSetCd, String publicGroupCd) プライマリーキーで特定されるアクセスコントローラの利用権限を保有するパブリックグループの基本モデルを取得します。
void | AccessControllerPublicGroupMapper.insert(AccessControllerPublicGroupBaseModel model) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ挿入します。
void | AccessControllerPublicGroupMapper.insert(Collection models) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを複数挿入します。
void | AccessControllerPublicGroupMapper.update(AccessControllerPublicGroupBaseModel model) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ更新します。
void | AccessControllerPublicGroupMapper.update(Collection models) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを複数更新します。
void | AccessControllerPublicGroupMapper.delete(AccessControllerPublicGroupBaseModel model) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ削除します。
void | AccessControllerPublicGroupMapper.delete(Collection models) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを複数削除します。
AccessControllerPostBaseModel | AccessControllerPostMapper.create(String accessControllerId, String companyCd, String postCd) プライマリキーに該当するアクセスコントローラの利用権限を保有する役職を生成します。
AccessControllerPostBaseModel | AccessControllerPostMapper.select(String accessControllerId, String companyCd, String postCd) プライマリーキーで特定されるアクセスコントローラの利用権限を保有する役職の基本モデルを取得します。
void | AccessControllerPostMapper.insert(AccessControllerPostBaseModel model) アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ挿入します。
void | AccessControllerPostMapper.insert(Collection models) アクセスコントローラの利用権限を保有する役職の基本モデルを複数挿入します。
void | AccessControllerPostMapper.update(AccessControllerPostBaseModel model) アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ更新します。
void | AccessControllerPostMapper.update(Collection models) アクセスコントローラの利用権限を保有する役職の基本モデルを複数更新します。
void | AccessControllerPostMapper.delete(AccessControllerPostBaseModel model) アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ削除します。
void | AccessControllerPostMapper.delete(Collection models) アクセスコントローラの利用権限を保有する役職の基本モデルを複数削除します。
AccessControllerBaseModel | AccessControllerMapper.create(String accessControllerId) プライマリキーに該当するアクセスコントローラ情報を生成します。
AccessControllerBaseModel | AccessControllerMapper.select(String accessControllerId) プライマリーキーで特定されるアクセスコントローラ情報の基本モデルを取得します。
void | AccessControllerMapper.insert(AccessControllerBaseModel model) アクセスコントローラ情報の基本モデルを1つだけ挿入します。
void | AccessControllerMapper.insert(Collection models) アクセスコントローラ情報の基本モデルを複数挿入します。
void | AccessControllerMapper.update(AccessControllerBaseModel model) アクセスコントローラ情報の基本モデルを1つだけ更新します。
void | AccessControllerMapper.update(Collection models) アクセスコントローラ情報の基本モデルを複数更新します。
void | AccessControllerMapper.delete(AccessControllerBaseModel model) アクセスコントローラ情報の基本モデルを1つだけ削除します。
void | AccessControllerMapper.delete(Collection models) アクセスコントローラ情報の基本モデルを複数削除します。
AccessControllerDepartmentBaseModel | AccessControllerDepartmentMapper.create(String accessControllerId, String companyCd, String departmentCd) プライマリキーに該当するアクセスコントローラの利用権限を保有する組織を生成します。
AccessControllerDepartmentBaseModel | AccessControllerDepartmentMapper.select(String accessControllerId, String companyCd, String departmentCd) プライマリーキーで特定されるアクセスコントローラの利用権限を保有する組織の基本モデルを取得します。
void | AccessControllerDepartmentMapper.insert(AccessControllerDepartmentBaseModel model) アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ挿入します。
void | AccessControllerDepartmentMapper.insert(Collection models) アクセスコントローラの利用権限を保有する組織の基本モデルを複数挿入します。
void | AccessControllerDepartmentMapper.update(AccessControllerDepartmentBaseModel model) アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ更新します。
void | AccessControllerDepartmentMapper.update(Collection models) アクセスコントローラの利用権限を保有する組織の基本モデルを複数更新します。
void | AccessControllerDepartmentMapper.delete(AccessControllerDepartmentBaseModel model) アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ削除します。
void | AccessControllerDepartmentMapper.delete(Collection models) アクセスコントローラの利用権限を保有する組織の基本モデルを複数削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.TermManagerException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.TermManagerException の使用

TermManagerException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.structure 期間情報などを扱うクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.structure での TermManagerException の使用

TermManagerException をスローする jp.co.intra_mart.foundation.datastore.common.structure のメソッド
static void | TermManager.validateTerm(Date activation, Date expiration) 指定された2つの日時が有効な期間を構成するかどうか調べます。
static void | TermManager.validateTerms(Term[] terms) 指定された期間配列が有効かどうかを調べます。
static Term[] | TermManager.subtract(Term[] term1, Term[] term2) 期間配列 term1 から 期間配列 term2 を差し引いた期間を返します。
static Term[] | TermManager.getOverlap(Term[] term1, Term[] term2) 2つの期間配列 term1 と term2 で重なっている期間を返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AccessorClosedException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス AccessorClosedException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException
すべての実装インタフェース:
Serializable
public class AccessorClosedException
extends AccessorException

アクセサのクローズ時に発生する例外クラス

アクセサがクローズされている場合に、以下のメソッドを呼び出された時にスローする。

  • setProperty(String, Object)

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
AccessorClosedException()
コンストラクタ
AccessorClosedException(String message)
コンストラクタ
AccessorClosedException(String message, Throwable cause)
コンストラクタ
AccessorClosedException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessorClosedException

public AccessorClosedException()
コンストラクタ

AccessorClosedException

public AccessorClosedException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

AccessorClosedException

public AccessorClosedException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

AccessorClosedException

public AccessorClosedException(String message,
                               Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccessorException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス AccessorException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccessorClosedException, AccessorIllegalPropertyValueException, DataNotFoundException, IllegalExtensionException
public class AccessorException
extends DataStoreApplicationException

アクセサで発生する例外の基底クラス

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
AccessorException()
コンストラクタ
AccessorException(String message)
コンストラクタ
AccessorException(String message, Throwable cause)
コンストラクタ
AccessorException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessorException

public AccessorException()
コンストラクタ

AccessorException

public AccessorException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

AccessorException

public AccessorException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

AccessorException

public AccessorException(String message,
                         Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessorIllegalPropertyValueException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス AccessorIllegalPropertyValueException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException
すべての実装インタフェース:
Serializable
public class AccessorIllegalPropertyValueException
extends AccessorException

アクセサのプロパティ設定に関する例外クラス

アクセサに不正な値が設定された場合にスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
AccessorIllegalPropertyValueException()
コンストラクタ
AccessorIllegalPropertyValueException(String message)
コンストラクタ
AccessorIllegalPropertyValueException(String message, Throwable cause)
コンストラクタ
AccessorIllegalPropertyValueException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessorIllegalPropertyValueException

public AccessorIllegalPropertyValueException()
コンストラクタ

AccessorIllegalPropertyValueException

public AccessorIllegalPropertyValueException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

AccessorIllegalPropertyValueException

public AccessorIllegalPropertyValueException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

AccessorIllegalPropertyValueException

public AccessorIllegalPropertyValueException(String message,
                                             Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessorSystemException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス AccessorSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.exception.FoundationRuntimeException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException
すべての実装インタフェース:
Serializable
public class AccessorSystemException
extends DataStoreSystemException

アクセサのプロパティに関する例外クラス

指定されたプロパティがアクセサに存在しない場合にスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
AccessorSystemException()
コンストラクタ
AccessorSystemException(String message)
コンストラクタ
AccessorSystemException(String message, Throwable cause)
コンストラクタ
AccessorSystemException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessorSystemException

public AccessorSystemException()
コンストラクタ

AccessorSystemException

public AccessorSystemException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

AccessorSystemException

public AccessorSystemException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

AccessorSystemException

public AccessorSystemException(String message,
                               Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BatchProcessException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス BatchProcessException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.datastore.exception.BatchProcessException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ExportInitializeException, ImportInitializeException
public class BatchProcessException
extends RuntimeException

バッチ実行時に処理エラーが発生したことを示すためにスローされます。

導入されたバージョン:
6.1
関連項目:
直列化された形式

コンストラクタの概要
BatchProcessException()
コンストラクタ
BatchProcessException(String message)
コンストラクタ
BatchProcessException(String message, Throwable cause)
コンストラクタ
BatchProcessException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BatchProcessException

public BatchProcessException()
コンストラクタ

BatchProcessException

public BatchProcessException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

BatchProcessException

public BatchProcessException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

BatchProcessException

public BatchProcessException(String message,
                             Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BatchSystemException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス BatchSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.datastore.exception.BatchSystemException
すべての実装インタフェース:
Serializable
public class BatchSystemException
extends RuntimeException

バッチ実行時にシステムエラーが発生したことを示すためにスローされます。

導入されたバージョン:
6.1
関連項目:
直列化された形式

コンストラクタの概要
BatchSystemException()
コンストラクタ
BatchSystemException(String message)
コンストラクタ
BatchSystemException(String message, Throwable cause)
コンストラクタ
BatchSystemException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BatchSystemException

public BatchSystemException()
コンストラクタ

BatchSystemException

public BatchSystemException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

BatchSystemException

public BatchSystemException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

BatchSystemException

public BatchSystemException(String message,
                            Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataNotFoundException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス DataNotFoundException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
IllegalLocaleException, IllegalTermException
public class DataNotFoundException
extends AccessorException

アクセサのプロパティ値の取得に関する例外クラス

指定されたプロパティに対する値が設定されていない場合にスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DataNotFoundException()
コンストラクタ
DataNotFoundException(String message)
コンストラクタ
DataNotFoundException(String message, Throwable cause)
コンストラクタ
DataNotFoundException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataNotFoundException

public DataNotFoundException()
コンストラクタ

DataNotFoundException

public DataNotFoundException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

DataNotFoundException

public DataNotFoundException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

DataNotFoundException

public DataNotFoundException(String message,
                             Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataStoreApplicationException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス DataStoreApplicationException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccessorException, EventNavigatorException, IllegalRelationshipException, ManagerException, MapperException, TermManagerException
public class DataStoreApplicationException
extends FoundationException

アプリケーション共通マスタで発生するアプリケーション例外の基底クラス

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DataStoreApplicationException()
コンストラクタ
DataStoreApplicationException(String message)
コンストラクタ
DataStoreApplicationException(String message, Throwable cause)
コンストラクタ
DataStoreApplicationException(Throwable cause)
コンストラクタ
メソッドの概要
String | getKey() エラーメッセージを作成するための識別子を取得します。
String[] | getValues() エラーメッセージで使用する置換用の文字列を取得します。
void | setKey(String key) エラーメッセージを作成するためのキーを取得します。
void | setValues(String[] values) エラーメッセージで使用する置換用の文字列を設定します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataStoreApplicationException

public DataStoreApplicationException()
コンストラクタ

DataStoreApplicationException

public DataStoreApplicationException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

DataStoreApplicationException

public DataStoreApplicationException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

DataStoreApplicationException

public DataStoreApplicationException(String message,
                                     Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
メソッドの詳細

setKey

public void setKey(String key)
エラーメッセージを作成するためのキーを取得します。

パラメータ:
key - メッセージキー

setValues

public void setValues(String[] values)
エラーメッセージで使用する置換用の文字列を設定します。

パラメータ:
values - 置換用文字列

getKey

public String getKey()
エラーメッセージを作成するための識別子を取得します。

戻り値:
メッセージキー

getValues

public String[] getValues()
エラーメッセージで使用する置換用の文字列を取得します。

戻り値:
置換用文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataStoreConfigException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス DataStoreConfigException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.exception.FoundationRuntimeException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException
すべての実装インタフェース:
Serializable
public class DataStoreConfigException
extends DataStoreSystemException

アプリケーション共通マスタの設定に関する例外クラス

アプリケーション共通マスタの設定に不整合がある場合にスローする。

関連項目:
直列化された形式

コンストラクタの概要
DataStoreConfigException()
詳細メッセージを指定しないで DataStoreConfigException を構築します。
DataStoreConfigException(String msg)
指定された詳細メッセージを持つ DataStoreConfigException を構築します。
DataStoreConfigException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PresentationPropertyException を構築します。
DataStoreConfigException(Throwable throwable)
この例外の発生原因となる例外を持つ PresentationPropertyException を構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataStoreConfigException

public DataStoreConfigException()
詳細メッセージを指定しないで DataStoreConfigException を構築します。

DataStoreConfigException

public DataStoreConfigException(String msg)
指定された詳細メッセージを持つ DataStoreConfigException を構築します。

パラメータ:
msg - 詳細メッセージ

DataStoreConfigException

public DataStoreConfigException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PresentationPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外

DataStoreConfigException

public DataStoreConfigException(Throwable throwable)
この例外の発生原因となる例外を持つ PresentationPropertyException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataStoreSystemException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス DataStoreSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.exception.FoundationRuntimeException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccessorSystemException, DataStoreConfigException, MapperDAOException
public class DataStoreSystemException
extends FoundationRuntimeException

アプリケーション共通マスタで発生するシステム例外の基底クラス

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DataStoreSystemException()
コンストラクタ
DataStoreSystemException(String message)
コンストラクタ
DataStoreSystemException(String message, Throwable cause)
コンストラクタ
DataStoreSystemException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataStoreSystemException

public DataStoreSystemException()
コンストラクタ

DataStoreSystemException

public DataStoreSystemException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

DataStoreSystemException

public DataStoreSystemException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

DataStoreSystemException

public DataStoreSystemException(String message,
                                Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IllegalExtensionException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス IllegalExtensionException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException
すべての実装インタフェース:
Serializable
public class IllegalExtensionException
extends AccessorException

拡張アクセサに関する例外クラス

拡張アクセサに対して不正な操作が行われた場合にスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
IllegalExtensionException()
コンストラクタ
IllegalExtensionException(String message)
コンストラクタ
IllegalExtensionException(String message, Throwable cause)
コンストラクタ
IllegalExtensionException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalExtensionException

public IllegalExtensionException()
コンストラクタ

IllegalExtensionException

public IllegalExtensionException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

IllegalExtensionException

public IllegalExtensionException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

IllegalExtensionException

public IllegalExtensionException(String message,
                                 Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IllegalLocaleException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス IllegalLocaleException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException
                            拡張 jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException
すべての実装インタフェース:
Serializable
public class IllegalLocaleException
extends DataNotFoundException

アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
IllegalLocaleException()
コンストラクタ
IllegalLocaleException(String message)
コンストラクタ
IllegalLocaleException(String message, Throwable cause)
コンストラクタ
IllegalLocaleException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalLocaleException

public IllegalLocaleException()
コンストラクタ

IllegalLocaleException

public IllegalLocaleException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

IllegalLocaleException

public IllegalLocaleException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

IllegalLocaleException

public IllegalLocaleException(String message,
                              Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IllegalRelationshipException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス IllegalRelationshipException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException
すべての実装インタフェース:
Serializable
public class IllegalRelationshipException
extends DataStoreApplicationException

リレーションシップに関する例外クラス

リレーションシップの整合性が正しくない場合にスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
IllegalRelationshipException()
コンストラクタ
IllegalRelationshipException(String message)
コンストラクタ
IllegalRelationshipException(String message, Throwable cause)
コンストラクタ
IllegalRelationshipException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalRelationshipException

public IllegalRelationshipException()
コンストラクタ

IllegalRelationshipException

public IllegalRelationshipException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

IllegalRelationshipException

public IllegalRelationshipException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

IllegalRelationshipException

public IllegalRelationshipException(String message,
                                    Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IllegalTermException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス IllegalTermException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException
                            拡張 jp.co.intra_mart.foundation.datastore.exception.IllegalTermException
すべての実装インタフェース:
Serializable
public class IllegalTermException
extends DataNotFoundException

アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
IllegalTermException()
コンストラクタ
IllegalTermException(String message)
コンストラクタ
IllegalTermException(String message, Throwable cause)
コンストラクタ
IllegalTermException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalTermException

public IllegalTermException()
コンストラクタ

IllegalTermException

public IllegalTermException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

IllegalTermException

public IllegalTermException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

IllegalTermException

public IllegalTermException(String message,
                            Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ImportException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス ImportException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.datastore.exception.ImportException
すべての実装インタフェース:
Serializable
public class ImportException
extends Exception

アプリケーション共通マスタのインポートに関する例外クラス

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
ImportException()
コンストラクタ
ImportException(String message)
コンストラクタ
ImportException(String message, Throwable cause)
コンストラクタ
ImportException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ImportException

public ImportException()
コンストラクタ

ImportException

public ImportException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

ImportException

public ImportException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

ImportException

public ImportException(String message,
                       Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ManagerException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス ManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.ManagerException
すべての実装インタフェース:
Serializable
public class ManagerException
extends DataStoreApplicationException

マネージャに関する例外クラス

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
ManagerException()
コンストラクタ
ManagerException(String message)
コンストラクタ
ManagerException(String message, Throwable cause)
コンストラクタ
ManagerException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ManagerException

public ManagerException()
コンストラクタ

ManagerException

public ManagerException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

ManagerException

public ManagerException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

ManagerException

public ManagerException(String message,
                        Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MapperDAOException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス MapperDAOException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.exception.FoundationRuntimeException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.MapperDAOException
すべての実装インタフェース:
Serializable
public class MapperDAOException
extends DataStoreSystemException

マッパーのデータベース接続に関する例外クラス

マッパーがデータベース接続で問題が発生した場合にスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
MapperDAOException()
コンストラクタ
MapperDAOException(String message)
コンストラクタ
MapperDAOException(String message, Throwable cause)
コンストラクタ
MapperDAOException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MapperDAOException

public MapperDAOException()
コンストラクタ

MapperDAOException

public MapperDAOException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

MapperDAOException

public MapperDAOException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

MapperDAOException

public MapperDAOException(String message,
                          Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MapperException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス MapperException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.MapperException
すべての実装インタフェース:
Serializable
public class MapperException
extends DataStoreApplicationException

マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
MapperException()
コンストラクタ
MapperException(String message)
コンストラクタ
MapperException(String message, Throwable cause)
コンストラクタ
MapperException(Throwable cause)
コンストラクタ
メソッドの概要
protected String | getBaseName() メッセージを取得するためのリソースバンドルの基底名を返します。
static void | setBaseName(String baseName) リソースバンドルの基底名を設定します。
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MapperException

public MapperException()
コンストラクタ

MapperException

public MapperException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

MapperException

public MapperException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

MapperException

public MapperException(String message,
                       Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
メソッドの詳細

getBaseName

protected String getBaseName()
メッセージを取得するためのリソースバンドルの基底名を返します。

戻り値:
基底名

setBaseName

public static void setBaseName(String baseName)
リソースバンドルの基底名を設定します。

パラメータ:
baseName - 基底名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.exception (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.exception
例外
AccessorClosedException
AccessorException
AccessorIllegalPropertyValueException
AccessorSystemException
BatchProcessException
BatchSystemException
DataNotFoundException
DataStoreApplicationException
DataStoreConfigException
DataStoreSystemException
IllegalExtensionException
IllegalLocaleException
IllegalRelationshipException
IllegalTermException
ImportException
ManagerException
MapperDAOException
MapperException
TermManagerException


jp.co.intra_mart.foundation.datastore.exception (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exception

アプリケーション共通マスタで発生する例外クラスを提供します。

参照:
説明

例外の概要
AccessorClosedException | アクセサのクローズ時に発生する例外クラス アクセサがクローズされている場合に、以下のメソッドを呼び出された時にスローする。
AccessorException | アクセサで発生する例外の基底クラス
AccessorIllegalPropertyValueException | アクセサのプロパティ設定に関する例外クラス アクセサに不正な値が設定された場合にスローする。
AccessorSystemException | アクセサのプロパティに関する例外クラス 指定されたプロパティがアクセサに存在しない場合にスローする。
BatchProcessException | バッチ実行時に処理エラーが発生したことを示すためにスローされます。
BatchSystemException | バッチ実行時にシステムエラーが発生したことを示すためにスローされます。
DataNotFoundException | アクセサのプロパティ値の取得に関する例外クラス 指定されたプロパティに対する値が設定されていない場合にスローする。
DataStoreApplicationException | アプリケーション共通マスタで発生するアプリケーション例外の基底クラス
DataStoreConfigException | アプリケーション共通マスタの設定に関する例外クラス アプリケーション共通マスタの設定に不整合がある場合にスローする。
DataStoreSystemException | アプリケーション共通マスタで発生するシステム例外の基底クラス
IllegalExtensionException | 拡張アクセサに関する例外クラス 拡張アクセサに対して不正な操作が行われた場合にスローする。
IllegalLocaleException | アクセサが保持する言語に関する例外クラス アクセサが保持していない言語を要求された場合にスローする。
IllegalRelationshipException | リレーションシップに関する例外クラス リレーションシップの整合性が正しくない場合にスローする。
IllegalTermException | アクセサが保持する期間に関する例外クラス アクセサが保持しない日時または期間が指定されたときにスローする。
ImportException | アプリケーション共通マスタのインポートに関する例外クラス
ManagerException | マネージャに関する例外クラス
MapperDAOException | マッパーのデータベース接続に関する例外クラス マッパーがデータベース接続で問題が発生した場合にスローする。
MapperException | マッパーに関する例外クラス マッパーの処理中に問題が発生した場合にスローする。
TermManagerException | 期間に関する例外クラス

パッケージ jp.co.intra_mart.foundation.datastore.exception の説明

アプリケーション共通マスタで発生する例外クラスを提供します。


jp.co.intra_mart.foundation.datastore.exception クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.exception.FoundationException
          • class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
            • class jp.co.intra_mart.foundation.datastore.exception.AccessorException
              • class jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException
              • class jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException
              • class jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException
                • class jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException
                • class jp.co.intra_mart.foundation.datastore.exception.IllegalTermException
              • class jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException
            • class jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException
            • class jp.co.intra_mart.foundation.datastore.exception.ManagerException
            • class jp.co.intra_mart.foundation.datastore.exception.MapperException
            • class jp.co.intra_mart.foundation.datastore.exception.TermManagerException
        • class jp.co.intra_mart.foundation.datastore.exception.ImportException
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.datastore.exception.BatchProcessException
          • class jp.co.intra_mart.foundation.datastore.exception.BatchSystemException
          • class jp.co.intra_mart.foundation.exception.FoundationRuntimeException
            • class jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException
              • class jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException
              • class jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException
              • class jp.co.intra_mart.foundation.datastore.exception.MapperDAOException


パッケージ jp.co.intra_mart.foundation.datastore.exception の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.exception の使用

jp.co.intra_mart.foundation.datastore.exception を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category | 分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.currency | 通貨情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item | 商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category | 商品カテゴリ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_template | 商品テンプレート属性情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group | プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.unit | 商品単位情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category | 会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company | 会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion | 組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version | 会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.deal | 取扱情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.department | 取扱組織権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.detail | 取扱詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group | 取扱パブリックグループ権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.role | 取扱ロール権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.attribute | 商品属性情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue | 商品カタログ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.item | 商品情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach | 商品分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.category | 商品カテゴリ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.type | 商品カテゴリ種別情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail | 商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.template | 商品テンプレート情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach | プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group | プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach | パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category | パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion | パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set | パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version | パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.unit | 単位情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.foundation.datastore.common.structure | 期間情報などを扱うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter | アプリケーション共通マスタのエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.common.config | エクスポート設定の解釈を行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer | アプリケーション共通マスタのインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.common.config | インポート定義情報の解釈を行うクラスを提供します。
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.system.security.datastore.inf |

jp.co.intra_mart.foundation.datastore.application.domain.category により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ImportException
アプリケーション共通マスタのインポートに関する例外クラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.domain.currency により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.domain.deal により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.domain.item により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ImportException
アプリケーション共通マスタのインポートに関する例外クラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.domain.item_category により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ImportException
アプリケーション共通マスタのインポートに関する例外クラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.domain.item_template により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ImportException
アプリケーション共通マスタのインポートに関する例外クラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.domain.private_group により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ImportException
アプリケーション共通マスタのインポートに関する例外クラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.domain.unit により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.domain.user により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ImportException
アプリケーション共通マスタのインポートに関する例外クラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.model.category.category_class により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.category.detail により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.company.attach により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.company.category により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.company.company により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.company.department により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.company.main により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.company.post により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.company.version により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.deal.deal により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.deal.department により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.deal.detail により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.deal.role により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.item.attribute により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.item.item により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.item_category.category により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.item_category.type により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.item_template.template により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.private_group.group により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.public_group.set により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.public_group.version により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.unit により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.user により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.common.accessor により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorClosedException
アクセサのクローズ時に発生する例外クラス

アクセサがクローズされている場合に、以下のメソッドを呼び出された時にスローする。
AccessorIllegalPropertyValueException
アクセサのプロパティ設定に関する例外クラス

アクセサに不正な値が設定された場合にスローする。
DataNotFoundException
アクセサのプロパティ値の取得に関する例外クラス

指定されたプロパティに対する値が設定されていない場合にスローする。
IllegalExtensionException
拡張アクセサに関する例外クラス

拡張アクセサに対して不正な操作が行われた場合にスローする。
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。

jp.co.intra_mart.foundation.datastore.common.model により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
DataStoreSystemException
アプリケーション共通マスタで発生するシステム例外の基底クラス
IllegalExtensionException
拡張アクセサに関する例外クラス

拡張アクセサに対して不正な操作が行われた場合にスローする。
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.common.structure により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
TermManagerException
期間に関する例外クラス

jp.co.intra_mart.foundation.datastore.exception により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
DataNotFoundException
アクセサのプロパティ値の取得に関する例外クラス

指定されたプロパティに対する値が設定されていない場合にスローする。
DataStoreApplicationException
アプリケーション共通マスタで発生するアプリケーション例外の基底クラス
DataStoreSystemException
アプリケーション共通マスタで発生するシステム例外の基底クラス

jp.co.intra_mart.foundation.datastore.exporter により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
BatchProcessException
バッチ実行時に処理エラーが発生したことを示すためにスローされます。

jp.co.intra_mart.foundation.datastore.exporter.common.config により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
BatchProcessException
バッチ実行時に処理エラーが発生したことを示すためにスローされます。

jp.co.intra_mart.foundation.datastore.importer により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
BatchProcessException
バッチ実行時に処理エラーが発生したことを示すためにスローされます。

jp.co.intra_mart.foundation.datastore.importer.common.config により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
BatchProcessException
バッチ実行時に処理エラーが発生したことを示すためにスローされます。

jp.co.intra_mart.foundation.navigator により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
DataStoreApplicationException
アプリケーション共通マスタで発生するアプリケーション例外の基底クラス

jp.co.intra_mart.system.security.datastore.inf により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


TermManagerException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス TermManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.TermManagerException
すべての実装インタフェース:
Serializable
public class TermManagerException
extends DataStoreApplicationException

期間に関する例外クラス

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
TermManagerException()
コンストラクタ
TermManagerException(String message)
コンストラクタ
TermManagerException(String message, Throwable cause)
コンストラクタ
TermManagerException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

TermManagerException

public TermManagerException()
コンストラクタ

TermManagerException

public TermManagerException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

TermManagerException

public TermManagerException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

TermManagerException

public TermManagerException(String message,
                            Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient の使用

AbstractExportManagerClient を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exporter.company | 会社・組織関連の情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.public_group | パブリックグループ情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.user | ユーザ関連の情報のエクスポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.exporter.company での AbstractExportManagerClient の使用

jp.co.intra_mart.foundation.datastore.exporter.company での AbstractExportManagerClient のサブクラス
class | CompanyExportManagerClient 会社情報のエクスポートを行います。
class | CompanyPostExportManagerClient 会社役職情報のエクスポートを行います。

jp.co.intra_mart.foundation.datastore.exporter.public_group での AbstractExportManagerClient の使用

jp.co.intra_mart.foundation.datastore.exporter.public_group での AbstractExportManagerClient のサブクラス
 class PublicGroupExportManagerClient
パブリックグループ情報のエクスポートを行います。

jp.co.intra_mart.foundation.datastore.exporter.user での AbstractExportManagerClient の使用

jp.co.intra_mart.foundation.datastore.exporter.user での AbstractExportManagerClient のサブクラス
class | UserAttachExportManagerClient ユーザ所属情報のエクスポートを行います。
class | UserProfileExportManagerClient ユーザ情報のエクスポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.ExportInitializeException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.ExportInitializeException の使用

ExportInitializeException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exporter.common.config エクスポート設定の解釈を行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.exporter.common.config での ExportInitializeException の使用

jp.co.intra_mart.foundation.datastore.exporter.common.config での ExportInitializeException のサブクラス
 class ExportConfigurationReaderException
エクスポート設定の読み込みでエラーが発生したことを示すためにスローされます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.exporter.ExportManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.exporter.ExportManager の使用

ExportManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exporter | アプリケーション共通マスタのエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.company | 会社・組織関連の情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.public_group | パブリックグループ情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.user | ユーザ関連の情報のエクスポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.exporter での ExportManager の使用

ExportManager を実装している jp.co.intra_mart.foundation.datastore.exporter のクラス
 class ExportManagerImpl
エクスポートマネージャーの汎用的な実装です。

ExportManager を返す jp.co.intra_mart.foundation.datastore.exporter のメソッド
protected abstract  ExportManager AbstractExportManagerClient.getExportManager()
エクスポートマネージャーのインスタンスを取得します。

ExportManager 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.exporter のメソッド
protected void | AbstractExportManagerClient.setName(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義された処理名をマネージャーに設定します。
protected void | AbstractExportManagerClient.setFormat(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたエクスポートデータのフォーマットをマネージャーに設定します。
protected void | AbstractExportManagerClient.setDate(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義された日付をマネージャーに設定します。
protected void | AbstractExportManagerClient.setEncoding(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたエクスポートデータのエンコーディング情報をマネージャーに設定します。
protected void | AbstractExportManagerClient.setSize(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたエクスポート単位のデータ数をマネージャーに設定します。
protected void | AbstractExportManagerClient.setExecuteUser(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義された実行ユーザコードをマネージャーに設定します。
protected void | AbstractExportManagerClient.setFilter(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたフィルタの情報をマネージャーに設定します。
protected void | AbstractExportManagerClient.setParameters(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたパラメータ情報をマネージャーに設定します。

jp.co.intra_mart.foundation.datastore.exporter.company での ExportManager の使用

ExportManager を実装している jp.co.intra_mart.foundation.datastore.exporter.company のクラス
class | CompanyExportManager 会社情報のエクスポートを行います。
class | CompanyPostExportManager 会社役職情報のエクスポートを行います。

ExportManager を返す jp.co.intra_mart.foundation.datastore.exporter.company のメソッド
protected ExportManager | CompanyPostExportManagerClient.getExportManager()
protected ExportManager | CompanyExportManagerClient.getExportManager()

jp.co.intra_mart.foundation.datastore.exporter.public_group での ExportManager の使用

ExportManager を実装している jp.co.intra_mart.foundation.datastore.exporter.public_group のクラス
 class PublicGroupExportManager
パブリックグループ情報のエクスポートを行います。

ExportManager を返す jp.co.intra_mart.foundation.datastore.exporter.public_group のメソッド
protected  ExportManager PublicGroupExportManagerClient.getExportManager()

jp.co.intra_mart.foundation.datastore.exporter.user での ExportManager の使用

ExportManager を実装している jp.co.intra_mart.foundation.datastore.exporter.user のクラス
class | UserAttachExportManager ユーザ所属情報のエクスポートを行います。
class | UserProfileExportManager ユーザ情報のエクスポートを行います。

ExportManager を返す jp.co.intra_mart.foundation.datastore.exporter.user のメソッド
protected ExportManager | UserProfileExportManagerClient.getExportManager()
protected ExportManager | UserAttachExportManagerClient.getExportManager()

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient の使用

ExportManagerClient を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exporter | アプリケーション共通マスタのエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.company | 会社・組織関連の情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.public_group | パブリックグループ情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.user | ユーザ関連の情報のエクスポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.exporter での ExportManagerClient の使用

ExportManagerClient を実装している jp.co.intra_mart.foundation.datastore.exporter のクラス
 class AbstractExportManagerClient
エクスポートマネージャークライアントの汎用的な実装です。

jp.co.intra_mart.foundation.datastore.exporter.company での ExportManagerClient の使用

ExportManagerClient を実装している jp.co.intra_mart.foundation.datastore.exporter.company のクラス
class | CompanyExportManagerClient 会社情報のエクスポートを行います。
class | CompanyPostExportManagerClient 会社役職情報のエクスポートを行います。

jp.co.intra_mart.foundation.datastore.exporter.public_group での ExportManagerClient の使用

ExportManagerClient を実装している jp.co.intra_mart.foundation.datastore.exporter.public_group のクラス
 class PublicGroupExportManagerClient
パブリックグループ情報のエクスポートを行います。

jp.co.intra_mart.foundation.datastore.exporter.user での ExportManagerClient の使用

ExportManagerClient を実装している jp.co.intra_mart.foundation.datastore.exporter.user のクラス
class | UserAttachExportManagerClient ユーザ所属情報のエクスポートを行います。
class | UserProfileExportManagerClient ユーザ情報のエクスポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl の使用

jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.Filter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.Filter の使用

Filter を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exporter | アプリケーション共通マスタのエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.common.config | エクスポート設定の解釈を行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.company | 会社・組織関連の情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.public_group | パブリックグループ情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.user | ユーザ関連の情報のエクスポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.exporter での Filter の使用

Filter 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.exporter のメソッド
void | ExportManagerImpl.setFilter(Filter filter) エクスポートフィルタを設定します。
void | ExportManager.setFilter(Filter filter) エクスポート対象を絞り込むためのフィルタを設定します。

jp.co.intra_mart.foundation.datastore.exporter.common.config での Filter の使用

Filter を返す jp.co.intra_mart.foundation.datastore.exporter.common.config のメソッド
 Filter ExportConfigurationReader.getFilter()
エクスポートのフィルタ情報を取得します。

jp.co.intra_mart.foundation.datastore.exporter.company での Filter の使用

Filter 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.exporter.company のメソッド
void | CompanyPostExportManager.setFilter(Filter filter)
void | CompanyExportManager.setFilter(Filter filter)

jp.co.intra_mart.foundation.datastore.exporter.public_group での Filter の使用

Filter 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.exporter.public_group のメソッド
 void PublicGroupExportManager.setFilter(Filter filter)

jp.co.intra_mart.foundation.datastore.exporter.user での Filter の使用

Filter 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.exporter.user のメソッド
void | UserProfileExportManager.setFilter(Filter filter)
void | UserAttachExportManager.setFilter(Filter filter)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader の使用

ExportConfigurationReader を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exporter | アプリケーション共通マスタのエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.company | 会社・組織関連の情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.public_group | パブリックグループ情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.user | ユーザ関連の情報のエクスポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.exporter での ExportConfigurationReader の使用

ExportConfigurationReader を返す jp.co.intra_mart.foundation.datastore.exporter のメソッド
protected abstract  ExportConfigurationReader AbstractExportManagerClient.getConfigurationReader(InputStream inputStream)
入力ストリームからエクスポート設定情報を取得します。

ExportConfigurationReader 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.exporter のメソッド
protected void | AbstractExportManagerClient.setName(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義された処理名をマネージャーに設定します。
protected void | AbstractExportManagerClient.setFormat(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたエクスポートデータのフォーマットをマネージャーに設定します。
protected void | AbstractExportManagerClient.setDate(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義された日付をマネージャーに設定します。
protected void | AbstractExportManagerClient.setEncoding(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたエクスポートデータのエンコーディング情報をマネージャーに設定します。
protected void | AbstractExportManagerClient.setSize(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたエクスポート単位のデータ数をマネージャーに設定します。
protected void | AbstractExportManagerClient.setExecuteUser(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義された実行ユーザコードをマネージャーに設定します。
protected void | AbstractExportManagerClient.setFilter(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたフィルタの情報をマネージャーに設定します。
protected void | AbstractExportManagerClient.setParameters(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたパラメータ情報をマネージャーに設定します。

jp.co.intra_mart.foundation.datastore.exporter.company での ExportConfigurationReader の使用

ExportConfigurationReader を返す jp.co.intra_mart.foundation.datastore.exporter.company のメソッド
protected ExportConfigurationReader | CompanyPostExportManagerClient.getConfigurationReader(InputStream inputStream)
protected ExportConfigurationReader | CompanyExportManagerClient.getConfigurationReader(InputStream inputStream)

jp.co.intra_mart.foundation.datastore.exporter.public_group での ExportConfigurationReader の使用

ExportConfigurationReader を返す jp.co.intra_mart.foundation.datastore.exporter.public_group のメソッド
protected  ExportConfigurationReader PublicGroupExportManagerClient.getConfigurationReader(InputStream inputStream)

jp.co.intra_mart.foundation.datastore.exporter.user での ExportConfigurationReader の使用

ExportConfigurationReader を返す jp.co.intra_mart.foundation.datastore.exporter.user のメソッド
protected ExportConfigurationReader | UserProfileExportManagerClient.getConfigurationReader(InputStream inputStream)
protected ExportConfigurationReader | UserAttachExportManagerClient.getConfigurationReader(InputStream inputStream)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReaderException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReaderException の使用

jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReaderException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ExportConfigurationReader (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter.common.config
インタフェース ExportConfigurationReader

public interface ExportConfigurationReader

エクスポート設定情報の読込みを行います。

導入されたバージョン:
6.1

メソッドの概要
Date | getDate() 日付を取得します。
String | getEncoding() エクスポートデータのエンコーディング情報を取得します。
String | getExecuteUser() 実行ユーザコードを取得します。
String[] | getExtensionParameterNames() パラメータ名の一覧を取得します。
String | getExtensionParameterValue(String key) 指定されたキーに対するパラメータ値を取得します。
Filter | getFilter() エクスポートのフィルタ情報を取得します。
String | getFormat() エクスポートデータのフォーマットを取得します。
String | getName() エクスポート処理名を取得します。
String | getOutputPath() エクスポートデータを出力するファイルパスを取得します。
int | getSize() エクスポート単位のデータ数を取得します。
void | initialize(String rootName) 初期化を行います。

メソッドの詳細

initialize

public void initialize(String rootName)
初期化を行います。
指定された要素内に定義された設定情報を読込みます。

パラメータ:
rootName - 設定情報を定義するルート要素の名前

getName

public String getName()
エクスポート処理名を取得します。

戻り値:
エクスポート処理名
例外:
ExportConfigurationReaderException - 設定情報の定義が不正な場合

getFormat

public String getFormat()
エクスポートデータのフォーマットを取得します。

戻り値:
エクスポートデータのフォーマット
例外:
ExportConfigurationReaderException - 設定情報の定義が不正な場合

getDate

public Date getDate()
日付を取得します。

戻り値:
日付
例外:
ExportConfigurationReaderException - 設定情報の定義が不正な場合

getEncoding

public String getEncoding()
エクスポートデータのエンコーディング情報を取得します。

戻り値:
エクスポートデータのエンコーディング情報
例外:
ExportConfigurationReaderException - 設定情報の定義が不正な場合

getExecuteUser

public String getExecuteUser()
実行ユーザコードを取得します。

戻り値:
実行ユーザコード
例外:
ExportConfigurationReaderException - 設定情報の定義が不正な場合

getOutputPath

public String getOutputPath()
エクスポートデータを出力するファイルパスを取得します。

戻り値:
出力ファイルパス
例外:
ExportConfigurationReaderException - 設定情報の定義が不正な場合

getSize

public int getSize()
エクスポート単位のデータ数を取得します。

戻り値:
エクスポート単位となるデータ数
例外:
ExportConfigurationReaderException - 設定情報の定義が不正な場合

getFilter

public Filter getFilter()
エクスポートのフィルタ情報を取得します。

戻り値:
エクスポートのフィルタ
例外:
ExportConfigurationReaderException - 設定情報の定義が不正な場合

getExtensionParameterNames

public String[] getExtensionParameterNames()
パラメータ名の一覧を取得します。

戻り値:
パラメータ名の一覧

getExtensionParameterValue

public String getExtensionParameterValue(String key)
指定されたキーに対するパラメータ値を取得します。

パラメータ:
key - キー
戻り値:
パラメータ値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExportConfigurationReaderException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter.common.config
クラス ExportConfigurationReaderException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.datastore.exception.BatchProcessException
                    拡張 jp.co.intra_mart.foundation.datastore.exporter.ExportInitializeException
                        拡張 jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReaderException
すべての実装インタフェース:
Serializable
public class ExportConfigurationReaderException
extends ExportInitializeException

エクスポート設定の読み込みでエラーが発生したことを示すためにスローされます。

導入されたバージョン:
6.1
関連項目:
直列化された形式

コンストラクタの概要
ExportConfigurationReaderException(String message)
コンストラクタ
ExportConfigurationReaderException(String message, Throwable cause)
コンストラクタ
ExportConfigurationReaderException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExportConfigurationReaderException

public ExportConfigurationReaderException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

ExportConfigurationReaderException

public ExportConfigurationReaderException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

ExportConfigurationReaderException

public ExportConfigurationReaderException(String message,
                                          Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.exporter.common.config (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.exporter.common.config
インタフェース
ExportConfigurationReader
例外
ExportConfigurationReaderException


jp.co.intra_mart.foundation.datastore.exporter.common.config (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exporter.common.config

エクスポート設定の解釈を行うクラスを提供します。

参照:
説明

インタフェースの概要
ExportConfigurationReader エクスポート設定情報の読込みを行います。

例外の概要
ExportConfigurationReaderException エクスポート設定の読み込みでエラーが発生したことを示すためにスローされます。

パッケージ jp.co.intra_mart.foundation.datastore.exporter.common.config の説明

エクスポート設定の解釈を行うクラスを提供します。


jp.co.intra_mart.foundation.datastore.exporter.common.config クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exporter.common.config の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.datastore.exception.BatchProcessException
            • class jp.co.intra_mart.foundation.datastore.exporter.ExportInitializeException
              • class jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReaderException

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader


パッケージ jp.co.intra_mart.foundation.datastore.exporter.common.config の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.exporter.common.config の使用

jp.co.intra_mart.foundation.datastore.exporter.common.config を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exporter | アプリケーション共通マスタのエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.company | 会社・組織関連の情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.public_group | パブリックグループ情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.user | ユーザ関連の情報のエクスポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.exporter により使用される jp.co.intra_mart.foundation.datastore.exporter.common.config のクラス
ExportConfigurationReader
エクスポート設定情報の読込みを行います。

jp.co.intra_mart.foundation.datastore.exporter.company により使用される jp.co.intra_mart.foundation.datastore.exporter.common.config のクラス
ExportConfigurationReader
エクスポート設定情報の読込みを行います。

jp.co.intra_mart.foundation.datastore.exporter.public_group により使用される jp.co.intra_mart.foundation.datastore.exporter.common.config のクラス
ExportConfigurationReader
エクスポート設定情報の読込みを行います。

jp.co.intra_mart.foundation.datastore.exporter.user により使用される jp.co.intra_mart.foundation.datastore.exporter.common.config のクラス
ExportConfigurationReader
エクスポート設定情報の読込みを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager の使用

jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient の使用

jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager の使用

jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient の使用

jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CompanyExportManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter.company
クラス CompanyExportManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager
すべての実装インタフェース:
ExportManager
public class CompanyExportManager
extends Object
implements ExportManager

会社情報のエクスポートを行います。

導入されたバージョン:
6.1

コンストラクタの概要
CompanyExportManager()
コンストラクタ 会社情報エクスポートマネージャーのインスタンスを生成します。
メソッドの概要
void | execute(OutputStream outputStream) エクスポートを実行します。
void | execute(String path) エクスポートを実行します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) エクスポートデータのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザコードを設定します。
void | setFilter(Filter filter) エクスポート対象を絞り込むためのフィルタを設定します。
void | setFormat(String format) エクスポートデータのフォーマットを設定します。
void | setName(String name) エクスポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setSize(int size) エクスポート単位のデータ数を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyExportManager

public CompanyExportManager()
コンストラクタ 会社情報エクスポートマネージャーのインスタンスを生成します。

メソッドの詳細

execute

public void execute(String path)
インタフェース ExportManager の記述:
エクスポートを実行します。
指定されたパスにエクスポートした情報を出力します。

定義:
インタフェース ExportManager 内の execute
パラメータ:
path - 出力パス

execute

public void execute(OutputStream outputStream)
インタフェース ExportManager の記述:
エクスポートを実行します。
指定された出力ストリームにエクスポートした情報を出力します。

定義:
インタフェース ExportManager 内の execute
パラメータ:
outputStream - 出力ストリーム

setDate

public void setDate(Date date)
インタフェース ExportManager の記述:
日付を設定します。
設定可能な日付はシステムの有効期間内に限られます。

定義:
インタフェース ExportManager 内の setDate
パラメータ:
date - 日付
関連項目:
DateUtil#getMinDate(), DateUtil#getMaxDate()

setEncoding

public void setEncoding(String encoding)
インタフェース ExportManager の記述:
エクスポートデータのエンコーディングを設定します。

定義:
インタフェース ExportManager 内の setEncoding
パラメータ:
encoding - エンコーディング

setExecuteUser

public void setExecuteUser(String user)
インタフェース ExportManager の記述:
実行ユーザコードを設定します。

定義:
インタフェース ExportManager 内の setExecuteUser
パラメータ:
user - 実行ユーザ

setFilter

public void setFilter(Filter filter)
インタフェース ExportManager の記述:
エクスポート対象を絞り込むためのフィルタを設定します。

定義:
インタフェース ExportManager 内の setFilter
パラメータ:
filter - フィルタ

setFormat

public void setFormat(String format)
インタフェース ExportManager の記述:
エクスポートデータのフォーマットを設定します。

定義:
インタフェース ExportManager 内の setFormat
パラメータ:
format - エクスポートデータのフォーマット

setName

public void setName(String name)
インタフェース ExportManager の記述:
エクスポート処理名を設定します。
この処理名を使って、エクスポート処理の排他制御を行います。
(同じ処理名をもつエクスポート処理を同時に実行することはできません。)

定義:
インタフェース ExportManager 内の setName
パラメータ:
name - エクスポート処理名

setParameter

public void setParameter(String key,
                         Object value)
インタフェース ExportManager の記述:
パラメータを設定します。
エクスポート実行時に使用する任意のパラメータを設定します。

定義:
インタフェース ExportManager 内の setParameter
パラメータ:
key - キー
value - 値

setSize

public void setSize(int size)
インタフェース ExportManager の記述:
エクスポート単位のデータ数を設定します。

定義:
インタフェース ExportManager 内の setSize
パラメータ:
size - エクスポート単位のデータ数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyExportManagerClient (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter.company
クラス CompanyExportManagerClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient
        拡張 jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient
すべての実装インタフェース:
ExportManagerClient
public class CompanyExportManagerClient
extends AbstractExportManagerClient
implements ExportManagerClient

会社情報のエクスポートを行います。

このクラスは、CompanyExportManager クラスのクライアントになります。
executeメソッドに指定された設定情報を解釈した後、CompanyExportManager クラスに エクスポート処理を委譲します。

導入されたバージョン:
6.1

コンストラクタの概要
CompanyExportManagerClient()
メソッドの概要
boolean | execute(InputStream configuration) エクスポートマネージャーを呼び出します。
boolean | execute(String configurationPath) エクスポートマネージャーを呼び出します。
protected ExportConfigurationReader | getConfigurationReader(InputStream inputStream) 入力ストリームからエクスポート設定情報を取得します。
protected String | getDefaultPath() エクスポート情報の出力ファイルのデフォルトパス情報を取得します。
protected ExportManager | getExportManager() エクスポートマネージャーのインスタンスを取得します。
クラス jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient から継承したメソッド
setDate, setEncoding, setExecuteUser, setFilter, setFormat, setName, setParameters, setSize
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyExportManagerClient

public CompanyExportManagerClient()
メソッドの詳細

execute

public boolean execute(String configurationPath)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーを初期化して、エクスポートを実行します。

定義:
インタフェース ExportManagerClient 内の execute
オーバーライド:
クラス AbstractExportManagerClient 内の execute
パラメータ:
configurationPath - エクスポート設定ファイルパス
戻り値:
エクスポートに成功した場合 true、失敗した場合 false

execute

public boolean execute(InputStream configuration)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーを初期化して、エクスポートを実行します。

定義:
インタフェース ExportManagerClient 内の execute
オーバーライド:
クラス AbstractExportManagerClient 内の execute
パラメータ:
configuration - エクスポート設定情報
戻り値:
エクスポートに成功した場合 true、失敗した場合 false

getExportManager

protected ExportManager getExportManager()
クラス AbstractExportManagerClient の記述:
エクスポートマネージャーのインスタンスを取得します。

定義:
クラス AbstractExportManagerClient 内の getExportManager
戻り値:
エクスポートマネージャー

getConfigurationReader

protected ExportConfigurationReader getConfigurationReader(InputStream inputStream)
クラス AbstractExportManagerClient の記述:
入力ストリームからエクスポート設定情報を取得します。

定義:
クラス AbstractExportManagerClient 内の getConfigurationReader
パラメータ:
inputStream - 入力ストリーム
戻り値:
エクスポート設定リーダー

getDefaultPath

protected String getDefaultPath()
クラス AbstractExportManagerClient の記述:
エクスポート情報の出力ファイルのデフォルトパス情報を取得します。

定義:
クラス AbstractExportManagerClient 内の getDefaultPath
戻り値:
出力ファイルパス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyPostExportManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter.company
クラス CompanyPostExportManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager
すべての実装インタフェース:
ExportManager
public class CompanyPostExportManager
extends Object
implements ExportManager

会社役職情報のエクスポートを行います。

導入されたバージョン:
6.1

コンストラクタの概要
CompanyPostExportManager()
コンストラクタ 会社役職エクスポートマネージャーのインスタンスを生成します。
メソッドの概要
void | execute(OutputStream outputStream) エクスポートを実行します。
void | execute(String path) エクスポートを実行します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) エクスポートデータのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザコードを設定します。
void | setFilter(Filter filter) エクスポート対象を絞り込むためのフィルタを設定します。
void | setFormat(String format) エクスポートデータのフォーマットを設定します。
void | setName(String name) エクスポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setSize(int size) エクスポート単位のデータ数を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyPostExportManager

public CompanyPostExportManager()
コンストラクタ 会社役職エクスポートマネージャーのインスタンスを生成します。

メソッドの詳細

execute

public void execute(String path)
インタフェース ExportManager の記述:
エクスポートを実行します。
指定されたパスにエクスポートした情報を出力します。

定義:
インタフェース ExportManager 内の execute
パラメータ:
path - 出力パス

execute

public void execute(OutputStream outputStream)
インタフェース ExportManager の記述:
エクスポートを実行します。
指定された出力ストリームにエクスポートした情報を出力します。

定義:
インタフェース ExportManager 内の execute
パラメータ:
outputStream - 出力ストリーム

setDate

public void setDate(Date date)
インタフェース ExportManager の記述:
日付を設定します。
設定可能な日付はシステムの有効期間内に限られます。

定義:
インタフェース ExportManager 内の setDate
パラメータ:
date - 日付
関連項目:
DateUtil#getMinDate(), DateUtil#getMaxDate()

setEncoding

public void setEncoding(String encoding)
インタフェース ExportManager の記述:
エクスポートデータのエンコーディングを設定します。

定義:
インタフェース ExportManager 内の setEncoding
パラメータ:
encoding - エンコーディング

setExecuteUser

public void setExecuteUser(String user)
インタフェース ExportManager の記述:
実行ユーザコードを設定します。

定義:
インタフェース ExportManager 内の setExecuteUser
パラメータ:
user - 実行ユーザ

setFilter

public void setFilter(Filter filter)
インタフェース ExportManager の記述:
エクスポート対象を絞り込むためのフィルタを設定します。

定義:
インタフェース ExportManager 内の setFilter
パラメータ:
filter - フィルタ

setFormat

public void setFormat(String format)
インタフェース ExportManager の記述:
エクスポートデータのフォーマットを設定します。

定義:
インタフェース ExportManager 内の setFormat
パラメータ:
format - エクスポートデータのフォーマット

setName

public void setName(String name)
インタフェース ExportManager の記述:
エクスポート処理名を設定します。
この処理名を使って、エクスポート処理の排他制御を行います。
(同じ処理名をもつエクスポート処理を同時に実行することはできません。)

定義:
インタフェース ExportManager 内の setName
パラメータ:
name - エクスポート処理名

setParameter

public void setParameter(String key,
                         Object value)
インタフェース ExportManager の記述:
パラメータを設定します。
エクスポート実行時に使用する任意のパラメータを設定します。

定義:
インタフェース ExportManager 内の setParameter
パラメータ:
key - キー
value - 値

setSize

public void setSize(int size)
インタフェース ExportManager の記述:
エクスポート単位のデータ数を設定します。

定義:
インタフェース ExportManager 内の setSize
パラメータ:
size - エクスポート単位のデータ数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyPostExportManagerClient (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter.company
クラス CompanyPostExportManagerClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient
        拡張 jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient
すべての実装インタフェース:
ExportManagerClient
public class CompanyPostExportManagerClient
extends AbstractExportManagerClient
implements ExportManagerClient

会社役職情報のエクスポートを行います。

このクラスは、CompanyPostExportManager クラスのクライアントになります。
executeメソッドに指定された定義された情報を解釈した後、CompanyPostExportManager クラスに エクスポート処理を委譲します。

導入されたバージョン:
6.1

コンストラクタの概要
CompanyPostExportManagerClient()
メソッドの概要
boolean | execute(InputStream configuration) エクスポートマネージャーを呼び出します。
boolean | execute(String configurationPath) エクスポートマネージャーを呼び出します。
protected ExportConfigurationReader | getConfigurationReader(InputStream inputStream) 入力ストリームからエクスポート設定情報を取得します。
protected String | getDefaultPath() エクスポート情報の出力ファイルのデフォルトパス情報を取得します。
protected ExportManager | getExportManager() エクスポートマネージャーのインスタンスを取得します。
クラス jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient から継承したメソッド
setDate, setEncoding, setExecuteUser, setFilter, setFormat, setName, setParameters, setSize
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyPostExportManagerClient

public CompanyPostExportManagerClient()
メソッドの詳細

execute

public boolean execute(String configurationPath)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーを初期化して、エクスポートを実行します。

定義:
インタフェース ExportManagerClient 内の execute
オーバーライド:
クラス AbstractExportManagerClient 内の execute
パラメータ:
configurationPath - エクスポート設定ファイルパス
戻り値:
エクスポートに成功した場合 true、失敗した場合 false

execute

public boolean execute(InputStream configuration)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーを初期化して、エクスポートを実行します。

定義:
インタフェース ExportManagerClient 内の execute
オーバーライド:
クラス AbstractExportManagerClient 内の execute
パラメータ:
configuration - エクスポート設定情報
戻り値:
エクスポートに成功した場合 true、失敗した場合 false

getExportManager

protected ExportManager getExportManager()
クラス AbstractExportManagerClient の記述:
エクスポートマネージャーのインスタンスを取得します。

定義:
クラス AbstractExportManagerClient 内の getExportManager
戻り値:
エクスポートマネージャー

getConfigurationReader

protected ExportConfigurationReader getConfigurationReader(InputStream inputStream)
クラス AbstractExportManagerClient の記述:
入力ストリームからエクスポート設定情報を取得します。

定義:
クラス AbstractExportManagerClient 内の getConfigurationReader
パラメータ:
inputStream - 入力ストリーム
戻り値:
エクスポート設定リーダー

getDefaultPath

protected String getDefaultPath()
クラス AbstractExportManagerClient の記述:
エクスポート情報の出力ファイルのデフォルトパス情報を取得します。

定義:
クラス AbstractExportManagerClient 内の getDefaultPath
戻り値:
出力ファイルパス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.exporter.company (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.exporter.company
クラス
CompanyExportManager
CompanyExportManagerClient
CompanyPostExportManager
CompanyPostExportManagerClient


jp.co.intra_mart.foundation.datastore.exporter.company (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exporter.company

会社・組織関連の情報のエクスポートを行うクラスを提供します。

参照:
説明

クラスの概要
CompanyExportManager | 会社情報のエクスポートを行います。
CompanyExportManagerClient | 会社情報のエクスポートを行います。
CompanyPostExportManager | 会社役職情報のエクスポートを行います。
CompanyPostExportManagerClient | 会社役職情報のエクスポートを行います。

パッケージ jp.co.intra_mart.foundation.datastore.exporter.company の説明

会社・組織関連の情報のエクスポートを行うクラスを提供します。


jp.co.intra_mart.foundation.datastore.exporter.company クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exporter.company の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
    • class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManager)
    • class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManager)


パッケージ jp.co.intra_mart.foundation.datastore.exporter.company の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.exporter.company の使用

jp.co.intra_mart.foundation.datastore.exporter.company はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager の使用

jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient の使用

jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.exporter.public_group (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.exporter.public_group
クラス
PublicGroupExportManager
PublicGroupExportManagerClient


jp.co.intra_mart.foundation.datastore.exporter.public_group (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exporter.public_group

パブリックグループ情報のエクスポートを行うクラスを提供します。

参照:
説明

クラスの概要
PublicGroupExportManager | パブリックグループ情報のエクスポートを行います。
PublicGroupExportManagerClient | パブリックグループ情報のエクスポートを行います。

パッケージ jp.co.intra_mart.foundation.datastore.exporter.public_group の説明

パブリックグループ情報のエクスポートを行うクラスを提供します。


jp.co.intra_mart.foundation.datastore.exporter.public_group クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exporter.public_group の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
    • class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManager)


パッケージ jp.co.intra_mart.foundation.datastore.exporter.public_group の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.exporter.public_group の使用

jp.co.intra_mart.foundation.datastore.exporter.public_group はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupExportManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter.public_group
クラス PublicGroupExportManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager
すべての実装インタフェース:
ExportManager
public class PublicGroupExportManager
extends Object
implements ExportManager

パブリックグループ情報のエクスポートを行います。

導入されたバージョン:
6.1

コンストラクタの概要
PublicGroupExportManager()
コンストラクタ パブリックグループ情報エクスポートマネージャーのインスタンスを生成します。
メソッドの概要
void | execute(OutputStream outputStream) エクスポートを実行します。
void | execute(String path) エクスポートを実行します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) エクスポートデータのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザコードを設定します。
void | setFilter(Filter filter) エクスポート対象を絞り込むためのフィルタを設定します。
void | setFormat(String format) エクスポートデータのフォーマットを設定します。
void | setName(String name) エクスポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setSize(int size) エクスポート単位のデータ数を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupExportManager

public PublicGroupExportManager()
コンストラクタ パブリックグループ情報エクスポートマネージャーのインスタンスを生成します。

メソッドの詳細

execute

public void execute(String path)
インタフェース ExportManager の記述:
エクスポートを実行します。
指定されたパスにエクスポートした情報を出力します。

定義:
インタフェース ExportManager 内の execute
パラメータ:
path - 出力パス

execute

public void execute(OutputStream outputStream)
インタフェース ExportManager の記述:
エクスポートを実行します。
指定された出力ストリームにエクスポートした情報を出力します。

定義:
インタフェース ExportManager 内の execute
パラメータ:
outputStream - 出力ストリーム

setDate

public void setDate(Date date)
インタフェース ExportManager の記述:
日付を設定します。
設定可能な日付はシステムの有効期間内に限られます。

定義:
インタフェース ExportManager 内の setDate
パラメータ:
date - 日付
関連項目:
DateUtil#getMinDate(), DateUtil#getMaxDate()

setEncoding

public void setEncoding(String encoding)
インタフェース ExportManager の記述:
エクスポートデータのエンコーディングを設定します。

定義:
インタフェース ExportManager 内の setEncoding
パラメータ:
encoding - エンコーディング

setExecuteUser

public void setExecuteUser(String user)
インタフェース ExportManager の記述:
実行ユーザコードを設定します。

定義:
インタフェース ExportManager 内の setExecuteUser
パラメータ:
user - 実行ユーザ

setFilter

public void setFilter(Filter filter)
インタフェース ExportManager の記述:
エクスポート対象を絞り込むためのフィルタを設定します。

定義:
インタフェース ExportManager 内の setFilter
パラメータ:
filter - フィルタ

setFormat

public void setFormat(String format)
インタフェース ExportManager の記述:
エクスポートデータのフォーマットを設定します。

定義:
インタフェース ExportManager 内の setFormat
パラメータ:
format - エクスポートデータのフォーマット

setName

public void setName(String name)
インタフェース ExportManager の記述:
エクスポート処理名を設定します。
この処理名を使って、エクスポート処理の排他制御を行います。
(同じ処理名をもつエクスポート処理を同時に実行することはできません。)

定義:
インタフェース ExportManager 内の setName
パラメータ:
name - エクスポート処理名

setParameter

public void setParameter(String key,
                         Object value)
インタフェース ExportManager の記述:
パラメータを設定します。
エクスポート実行時に使用する任意のパラメータを設定します。

定義:
インタフェース ExportManager 内の setParameter
パラメータ:
key - キー
value - 値

setSize

public void setSize(int size)
インタフェース ExportManager の記述:
エクスポート単位のデータ数を設定します。

定義:
インタフェース ExportManager 内の setSize
パラメータ:
size - エクスポート単位のデータ数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupExportManagerClient (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter.public_group
クラス PublicGroupExportManagerClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient
        拡張 jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient
すべての実装インタフェース:
ExportManagerClient
public class PublicGroupExportManagerClient
extends AbstractExportManagerClient
implements ExportManagerClient

パブリックグループ情報のエクスポートを行います。

このクラスは、PublicGroupExportManager クラスのクライアントになります。
executeメソッドに指定された設定情報を解釈した後、PublicGroupExportManager クラスに エクスポート処理を委譲します。

導入されたバージョン:
6.1

コンストラクタの概要
PublicGroupExportManagerClient()
メソッドの概要
boolean | execute(InputStream configuration) エクスポートマネージャーを呼び出します。
boolean | execute(String configurationPath) エクスポートマネージャーを呼び出します。
protected ExportConfigurationReader | getConfigurationReader(InputStream inputStream) 入力ストリームからエクスポート設定情報を取得します。
protected String | getDefaultPath() エクスポート情報の出力ファイルのデフォルトパス情報を取得します。
protected ExportManager | getExportManager() エクスポートマネージャーのインスタンスを取得します。
クラス jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient から継承したメソッド
setDate, setEncoding, setExecuteUser, setFilter, setFormat, setName, setParameters, setSize
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupExportManagerClient

public PublicGroupExportManagerClient()
メソッドの詳細

execute

public boolean execute(String configurationPath)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーを初期化して、エクスポートを実行します。

定義:
インタフェース ExportManagerClient 内の execute
オーバーライド:
クラス AbstractExportManagerClient 内の execute
パラメータ:
configurationPath - エクスポート設定ファイルパス
戻り値:
エクスポートに成功した場合 true、失敗した場合 false

execute

public boolean execute(InputStream configuration)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーを初期化して、エクスポートを実行します。

定義:
インタフェース ExportManagerClient 内の execute
オーバーライド:
クラス AbstractExportManagerClient 内の execute
パラメータ:
configuration - エクスポート設定情報
戻り値:
エクスポートに成功した場合 true、失敗した場合 false

getExportManager

protected ExportManager getExportManager()
クラス AbstractExportManagerClient の記述:
エクスポートマネージャーのインスタンスを取得します。

定義:
クラス AbstractExportManagerClient 内の getExportManager
戻り値:
エクスポートマネージャー

getConfigurationReader

protected ExportConfigurationReader getConfigurationReader(InputStream inputStream)
クラス AbstractExportManagerClient の記述:
入力ストリームからエクスポート設定情報を取得します。

定義:
クラス AbstractExportManagerClient 内の getConfigurationReader
パラメータ:
inputStream - 入力ストリーム
戻り値:
エクスポート設定リーダー

getDefaultPath

protected String getDefaultPath()
クラス AbstractExportManagerClient の記述:
エクスポート情報の出力ファイルのデフォルトパス情報を取得します。

定義:
クラス AbstractExportManagerClient 内の getDefaultPath
戻り値:
出力ファイルパス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager の使用

jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient の使用

jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager の使用

jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient の使用

jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.exporter.user (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.exporter.user
クラス
UserAttachExportManager
UserAttachExportManagerClient
UserProfileExportManager
UserProfileExportManagerClient


jp.co.intra_mart.foundation.datastore.exporter.user (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exporter.user

ユーザ関連の情報のエクスポートを行うクラスを提供します。

参照:
説明

クラスの概要
UserAttachExportManager | ユーザ所属情報のエクスポートを行います。
UserAttachExportManagerClient | ユーザ所属情報のエクスポートを行います。
UserProfileExportManager | ユーザ情報のエクスポートを行います。
UserProfileExportManagerClient | ユーザ情報のエクスポートを行います。

パッケージ jp.co.intra_mart.foundation.datastore.exporter.user の説明

ユーザ関連の情報のエクスポートを行うクラスを提供します。


jp.co.intra_mart.foundation.datastore.exporter.user クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exporter.user の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
    • class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManager)
    • class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManager)


パッケージ jp.co.intra_mart.foundation.datastore.exporter.user の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.exporter.user の使用

jp.co.intra_mart.foundation.datastore.exporter.user はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


UserAttachExportManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter.user
クラス UserAttachExportManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager
すべての実装インタフェース:
ExportManager
public class UserAttachExportManager
extends Object
implements ExportManager

ユーザ所属情報のエクスポートを行います。

導入されたバージョン:
6.1

コンストラクタの概要
UserAttachExportManager()
コンストラクタ ユーザ所属情報エクスポートマネージャーのインスタンスを生成します。
メソッドの概要
void | execute(OutputStream outputStream) エクスポートを実行します。
void | execute(String path) エクスポートを実行します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) エクスポートデータのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザコードを設定します。
void | setFilter(Filter filter) エクスポート対象を絞り込むためのフィルタを設定します。
void | setFormat(String format) エクスポートデータのフォーマットを設定します。
void | setName(String name) エクスポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setSize(int size) エクスポート単位のデータ数を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserAttachExportManager

public UserAttachExportManager()
コンストラクタ ユーザ所属情報エクスポートマネージャーのインスタンスを生成します。

メソッドの詳細

execute

public void execute(String path)
インタフェース ExportManager の記述:
エクスポートを実行します。
指定されたパスにエクスポートした情報を出力します。

定義:
インタフェース ExportManager 内の execute
パラメータ:
path - 出力パス

execute

public void execute(OutputStream outputStream)
インタフェース ExportManager の記述:
エクスポートを実行します。
指定された出力ストリームにエクスポートした情報を出力します。

定義:
インタフェース ExportManager 内の execute
パラメータ:
outputStream - 出力ストリーム

setDate

public void setDate(Date date)
インタフェース ExportManager の記述:
日付を設定します。
設定可能な日付はシステムの有効期間内に限られます。

定義:
インタフェース ExportManager 内の setDate
パラメータ:
date - 日付
関連項目:
DateUtil#getMinDate(), DateUtil#getMaxDate()

setEncoding

public void setEncoding(String encoding)
インタフェース ExportManager の記述:
エクスポートデータのエンコーディングを設定します。

定義:
インタフェース ExportManager 内の setEncoding
パラメータ:
encoding - エンコーディング

setExecuteUser

public void setExecuteUser(String user)
インタフェース ExportManager の記述:
実行ユーザコードを設定します。

定義:
インタフェース ExportManager 内の setExecuteUser
パラメータ:
user - 実行ユーザ

setFilter

public void setFilter(Filter filter)
インタフェース ExportManager の記述:
エクスポート対象を絞り込むためのフィルタを設定します。

定義:
インタフェース ExportManager 内の setFilter
パラメータ:
filter - フィルタ

setFormat

public void setFormat(String format)
インタフェース ExportManager の記述:
エクスポートデータのフォーマットを設定します。

定義:
インタフェース ExportManager 内の setFormat
パラメータ:
format - エクスポートデータのフォーマット

setName

public void setName(String name)
インタフェース ExportManager の記述:
エクスポート処理名を設定します。
この処理名を使って、エクスポート処理の排他制御を行います。
(同じ処理名をもつエクスポート処理を同時に実行することはできません。)

定義:
インタフェース ExportManager 内の setName
パラメータ:
name - エクスポート処理名

setParameter

public void setParameter(String key,
                         Object value)
インタフェース ExportManager の記述:
パラメータを設定します。
エクスポート実行時に使用する任意のパラメータを設定します。

定義:
インタフェース ExportManager 内の setParameter
パラメータ:
key - キー
value - 値

setSize

public void setSize(int size)
インタフェース ExportManager の記述:
エクスポート単位のデータ数を設定します。

定義:
インタフェース ExportManager 内の setSize
パラメータ:
size - エクスポート単位のデータ数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UserAttachExportManagerClient (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter.user
クラス UserAttachExportManagerClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient
        拡張 jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient
すべての実装インタフェース:
ExportManagerClient
public class UserAttachExportManagerClient
extends AbstractExportManagerClient
implements ExportManagerClient

ユーザ所属情報のエクスポートを行います。

このクラスは、UserAttachExportManager クラスのクライアントになります。
executeメソッドに指定された設定情報を解釈した後、UserAttachExportManager クラスに エクスポート処理を委譲します。

導入されたバージョン:
6.1

コンストラクタの概要
UserAttachExportManagerClient()
メソッドの概要
boolean | execute(InputStream configuration) エクスポートマネージャーを呼び出します。
boolean | execute(String configurationPath) エクスポートマネージャーを呼び出します。
protected ExportConfigurationReader | getConfigurationReader(InputStream inputStream) 入力ストリームからエクスポート設定情報を取得します。
protected String | getDefaultPath() エクスポート情報の出力ファイルのデフォルトパス情報を取得します。
protected ExportManager | getExportManager() エクスポートマネージャーのインスタンスを取得します。
クラス jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient から継承したメソッド
setDate, setEncoding, setExecuteUser, setFilter, setFormat, setName, setParameters, setSize
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserAttachExportManagerClient

public UserAttachExportManagerClient()
メソッドの詳細

execute

public boolean execute(String configurationPath)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーを初期化して、エクスポートを実行します。

定義:
インタフェース ExportManagerClient 内の execute
オーバーライド:
クラス AbstractExportManagerClient 内の execute
パラメータ:
configurationPath - エクスポート設定ファイルパス
戻り値:
エクスポートに成功した場合 true、失敗した場合 false

execute

public boolean execute(InputStream configuration)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーを初期化して、エクスポートを実行します。

定義:
インタフェース ExportManagerClient 内の execute
オーバーライド:
クラス AbstractExportManagerClient 内の execute
パラメータ:
configuration - エクスポート設定情報
戻り値:
エクスポートに成功した場合 true、失敗した場合 false

getExportManager

protected ExportManager getExportManager()
クラス AbstractExportManagerClient の記述:
エクスポートマネージャーのインスタンスを取得します。

定義:
クラス AbstractExportManagerClient 内の getExportManager
戻り値:
エクスポートマネージャー

getConfigurationReader

protected ExportConfigurationReader getConfigurationReader(InputStream inputStream)
クラス AbstractExportManagerClient の記述:
入力ストリームからエクスポート設定情報を取得します。

定義:
クラス AbstractExportManagerClient 内の getConfigurationReader
パラメータ:
inputStream - 入力ストリーム
戻り値:
エクスポート設定リーダー

getDefaultPath

protected String getDefaultPath()
クラス AbstractExportManagerClient の記述:
エクスポート情報の出力ファイルのデフォルトパス情報を取得します。

定義:
クラス AbstractExportManagerClient 内の getDefaultPath
戻り値:
出力ファイルパス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserProfileExportManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter.user
クラス UserProfileExportManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager
すべての実装インタフェース:
ExportManager
public class UserProfileExportManager
extends Object
implements ExportManager

ユーザ情報のエクスポートを行います。

導入されたバージョン:
6.1

コンストラクタの概要
UserProfileExportManager()
コンストラクタ ユーザ情報エクスポートマネージャーのインスタンスを生成します。
メソッドの概要
void | execute(OutputStream outputStream) エクスポートを実行します。
void | execute(String path) エクスポートを実行します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) エクスポートデータのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザコードを設定します。
void | setFilter(Filter filter) エクスポート対象を絞り込むためのフィルタを設定します。
void | setFormat(String format) エクスポートデータのフォーマットを設定します。
void | setName(String name) エクスポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setSize(int size) エクスポート単位のデータ数を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserProfileExportManager

public UserProfileExportManager()
コンストラクタ ユーザ情報エクスポートマネージャーのインスタンスを生成します。

メソッドの詳細

execute

public void execute(String path)
インタフェース ExportManager の記述:
エクスポートを実行します。
指定されたパスにエクスポートした情報を出力します。

定義:
インタフェース ExportManager 内の execute
パラメータ:
path - 出力パス

execute

public void execute(OutputStream outputStream)
インタフェース ExportManager の記述:
エクスポートを実行します。
指定された出力ストリームにエクスポートした情報を出力します。

定義:
インタフェース ExportManager 内の execute
パラメータ:
outputStream - 出力ストリーム

setDate

public void setDate(Date date)
インタフェース ExportManager の記述:
日付を設定します。
設定可能な日付はシステムの有効期間内に限られます。

定義:
インタフェース ExportManager 内の setDate
パラメータ:
date - 日付
関連項目:
DateUtil#getMinDate(), DateUtil#getMaxDate()

setEncoding

public void setEncoding(String encoding)
インタフェース ExportManager の記述:
エクスポートデータのエンコーディングを設定します。

定義:
インタフェース ExportManager 内の setEncoding
パラメータ:
encoding - エンコーディング

setExecuteUser

public void setExecuteUser(String user)
インタフェース ExportManager の記述:
実行ユーザコードを設定します。

定義:
インタフェース ExportManager 内の setExecuteUser
パラメータ:
user - 実行ユーザ

setFilter

public void setFilter(Filter filter)
インタフェース ExportManager の記述:
エクスポート対象を絞り込むためのフィルタを設定します。

定義:
インタフェース ExportManager 内の setFilter
パラメータ:
filter - フィルタ

setFormat

public void setFormat(String format)
インタフェース ExportManager の記述:
エクスポートデータのフォーマットを設定します。

定義:
インタフェース ExportManager 内の setFormat
パラメータ:
format - エクスポートデータのフォーマット

setName

public void setName(String name)
インタフェース ExportManager の記述:
エクスポート処理名を設定します。
この処理名を使って、エクスポート処理の排他制御を行います。
(同じ処理名をもつエクスポート処理を同時に実行することはできません。)

定義:
インタフェース ExportManager 内の setName
パラメータ:
name - エクスポート処理名

setParameter

public void setParameter(String key,
                         Object value)
インタフェース ExportManager の記述:
パラメータを設定します。
エクスポート実行時に使用する任意のパラメータを設定します。

定義:
インタフェース ExportManager 内の setParameter
パラメータ:
key - キー
value - 値

setSize

public void setSize(int size)
インタフェース ExportManager の記述:
エクスポート単位のデータ数を設定します。

定義:
インタフェース ExportManager 内の setSize
パラメータ:
size - エクスポート単位のデータ数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserProfileExportManagerClient (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter.user
クラス UserProfileExportManagerClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient
        拡張 jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient
すべての実装インタフェース:
ExportManagerClient
public class UserProfileExportManagerClient
extends AbstractExportManagerClient
implements ExportManagerClient

ユーザ情報のエクスポートを行います。

エクスポートされるのは、ユーザプロファイル情報のみです。
ユーザ所属情報をエクスポートする場合は、UserAttachExportManagerClient、 または UserAttachExportManager を使用してください。

このクラスは、UserProfileExportManager クラスのクライアントになります。
executeメソッドに指定された設定情報を解釈した後、UserProfileExportManager クラスに エクスポート処理を委譲します。

導入されたバージョン:
6.1

コンストラクタの概要
UserProfileExportManagerClient()
メソッドの概要
boolean | execute(InputStream configuration) エクスポートマネージャーを呼び出します。
boolean | execute(String configurationPath) エクスポートマネージャーを呼び出します。
protected ExportConfigurationReader | getConfigurationReader(InputStream inputStream) 入力ストリームからエクスポート設定情報を取得します。
protected String | getDefaultPath() エクスポート情報の出力ファイルのデフォルトパス情報を取得します。
protected ExportManager | getExportManager() エクスポートマネージャーのインスタンスを取得します。
クラス jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient から継承したメソッド
setDate, setEncoding, setExecuteUser, setFilter, setFormat, setName, setParameters, setSize
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserProfileExportManagerClient

public UserProfileExportManagerClient()
メソッドの詳細

execute

public boolean execute(String configurationPath)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーを初期化して、エクスポートを実行します。

定義:
インタフェース ExportManagerClient 内の execute
オーバーライド:
クラス AbstractExportManagerClient 内の execute
パラメータ:
configurationPath - エクスポート設定ファイルパス
戻り値:
エクスポートに成功した場合 true、失敗した場合 false

execute

public boolean execute(InputStream configuration)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーを初期化して、エクスポートを実行します。

定義:
インタフェース ExportManagerClient 内の execute
オーバーライド:
クラス AbstractExportManagerClient 内の execute
パラメータ:
configuration - エクスポート設定情報
戻り値:
エクスポートに成功した場合 true、失敗した場合 false

getExportManager

protected ExportManager getExportManager()
クラス AbstractExportManagerClient の記述:
エクスポートマネージャーのインスタンスを取得します。

定義:
クラス AbstractExportManagerClient 内の getExportManager
戻り値:
エクスポートマネージャー

getConfigurationReader

protected ExportConfigurationReader getConfigurationReader(InputStream inputStream)
クラス AbstractExportManagerClient の記述:
入力ストリームからエクスポート設定情報を取得します。

定義:
クラス AbstractExportManagerClient 内の getConfigurationReader
パラメータ:
inputStream - 入力ストリーム
戻り値:
エクスポート設定リーダー

getDefaultPath

protected String getDefaultPath()
クラス AbstractExportManagerClient の記述:
エクスポート情報の出力ファイルのデフォルトパス情報を取得します。

定義:
クラス AbstractExportManagerClient 内の getDefaultPath
戻り値:
出力ファイルパス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AbstractExportManagerClient (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter
クラス AbstractExportManagerClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient
すべての実装インタフェース:
ExportManagerClient
直系の既知のサブクラス:
CompanyExportManagerClient, CompanyPostExportManagerClient, PublicGroupExportManagerClient, UserAttachExportManagerClient, UserProfileExportManagerClient
public abstract class AbstractExportManagerClient
extends Object
implements ExportManagerClient

エクスポートマネージャークライアントの汎用的な実装です。

導入されたバージョン:
6.1

コンストラクタの概要
AbstractExportManagerClient()
メソッドの概要
boolean | execute(InputStream configuration) エクスポートマネージャーを呼び出します。
boolean | execute(String configurationPath) エクスポートマネージャーを呼び出します。
protected abstract ExportConfigurationReader | getConfigurationReader(InputStream inputStream) 入力ストリームからエクスポート設定情報を取得します。
protected abstract String | getDefaultPath() エクスポート情報の出力ファイルのデフォルトパス情報を取得します。
protected abstract ExportManager | getExportManager() エクスポートマネージャーのインスタンスを取得します。
protected void | setDate(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義された日付をマネージャーに設定します。
protected void | setEncoding(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたエクスポートデータのエンコーディング情報をマネージャーに設定します。
protected void | setExecuteUser(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義された実行ユーザコードをマネージャーに設定します。
protected void | setFilter(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたフィルタの情報をマネージャーに設定します。
protected void | setFormat(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたエクスポートデータのフォーマットをマネージャーに設定します。
protected void | setName(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義された処理名をマネージャーに設定します。
protected void | setParameters(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたパラメータ情報をマネージャーに設定します。
protected void | setSize(ExportManager manager, ExportConfigurationReader reader) エクスポート設定に定義されたエクスポート単位のデータ数をマネージャーに設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractExportManagerClient

public AbstractExportManagerClient()
メソッドの詳細

execute

public boolean execute(String configurationPath)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーの初期化を行い、エクスポートを実行します。

定義:
インタフェース ExportManagerClient 内の execute
パラメータ:
configurationPath - エクスポート設定ファイルパス
戻り値:
エクスポートに成功した場合 true
例外:
ExportInitializeException - エクスポートマネージャーの初期化でエラーが発生した場合
Error - エクスポート実行中に何らかのエラーが発生した場合

execute

public boolean execute(InputStream configuration)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーの初期化を行い、エクスポートを実行します。

定義:
インタフェース ExportManagerClient 内の execute
パラメータ:
configuration - エクスポート設定
戻り値:
エクスポートに成功した場合 true
例外:
ExportInitializeException - エクスポートマネージャーの初期化でエラーが発生した場合
Error - エクスポート実行中に何らかのエラーが発生した場合

getExportManager

protected abstract ExportManager getExportManager()
エクスポートマネージャーのインスタンスを取得します。

戻り値:
エクスポートマネージャー
例外:
ExportInitializeException - エクスポートマネージャーのインスタンスの生成に失敗した場合

getConfigurationReader

protected abstract ExportConfigurationReader getConfigurationReader(InputStream inputStream)
入力ストリームからエクスポート設定情報を取得します。

パラメータ:
inputStream - 入力ストリーム
戻り値:
エクスポート設定リーダー
例外:
ExportInitializeException - 入力ストリームの読み込みに失敗した場合

getDefaultPath

protected abstract String getDefaultPath()
エクスポート情報の出力ファイルのデフォルトパス情報を取得します。

戻り値:
出力ファイルパス

setName

protected void setName(ExportManager manager,
                       ExportConfigurationReader reader)
エクスポート設定に定義された処理名をマネージャーに設定します。

パラメータ:
manager - エクスポートマネージャー
reader - エクスポート設定リーダー

setFormat

protected void setFormat(ExportManager manager,
                         ExportConfigurationReader reader)
エクスポート設定に定義されたエクスポートデータのフォーマットをマネージャーに設定します。

パラメータ:
manager - エクスポートマネージャー
reader - エクスポート設定リーダー

setDate

protected void setDate(ExportManager manager,
                       ExportConfigurationReader reader)
エクスポート設定に定義された日付をマネージャーに設定します。

パラメータ:
manager - エクスポートマネージャー
reader - エクスポート設定リーダー

setEncoding

protected void setEncoding(ExportManager manager,
                           ExportConfigurationReader reader)
エクスポート設定に定義されたエクスポートデータのエンコーディング情報をマネージャーに設定します。

パラメータ:
manager - エクスポートマネージャー
reader - エクスポート設定リーダー

setSize

protected void setSize(ExportManager manager,
                       ExportConfigurationReader reader)
エクスポート設定に定義されたエクスポート単位のデータ数をマネージャーに設定します。

パラメータ:
manager - エクスポートマネージャー
reader - エクスポート設定リーダー

setExecuteUser

protected void setExecuteUser(ExportManager manager,
                              ExportConfigurationReader reader)
エクスポート設定に定義された実行ユーザコードをマネージャーに設定します。

パラメータ:
manager - エクスポートマネージャー
reader - エクスポート設定リーダー

setFilter

protected void setFilter(ExportManager manager,
                         ExportConfigurationReader reader)
エクスポート設定に定義されたフィルタの情報をマネージャーに設定します。

パラメータ:
manager - エクスポートマネージャー
reader - エクスポート設定リーダー

setParameters

protected void setParameters(ExportManager manager,
                             ExportConfigurationReader reader)
エクスポート設定に定義されたパラメータ情報をマネージャーに設定します。

パラメータ:
manager - エクスポートマネージャー
reader - エクスポート設定リーダー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExportInitializeException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter
クラス ExportInitializeException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.datastore.exception.BatchProcessException
                    拡張 jp.co.intra_mart.foundation.datastore.exporter.ExportInitializeException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ExportConfigurationReaderException
public class ExportInitializeException
extends BatchProcessException

エクスポートの初期化でエラーが発生したことを示すためにスローされます。

導入されたバージョン:
6.1
関連項目:
直列化された形式

コンストラクタの概要
ExportInitializeException(String message)
コンストラクタ
ExportInitializeException(String message, Throwable cause)
コンストラクタ
ExportInitializeException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExportInitializeException

public ExportInitializeException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

ExportInitializeException

public ExportInitializeException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

ExportInitializeException

public ExportInitializeException(String message,
                                 Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExportManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter
インタフェース ExportManager

既知の実装クラスの一覧:
CompanyExportManager, CompanyPostExportManager, ExportManagerImpl, PublicGroupExportManager, UserAttachExportManager, UserProfileExportManager
public interface ExportManager

エクスポートを行います。

導入されたバージョン:
6.1

メソッドの概要
void | execute(OutputStream outputStream) エクスポートを実行します。
void | execute(String path) エクスポートを実行します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) エクスポートデータのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザコードを設定します。
void | setFilter(Filter filter) エクスポート対象を絞り込むためのフィルタを設定します。
void | setFormat(String format) エクスポートデータのフォーマットを設定します。
void | setName(String name) エクスポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setSize(int size) エクスポート単位のデータ数を設定します。

メソッドの詳細

execute

public void execute(String path)
エクスポートを実行します。
指定されたパスにエクスポートした情報を出力します。

パラメータ:
path - 出力パス
例外:
ExportInitializeException - エクスポート処理の初期化でエラーが発生した場合
BatchProcessException - エクスポート処理中に何らかのエラーが発生した場合
BatchSystemException - エクスポート処理中にシステムエラーが発生した場合

execute

public void execute(OutputStream outputStream)
エクスポートを実行します。
指定された出力ストリームにエクスポートした情報を出力します。

パラメータ:
outputStream - 出力ストリーム
例外:
ExportInitializeException - エクスポート処理の初期化でエラーが発生した場合
BatchProcessException - エクスポート処理中に何らかのエラーが発生した場合
BatchSystemException - エクスポート処理中にシステムエラーが発生した場合

setName

public void setName(String name)
エクスポート処理名を設定します。
この処理名を使って、エクスポート処理の排他制御を行います。
(同じ処理名をもつエクスポート処理を同時に実行することはできません。)

パラメータ:
name - エクスポート処理名
例外:
ExportInitializeException - 処理名に null が設定された場合

setFormat

public void setFormat(String format)
エクスポートデータのフォーマットを設定します。

パラメータ:
format - エクスポートデータのフォーマット
例外:
ExportInitializeException - エクスポートデータのフォーマットに null が設定された場合

setDate

public void setDate(Date date)
日付を設定します。
設定可能な日付はシステムの有効期間内に限られます。

パラメータ:
date - 日付
例外:
ExportInitializeException - 日付に null、または有効期間外の日付が設定された場合
関連項目:
DateUtil#getMinDate(), DateUtil#getMaxDate()

setEncoding

public void setEncoding(String encoding)
エクスポートデータのエンコーディングを設定します。

パラメータ:
encoding - エンコーディング
例外:
ExportInitializeException - エンコーディングに null が設定された場合

setExecuteUser

public void setExecuteUser(String user)
実行ユーザコードを設定します。

パラメータ:
user - 実行ユーザ
例外:
ExportInitializeException - 実行ユーザに null が設定された場合

setSize

public void setSize(int size)
エクスポート単位のデータ数を設定します。

パラメータ:
size - エクスポート単位のデータ数
例外:
ExportInitializeException - データ数に 0 未満の数値が設定された場合

setFilter

public void setFilter(Filter filter)
エクスポート対象を絞り込むためのフィルタを設定します。

パラメータ:
filter - フィルタ

setParameter

public void setParameter(String key,
                         Object value)
パラメータを設定します。
エクスポート実行時に使用する任意のパラメータを設定します。

パラメータ:
key - キー
value - 値
例外:
ExportInitializeException - パラメータのキーに null が設定された場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExportManagerClient (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter
インタフェース ExportManagerClient

既知の実装クラスの一覧:
AbstractExportManagerClient, CompanyExportManagerClient, CompanyPostExportManagerClient, PublicGroupExportManagerClient, UserAttachExportManagerClient, UserProfileExportManagerClient
public interface ExportManagerClient

エクスポートマネージャーの呼び出しを行うクライアントです。

導入されたバージョン:
6.1

メソッドの概要
boolean | execute(InputStream configuration) エクスポートマネージャーを呼び出します。
boolean | execute(String configurationPath) エクスポートマネージャーを呼び出します。

メソッドの詳細

execute

public boolean execute(String configurationPath)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーを初期化して、エクスポートを実行します。

パラメータ:
configurationPath - エクスポート設定ファイルパス
戻り値:
エクスポートに成功した場合 true、失敗した場合 false

execute

public boolean execute(InputStream configuration)
エクスポートマネージャーを呼び出します。
設定ファイルに従ってエクスポートマネージャーを初期化して、エクスポートを実行します。

パラメータ:
configuration - エクスポート設定情報
戻り値:
エクスポートに成功した場合 true、失敗した場合 false
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExportManagerImpl (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter
クラス ExportManagerImpl

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl
すべての実装インタフェース:
ExportManager
public class ExportManagerImpl
extends Object
implements ExportManager

エクスポートマネージャーの汎用的な実装です。

導入されたバージョン:
6.1

コンストラクタの概要
ExportManagerImpl(String id)
コンストラクタ
メソッドの概要
void | execute(OutputStream outputStream) エクスポートを実行します。
void | execute(String path) エクスポートを実行します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) エクスポートファイルのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザを設定します。
void | setFilter(Filter filter) エクスポートフィルタを設定します。
void | setFormat(String format) エクスポートファイルのフォーマットを設定します。
void | setName(String name) エクスポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setSize(int size) エクスポート単位のデータ数を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExportManagerImpl

public ExportManagerImpl(String id)
コンストラクタ

パラメータ:
id - エクスポート種別を特定するための識別子
メソッドの詳細

execute

public void execute(String path)
エクスポートを実行します。

定義:
インタフェース ExportManager 内の execute
パラメータ:
path - エクスポートファイルのパス
例外:
ExportInitializeException - エクスポート処理の初期化でエラーが発生した場合
BatchProcessException - エクスポート処理中に何らかのエラーが発生した場合
BatchSystemException - エクスポート処理中にシステムエラーが発生した場合

execute

public void execute(OutputStream outputStream)
エクスポートを実行します。

定義:
インタフェース ExportManager 内の execute
パラメータ:
outputStream - エクスポートデータ
例外:
ExportInitializeException - エクスポート処理の初期化でエラーが発生した場合
BatchProcessException - エクスポート処理中に何らかのエラーが発生した場合
BatchSystemException - エクスポート処理中にシステムエラーが発生した場合

setName

public void setName(String name)
エクスポート処理名を設定します。
この処理名を使って、エクスポート処理の排他制御を行います。
(同じ処理名をもつエクスポート処理を同時に実行することはできません。)

定義:
インタフェース ExportManager 内の setName
パラメータ:
name - エクスポート処理名
例外:
ExportInitializeException - 処理名に null が設定された場合

setEncoding

public void setEncoding(String encoding)
エクスポートファイルのエンコーディングを設定します。

定義:
インタフェース ExportManager 内の setEncoding
パラメータ:
encoding - エンコーディング
例外:
ExportInitializeException - エンコーディングに null が設定された場合

setDate

public void setDate(Date date)
日付を設定します。
設定可能な日付はシステムの有効期間内に限られます。

定義:
インタフェース ExportManager 内の setDate
パラメータ:
date - 日付
例外:
ExportInitializeException - 日付に null、または有効期間外の日付が設定された場合
関連項目:
Term.getMinDate(), Term.getMaxDate()

setFormat

public void setFormat(String format)
エクスポートファイルのフォーマットを設定します。

定義:
インタフェース ExportManager 内の setFormat
パラメータ:
format - エクスポートファイルのフォーマット
例外:
ExportInitializeException - フォーマットに null が設定された場合

setExecuteUser

public void setExecuteUser(String user)
実行ユーザを設定します。

定義:
インタフェース ExportManager 内の setExecuteUser
パラメータ:
user - 実行ユーザ
例外:
ExportInitializeException - 実行ユーザに null が設定された場合

setSize

public void setSize(int size)
エクスポート単位のデータ数を設定します。

定義:
インタフェース ExportManager 内の setSize
パラメータ:
size - エクスポート単位のデータ数
例外:
ExportInitializeException - データ数に 0 未満の数値が設定された場合

setFilter

public void setFilter(Filter filter)
エクスポートフィルタを設定します。

定義:
インタフェース ExportManager 内の setFilter
パラメータ:
filter - エクスポート条件を指定するためのフィルタ

setParameter

public void setParameter(String key,
                         Object value)
パラメータを設定します。
エクスポート実行時に使用する任意のパラメータを設定します。

定義:
インタフェース ExportManager 内の setParameter
パラメータ:
key - キー
value - 値
例外:
ExportInitializeException - パラメータのキーに null が設定された場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Filter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exporter
クラス Filter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.exporter.Filter
すべての実装インタフェース:
Serializable
public class Filter
extends Object
implements Serializable

エクスポート対象のデータを絞り込むための情報を保持します。

導入されたバージョン:
6.1
関連項目:
直列化された形式

コンストラクタの概要
Filter(String[] value)
コンストラクタ
設定された値以外を抽出するフィルタを構築します。
Filter(String[] value, boolean exclusive)
コンストラクタ
設定された値に対するフィルタを構築します。
メソッドの概要
String[] | getValue() フィルタリングされる値の配列を返します。
boolean | isExclusive() フィルタリング対象の値が除外されるかどうか
String | toString() フィルタの文字列表現を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Filter

public Filter(String[] value)
コンストラクタ
設定された値以外を抽出するフィルタを構築します。

パラメータ:
value - エクスポートから除外される値の配列

Filter

public Filter(String[] value,
              boolean exclusive)
コンストラクタ
設定された値に対するフィルタを構築します。
構築されたフィルタは、exclusive の値により動作が変わります。

exclusive に true が設定された場合は、value 配列に設定された値以外を抽出します。 false が設定された場合は、value 配列に設定された値のみを抽出します。

パラメータ:
value - フィルタリングされる値の配列
exclusive - フィルタリングされる値を除外するかどうかのフラグ
メソッドの詳細

isExclusive

public boolean isExclusive()
フィルタリング対象の値が除外されるかどうか

戻り値:
除外される場合 true、それ以外の場合 false

getValue

public String[] getValue()
フィルタリングされる値の配列を返します。

戻り値:
フィルタリングされる値の配列

toString

public String toString()
フィルタの文字列表現を返します。

戻り値:
フィルタの文字列表現
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.exporter (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.exporter
インタフェース
ExportManager
ExportManagerClient
クラス
AbstractExportManagerClient
ExportManagerImpl
Filter
例外
ExportInitializeException


jp.co.intra_mart.foundation.datastore.exporter (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exporter

アプリケーション共通マスタのエクスポートを行うクラスを提供します。

参照:
説明

インタフェースの概要
ExportManager | エクスポートを行います。
ExportManagerClient | エクスポートマネージャーの呼び出しを行うクライアントです。

クラスの概要
AbstractExportManagerClient | エクスポートマネージャークライアントの汎用的な実装です。
ExportManagerImpl | エクスポートマネージャーの汎用的な実装です。
Filter | エクスポート対象のデータを絞り込むための情報を保持します。

例外の概要
ExportInitializeException エクスポートの初期化でエラーが発生したことを示すためにスローされます。

パッケージ jp.co.intra_mart.foundation.datastore.exporter の説明

アプリケーション共通マスタのエクスポートを行うクラスを提供します。


jp.co.intra_mart.foundation.datastore.exporter クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exporter の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
    • class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManager)
    • class jp.co.intra_mart.foundation.datastore.exporter.Filter (implements java.io.Serializable)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.datastore.exception.BatchProcessException
            • class jp.co.intra_mart.foundation.datastore.exporter.ExportInitializeException

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager
  • interface jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient


パッケージ jp.co.intra_mart.foundation.datastore.exporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.exporter の使用

jp.co.intra_mart.foundation.datastore.exporter を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exporter | アプリケーション共通マスタのエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.common.config | エクスポート設定の解釈を行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.company | 会社・組織関連の情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.public_group | パブリックグループ情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.user | ユーザ関連の情報のエクスポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.exporter により使用される jp.co.intra_mart.foundation.datastore.exporter のクラス
ExportManager
エクスポートを行います。
ExportManagerClient
エクスポートマネージャーの呼び出しを行うクライアントです。
Filter
エクスポート対象のデータを絞り込むための情報を保持します。

jp.co.intra_mart.foundation.datastore.exporter.common.config により使用される jp.co.intra_mart.foundation.datastore.exporter のクラス
ExportInitializeException
エクスポートの初期化でエラーが発生したことを示すためにスローされます。
Filter
エクスポート対象のデータを絞り込むための情報を保持します。

jp.co.intra_mart.foundation.datastore.exporter.company により使用される jp.co.intra_mart.foundation.datastore.exporter のクラス
AbstractExportManagerClient
エクスポートマネージャークライアントの汎用的な実装です。
ExportManager
エクスポートを行います。
ExportManagerClient
エクスポートマネージャーの呼び出しを行うクライアントです。
Filter
エクスポート対象のデータを絞り込むための情報を保持します。

jp.co.intra_mart.foundation.datastore.exporter.public_group により使用される jp.co.intra_mart.foundation.datastore.exporter のクラス
AbstractExportManagerClient
エクスポートマネージャークライアントの汎用的な実装です。
ExportManager
エクスポートを行います。
ExportManagerClient
エクスポートマネージャーの呼び出しを行うクライアントです。
Filter
エクスポート対象のデータを絞り込むための情報を保持します。

jp.co.intra_mart.foundation.datastore.exporter.user により使用される jp.co.intra_mart.foundation.datastore.exporter のクラス
AbstractExportManagerClient
エクスポートマネージャークライアントの汎用的な実装です。
ExportManager
エクスポートを行います。
ExportManagerClient
エクスポートマネージャーの呼び出しを行うクライアントです。
Filter
エクスポート対象のデータを絞り込むための情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient の使用

AbstractImportManagerClient を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.importer.company | 会社・組織関連の情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.public_group | パブリックグループ情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.user | ユーザ関連の情報のインポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.importer.company での AbstractImportManagerClient の使用

jp.co.intra_mart.foundation.datastore.importer.company での AbstractImportManagerClient のサブクラス
class | CompanyImportManagerClient 会社情報のインポートを行います。
class | CompanyPostImportManagerClient 会社役職情報のインポートを行います。

jp.co.intra_mart.foundation.datastore.importer.public_group での AbstractImportManagerClient の使用

jp.co.intra_mart.foundation.datastore.importer.public_group での AbstractImportManagerClient のサブクラス
 class PublicGroupImportManagerClient
パブリックグループ情報のインポートを行います。

jp.co.intra_mart.foundation.datastore.importer.user での AbstractImportManagerClient の使用

jp.co.intra_mart.foundation.datastore.importer.user での AbstractImportManagerClient のサブクラス
class | UserAttachImportManagerClient ユーザ所属情報のインポートを行います。
class | UserProfileImportManagerClient ユーザ情報のインポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.ImportInitializeException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.ImportInitializeException の使用

ImportInitializeException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.importer.common.config インポート定義情報の解釈を行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.importer.common.config での ImportInitializeException の使用

jp.co.intra_mart.foundation.datastore.importer.common.config での ImportInitializeException のサブクラス
 class ImportConfigurationReaderException
インポート設定の読み込みでエラーが発生したことを示すためにスローされます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.importer.ImportManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.importer.ImportManager の使用

ImportManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.importer | アプリケーション共通マスタのインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.company | 会社・組織関連の情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.public_group | パブリックグループ情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.user | ユーザ関連の情報のインポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.importer での ImportManager の使用

ImportManager を実装している jp.co.intra_mart.foundation.datastore.importer のクラス
 class ImportManagerImpl
インポートマネージャーの実装です。

ImportManager を返す jp.co.intra_mart.foundation.datastore.importer のメソッド
protected abstract  ImportManager AbstractImportManagerClient.getImportManager()
インポートマネージャーのインスタンスを取得します。

ImportManager 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.importer のメソッド
protected void | AbstractImportManagerClient.setName(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義された処理名をマネージャーに設定します。
protected void | AbstractImportManagerClient.setFormat(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたインポートファイルのフォーマットをマネージャーに設定します。
protected void | AbstractImportManagerClient.setDate(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義された日付をマネージャーに設定します。
protected void | AbstractImportManagerClient.setEncoding(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたインポートファイルのエンコーディング情報をマネージャーに設定します。
protected void | AbstractImportManagerClient.setCommitCount(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたインポートデータのコミット間隔をマネージャーに設定します。
protected void | AbstractImportManagerClient.setExecuteUser(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義された実行ユーザをマネージャーに設定します。
protected void | AbstractImportManagerClient.setRetry(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたリトライステータスをマネージャーに設定します。
protected void | AbstractImportManagerClient.setValidate(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたバリデーションステータスをマネージャーに設定します。
protected void | AbstractImportManagerClient.setParameters(ImportManager manager, ImportConfigurationReader reader) エクスポート設定に定義されたパラメータ情報をマネージャーに設定します。

jp.co.intra_mart.foundation.datastore.importer.company での ImportManager の使用

ImportManager を実装している jp.co.intra_mart.foundation.datastore.importer.company のクラス
class | CompanyImportManager 会社情報のインポートを行います。
class | CompanyPostImportManager 会社役職情報のインポートを行います。

ImportManager を返す jp.co.intra_mart.foundation.datastore.importer.company のメソッド
protected ImportManager | CompanyPostImportManagerClient.getImportManager()
protected ImportManager | CompanyImportManagerClient.getImportManager()

jp.co.intra_mart.foundation.datastore.importer.public_group での ImportManager の使用

ImportManager を実装している jp.co.intra_mart.foundation.datastore.importer.public_group のクラス
 class PublicGroupImportManager
パブリックグループ情報のインポートを行います。

ImportManager を返す jp.co.intra_mart.foundation.datastore.importer.public_group のメソッド
protected  ImportManager PublicGroupImportManagerClient.getImportManager()

jp.co.intra_mart.foundation.datastore.importer.user での ImportManager の使用

ImportManager を実装している jp.co.intra_mart.foundation.datastore.importer.user のクラス
class | UserAttachImportManager ユーザ所属情報のインポートを行います。
class | UserProfileImportManager ユーザ情報のインポートを行います。

ImportManager を返す jp.co.intra_mart.foundation.datastore.importer.user のメソッド
protected ImportManager | UserProfileImportManagerClient.getImportManager()
protected ImportManager | UserAttachImportManagerClient.getImportManager()

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient の使用

ImportManagerClient を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.importer | アプリケーション共通マスタのインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.company | 会社・組織関連の情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.public_group | パブリックグループ情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.user | ユーザ関連の情報のインポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.importer での ImportManagerClient の使用

ImportManagerClient を実装している jp.co.intra_mart.foundation.datastore.importer のクラス
 class AbstractImportManagerClient
インポートマネージャークライアントの汎用的な実装です。

jp.co.intra_mart.foundation.datastore.importer.company での ImportManagerClient の使用

ImportManagerClient を実装している jp.co.intra_mart.foundation.datastore.importer.company のクラス
class | CompanyImportManagerClient 会社情報のインポートを行います。
class | CompanyPostImportManagerClient 会社役職情報のインポートを行います。

jp.co.intra_mart.foundation.datastore.importer.public_group での ImportManagerClient の使用

ImportManagerClient を実装している jp.co.intra_mart.foundation.datastore.importer.public_group のクラス
 class PublicGroupImportManagerClient
パブリックグループ情報のインポートを行います。

jp.co.intra_mart.foundation.datastore.importer.user での ImportManagerClient の使用

ImportManagerClient を実装している jp.co.intra_mart.foundation.datastore.importer.user のクラス
class | UserAttachImportManagerClient ユーザ所属情報のインポートを行います。
class | UserProfileImportManagerClient ユーザ情報のインポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl の使用

jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader の使用

ImportConfigurationReader を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.importer | アプリケーション共通マスタのインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.company | 会社・組織関連の情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.public_group | パブリックグループ情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.user | ユーザ関連の情報のインポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.importer での ImportConfigurationReader の使用

ImportConfigurationReader を返す jp.co.intra_mart.foundation.datastore.importer のメソッド
protected abstract  ImportConfigurationReader AbstractImportManagerClient.getConfigurationReader(InputStream inputStream)
入力ストリームからポート設定情報を取得します。

ImportConfigurationReader 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.importer のメソッド
protected void | AbstractImportManagerClient.setName(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義された処理名をマネージャーに設定します。
protected void | AbstractImportManagerClient.setFormat(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたインポートファイルのフォーマットをマネージャーに設定します。
protected void | AbstractImportManagerClient.setDate(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義された日付をマネージャーに設定します。
protected void | AbstractImportManagerClient.setEncoding(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたインポートファイルのエンコーディング情報をマネージャーに設定します。
protected void | AbstractImportManagerClient.setCommitCount(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたインポートデータのコミット間隔をマネージャーに設定します。
protected void | AbstractImportManagerClient.setExecuteUser(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義された実行ユーザをマネージャーに設定します。
protected void | AbstractImportManagerClient.setRetry(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたリトライステータスをマネージャーに設定します。
protected void | AbstractImportManagerClient.setValidate(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたバリデーションステータスをマネージャーに設定します。
protected void | AbstractImportManagerClient.setParameters(ImportManager manager, ImportConfigurationReader reader) エクスポート設定に定義されたパラメータ情報をマネージャーに設定します。

jp.co.intra_mart.foundation.datastore.importer.company での ImportConfigurationReader の使用

ImportConfigurationReader を返す jp.co.intra_mart.foundation.datastore.importer.company のメソッド
protected ImportConfigurationReader | CompanyPostImportManagerClient.getConfigurationReader(InputStream inputStream)
protected ImportConfigurationReader | CompanyImportManagerClient.getConfigurationReader(InputStream inputStream)

jp.co.intra_mart.foundation.datastore.importer.public_group での ImportConfigurationReader の使用

ImportConfigurationReader を返す jp.co.intra_mart.foundation.datastore.importer.public_group のメソッド
protected  ImportConfigurationReader PublicGroupImportManagerClient.getConfigurationReader(InputStream inputStream)

jp.co.intra_mart.foundation.datastore.importer.user での ImportConfigurationReader の使用

ImportConfigurationReader を返す jp.co.intra_mart.foundation.datastore.importer.user のメソッド
protected ImportConfigurationReader | UserProfileImportManagerClient.getConfigurationReader(InputStream inputStream)
protected ImportConfigurationReader | UserAttachImportManagerClient.getConfigurationReader(InputStream inputStream)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReaderException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReaderException の使用

jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReaderException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ImportConfigurationReader (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer.common.config
インタフェース ImportConfigurationReader

public interface ImportConfigurationReader

インポート設定情報の読込みを行います。

導入されたバージョン:
6.1

メソッドの概要
int | getCommitCount() コミット間隔を取得します。
Date | getDate() 日付を取得します。
String | getEncoding() インポートデータのエンコーディング情報を取得します。
String | getExecuteUser() 実行ユーザコードを取得します。
String[] | getExtensionParameterNames() パラメータ名の一覧を取得します。
String | getExtensionParameterValue(String key) 指定されたキーに対するパラメータ値を取得します。
String | getFormat() インポートデータのフォーマットを取得します。
String[] | getImportFileSet(String defaultPath) インポートデータのファイルパスの一覧を取得します。
String | getName() インポート処理名を取得します。
void | initialize(String rootName) 初期化を行います。
Boolean | isRetry() インポート異常終了後の再実行時に、リトライ処理として実行するかどうか。
Boolean | isValidate() インポートデータに対してバリデーションを行うかどうか。

メソッドの詳細

initialize

public void initialize(String rootName)
初期化を行います。
指定された要素内に定義された設定情報を読込みます。

パラメータ:
rootName - 設定情報を定義するルート要素の名前

getName

public String getName()
インポート処理名を取得します。

戻り値:
インスポート処理名
例外:
ImportConfigurationReaderException - 設定情報の定義が不正な場合

getFormat

public String getFormat()
インポートデータのフォーマットを取得します。

戻り値:
インポートデータのフォーマット
例外:
ImportConfigurationReaderException - 設定情報の定義が不正な場合

getDate

public Date getDate()
日付を取得します。

戻り値:
日付
例外:
ImportConfigurationReaderException - 設定情報の定義が不正な場合

getEncoding

public String getEncoding()
インポートデータのエンコーディング情報を取得します。

戻り値:
インポートデータのエンコーディング情報
例外:
ImportConfigurationReaderException - 設定情報の定義が不正な場合

getExecuteUser

public String getExecuteUser()
実行ユーザコードを取得します。

戻り値:
実行ユーザコード
例外:
ImportConfigurationReaderException - 設定情報の定義が不正な場合

getImportFileSet

public String[] getImportFileSet(String defaultPath)
インポートデータのファイルパスの一覧を取得します。
デフォルトファイルパス情報は、インポート設定にインポートファイルパスの情報が 設定されていない場合に使用されます。

パラメータ:
defaultPath - デフォルトのファイルパス情報
戻り値:
入力ファイルパスの配列
例外:
ImportConfigurationReaderException - 設定情報の定義が不正な場合

getCommitCount

public int getCommitCount()
コミット間隔を取得します。

戻り値:
コミット間隔

isRetry

public Boolean isRetry()
インポート異常終了後の再実行時に、リトライ処理として実行するかどうか。

戻り値:
リトライを行う場合 true、それ以外の場合は false

isValidate

public Boolean isValidate()
インポートデータに対してバリデーションを行うかどうか。

戻り値:
バリデーションを行う場合 true、それ以外の場合は false

getExtensionParameterNames

public String[] getExtensionParameterNames()
パラメータ名の一覧を取得します。

戻り値:
パラメータ名の一覧

getExtensionParameterValue

public String getExtensionParameterValue(String key)
指定されたキーに対するパラメータ値を取得します。

パラメータ:
key - キー
戻り値:
パラメータ値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ImportConfigurationReaderException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer.common.config
クラス ImportConfigurationReaderException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.datastore.exception.BatchProcessException
                    拡張 jp.co.intra_mart.foundation.datastore.importer.ImportInitializeException
                        拡張 jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReaderException
すべての実装インタフェース:
Serializable
public class ImportConfigurationReaderException
extends ImportInitializeException

インポート設定の読み込みでエラーが発生したことを示すためにスローされます。

導入されたバージョン:
6.1
関連項目:
直列化された形式

コンストラクタの概要
ImportConfigurationReaderException(String message)
コンストラクタ
ImportConfigurationReaderException(String message, Throwable cause)
コンストラクタ
ImportConfigurationReaderException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ImportConfigurationReaderException

public ImportConfigurationReaderException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

ImportConfigurationReaderException

public ImportConfigurationReaderException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

ImportConfigurationReaderException

public ImportConfigurationReaderException(String message,
                                          Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.importer.common.config (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.importer.common.config
インタフェース
ImportConfigurationReader
例外
ImportConfigurationReaderException


jp.co.intra_mart.foundation.datastore.importer.common.config (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.importer.common.config

インポート定義情報の解釈を行うクラスを提供します。

参照:
説明

インタフェースの概要
ImportConfigurationReader インポート設定情報の読込みを行います。

例外の概要
ImportConfigurationReaderException インポート設定の読み込みでエラーが発生したことを示すためにスローされます。

パッケージ jp.co.intra_mart.foundation.datastore.importer.common.config の説明

インポート定義情報の解釈を行うクラスを提供します。


jp.co.intra_mart.foundation.datastore.importer.common.config クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.importer.common.config の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.datastore.exception.BatchProcessException
            • class jp.co.intra_mart.foundation.datastore.importer.ImportInitializeException
              • class jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReaderException

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader


パッケージ jp.co.intra_mart.foundation.datastore.importer.common.config の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.importer.common.config の使用

jp.co.intra_mart.foundation.datastore.importer.common.config を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.importer | アプリケーション共通マスタのインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.company | 会社・組織関連の情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.public_group | パブリックグループ情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.user | ユーザ関連の情報のインポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.importer により使用される jp.co.intra_mart.foundation.datastore.importer.common.config のクラス
ImportConfigurationReader
インポート設定情報の読込みを行います。

jp.co.intra_mart.foundation.datastore.importer.company により使用される jp.co.intra_mart.foundation.datastore.importer.common.config のクラス
ImportConfigurationReader
インポート設定情報の読込みを行います。

jp.co.intra_mart.foundation.datastore.importer.public_group により使用される jp.co.intra_mart.foundation.datastore.importer.common.config のクラス
ImportConfigurationReader
インポート設定情報の読込みを行います。

jp.co.intra_mart.foundation.datastore.importer.user により使用される jp.co.intra_mart.foundation.datastore.importer.common.config のクラス
ImportConfigurationReader
インポート設定情報の読込みを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager の使用

jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient の使用

jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager の使用

jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient の使用

jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CompanyImportManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer.company
クラス CompanyImportManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager
すべての実装インタフェース:
ImportManager
public class CompanyImportManager
extends Object
implements ImportManager

会社情報のインポートを行います。

導入されたバージョン:
6.1

コンストラクタの概要
CompanyImportManager()
コンストラクタ 会社インポートマネージャーのインスタンスを生成します。
メソッドの概要
void | execute(InputStream inputStream) インポートを実行します。
void | execute(String[] path) インポートを実行します。
void | setCommitCount(int commitCount) コミット間隔を設定します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) インポートファイルのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザを設定します。
void | setFormat(String format) インポートファイルのフォーマットを設定します。
void | setName(String name) インポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setRetry(boolean retry) インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
void | setValidate(boolean validate) インポートデータに対してバリデーションを行うかどうか設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyImportManager

public CompanyImportManager()
コンストラクタ 会社インポートマネージャーのインスタンスを生成します。

メソッドの詳細

execute

public void execute(String[] path)
インタフェース ImportManager の記述:
インポートを実行します。

定義:
インタフェース ImportManager 内の execute
パラメータ:
path - インポートファイルのパス

execute

public void execute(InputStream inputStream)
インタフェース ImportManager の記述:
インポートを実行します。

定義:
インタフェース ImportManager 内の execute
パラメータ:
inputStream - インポートデータ

setFormat

public void setFormat(String format)
インタフェース ImportManager の記述:
インポートファイルのフォーマットを設定します。

定義:
インタフェース ImportManager 内の setFormat
パラメータ:
format - インポートファイルのフォーマット

setCommitCount

public void setCommitCount(int commitCount)
インタフェース ImportManager の記述:
コミット間隔を設定します。
ここで設定された件数分のデータの更新が行われたらコミットを実行します。

定義:
インタフェース ImportManager 内の setCommitCount
パラメータ:
commitCount - コミット間隔

setDate

public void setDate(Date date)
インタフェース ImportManager の記述:
日付を設定します。

定義:
インタフェース ImportManager 内の setDate
パラメータ:
date - 日付

setEncoding

public void setEncoding(String encoding)
インタフェース ImportManager の記述:
インポートファイルのエンコーディングを設定します。

定義:
インタフェース ImportManager 内の setEncoding
パラメータ:
encoding - エンコーディング

setExecuteUser

public void setExecuteUser(String user)
インタフェース ImportManager の記述:
実行ユーザを設定します。

定義:
インタフェース ImportManager 内の setExecuteUser
パラメータ:
user - 実行ユーザ

setName

public void setName(String name)
インタフェース ImportManager の記述:
インポート処理名を設定します。

定義:
インタフェース ImportManager 内の setName
パラメータ:
name - インポート処理名

setParameter

public void setParameter(String key,
                         Object value)
インタフェース ImportManager の記述:
パラメータを設定します。

定義:
インタフェース ImportManager 内の setParameter
パラメータ:
key - キー
value - 値

setRetry

public void setRetry(boolean retry)
インタフェース ImportManager の記述:
インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
リトライステータスが true に設定された場合、リトライとして再実行します。 この時、前回の処理でコミットしたデータの登録処理はスキップされます。
リトライステータスが false に設定された場合、最初からインポート処理をやり直します。

定義:
インタフェース ImportManager 内の setRetry
パラメータ:
retry - リトライとして実行するかどうか

setValidate

public void setValidate(boolean validate)
インタフェース ImportManager の記述:
インポートデータに対してバリデーションを行うかどうか設定します。
バリデーションステータスが true に設定された場合、バリデーションを実行します。 false に設定された場合は、バリデーションは実行しません。

定義:
インタフェース ImportManager 内の setValidate
パラメータ:
validate - バリデーションを行うかどうか
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyImportManagerClient (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer.company
クラス CompanyImportManagerClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient
        拡張 jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient
すべての実装インタフェース:
ImportManagerClient
public class CompanyImportManagerClient
extends AbstractImportManagerClient
implements ImportManagerClient

会社情報のインポートを行います。

このクラスは、CompanyImportManager クラスのクライアントになります。
executeメソッドに指定された設定情報を解釈した後、CompanyImportManager クラスに インポート処理を委譲します。

導入されたバージョン:
6.1

コンストラクタの概要
CompanyImportManagerClient()
メソッドの概要
boolean | execute(InputStream configuration) 指定された定義情報をもとにインポート処理を行います。
boolean | execute(String configurationPath) 指定された定義情報をもとにインポート処理を行います。
protected ImportConfigurationReader | getConfigurationReader(InputStream inputStream) 入力ストリームからポート設定情報を取得します。
protected String | getDefaultImportPath() インポートファイルのデフォルトパス情報を取得します。
protected ImportManager | getImportManager() インポートマネージャーのインスタンスを取得します。
クラス jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient から継承したメソッド
setCommitCount, setDate, setEncoding, setExecuteUser, setFormat, setName, setParameters, setRetry, setValidate
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyImportManagerClient

public CompanyImportManagerClient()
メソッドの詳細

execute

public boolean execute(String configurationPath)
指定された定義情報をもとにインポート処理を行います。

定義:
インタフェース ImportManagerClient 内の execute
オーバーライド:
クラス AbstractImportManagerClient 内の execute
パラメータ:
configurationPath - 定義ファイルパス
戻り値:
インポートに成功した場合 true、失敗した場合 false

execute

public boolean execute(InputStream configuration)
指定された定義情報をもとにインポート処理を行います。

定義:
インタフェース ImportManagerClient 内の execute
オーバーライド:
クラス AbstractImportManagerClient 内の execute
パラメータ:
configuration - 定義情報
戻り値:
インポートに成功した場合 true、失敗した場合 false

getImportManager

protected ImportManager getImportManager()
クラス AbstractImportManagerClient の記述:
インポートマネージャーのインスタンスを取得します。

定義:
クラス AbstractImportManagerClient 内の getImportManager
戻り値:
インポートマネージャー

getConfigurationReader

protected ImportConfigurationReader getConfigurationReader(InputStream inputStream)
クラス AbstractImportManagerClient の記述:
入力ストリームからポート設定情報を取得します。

定義:
クラス AbstractImportManagerClient 内の getConfigurationReader
パラメータ:
inputStream - 入力ストリーム
戻り値:
インポート設定リーダー

getDefaultImportPath

protected String getDefaultImportPath()
クラス AbstractImportManagerClient の記述:
インポートファイルのデフォルトパス情報を取得します。

定義:
クラス AbstractImportManagerClient 内の getDefaultImportPath
戻り値:
デフォルト定義パス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyPostImportManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer.company
クラス CompanyPostImportManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager
すべての実装インタフェース:
ImportManager
public class CompanyPostImportManager
extends Object
implements ImportManager

会社役職情報のインポートを行います。

導入されたバージョン:
6.1

コンストラクタの概要
CompanyPostImportManager()
コンストラクタ 会社役職インポートマネージャーのインスタンスを生成します。
メソッドの概要
void | execute(InputStream inputStream) インポートを実行します。
void | execute(String[] path) インポートを実行します。
void | setCommitCount(int commitCount) コミット間隔を設定します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) インポートファイルのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザを設定します。
void | setFormat(String format) インポートファイルのフォーマットを設定します。
void | setName(String name) インポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setRetry(boolean retry) インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
void | setValidate(boolean validate) インポートデータに対してバリデーションを行うかどうか設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyPostImportManager

public CompanyPostImportManager()
コンストラクタ 会社役職インポートマネージャーのインスタンスを生成します。

メソッドの詳細

execute

public void execute(String[] path)
インタフェース ImportManager の記述:
インポートを実行します。

定義:
インタフェース ImportManager 内の execute
パラメータ:
path - インポートファイルのパス

execute

public void execute(InputStream inputStream)
インタフェース ImportManager の記述:
インポートを実行します。

定義:
インタフェース ImportManager 内の execute
パラメータ:
inputStream - インポートデータ

setFormat

public void setFormat(String format)
インタフェース ImportManager の記述:
インポートファイルのフォーマットを設定します。

定義:
インタフェース ImportManager 内の setFormat
パラメータ:
format - インポートファイルのフォーマット

setCommitCount

public void setCommitCount(int commitCount)
インタフェース ImportManager の記述:
コミット間隔を設定します。
ここで設定された件数分のデータの更新が行われたらコミットを実行します。

定義:
インタフェース ImportManager 内の setCommitCount
パラメータ:
commitCount - コミット間隔

setDate

public void setDate(Date date)
インタフェース ImportManager の記述:
日付を設定します。

定義:
インタフェース ImportManager 内の setDate
パラメータ:
date - 日付

setEncoding

public void setEncoding(String encoding)
インタフェース ImportManager の記述:
インポートファイルのエンコーディングを設定します。

定義:
インタフェース ImportManager 内の setEncoding
パラメータ:
encoding - エンコーディング

setExecuteUser

public void setExecuteUser(String user)
インタフェース ImportManager の記述:
実行ユーザを設定します。

定義:
インタフェース ImportManager 内の setExecuteUser
パラメータ:
user - 実行ユーザ

setName

public void setName(String name)
インタフェース ImportManager の記述:
インポート処理名を設定します。

定義:
インタフェース ImportManager 内の setName
パラメータ:
name - インポート処理名

setParameter

public void setParameter(String key,
                         Object value)
インタフェース ImportManager の記述:
パラメータを設定します。

定義:
インタフェース ImportManager 内の setParameter
パラメータ:
key - キー
value - 値

setRetry

public void setRetry(boolean retry)
インタフェース ImportManager の記述:
インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
リトライステータスが true に設定された場合、リトライとして再実行します。 この時、前回の処理でコミットしたデータの登録処理はスキップされます。
リトライステータスが false に設定された場合、最初からインポート処理をやり直します。

定義:
インタフェース ImportManager 内の setRetry
パラメータ:
retry - リトライとして実行するかどうか

setValidate

public void setValidate(boolean validate)
インタフェース ImportManager の記述:
インポートデータに対してバリデーションを行うかどうか設定します。
バリデーションステータスが true に設定された場合、バリデーションを実行します。 false に設定された場合は、バリデーションは実行しません。

定義:
インタフェース ImportManager 内の setValidate
パラメータ:
validate - バリデーションを行うかどうか
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyPostImportManagerClient (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer.company
クラス CompanyPostImportManagerClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient
        拡張 jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient
すべての実装インタフェース:
ImportManagerClient
public class CompanyPostImportManagerClient
extends AbstractImportManagerClient
implements ImportManagerClient

会社役職情報のインポートを行います。

このクラスは、CompanyPostImportManager クラスのクライアントになります。
executeメソッドに指定された設定情報を解釈した後、CompanyPostImportManager クラスに インポート処理を委譲します。

導入されたバージョン:
6.1

コンストラクタの概要
CompanyPostImportManagerClient()
メソッドの概要
boolean | execute(InputStream configuration) 指定された定義情報をもとにインポート処理を行います。
boolean | execute(String configurationPath) 指定された定義情報をもとにインポート処理を行います。
protected ImportConfigurationReader | getConfigurationReader(InputStream inputStream) 入力ストリームからポート設定情報を取得します。
protected String | getDefaultImportPath() インポートファイルのデフォルトパス情報を取得します。
protected ImportManager | getImportManager() インポートマネージャーのインスタンスを取得します。
クラス jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient から継承したメソッド
setCommitCount, setDate, setEncoding, setExecuteUser, setFormat, setName, setParameters, setRetry, setValidate
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyPostImportManagerClient

public CompanyPostImportManagerClient()
メソッドの詳細

execute

public boolean execute(String configurationPath)
指定された定義情報をもとにインポート処理を行います。

定義:
インタフェース ImportManagerClient 内の execute
オーバーライド:
クラス AbstractImportManagerClient 内の execute
パラメータ:
configurationPath - 定義ファイルパス
戻り値:
インポートに成功した場合 true、失敗した場合 false

execute

public boolean execute(InputStream configuration)
指定された定義情報をもとにインポート処理を行います。

定義:
インタフェース ImportManagerClient 内の execute
オーバーライド:
クラス AbstractImportManagerClient 内の execute
パラメータ:
configuration - 定義情報
戻り値:
インポートに成功した場合 true、失敗した場合 false

getImportManager

protected ImportManager getImportManager()
クラス AbstractImportManagerClient の記述:
インポートマネージャーのインスタンスを取得します。

定義:
クラス AbstractImportManagerClient 内の getImportManager
戻り値:
インポートマネージャー

getConfigurationReader

protected ImportConfigurationReader getConfigurationReader(InputStream inputStream)
クラス AbstractImportManagerClient の記述:
入力ストリームからポート設定情報を取得します。

定義:
クラス AbstractImportManagerClient 内の getConfigurationReader
パラメータ:
inputStream - 入力ストリーム
戻り値:
インポート設定リーダー

getDefaultImportPath

protected String getDefaultImportPath()
クラス AbstractImportManagerClient の記述:
インポートファイルのデフォルトパス情報を取得します。

定義:
クラス AbstractImportManagerClient 内の getDefaultImportPath
戻り値:
デフォルト定義パス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.importer.company (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.importer.company
クラス
CompanyImportManager
CompanyImportManagerClient
CompanyPostImportManager
CompanyPostImportManagerClient


jp.co.intra_mart.foundation.datastore.importer.company (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.importer.company

会社・組織関連の情報のインポートを行うクラスを提供します。

参照:
説明

クラスの概要
CompanyImportManager | 会社情報のインポートを行います。
CompanyImportManagerClient | 会社情報のインポートを行います。
CompanyPostImportManager | 会社役職情報のインポートを行います。
CompanyPostImportManagerClient | 会社役職情報のインポートを行います。

パッケージ jp.co.intra_mart.foundation.datastore.importer.company の説明

会社・組織関連の情報のインポートを行うクラスを提供します。


jp.co.intra_mart.foundation.datastore.importer.company クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.importer.company の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
    • class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager (implements jp.co.intra_mart.foundation.datastore.importer.ImportManager)
    • class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager (implements jp.co.intra_mart.foundation.datastore.importer.ImportManager)


パッケージ jp.co.intra_mart.foundation.datastore.importer.company の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.importer.company の使用

jp.co.intra_mart.foundation.datastore.importer.company はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager の使用

jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient の使用

jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.importer.public_group (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.importer.public_group
クラス
PublicGroupImportManager
PublicGroupImportManagerClient


jp.co.intra_mart.foundation.datastore.importer.public_group (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.importer.public_group

パブリックグループ情報のインポートを行うクラスを提供します。

参照:
説明

クラスの概要
PublicGroupImportManager | パブリックグループ情報のインポートを行います。
PublicGroupImportManagerClient | パブリックグループ情報のインポートを行います。

パッケージ jp.co.intra_mart.foundation.datastore.importer.public_group の説明

パブリックグループ情報のインポートを行うクラスを提供します。


jp.co.intra_mart.foundation.datastore.importer.public_group クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.importer.public_group の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
    • class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager (implements jp.co.intra_mart.foundation.datastore.importer.ImportManager)


パッケージ jp.co.intra_mart.foundation.datastore.importer.public_group の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.importer.public_group の使用

jp.co.intra_mart.foundation.datastore.importer.public_group はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupImportManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer.public_group
クラス PublicGroupImportManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager
すべての実装インタフェース:
ImportManager
public class PublicGroupImportManager
extends Object
implements ImportManager

パブリックグループ情報のインポートを行います。

導入されたバージョン:
6.1

コンストラクタの概要
PublicGroupImportManager()
コンストラクタ パブリックグループインポートマネージャーのインスタンスを生成します。
メソッドの概要
void | execute(InputStream inputStream) インポートを実行します。
void | execute(String[] path) インポートを実行します。
void | setCommitCount(int commitCount) コミット間隔を設定します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) インポートファイルのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザを設定します。
void | setFormat(String format) インポートファイルのフォーマットを設定します。
void | setName(String name) インポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setRetry(boolean retry) インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
void | setValidate(boolean validate) インポートデータに対してバリデーションを行うかどうか設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupImportManager

public PublicGroupImportManager()
コンストラクタ パブリックグループインポートマネージャーのインスタンスを生成します。

メソッドの詳細

execute

public void execute(String[] path)
インタフェース ImportManager の記述:
インポートを実行します。

定義:
インタフェース ImportManager 内の execute
パラメータ:
path - インポートファイルのパス

execute

public void execute(InputStream inputStream)
インタフェース ImportManager の記述:
インポートを実行します。

定義:
インタフェース ImportManager 内の execute
パラメータ:
inputStream - インポートデータ

setFormat

public void setFormat(String format)
インタフェース ImportManager の記述:
インポートファイルのフォーマットを設定します。

定義:
インタフェース ImportManager 内の setFormat
パラメータ:
format - インポートファイルのフォーマット

setCommitCount

public void setCommitCount(int commitCount)
インタフェース ImportManager の記述:
コミット間隔を設定します。
ここで設定された件数分のデータの更新が行われたらコミットを実行します。

定義:
インタフェース ImportManager 内の setCommitCount
パラメータ:
commitCount - コミット間隔

setDate

public void setDate(Date date)
インタフェース ImportManager の記述:
日付を設定します。

定義:
インタフェース ImportManager 内の setDate
パラメータ:
date - 日付

setEncoding

public void setEncoding(String encoding)
インタフェース ImportManager の記述:
インポートファイルのエンコーディングを設定します。

定義:
インタフェース ImportManager 内の setEncoding
パラメータ:
encoding - エンコーディング

setExecuteUser

public void setExecuteUser(String user)
インタフェース ImportManager の記述:
実行ユーザを設定します。

定義:
インタフェース ImportManager 内の setExecuteUser
パラメータ:
user - 実行ユーザ

setName

public void setName(String name)
インタフェース ImportManager の記述:
インポート処理名を設定します。

定義:
インタフェース ImportManager 内の setName
パラメータ:
name - インポート処理名

setParameter

public void setParameter(String key,
                         Object value)
インタフェース ImportManager の記述:
パラメータを設定します。

定義:
インタフェース ImportManager 内の setParameter
パラメータ:
key - キー
value - 値

setRetry

public void setRetry(boolean retry)
インタフェース ImportManager の記述:
インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
リトライステータスが true に設定された場合、リトライとして再実行します。 この時、前回の処理でコミットしたデータの登録処理はスキップされます。
リトライステータスが false に設定された場合、最初からインポート処理をやり直します。

定義:
インタフェース ImportManager 内の setRetry
パラメータ:
retry - リトライとして実行するかどうか

setValidate

public void setValidate(boolean validate)
インタフェース ImportManager の記述:
インポートデータに対してバリデーションを行うかどうか設定します。
バリデーションステータスが true に設定された場合、バリデーションを実行します。 false に設定された場合は、バリデーションは実行しません。

定義:
インタフェース ImportManager 内の setValidate
パラメータ:
validate - バリデーションを行うかどうか
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupImportManagerClient (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer.public_group
クラス PublicGroupImportManagerClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient
        拡張 jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient
すべての実装インタフェース:
ImportManagerClient
public class PublicGroupImportManagerClient
extends AbstractImportManagerClient
implements ImportManagerClient

パブリックグループ情報のインポートを行います。

このクラスは、PublicGroupImportManager クラスのクライアントになります。
executeメソッドに指定された設定情報を解釈した後、PublicGroupImportManager クラスに インポート処理を委譲します。

導入されたバージョン:
6.1

コンストラクタの概要
PublicGroupImportManagerClient()
メソッドの概要
boolean | execute(InputStream configuration) 指定された定義情報をもとにインポート処理を行います。
boolean | execute(String configurationPath) 指定された定義情報をもとにインポート処理を行います。
protected ImportConfigurationReader | getConfigurationReader(InputStream inputStream) 入力ストリームからポート設定情報を取得します。
protected String | getDefaultImportPath() インポートファイルのデフォルトパス情報を取得します。
protected ImportManager | getImportManager() インポートマネージャーのインスタンスを取得します。
クラス jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient から継承したメソッド
setCommitCount, setDate, setEncoding, setExecuteUser, setFormat, setName, setParameters, setRetry, setValidate
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupImportManagerClient

public PublicGroupImportManagerClient()
メソッドの詳細

execute

public boolean execute(String configurationPath)
指定された定義情報をもとにインポート処理を行います。

定義:
インタフェース ImportManagerClient 内の execute
オーバーライド:
クラス AbstractImportManagerClient 内の execute
パラメータ:
configurationPath - 定義ファイルパス
戻り値:
インポートに成功した場合 true、失敗した場合 false

execute

public boolean execute(InputStream configuration)
指定された定義情報をもとにインポート処理を行います。

定義:
インタフェース ImportManagerClient 内の execute
オーバーライド:
クラス AbstractImportManagerClient 内の execute
パラメータ:
configuration - 定義情報
戻り値:
インポートに成功した場合 true、失敗した場合 false

getImportManager

protected ImportManager getImportManager()
クラス AbstractImportManagerClient の記述:
インポートマネージャーのインスタンスを取得します。

定義:
クラス AbstractImportManagerClient 内の getImportManager
戻り値:
インポートマネージャー

getConfigurationReader

protected ImportConfigurationReader getConfigurationReader(InputStream inputStream)
クラス AbstractImportManagerClient の記述:
入力ストリームからポート設定情報を取得します。

定義:
クラス AbstractImportManagerClient 内の getConfigurationReader
パラメータ:
inputStream - 入力ストリーム
戻り値:
インポート設定リーダー

getDefaultImportPath

protected String getDefaultImportPath()
クラス AbstractImportManagerClient の記述:
インポートファイルのデフォルトパス情報を取得します。

定義:
クラス AbstractImportManagerClient 内の getDefaultImportPath
戻り値:
デフォルト定義パス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager の使用

jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient の使用

jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager の使用

jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient の使用

jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.importer.user (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.importer.user
クラス
UserAttachImportManager
UserAttachImportManagerClient
UserProfileImportManager
UserProfileImportManagerClient


jp.co.intra_mart.foundation.datastore.importer.user (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.importer.user

ユーザ関連の情報のインポートを行うクラスを提供します。

参照:
説明

クラスの概要
UserAttachImportManager | ユーザ所属情報のインポートを行います。
UserAttachImportManagerClient | ユーザ所属情報のインポートを行います。
UserProfileImportManager | ユーザ情報のインポートを行います。
UserProfileImportManagerClient | ユーザ情報のインポートを行います。

パッケージ jp.co.intra_mart.foundation.datastore.importer.user の説明

ユーザ関連の情報のインポートを行うクラスを提供します。


jp.co.intra_mart.foundation.datastore.importer.user クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.importer.user の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
    • class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager (implements jp.co.intra_mart.foundation.datastore.importer.ImportManager)
    • class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager (implements jp.co.intra_mart.foundation.datastore.importer.ImportManager)


パッケージ jp.co.intra_mart.foundation.datastore.importer.user の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.importer.user の使用

jp.co.intra_mart.foundation.datastore.importer.user はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


UserAttachImportManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer.user
クラス UserAttachImportManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager
すべての実装インタフェース:
ImportManager
public class UserAttachImportManager
extends Object
implements ImportManager

ユーザ所属情報のインポートを行います。

導入されたバージョン:
6.1

コンストラクタの概要
UserAttachImportManager()
コンストラクタ ユーザ所属情報インポートマネージャーのインスタンスを生成します。
メソッドの概要
void | execute(InputStream inputStream) インポートを実行します。
void | execute(String[] path) インポートを実行します。
void | setCommitCount(int commitCount) コミット間隔を設定します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) インポートファイルのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザを設定します。
void | setFormat(String format) インポートファイルのフォーマットを設定します。
void | setName(String name) インポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setRetry(boolean retry) インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
void | setValidate(boolean validate) インポートデータに対してバリデーションを行うかどうか設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserAttachImportManager

public UserAttachImportManager()
コンストラクタ ユーザ所属情報インポートマネージャーのインスタンスを生成します。

メソッドの詳細

execute

public void execute(String[] path)
インタフェース ImportManager の記述:
インポートを実行します。

定義:
インタフェース ImportManager 内の execute
パラメータ:
path - インポートファイルのパス

execute

public void execute(InputStream inputStream)
インタフェース ImportManager の記述:
インポートを実行します。

定義:
インタフェース ImportManager 内の execute
パラメータ:
inputStream - インポートデータ

setFormat

public void setFormat(String format)
インタフェース ImportManager の記述:
インポートファイルのフォーマットを設定します。

定義:
インタフェース ImportManager 内の setFormat
パラメータ:
format - インポートファイルのフォーマット

setCommitCount

public void setCommitCount(int commitCount)
インタフェース ImportManager の記述:
コミット間隔を設定します。
ここで設定された件数分のデータの更新が行われたらコミットを実行します。

定義:
インタフェース ImportManager 内の setCommitCount
パラメータ:
commitCount - コミット間隔

setDate

public void setDate(Date date)
インタフェース ImportManager の記述:
日付を設定します。

定義:
インタフェース ImportManager 内の setDate
パラメータ:
date - 日付

setEncoding

public void setEncoding(String encoding)
インタフェース ImportManager の記述:
インポートファイルのエンコーディングを設定します。

定義:
インタフェース ImportManager 内の setEncoding
パラメータ:
encoding - エンコーディング

setExecuteUser

public void setExecuteUser(String user)
インタフェース ImportManager の記述:
実行ユーザを設定します。

定義:
インタフェース ImportManager 内の setExecuteUser
パラメータ:
user - 実行ユーザ

setName

public void setName(String name)
インタフェース ImportManager の記述:
インポート処理名を設定します。

定義:
インタフェース ImportManager 内の setName
パラメータ:
name - インポート処理名

setParameter

public void setParameter(String key,
                         Object value)
インタフェース ImportManager の記述:
パラメータを設定します。

定義:
インタフェース ImportManager 内の setParameter
パラメータ:
key - キー
value - 値

setRetry

public void setRetry(boolean retry)
インタフェース ImportManager の記述:
インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
リトライステータスが true に設定された場合、リトライとして再実行します。 この時、前回の処理でコミットしたデータの登録処理はスキップされます。
リトライステータスが false に設定された場合、最初からインポート処理をやり直します。

定義:
インタフェース ImportManager 内の setRetry
パラメータ:
retry - リトライとして実行するかどうか

setValidate

public void setValidate(boolean validate)
インタフェース ImportManager の記述:
インポートデータに対してバリデーションを行うかどうか設定します。
バリデーションステータスが true に設定された場合、バリデーションを実行します。 false に設定された場合は、バリデーションは実行しません。

定義:
インタフェース ImportManager 内の setValidate
パラメータ:
validate - バリデーションを行うかどうか
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UserAttachImportManagerClient (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer.user
クラス UserAttachImportManagerClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient
        拡張 jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient
すべての実装インタフェース:
ImportManagerClient
public class UserAttachImportManagerClient
extends AbstractImportManagerClient
implements ImportManagerClient

ユーザ所属情報のインポートを行います。

このクラスは、UserAttachImportManager クラスのクライアントになります。
executeメソッドに指定された設定情報を解釈した後、UserAttachImportManager クラスに インポート処理を委譲します。

導入されたバージョン:
6.1

コンストラクタの概要
UserAttachImportManagerClient()
メソッドの概要
boolean | execute(InputStream configuration) 指定された定義情報をもとにインポート処理を行います。
boolean | execute(String configurationPath) 指定された定義情報をもとにインポート処理を行います。
protected ImportConfigurationReader | getConfigurationReader(InputStream inputStream) 入力ストリームからポート設定情報を取得します。
protected String | getDefaultImportPath() インポートファイルのデフォルトパス情報を取得します。
protected ImportManager | getImportManager() インポートマネージャーのインスタンスを取得します。
クラス jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient から継承したメソッド
setCommitCount, setDate, setEncoding, setExecuteUser, setFormat, setName, setParameters, setRetry, setValidate
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserAttachImportManagerClient

public UserAttachImportManagerClient()
メソッドの詳細

execute

public boolean execute(String configurationPath)
指定された定義情報をもとにインポート処理を行います。

定義:
インタフェース ImportManagerClient 内の execute
オーバーライド:
クラス AbstractImportManagerClient 内の execute
パラメータ:
configurationPath - 定義ファイルパス
戻り値:
インポートに成功した場合 true、失敗した場合 false

execute

public boolean execute(InputStream configuration)
指定された定義情報をもとにインポート処理を行います。

定義:
インタフェース ImportManagerClient 内の execute
オーバーライド:
クラス AbstractImportManagerClient 内の execute
パラメータ:
configuration - 定義情報
戻り値:
インポートに成功した場合 true、失敗した場合 false

getImportManager

protected ImportManager getImportManager()
クラス AbstractImportManagerClient の記述:
インポートマネージャーのインスタンスを取得します。

定義:
クラス AbstractImportManagerClient 内の getImportManager
戻り値:
インポートマネージャー

getConfigurationReader

protected ImportConfigurationReader getConfigurationReader(InputStream inputStream)
クラス AbstractImportManagerClient の記述:
入力ストリームからポート設定情報を取得します。

定義:
クラス AbstractImportManagerClient 内の getConfigurationReader
パラメータ:
inputStream - 入力ストリーム
戻り値:
インポート設定リーダー

getDefaultImportPath

protected String getDefaultImportPath()
クラス AbstractImportManagerClient の記述:
インポートファイルのデフォルトパス情報を取得します。

定義:
クラス AbstractImportManagerClient 内の getDefaultImportPath
戻り値:
デフォルト定義パス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserProfileImportManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer.user
クラス UserProfileImportManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager
すべての実装インタフェース:
ImportManager
public class UserProfileImportManager
extends Object
implements ImportManager

ユーザ情報のインポートを行います。

導入されたバージョン:
6.1

コンストラクタの概要
UserProfileImportManager()
コンストラクタ ユーザ情報インポートマネージャーのインスタンスを生成します。
メソッドの概要
void | execute(InputStream inputStream) インポートを実行します。
void | execute(String[] path) インポートを実行します。
void | setCommitCount(int commitCount) コミット間隔を設定します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) インポートファイルのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザを設定します。
void | setFormat(String format) インポートファイルのフォーマットを設定します。
void | setName(String name) インポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setRetry(boolean retry) インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
void | setValidate(boolean validate) インポートデータに対してバリデーションを行うかどうか設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserProfileImportManager

public UserProfileImportManager()
コンストラクタ ユーザ情報インポートマネージャーのインスタンスを生成します。

メソッドの詳細

execute

public void execute(String[] path)
インタフェース ImportManager の記述:
インポートを実行します。

定義:
インタフェース ImportManager 内の execute
パラメータ:
path - インポートファイルのパス

execute

public void execute(InputStream inputStream)
インタフェース ImportManager の記述:
インポートを実行します。

定義:
インタフェース ImportManager 内の execute
パラメータ:
inputStream - インポートデータ

setFormat

public void setFormat(String format)
インタフェース ImportManager の記述:
インポートファイルのフォーマットを設定します。

定義:
インタフェース ImportManager 内の setFormat
パラメータ:
format - インポートファイルのフォーマット

setCommitCount

public void setCommitCount(int commitCount)
インタフェース ImportManager の記述:
コミット間隔を設定します。
ここで設定された件数分のデータの更新が行われたらコミットを実行します。

定義:
インタフェース ImportManager 内の setCommitCount
パラメータ:
commitCount - コミット間隔

setDate

public void setDate(Date date)
インタフェース ImportManager の記述:
日付を設定します。

定義:
インタフェース ImportManager 内の setDate
パラメータ:
date - 日付

setEncoding

public void setEncoding(String encoding)
インタフェース ImportManager の記述:
インポートファイルのエンコーディングを設定します。

定義:
インタフェース ImportManager 内の setEncoding
パラメータ:
encoding - エンコーディング

setExecuteUser

public void setExecuteUser(String user)
インタフェース ImportManager の記述:
実行ユーザを設定します。

定義:
インタフェース ImportManager 内の setExecuteUser
パラメータ:
user - 実行ユーザ

setName

public void setName(String name)
インタフェース ImportManager の記述:
インポート処理名を設定します。

定義:
インタフェース ImportManager 内の setName
パラメータ:
name - インポート処理名

setParameter

public void setParameter(String key,
                         Object value)
インタフェース ImportManager の記述:
パラメータを設定します。

定義:
インタフェース ImportManager 内の setParameter
パラメータ:
key - キー
value - 値

setRetry

public void setRetry(boolean retry)
インタフェース ImportManager の記述:
インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
リトライステータスが true に設定された場合、リトライとして再実行します。 この時、前回の処理でコミットしたデータの登録処理はスキップされます。
リトライステータスが false に設定された場合、最初からインポート処理をやり直します。

定義:
インタフェース ImportManager 内の setRetry
パラメータ:
retry - リトライとして実行するかどうか

setValidate

public void setValidate(boolean validate)
インタフェース ImportManager の記述:
インポートデータに対してバリデーションを行うかどうか設定します。
バリデーションステータスが true に設定された場合、バリデーションを実行します。 false に設定された場合は、バリデーションは実行しません。

定義:
インタフェース ImportManager 内の setValidate
パラメータ:
validate - バリデーションを行うかどうか
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserProfileImportManagerClient (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer.user
クラス UserProfileImportManagerClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient
        拡張 jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient
すべての実装インタフェース:
ImportManagerClient
public class UserProfileImportManagerClient
extends AbstractImportManagerClient
implements ImportManagerClient

ユーザ情報のインポートを行います。

インポートされるのは、ユーザプロファイル情報のみです。
ユーザ所属情報をインポートする場合は、UserAttachImportManagerClient、 UserAttachImportManager を使用してください。

このクラスは、UserProfileImportManager クラスのクライアントになります。
executeメソッドに指定された設定情報を解釈した後、UserProfileImportManager クラスに インポート処理を委譲します。

導入されたバージョン:
6.1

コンストラクタの概要
UserProfileImportManagerClient()
メソッドの概要
boolean | execute(InputStream configuration) 指定された定義情報をもとにインポート処理を行います。
boolean | execute(String configurationPath) 指定された定義情報をもとにインポート処理を行います。
protected ImportConfigurationReader | getConfigurationReader(InputStream inputStream) 入力ストリームからポート設定情報を取得します。
protected String | getDefaultImportPath() インポートファイルのデフォルトパス情報を取得します。
protected ImportManager | getImportManager() インポートマネージャーのインスタンスを取得します。
クラス jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient から継承したメソッド
setCommitCount, setDate, setEncoding, setExecuteUser, setFormat, setName, setParameters, setRetry, setValidate
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserProfileImportManagerClient

public UserProfileImportManagerClient()
メソッドの詳細

execute

public boolean execute(String configurationPath)
指定された定義情報をもとにインポート処理を行います。

定義:
インタフェース ImportManagerClient 内の execute
オーバーライド:
クラス AbstractImportManagerClient 内の execute
パラメータ:
configurationPath - 定義ファイルパス
戻り値:
インポートに成功した場合 true、失敗した場合 false

execute

public boolean execute(InputStream configuration)
指定された定義情報をもとにインポート処理を行います。

定義:
インタフェース ImportManagerClient 内の execute
オーバーライド:
クラス AbstractImportManagerClient 内の execute
パラメータ:
configuration - 定義情報
戻り値:
インポートに成功した場合 true、失敗した場合 false

getImportManager

protected ImportManager getImportManager()
クラス AbstractImportManagerClient の記述:
インポートマネージャーのインスタンスを取得します。

定義:
クラス AbstractImportManagerClient 内の getImportManager
戻り値:
インポートマネージャー

getConfigurationReader

protected ImportConfigurationReader getConfigurationReader(InputStream inputStream)
クラス AbstractImportManagerClient の記述:
入力ストリームからポート設定情報を取得します。

定義:
クラス AbstractImportManagerClient 内の getConfigurationReader
パラメータ:
inputStream - 入力ストリーム
戻り値:
インポート設定リーダー

getDefaultImportPath

protected String getDefaultImportPath()
クラス AbstractImportManagerClient の記述:
インポートファイルのデフォルトパス情報を取得します。

定義:
クラス AbstractImportManagerClient 内の getDefaultImportPath
戻り値:
デフォルト定義パス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AbstractImportManagerClient (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer
クラス AbstractImportManagerClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient
すべての実装インタフェース:
ImportManagerClient
直系の既知のサブクラス:
CompanyImportManagerClient, CompanyPostImportManagerClient, PublicGroupImportManagerClient, UserAttachImportManagerClient, UserProfileImportManagerClient
public abstract class AbstractImportManagerClient
extends Object
implements ImportManagerClient

インポートマネージャークライアントの汎用的な実装です。

導入されたバージョン:
6.1

コンストラクタの概要
AbstractImportManagerClient()
メソッドの概要
boolean | execute(InputStream configuration) インポートマネージャーを呼び出します。
boolean | execute(String configurationPath) インポートマネージャーを呼び出します。
protected abstract ImportConfigurationReader | getConfigurationReader(InputStream inputStream) 入力ストリームからポート設定情報を取得します。
protected abstract String | getDefaultImportPath() インポートファイルのデフォルトパス情報を取得します。
protected abstract ImportManager | getImportManager() インポートマネージャーのインスタンスを取得します。
protected void | setCommitCount(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたインポートデータのコミット間隔をマネージャーに設定します。
protected void | setDate(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義された日付をマネージャーに設定します。
protected void | setEncoding(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたインポートファイルのエンコーディング情報をマネージャーに設定します。
protected void | setExecuteUser(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義された実行ユーザをマネージャーに設定します。
protected void | setFormat(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたインポートファイルのフォーマットをマネージャーに設定します。
protected void | setName(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義された処理名をマネージャーに設定します。
protected void | setParameters(ImportManager manager, ImportConfigurationReader reader) エクスポート設定に定義されたパラメータ情報をマネージャーに設定します。
protected void | setRetry(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたリトライステータスをマネージャーに設定します。
protected void | setValidate(ImportManager manager, ImportConfigurationReader reader) インポート設定に定義されたバリデーションステータスをマネージャーに設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractImportManagerClient

public AbstractImportManagerClient()
メソッドの詳細

execute

public boolean execute(String configurationPath)
インポートマネージャーを呼び出します。
設定ファイルに従ってインポートマネージャーの初期化を行い、インポートを実行します。

定義:
インタフェース ImportManagerClient 内の execute
パラメータ:
configurationPath - 定義ファイルパス
戻り値:
インポートに成功した場合 true
例外:
ImportInitializeException - インポートマネージャーの初期化でエラーが発生した場合
Error - インポート実行中に何らかのエラーが発生した場合

execute

public boolean execute(InputStream configuration)
インポートマネージャーを呼び出します。
設定ファイルに従ってインポートマネージャーの初期化を行い、インポートを実行します。

定義:
インタフェース ImportManagerClient 内の execute
パラメータ:
configuration - 定義情報
戻り値:
インポートに成功した場合 true
例外:
ImportInitializeException - インポートマネージャーの初期化でエラーが発生した場合
Error - インポート実行中に何らかのエラーが発生した場合

getImportManager

protected abstract ImportManager getImportManager()
インポートマネージャーのインスタンスを取得します。

戻り値:
インポートマネージャー
例外:
ImportInitializeException - インポートマネージャーのインスタンスの生成に失敗した場合

getConfigurationReader

protected abstract ImportConfigurationReader getConfigurationReader(InputStream inputStream)
入力ストリームからポート設定情報を取得します。

パラメータ:
inputStream - 入力ストリーム
戻り値:
インポート設定リーダー
例外:
ImportInitializeException - 入力ストリームの読み込みに失敗した場合

getDefaultImportPath

protected abstract String getDefaultImportPath()
インポートファイルのデフォルトパス情報を取得します。

戻り値:
デフォルト定義パス

setName

protected void setName(ImportManager manager,
                       ImportConfigurationReader reader)
インポート設定に定義された処理名をマネージャーに設定します。

パラメータ:
manager - インポートマネージャー
reader - インポート設定リーダー

setFormat

protected void setFormat(ImportManager manager,
                         ImportConfigurationReader reader)
インポート設定に定義されたインポートファイルのフォーマットをマネージャーに設定します。

パラメータ:
manager - インポートマネージャー
reader - インポート設定リーダー

setDate

protected void setDate(ImportManager manager,
                       ImportConfigurationReader reader)
インポート設定に定義された日付をマネージャーに設定します。

パラメータ:
manager - インポートマネージャー
reader - インポート設定リーダー

setEncoding

protected void setEncoding(ImportManager manager,
                           ImportConfigurationReader reader)
インポート設定に定義されたインポートファイルのエンコーディング情報をマネージャーに設定します。

パラメータ:
manager - インポートマネージャー
reader - インポート設定リーダー

setCommitCount

protected void setCommitCount(ImportManager manager,
                              ImportConfigurationReader reader)
インポート設定に定義されたインポートデータのコミット間隔をマネージャーに設定します。

パラメータ:
manager - インポートマネージャー
reader - インポート設定リーダー

setExecuteUser

protected void setExecuteUser(ImportManager manager,
                              ImportConfigurationReader reader)
インポート設定に定義された実行ユーザをマネージャーに設定します。

パラメータ:
manager - インポートマネージャー
reader - インポート設定リーダー

setRetry

protected void setRetry(ImportManager manager,
                        ImportConfigurationReader reader)
インポート設定に定義されたリトライステータスをマネージャーに設定します。
このステータスは、インポート異常終了後の再実行時に、リトライ処理として実行するかどうかの設定です。

パラメータ:
manager - インポートマネージャー
reader - インポート設定リーダー

setValidate

protected void setValidate(ImportManager manager,
                           ImportConfigurationReader reader)
インポート設定に定義されたバリデーションステータスをマネージャーに設定します。
このステータスは、インポートデータに対してバリデーションを行うかどうかの設定です。

パラメータ:
manager - インポートマネージャー
reader - インポート設定リーダー

setParameters

protected void setParameters(ImportManager manager,
                             ImportConfigurationReader reader)
エクスポート設定に定義されたパラメータ情報をマネージャーに設定します。

パラメータ:
manager - インポートマネージャー
reader - インポート設定リーダー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ImportInitializeException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer
クラス ImportInitializeException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.datastore.exception.BatchProcessException
                    拡張 jp.co.intra_mart.foundation.datastore.importer.ImportInitializeException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ImportConfigurationReaderException
public class ImportInitializeException
extends BatchProcessException

インポートの初期化で何らかのエラーが発生したことを示すためにスローされます。

導入されたバージョン:
6.1
関連項目:
直列化された形式

コンストラクタの概要
ImportInitializeException(String message)
コンストラクタ
ImportInitializeException(String message, Throwable cause)
コンストラクタ
ImportInitializeException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ImportInitializeException

public ImportInitializeException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

ImportInitializeException

public ImportInitializeException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

ImportInitializeException

public ImportInitializeException(String message,
                                 Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ImportManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer
インタフェース ImportManager

既知の実装クラスの一覧:
CompanyImportManager, CompanyPostImportManager, ImportManagerImpl, PublicGroupImportManager, UserAttachImportManager, UserProfileImportManager
public interface ImportManager

インポートを行います。

導入されたバージョン:
6.1

メソッドの概要
void | execute(InputStream inputStream) インポートを実行します。
void | execute(String[] path) インポートを実行します。
void | setCommitCount(int commitCount) コミット間隔を設定します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) インポートファイルのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザを設定します。
void | setFormat(String format) インポートファイルのフォーマットを設定します。
void | setName(String name) インポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setRetry(boolean retry) インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
void | setValidate(boolean validate) インポートデータに対してバリデーションを行うかどうか設定します。

メソッドの詳細

execute

public void execute(String[] path)
インポートを実行します。

パラメータ:
path - インポートファイルのパス

execute

public void execute(InputStream inputStream)
インポートを実行します。

パラメータ:
inputStream - インポートデータ

setName

public void setName(String name)
インポート処理名を設定します。

パラメータ:
name - インポート処理名

setDate

public void setDate(Date date)
日付を設定します。

パラメータ:
date - 日付

setEncoding

public void setEncoding(String encoding)
インポートファイルのエンコーディングを設定します。

パラメータ:
encoding - エンコーディング

setExecuteUser

public void setExecuteUser(String user)
実行ユーザを設定します。

パラメータ:
user - 実行ユーザ

setCommitCount

public void setCommitCount(int commitCount)
コミット間隔を設定します。
ここで設定された件数分のデータの更新が行われたらコミットを実行します。

パラメータ:
commitCount - コミット間隔

setFormat

public void setFormat(String format)
インポートファイルのフォーマットを設定します。

パラメータ:
format - インポートファイルのフォーマット

setRetry

public void setRetry(boolean retry)
インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
リトライステータスが true に設定された場合、リトライとして再実行します。 この時、前回の処理でコミットしたデータの登録処理はスキップされます。
リトライステータスが false に設定された場合、最初からインポート処理をやり直します。

パラメータ:
retry - リトライとして実行するかどうか

setValidate

public void setValidate(boolean validate)
インポートデータに対してバリデーションを行うかどうか設定します。
バリデーションステータスが true に設定された場合、バリデーションを実行します。 false に設定された場合は、バリデーションは実行しません。

パラメータ:
validate - バリデーションを行うかどうか

setParameter

public void setParameter(String key,
                         Object value)
パラメータを設定します。

パラメータ:
key - キー
value - 値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ImportManagerClient (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer
インタフェース ImportManagerClient

既知の実装クラスの一覧:
AbstractImportManagerClient, CompanyImportManagerClient, CompanyPostImportManagerClient, PublicGroupImportManagerClient, UserAttachImportManagerClient, UserProfileImportManagerClient
public interface ImportManagerClient

設定ファイルを読込んで、インポートマネージャーをセットアップ、実行します。

導入されたバージョン:
6.1

メソッドの概要
boolean | execute(InputStream configuration) 指定された定義情報をもとにインポート処理を行います。
boolean | execute(String configurationPath) 指定された定義情報をもとにインポート処理を行います。

メソッドの詳細

execute

public boolean execute(String configurationPath)
指定された定義情報をもとにインポート処理を行います。

パラメータ:
configurationPath - 定義ファイルパス
戻り値:
インポートに成功した場合 true、失敗した場合 false

execute

public boolean execute(InputStream configuration)
指定された定義情報をもとにインポート処理を行います。

パラメータ:
configuration - 定義情報
戻り値:
インポートに成功した場合 true、失敗した場合 false
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ImportManagerImpl (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.importer
クラス ImportManagerImpl

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl
すべての実装インタフェース:
ImportManager
public class ImportManagerImpl
extends Object
implements ImportManager

インポートマネージャーの実装です。

導入されたバージョン:
6.1

コンストラクタの概要
ImportManagerImpl(String id)
コンストラクタ
メソッドの概要
void | execute(InputStream inputStream) インポートを実行します。
void | execute(String[] path) インポートを実行します。
void | setCommitCount(int commitCount) コミット間隔を設定します。
void | setDate(Date date) 日付を設定します。
void | setEncoding(String encoding) インポートファイルのエンコーディングを設定します。
void | setExecuteUser(String user) 実行ユーザを設定します。
void | setFormat(String format) インポートファイルのフォーマットを設定します。
void | setName(String name) インポート処理名を設定します。
void | setParameter(String key, Object value) パラメータを設定します。
void | setRetry(boolean retry) インポート異常終了後の再実行時に、リトライとして実行するかどうかを設定します。
void | setValidate(boolean validate) インポートデータに対してバリデーションを行うかどうか設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ImportManagerImpl

public ImportManagerImpl(String id)
コンストラクタ

パラメータ:
id - インポート種別を特定するための識別子
メソッドの詳細

execute

public void execute(String[] path)
インポートを実行します。

定義:
インタフェース ImportManager 内の execute
パラメータ:
path - インポートファイルのパス
例外:
ImportInitializeException - インポータの初期処理に失敗した場合
BatchProcessException - インポート処理に何らかの理由で失敗した場合
BatchSystemException - インポート処理中にシステムエラーが発生した場合

execute

public void execute(InputStream inputStream)
インポートを実行します。

定義:
インタフェース ImportManager 内の execute
パラメータ:
inputStream - インポートデータ
例外:
ImportInitializeException - インポータの初期処理に失敗した場合
BatchProcessException - インポート処理中に何らかの理由で失敗した場合
BatchSystemException - インポート処理中にシステムエラーが発生した場合

setName

public void setName(String name)
インポート処理名を設定します。

定義:
インタフェース ImportManager 内の setName
パラメータ:
name - インポート処理名
例外:
ImportInitializeException - 処理名に null が設定された場合

setEncoding

public void setEncoding(String encoding)
インポートファイルのエンコーディングを設定します。

定義:
インタフェース ImportManager 内の setEncoding
パラメータ:
encoding - エンコーディング
例外:
ImportInitializeException - エンコーディングに null が設定された場合

setDate

public void setDate(Date date)
日付を設定します。

定義:
インタフェース ImportManager 内の setDate
パラメータ:
date - 日付
例外:
ImportInitializeException - 有効期間にない日付が設定された場合

setFormat

public void setFormat(String format)
インポートファイルのフォーマットを設定します。

定義:
インタフェース ImportManager 内の setFormat
パラメータ:
format - インポートファイルのフォーマット
例外:
ImportInitializeException - フォーマットに null が設定された場合

setExecuteUser

public void setExecuteUser(String user)
実行ユーザを設定します。

定義:
インタフェース ImportManager 内の setExecuteUser
パラメータ:
user - 実行ユーザ
例外:
ImportInitializeException - 実行ユーザに null が設定された場合

setCommitCount

public void setCommitCount(int commitCount)
コミット間隔を設定します。

定義:
インタフェース ImportManager 内の setCommitCount
パラメータ:
commitCount - コミット間隔
例外:
ImportInitializeException - コミット間隔に 0 未満の数値が設定された場合

setRetry

public void setRetry(boolean retry)
インポート異常終了後の再実行時に、リトライとして実行するかどうかを設定します。
リトライステータスが true に設定された場合、リトライとして再実行します。 この時、前回の処理でコミットしたデータの登録処理はスキップされます。
リトライステータスが false に設定された場合、最初からインポート処理をやり直します。

定義:
インタフェース ImportManager 内の setRetry
パラメータ:
retry - リトライとして実行するかどうか

setValidate

public void setValidate(boolean validate)
インポートデータに対してバリデーションを行うかどうか設定します。
バリデーションステータスが true に設定された場合、バリデーションを実行します。 false に設定された場合は、バリデーションは実行しません。

定義:
インタフェース ImportManager 内の setValidate
パラメータ:
validate - バリデーションを行うかどうか

setParameter

public void setParameter(String key,
                         Object value)
パラメータを設定します。

定義:
インタフェース ImportManager 内の setParameter
パラメータ:
key - キー
value - 値
例外:
ImportInitializeException - パラメータのキーに null が設定された場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.importer (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.datastore.importer
インタフェース
ImportManager
ImportManagerClient
クラス
AbstractImportManagerClient
ImportManagerImpl
例外
ImportInitializeException


jp.co.intra_mart.foundation.datastore.importer (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.importer

アプリケーション共通マスタのインポートを行うクラスを提供します。

参照:
説明

インタフェースの概要
ImportManager | インポートを行います。
ImportManagerClient | 設定ファイルを読込んで、インポートマネージャーをセットアップ、実行します。

クラスの概要
AbstractImportManagerClient | インポートマネージャークライアントの汎用的な実装です。
ImportManagerImpl | インポートマネージャーの実装です。

例外の概要
ImportInitializeException インポートの初期化で何らかのエラーが発生したことを示すためにスローされます。

パッケージ jp.co.intra_mart.foundation.datastore.importer の説明

アプリケーション共通マスタのインポートを行うクラスを提供します。


jp.co.intra_mart.foundation.datastore.importer クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.importer の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
    • class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl (implements jp.co.intra_mart.foundation.datastore.importer.ImportManager)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.datastore.exception.BatchProcessException
            • class jp.co.intra_mart.foundation.datastore.importer.ImportInitializeException

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.importer.ImportManager
  • interface jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient


パッケージ jp.co.intra_mart.foundation.datastore.importer の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.importer の使用

jp.co.intra_mart.foundation.datastore.importer を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.importer | アプリケーション共通マスタのインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.common.config | インポート定義情報の解釈を行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.company | 会社・組織関連の情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.public_group | パブリックグループ情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.user | ユーザ関連の情報のインポートを行うクラスを提供します。

jp.co.intra_mart.foundation.datastore.importer により使用される jp.co.intra_mart.foundation.datastore.importer のクラス
ImportManager
インポートを行います。
ImportManagerClient
設定ファイルを読込んで、インポートマネージャーをセットアップ、実行します。

jp.co.intra_mart.foundation.datastore.importer.common.config により使用される jp.co.intra_mart.foundation.datastore.importer のクラス
ImportInitializeException
インポートの初期化で何らかのエラーが発生したことを示すためにスローされます。

jp.co.intra_mart.foundation.datastore.importer.company により使用される jp.co.intra_mart.foundation.datastore.importer のクラス
AbstractImportManagerClient
インポートマネージャークライアントの汎用的な実装です。
ImportManager
インポートを行います。
ImportManagerClient
設定ファイルを読込んで、インポートマネージャーをセットアップ、実行します。

jp.co.intra_mart.foundation.datastore.importer.public_group により使用される jp.co.intra_mart.foundation.datastore.importer のクラス
AbstractImportManagerClient
インポートマネージャークライアントの汎用的な実装です。
ImportManager
インポートを行います。
ImportManagerClient
設定ファイルを読込んで、インポートマネージャーをセットアップ、実行します。

jp.co.intra_mart.foundation.datastore.importer.user により使用される jp.co.intra_mart.foundation.datastore.importer のクラス
AbstractImportManagerClient
インポートマネージャークライアントの汎用的な実装です。
ImportManager
インポートを行います。
ImportManagerClient
設定ファイルを読込んで、インポートマネージャーをセットアップ、実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.drawer.AbstractDrawer の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.drawer.AbstractDrawer の使用

AbstractDrawer を使用しているパッケージ
jp.co.intra_mart.foundation.graph グラフ描画に関するクラスを提供します。

jp.co.intra_mart.foundation.graph での AbstractDrawer の使用

jp.co.intra_mart.foundation.graph での AbstractDrawer のサブクラス
class | BarGraphDrawer 棒グラフを描画します。
class | CircleGraphDrawer 円グラフを描画します。
class | LineGraphDrawer 折れ線グラフを描画します。
class | PortFolioDrawer ポートフォリオを描画します。
class | RadarChartDrawer レーダーチャートを描画します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AbstractDrawer (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.drawer
クラス AbstractDrawer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.drawer.AbstractDrawer
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
BarGraphDrawer, CircleGraphDrawer, LineGraphDrawer, PortFolioDrawer, RadarChartDrawer
public abstract class AbstractDrawer
extends Object
implements Serializable

画像ファイル出力用のスケルトンクラスです。

サブクラスでは、createImage メソッドをオーバーライドして、 画像を描画する機能を実装する必要があります。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

コンストラクタの概要
protected AbstractDrawer()
唯一のコンストラクタ。
メソッドの概要
protected abstract void | createImage(Graphics g) 画像ファイルを描画します。
String | getContentType() 画像ファイルのフォーマットを返却します。
int | getHeight() 画像ファイルの高さを返却します。
int | getWidth() 画像ファイルの幅を返却します。
void | putImage(OutputStream out) 指定のストリームにファイルを出力します。
void | setContentType(String type) 画像ファイルのフォーマットを設定します。
void | setHeight(int height) 画像ファイルの高さを設定します。
void | setWidth(int width) 画像ファイルの幅を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractDrawer

protected AbstractDrawer()
唯一のコンストラクタ。

メソッドの詳細

createImage

protected abstract void createImage(Graphics g)
画像ファイルを描画します。
サブクラスでは、このメソッドをオーバーライドする必要があります。

パラメータ:
g - グラフィックコンテキスト

setContentType

public void setContentType(String type)
画像ファイルのフォーマットを設定します。

パラメータ:
type - コンテントタイプ
"png" または "jpeg" を指定。
初期のコンテントタイプはpngです。

setWidth

public void setWidth(int width)
画像ファイルの幅を設定します。

パラメータ:
width - 幅

setHeight

public void setHeight(int height)
画像ファイルの高さを設定します。

getContentType

public String getContentType()
画像ファイルのフォーマットを返却します。 初期のコンテントタイプはpngです。

戻り値:
コンテントタイプ

getWidth

public int getWidth()
画像ファイルの幅を返却します。

戻り値:
幅

getHeight

public int getHeight()
画像ファイルの高さを返却します。

戻り値:
高さ

putImage

public void putImage(OutputStream out)
              throws IOException
指定のストリームにファイルを出力します。
画像フォーマットは#setContentType()によって決定されます。

パラメータ:
out - 出力先ストリーム
例外:
IOException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.drawer (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.drawer
クラス
AbstractDrawer


jp.co.intra_mart.foundation.drawer (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.drawer

画像ファイル出力用クラスを提供します。

参照:
説明

クラスの概要
AbstractDrawer 画像ファイル出力用のスケルトンクラスです。

パッケージ jp.co.intra_mart.foundation.drawer の説明

画像ファイル出力用クラスを提供します。


jp.co.intra_mart.foundation.drawer クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.drawer の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.drawer.AbstractDrawer (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.drawer の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.drawer の使用

jp.co.intra_mart.foundation.drawer を使用しているパッケージ
jp.co.intra_mart.foundation.graph グラフ描画に関するクラスを提供します。

jp.co.intra_mart.foundation.graph により使用される jp.co.intra_mart.foundation.drawer のクラス
AbstractDrawer
画像ファイル出力用のスケルトンクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.exception.ChangedListenerException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.exception.ChangedListenerException の使用

ChangedListenerException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group | プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.password |
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での ChangedListenerException の使用

ChangedListenerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
void | CompanyChangedListener.companyAdded(String groupId, Company company) 会社情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.companyDeleted(String groupId, Company company) 会社情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedListener.departmentAdded(String groupId, Department department) 組織情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.departmentUpdated(String groupId, Department department) 組織情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedListener.departmentDeleted(String groupId, Department department) 組織情報がデータストアに更新された後に呼び出されます。
void | CompanyChangedListener.departmentJoined(String groupId, String company, String parentDepartment, String department, String version) 組織構成がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.departmentMoved(String groupId, String company, String parentDepartment, String department, String version) 組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
void | CompanyChangedListener.departmentLeft(String groupId, String company, String department, String version) 組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
void | CompanyChangedListener.categoryDetailSet(String groupId, CompanyCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.categoryDetailRemoved(String groupId, CompanyCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedListener.memberSet(String groupId, DepartmentAttach attach) 組織への人員の割当がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.memberDeleted(String groupId, DepartmentAttach attach) 組織からの人員の割当がデータストアから削除された後に呼び出されます。
void | CompanyChangedListener.mainSet(String groupId, DepartmentMain main) 主所属情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.mainRemoved(String groupId, DepartmentMain main) 主所属情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedListener.versionAdded(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.versionUpdated(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに更新された後に呼び出されます。
void | CompanyChangedListener.versionDeleted(String groupId, CompanyVersion version) 会社構成バージョンがデータストアから削除された後に呼び出されます。
void | CompanyChangedListener.versionCopied(String groupId, String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.postAdded(String groupId, CompanyPost post) 役職情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.postUpdated(String groupId, CompanyPost post) 役職情報がデータストアに更新された後に呼び出されます。
void | CompanyChangedListener.postDeleted(String groupId, CompanyPost post) 役職情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.datastore.application.domain.private_group での ChangedListenerException の使用

ChangedListenerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.private_group のメソッド
void | PrivateGroupChangedListener.privateGroupAdded(String groupId, PrivateGroup group) プライベートグループがデータストアに登録された後に呼び出されます。
void | PrivateGroupChangedListener.privateGroupUpdated(String groupId, PrivateGroup group) プライベートグループがデータストアに更新された後に呼び出されます。
void | PrivateGroupChangedListener.privateGroupDeleted(String groupId, PrivateGroup group) プライベートグループがデータストアから削除された後に呼び出されます。
void | PrivateGroupChangedListener.memberSet(String groupId, PrivateGroupAttach member) プライベートグループ所属情報がデータストアに登録された後に呼び出されます。
void | PrivateGroupChangedListener.memberDeleted(String groupId, PrivateGroupAttach member) プライベートグループ所属情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での ChangedListenerException の使用

ChangedListenerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
void | PublicGroupChangedListener.groupSetAdded(String groupId, PublicGroupSet groupSet) グループセットがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.groupSetDeleted(String groupId, PublicGroupSet groupSet) グループセットがデータストアから削除された後に呼び出されます。
void | PublicGroupChangedListener.publicGroupAdded(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.publicGroupUpdated(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedListener.publicGroupDeleted(String groupId, PublicGroup publicGroup) パブリックグループがデータストアから削除された後に呼び出されます。
void | PublicGroupChangedListener.publicGroupJoined(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.publicGroupMoved(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
void | PublicGroupChangedListener.publicGroupLeft(String groupId, String groupSet, String publicGroup, String version) パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
void | PublicGroupChangedListener.categoryDetailSet(String groupId, PublicGroupCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.categoryDetailRemoved(String groupId, PublicGroupCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | PublicGroupChangedListener.memberSet(String groupId, PublicGroupAttach attach) パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.memberDeleted(String groupId, PublicGroupAttach attach) パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
void | PublicGroupChangedListener.versionAdded(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.versionUpdated(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedListener.versionDeleted(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
void | PublicGroupChangedListener.versionCopied(String groupId, String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。

jp.co.intra_mart.foundation.datastore.application.domain.user での ChangedListenerException の使用

ChangedListenerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
void | UserChangedListener.userAdded(String groupId, User user) ユーザ情報がデータストアに登録された後に呼び出されます。
void | UserChangedListener.userUpdated(String groupId, User user) ユーザ情報がデータストアに対して更新された後に呼び出されます。
void | UserChangedListener.userDeleted(String groupId, User user) ユーザ情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.access での ChangedListenerException の使用

ChangedListenerException をスローする jp.co.intra_mart.foundation.security.access のメソッド
void | RoleChangedControllerListener.roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RoleChangedControllerListener.roleDeleted(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | RoleChangedControllerListener.roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | RoleChangedControllerListener.subRoleAdded(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | RoleChangedControllerListener.subRoleDeleted(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。
void | PublicGroupChangedControllerListener.groupSetAdded(String groupId, PublicGroupSet groupSet) グループセットがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedControllerListener.groupSetDeleted(String groupId, PublicGroupSet groupSet) グループセットがデータストアから削除された後に呼び出されます。
void | PublicGroupChangedControllerListener.publicGroupAdded(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedControllerListener.publicGroupUpdated(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedControllerListener.publicGroupDeleted(String groupId, PublicGroup publicGroup) パブリックグループがデータストアから削除された後に呼び出されます。
void | PublicGroupChangedControllerListener.publicGroupJoined(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedControllerListener.publicGroupMoved(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
void | PublicGroupChangedControllerListener.publicGroupLeft(String groupId, String groupSet, String publicGroup, String version) パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
void | PublicGroupChangedControllerListener.categoryDetailSet(String groupId, PublicGroupCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedControllerListener.categoryDetailRemoved(String groupId, PublicGroupCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | PublicGroupChangedControllerListener.memberSet(String groupId, PublicGroupAttach attach) パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedControllerListener.memberDeleted(String groupId, PublicGroupAttach attach) パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
void | PublicGroupChangedControllerListener.versionAdded(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedControllerListener.versionUpdated(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedControllerListener.versionDeleted(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
void | PublicGroupChangedControllerListener.versionCopied(String groupId, String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.companyAdded(String groupId, Company company) 会社情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.companyDeleted(String groupId, Company company) 会社情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedControllerListener.departmentAdded(String groupId, Department department) 組織情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.departmentUpdated(String groupId, Department department) 組織情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedControllerListener.departmentDeleted(String groupId, Department department) 組織情報がデータストアに更新された後に呼び出されます。
void | CompanyChangedControllerListener.departmentJoined(String groupId, String company, String parentDepartment, String department, String version) 組織構成がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.departmentMoved(String groupId, String company, String parentDepartment, String department, String version) 組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
void | CompanyChangedControllerListener.departmentLeft(String groupId, String company, String department, String version) 組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
void | CompanyChangedControllerListener.categoryDetailSet(String groupId, CompanyCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.categoryDetailRemoved(String groupId, CompanyCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedControllerListener.memberSet(String groupId, DepartmentAttach attach) 組織への人員の割当がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.memberDeleted(String groupId, DepartmentAttach attach) 組織からの人員の割当がデータストアから削除された後に呼び出されます。
void | CompanyChangedControllerListener.mainSet(String groupId, DepartmentMain main) 主所属情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.mainRemoved(String groupId, DepartmentMain main) 主所属情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedControllerListener.versionAdded(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.versionUpdated(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに更新された後に呼び出されます。
void | CompanyChangedControllerListener.versionDeleted(String groupId, CompanyVersion version) 会社構成バージョンがデータストアから削除された後に呼び出されます。
void | CompanyChangedControllerListener.versionCopied(String groupId, String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.postAdded(String groupId, CompanyPost post) 役職情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedControllerListener.postUpdated(String groupId, CompanyPost post) 役職情報がデータストアに更新された後に呼び出されます。
void | CompanyChangedControllerListener.postDeleted(String groupId, CompanyPost post) 役職情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.account での ChangedListenerException の使用

ChangedListenerException をスローする jp.co.intra_mart.foundation.security.account のメソッド
void | RoleChangedAccountListener.roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RoleChangedAccountListener.roleDeleted(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | RoleChangedAccountListener.roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | RoleChangedAccountListener.subRoleAdded(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | RoleChangedAccountListener.subRoleDeleted(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。
void | AccountChangedListener.accountAdded(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | AccountChangedListener.accountDeleted(String groupId, String userId) アカウント情報をデータストアから削除した直後にコールされます。
void | AccountChangedListener.accountUpdated(String groupId, Account account) アカウント情報をデータストアに更新した直後にコールされます。
void | AccountChangedListener.accountRoleAdded(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | AccountChangedListener.accountRoleDeleted(String groupId, String userId, String roleId) アカウントロール情報をデータストアから削除した直後にコールされます。
void | AccountChangedListener.accountRoleUpdated(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.menu での ChangedListenerException の使用

ChangedListenerException をスローする jp.co.intra_mart.foundation.security.menu のメソッド
void | RoleChangedMenuListener.roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RoleChangedMenuListener.roleDeleted(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | RoleChangedMenuListener.roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | RoleChangedMenuListener.subRoleAdded(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | RoleChangedMenuListener.subRoleDeleted(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。
void | PublicGroupChangedMenuListener.groupSetAdded(String groupId, PublicGroupSet groupSet) グループセットがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.groupSetDeleted(String groupId, PublicGroupSet groupSet) グループセットがデータストアから削除された後に呼び出されます。
void | PublicGroupChangedMenuListener.publicGroupAdded(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.publicGroupUpdated(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedMenuListener.publicGroupDeleted(String groupId, PublicGroup publicGroup) パブリックグループがデータストアから削除された後に呼び出されます。
void | PublicGroupChangedMenuListener.publicGroupJoined(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.publicGroupMoved(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
void | PublicGroupChangedMenuListener.publicGroupLeft(String groupId, String groupSet, String publicGroup, String version) パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
void | PublicGroupChangedMenuListener.categoryDetailSet(String groupId, PublicGroupCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.categoryDetailRemoved(String groupId, PublicGroupCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | PublicGroupChangedMenuListener.memberSet(String groupId, PublicGroupAttach attach) パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.memberDeleted(String groupId, PublicGroupAttach attach) パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
void | PublicGroupChangedMenuListener.versionAdded(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.versionUpdated(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedMenuListener.versionDeleted(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
void | PublicGroupChangedMenuListener.versionCopied(String groupId, String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.companyAdded(String groupId, Company company) 会社情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.companyDeleted(String groupId, Company company) 会社情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedMenuListener.departmentAdded(String groupId, Department department) 組織情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.departmentUpdated(String groupId, Department department) 組織情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedMenuListener.departmentDeleted(String groupId, Department department) 組織情報がデータストアに更新された後に呼び出されます。
void | CompanyChangedMenuListener.departmentJoined(String groupId, String company, String parentDepartment, String department, String version) 組織構成がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.departmentMoved(String groupId, String company, String parentDepartment, String department, String version) 組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
void | CompanyChangedMenuListener.departmentLeft(String groupId, String company, String department, String version) 組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
void | CompanyChangedMenuListener.categoryDetailSet(String groupId, CompanyCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.categoryDetailRemoved(String groupId, CompanyCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedMenuListener.memberSet(String groupId, DepartmentAttach attach) 組織への人員の割当がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.memberDeleted(String groupId, DepartmentAttach attach) 組織からの人員の割当がデータストアから削除された後に呼び出されます。
void | CompanyChangedMenuListener.mainSet(String groupId, DepartmentMain main) 主所属情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.mainRemoved(String groupId, DepartmentMain main) 主所属情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedMenuListener.versionAdded(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.versionUpdated(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに更新された後に呼び出されます。
void | CompanyChangedMenuListener.versionDeleted(String groupId, CompanyVersion version) 会社構成バージョンがデータストアから削除された後に呼び出されます。
void | CompanyChangedMenuListener.versionCopied(String groupId, String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.postAdded(String groupId, CompanyPost post) 役職情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.postUpdated(String groupId, CompanyPost post) 役職情報がデータストアに更新された後に呼び出されます。
void | CompanyChangedMenuListener.postDeleted(String groupId, CompanyPost post) 役職情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.password での ChangedListenerException の使用

ChangedListenerException をスローする jp.co.intra_mart.foundation.security.password のメソッド
void | PasswordHistoryAccountChangedListener.accountAdded(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | PasswordHistoryAccountChangedListener.accountDeleted(String groupId, String userId) アカウント情報をデータストアから削除した直後にコールされます。

jp.co.intra_mart.foundation.security.role での ChangedListenerException の使用

ChangedListenerException をスローする jp.co.intra_mart.foundation.security.role のメソッド
void | RoleChangedListener.roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RoleChangedListener.roleDeleted(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | RoleChangedListener.roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | RoleChangedListener.subRoleAdded(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | RoleChangedListener.subRoleDeleted(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.exception.FoundationException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.exception.FoundationException の使用

FoundationException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。
jp.co.intra_mart.foundation.exception | システムでスローされる例外クラスを提供します。
jp.co.intra_mart.foundation.image |
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.password |
jp.co.intra_mart.foundation.update |

jp.co.intra_mart.foundation.datastore.exception での FoundationException の使用

jp.co.intra_mart.foundation.datastore.exception での FoundationException のサブクラス
class | AccessorClosedException アクセサのクローズ時に発生する例外クラス アクセサがクローズされている場合に、以下のメソッドを呼び出された時にスローする。
class | AccessorException アクセサで発生する例外の基底クラス
class | AccessorIllegalPropertyValueException アクセサのプロパティ設定に関する例外クラス アクセサに不正な値が設定された場合にスローする。
class | DataNotFoundException アクセサのプロパティ値の取得に関する例外クラス 指定されたプロパティに対する値が設定されていない場合にスローする。
class | DataStoreApplicationException アプリケーション共通マスタで発生するアプリケーション例外の基底クラス
class | IllegalExtensionException 拡張アクセサに関する例外クラス 拡張アクセサに対して不正な操作が行われた場合にスローする。
class | IllegalLocaleException アクセサが保持する言語に関する例外クラス アクセサが保持していない言語を要求された場合にスローする。
class | IllegalRelationshipException リレーションシップに関する例外クラス リレーションシップの整合性が正しくない場合にスローする。
class | IllegalTermException アクセサが保持する期間に関する例外クラス アクセサが保持しない日時または期間が指定されたときにスローする。
class | ManagerException マネージャに関する例外クラス
class | MapperException マッパーに関する例外クラス マッパーの処理中に問題が発生した場合にスローする。
class | TermManagerException 期間に関する例外クラス

jp.co.intra_mart.foundation.exception での FoundationException の使用

jp.co.intra_mart.foundation.exception での FoundationException のサブクラス
 class ChangedListenerException
更新リスナーの例外クラス。

jp.co.intra_mart.foundation.image での FoundationException の使用

jp.co.intra_mart.foundation.image での FoundationException のサブクラス
class | DuplicateImageIconCodeException 登録時重複例外クラス。
class | DuplicateImageIconSrcException 作成/更新時URLの重複例外クラス。
class | ImageIconException イメージアイコンの例外クラス。
class | NotExistImageIconException イメージアイコンが存在しなかった場合の例外クラス。

jp.co.intra_mart.foundation.navigator での FoundationException の使用

jp.co.intra_mart.foundation.navigator での FoundationException のサブクラス
 class EventNavigatorException
イベントナビゲータマネージャに関する例外クラス

jp.co.intra_mart.foundation.security.exception での FoundationException の使用

jp.co.intra_mart.foundation.security.exception での FoundationException のサブクラス
class | AccessSecurityCreateException アクセスセキュリティ情報作成例外クラス。
class | AccessSecurityDeleteException アクセスセキュリティ情報削除例外クラス。
class | AccessSecurityException アクセスセキュリティの基本となる例外クラス。
class | AccessSecurityExportException エクスポート時例外クラス。
class | AccessSecurityImportException インポート時例外クラス。
class | AccessSecurityListenerExcpetion アクセスセキュリティリスナーの例外クラス。
class | AccessSecurityReadException アクセスセキュリティ情報の取得例外クラス。
class | AccessSecurityUpdateException アクセスセキュリティ情報更新例外クラス。
class | AccessSecurityWriteException アクセスセキュリティ情報の更新例外クラス。
class | ActiveSessionException アクティブなセッション情報例外の基本となる例外クラス。
class | ActiveSessionInvalidatedByForceException アクティブなセッションが強制的に無効化されたことに関する例外クラス
class | ActiveSessionNotExistException アクティブなセッションが存在しない例外クラス。
class | DuplicateException 作成時重複例外クラス。
class | DuplicateLoginDetectedException 重複ログイン検出例外クラス
class | DuplicateLoginException 重複ログイン制御例外の基本となる例外クラス。
class | IllegalArgumentException 引数が不正の例外クラス。
class | NoFilterException HTTPリクエスト・レスポンス取得例外クラス。
class | NoSessionCookieException セッション情報クッキー取得例外クラス。
class | NoSessionException セッション取得例外クラス。
class | NotExistException アクセスセキュリティ情報が存在しなかった場合の例外クラス。
class | NotFoundDataSourceException データソースの参照名未解決例外クラス。
class | NotSupportMethodException アクセスセキュリティのマネージャでサポートされないメソッドがコールされた場合の例外クラス。

jp.co.intra_mart.foundation.security.password での FoundationException の使用

jp.co.intra_mart.foundation.security.password での FoundationException のサブクラス
 class PasswordHistoryException
イメージアイコンの例外クラス。

jp.co.intra_mart.foundation.update での FoundationException の使用

FoundationException をスローする jp.co.intra_mart.foundation.update のメソッド
String[] | UpdateManager.getKeys() 保存されている更新管理キーの一覧を取得します。
Date | UpdateManager.getLastModified(String key) 更新日付を取得します。
boolean | UpdateManager.isUpDate(String key, Date now) 更新管理キーの更新日付が検証日付より新しいか検証します。
Date | UpdateManager.modify(String key) 対象となる更新管理キーの更新日付を更新します。
void | UpdateManager.remove(String key) 更新管理キーを削除します。
void | UpdateManager.removeAll() すべての更新管理キーを削除します。
void | UpdateAccessor.delete(String groupId, String key) キーを削除します。
void | UpdateAccessor.deleteAll(String groupId) すべてのキーを削除します。
String[] | UpdateAccessor.getKeys(String groupId) 保存されているキーの一覧を取得します。
void | UpdateAccessor.insert(String groupId, String key, Date date) キーを取得します。
Date | UpdateAccessor.select(String groupId, String key) 更新日付を取得します。
void | UpdateAccessor.update(String groupId, String key, Date date) キーの更新日付を更新します。
void | StandardUpdateAccessor.delete(String groupId, String key) キーを削除します。
void | StandardUpdateAccessor.deleteAll(String groupId) すべてのキーを削除します。
String[] | StandardUpdateAccessor.getKeys(String groupId) 保存されているキーの一覧を取得します。
void | StandardUpdateAccessor.insert(String groupId, String key, Date date) キーを取得します。
Date | StandardUpdateAccessor.select(String groupId, String key) 更新日付を取得します。
void | StandardUpdateAccessor.update(String groupId, String key, Date date) キーの更新日付を更新します。

FoundationException をスローする jp.co.intra_mart.foundation.update のコンストラクタ
UpdateManager(String groupId)
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.exception.FoundationRuntimeException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.exception.FoundationRuntimeException の使用

FoundationRuntimeException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.exception での FoundationRuntimeException の使用

jp.co.intra_mart.foundation.datastore.exception での FoundationRuntimeException のサブクラス
class | AccessorSystemException アクセサのプロパティに関する例外クラス 指定されたプロパティがアクセサに存在しない場合にスローする。
class | DataStoreConfigException アプリケーション共通マスタの設定に関する例外クラス アプリケーション共通マスタの設定に不整合がある場合にスローする。
class | DataStoreSystemException アプリケーション共通マスタで発生するシステム例外の基底クラス
class | MapperDAOException マッパーのデータベース接続に関する例外クラス マッパーがデータベース接続で問題が発生した場合にスローする。

jp.co.intra_mart.foundation.security.exception での FoundationRuntimeException の使用

jp.co.intra_mart.foundation.security.exception での FoundationRuntimeException のサブクラス
class | AccessSecurityConfigException アクセスセキュリティ設定に関する例外クラス。
class | AccessSecurityRuntimeException アクセスセキュリティランタイム例外クラス。
class | SystemConfigException システム設定に関する例外クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ChangedListenerException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.exception
クラス ChangedListenerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.exception.ChangedListenerException
すべての実装インタフェース:
Serializable
public class ChangedListenerException
extends FoundationException

更新リスナーの例外クラス。

更新リスナー内で例外が発せした場合にスローされます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ChangedListenerException()
コンストラクタ。
ChangedListenerException(String message)
コンストラクタ。
ChangedListenerException(String message, Throwable cause)
コンストラクタ。
ChangedListenerException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ChangedListenerException

public ChangedListenerException()
コンストラクタ。

ChangedListenerException

public ChangedListenerException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

ChangedListenerException

public ChangedListenerException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

ChangedListenerException

public ChangedListenerException(String message,
                                Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


FoundationException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.exception
クラス FoundationException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccessSecurityException, ChangedListenerException, DataStoreApplicationException, ImageIconException, PasswordHistoryException
public class FoundationException
extends Exception

システム基盤共通例外クラス。

システムでスローされる例外のスーパークラスです。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
FoundationException()
コンストラクタ。
FoundationException(String message)
コンストラクタ。
FoundationException(String message, Throwable cause)
コンストラクタ。
FoundationException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

FoundationException

public FoundationException()
コンストラクタ。

FoundationException

public FoundationException(String message)
コンストラクタ。

パラメータ:
message - メッセージ

FoundationException

public FoundationException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

FoundationException

public FoundationException(String message,
                           Throwable cause)
コンストラクタ。

パラメータ:
message - メッセージ
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FoundationRuntimeException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.exception
クラス FoundationRuntimeException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.exception.FoundationRuntimeException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccessSecurityRuntimeException, DataStoreSystemException
public class FoundationRuntimeException
extends RuntimeException

システム基盤共通ランタイム例外クラス。

システムでスローされるランタイム例外のスーパークラスです。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
FoundationRuntimeException()
コンストラクタ。
FoundationRuntimeException(String message)
コンストラクタ。
FoundationRuntimeException(String message, Throwable cause)
コンストラクタ。
FoundationRuntimeException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

FoundationRuntimeException

public FoundationRuntimeException()
コンストラクタ。

FoundationRuntimeException

public FoundationRuntimeException(String message)
コンストラクタ。

パラメータ:
message - メッセージ

FoundationRuntimeException

public FoundationRuntimeException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

FoundationRuntimeException

public FoundationRuntimeException(String message,
                                  Throwable cause)
コンストラクタ。

パラメータ:
message - メッセージ
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.exception (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.exception
例外
ChangedListenerException
FoundationException
FoundationRuntimeException


jp.co.intra_mart.foundation.exception (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.exception

システムでスローされる例外クラスを提供します。

参照:
説明

例外の概要
ChangedListenerException | 更新リスナーの例外クラス。
FoundationException | システム基盤共通例外クラス。
FoundationRuntimeException | システム基盤共通ランタイム例外クラス。

パッケージ jp.co.intra_mart.foundation.exception の説明

システムでスローされる例外クラスを提供します。


jp.co.intra_mart.foundation.exception クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.exception.FoundationException
          • class jp.co.intra_mart.foundation.exception.ChangedListenerException
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.exception.FoundationRuntimeException


パッケージ jp.co.intra_mart.foundation.exception の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.exception の使用

jp.co.intra_mart.foundation.exception を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group | プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。
jp.co.intra_mart.foundation.exception | システムでスローされる例外クラスを提供します。
jp.co.intra_mart.foundation.image |
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.password |
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。
jp.co.intra_mart.foundation.update |

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.exception のクラス
ChangedListenerException
更新リスナーの例外クラス。

jp.co.intra_mart.foundation.datastore.application.domain.private_group により使用される jp.co.intra_mart.foundation.exception のクラス
ChangedListenerException
更新リスナーの例外クラス。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.exception のクラス
ChangedListenerException
更新リスナーの例外クラス。

jp.co.intra_mart.foundation.datastore.application.domain.user により使用される jp.co.intra_mart.foundation.exception のクラス
ChangedListenerException
更新リスナーの例外クラス。

jp.co.intra_mart.foundation.datastore.exception により使用される jp.co.intra_mart.foundation.exception のクラス
FoundationException
システム基盤共通例外クラス。
FoundationRuntimeException
システム基盤共通ランタイム例外クラス。

jp.co.intra_mart.foundation.exception により使用される jp.co.intra_mart.foundation.exception のクラス
FoundationException
システム基盤共通例外クラス。

jp.co.intra_mart.foundation.image により使用される jp.co.intra_mart.foundation.exception のクラス
FoundationException
システム基盤共通例外クラス。

jp.co.intra_mart.foundation.navigator により使用される jp.co.intra_mart.foundation.exception のクラス
FoundationException
システム基盤共通例外クラス。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.exception のクラス
ChangedListenerException
更新リスナーの例外クラス。

jp.co.intra_mart.foundation.security.account により使用される jp.co.intra_mart.foundation.exception のクラス
ChangedListenerException
更新リスナーの例外クラス。

jp.co.intra_mart.foundation.security.exception により使用される jp.co.intra_mart.foundation.exception のクラス
FoundationException
システム基盤共通例外クラス。
FoundationRuntimeException
システム基盤共通ランタイム例外クラス。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.exception のクラス
ChangedListenerException
更新リスナーの例外クラス。

jp.co.intra_mart.foundation.security.password により使用される jp.co.intra_mart.foundation.exception のクラス
ChangedListenerException
更新リスナーの例外クラス。
FoundationException
システム基盤共通例外クラス。

jp.co.intra_mart.foundation.security.role により使用される jp.co.intra_mart.foundation.exception のクラス
ChangedListenerException
更新リスナーの例外クラス。

jp.co.intra_mart.foundation.update により使用される jp.co.intra_mart.foundation.exception のクラス
FoundationException
システム基盤共通例外クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.BarGraphDrawer の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.BarGraphDrawer の使用

jp.co.intra_mart.foundation.graph.BarGraphDrawer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.BarGraphObject の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.BarGraphObject の使用

BarGraphObject を使用しているパッケージ
jp.co.intra_mart.foundation.graph グラフ描画に関するクラスを提供します。

jp.co.intra_mart.foundation.graph での BarGraphObject の使用

BarGraphObject を返す jp.co.intra_mart.foundation.graph のメソッド
 BarGraphObject BarGraphDrawer.getData(int index)
リスト内の指定された位置にあるデータを返します。

BarGraphObject 型のパラメータを持つ jp.co.intra_mart.foundation.graph のメソッド
void | BarGraphDrawer.addData(BarGraphObject obj) 描画オブジェクトに新しいデータを追加します。
void | BarGraphDrawer.addData(int index, BarGraphObject obj) 指定された位置に、指定された描画オブジェクトを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.CircleGraphDrawer の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.CircleGraphDrawer の使用

jp.co.intra_mart.foundation.graph.CircleGraphDrawer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.CircleGraphObject の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.CircleGraphObject の使用

CircleGraphObject を使用しているパッケージ
jp.co.intra_mart.foundation.graph グラフ描画に関するクラスを提供します。

jp.co.intra_mart.foundation.graph での CircleGraphObject の使用

CircleGraphObject を返す jp.co.intra_mart.foundation.graph のメソッド
 CircleGraphObject CircleGraphDrawer.getData(int index)
リスト内の指定された位置にあるデータを返します。

CircleGraphObject 型のパラメータを持つ jp.co.intra_mart.foundation.graph のメソッド
void | CircleGraphDrawer.addData(CircleGraphObject obj) 描画オブジェクトに新しいデータを追加します。
void | CircleGraphDrawer.addData(int index, CircleGraphObject obj) 指定された位置に、指定された描画オブジェクトを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.LineGraphDrawer の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.LineGraphDrawer の使用

jp.co.intra_mart.foundation.graph.LineGraphDrawer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.LineGraphObject の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.LineGraphObject の使用

LineGraphObject を使用しているパッケージ
jp.co.intra_mart.foundation.graph グラフ描画に関するクラスを提供します。

jp.co.intra_mart.foundation.graph での LineGraphObject の使用

LineGraphObject を返す jp.co.intra_mart.foundation.graph のメソッド
 LineGraphObject LineGraphDrawer.getData(int index)
リスト内の指定された位置にあるデータを返します。

LineGraphObject 型のパラメータを持つ jp.co.intra_mart.foundation.graph のメソッド
void | LineGraphDrawer.addData(LineGraphObject obj) 描画オブジェクトに新しいデータを追加します。
void | LineGraphDrawer.addData(int index, LineGraphObject obj) 指定された位置に、指定された描画オブジェクトを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.PortFolioDrawer の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.PortFolioDrawer の使用

jp.co.intra_mart.foundation.graph.PortFolioDrawer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.PortFolioObject の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.PortFolioObject の使用

PortFolioObject を使用しているパッケージ
jp.co.intra_mart.foundation.graph グラフ描画に関するクラスを提供します。

jp.co.intra_mart.foundation.graph での PortFolioObject の使用

PortFolioObject を返す jp.co.intra_mart.foundation.graph のメソッド
 PortFolioObject PortFolioDrawer.getData(int index)
リスト内の指定された位置にあるデータを返します。

PortFolioObject 型のパラメータを持つ jp.co.intra_mart.foundation.graph のメソッド
void | PortFolioDrawer.addData(PortFolioObject obj) 描画オブジェクトに新しいデータを追加します。
void | PortFolioDrawer.addData(int index, PortFolioObject obj) 指定された位置に、指定された描画オブジェクトを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.RadarChartDrawer の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.RadarChartDrawer の使用

jp.co.intra_mart.foundation.graph.RadarChartDrawer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.RadarChartObject の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.RadarChartObject の使用

RadarChartObject を使用しているパッケージ
jp.co.intra_mart.foundation.graph グラフ描画に関するクラスを提供します。

jp.co.intra_mart.foundation.graph での RadarChartObject の使用

RadarChartObject を返す jp.co.intra_mart.foundation.graph のメソッド
 RadarChartObject RadarChartDrawer.getData(int index)
リスト内の指定された位置にあるデータを返します。

RadarChartObject 型のパラメータを持つ jp.co.intra_mart.foundation.graph のメソッド
void | RadarChartDrawer.addData(RadarChartObject obj) 描画オブジェクトに新しいデータを追加します。
void | RadarChartDrawer.addData(int index, RadarChartObject obj) 指定された位置に、指定された描画オブジェクトを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BarGraphDrawer (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス BarGraphDrawer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.drawer.AbstractDrawer
        拡張 jp.co.intra_mart.foundation.graph.BarGraphDrawer
すべての実装インタフェース:
Serializable
public class BarGraphDrawer
extends AbstractDrawer

棒グラフを描画します。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

フィールドの概要
static int | DEFAULT_BOTTOM_MARGIN 標準のグラフ領域の下部マージン
static Color | DEFAULT_GRAPH_BACKGROUND_COLOR 標準のグラフ領域の背景色
static Color | DEFAULT_GRAPH_BORDER_COLOR 標準のグラフ領域のボーダー色
static Color | DEFAULT_IMAGE_BACKGROUND_COLOR 標準の画像ファイル背景色
static Color | DEFAULT_IMAGE_BORDER_COLOR 標準の画像ファイルのボーダ色
static int | DEFAULT_LEFT_MARGIN 標準のグラフ領域の左側マージン
static int | DEFAULT_RIGHT_MARGIN 標準のグラフ領域の右側マージン
static int | DEFAULT_TOP_MARGIN 標準のグラフ領域の上部マージン
コンストラクタの概要
BarGraphDrawer(double min, double max, double count)
ｙ軸の目盛値をdouble表現で棒グラフを作成します。
BarGraphDrawer(int min, int max, int count)
ｙ軸の目盛値をint表現で棒グラフを作成します。
メソッドの概要
void | addData(BarGraphObject obj) 描画オブジェクトに新しいデータを追加します。
void | addData(int index, BarGraphObject obj) 指定された位置に、指定された描画オブジェクトを追加します。
void | clear() すべてのデータを削除します。
protected void | createImage(Graphics g) 棒グラフを描画します。
String[] | getCaption() ｘ軸のキャプションを返します。
Color | getCaptionColor() キャプションの文字色を返します。
BarGraphObject | getData(int index) リスト内の指定された位置にあるデータを返します。
Color | getGraphBackgroundColor() グラフ領域の背景色を返します。
Color | getGraphBorderColor() グラフ領域のボーダーの色を返します。
Color | getImageBackgroundColor() 画像ファイルの背景色を返します。
Color | getImageBorderColor() 画像ファイルのボーダ色を返します。
Color | getImgaeBackgroundColor() 推奨されていません。
Color | getImgaeBorderColor() 推奨されていません。
double | getMax() ｙ軸の最大値を返します。
double | getMin() ｙ軸の最小値を返します。
double | getScaleCount() ｙ軸の目盛間隔を返します。
boolean | isDouble() ｙ軸の目盛値がdouble表現かどうかを判定します。
void | remove(int index) 指定された位置のデータを削除します。
void | setCaption(String[] caption) ｘ軸のキャプションを設定します。
void | setCaptionColor(Color color) キャプションの文字色を設定します。
void | setGraphBackgroundColor(Color color) グラフ領域の背景色を設定します。
void | setGraphBorderColor(Color color) グラフ領域のボーダーの色を設定します。
void | setImageBackgroundColor(Color color) 画像ファイルの背景色を設定します。
void | setImageBorderColor(Color color) 画像ファイルのボーダ色を設定します。
void | setImgaeBackgroundColor(Color color) 推奨されていません。
void | setImgaeBorderColor(Color color) 推奨されていません。
void | setMargin(int top, int right, int bottom, int left) グラフ領域のマージンを設定します。
int | size() データの数を返します。
クラス jp.co.intra_mart.foundation.drawer.AbstractDrawer から継承したメソッド
getContentType, getHeight, getWidth, putImage, setContentType, setHeight, setWidth
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_TOP_MARGIN

public static int DEFAULT_TOP_MARGIN
標準のグラフ領域の上部マージン

DEFAULT_RIGHT_MARGIN

public static int DEFAULT_RIGHT_MARGIN
標準のグラフ領域の右側マージン

DEFAULT_BOTTOM_MARGIN

public static int DEFAULT_BOTTOM_MARGIN
標準のグラフ領域の下部マージン

DEFAULT_LEFT_MARGIN

public static int DEFAULT_LEFT_MARGIN
標準のグラフ領域の左側マージン

DEFAULT_IMAGE_BACKGROUND_COLOR

public static Color DEFAULT_IMAGE_BACKGROUND_COLOR
標準の画像ファイル背景色

DEFAULT_IMAGE_BORDER_COLOR

public static Color DEFAULT_IMAGE_BORDER_COLOR
標準の画像ファイルのボーダ色

DEFAULT_GRAPH_BACKGROUND_COLOR

public static Color DEFAULT_GRAPH_BACKGROUND_COLOR
標準のグラフ領域の背景色

DEFAULT_GRAPH_BORDER_COLOR

public static Color DEFAULT_GRAPH_BORDER_COLOR
標準のグラフ領域のボーダー色

コンストラクタの詳細

BarGraphDrawer

public BarGraphDrawer(int min,
                      int max,
                      int count)
ｙ軸の目盛値をint表現で棒グラフを作成します。

パラメータ:
min - ｙ軸の最小値
max - ｙ軸の最大値
count - ｙ軸の目盛間隔
例外:
IllegalArgumentException - max <= min または count <= 0

BarGraphDrawer

public BarGraphDrawer(double min,
                      double max,
                      double count)
ｙ軸の目盛値をdouble表現で棒グラフを作成します。

パラメータ:
min - ｙ軸の最小値
max - ｙ軸の最大値
count - ｙ軸の目盛間隔
例外:
IllegalArgumentException - max <= min または count <= 0
メソッドの詳細

getMax

public double getMax()
ｙ軸の最大値を返します。

戻り値:
double ｙ軸の最大値

getMin

public double getMin()
ｙ軸の最小値を返します。

戻り値:
double ｙ軸の最小値

getScaleCount

public double getScaleCount()
ｙ軸の目盛間隔を返します。

戻り値:
double ｙ軸の目盛間隔

setCaption

public void setCaption(String[] caption)
ｘ軸のキャプションを設定します。

パラメータ:
caption - キャプション

getCaption

public String[] getCaption()
ｘ軸のキャプションを返します。

戻り値:
キャプション

addData

public void addData(BarGraphObject obj)
描画オブジェクトに新しいデータを追加します。

パラメータ:
obj - データ

setImageBackgroundColor

public void setImageBackgroundColor(Color color)
画像ファイルの背景色を設定します。

パラメータ:
color -

setImgaeBackgroundColor

public void setImgaeBackgroundColor(Color color)
推奨されていません。

画像ファイルの背景色を設定します。

パラメータ:
color -

getImageBackgroundColor

public Color getImageBackgroundColor()
画像ファイルの背景色を返します。

戻り値:
color

getImgaeBackgroundColor

public Color getImgaeBackgroundColor()
推奨されていません。

画像ファイルの背景色を返します。

戻り値:
color

setImageBorderColor

public void setImageBorderColor(Color color)
画像ファイルのボーダ色を設定します。

パラメータ:
color -

setImgaeBorderColor

public void setImgaeBorderColor(Color color)
推奨されていません。

画像ファイルのボーダ色を設定します。

パラメータ:
color -

getImageBorderColor

public Color getImageBorderColor()
画像ファイルのボーダ色を返します。

戻り値:
color

getImgaeBorderColor

public Color getImgaeBorderColor()
推奨されていません。

画像ファイルのボーダ色を返します。

戻り値:
color

getGraphBackgroundColor

public Color getGraphBackgroundColor()
グラフ領域の背景色を返します。

戻り値:
Color グラフ領域の背景色

setGraphBackgroundColor

public void setGraphBackgroundColor(Color color)
グラフ領域の背景色を設定します。

パラメータ:
color - グラフ領域の背景色

getGraphBorderColor

public Color getGraphBorderColor()
グラフ領域のボーダーの色を返します。

戻り値:
グラフ領域のボーダーの色

setGraphBorderColor

public void setGraphBorderColor(Color color)
グラフ領域のボーダーの色を設定します。

パラメータ:
color - グラフ領域のボーダーの色

getCaptionColor

public Color getCaptionColor()
キャプションの文字色を返します。

戻り値:
キャプションの文字色

setCaptionColor

public void setCaptionColor(Color color)
キャプションの文字色を設定します。

パラメータ:
color - キャプションの文字色

addData

public void addData(int index,
                    BarGraphObject obj)
指定された位置に、指定された描画オブジェクトを追加します。 現在その位置にあるデータはindex値に１追加されます。

パラメータ:
obj - データ
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index > size())

isDouble

public boolean isDouble()
ｙ軸の目盛値がdouble表現かどうかを判定します。

戻り値:
doubleで表現する場合はtrue

getData

public BarGraphObject getData(int index)
リスト内の指定された位置にあるデータを返します。

パラメータ:
index - インデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

remove

public void remove(int index)
指定された位置のデータを削除します。 削除後は後続の要素を左側に移動します。

パラメータ:
index - 削除されるデータ値のインデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

size

public int size()
データの数を返します。

戻り値:
int 値の数

clear

public void clear()
すべてのデータを削除します。

setMargin

public void setMargin(int top,
                      int right,
                      int bottom,
                      int left)
グラフ領域のマージンを設定します。

パラメータ:
top - 上部のマージン
right - 右側のマ－ジン
bottom - 下部のマージン
left - 左側のマージン

createImage

protected void createImage(Graphics g)
棒グラフを描画します。

定義:
クラス AbstractDrawer 内の createImage
パラメータ:
g - グラフィックコンテキスト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BarGraphObject (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス BarGraphObject

java.lang.Object
    拡張 jp.co.intra_mart.foundation.graph.BarGraphObject
すべての実装インタフェース:
Serializable
public class BarGraphObject
extends Object
implements Serializable

BarGraphDrawerクラスのデータを保存するオブジェクトです。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

コンストラクタの概要
BarGraphObject()
デフォルトのデータオブジェクトを作成します。
BarGraphObject(Color color)
線の色を指定して、データオブジェクトを作成します。
メソッドの概要
void | addData(double number) 値を追加します。
void | addData(int number) 値を追加します。
void | clear() すべての値を削除します。
Color | getColor() 棒の色を返します。
double | getData(int index) 指定された位置にある値を返します。
void | remove(int index) 指定された位置の値を削除します。
void | setColor(Color color) 棒の色を設定します。
int | size() 値の数を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BarGraphObject

public BarGraphObject()
デフォルトのデータオブジェクトを作成します。

BarGraphObject

public BarGraphObject(Color color)
線の色を指定して、データオブジェクトを作成します。

パラメータ:
color - 描画される線の色
メソッドの詳細

addData

public void addData(double number)
値を追加します。

パラメータ:
number - 値

addData

public void addData(int number)
値を追加します。 intを与えますが、値はdoubleで扱われます。

パラメータ:
number - 値

getData

public double getData(int index)
指定された位置にある値を返します。

パラメータ:
index - 返される値のインデックス
戻り値:
double 値
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

remove

public void remove(int index)
指定された位置の値を削除します。 削除後は後続の要素を左側に移動します。

パラメータ:
index - 削除されるデータ値のインデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

size

public int size()
値の数を返します。

戻り値:
int 値の数

clear

public void clear()
すべての値を削除します。

getColor

public Color getColor()
棒の色を返します。

戻り値:
color 描画される棒の色

setColor

public void setColor(Color color)
棒の色を設定します。

パラメータ:
color - 描画される棒の色
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CircleGraphDrawer (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス CircleGraphDrawer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.drawer.AbstractDrawer
        拡張 jp.co.intra_mart.foundation.graph.CircleGraphDrawer
すべての実装インタフェース:
Serializable
public class CircleGraphDrawer
extends AbstractDrawer

円グラフを描画します。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

フィールドの概要
static int | DEFAULT_BOTTOM_MARGIN 標準のグラフ領域の下部マージン
static int | DEFAULT_CAPTION_MARGIN 標準のキャプション表示位置のマージン
static Color | DEFAULT_IMAGE_BACKGROUND_COLOR 標準の画像ファイル背景色
static Color | DEFAULT_IMAGE_BORDER_COLOR 標準の画像ファイルのボーダ色
static int | DEFAULT_LEFT_MARGIN 標準のグラフ領域の左側マージン
static int | DEFAULT_RIGHT_MARGIN 標準のグラフ領域の右側マージン
static int | DEFAULT_TOP_MARGIN 標準のグラフ領域の上部マージン
コンストラクタの概要
CircleGraphDrawer()
ｙ軸の目盛値をint表現で円グラフを作成します。
メソッドの概要
void | addData(CircleGraphObject obj) 描画オブジェクトに新しいデータを追加します。
void | addData(int index, CircleGraphObject obj) 指定された位置に、指定された描画オブジェクトを追加します。
void | clear() すべてのデータを削除します。
protected void | createImage(Graphics g) 円グラフを描画します。
int | getCaptionMargin() キャプション表示位置のマージンを返します。
CircleGraphObject | getData(int index) リスト内の指定された位置にあるデータを返します。
Color | getImageBackgroundColor() 画像ファイルの背景色を返します。
Color | getImageBorderColor() 画像ファイルのボーダ色を返します。
Color | getImgaeBackgroundColor() 推奨されていません。
Color | getImgaeBorderColor() 推奨されていません。
void | remove(int index) 指定された位置のデータを削除します。
void | setCaptionMargin(int margin) キャプション表示位置のマージンを設定します。
void | setImageBackgroundColor(Color color) 画像ファイルの背景色を設定します。
void | setImageBorderColor(Color color) 画像ファイルのボーダ色を設定します。
void | setImgaeBackgroundColor(Color color) 推奨されていません。
void | setImgaeBorderColor(Color color) 推奨されていません。
void | setMargin(int top, int right, int bottom, int left) グラフ領域のマージンを設定します。
int | size() データの数を返します。
クラス jp.co.intra_mart.foundation.drawer.AbstractDrawer から継承したメソッド
getContentType, getHeight, getWidth, putImage, setContentType, setHeight, setWidth
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_TOP_MARGIN

public static int DEFAULT_TOP_MARGIN
標準のグラフ領域の上部マージン

DEFAULT_RIGHT_MARGIN

public static int DEFAULT_RIGHT_MARGIN
標準のグラフ領域の右側マージン

DEFAULT_BOTTOM_MARGIN

public static int DEFAULT_BOTTOM_MARGIN
標準のグラフ領域の下部マージン

DEFAULT_LEFT_MARGIN

public static int DEFAULT_LEFT_MARGIN
標準のグラフ領域の左側マージン

DEFAULT_CAPTION_MARGIN

public static int DEFAULT_CAPTION_MARGIN
標準のキャプション表示位置のマージン

DEFAULT_IMAGE_BACKGROUND_COLOR

public static Color DEFAULT_IMAGE_BACKGROUND_COLOR
標準の画像ファイル背景色

DEFAULT_IMAGE_BORDER_COLOR

public static Color DEFAULT_IMAGE_BORDER_COLOR
標準の画像ファイルのボーダ色

コンストラクタの詳細

CircleGraphDrawer

public CircleGraphDrawer()
ｙ軸の目盛値をint表現で円グラフを作成します。

例外:
IllegalArgumentException - max <= min または count <= 0
メソッドの詳細

addData

public void addData(CircleGraphObject obj)
描画オブジェクトに新しいデータを追加します。

パラメータ:
obj - データ

setImageBackgroundColor

public void setImageBackgroundColor(Color color)
画像ファイルの背景色を設定します。

パラメータ:
color -

setImgaeBackgroundColor

public void setImgaeBackgroundColor(Color color)
推奨されていません。

画像ファイルの背景色を設定します。

パラメータ:
color -

getImageBackgroundColor

public Color getImageBackgroundColor()
画像ファイルの背景色を返します。

戻り値:
color

getImgaeBackgroundColor

public Color getImgaeBackgroundColor()
推奨されていません。

画像ファイルの背景色を返します。

戻り値:
color

setImageBorderColor

public void setImageBorderColor(Color color)
画像ファイルのボーダ色を設定します。

パラメータ:
color -

setImgaeBorderColor

public void setImgaeBorderColor(Color color)
推奨されていません。

画像ファイルのボーダ色を設定します。

パラメータ:
color -

getImageBorderColor

public Color getImageBorderColor()
画像ファイルのボーダ色を返します。

戻り値:
color

getImgaeBorderColor

public Color getImgaeBorderColor()
推奨されていません。

画像ファイルのボーダ色を返します。

戻り値:
color

addData

public void addData(int index,
                    CircleGraphObject obj)
指定された位置に、指定された描画オブジェクトを追加します。 現在その位置にあるデータはindex値に１追加されます。

パラメータ:
obj - データ
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index > size())

getData

public CircleGraphObject getData(int index)
リスト内の指定された位置にあるデータを返します。

パラメータ:
index - インデックス
戻り値:
jp.co.intra_mart.foundation.graph.RadarChartObject
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

remove

public void remove(int index)
指定された位置のデータを削除します。 削除後は後続の要素を左側に移動します。

パラメータ:
index - 削除されるデータ値のインデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

size

public int size()
データの数を返します。

戻り値:
int 値の数

clear

public void clear()
すべてのデータを削除します。

setMargin

public void setMargin(int top,
                      int right,
                      int bottom,
                      int left)
グラフ領域のマージンを設定します。

パラメータ:
top - 上部のマージン
right - 右側のマ－ジン
bottom - 下部のマージン
left - 左側のマージン

setCaptionMargin

public void setCaptionMargin(int margin)
キャプション表示位置のマージンを設定します。

パラメータ:
margin - キャプション表示位置のマージン

getCaptionMargin

public int getCaptionMargin()
キャプション表示位置のマージンを返します。

戻り値:
int キャプション表示位置のマージン

createImage

protected void createImage(Graphics g)
円グラフを描画します。

定義:
クラス AbstractDrawer 内の createImage
パラメータ:
g - グラフィックコンテキスト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CircleGraphObject (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス CircleGraphObject

java.lang.Object
    拡張 jp.co.intra_mart.foundation.graph.CircleGraphObject
すべての実装インタフェース:
Serializable
public class CircleGraphObject
extends Object
implements Serializable

CircleGraphDrawerクラスのデータを保存するオブジェクトです。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

コンストラクタの概要
CircleGraphObject(double number, Color color)
グラフ値と色を指定して、データオブジェクトを作成します。
CircleGraphObject(double number, Color color, String caption)
グラフ値と色とキャプションを指定して、データオブジェクトを作成します。
CircleGraphObject(int number, Color color)
グラフ値と色を指定して、データオブジェクトを作成します。
CircleGraphObject(int number, Color color, String caption)
グラフ値と色とキャプションを指定して、データオブジェクトを作成します。
メソッドの概要
String | getCaption() キャプション文字列を返します。
Color | getColor() グラフの色を返します。
double | getData() グラフ値を返します。
Color | getFontColor() キャプションの文字色を返します。
int | getFontSize() キャプションの文字サイズを返します。
boolean | isDouble() グラフ値がdouble表現かどうかを判定します。
void | setCaption(String caption) キャプション文字列を返します。
void | setFontColor(Color font_color) キャプションの文字色を設定します。
void | setFontSize(int font_size) キャプションの文字サイズを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CircleGraphObject

public CircleGraphObject(double number,
                         Color color)
グラフ値と色を指定して、データオブジェクトを作成します。 グラフ値は doubleです。

パラメータ:
number - グラフの値
color - 描画されるグラフの色

CircleGraphObject

public CircleGraphObject(int number,
                         Color color)
グラフ値と色を指定して、データオブジェクトを作成します。 グラフ値は intで与えますが、値はdoubleで扱われます。

パラメータ:
number - グラフの値
color - 描画されるグラフの色

CircleGraphObject

public CircleGraphObject(double number,
                         Color color,
                         String caption)
グラフ値と色とキャプションを指定して、データオブジェクトを作成します。 グラフ値は doubleです。

パラメータ:
number - グラフの値
color - 描画されるグラフの色
caption - キャプションの文字列

CircleGraphObject

public CircleGraphObject(int number,
                         Color color,
                         String caption)
グラフ値と色とキャプションを指定して、データオブジェクトを作成します。 グラフ値は intで与えますが、値はdoubleで扱われます。

パラメータ:
number - グラフの値
color - 描画されるグラフの色
caption - キャプションの文字列
メソッドの詳細

getData

public double getData()
グラフ値を返します。

戻り値:
double 値

getColor

public Color getColor()
グラフの色を返します。

戻り値:
color 描画されるグラフの色

getCaption

public String getCaption()
キャプション文字列を返します。

戻り値:
String キャプション文字列

setCaption

public void setCaption(String caption)
キャプション文字列を返します。

戻り値:
String キャプション文字列

getFontColor

public Color getFontColor()
キャプションの文字色を返します。

戻り値:
Color キャプションの文字色

setFontColor

public void setFontColor(Color font_color)
キャプションの文字色を設定します。

パラメータ:
font_color - キャプションの文字色

getFontSize

public int getFontSize()
キャプションの文字サイズを返します。

戻り値:
int キャプションの文字サイズ

setFontSize

public void setFontSize(int font_size)
キャプションの文字サイズを設定します。

パラメータ:
font_size - キャプションの文字サイズ

isDouble

public boolean isDouble()
グラフ値がdouble表現かどうかを判定します。

戻り値:
doubleで表現する場合はtrue
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LineGraphDrawer (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス LineGraphDrawer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.drawer.AbstractDrawer
        拡張 jp.co.intra_mart.foundation.graph.LineGraphDrawer
すべての実装インタフェース:
Serializable
public class LineGraphDrawer
extends AbstractDrawer

折れ線グラフを描画します。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

フィールドの概要
static int | DEFAULT_BOTTOM_MARGIN 標準のグラフ領域の下部マージン
static Color | DEFAULT_GRAPH_BACKGROUND_COLOR 標準のグラフ領域の背景色
static Color | DEFAULT_GRAPH_BORDER_COLOR 標準のグラフ領域のボーダー色
static Color | DEFAULT_IMAGE_BACKGROUND_COLOR 標準の画像ファイル背景色
static Color | DEFAULT_IMAGE_BORDER_COLOR 標準の画像ファイルのボーダ色
static int | DEFAULT_LEFT_MARGIN 標準のグラフ領域の左側マージン
static int | DEFAULT_RIGHT_MARGIN 標準のグラフ領域の右側マージン
static int | DEFAULT_TOP_MARGIN 標準のグラフ領域の上部マージン
コンストラクタの概要
LineGraphDrawer(double min, double max, double count)
ｙ軸の目盛値をdouble表現で折れ線グラフを作成します。
LineGraphDrawer(int min, int max, int count)
ｙ軸の目盛値をint表現で折れ線グラフを作成します。
メソッドの概要
void | addData(int index, LineGraphObject obj) 指定された位置に、指定された描画オブジェクトを追加します。
void | addData(LineGraphObject obj) 描画オブジェクトに新しいデータを追加します。
void | clear() すべてのデータを削除します。
protected void | createImage(Graphics g) 折れ線グラフを描画します。
String[] | getCaption() ｘ軸のキャプションを返します。
Color | getCaptionColor() キャプションの文字色を返します。
LineGraphObject | getData(int index) リスト内の指定された位置にあるデータを返します。
Color | getGraphBackgroundColor() グラフ領域の背景色を返します。
Color | getGraphBorderColor() グラフ領域のボーダーの色を返します。
Color | getImageBackgroundColor() 画像ファイルの背景色を返します。
Color | getImageBorderColor() 画像ファイルのボーダ色を返します。
Color | getImgaeBackgroundColor() 推奨されていません。
Color | getImgaeBorderColor() 推奨されていません。
double | getMax() ｙ軸の最大値を返します。
double | getMin() ｙ軸の最小値を返します。
double | getScaleCount() ｙ軸の目盛間隔を返します。
boolean | isDouble() ｙ軸の目盛値がdouble表現かどうかを判定します。
void | remove(int index) 指定された位置のデータを削除します。
void | setCaption(String[] caption) ｘ軸のキャプションを設定します。
void | setCaptionColor(Color color) キャプションの文字色を設定します。
void | setGraphBackgroundColor(Color color) グラフ領域の背景色を設定します。
void | setGraphBorderColor(Color color) グラフ領域のボーダーの色を設定します。
void | setImageBackgroundColor(Color color) 画像ファイルの背景色を設定します。
void | setImageBorderColor(Color color) 画像ファイルのボーダ色を設定します。
void | setImgaeBackgroundColor(Color color) 推奨されていません。
void | setImgaeBorderColor(Color color) 推奨されていません。
void | setMargin(int top, int right, int bottom, int left) グラフ領域のマージンを設定します。
int | size() データの数を返します。
クラス jp.co.intra_mart.foundation.drawer.AbstractDrawer から継承したメソッド
getContentType, getHeight, getWidth, putImage, setContentType, setHeight, setWidth
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_TOP_MARGIN

public static int DEFAULT_TOP_MARGIN
標準のグラフ領域の上部マージン

DEFAULT_RIGHT_MARGIN

public static int DEFAULT_RIGHT_MARGIN
標準のグラフ領域の右側マージン

DEFAULT_BOTTOM_MARGIN

public static int DEFAULT_BOTTOM_MARGIN
標準のグラフ領域の下部マージン

DEFAULT_LEFT_MARGIN

public static int DEFAULT_LEFT_MARGIN
標準のグラフ領域の左側マージン

DEFAULT_IMAGE_BACKGROUND_COLOR

public static Color DEFAULT_IMAGE_BACKGROUND_COLOR
標準の画像ファイル背景色

DEFAULT_IMAGE_BORDER_COLOR

public static Color DEFAULT_IMAGE_BORDER_COLOR
標準の画像ファイルのボーダ色

DEFAULT_GRAPH_BACKGROUND_COLOR

public static Color DEFAULT_GRAPH_BACKGROUND_COLOR
標準のグラフ領域の背景色

DEFAULT_GRAPH_BORDER_COLOR

public static Color DEFAULT_GRAPH_BORDER_COLOR
標準のグラフ領域のボーダー色

コンストラクタの詳細

LineGraphDrawer

public LineGraphDrawer(int min,
                       int max,
                       int count)
ｙ軸の目盛値をint表現で折れ線グラフを作成します。

パラメータ:
min - ｙ軸の最小値
max - ｙ軸の最大値
count - ｙ軸の目盛間隔
例外:
IllegalArgumentException - max <= min または count <= 0

LineGraphDrawer

public LineGraphDrawer(double min,
                       double max,
                       double count)
ｙ軸の目盛値をdouble表現で折れ線グラフを作成します。

パラメータ:
min - ｙ軸の最小値
max - ｙ軸の最大値
count - ｙ軸の目盛間隔
例外:
IllegalArgumentException - max <= min または count <= 0
メソッドの詳細

getMax

public double getMax()
ｙ軸の最大値を返します。

戻り値:
double ｙ軸の最大値

getMin

public double getMin()
ｙ軸の最小値を返します。

戻り値:
double ｙ軸の最小値

getScaleCount

public double getScaleCount()
ｙ軸の目盛間隔を返します。

戻り値:
double ｙ軸の目盛間隔

setCaption

public void setCaption(String[] caption)
ｘ軸のキャプションを設定します。

パラメータ:
caption - キャプション

getCaption

public String[] getCaption()
ｘ軸のキャプションを返します。

戻り値:
キャプション

addData

public void addData(LineGraphObject obj)
描画オブジェクトに新しいデータを追加します。

パラメータ:
obj - データ

setImageBackgroundColor

public void setImageBackgroundColor(Color color)
画像ファイルの背景色を設定します。

パラメータ:
color -

setImgaeBackgroundColor

public void setImgaeBackgroundColor(Color color)
推奨されていません。

画像ファイルの背景色を設定します。

パラメータ:
color -

getImageBackgroundColor

public Color getImageBackgroundColor()
画像ファイルの背景色を返します。

戻り値:
color

getImgaeBackgroundColor

public Color getImgaeBackgroundColor()
推奨されていません。

画像ファイルの背景色を返します。

戻り値:
color

setImageBorderColor

public void setImageBorderColor(Color color)
画像ファイルのボーダ色を設定します。

パラメータ:
color -

setImgaeBorderColor

public void setImgaeBorderColor(Color color)
推奨されていません。

画像ファイルのボーダ色を設定します。

パラメータ:
color -

getImageBorderColor

public Color getImageBorderColor()
画像ファイルのボーダ色を返します。

戻り値:
color

getImgaeBorderColor

public Color getImgaeBorderColor()
推奨されていません。

画像ファイルのボーダ色を返します。

戻り値:
color

getGraphBackgroundColor

public Color getGraphBackgroundColor()
グラフ領域の背景色を返します。

戻り値:
Color グラフ領域の背景色

setGraphBackgroundColor

public void setGraphBackgroundColor(Color color)
グラフ領域の背景色を設定します。

パラメータ:
color - グラフ領域の背景色

getGraphBorderColor

public Color getGraphBorderColor()
グラフ領域のボーダーの色を返します。

戻り値:
グラフ領域のボーダーの色

setGraphBorderColor

public void setGraphBorderColor(Color color)
グラフ領域のボーダーの色を設定します。

パラメータ:
color - グラフ領域のボーダーの色

getCaptionColor

public Color getCaptionColor()
キャプションの文字色を返します。

戻り値:
キャプションの文字色

setCaptionColor

public void setCaptionColor(Color color)
キャプションの文字色を設定します。

パラメータ:
color - キャプションの文字色

addData

public void addData(int index,
                    LineGraphObject obj)
指定された位置に、指定された描画オブジェクトを追加します。 現在その位置にあるデータはindex値に１追加されます。

パラメータ:
obj - データ
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index > size())

isDouble

public boolean isDouble()
ｙ軸の目盛値がdouble表現かどうかを判定します。

戻り値:
doubleで表現する場合はtrue

getData

public LineGraphObject getData(int index)
リスト内の指定された位置にあるデータを返します。

パラメータ:
index - インデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

remove

public void remove(int index)
指定された位置のデータを削除します。 削除後は後続の要素を左側に移動します。

パラメータ:
index - 削除されるデータ値のインデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

size

public int size()
データの数を返します。

戻り値:
int 値の数

clear

public void clear()
すべてのデータを削除します。

setMargin

public void setMargin(int top,
                      int right,
                      int bottom,
                      int left)
グラフ領域のマージンを設定します。

パラメータ:
top - 上部のマージン
right - 右側のマ－ジン
bottom - 下部のマージン
left - 左側のマージン

createImage

protected void createImage(Graphics g)
折れ線グラフを描画します。

定義:
クラス AbstractDrawer 内の createImage
パラメータ:
g - グラフィックコンテキスト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LineGraphObject (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス LineGraphObject

java.lang.Object
    拡張 jp.co.intra_mart.foundation.graph.LineGraphObject
すべての実装インタフェース:
Serializable
public class LineGraphObject
extends Object
implements Serializable

LineGraphDrawerクラスのデータを保存するオブジェクトです。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

フィールドの概要
static Stroke DEFAULT_STROKE
コンストラクタの概要
LineGraphObject()
デフォルトのデータオブジェクトを作成します。
LineGraphObject(Color color)
線の色を指定して、データオブジェクトを作成します。
LineGraphObject(Color color, Stroke stroke)
線の色と描画属性を指定して、データオブジェクトを作成します。
LineGraphObject(Stroke stroke)
線の描画属性を指定して、データオブジェクトを作成します。
メソッドの概要
void | addData(double number) 値を追加します。
void | addData(int number) 値を追加します。
void | clear() すべての値を削除します。
Color | getColor() 線の色を返します。
double | getData(int index) 指定された位置にある値を返します。
Stroke | getStroke() 描画される線の描画属性を返します。
void | remove(int index) 指定された位置の値を削除します。
void | setColor(Color color) 線の色を設定します。
void | setStroke(Stroke stroke) 描画される線の描画属性を設定します。
int | size() 値の数を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_STROKE

public static Stroke DEFAULT_STROKE
コンストラクタの詳細

LineGraphObject

public LineGraphObject()
デフォルトのデータオブジェクトを作成します。

LineGraphObject

public LineGraphObject(Color color)
線の色を指定して、データオブジェクトを作成します。

パラメータ:
color - 描画される線の色

LineGraphObject

public LineGraphObject(Stroke stroke)
線の描画属性を指定して、データオブジェクトを作成します。

パラメータ:
stroke - 描画される線の描画属性

LineGraphObject

public LineGraphObject(Color color,
                       Stroke stroke)
線の色と描画属性を指定して、データオブジェクトを作成します。

パラメータ:
color - 描画される線の色
stroke - 描画される線の描画属性
メソッドの詳細

addData

public void addData(double number)
値を追加します。

パラメータ:
number - 値

addData

public void addData(int number)
値を追加します。 intを与えますが、値はdoubleで扱われます。

パラメータ:
number - 値

getData

public double getData(int index)
指定された位置にある値を返します。

パラメータ:
index - 返される値のインデックス
戻り値:
double 値
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

remove

public void remove(int index)
指定された位置の値を削除します。 削除後は後続の要素を左側に移動します。

パラメータ:
index - 削除されるデータ値のインデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

size

public int size()
値の数を返します。

戻り値:
int 値の数

clear

public void clear()
すべての値を削除します。

getColor

public Color getColor()
線の色を返します。

戻り値:
color 描画される線の色

getStroke

public Stroke getStroke()
描画される線の描画属性を返します。

戻り値:
描画される線の描画属性

setColor

public void setColor(Color color)
線の色を設定します。

パラメータ:
color - 描画される線の色

setStroke

public void setStroke(Stroke stroke)
描画される線の描画属性を設定します。

パラメータ:
stroke - 描画される線の描画属性
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.graph (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.graph
クラス
BarGraphDrawer
BarGraphObject
CircleGraphDrawer
CircleGraphObject
LineGraphDrawer
LineGraphObject
PortFolioDrawer
PortFolioObject
RadarChartDrawer
RadarChartObject


jp.co.intra_mart.foundation.graph (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.graph

グラフ描画に関するクラスを提供します。

参照:
説明

クラスの概要
BarGraphDrawer | 棒グラフを描画します。
BarGraphObject | BarGraphDrawerクラスのデータを保存するオブジェクトです。
CircleGraphDrawer | 円グラフを描画します。
CircleGraphObject | CircleGraphDrawerクラスのデータを保存するオブジェクトです。
LineGraphDrawer | 折れ線グラフを描画します。
LineGraphObject | LineGraphDrawerクラスのデータを保存するオブジェクトです。
PortFolioDrawer | ポートフォリオを描画します。
PortFolioObject | PortFolioDrawerクラスのデータを保存するオブジェクトです。
RadarChartDrawer | レーダーチャートを描画します。
RadarChartObject | RadarChartDrawerクラスのデータを保存するオブジェクトです。

パッケージ jp.co.intra_mart.foundation.graph の説明

グラフ描画に関するクラスを提供します。


jp.co.intra_mart.foundation.graph クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.graph の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.drawer.AbstractDrawer (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.graph.BarGraphDrawer
      • class jp.co.intra_mart.foundation.graph.CircleGraphDrawer
      • class jp.co.intra_mart.foundation.graph.LineGraphDrawer
      • class jp.co.intra_mart.foundation.graph.PortFolioDrawer
      • class jp.co.intra_mart.foundation.graph.RadarChartDrawer
    • class jp.co.intra_mart.foundation.graph.BarGraphObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.graph.CircleGraphObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.graph.LineGraphObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.graph.PortFolioObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.graph.RadarChartObject (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.graph の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.graph の使用

jp.co.intra_mart.foundation.graph を使用しているパッケージ
jp.co.intra_mart.foundation.graph グラフ描画に関するクラスを提供します。

jp.co.intra_mart.foundation.graph により使用される jp.co.intra_mart.foundation.graph のクラス
BarGraphObject
BarGraphDrawerクラスのデータを保存するオブジェクトです。
CircleGraphObject
CircleGraphDrawerクラスのデータを保存するオブジェクトです。
LineGraphObject
LineGraphDrawerクラスのデータを保存するオブジェクトです。
PortFolioObject
PortFolioDrawerクラスのデータを保存するオブジェクトです。
RadarChartObject
RadarChartDrawerクラスのデータを保存するオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PortFolioDrawer (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス PortFolioDrawer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.drawer.AbstractDrawer
        拡張 jp.co.intra_mart.foundation.graph.PortFolioDrawer
すべての実装インタフェース:
Serializable
public class PortFolioDrawer
extends AbstractDrawer

ポートフォリオを描画します。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

フィールドの概要
static int | DEFAULT_BOTTOM_MARGIN 標準のグラフ領域の下部マージン
static Color | DEFAULT_GRAPH_BACKGROUND_COLOR 標準のグラフ領域の背景色
static Color | DEFAULT_GRAPH_BORDER_COLOR 標準のグラフ領域のボーダー色
static Color | DEFAULT_IMAGE_BACKGROUND_COLOR 標準の画像ファイル背景色
static Color | DEFAULT_IMAGE_BORDER_COLOR 標準の画像ファイルのボーダ色
static int | DEFAULT_LEFT_MARGIN 標準のグラフ領域の左側マージン
static int | DEFAULT_RIGHT_MARGIN 標準のグラフ領域の右側マージン
static int | DEFAULT_TOP_MARGIN 標準のグラフ領域の上部マージン
static String | SCALE_POSITION_CENTER ｘ軸、ｙ軸の目盛りの表示位置を「グラフの中心」に設定
static String | SCALE_POSITION_SIDE ｘ軸、ｙ軸の目盛りの表示位置を「グラフの枠」に設定
コンストラクタの概要
PortFolioDrawer(double x_center, double x_size, double x_count, double y_center, double y_size, double y_count)
ｘ軸、ｙ軸の目盛値をdouble表現でポートフォリオを作成します。
PortFolioDrawer(int x_center, int x_size, int x_count, int y_center, int y_size, int y_count)
ｘ軸、ｙ軸の目盛値をint表現でポートフォリオを作成します。
メソッドの概要
void | addData(int index, PortFolioObject obj) 指定された位置に、指定された描画オブジェクトを追加します。
void | addData(PortFolioObject obj) 描画オブジェクトに新しいデータを追加します。
void | clear() すべてのデータを削除します。
protected void | createImage(Graphics g) ポートフォリオを描画します。
Color | getCaptionColor() キャプションの文字色を返します。
double | getCenterPointX() ｘ軸の中心値を返します。
double | getCenterPointY() ｙ軸の中心値を返します。
PortFolioObject | getData(int index) リスト内の指定された位置にあるデータを返します。
double | getDataSizeX() ｘ軸の中心値からのデータサイズを返します。
double | getDataSizeY() ｙ軸の中心値からのデータサイズを返します。
Color | getGraphBackgroundColor() グラフ領域の背景色を返します。
Color | getGraphBorderColor() グラフ領域のボーダーの色を返します。
Color | getImageBackgroundColor() 画像ファイルの背景色を返します。
Color | getImageBorderColor() 画像ファイルのボーダ色を返します。
Color | getImgaeBackgroundColor() 推奨されていません。
Color | getImgaeBorderColor() 推奨されていません。
double | getScaleCountX() ｘ軸の目盛間隔を返します。
double | getScaleCountY() ｙ軸の目盛間隔を返します。
String | getScalePosition() ｘ軸、ｙ軸の目盛りの表示位置を返します。
boolean | isDouble() ｘ軸、ｙ軸の目盛値がdouble表現かどうかを判定します。
void | remove(int index) 指定された位置のデータを削除します。
void | setCaptionColor(Color color) キャプションの文字色を設定します。
void | setGraphBackgroundColor(Color color) グラフ領域の背景色を設定します。
void | setGraphBorderColor(Color color) グラフ領域のボーダーの色を設定します。
void | setImageBackgroundColor(Color color) 画像ファイルの背景色を設定します。
void | setImageBorderColor(Color color) 画像ファイルのボーダ色を設定します。
void | setImgaeBackgroundColor(Color color) 推奨されていません。
void | setImgaeBorderColor(Color color) 推奨されていません。
void | setMargin(int top, int right, int bottom, int left) グラフ領域のマージンを設定します。
void | setScalePosition(String scale_position) ｘ軸、ｙ軸の目盛りの表示位置を設定します。
int | size() データの数を返します。
クラス jp.co.intra_mart.foundation.drawer.AbstractDrawer から継承したメソッド
getContentType, getHeight, getWidth, putImage, setContentType, setHeight, setWidth
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_TOP_MARGIN

public static int DEFAULT_TOP_MARGIN
標準のグラフ領域の上部マージン

DEFAULT_RIGHT_MARGIN

public static int DEFAULT_RIGHT_MARGIN
標準のグラフ領域の右側マージン

DEFAULT_BOTTOM_MARGIN

public static int DEFAULT_BOTTOM_MARGIN
標準のグラフ領域の下部マージン

DEFAULT_LEFT_MARGIN

public static int DEFAULT_LEFT_MARGIN
標準のグラフ領域の左側マージン

DEFAULT_IMAGE_BACKGROUND_COLOR

public static Color DEFAULT_IMAGE_BACKGROUND_COLOR
標準の画像ファイル背景色

DEFAULT_IMAGE_BORDER_COLOR

public static Color DEFAULT_IMAGE_BORDER_COLOR
標準の画像ファイルのボーダ色

DEFAULT_GRAPH_BACKGROUND_COLOR

public static Color DEFAULT_GRAPH_BACKGROUND_COLOR
標準のグラフ領域の背景色

DEFAULT_GRAPH_BORDER_COLOR

public static Color DEFAULT_GRAPH_BORDER_COLOR
標準のグラフ領域のボーダー色

SCALE_POSITION_SIDE

public static String SCALE_POSITION_SIDE
ｘ軸、ｙ軸の目盛りの表示位置を「グラフの枠」に設定

SCALE_POSITION_CENTER

public static String SCALE_POSITION_CENTER
ｘ軸、ｙ軸の目盛りの表示位置を「グラフの中心」に設定

コンストラクタの詳細

PortFolioDrawer

public PortFolioDrawer(int x_center,
                       int x_size,
                       int x_count,
                       int y_center,
                       int y_size,
                       int y_count)
ｘ軸、ｙ軸の目盛値をint表現でポートフォリオを作成します。

パラメータ:
x_center - ｘ軸の中心値
x_size - ｘ軸の中心値からのデータサイズ
x_count - ｘ軸の目盛り間隔
y_center - ｙ軸の中心値
y_size - ｙ軸の中心値からのデータサイズ
y_count - ｙ軸の目盛り間隔
例外:
IllegalArgumentException - x_count <= 0 または y_count <= 0

PortFolioDrawer

public PortFolioDrawer(double x_center,
                       double x_size,
                       double x_count,
                       double y_center,
                       double y_size,
                       double y_count)
ｘ軸、ｙ軸の目盛値をdouble表現でポートフォリオを作成します。

パラメータ:
x_center - ｘ軸の中心値
x_size - ｘ軸の中心値からのデータサイズ
x_count - ｘ軸の目盛り間隔
y_center - ｙ軸の中心値
y_size - ｙ軸の中心値からのデータサイズ
y_count - ｙ軸の目盛り間隔
例外:
IllegalArgumentException - x_count <= 0 または y_count <= 0
メソッドの詳細

getCenterPointX

public double getCenterPointX()
ｘ軸の中心値を返します。

戻り値:
double ｘ軸の中心値

getDataSizeX

public double getDataSizeX()
ｘ軸の中心値からのデータサイズを返します。

戻り値:
double ｘ軸の中心値からのデータサイズ

getScaleCountX

public double getScaleCountX()
ｘ軸の目盛間隔を返します。

戻り値:
double ｘ軸の目盛り間隔

getCenterPointY

public double getCenterPointY()
ｙ軸の中心値を返します。

戻り値:
double ｙ軸の中心値

getDataSizeY

public double getDataSizeY()
ｙ軸の中心値からのデータサイズを返します。

戻り値:
double ｙ軸の中心値からのデータサイズ

getScaleCountY

public double getScaleCountY()
ｙ軸の目盛間隔を返します。

戻り値:
double ｙ軸の目盛り間隔

setScalePosition

public void setScalePosition(String scale_position)
ｘ軸、ｙ軸の目盛りの表示位置を設定します。 デフォルト値はSCALE_POSITION_CENTER（グラフの中心）になります

パラメータ:
scale_position - 目盛りの表示位置 SCALE_POSITION_CENTER：グラフの中心 SCALE_POSITION_SIDE：グラフの枠

getScalePosition

public String getScalePosition()
ｘ軸、ｙ軸の目盛りの表示位置を返します。

戻り値:
String 目盛りの表示位置 SCALE_POSITION_CENTER：グラフの中心 SCALE_POSITION_SIDE：グラフの枠

setImageBackgroundColor

public void setImageBackgroundColor(Color color)
画像ファイルの背景色を設定します。

パラメータ:
color -

setImgaeBackgroundColor

public void setImgaeBackgroundColor(Color color)
推奨されていません。

画像ファイルの背景色を設定します。

パラメータ:
color -

getImageBackgroundColor

public Color getImageBackgroundColor()
画像ファイルの背景色を返します。

戻り値:
color

getImgaeBackgroundColor

public Color getImgaeBackgroundColor()
推奨されていません。

画像ファイルの背景色を返します。

戻り値:
color

setImageBorderColor

public void setImageBorderColor(Color color)
画像ファイルのボーダ色を設定します。

パラメータ:
color -

setImgaeBorderColor

public void setImgaeBorderColor(Color color)
推奨されていません。

画像ファイルのボーダ色を設定します。

パラメータ:
color -

getImageBorderColor

public Color getImageBorderColor()
画像ファイルのボーダ色を返します。

戻り値:
color

getImgaeBorderColor

public Color getImgaeBorderColor()
推奨されていません。

画像ファイルのボーダ色を返します。

戻り値:
color

getGraphBackgroundColor

public Color getGraphBackgroundColor()
グラフ領域の背景色を返します。

戻り値:
Color グラフ領域の背景色

setGraphBackgroundColor

public void setGraphBackgroundColor(Color color)
グラフ領域の背景色を設定します。

パラメータ:
color - グラフ領域の背景色

getGraphBorderColor

public Color getGraphBorderColor()
グラフ領域のボーダーの色を返します。

戻り値:
グラフ領域のボーダーの色

setGraphBorderColor

public void setGraphBorderColor(Color color)
グラフ領域のボーダーの色を設定します。

パラメータ:
color - グラフ領域のボーダーの色

getCaptionColor

public Color getCaptionColor()
キャプションの文字色を返します。

戻り値:
キャプションの文字色

setCaptionColor

public void setCaptionColor(Color color)
キャプションの文字色を設定します。

パラメータ:
color - キャプションの文字色

addData

public void addData(PortFolioObject obj)
描画オブジェクトに新しいデータを追加します。

パラメータ:
obj - データ

addData

public void addData(int index,
                    PortFolioObject obj)
指定された位置に、指定された描画オブジェクトを追加します。 現在その位置にあるデータはindex値に１追加されます。

パラメータ:
obj - データ
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index > size())

isDouble

public boolean isDouble()
ｘ軸、ｙ軸の目盛値がdouble表現かどうかを判定します。

戻り値:
doubleで表現する場合はtrue

getData

public PortFolioObject getData(int index)
リスト内の指定された位置にあるデータを返します。

パラメータ:
index - インデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

remove

public void remove(int index)
指定された位置のデータを削除します。 削除後は後続の要素を左側に移動します。

パラメータ:
index - 削除されるデータ値のインデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

size

public int size()
データの数を返します。

戻り値:
int 値の数

clear

public void clear()
すべてのデータを削除します。

setMargin

public void setMargin(int top,
                      int right,
                      int bottom,
                      int left)
グラフ領域のマージンを設定します。

パラメータ:
top - 上部のマージン
right - 右側のマ－ジン
bottom - 下部のマージン
left - 左側のマージン

createImage

protected void createImage(Graphics g)
ポートフォリオを描画します。

定義:
クラス AbstractDrawer 内の createImage
パラメータ:
g - グラフィックコンテキスト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PortFolioObject (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス PortFolioObject

java.lang.Object
    拡張 jp.co.intra_mart.foundation.graph.PortFolioObject
すべての実装インタフェース:
Serializable
public class PortFolioObject
extends Object
implements Serializable

PortFolioDrawerクラスのデータを保存するオブジェクトです。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

コンストラクタの概要
PortFolioObject(double x_data, double y_data)
グラフのｘ値、ｙ値を指定して、データオブジェクトを作成します。
PortFolioObject(double x_data, double y_data, Color color, int size)
グラフのｘ値、ｙ値と描画する点の色とサイズを指定して、データオブジェクトを作成します。
PortFolioObject(int x_data, int y_data)
グラフのｘ値、ｙ値を指定して、データオブジェクトを作成します。
PortFolioObject(int x_data, int y_data, Color color, int size)
グラフのｘ値、ｙ値と描画する点の色とサイズを指定して、データオブジェクトを作成します。
メソッドの概要
Color | getColor() 描画する点の色を返します。
double | getDataX() グラフのｘ値を返します。
double | getDataY() グラフのｙ値を返します。
int | getSize() 描画する点のサイズを返します。
boolean | isDouble() グラフ値がdouble表現かどうかを判定します。
void | setColor(Color color) 描画する点の色を設定します。
void | setSize(int size) 描画する点のサイズを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PortFolioObject

public PortFolioObject(double x_data,
                       double y_data)
グラフのｘ値、ｙ値を指定して、データオブジェクトを作成します。 グラフ値は doubleです。

パラメータ:
x_data - グラフのｘ値
y_data - グラフのｙ値

PortFolioObject

public PortFolioObject(int x_data,
                       int y_data)
グラフのｘ値、ｙ値を指定して、データオブジェクトを作成します。 グラフ値は intで与えますが、値はdoubleで扱われます。

パラメータ:
x_data - グラフのｘ値
y_data - グラフのｙ値

PortFolioObject

public PortFolioObject(double x_data,
                       double y_data,
                       Color color,
                       int size)
グラフのｘ値、ｙ値と描画する点の色とサイズを指定して、データオブジェクトを作成します。 グラフ値は doubleです。

パラメータ:
x_data - グラフのｘ値
y_data - グラフのｙ値
color - 描画する点の色
size - 描画する点のサイズ

PortFolioObject

public PortFolioObject(int x_data,
                       int y_data,
                       Color color,
                       int size)
グラフのｘ値、ｙ値と描画する点の色とサイズを指定して、データオブジェクトを作成します。 グラフ値は intで与えますが、値はdoubleで扱われます。

パラメータ:
x_data - グラフのｘ値
y_data - グラフのｙ値
color - 描画する点の色
size - 描画する点のサイズ
メソッドの詳細

getDataX

public double getDataX()
グラフのｘ値を返します。

戻り値:
double ｘ値

getDataY

public double getDataY()
グラフのｙ値を返します。

戻り値:
double ｙ値

getColor

public Color getColor()
描画する点の色を返します。

戻り値:
color 描画する点の色

setColor

public void setColor(Color color)
描画する点の色を設定します。

パラメータ:
color - 描画する点の色

getSize

public int getSize()
描画する点のサイズを返します。

戻り値:
int 描画する点のサイズ

setSize

public void setSize(int size)
描画する点のサイズを設定します。

パラメータ:
size - 描画する点のサイズ

isDouble

public boolean isDouble()
グラフ値がdouble表現かどうかを判定します。

戻り値:
doubleで表現する場合はtrue
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RadarChartDrawer (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス RadarChartDrawer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.drawer.AbstractDrawer
        拡張 jp.co.intra_mart.foundation.graph.RadarChartDrawer
すべての実装インタフェース:
Serializable
public class RadarChartDrawer
extends AbstractDrawer

レーダーチャートを描画します。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

フィールドの概要
static int | DEFAULT_BOTTOM_MARGIN 標準のグラフ領域の下部マージン
static int | DEFAULT_CAPTION_MARGIN 標準のキャプション表示位置のマージン
static Color | DEFAULT_GRAPH_FRAME_COLOR 標準のグラフ枠の線色
static Color | DEFAULT_IMAGE_BACKGROUND_COLOR 標準の画像ファイル背景色
static Color | DEFAULT_IMAGE_BORDER_COLOR 標準の画像ファイルのボーダ色
static int | DEFAULT_LEFT_MARGIN 標準のグラフ領域の左側マージン
static int | DEFAULT_RIGHT_MARGIN 標準のグラフ領域の右側マージン
static int | DEFAULT_TOP_MARGIN 標準のグラフ領域の上部マージン
コンストラクタの概要
RadarChartDrawer(double min, double max, double count)
ｙ軸の目盛値をdouble表現でレーダーチャートを作成します。
RadarChartDrawer(int min, int max, int count)
ｙ軸の目盛値をint表現でレーダーチャートを作成します。
メソッドの概要
void | addData(int index, RadarChartObject obj) 指定された位置に、指定された描画オブジェクトを追加します。
void | addData(RadarChartObject obj) 描画オブジェクトに新しいデータを追加します。
void | clear() すべてのデータを削除します。
protected void | createImage(Graphics g) レーダーチャートを描画します。
String[] | getCaption() ｘ軸のキャプションを返します。
Color | getCaptionColor() キャプションの文字色を返します。
int | getCaptionMargin() キャプション表示位置のマージンを返します。
RadarChartObject | getData(int index) リスト内の指定された位置にあるデータを返します。
Color | getGraphFrameColor() グラフ枠の線色を返します。
Color | getImageBackgroundColor() 画像ファイルの背景色を返します。
Color | getImageBorderColor() 画像ファイルのボーダ色を返します。
Color | getImgaeBackgroundColor() 推奨されていません。
Color | getImgaeBorderColor() 推奨されていません。
double | getMax() ｙ軸の最大値を返します。
double | getMin() ｙ軸の最小値を返します。
double | getScaleCount() ｙ軸の目盛間隔を返します。
boolean | isDouble() ｙ軸の目盛値がdouble表現かどうかを判定します。
void | remove(int index) 指定された位置のデータを削除します。
void | setCaption(String[] caption) ｘ軸のキャプションを設定します。
void | setCaptionColor(Color color) キャプションの文字色を設定します。
void | setCaptionMargin(int margin) キャプション表示位置のマージンを設定します。
void | setGraphFrameColor(Color color) グラフ枠の線色を設定します。
void | setImageBackgroundColor(Color color) 画像ファイルの背景色を設定します。
void | setImageBorderColor(Color color) 画像ファイルのボーダ色を設定します。
void | setImgaeBackgroundColor(Color color) 推奨されていません。
void | setImgaeBorderColor(Color color) 推奨されていません。
void | setMargin(int top, int right, int bottom, int left) グラフ領域のマージンを設定します。
int | size() データの数を返します。
クラス jp.co.intra_mart.foundation.drawer.AbstractDrawer から継承したメソッド
getContentType, getHeight, getWidth, putImage, setContentType, setHeight, setWidth
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_TOP_MARGIN

public static int DEFAULT_TOP_MARGIN
標準のグラフ領域の上部マージン

DEFAULT_RIGHT_MARGIN

public static int DEFAULT_RIGHT_MARGIN
標準のグラフ領域の右側マージン

DEFAULT_BOTTOM_MARGIN

public static int DEFAULT_BOTTOM_MARGIN
標準のグラフ領域の下部マージン

DEFAULT_LEFT_MARGIN

public static int DEFAULT_LEFT_MARGIN
標準のグラフ領域の左側マージン

DEFAULT_CAPTION_MARGIN

public static int DEFAULT_CAPTION_MARGIN
標準のキャプション表示位置のマージン

DEFAULT_IMAGE_BACKGROUND_COLOR

public static Color DEFAULT_IMAGE_BACKGROUND_COLOR
標準の画像ファイル背景色

DEFAULT_IMAGE_BORDER_COLOR

public static Color DEFAULT_IMAGE_BORDER_COLOR
標準の画像ファイルのボーダ色

DEFAULT_GRAPH_FRAME_COLOR

public static Color DEFAULT_GRAPH_FRAME_COLOR
標準のグラフ枠の線色

コンストラクタの詳細

RadarChartDrawer

public RadarChartDrawer(int min,
                        int max,
                        int count)
ｙ軸の目盛値をint表現でレーダーチャートを作成します。

パラメータ:
min - ｙ軸の最小値
max - ｙ軸の最大値
count - ｙ軸の目盛間隔
例外:
IllegalArgumentException - max <= min または count <= 0

RadarChartDrawer

public RadarChartDrawer(double min,
                        double max,
                        double count)
ｙ軸の目盛値をdouble表現でレーダーチャートを作成します。

パラメータ:
min - ｙ軸の最小値
max - ｙ軸の最大値
count - ｙ軸の目盛間隔
例外:
IllegalArgumentException - max <= min または count <= 0
メソッドの詳細

getMax

public double getMax()
ｙ軸の最大値を返します。

戻り値:
double ｙ軸の最大値

getMin

public double getMin()
ｙ軸の最小値を返します。

戻り値:
double ｙ軸の最小値

getScaleCount

public double getScaleCount()
ｙ軸の目盛間隔を返します。

戻り値:
double ｙ軸の目盛間隔

setCaption

public void setCaption(String[] caption)
ｘ軸のキャプションを設定します。

パラメータ:
caption - キャプション

getCaption

public String[] getCaption()
ｘ軸のキャプションを返します。

戻り値:
キャプション

addData

public void addData(RadarChartObject obj)
描画オブジェクトに新しいデータを追加します。

パラメータ:
obj - データ

setImageBackgroundColor

public void setImageBackgroundColor(Color color)
画像ファイルの背景色を設定します。

パラメータ:
color -

setImgaeBackgroundColor

public void setImgaeBackgroundColor(Color color)
推奨されていません。

画像ファイルの背景色を設定します。

パラメータ:
color -

getImageBackgroundColor

public Color getImageBackgroundColor()
画像ファイルの背景色を返します。

戻り値:
color

getImgaeBackgroundColor

public Color getImgaeBackgroundColor()
推奨されていません。

画像ファイルの背景色を返します。

戻り値:
color

setImageBorderColor

public void setImageBorderColor(Color color)
画像ファイルのボーダ色を設定します。

パラメータ:
color -

setImgaeBorderColor

public void setImgaeBorderColor(Color color)
推奨されていません。

画像ファイルのボーダ色を設定します。

パラメータ:
color -

getImageBorderColor

public Color getImageBorderColor()
画像ファイルのボーダ色を返します。

戻り値:
color

getImgaeBorderColor

public Color getImgaeBorderColor()
推奨されていません。

画像ファイルのボーダ色を返します。

戻り値:
color

getGraphFrameColor

public Color getGraphFrameColor()
グラフ枠の線色を返します。

戻り値:
Color グラフ枠の線色

setGraphFrameColor

public void setGraphFrameColor(Color color)
グラフ枠の線色を設定します。

パラメータ:
color - グラフ枠の線色

getCaptionColor

public Color getCaptionColor()
キャプションの文字色を返します。

戻り値:
キャプションの文字色

setCaptionColor

public void setCaptionColor(Color color)
キャプションの文字色を設定します。

パラメータ:
color - キャプションの文字色

addData

public void addData(int index,
                    RadarChartObject obj)
指定された位置に、指定された描画オブジェクトを追加します。 現在その位置にあるデータはindex値に１追加されます。

パラメータ:
obj - データ
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index > size())

isDouble

public boolean isDouble()
ｙ軸の目盛値がdouble表現かどうかを判定します。

戻り値:
doubleで表現する場合はtrue

getData

public RadarChartObject getData(int index)
リスト内の指定された位置にあるデータを返します。

パラメータ:
index - インデックス
戻り値:
jp.co.intra_mart.foundation.graph.RadarChartObject
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

remove

public void remove(int index)
指定された位置のデータを削除します。 削除後は後続の要素を左側に移動します。

パラメータ:
index - 削除されるデータ値のインデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

size

public int size()
データの数を返します。

戻り値:
int 値の数

clear

public void clear()
すべてのデータを削除します。

setMargin

public void setMargin(int top,
                      int right,
                      int bottom,
                      int left)
グラフ領域のマージンを設定します。

パラメータ:
top - 上部のマージン
right - 右側のマ－ジン
bottom - 下部のマージン
left - 左側のマージン

setCaptionMargin

public void setCaptionMargin(int margin)
キャプション表示位置のマージンを設定します。

パラメータ:
margin - キャプション表示位置のマージン

getCaptionMargin

public int getCaptionMargin()
キャプション表示位置のマージンを返します。

戻り値:
int キャプション表示位置のマージン

createImage

protected void createImage(Graphics g)
レーダーチャートを描画します。

定義:
クラス AbstractDrawer 内の createImage
パラメータ:
g - グラフィックコンテキスト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RadarChartObject (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス RadarChartObject

java.lang.Object
    拡張 jp.co.intra_mart.foundation.graph.RadarChartObject
すべての実装インタフェース:
Serializable
public class RadarChartObject
extends Object
implements Serializable

RadarChartDrawerクラスのデータを保存するオブジェクトです。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

コンストラクタの概要
RadarChartObject()
デフォルトのデータオブジェクトを作成します。
RadarChartObject(boolean fill)
塗りつぶしの可否を指定して、データオブジェクトを作成します。
RadarChartObject(Color color)
グラフ線の色を指定して、データオブジェクトを作成します。
RadarChartObject(Color color, boolean fill)
グラフの色と塗りつぶしの可否を指定して、データオブジェクトを作成します。
メソッドの概要
void | addData(double number) 値を追加します。
void | addData(int number) 値を追加します。
void | clear() すべての値を削除します。
Color | getColor() グラフ線の色を返します。
double | getData(int index) 指定された位置にある値を返します。
boolean | getFill() 描画されるグラフの塗りつぶし可否を返します。
void | remove(int index) 指定された位置の値を削除します。
void | setColor(Color color) グラフ線の色を設定します。
void | setFill(boolean fill) 描画されるグラフの塗りつぶし可否を設定します。
int | size() 値の数を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RadarChartObject

public RadarChartObject()
デフォルトのデータオブジェクトを作成します。

RadarChartObject

public RadarChartObject(Color color)
グラフ線の色を指定して、データオブジェクトを作成します。

パラメータ:
color - 描画されるグラフの色

RadarChartObject

public RadarChartObject(boolean fill)
塗りつぶしの可否を指定して、データオブジェクトを作成します。

パラメータ:
fill - 描画されるグラフの塗りつぶし可否（true：塗りつぶす／false：塗りつぶさない）

RadarChartObject

public RadarChartObject(Color color,
                        boolean fill)
グラフの色と塗りつぶしの可否を指定して、データオブジェクトを作成します。

パラメータ:
color - 描画される線の色
fill - 描画されるグラフの塗りつぶし可否（true：塗りつぶす／false：塗りつぶさない）
メソッドの詳細

addData

public void addData(double number)
値を追加します。

パラメータ:
number - 値

addData

public void addData(int number)
値を追加します。 intを与えますが、値はdoubleで扱われます。

パラメータ:
number - 値

getData

public double getData(int index)
指定された位置にある値を返します。

パラメータ:
index - 返される値のインデックス
戻り値:
double 値
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

remove

public void remove(int index)
指定された位置の値を削除します。 削除後は後続の要素を左側に移動します。

パラメータ:
index - 削除されるデータ値のインデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

size

public int size()
値の数を返します。

戻り値:
int 値の数

clear

public void clear()
すべての値を削除します。

getColor

public Color getColor()
グラフ線の色を返します。

戻り値:
color 描画されるグラフ線の色

getFill

public boolean getFill()
描画されるグラフの塗りつぶし可否を返します。

戻り値:
描画されるグラフの塗りつぶし可否（true：塗りつぶす／false：塗りつぶさない）

setColor

public void setColor(Color color)
グラフ線の色を設定します。

パラメータ:
color - 描画されるグラフ線の色

setFill

public void setFill(boolean fill)
描画されるグラフの塗りつぶし可否を設定します。

パラメータ:
fill - 描画されるグラフの塗りつぶし可否（true：塗りつぶす／false：塗りつぶさない）
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の使用

jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ImAjaxUtil (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.http.ajax
クラス ImAjaxUtil

java.lang.Object
    拡張 jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil
public class ImAjaxUtil
extends Object

CSJSライブラリ「ImAjax」で通信を行う際に有用なサーバサイドのユーティリティクラスです。

CSJSライブラリ「ImAjax」で通信を行う際、 レスポンスヘッダにエラーコードとエラーメッセージを設定することが可能です。
レスポンスヘッダのフォーマットは以下の通りです。

ヘッダー名 | ヘッダー値
x-jp-co-intra-mart-ajax-error-code | エラーコード
x-jp-co-intra-mart-ajax-error-message | エラーコードに紐づくエラーメッセージ

エラーメッセージは、JavaScript(＝EcmaScript) のencodeURIComponent()を利用して、 自動的にエンコードされます。
（エンコード処理は、ResponseCharacterEncodingFilter 内で実行されます）

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
static String | IM_AJAX_USER_AGENT_FIREFOX 「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Firefox
static String | IM_AJAX_USER_AGENT_IE 「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Internet Explorer
static String | IM_AJAX_USER_AGENT_NETSCAPE 「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Netscape
static String | IM_AJAX_USER_AGENT_OPERA 「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Opera
static String | IM_AJAX_USER_AGENT_SAFARI 「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Safari
static String | REQUEST_HEADER_NAME_IM_AJAX_REQUEST ImAjaxからの通信だということを判定可能にするためのリクエスト・ヘッダ名。
static String | REQUEST_HEADER_NAME_IM_AJAX_USER_AGENT ブラウザの種類を判定可能にするためのリクエスト・ヘッダ名。
static String | RESPONSE_HEADER_NAME_IM_AJAX_ERROR_CODE ImAjaxへエラーコードを通知するためのレスポンス・ヘッダ名。
static String | RESPONSE_HEADER_NAME_IM_AJAX_ERROR_MESSAGE ImAjaxへエラーメッセージを通知するためのレスポンス・ヘッダ名。
コンストラクタの概要
ImAjaxUtil()
メソッドの概要
static void | setErrorResponseHeaders(HttpServletResponse response, String errorCode) レスポンスヘッダにエラーコードとエラーメッセージを設定します。
static void | setErrorResponseHeaders(HttpServletResponse response, String errorCode, String arg) レスポンスヘッダにエラーコードとエラーメッセージを設定します。
static void | setErrorResponseHeaders(HttpServletResponse response, String errorCode, String[] args) レスポンスヘッダにエラーコードとエラーメッセージを設定します。
static void | setErrorResponseHeaders(HttpServletResponse response, String errorCode, String arg1, String arg2) レスポンスヘッダにエラーコードとエラーメッセージを設定します。
static void | setErrorResponseHeaders(HttpServletResponse response, String errorCode, String arg1, String arg2, String arg3) レスポンスヘッダにエラーコードとエラーメッセージを設定します。
static void | setErrorResponseHeaders(String errorCode) レスポンスヘッダにエラーコードとエラーメッセージを設定します。
static void | setErrorResponseHeaders(String errorCode, String arg) レスポンスヘッダにエラーコードとエラーメッセージを設定します。
static void | setErrorResponseHeaders(String errorCode, String[] args) レスポンスヘッダにエラーコードとエラーメッセージを設定します。
static void | setErrorResponseHeaders(String errorCode, String arg1, String arg2) レスポンスヘッダにエラーコードとエラーメッセージを設定します。
static void | setErrorResponseHeaders(String errorCode, String arg1, String arg2, String arg3) レスポンスヘッダにエラーコードとエラーメッセージを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

REQUEST_HEADER_NAME_IM_AJAX_REQUEST

public static final String REQUEST_HEADER_NAME_IM_AJAX_REQUEST
ImAjaxからの通信だということを判定可能にするためのリクエスト・ヘッダ名。

関連項目:
定数フィールド値

REQUEST_HEADER_NAME_IM_AJAX_USER_AGENT

public static final String REQUEST_HEADER_NAME_IM_AJAX_USER_AGENT
ブラウザの種類を判定可能にするためのリクエスト・ヘッダ名。

関連項目:
定数フィールド値

IM_AJAX_USER_AGENT_IE

public static final String IM_AJAX_USER_AGENT_IE
「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Internet Explorer

関連項目:
定数フィールド値

IM_AJAX_USER_AGENT_FIREFOX

public static final String IM_AJAX_USER_AGENT_FIREFOX
「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Firefox

関連項目:
定数フィールド値

IM_AJAX_USER_AGENT_NETSCAPE

public static final String IM_AJAX_USER_AGENT_NETSCAPE
「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Netscape

関連項目:
定数フィールド値

IM_AJAX_USER_AGENT_OPERA

public static final String IM_AJAX_USER_AGENT_OPERA
「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Opera

関連項目:
定数フィールド値

IM_AJAX_USER_AGENT_SAFARI

public static final String IM_AJAX_USER_AGENT_SAFARI
「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Safari

関連項目:
定数フィールド値

RESPONSE_HEADER_NAME_IM_AJAX_ERROR_CODE

public static final String RESPONSE_HEADER_NAME_IM_AJAX_ERROR_CODE
ImAjaxへエラーコードを通知するためのレスポンス・ヘッダ名。

関連項目:
定数フィールド値

RESPONSE_HEADER_NAME_IM_AJAX_ERROR_MESSAGE

public static final String RESPONSE_HEADER_NAME_IM_AJAX_ERROR_MESSAGE
ImAjaxへエラーメッセージを通知するためのレスポンス・ヘッダ名。

関連項目:
定数フィールド値
コンストラクタの詳細

ImAjaxUtil

public ImAjaxUtil()
メソッドの詳細

setErrorResponseHeaders

public static void setErrorResponseHeaders(String errorCode)
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
現在ログインしているユーザのロケールでメッセージを設定します。
ヘッダがすでに設定されていた場合は、新しい値が以前の値を上書きします。

レスポンスヘッダのフォーマットは、こちらを参照してください。

パラメータ:
errorCode - エラーコード
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。

setErrorResponseHeaders

public static void setErrorResponseHeaders(String errorCode,
                                           String arg)
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
現在ログインしているユーザのロケールでメッセージを設定します。
ヘッダがすでに設定されていた場合は、新しい値が以前の値を上書きします。

レスポンスヘッダのフォーマットは、こちらを参照してください。

パラメータ:
errorCode - エラーコード
arg - 置換文字列

setErrorResponseHeaders

public static void setErrorResponseHeaders(String errorCode,
                                           String arg1,
                                           String arg2)
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
現在ログインしているユーザのロケールでメッセージを設定します。
ヘッダがすでに設定されていた場合は、新しい値が以前の値を上書きします。

レスポンスヘッダのフォーマットは、こちらを参照してください。

パラメータ:
errorCode - エラーコード
arg1 - 置換文字列１
arg2 - 置換文字列２

setErrorResponseHeaders

public static void setErrorResponseHeaders(String errorCode,
                                           String arg1,
                                           String arg2,
                                           String arg3)
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
現在ログインしているユーザのロケールでメッセージを設定します。
ヘッダがすでに設定されていた場合は、新しい値が以前の値を上書きします。

レスポンスヘッダのフォーマットは、こちらを参照してください。

パラメータ:
errorCode - エラーコード
arg1 - 置換文字列１
arg2 - 置換文字列２
arg3 - 置換文字列３

setErrorResponseHeaders

public static void setErrorResponseHeaders(String errorCode,
                                           String[] args)
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
現在ログインしているユーザのロケールでメッセージを設定します。
ヘッダがすでに設定されていた場合は、新しい値が以前の値を上書きします。

レスポンスヘッダのフォーマットは、こちらを参照してください。

パラメータ:
errorCode - エラーコード
args - 置換文字列の配列

setErrorResponseHeaders

public static void setErrorResponseHeaders(HttpServletResponse response,
                                           String errorCode)
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
現在ログインしているユーザのロケールでメッセージを設定します。
ヘッダがすでに設定されていた場合は、新しい値が以前の値を上書きします。

レスポンスヘッダのフォーマットは、こちらを参照してください。

パラメータ:
response - レスポンス
errorCode - エラーコード

setErrorResponseHeaders

public static void setErrorResponseHeaders(HttpServletResponse response,
                                           String errorCode,
                                           String arg)
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
現在ログインしているユーザのロケールでメッセージを設定します。
ヘッダがすでに設定されていた場合は、新しい値が以前の値を上書きします。

レスポンスヘッダのフォーマットは、こちらを参照してください。

パラメータ:
response - レスポンス
errorCode - エラーコード
arg - 置換文字列

setErrorResponseHeaders

public static void setErrorResponseHeaders(HttpServletResponse response,
                                           String errorCode,
                                           String arg1,
                                           String arg2)
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
現在ログインしているユーザのロケールでメッセージを設定します。
ヘッダがすでに設定されていた場合は、新しい値が以前の値を上書きします。

レスポンスヘッダのフォーマットは、こちらを参照してください。

パラメータ:
response - レスポンス
errorCode - エラーコード
arg1 - 置換文字列１
arg2 - 置換文字列２

setErrorResponseHeaders

public static void setErrorResponseHeaders(HttpServletResponse response,
                                           String errorCode,
                                           String arg1,
                                           String arg2,
                                           String arg3)
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
現在ログインしているユーザのロケールでメッセージを設定します。
ヘッダがすでに設定されていた場合は、新しい値が以前の値を上書きします。

レスポンスヘッダのフォーマットは、こちらを参照してください。

パラメータ:
response - レスポンス
errorCode - エラーコード
arg1 - 置換文字列１
arg2 - 置換文字列２
arg3 - 置換文字列３

setErrorResponseHeaders

public static void setErrorResponseHeaders(HttpServletResponse response,
                                           String errorCode,
                                           String[] args)
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
現在ログインしているユーザのロケールでメッセージを設定します。
ヘッダがすでに設定されていた場合は、新しい値が以前の値を上書きします。

レスポンスヘッダのフォーマットは、こちらを参照してください。

パラメータ:
response - レスポンス
errorCode - エラーコード
args - 置換文字列の配列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.http.ajax (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.http.ajax
クラス
ImAjaxUtil


jp.co.intra_mart.foundation.http.ajax (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.http.ajax

クラスの概要
ImAjaxUtil CSJSライブラリ「ImAjax」で通信を行う際に有用なサーバサイドのユーティリティクラスです。


jp.co.intra_mart.foundation.http.ajax クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.http.ajax の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil


パッケージ jp.co.intra_mart.foundation.http.ajax の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.http.ajax の使用

jp.co.intra_mart.foundation.http.ajax はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.http.CGIEnvironment の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.http.CGIEnvironment の使用

jp.co.intra_mart.foundation.http.CGIEnvironment はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.http.FileSender の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.http.FileSender の使用

jp.co.intra_mart.foundation.http.FileSender はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.http.MultipartFormData.Entity の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.http.MultipartFormData.Entity の使用

MultipartFormData.Entity を使用しているパッケージ
jp.co.intra_mart.foundation.http ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.http での MultipartFormData.Entity の使用

MultipartFormData.Entity を返す jp.co.intra_mart.foundation.http のメソッド
MultipartFormData.Entity | MultipartFormData.getEntity(int index) 推奨されていません。 指定のインデックスに該当するエンティティを取得します。
MultipartFormData.Entity | MultipartFormData.getEntity(String name) 推奨されていません。 指定の名前を持つエンティティを取得します。
MultipartFormData.Entity[] | MultipartFormData.getEntities(String name) 推奨されていません。 指定の名前を持つエンティティをすべて取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.http.MultipartFormData の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.http.MultipartFormData の使用

jp.co.intra_mart.foundation.http.MultipartFormData はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.http.SessionQuery の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.http.SessionQuery の使用

jp.co.intra_mart.foundation.http.SessionQuery はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CGIEnvironment (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.http
クラス CGIEnvironment

java.lang.Object
    拡張 java.util.AbstractMap
        拡張 java.util.HashMap
            拡張 jp.co.intra_mart.foundation.http.CGIEnvironment
すべての実装インタフェース:
Cloneable, Map, Serializable
public class CGIEnvironment
extends HashMap

このクラスは、サーブレットクラス内で CGI 環境変数を扱えるように 各パラメータを CGI 環境変数で定義されているキーワードにマップします。
ユーザー・プログラムでは、このクラスを利用する事でサーブレット環境で CGI 環境変数インターフェースを実装する事が出来ます。

関連項目:
HttpServletRequest, HashMap, 直列化された形式

コンストラクタの概要
CGIEnvironment(HttpServletRequest httpRequest)
HTTP リクエストヘッダおよび Web サーバ情報から CGI 環境変数情報を構築します。
メソッドの概要
 String getenv(String key)
値の取得。
クラス java.util.HashMap から継承したメソッド
clear, clone, containsKey, containsValue, entrySet, get, isEmpty, keySet, put, putAll, remove, size, values
クラス java.util.AbstractMap から継承したメソッド
equals, hashCode, toString
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait
インタフェース java.util.Map から継承したメソッド
equals, hashCode

コンストラクタの詳細

CGIEnvironment

public CGIEnvironment(HttpServletRequest httpRequest)
HTTP リクエストヘッダおよび Web サーバ情報から CGI 環境変数情報を構築します。

パラメータ:
httpRequest - サーブレット実行時に受け取るリクエストオブジェクト
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getenv

public String getenv(String key)
値の取得。

キーにマップされている値を返します。
引数 key には、ＣＧＩ環境変数の変数名を指定して下さい。 引数に指定されたＣＧＩ環境変数にマップされている値がない場合 null を 返します。

パラメータ:
key - 値にマップされているキー
戻り値:
キーにマップされている値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


FileSender (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.http
クラス FileSender

java.lang.Object
    拡張 jp.co.intra_mart.foundation.http.FileSender
public class FileSender
extends Object

このクラスは、HTTP レスポンスに対して指定のバイトをストリームとして 出力します。

関連項目:
HttpServletResponse

コンストラクタの概要
FileSender(HttpServletResponse httpResponse)
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSender(HttpServletResponse httpResponse, MultipurposeInternetMailExtensions mimeType)
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSender(HttpServletResponse httpResponse, MultipurposeInternetMailExtensions mimeType, String filename)
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSender(HttpServletResponse httpResponse, String filename)
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
メソッドの概要
void | write(byte b) バイトの出力。
void | write(byte[] src) バイトの出力。
void | write(byte[] src, int off, int len) バイトの出力。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FileSender

public FileSender(HttpServletResponse httpResponse)
           throws IOException
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。

このコンストラクタでは、HTTP レスポンスヘッダの Content-Type および Content-Disposition の設定を自動的に行います。 その他のヘッダへの設定は httpResponse に対して 直接設定をしてください。
HTTP レスポンスヘッダの Content-Type には、MIME タイプとして application/octet-stream を指定します。
HTTP レスポンスヘッダの Content-Disposition は、以下のように定義します。
Content-Disposition: attachment

例外:
IOException - 入出力エラー

FileSender

public FileSender(HttpServletResponse httpResponse,
                  MultipurposeInternetMailExtensions mimeType)
           throws IOException
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。

このコンストラクタでは、HTTP レスポンスヘッダの Content-Type および Content-Disposition の設定を自動的に行います。 その他のヘッダへの設定は httpResponse に対して 直接設定をしてください。
HTTP レスポンスヘッダの Content-Type には、MIME タイプとして 引数 mimeType の表す MIME タイプを設定します。

パラメータ:
mimeType - MIME タイプ
例外:
IOException - 入出力エラー

FileSender

public FileSender(HttpServletResponse httpResponse,
                  String filename)
           throws IOException
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。

このコンストラクタでは、HTTP レスポンスヘッダの Content-Type および Content-Disposition の設定を自動的に行います。 その他のヘッダへの設定は httpResponse に対して 直接設定をしてください。
HTTP レスポンスヘッダの Content-Type には、MIME タイプとして 指定のファイル名にマップされている MIME を表す文字列か、または、 指定のファイル名にマップされている MIME タイプを解決できなかった 場合には application/octet-stream を指定します。
HTTP レスポンスヘッダの Content-Disposition は、以下のように定義します。
Content-Disposition: attachment; filename=ファイル名
“ファイル名”の部分には、引数 filename が設定されます。

パラメータ:
filename - ファイル名
例外:
IOException - 入出力エラー

FileSender

public FileSender(HttpServletResponse httpResponse,
                  MultipurposeInternetMailExtensions mimeType,
                  String filename)
           throws IOException
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。

このコンストラクタでは、HTTP レスポンスヘッダの Content-Type および Content-Disposition の設定を自動的に行います。 その他のヘッダへの設定は httpResponse に対して 直接設定をしてください。
HTTP レスポンスヘッダの Content-Type には、MIME タイプとして 引数 mimeType の表す MIME タイプを設定します。
HTTP レスポンスヘッダの Content-Disposition は、以下のように定義します。
Content-Disposition: attachment; filename=ファイル名
“ファイル名”の部分には、引数 filename が設定されます。

パラメータ:
mimeType - MIME タイプ
filename - ファイル名
例外:
IOException - 入出力エラー
メソッドの詳細

write

public void write(byte b)
           throws IOException
バイトの出力。

指定のバイトを HTTP レスポンスの出力ストリームに書き出します。

パラメータ:
b - ストリームに書き出すバイト
例外:
IOException - 入出力エラー

write

public void write(byte[] src)
           throws IOException
バイトの出力。

指定のバイトを HTTP レスポンスの出力ストリームに書き出します。

パラメータ:
src - ストリームに書き出すバイト列
例外:
IOException - 入出力エラー

write

public void write(byte[] src,
                  int off,
                  int len)
           throws IOException
バイトの出力。

オフセット off から始まる指定のバイト配列から HTTP レスポンスの 出力ストリームに len バイトを書き込みます。

パラメータ:
src - ストリームに書き出すバイト列
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MultipartFormData.Entity (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.http
インタフェース MultipartFormData.Entity

含まれているインタフェース:
MultipartFormData
推奨されていません。 jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity インタフェースを使用してください。

public static interface MultipartFormData.Entity

フォームデータのエンティティです。

フォームから送信された情報を解析した結果の各エンティティは、 ヘッダ情報とデータで構成されます。

メソッドの概要
boolean | containsHeader(String name) 推奨されていません。 指定された文字列がヘッダの名称かどうかを判定します。
byte[] | getBytes() 推奨されていません。 データ部をバイト配列として取得します。
String | getContent() 推奨されていません。 データ部を文字列表現として取得します。
String | getContent(String enc) 推奨されていません。 データ部を指定された文字コードで変換した結果を文字列表現として 取得します。
int | getContentLength() 推奨されていません。 データ部のバイト長を取得します。
String | getFileName() 推奨されていません。 アップロードされたファイルのファイル名を取得します。
String | getHeader(String name) 推奨されていません。 ヘッダの取得。
String[] | getHeaderNames() 推奨されていません。 ヘッダ名称一覧の取得。
InputStream | getInputStream() 推奨されていません。 データ部を入力ストリームとして取得します。
String | getName() 推奨されていません。 フォームのコントロール名称の取得。
Reader | getReader() 推奨されていません。 getReader(String) に置き換えられました。
Reader | getReader(String encoding) 推奨されていません。 データ部を Reader として取得します。

メソッドの詳細

getName

public String getName()
推奨されていません。
フォームのコントロール名称の取得。

フォームから送信された情報のうち、このエンティティが表す情報の もととなったフォーム中に定義されたコントロールの名称を返します。

戻り値:
コントロール名称

getFileName

public String getFileName()
推奨されていません。
アップロードされたファイルのファイル名を取得します。

ファイルアップロードをしたリクエストではない場合は、null を返します。
Content-Disposition: form-data; name="ctrl_name"; filename="file_path"
ヘッダは、上記のような形式で受け取れる
ctrl_name: <INPUT type="file"> の name 属性
file_path: クライアントでのファイル名
ヘッダ情報は他にもあるが、上記の行のみを対象に解析を行う

戻り値:
String ファイル名

getHeaderNames

public String[] getHeaderNames()
推奨されていません。
ヘッダ名称一覧の取得。

このエンティティのもつヘッダ情報の名称一覧を返します。

戻り値:
ヘッダ名称の取得

getHeader

public String getHeader(String name)
推奨されていません。
ヘッダの取得。

返却値は、文字エンコーディングの変換が行われていない状態の文字列を返却します。 具体的には、javax.servlet.ServletRequest#getInputStream()を利用して リクエストの内容をバイト配列で取得し、それを「ISO-8859-1」で文字列化した内容が返却されます。

別のエンコーディングに変換する場合、以下のようなコードで変換する必要があります。

 byte[] rawData = entity.getHeader(headerName).getBytes("ISO-8859-1");
 String encodedValue = new String(rawData, request.getCharacterEncoding());

パラメータ:
name - ヘッダ名称
戻り値:
ヘッダ名称にマップされている値

containsHeader

public boolean containsHeader(String name)
推奨されていません。
指定された文字列がヘッダの名称かどうかを判定します。

パラメータ:
name - ヘッダ名称
戻り値:
ヘッダ名称が値にマップされている場合 true

getContentLength

public int getContentLength()
推奨されていません。
データ部のバイト長を取得します。

戻り値:
データのサイズ

getContent

public String getContent()
推奨されていません。
データ部を文字列表現として取得します。

入力されたバイトデータから文字列への変換には、Application Runtimeが稼動しているJavaVMの デフォルト文字エンコーディングを使います。

戻り値:
データ

getContent

public String getContent(String enc)
                  throws UnsupportedEncodingException
推奨されていません。
データ部を指定された文字コードで変換した結果を文字列表現として 取得します。

指定のエンコード名がサポートされていない場合 UnsupportedEncodingException がスローされます。

パラメータ:
enc - エンコード名
戻り値:
データ
例外:
UnsupportedEncodingException
関連項目:
UnsupportedEncodingException

getBytes

public byte[] getBytes()
推奨されていません。
データ部をバイト配列として取得します。

戻り値:
データ

getReader

public Reader getReader()
推奨されていません。 getReader(String) に置き換えられました。

データ部を Reader として取得します。

Application Runtimeが稼動しているJavaVMのデフォルト文字エンコーディングを使うReaderを返します。

戻り値:
データ

getReader

public Reader getReader(String encoding)
推奨されていません。
データ部を Reader として取得します。

戻り値:
データ
導入されたバージョン:
6.1.12

getInputStream

public InputStream getInputStream()
推奨されていません。
データ部を入力ストリームとして取得します。

戻り値:
データ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MultipartFormData (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.http
クラス MultipartFormData

java.lang.Object
    拡張 java.util.AbstractCollection
        拡張 java.util.AbstractList
            拡張 java.util.ArrayList
                拡張 jp.co.intra_mart.foundation.http.MultipartFormData
すべての実装インタフェース:
Cloneable, Collection, List, RandomAccess, Serializable
推奨されていません。 jp.co.intra_mart.common.aid.javaee.http.MultipartFormData クラスを使用してください。

public class MultipartFormData
extends ArrayList

フォームから enctype が multipart/form-data で送信されてきた情報を 解析するオブジェクトです。

このオブジェクトは、ブラウザから multipart/form-data 形式でリクエストされた データを解析し、boundary で区切られた各情報(エンティティ)をとしてリストに 保管します。

このクラスを利用する事により、ブラウザからサーバに対するファイルの アップロードなどが簡単に実装する事ができます。

留意点

intra-mart6.1.11から、アップロードされたファイルが指定した閾値を超えた場合、 メモリ上ではなく一時ファイルに書き出し、OutOfMemoryErrorの発生を抑えることが できるようになりました。内部では Apache Commons FileUpload を利用しています。

一時ファイルは、ガベージコレクタがMultiPartFormData.Entityを解放するタイミングで 削除されます。従いまして、MultiPartFormData.Entityが解放される前にintra-martが 停止すると一時ファイルは削除されません。

一時ファイルの格納先は、デフォルトではJavaのテンポラリフォルダ(java.io.tmpdir)です。 ファイル名は upload_ランダムな文字列.tmp です。

なお、アップロードされたファイルを常にメモリ上で扱う実装と一時ファイルに書き出す実装の切り替え、 一時ファイルの格納先、一時ファイルに書き出すかどうかの閾値を設定ファイルで指定することができます。 設定ファイルは、 %ApplicationRuntime%/doc/imart/WEB-INF/classes/jp/co/intra_mart/common/aid/javaee/http/MultipartFormData.properties です。

設定ファイルの内容はMultipartFormDataResourceBundleを参照してください。

関連項目:
直列化された形式

入れ子クラスの概要
static interface MultipartFormData.Entity
推奨されていません。 jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity インタフェースを使用してください。
フィールドの概要
クラス java.util.AbstractList から継承したフィールド
modCount
コンストラクタの概要
MultipartFormData(ServletRequest req)
推奨されていません。 リクエストされた情報を解析して、新しいオブジェクトを構築します。
メソッドの概要
void | add(int index, Object element) 推奨されていません。 リストの指定された位置に、指定された要素を挿入します。
boolean | add(Object o) 推奨されていません。 リストの最後に、指定された要素を追加します。
boolean | addAll(Collection c) 推奨されていません。 リストの末尾に、指定された Collection のすべての要素を追加します。
boolean | addAll(int index, Collection c) 推奨されていません。 リスト内の指定された位置から、指定された Collection のすべての要素を挿入します。
void | clear() 推奨されていません。 リストからすべての要素を削除します。
boolean | contains(Object elem) 推奨されていません。 リストに指定の要素がある場合に true を返します。
boolean | containsAll(Collection c) 推奨されていません。 このコレクション内に、指定されたコレクションのすべての要素がある場合に true を返します。
void | ensureCapacity(int minCapacity) 推奨されていません。 必要に応じて、この ArrayList のインスタンスのサイズを拡大し、少なくとも最小サイズ引数で指定された数の要素を格納できるようにします。
boolean | equals(Object o) 推奨されていません。 指定されたオブジェクトとリストが等しいかどうかを比較します。
Object | get(int index) 推奨されていません。 リスト内の指定された位置にある要素を返します。
MultipartFormData.Entity[] | getEntities(String name) 推奨されていません。 指定の名前を持つエンティティをすべて取得します。
MultipartFormData.Entity | getEntity(int index) 推奨されていません。 指定のインデックスに該当するエンティティを取得します。
MultipartFormData.Entity | getEntity(String name) 推奨されていません。 指定の名前を持つエンティティを取得します。
int | hashCode() 推奨されていません。 このリストのハッシュコード値を返します。
int | indexOf(Object elem) 推奨されていません。 equals メソッドを使って等しいかどうかを判定しながら、指定された引数と同じ内容の要素を先頭から検索します。
boolean | isEmpty() 推奨されていません。 リストに要素がないかどうかを判定します。
Iterator | iterator() 推奨されていません。 このリスト内の要素を適切な順序で繰り返し処理する反復子を返します。
int | lastIndexOf(Object elem) 推奨されていません。 指定されたオブジェクトがリスト内で最後に現れるインデックスを返します。
ListIterator | listIterator() 推奨されていません。 このリスト内の要素を適切な順序で繰り返し処理する反復子を返します。
ListIterator | listIterator(int index) 推奨されていません。 リスト内の要素を適切な順序で繰り返し処理する、リスト内の指定された位置から開始する反復子を返します。
Object | remove(int index) 推奨されていません。 リスト内の指定された位置から要素を削除します。
boolean | remove(Object o) 推奨されていません。 指定された要素のインスタンスがこのコレクションにあれば、そのインスタンスをコレクションから 1 つ削除します。
boolean | removeAll(Collection c) 推奨されていません。 このコレクションから、指定されたコレクションに含まれる要素をすべて削除します。
boolean | retainAll(Collection c) 推奨されていません。 このコレクションにおいて、指定されたコレクションに格納されている要素だけを保持します。
Object | set(int index, Object element) 推奨されていません。 リストの指定された位置にある要素を、指定された要素で置き換えます。
int | size() 推奨されていません。 リスト内にある要素の数を返します。
List | subList(int fromIndex, int toIndex) 推奨されていません。 このリストの、fromIndex (これを含む) から toIndex (これを含まない) の範囲の部分のビューを返します。
Object[] | toArray() 推奨されていません。 リスト内のすべての要素が正しい順序で格納されている配列を返します。
Object[] | toArray(Object[] a) 推奨されていません。 リスト内のすべての要素が正しい順序で格納されている配列を返します。
void | trimToSize() 推奨されていません。 この ArrayList のインスタンスのサイズをリストの現在のサイズに縮小します。
クラス java.util.ArrayList から継承したメソッド
clone, removeRange
クラス java.util.AbstractCollection から継承したメソッド
toString
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MultipartFormData

public MultipartFormData(ServletRequest req)
                  throws IOException,
                         IllegalArgumentException
推奨されていません。
リクエストされた情報を解析して、新しいオブジェクトを構築します。
multipart/form-data 形式のリクエストを解析します。

req が multipart/form-data で受信したリクエストではない場合、 IllegalArgumentException をスローします。

パラメータ:
req - サーブレットエンジンから渡されるリクエスト情報オブジェクト
例外:
IOException - リクエストデータ解析時の入出力エラー
IllegalArgumentException - 引数が不正の場合
メソッドの詳細

getEntity

public MultipartFormData.Entity getEntity(int index)
推奨されていません。
指定のインデックスに該当するエンティティを取得します。

インデックスが範囲外の場合(インデックスが負または size() よりも大きい) IndexOutOfBoundsException をスローします。

パラメータ:
index - 返すエンティティのインデックス
戻り値:
リスト内の指定された位置にあるエンティティ

getEntity

public MultipartFormData.Entity getEntity(String name)
推奨されていません。
指定の名前を持つエンティティを取得します。

エンティティの名前とは、フォームのコントロール名称のことです。 指定の名前を持つエンティティが複数存在する場合、その中のいずれか一つが 返されます。 該当するエンティティが存在しない場合 null を返します。

戻り値:
指定の名前を持つエンティティ
関連項目:
MultipartFormData.Entity.getName()

getEntities

public MultipartFormData.Entity[] getEntities(String name)
推奨されていません。
指定の名前を持つエンティティをすべて取得します。

エンティティの名前とは、フォームのコントロール名称のことです。 該当するエンティティが存在しない場合、空の配列を返します。

戻り値:
指定の名前を持つエンティティ
関連項目:
MultipartFormData.Entity.getName()

add

public void add(int index,
                Object element)
推奨されていません。
リストの指定された位置に、指定された要素を挿入します。

add

public boolean add(Object o)
推奨されていません。
リストの最後に、指定された要素を追加します。

addAll

public boolean addAll(Collection c)
推奨されていません。
リストの末尾に、指定された Collection のすべての要素を追加します。

addAll

public boolean addAll(int index,
                      Collection c)
推奨されていません。
リスト内の指定された位置から、指定された Collection のすべての要素を挿入します。

clear

public void clear()
推奨されていません。
リストからすべての要素を削除します。

contains

public boolean contains(Object elem)
推奨されていません。
リストに指定の要素がある場合に true を返します。

containsAll

public boolean containsAll(Collection c)
推奨されていません。
このコレクション内に、指定されたコレクションのすべての要素がある場合に true を返します。

ensureCapacity

public void ensureCapacity(int minCapacity)
推奨されていません。
必要に応じて、この ArrayList のインスタンスのサイズを拡大し、少なくとも最小サイズ引数で指定された数の要素を格納できるようにします。

equals

public boolean equals(Object o)
推奨されていません。
指定されたオブジェクトとリストが等しいかどうかを比較します。

get

public Object get(int index)
推奨されていません。
リスト内の指定された位置にある要素を返します。

hashCode

public int hashCode()
推奨されていません。
このリストのハッシュコード値を返します。

indexOf

public int indexOf(Object elem)
推奨されていません。
equals メソッドを使って等しいかどうかを判定しながら、指定された引数と同じ内容の要素を先頭から検索します。

isEmpty

public boolean isEmpty()
推奨されていません。
リストに要素がないかどうかを判定します。

iterator

public Iterator iterator()
推奨されていません。
このリスト内の要素を適切な順序で繰り返し処理する反復子を返します。

lastIndexOf

public int lastIndexOf(Object elem)
推奨されていません。
指定されたオブジェクトがリスト内で最後に現れるインデックスを返します。

listIterator

public ListIterator listIterator()
推奨されていません。
このリスト内の要素を適切な順序で繰り返し処理する反復子を返します。

listIterator

public ListIterator listIterator(int index)
推奨されていません。
リスト内の要素を適切な順序で繰り返し処理する、リスト内の指定された位置から開始する反復子を返します。

remove

public Object remove(int index)
推奨されていません。
リスト内の指定された位置から要素を削除します。

remove

public boolean remove(Object o)
推奨されていません。
指定された要素のインスタンスがこのコレクションにあれば、そのインスタンスをコレクションから 1 つ削除します。

removeAll

public boolean removeAll(Collection c)
推奨されていません。
このコレクションから、指定されたコレクションに含まれる要素をすべて削除します。

retainAll

public boolean retainAll(Collection c)
推奨されていません。
このコレクションにおいて、指定されたコレクションに格納されている要素だけを保持します。

set

public Object set(int index,
                  Object element)
推奨されていません。
リストの指定された位置にある要素を、指定された要素で置き換えます。

size

public int size()
推奨されていません。
リスト内にある要素の数を返します。

subList

public List subList(int fromIndex,
                    int toIndex)
推奨されていません。
このリストの、fromIndex (これを含む) から toIndex (これを含まない) の範囲の部分のビューを返します。

toArray

public Object[] toArray()
推奨されていません。
リスト内のすべての要素が正しい順序で格納されている配列を返します。

toArray

public Object[] toArray(Object[] a)
推奨されていません。
リスト内のすべての要素が正しい順序で格納されている配列を返します。

trimToSize

public void trimToSize()
推奨されていません。
この ArrayList のインスタンスのサイズをリストの現在のサイズに縮小します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.http (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.http
インタフェース
MultipartFormData.Entity
クラス
CGIEnvironment
FileSender
MultipartFormData
SessionQuery


jp.co.intra_mart.foundation.http (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.http

ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

参照:
説明

インタフェースの概要
MultipartFormData.Entity 推奨されていません。 jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity インタフェースを使用してください。

クラスの概要
CGIEnvironment | このクラスは、サーブレットクラス内で CGI 環境変数を扱えるように 各パラメータを CGI 環境変数で定義されているキーワードにマップします。
FileSender | このクラスは、HTTP レスポンスに対して指定のバイトをストリームとして 出力します。
MultipartFormData | 推奨されていません。 jp.co.intra_mart.common.aid.javaee.http.MultipartFormData クラスを使用してください。
SessionQuery | 推奨されていません。 GenericURLBuilder および URLBuilder に置き替えられました。

パッケージ jp.co.intra_mart.foundation.http の説明

ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。


jp.co.intra_mart.foundation.http クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.http の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.util.AbstractCollection (implements java.util.Collection)
      • class java.util.AbstractList (implements java.util.List)
        • class java.util.ArrayList (implements java.lang.Cloneable, java.util.List, java.util.RandomAccess, java.io.Serializable)
          • class jp.co.intra_mart.foundation.http.MultipartFormData
    • class java.util.AbstractMap (implements java.util.Map)
      • class java.util.HashMap (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class jp.co.intra_mart.foundation.http.CGIEnvironment
    • class jp.co.intra_mart.foundation.http.FileSender
    • class jp.co.intra_mart.foundation.http.SessionQuery

インタフェース階層

  • interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity


パッケージ jp.co.intra_mart.foundation.http の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.http の使用

jp.co.intra_mart.foundation.http を使用しているパッケージ
jp.co.intra_mart.foundation.http ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.http により使用される jp.co.intra_mart.foundation.http のクラス
MultipartFormData.Entity
推奨されていません。 jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity インタフェースを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SessionQuery (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.http
クラス SessionQuery

java.lang.Object
    拡張 jp.co.intra_mart.foundation.http.SessionQuery
推奨されていません。 GenericURLBuilder および URLBuilder に置き替えられました。

public class SessionQuery
extends Object

このクラスは、intra-mart のセッションを維持したまま プレゼンテーション・ページ＆ファンクション・コンテナを HTTP を利用して 呼び出すためのセッション引数を提供します。
このクラスを利用することにより、ＪＳＰおよびサーブレットにより作成された ページからスクリプト開発モデルのページに対してリンクすることができます。

なお、ＪＳＰおよびサーブレット間でのセッション維持には利用できません。

関連項目:
GenericURLBuilder, URLBuilder

コンストラクタの概要
SessionQuery(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 GenericURLBuilder および URLBuilder に置き替えられました。
メソッドの概要
 String addURL(String url)
推奨されていません。 GenericURLBuilder.createFilePath(String) および URLBuilder.createURLonSession(String)に置き替えられました。
protected  String getQuery()
推奨されていません。 代替えメソッドはありません。
 String getQueryName()
推奨されていません。 代替えメソッドはありません。
 String getQueryValue()
推奨されていません。 GenericURLBuilder.createFilePath(String) に置き替えられました。
 String setTo(String path)
推奨されていません。 代替えメソッドはありません。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SessionQuery

public SessionQuery(HttpServletRequest request,
                    HttpServletResponse response)
推奨されていません。 GenericURLBuilder および URLBuilder に置き替えられました。

セッションを維持するためのリクエスト引数を作成するインスタンスを 構築します。

指定のセッションＩＤにより遷移先のページで セッションを共有することができます。

例外:
NullPointerException - 引数が null
メソッドの詳細

setTo

public String setTo(String path)
推奨されていません。 代替えメソッドはありません。

遷移先ページの指定。

遷移先のプレゼンテーション・ページのパスを指定します。
パスは、InformationServer からの相対形式で拡張子(.html)を 省略したものを指定して下さい。

sample/tutorial/beginner/index.html へ遷移する場合、 sample/tutorial/beginner/index という文字列を引数 path に指定します。

パラメータ:
path - ファイル名
戻り値:
このメソッドで設定済みだった値
例外:
NullPointerException - 引数が null

getQueryName

public String getQueryName()
推奨されていません。 代替えメソッドはありません。

クエリー引数名称の取得。

クエリー引数の名称を返します。
このメソッドの値を <INPUT> の name 属性値として指定する事で、 セッションを維持したまま intra-mart のプレゼンテーション・ページへ 遷移するフォームを作成する事が出来ます。

戻り値:
クエリー引数名称

getQueryValue

public String getQueryValue()
推奨されていません。 GenericURLBuilder.createFilePath(String) に置き替えられました。

クエリー引数値の取得。

クエリー引数の値を返します。
このメソッドの値を <INPUT> の value 属性値として指定する事で、 セッションを維持したまま intra-mart のプレゼンテーション・ページへ 遷移するフォームを作成する事が出来ます。

戻り値:
クエリー引数値

getQuery

protected String getQuery()
推奨されていません。 代替えメソッドはありません。

クエリー引数の取得。

クエリー引数を返します。

戻り値:
クエリー引数

addURL

public String addURL(String url)
推奨されていません。 GenericURLBuilder.createFilePath(String) および URLBuilder.createURLonSession(String)に置き替えられました。

ＵＲＬへのクエリーの追加。

セッションを維持したまま intra-mart へアクセスするＵＲＬを返します。

パラメータ:
url - intra-mart にアクセスするためのＵＲＬ
戻り値:
セッション維持の為のクエリー引数を付加したＵＲＬ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.image.DuplicateImageIconCodeException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.image.DuplicateImageIconCodeException の使用

DuplicateImageIconCodeException を使用しているパッケージ
jp.co.intra_mart.foundation.image

jp.co.intra_mart.foundation.image での DuplicateImageIconCodeException の使用

DuplicateImageIconCodeException をスローする jp.co.intra_mart.foundation.image のメソッド
void | ImageIconManager.addGroupImageIcon(ImageIconInfo imageIconInfo) グループのイメージアイコン情報を新規登録します。
void | ImageIconManager.addUserImageIcon(ImageIconInfo imageIconInfo, String userCd) ユーザのイメージアイコン情報を新規登録します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.image.DuplicateImageIconSrcException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.image.DuplicateImageIconSrcException の使用

DuplicateImageIconSrcException を使用しているパッケージ
jp.co.intra_mart.foundation.image

jp.co.intra_mart.foundation.image での DuplicateImageIconSrcException の使用

DuplicateImageIconSrcException をスローする jp.co.intra_mart.foundation.image のメソッド
void | ImageIconManager.addGroupImageIcon(ImageIconInfo imageIconInfo) グループのイメージアイコン情報を新規登録します。
void | ImageIconManager.addUserImageIcon(ImageIconInfo imageIconInfo, String userCd) ユーザのイメージアイコン情報を新規登録します。
void | ImageIconManager.updateGroupImageIcon(ImageIconInfo imageIconInfo) グループのイメージアイコン情報を更新します。
void | ImageIconManager.updateUserImageIcon(ImageIconInfo imageIconInfo, String userCd) ユーザのイメージアイコン情報を更新します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.image.ImageIconException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.image.ImageIconException の使用

ImageIconException を使用しているパッケージ
jp.co.intra_mart.foundation.image

jp.co.intra_mart.foundation.image での ImageIconException の使用

jp.co.intra_mart.foundation.image での ImageIconException のサブクラス
class | DuplicateImageIconCodeException 登録時重複例外クラス。
class | DuplicateImageIconSrcException 作成/更新時URLの重複例外クラス。
class | NotExistImageIconException イメージアイコンが存在しなかった場合の例外クラス。

ImageIconException をスローする jp.co.intra_mart.foundation.image のメソッド
ImageIconInfo[] | ImageIconManager.getGroupImageIcons() すべてのグループイメージアイコンを取得します。
ImageIconInfo[] | ImageIconManager.getUserImageIcons(String userCd) すべてのユーザイメージアイコンを取得します。
ImageIconInfo | ImageIconManager.getImageIcon(String imageIconCd) イメージアイコン情報を取得します。
void | ImageIconManager.addGroupImageIcon(ImageIconInfo imageIconInfo) グループのイメージアイコン情報を新規登録します。
void | ImageIconManager.addUserImageIcon(ImageIconInfo imageIconInfo, String userCd) ユーザのイメージアイコン情報を新規登録します。
boolean | ImageIconManager.existImageIcon(String imageIconCd) イメージアイコンの存在チェックをします。
boolean | ImageIconManager.existGroupImageIconBySrc(String src) URLをもつグループイメージアイコンの存在チェックをします。
boolean | ImageIconManager.existUserImageIconBySrc(String userCd, String src) URLをもつユーザイメージアイコンの存在チェックをします。
void | ImageIconManager.deleteGroupImageIcons() グループのイメージアイコン情報をすべて削除します。
void | ImageIconManager.deleteUserImageIcons(String userCd) ユーザのイメージアイコン情報をすべて削除します。
void | ImageIconManager.deleteImageIcon(String imageIconCd) イメージアイコン情報を削除します。
boolean | ImageIconManager.existGroupImageIcons() グループイメージアイコンの存在チェックをします。
boolean | ImageIconManager.existUserImageIcons(String userCd) ユーザイメージアイコンの存在チェックをします。
void | ImageIconManager.updateGroupImageIcon(ImageIconInfo imageIconInfo) グループのイメージアイコン情報を更新します。
void | ImageIconManager.updateUserImageIcon(ImageIconInfo imageIconInfo, String userCd) ユーザのイメージアイコン情報を更新します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.image.ImageIconInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.image.ImageIconInfo の使用

ImageIconInfo を使用しているパッケージ
jp.co.intra_mart.foundation.image

jp.co.intra_mart.foundation.image での ImageIconInfo の使用

ImageIconInfo を返す jp.co.intra_mart.foundation.image のメソッド
ImageIconInfo[] | ImageIconManager.getGroupImageIcons() すべてのグループイメージアイコンを取得します。
ImageIconInfo[] | ImageIconManager.getUserImageIcons(String userCd) すべてのユーザイメージアイコンを取得します。
ImageIconInfo | ImageIconManager.getImageIcon(String imageIconCd) イメージアイコン情報を取得します。

ImageIconInfo 型のパラメータを持つ jp.co.intra_mart.foundation.image のメソッド
void | ImageIconManager.addGroupImageIcon(ImageIconInfo imageIconInfo) グループのイメージアイコン情報を新規登録します。
void | ImageIconManager.addUserImageIcon(ImageIconInfo imageIconInfo, String userCd) ユーザのイメージアイコン情報を新規登録します。
void | ImageIconManager.updateGroupImageIcon(ImageIconInfo imageIconInfo) グループのイメージアイコン情報を更新します。
void | ImageIconManager.updateUserImageIcon(ImageIconInfo imageIconInfo, String userCd) ユーザのイメージアイコン情報を更新します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.image.ImageIconManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.image.ImageIconManager の使用

jp.co.intra_mart.foundation.image.ImageIconManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.image.ImageIconMessageBundle の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.image.ImageIconMessageBundle の使用

jp.co.intra_mart.foundation.image.ImageIconMessageBundle はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.image.NotExistImageIconException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.image.NotExistImageIconException の使用

NotExistImageIconException を使用しているパッケージ
jp.co.intra_mart.foundation.image

jp.co.intra_mart.foundation.image での NotExistImageIconException の使用

NotExistImageIconException をスローする jp.co.intra_mart.foundation.image のメソッド
ImageIconInfo[] | ImageIconManager.getGroupImageIcons() すべてのグループイメージアイコンを取得します。
ImageIconInfo[] | ImageIconManager.getUserImageIcons(String userCd) すべてのユーザイメージアイコンを取得します。
void | ImageIconManager.deleteGroupImageIcons() グループのイメージアイコン情報をすべて削除します。
void | ImageIconManager.deleteUserImageIcons(String userCd) ユーザのイメージアイコン情報をすべて削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DuplicateImageIconCodeException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.image
クラス DuplicateImageIconCodeException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.image.ImageIconException
                    拡張 jp.co.intra_mart.foundation.image.DuplicateImageIconCodeException
すべての実装インタフェース:
Serializable
public class DuplicateImageIconCodeException
extends ImageIconException

登録時重複例外クラス。

イメージアイコンを新規登録時に、 イメージイメージアイコンコードが重複している場合にスローされます。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DuplicateImageIconCodeException()
コンストラクタ。
DuplicateImageIconCodeException(String imageIconCd, String loginType)
コンストラクタ。
DuplicateImageIconCodeException(String imageIconCd, String loginType, Throwable cause)
コンストラクタ。
DuplicateImageIconCodeException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DuplicateImageIconCodeException

public DuplicateImageIconCodeException()
コンストラクタ。

DuplicateImageIconCodeException

public DuplicateImageIconCodeException(String imageIconCd,
                                       String loginType)
コンストラクタ。

パラメータ:
imageIconCd - イメージアイコンコード
loginType - ログインタイプ

DuplicateImageIconCodeException

public DuplicateImageIconCodeException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

DuplicateImageIconCodeException

public DuplicateImageIconCodeException(String imageIconCd,
                                       String loginType,
                                       Throwable cause)
コンストラクタ。

パラメータ:
imageIconCd - イメージアイコンコード
loginType - ログインタイプ
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DuplicateImageIconSrcException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.image
クラス DuplicateImageIconSrcException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.image.ImageIconException
                    拡張 jp.co.intra_mart.foundation.image.DuplicateImageIconSrcException
すべての実装インタフェース:
Serializable
public class DuplicateImageIconSrcException
extends ImageIconException

作成/更新時URLの重複例外クラス。

イメージアイコンを新規作成または更新時に、 イメージアイコンのURLが重複している場合にスローされます。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DuplicateImageIconSrcException()
コンストラクタ。
DuplicateImageIconSrcException(String loginType, String src)
コンストラクタ。
DuplicateImageIconSrcException(String src, String loginType, Throwable cause)
コンストラクタ。
DuplicateImageIconSrcException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DuplicateImageIconSrcException

public DuplicateImageIconSrcException()
コンストラクタ。

DuplicateImageIconSrcException

public DuplicateImageIconSrcException(String loginType,
                                      String src)
コンストラクタ。

パラメータ:
loginType - ログインタイプ
src - イメージアイコンURL

DuplicateImageIconSrcException

public DuplicateImageIconSrcException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

DuplicateImageIconSrcException

public DuplicateImageIconSrcException(String src,
                                      String loginType,
                                      Throwable cause)
コンストラクタ。

パラメータ:
src - イメージアイコンURL
loginType - ログインタイプ
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ImageIconException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.image
クラス ImageIconException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.image.ImageIconException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
DuplicateImageIconCodeException, DuplicateImageIconSrcException, NotExistImageIconException
public class ImageIconException
extends FoundationException

イメージアイコンの例外クラス。

イメージアイコン内で例外が発生した場合にスローされます。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ImageIconException()
コンストラクタ。
ImageIconException(String message)
コンストラクタ。
ImageIconException(String message, Throwable cause)
コンストラクタ。
ImageIconException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ImageIconException

public ImageIconException()
コンストラクタ。

ImageIconException

public ImageIconException(String message)
コンストラクタ。

パラメータ:
message - メッセージ

ImageIconException

public ImageIconException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

ImageIconException

public ImageIconException(String message,
                          Throwable cause)
コンストラクタ。

パラメータ:
message - メッセージ
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ImageIconInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.image
クラス ImageIconInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.image.ImageIconInfo
public class ImageIconInfo
extends Object

イメージアイコン情報クラス。
イメージアイコンのイメージアイコンコード、URL、ソートキーを持ちます。

導入されたバージョン:
6.0
バージョン:
1.0

フィールドの概要
static int DEFAULT_SORT_KEY
デフォルトソートキー
コンストラクタの概要
ImageIconInfo(String src)
コンストラクタ。
ImageIconInfo(String src, int sortKey)
コンストラクタ。
ImageIconInfo(String imageIconCd, String src, int sortKey)
コンストラクタ。
メソッドの概要
String | getImageIconCd() イメージアイコンコードを取得する。
int | getSortKey() ソートキーを取得する。
String | getSrc() イメージアイコンURLを取得する。
void | setImageIconCd(String iconCd) イメージアイコンコードを設定する。
void | setSortKey(int sortKey) ソートキーを設定する。
void | setSrc(String src) イメージアイコンURLを設定する。
String | toString() この ImageIconInfo の値を表す String オブジェクトを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

フィールドの詳細

DEFAULT_SORT_KEY

public static final int DEFAULT_SORT_KEY
デフォルトソートキー

関連項目:
定数フィールド値
コンストラクタの詳細

ImageIconInfo

public ImageIconInfo(String src)
コンストラクタ。

引数にイメージアイコンのURL(src)を指定します。
イメージアイコンコードは自動的に生成されます。
ソートキーはデフォルト値(DEFAULT_SORT_KEY)が設定されます。

パラメータ:
src - イメージアイコンのURL

ImageIconInfo

public ImageIconInfo(String src,
                     int sortKey)
コンストラクタ。

引数にイメージアイコンのURL、ソートキーを指定します。
イメージアイコンコードは自動的に生成されます。

パラメータ:
src - イメージアイコンのURL
sortKey - ソートキー

ImageIconInfo

public ImageIconInfo(String imageIconCd,
                     String src,
                     int sortKey)
コンストラクタ。

引数にイメージアイコンコード、イメージアイコンのURL、ソートキーを指定します。

パラメータ:
imageIconCd - イメージアイコンコード
src - イメージアイコンのURL
sortKey - ソートキー
メソッドの詳細

getImageIconCd

public String getImageIconCd()
イメージアイコンコードを取得する。

ログイングループで一意に識別されるイメージアイコンコードを返却します。

戻り値:
イメージアイコンコード

setImageIconCd

public void setImageIconCd(String iconCd)
イメージアイコンコードを設定する。

ログイングループで一意に識別されるイメージアイコンコードを設定します。

パラメータ:
iconCd - イメージアイコンコード

getSortKey

public int getSortKey()
ソートキーを取得する。

イメージアイコンの並び順を表したソートキーを返却します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定する。

イメージアイコンの並び順を表したソートキーを設定します。

パラメータ:
sortKey - ソートキー

getSrc

public String getSrc()
イメージアイコンURLを取得する。

コンテキストルートからのパスとなるイメージアイコンのURLを取得します。

戻り値:
イメージアイコンURL

setSrc

public void setSrc(String src)
イメージアイコンURLを設定する。

コンテキストルートからのパスとなるイメージアイコンのURLを設定します。

パラメータ:
src - イメージアイコンURL

toString

public String toString()
この ImageIconInfo の値を表す String オブジェクトを返します。

この ImageIconInfo の値を表す String オブジェクトを返します。 形式は以下のようになります。
imageIconCd: imageIconCd, src: src, sortKey: sortKey

戻り値:
この ImageIconInfo の値を表す String オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ImageIconManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.image
クラス ImageIconManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.image.ImageIconManager
public class ImageIconManager
extends Object

アイコンマネージャクラス。
イメージアイコン情報の操作を行います。

導入されたバージョン:
6.0
バージョン:
1.0

コンストラクタの概要
ImageIconManager(String groupId)
メソッドの概要
void | addGroupImageIcon(ImageIconInfo imageIconInfo) グループのイメージアイコン情報を新規登録します。
void | addUserImageIcon(ImageIconInfo imageIconInfo, String userCd) ユーザのイメージアイコン情報を新規登録します。
void | deleteGroupImageIcons() グループのイメージアイコン情報をすべて削除します。
void | deleteImageIcon(String imageIconCd) イメージアイコン情報を削除します。
void | deleteUserImageIcons(String userCd) ユーザのイメージアイコン情報をすべて削除します。
boolean | existGroupImageIconBySrc(String src) URLをもつグループイメージアイコンの存在チェックをします。
boolean | existGroupImageIcons() グループイメージアイコンの存在チェックをします。
boolean | existImageIcon(String imageIconCd) イメージアイコンの存在チェックをします。
boolean | existUserImageIconBySrc(String userCd, String src) URLをもつユーザイメージアイコンの存在チェックをします。
boolean | existUserImageIcons(String userCd) ユーザイメージアイコンの存在チェックをします。
ImageIconInfo[] | getGroupImageIcons() すべてのグループイメージアイコンを取得します。
ImageIconInfo | getImageIcon(String imageIconCd) イメージアイコン情報を取得します。
ImageIconInfo[] | getUserImageIcons(String userCd) すべてのユーザイメージアイコンを取得します。
boolean | isDuplicateSrc() イメージアイコンのURLの重複チェックの有効/無効を取得します。
void | setDuplicateSrc(boolean duplicateSrc) イメージアイコンのURLの重複チェックの有効/無効を設定します。
void | updateGroupImageIcon(ImageIconInfo imageIconInfo) グループのイメージアイコン情報を更新します。
void | updateUserImageIcon(ImageIconInfo imageIconInfo, String userCd) ユーザのイメージアイコン情報を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ImageIconManager

public ImageIconManager(String groupId)
パラメータ:
groupId - グループID
メソッドの詳細

isDuplicateSrc

public boolean isDuplicateSrc()
イメージアイコンのURLの重複チェックの有効/無効を取得します。

  • true: 登録/更新時にイメージアイコンのURLがすでに登録済かどうかのチェックを行います。
  • false: 登録/更新時にイメージアイコンのURLがすでに登録済かどうかのチェックを行いません。
  • デフォルト: 無効(false)

      • 戻り値:
      イメージアイコンのURLの重複チェックの有効/無効

setDuplicateSrc

public void setDuplicateSrc(boolean duplicateSrc)
イメージアイコンのURLの重複チェックの有効/無効を設定します。

  • true: 登録/更新時にイメージアイコンのURLがすでに登録済かどうかのチェックを行います。
  • false: 登録/更新時にイメージアイコンのURLがすでに登録済かどうかのチェックを行いません。
  • デフォルト: 無効(false)

      • パラメータ:
      duplicateSrc - イメージアイコンのURLの重複チェックの有効/無効

getGroupImageIcons

public ImageIconInfo[] getGroupImageIcons()
                                   throws NotExistImageIconException,
                                          ImageIconException
すべてのグループイメージアイコンを取得します。

配列要素の順番はソートキーの昇順となります。

戻り値:
すべてのグループイメージアイコン情報
例外:
NotExistImageIconException - グループイメージアイコンが存在しない場合にスローされます。 ImageIconException イメージアイコン情報の取得に失敗した場合にスローされます。
ImageIconException

getUserImageIcons

public ImageIconInfo[] getUserImageIcons(String userCd)
                                  throws NotExistImageIconException,
                                         ImageIconException
すべてのユーザイメージアイコンを取得します。

配列要素の順番はソートキーの昇順となります。

戻り値:
すべてのユーザイメージアイコン情報
例外:
NotExistImageIconException - ユーザイメージアイコンが存在しない場合にスローされます。 ImageIconException イメージアイコン情報の取得に失敗した場合にスローされます。
ImageIconException

getImageIcon

public ImageIconInfo getImageIcon(String imageIconCd)
                           throws ImageIconException
イメージアイコン情報を取得します。

引数のイメージアイコンコードからイメージアイコンを取得します。

パラメータ:
imageIconCd - イメージアイコンコード
戻り値:
イメージアイコン情報またはnull
例外:
NotExistImageIconException - 引数のイメージアイコンが存在しない場合にスローされます。 ImageIconException イメージアイコン情報の取得に失敗した場合にスローされます。
ImageIconException

addGroupImageIcon

public void addGroupImageIcon(ImageIconInfo imageIconInfo)
                       throws DuplicateImageIconCodeException,
                              DuplicateImageIconSrcException,
                              ImageIconException
グループのイメージアイコン情報を新規登録します。

イメージアイコンURLの重複チェックが有効の場合、グループイメージアイコンにおいて重複していた場合にスローされます。

パラメータ:
imageIconInfo - イメージアイコン情報
例外:
DuplicateImageIconCodeException - イメージアイコンコードが重複している場合にスローされます。
DuplicateImageIconSrcException イメージアイコンURLの重複チェックが有効の場合、グループイメージアイコンにおいて重複していた場合にスローされます。
ImageIconException イメージアイコンの登録に失敗した場合にスローされます。
DuplicateImageIconSrcException
ImageIconException

addUserImageIcon

public void addUserImageIcon(ImageIconInfo imageIconInfo,
                             String userCd)
                      throws DuplicateImageIconCodeException,
                             DuplicateImageIconSrcException,
                             ImageIconException
ユーザのイメージアイコン情報を新規登録します。

イメージアイコンURLの重複チェックが有効の場合、ユーザイメージアイコンにおいて重複していた場合にスローされます。

パラメータ:
imageIconInfo - イメージアイコン情報
例外:
DuplicateImageIconCodeException - イメージアイコンコードが重複している場合にスローされます。
DuplicateImageIconSrcException イメージアイコンURLの重複チェックが有効の場合、引数のユーザのユーザイメージアイコンにおいて重複していた場合にスローされます。
ImageIconException イメージアイコンの登録に失敗した場合にスローされます。
DuplicateImageIconSrcException
ImageIconException

existImageIcon

public boolean existImageIcon(String imageIconCd)
                       throws ImageIconException
イメージアイコンの存在チェックをします。

  • true: イメージアイコンが存在している
  • false: イメージアイコンが存在していない

パラメータ:
imageIconCd - イメージアイコンコード
戻り値:
イメージアイコンが存在している(true)/存在していない(false)
例外:
ImageIconException - イメージアイコンの存在チェックに失敗した場合にスローされます。

existGroupImageIconBySrc

public boolean existGroupImageIconBySrc(String src)
                                 throws ImageIconException
URLをもつグループイメージアイコンの存在チェックをします。

引数のイメージアイコンURLからなるグループイメージアイコンの存在チェックをします。
  • true: イメージアイコンが存在している
  • false: イメージアイコンが存在していない

パラメータ:
src - イメージアイコンURL
戻り値:
グループイメージアイコンが存在している(true)/存在していない(false)かを返却します。
例外:
ImageIconException - イメージアイコンの存在チェックに失敗した場合にスローされます。

existUserImageIconBySrc

public boolean existUserImageIconBySrc(String userCd,
                                       String src)
                                throws ImageIconException
URLをもつユーザイメージアイコンの存在チェックをします。

引数のイメージアイコンURLからなるユーザイメージアイコンの存在チェックをします。
  • true: イメージアイコンが存在している
  • false: イメージアイコンが存在していない

パラメータ:
userCd - ユーザコード
src - イメージアイコンURL
戻り値:
ユーザイメージアイコンが存在している(true)/存在していない(false)かを返却します。
例外:
ImageIconException - イメージアイコンの存在チェックに失敗した場合にスローされます。

deleteGroupImageIcons

public void deleteGroupImageIcons()
                           throws NotExistImageIconException,
                                  ImageIconException
グループのイメージアイコン情報をすべて削除します。

例外:
NotExistImageIconException - 削除前にグループのイメージアイコン情報が存在しない場合にスローされます。
ImageIconException イメージアイコンの削除に失敗した場合にスローされます。
ImageIconException

deleteUserImageIcons

public void deleteUserImageIcons(String userCd)
                          throws NotExistImageIconException,
                                 ImageIconException
ユーザのイメージアイコン情報をすべて削除します。

パラメータ:
userCd - ユーザコード
例外:
NotExistImageIconException - 削除前にユーザのイメージアイコン情報が存在しない場合にスローされます。
ImageIconException イメージアイコンの削除に失敗した場合にスローされます。
ImageIconException

deleteImageIcon

public void deleteImageIcon(String imageIconCd)
                     throws ImageIconException
イメージアイコン情報を削除します。
引数で指定したイメージアイコン情報を削除します。

パラメータ:
imageIconCd - イメージアイコンコード
例外:
NotExistImageIconException - 削除前にイメージアイコン情報が存在しない場合にスローされます。
ImageIconException イメージアイコンの削除に失敗した場合にスローされます。
ImageIconException

existGroupImageIcons

public boolean existGroupImageIcons()
                             throws ImageIconException
グループイメージアイコンの存在チェックをします。

  • true: グループイメージアイコンが存在している
  • false: グループイメージアイコンが存在していない

戻り値:
グループイメージアイコンが存在している(true)/存在していない(false)かを返却します。
例外:
ImageIconException - グループイメージアイコンの存在チェックに失敗した場合にスローされます。

existUserImageIcons

public boolean existUserImageIcons(String userCd)
                            throws ImageIconException
ユーザイメージアイコンの存在チェックをします。

  • true: ユーザイメージアイコンが存在している
  • false: ユーザイメージアイコンが存在していない

パラメータ:
userCd - ユーザコード
戻り値:
ユーザイメージアイコンが存在している(true)/存在していない(false)かを返却します。
例外:
ImageIconException - ユーザイメージアイコンの存在チェックに失敗した場合にスローされます。

updateGroupImageIcon

public void updateGroupImageIcon(ImageIconInfo imageIconInfo)
                          throws DuplicateImageIconSrcException,
                                 ImageIconException
グループのイメージアイコン情報を更新します。
イメージアイコンURLの重複チェックが有効の場合、グループイメージアイコンにおいて重複していた場合にスローされます。

パラメータ:
imageIconInfo - イメージアイコン情報
例外:
DuplicateImageIconSrcException - イメージアイコンURLの重複チェックが有効の場合、グループイメージアイコンにおいて重複していた場合にスローされます。
ImageIconException イメージアイコンの更新に失敗した場合にスローされます。
ImageIconException

updateUserImageIcon

public void updateUserImageIcon(ImageIconInfo imageIconInfo,
                                String userCd)
                         throws DuplicateImageIconSrcException,
                                ImageIconException
ユーザのイメージアイコン情報を更新します。
イメージアイコンURLの重複チェックが有効の場合、ユーザイメージアイコンにおいて重複していた場合にスローされます。

パラメータ:
imageIconInfo - イメージアイコン情報
例外:
DuplicateImageIconSrcException - イメージアイコンURLの重複チェックが有効の場合、引数のユーザのユーザイメージアイコンにおいて重複していた場合にスローされます。
ImageIconException イメージアイコンの更新に失敗した場合にスローされます。
ImageIconException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ImageIconMessageBundle (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.image
クラス ImageIconMessageBundle

java.lang.Object
    拡張 jp.co.intra_mart.foundation.image.ImageIconMessageBundle
public class ImageIconMessageBundle
extends Object

コンストラクタの概要
ImageIconMessageBundle()
メソッドの概要
static String | getMessage(Locale locale, String key) イメージアイコンメッセージを取得します。
static String | getMessage(Locale locale, String key, String arg) 置換文字列を挿入したイメージアイコンメッセージを取得します。
static String | getMessage(Locale locale, String key, String[] args) 置換文字列を挿入したイメージアイコンメッセージを取得します。
static String | getMessage(Locale locale, String key, String arg1, String arg2) 置換文字列を挿入したイメージアイコンメッセージを取得します。
static String | getMessage(Locale locale, String key, String arg1, String arg2, String arg3) 置換文字列を挿入したイメージアイコンメッセージを取得します。
static String | getMessage(String key) イメージアイコンメッセージを取得します。
static String | getMessage(String key, String arg) 置換文字列を挿入したイメージアイコンメッセージを取得します。
static String | getMessage(String key, String[] args) 置換文字列を挿入したイメージアイコンメッセージを取得します。
static String | getMessage(String key, String arg1, String arg2) 置換文字列を挿入したイメージアイコンメッセージを取得します。
static String | getMessage(String key, String arg1, String arg2, String arg3) 置換文字列を挿入したイメージアイコンメッセージを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ImageIconMessageBundle

public ImageIconMessageBundle()
メソッドの詳細

getMessage

public static String getMessage(Locale locale,
                                String key)
イメージアイコンメッセージを取得します。

パラメータ:
locale - ロケール
key - メッセージID
戻り値:
イメージアイコンメッセージ

getMessage

public static String getMessage(Locale locale,
                                String key,
                                String arg)
置換文字列を挿入したイメージアイコンメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
locale - ロケール
key - メッセージID
arg - 置換文字列
戻り値:
置換文字列を挿入したイメージアイコンメッセージ

getMessage

public static String getMessage(Locale locale,
                                String key,
                                String arg1,
                                String arg2)
置換文字列を挿入したイメージアイコンメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
locale - ロケール
key - メッセージID
戻り値:
置換文字列を挿入したイメージアイコンメッセージ

getMessage

public static String getMessage(Locale locale,
                                String key,
                                String arg1,
                                String arg2,
                                String arg3)
置換文字列を挿入したイメージアイコンメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
locale - ロケール
key - メッセージID
戻り値:
置換文字列を挿入したイメージアイコンメッセージ

getMessage

public static String getMessage(Locale locale,
                                String key,
                                String[] args)
置換文字列を挿入したイメージアイコンメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
locale - ロケール
key - メッセージID
args - 置換文字列の配列
戻り値:
置換文字列を挿入したイメージアイコンメッセージ

getMessage

public static String getMessage(String key)
イメージアイコンメッセージを取得します。

パラメータ:
key - メッセージID
戻り値:
イメージアイコンメッセージ

getMessage

public static String getMessage(String key,
                                String arg)
置換文字列を挿入したイメージアイコンメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
key - メッセージID
arg - 置換文字列
戻り値:
置換文字列を挿入したイメージアイコンメッセージ

getMessage

public static String getMessage(String key,
                                String arg1,
                                String arg2)
置換文字列を挿入したイメージアイコンメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
key - メッセージID
戻り値:
置換文字列を挿入したイメージアイコンメッセージ

getMessage

public static String getMessage(String key,
                                String arg1,
                                String arg2,
                                String arg3)
置換文字列を挿入したイメージアイコンメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
key - メッセージID
戻り値:
置換文字列を挿入したイメージアイコンメッセージ

getMessage

public static String getMessage(String key,
                                String[] args)
置換文字列を挿入したイメージアイコンメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
key - メッセージID
args - 置換文字列の配列
戻り値:
置換文字列を挿入したイメージアイコンメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


NotExistImageIconException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.image
クラス NotExistImageIconException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.image.ImageIconException
                    拡張 jp.co.intra_mart.foundation.image.NotExistImageIconException
すべての実装インタフェース:
Serializable
public class NotExistImageIconException
extends ImageIconException

イメージアイコンが存在しなかった場合の例外クラス。

イメージアイコンがデータベースに存在しなかった場合にスローします。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
NotExistImageIconException()
コンストラクタ。
NotExistImageIconException(String imageIconCd, String loginType)
コンストラクタ。
NotExistImageIconException(String imageIconCd, String loginType, Throwable cause)
コンストラクタ。
NotExistImageIconException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NotExistImageIconException

public NotExistImageIconException()
コンストラクタ。

NotExistImageIconException

public NotExistImageIconException(String imageIconCd,
                                  String loginType)
コンストラクタ。

パラメータ:
imageIconCd - イメージアイコンコード
loginType - ログインタイプ

NotExistImageIconException

public NotExistImageIconException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

NotExistImageIconException

public NotExistImageIconException(String imageIconCd,
                                  String loginType,
                                  Throwable cause)
コンストラクタ。

パラメータ:
imageIconCd - イメージアイコンコード
loginType - ログインタイプ
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.image (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.image
クラス
ImageIconInfo
ImageIconManager
ImageIconMessageBundle
例外
DuplicateImageIconCodeException
DuplicateImageIconSrcException
ImageIconException
NotExistImageIconException


jp.co.intra_mart.foundation.image (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.image

クラスの概要
ImageIconInfo | イメージアイコン情報クラス。
ImageIconManager | アイコンマネージャクラス。
ImageIconMessageBundle |

例外の概要
DuplicateImageIconCodeException | 登録時重複例外クラス。
DuplicateImageIconSrcException | 作成/更新時URLの重複例外クラス。
ImageIconException | イメージアイコンの例外クラス。
NotExistImageIconException | イメージアイコンが存在しなかった場合の例外クラス。


jp.co.intra_mart.foundation.image クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.image の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.image.ImageIconInfo
    • class jp.co.intra_mart.foundation.image.ImageIconManager
    • class jp.co.intra_mart.foundation.image.ImageIconMessageBundle
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.exception.FoundationException
          • class jp.co.intra_mart.foundation.image.ImageIconException
            • class jp.co.intra_mart.foundation.image.DuplicateImageIconCodeException
            • class jp.co.intra_mart.foundation.image.DuplicateImageIconSrcException
            • class jp.co.intra_mart.foundation.image.NotExistImageIconException


パッケージ jp.co.intra_mart.foundation.image の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.image の使用

jp.co.intra_mart.foundation.image を使用しているパッケージ
jp.co.intra_mart.foundation.image

jp.co.intra_mart.foundation.image により使用される jp.co.intra_mart.foundation.image のクラス
DuplicateImageIconCodeException
登録時重複例外クラス。
DuplicateImageIconSrcException
作成/更新時URLの重複例外クラス。
ImageIconException
イメージアイコンの例外クラス。
ImageIconInfo
イメージアイコン情報クラス。
NotExistImageIconException
イメージアイコンが存在しなかった場合の例外クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.log.LogConstraint の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.log.LogConstraint の使用

jp.co.intra_mart.foundation.log.LogConstraint はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


LogConstraint (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.log
インタフェース LogConstraint

public interface LogConstraint

ログ定数インタフェース。ログで使用する定数値を定義したインターフェース。

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
static String RESPONSE_HEADER_NAME_NEXT_PAGE_TITLE
遷移先画面タイトルをレスポンスヘッダに登録するためのレスポンスヘッダ名。

フィールドの詳細

RESPONSE_HEADER_NAME_NEXT_PAGE_TITLE

public static final String RESPONSE_HEADER_NAME_NEXT_PAGE_TITLE
遷移先画面タイトルをレスポンスヘッダに登録するためのレスポンスヘッダ名。

関連項目:
定数フィールド値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.log (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.log
インタフェース
LogConstraint


jp.co.intra_mart.foundation.log (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.log

インタフェースの概要
LogConstraint ログ定数インタフェース。


jp.co.intra_mart.foundation.log クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.log の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.log.LogConstraint


パッケージ jp.co.intra_mart.foundation.log の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.log の使用

jp.co.intra_mart.foundation.log はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.mail.MailSender の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.mail.MailSender の使用

MailSender を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail メール送信クラスを提供します。

jp.co.intra_mart.foundation.mail.javamail での MailSender の使用

MailSender を実装している jp.co.intra_mart.foundation.mail.javamail のクラス
 class JavaMailSender
JavaMailをラップしたメール送信オブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.MailSenderException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.MailSenderException の使用

MailSenderException を使用しているパッケージ
jp.co.intra_mart.foundation.mail | メール送信に関するクラスを提供します。
jp.co.intra_mart.foundation.mail.javamail | メール送信クラスを提供します。
jp.co.intra_mart.foundation.mail.javamail.listener |
jp.co.intra_mart.foundation.mail.javamail.listener.impl |

jp.co.intra_mart.foundation.mail での MailSenderException の使用

MailSenderException をスローする jp.co.intra_mart.foundation.mail のメソッド
 void MailSender.send()
メールを送信します。

jp.co.intra_mart.foundation.mail.javamail での MailSenderException の使用

MailSenderException をスローする jp.co.intra_mart.foundation.mail.javamail のメソッド
protected void | StandardMail.init() StandardMailオブジェクトを初期化します。
protected Properties | StandardMail.getProperties() JavaMailのSMTPセッションに渡す属性を初期化します。
protected Session | StandardMail.createSession(Properties prop) SMTPセッションを構築します。
protected void | StandardMail.prepareSession(Session session) SMTPセッションに対して操作を行います。
protected void | StandardMail.prepareMimeMessage(MimeMessage message) MIMEメッセージに対して操作を行います。
void | JavaMailSender.send() メールを送信します。

jp.co.intra_mart.foundation.mail.javamail.listener での MailSenderException の使用

MailSenderException をスローする jp.co.intra_mart.foundation.mail.javamail.listener のメソッド
 int MailSendListener.onSendMail(MailSendEvent event)
メール送信が行われたことを通知します。

jp.co.intra_mart.foundation.mail.javamail.listener.impl での MailSenderException の使用

MailSenderException をスローする jp.co.intra_mart.foundation.mail.javamail.listener.impl のメソッド
 int HalfKanaTransrateListener.onSendMail(MailSendEvent event)
メール送信が行われたことを通知します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.javamail.JavaMailSender の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.javamail.JavaMailSender の使用

jp.co.intra_mart.foundation.mail.javamail.JavaMailSender はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.javamail.StandardMail の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.javamail.StandardMail の使用

StandardMail を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail | メール送信クラスを提供します。
jp.co.intra_mart.foundation.mail.javamail.listener |

jp.co.intra_mart.foundation.mail.javamail での StandardMail の使用

StandardMail 型のパラメータを持つ jp.co.intra_mart.foundation.mail.javamail のコンストラクタ
JavaMailSender(StandardMail mail)
JavaMailSenderを新規に作成します。

jp.co.intra_mart.foundation.mail.javamail.listener での StandardMail の使用

StandardMail を返す jp.co.intra_mart.foundation.mail.javamail.listener のメソッド
 StandardMail MailSendEvent.getMail()
メールの属性を取得します。

StandardMail 型のパラメータを持つ jp.co.intra_mart.foundation.mail.javamail.listener のメソッド
 void MailSendEvent.setMail(StandardMail mail)
メールの属性を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent の使用

MailSendEvent を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail.listener
jp.co.intra_mart.foundation.mail.javamail.listener.impl

jp.co.intra_mart.foundation.mail.javamail.listener での MailSendEvent の使用

MailSendEvent 型のパラメータを持つ jp.co.intra_mart.foundation.mail.javamail.listener のメソッド
 int MailSendListener.onSendMail(MailSendEvent event)
メール送信が行われたことを通知します。

jp.co.intra_mart.foundation.mail.javamail.listener.impl での MailSendEvent の使用

MailSendEvent 型のパラメータを持つ jp.co.intra_mart.foundation.mail.javamail.listener.impl のメソッド
 int HalfKanaTransrateListener.onSendMail(MailSendEvent event)
メール送信が行われたことを通知します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener の使用

MailSendListener を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail.listener.impl

jp.co.intra_mart.foundation.mail.javamail.listener.impl での MailSendListener の使用

MailSendListener を実装している jp.co.intra_mart.foundation.mail.javamail.listener.impl のクラス
 class HalfKanaTransrateListener
送信メールの件名と本文に含まれる半角カナ文字を、全角カナ文字に変換するリスナです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


MailSendEvent (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.listener
クラス MailSendEvent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent
public class MailSendEvent
extends Object

メール送信イベントです。

導入されたバージョン:
6.1.8

コンストラクタの概要
MailSendEvent()
SendMailEventを新規に生成します。
メソッドの概要
StandardMail | getMail() メールの属性を取得します。
Session | getSession() メール送信のセッションを取得します。
void | setMail(StandardMail mail) メールの属性を設定します。
void | setSession(Session session) メール送信のセッションを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MailSendEvent

public MailSendEvent()
SendMailEventを新規に生成します。

メソッドの詳細

getMail

public StandardMail getMail()
メールの属性を取得します。

戻り値:
メールの属性

setMail

public void setMail(StandardMail mail)
メールの属性を設定します。

パラメータ:
mail - メールの属性

getSession

public Session getSession()
メール送信のセッションを取得します。

戻り値:
セッション

setSession

public void setSession(Session session)
メール送信のセッションを設定します。

パラメータ:
session - セッション
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MailSendListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.listener
インタフェース MailSendListener

既知の実装クラスの一覧:
HalfKanaTransrateListener
public interface MailSendListener

メール送信イベントのListenerインタフェースです。

リスナを利用するには、MailSendListenerの実装クラスを作成し、 onSendMail(MailSendEvent)メソッドを実装してください。 そのクラス名をServerManager上の /conf/mail/mailSendListener.xmlに記述してください。以下はその記述例です。

 <listener-config>
   <listener>
     <listener-class>foo.TestListener1</listener-class>
   </listener>
   <listener>
     <listener-class>foo.TestListener2</listener-class>
   </listener>
 </listener-config>

リスナはメール送信時に、記述されている順に実行されます。 また、リスナのスキップや送信の中止も可能です。 通常onSendMail(MailSendEvent)メソッドの戻り値はCONTINUEです。 リスナ実行中に以降のリスナをスキップする場合はSKIP_LISTENERを返却してください。 メール送信を行わない場合はSTOP_MAILSENDを返却してください。

導入されたバージョン:
6.1.8

フィールドの概要
static int | CONTINUE リスナー処理を続行し、メール送信を行います。
static int | SKIP_LISTENER リスナー処理を中止し、メール送信を行います。
static int | STOP_MAILSEND リスナー処理を中止し、メール送信を中止します。
メソッドの概要
 int onSendMail(MailSendEvent event)
メール送信が行われたことを通知します。

フィールドの詳細

CONTINUE

public static final int CONTINUE
リスナー処理を続行し、メール送信を行います。

関連項目:
定数フィールド値

SKIP_LISTENER

public static final int SKIP_LISTENER
リスナー処理を中止し、メール送信を行います。

関連項目:
定数フィールド値

STOP_MAILSEND

public static final int STOP_MAILSEND
リスナー処理を中止し、メール送信を中止します。

関連項目:
定数フィールド値
メソッドの詳細

onSendMail

public int onSendMail(MailSendEvent event)
               throws MailSenderException
メール送信が行われたことを通知します。
メール送信イベントを受け取り、次のリスナーに処理を移します。

パラメータ:
event - メール送信イベント
例外:
MailSenderException - リスナーで例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.mail.javamail.listener (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.mail.javamail.listener
インタフェース
MailSendListener
クラス
MailSendEvent


jp.co.intra_mart.foundation.mail.javamail.listener (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.listener

インタフェースの概要
MailSendListener メール送信イベントのListenerインタフェースです。

クラスの概要
MailSendEvent メール送信イベントです。


jp.co.intra_mart.foundation.mail.javamail.listener クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.listener の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent

インタフェース階層

  • interface jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener


パッケージ jp.co.intra_mart.foundation.mail.javamail.listener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.mail.javamail.listener の使用

jp.co.intra_mart.foundation.mail.javamail.listener を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail.listener
jp.co.intra_mart.foundation.mail.javamail.listener.impl

jp.co.intra_mart.foundation.mail.javamail.listener により使用される jp.co.intra_mart.foundation.mail.javamail.listener のクラス
MailSendEvent
メール送信イベントです。

jp.co.intra_mart.foundation.mail.javamail.listener.impl により使用される jp.co.intra_mart.foundation.mail.javamail.listener のクラス
MailSendEvent
メール送信イベントです。
MailSendListener
メール送信イベントのListenerインタフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.mail.javamail.model.AttachmentFile の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.mail.javamail.model.AttachmentFile の使用

jp.co.intra_mart.foundation.mail.javamail.model.AttachmentFile はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.mail.javamail.model.MailAddress の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.mail.javamail.model.MailAddress の使用

MailAddress を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail メール送信クラスを提供します。

jp.co.intra_mart.foundation.mail.javamail での MailAddress の使用

MailAddress を返す jp.co.intra_mart.foundation.mail.javamail のメソッド
 MailAddress StandardMail.getFrom()
Fromを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AttachmentFile (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.model
インタフェース AttachmentFile

public interface AttachmentFile

添付ファイルのモデルです。

導入されたバージョン:
6.1.8

メソッドの概要
String | getFile() 添付ファイルを取得します。
String | getName() 添付ファイルのファイル名を取得します。

メソッドの詳細

getName

public String getName()
添付ファイルのファイル名を取得します。

戻り値:
ファイル名

getFile

public String getFile()
添付ファイルを取得します。

戻り値:
添付ファイル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MailAddress (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.model
インタフェース MailAddress

public interface MailAddress

メールアドレスのモデルです。

導入されたバージョン:
6.1.8

メソッドの概要
String | getAddress() メールアドレスを取得します。
String | getPersonal() 名前を取得します。

メソッドの詳細

getPersonal

public String getPersonal()
名前を取得します。

戻り値:
名前

getAddress

public String getAddress()
メールアドレスを取得します。

戻り値:
メールアドレス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.mail.javamail.model (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.mail.javamail.model
インタフェース
AttachmentFile
MailAddress


jp.co.intra_mart.foundation.mail.javamail.model (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.model

インタフェースの概要
AttachmentFile | 添付ファイルのモデルです。
MailAddress | メールアドレスのモデルです。


jp.co.intra_mart.foundation.mail.javamail.model クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.model の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.mail.javamail.model.AttachmentFile
  • interface jp.co.intra_mart.foundation.mail.javamail.model.MailAddress


パッケージ jp.co.intra_mart.foundation.mail.javamail.model の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.mail.javamail.model の使用

jp.co.intra_mart.foundation.mail.javamail.model を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail メール送信クラスを提供します。

jp.co.intra_mart.foundation.mail.javamail により使用される jp.co.intra_mart.foundation.mail.javamail.model のクラス
MailAddress
メールアドレスのモデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException の使用

JavaMailPropertyException を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail.property

jp.co.intra_mart.foundation.mail.javamail.property での JavaMailPropertyException の使用

JavaMailPropertyException をスローする jp.co.intra_mart.foundation.mail.javamail.property のメソッド
static JavaMailPropertyHandler JavaMailPropertyHandler.getInstance()
JavaMailPropertyHandlerのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler の使用

JavaMailPropertyHandler を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail.property

jp.co.intra_mart.foundation.mail.javamail.property での JavaMailPropertyHandler の使用

JavaMailPropertyHandler を返す jp.co.intra_mart.foundation.mail.javamail.property のメソッド
static JavaMailPropertyHandler JavaMailPropertyHandler.getInstance()
JavaMailPropertyHandlerのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl の使用

jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


JavaMailPropertyException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.property
クラス JavaMailPropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException
すべての実装インタフェース:
Serializable
public class JavaMailPropertyException
extends Exception

JavaMailSenderの設定に関する情報を提供する例外です。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
JavaMailPropertyException()
JavaMailPropertyExceptionを構築します。
JavaMailPropertyException(String message)
指定された詳細メッセージを使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyException(String message, Throwable cause)
指定された詳細メッセージおよび原因を使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyException(Throwable cause)
指定された原因を使用してJavaMailPropertyExceptionを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

JavaMailPropertyException

public JavaMailPropertyException()
JavaMailPropertyExceptionを構築します。

JavaMailPropertyException

public JavaMailPropertyException(String message)
指定された詳細メッセージを使用してJavaMailPropertyExceptionを構築します。

パラメータ:
message -

JavaMailPropertyException

public JavaMailPropertyException(String message,
                                 Throwable cause)
指定された詳細メッセージおよび原因を使用してJavaMailPropertyExceptionを構築します。

パラメータ:
message -
cause -

JavaMailPropertyException

public JavaMailPropertyException(Throwable cause)
指定された原因を使用してJavaMailPropertyExceptionを構築します。

パラメータ:
cause -
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


JavaMailPropertyHandler (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.property
クラス JavaMailPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler
public class JavaMailPropertyHandler
extends Object

JavaMailSenderの設定を保持します。

導入されたバージョン:
5.0.2

メソッドの概要
String | getCharset(Locale locale) キャラクターセットを取得します。
String | getContentTransferEncoding(Locale locale) Content-Transfer-Encodingを取得します。
String | getContentType(String ext) コンテントタイプを取得します。
boolean | getDebugOption() JavaMailに設定するデバック設定の有無を取得します。
static JavaMailPropertyHandler | getInstance() JavaMailPropertyHandlerのインスタンスを取得します。
Collection | getListeners() メール送信リスナを取得します。
String | getMimeEncoding(Locale locale) MIMEエンコードを取得します。
int | getSMTPConnectionTimeout() SMTPサーバへのコネクションタイムアウト時間を取得します。
String | getSMTPPassword() SMTP認証のパスワードを取得します
int | getSMTPTimeout() SMTPサーバとの入出力タイムアウト時間を取得します。
String | getSMTPUser() SMTP認証のユーザを取得します
String | getXMailerHeader() 送信メールに付加するX-Mailerヘッダを取得します。
boolean | isEnableSMTPAuth() SMTP認証の有効/無効を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getInstance

public static JavaMailPropertyHandler getInstance()
                                           throws JavaMailPropertyException
JavaMailPropertyHandlerのインスタンスを取得します。

戻り値:
JavaMailPropertyHandlerのインスタンス
例外:
JavaMailPropertyException

getContentType

public String getContentType(String ext)
コンテントタイプを取得します。

パラメータ:
ext - ドットを含む拡張子
戻り値:
コンテントタイプ

getXMailerHeader

public String getXMailerHeader()
送信メールに付加するX-Mailerヘッダを取得します。

戻り値:
X-Mailerヘッダ

getDebugOption

public boolean getDebugOption()
JavaMailに設定するデバック設定の有無を取得します。

戻り値:
デバック設定

getSMTPConnectionTimeout

public int getSMTPConnectionTimeout()
SMTPサーバへのコネクションタイムアウト時間を取得します。

戻り値:
タイムアウト時間

getSMTPTimeout

public int getSMTPTimeout()
SMTPサーバとの入出力タイムアウト時間を取得します。

戻り値:
タイムアウト時間

isEnableSMTPAuth

public boolean isEnableSMTPAuth()
SMTP認証の有効/無効を取得します。

戻り値:
SMTPの有効/無効
導入されたバージョン:
7.0.2

getSMTPUser

public String getSMTPUser()
SMTP認証のユーザを取得します

戻り値:
ユーザ
導入されたバージョン:
7.0.2

getSMTPPassword

public String getSMTPPassword()
SMTP認証のパスワードを取得します

戻り値:
パスワード
導入されたバージョン:
7.0.2

getCharset

public String getCharset(Locale locale)
キャラクターセットを取得します。

パラメータ:
locale - ロケール
戻り値:
キャラクターセット

getMimeEncoding

public String getMimeEncoding(Locale locale)
MIMEエンコードを取得します。

パラメータ:
locale - ロケール
戻り値:
エンコード

getContentTransferEncoding

public String getContentTransferEncoding(Locale locale)
Content-Transfer-Encodingを取得します。

パラメータ:
locale - ロケール
戻り値:
Content-Transfer-Encoding

getListeners

public Collection getListeners()
メール送信リスナを取得します。
コレクションの要素はMailSendListenerのインスタンスです。

戻り値:
メール送信リスナ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


JavaMailPropertyHandlerInitializerImpl (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.property
クラス JavaMailPropertyHandlerInitializerImpl

java.lang.Object
    拡張 jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl
すべての実装インタフェース:
jp.co.intra_mart.system.service.ApplicationInitializer
public class JavaMailPropertyHandlerInitializerImpl
extends Object
implements jp.co.intra_mart.system.service.ApplicationInitializer

JavaMailPropertyHandlerの初期化クラス。

JavaMailSenderの設定を保持するJavaMailPropertyHandlerの初期化を行います。 アプリケーションライタイム起動時に呼ばれます。

導入されたバージョン:
6.0.2

コンストラクタの概要
JavaMailPropertyHandlerInitializerImpl()
メソッドの概要
 void initialize()
初期化処理を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

JavaMailPropertyHandlerInitializerImpl

public JavaMailPropertyHandlerInitializerImpl()
メソッドの詳細

initialize

public void initialize()
初期化処理を行います。

定義:
インタフェース jp.co.intra_mart.system.service.ApplicationInitializer 内の initialize
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.mail.javamail.property (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.mail.javamail.property
クラス
JavaMailPropertyHandler
JavaMailPropertyHandlerInitializerImpl
例外
JavaMailPropertyException


jp.co.intra_mart.foundation.mail.javamail.property (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.property

クラスの概要
JavaMailPropertyHandler | JavaMailSenderの設定を保持します。
JavaMailPropertyHandlerInitializerImpl | JavaMailPropertyHandlerの初期化クラス。

例外の概要
JavaMailPropertyException JavaMailSenderの設定に関する情報を提供する例外です。


jp.co.intra_mart.foundation.mail.javamail.property クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.property の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler
    • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl (implements jp.co.intra_mart.system.service.ApplicationInitializer)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException


パッケージ jp.co.intra_mart.foundation.mail.javamail.property の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.mail.javamail.property の使用

jp.co.intra_mart.foundation.mail.javamail.property を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail.property

jp.co.intra_mart.foundation.mail.javamail.property により使用される jp.co.intra_mart.foundation.mail.javamail.property のクラス
JavaMailPropertyException
JavaMailSenderの設定に関する情報を提供する例外です。
JavaMailPropertyHandler
JavaMailSenderの設定を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


JavaMailSender (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail
クラス JavaMailSender

java.lang.Object
    拡張 jp.co.intra_mart.foundation.mail.javamail.JavaMailSender
すべての実装インタフェース:
MailSender
public class JavaMailSender
extends Object
implements MailSender

JavaMailをラップしたメール送信オブジェクトです。
メールの送信情報はStandardMailのインスタンスにより 決定されます。

JavaMailSenderはリスナを実装することで、メール送信前に任意の処理を実行することが可能です。
リスナでは送信メールの情報を参照したり、送信を中止することも可能です。 リスナの詳しい説明についてはMailSendListener を参照してください。

導入されたバージョン:
5.0
関連項目:
StandardMail

コンストラクタの概要
JavaMailSender(StandardMail mail)
JavaMailSenderを新規に作成します。
メソッドの概要
 void send()
メールを送信します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

JavaMailSender

public JavaMailSender(StandardMail mail)
JavaMailSenderを新規に作成します。

パラメータ:
mail - 送信メール
メソッドの詳細

send

public void send()
          throws MailSenderException
メールを送信します。

定義:
インタフェース MailSender 内の send
例外:
MailSenderException - メール送信時に例外が発生。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.mail.javamail (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.mail.javamail
クラス
JavaMailSender
StandardMail


jp.co.intra_mart.foundation.mail.javamail (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail

メール送信クラスを提供します。

参照:
説明

クラスの概要
JavaMailSender | JavaMailをラップしたメール送信オブジェクトです。
StandardMail | 送信するメールの属性を保管します。

パッケージ jp.co.intra_mart.foundation.mail.javamail の説明

メール送信クラスを提供します。


jp.co.intra_mart.foundation.mail.javamail クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender (implements jp.co.intra_mart.foundation.mail.MailSender)
    • class jp.co.intra_mart.foundation.mail.javamail.StandardMail


パッケージ jp.co.intra_mart.foundation.mail.javamail の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.mail.javamail の使用

jp.co.intra_mart.foundation.mail.javamail を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail | メール送信クラスを提供します。
jp.co.intra_mart.foundation.mail.javamail.listener |

jp.co.intra_mart.foundation.mail.javamail により使用される jp.co.intra_mart.foundation.mail.javamail のクラス
StandardMail
送信するメールの属性を保管します。

jp.co.intra_mart.foundation.mail.javamail.listener により使用される jp.co.intra_mart.foundation.mail.javamail のクラス
StandardMail
送信するメールの属性を保管します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardMail (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail
クラス StandardMail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.mail.javamail.StandardMail
public class StandardMail
extends Object

送信するメールの属性を保管します。

  • キャラクターセット、エンコード
    このオブジェクトが保持するメールのキャラクターセット、エンコディングの設定は ロケールに依存します。ロケール毎の設定は定義ファイルをにより決定されます。
    ServerManager上に /conf/mail/encode.properties として、定義ファイルを配置してください。

    指定可能なキーの一覧
    charset | キャラクターセット
    mimeEncoding | MIMEエンコード (B or Q)
    contentTransferEncoding | ボディのエンコード

  • SMTP Authentication
    StandardMail は SMTP Authentication に対応しています。有効にする場合は ServerManager 上の /conf/mail/smtpAuth.properties を編集してください。

    enable SMTP Authの有効
    (true or false)
    user | ユーザID
    password | パスワード

導入されたバージョン:
5.0
関連項目:
JavaMailSender

コンストラクタの概要
StandardMail()
システムのロケールからメール属性オブジェクトを新規に作成します。
StandardMail(Locale locale)
ロケールを指定してメール属性オブジェクトを新規に作成します。
メソッドの概要
void | addAttachment(String filename, String file) 添付ファイルを追加します。
void | addBcc(String address) Bccを追加します。
void | addBcc(String address, String personal) Bccを追加します。
void | addCc(String address) Ccを追加します。
void | addCc(String address, String personal) Ccを追加します。
void | addHeader(String name, String value) ヘッダーを追加します。
void | addReplyTo(String replyto) ReplyToを追加します。
void | addTo(String address) Toを追加します。
void | addTo(String address, String personal) Toを追加します。
protected Session | createSession(Properties prop) SMTPセッションを構築します。
Collection | getAttachment() 添付ファイルを取得します。
Collection | getBcc() Bccの一覧を取得します。
Collection | getCc() Ccの一覧を取得します。
MailAddress | getFrom() Fromを取得します。
Locale | getLocale() ロケールを取得します。
protected Properties | getProperties() JavaMailのSMTPセッションに渡す属性を初期化します。
String | getSubject() Subjectを取得します。
String | getText() 本文を取得します。
Collection | getTo() Toの一覧を取得します。
protected void | init() StandardMailオブジェクトを初期化します。
protected void | prepareMimeMessage(MimeMessage message) MIMEメッセージに対して操作を行います。
protected void | prepareSession(Session session) SMTPセッションに対して操作を行います。
void | setFrom(String address) Fromを設定します。
void | setFrom(String address, String personal) Fromを設定します。
void | setSubject(String subject) Subjectを設定します。
void | setText(String text) 本文を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardMail

public StandardMail()
システムのロケールからメール属性オブジェクトを新規に作成します。

StandardMail

public StandardMail(Locale locale)
ロケールを指定してメール属性オブジェクトを新規に作成します。

パラメータ:
locale - 送信先ロケール
メソッドの詳細

init

protected void init()
             throws MailSenderException
StandardMailオブジェクトを初期化します。 このメソッドはJavaMailSender.send()から呼ばれます。

例外:
MailSenderException - StandardMailオブジェクトを初期化時に例外が発生。

getLocale

public Locale getLocale()
ロケールを取得します。

戻り値:
ロケール

getProperties

protected Properties getProperties()
                            throws MailSenderException
JavaMailのSMTPセッションに渡す属性を初期化します。

ここではSMTPサーバのホスト及びポートを設定します。
このメソッドはJavaMailSender.send()から呼ばれます。

戻り値:
属性
例外:
MailSenderException - 属性設定時に例外が発生。

createSession

protected Session createSession(Properties prop)
                         throws MailSenderException
SMTPセッションを構築します。 SMTP認証が有効の場合は、認証情報が含まれたセッションを構築します。

パラメータ:
prop - 属性
戻り値:
SMTPセッション
例外:
MailSenderException - SMTPセッション構築時に例外が発生
導入されたバージョン:
7.0.2

prepareSession

protected void prepareSession(Session session)
                       throws MailSenderException
SMTPセッションに対して操作を行います。

ここでは、JavaMailにデバックオプションを設定します。 設定値は"conf/mail/javaMail.properties"の設定値が有効となります。
このメソッドはJavaMailSender.send()から呼ばれます。

パラメータ:
session - SMTPセッション
例外:
MailSenderException - セッション操作中に例外が発生。

prepareMimeMessage

protected void prepareMimeMessage(MimeMessage message)
                           throws MailSenderException
MIMEメッセージに対して操作を行います。 このメソッドはJavaMailSender.send()から呼ばれます。

パラメータ:
message - メッセージ
例外:
MailSenderException - メッセージ操作中に例外が発生。

addHeader

public void addHeader(String name,
                      String value)
ヘッダーを追加します。

パラメータ:
name - ヘッダーの名前
value - ヘッダーの値

addReplyTo

public void addReplyTo(String replyto)
ReplyToを追加します。

パラメータ:
replyto - ReplyToに追加するメールアドレス

setFrom

public void setFrom(String address)
Fromを設定します。

パラメータ:
address - メールアドレス

setFrom

public void setFrom(String address,
                    String personal)
Fromを設定します。

パラメータ:
address - メールアドレス
personal - 名前

setSubject

public void setSubject(String subject)
Subjectを設定します。

パラメータ:
subject - Subject

addTo

public void addTo(String address)
Toを追加します。

パラメータ:
address - メールアドレス

addTo

public void addTo(String address,
                  String personal)
Toを追加します。

パラメータ:
address - メールアドレス
personal - 名前

addCc

public void addCc(String address)
Ccを追加します。

パラメータ:
address - メールアドレス

addCc

public void addCc(String address,
                  String personal)
Ccを追加します。

パラメータ:
address - メールアドレス
personal - 名前

addBcc

public void addBcc(String address)
Bccを追加します。

パラメータ:
address - メールアドレス

addBcc

public void addBcc(String address,
                   String personal)
Bccを追加します。

パラメータ:
address - メールアドレス
personal - 名前

setText

public void setText(String text)
本文を設定します。

パラメータ:
text - 本文

addAttachment

public void addAttachment(String filename,
                          String file)
添付ファイルを追加します。

パラメータ:
filename - 添付ファイル名
file - ファイル

getAttachment

public Collection getAttachment()
添付ファイルを取得します。
コレクションの要素はAttachmentFileのインスタンスです。

戻り値:
添付ファイル

getSubject

public String getSubject()
Subjectを取得します。

戻り値:
Subject

getText

public String getText()
本文を取得します。

戻り値:
本文

getFrom

public MailAddress getFrom()
Fromを取得します。

戻り値:
from

getTo

public Collection getTo()
Toの一覧を取得します。
コレクションの要素はMailAddressのインスタンスです。

戻り値:

getCc

public Collection getCc()
Ccの一覧を取得します。
コレクションの要素はMailAddressのインスタンスです。

戻り値:

getBcc

public Collection getBcc()
Bccの一覧を取得します。
コレクションの要素はMailAddressのインスタンスです。

戻り値:
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MailSender (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail
インタフェース MailSender

既知の実装クラスの一覧:
JavaMailSender
public interface MailSender

メールを送信するためのインターフェースです。

導入されたバージョン:
5.0

メソッドの概要
 void send()
メールを送信します。

メソッドの詳細

send

public void send()
          throws MailSenderException
メールを送信します。

例外:
MailSenderException - メール送信時に例外が発生。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MailSenderException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail
クラス MailSenderException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.mail.MailSenderException
すべての実装インタフェース:
Serializable
public class MailSenderException
extends Exception

メール送信時またはその他の不正な処理に関する情報を提供する例外です。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
MailSenderException()
MailSenderExceptionを構築します。
MailSenderException(String message)
指定された詳細メッセージを使用してMailSenderExceptionを構築します。
MailSenderException(String message, Throwable cause)
指定された詳細メッセージおよび原因を使用してMailSenderExceptionを構築します。
MailSenderException(Throwable cause)
指定された原因を使用してMailSenderExceptionを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MailSenderException

public MailSenderException()
MailSenderExceptionを構築します。

MailSenderException

public MailSenderException(String message)
指定された詳細メッセージを使用してMailSenderExceptionを構築します。

パラメータ:
message -

MailSenderException

public MailSenderException(String message,
                           Throwable cause)
指定された詳細メッセージおよび原因を使用してMailSenderExceptionを構築します。

パラメータ:
message -
cause -

MailSenderException

public MailSenderException(Throwable cause)
指定された原因を使用してMailSenderExceptionを構築します。

パラメータ:
cause -
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.mail (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.mail
インタフェース
MailSender
例外
MailSenderException


jp.co.intra_mart.foundation.mail (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail

メール送信に関するクラスを提供します。

参照:
説明

インタフェースの概要
MailSender メールを送信するためのインターフェースです。

例外の概要
MailSenderException メール送信時またはその他の不正な処理に関する情報を提供する例外です。

パッケージ jp.co.intra_mart.foundation.mail の説明

メール送信に関するクラスを提供します。


jp.co.intra_mart.foundation.mail クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.mail.MailSenderException

インタフェース階層

  • interface jp.co.intra_mart.foundation.mail.MailSender


パッケージ jp.co.intra_mart.foundation.mail の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.mail の使用

jp.co.intra_mart.foundation.mail を使用しているパッケージ
jp.co.intra_mart.foundation.mail | メール送信に関するクラスを提供します。
jp.co.intra_mart.foundation.mail.javamail | メール送信クラスを提供します。
jp.co.intra_mart.foundation.mail.javamail.listener |
jp.co.intra_mart.foundation.mail.javamail.listener.impl |

jp.co.intra_mart.foundation.mail により使用される jp.co.intra_mart.foundation.mail のクラス
MailSenderException
メール送信時またはその他の不正な処理に関する情報を提供する例外です。

jp.co.intra_mart.foundation.mail.javamail により使用される jp.co.intra_mart.foundation.mail のクラス
MailSender
メールを送信するためのインターフェースです。
MailSenderException
メール送信時またはその他の不正な処理に関する情報を提供する例外です。

jp.co.intra_mart.foundation.mail.javamail.listener により使用される jp.co.intra_mart.foundation.mail のクラス
MailSenderException
メール送信時またはその他の不正な処理に関する情報を提供する例外です。

jp.co.intra_mart.foundation.mail.javamail.listener.impl により使用される jp.co.intra_mart.foundation.mail のクラス
MailSenderException
メール送信時またはその他の不正な処理に関する情報を提供する例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventAccessInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventAccessInfo の使用

EventAccessInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventAccessInfo の使用

EventAccessInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
 EventAccessInfo NavigatorAuthenticateItem.getAccessInfo()

EventAccessInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
 void NavigatorAuthenticateItem.setAccessInfo(EventAccessInfo accessInfo)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventFlow の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventFlow の使用

EventFlow を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventFlow の使用

EventFlow を返す jp.co.intra_mart.foundation.navigator のメソッド
EventFlow | StandardEventNavigatorAccessor.getEventFlow(EventNavigatorManager manager, String eventFlowId) イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
EventFlow | StandardEventNavigatorAccessor.copyEventFlow(EventNavigatorManager manager, String eventFlowId) イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
EventFlow[] | StandardEventNavigatorAccessor.getEventFlows(EventNavigatorManager manager) すべてのイベントフローを取得します。
EventFlow | EventNavigatorManager.getEventFlow(String eventFllowId) イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
EventFlow[] | EventNavigatorManager.getEventFlows() イベントフローの取得（全件） 全イベントフローを取得し、返却する。
EventFlow | EventNavigatorManager.copyEventFlow(String eventFllowId) イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
EventFlow | EventNavigatorAccessor.getEventFlow(EventNavigatorManager manager, String eventFllowId) イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
EventFlow[] | EventNavigatorAccessor.getEventFlows(EventNavigatorManager manager) すべてのイベントフローを取得します。
EventFlow | EventNavigatorAccessor.copyEventFlow(EventNavigatorManager manager, String eventFllowId) イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。

EventFlow 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | StandardEventNavigatorAccessor.updateEventFlow(EventNavigatorManager manager, EventFlow eventFlow) イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
void | StandardEventNavigatorAccessor.registEventFlow(EventNavigatorManager manager, EventFlow eventFlow) イベントフローを更新します。
void | EventNavigatorManager.registEventFlow(EventFlow eventFllow) イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
void | EventNavigatorManager.updateEventFlow(EventFlow eventFllow) イベントフローの更新 イベントフロー情報をDB更新する。
void | EventNavigatorAccessor.registEventFlow(EventNavigatorManager manager, EventFlow eventFllow) イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
void | EventNavigatorAccessor.updateEventFlow(EventNavigatorManager manager, EventFlow eventFllow) イベントフローの更新 イベントフロー情報をDB更新する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventFlowInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventFlowInfo の使用

EventFlowInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventFlowInfo の使用

EventFlowInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
EventFlowInfo[] | StandardEventNavigatorAccessor.getEventFlowInfos(EventNavigatorManager manager, String searchTitle, boolean permissionCheck, int currentPage) イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
EventFlowInfo[] | EventNavigatorManager.getEventFlowInfos(String searchTitle, boolean permissionCheck, int currentPage) イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
EventFlowInfo[] | EventNavigatorAccessor.getEventFlowInfos(EventNavigatorManager manager, String searchTitle, boolean permissionCheck, int currentPage) イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。

EventFlowInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | StandardEventNavigatorAccessor.setOrderSortNum(EventNavigatorManager manager, EventFlowInfo[] eventFlowInfos) 表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
void | EventNavigatorManager.setOrderSortNum(EventFlowInfo[] eventFlowInfos) 表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
void | EventNavigatorAccessor.setOrderSortNum(EventNavigatorManager manager, EventFlowInfo[] eventFlowInfos) 表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventHistoryInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventHistoryInfo の使用

EventHistoryInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventHistoryInfo の使用

EventHistoryInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
EventHistoryInfo[] | EventResultItemInfo.getEventHistory() イベント履歴情報リスト取得
EventHistoryInfo[] | EventItemInfo.getEventHistory() イベント履歴情報リスト取得

EventHistoryInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | EventResultItemInfo.setEventHistory(EventHistoryInfo[] eventHistory) イベント履歴情報リスト設定
void | EventItemInfo.setEventHistory(EventHistoryInfo[] eventHistory) イベント履歴情報リスト設定

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventItem の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventItem の使用

EventItem を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventItem の使用

EventItem を返す jp.co.intra_mart.foundation.navigator のメソッド
EventItem | SelectItem.getNextEventItem()
EventItem | EventFlow.getStartEventItem()

EventItem 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | SelectItem.setNextEventItem(EventItem nextEventItem)
void | EventFlow.setStartEventItem(EventItem startEventItem)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventItemInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventItemInfo の使用

EventItemInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventItemInfo の使用

EventItemInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
EventItemInfo | StandardEventNavigatorAccessor.getEventItemInfo(EventNavigatorManager manager, String eventFlowId, String eventItemId) イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
EventItemInfo | EventNavigatorManager.getEventItemInfo(String eventFllowId, String eventItemId) イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
EventItemInfo | EventNavigatorAccessor.getEventItemInfo(EventNavigatorManager manager, String eventFllowId, String eventItemId) イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor の使用

EventNavigatorAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventNavigatorAccessor の使用

EventNavigatorAccessor を実装している jp.co.intra_mart.foundation.navigator のクラス
 class StandardEventNavigatorAccessor
イベントナビゲーター管理アクセッサクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventNavigatorConst の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventNavigatorConst の使用

jp.co.intra_mart.foundation.navigator.EventNavigatorConst はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventNavigatorException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventNavigatorException の使用

EventNavigatorException を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventNavigatorException の使用

EventNavigatorException をスローする jp.co.intra_mart.foundation.navigator のメソッド
void | StandardEventNavigatorImporter.doImport(EventNavigatorManager manager, InputStream inputStream) インポートを行います。
boolean | StandardEventNavigatorImporter.checkStrLength(String str, int length) 文字列チェック（共通）
boolean | StandardEventNavigatorImporter.checkLocale(String keyLocale, String[] locales) ロケールチェック（共通）
void | StandardEventNavigatorImporter.checkTitleInfo(NavigatorItem item, String[] locales, String strURI) タイトル情報のロケールマッチング（共通）
void | StandardEventNavigatorExporter.doExport(EventNavigatorManager manager, OutputStream outputStream, boolean editFlag) エクスポートを行います。
EventFlowInfo[] | StandardEventNavigatorAccessor.getEventFlowInfos(EventNavigatorManager manager, String searchTitle, boolean permissionCheck, int currentPage) イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
void | StandardEventNavigatorAccessor.deleteEventFlow(EventNavigatorManager manager, String eventFlowId) イベントフローの削除 イベントフローIDから、イベントフローを削除する。
EventFlow | StandardEventNavigatorAccessor.getEventFlow(EventNavigatorManager manager, String eventFlowId) イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
void | StandardEventNavigatorAccessor.updateEventFlow(EventNavigatorManager manager, EventFlow eventFlow) イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
EventFlow | StandardEventNavigatorAccessor.copyEventFlow(EventNavigatorManager manager, String eventFlowId) イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
EventItemInfo | StandardEventNavigatorAccessor.getEventItemInfo(EventNavigatorManager manager, String eventFlowId, String eventItemId) イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
EventResultItemInfo | StandardEventNavigatorAccessor.getEventResultItemInfo(EventNavigatorManager manager, String eventFlowId, String resultItemId) ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
String | StandardEventNavigatorAccessor.addEventResultItemInfo(EventNavigatorManager manager, String userId, String eventFlowId, EventResultItemInfo resultItemInfo) 保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
void | StandardEventNavigatorAccessor.deleteSaveResultHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。
SaveEventResultItemInfo | StandardEventNavigatorAccessor.getSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
void | StandardEventNavigatorAccessor.updateEventResultItemInfo(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | StandardEventNavigatorAccessor.updateEventResultItemInfoTitle(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
SaveEventResultItemInfo[] | StandardEventNavigatorAccessor.getSaveEventResultItemInfos(EventNavigatorManager manager, String userId, String searchTitle, String sortKey, String oeder, int currentPage) 保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
void | StandardEventNavigatorAccessor.removeSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String saveResultItemId) 保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。
void | StandardEventNavigatorAccessor.addFavoriteSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String saveResultItemId) 保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。
SaveEventResultItemInfo[] | StandardEventNavigatorAccessor.getSaveEventResultItemInfosHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
void | StandardEventNavigatorAccessor.setOrderSortNum(EventNavigatorManager manager, EventFlowInfo[] eventFlowInfos) 表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
void | StandardEventNavigatorAccessor.setViewOpen(EventNavigatorManager manager, String eventFlowId, String open) 表示設定 イベントフロー情報に表示／非表示を設定する。
String[] | StandardEventNavigatorAccessor.getEventFlowIds(EventNavigatorManager manager) すべてのイベントフローIDを取得します。
EventFlow[] | StandardEventNavigatorAccessor.getEventFlows(EventNavigatorManager manager) すべてのイベントフローを取得します。
LinkPageInfo | StandardEventNavigatorAccessor.getLinkPageInfo(EventNavigatorManager manager, String eventFlowId, String eventResultId, String resultPageId) 結果ページ情報を取得します。
LinkPageInfo | StandardEventNavigatorAccessor.getSaveLinkPageInfo(EventNavigatorManager manager, String userId, String eventResultId, String resultPageId) 保存結果ページ情報を取得します。
void | StandardEventNavigatorAccessor.registEventFlow(EventNavigatorManager manager, EventFlow eventFlow) イベントフローを更新します。
EventFlowInfo[] | EventNavigatorManager.getEventFlowInfos(String searchTitle, boolean permissionCheck, int currentPage) イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
void | EventNavigatorManager.deleteEventFlow(String eventFlowId) イベントフローの削除 イベントフローIDから、イベントフローを削除する。
EventFlow | EventNavigatorManager.getEventFlow(String eventFllowId) イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
EventFlow[] | EventNavigatorManager.getEventFlows() イベントフローの取得（全件） 全イベントフローを取得し、返却する。
void | EventNavigatorManager.registEventFlow(EventFlow eventFllow) イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
EventFlow | EventNavigatorManager.copyEventFlow(String eventFllowId) イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
EventItemInfo | EventNavigatorManager.getEventItemInfo(String eventFllowId, String eventItemId) イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
EventResultItemInfo | EventNavigatorManager.getEventResultItemInfo(String eventFllowId, String resultItemId) ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
String | EventNavigatorManager.addEventResultItemInfo(String userId, String eventFlowId, EventResultItemInfo resultItemInfo) 保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
void | EventNavigatorManager.deleteSaveResultHistory(String userId) 保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。
SaveEventResultItemInfo | EventNavigatorManager.getSaveEventResultItemInfo(String userId, String resultItemId) 保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
void | EventNavigatorManager.updateEventResultItemInfo(String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | EventNavigatorManager.updateEventResultItemInfoTitle(String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
SaveEventResultItemInfo[] | EventNavigatorManager.getSaveEventResultItemInfos(String searchTitle, String userId, String sortKey, String oeder, int currentPage) 保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
void | EventNavigatorManager.removeSaveEventResultItemInfo(String userId, String resultItemId) 保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。
void | EventNavigatorManager.addFavoriteSaveEventResultItemInfo(String userId, String resultItemId) 保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。
SaveEventResultItemInfo[] | EventNavigatorManager.getSaveEventResultItemInfosHistory(String userId) 保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
void | EventNavigatorManager.updateEventFlow(EventFlow eventFllow) イベントフローの更新 イベントフロー情報をDB更新する。
void | EventNavigatorManager.setOrderSortNum(EventFlowInfo[] eventFlowInfos) 表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
void | EventNavigatorManager.setViewOpen(String eventFlowId, String open) 表示設定 イベントフロー情報に表示／非表示を設定する。
void | EventNavigatorManager.importData(InputStream inputStream) インポートを行います。
void | EventNavigatorManager.exportData(OutputStream outputStream, boolean editFlag) エクスポートを行います。
LinkPageInfo | EventNavigatorManager.getLinkPageInfo(String eventFlowId, String eventResultId, String resultPageId) 結果ページ情報を取得します。
LinkPageInfo | EventNavigatorManager.getSaveLinkPageInfo(String userId, String eventResultId, String resultPageId) 保存結果ページ情報を取得します。
String | EventNavigatorManager.getConfigPageCount(String userId) 履歴表示件数の取得。
void | EventNavigatorManager.setConfigPageCount(String userId, int iCount) 履歴表示件数の設定。
void | EventNavigatorImporter.doImport(EventNavigatorManager manager, InputStream inputStream) インポートを行います。
void | EventNavigatorExporter.doExport(EventNavigatorManager manager, OutputStream outputStream, boolean editFlag) エクスポートを行います。
EventFlowInfo[] | EventNavigatorAccessor.getEventFlowInfos(EventNavigatorManager manager, String searchTitle, boolean permissionCheck, int currentPage) イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
void | EventNavigatorAccessor.deleteEventFlow(EventNavigatorManager manager, String eventFllowId) イベントフローの削除 イベントフローIDから、イベントフローを削除する。
EventFlow | EventNavigatorAccessor.getEventFlow(EventNavigatorManager manager, String eventFllowId) イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
EventFlow[] | EventNavigatorAccessor.getEventFlows(EventNavigatorManager manager) すべてのイベントフローを取得します。
void | EventNavigatorAccessor.registEventFlow(EventNavigatorManager manager, EventFlow eventFllow) イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
EventFlow | EventNavigatorAccessor.copyEventFlow(EventNavigatorManager manager, String eventFllowId) イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
EventItemInfo | EventNavigatorAccessor.getEventItemInfo(EventNavigatorManager manager, String eventFllowId, String eventItemId) イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
EventResultItemInfo | EventNavigatorAccessor.getEventResultItemInfo(EventNavigatorManager manager, String eventFllowId, String resultItemId) ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
String | EventNavigatorAccessor.addEventResultItemInfo(EventNavigatorManager manager, String userId, String eventFlowId, EventResultItemInfo resultItemInfo) 保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
void | EventNavigatorAccessor.deleteSaveResultHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。
SaveEventResultItemInfo | EventNavigatorAccessor.getSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
void | EventNavigatorAccessor.updateEventResultItemInfo(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | EventNavigatorAccessor.updateEventResultItemInfoTitle(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
SaveEventResultItemInfo[] | EventNavigatorAccessor.getSaveEventResultItemInfos(EventNavigatorManager manager, String userId, String searchTitle, String sortKey, String oeder, int currentPage) 保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
void | EventNavigatorAccessor.removeSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。
void | EventNavigatorAccessor.addFavoriteSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。
SaveEventResultItemInfo[] | EventNavigatorAccessor.getSaveEventResultItemInfosHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
void | EventNavigatorAccessor.updateEventFlow(EventNavigatorManager manager, EventFlow eventFllow) イベントフローの更新 イベントフロー情報をDB更新する。
void | EventNavigatorAccessor.setOrderSortNum(EventNavigatorManager manager, EventFlowInfo[] eventFlowInfos) 表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
void | EventNavigatorAccessor.setViewOpen(EventNavigatorManager manager, String eventFlowId, String open) 表示設定 イベントフロー情報に表示／非表示を設定する。
String[] | EventNavigatorAccessor.getEventFlowIds(EventNavigatorManager manager) すべてのイベントフローIDを取得します。
LinkPageInfo | EventNavigatorAccessor.getLinkPageInfo(EventNavigatorManager manager, String eventFlowId, String eventResultId, String resultPageId) 結果ページ情報を取得します。
LinkPageInfo | EventNavigatorAccessor.getSaveLinkPageInfo(EventNavigatorManager manager, String userId, String eventResultId, String resultPageId) 保存結果ページ情報を取得します。

EventNavigatorException をスローする jp.co.intra_mart.foundation.navigator のコンストラクタ
EventNavigatorManager(String groupId, String locale)
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.navigator.EventNavigatorExporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.navigator.EventNavigatorExporter の使用

EventNavigatorExporter を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventNavigatorExporter の使用

EventNavigatorExporter を実装している jp.co.intra_mart.foundation.navigator のクラス
 class StandardEventNavigatorExporter

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventNavigatorHandler の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventNavigatorHandler の使用

jp.co.intra_mart.foundation.navigator.EventNavigatorHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.navigator.EventNavigatorImporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.navigator.EventNavigatorImporter の使用

EventNavigatorImporter を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventNavigatorImporter の使用

EventNavigatorImporter を実装している jp.co.intra_mart.foundation.navigator のクラス
 class StandardEventNavigatorImporter
イベントナビゲーターのインポートクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventNavigatorManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventNavigatorManager の使用

EventNavigatorManager を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventNavigatorManager の使用

EventNavigatorManager 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | StandardEventNavigatorImporter.doImport(EventNavigatorManager manager, InputStream inputStream) インポートを行います。
void | StandardEventNavigatorExporter.doExport(EventNavigatorManager manager, OutputStream outputStream, boolean editFlag) エクスポートを行います。
EventFlowInfo[] | StandardEventNavigatorAccessor.getEventFlowInfos(EventNavigatorManager manager, String searchTitle, boolean permissionCheck, int currentPage) イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
void | StandardEventNavigatorAccessor.deleteEventFlow(EventNavigatorManager manager, String eventFlowId) イベントフローの削除 イベントフローIDから、イベントフローを削除する。
EventFlow | StandardEventNavigatorAccessor.getEventFlow(EventNavigatorManager manager, String eventFlowId) イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
void | StandardEventNavigatorAccessor.updateEventFlow(EventNavigatorManager manager, EventFlow eventFlow) イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
EventFlow | StandardEventNavigatorAccessor.copyEventFlow(EventNavigatorManager manager, String eventFlowId) イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
EventItemInfo | StandardEventNavigatorAccessor.getEventItemInfo(EventNavigatorManager manager, String eventFlowId, String eventItemId) イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
EventResultItemInfo | StandardEventNavigatorAccessor.getEventResultItemInfo(EventNavigatorManager manager, String eventFlowId, String resultItemId) ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
String | StandardEventNavigatorAccessor.addEventResultItemInfo(EventNavigatorManager manager, String userId, String eventFlowId, EventResultItemInfo resultItemInfo) 保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
void | StandardEventNavigatorAccessor.deleteSaveResultHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。
SaveEventResultItemInfo | StandardEventNavigatorAccessor.getSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
void | StandardEventNavigatorAccessor.updateEventResultItemInfo(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | StandardEventNavigatorAccessor.updateEventResultItemInfoTitle(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
SaveEventResultItemInfo[] | StandardEventNavigatorAccessor.getSaveEventResultItemInfos(EventNavigatorManager manager, String userId, String searchTitle, String sortKey, String oeder, int currentPage) 保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
void | StandardEventNavigatorAccessor.removeSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String saveResultItemId) 保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。
void | StandardEventNavigatorAccessor.addFavoriteSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String saveResultItemId) 保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。
SaveEventResultItemInfo[] | StandardEventNavigatorAccessor.getSaveEventResultItemInfosHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
void | StandardEventNavigatorAccessor.setOrderSortNum(EventNavigatorManager manager, EventFlowInfo[] eventFlowInfos) 表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
void | StandardEventNavigatorAccessor.setViewOpen(EventNavigatorManager manager, String eventFlowId, String open) 表示設定 イベントフロー情報に表示／非表示を設定する。
String[] | StandardEventNavigatorAccessor.getEventFlowIds(EventNavigatorManager manager) すべてのイベントフローIDを取得します。
EventFlow[] | StandardEventNavigatorAccessor.getEventFlows(EventNavigatorManager manager) すべてのイベントフローを取得します。
LinkPageInfo | StandardEventNavigatorAccessor.getLinkPageInfo(EventNavigatorManager manager, String eventFlowId, String eventResultId, String resultPageId) 結果ページ情報を取得します。
LinkPageInfo | StandardEventNavigatorAccessor.getSaveLinkPageInfo(EventNavigatorManager manager, String userId, String eventResultId, String resultPageId) 保存結果ページ情報を取得します。
void | StandardEventNavigatorAccessor.registEventFlow(EventNavigatorManager manager, EventFlow eventFlow) イベントフローを更新します。
Object | EventNavigatorReaderDecorator.doDecoration(EventNavigatorManager manager, Object obj) イベントナビゲータのオブジェクト情報をデータストアからの読み込み直後にコールされます。
void | EventNavigatorImporter.doImport(EventNavigatorManager manager, InputStream inputStream) インポートを行います。
void | EventNavigatorExporter.doExport(EventNavigatorManager manager, OutputStream outputStream, boolean editFlag) エクスポートを行います。
EventFlowInfo[] | EventNavigatorAccessor.getEventFlowInfos(EventNavigatorManager manager, String searchTitle, boolean permissionCheck, int currentPage) イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
void | EventNavigatorAccessor.deleteEventFlow(EventNavigatorManager manager, String eventFllowId) イベントフローの削除 イベントフローIDから、イベントフローを削除する。
EventFlow | EventNavigatorAccessor.getEventFlow(EventNavigatorManager manager, String eventFllowId) イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
EventFlow[] | EventNavigatorAccessor.getEventFlows(EventNavigatorManager manager) すべてのイベントフローを取得します。
void | EventNavigatorAccessor.registEventFlow(EventNavigatorManager manager, EventFlow eventFllow) イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
EventFlow | EventNavigatorAccessor.copyEventFlow(EventNavigatorManager manager, String eventFllowId) イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
EventItemInfo | EventNavigatorAccessor.getEventItemInfo(EventNavigatorManager manager, String eventFllowId, String eventItemId) イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
EventResultItemInfo | EventNavigatorAccessor.getEventResultItemInfo(EventNavigatorManager manager, String eventFllowId, String resultItemId) ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
String | EventNavigatorAccessor.addEventResultItemInfo(EventNavigatorManager manager, String userId, String eventFlowId, EventResultItemInfo resultItemInfo) 保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
void | EventNavigatorAccessor.deleteSaveResultHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。
SaveEventResultItemInfo | EventNavigatorAccessor.getSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
void | EventNavigatorAccessor.updateEventResultItemInfo(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | EventNavigatorAccessor.updateEventResultItemInfoTitle(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
SaveEventResultItemInfo[] | EventNavigatorAccessor.getSaveEventResultItemInfos(EventNavigatorManager manager, String userId, String searchTitle, String sortKey, String oeder, int currentPage) 保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
void | EventNavigatorAccessor.removeSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。
void | EventNavigatorAccessor.addFavoriteSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。
SaveEventResultItemInfo[] | EventNavigatorAccessor.getSaveEventResultItemInfosHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
void | EventNavigatorAccessor.updateEventFlow(EventNavigatorManager manager, EventFlow eventFllow) イベントフローの更新 イベントフロー情報をDB更新する。
void | EventNavigatorAccessor.setOrderSortNum(EventNavigatorManager manager, EventFlowInfo[] eventFlowInfos) 表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
void | EventNavigatorAccessor.setViewOpen(EventNavigatorManager manager, String eventFlowId, String open) 表示設定 イベントフロー情報に表示／非表示を設定する。
String[] | EventNavigatorAccessor.getEventFlowIds(EventNavigatorManager manager) すべてのイベントフローIDを取得します。
LinkPageInfo | EventNavigatorAccessor.getLinkPageInfo(EventNavigatorManager manager, String eventFlowId, String eventResultId, String resultPageId) 結果ページ情報を取得します。
LinkPageInfo | EventNavigatorAccessor.getSaveLinkPageInfo(EventNavigatorManager manager, String userId, String eventResultId, String resultPageId) 保存結果ページ情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventNavigatorPermissionSelector の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventNavigatorPermissionSelector の使用

jp.co.intra_mart.foundation.navigator.EventNavigatorPermissionSelector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.navigator.EventNavigatorReaderDecorator の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.navigator.EventNavigatorReaderDecorator の使用

jp.co.intra_mart.foundation.navigator.EventNavigatorReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventResultItem の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventResultItem の使用

EventResultItem を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventResultItem の使用

EventResultItem を返す jp.co.intra_mart.foundation.navigator のメソッド
 EventResultItem SelectItem.getNextEventResultItem()

EventResultItem 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
 void SelectItem.setNextEventResultItem(EventResultItem nextEventResultItem)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.EventResultItemInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.EventResultItemInfo の使用

EventResultItemInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での EventResultItemInfo の使用

EventResultItemInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
EventResultItemInfo | StandardEventNavigatorAccessor.getEventResultItemInfo(EventNavigatorManager manager, String eventFlowId, String resultItemId) ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
EventResultItemInfo | EventNavigatorManager.getEventResultItemInfo(String eventFllowId, String resultItemId) ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
EventResultItemInfo | EventNavigatorAccessor.getEventResultItemInfo(EventNavigatorManager manager, String eventFllowId, String resultItemId) ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。

EventResultItemInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
String | StandardEventNavigatorAccessor.addEventResultItemInfo(EventNavigatorManager manager, String userId, String eventFlowId, EventResultItemInfo resultItemInfo) 保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
String | EventNavigatorManager.addEventResultItemInfo(String userId, String eventFlowId, EventResultItemInfo resultItemInfo) 保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
String | EventNavigatorAccessor.addEventResultItemInfo(EventNavigatorManager manager, String userId, String eventFlowId, EventResultItemInfo resultItemInfo) 保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.LinkPageInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.LinkPageInfo の使用

LinkPageInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での LinkPageInfo の使用

LinkPageInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
LinkPageInfo | StandardEventNavigatorAccessor.getLinkPageInfo(EventNavigatorManager manager, String eventFlowId, String eventResultId, String resultPageId) 結果ページ情報を取得します。
LinkPageInfo | StandardEventNavigatorAccessor.getSaveLinkPageInfo(EventNavigatorManager manager, String userId, String eventResultId, String resultPageId) 保存結果ページ情報を取得します。
LinkPageInfo | ResultPageItem.getLinkPageInfo()
LinkPageInfo | EventNavigatorManager.getLinkPageInfo(String eventFlowId, String eventResultId, String resultPageId) 結果ページ情報を取得します。
LinkPageInfo | EventNavigatorManager.getSaveLinkPageInfo(String userId, String eventResultId, String resultPageId) 保存結果ページ情報を取得します。
LinkPageInfo | EventNavigatorAccessor.getLinkPageInfo(EventNavigatorManager manager, String eventFlowId, String eventResultId, String resultPageId) 結果ページ情報を取得します。
LinkPageInfo | EventNavigatorAccessor.getSaveLinkPageInfo(EventNavigatorManager manager, String userId, String eventResultId, String resultPageId) 保存結果ページ情報を取得します。

LinkPageInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
 void ResultPageItem.setLinkPageInfo(LinkPageInfo linkPageInfo)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem の使用

NavigatorAuthenticateItem を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での NavigatorAuthenticateItem の使用

jp.co.intra_mart.foundation.navigator での NavigatorAuthenticateItem のサブクラス
class | EventFlow イベントフロークラス
class | ResultPageItem 結果ページクラス
class | SelectItem 選択アイテムクラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.NavigatorItem の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.NavigatorItem の使用

NavigatorItem を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での NavigatorItem の使用

jp.co.intra_mart.foundation.navigator での NavigatorItem のサブクラス
class | EventFlow イベントフロークラス
class | EventItem イベントアイテムクラス
class | EventResultItem ナビゲート結果クラス
class | NavigatorAuthenticateItem 選択アイテムクラス
class | ResultPageItem 結果ページクラス
class | SelectItem 選択アイテムクラス

NavigatorItem 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
 void StandardEventNavigatorImporter.checkTitleInfo(NavigatorItem item, String[] locales, String strURI)
タイトル情報のロケールマッチング（共通）

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.ResultPageItem の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.ResultPageItem の使用

ResultPageItem を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での ResultPageItem の使用

ResultPageItem を返す jp.co.intra_mart.foundation.navigator のメソッド
 ResultPageItem[] EventResultItem.getPageItem()

ResultPageItem 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | EventResultItem.setPageItem(ResultPageItem[] pageItem)
void | EventResultItem.addPage(ResultPageItem page) リンクページ情報追加

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.ResultPageItemInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.ResultPageItemInfo の使用

ResultPageItemInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での ResultPageItemInfo の使用

ResultPageItemInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
ResultPageItemInfo[] | SaveEventResultItemInfo.getResultPageItemInfos() 結果ページ情報リスト取得
ResultPageItemInfo[] | EventResultItemInfo.getResultPageItemInfos() 結果ページ情報リスト取得

ResultPageItemInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | SaveEventResultItemInfo.setResultPageItemInfos(ResultPageItemInfo[] resultPageItemInfos) 結果ページ情報リスト設定
void | EventResultItemInfo.setResultPageItemInfos(ResultPageItemInfo[] resultPageItemInfos) 結果ページ情報リスト設定

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.SaveEventHistoryInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.SaveEventHistoryInfo の使用

SaveEventHistoryInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での SaveEventHistoryInfo の使用

SaveEventHistoryInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
 SaveEventHistoryInfo[] SaveEventResultItemInfo.getEventHistory()
イベント履歴情報リスト取得

SaveEventHistoryInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
 void SaveEventResultItemInfo.setEventHistory(SaveEventHistoryInfo[] eventHistory)
イベント履歴情報リスト設定

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo の使用

SaveEventResultItemInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での SaveEventResultItemInfo の使用

SaveEventResultItemInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
SaveEventResultItemInfo | StandardEventNavigatorAccessor.getSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
SaveEventResultItemInfo[] | StandardEventNavigatorAccessor.getSaveEventResultItemInfos(EventNavigatorManager manager, String userId, String searchTitle, String sortKey, String oeder, int currentPage) 保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
SaveEventResultItemInfo[] | StandardEventNavigatorAccessor.getSaveEventResultItemInfosHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
SaveEventResultItemInfo | EventNavigatorManager.getSaveEventResultItemInfo(String userId, String resultItemId) 保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
SaveEventResultItemInfo[] | EventNavigatorManager.getSaveEventResultItemInfos(String searchTitle, String userId, String sortKey, String oeder, int currentPage) 保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
SaveEventResultItemInfo[] | EventNavigatorManager.getSaveEventResultItemInfosHistory(String userId) 保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
SaveEventResultItemInfo | EventNavigatorAccessor.getSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
SaveEventResultItemInfo[] | EventNavigatorAccessor.getSaveEventResultItemInfos(EventNavigatorManager manager, String userId, String searchTitle, String sortKey, String oeder, int currentPage) 保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
SaveEventResultItemInfo[] | EventNavigatorAccessor.getSaveEventResultItemInfosHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。

SaveEventResultItemInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | StandardEventNavigatorAccessor.updateEventResultItemInfo(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | StandardEventNavigatorAccessor.updateEventResultItemInfoTitle(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | EventNavigatorManager.updateEventResultItemInfo(String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | EventNavigatorManager.updateEventResultItemInfoTitle(String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | EventNavigatorAccessor.updateEventResultItemInfo(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | EventNavigatorAccessor.updateEventResultItemInfoTitle(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.SelectItem の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.SelectItem の使用

SelectItem を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での SelectItem の使用

SelectItem を返す jp.co.intra_mart.foundation.navigator のメソッド
SelectItem[] | EventItem.getSelectItem()
SelectItem | EventItem.getSelectItem(int index)

SelectItem 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | EventItem.setSelectItem(SelectItem[] selectItem)
void | EventItem.add(SelectItem node) イベントノード追加

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.SelectItemInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.SelectItemInfo の使用

SelectItemInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での SelectItemInfo の使用

SelectItemInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
 SelectItemInfo[] EventItemInfo.getSelectItemInfos()
選択アイテム情報リスト取得

SelectItemInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
 void EventItemInfo.setSelectItemInfos(SelectItemInfo[] selectItemInfos)
選択アイテム情報リスト設定

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor の使用

jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter の使用

jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter の使用

jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.navigator.TitleInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.navigator.TitleInfo の使用

TitleInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator での TitleInfo の使用

jp.co.intra_mart.foundation.navigator での TitleInfo のサブクラス
class | EventFlowInfo イベントフロー情報
class | EventItemInfo イベントアイテム情報
class | EventResultItemInfo ナビゲート結果情報
class | LinkPageInfo リンク情報
class | ResultPageItemInfo 結果ページ情報
class | SaveEventResultItemInfo 保存ナビゲート結果情報
class | SelectItemInfo 選択アイテム情報

TitleInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
 TitleInfo NavigatorItem.getTitleInfo(Locale locale)

TitleInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
 void NavigatorItem.setTitleInfo(Locale locale, TitleInfo titleInfo)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


EventAccessInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventAccessInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.EventAccessInfo
すべての実装インタフェース:
Serializable
public class EventAccessInfo
extends Object
implements Serializable

アクセス権情報

関連項目:
直列化された形式

コンストラクタの概要
EventAccessInfo()
メソッドの概要
void | addDepartment(DepartmentInfo department)
void | addPost(PostInfo post)
void | addPublicGroup(PublicGroupInfo publicGroup)
void | addRole(Role role)
DepartmentInfo | getDepartment(int i)
DepartmentInfo[] | getDepartments()
PostInfo | getPost(int i)
PostInfo[] | getPosts()
PublicGroupInfo | getPublicGroup(int i)
PublicGroupInfo[] | getPublicGroups()
Role | getRole(int i)
Role[] | getRoles()
boolean | isRequiredCheck() 権限チェック要否
void | setDepartment(int i, DepartmentInfo department)
void | setDepartments(DepartmentInfo[] departments)
void | setPost(int i, PostInfo post)
void | setPosts(PostInfo[] posts)
void | setPublicGroup(int i, PublicGroupInfo publicGroup)
void | setPublicGroups(PublicGroupInfo[] publicGroups)
void | setRole(int i, Role role)
void | setRoles(Role[] roles)
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventAccessInfo

public EventAccessInfo()
メソッドの詳細

getDepartments

public DepartmentInfo[] getDepartments()
戻り値:
departments を戻します。

getDepartment

public DepartmentInfo getDepartment(int i)
パラメータ:
i - 取得するインデックス
戻り値:
department を戻します。

setDepartments

public void setDepartments(DepartmentInfo[] departments)
パラメータ:
departments - 設定する departments。

setDepartment

public void setDepartment(int i,
                          DepartmentInfo department)
パラメータ:
i - 設定するインデックス
department - 設定する department。

addDepartment

public void addDepartment(DepartmentInfo department)
パラメータ:
department - 設定する department。

getPosts

public PostInfo[] getPosts()
戻り値:
posts を戻します。

getPost

public PostInfo getPost(int i)
パラメータ:
i - 取得するインデックス
戻り値:
posts を戻します。

setPosts

public void setPosts(PostInfo[] posts)
パラメータ:
posts - 設定する posts。

setPost

public void setPost(int i,
                    PostInfo post)
パラメータ:
i - 設定するインデックス
post - 設定する post。

addPost

public void addPost(PostInfo post)
パラメータ:
post - 設定する post。

getPublicGroups

public PublicGroupInfo[] getPublicGroups()
戻り値:
publicGroups を戻します。

getPublicGroup

public PublicGroupInfo getPublicGroup(int i)
パラメータ:
i - 取得するインデックス
戻り値:
department を戻します。

setPublicGroups

public void setPublicGroups(PublicGroupInfo[] publicGroups)
パラメータ:
publicGroups - 設定する publicGroups。

setPublicGroup

public void setPublicGroup(int i,
                           PublicGroupInfo publicGroup)
パラメータ:
i - 設定するインデックス
publicGroup - 設定する publicGroup。

addPublicGroup

public void addPublicGroup(PublicGroupInfo publicGroup)
パラメータ:
publicGroup - 設定する publicGroup。

getRoles

public Role[] getRoles()
戻り値:
roles を戻します。

getRole

public Role getRole(int i)
パラメータ:
i - 取得するインデックス
戻り値:
roles を戻します。

setRoles

public void setRoles(Role[] roles)
パラメータ:
roles - 設定する roles。

setRole

public void setRole(int i,
                    Role role)
パラメータ:
i - 設定するインデックス
role - 設定する role。

addRole

public void addRole(Role role)
パラメータ:
role - 設定する role。

isRequiredCheck

public boolean isRequiredCheck()
権限チェック要否

戻り値:
boolean 権限チェック要否
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventFlow (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventFlow

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.NavigatorItem
        拡張 jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem
            拡張 jp.co.intra_mart.foundation.navigator.EventFlow
すべての実装インタフェース:
Serializable
public class EventFlow
extends NavigatorAuthenticateItem

イベントフロークラス

関連項目:
直列化された形式

コンストラクタの概要
EventFlow()
メソッドの概要
String | getId()
String | getOpen()
int | getSortNumber()
EventItem | getStartEventItem()
void | setId(String id)
void | setOpen(String open)
void | setSortNumber(int sortNumber)
void | setStartEventItem(EventItem startEventItem)
クラス jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem から継承したメソッド
getAccessInfo, setAccessInfo
クラス jp.co.intra_mart.foundation.navigator.NavigatorItem から継承したメソッド
getKeys, getTitleInfo, removeTitleInfo, setTitleInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventFlow

public EventFlow()
メソッドの詳細

getId

public String getId()
戻り値:
id を戻します。

setId

public void setId(String id)
パラメータ:
id - 設定する id。

getOpen

public String getOpen()
戻り値:
open を戻します。

setOpen

public void setOpen(String open)
パラメータ:
open - 設定する open。

getStartEventItem

public EventItem getStartEventItem()
戻り値:
startEventItem を戻します。

setStartEventItem

public void setStartEventItem(EventItem startEventItem)
パラメータ:
startEventItem - 設定する startEventItem。

getSortNumber

public int getSortNumber()
戻り値:
sortNumber を戻します。

setSortNumber

public void setSortNumber(int sortNumber)
パラメータ:
sortNumber - 設定する sortNumber。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventFlowInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventFlowInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.TitleInfo
        拡張 jp.co.intra_mart.foundation.navigator.EventFlowInfo
すべての実装インタフェース:
Serializable
public class EventFlowInfo
extends TitleInfo

イベントフロー情報

関連項目:
直列化された形式

コンストラクタの概要
EventFlowInfo()
メソッドの概要
String | getId() イベントフローID取得
String | getOpen() 公開フラグ取得
String | getStartEventId() スタートイベントアイテムID取得
boolean | isPermissionCheck() パーミッションチェックフラグ取得
void | setId(String id) イベントフローID設定
void | setOpen(String open) 公開フラグ設定
void | setPermissionCheck(boolean check) パーミッションチェックフラグ設定
void | setStartEventId(String startEventId) スタートイベントアイテムID設定
クラス jp.co.intra_mart.foundation.navigator.TitleInfo から継承したメソッド
getComment, getTitle, setComment, setTitle
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventFlowInfo

public EventFlowInfo()
メソッドの詳細

getId

public String getId()
イベントフローID取得

戻り値:
Returns the id.

setId

public void setId(String id)
イベントフローID設定

パラメータ:
id - The id to set.

getStartEventId

public String getStartEventId()
スタートイベントアイテムID取得

戻り値:
Returns the startEventId.

setStartEventId

public void setStartEventId(String startEventId)
スタートイベントアイテムID設定

パラメータ:
startEventId - The startEventId to set.

getOpen

public String getOpen()
公開フラグ取得

戻り値:
Returns the open.

setOpen

public void setOpen(String open)
公開フラグ設定

パラメータ:
open - The open to set.

isPermissionCheck

public boolean isPermissionCheck()
パーミッションチェックフラグ取得

戻り値:
Returns the permissionCheck.

setPermissionCheck

public void setPermissionCheck(boolean check)
パーミッションチェックフラグ設定

パラメータ:
check - The permissionCheck to set.
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventHistoryInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventHistoryInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.EventHistoryInfo
すべての実装インタフェース:
Serializable
public class EventHistoryInfo
extends Object
implements Serializable

イベント履歴情報

関連項目:
直列化された形式

コンストラクタの概要
EventHistoryInfo()
メソッドの概要
String | getAnswer() 質問取得
String | getId() イベントアイテムID取得
String | getQuestion() 回答取得
void | setAnswer(String answer) 質問設定
void | setId(String id) イベントアイテムID設定
void | setQuestion(String question) 回答設定
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventHistoryInfo

public EventHistoryInfo()
メソッドの詳細

getId

public String getId()
イベントアイテムID取得

戻り値:
Returns the id.

setId

public void setId(String id)
イベントアイテムID設定

パラメータ:
id - The id to set.

getAnswer

public String getAnswer()
質問取得

戻り値:
Returns the answer.

setAnswer

public void setAnswer(String answer)
質問設定

パラメータ:
answer - The answer to set.

getQuestion

public String getQuestion()
回答取得

戻り値:
Returns the question.

setQuestion

public void setQuestion(String question)
回答設定

パラメータ:
question - The question to set.
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventItem (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.NavigatorItem
        拡張 jp.co.intra_mart.foundation.navigator.EventItem
すべての実装インタフェース:
Serializable
public class EventItem
extends NavigatorItem

イベントアイテムクラス

関連項目:
直列化された形式

コンストラクタの概要
EventItem()
メソッドの概要
void | add(SelectItem node) イベントノード追加
SelectItem[] | getSelectItem()
SelectItem | getSelectItem(int index)
void | setSelectItem(SelectItem[] selectItem)
クラス jp.co.intra_mart.foundation.navigator.NavigatorItem から継承したメソッド
getKeys, getTitleInfo, removeTitleInfo, setTitleInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventItem

public EventItem()
メソッドの詳細

getSelectItem

public SelectItem[] getSelectItem()
戻り値:
selectItem を戻します。

getSelectItem

public SelectItem getSelectItem(int index)
パラメータ:
index - インデックス
戻り値:
selectItem を戻します。

setSelectItem

public void setSelectItem(SelectItem[] selectItem)
パラメータ:
selectItem - 設定する selectItem。

add

public void add(SelectItem node)
イベントノード追加

パラメータ:
node - 追加するノード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventItemInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventItemInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.TitleInfo
        拡張 jp.co.intra_mart.foundation.navigator.EventItemInfo
すべての実装インタフェース:
Serializable
public class EventItemInfo
extends TitleInfo

イベントアイテム情報

関連項目:
直列化された形式

コンストラクタの概要
EventItemInfo()
メソッドの概要
EventHistoryInfo[] | getEventHistory() イベント履歴情報リスト取得
String | getId() イベントアイテムID取得
SelectItemInfo[] | getSelectItemInfos() 選択アイテム情報リスト取得
void | setEventHistory(EventHistoryInfo[] eventHistory) イベント履歴情報リスト設定
void | setId(String id) イベントアイテムID設定
void | setSelectItemInfos(SelectItemInfo[] selectItemInfos) 選択アイテム情報リスト設定
クラス jp.co.intra_mart.foundation.navigator.TitleInfo から継承したメソッド
getComment, getTitle, setComment, setTitle
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventItemInfo

public EventItemInfo()
メソッドの詳細

getId

public String getId()
イベントアイテムID取得

戻り値:
Returns the id.

setId

public void setId(String id)
イベントアイテムID設定

パラメータ:
id - The id to set.

getSelectItemInfos

public SelectItemInfo[] getSelectItemInfos()
選択アイテム情報リスト取得

戻り値:
Returns the selectItemInfos.

setSelectItemInfos

public void setSelectItemInfos(SelectItemInfo[] selectItemInfos)
選択アイテム情報リスト設定

getEventHistory

public EventHistoryInfo[] getEventHistory()
イベント履歴情報リスト取得

戻り値:
Returns the eventHistory.

setEventHistory

public void setEventHistory(EventHistoryInfo[] eventHistory)
イベント履歴情報リスト設定

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventNavigatorAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
インタフェース EventNavigatorAccessor

既知の実装クラスの一覧:
StandardEventNavigatorAccessor
public interface EventNavigatorAccessor

イベントナビゲーター管理アクセッサインタフェース。

イベントナビゲーター情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
String | addEventResultItemInfo(EventNavigatorManager manager, String userId, String eventFlowId, EventResultItemInfo resultItemInfo) 保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
void | addFavoriteSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。
EventFlow | copyEventFlow(EventNavigatorManager manager, String eventFllowId) イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
void | deleteEventFlow(EventNavigatorManager manager, String eventFllowId) イベントフローの削除 イベントフローIDから、イベントフローを削除する。
void | deleteSaveResultHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。
EventFlow | getEventFlow(EventNavigatorManager manager, String eventFllowId) イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
String[] | getEventFlowIds(EventNavigatorManager manager) すべてのイベントフローIDを取得します。
EventFlowInfo[] | getEventFlowInfos(EventNavigatorManager manager, String searchTitle, boolean permissionCheck, int currentPage) イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
EventFlow[] | getEventFlows(EventNavigatorManager manager) すべてのイベントフローを取得します。
EventItemInfo | getEventItemInfo(EventNavigatorManager manager, String eventFllowId, String eventItemId) イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
EventResultItemInfo | getEventResultItemInfo(EventNavigatorManager manager, String eventFllowId, String resultItemId) ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
LinkPageInfo | getLinkPageInfo(EventNavigatorManager manager, String eventFlowId, String eventResultId, String resultPageId) 結果ページ情報を取得します。
SaveEventResultItemInfo | getSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
SaveEventResultItemInfo[] | getSaveEventResultItemInfos(EventNavigatorManager manager, String userId, String searchTitle, String sortKey, String oeder, int currentPage) 保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
SaveEventResultItemInfo[] | getSaveEventResultItemInfosHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
LinkPageInfo | getSaveLinkPageInfo(EventNavigatorManager manager, String userId, String eventResultId, String resultPageId) 保存結果ページ情報を取得します。
void | init(String[] args) イベントナビゲーター管理アクセッサの初期化。
void | registEventFlow(EventNavigatorManager manager, EventFlow eventFllow) イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
void | removeSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。
void | setOrderSortNum(EventNavigatorManager manager, EventFlowInfo[] eventFlowInfos) 表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
void | setViewOpen(EventNavigatorManager manager, String eventFlowId, String open) 表示設定 イベントフロー情報に表示／非表示を設定する。
void | updateEventFlow(EventNavigatorManager manager, EventFlow eventFllow) イベントフローの更新 イベントフロー情報をDB更新する。
void | updateEventResultItemInfo(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | updateEventResultItemInfoTitle(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。

メソッドの詳細

init

public void init(String[] args)
イベントナビゲーター管理アクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

getEventFlowInfos

public EventFlowInfo[] getEventFlowInfos(EventNavigatorManager manager,
                                         String searchTitle,
                                         boolean permissionCheck,
                                         int currentPage)
                                  throws EventNavigatorException
イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。

パラメータ:
manager - イベントナビゲータ管理オブジェクト
searchTitle - 検索タイトル
permissionCheck - 権限チェック要否
currentPage - 表示指定頁
戻り値:
イベントフロー情報一覧
例外:
EventNavigatorException - イベントフロー情報一覧取得処理に失敗した場合にスローされます。

deleteEventFlow

public void deleteEventFlow(EventNavigatorManager manager,
                            String eventFllowId)
                     throws EventNavigatorException
イベントフローの削除 イベントフローIDから、イベントフローを削除する。

パラメータ:
eventFllowId - イベントフローID
例外:
EventNavigatorException - イベントフロー削除処理に失敗した場合にスローされます。

getEventFlow

public EventFlow getEventFlow(EventNavigatorManager manager,
                              String eventFllowId)
                       throws EventNavigatorException
イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。

パラメータ:
eventFllowId - イベントフローID
戻り値:
イベントフロー
例外:
EventNavigatorException - イベントフロー取得処理に失敗した場合にスローされます。

getEventFlows

public EventFlow[] getEventFlows(EventNavigatorManager manager)
                          throws EventNavigatorException
すべてのイベントフローを取得します。

パラメータ:
manager -
戻り値:
イベントフローの配列
例外:
EventNavigatorException

registEventFlow

public void registEventFlow(EventNavigatorManager manager,
                            EventFlow eventFllow)
                     throws EventNavigatorException
イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。

パラメータ:
eventFllow - イベントフロー
例外:
EventNavigatorException - イベントフロー登録処理に失敗した場合にスローされます。

copyEventFlow

public EventFlow copyEventFlow(EventNavigatorManager manager,
                               String eventFllowId)
                        throws EventNavigatorException
イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。

パラメータ:
eventFllowId - コピー元イベントフローID
戻り値:
コピー先イベントフロー
例外:
EventNavigatorException - イベントフローコピー処理に失敗した場合にスローされます。

getEventItemInfo

public EventItemInfo getEventItemInfo(EventNavigatorManager manager,
                                      String eventFllowId,
                                      String eventItemId)
                               throws EventNavigatorException
イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。

パラメータ:
eventFllowId - イベントフローID
eventItemId - イベントアイテムID
戻り値:
イベントアイテム情報
例外:
EventNavigatorException - イベントアイテム情報取得処理に失敗した場合にスローされます。

getEventResultItemInfo

public EventResultItemInfo getEventResultItemInfo(EventNavigatorManager manager,
                                                  String eventFllowId,
                                                  String resultItemId)
                                           throws EventNavigatorException
ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。

パラメータ:
eventFllowId - イベントフローID
resultItemId - ナビゲート結果ID
戻り値:
ナビゲート結果情報
例外:
EventNavigatorException - ナビゲート結果情報取得処理に失敗した場合にスローされます。

addEventResultItemInfo

public String addEventResultItemInfo(EventNavigatorManager manager,
                                     String userId,
                                     String eventFlowId,
                                     EventResultItemInfo resultItemInfo)
                              throws EventNavigatorException
保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。

パラメータ:
userId - ユーザID
resultItemInfo - ナビゲート結果情報
戻り値:
保存ナビゲート結果ID
例外:
EventNavigatorException - 保存ナビゲート結果情報（履歴）登録処理に失敗した場合にスローされます。

deleteSaveResultHistory

public void deleteSaveResultHistory(EventNavigatorManager manager,
                                    String userId)
                             throws EventNavigatorException
保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。

パラメータ:
userId - ユーザID
例外:
EventNavigatorException - 保存ナビゲート結果情報（履歴）削除処理に失敗した場合にスローされます。

getSaveEventResultItemInfo

public SaveEventResultItemInfo getSaveEventResultItemInfo(EventNavigatorManager manager,
                                                          String userId,
                                                          String resultItemId)
                                                   throws EventNavigatorException
保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。

パラメータ:
userId - ユーザID
resultItemId - ナビゲート結果ID
戻り値:
保存ナビゲート結果情報
例外:
EventNavigatorException - 保存ナビゲート結果情報取得処理に失敗した場合にスローされます。

updateEventResultItemInfo

public void updateEventResultItemInfo(EventNavigatorManager manager,
                                      String userId,
                                      SaveEventResultItemInfo saveResultItemInfo)
                               throws EventNavigatorException
保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。

パラメータ:
userId - ユーザID
saveResultItemInfo - 保存ナビゲート結果情報
例外:
EventNavigatorException - 保存ナビゲート結果情報（ユーザ）更新処理に失敗した場合にスローされます。

updateEventResultItemInfoTitle

public void updateEventResultItemInfoTitle(EventNavigatorManager manager,
                                           String userId,
                                           SaveEventResultItemInfo saveResultItemInfo)
                                    throws EventNavigatorException
保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。

パラメータ:
userId - ユーザID
saveResultItemInfo - 保存ナビゲート結果情報
例外:
EventNavigatorException - 保存ナビゲート結果情報（ユーザ）更新処理に失敗した場合にスローされます。

getSaveEventResultItemInfos

public SaveEventResultItemInfo[] getSaveEventResultItemInfos(EventNavigatorManager manager,
                                                             String userId,
                                                             String searchTitle,
                                                             String sortKey,
                                                             String oeder,
                                                             int currentPage)
                                                      throws EventNavigatorException
保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。

パラメータ:
userId - ユーザID
searchTitle - 検索タイトル
sortKey - ソートキー
oeder - 昇降指定
currentPage - 表示指定頁
戻り値:
保存ナビゲート結果情報の配列（ユーザ）
例外:
EventNavigatorException - 保存ナビゲート結果情報一覧（ユーザ）取得処理に失敗した場合にスローされます。

removeSaveEventResultItemInfo

public void removeSaveEventResultItemInfo(EventNavigatorManager manager,
                                          String userId,
                                          String resultItemId)
                                   throws EventNavigatorException
保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。

パラメータ:
userId - ユーザID
resultItemId - 保存ナビゲート結果ID
例外:
EventNavigatorException - 保存ナビゲート結果情報削除処理に失敗した場合にスローされます。

addFavoriteSaveEventResultItemInfo

public void addFavoriteSaveEventResultItemInfo(EventNavigatorManager manager,
                                               String userId,
                                               String resultItemId)
                                        throws EventNavigatorException
保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。

パラメータ:
userId - ユーザID
resultItemId - 保存ナビゲート結果ID
例外:
EventNavigatorException - 保存ナビゲート結果情報お気に入りへ追加処理に失敗した場合にスローされます。

getSaveEventResultItemInfosHistory

public SaveEventResultItemInfo[] getSaveEventResultItemInfosHistory(EventNavigatorManager manager,
                                                                    String userId)
                                                             throws EventNavigatorException
保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。

パラメータ:
userId - ユーザID
戻り値:
保存ナビゲート結果情報の配列（履歴）
例外:
EventNavigatorException - 保存ナビゲート結果情報一覧（履歴）取得処理に失敗した場合にスローされます。

updateEventFlow

public void updateEventFlow(EventNavigatorManager manager,
                            EventFlow eventFllow)
                     throws EventNavigatorException
イベントフローの更新 イベントフロー情報をDB更新する。

パラメータ:
eventFllow - イベントフロー
例外:
EventNavigatorException - イベントフロー更新処理に失敗した場合にスローされます。

setOrderSortNum

public void setOrderSortNum(EventNavigatorManager manager,
                            EventFlowInfo[] eventFlowInfos)
                     throws EventNavigatorException
表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。

例外:
EventNavigatorException - 表示順設定処理に失敗した場合にスローされます。

setViewOpen

public void setViewOpen(EventNavigatorManager manager,
                        String eventFlowId,
                        String open)
                 throws EventNavigatorException
表示設定 イベントフロー情報に表示／非表示を設定する。

パラメータ:
eventFlowId - イベントフローID
open - 表示フラグ
例外:
EventNavigatorException - 表示順設定処理に失敗した場合にスローされます。

getEventFlowIds

public String[] getEventFlowIds(EventNavigatorManager manager)
                         throws EventNavigatorException
すべてのイベントフローIDを取得します。

戻り値:
イベントフローIDの配列
例外:
EventNavigatorException

getLinkPageInfo

public LinkPageInfo getLinkPageInfo(EventNavigatorManager manager,
                                    String eventFlowId,
                                    String eventResultId,
                                    String resultPageId)
                             throws EventNavigatorException
結果ページ情報を取得します。

パラメータ:
manager -
eventFlowId - イベントフローID
eventResultId - ナビゲート結果ID
resultPageId - 結果ページID
戻り値:
結果ページ情報
例外:
EventNavigatorException

getSaveLinkPageInfo

public LinkPageInfo getSaveLinkPageInfo(EventNavigatorManager manager,
                                        String userId,
                                        String eventResultId,
                                        String resultPageId)
                                 throws EventNavigatorException
保存結果ページ情報を取得します。

パラメータ:
manager -
userId - ユーザID
eventResultId - ナビゲート結果ID
resultPageId - 結果ページID
戻り値:
保存結果ページ情報
例外:
EventNavigatorException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventNavigatorConst (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventNavigatorConst

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.EventNavigatorConst
public class EventNavigatorConst
extends Object

イベントナビゲーターで使用する定数の一覧

フィールドの概要
static String | ATTRIBUTE_TYPE_HISTORY_COUNT 属性タイプ ：履歴表示件数
static String | COLUMN_NAVIGATOR_ACTION_TYPE
static String | COLUMN_NAVIGATOR_ANSWER
static String | COLUMN_NAVIGATOR_COMPANY_CD
static String | COLUMN_NAVIGATOR_DEPARTMENT_CD
static String | COLUMN_NAVIGATOR_DESCRIPTION
static String | COLUMN_NAVIGATOR_EVENT_FLOW_ID イベントフロー
static String | COLUMN_NAVIGATOR_EVENT_ITEM_ID イベントアイテム
static String | COLUMN_NAVIGATOR_EVENT_RESULT_ID ナビゲート結果
static String | COLUMN_NAVIGATOR_IDENTIFICATION_ID タイトル情報
static String | COLUMN_NAVIGATOR_LOCALE
static String | COLUMN_NAVIGATOR_MAX_SORT_NUM
static String | COLUMN_NAVIGATOR_NEXT_ITEM_ID
static String | COLUMN_NAVIGATOR_OPEN
static String | COLUMN_NAVIGATOR_PAGE_URL
static String | COLUMN_NAVIGATOR_PARAM_KEY ページパラメータ
static String | COLUMN_NAVIGATOR_PARAM_VALUE
static String | COLUMN_NAVIGATOR_PERMISSION_CHECK_FLAG
static String | COLUMN_NAVIGATOR_POST_CD
static String | COLUMN_NAVIGATOR_PUBLIC_GROUP_CD
static String | COLUMN_NAVIGATOR_PUBLIC_GROUP_SET_CD
static String | COLUMN_NAVIGATOR_QUESTION 保存イベント履歴
static String | COLUMN_NAVIGATOR_RECORD_DATE
static String | COLUMN_NAVIGATOR_RECORD_USER 共通
static String | COLUMN_NAVIGATOR_RESULT_PAGE_ID 結果ページ
static String | COLUMN_NAVIGATOR_ROLE_ID 権限情報
static String | COLUMN_NAVIGATOR_SELECT_ITEM_ID 選択アイテム
static String | COLUMN_NAVIGATOR_SORT_NUMBER
static String | COLUMN_NAVIGATOR_START_EVENT_ITEM_ID
static String | COLUMN_NAVIGATOR_TITLE
static String | COLUMN_NAVIGATOR_TYPE
static String | COLUMN_NAVIGATOR_USER_ID 保存ナビゲート結果
static String | CONFIG_FILE
static String | DB_DB2
static String | DB_ORACLE
static String | DB_POSTGRE
static String | DEFAULT_ACCESSOR
static String | DEFAULT_COMMENT
static String | DEFAULT_CONFIG_PAGE_COUNT 履歴表示件数 ：デフォルト件数
static String | DEFAULT_EXPORTER
static String | DEFAULT_IMPORTER
static String | DEFAULT_TITLE
static String | ESCAPE_LEFT_PARENTHESIS
static String | ESCAPE_PERCENTAGE
static String | ESCAPE_RIGHT_PARENTHESIS
static String | ESCAPE_STRING エスケープ文字
static String | ESCAPE_UNDER_SCORE
static String | EVENT_NAVIGATOR_PERMISSION_SELECTOR アクセス権限チェッククラス取得用キー
static String | ID_NAVIGATOR_ACCESS_INFO ACCESS INFO
static String | ID_NAVIGATOR_COMMENT
static String | ID_NAVIGATOR_COMPANY_ID
static String | ID_NAVIGATOR_DEPARTMENT
static String | ID_NAVIGATOR_DEPARTMENT_ID
static String | ID_NAVIGATOR_EVENT_FLOW EVENT FLOW
static String | ID_NAVIGATOR_EVENT_FLOW_ID
static String | ID_NAVIGATOR_EVENT_FLOW_OPEN
static String | ID_NAVIGATOR_EVENT_FLOW_SORT_NUMBER
static String | ID_NAVIGATOR_EVENT_ITEM EVENT ITEM
static String | ID_NAVIGATOR_EVENT_ITEM_ID
static String | ID_NAVIGATOR_EVENT_RESULT EVENT RESULT
static String | ID_NAVIGATOR_EVENT_RESULT_ID
static String | ID_NAVIGATOR_GROUP_ID
static String | ID_NAVIGATOR_GROUP_SET_ID
static String | ID_NAVIGATOR_ITEM_TYPE
static String | ID_NAVIGATOR_LINK_PAGE LINK PAGE
static String | ID_NAVIGATOR_LOCALE
static String | ID_NAVIGATOR_PARAM
static String | ID_NAVIGATOR_PARAM_KEY
static String | ID_NAVIGATOR_PARAM_VALUE
static String | ID_NAVIGATOR_POST
static String | ID_NAVIGATOR_POST_ID
static String | ID_NAVIGATOR_PUBLIC_GROUP
static String | ID_NAVIGATOR_RESULT_PAGE RESULT PAGE
static String | ID_NAVIGATOR_RESULT_PAGE_ID
static String | ID_NAVIGATOR_RESULT_PAGE_LIST
static String | ID_NAVIGATOR_ROLE
static String | ID_NAVIGATOR_ROLE_ID
static String | ID_NAVIGATOR_SELECT_ITEM SELECT ITEM
static String | ID_NAVIGATOR_SELECT_ITEM_ID
static String | ID_NAVIGATOR_SELECT_ITEM_LIST
static String | ID_NAVIGATOR_TITLE
static String | ID_NAVIGATOR_TITLE_INFO TITLE INFO
static String | ID_NAVIGATOR_URL
static String | ID_ROOT
static String | ID_ROOT_NAVIGATOR
static String | KIND_NAVIGATOR 種別 イベントナビゲーター
static String | OPEN_FLG_CLOSE 公開フラグ：非公開
static String | OPEN_FLG_EDIT 公開フラグ：編集中
static String | OPEN_FLG_OPEN 公開フラグ：公開
static String | ROOT_FOLDER
static String | SAVE_TYPE_FAVORITE ナビゲート結果保存タイプ：お気に入り
static String | SAVE_TYPE_HISTORY ナビゲート結果保存タイプ：履歴
static String | TABLE_B_M_EVENT_DEPARTMENT
static String | TABLE_B_M_EVENT_FLOW
static String | TABLE_B_M_EVENT_ITEM
static String | TABLE_B_M_EVENT_PAGE
static String | TABLE_B_M_EVENT_PAGE_PARAM
static String | TABLE_B_M_EVENT_POST
static String | TABLE_B_M_EVENT_PUBLIC_GROUP
static String | TABLE_B_M_EVENT_RESULT
static String | TABLE_B_M_EVENT_ROLE
static String | TABLE_B_M_EVENT_SAVE_RESULT
static String | TABLE_B_M_EVENT_SELECT
static String | TABLE_B_M_EVENT_TITLE_INFO
static String | TYPE_EVENT 遷移先タイプ：イベントアイテム
static String | TYPE_RESULT 遷移先タイプ：ナビゲート結果
コンストラクタの概要
EventNavigatorConst()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KIND_NAVIGATOR

public static final String KIND_NAVIGATOR
種別 イベントナビゲーター

関連項目:
定数フィールド値

TYPE_EVENT

public static final String TYPE_EVENT
遷移先タイプ：イベントアイテム

関連項目:
定数フィールド値

TYPE_RESULT

public static final String TYPE_RESULT
遷移先タイプ：ナビゲート結果

関連項目:
定数フィールド値

SAVE_TYPE_FAVORITE

public static final String SAVE_TYPE_FAVORITE
ナビゲート結果保存タイプ：お気に入り

関連項目:
定数フィールド値

SAVE_TYPE_HISTORY

public static final String SAVE_TYPE_HISTORY
ナビゲート結果保存タイプ：履歴

関連項目:
定数フィールド値

DEFAULT_CONFIG_PAGE_COUNT

public static final String DEFAULT_CONFIG_PAGE_COUNT
履歴表示件数 ：デフォルト件数

関連項目:
定数フィールド値

ATTRIBUTE_TYPE_HISTORY_COUNT

public static final String ATTRIBUTE_TYPE_HISTORY_COUNT
属性タイプ ：履歴表示件数

関連項目:
定数フィールド値

EVENT_NAVIGATOR_PERMISSION_SELECTOR

public static final String EVENT_NAVIGATOR_PERMISSION_SELECTOR
アクセス権限チェッククラス取得用キー

関連項目:
定数フィールド値

OPEN_FLG_OPEN

public static final String OPEN_FLG_OPEN
公開フラグ：公開

関連項目:
定数フィールド値

OPEN_FLG_CLOSE

public static final String OPEN_FLG_CLOSE
公開フラグ：非公開

関連項目:
定数フィールド値

OPEN_FLG_EDIT

public static final String OPEN_FLG_EDIT
公開フラグ：編集中

関連項目:
定数フィールド値

DEFAULT_ACCESSOR

public static final String DEFAULT_ACCESSOR
関連項目:
定数フィールド値

DEFAULT_IMPORTER

public static final String DEFAULT_IMPORTER
関連項目:
定数フィールド値

DEFAULT_EXPORTER

public static final String DEFAULT_EXPORTER
関連項目:
定数フィールド値

ROOT_FOLDER

public static final String ROOT_FOLDER
関連項目:
定数フィールド値

CONFIG_FILE

public static final String CONFIG_FILE
関連項目:
定数フィールド値

DEFAULT_TITLE

public static final String DEFAULT_TITLE
関連項目:
定数フィールド値

DEFAULT_COMMENT

public static final String DEFAULT_COMMENT
関連項目:
定数フィールド値

TABLE_B_M_EVENT_FLOW

public static final String TABLE_B_M_EVENT_FLOW
関連項目:
定数フィールド値

TABLE_B_M_EVENT_ITEM

public static final String TABLE_B_M_EVENT_ITEM
関連項目:
定数フィールド値

TABLE_B_M_EVENT_SELECT

public static final String TABLE_B_M_EVENT_SELECT
関連項目:
定数フィールド値

TABLE_B_M_EVENT_RESULT

public static final String TABLE_B_M_EVENT_RESULT
関連項目:
定数フィールド値

TABLE_B_M_EVENT_PAGE

public static final String TABLE_B_M_EVENT_PAGE
関連項目:
定数フィールド値

TABLE_B_M_EVENT_PAGE_PARAM

public static final String TABLE_B_M_EVENT_PAGE_PARAM
関連項目:
定数フィールド値

TABLE_B_M_EVENT_TITLE_INFO

public static final String TABLE_B_M_EVENT_TITLE_INFO
関連項目:
定数フィールド値

TABLE_B_M_EVENT_ROLE

public static final String TABLE_B_M_EVENT_ROLE
関連項目:
定数フィールド値

TABLE_B_M_EVENT_DEPARTMENT

public static final String TABLE_B_M_EVENT_DEPARTMENT
関連項目:
定数フィールド値

TABLE_B_M_EVENT_POST

public static final String TABLE_B_M_EVENT_POST
関連項目:
定数フィールド値

TABLE_B_M_EVENT_PUBLIC_GROUP

public static final String TABLE_B_M_EVENT_PUBLIC_GROUP
関連項目:
定数フィールド値

TABLE_B_M_EVENT_SAVE_RESULT

public static final String TABLE_B_M_EVENT_SAVE_RESULT
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_RECORD_USER

public static final String COLUMN_NAVIGATOR_RECORD_USER
共通

関連項目:
定数フィールド値

COLUMN_NAVIGATOR_RECORD_DATE

public static final String COLUMN_NAVIGATOR_RECORD_DATE
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_EVENT_FLOW_ID

public static final String COLUMN_NAVIGATOR_EVENT_FLOW_ID
イベントフロー

関連項目:
定数フィールド値

COLUMN_NAVIGATOR_START_EVENT_ITEM_ID

public static final String COLUMN_NAVIGATOR_START_EVENT_ITEM_ID
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_OPEN

public static final String COLUMN_NAVIGATOR_OPEN
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_SORT_NUMBER

public static final String COLUMN_NAVIGATOR_SORT_NUMBER
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_MAX_SORT_NUM

public static final String COLUMN_NAVIGATOR_MAX_SORT_NUM
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_PERMISSION_CHECK_FLAG

public static final String COLUMN_NAVIGATOR_PERMISSION_CHECK_FLAG
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_EVENT_ITEM_ID

public static final String COLUMN_NAVIGATOR_EVENT_ITEM_ID
イベントアイテム

関連項目:
定数フィールド値

COLUMN_NAVIGATOR_SELECT_ITEM_ID

public static final String COLUMN_NAVIGATOR_SELECT_ITEM_ID
選択アイテム

関連項目:
定数フィールド値

COLUMN_NAVIGATOR_ACTION_TYPE

public static final String COLUMN_NAVIGATOR_ACTION_TYPE
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_NEXT_ITEM_ID

public static final String COLUMN_NAVIGATOR_NEXT_ITEM_ID
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_EVENT_RESULT_ID

public static final String COLUMN_NAVIGATOR_EVENT_RESULT_ID
ナビゲート結果

関連項目:
定数フィールド値

COLUMN_NAVIGATOR_RESULT_PAGE_ID

public static final String COLUMN_NAVIGATOR_RESULT_PAGE_ID
結果ページ

関連項目:
定数フィールド値

COLUMN_NAVIGATOR_PAGE_URL

public static final String COLUMN_NAVIGATOR_PAGE_URL
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_PARAM_KEY

public static final String COLUMN_NAVIGATOR_PARAM_KEY
ページパラメータ

関連項目:
定数フィールド値

COLUMN_NAVIGATOR_PARAM_VALUE

public static final String COLUMN_NAVIGATOR_PARAM_VALUE
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_IDENTIFICATION_ID

public static final String COLUMN_NAVIGATOR_IDENTIFICATION_ID
タイトル情報

関連項目:
定数フィールド値

COLUMN_NAVIGATOR_LOCALE

public static final String COLUMN_NAVIGATOR_LOCALE
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_TITLE

public static final String COLUMN_NAVIGATOR_TITLE
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_DESCRIPTION

public static final String COLUMN_NAVIGATOR_DESCRIPTION
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_ROLE_ID

public static final String COLUMN_NAVIGATOR_ROLE_ID
権限情報

関連項目:
定数フィールド値

COLUMN_NAVIGATOR_COMPANY_CD

public static final String COLUMN_NAVIGATOR_COMPANY_CD
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_DEPARTMENT_CD

public static final String COLUMN_NAVIGATOR_DEPARTMENT_CD
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_POST_CD

public static final String COLUMN_NAVIGATOR_POST_CD
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_PUBLIC_GROUP_SET_CD

public static final String COLUMN_NAVIGATOR_PUBLIC_GROUP_SET_CD
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_PUBLIC_GROUP_CD

public static final String COLUMN_NAVIGATOR_PUBLIC_GROUP_CD
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_USER_ID

public static final String COLUMN_NAVIGATOR_USER_ID
保存ナビゲート結果

関連項目:
定数フィールド値

COLUMN_NAVIGATOR_TYPE

public static final String COLUMN_NAVIGATOR_TYPE
関連項目:
定数フィールド値

COLUMN_NAVIGATOR_QUESTION

public static final String COLUMN_NAVIGATOR_QUESTION
保存イベント履歴

関連項目:
定数フィールド値

COLUMN_NAVIGATOR_ANSWER

public static final String COLUMN_NAVIGATOR_ANSWER
関連項目:
定数フィールド値

ESCAPE_STRING

public static final String ESCAPE_STRING
エスケープ文字

関連項目:
定数フィールド値

ESCAPE_UNDER_SCORE

public static final String ESCAPE_UNDER_SCORE
関連項目:
定数フィールド値

ESCAPE_PERCENTAGE

public static final String ESCAPE_PERCENTAGE
関連項目:
定数フィールド値

ESCAPE_LEFT_PARENTHESIS

public static final String ESCAPE_LEFT_PARENTHESIS
関連項目:
定数フィールド値

ESCAPE_RIGHT_PARENTHESIS

public static final String ESCAPE_RIGHT_PARENTHESIS
関連項目:
定数フィールド値

DB_ORACLE

public static final String DB_ORACLE
関連項目:
定数フィールド値

DB_DB2

public static final String DB_DB2
関連項目:
定数フィールド値

DB_POSTGRE

public static final String DB_POSTGRE
関連項目:
定数フィールド値

ID_ROOT

public static final String ID_ROOT
関連項目:
定数フィールド値

ID_ROOT_NAVIGATOR

public static final String ID_ROOT_NAVIGATOR
関連項目:
定数フィールド値

ID_NAVIGATOR_EVENT_FLOW

public static final String ID_NAVIGATOR_EVENT_FLOW
EVENT FLOW

関連項目:
定数フィールド値

ID_NAVIGATOR_EVENT_FLOW_ID

public static final String ID_NAVIGATOR_EVENT_FLOW_ID
関連項目:
定数フィールド値

ID_NAVIGATOR_EVENT_FLOW_OPEN

public static final String ID_NAVIGATOR_EVENT_FLOW_OPEN
関連項目:
定数フィールド値

ID_NAVIGATOR_EVENT_FLOW_SORT_NUMBER

public static final String ID_NAVIGATOR_EVENT_FLOW_SORT_NUMBER
関連項目:
定数フィールド値

ID_NAVIGATOR_EVENT_ITEM

public static final String ID_NAVIGATOR_EVENT_ITEM
EVENT ITEM

関連項目:
定数フィールド値

ID_NAVIGATOR_EVENT_ITEM_ID

public static final String ID_NAVIGATOR_EVENT_ITEM_ID
関連項目:
定数フィールド値

ID_NAVIGATOR_SELECT_ITEM_LIST

public static final String ID_NAVIGATOR_SELECT_ITEM_LIST
関連項目:
定数フィールド値

ID_NAVIGATOR_SELECT_ITEM

public static final String ID_NAVIGATOR_SELECT_ITEM
SELECT ITEM

関連項目:
定数フィールド値

ID_NAVIGATOR_SELECT_ITEM_ID

public static final String ID_NAVIGATOR_SELECT_ITEM_ID
関連項目:
定数フィールド値

ID_NAVIGATOR_ITEM_TYPE

public static final String ID_NAVIGATOR_ITEM_TYPE
関連項目:
定数フィールド値

ID_NAVIGATOR_EVENT_RESULT

public static final String ID_NAVIGATOR_EVENT_RESULT
EVENT RESULT

関連項目:
定数フィールド値

ID_NAVIGATOR_EVENT_RESULT_ID

public static final String ID_NAVIGATOR_EVENT_RESULT_ID
関連項目:
定数フィールド値

ID_NAVIGATOR_RESULT_PAGE_LIST

public static final String ID_NAVIGATOR_RESULT_PAGE_LIST
関連項目:
定数フィールド値

ID_NAVIGATOR_RESULT_PAGE

public static final String ID_NAVIGATOR_RESULT_PAGE
RESULT PAGE

関連項目:
定数フィールド値

ID_NAVIGATOR_RESULT_PAGE_ID

public static final String ID_NAVIGATOR_RESULT_PAGE_ID
関連項目:
定数フィールド値

ID_NAVIGATOR_LINK_PAGE

public static final String ID_NAVIGATOR_LINK_PAGE
LINK PAGE

関連項目:
定数フィールド値

ID_NAVIGATOR_URL

public static final String ID_NAVIGATOR_URL
関連項目:
定数フィールド値

ID_NAVIGATOR_PARAM

public static final String ID_NAVIGATOR_PARAM
関連項目:
定数フィールド値

ID_NAVIGATOR_PARAM_KEY

public static final String ID_NAVIGATOR_PARAM_KEY
関連項目:
定数フィールド値

ID_NAVIGATOR_PARAM_VALUE

public static final String ID_NAVIGATOR_PARAM_VALUE
関連項目:
定数フィールド値

ID_NAVIGATOR_TITLE_INFO

public static final String ID_NAVIGATOR_TITLE_INFO
TITLE INFO

関連項目:
定数フィールド値

ID_NAVIGATOR_LOCALE

public static final String ID_NAVIGATOR_LOCALE
関連項目:
定数フィールド値

ID_NAVIGATOR_TITLE

public static final String ID_NAVIGATOR_TITLE
関連項目:
定数フィールド値

ID_NAVIGATOR_COMMENT

public static final String ID_NAVIGATOR_COMMENT
関連項目:
定数フィールド値

ID_NAVIGATOR_ACCESS_INFO

public static final String ID_NAVIGATOR_ACCESS_INFO
ACCESS INFO

関連項目:
定数フィールド値

ID_NAVIGATOR_ROLE

public static final String ID_NAVIGATOR_ROLE
関連項目:
定数フィールド値

ID_NAVIGATOR_ROLE_ID

public static final String ID_NAVIGATOR_ROLE_ID
関連項目:
定数フィールド値

ID_NAVIGATOR_DEPARTMENT

public static final String ID_NAVIGATOR_DEPARTMENT
関連項目:
定数フィールド値

ID_NAVIGATOR_DEPARTMENT_ID

public static final String ID_NAVIGATOR_DEPARTMENT_ID
関連項目:
定数フィールド値

ID_NAVIGATOR_COMPANY_ID

public static final String ID_NAVIGATOR_COMPANY_ID
関連項目:
定数フィールド値

ID_NAVIGATOR_POST

public static final String ID_NAVIGATOR_POST
関連項目:
定数フィールド値

ID_NAVIGATOR_POST_ID

public static final String ID_NAVIGATOR_POST_ID
関連項目:
定数フィールド値

ID_NAVIGATOR_PUBLIC_GROUP

public static final String ID_NAVIGATOR_PUBLIC_GROUP
関連項目:
定数フィールド値

ID_NAVIGATOR_GROUP_ID

public static final String ID_NAVIGATOR_GROUP_ID
関連項目:
定数フィールド値

ID_NAVIGATOR_GROUP_SET_ID

public static final String ID_NAVIGATOR_GROUP_SET_ID
関連項目:
定数フィールド値
コンストラクタの詳細

EventNavigatorConst

public EventNavigatorConst()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventNavigatorException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventNavigatorException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.navigator.EventNavigatorException
すべての実装インタフェース:
Serializable
public class EventNavigatorException
extends DataStoreApplicationException

イベントナビゲータマネージャに関する例外クラス

導入されたバージョン:
6.1
関連項目:
直列化された形式

コンストラクタの概要
EventNavigatorException()
コンストラクタ
EventNavigatorException(String message)
コンストラクタ
EventNavigatorException(String message, Throwable cause)
コンストラクタ
EventNavigatorException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EventNavigatorException

public EventNavigatorException()
コンストラクタ

EventNavigatorException

public EventNavigatorException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

EventNavigatorException

public EventNavigatorException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

EventNavigatorException

public EventNavigatorException(String message,
                               Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventNavigatorExporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
インタフェース EventNavigatorExporter

既知の実装クラスの一覧:
StandardEventNavigatorExporter
public interface EventNavigatorExporter

イベントナビゲータバックアップインタフェースです。

バージョン:
1.0

メソッドの概要
void | doExport(EventNavigatorManager manager, OutputStream outputStream, boolean editFlag) エクスポートを行います。
void | init(String[] args) イベントナビゲータバックアップエクスポータの初期化。

メソッドの詳細

init

public void init(String[] args)
イベントナビゲータバックアップエクスポータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

doExport

public void doExport(EventNavigatorManager manager,
                     OutputStream outputStream,
                     boolean editFlag)
              throws EventNavigatorException
エクスポートを行います。

イベントナビゲータ情報をバックアップファイルに出力します。

パラメータ:
manager - イベントナビゲータマネージャ イベントナビゲータモデルクラスの配列
outputStream - 出力ストリーム
例外:
EventNavigatorException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventNavigatorHandler (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventNavigatorHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.EventNavigatorHandler
public class EventNavigatorHandler
extends Object

コンストラクタの概要
EventNavigatorHandler()
メソッドの概要
static String getMessage(String key, String arg)
メッセージの取得。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventNavigatorHandler

public EventNavigatorHandler()
メソッドの詳細

getMessage

public static String getMessage(String key,
                                String arg)
メッセージの取得。

パラメータ:
key - メッセージのキー
arg - メッセージパラメータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventNavigatorImporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
インタフェース EventNavigatorImporter

既知の実装クラスの一覧:
StandardEventNavigatorImporter
public interface EventNavigatorImporter

イベントナビゲータバックアップインタフェースです。

バージョン:
1.0

メソッドの概要
void | doImport(EventNavigatorManager manager, InputStream inputStream) インポートを行います。
void | init(String[] args) イベントナビゲータバックアップインポータの初期化。

メソッドの詳細

init

public void init(String[] args)
イベントナビゲータバックアップインポータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

doImport

public void doImport(EventNavigatorManager manager,
                     InputStream inputStream)
              throws EventNavigatorException
インポートを行います。

ストリーム内の情報からイベントナビゲータ情報を取得し、生成します。

パラメータ:
manager - イベントナビゲータマネージャクラス
inputStream - 入力ストリーム
例外:
EventNavigatorException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventNavigatorManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventNavigatorManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.EventNavigatorManager
public class EventNavigatorManager
extends Object

イベントナビゲーター管理マネージャクラス。

イベントナビゲーター情報に関連する操作を行います。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
EventNavigatorManager(String groupId, String locale)
コンストラクタ。
メソッドの概要
String | addEventResultItemInfo(String userId, String eventFlowId, EventResultItemInfo resultItemInfo) 保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
void | addFavoriteSaveEventResultItemInfo(String userId, String resultItemId) 保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。
EventFlow | copyEventFlow(String eventFllowId) イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
void | deleteEventFlow(String eventFlowId) イベントフローの削除 イベントフローIDから、イベントフローを削除する。
void | deleteSaveResultHistory(String userId) 保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。
void | exportData(OutputStream outputStream, boolean editFlag) エクスポートを行います。
String | getConfigPageCount(String userId) 履歴表示件数の取得。
EventFlow | getEventFlow(String eventFllowId) イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
EventFlowInfo[] | getEventFlowInfos(String searchTitle, boolean permissionCheck, int currentPage) イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
EventFlow[] | getEventFlows() イベントフローの取得（全件） 全イベントフローを取得し、返却する。
EventItemInfo | getEventItemInfo(String eventFllowId, String eventItemId) イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
EventResultItemInfo | getEventResultItemInfo(String eventFllowId, String resultItemId) ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
LinkPageInfo | getLinkPageInfo(String eventFlowId, String eventResultId, String resultPageId) 結果ページ情報を取得します。
String | getLocale() ロケールを取得します。
String | getLoginGroupId() ログイングループIDを取得します。
SaveEventResultItemInfo | getSaveEventResultItemInfo(String userId, String resultItemId) 保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
SaveEventResultItemInfo[] | getSaveEventResultItemInfos(String searchTitle, String userId, String sortKey, String oeder, int currentPage) 保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
SaveEventResultItemInfo[] | getSaveEventResultItemInfosHistory(String userId) 保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
LinkPageInfo | getSaveLinkPageInfo(String userId, String eventResultId, String resultPageId) 保存結果ページ情報を取得します。
void | importData(InputStream inputStream) インポートを行います。
void | registEventFlow(EventFlow eventFllow) イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
void | removeSaveEventResultItemInfo(String userId, String resultItemId) 保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。
void | setConfigPageCount(String userId, int iCount) 履歴表示件数の設定。
void | setOrderSortNum(EventFlowInfo[] eventFlowInfos) 表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
void | setViewOpen(String eventFlowId, String open) 表示設定 イベントフロー情報に表示／非表示を設定する。
void | updateEventFlow(EventFlow eventFllow) イベントフローの更新 イベントフロー情報をDB更新する。
void | updateEventResultItemInfo(String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | updateEventResultItemInfoTitle(String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventNavigatorManager

public EventNavigatorManager(String groupId,
                             String locale)
                      throws EventNavigatorException
コンストラクタ。

パラメータ:
groupId - ログイングループID
locale - ロケール
メソッドの詳細

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

戻り値:
ログイングループID

getLocale

public String getLocale()
ロケールを取得します。

戻り値:
ロケール

getEventFlowInfos

public EventFlowInfo[] getEventFlowInfos(String searchTitle,
                                         boolean permissionCheck,
                                         int currentPage)
                                  throws EventNavigatorException
イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。

パラメータ:
searchTitle - 検索タイトル
permissionCheck - 権限チェック要否
currentPage - 表示指定頁
戻り値:
イベントフロー情報一覧
例外:
EventNavigatorException - イベントフロー情報一覧取得処理に失敗した場合にスローされます。

deleteEventFlow

public void deleteEventFlow(String eventFlowId)
                     throws EventNavigatorException
イベントフローの削除 イベントフローIDから、イベントフローを削除する。

例外:
EventNavigatorException - イベントフロー削除処理に失敗した場合にスローされます。

getEventFlow

public EventFlow getEventFlow(String eventFllowId)
                       throws EventNavigatorException
イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。

パラメータ:
eventFllowId - イベントフローID
戻り値:
イベントフロー
例外:
EventNavigatorException - イベントフロー取得処理に失敗した場合にスローされます。

getEventFlows

public EventFlow[] getEventFlows()
                          throws EventNavigatorException
イベントフローの取得（全件） 全イベントフローを取得し、返却する。

戻り値:
イベントフローの配列
例外:
EventNavigatorException - イベントフロー取得処理に失敗した場合にスローされます。

registEventFlow

public void registEventFlow(EventFlow eventFllow)
                     throws EventNavigatorException
イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。

パラメータ:
eventFllow - イベントフロー
例外:
EventNavigatorException - イベントフロー登録処理に失敗した場合にスローされます。

copyEventFlow

public EventFlow copyEventFlow(String eventFllowId)
                        throws EventNavigatorException
イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。

パラメータ:
eventFllowId - コピー元イベントフローID
戻り値:
コピー先イベントフロー
例外:
EventNavigatorException - イベントフローコピー処理に失敗した場合にスローされます。

getEventItemInfo

public EventItemInfo getEventItemInfo(String eventFllowId,
                                      String eventItemId)
                               throws EventNavigatorException
イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。

パラメータ:
eventFllowId - イベントフローID
eventItemId - イベントアイテムID
戻り値:
イベントアイテム情報
例外:
EventNavigatorException - イベントアイテム情報取得処理に失敗した場合にスローされます。

getEventResultItemInfo

public EventResultItemInfo getEventResultItemInfo(String eventFllowId,
                                                  String resultItemId)
                                           throws EventNavigatorException
ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。

パラメータ:
eventFllowId - イベントフローID
resultItemId - ナビゲート結果ID
戻り値:
ナビゲート結果情報
例外:
EventNavigatorException - ナビゲート結果情報取得処理に失敗した場合にスローされます。

addEventResultItemInfo

public String addEventResultItemInfo(String userId,
                                     String eventFlowId,
                                     EventResultItemInfo resultItemInfo)
                              throws EventNavigatorException
保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。

パラメータ:
userId - ユーザID
resultItemInfo - ナビゲート結果情報
戻り値:
保存ナビゲート結果ID
例外:
EventNavigatorException - 保存ナビゲート結果情報（履歴）登録処理に失敗した場合にスローされます。

deleteSaveResultHistory

public void deleteSaveResultHistory(String userId)
                             throws EventNavigatorException
保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。

パラメータ:
userId - ユーザID
例外:
EventNavigatorException - 保存ナビゲート結果情報（履歴）削除処理に失敗した場合にスローされます。

getSaveEventResultItemInfo

public SaveEventResultItemInfo getSaveEventResultItemInfo(String userId,
                                                          String resultItemId)
                                                   throws EventNavigatorException
保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。

パラメータ:
userId - ユーザID
resultItemId - ナビゲート結果ID
戻り値:
保存ナビゲート結果情報
例外:
EventNavigatorException - 保存ナビゲート結果情報取得処理に失敗した場合にスローされます。

updateEventResultItemInfo

public void updateEventResultItemInfo(String userId,
                                      SaveEventResultItemInfo saveResultItemInfo)
                               throws EventNavigatorException
保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。

パラメータ:
userId - ユーザID
saveResultItemInfo - 保存ナビゲート結果情報
例外:
EventNavigatorException - 保存ナビゲート結果情報更新（ユーザ）処理に失敗した場合にスローされます。

updateEventResultItemInfoTitle

public void updateEventResultItemInfoTitle(String userId,
                                           SaveEventResultItemInfo saveResultItemInfo)
                                    throws EventNavigatorException
保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。

パラメータ:
userId - ユーザID
saveResultItemInfo - 保存ナビゲート結果情報
例外:
EventNavigatorException - 保存ナビゲート結果情報更新（ユーザ）処理に失敗した場合にスローされます。

getSaveEventResultItemInfos

public SaveEventResultItemInfo[] getSaveEventResultItemInfos(String searchTitle,
                                                             String userId,
                                                             String sortKey,
                                                             String oeder,
                                                             int currentPage)
                                                      throws EventNavigatorException
保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。

パラメータ:
searchTitle - 検索タイトル
userId - ユーザID
sortKey - ソートキー
oeder - 昇降指定
currentPage - 表示指定頁
戻り値:
保存ナビゲート結果情報の配列（ユーザ）
例外:
EventNavigatorException - 保存ナビゲート結果情報一覧（ユーザ）取得処理に失敗した場合にスローされます。

removeSaveEventResultItemInfo

public void removeSaveEventResultItemInfo(String userId,
                                          String resultItemId)
                                   throws EventNavigatorException
保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。

パラメータ:
userId - ユーザID
resultItemId - 保存ナビゲート結果ID
例外:
EventNavigatorException - 保存ナビゲート結果情報削除処理に失敗した場合にスローされます。

addFavoriteSaveEventResultItemInfo

public void addFavoriteSaveEventResultItemInfo(String userId,
                                               String resultItemId)
                                        throws EventNavigatorException
保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。

パラメータ:
userId - ユーザID
resultItemId - 保存ナビゲート結果ID
例外:
EventNavigatorException - 保存ナビゲート結果情報お気に入りへ追加処理に失敗した場合にスローされます。

getSaveEventResultItemInfosHistory

public SaveEventResultItemInfo[] getSaveEventResultItemInfosHistory(String userId)
                                                             throws EventNavigatorException
保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。

パラメータ:
userId - ユーザID
戻り値:
保存ナビゲート結果情報の配列（履歴）
例外:
EventNavigatorException - 保存ナビゲート結果情報一覧（履歴）取得処理に失敗した場合にスローされます。

updateEventFlow

public void updateEventFlow(EventFlow eventFllow)
                     throws EventNavigatorException
イベントフローの更新 イベントフロー情報をDB更新する。

パラメータ:
eventFllow - イベントフロー
例外:
EventNavigatorException - イベントフロー更新処理に失敗した場合にスローされます。

setOrderSortNum

public void setOrderSortNum(EventFlowInfo[] eventFlowInfos)
                     throws EventNavigatorException
表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。

例外:
EventNavigatorException - 表示順設定処理に失敗した場合にスローされます。

setViewOpen

public void setViewOpen(String eventFlowId,
                        String open)
                 throws EventNavigatorException
表示設定 イベントフロー情報に表示／非表示を設定する。

パラメータ:
eventFlowId - イベントフローID
open - 表示フラグ
例外:
EventNavigatorException - 表示順設定処理に失敗した場合にスローされます。

importData

public void importData(InputStream inputStream)
                throws EventNavigatorException
インポートを行います。

パラメータ:
inputStream - 入力ストリーム
例外:
EventNavigatorException - インポートに失敗した場合、または引数が不正だった場合にスローされます。

exportData

public void exportData(OutputStream outputStream,
                       boolean editFlag)
                throws EventNavigatorException
エクスポートを行います。

パラメータ:
outputStream - 出力ストリーム
例外:
EventNavigatorException - エクスポートに失敗した場合、または引数が不正だった場合にスローされます。

getLinkPageInfo

public LinkPageInfo getLinkPageInfo(String eventFlowId,
                                    String eventResultId,
                                    String resultPageId)
                             throws EventNavigatorException
結果ページ情報を取得します。

パラメータ:
eventFlowId - イベントフローID
eventResultId - ナビゲート結果ID
resultPageId - 結果ページID
戻り値:
結果ページ情報
例外:
EventNavigatorException

getSaveLinkPageInfo

public LinkPageInfo getSaveLinkPageInfo(String userId,
                                        String eventResultId,
                                        String resultPageId)
                                 throws EventNavigatorException
保存結果ページ情報を取得します。

パラメータ:
userId - ユーザID
eventResultId - ナビゲート結果ID
resultPageId - 結果ページID
戻り値:
保存結果ページ情報
例外:
EventNavigatorException

getConfigPageCount

public String getConfigPageCount(String userId)
                          throws EventNavigatorException
履歴表示件数の取得。

パラメータ:
userId - ユーザID
例外:
EventNavigatorException - 履歴表示件数の取得に失敗した場合にスローされます。

setConfigPageCount

public void setConfigPageCount(String userId,
                               int iCount)
                        throws EventNavigatorException
履歴表示件数の設定。

パラメータ:
userId - ユーザID
iCount - 履歴表示件数
例外:
EventNavigatorException - 履歴表示件数の設定に失敗した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventNavigatorPermissionSelector (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventNavigatorPermissionSelector

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.EventNavigatorPermissionSelector
すべての実装インタフェース:
PermissionSelector
public class EventNavigatorPermissionSelector
extends Object
implements PermissionSelector

ユーザIDから有効なID一覧を取得するセレクタ。

選択条件としてのユーザIDからアクセス可能なイベントフロー、選択アイテム、結果ページの固有IDを選択します。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
EventNavigatorPermissionSelector()
コンストラクタ。
メソッドの概要
Collection | doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
void | init(Map param) インスタンスの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventNavigatorPermissionSelector

public EventNavigatorPermissionSelector()
コンストラクタ。

メソッドの詳細

doSelection

public Collection doSelection(String groupId,
                              String[] infos)
                       throws AccessSecurityException
選択用情報を利用して選別された情報のリストを返却します。
返却される情報のリストの各要素はJavaBeansの規格に準ずるオブジェクトでなければなりません。

定義:
インタフェース PermissionSelector 内の doSelection
パラメータ:
groupId - ログイングループID
infos - 選択用情報(配列)
この情報を利用して、選別された情報のリストを作成して返却します。
戻り値:
選別された情報のリスト
例外:
AccessSecurityException

init

public void init(Map param)
インスタンスの初期化を行います。
このインスタンスが生成された時に1度だけコールされます。

定義:
インタフェース PermissionSelector 内の init
パラメータ:
param - XMLで定義されたPermissionSelectorに関連付けられたパラメータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventNavigatorReaderDecorator (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
インタフェース EventNavigatorReaderDecorator

public interface EventNavigatorReaderDecorator

メソッドの概要
Object | doDecoration(EventNavigatorManager manager, Object obj) イベントナビゲータのオブジェクト情報をデータストアからの読み込み直後にコールされます。
void | init(String[] args) イベントナビゲータデコレータの初期化。

メソッドの詳細

init

public void init(String[] args)
イベントナビゲータデコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

doDecoration

public Object doDecoration(EventNavigatorManager manager,
                           Object obj)
イベントナビゲータのオブジェクト情報をデータストアからの読み込み直後にコールされます。

パラメータ:
manager - イベントナビゲータ管理オブジェクト
obj - 読み込みが行われた イベントナビゲータのオブジェクト情報
戻り値:
拡張された イベントナビゲータのオブジェクト情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventResultItem (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventResultItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.NavigatorItem
        拡張 jp.co.intra_mart.foundation.navigator.EventResultItem
すべての実装インタフェース:
Serializable
public class EventResultItem
extends NavigatorItem

ナビゲート結果クラス

関連項目:
直列化された形式

コンストラクタの概要
EventResultItem()
メソッドの概要
void | addPage(ResultPageItem page) リンクページ情報追加
ResultPageItem[] | getPageItem()
void | setPageItem(ResultPageItem[] pageItem)
クラス jp.co.intra_mart.foundation.navigator.NavigatorItem から継承したメソッド
getKeys, getTitleInfo, removeTitleInfo, setTitleInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventResultItem

public EventResultItem()
メソッドの詳細

getPageItem

public ResultPageItem[] getPageItem()
戻り値:
pageItem を戻します。

setPageItem

public void setPageItem(ResultPageItem[] pageItem)
パラメータ:
pageItem - 設定する pageItem。

addPage

public void addPage(ResultPageItem page)
リンクページ情報追加

パラメータ:
page - 追加するリンクページ情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventResultItemInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス EventResultItemInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.TitleInfo
        拡張 jp.co.intra_mart.foundation.navigator.EventResultItemInfo
すべての実装インタフェース:
Serializable
public class EventResultItemInfo
extends TitleInfo

ナビゲート結果情報

関連項目:
直列化された形式

コンストラクタの概要
EventResultItemInfo()
メソッドの概要
EventHistoryInfo[] | getEventHistory() イベント履歴情報リスト取得
String | getId() ナビゲート結果ID取得
ResultPageItemInfo[] | getResultPageItemInfos() 結果ページ情報リスト取得
void | setEventHistory(EventHistoryInfo[] eventHistory) イベント履歴情報リスト設定
void | setId(String id) ナビゲート結果ID設定
void | setResultPageItemInfos(ResultPageItemInfo[] resultPageItemInfos) 結果ページ情報リスト設定
クラス jp.co.intra_mart.foundation.navigator.TitleInfo から継承したメソッド
getComment, getTitle, setComment, setTitle
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventResultItemInfo

public EventResultItemInfo()
メソッドの詳細

getId

public String getId()
ナビゲート結果ID取得

戻り値:
Returns the id.

setId

public void setId(String id)
ナビゲート結果ID設定

パラメータ:
id - The id to set.

getResultPageItemInfos

public ResultPageItemInfo[] getResultPageItemInfos()
結果ページ情報リスト取得

戻り値:
Returns the resultPageItemInfos.

setResultPageItemInfos

public void setResultPageItemInfos(ResultPageItemInfo[] resultPageItemInfos)
結果ページ情報リスト設定

パラメータ:
resultPageItemInfos - The resultPageItemInfos to set.

getEventHistory

public EventHistoryInfo[] getEventHistory()
イベント履歴情報リスト取得

戻り値:
Returns the eventHistory.

setEventHistory

public void setEventHistory(EventHistoryInfo[] eventHistory)
イベント履歴情報リスト設定

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LinkPageInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス LinkPageInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.TitleInfo
        拡張 jp.co.intra_mart.foundation.navigator.LinkPageInfo
すべての実装インタフェース:
Serializable
public class LinkPageInfo
extends TitleInfo

リンク情報

関連項目:
直列化された形式

コンストラクタの概要
LinkPageInfo()
メソッドの概要
String[] | getKeys() URLパラメータリストのキー配列取得
String | getParamValue(String key)
String | getUrl() URL取得
void | setParamValue(String key, String value)
void | setUrl(String url) URL設定
クラス jp.co.intra_mart.foundation.navigator.TitleInfo から継承したメソッド
getComment, getTitle, setComment, setTitle
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LinkPageInfo

public LinkPageInfo()
メソッドの詳細

getUrl

public String getUrl()
URL取得

戻り値:
Returns the url.

setUrl

public void setUrl(String url)
URL設定

パラメータ:
url - The url to set.

getParamValue

public String getParamValue(String key)
戻り値:
URLパラメータ取得。

setParamValue

public void setParamValue(String key,
                          String value)

getKeys

public String[] getKeys()
URLパラメータリストのキー配列取得

戻り値:
Returns the param.
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NavigatorAuthenticateItem (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス NavigatorAuthenticateItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.NavigatorItem
        拡張 jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
EventFlow, ResultPageItem, SelectItem
public abstract class NavigatorAuthenticateItem
extends NavigatorItem

選択アイテムクラス

関連項目:
直列化された形式

コンストラクタの概要
NavigatorAuthenticateItem()
メソッドの概要
EventAccessInfo | getAccessInfo()
void | setAccessInfo(EventAccessInfo accessInfo)
クラス jp.co.intra_mart.foundation.navigator.NavigatorItem から継承したメソッド
getKeys, getTitleInfo, removeTitleInfo, setTitleInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NavigatorAuthenticateItem

public NavigatorAuthenticateItem()
メソッドの詳細

getAccessInfo

public EventAccessInfo getAccessInfo()
戻り値:
accessInfo を戻します。

setAccessInfo

public void setAccessInfo(EventAccessInfo accessInfo)
パラメータ:
accessInfo - 設定する accessInfo。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NavigatorItem (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス NavigatorItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.NavigatorItem
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
EventItem, EventResultItem, NavigatorAuthenticateItem
public abstract class NavigatorItem
extends Object
implements Serializable

イベントナビゲータアイテムクラス

関連項目:
直列化された形式

コンストラクタの概要
NavigatorItem()
メソッドの概要
Locale[] | getKeys() タイトル情報リストのキー配列取得
TitleInfo | getTitleInfo(Locale locale)
void | removeTitleInfo(Locale locale)
void | setTitleInfo(Locale locale, TitleInfo titleInfo)
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NavigatorItem

public NavigatorItem()
メソッドの詳細

getTitleInfo

public TitleInfo getTitleInfo(Locale locale)
戻り値:
titleInfo を戻します。

setTitleInfo

public void setTitleInfo(Locale locale,
                         TitleInfo titleInfo)
パラメータ:
titleInfo - 設定する titleInfo。

removeTitleInfo

public void removeTitleInfo(Locale locale)

getKeys

public Locale[] getKeys()
タイトル情報リストのキー配列取得

戻り値:
Returns the param.
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.navigator (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.navigator
インタフェース
EventNavigatorAccessor
EventNavigatorExporter
EventNavigatorImporter
EventNavigatorReaderDecorator
クラス
EventAccessInfo
EventFlow
EventFlowInfo
EventHistoryInfo
EventItem
EventItemInfo
EventNavigatorConst
EventNavigatorHandler
EventNavigatorManager
EventNavigatorPermissionSelector
EventResultItem
EventResultItemInfo
LinkPageInfo
NavigatorAuthenticateItem
NavigatorItem
ResultPageItem
ResultPageItemInfo
SaveEventHistoryInfo
SaveEventResultItemInfo
SelectItem
SelectItemInfo
StandardEventNavigatorAccessor
StandardEventNavigatorExporter
StandardEventNavigatorImporter
TitleInfo
例外
EventNavigatorException


jp.co.intra_mart.foundation.navigator (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.navigator

インタフェースの概要
EventNavigatorAccessor | イベントナビゲーター管理アクセッサインタフェース。
EventNavigatorExporter | イベントナビゲータバックアップインタフェースです。
EventNavigatorImporter | イベントナビゲータバックアップインタフェースです。
EventNavigatorReaderDecorator |

クラスの概要
EventAccessInfo | アクセス権情報
EventFlow | イベントフロークラス
EventFlowInfo | イベントフロー情報
EventHistoryInfo | イベント履歴情報
EventItem | イベントアイテムクラス
EventItemInfo | イベントアイテム情報
EventNavigatorConst | イベントナビゲーターで使用する定数の一覧
EventNavigatorHandler |
EventNavigatorManager | イベントナビゲーター管理マネージャクラス。
EventNavigatorPermissionSelector | ユーザIDから有効なID一覧を取得するセレクタ。
EventResultItem | ナビゲート結果クラス
EventResultItemInfo | ナビゲート結果情報
LinkPageInfo | リンク情報
NavigatorAuthenticateItem | 選択アイテムクラス
NavigatorItem | イベントナビゲータアイテムクラス
ResultPageItem | 結果ページクラス
ResultPageItemInfo | 結果ページ情報
SaveEventHistoryInfo | 保存イベント履歴情報クラス
SaveEventResultItemInfo | 保存ナビゲート結果情報
SelectItem | 選択アイテムクラス
SelectItemInfo | 選択アイテム情報
StandardEventNavigatorAccessor | イベントナビゲーター管理アクセッサクラス。
StandardEventNavigatorExporter |
StandardEventNavigatorImporter | イベントナビゲーターのインポートクラス。
TitleInfo | タイトル情報

例外の概要
EventNavigatorException イベントナビゲータマネージャに関する例外クラス


jp.co.intra_mart.foundation.navigator クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.navigator の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.navigator.EventAccessInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.navigator.EventHistoryInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.navigator.EventNavigatorConst
    • class jp.co.intra_mart.foundation.navigator.EventNavigatorHandler
    • class jp.co.intra_mart.foundation.navigator.EventNavigatorManager
    • class jp.co.intra_mart.foundation.navigator.EventNavigatorPermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.foundation.navigator.NavigatorItem (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.navigator.EventItem
      • class jp.co.intra_mart.foundation.navigator.EventResultItem
      • class jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem
        • class jp.co.intra_mart.foundation.navigator.EventFlow
        • class jp.co.intra_mart.foundation.navigator.ResultPageItem
        • class jp.co.intra_mart.foundation.navigator.SelectItem
    • class jp.co.intra_mart.foundation.navigator.SaveEventHistoryInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor (implements jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor)
    • class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter (implements jp.co.intra_mart.foundation.navigator.EventNavigatorExporter)
    • class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter (implements jp.co.intra_mart.foundation.navigator.EventNavigatorImporter)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.exception.FoundationException
          • class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
            • class jp.co.intra_mart.foundation.navigator.EventNavigatorException
    • class jp.co.intra_mart.foundation.navigator.TitleInfo (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.navigator.EventFlowInfo
      • class jp.co.intra_mart.foundation.navigator.EventItemInfo
      • class jp.co.intra_mart.foundation.navigator.EventResultItemInfo
      • class jp.co.intra_mart.foundation.navigator.LinkPageInfo
      • class jp.co.intra_mart.foundation.navigator.ResultPageItemInfo
      • class jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo
      • class jp.co.intra_mart.foundation.navigator.SelectItemInfo

インタフェース階層

  • interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor
  • interface jp.co.intra_mart.foundation.navigator.EventNavigatorExporter
  • interface jp.co.intra_mart.foundation.navigator.EventNavigatorImporter
  • interface jp.co.intra_mart.foundation.navigator.EventNavigatorReaderDecorator


パッケージ jp.co.intra_mart.foundation.navigator の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.navigator の使用

jp.co.intra_mart.foundation.navigator を使用しているパッケージ
jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.navigator により使用される jp.co.intra_mart.foundation.navigator のクラス
EventAccessInfo
アクセス権情報
EventFlow
イベントフロークラス
EventFlowInfo
イベントフロー情報
EventHistoryInfo
イベント履歴情報
EventItem
イベントアイテムクラス
EventItemInfo
イベントアイテム情報
EventNavigatorAccessor
イベントナビゲーター管理アクセッサインタフェース。
EventNavigatorException
イベントナビゲータマネージャに関する例外クラス
EventNavigatorExporter
イベントナビゲータバックアップインタフェースです。
EventNavigatorImporter
イベントナビゲータバックアップインタフェースです。
EventNavigatorManager
イベントナビゲーター管理マネージャクラス。
EventResultItem
ナビゲート結果クラス
EventResultItemInfo
ナビゲート結果情報
LinkPageInfo
リンク情報
NavigatorAuthenticateItem
選択アイテムクラス
NavigatorItem
イベントナビゲータアイテムクラス
ResultPageItem
結果ページクラス
ResultPageItemInfo
結果ページ情報
SaveEventHistoryInfo
保存イベント履歴情報クラス
SaveEventResultItemInfo
保存ナビゲート結果情報
SelectItem
選択アイテムクラス
SelectItemInfo
選択アイテム情報
TitleInfo
タイトル情報

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ResultPageItem (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス ResultPageItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.NavigatorItem
        拡張 jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem
            拡張 jp.co.intra_mart.foundation.navigator.ResultPageItem
すべての実装インタフェース:
Serializable
public class ResultPageItem
extends NavigatorAuthenticateItem

結果ページクラス

関連項目:
直列化された形式

コンストラクタの概要
ResultPageItem()
メソッドの概要
LinkPageInfo | getLinkPageInfo()
void | setLinkPageInfo(LinkPageInfo linkPageInfo)
クラス jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem から継承したメソッド
getAccessInfo, setAccessInfo
クラス jp.co.intra_mart.foundation.navigator.NavigatorItem から継承したメソッド
getKeys, getTitleInfo, removeTitleInfo, setTitleInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ResultPageItem

public ResultPageItem()
メソッドの詳細

getLinkPageInfo

public LinkPageInfo getLinkPageInfo()
戻り値:
linkPageInfo を戻します。

setLinkPageInfo

public void setLinkPageInfo(LinkPageInfo linkPageInfo)
パラメータ:
linkPageInfo - 設定する linkPageInfo。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ResultPageItemInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス ResultPageItemInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.TitleInfo
        拡張 jp.co.intra_mart.foundation.navigator.ResultPageItemInfo
すべての実装インタフェース:
Serializable
public class ResultPageItemInfo
extends TitleInfo

結果ページ情報

関連項目:
直列化された形式

コンストラクタの概要
ResultPageItemInfo()
メソッドの概要
String | getId() 保存結果ページID取得
boolean | isPermissionCheck() パーミッションチェックフラグ取得
void | setId(String id) 保存結果ページID設定
void | setPermissionCheck(boolean check) パーミッションチェックフラグ設定
クラス jp.co.intra_mart.foundation.navigator.TitleInfo から継承したメソッド
getComment, getTitle, setComment, setTitle
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ResultPageItemInfo

public ResultPageItemInfo()
メソッドの詳細

getId

public String getId()
保存結果ページID取得

戻り値:
Returns the id.

setId

public void setId(String id)
保存結果ページID設定

パラメータ:
id - The id to set.

isPermissionCheck

public boolean isPermissionCheck()
パーミッションチェックフラグ取得

戻り値:
Returns the permissionCheck.

setPermissionCheck

public void setPermissionCheck(boolean check)
パーミッションチェックフラグ設定

パラメータ:
check - The permissionCheck to set.
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SaveEventHistoryInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス SaveEventHistoryInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.SaveEventHistoryInfo
すべての実装インタフェース:
Serializable
public class SaveEventHistoryInfo
extends Object
implements Serializable

保存イベント履歴情報クラス

関連項目:
直列化された形式

コンストラクタの概要
SaveEventHistoryInfo()
メソッドの概要
String | getAnswer() 質問取得
String | getQuestion() 回答取得
void | setAnswer(String answer) 質問設定
void | setQuestion(String question) 回答設定
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SaveEventHistoryInfo

public SaveEventHistoryInfo()
メソッドの詳細

getAnswer

public String getAnswer()
質問取得

戻り値:
Returns the answer.

setAnswer

public void setAnswer(String answer)
質問設定

パラメータ:
answer - The answer to set.

getQuestion

public String getQuestion()
回答取得

戻り値:
Returns the question.

setQuestion

public void setQuestion(String question)
回答設定

パラメータ:
question - The question to set.
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SaveEventResultItemInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス SaveEventResultItemInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.TitleInfo
        拡張 jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo
すべての実装インタフェース:
Serializable
public class SaveEventResultItemInfo
extends TitleInfo

保存ナビゲート結果情報

関連項目:
直列化された形式

コンストラクタの概要
SaveEventResultItemInfo()
メソッドの概要
SaveEventHistoryInfo[] | getEventHistory() イベント履歴情報リスト取得
String | getId() 保存ナビゲート結果ID取得
ResultPageItemInfo[] | getResultPageItemInfos() 結果ページ情報リスト取得
Date | getSaveDate() 保存日時取得
void | setEventHistory(SaveEventHistoryInfo[] eventHistory) イベント履歴情報リスト設定
void | setId(String id) 保存ナビゲート結果ID設定
void | setResultPageItemInfos(ResultPageItemInfo[] resultPageItemInfos) 結果ページ情報リスト設定
void | setSaveDate(Date saveDate) 保存日時設定
クラス jp.co.intra_mart.foundation.navigator.TitleInfo から継承したメソッド
getComment, getTitle, setComment, setTitle
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SaveEventResultItemInfo

public SaveEventResultItemInfo()
メソッドの詳細

getId

public String getId()
保存ナビゲート結果ID取得

戻り値:
Returns the id.

setId

public void setId(String id)
保存ナビゲート結果ID設定

パラメータ:
id - The id to set.

getSaveDate

public Date getSaveDate()
保存日時取得

戻り値:
Returns the saveDate.

setSaveDate

public void setSaveDate(Date saveDate)
保存日時設定

パラメータ:
saveDate - The saveDate to set.

getResultPageItemInfos

public ResultPageItemInfo[] getResultPageItemInfos()
結果ページ情報リスト取得

戻り値:
Returns the resultPageItemInfos.

setResultPageItemInfos

public void setResultPageItemInfos(ResultPageItemInfo[] resultPageItemInfos)
結果ページ情報リスト設定

パラメータ:
resultPageItemInfos - The resultPageItemInfos to set.

getEventHistory

public SaveEventHistoryInfo[] getEventHistory()
イベント履歴情報リスト取得

戻り値:
Returns the eventHistory.

setEventHistory

public void setEventHistory(SaveEventHistoryInfo[] eventHistory)
イベント履歴情報リスト設定

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SelectItem (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス SelectItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.NavigatorItem
        拡張 jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem
            拡張 jp.co.intra_mart.foundation.navigator.SelectItem
すべての実装インタフェース:
Serializable
public class SelectItem
extends NavigatorAuthenticateItem

選択アイテムクラス

関連項目:
直列化された形式

コンストラクタの概要
SelectItem()
メソッドの概要
EventItem | getNextEventItem()
EventResultItem | getNextEventResultItem()
String | getNextType()
void | setNextEventItem(EventItem nextEventItem)
void | setNextEventResultItem(EventResultItem nextEventResultItem)
クラス jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem から継承したメソッド
getAccessInfo, setAccessInfo
クラス jp.co.intra_mart.foundation.navigator.NavigatorItem から継承したメソッド
getKeys, getTitleInfo, removeTitleInfo, setTitleInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SelectItem

public SelectItem()
メソッドの詳細

getNextEventItem

public EventItem getNextEventItem()
戻り値:
nextEventItem を戻します。

setNextEventItem

public void setNextEventItem(EventItem nextEventItem)
パラメータ:
nextEventItem - 設定する nextEventItem。

getNextEventResultItem

public EventResultItem getNextEventResultItem()
戻り値:
nextEventResultItem を戻します。

setNextEventResultItem

public void setNextEventResultItem(EventResultItem nextEventResultItem)
パラメータ:
nextEventResultItem - 設定する nextEventResultItem。

getNextType

public String getNextType()
戻り値:
nextType を戻します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SelectItemInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス SelectItemInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.TitleInfo
        拡張 jp.co.intra_mart.foundation.navigator.SelectItemInfo
すべての実装インタフェース:
Serializable
public class SelectItemInfo
extends TitleInfo

選択アイテム情報

関連項目:
直列化された形式

コンストラクタの概要
SelectItemInfo()
メソッドの概要
String | getId() 選択アイテムID取得
String | getNextItemId() 遷移先アイテムID取得
String | getNextType() 遷移先タイプ取得
boolean | isPermissionCheck() パーミッションチェックフラグ取得
void | setId(String id) 選択アイテムID設定
void | setNextItemId(String nextItemId) 遷移先アイテムID設定
void | setNextType(String nextType) 遷移先タイプ設定
void | setPermissionCheck(boolean check) パーミッションチェックフラグ設定
クラス jp.co.intra_mart.foundation.navigator.TitleInfo から継承したメソッド
getComment, getTitle, setComment, setTitle
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SelectItemInfo

public SelectItemInfo()
メソッドの詳細

getId

public String getId()
選択アイテムID取得

戻り値:
Returns the id.

setId

public void setId(String id)
選択アイテムID設定

パラメータ:
id - The id to set.

getNextItemId

public String getNextItemId()
遷移先アイテムID取得

戻り値:
Returns the nextItemId.

setNextItemId

public void setNextItemId(String nextItemId)
遷移先アイテムID設定

パラメータ:
nextItemId - The nextItemId to set.

getNextType

public String getNextType()
遷移先タイプ取得

戻り値:
Returns the nextType.

setNextType

public void setNextType(String nextType)
遷移先タイプ設定

パラメータ:
nextType - The nextType to set.

isPermissionCheck

public boolean isPermissionCheck()
パーミッションチェックフラグ取得

戻り値:
Returns the permissionCheck.

setPermissionCheck

public void setPermissionCheck(boolean check)
パーミッションチェックフラグ設定

パラメータ:
check - The permissionCheck to set.
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardEventNavigatorAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス StandardEventNavigatorAccessor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor
すべての実装インタフェース:
EventNavigatorAccessor
public class StandardEventNavigatorAccessor
extends Object
implements EventNavigatorAccessor

イベントナビゲーター管理アクセッサクラス。

イベントナビゲーター情報の読み込みおよび書き込みクラスです。

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
static String | DEFAULT_COMMENT コメント
static String | DEFAULT_FAVORITE 保存ナビゲート結果（お気に入）
static String | DEFAULT_HISTORY 保存ナビゲート結果（履歴）
static String | DEFAULT_TITLE タイトル
static String | KIND_NAVIGATOR 種別 ロール。
コンストラクタの概要
StandardEventNavigatorAccessor()
コンストラクタ
メソッドの概要
String | addEventResultItemInfo(EventNavigatorManager manager, String userId, String eventFlowId, EventResultItemInfo resultItemInfo) 保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
void | addFavoriteSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String saveResultItemId) 保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。
EventFlow | copyEventFlow(EventNavigatorManager manager, String eventFlowId) イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
void | deleteEventFlow(EventNavigatorManager manager, String eventFlowId) イベントフローの削除 イベントフローIDから、イベントフローを削除する。
void | deleteSaveResultHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。
EventFlow | getEventFlow(EventNavigatorManager manager, String eventFlowId) イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
String[] | getEventFlowIds(EventNavigatorManager manager) すべてのイベントフローIDを取得します。
EventFlowInfo[] | getEventFlowInfos(EventNavigatorManager manager, String searchTitle, boolean permissionCheck, int currentPage) イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
EventFlow[] | getEventFlows(EventNavigatorManager manager) すべてのイベントフローを取得します。
EventItemInfo | getEventItemInfo(EventNavigatorManager manager, String eventFlowId, String eventItemId) イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
EventResultItemInfo | getEventResultItemInfo(EventNavigatorManager manager, String eventFlowId, String resultItemId) ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
LinkPageInfo | getLinkPageInfo(EventNavigatorManager manager, String eventFlowId, String eventResultId, String resultPageId) 結果ページ情報を取得します。
protected String | getLoginUser() ログインユーザを取得します。
SaveEventResultItemInfo | getSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String resultItemId) 保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
SaveEventResultItemInfo[] | getSaveEventResultItemInfos(EventNavigatorManager manager, String userId, String searchTitle, String sortKey, String oeder, int currentPage) 保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
SaveEventResultItemInfo[] | getSaveEventResultItemInfosHistory(EventNavigatorManager manager, String userId) 保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
LinkPageInfo | getSaveLinkPageInfo(EventNavigatorManager manager, String userId, String eventResultId, String resultPageId) 保存結果ページ情報を取得します。
void | init(String[] args) イベントナビゲーター管理アクセッサの初期化。
void | registEventFlow(EventNavigatorManager manager, EventFlow eventFlow) イベントフローを更新します。
void | removeSaveEventResultItemInfo(EventNavigatorManager manager, String userId, String saveResultItemId) 保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。
void | setOrderSortNum(EventNavigatorManager manager, EventFlowInfo[] eventFlowInfos) 表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
void | setViewOpen(EventNavigatorManager manager, String eventFlowId, String open) 表示設定 イベントフロー情報に表示／非表示を設定する。
void | updateEventFlow(EventNavigatorManager manager, EventFlow eventFlow) イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
void | updateEventResultItemInfo(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
void | updateEventResultItemInfoTitle(EventNavigatorManager manager, String userId, SaveEventResultItemInfo saveResultItemInfo) 保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KIND_NAVIGATOR

public static final String KIND_NAVIGATOR
種別 ロール。

関連項目:
定数フィールド値

DEFAULT_TITLE

public static final String DEFAULT_TITLE
タイトル

関連項目:
定数フィールド値

DEFAULT_COMMENT

public static final String DEFAULT_COMMENT
コメント

関連項目:
定数フィールド値

DEFAULT_FAVORITE

public static final String DEFAULT_FAVORITE
保存ナビゲート結果（お気に入）

関連項目:
定数フィールド値

DEFAULT_HISTORY

public static final String DEFAULT_HISTORY
保存ナビゲート結果（履歴）

関連項目:
定数フィールド値
コンストラクタの詳細

StandardEventNavigatorAccessor

public StandardEventNavigatorAccessor()
コンストラクタ

メソッドの詳細

init

public void init(String[] args)
イベントナビゲーター管理アクセッサの初期化。

定義:
インタフェース EventNavigatorAccessor 内の init

getEventFlowInfos

public EventFlowInfo[] getEventFlowInfos(EventNavigatorManager manager,
                                         String searchTitle,
                                         boolean permissionCheck,
                                         int currentPage)
                                  throws EventNavigatorException
イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。

定義:
インタフェース EventNavigatorAccessor 内の getEventFlowInfos
パラメータ:
manager - イベントナビゲータ管理オブジェクト
searchTitle - 検索タイトル
permissionCheck - 権限チェック要否
currentPage - 表示指定頁
戻り値:
イベントフロー情報一覧
例外:
EventNavigatorException - イベントフロー情報一覧取得処理に失敗した場合にスローされます。

deleteEventFlow

public void deleteEventFlow(EventNavigatorManager manager,
                            String eventFlowId)
                     throws EventNavigatorException
イベントフローの削除 イベントフローIDから、イベントフローを削除する。

定義:
インタフェース EventNavigatorAccessor 内の deleteEventFlow
パラメータ:
eventFlowId - イベントフローID
例外:
EventNavigatorException - イベントフロー削除処理に失敗した場合にスローされます。

getEventFlow

public EventFlow getEventFlow(EventNavigatorManager manager,
                              String eventFlowId)
                       throws EventNavigatorException
イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。

定義:
インタフェース EventNavigatorAccessor 内の getEventFlow
パラメータ:
eventFlowId - イベントフローID
戻り値:
イベントフロー
例外:
EventNavigatorException - イベントフロー取得処理に失敗した場合にスローされます。

updateEventFlow

public void updateEventFlow(EventNavigatorManager manager,
                            EventFlow eventFlow)
                     throws EventNavigatorException
イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。

定義:
インタフェース EventNavigatorAccessor 内の updateEventFlow
パラメータ:
eventFlow - イベントフロー
例外:
EventNavigatorException - イベントフロー登録処理に失敗した場合にスローされます。

copyEventFlow

public EventFlow copyEventFlow(EventNavigatorManager manager,
                               String eventFlowId)
                        throws EventNavigatorException
イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。

定義:
インタフェース EventNavigatorAccessor 内の copyEventFlow
パラメータ:
eventFlowId - コピー元イベントフローID
戻り値:
コピー先イベントフロー
例外:
EventNavigatorException - イベントフローコピー処理に失敗した場合にスローされます。

getEventItemInfo

public EventItemInfo getEventItemInfo(EventNavigatorManager manager,
                                      String eventFlowId,
                                      String eventItemId)
                               throws EventNavigatorException
イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。

定義:
インタフェース EventNavigatorAccessor 内の getEventItemInfo
パラメータ:
eventFlowId - イベントフローID
eventItemId - イベントアイテムID
戻り値:
イベントアイテム情報
例外:
EventNavigatorException - イベントアイテム情報取得処理に失敗した場合にスローされます。

getEventResultItemInfo

public EventResultItemInfo getEventResultItemInfo(EventNavigatorManager manager,
                                                  String eventFlowId,
                                                  String resultItemId)
                                           throws EventNavigatorException
ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。

定義:
インタフェース EventNavigatorAccessor 内の getEventResultItemInfo
パラメータ:
eventFlowId - イベントフローID
resultItemId - ナビゲート結果ID
戻り値:
ナビゲート結果情報
例外:
EventNavigatorException - ナビゲート結果情報取得処理に失敗した場合にスローされます。

addEventResultItemInfo

public String addEventResultItemInfo(EventNavigatorManager manager,
                                     String userId,
                                     String eventFlowId,
                                     EventResultItemInfo resultItemInfo)
                              throws EventNavigatorException
保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。

定義:
インタフェース EventNavigatorAccessor 内の addEventResultItemInfo
パラメータ:
userId - ユーザID
eventFlowId - イベントフローID
resultItemInfo - ナビゲート結果情報
戻り値:
保存ナビゲート結果ID
例外:
EventNavigatorException - 保存ナビゲート結果情報（履歴）登録処理に失敗した場合にスローされます。

deleteSaveResultHistory

public void deleteSaveResultHistory(EventNavigatorManager manager,
                                    String userId)
                             throws EventNavigatorException
保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。

定義:
インタフェース EventNavigatorAccessor 内の deleteSaveResultHistory
パラメータ:
userId - ユーザID
例外:
EventNavigatorException - 保存ナビゲート結果情報（履歴）削除処理に失敗した場合にスローされます。

getSaveEventResultItemInfo

public SaveEventResultItemInfo getSaveEventResultItemInfo(EventNavigatorManager manager,
                                                          String userId,
                                                          String resultItemId)
                                                   throws EventNavigatorException
保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。

定義:
インタフェース EventNavigatorAccessor 内の getSaveEventResultItemInfo
パラメータ:
userId - ユーザID
resultItemId - ナビゲート結果ID
戻り値:
保存ナビゲート結果情報
例外:
EventNavigatorException - 保存ナビゲート結果情報取得処理に失敗した場合にスローされます。

updateEventResultItemInfo

public void updateEventResultItemInfo(EventNavigatorManager manager,
                                      String userId,
                                      SaveEventResultItemInfo saveResultItemInfo)
                               throws EventNavigatorException
保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。

定義:
インタフェース EventNavigatorAccessor 内の updateEventResultItemInfo
パラメータ:
userId - ユーザID
saveResultItemInfo - 保存ナビゲート結果情報
例外:
EventNavigatorException - 保存ナビゲート結果情報（ユーザ）更新処理に失敗した場合にスローされます。

updateEventResultItemInfoTitle

public void updateEventResultItemInfoTitle(EventNavigatorManager manager,
                                           String userId,
                                           SaveEventResultItemInfo saveResultItemInfo)
                                    throws EventNavigatorException
保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。

定義:
インタフェース EventNavigatorAccessor 内の updateEventResultItemInfoTitle
パラメータ:
manager - マネージャー
userId - ユーザID
saveResultItemInfo - 保存ナビゲート結果情報
例外:
EventNavigatorException - 保存ナビゲート結果情報（ユーザ）更新処理に失敗した場合にスローされます。

getSaveEventResultItemInfos

public SaveEventResultItemInfo[] getSaveEventResultItemInfos(EventNavigatorManager manager,
                                                             String userId,
                                                             String searchTitle,
                                                             String sortKey,
                                                             String oeder,
                                                             int currentPage)
                                                      throws EventNavigatorException
保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。

定義:
インタフェース EventNavigatorAccessor 内の getSaveEventResultItemInfos
パラメータ:
userId - ユーザID
searchTitle - 検索タイトル
sortKey - ソートキー
oeder - 昇降指定
currentPage - 表示指定頁
戻り値:
保存ナビゲート結果情報の配列（ユーザ）
例外:
EventNavigatorException - 保存ナビゲート結果情報一覧（ユーザ）取得処理に失敗した場合にスローされます。

removeSaveEventResultItemInfo

public void removeSaveEventResultItemInfo(EventNavigatorManager manager,
                                          String userId,
                                          String saveResultItemId)
                                   throws EventNavigatorException
保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。

定義:
インタフェース EventNavigatorAccessor 内の removeSaveEventResultItemInfo
パラメータ:
userId - ユーザID
saveResultItemId - 保存ナビゲート結果ID
例外:
EventNavigatorException - 保存ナビゲート結果情報削除処理に失敗した場合にスローされます。

addFavoriteSaveEventResultItemInfo

public void addFavoriteSaveEventResultItemInfo(EventNavigatorManager manager,
                                               String userId,
                                               String saveResultItemId)
                                        throws EventNavigatorException
保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。

定義:
インタフェース EventNavigatorAccessor 内の addFavoriteSaveEventResultItemInfo
パラメータ:
manager - マネージャー
userId - ユーザID
saveResultItemId - 保存ナビゲート結果ID
例外:
EventNavigatorException - 保存ナビゲート結果情報お気に入りへ追加処理に失敗した場合にスローされます。

getSaveEventResultItemInfosHistory

public SaveEventResultItemInfo[] getSaveEventResultItemInfosHistory(EventNavigatorManager manager,
                                                                    String userId)
                                                             throws EventNavigatorException
保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。

定義:
インタフェース EventNavigatorAccessor 内の getSaveEventResultItemInfosHistory
パラメータ:
userId - ユーザID
戻り値:
保存ナビゲート結果情報の配列（履歴）
例外:
EventNavigatorException - 保存ナビゲート結果情報一覧（履歴）取得処理に失敗した場合にスローされます。

setOrderSortNum

public void setOrderSortNum(EventNavigatorManager manager,
                            EventFlowInfo[] eventFlowInfos)
                     throws EventNavigatorException
表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。

定義:
インタフェース EventNavigatorAccessor 内の setOrderSortNum
パラメータ:
manager - イベントナビゲータ管理オブジェクト
eventFlowInfos - イベントフロー情報配列
例外:
EventNavigatorException - 表示順設定処理に失敗した場合にスローされます。

setViewOpen

public void setViewOpen(EventNavigatorManager manager,
                        String eventFlowId,
                        String open)
                 throws EventNavigatorException
表示設定 イベントフロー情報に表示／非表示を設定する。

定義:
インタフェース EventNavigatorAccessor 内の setViewOpen
パラメータ:
eventFlowId - イベントフローID
open - 表示フラグ
例外:
EventNavigatorException - 表示順設定処理に失敗した場合にスローされます。

getEventFlowIds

public String[] getEventFlowIds(EventNavigatorManager manager)
                         throws EventNavigatorException
すべてのイベントフローIDを取得します。

定義:
インタフェース EventNavigatorAccessor 内の getEventFlowIds
パラメータ:
manager -
戻り値:
イベントフローIDの配列
例外:
EventNavigatorException

getEventFlows

public EventFlow[] getEventFlows(EventNavigatorManager manager)
                          throws EventNavigatorException
すべてのイベントフローを取得します。

定義:
インタフェース EventNavigatorAccessor 内の getEventFlows
パラメータ:
manager -
戻り値:
イベントフローの配列
例外:
EventNavigatorException

getLinkPageInfo

public LinkPageInfo getLinkPageInfo(EventNavigatorManager manager,
                                    String eventFlowId,
                                    String eventResultId,
                                    String resultPageId)
                             throws EventNavigatorException
結果ページ情報を取得します。

定義:
インタフェース EventNavigatorAccessor 内の getLinkPageInfo
パラメータ:
manager -
eventFlowId - イベントフローID
eventResultId - ナビゲート結果ID
resultPageId - 結果ページID
戻り値:
結果ページ情報
例外:
EventNavigatorException

getSaveLinkPageInfo

public LinkPageInfo getSaveLinkPageInfo(EventNavigatorManager manager,
                                        String userId,
                                        String eventResultId,
                                        String resultPageId)
                                 throws EventNavigatorException
保存結果ページ情報を取得します。

定義:
インタフェース EventNavigatorAccessor 内の getSaveLinkPageInfo
パラメータ:
manager -
userId - ユーザID
eventResultId - ナビゲート結果ID
resultPageId - 結果ページID
戻り値:
保存結果ページ情報
例外:
EventNavigatorException

getLoginUser

protected String getLoginUser()
ログインユーザを取得します。
ログインユーザの取得に失敗した場合は空文字列を返却します。

戻り値:
ログインユーザID

registEventFlow

public void registEventFlow(EventNavigatorManager manager,
                            EventFlow eventFlow)
                     throws EventNavigatorException
イベントフローを更新します。

定義:
インタフェース EventNavigatorAccessor 内の registEventFlow
パラメータ:
eventFlow - イベントフロー
例外:
EventNavigatorException - イベントフローの更新に失敗した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardEventNavigatorExporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス StandardEventNavigatorExporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter
すべての実装インタフェース:
EventNavigatorExporter
public class StandardEventNavigatorExporter
extends Object
implements EventNavigatorExporter

コンストラクタの概要
StandardEventNavigatorExporter()
メソッドの概要
boolean | checkLocale(String keyLocale, String[] syslocales) ロケールチェック（共通）
void | doExport(EventNavigatorManager manager, OutputStream outputStream, boolean editFlag) エクスポートを行います。
void | init(String[] args) イベントナビゲータバックアップエクスポータの初期化。
Locale[] | matchSysLocales(Locale[] locales, String[] syslocales) ロケールマッチング（共通）
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardEventNavigatorExporter

public StandardEventNavigatorExporter()
メソッドの詳細

init

public void init(String[] args)
インタフェース EventNavigatorExporter の記述:
イベントナビゲータバックアップエクスポータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース EventNavigatorExporter 内の init

doExport

public void doExport(EventNavigatorManager manager,
                     OutputStream outputStream,
                     boolean editFlag)
              throws EventNavigatorException
エクスポートを行います。

イベントフロー情報からXMLを生成します。

定義:
インタフェース EventNavigatorExporter 内の doExport
パラメータ:
manager - イベントナビゲータマネージャクラス
outputStream - 出力ストリーム
例外:
EventNavigatorException

matchSysLocales

public Locale[] matchSysLocales(Locale[] locales,
                                String[] syslocales)
ロケールマッチング（共通）

パラメータ:
locales - タイトルのロケール
syslocales - システムのロケール

checkLocale

public boolean checkLocale(String keyLocale,
                           String[] syslocales)
ロケールチェック（共通）

パラメータ:
keyLocale - タイトル情報のロケール
syslocales - システムのロケール
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardEventNavigatorImporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス StandardEventNavigatorImporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter
すべての実装インタフェース:
EventNavigatorImporter
public class StandardEventNavigatorImporter
extends Object
implements EventNavigatorImporter

イベントナビゲーターのインポートクラス。

バージョン:
1.0

コンストラクタの概要
StandardEventNavigatorImporter()
メソッドの概要
boolean | checkLocale(String keyLocale, String[] locales) ロケールチェック（共通）
boolean | checkStrLength(String str, int length) 文字列チェック（共通）
void | checkTitleInfo(NavigatorItem item, String[] locales, String strURI) タイトル情報のロケールマッチング（共通）
void | doImport(EventNavigatorManager manager, InputStream inputStream) インポートを行います。
String | getPathXML(Node node, Node parent_node) このノードのフルパスを取得します。
void | init(String[] args) 初期化。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardEventNavigatorImporter

public StandardEventNavigatorImporter()
メソッドの詳細

init

public void init(String[] args)
初期化。

初期化します。

定義:
インタフェース EventNavigatorImporter 内の init

doImport

public void doImport(EventNavigatorManager manager,
                     InputStream inputStream)
              throws EventNavigatorException
インポートを行います。

ストリーム内の情報からメニュー情報を生成します。

定義:
インタフェース EventNavigatorImporter 内の doImport
パラメータ:
manager - メニューマネージャクラス
inputStream - 入力ストリーム
例外:
EventNavigatorException

checkStrLength

public boolean checkStrLength(String str,
                              int length)
                       throws EventNavigatorException
文字列チェック（共通）

パラメータ:
str - 対象文字列
length - レングス値
例外:
EventNavigatorException

checkLocale

public boolean checkLocale(String keyLocale,
                           String[] locales)
                    throws EventNavigatorException
ロケールチェック（共通）

パラメータ:
keyLocale - タイトル情報のロケール
locales - システムのロケール
例外:
EventNavigatorException

checkTitleInfo

public void checkTitleInfo(NavigatorItem item,
                           String[] locales,
                           String strURI)
                    throws EventNavigatorException
タイトル情報のロケールマッチング（共通）

パラメータ:
item - アイテム情報
locales - システムのロケール
例外:
EventNavigatorException

getPathXML

public String getPathXML(Node node,
                         Node parent_node)
このノードのフルパスを取得します。

このノードのフルパス '/'でつないだパスを取得します。

戻り値:
ノードのフルパス。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TitleInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.navigator
クラス TitleInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.navigator.TitleInfo
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
EventFlowInfo, EventItemInfo, EventResultItemInfo, LinkPageInfo, ResultPageItemInfo, SaveEventResultItemInfo, SelectItemInfo
public class TitleInfo
extends Object
implements Serializable

タイトル情報

関連項目:
直列化された形式

コンストラクタの概要
TitleInfo()
メソッドの概要
String | getComment() コメント取得
String | getTitle() タイトル取得
void | setComment(String comment) コメント設定
void | setTitle(String title) タイトル設定
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

TitleInfo

public TitleInfo()
メソッドの詳細

getTitle

public String getTitle()
タイトル取得

戻り値:
Returns the strTitle.

setTitle

public void setTitle(String title)
タイトル設定

パラメータ:
title - The title to set.

getComment

public String getComment()
コメント取得

戻り値:
Returns the comment.

setComment

public void setComment(String comment)
コメント設定

パラメータ:
comment - The strComment to set.
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer の使用

AbstractTreeNodeContainer を使用しているパッケージ
jp.co.intra_mart.foundation.page ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.page での AbstractTreeNodeContainer の使用

jp.co.intra_mart.foundation.page での AbstractTreeNodeContainer のサブクラス
class | TreeBranch ツリービュー内の「フォルダ」をあらわすクラスです。
class | TreeRoot ツリービュー内の「ホーム」をあらわすクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.page.EventScript の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.page.EventScript の使用

jp.co.intra_mart.foundation.page.EventScript はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.page.NodeNameComparator の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.page.NodeNameComparator の使用

jp.co.intra_mart.foundation.page.NodeNameComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.page.NodeTypeComparator の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.page.NodeTypeComparator の使用

jp.co.intra_mart.foundation.page.NodeTypeComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.page.TreeBranch の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.page.TreeBranch の使用

TreeBranch を使用しているパッケージ
jp.co.intra_mart.foundation.page ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.page での TreeBranch の使用

TreeBranch 型のパラメータを持つ jp.co.intra_mart.foundation.page のメソッド
void | TreeBranch.setAll(TreeBranch branch) 指定された branch 内の表示名称、ポップアップ文字列、引数文字列をこのオブジェクトに設定します。
void | AbstractTreeNodeContainer.addChildBranch(TreeBranch branch) 指定されたブランチ branchを子ノードとして追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.page.TreeLeaf の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.page.TreeLeaf の使用

TreeLeaf を使用しているパッケージ
jp.co.intra_mart.foundation.page ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.page での TreeLeaf の使用

TreeLeaf 型のパラメータを持つ jp.co.intra_mart.foundation.page のメソッド
 void AbstractTreeNodeContainer.addChildLeaf(TreeLeaf leaf)
指定されたリーフ leafを子ノードとして追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.page.TreeNode の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.page.TreeNode の使用

TreeNode を使用しているパッケージ
jp.co.intra_mart.foundation.page ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.page での TreeNode の使用

TreeNode を実装している jp.co.intra_mart.foundation.page のクラス
class | TreeBranch ツリービュー内の「フォルダ」をあらわすクラスです。
class | TreeLeaf ツリービュー内の「ページ」をあらわすクラスです。

TreeNode 型のパラメータを持つ jp.co.intra_mart.foundation.page のメソッド
void | AbstractTreeNodeContainer.addChildNode(TreeNode node) 指定されたノード node を子ノードとして追加します。
boolean | AbstractTreeNodeContainer.hasChildNode(TreeNode node) 指定されたノード node を持っているか調べます。
boolean | AbstractTreeNodeContainer.removeChildNode(TreeNode node) 指定されたノード node をこのノードの子から削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.page.TreeNodeContainer の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.page.TreeNodeContainer の使用

TreeNodeContainer を使用しているパッケージ
jp.co.intra_mart.foundation.page ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.page での TreeNodeContainer の使用

jp.co.intra_mart.foundation.page での TreeNodeContainer のサブインタフェース
 interface TreeNodeProvider
ツリービューの「ホーム」をあらわすインターフェースです。

TreeNodeContainer を実装している jp.co.intra_mart.foundation.page のクラス
class | AbstractTreeNodeContainer ツリービューの子ノードを扱うためのメソッドを提供する抽象クラスです。
class | TreeBranch ツリービュー内の「フォルダ」をあらわすクラスです。
class | TreeRoot ツリービュー内の「ホーム」をあらわすクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.page.TreeNodeProvider の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.page.TreeNodeProvider の使用

TreeNodeProvider を使用しているパッケージ
jp.co.intra_mart.foundation.page ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.page での TreeNodeProvider の使用

TreeNodeProvider を実装している jp.co.intra_mart.foundation.page のクラス
 class TreeRoot
ツリービュー内の「ホーム」をあらわすクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.page.TreeRoot の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.page.TreeRoot の使用

jp.co.intra_mart.foundation.page.TreeRoot はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AbstractTreeNodeContainer (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
クラス AbstractTreeNodeContainer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer
すべての実装インタフェース:
TreeNodeContainer
直系の既知のサブクラス:
TreeBranch, TreeRoot
public abstract class AbstractTreeNodeContainer
extends Object
implements TreeNodeContainer

ツリービューの子ノードを扱うためのメソッドを提供する抽象クラスです。
この抽象クラスを使用して、ツリービューの「ホーム」と「フォルダ」は子ノードの追加、削除などの処理を行います。

導入されたバージョン:
version 4.3
バージョン:
1.0

コンストラクタの概要
AbstractTreeNodeContainer()
子ノードを追加順に並べる、新しいオブジェクトを生成します。
AbstractTreeNodeContainer(Comparator comparator)
指定されたコンパレータに従って子ノードを並べる、新しいオブジェクトを生成します。
メソッドの概要
void | addChildBranch(TreeBranch branch) 指定されたブランチ branchを子ノードとして追加します。
void | addChildLeaf(TreeLeaf leaf) 指定されたリーフ leafを子ノードとして追加します。
void | addChildNode(TreeNode node) 指定されたノード node を子ノードとして追加します。
Collection | getChildNodes() このノードの子ノードをすべて含む Collectionを返します。
boolean | hasChildNode(TreeNode node) 指定されたノード node を持っているか調べます。
boolean | hasChildNodes() このノードが子ノードを持っているかどうかを判断します。
boolean | isEmpty() このノードの下に子ノードがないか調べます。
boolean | removeChildNode(TreeNode node) 指定されたノード node をこのノードの子から削除します。
void | removeChildNodes() 子ノードを全て削除します。
int | size() このノードが持つ子ノードの数を返します。
void | sort(Comparator comparator) 指定されたコンパレータに従って、子ノードをソートします。
void | sortAll(Comparator comparator) このノードの下にある、全ての子ノードを指定されたコンパレータに従ってソートします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractTreeNodeContainer

public AbstractTreeNodeContainer()
子ノードを追加順に並べる、新しいオブジェクトを生成します。

AbstractTreeNodeContainer

public AbstractTreeNodeContainer(Comparator comparator)
指定されたコンパレータに従って子ノードを並べる、新しいオブジェクトを生成します。

パラメータ:
comparator - コンパレータ
メソッドの詳細

addChildNode

public void addChildNode(TreeNode node)
                  throws NullPointerException
指定されたノード node を子ノードとして追加します。

パラメータ:
node - ツリーノード
例外:
NullPoiterException - 引数がnullだった場合
NullPointerException

addChildBranch

public void addChildBranch(TreeBranch branch)
                    throws NullPointerException
指定されたブランチ branchを子ノードとして追加します。

パラメータ:
branch - ブランチ
例外:
NullPointerException - 引数がnullだった場合

addChildLeaf

public void addChildLeaf(TreeLeaf leaf)
指定されたリーフ leafを子ノードとして追加します。

パラメータ:
leaf - リーフ
例外:
NullPointerException - 引数がnullだった場合

hasChildNode

public boolean hasChildNode(TreeNode node)
指定されたノード node を持っているか調べます。 持っているときはtrueを返します。

パラメータ:
node - 子として持っているかどうか調べるノード
戻り値:
指定されたノードを持つときはtrue、持っていないときはfalseを返します。

removeChildNode

public boolean removeChildNode(TreeNode node)
指定されたノード　node をこのノードの子から削除します。

パラメータ:
node - 削除指定されたノード
戻り値:
削除に成功したときはtrue、削除に失敗したときはfalseを返します。

removeChildNodes

public void removeChildNodes()
子ノードを全て削除します。

sort

public void sort(Comparator comparator)
          throws NullPointerException
指定されたコンパレータに従って、子ノードをソートします。 このメソッド呼出後、子ノードの追加は指定されたコンパレータに従ってソートされます。

パラメータ:
comparator - コンパレータ
例外:
NullPoiterException - 引数がnullだったとき
NullPointerException

sortAll

public void sortAll(Comparator comparator)
             throws NullPointerException
このノードの下にある、全ての子ノードを指定されたコンパレータに従ってソートします。

パラメータ:
comparator - コンパレータ
例外:
NullPointerException - 引数がnullだったとき

getChildNodes

public Collection getChildNodes()
このノードの子ノードをすべて含む Collectionを返します。 もし、一つも子ノードがない時は空のCollectionが返されます。

定義:
インタフェース TreeNodeContainer 内の getChildNodes
戻り値:
子ノードを含むCollection

hasChildNodes

public boolean hasChildNodes()
このノードが子ノードを持っているかどうかを判断します。 持っているときは、trueを返します。

定義:
インタフェース TreeNodeContainer 内の hasChildNodes
戻り値:
持ってるときは、trueを返します。

isEmpty

public boolean isEmpty()
このノードの下に子ノードがないか調べます。 このノードが一つも子を持っていないときにtrueを返します。

定義:
インタフェース TreeNodeContainer 内の isEmpty
戻り値:
子を持っていないときにtrueを返します。

size

public int size()
このノードが持つ子ノードの数を返します。

定義:
インタフェース TreeNodeContainer 内の size
戻り値:
子ノードの数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventScript (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
クラス EventScript

java.lang.Object
    拡張 jp.co.intra_mart.foundation.page.EventScript
public class EventScript
extends Object

ブラウザでスクリプトの各変数に対する変更イベントを実装するための スクリプトコードを提供します。

このオブジェクトが作成するスクリプトは JavaScript 1.2 に準拠します。

このオブジェクトが作成するスクリプトの動作にはクッキーを利用しています。 クッキーの容量制限を越える量の値をやり取り(監視や受取)はできません。 また、クッキーを保存する際、クッキーの path 属性は 「/」で値を保存 していますので、この機能で扱うデータは、セキュリティ的に問題のない 範囲にとどめるか、またはセキュリティ的に問題となる場合には、 他の方法を利用するようにして下さい。

イベント同士でやり取りできる値の変数型は、クッキーの制約により 文字列型のみとなります。他の変数型の値に関しては、イベントでの入出力に おいて、データの整合性が保証されません。

このオブジェクトは、新しいインスタンスが構築されるたびに内部のシーケンサに より各々のインスタンスに対してＩＤが割り振られています。このＩＤは、 ブラウザでイベントが実行された時にイベントのスクリプトが誤動作をしない ように各変数や関数名称に利用されています。
従って、１つのインスタンスから複数回にわたりスクリプトを生成して １つのページで動作させた場合、それらのスクリプトは誤動作をします。
またＩＤは、0 から始まり 255 までカウントされ、256 に達した時点で 再び 0 からインクリメントされるように実装されています。つまり、初めて 構築されたインスタンスと 257 回目に構築されたインスタンスにより 生成されたイベントのためのスクリプトを同じページで実行した場合、 誤動作を起こします。

JSP でこのクラスを利用する場合の例

<% EventScript es = new EventScript("my_event"); %>
<% es.setOnChange("window.alert(\"Change!!\");"); %>
<SCRIPT> <%= es.getScript(); %> </SCRIPT>

フィールドの概要
protected static int counter
このクラスからインスタンスが生成された回数。
コンストラクタの概要
EventScript(String name)
イベントスクリプトを作成するためのインスタンスを構築します。
メソッドの概要
String | getLanguage() 言語名を返します。
String | getLanguageVersion() 言語のバージョンを返します。
String | getScript() 設定された情報からイベントのためのスクリプトを作成します。
void | setFocus(String valName) イベントとして監視する変数名を指定します。
void | setInitialize(String value) イベントの初期値を指定します。
void | setOnChange(String src) 監視している値に変更があった場合に実行するスクリプトを指定します。
void | setReceive(String valName) イベントから値を受け取る変数名を指定します。
int | setTimer(int millis) イベントの監視間隔を設定します。
String | toString() このオブジェクトの文字列表現を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

フィールドの詳細

counter

protected static volatile int counter
このクラスからインスタンスが生成された回数。

この値は、0 から 255 の範囲で加算されていき、256 に達した時 0 にリセットされて再び加算されていきます。

コンストラクタの詳細

EventScript

public EventScript(String name)
イベントスクリプトを作成するためのインスタンスを構築します。

引数 name は、このイベントのＩＤになります。 同じＩＤを持つ EventScript のインスタンスから生成されたイベントは ブラウザで実行された時に、それぞれ連携しあうことができます。

パラメータ:
name - このイベントのＩＤ
例外:
NullPointerException - 引数が null
メソッドの詳細

getLanguage

public String getLanguage()
言語名を返します。

このオブジェクトの生成するスクリプトは、このメソッドの返す言語に準拠 しています。 ブラウザが、この言語に対応していない場合、イベントのスクリプトは 正常に動作しません。

戻り値:
生成されるスクリプトの言語名

getLanguageVersion

public String getLanguageVersion()
言語のバージョンを返します。

このオブジェクトの生成するスクリプトは、メソッド getLanguage() の返す 言語のこのメソッドの返すバージョンに準拠しています。 ブラウザが、この言語のバージョンに対応していない場合、 イベントのスクリプトは正常に動作しません。

戻り値:
生成されるスクリプトの言語のバージョン
関連項目:
getLanguage()

setTimer

public int setTimer(int millis)
イベントの監視間隔を設定します。

指定のミリ秒間隔で変数を監視します。
インスタンス構築時の初期値は 250 ミリ秒に設定されています。この値を 小さくする事で EventScript 同士の連携のタイミングをよりリアルタイムに することができますが、クライアント・コンピュータに大きな負荷が かかってしまいます。
戻り値は、前に設定されていた値です。

パラメータ:
millis - 監視間隔（ミリ秒）
戻り値:
前に設定されていた値

setReceive

public void setReceive(String valName)
イベントから値を受け取る変数名を指定します。

ここでは、イベントから値を受け取るための変数名称を指定します。
変数は、ブラウザ上で動作するスクリプトで扱える変数に限ります。

パラメータ:
valName - 変数名称

setFocus

public void setFocus(String valName)
イベントとして監視する変数名を指定します。

ここでは、イベントで値を監視する変数名称を指定します。
変数は、ブラウザ上で動作するスクリプトで扱える変数に限ります。

パラメータ:
valName - 変数名称

setInitialize

public void setInitialize(String value)
イベントの初期値を指定します。

イベント内部の監視変数の初期値を設定します。
初期値を監視対象変数の現在値と同じ値に設定する事により イベント動作開始時の setOnChange() の誤動作を 未然に防ぐ事が出来ます。

パラメータ:
value - 初期値
関連項目:
setOnChange(java.lang.String)

setOnChange

public void setOnChange(String src)
監視している値に変更があった場合に実行するスクリプトを指定します。

スクリプトは、ブラウザ上で動作するスクリプトに限ります。

パラメータ:
src - 変更イベント発生時に実行するスクリプト

getScript

public String getScript()
設定された情報からイベントのためのスクリプトを作成します。

このメソッドの返すスクリプトがブラウザ上で実行された時 イベントとして動作します。

戻り値:
スクリプトのソース

toString

public String toString()
このオブジェクトの文字列表現を返します。

実際には、このメソッドの結果は getScript() と同じです。

戻り値:
このオブジェクトの文字列表現
関連項目:
getScript()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NodeNameComparator (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
クラス NodeNameComparator

java.lang.Object
    拡張 jp.co.intra_mart.foundation.page.NodeNameComparator
すべての実装インタフェース:
Comparator, Serializable
public class NodeNameComparator
extends Object
implements Comparator, Serializable

ツリービューのノードを名前順にソートするためのコンパレータです。 並びは名前の昇順になります。

導入されたバージョン:
version 4.3
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
NodeNameComparator()
メソッドの概要
 int compare(Object arg0, Object arg1)
順序付けのために 2 つの引数を比較するメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

NodeNameComparator

public NodeNameComparator()
メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
順序付けのために 2 つの引数を比較するメソッドです。
最初の引数が 2 番目の引数より小さ い場合は負の整数、両方が等しい場合は 0、最初の引数が 2 番目の引 数より大きい場合は正の整数を返します。
このメソッドはツリービューのノードを名前で昇順にソートすることを目的としています。 もし、arg0とarg1が同じ名前でarg0.equals(arg1) == falseの時は正の整数を返します。arg0.equals(arg1)==trueの時は0を返します。

定義:
インタフェース Comparator 内の compare
パラメータ:
arg0 - 引数１
arg1 - 引数２
戻り値:
比較した結果
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NodeTypeComparator (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
クラス NodeTypeComparator

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.AbstractDualComparator
        拡張 jp.co.intra_mart.foundation.page.NodeTypeComparator
すべての実装インタフェース:
Comparator, DualComparator, Serializable
public class NodeTypeComparator
extends AbstractDualComparator

ツリービューのノードを種類順にソートするためのコンパレータです。
並び順は「フォルダ」、「ページ」の順になります。 比較対象の２つノードの種類が同じときは、コンストラクタで与えられた、 第２コンパレータで比較を行い、その結果を返します。

導入されたバージョン:
version 4.3
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
NodeTypeComparator(Comparator secondaryComparator)
第２コンパレータ secondaryComparatorを指定して、新たなオブジェクトを生成します。
メソッドの概要
Comparator | getPrimaryComparator() 第１コンパレータを取得します。
Comparator | getSecondaryComparator() 第２コンパレータを取得します。
クラス jp.co.intra_mart.foundation.utility.AbstractDualComparator から継承したメソッド
compare
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

NodeTypeComparator

public NodeTypeComparator(Comparator secondaryComparator)
第２コンパレータ secondaryComparatorを指定して、新たなオブジェクトを生成します。

パラメータ:
secondaryComparator - 第２コンパレータ
メソッドの詳細

getPrimaryComparator

public Comparator getPrimaryComparator()
第１コンパレータを取得します。
このクラスの第１コンパレータは、ツリービューのノードを種類順にソートするコンパレータです。

戻り値:
第１コンパレータ

getSecondaryComparator

public Comparator getSecondaryComparator()
第２コンパレータを取得します。
このクラスの第２コンパレータは、コンストラクタで指定されたコンパレータです。

戻り値:
第２コンパレータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.page (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.page
インタフェース
TreeNode
TreeNodeContainer
TreeNodeProvider
クラス
AbstractTreeNodeContainer
EventScript
NodeNameComparator
NodeTypeComparator
TreeBranch
TreeLeaf
TreeRoot


jp.co.intra_mart.foundation.page (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.page

ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

参照:
説明

インタフェースの概要
TreeNode | ツリービュー内の単一のノードを表すインターフェースです。
TreeNodeContainer | 子ノードを参照するためのメソッドが定義されたインターフェースです。
TreeNodeProvider | ツリービューの「ホーム」をあらわすインターフェースです。

クラスの概要
AbstractTreeNodeContainer | ツリービューの子ノードを扱うためのメソッドを提供する抽象クラスです。
EventScript | ブラウザでスクリプトの各変数に対する変更イベントを実装するための スクリプトコードを提供します。
NodeNameComparator | ツリービューのノードを名前順にソートするためのコンパレータです。
NodeTypeComparator | ツリービューのノードを種類順にソートするためのコンパレータです。
TreeBranch | ツリービュー内の「フォルダ」をあらわすクラスです。
TreeLeaf | ツリービュー内の「ページ」をあらわすクラスです。
TreeRoot | ツリービュー内の「ホーム」をあらわすクラスです。

パッケージ jp.co.intra_mart.foundation.page の説明

ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。


jp.co.intra_mart.foundation.page クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.page の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.utility.AbstractDualComparator (implements jp.co.intra_mart.foundation.utility.DualComparator)
      • class jp.co.intra_mart.foundation.page.NodeTypeComparator
    • class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer (implements jp.co.intra_mart.foundation.page.TreeNodeContainer)
      • class jp.co.intra_mart.foundation.page.TreeBranch (implements jp.co.intra_mart.foundation.page.TreeNode)
      • class jp.co.intra_mart.foundation.page.TreeRoot (implements jp.co.intra_mart.foundation.page.TreeNodeProvider)
    • class jp.co.intra_mart.foundation.page.EventScript
    • class jp.co.intra_mart.foundation.page.NodeNameComparator (implements java.util.Comparator, java.io.Serializable)
    • class jp.co.intra_mart.foundation.page.TreeLeaf (implements jp.co.intra_mart.foundation.page.TreeNode)

インタフェース階層

  • interface jp.co.intra_mart.foundation.page.TreeNode
  • interface jp.co.intra_mart.foundation.page.TreeNodeContainer
    • interface jp.co.intra_mart.foundation.page.TreeNodeProvider


パッケージ jp.co.intra_mart.foundation.page の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.page の使用

jp.co.intra_mart.foundation.page を使用しているパッケージ
jp.co.intra_mart.foundation.page ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.page により使用される jp.co.intra_mart.foundation.page のクラス
AbstractTreeNodeContainer
ツリービューの子ノードを扱うためのメソッドを提供する抽象クラスです。
TreeBranch
ツリービュー内の「フォルダ」をあらわすクラスです。
TreeLeaf
ツリービュー内の「ページ」をあらわすクラスです。
TreeNode
ツリービュー内の単一のノードを表すインターフェースです。
TreeNodeContainer
子ノードを参照するためのメソッドが定義されたインターフェースです。
TreeNodeProvider
ツリービューの「ホーム」をあらわすインターフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


TreeBranch (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
クラス TreeBranch

java.lang.Object
    拡張 jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer
        拡張 jp.co.intra_mart.foundation.page.TreeBranch
すべての実装インタフェース:
TreeNode, TreeNodeContainer
public class TreeBranch
extends AbstractTreeNodeContainer
implements TreeNode

ツリービュー内の「フォルダ」をあらわすクラスです。
TreeNodeインターフェースの実装クラスのインスタンスを子ノードとして持つことが出来ます。

導入されたバージョン:
version 4.3
バージョン:
1.0

コンストラクタの概要
TreeBranch()
新しいTreeBranchオブジェクトを生成します。
TreeBranch(Comparator comparator)
指定されたコンパレータに従って子ノードをソートする、新しいTreeBranchオブジェクトを生成します。
メソッドの概要
String | getArgument() 引数文字列を取得します。
String | getName() 項目の表示名称のを取得します。
String | getNote() マウスポイント時に表示されるポップアップ文字列を取得します。
void | setAll(TreeBranch branch) 指定された branch 内の表示名称、ポップアップ文字列、引数文字列をこのオブジェクトに設定します。
void | setArgument(String argument) 引数文字列を設定します。
void | setName(String name) 項目の表示名称のを設定します。
void | setNote(String note) マウスポイント時に表示されるポップアップ文字列を設定します。
クラス jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer から継承したメソッド
addChildBranch, addChildLeaf, addChildNode, getChildNodes, hasChildNode, hasChildNodes, isEmpty, removeChildNode, removeChildNodes, size, sort, sortAll
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

TreeBranch

public TreeBranch()
新しいTreeBranchオブジェクトを生成します。

TreeBranch

public TreeBranch(Comparator comparator)
指定されたコンパレータに従って子ノードをソートする、新しいTreeBranchオブジェクトを生成します。

パラメータ:
comparator - コンパレータ
メソッドの詳細

getName

public String getName()
項目の表示名称のを取得します。

定義:
インタフェース TreeNode 内の getName
戻り値:
項目の表示名称

setName

public void setName(String name)
項目の表示名称のを設定します。

パラメータ:
name - 項目の表示名称

getNote

public String getNote()
マウスポイント時に表示されるポップアップ文字列を取得します。

定義:
インタフェース TreeNode 内の getNote
戻り値:
ポップアップ文字列

setNote

public void setNote(String note)
マウスポイント時に表示されるポップアップ文字列を設定します。

パラメータ:
note - ポップアップ文字列

getArgument

public String getArgument()
引数文字列を取得します。引数文字列はマウスクリックイベント発生時に実行される任意の Client Side JavaScript 関数に渡されます。

定義:
インタフェース TreeNode 内の getArgument
戻り値:
引数文字列

setArgument

public void setArgument(String argument)
引数文字列を設定します。引数文字列はマウスクリックイベント発生時に実行される任意の Client Side JavaScript 関数に渡されます。

パラメータ:
argument - 引数文字列

setAll

public void setAll(TreeBranch branch)
指定された branch 内の表示名称、ポップアップ文字列、引数文字列をこのオブジェクトに設定します。

パラメータ:
branch - 指定されたブランチ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TreeLeaf (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
クラス TreeLeaf

java.lang.Object
    拡張 jp.co.intra_mart.foundation.page.TreeLeaf
すべての実装インタフェース:
TreeNode
public class TreeLeaf
extends Object
implements TreeNode

ツリービュー内の「ページ」をあらわすクラスです。 このクラスは子ノードを持つことが出来ません。

導入されたバージョン:
version 4.3
バージョン:
1.0

コンストラクタの概要
TreeLeaf()
新しくTreeLeafオブジェクトを生成します。
TreeLeaf(String name)
新しくTreeLeafオブジェクトを生成し、表示名称を設定します。
TreeLeaf(String name, String note)
新しくTreeLeafオブジェクトを生成し、表示名称と、ポップアップ文字列を設定します。
メソッドの概要
String | getArgument() 引数文字列を取得します。
String | getName() 項目の表示名称のを取得します。
String | getNote() マウスポイント時に表示されるポップアップ文字列を取得します。
void | setArgument(String argument) マウスクリックイベント発生時に実行される任意の Client Side JavaScript 関数に渡される引数文字列を設定します。
void | setName(String name) 項目の表示名称を設定します。
void | setNote(String note) マウスポイント時に表示されるポップアップ文字列を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

TreeLeaf

public TreeLeaf()
新しくTreeLeafオブジェクトを生成します。

TreeLeaf

public TreeLeaf(String name)
新しくTreeLeafオブジェクトを生成し、表示名称を設定します。

パラメータ:
name - 表示名称

TreeLeaf

public TreeLeaf(String name,
                String note)
新しくTreeLeafオブジェクトを生成し、表示名称と、ポップアップ文字列を設定します。

パラメータ:
name - 表示名称
note - ポップアップ文字列
メソッドの詳細

getName

public String getName()
項目の表示名称のを取得します。

定義:
インタフェース TreeNode 内の getName
戻り値:
項目の表示名称

setName

public void setName(String name)
項目の表示名称を設定します。

パラメータ:
name - 項目の表示名称

getNote

public String getNote()
マウスポイント時に表示されるポップアップ文字列を取得します。

定義:
インタフェース TreeNode 内の getNote
戻り値:
note ポップアップ文字列

setNote

public void setNote(String note)
マウスポイント時に表示されるポップアップ文字列を設定します。

パラメータ:
note -

getArgument

public String getArgument()
引数文字列を取得します。引数文字列はマウスクリックイベント発生時に実行される任意の Client Side JavaScript 関数に渡されます。

定義:
インタフェース TreeNode 内の getArgument
戻り値:
JavaScript JavaScript関数に渡される引数文字列

setArgument

public void setArgument(String argument)
マウスクリックイベント発生時に実行される任意の Client Side JavaScript 関数に渡される引数文字列を設定します。

パラメータ:
argument - 引数文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TreeNode (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
インタフェース TreeNode

既知の実装クラスの一覧:
TreeBranch, TreeLeaf
public interface TreeNode

ツリービュー内の単一のノードを表すインターフェースです。 ツリービュー表示時の表示名称、ポップアップ文字列、JavaScript 関数に渡される引数文字列を取得するメソッドを持ちます。

導入されたバージョン:
version 4.3
バージョン:
1.0

メソッドの概要
String | getArgument() 引数文字列を取得します。
String | getName() 項目の表示名称のを取得します。
String | getNote() マウスポイント時に表示されるポップアップ文字列を取得します。

メソッドの詳細

getName

public String getName()
項目の表示名称のを取得します。

戻り値:
項目の表示名称

getNote

public String getNote()
マウスポイント時に表示されるポップアップ文字列を取得します。

戻り値:
ポップアップ文字列

getArgument

public String getArgument()
引数文字列を取得します。引数文字列はマウスクリックイベント発生時に実行される任意の Client Side JavaScript 関数に渡されます。

戻り値:
引数文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


TreeNodeContainer (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
インタフェース TreeNodeContainer

既知のサブインタフェースの一覧:
TreeNodeProvider
既知の実装クラスの一覧:
AbstractTreeNodeContainer, TreeRoot
public interface TreeNodeContainer

子ノードを参照するためのメソッドが定義されたインターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
Collection | getChildNodes() このノードの子をすべて含む Collectionを返します。
boolean | hasChildNodes() このノードが子ノードを持っているかどうかを判断します。
boolean | isEmpty() このノードが一つも子を持っていないときにtrueを返します。
int | size() このノードが持つ子ノードの数を返します。

メソッドの詳細

getChildNodes

public Collection getChildNodes()
このノードの子をすべて含む Collectionを返します。 もし、一つも子ノードがない時は空のCollectionが返されます。

戻り値:
子ノードを含むCollection

hasChildNodes

public boolean hasChildNodes()
このノードが子ノードを持っているかどうかを判断します。 持っているときは、trueを返します。

戻り値:
持ってるときは、trueを返します。

isEmpty

public boolean isEmpty()
このノードが一つも子を持っていないときにtrueを返します。

戻り値:
子を持っていないときにtrueを返します。

size

public int size()
このノードが持つ子ノードの数を返します。

戻り値:
子ノードの数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TreeNodeProvider (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
インタフェース TreeNodeProvider

すべてのスーパーインタフェース:
TreeNodeContainer
既知の実装クラスの一覧:
TreeRoot
public interface TreeNodeProvider
extends TreeNodeContainer

ツリービューの「ホーム」をあらわすインターフェースです。 ツリービューの「ホーム」をあらわすクラスを作成するときは必ずこのインターフェースを実装する必要があります。

導入されたバージョン:
version 4.3
バージョン:
1.0

メソッドの概要
 Set getNodeSet()
ツリービュー内の「ホーム」以外の全てのノードが含まれるSetを返します。
インタフェース jp.co.intra_mart.foundation.page.TreeNodeContainer から継承したメソッド
getChildNodes, hasChildNodes, isEmpty, size

メソッドの詳細

getNodeSet

public Set getNodeSet()
ツリービュー内の「ホーム」以外の全てのノードが含まれるSetを返します。

戻り値:
ルート以外の全てのノードが含まれるSet
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


TreeRoot (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
クラス TreeRoot

java.lang.Object
    拡張 jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer
        拡張 jp.co.intra_mart.foundation.page.TreeRoot
すべての実装インタフェース:
TreeNodeContainer, TreeNodeProvider
public class TreeRoot
extends AbstractTreeNodeContainer
implements TreeNodeProvider

ツリービュー内の「ホーム」をあらわすクラスです。 子のクラスのオブジェクトは、ツリービュー内に一つだけ存在し、ツリーの原点となるノードです。

導入されたバージョン:
version 4.3
バージョン:
1.0

コンストラクタの概要
TreeRoot()
新しいTreeRootオブジェクトを生成します。
TreeRoot(Comparator comparator)
指定されたコンパレータに従って子ノードをソートする、新しいTreeRootオブジェクトを生成します。
メソッドの概要
 Set getNodeSet()
ツリービュー内の「ホーム」以外の全てのノードが含まれるSetを返します。
クラス jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer から継承したメソッド
addChildBranch, addChildLeaf, addChildNode, getChildNodes, hasChildNode, hasChildNodes, isEmpty, removeChildNode, removeChildNodes, size, sort, sortAll
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.foundation.page.TreeNodeContainer から継承したメソッド
getChildNodes, hasChildNodes, isEmpty, size

コンストラクタの詳細

TreeRoot

public TreeRoot()
新しいTreeRootオブジェクトを生成します。

TreeRoot

public TreeRoot(Comparator comparator)
指定されたコンパレータに従って子ノードをソートする、新しいTreeRootオブジェクトを生成します。

パラメータ:
comparator - 指定されたコンパレータ
メソッドの詳細

getNodeSet

public Set getNodeSet()
ツリービュー内の「ホーム」以外の全てのノードが含まれるSetを返します。

定義:
インタフェース TreeNodeProvider 内の getNodeSet
戻り値:
ルート以外の全てのノードが含まれるSet
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager の使用

jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived の使用

NewArrived を使用しているパッケージ
jp.co.intra_mart.foundation.portal.general_purpose_portlet
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider
jp.co.intra_mart.foundation.security.password

jp.co.intra_mart.foundation.portal.general_purpose_portlet での NewArrived の使用

NewArrived を返す jp.co.intra_mart.foundation.portal.general_purpose_portlet のメソッド
static NewArrived[] NewArrivedManager.getNewArrivedList(String config)
汎用新着情報の一覧を取得します。

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider での NewArrived の使用

NewArrived を返す jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider のメソッド
NewArrived[] | PageBaseCallProvider.getNewArrivedList(String user, String group) 汎用新着情報を取得
NewArrived[] | NewArrivedProvider.getNewArrivedList(String user, String group) 新着情報を一覧を取得します。

jp.co.intra_mart.foundation.security.password での NewArrived の使用

NewArrived を返す jp.co.intra_mart.foundation.security.password のメソッド
 NewArrived[] PasswordHistoryNewArrivedProvider.getNewArrivedList(String user, String group)
パスワード履歴管理の新着情報を一覧を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


NewArrived (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.general_purpose_portlet.model
クラス NewArrived

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived
すべての実装インタフェース:
Serializable
public class NewArrived
extends Object
implements Serializable

汎用新着情報を保持します。

導入されたバージョン:
5.1
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
NewArrived()
メソッドの概要
String | getCategory() 新着情報のカテゴリ名を取得します。
String | getContents() 新着情報の内容を取得します。
String | getDate() 日付を取得します。
String | getUrl() リンク先のURLを取得します。
boolean | isPopup() リンクへ参照時にポップアップを呼び出すかどうかを取得します。
void | setCategory(String category) 新着情報のカテゴリ名を設定します。
void | setContents(String contents) 新着情報の内容を設定します。
void | setDate(String date) 日付を設定します。
void | setPopup(boolean popup) リンクへ参照時にポップアップを呼び出すかどうかを設定します。
void | setUrl(String url) リンク先のURLを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NewArrived

public NewArrived()
メソッドの詳細

getCategory

public String getCategory()
新着情報のカテゴリ名を取得します。

戻り値:
新着カテゴリ名

setCategory

public void setCategory(String category)
新着情報のカテゴリ名を設定します。 カテゴリ名に null が設定された場合は、空文字に変換します。

パラメータ:
category - 新着カテゴリ名

getContents

public String getContents()
新着情報の内容を取得します。

戻り値:
新着情報の内容

setContents

public void setContents(String contents)
新着情報の内容を設定します。 内容に null が設定された場合は、空文字に変換します。

パラメータ:
contents - 新着情報の内容

getUrl

public String getUrl()
リンク先のURLを取得します。

戻り値:
リンク先のURL

setUrl

public void setUrl(String url)
リンク先のURLを設定します。 URLに null が設定された場合は、空文字に変換します。

パラメータ:
url - リンク先のURL

isPopup

public boolean isPopup()
リンクへ参照時にポップアップを呼び出すかどうかを取得します。

戻り値:
ポップアップを呼び出す場合は true、それ以外は falseを返します。

setPopup

public void setPopup(boolean popup)
リンクへ参照時にポップアップを呼び出すかどうかを設定します。

パラメータ:
popup - ポップアップするかどうか

getDate

public String getDate()
日付を取得します。

戻り値:
日付

setDate

public void setDate(String date)
日付を設定します。 日付に null が設定された場合は、空文字に変換します。

パラメータ:
date - 日付
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.portal.general_purpose_portlet.model (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.portal.general_purpose_portlet.model
クラス
NewArrived


jp.co.intra_mart.foundation.portal.general_purpose_portlet.model (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet.model

クラスの概要
NewArrived 汎用新着情報を保持します。


jp.co.intra_mart.foundation.portal.general_purpose_portlet.model クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet.model の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet.model の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.portal.general_purpose_portlet.model の使用

jp.co.intra_mart.foundation.portal.general_purpose_portlet.model を使用しているパッケージ
jp.co.intra_mart.foundation.portal.general_purpose_portlet
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider
jp.co.intra_mart.foundation.security.password

jp.co.intra_mart.foundation.portal.general_purpose_portlet により使用される jp.co.intra_mart.foundation.portal.general_purpose_portlet.model のクラス
NewArrived
汎用新着情報を保持します。

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider により使用される jp.co.intra_mart.foundation.portal.general_purpose_portlet.model のクラス
NewArrived
汎用新着情報を保持します。

jp.co.intra_mart.foundation.security.password により使用される jp.co.intra_mart.foundation.portal.general_purpose_portlet.model のクラス
NewArrived
汎用新着情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider の使用

NewArrivedProvider を使用しているパッケージ
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider
jp.co.intra_mart.foundation.security.password

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider での NewArrivedProvider の使用

NewArrivedProvider を実装している jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider のクラス
 class PageBaseCallProvider
NewArrivedProvider インターフェースの実装です。

jp.co.intra_mart.foundation.security.password での NewArrivedProvider の使用

NewArrivedProvider を実装している jp.co.intra_mart.foundation.security.password のクラス
 class PasswordHistoryNewArrivedProvider
パスワード履歴管理汎用新着情報のプロバイダ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider の使用

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


NewArrivedProvider (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider
インタフェース NewArrivedProvider

既知の実装クラスの一覧:
PageBaseCallProvider, PasswordHistoryNewArrivedProvider
public interface NewArrivedProvider

汎用新着情報のプロバイダのインターフェースです。

導入されたバージョン:
5.1
バージョン:
1.0

メソッドの概要
NewArrived[] | getNewArrivedList(String user, String group) 新着情報を一覧を取得します。
void | init(Properties properties) 初期化を行います。

メソッドの詳細

init

public void init(Properties properties)
初期化を行います。

パラメータ:
properties - 初期化パラメータ

getNewArrivedList

public NewArrived[] getNewArrivedList(String user,
                                      String group)
                               throws jp.co.intra_mart.framework.system.exception.ApplicationException
新着情報を一覧を取得します。
新着情報が存在しない場合は、空の配列を返します。

パラメータ:
user - ログインユーザコード
group - ログイングループID
戻り値:
新着情報の一覧
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException - 新着情報の取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider
インタフェース
NewArrivedProvider
クラス
PageBaseCallProvider


jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider

インタフェースの概要
NewArrivedProvider 汎用新着情報のプロバイダのインターフェースです。

クラスの概要
PageBaseCallProvider NewArrivedProvider インターフェースの実装です。


jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider (implements jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider)

インタフェース階層

  • interface jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider


パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider の使用

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider を使用しているパッケージ
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider
jp.co.intra_mart.foundation.security.password

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider により使用される jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider のクラス
NewArrivedProvider
汎用新着情報のプロバイダのインターフェースです。

jp.co.intra_mart.foundation.security.password により使用される jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider のクラス
NewArrivedProvider
汎用新着情報のプロバイダのインターフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PageBaseCallProvider (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider
クラス PageBaseCallProvider

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider
すべての実装インタフェース:
NewArrivedProvider
public class PageBaseCallProvider
extends Object
implements NewArrivedProvider

NewArrivedProvider インターフェースの実装です。

このクラスは、initメソッドで設定される Properties オブジェクトから 定数 PAGE_PATH をキー名として特定されるページベースプログラムから、新着情報の一覧を取得します。
ページベースプログラムにパラメータを渡したい場合は、initメソッドで設定される Properties オブジェクトにページベースプログラムの情報に加えて、任意のキーでパラメータを設定して下さい。

このクラスから呼び出されるページベースプログラムは、返却値として配列を返す必要があります。 配列の要素は、以下のプロパティを格納したオブジェクトです。

新着情報オブジェクト
プロパティ名 | JavaScriptの型 | 設定内容
category | String | 新着情報のカテゴリ名
contents | String | 新着情報の内容
url | String | 新着情報の詳細情報へ遷移するURL
popup | Boolean | 詳細情報へ遷移する際にポップアップするかどうかのフラグ
date | String | 新着情報の配信日付

導入されたバージョン:
5.1
バージョン:
1.0

フィールドの概要
static String PAGE_PATH
ページベースプログラム名を特定するキー
コンストラクタの概要
PageBaseCallProvider()
メソッドの概要
NewArrived[] | getNewArrivedList(String user, String group) 汎用新着情報を取得
void | init(Properties properties) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PAGE_PATH

public static final String PAGE_PATH
ページベースプログラム名を特定するキー

関連項目:
定数フィールド値
コンストラクタの詳細

PageBaseCallProvider

public PageBaseCallProvider()
メソッドの詳細

getNewArrivedList

public NewArrived[] getNewArrivedList(String user,
                                      String group)
                               throws jp.co.intra_mart.framework.system.exception.ApplicationException
汎用新着情報を取得

定義:
インタフェース NewArrivedProvider 内の getNewArrivedList
パラメータ:
user - ユーザコード
group - グループコード
戻り値:
汎用新着情報一覧
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException - 新着情報の取得に失敗した場合

init

public void init(Properties properties)
初期化を行います。

定義:
インタフェース NewArrivedProvider 内の init
パラメータ:
properties - 初期化パラメータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


NewArrivedManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.general_purpose_portlet
クラス NewArrivedManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager
public class NewArrivedManager
extends Object

汎用新着情報の取得処理を行うクラスです。
汎用新着情報の取得を行う際は、このクラスを利用します。

導入されたバージョン:
5.1
バージョン:
1.0

コンストラクタの概要
NewArrivedManager()
メソッドの概要
static NewArrived[] getNewArrivedList(String config)
汎用新着情報の一覧を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NewArrivedManager

public NewArrivedManager()
メソッドの詳細

getNewArrivedList

public static NewArrived[] getNewArrivedList(String config)
                                      throws jp.co.intra_mart.framework.system.exception.ApplicationException
汎用新着情報の一覧を取得します。
引数の設定ファイルは、ストレージサービスからの相対パスで指定します。
新着情報が存在しなかった場合は、空の配列を返します。

パラメータ:
config - 設定ファイル
戻り値:
新着情報の一覧
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException - 新着情報の取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.portal.general_purpose_portlet (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.portal.general_purpose_portlet
クラス
NewArrivedManager


jp.co.intra_mart.foundation.portal.general_purpose_portlet (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet

クラスの概要
NewArrivedManager 汎用新着情報の取得処理を行うクラスです。


jp.co.intra_mart.foundation.portal.general_purpose_portlet クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager


パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.portal.general_purpose_portlet の使用

jp.co.intra_mart.foundation.portal.general_purpose_portlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.portlet.PortletManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.portlet.PortletManager の使用

jp.co.intra_mart.foundation.portal.portlet.PortletManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.portlet.PortletManagerException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.portlet.PortletManagerException の使用

PortletManagerException を使用しているパッケージ
jp.co.intra_mart.foundation.portal.portlet

jp.co.intra_mart.foundation.portal.portlet での PortletManagerException の使用

PortletManagerException をスローする jp.co.intra_mart.foundation.portal.portlet のメソッド
void | PortletManager.setPortlet(Portlet portlet) ポートレット情報を登録します。
void | PortletManager.deletePortlet(Portlet portlet) ポートレット情報を削除します。
Portlet | PortletManager.getPortlet(String portletCode, String pageKind) すでに登録済のポートレット情報を取得します。
Portlet[] | PortletManager.getPortlets() すでに登録されているポートレット情報の一覧を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.portlet.PortletMapping の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.portlet.PortletMapping の使用

PortletMapping を使用しているパッケージ
jp.co.intra_mart.foundation.portal.portlet

jp.co.intra_mart.foundation.portal.portlet での PortletMapping の使用

PortletMapping を返す jp.co.intra_mart.foundation.portal.portlet のメソッド
static PortletMapping PortletMapping.getInstance()
インスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet の使用

jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet の使用

J2eeFwPortlet を使用しているパッケージ
jp.co.intra_mart.foundation.portal.portlet.model

jp.co.intra_mart.foundation.portal.portlet.model での J2eeFwPortlet の使用

jp.co.intra_mart.foundation.portal.portlet.model での J2eeFwPortlet のサブクラス
class | MenuLinkSetPortlet ページ種別「メニューリンクセット」に対するポートレットのモデルです。
class | RssPortlet ページ種別「RSS」に対するポートレットのモデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet の使用

jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet の使用

jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.portlet.model.Portlet の使用

Portlet を使用しているパッケージ
jp.co.intra_mart.foundation.portal.portlet
jp.co.intra_mart.foundation.portal.portlet.model

jp.co.intra_mart.foundation.portal.portlet での Portlet の使用

Portlet を返す jp.co.intra_mart.foundation.portal.portlet のメソッド
Portlet | PortletMapping.getPortlet(String pageKind) 指定されたページ種別に対応するポートレットモデルのインスタンスを取得します。
Portlet | PortletManager.getPortlet(String portletCode, String pageKind) すでに登録済のポートレット情報を取得します。
Portlet[] | PortletManager.getPortlets() すでに登録されているポートレット情報の一覧を取得します。

Portlet 型のパラメータを持つ jp.co.intra_mart.foundation.portal.portlet のメソッド
void | PortletManager.setPortlet(Portlet portlet) ポートレット情報を登録します。
void | PortletManager.deletePortlet(Portlet portlet) ポートレット情報を削除します。

jp.co.intra_mart.foundation.portal.portlet.model での Portlet の使用

jp.co.intra_mart.foundation.portal.portlet.model での Portlet のサブクラス
class | InternetPortlet ページ種別「インターネット」に対するポートレットのモデルです。
class | J2eeFwPortlet ページ種別「J2EEフレームワーク」に対するポートレットのモデルです。
class | JspPortlet ページ種別「Servlet/JSP」に対するポートレットのモデルです。
class | MenuLinkSetPortlet ページ種別「メニューリンクセット」に対するポートレットのモデルです。
class | PresentationPagePortlet ページ種別「プレゼンテーションページ」に対するポートレットのモデルです。
class | RssPortlet ページ種別「RSS」に対するポートレットのモデルです。
class | StandardPortlet 標準ポートレットに対するモデルの抽象クラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet の使用

jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet の使用

jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet の使用

StandardPortlet を使用しているパッケージ
jp.co.intra_mart.foundation.portal.portlet.model

jp.co.intra_mart.foundation.portal.portlet.model での StandardPortlet の使用

jp.co.intra_mart.foundation.portal.portlet.model での StandardPortlet のサブクラス
class | InternetPortlet ページ種別「インターネット」に対するポートレットのモデルです。
class | JspPortlet ページ種別「Servlet/JSP」に対するポートレットのモデルです。
class | PresentationPagePortlet ページ種別「プレゼンテーションページ」に対するポートレットのモデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


InternetPortlet (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.portlet.model
クラス InternetPortlet

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.portlet.model.Portlet
        拡張 jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet
            拡張 jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet
すべての実装インタフェース:
Serializable
public class InternetPortlet
extends StandardPortlet

ページ種別「インターネット」に対するポートレットのモデルです。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
static String PAGE_KIND
ページ種別
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したフィールド
DISPLAY_NONE, DISPLAY_PERCENT, DISPLAY_PIXCEL
コンストラクタの概要
InternetPortlet()
メソッドの概要
boolean | equals(Object obj) このポートレットと別のオブジェクトとが等しいかどうかを比較します。
String | getPageKind() ページ種別を取得します。
クラス jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet から継承したメソッド
getArgument, getUrl, setArgument, setUrl
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したメソッド
getApplication, getCacheTime, getExplain, getHeight, getPortletCode, getPortletName, getRecordDate, getRecordUserCode, getUnit, getWidth, hashCode, isTitleBar, setApplication, setCacheConfig, setExplain, setHeight, setPortletCode, setPortletName, setRecordDate, setRecordUserCode, setTitleBar, setUnit, setWidth
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PAGE_KIND

public static final String PAGE_KIND
ページ種別

関連項目:
定数フィールド値
コンストラクタの詳細

InternetPortlet

public InternetPortlet()
メソッドの詳細

getPageKind

public String getPageKind()
ページ種別を取得します。

定義:
クラス Portlet 内の getPageKind
戻り値:
ページ種別

equals

public boolean equals(Object obj)
このポートレットと別のオブジェクトとが等しいかどうかを比較します。
2つのポートレットが等しいのは、同じポートレット種別、同じポートレットコードを持つ場合です。

戻り値:
オブジェクトが同じである場合はtrue、そうでない場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


J2eeFwPortlet (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.portlet.model
クラス J2eeFwPortlet

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.portlet.model.Portlet
        拡張 jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
MenuLinkSetPortlet, RssPortlet
public class J2eeFwPortlet
extends Portlet

ページ種別「J2EEフレームワーク」に対するポートレットのモデルです。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
static String PAGE_KIND
ページ種別
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したフィールド
DISPLAY_NONE, DISPLAY_PERCENT, DISPLAY_PIXCEL
コンストラクタの概要
J2eeFwPortlet()
メソッドの概要
boolean | equals(Object obj) このポートレットと別のオブジェクトとが等しいかどうかを比較します。
String | getApplicationId() アプリケーションIDを取得します。
String | getArgument() ページ引数を取得します。
String | getPageKind() ページ種別を取得します。
String | getServiceId() サービスIDを取得します。
void | setApplicationId(String applicationId) アプリケーションIDを設定します。
void | setArgument(String argument) ページ引数を設定します。
void | setServiceId(String serviceId) サービスIDを設定します。
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したメソッド
getApplication, getCacheTime, getExplain, getHeight, getPortletCode, getPortletName, getRecordDate, getRecordUserCode, getUnit, getWidth, hashCode, isTitleBar, setApplication, setCacheConfig, setExplain, setHeight, setPortletCode, setPortletName, setRecordDate, setRecordUserCode, setTitleBar, setUnit, setWidth
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PAGE_KIND

public static final String PAGE_KIND
ページ種別

関連項目:
定数フィールド値
コンストラクタの詳細

J2eeFwPortlet

public J2eeFwPortlet()
メソッドの詳細

getApplicationId

public String getApplicationId()
アプリケーションIDを取得します。

戻り値:
アプリケーションID
例外:
IllegalStateException - アプリケーションIDがnullである場合

setApplicationId

public void setApplicationId(String applicationId)
アプリケーションIDを設定します。(必須)
アプリケーションIDは必須項目です。必ずnull以外の値を設定して下さい。

パラメータ:
applicationId - アプリケーションID
例外:
IllegalArgumentException - アプリケーションIDにnullが設定された場合

getServiceId

public String getServiceId()
サービスIDを取得します。

戻り値:
サービスID
例外:
IllegalStateException - サービスIDがnullである場合

setServiceId

public void setServiceId(String serviceId)
サービスIDを設定します。(必須)
サービスIDは必須項目です。必ずnull以外の値を設定して下さい。

パラメータ:
serviceId - サービスID
例外:
IllegalArgumentException - サービスIDにnullが設定された場合

getArgument

public String getArgument()
ページ引数を取得します。

戻り値:
ページ引数

setArgument

public void setArgument(String argument)
ページ引数を設定します。

パラメータ:
argument - ページ引数

getPageKind

public String getPageKind()
ページ種別を取得します。

定義:
クラス Portlet 内の getPageKind
戻り値:
ページ種別

equals

public boolean equals(Object obj)
このポートレットと別のオブジェクトとが等しいかどうかを比較します。
2つのポートレットが等しいのは、同じポートレット種別、同じポートレットコードを持つ場合です。

戻り値:
オブジェクトが同じである場合はtrue、そうでない場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


JspPortlet (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.portlet.model
クラス JspPortlet

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.portlet.model.Portlet
        拡張 jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet
            拡張 jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet
すべての実装インタフェース:
Serializable
public class JspPortlet
extends StandardPortlet

ページ種別「Servlet/JSP」に対するポートレットのモデルです。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
static String PAGE_KIND
ページ種別
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したフィールド
DISPLAY_NONE, DISPLAY_PERCENT, DISPLAY_PIXCEL
コンストラクタの概要
JspPortlet()
メソッドの概要
boolean | equals(Object obj) このポートレットと別のオブジェクトとが等しいかどうかを比較します。
String | getPageKind() ページ種別を取得します。
クラス jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet から継承したメソッド
getArgument, getUrl, setArgument, setUrl
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したメソッド
getApplication, getCacheTime, getExplain, getHeight, getPortletCode, getPortletName, getRecordDate, getRecordUserCode, getUnit, getWidth, hashCode, isTitleBar, setApplication, setCacheConfig, setExplain, setHeight, setPortletCode, setPortletName, setRecordDate, setRecordUserCode, setTitleBar, setUnit, setWidth
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PAGE_KIND

public static final String PAGE_KIND
ページ種別

関連項目:
定数フィールド値
コンストラクタの詳細

JspPortlet

public JspPortlet()
メソッドの詳細

getPageKind

public String getPageKind()
ページ種別を取得します。

定義:
クラス Portlet 内の getPageKind
戻り値:
ページ種別

equals

public boolean equals(Object obj)
このポートレットと別のオブジェクトとが等しいかどうかを比較します。
2つのポートレットが等しいのは、同じポートレット種別、同じポートレットコードを持つ場合です。

戻り値:
オブジェクトが同じである場合はtrue、そうでない場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuLinkSetPortlet (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.portlet.model
クラス MenuLinkSetPortlet

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.portlet.model.Portlet
        拡張 jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet
            拡張 jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet
すべての実装インタフェース:
Serializable
public class MenuLinkSetPortlet
extends J2eeFwPortlet

ページ種別「メニューリンクセット」に対するポートレットのモデルです。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
static String PAGE_KIND
ページ種別
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したフィールド
DISPLAY_NONE, DISPLAY_PERCENT, DISPLAY_PIXCEL
コンストラクタの概要
MenuLinkSetPortlet()
コンストラクタ
メソッドの概要
boolean | equals(Object obj) このポートレットと別のオブジェクトとが等しいかどうかを比較します。
String | getMenuLinkSetCode() メニューリンクセットコードを取得します。
String | getPageKind() ページ種別を取得します。
void | setMenuLinkSetCode(String menuLinkSetCode) メニューリンクセットコードを設定します。
クラス jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet から継承したメソッド
getApplicationId, getArgument, getServiceId, setApplicationId, setArgument, setServiceId
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したメソッド
getApplication, getCacheTime, getExplain, getHeight, getPortletCode, getPortletName, getRecordDate, getRecordUserCode, getUnit, getWidth, hashCode, isTitleBar, setApplication, setCacheConfig, setExplain, setHeight, setPortletCode, setPortletName, setRecordDate, setRecordUserCode, setTitleBar, setUnit, setWidth
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PAGE_KIND

public static final String PAGE_KIND
ページ種別

関連項目:
定数フィールド値
コンストラクタの詳細

MenuLinkSetPortlet

public MenuLinkSetPortlet()
コンストラクタ

メソッドの詳細

getMenuLinkSetCode

public String getMenuLinkSetCode()
メニューリンクセットコードを取得します。

戻り値:
メニューリンクセットコード
例外:
IllegalStateException - メニューリンクセットコードがnullである場合

setMenuLinkSetCode

public void setMenuLinkSetCode(String menuLinkSetCode)
メニューリンクセットコードを設定します。(必須)
メニューリンクセットコードは必須項目です。必ずnull以外の値を設定して下さい。

パラメータ:
menuLinkSetCode - メニューリンクセットコード
例外:
IllegalArgumentException - メニューリンクセットコードにnullが設定された場合

getPageKind

public String getPageKind()
ページ種別を取得します。

オーバーライド:
クラス J2eeFwPortlet 内の getPageKind
戻り値:
ページ種別

equals

public boolean equals(Object obj)
このポートレットと別のオブジェクトとが等しいかどうかを比較します。
2つのポートレットが等しいのは、同じポートレット種別、同じポートレットコードを持つ場合です。

オーバーライド:
クラス J2eeFwPortlet 内の equals
戻り値:
オブジェクトが同じである場合はtrue、そうでない場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.portal.portlet.model (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.portal.portlet.model
クラス
InternetPortlet
J2eeFwPortlet
JspPortlet
MenuLinkSetPortlet
Portlet
PresentationPagePortlet
RssPortlet
StandardPortlet


jp.co.intra_mart.foundation.portal.portlet.model (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.portlet.model

クラスの概要
InternetPortlet | ページ種別「インターネット」に対するポートレットのモデルです。
J2eeFwPortlet | ページ種別「J2EEフレームワーク」に対するポートレットのモデルです。
JspPortlet | ページ種別「Servlet/JSP」に対するポートレットのモデルです。
MenuLinkSetPortlet | ページ種別「メニューリンクセット」に対するポートレットのモデルです。
Portlet | すべてのポートレットの基底となる抽象クラスです。
PresentationPagePortlet | ページ種別「プレゼンテーションページ」に対するポートレットのモデルです。
RssPortlet | ページ種別「RSS」に対するポートレットのモデルです。
StandardPortlet | 標準ポートレットに対するモデルの抽象クラスです。


jp.co.intra_mart.foundation.portal.portlet.model クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.portlet.model の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.portal.portlet.model.Portlet (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet
        • class jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet
        • class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet
      • class jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet
        • class jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet
        • class jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet
        • class jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet


パッケージ jp.co.intra_mart.foundation.portal.portlet.model の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.portal.portlet.model の使用

jp.co.intra_mart.foundation.portal.portlet.model を使用しているパッケージ
jp.co.intra_mart.foundation.portal.portlet
jp.co.intra_mart.foundation.portal.portlet.model

jp.co.intra_mart.foundation.portal.portlet により使用される jp.co.intra_mart.foundation.portal.portlet.model のクラス
Portlet
すべてのポートレットの基底となる抽象クラスです。

jp.co.intra_mart.foundation.portal.portlet.model により使用される jp.co.intra_mart.foundation.portal.portlet.model のクラス
J2eeFwPortlet
ページ種別「J2EEフレームワーク」に対するポートレットのモデルです。
Portlet
すべてのポートレットの基底となる抽象クラスです。
StandardPortlet
標準ポートレットに対するモデルの抽象クラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Portlet (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.portlet.model
クラス Portlet

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.portlet.model.Portlet
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
J2eeFwPortlet, StandardPortlet
public abstract class Portlet
extends Object
implements Serializable

すべてのポートレットの基底となる抽象クラスです。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
static String | DISPLAY_NONE 表示単位を指定しない状態
static String | DISPLAY_PERCENT 表示単位パーセント
static String | DISPLAY_PIXCEL 表示単位ピクセル
コンストラクタの概要
Portlet()
メソッドの概要
String | getApplication() アプリケーション名を取得します。
int | getCacheTime() キャッシュ時間を取得します。
String | getExplain() 説明を取得します。
int | getHeight() 表示単位に対する高さを取得します。
abstract String | getPageKind() ページ種別を取得します。
String | getPortletCode() ポートレットコードを取得します。
String | getPortletName() ポートレット名を取得します。
Date | getRecordDate() レコード更新日を取得します。
String | getRecordUserCode() レコード更新ユーザコードを取得します。
String | getUnit() 表示単位を取得します。
int | getWidth() 表示単位に対する幅を取得します。
int | hashCode() このオブジェクトに対するハッシュコード値を返します。
boolean | isTitleBar() タイトルバーを表示するかどうかのステータスを取得します。
void | setApplication(String application) アプリケーション名を設定します。
void | setCacheConfig(int cacheTime) キャッシュ時間を設定します。
void | setExplain(String explain) 説明を設定します。
void | setHeight(int height) 表示単位に対する高さを設定します。
void | setPortletCode(String portletCode) ポートレットコードを設定します。
void | setPortletName(String portletName) ポートレット名を設定します。
void | setRecordDate(Date recordDate) レコード更新日を設定します。
void | setRecordUserCode(String recordUserCode) レコード更新ユーザコードを設定します。
void | setTitleBar(boolean titleBar) タイトルバーを表示するかどうかのステータスを設定します。
void | setUnit(String unit) 表示単位を設定します。
void | setWidth(int width) 表示単位に対する幅設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DISPLAY_NONE

public static final String DISPLAY_NONE
表示単位を指定しない状態

DISPLAY_PERCENT

public static final String DISPLAY_PERCENT
表示単位パーセント

関連項目:
定数フィールド値

DISPLAY_PIXCEL

public static final String DISPLAY_PIXCEL
表示単位ピクセル

関連項目:
定数フィールド値
コンストラクタの詳細

Portlet

public Portlet()
メソッドの詳細

getApplication

public String getApplication()
アプリケーション名を取得します。

戻り値:
アプリケーション名

setApplication

public void setApplication(String application)
アプリケーション名を設定します。

パラメータ:
application - アプリケーション名

getCacheTime

public int getCacheTime()
キャッシュ時間を取得します。
初期値は 0 (キャッシュ設定なし)になります。

戻り値:
キャッシュ時間

setCacheConfig

public void setCacheConfig(int cacheTime)
キャッシュ時間を設定します。

パラメータ:
cacheTime - キャッシュ時間

getHeight

public int getHeight()
表示単位に対する高さを取得します。

戻り値:
表示高さ

setHeight

public void setHeight(int height)
表示単位に対する高さを設定します。

パラメータ:
height - 表示高

getUnit

public String getUnit()
表示単位を取得します。

戻り値:
表示単位

setUnit

public void setUnit(String unit)
表示単位を設定します。
表示単位には、以下のいずれのかの値を設定して下さい。
  • Portlet.DISPLAY_NONE (初期値)
  • Portlet.DISPLAY_PERCENT
  • Portlet.DISPLAY_PIXCEL
何れにも該当しない値が設定された場合は表示設定なしとします。

getWidth

public int getWidth()
表示単位に対する幅を取得します。

戻り値:
表示幅

setWidth

public void setWidth(int width)
表示単位に対する幅設定します。

パラメータ:
width - 表示幅

getExplain

public String getExplain()
説明を取得します。

戻り値:
説明

setExplain

public void setExplain(String explain)
説明を設定します。

パラメータ:
explain - 説明

getPortletCode

public String getPortletCode()
ポートレットコードを取得します。

戻り値:
ポートレットコード
例外:
IllegalStateException - ポートレットコードがnullである場合

setPortletCode

public void setPortletCode(String portletCode)
ポートレットコードを設定します。(必須)
ポートレットコードは必須項目です。必ずnull以外の値を設定して下さい。

パラメータ:
portletCode - ポートレットコード
例外:
IllegalArgumentException - ポートレットコードにnullが設定された場合

getPortletName

public String getPortletName()
ポートレット名を取得します。

戻り値:
ポートレット名
例外:
IllegalStateException - ポートレット名がnullである場合

setPortletName

public void setPortletName(String portletName)
ポートレット名を設定します。(必須)
ポートレット名は必須項目です。必ずnull以外の値を設定して下さい。

パラメータ:
portletName - ポートレット名
例外:
IllegalArgumentException - ポートレット名にnullが設定された場合

isTitleBar

public boolean isTitleBar()
タイトルバーを表示するかどうかのステータスを取得します。

戻り値:
タイトルバーを表示するかどうかのステータス

setTitleBar

public void setTitleBar(boolean titleBar)
タイトルバーを表示するかどうかのステータスを設定します。

パラメータ:
titleBar - タイトルバーを表示するかどうかのステータス

getPageKind

public abstract String getPageKind()
ページ種別を取得します。

戻り値:
ページ種別

getRecordUserCode

public String getRecordUserCode()
レコード更新ユーザコードを取得します。

戻り値:
レコード更新ユーザコード

setRecordUserCode

public void setRecordUserCode(String recordUserCode)
レコード更新ユーザコードを設定します。

パラメータ:
recordUserCode - レコード更新ユーザコード

getRecordDate

public Date getRecordDate()
レコード更新日を取得します。
初期値はモデル生成時のシステム時間になります。

戻り値:
レコード更新日

setRecordDate

public void setRecordDate(Date recordDate)
レコード更新日を設定します。

パラメータ:
recordDate - レコード更新日
例外:
IllegalArgumentException - レコード更新日にnullが設定された場合

hashCode

public int hashCode()
このオブジェクトに対するハッシュコード値を返します。

戻り値:
このオブジェクトのハッシュコード値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PresentationPagePortlet (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.portlet.model
クラス PresentationPagePortlet

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.portlet.model.Portlet
        拡張 jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet
            拡張 jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet
すべての実装インタフェース:
Serializable
public class PresentationPagePortlet
extends StandardPortlet

ページ種別「プレゼンテーションページ」に対するポートレットのモデルです。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
static String PAGE_KIND
ページ種別
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したフィールド
DISPLAY_NONE, DISPLAY_PERCENT, DISPLAY_PIXCEL
コンストラクタの概要
PresentationPagePortlet()
メソッドの概要
boolean | equals(Object obj) このポートレットと別のオブジェクトとが等しいかどうかを比較します。
String | getPageKind() ページ種別を取得します。
クラス jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet から継承したメソッド
getArgument, getUrl, setArgument, setUrl
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したメソッド
getApplication, getCacheTime, getExplain, getHeight, getPortletCode, getPortletName, getRecordDate, getRecordUserCode, getUnit, getWidth, hashCode, isTitleBar, setApplication, setCacheConfig, setExplain, setHeight, setPortletCode, setPortletName, setRecordDate, setRecordUserCode, setTitleBar, setUnit, setWidth
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PAGE_KIND

public static final String PAGE_KIND
ページ種別

関連項目:
定数フィールド値
コンストラクタの詳細

PresentationPagePortlet

public PresentationPagePortlet()
メソッドの詳細

getPageKind

public String getPageKind()
ページ種別を取得します。

定義:
クラス Portlet 内の getPageKind
戻り値:
ページ種別

equals

public boolean equals(Object obj)
このポートレットと別のオブジェクトとが等しいかどうかを比較します。
2つのポートレットが等しいのは、同じポートレット種別、同じポートレットコードを持つ場合です。

戻り値:
オブジェクトが同じである場合はtrue、そうでない場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RssPortlet (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.portlet.model
クラス RssPortlet

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.portlet.model.Portlet
        拡張 jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet
            拡張 jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet
すべての実装インタフェース:
Serializable
public class RssPortlet
extends J2eeFwPortlet

ページ種別「RSS」に対するポートレットのモデルです。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
static String PAGE_KIND
ページ種別
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したフィールド
DISPLAY_NONE, DISPLAY_PERCENT, DISPLAY_PIXCEL
コンストラクタの概要
RssPortlet()
コンストラクタ
メソッドの概要
boolean | equals(Object obj) このポートレットと別のオブジェクトとが等しいかどうかを比較します。
String | getPageKind() ページ種別を取得します。
String | getParserKey() RSS解析キーを取得します。
String | getProxyHost() プロキシホスト名を取得します。
int | getProxyPort() プロキシポート番号を取得します。
String | getRssUrl() URLを取得します。
void | setParserKey(String parserKey) RSS解析キーを設定します。
void | setProxyHost(String proxyHost) プロキシホスト名を設定します。
void | setProxyPort(int proxyPort) プロキシポート番号を設定します。
void | setRssUrl(String rssUrl) URLを設定します。
クラス jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet から継承したメソッド
getApplicationId, getArgument, getServiceId, setApplicationId, setArgument, setServiceId
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したメソッド
getApplication, getCacheTime, getExplain, getHeight, getPortletCode, getPortletName, getRecordDate, getRecordUserCode, getUnit, getWidth, hashCode, isTitleBar, setApplication, setCacheConfig, setExplain, setHeight, setPortletCode, setPortletName, setRecordDate, setRecordUserCode, setTitleBar, setUnit, setWidth
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PAGE_KIND

public static final String PAGE_KIND
ページ種別

関連項目:
定数フィールド値
コンストラクタの詳細

RssPortlet

public RssPortlet()
コンストラクタ

メソッドの詳細

getParserKey

public String getParserKey()
RSS解析キーを取得します。

戻り値:
RSS解析キー
例外:
IllegalStateException - RSS解析キーがnullである場合

setParserKey

public void setParserKey(String parserKey)
RSS解析キーを設定します。(必須)
RSS解析キーは必須項目です。必ずnull以外の値を設定して下さい。

パラメータ:
parserKey - RSS解析キー
例外:
IllegalArgumentException - RSS解析キーにnullが設定された場合

getProxyHost

public String getProxyHost()
プロキシホスト名を取得します。

戻り値:
プロキシホスト名

setProxyHost

public void setProxyHost(String proxyHost)
プロキシホスト名を設定します。

パラメータ:
proxyHost - プロキシホスト名

getProxyPort

public int getProxyPort()
プロキシポート番号を取得します。
ポート番号が設定されていない場合は、-1を返却します。

戻り値:
プロキシポート番号

setProxyPort

public void setProxyPort(int proxyPort)
プロキシポート番号を設定します。

パラメータ:
proxyPort - プロキシポート番号

getRssUrl

public String getRssUrl()
URLを取得します。

戻り値:
rssUrl
例外:
IllegalStateException - URLがnullである場合

setRssUrl

public void setRssUrl(String rssUrl)
URLを設定します。(必須)
URLは必須項目です。必ずnull以外の値を設定して下さい。

例外:
IllegalArgumentException - URLにnullが設定された場合

getPageKind

public String getPageKind()
ページ種別を取得します。

オーバーライド:
クラス J2eeFwPortlet 内の getPageKind
戻り値:
ページ種別

equals

public boolean equals(Object obj)
このポートレットと別のオブジェクトとが等しいかどうかを比較します。
2つのポートレットが等しいのは、同じポートレット種別、同じポートレットコードを持つ場合です。

オーバーライド:
クラス J2eeFwPortlet 内の equals
戻り値:
オブジェクトが同じである場合はtrue、そうでない場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardPortlet (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.portlet.model
クラス StandardPortlet

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.portlet.model.Portlet
        拡張 jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
InternetPortlet, JspPortlet, PresentationPagePortlet
public abstract class StandardPortlet
extends Portlet

標準ポートレットに対するモデルの抽象クラスです。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したフィールド
DISPLAY_NONE, DISPLAY_PERCENT, DISPLAY_PIXCEL
コンストラクタの概要
StandardPortlet()
メソッドの概要
String | getArgument() ページ引数を取得します。
String | getUrl() URLを取得します。
void | setArgument(String argument) ページ引数を設定します。
void | setUrl(String url) URLを設定します。
クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet から継承したメソッド
getApplication, getCacheTime, getExplain, getHeight, getPageKind, getPortletCode, getPortletName, getRecordDate, getRecordUserCode, getUnit, getWidth, hashCode, isTitleBar, setApplication, setCacheConfig, setExplain, setHeight, setPortletCode, setPortletName, setRecordDate, setRecordUserCode, setTitleBar, setUnit, setWidth
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardPortlet

public StandardPortlet()
メソッドの詳細

getArgument

public String getArgument()
ページ引数を取得します。

戻り値:
ページ引数

setArgument

public void setArgument(String argument)
ページ引数を設定します。

パラメータ:
argument - ページ引数

getUrl

public String getUrl()
URLを取得します。

戻り値:
URL
例外:
IllegalStateException - URLがnullである場合

setUrl

public void setUrl(String url)
URLを設定します。(必須)
URLは必須項目です。必ずnull以外の値を設定して下さい。

パラメータ:
url - URL
例外:
IllegalArgumentException - URLにnullが設定された場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.portal.portlet (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.portal.portlet
クラス
PortletManager
PortletMapping
例外
PortletManagerException


jp.co.intra_mart.foundation.portal.portlet (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.portlet

クラスの概要
PortletManager | ポートレット情報の登録・参照を行うマネージャクラスです。
PortletMapping | ポートレットの種別とモデルのマッピングを管理します。

例外の概要
PortletManagerException ポートレットマネージャー操作時に発生するすべての例外のクラスです。


jp.co.intra_mart.foundation.portal.portlet クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.portlet の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.portal.portlet.PortletManager
    • class jp.co.intra_mart.foundation.portal.portlet.PortletMapping
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.portal.portlet.PortletManagerException


パッケージ jp.co.intra_mart.foundation.portal.portlet の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.portal.portlet の使用

jp.co.intra_mart.foundation.portal.portlet を使用しているパッケージ
jp.co.intra_mart.foundation.portal.portlet

jp.co.intra_mart.foundation.portal.portlet により使用される jp.co.intra_mart.foundation.portal.portlet のクラス
PortletManagerException
ポートレットマネージャー操作時に発生するすべての例外のクラスです。
PortletMapping
ポートレットの種別とモデルのマッピングを管理します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PortletManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.portlet
クラス PortletManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.portlet.PortletManager
public class PortletManager
extends Object

ポートレット情報の登録・参照を行うマネージャクラスです。

導入されたバージョン:
6.0
バージョン:
1.0

コンストラクタの概要
PortletManager(String groupId)
コンストラクタ
メソッドの概要
void | deletePortlet(Portlet portlet) ポートレット情報を削除します。
Portlet | getPortlet(String portletCode, String pageKind) すでに登録済のポートレット情報を取得します。
Portlet[] | getPortlets() すでに登録されているポートレット情報の一覧を取得します。
void | setPortlet(Portlet portlet) ポートレット情報を登録します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PortletManager

public PortletManager(String groupId)
コンストラクタ

パラメータ:
groupId - ログイングループID
メソッドの詳細

setPortlet

public void setPortlet(Portlet portlet)
                throws PortletManagerException
ポートレット情報を登録します。

指定されたポートレット情報が存在ない場合は新規登録します。
すでに存在する場合は更新を行います。

パラメータ:
portlet - ポートレット情報
例外:
PortletManagerException - ポートレットの登録に失敗した場合

deletePortlet

public void deletePortlet(Portlet portlet)
                   throws PortletManagerException
ポートレット情報を削除します。

パラメータ:
portlet - ポートレット情報
例外:
PortletManagerException - ポートレットの削除に失敗した場合

getPortlet

public Portlet getPortlet(String portletCode,
                          String pageKind)
                   throws PortletManagerException
すでに登録済のポートレット情報を取得します。
指定されたポートレット情報が存在しない場合は、nullを返します。

パラメータ:
portletCode - ポートレットコード
pageKind - ページ種別
戻り値:
ポートレット情報
例外:
PortletManagerException - ポートレット情報の取得に失敗した場合

getPortlets

public Portlet[] getPortlets()
                      throws PortletManagerException
すでに登録されているポートレット情報の一覧を取得します。

ポートレット情報を1件も取得できなかった場合は、空の配列を返します。

戻り値:
ポートレット情報の一覧
例外:
PortletManagerException - ポートレット一覧の取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PortletManagerException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.portlet
クラス PortletManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.portal.portlet.PortletManagerException
すべての実装インタフェース:
Serializable
public class PortletManagerException
extends RuntimeException

ポートレットマネージャー操作時に発生するすべての例外のクラスです。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
PortletManagerException()
コンストラクタ
PortletManagerException(String message)
コンストラクタ
PortletManagerException(String message, Throwable cause)
コンストラクタ
PortletManagerException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PortletManagerException

public PortletManagerException()
コンストラクタ

PortletManagerException

public PortletManagerException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

PortletManagerException

public PortletManagerException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

PortletManagerException

public PortletManagerException(String message,
                               Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PortletMapping (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.portlet
クラス PortletMapping

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.portlet.PortletMapping
public class PortletMapping
extends Object

ポートレットの種別とモデルのマッピングを管理します。

導入されたバージョン:
6.0
バージョン:
1.0

フィールドの概要
static String MAPPING_FILE_PATH
ポートレットマッピングの設定ファイルのパス情報
メソッドの概要
String[] | getAvailablePageKind() 利用可能なポートレット種別の一覧を取得します。
static PortletMapping | getInstance() インスタンスを取得します。
Portlet | getPortlet(String pageKind) 指定されたページ種別に対応するポートレットモデルのインスタンスを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

MAPPING_FILE_PATH

public static String MAPPING_FILE_PATH
ポートレットマッピングの設定ファイルのパス情報

メソッドの詳細

getInstance

public static PortletMapping getInstance()
インスタンスを取得します。

戻り値:
PortletMappingのインスタンス

getPortlet

public Portlet getPortlet(String pageKind)
指定されたページ種別に対応するポートレットモデルのインスタンスを取得します。

パラメータ:
pageKind - ページ種別
戻り値:
ポートレットモデルのインスタンス

getAvailablePageKind

public String[] getAvailablePageKind()
利用可能なポートレット種別の一覧を取得します。

戻り値:
ポートレットのページ種別の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.scenario.FunctionContainer の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.scenario.FunctionContainer の使用

FunctionContainer を使用しているパッケージ
jp.co.intra_mart.foundation.scenario スクリプト開発モデルのプログラムと連携するＡＰＩ。

jp.co.intra_mart.foundation.scenario での FunctionContainer の使用

jp.co.intra_mart.foundation.scenario での FunctionContainer のサブクラス
 class FunctionContainerFile
FunctionContainerFile クラスは、ファンクション・コンテナとなるファイルを コンパイルして実行可能な環境を提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.scenario.FunctionContainerFile の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.scenario.FunctionContainerFile の使用

jp.co.intra_mart.foundation.scenario.FunctionContainerFile はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.scenario.NoSuchPropertyException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.scenario.NoSuchPropertyException の使用

NoSuchPropertyException を使用しているパッケージ
jp.co.intra_mart.foundation.scenario スクリプト開発モデルのプログラムと連携するＡＰＩ。

jp.co.intra_mart.foundation.scenario での NoSuchPropertyException の使用

NoSuchPropertyException をスローする jp.co.intra_mart.foundation.scenario のメソッド
ScriptValue | VariableScope.invoke(String name, String arg) 指定関数を実行します。
ScriptValue | VariableScope.invoke(String name, Number arg) 指定関数を実行します。
ScriptValue | VariableScope.invoke(String name, Object[] args) 指定関数を実行します。
ScriptValue | VariableScope.getProperty(String name) プロパティ値を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.scenario.PresentationPage の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.scenario.PresentationPage の使用

jp.co.intra_mart.foundation.scenario.PresentationPage はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.scenario.ScriptCompileException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.scenario.ScriptCompileException の使用

ScriptCompileException を使用しているパッケージ
jp.co.intra_mart.foundation.scenario スクリプト開発モデルのプログラムと連携するＡＰＩ。

jp.co.intra_mart.foundation.scenario での ScriptCompileException の使用

ScriptCompileException をスローする jp.co.intra_mart.foundation.scenario のメソッド
protected void | FunctionContainer.compileString(String src) スクリプトのソースをコンパイルします。
protected void | FunctionContainer.compileReader(Reader in) スクリプトのソースをコンパイルします。

ScriptCompileException をスローする jp.co.intra_mart.foundation.scenario のコンストラクタ
FunctionContainerFile(String path, Locale locale)
ファンクション・コンテナをコンパイルします。
FunctionContainerFile(String path)
ファンクション・コンテナをコンパイルします。
FunctionContainer(Reader in)
新しいインスタンスを構築します。
FunctionContainer(String src)
新しいインスタンスを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.scenario.ScriptRuntimeException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.scenario.ScriptRuntimeException の使用

ScriptRuntimeException を使用しているパッケージ
jp.co.intra_mart.foundation.scenario スクリプト開発モデルのプログラムと連携するＡＰＩ。

jp.co.intra_mart.foundation.scenario での ScriptRuntimeException の使用

ScriptRuntimeException をスローする jp.co.intra_mart.foundation.scenario のメソッド
ScriptValue | VariableScope.invoke(String name, String arg) 指定関数を実行します。
ScriptValue | VariableScope.invoke(String name, Number arg) 指定関数を実行します。
ScriptValue | VariableScope.invoke(String name, Object[] args) 指定関数を実行します。
String | PresentationPage.execute(String path) プログラム実行。
String | PresentationPage.execute(String path, Object[] args) プログラム実行。
VariableScope | FunctionContainer.execute() スクリプトの実行。
VariableScope | FunctionContainer.execute(HttpServletRequest request, HttpServletResponse response) スクリプトの実行。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.scenario.ScriptValue の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.scenario.ScriptValue の使用

ScriptValue を使用しているパッケージ
jp.co.intra_mart.foundation.scenario スクリプト開発モデルのプログラムと連携するＡＰＩ。

jp.co.intra_mart.foundation.scenario での ScriptValue の使用

jp.co.intra_mart.foundation.scenario での ScriptValue のサブインタフェース
 interface VariableScope
スクリプトのスコープを表すオブジェクトです。

ScriptValue を返す jp.co.intra_mart.foundation.scenario のメソッド
ScriptValue | VariableScope.invoke(String name, String arg) 指定関数を実行します。
ScriptValue | VariableScope.invoke(String name, Number arg) 指定関数を実行します。
ScriptValue | VariableScope.invoke(String name, Object[] args) 指定関数を実行します。
ScriptValue | VariableScope.getProperty(String name) プロパティ値を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.scenario.VariableScope の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.scenario.VariableScope の使用

VariableScope を使用しているパッケージ
jp.co.intra_mart.foundation.scenario スクリプト開発モデルのプログラムと連携するＡＰＩ。

jp.co.intra_mart.foundation.scenario での VariableScope の使用

VariableScope を返す jp.co.intra_mart.foundation.scenario のメソッド
VariableScope | FunctionContainer.execute() スクリプトの実行。
VariableScope | FunctionContainer.execute(HttpServletRequest request, HttpServletResponse response) スクリプトの実行。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


FunctionContainer (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.scenario
クラス FunctionContainer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.scenario.FunctionContainer
直系の既知のサブクラス:
FunctionContainerFile
public abstract class FunctionContainer
extends Object

FunctionContainer クラスは、ファンクション・コンテナとなるスクリプトを コンパイルして実行可能な環境を提供します。

関連項目:
Object

コンストラクタの概要
protected | FunctionContainer() 新しいインスタンスを構築します。
 | FunctionContainer(Reader in) 新しいインスタンスを構築します。
 | FunctionContainer(String src) 新しいインスタンスを構築します。
メソッドの概要
protected void | compileReader(Reader in) スクリプトのソースをコンパイルします。
protected void | compileString(String src) スクリプトのソースをコンパイルします。
VariableScope | execute() スクリプトの実行。
VariableScope | execute(HttpServletRequest request, HttpServletResponse response) スクリプトの実行。
abstract String | sourceName() ソース名称の取得。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FunctionContainer

protected FunctionContainer()
新しいインスタンスを構築します。

このコンストラクタでは、このクラスを継承したサブクラス側で compileReader() メソッド等を利用してソースをコンパイルすることを 保証しなければなりません。

FunctionContainer

public FunctionContainer(Reader in)
                  throws IOException,
                         ScriptCompileException
新しいインスタンスを構築します。

指定のファンクション・コンテナをコンパイルします。

パラメータ:
in - ファンクションコンテナのソース
例外:
IOException - Reader の入出力エラー
ScriptCompileException - コンパイルエラー

FunctionContainer

public FunctionContainer(String src)
                  throws IOException,
                         ScriptCompileException
新しいインスタンスを構築します。

指定のファンクション・コンテナをコンパイルします。

パラメータ:
src - ファンクションコンテナのソース
例外:
IOException - Reader の入出力エラー
ScriptCompileException - コンパイルエラー
メソッドの詳細

compileString

protected void compileString(String src)
                      throws IOException,
                             ScriptCompileException
スクリプトのソースをコンパイルします。

パラメータ:
src - ファンクションコンテナのソース
例外:
IOException - Reader の入出力エラー
ScriptCompileException - コンパイルエラー

compileReader

protected void compileReader(Reader in)
                      throws IOException,
                             ScriptCompileException
スクリプトのソースをコンパイルします。

パラメータ:
in - ファンクションコンテナのソース
例外:
IOException - Reader の入出力エラー
ScriptCompileException - コンパイルエラー

sourceName

public abstract String sourceName()
ソース名称の取得。

スクリプトのソース名称を返します。
このクラスの汎用規約では、スクリプトがファイルの場合は ファイルのパス名を返します。

戻り値:
ソースの名前

execute

public VariableScope execute()
                      throws ScriptRuntimeException
スクリプトの実行。

スクリプトを実行します。
このメソッドによる実行時は、セッションが不明となるため、 セッションに関連したAPIを利用したスクリプトを実行することはできません。

戻り値は、このスクリプトのスコープです。

戻り値:
スクリプトのスコープを表すオブジェクト
例外:
ScriptRuntimeException - スクリプトの実行時エラー

execute

public VariableScope execute(HttpServletRequest request,
                             HttpServletResponse response)
                      throws ScriptRuntimeException
スクリプトの実行。

セッションを伴ってスクリプトを実行します。
指定のサーブレットにより管理されているセッションを維持したまま スクリプトを実行します。 また、このメソッドを利用する事により、セッション関連の ＡＰＩをスクリプト中で利用する事ができます。
戻り値は、このスクリプトのスコープです。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
スクリプトのスコープを表すオブジェクト
例外:
ScriptRuntimeException - スクリプトの実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


FunctionContainerFile (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.scenario
クラス FunctionContainerFile

java.lang.Object
    拡張 jp.co.intra_mart.foundation.scenario.FunctionContainer
        拡張 jp.co.intra_mart.foundation.scenario.FunctionContainerFile
public class FunctionContainerFile
extends FunctionContainer

FunctionContainerFile クラスは、ファンクション・コンテナとなるファイルを コンパイルして実行可能な環境を提供します。
ファイルは Resource Service によって管理されているものに限ります。

関連項目:
FunctionContainer

コンストラクタの概要
FunctionContainerFile(String path)
ファンクション・コンテナをコンパイルします。
FunctionContainerFile(String path, Locale locale)
ファンクション・コンテナをコンパイルします。
メソッドの概要
 String sourceName()
スクリプトのファイルパス名を返します。
クラス jp.co.intra_mart.foundation.scenario.FunctionContainer から継承したメソッド
compileReader, compileString, execute, execute
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FunctionContainerFile

public FunctionContainerFile(String path,
                             Locale locale)
                      throws IOException,
                             ScriptCompileException
ファンクション・コンテナをコンパイルします。

このコンストラクタの呼び出しは、以下と同様です。 new FunctionContainerFile(path, java.util.Locale.getDefault())

パラメータ:
path - ソースファイルのパス名
locale - ソースのロケール
例外:
IOException - Reader の入出力エラー
ScriptCompileException - コンパイルエラー
導入されたバージョン:
version 5.0

FunctionContainerFile

public FunctionContainerFile(String path)
                      throws IOException,
                             ScriptCompileException
ファンクション・コンテナをコンパイルします。

ファンクション・コンテナのファイルパスは、Resource Service が 管理しているリソースルートディレクトリ(標準では pages/)からの 相対形式で指定して下さい。
例） new FunctionContainerFile("my/container/library.js")

パラメータ:
path - ソースファイルのパス名
例外:
IOException - Reader の入出力エラー
ScriptCompileException - コンパイルエラー
メソッドの詳細

sourceName

public String sourceName()
スクリプトのファイルパス名を返します。

定義:
クラス FunctionContainer 内の sourceName
戻り値:
ファイルパス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NoSuchPropertyException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.scenario
クラス NoSuchPropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.scenario.NoSuchPropertyException
すべての実装インタフェース:
Serializable
public class NoSuchPropertyException
extends Exception

NoSuchPropertyException クラスは、指定されたプロパティがオブジェクトには ないことを通知します。

関連項目:
Object, Exception, 直列化された形式

コンストラクタの概要
NoSuchPropertyException(String message)
詳細メッセージを指定して NoSuchPropertyException を構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NoSuchPropertyException

public NoSuchPropertyException(String message)
詳細メッセージを指定して NoSuchPropertyException を構築します。

文字列 message は、 java.lang.Throwable クラスの Throwable.getMessage() メソッドを使って あとで取り出すことができます。

パラメータ:
message - 詳細メッセージ
関連項目:
Throwable.getMessage()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.scenario (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.scenario
インタフェース
ScriptValue
VariableScope
クラス
FunctionContainer
FunctionContainerFile
PresentationPage
例外
NoSuchPropertyException
ScriptCompileException
ScriptRuntimeException


jp.co.intra_mart.foundation.scenario (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.scenario

スクリプト開発モデルのプログラムと連携するＡＰＩ。

参照:
説明

インタフェースの概要
ScriptValue | スクリプトの値を保持するオブジェクトです。
VariableScope | スクリプトのスコープを表すオブジェクトです。

クラスの概要
FunctionContainer | FunctionContainer クラスは、ファンクション・コンテナとなるスクリプトを コンパイルして実行可能な環境を提供します。
FunctionContainerFile | FunctionContainerFile クラスは、ファンクション・コンテナとなるファイルを コンパイルして実行可能な環境を提供します。
PresentationPage | PresentationPage クラスは、プレゼンテーション・ページとなるスクリプトを コンパイルして実行可能な環境を提供します。

例外の概要
NoSuchPropertyException | NoSuchPropertyException クラスは、指定されたプロパティがオブジェクトには ないことを通知します。
ScriptCompileException | ScriptCompileException クラスは、スクリプトのコンパイル時にエラーが発生 場合にスローされる例外です。
ScriptRuntimeException | ScriptRuntimeException クラスは、スクリプトの実行時にエラーが発生 場合にスローされる例外です。

パッケージ jp.co.intra_mart.foundation.scenario の説明

スクリプト開発モデルのプログラムと連携するＡＰＩ。


jp.co.intra_mart.foundation.scenario クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.scenario の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.scenario.FunctionContainer
      • class jp.co.intra_mart.foundation.scenario.FunctionContainerFile
    • class jp.co.intra_mart.foundation.scenario.PresentationPage
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.scenario.NoSuchPropertyException
        • class jp.co.intra_mart.foundation.scenario.ScriptCompileException
        • class jp.co.intra_mart.foundation.scenario.ScriptRuntimeException

インタフェース階層

  • interface jp.co.intra_mart.foundation.scenario.ScriptValue
    • interface jp.co.intra_mart.foundation.scenario.VariableScope


パッケージ jp.co.intra_mart.foundation.scenario の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.scenario の使用

jp.co.intra_mart.foundation.scenario を使用しているパッケージ
jp.co.intra_mart.foundation.scenario スクリプト開発モデルのプログラムと連携するＡＰＩ。

jp.co.intra_mart.foundation.scenario により使用される jp.co.intra_mart.foundation.scenario のクラス
FunctionContainer
FunctionContainer クラスは、ファンクション・コンテナとなるスクリプトを コンパイルして実行可能な環境を提供します。
NoSuchPropertyException
NoSuchPropertyException クラスは、指定されたプロパティがオブジェクトには ないことを通知します。
ScriptCompileException
ScriptCompileException クラスは、スクリプトのコンパイル時にエラーが発生 場合にスローされる例外です。
ScriptRuntimeException
ScriptRuntimeException クラスは、スクリプトの実行時にエラーが発生 場合にスローされる例外です。
ScriptValue
スクリプトの値を保持するオブジェクトです。
VariableScope
スクリプトのスコープを表すオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PresentationPage (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.scenario
クラス PresentationPage

java.lang.Object
    拡張 jp.co.intra_mart.foundation.scenario.PresentationPage
public abstract class PresentationPage
extends Object

PresentationPage クラスは、プレゼンテーション・ページとなるスクリプトを コンパイルして実行可能な環境を提供します。

プレゼンテーションページを実行するには、リンク先 URL を プログラマが意識する必要があります。

リンク先 URL とは、プレゼンテーションページ内のリンクやフォームを 表現する <IMART> タグ内で使われるもので、そのリンクをクリックした 場合や、そのフォームをサブミットした場合にリクエストを送信するアドレス になります。したがって、その URL は intra-mart に接続できて スクリプト開発モデルのページをリクエストできるという条件を 満たす必要があります。 この条件を満たす URL は、通常はログイン画面をリクエストするための URL と等しくなります。intra-mart を標準的にインストールした状態では、

http://サーバアドレス:ポート番号/imart/intramart
になります。

セッションを持つページを作成する場合は、 ログイン画面からログインした時に割り当てられた セッションを維持するように実行することが必要になります。 セッションを維持したページを作成する場合、Servlet の リクエストおよびレスポンスが必要になります。 これは、Servlet の HTTP セッションを利用してセッションを 確立しているためであり、他の方法ではセッションを維持したページを 作成することはできません。
セッションを指定しなかった場合、ユーザー情報を決定することができないため、 ユーザおよびログイングループに関わるすべての API の利用が不可能となります。

導入されたバージョン:
version 3.2
関連項目:
Object

コンストラクタの概要
PresentationPage()
セッションを持たないページ作成用オブジェクトを作成します。
PresentationPage(HttpServletRequest request, HttpServletResponse response)
任意のセッションを持つページ作成オブジェクトを構築します。
メソッドの概要
String | execute(String path) プログラム実行。
String | execute(String path, Object[] args) プログラム実行。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PresentationPage

public PresentationPage()
セッションを持たないページ作成用オブジェクトを作成します。

PresentationPage

public PresentationPage(HttpServletRequest request,
                        HttpServletResponse response)
                 throws IllegalArgumentException
任意のセッションを持つページ作成オブジェクトを構築します。

パラメータ:
request - サーブレットの引数オブジェクト
response - サーブレットのレスポンスオブジェクト
例外:
IllegalArgumentException - 引数のいずれかが NULL である場合に スローされます
メソッドの詳細

execute

public String execute(String path)
               throws ScriptRuntimeException,
                      FileNotFoundException
プログラム実行。

指定のプログラムを実行します。

プログラムは HTML および JavaScript ファイルで、引数 path には、Information Server のプログラムパスからの相対形式で拡張子を省略 した形式で指定します。実行エンジンは、自動的に path.html および path.js を探して実行します。

パラメータ:
path - 実行するプログラムのパス
戻り値:
HTML ソース
例外:
ScriptRuntimeException - ページプログラム実行時エラー
FileNotFoundException

execute

public String execute(String path,
                      Object[] args)
               throws ScriptRuntimeException,
                      FileNotFoundException
プログラム実行。

指定のプログラムを実行します。

プログラムは HTML および JavaScript ファイルで、引数 path には、Resource-Service のプログラムパスからの相対形式で拡張子を省略 した形式で指定します。実行エンジンは、自動的に path.html および path.js を探して実行します。

引数 args は、path.js に定義されている init() メソッドの 実行時引数として渡されます。 args が持つ要素の個数は、init() 関数に渡される引数の個数と 等しくなります。

パラメータ:
path - 実行するプログラムのパス
args - プログラム実行時の任意引数
戻り値:
HTML ソース
例外:
ScriptRuntimeException - ページプログラム実行時エラー
FileNotFoundException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ScriptCompileException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.scenario
クラス ScriptCompileException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.scenario.ScriptCompileException
すべての実装インタフェース:
Serializable
public class ScriptCompileException
extends Exception

ScriptCompileException クラスは、スクリプトのコンパイル時にエラーが発生 場合にスローされる例外です。
コンパイルエラーとは、主に構文エラーになります。

関連項目:
Object, Exception, 直列化された形式

コンストラクタの概要
ScriptCompileException(String message)
詳細メッセージを指定して ScriptCompileException を構築します。
ScriptCompileException(String message, Throwable cause)
詳細メッセージを指定して ScriptCompileException を構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ScriptCompileException

public ScriptCompileException(String message)
詳細メッセージを指定して ScriptCompileException を構築します。

文字列 message は、 java.lang.Throwable クラスの Throwable.getMessage() メソッドを使って あとで取り出すことができます。

パラメータ:
message - 詳細メッセージ
関連項目:
Throwable.getMessage()

ScriptCompileException

public ScriptCompileException(String message,
                              Throwable cause)
詳細メッセージを指定して ScriptCompileException を構築します。

文字列 message は、 java.lang.Throwable クラスの Throwable.getMessage() メソッドを使って あとで取り出すことができます。

パラメータ:
message - 詳細メッセージ
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す
導入されたバージョン:
version 4.3
関連項目:
Throwable.getMessage()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ScriptRuntimeException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.scenario
クラス ScriptRuntimeException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.scenario.ScriptRuntimeException
すべての実装インタフェース:
Serializable
public class ScriptRuntimeException
extends Exception

ScriptRuntimeException クラスは、スクリプトの実行時にエラーが発生 場合にスローされる例外です。

関連項目:
Object, Exception, 直列化された形式

コンストラクタの概要
ScriptRuntimeException(String message)
詳細メッセージを指定して ScriptRuntimeException を構築します。
ScriptRuntimeException(String message, Throwable cause)
詳細メッセージを指定して ScriptRuntimeException を構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ScriptRuntimeException

public ScriptRuntimeException(String message)
詳細メッセージを指定して ScriptRuntimeException を構築します。

文字列 message は、 java.lang.Throwable クラスの Throwable.getMessage() メソッドを使って あとで取り出すことができます。

パラメータ:
message - 詳細メッセージ
関連項目:
Throwable.getMessage()

ScriptRuntimeException

public ScriptRuntimeException(String message,
                              Throwable cause)
詳細メッセージを指定して ScriptRuntimeException を構築します。

文字列 message は、 java.lang.Throwable クラスの Throwable.getMessage() メソッドを使って あとで取り出すことができます。

パラメータ:
message - 詳細メッセージ
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す
導入されたバージョン:
version 4.3
関連項目:
Throwable.getMessage()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ScriptValue (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.scenario
インタフェース ScriptValue

既知のサブインタフェースの一覧:
VariableScope
public interface ScriptValue

スクリプトの値を保持するオブジェクトです。

メソッドの概要
boolean | booleanValue() このオブジェクトの示す値の真偽値表現を取得します。
double | doubleValue() このオブジェクトの示す値の数値表現を取得します。
Object | getValue() このオブジェクトの示す値を取得します。
boolean | isFunction() このオブジェクトの示す値が関数かどうか判定します。
boolean | isInstance(Class c) このオブジェクトの示す値が c が表すオブジェクトと代入互換の 関係にあるかどうか判定します。
boolean | isNull() このオブジェクトの示す値が null かどうか判定します。
boolean | isObject() このオブジェクトの示す値がオブジェクトかどうか判定します。
boolean | isUndefined() このオブジェクトの示す値が undefined かどうか判定します。
String | toString() このオブジェクトの示す値の文字列表現を取得します。

メソッドの詳細

isObject

public boolean isObject()
このオブジェクトの示す値がオブジェクトかどうか判定します。

戻り値:
オブジェクトの場合 true、そうでない場合 false

isFunction

public boolean isFunction()
このオブジェクトの示す値が関数かどうか判定します。

戻り値:
関数の場合 true、そうでない場合 false

isUndefined

public boolean isUndefined()
このオブジェクトの示す値が undefined かどうか判定します。

戻り値:
Undefined の場合 true、そうでない場合 false

isNull

public boolean isNull()
このオブジェクトの示す値が null かどうか判定します。

戻り値:
null の場合 true、そうでない場合 false

isInstance

public boolean isInstance(Class c)
このオブジェクトの示す値が c が表すオブジェクトと代入互換の 関係にあるかどうか判定します。

このメソッドは、c の isInstance() メソッドにより判定を行います。

戻り値:
代入互換の関係にある場合 true、そうでない場合 false
関連項目:
Class.isInstance(java.lang.Object)

getValue

public Object getValue()
このオブジェクトの示す値を取得します。

戻り値:
値

toString

public String toString()
このオブジェクトの示す値の文字列表現を取得します。

戻り値:
値の文字列表現

doubleValue

public double doubleValue()
このオブジェクトの示す値の数値表現を取得します。

戻り値:
値の数値表現

booleanValue

public boolean booleanValue()
このオブジェクトの示す値の真偽値表現を取得します。

戻り値:
値の真偽値表現
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


VariableScope (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.scenario
インタフェース VariableScope

すべてのスーパーインタフェース:
ScriptValue
public interface VariableScope
extends ScriptValue

スクリプトのスコープを表すオブジェクトです。

メソッドの概要
ScriptValue | getProperty(String name) プロパティ値を取得します。
boolean | hasProperty(String name) プロパティが存在しているかをチェックします。
ScriptValue | invoke(String name, Number arg) 指定関数を実行します。
ScriptValue | invoke(String name, Object[] args) 指定関数を実行します。
ScriptValue | invoke(String name, String arg) 指定関数を実行します。
Object[] | keys() プロパティの名称一覧を取得します。
インタフェース jp.co.intra_mart.foundation.scenario.ScriptValue から継承したメソッド
booleanValue, doubleValue, getValue, isFunction, isInstance, isNull, isObject, isUndefined, toString

メソッドの詳細

invoke

public ScriptValue invoke(String name,
                          String arg)
                   throws ScriptRuntimeException,
                          NoSuchPropertyException
指定関数を実行します。

指定の関数を指定の引数を伴って実行します。
返却値は、呼び出した関数の戻り値になりますが、 スクリプトおよび JAVA の双方で解釈できる型 (String, Number, Boolean)に限られます。

パラメータ:
name - 関数名
arg - 引数
戻り値:
関数の戻り値
例外:
ScriptRuntimeException - スクリプト実行時エラー
NoSuchPropertyException - 指定のプロパティが存在しない場合

invoke

public ScriptValue invoke(String name,
                          Number arg)
                   throws ScriptRuntimeException,
                          NoSuchPropertyException
指定関数を実行します。

指定の関数を指定の引数を伴って実行します。
返却値は、呼び出した関数の戻り値になりますが、 スクリプトおよび JAVA の双方で解釈できる型 (String, Number, Boolean)に限られます。

パラメータ:
name - 関数名
arg - 引数
戻り値:
関数の戻り値
例外:
ScriptRuntimeException - スクリプト実行時エラー
NoSuchPropertyException - 指定のプロパティが存在しない場合

invoke

public ScriptValue invoke(String name,
                          Object[] args)
                   throws ScriptRuntimeException,
                          NoSuchPropertyException
指定関数を実行します。

指定の関数を指定の引数を伴って実行します。
引数は配列形式で複数の値を指定できます。また、引数に指定できる データ型は、スクリプトで解釈できる型(String, Number, Boolean)に 限られます。
返却値は、呼び出した関数の戻り値になりますが、引数同様 スクリプトおよび JAVA の双方で解釈できる型 (String, Number, Boolean)に限られます。

パラメータ:
name - 関数名
args - 引数
戻り値:
関数の戻り値
例外:
ScriptRuntimeException - スクリプト実行時エラー
NoSuchPropertyException - 指定のプロパティが存在しない場合

getProperty

public ScriptValue getProperty(String name)
                        throws NoSuchPropertyException
プロパティ値を取得します。 このスコープにおいて指定のプロパティ名にマップされている 値を取得します。

パラメータ:
name - プロパティ名
戻り値:
プロパティにマップされている値
例外:
NoSuchPropertyException - 指定のプロパティが存在しない場合

hasProperty

public boolean hasProperty(String name)
プロパティが存在しているかをチェックします。 このスコープにおいて指定のプロパティが値にマップされている場合 真値(true)を返します。

パラメータ:
name - プロパティ名
戻り値:
プロパティがマップされている場合 true

keys

public Object[] keys()
プロパティの名称一覧を取得します。 このスコープが保持しているプロパティのプロパティ名を配列形式で 取得します。

戻り値:
このスコープが保持しているプロパティの名称一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.access.AccessController の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.access.AccessController の使用

AccessController を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |

jp.co.intra_mart.foundation.security での AccessController の使用

AccessController を返す jp.co.intra_mart.foundation.security のメソッド
AccessController | StandardAccessControllerAccessor.getController(String groupId, String controllerId) アクセスコントローラ情報を取得します。
AccessController[] | StandardAccessControllerAccessor.getControllers(String groupId) すべてのアクセスコントローラ情報を取得します。

AccessController 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | StandardAccessControllerAccessor.insertAccessController(String groupId, AccessController controller) アクセスコントローラを作成します。
void | StandardAccessControllerAccessor.updateController(String groupId, AccessController controller) アクセスコントローラを更新します。

jp.co.intra_mart.foundation.security.access での AccessController の使用

AccessController を返す jp.co.intra_mart.foundation.security.access のメソッド
AccessController | AccessControllerReaderDecorator.doDecoration(String groupId, AccessController controller) アクセスコントローラデータストアからの読み込み直後にコールされます。
AccessController | AccessControllerManager.getController(String controllerId) 指定されたアクセスコントローラIDに対応するアクセスコントローラを取得します。
AccessController[] | AccessControllerManager.getControllers() すべてのアクセスコントローラを取得します。
AccessController | AccessControllerAccessor.getController(String groupId, String controllerId) アクセスコントローラ情報を取得します。
AccessController[] | AccessControllerAccessor.getControllers(String groupId) すべてのアクセスコントローラ情報を取得します。

AccessController 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
AccessController | AccessControllerReaderDecorator.doDecoration(String groupId, AccessController controller) アクセスコントローラデータストアからの読み込み直後にコールされます。
void | AccessControllerQueryWriterListener.queryCreate(String groupId, AccessController controller) アクセスコントローラ情報をデータストアに作成する直前にコールされます。
void | AccessControllerQueryWriterListener.queryUpdate(String groupId, AccessController controller) アクセスコントローラ情報をデータストアに更新する直前にコールされます。
void | AccessControllerPostWriterListener.postCreate(String groupId, AccessController controller) アクセスコントローラ情報をデータストアに作成した直後にコールされます。
void | AccessControllerPostWriterListener.postUpdate(String groupId, AccessController controller) アクセスコントローラ情報をデータストアに更新した直後にコールされます。
void | AccessControllerManager.addController(AccessController controller) アクセスコントローラを追加します。
void | AccessControllerManager.updateController(AccessController controller) アクセスコントローラを更新します。
void | AccessControllerAccessor.insertAccessController(String groupId, AccessController controller) アクセスコントローラを作成します。
void | AccessControllerAccessor.updateController(String groupId, AccessController controller) アクセスコントローラを更新します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.access.AccessControllerAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.access.AccessControllerAccessor の使用

AccessControllerAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での AccessControllerAccessor の使用

AccessControllerAccessor を実装している jp.co.intra_mart.foundation.security のクラス
 class StandardAccessControllerAccessor

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.access.AccessControllerExporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.access.AccessControllerExporter の使用

AccessControllerExporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.access

jp.co.intra_mart.foundation.security.access での AccessControllerExporter の使用

AccessControllerExporter を実装している jp.co.intra_mart.foundation.security.access のクラス
 class StandardAccessControllerBackup

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.access.AccessControllerImporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.access.AccessControllerImporter の使用

AccessControllerImporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.access

jp.co.intra_mart.foundation.security.access での AccessControllerImporter の使用

AccessControllerImporter を実装している jp.co.intra_mart.foundation.security.access のクラス
 class StandardAccessControllerBackup

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.access.AccessControllerManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.access.AccessControllerManager の使用

AccessControllerManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.access

jp.co.intra_mart.foundation.security.access での AccessControllerManager の使用

AccessControllerManager 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | AccessControllerImporter.doImport(InputStream inputStream, AccessControllerManager manager) インポートを行います。
void | AccessControllerExporter.doExport(AccessControllerManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardAccessControllerBackup.doImport(InputStream inputStream, AccessControllerManager manager)
void | StandardAccessControllerBackup.doExport(AccessControllerManager manager, OutputStream outputStream)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.access.AccessControllerPostWriterListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.access.AccessControllerPostWriterListener の使用

jp.co.intra_mart.foundation.security.access.AccessControllerPostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.access.AccessControllerQueryWriterListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.access.AccessControllerQueryWriterListener の使用

jp.co.intra_mart.foundation.security.access.AccessControllerQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.access.AccessControllerReaderDecorator の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.access.AccessControllerReaderDecorator の使用

jp.co.intra_mart.foundation.security.access.AccessControllerReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener の使用

jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener の使用

jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener の使用

jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.access.StandardAccessControllerBackup の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.access.StandardAccessControllerBackup の使用

jp.co.intra_mart.foundation.security.access.StandardAccessControllerBackup はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AccessController (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.access
クラス AccessController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.access.AccessController
すべての実装インタフェース:
Serializable
public class AccessController
extends Object
implements Serializable

アクセスコントローラ・モデルクラス。

アクセスコントローラのデータモデルを定義します。

導入されたバージョン:
6.1
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
AccessController()
コンストラクタ。
AccessController(String controllerId)
コンストラクタ。
メソッドの概要
String | getControllerId() コントローラＩＤを取得します。
String | getDescription() 説明を取得します。
String | getDisplayName() 表示名を取得します。
void | setAccessControllerId(String controllerId) コントローラＩＤを設定します。
void | setDescription(String description) 説明を設定します。
void | setDisplayName(String displayName) 表示名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AccessController

public AccessController(String controllerId)
コンストラクタ。

コントローラＩＤを指定して、インスタンスを生成します。

パラメータ:
controllerId -

AccessController

public AccessController()
コンストラクタ。

メソッドの詳細

getControllerId

public String getControllerId()
コントローラＩＤを取得します。

戻り値:
コントローラＩＤ

setAccessControllerId

public void setAccessControllerId(String controllerId)
コントローラＩＤを設定します。

パラメータ:
controllerId - コントローラＩＤ

getDescription

public String getDescription()
説明を取得します。

戻り値:
説明

setDescription

public void setDescription(String description)
説明を設定します。

パラメータ:
description - 説明

getDisplayName

public String getDisplayName()
表示名を取得します。

戻り値:
表示名

setDisplayName

public void setDisplayName(String displayName)
表示名を設定します。

パラメータ:
displayName - 表示名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccessControllerAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.access
インタフェース AccessControllerAccessor

既知の実装クラスの一覧:
StandardAccessControllerAccessor
public interface AccessControllerAccessor

アクセスコントローラアクセッサインタフェース。

アクセスコントローラ情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
void | deleteController(String groupId, String controllerId) アクセスコントローラを削除します。
void | deleteControllerDepartment(String groupId, String id, DepartmentInfo departmentInfo) アクセスコントローラ組織を削除します。
void | deleteControllerDepartments(String groupId, String id) すべてのアクセスコントローラ組織を削除します。
void | deleteControllerPost(String groupId, String id, PostInfo postInfo) アクセスコントローラ役職を削除します。
void | deleteControllerPosts(String groupId, String id) すべてのアクセスコントローラ役職を削除します。
void | deleteControllerPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) アクセスコントローラパブリックグループを削除します。
void | deleteControllerPublicGroups(String groupId, String id) すべてのアクセスコントローラパブリックグループを削除します。
void | deleteControllerRole(String groupId, String id, String roleId) アクセスコントローラロールを削除します。
void | deleteControllerRoles(String groupId, String id) すべてのアクセスコントローラロールを削除します。
AccessController | getController(String groupId, String controllerId) アクセスコントローラ情報を取得します。
DepartmentInfo[] | getControllerDepartments(String groupId, String id) すべてのアクセスコントローラ組織を取得します。
String[] | getControllerIds(String groupId) すべてのアクセスコントローラIDを取得します。
String[] | getControllerIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つコントローラIDをすべて取得します。
String[] | getControllerIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つコントローラIDをすべて取得します。
String[] | getControllerIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つコントローラIDをすべて取得します。
String[] | getControllerIdsByRole(String groupId, String[] roleIds) 指定されたロールIDを持つコントローラIDをすべて取得します。
PostInfo[] | getControllerPosts(String groupId, String id) すべてのアクセスコントローラ役職を取得します。
PublicGroupInfo[] | getControllerPublicGroups(String groupId, String id) すべてのアクセスコントローラパブリックグループを取得します。
String[] | getControllerRoles(String groupId, String id) すべてのアクセスコントローラロールを取得します。
AccessController[] | getControllers(String groupId) すべてのアクセスコントローラ情報を取得します。
void | init(Map params) アクセスコントローラアクセッサの初期化。
void | insertAccessController(String groupId, AccessController controller) アクセスコントローラを作成します。
void | insertControllerDepartment(String groupId, String id, DepartmentInfo departmentInfo) アクセスコントローラ組織を新規に作成します。
void | insertControllerPost(String groupId, String id, PostInfo postInfo) アクセスコントローラ役職を新規に作成します。
void | insertControllerPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) アクセスコントローラパブリックグループを新規に作成します。
void | insertControllerRole(String groupId, String id, String roleId) アクセスコントローラロールを新規に作成します。
void | updateController(String groupId, AccessController controller) アクセスコントローラを更新します。

メソッドの詳細

deleteController

public void deleteController(String groupId,
                             String controllerId)
                      throws AccessSecurityWriteException
アクセスコントローラを削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException

deleteControllerDepartment

public void deleteControllerDepartment(String groupId,
                                       String id,
                                       DepartmentInfo departmentInfo)
                                throws AccessSecurityWriteException
アクセスコントローラ組織を削除します。

パラメータ:
groupId - ログイングループID
id - コントローラID
departmentInfo - 組織情報
例外:
AccessSecurityWriteException

deleteControllerDepartments

public void deleteControllerDepartments(String groupId,
                                        String id)
                                 throws AccessSecurityWriteException
すべてのアクセスコントローラ組織を削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException

deleteControllerPost

public void deleteControllerPost(String groupId,
                                 String id,
                                 PostInfo postInfo)
                          throws AccessSecurityWriteException
アクセスコントローラ役職を削除します。

パラメータ:
groupId - ログイングループID
id - コントローラID
postInfo - 役職情報
例外:
AccessSecurityWriteException

deleteControllerPosts

public void deleteControllerPosts(String groupId,
                                  String id)
                           throws AccessSecurityWriteException
すべてのアクセスコントローラ役職を削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException

deleteControllerPublicGroup

public void deleteControllerPublicGroup(String groupId,
                                        String id,
                                        PublicGroupInfo publicGroupInfo)
                                 throws AccessSecurityWriteException
アクセスコントローラパブリックグループを削除します。

パラメータ:
groupId - ログイングループID
id - コントローラID
publicGroupInfo - パブリックグループ情報
例外:
AccessSecurityWriteException

deleteControllerPublicGroups

public void deleteControllerPublicGroups(String groupId,
                                         String id)
                                  throws AccessSecurityWriteException
すべてのアクセスコントローラパブリックグループを削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException

deleteControllerRole

public void deleteControllerRole(String groupId,
                                 String id,
                                 String roleId)
                          throws AccessSecurityWriteException
アクセスコントローラロールを削除します。

パラメータ:
groupId - ログイングループID
id - コントローラID
roleId - ロールID
例外:
AccessSecurityWriteException

deleteControllerRoles

public void deleteControllerRoles(String groupId,
                                  String id)
                           throws AccessSecurityWriteException
すべてのアクセスコントローラロールを削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException

getController

public AccessController getController(String groupId,
                                      String controllerId)
                               throws AccessSecurityReadException
アクセスコントローラ情報を取得します。

存在しない場合は、nullを返却します。

パラメータ:
groupId - ログイングループID
controllerId - コントローラID
戻り値:
アクセスコントローラ情報
例外:
AccessSecurityReadException

getControllers

public AccessController[] getControllers(String groupId)
                                  throws AccessSecurityReadException
すべてのアクセスコントローラ情報を取得します。

一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
戻り値:
アクセスコントローラ情報の配列
例外:
AccessSecurityReadException

getControllerDepartments

public DepartmentInfo[] getControllerDepartments(String groupId,
                                                 String id)
                                          throws AccessSecurityReadException
すべてのアクセスコントローラ組織を取得します。

一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
id - コントローラID
戻り値:
組織情報の配列
例外:
AccessSecurityReadException

getControllerIds

public String[] getControllerIds(String groupId)
                          throws AccessSecurityReadException
すべてのアクセスコントローラIDを取得します。

一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
戻り値:
クセスコントローラIDの配列
例外:
AccessSecurityReadException

getControllerIdsByDepartment

public String[] getControllerIdsByDepartment(String groupId,
                                             DepartmentInfo[] departments)
                                      throws AccessSecurityReadException
指定された組織を持つコントローラIDをすべて取得します。

パラメータ:
groupId - ログイングループID
departments - 組織情報の配列
戻り値:
コントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerIdsByPost

public String[] getControllerIdsByPost(String groupId,
                                       PostInfo[] posts)
                                throws AccessSecurityReadException
指定された役職を持つコントローラIDをすべて取得します。

パラメータ:
groupId - ログイングループID
posts - 役職情報の配列
戻り値:
コントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerIdsByPublicGroup

public String[] getControllerIdsByPublicGroup(String groupId,
                                              PublicGroupInfo[] publicGroups)
                                       throws AccessSecurityReadException
指定されたパブリックグループを持つコントローラIDをすべて取得します。

パラメータ:
groupId - ログイングループID
publicGroups - パブリックグループの配列
戻り値:
コントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerIdsByRole

public String[] getControllerIdsByRole(String groupId,
                                       String[] roleIds)
                                throws AccessSecurityReadException
指定されたロールIDを持つコントローラIDをすべて取得します。

パラメータ:
groupId - ログイングループID
roleIds - ロールIDの配列
戻り値:
コントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerPosts

public PostInfo[] getControllerPosts(String groupId,
                                     String id)
                              throws AccessSecurityReadException
すべてのアクセスコントローラ役職を取得します。

一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
id - コントローラID
戻り値:
役職情報の配列
例外:
AccessSecurityReadException

getControllerPublicGroups

public PublicGroupInfo[] getControllerPublicGroups(String groupId,
                                                   String id)
                                            throws AccessSecurityReadException
すべてのアクセスコントローラパブリックグループを取得します。

一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
id - コントローラID
戻り値:
パブリックグループ情報の配列
例外:
AccessSecurityReadException

getControllerRoles

public String[] getControllerRoles(String groupId,
                                   String id)
                            throws AccessSecurityReadException
すべてのアクセスコントローラロールを取得します。

一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
id - コントローラID
戻り値:
アクセスコントローラロールIDの配列
例外:
AccessSecurityReadException

init

public void init(Map params)
アクセスコントローラアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

insertAccessController

public void insertAccessController(String groupId,
                                   AccessController controller)
                            throws AccessSecurityWriteException
アクセスコントローラを作成します。

パラメータ:
groupId - ログイングループID
controller - アクセスコントローラ情報
例外:
AccessSecurityWriteException

insertControllerDepartment

public void insertControllerDepartment(String groupId,
                                       String id,
                                       DepartmentInfo departmentInfo)
                                throws AccessSecurityWriteException
アクセスコントローラ組織を新規に作成します。

パラメータ:
groupId - ログイングループID
id - コントローラID
departmentInfo - 組織情報
例外:
AccessSecurityWriteException

insertControllerPost

public void insertControllerPost(String groupId,
                                 String id,
                                 PostInfo postInfo)
                          throws AccessSecurityWriteException
アクセスコントローラ役職を新規に作成します。

パラメータ:
groupId - ログイングループID
id - コントローラID
postInfo - 役職情報
例外:
AccessSecurityWriteException

insertControllerPublicGroup

public void insertControllerPublicGroup(String groupId,
                                        String id,
                                        PublicGroupInfo publicGroupInfo)
                                 throws AccessSecurityWriteException
アクセスコントローラパブリックグループを新規に作成します。

パラメータ:
groupId - ログイングループID
id - コントローラID
publicGroupInfo - パブリックグループ情報
例外:
AccessSecurityWriteException

insertControllerRole

public void insertControllerRole(String groupId,
                                 String id,
                                 String roleId)
                          throws AccessSecurityWriteException
アクセスコントローラロールを新規に作成します。

パラメータ:
groupId - ログイングループID
id - コントローラID
roleId - ロールID
例外:
AccessSecurityWriteException

updateController

public void updateController(String groupId,
                             AccessController controller)
                      throws AccessSecurityWriteException
アクセスコントローラを更新します。

パラメータ:
groupId - ログイングループID
controller - アクセスコントローラ情報
例外:
AccessSecurityWriteException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccessControllerExporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.access
インタフェース AccessControllerExporter

既知の実装クラスの一覧:
StandardAccessControllerBackup
public interface AccessControllerExporter

アクセスコントローラエクスポートインタフェースです。

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
void | doExport(AccessControllerManager manager, OutputStream outputStream) エクスポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doExport

public void doExport(AccessControllerManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

アクセスコントローラ情報をバックアップファイルに出力します。

パラメータ:
manager - アクセスコントローラマネージャ
outputStream - 出力ストリーム
例外:
AccessSecurityExportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerImporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.access
インタフェース AccessControllerImporter

既知の実装クラスの一覧:
StandardAccessControllerBackup
public interface AccessControllerImporter

アクセスコントローラインポートインタフェースです。

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
void | doImport(InputStream inputStream, AccessControllerManager manager) インポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doImport

public void doImport(InputStream inputStream,
                     AccessControllerManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からアクセスコントローラ情報を取得し、生成します。

パラメータ:
manager - アクセスコントローラマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.access
クラス AccessControllerManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.access.AccessControllerManager
public final class AccessControllerManager
extends Object

アクセスコントローラマネージャクラス。

アクセスコントローラ情報の操作を行います。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
AccessControllerManager(String groupId)
コンストラクタ。
メソッドの概要
 void addController(AccessController controller)
アクセスコントローラを追加します。
 void addControllerDepartment(String controllerId, DepartmentInfo departmentInfo)
組織をアクセスコントローラに紐付けます。
 void addControllerPost(String controllerId, PostInfo postInfo)
役職をアクセスコントローラに紐付けます。
 void addControllerPublicGroup(String controllerId, PublicGroupInfo publicGroupInfo)
パブリックグループをアクセスコントローラに紐付けます。
 void addControllerRole(String controllerId, String roleId)
ロールをアクセスコントローラに紐付けます。
static void clearInstance()
アクセスコントローラマネージャのインスタンスを初期化します。
 void deleteController(String controllerId)
アクセスコントローラを削除します。
 void deleteControllerDepartment(String controllerId, DepartmentInfo departmentInfo)
組織の紐付けをアクセスコントローラから削除します。
 void deleteControllerDepartments(String controllerId)
組織の紐付けをアクセスコントローラからすべて削除します。
 void deleteControllerPost(String controllerId, PostInfo postInfo)
役織の紐付けをアクセスコントローラから削除します。
 void deleteControllerPosts(String controllerId)
役織の紐付けをアクセスコントローラからすべて削除します。
 void deleteControllerPublicGroup(String controllerId, PublicGroupInfo publicGroupInfo)
パブリックグループの紐付けをアクセスコントローラから削除します。
 void deleteControllerPublicGroups(String controllerId)
パブリックグループの紐付けをアクセスコントローラからすべて削除します。
 void deleteControllerRole(String controllerId, String roleId)
ロールの紐付けをアクセスコントローラから削除します。
 void deleteControllerRoles(String controllerId)
ロールの紐付けをアクセスコントローラから削除します。
 void deleteControllers()
すべてのアクセスコントローラを削除します。
 void exportData(String category, OutputStream outputStream)
アクセスコントローラ情報をエクスポートします。
 AccessController getController(String controllerId)
指定されたアクセスコントローラIDに対応するアクセスコントローラを取得します。
 DepartmentInfo[] getControllerDepartments(String controllerId)
アクセスコントローラに紐付いた組織の一覧を取得します。
 String[] getControllerIds()
すべてのアクセスコントローラIDを取得します。
 String[] getControllerIdsByDepartment(DepartmentInfo[] departments)
指定された組織を持つアクセスコントローラIDをすべて取得します。
 String[] getControllerIdsByPost(PostInfo[] posts)
指定された役職を持つアクセスコントローラIDをすべて取得します。
 String[] getControllerIdsByPublicGroup(PublicGroupInfo[] publicGroups)
指定されたパブリックグループを持つアクセスコントローラIDをすべて取得します。
 String[] getControllerIdsByRole(String[] roleIds)
指定されたロールIDを持つアクセスコントローラIDをすべて取得します。
 String[] getControllerIdsByUser(String userId, Date date)
指定されたユーザIDおよび日付で有効なアクセスコントローラIDをすべて取得します。
 PostInfo[] getControllerPosts(String controllerId)
アクセスコントローラに紐付いた役職の一覧を取得します。
 PublicGroupInfo[] getControllerPublicGroups(String controllerId)
アクセスコントローラに紐付いたパブリックグループの一覧を取得します。
 String[] getControllerRoles(String controllerId)
アクセスコントローラに紐付いたロールの一覧を取得します。
 AccessController[] getControllers()
すべてのアクセスコントローラを取得します。
 String[] getExportCategories()
アクセスコントローラエクスポート用のカテゴリの一覧を取得します。
 String[] getImportCategories()
アクセスコントローラインポート用のカテゴリの一覧を取得します。
 String getLoginGroupId()
ログイングループIDを取得します。
 void importData(String category, InputStream inputStream)
/** アクセスコントローラ情報をインポートします。
 boolean isUpdate(Date date)
アクセスコントローラが指定された日付よりも新しいかチェックします。
 void updateController(AccessController controller)
アクセスコントローラを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AccessControllerManager

public AccessControllerManager(String groupId)
                        throws AccessSecurityException
コンストラクタ。

ログイングループ単位のアクセスコントローラを操作するマネージャーを作成します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityException - ログイングループIDが不正な場合にスローされます。
メソッドの詳細

clearInstance

public static void clearInstance()
アクセスコントローラマネージャのインスタンスを初期化します。

アクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。
通常、このメソッドを使用する必要はありません。

addController

public void addController(AccessController controller)
                   throws AccessSecurityException
アクセスコントローラを追加します。

パラメータ:
controller - アクセスコントローラ
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

addControllerDepartment

public void addControllerDepartment(String controllerId,
                                    DepartmentInfo departmentInfo)
                             throws AccessSecurityException
組織をアクセスコントローラに紐付けます。

パラメータ:
controllerId - アクセスコントローラID
departmentInfo - 組織情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

addControllerPost

public void addControllerPost(String controllerId,
                              PostInfo postInfo)
                       throws AccessSecurityException
役職をアクセスコントローラに紐付けます。

パラメータ:
controllerId - アクセスコントローラID
postInfo - 役職情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

addControllerPublicGroup

public void addControllerPublicGroup(String controllerId,
                                     PublicGroupInfo publicGroupInfo)
                              throws AccessSecurityException
パブリックグループをアクセスコントローラに紐付けます。

パラメータ:
controllerId - アクセスコントローラID
publicGroupInfo - パブリックグループ
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

addControllerRole

public void addControllerRole(String controllerId,
                              String roleId)
                       throws AccessSecurityException
ロールをアクセスコントローラに紐付けます。

パラメータ:
controllerId - アクセスコントローラID
roleId - ロールID
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteController

public void deleteController(String controllerId)
                      throws AccessSecurityException
アクセスコントローラを削除します。

パラメータ:
controllerId - アクセスコントローラID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteControllerDepartment

public void deleteControllerDepartment(String controllerId,
                                       DepartmentInfo departmentInfo)
                                throws AccessSecurityException
組織の紐付けをアクセスコントローラから削除します。

パラメータ:
controllerId - アクセスコントローラID
departmentInfo - 組織情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteControllerDepartments

public void deleteControllerDepartments(String controllerId)
                                 throws AccessSecurityException
組織の紐付けをアクセスコントローラからすべて削除します。

パラメータ:
controllerId - アクセスコントローラID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteControllerPost

public void deleteControllerPost(String controllerId,
                                 PostInfo postInfo)
                          throws AccessSecurityException
役織の紐付けをアクセスコントローラから削除します。

パラメータ:
controllerId - アクセスコントローラID
postInfo - 役織情報
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteControllerPosts

public void deleteControllerPosts(String controllerId)
                           throws AccessSecurityException
役織の紐付けをアクセスコントローラからすべて削除します。

パラメータ:
controllerId - アクセスコントローラID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteControllerPublicGroup

public void deleteControllerPublicGroup(String controllerId,
                                        PublicGroupInfo publicGroupInfo)
                                 throws AccessSecurityException
パブリックグループの紐付けをアクセスコントローラから削除します。

パラメータ:
controllerId - アクセスコントローラID
publicGroupInfo - パブリックグループ
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteControllerPublicGroups

public void deleteControllerPublicGroups(String controllerId)
                                  throws AccessSecurityException
パブリックグループの紐付けをアクセスコントローラからすべて削除します。

パラメータ:
controllerId - アクセスコントローラID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteControllerRole

public void deleteControllerRole(String controllerId,
                                 String roleId)
                          throws AccessSecurityException
ロールの紐付けをアクセスコントローラから削除します。

パラメータ:
controllerId - アクセスコントローラID
roleId - ロールID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteControllerRoles

public void deleteControllerRoles(String controllerId)
                           throws AccessSecurityException
ロールの紐付けをアクセスコントローラから削除します。

パラメータ:
controllerId - アクセスコントローラID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteControllers

public void deleteControllers()
                       throws AccessSecurityException
すべてのアクセスコントローラを削除します。

例外:
AccessSecurityException - 削除処理に失敗した場合にスローされます。

exportData

public void exportData(String category,
                       OutputStream outputStream)
                throws AccessSecurityException
アクセスコントローラ情報をエクスポートします。

パラメータ:
category - カテゴリ
outputStream - 出力ストリーム
例外:
AccessSecurityException - エクスポートに失敗した場合、または引数が不正だった場合にスローされます。

getController

public AccessController getController(String controllerId)
                               throws AccessSecurityException
指定されたアクセスコントローラIDに対応するアクセスコントローラを取得します。

パラメータ:
controllerId - アクセスコントローラID
戻り値:
アクセスコントローラ
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getControllerDepartments

public DepartmentInfo[] getControllerDepartments(String controllerId)
                                          throws AccessSecurityException
アクセスコントローラに紐付いた組織の一覧を取得します。

パラメータ:
controllerId - アクセスコントローラID
戻り値:
組織情報の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getControllerIds

public String[] getControllerIds()
                          throws AccessSecurityException
すべてのアクセスコントローラIDを取得します。

戻り値:
アクセスコントローラIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getControllerIdsByDepartment

public String[] getControllerIdsByDepartment(DepartmentInfo[] departments)
                                      throws AccessSecurityException
指定された組織を持つアクセスコントローラIDをすべて取得します。

パラメータ:
departments - 組織情報の配列
戻り値:
アクセスコントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerIdsByPost

public String[] getControllerIdsByPost(PostInfo[] posts)
                                throws AccessSecurityException
指定された役職を持つアクセスコントローラIDをすべて取得します。

パラメータ:
posts - 役職情報の配列
戻り値:
アクセスコントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerIdsByPublicGroup

public String[] getControllerIdsByPublicGroup(PublicGroupInfo[] publicGroups)
                                       throws AccessSecurityException
指定されたパブリックグループを持つアクセスコントローラIDをすべて取得します。

パラメータ:
publicGroups - パブリックグループの配列
戻り値:
アクセスコントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerIdsByRole

public String[] getControllerIdsByRole(String[] roleIds)
                                throws AccessSecurityException
指定されたロールIDを持つアクセスコントローラIDをすべて取得します。

パラメータ:
roleIds - ロールIDの配列
戻り値:
アクセスコントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerIdsByUser

public String[] getControllerIdsByUser(String userId,
                                       Date date)
                                throws AccessSecurityException
指定されたユーザIDおよび日付で有効なアクセスコントローラIDをすべて取得します。

パラメータ:
userId - ユーザID
date - 日付
戻り値:
アクセスコントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerPosts

public PostInfo[] getControllerPosts(String controllerId)
                              throws AccessSecurityException
アクセスコントローラに紐付いた役職の一覧を取得します。

パラメータ:
controllerId - アクセスコントローラID
戻り値:
役職情報の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getControllerPublicGroups

public PublicGroupInfo[] getControllerPublicGroups(String controllerId)
                                            throws AccessSecurityException
アクセスコントローラに紐付いたパブリックグループの一覧を取得します。

パラメータ:
controllerId - アクセスコントローラID
戻り値:
パブリックグループの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getControllerRoles

public String[] getControllerRoles(String controllerId)
                            throws AccessSecurityException
アクセスコントローラに紐付いたロールの一覧を取得します。

パラメータ:
controllerId - アクセスコントローラID
戻り値:
ロールIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getControllers

public AccessController[] getControllers()
                                  throws AccessSecurityException
すべてのアクセスコントローラを取得します。

戻り値:
アクセスコントローラ情報の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getExportCategories

public String[] getExportCategories()
                             throws AccessSecurityException
アクセスコントローラエクスポート用のカテゴリの一覧を取得します。

戻り値:
アクセスコントローラエクスポート用カテゴリの一覧
例外:
AccessSecurityException - アクセスコントローラエクスポート用のカテゴリの取得に失敗した場合にスローされます。

getImportCategories

public String[] getImportCategories()
                             throws AccessSecurityException
アクセスコントローラインポート用のカテゴリの一覧を取得します。

戻り値:
アクセスコントローラインポート用カテゴリの一覧
例外:
AccessSecurityException - アクセスコントローラインポート用のカテゴリの取得に失敗した場合にスローされます。

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

戻り値:
ログイングループID

importData

public void importData(String category,
                       InputStream inputStream)
                throws AccessSecurityException
/** アクセスコントローラ情報をインポートします。

パラメータ:
category - カテゴリ
inputStream - 入力ストリーム
例外:
AccessSecurityException - インポートに失敗した場合、または引数が不正だった場合にスローされます。

updateController

public void updateController(AccessController controller)
                      throws AccessSecurityException
アクセスコントローラを更新します。

パラメータ:
controller - アクセスコントローラ情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

isUpdate

public boolean isUpdate(Date date)
                 throws AccessSecurityException
アクセスコントローラが指定された日付よりも新しいかチェックします。

パラメータ:
date - チェック日付
例外:
AccessSecurityReadException - 更新チェックに失敗した場合スローされます。
AccessSecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerPostWriterListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.access
インタフェース AccessControllerPostWriterListener

public interface AccessControllerPostWriterListener

アクセスコントローラ情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
6.1
バージョン:
1.0
関連項目:
AccessControllerManager

メソッドの概要
void | init(Map params) アクセスコントローラリスナーの初期化。
void | postCreate(String groupId, AccessController controller) アクセスコントローラ情報をデータストアに作成した直後にコールされます。
void | postDelete(String groupId, String controllerId) アクセスコントローラ情報をデータストアから削除した直後にコールされます。
void | postUpdate(String groupId, AccessController controller) アクセスコントローラ情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
アクセスコントローラリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreate

public void postCreate(String groupId,
                       AccessController controller)
                throws AccessSecurityListenerExcpetion
アクセスコントローラ情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
controller - 作成されたアクセスコントローラ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDelete

public void postDelete(String groupId,
                       String controllerId)
                throws AccessSecurityListenerExcpetion
アクセスコントローラ情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
controllerId - 削除されたアクセスコントローラID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdate

public void postUpdate(String groupId,
                       AccessController controller)
                throws AccessSecurityListenerExcpetion
アクセスコントローラ情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
controller - 更新されたアクセスコントローラ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerQueryWriterListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.access
インタフェース AccessControllerQueryWriterListener

public interface AccessControllerQueryWriterListener

アクセスコントローラ情報書き込み時（書き込む直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
6.1
バージョン:
1.0
関連項目:
AccessControllerManager

メソッドの概要
void | init(Map params) アクセスコントローラリスナーの初期化。
void | queryCreate(String groupId, AccessController controller) アクセスコントローラ情報をデータストアに作成する直前にコールされます。
void | queryDelete(String groupId, String controllerId) アクセスコントローラ情報をデータストアから削除する直前にコールされます。
void | queryUpdate(String groupId, AccessController controller) アクセスコントローラ情報をデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
アクセスコントローラリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreate

public void queryCreate(String groupId,
                        AccessController controller)
                 throws AccessSecurityListenerExcpetion
アクセスコントローラ情報をデータストアに作成する直前にコールされます。

パラメータ:
groupId - ログイングループID
controller - 作成されるアクセスコントローラ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDelete

public void queryDelete(String groupId,
                        String controllerId)
                 throws AccessSecurityListenerExcpetion
アクセスコントローラ情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
controllerId - 削除されるアクセスコントローラID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdate

public void queryUpdate(String groupId,
                        AccessController controller)
                 throws AccessSecurityListenerExcpetion
アクセスコントローラ情報をデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
controller - 更新されるアクセスコントローラ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerReaderDecorator (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.access
インタフェース AccessControllerReaderDecorator

public interface AccessControllerReaderDecorator

アクセスコントローラ情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
AccessController | doDecoration(String groupId, AccessController controller) アクセスコントローラデータストアからの読み込み直後にコールされます。
void | init(Map params) アクセスコントローラデコレータの初期化。

メソッドの詳細

init

public void init(Map params)
アクセスコントローラデコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public AccessController doDecoration(String groupId,
                                     AccessController controller)
アクセスコントローラデータストアからの読み込み直後にコールされます。

パラメータ:
groupId - ログイングループID
controller - 読み込みが行われたアクセスコントローラ情報
戻り値:
拡張されたアクセスコントローラ情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyChangedControllerListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.access
クラス CompanyChangedControllerListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener
すべての実装インタフェース:
CompanyChangedListener
public class CompanyChangedControllerListener
extends Object
implements CompanyChangedListener

会社・組織・役職が削除された場合にアクセスコントローラに紐付く会社・組織・役職を削除するリスナークラスです。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
CompanyChangedControllerListener()
メソッドの概要
void | categoryDetailRemoved(String groupId, CompanyCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | categoryDetailSet(String groupId, CompanyCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | companyAdded(String groupId, Company company) 会社情報がデータストアに登録された後に呼び出されます。
void | companyDeleted(String groupId, Company company) 会社情報がデータストアから削除された後に呼び出されます。
void | departmentAdded(String groupId, Department department) 組織情報がデータストアに登録された後に呼び出されます。
void | departmentDeleted(String groupId, Department department) 組織情報がデータストアに更新された後に呼び出されます。
void | departmentJoined(String groupId, String company, String parentDepartment, String department, String version) 組織構成がデータストアに登録された後に呼び出されます。
void | departmentLeft(String groupId, String company, String department, String version) 組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
void | departmentMoved(String groupId, String company, String parentDepartment, String department, String version) 組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
void | departmentUpdated(String groupId, Department department) 組織情報がデータストアから削除された後に呼び出されます。
void | init(Map params) 会社リスナーの初期化を行います。
void | mainRemoved(String groupId, DepartmentMain main) 主所属情報がデータストアから削除された後に呼び出されます。
void | mainSet(String groupId, DepartmentMain main) 主所属情報がデータストアに登録された後に呼び出されます。
void | memberDeleted(String groupId, DepartmentAttach attach) 組織からの人員の割当がデータストアから削除された後に呼び出されます。
void | memberSet(String groupId, DepartmentAttach attach) 組織への人員の割当がデータストアに登録された後に呼び出されます。
void | postAdded(String groupId, CompanyPost post) 役職情報がデータストアに登録された後に呼び出されます。
void | postDeleted(String groupId, CompanyPost post) 役職情報がデータストアから削除された後に呼び出されます。
void | postUpdated(String groupId, CompanyPost post) 役職情報がデータストアに更新された後に呼び出されます。
void | setUserId(String userId) ログインユーザIDを設定します。
void | versionAdded(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに登録された後に呼び出されます。
void | versionCopied(String groupId, String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
void | versionDeleted(String groupId, CompanyVersion version) 会社構成バージョンがデータストアから削除された後に呼び出されます。
void | versionUpdated(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに更新された後に呼び出されます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyChangedControllerListener

public CompanyChangedControllerListener()
メソッドの詳細

init

public void init(Map params)
会社リスナーの初期化を行います。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース CompanyChangedListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

setUserId

public void setUserId(String userId)
ログインユーザIDを設定します。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース CompanyChangedListener 内の setUserId
パラメータ:
userId - ログインユーザID

companyAdded

public void companyAdded(String groupId,
                         Company company)
                  throws ChangedListenerException
会社情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の companyAdded
パラメータ:
groupId - ログイングループID
company - 会社情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

companyDeleted

public void companyDeleted(String groupId,
                           Company company)
                    throws ChangedListenerException
会社情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の companyDeleted
パラメータ:
groupId - ログイングループID
company - 会社情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentAdded

public void departmentAdded(String groupId,
                            Department department)
                     throws ChangedListenerException
組織情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentAdded
パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentUpdated

public void departmentUpdated(String groupId,
                              Department department)
                       throws ChangedListenerException
組織情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentUpdated
パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentDeleted

public void departmentDeleted(String groupId,
                              Department department)
                       throws ChangedListenerException
組織情報がデータストアに更新された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentDeleted
パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentJoined

public void departmentJoined(String groupId,
                             String company,
                             String parentDepartment,
                             String department,
                             String version)
                      throws ChangedListenerException
組織構成がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentJoined
パラメータ:
groupId - ログイングループID
company - 会社コード
parentDepartment - 新規登録する組織の上位となる組織の組織コード（または会社の会社コード）
department - 組織情報（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentMoved

public void departmentMoved(String groupId,
                            String company,
                            String parentDepartment,
                            String department,
                            String version)
                     throws ChangedListenerException
組織構成からの組織の移動がデータストアに反映された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentMoved
パラメータ:
groupId - ログイングループID
company - 上位組織と移動対象の組織が所属する会社の会社コード
parentDepartment - 上位組織の組織コード（または会社の会社コード）
department - 移動する組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentLeft

public void departmentLeft(String groupId,
                           String company,
                           String department,
                           String version)
                    throws ChangedListenerException
組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentLeft
パラメータ:
groupId - ログイングループID
company - 会社コード
department - 離脱させる組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailSet

public void categoryDetailSet(String groupId,
                              CompanyCategory category)
                       throws ChangedListenerException
分類区分情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の categoryDetailSet
パラメータ:
groupId - ログイングループID
category - 登録された分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailRemoved

public void categoryDetailRemoved(String groupId,
                                  CompanyCategory category)
                           throws ChangedListenerException
分類区分情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の categoryDetailRemoved
パラメータ:
groupId - ログイングループID
category - 削除された分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberSet

public void memberSet(String groupId,
                      DepartmentAttach attach)
               throws ChangedListenerException
組織への人員の割当がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の memberSet
パラメータ:
groupId - ログイングループID
attach - 割当られた人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberDeleted

public void memberDeleted(String groupId,
                          DepartmentAttach attach)
                   throws ChangedListenerException
組織からの人員の割当がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の memberDeleted
パラメータ:
groupId - ログイングループID
attach - 組織から外された人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

mainSet

public void mainSet(String groupId,
                    DepartmentMain main)
             throws ChangedListenerException
主所属情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の mainSet
パラメータ:
groupId - ログイングループID
main - 主所属情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

mainRemoved

public void mainRemoved(String groupId,
                        DepartmentMain main)
                 throws ChangedListenerException
主所属情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の mainRemoved
パラメータ:
groupId - ログイングループID
main - 主所属情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionAdded

public void versionAdded(String groupId,
                         CompanyVersion version)
                  throws ChangedListenerException
会社構成バージョンがデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の versionAdded
パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionUpdated

public void versionUpdated(String groupId,
                           CompanyVersion version)
                    throws ChangedListenerException
会社構成バージョンがデータストアに更新された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の versionUpdated
パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionDeleted

public void versionDeleted(String groupId,
                           CompanyVersion version)
                    throws ChangedListenerException
会社構成バージョンがデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の versionDeleted
パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionCopied

public void versionCopied(String groupId,
                          String company,
                          String srcVersion,
                          String destVersion,
                          Term term)
                   throws ChangedListenerException
登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の versionCopied
パラメータ:
groupId - ログイングループID
company - コピー元、コピー先の会社構成バージョンの会社コード
srcVersion - コピー元の会社構成バージョンのバージョンコード
destVersion - コピー先の会社構成バージョンのバージョンコード
term - コピー先の会社構成バージョンの期間
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

postAdded

public void postAdded(String groupId,
                      CompanyPost post)
               throws ChangedListenerException
役職情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の postAdded
パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

postUpdated

public void postUpdated(String groupId,
                        CompanyPost post)
                 throws ChangedListenerException
役職情報がデータストアに更新された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の postUpdated
パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

postDeleted

public void postDeleted(String groupId,
                        CompanyPost post)
                 throws ChangedListenerException
役職情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の postDeleted
パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.access (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.security.access
インタフェース
AccessControllerAccessor
AccessControllerExporter
AccessControllerImporter
AccessControllerPostWriterListener
AccessControllerQueryWriterListener
AccessControllerReaderDecorator
クラス
AccessController
AccessControllerManager
CompanyChangedControllerListener
PublicGroupChangedControllerListener
RoleChangedControllerListener
StandardAccessControllerBackup


jp.co.intra_mart.foundation.security.access (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.access

インタフェースの概要
AccessControllerAccessor | アクセスコントローラアクセッサインタフェース。
AccessControllerExporter | アクセスコントローラエクスポートインタフェースです。
AccessControllerImporter | アクセスコントローラインポートインタフェースです。
AccessControllerPostWriterListener | アクセスコントローラ情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AccessControllerQueryWriterListener | アクセスコントローラ情報書き込み時（書き込む直前）のリスナ・インターフェースを定義します。
AccessControllerReaderDecorator | アクセスコントローラ情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

クラスの概要
AccessController | アクセスコントローラ・モデルクラス。
AccessControllerManager | アクセスコントローラマネージャクラス。
CompanyChangedControllerListener | 会社・組織・役職が削除された場合にアクセスコントローラに紐付く会社・組織・役職を削除するリスナークラスです。
PublicGroupChangedControllerListener | パブリックグループが削除された場合にアクセスコントローラに紐付くパブリックグループを削除するリスナークラスです。
RoleChangedControllerListener | ロールが削除された場合にアクセスコントローラに紐付くロールを削除するリスナークラスです。
StandardAccessControllerBackup |


jp.co.intra_mart.foundation.security.access クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.access の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.access.AccessController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.access.AccessControllerManager
    • class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener)
    • class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener (implements jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener)
    • class jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener (implements jp.co.intra_mart.foundation.security.role.RoleChangedListener)
    • class jp.co.intra_mart.foundation.security.access.StandardAccessControllerBackup (implements jp.co.intra_mart.foundation.security.access.AccessControllerExporter, jp.co.intra_mart.foundation.security.access.AccessControllerImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor
  • interface jp.co.intra_mart.foundation.security.access.AccessControllerExporter
  • interface jp.co.intra_mart.foundation.security.access.AccessControllerImporter
  • interface jp.co.intra_mart.foundation.security.access.AccessControllerPostWriterListener
  • interface jp.co.intra_mart.foundation.security.access.AccessControllerQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.access.AccessControllerReaderDecorator


パッケージ jp.co.intra_mart.foundation.security.access の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.access の使用

jp.co.intra_mart.foundation.security.access を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |

jp.co.intra_mart.foundation.security により使用される jp.co.intra_mart.foundation.security.access のクラス
AccessController
アクセスコントローラ・モデルクラス。
AccessControllerAccessor
アクセスコントローラアクセッサインタフェース。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.security.access のクラス
AccessController
アクセスコントローラ・モデルクラス。
AccessControllerExporter
アクセスコントローラエクスポートインタフェースです。
AccessControllerImporter
アクセスコントローラインポートインタフェースです。
AccessControllerManager
アクセスコントローラマネージャクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupChangedControllerListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.access
クラス PublicGroupChangedControllerListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener
すべての実装インタフェース:
PublicGroupChangedListener
public class PublicGroupChangedControllerListener
extends Object
implements PublicGroupChangedListener

パブリックグループが削除された場合にアクセスコントローラに紐付くパブリックグループを削除するリスナークラスです。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
PublicGroupChangedControllerListener()
メソッドの概要
void | categoryDetailRemoved(String groupId, PublicGroupCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | categoryDetailSet(String groupId, PublicGroupCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | groupSetAdded(String groupId, PublicGroupSet groupSet) グループセットがデータストアに登録された後に呼び出されます。
void | groupSetDeleted(String groupId, PublicGroupSet groupSet) グループセットがデータストアから削除された後に呼び出されます。
void | init(Map params) アカウントリスナーの初期化を行います。
void | memberDeleted(String groupId, PublicGroupAttach attach) パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
void | memberSet(String groupId, PublicGroupAttach attach) パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
void | publicGroupAdded(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに登録された後に呼び出されます。
void | publicGroupDeleted(String groupId, PublicGroup publicGroup) パブリックグループがデータストアから削除された後に呼び出されます。
void | publicGroupJoined(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
void | publicGroupLeft(String groupId, String groupSet, String publicGroup, String version) パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
void | publicGroupMoved(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
void | publicGroupUpdated(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに更新された後に呼び出されます。
void | setUesrId(String userid) ログインユーザIDを設定します。
void | versionAdded(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
void | versionCopied(String groupId, String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
void | versionDeleted(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
void | versionUpdated(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupChangedControllerListener

public PublicGroupChangedControllerListener()
メソッドの詳細

init

public void init(Map params)
アカウントリスナーの初期化を行います。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

setUesrId

public void setUesrId(String userid)
ログインユーザIDを設定します。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の setUesrId
パラメータ:
userid - ログインユーザID

groupSetAdded

public void groupSetAdded(String groupId,
                          PublicGroupSet groupSet)
                   throws ChangedListenerException
グループセットがデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の groupSetAdded
パラメータ:
groupId - ログイングループID
groupSet - グループセット
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

groupSetDeleted

public void groupSetDeleted(String groupId,
                            PublicGroupSet groupSet)
                     throws ChangedListenerException
グループセットがデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の groupSetDeleted
パラメータ:
groupId - ログイングループID
groupSet - グループセット
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupAdded

public void publicGroupAdded(String groupId,
                             PublicGroup publicGroup)
                      throws ChangedListenerException
パブリックグループがデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupAdded
パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupUpdated

public void publicGroupUpdated(String groupId,
                               PublicGroup publicGroup)
                        throws ChangedListenerException
パブリックグループがデータストアに更新された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupUpdated
パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupDeleted

public void publicGroupDeleted(String groupId,
                               PublicGroup publicGroup)
                        throws ChangedListenerException
パブリックグループがデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupDeleted
パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupJoined

public void publicGroupJoined(String groupId,
                              String groupSet,
                              String parentGroup,
                              String publicGroup,
                              String version)
                       throws ChangedListenerException
パブリックグループ構成情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupJoined
パラメータ:
groupId - ログイングループID
groupSet - 上位パブリックグループと新規登録されるパブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup - 新規登録するパブリックグループの上位となるパブリックグループのグループコード（またはパブリックグループセットのグループセットコード）
publicGroup - パブリックグループ情報（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupMoved

public void publicGroupMoved(String groupId,
                             String groupSet,
                             String parentGroup,
                             String publicGroup,
                             String version)
                      throws ChangedListenerException
パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupMoved
パラメータ:
groupId - ログイングループID
groupSet - 上位パブリックグループと移動対象のパブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup - 上位パブリックグループのグループコード（またはパブリックグループセットのグループセットコード）
publicGroup - 移動するパブリックグループのグループコード（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupLeft

public void publicGroupLeft(String groupId,
                            String groupSet,
                            String publicGroup,
                            String version)
                     throws ChangedListenerException
パブリックグループ構成情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupLeft
パラメータ:
groupId - ログイングループID
groupSet - グループセットコード
publicGroup - 離脱させるパブリックグループのグループコード（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailSet

public void categoryDetailSet(String groupId,
                              PublicGroupCategory category)
                       throws ChangedListenerException
分類区分情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の categoryDetailSet
パラメータ:
groupId - ログイングループID
category - 分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailRemoved

public void categoryDetailRemoved(String groupId,
                                  PublicGroupCategory category)
                           throws ChangedListenerException
分類区分情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の categoryDetailRemoved
パラメータ:
groupId - ログイングループID
category - 分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberSet

public void memberSet(String groupId,
                      PublicGroupAttach attach)
               throws ChangedListenerException
パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の memberSet
パラメータ:
groupId - ログイングループID
attach - 割当られた人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberDeleted

public void memberDeleted(String groupId,
                          PublicGroupAttach attach)
                   throws ChangedListenerException
パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の memberDeleted
パラメータ:
groupId - ログイングループID
attach - パブリックグループから外された人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionAdded

public void versionAdded(String groupId,
                         PublicGroupVersion version)
                  throws ChangedListenerException
パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の versionAdded
パラメータ:
groupId - ログイングループID
version - パブリックグループ構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionUpdated

public void versionUpdated(String groupId,
                           PublicGroupVersion version)
                    throws ChangedListenerException
パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の versionUpdated
パラメータ:
groupId - ログイングループID
version - パブリックグループセット構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionDeleted

public void versionDeleted(String groupId,
                           PublicGroupVersion version)
                    throws ChangedListenerException
パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の versionDeleted
パラメータ:
groupId - ログイングループID
version - パブリックグループセット構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionCopied

public void versionCopied(String groupId,
                          String groupSet,
                          String srcVersion,
                          String destVersion,
                          Term term)
                   throws ChangedListenerException
登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の versionCopied
パラメータ:
groupId - ログイングループID
groupSet - コピー元、コピー先のパブリックグループセット構成バージョンのパブリックグループコード
srcVersion - コピー元のパブリックグループセット構成バージョンのバージョンコード
destVersion - コピー先のパブリックグループセット構成バージョンのバージョンコード
term - コピー先のパブリックグループセット構成バージョンの期間
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleChangedControllerListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.access
クラス RoleChangedControllerListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener
すべての実装インタフェース:
RoleChangedListener
public class RoleChangedControllerListener
extends Object
implements RoleChangedListener

ロールが削除された場合にアクセスコントローラに紐付くロールを削除するリスナークラスです。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
RoleChangedControllerListener()
コンストラクタ。
メソッドの概要
void | init(Map params) ロールリスナーの初期化。
void | roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | roleDeleted(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | subRoleAdded(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | subRoleDeleted(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RoleChangedControllerListener

public RoleChangedControllerListener()
コンストラクタ。

メソッドの詳細

init

public void init(Map params)
ロールリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース RoleChangedListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

roleAdded

public void roleAdded(String groupId,
                      Role role)
               throws ChangedListenerException
ロール情報をデータストアに作成した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の roleAdded
パラメータ:
groupId - ログイングループID
role - 作成されたロール
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

roleDeleted

public void roleDeleted(String groupId,
                        String roleId)
                 throws ChangedListenerException
ロール情報をデータストアから削除した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の roleDeleted
パラメータ:
groupId - ログイングループID
roleId - 削除されたロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

roleUpdated

public void roleUpdated(String groupId,
                        Role role)
                 throws ChangedListenerException
ロール情報をデータストアに更新した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の roleUpdated
パラメータ:
groupId - ログイングループID
role - 更新されたロール
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

subRoleAdded

public void subRoleAdded(String groupId,
                         String roleId,
                         String subRoleId)
                  throws ChangedListenerException
ロールにサブロールを追加した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の subRoleAdded
パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 追加されたサブロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

subRoleDeleted

public void subRoleDeleted(String groupId,
                           String roleId,
                           String subRoleId)
                    throws ChangedListenerException
ロールからサブロールを削除した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の subRoleDeleted
パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 削除されたサブロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardAccessControllerBackup (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.access
クラス StandardAccessControllerBackup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.access.StandardAccessControllerBackup
すべての実装インタフェース:
AccessControllerExporter, AccessControllerImporter
public class StandardAccessControllerBackup
extends Object
implements AccessControllerImporter, AccessControllerExporter

コンストラクタの概要
StandardAccessControllerBackup()
メソッドの概要
void | doExport(AccessControllerManager manager, OutputStream outputStream) エクスポートを行います。
void | doImport(InputStream inputStream, AccessControllerManager manager) インポートを行います。
void | init(Map params) 初期化。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardAccessControllerBackup

public StandardAccessControllerBackup()
メソッドの詳細

init

public void init(Map params)
初期化。

初期化します。

定義:
インタフェース AccessControllerImporter 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     AccessControllerManager manager)
              throws AccessSecurityImportException
インタフェース AccessControllerImporter の記述:
インポートを行います。

ストリーム内の情報からアクセスコントローラ情報を取得し、生成します。

定義:
インタフェース AccessControllerImporter 内の doImport
パラメータ:
manager - アクセスコントローラマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

doExport

public void doExport(AccessControllerManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
インタフェース AccessControllerExporter の記述:
エクスポートを行います。

アクセスコントローラ情報をバックアップファイルに出力します。

定義:
インタフェース AccessControllerExporter 内の doExport
パラメータ:
manager - アクセスコントローラマネージャ
outputStream - 出力ストリーム
例外:
AccessSecurityExportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.account.Account の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.account.Account の使用

Account を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession |
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification.ldap.extension | ユーザログインLDAP認証クラス(複数OU対応版)の設定方法。
jp.co.intra_mart.foundation.security.mobile |
jp.co.intra_mart.foundation.security.password |

jp.co.intra_mart.foundation.security での Account の使用

Account を返す jp.co.intra_mart.foundation.security のメソッド
Account | StandardAccountAccessor.getAccount(String groupId, String userId) アカウント情報を取得する。
Account[] | StandardAccountAccessor.getAccountsByUserIds(String groupId, String[] userIds) 指定されたユーザIDのアカウント情報をすべて取得する。
Account[] | StandardAccountAccessor.searchAccounts(String groupId, String userId) アカウント情報の読み込みます。

Account 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | StandardAccountAccessor.insertAccount(String groupId, Account account) アカウント情報を新規追加する。
void | StandardAccountAccessor.updateAccount(String groupId, Account account) アカウント情報を更新する。

jp.co.intra_mart.foundation.security.account での Account の使用

Account を返す jp.co.intra_mart.foundation.security.account のメソッド
Account | AccountReaderDecorator.doDecoration(String groupId, Account account) アカウントをデータストアからの読み込み直後にコールされます。
Account | AccountManager.getAccount(String userId) ユーザIDにマッチしたユーザデータを１件取得します。
Account[] | AccountManager.getAccounts() ログイングループ内のすべてのユーザアカウントを取得します。
Account[] | AccountManager.getAccountsByUserIds(String[] userIds) ログイングループ内で引数指定したユーザIDのユーザアカウントをすべて取得します。
Account[] | AccountManager.searchAccounts(String userId) ユーザIDを検索してマッチしたアカウントを配列で返します。
Account | AccountAccessor.getAccount(String groupId, String userId) アカウント情報を取得する。
Account[] | AccountAccessor.getAccountsByUserIds(String groupId, String[] userIds) 指定されたユーザIDのアカウント情報をすべて取得する。
Account[] | AccountAccessor.searchAccounts(String groupId, String userId) アカウント情報の読み込みます。
protected Account[] | StandardAccountBackup.getAllAccounts(String groupId)
protected Account[] | CsvAccountBackup.getAllAccounts(String groupId)

Account 型のパラメータを持つ jp.co.intra_mart.foundation.security.account のメソッド
Account | AccountReaderDecorator.doDecoration(String groupId, Account account) アカウントをデータストアからの読み込み直後にコールされます。
void | AccountQueryWriterListener.queryCreateAccount(String groupId, Account account) アカウント情報をデータストアに作成する直前にコールされます。
void | AccountQueryWriterListener.queryUpdateAccount(String groupId, Account account) アカウント情報をデータストアに更新する直前にコールされます。
void | AccountPostWriterListener.postCreateAccount(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | AccountPostWriterListener.postUpdateAccount(String groupId, Account account) アカウント情報をデータストアに更新した直後にコールされます。
void | AccountManager.addAccount(Account account) アカウントを新規追加します。
void | AccountManager.updateAccount(Account account) アカウントを更新します。
void | AccountChangedListener.accountAdded(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | AccountChangedListener.accountUpdated(String groupId, Account account) アカウント情報をデータストアに更新した直後にコールされます。
void | AccountAccessor.insertAccount(String groupId, Account account) アカウント情報を新規追加する。
void | AccountAccessor.updateAccount(String groupId, Account account) アカウント情報を更新する。

jp.co.intra_mart.foundation.security.activesession での Account の使用

Account 型のパラメータを持つ jp.co.intra_mart.foundation.security.activesession のメソッド
 void UserActiveSessionRegister.doCertification(int certificationResult, LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response)
ユーザの認証後にコールされるメソッドです。

jp.co.intra_mart.foundation.security.certification での Account の使用

Account 型のパラメータを持つ jp.co.intra_mart.foundation.security.certification のメソッド
void | UserCertificationListener.doCertification(int certificationResult, LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザの認証後にコールされるメソッドです。
int | UserCertification.certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証する。
int | StandardUserCertification.certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証します。
int | LDAPUserCertification.certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証する。

jp.co.intra_mart.foundation.security.certification.ldap.extension での Account の使用

Account 型のパラメータを持つ jp.co.intra_mart.foundation.security.certification.ldap.extension のメソッド
 int LDAPUserCertification.certification(LoginInfo loginInfo, Account account, HttpServletRequest req, HttpServletResponse resp)
LDAPに対してユーザを認証します。

jp.co.intra_mart.foundation.security.mobile での Account の使用

Account 型のパラメータを持つ jp.co.intra_mart.foundation.security.mobile のメソッド
void | NonceResetListener4MobileEasyLogin.queryUpdateAccount(String groupId, Account account)
void | NonceResetListener4MobileEasyLogin.postUpdateAccount(String groupId, Account account)
void | NonceResetListener4MobileEasyLogin.queryCreateAccount(String groupId, Account account)
void | NonceResetListener4MobileEasyLogin.postCreateAccount(String groupId, Account account)

jp.co.intra_mart.foundation.security.password での Account の使用

Account 型のパラメータを持つ jp.co.intra_mart.foundation.security.password のメソッド
void | PasswordHistoryAccountChangedListener.accountAdded(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | PasswordHistoryAccountChangedListener.accountUpdated(String groupId, Account account) アカウント情報をデータストアに更新した直後にコールされます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.account.AccountAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.account.AccountAccessor の使用

AccountAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での AccountAccessor の使用

AccountAccessor を実装している jp.co.intra_mart.foundation.security のクラス
 class StandardAccountAccessor
アカウントアクセッサクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.account.AccountChangedListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.account.AccountChangedListener の使用

AccountChangedListener を使用しているパッケージ
jp.co.intra_mart.foundation.security.password

jp.co.intra_mart.foundation.security.password での AccountChangedListener の使用

AccountChangedListener を実装している jp.co.intra_mart.foundation.security.password のクラス
 class PasswordHistoryAccountChangedListener
アカウント情報変更リスナー(パスワード履歴管理)。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.account.AccountExporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.account.AccountExporter の使用

AccountExporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.account アカウントに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.account での AccountExporter の使用

AccountExporter を実装している jp.co.intra_mart.foundation.security.account のクラス
class | CsvAccountBackup CSVアカウントバックアップクラスです。
class | StandardAccountBackup アカウント情報をインポート・エクスポートするクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.account.AccountImporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.account.AccountImporter の使用

AccountImporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.account アカウントに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.account での AccountImporter の使用

AccountImporter を実装している jp.co.intra_mart.foundation.security.account のクラス
class | CsvAccountBackup CSVアカウントバックアップクラスです。
class | StandardAccountBackup アカウント情報をインポート・エクスポートするクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.account.AccountManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.account.AccountManager の使用

AccountManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.account アカウントに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.account での AccountManager の使用

AccountManager 型のパラメータを持つ jp.co.intra_mart.foundation.security.account のメソッド
void | AccountImporter.doImport(InputStream inputStream, AccountManager manager) インポートを行います。
void | AccountExporter.doExport(AccountManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardAccountBackup.doImport(InputStream inputStream, AccountManager manager) インポートを行います。
void | StandardAccountBackup.doExport(AccountManager manager, OutputStream outputStream) エクスポートを行います。
void | CsvAccountBackup.doImport(InputStream inputStream, AccountManager manager) インポートを行います。
void | CsvAccountBackup.doExport(AccountManager manager, OutputStream outputStream) エクスポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.account.AccountPostWriterListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.account.AccountPostWriterListener の使用

AccountPostWriterListener を使用しているパッケージ
jp.co.intra_mart.foundation.security.mobile

jp.co.intra_mart.foundation.security.mobile での AccountPostWriterListener の使用

AccountPostWriterListener を実装している jp.co.intra_mart.foundation.security.mobile のクラス
 class NonceResetListener4MobileEasyLogin
かんたんログイン用のNonceを再設定する為のリスナーです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener の使用

AccountQueryWriterListener を使用しているパッケージ
jp.co.intra_mart.foundation.security.mobile

jp.co.intra_mart.foundation.security.mobile での AccountQueryWriterListener の使用

AccountQueryWriterListener を実装している jp.co.intra_mart.foundation.security.mobile のクラス
 class NonceResetListener4MobileEasyLogin
かんたんログイン用のNonceを再設定する為のリスナーです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.account.AccountReaderDecorator の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.account.AccountReaderDecorator の使用

jp.co.intra_mart.foundation.security.account.AccountReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.account.AccountRole の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.account.AccountRole の使用

AccountRole を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.mobile |
jp.co.intra_mart.foundation.security.password |

jp.co.intra_mart.foundation.security での AccountRole の使用

AccountRole を返す jp.co.intra_mart.foundation.security のメソッド
AccountRole | StandardAccountAccessor.getAccountRole(String groupId, String userId, String roleId) アカウントロール情報を取得する。
AccountRole[] | StandardAccountAccessor.getAccountRoles(String groupId, String userId) アカウントロール情報をすべて取得する。

AccountRole 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | StandardAccountAccessor.insertAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を新規追加する。
void | StandardAccountAccessor.updateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を更新する。

jp.co.intra_mart.foundation.security.account での AccountRole の使用

AccountRole を返す jp.co.intra_mart.foundation.security.account のメソッド
AccountRole[] | AccountManager.getAccountRoles(String userId) アカウントロールをすべて取得します。
AccountRole[] | AccountManager.getAccountRoles(String userId, Date date) 有効期間内のアカウントロールをすべて取得します。
AccountRole | AccountAccessor.getAccountRole(String groupId, String userId, String roleId) アカウントロール情報を取得する。
AccountRole[] | AccountAccessor.getAccountRoles(String groupId, String userId) アカウントロール情報をすべて取得する。

AccountRole 型のパラメータを持つ jp.co.intra_mart.foundation.security.account のメソッド
void | AccountQueryWriterListener.queryCreateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | AccountQueryWriterListener.queryUpdateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新する直前にコールされます。
void | AccountPostWriterListener.postCreateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | AccountPostWriterListener.postUpdateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新した直後にコールされます。
void | AccountManager.addAccountRole(String userId, AccountRole accountRole) アカウントロールを新規追加します。
void | AccountManager.updateAccountRole(String userId, AccountRole accountRole) アカウントロールを更新します。
void | AccountChangedListener.accountRoleAdded(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | AccountChangedListener.accountRoleUpdated(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新した直後にコールされます。
void | AccountAccessor.insertAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を新規追加する。
void | AccountAccessor.updateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を更新する。

jp.co.intra_mart.foundation.security.mobile での AccountRole の使用

AccountRole 型のパラメータを持つ jp.co.intra_mart.foundation.security.mobile のメソッド
void | NonceResetListener4MobileEasyLogin.queryCreateAccountRole(String groupId, String userId, AccountRole accountRole)
void | NonceResetListener4MobileEasyLogin.queryUpdateAccountRole(String groupId, String userId, AccountRole accountRole)
void | NonceResetListener4MobileEasyLogin.postCreateAccountRole(String groupId, String userId, AccountRole accountRole)
void | NonceResetListener4MobileEasyLogin.postUpdateAccountRole(String groupId, String userId, AccountRole accountRole)

jp.co.intra_mart.foundation.security.password での AccountRole の使用

AccountRole 型のパラメータを持つ jp.co.intra_mart.foundation.security.password のメソッド
void | PasswordHistoryAccountChangedListener.accountRoleAdded(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | PasswordHistoryAccountChangedListener.accountRoleUpdated(String grouId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新した直後にコールされます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.account.CsvAccountBackup の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.account.CsvAccountBackup の使用

jp.co.intra_mart.foundation.security.account.CsvAccountBackup はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.account.FavoriteMenu の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.account.FavoriteMenu の使用

FavoriteMenu を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.mobile |

jp.co.intra_mart.foundation.security での FavoriteMenu の使用

FavoriteMenu を返す jp.co.intra_mart.foundation.security のメソッド
FavoriteMenu | StandardAccountAccessor.getFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を取得する。
FavoriteMenu[] | StandardAccountAccessor.getFavoriteMenus(String groupId, String userId) マイメニュー情報をすべて取得する。

FavoriteMenu 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | StandardAccountAccessor.insertFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を新規追加する。
void | StandardAccountAccessor.updateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を更新する。

jp.co.intra_mart.foundation.security.account での FavoriteMenu の使用

FavoriteMenu を返す jp.co.intra_mart.foundation.security.account のメソッド
FavoriteMenu[] | AccountManager.getFavoriteMenus(String userId) マイメニューをすべて取得します。
FavoriteMenu | AccountAccessor.getFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を取得する。
FavoriteMenu[] | AccountAccessor.getFavoriteMenus(String groupId, String userId) マイメニュー情報をすべて取得する。

FavoriteMenu 型のパラメータを持つ jp.co.intra_mart.foundation.security.account のメソッド
void | AccountQueryWriterListener.queryCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに作成する直前にコールされます。
void | AccountQueryWriterListener.queryUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに更新する直前にコールされます。
void | AccountPostWriterListener.postCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに作成した直後にコールされます。
void | AccountPostWriterListener.postUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに更新した直後にコールされます。
void | AccountManager.addFavoriteMenu(String userId, FavoriteMenu favoriteMenu) マイメニューを新規追加します。
void | AccountManager.updateFavoriteMenu(String userId, FavoriteMenu favoriteMenu) マイメニューを更新します。
void | AccountAccessor.insertFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を新規追加する。
void | AccountAccessor.updateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を更新する。

jp.co.intra_mart.foundation.security.mobile での FavoriteMenu の使用

FavoriteMenu 型のパラメータを持つ jp.co.intra_mart.foundation.security.mobile のメソッド
void | NonceResetListener4MobileEasyLogin.queryCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu)
void | NonceResetListener4MobileEasyLogin.queryUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu)
void | NonceResetListener4MobileEasyLogin.postCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu)
void | NonceResetListener4MobileEasyLogin.postUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener の使用

jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.account.StandardAccountBackup の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.account.StandardAccountBackup の使用

jp.co.intra_mart.foundation.security.account.StandardAccountBackup はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Account (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
クラス Account

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.account.Account
すべての実装インタフェース:
LocaleProvider, Serializable
public class Account
extends Object
implements LocaleProvider, Serializable

アカウントモデル。

このアカウントにが有効になる条件（ログインできる条件）は、
有効開始日 <= 日付 < 有効終了日の範囲でかつ、アカウントがライセンス登録してある場合です。
アカウントのライセンス登録については、ライセンスマネージャ( LicenseManager)を参照してください。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
AccountManager, 直列化された形式

コンストラクタの概要
Account(String userID)
コンストラクタ。
メソッドの概要
boolean | equals(Object account) オブジェクトを比較します。
String | getColorPatternId() カラーパターンIDを取得します。
String | getDescription() 説明を取得します。
String | getEncoding() エンコーディング情報を取得します。
Locale | getLocale() ロケールを取得します。
Date | getLockDate() アカウントロック日付を取得します。
int | getLoginFailureCount() ログイン失敗回数を取得します。
String | getMainPagePatternId() メインページパターンIDを取得します。
String | getMobilePassword() モバイル用パスワードを取得します。
String | getPassword() パスワードを取得します。
String | getUserId() ユーザIDを取得します。
Date | getValidEndDate() 有効終了日を取得します。
Date | getValidStartDate() 有効開始日取得。
int | hashCode() ハッシュコードを取得します。
void | increaseLoginFailureCount() ログイン失敗回数をカウントアップします。
boolean | isGoOut() 外出状態を取得します。
boolean | isLock() アカウントロック状態を取得します。
void | resetLock() アカウントロックをリセットします。
void | setColorPatternId(String colorPattrenId) カラーパターンIDを設定します。
void | setDescription(String description) 説明を設定します。
void | setEncoding(String encoding) エンコーディング情報を設定します。
void | setGoOut(boolean goOut) 外出状態を設定します。
void | setLocale(Locale locale) ロケールを設定します。
void | setLockDate(Date lockDate) アカウントロック日付を設定します。
void | setLoginFailureCount(int loginFailureCount) ログイン失敗回数を設定します。
void | setMainPagePatternId(String mainPagePatternId) メインページパターンIDを設定する。
void | setMobilePassword(String mobilePassword) モバイル用パスワードを設定します。
void | setPassword(String password) パスワードを設定します。
protected void | setUserId(String userId) ユーザIDを設定します。
void | setValidEndDate(Date endDate) 有効終了日を設定します。
void | setValidStartDate(Date startDate) 有効開始日を設定します。
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Account

public Account(String userID)
コンストラクタ。

パラメータ:
userID - ユーザID
メソッドの詳細

equals

public boolean equals(Object account)
オブジェクトを比較します。

指定されたオブジェクトとこのモデルが等しいかどうかを比較します。

パラメータ:
account - モデルと等しいかどうかを比較するオブジェクト
戻り値:
指定されたオブジェクトがこのモデルと等しい場合は true
関連項目:
Object.equals(Object)

getEncoding

public String getEncoding()
エンコーディング情報を取得します。

定義:
インタフェース LocaleProvider 内の getEncoding
戻り値:
エンコーディング情報
関連項目:
LocaleProvider.getEncoding()

getLocale

public Locale getLocale()
ロケールを取得します。

定義:
インタフェース LocaleProvider 内の getLocale
戻り値:
ロケール
関連項目:
LocaleProvider.getLocale()

getLockDate

public Date getLockDate()
アカウントロック日付を取得します。

戻り値:
ロックされている場合は、このアカウントがロックされた日付を返却します。
ロックされていない場合はnullを返却します。

getLoginFailureCount

public int getLoginFailureCount()
ログイン失敗回数を取得します。

このアカウントがログインに失敗している回数を返却します。

戻り値:
ログイン失敗回数

getMainPagePatternId

public String getMainPagePatternId()
メインページパターンIDを取得します。

戻り値:
メインページパターンID

getMobilePassword

public String getMobilePassword()
モバイル用パスワードを取得します。

戻り値:
モバイル用パスワード

getDescription

public String getDescription()
説明を取得します。

戻り値:
説明

getColorPatternId

public String getColorPatternId()
カラーパターンIDを取得します。

戻り値:
カラーパターンID

getPassword

public String getPassword()
パスワードを取得します。

戻り値:
パスワード

getUserId

public String getUserId()
ユーザIDを取得します。

戻り値:
ユーザID

getValidEndDate

public Date getValidEndDate()
有効終了日を取得します。

アカウントは有効終了日の前日まで有効となります。

戻り値:
有効終了日

getValidStartDate

public Date getValidStartDate()
有効開始日取得。

アカウントは有効開始日から有効となります。

戻り値:
有効開始日

hashCode

public int hashCode()
ハッシュコードを取得します。

戻り値:
ハッシュコード

increaseLoginFailureCount

public void increaseLoginFailureCount()
ログイン失敗回数をカウントアップします。

isGoOut

public boolean isGoOut()
外出状態を取得します。

戻り値:
外出している場合は、true

isLock

public boolean isLock()
アカウントロック状態を取得します。

戻り値:
ロックされている場合は、true

resetLock

public void resetLock()
アカウントロックをリセットします。

アカウントロックを解除し、ログイン失敗回数を０にリセットします。

setEncoding

public void setEncoding(String encoding)
エンコーディング情報を設定します。

パラメータ:
encoding - エンコーディング情報

setGoOut

public void setGoOut(boolean goOut)
外出状態を設定します。

パラメータ:
goOut - 外出している場合はtrue

setLocale

public void setLocale(Locale locale)
ロケールを設定します。

パラメータ:
locale - ロケール

setLockDate

public void setLockDate(Date lockDate)
アカウントロック日付を設定します。

パラメータ:
lockDate - 日付を設定した場合、アカウントはロックされる。 nullを設定した場合、アカウントのロックは解除される。

setLoginFailureCount

public void setLoginFailureCount(int loginFailureCount)
ログイン失敗回数を設定します。

設定できる値は0以上です。

パラメータ:
loginFailureCount - ログイン失敗回数

setMainPagePatternId

public void setMainPagePatternId(String mainPagePatternId)
メインページパターンIDを設定する。

パラメータ:
mainPagePatternId - メインページパターンID

setMobilePassword

public void setMobilePassword(String mobilePassword)
モバイル用パスワードを設定します。

パラメータ:
mobilePassword - モバイル用パスワード

setDescription

public void setDescription(String description)
説明を設定します。

パラメータ:
description - 説明

setColorPatternId

public void setColorPatternId(String colorPattrenId)
カラーパターンIDを設定します。

パラメータ:
colorPattrenId - カラーパターンID

setPassword

public void setPassword(String password)
パスワードを設定します。

パラメータ:
password - パスワード

setUserId

protected void setUserId(String userId)
ユーザIDを設定します。

パラメータ:
userId - ユーザID

setValidEndDate

public void setValidEndDate(Date endDate)
有効終了日を設定します。

設定されるのは、日付のみで、時間は00:00:00に設定されます。
有効になるのは設定された日付の前日までです。
nullを設定した場合は、最大未来日に設定されます。

パラメータ:
endDate - 有効終了日

setValidStartDate

public void setValidStartDate(Date startDate)
有効開始日を設定します。

設定されるのは、日付のみで、時間は00:00:00に設定されます。
有効になるのは設定された日付からです。
nullを設定した場合は、最大過去日に設定されます。

パラメータ:
startDate - 有効開始日
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccountAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
インタフェース AccountAccessor

既知の実装クラスの一覧:
StandardAccountAccessor
public interface AccountAccessor

アカウントアクセッサインタフェース。

アカウント情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | deleteAccount(String groupId, String userId) アカウント情報を削除する。
void | deleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報を削除する。
void | deleteAttribute(String groupId, String userId, String name) アカウント属性情報を削除する。
void | deleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を削除する。
Account | getAccount(String groupId, String userId) アカウント情報を取得する。
int | getAccountCount(String groupId) アカウント数を取得する。
AccountRole | getAccountRole(String groupId, String userId, String roleId) アカウントロール情報を取得する。
String[] | getAccountRoleIds(String groupId, String userId) アカウントロールIDをすべて取得する。
AccountRole[] | getAccountRoles(String groupId, String userId) アカウントロール情報をすべて取得する。
Account[] | getAccountsByUserIds(String groupId, String[] userIds) 指定されたユーザIDのアカウント情報をすべて取得する。
String | getAttribute(String groupId, String userId, String name) アカウント属性情報を取得する。
String[] | getAttributeNames(String groupId, String userId) アカウント属性情報の名前の一覧を取得する。
FavoriteMenu | getFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を取得する。
String[] | getFavoriteMenuIds(String groupId, String userId) マイメニューIDをすべて取得する。
FavoriteMenu[] | getFavoriteMenus(String groupId, String userId) マイメニュー情報をすべて取得する。
String[] | getUserIds(String groupId) ユーザIDの一覧を取得する。
String[] | getUserIdsByAccountRole(String groupId, String roleId) 引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
String[] | getUserIdsByAttribute(String groupId, String key, String value) アカウント属性情報の値と一致するユーザIDを取得する。
String[] | getUserIdsByRoles(String groupId, String[] roleIds, Date date) 指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
void | init(Map params) アカウントアクセッサの初期化。
void | insertAccount(String groupId, Account account) アカウント情報を新規追加する。
void | insertAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を新規追加する。
void | insertFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を新規追加する。
Account[] | searchAccounts(String groupId, String userId) アカウント情報の読み込みます。
void | setAttribute(String groupId, String userId, String name, String value) アカウント属性情報を設定する。
void | updateAccount(String groupId, Account account) アカウント情報を更新する。
void | updateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を更新する。
void | updateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を更新する。

メソッドの詳細

deleteAccount

public void deleteAccount(String groupId,
                          String userId)
                   throws AccessSecurityWriteException,
                          NotExistException
アカウント情報を削除する。

パラメータ:
groupId - ログイングループID
userId - 削除するユーザコード
例外:
AccessSecurityWriteException - アカウント情報の削除に失敗した場合スローされます。
NotExistException - 削除するアカウント情報が存在しない場合にスローされます。

deleteAccountRole

public void deleteAccountRole(String groupId,
                              String userId,
                              String roleId)
                       throws AccessSecurityWriteException,
                              NotExistException
アカウントロール情報を削除する。

アカウントに紐付くアカウントロール情報を削除します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
roleId - ロールID
例外:
AccessSecurityWriteException - アカウントロール情報の削除に失敗した場合スローされます。
NotExistException - 削除するアカウントロール情報が存在しない場合にスローされます。

deleteFavoriteMenu

public void deleteFavoriteMenu(String groupId,
                               String userId,
                               String menuId)
                        throws AccessSecurityWriteException,
                               NotExistException
マイメニュー情報を削除する。

アカウントに紐付くマイメニュー情報を削除します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
menuId - メニューID
例外:
AccessSecurityWriteException - マイメニュー情報の削除に失敗した場合スローされます。
NotExistException - 削除するマイメニュー情報が存在しない場合にスローされます。

getAccount

public Account getAccount(String groupId,
                          String userId)
                   throws AccessSecurityReadException
アカウント情報を取得する。

パラメータ:
groupId - ログイングループID
userId - ユーザIDの完全一致名
戻り値:
ユーザアカウントオブジェクト
存在しない場合は、nullを返却します。
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

getAccountsByUserIds

public Account[] getAccountsByUserIds(String groupId,
                                      String[] userIds)
                               throws AccessSecurityReadException
指定されたユーザIDのアカウント情報をすべて取得する。

パラメータ:
groupId - ログイングループID
userIds - ユーザIDの配列
戻り値:
ユーザアカウントオブジェクトの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

getAccountCount

public int getAccountCount(String groupId)
                    throws AccessSecurityReadException
アカウント数を取得する。

パラメータ:
groupId - ログイングループID
戻り値:
ユーザアカウント数
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

getAccountRole

public AccountRole getAccountRole(String groupId,
                                  String userId,
                                  String roleId)
                           throws AccessSecurityReadException
アカウントロール情報を取得する。

アカウントに紐付くアカウントロール情報を取得します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
roleId - ロールID
戻り値:
ユーザアカウントロール情報
存在しない場合は、nullを返却します。
例外:
AccessSecurityReadException - アカウントロール情報取得に失敗した場合スローされます。

getAccountRoleIds

public String[] getAccountRoleIds(String groupId,
                                  String userId)
                           throws AccessSecurityReadException
アカウントロールIDをすべて取得する。

アカウントに紐付くアカウントロールIDをすべて取得します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
ユーザアカウントロール情報の配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - アカウントロール情報取得に失敗した場合スローされます。

getAccountRoles

public AccountRole[] getAccountRoles(String groupId,
                                     String userId)
                              throws AccessSecurityReadException
アカウントロール情報をすべて取得する。

アカウントに紐付くアカウントロール情報をすべて取得します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
ユーザアカウントロール情報の配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - アカウントロール情報取得に失敗した場合スローされます。

getFavoriteMenu

public FavoriteMenu getFavoriteMenu(String groupId,
                                    String userId,
                                    String menuId)
                             throws AccessSecurityReadException
マイメニュー情報を取得する。

アカウントに紐付くマイメニュー情報を取得します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
menuId - メニューID
戻り値:
マイメニュー情報
存在しない場合は、nullを返却します。
例外:
AccessSecurityReadException - マイメニュー情報取得に失敗した場合スローされます。

getFavoriteMenuIds

public String[] getFavoriteMenuIds(String groupId,
                                   String userId)
                            throws AccessSecurityReadException
マイメニューIDをすべて取得する。

アカウントに紐付くマイメニューIDをすべて取得します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
マイメニュー情報の配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - マイメニュー情報取得に失敗した場合スローされます。

getFavoriteMenus

public FavoriteMenu[] getFavoriteMenus(String groupId,
                                       String userId)
                                throws AccessSecurityReadException
マイメニュー情報をすべて取得する。

アカウントに紐付くマイメニュー情報をすべて取得します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
マイメニュー情報の配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - マイメニュー情報取得に失敗した場合スローされます。

getUserIds

public String[] getUserIds(String groupId)
                    throws AccessSecurityReadException
ユーザIDの一覧を取得する。

パラメータ:
groupId - ログイングループID
戻り値:
ユーザIDの配列
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

getUserIdsByRoles

public String[] getUserIdsByRoles(String groupId,
                                  String[] roleIds,
                                  Date date)
                           throws AccessSecurityReadException
指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。

パラメータ:
groupId - ログイングループID
roleIds - 検証用ロールIDの一覧
date - 有効期間判定用の日付
戻り値:
有効なアカウントロールを持つアカウントのユーザIDの配列
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

init

public void init(Map params)
アカウントアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

insertAccount

public void insertAccount(String groupId,
                          Account account)
                   throws AccessSecurityWriteException,
                          DuplicateException
アカウント情報を新規追加する。

パラメータ:
groupId - ログイングループID
account - アカウント情報
例外:
AccessSecurityWriteException - アカウント情報の作成に失敗した場合スローされます。
DuplicateException - 追加するアカウント情報が既に存在した場合スローされます。

insertAccountRole

public void insertAccountRole(String groupId,
                              String userId,
                              AccountRole accountRole)
                       throws AccessSecurityWriteException,
                              DuplicateException
アカウントロール情報を新規追加する。

アカウントに紐付くアカウントロール情報を新規に追加します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
accountRole - アカウントロール情報
例外:
AccessSecurityWriteException - アカウントロール情報の作成に失敗した場合スローされます。
DuplicateException - 追加するアカウントロール情報が既に存在した場合スローされます。

insertFavoriteMenu

public void insertFavoriteMenu(String groupId,
                               String userId,
                               FavoriteMenu favoriteMenu)
                        throws AccessSecurityWriteException,
                               DuplicateException
マイメニュー情報を新規追加する。

アカウントに紐付くマイメニュー情報を新規に追加します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
favoriteMenu - マイメニュー情報
例外:
AccessSecurityWriteException - マイメニュー情報の作成に失敗した場合スローされます。
DuplicateException - 追加するマイメニュー情報が既に存在した場合スローされます。

searchAccounts

public Account[] searchAccounts(String groupId,
                                String userId)
                         throws AccessSecurityReadException
アカウント情報の読み込みます。 ユーザIDまたはユーザIDの一部をキーとして検索し、マッチしたアカウント情報を返します。
ただし、以下の文字列を特殊文字列として扱う。
* 0以上の長さの文字列とマッチ
? 1文字の文字列とマッチ

パラメータ:
groupId - ログイングループID
userId - ユーザID（検索キー）
戻り値:
アカウント情報配列
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

updateAccount

public void updateAccount(String groupId,
                          Account account)
                   throws AccessSecurityWriteException,
                          NotExistException
アカウント情報を更新する。

パラメータ:
groupId - ログイングループID
account - アカウント情報
例外:
AccessSecurityWriteException - アカウント情報の更新に失敗した場合スローされます。
NotExistException - 更新するアカウント情報が存在しない場合にスローされます。

updateAccountRole

public void updateAccountRole(String groupId,
                              String userId,
                              AccountRole accountRole)
                       throws AccessSecurityWriteException,
                              NotExistException
アカウントロール情報を更新する。

アカウントに紐付くアカウントロール情報を更新します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
accountRole - アカウントロール情報
例外:
AccessSecurityWriteException - アカウントロール情報の更新に失敗した場合スローされます。
NotExistException - 更新するアカウントロール情報が存在しない場合にスローされます。

updateFavoriteMenu

public void updateFavoriteMenu(String groupId,
                               String userId,
                               FavoriteMenu favoriteMenu)
                        throws AccessSecurityWriteException,
                               NotExistException
マイメニュー情報を更新する。

アカウントに紐付くマイメニュー情報を更新します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
favoriteMenu - マイメニュー情報
例外:
AccessSecurityWriteException - マイメニュー情報の更新に失敗した場合スローされます。
NotExistException - 更新するマイメニュー情報が存在しない場合にスローされます。

getUserIdsByAccountRole

public String[] getUserIdsByAccountRole(String groupId,
                                        String roleId)
                                 throws AccessSecurityReadException
引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。 引数で指定したアカウントロールを持つアカウントのユーザIDの一覧を返却します。
指定したアカウントロールの階層のチェックはお行いません。

パラメータ:
groupId - ログイングループID
roleId - String アカウントロールのロールID
戻り値:
ユーザIDの配列（データがない場合は空の配列を返します）
例外:
AccessSecurityReadException - アカウント情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getAttribute

public String getAttribute(String groupId,
                           String userId,
                           String name)
                    throws AccessSecurityReadException
アカウント属性情報を取得する。

パラメータ:
groupId - ログイングループID
userId - ユーザID
name - 属性名
戻り値:
アカウント属性値
存在しない場合は、nullを返却します。
例外:
AccessSecurityReadException - アカウント属性情報の取得に失敗した場合スローされます。

getAttributeNames

public String[] getAttributeNames(String groupId,
                                  String userId)
                           throws AccessSecurityReadException
アカウント属性情報の名前の一覧を取得する。

パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
アカウント属性の名前の一覧
存在しない場合は空の配列を返却します。
例外:
AccessSecurityReadException - アカウント属性情報の取得に失敗した場合スローされます。

getUserIdsByAttribute

public String[] getUserIdsByAttribute(String groupId,
                                      String key,
                                      String value)
                               throws AccessSecurityReadException
アカウント属性情報の値と一致するユーザIDを取得する。

パラメータ:
groupId - ログイングループID
key - 検索対象の属性キー名
value - 検索値
戻り値:
ユーザIDの一覧
存在しない場合は空の配列を返却します。
例外:
AccessSecurityReadException - アカウント属性情報の取得に失敗した場合スローされます。

setAttribute

public void setAttribute(String groupId,
                         String userId,
                         String name,
                         String value)
                  throws AccessSecurityWriteException
アカウント属性情報を設定する。
引数で指定した属性名に一致する属性情報が存在しない場合は、新規登録します。
引数で指定した属性名に一致する属性情報がすでに存在する場合は、指定された属性値で更新します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
name - 属性名
value - 属性値
例外:
AccessSecurityWriteException - アカウント情報の設定に失敗した場合スローされます。

deleteAttribute

public void deleteAttribute(String groupId,
                            String userId,
                            String name)
                     throws AccessSecurityWriteException,
                            NotExistException
アカウント属性情報を削除する。

パラメータ:
groupId - ログイングループID
userId - ユーザID
name - 属性名
例外:
AccessSecurityWriteException - アカウント属性情報の削除に失敗した場合スローされます。
NotExistException - 削除するアカウント情報が存在しない場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccountChangedListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
インタフェース AccountChangedListener

既知の実装クラスの一覧:
PasswordHistoryAccountChangedListener
public interface AccountChangedListener

アカウント情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
AccountManager

メソッドの概要
void | accountAdded(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | accountDeleted(String groupId, String userId) アカウント情報をデータストアから削除した直後にコールされます。
void | accountRoleAdded(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | accountRoleDeleted(String groupId, String userId, String roleId) アカウントロール情報をデータストアから削除した直後にコールされます。
void | accountRoleUpdated(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新した直後にコールされます。
void | accountUpdated(String groupId, Account account) アカウント情報をデータストアに更新した直後にコールされます。
void | init(Map params) アカウントリスナーの初期化。

メソッドの詳細

init

public void init(Map params)
アカウントリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

accountAdded

public void accountAdded(String groupId,
                         Account account)
                  throws ChangedListenerException
アカウント情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
account - 作成されたアカウント情報
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

accountDeleted

public void accountDeleted(String groupId,
                           String userId)
                    throws ChangedListenerException
アカウント情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 削除されたユーザID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

accountUpdated

public void accountUpdated(String groupId,
                           Account account)
                    throws ChangedListenerException
アカウント情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
account - 更新されたアカウント情報
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

accountRoleAdded

public void accountRoleAdded(String groupId,
                             String userId,
                             AccountRole accountRole)
                      throws ChangedListenerException
アカウントロール情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 作成されたアカウントロール情報
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

accountRoleDeleted

public void accountRoleDeleted(String groupId,
                               String userId,
                               String roleId)
                        throws ChangedListenerException
アカウントロール情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
roleId - 削除されたロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

accountRoleUpdated

public void accountRoleUpdated(String groupId,
                               String userId,
                               AccountRole accountRole)
                        throws ChangedListenerException
アカウントロール情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 更新されたアカウントロール情報
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountExporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
インタフェース AccountExporter

既知の実装クラスの一覧:
CsvAccountBackup, StandardAccountBackup
public interface AccountExporter

アカウントエクスポートインタフェースです。

バージョン:
1.0

メソッドの概要
void | doExport(AccountManager manager, OutputStream outputStream) エクスポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doExport

public void doExport(AccountManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

アカウント情報をバックアップファイルに出力します。

パラメータ:
manager - アカウントマネージャ
outputStream - 出力ストリーム
例外:
AccessSecurityExportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountImporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
インタフェース AccountImporter

既知の実装クラスの一覧:
CsvAccountBackup, StandardAccountBackup
public interface AccountImporter

アカウントインポートインタフェースです。

バージョン:
1.0

メソッドの概要
void | doImport(InputStream inputStream, AccountManager manager) インポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doImport

public void doImport(InputStream inputStream,
                     AccountManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からアカウント情報を取得し、生成します。

パラメータ:
manager - アカウントマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
クラス AccountManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.account.AccountManager
public final class AccountManager
extends Object

アカウントマネージャクラス。
アカウント情報の操作を行います。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
Account

フィールドの概要
static String | ACCOUNT_ROLE_PERMISSION_SELECTOR パーミッションセレクタ: ユーザが保有するすべてのロール取得用ID。
static String | ATTR_MENU_DISPLAY ユーザ属性名: ログイン時のメニュー表示・非表示用。
static String | ATTR_MENU_FOLDER_DISPLAY_METHOD ユーザ属性名: メニューフォルダの表示方法。
static String | ATTR_MOBILE_EASY_LOGIN ユーザ属性名: かんたんログイン用。
static String | ATTR_MOBILE_EASY_LOGIN_NONCE ユーザ属性名: かんたんログインのアクセスキー生成時に必要なNonce用。
static String | ATTR_MY_MENU_POSITION ユーザ属性名: マイメニュー表示位置用。
static String | ATTR_REPORT_LIMIT_DAYS ユーザ属性名: パスワード期限切れ通知用。
static String | CRYPTION_CATEGORY_MOBILE_USER_AGENT 暗号化アルゴリズムカテゴリ: モバイル端末個体識別番号用。
コンストラクタの概要
AccountManager(String groupId)
コンストラクタ。
メソッドの概要
void | addAccount(Account account) アカウントを新規追加します。
void | addAccountRole(String userId, AccountRole accountRole) アカウントロールを新規追加します。
void | addFavoriteMenu(String userId, FavoriteMenu favoriteMenu) マイメニューを新規追加します。
static void | clearInstance() アカウントマネージャのインスタンスを初期化します。
boolean | contains(String userId) アカウントの存在チェックを行います。
int | count() アカウントの登録数を取得します。
void | deleteAccount(String userId) アカウントを削除します。
void | deleteAccountRole(String userId, String roleId) アカウントロールを削除します。
void | deleteAccountRoles(String userId) アカウントロールをすべて削除します。
void | deleteAccounts() アカウントをすべて削除します。
void | deleteAttribute(String userId, String name) アカウント属性情報を削除する。
void | deleteFavoriteMenu(String userId, String menuId) マイメニューを削除します。
void | deleteFavoriteMenus(String userId) マイメニューをすべて削除します。
void | exportData(String category, OutputStream outputStream) アカウント情報をエクスポートします。
Account | getAccount(String userId) ユーザIDにマッチしたユーザデータを１件取得します。
String[] | getAccountRoleIds(String userId) アカウントロールIDをすべて取得します。
AccountRole[] | getAccountRoles(String userId) アカウントロールをすべて取得します。
AccountRole[] | getAccountRoles(String userId, Date date) 有効期間内のアカウントロールをすべて取得します。
Account[] | getAccounts() ログイングループ内のすべてのユーザアカウントを取得します。
Account[] | getAccountsByUserIds(String[] userIds) ログイングループ内で引数指定したユーザIDのユーザアカウントをすべて取得します。
String | getAttribute(String userId, String name) アカウント属性情報を取得する。
String | getAttribute(String userId, String name, String def) アカウント属性情報を取得する。
String[] | getAttributeNames(String userId) アカウント属性名の一覧を取得する。
String[] | getExportCategories() アカウントエクスポート用のカテゴリの一覧を取得します。
String[] | getFavoriteMenuIds(String userId) マイメニューIDをすべて取得します。
FavoriteMenu[] | getFavoriteMenus(String userId) マイメニューをすべて取得します。
String[] | getImportCategories() アカウントインポート用のカテゴリの一覧を取得します。
String | getLoginGroupId() ログイングループIDを取得します。
String[] | getRoleIds(String userId, Date date) アカウントに紐付く有効なロールIDをすべて取得します。
String[] | getUserIds() すべてのユーザIDを取得します。
String[] | getUserIdsByAccountRole(String roleId) 引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
String[] | getUserIdsByAttribute(String key, String value) アカウント属性情報の値と一致するユーザIDを取得します。
String[] | getUserIdsByRole(String roleId, Date date) 有効なロールIDを持つすべてのユーザIDを取得します。
void | importData(String category, InputStream inputStream) アカウント情報をインポートします。
boolean | isUpdate(Date date) アカウント情報が指定された日付よりも新しいかチェックします。
Account[] | searchAccounts(String userId) ユーザIDを検索してマッチしたアカウントを配列で返します。
void | setAttribute(String userId, String name, String value) アカウント属性情報を設定する。
void | updateAccount(Account account) アカウントを更新します。
void | updateAccountRole(String userId, AccountRole accountRole) アカウントロールを更新します。
void | updateFavoriteMenu(String userId, FavoriteMenu favoriteMenu) マイメニューを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ATTR_REPORT_LIMIT_DAYS

public static final String ATTR_REPORT_LIMIT_DAYS
ユーザ属性名: パスワード期限切れ通知用。

関連項目:
定数フィールド値

ATTR_MENU_DISPLAY

public static final String ATTR_MENU_DISPLAY
ユーザ属性名: ログイン時のメニュー表示・非表示用。

関連項目:
定数フィールド値

ATTR_MENU_FOLDER_DISPLAY_METHOD

public static final String ATTR_MENU_FOLDER_DISPLAY_METHOD
ユーザ属性名: メニューフォルダの表示方法。

関連項目:
定数フィールド値

ATTR_MY_MENU_POSITION

public static final String ATTR_MY_MENU_POSITION
ユーザ属性名: マイメニュー表示位置用。

関連項目:
定数フィールド値

ATTR_MOBILE_EASY_LOGIN

public static final String ATTR_MOBILE_EASY_LOGIN
ユーザ属性名: かんたんログイン用。

関連項目:
定数フィールド値

ACCOUNT_ROLE_PERMISSION_SELECTOR

public static final String ACCOUNT_ROLE_PERMISSION_SELECTOR
パーミッションセレクタ: ユーザが保有するすべてのロール取得用ID。

関連項目:
定数フィールド値

ATTR_MOBILE_EASY_LOGIN_NONCE

public static final String ATTR_MOBILE_EASY_LOGIN_NONCE
ユーザ属性名: かんたんログインのアクセスキー生成時に必要なNonce用。

導入されたバージョン:
6.1.11
関連項目:
定数フィールド値

CRYPTION_CATEGORY_MOBILE_USER_AGENT

public static final String CRYPTION_CATEGORY_MOBILE_USER_AGENT
暗号化アルゴリズムカテゴリ: モバイル端末個体識別番号用。

導入されたバージョン:
6.1.11
関連項目:
AccessSecurityManager.encrypt(String, String), AccessSecurityManager.decrypt(String, String), 定数フィールド値
コンストラクタの詳細

AccountManager

public AccountManager(String groupId)
               throws AccessSecurityException
コンストラクタ。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityException - ログイングループIDが不正な場合にスローされます。
メソッドの詳細

clearInstance

public static void clearInstance()
アカウントマネージャのインスタンスを初期化します。

アクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。
通常、このメソッドを使用する必要はありません。

addAccount

public void addAccount(Account account)
                throws AccessSecurityException
アカウントを新規追加します。

パラメータ:
account - アカウント情報
例外:
AccessSecurityException - アカウント情報の作成に失敗した場合、または引数が不正な場合にスローされます。

addAccountRole

public void addAccountRole(String userId,
                           AccountRole accountRole)
                    throws AccessSecurityException
アカウントロールを新規追加します。

アカウントに紐付くアカウントロールを新規追加します。

パラメータ:
userId - 対象ユーザID
accountRole - アカウントロール情報
例外:
AccessSecurityException - アカウントロール情報の作成に失敗した場合、または引数が不正な場合にスローされます。

addFavoriteMenu

public void addFavoriteMenu(String userId,
                            FavoriteMenu favoriteMenu)
                     throws AccessSecurityException
マイメニューを新規追加します。

アカウントに紐付くマイメニューを新規追加します。

パラメータ:
userId - 対象ユーザID
favoriteMenu - マイメニュー情報
例外:
AccessSecurityException - マイメニュー情報の作成に失敗した場合、または引数が不正な場合にスローされます。

contains

public boolean contains(String userId)
                 throws AccessSecurityException
アカウントの存在チェックを行います。

パラメータ:
userId - ユーザID
戻り値:
true:存在する false:存在しない
例外:
AccessSecurityException - アカウント情報の取得に失敗した場合、または引数が不正な場合にスローされます。

count

public int count()
          throws AccessSecurityException
アカウントの登録数を取得します。

戻り値:
アカウント登録数
例外:
AccessSecurityException - アカウント情報の取得に失敗した場合に、スローされます。

deleteAccount

public void deleteAccount(String userId)
                   throws AccessSecurityException
アカウントを削除します。

パラメータ:
userId - ユーザID
例外:
AccessSecurityException - アカウント情報の削除に失敗した場合、または引数が不正な場合にスローされます。

deleteAccountRole

public void deleteAccountRole(String userId,
                              String roleId)
                       throws AccessSecurityException
アカウントロールを削除します。

アカウントに紐付くアカウントロールを削除します。

パラメータ:
userId - 対象ユーザID
roleId - ロールID
例外:
AccessSecurityException - アカウントロール情報の削除に失敗した場合、または引数が不正な場合にスローされます。

deleteAccountRoles

public void deleteAccountRoles(String userId)
                        throws AccessSecurityException
アカウントロールをすべて削除します。

アカウントに紐付くアカウントロールをすべて削除します。

パラメータ:
userId - 対象ユーザID
例外:
AccessSecurityException - アカウントロール情報の削除に失敗した場合、または引数が不正な場合にスローされます。

deleteAccounts

public void deleteAccounts()
                    throws AccessSecurityException
アカウントをすべて削除します。

例外:
AccessSecurityException - アカウントの削除に失敗した場合にスローされます。

deleteFavoriteMenu

public void deleteFavoriteMenu(String userId,
                               String menuId)
                        throws AccessSecurityException
マイメニューを削除します。

アカウントに紐付くマイメニューを削除します。

パラメータ:
userId - 対象ユーザID
menuId - メニューID
例外:
AccessSecurityException - マイメニュー情報の削除に失敗した場合、または引数が不正な場合にスローされます。

deleteFavoriteMenus

public void deleteFavoriteMenus(String userId)
                         throws AccessSecurityException
マイメニューをすべて削除します。

アカウントに紐付くマイメニューをすべて削除します。

パラメータ:
userId - 対象ユーザID
例外:
AccessSecurityException - マイメニュー情報の削除に失敗した場合、または引数が不正な場合にスローされます。

exportData

public void exportData(String category,
                       OutputStream outputStream)
                throws AccessSecurityException
アカウント情報をエクスポートします。

パラメータ:
category - カテゴリ
outputStream - 出力ストリーム
例外:
AccessSecurityException - エクスポートに失敗した場合、または引数が不正な場合にスローされます。

getAccount

public Account getAccount(String userId)
                   throws AccessSecurityException
ユーザIDにマッチしたユーザデータを１件取得します。
※一度、取得したデータはキャッシュに保管します。

パラメータ:
userId -
戻り値:
ユーザデータ
例外:
AccessSecurityException - アカウントの取得に失敗した場合、または引数が不正な場合にスローされます。

getAccountRoleIds

public String[] getAccountRoleIds(String userId)
                           throws AccessSecurityException
アカウントロールIDをすべて取得します。

アカウントに紐付くアカウントロールIDをすべて取得します。

パラメータ:
userId - 対象ユーザID
戻り値:
アカウントロールIDの配列
データがない場合は空の配列を返します。
例外:
AccessSecurityException - アカウントロール情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getAccountRoles

public AccountRole[] getAccountRoles(String userId)
                              throws AccessSecurityException
アカウントロールをすべて取得します。

アカウントに紐付くアカウントロールをすべて取得します。

パラメータ:
userId - 対象ユーザID
戻り値:
アカウントロール情報の配列
データがない場合は空の配列を返します。
例外:
AccessSecurityException - アカウントロール情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getAccountRoles

public AccountRole[] getAccountRoles(String userId,
                                     Date date)
                              throws AccessSecurityException
有効期間内のアカウントロールをすべて取得します。

指定日付でアカウントに紐付く有効なアカウントロールをすべて取得します。

パラメータ:
userId - 対象ユーザID
date - 有効期間判定用の日付
戻り値:
アカウントロール情報の配列
データがない場合は空の配列を返します。
例外:
AccessSecurityException - アカウントロール情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getAccounts

public Account[] getAccounts()
                      throws AccessSecurityException
ログイングループ内のすべてのユーザアカウントを取得します。

戻り値:
アカウント情報の配列（データがない場合は空の配列を返します。）
例外:
AccessSecurityException - アカウント情報の取得に失敗した場合にスローされます。

getAccountsByUserIds

public Account[] getAccountsByUserIds(String[] userIds)
                               throws AccessSecurityException
ログイングループ内で引数指定したユーザIDのユーザアカウントをすべて取得します。

パラメータ:
userIds - ユーザIDの配列
戻り値:
アカウント情報の配列（データがない場合は空の配列を返します。）
例外:
AccessSecurityException - アカウント情報の取得に失敗した場合にスローされます。

getExportCategories

public String[] getExportCategories()
                             throws AccessSecurityException
アカウントエクスポート用のカテゴリの一覧を取得します。

戻り値:
アカウントエクスポート用カテゴリの一覧
例外:
AccessSecurityException - アカウントエクスポート用のカテゴリの取得に失敗した場合にスローされます。

getFavoriteMenuIds

public String[] getFavoriteMenuIds(String userId)
                            throws AccessSecurityException
マイメニューIDをすべて取得します。

アカウントに紐付くマイメニューIDをすべて取得します。

パラメータ:
userId - 対象ユーザID
戻り値:
マイメニューIDの配列
データがない場合は空の配列を返します。
例外:
AccessSecurityException - マイメニュー情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getFavoriteMenus

public FavoriteMenu[] getFavoriteMenus(String userId)
                                throws AccessSecurityException
マイメニューをすべて取得します。

アカウントに紐付くマイメニューをすべて取得します。

パラメータ:
userId - 対象ユーザID
戻り値:
マイメニュー情報の配列
データがない場合は空の配列を返します。
例外:
AccessSecurityException - マイメニュー情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getImportCategories

public String[] getImportCategories()
                             throws AccessSecurityException
アカウントインポート用のカテゴリの一覧を取得します。

戻り値:
アカウントインポート用カテゴリの一覧
例外:
AccessSecurityException - アカウントインポート用のカテゴリの取得に失敗した場合にスローされます。

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

戻り値:
ログイングループID

getRoleIds

public String[] getRoleIds(String userId,
                           Date date)
                    throws AccessSecurityException
アカウントに紐付く有効なロールIDをすべて取得します。

指定日付でアカウントに紐付く有効なアカウントロールをすべて取得し、
有効なアカウントロールが持つすべてのサブロールを取得して、ロールIDの一覧を返却します。

パラメータ:
userId - 対象ユーザID
date - 有効期間判定用の日付
戻り値:
ロールIDの配列
該当するロールがない場合は空の配列を返します。
例外:
AccessSecurityException - ロール情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getUserIds

public String[] getUserIds()
                    throws AccessSecurityException
すべてのユーザIDを取得します。

戻り値:
ユーザIDの配列（データがない場合は空の配列を返します）
例外:
AccessSecurityException - ユーザIDの取得に失敗した場合にスローされます。

getUserIdsByAccountRole

public String[] getUserIdsByAccountRole(String roleId)
                                 throws AccessSecurityException
引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。 引数で指定したアカウントロールを持つアカウントのユーザIDの一覧を返却します。
指定したアカウントロールの階層のチェックはお行いません。

パラメータ:
roleId - String アカウントロールのロールID
戻り値:
ユーザIDの配列（データがない場合は空の配列を返します）
例外:
AccessSecurityException - アカウント情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getUserIdsByRole

public String[] getUserIdsByRole(String roleId,
                                 Date date)
                          throws AccessSecurityException
有効なロールIDを持つすべてのユーザIDを取得します。

指定したロールIDからすべての親ロールを取得し、
指定日付で有効なアカウントロールを持つアカウントのユーザIDの一覧を返却します。

パラメータ:
roleId - ロールID
date - 有効期間判定用の日付
戻り値:
ユーザIDの配列
該当するユーザがない場合は空の配列を返します。
例外:
AccessSecurityException - アカウント情報の取得に失敗した場合、または引数が不正な場合にスローされます。

importData

public void importData(String category,
                       InputStream inputStream)
                throws AccessSecurityException
アカウント情報をインポートします。

パラメータ:
category - カテゴリ
inputStream - 入力ストリーム
例外:
AccessSecurityException - インポートに失敗した場合、または引数が不正な場合にスローされます。

searchAccounts

public Account[] searchAccounts(String userId)
                         throws AccessSecurityException
ユーザIDを検索してマッチしたアカウントを配列で返します。
ユーザIDまたはユーザIDの一部をキーとして検索し、マッチしたアカウント情報を返します。
ただし、以下の文字列を特殊文字列として扱います。
* 0以上の長さの文字列とマッチ
? 1文字の文字列とマッチ

パラメータ:
userId - 検索キー
戻り値:
ユーザアカウント配列
データがない場合は空の配列を返します。
例外:
AccessSecurityException - アカウントの取得に失敗した場合、または引数が不正な場合にスローされます。

updateAccount

public void updateAccount(Account account)
                   throws AccessSecurityException
アカウントを更新します。

パラメータ:
account - アカウント情報
例外:
AccessSecurityException - アカウントの更新に失敗した場合、または引数が不正な場合にスローされます。

updateAccountRole

public void updateAccountRole(String userId,
                              AccountRole accountRole)
                       throws AccessSecurityException
アカウントロールを更新します。

アカウントに紐付くアカウントロールを更新します。

パラメータ:
userId - 対象ユーザID
accountRole - アカウントロール情報
例外:
AccessSecurityException - アカウントロール情報の更新に失敗した場合、または引数が不正な場合にスローされます。

updateFavoriteMenu

public void updateFavoriteMenu(String userId,
                               FavoriteMenu favoriteMenu)
                        throws AccessSecurityException
マイメニューを更新します。

アカウントに紐付くマイメニューを更新します。

パラメータ:
userId - 対象ユーザID
favoriteMenu - マイメニュー情報
例外:
AccessSecurityException - マイメニュー情報の更新に失敗した場合、または引数が不正な場合にスローされます。

getAttribute

public String getAttribute(String userId,
                           String name)
                    throws AccessSecurityException
アカウント属性情報を取得する。

パラメータ:
userId - ユーザID
name - 属性名
戻り値:
アカウント属性値
存在しない場合は、nullを返却します。
例外:
AccessSecurityException - アカウント属性情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getAttribute

public String getAttribute(String userId,
                           String name,
                           String def)
                    throws AccessSecurityException
アカウント属性情報を取得する。

パラメータ:
userId - ユーザID
name - 属性名
def - デフォルト値
戻り値:
アカウント属性値
存在しない場合は、引数で指定されたデフォルト値を返却します。
例外:
AccessSecurityException - アカウント属性情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getAttributeNames

public String[] getAttributeNames(String userId)
                           throws AccessSecurityException
アカウント属性名の一覧を取得する。

パラメータ:
userId - ユーザID
戻り値:
アカウント属性の名前の一覧
存在しない場合は空の配列を返却します。
例外:
AccessSecurityException - アカウント属性情報の取得に失敗した場合、または引数が不正な場合にスローされます。

setAttribute

public void setAttribute(String userId,
                         String name,
                         String value)
                  throws AccessSecurityException
アカウント属性情報を設定する。
引数で指定した属性名に一致する属性情報が存在しない場合は、新規に登録します。
引数で指定した属性名に一致する属性情報がすでに存在する場合は、指定された属性値で更新します。

パラメータ:
userId - ユーザID
name - 属性名
value - 属性値
例外:
AccessSecurityException - アカウント情報の設定に失敗した場合、または引数が不正な場合にスローされます。

deleteAttribute

public void deleteAttribute(String userId,
                            String name)
                     throws AccessSecurityException
アカウント属性情報を削除する。

パラメータ:
userId - ユーザID
name - 属性名
例外:
AccessSecurityException - アカウント属性情報の削除に失敗した場合、または引数が不正な場合にスローされます。

getUserIdsByAttribute

public String[] getUserIdsByAttribute(String key,
                                      String value)
                               throws AccessSecurityException
アカウント属性情報の値と一致するユーザIDを取得します。

検索対象の属性キーの値が検索値と等しいユーザIDの一覧を取得します。

パラメータ:
key - 検索対象の属性キー名
value - 検索値
戻り値:
ユーザIDの一覧
存在しない場合は空の配列を返却します。
例外:
AccessSecurityException - アカウント属性情報の取得に失敗した場合スローされます。

isUpdate

public boolean isUpdate(Date date)
                 throws AccessSecurityException
アカウント情報が指定された日付よりも新しいかチェックします。

パラメータ:
date - チェック日付
例外:
AccessSecurityReadException - 更新チェックに失敗した場合スローされます。
AccessSecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountPostWriterListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
インタフェース AccountPostWriterListener

既知の実装クラスの一覧:
NonceResetListener4MobileEasyLogin
public interface AccountPostWriterListener

アカウント情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
AccountManager

メソッドの概要
void | init(Map params) アカウントリスナーの初期化。
void | postCreateAccount(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | postCreateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | postCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに作成した直後にコールされます。
void | postDeleteAccount(String groupId, String userId) アカウント情報をデータストアから削除した直後にコールされます。
void | postDeleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報をデータストアから削除した直後にコールされます。
void | postDeleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報をデータストアから削除した直後にコールされます。
void | postUpdateAccount(String groupId, Account account) アカウント情報をデータストアに更新した直後にコールされます。
void | postUpdateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新した直後にコールされます。
void | postUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
アカウントリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreateAccount

public void postCreateAccount(String groupId,
                              Account account)
                       throws AccessSecurityListenerExcpetion
アカウント情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
account - 作成されたアカウント情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteAccount

public void postDeleteAccount(String groupId,
                              String userId)
                       throws AccessSecurityListenerExcpetion
アカウント情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 削除されたユーザID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateAccount

public void postUpdateAccount(String groupId,
                              Account account)
                       throws AccessSecurityListenerExcpetion
アカウント情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
account - 更新されたアカウント情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postCreateAccountRole

public void postCreateAccountRole(String groupId,
                                  String userId,
                                  AccountRole accountRole)
                           throws AccessSecurityListenerExcpetion
アカウントロール情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 作成されたアカウントロール情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteAccountRole

public void postDeleteAccountRole(String groupId,
                                  String userId,
                                  String roleId)
                           throws AccessSecurityListenerExcpetion
アカウントロール情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
roleId - 削除されたロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateAccountRole

public void postUpdateAccountRole(String groupId,
                                  String userId,
                                  AccountRole accountRole)
                           throws AccessSecurityListenerExcpetion
アカウントロール情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 更新されたアカウントロール情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postCreateFavoriteMenu

public void postCreateFavoriteMenu(String groupId,
                                   String userId,
                                   FavoriteMenu favoriteMenu)
                            throws AccessSecurityListenerExcpetion
マイメニュー情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
favoriteMenu - 作成されたマイメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteFavoriteMenu

public void postDeleteFavoriteMenu(String groupId,
                                   String userId,
                                   String menuId)
                            throws AccessSecurityListenerExcpetion
マイメニュー情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
menuId - 削除されたマイメニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateFavoriteMenu

public void postUpdateFavoriteMenu(String groupId,
                                   String userId,
                                   FavoriteMenu favoriteMenu)
                            throws AccessSecurityListenerExcpetion
マイメニュー情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
favoriteMenu - 更新されたマイメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountQueryWriterListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
インタフェース AccountQueryWriterListener

既知の実装クラスの一覧:
NonceResetListener4MobileEasyLogin
public interface AccountQueryWriterListener

アカウント情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
AccountManager

メソッドの概要
void | init(Map params) アカウントリスナーの初期化。
void | queryCreateAccount(String groupId, Account account) アカウント情報をデータストアに作成する直前にコールされます。
void | queryCreateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | queryCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに作成する直前にコールされます。
void | queryDeleteAccount(String groupId, String userId) アカウント情報をデータストアから削除する直前にコールされます。
void | queryDeleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報をデータストアから削除する直前にコールされます。
void | queryDeleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報をデータストアから削除する直前にコールされます。
void | queryUpdateAccount(String groupId, Account account) アカウント情報をデータストアに更新する直前にコールされます。
void | queryUpdateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新する直前にコールされます。
void | queryUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
アカウントリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreateAccount

public void queryCreateAccount(String groupId,
                               Account account)
                        throws AccessSecurityListenerExcpetion
アカウント情報をデータストアに作成する直前にコールされます。

パラメータ:
groupId - ログイングループID
account - 作成されるアカウント情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteAccount

public void queryDeleteAccount(String groupId,
                               String userId)
                        throws AccessSecurityListenerExcpetion
アカウント情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
userId - 削除されるユーザコード
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdateAccount

public void queryUpdateAccount(String groupId,
                               Account account)
                        throws AccessSecurityListenerExcpetion
アカウント情報をデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
account - 更新されるアカウント情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryCreateAccountRole

public void queryCreateAccountRole(String groupId,
                                   String userId,
                                   AccountRole accountRole)
                            throws AccessSecurityListenerExcpetion
アカウントロール情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 作成されるアカウントロール情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteAccountRole

public void queryDeleteAccountRole(String groupId,
                                   String userId,
                                   String roleId)
                            throws AccessSecurityListenerExcpetion
アカウントロール情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
roleId - 削除されるロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdateAccountRole

public void queryUpdateAccountRole(String groupId,
                                   String userId,
                                   AccountRole accountRole)
                            throws AccessSecurityListenerExcpetion
アカウントロール情報をデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 更新されるアカウントロール情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryCreateFavoriteMenu

public void queryCreateFavoriteMenu(String groupId,
                                    String userId,
                                    FavoriteMenu favoriteMenu)
                             throws AccessSecurityListenerExcpetion
マイメニュー情報をデータストアに作成する直前にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
favoriteMenu - 作成されるマイメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteFavoriteMenu

public void queryDeleteFavoriteMenu(String groupId,
                                    String userId,
                                    String menuId)
                             throws AccessSecurityListenerExcpetion
マイメニュー情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
menuId - 削除されるマイメニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdateFavoriteMenu

public void queryUpdateFavoriteMenu(String groupId,
                                    String userId,
                                    FavoriteMenu favoriteMenu)
                             throws AccessSecurityListenerExcpetion
マイメニュー情報をデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
favoriteMenu - 更新されるマイメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountReaderDecorator (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
インタフェース AccountReaderDecorator

public interface AccountReaderDecorator

アカウント情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
Account | doDecoration(String groupId, Account account) アカウントをデータストアからの読み込み直後にコールされます。
void | init(Map params) アカウントデコレータの初期化。

メソッドの詳細

init

public void init(Map params)
アカウントデコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public Account doDecoration(String groupId,
                            Account account)
アカウントをデータストアからの読み込み直後にコールされます。

パラメータ:
groupId - ログイングループID
account - 読み込みが行われたアカウント情報
戻り値:
拡張されたアカウント情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccountRole (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
クラス AccountRole

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.account.AccountRole
すべての実装インタフェース:
Serializable
public class AccountRole
extends Object
implements Serializable

アカウント用ロールモデル。

アカウントに対してこのロールが有効になる範囲は、有効開始日 <= 日付 < 有効終了日の範囲です。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
AccountRole(String roleId)
コンストラクタ。
メソッドの概要
String | getRoleId() ロールIDを取得します。
Date | getRoleValidEndDate() ロール有効終了日を取得します。
Date | getRoleValidStartDate() ロール有効開始日を取得します。
protected void | setRoleId(String roleId) ロールIDを設定します。
void | setRoleValidEndDate(Date roleValidEndDate) ロール有効終了日を設定します。
void | setRoleValidStartDate(Date roleValidStartDate) ロール有効開始日を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AccountRole

public AccountRole(String roleId)
コンストラクタ。

パラメータ:
roleId - ロールID
メソッドの詳細

getRoleId

public String getRoleId()
ロールIDを取得します。

戻り値:
ロールID

getRoleValidEndDate

public Date getRoleValidEndDate()
ロール有効終了日を取得します。

戻り値:
ロール有効終了日
設定されていない場合は、日付の最大過去日を返却します。

getRoleValidStartDate

public Date getRoleValidStartDate()
ロール有効開始日を取得します。

戻り値:
ロール有効開始日
設定されていない場合は、日付の最大未来日を返却します。

setRoleId

protected void setRoleId(String roleId)
ロールIDを設定します。

パラメータ:
roleId - ロールID

setRoleValidEndDate

public void setRoleValidEndDate(Date roleValidEndDate)
ロール有効終了日を設定します。

設定されるのは、日付のみで、時間は00:00:00に設定されます。
有効になるのは設定された日付の前日までです。
nullを設定した場合は、最大未来日に設定されます。

パラメータ:
roleValidEndDate - ロール有効終了日

setRoleValidStartDate

public void setRoleValidStartDate(Date roleValidStartDate)
ロール有効開始日を設定します。

設定されるのは、日付のみで、時間は00:00:00に設定されます。
有効になるのは設定された日付からです。
nullを設定した場合は、最大過去日に設定されます。

パラメータ:
roleValidStartDate - ロール有効開始日
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CsvAccountBackup (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
クラス CsvAccountBackup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.account.CsvAccountBackup
すべての実装インタフェース:
AccountExporter, AccountImporter
public class CsvAccountBackup
extends Object
implements AccountImporter, AccountExporter

CSVアカウントバックアップクラスです。
CSV形式でのアカウント情報のインポートおよびエクスポートを実現します。

アカウントのCSVフォーマットについて

各行の一列目には、情報ヘッダを記述します。
各ヘッダ情報別に、2列目以降に設定する内容が異なります。

各情報ヘッダの詳細は、以下の通りです。

account（アカウント基本情報）
account,ユーザID,パスワード,ロケール,エンコーディング,モバイル用パスワード,説明,有効開始日,有効終了日,外出フラグ,メインページパターン,カラーパターン,ライセンス

  • 有効開始日および有効終了日のフォーマットは yyyy/MM/dd|hh:mm:ss です。
  • 有効開始日を空文字列とした場合は、最大過去日付(1582/10/15|00:00:00)となります。
  • 有効終了日を空文字列とした場合は、最大未来日付(9999/12/31|23:59:59)となります。
    • roles（アカウントロール情報）
    roles,ユーザID,ロールID,ロール有効開始日,ロール有効終了日,ロールID,ロール有効開始日,ロール有効終了日,・・・

  • 複数のロールを記述する場合は、ロールID,ロール有効開始日,ロール有効終了日の順で繰り返し記述します。
  • ロール有効開始日およびロール有効終了日のフォーマットは yyyy/MM/dd|hh:mm:ss です。
  • ロール有効開始日を空文字列とした場合は、最大過去日付(1582/10/15|00:00:00)となります。
  • ロール有効終了日を空文字列とした場合は、最大未来日付(9999/12/31|23:59:59)となります。
    • my-menus（マイメニュー情報）
    my-menus,ユーザID,メニューID,表示名,イメージパス,ソート番号（数字）,メニューID,表示名,イメージパス,ソート番号（数字）,・・・

  • 複数のマイメニューを記述する場合は、メニューID,表示名,イメージパス,ソート番号（数字）の順で繰り返し記述します。
    • app-roles（アプリケーションロール）
    app-roles,ユーザID,アプリケーションID,アプリケーションID,・・・

  • 複数のアプリケーションロールを記述する場合は、アプリケーションIDを繰り返し記述します。
    • attrs （ユーザ属性）
    attrs,ユーザID,属性キー,属性S値,属性キー,属性値,・・・

  • 複数のユーザ属性を記述する場合は、属性キー,属性値の順で繰り返し記述します。
    • 記述例

    account,guest,guest,ja,Shift_JIS,0123,ゲストユーザ,1582/10/15|00:00:00,9999/12/31|23:59:59,FALSE,,,TRUE
    roles,guest,userSetting,1582/10/15|00:00:00,9999/12/31|23:59:59,level3,,
    my-menus,guest,menu_id1,メニュー別名１,images/image1.gif,1,menu_id2,メニュー別名２,images/image1.gif,2
    app-roles,guest,SP,WM
    attrs,guest,attr1,value1,attr2,value2

    導入されたバージョン:
    6.1
    バージョン:
    1.0

    フィールドの概要
    static String ID_CRYPTION_CLASS
    暗号化クラス名
    コンストラクタの概要
    CsvAccountBackup()
    メソッドの概要
void | doExport(AccountManager manager, OutputStream outputStream) エクスポートを行います。
void | doImport(InputStream inputStream, AccountManager manager) インポートを行います。
protected Account[] | getAllAccounts(String groupId)
protected Map | getParams() パラメータを取得します。
void | init(Map params) 初期化。
    クラス java.lang.Object から継承したメソッド
    clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    フィールドの詳細

    ID_CRYPTION_CLASS

    public static final String ID_CRYPTION_CLASS
    暗号化クラス名

    関連項目:
    定数フィールド値
    コンストラクタの詳細

    CsvAccountBackup

    public CsvAccountBackup()
    メソッドの詳細

    init

    public void init(Map params)
    初期化。

    初期化する。

    定義:
    インタフェース AccountImporter 内の init
    パラメータ:
    params - 初期化パラメータのマップ(Map)

    getParams

    protected Map getParams()
    パラメータを取得します。

    doImport

    public void doImport(InputStream inputStream,
                     AccountManager manager)
              throws AccessSecurityImportException
    インポートを行います。

    ストリーム内の情報からアカウント情報を生成します。

    定義:
    インタフェース AccountImporter 内の doImport
    パラメータ:
    manager - アカウントマネージャクラス
    inputStream - 入力ストリーム
    例外:
    AccessSecurityImportException

    doExport

    public void doExport(AccountManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
    エクスポートを行います。

    アカウントバックアップ情報を生成し、ストリームに返却します。

    定義:
    インタフェース AccountExporter 内の doExport
    パラメータ:
    manager - アカウントマネージャクラス
    outputStream - 出力ストリーム
    例外:
    AccessSecurityExportException

    getAllAccounts

    protected Account[] getAllAccounts(String groupId)
                            throws AccessSecurityException
    例外:
    AccessSecurityException
    概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
            intra-mart 6.1.14
    前のクラス 次のクラス フレームあり フレームなし
    概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FavoriteMenu (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
クラス FavoriteMenu

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.account.FavoriteMenu
すべての実装インタフェース:
Serializable
public class FavoriteMenu
extends Object
implements Serializable

マイメニューモデル。

マイメニューの情報を保管するモデルクラスです。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
FavoriteMenu(String menuId)
コンストラクタ。
FavoriteMenu(String menuId, String displayName, int sortNumber)
コンストラクタ。
メソッドの概要
String | getDisplayName() マイメニュー表示名を取得します。
String | getImagePath() マイメニューイメージを取得します。
String | getMenuId() メニューIDを取得します。
int | getSortNumber() ソート番号を取得します。
void | setDisplayName(String displayName) マイメニュー表示名を設定する。
void | setImagePath(String imagePath) マイメニューイメージパスを設定します。
protected void | setMenuId(String menuId) メニューIDを設定します。
void | setSortNumber(int sortNumber) ソート番号を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FavoriteMenu

public FavoriteMenu(String menuId,
                    String displayName,
                    int sortNumber)
コンストラクタ。

パラメータ:
displayName - マイメニュー表示名
menuId - メニューID
sortNumber - ソート番号

FavoriteMenu

public FavoriteMenu(String menuId)
コンストラクタ。

パラメータ:
menuId - メニューID
メソッドの詳細

getDisplayName

public String getDisplayName()
マイメニュー表示名を取得します。

戻り値:
マイメニュー表示名

getMenuId

public String getMenuId()
メニューIDを取得します。

戻り値:
メニューID

getSortNumber

public int getSortNumber()
ソート番号を取得します。

戻り値:
ソート番号

setDisplayName

public void setDisplayName(String displayName)
マイメニュー表示名を設定する。

パラメータ:
displayName - マイメニュー表示名

setMenuId

protected void setMenuId(String menuId)
メニューIDを設定します。

パラメータ:
menuId - メニューID

setSortNumber

public void setSortNumber(int sortNumber)
ソート番号を設定します。

パラメータ:
sortNumber - ソート番号

getImagePath

public String getImagePath()
マイメニューイメージを取得します。

戻り値:
String

setImagePath

public void setImagePath(String imagePath)
マイメニューイメージパスを設定します。

パラメータ:
imagePath - マイメニューイメージパス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.account (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.security.account
インタフェース
AccountAccessor
AccountChangedListener
AccountExporter
AccountImporter
AccountPostWriterListener
AccountQueryWriterListener
AccountReaderDecorator
クラス
Account
AccountManager
AccountRole
CsvAccountBackup
FavoriteMenu
RoleChangedAccountListener
StandardAccountBackup


jp.co.intra_mart.foundation.security.account (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.account

アカウントに関連するクラスを提供します。

参照:
説明

インタフェースの概要
AccountAccessor | アカウントアクセッサインタフェース。
AccountChangedListener | アカウント情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AccountExporter | アカウントエクスポートインタフェースです。
AccountImporter | アカウントインポートインタフェースです。
AccountPostWriterListener | アカウント情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AccountQueryWriterListener | アカウント情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
AccountReaderDecorator | アカウント情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

クラスの概要
Account | アカウントモデル。
AccountManager | アカウントマネージャクラス。
AccountRole | アカウント用ロールモデル。
CsvAccountBackup | CSVアカウントバックアップクラスです。
FavoriteMenu | マイメニューモデル。
RoleChangedAccountListener | ロールが削除された場合にアカウントに紐付くロールを削除するリスナークラス。
StandardAccountBackup | アカウント情報をインポート・エクスポートするクラス。

パッケージ jp.co.intra_mart.foundation.security.account の説明

アカウントに関連するクラスを提供します。


jp.co.intra_mart.foundation.security.account クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.account の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.account.Account (implements jp.co.intra_mart.foundation.security.LocaleProvider, java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.account.AccountManager
    • class jp.co.intra_mart.foundation.security.account.AccountRole (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.account.CsvAccountBackup (implements jp.co.intra_mart.foundation.security.account.AccountExporter, jp.co.intra_mart.foundation.security.account.AccountImporter)
    • class jp.co.intra_mart.foundation.security.account.FavoriteMenu (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener (implements jp.co.intra_mart.foundation.security.role.RoleChangedListener)
    • class jp.co.intra_mart.foundation.security.account.StandardAccountBackup (implements jp.co.intra_mart.foundation.security.account.AccountExporter, jp.co.intra_mart.foundation.security.account.AccountImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.account.AccountAccessor
  • interface jp.co.intra_mart.foundation.security.account.AccountChangedListener
  • interface jp.co.intra_mart.foundation.security.account.AccountExporter
  • interface jp.co.intra_mart.foundation.security.account.AccountImporter
  • interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener
  • interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.account.AccountReaderDecorator


パッケージ jp.co.intra_mart.foundation.security.account の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.account の使用

jp.co.intra_mart.foundation.security.account を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession |
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.mobile |
jp.co.intra_mart.foundation.security.password |

jp.co.intra_mart.foundation.security により使用される jp.co.intra_mart.foundation.security.account のクラス
Account
アカウントモデル。
AccountAccessor
アカウントアクセッサインタフェース。
AccountRole
アカウント用ロールモデル。
FavoriteMenu
マイメニューモデル。

jp.co.intra_mart.foundation.security.account により使用される jp.co.intra_mart.foundation.security.account のクラス
Account
アカウントモデル。
AccountExporter
アカウントエクスポートインタフェースです。
AccountImporter
アカウントインポートインタフェースです。
AccountManager
アカウントマネージャクラス。
AccountRole
アカウント用ロールモデル。
FavoriteMenu
マイメニューモデル。

jp.co.intra_mart.foundation.security.activesession により使用される jp.co.intra_mart.foundation.security.account のクラス
Account
アカウントモデル。

jp.co.intra_mart.foundation.security.certification により使用される jp.co.intra_mart.foundation.security.account のクラス
Account
アカウントモデル。

jp.co.intra_mart.foundation.security.mobile により使用される jp.co.intra_mart.foundation.security.account のクラス
Account
アカウントモデル。
AccountPostWriterListener
アカウント情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AccountQueryWriterListener
アカウント情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
AccountRole
アカウント用ロールモデル。
FavoriteMenu
マイメニューモデル。

jp.co.intra_mart.foundation.security.password により使用される jp.co.intra_mart.foundation.security.account のクラス
Account
アカウントモデル。
AccountChangedListener
アカウント情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AccountRole
アカウント用ロールモデル。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


RoleChangedAccountListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
クラス RoleChangedAccountListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener
すべての実装インタフェース:
RoleChangedListener
public class RoleChangedAccountListener
extends Object
implements RoleChangedListener

ロールが削除された場合にアカウントに紐付くロールを削除するリスナークラス。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
RoleChangedAccountListener()
コンストラクタ。
メソッドの概要
void | init(Map params) ロールリスナーの初期化。
void | roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | roleDeleted(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | subRoleAdded(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | subRoleDeleted(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RoleChangedAccountListener

public RoleChangedAccountListener()
コンストラクタ。

メソッドの詳細

init

public void init(Map params)
ロールリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース RoleChangedListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

roleAdded

public void roleAdded(String groupId,
                      Role role)
               throws ChangedListenerException
ロール情報をデータストアに作成した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の roleAdded
パラメータ:
groupId - ログイングループID
role - 作成されたロール
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

roleDeleted

public void roleDeleted(String groupId,
                        String roleId)
                 throws ChangedListenerException
ロール情報をデータストアから削除した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の roleDeleted
パラメータ:
groupId - ログイングループID
roleId - 削除されたロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

roleUpdated

public void roleUpdated(String groupId,
                        Role role)
                 throws ChangedListenerException
ロール情報をデータストアに更新した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の roleUpdated
パラメータ:
groupId - ログイングループID
role - 更新されたロール
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

subRoleAdded

public void subRoleAdded(String groupId,
                         String roleId,
                         String subRoleId)
                  throws ChangedListenerException
ロールにサブロールを追加した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の subRoleAdded
パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 追加されたサブロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

subRoleDeleted

public void subRoleDeleted(String groupId,
                           String roleId,
                           String subRoleId)
                    throws ChangedListenerException
ロールからサブロールを削除した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の subRoleDeleted
パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 削除されたサブロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardAccountBackup (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
クラス StandardAccountBackup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.account.StandardAccountBackup
すべての実装インタフェース:
AccountExporter, AccountImporter
public class StandardAccountBackup
extends Object
implements AccountImporter, AccountExporter

アカウント情報をインポート・エクスポートするクラス。

アカウント情報をXML形式でインポート・エクスポートするクラスです。

このクラスを[ServerManager]/access-security.xmlのbackup-configタグ内に設定して利用します。

設定例

 <backup-config>
   <backup-group>
     <category>カテゴリ名</category>
     <account-backup>
       <import>
          <import-class>jp.co.intra_mart.foundation.security.account.StandardAccountBackup</import-class>
       </import>
       <export>
         <export-class>jp.co.intra_mart.foundation.security.account.StandardAccountBackup</export-class>
       </export>
     </account-backup>
   </backup-group>
 <backup-config>

導入されたバージョン:
5.0
バージョン:
2.0

フィールドの概要
static String ID_CRYPTION_CLASS
暗号化クラス名
コンストラクタの概要
StandardAccountBackup()
メソッドの概要
void | doExport(AccountManager manager, OutputStream outputStream) エクスポートを行います。
void | doImport(InputStream inputStream, AccountManager manager) インポートを行います。
protected Account[] | getAllAccounts(String groupId)
void | init(Map params) 初期化。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_CRYPTION_CLASS

public static final String ID_CRYPTION_CLASS
暗号化クラス名

関連項目:
定数フィールド値
コンストラクタの詳細

StandardAccountBackup

public StandardAccountBackup()
メソッドの詳細

init

public void init(Map params)
初期化。

初期化する。

定義:
インタフェース AccountImporter 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     AccountManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からアカウント情報を生成します。

定義:
インタフェース AccountImporter 内の doImport
パラメータ:
manager - アカウントマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

doExport

public void doExport(AccountManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

アカウントバックアップ情報を生成し、ストリームに返却します。

定義:
インタフェース AccountExporter 内の doExport
パラメータ:
manager - アカウントマネージャクラス
outputStream - 出力ストリーム
例外:
AccessSecurityExportException

getAllAccounts

protected Account[] getAllAccounts(String groupId)
                            throws AccessSecurityException
例外:
AccessSecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor の使用

ActiveSessionAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.security.activesession

jp.co.intra_mart.foundation.security.activesession での ActiveSessionAccessor の使用

ActiveSessionAccessor を実装している jp.co.intra_mart.foundation.security.activesession のクラス
 class StandardActiveSessionAccessor
アクティブなセッション情報操作実装クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.activesession.ActiveSessionBindingListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.activesession.ActiveSessionBindingListener の使用

jp.co.intra_mart.foundation.security.activesession.ActiveSessionBindingListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo の使用

ActiveSessionInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security.activesession
jp.co.intra_mart.foundation.security.duplication

jp.co.intra_mart.foundation.security.activesession での ActiveSessionInfo の使用

ActiveSessionInfo を返す jp.co.intra_mart.foundation.security.activesession のメソッド
ActiveSessionInfo[] | StandardActiveSessionAccessor.getActiveSessionInfos(String groupId) アクティブなすべてのセッション情報を取得します。
ActiveSessionInfo | StandardActiveSessionAccessor.getActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を取得します。
ActiveSessionInfo | StandardActiveSessionAccessor.getInvalidatedActiveSessionInfo(String groupId, String sessionId) 無効化されたアクティブなセッション情報を取得します。
ActiveSessionInfo[] | StandardActiveSessionAccessor.getActiveSessionInfos(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | StandardActiveSessionAccessor.getActiveSessionInfos(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | StandardActiveSessionAccessor.searchActiveSessionInfosByUserId(String groupId, String loginType, String userId) 引数で指定されたユーザ条件からアクティブなセッション情報を検索します。
ActiveSessionInfo[] | ActiveSessionManager.getActiveSessionInfos(String groupId) アクティブなすべてのセッション情報を取得します。
ActiveSessionInfo | ActiveSessionManager.getActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を取得します。
ActiveSessionInfo | ActiveSessionManager.getInvalidatedActiveSessionInfo(String groupId, String sessionId) 無効化されたアクティブなセッション情報を取得します。
ActiveSessionInfo[] | ActiveSessionManager.getActiveSessionInfos(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | ActiveSessionManager.getActiveSessionInfos(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | ActiveSessionManager.searchActiveSessionInfosByUserId(String groupId, String loginType, String userId) 引数で指定されたユーザ条件からアクティブなセッション情報を検索します。
ActiveSessionInfo[] | ActiveSessionAccessor.getActiveSessionInfos(String groupId) アクティブなすべてのセッション情報を取得します。
ActiveSessionInfo | ActiveSessionAccessor.getActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を取得します。
ActiveSessionInfo | ActiveSessionAccessor.getInvalidatedActiveSessionInfo(String groupId, String sessionId) 無効化されたアクティブなセッション情報を取得します。
ActiveSessionInfo[] | ActiveSessionAccessor.getActiveSessionInfos(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | ActiveSessionAccessor.getActiveSessionInfos(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | ActiveSessionAccessor.searchActiveSessionInfosByUserId(String groupId, String loginType, String userId) 引数で指定されたユーザ条件からアクティブなセッション情報を検索します。

ActiveSessionInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.activesession のメソッド
void | StandardActiveSessionAccessor.addActiveSessionInfo(ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報を登録します。
void | ActiveSessionManager.addActiveSessionInfo(ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報を登録します。
void | ActiveSessionAccessor.addActiveSessionInfo(ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報を登録します。

ActiveSessionInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.activesession のコンストラクタ
ActiveSessionBindingListener(ActiveSessionInfo activeSessionInfo)
コンストラクタ。

jp.co.intra_mart.foundation.security.duplication での ActiveSessionInfo の使用

ActiveSessionInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.duplication のメソッド
boolean | StandardDuplicateLoginAccessor.isDetectEnable(ActiveSessionInfo activeSessionInfo) 検出処理が有効かどうか取得します。
boolean | StandardDuplicateLoginAccessor.isInvalidatableByUser(ActiveSessionInfo activeSessionInfo) ユーザ自身のセッションの無効化が可能か取得します。
boolean | DuplicateLoginManager.isDuplicateLogined(ActiveSessionInfo activeSessionInfo) 引数で指定されたユーザが重複してログインしているかどうか判別します。
boolean | DuplicateLoginManager.isDetectEnable(ActiveSessionInfo activeSessionInfo) 検出処理が有効かどうか取得します。
boolean | DuplicateLoginManager.isInvalidatableByUser(ActiveSessionInfo activeSessionInfo) ユーザ自身のセッションの無効化が可能か取得します。
void | DuplicateLoginManager.invalidateOtherSessions(ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報以外のセッション情報をすべて無効にします。
boolean | DuplicateLoginAccessor.isDetectEnable(ActiveSessionInfo activeSessionInfo) 検出処理が有効かどうか取得します。
boolean | DuplicateLoginAccessor.isInvalidatableByUser(ActiveSessionInfo activeSessionInfo) ユーザ自身のセッションの無効化が可能か取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager の使用

jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.activesession.GroupActiveSessionRegister の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.activesession.GroupActiveSessionRegister の使用

jp.co.intra_mart.foundation.security.activesession.GroupActiveSessionRegister はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.activesession.NavigatorInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.activesession.NavigatorInfo の使用

NavigatorInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security.activesession

jp.co.intra_mart.foundation.security.activesession での NavigatorInfo の使用

NavigatorInfo を返す jp.co.intra_mart.foundation.security.activesession のメソッド
 NavigatorInfo ActiveSessionManager.distinctNavigator(String userAgent)
引数で指定されたユーザエージェント情報から判別してナビゲータ情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor の使用

jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.activesession.UserActiveSessionRegister の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.activesession.UserActiveSessionRegister の使用

jp.co.intra_mart.foundation.security.activesession.UserActiveSessionRegister はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ActiveSessionAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.activesession
インタフェース ActiveSessionAccessor

既知の実装クラスの一覧:
StandardActiveSessionAccessor
public interface ActiveSessionAccessor

アクティブなセッション情報操作インターフェース。

アクティブなセッション情報操作のためのインターフェース。

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
void | addActiveSessionInfo(ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報を登録します。
int | count(String groupId) アクティブなすべてのセッション数を取得します。
int | count(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。
int | count(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなすべてのセッション数を取得します。
void | destory(String groupId) アクティブなセッション情報をすべて破棄します。
boolean | exists(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が存在するかどうか取得します。
ActiveSessionInfo | getActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | getActiveSessionInfos(String groupId) アクティブなすべてのセッション情報を取得します。
ActiveSessionInfo[] | getActiveSessionInfos(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | getActiveSessionInfos(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなセッション情報を取得します。
String | getActiveSessionInvalidatedPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 引数で指定されたアクティブなセッション情報が無効化されたされていた場合の遷移先ページURLを取得します。
ActiveSessionInfo | getInvalidatedActiveSessionInfo(String groupId, String sessionId) 無効化されたアクティブなセッション情報を取得します。
void | init(Node defaultNode, Node node) 設定ファイルの情報を基に初期化します。
void | invalidate(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
boolean | isObservable() アクティブセッションの監視を行うかどうか取得します。
boolean | isValid(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
void | removeActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を削除します。
ActiveSessionInfo[] | searchActiveSessionInfosByUserId(String groupId, String loginType, String userId) 引数で指定されたユーザ条件からアクティブなセッション情報を検索します。
void | updateLastResponseTime(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。
void | updateToProcessing(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報を処理中に更新します。

メソッドの詳細

init

public void init(Node defaultNode,
                 Node node)
          throws ActiveSessionException
設定ファイルの情報を基に初期化します。

パラメータ:
defaultNode - デフォルトノード
node - デフォルトノード
例外:
ActiveSessionException - 初期化処理で例外が発生した場合にスローします。

isObservable

public boolean isObservable()
アクティブセッションの監視を行うかどうか取得します。

戻り値:
アクティブセッションの監視を行う場合 true
導入されたバージョン:
6.1.6

addActiveSessionInfo

public void addActiveSessionInfo(ActiveSessionInfo activeSessionInfo)
                          throws ActiveSessionException
引数で指定されたアクティブなセッション情報を登録します。

パラメータ:
activeSessionInfo - アクティブなセッション情報
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

removeActiveSessionInfo

public void removeActiveSessionInfo(String groupId,
                                    String sessionId)
                             throws ActiveSessionNotExistException,
                                    ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報を削除します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

destory

public void destory(String groupId)
             throws ActiveSessionException
アクティブなセッション情報をすべて破棄します。

パラメータ:
groupId - ログイングループID
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

invalidate

public void invalidate(String groupId,
                       String sessionId)
                throws ActiveSessionNotExistException,
                       ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報を無効化します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

isValid

public boolean isValid(String groupId,
                       String sessionId)
                throws ActiveSessionNotExistException,
                       ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
戻り値:
アクティブなセッション情報が有効かどうか
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

count

public int count(String groupId)
          throws ActiveSessionException
アクティブなすべてのセッション数を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
アクティブなすべてのセッション数
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

count

public int count(String groupId,
                 String loginType,
                 String userId)
          throws ActiveSessionException
引数で指定されたユーザのアクティブなすべてのセッション数を取得します。

パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
userId - ユーザID
戻り値:
アクティブなすべてのセッション数
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

count

public int count(String groupId,
                 String loginType)
          throws ActiveSessionException
引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。

パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
戻り値:
アクティブなすべてのセッション数
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

exists

public boolean exists(String groupId,
                      String sessionId)
               throws ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報が存在するかどうか取得します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
戻り値:
アクティブなセッション情報が存在するかどうか
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getActiveSessionInfos

public ActiveSessionInfo[] getActiveSessionInfos(String groupId)
                                          throws ActiveSessionException
アクティブなすべてのセッション情報を取得します。

1件も存在しない場合、戻り値は空の配列となります。 配列の並び順はログイン時刻の昇順となります。

パラメータ:
groupId - ログイングループID
戻り値:
アクティブなセッション情報一覧
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getActiveSessionInfo

public ActiveSessionInfo getActiveSessionInfo(String groupId,
                                              String sessionId)
                                       throws ActiveSessionNotExistException,
                                              ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報を取得します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
戻り値:
アクティブなセッション情報
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getInvalidatedActiveSessionInfo

public ActiveSessionInfo getInvalidatedActiveSessionInfo(String groupId,
                                                         String sessionId)
                                                  throws ActiveSessionNotExistException,
                                                         ActiveSessionException
無効化されたアクティブなセッション情報を取得します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
戻り値:
アクティブなセッション情報
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getActiveSessionInfos

public ActiveSessionInfo[] getActiveSessionInfos(String groupId,
                                                 String loginType,
                                                 String userId)
                                          throws ActiveSessionException
引数で指定されたユーザのアクティブなセッション情報を取得します。

1件も存在しない場合、戻り値は空の配列となります。
配列の並び順はログイン時刻の昇順となります。

パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
userId - ユーザID
戻り値:
アクティブなセッション情報一覧
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getActiveSessionInfos

public ActiveSessionInfo[] getActiveSessionInfos(String groupId,
                                                 String loginType)
                                          throws ActiveSessionException
引数で指定されたログインタイプのアクティブなセッション情報を取得します。

1件も存在しない場合、戻り値は空の配列となります。
配列の並び順はログイン時刻の昇順となります。

パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
戻り値:
アクティブなセッション情報一覧
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

searchActiveSessionInfosByUserId

public ActiveSessionInfo[] searchActiveSessionInfosByUserId(String groupId,
                                                            String loginType,
                                                            String userId)
                                                     throws ActiveSessionException
引数で指定されたユーザ条件からアクティブなセッション情報を検索します。

ユーザIDに検索条件を指定します。
1件も存在しない場合、戻り値は空の配列となります。
配列の並び順はログイン時刻の昇順となります。

パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
userId - ユーザID
戻り値:
アクティブなセッション情報一覧
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

updateToProcessing

public void updateToProcessing(String groupId,
                               String sessionId)
                        throws ActiveSessionNotExistException,
                               ActiveSessionException
引数で指定されたアクティブなセッション情報を処理中に更新します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

updateLastResponseTime

public void updateLastResponseTime(String groupId,
                                   String sessionId)
                            throws ActiveSessionNotExistException,
                                   ActiveSessionException
引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getActiveSessionInvalidatedPage

public String getActiveSessionInvalidatedPage(SessionInfo sessionInfo,
                                              HttpServletRequest request,
                                              HttpServletResponse response)
引数で指定されたアクティブなセッション情報が無効化されたされていた場合の遷移先ページURLを取得します。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
遷移先ページ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ActiveSessionBindingListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.activesession
クラス ActiveSessionBindingListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.activesession.ActiveSessionBindingListener
すべての実装インタフェース:
EventListener, HttpSessionBindingListener, Serializable
public class ActiveSessionBindingListener
extends Object
implements HttpSessionBindingListener, Serializable

HttpSessionBindingListener を実装したアクティブなセッション情報を登録または削除するためのイベントトリガークラス。

導入されたバージョン:
6.1
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ActiveSessionBindingListener()
コンストラクタ。
ActiveSessionBindingListener(ActiveSessionInfo activeSessionInfo)
コンストラクタ。
メソッドの概要
void | valueBound(HttpSessionBindingEvent event) このオブジェクトがセッションに結びつけられた時に呼び出されます。
void | valueUnbound(HttpSessionBindingEvent event) このオブジェクトがセッションから取り外された時に呼び出されます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ActiveSessionBindingListener

public ActiveSessionBindingListener()
コンストラクタ。

ActiveSessionBindingListener

public ActiveSessionBindingListener(ActiveSessionInfo activeSessionInfo)
コンストラクタ。

メソッドの詳細

valueBound

public void valueBound(HttpSessionBindingEvent event)
このオブジェクトがセッションに結びつけられた時に呼び出されます。

アクティブなセッション情報が登録されていない場合、登録します。

定義:
インタフェース HttpSessionBindingListener 内の valueBound
関連項目:
HttpSessionBindingListener.valueBound(HttpSessionBindingEvent)

valueUnbound

public void valueUnbound(HttpSessionBindingEvent event)
このオブジェクトがセッションから取り外された時に呼び出されます。

アクティブなセッション情報を削除します。

定義:
インタフェース HttpSessionBindingListener 内の valueUnbound
関連項目:
HttpSessionBindingListener.valueUnbound(HttpSessionBindingEvent)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ActiveSessionInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.activesession
クラス ActiveSessionInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo
すべての実装インタフェース:
Serializable
public final class ActiveSessionInfo
extends Object
implements Serializable

アクティブなセッション情報操作クラス。

導入されたバージョン:
6.1
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ActiveSessionInfo()
コンストラクタ。
ActiveSessionInfo(HttpServletRequest request)
コンストラクタ。
ActiveSessionInfo(SessionInfo sessionInfo, HttpSession session, String remoteAddr, String userAgent)
コンストラクタ。
ActiveSessionInfo(SessionInfo sessionInfo, String sessionId, int expireInterval, String remoteAddr, String userAgent)
コンストラクタ。
メソッドの概要
int | getExpireInterval() クライアントのアクセスとアクセスの間に、サーブレットコンテナがこのセッションを保ち続ける最大の時間間隔を秒数で返します。
String | getInvalidateLoginType() 無効化したユーザのログインタイプを取得する。
long | getInvalidateTime() 無効化された時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を取得する。
String | getInvalidateUserId() 無効化したユーザのログインユーザIDを取得する。
long | getLastResponseTime() 最終応答時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を取得する。
String | getLoginGroup() ログイングループIDを取得する。
long | getLoginTime() ログイン時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を取得する。
String | getLoginType() ログインタイプを取得する。
String | getRemoteAddr() リクエスト元のクライアントの IP(Internet Protocol) アドレスを取得する。
String | getSessionId() セッションIDを取得する。
String | getUserAgent() ブラウザ情報を取得する。
String | getUserId() ログインユーザIDを取得する。
boolean | isActive() 現在の時刻と比較して、セッションが有効か無効か取得する。
boolean | isActive(long timeMillis) 引数で指定された時刻と比較して、セッションが有効か無効か取得する。
boolean | isProcessing() クライアントのアクセスに対して処理中がどうか取得する。
boolean | isValid() アクティブなセッション情報が有効かどうか取得します。
void | setExpireInterval(int expireInterval) 最終応答時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を設定する。
void | setInvalidateLoginType(String invalidateLoginType) 無効化したユーザのログインタイプを設定する。
void | setInvalidateTime(long invalidateTime) 無効化された時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を設定する。
void | setInvalidateUserId(String invalidateUserId) 無効化したユーザのログインユーザIDを設定する。
void | setLastResponseTime(long lastResponseTime) 最終応答時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を設定する。
void | setLoginGroup(String loginGroup) ログイングループIDを設定する。
void | setLoginTime(long loginTime) ログイン時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を設定する。
void | setLoginType(String loginType) ログインタイプを設定する。
void | setProcessing(boolean processing) クライアントのアクセスに対して処理中がどうか設定する。
void | setRemoteAddr(String remoteAddr) リクエスト元のクライアントの IP(Internet Protocol) アドレスを設定する。
void | setSessionId(String sessionId) セッションIDを設定する。
void | setUserAgent(String userAgent) ブラウザ情報を設定する。
void | setUserId(String userId) ログインユーザIDを設定する。
void | setValid(boolean valid) アクティブなセッション情報を有効・無効化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ActiveSessionInfo

public ActiveSessionInfo()
コンストラクタ。

無効なセッションとしてインスタンスを構成する。

ActiveSessionInfo

public ActiveSessionInfo(HttpServletRequest request)
                  throws NoFilterException,
                         AccessSecurityException,
                         NullPointerException
コンストラクタ。

有効なセッションとしてインスタンスを構成する。

パラメータ:
request - リクエスト
例外:
AccessSecurityException
NoFilterException - セッションが無効の場合にスローされます。
NullPointerException

ActiveSessionInfo

public ActiveSessionInfo(SessionInfo sessionInfo,
                         HttpSession session,
                         String remoteAddr,
                         String userAgent)
コンストラクタ。

有効なセッションとしてインスタンスを構成する。

パラメータ:
sessionInfo - intra-amrtセッション情報
session - HTTPセッション情報
remoteAddr - クライアントの IP アドレス
userAgent - ブラウザ情報

ActiveSessionInfo

public ActiveSessionInfo(SessionInfo sessionInfo,
                         String sessionId,
                         int expireInterval,
                         String remoteAddr,
                         String userAgent)
コンストラクタ。

有効なセッションとしてインスタンスを構成する。

パラメータ:
sessionInfo - intra-amrtセッション情報
sessionId - セッションID
expireInterval - セッションを保ち続ける最大の時間間隔(秒数)
remoteAddr - クライアントの IP アドレス
userAgent - ブラウザ情報
メソッドの詳細

isActive

public boolean isActive()
現在の時刻と比較して、セッションが有効か無効か取得する。

戻り値:
セッションが有効か無効

isActive

public boolean isActive(long timeMillis)
引数で指定された時刻と比較して、セッションが有効か無効か取得する。

パラメータ:
timeMillis - 時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)
戻り値:
セッションが有効か無効

getSessionId

public String getSessionId()
セッションIDを取得する。

戻り値:
セッションID

setSessionId

public void setSessionId(String sessionId)
セッションIDを設定する。

パラメータ:
sessionId - セッションID

getLoginType

public String getLoginType()
ログインタイプを取得する。

戻り値:
ログインタイプ
関連項目:
SecurityConstraint#LT_SUPER, SecurityConstraint#LT_GROUP, SecurityConstraint#LT_USER

setLoginType

public void setLoginType(String loginType)
ログインタイプを設定する。

パラメータ:
loginType - ログインタイプ

getLoginGroup

public String getLoginGroup()
ログイングループIDを取得する。

戻り値:
ログイングループID

setLoginGroup

public void setLoginGroup(String loginGroup)
ログイングループIDを設定する。

パラメータ:
loginGroup - ログイングループID

getUserId

public String getUserId()
ログインユーザIDを取得する。

戻り値:
ログインユーザID

setUserId

public void setUserId(String userId)
ログインユーザIDを設定する。

パラメータ:
userId - ログインユーザID

getLoginTime

public long getLoginTime()
ログイン時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を取得する。

戻り値:
ログイン時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)

setLoginTime

public void setLoginTime(long loginTime)
ログイン時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を設定する。

パラメータ:
loginTime - ログイン時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)

getLastResponseTime

public long getLastResponseTime()
最終応答時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を取得する。

戻り値:
最終応答時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)

setExpireInterval

public void setExpireInterval(int expireInterval)
最終応答時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を設定する。

パラメータ:
expireInterval - 最終応答時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)

setLastResponseTime

public void setLastResponseTime(long lastResponseTime)
最終応答時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を設定する。

getExpireInterval

public int getExpireInterval()
クライアントのアクセスとアクセスの間に、サーブレットコンテナがこのセッションを保ち続ける最大の時間間隔を秒数で返します。

負の値は、セッションがタイムアウトにならないことを示します。

戻り値:
このセッションが、クライアントの要求と要求との間で保持され続ける秒数を指定する整数
関連項目:
HttpSession.getMaxInactiveInterval()

getRemoteAddr

public String getRemoteAddr()
リクエスト元のクライアントの IP(Internet Protocol) アドレスを取得する。

戻り値:
リクエスト元のクライアントの IP(Internet Protocol) アドレス
関連項目:
ServletRequest#getRemoteAddr()

setRemoteAddr

public void setRemoteAddr(String remoteAddr)
リクエスト元のクライアントの IP(Internet Protocol) アドレスを設定する。

パラメータ:
remoteAddr - リクエスト元のクライアントの IP(Internet Protocol) アドレス

getUserAgent

public String getUserAgent()
ブラウザ情報を取得する。

このブラウザ情報は ServletRequest#getHeader("User-Agent") で取得できる値を想定する。

戻り値:
ブラウザ情報

setUserAgent

public void setUserAgent(String userAgent)
ブラウザ情報を設定する。

パラメータ:
userAgent - ブラウザ情報

isProcessing

public boolean isProcessing()
クライアントのアクセスに対して処理中がどうか取得する。

戻り値:
処理中がどうか

setProcessing

public void setProcessing(boolean processing)
クライアントのアクセスに対して処理中がどうか設定する。

パラメータ:
processing - 処理中がどうか

setValid

public void setValid(boolean valid)
アクティブなセッション情報を有効・無効化します。

パラメータ:
valid - 有効(true) or 無効(false)

isValid

public boolean isValid()
アクティブなセッション情報が有効かどうか取得します。

getInvalidateLoginType

public String getInvalidateLoginType()
無効化したユーザのログインタイプを取得する。

戻り値:
無効化したユーザのログインタイプ
関連項目:
SecurityConstraint#LT_SUPER, SecurityConstraint#LT_GROUP, SecurityConstraint#LT_USER

setInvalidateLoginType

public void setInvalidateLoginType(String invalidateLoginType)
無効化したユーザのログインタイプを設定する。

関連項目:
SecurityConstraint#LT_SUPER, SecurityConstraint#LT_GROUP, SecurityConstraint#LT_USER

getInvalidateUserId

public String getInvalidateUserId()
無効化したユーザのログインユーザIDを取得する。

戻り値:
無効化したユーザのログインユーザID

setInvalidateUserId

public void setInvalidateUserId(String invalidateUserId)
無効化したユーザのログインユーザIDを設定する。

getInvalidateTime

public long getInvalidateTime()
無効化された時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を取得する。

戻り値:
無効化された時刻

setInvalidateTime

public void setInvalidateTime(long invalidateTime)
無効化された時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を設定する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ActiveSessionManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.activesession
クラス ActiveSessionManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager
public class ActiveSessionManager
extends Object

アクティブセッション情報管理マネージャクラス。

アクティブなセッション情報に対して重複ログインを管理するためのクラス

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
static String | DEFAULT_ACTIVE_SESSION_ACCESSOR
static String | DEFAULT_SP_ACTIVE_SESSION_BINDING_LISTENER
コンストラクタの概要
ActiveSessionManager()
コンストラクタ。
メソッドの概要
void | addActiveSessionInfo(ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報を登録します。
int | count(String groupId) アクティブなすべてのセッション数を取得します。
int | count(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。
int | count(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなすべてのセッション数を取得します。
void | destory(String groupId) アクティブなセッション情報をすべて破棄します。
NavigatorInfo | distinctNavigator(String userAgent) 引数で指定されたユーザエージェント情報から判別してナビゲータ情報を取得します。
String | getActiveSessionBindingListenerSessionName() アクティブなセッション情報を登録・削除するために使用するセッション名を取得します。
ActiveSessionInfo | getActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | getActiveSessionInfos(String groupId) アクティブなすべてのセッション情報を取得します。
ActiveSessionInfo[] | getActiveSessionInfos(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | getActiveSessionInfos(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなセッション情報を取得します。
String | getActiveSessionInvalidatedPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 引数で指定されたアクティブなセッション情報が無効化されたされていた場合の遷移先ページURLを取得します。
ActiveSessionInfo | getInvalidatedActiveSessionInfo(String groupId, String sessionId) 無効化されたアクティブなセッション情報を取得します。
boolean | hasActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が存在するかチェックします。
void | invalidate(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
boolean | isLogined(String groupId, String loginType, String userId) 引数で指定されたユーザがログインしているかどうか判別します。
boolean | isObservable(String groupId) アクティブセッションの監視を行うかどうか取得します。
boolean | isValid(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
void | removeActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を削除します。
ActiveSessionInfo[] | searchActiveSessionInfosByUserId(String groupId, String loginType, String userId) 引数で指定されたユーザ条件からアクティブなセッション情報を検索します。
void | updateLastResponseTime(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。
void | updateToProcessing(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報を処理中に更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_SP_ACTIVE_SESSION_BINDING_LISTENER

public static final String DEFAULT_SP_ACTIVE_SESSION_BINDING_LISTENER
関連項目:
定数フィールド値

DEFAULT_ACTIVE_SESSION_ACCESSOR

public static final String DEFAULT_ACTIVE_SESSION_ACCESSOR
関連項目:
定数フィールド値
コンストラクタの詳細

ActiveSessionManager

public ActiveSessionManager()
コンストラクタ。

メソッドの詳細

isObservable

public boolean isObservable(String groupId)
アクティブセッションの監視を行うかどうか取得します。

パラメータ:
groupId - ログイングループID
戻り値:
アクティブセッションの監視を行う場合 true
導入されたバージョン:
6.1.6

addActiveSessionInfo

public void addActiveSessionInfo(ActiveSessionInfo activeSessionInfo)
                          throws ActiveSessionException
引数で指定されたアクティブなセッション情報を登録します。

パラメータ:
activeSessionInfo - アクティブなセッション情報
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

removeActiveSessionInfo

public void removeActiveSessionInfo(String groupId,
                                    String sessionId)
                             throws ActiveSessionNotExistException,
                                    ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報を削除します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

destory

public void destory(String groupId)
             throws ActiveSessionException
アクティブなセッション情報をすべて破棄します。

パラメータ:
groupId - ログイングループID
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

invalidate

public void invalidate(String groupId,
                       String sessionId)
                throws ActiveSessionNotExistException,
                       ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報を無効化します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

isValid

public boolean isValid(String groupId,
                       String sessionId)
                throws ActiveSessionNotExistException,
                       ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
戻り値:
アクティブなセッション情報が有効かどうか
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

isLogined

public boolean isLogined(String groupId,
                         String loginType,
                         String userId)
                  throws ActiveSessionException
引数で指定されたユーザがログインしているかどうか判別します。

パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
userId - ユーザID
戻り値:
ログインしている場合 true、ログインしていない場合 false
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

count

public int count(String groupId)
          throws ActiveSessionException
アクティブなすべてのセッション数を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
アクティブなすべてのセッション数
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

count

public int count(String groupId,
                 String loginType,
                 String userId)
          throws ActiveSessionException
引数で指定されたユーザのアクティブなすべてのセッション数を取得します。

パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
userId - ユーザID
戻り値:
アクティブなすべてのセッション数
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

count

public int count(String groupId,
                 String loginType)
          throws ActiveSessionException
引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。

パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
戻り値:
アクティブなすべてのセッション数
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getActiveSessionInfos

public ActiveSessionInfo[] getActiveSessionInfos(String groupId)
                                          throws ActiveSessionException
アクティブなすべてのセッション情報を取得します。

1件も存在しない場合、戻り値は空の配列となります。 配列の並び順はログイン時刻の昇順となります。

パラメータ:
groupId - ログイングループID
戻り値:
アクティブなセッション情報一覧
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getActiveSessionInfo

public ActiveSessionInfo getActiveSessionInfo(String groupId,
                                              String sessionId)
                                       throws ActiveSessionNotExistException,
                                              ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報を取得します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
戻り値:
アクティブなセッション情報
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

hasActiveSessionInfo

public boolean hasActiveSessionInfo(String groupId,
                                    String sessionId)
                             throws ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報が存在するかチェックします。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
戻り値:
アクティブなセッション情報が存在する場合 true、存在しない場合 false
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getInvalidatedActiveSessionInfo

public ActiveSessionInfo getInvalidatedActiveSessionInfo(String groupId,
                                                         String sessionId)
                                                  throws ActiveSessionNotExistException,
                                                         ActiveSessionException
無効化されたアクティブなセッション情報を取得します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
戻り値:
アクティブなセッション情報
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getActiveSessionInfos

public ActiveSessionInfo[] getActiveSessionInfos(String groupId,
                                                 String loginType,
                                                 String userId)
                                          throws ActiveSessionException
引数で指定されたユーザのアクティブなセッション情報を取得します。

1件も存在しない場合、戻り値は空の配列となります。
配列の並び順はログイン時刻の昇順となります。

パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
userId - ユーザID
戻り値:
アクティブなセッション情報一覧
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getActiveSessionInfos

public ActiveSessionInfo[] getActiveSessionInfos(String groupId,
                                                 String loginType)
                                          throws ActiveSessionException
引数で指定されたログインタイプのアクティブなセッション情報を取得します。

1件も存在しない場合、戻り値は空の配列となります。
配列の並び順はログイン時刻の昇順となります。

パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
戻り値:
アクティブなセッション情報一覧
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

searchActiveSessionInfosByUserId

public ActiveSessionInfo[] searchActiveSessionInfosByUserId(String groupId,
                                                            String loginType,
                                                            String userId)
                                                     throws ActiveSessionException
引数で指定されたユーザ条件からアクティブなセッション情報を検索します。

ユーザIDに検索条件を指定します。
1件も存在しない場合、戻り値は空の配列となります。
配列の並び順はログイン時刻の昇順となります。

パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
userId - ユーザID
戻り値:
アクティブなセッション情報一覧
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

updateToProcessing

public void updateToProcessing(String groupId,
                               String sessionId)
                        throws ActiveSessionNotExistException,
                               ActiveSessionException
引数で指定されたアクティブなセッション情報を処理中に更新します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

updateLastResponseTime

public void updateLastResponseTime(String groupId,
                                   String sessionId)
                            throws ActiveSessionNotExistException,
                                   ActiveSessionException
引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。

パラメータ:
groupId - ログイングループID
sessionId - セッションID
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getActiveSessionInvalidatedPage

public String getActiveSessionInvalidatedPage(SessionInfo sessionInfo,
                                              HttpServletRequest request,
                                              HttpServletResponse response)
引数で指定されたアクティブなセッション情報が無効化されたされていた場合の遷移先ページURLを取得します。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
遷移先ページ

getActiveSessionBindingListenerSessionName

public String getActiveSessionBindingListenerSessionName()
アクティブなセッション情報を登録・削除するために使用するセッション名を取得します。

戻り値:
アクティブなセッション情報を登録・削除するために使用するセッション名

distinctNavigator

public NavigatorInfo distinctNavigator(String userAgent)
引数で指定されたユーザエージェント情報から判別してナビゲータ情報を取得します。

パラメータ:
userAgent - ユーザエージェント情報
戻り値:
ナビゲータ情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GroupActiveSessionRegister (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.activesession
クラス GroupActiveSessionRegister

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.activesession.GroupActiveSessionRegister
すべての実装インタフェース:
SuperCertificationListener
public class GroupActiveSessionRegister
extends Object
implements SuperCertificationListener

管理者ログイン認証リスナー実装クラス。

グループ管理者の認証成功時、アクティブなセッション情報を登録します。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
GroupActiveSessionRegister()
メソッドの概要
void | doCertification(int certificationResult, LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者の認証後にコールされるメソッドです。
void | init(Map params) 管理者ログイン認証リスナーの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GroupActiveSessionRegister

public GroupActiveSessionRegister()
メソッドの詳細

init

public void init(Map params)
管理者ログイン認証リスナーの初期化を行います。

管理者ログイン認証リスナーのインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース SuperCertificationListener 内の init
パラメータ:
params - 初期化パラメータのマップ

doCertification

public void doCertification(int certificationResult,
                            LoginInfo loginInfo,
                            SuperUser user,
                            HttpServletRequest request,
                            HttpServletResponse response)
管理者の認証後にコールされるメソッドです。

グループ管理者の認証成功時、アクティブなセッション情報を登録します。

定義:
インタフェース SuperCertificationListener 内の doCertification
パラメータ:
certificationResult - 認証結果
認証成功 | SecurityConstraint.CR_OK
ユーザ不一致 | SecurityConstraint.CR_NO_USER
認証失敗(パスワード不一致) | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
loginInfo - ログイン情報
user - 管理者情報
request - サーブレットリクエスト
response - サーブレットレスポンス
導入されたバージョン:
6.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NavigatorInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.activesession
クラス NavigatorInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.activesession.NavigatorInfo
public class NavigatorInfo
extends Object

ナビゲータ情報クラス。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
NavigatorInfo()
コンストラクタ。
メソッドの概要
String | getAppName() ブラウザ名を取得します。
void | setAppName(String appName) ブラウザ名を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NavigatorInfo

public NavigatorInfo()
コンストラクタ。

メソッドの詳細

getAppName

public String getAppName()
ブラウザ名を取得します。

戻り値:
ブラウザ名

setAppName

public void setAppName(String appName)
ブラウザ名を取得します。

パラメータ:
appName - ブラウザ名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.activesession (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.security.activesession
インタフェース
ActiveSessionAccessor
クラス
ActiveSessionBindingListener
ActiveSessionInfo
ActiveSessionManager
GroupActiveSessionRegister
NavigatorInfo
StandardActiveSessionAccessor
UserActiveSessionRegister


jp.co.intra_mart.foundation.security.activesession (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.activesession

インタフェースの概要
ActiveSessionAccessor アクティブなセッション情報操作インターフェース。

クラスの概要
ActiveSessionBindingListener | HttpSessionBindingListener を実装したアクティブなセッション情報を登録または削除するためのイベントトリガークラス。
ActiveSessionInfo | アクティブなセッション情報操作クラス。
ActiveSessionManager | アクティブセッション情報管理マネージャクラス。
GroupActiveSessionRegister | 管理者ログイン認証リスナー実装クラス。
NavigatorInfo | ナビゲータ情報クラス。
StandardActiveSessionAccessor | アクティブなセッション情報操作実装クラス。
UserActiveSessionRegister | ユーザログイン認証リスナー実装クラス。


jp.co.intra_mart.foundation.security.activesession クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.activesession の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.activesession.ActiveSessionBindingListener (implements javax.servlet.http.HttpSessionBindingListener, java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager
    • class jp.co.intra_mart.foundation.security.activesession.GroupActiveSessionRegister (implements jp.co.intra_mart.foundation.security.certification.SuperCertificationListener)
    • class jp.co.intra_mart.foundation.security.activesession.NavigatorInfo
    • class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor (implements jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor)
    • class jp.co.intra_mart.foundation.security.activesession.UserActiveSessionRegister (implements jp.co.intra_mart.foundation.security.certification.UserCertificationListener)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor


パッケージ jp.co.intra_mart.foundation.security.activesession の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.activesession の使用

jp.co.intra_mart.foundation.security.activesession を使用しているパッケージ
jp.co.intra_mart.foundation.security.activesession
jp.co.intra_mart.foundation.security.duplication

jp.co.intra_mart.foundation.security.activesession により使用される jp.co.intra_mart.foundation.security.activesession のクラス
ActiveSessionAccessor
アクティブなセッション情報操作インターフェース。
ActiveSessionInfo
アクティブなセッション情報操作クラス。
NavigatorInfo
ナビゲータ情報クラス。

jp.co.intra_mart.foundation.security.duplication により使用される jp.co.intra_mart.foundation.security.activesession のクラス
ActiveSessionInfo
アクティブなセッション情報操作クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardActiveSessionAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.activesession
クラス StandardActiveSessionAccessor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor
すべての実装インタフェース:
ActiveSessionAccessor
public class StandardActiveSessionAccessor
extends Object
implements ActiveSessionAccessor

アクティブなセッション情報操作実装クラス。

アクティブなセッション情報操作のための実装クラス
本クラスは、任意のログイングループのグループ管理者および一般ユーザ用に使用されることを期待する。

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
static String | DEFAULT_ACCESS_SECURITY_PAGE_PROVIDER_CLASS
static String | DEFAULT_PAGE_LOCATION
コンストラクタの概要
StandardActiveSessionAccessor()
メソッドの概要
void | addActiveSessionInfo(ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報を登録します。
int | count(String groupId) アクティブなすべてのセッション数を取得します。
int | count(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。
int | count(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなすべてのセッション数を取得します。
void | destory(String groupId) アクティブなセッション情報をすべて破棄します。
boolean | exists(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が存在するかどうか取得します。
ActiveSessionInfo | getActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | getActiveSessionInfos(String groupId) アクティブなすべてのセッション情報を取得します。
ActiveSessionInfo[] | getActiveSessionInfos(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | getActiveSessionInfos(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなセッション情報を取得します。
String | getActiveSessionInvalidatedPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 引数で指定されたアクティブなセッション情報が無効化されたされていた場合の遷移先ページURLを取得します。
ActiveSessionInfo | getInvalidatedActiveSessionInfo(String groupId, String sessionId) 無効化されたアクティブなセッション情報を取得します。
void | init(Node defaultNode, Node node) 設定ファイル conf/active-session-config.xml の情報を基に初期化します。
void | invalidate(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
boolean | isObservable() アクティブセッションの監視を行うかどうか取得します。
boolean | isValid(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
void | removeActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を削除します。
ActiveSessionInfo[] | searchActiveSessionInfosByUserId(String groupId, String loginType, String userId) 引数で指定されたユーザ条件からアクティブなセッション情報を検索します。
void | updateLastResponseTime(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。
void | updateToProcessing(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報を処理中に更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_ACCESS_SECURITY_PAGE_PROVIDER_CLASS

public static final String DEFAULT_ACCESS_SECURITY_PAGE_PROVIDER_CLASS
関連項目:
定数フィールド値

DEFAULT_PAGE_LOCATION

public static final String DEFAULT_PAGE_LOCATION
関連項目:
定数フィールド値
コンストラクタの詳細

StandardActiveSessionAccessor

public StandardActiveSessionAccessor()
メソッドの詳細

init

public void init(Node defaultNode,
                 Node node)
          throws ActiveSessionException
設定ファイル conf/active-session-config.xml の情報を基に初期化します。

定義:
インタフェース ActiveSessionAccessor 内の init
パラメータ:
defaultNode - デフォルトノード
node - デフォルトノード
例外:
ActiveSessionException - 初期化処理で例外が発生した場合にスローされます。

isObservable

public boolean isObservable()
アクティブセッションの監視を行うかどうか取得します。

定義:
インタフェース ActiveSessionAccessor 内の isObservable
戻り値:
アクティブセッションの監視を行う場合 true
導入されたバージョン:
6.1.6

addActiveSessionInfo

public void addActiveSessionInfo(ActiveSessionInfo activeSessionInfo)
                          throws ActiveSessionException
引数で指定されたアクティブなセッション情報を登録します。

定義:
インタフェース ActiveSessionAccessor 内の addActiveSessionInfo
パラメータ:
activeSessionInfo - アクティブなセッション情報
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローされます。

removeActiveSessionInfo

public void removeActiveSessionInfo(String groupId,
                                    String sessionId)
                             throws ActiveSessionNotExistException,
                                    ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報を削除します。

定義:
インタフェース ActiveSessionAccessor 内の removeActiveSessionInfo
パラメータ:
groupId - ログイングループID
sessionId - セッションID
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローされます。

destory

public void destory(String groupId)
             throws ActiveSessionException
アクティブなセッション情報をすべて破棄します。

定義:
インタフェース ActiveSessionAccessor 内の destory
パラメータ:
groupId - ログイングループID
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローされます。

invalidate

public void invalidate(String groupId,
                       String sessionId)
                throws ActiveSessionNotExistException,
                       ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報を無効化します。

定義:
インタフェース ActiveSessionAccessor 内の invalidate
パラメータ:
groupId - ログイングループID
sessionId - セッションID
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローされます。

isValid

public boolean isValid(String groupId,
                       String sessionId)
                throws ActiveSessionNotExistException,
                       ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。

定義:
インタフェース ActiveSessionAccessor 内の isValid
パラメータ:
groupId - ログイングループID
sessionId - セッションID
戻り値:
アクティブなセッション情報が有効かどうか
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローされます。

count

public int count(String groupId)
          throws ActiveSessionException
アクティブなすべてのセッション数を取得します。

定義:
インタフェース ActiveSessionAccessor 内の count
パラメータ:
groupId - ログイングループID
戻り値:
アクティブなすべてのセッション数
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローされます。

count

public int count(String groupId,
                 String loginType,
                 String userId)
          throws ActiveSessionException
引数で指定されたユーザのアクティブなすべてのセッション数を取得します。

定義:
インタフェース ActiveSessionAccessor 内の count
パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
userId - ユーザID
戻り値:
アクティブなすべてのセッション数
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローされます。

count

public int count(String groupId,
                 String loginType)
          throws ActiveSessionException
引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。

定義:
インタフェース ActiveSessionAccessor 内の count
パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
戻り値:
アクティブなすべてのセッション数
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

exists

public boolean exists(String groupId,
                      String sessionId)
               throws ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報が存在するかどうか取得します。

定義:
インタフェース ActiveSessionAccessor 内の exists
パラメータ:
groupId - ログイングループID
sessionId - セッションID
戻り値:
アクティブなセッション情報が存在するかどうか
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getActiveSessionInfos

public ActiveSessionInfo[] getActiveSessionInfos(String groupId)
                                          throws ActiveSessionException
アクティブなすべてのセッション情報を取得します。

1件も存在しない場合、戻り値は空の配列となります。 配列の並び順はログイン時刻の昇順となります。

定義:
インタフェース ActiveSessionAccessor 内の getActiveSessionInfos
パラメータ:
groupId - ログイングループID
戻り値:
アクティブなセッション情報一覧
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローされます。

getActiveSessionInfo

public ActiveSessionInfo getActiveSessionInfo(String groupId,
                                              String sessionId)
                                       throws ActiveSessionNotExistException,
                                              ActiveSessionException
引数で指定されたセッションIDのアクティブなセッション情報を取得します。

定義:
インタフェース ActiveSessionAccessor 内の getActiveSessionInfo
パラメータ:
groupId - ログイングループID
sessionId - セッションID
戻り値:
アクティブなセッション情報
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローされます。

getInvalidatedActiveSessionInfo

public ActiveSessionInfo getInvalidatedActiveSessionInfo(String groupId,
                                                         String sessionId)
                                                  throws ActiveSessionNotExistException,
                                                         ActiveSessionException
無効化されたアクティブなセッション情報を取得します。

定義:
インタフェース ActiveSessionAccessor 内の getInvalidatedActiveSessionInfo
パラメータ:
groupId - ログイングループID
sessionId - セッションID
戻り値:
アクティブなセッション情報
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

getActiveSessionInfos

public ActiveSessionInfo[] getActiveSessionInfos(String groupId,
                                                 String loginType,
                                                 String userId)
                                          throws ActiveSessionException
引数で指定されたユーザのアクティブなセッション情報を取得します。

1件も存在しない場合、戻り値は空の配列となります。
配列の並び順はログイン時刻の昇順となります。

定義:
インタフェース ActiveSessionAccessor 内の getActiveSessionInfos
パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
userId - ユーザID
戻り値:
アクティブなセッション情報一覧
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローされます。

getActiveSessionInfos

public ActiveSessionInfo[] getActiveSessionInfos(String groupId,
                                                 String loginType)
                                          throws ActiveSessionException
引数で指定されたログインタイプのアクティブなセッション情報を取得します。

1件も存在しない場合、戻り値は空の配列となります。
配列の並び順はログイン時刻の昇順となります。

定義:
インタフェース ActiveSessionAccessor 内の getActiveSessionInfos
パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
戻り値:
アクティブなセッション情報一覧
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

searchActiveSessionInfosByUserId

public ActiveSessionInfo[] searchActiveSessionInfosByUserId(String groupId,
                                                            String loginType,
                                                            String userId)
                                                     throws ActiveSessionException
引数で指定されたユーザ条件からアクティブなセッション情報を検索します。

ユーザIDに検索条件を指定します。
1件も存在しない場合、戻り値は空の配列となります。
配列の並び順はログイン時刻の昇順となります。

定義:
インタフェース ActiveSessionAccessor 内の searchActiveSessionInfosByUserId
パラメータ:
groupId - ログイングループID
loginType - ログインタイプ
userId - ユーザID
戻り値:
アクティブなセッション情報一覧
例外:
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローします。

updateToProcessing

public void updateToProcessing(String groupId,
                               String sessionId)
                        throws ActiveSessionNotExistException,
                               ActiveSessionException
引数で指定されたアクティブなセッション情報を処理中に更新します。

定義:
インタフェース ActiveSessionAccessor 内の updateToProcessing
パラメータ:
groupId - ログイングループID
sessionId - セッションID
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローされます。

updateLastResponseTime

public void updateLastResponseTime(String groupId,
                                   String sessionId)
                            throws ActiveSessionNotExistException,
                                   ActiveSessionException
引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。

定義:
インタフェース ActiveSessionAccessor 内の updateLastResponseTime
パラメータ:
groupId - ログイングループID
sessionId - セッションID
例外:
ActiveSessionNotExistException - アクティブなセッション情報が存在しない場合にスローされます。
ActiveSessionException - アクティブなセッション情報操作中に例外が発生した場合にスローされます。

getActiveSessionInvalidatedPage

public String getActiveSessionInvalidatedPage(SessionInfo sessionInfo,
                                              HttpServletRequest request,
                                              HttpServletResponse response)
引数で指定されたアクティブなセッション情報が無効化されたされていた場合の遷移先ページURLを取得します。

定義:
インタフェース ActiveSessionAccessor 内の getActiveSessionInvalidatedPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
遷移先ページ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserActiveSessionRegister (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.activesession
クラス UserActiveSessionRegister

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.activesession.UserActiveSessionRegister
すべての実装インタフェース:
UserCertificationListener
public class UserActiveSessionRegister
extends Object
implements UserCertificationListener

ユーザログイン認証リスナー実装クラス。

認証成功時、アクティブなセッション情報を登録します。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
UserActiveSessionRegister()
メソッドの概要
void | doCertification(int certificationResult, LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザの認証後にコールされるメソッドです。
void | init(Map params) ユーザログイン認証リスナーの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserActiveSessionRegister

public UserActiveSessionRegister()
メソッドの詳細

init

public void init(Map params)
ユーザログイン認証リスナーの初期化を行います。

ユーザログイン認証リスナーのインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース UserCertificationListener 内の init
パラメータ:
params - 初期化パラメータのマップ

doCertification

public void doCertification(int certificationResult,
                            LoginInfo loginInfo,
                            Account user,
                            HttpServletRequest request,
                            HttpServletResponse response)
ユーザの認証後にコールされるメソッドです。

認証成功時、アクティブなセッション情報を登録します。

定義:
インタフェース UserCertificationListener 内の doCertification
パラメータ:
certificationResult - 認証結果
認証成功 | SecurityConstraint.CR_OK
認証失敗 | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
loginInfo - ログイン情報
user - ユーザ情報
request - サーブレットリクエスト
response - サーブレットレスポンス
導入されたバージョン:
6.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.admin.SuperUser の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.admin.SuperUser の使用

SuperUser を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession |
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security での SuperUser の使用

SuperUser を返す jp.co.intra_mart.foundation.security のメソッド
 SuperUser SystemManager.getSuperUser()
システム管理者情報を取得します。

SuperUser 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | SystemManager.addSuperUser(SuperUser superUser) システム管理者情報を新規に作成します。
void | SystemManager.updateSuperUser(SuperUser superUser) システム管理者情報を更新します。

jp.co.intra_mart.foundation.security.activesession での SuperUser の使用

SuperUser 型のパラメータを持つ jp.co.intra_mart.foundation.security.activesession のメソッド
 void GroupActiveSessionRegister.doCertification(int certificationResult, LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response)
管理者の認証後にコールされるメソッドです。

jp.co.intra_mart.foundation.security.admin での SuperUser の使用

SuperUser を返す jp.co.intra_mart.foundation.security.admin のメソッド
SuperUser | SuperUserReaderDecorator.doDecoration(SuperUser superUser) システム管理者情報をデータストアからの読み込み直後にコールされます。
SuperUser | SuperUserAccessor.getSuperUser() システム管理者情報を取得します。

SuperUser 型のパラメータを持つ jp.co.intra_mart.foundation.security.admin のメソッド
SuperUser | SuperUserReaderDecorator.doDecoration(SuperUser superUser) システム管理者情報をデータストアからの読み込み直後にコールされます。
void | SuperUserQueryWriterListener.queryCreate(SuperUser superUser) システム管理者情報をデータストアに作成する直前にコールされます。
void | SuperUserQueryWriterListener.queryUpdate(SuperUser superUser) システム管理者情報をデータストアに更新する直前にコールされます。
void | SuperUserPostWriterListener.postCreate(SuperUser superUser) システム管理者情報をデータストアに作成した直後にコールされます。
void | SuperUserPostWriterListener.postUpdate(SuperUser superUser) システム管理者情報をデータストアに更新した直後にコールされます。
void | SuperUserAccessor.insertSuperUser(SuperUser superUser) システム管理者情報を新規追加します。
void | SuperUserAccessor.updateSuperUser(SuperUser superUser) システム管理者情報を更新します。

jp.co.intra_mart.foundation.security.certification での SuperUser の使用

SuperUser 型のパラメータを持つ jp.co.intra_mart.foundation.security.certification のメソッド
int | SuperUserNoCertification.certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証します。
void | SuperCertificationListener.doCertification(int certificationResult, LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者の認証後にコールされるメソッドです。
int | SuperCertification.certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証する。
int | StandardSuperUserCertification.certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証します。

jp.co.intra_mart.foundation.security.group での SuperUser の使用

SuperUser を返す jp.co.intra_mart.foundation.security.group のメソッド
SuperUser | LoginGroupManager.getSuperUser(String groupId) グループ管理者情報を取得します。
SuperUser | GroupSuperUserReaderDecorator.doDecoration(String groupId, SuperUser superUser) アカウントをデータストアからの読み込み直後にコールされます。
SuperUser | GroupSuperUserAccessor.getSuperUser(String groupId) グループ管理者情報を取得します。

SuperUser 型のパラメータを持つ jp.co.intra_mart.foundation.security.group のメソッド
void | LoginGroupManager.addSuperUser(String groupId, SuperUser superUser) グループ管理者を新規追加します。
void | LoginGroupManager.updateSuperUser(String groupId, SuperUser superUser) グループ管理者情報を更新します。
SuperUser | GroupSuperUserReaderDecorator.doDecoration(String groupId, SuperUser superUser) アカウントをデータストアからの読み込み直後にコールされます。
void | GroupSuperUserQueryWriterListener.queryCreate(String groupId, SuperUser superUser) グループ管理者情報をデータストアに作成する直前にコールされます。
void | GroupSuperUserQueryWriterListener.queryUpdate(String groupId, SuperUser superUser) グループ管理者情報をデータストアに更新する直前にコールされます。
void | GroupSuperUserPostWriterListener.postCreate(String groupId, SuperUser superUser) グループ管理者情報をデータストアに作成した直後にコールされます。
void | GroupSuperUserPostWriterListener.postUpdate(String groupId, SuperUser superUser) グループ管理者情報をデータストアに更新した直後にコールされます。
void | GroupSuperUserAccessor.insertSuperUser(String groupId, SuperUser superUser) グループ管理者情報を新規追加します。
void | GroupSuperUserAccessor.updateSuperUser(String groupId, SuperUser superUser) グループ管理者情報を更新します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.admin.SuperUserAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.admin.SuperUserAccessor の使用

jp.co.intra_mart.foundation.security.admin.SuperUserAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener の使用

jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener の使用

jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator の使用

jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.security.admin (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.security.admin
インタフェース
SuperUserAccessor
SuperUserPostWriterListener
SuperUserQueryWriterListener
SuperUserReaderDecorator
クラス
SuperUser


jp.co.intra_mart.foundation.security.admin (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.admin

システム管理者に関連するクラスを提供します。

参照:
説明

インタフェースの概要
SuperUserAccessor | システム管理者アクセッサインタフェース。
SuperUserPostWriterListener | システム管理者情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
SuperUserQueryWriterListener | システム管理者情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
SuperUserReaderDecorator | システム管理者情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

クラスの概要
SuperUser スーパーユーザ・モデルインタフェース。

パッケージ jp.co.intra_mart.foundation.security.admin の説明

システム管理者に関連するクラスを提供します。


jp.co.intra_mart.foundation.security.admin クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.admin の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.admin.SuperUser (implements jp.co.intra_mart.foundation.security.LocaleProvider, java.io.Serializable)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor
  • interface jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener
  • interface jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator


パッケージ jp.co.intra_mart.foundation.security.admin の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.admin の使用

jp.co.intra_mart.foundation.security.admin を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession |
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security により使用される jp.co.intra_mart.foundation.security.admin のクラス
SuperUser
スーパーユーザ・モデルインタフェース。

jp.co.intra_mart.foundation.security.activesession により使用される jp.co.intra_mart.foundation.security.admin のクラス
SuperUser
スーパーユーザ・モデルインタフェース。

jp.co.intra_mart.foundation.security.admin により使用される jp.co.intra_mart.foundation.security.admin のクラス
SuperUser
スーパーユーザ・モデルインタフェース。

jp.co.intra_mart.foundation.security.certification により使用される jp.co.intra_mart.foundation.security.admin のクラス
SuperUser
スーパーユーザ・モデルインタフェース。

jp.co.intra_mart.foundation.security.group により使用される jp.co.intra_mart.foundation.security.admin のクラス
SuperUser
スーパーユーザ・モデルインタフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SuperUser (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.admin
クラス SuperUser

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.admin.SuperUser
すべての実装インタフェース:
LocaleProvider, Serializable
public class SuperUser
extends Object
implements LocaleProvider, Serializable

スーパーユーザ・モデルインタフェース。 スーパーユーザのデータモデルインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
SystemManager, 直列化された形式

コンストラクタの概要
protected | SuperUser() コンストラクタ。
 | SuperUser(String userId) コンストラクタ。
メソッドの概要
boolean | equals(Object superUser) オブジェクトの比較。
String | getEncoding() エンコーディングの取得。
Locale | getLocale() ロケールの取得。
String | getMailAddress() メールアドレス取得。
String | getPassword() パスワード取得。
String | getTelNo() 電話番号取得。
String | getUserId() ユーザID取得。
int | hashCode() ハッシュコード値取得。
void | setEncoding(String encoding) エンコーディングの設定。
void | setLocale(Locale locale) ロケールの設定。
void | setMailAddress(String mailAddress) メールアドレス設定。
void | setPassword(String password) パスワード設定。
void | setTelNo(String telNo) 電話番号設定。
void | setUserId(String id) ユーザID設定。
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SuperUser

protected SuperUser()
コンストラクタ。

SuperUser

public SuperUser(String userId)
コンストラクタ。

パラメータ:
userId - スーパーユーザのユーザID
メソッドの詳細

equals

public boolean equals(Object superUser)
オブジェクトの比較。

指定されたオブジェクトとこのモデルが等しいかどうかを比較します。

パラメータ:
superUser - モデルと等しいかどうかを比較するオブジェクト
戻り値:
指定されたオブジェクトがこのモデルと等しい場合は true
関連項目:
Object.equals(Object)

getEncoding

public String getEncoding()
エンコーディングの取得。

定義:
インタフェース LocaleProvider 内の getEncoding
戻り値:
エンコード
関連項目:
LocaleProvider.getEncoding()

getLocale

public Locale getLocale()
ロケールの取得。

定義:
インタフェース LocaleProvider 内の getLocale
戻り値:
ロケール
関連項目:
LocaleProvider.getLocale()

getMailAddress

public String getMailAddress()
メールアドレス取得。

スーパーユーザのメールアドレスを取得します

戻り値:
メールアドレス
関連項目:
getMailAddress()

getPassword

public String getPassword()
パスワード取得。

スーパーユーザのパスワードを取得します

戻り値:
パスワード
関連項目:
getPassword()

getTelNo

public String getTelNo()
電話番号取得。

スーパーユーザの電話番号を取得します

戻り値:
電話番号
関連項目:
getTelNo()

getUserId

public String getUserId()
ユーザID取得。

スーパーユーザのユーザIDを取得します

戻り値:
ユーザID
関連項目:
getUserId()

hashCode

public int hashCode()
ハッシュコード値取得。

このモデルのハッシュコード値を返します

戻り値:
ハッシュコード
関連項目:
Object.hashCode()

setEncoding

public void setEncoding(String encoding)
エンコーディングの設定。

パラメータ:
encoding - エンコーディング
関連項目:
setEncoding(String)

setLocale

public void setLocale(Locale locale)
ロケールの設定。

パラメータ:
locale - ロケール
関連項目:
setLocale(Locale)

setMailAddress

public void setMailAddress(String mailAddress)
メールアドレス設定。

スーパーユーザのメールアドレスを設定します

パラメータ:
mailAddress - メールアドレス
関連項目:
setMailAddress(String)

setPassword

public void setPassword(String password)
パスワード設定。

スーパーユーザのパスワードを設定します

パラメータ:
password - パスワード
関連項目:
setPassword(String)

setTelNo

public void setTelNo(String telNo)
電話番号設定。

スーパーユーザの電話番号を設定します

パラメータ:
telNo - 電話番号
関連項目:
setTelNo(String)

setUserId

public void setUserId(String id)
ユーザID設定。

スーパーユーザのユーザIDを設定します

パラメータ:
id - ユーザID
関連項目:
setUserId(String)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SuperUserAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.admin
インタフェース SuperUserAccessor

public interface SuperUserAccessor

システム管理者アクセッサインタフェース。

システム管理者情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
SuperUser | getSuperUser() システム管理者情報を取得します。
void | init(Map params) システム管理者アクセッサを初期化します。
void | insertSuperUser(SuperUser superUser) システム管理者情報を新規追加します。
void | updateSuperUser(SuperUser superUser) システム管理者情報を更新します。

メソッドの詳細

getSuperUser

public SuperUser getSuperUser()
                       throws AccessSecurityReadException
システム管理者情報を取得します。

戻り値:
システム管理者情報
例外:
AccessSecurityReadException - システム管理者情報の取得に失敗した場合にスローされます。

init

public void init(Map params)
システム管理者アクセッサを初期化します。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

insertSuperUser

public void insertSuperUser(SuperUser superUser)
                     throws AccessSecurityWriteException,
                            DuplicateException
システム管理者情報を新規追加します。

パラメータ:
superUser - システム管理者情報
例外:
AccessSecurityWriteException - システム管理者情報の作成に失敗した場合にスローされます。
DuplicateException - 追加するシステム管理者が既に存在した場合にスローされます。

updateSuperUser

public void updateSuperUser(SuperUser superUser)
                     throws AccessSecurityWriteException,
                            NotExistException
システム管理者情報を更新します。

パラメータ:
superUser - システム管理者情報
例外:
AccessSecurityWriteException - システム管理者情報の更新に失敗した場合にスローされます。
NotExistException - 更新するシステム管理者が存在しない場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SuperUserPostWriterListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.admin
インタフェース SuperUserPostWriterListener

public interface SuperUserPostWriterListener

システム管理者情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | init(Map params) システム管理者リスナーの初期化。
void | postCreate(SuperUser superUser) システム管理者情報をデータストアに作成した直後にコールされます。
void | postUpdate(SuperUser superUser) システム管理者情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
システム管理者リスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreate

public void postCreate(SuperUser superUser)
                throws AccessSecurityListenerExcpetion
システム管理者情報をデータストアに作成した直後にコールされます。

パラメータ:
superUser - 作成されたシステム管理者情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdate

public void postUpdate(SuperUser superUser)
                throws AccessSecurityListenerExcpetion
システム管理者情報をデータストアに更新した直後にコールされます。

パラメータ:
superUser - 更新されたシステム管理者情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SuperUserQueryWriterListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.admin
インタフェース SuperUserQueryWriterListener

public interface SuperUserQueryWriterListener

システム管理者情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | init(Map params) システム管理者リスナーの初期化。
void | queryCreate(SuperUser superUser) システム管理者情報をデータストアに作成する直前にコールされます。
void | queryUpdate(SuperUser superUser) システム管理者情報をデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
システム管理者リスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreate

public void queryCreate(SuperUser superUser)
                 throws AccessSecurityListenerExcpetion
システム管理者情報をデータストアに作成する直前にコールされます。

パラメータ:
superUser - 作成されるシステム管理者情報
戻り値:
システム管理者情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdate

public void queryUpdate(SuperUser superUser)
                 throws AccessSecurityListenerExcpetion
システム管理者情報をデータストアに更新する直前にコールされます。

パラメータ:
superUser - 更新されるシステム管理者情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SuperUserReaderDecorator (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.admin
インタフェース SuperUserReaderDecorator

public interface SuperUserReaderDecorator

システム管理者情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
SuperUser | doDecoration(SuperUser superUser) システム管理者情報をデータストアからの読み込み直後にコールされます。
void | init(Map params) システム管理者デコレータの初期化。

メソッドの詳細

init

public void init(Map params)
システム管理者デコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public SuperUser doDecoration(SuperUser superUser)
システム管理者情報をデータストアからの読み込み直後にコールされます。

パラメータ:
superUser - 読み込みが行われた管理者情報
戻り値:
拡張された管理者情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.batch.Batch の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.batch.Batch の使用

Batch を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での Batch の使用

Batch を返す jp.co.intra_mart.foundation.security のメソッド
Batch | StandardBatchAccessor.getBatch(String groupId, String batchId) バッチを取得します。
Batch[] | StandardBatchAccessor.getBatches(String groupId) バッチの一覧を取得します。
Batch[] | StandardBatchAccessor.getBatchesByIds(String groupId, String[] batchIds) 引数に指定したバッチIDのバッチ情報をすべて取得します。

Batch 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | StandardBatchAccessor.insertBatch(String groupId, Batch batch) バッチを登録します。
void | StandardBatchAccessor.updateBatch(String groupId, Batch batch) バッチを更新します。

jp.co.intra_mart.foundation.security.batch での Batch の使用

Batch を返す jp.co.intra_mart.foundation.security.batch のメソッド
Batch | BatchReaderDecorator.doDecoration(String groupId, Batch batch) バッチをデータストアからの読み込み直後にコールされます。
Batch | BatchManager.getBatch(String batchId) バッチ情報を取得します。
Batch[] | BatchManager.getBatches() すべてのバッチ情報を取得します。
Batch[] | BatchManager.getBatchesByIds(String[] batchIds) ログイングループ内で引数指定したバッチIDのバッチ情報をすべて取得します。
Batch | BatchAccessor.getBatch(String groupId, String batchId) バッチ情報を取得します。
Batch[] | BatchAccessor.getBatches(String groupId) すべてのバッチ情報を取得します。
Batch[] | BatchAccessor.getBatchesByIds(String groupId, String[] batchIds) 引数に指定したバッチIDのバッチ情報をすべて取得します。

Batch 型のパラメータを持つ jp.co.intra_mart.foundation.security.batch のメソッド
Batch | BatchReaderDecorator.doDecoration(String groupId, Batch batch) バッチをデータストアからの読み込み直後にコールされます。
void | BatchQueryWriterListener.queryCreate(String groupId, Batch batch) バッチ情報をデータストアに作成する直前にコールされます。
void | BatchQueryWriterListener.queryUpdate(String groupId, Batch batch) バッチ情報をデータストアに更新する直前にコールされます。
void | BatchPostWriterListener.postCreate(String groupId, Batch batch) バッチ情報をデータストアに作成した直後にコールされます。
void | BatchPostWriterListener.postUpdate(String groupId, Batch batch) バッチ情報をデータストアに更新した直後にコールされます。
void | BatchManager.addBatch(Batch batch) バッチ情報を新規登録します。
void | BatchManager.updateBatch(Batch batch) バッチ情報を更新します。
void | BatchAccessor.updateBatch(String groupId, Batch batch) バッチ情報を更新します。
void | BatchAccessor.insertBatch(String groupId, Batch batch) バッチ情報を新規に追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.batch.BatchAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.batch.BatchAccessor の使用

BatchAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での BatchAccessor の使用

BatchAccessor を実装している jp.co.intra_mart.foundation.security のクラス
 class StandardBatchAccessor
バッチアクセッサクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.batch.BatchExporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.batch.BatchExporter の使用

BatchExporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.batch バッチに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.batch での BatchExporter の使用

BatchExporter を実装している jp.co.intra_mart.foundation.security.batch のクラス
 class StandardBatchBackup
バッチバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.batch.BatchImporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.batch.BatchImporter の使用

BatchImporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.batch バッチに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.batch での BatchImporter の使用

BatchImporter を実装している jp.co.intra_mart.foundation.security.batch のクラス
 class StandardBatchBackup
バッチバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.batch.BatchManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.batch.BatchManager の使用

BatchManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.batch バッチに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.batch での BatchManager の使用

BatchManager 型のパラメータを持つ jp.co.intra_mart.foundation.security.batch のメソッド
void | BatchImporter.doImport(InputStream inputStream, BatchManager manager) インポートを行います。
void | BatchExporter.doExport(BatchManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardBatchBackup.doImport(InputStream inputStream, BatchManager manager) インポートを行います。
void | StandardBatchBackup.doExport(BatchManager manager, OutputStream outputStream) エクスポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener の使用

jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener の使用

jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator の使用

jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.batch.StandardBatchBackup の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.batch.StandardBatchBackup の使用

jp.co.intra_mart.foundation.security.batch.StandardBatchBackup はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Batch (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
クラス Batch

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.batch.Batch
すべての実装インタフェース:
Serializable
public class Batch
extends Object
implements Serializable

バッチ・モデルクラス

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
BatchManager, 直列化された形式

フィールドの概要
static String | LANG_JAVA プログラム言語(JAVA)。
static String | LANG_JAVA_SCRIPT プログラム言語(JavaScript)。
コンストラクタの概要
Batch()
コンストラクタ。
Batch(String batchId)
コンストラクタ。
メソッドの概要
String | getBatchId() バッチＩＤを取得します。
String | getDescription() バッチ内容を取得します。
String | getName() バッチ名を取得します。
String | getProgramLanguage() 実行プログラム言語を取得します。
String | getProgramPath() 実行プログラムパスを取得します。
int | getRunDay() 実行日を取得します。
int | getRunDayWeek() 実行曜日を取得します。
int | getRunHour() 実行時を取得します。
int | getRunMinute() 実行分を取得します。
int | getRunMonth() 実行月を取得します。
int | getRunSecond() 実行秒を取得します。
int | getRunYear() 実行年を取得します。
boolean | isValidate() 有効・無効フラグを取得します。
protected void | setBatchId(String batchId) バッチＩＤを設定します。
void | setDescription(String description) バッチ内容を設定します。
void | setName(String name) バッチ名を設定します。
void | setProgramLanguage(String programLanguage) 実行プログラム言語の種類を設定します。
void | setProgramPath(String programPath) 実行プログラムパスを設定します。
void | setRunDay(int runDay) 実行日を設定します。
void | setRunDayWeek(int runDayWeek) 実行曜日を設定します。
void | setRunHour(int runHour) 実行時を設定します。
void | setRunMinute(int runMinute) 実行分を設定します。
void | setRunMonth(int runMonth) 実行月を設定します。
void | setRunSecond(int runSecond) 実行秒を設定します。
void | setRunYear(int runYear) 実行年を設定します。
void | setValidate(boolean validFlg) バッチの有効・無効を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

LANG_JAVA

public static final String LANG_JAVA
プログラム言語(JAVA)。
バッチを実行するプログラム言語の種類。

関連項目:
setProgramLanguage(String), 定数フィールド値

LANG_JAVA_SCRIPT

public static final String LANG_JAVA_SCRIPT
プログラム言語(JavaScript)。
バッチを実行するプログラム言語の種類。

関連項目:
setProgramLanguage(String), 定数フィールド値
コンストラクタの詳細

Batch

public Batch()
コンストラクタ。

バッチIDは自動採番されます。

Batch

public Batch(String batchId)
コンストラクタ。

パラメータ:
batchId - バッチID
メソッドの詳細

getBatchId

public String getBatchId()
バッチＩＤを取得します。

戻り値:
バッチＩＤ

getDescription

public String getDescription()
バッチ内容を取得します。

戻り値:
バッチ内容

getName

public String getName()
バッチ名を取得します。

戻り値:
バッチ名

getProgramLanguage

public String getProgramLanguage()
実行プログラム言語を取得します。
(java/js)

戻り値:
実行プログラム言語

getProgramPath

public String getProgramPath()
実行プログラムパスを取得します。

戻り値:
実行プログラムパス

getRunDay

public int getRunDay()
実行日を取得します。

戻り値:
実行日

getRunDayWeek

public int getRunDayWeek()
実行曜日を取得します。

戻り値:
曜日

getRunHour

public int getRunHour()
実行時を取得します。

戻り値:
実行時

getRunMinute

public int getRunMinute()
実行分を取得します。

戻り値:
実行分

getRunMonth

public int getRunMonth()
実行月を取得します。

戻り値:
実行月

getRunSecond

public int getRunSecond()
実行秒を取得します。

戻り値:
実行秒

getRunYear

public int getRunYear()
実行年を取得します。

戻り値:
実行年

isValidate

public boolean isValidate()
有効・無効フラグを取得します。

戻り値:
有効/無効

setBatchId

protected void setBatchId(String batchId)
バッチＩＤを設定します。

パラメータ:
batchId - バッチＩＤ

setDescription

public void setDescription(String description)
バッチ内容を設定します。

パラメータ:
description - バッチ内容

setName

public void setName(String name)
バッチ名を設定します。

パラメータ:
name - バッチ名

setProgramLanguage

public void setProgramLanguage(String programLanguage)
実行プログラム言語の種類を設定します。

設定できる値は、JavaScript( LANG_JAVA_SCRIPT)または、java( LANG_JAVA)のいずれかです。
デフォルトは、JavaScriptです。

パラメータ:
programLanguage - 実行プログラム言語

setProgramPath

public void setProgramPath(String programPath)
実行プログラムパスを設定します。 実行プログラム言語がJavaScriptである場合は、pages以下のパスを設定してください。 実行プログラム言語がjavaである場合は、クラスのフルパッケージ名を設定してください。

パラメータ:
programPath - 実行プログラムパス
関連項目:
getProgramLanguage()

setRunDay

public void setRunDay(int runDay)
実行日を設定します。

設定できる値は、-1,１～３１です。
範囲外の値を設定した場合は、-1に設定されます。
-1を設定した場合は、毎日実行されます。

パラメータ:
runDay - 実行日

setRunDayWeek

public void setRunDayWeek(int runDayWeek)
実行曜日を設定します。

設定できる値は、0(日曜日)から6(土曜日)までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。
実行日が設定されいる場合は、この設定は無視されます。

パラメータ:
runDayWeek - 曜日

setRunHour

public void setRunHour(int runHour)
実行時を設定します。

設定できる値は、-1,０～２３です。
範囲外の値を設定した場合は、-1に設定されます。
-1を設定した場合は、毎時実行されます。

パラメータ:
runHour - 実行時

setRunMinute

public void setRunMinute(int runMinute)
実行分を設定します。

設定できる値は、-1,０～５９です。
範囲外の値を設定した場合は、-1に設定されます。
-1を設定した場合は、毎分実行されます。

パラメータ:
runMinute - 実行分

setRunMonth

public void setRunMonth(int runMonth)
実行月を設定します。

設定できる値は、-1,１～１２です。
範囲外の値を設定した場合は、-1に設定されます。
-1を設定した場合は、毎月実行されます。

パラメータ:
runMonth - 実行月

setRunSecond

public void setRunSecond(int runSecond)
実行秒を設定します。

設定できる値は、-1,０～５９です。
範囲外の値を設定した場合は、-1に設定されます。
-1を設定した場合は、毎秒実行されます。

パラメータ:
runSecond - 実行秒

setRunYear

public void setRunYear(int runYear)
実行年を設定します。

設定できる値は、-1,０～です。
-1以下を設定した場合は、-1に設定されます。
-1を設定した場合は、毎年実行されます。

パラメータ:
runYear - 実行年

setValidate

public void setValidate(boolean validFlg)
バッチの有効・無効を設定します。

パラメータ:
validFlg - 有効/無効
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BatchAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
インタフェース BatchAccessor

既知の実装クラスの一覧:
StandardBatchAccessor
public interface BatchAccessor

メソッドの概要
void | deleteBatch(String groupId, String batchId) バッチ情報を削除します。
Batch | getBatch(String groupId, String batchId) バッチ情報を取得します。
Batch[] | getBatches(String groupId) すべてのバッチ情報を取得します。
Batch[] | getBatchesByIds(String groupId, String[] batchIds) 引数に指定したバッチIDのバッチ情報をすべて取得します。
String[] | getBatchIds(String groupId) すべてのバッチIDを取得します。
void | init(Map params) アクセッサの初期化。
void | insertBatch(String groupId, Batch batch) バッチ情報を新規に追加します。
void | updateBatch(String groupId, Batch batch) バッチ情報を更新します。

メソッドの詳細

deleteBatch

public void deleteBatch(String groupId,
                        String batchId)
                 throws AccessSecurityWriteException,
                        NotExistException
バッチ情報を削除します。

パラメータ:
groupId - ログイングループID
batchId - 削除するバッチID
例外:
AccessSecurityWriteException - バッチ情報の削除に失敗した場合スローされます。
NotExistException - 削除するバッチ情報が存在しない場合スローされます。

updateBatch

public void updateBatch(String groupId,
                        Batch batch)
                 throws AccessSecurityWriteException,
                        NotExistException
バッチ情報を更新します。

パラメータ:
groupId - ログイングループID
batch - 更新するバッチ
例外:
AccessSecurityWriteException - バッチ情報の更新に失敗した場合スローされます。
NotExistException - 削除するバッチ情報が存在しない場合スローされます。

insertBatch

public void insertBatch(String groupId,
                        Batch batch)
                 throws AccessSecurityWriteException,
                        DuplicateException
バッチ情報を新規に追加します。

パラメータ:
groupId - ログイングループID
batch - 新規登録するバッチ
例外:
AccessSecurityWriteException - バッチ情報の新規登録に失敗した場合スローされます。
DuplicateException - 追加するバッチ情報が既に存在した場合スローされます。

getBatch

public Batch getBatch(String groupId,
                      String batchId)
               throws AccessSecurityReadException
バッチ情報を取得します。

パラメータ:
groupId - ログイングループID
batchId - バッチＩＤ
戻り値:
取得されたバッチ
例外:
AccessSecurityReadException - バッチ情報の取得に失敗した場合スローされます。

getBatches

public Batch[] getBatches(String groupId)
                   throws AccessSecurityReadException
すべてのバッチ情報を取得します。 一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
戻り値:
取得されたバッチ
例外:
AccessSecurityReadException - バッチ情報の取得に失敗した場合スローされます。

getBatchesByIds

public Batch[] getBatchesByIds(String groupId,
                               String[] batchIds)
                        throws AccessSecurityReadException
引数に指定したバッチIDのバッチ情報をすべて取得します。
一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
batchIds - バッチＩＤの配列
戻り値:
取得されたバッチの配列
例外:
AccessSecurityReadException - バッチ情報の取得に失敗した場合スローされます。

getBatchIds

public String[] getBatchIds(String groupId)
                     throws AccessSecurityReadException
すべてのバッチIDを取得します。
一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
戻り値:
バッチIDの配列
例外:
AccessSecurityReadException - バッチ情報の取得に失敗した場合スローされます。

init

public void init(Map params)
アクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BatchExporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
インタフェース BatchExporter

既知の実装クラスの一覧:
StandardBatchBackup
public interface BatchExporter

バッチバックアップインタフェースです。

バージョン:
1.0

メソッドの概要
void | doExport(BatchManager manager, OutputStream outputStream) エクスポートを行います。
void | init(Map params) バッチバックアップエクスポータの初期化。

メソッドの詳細

init

public void init(Map params)
バッチバックアップエクスポータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doExport

public void doExport(BatchManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

バッチ情報をバックアップファイルに出力します。

パラメータ:
manager - バッチマネージャ バッチモデルクラスの配列
outputStream - 出力ストリーム
例外:
AccessSecurityExportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BatchImporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
インタフェース BatchImporter

既知の実装クラスの一覧:
StandardBatchBackup
public interface BatchImporter

バッチバックアップインタフェースです。

バージョン:
1.0

メソッドの概要
void | doImport(InputStream inputStream, BatchManager manager) インポートを行います。
void | init(Map params) バッチバックアップインポータの初期化。

メソッドの詳細

init

public void init(Map params)
バッチバックアップインポータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     BatchManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からバッチ情報を取得し、生成します。

パラメータ:
manager - バッチマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BatchManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
クラス BatchManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.batch.BatchManager
public class BatchManager
extends Object

バッチマネージャクラス。

バッチ情報の操作を行います。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
Batch

コンストラクタの概要
BatchManager(String groupId)
コンストラクタ。
メソッドの概要
void | addBatch(Batch batch) バッチ情報を新規登録します。
static void | clearInstance() バッチマネージャのインスタンスを初期化します。
void | deleteBatch(String batchId) バッチ情報を削除します。
void | deleteBatches() すべてのバッチ情報を削除します。
void | exportData(String category, OutputStream outputStream) エクスポートを行います。
Batch | getBatch(String batchId) バッチ情報を取得します。
Batch[] | getBatches() すべてのバッチ情報を取得します。
Batch[] | getBatchesByIds(String[] batchIds) ログイングループ内で引数指定したバッチIDのバッチ情報をすべて取得します。
String[] | getBatchIds() バッチIDの一覧を取得します。
String[] | getExportCategories() バッチエクスポート用のカテゴリの一覧を取得します。
String[] | getImportCategories() バッチインポート用のカテゴリの一覧を取得します。
String | getLoginGroupId() ログイングループIDを取得します。
void | importData(String category, InputStream inputStream) インポートを行います。
boolean | isUpdate(Date date) バッチ情報が指定された日付よりも新しいかチェックします。
void | updateBatch(Batch batch) バッチ情報を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BatchManager

public BatchManager(String groupId)
             throws AccessSecurityException
コンストラクタ。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityException - ログイングループIDが不正な場合にスローされます。
導入されたバージョン:
5.0
メソッドの詳細

clearInstance

public static void clearInstance()
バッチマネージャのインスタンスを初期化します。

アクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。
通常、このメソッドを使用する必要はありません。

addBatch

public void addBatch(Batch batch)
              throws AccessSecurityException
バッチ情報を新規登録します。

パラメータ:
batch - 新規登録するバッチ
例外:
AccessSecurityException - バッチ情報の新規登録に失敗した場合、または引数が不正だった場合にスローされます。

deleteBatch

public void deleteBatch(String batchId)
                 throws AccessSecurityException
バッチ情報を削除します。

パラメータ:
batchId - 削除するバッチID
例外:
AccessSecurityException - バッチ情報の削除に失敗した場合、または引数が不正だった場合にスローされます。

deleteBatches

public void deleteBatches()
                   throws AccessSecurityException
すべてのバッチ情報を削除します。

例外:
AccessSecurityException - バッチ情報の削除に失敗した場合、または引数が不正だった場合にスローされます。

exportData

public void exportData(String category,
                       OutputStream outputStream)
                throws AccessSecurityException
エクスポートを行います。

パラメータ:
category - カテゴリ名
outputStream - 出力ストリーム
例外:
AccessSecurityException - エクスポートに失敗した場合、または引数が不正だった場合にスローされます。

getBatch

public Batch getBatch(String batchId)
               throws AccessSecurityException
バッチ情報を取得します。

パラメータ:
batchId - バッチＩＤ
戻り値:
取得されたバッチ
例外:
AccessSecurityException - バッチ情報の取得に失敗した場合、または引数が不正だった場合にスローされます。

getBatches

public Batch[] getBatches()
                   throws AccessSecurityException
すべてのバッチ情報を取得します。

戻り値:
取得されたバッチ
例外:
AccessSecurityException - バッチ情報の取得に失敗した場合にスローされます。

getBatchesByIds

public Batch[] getBatchesByIds(String[] batchIds)
                        throws AccessSecurityException
ログイングループ内で引数指定したバッチIDのバッチ情報をすべて取得します。

パラメータ:
batchIds - バッチIDの配列
戻り値:
バッチ情報の配列（データがない場合は空の配列を返します。）
例外:
AccessSecurityException - バッチ情報の取得に失敗した場合にスローされます。

getBatchIds

public String[] getBatchIds()
                     throws AccessSecurityException
バッチIDの一覧を取得します。

戻り値:
バッチIDの配列
例外:
AccessSecurityException - バッチ情報の取得に失敗した場合にスローされます。

getExportCategories

public String[] getExportCategories()
                             throws AccessSecurityException
バッチエクスポート用のカテゴリの一覧を取得します。

戻り値:
バッチエクスポート用カテゴリの一覧
例外:
AccessSecurityException - バッチエクスポート用のカテゴリの取得に失敗した場合にスローされます。

getImportCategories

public String[] getImportCategories()
                             throws AccessSecurityException
バッチインポート用のカテゴリの一覧を取得します。

戻り値:
バッチインポート用カテゴリの一覧
例外:
AccessSecurityException - バッチインポート用のカテゴリの取得に失敗した場合にスローされます。

importData

public void importData(String category,
                       InputStream inputStream)
                throws AccessSecurityException
インポートを行います。

パラメータ:
category - カテゴリ名
inputStream - 入力ストリーム
例外:
AccessSecurityException - インポートに失敗した場合、または引数が不正だった場合にスローされます。

updateBatch

public void updateBatch(Batch batch)
                 throws AccessSecurityException
バッチ情報を更新します。

パラメータ:
batch - 更新するバッチ
例外:
AccessSecurityException - バッチ情報の更新に失敗した場合、または引数が不正だった場合にスローされます。

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

戻り値:
ログイングループID

isUpdate

public boolean isUpdate(Date date)
                 throws AccessSecurityException
バッチ情報が指定された日付よりも新しいかチェックします。

パラメータ:
date - チェック日付
例外:
AccessSecurityReadException - 更新チェックに失敗した場合スローされます。
AccessSecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BatchPostWriterListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
インタフェース BatchPostWriterListener

public interface BatchPostWriterListener

メソッドの概要
void | init(Map params) バッチリスナーの初期化。
void | postCreate(String groupId, Batch batch) バッチ情報をデータストアに作成した直後にコールされます。
void | postDelete(String groupId, String batchId) バッチ情報をデータストアから削除した直後にコールされます。
void | postUpdate(String groupId, Batch batch) バッチ情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
バッチリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreate

public void postCreate(String groupId,
                       Batch batch)
                throws AccessSecurityListenerExcpetion
バッチ情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
batch - 作成されたバッチ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDelete

public void postDelete(String groupId,
                       String batchId)
                throws AccessSecurityListenerExcpetion
バッチ情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
batchId - 削除されたバッチId
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdate

public void postUpdate(String groupId,
                       Batch batch)
                throws AccessSecurityListenerExcpetion
バッチ情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
batch - 更新されたバッチ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BatchQueryWriterListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
インタフェース BatchQueryWriterListener

public interface BatchQueryWriterListener

メソッドの概要
void | init(Map params) バッチリスナーの初期化。
void | queryCreate(String groupId, Batch batch) バッチ情報をデータストアに作成する直前にコールされます。
void | queryDelete(String groupId, String batchId) バッチ情報をデータストアから削除する直前にコールされます。
void | queryUpdate(String groupId, Batch batch) バッチ情報をデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
バッチリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreate

public void queryCreate(String groupId,
                        Batch batch)
                 throws AccessSecurityListenerExcpetion
バッチ情報をデータストアに作成する直前にコールされます。

パラメータ:
groupId - ログイングループID
batch - 作成されるバッチ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDelete

public void queryDelete(String groupId,
                        String batchId)
                 throws AccessSecurityListenerExcpetion
バッチ情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
batchId - 削除されるバッチID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdate

public void queryUpdate(String groupId,
                        Batch batch)
                 throws AccessSecurityListenerExcpetion
バッチ情報をデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
batch - 更新されるバッチ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BatchReaderDecorator (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
インタフェース BatchReaderDecorator

public interface BatchReaderDecorator

メソッドの概要
Batch | doDecoration(String groupId, Batch batch) バッチをデータストアからの読み込み直後にコールされます。
void | init(Map params) バッチデコレータの初期化。

メソッドの詳細

init

public void init(Map params)
バッチデコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public Batch doDecoration(String groupId,
                          Batch batch)
バッチをデータストアからの読み込み直後にコールされます。

パラメータ:
groupId - ログイングループID
batch - 読み込みが行われたバッチ情報
戻り値:
拡張されたバッチ情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.batch (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.security.batch
インタフェース
BatchAccessor
BatchExporter
BatchImporter
BatchPostWriterListener
BatchQueryWriterListener
BatchReaderDecorator
クラス
Batch
BatchManager
StandardBatchBackup


jp.co.intra_mart.foundation.security.batch (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.batch

バッチに関連するクラスを提供します。

参照:
説明

インタフェースの概要
BatchAccessor |
BatchExporter | バッチバックアップインタフェースです。
BatchImporter | バッチバックアップインタフェースです。
BatchPostWriterListener |
BatchQueryWriterListener |
BatchReaderDecorator |

クラスの概要
Batch | バッチ・モデルクラス
BatchManager | バッチマネージャクラス。
StandardBatchBackup | バッチバックアップクラスです。

パッケージ jp.co.intra_mart.foundation.security.batch の説明

バッチに関連するクラスを提供します。


jp.co.intra_mart.foundation.security.batch クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.batch の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.batch.Batch (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.batch.BatchManager
    • class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup (implements jp.co.intra_mart.foundation.security.batch.BatchExporter, jp.co.intra_mart.foundation.security.batch.BatchImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.batch.BatchAccessor
  • interface jp.co.intra_mart.foundation.security.batch.BatchExporter
  • interface jp.co.intra_mart.foundation.security.batch.BatchImporter
  • interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener
  • interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator


パッケージ jp.co.intra_mart.foundation.security.batch の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.batch の使用

jp.co.intra_mart.foundation.security.batch を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。

jp.co.intra_mart.foundation.security により使用される jp.co.intra_mart.foundation.security.batch のクラス
Batch
バッチ・モデルクラス
BatchAccessor

jp.co.intra_mart.foundation.security.batch により使用される jp.co.intra_mart.foundation.security.batch のクラス
Batch
バッチ・モデルクラス
BatchExporter
バッチバックアップインタフェースです。
BatchImporter
バッチバックアップインタフェースです。
BatchManager
バッチマネージャクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardBatchBackup (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
クラス StandardBatchBackup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.batch.StandardBatchBackup
すべての実装インタフェース:
BatchExporter, BatchImporter
public class StandardBatchBackup
extends Object
implements BatchImporter, BatchExporter

バッチバックアップクラスです。

バージョン:
1.0

コンストラクタの概要
StandardBatchBackup()
メソッドの概要
void | doExport(BatchManager manager, OutputStream outputStream) エクスポートを行います。
void | doImport(InputStream inputStream, BatchManager manager) インポートを行います。
void | init(Map params) バッチバックアップの初期化。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardBatchBackup

public StandardBatchBackup()
メソッドの詳細

init

public void init(Map params)
バッチバックアップの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース BatchImporter 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     BatchManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からバッチ情報を生成します。

定義:
インタフェース BatchImporter 内の doImport
パラメータ:
manager - バッチマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

doExport

public void doExport(BatchManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

バッチバックアップ情報を生成し、ストリームに返却します。

定義:
インタフェース BatchExporter 内の doExport
パラメータ:
manager - バッチマネージャ
outputStream - 出力ストリーム
例外:
AccessSecurityExportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.security.calendar.CalendarAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.CalendarAccessor の使用

CalendarAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での CalendarAccessor の使用

CalendarAccessor を実装している jp.co.intra_mart.foundation.security のクラス
 class StandardCalendarAccessor
カレンダーアクセッサクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.calendar.CalendarExporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.CalendarExporter の使用

CalendarExporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.calendar カレンダーに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.calendar での CalendarExporter の使用

CalendarExporter を実装している jp.co.intra_mart.foundation.security.calendar のクラス
 class StandardCalendarBackup
カレンダーバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.calendar.CalendarImporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.CalendarImporter の使用

CalendarImporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.calendar カレンダーに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.calendar での CalendarImporter の使用

CalendarImporter を実装している jp.co.intra_mart.foundation.security.calendar のクラス
 class StandardCalendarBackup
カレンダーバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.CalendarInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.CalendarInfo の使用

CalendarInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での CalendarInfo の使用

CalendarInfo を返す jp.co.intra_mart.foundation.security のメソッド
CalendarInfo | StandardCalendarAccessor.getCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータを取得します。
CalendarInfo[] | StandardCalendarAccessor.getCalendarInfos(String groupId, String calendarId) すべてのカレンダーデータを取得します。
CalendarInfo[] | StandardCalendarAccessor.getCalendarInfosByIds(String groupId, String calendarId, String[] calendarInfoIds) 指定されたカレンダーデータIDのカレンダー情報をすべて取得する。

CalendarInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | StandardCalendarAccessor.insertCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に作成します。
void | StandardCalendarAccessor.updateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。

jp.co.intra_mart.foundation.security.calendar での CalendarInfo の使用

CalendarInfo を返す jp.co.intra_mart.foundation.security.calendar のメソッド
CalendarInfo[] | DayInfo.getCalendarInfo() マッチしたカレンダーデータの一覧を取得します。
CalendarInfo[] | CategorizedCalendarInfo.getConfigDayInfos() データタイプが名称であるカレンダーデータの一覧を取得します。
CalendarInfo[] | CategorizedCalendarInfo.getHodildayInfos() データタイプが休日であるカレンダーデータの一覧を取得します。
CalendarInfo[] | CategorizedCalendarInfo.getNationalHodildayInfos() データタイプが祝祭日であるカレンダーデータの一覧を取得します。
CalendarInfo[] | CategorizedCalendarInfo.getWeekdayInfos() データタイプが非休日であるカレンダーデータの一覧を取得します。
CalendarInfo | CalendarReaderDecorator.doDecoration(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアからの読み込み直後にコールされます。
CalendarInfo | CalendarManager.getCalendarInfo(String calendarId, String dataId) カレンダーデータを取得します。
CalendarInfo[] | CalendarManager.getCalendarInfos(String calendarId) すべてのカレンダーデータを取得します。
CalendarInfo[] | CalendarManager.getCalendarInfosByIds(String calendarId, String[] calendarInfoIds) ログイングループ内で引数指定したカレンダーデータIDのカレンダーをすべて取得します。
CalendarInfo | CalendarAccessor.getCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータを取得します。
CalendarInfo[] | CalendarAccessor.getCalendarInfos(String groupId, String calendarId) すべてのカレンダーデータを取得します。
CalendarInfo[] | CalendarAccessor.getCalendarInfosByIds(String groupId, String calendarId, String[] calendarInfoIds) 指定されたカレンダIDのカレンダ情報をすべて取得する。

CalendarInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.calendar のメソッド
CalendarInfo | CalendarReaderDecorator.doDecoration(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアからの読み込み直後にコールされます。
void | CalendarQueryWriterListener.queryCreateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに作成する直前にコールされます。
void | CalendarQueryWriterListener.queryUpdateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに更新する直前にコールされます。
void | CalendarPostWriterListener.postCreateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに作成した直後にコールされます。
void | CalendarPostWriterListener.postUpdateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに更新した直後にコールされます。
boolean | CalendarPluginVernalEquinox.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginMondayMakeupHoliday.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginLastDayInTheMonth.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginEndOfTheMonth.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginAutumnalEquinox.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPlugin.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
void | CalendarManager.addCalendarInfo(String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に追加します。
void | CalendarManager.updateCalendarInfo(String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。
void | CalendarAccessor.insertCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に作成します。
void | CalendarAccessor.updateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。

CalendarInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.calendar のコンストラクタ
CategorizedCalendarInfo(CalendarInfo[] calendarInfos)
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.CalendarManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.CalendarManager の使用

CalendarManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.calendar カレンダーに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.calendar での CalendarManager の使用

CalendarManager 型のパラメータを持つ jp.co.intra_mart.foundation.security.calendar のメソッド
boolean | CalendarPluginVernalEquinox.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginMondayMakeupHoliday.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginLastDayInTheMonth.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginEndOfTheMonth.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginAutumnalEquinox.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPlugin.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
void | CalendarImporter.doImport(InputStream inputStream, CalendarManager manager) インポートを行います。
void | CalendarExporter.doExport(CalendarManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardCalendarBackup.doImport(InputStream inputStream, CalendarManager manager) インポートを行います。
void | StandardCalendarBackup.doExport(CalendarManager manager, OutputStream outputStream) エクスポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.calendar.CalendarPlugin の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.CalendarPlugin の使用

CalendarPlugin を使用しているパッケージ
jp.co.intra_mart.foundation.security.calendar カレンダーに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.calendar での CalendarPlugin の使用

CalendarPlugin を実装している jp.co.intra_mart.foundation.security.calendar のクラス
class | CalendarPluginAutumnalEquinox カレンダデータプラグインクラス。
class | CalendarPluginEndOfTheMonth カレンダデータプラグインクラス。
class | CalendarPluginLastDayInTheMonth カレンダデータプラグインクラス。
class | CalendarPluginMondayMakeupHoliday カレンダデータプラグインクラス。
class | CalendarPluginVernalEquinox カレンダデータプラグインクラス。

CalendarPlugin を返す jp.co.intra_mart.foundation.security.calendar のメソッド
 CalendarPlugin CalendarManager.getPlugin(String pluginId)
カレンダーデータプラグインを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox の使用

jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth の使用

jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo の使用

jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth の使用

jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday の使用

jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox の使用

jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener の使用

jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener の使用

jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator の使用

jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo の使用

CategorizedCalendarInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security.calendar カレンダーに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.calendar での CategorizedCalendarInfo の使用

CategorizedCalendarInfo を返す jp.co.intra_mart.foundation.security.calendar のメソッド
 CategorizedCalendarInfo CalendarManager.getCategorizedCalendarInfos(String calendarId)
すべてのカレンダーデータをデータタイプ別に分類して取得します。

CategorizedCalendarInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.calendar のメソッド
boolean | CalendarPluginVernalEquinox.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginMondayMakeupHoliday.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginLastDayInTheMonth.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginEndOfTheMonth.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginAutumnalEquinox.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPlugin.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
DayInfo | CalendarManager.getDayInfo(CategorizedCalendarInfo categorizedCalendarInfo, Date date) 日付情報を取得します。
DayInfo[] | CalendarManager.getMonthInfos(CategorizedCalendarInfo categorizedCalendarInfo, int year, int month) 月情報を取得します。
boolean | CalendarManager.isHoliday(String calendarId, CategorizedCalendarInfo categorizedCalendarInfo, Date date) 休日かどうか判定します。
boolean | CalendarManager.isNationalHoliday(CategorizedCalendarInfo categorizedCalendarInfo, Date date) 祝日かどうか判定します。
boolean | CalendarManager.isWeekday(String calendarId, CategorizedCalendarInfo categorizedCalendarInfo, Date date) 平日かどうか判定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.calendar.DayInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.DayInfo の使用

DayInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security.calendar カレンダーに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.calendar での DayInfo の使用

DayInfo を返す jp.co.intra_mart.foundation.security.calendar のメソッド
DayInfo | CalendarManager.getDayInfo(CategorizedCalendarInfo categorizedCalendarInfo, Date date) 日付情報を取得します。
DayInfo[] | CalendarManager.getMonthInfos(CategorizedCalendarInfo categorizedCalendarInfo, int year, int month) 月情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup の使用

jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CalendarAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース CalendarAccessor

既知の実装クラスの一覧:
StandardCalendarAccessor
public interface CalendarAccessor

カレンダーアクセッサインタフェース。

カレンダー情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | deleteCalendar(String groupId, String calendarId) カレンダーを削除します。
void | deleteCalendarInfo(String groupId, String calendarId, String dataId) 指定されたカレンダーデータを削除します。
String[] | getCalendarIds(String groupId) すべてのカレンダーIDを取得します。
CalendarInfo | getCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータを取得します。
String[] | getCalendarInfoIds(String groupId, String calendarId) すべてのカレンダーデータIDを取得します。
CalendarInfo[] | getCalendarInfos(String groupId, String calendarId) すべてのカレンダーデータを取得します。
CalendarInfo[] | getCalendarInfosByIds(String groupId, String calendarId, String[] calendarInfoIds) 指定されたカレンダIDのカレンダ情報をすべて取得する。
void | init(Map params) カレンダーアクセッサの初期化。
void | insertCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に作成します。
void | updateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。

メソッドの詳細

deleteCalendar

public void deleteCalendar(String groupId,
                           String calendarId)
                    throws AccessSecurityWriteException,
                           NotExistException
カレンダーを削除します。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
例外:
AccessSecurityWriteException
NotExistException

deleteCalendarInfo

public void deleteCalendarInfo(String groupId,
                               String calendarId,
                               String dataId)
                        throws AccessSecurityWriteException,
                               NotExistException
指定されたカレンダーデータを削除します。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
dataId - カレンダーデータID
例外:
AccessSecurityWriteException
NotExistException

getCalendarIds

public String[] getCalendarIds(String groupId)
                        throws AccessSecurityReadException
すべてのカレンダーIDを取得します。
カレンダーIDが存在しない場合は空の配列を返却します。

パラメータ:
groupId - ログイングループID
戻り値:
カレンダーIDの配列
例外:
AccessSecurityReadException

getCalendarInfo

public CalendarInfo getCalendarInfo(String groupId,
                                    String calendarId,
                                    String dataId)
                             throws AccessSecurityReadException
カレンダーデータを取得します。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
dataId - カレンダーデータID
戻り値:
カレンダーデータ
例外:
AccessSecurityReadException

getCalendarInfoIds

public String[] getCalendarInfoIds(String groupId,
                                   String calendarId)
                            throws AccessSecurityReadException
すべてのカレンダーデータIDを取得します。
カレンダーデータIDが存在しない場合は空の配列を返却します。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
戻り値:
カレンダーデータIDの配列
例外:
AccessSecurityReadException

getCalendarInfos

public CalendarInfo[] getCalendarInfos(String groupId,
                                       String calendarId)
                                throws AccessSecurityReadException
すべてのカレンダーデータを取得します。

カレンダーデータが存在しない場合は空の配列を返却します。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
戻り値:
カレンダーデータの配列
例外:
AccessSecurityReadException

getCalendarInfosByIds

public CalendarInfo[] getCalendarInfosByIds(String groupId,
                                            String calendarId,
                                            String[] calendarInfoIds)
                                     throws AccessSecurityReadException
指定されたカレンダIDのカレンダ情報をすべて取得する。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfoIds - カレンダーデータIDの配列
戻り値:
カレンダオブジェクトの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - カレンダ情報取得に失敗した場合スローされます。

init

public void init(Map params)
カレンダーアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

insertCalendarInfo

public void insertCalendarInfo(String groupId,
                               String calendarId,
                               CalendarInfo calendarInfo)
                        throws AccessSecurityWriteException,
                               DuplicateException
カレンダーデータを新規に作成します。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfo - カレンダーデータ
例外:
AccessSecurityWriteException
DuplicateException

updateCalendarInfo

public void updateCalendarInfo(String groupId,
                               String calendarId,
                               CalendarInfo calendarInfo)
                        throws AccessSecurityWriteException,
                               NotExistException
カレンダーデータを更新します。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfo - カレンダーデータ
例外:
AccessSecurityWriteException
NotExistException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CalendarExporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース CalendarExporter

既知の実装クラスの一覧:
StandardCalendarBackup
public interface CalendarExporter

カレンダーバックアップインタフェースです。

バージョン:
1.0

メソッドの概要
void | doExport(CalendarManager manager, OutputStream outputStream) エクスポートを行います。
void | init(Map params) カレンダーバックアップエクスポータの初期化。

メソッドの詳細

init

public void init(Map params)
カレンダーバックアップエクスポータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doExport

public void doExport(CalendarManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

カレンダーとカレンダー情報を
バックアップファイルに出力します。

パラメータ:
manager - カレンダーマネージャクラス
outputStream - 出力ストリーム
例外:
AccessSecurityExportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarImporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース CalendarImporter

既知の実装クラスの一覧:
StandardCalendarBackup
public interface CalendarImporter

カレンダーバックアップインタフェースです。

バージョン:
1.0

メソッドの概要
void | doImport(InputStream inputStream, CalendarManager manager) インポートを行います。
void | init(Map params) カレンダーバックアップインポータの初期化。

メソッドの詳細

init

public void init(Map params)
カレンダーバックアップインポータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     CalendarManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からカレンダーと
付随するカレンダー情報を取得し、生成します。

パラメータ:
manager - カレンダーマネージャクラス
inputStream - 入力ストリーム
戻り値:
バッチモデルクラスの配列
例外:
AccessSecurityImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス CalendarInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.CalendarInfo
すべての実装インタフェース:
Serializable
public class CalendarInfo
extends Object
implements Serializable

カレンダーデータ・モデルクラス

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
CalendarManager, 直列化された形式

フィールドの概要
static String | TYPE_CONFIG 名称（データタイプの定数）。
static String | TYPE_HOLIDAY 休日（データタイプの定数）。
static String | TYPE_NATIONAL_HOLDAY 祝祭日（データタイプの定数）。
static String | TYPE_WEEKDAY 非休日（データタイプの定数）。
コンストラクタの概要
CalendarInfo()
コンストラクタ。
CalendarInfo(String dataId)
コンストラクタ。
メソッドの概要
String | getColor() 色を取得します。
String | getDataId() データＩＤを取得します。
String | getDataType() データタイプを取得します。
int | getDay() 日を取得します。
int | getDayWeek() 曜日を取得します。
String | getDescription() データの説明を取得します。
String | getDisplayName(Locale locale) 表示名を取得します。
Locale[] | getLocales() 表示名として保管されているロケールの一覧を取得します。
int | getMonth() 月を取得します。
String | getPlugin() プラグインIDを取得します。
int | getPriority() 優先度を取得します。
int | getTimes() 次を取得します。
int | getValidEndYear() 有効終了年を取得します。
int | getValidStartYear() 有効開始年を取得します。
int | getWeek() 週を取得します。
int | getYear() 年を取得します。
void | removeDisplayName(Locale locale) ロケールに対応した表示名を削除します。
void | setColor(String color) 色を設定します。
protected void | setDataId(String dataId) データIDを設定します。
void | setDataType(String dataType) データタイプを設定します。
void | setDay(int day) 日を設定します。
void | setDayWeek(int dayWeek) 曜日を設定します。
void | setDescription(String description) データの説明を設定します。
void | setDisplayName(Locale locale, String displayName) 表示名を設定します。
void | setMonth(int month) 月を設定します。
void | setPlugin(String plugin) プラグインIDを設定します。
void | setTimes(int times) 第ｎ～曜日を設定します。
void | setValidEndYear(int validEndYear) 有効終了年を設定します。
void | setValidStartYear(int validStartYear) 有効開始年を設定します。
void | setWeek(int week) 第ｎ週目を設定します。
void | setYear(int year) 年を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

TYPE_CONFIG

public static final String TYPE_CONFIG
名称（データタイプの定数）。

関連項目:
定数フィールド値

TYPE_HOLIDAY

public static final String TYPE_HOLIDAY
休日（データタイプの定数）。

関連項目:
定数フィールド値

TYPE_WEEKDAY

public static final String TYPE_WEEKDAY
非休日（データタイプの定数）。

関連項目:
定数フィールド値

TYPE_NATIONAL_HOLDAY

public static final String TYPE_NATIONAL_HOLDAY
祝祭日（データタイプの定数）。

関連項目:
定数フィールド値
コンストラクタの詳細

CalendarInfo

public CalendarInfo()
コンストラクタ。

データIDは自動採番されます。

CalendarInfo

public CalendarInfo(String dataId)
コンストラクタ。

パラメータ:
dataId - カレンダーデータID
メソッドの詳細

getColor

public String getColor()
色を取得します。

戻り値:
色

getDataId

public String getDataId()
データＩＤを取得します。

戻り値:
データＩＤ

getDataType

public String getDataType()
データタイプを取得します。

戻り値:
データタイプ

getDay

public int getDay()
日を取得します。

戻り値:
日

getDayWeek

public int getDayWeek()
曜日を取得します。

戻り値:
曜日

getDescription

public String getDescription()
データの説明を取得します。

戻り値:
データの説明

getDisplayName

public String getDisplayName(Locale locale)
表示名を取得します。

引数のロケールに対応した表示名を取得します。

パラメータ:
locale - ロケール
戻り値:
ロケールに対応した表示名

removeDisplayName

public void removeDisplayName(Locale locale)
ロケールに対応した表示名を削除します。

ロケールに対応した表示名を削除します。

パラメータ:
locale - ロケール

getLocales

public Locale[] getLocales()
表示名として保管されているロケールの一覧を取得します。

戻り値:
表示名として保管されているロケールの配列

getMonth

public int getMonth()
月を取得します。

戻り値:
月

getPlugin

public String getPlugin()
プラグインIDを取得します。

戻り値:
プラグインID

getTimes

public int getTimes()
次を取得します。
第ｎ～曜日

戻り値:
次

getValidEndYear

public int getValidEndYear()
有効終了年を取得します。

戻り値:
有効終了年

getValidStartYear

public int getValidStartYear()
有効開始年を取得します。

戻り値:
有効開始年

getWeek

public int getWeek()
週を取得します。
第ｎ週目

戻り値:
週

getYear

public int getYear()
年を取得します。

戻り値:
年

setColor

public void setColor(String color)
色を設定します。

パラメータ:
color - 色

setDataId

protected void setDataId(String dataId)
データIDを設定します。

パラメータ:
dataId - データID

setDataType

public void setDataType(String dataType)
データタイプを設定します。

設定できる値は、 TYPE_CONFIG(名称)、 TYPE_HOLIDAY(休日)、 TYPE_WEEKDAY (非休日)、 TYPE_NATIONAL_HOLDAY(祝祭日)のいずれかです。
上記以外の値が設定された場合は、 TYPE_CONFIG(名称)に設定されます。

パラメータ:
dataType - データタイプ

setDay

public void setDay(int day)
日を設定します。

設定できる値は、1から31までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。

パラメータ:
day - 日

setDayWeek

public void setDayWeek(int dayWeek)
曜日を設定します。

設定できる値は、0(日曜日)から6(土曜日)までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。

設定した曜日(日)を特定したい場合は、第ｎ～曜日の設定( getTimes())
または第ｎ週の設定( getWeek())と共に設定が可能です。
第ｎ～曜日の設定、第ｎ週の設定共に設定を行わなかった場合は、すべての指定曜日の設定となります。

パラメータ:
dayWeek - 曜日

setDescription

public void setDescription(String description)
データの説明を設定します。

パラメータ:
description - データの説明

setDisplayName

public void setDisplayName(Locale locale,
                           String displayName)
表示名を設定します。

ロケールに対応する表示名を設定します。

パラメータ:
locale - ロケール
displayName - 表示名

setMonth

public void setMonth(int month)
月を設定します。

設定できる値は、1から12までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。

パラメータ:
month - 月

setPlugin

public void setPlugin(String plugin)
プラグインIDを設定します。

この設定を無効にするにはnullまたは空文字列を設定します。

パラメータ:
plugin - プラグインID

setTimes

public void setTimes(int times)
第ｎ～曜日を設定します。

設定できる値は、1から5までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。

曜日の設定( setDayWeek(int)) と共に設定すると、日を特定できます。

パラメータ:
times - 第ｎ～曜日

setValidEndYear

public void setValidEndYear(int validEndYear)
有効終了年を設定します。

この設定を無効にするには-1を設定します。

パラメータ:
validEndYear - 有効終了年

setValidStartYear

public void setValidStartYear(int validStartYear)
有効開始年を設定します。

この設定を無効にするには-1を設定します。

パラメータ:
validStartYear - 有効開始年

setWeek

public void setWeek(int week)
第ｎ週目を設定します。

設定できる値は、1から6までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。

曜日の設定( setDayWeek(int)) と共に設定すると、日が特定できます。

パラメータ:
week - 週

setYear

public void setYear(int year)
年を設定します。

この設定を無効にするには-1を設定します。

パラメータ:
year - 年

getPriority

public int getPriority()
優先度を取得します。

戻り値:
優先度
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CalendarManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス CalendarManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.CalendarManager
public class CalendarManager
extends Object

カレンダーマネージャクラス

カレンダー情報の操作を行います。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
CalendarInfo

コンストラクタの概要
CalendarManager(String groupId)
コンストラクタ。
メソッドの概要
void | addCalendarInfo(String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に追加します。
static void | clearInstance() カレンダーマネージャのインスタンスを初期化します。
void | deleteCalendar(String calendarId) カレンダーを削除します。
void | deleteCalendarInfo(String calendarId, String dataId) カレンダーデータを削除します。
void | deleteCalendarInfos(String calendarId) すべてのカレンダーデータを削除します。
void | deleteCalendars() すべてのカレンダーを削除します。
void | exportData(String category, OutputStream outputStream) エクスポートを行います。
String[] | getCalendarIds() すべてのカレンダーIDを取得します。
CalendarInfo | getCalendarInfo(String calendarId, String dataId) カレンダーデータを取得します。
String[] | getCalendarInfoIds(String calendarId) すべてのカレンダーデータIDを取得します。
CalendarInfo[] | getCalendarInfos(String calendarId) すべてのカレンダーデータを取得します。
CalendarInfo[] | getCalendarInfosByIds(String calendarId, String[] calendarInfoIds) ログイングループ内で引数指定したカレンダーデータIDのカレンダーをすべて取得します。
CategorizedCalendarInfo | getCategorizedCalendarInfos(String calendarId) すべてのカレンダーデータをデータタイプ別に分類して取得します。
DayInfo | getDayInfo(CategorizedCalendarInfo categorizedCalendarInfo, Date date) 日付情報を取得します。
String | getDefaultCalendarId() デフォルトカレンダーIDを取得します。
String[] | getExportCategories() カレンダーエクスポート用のカテゴリの一覧を取得します。
String[] | getImportCategories() カレンダーインポート用のカテゴリの一覧を取得します。
String | getLoginGroupId() ログイングループIDを取得します。
DayInfo[] | getMonthInfos(CategorizedCalendarInfo categorizedCalendarInfo, int year, int month) 月情報を取得します。
CalendarPlugin | getPlugin(String pluginId) カレンダーデータプラグインを取得します。
String[] | getPluginIds() カレンダーデータプラグインIDの一覧を取得します。
void | importData(String category, InputStream inputStream) インポートを行います。
boolean | isHoliday(String calendarId, CategorizedCalendarInfo categorizedCalendarInfo, Date date) 休日かどうか判定します。
boolean | isNationalHoliday(CategorizedCalendarInfo categorizedCalendarInfo, Date date) 祝日かどうか判定します。
boolean | isUpdate(String calendarId, Date date) カレンダーデータが指定された日付よりも新しいかチェックします。
boolean | isWeekday(String calendarId, CategorizedCalendarInfo categorizedCalendarInfo, Date date) 平日かどうか判定します。
void | updateCalendarInfo(String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CalendarManager

public CalendarManager(String groupId)
                throws AccessSecurityException
コンストラクタ。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityException - ログイングループIDが不正な場合にスローされます。
メソッドの詳細

clearInstance

public static void clearInstance()
カレンダーマネージャのインスタンスを初期化します。

アクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。
通常、このメソッドを使用する必要はありません。

addCalendarInfo

public void addCalendarInfo(String calendarId,
                            CalendarInfo calendarInfo)
                     throws AccessSecurityException
カレンダーデータを新規に追加します。

パラメータ:
calendarId - カレンダーID
calendarInfo - カレンダーデータ
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正な場合にスローされます。

deleteCalendar

public void deleteCalendar(String calendarId)
                    throws AccessSecurityException
カレンダーを削除します。

パラメータ:
calendarId - カレンダーID
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正な場合にスローされます。

deleteCalendarInfo

public void deleteCalendarInfo(String calendarId,
                               String dataId)
                        throws AccessSecurityException
カレンダーデータを削除します。

パラメータ:
calendarId - カレンダーID
dataId - 削除するカレンダーデータID
戻り値:
カレンダーデータ
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正な場合にスローされます。

deleteCalendarInfos

public void deleteCalendarInfos(String calendarId)
                         throws AccessSecurityException
すべてのカレンダーデータを削除します。

パラメータ:
calendarId - カレンダーID
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正な場合にスローされます。

deleteCalendars

public void deleteCalendars()
                     throws AccessSecurityException
すべてのカレンダーを削除します。

例外:
AccessSecurityException - 書き込みに失敗した場合にスローされます。

exportData

public void exportData(String category,
                       OutputStream outputStream)
                throws AccessSecurityException
エクスポートを行います。

パラメータ:
outputStream - 出力ストリーム
例外:
AccessSecurityException - エクスポートに失敗した場合、または引数が不正な場合にスローされます。

getCalendarIds

public String[] getCalendarIds()
                        throws AccessSecurityException
すべてのカレンダーIDを取得します。

戻り値:
カレンダーIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getCalendarInfo

public CalendarInfo getCalendarInfo(String calendarId,
                                    String dataId)
                             throws AccessSecurityException
カレンダーデータを取得します。

パラメータ:
calendarId - カレンダーID
dataId - カレンダーデータID
戻り値:
カレンダーデータ
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正な場合にスローされます。

getCalendarInfoIds

public String[] getCalendarInfoIds(String calendarId)
                            throws AccessSecurityException
すべてのカレンダーデータIDを取得します。

パラメータ:
calendarId - カレンダーID
戻り値:
カレンダーデータIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正な場合にスローされます。

getCalendarInfos

public CalendarInfo[] getCalendarInfos(String calendarId)
                                throws AccessSecurityException
すべてのカレンダーデータを取得します。

パラメータ:
calendarId - カレンダーID
戻り値:
カレンダーに属するすべてのカレンダーデータ
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正な場合にスローされます。

getCalendarInfosByIds

public CalendarInfo[] getCalendarInfosByIds(String calendarId,
                                            String[] calendarInfoIds)
                                     throws AccessSecurityException
ログイングループ内で引数指定したカレンダーデータIDのカレンダーをすべて取得します。

パラメータ:
calendarId - カレンダーID
calendarInfoIds - カレンダーデータIDの配列
戻り値:
カレンダー情報の配列（データがない場合は空の配列を返します。）
例外:
AccessSecurityException - カレンダー情報の取得に失敗した場合にスローされます。

getCategorizedCalendarInfos

public CategorizedCalendarInfo getCategorizedCalendarInfos(String calendarId)
                                                    throws AccessSecurityException
すべてのカレンダーデータをデータタイプ別に分類して取得します。

一度、取得したカレンダーデータは、変更がない限りメモリ上にプールされ、
取得パフォーマンスの向上がなされています。(since 6.1.3)

パラメータ:
calendarId - カレンダーID
戻り値:
カレンダーに属するデータタイプ別に分類されたべてのカレンダーデータ
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getDayInfo

public DayInfo getDayInfo(CategorizedCalendarInfo categorizedCalendarInfo,
                          Date date)
                   throws AccessSecurityException
日付情報を取得します。

パラメータ:
categorizedCalendarInfo - カテゴライズカレンダーデータ
date - 日付
戻り値:
カレンダーに属するデータタイプ別に分類されたすべてのカレンダーデータ
例外:
AccessSecurityException - 引数が不正な場合にスローされます。

getDefaultCalendarId

public String getDefaultCalendarId()
デフォルトカレンダーIDを取得します。

戻り値:
デフォルトカレンダーID

getExportCategories

public String[] getExportCategories()
                             throws AccessSecurityException
カレンダーエクスポート用のカテゴリの一覧を取得します。

戻り値:
カレンダーエクスポート用カテゴリの一覧
例外:
AccessSecurityException - カレンダーエクスポート用のカテゴリの取得に失敗した場合にスローされます。

getImportCategories

public String[] getImportCategories()
                             throws AccessSecurityException
カレンダーインポート用のカテゴリの一覧を取得します。

戻り値:
カレンダーインポート用カテゴリの一覧
例外:
AccessSecurityException - カレンダーインポート用のカテゴリの取得に失敗した場合にスローされます。

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

戻り値:
ログイングループID

getMonthInfos

public DayInfo[] getMonthInfos(CategorizedCalendarInfo categorizedCalendarInfo,
                               int year,
                               int month)
                        throws AccessSecurityException
月情報を取得します。

パラメータ:
categorizedCalendarInfo - カテゴライズカレンダーデータ
year - 年
month - 月
戻り値:
カレンダーに属するデータタイプ別に分類されたすべてのカレンダーデータ
例外:
AccessSecurityException - 引数が不正な場合にスローされます。

getPlugin

public CalendarPlugin getPlugin(String pluginId)
                         throws AccessSecurityException
カレンダーデータプラグインを取得します。

存在しない場合は、nullを返却します。

パラメータ:
pluginId - 取得するカレンダーデータプラグインID
戻り値:
カレンダーデータプラグイン 引数が不正な場合にスローされます。
例外:
AccessSecurityException

getPluginIds

public String[] getPluginIds()
カレンダーデータプラグインIDの一覧を取得します。

戻り値:
カレンダーデータプラグインIDの配列

importData

public void importData(String category,
                       InputStream inputStream)
                throws AccessSecurityException
インポートを行います。

パラメータ:
category - カテゴリ名
inputStream - 入力ストリーム
例外:
AccessSecurityException - インポートに失敗した場合、または引数が不正な場合にスローされます。

isHoliday

public boolean isHoliday(String calendarId,
                         CategorizedCalendarInfo categorizedCalendarInfo,
                         Date date)
                  throws AccessSecurityException
休日かどうか判定します。

パラメータ:
calendarId - カレンダーId
categorizedCalendarInfo - カテゴライズカレンダーデータ
date - 日付情報
戻り値:
判定結果 true:休日 false:平日
例外:
AccessSecurityException - 引数が不正な場合にスローされます。

isNationalHoliday

public boolean isNationalHoliday(CategorizedCalendarInfo categorizedCalendarInfo,
                                 Date date)
                          throws AccessSecurityException
祝日かどうか判定します。

パラメータ:
categorizedCalendarInfo - カテゴライズカレンダーデータ
date - 日付情報
戻り値:
判定結果 true:祝日 false:祝日以外の日
例外:
AccessSecurityExceptionc - 引数が不正な場合にスローされます。
AccessSecurityException

isWeekday

public boolean isWeekday(String calendarId,
                         CategorizedCalendarInfo categorizedCalendarInfo,
                         Date date)
                  throws AccessSecurityException
平日かどうか判定します。

パラメータ:
calendarId - カレンダーId
categorizedCalendarInfo - カテゴライズカレンダーデータ
date - 日付情報
戻り値:
判定結果 true:平日 false:休日
例外:
AccessSecurityException - 引数が不正な場合にスローされます。

updateCalendarInfo

public void updateCalendarInfo(String calendarId,
                               CalendarInfo calendarInfo)
                        throws AccessSecurityException
カレンダーデータを更新します。

パラメータ:
calendarId - カレンダーID
calendarInfo - カレンダーデータ
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正な場合にスローされます。

isUpdate

public boolean isUpdate(String calendarId,
                        Date date)
                 throws AccessSecurityException
カレンダーデータが指定された日付よりも新しいかチェックします。

パラメータ:
calendarId - カレンダーID
date - チェック日付
例外:
AccessSecurityReadException - カレンダー情報取得に失敗した場合スローされます。
AccessSecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarPlugin (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース CalendarPlugin

既知の実装クラスの一覧:
CalendarPluginAutumnalEquinox, CalendarPluginEndOfTheMonth, CalendarPluginLastDayInTheMonth, CalendarPluginMondayMakeupHoliday, CalendarPluginVernalEquinox
public interface CalendarPlugin

カレンダデータプラグインインターフェース。

カレンダデータの有効無効を判定するプラグインのインターフェース

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
 boolean validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date)
カレンダーデータが有効かどうか検証します。

メソッドの詳細

validate

public boolean validate(CalendarManager calendarManager,
                        CategorizedCalendarInfo categorizedCalendarInfo,
                        CalendarInfo calendarInfo,
                        Date date)
カレンダーデータが有効かどうか検証します。

指定した日付に対して、カレンダーデータが有効かどうか検証します。

パラメータ:
categorizedCalendarInfo - 対象カレンダーのカテゴライズされたカレンダーデータ
calendarInfo - 対象カレンダーデータ
date - 対象の日付
戻り値:
対象のカレンダーデータが有効な場合は、trueを返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarPluginAutumnalEquinox (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス CalendarPluginAutumnalEquinox

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox
すべての実装インタフェース:
CalendarPlugin
public class CalendarPluginAutumnalEquinox
extends Object
implements CalendarPlugin

カレンダデータプラグインクラス。

カレンダデータの有効無効を判定するプラグインのクラスです。
利用方法：設定画面において、休日設定・9 月・22, 23 および 24 日
プラグイン設定で『秋分の日』を選択して利用します。
(２種類の同時設定が必要です)
判定基準：グレゴリオ歴をもとにして天文学の黄道起動計算に基づいて
定義された簡易計算式を用いて決定します。
指定の日付が秋分の日である場合に真値を、秋分の日ではない
場合に偽値を返却します。
注意事項：簡易計算式を用いて計算しているため、このロジックの有効
期間は、1900 年 3 月以降 2099 年までとなります。
(この期間外では、正しい結果を返さないことがあります)
このロジックは計算式による予測値にすぎず、日本の法律で
定められている秋分の日と完全に一致しないことがあります。
日本の祝日として定められた秋分の日の正式な日付は、前年の
2 月 1 日に国立天文台より官報として公示される文書を
参照するようにして下さい。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
CalendarPluginAutumnalEquinox()
メソッドの概要
 boolean validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date)
カレンダーデータが有効かどうか検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CalendarPluginAutumnalEquinox

public CalendarPluginAutumnalEquinox()
メソッドの詳細

validate

public boolean validate(CalendarManager calendarManager,
                        CategorizedCalendarInfo categorizedCalendarInfo,
                        CalendarInfo calendarInfo,
                        Date date)
カレンダーデータが有効かどうか検証します。

指定した日付に対して、カレンダーデータが有効かどうか検証します。
指定日付が秋分の日かどうかをチェックします。

定義:
インタフェース CalendarPlugin 内の validate
パラメータ:
categorizedCalendarInfo - 対象カレンダーのカテゴライズされたカレンダーデータ
calendarInfo - 対象カレンダーデータ
date - 対象の日付
戻り値:
対象のカレンダーデータが有効な場合は、trueを返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarPluginEndOfTheMonth (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス CalendarPluginEndOfTheMonth

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth
すべての実装インタフェース:
CalendarPlugin
public class CalendarPluginEndOfTheMonth
extends Object
implements CalendarPlugin

カレンダデータプラグインクラス。

カレンダデータの有効無効を判定するプラグインクラスです。
利用方法：設定画面において、休日設定・月曜日・プラグイン設定で
『月末』を選択して利用します。
判定基準：日付がその月の最終日である状態を
真値(月末)として判定します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
CalendarPluginEndOfTheMonth()
メソッドの概要
 boolean validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date)
カレンダーデータが有効かどうか検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CalendarPluginEndOfTheMonth

public CalendarPluginEndOfTheMonth()
メソッドの詳細

validate

public boolean validate(CalendarManager calendarManager,
                        CategorizedCalendarInfo categorizedCalendarInfo,
                        CalendarInfo calendarInfo,
                        Date date)
カレンダーデータが有効かどうか検証します。

指定した日付に対して、カレンダーデータが有効かどうか検証します。
指定日付が月末かどうかをチェックします。

定義:
インタフェース CalendarPlugin 内の validate
パラメータ:
categorizedCalendarInfo - 対象カレンダーのカテゴライズされたカレンダーデータ
calendarInfo - 対象カレンダーデータ
date - 対象の日付
戻り値:
対象のカレンダーデータが有効な場合は、trueを返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarPluginInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース CalendarPluginInfo

public interface CalendarPluginInfo

カレンダーデータプラグイン情報のインターフェース。

カレンダーデータプラグイン情報のインターフェースです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getPluginClass() カレンダーデータプラグインクラス名を取得します。
String | getPluginId() カレンダーデータプラグインIDを取得します。

メソッドの詳細

getPluginClass

public String getPluginClass()
カレンダーデータプラグインクラス名を取得します。

カレンダーデータプラグインクラスのフルパッケージ名を返却します。
CalendarPluginを実装したクラスでなければなりません。

戻り値:
カレンダーデータプラグインクラス名

getPluginId

public String getPluginId()
カレンダーデータプラグインIDを取得します。

戻り値:
カレンダーデータプラグインID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarPluginLastDayInTheMonth (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス CalendarPluginLastDayInTheMonth

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth
すべての実装インタフェース:
CalendarPlugin
public class CalendarPluginLastDayInTheMonth
extends Object
implements CalendarPlugin

カレンダデータプラグインクラス。

カレンダデータの有効無効を判定するプラグインクラスです。
月内の最終曜日を定義するためのプラグインクラスです。
利用方法：設定画面において、休日設定・月曜日・プラグイン設定で
『最終曜日』を選択して利用します。
判定基準：日付がその月の最終曜日である状態を
真値(最終曜日)として判定します。
これにより、月曜日設定と組み合わせた場合、
最終月曜日という設定が可能になります。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
CalendarPluginLastDayInTheMonth()
メソッドの概要
 boolean validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date)
カレンダーデータが有効かどうか検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CalendarPluginLastDayInTheMonth

public CalendarPluginLastDayInTheMonth()
メソッドの詳細

validate

public boolean validate(CalendarManager calendarManager,
                        CategorizedCalendarInfo categorizedCalendarInfo,
                        CalendarInfo calendarInfo,
                        Date date)
カレンダーデータが有効かどうか検証します。

指定した日付に対して、カレンダーデータが有効かどうか検証します。
指定日付が最終曜日かどうかをチェックします。

定義:
インタフェース CalendarPlugin 内の validate
パラメータ:
categorizedCalendarInfo - 対象カレンダーのカテゴライズされたカレンダーデータ
calendarInfo - 対象カレンダーデータ
date - 対象の日付
戻り値:
対象のカレンダーデータが有効な場合は、trueを返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarPluginMondayMakeupHoliday (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス CalendarPluginMondayMakeupHoliday

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday
すべての実装インタフェース:
CalendarPlugin
public class CalendarPluginMondayMakeupHoliday
extends Object
implements CalendarPlugin

カレンダデータプラグインクラス。

カレンダデータの有効無効を判定するプラグインのクラスです。
振替休日を定義するためのプラグインです。
利用方法：設定画面において、休日設定・月曜日・プラグイン設定で
『振替休日』を選択して利用します。
判定基準：前日が休日設定であり、２種類以上の休日設定が重なっている
状態を真値(振替休日)とし１種類の休日設定のみの判定である
状態を偽値(休日ではない)と判定します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
CalendarPluginMondayMakeupHoliday()
メソッドの概要
 boolean validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date)
カレンダーデータが有効かどうか検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CalendarPluginMondayMakeupHoliday

public CalendarPluginMondayMakeupHoliday()
メソッドの詳細

validate

public boolean validate(CalendarManager calendarManager,
                        CategorizedCalendarInfo categorizedCalendarInfo,
                        CalendarInfo calendarInfo,
                        Date date)
カレンダーデータが有効かどうか検証します。

指定した日付に対して、カレンダーデータが有効かどうか検証します。
指定日付が振替休日扱いかどうかをチェックします。

定義:
インタフェース CalendarPlugin 内の validate
パラメータ:
categorizedCalendarInfo - 対象カレンダーのカテゴライズされたカレンダーデータ
calendarInfo - 対象カレンダーデータ
date - 対象の日付
戻り値:
対象のカレンダーデータが有効な場合は、trueを返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarPluginVernalEquinox (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス CalendarPluginVernalEquinox

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox
すべての実装インタフェース:
CalendarPlugin
public class CalendarPluginVernalEquinox
extends Object
implements CalendarPlugin

カレンダデータプラグインクラス。

カレンダデータの有効無効を判定するプラグインのクラスです。
利用方法：設定画面において、休日設定・3 月・19, 20, 21 および 22 日
プラグイン設定で『春分の日』を選択して利用します。
(２種類の同時設定が必要です)
判定基準：グレゴリオ歴をもとにして天文学の黄道起動計算に基づいて
定義された簡易計算式を用いて決定します。
指定の日付が春分の日である場合に真値を、春分の日ではない
場合に偽値を返却します。
注意事項：簡易計算式を用いて計算しているため、このロジックの有効
期間は、1960 年 3 月以降 2099 年までとなります。
(この期間外では、正しい結果を返さないことがあります)
このロジックは計算式による予測値にすぎず、日本の法律で
定められている春分の日と完全に一致しないことがあります。
日本の祝日として定められた春分の日の正式な日付は、前年の
2 月 1 日に国立天文台より官報として公示される文書を
参照するようにして下さい。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
CalendarPluginVernalEquinox()
メソッドの概要
 boolean validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date)
カレンダーデータが有効かどうか検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CalendarPluginVernalEquinox

public CalendarPluginVernalEquinox()
メソッドの詳細

validate

public boolean validate(CalendarManager calendarManager,
                        CategorizedCalendarInfo categorizedCalendarInfo,
                        CalendarInfo calendarInfo,
                        Date date)
カレンダーデータが有効かどうか検証します。

指定した日付に対して、カレンダーデータが有効かどうか検証します。
指定日付が春分の日かどうかをチェックします。

定義:
インタフェース CalendarPlugin 内の validate
パラメータ:
categorizedCalendarInfo - 対象カレンダーのカテゴライズされたカレンダーデータ
calendarInfo - 対象カレンダーデータ
date - 対象の日付
戻り値:
対象のカレンダーデータが有効な場合は、trueを返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarPostWriterListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース CalendarPostWriterListener

public interface CalendarPostWriterListener

カレンダー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
CalendarManager

メソッドの概要
void | init(Map params) カレンダーリスナーの初期化。
void | postCreateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに作成した直後にコールされます。
void | postDeleteCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータをデータストアから削除した直後にコールされます。
void | postUpdateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
カレンダーリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreateCalendarInfo

public void postCreateCalendarInfo(String groupId,
                                   String calendarId,
                                   CalendarInfo calendarInfo)
                            throws AccessSecurityListenerExcpetion
カレンダーデータをデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfo - 作成されたカレンダーデータ
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteCalendarInfo

public void postDeleteCalendarInfo(String groupId,
                                   String calendarId,
                                   String dataId)
                            throws AccessSecurityListenerExcpetion
カレンダーデータをデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
dataId - 削除されたカレンダーデータID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateCalendarInfo

public void postUpdateCalendarInfo(String groupId,
                                   String calendarId,
                                   CalendarInfo calendarInfo)
                            throws AccessSecurityListenerExcpetion
カレンダーデータをデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfo - 更新されたカレンダーデータ
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarQueryWriterListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース CalendarQueryWriterListener

public interface CalendarQueryWriterListener

カレンダー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
CalendarManager

メソッドの概要
void | init(Map params) カレンダーリスナーの初期化。
void | queryCreateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに作成する直前にコールされます。
void | queryDeleteCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータをデータストアから削除する直前にコールされます。
void | queryUpdateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
カレンダーリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreateCalendarInfo

public void queryCreateCalendarInfo(String groupId,
                                    String calendarId,
                                    CalendarInfo calendarInfo)
                             throws AccessSecurityListenerExcpetion
カレンダーデータをデータストアに作成する直前にコールされます。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfo - 作成されるカレンダーデータ
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteCalendarInfo

public void queryDeleteCalendarInfo(String groupId,
                                    String calendarId,
                                    String dataId)
                             throws AccessSecurityListenerExcpetion
カレンダーデータをデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
dataId - 削除されるカレンダーデータID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdateCalendarInfo

public void queryUpdateCalendarInfo(String groupId,
                                    String calendarId,
                                    CalendarInfo calendarInfo)
                             throws AccessSecurityListenerExcpetion
カレンダーデータをデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfo - 更新されるカレンダーデータ
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarReaderDecorator (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース CalendarReaderDecorator

public interface CalendarReaderDecorator

アカウント情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
CalendarInfo | doDecoration(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアからの読み込み直後にコールされます。
void | init(Map params) カレンダーデコレータの初期化。

メソッドの詳細

init

public void init(Map params)
カレンダーデコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public CalendarInfo doDecoration(String groupId,
                                 String calendarId,
                                 CalendarInfo calendarInfo)
カレンダーデータをデータストアからの読み込み直後にコールされます。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfo - 読み込みが行われたカレンダーデータ
戻り値:
拡張されたカレンダーデータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CategorizedCalendarInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス CategorizedCalendarInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo
public class CategorizedCalendarInfo
extends Object

カテゴライズカレンダーデータクラス。

データタイプで分類されたされたカレンダーデータの情報を保持するクラス。

分類されるデータタイプの種類は、以下の通りです。

  • 名称（ CalendarInfo.TYPE_CONFIG） getConfigDayInfos()
  • 休日（ CalendarInfo.TYPE_HOLIDAY） getHodildayInfos()
  • 非休日（ CalendarInfo.TYPE_WEEKDAY） getWeekdayInfos()
  • 祝祭日（ CalendarInfo.TYPE_NATIONAL_HOLDAY） getNationalHodildayInfos()

    • 導入されたバージョン:
    5.0
    バージョン:
    1.0

    コンストラクタの概要
    protected CategorizedCalendarInfo(CalendarInfo[] calendarInfos)
    コンストラクタ。
    メソッドの概要
CalendarInfo[] | getConfigDayInfos() データタイプが名称であるカレンダーデータの一覧を取得します。
CalendarInfo[] | getHodildayInfos() データタイプが休日であるカレンダーデータの一覧を取得します。
CalendarInfo[] | getNationalHodildayInfos() データタイプが祝祭日であるカレンダーデータの一覧を取得します。
CalendarInfo[] | getWeekdayInfos() データタイプが非休日であるカレンダーデータの一覧を取得します。
    クラス java.lang.Object から継承したメソッド
    clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    コンストラクタの詳細

    CategorizedCalendarInfo

    protected CategorizedCalendarInfo(CalendarInfo[] calendarInfos)
    コンストラクタ。

    パラメータ:
    calendarInfos - カレンダデータの配列
    メソッドの詳細

    getConfigDayInfos

    public CalendarInfo[] getConfigDayInfos()
    データタイプが名称であるカレンダーデータの一覧を取得します。

    戻り値:
    データタイプが名称であるカレンダーデータの配列

    getHodildayInfos

    public CalendarInfo[] getHodildayInfos()
    データタイプが休日であるカレンダーデータの一覧を取得します。

    戻り値:
    データタイプが休日であるカレンダーデータの配列

    getNationalHodildayInfos

    public CalendarInfo[] getNationalHodildayInfos()
    データタイプが祝祭日であるカレンダーデータの一覧を取得します。

    戻り値:
    データタイプが祝祭日であるカレンダーデータの配列

    getWeekdayInfos

    public CalendarInfo[] getWeekdayInfos()
    データタイプが非休日であるカレンダーデータの一覧を取得します。

    戻り値:
    データタイプが非休日であるカレンダーデータの配列
    概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
            intra-mart 6.1.14
    前のクラス 次のクラス フレームあり フレームなし
    概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DayInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース DayInfo

public interface DayInfo

日付に対するカレンダーデータ情報の取得インターフェース。

日付に対するカレンダーデータの情報にアクセスするインターフェースです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
CalendarInfo[] | getCalendarInfo() マッチしたカレンダーデータの一覧を取得します。
String | getColor() 背景色を取得します。
Date | getDate() 対象の日付を取得します。
int | getMatchCount() 名称設定以外でマッチしたカレンダーデータの数を取得します。
boolean | isHoliday() 休日設定にマッチしているかどうかを取得します。
boolean | isNationalHoliday() 祝祭日設定にマッチしているかどうかを取得します。。
boolean | isWeekday() 非休日設定にマッチしているかどうかを取得します。

メソッドの詳細

getColor

public String getColor()
背景色を取得します。

戻り値:
背景色

getDate

public Date getDate()
対象の日付を取得します。

戻り値:
date

getCalendarInfo

public CalendarInfo[] getCalendarInfo()
マッチしたカレンダーデータの一覧を取得します。

戻り値:
マッチしたカレンダーデータの配列

isHoliday

public boolean isHoliday()
休日設定にマッチしているかどうかを取得します。

戻り値:
休日設定にマッチしている場合はtrue

isNationalHoliday

public boolean isNationalHoliday()
祝祭日設定にマッチしているかどうかを取得します。。

戻り値:
祝祭日設定にマッチしている場合はtrue

isWeekday

public boolean isWeekday()
非休日設定にマッチしているかどうかを取得します。

戻り値:
非休日設定にマッチしている場合はtrue

getMatchCount

public int getMatchCount()
名称設定以外でマッチしたカレンダーデータの数を取得します。

戻り値:
名称設定以外でマッチしたカレンダーデータの数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.calendar (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.security.calendar
インタフェース
CalendarAccessor
CalendarExporter
CalendarImporter
CalendarPlugin
CalendarPluginInfo
CalendarPostWriterListener
CalendarQueryWriterListener
CalendarReaderDecorator
DayInfo
クラス
CalendarInfo
CalendarManager
CalendarPluginAutumnalEquinox
CalendarPluginEndOfTheMonth
CalendarPluginLastDayInTheMonth
CalendarPluginMondayMakeupHoliday
CalendarPluginVernalEquinox
CategorizedCalendarInfo
StandardCalendarBackup


jp.co.intra_mart.foundation.security.calendar (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.calendar

カレンダーに関連するクラスを提供します。

参照:
説明

インタフェースの概要
CalendarAccessor | カレンダーアクセッサインタフェース。
CalendarExporter | カレンダーバックアップインタフェースです。
CalendarImporter | カレンダーバックアップインタフェースです。
CalendarPlugin | カレンダデータプラグインインターフェース。
CalendarPluginInfo | カレンダーデータプラグイン情報のインターフェース。
CalendarPostWriterListener | カレンダー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
CalendarQueryWriterListener | カレンダー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
CalendarReaderDecorator | アカウント情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
DayInfo | 日付に対するカレンダーデータ情報の取得インターフェース。

クラスの概要
CalendarInfo | カレンダーデータ・モデルクラス
CalendarManager | カレンダーマネージャクラス カレンダー情報の操作を行います。
CalendarPluginAutumnalEquinox | カレンダデータプラグインクラス。
CalendarPluginEndOfTheMonth | カレンダデータプラグインクラス。
CalendarPluginLastDayInTheMonth | カレンダデータプラグインクラス。
CalendarPluginMondayMakeupHoliday | カレンダデータプラグインクラス。
CalendarPluginVernalEquinox | カレンダデータプラグインクラス。
CategorizedCalendarInfo | カテゴライズカレンダーデータクラス。
StandardCalendarBackup | カレンダーバックアップクラスです。

パッケージ jp.co.intra_mart.foundation.security.calendar の説明

カレンダーに関連するクラスを提供します。


jp.co.intra_mart.foundation.security.calendar クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.calendar の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.calendar.CalendarInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarManager
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo
    • class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup (implements jp.co.intra_mart.foundation.security.calendar.CalendarExporter, jp.co.intra_mart.foundation.security.calendar.CalendarImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarExporter
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarImporter
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarPlugin
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator
  • interface jp.co.intra_mart.foundation.security.calendar.DayInfo


パッケージ jp.co.intra_mart.foundation.security.calendar の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.calendar の使用

jp.co.intra_mart.foundation.security.calendar を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。

jp.co.intra_mart.foundation.security により使用される jp.co.intra_mart.foundation.security.calendar のクラス
CalendarAccessor
カレンダーアクセッサインタフェース。
CalendarInfo
カレンダーデータ・モデルクラス

jp.co.intra_mart.foundation.security.calendar により使用される jp.co.intra_mart.foundation.security.calendar のクラス
CalendarExporter
カレンダーバックアップインタフェースです。
CalendarImporter
カレンダーバックアップインタフェースです。
CalendarInfo
カレンダーデータ・モデルクラス
CalendarManager
カレンダーマネージャクラス

カレンダー情報の操作を行います。
CalendarPlugin
カレンダデータプラグインインターフェース。
CategorizedCalendarInfo
カテゴライズカレンダーデータクラス。
DayInfo
日付に対するカレンダーデータ情報の取得インターフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardCalendarBackup (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス StandardCalendarBackup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup
すべての実装インタフェース:
CalendarExporter, CalendarImporter
public class StandardCalendarBackup
extends Object
implements CalendarImporter, CalendarExporter

カレンダーバックアップクラスです。

バージョン:
1.0

コンストラクタの概要
StandardCalendarBackup()
メソッドの概要
void | doExport(CalendarManager manager, OutputStream outputStream) エクスポートを行います。
void | doImport(InputStream inputStream, CalendarManager manager) インポートを行います。
void | init(Map params) カレンダーバックアップの初期化。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardCalendarBackup

public StandardCalendarBackup()
メソッドの詳細

init

public void init(Map params)
カレンダーバックアップの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース CalendarImporter 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     CalendarManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリームからカレンダーと
付随するカレンダーデータを取得し、生成します。

定義:
インタフェース CalendarImporter 内の doImport
パラメータ:
manager - カレンダーマネージャクラス
inputStream - 入力ストリーム
戻り値:
バッチモデルクラスの配列
例外:
AccessSecurityImportException

doExport

public void doExport(CalendarManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

カレンダーとカレンダーデータを
バックアップファイルに出力します。

定義:
インタフェース CalendarExporter 内の doExport
パラメータ:
manager - カレンダーマネージャクラス
outputStream - 出力ストリーム
例外:
AccessSecurityExportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.security.certification.ErrorPageProvider の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.certification.ErrorPageProvider の使用

ErrorPageProvider を使用しているパッケージ
jp.co.intra_mart.foundation.security.certification 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.certification での ErrorPageProvider の使用

ErrorPageProvider を実装している jp.co.intra_mart.foundation.security.certification のクラス
 class StandardErrorPageProvider
標準のエラーページプロバイダクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.LDAPUserCertification の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.LDAPUserCertification の使用

jp.co.intra_mart.foundation.security.certification.LDAPUserCertification はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.certification.LoginInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.certification.LoginInfo の使用

LoginInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession |
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification.ldap.extension | ユーザログインLDAP認証クラス(複数OU対応版)の設定方法。

jp.co.intra_mart.foundation.security での LoginInfo の使用

LoginInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
 int AccessSecurityManager.getLicense(LoginInfo loginInfo)
アカウントライセンスチェックを行います。

jp.co.intra_mart.foundation.security.activesession での LoginInfo の使用

LoginInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.activesession のメソッド
void | UserActiveSessionRegister.doCertification(int certificationResult, LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザの認証後にコールされるメソッドです。
void | GroupActiveSessionRegister.doCertification(int certificationResult, LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者の認証後にコールされるメソッドです。

jp.co.intra_mart.foundation.security.certification での LoginInfo の使用

jp.co.intra_mart.foundation.security.certification での LoginInfo のサブインタフェース
 interface LoginRequestInfo
intra-martログイン情報操作インタフェース。

LoginInfo を返す jp.co.intra_mart.foundation.security.certification のメソッド
LoginInfo | RequestAnalyzer.parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。
LoginInfo | StandardRequestAnalyzer.parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。
LoginInfo | SSORequestAnalyzer.parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。

LoginInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.certification のメソッド
void | UserCertificationListener.doCertification(int certificationResult, LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザの認証後にコールされるメソッドです。
int | UserCertification.certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証する。
int | SuperUserNoCertification.certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証します。
void | SuperCertificationListener.doCertification(int certificationResult, LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者の認証後にコールされるメソッドです。
int | SuperCertification.certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証する。
int | StandardUserCertification.certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証します。
int | StandardSuperUserCertification.certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証します。
int | LDAPUserCertification.certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証する。

jp.co.intra_mart.foundation.security.certification.ldap.extension での LoginInfo の使用

LoginInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.certification.ldap.extension のメソッド
 int LDAPUserCertification.certification(LoginInfo loginInfo, Account account, HttpServletRequest req, HttpServletResponse resp)
LDAPに対してユーザを認証します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.certification.LoginRequestInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.certification.LoginRequestInfo の使用

LoginRequestInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security での LoginRequestInfo の使用

LoginRequestInfo を返す jp.co.intra_mart.foundation.security のメソッド
 LoginRequestInfo AccessSecurityManager.createLoginRequestInfo(String loginType)
ログイン情報を作成します。

LoginRequestInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
int | AccessSecurityManager.forceLogin(LoginRequestInfo loginRequestInfo) 強制ログイン処理を行います。
int | AccessSecurityManager.forceLogin(LoginRequestInfo loginRequestInfo, HttpServletRequest request, HttpServletResponse response) 強制ログイン処理を行います。
int | AccessSecurityManager.getInitialCertification(LoginRequestInfo loginInfo) カレントスレッドの情報から初期アクセス処理を行います。
int | AccessSecurityManager.getInitialCertification(LoginRequestInfo loginInfo, HttpServletRequest request, HttpServletResponse response) 初期アクセス処理を行います。
int | AccessSecurityManager.login(LoginRequestInfo loginRequestInfo) ログイン処理を行います。
int | AccessSecurityManager.login(LoginRequestInfo loginRequestInfo, HttpServletRequest request, HttpServletResponse response) ログイン処理を行います。

jp.co.intra_mart.foundation.security.certification での LoginRequestInfo の使用

LoginRequestInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.certification のメソッド
LoginInfo | RequestAnalyzer.parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。
LoginInfo | StandardRequestAnalyzer.parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。
LoginInfo | SSORequestAnalyzer.parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider の使用

PortalStandardUserPageProvider を使用しているパッケージ
jp.co.intra_mart.foundation.security.password

jp.co.intra_mart.foundation.security.password での PortalStandardUserPageProvider の使用

jp.co.intra_mart.foundation.security.password での PortalStandardUserPageProvider のサブクラス
 class PasswordHistoryUserPageProvider
パスワード履歴管理スタンダードユーザページプロバイダクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.certification.RequestAnalyzer の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.certification.RequestAnalyzer の使用

RequestAnalyzer を使用しているパッケージ
jp.co.intra_mart.foundation.security.certification 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.certification での RequestAnalyzer の使用

RequestAnalyzer を実装している jp.co.intra_mart.foundation.security.certification のクラス
class | SSORequestAnalyzer SSOのログインリクエスト解析クラス。
class | StandardRequestAnalyzer 標準のログインリクエスト解析クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の使用

jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider の使用

jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider の使用

jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer の使用

StandardRequestAnalyzer を使用しているパッケージ
jp.co.intra_mart.foundation.security.certification 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.certification での StandardRequestAnalyzer の使用

jp.co.intra_mart.foundation.security.certification での StandardRequestAnalyzer のサブクラス
 class SSORequestAnalyzer
SSOのログインリクエスト解析クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification の使用

jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider の使用

jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.StandardUserCertification の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.StandardUserCertification の使用

StandardUserCertification を使用しているパッケージ
jp.co.intra_mart.foundation.security.certification 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.certification での StandardUserCertification の使用

jp.co.intra_mart.foundation.security.certification での StandardUserCertification のサブクラス
 class LDAPUserCertification
ユーザログインLDAP認証クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider の使用

StandardUserPageProvider を使用しているパッケージ
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.password |

jp.co.intra_mart.foundation.security.certification での StandardUserPageProvider の使用

jp.co.intra_mart.foundation.security.certification での StandardUserPageProvider のサブクラス
 class PortalStandardUserPageProvider
ポータルユーザページプロバイダクラス。

jp.co.intra_mart.foundation.security.password での StandardUserPageProvider の使用

jp.co.intra_mart.foundation.security.password での StandardUserPageProvider のサブクラス
 class PasswordHistoryUserPageProvider
パスワード履歴管理スタンダードユーザページプロバイダクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.certification.SuperCertification の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.certification.SuperCertification の使用

SuperCertification を使用しているパッケージ
jp.co.intra_mart.foundation.security.certification 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.certification での SuperCertification の使用

SuperCertification を実装している jp.co.intra_mart.foundation.security.certification のクラス
class | StandardSuperUserCertification 管理者ログイン認証の実装クラス。
class | SuperUserNoCertification システム管理者ログイン時に強制認証を行う実装クラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.certification.SuperCertificationListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.certification.SuperCertificationListener の使用

SuperCertificationListener を使用しているパッケージ
jp.co.intra_mart.foundation.security.activesession

jp.co.intra_mart.foundation.security.activesession での SuperCertificationListener の使用

SuperCertificationListener を実装している jp.co.intra_mart.foundation.security.activesession のクラス
 class GroupActiveSessionRegister
管理者ログイン認証リスナー実装クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification の使用

jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.certification.UserCertification の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.certification.UserCertification の使用

UserCertification を使用しているパッケージ
jp.co.intra_mart.foundation.security.certification 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.certification での UserCertification の使用

UserCertification を実装している jp.co.intra_mart.foundation.security.certification のクラス
class | LDAPUserCertification ユーザログインLDAP認証クラス。
class | StandardUserCertification ユーザログイン認証クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.certification.UserCertificationListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.certification.UserCertificationListener の使用

UserCertificationListener を使用しているパッケージ
jp.co.intra_mart.foundation.security.activesession

jp.co.intra_mart.foundation.security.activesession での UserCertificationListener の使用

UserCertificationListener を実装している jp.co.intra_mart.foundation.security.activesession のクラス
 class UserActiveSessionRegister
ユーザログイン認証リスナー実装クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.certification.UserPageProvider の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.certification.UserPageProvider の使用

UserPageProvider を使用しているパッケージ
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.password |

jp.co.intra_mart.foundation.security.certification での UserPageProvider の使用

UserPageProvider を実装している jp.co.intra_mart.foundation.security.certification のクラス
class | PortalStandardUserPageProvider ポータルユーザページプロバイダクラス。
class | StandardGroupSuperUserPageProvider 標準のログイングループ管理者用ページプロバイダクラス。
class | StandardSuperUserPageProvider 標準のシステム管理者用のユーザページプロバイダクラス。
class | StandardUserPageProvider 標準のユーザページプロバイダクラス。

jp.co.intra_mart.foundation.security.password での UserPageProvider の使用

UserPageProvider を実装している jp.co.intra_mart.foundation.security.password のクラス
 class PasswordHistoryUserPageProvider
パスワード履歴管理スタンダードユーザページプロバイダクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoBuilder の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoBuilder の使用

jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoBuilder はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel の使用

jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPUserCertification の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPUserCertification の使用

jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPUserCertification はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


LDAPContextInfoBuilder (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification.ldap.extension
クラス LDAPContextInfoBuilder

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoBuilder
public class LDAPContextInfoBuilder
extends Object

ログイングループ毎の設定情報モデルを作成するビルドクラス。
作成された設定情報モデルは、ログイングループID毎に纏められ、
Mapに格納されて返される。

key | value
String：ログイングループID | LDAPContextInfoModel：設定情報モデル

導入されたバージョン:
5.1
バージョン:
1.0

コンストラクタの概要
LDAPContextInfoBuilder()
メソッドの概要
static Map buildLDAPContextInfo(Map params)
設定情報モデルをログイングループID毎に作成し、Mapで返す。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LDAPContextInfoBuilder

public LDAPContextInfoBuilder()
メソッドの詳細

buildLDAPContextInfo

public static Map buildLDAPContextInfo(Map params)
設定情報モデルをログイングループID毎に作成し、Mapで返す。
「[AP_HOME]/conf/access-security.xml」の"security-config/user-security/auto-certification"及び
"security-config/user-security/certification"に設定されている＜init-param＞タグ情報を元に
作成する。

パラメータ:
params - xml上の設定情報
戻り値:
ログイングループID毎の設定情報モデルのMap
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LDAPContextInfoModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification.ldap.extension
クラス LDAPContextInfoModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel
public class LDAPContextInfoModel
extends Object

ユーザログインLDAP認証で認証情報モデルクラス(複数OU対応版)。

LDAPログイン認証を行うための認証情報を保持するクラス

導入されたバージョン:
5.1
バージョン:
1.0

コンストラクタの概要
LDAPContextInfoModel()
メソッドの概要
void | addOtherInfo(Object key, Object value) その他情報を追加する。
String | getBaseDn() ベースDNを取得する。
String | getConnectTimeout() 接続タイムアウト時間を取得する。
String | getConnectTimeoutPropertyName() 接続タイムアウトを設定するプロパティ名を取得する。
String | getGroupId() ログイングループIDを取得する。
String | getSerchFilter() 検索フィルタを取得する。
boolean | isAttemptOnFailedAuthentication() LDAP認証失敗(ユーザIDまたはパスワードが不正)時に次のプロバイダURLに認証の試みを取得する。
boolean | isLoadBalancing() ロードバランサの有効・無効を設定を取得する。
Hashtable | makeCertifyEnvironment(Hashtable serchEnvironment, String userDn, String delim, String passwd) LDAP認証用の設定情報を作成する。
SearchControls | makeSearchControls() 検索用のサーチコントローラーを作成する。
Hashtable[] | makeSerchEnvironments() LDAP上のユーザを検索する為の設定情報を作成する。
void | setAttemptOnFailedAuthentication(String attemptOnFailedAuthentication) LDAP認証失敗(ユーザIDまたはパスワードが不正)時に次のプロバイダURLに認証の試みを設定する。
void | setBaseDn(String baseDn) ベースDNを設定する。
void | setConnectTimeout(String connectTimeout) 接続タイムアウト時間を設定する。
void | setConnectTimeoutPropertyName(String connectTimeoutPropertyName) 接続タイムアウトを設定するプロパティ名を設定する。
void | setContextFactory(String contextFactory) コンテキストファクトリを設定する。
void | setCountLimit(String countLimit) 最大検索数を設定する。
void | setDerefLinf(String derefLinf) 間接参照の有無を設定する。
void | setGroupId(String groupId) ログイングループIDを設定する。
void | setLoadBalancing(String loadBalancing) ロードバランサの有効・無効を設定する。
void | setProviderUrl(String providerUrl) プロパイダーURLを設定する。
void | setReturningAttributes(String returningAttributes, String delim) 結果属性指定を設定する。
void | setReturningObj(String returningObj) 結果としてオブジェクト許可を設定する。
void | setSerchFilter(String serchFilter) 検索フィルタを設定する。
void | setSerchingDn(String serchingDn) 検索用ユーザDNを設定する。
void | setSerchingPw(String serchingPw) 検索用ユーザパスワードを設定する。
void | setTimeLimit(String timeLimit) 時間制限を設定する。
String | toString() 設定情報モデルの内容を返す。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

LDAPContextInfoModel

public LDAPContextInfoModel()
メソッドの詳細

getBaseDn

public String getBaseDn()
ベースDNを取得する。

戻り値:
ベースDN

setBaseDn

public void setBaseDn(String baseDn)
ベースDNを設定する。

パラメータ:
baseDn - ベースDN

setContextFactory

public void setContextFactory(String contextFactory)
コンテキストファクトリを設定する。

パラメータ:
contextFactory - コンテキストファクトリ

setCountLimit

public void setCountLimit(String countLimit)
最大検索数を設定する。

パラメータ:
countLimit - 最大検索数(文字列)

setDerefLinf

public void setDerefLinf(String derefLinf)
間接参照の有無を設定する。

パラメータ:
derefLinf - 間接参照の有無(文字列)

setProviderUrl

public void setProviderUrl(String providerUrl)
プロパイダーURLを設定する。

パラメータ:
providerUrl - プロパイダーURL

setReturningAttributes

public void setReturningAttributes(String returningAttributes,
                                   String delim)
結果属性指定を設定する。

パラメータ:
returningAttributes - 結果属性指定(複数指定可能)
delim - 区切文字

setReturningObj

public void setReturningObj(String returningObj)
結果としてオブジェクト許可を設定する。

パラメータ:
returningObj - 結果としてオブジェクト許可

getSerchFilter

public String getSerchFilter()
検索フィルタを取得する。

戻り値:
検索フィルタ

setSerchFilter

public void setSerchFilter(String serchFilter)
検索フィルタを設定する。

パラメータ:
serchFilter - 検索フィルタ

setLoadBalancing

public void setLoadBalancing(String loadBalancing)
ロードバランサの有効・無効を設定する。

パラメータ:
loadBalancing - ロードバランサの有効・無効

isLoadBalancing

public boolean isLoadBalancing()
ロードバランサの有効・無効を設定を取得する。

戻り値:
ロードバランサの有効・無効

setConnectTimeoutPropertyName

public void setConnectTimeoutPropertyName(String connectTimeoutPropertyName)
接続タイムアウトを設定するプロパティ名を設定する。

パラメータ:
connectTimeoutPropertyName - 接続タイムアウトを設定するプロパティ名

getConnectTimeoutPropertyName

public String getConnectTimeoutPropertyName()
接続タイムアウトを設定するプロパティ名を取得する。

戻り値:
接続タイムアウトを設定するプロパティ名

setConnectTimeout

public void setConnectTimeout(String connectTimeout)
接続タイムアウト時間を設定する。

パラメータ:
connectTimeout - 接続タイムアウト時間

getConnectTimeout

public String getConnectTimeout()
接続タイムアウト時間を取得する。

戻り値:
接続タイムアウト時間

isAttemptOnFailedAuthentication

public boolean isAttemptOnFailedAuthentication()
LDAP認証失敗(ユーザIDまたはパスワードが不正)時に次のプロバイダURLに認証の試みを取得する。

戻り値:
LDAP認証失敗時に次のプロバイダURLに認証の試み

setAttemptOnFailedAuthentication

public void setAttemptOnFailedAuthentication(String attemptOnFailedAuthentication)
LDAP認証失敗(ユーザIDまたはパスワードが不正)時に次のプロバイダURLに認証の試みを設定する。

パラメータ:
attemptOnFailedAuthentication - LDAP認証失敗時に次のプロバイダURLに認証の試み

setSerchingDn

public void setSerchingDn(String serchingDn)
検索用ユーザDNを設定する。

パラメータ:
serchingDn - 検索用ユーザDN

setSerchingPw

public void setSerchingPw(String serchingPw)
検索用ユーザパスワードを設定する。

パラメータ:
serchingPw - 検索用ユーザパスワード

setTimeLimit

public void setTimeLimit(String timeLimit)
時間制限を設定する。

パラメータ:
timeLimit - 時間制限

getGroupId

public String getGroupId()
ログイングループIDを取得する。

戻り値:
ログイングループID

setGroupId

public void setGroupId(String groupId)
ログイングループIDを設定する。

パラメータ:
groupId - ログイングループID

addOtherInfo

public void addOtherInfo(Object key,
                         Object value)
その他情報を追加する。

パラメータ:
key - キー
value - 値

makeSerchEnvironments

public Hashtable[] makeSerchEnvironments()
LDAP上のユーザを検索する為の設定情報を作成する。

戻り値:
設定情報

makeSearchControls

public SearchControls makeSearchControls()
検索用のサーチコントローラーを作成する。

戻り値:
サーチコントローラー

makeCertifyEnvironment

public Hashtable makeCertifyEnvironment(Hashtable serchEnvironment,
                                        String userDn,
                                        String delim,
                                        String passwd)
LDAP認証用の設定情報を作成する。

パラメータ:
serchEnvironment - 設定情報
userDn - ユーザDN
delim - ユーザDNとベースDNを繋げる区切文字(デフォルト：カンマ[,])
passwd - パスワード
戻り値:
設定情報

toString

public String toString()
設定情報モデルの内容を返す。

戻り値:
設定情報モデルの内容
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LDAPUserCertification (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification.ldap.extension
クラス LDAPUserCertification

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardUserCertification
        拡張 jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPUserCertification
すべての実装インタフェース:
UserCertification
public class LDAPUserCertification
extends StandardUserCertification

ユーザログインLDAP認証クラス(複数OU対応版)。

一般ユーザのLDAPログイン認証を行うためのクラス

初期化パラメータは以下のものを必要とします。
ログイングループごとに必須パラメータとLDAP環境による任意パラメータが必要です。

必須パラメータ | 説明
ログイングループID.provider-url | プロバイダURLを設定します(Ex : ldap://localhost:389/)。 カンマ(,)区切りで複数指定可能(Ex : ldap://localhost:389/, ldap://localhost:27272/)。 複数指定した場合、左から順にLDAPサーバに通信を試みます。通信できない場合のみ次の接続先に通信を試みます。
ログイングループID.context-factory | コンテキストファクトリを設定します。（Ex : com.sun.jndi.ldap.LdapCtxFactory）
ログイングループID.base-dn | 識別情報のベースを設定します。（Ex : dc=ldaps,dc=intra-mart,dc=jp）
ログイングループID.serch-filter | ユーザを特定する為に一意になる属性を設定します。（Ex : uid=?）
任意パラメータ | 説明
ログイングループID.load-balancing | ロードバランサを有効にします。(true/false) 設定しない場合はfalseとして扱います。 falseを指定した場合、プロバイダURLを左から順に認証を試みます。 trueを指定した場合、プロバイダURLの開始位置をランダムに決定し、決定した位置を基準に右方向に順に認証を試みます。
ログイングループID.attempt-on-failed-authentication | LDAP認証失敗(ユーザIDまたはパスワードが不正)時に次のプロバイダURLに認証を試みます(true/false)。 設定しない場合はfalseとして扱います。 falseを指定した場合、次のプロバイダURLに認証を試みません。 trueを指定した場合、次のプロバイダURLに認証を試みます。
ログイングループID.connect-timeout-property-name | 接続タイムアウトを設定するプロパティ名を設定します。（Ex : com.sun.jndi.ldap.connect.timeout）
ログイングループID.connect-timeout | 接続タイムアウト時間を設定します。 プロパティに com.sun.jndi.ldap.connect.timeout を指定した場合、ミリ秒数を示す0より大きい整数で指定し、LDAP プロバイダがこの値の期間中に接続を確立できないと、接続の試行は中止されます。 0 以下の整数指定した場合または設定しない場合は、TCP などのネットワークプロトコルのタイムアウト値が使用されます。
ログイングループID.serching-dn | LDAP上でユーザを検索する為のユーザ(DN)を設定します。(Ex : uid=admin,cn=User,dc=ldaps,dc=intra,dc=intra-mart,dc=jp) この設定は、ActiveDirectoryの場合には必要になります。
ログイングループID.serching-pw | LDAP上でユーザを検索する為のユーザパスワードを設定します。（Ex : admin） この設定は、ActiveDirectoryの場合には必要になります。
検索パラメータ | 説明
ログイングループID.count-limit | 最大検索数を設定します。デフォルト：0（上限無し）
ログイングループID.time-limit | 時間制限（ミリ秒）を設定します。デフォルト：0（無制限）
ログイングループID.deref-linf | 間接参照の有無を設定します。デフォルト：false
ログイングループID.returning-obj | 結果の一部がオブジェクトとして返るかを設定します。デフォルト：false
ログイングループID.returning-attribute 結果として返される属性を設定します。デフォルト：指定なし(すべての属性)
属性ID
指定した属性のみ返す。（複数指定可能：[,]カンマで区切る）
指定なし
すべての属性を返す

以下はログイングループ全体に対して設定するパラメータです。
パラメータ | 説明
permit-no-password | 空パスワードによる認証処理を許可するかどうか設定します。(true/false) 設定しない場合はfalseとして扱います。 falseを指定した場合、パスワード無しを認証失敗とみなします。 trueを指定した場合、空パスワードでLDAPに問い合わせます。
log | ログをコンソールに出力します。(true/false) 設定しない場合はfalseとして扱います。 デバッグ用オプションです。

ログイングループID.base-dnを元に、ログイングループID.serch-filterの'?'の部分をユーザIDに置換して、 LDAP検索を行い、ユーザのフルDNを作成し、そのフルDNで認証を行います。
このdnの記述方法は、LDAPサーバによって異なります。

導入されたバージョン:
5.1
バージョン:
1.0

コンストラクタの概要
LDAPUserCertification()
メソッドの概要
int | certification(LoginInfo loginInfo, Account account, HttpServletRequest req, HttpServletResponse resp) LDAPに対してユーザを認証します。
void | init(Map params) ユーザログイン認証の初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LDAPUserCertification

public LDAPUserCertification()
メソッドの詳細

init

public void init(Map params)
ユーザログイン認証の初期化を行います。

ユーザログイン認証のインスタンス生成時に一度だけ呼び出されます。

初期化パラメータを元にログイングループID毎の設定情報モデルを作成します。

定義:
インタフェース UserCertification 内の init
オーバーライド:
クラス StandardUserCertification 内の init
パラメータ:
params - 初期化パラメータのマップ

certification

public int certification(LoginInfo loginInfo,
                         Account account,
                         HttpServletRequest req,
                         HttpServletResponse resp)
LDAPに対してユーザを認証します。

定義:
インタフェース UserCertification 内の certification
オーバーライド:
クラス StandardUserCertification 内の certification
パラメータ:
loginInfo - ログイン情報
account - ユーザ情報
req - サーブレットリクエスト
resp - サーブレットレスポンス
戻り値:
認証結果
認証成功 | SecurityConstraint.CR_OK
認証失敗 | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.certification.ldap.extension (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.security.certification.ldap.extension
クラス
LDAPContextInfoBuilder
LDAPContextInfoModel
LDAPUserCertification


jp.co.intra_mart.foundation.security.certification.ldap.extension (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.certification.ldap.extension

ユーザログインLDAP認証クラス(複数OU対応版)の設定方法。

参照:
説明

クラスの概要
LDAPContextInfoBuilder | ログイングループ毎の設定情報モデルを作成するビルドクラス。
LDAPContextInfoModel | ユーザログインLDAP認証で認証情報モデルクラス(複数OU対応版)。
LDAPUserCertification | ユーザログインLDAP認証クラス(複数OU対応版)。

パッケージ jp.co.intra_mart.foundation.security.certification.ldap.extension の説明

ユーザログインLDAP認証クラス(複数OU対応版)の設定方法。

はじめにアプリケーションランタイム/doc/imart/WEB-INF/libフォルダにlib/ldap_extension.jarファイルをコピーします。

次にLDAPUserCertificationクラスを以下の設定ファイルに記述します。
サーバーマネージャインストールディレクトリ/conf/access-security.xml
<access-security>/<security-config>/<user-security>のタグに記述します。

    <auto-certification>
      <certification-class>jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPUserCertification</certification-class>
      <init-param>
        <param-name>初期化パラメータ名</param-name>
        <param-value>初期化パラメータ値</param-value>
      </init-param>
    </auto-certification>
    <certification>
      <certification-class>jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPUserCertification</certification-class>
      <init-param>
        <param-name>初期化パラメータ名</param-name>
        <param-value>初期化パラメータ値</param-value>
      </init-param>
    </certification>
<auto-certification>タグには、ログイン画面表示前のリクエストから認証処理を行うユーザログイン認証インタフェース実装クラスを設定します。
また、このタグは省略可能です。省略した場合は、自動ログインができなくなります。（ログイン画面を出さずにログイン）

<certification>タグには、ログイン画面からのリクエストから認証処理を行うユーザログイン認証インタフェース実装クラスを設定します。

<init-param>タグは複数設定可能です。
このタグに設定された値は、クラス初期化時に、init関数の引数として渡されます。
初期化パラメータの詳細はLDAPUserCertificationをご覧ください。

最後にサーバを再起動します。


jp.co.intra_mart.foundation.security.certification.ldap.extension クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.certification.ldap.extension の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoBuilder
    • class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel
    • class jp.co.intra_mart.foundation.security.certification.StandardUserCertification (implements jp.co.intra_mart.foundation.security.certification.UserCertification)
      • class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPUserCertification


パッケージ jp.co.intra_mart.foundation.security.certification.ldap.extension の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.certification.ldap.extension の使用

jp.co.intra_mart.foundation.security.certification.ldap.extension はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ErrorPageProvider (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
インタフェース ErrorPageProvider

既知の実装クラスの一覧:
StandardErrorPageProvider
public interface ErrorPageProvider

エラーページプロバイダインタフェース。

ユーザ用の各種エラーページを取得するためのインタフェース
エラーページプロバイダを実装する場合は必ずこのインタフェースを実装します。
アクセスセキュリティAPIはこのインタフェースを通じて必要なエラーページを取得します。

このインターフェースを実装したクラスを以下の設定ファイルに記述します。
サーバーマネージャインストールディレクトリ/conf/access-security.xml

 <access-security>
   <security-config>
     <error-page-provider>
       <page-provider-class>エラーページプロバイダインタフェース実装クラス名（フルパッケージ名）</page-provider-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </error-page-provider>
   </security-config>
 </access-security>
<init-param>タグは複数設定可能です。
このタグに設定された値は、クラス初期化時に、init関数の引数として渡されます。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getCertificationErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 認証失敗エラーページURLを取得する。
String | getGroupErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ログイングループエラーページURLを取得する。
String | getLicenceErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ライセンスエラーページURLを取得する。
String | getLockedErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ユーザロックエラーページURLを取得する。
String | getNoPermissionErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 無許可アクセスエラーページURLを取得する。
String | getSessionErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) セッションエラーページURLを取得する。
String | getSessionTimeoutErrorPage(HttpServletRequest request, HttpServletResponse response) セッションタイムアウトエラーページURLを取得する。
String | getSystemErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 認証処理エラーページURLを取得する。
void | init(Map params) ページプロバイダの初期化を行います。

メソッドの詳細

init

public void init(Map params)
ページプロバイダの初期化を行います。

ページプロバイダのインスタンス生成時に一度だけ呼び出されます。

パラメータ:
params - 初期化パラメータのマップ

getCertificationErrorPage

public String getCertificationErrorPage(SessionInfo sessionInfo,
                                        HttpServletRequest request,
                                        HttpServletResponse response)
認証失敗エラーページURLを取得する。

認証に失敗した場合( SecurityConstraint.CR_NG)に表示するページを取得する。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証失敗エラーページURL

getLockedErrorPage

public String getLockedErrorPage(SessionInfo sessionInfo,
                                 HttpServletRequest request,
                                 HttpServletResponse response)
ユーザロックエラーページURLを取得する。

各ログインタイプ別のページプロバイダからユーザロックエラーページが取得できなかった場合に利用される。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ユーザロックエラーページURL

getLicenceErrorPage

public String getLicenceErrorPage(SessionInfo sessionInfo,
                                  HttpServletRequest request,
                                  HttpServletResponse response)
ライセンスエラーページURLを取得する。

認証するユーザにライセンスがないか、または有効期間内でない場合( SecurityConstraint.CR_NO_LICENSE )に表示するページを取得する。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ライセンスエラーページURL

getGroupErrorPage

public String getGroupErrorPage(SessionInfo sessionInfo,
                                HttpServletRequest request,
                                HttpServletResponse response)
ログイングループエラーページURLを取得する。

認証するログイングループが存在しない場合( SecurityConstraint.CR_NO_GROUP )に表示するページを取得する。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ログイングループエラーページURL

getSessionErrorPage

public String getSessionErrorPage(SessionInfo sessionInfo,
                                  HttpServletRequest request,
                                  HttpServletResponse response)
セッションエラーページURLを取得する。

セッション情報に不整合が出た場合( SecurityConstraint.CR_SESSION_UNMATCH )に表示するページを取得する。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
セッションエラーページURL

getSessionTimeoutErrorPage

public String getSessionTimeoutErrorPage(HttpServletRequest request,
                                         HttpServletResponse response)
セッションタイムアウトエラーページURLを取得する。

セッションがタイムアウトになった場合( SecurityConstraint.CR_SESSION_TIMEOUT )に表示するページを取得する。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
セッションタイムアウトエラーページURL

getNoPermissionErrorPage

public String getNoPermissionErrorPage(SessionInfo sessionInfo,
                                       HttpServletRequest request,
                                       HttpServletResponse response)
無許可アクセスエラーページURLを取得する。

無許可のURLにアクセスした場合( SecurityConstraint.CR_NO_PERMISSION )に表示するページを取得する。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
無許可アクセスエラーページURL

getSystemErrorPage

public String getSystemErrorPage(SessionInfo sessionInfo,
                                 HttpServletRequest request,
                                 HttpServletResponse response)
認証処理エラーページURLを取得する。

認証処理中にエラーが発生した場合( SecurityConstraint.CR_ERROR)に表示するページを取得する。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証処理エラーページURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LDAPUserCertification (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス LDAPUserCertification

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardUserCertification
        拡張 jp.co.intra_mart.foundation.security.certification.LDAPUserCertification
すべての実装インタフェース:
UserCertification
public class LDAPUserCertification
extends StandardUserCertification

ユーザログインLDAP認証クラス。

一般ユーザのLDAPログイン認証を行うためのクラス

初期化パラメータは以下のものを必要とします。
ログイングループごとに3つのパラメータが必要です。

パラメータ名 | 説明
ログイングループID.provider-url | プロバイダURLを設定します(Ex : ldap://localhost:389/)。 カンマ(,)区切りで複数指定可能(Ex : ldap://localhost:389/, ldap://localhost:27272/)。 複数指定した場合、左から順にLDAPサーバに通信を試みます。通信できない場合のみ次の接続先に通信を試みます。
ログイングループID.load-balancing | ロードバランサを有効にします。(true/false) 設定しない場合はfalseとして扱います。 falseを指定した場合、プロバイダURLを左から順に認証を試みます。 trueを指定した場合、プロバイダURLの開始位置をランダムに決定し、決定した位置を基準に右方向に順に認証を試みます。
ログイングループID.dn | 識別情報を設定します。（Ex : uid=?,ou=People, o=ldaps.intra-mart.jp）
ログイングループID.context-factory | コンテキストファクトリを設定します。（Ex : com.sun.jndi.ldap.LdapCtxFactory）
ログイングループID.connect-timeout-property-name | 接続タイムアウトを設定するプロパティ名を設定します。（Ex : com.sun.jndi.ldap.connect.timeout）
ログイングループID.connect-timeout | 接続タイムアウト時間を設定します。 プロパティに com.sun.jndi.ldap.connect.timeout を指定した場合、ミリ秒数を示す0より大きい整数で指定し、LDAP プロバイダがこの値の期間中に接続を確立できないと、接続の試行は中止されます。 0 以下の整数指定した場合または設定しない場合は、TCP などのネットワークプロトコルのタイムアウト値が使用されます。
ログイングループID.attempt-on-failed-authentication | LDAP認証失敗(ユーザIDまたはパスワードが不正)時に次のプロバイダURLに認証を試みます(true/false)。 設定しない場合はfalseとして扱います。 falseを指定した場合、次のプロバイダURLに認証を試みません。 trueを指定した場合、次のプロバイダURLに認証を試みます。
permit-no-password | パスワードなしを許可します。(true/false) 設定しない場合はfalseとして扱います。 falseを指定した場合、パスワード無しを認証失敗とみなします。 trueを指定した場合、空パスワードでLDAPに問い合わせます。
log | ログをコンソールに出力します。(true/false) 設定しない場合はfalseとして扱います。 デバッグ用オプションです。

ログイングループID.dn に設定する'?'の部分をユーザIDに置換して、認証を行います。
このdnの記述方法は、LDAPサーバによって異なります。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
LDAPUserCertification()
メソッドの概要
int | certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証する。
void | init(Map params) ユーザログイン認証の初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LDAPUserCertification

public LDAPUserCertification()
メソッドの詳細

certification

public int certification(LoginInfo loginInfo,
                         Account user,
                         HttpServletRequest request,
                         HttpServletResponse response)
ユーザを認証する。

定義:
インタフェース UserCertification 内の certification
オーバーライド:
クラス StandardUserCertification 内の certification
パラメータ:
loginInfo - ログイン情報
user - ユーザ情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証結果
認証成功 | SecurityConstraint.CR_OK
認証失敗 | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
導入されたバージョン:
5.0

init

public void init(Map params)
ユーザログイン認証の初期化を行います。

ユーザログイン認証のインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース UserCertification 内の init
オーバーライド:
クラス StandardUserCertification 内の init
パラメータ:
params - 初期化パラメータのマップ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LoginInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
インタフェース LoginInfo

すべてのスーパーインタフェース:
LocaleProvider
既知のサブインタフェースの一覧:
LoginRequestInfo
public interface LoginInfo
extends LocaleProvider

intra-martログイン情報操作インタフェース。

intra-martログイン情報を操作するためのインタフェース
intra-martログイン情報を操作する場合は、必ずこのインターフェースを利用して行う。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getClientType() クライアントタイプを取得する。
String | getEncoding() エンコーディングを取得する。
String | getInitialUrl() 初期アクセスURLを取得する。
Locale | getLocale() ロケールを取得する。
String | getLoginGroup() ログイングループIDを取得する。
String | getLoginType() ログインタイプを取得する。
String | getPassword() ログインパスワードを取得する。
String | getUrl() ダイレクトＵＲＬを取得する。
String | getUrlSignature() ダイレクトＵＲＬ署名を取得する。
String | getUser() ログインユーザIDを取得する。
boolean | isDoneCertification() 認証が終了しているかどうかを取得する。

メソッドの詳細

getClientType

public String getClientType()
クライアントタイプを取得する。

戻り値:
クライアントタイプ

getEncoding

public String getEncoding()
エンコーディングを取得する。

定義:
インタフェース LocaleProvider 内の getEncoding
戻り値:
エンコーディング

getLocale

public Locale getLocale()
ロケールを取得する。

定義:
インタフェース LocaleProvider 内の getLocale
戻り値:
ロケール

getLoginGroup

public String getLoginGroup()
ログイングループIDを取得する。

戻り値:
ログイングループID

getLoginType

public String getLoginType()
ログインタイプを取得する。

戻り値:
ログインタイプ
関連項目:
SecurityConstraint.LT_SUPER, SecurityConstraint.LT_GROUP, SecurityConstraint.LT_USER

getPassword

public String getPassword()
ログインパスワードを取得する。

戻り値:
パスワード

getUrl

public String getUrl()
ダイレクトＵＲＬを取得する。

戻り値:
ダイレクトＵＲＬ

getUrlSignature

public String getUrlSignature()
ダイレクトＵＲＬ署名を取得する。

戻り値:
ダイレクトＵＲＬ署名

getUser

public String getUser()
ログインユーザIDを取得する。

戻り値:
ログインユーザID

getInitialUrl

public String getInitialUrl()
初期アクセスURLを取得する。

戻り値:
初期アクセスURL

isDoneCertification

public boolean isDoneCertification()
認証が終了しているかどうかを取得する。

戻り値:
すでに認証が終了している：true
まだ認証が終了していない：false
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginRequestInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
インタフェース LoginRequestInfo

すべてのスーパーインタフェース:
LocaleProvider, LoginInfo
public interface LoginRequestInfo
extends LoginInfo

intra-martログイン情報操作インタフェース。

intra-martログイン情報を操作するためのインタフェース
intra-martログイン情報を操作する場合は、必ずこのインターフェースを利用して行う。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getClientType() クライアントタイプを取得する。
String | getEncoding() エンコーディングを取得する。
Locale | getLocale() ロケールを取得する。
String | getLoginGroup() ログイングループIDを取得する。
String | getLoginType() ログインタイプを取得する。
String | getPassword() ログインパスワードを取得する。
String | getUrl() ダイレクトＵＲＬを取得する。
String | getUrlSignature() ダイレクトＵＲＬ署名を取得する。
String | getUser() ログインユーザIDを取得する。
void | setClientType(String clientType) クライアントタイプを設定する。
void | setDoneCertification(boolean cert) 認証が終了しているかどうかを設定する。
void | setEncoding(String encoding) ログインエンコーディングを設定する。
void | setInitialUrl(String url) 初期アクセスURLを設定する。
void | setLocale(Locale locale) ログインロケールを設定する。
void | setLoginGroup(String groupId) ログイングループIDを設定する。
void | setPassword(String password) ログインパスワードを設定する。
void | setUrl(String url) ダイレクトＵＲＬを設定する。
void | setUrlSignature(String signature) ダイレクトＵＲＬ署名を設定する。
void | setUser(String user) ログインユーザIDを設定する。
インタフェース jp.co.intra_mart.foundation.security.certification.LoginInfo から継承したメソッド
getInitialUrl, isDoneCertification

メソッドの詳細

getClientType

public String getClientType()
クライアントタイプを取得する。

定義:
インタフェース LoginInfo 内の getClientType
戻り値:
クライアントタイプ

getEncoding

public String getEncoding()
エンコーディングを取得する。

定義:
インタフェース LoginInfo 内の getEncoding
戻り値:
エンコーディング

getLocale

public Locale getLocale()
ロケールを取得する。

定義:
インタフェース LoginInfo 内の getLocale
戻り値:
ロケール

getLoginGroup

public String getLoginGroup()
ログイングループIDを取得する。

定義:
インタフェース LoginInfo 内の getLoginGroup
戻り値:
ログイングループID

getLoginType

public String getLoginType()
ログインタイプを取得する。

定義:
インタフェース LoginInfo 内の getLoginType
戻り値:
ログインタイプ
関連項目:
SecurityConstraint.LT_SUPER, SecurityConstraint.LT_GROUP, SecurityConstraint.LT_USER

getPassword

public String getPassword()
ログインパスワードを取得する。

定義:
インタフェース LoginInfo 内の getPassword
戻り値:
パスワード

getUrl

public String getUrl()
ダイレクトＵＲＬを取得する。

定義:
インタフェース LoginInfo 内の getUrl
戻り値:
ダイレクトＵＲＬ

getUrlSignature

public String getUrlSignature()
ダイレクトＵＲＬ署名を取得する。

定義:
インタフェース LoginInfo 内の getUrlSignature
戻り値:
ダイレクトＵＲＬ署名

getUser

public String getUser()
ログインユーザIDを取得する。

定義:
インタフェース LoginInfo 内の getUser
戻り値:
ログインユーザID

setClientType

public void setClientType(String clientType)
クライアントタイプを設定する。

パラメータ:
clientType - クライアントタイプ

setEncoding

public void setEncoding(String encoding)
ログインエンコーディングを設定する。

パラメータ:
encoding - ログインエンコーディング

setLocale

public void setLocale(Locale locale)
ログインロケールを設定する。

導入されたバージョン:
5.0

setLoginGroup

public void setLoginGroup(String groupId)
ログイングループIDを設定する。

パラメータ:
groupId - ログイングループID

setPassword

public void setPassword(String password)
ログインパスワードを設定する。

パラメータ:
password - パスワード

setUrl

public void setUrl(String url)
ダイレクトＵＲＬを設定する。

パラメータ:
url - ダイレクトＵＲＬ

setUrlSignature

public void setUrlSignature(String signature)
ダイレクトＵＲＬ署名を設定する。

パラメータ:
signature - ダイレクトＵＲＬ署名

setUser

public void setUser(String user)
ログインユーザIDを設定する。

パラメータ:
user - ログインユーザID

setInitialUrl

public void setInitialUrl(String url)
初期アクセスURLを設定する。

戻り値:
初期アクセスURL

setDoneCertification

public void setDoneCertification(boolean cert)
認証が終了しているかどうかを設定する。

パラメータ:
cert - 認証が終了している場合はtrueを設定
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.certification (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.security.certification
インタフェース
ErrorPageProvider
LoginInfo
LoginRequestInfo
RequestAnalyzer
SuperCertification
SuperCertificationListener
UserCertification
UserCertificationListener
UserPageProvider
クラス
LDAPUserCertification
PortalStandardUserPageProvider
SSORequestAnalyzer
StandardErrorPageProvider
StandardGroupSuperUserPageProvider
StandardRequestAnalyzer
StandardSuperUserCertification
StandardSuperUserPageProvider
StandardUserCertification
StandardUserPageProvider
SuperUserNoCertification


jp.co.intra_mart.foundation.security.certification (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.certification

認証に関連するクラスを提供します。

参照:
説明

インタフェースの概要
ErrorPageProvider | エラーページプロバイダインタフェース。
LoginInfo | intra-martログイン情報操作インタフェース。
LoginRequestInfo | intra-martログイン情報操作インタフェース。
RequestAnalyzer | リクエストアナライザインタフェース。
SuperCertification | 管理者ログイン認証インタフェース。
SuperCertificationListener | 管理者ログイン認証リスナーインタフェース。
UserCertification | ユーザログイン認証インタフェース。
UserCertificationListener | ユーザログイン認証リスナーインタフェース。
UserPageProvider | ユーザページプロバイダインタフェース。

クラスの概要
LDAPUserCertification | ユーザログインLDAP認証クラス。
PortalStandardUserPageProvider | ポータルユーザページプロバイダクラス。
SSORequestAnalyzer | SSOのログインリクエスト解析クラス。
StandardErrorPageProvider | 標準のエラーページプロバイダクラス。
StandardGroupSuperUserPageProvider | 標準のログイングループ管理者用ページプロバイダクラス。
StandardRequestAnalyzer | 標準のログインリクエスト解析クラス。
StandardSuperUserCertification | 管理者ログイン認証の実装クラス。
StandardSuperUserPageProvider | 標準のシステム管理者用のユーザページプロバイダクラス。
StandardUserCertification | ユーザログイン認証クラス。
StandardUserPageProvider | 標準のユーザページプロバイダクラス。
SuperUserNoCertification | システム管理者ログイン時に強制認証を行う実装クラスです。

パッケージ jp.co.intra_mart.foundation.security.certification の説明

認証に関連するクラスを提供します。


jp.co.intra_mart.foundation.security.certification クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.certification の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider (implements jp.co.intra_mart.foundation.security.certification.ErrorPageProvider)
    • class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider (implements jp.co.intra_mart.foundation.security.certification.UserPageProvider)
    • class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer (implements jp.co.intra_mart.foundation.security.certification.RequestAnalyzer)
      • class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer
    • class jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification (implements jp.co.intra_mart.foundation.security.certification.SuperCertification)
    • class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider (implements jp.co.intra_mart.foundation.security.certification.UserPageProvider)
    • class jp.co.intra_mart.foundation.security.certification.StandardUserCertification (implements jp.co.intra_mart.foundation.security.certification.UserCertification)
      • class jp.co.intra_mart.foundation.security.certification.LDAPUserCertification
    • class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider (implements jp.co.intra_mart.foundation.security.certification.UserPageProvider)
      • class jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider
    • class jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification (implements jp.co.intra_mart.foundation.security.certification.SuperCertification)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider
  • interface jp.co.intra_mart.foundation.security.LocaleProvider
    • interface jp.co.intra_mart.foundation.security.certification.LoginInfo
      • interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo
  • interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer
  • interface jp.co.intra_mart.foundation.security.certification.SuperCertification
  • interface jp.co.intra_mart.foundation.security.certification.SuperCertificationListener
  • interface jp.co.intra_mart.foundation.security.certification.UserCertification
  • interface jp.co.intra_mart.foundation.security.certification.UserCertificationListener
  • interface jp.co.intra_mart.foundation.security.certification.UserPageProvider


パッケージ jp.co.intra_mart.foundation.security.certification の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.certification の使用

jp.co.intra_mart.foundation.security.certification を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession |
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.password |

jp.co.intra_mart.foundation.security により使用される jp.co.intra_mart.foundation.security.certification のクラス
LoginInfo
intra-martログイン情報操作インタフェース。
LoginRequestInfo
intra-martログイン情報操作インタフェース。

jp.co.intra_mart.foundation.security.activesession により使用される jp.co.intra_mart.foundation.security.certification のクラス
LoginInfo
intra-martログイン情報操作インタフェース。
SuperCertificationListener
管理者ログイン認証リスナーインタフェース。
UserCertificationListener
ユーザログイン認証リスナーインタフェース。

jp.co.intra_mart.foundation.security.certification により使用される jp.co.intra_mart.foundation.security.certification のクラス
ErrorPageProvider
エラーページプロバイダインタフェース。
LoginInfo
intra-martログイン情報操作インタフェース。
LoginRequestInfo
intra-martログイン情報操作インタフェース。
RequestAnalyzer
リクエストアナライザインタフェース。
StandardRequestAnalyzer
標準のログインリクエスト解析クラス。
StandardUserCertification
ユーザログイン認証クラス。
StandardUserPageProvider
標準のユーザページプロバイダクラス。
SuperCertification
管理者ログイン認証インタフェース。
UserCertification
ユーザログイン認証インタフェース。
UserPageProvider
ユーザページプロバイダインタフェース。

jp.co.intra_mart.foundation.security.password により使用される jp.co.intra_mart.foundation.security.certification のクラス
PortalStandardUserPageProvider
ポータルユーザページプロバイダクラス。
StandardUserPageProvider
標準のユーザページプロバイダクラス。
UserPageProvider
ユーザページプロバイダインタフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PortalStandardUserPageProvider (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス PortalStandardUserPageProvider

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider
        拡張 jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider
すべての実装インタフェース:
UserPageProvider
直系の既知のサブクラス:
PasswordHistoryUserPageProvider
public class PortalStandardUserPageProvider
extends StandardUserPageProvider

ポータルユーザページプロバイダクラス。

標準のポータルユーザページプロバイダクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
PortalStandardUserPageProvider()
コンストラクタ。
メソッドの概要
protected String | getExtendedMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 拡張メインページURLを取得します。
String | getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得します。
void | init(Map params) ページプロバイダの初期化を行います。
クラス jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider から継承したメソッド
getMainPage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PortalStandardUserPageProvider

public PortalStandardUserPageProvider()
コンストラクタ。

メソッドの詳細

init

public void init(Map params)
ページプロバイダの初期化を行います。

ページプロバイダのインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース UserPageProvider 内の init
オーバーライド:
クラス StandardUserPageProvider 内の init
パラメータ:
params - 初期化パラメータのマップ

getInitalPage

public String getInitalPage(SessionInfo sessionInfo,
                            HttpServletRequest request,
                            HttpServletResponse response)
初期ページURLを取得します。

初期アクセス時に表示するURLを取得します。

定義:
インタフェース UserPageProvider 内の getInitalPage
オーバーライド:
クラス StandardUserPageProvider 内の getInitalPage
パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL

getExtendedMainPage

protected String getExtendedMainPage(SessionInfo sessionInfo,
                                     HttpServletRequest request,
                                     HttpServletResponse response)
拡張メインページURLを取得します。

ログイン後の拡張メイン画面を表示するURLを取得する。

オーバーライド:
クラス StandardUserPageProvider 内の getExtendedMainPage
パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RequestAnalyzer (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
インタフェース RequestAnalyzer

既知の実装クラスの一覧:
StandardRequestAnalyzer
public interface RequestAnalyzer

リクエストアナライザインタフェース。

サーブレットリクエストからログインに必要な情報を取得して返却するするインタフェース。
アクセスセキュリティAPIはこのインタフェースを通じて必要なログイン情報を取得します。

このインターフェースを実装したクラスを以下の設定ファイルに記述します。
サーバーマネージャインストールディレクトリ/conf/access-security.xml
<access-security>/<security-config>以下の<super-user-security>,<group-super-user-security>,<user-security>の各タグに記述します。

<super-user-security>は、システム管理者に対する設定です。
<group-super-user-security>は、ログイングループ管理者に対する設定です。
<user-security>は、一般ユーザに対する設定です。

     <initial-request-analyzer>
       <request-analyzer-class>クエストアナライザインタフェース実装クラス名（フルパッケージ名）</request-analyzer-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </initial-request-analyzer>
     <login-request-analyzer>
       <request-analyzer-class>クエストアナライザインタフェース実装クラス名（フルパッケージ名）</request-analyzer-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </login-request-analyzer>
<initial-request-analyzer>タグには、ログイン画面表示前のリクエストを解析するクエストアナライザインタフェース実装クラスを設定します。

<login-request-analyzer>タグには、ログイン画面からのリクエストを解析するクエストアナライザインタフェース実装クラスを設定します。

<init-param>タグは複数設定可能です。
このタグに設定された値は、クラス初期化時に、init関数の引数として渡されます。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getLoginGroupParameterName() ログイングループＩＤリクエストパラメータ名を取得する。
String | getUrlParameterName() ダイレクトＵＲＬリクエストパラメータ名を取得する。
String | getUrlSignParameterName() ダイレクトＵＲＬ署名リクエストパラメータ名を取得する。
String | getUserParameterName() ユーザＩＤリクエストパラメータ名を取得する。
void | init(Map params) ログインリクエストアナライザの初期化。
LoginInfo | parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。

メソッドの詳細

init

public void init(Map params)
ログインリクエストアナライザの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

parseRequest

public LoginInfo parseRequest(LoginRequestInfo loginInfo,
                              HttpServletRequest request)
リクエストパラメータの解析。

リクエストを解析してログイン情報を返却します。

パラメータ:
loginInfo - ベースとなるログインリクエスト情報
サーブレットリクエスト(request)から取得した情報をこのパラメータ(loginRequestInfo)のプロパティに設定して返却する。
request - HTTPサーブレットリクエスト
戻り値:
ログイン情報

getLoginGroupParameterName

public String getLoginGroupParameterName()
ログイングループＩＤリクエストパラメータ名を取得する。

戻り値:
ログイングループＩＤリクエストパラメータ名

getUserParameterName

public String getUserParameterName()
ユーザＩＤリクエストパラメータ名を取得する。

戻り値:
ユーザＩＤリクエストパラメータ名

getUrlParameterName

public String getUrlParameterName()
ダイレクトＵＲＬリクエストパラメータ名を取得する。

戻り値:
ダイレクトＵＲＬリクエストパラメータ名

getUrlSignParameterName

public String getUrlSignParameterName()
ダイレクトＵＲＬ署名リクエストパラメータ名を取得する。

戻り値:
ダイレクトＵＲＬ署名リクエストパラメータ名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SSORequestAnalyzer (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス SSORequestAnalyzer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer
        拡張 jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer
すべての実装インタフェース:
RequestAnalyzer
public class SSORequestAnalyzer
extends StandardRequestAnalyzer

SSOのログインリクエスト解析クラス。

im-SecureSignOnと連動するSSOログインリクエスト解析クラスです。

各リクエストパラメータから情報を取得してLoginInfoに設定します。
各リクエストパラメータから情報が取得されなかったものはLoginInfoに設定しません。
解析では、im-SecureSignOnののクッキー情報からログイングループ、ユーザ情報を取得します。

ログアウト時に特定のURLへのリクエストを行う場合は初期化パラメータで設定します。

パラメータ名 | 説明
sso-logout-url | ログアウト時にリクエストを行うURLを設定します。(Ex : http://server:8080/sso/logout.do)

設定方法：
このクラスを以下の設定ファイルに記述します。
サーバーマネージャインストールディレクトリ/conf/access-security.xml

   <user-security>
     <initial-request-analyzer>
       <request-analyzer-class>jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer</request-analyzer-class>
       <init-param>
         <param-name>sso-logout-url</param-name>
         <param-value>http://server:8080/sso/logout.do</param-value>
       </init-param>
     </initial-request-analyzer>
     .....
     <auto-certification>
       <certification-class>jp.co.intra_mart.foundation.security.certification.StandardUserCertification</certification-class>
       <init-param>
         <param-name>mobile-client-type</param-name>
         <param-value>mobile</param-value>
       </init-param>
     </auto-certification>
     <certification>
       <certification-class>jp.co.intra_mart.foundation.security.certification.StandardUserCertification</certification-class>
       <init-param>
       <param-name>mobile-client-type</param-name>
       <param-value>mobile</param-value>
     </init-param>
   </user-security>

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String | DEFAULT_AUTH_COOKIE_NAME
static String | DEFAULT_LOGIN_KEY
static String | KEY_AUTH_COOKIE_NAME
static String | KEY_LOGIN_KEY
static String | SSO_LOGOUT_URL
コンストラクタの概要
SSORequestAnalyzer()
メソッドの概要
void | init(Map params) ログインリクエストアナライザの初期化。
LoginInfo | parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。
クラス jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer から継承したメソッド
getLoginGroupParameterName, getShortCutName, getUrlParameterName, getUrlSignParameterName, getUserParameterName
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KEY_LOGIN_KEY

public static final String KEY_LOGIN_KEY
関連項目:
定数フィールド値

KEY_AUTH_COOKIE_NAME

public static final String KEY_AUTH_COOKIE_NAME
関連項目:
定数フィールド値

DEFAULT_LOGIN_KEY

public static final String DEFAULT_LOGIN_KEY
関連項目:
定数フィールド値

DEFAULT_AUTH_COOKIE_NAME

public static final String DEFAULT_AUTH_COOKIE_NAME
関連項目:
定数フィールド値

SSO_LOGOUT_URL

public static final String SSO_LOGOUT_URL
関連項目:
定数フィールド値
コンストラクタの詳細

SSORequestAnalyzer

public SSORequestAnalyzer()
メソッドの詳細

init

public void init(Map params)
ログインリクエストアナライザの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース RequestAnalyzer 内の init
オーバーライド:
クラス StandardRequestAnalyzer 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

parseRequest

public LoginInfo parseRequest(LoginRequestInfo loginInfo,
                              HttpServletRequest request)
リクエストパラメータの解析。

リクエストを解析してログイン情報を返却します。

定義:
インタフェース RequestAnalyzer 内の parseRequest
オーバーライド:
クラス StandardRequestAnalyzer 内の parseRequest
パラメータ:
loginInfo - ベースとなるログインリクエスト情報
サーブレットリクエスト(request)から取得した情報をこのパラメータ(loginRequestInfo)のプロパティに設定して返却する。
request - HTTPサーブレットリクエスト
戻り値:
ログイン情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardErrorPageProvider (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス StandardErrorPageProvider

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider
すべての実装インタフェース:
ErrorPageProvider
public class StandardErrorPageProvider
extends Object
implements ErrorPageProvider

標準のエラーページプロバイダクラス。

初期化パラメータは以下のものを必要とします。

パラメータ名 | 説明
certification-error-page | デフォルトの認証失敗画面URLを設定します。
locked-error-page | ユーザがロック状態の場合のデフォルト画面URLを設定します。
license-error-page | ログインライセンスがないの場合のデフォルト画面URLを設定します。
group-error-page | ログイングループが存在しない場合のデフォルト画面URLを設定します。
permission-error-page | 無許可アクセスページにアクセスした場合の画面のURLを設定します。
session-error-page | セッション情報不整合の場合のデフォルト画面URLを設定します。
session-timeout-page | セッションタイムアウトの場合のデフォルト画面URLを設定します。
system-error-page | デフォルトの認証処理失敗時のデフォルト画面URLを設定します。
certification-error-page.クライアントタイプ | クライアントタイプ別に認証失敗画面のURLを設定します。
locked-error-page.クライアントタイプ | クライアントタイプ別にユーザがロック状態の場合の画面URLを設定します。
license-error-page.クライアントタイプ | クライアントタイプ別にログインライセンスがない場合の画面URLを設定します。
group-error-page.クライアントタイプ | クライアントタイプ別にログイングループが存在しない場合の画面URLを設定します。
permission-error-page.クライアントタイプ | クライアントタイプ別に無許可アクセスページにアクセスした場合の画面のURLを設定します。
session-error-page.クライアントタイプ | クライアントタイプ別セッション情報不整合の場合の画面URLを設定します。
session-timeout-page.クライアントタイプ | クライアントタイプ別セッションタイムアウトの場合の画面URLを設定します。
system-error-page.クライアントタイプ | クライアントタイプ別認証処理失敗時の画面URLを設定します。

ページ決定のルール
certification-error-page.クライアントタイプ を例に取った場合
クライアントタイプ（large）の場合は

① certification-error-page.largeのＵＲＬ
② certification-error-pageのＵＲＬ

の順序でＵＲＬを決定します。
なお、設定するURLはコンテキストパスからの相対パスで記述します。
取得されるURLの先頭には、'/'をつけたものを返却します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
StandardErrorPageProvider()
デフォルトコンストラクタ
メソッドの概要
String | getCertificationErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 認証失敗エラーページURLを取得します。
String | getGroupErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ログイングループエラーページURLを取得します。
String | getLicenceErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ライセンスエラーページURLを取得します。
String | getLockedErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ユーザロックエラーページURLを取得します。
String | getNoPermissionErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 無許可アクセスエラーページURLを取得する。
String | getSessionErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) セッションエラーページURLを取得する。
String | getSessionTimeoutErrorPage(HttpServletRequest request, HttpServletResponse response) セッションタイムアウトエラーページURLを取得する。
String | getSystemErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 認証処理エラーページURLを取得する。
void | init(Map params) ページプロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardErrorPageProvider

public StandardErrorPageProvider()
デフォルトコンストラクタ

メソッドの詳細

init

public void init(Map params)
ページプロバイダの初期化を行います。

ページプロバイダのインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース ErrorPageProvider 内の init
パラメータ:
params - 初期化パラメータのマップ

getCertificationErrorPage

public String getCertificationErrorPage(SessionInfo sessionInfo,
                                        HttpServletRequest request,
                                        HttpServletResponse response)
認証失敗エラーページURLを取得します。

認証に失敗した場合( SecurityConstraint.CR_NG)に表示するページを取得します。

定義:
インタフェース ErrorPageProvider 内の getCertificationErrorPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証失敗エラーページURL

getGroupErrorPage

public String getGroupErrorPage(SessionInfo sessionInfo,
                                HttpServletRequest request,
                                HttpServletResponse response)
ログイングループエラーページURLを取得します。

認証するログイングループが存在しない場合( SecurityConstraint.CR_NO_GROUP )に表示するページを取得します。

定義:
インタフェース ErrorPageProvider 内の getGroupErrorPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ログイングループエラーページURL

getLicenceErrorPage

public String getLicenceErrorPage(SessionInfo sessionInfo,
                                  HttpServletRequest request,
                                  HttpServletResponse response)
ライセンスエラーページURLを取得します。

認証するユーザにライセンスがないか、または有効期間内でない場合( SecurityConstraint.CR_NO_LICENSE )に表示するページを取得します。

定義:
インタフェース ErrorPageProvider 内の getLicenceErrorPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ライセンスエラーページURL

getLockedErrorPage

public String getLockedErrorPage(SessionInfo sessionInfo,
                                 HttpServletRequest request,
                                 HttpServletResponse response)
ユーザロックエラーページURLを取得します。

各ログインタイプ別のページプロバイダからユーザロックエラーページが取得できなかった場合に利用される。

定義:
インタフェース ErrorPageProvider 内の getLockedErrorPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ユーザロックエラーページURL

getNoPermissionErrorPage

public String getNoPermissionErrorPage(SessionInfo sessionInfo,
                                       HttpServletRequest request,
                                       HttpServletResponse response)
無許可アクセスエラーページURLを取得する。

無許可のURLにアクセスした場合( SecurityConstraint.CR_NO_PERMISSION )に表示するページを取得する。

定義:
インタフェース ErrorPageProvider 内の getNoPermissionErrorPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
無許可アクセスエラーページURL

getSessionErrorPage

public String getSessionErrorPage(SessionInfo sessionInfo,
                                  HttpServletRequest request,
                                  HttpServletResponse response)
セッションエラーページURLを取得する。

セッション情報に不整合が出た場合( SecurityConstraint.CR_SESSION_UNMATCH )に表示するページを取得する。

定義:
インタフェース ErrorPageProvider 内の getSessionErrorPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
セッションエラーページURL

getSessionTimeoutErrorPage

public String getSessionTimeoutErrorPage(HttpServletRequest request,
                                         HttpServletResponse response)
セッションタイムアウトエラーページURLを取得する。

セッションがタイムアウトになった場合( SecurityConstraint.CR_SESSION_TIMEOUT )に表示するページを取得する。

定義:
インタフェース ErrorPageProvider 内の getSessionTimeoutErrorPage
パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
セッションタイムアウトエラーページURL

getSystemErrorPage

public String getSystemErrorPage(SessionInfo sessionInfo,
                                 HttpServletRequest request,
                                 HttpServletResponse response)
認証処理エラーページURLを取得する。

認証処理中にエラーが発生した場合( SecurityConstraint.CR_ERROR)に表示するページを取得する。

定義:
インタフェース ErrorPageProvider 内の getSystemErrorPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証処理エラーページURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardGroupSuperUserPageProvider (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス StandardGroupSuperUserPageProvider

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider
すべての実装インタフェース:
UserPageProvider
public class StandardGroupSuperUserPageProvider
extends Object
implements UserPageProvider

標準のログイングループ管理者用ページプロバイダクラス。

初期化パラメータは以下のものを必要とします。

パラメータ名 | 説明
initial-page | 初期画面のURLを設定します。
main-page | メイン画面のURLを設定します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
StandardGroupSuperUserPageProvider()
デフォルトコンストラクタ
メソッドの概要
String | getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得する。
String | getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得する。
void | init(Map params) ページプロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardGroupSuperUserPageProvider

public StandardGroupSuperUserPageProvider()
デフォルトコンストラクタ

メソッドの詳細

init

public void init(Map params)
ページプロバイダの初期化を行います。

ページプロバイダのインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース UserPageProvider 内の init
パラメータ:
params - 初期化パラメータのマップ

getInitalPage

public String getInitalPage(SessionInfo sessionInfo,
                            HttpServletRequest request,
                            HttpServletResponse response)
初期ページURLを取得する。

初期アクセス時に表示するURLを取得する。

定義:
インタフェース UserPageProvider 内の getInitalPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL

getMainPage

public String getMainPage(SessionInfo sessionInfo,
                          HttpServletRequest request,
                          HttpServletResponse response)
メインページURLを取得する。

ログイン後のメイン画面を表示するURLを取得する。

定義:
インタフェース UserPageProvider 内の getMainPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardRequestAnalyzer (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス StandardRequestAnalyzer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer
すべての実装インタフェース:
RequestAnalyzer
直系の既知のサブクラス:
SSORequestAnalyzer
public class StandardRequestAnalyzer
extends Object
implements RequestAnalyzer

標準のログインリクエスト解析クラス。

各リクエストパラメータから情報を取得してLoginInfoに設定します。
各リクエストパラメータから情報が取得されなかったものはLoginInfoに設定しません。
解析では、デフォルトのリクエストパラメータを使用して各情報を取得します。

初期化パラメータは以下のものを必要とします。
初期化パラメータは、すべて省略可能です。省略した場合は、各デフォルトのリクエストパラメータ名から情報を取得します。

パラメータ名 | 説明 | デフォルト値
login-type | ログインタイプが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_LOGIN_TYPE
client-type | クライアントタイプが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_CLIENT_TYPE
locale | ロケールが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_LOCALE
encoding | エンコーディングが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_ENCODING
login-group | ログイングループが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_LOGIN_GROUP
user | ユーザIDが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_USER
passward | パスワードが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_PASSWORD
url | ダイレクトＵＲＬが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_URL
url-sign | ダイレクトＵＲＬ署名が設定されるパラメータ名を設定します。 | SecurityConstraint.RP_URL_SIGN
shortcut | ショートカットＩＤが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_SHORTCUT

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
StandardRequestAnalyzer()
デフォルトコンストラクタ。
メソッドの概要
String | getLoginGroupParameterName() ログイングループＩＤリクエストパラメータ名を取得する。
String | getShortCutName() ショートカット用ＵＲＬパラメータ名を取得する。
String | getUrlParameterName() ダイレクトＵＲＬリクエストパラメータ名を取得する。
String | getUrlSignParameterName() ダイレクトＵＲＬ署名リクエストパラメータ名を取得する。
String | getUserParameterName() ユーザＩＤリクエストパラメータ名を取得する。
void | init(Map params) ログインリクエストアナライザの初期化。
LoginInfo | parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardRequestAnalyzer

public StandardRequestAnalyzer()
デフォルトコンストラクタ。

メソッドの詳細

getLoginGroupParameterName

public String getLoginGroupParameterName()
ログイングループＩＤリクエストパラメータ名を取得する。

定義:
インタフェース RequestAnalyzer 内の getLoginGroupParameterName
戻り値:
ログイングループＩＤリクエストパラメータ名

getUrlParameterName

public String getUrlParameterName()
ダイレクトＵＲＬリクエストパラメータ名を取得する。

定義:
インタフェース RequestAnalyzer 内の getUrlParameterName
戻り値:
ダイレクトＵＲＬリクエストパラメータ名

getUrlSignParameterName

public String getUrlSignParameterName()
ダイレクトＵＲＬ署名リクエストパラメータ名を取得する。

定義:
インタフェース RequestAnalyzer 内の getUrlSignParameterName
戻り値:
ダイレクトＵＲＬ署名リクエストパラメータ名

getUserParameterName

public String getUserParameterName()
ユーザＩＤリクエストパラメータ名を取得する。

定義:
インタフェース RequestAnalyzer 内の getUserParameterName
戻り値:
ユーザＩＤリクエストパラメータ名

getShortCutName

public String getShortCutName()
ショートカット用ＵＲＬパラメータ名を取得する。

戻り値:
ショートカット用ＵＲＬパラメータ名

init

public void init(Map params)
ログインリクエストアナライザの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース RequestAnalyzer 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

parseRequest

public LoginInfo parseRequest(LoginRequestInfo loginInfo,
                              HttpServletRequest request)
リクエストパラメータの解析。

リクエストを解析してログイン情報を返却します。

定義:
インタフェース RequestAnalyzer 内の parseRequest
パラメータ:
loginInfo - ベースとなるログインリクエスト情報
サーブレットリクエスト(request)から取得した情報をこのパラメータ(loginRequestInfo)のプロパティに設定して返却する。
request - HTTPサーブレットリクエスト
戻り値:
ログイン情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardSuperUserCertification (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス StandardSuperUserCertification

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification
すべての実装インタフェース:
SuperCertification
public class StandardSuperUserCertification
extends Object
implements SuperCertification

管理者ログイン認証の実装クラス。

管理者ログイン認証を行うためのクラス

初期化パラメータは以下のものを必要とします。

パラメータ名 | 説明
address-filter | クライアントのIPアドレスでフィルタリングします。 IPアドレスの正規表現を設定設定します。 必要ない場合は省略可能です。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
StandardSuperUserCertification()
デフォルトコンストラクタ
メソッドの概要
int | certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証します。
void | init(Map params) 管理者ログイン認証の初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardSuperUserCertification

public StandardSuperUserCertification()
デフォルトコンストラクタ

メソッドの詳細

init

public void init(Map params)
管理者ログイン認証の初期化を行います。

管理者ログイン認証のインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース SuperCertification 内の init
パラメータ:
params - 初期化パラメータのマップ

certification

public int certification(LoginInfo loginInfo,
                         SuperUser user,
                         HttpServletRequest request,
                         HttpServletResponse response)
管理者を認証します。

定義:
インタフェース SuperCertification 内の certification
パラメータ:
loginInfo - ログイン情報
user - 管理者情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証結果
認証成功 | SecurityConstraint.CR_OK
ユーザ不一致 | SecurityConstraint.CR_NO_USER
認証失敗(パスワード不一致) | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardSuperUserPageProvider (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス StandardSuperUserPageProvider

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider
すべての実装インタフェース:
UserPageProvider
public class StandardSuperUserPageProvider
extends Object
implements UserPageProvider

標準のシステム管理者用のユーザページプロバイダクラス。

初期化パラメータは以下のものを必要とします。

パラメータ名 | 説明
initial-page | 初期画面のURLを設定します。
main-page | メイン画面のURLを設定します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
StandardSuperUserPageProvider()
デフォルトコンストラクタ
メソッドの概要
String | getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得する。
String | getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得する。
void | init(Map params) ページプロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardSuperUserPageProvider

public StandardSuperUserPageProvider()
デフォルトコンストラクタ

メソッドの詳細

init

public void init(Map params)
ページプロバイダの初期化を行います。

ページプロバイダのインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース UserPageProvider 内の init
パラメータ:
params - 初期化パラメータのマップ

getInitalPage

public String getInitalPage(SessionInfo sessionInfo,
                            HttpServletRequest request,
                            HttpServletResponse response)
初期ページURLを取得する。

初期アクセス時に表示するURLを取得する。

定義:
インタフェース UserPageProvider 内の getInitalPage
パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL

getMainPage

public String getMainPage(SessionInfo sessionInfo,
                          HttpServletRequest request,
                          HttpServletResponse response)
メインページURLを取得する。

ログイン後のメイン画面を表示するURLを取得する。

定義:
インタフェース UserPageProvider 内の getMainPage
パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardUserCertification (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス StandardUserCertification

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardUserCertification
すべての実装インタフェース:
UserCertification
直系の既知のサブクラス:
LDAPUserCertification, LDAPUserCertification
public class StandardUserCertification
extends Object
implements UserCertification

ユーザログイン認証クラス。

標準のユーザログイン認証を行うためのクラス

初期化パラメータは以下のものを必要とします。

パラメータ名 | 説明
mobile-client-type | モバイルパスワードで認証を行うクライアントタイプを設定します。 (複数設定する場合は、カンマ区切りで設定します。) 例）small,medium

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
StandardUserCertification()
デフォルトコンストラクタ。
メソッドの概要
int | certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証します。
void | init(Map params) ユーザログイン認証の初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardUserCertification

public StandardUserCertification()
デフォルトコンストラクタ。

メソッドの詳細

init

public void init(Map params)
ユーザログイン認証の初期化を行います。

ユーザログイン認証のインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース UserCertification 内の init
パラメータ:
params - 初期化パラメータのマップ

certification

public int certification(LoginInfo loginInfo,
                         Account user,
                         HttpServletRequest request,
                         HttpServletResponse response)
ユーザを認証します。

定義:
インタフェース UserCertification 内の certification
パラメータ:
loginInfo - ログイン情報
user - ユーザ情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証結果
認証成功 | SecurityConstraint.CR_OK
認証失敗 | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardUserPageProvider (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス StandardUserPageProvider

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider
すべての実装インタフェース:
UserPageProvider
直系の既知のサブクラス:
PortalStandardUserPageProvider
public class StandardUserPageProvider
extends Object
implements UserPageProvider

標準のユーザページプロバイダクラス。
初期化パラメータは以下のものを必要とします。

パラメータ名 | 説明
initial-page | デフォルトの初期画面のURLを設定します。
initial-page.クライアントタイプ | クライアント別にデフォルトの初期画面のURLを設定します。
initial-page.クライアントタイプ.ログイングループID | ログイングループ別にデフォルトの初期画面のURLを設定します。
main-page | デフォルトのメイン画面のURLを設定します。
main-page.クライアントタイプ | クライアント別にデフォルトのメイン画面のURLを設定します。
main-page.クライアントタイプ.ログイングループID | ログイングループ別にデフォルトのメイン画面のURLを設定します。

ページ決定のルール
main-page.クライアントタイプ.[ログイングループID]を例に取った場合
ユーザがログイングループID（group_01）、クライアントタイプ（large）の場合は

① ダイレクトURLのURL
② ユーザに設定されているメインパターンIDのURL
③ main-page.large.group_01のURL
④ main-page.largeのURL
⑤ main-pageのURL

の順序でURLを決定します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
StandardUserPageProvider()
デフォルトコンストラクタ
メソッドの概要
protected String | getExtendedMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 拡張メインページURLを取得します。
String | getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得します。
String | getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得します。
void | init(Map params) ページプロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardUserPageProvider

public StandardUserPageProvider()
デフォルトコンストラクタ

メソッドの詳細

init

public void init(Map params)
ページプロバイダの初期化を行います。

ページプロバイダのインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース UserPageProvider 内の init
パラメータ:
params - 初期化パラメータのマップ

getInitalPage

public String getInitalPage(SessionInfo sessionInfo,
                            HttpServletRequest request,
                            HttpServletResponse response)
初期ページURLを取得します。

初期アクセス時に表示するURLを取得します。

定義:
インタフェース UserPageProvider 内の getInitalPage
パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL

getMainPage

public String getMainPage(SessionInfo sessionInfo,
                          HttpServletRequest request,
                          HttpServletResponse response)
メインページURLを取得します。

ログイン後のメイン画面を表示するURLを取得する。
拡張メインページが存在する（getExtendedMainPage()の返却値がNULLでない。）場合は、そのページを返却します。

定義:
インタフェース UserPageProvider 内の getMainPage
パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL

getExtendedMainPage

protected String getExtendedMainPage(SessionInfo sessionInfo,
                                     HttpServletRequest request,
                                     HttpServletResponse response)
拡張メインページURLを取得します。

ログイン後の拡張メイン画面を表示するURLを取得します。

ダイレクトURLが有効な場合は、ダイレクトURLをメインページとして返却します。
ログインユーザにメインページパターンIDが設定されている場合は、そのメインページを返却します。
上記のいずれにも当てはまらない場合はNULLを返却します。

パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SuperCertification (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
インタフェース SuperCertification

既知の実装クラスの一覧:
StandardSuperUserCertification, SuperUserNoCertification
public interface SuperCertification

管理者ログイン認証インタフェース。

管理者ログイン認証を行うためのインタフェース
管理者ログイン認証を実装する場合は必ずこのインターフェースを実装する。
アクセスセキュリティAPIはこのインタフェースを通じて認証処理を行います。

このインターフェースを実装したクラスを以下の設定ファイルに記述します。
サーバーマネージャインストールディレクトリ/conf/access-security.xml
<access-security>/<security-config>以下の<super-user-security>,<group-super-user-security>の各タグに記述します。

<super-user-security>は、システム管理者に対する設定です。
<group-super-user-security>は、ログイングループ管理者に対する設定です。

     <auto-certification>
       <certification-class>管理者ログイン認証インタフェース実装クラス名（フルパッケージ名）</certification-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </auto-certification>
     <certification>
       <certification-class>管理者ログイン認証インタフェース実装クラス名（フルパッケージ名）</certification-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </certification>
<auto-certification>タグには、ログイン画面表示前のリクエストから認証処理を行う管理者ログイン認証インタフェース実装クラスを設定します。
また、このタグは省略可能です。省略した場合は、自動ログインができなくなります。（ログイン画面を出さずにログイン）

<certification>タグには、ログイン画面からのリクエストから認証処理を行う管理者ログイン認証インタフェース実装クラスを設定します。

<init-param>タグは複数設定可能です。
このタグに設定された値は、クラス初期化時に、init関数の引数として渡されます。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
int | certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証する。
void | init(Map params) 管理者ログイン認証の初期化を行います。

メソッドの詳細

init

public void init(Map params)
管理者ログイン認証の初期化を行います。

管理者ログイン認証のインスタンス生成時に一度だけ呼び出されます。

パラメータ:
params - 初期化パラメータのマップ

certification

public int certification(LoginInfo loginInfo,
                         SuperUser user,
                         HttpServletRequest request,
                         HttpServletResponse response)
管理者を認証する。

パラメータ:
loginInfo - ログイン情報
user - 管理者情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証結果
認証成功 | SecurityConstraint.CR_OK
ユーザ不一致 | SecurityConstraint.CR_NO_USER
認証失敗(パスワード不一致) | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SuperCertificationListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
インタフェース SuperCertificationListener

既知の実装クラスの一覧:
GroupActiveSessionRegister
public interface SuperCertificationListener

管理者ログイン認証リスナーインタフェース。

管理者ログイン認証後にコールされる認証用リスナーインタフェース
管理者ログイン認証リスナーを実装する場合は必ずこのインターフェースを実装する。

このインターフェースを実装したクラスを以下の設定ファイルに記述します。
サーバーマネージャインストールディレクトリ/conf/access-security.xml
<access-security>/<security-config>以下の<super-user-security>,<group-super-user-security>の各タグに記述します。

<super-user-security>は、システム管理者に対する設定です。
<group-super-user-security>は、ログイングループ管理者に対する設定です。

     <certification-listener>
       <listener-class>管理者ログイン認証リスナーインタフェース実装クラス名（フルパッケージ名）</listener-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </certification-listener>

<init-param>タグは複数設定可能です。
このタグに設定された値は、クラス初期化時に、init関数の引数として渡されます。

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
void | doCertification(int certificationResult, LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者の認証後にコールされるメソッドです。
void | init(Map params) 管理者ログイン認証リスナーの初期化を行います。

メソッドの詳細

init

public void init(Map params)
管理者ログイン認証リスナーの初期化を行います。

管理者ログイン認証リスナーのインスタンス生成時に一度だけ呼び出されます。

パラメータ:
params - 初期化パラメータのマップ

doCertification

public void doCertification(int certificationResult,
                            LoginInfo loginInfo,
                            SuperUser user,
                            HttpServletRequest request,
                            HttpServletResponse response)
管理者の認証後にコールされるメソッドです。

パラメータ:
certificationResult - 認証結果
認証成功 | SecurityConstraint.CR_OK
ユーザ不一致 | SecurityConstraint.CR_NO_USER
認証失敗(パスワード不一致) | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
loginInfo - ログイン情報
user - 管理者情報
request - サーブレットリクエスト
response - サーブレットレスポンス
導入されたバージョン:
6.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SuperUserNoCertification (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス SuperUserNoCertification

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification
すべての実装インタフェース:
SuperCertification
public class SuperUserNoCertification
extends Object
implements SuperCertification

システム管理者ログイン時に強制認証を行う実装クラスです。

このクラスは、システム管理者ログインの認証を必ず成功させるクラスです。

システム管理者のパスワードを忘れた場合などの緊急事態にこのクラスを設定することで、必ずログインできるようになります。
事態を回避できた後は、セキュリティ上、必ず設定を元の状態に戻してください。
サーバ/conf/access-security.xmlのsecurity-configにこのクラスを利用するように設定することでクラスが利用されるようになります。

<security-config>
.....
<super-user-security>
.....
<certification>
<certification-class>jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification</certification-class>
 </certification>
.....
</super-user-security>
.....
</security-config>

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
SuperUserNoCertification()
デフォルトコンストラクタ
メソッドの概要
int | certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証します。
void | init(Map params) 管理者ログイン認証の初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SuperUserNoCertification

public SuperUserNoCertification()
デフォルトコンストラクタ

メソッドの詳細

init

public void init(Map params)
管理者ログイン認証の初期化を行います。

管理者ログイン認証のインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース SuperCertification 内の init
パラメータ:
params - 初期化パラメータのマップ

certification

public int certification(LoginInfo loginInfo,
                         SuperUser user,
                         HttpServletRequest request,
                         HttpServletResponse response)
管理者を認証します。

定義:
インタフェース SuperCertification 内の certification
パラメータ:
loginInfo - ログイン情報
user - 管理者情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証結果
認証成功 | SecurityConstraint.CR_OK
認証失敗 | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UserCertification (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
インタフェース UserCertification

既知の実装クラスの一覧:
StandardUserCertification
public interface UserCertification

ユーザログイン認証インタフェース。

ユーザログイン認証を行うためのインタフェース
ユーザログイン認証を実装する場合は必ずこのインターフェースを実装する。
アクセスセキュリティAPIはこのインタフェースを通じて認証処理を行います。

このインターフェースを実装したクラスを以下の設定ファイルに記述します。
サーバーマネージャインストールディレクトリ/conf/access-security.xml
<access-security>/<security-config>/<user-security>のタグに記述します。

     <auto-certification>
       <certification-class>ユーザログイン認証インタフェース実装クラス名（フルパッケージ名）</certification-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </auto-certification>
     <certification>
       <certification-class>ユーザログイン認証インタフェース実装クラス名（フルパッケージ名）</certification-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </certification>
<auto-certification>タグには、ログイン画面表示前のリクエストから認証処理を行ユーザログイン認証インタフェース実装クラスを設定します。
また、このタグは省略可能です。省略した場合は、自動ログインができなくなります。（ログイン画面を出さずにログイン）

<certification>タグには、ログイン画面からのリクエストから認証処理を行うユーザログイン認証インタフェース実装クラスを設定します。

<init-param>タグは複数設定可能です。
このタグに設定された値は、クラス初期化時に、init関数の引数として渡されます。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
int | certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証する。
void | init(Map params) ユーザログイン認証の初期化を行います。

メソッドの詳細

init

public void init(Map params)
ユーザログイン認証の初期化を行います。

ユーザログイン認証のインスタンス生成時に一度だけ呼び出されます。

パラメータ:
params - 初期化パラメータのマップ

certification

public int certification(LoginInfo loginInfo,
                         Account user,
                         HttpServletRequest request,
                         HttpServletResponse response)
ユーザを認証する。

パラメータ:
loginInfo - ログイン情報
user - ユーザ情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証結果
認証成功 | SecurityConstraint.CR_OK
認証失敗 | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserCertificationListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
インタフェース UserCertificationListener

既知の実装クラスの一覧:
UserActiveSessionRegister
public interface UserCertificationListener

ユーザログイン認証リスナーインタフェース。

ユーザログイン認証後にコールされる認証リスナーインタフェース
ユーザログイン認証リスナーを実装する場合は必ずこのインターフェースを実装する。

このインターフェースを実装したクラスを以下の設定ファイルに記述します。
サーバーマネージャインストールディレクトリ/conf/access-security.xml
<access-security>/<security-config>/<user-security> の
<certification> または <auto-certification> タグに記述します。

     <certification-listener>
       <listener-class>ユーザログイン認証リスナーインタフェース実装クラス名（フルパッケージ名）</listener-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </certification-listener>

<certification-listener>タグは複数設定可能です。
<init-param>タグは複数設定可能です。
このタグに設定された値は、クラス初期化時に、init関数の引数として渡されます。

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
void | doCertification(int certificationResult, LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザの認証後にコールされるメソッドです。
void | init(Map params) ユーザログイン認証リスナーの初期化を行います。

メソッドの詳細

init

public void init(Map params)
ユーザログイン認証リスナーの初期化を行います。

ユーザログイン認証リスナーのインスタンス生成時に一度だけ呼び出されます。

パラメータ:
params - 初期化パラメータのマップ

doCertification

public void doCertification(int certificationResult,
                            LoginInfo loginInfo,
                            Account user,
                            HttpServletRequest request,
                            HttpServletResponse response)
ユーザの認証後にコールされるメソッドです。

パラメータ:
certificationResult - 認証結果
認証成功 | SecurityConstraint.CR_OK
認証失敗 | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
loginInfo - ログイン情報
user - ユーザ情報
request - サーブレットリクエスト
response - サーブレットレスポンス
導入されたバージョン:
6.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserPageProvider (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
インタフェース UserPageProvider

既知の実装クラスの一覧:
StandardGroupSuperUserPageProvider, StandardSuperUserPageProvider, StandardUserPageProvider
public interface UserPageProvider

ユーザページプロバイダインタフェース。

ユーザ用の各種ページを取得するためのインタフェース
ユーザページプロバイダを実装する場合は必ずこのインターフェースを実装する。
アクセスセキュリティAPIはこのインタフェースを通じてログイン画面およびログイン後のメイン画面を行います。

このインターフェースを実装したクラスを以下の設定ファイルに記述します。
サーバーマネージャインストールディレクトリ/conf/access-security.xml
<access-security>/<security-config>以下の<super-user-security>,<group-super-user-security><user-security>の各タグに記述します。

<super-user-security>は、システム管理者に対する設定です。
<group-super-user-security>は、ログイングループ管理者に対する設定です。
<user-security>は、一般ユーザに対する設定です。

     <page-provider>
       <page-provider-class>ユーザページプロバイダ実装クラス名（フルパッケージ名）</page-provider-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </page-provider>
<init-param>タグは複数設定可能です。
このタグに設定された値は、クラス初期化時に、init関数の引数として渡されます。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得する。
String | getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得する。
void | init(Map params) ページプロバイダの初期化を行います。

メソッドの詳細

init

public void init(Map params)
ページプロバイダの初期化を行います。

ページプロバイダのインスタンス生成時に一度だけ呼び出されます。

パラメータ:
params - 初期化パラメータのマップ

getInitalPage

public String getInitalPage(SessionInfo sessionInfo,
                            HttpServletRequest request,
                            HttpServletResponse response)
初期ページURLを取得する。

初期アクセス時に表示するURLを取得する。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL

getMainPage

public String getMainPage(SessionInfo sessionInfo,
                          HttpServletRequest request,
                          HttpServletResponse response)
メインページURLを取得する。

ログイン後のメイン画面を表示するURLを取得する。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.AccessSecurityManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.AccessSecurityManager の使用

AccessSecurityManager を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での AccessSecurityManager の使用

AccessSecurityManager を返す jp.co.intra_mart.foundation.security のメソッド
static AccessSecurityManager AccessSecurityManager.getInstance()
セキュリティマネージャのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.ClientTypeInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.ClientTypeInfo の使用

ClientTypeInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での ClientTypeInfo の使用

ClientTypeInfo を返す jp.co.intra_mart.foundation.security のメソッド
ClientTypeInfo | SystemManager.getClientType(Locale reqLocale, String clientType) 指定ロケールでクライアントタイプ情報を取得します。
ClientTypeInfo[] | SystemManager.getClientTypes(Locale reqLocale) 指定ロケールでクライアントタイプ情報の一覧を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.ColorPatternInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.ColorPatternInfo の使用

ColorPatternInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での ColorPatternInfo の使用

ColorPatternInfo を返す jp.co.intra_mart.foundation.security のメソッド
ColorPatternInfo | SystemManager.getColorPattern(Locale reqLocale, String colorPatternId) 指定ロケールでカラーパターン情報を取得します。
ColorPatternInfo[] | SystemManager.getColorPatterns(Locale reqLocale) 指定ロケールでカラーパターン情報の一覧を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.DepartmentInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.DepartmentInfo の使用

DepartmentInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.navigator での DepartmentInfo の使用

DepartmentInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
DepartmentInfo[] | EventAccessInfo.getDepartments()
DepartmentInfo | EventAccessInfo.getDepartment(int i)

DepartmentInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | EventAccessInfo.setDepartments(DepartmentInfo[] departments)
void | EventAccessInfo.setDepartment(int i, DepartmentInfo department)
void | EventAccessInfo.addDepartment(DepartmentInfo department)

jp.co.intra_mart.foundation.security での DepartmentInfo の使用

DepartmentInfo を返す jp.co.intra_mart.foundation.security のメソッド
DepartmentInfo[] | StandardMenuAccessor.getMenuDepartments(String groupId, String id) すべてのメニュー組織を取得します。
DepartmentInfo[] | StandardAccessControllerAccessor.getControllerDepartments(String groupId, String id) すべてのアクセスコントローラ組織を取得します。

DepartmentInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | StandardMenuAccessor.deleteMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を削除します。
String[] | StandardMenuAccessor.getMenuIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つメニューIDをすべて取得します。
void | StandardMenuAccessor.insertMenuDepartment(String groupId, String menuId, DepartmentInfo departmentInfo) メニュー組織を新規に作成します。
void | StandardAccessControllerAccessor.deleteControllerDepartment(String groupId, String id, DepartmentInfo departmentInfo) アクセスコントローラ組織を削除します。
String[] | StandardAccessControllerAccessor.getControllerIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つコントローラIDをすべて取得します。
void | StandardAccessControllerAccessor.insertControllerDepartment(String groupId, String id, DepartmentInfo departmentInfo) アクセスコントローラ組織を新規に作成します。

jp.co.intra_mart.foundation.security.access での DepartmentInfo の使用

DepartmentInfo を返す jp.co.intra_mart.foundation.security.access のメソッド
DepartmentInfo[] | AccessControllerManager.getControllerDepartments(String controllerId) アクセスコントローラに紐付いた組織の一覧を取得します。
DepartmentInfo[] | AccessControllerAccessor.getControllerDepartments(String groupId, String id) すべてのアクセスコントローラ組織を取得します。

DepartmentInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | AccessControllerManager.addControllerDepartment(String controllerId, DepartmentInfo departmentInfo) 組織をアクセスコントローラに紐付けます。
void | AccessControllerManager.deleteControllerDepartment(String controllerId, DepartmentInfo departmentInfo) 組織の紐付けをアクセスコントローラから削除します。
String[] | AccessControllerManager.getControllerIdsByDepartment(DepartmentInfo[] departments) 指定された組織を持つアクセスコントローラIDをすべて取得します。
void | AccessControllerAccessor.deleteControllerDepartment(String groupId, String id, DepartmentInfo departmentInfo) アクセスコントローラ組織を削除します。
String[] | AccessControllerAccessor.getControllerIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つコントローラIDをすべて取得します。
void | AccessControllerAccessor.insertControllerDepartment(String groupId, String id, DepartmentInfo departmentInfo) アクセスコントローラ組織を新規に作成します。

jp.co.intra_mart.foundation.security.menu での DepartmentInfo の使用

DepartmentInfo を返す jp.co.intra_mart.foundation.security.menu のメソッド
DepartmentInfo[] | MenuManager.getMenuDepartments(String menuId) メニューに紐付いた組織の一覧を取得します。
DepartmentInfo[] | MenuAccessor.getMenuDepartments(String groupId, String id) すべてのメニュー組織を取得します。

DepartmentInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuManager.addMenuDepartment(String menuId, DepartmentInfo departmentInfo) 組織をメニューに紐付けます。
void | MenuManager.deleteMenuDepartment(String menuId, DepartmentInfo departmentInfo) 組織の紐付けをメニューから削除します。
String[] | MenuManager.getMenuIdsByDepartment(DepartmentInfo[] departments) 指定された組織を持つメニューIDをすべて取得します。
void | MenuAccessor.deleteMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を削除します。
String[] | MenuAccessor.getMenuIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つメニューIDをすべて取得します。
void | MenuAccessor.insertMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を新規に作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.ExtendsImport の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.ExtendsImport の使用

jp.co.intra_mart.foundation.security.ExtendsImport はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.ExtendsImportManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.ExtendsImportManager の使用

ExtendsImportManager を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での ExtendsImportManager の使用

ExtendsImportManager を返す jp.co.intra_mart.foundation.security のメソッド
static ExtendsImportManager ExtendsImportManager.getInstance()

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.INonTransaction の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.INonTransaction の使用

jp.co.intra_mart.foundation.security.INonTransaction はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.LocaleInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.LocaleInfo の使用

LocaleInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での LocaleInfo の使用

LocaleInfo を返す jp.co.intra_mart.foundation.security のメソッド
LocaleInfo | SystemManager.getLocale(Locale reqLocale, Locale locale) 指定ロケールでロケール情報を取得します。
LocaleInfo[] | SystemManager.getLocales(Locale reqLocale) 指定ロケールでロケール情報の一覧を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.LocaleProvider の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.LocaleProvider の使用

LocaleProvider を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security での LocaleProvider の使用

jp.co.intra_mart.foundation.security での LocaleProvider のサブインタフェース
interface | LocaleInfo ロケｰル情報・モデルインタフェース。
interface | SessionInfo intra-martセッション情報参照インタフェース。

jp.co.intra_mart.foundation.security.account での LocaleProvider の使用

LocaleProvider を実装している jp.co.intra_mart.foundation.security.account のクラス
 class Account
アカウントモデル。

jp.co.intra_mart.foundation.security.admin での LocaleProvider の使用

LocaleProvider を実装している jp.co.intra_mart.foundation.security.admin のクラス
 class SuperUser
スーパーユーザ・モデルインタフェース。

jp.co.intra_mart.foundation.security.certification での LocaleProvider の使用

jp.co.intra_mart.foundation.security.certification での LocaleProvider のサブインタフェース
interface | LoginInfo intra-martログイン情報操作インタフェース。
interface | LoginRequestInfo intra-martログイン情報操作インタフェース。

jp.co.intra_mart.foundation.security.group での LocaleProvider の使用

LocaleProvider を実装している jp.co.intra_mart.foundation.security.group のクラス
 class LoginGroup
ログイングループ・モデル。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.PostInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.PostInfo の使用

PostInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.navigator での PostInfo の使用

PostInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
PostInfo[] | EventAccessInfo.getPosts()
PostInfo | EventAccessInfo.getPost(int i)

PostInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | EventAccessInfo.setPosts(PostInfo[] posts)
void | EventAccessInfo.setPost(int i, PostInfo post)
void | EventAccessInfo.addPost(PostInfo post)

jp.co.intra_mart.foundation.security での PostInfo の使用

PostInfo を返す jp.co.intra_mart.foundation.security のメソッド
PostInfo[] | StandardMenuAccessor.getMenuPosts(String groupId, String id) すべてのメニュー役職を取得します。
PostInfo[] | StandardAccessControllerAccessor.getControllerPosts(String groupId, String id) すべてのアクセスコントローラ役職を取得します。

PostInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | StandardMenuAccessor.deleteMenuPost(String groupId, String id, PostInfo postInfo) メニュー役職を削除します。
String[] | StandardMenuAccessor.getMenuIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つメニューIDをすべて取得します。
void | StandardMenuAccessor.insertMenuPost(String groupId, String menuId, PostInfo postInfo) メニュー役職を新規に作成します。
void | StandardAccessControllerAccessor.deleteControllerPost(String groupId, String id, PostInfo postInfo) アクセスコントローラ役職を削除します。
String[] | StandardAccessControllerAccessor.getControllerIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つコントローラIDをすべて取得します。
void | StandardAccessControllerAccessor.insertControllerPost(String groupId, String id, PostInfo postInfo) アクセスコントローラ役職を新規に作成します。

jp.co.intra_mart.foundation.security.access での PostInfo の使用

PostInfo を返す jp.co.intra_mart.foundation.security.access のメソッド
PostInfo[] | AccessControllerManager.getControllerPosts(String controllerId) アクセスコントローラに紐付いた役職の一覧を取得します。
PostInfo[] | AccessControllerAccessor.getControllerPosts(String groupId, String id) すべてのアクセスコントローラ役職を取得します。

PostInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | AccessControllerManager.addControllerPost(String controllerId, PostInfo postInfo) 役職をアクセスコントローラに紐付けます。
void | AccessControllerManager.deleteControllerPost(String controllerId, PostInfo postInfo) 役織の紐付けをアクセスコントローラから削除します。
String[] | AccessControllerManager.getControllerIdsByPost(PostInfo[] posts) 指定された役職を持つアクセスコントローラIDをすべて取得します。
void | AccessControllerAccessor.deleteControllerPost(String groupId, String id, PostInfo postInfo) アクセスコントローラ役職を削除します。
String[] | AccessControllerAccessor.getControllerIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つコントローラIDをすべて取得します。
void | AccessControllerAccessor.insertControllerPost(String groupId, String id, PostInfo postInfo) アクセスコントローラ役職を新規に作成します。

jp.co.intra_mart.foundation.security.menu での PostInfo の使用

PostInfo を返す jp.co.intra_mart.foundation.security.menu のメソッド
PostInfo[] | MenuManager.getMenuPosts(String menuId) メニューに紐付いた役職の一覧を取得します。
PostInfo[] | MenuAccessor.getMenuPosts(String groupId, String id) すべてのメニュー役職を取得します。

PostInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuManager.addMenuPost(String menuId, PostInfo postInfo) 役職をメニューに紐付けます。
void | MenuManager.deleteMenuPost(String menuId, PostInfo postInfo) 役織の紐付けをメニューから削除します。
String[] | MenuManager.getMenuIdsByPost(PostInfo[] posts) 指定された役職を持つメニューIDをすべて取得します。
void | MenuAccessor.deleteMenuPost(String groupId, String id, PostInfo postInfo) メニュー役職を削除します。
String[] | MenuAccessor.getMenuIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つメニューIDをすべて取得します。
void | MenuAccessor.insertMenuPost(String groupId, String id, PostInfo postInfo) メニュー役職を新規に作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.PublicGroupInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.PublicGroupInfo の使用

PublicGroupInfo を使用しているパッケージ
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.navigator での PublicGroupInfo の使用

PublicGroupInfo を返す jp.co.intra_mart.foundation.navigator のメソッド
PublicGroupInfo[] | EventAccessInfo.getPublicGroups()
PublicGroupInfo | EventAccessInfo.getPublicGroup(int i)

PublicGroupInfo 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | EventAccessInfo.setPublicGroups(PublicGroupInfo[] publicGroups)
void | EventAccessInfo.setPublicGroup(int i, PublicGroupInfo publicGroup)
void | EventAccessInfo.addPublicGroup(PublicGroupInfo publicGroup)

jp.co.intra_mart.foundation.security での PublicGroupInfo の使用

PublicGroupInfo を返す jp.co.intra_mart.foundation.security のメソッド
PublicGroupInfo[] | StandardMenuAccessor.getMenuPublicGroups(String groupId, String id) すべてのメニューパブリックグループを取得します。
PublicGroupInfo[] | StandardAccessControllerAccessor.getControllerPublicGroups(String groupId, String id) すべてのアクセスコントローラパブリックグループを取得します。

PublicGroupInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | StandardMenuAccessor.deleteMenuPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) メニューパブリックグループを削除します。
String[] | StandardMenuAccessor.getMenuIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つメニューIDをすべて取得します。
void | StandardMenuAccessor.insertMenuPublicGroup(String groupId, String menuId, PublicGroupInfo publicGroupInfo) メニューパブリックグループを新規に作成します。
void | StandardAccessControllerAccessor.deleteControllerPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) アクセスコントローラパブリックグループを削除します。
String[] | StandardAccessControllerAccessor.getControllerIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つコントローラIDをすべて取得します。
void | StandardAccessControllerAccessor.insertControllerPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) アクセスコントローラパブリックグループを新規に作成します。

jp.co.intra_mart.foundation.security.access での PublicGroupInfo の使用

PublicGroupInfo を返す jp.co.intra_mart.foundation.security.access のメソッド
PublicGroupInfo[] | AccessControllerManager.getControllerPublicGroups(String controllerId) アクセスコントローラに紐付いたパブリックグループの一覧を取得します。
PublicGroupInfo[] | AccessControllerAccessor.getControllerPublicGroups(String groupId, String id) すべてのアクセスコントローラパブリックグループを取得します。

PublicGroupInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | AccessControllerManager.addControllerPublicGroup(String controllerId, PublicGroupInfo publicGroupInfo) パブリックグループをアクセスコントローラに紐付けます。
void | AccessControllerManager.deleteControllerPublicGroup(String controllerId, PublicGroupInfo publicGroupInfo) パブリックグループの紐付けをアクセスコントローラから削除します。
String[] | AccessControllerManager.getControllerIdsByPublicGroup(PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つアクセスコントローラIDをすべて取得します。
void | AccessControllerAccessor.deleteControllerPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) アクセスコントローラパブリックグループを削除します。
String[] | AccessControllerAccessor.getControllerIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つコントローラIDをすべて取得します。
void | AccessControllerAccessor.insertControllerPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) アクセスコントローラパブリックグループを新規に作成します。

jp.co.intra_mart.foundation.security.menu での PublicGroupInfo の使用

PublicGroupInfo を返す jp.co.intra_mart.foundation.security.menu のメソッド
PublicGroupInfo[] | MenuManager.getMenuPublicGroups(String menuId) メニューに紐付いたパブリックグループの一覧を取得します。
PublicGroupInfo[] | MenuAccessor.getMenuPublicGroups(String groupId, String id) すべてのメニューパブリックグループを取得します。

PublicGroupInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuManager.addMenuPublicGroup(String menuId, PublicGroupInfo publicGroupInfo) パブリックグループをメニューに紐付けます。
void | MenuManager.deleteMenuPublicGroup(String menuId, PublicGroupInfo publicGroupInfo) パブリックグループの紐付けをメニューから削除します。
String[] | MenuManager.getMenuIdsByPublicGroup(PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つメニューIDをすべて取得します。
void | MenuAccessor.deleteMenuPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) メニューパブリックグループを削除します。
String[] | MenuAccessor.getMenuIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つメニューIDをすべて取得します。
void | MenuAccessor.insertMenuPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) メニューパブリックグループを新規に作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.SecurityConstraint の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.SecurityConstraint の使用

jp.co.intra_mart.foundation.security.SecurityConstraint はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.SessionConfig の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.SessionConfig の使用

SessionConfig を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での SessionConfig の使用

SessionConfig を返す jp.co.intra_mart.foundation.security のメソッド
 SessionConfig AccessSecurityManager.getSessionConfig()
セッション情報保管パラメータを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.SessionInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.SessionInfo の使用

SessionInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession |
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.duplication |
jp.co.intra_mart.foundation.security.password |

jp.co.intra_mart.foundation.security での SessionInfo の使用

SessionInfo を返す jp.co.intra_mart.foundation.security のメソッド
SessionInfo | AccessSecurityManager.getCookieSessionInfo() カレントスレッド情報のクッキーからintra-martセッション情報を取得します。
SessionInfo | AccessSecurityManager.getCookieSessionInfo(HttpServletRequest request) クッキーからintra-martセッション情報を取得します。
SessionInfo | AccessSecurityManager.getSessionInfo() カレントスレッド情報からintra-martセッション情報を取得します。
SessionInfo | AccessSecurityManager.getSessionInfo(HttpServletRequest request, HttpServletResponse response) intra-martセッション情報を取得します。

SessionInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
String | AccessSecurityManager.getInitialPage(SessionInfo sessionInfo) カレントスレッド情報から初期アクセスページURLを取得します。
String | AccessSecurityManager.getInitialPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期アクセスページURLを取得します。
String | AccessSecurityManager.getMainPage(SessionInfo sessionInfo) カレントスレッド情報からメインページURLを取得します。
String | AccessSecurityManager.getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得します。
int | AccessSecurityManager.getSessionMode(SessionInfo sessionInfo) intra-martセッションの状態を取得します。

jp.co.intra_mart.foundation.security.activesession での SessionInfo の使用

SessionInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.activesession のメソッド
String | StandardActiveSessionAccessor.getActiveSessionInvalidatedPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 引数で指定されたアクティブなセッション情報が無効化されたされていた場合の遷移先ページURLを取得します。
String | ActiveSessionManager.getActiveSessionInvalidatedPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 引数で指定されたアクティブなセッション情報が無効化されたされていた場合の遷移先ページURLを取得します。
String | ActiveSessionAccessor.getActiveSessionInvalidatedPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 引数で指定されたアクティブなセッション情報が無効化されたされていた場合の遷移先ページURLを取得します。

SessionInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.activesession のコンストラクタ
ActiveSessionInfo(SessionInfo sessionInfo, HttpSession session, String remoteAddr, String userAgent)
コンストラクタ。
ActiveSessionInfo(SessionInfo sessionInfo, String sessionId, int expireInterval, String remoteAddr, String userAgent)
コンストラクタ。

jp.co.intra_mart.foundation.security.certification での SessionInfo の使用

SessionInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.certification のメソッド
String | UserPageProvider.getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得する。
String | UserPageProvider.getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得する。
String | ErrorPageProvider.getCertificationErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 認証失敗エラーページURLを取得する。
String | ErrorPageProvider.getLockedErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ユーザロックエラーページURLを取得する。
String | ErrorPageProvider.getLicenceErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ライセンスエラーページURLを取得する。
String | ErrorPageProvider.getGroupErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ログイングループエラーページURLを取得する。
String | ErrorPageProvider.getSessionErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) セッションエラーページURLを取得する。
String | ErrorPageProvider.getNoPermissionErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 無許可アクセスエラーページURLを取得する。
String | ErrorPageProvider.getSystemErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 認証処理エラーページURLを取得する。
String | StandardUserPageProvider.getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得します。
String | StandardUserPageProvider.getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得します。
protected String | StandardUserPageProvider.getExtendedMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 拡張メインページURLを取得します。
String | StandardSuperUserPageProvider.getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得する。
String | StandardSuperUserPageProvider.getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得する。
String | StandardGroupSuperUserPageProvider.getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得する。
String | StandardGroupSuperUserPageProvider.getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得する。
String | StandardErrorPageProvider.getCertificationErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 認証失敗エラーページURLを取得します。
String | StandardErrorPageProvider.getGroupErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ログイングループエラーページURLを取得します。
String | StandardErrorPageProvider.getLicenceErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ライセンスエラーページURLを取得します。
String | StandardErrorPageProvider.getLockedErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ユーザロックエラーページURLを取得します。
String | StandardErrorPageProvider.getNoPermissionErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 無許可アクセスエラーページURLを取得する。
String | StandardErrorPageProvider.getSessionErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) セッションエラーページURLを取得する。
String | StandardErrorPageProvider.getSystemErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 認証処理エラーページURLを取得する。
String | PortalStandardUserPageProvider.getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得します。
protected String | PortalStandardUserPageProvider.getExtendedMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 拡張メインページURLを取得します。

jp.co.intra_mart.foundation.security.duplication での SessionInfo の使用

SessionInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.duplication のメソッド
String | StandardDuplicateLoginAccessor.getDuplicateLoginDetectionPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 引数で指定されたアクティブなセッション情報が重複ログインした場合の遷移先ページURLを取得します。
String | DuplicateLoginManager.getDuplicateLoginDetectionPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 引数で指定されたアクティブなセッション情報が重複ログインした場合の遷移先ページURLを取得します。
String | DuplicateLoginAccessor.getDuplicateLoginDetectionPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 引数で指定されたアクティブなセッション情報が重複ログインした場合の遷移先ページURLを取得します。

jp.co.intra_mart.foundation.security.password での SessionInfo の使用

SessionInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.password のメソッド
protected  String PasswordHistoryUserPageProvider.getExtendedMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor の使用

jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.StandardAccountAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.StandardAccountAccessor の使用

jp.co.intra_mart.foundation.security.StandardAccountAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.StandardBatchAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.StandardBatchAccessor の使用

jp.co.intra_mart.foundation.security.StandardBatchAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.StandardCalendarAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.StandardCalendarAccessor の使用

jp.co.intra_mart.foundation.security.StandardCalendarAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.StandardMenuAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.StandardMenuAccessor の使用

jp.co.intra_mart.foundation.security.StandardMenuAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.StandardRoleAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.StandardRoleAccessor の使用

jp.co.intra_mart.foundation.security.StandardRoleAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.SystemManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.SystemManager の使用

SystemManager を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での SystemManager の使用

SystemManager を返す jp.co.intra_mart.foundation.security のメソッド
static SystemManager SystemManager.getInstance()
システムマネージャインスタンスを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.SystemSourceProvider の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.SystemSourceProvider の使用

SystemSourceProvider を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での SystemSourceProvider の使用

SystemSourceProvider 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
static void SystemManager.setSorucePovider(SystemSourceProvider provider)
ソースプロバイダを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.cryption.Cryption の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.cryption.Cryption の使用

Cryption を使用しているパッケージ
jp.co.intra_mart.foundation.security.cryption 暗号化に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.cryption での Cryption の使用

Cryption を実装している jp.co.intra_mart.foundation.security.cryption のクラス
class | NoCryption 暗号化処理を行わない実装クラス。
class | StandardCryption 文字列の暗号化・復号化を行う標準の実装クラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.cryption.NoCryption の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.cryption.NoCryption の使用

jp.co.intra_mart.foundation.security.cryption.NoCryption はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.cryption.StandardCryption の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.cryption.StandardCryption の使用

jp.co.intra_mart.foundation.security.cryption.StandardCryption はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Cryption (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.cryption
インタフェース Cryption

既知の実装クラスの一覧:
NoCryption, StandardCryption
public interface Cryption

文字列の暗号化・復号化インタフェース。

文字列の暗号化・復号化を行うインタフェース

jp.co.intra_mart.foundation.security.StandardAccountAccessorを用いている場合は、
サーバ/conf/access-security.xmlのaccess-configにこのクラスを実装したクラスを利用するように設定することでこのクラスが利用されるようになります。

jp.co.intra_mart.foundation.security.StandardAccountAccessorでは、パスワードおよびモバイルパスワードを
このクラスを実装したクラスの暗号化処理を使って暗号化・復号化を行っています。
<access-config>
.....
<account>
<accessor>
<accessor-class>jp.co.intra_mart.foundation.security.StandardAccountAccessor</accessor-class>
<init-param>
<param-name>cryption-class</param-name>
<param-value>jp.co.intra_mart.foundation.security.cryption.Cryptionを実装したクラス</param-value>
</init-param>
 </accessor>
</account>
.....
</access-config>

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | decrypt(String secret) 暗号化された文字列を復号するe。
String | encrypt(String plane) 文字列を暗号化する。

メソッドの詳細

decrypt

public String decrypt(String secret)
暗号化された文字列を復号するe。

パラメータ:
secret - 暗号化された文字列
戻り値:
復号化された文字列

encrypt

public String encrypt(String plane)
文字列を暗号化する。

パラメータ:
plane - 暗号化する文字列
戻り値:
暗号化された文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


NoCryption (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.cryption
クラス NoCryption

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.cryption.NoCryption
すべての実装インタフェース:
Cryption
public class NoCryption
extends Object
implements Cryption

暗号化処理を行わない実装クラス。

暗号化処理を行わないクラスです。
標準では、アカウントのパスワード、モバイルパスワードを暗号化するためにStandardCryption が利用されますが、
このクラスを用いることにより、データストアに暗号化を行わないで、保管することができます。
サーバ/conf/access-security.xmlのaccess-configにこのクラスを利用するように設定することでこのクラスが利用されるようになります。

<access-config>
.....
<account>
<accessor>
<accessor-class>jp.co.intra_mart.foundation.security.StandardAccountAccessor</accessor-class>
<init-param>
<param-name>cryption-class</param-name>
<param-value>jp.co.intra_mart.foundation.security.cryption.NoCryption</param-value>
</init-param>
 </accessor>
</account>
.....
</access-config>

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
NoCryption()
コンストラクタ。
メソッドの概要
String | decrypt(String secret) 暗号化された文字列を復号するe。
String | encrypt(String plane) 文字列を暗号化する。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NoCryption

public NoCryption()
コンストラクタ。

メソッドの詳細

decrypt

public String decrypt(String secret)
暗号化された文字列を復号するe。

このメソッドでは、引数に渡された値をそのまま返却します。

定義:
インタフェース Cryption 内の decrypt
パラメータ:
secret - 暗号化された文字列
戻り値:
復号化された文字列

encrypt

public String encrypt(String plane)
文字列を暗号化する。

このメソッドでは、引数に渡された値をそのまま返却します。

定義:
インタフェース Cryption 内の encrypt
パラメータ:
plane - 暗号化する文字列
戻り値:
暗号化された文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.cryption (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.security.cryption
インタフェース
Cryption
クラス
NoCryption
StandardCryption


jp.co.intra_mart.foundation.security.cryption (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.cryption

暗号化に関連するクラスを提供します。

参照:
説明

インタフェースの概要
Cryption 文字列の暗号化・復号化インタフェース。

クラスの概要
NoCryption | 暗号化処理を行わない実装クラス。
StandardCryption | 文字列の暗号化・復号化を行う標準の実装クラスです。

パッケージ jp.co.intra_mart.foundation.security.cryption の説明

暗号化に関連するクラスを提供します。


jp.co.intra_mart.foundation.security.cryption クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.cryption の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.cryption.NoCryption (implements jp.co.intra_mart.foundation.security.cryption.Cryption)
    • class jp.co.intra_mart.foundation.security.cryption.StandardCryption (implements jp.co.intra_mart.foundation.security.cryption.Cryption)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.cryption.Cryption


パッケージ jp.co.intra_mart.foundation.security.cryption の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.cryption の使用

jp.co.intra_mart.foundation.security.cryption を使用しているパッケージ
jp.co.intra_mart.foundation.security.cryption 暗号化に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.cryption により使用される jp.co.intra_mart.foundation.security.cryption のクラス
Cryption
文字列の暗号化・復号化インタフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardCryption (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.cryption
クラス StandardCryption

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.cryption.StandardCryption
すべての実装インタフェース:
Cryption
public class StandardCryption
extends Object
implements Cryption

文字列の暗号化・復号化を行う標準の実装クラスです。

jp.co.intra_mart.foundation.security.StandardAccountAccessorでパスワードとモバイルパスワードを
暗号化して保存、復号化して取得するための標準のクラスとして利用しています。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
StandardCryption()
コンストラクタ。
メソッドの概要
String | decrypt(String secret) 暗号化された文字列を復号するe。
String | encrypt(String plane) 文字列を暗号化する。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardCryption

public StandardCryption()
コンストラクタ。

メソッドの詳細

decrypt

public String decrypt(String secret)
暗号化された文字列を復号するe。

定義:
インタフェース Cryption 内の decrypt
パラメータ:
secret - 暗号化された文字列
戻り値:
復号化された文字列 復号に失敗した場合はnullを返却します。
関連項目:
Cryption.decrypt(java.lang.String)

encrypt

public String encrypt(String plane)
文字列を暗号化する。

定義:
インタフェース Cryption 内の encrypt
パラメータ:
plane - 暗号化する文字列
戻り値:
暗号化された文字列 暗号化に失敗した場合はnullを返却します。
関連項目:
Cryption.encrypt(java.lang.String)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor の使用

DuplicateLoginAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.security.duplication

jp.co.intra_mart.foundation.security.duplication での DuplicateLoginAccessor の使用

DuplicateLoginAccessor を実装している jp.co.intra_mart.foundation.security.duplication のクラス
 class StandardDuplicateLoginAccessor
重複ログイン操作インターフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager の使用

jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor の使用

jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DuplicateLoginAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.duplication
インタフェース DuplicateLoginAccessor

既知の実装クラスの一覧:
StandardDuplicateLoginAccessor
public interface DuplicateLoginAccessor

重複ログイン操作インターフェース。

アクティブなセッション情報に対して重複ログインを管理するためのクラス

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
String | getDuplicateLoginDetectionPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 引数で指定されたアクティブなセッション情報が重複ログインした場合の遷移先ページURLを取得します。
void | init(Node defaultNode, Node node) 設定ファイルの情報を基に初期化します。
boolean | isDetectEnable(ActiveSessionInfo activeSessionInfo) 検出処理が有効かどうか取得します。
boolean | isDetectEnable(String loginGroup, String loginType) 検出処理が有効かどうか取得します。
boolean | isInvalidatableByUser(ActiveSessionInfo activeSessionInfo) ユーザ自身のセッションの無効化が可能か取得します。
boolean | isInvalidatableByUser(String loginGroup, String loginType) ユーザ自身のセッションの無効化が可能か取得します。

メソッドの詳細

init

public void init(Node defaultNode,
                 Node node)
          throws DuplicateLoginException
設定ファイルの情報を基に初期化します。

パラメータ:
defaultNode - デフォルトノード
node - デフォルトノード
例外:
DuplicateLoginException - 初期化処理で例外が発生した場合にスローされます。

isDetectEnable

public boolean isDetectEnable(ActiveSessionInfo activeSessionInfo)
検出処理が有効かどうか取得します。

パラメータ:
activeSessionInfo - アクティブなセッション情報
戻り値:
検出処理が有効かどうか

isDetectEnable

public boolean isDetectEnable(String loginGroup,
                              String loginType)
検出処理が有効かどうか取得します。

パラメータ:
loginGroup - ログイングループ
loginType - ログインタイプ
戻り値:
検出処理が有効かどうか

isInvalidatableByUser

public boolean isInvalidatableByUser(ActiveSessionInfo activeSessionInfo)
ユーザ自身のセッションの無効化が可能か取得します。

パラメータ:
activeSessionInfo - アクティブなセッション情報
戻り値:
検出処理が有効かどうか

isInvalidatableByUser

public boolean isInvalidatableByUser(String loginGroup,
                                     String loginType)
ユーザ自身のセッションの無効化が可能か取得します。

パラメータ:
loginGroup - ログイングループ
loginType - ログインタイプ
戻り値:
検出処理が有効かどうか

getDuplicateLoginDetectionPage

public String getDuplicateLoginDetectionPage(SessionInfo sessionInfo,
                                             HttpServletRequest request,
                                             HttpServletResponse response)
引数で指定されたアクティブなセッション情報が重複ログインした場合の遷移先ページURLを取得します。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
遷移先ページ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DuplicateLoginManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.duplication
クラス DuplicateLoginManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager
public class DuplicateLoginManager
extends Object

重複ログイン管理マネージャクラス。

アクティブなセッション情報に対して重複ログインを管理するためのクラス

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
static String | DEFAULT_ATTR_INVALIDATE_OTHER_SESSIONS
static String | DEFAULT_ATTR_REQUESTED_PAGE
static String | DEFAULT_DUPLICATE_LOGIN_ACCESSOR
コンストラクタの概要
DuplicateLoginManager()
コンストラクタ。
メソッドの概要
String | getDuplicateLoginDetectionPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 引数で指定されたアクティブなセッション情報が重複ログインした場合の遷移先ページURLを取得します。
String | getInvalidateOtherSessionsAttributeName() 現在のセッション以外のアクティブなセッション情報を削除するために使用する属性名を取得します。
String | getRequestedPageAttributeName() リクエストされたページURLを保持するために使用する属性名を取得します。
void | invalidateOtherSessions(ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報以外のセッション情報をすべて無効にします。
boolean | isDetectEnable(ActiveSessionInfo activeSessionInfo) 検出処理が有効かどうか取得します。
boolean | isDetectEnable(String loginGroup, String loginType) 検出処理が有効かどうか取得します。
boolean | isDuplicateLogined(ActiveSessionInfo activeSessionInfo) 引数で指定されたユーザが重複してログインしているかどうか判別します。
boolean | isDuplicateLogined(String loginGroup, String loginType, String userId, String sessionId) 引数で指定されたユーザが重複してログインしているかどうか判別します。
boolean | isInvalidatableByUser(ActiveSessionInfo activeSessionInfo) ユーザ自身のセッションの無効化が可能か取得します。
boolean | isInvalidatableByUser(String loginGroup, String loginType) ユーザ自身のセッションの無効化が可能か取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_ATTR_REQUESTED_PAGE

public static final String DEFAULT_ATTR_REQUESTED_PAGE
関連項目:
定数フィールド値

DEFAULT_ATTR_INVALIDATE_OTHER_SESSIONS

public static final String DEFAULT_ATTR_INVALIDATE_OTHER_SESSIONS
関連項目:
定数フィールド値

DEFAULT_DUPLICATE_LOGIN_ACCESSOR

public static final String DEFAULT_DUPLICATE_LOGIN_ACCESSOR
関連項目:
定数フィールド値
コンストラクタの詳細

DuplicateLoginManager

public DuplicateLoginManager()
コンストラクタ。

メソッドの詳細

isDuplicateLogined

public boolean isDuplicateLogined(ActiveSessionInfo activeSessionInfo)
                           throws DuplicateLoginException
引数で指定されたユーザが重複してログインしているかどうか判別します。

パラメータ:
activeSessionInfo - アクティブなセッション情報
戻り値:
重複してログインしているかどうか
例外:
DuplicateLoginException - 重複ログイン制御処理中にエラーが発生した場合にスローされます。

isDuplicateLogined

public boolean isDuplicateLogined(String loginGroup,
                                  String loginType,
                                  String userId,
                                  String sessionId)
                           throws DuplicateLoginException
引数で指定されたユーザが重複してログインしているかどうか判別します。

パラメータ:
loginGroup - ログイングループID
loginType - ログインタイプ
userId - ユーザID
sessionId - セッションID
戻り値:
重複してログインしている場合 true、重複してログインしていない場合 false
例外:
DuplicateLoginException - 重複ログイン制御処理中にエラーが発生した場合にスローされます。

isDetectEnable

public boolean isDetectEnable(ActiveSessionInfo activeSessionInfo)
検出処理が有効かどうか取得します。

パラメータ:
activeSessionInfo - アクティブなセッション情報
戻り値:
検出処理が有効かどうか

isDetectEnable

public boolean isDetectEnable(String loginGroup,
                              String loginType)
検出処理が有効かどうか取得します。

パラメータ:
loginGroup - ログイングループ
loginType - ログインタイプ
戻り値:
検出処理が有効かどうか

isInvalidatableByUser

public boolean isInvalidatableByUser(ActiveSessionInfo activeSessionInfo)
ユーザ自身のセッションの無効化が可能か取得します。

パラメータ:
activeSessionInfo - アクティブなセッション情報
戻り値:
検出処理が有効かどうか

isInvalidatableByUser

public boolean isInvalidatableByUser(String loginGroup,
                                     String loginType)
ユーザ自身のセッションの無効化が可能か取得します。

パラメータ:
loginGroup - ログイングループ
loginType - ログインタイプ
戻り値:
検出処理が有効かどうか

invalidateOtherSessions

public void invalidateOtherSessions(ActiveSessionInfo activeSessionInfo)
                             throws DuplicateLoginException
引数で指定されたアクティブなセッション情報以外のセッション情報をすべて無効にします。

パラメータ:
activeSessionInfo - アクティブなセッション情報
例外:
DuplicateLoginException - 重複ログイン制御処理中にエラーが発生した場合にスローされます。

getDuplicateLoginDetectionPage

public String getDuplicateLoginDetectionPage(SessionInfo sessionInfo,
                                             HttpServletRequest request,
                                             HttpServletResponse response)
引数で指定されたアクティブなセッション情報が重複ログインした場合の遷移先ページURLを取得します。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
遷移先ページ

getRequestedPageAttributeName

public String getRequestedPageAttributeName()
リクエストされたページURLを保持するために使用する属性名を取得します。

戻り値:
リクエストされたページURLを保持するために使用する属性名

getInvalidateOtherSessionsAttributeName

public String getInvalidateOtherSessionsAttributeName()
現在のセッション以外のアクティブなセッション情報を削除するために使用する属性名を取得します。

戻り値:
現在のセッション以外のアクティブなセッション情報を削除するために使用する属性名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.duplication (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.security.duplication
インタフェース
DuplicateLoginAccessor
クラス
DuplicateLoginManager
StandardDuplicateLoginAccessor


jp.co.intra_mart.foundation.security.duplication (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.duplication

インタフェースの概要
DuplicateLoginAccessor 重複ログイン操作インターフェース。

クラスの概要
DuplicateLoginManager | 重複ログイン管理マネージャクラス。
StandardDuplicateLoginAccessor | 重複ログイン操作インターフェース。


jp.co.intra_mart.foundation.security.duplication クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.duplication の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager
    • class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor (implements jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor


パッケージ jp.co.intra_mart.foundation.security.duplication の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.duplication の使用

jp.co.intra_mart.foundation.security.duplication を使用しているパッケージ
jp.co.intra_mart.foundation.security.duplication

jp.co.intra_mart.foundation.security.duplication により使用される jp.co.intra_mart.foundation.security.duplication のクラス
DuplicateLoginAccessor
重複ログイン操作インターフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardDuplicateLoginAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.duplication
クラス StandardDuplicateLoginAccessor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor
すべての実装インタフェース:
DuplicateLoginAccessor
public class StandardDuplicateLoginAccessor
extends Object
implements DuplicateLoginAccessor

重複ログイン操作インターフェース。

アクティブなセッション情報に対して重複ログインを管理するためのクラス

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
static String | DEFAULT_ACCESS_SECURITY_PAGE_PROVIDER_CLASS
static String | DEFAULT_DUPLICATE_LOGIN_DETECT_ENABLE
static String | DEFAULT_INVALIDATABLE_BY_USER
static String | DEFAULT_PAGE_LOCATION
コンストラクタの概要
StandardDuplicateLoginAccessor()
メソッドの概要
String | getDuplicateLoginDetectionPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 引数で指定されたアクティブなセッション情報が重複ログインした場合の遷移先ページURLを取得します。
void | init(Node defaultNode, Node node) 設定ファイル conf/duplicate-login.xml の情報を基に初期化します。
boolean | isDetectEnable(ActiveSessionInfo activeSessionInfo) 検出処理が有効かどうか取得します。
boolean | isDetectEnable(String loginGroup, String loginType) 重複ログイン検出処理が有効かどうか取得します。
boolean | isInvalidatableByUser(ActiveSessionInfo activeSessionInfo) ユーザ自身のセッションの無効化が可能か取得します。
boolean | isInvalidatableByUser(String loginGroup, String loginType) ユーザ自身のセッションの無効化が可能か取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_ACCESS_SECURITY_PAGE_PROVIDER_CLASS

public static final String DEFAULT_ACCESS_SECURITY_PAGE_PROVIDER_CLASS
関連項目:
定数フィールド値

DEFAULT_PAGE_LOCATION

public static final String DEFAULT_PAGE_LOCATION
関連項目:
定数フィールド値

DEFAULT_DUPLICATE_LOGIN_DETECT_ENABLE

public static final String DEFAULT_DUPLICATE_LOGIN_DETECT_ENABLE
関連項目:
定数フィールド値

DEFAULT_INVALIDATABLE_BY_USER

public static final String DEFAULT_INVALIDATABLE_BY_USER
関連項目:
定数フィールド値
コンストラクタの詳細

StandardDuplicateLoginAccessor

public StandardDuplicateLoginAccessor()
メソッドの詳細

init

public void init(Node defaultNode,
                 Node node)
          throws DuplicateLoginException
設定ファイル conf/duplicate-login.xml の情報を基に初期化します。

定義:
インタフェース DuplicateLoginAccessor 内の init
パラメータ:
defaultNode - デフォルトノード
node - デフォルトノード
例外:
ActiveSessionException - 初期化処理で例外が発生した場合にスローされます。
DuplicateLoginException - 初期化処理で例外が発生した場合にスローされます。

isDetectEnable

public boolean isDetectEnable(ActiveSessionInfo activeSessionInfo)
検出処理が有効かどうか取得します。

定義:
インタフェース DuplicateLoginAccessor 内の isDetectEnable
パラメータ:
activeSessionInfo - アクティブなセッション情報
戻り値:
検出処理が有効かどうか

isDetectEnable

public boolean isDetectEnable(String loginGroup,
                              String loginType)
重複ログイン検出処理が有効かどうか取得します。

定義:
インタフェース DuplicateLoginAccessor 内の isDetectEnable
パラメータ:
loginGroup - ログイングループ
loginType - ログインタイプ
戻り値:
検出処理が有効かどうか

isInvalidatableByUser

public boolean isInvalidatableByUser(ActiveSessionInfo activeSessionInfo)
ユーザ自身のセッションの無効化が可能か取得します。

定義:
インタフェース DuplicateLoginAccessor 内の isInvalidatableByUser
パラメータ:
activeSessionInfo - アクティブなセッション情報
戻り値:
検出処理が有効かどうか

isInvalidatableByUser

public boolean isInvalidatableByUser(String loginGroup,
                                     String loginType)
ユーザ自身のセッションの無効化が可能か取得します。

定義:
インタフェース DuplicateLoginAccessor 内の isInvalidatableByUser
パラメータ:
loginGroup - ログイングループ
loginType - ログインタイプ
戻り値:
検出処理が有効かどうか

getDuplicateLoginDetectionPage

public String getDuplicateLoginDetectionPage(SessionInfo sessionInfo,
                                             HttpServletRequest request,
                                             HttpServletResponse response)
引数で指定されたアクティブなセッション情報が重複ログインした場合の遷移先ページURLを取得します。

定義:
インタフェース DuplicateLoginAccessor 内の getDuplicateLoginDetectionPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
遷移先ページ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException の使用

AccessSecurityConfigException を使用しているパッケージ
jp.co.intra_mart.foundation.security.mobile

jp.co.intra_mart.foundation.security.mobile での AccessSecurityConfigException の使用

AccessSecurityConfigException をスローする jp.co.intra_mart.foundation.security.mobile のメソッド
static String | MobileEasyLoginUtil.getMobileEasyLoginURL(String groupId, String userId) かんたんログイン用のURLを取得します。
static String | MobileEasyLoginUtil.getMobileEasyLoginURL(HttpServletRequest request, String groupId, String userId) かんたんログイン用のURLを取得します。
static String | MobileEasyLoginUtil.getAccessKeyWithRequestParameter(String groupId, String userId) かんたんログイン用のアクセスキーをリクエストパラメータの形式で取得します。
static String | MobileEasyLoginUtil.getAccessKey(String groupId, String userId) かんたんログイン用のアクセスキーを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException の使用

jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException の使用

jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityException の使用

AccessSecurityException を使用しているパッケージ
jp.co.intra_mart.foundation.database | データベースへアクセスするためのクラスを提供します。
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession |
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.license | ライセンスに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.message | メッセージに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.mobile |
jp.co.intra_mart.foundation.security.permission | 権限に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.shortcut |

jp.co.intra_mart.foundation.database での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.database のメソッド
Connection | DatabaseManager.getLoginGroupConnection(String groupId) ログイングループIDからコネクションオブジェクトを取得します。
Connection | DatabaseManager.getSystemConnection(String connectId) システム接続名からコネクションオブジェクトを取得します。

jp.co.intra_mart.foundation.navigator での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.navigator のメソッド
 Collection EventNavigatorPermissionSelector.doSelection(String groupId, String[] infos)
選択用情報を利用して選別された情報のリストを返却します。

jp.co.intra_mart.foundation.security での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security のメソッド
static void | SystemManager.setSorucePovider(SystemSourceProvider provider) ソースプロバイダを設定します。
void | SystemManager.addSuperUser(SuperUser superUser) システム管理者情報を新規に作成します。
ClientTypeInfo | SystemManager.getClientType(Locale reqLocale, String clientType) 指定ロケールでクライアントタイプ情報を取得します。
ClientTypeInfo[] | SystemManager.getClientTypes(Locale reqLocale) 指定ロケールでクライアントタイプ情報の一覧を取得します。
ColorPatternInfo | SystemManager.getColorPattern(Locale reqLocale, String colorPatternId) 指定ロケールでカラーパターン情報を取得します。
ColorPatternInfo[] | SystemManager.getColorPatterns(Locale reqLocale) 指定ロケールでカラーパターン情報の一覧を取得します。
String | SystemManager.getDefaultEncoding(Locale reqLocale) ロケールに対応するデフォルトエンコーディングを取得します。
LocaleInfo | SystemManager.getLocale(Locale reqLocale, Locale locale) 指定ロケールでロケール情報を取得します。
LocaleInfo[] | SystemManager.getLocales(Locale reqLocale) 指定ロケールでロケール情報の一覧を取得します。
SuperUser | SystemManager.getSuperUser() システム管理者情報を取得します。
void | SystemManager.updateSuperUser(SuperUser superUser) システム管理者情報を更新します。
void | ExtendsImportManager.doImport(String groupId, String module) 拡張インポート処理を実行します。
static AccessSecurityManager | AccessSecurityManager.getInstance() セキュリティマネージャのインスタンスを取得します。
String | AccessSecurityManager.createUrlSignature(String url, String groupId, String userId) ダイレクトＵＲＬ署名を作成します。
int | AccessSecurityManager.forceLogin(LoginRequestInfo loginRequestInfo) 強制ログイン処理を行います。
int | AccessSecurityManager.forceLogin(LoginRequestInfo loginRequestInfo, HttpServletRequest request, HttpServletResponse response) 強制ログイン処理を行います。
void | AccessSecurityManager.forward(HttpServletRequest request, HttpServletResponse response, String url) 指定したURLにフォワードします。
void | AccessSecurityManager.forward(String url) 指定したURLにフォワードします。
String | AccessSecurityManager.getErrorPage(int errorCode) カレントスレッド情報からエラーページＵＲＬを取得します。
String | AccessSecurityManager.getErrorPage(int errorCode, HttpServletRequest request, HttpServletResponse response) エラーページＵＲＬを取得します。
int | AccessSecurityManager.getInitialCertification(LoginRequestInfo loginInfo) カレントスレッドの情報から初期アクセス処理を行います。
int | AccessSecurityManager.getInitialCertification(LoginRequestInfo loginInfo, HttpServletRequest request, HttpServletResponse response) 初期アクセス処理を行います。
String | AccessSecurityManager.getInitialPage() カレントスレッド情報から初期アクセスページURLを取得します。
String | AccessSecurityManager.getInitialPage(SessionInfo sessionInfo) カレントスレッド情報から初期アクセスページURLを取得します。
String | AccessSecurityManager.getInitialPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期アクセスページURLを取得します。
int | AccessSecurityManager.getLicense(LoginInfo loginInfo) アカウントライセンスチェックを行います。
int | AccessSecurityManager.getLoginCertification() カレントスレッド情報からログイン処理を行います。
int | AccessSecurityManager.getLoginCertification(HttpServletRequest request, HttpServletResponse response) ログイン処理を行います。
String | AccessSecurityManager.getMainPage() カレントスレッド情報からメインページURLを取得します。
String | AccessSecurityManager.getMainPage(SessionInfo sessionInfo) カレントスレッド情報からメインページURLを取得します。
String | AccessSecurityManager.getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得します。
SessionConfig | AccessSecurityManager.getSessionConfig() セッション情報保管パラメータを取得します。
SessionInfo | AccessSecurityManager.getSessionInfo() カレントスレッド情報からintra-martセッション情報を取得します。
SessionInfo | AccessSecurityManager.getSessionInfo(HttpServletRequest request, HttpServletResponse response) intra-martセッション情報を取得します。
int | AccessSecurityManager.getSessionMode() intra-martセッションの状態を取得します。
int | AccessSecurityManager.getSessionMode(SessionInfo sessionInfo) intra-martセッションの状態を取得します。
int | AccessSecurityManager.login(LoginRequestInfo loginRequestInfo) ログイン処理を行います。
int | AccessSecurityManager.login(LoginRequestInfo loginRequestInfo, HttpServletRequest request, HttpServletResponse response) ログイン処理を行います。
void | AccessSecurityManager.logout() ログアウト処理を行います。
void | AccessSecurityManager.logout(HttpServletRequest request, HttpServletResponse response) ログアウト処理を行います。

jp.co.intra_mart.foundation.security.access での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.access のメソッド
 void AccessControllerManager.addController(AccessController controller)
アクセスコントローラを追加します。
 void AccessControllerManager.addControllerDepartment(String controllerId, DepartmentInfo departmentInfo)
組織をアクセスコントローラに紐付けます。
 void AccessControllerManager.addControllerPost(String controllerId, PostInfo postInfo)
役職をアクセスコントローラに紐付けます。
 void AccessControllerManager.addControllerPublicGroup(String controllerId, PublicGroupInfo publicGroupInfo)
パブリックグループをアクセスコントローラに紐付けます。
 void AccessControllerManager.addControllerRole(String controllerId, String roleId)
ロールをアクセスコントローラに紐付けます。
 void AccessControllerManager.deleteController(String controllerId)
アクセスコントローラを削除します。
 void AccessControllerManager.deleteControllerDepartment(String controllerId, DepartmentInfo departmentInfo)
組織の紐付けをアクセスコントローラから削除します。
 void AccessControllerManager.deleteControllerDepartments(String controllerId)
組織の紐付けをアクセスコントローラからすべて削除します。
 void AccessControllerManager.deleteControllerPost(String controllerId, PostInfo postInfo)
役織の紐付けをアクセスコントローラから削除します。
 void AccessControllerManager.deleteControllerPosts(String controllerId)
役織の紐付けをアクセスコントローラからすべて削除します。
 void AccessControllerManager.deleteControllerPublicGroup(String controllerId, PublicGroupInfo publicGroupInfo)
パブリックグループの紐付けをアクセスコントローラから削除します。
 void AccessControllerManager.deleteControllerPublicGroups(String controllerId)
パブリックグループの紐付けをアクセスコントローラからすべて削除します。
 void AccessControllerManager.deleteControllerRole(String controllerId, String roleId)
ロールの紐付けをアクセスコントローラから削除します。
 void AccessControllerManager.deleteControllerRoles(String controllerId)
ロールの紐付けをアクセスコントローラから削除します。
 void AccessControllerManager.deleteControllers()
すべてのアクセスコントローラを削除します。
 void AccessControllerManager.exportData(String category, OutputStream outputStream)
アクセスコントローラ情報をエクスポートします。
 AccessController AccessControllerManager.getController(String controllerId)
指定されたアクセスコントローラIDに対応するアクセスコントローラを取得します。
 DepartmentInfo[] AccessControllerManager.getControllerDepartments(String controllerId)
アクセスコントローラに紐付いた組織の一覧を取得します。
 String[] AccessControllerManager.getControllerIds()
すべてのアクセスコントローラIDを取得します。
 String[] AccessControllerManager.getControllerIdsByDepartment(DepartmentInfo[] departments)
指定された組織を持つアクセスコントローラIDをすべて取得します。
 String[] AccessControllerManager.getControllerIdsByPost(PostInfo[] posts)
指定された役職を持つアクセスコントローラIDをすべて取得します。
 String[] AccessControllerManager.getControllerIdsByPublicGroup(PublicGroupInfo[] publicGroups)
指定されたパブリックグループを持つアクセスコントローラIDをすべて取得します。
 String[] AccessControllerManager.getControllerIdsByRole(String[] roleIds)
指定されたロールIDを持つアクセスコントローラIDをすべて取得します。
 String[] AccessControllerManager.getControllerIdsByUser(String userId, Date date)
指定されたユーザIDおよび日付で有効なアクセスコントローラIDをすべて取得します。
 PostInfo[] AccessControllerManager.getControllerPosts(String controllerId)
アクセスコントローラに紐付いた役職の一覧を取得します。
 PublicGroupInfo[] AccessControllerManager.getControllerPublicGroups(String controllerId)
アクセスコントローラに紐付いたパブリックグループの一覧を取得します。
 String[] AccessControllerManager.getControllerRoles(String controllerId)
アクセスコントローラに紐付いたロールの一覧を取得します。
 AccessController[] AccessControllerManager.getControllers()
すべてのアクセスコントローラを取得します。
 String[] AccessControllerManager.getExportCategories()
アクセスコントローラエクスポート用のカテゴリの一覧を取得します。
 String[] AccessControllerManager.getImportCategories()
アクセスコントローラインポート用のカテゴリの一覧を取得します。
 void AccessControllerManager.importData(String category, InputStream inputStream)
/** アクセスコントローラ情報をインポートします。
 void AccessControllerManager.updateController(AccessController controller)
アクセスコントローラを更新します。
 boolean AccessControllerManager.isUpdate(Date date)
アクセスコントローラが指定された日付よりも新しいかチェックします。

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.access のコンストラクタ
AccessControllerManager(String groupId)
コンストラクタ。

jp.co.intra_mart.foundation.security.account での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.account のメソッド
void | AccountManager.addAccount(Account account) アカウントを新規追加します。
void | AccountManager.addAccountRole(String userId, AccountRole accountRole) アカウントロールを新規追加します。
void | AccountManager.addFavoriteMenu(String userId, FavoriteMenu favoriteMenu) マイメニューを新規追加します。
boolean | AccountManager.contains(String userId) アカウントの存在チェックを行います。
int | AccountManager.count() アカウントの登録数を取得します。
void | AccountManager.deleteAccount(String userId) アカウントを削除します。
void | AccountManager.deleteAccountRole(String userId, String roleId) アカウントロールを削除します。
void | AccountManager.deleteAccountRoles(String userId) アカウントロールをすべて削除します。
void | AccountManager.deleteAccounts() アカウントをすべて削除します。
void | AccountManager.deleteFavoriteMenu(String userId, String menuId) マイメニューを削除します。
void | AccountManager.deleteFavoriteMenus(String userId) マイメニューをすべて削除します。
void | AccountManager.exportData(String category, OutputStream outputStream) アカウント情報をエクスポートします。
Account | AccountManager.getAccount(String userId) ユーザIDにマッチしたユーザデータを１件取得します。
String[] | AccountManager.getAccountRoleIds(String userId) アカウントロールIDをすべて取得します。
AccountRole[] | AccountManager.getAccountRoles(String userId) アカウントロールをすべて取得します。
AccountRole[] | AccountManager.getAccountRoles(String userId, Date date) 有効期間内のアカウントロールをすべて取得します。
Account[] | AccountManager.getAccounts() ログイングループ内のすべてのユーザアカウントを取得します。
Account[] | AccountManager.getAccountsByUserIds(String[] userIds) ログイングループ内で引数指定したユーザIDのユーザアカウントをすべて取得します。
String[] | AccountManager.getExportCategories() アカウントエクスポート用のカテゴリの一覧を取得します。
String[] | AccountManager.getFavoriteMenuIds(String userId) マイメニューIDをすべて取得します。
FavoriteMenu[] | AccountManager.getFavoriteMenus(String userId) マイメニューをすべて取得します。
String[] | AccountManager.getImportCategories() アカウントインポート用のカテゴリの一覧を取得します。
String[] | AccountManager.getRoleIds(String userId, Date date) アカウントに紐付く有効なロールIDをすべて取得します。
String[] | AccountManager.getUserIds() すべてのユーザIDを取得します。
String[] | AccountManager.getUserIdsByAccountRole(String roleId) 引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
String[] | AccountManager.getUserIdsByRole(String roleId, Date date) 有効なロールIDを持つすべてのユーザIDを取得します。
void | AccountManager.importData(String category, InputStream inputStream) アカウント情報をインポートします。
Account[] | AccountManager.searchAccounts(String userId) ユーザIDを検索してマッチしたアカウントを配列で返します。
void | AccountManager.updateAccount(Account account) アカウントを更新します。
void | AccountManager.updateAccountRole(String userId, AccountRole accountRole) アカウントロールを更新します。
void | AccountManager.updateFavoriteMenu(String userId, FavoriteMenu favoriteMenu) マイメニューを更新します。
String | AccountManager.getAttribute(String userId, String name) アカウント属性情報を取得する。
String | AccountManager.getAttribute(String userId, String name, String def) アカウント属性情報を取得する。
String[] | AccountManager.getAttributeNames(String userId) アカウント属性名の一覧を取得する。
void | AccountManager.setAttribute(String userId, String name, String value) アカウント属性情報を設定する。
void | AccountManager.deleteAttribute(String userId, String name) アカウント属性情報を削除する。
String[] | AccountManager.getUserIdsByAttribute(String key, String value) アカウント属性情報の値と一致するユーザIDを取得します。
boolean | AccountManager.isUpdate(Date date) アカウント情報が指定された日付よりも新しいかチェックします。
protected Account[] | StandardAccountBackup.getAllAccounts(String groupId)
protected Account[] | CsvAccountBackup.getAllAccounts(String groupId)

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.account のコンストラクタ
AccountManager(String groupId)
コンストラクタ。

jp.co.intra_mart.foundation.security.activesession での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.activesession のコンストラクタ
ActiveSessionInfo(HttpServletRequest request)
コンストラクタ。

jp.co.intra_mart.foundation.security.batch での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.batch のメソッド
void | BatchManager.addBatch(Batch batch) バッチ情報を新規登録します。
void | BatchManager.deleteBatch(String batchId) バッチ情報を削除します。
void | BatchManager.deleteBatches() すべてのバッチ情報を削除します。
void | BatchManager.exportData(String category, OutputStream outputStream) エクスポートを行います。
Batch | BatchManager.getBatch(String batchId) バッチ情報を取得します。
Batch[] | BatchManager.getBatches() すべてのバッチ情報を取得します。
Batch[] | BatchManager.getBatchesByIds(String[] batchIds) ログイングループ内で引数指定したバッチIDのバッチ情報をすべて取得します。
String[] | BatchManager.getBatchIds() バッチIDの一覧を取得します。
String[] | BatchManager.getExportCategories() バッチエクスポート用のカテゴリの一覧を取得します。
String[] | BatchManager.getImportCategories() バッチインポート用のカテゴリの一覧を取得します。
void | BatchManager.importData(String category, InputStream inputStream) インポートを行います。
void | BatchManager.updateBatch(Batch batch) バッチ情報を更新します。
boolean | BatchManager.isUpdate(Date date) バッチ情報が指定された日付よりも新しいかチェックします。

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.batch のコンストラクタ
BatchManager(String groupId)
コンストラクタ。

jp.co.intra_mart.foundation.security.calendar での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.calendar のメソッド
void | CalendarManager.addCalendarInfo(String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に追加します。
void | CalendarManager.deleteCalendar(String calendarId) カレンダーを削除します。
void | CalendarManager.deleteCalendarInfo(String calendarId, String dataId) カレンダーデータを削除します。
void | CalendarManager.deleteCalendarInfos(String calendarId) すべてのカレンダーデータを削除します。
void | CalendarManager.deleteCalendars() すべてのカレンダーを削除します。
void | CalendarManager.exportData(String category, OutputStream outputStream) エクスポートを行います。
String[] | CalendarManager.getCalendarIds() すべてのカレンダーIDを取得します。
CalendarInfo | CalendarManager.getCalendarInfo(String calendarId, String dataId) カレンダーデータを取得します。
String[] | CalendarManager.getCalendarInfoIds(String calendarId) すべてのカレンダーデータIDを取得します。
CalendarInfo[] | CalendarManager.getCalendarInfos(String calendarId) すべてのカレンダーデータを取得します。
CalendarInfo[] | CalendarManager.getCalendarInfosByIds(String calendarId, String[] calendarInfoIds) ログイングループ内で引数指定したカレンダーデータIDのカレンダーをすべて取得します。
CategorizedCalendarInfo | CalendarManager.getCategorizedCalendarInfos(String calendarId) すべてのカレンダーデータをデータタイプ別に分類して取得します。
DayInfo | CalendarManager.getDayInfo(CategorizedCalendarInfo categorizedCalendarInfo, Date date) 日付情報を取得します。
String[] | CalendarManager.getExportCategories() カレンダーエクスポート用のカテゴリの一覧を取得します。
String[] | CalendarManager.getImportCategories() カレンダーインポート用のカテゴリの一覧を取得します。
DayInfo[] | CalendarManager.getMonthInfos(CategorizedCalendarInfo categorizedCalendarInfo, int year, int month) 月情報を取得します。
CalendarPlugin | CalendarManager.getPlugin(String pluginId) カレンダーデータプラグインを取得します。
void | CalendarManager.importData(String category, InputStream inputStream) インポートを行います。
boolean | CalendarManager.isHoliday(String calendarId, CategorizedCalendarInfo categorizedCalendarInfo, Date date) 休日かどうか判定します。
boolean | CalendarManager.isNationalHoliday(CategorizedCalendarInfo categorizedCalendarInfo, Date date) 祝日かどうか判定します。
boolean | CalendarManager.isWeekday(String calendarId, CategorizedCalendarInfo categorizedCalendarInfo, Date date) 平日かどうか判定します。
void | CalendarManager.updateCalendarInfo(String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。
boolean | CalendarManager.isUpdate(String calendarId, Date date) カレンダーデータが指定された日付よりも新しいかチェックします。

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.calendar のコンストラクタ
CalendarManager(String groupId)
コンストラクタ。

jp.co.intra_mart.foundation.security.exception での AccessSecurityException の使用

jp.co.intra_mart.foundation.security.exception での AccessSecurityException のサブクラス
class | AccessSecurityCreateException アクセスセキュリティ情報作成例外クラス。
class | AccessSecurityDeleteException アクセスセキュリティ情報削除例外クラス。
class | AccessSecurityExportException エクスポート時例外クラス。
class | AccessSecurityImportException インポート時例外クラス。
class | AccessSecurityListenerExcpetion アクセスセキュリティリスナーの例外クラス。
class | AccessSecurityReadException アクセスセキュリティ情報の取得例外クラス。
class | AccessSecurityUpdateException アクセスセキュリティ情報更新例外クラス。
class | AccessSecurityWriteException アクセスセキュリティ情報の更新例外クラス。
class | ActiveSessionException アクティブなセッション情報例外の基本となる例外クラス。
class | ActiveSessionInvalidatedByForceException アクティブなセッションが強制的に無効化されたことに関する例外クラス
class | ActiveSessionNotExistException アクティブなセッションが存在しない例外クラス。
class | DuplicateException 作成時重複例外クラス。
class | DuplicateLoginDetectedException 重複ログイン検出例外クラス
class | DuplicateLoginException 重複ログイン制御例外の基本となる例外クラス。
class | IllegalArgumentException 引数が不正の例外クラス。
class | NoFilterException HTTPリクエスト・レスポンス取得例外クラス。
class | NoSessionCookieException セッション情報クッキー取得例外クラス。
class | NoSessionException セッション取得例外クラス。
class | NotExistException アクセスセキュリティ情報が存在しなかった場合の例外クラス。
class | NotFoundDataSourceException データソースの参照名未解決例外クラス。
class | NotSupportMethodException アクセスセキュリティのマネージャでサポートされないメソッドがコールされた場合の例外クラス。

jp.co.intra_mart.foundation.security.group での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.group のメソッド
void | LoginGroupManager.addLoginGroup(LoginGroup loginGroup) ログイングループを新規追加します。
void | LoginGroupManager.addMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを新規追加します。
void | LoginGroupManager.addSuperUser(String groupId, SuperUser superUser) グループ管理者を新規追加します。
int | LoginGroupManager.countLoginGroups() ログイングループ数を取得します。
void | LoginGroupManager.deleteMainPagePatterns(String groupId) メインページパターンをすべて削除します。
void | LoginGroupManager.deleteLoginGroup(String groupId) ログイングループを削除します。
void | LoginGroupManager.deleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを削除します。
void | LoginGroupManager.deleteSuperUser(String groupId) グループ管理者情報を削除します。
LoginGroup | LoginGroupManager.getLoginGroup(String groupId) ログイングループ情報を取得します。
String[] | LoginGroupManager.getLoginGroupIds() ログイングループIDの一覧を取得します。
LoginGroup[] | LoginGroupManager.getLoginGroups() ログイングループの一覧を取得します。
MainPagePatternInfo | LoginGroupManager.getMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを取得します。
String[] | LoginGroupManager.getMainPagePatternIds(String groupId) メインページパターンIDの一覧を取得します。
MainPagePatternInfo[] | LoginGroupManager.getMainPagePatterns(String groupId) メインページパターンの一覧を取得します。
SuperUser | LoginGroupManager.getSuperUser(String groupId) グループ管理者情報を取得します。
void | LoginGroupManager.updateLoginGroup(LoginGroup loginGroup) ログイングループ情報を更新します。
void | LoginGroupManager.updateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを更新します。
void | LoginGroupManager.updateSuperUser(String groupId, SuperUser superUser) グループ管理者情報を更新します。

jp.co.intra_mart.foundation.security.license での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.license のメソッド
static ApplicationInfo | LicenseManager.getApplication(String applicaionId) アプリケーション情報を取得します。
static double | LicenseManager.getApplicationLicense(String applicaionId) アプリケーションの登録ユーザ数を取得します。
static ApplicationInfo[] | LicenseManager.getApplications() アプリケーション情報の一覧を取得します。
static ApplicationInfo | LicenseManager.getProduct() システム情報を取得します。
static double | LicenseManager.getSystemLicense() システム全体の登録ライセンス数。
static double | LicenseManager.getSystemMaxLicense() システム全体のライセンス数。
void | LicenseManager.deleteAccountLicense(String userId) 指定されたユーザのライセンスを削除します。
void | LicenseManager.deleteApplicationLicenseFromAccount(String userId, String applicationId) アプリケーションライセンスをアカウントから削除します。
double | LicenseManager.getLicense() グループ内で登録されているライセンス数を取得します。
double | LicenseManager.getMaxLicense() ログイングループ内の最大登録可能ライセンス数を取得します。
String[] | LicenseManager.getRegisteredAccountLicenses() ログイングループにライセンス登録されているすべてのユーザIDを返します。
String[] | LicenseManager.getRegisteredApplicationLicensesToAccount(String userId) アカウントに登録されているアプリケーションライセンスの一覧を取得します。
boolean | LicenseManager.isRegisteredAccountLicense(String userId) 指定されたユーザがライセンスに登録されているかどうかをチェックします。
boolean | LicenseManager.isRegisteredApplicationLicenseToAccount(String userId, String applicationId) アカウントにアプリケーションライセンスが登録されてるか検証します。
boolean | LicenseManager.registerAccountLicense(String userId) ライセンス登録します。
boolean | LicenseManager.registerApplicationLicenseToAccount(String userId, String applicationId) アプリケーションライセンスをアカウントに登録します。
boolean | LicenseManager.setMaxLicense(double maxLicense) ログイングループ内の最大登録可能ライセンス数を設定します。

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.license のコンストラクタ
LicenseManager(String groupId)
コンストラクタ。

jp.co.intra_mart.foundation.security.menu での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuManager.addMenuDepartment(String menuId, DepartmentInfo departmentInfo) 組織をメニューに紐付けます。
void | MenuManager.addMenuItem(String parentMenuId, MenuItem menuItem) メニューを追加します。
void | MenuManager.addMenuPost(String menuId, PostInfo postInfo) 役職をメニューに紐付けます。
void | MenuManager.addMenuPublicGroup(String menuId, PublicGroupInfo publicGroupInfo) パブリックグループをメニューに紐付けます。
void | MenuManager.addMenuRole(String menuId, String roleId) ロールをメニューに紐付けます。
void | MenuManager.deleteMenuDepartment(String menuId, DepartmentInfo departmentInfo) 組織の紐付けをメニューから削除します。
void | MenuManager.deleteMenuDepartments(String menuId) 組織の紐付けをメニューからすべて削除します。
void | MenuManager.deleteMenuItem(String menuId) メニューを削除します。
void | MenuManager.deleteMenuItems() すべてのメニューを削除します。
void | MenuManager.deleteMenuPost(String menuId, PostInfo postInfo) 役織の紐付けをメニューから削除します。
void | MenuManager.deleteMenuPosts(String menuId) 役織の紐付けをメニューからすべて削除します。
void | MenuManager.deleteMenuPublicGroup(String menuId, PublicGroupInfo publicGroupInfo) パブリックグループの紐付けをメニューから削除します。
void | MenuManager.deleteMenuPublicGroups(String menuId) パブリックグループの紐付けをメニューからすべて削除します。
void | MenuManager.deleteMenuRole(String menuId, String roleId) ロールの紐付けをメニューから削除します。
void | MenuManager.deleteMenuRoles(String menuId) ロールの紐付けをメニューから削除します。
void | MenuManager.exportData(String category, OutputStream outputStream) メニュー情報をエクスポートします。
MenuTree[] | MenuManager.getAccountMenuTree(String userId, String clientType) 指定したアカウントのメニュー構成を取得します。
String[] | MenuManager.getChildMenuIds(String menuId) 子メニューIDを取得します。
String[] | MenuManager.getExportCategories() メニューエクスポート用のカテゴリの一覧を取得します。
String[] | MenuManager.getFirstMenuIds() 第一階層のメニューIDをすべて取得します。
String[] | MenuManager.getImportCategories() メニューインポート用のカテゴリの一覧を取得します。
DepartmentInfo[] | MenuManager.getMenuDepartments(String menuId) メニューに紐付いた組織の一覧を取得します。
String[] | MenuManager.getMenuIds() すべてのメニューIDを取得します。
String[] | MenuManager.getMenuIdsByDepartment(DepartmentInfo[] departments) 指定された組織を持つメニューIDをすべて取得します。
String[] | MenuManager.getMenuIdsByPost(PostInfo[] posts) 指定された役職を持つメニューIDをすべて取得します。
String[] | MenuManager.getMenuIdsByPublicGroup(PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つメニューIDをすべて取得します。
String[] | MenuManager.getMenuIdsByRole(String[] roleIds) 指定されたロールIDを持つメニューIDをすべて取得します。
MenuItem | MenuManager.getMenuItem(String menuId) 指定されたメニューIDに対応するメニューを取得します。
MenuItem[] | MenuManager.getMenuItems() すべてのメニューを取得します。
MenuItem[] | MenuManager.getMenuItemsByIds(String[] menuIds) ログイングループ内で引数指定したメニューIDのメニュー情報をすべて取得します。
PostInfo[] | MenuManager.getMenuPosts(String menuId) メニューに紐付いた役職の一覧を取得します。
PublicGroupInfo[] | MenuManager.getMenuPublicGroups(String menuId) メニューに紐付いたパブリックグループの一覧を取得します。
String[] | MenuManager.getMenuRoles(String menuId) メニューに紐付いたロールの一覧を取得します。
MenuTree[] | MenuManager.getMenuTree() メニュー構成を取得します。
MenuTree[] | MenuManager.getMenuTree(String clientType) 指定されたクライアントタイプのみのメニュー構成を取得します。
MenuTree[] | MenuManager.getMenuTree(String clientType, String[] menuIds, boolean showNoChildFolder) 指定されたクライアントタイプと指定されたメニューIDのみのメニュー構成を取得します。
String | MenuManager.getParentMenuId(String menuId) 指定されたメニューの親メニューを取得します。
void | MenuManager.importData(String category, InputStream inputStream) メニュー情報をインポートします。
void | MenuManager.moveMenuItem(MenuInclusion menuInclusion) メニューを移動します。
void | MenuManager.updateMenuItem(MenuItem menuItem) メニューを更新します。
boolean | MenuManager.isUpdate(Date date) メニュー情報が指定された日付よりも新しいかチェックします。
void | AdminMenuManager.addMenuItem(String parentMenuId, MenuItem menuItem) メニューを追加します。
void | AdminMenuManager.addMenuLoginGroup(String menuId, String groupId) 指定したログイングループのアクセス権をメニューに設定します。
void | AdminMenuManager.deleteMenuItem(String menuId) メニューを削除します。
void | AdminMenuManager.deleteMenuItems() すべてのメニューを削除します。
void | AdminMenuManager.deleteMenuLoginGroup(String menuId, String groupId) 指定したログイングループのアクセス権をメニューから削除します。
void | AdminMenuManager.exportData(String category, OutputStream outputStream) メニュー情報・エクスポート。
String[] | AdminMenuManager.getChildMenuIds(String menuId) 子メニューIDを取得します。
String[] | AdminMenuManager.getFirstMenuIds() 第一階層のメニューIDをすべて取得します。
String[] | AdminMenuManager.getMenuIds() すべてのメニューIDを取得します。
MenuItem | AdminMenuManager.getMenuItem(String menuId) 指定されたメニューIDに対応するメニューを取得します。
MenuItem[] | AdminMenuManager.getMenuItems() すべてのメニューを取得します。
MenuTree[] | AdminMenuManager.getMenuTree() メニュー構成を取得します。
MenuTree[] | AdminMenuManager.getMenuTree(String groupId) 引数に指定したログイングループのメニュー構成を取得します。
String[] | AdminMenuManager.getMenuLoginGroups(String menuId) 引数に指定したメニューを参照可能なログイングループIDの一覧を取得します。
String | AdminMenuManager.getParentMenuId(String menuId) 指定されたメニューの親メニューを取得します。
void | AdminMenuManager.importData(String category, InputStream inputStream) メニュー情報・インポート。
void | AdminMenuManager.moveMenuItem(MenuInclusion menuInclusion) メニューを移動します。
void | AdminMenuManager.updateMenuItem(MenuItem menuItem) メニューを更新します。
String[] | AdminMenuManager.getMenuIdsByLoginGroup(String groupId) 引き数に指定したログイングループが参照可能なメニューIDの一覧を取得します。
MenuItem[] | AdminMenuManager.getMenuItemsByIds(String[] menuIds) 引き数に指定したメニューIDに一致するメニューアイテムの一覧を取得します。
void | AdminMenuManager.setAccessControlEnabled(String menuId, boolean accessControl) メニューアイテムに対するアクセス権を設定します。
boolean | AdminMenuManager.isAccessControlEnabled(String menuId) メニューアイテムのアクセス権の有無を取得します。

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.menu のコンストラクタ
MenuManager(String groupId)
コンストラクタ。

jp.co.intra_mart.foundation.security.message での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.message のメソッド
String | MessageManager.getMessage(Locale locale, String key) メッセージを取得します。
String | MessageManager.getMessage(Locale locale, String key, String arg) メッセージを取得します。
String | MessageManager.getMessage(Locale locale, String key, String arg1, String arg2) メッセージを取得します。
String | MessageManager.getMessage(Locale locale, String key, String arg1, String arg2, String arg3) メッセージを取得します。
String | MessageManager.getMessage(Locale locale, String key, String[] args) メッセージを取得します。
String | MessageManager.getMessage(String key) メッセージを取得します。
String | MessageManager.getMessage(String key, String arg) メッセージを取得します。
String | MessageManager.getMessage(String key, String arg1, String arg2) メッセージを取得します。
String | MessageManager.getMessage(String key, String arg1, String arg2, String arg3) メッセージを取得します。
String | MessageManager.getMessage(String key, String[] args) メッセージを取得します。

jp.co.intra_mart.foundation.security.mobile での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.mobile のメソッド
static String | MobileEasyLoginUtil.getMobileEasyLoginURL(String groupId, String userId) かんたんログイン用のURLを取得します。
static String | MobileEasyLoginUtil.getMobileEasyLoginURL(HttpServletRequest request, String groupId, String userId) かんたんログイン用のURLを取得します。
static String | MobileEasyLoginUtil.getAccessKeyWithRequestParameter(String groupId, String userId) かんたんログイン用のアクセスキーをリクエストパラメータの形式で取得します。
static String | MobileEasyLoginUtil.getAccessKey(String groupId, String userId) かんたんログイン用のアクセスキーを取得します。
static void | MobileEasyLoginUtil.reGenerateNonce(String groupId, String userId) かんたんログイン用のNonceを新たに生成し、アカウント属性情報として保存します。

jp.co.intra_mart.foundation.security.permission での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.permission のメソッド
Collection | PermissionSelector.doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
PermissionSelector | PermissionManager.getPermissionSelector(String category) 指定されたカテゴリについて、設定XMLファイルで定義されているPermissionSelectorを返します。
Collection | PermissionManager.doSelection(String category, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
Collection | PermissionManager.doSelection(String category, String info) 選択用情報を利用して選別された情報のリストを返却します。
Collection | AdminMenuPermissionSelector.doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
Collection | MenuPermissionSelector.doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
Collection | AccountRolePermissionSelector.doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
Collection | AccessControllerPermissionSelector.doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.permission のコンストラクタ
PermissionManager(String groupId)
コンストラクタ。

jp.co.intra_mart.foundation.security.role での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.role のメソッド
void | RoleManager.addRole(Role role) ロール情報を新規登録します。
void | RoleManager.addSubRole(String roleId, String subRoleId) サブロールIDを追加します。
boolean | RoleManager.certify(String[] users, String[] roles) ロール内包を認証します。
boolean | RoleManager.contains(String roleId) ロールの存在チェックを行います。
boolean | RoleManager.containsCategory(String category) カテゴリーの存在チェックをします。
int | RoleManager.countByCategory(String category) カテゴリーに属するロール数を取得します。
void | RoleManager.deleteCategories() すべてのカテゴリーを削除します。
void | RoleManager.deleteCategory(String category) カテゴリーを削除します。
void | RoleManager.deleteRole(String roleId) ロールを削除します。
void | RoleManager.deleteRoles() すべてのロールを削除します。
void | RoleManager.deleteSubRole(String roleId, String subRoleId) 指定したサブロールIDを削除します。
void | RoleManager.deleteSubRoles(String roleId) 全てのサブロールIDを削除します。
void | RoleManager.exportData(String category, OutputStream outputStream) ロール情報・エクスポート。
String[] | RoleManager.getAllParentRoleIds(String roleId) 全ての親ロールIDを取得します。
String[] | RoleManager.getAllSubRoleIds(String roleId) 全てのサブロールサマリを取得します。
String[] | RoleManager.getExportCategories() ロールエクスポート用のカテゴリの一覧を取得します。
String[] | RoleManager.getImportCategories() ロールインポート用のカテゴリの一覧を取得します。
String[] | RoleManager.getParentRoleIds(String roleId) 親ロールIDを取得します。
Role | RoleManager.getRole(String roleId) ロール情報を取得します。
Role[] | RoleManager.getRolesByCategory(String category) カテゴリー検索によりロールを取得します。
Role[] | RoleManager.getRolesByIds(String[] roleIds) ログイングループ内で引数指定したロールIDのロール情報をすべて取得します。
String[] | RoleManager.getSubRole(String roleId) サブロール(一階層のみ)を取得します。
void | RoleManager.importData(String category, InputStream inputStream) ロール情報・インポート。
void | RoleManager.moveCategory(String oldCategory, String newCategory) カテゴリーを更新します。
Role[] | RoleManager.searchRolesById(String key) ロールID検索によりロールを取得します。
Role[] | RoleManager.searchRolesByName(String name) ロール名称検索によりロールを取得します。
void | RoleManager.updateRole(Role role) ロール情報を更新します。
boolean | RoleManager.isUpdate(Date date) ロール情報が指定された日付よりも新しいかチェックします。

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.role のコンストラクタ
RoleManager(String gid)
コンストラクタ。

jp.co.intra_mart.foundation.security.shortcut での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.shortcut のメソッド
String | ShortCutManager.createShortCut(ShortCutInfo shortCutInfo) ショートカットＩＤ作成。
void | ShortCutManager.deleteShortCut(String shortCutId) ショートカットＩＤ削除。
int | ShortCutManager.verifyShortCut(Date verifyDate) ショートカット検証。
ShortCutInfo | ShortCutManager.getShortCutInfo(String shortCutId) ショートカット情報取得。
String | ShortCutManager.getErrorPage() ショートカットエラーページ取得。
String | ShortCutManager.getMainPage() ショートカットメインページ取得。
Date | ShortCutManager.addValidEndDate(int countDays) SYSTEM日付に指定した日数を加えた日付を取得します。
String | ShortCutAccessor.createShortCut(String groupId, ShortCutInfo shortCutInfo) ショートカットIDを作成します。
void | ShortCutAccessor.deleteShortCut(String groupId, String shortCutId) ショートカットIDを削除します。
int | ShortCutAccessor.verifyShortCut(String groupId, Date verifyDate) ショートカットIDを検証します。
ShortCutInfo | ShortCutAccessor.getShortCutInfo(String groupId, String shortCutId) ショートカット情報を取得します。
Date | ShortCutAccessor.addValidEndDate(int countDays) SYSTEM日付に指定した日数を加えた日付を取得します。
String | StandardShortCutAccessor.createShortCut(String groupId, ShortCutInfo shortCutInfo) ショートカットIDを作成します。
void | StandardShortCutAccessor.deleteShortCut(String groupId, String shortCutId) ショートカットIDを削除します。
int | StandardShortCutAccessor.verifyShortCut(String groupId, Date verifyDate) ショートカットIDを検証します。
ShortCutInfo | StandardShortCutAccessor.getShortCutInfo(String groupId, String shortCutId) ショートカット情報を取得します。
Date | StandardShortCutAccessor.addValidEndDate(int countDays) SYSTEM日付に指定した日数を加えた日付を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException の使用

AccessSecurityExportException を使用しているパッケージ
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.access での AccessSecurityExportException の使用

AccessSecurityExportException をスローする jp.co.intra_mart.foundation.security.access のメソッド
void | AccessControllerExporter.doExport(AccessControllerManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardAccessControllerBackup.doExport(AccessControllerManager manager, OutputStream outputStream)

jp.co.intra_mart.foundation.security.account での AccessSecurityExportException の使用

AccessSecurityExportException をスローする jp.co.intra_mart.foundation.security.account のメソッド
void | AccountExporter.doExport(AccountManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardAccountBackup.doExport(AccountManager manager, OutputStream outputStream) エクスポートを行います。
void | CsvAccountBackup.doExport(AccountManager manager, OutputStream outputStream) エクスポートを行います。

jp.co.intra_mart.foundation.security.batch での AccessSecurityExportException の使用

AccessSecurityExportException をスローする jp.co.intra_mart.foundation.security.batch のメソッド
void | BatchExporter.doExport(BatchManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardBatchBackup.doExport(BatchManager manager, OutputStream outputStream) エクスポートを行います。

jp.co.intra_mart.foundation.security.calendar での AccessSecurityExportException の使用

AccessSecurityExportException をスローする jp.co.intra_mart.foundation.security.calendar のメソッド
void | CalendarExporter.doExport(CalendarManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardCalendarBackup.doExport(CalendarManager manager, OutputStream outputStream) エクスポートを行います。

jp.co.intra_mart.foundation.security.menu での AccessSecurityExportException の使用

AccessSecurityExportException をスローする jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuExporter.doExport(MenuManager manager, OutputStream outputStream) エクスポートを行います。
void | AdminMenuExporter.doExport(AdminMenuManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardMenuBackup.doExport(MenuManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardAdminMenuBackup.doExport(AdminMenuManager manager, OutputStream outputStream) エクスポートを行います。

jp.co.intra_mart.foundation.security.role での AccessSecurityExportException の使用

AccessSecurityExportException をスローする jp.co.intra_mart.foundation.security.role のメソッド
void | RoleExporter.doExport(RoleManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardRoleBackup.doExport(RoleManager manager, OutputStream outputStream) エクスポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException の使用

AccessSecurityImportException を使用しているパッケージ
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.access での AccessSecurityImportException の使用

AccessSecurityImportException をスローする jp.co.intra_mart.foundation.security.access のメソッド
void | AccessControllerImporter.doImport(InputStream inputStream, AccessControllerManager manager) インポートを行います。
void | StandardAccessControllerBackup.doImport(InputStream inputStream, AccessControllerManager manager)

jp.co.intra_mart.foundation.security.account での AccessSecurityImportException の使用

AccessSecurityImportException をスローする jp.co.intra_mart.foundation.security.account のメソッド
void | AccountImporter.doImport(InputStream inputStream, AccountManager manager) インポートを行います。
void | StandardAccountBackup.doImport(InputStream inputStream, AccountManager manager) インポートを行います。
void | CsvAccountBackup.doImport(InputStream inputStream, AccountManager manager) インポートを行います。

jp.co.intra_mart.foundation.security.batch での AccessSecurityImportException の使用

AccessSecurityImportException をスローする jp.co.intra_mart.foundation.security.batch のメソッド
void | BatchImporter.doImport(InputStream inputStream, BatchManager manager) インポートを行います。
void | StandardBatchBackup.doImport(InputStream inputStream, BatchManager manager) インポートを行います。

jp.co.intra_mart.foundation.security.calendar での AccessSecurityImportException の使用

AccessSecurityImportException をスローする jp.co.intra_mart.foundation.security.calendar のメソッド
void | CalendarImporter.doImport(InputStream inputStream, CalendarManager manager) インポートを行います。
void | StandardCalendarBackup.doImport(InputStream inputStream, CalendarManager manager) インポートを行います。

jp.co.intra_mart.foundation.security.menu での AccessSecurityImportException の使用

AccessSecurityImportException をスローする jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuImporter.doImport(InputStream inputStream, MenuManager manager) インポートを行います。
void | AdminMenuImporter.doImport(InputStream inputStream, AdminMenuManager manager) インポートを行います。
void | StandardMenuBackup.doImport(InputStream inputStream, MenuManager manager) インポートを行います。
void | StandardAdminMenuBackup.doImport(InputStream inputStream, AdminMenuManager manager) インポートを行います。

jp.co.intra_mart.foundation.security.role での AccessSecurityImportException の使用

AccessSecurityImportException をスローする jp.co.intra_mart.foundation.security.role のメソッド
void | RoleImporter.doImport(InputStream inputStream, RoleManager manager) インポートを行います。
void | StandardRoleBackup.doImport(InputStream inputStream, RoleManager manager) インポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion を使用しているパッケージ
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.mobile |
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.access での AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion をスローする jp.co.intra_mart.foundation.security.access のメソッド
void | AccessControllerQueryWriterListener.queryCreate(String groupId, AccessController controller) アクセスコントローラ情報をデータストアに作成する直前にコールされます。
void | AccessControllerQueryWriterListener.queryDelete(String groupId, String controllerId) アクセスコントローラ情報をデータストアから削除する直前にコールされます。
void | AccessControllerQueryWriterListener.queryUpdate(String groupId, AccessController controller) アクセスコントローラ情報をデータストアに更新する直前にコールされます。
void | AccessControllerPostWriterListener.postCreate(String groupId, AccessController controller) アクセスコントローラ情報をデータストアに作成した直後にコールされます。
void | AccessControllerPostWriterListener.postDelete(String groupId, String controllerId) アクセスコントローラ情報をデータストアから削除した直後にコールされます。
void | AccessControllerPostWriterListener.postUpdate(String groupId, AccessController controller) アクセスコントローラ情報をデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.account での AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion をスローする jp.co.intra_mart.foundation.security.account のメソッド
void | AccountQueryWriterListener.queryCreateAccount(String groupId, Account account) アカウント情報をデータストアに作成する直前にコールされます。
void | AccountQueryWriterListener.queryDeleteAccount(String groupId, String userId) アカウント情報をデータストアから削除する直前にコールされます。
void | AccountQueryWriterListener.queryUpdateAccount(String groupId, Account account) アカウント情報をデータストアに更新する直前にコールされます。
void | AccountQueryWriterListener.queryCreateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | AccountQueryWriterListener.queryDeleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報をデータストアから削除する直前にコールされます。
void | AccountQueryWriterListener.queryUpdateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新する直前にコールされます。
void | AccountQueryWriterListener.queryCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに作成する直前にコールされます。
void | AccountQueryWriterListener.queryDeleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報をデータストアから削除する直前にコールされます。
void | AccountQueryWriterListener.queryUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに更新する直前にコールされます。
void | AccountPostWriterListener.postCreateAccount(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | AccountPostWriterListener.postDeleteAccount(String groupId, String userId) アカウント情報をデータストアから削除した直後にコールされます。
void | AccountPostWriterListener.postUpdateAccount(String groupId, Account account) アカウント情報をデータストアに更新した直後にコールされます。
void | AccountPostWriterListener.postCreateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | AccountPostWriterListener.postDeleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報をデータストアから削除した直後にコールされます。
void | AccountPostWriterListener.postUpdateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新した直後にコールされます。
void | AccountPostWriterListener.postCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに作成した直後にコールされます。
void | AccountPostWriterListener.postDeleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報をデータストアから削除した直後にコールされます。
void | AccountPostWriterListener.postUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.admin での AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion をスローする jp.co.intra_mart.foundation.security.admin のメソッド
void | SuperUserQueryWriterListener.queryCreate(SuperUser superUser) システム管理者情報をデータストアに作成する直前にコールされます。
void | SuperUserQueryWriterListener.queryUpdate(SuperUser superUser) システム管理者情報をデータストアに更新する直前にコールされます。
void | SuperUserPostWriterListener.postCreate(SuperUser superUser) システム管理者情報をデータストアに作成した直後にコールされます。
void | SuperUserPostWriterListener.postUpdate(SuperUser superUser) システム管理者情報をデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.batch での AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion をスローする jp.co.intra_mart.foundation.security.batch のメソッド
void | BatchQueryWriterListener.queryCreate(String groupId, Batch batch) バッチ情報をデータストアに作成する直前にコールされます。
void | BatchQueryWriterListener.queryDelete(String groupId, String batchId) バッチ情報をデータストアから削除する直前にコールされます。
void | BatchQueryWriterListener.queryUpdate(String groupId, Batch batch) バッチ情報をデータストアに更新する直前にコールされます。
void | BatchPostWriterListener.postCreate(String groupId, Batch batch) バッチ情報をデータストアに作成した直後にコールされます。
void | BatchPostWriterListener.postDelete(String groupId, String batchId) バッチ情報をデータストアから削除した直後にコールされます。
void | BatchPostWriterListener.postUpdate(String groupId, Batch batch) バッチ情報をデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.calendar での AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion をスローする jp.co.intra_mart.foundation.security.calendar のメソッド
void | CalendarQueryWriterListener.queryCreateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに作成する直前にコールされます。
void | CalendarQueryWriterListener.queryDeleteCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータをデータストアから削除する直前にコールされます。
void | CalendarQueryWriterListener.queryUpdateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに更新する直前にコールされます。
void | CalendarPostWriterListener.postCreateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに作成した直後にコールされます。
void | CalendarPostWriterListener.postDeleteCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータをデータストアから削除した直後にコールされます。
void | CalendarPostWriterListener.postUpdateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.group での AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion をスローする jp.co.intra_mart.foundation.security.group のメソッド
void | MainPageImportLoginGroupPostWriterListener.postCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成した直後にコールされます。
void | MainPageImportLoginGroupPostWriterListener.postCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成した直後にコールされます。
void | MainPageImportLoginGroupPostWriterListener.postDeleteLoginGroup(String groupId) ログイングループ情報をデータストアから削除した直後にコールされます。
void | MainPageImportLoginGroupPostWriterListener.postDeleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターン情報をデータストアから削除した直後にコールされます。
void | MainPageImportLoginGroupPostWriterListener.postUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新した直後にコールされます。
void | MainPageImportLoginGroupPostWriterListener.postUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新した直後にコールされます。
void | LoginGroupQueryWriterListener.queryCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成する直前にコールされます。
void | LoginGroupQueryWriterListener.queryCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成する前にコールされます。
void | LoginGroupQueryWriterListener.queryDeleteLoginGroup(String groupId) ログイングループ情報をデータストアから削除する直前にコールされます。
void | LoginGroupQueryWriterListener.queryDeleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターン情報をデータストアから削除する前にコールされます。
void | LoginGroupQueryWriterListener.queryUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新する直前にコールされます。
void | LoginGroupQueryWriterListener.queryUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新する前にコールされます。
void | LoginGroupPostWriterListener.postCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成した直後にコールされます。
void | LoginGroupPostWriterListener.postCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成した直後にコールされます。
void | LoginGroupPostWriterListener.postDeleteLoginGroup(String groupId) ログイングループ情報をデータストアから削除した直後にコールされます。
void | LoginGroupPostWriterListener.postDeleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターン情報をデータストアから削除した直後にコールされます。
void | LoginGroupPostWriterListener.postUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新した直後にコールされます。
void | LoginGroupPostWriterListener.postUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.menu での AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion をスローする jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuQueryWriterListener.queryCreate(String groupId, MenuItem item) メニュー情報をデータストアに作成する直前にコールされます。
void | MenuQueryWriterListener.queryDelete(String groupId, String menuId) メニュー情報をデータストアから削除する直前にコールされます。
void | MenuQueryWriterListener.queryUpdate(String groupId, MenuItem item) メニュー情報をデータストアに更新する直前にコールされます。
void | MenuQueryWriterListener.queryMove(String groupId, String parentId, String childId) メニューの親子関係を更新する直前にコールされます。
void | MenuPostWriterListener.postCreate(String groupId, MenuItem item) メニュー情報をデータストアに作成した直後にコールされます。
void | MenuPostWriterListener.postDelete(String groupId, String menuId) メニュー情報をデータストアから削除した直後にコールされます。
void | MenuPostWriterListener.postUpdate(String groupId, MenuItem item) メニュー情報をデータストアに更新した直後にコールされます。
void | MenuPostWriterListener.postMove(String groupId, String parentId, String childId) メニューの親子関係を更新した直後にコールされます。
void | AdminMenuQueryWriterListener.queryCreate(MenuItem item) メニュー情報をデータストアに作成する直前にコールされます。
void | AdminMenuQueryWriterListener.queryDelete(String menuId) メニュー情報をデータストアから削除する直前にコールされます。
void | AdminMenuQueryWriterListener.queryUpdate(MenuItem item) メニュー情報をデータストアに更新する直前にコールされます。
void | AdminMenuQueryWriterListener.queryMove(String parentId, String childId) メニューの親子関係を更新する直前にコールされます。
void | AdminMenuQueryWriterListener.querySetAccessControlEnabled(String menuId, boolean accessControl) アクセス権限を設定する直前にコールされます。
void | AdminMenuQueryWriterListener.queryAddMenuLoginGroup(String menuId, String groupId) アクセスを許可するログイングループを追加する直前にコールされます。
void | AdminMenuQueryWriterListener.queryDeleteMenuLoginGroup(String menuId, String groupId) アクセスを許可するログイングループを削除する直前にコールされます。
void | AdminMenuPostWriterListener.postCreate(MenuItem item) メニュー情報をデータストアに作成した直後にコールされます。
void | AdminMenuPostWriterListener.postDelete(String menuId) メニュー情報をデータストアから削除した直後にコールされます。
void | AdminMenuPostWriterListener.postUpdate(MenuItem item) メニュー情報をデータストアに更新した直後にコールされます。
void | AdminMenuPostWriterListener.postMove(String parentId, String childId) メニューの親子関係を更新した直後にコールされます。
void | AdminMenuPostWriterListener.postSetAccessControlEnabled(String menuId, boolean accessControl) アクセス権限を設定する直前にコールされます。
void | AdminMenuPostWriterListener.postAddMenuLoginGroup(String menuId, String groupId) アクセスを許可するログイングループを追加する直後にコールされます。
void | AdminMenuPostWriterListener.postDeleteMenuLoginGroup(String menuId, String groupId) アクセスを許可するログイングループを削除する直後にコールされます。

jp.co.intra_mart.foundation.security.mobile での AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion をスローする jp.co.intra_mart.foundation.security.mobile のメソッド
void | NonceResetListener4MobileEasyLogin.queryUpdateAccount(String groupId, Account account)
void | NonceResetListener4MobileEasyLogin.postUpdateAccount(String groupId, Account account)
void | NonceResetListener4MobileEasyLogin.queryCreateAccount(String groupId, Account account)
void | NonceResetListener4MobileEasyLogin.queryCreateAccountRole(String groupId, String userId, AccountRole accountRole)
void | NonceResetListener4MobileEasyLogin.queryCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu)
void | NonceResetListener4MobileEasyLogin.queryDeleteAccount(String groupId, String userId)
void | NonceResetListener4MobileEasyLogin.queryDeleteAccountRole(String groupId, String userId, String roleId)
void | NonceResetListener4MobileEasyLogin.queryDeleteFavoriteMenu(String groupId, String userId, String menuId)
void | NonceResetListener4MobileEasyLogin.queryUpdateAccountRole(String groupId, String userId, AccountRole accountRole)
void | NonceResetListener4MobileEasyLogin.queryUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu)
void | NonceResetListener4MobileEasyLogin.postCreateAccount(String groupId, Account account)
void | NonceResetListener4MobileEasyLogin.postCreateAccountRole(String groupId, String userId, AccountRole accountRole)
void | NonceResetListener4MobileEasyLogin.postCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu)
void | NonceResetListener4MobileEasyLogin.postDeleteAccount(String groupId, String userId)
void | NonceResetListener4MobileEasyLogin.postDeleteAccountRole(String groupId, String userId, String roleId)
void | NonceResetListener4MobileEasyLogin.postDeleteFavoriteMenu(String groupId, String userId, String menuId)
void | NonceResetListener4MobileEasyLogin.postUpdateAccountRole(String groupId, String userId, AccountRole accountRole)
void | NonceResetListener4MobileEasyLogin.postUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu)

jp.co.intra_mart.foundation.security.role での AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion をスローする jp.co.intra_mart.foundation.security.role のメソッド
void | RoleQueryWriterListener.queryCreateRole(String groupId, Role role) ロール情報をデータストアに作成する直前にコールされます。
void | RoleQueryWriterListener.queryDeleteRole(String groupId, String roleId) ロール情報をデータストアから削除する直前にコールされます。
void | RoleQueryWriterListener.queryUpdateRole(String groupId, Role role) ロール情報をデータストアに更新する直前にコールされます。
void | RoleQueryWriterListener.postCreateSubRole(String groupId, String roleId, String subRoleId) ロールにサブロールを追加する直前にコールされます。
void | RoleQueryWriterListener.postDeleteSubRole(String groupId, String roleId, String subRoleId) ロールからサブロールを削除する直前にコールされます。
void | RolePostWriterListener.postCreateRole(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RolePostWriterListener.postDeleteRole(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | RolePostWriterListener.postUpdateRole(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | RolePostWriterListener.postCreateSubRole(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | RolePostWriterListener.postDeleteSubRole(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException の使用

AccessSecurityReadException を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での AccessSecurityReadException の使用

AccessSecurityReadException をスローする jp.co.intra_mart.foundation.security のメソッド
String[] | StandardRoleAccessor.getAllParentRoleIds(String groupId, String roleId) すべての親ロールの一覧を取得します。
String[] | StandardRoleAccessor.getAllSubRoleIds(String groupId, String roleId) すべてのサブロールの一覧を取得します。
String[] | StandardRoleAccessor.getCategories(String groupId) カテゴリの一覧を取得します。
String[] | StandardRoleAccessor.getParentRoleIds(String groupId, String roleId) 親ロールの一覧を取得します。
Role[] | StandardRoleAccessor.getRoleData(String groupId) ロール情報を全件取得します。
Role | StandardRoleAccessor.getRoleData(String groupId, String roleId) ロール情報を取得します。
Role[] | StandardRoleAccessor.getRoleDataByCategory(String groupId, String category) カテゴリからロール情報を取得します。
Role[] | StandardRoleAccessor.getRolesByIds(String groupId, String[] roleIds) 指定されたロールIDのロール情報をすべて取得します。
String[] | StandardRoleAccessor.getSubRoleIds(String groupId, String roleId) サブロールIDサマリを取得します。
String[] | StandardMenuAccessor.getChildMenuIds(String groupId, String menuId) 引数で指定されたノードの直下の子メニューIDを配列で取得します。
String[] | StandardMenuAccessor.getFirstMenuIds(String groupId) 第一階層に属するメニューIDを配列で取得します。
DepartmentInfo[] | StandardMenuAccessor.getMenuDepartments(String groupId, String id) すべてのメニュー組織を取得します。
String[] | StandardMenuAccessor.getMenuIds(String groupId) すべてのメニューIDを取得します。
String[] | StandardMenuAccessor.getMenuIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つメニューIDをすべて取得します。
String[] | StandardMenuAccessor.getMenuIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つメニューIDをすべて取得します。
String[] | StandardMenuAccessor.getMenuIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つメニューIDをすべて取得します。
String[] | StandardMenuAccessor.getMenuIdsByRole(String groupId, String[] roleIds) 指定されたロールIDを持つメニューIDをすべて取得します。
MenuInclusion[] | StandardMenuAccessor.getMenuInclusions(String groupId) すべてのメニュー構成を取得します。
MenuItem | StandardMenuAccessor.getMenuItem(String groupId, String menuId) 指定されたメニューIDに対するノードを取得します。
MenuItem[] | StandardMenuAccessor.getMenuItems(String groupId) すべてのノードを取得します。
MenuItem[] | StandardMenuAccessor.getMenuItemsByIds(String groupId, String[] menuIds) 指定されたメニューIDのメニュー情報をすべて取得します。
PostInfo[] | StandardMenuAccessor.getMenuPosts(String groupId, String id) すべてのメニュー役職を取得します。
PublicGroupInfo[] | StandardMenuAccessor.getMenuPublicGroups(String groupId, String id) すべてのメニューパブリックグループを取得します。
String[] | StandardMenuAccessor.getMenuRoles(String groupId, String menuId) すべてのメニューロールを取得します。
String | StandardMenuAccessor.getParentMenuId(String groupId, String menuId) 引数で指定されたノードの親ノードを取得します。
String[] | StandardCalendarAccessor.getCalendarIds(String groupId) すべてのカレンダーIDを取得します。
CalendarInfo | StandardCalendarAccessor.getCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータを取得します。
String[] | StandardCalendarAccessor.getCalendarInfoIds(String groupId, String calendarId) すべてのカレンダーデータIDを取得します。
CalendarInfo[] | StandardCalendarAccessor.getCalendarInfos(String groupId, String calendarId) すべてのカレンダーデータを取得します。
CalendarInfo[] | StandardCalendarAccessor.getCalendarInfosByIds(String groupId, String calendarId, String[] calendarInfoIds) 指定されたカレンダーデータIDのカレンダー情報をすべて取得する。
Batch | StandardBatchAccessor.getBatch(String groupId, String batchId) バッチを取得します。
Batch[] | StandardBatchAccessor.getBatches(String groupId) バッチの一覧を取得します。
Batch[] | StandardBatchAccessor.getBatchesByIds(String groupId, String[] batchIds) 引数に指定したバッチIDのバッチ情報をすべて取得します。
String[] | StandardBatchAccessor.getBatchIds(String groupId) バッチIDの一覧を取得します。
protected String[] | StandardAccountAccessor.getUserIdsByRolesIn(String groupId, String[] roleIds, Date date) 指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
protected String[] | StandardAccountAccessor.getUserIdsByRolesPlural(String groupId, String[] roleIds, Date date) 指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
Account | StandardAccountAccessor.getAccount(String groupId, String userId) アカウント情報を取得する。
int | StandardAccountAccessor.getAccountCount(String groupId) アカウント数を取得する。
AccountRole | StandardAccountAccessor.getAccountRole(String groupId, String userId, String roleId) アカウントロール情報を取得する。
String[] | StandardAccountAccessor.getAccountRoleIds(String groupId, String userId) アカウントロールIDをすべて取得する。
AccountRole[] | StandardAccountAccessor.getAccountRoles(String groupId, String userId) アカウントロール情報をすべて取得する。
Account[] | StandardAccountAccessor.getAccountsByUserIds(String groupId, String[] userIds) 指定されたユーザIDのアカウント情報をすべて取得する。
FavoriteMenu | StandardAccountAccessor.getFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を取得する。
String[] | StandardAccountAccessor.getFavoriteMenuIds(String groupId, String userId) マイメニューIDをすべて取得する。
FavoriteMenu[] | StandardAccountAccessor.getFavoriteMenus(String groupId, String userId) マイメニュー情報をすべて取得する。
String[] | StandardAccountAccessor.getUserIds(String groupId) ユーザIDの一覧を取得する。
String[] | StandardAccountAccessor.getUserIdsByAccountRole(String groupId, String roleId) 引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
String[] | StandardAccountAccessor.getUserIdsByRoles(String groupId, String[] roleIds, Date date) 指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
Account[] | StandardAccountAccessor.searchAccounts(String groupId, String userId) アカウント情報の読み込みます。
String | StandardAccountAccessor.getAttribute(String groupId, String userId, String name) アカウント属性情報を取得する。
String[] | StandardAccountAccessor.getAttributeNames(String groupId, String userId) アカウント属性名の一覧を取得する。
String[] | StandardAccountAccessor.getUserIdsByAttribute(String groupId, String key, String value) アカウント属性情報の値と一致するユーザIDを取得する。
AccessController | StandardAccessControllerAccessor.getController(String groupId, String controllerId) アクセスコントローラ情報を取得します。
AccessController[] | StandardAccessControllerAccessor.getControllers(String groupId) すべてのアクセスコントローラ情報を取得します。
DepartmentInfo[] | StandardAccessControllerAccessor.getControllerDepartments(String groupId, String id) すべてのアクセスコントローラ組織を取得します。
String[] | StandardAccessControllerAccessor.getControllerIds(String groupId) すべてのアクセスコントローラIDを取得します。
String[] | StandardAccessControllerAccessor.getControllerIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つコントローラIDをすべて取得します。
String[] | StandardAccessControllerAccessor.getControllerIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つコントローラIDをすべて取得します。
String[] | StandardAccessControllerAccessor.getControllerIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つコントローラIDをすべて取得します。
String[] | StandardAccessControllerAccessor.getControllerIdsByRole(String groupId, String[] roleIds) 指定されたロールIDを持つコントローラIDをすべて取得します。
PostInfo[] | StandardAccessControllerAccessor.getControllerPosts(String groupId, String id) すべてのアクセスコントローラ役職を取得します。
PublicGroupInfo[] | StandardAccessControllerAccessor.getControllerPublicGroups(String groupId, String id) すべてのアクセスコントローラパブリックグループを取得します。
String[] | StandardAccessControllerAccessor.getControllerRoles(String groupId, String id) すべてのアクセスコントローラロールを取得します。

jp.co.intra_mart.foundation.security.access での AccessSecurityReadException の使用

AccessSecurityReadException をスローする jp.co.intra_mart.foundation.security.access のメソッド
AccessController | AccessControllerAccessor.getController(String groupId, String controllerId) アクセスコントローラ情報を取得します。
AccessController[] | AccessControllerAccessor.getControllers(String groupId) すべてのアクセスコントローラ情報を取得します。
DepartmentInfo[] | AccessControllerAccessor.getControllerDepartments(String groupId, String id) すべてのアクセスコントローラ組織を取得します。
String[] | AccessControllerAccessor.getControllerIds(String groupId) すべてのアクセスコントローラIDを取得します。
String[] | AccessControllerAccessor.getControllerIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つコントローラIDをすべて取得します。
String[] | AccessControllerAccessor.getControllerIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つコントローラIDをすべて取得します。
String[] | AccessControllerAccessor.getControllerIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つコントローラIDをすべて取得します。
String[] | AccessControllerAccessor.getControllerIdsByRole(String groupId, String[] roleIds) 指定されたロールIDを持つコントローラIDをすべて取得します。
PostInfo[] | AccessControllerAccessor.getControllerPosts(String groupId, String id) すべてのアクセスコントローラ役職を取得します。
PublicGroupInfo[] | AccessControllerAccessor.getControllerPublicGroups(String groupId, String id) すべてのアクセスコントローラパブリックグループを取得します。
String[] | AccessControllerAccessor.getControllerRoles(String groupId, String id) すべてのアクセスコントローラロールを取得します。

jp.co.intra_mart.foundation.security.account での AccessSecurityReadException の使用

AccessSecurityReadException をスローする jp.co.intra_mart.foundation.security.account のメソッド
Account | AccountAccessor.getAccount(String groupId, String userId) アカウント情報を取得する。
Account[] | AccountAccessor.getAccountsByUserIds(String groupId, String[] userIds) 指定されたユーザIDのアカウント情報をすべて取得する。
int | AccountAccessor.getAccountCount(String groupId) アカウント数を取得する。
AccountRole | AccountAccessor.getAccountRole(String groupId, String userId, String roleId) アカウントロール情報を取得する。
String[] | AccountAccessor.getAccountRoleIds(String groupId, String userId) アカウントロールIDをすべて取得する。
AccountRole[] | AccountAccessor.getAccountRoles(String groupId, String userId) アカウントロール情報をすべて取得する。
FavoriteMenu | AccountAccessor.getFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を取得する。
String[] | AccountAccessor.getFavoriteMenuIds(String groupId, String userId) マイメニューIDをすべて取得する。
FavoriteMenu[] | AccountAccessor.getFavoriteMenus(String groupId, String userId) マイメニュー情報をすべて取得する。
String[] | AccountAccessor.getUserIds(String groupId) ユーザIDの一覧を取得する。
String[] | AccountAccessor.getUserIdsByRoles(String groupId, String[] roleIds, Date date) 指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
Account[] | AccountAccessor.searchAccounts(String groupId, String userId) アカウント情報の読み込みます。
String[] | AccountAccessor.getUserIdsByAccountRole(String groupId, String roleId) 引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
String | AccountAccessor.getAttribute(String groupId, String userId, String name) アカウント属性情報を取得する。
String[] | AccountAccessor.getAttributeNames(String groupId, String userId) アカウント属性情報の名前の一覧を取得する。
String[] | AccountAccessor.getUserIdsByAttribute(String groupId, String key, String value) アカウント属性情報の値と一致するユーザIDを取得する。

jp.co.intra_mart.foundation.security.admin での AccessSecurityReadException の使用

AccessSecurityReadException をスローする jp.co.intra_mart.foundation.security.admin のメソッド
 SuperUser SuperUserAccessor.getSuperUser()
システム管理者情報を取得します。

jp.co.intra_mart.foundation.security.batch での AccessSecurityReadException の使用

AccessSecurityReadException をスローする jp.co.intra_mart.foundation.security.batch のメソッド
Batch | BatchAccessor.getBatch(String groupId, String batchId) バッチ情報を取得します。
Batch[] | BatchAccessor.getBatches(String groupId) すべてのバッチ情報を取得します。
Batch[] | BatchAccessor.getBatchesByIds(String groupId, String[] batchIds) 引数に指定したバッチIDのバッチ情報をすべて取得します。
String[] | BatchAccessor.getBatchIds(String groupId) すべてのバッチIDを取得します。

jp.co.intra_mart.foundation.security.calendar での AccessSecurityReadException の使用

AccessSecurityReadException をスローする jp.co.intra_mart.foundation.security.calendar のメソッド
String[] | CalendarAccessor.getCalendarIds(String groupId) すべてのカレンダーIDを取得します。
CalendarInfo | CalendarAccessor.getCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータを取得します。
String[] | CalendarAccessor.getCalendarInfoIds(String groupId, String calendarId) すべてのカレンダーデータIDを取得します。
CalendarInfo[] | CalendarAccessor.getCalendarInfos(String groupId, String calendarId) すべてのカレンダーデータを取得します。
CalendarInfo[] | CalendarAccessor.getCalendarInfosByIds(String groupId, String calendarId, String[] calendarInfoIds) 指定されたカレンダIDのカレンダ情報をすべて取得する。

jp.co.intra_mart.foundation.security.group での AccessSecurityReadException の使用

AccessSecurityReadException をスローする jp.co.intra_mart.foundation.security.group のメソッド
LoginGroup | LoginGroupAccessor.getLoginGroup(String groupId) ログイングループ情報を取得します。
String[] | LoginGroupAccessor.getLoginGroupIds() ログイングループIDの一覧を取得します。
MainPagePatternInfo | LoginGroupAccessor.getMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを取得します。
String[] | LoginGroupAccessor.getMainPagePatternIds(String groupId) メインページパターンIDの一覧を取得します。
SuperUser | GroupSuperUserAccessor.getSuperUser(String groupId) グループ管理者情報を取得します。

jp.co.intra_mart.foundation.security.menu での AccessSecurityReadException の使用

AccessSecurityReadException をスローする jp.co.intra_mart.foundation.security.menu のメソッド
String[] | MenuAccessor.getChildMenuIds(String groupId, String menuId) 引数で指定されたノードの直下の子ノードを配列で取得します。
String[] | MenuAccessor.getFirstMenuIds(String groupId) 第一階層に属するノードを配列で取得します。
DepartmentInfo[] | MenuAccessor.getMenuDepartments(String groupId, String id) すべてのメニュー組織を取得します。
String[] | MenuAccessor.getMenuIds(String groupId) すべてのメニューIDを取得します。
String[] | MenuAccessor.getMenuIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つメニューIDをすべて取得します。
String[] | MenuAccessor.getMenuIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つメニューIDをすべて取得します。
String[] | MenuAccessor.getMenuIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つメニューIDをすべて取得します。
String[] | MenuAccessor.getMenuIdsByRole(String groupId, String[] roleIds) 指定されたロールIDを持つメニューIDをすべて取得します。
MenuInclusion[] | MenuAccessor.getMenuInclusions(String groupId) すべてのメニュー構成を取得します。
MenuItem | MenuAccessor.getMenuItem(String groupId, String menuId) 指定されたメニューIDに対するノードを取得します。
MenuItem[] | MenuAccessor.getMenuItems(String groupId) すべてのノードを取得します。
MenuItem[] | MenuAccessor.getMenuItemsByIds(String groupId, String[] menuIds) 指定されたユーザIDのメニュー情報をすべて取得します。
PostInfo[] | MenuAccessor.getMenuPosts(String groupId, String id) すべてのメニュー役職を取得します。
PublicGroupInfo[] | MenuAccessor.getMenuPublicGroups(String groupId, String id) すべてのメニューパブリックグループを取得します。
String[] | MenuAccessor.getMenuRoles(String groupId, String id) すべてのメニューロールを取得します。
String | MenuAccessor.getParentMenuId(String groupId, String menuId) 引数で指定されたノードの親ノードを取得します。
String[] | AdminMenuAccessor.getChildMenuIds(String menuId) 引数で指定されたノードの直下の子ノードを配列で取得します。
String[] | AdminMenuAccessor.getFirstMenuIds() 第一階層に属するノードを配列で取得します。
String[] | AdminMenuAccessor.getMenuIds() すべてのメニューIDを取得します。
MenuInclusion[] | AdminMenuAccessor.getMenuInclusions() すべてのメニュー構成を取得します。
MenuItem | AdminMenuAccessor.getMenuItem(String menuId) 指定されたメニューIDに対するノードを取得します。
MenuItem[] | AdminMenuAccessor.getMenuItems() すべてのノードを取得します。
String | AdminMenuAccessor.getParentMenuId(String menuId) 引数で指定されたノードの親ノードを取得します。
String[] | AdminMenuAccessor.getMenuIdsByLoginGroup(String groupId) ログイングループがアクセス可能な管理メニューIDの一覧を取得します。
MenuItem[] | AdminMenuAccessor.getMenuItemsByIds(String[] menuIds) 管理メニューIDの一覧からメニューアイテムを取得します。
String[] | AdminMenuAccessor.getMenuLoginGroups(String menuId) 管理メニューにアクセス可能なログイングループの一覧を取得します。
boolean | AdminMenuAccessor.isAccessControlEnabled(String menuId) メニューアイテムのアクセス権の有無を取得します。

jp.co.intra_mart.foundation.security.role での AccessSecurityReadException の使用

AccessSecurityReadException をスローする jp.co.intra_mart.foundation.security.role のメソッド
int | RoleManager.count() ロール数を取得します。
String[] | RoleManager.getCategories() カテゴリーの一覧を取得します。
String[] | RoleManager.getRoleIds() すべてのロールIDを取得します。
Role[] | RoleManager.getRoles() すべてのロール情報を取得します。
String[] | RoleAccessor.getAllParentRoleIds(String groupId, String roleId) すべての親ロールの一覧を取得する。
String[] | RoleAccessor.getAllSubRoleIds(String groupId, String roleId) すべてのサブロールの一覧を取得する。
String[] | RoleAccessor.getCategories(String groupId) カテゴリの一覧を取得する。
String[] | RoleAccessor.getParentRoleIds(String groupId, String roleId) 親ロールの一覧を取得する。
Role[] | RoleAccessor.getRoleData(String groupId) ロール情報を全件取得する。
Role | RoleAccessor.getRoleData(String groupId, String roleId) ロール情報を取得する。
Role[] | RoleAccessor.getRoleDataByCategory(String groupId, String category) カテゴリからロール情報を取得する。
Role[] | RoleAccessor.getRolesByIds(String groupId, String[] roleIds) 指定されたロールIDのロール情報をすべて取得する。
String[] | RoleAccessor.getSubRoleIds(String groupId, String roleId) サブロールIDサマリを取得する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException の使用

AccessSecurityRuntimeException を使用しているパッケージ
jp.co.intra_mart.foundation.security.exception アクセスセキュリティ例外に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.exception での AccessSecurityRuntimeException の使用

jp.co.intra_mart.foundation.security.exception での AccessSecurityRuntimeException のサブクラス
class | AccessSecurityConfigException アクセスセキュリティ設定に関する例外クラス。
class | SystemConfigException システム設定に関する例外クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException の使用

jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException の使用

AccessSecurityWriteException を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での AccessSecurityWriteException の使用

AccessSecurityWriteException をスローする jp.co.intra_mart.foundation.security のメソッド
void | StandardRoleAccessor.createRole(String groupId, Role role) ロール情報を新規追加します。
void | StandardRoleAccessor.deleteCategory(String groupId) すべてのカテゴリを削除します。
void | StandardRoleAccessor.deleteCategory(String groupId, String category) カテゴリを削除します。
void | StandardRoleAccessor.deleteRole(String groupId) すべてのロール情報を削除します。
void | StandardRoleAccessor.deleteRole(String groupId, String roleId) ロール情報を削除します。
void | StandardRoleAccessor.deleteSubRole(String groupId, String roleId) サブロールIDを削除します。
void | StandardRoleAccessor.deleteSubRole(String groupId, String roleId, String subRoleId) 指定したサブロールIDを削除します。
void | StandardRoleAccessor.insertSubRole(String groupId, String roleId, String subRoleId) サブロールを作成します。
void | StandardRoleAccessor.updateCategory(String groupId, String oldCategory, String newCategory) カテゴリを更新します。
void | StandardRoleAccessor.updateRole(String groupId, Role role) ロール情報を更新します。
void | StandardMenuAccessor.deleteMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を削除します。
void | StandardMenuAccessor.deleteMenuDepartments(String groupId, String id) すべてのメニュー組織を削除します。
void | StandardMenuAccessor.deleteMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を削除します。
void | StandardMenuAccessor.deleteMenuItem(String groupId, String id) 引数で渡されたノードを削除します。
void | StandardMenuAccessor.deleteMenuPost(String groupId, String id, PostInfo postInfo) メニュー役職を削除します。
void | StandardMenuAccessor.deleteMenuPosts(String groupId, String id) すべてのメニュー役職を削除します。
void | StandardMenuAccessor.deleteMenuPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) メニューパブリックグループを削除します。
void | StandardMenuAccessor.deleteMenuPublicGroups(String groupId, String id) すべてのメニューパブリックグループを削除します。
void | StandardMenuAccessor.deleteMenuRole(String groupId, String id, String roleId) メニューロールを削除します。
void | StandardMenuAccessor.deleteMenuRoles(String groupId, String menuId) すべてのメニューロールを削除します。
void | StandardMenuAccessor.insertMenuDepartment(String groupId, String menuId, DepartmentInfo departmentInfo) メニュー組織を新規に作成します。
void | StandardMenuAccessor.insertMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を新規に作成します。
void | StandardMenuAccessor.insertMenuItem(String groupId, MenuItem menuItem, String parentId) 引数で渡されたノードを新規追加します。
void | StandardMenuAccessor.insertMenuPost(String groupId, String menuId, PostInfo postInfo) メニュー役職を新規に作成します。
void | StandardMenuAccessor.insertMenuPublicGroup(String groupId, String menuId, PublicGroupInfo publicGroupInfo) メニューパブリックグループを新規に作成します。
void | StandardMenuAccessor.insertMenuRole(String groupId, String menuId, String roleId) メニューロールを新規に作成します。
void | StandardMenuAccessor.updateMenuItem(String groupId, MenuItem menuItem) 引数で渡されたノードを更新します。
void | StandardCalendarAccessor.deleteCalendar(String groupId, String calendarId) カレンダーを削除します。
void | StandardCalendarAccessor.deleteCalendarInfo(String groupId, String calendarId, String dataId) 指定されたカレンダーデータを削除します。
void | StandardCalendarAccessor.insertCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に作成します。
void | StandardCalendarAccessor.updateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。
void | StandardBatchAccessor.deleteBatch(String groupId, String batchId) バッチを削除します。
void | StandardBatchAccessor.insertBatch(String groupId, Batch batch) バッチを登録します。
void | StandardBatchAccessor.updateBatch(String groupId, Batch batch) バッチを更新します。
void | StandardAccountAccessor.deleteAccount(String groupId, String userId) アカウント情報を削除する。
void | StandardAccountAccessor.deleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報を削除する。
void | StandardAccountAccessor.deleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を削除する。
void | StandardAccountAccessor.insertAccount(String groupId, Account account) アカウント情報を新規追加する。
void | StandardAccountAccessor.insertAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を新規追加する。
void | StandardAccountAccessor.insertFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を新規追加する。
void | StandardAccountAccessor.updateAccount(String groupId, Account account) アカウント情報を更新する。
void | StandardAccountAccessor.updateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を更新する。
void | StandardAccountAccessor.updateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を更新する。
void | StandardAccountAccessor.setAttribute(String groupId, String userId, String name, String value) アカウント属性情報を設定する。
void | StandardAccountAccessor.deleteAttribute(String groupId, String userId, String name) アカウント属性情報を削除する。
void | StandardAccessControllerAccessor.deleteController(String groupId, String controllerId) アクセスコントローラを削除します。
void | StandardAccessControllerAccessor.deleteControllerDepartment(String groupId, String id, DepartmentInfo departmentInfo) アクセスコントローラ組織を削除します。
void | StandardAccessControllerAccessor.deleteControllerDepartments(String groupId, String id) すべてのアクセスコントローラ組織を削除します。
void | StandardAccessControllerAccessor.deleteControllerPost(String groupId, String id, PostInfo postInfo) アクセスコントローラ役職を削除します。
void | StandardAccessControllerAccessor.deleteControllerPosts(String groupId, String id) すべてのアクセスコントローラ役職を削除します。
void | StandardAccessControllerAccessor.deleteControllerPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) アクセスコントローラパブリックグループを削除します。
void | StandardAccessControllerAccessor.deleteControllerPublicGroups(String groupId, String id) すべてのアクセスコントローラパブリックグループを削除します。
void | StandardAccessControllerAccessor.deleteControllerRole(String groupId, String id, String roleId) アクセスコントローラロールを削除します。
void | StandardAccessControllerAccessor.deleteControllerRoles(String groupId, String id) すべてのアクセスコントローラロールを削除します。
void | StandardAccessControllerAccessor.insertAccessController(String groupId, AccessController controller) アクセスコントローラを作成します。
void | StandardAccessControllerAccessor.insertControllerDepartment(String groupId, String id, DepartmentInfo departmentInfo) アクセスコントローラ組織を新規に作成します。
void | StandardAccessControllerAccessor.insertControllerPost(String groupId, String id, PostInfo postInfo) アクセスコントローラ役職を新規に作成します。
void | StandardAccessControllerAccessor.insertControllerPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) アクセスコントローラパブリックグループを新規に作成します。
void | StandardAccessControllerAccessor.insertControllerRole(String groupId, String id, String roleId) アクセスコントローラロールを新規に作成します。
void | StandardAccessControllerAccessor.updateController(String groupId, AccessController controller) アクセスコントローラを更新します。

jp.co.intra_mart.foundation.security.access での AccessSecurityWriteException の使用

AccessSecurityWriteException をスローする jp.co.intra_mart.foundation.security.access のメソッド
void | AccessControllerAccessor.deleteController(String groupId, String controllerId) アクセスコントローラを削除します。
void | AccessControllerAccessor.deleteControllerDepartment(String groupId, String id, DepartmentInfo departmentInfo) アクセスコントローラ組織を削除します。
void | AccessControllerAccessor.deleteControllerDepartments(String groupId, String id) すべてのアクセスコントローラ組織を削除します。
void | AccessControllerAccessor.deleteControllerPost(String groupId, String id, PostInfo postInfo) アクセスコントローラ役職を削除します。
void | AccessControllerAccessor.deleteControllerPosts(String groupId, String id) すべてのアクセスコントローラ役職を削除します。
void | AccessControllerAccessor.deleteControllerPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) アクセスコントローラパブリックグループを削除します。
void | AccessControllerAccessor.deleteControllerPublicGroups(String groupId, String id) すべてのアクセスコントローラパブリックグループを削除します。
void | AccessControllerAccessor.deleteControllerRole(String groupId, String id, String roleId) アクセスコントローラロールを削除します。
void | AccessControllerAccessor.deleteControllerRoles(String groupId, String id) すべてのアクセスコントローラロールを削除します。
void | AccessControllerAccessor.insertAccessController(String groupId, AccessController controller) アクセスコントローラを作成します。
void | AccessControllerAccessor.insertControllerDepartment(String groupId, String id, DepartmentInfo departmentInfo) アクセスコントローラ組織を新規に作成します。
void | AccessControllerAccessor.insertControllerPost(String groupId, String id, PostInfo postInfo) アクセスコントローラ役職を新規に作成します。
void | AccessControllerAccessor.insertControllerPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) アクセスコントローラパブリックグループを新規に作成します。
void | AccessControllerAccessor.insertControllerRole(String groupId, String id, String roleId) アクセスコントローラロールを新規に作成します。
void | AccessControllerAccessor.updateController(String groupId, AccessController controller) アクセスコントローラを更新します。

jp.co.intra_mart.foundation.security.account での AccessSecurityWriteException の使用

AccessSecurityWriteException をスローする jp.co.intra_mart.foundation.security.account のメソッド
void | AccountAccessor.deleteAccount(String groupId, String userId) アカウント情報を削除する。
void | AccountAccessor.deleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報を削除する。
void | AccountAccessor.deleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を削除する。
void | AccountAccessor.insertAccount(String groupId, Account account) アカウント情報を新規追加する。
void | AccountAccessor.insertAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を新規追加する。
void | AccountAccessor.insertFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を新規追加する。
void | AccountAccessor.updateAccount(String groupId, Account account) アカウント情報を更新する。
void | AccountAccessor.updateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を更新する。
void | AccountAccessor.updateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を更新する。
void | AccountAccessor.setAttribute(String groupId, String userId, String name, String value) アカウント属性情報を設定する。
void | AccountAccessor.deleteAttribute(String groupId, String userId, String name) アカウント属性情報を削除する。

jp.co.intra_mart.foundation.security.admin での AccessSecurityWriteException の使用

AccessSecurityWriteException をスローする jp.co.intra_mart.foundation.security.admin のメソッド
void | SuperUserAccessor.insertSuperUser(SuperUser superUser) システム管理者情報を新規追加します。
void | SuperUserAccessor.updateSuperUser(SuperUser superUser) システム管理者情報を更新します。

jp.co.intra_mart.foundation.security.batch での AccessSecurityWriteException の使用

AccessSecurityWriteException をスローする jp.co.intra_mart.foundation.security.batch のメソッド
void | BatchAccessor.deleteBatch(String groupId, String batchId) バッチ情報を削除します。
void | BatchAccessor.updateBatch(String groupId, Batch batch) バッチ情報を更新します。
void | BatchAccessor.insertBatch(String groupId, Batch batch) バッチ情報を新規に追加します。

jp.co.intra_mart.foundation.security.calendar での AccessSecurityWriteException の使用

AccessSecurityWriteException をスローする jp.co.intra_mart.foundation.security.calendar のメソッド
void | CalendarAccessor.deleteCalendar(String groupId, String calendarId) カレンダーを削除します。
void | CalendarAccessor.deleteCalendarInfo(String groupId, String calendarId, String dataId) 指定されたカレンダーデータを削除します。
void | CalendarAccessor.insertCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に作成します。
void | CalendarAccessor.updateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。

jp.co.intra_mart.foundation.security.exception での AccessSecurityWriteException の使用

jp.co.intra_mart.foundation.security.exception での AccessSecurityWriteException のサブクラス
class | AccessSecurityCreateException アクセスセキュリティ情報作成例外クラス。
class | AccessSecurityDeleteException アクセスセキュリティ情報削除例外クラス。
class | AccessSecurityUpdateException アクセスセキュリティ情報更新例外クラス。
class | DuplicateException 作成時重複例外クラス。
class | NotExistException アクセスセキュリティ情報が存在しなかった場合の例外クラス。
class | NotSupportMethodException アクセスセキュリティのマネージャでサポートされないメソッドがコールされた場合の例外クラス。

jp.co.intra_mart.foundation.security.group での AccessSecurityWriteException の使用

AccessSecurityWriteException をスローする jp.co.intra_mart.foundation.security.group のメソッド
void | LoginGroupAccessor.deleteLoginGroup(String groupId) ログイングループを削除します。
void | LoginGroupAccessor.deleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを削除します。
void | LoginGroupAccessor.insertLoginGroup(LoginGroup loginGroup) ログイングループを新規追加します。
void | LoginGroupAccessor.insertMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを新規追加します。
void | LoginGroupAccessor.updateLoginGroup(LoginGroup loginGroup) ログイングループを更新します。
void | LoginGroupAccessor.updateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを更新します。
void | GroupSuperUserAccessor.deleteSuperUser(String groupId) グループ管理者情報を削除します。
void | GroupSuperUserAccessor.insertSuperUser(String groupId, SuperUser superUser) グループ管理者情報を新規追加します。
void | GroupSuperUserAccessor.updateSuperUser(String groupId, SuperUser superUser) グループ管理者情報を更新します。

jp.co.intra_mart.foundation.security.menu での AccessSecurityWriteException の使用

AccessSecurityWriteException をスローする jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuAccessor.deleteMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を削除します。
void | MenuAccessor.deleteMenuDepartments(String groupId, String id) すべてのメニュー組織を削除します。
void | MenuAccessor.deleteMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を削除します。
void | MenuAccessor.deleteMenuItem(String groupId, String id) 引数で渡されたノードを削除します。
void | MenuAccessor.deleteMenuPost(String groupId, String id, PostInfo postInfo) メニュー役職を削除します。
void | MenuAccessor.deleteMenuPosts(String groupId, String id) すべてのメニュー役職を削除します。
void | MenuAccessor.deleteMenuPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) メニューパブリックグループを削除します。
void | MenuAccessor.deleteMenuPublicGroups(String groupId, String id) すべてのメニューパブリックグループを削除します。
void | MenuAccessor.deleteMenuRole(String groupId, String id, String roleId) メニューロールを削除します。
void | MenuAccessor.deleteMenuRoles(String groupId, String id) すべてのメニューロールを削除します。
void | MenuAccessor.insertMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を新規に作成します。
void | MenuAccessor.insertMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を新規に作成します。
void | MenuAccessor.insertMenuItem(String groupId, MenuItem menuItem, String parentId) 引数で渡されたノードを新規追加します。
void | MenuAccessor.insertMenuPost(String groupId, String id, PostInfo postInfo) メニュー役職を新規に作成します。
void | MenuAccessor.insertMenuPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) メニューパブリックグループを新規に作成します。
void | MenuAccessor.insertMenuRole(String groupId, String id, String roleId) メニューロールを新規に作成します。
void | MenuAccessor.updateMenuItem(String groupId, MenuItem menuItem) 引数で渡されたノードを更新します。
void | AdminMenuAccessor.deleteMenuInclusion(MenuInclusion menuInclusion) メニュー構成を削除します。
void | AdminMenuAccessor.deleteMenuItem(String menuId) 引数で渡されたノードを削除します。
void | AdminMenuAccessor.insertMenuInclusion(MenuInclusion menuInclusion) メニュー構成を新規に作成します。
void | AdminMenuAccessor.insertMenuItem(MenuItem menuItem, String parentId) 引数で渡されたノードを新規追加します。
void | AdminMenuAccessor.updateMenuItem(MenuItem menuItem) 引数で渡されたノードを更新します。
void | AdminMenuAccessor.addMenuLoginGroup(String menuId, String groupId) 管理メニューにアクセス権を設定します。
void | AdminMenuAccessor.deleteMenuLoginGroup(String menuId, String groupId) 管理メニューに設定されているアクセス権を削除します。
void | AdminMenuAccessor.setAccessControlEnabled(String menuId, boolean accessControl) メニューアイテムに対するアクセス権を設定します。

jp.co.intra_mart.foundation.security.role での AccessSecurityWriteException の使用

AccessSecurityWriteException をスローする jp.co.intra_mart.foundation.security.role のメソッド
void | RoleAccessor.createRole(String groupId, Role role) ロール情報を新規に追加する。
void | RoleAccessor.deleteCategory(String groupId) すべてのカテゴリを削除する。
void | RoleAccessor.deleteCategory(String groupId, String category) カテゴリを削除する。
void | RoleAccessor.deleteRole(String groupId) すべてのロール情報を削除する。
void | RoleAccessor.deleteRole(String groupId, String roleId) ロール情報を削除する。
void | RoleAccessor.updateCategory(String groupId, String oldCategory, String newCategory) カテゴリを更新する。
void | RoleAccessor.updateRole(String groupId, Role role) ロール情報を更新する。
void | RoleAccessor.insertSubRole(String groupId, String roleId, String subRoleId) サブロールを作成する。
void | RoleAccessor.deleteSubRole(String groupId, String roleId, String subRoleId) サブロールIDサマリを削除する。
void | RoleAccessor.deleteSubRole(String groupId, String roleId) 指定したロールのサブロールIDサマリを全削除する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.ActiveSessionException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.ActiveSessionException の使用

ActiveSessionException を使用しているパッケージ
jp.co.intra_mart.foundation.security.activesession |
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.activesession での ActiveSessionException の使用

ActiveSessionException をスローする jp.co.intra_mart.foundation.security.activesession のメソッド
void | StandardActiveSessionAccessor.init(Node defaultNode, Node node) 設定ファイル conf/active-session-config.xml の情報を基に初期化します。
void | StandardActiveSessionAccessor.addActiveSessionInfo(ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報を登録します。
void | StandardActiveSessionAccessor.removeActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を削除します。
void | StandardActiveSessionAccessor.destory(String groupId) アクティブなセッション情報をすべて破棄します。
void | StandardActiveSessionAccessor.invalidate(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
boolean | StandardActiveSessionAccessor.isValid(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
int | StandardActiveSessionAccessor.count(String groupId) アクティブなすべてのセッション数を取得します。
int | StandardActiveSessionAccessor.count(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなすべてのセッション数を取得します。
int | StandardActiveSessionAccessor.count(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。
boolean | StandardActiveSessionAccessor.exists(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が存在するかどうか取得します。
ActiveSessionInfo[] | StandardActiveSessionAccessor.getActiveSessionInfos(String groupId) アクティブなすべてのセッション情報を取得します。
ActiveSessionInfo | StandardActiveSessionAccessor.getActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を取得します。
ActiveSessionInfo | StandardActiveSessionAccessor.getInvalidatedActiveSessionInfo(String groupId, String sessionId) 無効化されたアクティブなセッション情報を取得します。
ActiveSessionInfo[] | StandardActiveSessionAccessor.getActiveSessionInfos(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | StandardActiveSessionAccessor.getActiveSessionInfos(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | StandardActiveSessionAccessor.searchActiveSessionInfosByUserId(String groupId, String loginType, String userId) 引数で指定されたユーザ条件からアクティブなセッション情報を検索します。
void | StandardActiveSessionAccessor.updateToProcessing(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報を処理中に更新します。
void | StandardActiveSessionAccessor.updateLastResponseTime(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。
void | ActiveSessionManager.addActiveSessionInfo(ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報を登録します。
void | ActiveSessionManager.removeActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を削除します。
void | ActiveSessionManager.destory(String groupId) アクティブなセッション情報をすべて破棄します。
void | ActiveSessionManager.invalidate(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
boolean | ActiveSessionManager.isValid(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
boolean | ActiveSessionManager.isLogined(String groupId, String loginType, String userId) 引数で指定されたユーザがログインしているかどうか判別します。
int | ActiveSessionManager.count(String groupId) アクティブなすべてのセッション数を取得します。
int | ActiveSessionManager.count(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなすべてのセッション数を取得します。
int | ActiveSessionManager.count(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。
ActiveSessionInfo[] | ActiveSessionManager.getActiveSessionInfos(String groupId) アクティブなすべてのセッション情報を取得します。
ActiveSessionInfo | ActiveSessionManager.getActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を取得します。
boolean | ActiveSessionManager.hasActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が存在するかチェックします。
ActiveSessionInfo | ActiveSessionManager.getInvalidatedActiveSessionInfo(String groupId, String sessionId) 無効化されたアクティブなセッション情報を取得します。
ActiveSessionInfo[] | ActiveSessionManager.getActiveSessionInfos(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | ActiveSessionManager.getActiveSessionInfos(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | ActiveSessionManager.searchActiveSessionInfosByUserId(String groupId, String loginType, String userId) 引数で指定されたユーザ条件からアクティブなセッション情報を検索します。
void | ActiveSessionManager.updateToProcessing(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報を処理中に更新します。
void | ActiveSessionManager.updateLastResponseTime(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。
void | ActiveSessionAccessor.init(Node defaultNode, Node node) 設定ファイルの情報を基に初期化します。
void | ActiveSessionAccessor.addActiveSessionInfo(ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報を登録します。
void | ActiveSessionAccessor.removeActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を削除します。
void | ActiveSessionAccessor.destory(String groupId) アクティブなセッション情報をすべて破棄します。
void | ActiveSessionAccessor.invalidate(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
boolean | ActiveSessionAccessor.isValid(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
int | ActiveSessionAccessor.count(String groupId) アクティブなすべてのセッション数を取得します。
int | ActiveSessionAccessor.count(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなすべてのセッション数を取得します。
int | ActiveSessionAccessor.count(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。
boolean | ActiveSessionAccessor.exists(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が存在するかどうか取得します。
ActiveSessionInfo[] | ActiveSessionAccessor.getActiveSessionInfos(String groupId) アクティブなすべてのセッション情報を取得します。
ActiveSessionInfo | ActiveSessionAccessor.getActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を取得します。
ActiveSessionInfo | ActiveSessionAccessor.getInvalidatedActiveSessionInfo(String groupId, String sessionId) 無効化されたアクティブなセッション情報を取得します。
ActiveSessionInfo[] | ActiveSessionAccessor.getActiveSessionInfos(String groupId, String loginType, String userId) 引数で指定されたユーザのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | ActiveSessionAccessor.getActiveSessionInfos(String groupId, String loginType) 引数で指定されたログインタイプのアクティブなセッション情報を取得します。
ActiveSessionInfo[] | ActiveSessionAccessor.searchActiveSessionInfosByUserId(String groupId, String loginType, String userId) 引数で指定されたユーザ条件からアクティブなセッション情報を検索します。
void | ActiveSessionAccessor.updateToProcessing(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報を処理中に更新します。
void | ActiveSessionAccessor.updateLastResponseTime(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。

jp.co.intra_mart.foundation.security.exception での ActiveSessionException の使用

jp.co.intra_mart.foundation.security.exception での ActiveSessionException のサブクラス
class | ActiveSessionInvalidatedByForceException アクティブなセッションが強制的に無効化されたことに関する例外クラス
class | ActiveSessionNotExistException アクティブなセッションが存在しない例外クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.ActiveSessionInvalidatedByForceException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.ActiveSessionInvalidatedByForceException の使用

jp.co.intra_mart.foundation.security.exception.ActiveSessionInvalidatedByForceException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.ActiveSessionNotExistException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.ActiveSessionNotExistException の使用

ActiveSessionNotExistException を使用しているパッケージ
jp.co.intra_mart.foundation.security.activesession

jp.co.intra_mart.foundation.security.activesession での ActiveSessionNotExistException の使用

ActiveSessionNotExistException をスローする jp.co.intra_mart.foundation.security.activesession のメソッド
void | StandardActiveSessionAccessor.removeActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を削除します。
void | StandardActiveSessionAccessor.invalidate(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
boolean | StandardActiveSessionAccessor.isValid(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
ActiveSessionInfo | StandardActiveSessionAccessor.getActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を取得します。
ActiveSessionInfo | StandardActiveSessionAccessor.getInvalidatedActiveSessionInfo(String groupId, String sessionId) 無効化されたアクティブなセッション情報を取得します。
void | StandardActiveSessionAccessor.updateToProcessing(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報を処理中に更新します。
void | StandardActiveSessionAccessor.updateLastResponseTime(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。
void | ActiveSessionManager.removeActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を削除します。
void | ActiveSessionManager.invalidate(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
boolean | ActiveSessionManager.isValid(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
ActiveSessionInfo | ActiveSessionManager.getActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を取得します。
ActiveSessionInfo | ActiveSessionManager.getInvalidatedActiveSessionInfo(String groupId, String sessionId) 無効化されたアクティブなセッション情報を取得します。
void | ActiveSessionManager.updateToProcessing(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報を処理中に更新します。
void | ActiveSessionManager.updateLastResponseTime(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。
void | ActiveSessionAccessor.removeActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を削除します。
void | ActiveSessionAccessor.invalidate(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
boolean | ActiveSessionAccessor.isValid(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
ActiveSessionInfo | ActiveSessionAccessor.getActiveSessionInfo(String groupId, String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を取得します。
ActiveSessionInfo | ActiveSessionAccessor.getInvalidatedActiveSessionInfo(String groupId, String sessionId) 無効化されたアクティブなセッション情報を取得します。
void | ActiveSessionAccessor.updateToProcessing(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報を処理中に更新します。
void | ActiveSessionAccessor.updateLastResponseTime(String groupId, String sessionId) 引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.DuplicateException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.DuplicateException の使用

DuplicateException を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security での DuplicateException の使用

DuplicateException をスローする jp.co.intra_mart.foundation.security のメソッド
void | StandardCalendarAccessor.insertCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に作成します。
void | StandardBatchAccessor.insertBatch(String groupId, Batch batch) バッチを登録します。
void | StandardAccountAccessor.insertAccount(String groupId, Account account) アカウント情報を新規追加する。
void | StandardAccountAccessor.insertAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を新規追加する。
void | StandardAccountAccessor.insertFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を新規追加する。

jp.co.intra_mart.foundation.security.account での DuplicateException の使用

DuplicateException をスローする jp.co.intra_mart.foundation.security.account のメソッド
void | AccountAccessor.insertAccount(String groupId, Account account) アカウント情報を新規追加する。
void | AccountAccessor.insertAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を新規追加する。
void | AccountAccessor.insertFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を新規追加する。

jp.co.intra_mart.foundation.security.admin での DuplicateException の使用

DuplicateException をスローする jp.co.intra_mart.foundation.security.admin のメソッド
 void SuperUserAccessor.insertSuperUser(SuperUser superUser)
システム管理者情報を新規追加します。

jp.co.intra_mart.foundation.security.batch での DuplicateException の使用

DuplicateException をスローする jp.co.intra_mart.foundation.security.batch のメソッド
 void BatchAccessor.insertBatch(String groupId, Batch batch)
バッチ情報を新規に追加します。

jp.co.intra_mart.foundation.security.calendar での DuplicateException の使用

DuplicateException をスローする jp.co.intra_mart.foundation.security.calendar のメソッド
 void CalendarAccessor.insertCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo)
カレンダーデータを新規に作成します。

jp.co.intra_mart.foundation.security.group での DuplicateException の使用

DuplicateException をスローする jp.co.intra_mart.foundation.security.group のメソッド
void | LoginGroupAccessor.insertLoginGroup(LoginGroup loginGroup) ログイングループを新規追加します。
void | LoginGroupAccessor.insertMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを新規追加します。
void | GroupSuperUserAccessor.insertSuperUser(String groupId, SuperUser superUser) グループ管理者情報を新規追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.DuplicateLoginDetectedException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.DuplicateLoginDetectedException の使用

jp.co.intra_mart.foundation.security.exception.DuplicateLoginDetectedException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.DuplicateLoginException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.DuplicateLoginException の使用

DuplicateLoginException を使用しているパッケージ
jp.co.intra_mart.foundation.security.duplication |
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.duplication での DuplicateLoginException の使用

DuplicateLoginException をスローする jp.co.intra_mart.foundation.security.duplication のメソッド
void | StandardDuplicateLoginAccessor.init(Node defaultNode, Node node) 設定ファイル conf/duplicate-login.xml の情報を基に初期化します。
boolean | DuplicateLoginManager.isDuplicateLogined(ActiveSessionInfo activeSessionInfo) 引数で指定されたユーザが重複してログインしているかどうか判別します。
boolean | DuplicateLoginManager.isDuplicateLogined(String loginGroup, String loginType, String userId, String sessionId) 引数で指定されたユーザが重複してログインしているかどうか判別します。
void | DuplicateLoginManager.invalidateOtherSessions(ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報以外のセッション情報をすべて無効にします。
void | DuplicateLoginAccessor.init(Node defaultNode, Node node) 設定ファイルの情報を基に初期化します。

jp.co.intra_mart.foundation.security.exception での DuplicateLoginException の使用

jp.co.intra_mart.foundation.security.exception での DuplicateLoginException のサブクラス
 class DuplicateLoginDetectedException
重複ログイン検出例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.IllegalArgumentException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.IllegalArgumentException の使用

jp.co.intra_mart.foundation.security.exception.IllegalArgumentException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.NoFilterException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.NoFilterException の使用

NoFilterException を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession |

jp.co.intra_mart.foundation.security での NoFilterException の使用

NoFilterException をスローする jp.co.intra_mart.foundation.security のメソッド
int | AccessSecurityManager.forceLogin(LoginRequestInfo loginRequestInfo) 強制ログイン処理を行います。
void | AccessSecurityManager.forward(String url) 指定したURLにフォワードします。
SessionInfo | AccessSecurityManager.getCookieSessionInfo() カレントスレッド情報のクッキーからintra-martセッション情報を取得します。
String | AccessSecurityManager.getErrorPage(int errorCode) カレントスレッド情報からエラーページＵＲＬを取得します。
int | AccessSecurityManager.getInitialCertification(LoginRequestInfo loginInfo) カレントスレッドの情報から初期アクセス処理を行います。
String | AccessSecurityManager.getInitialPage() カレントスレッド情報から初期アクセスページURLを取得します。
String | AccessSecurityManager.getInitialPage(SessionInfo sessionInfo) カレントスレッド情報から初期アクセスページURLを取得します。
int | AccessSecurityManager.getLoginCertification() カレントスレッド情報からログイン処理を行います。
String | AccessSecurityManager.getMainPage() カレントスレッド情報からメインページURLを取得します。
String | AccessSecurityManager.getMainPage(SessionInfo sessionInfo) カレントスレッド情報からメインページURLを取得します。
SessionInfo | AccessSecurityManager.getSessionInfo() カレントスレッド情報からintra-martセッション情報を取得します。
int | AccessSecurityManager.getSessionMode() intra-martセッションの状態を取得します。
int | AccessSecurityManager.login(LoginRequestInfo loginRequestInfo) ログイン処理を行います。
void | AccessSecurityManager.logout() ログアウト処理を行います。
void | AccessSecurityManager.secureRedirect(String url, Map args) 呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。
String | AccessSecurityManager.getMobileUserAgent() モバイル端末の固体識別番号を取得します。

jp.co.intra_mart.foundation.security.activesession での NoFilterException の使用

NoFilterException をスローする jp.co.intra_mart.foundation.security.activesession のコンストラクタ
ActiveSessionInfo(HttpServletRequest request)
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.NoSessionCookieException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.NoSessionCookieException の使用

jp.co.intra_mart.foundation.security.exception.NoSessionCookieException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.NoSessionException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.NoSessionException の使用

jp.co.intra_mart.foundation.security.exception.NoSessionException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.NotExistException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.NotExistException の使用

NotExistException を使用しているパッケージ
jp.co.intra_mart.foundation.database | データベースへアクセスするためのクラスを提供します。
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.database での NotExistException の使用

NotExistException をスローする jp.co.intra_mart.foundation.database のメソッド
Connection | DatabaseManager.getLoginGroupConnection(String groupId) ログイングループIDからコネクションオブジェクトを取得します。
Connection | DatabaseManager.getSystemConnection(String connectId) システム接続名からコネクションオブジェクトを取得します。

jp.co.intra_mart.foundation.security での NotExistException の使用

NotExistException をスローする jp.co.intra_mart.foundation.security のメソッド
void | StandardMenuAccessor.deleteMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を削除します。
void | StandardCalendarAccessor.deleteCalendar(String groupId, String calendarId) カレンダーを削除します。
void | StandardCalendarAccessor.deleteCalendarInfo(String groupId, String calendarId, String dataId) 指定されたカレンダーデータを削除します。
void | StandardCalendarAccessor.updateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。
void | StandardBatchAccessor.deleteBatch(String groupId, String batchId) バッチを削除します。
void | StandardBatchAccessor.updateBatch(String groupId, Batch batch) バッチを更新します。
void | StandardAccountAccessor.deleteAccount(String groupId, String userId) アカウント情報を削除する。
void | StandardAccountAccessor.deleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報を削除する。
void | StandardAccountAccessor.deleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を削除する。
void | StandardAccountAccessor.updateAccount(String groupId, Account account) アカウント情報を更新する。
void | StandardAccountAccessor.updateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を更新する。
void | StandardAccountAccessor.updateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を更新する。
void | StandardAccountAccessor.deleteAttribute(String groupId, String userId, String name) アカウント属性情報を削除する。

jp.co.intra_mart.foundation.security.account での NotExistException の使用

NotExistException をスローする jp.co.intra_mart.foundation.security.account のメソッド
void | AccountAccessor.deleteAccount(String groupId, String userId) アカウント情報を削除する。
void | AccountAccessor.deleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報を削除する。
void | AccountAccessor.deleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を削除する。
void | AccountAccessor.updateAccount(String groupId, Account account) アカウント情報を更新する。
void | AccountAccessor.updateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を更新する。
void | AccountAccessor.updateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を更新する。
void | AccountAccessor.deleteAttribute(String groupId, String userId, String name) アカウント属性情報を削除する。

jp.co.intra_mart.foundation.security.admin での NotExistException の使用

NotExistException をスローする jp.co.intra_mart.foundation.security.admin のメソッド
 void SuperUserAccessor.updateSuperUser(SuperUser superUser)
システム管理者情報を更新します。

jp.co.intra_mart.foundation.security.batch での NotExistException の使用

NotExistException をスローする jp.co.intra_mart.foundation.security.batch のメソッド
void | BatchAccessor.deleteBatch(String groupId, String batchId) バッチ情報を削除します。
void | BatchAccessor.updateBatch(String groupId, Batch batch) バッチ情報を更新します。

jp.co.intra_mart.foundation.security.calendar での NotExistException の使用

NotExistException をスローする jp.co.intra_mart.foundation.security.calendar のメソッド
void | CalendarAccessor.deleteCalendar(String groupId, String calendarId) カレンダーを削除します。
void | CalendarAccessor.deleteCalendarInfo(String groupId, String calendarId, String dataId) 指定されたカレンダーデータを削除します。
void | CalendarAccessor.updateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。

jp.co.intra_mart.foundation.security.group での NotExistException の使用

NotExistException をスローする jp.co.intra_mart.foundation.security.group のメソッド
void | LoginGroupAccessor.deleteLoginGroup(String groupId) ログイングループを削除します。
void | LoginGroupAccessor.deleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを削除します。
void | LoginGroupAccessor.updateLoginGroup(LoginGroup loginGroup) ログイングループを更新します。
void | LoginGroupAccessor.updateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを更新します。
void | GroupSuperUserAccessor.deleteSuperUser(String groupId) グループ管理者情報を削除します。
void | GroupSuperUserAccessor.updateSuperUser(String groupId, SuperUser superUser) グループ管理者情報を更新します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException の使用

jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.NotSupportMethodException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.NotSupportMethodException の使用

jp.co.intra_mart.foundation.security.exception.NotSupportMethodException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.SystemConfigException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.SystemConfigException の使用

jp.co.intra_mart.foundation.security.exception.SystemConfigException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AccessSecurityConfigException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityConfigException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.exception.FoundationRuntimeException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException
                        拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException
すべての実装インタフェース:
Serializable
public class AccessSecurityConfigException
extends AccessSecurityRuntimeException

アクセスセキュリティ設定に関する例外クラス。

アクセスセキュリティ設定が正しく設定されていない場合にスローされる。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
AccessSecurityConfigException()
コンストラクタ。
AccessSecurityConfigException(String message)
コンストラクタ。
AccessSecurityConfigException(String message, Throwable cause)
コンストラクタ。
AccessSecurityConfigException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityConfigException

public AccessSecurityConfigException()
コンストラクタ。

AccessSecurityConfigException

public AccessSecurityConfigException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

AccessSecurityConfigException

public AccessSecurityConfigException(String message,
                                     Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

AccessSecurityConfigException

public AccessSecurityConfigException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityCreateException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityCreateException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
                        拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException
すべての実装インタフェース:
Serializable
public class AccessSecurityCreateException
extends AccessSecurityWriteException

アクセスセキュリティ情報作成例外クラス。

アクセスセキュリティ情報の作成に失敗した場合にスローされます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
AccessSecurityCreateException(String key, String kind)
コンストラクタ。
AccessSecurityCreateException(String key, String kind, String group)
コンストラクタ。
AccessSecurityCreateException(String key, String kind, String group, Throwable cause)
コンストラクタ。
AccessSecurityCreateException(String key, String kind, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityCreateException

public AccessSecurityCreateException(String key,
                                     String kind,
                                     String group)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ

AccessSecurityCreateException

public AccessSecurityCreateException(String key,
                                     String kind)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別

AccessSecurityCreateException

public AccessSecurityCreateException(String key,
                                     String kind,
                                     String group,
                                     Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ
cause - 原因となる例外

AccessSecurityCreateException

public AccessSecurityCreateException(String key,
                                     String kind,
                                     Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityDeleteException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityDeleteException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
                        拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException
すべての実装インタフェース:
Serializable
public class AccessSecurityDeleteException
extends AccessSecurityWriteException

アクセスセキュリティ情報削除例外クラス。

アクセスセキュリティ情報の削除に失敗した場合にスローされます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
AccessSecurityDeleteException(String key, String kind)
コンストラクタ。
AccessSecurityDeleteException(String key, String kind, String group)
コンストラクタ。
AccessSecurityDeleteException(String key, String kind, String group, Throwable cause)
コンストラクタ。
AccessSecurityDeleteException(String key, String kind, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityDeleteException

public AccessSecurityDeleteException(String key,
                                     String kind,
                                     String group)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ

AccessSecurityDeleteException

public AccessSecurityDeleteException(String key,
                                     String kind)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別

AccessSecurityDeleteException

public AccessSecurityDeleteException(String key,
                                     String kind,
                                     String group,
                                     Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ
cause - 原因となる例外

AccessSecurityDeleteException

public AccessSecurityDeleteException(String key,
                                     String kind,
                                     Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccessSecurityExportException, AccessSecurityImportException, AccessSecurityListenerExcpetion, AccessSecurityReadException, AccessSecurityWriteException, ActiveSessionException, DuplicateLoginException, IllegalArgumentException, NoFilterException, NoSessionCookieException, NoSessionException, NotFoundDataSourceException
public class AccessSecurityException
extends FoundationException

アクセスセキュリティの基本となる例外クラス。

アクセスセキュリティで例外が発生した場合にスローされる。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
static String | KIND_ROLE 種別 ロール。
static String | KIND_ROLE_SUB 種別 サブロール(ロール)。
コンストラクタの概要
AccessSecurityException()
コンストラクタ。
AccessSecurityException(String message)
コンストラクタ。
AccessSecurityException(String message, Throwable cause)
コンストラクタ。
AccessSecurityException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

フィールドの詳細

KIND_ROLE

public static final String KIND_ROLE
種別 ロール。

関連項目:
定数フィールド値

KIND_ROLE_SUB

public static final String KIND_ROLE_SUB
種別 サブロール(ロール)。

関連項目:
定数フィールド値
コンストラクタの詳細

AccessSecurityException

public AccessSecurityException()
コンストラクタ。

AccessSecurityException

public AccessSecurityException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

AccessSecurityException

public AccessSecurityException(String message,
                               Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

AccessSecurityException

public AccessSecurityException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityExportException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityExportException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException
すべての実装インタフェース:
Serializable
public class AccessSecurityExportException
extends AccessSecurityException

エクスポート時例外クラス。

エクスポート時に例外が発生した場合にスローする。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
AccessSecurityExportException(String name)
コンストラクタ。
AccessSecurityExportException(String name, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityExportException

public AccessSecurityExportException(String name)
コンストラクタ。

パラメータ:
name - 重複している名称

AccessSecurityExportException

public AccessSecurityExportException(String name,
                                     Throwable cause)
コンストラクタ。

パラメータ:
name - 重複している名称
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityImportException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityImportException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException
すべての実装インタフェース:
Serializable
public class AccessSecurityImportException
extends AccessSecurityException

インポート時例外クラス。

インポート時に例外が発生した場合にスローする。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
AccessSecurityImportException(String name)
コンストラクタ。
AccessSecurityImportException(String name, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityImportException

public AccessSecurityImportException(String name)
コンストラクタ。

パラメータ:
name - 重複している名称

AccessSecurityImportException

public AccessSecurityImportException(String name,
                                     Throwable cause)
コンストラクタ。

パラメータ:
name - 重複している名称
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityListenerExcpetion (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityListenerExcpetion

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion
すべての実装インタフェース:
Serializable
public class AccessSecurityListenerExcpetion
extends AccessSecurityException

アクセスセキュリティリスナーの例外クラス。

アクセスセキュリティリスナー内で例外が発せした場合にスローされます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
AccessSecurityListenerExcpetion()
コンストラクタ。
AccessSecurityListenerExcpetion(String message)
コンストラクタ。
AccessSecurityListenerExcpetion(String message, Throwable cause)
コンストラクタ。
AccessSecurityListenerExcpetion(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityListenerExcpetion

public AccessSecurityListenerExcpetion()
コンストラクタ。

AccessSecurityListenerExcpetion

public AccessSecurityListenerExcpetion(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

AccessSecurityListenerExcpetion

public AccessSecurityListenerExcpetion(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

AccessSecurityListenerExcpetion

public AccessSecurityListenerExcpetion(String message,
                                       Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityReadException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityReadException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException
すべての実装インタフェース:
Serializable
public class AccessSecurityReadException
extends AccessSecurityException

アクセスセキュリティ情報の取得例外クラス。

アクセスセキュリティ情報の取得に失敗した場合にスローされる。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
AccessSecurityReadException(String message)
コンストラクタ。
AccessSecurityReadException(String key, String kind)
コンストラクタ。
AccessSecurityReadException(String key, String kind, String group)
コンストラクタ。
AccessSecurityReadException(String key, String kind, String group, Throwable cause)
コンストラクタ。
AccessSecurityReadException(String key, String kind, Throwable cause)
コンストラクタ。
AccessSecurityReadException(String message, Throwable cause)
コンストラクタ。
AccessSecurityReadException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityReadException

public AccessSecurityReadException(String key,
                                   String kind,
                                   String group)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ

AccessSecurityReadException

public AccessSecurityReadException(String key,
                                   String kind)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別

AccessSecurityReadException

public AccessSecurityReadException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

AccessSecurityReadException

public AccessSecurityReadException(String key,
                                   String kind,
                                   String group,
                                   Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ
cause - 原因となる例外

AccessSecurityReadException

public AccessSecurityReadException(String key,
                                   String kind,
                                   Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
cause - 原因となる例外

AccessSecurityReadException

public AccessSecurityReadException(String message,
                                   Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

AccessSecurityReadException

public AccessSecurityReadException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityRuntimeException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityRuntimeException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.exception.FoundationRuntimeException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccessSecurityConfigException, SystemConfigException
public class AccessSecurityRuntimeException
extends FoundationRuntimeException

アクセスセキュリティランタイム例外クラス。

アクセスセキュリティ設定ファイル群の不備などでシステム運用が続行不可な場合のランタイム例外クラスです。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
AccessSecurityRuntimeException()
コンストラクタ。
AccessSecurityRuntimeException(String message)
コンストラクタ。
AccessSecurityRuntimeException(String message, Throwable cause)
コンストラクタ。
AccessSecurityRuntimeException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityRuntimeException

public AccessSecurityRuntimeException()
コンストラクタ。

AccessSecurityRuntimeException

public AccessSecurityRuntimeException(String message)
コンストラクタ。

パラメータ:
message - メッセージ

AccessSecurityRuntimeException

public AccessSecurityRuntimeException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

AccessSecurityRuntimeException

public AccessSecurityRuntimeException(String message,
                                      Throwable cause)
コンストラクタ。

パラメータ:
message - メッセージ
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityUpdateException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityUpdateException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
                        拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException
すべての実装インタフェース:
Serializable
public class AccessSecurityUpdateException
extends AccessSecurityWriteException

アクセスセキュリティ情報更新例外クラス。

アクセスセキュリティ情報の更新に失敗した場合にスローされます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
AccessSecurityUpdateException(String key, String kind)
コンストラクタ。
AccessSecurityUpdateException(String key, String kind, String group)
コンストラクタ。
AccessSecurityUpdateException(String key, String kind, String group, Throwable cause)
コンストラクタ。
AccessSecurityUpdateException(String key, String kind, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityUpdateException

public AccessSecurityUpdateException(String key,
                                     String kind,
                                     String group)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ

AccessSecurityUpdateException

public AccessSecurityUpdateException(String key,
                                     String kind)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別

AccessSecurityUpdateException

public AccessSecurityUpdateException(String key,
                                     String kind,
                                     String group,
                                     Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ
cause - 原因となる例外

AccessSecurityUpdateException

public AccessSecurityUpdateException(String key,
                                     String kind,
                                     Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityWriteException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityWriteException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccessSecurityCreateException, AccessSecurityDeleteException, AccessSecurityUpdateException, DuplicateException, NotExistException, NotSupportMethodException
public class AccessSecurityWriteException
extends AccessSecurityException

アクセスセキュリティ情報の更新例外クラス。

アクセスセキュリティ情報の更新に失敗した場合にスローされる。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
AccessSecurityWriteException()
コンストラクタ。
AccessSecurityWriteException(String message)
コンストラクタ。
AccessSecurityWriteException(String message, Throwable cause)
コンストラクタ。
AccessSecurityWriteException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityWriteException

public AccessSecurityWriteException()
コンストラクタ。

AccessSecurityWriteException

public AccessSecurityWriteException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

AccessSecurityWriteException

public AccessSecurityWriteException(String message,
                                    Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

AccessSecurityWriteException

public AccessSecurityWriteException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ActiveSessionException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス ActiveSessionException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.ActiveSessionException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ActiveSessionInvalidatedByForceException, ActiveSessionNotExistException
public class ActiveSessionException
extends AccessSecurityException

アクティブなセッション情報例外の基本となる例外クラス。

導入されたバージョン:
6.1
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
ActiveSessionException()
コンストラクタ。
ActiveSessionException(String message)
コンストラクタ。
ActiveSessionException(String message, Throwable cause)
コンストラクタ。
ActiveSessionException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ActiveSessionException

public ActiveSessionException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

ActiveSessionException

public ActiveSessionException(String message,
                              Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

ActiveSessionException

public ActiveSessionException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

ActiveSessionException

public ActiveSessionException()
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ActiveSessionInvalidatedByForceException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス ActiveSessionInvalidatedByForceException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.ActiveSessionException
                        拡張 jp.co.intra_mart.foundation.security.exception.ActiveSessionInvalidatedByForceException
すべての実装インタフェース:
Serializable
public class ActiveSessionInvalidatedByForceException
extends ActiveSessionException

アクティブなセッションが強制的に無効化されたことに関する例外クラス

導入されたバージョン:
6.1
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
ActiveSessionInvalidatedByForceException()
コンストラクタ。
ActiveSessionInvalidatedByForceException(String message)
コンストラクタ。
ActiveSessionInvalidatedByForceException(String message, Throwable cause)
コンストラクタ。
ActiveSessionInvalidatedByForceException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ActiveSessionInvalidatedByForceException

public ActiveSessionInvalidatedByForceException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

ActiveSessionInvalidatedByForceException

public ActiveSessionInvalidatedByForceException(String message,
                                                Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

ActiveSessionInvalidatedByForceException

public ActiveSessionInvalidatedByForceException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

ActiveSessionInvalidatedByForceException

public ActiveSessionInvalidatedByForceException()
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ActiveSessionNotExistException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス ActiveSessionNotExistException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.ActiveSessionException
                        拡張 jp.co.intra_mart.foundation.security.exception.ActiveSessionNotExistException
すべての実装インタフェース:
Serializable
public class ActiveSessionNotExistException
extends ActiveSessionException

アクティブなセッションが存在しない例外クラス。

導入されたバージョン:
6.1
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
ActiveSessionNotExistException()
コンストラクタ。
ActiveSessionNotExistException(String message)
コンストラクタ。
ActiveSessionNotExistException(String message, Throwable cause)
コンストラクタ。
ActiveSessionNotExistException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ActiveSessionNotExistException

public ActiveSessionNotExistException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

ActiveSessionNotExistException

public ActiveSessionNotExistException(String message,
                                      Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

ActiveSessionNotExistException

public ActiveSessionNotExistException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

ActiveSessionNotExistException

public ActiveSessionNotExistException()
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DuplicateException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス DuplicateException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
                        拡張 jp.co.intra_mart.foundation.security.exception.DuplicateException
すべての実装インタフェース:
Serializable
public class DuplicateException
extends AccessSecurityWriteException

作成時重複例外クラス。

アクセスセキュリティ情報を新規作成する場合に重複が起こった場合にスローする。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
DuplicateException(String key, String kind)
コンストラクタ。
DuplicateException(String key, String kind, String group)
コンストラクタ。
DuplicateException(String key, String kind, String group, Throwable cause)
コンストラクタ。
DuplicateException(String key, String kind, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DuplicateException

public DuplicateException(String key,
                          String kind,
                          String group)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ

DuplicateException

public DuplicateException(String key,
                          String kind)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別

DuplicateException

public DuplicateException(String key,
                          String kind,
                          String group,
                          Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ
cause - 原因となる例外

DuplicateException

public DuplicateException(String key,
                          String kind,
                          Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DuplicateLoginDetectedException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス DuplicateLoginDetectedException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.DuplicateLoginException
                        拡張 jp.co.intra_mart.foundation.security.exception.DuplicateLoginDetectedException
すべての実装インタフェース:
Serializable
public class DuplicateLoginDetectedException
extends DuplicateLoginException

重複ログイン検出例外クラス

導入されたバージョン:
6.1
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
DuplicateLoginDetectedException()
コンストラクタ。
DuplicateLoginDetectedException(String message)
コンストラクタ。
DuplicateLoginDetectedException(String message, Throwable cause)
コンストラクタ。
DuplicateLoginDetectedException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DuplicateLoginDetectedException

public DuplicateLoginDetectedException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

DuplicateLoginDetectedException

public DuplicateLoginDetectedException(String message,
                                       Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

DuplicateLoginDetectedException

public DuplicateLoginDetectedException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

DuplicateLoginDetectedException

public DuplicateLoginDetectedException()
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DuplicateLoginException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス DuplicateLoginException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.DuplicateLoginException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
DuplicateLoginDetectedException
public class DuplicateLoginException
extends AccessSecurityException

重複ログイン制御例外の基本となる例外クラス。

導入されたバージョン:
6.1
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
DuplicateLoginException()
コンストラクタ。
DuplicateLoginException(String message)
コンストラクタ。
DuplicateLoginException(String message, Throwable cause)
コンストラクタ。
DuplicateLoginException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DuplicateLoginException

public DuplicateLoginException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

DuplicateLoginException

public DuplicateLoginException(String message,
                               Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

DuplicateLoginException

public DuplicateLoginException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

DuplicateLoginException

public DuplicateLoginException()
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IllegalArgumentException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス IllegalArgumentException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.IllegalArgumentException
すべての実装インタフェース:
Serializable
public class IllegalArgumentException
extends AccessSecurityException

引数が不正の例外クラス。

引数が不正であった場合にスローされます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
IllegalArgumentException(String argName, String function)
コンストラクタ。
IllegalArgumentException(String argName, String function, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalArgumentException

public IllegalArgumentException(String argName,
                                String function)
コンストラクタ。

パラメータ:
argName - 不正な引数名

IllegalArgumentException

public IllegalArgumentException(String argName,
                                String function,
                                Throwable cause)
コンストラクタ。

パラメータ:
argName - 不正な引数名
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NoFilterException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス NoFilterException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.NoFilterException
すべての実装インタフェース:
Serializable
public class NoFilterException
extends AccessSecurityException

HTTPリクエスト・レスポンス取得例外クラス。

HTTPリクエスト・レスポンス情報が取得できなかった場合の例外。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
NoFilterException()
コンストラクタ。
NoFilterException(String message)
コンストラクタ。
NoFilterException(String message, Throwable cause)
コンストラクタ。
NoFilterException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NoFilterException

public NoFilterException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

NoFilterException

public NoFilterException(String message,
                         Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

NoFilterException

public NoFilterException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

NoFilterException

public NoFilterException()
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NoSessionCookieException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス NoSessionCookieException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.NoSessionCookieException
すべての実装インタフェース:
Serializable
public class NoSessionCookieException
extends AccessSecurityException

セッション情報クッキー取得例外クラス。

セッション情報クッキーが取得できなかった場合の例外。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
NoSessionCookieException(String cookieName)
コンストラクタ。
NoSessionCookieException(String cookieName, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NoSessionCookieException

public NoSessionCookieException(String cookieName,
                                Throwable cause)
コンストラクタ。

パラメータ:
cookieName - 存在しなかったクッキー名
cause - 原因となる例外

NoSessionCookieException

public NoSessionCookieException(String cookieName)
コンストラクタ。

パラメータ:
cookieName - 存在しなかったクッキー名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NoSessionException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス NoSessionException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.NoSessionException
すべての実装インタフェース:
Serializable
public class NoSessionException
extends AccessSecurityException

セッション取得例外クラス。

セッション情報が取得できなかった場合の例外。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
NoSessionException()
コンストラクタ。
NoSessionException(String message)
コンストラクタ。
NoSessionException(String message, Throwable cause)
コンストラクタ。
NoSessionException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NoSessionException

public NoSessionException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

NoSessionException

public NoSessionException(String message,
                          Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

NoSessionException

public NoSessionException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

NoSessionException

public NoSessionException()
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NotExistException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス NotExistException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
                        拡張 jp.co.intra_mart.foundation.security.exception.NotExistException
すべての実装インタフェース:
Serializable
public class NotExistException
extends AccessSecurityWriteException

アクセスセキュリティ情報が存在しなかった場合の例外クラス。

アクセスセキュリティ情報が存在しなかった場合にスローする。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
NotExistException(String key, String kind)
コンストラクタ。
NotExistException(String key, String kind, String group)
コンストラクタ。
NotExistException(String key, String kind, String group, Throwable cause)
コンストラクタ。
NotExistException(String key, String kind, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NotExistException

public NotExistException(String key,
                         String kind,
                         String group)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ

NotExistException

public NotExistException(String key,
                         String kind)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別

NotExistException

public NotExistException(String key,
                         String kind,
                         String group,
                         Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ
cause - 原因となる例外

NotExistException

public NotExistException(String key,
                         String kind,
                         Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NotFoundDataSourceException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス NotFoundDataSourceException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException
すべての実装インタフェース:
Serializable
public class NotFoundDataSourceException
extends AccessSecurityException

データソースの参照名未解決例外クラス。

ログイングループおよび接続名に紐付いたデータソース参照名が見つからなかった場合にスローする。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
NotFoundDataSourceException(String name, String type)
コンストラクタ。
NotFoundDataSourceException(String name, String type, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NotFoundDataSourceException

public NotFoundDataSourceException(String name,
                                   String type)
コンストラクタ。

パラメータ:
name - 見つからなかったログイングループまたは接続名
type - 接続種別

NotFoundDataSourceException

public NotFoundDataSourceException(String name,
                                   String type,
                                   Throwable cause)
コンストラクタ。

パラメータ:
name - 見つからなかったログイングループまたは接続名
type - 接続種別
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NotSupportMethodException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス NotSupportMethodException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
                        拡張 jp.co.intra_mart.foundation.security.exception.NotSupportMethodException
すべての実装インタフェース:
Serializable
public class NotSupportMethodException
extends AccessSecurityWriteException

アクセスセキュリティのマネージャでサポートされないメソッドがコールされた場合の例外クラス。

アクセスセキュリティのマネージャでサポートされないメソッドがコールされた場合にスローする。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
NotSupportMethodException()
コンストラクタ。
NotSupportMethodException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NotSupportMethodException

public NotSupportMethodException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

NotSupportMethodException

public NotSupportMethodException()
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.exception (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.security.exception
例外
AccessSecurityConfigException
AccessSecurityCreateException
AccessSecurityDeleteException
AccessSecurityException
AccessSecurityExportException
AccessSecurityImportException
AccessSecurityListenerExcpetion
AccessSecurityReadException
AccessSecurityRuntimeException
AccessSecurityUpdateException
AccessSecurityWriteException
ActiveSessionException
ActiveSessionInvalidatedByForceException
ActiveSessionNotExistException
DuplicateException
DuplicateLoginDetectedException
DuplicateLoginException
IllegalArgumentException
NoFilterException
NoSessionCookieException
NoSessionException
NotExistException
NotFoundDataSourceException
NotSupportMethodException
SystemConfigException


jp.co.intra_mart.foundation.security.exception (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.exception

アクセスセキュリティ例外に関連するクラスを提供します。

参照:
説明

例外の概要
AccessSecurityConfigException | アクセスセキュリティ設定に関する例外クラス。
AccessSecurityCreateException | アクセスセキュリティ情報作成例外クラス。
AccessSecurityDeleteException | アクセスセキュリティ情報削除例外クラス。
AccessSecurityException | アクセスセキュリティの基本となる例外クラス。
AccessSecurityExportException | エクスポート時例外クラス。
AccessSecurityImportException | インポート時例外クラス。
AccessSecurityListenerExcpetion | アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException | アクセスセキュリティ情報の取得例外クラス。
AccessSecurityRuntimeException | アクセスセキュリティランタイム例外クラス。
AccessSecurityUpdateException | アクセスセキュリティ情報更新例外クラス。
AccessSecurityWriteException | アクセスセキュリティ情報の更新例外クラス。
ActiveSessionException | アクティブなセッション情報例外の基本となる例外クラス。
ActiveSessionInvalidatedByForceException | アクティブなセッションが強制的に無効化されたことに関する例外クラス
ActiveSessionNotExistException | アクティブなセッションが存在しない例外クラス。
DuplicateException | 作成時重複例外クラス。
DuplicateLoginDetectedException | 重複ログイン検出例外クラス
DuplicateLoginException | 重複ログイン制御例外の基本となる例外クラス。
IllegalArgumentException | 引数が不正の例外クラス。
NoFilterException | HTTPリクエスト・レスポンス取得例外クラス。
NoSessionCookieException | セッション情報クッキー取得例外クラス。
NoSessionException | セッション取得例外クラス。
NotExistException | アクセスセキュリティ情報が存在しなかった場合の例外クラス。
NotFoundDataSourceException | データソースの参照名未解決例外クラス。
NotSupportMethodException | アクセスセキュリティのマネージャでサポートされないメソッドがコールされた場合の例外クラス。
SystemConfigException | システム設定に関する例外クラス。

パッケージ jp.co.intra_mart.foundation.security.exception の説明

アクセスセキュリティ例外に関連するクラスを提供します。


jp.co.intra_mart.foundation.security.exception クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.exception.FoundationException
          • class jp.co.intra_mart.foundation.security.exception.AccessSecurityException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException
              • class jp.co.intra_mart.foundation.security.exception.DuplicateException
              • class jp.co.intra_mart.foundation.security.exception.NotExistException
              • class jp.co.intra_mart.foundation.security.exception.NotSupportMethodException
            • class jp.co.intra_mart.foundation.security.exception.ActiveSessionException
              • class jp.co.intra_mart.foundation.security.exception.ActiveSessionInvalidatedByForceException
              • class jp.co.intra_mart.foundation.security.exception.ActiveSessionNotExistException
            • class jp.co.intra_mart.foundation.security.exception.DuplicateLoginException
              • class jp.co.intra_mart.foundation.security.exception.DuplicateLoginDetectedException
            • class jp.co.intra_mart.foundation.security.exception.IllegalArgumentException
            • class jp.co.intra_mart.foundation.security.exception.NoFilterException
            • class jp.co.intra_mart.foundation.security.exception.NoSessionCookieException
            • class jp.co.intra_mart.foundation.security.exception.NoSessionException
            • class jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.exception.FoundationRuntimeException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException
              • class jp.co.intra_mart.foundation.security.exception.SystemConfigException


パッケージ jp.co.intra_mart.foundation.security.exception の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.exception の使用

jp.co.intra_mart.foundation.security.exception を使用しているパッケージ
jp.co.intra_mart.foundation.database | データベースへアクセスするためのクラスを提供します。
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession |
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.duplication |
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.license | ライセンスに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.message | メッセージに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.mobile |
jp.co.intra_mart.foundation.security.permission | 権限に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.shortcut |

jp.co.intra_mart.foundation.database により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
NotExistException
アクセスセキュリティ情報が存在しなかった場合の例外クラス。

jp.co.intra_mart.foundation.navigator により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。

jp.co.intra_mart.foundation.security により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityReadException
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。
DuplicateException
作成時重複例外クラス。
NoFilterException
HTTPリクエスト・レスポンス取得例外クラス。
NotExistException
アクセスセキュリティ情報が存在しなかった場合の例外クラス。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityExportException
エクスポート時例外クラス。
AccessSecurityImportException
インポート時例外クラス。
AccessSecurityListenerExcpetion
アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。

jp.co.intra_mart.foundation.security.account により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityExportException
エクスポート時例外クラス。
AccessSecurityImportException
インポート時例外クラス。
AccessSecurityListenerExcpetion
アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。
DuplicateException
作成時重複例外クラス。
NotExistException
アクセスセキュリティ情報が存在しなかった場合の例外クラス。

jp.co.intra_mart.foundation.security.activesession により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
ActiveSessionException
アクティブなセッション情報例外の基本となる例外クラス。
ActiveSessionNotExistException
アクティブなセッションが存在しない例外クラス。
NoFilterException
HTTPリクエスト・レスポンス取得例外クラス。

jp.co.intra_mart.foundation.security.admin により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityListenerExcpetion
アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。
DuplicateException
作成時重複例外クラス。
NotExistException
アクセスセキュリティ情報が存在しなかった場合の例外クラス。

jp.co.intra_mart.foundation.security.batch により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityExportException
エクスポート時例外クラス。
AccessSecurityImportException
インポート時例外クラス。
AccessSecurityListenerExcpetion
アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。
DuplicateException
作成時重複例外クラス。
NotExistException
アクセスセキュリティ情報が存在しなかった場合の例外クラス。

jp.co.intra_mart.foundation.security.calendar により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityExportException
エクスポート時例外クラス。
AccessSecurityImportException
インポート時例外クラス。
AccessSecurityListenerExcpetion
アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。
DuplicateException
作成時重複例外クラス。
NotExistException
アクセスセキュリティ情報が存在しなかった場合の例外クラス。

jp.co.intra_mart.foundation.security.duplication により使用される jp.co.intra_mart.foundation.security.exception のクラス
DuplicateLoginException
重複ログイン制御例外の基本となる例外クラス。

jp.co.intra_mart.foundation.security.exception により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityRuntimeException
アクセスセキュリティランタイム例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。
ActiveSessionException
アクティブなセッション情報例外の基本となる例外クラス。
DuplicateLoginException
重複ログイン制御例外の基本となる例外クラス。

jp.co.intra_mart.foundation.security.group により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityListenerExcpetion
アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。
DuplicateException
作成時重複例外クラス。
NotExistException
アクセスセキュリティ情報が存在しなかった場合の例外クラス。

jp.co.intra_mart.foundation.security.license により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityExportException
エクスポート時例外クラス。
AccessSecurityImportException
インポート時例外クラス。
AccessSecurityListenerExcpetion
アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。

jp.co.intra_mart.foundation.security.message により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。

jp.co.intra_mart.foundation.security.mobile により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityConfigException
アクセスセキュリティ設定に関する例外クラス。
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityListenerExcpetion
アクセスセキュリティリスナーの例外クラス。

jp.co.intra_mart.foundation.security.permission により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。

jp.co.intra_mart.foundation.security.role により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityExportException
エクスポート時例外クラス。
AccessSecurityImportException
インポート時例外クラス。
AccessSecurityListenerExcpetion
アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。

jp.co.intra_mart.foundation.security.shortcut により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SystemConfigException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス SystemConfigException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.exception.FoundationRuntimeException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException
                        拡張 jp.co.intra_mart.foundation.security.exception.SystemConfigException
すべての実装インタフェース:
Serializable
public class SystemConfigException
extends AccessSecurityRuntimeException

システム設定に関する例外クラス。

システム設定が正しく設定されていない場合にスローされる。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SystemConfigException()
コンストラクタ。
SystemConfigException(String message)
コンストラクタ。
SystemConfigException(String message, Throwable cause)
コンストラクタ。
SystemConfigException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SystemConfigException

public SystemConfigException()
コンストラクタ。

SystemConfigException

public SystemConfigException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

SystemConfigException

public SystemConfigException(String message,
                             Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

SystemConfigException

public SystemConfigException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.filter.ActiveSessionFilter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.filter.ActiveSessionFilter の使用

jp.co.intra_mart.foundation.security.filter.ActiveSessionFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.filter.DuplicateLoginHandlingFilter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.filter.DuplicateLoginHandlingFilter の使用

jp.co.intra_mart.foundation.security.filter.DuplicateLoginHandlingFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter の使用

jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter の使用

jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter の使用

jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.filter.SessionFilter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.filter.SessionFilter の使用

jp.co.intra_mart.foundation.security.filter.SessionFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.filter.URLAccessFilter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.filter.URLAccessFilter の使用

jp.co.intra_mart.foundation.security.filter.URLAccessFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ActiveSessionFilter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.filter
クラス ActiveSessionFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.foundation.security.filter.ActiveSessionFilter
すべての実装インタフェース:
Filter
public class ActiveSessionFilter
extends jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter

アクティブセッションフィルタ。

無効にされたアクティブセッションを検出するためのフィルターです。
アクティブセッションとは、フィルターSessionFilterによって有効であると判断されたセッションのことを表します。
注意
このフィルターは必ず SessionFilter が設定された各サーブレットの最後に設定してください。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
ActiveSessionFilter()
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタを実行します。
protected void | handleInit() 初期化します。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ActiveSessionFilter

public ActiveSessionFilter()
メソッドの詳細

handleInit

protected void handleInit()
                   throws ServletException
初期化します。

例外:
ServletException - サーブレットでエラーが発生した場合スローします。
関連項目:
Filter.init(javax.servlet.FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタを実行します。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
chain - フィルタチェーン
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException
関連項目:
Filter.doFilter(javax.servlet.ServletRequest, javax.servlet.ServletResponse, javax.servlet.FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DuplicateLoginHandlingFilter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.filter
クラス DuplicateLoginHandlingFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.foundation.security.filter.DuplicateLoginHandlingFilter
すべての実装インタフェース:
Filter
public class DuplicateLoginHandlingFilter
extends jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter

重複ログインハンドリングフィルタ。

重複ログインをハンドリングするためのフィルターです。

注意
このフィルターは必ず ActiveSessionFilter が設定された各サーブレットの最後に設定してください。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
DuplicateLoginHandlingFilter()
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタを実行します。
protected void | handleInit() 初期化します。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DuplicateLoginHandlingFilter

public DuplicateLoginHandlingFilter()
メソッドの詳細

handleInit

protected void handleInit()
                   throws ServletException
初期化します。

例外:
ServletException - サーブレットでエラーが発生した場合スローします。
関連項目:
Filter.init(javax.servlet.FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタを実行します。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
chain - フィルタチェーン
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException
関連項目:
Filter.doFilter(javax.servlet.ServletRequest, javax.servlet.ServletResponse, javax.servlet.FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InitialPageSessionHandlingFilter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.filter
クラス InitialPageSessionHandlingFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter
すべての実装インタフェース:
Filter
public class InitialPageSessionHandlingFilter
extends jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter

ログインしている状態にログイン画面を表示しようとした際に警告ページを表示するためのフィルタ。

ログインしている状態とは「ログインページ表示要求のリクエストにセッション(HttpSession)が存在し、 そのセッションがintra-martのアクセスセキュリティ上のセッションモード(AccessSecurityManager.getSessionMode())が ログイン状態(SecurityConstraint.CR_SESSION_LOGON)の場合」

このフィルタを利用することで、たとえば以下のことが行える。

  • タブブラウザで任意のタブAでintra-martにログイン後、任意のタブBでintra-martにログインするためにログイン画面を表示しようとすると指定した警告ページを表示できる。
    これは、クッキー内にタブAのセッションID(クッキー名：jsessionid)が保管されており、そのセッションIDのHttpSessionの有効な期間まで、またはブラウザのプロセスが終了されるまで残っているためであり、 クッキーからそのセッションIDが消えればログイン画面は表示される。

パラメータ：
パラメータ名 | 説明
enable | このフィルターを利用する場合 true を指定。無効にする場合は false を指定。 ※上記以外の値が設定された場合は本フィルターは無効になります。
warning-page-path | フォワード先の警告ページ画面のURLを指定してください ※例： system/security/error/request_session_already_logon_error.jssp

このフィルタは以下のサーブレットに対して使用されることを想定しています。
  • UserInitialServlet
  • GroupSuperUserInitialServlet
  • SuperUserInitialServlet
上記のサーブレットに使用する場合、そのサーブレットのフィルターマッピングの設定の最後に追加設定してください。

【使用例】 UserInitialServlet に本フィルターを設定する例
   <filter>
       <filter-name>InitialPageSessionHandlingFilter</filter-name>
       <filter-class>jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter</filter-class>
       <init-param>
           <param-name>enable</param-name>
           <param-value>true</param-value>
       </init-param>
       <init-param>
           <param-name>warning-page-path</param-name>
           <param-value>system/security/error/request_session_already_logon_error.jssp</param-value>
       </init-param>
   </filter>

       : (省略)

   <filter-mapping>
       <filter-name>InitialPageSessionHandlingFilter</filter-name>
        <servlet-name>UserInitialServlet</servlet-name>
   </filter-mapping>

導入されたバージョン:
6.1.7

フィールドの概要
static String DEFAULT_ATTR_REQUESTED_PAGE
遷移先の警告ページにリクエストURLを渡すために利用するリクエスト属性名のデフォルト名
コンストラクタの概要
InitialPageSessionHandlingFilter()
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタを実行します。
protected void | handleInit() 初期化します。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_ATTR_REQUESTED_PAGE

public static final String DEFAULT_ATTR_REQUESTED_PAGE
遷移先の警告ページにリクエストURLを渡すために利用するリクエスト属性名のデフォルト名

関連項目:
定数フィールド値
コンストラクタの詳細

InitialPageSessionHandlingFilter

public InitialPageSessionHandlingFilter()
メソッドの詳細

handleInit

protected void handleInit()
                   throws ServletException
初期化します。

例外:
ServletException - サーブレットでエラーが発生した場合スローします。
関連項目:
Filter.init(javax.servlet.FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタを実行します。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
chain - フィルタチェーン
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException
関連項目:
Filter.doFilter(javax.servlet.ServletRequest, javax.servlet.ServletResponse, javax.servlet.FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.filter (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.security.filter
クラス
ActiveSessionFilter
DuplicateLoginHandlingFilter
InitialPageSessionHandlingFilter
RequestCharacterEncodingFilter
ResponseCharacterEncodingFilter
SessionFilter
URLAccessFilter


jp.co.intra_mart.foundation.security.filter (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.filter

アクセスセキュリティのフィルタに関連するクラスを提供します。

参照:
説明

クラスの概要
ActiveSessionFilter | アクティブセッションフィルタ。
DuplicateLoginHandlingFilter | 重複ログインハンドリングフィルタ。
InitialPageSessionHandlingFilter | ログインしている状態にログイン画面を表示しようとした際に警告ページを表示するためのフィルタ。
RequestCharacterEncodingFilter | リクエストに対するエンコードは SessionInfo.getEncoding()が 返す値をになります。
ResponseCharacterEncodingFilter | レスポンスの文字エンコーディングを自動解決するフィルタです。
SessionFilter | セッションフィルタ。
URLAccessFilter | URLアクセスフィルタ。

パッケージ jp.co.intra_mart.foundation.security.filter の説明

アクセスセキュリティのフィルタに関連するクラスを提供します。


jp.co.intra_mart.foundation.security.filter クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.filter の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter (implements javax.servlet.Filter)
      • class jp.co.intra_mart.foundation.security.filter.ActiveSessionFilter
      • class jp.co.intra_mart.foundation.security.filter.DuplicateLoginHandlingFilter
      • class jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter
      • class jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter
      • class jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter
    • class jp.co.intra_mart.foundation.security.filter.SessionFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.foundation.security.filter.URLAccessFilter (implements javax.servlet.Filter)


パッケージ jp.co.intra_mart.foundation.security.filter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.filter の使用

jp.co.intra_mart.foundation.security.filter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


RequestCharacterEncodingFilter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.filter
クラス RequestCharacterEncodingFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter
すべての実装インタフェース:
Filter
public class RequestCharacterEncodingFilter
extends jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter

リクエストに対するエンコードは SessionInfo.getEncoding()が 返す値をになります。 リクエストの文字エンコーディングは、 ServletRequest.setCharacterEncoding(java.lang.String) によってセットされます。
ここでSessionInfo.getEncoding() を取得できなかった場合エンコードの設定はしないで次の処理に遷移します。

バージョン:
1.0

コンストラクタの概要
RequestCharacterEncodingFilter()
メソッドの概要
 void doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain)
リクエストの文字エンコードをアクセスセキュリティ情報を基にエンコーディングを設定して、 次のフィルタチェーンを実行します。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, handleInit, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RequestCharacterEncodingFilter

public RequestCharacterEncodingFilter()
メソッドの詳細

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws ServletException,
                     IOException
リクエストの文字エンコードをアクセスセキュリティ情報を基にエンコーディングを設定して、 次のフィルタチェーンを実行します。

パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ResponseCharacterEncodingFilter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.filter
クラス ResponseCharacterEncodingFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter
すべての実装インタフェース:
Filter
public class ResponseCharacterEncodingFilter
extends jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter

レスポンスの文字エンコーディングを自動解決するフィルタです。

レスポンスに対するエンコードは SessionInfo.getEncoding()が 返す値をになります。 レスポンスの文字エンコーディングは、Content-Type 設定と共に ServletResponse.setContentType(java.lang.String) によってセットされます。

このフィルタでは、ServletResponse をラップします。 ラップされた ServletResponse に対して #setContentType(String) を 明示的に実行した場合、自動的に Content-Type を書き換えません。 このフィルタ動作によって Content-Type が自動的にセットされるのは、 ラップされた ServletResponse の #setContentType(String) が実行されていない 状態で、ServletResponse の #getOutputStream() または #getWriter() が 呼び出された場合に限られます。

このフィルタに設定可能な初期化パラメータは以下のとおりです。

mime このフィルタがContent-Typeを自動的にセットする時の MIME タイプ。標準は text/html です。

バージョン:
1.0

コンストラクタの概要
ResponseCharacterEncodingFilter()
新しくフィルタを作成します。
メソッドの概要
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) レスポンスソースの文字エンコードをアクセスセキュリティ情報を基にして 自動解決する HttpServletResponse を作成して、 次のフィルタチェーンを実行します。
void | handleInit() このフィルタを初期化します。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ResponseCharacterEncodingFilter

public ResponseCharacterEncodingFilter()
新しくフィルタを作成します。

メソッドの詳細

handleInit

public void handleInit()
このフィルタを初期化します。

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws ServletException,
                     IOException
レスポンスソースの文字エンコードをアクセスセキュリティ情報を基にして 自動解決する HttpServletResponse を作成して、 次のフィルタチェーンを実行します。

このメソッドが作る HttpServletResponse は、引数 response をラップし、 #getWriter() メソッドが実行された時に #setContentType() を一度も 呼び出されていない場合、アクセスセキュリティＡＰＩを通して、 現在のセッションで有効な文字エンコーディングを自動解決し、 Content-Type をセットしてから、引数 response の #getWriter() メソッドを 呼び出します。

パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionFilter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.filter
クラス SessionFilter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.filter.SessionFilter
すべての実装インタフェース:
Filter
public class SessionFilter
extends Object
implements Filter

セッションフィルタ。

セッション情報の状況をチェックします。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String SESSION_TIMEOUT_HEADER_KEY
セッションタイムアウトレスポンスヘッダーキー。
コンストラクタの概要
SessionFilter()
メソッドの概要
void | destroy() 破棄します。
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタを実行します。
void | init(FilterConfig config) 初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

SESSION_TIMEOUT_HEADER_KEY

public static final String SESSION_TIMEOUT_HEADER_KEY
セッションタイムアウトレスポンスヘッダーキー。

セッションタイムアウトが発生した場合
レスポンスヘッダに、このキーを設定します。

関連項目:
定数フィールド値
コンストラクタの詳細

SessionFilter

public SessionFilter()
メソッドの詳細

init

public void init(FilterConfig config)
          throws ServletException
初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
config - フィルタコンフィグ
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
関連項目:
Filter.init(javax.servlet.FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタを実行します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
chain - フィルタチェーン
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException
関連項目:
Filter.doFilter(javax.servlet.ServletRequest, javax.servlet.ServletResponse, javax.servlet.FilterChain)

destroy

public void destroy()
破棄します。

定義:
インタフェース Filter 内の destroy
関連項目:
Filter.destroy()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


URLAccessFilter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.filter
クラス URLAccessFilter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.filter.URLAccessFilter
すべての実装インタフェース:
Filter
public class URLAccessFilter
extends Object
implements Filter

URLアクセスフィルタ。

初期パラメータで設定されたＵＲＬでフィルタを行います。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
URLAccessFilter()
メソッドの概要
void | destroy() 破棄します。
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタを実行します。
void | init(FilterConfig config) 初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLAccessFilter

public URLAccessFilter()
メソッドの詳細

init

public void init(FilterConfig config)
          throws ServletException
初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
config - フィルタコンフィグ
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
関連項目:
Filter.init(javax.servlet.FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタを実行します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
chain - フィルタチェーン
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException
関連項目:
Filter.doFilter(javax.servlet.ServletRequest, javax.servlet.ServletResponse, javax.servlet.FilterChain)

destroy

public void destroy()
破棄します。

定義:
インタフェース Filter 内の destroy
関連項目:
Filter.destroy()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor の使用

jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener の使用

jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener の使用

jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator の使用

jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.group.LoginGroup の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.group.LoginGroup の使用

LoginGroup を使用しているパッケージ
jp.co.intra_mart.foundation.security.group グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.group での LoginGroup の使用

LoginGroup を返す jp.co.intra_mart.foundation.security.group のメソッド
LoginGroup | LoginGroupReaderDecorator.doDecoration(LoginGroup loginGroup) ログイングループをデータストアからの読み込み直後にコールされます。
LoginGroup | LoginGroupManager.getLoginGroup(String groupId) ログイングループ情報を取得します。
LoginGroup[] | LoginGroupManager.getLoginGroups() ログイングループの一覧を取得します。
LoginGroup | LoginGroupAccessor.getLoginGroup(String groupId) ログイングループ情報を取得します。

LoginGroup 型のパラメータを持つ jp.co.intra_mart.foundation.security.group のメソッド
void | MainPageImportLoginGroupPostWriterListener.postCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成した直後にコールされます。
void | MainPageImportLoginGroupPostWriterListener.postUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新した直後にコールされます。
LoginGroup | LoginGroupReaderDecorator.doDecoration(LoginGroup loginGroup) ログイングループをデータストアからの読み込み直後にコールされます。
void | LoginGroupQueryWriterListener.queryCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成する直前にコールされます。
void | LoginGroupQueryWriterListener.queryUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新する直前にコールされます。
void | LoginGroupPostWriterListener.postCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成した直後にコールされます。
void | LoginGroupPostWriterListener.postUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新した直後にコールされます。
void | LoginGroupManager.addLoginGroup(LoginGroup loginGroup) ログイングループを新規追加します。
void | LoginGroupManager.updateLoginGroup(LoginGroup loginGroup) ログイングループ情報を更新します。
void | LoginGroupAccessor.insertLoginGroup(LoginGroup loginGroup) ログイングループを新規追加します。
void | LoginGroupAccessor.updateLoginGroup(LoginGroup loginGroup) ログイングループを更新します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.group.LoginGroupAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.group.LoginGroupAccessor の使用

jp.co.intra_mart.foundation.security.group.LoginGroupAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.group.LoginGroupManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.group.LoginGroupManager の使用

LoginGroupManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.group グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.group での LoginGroupManager の使用

LoginGroupManager を返す jp.co.intra_mart.foundation.security.group のメソッド
static LoginGroupManager LoginGroupManager.getInstance()
ログイングループマネージャのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener の使用

LoginGroupPostWriterListener を使用しているパッケージ
jp.co.intra_mart.foundation.security.group グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.group での LoginGroupPostWriterListener の使用

LoginGroupPostWriterListener を実装している jp.co.intra_mart.foundation.security.group のクラス
 class MainPageImportLoginGroupPostWriterListener
ログイングループ作成時にメインページパターンを設定するリスナークラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener の使用

jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator の使用

jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener の使用

jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.group.MainPagePatternInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.group.MainPagePatternInfo の使用

MainPagePatternInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security.group グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.group での MainPagePatternInfo の使用

MainPagePatternInfo を返す jp.co.intra_mart.foundation.security.group のメソッド
MainPagePatternInfo | LoginGroupManager.getMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを取得します。
MainPagePatternInfo[] | LoginGroupManager.getMainPagePatterns(String groupId) メインページパターンの一覧を取得します。
MainPagePatternInfo | LoginGroupAccessor.getMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを取得します。

MainPagePatternInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.group のメソッド
void | MainPageImportLoginGroupPostWriterListener.postCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成した直後にコールされます。
void | MainPageImportLoginGroupPostWriterListener.postUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新した直後にコールされます。
void | LoginGroupQueryWriterListener.queryCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成する前にコールされます。
void | LoginGroupQueryWriterListener.queryUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新する前にコールされます。
void | LoginGroupPostWriterListener.postCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成した直後にコールされます。
void | LoginGroupPostWriterListener.postUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新した直後にコールされます。
void | LoginGroupManager.addMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを新規追加します。
void | LoginGroupManager.updateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを更新します。
void | LoginGroupAccessor.insertMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを新規追加します。
void | LoginGroupAccessor.updateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを更新します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


GroupSuperUserAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
インタフェース GroupSuperUserAccessor

public interface GroupSuperUserAccessor

グループ管理者アクセッサインタフェース。

グループ管理者情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | deleteSuperUser(String groupId) グループ管理者情報を削除します。
SuperUser | getSuperUser(String groupId) グループ管理者情報を取得します。
void | init(Map params) グループ管理者アクセッサを初期化します。
void | insertSuperUser(String groupId, SuperUser superUser) グループ管理者情報を新規追加します。
void | updateSuperUser(String groupId, SuperUser superUser) グループ管理者情報を更新します。

メソッドの詳細

deleteSuperUser

public void deleteSuperUser(String groupId)
                     throws AccessSecurityWriteException,
                            NotExistException
グループ管理者情報を削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException - グループ管理者情報の削除に失敗した場合にスローされます。
NotExistException - 削除するグループ管理者が存在しない場合にスローされます。

getSuperUser

public SuperUser getSuperUser(String groupId)
                       throws AccessSecurityReadException
グループ管理者情報を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
グループ管理者情報
存在しない場合は、nullを返却します。
例外:
AccessSecurityReadException - グループ管理者情報の取得に失敗した場合にスローされます。

init

public void init(Map params)
グループ管理者アクセッサを初期化します。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

insertSuperUser

public void insertSuperUser(String groupId,
                            SuperUser superUser)
                     throws AccessSecurityWriteException,
                            DuplicateException
グループ管理者情報を新規追加します。

パラメータ:
groupId - ログイングループID
superUser - グループ管理者情報
例外:
AccessSecurityWriteException - グループ管理者情報の作成に失敗した場合にスローされます。
DuplicateException - 追加するグループ管理者が既に存在した場合にスローされます。

updateSuperUser

public void updateSuperUser(String groupId,
                            SuperUser superUser)
                     throws AccessSecurityWriteException,
                            NotExistException
グループ管理者情報を更新します。

パラメータ:
groupId - ログイングループID
superUser - グループ管理者情報
例外:
AccessSecurityWriteException - グループ管理者情報の更新に失敗した場合にスローされます。
NotExistException - 更新するグループ管理者が存在しない場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


GroupSuperUserPostWriterListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
インタフェース GroupSuperUserPostWriterListener

public interface GroupSuperUserPostWriterListener

グループ管理者情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | init(Map params) グループ管理者リスナーの初期化。
void | postCreate(String groupId, SuperUser superUser) グループ管理者情報をデータストアに作成した直後にコールされます。
void | postDelete(String groupId) グループ管理者情報をデータストアから削除した直後にコールされます。
void | postUpdate(String groupId, SuperUser superUser) グループ管理者情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
グループ管理者リスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreate

public void postCreate(String groupId,
                       SuperUser superUser)
グループ管理者情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
superUser - 作成されたグループ管理者情報

postUpdate

public void postUpdate(String groupId,
                       SuperUser superUser)
グループ管理者情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
superUser - 更新されたグループ管理者情報

postDelete

public void postDelete(String groupId)
グループ管理者情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GroupSuperUserQueryWriterListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
インタフェース GroupSuperUserQueryWriterListener

public interface GroupSuperUserQueryWriterListener

グループ管理者情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | init(Map params) グループ管理者リスナーの初期化。
void | queryCreate(String groupId, SuperUser superUser) グループ管理者情報をデータストアに作成する直前にコールされます。
void | queryDelete(String groupId) グループ管理者情報をデータストアから削除する直前にコールされます。
void | queryUpdate(String groupId, SuperUser superUser) グループ管理者情報をデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
グループ管理者リスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreate

public void queryCreate(String groupId,
                        SuperUser superUser)
グループ管理者情報をデータストアに作成する直前にコールされます。

パラメータ:
groupId - ログイングループID
superUser - 作成されるグループ管理者情報
戻り値:
グループ管理者情報

queryUpdate

public void queryUpdate(String groupId,
                        SuperUser superUser)
グループ管理者情報をデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
superUser - 更新されるグループ管理者情報

queryDelete

public void queryDelete(String groupId)
グループ管理者情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GroupSuperUserReaderDecorator (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
インタフェース GroupSuperUserReaderDecorator

public interface GroupSuperUserReaderDecorator

管理者情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
SuperUser | doDecoration(String groupId, SuperUser superUser) アカウントをデータストアからの読み込み直後にコールされます。
void | init(Map params) 管理者デコレータの初期化。

メソッドの詳細

init

public void init(Map params)
管理者デコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public SuperUser doDecoration(String groupId,
                              SuperUser superUser)
アカウントをデータストアからの読み込み直後にコールされます。

引数のgroupIdがnullの場合はシステム管理者の管理者情報を拡張して返却します。
引数のgroupIdがnullのでない場合はグループ管理者の管理者情報を拡張して返却します。

パラメータ:
groupId - ログイングループID
superUser - 読み込みが行われた管理者情報
戻り値:
拡張された管理者情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginGroup (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
クラス LoginGroup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.group.LoginGroup
すべての実装インタフェース:
LocaleProvider, Serializable
public class LoginGroup
extends Object
implements LocaleProvider, Serializable

ログイングループ・モデル。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
LoginGroupManager, 直列化された形式

コンストラクタの概要
protected | LoginGroup() コンストラクタ。
 | LoginGroup(String groupId) コンストラクタ。
メソッドの概要
boolean | equals(Object loginGroup) オブジェクトの比較。
String | getColorPatternId() カラーパターンIDを取得します。
String | getEncoding() エンコーディングを取得します。
Locale | getLocale() ロケールを取得します。
int | getLockCount() アカウントをロックするログイン失敗回数を取得します。
int | getLockTerm() アカウントをロックする期間を取得します。
String | getLoginGroupId() ログイングループIDを取得します。
int | hashCode() ハッシュコードを取得します。
void | setColorPatternId(String colorPattrenId) カラーパターンIDを設定します。
void | setEncoding(String encoding) エンコーディングを設定します。
void | setLocale(Locale locale) ロケールを設定します。
void | setLockCount(int count) アカウントをロックするログイン失敗回数を設定します。
void | setLockTerm(int term) アカウントをロックする期間を設定します。
protected void | setLoginGroupId(String groupId) ログイングループIDを設定します。
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LoginGroup

protected LoginGroup()
コンストラクタ。

LoginGroup

public LoginGroup(String groupId)
コンストラクタ。

パラメータ:
groupId - ログイングループID
メソッドの詳細

equals

public boolean equals(Object loginGroup)
オブジェクトの比較。 指定されたオブジェクトとこのモデルが等しいかどうかを比較します。

パラメータ:
loginGroup - モデルと等しいかどうかを比較するオブジェクト
戻り値:
指定されたオブジェクトがこのモデルと等しい場合は true
関連項目:
Object.equals(Object)

getEncoding

public String getEncoding()
エンコーディングを取得します。

定義:
インタフェース LocaleProvider 内の getEncoding
戻り値:
エンコーディング
関連項目:
LocaleProvider.getEncoding()

getLocale

public Locale getLocale()
ロケールを取得します。

定義:
インタフェース LocaleProvider 内の getLocale
戻り値:
ロケール
関連項目:
LocaleProvider.getLocale()

getLockCount

public int getLockCount()
アカウントをロックするログイン失敗回数を取得します。

戻り値:
アカウントをロックするログイン失敗回数
アカウントロックを行わない場合は0を返却します。

getLockTerm

public int getLockTerm()
アカウントをロックする期間を取得します。

戻り値:
アカウントをロックする期間（分）
ロックする期間が設定されていない場合は0が返却されます。

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

戻り値:
ログイングループID

getColorPatternId

public String getColorPatternId()
カラーパターンIDを取得します。

戻り値:
カラーパターンID

hashCode

public int hashCode()
ハッシュコードを取得します。

戻り値:
ハッシュコード
関連項目:
Object.hashCode()

setEncoding

public void setEncoding(String encoding)
エンコーディングを設定します。

パラメータ:
encoding - エンコーディング

setLocale

public void setLocale(Locale locale)
ロケールを設定します。

パラメータ:
locale - ロケール名
関連項目:
setLocale(Locale)

setLockCount

public void setLockCount(int count)
アカウントをロックするログイン失敗回数を設定します。

設定できる値は、0以上です。
0が設定された場合はアカウントロックを行ないません。

パラメータ:
count - アカウントをロックするログイン失敗回数

setLockTerm

public void setLockTerm(int term)
アカウントをロックする期間を設定します。

設定できる値は、0以上です。
アカウントがロックされた場合の、ロック解除までの時間を分単位で設定します。
0が設定された場合は、自動的にアカウントロックは解除されません。

パラメータ:
term - アカウントをロックする期間

setLoginGroupId

protected void setLoginGroupId(String groupId)
ログイングループIDを設定します。

パラメータ:
groupId - ログイングループID

setColorPatternId

public void setColorPatternId(String colorPattrenId)
カラーパターンIDを設定します。

パラメータ:
colorPattrenId - カラーパターンID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LoginGroupAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
インタフェース LoginGroupAccessor

public interface LoginGroupAccessor

ログイングループアクセッサインタフェース。

ログイングループ情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | deleteLoginGroup(String groupId) ログイングループを削除します。
void | deleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを削除します。
LoginGroup | getLoginGroup(String groupId) ログイングループ情報を取得します。
String[] | getLoginGroupIds() ログイングループIDの一覧を取得します。
MainPagePatternInfo | getMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを取得します。
String[] | getMainPagePatternIds(String groupId) メインページパターンIDの一覧を取得します。
void | init(Map params) ログイングアクセッサの初期化。
void | insertLoginGroup(LoginGroup loginGroup) ログイングループを新規追加します。
void | insertMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを新規追加します。
void | updateLoginGroup(LoginGroup loginGroup) ログイングループを更新します。
void | updateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを更新します。

メソッドの詳細

deleteLoginGroup

public void deleteLoginGroup(String groupId)
                      throws AccessSecurityWriteException,
                             NotExistException
ログイングループを削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException - ログイングループ情報の削除に失敗した場合にスローされます。
NotExistException - 削除するログイングループ情報が存在しない場合にスローされます。

deleteMainPagePattern

public void deleteMainPagePattern(String groupId,
                                  String mainPagePatternId)
                           throws AccessSecurityWriteException,
                                  NotExistException
メインページパターンを削除します。

ログイングループに紐付くメインページパターンを削除します。

パラメータ:
groupId - ログイングループID
mainPagePatternId - メインページパターンID
例外:
AccessSecurityWriteException - メインページパターン情報の更新に失敗した場合にスローされます。
NotExistException - 削除するメインページパターン情報が存在しない場合にスローされます。

getLoginGroup

public LoginGroup getLoginGroup(String groupId)
                         throws AccessSecurityReadException
ログイングループ情報を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
ログイングループ情報
存在しない場合は、nullを返却します。
例外:
AccessSecurityReadException - ログイングループ情報の取得に失敗した場合にスローされます。

getLoginGroupIds

public String[] getLoginGroupIds()
                          throws AccessSecurityReadException
ログイングループIDの一覧を取得します。

戻り値:
ログイングループIDの配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - ログイングループ情報の取得に失敗した場合にスローされます。

getMainPagePattern

public MainPagePatternInfo getMainPagePattern(String groupId,
                                              String mainPagePatternId)
                                       throws AccessSecurityReadException
メインページパターンを取得します。

パラメータ:
groupId - ログイングループID
mainPagePatternId - メインページパターンID
戻り値:
メインパターン情報
例外:
AccessSecurityReadException - メインページパターン情報の取得に失敗した場合にスローされます。

getMainPagePatternIds

public String[] getMainPagePatternIds(String groupId)
                               throws AccessSecurityReadException
メインページパターンIDの一覧を取得します。

ログイングループに紐付くメインページパターンIDの一覧を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
メインページパターンIDの配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - メインページパターン情報の取得に失敗した場合にスローされます。

init

public void init(Map params)
ログイングアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

insertLoginGroup

public void insertLoginGroup(LoginGroup loginGroup)
                      throws AccessSecurityWriteException,
                             DuplicateException
ログイングループを新規追加します。

パラメータ:
loginGroup - ログイングループ情報
例外:
AccessSecurityWriteException - ログイングループ情報の作成に失敗した場合にスローされます。
DuplicateException - 追加するログイングループ情報が既に存在した場合にスローされます。

insertMainPagePattern

public void insertMainPagePattern(String groupId,
                                  MainPagePatternInfo mainPagePatternInfo)
                           throws AccessSecurityWriteException,
                                  DuplicateException
メインページパターンを新規追加します。

ログイングループに紐付くメインページパターンを新規追加します。

パラメータ:
groupId - ログイングループID
mainPagePatternInfo -
例外:
AccessSecurityWriteException - メインページパターン情報の作成に失敗した場合にスローされます。
DuplicateException - 追加するメインページパターン情報が既に存在した場合にスローされます。

updateLoginGroup

public void updateLoginGroup(LoginGroup loginGroup)
                      throws AccessSecurityWriteException,
                             NotExistException
ログイングループを更新します。

パラメータ:
loginGroup - ログイングループ情報
例外:
AccessSecurityWriteException - ログイングループ情報の更新に失敗した場合にスローされます。
NotExistException - 更新するログイングループ情報が存在しない場合にスローされます。

updateMainPagePattern

public void updateMainPagePattern(String groupId,
                                  MainPagePatternInfo mainPagePatternInfo)
                           throws AccessSecurityWriteException,
                                  NotExistException
メインページパターンを更新します。

ログイングループに紐付くメインページパターンを更新します。

パラメータ:
groupId - ログイングループID
mainPagePatternInfo -
例外:
AccessSecurityWriteException - メインページパターン情報の更新に失敗した場合にスローされます。
NotExistException - 更新するメインページパターン情報が存在しない場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginGroupManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
クラス LoginGroupManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.group.LoginGroupManager
public class LoginGroupManager
extends Object

ログイングループマネージャクラス。

ログイングループ情報を操作を行います。
ログイングループマネージャでは、以下の操作が可能です。

  • ログイングループの追加、更新、削除。
  • ログイングループへのグループ管理者の追加、更新、削除。
  • ログイングループへのメインページパターンの追加、更新、削除。

    • 導入されたバージョン:
    5.0
    バージョン:
    1.0
    関連項目:
    LoginGroup, SuperUser, MainPagePatternInfo

    メソッドの概要
void | addLoginGroup(LoginGroup loginGroup) ログイングループを新規追加します。
void | addMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを新規追加します。
void | addSuperUser(String groupId, SuperUser superUser) グループ管理者を新規追加します。
static void | clearInstance() ログイングループマネージャのインスタンスを初期化します。
int | countLoginGroups() ログイングループ数を取得します。
void | deleteLoginGroup(String groupId) ログイングループを削除します。
void | deleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを削除します。
void | deleteMainPagePatterns(String groupId) メインページパターンをすべて削除します。
void | deleteSuperUser(String groupId) グループ管理者情報を削除します。
static LoginGroupManager | getInstance() ログイングループマネージャのインスタンスを取得します。
LoginGroup | getLoginGroup(String groupId) ログイングループ情報を取得します。
String[] | getLoginGroupIds() ログイングループIDの一覧を取得します。
LoginGroup[] | getLoginGroups() ログイングループの一覧を取得します。
MainPagePatternInfo | getMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを取得します。
String[] | getMainPagePatternIds(String groupId) メインページパターンIDの一覧を取得します。
MainPagePatternInfo[] | getMainPagePatterns(String groupId) メインページパターンの一覧を取得します。
SuperUser | getSuperUser(String groupId) グループ管理者情報を取得します。
void | updateLoginGroup(LoginGroup loginGroup) ログイングループ情報を更新します。
void | updateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを更新します。
void | updateSuperUser(String groupId, SuperUser superUser) グループ管理者情報を更新します。
    クラス java.lang.Object から継承したメソッド
    clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    メソッドの詳細

    clearInstance

    public static void clearInstance()
    ログイングループマネージャのインスタンスを初期化します。

    アクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

    アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。
    通常、このメソッドを使用する必要はありません。

    getInstance

    public static LoginGroupManager getInstance()
    ログイングループマネージャのインスタンスを取得します。

    戻り値:
    ログイングループマネージャのインスタンス

    addLoginGroup

    public void addLoginGroup(LoginGroup loginGroup)
                   throws AccessSecurityException
    ログイングループを新規追加します。

    ログイングループを新規に追加します。
    ログイングループIDはユニークなものを設定してください。

    パラメータ:
    loginGroup - ログイングループ情報
    例外:
    AccessSecurityException - ログイングループ情報の追加に失敗した場合にスローされます。

    addMainPagePattern

    public void addMainPagePattern(String groupId,
                               MainPagePatternInfo mainPagePatternInfo)
                        throws AccessSecurityException
    メインページパターンを新規追加します。

    ログイングループに対してメインページパターンを新規に追加します。
    メインページパターンIDはログイングループ単位でユニークなものを設定してください。
    存在しないログイングループに対して、メインページパターンは追加できません。

    パラメータ:
    groupId - ログイングループID
    mainPagePatternInfo - メインページパターン情報
    例外:
    AccessSecurityWriteException - メインページパターン情報の追加に失敗した場合、または引数が不正だった場合にスローされます。
    AccessSecurityException

    addSuperUser

    public void addSuperUser(String groupId,
                         SuperUser superUser)
                  throws AccessSecurityException
    グループ管理者を新規追加します。

    ログイングループに対してグループ管理者を新規に追加します。
    存在しないログイングループに対して、グループ管理者は追加できません。

    パラメータ:
    groupId - ログイングループID
    superUser - グループ管理者情報
    例外:
    AccessSecurityException - グループ管理者情報の追加に失敗した場合、または引数が不正だった場合にスローされます。

    countLoginGroups

    public int countLoginGroups()
                     throws AccessSecurityException
    ログイングループ数を取得します。

    現在登録されているログイングループの数を返却します。

    戻り値:
    ログイングループ数
    例外:
    AccessSecurityException - ログイングループ情報の取得に失敗した場合にスローされます。

    deleteMainPagePatterns

    public void deleteMainPagePatterns(String groupId)
                            throws AccessSecurityException
    メインページパターンをすべて削除します。

    ログイングループに属するすべてのメインページパターンを削除します。
    存在しないログイングループに対して、メインページパターンの削除はできません。

    パラメータ:
    groupId - ログイングループID
    例外:
    AccessSecurityWriteException - メインページパターン情報の更新に失敗した場合にスローされます。
    AccessSecurityException

    deleteLoginGroup

    public void deleteLoginGroup(String groupId)
                      throws AccessSecurityException
    ログイングループを削除します。 ログイングループに属するすべてのアクセスセキュリティ情報も同時に削除されます。

    削除対象情報：
  • メインページパターン
  • グループ管理者
  • ロール
  • アカウント
  • メニュー
  • カレンダ
  • アクセスコントローラ
  • バッチ

    • パラメータ:
    groupId - ログイングループID
    例外:
    AccessSecurityException - ログイングループ情報の削除に失敗した場合にスローされます。

    deleteMainPagePattern

    public void deleteMainPagePattern(String groupId,
                                  String mainPagePatternId)
                           throws AccessSecurityException
    メインページパターンを削除します。

    ログイングループに属するメインページパターンを削除します。
    存在しないログイングループに対して、メインページパターンの削除はできません。

    パラメータ:
    groupId - ログイングループID
    mainPagePatternId - メインページパターンID
    例外:
    AccessSecurityWriteException - メインページパターン情報の更新に失敗した場合に、または引数が不正だった場合にスローされます。
    AccessSecurityException

    deleteSuperUser

    public void deleteSuperUser(String groupId)
                     throws AccessSecurityException
    グループ管理者情報を削除します。

    ログイングループに属するグループ管理者を削除します。
    存在しないログイングループに対して、グループ管理者の削除はできません。

    パラメータ:
    groupId - ログイングループID
    例外:
    AccessSecurityException - グループ管理者情報の削除に失敗した場合にスローされます。

    getLoginGroup

    public LoginGroup getLoginGroup(String groupId)
                         throws AccessSecurityException
    ログイングループ情報を取得します。

    引数で指定したログイングループIDのログイングループ情報を取得します。
    指定したログイングループIDのログイングループが存在しない場合は、nullを返却します。

    パラメータ:
    groupId - ログイングルーID
    戻り値:
    ログイングループ情報
    例外:
    AccessSecurityException - ログイングループ情報の取得に失敗した場合にスローされます。

    getLoginGroupIds

    public String[] getLoginGroupIds()
                          throws AccessSecurityException
    ログイングループIDの一覧を取得します。

    現在登録されているログイングループのログイングループIDの一覧を取得します。
    ログイングループが一件も存在しない場合は、空の配列を返却します。

    戻り値:
    ログイングループIDの配列
    例外:
    AccessSecurityException - ログイングループ情報の取得に失敗した場合にスローされます。

    getLoginGroups

    public LoginGroup[] getLoginGroups()
                            throws AccessSecurityException
    ログイングループの一覧を取得します。

    現在登録されているログイングループの一覧を取得します。
    ログイングループが一件も存在しない場合は、空の配列を返却します。

    戻り値:
    ログイングループ情報の配列
    例外:
    AccessSecurityException - ログイングループ情報の取得に失敗した場合にスローされます。

    getMainPagePattern

    public MainPagePatternInfo getMainPagePattern(String groupId,
                                              String mainPagePatternId)
                                       throws AccessSecurityException
    メインページパターンを取得します。

    ログイングループに属するメインページパターンを取得します。
    ログイングループに属するメインページパターンIDが存在しない場合は、nullを返却します。

    パラメータ:
    groupId - ログイングループID
    mainPagePatternId - メインページパターンID
    戻り値:
    メインページパターン情報
    例外:
    AccessSecurityReadException - メインページパターン情報の取得に失敗した場合、または引数が不正だった場合にスローされます。
    AccessSecurityException

    getMainPagePatternIds

    public String[] getMainPagePatternIds(String groupId)
                               throws AccessSecurityException
    メインページパターンIDの一覧を取得します。

    ログイングループに属するメインパターンIDの一覧を取得します。
    ログイングループに属するメインパターンが一件も存在しない場合は、空の配列を返却します。

    パラメータ:
    groupId - ログイングループID
    戻り値:
    メインページパターンIDの配列
    例外:
    AccessSecurityReadException - メインページパターン情報の取得に失敗した場合にスローされます。
    AccessSecurityException

    getMainPagePatterns

    public MainPagePatternInfo[] getMainPagePatterns(String groupId)
                                          throws AccessSecurityException
    メインページパターンの一覧を取得します。

    ログイングループに属するメインパターンの一覧を取得します。
    ログイングループに属するメインパターンが一件も存在しない場合は、空の配列を返却します。

    パラメータ:
    groupId - ログイングループID
    戻り値:
    メインページパターン情報の配列
    例外:
    AccessSecurityReadException - メインページパターン情報の取得に失敗した場合にスローされます。
    AccessSecurityException

    getSuperUser

    public SuperUser getSuperUser(String groupId)
                       throws AccessSecurityException
    グループ管理者情報を取得します。

    ログイングループに属するグループ管理者を取得します。
    ログイングループに属するグループ管理者が存在しない場合は、nullを返却します。

    パラメータ:
    groupId - ログイングループID
    戻り値:
    グループ管理者情報
    例外:
    AccessSecurityException - グループ管理者情報の取得に失敗した場合にスローされます。

    updateLoginGroup

    public void updateLoginGroup(LoginGroup loginGroup)
                      throws AccessSecurityException
    ログイングループ情報を更新します。

    既に登録されているログイングループを更新します。
    存在しないログイングループに対して、ログイングループの更新はできません。

    パラメータ:
    loginGroup - ログイングループID
    例外:
    AccessSecurityException - ログイングループ情報の更新に失敗した場合にスローされます。

    updateMainPagePattern

    public void updateMainPagePattern(String groupId,
                                  MainPagePatternInfo mainPagePatternInfo)
                           throws AccessSecurityException
    メインページパターンを更新します。

    既に登録されているログイングループに属するメインページパターンを更新します。
    存在しないログイングループに対して、メインページパターンの更新はできません。

    パラメータ:
    groupId - ログイングループID
    mainPagePatternInfo -
    例外:
    AccessSecurityWriteException - メインページパターン情報の更新に失敗した場合、または引数が不正だった場合にスローされます。
    AccessSecurityException

    updateSuperUser

    public void updateSuperUser(String groupId,
                            SuperUser superUser)
                     throws AccessSecurityException
    グループ管理者情報を更新します。

    既に登録されているログイングループに属するグループ管理者を更新します。
    存在しないログイングループに対して、グループ管理者の更新はできません。

    パラメータ:
    groupId - ログイングループID
    superUser - グループ管理者情報
    例外:
    AccessSecurityException - グループ管理者情報の更新に失敗した場合、または引数が不正だった場合にスローされます。
    概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
            intra-mart 6.1.14
    前のクラス 次のクラス フレームあり フレームなし
    概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginGroupPostWriterListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
インタフェース LoginGroupPostWriterListener

既知の実装クラスの一覧:
MainPageImportLoginGroupPostWriterListener
public interface LoginGroupPostWriterListener

ログイングループ情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
LoginGroupManager

メソッドの概要
void | init(Map params) ログイングループ書き込み時（書き込み直前）のリスナの初期化。
void | postCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成した直後にコールされます。
void | postCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成した直後にコールされます。
void | postDeleteLoginGroup(String groupId) ログイングループ情報をデータストアから削除した直後にコールされます。
void | postDeleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターン情報をデータストアから削除した直後にコールされます。
void | postUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新した直後にコールされます。
void | postUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
ログイングループ書き込み時（書き込み直前）のリスナの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreateLoginGroup

public void postCreateLoginGroup(LoginGroup loginGroup)
                          throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアに作成した直後にコールされます。

パラメータ:
loginGroup - 作成されたログイングループ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postCreateMainPagePattern

public void postCreateMainPagePattern(String groupId,
                                      MainPagePatternInfo mainPagePatternInfo)
                               throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - 対象ログイングループID
mainPagePatternInfo - 作成されたメインページパターン情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteLoginGroup

public void postDeleteLoginGroup(String groupId)
                          throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - 削除されたログイングループID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteMainPagePattern

public void postDeleteMainPagePattern(String groupId,
                                      String mainPagePatternId)
                               throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - 対象ログイングループID
mainPagePatternId - 削除されたメインページパターンID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateLoginGroup

public void postUpdateLoginGroup(LoginGroup loginGroup)
                          throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアに更新した直後にコールされます。

パラメータ:
loginGroup - 更新されたログイングループ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateMainPagePattern

public void postUpdateMainPagePattern(String groupId,
                                      MainPagePatternInfo mainPagePatternInfo)
                               throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - 対象ログイングループID
mainPagePatternInfo - 更新されたメインページパターン情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginGroupQueryWriterListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
インタフェース LoginGroupQueryWriterListener

public interface LoginGroupQueryWriterListener

ログイングループ情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
LoginGroupManager

メソッドの概要
void | init(Map params) ログイングループ書き込み時（書き込み直前）のリスナの初期化。
void | queryCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成する直前にコールされます。
void | queryCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成する前にコールされます。
void | queryDeleteLoginGroup(String groupId) ログイングループ情報をデータストアから削除する直前にコールされます。
void | queryDeleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターン情報をデータストアから削除する前にコールされます。
void | queryUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新する直前にコールされます。
void | queryUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新する前にコールされます。

メソッドの詳細

init

public void init(Map params)
ログイングループ書き込み時（書き込み直前）のリスナの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreateLoginGroup

public void queryCreateLoginGroup(LoginGroup loginGroup)
                           throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアに作成する直前にコールされます。

パラメータ:
loginGroup - 作成されるログイングループ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryCreateMainPagePattern

public void queryCreateMainPagePattern(String groupId,
                                       MainPagePatternInfo mainPagePatternInfo)
                                throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアに作成する前にコールされます。

パラメータ:
groupId - 対象ログイングループID
mainPagePatternInfo - 作成されるメインページパターン情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteLoginGroup

public void queryDeleteLoginGroup(String groupId)
                           throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - 削除されるログイングループID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteMainPagePattern

public void queryDeleteMainPagePattern(String groupId,
                                       String mainPagePatternId)
                                throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアから削除する前にコールされます。

パラメータ:
groupId - 対象ログイングループID
mainPagePatternId - 削除されるメインページパターンID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdateLoginGroup

public void queryUpdateLoginGroup(LoginGroup loginGroup)
                           throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアに更新する直前にコールされます。

パラメータ:
loginGroup - 更新されるログイングループ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdateMainPagePattern

public void queryUpdateMainPagePattern(String groupId,
                                       MainPagePatternInfo mainPagePatternInfo)
                                throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアに更新する前にコールされます。

パラメータ:
groupId - 対象ログイングループID
mainPagePatternInfo - 更新されるメインページパターン情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginGroupReaderDecorator (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
インタフェース LoginGroupReaderDecorator

public interface LoginGroupReaderDecorator

ログイングループ情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
LoginGroup | doDecoration(LoginGroup loginGroup) ログイングループをデータストアからの読み込み直後にコールされます。
void | init(Map params) ログイングループデコレータの初期化。

メソッドの詳細

init

public void init(Map params)
ログイングループデコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public LoginGroup doDecoration(LoginGroup loginGroup)
ログイングループをデータストアからの読み込み直後にコールされます。

パラメータ:
loginGroup - 読み込みが行われたログイングループ情報
戻り値:
拡張されたログイングループ情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MainPageImportLoginGroupPostWriterListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
クラス MainPageImportLoginGroupPostWriterListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener
すべての実装インタフェース:
LoginGroupPostWriterListener
public class MainPageImportLoginGroupPostWriterListener
extends Object
implements LoginGroupPostWriterListener

ログイングループ作成時にメインページパターンを設定するリスナークラス。

ログイングループ作成時に設定されたメインページパターン情報を追加します。
デフォルトの設定ファイルはストレージサーバ/system/basic/init-main-page.xmlです。
初期化パラメータ(main-page-file)で見込む設定ファイルを変更できます。
初期化パラメータには、ストレージサーバからの相対パスで指定してください。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
MainPageImportLoginGroupPostWriterListener()
コンストラクタ。
メソッドの概要
void | init(Map params) ログイングループ書き込み時（書き込み直前）のリスナの初期化。
void | postCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成した直後にコールされます。
void | postCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成した直後にコールされます。
void | postDeleteLoginGroup(String groupId) ログイングループ情報をデータストアから削除した直後にコールされます。
void | postDeleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターン情報をデータストアから削除した直後にコールされます。
void | postUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新した直後にコールされます。
void | postUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新した直後にコールされます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MainPageImportLoginGroupPostWriterListener

public MainPageImportLoginGroupPostWriterListener()
コンストラクタ。

メソッドの詳細

init

public void init(Map params)
ログイングループ書き込み時（書き込み直前）のリスナの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース LoginGroupPostWriterListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

postCreateLoginGroup

public void postCreateLoginGroup(LoginGroup loginGroup)
                          throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアに作成した直後にコールされます。

定義:
インタフェース LoginGroupPostWriterListener 内の postCreateLoginGroup
パラメータ:
loginGroup - 作成されたログイングループ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postCreateMainPagePattern

public void postCreateMainPagePattern(String groupId,
                                      MainPagePatternInfo mainPagePatternInfo)
                               throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアに作成した直後にコールされます。

定義:
インタフェース LoginGroupPostWriterListener 内の postCreateMainPagePattern
パラメータ:
groupId - 対象ログイングループID
mainPagePatternInfo - 作成されたメインページパターン情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteLoginGroup

public void postDeleteLoginGroup(String groupId)
                          throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアから削除した直後にコールされます。

定義:
インタフェース LoginGroupPostWriterListener 内の postDeleteLoginGroup
パラメータ:
groupId - 削除されたログイングループID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteMainPagePattern

public void postDeleteMainPagePattern(String groupId,
                                      String mainPagePatternId)
                               throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアから削除した直後にコールされます。

定義:
インタフェース LoginGroupPostWriterListener 内の postDeleteMainPagePattern
パラメータ:
groupId - 対象ログイングループID
mainPagePatternId - 削除されたメインページパターンID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateLoginGroup

public void postUpdateLoginGroup(LoginGroup loginGroup)
                          throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアに更新した直後にコールされます。

定義:
インタフェース LoginGroupPostWriterListener 内の postUpdateLoginGroup
パラメータ:
loginGroup - 更新されたログイングループ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateMainPagePattern

public void postUpdateMainPagePattern(String groupId,
                                      MainPagePatternInfo mainPagePatternInfo)
                               throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアに更新した直後にコールされます。

定義:
インタフェース LoginGroupPostWriterListener 内の postUpdateMainPagePattern
パラメータ:
groupId - 対象ログイングループID
mainPagePatternInfo - 更新されたメインページパターン情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MainPagePatternInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
クラス MainPagePatternInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.group.MainPagePatternInfo
すべての実装インタフェース:
Serializable
public class MainPagePatternInfo
extends Object
implements Serializable

メインページパターン情報クラス。

メインページパターン情報を保管するクラス。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
MainPagePatternInfo(String mainPagePatternId)
コンストラクタ。
メソッドの概要
String | getMainPagePatternId() メインページパターンIDを取得する。
String | getMainPagePatternImageUrl() メインページパターンイメージURLを取得する。
String | getMainPagePatternUrl() メインページパターンURLを取得する。
void | setMainPagePatternImageUrl(String mainPagePatternImageUrl) メインページパターンイメージURLを設定する。
void | setMainPagePatternUrl(String mainPagePatternUrl) メインページパターンURLを設定する。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MainPagePatternInfo

public MainPagePatternInfo(String mainPagePatternId)
コンストラクタ。

パラメータ:
mainPagePatternId - メインページパターンID
メソッドの詳細

getMainPagePatternId

public String getMainPagePatternId()
メインページパターンIDを取得する。

戻り値:
メインページパターンID

getMainPagePatternImageUrl

public String getMainPagePatternImageUrl()
メインページパターンイメージURLを取得する。

戻り値:
メインページパターンイメージURL。

getMainPagePatternUrl

public String getMainPagePatternUrl()
メインページパターンURLを取得する。

戻り値:
メインページパターンURL。

setMainPagePatternImageUrl

public void setMainPagePatternImageUrl(String mainPagePatternImageUrl)
メインページパターンイメージURLを設定する。

パラメータ:
mainPagePatternImageUrl - メインページパターンイメージURL。

setMainPagePatternUrl

public void setMainPagePatternUrl(String mainPagePatternUrl)
メインページパターンURLを設定する。

パラメータ:
mainPagePatternUrl - メインページパターンURL。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.group (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.security.group
インタフェース
GroupSuperUserAccessor
GroupSuperUserPostWriterListener
GroupSuperUserQueryWriterListener
GroupSuperUserReaderDecorator
LoginGroupAccessor
LoginGroupPostWriterListener
LoginGroupQueryWriterListener
LoginGroupReaderDecorator
クラス
LoginGroup
LoginGroupManager
MainPageImportLoginGroupPostWriterListener
MainPagePatternInfo


jp.co.intra_mart.foundation.security.group (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.group

グループ管理者に関連するクラスを提供します。

参照:
説明

インタフェースの概要
GroupSuperUserAccessor | グループ管理者アクセッサインタフェース。
GroupSuperUserPostWriterListener | グループ管理者情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
GroupSuperUserQueryWriterListener | グループ管理者情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
GroupSuperUserReaderDecorator | 管理者情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
LoginGroupAccessor | ログイングループアクセッサインタフェース。
LoginGroupPostWriterListener | ログイングループ情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
LoginGroupQueryWriterListener | ログイングループ情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
LoginGroupReaderDecorator | ログイングループ情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

クラスの概要
LoginGroup | ログイングループ・モデル。
LoginGroupManager | ログイングループマネージャクラス。
MainPageImportLoginGroupPostWriterListener | ログイングループ作成時にメインページパターンを設定するリスナークラス。
MainPagePatternInfo | メインページパターン情報クラス。

パッケージ jp.co.intra_mart.foundation.security.group の説明

グループ管理者に関連するクラスを提供します。


jp.co.intra_mart.foundation.security.group クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.group の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.group.LoginGroup (implements jp.co.intra_mart.foundation.security.LocaleProvider, java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.group.LoginGroupManager
    • class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener (implements jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener)
    • class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo (implements java.io.Serializable)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor
  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener
  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator


パッケージ jp.co.intra_mart.foundation.security.group の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.group の使用

jp.co.intra_mart.foundation.security.group を使用しているパッケージ
jp.co.intra_mart.foundation.security.group グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.group により使用される jp.co.intra_mart.foundation.security.group のクラス
LoginGroup
ログイングループ・モデル。
LoginGroupManager
ログイングループマネージャクラス。
LoginGroupPostWriterListener
ログイングループ情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
MainPagePatternInfo
メインページパターン情報クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.license.ApplicationInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.license.ApplicationInfo の使用

ApplicationInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security.license ライセンスに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.license での ApplicationInfo の使用

ApplicationInfo を返す jp.co.intra_mart.foundation.security.license のメソッド
static ApplicationInfo | LicenseManager.getApplication(String applicaionId) アプリケーション情報を取得します。
static ApplicationInfo[] | LicenseManager.getApplications() アプリケーション情報の一覧を取得します。
static ApplicationInfo | LicenseManager.getProduct() システム情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.license.LicenseManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.license.LicenseManager の使用

jp.co.intra_mart.foundation.security.license.LicenseManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ApplicationInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.license
インタフェース ApplicationInfo

public interface ApplicationInfo

アプリケーション情報のインタフェース。

インストールされているアプリケーションの情報を提供するインタフェース

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
long | getExpiredDate() 試用期限の日付を取得します。
long | getInstallDate() インストールされた日付を取得します。
double | getLicense() アプリケーションライセンスが登録されているアカウント数を取得する。
String[] | getLicenseKeys() ライセンス・キーの取得 ライセンス・キーが登録されていない場合は、空の配列を返却します。
long | getLimitedDate() 使用期限の日付を取得します。
double | getMaxLicense() アプリケーションの最大登録可能なラインセンス数を取得します。
double | getMaxProcess() アプリケーションランタイムの最大使用可能なラインセンス数を取得します。
String | getName() アプリケーション名を取得します。
String | getPackageVersion() パッケージバージョンを取得します。
String[] | getProperties(String key) インストール情報を取得します。
String | getProperty(String key) インストール情報を取得します。
Integer[] | getSerialNumbers() シリアル番号の取得 ライセンス・キーが登録されていない場合は、空の配列を返却します。
Locale[] | getTargetLocales() 対象ロケールの取得。
String | getType() アプリケーションタイプを取得します。
String | getVersion() バージョンを取得します。
boolean | isExpired() 試用期限が切れているかどうかを判定します。
boolean | isFree() ライセンスフリーであるかどうかを判定します。
boolean | isLimited() 期限付きライセンスであるかどうかを判定します。
boolean | isTrial() 試用版であるかどうかを判定します。

メソッドの詳細

getLicenseKeys

public String[] getLicenseKeys()
ライセンス・キーの取得
ライセンス・キーが登録されていない場合は、空の配列を返却します。

戻り値:
ライセンス・キー。

getName

public String getName()
アプリケーション名を取得します。

戻り値:
アプリケーション名

getType

public String getType()
アプリケーションタイプを取得します。

戻り値:
アプリケーションタイプ

getVersion

public String getVersion()
バージョンを取得します。

戻り値:
バージョン

getPackageVersion

public String getPackageVersion()
パッケージバージョンを取得します。

戻り値:
パッケージバージョン

getSerialNumbers

public Integer[] getSerialNumbers()
シリアル番号の取得
ライセンス・キーが登録されていない場合は、空の配列を返却します。

戻り値:
シリアル番号。

getMaxProcess

public double getMaxProcess()
アプリケーションランタイムの最大使用可能なラインセンス数を取得します。
無制限の場合は Double.POSITIVE_INFINITYを返します。

戻り値:
アプリケーションランタイムの最大使用可能なラインセンス数

getMaxLicense

public double getMaxLicense()
アプリケーションの最大登録可能なラインセンス数を取得します。
無制限の場合は Double.POSITIVE_INFINITYを返します。

戻り値:
アプリケーションの最大登録可能なライセンス数

isTrial

public boolean isTrial()
試用版であるかどうかを判定します。

戻り値:
true : 試用版 / false : 製品版

isFree

public boolean isFree()
ライセンスフリーであるかどうかを判定します。

戻り値:
true : ライセンスフリー / false : ライセンス必須

isExpired

public boolean isExpired()
試用期限が切れているかどうかを判定します。

戻り値:
true : 試用期限が切れている / false : 試用期限内

isLimited

public boolean isLimited()
期限付きライセンスであるかどうかを判定します。

戻り値:
true : 期限付きライセンス / false : 通常ライセンス

getInstallDate

public long getInstallDate()
インストールされた日付を取得します。
単位はミリ秒で返却します。

戻り値:
インストールされた日付（ミリ秒）

getExpiredDate

public long getExpiredDate()
試用期限の日付を取得します。
単位はミリ秒で返却します。

戻り値:
試用期限の日付（ミリ秒）

getLimitedDate

public long getLimitedDate()
使用期限の日付を取得します。
単位はミリ秒で返却します。

戻り値:
使用期限の日付（ミリ秒）

getProperty

public String getProperty(String key)
インストール情報を取得します。

パラメータ:
key - インストール情報のキー
戻り値:
キーに対応するインストール情報

getProperties

public String[] getProperties(String key)
インストール情報を取得します。

パラメータ:
key - インストール情報のキー
戻り値:
キーに対応するインストール情報の配列

getLicense

public double getLicense()
アプリケーションライセンスが登録されているアカウント数を取得する。

戻り値:
登録されているアカウント数

getTargetLocales

public Locale[] getTargetLocales()
対象ロケールの取得。
言語パックライセンスが登録されていない場合は、空の配列を返却します。

戻り値:
対象ロケール。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LicenseManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.license
クラス LicenseManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.license.LicenseManager
public final class LicenseManager
extends Object

ライセンス・マネージャクラス。 イントラマートのライセンスを管理するマネージャクラスを定義します

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
ApplicationInfo

コンストラクタの概要
LicenseManager(String groupId)
コンストラクタ。
メソッドの概要
void | deleteAccountLicense(String userId) 指定されたユーザのライセンスを削除します。
void | deleteApplicationLicenseFromAccount(String userId, String applicationId) アプリケーションライセンスをアカウントから削除します。
static ApplicationInfo | getApplication(String applicaionId) アプリケーション情報を取得します。
static double | getApplicationLicense(String applicaionId) アプリケーションの登録ユーザ数を取得します。
static ApplicationInfo[] | getApplications() アプリケーション情報の一覧を取得します。
double | getLicense() グループ内で登録されているライセンス数を取得します。
double | getMaxLicense() ログイングループ内の最大登録可能ライセンス数を取得します。
static ApplicationInfo | getProduct() システム情報を取得します。
String[] | getRegisteredAccountLicenses() ログイングループにライセンス登録されているすべてのユーザIDを返します。
String[] | getRegisteredApplicationLicensesToAccount(String userId) アカウントに登録されているアプリケーションライセンスの一覧を取得します。
static double | getSystemLicense() システム全体の登録ライセンス数。
static double | getSystemMaxLicense() システム全体のライセンス数。
boolean | isRegisteredAccountLicense(String userId) 指定されたユーザがライセンスに登録されているかどうかをチェックします。
boolean | isRegisteredApplicationLicenseToAccount(String userId, String applicationId) アカウントにアプリケーションライセンスが登録されてるか検証します。
boolean | registerAccountLicense(String userId) ライセンス登録します。
boolean | registerApplicationLicenseToAccount(String userId, String applicationId) アプリケーションライセンスをアカウントに登録します。
boolean | setMaxLicense(double maxLicense) ログイングループ内の最大登録可能ライセンス数を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LicenseManager

public LicenseManager(String groupId)
               throws AccessSecurityException
コンストラクタ。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityException - 引数が不正だった場合にスローされます。
メソッドの詳細

getApplication

public static ApplicationInfo getApplication(String applicaionId)
                                      throws AccessSecurityException
アプリケーション情報を取得します。
引数に指定されたアプリケーションの情報を取得します。

パラメータ:
applicaionId - アプリケーションID
戻り値:
アプリケーション情報
指定したアプリケーションが存在しない場合はnullを返します。
例外:
AccessSecurityException - アプリケーション情報の取得に失敗した場合にスローされます。

getApplicationLicense

public static double getApplicationLicense(String applicaionId)
                                    throws AccessSecurityException
アプリケーションの登録ユーザ数を取得します。

引数に指定されたアプリケーションIDを持つユーザの数を取得します。

パラメータ:
applicaionId - アプリケーションID
戻り値:
アプリケーションIDを持つユーザの数
指定したアプリケーションが存在しない場合は0
例外:
AccessSecurityException

getApplications

public static ApplicationInfo[] getApplications()
                                         throws AccessSecurityException
アプリケーション情報の一覧を取得します。

戻り値:
アプリケーション情報の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getProduct

public static ApplicationInfo getProduct()
                                  throws AccessSecurityException
システム情報を取得します。

戻り値:
ApplicationInfo システム情報
システム情報の取得に失敗した場合はnull システム情報の取得に失敗した場合にスローされます。
例外:
AccessSecurityException

getSystemLicense

public static double getSystemLicense()
                               throws AccessSecurityException
システム全体の登録ライセンス数。

戻り値:
システム全体の登録ライセンス数
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getSystemMaxLicense

public static double getSystemMaxLicense()
                                  throws AccessSecurityException
システム全体のライセンス数。
無制限の場合は Double.POSITIVE_INFINITYを返します。

戻り値:
システム全体のライセンス数
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

deleteAccountLicense

public void deleteAccountLicense(String userId)
                          throws AccessSecurityException
指定されたユーザのライセンスを削除します。

パラメータ:
userId - ユーザID
例外:
AccessSecurityException - 引数が不正だった場合、または書き込み処理に失敗した場合にスローされます。

deleteApplicationLicenseFromAccount

public void deleteApplicationLicenseFromAccount(String userId,
                                                String applicationId)
                                         throws AccessSecurityException
アプリケーションライセンスをアカウントから削除します。

パラメータ:
userId - ユーザID
applicationId - アプリケーションID
例外:
AccessSecurityException - 引数が不正だった場合、または書き込み処理に失敗した場合にスローされます。

getLicense

public double getLicense()
                  throws AccessSecurityException
グループ内で登録されているライセンス数を取得します。

戻り値:
登録ライセンス数
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getMaxLicense

public double getMaxLicense()
                     throws AccessSecurityException
ログイングループ内の最大登録可能ライセンス数を取得します。
無制限の場合は Double.POSITIVE_INFINITYを返します。

戻り値:
最大登録可能ライセンス数
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getRegisteredAccountLicenses

public String[] getRegisteredAccountLicenses()
                                      throws AccessSecurityException
ログイングループにライセンス登録されているすべてのユーザIDを返します。

戻り値:
ユーザID配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getRegisteredApplicationLicensesToAccount

public String[] getRegisteredApplicationLicensesToAccount(String userId)
                                                   throws AccessSecurityException
アカウントに登録されているアプリケーションライセンスの一覧を取得します。

パラメータ:
userId - ユーザID
戻り値:
アカウントに登録されているアプリケーションライセンスの一覧
例外:
AccessSecurityException - 引数が不正だった場合、または読み込み処理に失敗した場合にスローされます。

isRegisteredAccountLicense

public boolean isRegisteredAccountLicense(String userId)
                                   throws AccessSecurityException
指定されたユーザがライセンスに登録されているかどうかをチェックします。

パラメータ:
userId - ユーザID
戻り値:
true:登録されている場合 false:登録されていない場合
例外:
AccessSecurityException - 引数が不正だった場合、または読み込み処理に失敗した場合にスローされます。

isRegisteredApplicationLicenseToAccount

public boolean isRegisteredApplicationLicenseToAccount(String userId,
                                                       String applicationId)
                                                throws AccessSecurityException
アカウントにアプリケーションライセンスが登録されてるか検証します。

パラメータ:
userId - ユーザID
applicationId - アプリケーションID
戻り値:
true:登録されている場合 false:登録されていない場合
例外:
AccessSecurityException - 引数が不正だった場合、または読み込み処理に失敗した場合にスローされます。

registerAccountLicense

public boolean registerAccountLicense(String userId)
                               throws AccessSecurityException
ライセンス登録します。
指定されたユーザIDとコンストラクタで指定したログイングループIDでライセンス登録をします。
最大登録可能ライセンス数とログイングループ内最大登録可能ライセンス数を調査して これを超えた場合はエラーとします。

パラメータ:
userId - ユーザID
戻り値:
true：処理成功 false：処理失敗
例外:
AccessSecurityException - 引数が不正だった場合、または書き込み処理に失敗した場合にスローされます。

registerApplicationLicenseToAccount

public boolean registerApplicationLicenseToAccount(String userId,
                                                   String applicationId)
                                            throws AccessSecurityException
アプリケーションライセンスをアカウントに登録します。

すでに登録されているアプリケーション最大登録可能ライセンス数と合わせて
最大登録可能ライセンス数を超えた場合はエラーとします。

パラメータ:
userId - ユーザID
applicationId - アプリケーションID
戻り値:
true：処理成功 false：処理失敗
例外:
AccessSecurityException - 引数が不正だった場合、または書き込み処理に失敗した場合にスローされます。

setMaxLicense

public boolean setMaxLicense(double maxLicense)
                      throws AccessSecurityException
ログイングループ内の最大登録可能ライセンス数を設定します。

すでに登録されているログイングループ内最大登録可能ライセンス数の合計と合わせて
最大登録可能ライセンス数を超えた場合はエラーとします。

パラメータ:
maxLicense - 最大登録可能ライセンス数
戻り値:
true：処理成功 false：処理失敗
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.license (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.security.license
インタフェース
ApplicationInfo
クラス
LicenseManager


jp.co.intra_mart.foundation.security.license (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.license

ライセンスに関連するクラスを提供します。

参照:
説明

インタフェースの概要
ApplicationInfo アプリケーション情報のインタフェース。

クラスの概要
LicenseManager ライセンス・マネージャクラス。

パッケージ jp.co.intra_mart.foundation.security.license の説明

ライセンスに関連するクラスを提供します。


jp.co.intra_mart.foundation.security.license クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.license の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.license.LicenseManager

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.license.ApplicationInfo


パッケージ jp.co.intra_mart.foundation.security.license の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.license の使用

jp.co.intra_mart.foundation.security.license を使用しているパッケージ
jp.co.intra_mart.foundation.security.license ライセンスに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.license により使用される jp.co.intra_mart.foundation.security.license のクラス
ApplicationInfo
アプリケーション情報のインタフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor の使用

jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.AdminMenuExporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.AdminMenuExporter の使用

AdminMenuExporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での AdminMenuExporter の使用

AdminMenuExporter を実装している jp.co.intra_mart.foundation.security.menu のクラス
 class StandardAdminMenuBackup
メニューバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.AdminMenuImporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.AdminMenuImporter の使用

AdminMenuImporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での AdminMenuImporter の使用

AdminMenuImporter を実装している jp.co.intra_mart.foundation.security.menu のクラス
 class StandardAdminMenuBackup
メニューバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion の使用

jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.AdminMenuManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.AdminMenuManager の使用

AdminMenuManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での AdminMenuManager の使用

AdminMenuManager を返す jp.co.intra_mart.foundation.security.menu のメソッド
static AdminMenuManager AdminMenuManager.getInstance()
ログイングループマネージャのインスタンスを取得します。

AdminMenuManager 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | AdminMenuImporter.doImport(InputStream inputStream, AdminMenuManager manager) インポートを行います。
void | AdminMenuExporter.doExport(AdminMenuManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardAdminMenuBackup.doImport(InputStream inputStream, AdminMenuManager manager) インポートを行います。
void | StandardAdminMenuBackup.doExport(AdminMenuManager manager, OutputStream outputStream) エクスポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener の使用

jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener の使用

jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator の使用

jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener の使用

jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.MenuAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.MenuAccessor の使用

MenuAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での MenuAccessor の使用

MenuAccessor を実装している jp.co.intra_mart.foundation.security のクラス
 class StandardMenuAccessor
メニューアクセッサクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.MenuExporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.MenuExporter の使用

MenuExporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での MenuExporter の使用

MenuExporter を実装している jp.co.intra_mart.foundation.security.menu のクラス
 class StandardMenuBackup
メニューバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.MenuImporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.MenuImporter の使用

MenuImporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での MenuImporter の使用

MenuImporter を実装している jp.co.intra_mart.foundation.security.menu のクラス
 class StandardMenuBackup
メニューバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.MenuInclusion の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.MenuInclusion の使用

MenuInclusion を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での MenuInclusion の使用

MenuInclusion を返す jp.co.intra_mart.foundation.security のメソッド
 MenuInclusion[] StandardMenuAccessor.getMenuInclusions(String groupId)
すべてのメニュー構成を取得します。

MenuInclusion 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | StandardMenuAccessor.deleteMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を削除します。
void | StandardMenuAccessor.insertMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を新規に作成します。

jp.co.intra_mart.foundation.security.menu での MenuInclusion の使用

MenuInclusion を返す jp.co.intra_mart.foundation.security.menu のメソッド
MenuInclusion[] | MenuAccessor.getMenuInclusions(String groupId) すべてのメニュー構成を取得します。
MenuInclusion[] | AdminMenuAccessor.getMenuInclusions() すべてのメニュー構成を取得します。

MenuInclusion 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuManager.moveMenuItem(MenuInclusion menuInclusion) メニューを移動します。
void | MenuAccessor.deleteMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を削除します。
void | MenuAccessor.insertMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を新規に作成します。
void | AdminMenuManager.moveMenuItem(MenuInclusion menuInclusion) メニューを移動します。
void | AdminMenuAccessor.deleteMenuInclusion(MenuInclusion menuInclusion) メニュー構成を削除します。
void | AdminMenuAccessor.insertMenuInclusion(MenuInclusion menuInclusion) メニュー構成を新規に作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.MenuItem の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.MenuItem の使用

MenuItem を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での MenuItem の使用

MenuItem を返す jp.co.intra_mart.foundation.security のメソッド
MenuItem[] | SystemManager.getSystemMenu() システムメニューを取得します。
MenuItem | StandardMenuAccessor.getMenuItem(String groupId, String menuId) 指定されたメニューIDに対するノードを取得します。
MenuItem[] | StandardMenuAccessor.getMenuItems(String groupId) すべてのノードを取得します。
MenuItem[] | StandardMenuAccessor.getMenuItemsByIds(String groupId, String[] menuIds) 指定されたメニューIDのメニュー情報をすべて取得します。

MenuItem 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | StandardMenuAccessor.insertMenuItem(String groupId, MenuItem menuItem, String parentId) 引数で渡されたノードを新規追加します。
void | StandardMenuAccessor.updateMenuItem(String groupId, MenuItem menuItem) 引数で渡されたノードを更新します。

jp.co.intra_mart.foundation.security.menu での MenuItem の使用

MenuItem を返す jp.co.intra_mart.foundation.security.menu のメソッド
MenuItem | MenuTree.getMenuItem() メニューを取得します。
MenuItem | MenuReaderDecorator.doDecoration(String groupId, MenuItem item) メニューデータストアからの読み込み直後にコールされます。
MenuItem | MenuManager.getMenuItem(String menuId) 指定されたメニューIDに対応するメニューを取得します。
MenuItem[] | MenuManager.getMenuItems() すべてのメニューを取得します。
MenuItem[] | MenuManager.getMenuItemsByIds(String[] menuIds) ログイングループ内で引数指定したメニューIDのメニュー情報をすべて取得します。
MenuItem | MenuAccessor.getMenuItem(String groupId, String menuId) 指定されたメニューIDに対するノードを取得します。
MenuItem[] | MenuAccessor.getMenuItems(String groupId) すべてのノードを取得します。
MenuItem[] | MenuAccessor.getMenuItemsByIds(String groupId, String[] menuIds) 指定されたユーザIDのメニュー情報をすべて取得します。
MenuItem | AdminMenuReaderDecorator.doDecoration(MenuItem item) メニューデータストアからの読み込み直後にコールされます。
MenuItem | AdminMenuManager.getMenuItem(String menuId) 指定されたメニューIDに対応するメニューを取得します。
MenuItem[] | AdminMenuManager.getMenuItems() すべてのメニューを取得します。
MenuItem[] | AdminMenuManager.getMenuItemsByIds(String[] menuIds) 引き数に指定したメニューIDに一致するメニューアイテムの一覧を取得します。
MenuItem | AdminMenuAccessor.getMenuItem(String menuId) 指定されたメニューIDに対するノードを取得します。
MenuItem[] | AdminMenuAccessor.getMenuItems() すべてのノードを取得します。
MenuItem[] | AdminMenuAccessor.getMenuItemsByIds(String[] menuIds) 管理メニューIDの一覧からメニューアイテムを取得します。

MenuItem 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
MenuItem | MenuReaderDecorator.doDecoration(String groupId, MenuItem item) メニューデータストアからの読み込み直後にコールされます。
void | MenuQueryWriterListener.queryCreate(String groupId, MenuItem item) メニュー情報をデータストアに作成する直前にコールされます。
void | MenuQueryWriterListener.queryUpdate(String groupId, MenuItem item) メニュー情報をデータストアに更新する直前にコールされます。
void | MenuPostWriterListener.postCreate(String groupId, MenuItem item) メニュー情報をデータストアに作成した直後にコールされます。
void | MenuPostWriterListener.postUpdate(String groupId, MenuItem item) メニュー情報をデータストアに更新した直後にコールされます。
void | MenuManager.addMenuItem(String parentMenuId, MenuItem menuItem) メニューを追加します。
void | MenuManager.updateMenuItem(MenuItem menuItem) メニューを更新します。
void | MenuAccessor.insertMenuItem(String groupId, MenuItem menuItem, String parentId) 引数で渡されたノードを新規追加します。
void | MenuAccessor.updateMenuItem(String groupId, MenuItem menuItem) 引数で渡されたノードを更新します。
MenuItem | AdminMenuReaderDecorator.doDecoration(MenuItem item) メニューデータストアからの読み込み直後にコールされます。
void | AdminMenuQueryWriterListener.queryCreate(MenuItem item) メニュー情報をデータストアに作成する直前にコールされます。
void | AdminMenuQueryWriterListener.queryUpdate(MenuItem item) メニュー情報をデータストアに更新する直前にコールされます。
void | AdminMenuPostWriterListener.postCreate(MenuItem item) メニュー情報をデータストアに作成した直後にコールされます。
void | AdminMenuPostWriterListener.postUpdate(MenuItem item) メニュー情報をデータストアに更新した直後にコールされます。
void | AdminMenuManager.addMenuItem(String parentMenuId, MenuItem menuItem) メニューを追加します。
void | AdminMenuManager.updateMenuItem(MenuItem menuItem) メニューを更新します。
void | AdminMenuAccessor.insertMenuItem(MenuItem menuItem, String parentId) 引数で渡されたノードを新規追加します。
void | AdminMenuAccessor.updateMenuItem(MenuItem menuItem) 引数で渡されたノードを更新します。

MenuItem 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のコンストラクタ
MenuTree(MenuItem menuItem)
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.MenuManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.MenuManager の使用

MenuManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での MenuManager の使用

MenuManager 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuImporter.doImport(InputStream inputStream, MenuManager manager) インポートを行います。
void | MenuExporter.doExport(MenuManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardMenuBackup.doImport(InputStream inputStream, MenuManager manager) インポートを行います。
void | StandardMenuBackup.doExport(MenuManager manager, OutputStream outputStream) エクスポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener の使用

jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener の使用

jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator の使用

jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.MenuTree の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.MenuTree の使用

MenuTree を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での MenuTree の使用

MenuTree を返す jp.co.intra_mart.foundation.security.menu のメソッド
MenuTree[] | MenuTree.getChildren() 子メニューの一覧を取得します。
MenuTree[] | MenuManager.getAccountMenuTree(String userId, String clientType) 指定したアカウントのメニュー構成を取得します。
MenuTree[] | MenuManager.getMenuTree() メニュー構成を取得します。
MenuTree[] | MenuManager.getMenuTree(String clientType) 指定されたクライアントタイプのみのメニュー構成を取得します。
MenuTree[] | MenuManager.getMenuTree(String clientType, String[] menuIds, boolean showNoChildFolder) 指定されたクライアントタイプと指定されたメニューIDのみのメニュー構成を取得します。
MenuTree[] | AdminMenuManager.getMenuTree() メニュー構成を取得します。
MenuTree[] | AdminMenuManager.getMenuTree(String groupId) 引数に指定したログイングループのメニュー構成を取得します。

MenuTree 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
 void MenuTree.addChild(MenuTree menuTree)
子メニューを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener の使用

jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener の使用

jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup の使用

jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.StandardMenuBackup の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.StandardMenuBackup の使用

jp.co.intra_mart.foundation.security.menu.StandardMenuBackup はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AdminMenuAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース AdminMenuAccessor

public interface AdminMenuAccessor

メニューアクセッサインタフェース。

メニュー情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | addMenuLoginGroup(String menuId, String groupId) 管理メニューにアクセス権を設定します。
void | deleteMenuInclusion(MenuInclusion menuInclusion) メニュー構成を削除します。
void | deleteMenuItem(String menuId) 引数で渡されたノードを削除します。
void | deleteMenuLoginGroup(String menuId, String groupId) 管理メニューに設定されているアクセス権を削除します。
String[] | getChildMenuIds(String menuId) 引数で指定されたノードの直下の子ノードを配列で取得します。
String[] | getFirstMenuIds() 第一階層に属するノードを配列で取得します。
String[] | getMenuIds() すべてのメニューIDを取得します。
String[] | getMenuIdsByLoginGroup(String groupId) ログイングループがアクセス可能な管理メニューIDの一覧を取得します。
MenuInclusion[] | getMenuInclusions() すべてのメニュー構成を取得します。
MenuItem | getMenuItem(String menuId) 指定されたメニューIDに対するノードを取得します。
MenuItem[] | getMenuItems() すべてのノードを取得します。
MenuItem[] | getMenuItemsByIds(String[] menuIds) 管理メニューIDの一覧からメニューアイテムを取得します。
String[] | getMenuLoginGroups(String menuId) 管理メニューにアクセス可能なログイングループの一覧を取得します。
String | getParentMenuId(String menuId) 引数で指定されたノードの親ノードを取得します。
void | init(Map params) メニューアクセッサの初期化。
void | insertMenuInclusion(MenuInclusion menuInclusion) メニュー構成を新規に作成します。
void | insertMenuItem(MenuItem menuItem, String parentId) 引数で渡されたノードを新規追加します。
boolean | isAccessControlEnabled(String menuId) メニューアイテムのアクセス権の有無を取得します。
void | setAccessControlEnabled(String menuId, boolean accessControl) メニューアイテムに対するアクセス権を設定します。
void | updateMenuItem(MenuItem menuItem) 引数で渡されたノードを更新します。

メソッドの詳細

deleteMenuInclusion

public void deleteMenuInclusion(MenuInclusion menuInclusion)
                         throws AccessSecurityWriteException
メニュー構成を削除します。

パラメータ:
menuInclusion - メニュー構成
例外:
AccessSecurityWriteException

deleteMenuItem

public void deleteMenuItem(String menuId)
                    throws AccessSecurityWriteException
引数で渡されたノードを削除します。

パラメータ:
menuId - メニューID
例外:
AccessSecurityWriteException

getChildMenuIds

public String[] getChildMenuIds(String menuId)
                         throws AccessSecurityReadException
引数で指定されたノードの直下の子ノードを配列で取得します。

パラメータ:
menuId - メニューID
戻り値:
子メニューIDの配列
例外:
AccessSecurityReadException

getFirstMenuIds

public String[] getFirstMenuIds()
                         throws AccessSecurityReadException
第一階層に属するノードを配列で取得します。

戻り値:
第一階層のメニューIDの配列
例外:
AccessSecurityReadException

getMenuIds

public String[] getMenuIds()
                    throws AccessSecurityReadException
すべてのメニューIDを取得します。

戻り値:
メニューIDの配列
例外:
AccessSecurityReadException

getMenuInclusions

public MenuInclusion[] getMenuInclusions()
                                  throws AccessSecurityReadException
すべてのメニュー構成を取得します。

戻り値:
メニュー構成の配列
例外:
AccessSecurityReadException

getMenuItem

public MenuItem getMenuItem(String menuId)
                     throws AccessSecurityReadException
指定されたメニューIDに対するノードを取得します。

パラメータ:
menuId - メニューID
戻り値:
ノード
例外:
AccessSecurityReadException

getMenuItems

public MenuItem[] getMenuItems()
                        throws AccessSecurityReadException
すべてのノードを取得します。

戻り値:
ノード配列
例外:
AccessSecurityReadException

getParentMenuId

public String getParentMenuId(String menuId)
                       throws AccessSecurityReadException
引数で指定されたノードの親ノードを取得します。

パラメータ:
menuId - メニューID
戻り値:
親メニューID
例外:
AccessSecurityReadException

init

public void init(Map params)
メニューアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

insertMenuInclusion

public void insertMenuInclusion(MenuInclusion menuInclusion)
                         throws AccessSecurityWriteException
メニュー構成を新規に作成します。

パラメータ:
menuInclusion - メニュー構成
例外:
AccessSecurityWriteException

insertMenuItem

public void insertMenuItem(MenuItem menuItem,
                           String parentId)
                    throws AccessSecurityWriteException
引数で渡されたノードを新規追加します。

パラメータ:
menuItem - メニューID
parentId -
例外:
AccessSecurityWriteException

updateMenuItem

public void updateMenuItem(MenuItem menuItem)
                    throws AccessSecurityWriteException
引数で渡されたノードを更新します。

パラメータ:
menuItem - メニュー
例外:
AccessSecurityWriteException

getMenuIdsByLoginGroup

public String[] getMenuIdsByLoginGroup(String groupId)
                                throws AccessSecurityReadException
ログイングループがアクセス可能な管理メニューIDの一覧を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
管理メニューIDの一覧
例外:
AccessSecurityReadException - メニューID取得時に例外が発生
導入されたバージョン:
5.1

getMenuItemsByIds

public MenuItem[] getMenuItemsByIds(String[] menuIds)
                             throws AccessSecurityReadException
管理メニューIDの一覧からメニューアイテムを取得します。

パラメータ:
menuIds - 管理メニューIDの一覧
戻り値:
メニューアイテムの一覧
例外:
AccessSecurityReadException - メニューアイテム取得時に例外が発生
導入されたバージョン:
5.1

addMenuLoginGroup

public void addMenuLoginGroup(String menuId,
                              String groupId)
                       throws AccessSecurityWriteException
管理メニューにアクセス権を設定します。

パラメータ:
menuId - 管理メニューID
groupId - ログイングループID
例外:
AccessSecurityWriteException - アクセス権設定時に例外が発生
導入されたバージョン:
5.1

deleteMenuLoginGroup

public void deleteMenuLoginGroup(String menuId,
                                 String groupId)
                          throws AccessSecurityWriteException
管理メニューに設定されているアクセス権を削除します。

パラメータ:
menuId - 管理メニューID
groupId - ログイングループID
例外:
AccessSecurityWriteException - アクセス権削除時に例外が発生
導入されたバージョン:
5.1

getMenuLoginGroups

public String[] getMenuLoginGroups(String menuId)
                            throws AccessSecurityReadException
管理メニューにアクセス可能なログイングループの一覧を取得します。

パラメータ:
menuId - 管理メニューID
例外:
AccessSecurityReadException - アクセス権取得時に例外が発生
導入されたバージョン:
5.1

setAccessControlEnabled

public void setAccessControlEnabled(String menuId,
                                    boolean accessControl)
                             throws AccessSecurityWriteException
メニューアイテムに対するアクセス権を設定します。 アクセス権を有効にすると、ログイングループ毎にアクセス制限を設定可能です。 未設定の場合はアクセス制限を行いません。

パラメータ:
menuId - メニューID
accessControl - true/有効、false/無効
例外:
AccessSecurityWriteException - アクセス権限設定時に例外が発生

isAccessControlEnabled

public boolean isAccessControlEnabled(String menuId)
                               throws AccessSecurityReadException
メニューアイテムのアクセス権の有無を取得します。

パラメータ:
menuId - メニューID
戻り値:
true/有効、false/無効
例外:
AccessSecurityReadException - アクセス権限取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AdminMenuExporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース AdminMenuExporter

既知の実装クラスの一覧:
StandardAdminMenuBackup
public interface AdminMenuExporter

メニューエクスポートインタフェースです。

バージョン:
1.0

メソッドの概要
void | doExport(AdminMenuManager manager, OutputStream outputStream) エクスポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doExport

public void doExport(AdminMenuManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

メニュー情報をバックアップファイルに出力します。

パラメータ:
manager - メニューマネージャ
outputStream - 出力ストリーム
例外:
AccessSecurityExportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AdminMenuImporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース AdminMenuImporter

既知の実装クラスの一覧:
StandardAdminMenuBackup
public interface AdminMenuImporter

メニューインポートインタフェースです。

バージョン:
1.0

メソッドの概要
void | doImport(InputStream inputStream, AdminMenuManager manager) インポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doImport

public void doImport(InputStream inputStream,
                     AdminMenuManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からメニュー情報を取得し、生成します。

パラメータ:
manager - メニューマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AdminMenuInclusion (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス AdminMenuInclusion

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion
すべての実装インタフェース:
Serializable
public class AdminMenuInclusion
extends Object
implements Serializable

メニュー内包情報クラス。

メニューの親子関係を保持するクラスです。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
AdminMenuInclusion(String parentMenuId, String childMenuId)
コンストラクタ。
メソッドの概要
String | getChildMenuId() 子メニューIDを取得します。
String | getParentMenuId() 親メニューIDを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AdminMenuInclusion

public AdminMenuInclusion(String parentMenuId,
                          String childMenuId)
コンストラクタ。

メソッドの詳細

getChildMenuId

public String getChildMenuId()
子メニューIDを取得します。

戻り値:
子メニューID

getParentMenuId

public String getParentMenuId()
親メニューIDを取得します。

戻り値:
親メニューID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AdminMenuManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス AdminMenuManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.AdminMenuManager
public final class AdminMenuManager
extends Object

管理メニューマネージャクラス。

グループ管理者が利用する管理メニュー情報の操作を行います。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | addMenuItem(String parentMenuId, MenuItem menuItem) メニューを追加します。
void | addMenuLoginGroup(String menuId, String groupId) 指定したログイングループのアクセス権をメニューに設定します。
static void | clearInstance() ログイングループマネージャのインスタンスを初期化します。
void | deleteMenuItem(String menuId) メニューを削除します。
void | deleteMenuItems() すべてのメニューを削除します。
void | deleteMenuLoginGroup(String menuId, String groupId) 指定したログイングループのアクセス権をメニューから削除します。
void | exportData(String category, OutputStream outputStream) メニュー情報・エクスポート。
String[] | getChildMenuIds(String menuId) 子メニューIDを取得します。
String[] | getExportCategories() 管理メニューエクスポート用のカテゴリの一覧を取得します。
String[] | getFirstMenuIds() 第一階層のメニューIDをすべて取得します。
String[] | getImportCategories() 管理メニューインポート用のカテゴリの一覧を取得します。
static AdminMenuManager | getInstance() ログイングループマネージャのインスタンスを取得します。
String[] | getMenuIds() すべてのメニューIDを取得します。
String[] | getMenuIdsByLoginGroup(String groupId) 引き数に指定したログイングループが参照可能なメニューIDの一覧を取得します。
MenuItem | getMenuItem(String menuId) 指定されたメニューIDに対応するメニューを取得します。
MenuItem[] | getMenuItems() すべてのメニューを取得します。
MenuItem[] | getMenuItemsByIds(String[] menuIds) 引き数に指定したメニューIDに一致するメニューアイテムの一覧を取得します。
String[] | getMenuLoginGroups(String menuId) 引数に指定したメニューを参照可能なログイングループIDの一覧を取得します。
MenuTree[] | getMenuTree() メニュー構成を取得します。
MenuTree[] | getMenuTree(String groupId) 引数に指定したログイングループのメニュー構成を取得します。
String | getParentMenuId(String menuId) 指定されたメニューの親メニューを取得します。
void | importData(String category, InputStream inputStream) メニュー情報・インポート。
boolean | isAccessControlEnabled(String menuId) メニューアイテムのアクセス権の有無を取得します。
void | moveMenuItem(MenuInclusion menuInclusion) メニューを移動します。
void | setAccessControlEnabled(String menuId, boolean accessControl) メニューアイテムに対するアクセス権を設定します。
void | updateMenuItem(MenuItem menuItem) メニューを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

clearInstance

public static void clearInstance()
ログイングループマネージャのインスタンスを初期化します。

アクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。
通常、このメソッドを使用する必要はありません。

getInstance

public static AdminMenuManager getInstance()
ログイングループマネージャのインスタンスを取得します。

戻り値:
ログイングループマネージャのインスタンス

addMenuItem

public void addMenuItem(String parentMenuId,
                        MenuItem menuItem)
                 throws AccessSecurityException
メニューを追加します。

パラメータ:
parentMenuId - 親メニューID
nullの場合は、第一階層へ追加される。
例外:
AccessSecurityException - メニューの追加に失敗した場合にスローされます。

addMenuLoginGroup

public void addMenuLoginGroup(String menuId,
                              String groupId)
                       throws AccessSecurityException
指定したログイングループのアクセス権をメニューに設定します。

パラメータ:
menuId - メニューID
groupId - ログイングループID
例外:
AccessSecurityException - アクセス権設定時に例外が発生
導入されたバージョン:
5.1

deleteMenuItem

public void deleteMenuItem(String menuId)
                    throws AccessSecurityException
メニューを削除します。

パラメータ:
menuId - メニューID
例外:
AccessSecurityException

deleteMenuItems

public void deleteMenuItems()
                     throws AccessSecurityException
すべてのメニューを削除します。

例外:
AccessSecurityException

deleteMenuLoginGroup

public void deleteMenuLoginGroup(String menuId,
                                 String groupId)
                          throws AccessSecurityException
指定したログイングループのアクセス権をメニューから削除します。

パラメータ:
menuId - メニューID
groupId - ログイングループID
例外:
AccessSecurityException - アクセス権削除時に例外が発生
導入されたバージョン:
5.1

exportData

public void exportData(String category,
                       OutputStream outputStream)
                throws AccessSecurityException
メニュー情報・エクスポート。

パラメータ:
category - カテゴリ
outputStream - 出力ストリーム
例外:
AccessSecurityException

getChildMenuIds

public String[] getChildMenuIds(String menuId)
                         throws AccessSecurityException
子メニューIDを取得します。

パラメータ:
menuId - 親メニューID
戻り値:
子メニューの配列
例外:
AccessSecurityException

getFirstMenuIds

public String[] getFirstMenuIds()
                         throws AccessSecurityException
第一階層のメニューIDをすべて取得します。

戻り値:
第一階層のメニューIDの配列
例外:
AccessSecurityException

getMenuIds

public String[] getMenuIds()
                    throws AccessSecurityException
すべてのメニューIDを取得します。

戻り値:
メニューIDの配列
例外:
AccessSecurityException

getMenuItem

public MenuItem getMenuItem(String menuId)
                     throws AccessSecurityException
指定されたメニューIDに対応するメニューを取得します。

パラメータ:
menuId - メニューID
戻り値:
メニュー
例外:
AccessSecurityException

getMenuItems

public MenuItem[] getMenuItems()
                        throws AccessSecurityException
すべてのメニューを取得します。

戻り値:
メニューの配列
例外:
AccessSecurityException

getMenuTree

public MenuTree[] getMenuTree()
                       throws AccessSecurityException
メニュー構成を取得します。

戻り値:
メニュー構成の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getMenuTree

public MenuTree[] getMenuTree(String groupId)
                       throws AccessSecurityException
引数に指定したログイングループのメニュー構成を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
メニュー構成の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。
導入されたバージョン:
5.1

getMenuLoginGroups

public String[] getMenuLoginGroups(String menuId)
                            throws AccessSecurityException
引数に指定したメニューを参照可能なログイングループIDの一覧を取得します。

パラメータ:
menuId - メニューID
戻り値:
ログイングループIDの一覧
例外:
AccessSecurityException - メニュー情報取得時に例外発生
導入されたバージョン:
5.1

getParentMenuId

public String getParentMenuId(String menuId)
                       throws AccessSecurityException
指定されたメニューの親メニューを取得します。

パラメータ:
menuId - メニューID
戻り値:
親メニューID
例外:
AccessSecurityException

importData

public void importData(String category,
                       InputStream inputStream)
                throws AccessSecurityException
メニュー情報・インポート。

パラメータ:
category - カテゴリ
inputStream - 入力ストリーム
例外:
AccessSecurityException

moveMenuItem

public void moveMenuItem(MenuInclusion menuInclusion)
                  throws AccessSecurityException
メニューを移動します。

パラメータ:
menuInclusion - 新しいメニュー構成
例外:
AccessSecurityException - メニューの更新に失敗した場合にスローされます。

updateMenuItem

public void updateMenuItem(MenuItem menuItem)
                    throws AccessSecurityException
メニューを更新します。

パラメータ:
menuItem -
例外:
AccessSecurityException

getExportCategories

public String[] getExportCategories()
管理メニューエクスポート用のカテゴリの一覧を取得します。

戻り値:
管理メニューエクスポート用カテゴリの一覧

getImportCategories

public String[] getImportCategories()
管理メニューインポート用のカテゴリの一覧を取得します。

戻り値:
管理メニューインポート用カテゴリの一覧

getMenuIdsByLoginGroup

public String[] getMenuIdsByLoginGroup(String groupId)
                                throws AccessSecurityException
引き数に指定したログイングループが参照可能なメニューIDの一覧を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
メニューIDの一覧
例外:
AccessSecurityException - メニュー情報取得時に例外が発生
導入されたバージョン:
5.1

getMenuItemsByIds

public MenuItem[] getMenuItemsByIds(String[] menuIds)
                             throws AccessSecurityException
引き数に指定したメニューIDに一致するメニューアイテムの一覧を取得します。

パラメータ:
menuIds - メニューID
戻り値:
メニューアイテムの一覧
例外:
AccessSecurityException - メニュー情報取得時に例外発生
導入されたバージョン:
5.1

setAccessControlEnabled

public void setAccessControlEnabled(String menuId,
                                    boolean accessControl)
                             throws AccessSecurityException
メニューアイテムに対するアクセス権を設定します。 アクセス権を有効にすると、ログイングループ毎にアクセス制限を設定可能です。 未設定の場合はアクセス制限を行いません。

パラメータ:
menuId - メニューID
accessControl - true/有効、false/無効
例外:
AccessSecurityException - アクセス権限設定時に例外が発生
導入されたバージョン:
5.1

isAccessControlEnabled

public boolean isAccessControlEnabled(String menuId)
                               throws AccessSecurityException
メニューアイテムのアクセス権の有無を取得します。

パラメータ:
menuId - メニューID
戻り値:
true/有効、false/無効
例外:
AccessSecurityException - アクセス権限取得時に例外が発生
導入されたバージョン:
5.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AdminMenuPostWriterListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース AdminMenuPostWriterListener

public interface AdminMenuPostWriterListener

メニュー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
MenuManager

メソッドの概要
void | init(Map params) メニューリスナーの初期化。
void | postAddMenuLoginGroup(String menuId, String groupId) アクセスを許可するログイングループを追加する直後にコールされます。
void | postCreate(MenuItem item) メニュー情報をデータストアに作成した直後にコールされます。
void | postDelete(String menuId) メニュー情報をデータストアから削除した直後にコールされます。
void | postDeleteMenuLoginGroup(String menuId, String groupId) アクセスを許可するログイングループを削除する直後にコールされます。
void | postMove(String parentId, String childId) メニューの親子関係を更新した直後にコールされます。
void | postSetAccessControlEnabled(String menuId, boolean accessControl) アクセス権限を設定する直前にコールされます。
void | postUpdate(MenuItem item) メニュー情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
メニューリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreate

public void postCreate(MenuItem item)
                throws AccessSecurityListenerExcpetion
メニュー情報をデータストアに作成した直後にコールされます。

パラメータ:
item - 作成されたメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDelete

public void postDelete(String menuId)
                throws AccessSecurityListenerExcpetion
メニュー情報をデータストアから削除した直後にコールされます。

パラメータ:
menuId - 削除されたメニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdate

public void postUpdate(MenuItem item)
                throws AccessSecurityListenerExcpetion
メニュー情報をデータストアに更新した直後にコールされます。

パラメータ:
item - 更新されたメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postMove

public void postMove(String parentId,
                     String childId)
              throws AccessSecurityListenerExcpetion
メニューの親子関係を更新した直後にコールされます。

パラメータ:
parentId - 新しい親メニューID
childId - 新しい子メニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postSetAccessControlEnabled

public void postSetAccessControlEnabled(String menuId,
                                        boolean accessControl)
                                 throws AccessSecurityListenerExcpetion
アクセス権限を設定する直前にコールされます。

パラメータ:
menuId - メニューID
accessControl - true/有効、false/無効
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
導入されたバージョン:
5.1

postAddMenuLoginGroup

public void postAddMenuLoginGroup(String menuId,
                                  String groupId)
                           throws AccessSecurityListenerExcpetion
アクセスを許可するログイングループを追加する直後にコールされます。

パラメータ:
menuId - メニューID
groupId - ログイングループID
例外:
AccessSecurityListenerExcpetion
導入されたバージョン:
5.1

postDeleteMenuLoginGroup

public void postDeleteMenuLoginGroup(String menuId,
                                     String groupId)
                              throws AccessSecurityListenerExcpetion
アクセスを許可するログイングループを削除する直後にコールされます。

パラメータ:
menuId - メニューID
groupId - ログイングループID
例外:
AccessSecurityListenerExcpetion
導入されたバージョン:
5.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AdminMenuQueryWriterListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース AdminMenuQueryWriterListener

public interface AdminMenuQueryWriterListener

メニュー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
MenuManager

メソッドの概要
void | init(Map params) メニューリスナーの初期化。
void | queryAddMenuLoginGroup(String menuId, String groupId) アクセスを許可するログイングループを追加する直前にコールされます。
void | queryCreate(MenuItem item) メニュー情報をデータストアに作成する直前にコールされます。
void | queryDelete(String menuId) メニュー情報をデータストアから削除する直前にコールされます。
void | queryDeleteMenuLoginGroup(String menuId, String groupId) アクセスを許可するログイングループを削除する直前にコールされます。
void | queryMove(String parentId, String childId) メニューの親子関係を更新する直前にコールされます。
void | querySetAccessControlEnabled(String menuId, boolean accessControl) アクセス権限を設定する直前にコールされます。
void | queryUpdate(MenuItem item) メニュー情報をデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
メニューリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreate

public void queryCreate(MenuItem item)
                 throws AccessSecurityListenerExcpetion
メニュー情報をデータストアに作成する直前にコールされます。

パラメータ:
item - 作成されるメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDelete

public void queryDelete(String menuId)
                 throws AccessSecurityListenerExcpetion
メニュー情報をデータストアから削除する直前にコールされます。

パラメータ:
menuId - 削除されるメニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdate

public void queryUpdate(MenuItem item)
                 throws AccessSecurityListenerExcpetion
メニュー情報をデータストアに更新する直前にコールされます。

パラメータ:
item - 更新されるメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryMove

public void queryMove(String parentId,
                      String childId)
               throws AccessSecurityListenerExcpetion
メニューの親子関係を更新する直前にコールされます。

パラメータ:
parentId - 新しい親メニューID
childId - 新しい子メニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

querySetAccessControlEnabled

public void querySetAccessControlEnabled(String menuId,
                                         boolean accessControl)
                                  throws AccessSecurityListenerExcpetion
アクセス権限を設定する直前にコールされます。

パラメータ:
menuId - メニューID
accessControl - true/有効、false/無効
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
導入されたバージョン:
5.1

queryAddMenuLoginGroup

public void queryAddMenuLoginGroup(String menuId,
                                   String groupId)
                            throws AccessSecurityListenerExcpetion
アクセスを許可するログイングループを追加する直前にコールされます。

パラメータ:
menuId - メニューID
groupId - ログイングループID
例外:
AccessSecurityListenerExcpetion
導入されたバージョン:
5.1

queryDeleteMenuLoginGroup

public void queryDeleteMenuLoginGroup(String menuId,
                                      String groupId)
                               throws AccessSecurityListenerExcpetion
アクセスを許可するログイングループを削除する直前にコールされます。

パラメータ:
menuId - メニューID
groupId - ログイングループID
例外:
AccessSecurityListenerExcpetion
導入されたバージョン:
5.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AdminMenuReaderDecorator (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース AdminMenuReaderDecorator

public interface AdminMenuReaderDecorator

メニュー情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
MenuItem | doDecoration(MenuItem item) メニューデータストアからの読み込み直後にコールされます。
void | init(Map params) メニューデコレータの初期化。

メソッドの詳細

init

public void init(Map params)
メニューデコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public MenuItem doDecoration(MenuItem item)
メニューデータストアからの読み込み直後にコールされます。

パラメータ:
item - 読み込みが行われたメニュー情報
戻り値:
拡張されたメニュー情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyChangedMenuListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス CompanyChangedMenuListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener
すべての実装インタフェース:
CompanyChangedListener
public class CompanyChangedMenuListener
extends Object
implements CompanyChangedListener

会社・組織に関する情報の変更時のリスナーです。

導入されたバージョン:
5.0

コンストラクタの概要
CompanyChangedMenuListener()
メソッドの概要
void | categoryDetailRemoved(String groupId, CompanyCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | categoryDetailSet(String groupId, CompanyCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | companyAdded(String groupId, Company company) 会社情報がデータストアに登録された後に呼び出されます。
void | companyDeleted(String groupId, Company company) 会社情報がデータストアから削除された後に呼び出されます。
void | departmentAdded(String groupId, Department department) 組織情報がデータストアに登録された後に呼び出されます。
void | departmentDeleted(String groupId, Department department) 組織情報がデータストアに更新された後に呼び出されます。
void | departmentJoined(String groupId, String company, String parentDepartment, String department, String version) 組織構成がデータストアに登録された後に呼び出されます。
void | departmentLeft(String groupId, String company, String department, String version) 組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
void | departmentMoved(String groupId, String company, String parentDepartment, String department, String version) 組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
void | departmentUpdated(String groupId, Department department) 組織情報がデータストアから削除された後に呼び出されます。
void | init(Map params) 会社リスナーの初期化を行います。
void | mainRemoved(String groupId, DepartmentMain main) 主所属情報がデータストアから削除された後に呼び出されます。
void | mainSet(String groupId, DepartmentMain main) 主所属情報がデータストアに登録された後に呼び出されます。
void | memberDeleted(String groupId, DepartmentAttach attach) 組織からの人員の割当がデータストアから削除された後に呼び出されます。
void | memberSet(String groupId, DepartmentAttach attach) 組織への人員の割当がデータストアに登録された後に呼び出されます。
void | postAdded(String groupId, CompanyPost post) 役職情報がデータストアに登録された後に呼び出されます。
void | postDeleted(String groupId, CompanyPost post) 役職情報がデータストアから削除された後に呼び出されます。
void | postUpdated(String groupId, CompanyPost post) 役職情報がデータストアに更新された後に呼び出されます。
void | setUserId(String userId) ログインユーザIDを設定します。
void | versionAdded(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに登録された後に呼び出されます。
void | versionCopied(String groupId, String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
void | versionDeleted(String groupId, CompanyVersion version) 会社構成バージョンがデータストアから削除された後に呼び出されます。
void | versionUpdated(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに更新された後に呼び出されます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyChangedMenuListener

public CompanyChangedMenuListener()
メソッドの詳細

init

public void init(Map params)
会社リスナーの初期化を行います。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース CompanyChangedListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

setUserId

public void setUserId(String userId)
ログインユーザIDを設定します。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース CompanyChangedListener 内の setUserId
パラメータ:
userId - ログインユーザID

companyAdded

public void companyAdded(String groupId,
                         Company company)
                  throws ChangedListenerException
会社情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の companyAdded
パラメータ:
groupId - ログイングループID
company - 会社情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

companyDeleted

public void companyDeleted(String groupId,
                           Company company)
                    throws ChangedListenerException
会社情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の companyDeleted
パラメータ:
groupId - ログイングループID
company - 会社情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentAdded

public void departmentAdded(String groupId,
                            Department department)
                     throws ChangedListenerException
組織情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentAdded
パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentUpdated

public void departmentUpdated(String groupId,
                              Department department)
                       throws ChangedListenerException
組織情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentUpdated
パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentDeleted

public void departmentDeleted(String groupId,
                              Department department)
                       throws ChangedListenerException
組織情報がデータストアに更新された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentDeleted
パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentJoined

public void departmentJoined(String groupId,
                             String company,
                             String parentDepartment,
                             String department,
                             String version)
                      throws ChangedListenerException
組織構成がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentJoined
パラメータ:
groupId - ログイングループID
company - 会社コード
parentDepartment - 新規登録する組織の上位となる組織の組織コード（または会社の会社コード）
department - 組織情報（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentMoved

public void departmentMoved(String groupId,
                            String company,
                            String parentDepartment,
                            String department,
                            String version)
                     throws ChangedListenerException
組織構成からの組織の移動がデータストアに反映された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentMoved
パラメータ:
groupId - ログイングループID
company - 上位組織と移動対象の組織が所属する会社の会社コード
parentDepartment - 上位組織の組織コード（または会社の会社コード）
department - 移動する組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentLeft

public void departmentLeft(String groupId,
                           String company,
                           String department,
                           String version)
                    throws ChangedListenerException
組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentLeft
パラメータ:
groupId - ログイングループID
company - 会社コード
department - 離脱させる組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailSet

public void categoryDetailSet(String groupId,
                              CompanyCategory category)
                       throws ChangedListenerException
分類区分情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の categoryDetailSet
パラメータ:
groupId - ログイングループID
category - 登録された分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailRemoved

public void categoryDetailRemoved(String groupId,
                                  CompanyCategory category)
                           throws ChangedListenerException
分類区分情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の categoryDetailRemoved
パラメータ:
groupId - ログイングループID
category - 削除された分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberSet

public void memberSet(String groupId,
                      DepartmentAttach attach)
               throws ChangedListenerException
組織への人員の割当がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の memberSet
パラメータ:
groupId - ログイングループID
attach - 割当られた人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberDeleted

public void memberDeleted(String groupId,
                          DepartmentAttach attach)
                   throws ChangedListenerException
組織からの人員の割当がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の memberDeleted
パラメータ:
groupId - ログイングループID
attach - 組織から外された人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

mainSet

public void mainSet(String groupId,
                    DepartmentMain main)
             throws ChangedListenerException
主所属情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の mainSet
パラメータ:
groupId - ログイングループID
main - 主所属情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

mainRemoved

public void mainRemoved(String groupId,
                        DepartmentMain main)
                 throws ChangedListenerException
主所属情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の mainRemoved
パラメータ:
groupId - ログイングループID
main - 主所属情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionAdded

public void versionAdded(String groupId,
                         CompanyVersion version)
                  throws ChangedListenerException
会社構成バージョンがデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の versionAdded
パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionUpdated

public void versionUpdated(String groupId,
                           CompanyVersion version)
                    throws ChangedListenerException
会社構成バージョンがデータストアに更新された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の versionUpdated
パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionDeleted

public void versionDeleted(String groupId,
                           CompanyVersion version)
                    throws ChangedListenerException
会社構成バージョンがデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の versionDeleted
パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionCopied

public void versionCopied(String groupId,
                          String company,
                          String srcVersion,
                          String destVersion,
                          Term term)
                   throws ChangedListenerException
登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の versionCopied
パラメータ:
groupId - ログイングループID
company - コピー元、コピー先の会社構成バージョンの会社コード
srcVersion - コピー元の会社構成バージョンのバージョンコード
destVersion - コピー先の会社構成バージョンのバージョンコード
term - コピー先の会社構成バージョンの期間
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

postAdded

public void postAdded(String groupId,
                      CompanyPost post)
               throws ChangedListenerException
役職情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の postAdded
パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

postUpdated

public void postUpdated(String groupId,
                        CompanyPost post)
                 throws ChangedListenerException
役職情報がデータストアに更新された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の postUpdated
パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

postDeleted

public void postDeleted(String groupId,
                        CompanyPost post)
                 throws ChangedListenerException
役職情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の postDeleted
パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース MenuAccessor

既知の実装クラスの一覧:
StandardMenuAccessor
public interface MenuAccessor

メニューアクセッサインタフェース。

メニュー情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | deleteMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を削除します。
void | deleteMenuDepartments(String groupId, String id) すべてのメニュー組織を削除します。
void | deleteMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を削除します。
void | deleteMenuItem(String groupId, String id) 引数で渡されたノードを削除します。
void | deleteMenuPost(String groupId, String id, PostInfo postInfo) メニュー役職を削除します。
void | deleteMenuPosts(String groupId, String id) すべてのメニュー役職を削除します。
void | deleteMenuPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) メニューパブリックグループを削除します。
void | deleteMenuPublicGroups(String groupId, String id) すべてのメニューパブリックグループを削除します。
void | deleteMenuRole(String groupId, String id, String roleId) メニューロールを削除します。
void | deleteMenuRoles(String groupId, String id) すべてのメニューロールを削除します。
String[] | getChildMenuIds(String groupId, String menuId) 引数で指定されたノードの直下の子ノードを配列で取得します。
String[] | getFirstMenuIds(String groupId) 第一階層に属するノードを配列で取得します。
DepartmentInfo[] | getMenuDepartments(String groupId, String id) すべてのメニュー組織を取得します。
String[] | getMenuIds(String groupId) すべてのメニューIDを取得します。
String[] | getMenuIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つメニューIDをすべて取得します。
String[] | getMenuIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つメニューIDをすべて取得します。
String[] | getMenuIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つメニューIDをすべて取得します。
String[] | getMenuIdsByRole(String groupId, String[] roleIds) 指定されたロールIDを持つメニューIDをすべて取得します。
MenuInclusion[] | getMenuInclusions(String groupId) すべてのメニュー構成を取得します。
MenuItem | getMenuItem(String groupId, String menuId) 指定されたメニューIDに対するノードを取得します。
MenuItem[] | getMenuItems(String groupId) すべてのノードを取得します。
MenuItem[] | getMenuItemsByIds(String groupId, String[] menuIds) 指定されたユーザIDのメニュー情報をすべて取得します。
PostInfo[] | getMenuPosts(String groupId, String id) すべてのメニュー役職を取得します。
PublicGroupInfo[] | getMenuPublicGroups(String groupId, String id) すべてのメニューパブリックグループを取得します。
String[] | getMenuRoles(String groupId, String id) すべてのメニューロールを取得します。
String | getParentMenuId(String groupId, String menuId) 引数で指定されたノードの親ノードを取得します。
void | init(Map params) メニューアクセッサの初期化。
void | insertMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を新規に作成します。
void | insertMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を新規に作成します。
void | insertMenuItem(String groupId, MenuItem menuItem, String parentId) 引数で渡されたノードを新規追加します。
void | insertMenuPost(String groupId, String id, PostInfo postInfo) メニュー役職を新規に作成します。
void | insertMenuPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) メニューパブリックグループを新規に作成します。
void | insertMenuRole(String groupId, String id, String roleId) メニューロールを新規に作成します。
void | updateMenuItem(String groupId, MenuItem menuItem) 引数で渡されたノードを更新します。

メソッドの詳細

deleteMenuDepartment

public void deleteMenuDepartment(String groupId,
                                 String id,
                                 DepartmentInfo departmentInfo)
                          throws AccessSecurityWriteException
メニュー組織を削除します。

パラメータ:
groupId - ログイングループID
id - メニューID
departmentInfo - 組織情報
例外:
AccessSecurityWriteException

deleteMenuDepartments

public void deleteMenuDepartments(String groupId,
                                  String id)
                           throws AccessSecurityWriteException
すべてのメニュー組織を削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException

deleteMenuInclusion

public void deleteMenuInclusion(String groupId,
                                MenuInclusion menuInclusion)
                         throws AccessSecurityWriteException
メニュー構成を削除します。

パラメータ:
groupId - ログイングループID
menuInclusion - メニュー構成
例外:
AccessSecurityWriteException

deleteMenuItem

public void deleteMenuItem(String groupId,
                           String id)
                    throws AccessSecurityWriteException
引数で渡されたノードを削除します。

パラメータ:
groupId -
id -
例外:
AccessSecurityWriteException

deleteMenuPost

public void deleteMenuPost(String groupId,
                           String id,
                           PostInfo postInfo)
                    throws AccessSecurityWriteException
メニュー役職を削除します。

パラメータ:
groupId - ログイングループID
id - メニューID
postInfo - 役職情報
例外:
AccessSecurityWriteException

deleteMenuPosts

public void deleteMenuPosts(String groupId,
                            String id)
                     throws AccessSecurityWriteException
すべてのメニュー役職を削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException

deleteMenuPublicGroup

public void deleteMenuPublicGroup(String groupId,
                                  String id,
                                  PublicGroupInfo publicGroupInfo)
                           throws AccessSecurityWriteException
メニューパブリックグループを削除します。

パラメータ:
groupId - ログイングループID
id - メニューID
publicGroupInfo - パブリックグループ情報
例外:
AccessSecurityWriteException

deleteMenuPublicGroups

public void deleteMenuPublicGroups(String groupId,
                                   String id)
                            throws AccessSecurityWriteException
すべてのメニューパブリックグループを削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException

deleteMenuRole

public void deleteMenuRole(String groupId,
                           String id,
                           String roleId)
                    throws AccessSecurityWriteException
メニューロールを削除します。

パラメータ:
groupId - ログイングループID
id - メニューID
roleId - ロールID
例外:
AccessSecurityWriteException

deleteMenuRoles

public void deleteMenuRoles(String groupId,
                            String id)
                     throws AccessSecurityWriteException
すべてのメニューロールを削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException

getChildMenuIds

public String[] getChildMenuIds(String groupId,
                                String menuId)
                         throws AccessSecurityReadException
引数で指定されたノードの直下の子ノードを配列で取得します。

パラメータ:
groupId - ログイングループID
menuId - メニューID
戻り値:
子メニューIDの配列
例外:
AccessSecurityReadException

getFirstMenuIds

public String[] getFirstMenuIds(String groupId)
                         throws AccessSecurityReadException
第一階層に属するノードを配列で取得します。

パラメータ:
groupId - ログイングループID
戻り値:
第一階層のメニューIDの配列
例外:
AccessSecurityReadException

getMenuDepartments

public DepartmentInfo[] getMenuDepartments(String groupId,
                                           String id)
                                    throws AccessSecurityReadException
すべてのメニュー組織を取得します。

一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
id - メニューID
戻り値:
組織情報の配列
例外:
AccessSecurityReadException

getMenuIds

public String[] getMenuIds(String groupId)
                    throws AccessSecurityReadException
すべてのメニューIDを取得します。

パラメータ:
groupId -
戻り値:
メニューIDの配列
例外:
AccessSecurityReadException

getMenuIdsByDepartment

public String[] getMenuIdsByDepartment(String groupId,
                                       DepartmentInfo[] departments)
                                throws AccessSecurityReadException
指定された組織を持つメニューIDをすべて取得します。

パラメータ:
groupId - ログイングループID
departments - 組織情報の配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - メニュー情報取得に失敗した場合スローされます。

getMenuIdsByPost

public String[] getMenuIdsByPost(String groupId,
                                 PostInfo[] posts)
                          throws AccessSecurityReadException
指定された役職を持つメニューIDをすべて取得します。

パラメータ:
groupId - ログイングループID
posts - 役職情報の配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - メニュー情報取得に失敗した場合スローされます。

getMenuIdsByPublicGroup

public String[] getMenuIdsByPublicGroup(String groupId,
                                        PublicGroupInfo[] publicGroups)
                                 throws AccessSecurityReadException
指定されたパブリックグループを持つメニューIDをすべて取得します。

パラメータ:
groupId - ログイングループID
publicGroups - パブリックグループの配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - メニュー情報取得に失敗した場合スローされます。

getMenuIdsByRole

public String[] getMenuIdsByRole(String groupId,
                                 String[] roleIds)
                          throws AccessSecurityReadException
指定されたロールIDを持つメニューIDをすべて取得します。

パラメータ:
groupId - ログイングループID
roleIds - ロールIDの配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - メニュー情報取得に失敗した場合スローされます。

getMenuInclusions

public MenuInclusion[] getMenuInclusions(String groupId)
                                  throws AccessSecurityReadException
すべてのメニュー構成を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
メニュー構成の配列
例外:
AccessSecurityReadException

getMenuItem

public MenuItem getMenuItem(String groupId,
                            String menuId)
                     throws AccessSecurityReadException
指定されたメニューIDに対するノードを取得します。

パラメータ:
groupId - グループID
menuId - メニューID
戻り値:
ノード
例外:
AccessSecurityReadException

getMenuItems

public MenuItem[] getMenuItems(String groupId)
                        throws AccessSecurityReadException
すべてのノードを取得します。

パラメータ:
groupId -
戻り値:
ノード配列
例外:
AccessSecurityReadException

getMenuItemsByIds

public MenuItem[] getMenuItemsByIds(String groupId,
                                    String[] menuIds)
                             throws AccessSecurityReadException
指定されたユーザIDのメニュー情報をすべて取得します。

パラメータ:
groupId - ログイングループID
menuIds - メニューIDの配列
戻り値:
メニューオブジェクトの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - メニュー情報取得に失敗した場合スローされます。

getMenuPosts

public PostInfo[] getMenuPosts(String groupId,
                               String id)
                        throws AccessSecurityReadException
すべてのメニュー役職を取得します。

一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
id - メニューID
戻り値:
役職情報の配列
例外:
AccessSecurityReadException

getMenuPublicGroups

public PublicGroupInfo[] getMenuPublicGroups(String groupId,
                                             String id)
                                      throws AccessSecurityReadException
すべてのメニューパブリックグループを取得します。

一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
id - メニューID
戻り値:
パブリックグループ情報の配列
例外:
AccessSecurityReadException

getMenuRoles

public String[] getMenuRoles(String groupId,
                             String id)
                      throws AccessSecurityReadException
すべてのメニューロールを取得します。

一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
id - メニューID
戻り値:
メニューロールIDの配列
例外:
AccessSecurityReadException

getParentMenuId

public String getParentMenuId(String groupId,
                              String menuId)
                       throws AccessSecurityReadException
引数で指定されたノードの親ノードを取得します。

パラメータ:
groupId - ログイングループID
menuId - メニューID
戻り値:
親メニューID
例外:
AccessSecurityReadException

init

public void init(Map params)
メニューアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

insertMenuDepartment

public void insertMenuDepartment(String groupId,
                                 String id,
                                 DepartmentInfo departmentInfo)
                          throws AccessSecurityWriteException
メニュー組織を新規に作成します。

パラメータ:
groupId - ログイングループID
id - メニューID
departmentInfo - 組織情報
例外:
AccessSecurityWriteException

insertMenuInclusion

public void insertMenuInclusion(String groupId,
                                MenuInclusion menuInclusion)
                         throws AccessSecurityWriteException
メニュー構成を新規に作成します。

パラメータ:
groupId - ログイングループID
menuInclusion - メニュー構成
例外:
AccessSecurityWriteException

insertMenuItem

public void insertMenuItem(String groupId,
                           MenuItem menuItem,
                           String parentId)
                    throws AccessSecurityWriteException
引数で渡されたノードを新規追加します。

パラメータ:
groupId -
menuItem -
parentId -
例外:
AccessSecurityWriteException

insertMenuPost

public void insertMenuPost(String groupId,
                           String id,
                           PostInfo postInfo)
                    throws AccessSecurityWriteException
メニュー役職を新規に作成します。

パラメータ:
groupId - ログイングループID
id - メニューID
postInfo - 役職情報
例外:
AccessSecurityWriteException

insertMenuPublicGroup

public void insertMenuPublicGroup(String groupId,
                                  String id,
                                  PublicGroupInfo publicGroupInfo)
                           throws AccessSecurityWriteException
メニューパブリックグループを新規に作成します。

パラメータ:
groupId - ログイングループID
id - メニューID
publicGroupInfo - パブリックグループ情報
例外:
AccessSecurityWriteException

insertMenuRole

public void insertMenuRole(String groupId,
                           String id,
                           String roleId)
                    throws AccessSecurityWriteException
メニューロールを新規に作成します。

パラメータ:
groupId - ログイングループID
id - メニューID
roleId - ロールID
例外:
AccessSecurityWriteException

updateMenuItem

public void updateMenuItem(String groupId,
                           MenuItem menuItem)
                    throws AccessSecurityWriteException
引数で渡されたノードを更新します。

パラメータ:
groupId - ログイングループID
menuItem - メニュー
例外:
AccessSecurityWriteException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuExporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース MenuExporter

既知の実装クラスの一覧:
StandardMenuBackup
public interface MenuExporter

メニューエクスポートインタフェースです。

バージョン:
1.0

メソッドの概要
void | doExport(MenuManager manager, OutputStream outputStream) エクスポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doExport

public void doExport(MenuManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

メニュー情報をバックアップファイルに出力します。

パラメータ:
manager - メニューマネージャ
outputStream - 出力ストリーム
例外:
AccessSecurityExportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuImporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース MenuImporter

既知の実装クラスの一覧:
StandardMenuBackup
public interface MenuImporter

メニューインポートインタフェースです。

バージョン:
1.0

メソッドの概要
void | doImport(InputStream inputStream, MenuManager manager) インポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doImport

public void doImport(InputStream inputStream,
                     MenuManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からメニュー情報を取得し、生成します。

パラメータ:
manager - メニューマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuInclusion (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス MenuInclusion

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.MenuInclusion
すべての実装インタフェース:
Serializable
public class MenuInclusion
extends Object
implements Serializable

メニュー内包情報クラス。

メニューの親子関係を保持するクラスです。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
MenuInclusion(String parentMenuId, String childMenuId)
コンストラクタ。
メソッドの概要
String | getChildMenuId() 子メニューIDを取得します。
String | getKeyString() メニュー内包情報の識別子を取得します。
String | getParentMenuId() 親メニューIDを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MenuInclusion

public MenuInclusion(String parentMenuId,
                     String childMenuId)
コンストラクタ。

メソッドの詳細

getChildMenuId

public String getChildMenuId()
子メニューIDを取得します。

戻り値:
子メニューID

getParentMenuId

public String getParentMenuId()
親メニューIDを取得します。

戻り値:
親メニューID

getKeyString

public String getKeyString()
メニュー内包情報の識別子を取得します。

戻り値:
メニュー内包情報の識別子
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuItem (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス MenuItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.MenuItem
すべての実装インタフェース:
Serializable
public class MenuItem
extends Object
implements Serializable

メニュー・モデルクラス。 メニューのデータモデルを定義します

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
MenuManager, 直列化された形式

フィールドの概要
static String | CONTENT_TYPE_IN メニューコンテンツの種類（内部URL）。
static String | CONTENT_TYPE_OUT メニューコンテンツの種類（外部URL）。
static String | MENU_TYPE_FOLDER メニュータイプ（フォルダ）。
static String | MENU_TYPE_ITEM メニュータイプ（アイテム）。
コンストラクタの概要
MenuItem()
コンストラクタ。
MenuItem(String id)
コンストラクタ。
メソッドの概要
boolean | equals(Object obj) このオブジェクトと他のオブジェクトが等しいかどうかを示します。
String | getArgument(String key) 引数を取得します。
String[] | getArgumentKeys() 引数キーの一覧を取得します。
String | getClientType() クライアントタイプを取します。
String | getContents() コンテンツの種類を取得します。
String | getDescription() 説明を取得します。
String | getDisplayName(Locale locale) メニュー名を取得します。
String | getId() メニューIDを取得します。
String | getImagePath() メニューイメージパスを取得します。
Locale[] | getLocales() メニュー名として保管されているロケールの一覧を取得します。
int | getSortNumber() ソート番号を取得します。
String | getType() ノードのタイプを取得します。
String | getUrl() URLを取得します。
int | hashCode() ハッシュコードを取得します。
void | removeArgument(String key) 引数を削除します。
void | removeDisplayName(Locale locale) ロケールに対応したメニュー名を削除します。
void | setArgument(String key, String value) 引数を設定します。
void | setClientType(String clientType) クライアントタイプを設定します。
void | setContents(String contents) コンテンツの種類を設定します。
void | setDescription(String description) 説明を設定します。
void | setDisplayName(Locale locale, String displayName) メニュー名を設定します。
void | setId(String id) メニューIDを設定します。
void | setImagePath(String imagePath) メニューイメージパスを設定します。
void | setSortNumber(int sortNumber) ソート番号を設定します。
void | setType(String type) ノードのタイプを設定します。
void | setUrl(String url) URLを設定します。
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

CONTENT_TYPE_IN

public static final String CONTENT_TYPE_IN
メニューコンテンツの種類（内部URL）。

関連項目:
定数フィールド値

CONTENT_TYPE_OUT

public static final String CONTENT_TYPE_OUT
メニューコンテンツの種類（外部URL）。

関連項目:
定数フィールド値

MENU_TYPE_FOLDER

public static final String MENU_TYPE_FOLDER
メニュータイプ（フォルダ）。

関連項目:
定数フィールド値

MENU_TYPE_ITEM

public static final String MENU_TYPE_ITEM
メニュータイプ（アイテム）。

関連項目:
定数フィールド値
コンストラクタの詳細

MenuItem

public MenuItem()
コンストラクタ。

メニューIDは自動採番されます。

MenuItem

public MenuItem(String id)
コンストラクタ。

パラメータ:
id - メニューID
メソッドの詳細

equals

public boolean equals(Object obj)
このオブジェクトと他のオブジェクトが等しいかどうかを示します。

パラメータ:
obj - 比較対象の参照オブジェクト
戻り値:
引数に指定されたオブジェクトとこのオブジェクトが等しい場合は true、そうでない場合は false
関連項目:
Object.equals(java.lang.Object)

getArgument

public String getArgument(String key)
引数を取得します。

パラメータ:
key - 属性のキー
戻り値:
属性値

getArgumentKeys

public String[] getArgumentKeys()
引数キーの一覧を取得します。

戻り値:
引数キーの配列

getClientType

public String getClientType()
クライアントタイプを取します。

戻り値:
クライアントタイプ

getContents

public String getContents()
コンテンツの種類を取得します。

戻り値:
コンテンツの種類

getDescription

public String getDescription()
説明を取得します。

戻り値:
説明

getDisplayName

public String getDisplayName(Locale locale)
メニュー名を取得します。

パラメータ:
locale - ロケール名
戻り値:
メニュー名

getId

public String getId()
メニューIDを取得します。

戻り値:
メニューID

getLocales

public Locale[] getLocales()
メニュー名として保管されているロケールの一覧を取得します。

戻り値:
メニュー名として保管されているロケールの配列

getSortNumber

public int getSortNumber()
ソート番号を取得します。

戻り値:
ソート番号

getType

public String getType()
ノードのタイプを取得します。

返却される値は、フォルダ( MENU_TYPE_FOLDER)、またはアイテム(MENU_TYPE_ITEM)です。

戻り値:
ノードのタイプ

getUrl

public String getUrl()
URLを取得します。

戻り値:
URL

hashCode

public int hashCode()
ハッシュコードを取得します。

戻り値:
ハッシュコード
関連項目:
Object.hashCode()

removeArgument

public void removeArgument(String key)
引数を削除します。

パラメータ:
key - 引数キー

removeDisplayName

public void removeDisplayName(Locale locale)
ロケールに対応したメニュー名を削除します。

パラメータ:
locale - ロケール

setArgument

public void setArgument(String key,
                        String value)
引数を設定します。

パラメータ:
key - 引数キー
value - 引数値

setClientType

public void setClientType(String clientType)
クライアントタイプを設定します。

パラメータ:
clientType - クライアントタイプ

setContents

public void setContents(String contents)
コンテンツの種類を設定します。

パラメータ:
contents - コンテンツの種類

setDescription

public void setDescription(String description)
説明を設定します。

パラメータ:
description - 説明

setDisplayName

public void setDisplayName(Locale locale,
                           String displayName)
メニュー名を設定します。

パラメータ:
locale - ロケール名
displayName - メニュー名

setId

public void setId(String id)
メニューIDを設定します。

パラメータ:
id - メニューID

setSortNumber

public void setSortNumber(int sortNumber)
ソート番号を設定します。

パラメータ:
sortNumber - ソート番号

setType

public void setType(String type)
ノードのタイプを設定します。

設定できる値は、フォルダ( MENU_TYPE_FOLDER)、またはアイテム(MENU_TYPE_ITEM)です。
上記の値以外を設定した場合は、アイテム( MENU_TYPE_ITEM)に設定されます。

パラメータ:
type - メニュータイプ

setUrl

public void setUrl(String url)
URLを設定します。

パラメータ:
url - URL

getImagePath

public String getImagePath()
メニューイメージパスを取得します。

戻り値:
イメージパス

setImagePath

public void setImagePath(String imagePath)
メニューイメージパスを設定します。

パラメータ:
imagePath - イメージパス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス MenuManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.MenuManager
public final class MenuManager
extends Object

メニューマネージャクラス。

メニュー情報の操作を行います。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
MenuManager(String groupId)
コンストラクタ。
メソッドの概要
void | addMenuDepartment(String menuId, DepartmentInfo departmentInfo) 組織をメニューに紐付けます。
void | addMenuItem(String parentMenuId, MenuItem menuItem) メニューを追加します。
void | addMenuPost(String menuId, PostInfo postInfo) 役職をメニューに紐付けます。
void | addMenuPublicGroup(String menuId, PublicGroupInfo publicGroupInfo) パブリックグループをメニューに紐付けます。
void | addMenuRole(String menuId, String roleId) ロールをメニューに紐付けます。
static void | clearInstance() メニューマネージャのインスタンスを初期化します。
void | deleteMenuDepartment(String menuId, DepartmentInfo departmentInfo) 組織の紐付けをメニューから削除します。
void | deleteMenuDepartments(String menuId) 組織の紐付けをメニューからすべて削除します。
void | deleteMenuItem(String menuId) メニューを削除します。
void | deleteMenuItems() すべてのメニューを削除します。
void | deleteMenuPost(String menuId, PostInfo postInfo) 役織の紐付けをメニューから削除します。
void | deleteMenuPosts(String menuId) 役織の紐付けをメニューからすべて削除します。
void | deleteMenuPublicGroup(String menuId, PublicGroupInfo publicGroupInfo) パブリックグループの紐付けをメニューから削除します。
void | deleteMenuPublicGroups(String menuId) パブリックグループの紐付けをメニューからすべて削除します。
void | deleteMenuRole(String menuId, String roleId) ロールの紐付けをメニューから削除します。
void | deleteMenuRoles(String menuId) ロールの紐付けをメニューから削除します。
void | exportData(String category, OutputStream outputStream) メニュー情報をエクスポートします。
MenuTree[] | getAccountMenuTree(String userId, String clientType) 指定したアカウントのメニュー構成を取得します。
String[] | getChildMenuIds(String menuId) 子メニューIDを取得します。
String[] | getExportCategories() メニューエクスポート用のカテゴリの一覧を取得します。
String[] | getFirstMenuIds() 第一階層のメニューIDをすべて取得します。
String[] | getImportCategories() メニューインポート用のカテゴリの一覧を取得します。
String | getLoginGroupId() ログイングループIDを取得します。
DepartmentInfo[] | getMenuDepartments(String menuId) メニューに紐付いた組織の一覧を取得します。
String[] | getMenuIds() すべてのメニューIDを取得します。
String[] | getMenuIdsByDepartment(DepartmentInfo[] departments) 指定された組織を持つメニューIDをすべて取得します。
String[] | getMenuIdsByPost(PostInfo[] posts) 指定された役職を持つメニューIDをすべて取得します。
String[] | getMenuIdsByPublicGroup(PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つメニューIDをすべて取得します。
String[] | getMenuIdsByRole(String[] roleIds) 指定されたロールIDを持つメニューIDをすべて取得します。
MenuItem | getMenuItem(String menuId) 指定されたメニューIDに対応するメニューを取得します。
MenuItem[] | getMenuItems() すべてのメニューを取得します。
MenuItem[] | getMenuItemsByIds(String[] menuIds) ログイングループ内で引数指定したメニューIDのメニュー情報をすべて取得します。
PostInfo[] | getMenuPosts(String menuId) メニューに紐付いた役職の一覧を取得します。
PublicGroupInfo[] | getMenuPublicGroups(String menuId) メニューに紐付いたパブリックグループの一覧を取得します。
String[] | getMenuRoles(String menuId) メニューに紐付いたロールの一覧を取得します。
MenuTree[] | getMenuTree() メニュー構成を取得します。
MenuTree[] | getMenuTree(String clientType) 指定されたクライアントタイプのみのメニュー構成を取得します。
MenuTree[] | getMenuTree(String clientType, String[] menuIds, boolean showNoChildFolder) 指定されたクライアントタイプと指定されたメニューIDのみのメニュー構成を取得します。
String | getParentMenuId(String menuId) 指定されたメニューの親メニューを取得します。
void | importData(String category, InputStream inputStream) メニュー情報をインポートします。
boolean | isUpdate(Date date) メニュー情報が指定された日付よりも新しいかチェックします。
void | moveMenuItem(MenuInclusion menuInclusion) メニューを移動します。
void | updateMenuItem(MenuItem menuItem) メニューを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MenuManager

public MenuManager(String groupId)
            throws AccessSecurityException
コンストラクタ。

ログイングループ単位のメニューを操作するマネージャーを作成します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityException - ログイングループIDが不正な場合にスローされます。
メソッドの詳細

clearInstance

public static void clearInstance()
メニューマネージャのインスタンスを初期化します。

アクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。
通常、このメソッドを使用する必要はありません。

addMenuDepartment

public void addMenuDepartment(String menuId,
                              DepartmentInfo departmentInfo)
                       throws AccessSecurityException
組織をメニューに紐付けます。

パラメータ:
menuId - メニューID
departmentInfo - 組織情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

addMenuItem

public void addMenuItem(String parentMenuId,
                        MenuItem menuItem)
                 throws AccessSecurityException
メニューを追加します。

パラメータ:
parentMenuId - 親メニューID
nullの場合は、第一階層へ追加されます。
menuItem - メニュー
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

addMenuPost

public void addMenuPost(String menuId,
                        PostInfo postInfo)
                 throws AccessSecurityException
役職をメニューに紐付けます。

パラメータ:
menuId - メニューID
postInfo - 役職情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

addMenuPublicGroup

public void addMenuPublicGroup(String menuId,
                               PublicGroupInfo publicGroupInfo)
                        throws AccessSecurityException
パブリックグループをメニューに紐付けます。

パラメータ:
menuId - メニューID
publicGroupInfo - パブリックグループ
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

addMenuRole

public void addMenuRole(String menuId,
                        String roleId)
                 throws AccessSecurityException
ロールをメニューに紐付けます。

パラメータ:
menuId - メニューID
roleId - ロールID
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuDepartment

public void deleteMenuDepartment(String menuId,
                                 DepartmentInfo departmentInfo)
                          throws AccessSecurityException
組織の紐付けをメニューから削除します。

パラメータ:
menuId - メニューID
departmentInfo - 組織情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuDepartments

public void deleteMenuDepartments(String menuId)
                           throws AccessSecurityException
組織の紐付けをメニューからすべて削除します。

パラメータ:
menuId - メニューID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuItem

public void deleteMenuItem(String menuId)
                    throws AccessSecurityException
メニューを削除します。

パラメータ:
menuId - メニューID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuItems

public void deleteMenuItems()
                     throws AccessSecurityException
すべてのメニューを削除します。

例外:
AccessSecurityException - 削除処理に失敗した場合にスローされます。

deleteMenuPost

public void deleteMenuPost(String menuId,
                           PostInfo postInfo)
                    throws AccessSecurityException
役織の紐付けをメニューから削除します。

パラメータ:
menuId - メニューID
postInfo - 役織情報
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuPosts

public void deleteMenuPosts(String menuId)
                     throws AccessSecurityException
役織の紐付けをメニューからすべて削除します。

パラメータ:
menuId - メニューID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuPublicGroup

public void deleteMenuPublicGroup(String menuId,
                                  PublicGroupInfo publicGroupInfo)
                           throws AccessSecurityException
パブリックグループの紐付けをメニューから削除します。

パラメータ:
menuId - メニューID
publicGroupInfo - パブリックグループ
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuPublicGroups

public void deleteMenuPublicGroups(String menuId)
                            throws AccessSecurityException
パブリックグループの紐付けをメニューからすべて削除します。

パラメータ:
menuId - メニューID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuRole

public void deleteMenuRole(String menuId,
                           String roleId)
                    throws AccessSecurityException
ロールの紐付けをメニューから削除します。

パラメータ:
menuId - メニューID
roleId - ロールID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuRoles

public void deleteMenuRoles(String menuId)
                     throws AccessSecurityException
ロールの紐付けをメニューから削除します。

パラメータ:
menuId - メニューID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

exportData

public void exportData(String category,
                       OutputStream outputStream)
                throws AccessSecurityException
メニュー情報をエクスポートします。

パラメータ:
category - カテゴリ
outputStream - 出力ストリーム
例外:
AccessSecurityException - エクスポートに失敗した場合、または引数が不正だった場合にスローされます。

getAccountMenuTree

public MenuTree[] getAccountMenuTree(String userId,
                                     String clientType)
                              throws AccessSecurityException
指定したアカウントのメニュー構成を取得します。

このメソッドはメニューの絞り込みにPermissionManagerを利用しています。
PermissionManagerでメニューの絞り込みに利用されるカテゴリは、'account-menu'です。

パラメータ:
userId - ユーザID
clientType - クライアントタイプ
戻り値:
メニュー構成の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getChildMenuIds

public String[] getChildMenuIds(String menuId)
                         throws AccessSecurityException
子メニューIDを取得します。

パラメータ:
menuId - 親メニューID
戻り値:
子メニューIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getExportCategories

public String[] getExportCategories()
                             throws AccessSecurityException
メニューエクスポート用のカテゴリの一覧を取得します。

戻り値:
メニューエクスポート用カテゴリの一覧
例外:
AccessSecurityException - メニューエクスポート用のカテゴリの取得に失敗した場合にスローされます。

getFirstMenuIds

public String[] getFirstMenuIds()
                         throws AccessSecurityException
第一階層のメニューIDをすべて取得します。

戻り値:
第一階層のメニューIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getImportCategories

public String[] getImportCategories()
                             throws AccessSecurityException
メニューインポート用のカテゴリの一覧を取得します。

戻り値:
メニューインポート用カテゴリの一覧
例外:
AccessSecurityException - メニューインポート用のカテゴリの取得に失敗した場合にスローされます。

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

戻り値:
ログイングループID

getMenuDepartments

public DepartmentInfo[] getMenuDepartments(String menuId)
                                    throws AccessSecurityException
メニューに紐付いた組織の一覧を取得します。

パラメータ:
menuId - メニューID
戻り値:
組織情報の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getMenuIds

public String[] getMenuIds()
                    throws AccessSecurityException
すべてのメニューIDを取得します。

戻り値:
メニューIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getMenuIdsByDepartment

public String[] getMenuIdsByDepartment(DepartmentInfo[] departments)
                                throws AccessSecurityException
指定された組織を持つメニューIDをすべて取得します。

パラメータ:
departments - 組織情報の配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityException - メニュー情報取得に失敗した場合スローされます。

getMenuIdsByPost

public String[] getMenuIdsByPost(PostInfo[] posts)
                          throws AccessSecurityException
指定された役職を持つメニューIDをすべて取得します。

パラメータ:
posts - 役職情報の配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityException - メニュー情報取得に失敗した場合スローされます。

getMenuIdsByPublicGroup

public String[] getMenuIdsByPublicGroup(PublicGroupInfo[] publicGroups)
                                 throws AccessSecurityException
指定されたパブリックグループを持つメニューIDをすべて取得します。

パラメータ:
publicGroups - パブリックグループの配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityException - メニュー情報取得に失敗した場合スローされます。

getMenuIdsByRole

public String[] getMenuIdsByRole(String[] roleIds)
                          throws AccessSecurityException
指定されたロールIDを持つメニューIDをすべて取得します。

パラメータ:
roleIds - ロールIDの配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityException - メニュー情報取得に失敗した場合スローされます。

getMenuItem

public MenuItem getMenuItem(String menuId)
                     throws AccessSecurityException
指定されたメニューIDに対応するメニューを取得します。

パラメータ:
menuId - メニューID
戻り値:
メニュー
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getMenuItems

public MenuItem[] getMenuItems()
                        throws AccessSecurityException
すべてのメニューを取得します。

戻り値:
メニュー情報の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getMenuItemsByIds

public MenuItem[] getMenuItemsByIds(String[] menuIds)
                             throws AccessSecurityException
ログイングループ内で引数指定したメニューIDのメニュー情報をすべて取得します。

パラメータ:
menuIds - メニューIDの配列
戻り値:
メニュー情報の配列（データがない場合は空の配列を返します。）
例外:
AccessSecurityException - メニュー情報の取得に失敗した場合にスローされます。

getMenuPosts

public PostInfo[] getMenuPosts(String menuId)
                        throws AccessSecurityException
メニューに紐付いた役職の一覧を取得します。

パラメータ:
menuId - メニューID
戻り値:
役職情報の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getMenuPublicGroups

public PublicGroupInfo[] getMenuPublicGroups(String menuId)
                                      throws AccessSecurityException
メニューに紐付いたパブリックグループの一覧を取得します。

パラメータ:
menuId - メニューID
戻り値:
パブリックグループの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getMenuRoles

public String[] getMenuRoles(String menuId)
                      throws AccessSecurityException
メニューに紐付いたロールの一覧を取得します。

パラメータ:
menuId - メニューID
戻り値:
ロールIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getMenuTree

public MenuTree[] getMenuTree()
                       throws AccessSecurityException
メニュー構成を取得します。

戻り値:
メニュー構成の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getMenuTree

public MenuTree[] getMenuTree(String clientType)
                       throws AccessSecurityException
指定されたクライアントタイプのみのメニュー構成を取得します。

パラメータ:
clientType - クライアントタイプ この値がnullの場合は、すべてのクライアントタイプが対象となります。
戻り値:
メニュー構成の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getMenuTree

public MenuTree[] getMenuTree(String clientType,
                              String[] menuIds,
                              boolean showNoChildFolder)
                       throws AccessSecurityException
指定されたクライアントタイプと指定されたメニューIDのみのメニュー構成を取得します。

パラメータ:
clientType - クライアントタイプ
この値がnullの場合は、すべてのクライアントタイプが対象となります。
menuIds - 作成対象のメニューIDの配列
この値がnullの場合は、すべてのメニューIDが対象となります。
showNoChildFolder - 子メニューを持た持たないフォルダーを表示するかどうか
戻り値:
メニュー構成の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getParentMenuId

public String getParentMenuId(String menuId)
                       throws AccessSecurityException
指定されたメニューの親メニューを取得します。

メニューIDがトップメニューであった場合は、nullを返却します。

パラメータ:
menuId - メニューID
戻り値:
親メニューID
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

importData

public void importData(String category,
                       InputStream inputStream)
                throws AccessSecurityException
メニュー情報をインポートします。

パラメータ:
category - カテゴリ
inputStream - 入力ストリーム
例外:
AccessSecurityException - インポートに失敗した場合、または引数が不正だった場合にスローされます。

moveMenuItem

public void moveMenuItem(MenuInclusion menuInclusion)
                  throws AccessSecurityException
メニューを移動します。

パラメータ:
menuInclusion - 新しいメニュー構成
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または書き込み処理に失敗した場合にスローされます。

updateMenuItem

public void updateMenuItem(MenuItem menuItem)
                    throws AccessSecurityException
メニューを更新します。

パラメータ:
menuItem - メニュー情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

isUpdate

public boolean isUpdate(Date date)
                 throws AccessSecurityException
メニュー情報が指定された日付よりも新しいかチェックします。

パラメータ:
date - チェック日付
例外:
AccessSecurityReadException - 更新チェックに失敗した場合スローされます。
AccessSecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuPostWriterListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース MenuPostWriterListener

public interface MenuPostWriterListener

メニュー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
MenuManager

メソッドの概要
void | init(Map params) メニューリスナーの初期化。
void | postCreate(String groupId, MenuItem item) メニュー情報をデータストアに作成した直後にコールされます。
void | postDelete(String groupId, String menuId) メニュー情報をデータストアから削除した直後にコールされます。
void | postMove(String groupId, String parentId, String childId) メニューの親子関係を更新した直後にコールされます。
void | postUpdate(String groupId, MenuItem item) メニュー情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
メニューリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreate

public void postCreate(String groupId,
                       MenuItem item)
                throws AccessSecurityListenerExcpetion
メニュー情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
item - 作成されたメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDelete

public void postDelete(String groupId,
                       String menuId)
                throws AccessSecurityListenerExcpetion
メニュー情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
menuId - 削除されたメニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdate

public void postUpdate(String groupId,
                       MenuItem item)
                throws AccessSecurityListenerExcpetion
メニュー情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
item - 更新されたメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postMove

public void postMove(String groupId,
                     String parentId,
                     String childId)
              throws AccessSecurityListenerExcpetion
メニューの親子関係を更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
parentId - 新しい親メニューID
childId - 新しい子メニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuQueryWriterListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース MenuQueryWriterListener

public interface MenuQueryWriterListener

メニュー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
MenuManager

メソッドの概要
void | init(Map params) メニューリスナーの初期化。
void | queryCreate(String groupId, MenuItem item) メニュー情報をデータストアに作成する直前にコールされます。
void | queryDelete(String groupId, String menuId) メニュー情報をデータストアから削除する直前にコールされます。
void | queryMove(String groupId, String parentId, String childId) メニューの親子関係を更新する直前にコールされます。
void | queryUpdate(String groupId, MenuItem item) メニュー情報をデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
メニューリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreate

public void queryCreate(String groupId,
                        MenuItem item)
                 throws AccessSecurityListenerExcpetion
メニュー情報をデータストアに作成する直前にコールされます。

パラメータ:
groupId - ログイングループID
item - 作成されるメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDelete

public void queryDelete(String groupId,
                        String menuId)
                 throws AccessSecurityListenerExcpetion
メニュー情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
menuId - 削除されるメニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdate

public void queryUpdate(String groupId,
                        MenuItem item)
                 throws AccessSecurityListenerExcpetion
メニュー情報をデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
item - 更新されるメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryMove

public void queryMove(String groupId,
                      String parentId,
                      String childId)
               throws AccessSecurityListenerExcpetion
メニューの親子関係を更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
parentId - 新しい親メニューID
childId - 新しい子メニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuReaderDecorator (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース MenuReaderDecorator

public interface MenuReaderDecorator

メニュー情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
MenuItem | doDecoration(String groupId, MenuItem item) メニューデータストアからの読み込み直後にコールされます。
void | init(Map params) メニューデコレータの初期化。

メソッドの詳細

init

public void init(Map params)
メニューデコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public MenuItem doDecoration(String groupId,
                             MenuItem item)
メニューデータストアからの読み込み直後にコールされます。

パラメータ:
groupId - ログイングループID
item - 読み込みが行われたメニュー情報
戻り値:
拡張されたメニュー情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MenuTree (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス MenuTree

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.MenuTree
すべての実装インタフェース:
Comparator
public class MenuTree
extends Object
implements Comparator

メニューツリークラス。

メニューをツリー形式で保管するクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
MenuTree(MenuItem menuItem)
コンストラクタ。
メソッドの概要
void | addChild(MenuTree menuTree) 子メニューを追加します。
int | compare(Object o1, Object o2) 順序付けのために 2 つの引数を比較します。
void | deleteChild(String menuId) 子メニューを削除します。
boolean | equals(Object obj) このオブジェクトと他のオブジェクトが等しいかどうかを示します。
MenuTree[] | getChildren() 子メニューの一覧を取得します。
MenuItem | getMenuItem() メニューを取得します。
boolean | hasChildren() 子メニューが存在するかどうかを取得します。
int | hashCode() ハッシュコードを取得します。
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MenuTree

public MenuTree(MenuItem menuItem)
コンストラクタ。

パラメータ:
menuItem - メニュー
メソッドの詳細

addChild

public void addChild(MenuTree menuTree)
子メニューを追加します。

パラメータ:
menuTree - 子メニューのMenuTree

compare

public int compare(Object o1,
                   Object o2)
順序付けのために 2 つの引数を比較します。

定義:
インタフェース Comparator 内の compare
パラメータ:
o1 - 比較対象の最初のオブジェクト
o2 - 比較対象の 2 番目のオブジェクト
戻り値:
最初の引数が 2 番目の引数より小さい場合は負の整数、両方が等しい場合は 0、最初の引数が 2 番目の引数より大きい場合は正の整数
関連項目:
Comparator.compare(java.lang.Object, java.lang.Object)

deleteChild

public void deleteChild(String menuId)
子メニューを削除します。

パラメータ:
menuId - メニューID

equals

public boolean equals(Object obj)
このオブジェクトと他のオブジェクトが等しいかどうかを示します。

定義:
インタフェース Comparator 内の equals
パラメータ:
obj - 比較対象の参照オブジェクト
戻り値:
引数に指定されたオブジェクトとこのオブジェクトが等しい場合は true、そうでない場合は false
関連項目:
Object.equals(java.lang.Object)

getChildren

public MenuTree[] getChildren()
子メニューの一覧を取得します。

戻り値:
子メニュー(MenuTree)の配列

hasChildren

public boolean hasChildren()
子メニューが存在するかどうかを取得します。

戻り値:
true : 子メニューあり / false : 子メニューなし

getMenuItem

public MenuItem getMenuItem()
メニューを取得します。

戻り値:
メニュー

hashCode

public int hashCode()
ハッシュコードを取得します。

戻り値:
ハッシュコード
関連項目:
Object.hashCode()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.menu (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.security.menu
インタフェース
AdminMenuAccessor
AdminMenuExporter
AdminMenuImporter
AdminMenuPostWriterListener
AdminMenuQueryWriterListener
AdminMenuReaderDecorator
MenuAccessor
MenuExporter
MenuImporter
MenuPostWriterListener
MenuQueryWriterListener
MenuReaderDecorator
クラス
AdminMenuInclusion
AdminMenuManager
CompanyChangedMenuListener
MenuInclusion
MenuItem
MenuManager
MenuTree
PublicGroupChangedMenuListener
RoleChangedMenuListener
StandardAdminMenuBackup
StandardMenuBackup


jp.co.intra_mart.foundation.security.menu (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.menu

メニューに関連するクラスを提供します。

参照:
説明

インタフェースの概要
AdminMenuAccessor | メニューアクセッサインタフェース。
AdminMenuExporter | メニューエクスポートインタフェースです。
AdminMenuImporter | メニューインポートインタフェースです。
AdminMenuPostWriterListener | メニュー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AdminMenuQueryWriterListener | メニュー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
AdminMenuReaderDecorator | メニュー情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
MenuAccessor | メニューアクセッサインタフェース。
MenuExporter | メニューエクスポートインタフェースです。
MenuImporter | メニューインポートインタフェースです。
MenuPostWriterListener | メニュー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
MenuQueryWriterListener | メニュー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
MenuReaderDecorator | メニュー情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

クラスの概要
AdminMenuInclusion | メニュー内包情報クラス。
AdminMenuManager | 管理メニューマネージャクラス。
CompanyChangedMenuListener | 会社・組織に関する情報の変更時のリスナーです。
MenuInclusion | メニュー内包情報クラス。
MenuItem | メニュー・モデルクラス。
MenuManager | メニューマネージャクラス。
MenuTree | メニューツリークラス。
PublicGroupChangedMenuListener | パブリックグループに関する情報の変更時のリスナーです。
RoleChangedMenuListener | ロールが削除された場合にメニューに紐付くロールを削除するリスナークラス。
StandardAdminMenuBackup | メニューバックアップクラスです。
StandardMenuBackup | メニューバックアップクラスです。

パッケージ jp.co.intra_mart.foundation.security.menu の説明

メニューに関連するクラスを提供します。


jp.co.intra_mart.foundation.security.menu クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.menu の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.AdminMenuManager
    • class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener)
    • class jp.co.intra_mart.foundation.security.menu.MenuInclusion (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.MenuItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.MenuManager
    • class jp.co.intra_mart.foundation.security.menu.MenuTree (implements java.util.Comparator)
    • class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener (implements jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener)
    • class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener (implements jp.co.intra_mart.foundation.security.role.RoleChangedListener)
    • class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup (implements jp.co.intra_mart.foundation.security.menu.AdminMenuExporter, jp.co.intra_mart.foundation.security.menu.AdminMenuImporter)
    • class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup (implements jp.co.intra_mart.foundation.security.menu.MenuExporter, jp.co.intra_mart.foundation.security.menu.MenuImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuExporter
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuImporter
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator
  • interface jp.co.intra_mart.foundation.security.menu.MenuAccessor
  • interface jp.co.intra_mart.foundation.security.menu.MenuExporter
  • interface jp.co.intra_mart.foundation.security.menu.MenuImporter
  • interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator


パッケージ jp.co.intra_mart.foundation.security.menu の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.menu の使用

jp.co.intra_mart.foundation.security.menu を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security により使用される jp.co.intra_mart.foundation.security.menu のクラス
MenuAccessor
メニューアクセッサインタフェース。
MenuInclusion
メニュー内包情報クラス。
MenuItem
メニュー・モデルクラス。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.security.menu のクラス
AdminMenuExporter
メニューエクスポートインタフェースです。
AdminMenuImporter
メニューインポートインタフェースです。
AdminMenuManager
管理メニューマネージャクラス。
MenuExporter
メニューエクスポートインタフェースです。
MenuImporter
メニューインポートインタフェースです。
MenuInclusion
メニュー内包情報クラス。
MenuItem
メニュー・モデルクラス。
MenuManager
メニューマネージャクラス。
MenuTree
メニューツリークラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupChangedMenuListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス PublicGroupChangedMenuListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener
すべての実装インタフェース:
PublicGroupChangedListener
public class PublicGroupChangedMenuListener
extends Object
implements PublicGroupChangedListener

パブリックグループに関する情報の変更時のリスナーです。

導入されたバージョン:
5.0

コンストラクタの概要
PublicGroupChangedMenuListener()
メソッドの概要
void | categoryDetailRemoved(String groupId, PublicGroupCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | categoryDetailSet(String groupId, PublicGroupCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | groupSetAdded(String groupId, PublicGroupSet groupSet) グループセットがデータストアに登録された後に呼び出されます。
void | groupSetDeleted(String groupId, PublicGroupSet groupSet) グループセットがデータストアから削除された後に呼び出されます。
void | init(Map params) アカウントリスナーの初期化を行います。
void | memberDeleted(String groupId, PublicGroupAttach attach) パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
void | memberSet(String groupId, PublicGroupAttach attach) パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
void | publicGroupAdded(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに登録された後に呼び出されます。
void | publicGroupDeleted(String groupId, PublicGroup publicGroup) パブリックグループがデータストアから削除された後に呼び出されます。
void | publicGroupJoined(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
void | publicGroupLeft(String groupId, String groupSet, String publicGroup, String version) パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
void | publicGroupMoved(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
void | publicGroupUpdated(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに更新された後に呼び出されます。
void | setUesrId(String userid) ログインユーザIDを設定します。
void | versionAdded(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
void | versionCopied(String groupId, String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
void | versionDeleted(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
void | versionUpdated(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupChangedMenuListener

public PublicGroupChangedMenuListener()
メソッドの詳細

init

public void init(Map params)
アカウントリスナーの初期化を行います。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

setUesrId

public void setUesrId(String userid)
ログインユーザIDを設定します。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の setUesrId
パラメータ:
userid - ログインユーザID

groupSetAdded

public void groupSetAdded(String groupId,
                          PublicGroupSet groupSet)
                   throws ChangedListenerException
グループセットがデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の groupSetAdded
パラメータ:
groupId - ログイングループID
groupSet - グループセット
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

groupSetDeleted

public void groupSetDeleted(String groupId,
                            PublicGroupSet groupSet)
                     throws ChangedListenerException
グループセットがデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の groupSetDeleted
パラメータ:
groupId - ログイングループID
groupSet - グループセット
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupAdded

public void publicGroupAdded(String groupId,
                             PublicGroup publicGroup)
                      throws ChangedListenerException
パブリックグループがデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupAdded
パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupUpdated

public void publicGroupUpdated(String groupId,
                               PublicGroup publicGroup)
                        throws ChangedListenerException
パブリックグループがデータストアに更新された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupUpdated
パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupDeleted

public void publicGroupDeleted(String groupId,
                               PublicGroup publicGroup)
                        throws ChangedListenerException
パブリックグループがデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupDeleted
パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupJoined

public void publicGroupJoined(String groupId,
                              String groupSet,
                              String parentGroup,
                              String publicGroup,
                              String version)
                       throws ChangedListenerException
パブリックグループ構成情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupJoined
パラメータ:
groupId - ログイングループID
groupSet - 上位パブリックグループと新規登録されるパブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup - 新規登録するパブリックグループの上位となるパブリックグループのグループコード（またはパブリックグループセットのグループセットコード）
publicGroup - パブリックグループ情報（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupMoved

public void publicGroupMoved(String groupId,
                             String groupSet,
                             String parentGroup,
                             String publicGroup,
                             String version)
                      throws ChangedListenerException
パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupMoved
パラメータ:
groupId - ログイングループID
groupSet - 上位パブリックグループと移動対象のパブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup - 上位パブリックグループのグループコード（またはパブリックグループセットのグループセットコード）
publicGroup - 移動するパブリックグループのグループコード（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupLeft

public void publicGroupLeft(String groupId,
                            String groupSet,
                            String publicGroup,
                            String version)
                     throws ChangedListenerException
パブリックグループ構成情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupLeft
パラメータ:
groupId - ログイングループID
groupSet - グループセットコード
publicGroup - 離脱させるパブリックグループのグループコード（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailSet

public void categoryDetailSet(String groupId,
                              PublicGroupCategory category)
                       throws ChangedListenerException
分類区分情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の categoryDetailSet
パラメータ:
groupId - ログイングループID
category - 分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailRemoved

public void categoryDetailRemoved(String groupId,
                                  PublicGroupCategory category)
                           throws ChangedListenerException
分類区分情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の categoryDetailRemoved
パラメータ:
groupId - ログイングループID
category - 分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberSet

public void memberSet(String groupId,
                      PublicGroupAttach attach)
               throws ChangedListenerException
パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の memberSet
パラメータ:
groupId - ログイングループID
attach - 割当られた人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberDeleted

public void memberDeleted(String groupId,
                          PublicGroupAttach attach)
                   throws ChangedListenerException
パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の memberDeleted
パラメータ:
groupId - ログイングループID
attach - パブリックグループから外された人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionAdded

public void versionAdded(String groupId,
                         PublicGroupVersion version)
                  throws ChangedListenerException
パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の versionAdded
パラメータ:
groupId - ログイングループID
version - パブリックグループ構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionUpdated

public void versionUpdated(String groupId,
                           PublicGroupVersion version)
                    throws ChangedListenerException
パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の versionUpdated
パラメータ:
groupId - ログイングループID
version - パブリックグループセット構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionDeleted

public void versionDeleted(String groupId,
                           PublicGroupVersion version)
                    throws ChangedListenerException
パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の versionDeleted
パラメータ:
groupId - ログイングループID
version - パブリックグループセット構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionCopied

public void versionCopied(String groupId,
                          String groupSet,
                          String srcVersion,
                          String destVersion,
                          Term term)
                   throws ChangedListenerException
登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の versionCopied
パラメータ:
groupId - ログイングループID
groupSet - コピー元、コピー先のパブリックグループセット構成バージョンのパブリックグループコード
srcVersion - コピー元のパブリックグループセット構成バージョンのバージョンコード
destVersion - コピー先のパブリックグループセット構成バージョンのバージョンコード
term - コピー先のパブリックグループセット構成バージョンの期間
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleChangedMenuListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス RoleChangedMenuListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener
すべての実装インタフェース:
RoleChangedListener
public class RoleChangedMenuListener
extends Object
implements RoleChangedListener

ロールが削除された場合にメニューに紐付くロールを削除するリスナークラス。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
RoleChangedMenuListener()
コンストラクタ。
メソッドの概要
void | init(Map params) ロールリスナーの初期化。
void | roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | roleDeleted(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | subRoleAdded(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | subRoleDeleted(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RoleChangedMenuListener

public RoleChangedMenuListener()
コンストラクタ。

メソッドの詳細

init

public void init(Map params)
ロールリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース RoleChangedListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

roleAdded

public void roleAdded(String groupId,
                      Role role)
               throws ChangedListenerException
ロール情報をデータストアに作成した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の roleAdded
パラメータ:
groupId - ログイングループID
role - 作成されたロール
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

roleDeleted

public void roleDeleted(String groupId,
                        String roleId)
                 throws ChangedListenerException
ロール情報をデータストアから削除した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の roleDeleted
パラメータ:
groupId - ログイングループID
roleId - 削除されたロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

roleUpdated

public void roleUpdated(String groupId,
                        Role role)
                 throws ChangedListenerException
ロール情報をデータストアに更新した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の roleUpdated
パラメータ:
groupId - ログイングループID
role - 更新されたロール
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

subRoleAdded

public void subRoleAdded(String groupId,
                         String roleId,
                         String subRoleId)
                  throws ChangedListenerException
ロールにサブロールを追加した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の subRoleAdded
パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 追加されたサブロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

subRoleDeleted

public void subRoleDeleted(String groupId,
                           String roleId,
                           String subRoleId)
                    throws ChangedListenerException
ロールからサブロールを削除した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の subRoleDeleted
パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 削除されたサブロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardAdminMenuBackup (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス StandardAdminMenuBackup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup
すべての実装インタフェース:
AdminMenuExporter, AdminMenuImporter
public class StandardAdminMenuBackup
extends Object
implements AdminMenuImporter, AdminMenuExporter

メニューバックアップクラスです。

バージョン:
1.0

コンストラクタの概要
StandardAdminMenuBackup()
メソッドの概要
void | doExport(AdminMenuManager manager, OutputStream outputStream) エクスポートを行います。
void | doImport(InputStream inputStream, AdminMenuManager manager) インポートを行います。
void | init(Map params) 初期化。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardAdminMenuBackup

public StandardAdminMenuBackup()
メソッドの詳細

init

public void init(Map params)
初期化。

初期化します。

定義:
インタフェース AdminMenuImporter 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     AdminMenuManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からメニュー情報を生成します。

定義:
インタフェース AdminMenuImporter 内の doImport
パラメータ:
manager - メニューマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

doExport

public void doExport(AdminMenuManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

メニューバックアップ情報を生成し、ストリームに返却します。

定義:
インタフェース AdminMenuExporter 内の doExport
パラメータ:
manager - メニューマネージャクラス
outputStream - 出力ストリーム
例外:
AccessSecurityExportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardMenuBackup (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス StandardMenuBackup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.StandardMenuBackup
すべての実装インタフェース:
MenuExporter, MenuImporter
public class StandardMenuBackup
extends Object
implements MenuImporter, MenuExporter

メニューバックアップクラスです。

バージョン:
1.0

コンストラクタの概要
StandardMenuBackup()
メソッドの概要
void | doExport(MenuManager manager, OutputStream outputStream) エクスポートを行います。
void | doImport(InputStream inputStream, MenuManager manager) インポートを行います。
void | init(Map params) 初期化。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardMenuBackup

public StandardMenuBackup()
メソッドの詳細

init

public void init(Map params)
初期化。

初期化します。

定義:
インタフェース MenuImporter 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     MenuManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からメニュー情報を生成します。

定義:
インタフェース MenuImporter 内の doImport
パラメータ:
manager - メニューマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

doExport

public void doExport(MenuManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

メニューバックアップ情報を生成し、ストリームに返却します。

定義:
インタフェース MenuExporter 内の doExport
パラメータ:
manager - メニューマネージャクラス
outputStream - 出力ストリーム
例外:
AccessSecurityExportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.message.MessageManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.message.MessageManager の使用

MessageManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.message メッセージに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.message での MessageManager の使用

MessageManager を返す jp.co.intra_mart.foundation.security.message のメソッド
static MessageManager MessageManager.getInstance()
メッセージマネージャのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


MessageManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.message
クラス MessageManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.message.MessageManager
public class MessageManager
extends Object

メッセージマネージャクラス。

メッセージを取得するクラス。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
static MessageManager | getInstance() メッセージマネージャのインスタンスを取得します。
String | getMessage(Locale locale, String key) メッセージを取得します。
String | getMessage(Locale locale, String key, String arg) メッセージを取得します。
String | getMessage(Locale locale, String key, String[] args) メッセージを取得します。
String | getMessage(Locale locale, String key, String arg1, String arg2) メッセージを取得します。
String | getMessage(Locale locale, String key, String arg1, String arg2, String arg3) メッセージを取得します。
String | getMessage(String key) メッセージを取得します。
String | getMessage(String key, String arg) メッセージを取得します。
String | getMessage(String key, String[] args) メッセージを取得します。
String | getMessage(String key, String arg1, String arg2) メッセージを取得します。
String | getMessage(String key, String arg1, String arg2, String arg3) メッセージを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getInstance

public static MessageManager getInstance()
メッセージマネージャのインスタンスを取得します。

戻り値:
メッセージマネージャのインスタンス

getMessage

public String getMessage(Locale locale,
                         String key)
                  throws AccessSecurityException
メッセージを取得します。

指定ロケールでメッセージを取得します。

パラメータ:
locale - 指定ロケール
key - メッセージキー名
戻り値:
アクセスセキュリティメッセージ
例外:
AccessSecurityException - 引数が不正な場合にスローされます。

getMessage

public String getMessage(Locale locale,
                         String key,
                         String arg)
                  throws AccessSecurityException
メッセージを取得します。

指定ロケールでメッセージを取得します。
引数に置換文字列を１つ取ります。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。
よってメッセージキー名により取得されるメッセージの内容を上記メソッドの第1引数に渡して処理しますので、
対応するメッセージの内容（propertiesファイルの内容）は、MessageFormatのpattern文字列に沿ったメッセージを記述してください。

置換文字列を利用した場合,取得結果に対して
"'"を表現するには"''"
"{"を表現するには"'{"
を対象のメッセージに記述してください。

パラメータ:
locale - 指定ロケール
key - メッセージキー名
arg - 置換文字列
戻り値:
置換文字列をを挿入したメッセージ
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。

getMessage

public String getMessage(Locale locale,
                         String key,
                         String arg1,
                         String arg2)
                  throws AccessSecurityException
メッセージを取得します。

指定ロケールでメッセージを取得します。
引数に置換文字列を２つ取ります。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。
よってメッセージキー名により取得されるメッセージの内容を上記メソッドの第1引数に渡して処理しますので、
対応するメッセージの内容（propertiesファイルの内容）は、MessageFormatのpattern文字列に沿ったメッセージを記述してください。

置換文字列を利用した場合,取得結果に対して
"'"を表現するには"''"
"{"を表現するには"'{"
を対象のメッセージに記述してください。

パラメータ:
locale - 指定ロケール
key - メッセージキー名
arg1 - 置換文字列１
arg2 - 置換文字列２
戻り値:
置換文字列をを挿入したメッセージ
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。

getMessage

public String getMessage(Locale locale,
                         String key,
                         String arg1,
                         String arg2,
                         String arg3)
                  throws AccessSecurityException
メッセージを取得します。

指定ロケールでメッセージを取得します。
引数に置換文字列を３つ取ります。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。
よってメッセージキー名により取得されるメッセージの内容を上記メソッドの第1引数に渡して処理しますので、
対応するメッセージの内容（propertiesファイルの内容）は、MessageFormatのpattern文字列に沿ったメッセージを記述してください。

置換文字列を利用した場合,取得結果に対して
"'"を表現するには"''"
"{"を表現するには"'{"
を対象のメッセージに記述してください。

パラメータ:
locale - 指定ロケール
key - メッセージキー名
arg1 - 置換文字列１
arg2 - 置換文字列２
arg3 - 置換文字列３
戻り値:
置換文字列をを挿入したメッセージ
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。

getMessage

public String getMessage(Locale locale,
                         String key,
                         String[] args)
                  throws AccessSecurityException
メッセージを取得します。

指定ロケールでメッセージを取得します。
引数に置換文字列の配列を取ります。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。
よってメッセージキー名により取得されるメッセージの内容を上記メソッドの第1引数に渡して処理しますので、
対応するメッセージの内容（propertiesファイルの内容）は、MessageFormatのpattern文字列に沿ったメッセージを記述してください。

置換文字列を利用した場合,取得結果に対して
"'"を表現するには"''"
"{"を表現するには"'{"
を対象のメッセージに記述してください。

置換文字列の配列に空の配列を指定した場合、MessageFormat#format関数を利用しませんので、取得したメッセージを変換せずにそのまま返却します。

パラメータ:
locale - 指定ロケール
key - メッセージキー名
args - 置換文字列の配列
戻り値:
置換文字列をを挿入したメッセージ
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。

getMessage

public String getMessage(String key)
                  throws AccessSecurityException
メッセージを取得します。

現在ログインしているユーザのロケールでメッセージを取得します。

パラメータ:
key - メッセージキー名
戻り値:
メッセージ
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。

getMessage

public String getMessage(String key,
                         String arg)
                  throws AccessSecurityException
メッセージを取得します。

現在ログインしているユーザのロケールでメッセージを取得します。
引数に置換文字列を１つ取ります。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。
よってメッセージキー名により取得されるメッセージの内容を上記メソッドの第1引数に渡して処理しますので、
対応するメッセージの内容（propertiesファイルの内容）は、MessageFormatのpattern文字列に沿ったメッセージを記述してください。

置換文字列を利用した場合,取得結果に対して
"'"を表現するには"''"
"{"を表現するには"'{"
を対象のメッセージに記述してください。

パラメータ:
key - メッセージキー名
arg - 置換文字列
戻り値:
置換文字列をを挿入したメッセージ
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。

getMessage

public String getMessage(String key,
                         String arg1,
                         String arg2)
                  throws AccessSecurityException
メッセージを取得します。

現在ログインしているユーザのロケールでメッセージを取得します。
引数に置換文字列を２つ取ります。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。
よってメッセージキー名により取得されるメッセージの内容を上記メソッドの第1引数に渡して処理しますので、
対応するメッセージの内容（propertiesファイルの内容）は、MessageFormatのpattern文字列に沿ったメッセージを記述してください。

置換文字列を利用した場合,取得結果に対して
"'"を表現するには"''"
"{"を表現するには"'{"
を対象のメッセージに記述してください。

パラメータ:
key - メッセージキー名
arg1 - 置換文字列１
arg2 - 置換文字列２
戻り値:
置換文字列をを挿入したメッセージ
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。

getMessage

public String getMessage(String key,
                         String arg1,
                         String arg2,
                         String arg3)
                  throws AccessSecurityException
メッセージを取得します。

現在ログインしているユーザのロケールでメッセージを取得します。
引数に置換文字列を３つ取ります。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。
よってメッセージキー名により取得されるメッセージの内容を上記メソッドの第1引数に渡して処理しますので、
対応するメッセージの内容（propertiesファイルの内容）は、MessageFormatのpattern文字列に沿ったメッセージを記述してください。

置換文字列を利用した場合,取得結果に対して
"'"を表現するには"''"
"{"を表現するには"'{"
を対象のメッセージに記述してください。

パラメータ:
key - メッセージキー名
arg1 - 置換文字列１
arg2 - 置換文字列２
arg3 - 置換文字列３
戻り値:
置換文字列をを挿入したメッセージ
例外:
AccessSecurityException - 引数が不正な場合にスローされます。

getMessage

public String getMessage(String key,
                         String[] args)
                  throws AccessSecurityException
メッセージを取得します。

現在ログインしているユーザのロケールでメッセージを取得します。
引数に置換文字列の配列を取ります。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。
よってメッセージキー名により取得されるメッセージの内容を上記メソッドの第1引数に渡して処理しますので、
対応するメッセージの内容（propertiesファイルの内容）は、MessageFormatのpattern文字列に沿ったメッセージを記述してください。

置換文字列を利用した場合,取得結果に対して
"'"を表現するには"''"
"{"を表現するには"'{"
を対象のメッセージに記述してください。

置換文字列の配列に空の配列を指定した場合、MessageFormat#format関数を利用しませんので、取得したメッセージを変換せずにそのまま返却します。

パラメータ:
key - メッセージキー名
args - 置換文字列の配列
戻り値:
置換文字列をを挿入したメッセージ
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.message (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.security.message
クラス
MessageManager


jp.co.intra_mart.foundation.security.message (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.message

メッセージに関連するクラスを提供します。

参照:
説明

クラスの概要
MessageManager メッセージマネージャクラス。

パッケージ jp.co.intra_mart.foundation.security.message の説明

メッセージに関連するクラスを提供します。


jp.co.intra_mart.foundation.security.message クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.message の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.message.MessageManager


パッケージ jp.co.intra_mart.foundation.security.message の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.message の使用

jp.co.intra_mart.foundation.security.message を使用しているパッケージ
jp.co.intra_mart.foundation.security.message メッセージに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.message により使用される jp.co.intra_mart.foundation.security.message のクラス
MessageManager
メッセージマネージャクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuAnalyzer の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuAnalyzer の使用

jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuAnalyzer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuHdmlAnalyzer の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuHdmlAnalyzer の使用

jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuHdmlAnalyzer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoAnalyzer の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoAnalyzer の使用

jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoAnalyzer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoMoveAnalyzer の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoMoveAnalyzer の使用

jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoMoveAnalyzer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginJphoneAnalyzer の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginJphoneAnalyzer の使用

jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginJphoneAnalyzer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginSoftBankAnalyzer の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginSoftBankAnalyzer の使用

jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginSoftBankAnalyzer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginVodafoneAnalyzer の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginVodafoneAnalyzer の使用

jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginVodafoneAnalyzer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider の使用

MobileUserAgentProvider を使用しているパッケージ
jp.co.intra_mart.foundation.security.mobile

jp.co.intra_mart.foundation.security.mobile での MobileUserAgentProvider の使用

MobileUserAgentProvider を実装している jp.co.intra_mart.foundation.security.mobile のクラス
class | MobileEasyLoginAuAnalyzer モバイル端末固体識別番号取得プロバイダクラス Au用(WAP2.0)
class | MobileEasyLoginAuHdmlAnalyzer 推奨されていません。
class | MobileEasyLoginDocomoAnalyzer モバイル端末固体識別番号取得プロバイダクラス NTT DoCoMo用(FOMA)
class | MobileEasyLoginDocomoMoveAnalyzer 推奨されていません。
class | MobileEasyLoginJphoneAnalyzer 推奨されていません。
class | MobileEasyLoginSoftBankAnalyzer モバイル端末固体識別番号取得プロバイダクラス SoftBank用(3GC型)
class | MobileEasyLoginVodafoneAnalyzer モバイル端末固体識別番号取得プロバイダクラス Vodafone用(3GC型)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


MobileEasyLoginAuAnalyzer (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.mobile
クラス MobileEasyLoginAuAnalyzer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuAnalyzer
すべての実装インタフェース:
MobileUserAgentProvider
public class MobileEasyLoginAuAnalyzer
extends Object
implements MobileUserAgentProvider

モバイル端末固体識別番号取得プロバイダクラス Au用(WAP2.0)

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
MobileEasyLoginAuAnalyzer()
メソッドの概要
boolean | checkMobile(String userAgent, HttpServletRequest request) モバイル端末の種別をチェックします。
String | getUserAgent(String userAgent, HttpServletRequest request) モバイル端末固体識別番号を取得します。
void | init(Node node) モバイル端末固体識別番号取得プロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MobileEasyLoginAuAnalyzer

public MobileEasyLoginAuAnalyzer()
メソッドの詳細

init

public void init(Node node)
モバイル端末固体識別番号取得プロバイダの初期化を行います。

定義:
インタフェース MobileUserAgentProvider 内の init
パラメータ:
node - ノード

checkMobile

public boolean checkMobile(String userAgent,
                           HttpServletRequest request)
モバイル端末の種別をチェックします。

定義:
インタフェース MobileUserAgentProvider 内の checkMobile
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
対象のモバイル端末の場合は true を返却します。

getUserAgent

public String getUserAgent(String userAgent,
                           HttpServletRequest request)
モバイル端末固体識別番号を取得します。 モバイル端末固体識別番号が取得できなかった場合はnullを返却します。

定義:
インタフェース MobileUserAgentProvider 内の getUserAgent
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
固体識別番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MobileEasyLoginAuHdmlAnalyzer (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.mobile
クラス MobileEasyLoginAuHdmlAnalyzer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuHdmlAnalyzer
すべての実装インタフェース:
MobileUserAgentProvider

public class MobileEasyLoginAuHdmlAnalyzer
extends Object
implements MobileUserAgentProvider

モバイル端末固体識別番号取得プロバイダクラス Au用(HDML)

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
MobileEasyLoginAuHdmlAnalyzer()
推奨されていません。
メソッドの概要
boolean | checkMobile(String userAgent, HttpServletRequest request) 推奨されていません。 モバイル端末の種別をチェックします。
String | getUserAgent(String userAgent, HttpServletRequest request) 推奨されていません。 モバイル端末固体識別番号を取得します。
void | init(Node node) 推奨されていません。 モバイル端末固体識別番号取得プロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MobileEasyLoginAuHdmlAnalyzer

public MobileEasyLoginAuHdmlAnalyzer()
推奨されていません。
メソッドの詳細

init

public void init(Node node)
推奨されていません。
モバイル端末固体識別番号取得プロバイダの初期化を行います。

定義:
インタフェース MobileUserAgentProvider 内の init
パラメータ:
node - ノード

checkMobile

public boolean checkMobile(String userAgent,
                           HttpServletRequest request)
推奨されていません。
モバイル端末の種別をチェックします。

定義:
インタフェース MobileUserAgentProvider 内の checkMobile
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
対象のモバイル端末の場合は true を返却します。

getUserAgent

public String getUserAgent(String userAgent,
                           HttpServletRequest request)
推奨されていません。
モバイル端末固体識別番号を取得します。 モバイル端末固体識別番号が取得できなかった場合はnullを返却します。

定義:
インタフェース MobileUserAgentProvider 内の getUserAgent
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
固体識別番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MobileEasyLoginDocomoAnalyzer (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.mobile
クラス MobileEasyLoginDocomoAnalyzer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoAnalyzer
すべての実装インタフェース:
MobileUserAgentProvider
public class MobileEasyLoginDocomoAnalyzer
extends Object
implements MobileUserAgentProvider

モバイル端末固体識別番号取得プロバイダクラス NTT DoCoMo用(FOMA)

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
MobileEasyLoginDocomoAnalyzer()
メソッドの概要
boolean | checkMobile(String userAgent, HttpServletRequest request) モバイル端末の種別をチェックします。
String | getUserAgent(String userAgent, HttpServletRequest request) モバイル端末固体識別番号を取得します。
void | init(Node node) モバイル端末固体識別番号取得プロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MobileEasyLoginDocomoAnalyzer

public MobileEasyLoginDocomoAnalyzer()
メソッドの詳細

init

public void init(Node node)
モバイル端末固体識別番号取得プロバイダの初期化を行います。

定義:
インタフェース MobileUserAgentProvider 内の init
パラメータ:
node - ノード

checkMobile

public boolean checkMobile(String userAgent,
                           HttpServletRequest request)
モバイル端末の種別をチェックします。

定義:
インタフェース MobileUserAgentProvider 内の checkMobile
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
対象のモバイル端末の場合は true を返却します。

getUserAgent

public String getUserAgent(String userAgent,
                           HttpServletRequest request)
モバイル端末固体識別番号を取得します。 モバイル端末固体識別番号が取得できなかった場合はnullを返却します。

定義:
インタフェース MobileUserAgentProvider 内の getUserAgent
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
固体識別番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MobileEasyLoginDocomoMoveAnalyzer (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.mobile
クラス MobileEasyLoginDocomoMoveAnalyzer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoMoveAnalyzer
すべての実装インタフェース:
MobileUserAgentProvider

public class MobileEasyLoginDocomoMoveAnalyzer
extends Object
implements MobileUserAgentProvider

モバイル端末固体識別番号取得プロバイダクラス NTT DoCoMo用(move)

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
MobileEasyLoginDocomoMoveAnalyzer()
推奨されていません。
メソッドの概要
boolean | checkMobile(String userAgent, HttpServletRequest request) 推奨されていません。 モバイル端末の種別をチェックします。
String | getUserAgent(String userAgent, HttpServletRequest request) 推奨されていません。 モバイル端末固体識別番号を取得します。
void | init(Node node) 推奨されていません。 モバイル端末固体識別番号取得プロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MobileEasyLoginDocomoMoveAnalyzer

public MobileEasyLoginDocomoMoveAnalyzer()
推奨されていません。
メソッドの詳細

init

public void init(Node node)
推奨されていません。
モバイル端末固体識別番号取得プロバイダの初期化を行います。

定義:
インタフェース MobileUserAgentProvider 内の init
パラメータ:
node - ノード

checkMobile

public boolean checkMobile(String userAgent,
                           HttpServletRequest request)
推奨されていません。
モバイル端末の種別をチェックします。

定義:
インタフェース MobileUserAgentProvider 内の checkMobile
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
対象のモバイル端末の場合は true を返却します。

getUserAgent

public String getUserAgent(String userAgent,
                           HttpServletRequest request)
推奨されていません。
モバイル端末固体識別番号を取得します。 モバイル端末固体識別番号が取得できなかった場合はnullを返却します。

定義:
インタフェース MobileUserAgentProvider 内の getUserAgent
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
固体識別番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MobileEasyLoginJphoneAnalyzer (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.mobile
クラス MobileEasyLoginJphoneAnalyzer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginJphoneAnalyzer
すべての実装インタフェース:
MobileUserAgentProvider

public class MobileEasyLoginJphoneAnalyzer
extends Object
implements MobileUserAgentProvider

モバイル端末固体識別番号取得プロバイダクラス J-PHONE用

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
MobileEasyLoginJphoneAnalyzer()
推奨されていません。
メソッドの概要
boolean | checkMobile(String userAgent, HttpServletRequest request) 推奨されていません。 モバイル端末の種別をチェックします。
String | getUserAgent(String userAgent, HttpServletRequest request) 推奨されていません。 モバイル端末固体識別番号を取得します。
void | init(Node node) 推奨されていません。 モバイル端末固体識別番号取得プロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MobileEasyLoginJphoneAnalyzer

public MobileEasyLoginJphoneAnalyzer()
推奨されていません。
メソッドの詳細

init

public void init(Node node)
推奨されていません。
モバイル端末固体識別番号取得プロバイダの初期化を行います。

定義:
インタフェース MobileUserAgentProvider 内の init
パラメータ:
node - ノード

checkMobile

public boolean checkMobile(String userAgent,
                           HttpServletRequest request)
推奨されていません。
モバイル端末の種別をチェックします。

定義:
インタフェース MobileUserAgentProvider 内の checkMobile
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
対象のモバイル端末の場合は true を返却します。

getUserAgent

public String getUserAgent(String userAgent,
                           HttpServletRequest request)
推奨されていません。
モバイル端末固体識別番号を取得します。 モバイル端末固体識別番号が取得できなかった場合はnullを返却します。

定義:
インタフェース MobileUserAgentProvider 内の getUserAgent
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
固体識別番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MobileEasyLoginSoftBankAnalyzer (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.mobile
クラス MobileEasyLoginSoftBankAnalyzer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginSoftBankAnalyzer
すべての実装インタフェース:
MobileUserAgentProvider
public class MobileEasyLoginSoftBankAnalyzer
extends Object
implements MobileUserAgentProvider

モバイル端末固体識別番号取得プロバイダクラス SoftBank用(3GC型)

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
MobileEasyLoginSoftBankAnalyzer()
メソッドの概要
boolean | checkMobile(String userAgent, HttpServletRequest request) モバイル端末の種別をチェックします。
String | getUserAgent(String userAgent, HttpServletRequest request) モバイル端末固体識別番号を取得します。
void | init(Node node) モバイル端末固体識別番号取得プロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MobileEasyLoginSoftBankAnalyzer

public MobileEasyLoginSoftBankAnalyzer()
メソッドの詳細

init

public void init(Node node)
モバイル端末固体識別番号取得プロバイダの初期化を行います。

定義:
インタフェース MobileUserAgentProvider 内の init
パラメータ:
node - ノード

checkMobile

public boolean checkMobile(String userAgent,
                           HttpServletRequest request)
モバイル端末の種別をチェックします。

定義:
インタフェース MobileUserAgentProvider 内の checkMobile
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
対象のモバイル端末の場合は true を返却します。

getUserAgent

public String getUserAgent(String userAgent,
                           HttpServletRequest request)
モバイル端末固体識別番号を取得します。 モバイル端末固体識別番号が取得できなかった場合はnullを返却します。

定義:
インタフェース MobileUserAgentProvider 内の getUserAgent
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
固体識別番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MobileEasyLoginVodafoneAnalyzer (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.mobile
クラス MobileEasyLoginVodafoneAnalyzer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginVodafoneAnalyzer
すべての実装インタフェース:
MobileUserAgentProvider
public class MobileEasyLoginVodafoneAnalyzer
extends Object
implements MobileUserAgentProvider

モバイル端末固体識別番号取得プロバイダクラス Vodafone用(3GC型)

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
MobileEasyLoginVodafoneAnalyzer()
メソッドの概要
boolean | checkMobile(String userAgent, HttpServletRequest request) モバイル端末の種別をチェックします。
String | getUserAgent(String userAgent, HttpServletRequest request) モバイル端末固体識別番号を取得します。
void | init(Node node) モバイル端末固体識別番号取得プロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MobileEasyLoginVodafoneAnalyzer

public MobileEasyLoginVodafoneAnalyzer()
メソッドの詳細

init

public void init(Node node)
モバイル端末固体識別番号取得プロバイダの初期化を行います。

定義:
インタフェース MobileUserAgentProvider 内の init
パラメータ:
node - ノード

checkMobile

public boolean checkMobile(String userAgent,
                           HttpServletRequest request)
モバイル端末の種別をチェックします。

定義:
インタフェース MobileUserAgentProvider 内の checkMobile
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
対象のモバイル端末の場合は true を返却します。

getUserAgent

public String getUserAgent(String userAgent,
                           HttpServletRequest request)
モバイル端末固体識別番号を取得します。 モバイル端末固体識別番号が取得できなかった場合はnullを返却します。

定義:
インタフェース MobileUserAgentProvider 内の getUserAgent
パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
固体識別番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MobileUserAgentProvider (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.mobile
インタフェース MobileUserAgentProvider

既知の実装クラスの一覧:
MobileEasyLoginAuAnalyzer, MobileEasyLoginAuHdmlAnalyzer, MobileEasyLoginDocomoAnalyzer, MobileEasyLoginDocomoMoveAnalyzer, MobileEasyLoginJphoneAnalyzer, MobileEasyLoginSoftBankAnalyzer, MobileEasyLoginVodafoneAnalyzer
public interface MobileUserAgentProvider

モバイル端末固体識別番号取得プロバイダインタフェース。

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
boolean | checkMobile(String userAgent, HttpServletRequest request) モバイル端末の種別をチェックします。
String | getUserAgent(String userAgent, HttpServletRequest request) モバイル端末固体識別番号を取得します。
void | init(Node node) 設定ファイルの情報を基に初期化します。

メソッドの詳細

init

public void init(Node node)
設定ファイルの情報を基に初期化します。

パラメータ:
node - ノード

checkMobile

public boolean checkMobile(String userAgent,
                           HttpServletRequest request)
モバイル端末の種別をチェックします。

パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
対象のモバイル端末の場合は true を返却します。

getUserAgent

public String getUserAgent(String userAgent,
                           HttpServletRequest request)
モバイル端末固体識別番号を取得します。

モバイル端末固体識別番号が取得できなかった場合はnullを返却します。

パラメータ:
userAgent - ユーザエージェントヘッダー値
request - サーブレットリクエスト
戻り値:
固体識別番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.mobile (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.security.mobile
インタフェース
MobileUserAgentProvider
クラス
MobileEasyLoginAuAnalyzer
MobileEasyLoginAuHdmlAnalyzer
MobileEasyLoginDocomoAnalyzer
MobileEasyLoginDocomoMoveAnalyzer
MobileEasyLoginJphoneAnalyzer
MobileEasyLoginSoftBankAnalyzer
MobileEasyLoginUtil
MobileEasyLoginVodafoneAnalyzer
NonceResetListener4MobileEasyLogin


jp.co.intra_mart.foundation.security.mobile (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.mobile

インタフェースの概要
MobileUserAgentProvider モバイル端末固体識別番号取得プロバイダインタフェース。

クラスの概要
MobileEasyLoginAuAnalyzer | モバイル端末固体識別番号取得プロバイダクラス Au用(WAP2.0)
MobileEasyLoginAuHdmlAnalyzer | 推奨されていません。
MobileEasyLoginDocomoAnalyzer | モバイル端末固体識別番号取得プロバイダクラス NTT DoCoMo用(FOMA)
MobileEasyLoginDocomoMoveAnalyzer | 推奨されていません。
MobileEasyLoginJphoneAnalyzer | 推奨されていません。
MobileEasyLoginSoftBankAnalyzer | モバイル端末固体識別番号取得プロバイダクラス SoftBank用(3GC型)
MobileEasyLoginUtil | かんたんログイン機能のユーティリティクラスです。
MobileEasyLoginVodafoneAnalyzer | モバイル端末固体識別番号取得プロバイダクラス Vodafone用(3GC型)
NonceResetListener4MobileEasyLogin | かんたんログイン用のNonceを再設定する為のリスナーです。


jp.co.intra_mart.foundation.security.mobile クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.mobile の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuHdmlAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoMoveAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginJphoneAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginSoftBankAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginVodafoneAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin (implements jp.co.intra_mart.foundation.security.account.AccountPostWriterListener, jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider


パッケージ jp.co.intra_mart.foundation.security.mobile の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.mobile の使用

jp.co.intra_mart.foundation.security.mobile を使用しているパッケージ
jp.co.intra_mart.foundation.security.mobile

jp.co.intra_mart.foundation.security.mobile により使用される jp.co.intra_mart.foundation.security.mobile のクラス
MobileUserAgentProvider
モバイル端末固体識別番号取得プロバイダインタフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.password.PasswordHistory の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.password.PasswordHistory の使用

PasswordHistory を使用しているパッケージ
jp.co.intra_mart.foundation.security.password

jp.co.intra_mart.foundation.security.password での PasswordHistory の使用

PasswordHistory を返す jp.co.intra_mart.foundation.security.password のメソッド
PasswordHistory[] | StandardPasswordHistoryAccessor.getPasswordHistories(String groupId, String userId) パスワード履歴を取得。
PasswordHistory | StandardPasswordHistoryAccessor.getLatestPasswordHistory(String groupId, String userId) 最新のパスワードと更新日付を取得。
PasswordHistory | PasswordHistoryManager.getLatestPasswordHistory(String userId) 最新のパスワードと更新日付を取得。
PasswordHistory[] | PasswordHistoryManager.getPasswordHistories(String userId) パスワード履歴を取得。
PasswordHistory[] | PasswordHistoryAccessor.getPasswordHistories(String groupId, String userId) パスワード履歴を取得。
PasswordHistory | PasswordHistoryAccessor.getLatestPasswordHistory(String groupId, String userId) 最新のパスワードと更新日付を取得。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor の使用

PasswordHistoryAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.security.password

jp.co.intra_mart.foundation.security.password での PasswordHistoryAccessor の使用

PasswordHistoryAccessor を実装している jp.co.intra_mart.foundation.security.password のクラス
 class StandardPasswordHistoryAccessor
パスワード履歴管理アクセッサクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener の使用

jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.password.PasswordHistoryException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.password.PasswordHistoryException の使用

PasswordHistoryException を使用しているパッケージ
jp.co.intra_mart.foundation.security.password

jp.co.intra_mart.foundation.security.password での PasswordHistoryException の使用

PasswordHistoryException をスローする jp.co.intra_mart.foundation.security.password のメソッド
void | StandardPasswordHistoryAccessor.addPasswordHistory(String groupId, String userId, String password) パスワード履歴の追加。
PasswordHistoryResult | StandardPasswordHistoryAccessor.checkPasswordHistory(String groupId, String userId, String password) 入力パスワードのチェック。
void | StandardPasswordHistoryAccessor.clearPasswordHistories(String groupId) パスワード履歴の消去。
void | StandardPasswordHistoryAccessor.clearPasswordHistory(String groupId, String userId) 指定ユーザのパスワード履歴の消去。
PasswordHistory[] | StandardPasswordHistoryAccessor.getPasswordHistories(String groupId, String userId) パスワード履歴を取得。
int | StandardPasswordHistoryAccessor.getPasswordHistoryCount(String groupId, String userId) パスワード履歴数を取得。
void | StandardPasswordHistoryAccessor.verifyPasswordHistory(String groupId, String userId, int remain) ユーザのパスワードを消去。
PasswordHistory | StandardPasswordHistoryAccessor.getLatestPasswordHistory(String groupId, String userId) 最新のパスワードと更新日付を取得。
void | PasswordHistoryManager.addPasswordHistory(String userId, String password) パスワード履歴の追加。
PasswordHistoryResult | PasswordHistoryManager.checkPasswordHistory(String userId, String password) パスワードの入力チェック。
void | PasswordHistoryManager.clearPasswordHistories() パスワード履歴の消去。
void | PasswordHistoryManager.clearPasswordHistory(String userId) 指定ユーザのパスワード履歴の消去。
PasswordHistory | PasswordHistoryManager.getLatestPasswordHistory(String userId) 最新のパスワードと更新日付を取得。
PasswordHistory[] | PasswordHistoryManager.getPasswordHistories(String userId) パスワード履歴を取得。
int | PasswordHistoryManager.getPasswordHistoryCount(String userId) パスワード履歴数を取得。
void | PasswordHistoryManager.verifyPasswordHistory(String userId, int remain) ユーザのパスワード履歴を消去。
void | PasswordHistoryAccessor.addPasswordHistory(String groupId, String userId, String password) パスワード履歴の追加。
PasswordHistoryResult | PasswordHistoryAccessor.checkPasswordHistory(String groupId, String userId, String password) パスワードの入力チェック。
void | PasswordHistoryAccessor.clearPasswordHistories(String groupId) パスワード履歴の消去。
void | PasswordHistoryAccessor.clearPasswordHistory(String groupId, String userId) 指定ユーザのパスワード履歴の消去。
PasswordHistory[] | PasswordHistoryAccessor.getPasswordHistories(String groupId, String userId) パスワード履歴を取得。
PasswordHistory | PasswordHistoryAccessor.getLatestPasswordHistory(String groupId, String userId) 最新のパスワードと更新日付を取得。
int | PasswordHistoryAccessor.getPasswordHistoryCount(String groupId, String userId) パスワード履歴数を取得。
void | PasswordHistoryAccessor.verifyPasswordHistory(String groupId, String userId, int remain) ユーザのパスワードを消去。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.password.PasswordHistoryManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.password.PasswordHistoryManager の使用

jp.co.intra_mart.foundation.security.password.PasswordHistoryManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.password.PasswordHistoryManagerInitializerImpl の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.password.PasswordHistoryManagerInitializerImpl の使用

jp.co.intra_mart.foundation.security.password.PasswordHistoryManagerInitializerImpl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.password.PasswordHistoryNewArrivedProvider の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.password.PasswordHistoryNewArrivedProvider の使用

jp.co.intra_mart.foundation.security.password.PasswordHistoryNewArrivedProvider はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.password.PasswordHistoryResult の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.password.PasswordHistoryResult の使用

PasswordHistoryResult を使用しているパッケージ
jp.co.intra_mart.foundation.security.password

jp.co.intra_mart.foundation.security.password での PasswordHistoryResult の使用

PasswordHistoryResult を返す jp.co.intra_mart.foundation.security.password のメソッド
PasswordHistoryResult | StandardPasswordHistoryAccessor.checkPasswordHistory(String groupId, String userId, String password) 入力パスワードのチェック。
PasswordHistoryResult | PasswordHistoryManager.checkPasswordHistory(String userId, String password) パスワードの入力チェック。
PasswordHistoryResult | PasswordHistoryAccessor.checkPasswordHistory(String groupId, String userId, String password) パスワードの入力チェック。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.password.PasswordHistoryUserPageProvider の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.password.PasswordHistoryUserPageProvider の使用

jp.co.intra_mart.foundation.security.password.PasswordHistoryUserPageProvider はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor の使用

jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.security.password (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.security.password
インタフェース
PasswordHistoryAccessor
クラス
PasswordHistory
PasswordHistoryAccountChangedListener
PasswordHistoryManager
PasswordHistoryManagerInitializerImpl
PasswordHistoryNewArrivedProvider
PasswordHistoryResult
PasswordHistoryUserPageProvider
StandardPasswordHistoryAccessor
例外
PasswordHistoryException


jp.co.intra_mart.foundation.security.password (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.password

インタフェースの概要
PasswordHistoryAccessor パスワード履歴管理アクセッサインターフェース。

クラスの概要
PasswordHistory | パスワード履歴管理情報クラス
PasswordHistoryAccountChangedListener | アカウント情報変更リスナー(パスワード履歴管理)。
PasswordHistoryManager | パスワード履歴管理マネージャクラス ServerManager/conf/password-history.xmlからパスワード履歴管理に関するパラメータを取得します。
PasswordHistoryManagerInitializerImpl | パスワード履歴管理マネージャの初期化クラス。
PasswordHistoryNewArrivedProvider | パスワード履歴管理汎用新着情報のプロバイダ。
PasswordHistoryResult | パスワード履歴管理リザルトクラス。
PasswordHistoryUserPageProvider | パスワード履歴管理スタンダードユーザページプロバイダクラス。
StandardPasswordHistoryAccessor | パスワード履歴管理アクセッサクラス。

例外の概要
PasswordHistoryException イメージアイコンの例外クラス。


jp.co.intra_mart.foundation.security.password クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.password の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.password.PasswordHistory
    • class jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener (implements jp.co.intra_mart.foundation.security.account.AccountChangedListener)
    • class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager
    • class jp.co.intra_mart.foundation.security.password.PasswordHistoryManagerInitializerImpl (implements jp.co.intra_mart.system.service.ApplicationInitializer)
    • class jp.co.intra_mart.foundation.security.password.PasswordHistoryNewArrivedProvider (implements jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider)
    • class jp.co.intra_mart.foundation.security.password.PasswordHistoryResult
    • class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor (implements jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor)
    • class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider (implements jp.co.intra_mart.foundation.security.certification.UserPageProvider)
      • class jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider
        • class jp.co.intra_mart.foundation.security.password.PasswordHistoryUserPageProvider
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.exception.FoundationException
          • class jp.co.intra_mart.foundation.security.password.PasswordHistoryException

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor


パッケージ jp.co.intra_mart.foundation.security.password の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.password の使用

jp.co.intra_mart.foundation.security.password を使用しているパッケージ
jp.co.intra_mart.foundation.security.password

jp.co.intra_mart.foundation.security.password により使用される jp.co.intra_mart.foundation.security.password のクラス
PasswordHistory
パスワード履歴管理情報クラス
PasswordHistoryAccessor
パスワード履歴管理アクセッサインターフェース。
PasswordHistoryException
イメージアイコンの例外クラス。
PasswordHistoryResult
パスワード履歴管理リザルトクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PasswordHistory (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.password
クラス PasswordHistory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.password.PasswordHistory
public class PasswordHistory
extends Object

パスワード履歴管理情報クラス

コンストラクタの概要
PasswordHistory()
メソッドの概要
Date | getDate() 日付を取得します。
String | getPassword() パスワードを取得します。
void | setDate(Date date) 日付を設定します。
void | setPassword(String password) パスワードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PasswordHistory

public PasswordHistory()
メソッドの詳細

getPassword

public String getPassword()
パスワードを取得します。

戻り値:
password を戻します。

setPassword

public void setPassword(String password)
パスワードを設定します。

パラメータ:
password - password を設定。

getDate

public Date getDate()
日付を取得します。

戻り値:
date を戻します。

setDate

public void setDate(Date date)
日付を設定します。

パラメータ:
date - date を設定。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PasswordHistoryAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.password
インタフェース PasswordHistoryAccessor

既知の実装クラスの一覧:
StandardPasswordHistoryAccessor
public interface PasswordHistoryAccessor

パスワード履歴管理アクセッサインターフェース。

パスワード履歴管理情報の読み込みおよび書き込みのインタフェースを定義します。

メソッドの概要
void | addPasswordHistory(String groupId, String userId, String password) パスワード履歴の追加。
PasswordHistoryResult | checkPasswordHistory(String groupId, String userId, String password) パスワードの入力チェック。
void | clearPasswordHistories(String groupId) パスワード履歴の消去。
void | clearPasswordHistory(String groupId, String userId) 指定ユーザのパスワード履歴の消去。
String | createPassword(int count) パスワードをランダムに生成。
PasswordHistory | getLatestPasswordHistory(String groupId, String userId) 最新のパスワードと更新日付を取得。
int | getPasswordExpireLimit(String groupId) パスワード履歴数を取得。
PasswordHistory[] | getPasswordHistories(String groupId, String userId) パスワード履歴を取得。
int | getPasswordHistoryCount(String groupId, String userId) パスワード履歴数を取得。
int | getPasswordHistoryManagedCount(String groupId) 世代管理数を取得。
String | getPasswordPage(String groupId) パスワード変更画面のＵＲＬを取得。
void | init(Node defaultNode, Node groupNode) パラメータを取得。
boolean | isChangePasswordFirstLogin(String groupId) 初回ログイン時にパスワード変更要求を行うかの判定。
boolean | isDenyClientType(String clientType) クライアントタイプの判定 パラメータdeny-client-typesに記述があるクライアントタイプの判定を行う。
boolean | isFirstLogin(String groupId, String userId) 初回ログインの判定
boolean | isForwardInitialPage(String groupId) パスワード変更後の画面遷移。
boolean | isPasswordExpired(String groupId, String userId, String clientType, Date date) パスワード変更要求の判定。
boolean | isPasswordHistoryManaged(String groupId) 履歴管理の有無。
void | verifyPasswordHistory(String groupId, String userId, int remain) ユーザのパスワードを消去。

メソッドの詳細

addPasswordHistory

public void addPasswordHistory(String groupId,
                               String userId,
                               String password)
                        throws PasswordHistoryException
パスワード履歴の追加。

指定ユーザの入力パスワードをデータベースに追加します。

パラメータ:
groupId - グループID
userId - ユーザID
password - 入力パスワード
例外:
PasswordHistoryException - パスワード履歴の追加に失敗した場合にスローされます。

checkPasswordHistory

public PasswordHistoryResult checkPasswordHistory(String groupId,
                                                  String userId,
                                                  String password)
                                           throws PasswordHistoryException
パスワードの入力チェック。

パスワードの入力チェックを行います。

パラメータ:
groupId - グループID
userId - ユーザID
password - 入力パスワード
戻り値:
true　/　false,メッセージ,詳細メッセージ
例外:
PasswordHistoryException - パスワードの入力チェックに失敗した場合にスローされます。

clearPasswordHistories

public void clearPasswordHistories(String groupId)
                            throws PasswordHistoryException
パスワード履歴の消去。

引数のログイングループのパスワード履歴をすべて消去します。

パラメータ:
groupId - グループID
例外:
PasswordHistoryException - パスワード履歴の消去に失敗した場合にスローされます。

clearPasswordHistory

public void clearPasswordHistory(String groupId,
                                 String userId)
                          throws PasswordHistoryException
指定ユーザのパスワード履歴の消去。

引数のユーザのパスワード履歴を消去します。

パラメータ:
groupId - グループID
userId - ユーザID
例外:
PasswordHistoryException - 指定ユーザのパスワード履歴の消去に失敗した場合にスローされます。

getPasswordHistories

public PasswordHistory[] getPasswordHistories(String groupId,
                                              String userId)
                                       throws PasswordHistoryException
パスワード履歴を取得。

指定ユーザのパスワード履歴を取得します。

パラメータ:
groupId - グループID
userId - ユーザID
戻り値:
指定ユーザのパスワード履歴一覧
例外:
PasswordHistoryException - パスワード履歴の取得に失敗した場合にスローされます。

getLatestPasswordHistory

public PasswordHistory getLatestPasswordHistory(String groupId,
                                                String userId)
                                         throws PasswordHistoryException
最新のパスワードと更新日付を取得。

指定ユーザの最新パスワードと更新日付を取得します。

パラメータ:
groupId - グループID
userId - ユーザID
戻り値:
パスワード、更新日付
例外:
PasswordHistoryException - 最新のパスワード情報の取得に失敗した場合にスローされます。

getPasswordHistoryCount

public int getPasswordHistoryCount(String groupId,
                                   String userId)
                            throws PasswordHistoryException
パスワード履歴数を取得。

指定ユーザのパスワード履歴数を取得します。

パラメータ:
groupId - グループID
userId - ユーザID
戻り値:
パスワード履歴数
例外:
PasswordHistoryException - パスワード履歴数の取得に失敗した場合にスローされます。

getPasswordHistoryManagedCount

public int getPasswordHistoryManagedCount(String groupId)
世代管理数を取得。

パスワードの世代管理数を取得します。

パラメータ:
groupId - グループID
戻り値:
パスワード世代管理数

getPasswordPage

public String getPasswordPage(String groupId)
パスワード変更画面のＵＲＬを取得。

パスワード変更画面のＵＲＬを取得します。

パラメータ:
groupId - グループID
戻り値:
パスワード変更画面のＵＲＬ

init

public void init(Node defaultNode,
                 Node groupNode)
パラメータを取得。

設定したパスワード履歴管理に関するパラメータを取得します。

パラメータ:
defaultNode - デフォルトパラメータ
groupNode - グループパラメータ

isForwardInitialPage

public boolean isForwardInitialPage(String groupId)
パスワード変更後の画面遷移。

パスワードの有効期限切れによるパスワード再設定後、ログイン画面に戻るか、ログイン処理を継続してログインするかを判定します。

パラメータ:
groupId - グループID
戻り値:
true / false

isPasswordExpired

public boolean isPasswordExpired(String groupId,
                                 String userId,
                                 String clientType,
                                 Date date)
パスワード変更要求の判定。

パスワード変更要求を行うか判定します。

パラメータ:
groupId - グループID
userId - ユーザID
clientType - クライアントタイプ
date - パスワードのチェックの基準となる日付。省略された場合、現在日付が利用されます。
戻り値:
true / false

isPasswordHistoryManaged

public boolean isPasswordHistoryManaged(String groupId)
履歴管理の有無。

履歴管理を行うかどうか判定します。

パラメータ:
groupId - グループID
戻り値:
ture / false

verifyPasswordHistory

public void verifyPasswordHistory(String groupId,
                                  String userId,
                                  int remain)
                           throws PasswordHistoryException
ユーザのパスワードを消去。

引数 remain の値分残してユーザの履歴を消去します。
引数 remain が0以下の場合、履歴をすべて消去します。

パラメータ:
groupId - グループID
userId - ユーザID
remain - 残す履歴の数
例外:
PasswordHistoryException - パスワードの消去に失敗した場合にスローされます。

createPassword

public String createPassword(int count)
パスワードをランダムに生成。

引数の値の長さのパスワードをランダムに生成します。
呼出し毎に異なるパスワードを生成します。

パラメータ:
count - パスワードの長さ
戻り値:
生成されたパスワード

isChangePasswordFirstLogin

public boolean isChangePasswordFirstLogin(String groupId)
初回ログイン時にパスワード変更要求を行うかの判定。

パラメータ:
groupId - グループID
戻り値:
true：パスワード変更要求を行う / false：パスワード変更要求を行わない

isFirstLogin

public boolean isFirstLogin(String groupId,
                            String userId)
初回ログインの判定

パラメータ:
groupId - グループID
userId - ユーザID
戻り値:
true：初回ログイン / false　初回ログインではない

isDenyClientType

public boolean isDenyClientType(String clientType)
クライアントタイプの判定

パラメータdeny-client-typesに記述があるクライアントタイプの判定を行う。

パラメータ:
clientType - クライアントタイプ
戻り値:
true：クライアントタイプが含まれている false：クライアントタイプが含まれていない

getPasswordExpireLimit

public int getPasswordExpireLimit(String groupId)
パスワード履歴数を取得。

指定ユーザのパスワード履歴数を取得します。

パラメータ:
groupId - グループID
戻り値:
パスワード履歴数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PasswordHistoryAccountChangedListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.password
クラス PasswordHistoryAccountChangedListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener
すべての実装インタフェース:
AccountChangedListener
public class PasswordHistoryAccountChangedListener
extends Object
implements AccountChangedListener

アカウント情報変更リスナー(パスワード履歴管理)。

アカウント情報が変更された時に
パスワード履歴管理情報との整合性を保つクラスです。

導入されたバージョン:
6.1.3
バージョン:
1.0

コンストラクタの概要
PasswordHistoryAccountChangedListener()
メソッドの概要
void | accountAdded(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | accountDeleted(String groupId, String userId) アカウント情報をデータストアから削除した直後にコールされます。
void | accountRoleAdded(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | accountRoleDeleted(String groupId, String userId, String roleId) アカウントロール情報をデータストアから削除した直後にコールされます。
void | accountRoleUpdated(String grouId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新した直後にコールされます。
void | accountUpdated(String groupId, Account account) アカウント情報をデータストアに更新した直後にコールされます。
void | init(Map params) アカウントリスナーの初期化。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PasswordHistoryAccountChangedListener

public PasswordHistoryAccountChangedListener()
メソッドの詳細

init

public void init(Map params)
アカウントリスナーの初期化。

定義:
インタフェース AccountChangedListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

accountAdded

public void accountAdded(String groupId,
                         Account account)
                  throws ChangedListenerException
アカウント情報をデータストアに作成した直後にコールされます。 作成されたアカウント情報に対するプロファイルが存在する場合に、 アカウントフラグを設定します。

定義:
インタフェース AccountChangedListener 内の accountAdded
パラメータ:
groupId - ログイングループID
account - 作成されたアカウント情報
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

accountDeleted

public void accountDeleted(String groupId,
                           String userId)
                    throws ChangedListenerException
アカウント情報をデータストアから削除した直後にコールされます。

削除されたアカウント情報に対するパスワード履歴管理情報が存在した場合に、
パスワード履歴管理情報を削除します。

定義:
インタフェース AccountChangedListener 内の accountDeleted
パラメータ:
groupId - ログイングループID
userId - 削除されたユーザID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

accountUpdated

public void accountUpdated(String groupId,
                           Account account)
アカウント情報をデータストアに更新した直後にコールされます。 このリスナーでは、このイベントに対して処理は何も行いません。

定義:
インタフェース AccountChangedListener 内の accountUpdated
パラメータ:
groupId - ログイングループID
account - 更新されたアカウント情報

accountRoleAdded

public void accountRoleAdded(String groupId,
                             String userId,
                             AccountRole accountRole)
アカウントロール情報をデータストアに作成した直後にコールされます。 このリスナーでは、このイベントに対して処理は何も行いません。

定義:
インタフェース AccountChangedListener 内の accountRoleAdded
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 作成されたアカウントロール情報

accountRoleDeleted

public void accountRoleDeleted(String groupId,
                               String userId,
                               String roleId)
アカウントロール情報をデータストアから削除した直後にコールされます。 このリスナーでは、このイベントに対して処理は何も行いません。

定義:
インタフェース AccountChangedListener 内の accountRoleDeleted
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
roleId - 削除されたロールID

accountRoleUpdated

public void accountRoleUpdated(String grouId,
                               String userId,
                               AccountRole accountRole)
アカウントロール情報をデータストアに更新した直後にコールされます。 このリスナーでは、このイベントに対して処理は何も行いません。

定義:
インタフェース AccountChangedListener 内の accountRoleUpdated
パラメータ:
userId - 対象ユーザID
accountRole - 更新されたアカウントロール情報
grouId - ログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PasswordHistoryException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.password
クラス PasswordHistoryException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.password.PasswordHistoryException
すべての実装インタフェース:
Serializable
public class PasswordHistoryException
extends FoundationException

イメージアイコンの例外クラス。

イメージアイコン内で例外が発生した場合にスローされます。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
PasswordHistoryException()
コンストラクタ。
PasswordHistoryException(String message)
コンストラクタ。
PasswordHistoryException(String message, Throwable cause)
コンストラクタ。
PasswordHistoryException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PasswordHistoryException

public PasswordHistoryException()
コンストラクタ。

PasswordHistoryException

public PasswordHistoryException(String message)
コンストラクタ。

パラメータ:
message - メッセージ

PasswordHistoryException

public PasswordHistoryException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

PasswordHistoryException

public PasswordHistoryException(String message,
                                Throwable cause)
コンストラクタ。

パラメータ:
message - メッセージ
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PasswordHistoryManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.password
クラス PasswordHistoryManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.password.PasswordHistoryManager
public class PasswordHistoryManager
extends Object

パスワード履歴管理マネージャクラス

ServerManager/conf/password-history.xmlからパスワード履歴管理に関するパラメータを取得します。

以下はpassword-history.xmlのタグの説明です。

<password-history>
  <group-default accessor-class="jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor">
     <change-password-first-login>false</change-password-first-login>
      <password-expire-limit>0</password-expire-limit>
                        ・
                デフォルトパラメータ群
                        ・
  </group-default>

  <group name="default" accessor-class="jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor">
    <change-password-first-login>true</change-password-first-login>
    <password-expire-limit>0</password-expire-limit>
                        ・
                ログイングループパラメータ群
                        ・
  </group>
</password-history>

その他のタグに関してはこちらを参照してください。StandardPasswordHistoryAccessor

タグ名 | 説明 | デフォルト値
accessor-class | パスワード履歴管理のデフォルトパラメータ | jp.co.intra_mart.foundation. security.password. StandardPasswardAccessor
group | ログイングループのグループ名を属性として所持します。 複数記述することが可能です。 | なし

コンストラクタの概要
PasswordHistoryManager(String groupId)
メソッドの概要
void | addPasswordHistory(String userId, String password) パスワード履歴の追加。
PasswordHistoryResult | checkPasswordHistory(String userId, String password) パスワードの入力チェック。
static void | clearInstance()
void | clearPasswordHistories() パスワード履歴の消去。
void | clearPasswordHistory(String userId) 指定ユーザのパスワード履歴の消去。
String | createPassword(int count)
String | getGroupId()
PasswordHistory | getLatestPasswordHistory(String userId) 最新のパスワードと更新日付を取得。
int | getPasswordExpireLimit() 設定したパスワードの有効期限を取得。
PasswordHistory[] | getPasswordHistories(String userId) パスワード履歴を取得。
int | getPasswordHistoryCount(String userId) パスワード履歴数を取得。
int | getPasswordHistoryManagedCount() 世代管理数を取得。
String | getPasswordPage() パスワード変更画面のＵＲＬを取得。
boolean | isChangePasswordFirstLogin() 初回ログイン時のパスワード変更要求を行うかの判定。
boolean | isDenyClientType(String clientType) クライアントタイプの判定 パラメータmobile-client-typesに記述があるクライアントタイプの判定を行う。
boolean | isFirstLogin(String userId) 初回ログインの判定 初回ログインかどうかを判定します。
boolean | isForwardInitialPage() パスワード変更後の画面遷移。
boolean | isPasswordExpired(String userId, String clientType, Date date) パスワード有効期限切れかどうかの判定。
boolean | isPasswordHistoryManaged() 履歴管理の有無。
void | verifyPasswordHistory(String userId, int remain) ユーザのパスワード履歴を消去。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PasswordHistoryManager

public PasswordHistoryManager(String groupId)
メソッドの詳細

clearInstance

public static void clearInstance()

addPasswordHistory

public void addPasswordHistory(String userId,
                               String password)
                        throws PasswordHistoryException
パスワード履歴の追加。

指定ユーザの入力パスワードをデータベースに追加します。

パラメータ:
userId -
password -
例外:
PasswordHistoryException - パスワード履歴の追加に失敗した場合にスローされます。

checkPasswordHistory

public PasswordHistoryResult checkPasswordHistory(String userId,
                                                  String password)
                                           throws PasswordHistoryException
パスワードの入力チェック。

パスワードの入力チェックを行います。

パラメータ:
userId -
password -
戻り値:
true　/　false,メッセージ,詳細メッセージ
例外:
PasswordHistoryException - パスワードの入力チェックに失敗した場合にスローされます。

getPasswordPage

public String getPasswordPage()
パスワード変更画面のＵＲＬを取得。

パスワード変更画面のＵＲＬを取得します。

戻り値:
パスワード変更画面のＵＲＬ

isPasswordExpired

public boolean isPasswordExpired(String userId,
                                 String clientType,
                                 Date date)
パスワード有効期限切れかどうかの判定。

パスワード有効期限切れを判定します。

パラメータ:
userId -
clientType -
date - パスワードのチェックの基準となる日付。省略された場合、現在日付が利用されます。
戻り値:
true : パスワードが有効期限切れの場合 / false : パスワードが有効期限内の場合

isPasswordHistoryManaged

public boolean isPasswordHistoryManaged()
履歴管理の有無。

履歴管理を行うかどうか判定します。

戻り値:
ture / false

clearPasswordHistories

public void clearPasswordHistories()
                            throws PasswordHistoryException
パスワード履歴の消去。

パスワード履歴をすべて消去します。

例外:
PasswordHistoryException - パスワード履歴の消去に失敗した場合にスローされます。

clearPasswordHistory

public void clearPasswordHistory(String userId)
                          throws PasswordHistoryException
指定ユーザのパスワード履歴の消去。

引数のユーザのパスワード履歴を消去します。

パラメータ:
userId -
例外:
PasswordHistoryException - 指定ユーザのパスワードの消去に失敗した場合にスローされます。

getLatestPasswordHistory

public PasswordHistory getLatestPasswordHistory(String userId)
                                         throws PasswordHistoryException
最新のパスワードと更新日付を取得。

指定ユーザの最新パスワードと更新日付を取得します。

パラメータ:
userId -
戻り値:
最新パスワード、更新日付
例外:
PasswordHistoryException - 最新のパスワード情報の取得に失敗した場合にスローされます。

getPasswordHistories

public PasswordHistory[] getPasswordHistories(String userId)
                                       throws PasswordHistoryException
パスワード履歴を取得。

指定ユーザのパスワード履歴を取得します。

パラメータ:
userId -
戻り値:
指定ユーザのパスワード履歴一覧
例外:
PasswordHistoryException - パスワード履歴の取得に失敗した場合にスローされます。

getPasswordHistoryCount

public int getPasswordHistoryCount(String userId)
                            throws PasswordHistoryException
パスワード履歴数を取得。

指定ユーザのパスワード履歴数を取得します。

パラメータ:
userId -
戻り値:
パスワード履歴数
例外:
PasswordHistoryException - パスワード履歴数の取得に失敗した場合にスローされます。

getPasswordHistoryManagedCount

public int getPasswordHistoryManagedCount()
世代管理数を取得。

パスワードの世代管理数を取得します。

戻り値:
パスワード世代管理数

isForwardInitialPage

public boolean isForwardInitialPage()
パスワード変更後の画面遷移。

パスワードの有効期限切れによるパスワード再設定後、ログイン画面に戻るか、ログイン処理を継続してログインするかを判定します。

戻り値:
true/false

verifyPasswordHistory

public void verifyPasswordHistory(String userId,
                                  int remain)
                           throws PasswordHistoryException
ユーザのパスワード履歴を消去。

引数の値分残してユーザの履歴を消去します。

パラメータ:
userId -
remain -
例外:
PasswordHistoryException - 指定ユーザのパスワード履歴の消去に失敗した場合にスローされます。

getGroupId

public String getGroupId()
戻り値:
groupId を戻します。

createPassword

public String createPassword(int count)
戻り値:
passwordを戻します。

isChangePasswordFirstLogin

public boolean isChangePasswordFirstLogin()
初回ログイン時のパスワード変更要求を行うかの判定。

初回ログイン時にパスワード変更要求を行うかを判定します。

戻り値:
true：パスワード変更要求を行う / false：パスワード変更要求を行わない

isFirstLogin

public boolean isFirstLogin(String userId)
初回ログインの判定

初回ログインかどうかを判定します。

パラメータ:
userId - ユーザID
戻り値:
true:初回ログイン / false:初回ログインではない

isDenyClientType

public boolean isDenyClientType(String clientType)
クライアントタイプの判定

パラメータmobile-client-typesに記述があるクライアントタイプの判定を行う。

パラメータ:
clientType - クライアントタイプ
戻り値:
true：クライアントタイプが含まれている false：クライアントタイプが含まれていない

getPasswordExpireLimit

public int getPasswordExpireLimit()
設定したパスワードの有効期限を取得。

パラメータで設定したパスワードの有効期限日数を取得します。

戻り値:
パスワードの有効期限日数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PasswordHistoryManagerInitializerImpl (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.password
クラス PasswordHistoryManagerInitializerImpl

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.password.PasswordHistoryManagerInitializerImpl
すべての実装インタフェース:
jp.co.intra_mart.system.service.ApplicationInitializer
public class PasswordHistoryManagerInitializerImpl
extends Object
implements jp.co.intra_mart.system.service.ApplicationInitializer

パスワード履歴管理マネージャの初期化クラス。
パスワード履歴管理マネージャの初期化を行います。
アプリケーションライタイム起動時に呼ばれます。

導入されたバージョン:
6.0.2
バージョン:
1.0

コンストラクタの概要
PasswordHistoryManagerInitializerImpl()
メソッドの概要
 void initialize()
初期化処理を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PasswordHistoryManagerInitializerImpl

public PasswordHistoryManagerInitializerImpl()
メソッドの詳細

initialize

public void initialize()
初期化処理を行います。

定義:
インタフェース jp.co.intra_mart.system.service.ApplicationInitializer 内の initialize
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PasswordHistoryNewArrivedProvider (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.password
クラス PasswordHistoryNewArrivedProvider

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.password.PasswordHistoryNewArrivedProvider
すべての実装インタフェース:
NewArrivedProvider
public class PasswordHistoryNewArrivedProvider
extends Object
implements NewArrivedProvider

パスワード履歴管理汎用新着情報のプロバイダ。

パスワード履歴管理を行っている場合でかつ、設定された日数以内にパスワードの有効期限が入った場合、汎用新着ポートレットに情報を供給します。

「初期化パラメータ一覧」

パラメータ | 説明 | デフォルト値
report-limit-days | 有効期限の何日前に報告するかの日数を設定します。 | 5 (5日前から通知)
link-page | リンク先のページです。 スクリプト開発モデルプログラムのURLの場合は拡張子(.jssp)を付加します。 | パスワード変更画面 /system/setting/user/password/main.jssp

導入されたバージョン:
6.0
バージョン:
1.0

コンストラクタの概要
PasswordHistoryNewArrivedProvider()
メソッドの概要
NewArrived[] | getNewArrivedList(String user, String group) パスワード履歴管理の新着情報を一覧を取得します。
void | init(Properties properties) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PasswordHistoryNewArrivedProvider

public PasswordHistoryNewArrivedProvider()
メソッドの詳細

init

public void init(Properties properties)
初期化を行います。

定義:
インタフェース NewArrivedProvider 内の init
パラメータ:
properties - 初期化パラメータ

getNewArrivedList

public NewArrived[] getNewArrivedList(String user,
                                      String group)
パスワード履歴管理の新着情報を一覧を取得します。

新着情報が存在しない場合は、空の配列を返します。
初期化パラメータで設定された日数以内にパスワードの有効期限が入った場合、汎用新着ポートレットに情報を供給します。

定義:
インタフェース NewArrivedProvider 内の getNewArrivedList
パラメータ:
user - ログインユーザコード
group - ログイングループID
戻り値:
新着情報の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PasswordHistoryResult (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.password
クラス PasswordHistoryResult

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.password.PasswordHistoryResult
public class PasswordHistoryResult
extends Object

パスワード履歴管理リザルトクラス。

パスワード入力チェック結果を取得します。

コンストラクタの概要
PasswordHistoryResult()
PasswordHistoryResult(String message, String detail)
メソッドの概要
String | getDetail() 詳細メッセージを取得します。
String | getMessage() メッセージを取得します。
boolean | isSuccess() パスワードチェックの成否を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PasswordHistoryResult

public PasswordHistoryResult()

PasswordHistoryResult

public PasswordHistoryResult(String message,
                             String detail)
パラメータ:
message - メッセージ
detail - 詳細メッセージ
メソッドの詳細

getDetail

public String getDetail()
詳細メッセージを取得します。

戻り値:
detail を戻します。

getMessage

public String getMessage()
メッセージを取得します。

戻り値:
message を戻します。

isSuccess

public boolean isSuccess()
パスワードチェックの成否を取得します。

戻り値:
success を戻します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PasswordHistoryUserPageProvider (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.password
クラス PasswordHistoryUserPageProvider

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider
        拡張 jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider
            拡張 jp.co.intra_mart.foundation.security.password.PasswordHistoryUserPageProvider
すべての実装インタフェース:
UserPageProvider
public class PasswordHistoryUserPageProvider
extends PortalStandardUserPageProvider

パスワード履歴管理スタンダードユーザページプロバイダクラス。

コンストラクタの概要
PasswordHistoryUserPageProvider()
メソッドの概要
protected String | getExtendedMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 拡張メインページURLを取得します。
void | init(Map params) ページプロバイダの初期化を行います。
クラス jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider から継承したメソッド
getInitalPage
クラス jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider から継承したメソッド
getMainPage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PasswordHistoryUserPageProvider

public PasswordHistoryUserPageProvider()
メソッドの詳細

getExtendedMainPage

protected String getExtendedMainPage(SessionInfo sessionInfo,
                                     HttpServletRequest request,
                                     HttpServletResponse response)
クラス PortalStandardUserPageProvider の記述:
拡張メインページURLを取得します。

ログイン後の拡張メイン画面を表示するURLを取得する。

オーバーライド:
クラス PortalStandardUserPageProvider 内の getExtendedMainPage
パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL

init

public void init(Map params)
クラス PortalStandardUserPageProvider の記述:
ページプロバイダの初期化を行います。

ページプロバイダのインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース UserPageProvider 内の init
オーバーライド:
クラス PortalStandardUserPageProvider 内の init
パラメータ:
params - 初期化パラメータのマップ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardPasswordHistoryAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.password
クラス StandardPasswordHistoryAccessor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor
すべての実装インタフェース:
PasswordHistoryAccessor
public class StandardPasswordHistoryAccessor
extends Object
implements PasswordHistoryAccessor

パスワード履歴管理アクセッサクラス。

パスワード履歴の読み込みおよび書き込みクラスです。

タグ名 | 属性 | 説明 | デフォルト値
change-password-first-login | (なし) | 初回ログイン時のパスワード変更要求の有無を設定します。 | false
password-expire-limit | (なし) | パスワードの有効期限（日数）を設定します。0の場合無期限となります。 | 0
password-history-count | (なし) | 何世代前まで世代管理を行うかを設定します。0の場合履歴管理を行いません。 | 0
deny-client-types | なし | パスワード変更画面に遷移させないクライアントタイプをカンマ区切りで設定します。 | mobile
password-expire-page | (なし) | パスワード変更画面ＵＲＬを設定します。 | /system/security/user /password_expire.jssp
check-password | enable | パスワードチェックの利用有無を判定します。 enable属性： true：利用 false：利用なし | false
check-password-length | enable | パスワードの文字数判定の利用有無とその範囲を設定します。 enable属性： true：利用 false：利用なし min属性：パスワードの最小文字数（半角数字,0以上）を設定します。 max属性：パスワードの最大文字数（半角数字,最大50）を設定します。 51文字以上は入力することができません。 | false
 | min |  | 0
 | max |  | 50
allow-latin-letters | required | 使用可能文字の設定(アルファベット)を行います。 required属性：混在判定の利用有無 true：利用 false：利用なし | ABCDEFGHIJ KLMNOPQRS TUVWXYZabc defghijklmnop qrstuvwxyz
allow-number | required | 使用可能文字の設定(数字)を行います。 required属性：混在判定の利用有無 true：利用 false：利用なし | 0123456789
allow-extra-char | required | 使用可能文字の設定（その他の文字列、記号など)を行います。 required属性：混在判定の利用有無 true：利用 false：利用なし | _-.+$#!/@
deny-old-password | (なし) | パスワード履歴管理で管理されているパスワードは拒否するかどうかを設定します。 true：利用 false：利用なし | false
deny-userid | (なし) | useridと同じパスワードを拒否するかどうかを設定します。 true：利用 false：利用なし | false
password-cryption-class | (なし) | 暗号化を行うクラスを設定します。 | jp.co.intra_mart. foundation.security.cryption. StandardCryption
return-initial-page | (なし) | パスワード有効期限切れの場合、パスワード変更後 ログイン画面に戻るかそのままログイン処理を継続し てログインするか判定します。 true:ログイン画面に戻ります。 false:ログイン処理を継続してログインします。 | false

コンストラクタの概要
StandardPasswordHistoryAccessor()
メソッドの概要
void | addPasswordHistory(String groupId, String userId, String password) パスワード履歴の追加。
PasswordHistoryResult | checkPasswordHistory(String groupId, String userId, String password) 入力パスワードのチェック。
void | clearPasswordHistories(String groupId) パスワード履歴の消去。
void | clearPasswordHistory(String groupId, String userId) 指定ユーザのパスワード履歴の消去。
String | createPassword(int count) パスワードをランダムに生成。
PasswordHistory | getLatestPasswordHistory(String groupId, String userId) 最新のパスワードと更新日付を取得。
int | getPasswordExpireLimit(String groupId) 設定したパスワードの有効期限を取得。
PasswordHistory[] | getPasswordHistories(String groupId, String userId) パスワード履歴を取得。
int | getPasswordHistoryCount(String groupId, String userId) パスワード履歴数を取得。
int | getPasswordHistoryManagedCount(String groupId) 世代管理数を取得。
String | getPasswordPage(String groupId) パスワード変更画面のＵＲＬを取得。
void | init(Node defaultNode, Node groupNode) パラメータを取得。
boolean | isChangePasswordFirstLogin(String groupId) 初回ログイン時にパスワード変更要求を行うかの判定。
boolean | isDenyClientType(String clientType) クライアントタイプの判定 パラメータdeny-client-typesに記述があるクライアントタイプの判定を行う。
boolean | isFirstLogin(String groupId, String userId) 初回ログインの判定
boolean | isForwardInitialPage(String groupId) パスワード変更後の画面遷移。
boolean | isPasswordExpired(String groupId, String userId, String clientType, Date date) パスワードが有効期限切れかどうかの判定。
boolean | isPasswordHistoryManaged(String groupId) 履歴管理の有無。
void | verifyPasswordHistory(String groupId, String userId, int remain) ユーザのパスワードを消去。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardPasswordHistoryAccessor

public StandardPasswordHistoryAccessor()
メソッドの詳細

init

public void init(Node defaultNode,
                 Node groupNode)
パラメータを取得。

設定したパスワード履歴管理に関するパラメータを取得します。

定義:
インタフェース PasswordHistoryAccessor 内の init
パラメータ:
defaultNode - デフォルトパラメータ
groupNode - ログイングループパラメータ

addPasswordHistory

public void addPasswordHistory(String groupId,
                               String userId,
                               String password)
                        throws PasswordHistoryException
パスワード履歴の追加。

指定ユーザの入力パスワードをデータベースに追加します。

定義:
インタフェース PasswordHistoryAccessor 内の addPasswordHistory
パラメータ:
groupId - グループID
userId - ユーザID
password - 入力パスワード
例外:
PasswordHistoryException - パスワード履歴の追加に失敗した場合にスローされます。

checkPasswordHistory

public PasswordHistoryResult checkPasswordHistory(String groupId,
                                                  String userId,
                                                  String password)
                                           throws PasswordHistoryException
入力パスワードのチェック。

パスワードのチェックを行います。

パスワードの文字数をチェックします。
パスワードが51文字以上の場合、falseを返します。

パスワードの入力チェックの利用について判定します。
パラメータ"check-password"で設定した値が設定した値がfalseの場合trueを返します。パスワードチェックは行いません。
trueの場合は以下のパスワードチェックを行います。

使用不可能文字が混在していないかチェックを行います。

check-password-lengthがtrueの場合文字数チェックを行います。

deny-useridがtrueの場合useridと同一パスワードの判定を行います。

英数字記号混在判定チェックを行います。
英字　数字　記号全ての判定をtrueにした場合、最低3文字以上のパスワードを設定する必要があります。

deny-old-passwordがtrueかつがpassword-history-countが0より大きい場合、世代管理チェックを行います。

定義:
インタフェース PasswordHistoryAccessor 内の checkPasswordHistory
パラメータ:
groupId - グループID
userId - ユーザID
password - 入力パスワード
戻り値:
true：入力チェック成功　false：入力チェック失敗,メッセージ,詳細メッセージ
例外:
PasswordHistoryException - 入力パスワードのチェックに失敗した場合にスローされます。

clearPasswordHistories

public void clearPasswordHistories(String groupId)
                            throws PasswordHistoryException
パスワード履歴の消去。

引数のログイングループのパスワード履歴をすべて消去します。

定義:
インタフェース PasswordHistoryAccessor 内の clearPasswordHistories
パラメータ:
groupId - グループID
例外:
PasswordHistoryException - パスワード履歴の消去に失敗した場合にスローされます。

clearPasswordHistory

public void clearPasswordHistory(String groupId,
                                 String userId)
                          throws PasswordHistoryException
指定ユーザのパスワード履歴の消去。

引数のユーザのパスワード履歴を消去します。

定義:
インタフェース PasswordHistoryAccessor 内の clearPasswordHistory
パラメータ:
groupId - グループID
userId - ユーザID
例外:
PasswordHistoryException - 指定ユーザのパスワード履歴の消去に失敗した場合にスローされます。

getPasswordHistories

public PasswordHistory[] getPasswordHistories(String groupId,
                                              String userId)
                                       throws PasswordHistoryException
パスワード履歴を取得。

指定ユーザのパスワード履歴を取得します。

定義:
インタフェース PasswordHistoryAccessor 内の getPasswordHistories
パラメータ:
groupId - グループID
userId - ユーザID
戻り値:
指定ユーザのパスワード履歴一覧
例外:
PasswordHistoryException - パスワード履歴の取得に失敗した場合にスローされます。

getPasswordHistoryCount

public int getPasswordHistoryCount(String groupId,
                                   String userId)
                            throws PasswordHistoryException
パスワード履歴数を取得。

指定ユーザのパスワード履歴数を取得します。

定義:
インタフェース PasswordHistoryAccessor 内の getPasswordHistoryCount
パラメータ:
groupId - グループID
userId - ユーザID
戻り値:
パスワード履歴数
例外:
PasswordHistoryException - パスワード履歴数の取得に失敗した場合にスローされます。

getPasswordHistoryManagedCount

public int getPasswordHistoryManagedCount(String groupId)
世代管理数を取得。

パスワードの世代管理数を取得します。

定義:
インタフェース PasswordHistoryAccessor 内の getPasswordHistoryManagedCount
パラメータ:
groupId - グループID
戻り値:
パスワード世代管理数

getPasswordPage

public String getPasswordPage(String groupId)
パスワード変更画面のＵＲＬを取得。

パスワード変更画面のＵＲＬを取得します。

定義:
インタフェース PasswordHistoryAccessor 内の getPasswordPage
パラメータ:
groupId - グループID
戻り値:
パスワード変更画面のＵＲＬ

isForwardInitialPage

public boolean isForwardInitialPage(String groupId)
パスワード変更後の画面遷移。

パスワードの有効期限切れによるパスワード再設定後、ログイン画面に戻るか、ログイン処理を継続してログインするかを判定します。

定義:
インタフェース PasswordHistoryAccessor 内の isForwardInitialPage
パラメータ:
groupId - グループID
戻り値:
true：ログイン画面に戻ります。　false：ログイン処理を継続してログインします。

isPasswordExpired

public boolean isPasswordExpired(String groupId,
                                 String userId,
                                 String clientType,
                                 Date date)
パスワードが有効期限切れかどうかの判定。

パスワードが有効期限切れかどうかを行うか判定します。
クライアントタイプがdeny-client-typesに記述されているクライアントタイプの場合はパスワードの有効期限チェックを行いません。

定義:
インタフェース PasswordHistoryAccessor 内の isPasswordExpired
パラメータ:
groupId - グループID
userId - ユーザID
clientType - クライアントタイプ
date - パスワードのチェックの基準となる日付。省略された場合、現在日付が利用されます。
戻り値:
true：パスワード変更要求を行います。　false：パスワード変更要求を行いません。

isPasswordHistoryManaged

public boolean isPasswordHistoryManaged(String groupId)
履歴管理の有無。

履歴管理を行うかどうか判定します。
パラメータ"password-expire-limit"が0の場合履歴管理は行いません。

定義:
インタフェース PasswordHistoryAccessor 内の isPasswordHistoryManaged
パラメータ:
groupId - グループID
戻り値:
ture：履歴管理を行います。　false：履歴管理を行いません。

verifyPasswordHistory

public void verifyPasswordHistory(String groupId,
                                  String userId,
                                  int remain)
                           throws PasswordHistoryException
ユーザのパスワードを消去。

引数 remain の値分残してユーザの履歴を消去します。
引数 remain が0以下の場合、履歴をすべて消去します。

定義:
インタフェース PasswordHistoryAccessor 内の verifyPasswordHistory
パラメータ:
groupId - グループID
userId - ユーザID
remain - 残す履歴の数
例外:
PasswordHistoryException - パスワード履歴の消去に失敗した場合にスローされます。

getLatestPasswordHistory

public PasswordHistory getLatestPasswordHistory(String groupId,
                                                String userId)
                                         throws PasswordHistoryException
最新のパスワードと更新日付を取得。

指定ユーザの最新パスワードと更新日付を取得します。

定義:
インタフェース PasswordHistoryAccessor 内の getLatestPasswordHistory
パラメータ:
groupId - グループID
userId - ユーザID
戻り値:
パスワード、更新日付
例外:
PasswordHistoryException - 最新のパスワード情報の取得に失敗した場合にスローされます。

createPassword

public String createPassword(int count)
パスワードをランダムに生成。

引数の値の長さのパスワードをランダムに生成します。
呼出し毎に異なるパスワードを生成します。

定義:
インタフェース PasswordHistoryAccessor 内の createPassword
パラメータ:
count - パスワードの長さ
戻り値:
生成されたパスワード

isChangePasswordFirstLogin

public boolean isChangePasswordFirstLogin(String groupId)
初回ログイン時にパスワード変更要求を行うかの判定。

定義:
インタフェース PasswordHistoryAccessor 内の isChangePasswordFirstLogin
パラメータ:
groupId - グループID
戻り値:
true：パスワード変更要求を行う / false：パスワード変更要求を行わない

isFirstLogin

public boolean isFirstLogin(String groupId,
                            String userId)
初回ログインの判定

定義:
インタフェース PasswordHistoryAccessor 内の isFirstLogin
パラメータ:
groupId - グループID
userId - ユーザID
戻り値:
true：初回ログイン / false：初回ログインではない

isDenyClientType

public boolean isDenyClientType(String clientType)
クライアントタイプの判定

パラメータdeny-client-typesに記述があるクライアントタイプの判定を行う。

定義:
インタフェース PasswordHistoryAccessor 内の isDenyClientType
パラメータ:
clientType - クライアントタイプ
戻り値:
true：クライアントタイプが含まれている false：クライアントタイプが含まれていない

getPasswordExpireLimit

public int getPasswordExpireLimit(String groupId)
設定したパスワードの有効期限を取得。

パラメータで設定したパスワードの有効期限日数を取得します。

定義:
インタフェース PasswordHistoryAccessor 内の getPasswordExpireLimit
パラメータ:
groupId - グループID
戻り値:
パスワード有効期限日数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.permission.AccessControllerPermissionSelector の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.permission.AccessControllerPermissionSelector の使用

jp.co.intra_mart.foundation.security.permission.AccessControllerPermissionSelector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector の使用

jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.permission.AdminMenuPermissionSelector の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.permission.AdminMenuPermissionSelector の使用

jp.co.intra_mart.foundation.security.permission.AdminMenuPermissionSelector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector の使用

jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.permission.PermissionManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.permission.PermissionManager の使用

jp.co.intra_mart.foundation.security.permission.PermissionManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.permission.PermissionSelector の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.permission.PermissionSelector の使用

PermissionSelector を使用しているパッケージ
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.security.permission | 権限に関連するクラスを提供します。

jp.co.intra_mart.foundation.navigator での PermissionSelector の使用

PermissionSelector を実装している jp.co.intra_mart.foundation.navigator のクラス
 class EventNavigatorPermissionSelector
ユーザIDから有効なID一覧を取得するセレクタ。

jp.co.intra_mart.foundation.security.permission での PermissionSelector の使用

PermissionSelector を実装している jp.co.intra_mart.foundation.security.permission のクラス
class | AccessControllerPermissionSelector ユーザIDから有効なアクセスコントローラのID一覧を取得するセレクタ。
class | AccountRolePermissionSelector ユーザIDから有効なすべてのロールを取得するセレクタ。
class | AdminMenuPermissionSelector ユーザIDから有効なメニューのID一覧を取得するセレクタ。
class | MenuPermissionSelector ユーザIDから有効なメニューのID一覧を取得するセレクタ。

PermissionSelector を返す jp.co.intra_mart.foundation.security.permission のメソッド
 PermissionSelector PermissionManager.getPermissionSelector(String category)
指定されたカテゴリについて、設定XMLファイルで定義されているPermissionSelectorを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AccessControllerPermissionSelector (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.permission
クラス AccessControllerPermissionSelector

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.permission.AccessControllerPermissionSelector
すべての実装インタフェース:
PermissionSelector
public class AccessControllerPermissionSelector
extends Object
implements PermissionSelector

ユーザIDから有効なアクセスコントローラのID一覧を取得するセレクタ。

選択条件としてのユーザIDと日付からアクセス可能なアクセスコントローラのアクセスコントローラIDを選択します。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
AccessControllerPermissionSelector()
コンストラクタ。
メソッドの概要
Collection | doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
void | init(Map param) インスタンスの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AccessControllerPermissionSelector

public AccessControllerPermissionSelector()
コンストラクタ。

メソッドの詳細

doSelection

public Collection doSelection(String groupId,
                              String[] infos)
                       throws AccessSecurityException
選択用情報を利用して選別された情報のリストを返却します。
返却される情報のリストの各要素はJavaBeansの規格に準ずるオブジェクトでなければなりません。

定義:
インタフェース PermissionSelector 内の doSelection
パラメータ:
groupId - ログイングループID
infos - 選択用情報(配列)
0 : ログイングループID
1 : 対象日付(YYYY/MM/DD|hh:mm:ss)(省略可)
対象日付を省略した場合は、現在の日付を使用します。
上記の情報を利用して、選別された情報のリストを作成して返却します。
戻り値:
選別された情報のリスト
例外:
AccessSecurityException

init

public void init(Map param)
インスタンスの初期化を行います。
このインスタンスが生成された時に1度だけコールされます。

定義:
インタフェース PermissionSelector 内の init
パラメータ:
param - XMLで定義されたPermissionSelectorに関連付けられたパラメータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccountRolePermissionSelector (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.permission
クラス AccountRolePermissionSelector

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector
すべての実装インタフェース:
PermissionSelector
public class AccountRolePermissionSelector
extends Object
implements PermissionSelector

ユーザIDから有効なすべてのロールを取得するセレクタ。

選択条件としてのユーザIDからユーザが保有するすべてのロールIDを選択します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
AccountRolePermissionSelector()
コンストラクタ。
メソッドの概要
Collection | doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
void | init(Map param) インスタンスの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AccountRolePermissionSelector

public AccountRolePermissionSelector()
コンストラクタ。

メソッドの詳細

doSelection

public Collection doSelection(String groupId,
                              String[] infos)
                       throws AccessSecurityException
選択用情報を利用して選別された情報のリストを返却します。
返却される情報のリストの各要素はJavaBeansの規格に準ずるオブジェクトでなければなりません。

定義:
インタフェース PermissionSelector 内の doSelection
パラメータ:
groupId - ログイングループID
infos - 選択用情報(配列)
この情報を利用して、選別された情報のリストを作成して返却します。
戻り値:
選別された情報のリスト
例外:
AccessSecurityException

init

public void init(Map param)
インスタンスの初期化を行います。
このインスタンスが生成された時に1度だけコールされます。

定義:
インタフェース PermissionSelector 内の init
パラメータ:
param - XMLで定義されたPermissionSelectorに関連付けられたパラメータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AdminMenuPermissionSelector (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.permission
クラス AdminMenuPermissionSelector

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.permission.AdminMenuPermissionSelector
すべての実装インタフェース:
PermissionSelector
public class AdminMenuPermissionSelector
extends Object
implements PermissionSelector

ユーザIDから有効なメニューのID一覧を取得するセレクタ。

選択条件としてのユーザIDからアクセス可能なメニューのメニューIDを選択します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
AdminMenuPermissionSelector()
コンストラクタ。
メソッドの概要
Collection | doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
void | init(Map param) インスタンスの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AdminMenuPermissionSelector

public AdminMenuPermissionSelector()
コンストラクタ。

メソッドの詳細

doSelection

public Collection doSelection(String groupId,
                              String[] infos)
                       throws AccessSecurityException
選択用情報を利用して選別された情報のリストを返却します。
返却される情報のリストの各要素はJavaBeansの規格に準ずるオブジェクトでなければなりません。

定義:
インタフェース PermissionSelector 内の doSelection
パラメータ:
groupId - ログイングループID
infos - 選択用情報(配列)
この情報を利用して、選別された情報のリストを作成して返却します。
戻り値:
選別された情報のリスト
例外:
AccessSecurityException

init

public void init(Map param)
インスタンスの初期化を行います。
このインスタンスが生成された時に1度だけコールされます。

定義:
インタフェース PermissionSelector 内の init
パラメータ:
param - XMLで定義されたPermissionSelectorに関連付けられたパラメータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuPermissionSelector (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.permission
クラス MenuPermissionSelector

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector
すべての実装インタフェース:
PermissionSelector
public class MenuPermissionSelector
extends Object
implements PermissionSelector

ユーザIDから有効なメニューのID一覧を取得するセレクタ。

選択条件としてのユーザIDからアクセス可能なメニューのメニューIDを選択します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
MenuPermissionSelector()
コンストラクタ。
メソッドの概要
Collection | doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
void | init(Map param) インスタンスの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MenuPermissionSelector

public MenuPermissionSelector()
コンストラクタ。

メソッドの詳細

doSelection

public Collection doSelection(String groupId,
                              String[] infos)
                       throws AccessSecurityException
選択用情報を利用して選別された情報のリストを返却します。
返却される情報のリストの各要素はJavaBeansの規格に準ずるオブジェクトでなければなりません。

定義:
インタフェース PermissionSelector 内の doSelection
パラメータ:
groupId - ログイングループID
infos - 選択用情報(配列)
この情報を利用して、選別された情報のリストを作成して返却します。
戻り値:
選別された情報のリスト
例外:
AccessSecurityException

init

public void init(Map param)
インスタンスの初期化を行います。
このインスタンスが生成された時に1度だけコールされます。

定義:
インタフェース PermissionSelector 内の init
パラメータ:
param - XMLで定義されたPermissionSelectorに関連付けられたパラメータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.permission (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.security.permission
インタフェース
PermissionSelector
クラス
AccessControllerPermissionSelector
AccountRolePermissionSelector
AdminMenuPermissionSelector
MenuPermissionSelector
PermissionManager


jp.co.intra_mart.foundation.security.permission (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.permission

権限に関連するクラスを提供します。

参照:
説明

インタフェースの概要
PermissionSelector パーミッション・作成クラスインタフェース。

クラスの概要
AccessControllerPermissionSelector | ユーザIDから有効なアクセスコントローラのID一覧を取得するセレクタ。
AccountRolePermissionSelector | ユーザIDから有効なすべてのロールを取得するセレクタ。
AdminMenuPermissionSelector | ユーザIDから有効なメニューのID一覧を取得するセレクタ。
MenuPermissionSelector | ユーザIDから有効なメニューのID一覧を取得するセレクタ。
PermissionManager | パーミッション・マネージャクラス。

パッケージ jp.co.intra_mart.foundation.security.permission の説明

権限に関連するクラスを提供します。


jp.co.intra_mart.foundation.security.permission クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.permission の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.permission.AccessControllerPermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.foundation.security.permission.AdminMenuPermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.foundation.security.permission.PermissionManager

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.permission.PermissionSelector


パッケージ jp.co.intra_mart.foundation.security.permission の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.permission の使用

jp.co.intra_mart.foundation.security.permission を使用しているパッケージ
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.security.permission | 権限に関連するクラスを提供します。

jp.co.intra_mart.foundation.navigator により使用される jp.co.intra_mart.foundation.security.permission のクラス
PermissionSelector
パーミッション・作成クラスインタフェース。

jp.co.intra_mart.foundation.security.permission により使用される jp.co.intra_mart.foundation.security.permission のクラス
PermissionSelector
パーミッション・作成クラスインタフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PermissionManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.permission
クラス PermissionManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.permission.PermissionManager
public class PermissionManager
extends Object

パーミッション・マネージャクラス。

パーミッションを生成するマネージャクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
PermissionManager(String groupId)
コンストラクタ。
メソッドの概要
Collection | doSelection(String category, String info) 選択用情報を利用して選別された情報のリストを返却します。
Collection | doSelection(String category, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
String[] | getCategories() 設定XMLファイルで定義されているすべてのカテゴリ名を返却します。
PermissionSelector | getPermissionSelector(String category) 指定されたカテゴリについて、設定XMLファイルで定義されているPermissionSelectorを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PermissionManager

public PermissionManager(String groupId)
                  throws AccessSecurityException
コンストラクタ。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityException - ログイングループIDが不正な場合にスローされます。
メソッドの詳細

getCategories

public String[] getCategories()
設定XMLファイルで定義されているすべてのカテゴリ名を返却します。

戻り値:
カテゴリ名配列
導入されたバージョン:
5.0

getPermissionSelector

public PermissionSelector getPermissionSelector(String category)
                                         throws AccessSecurityException
指定されたカテゴリについて、設定XMLファイルで定義されているPermissionSelectorを返します。
カテゴリに一致する情報がない場合は、nullが返却されます。

パラメータ:
category - 設定ファイル内のカテゴリ名
戻り値:
カテゴリに対応するPermissionSelectorインスタンス
例外:
AccessSecurityException - 引数が不正だった場合にスローされます。

doSelection

public Collection doSelection(String category,
                              String[] infos)
                       throws AccessSecurityException
選択用情報を利用して選別された情報のリストを返却します。
返却される情報のリストの各要素はJavaBeansの規格に準ずるオブジェクトです。

パラメータ:
category - カテゴリ
設定XMLファイルで定義されています。
infos - 選択用情報(配列)
この情報を利用して、選別された情報のリストを作成して返却します。
戻り値:
選別された情報リスト
カテゴリが存在しなかった場合は、nullを返却します。
例外:
AccessSecurityException - パーミッション作成に失敗した場合、または引数が不正だった場合にスローされます。

doSelection

public Collection doSelection(String category,
                              String info)
                       throws AccessSecurityException
選択用情報を利用して選別された情報のリストを返却します。
返却される情報のリストの各要素はJavaBeansの規格に準ずるオブジェクトです。

パラメータ:
category - カテゴリ
設定XMLファイルで定義されています。
info - 選択用情報
この情報を利用して、選別された情報のリストを作成して返却します。
戻り値:
選別された情報リスト
カテゴリが存在しなかった場合は、nullを返却します。
例外:
AccessSecurityException - パーミッション作成に失敗した場合、または引数が不正だった場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PermissionSelector (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.permission
インタフェース PermissionSelector

既知の実装クラスの一覧:
AccessControllerPermissionSelector, AccountRolePermissionSelector, AdminMenuPermissionSelector, EventNavigatorPermissionSelector, MenuPermissionSelector
public interface PermissionSelector

パーミッション・作成クラスインタフェース。 パーミッションの作成クラスが実装するメソッドを定義します。
各種PermissionFactoryクラスは必ずこのインタフェースを実装し、設定XMLファイルに登録します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
Collection | doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
void | init(Map param) インスタンスの初期化を行います。

メソッドの詳細

doSelection

public Collection doSelection(String groupId,
                              String[] infos)
                       throws AccessSecurityException
選択用情報を利用して選別された情報のリストを返却します。
返却される情報のリストの各要素はJavaBeansの規格に準ずるオブジェクトでなければなりません。

パラメータ:
groupId - ログイングループID
infos - 選択用情報(配列)
この情報を利用して、選別された情報のリストを作成して返却します。
戻り値:
選別された情報のリスト
例外:
AccessSecurityException

init

public void init(Map param)
インスタンスの初期化を行います。
このインスタンスが生成された時に1度だけコールされます。

パラメータ:
param - XMLで定義されたPermissionSelectorに関連付けられたパラメータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.role.Role の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.role.Role の使用

Role を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal での Role の使用

Role を返す jp.co.intra_mart.foundation.datastore.application.domain.deal のメソッド
abstract  Role[] DealPermissionManager.getRoles(Deal deal)
取扱情報を保有するアクセス権をもつロールを返します。

jp.co.intra_mart.foundation.navigator での Role の使用

Role を返す jp.co.intra_mart.foundation.navigator のメソッド
Role[] | EventAccessInfo.getRoles()
Role | EventAccessInfo.getRole(int i)

Role 型のパラメータを持つ jp.co.intra_mart.foundation.navigator のメソッド
void | EventAccessInfo.setRoles(Role[] roles)
void | EventAccessInfo.setRole(int i, Role role)
void | EventAccessInfo.addRole(Role role)

jp.co.intra_mart.foundation.security での Role の使用

Role を返す jp.co.intra_mart.foundation.security のメソッド
Role[] | StandardRoleAccessor.getRoleData(String groupId) ロール情報を全件取得します。
Role | StandardRoleAccessor.getRoleData(String groupId, String roleId) ロール情報を取得します。
Role[] | StandardRoleAccessor.getRoleDataByCategory(String groupId, String category) カテゴリからロール情報を取得します。
Role[] | StandardRoleAccessor.getRolesByIds(String groupId, String[] roleIds) 指定されたロールIDのロール情報をすべて取得します。

Role 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | StandardRoleAccessor.createRole(String groupId, Role role) ロール情報を新規追加します。
void | StandardRoleAccessor.updateRole(String groupId, Role role) ロール情報を更新します。

jp.co.intra_mart.foundation.security.access での Role の使用

Role 型のパラメータを持つ jp.co.intra_mart.foundation.security.access のメソッド
void | RoleChangedControllerListener.roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RoleChangedControllerListener.roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.account での Role の使用

Role 型のパラメータを持つ jp.co.intra_mart.foundation.security.account のメソッド
void | RoleChangedAccountListener.roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RoleChangedAccountListener.roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.menu での Role の使用

Role 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | RoleChangedMenuListener.roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RoleChangedMenuListener.roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.role での Role の使用

Role を返す jp.co.intra_mart.foundation.security.role のメソッド
Role | RoleReaderDecorator.doDecoration(String groupId, Role role) ロール情報をデータストアから読み込んだ直後にコールされます。
Role | RoleManager.getRole(String roleId) ロール情報を取得します。
Role[] | RoleManager.getRoles() すべてのロール情報を取得します。
Role[] | RoleManager.getRolesByCategory(String category) カテゴリー検索によりロールを取得します。
Role[] | RoleManager.getRolesByIds(String[] roleIds) ログイングループ内で引数指定したロールIDのロール情報をすべて取得します。
Role[] | RoleManager.searchRolesById(String key) ロールID検索によりロールを取得します。
Role[] | RoleManager.searchRolesByName(String name) ロール名称検索によりロールを取得します。
Role[] | RoleAccessor.getRoleData(String groupId) ロール情報を全件取得する。
Role | RoleAccessor.getRoleData(String groupId, String roleId) ロール情報を取得する。
Role[] | RoleAccessor.getRoleDataByCategory(String groupId, String category) カテゴリからロール情報を取得する。
Role[] | RoleAccessor.getRolesByIds(String groupId, String[] roleIds) 指定されたロールIDのロール情報をすべて取得する。

Role 型のパラメータを持つ jp.co.intra_mart.foundation.security.role のメソッド
Role | RoleReaderDecorator.doDecoration(String groupId, Role role) ロール情報をデータストアから読み込んだ直後にコールされます。
void | RoleQueryWriterListener.queryCreateRole(String groupId, Role role) ロール情報をデータストアに作成する直前にコールされます。
void | RoleQueryWriterListener.queryUpdateRole(String groupId, Role role) ロール情報をデータストアに更新する直前にコールされます。
void | RolePostWriterListener.postCreateRole(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RolePostWriterListener.postUpdateRole(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | RoleManager.addRole(Role role) ロール情報を新規登録します。
void | RoleManager.updateRole(Role role) ロール情報を更新します。
void | RoleChangedListener.roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RoleChangedListener.roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | RoleAccessor.createRole(String groupId, Role role) ロール情報を新規に追加する。
void | RoleAccessor.updateRole(String groupId, Role role) ロール情報を更新する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.role.RoleAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.role.RoleAccessor の使用

RoleAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での RoleAccessor の使用

RoleAccessor を実装している jp.co.intra_mart.foundation.security のクラス
 class StandardRoleAccessor
ロールアクセッサクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.role.RoleChangedListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.role.RoleChangedListener の使用

RoleChangedListener を使用しているパッケージ
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.access での RoleChangedListener の使用

RoleChangedListener を実装している jp.co.intra_mart.foundation.security.access のクラス
 class RoleChangedControllerListener
ロールが削除された場合にアクセスコントローラに紐付くロールを削除するリスナークラスです。

jp.co.intra_mart.foundation.security.account での RoleChangedListener の使用

RoleChangedListener を実装している jp.co.intra_mart.foundation.security.account のクラス
 class RoleChangedAccountListener
ロールが削除された場合にアカウントに紐付くロールを削除するリスナークラス。

jp.co.intra_mart.foundation.security.menu での RoleChangedListener の使用

RoleChangedListener を実装している jp.co.intra_mart.foundation.security.menu のクラス
 class RoleChangedMenuListener
ロールが削除された場合にメニューに紐付くロールを削除するリスナークラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.role.RoleExporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.role.RoleExporter の使用

RoleExporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.role ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.role での RoleExporter の使用

RoleExporter を実装している jp.co.intra_mart.foundation.security.role のクラス
 class StandardRoleBackup
ロールバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.role.RoleImporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.role.RoleImporter の使用

RoleImporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.role ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.role での RoleImporter の使用

RoleImporter を実装している jp.co.intra_mart.foundation.security.role のクラス
 class StandardRoleBackup
ロールバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.role.RoleManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.role.RoleManager の使用

RoleManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.role ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.role での RoleManager の使用

RoleManager 型のパラメータを持つ jp.co.intra_mart.foundation.security.role のメソッド
void | RoleImporter.doImport(InputStream inputStream, RoleManager manager) インポートを行います。
void | RoleExporter.doExport(RoleManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardRoleBackup.doImport(InputStream inputStream, RoleManager manager) インポートを行います。
void | StandardRoleBackup.doExport(RoleManager manager, OutputStream outputStream) エクスポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.role.RolePostWriterListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.role.RolePostWriterListener の使用

jp.co.intra_mart.foundation.security.role.RolePostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener の使用

jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.role.RoleReaderDecorator の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.role.RoleReaderDecorator の使用

jp.co.intra_mart.foundation.security.role.RoleReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.role.StandardRoleBackup の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.role.StandardRoleBackup の使用

jp.co.intra_mart.foundation.security.role.StandardRoleBackup はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.security.role (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.security.role
インタフェース
RoleAccessor
RoleChangedListener
RoleExporter
RoleImporter
RolePostWriterListener
RoleQueryWriterListener
RoleReaderDecorator
クラス
Role
RoleManager
StandardRoleBackup


jp.co.intra_mart.foundation.security.role (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.role

ロールに関連するクラスを提供します。

参照:
説明

インタフェースの概要
RoleAccessor | ロールアクセッサインタフェース。
RoleChangedListener | ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
RoleExporter | ロールエクスポートインタフェースです。
RoleImporter | ロールインポートインタフェースです。
RolePostWriterListener | ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
RoleQueryWriterListener | ロール情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
RoleReaderDecorator | ロール情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

クラスの概要
Role | ロール・モデルインタフェース。
RoleManager | ロールマネージャクラス。
StandardRoleBackup | ロールバックアップクラスです。

パッケージ jp.co.intra_mart.foundation.security.role の説明

ロールに関連するクラスを提供します。


jp.co.intra_mart.foundation.security.role クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.role の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.role.Role (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.role.RoleManager
    • class jp.co.intra_mart.foundation.security.role.StandardRoleBackup (implements jp.co.intra_mart.foundation.security.role.RoleExporter, jp.co.intra_mart.foundation.security.role.RoleImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.role.RoleAccessor
  • interface jp.co.intra_mart.foundation.security.role.RoleChangedListener
  • interface jp.co.intra_mart.foundation.security.role.RoleExporter
  • interface jp.co.intra_mart.foundation.security.role.RoleImporter
  • interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener
  • interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.role.RoleReaderDecorator


パッケージ jp.co.intra_mart.foundation.security.role の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.role の使用

jp.co.intra_mart.foundation.security.role を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.deal により使用される jp.co.intra_mart.foundation.security.role のクラス
Role
ロール・モデルインタフェース。

jp.co.intra_mart.foundation.navigator により使用される jp.co.intra_mart.foundation.security.role のクラス
Role
ロール・モデルインタフェース。

jp.co.intra_mart.foundation.security により使用される jp.co.intra_mart.foundation.security.role のクラス
Role
ロール・モデルインタフェース。
RoleAccessor
ロールアクセッサインタフェース。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.security.role のクラス
Role
ロール・モデルインタフェース。
RoleChangedListener
ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

jp.co.intra_mart.foundation.security.account により使用される jp.co.intra_mart.foundation.security.role のクラス
Role
ロール・モデルインタフェース。
RoleChangedListener
ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.security.role のクラス
Role
ロール・モデルインタフェース。
RoleChangedListener
ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

jp.co.intra_mart.foundation.security.role により使用される jp.co.intra_mart.foundation.security.role のクラス
Role
ロール・モデルインタフェース。
RoleExporter
ロールエクスポートインタフェースです。
RoleImporter
ロールインポートインタフェースです。
RoleManager
ロールマネージャクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Role (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
クラス Role

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.role.Role
すべての実装インタフェース:
Serializable
public class Role
extends Object
implements Serializable

ロール・モデルインタフェース。

ロールのデータモデルインタフェースを定義する。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
Role()
コンストラクタ。
Role(String roleId)
コンストラクタ。
Role(String roleId, String roleName)
コンストラクタ。
メソッドの概要
boolean | equals(Object role) データモデルのチェック。
String | getCategory() ロールカテゴリを取得します。
String | getDescription() 説明を取得します。
String | getDisplayName(Locale locale) ロール表示名を取得します。
Locale[] | getLocales() ロケールの一覧を取得します。
String | getRoleId() ロールIDを取得します。
String | getRoleName() ロール名を取得します。
int | hashCode() ハッシュコードを取得します。
void | removeDisplayName(Locale locale) ロケールに対応したロール表示名を削除します。
void | setCategory(String category) ロールカテゴリを設定します。
void | setDescription(String description) 説明を設定します。
void | setDisplayName(Locale locale, String displayName) ロール表示名を設定します。
void | setRoleId(String roleId) ロールIDを設定します。
void | setRoleName(String name) ロール名を設定します。
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Role

public Role()
コンストラクタ。

ロールIDは自動採番されます。

Role

public Role(String roleId)
コンストラクタ。

パラメータ:
roleId - ロールID

Role

public Role(String roleId,
            String roleName)
     throws IOException
コンストラクタ。

パラメータ:
roleId - ロールID
roleName - ロール名
メソッドの詳細

equals

public boolean equals(Object role)
データモデルのチェック。

指定されたオブジェクトがモデルと一致するかをチェックする

パラメータ:
role - :チェック対象のオブジェクト
戻り値:
true :オブジェクトがモデルと一致 false :オブジェクトがモデルと不一致
関連項目:
Object.equals(Object)

getCategory

public String getCategory()
ロールカテゴリを取得します。

戻り値:
ロールカテゴリ

getDescription

public String getDescription()
説明を取得します。

戻り値:
ロールの説明

getDisplayName

public String getDisplayName(Locale locale)
ロール表示名を取得します。

ロケールに対応したロール表示名を取得します。
存在しないロケールの場合は空文字を返します 。

パラメータ:
locale - ロケール
戻り値:
ロール表示名

getLocales

public Locale[] getLocales()
ロケールの一覧を取得します。

表示名として登録されているロケールの一覧を取得します。

戻り値:
登録されているロケールの一覧。

getRoleId

public String getRoleId()
ロールIDを取得します。

戻り値:
ロールID

getRoleName

public String getRoleName()
ロール名を取得します。

戻り値:
ロール名

hashCode

public int hashCode()
ハッシュコードを取得します。

戻り値:
ハッシュコード
関連項目:
Object.hashCode()

setCategory

public void setCategory(String category)
ロールカテゴリを設定します。

パラメータ:
category - ロールカテゴリ

setDescription

public void setDescription(String description)
説明を設定します。

パラメータ:
description - ロールの説明

setDisplayName

public void setDisplayName(Locale locale,
                           String displayName)
ロール表示名を設定します。

ロケールに対応したロール表示名を設定します。

パラメータ:
locale - ロケール
displayName - ロール表示名

removeDisplayName

public void removeDisplayName(Locale locale)
ロケールに対応したロール表示名を削除します。

ロケールに対応したロール表示名を削除します。

パラメータ:
locale - ロケール

setRoleId

public void setRoleId(String roleId)
ロールIDを設定します。

パラメータ:
roleId - ロールID

setRoleName

public void setRoleName(String name)
ロール名を設定します。

パラメータ:
name - ロール名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


RoleAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
インタフェース RoleAccessor

既知の実装クラスの一覧:
StandardRoleAccessor
public interface RoleAccessor

ロールアクセッサインタフェース。

ロール情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | createRole(String groupId, Role role) ロール情報を新規に追加する。
void | deleteCategory(String groupId) すべてのカテゴリを削除する。
void | deleteCategory(String groupId, String category) カテゴリを削除する。
void | deleteRole(String groupId) すべてのロール情報を削除する。
void | deleteRole(String groupId, String roleId) ロール情報を削除する。
void | deleteSubRole(String groupId, String roleId) 指定したロールのサブロールIDサマリを全削除する。
void | deleteSubRole(String groupId, String roleId, String subRoleId) サブロールIDサマリを削除する。
String[] | getAllParentRoleIds(String groupId, String roleId) すべての親ロールの一覧を取得する。
String[] | getAllSubRoleIds(String groupId, String roleId) すべてのサブロールの一覧を取得する。
String[] | getCategories(String groupId) カテゴリの一覧を取得する。
String[] | getParentRoleIds(String groupId, String roleId) 親ロールの一覧を取得する。
Role[] | getRoleData(String groupId) ロール情報を全件取得する。
Role | getRoleData(String groupId, String roleId) ロール情報を取得する。
Role[] | getRoleDataByCategory(String groupId, String category) カテゴリからロール情報を取得する。
Role[] | getRolesByIds(String groupId, String[] roleIds) 指定されたロールIDのロール情報をすべて取得する。
String[] | getSubRoleIds(String groupId, String roleId) サブロールIDサマリを取得する。
void | init(Map params) ロールアクセッサの初期化。
void | insertSubRole(String groupId, String roleId, String subRoleId) サブロールを作成する。
void | updateCategory(String groupId, String oldCategory, String newCategory) カテゴリを更新する。
void | updateRole(String groupId, Role role) ロール情報を更新する。

メソッドの詳細

createRole

public void createRole(String groupId,
                       Role role)
                throws AccessSecurityWriteException
ロール情報を新規に追加する。

パラメータ:
groupId - ログイングループID
role - ロール情報
例外:
AccessSecurityWriteException - ロール情報の作成に失敗した場合にスローされます。

deleteCategory

public void deleteCategory(String groupId)
                    throws AccessSecurityWriteException
すべてのカテゴリを削除する。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException - カテゴリの削除に失敗した場合にスローされます。

deleteCategory

public void deleteCategory(String groupId,
                           String category)
                    throws AccessSecurityWriteException
カテゴリを削除する。

パラメータ:
groupId - ログイングループID
category - カテゴリ名
例外:
AccessSecurityWriteException - カテゴリの削除に失敗した場合にスローされます。

deleteRole

public void deleteRole(String groupId)
                throws AccessSecurityWriteException
すべてのロール情報を削除する。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException - ロール情報の削除に失敗した場合にスローされます。

deleteRole

public void deleteRole(String groupId,
                       String roleId)
                throws AccessSecurityWriteException
ロール情報を削除する。

パラメータ:
groupId - ログイングループID
roleId - ロールID
例外:
AccessSecurityWriteException - ロール情報の削除に失敗した場合にスローされます。

getAllParentRoleIds

public String[] getAllParentRoleIds(String groupId,
                                    String roleId)
                             throws AccessSecurityReadException
すべての親ロールの一覧を取得する。

引数に指定したロールの上位階層にあるすべての親ロールを取得する。
親ロールが一件も存在しない場合空の配列を返却する。

パラメータ:
groupId - ログイングループID
roleId - ロールID
戻り値:
すべての親ロールIDの配列
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getAllSubRoleIds

public String[] getAllSubRoleIds(String groupId,
                                 String roleId)
                          throws AccessSecurityReadException
すべてのサブロールの一覧を取得する。

引数に指定したロールの下位階層にあるすべてのサブロールを取得する。
サブロールが一件も存在しない場合空の配列を返却する。

パラメータ:
groupId - ログイングループID
roleId - ロールID
戻り値:
すべてのサブロールIDの配列
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getCategories

public String[] getCategories(String groupId)
                       throws AccessSecurityReadException
カテゴリの一覧を取得する。

指定したログイングループに属するカテゴリが存在しない場合は空の配列を返却する。

パラメータ:
groupId - ログイングループID
戻り値:
カテゴリ名の配列
例外:
AccessSecurityReadException - カテゴリの取得に失敗した場合にスローされます。

getParentRoleIds

public String[] getParentRoleIds(String groupId,
                                 String roleId)
                          throws AccessSecurityReadException
親ロールの一覧を取得する。

引数に指定したロールの１階層上位にあるすべての親ロールを取得する。
親ロールが一件も存在しない場合空の配列を返却する。

パラメータ:
groupId - ログイングループID
roleId - ロールID
戻り値:
親ロールIDの配列
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getRoleData

public Role[] getRoleData(String groupId)
                   throws AccessSecurityReadException
ロール情報を全件取得する。

指定されたログイングループに属するロールが存在しない場合は空の配列を返却する。

パラメータ:
groupId - ログイングループID
戻り値:
ロール情報の配列
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getRoleData

public Role getRoleData(String groupId,
                        String roleId)
                 throws AccessSecurityReadException
ロール情報を取得する。

指定されたロールIDをもつロールが存在しない場合はnullを返す

パラメータ:
groupId - ログイングループID
roleId - ロールID
戻り値:
ロールデータ
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getRoleDataByCategory

public Role[] getRoleDataByCategory(String groupId,
                                    String category)
                             throws AccessSecurityReadException
カテゴリからロール情報を取得する。

指定されたカテゴリに属するロール情報を取得する
指定したカテゴリーに属するロールが存在しない場合は空の配列を返却する。

パラメータ:
groupId - ログイングループID
category - カテゴリ名
戻り値:
ロール情報の配列
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getRolesByIds

public Role[] getRolesByIds(String groupId,
                            String[] roleIds)
                     throws AccessSecurityReadException
指定されたロールIDのロール情報をすべて取得する。

パラメータ:
groupId - ログイングループID
roleIds - ロールIDの配列
戻り値:
ロールオブジェクトの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - ロール情報取得に失敗した場合スローされます。

init

public void init(Map params)
ロールアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

updateCategory

public void updateCategory(String groupId,
                           String oldCategory,
                           String newCategory)
                    throws AccessSecurityWriteException
カテゴリを更新する。

旧カテゴリ名を新カテゴリ名に更新する。

パラメータ:
groupId - ログイングループID
oldCategory - 旧カテゴリ名
newCategory - 新カテゴリ名
例外:
AccessSecurityWriteException - カテゴリの更新に失敗した場合にスローされます。

updateRole

public void updateRole(String groupId,
                       Role role)
                throws AccessSecurityWriteException
ロール情報を更新する。

パラメータ:
groupId - ログイングループID
role - ロール情報
例外:
AccessSecurityWriteException - ロール情報の更新に失敗した場合にスローされます。

insertSubRole

public void insertSubRole(String groupId,
                          String roleId,
                          String subRoleId)
                   throws AccessSecurityWriteException
サブロールを作成する。

パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 追加するサブロールID
例外:
AccessSecurityWriteException - ロール情報の更新に失敗した場合にスローされます。

deleteSubRole

public void deleteSubRole(String groupId,
                          String roleId,
                          String subRoleId)
                   throws AccessSecurityWriteException
サブロールIDサマリを削除する。

パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 削除するサブロールID
例外:
AccessSecurityWriteException - ロール情報の更新に失敗した場合にスローされます。

deleteSubRole

public void deleteSubRole(String groupId,
                          String roleId)
                   throws AccessSecurityWriteException
指定したロールのサブロールIDサマリを全削除する。

パラメータ:
groupId - ログイングループID
roleId - ロールID
例外:
AccessSecurityWriteException - ロール情報の更新に失敗した場合にスローされます。

getSubRoleIds

public String[] getSubRoleIds(String groupId,
                              String roleId)
                       throws AccessSecurityReadException
サブロールIDサマリを取得する。

パラメータ:
groupId - ログイングループID
roleId - ロールID
戻り値:
String[] サブロールID
例外:
AccessSecurityWriteException - ロール情報の更新に失敗した場合にスローされます。
AccessSecurityReadException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


RoleChangedListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
インタフェース RoleChangedListener

既知の実装クラスの一覧:
RoleChangedAccountListener, RoleChangedControllerListener, RoleChangedMenuListener
public interface RoleChangedListener

ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | init(Map params) ロールリスナーの初期化。
void | roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | roleDeleted(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | subRoleAdded(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | subRoleDeleted(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
ロールリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

roleAdded

public void roleAdded(String groupId,
                      Role role)
               throws ChangedListenerException
ロール情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
role - 作成されたロール
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

roleDeleted

public void roleDeleted(String groupId,
                        String roleId)
                 throws ChangedListenerException
ロール情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
roleId - 削除されたロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

roleUpdated

public void roleUpdated(String groupId,
                        Role role)
                 throws ChangedListenerException
ロール情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
role - 更新されたロール
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

subRoleAdded

public void subRoleAdded(String groupId,
                         String roleId,
                         String subRoleId)
                  throws ChangedListenerException
ロールにサブロールを追加した直後にコールされます。

パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 追加されたサブロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

subRoleDeleted

public void subRoleDeleted(String groupId,
                           String roleId,
                           String subRoleId)
                    throws ChangedListenerException
ロールからサブロールを削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 削除されたサブロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleExporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
インタフェース RoleExporter

既知の実装クラスの一覧:
StandardRoleBackup
public interface RoleExporter

ロールエクスポートインタフェースです。

バージョン:
1.0

メソッドの概要
void | doExport(RoleManager manager, OutputStream outputStream) エクスポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doExport

public void doExport(RoleManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

ロール情報をバックアップファイルに出力します。

パラメータ:
manager - ロールマネージャ
outputStream - 出力ストリーム
例外:
AccessSecurityExportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleImporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
インタフェース RoleImporter

既知の実装クラスの一覧:
StandardRoleBackup
public interface RoleImporter

ロールインポートインタフェースです。

バージョン:
1.0

メソッドの概要
void | doImport(InputStream inputStream, RoleManager manager) インポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doImport

public void doImport(InputStream inputStream,
                     RoleManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からロール情報を取得し、生成します。

パラメータ:
manager - ロールマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
クラス RoleManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.role.RoleManager
public class RoleManager
extends Object

ロールマネージャクラス。

ロール情報に関連する操作を行います。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
RoleManager(String gid)
コンストラクタ。
メソッドの概要
void | addRole(Role role) ロール情報を新規登録します。
void | addSubRole(String roleId, String subRoleId) サブロールIDを追加します。
boolean | certify(String[] users, String[] roles) ロール内包を認証します。
boolean | contains(String roleId) ロールの存在チェックを行います。
boolean | containsCategory(String category) カテゴリーの存在チェックをします。
int | count() ロール数を取得します。
int | countByCategory(String category) カテゴリーに属するロール数を取得します。
void | deleteCategories() すべてのカテゴリーを削除します。
void | deleteCategory(String category) カテゴリーを削除します。
void | deleteRole(String roleId) ロールを削除します。
void | deleteRoles() すべてのロールを削除します。
void | deleteSubRole(String roleId, String subRoleId) 指定したサブロールIDを削除します。
void | deleteSubRoles(String roleId) 全てのサブロールIDを削除します。
void | exportData(String category, OutputStream outputStream) ロール情報・エクスポート。
String[] | getAllParentRoleIds(String roleId) 全ての親ロールIDを取得します。
String[] | getAllSubRoleIds(String roleId) 全てのサブロールサマリを取得します。
String[] | getCategories() カテゴリーの一覧を取得します。
String[] | getExportCategories() ロールエクスポート用のカテゴリの一覧を取得します。
String[] | getImportCategories() ロールインポート用のカテゴリの一覧を取得します。
String | getLoginGroupId() ログイングループIDを取得します。
String[] | getParentRoleIds(String roleId) 親ロールIDを取得します。
Role | getRole(String roleId) ロール情報を取得します。
String[] | getRoleIds() すべてのロールIDを取得します。
Role[] | getRoles() すべてのロール情報を取得します。
Role[] | getRolesByCategory(String category) カテゴリー検索によりロールを取得します。
Role[] | getRolesByIds(String[] roleIds) ログイングループ内で引数指定したロールIDのロール情報をすべて取得します。
String[] | getSubRole(String roleId) サブロール(一階層のみ)を取得します。
void | importData(String category, InputStream inputStream) ロール情報・インポート。
boolean | isUpdate(Date date) ロール情報が指定された日付よりも新しいかチェックします。
void | moveCategory(String oldCategory, String newCategory) カテゴリーを更新します。
Role[] | searchRolesById(String key) ロールID検索によりロールを取得します。
Role[] | searchRolesByName(String name) ロール名称検索によりロールを取得します。
void | updateRole(Role role) ロール情報を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RoleManager

public RoleManager(String gid)
            throws AccessSecurityException
コンストラクタ。

パラメータ:
gid - ログイングループID
例外:
AccessSecurityException - 指定のログイングループIDが不正の場合にスローされます。
メソッドの詳細

addRole

public void addRole(Role role)
             throws AccessSecurityException
ロール情報を新規登録します。

ロール情報をデータソースに新規登録します。

パラメータ:
role - ロール情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

addSubRole

public void addSubRole(String roleId,
                       String subRoleId)
                throws AccessSecurityException
サブロールIDを追加します。

パラメータ:
roleId - ロールID
subRoleId - サブロールID
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

certify

public boolean certify(String[] users,
                       String[] roles)
                throws AccessSecurityException
ロール内包を認証します。

第1引数で指定されたロール配列と第2引数で指定されたロールの配列で同一のものがあるかをチェックします。
第1引数のロールのみ、ネストしたロールも含めてチェックします。

パラメータ:
users - ロールIDの配列
roles - ロールIDの配列
戻り値:
同じロールがある場合:true ない場合:false
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

contains

public boolean contains(String roleId)
                 throws AccessSecurityException
ロールの存在チェックを行います。

指定のロールが存在するかをチェックします。

パラメータ:
roleId - ロールID
戻り値:
true: 指定のロールが存在します。
false: 指定のロールが存在しません。
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

containsCategory

public boolean containsCategory(String category)
                         throws AccessSecurityException
カテゴリーの存在チェックをします。

指定のカテゴリーが該当するログイングループ内で登録されているかをチェックします。

パラメータ:
category - カテゴリー
戻り値:
true:登録済み false:未登録
例外:
AccessSecurityException - 引数が不正だった場合にスローされます。

count

public int count()
          throws AccessSecurityReadException
ロール数を取得します。

ログイングループ内のロール数を取得します。

戻り値:
ロール数
例外:
AccessSecurityReadException - 読み込み処理に失敗した場合にスローされます。

countByCategory

public int countByCategory(String category)
                    throws AccessSecurityException
カテゴリーに属するロール数を取得します。

ログイングループ内の指定カテゴリーに属するロールの数を取得します。

戻り値:
ロール数
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteCategories

public void deleteCategories()
                      throws AccessSecurityException
すべてのカテゴリーを削除します。

ログイングループに属するカテゴリーを全件削除します

例外:
AccessSecurityException - 更新処理に失敗した場合にスローされます。

deleteCategory

public void deleteCategory(String category)
                    throws AccessSecurityException
カテゴリーを削除します。

ログイングループ内のカテゴリーを削除します。

パラメータ:
category - カテゴリー
例外:
AccessSecurityReadException - 読み込み処理、または書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。
AccessSecurityException

deleteRole

public void deleteRole(String roleId)
                throws AccessSecurityException
ロールを削除します。

指定のロール情報を削除します。

パラメータ:
roleId - ロールID
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteRoles

public void deleteRoles()
                 throws AccessSecurityException
すべてのロールを削除します。

すべてのロール情報を削除します 。

例外:
AccessSecurityException - 書き込み処理、または読み込み処理に失敗した場合にスローされます。

deleteSubRole

public void deleteSubRole(String roleId,
                          String subRoleId)
                   throws AccessSecurityException
指定したサブロールIDを削除します。

パラメータ:
roleId - ロールID
subRoleId - サブロールID
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteSubRoles

public void deleteSubRoles(String roleId)
                    throws AccessSecurityException
全てのサブロールIDを削除します。

パラメータ:
roleId -
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

exportData

public void exportData(String category,
                       OutputStream outputStream)
                throws AccessSecurityException
ロール情報・エクスポート。

パラメータ:
category - カテゴリ
outputStream - 出力ストリーム
例外:
AccessSecurityException - エクスポートに失敗した場合、または引数が不正だった場合にスローされます。

getAllParentRoleIds

public String[] getAllParentRoleIds(String roleId)
                             throws AccessSecurityException
全ての親ロールIDを取得します。

指定したロールに属する親ロールのロールIDをすべて取得します。
ネストした親ロールについても全て取得します。
存在しない場合は空の文字列を返却します。

パラメータ:
roleId - ロールID
戻り値:
親ロールのロールID配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getAllSubRoleIds

public String[] getAllSubRoleIds(String roleId)
                          throws AccessSecurityException
全てのサブロールサマリを取得します。

パラメータ:
roleId - ロールID
戻り値:
サブロールIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getCategories

public String[] getCategories()
                       throws AccessSecurityReadException
カテゴリーの一覧を取得します。

ログイングループに属するカテゴリーの一覧を取得します。

戻り値:
カテゴリー一覧
例外:
AccessSecurityReadException - 読み込み処理に失敗した場合にスローされます。

getExportCategories

public String[] getExportCategories()
                             throws AccessSecurityException
ロールエクスポート用のカテゴリの一覧を取得します。

戻り値:
ロールエクスポート用カテゴリの一覧
例外:
AccessSecurityException - ロールエクスポート用のカテゴリの取得に失敗した場合にスローされます。

getImportCategories

public String[] getImportCategories()
                             throws AccessSecurityException
ロールインポート用のカテゴリの一覧を取得します。

戻り値:
ロールインポート用カテゴリの一覧
例外:
AccessSecurityException - ロールインポート用のカテゴリの取得に失敗した場合にスローされます。

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

戻り値:
ログイングループID

getParentRoleIds

public String[] getParentRoleIds(String roleId)
                          throws AccessSecurityException
親ロールIDを取得します。

指定のロールの一階層上のロールを取得します。
存在しない場合は空の配列を返却します。

パラメータ:
roleId - ロールID
戻り値:
親ロールIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getRole

public Role getRole(String roleId)
             throws AccessSecurityException
ロール情報を取得します。

指定されたロールの情報を取得します。
存在しない場合はnullを返却します。

パラメータ:
roleId - ロールID
戻り値:
ロール情報
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getRoleIds

public String[] getRoleIds()
                    throws AccessSecurityReadException
すべてのロールIDを取得します。

ログイングループ内で登録されている全てのロールのIDを取得します。
存在しない場合は空の配列を返却します。

戻り値:
ロールIDの配列
例外:
AccessSecurityReadException - 読み込み処理に失敗した場合にスローされます。

getRoles

public Role[] getRoles()
                throws AccessSecurityReadException
すべてのロール情報を取得します。

ログイングループ内のロール情報を全て取得します。

戻り値:
ロール情報の配列(存在しない場合は空のモデルを返却します。)
例外:
AccessSecurityReadException - 読み込み処理に失敗した場合にスローされます。

getRolesByCategory

public Role[] getRolesByCategory(String category)
                          throws AccessSecurityException
カテゴリー検索によりロールを取得します。

指定したカテゴリーに属するロール情報を全て取得します。

パラメータ:
category - カテゴリー
戻り値:
ロールの配列(検索にヒットしない場合は空のロール)
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getRolesByIds

public Role[] getRolesByIds(String[] roleIds)
                     throws AccessSecurityException
ログイングループ内で引数指定したロールIDのロール情報をすべて取得します。

パラメータ:
roleIds - ロールIDの配列
戻り値:
ロール情報の配列（データがない場合は空の配列を返します。）
例外:
AccessSecurityException - ロール情報の取得に失敗した場合にスローされます。

getSubRole

public String[] getSubRole(String roleId)
                    throws AccessSecurityException
サブロール(一階層のみ)を取得します。

パラメータ:
roleId -
戻り値:
ロールの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

importData

public void importData(String category,
                       InputStream inputStream)
                throws AccessSecurityException
ロール情報・インポート。

パラメータ:
category - カテゴリ
inputStream - 入力ストリーム
例外:
AccessSecurityException - インポートに失敗した場合、または引数が不正だった場合にスローされます。

moveCategory

public void moveCategory(String oldCategory,
                         String newCategory)
                  throws AccessSecurityException
カテゴリーを更新します。

ログイングループ内のカテゴリーを更新します。

パラメータ:
oldCategory - 旧カテゴリー
newCategory - 新カテゴリー
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

searchRolesById

public Role[] searchRolesById(String key)
                       throws AccessSecurityException
ロールID検索によりロールを取得します。

引数に類似(前方後方一致)するロールIDを持つロール情報を全て取得します。

パラメータ:
key - 検索ロールID
戻り値:
ロールの配列(検索にヒットしない場合は空のロール)
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

searchRolesByName

public Role[] searchRolesByName(String name)
                         throws AccessSecurityException
ロール名称検索によりロールを取得します。

引数に類似(前方後方一致)する名称を持つロール情報を全て取得します。

パラメータ:
name - 検索ロール名称
戻り値:
ロールの配列(検索にヒットしない場合は空の配列)
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

updateRole

public void updateRole(Role role)
                throws AccessSecurityException
ロール情報を更新します。

データソース上の指定のロール情報を更新します。

パラメータ:
role - ロール情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

isUpdate

public boolean isUpdate(Date date)
                 throws AccessSecurityException
ロール情報が指定された日付よりも新しいかチェックします。

パラメータ:
date - チェック日付
例外:
AccessSecurityReadException - 更新チェックに失敗した場合スローされます。
AccessSecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RolePostWriterListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
インタフェース RolePostWriterListener

public interface RolePostWriterListener

ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | init(Map params) ロールリスナーの初期化。
void | postCreateRole(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | postCreateSubRole(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | postDeleteRole(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | postDeleteSubRole(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。
void | postUpdateRole(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
ロールリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreateRole

public void postCreateRole(String groupId,
                           Role role)
                    throws AccessSecurityListenerExcpetion
ロール情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
role - 作成されたロール
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteRole

public void postDeleteRole(String groupId,
                           String roleId)
                    throws AccessSecurityListenerExcpetion
ロール情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
roleId - 削除されたロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateRole

public void postUpdateRole(String groupId,
                           Role role)
                    throws AccessSecurityListenerExcpetion
ロール情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
role - 更新されたロール
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postCreateSubRole

public void postCreateSubRole(String groupId,
                              String roleId,
                              String subRoleId)
                       throws AccessSecurityListenerExcpetion
ロールにサブロールを追加した直後にコールされます。

パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 追加されたサブロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteSubRole

public void postDeleteSubRole(String groupId,
                              String roleId,
                              String subRoleId)
                       throws AccessSecurityListenerExcpetion
ロールからサブロールを削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 削除されたサブロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleQueryWriterListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
インタフェース RoleQueryWriterListener

public interface RoleQueryWriterListener

ロール情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | init(Map params) ロールリスナーの初期化。
void | postCreateSubRole(String groupId, String roleId, String subRoleId) ロールにサブロールを追加する直前にコールされます。
void | postDeleteSubRole(String groupId, String roleId, String subRoleId) ロールからサブロールを削除する直前にコールされます。
void | queryCreateRole(String groupId, Role role) ロール情報をデータストアに作成する直前にコールされます。
void | queryDeleteRole(String groupId, String roleId) ロール情報をデータストアから削除する直前にコールされます。
void | queryUpdateRole(String groupId, Role role) ロール情報をデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
ロールリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreateRole

public void queryCreateRole(String groupId,
                            Role role)
                     throws AccessSecurityListenerExcpetion
ロール情報をデータストアに作成する直前にコールされます。

パラメータ:
groupId - ログイングループID
role - 作成されるロール
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteRole

public void queryDeleteRole(String groupId,
                            String roleId)
                     throws AccessSecurityListenerExcpetion
ロール情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
roleId - 削除されるロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdateRole

public void queryUpdateRole(String groupId,
                            Role role)
                     throws AccessSecurityListenerExcpetion
ロール情報をデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
role - 更新されるロール
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postCreateSubRole

public void postCreateSubRole(String groupId,
                              String roleId,
                              String subRoleId)
                       throws AccessSecurityListenerExcpetion
ロールにサブロールを追加する直前にコールされます。

パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 追加されるサブロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteSubRole

public void postDeleteSubRole(String groupId,
                              String roleId,
                              String subRoleId)
                       throws AccessSecurityListenerExcpetion
ロールからサブロールを削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 削除されるサブロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleReaderDecorator (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
インタフェース RoleReaderDecorator

public interface RoleReaderDecorator

ロール情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
Role | doDecoration(String groupId, Role role) ロール情報をデータストアから読み込んだ直後にコールされます。
void | init(Map params) ロールデコレータの初期化。

メソッドの詳細

doDecoration

public Role doDecoration(String groupId,
                         Role role)
ロール情報をデータストアから読み込んだ直後にコールされます。

パラメータ:
groupId - ログイングループID
role - 読み込みが行われたロール情報
戻り値:
拡張されたロール情報

init

public void init(Map params)
ロールデコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


StandardRoleBackup (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
クラス StandardRoleBackup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.role.StandardRoleBackup
すべての実装インタフェース:
RoleExporter, RoleImporter
public class StandardRoleBackup
extends Object
implements RoleImporter, RoleExporter

ロールバックアップクラスです。

バージョン:
1.0

フィールドの概要
static String KIND_ROLE
種別 ロール。
コンストラクタの概要
StandardRoleBackup()
メソッドの概要
void | doExport(RoleManager manager, OutputStream outputStream) エクスポートを行います。
void | doImport(InputStream inputStream, RoleManager manager) インポートを行います。
void | init(Map params) 初期化。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KIND_ROLE

public static final String KIND_ROLE
種別 ロール。

関連項目:
定数フィールド値
コンストラクタの詳細

StandardRoleBackup

public StandardRoleBackup()
メソッドの詳細

init

public void init(Map params)
初期化。

初期化する。

定義:
インタフェース RoleImporter 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     RoleManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からロール情報を生成します。

定義:
インタフェース RoleImporter 内の doImport
パラメータ:
manager - ロールマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

doExport

public void doExport(RoleManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

ロールバックアップ情報を生成し、ストリームに返却します。

定義:
インタフェース RoleExporter 内の doExport
パラメータ:
manager - ロールマネージャクラス
outputStream - 出力ストリーム
例外:
AccessSecurityExportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet の使用

jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.servlet.LogoutInitialUrlValidator の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.servlet.LogoutInitialUrlValidator の使用

jp.co.intra_mart.foundation.security.servlet.LogoutInitialUrlValidator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.servlet.LogoutServlet の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.servlet.LogoutServlet の使用

jp.co.intra_mart.foundation.security.servlet.LogoutServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.servlet.MenuServlet の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.servlet.MenuServlet の使用

jp.co.intra_mart.foundation.security.servlet.MenuServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet の使用

jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet の使用

jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.servlet.UserInitialServlet の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.servlet.UserInitialServlet の使用

jp.co.intra_mart.foundation.security.servlet.UserInitialServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


GroupSuperUserInitialServlet (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.servlet
クラス GroupSuperUserInitialServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
public class GroupSuperUserInitialServlet
extends HttpServlet

グループ管理者初期アクセスサーブレット。

システム管理者での初期アクセスを処理するサーブレット。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
GroupSuperUserInitialServlet()
メソッドの概要
void | destroy() サーブレットの放棄を行います。
protected void | doGet(HttpServletRequest request, HttpServletResponse response) GETメソッドに対するサービスを行います。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) POSTメソッドに対するサービスを行います。
void | init() サーブレットの初期化を行います。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GroupSuperUserInitialServlet

public GroupSuperUserInitialServlet()
メソッドの詳細

destroy

public void destroy()
サーブレットの放棄を行います。

導入されたバージョン:
5.0
関連項目:
Servlet.destroy()

init

public void init()
          throws ServletException
サーブレットの初期化を行います。

例外:
ServletException
導入されたバージョン:
5.0
関連項目:
GenericServlet.init()

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
GETメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doGet(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
POSTメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doPost(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LogoutInitialUrlValidator (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.servlet
インタフェース LogoutInitialUrlValidator

public interface LogoutInitialUrlValidator

ログアウト後に遷移するURL検証インタフェース ログアウト後に遷移するURLを検証するためのインタフェースです。

導入されたバージョン:
6.0.9

メソッドの概要
 String validation(String initialUrl)
ログアウト後に遷移しようとするURLを検証します。

メソッドの詳細

validation

public String validation(String initialUrl)
ログアウト後に遷移しようとするURLを検証します。

検証後、遷移したいURLを返します。
nullまたは空文字列を返却した場合、ログアウトサーブレットは、レスポンスコード(204)を返却します。

パラメータ:
initialUrl - ログアウト後に遷移しようとするURL
戻り値:
検証後の遷移先のURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LogoutServlet (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.servlet
クラス LogoutServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.foundation.security.servlet.LogoutServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
public class LogoutServlet
extends HttpServlet

ログアウトサーブレット。

ログアウトの処理を行うサーブレット。

ログアウト処理を行った後、指定のURLに遷移します。
遷移先ページの決定順位は以下の通りです。

1．サーブレットの引数パラメータ(im_initial_url)に指定したURL
2．セッションに保管されている初期URL
3．クッキーに保管されている初期URL
この後、サーブレット初期化パラメータ(validator-class)に検証用実装クラスが
設定されている場合は、このクラスを用いて、URLの検証を行います。
なお、検証用実装クラスは、LogoutInitialUrlValidatorを実装している必要があります。

URLがnullの場合、および空文字列の場合は、レスポンスコード(204)を返却します。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
LogoutServlet()
メソッドの概要
void | destroy() サーブレットの放棄を行います。
protected void | doGet(HttpServletRequest request, HttpServletResponse response) GETメソッドに対するサービスを行います。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) POSTメソッドに対するサービスを行います。
void | init() サーブレットの初期化を行います。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LogoutServlet

public LogoutServlet()
メソッドの詳細

destroy

public void destroy()
サーブレットの放棄を行います。

関連項目:
Servlet.destroy()

init

public void init()
          throws ServletException
サーブレットの初期化を行います。

例外:
ServletException - サーブレットでエラーが発生した場合スローします。
関連項目:
GenericServlet.init()

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
GETメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doGet(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
POSTメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doPost(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuServlet (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.servlet
クラス MenuServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.foundation.security.servlet.MenuServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
public class MenuServlet
extends HttpServlet

メニュー連携サーブレットクラス。

メニューIDから画面に遷移を行うサーブレットです。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
MenuServlet()
コンストラクタ。
メソッドの概要
protected void | doGet(HttpServletRequest request, HttpServletResponse response) GETメソッドです。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) POSTメソッドです。
void | init() メニューサーブレットの初期化を行います。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
destroy, getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MenuServlet

public MenuServlet()
コンストラクタ。

メソッドの詳細

init

public void init()
          throws ServletException
メニューサーブレットの初期化を行います。

例外:
ServletException
関連項目:
Servlet.init(javax.servlet.ServletConfig)

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
POSTメソッドです。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
例外:
ServletException
IOException
関連項目:
HttpServlet.doPost(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
GETメソッドです。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
例外:
ServletException
IOException
関連項目:
HttpServlet.doPost(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.servlet (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.security.servlet
インタフェース
LogoutInitialUrlValidator
クラス
GroupSuperUserInitialServlet
LogoutServlet
MenuServlet
SuperUserInitialServlet
UserCertificationServlet
UserInitialServlet


jp.co.intra_mart.foundation.security.servlet (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.servlet

サーブレットに関連するクラスを提供します。

参照:
説明

インタフェースの概要
LogoutInitialUrlValidator ログアウト後に遷移するURL検証インタフェース ログアウト後に遷移するURLを検証するためのインタフェースです。

クラスの概要
GroupSuperUserInitialServlet | グループ管理者初期アクセスサーブレット。
LogoutServlet | ログアウトサーブレット。
MenuServlet | メニュー連携サーブレットクラス。
SuperUserInitialServlet | システム管理者初期アクセスサーブレット。
UserCertificationServlet | ユーザ認証サーブレット。
UserInitialServlet | ユーザ初期アクセスサーブレット。

パッケージ jp.co.intra_mart.foundation.security.servlet の説明

サーブレットに関連するクラスを提供します。


jp.co.intra_mart.foundation.security.servlet クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.servlet の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • class javax.servlet.http.HttpServlet (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet
        • class jp.co.intra_mart.foundation.security.servlet.LogoutServlet
        • class jp.co.intra_mart.foundation.security.servlet.MenuServlet
        • class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet
        • class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet
        • class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.servlet.LogoutInitialUrlValidator


パッケージ jp.co.intra_mart.foundation.security.servlet の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.servlet の使用

jp.co.intra_mart.foundation.security.servlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SuperUserInitialServlet (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.servlet
クラス SuperUserInitialServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
public class SuperUserInitialServlet
extends HttpServlet

システム管理者初期アクセスサーブレット。

システム管理者での初期アクセスを処理するサーブレット。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SuperUserInitialServlet()
メソッドの概要
void | destroy() サーブレットの放棄を行います。
protected void | doGet(HttpServletRequest request, HttpServletResponse response) GETメソッドに対するサービスを行います。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) POSTメソッドに対するサービスを行います。
void | init() サーブレットの初期化を行います。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SuperUserInitialServlet

public SuperUserInitialServlet()
メソッドの詳細

destroy

public void destroy()
サーブレットの放棄を行います。

導入されたバージョン:
5.0
関連項目:
Servlet.destroy()

init

public void init()
          throws ServletException
サーブレットの初期化を行います。

例外:
ServletException - サーブレットでエラーが発生した場合スローします。
導入されたバージョン:
5.0
関連項目:
GenericServlet.init()

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
GETメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doGet(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
POSTメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doPost(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserCertificationServlet (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.servlet
クラス UserCertificationServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
public class UserCertificationServlet
extends HttpServlet

ユーザ認証サーブレット。

ユーザでの認証アクセスを処理するサーブレット。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
UserCertificationServlet()
メソッドの概要
void | destroy() サーブレットの放棄を行います。
protected void | doGet(HttpServletRequest request, HttpServletResponse response) GETメソッドに対するサービスを行います。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) POSTメソッドに対するサービスを行います。
void | init() サーブレットの初期化を行います。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserCertificationServlet

public UserCertificationServlet()
メソッドの詳細

destroy

public void destroy()
サーブレットの放棄を行います。

導入されたバージョン:
5.0
関連項目:
Servlet.destroy()

init

public void init()
          throws ServletException
サーブレットの初期化を行います。

例外:
ServletException - サーブレットでエラーが発生した場合スローします。
導入されたバージョン:
5.0
関連項目:
GenericServlet.init()

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
GETメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doGet(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
POSTメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doPost(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserInitialServlet (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.servlet
クラス UserInitialServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.foundation.security.servlet.UserInitialServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
public class UserInitialServlet
extends HttpServlet

ユーザ初期アクセスサーブレット。

ユーザでの初期アクセスを処理するサーブレット。

利用するクライアントタイプ別にサーブレットおよびサーブレットマッピングを定義します。(web.xml)
サーブレットを定義する場合に必以下の初期化パラメータが必要です。

パラメータ名 | 説明
client-type | このサーブレットが処理するクライアントタイプです。
group-regexp | URLからログイングループIDを抜き出すための正規表現です。 正規表現の()内にマッチしたものをログイングループIDと見なします。 省略した場合のデフォルトは(.+)\.です。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
UserInitialServlet()
メソッドの概要
void | destroy() サーブレットの放棄を行います。
protected void | doGet(HttpServletRequest request, HttpServletResponse response) GETメソッドに対するサービスを行います。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) POSTメソッドに対するサービスを行います。
void | init() サーブレットの初期化を行います。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserInitialServlet

public UserInitialServlet()
メソッドの詳細

destroy

public void destroy()
サーブレットの放棄を行います。

導入されたバージョン:
5.0
関連項目:
Servlet.destroy()

init

public void init()
          throws ServletException
サーブレットの初期化を行います。

例外:
ServletException - サーブレットでエラーが発生した場合スローします。
導入されたバージョン:
5.0
関連項目:
GenericServlet.init()

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
GETメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doGet(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
POSTメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doPost(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor の使用

ShortCutAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.security.shortcut

jp.co.intra_mart.foundation.security.shortcut での ShortCutAccessor の使用

ShortCutAccessor を実装している jp.co.intra_mart.foundation.security.shortcut のクラス
 class StandardShortCutAccessor
ショートカットアクセッサクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo の使用

ShortCutInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security.shortcut

jp.co.intra_mart.foundation.security.shortcut での ShortCutInfo の使用

ShortCutInfo を返す jp.co.intra_mart.foundation.security.shortcut のメソッド
ShortCutInfo | ShortCutManager.getShortCutInfo(String shortCutId) ショートカット情報取得。
ShortCutInfo | ShortCutAccessor.getShortCutInfo(String groupId, String shortCutId) ショートカット情報を取得します。
ShortCutInfo | StandardShortCutAccessor.getShortCutInfo(String groupId, String shortCutId) ショートカット情報を取得します。

ShortCutInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.shortcut のメソッド
String | ShortCutManager.createShortCut(ShortCutInfo shortCutInfo) ショートカットＩＤ作成。
String | ShortCutAccessor.createShortCut(String groupId, ShortCutInfo shortCutInfo) ショートカットIDを作成します。
String | StandardShortCutAccessor.createShortCut(String groupId, ShortCutInfo shortCutInfo) ショートカットIDを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.shortcut.ShortCutManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.shortcut.ShortCutManager の使用

jp.co.intra_mart.foundation.security.shortcut.ShortCutManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor の使用

jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.security.shortcut (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.security.shortcut
インタフェース
ShortCutAccessor
クラス
ShortCutInfo
ShortCutManager
StandardShortCutAccessor


jp.co.intra_mart.foundation.security.shortcut (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.shortcut

インタフェースの概要
ShortCutAccessor ショートカットアクセッサインタフェース。

クラスの概要
ShortCutInfo | ショートカット情報クラス。
ShortCutManager | ショートカットマネージャクラス ServerManager/conf/short-cut-config.xmlからショートカット情報に関するパラメータを取得します。
StandardShortCutAccessor | ショートカットアクセッサクラス。


jp.co.intra_mart.foundation.security.shortcut クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.shortcut の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.shortcut.ShortCutManager
    • class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor (implements jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor


パッケージ jp.co.intra_mart.foundation.security.shortcut の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.shortcut の使用

jp.co.intra_mart.foundation.security.shortcut を使用しているパッケージ
jp.co.intra_mart.foundation.security.shortcut

jp.co.intra_mart.foundation.security.shortcut により使用される jp.co.intra_mart.foundation.security.shortcut のクラス
ShortCutAccessor
ショートカットアクセッサインタフェース。
ShortCutInfo
ショートカット情報クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ShortCutAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.shortcut
インタフェース ShortCutAccessor

既知の実装クラスの一覧:
StandardShortCutAccessor
public interface ShortCutAccessor

ショートカットアクセッサインタフェース。

ショートカット情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
Date | addValidEndDate(int countDays) SYSTEM日付に指定した日数を加えた日付を取得します。
String | createShortCut(String groupId, ShortCutInfo shortCutInfo) ショートカットIDを作成します。
void | deleteShortCut(String groupId, String shortCutId) ショートカットIDを削除します。
String | getErrorPage(String groupId) エラーページのパスを取得します。
String | getMainPage(String groupId) ショートカット表示用のパスを取得します。
ShortCutInfo | getShortCutInfo(String groupId, String shortCutId) ショートカット情報を取得します。
void | init(Node node) ショートカットアクセッサを初期化します。
int | verifyShortCut(String groupId, Date verifyDate) ショートカットIDを検証します。

メソッドの詳細

init

public void init(Node node)
ショートカットアクセッサを初期化します。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
node - 初期化パラメータのDOM

createShortCut

public String createShortCut(String groupId,
                             ShortCutInfo shortCutInfo)
                      throws AccessSecurityException
ショートカットIDを作成します。

パラメータ:
groupId - ログイングループID
shortCutInfo - ショートカット情報
戻り値:
ショートカットID
例外:
ショートカット情報の登録に失敗した場合、スローされます。
AccessSecurityException

deleteShortCut

public void deleteShortCut(String groupId,
                           String shortCutId)
                    throws AccessSecurityException
ショートカットIDを削除します。

パラメータ:
groupId - ログイングループID
shortCutId - ショートカットID
例外:
ショートカット情報の削除に失敗した場合、スローされます。
AccessSecurityException

verifyShortCut

public int verifyShortCut(String groupId,
                          Date verifyDate)
                   throws AccessSecurityException
ショートカットIDを検証します。

パラメータ:
groupId - ログイングループID
verifyDate - 検証日付
戻り値:
削除件数
例外:
過去のショートカット情報の削除に失敗した場合、スローされます。
AccessSecurityException

getShortCutInfo

public ShortCutInfo getShortCutInfo(String groupId,
                                    String shortCutId)
                             throws AccessSecurityException
ショートカット情報を取得します。

パラメータ:
groupId - ログイングループID
shortCutId - ショートカットID
戻り値:
ショートカット情報(取得できなかった場合、NULLを返却)
例外:
ショートカット情報の取得に失敗した場合、スローされます。
AccessSecurityException

getErrorPage

public String getErrorPage(String groupId)
エラーページのパスを取得します。

パラメータ:
groupId - ログイングループID
戻り値:
エラーページパス

getMainPage

public String getMainPage(String groupId)
ショートカット表示用のパスを取得します。

パラメータ:
groupId - ログイングループID
戻り値:
メインページパス

addValidEndDate

public Date addValidEndDate(int countDays)
                     throws AccessSecurityException
SYSTEM日付に指定した日数を加えた日付を取得します。

パラメータ:
countDays - 指定日数
戻り値:
SYSTEM日付に指定した日数を加えた日付
例外:
日付の取得に失敗した場合、スローされます。
AccessSecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ShortCutInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.shortcut
クラス ShortCutInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo
すべての実装インタフェース:
Serializable
public class ShortCutInfo
extends Object
implements Serializable

ショートカット情報クラス。

ショートカット情報を保管するクラスです。
ショートカット機能のユーザ判定、ログイン判定情報として利用します。

導入されたバージョン:
6.1
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ShortCutInfo()
メソッドの概要
String[] | getAllowsUsers() 許可ユーザを取得します。
String | getUrl() ＵＲＬを取得します。
String | getUrlParam(String key) ＵＲＬ引数(Map)の値を取得します。
String[] | getUrlParamKeys() ＵＲＬ引数(MAP)のキーの一覧を取得します。
Date | getValidEndDate() 有効終了日を取得します。
boolean | isAuth() 認証フラグを取得します。
void | removeUrlParam(String key) ＵＲＬ引数(Map)を削除します。
void | setAllowsUsers(String[] allowsUsers) 許可ユーザを設定します。
void | setIsAuth(boolean isAuth) 認証フラグを設定します。
void | setUrl(String url) ＵＲＬを設定します。
void | setUrlParam(String key, String value) ＵＲＬ引数(MAP)をセットする。
void | setValidEndDate(Date validEndDate) 有効終了日を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ShortCutInfo

public ShortCutInfo()
メソッドの詳細

getUrl

public String getUrl()
ＵＲＬを取得します。

戻り値:
url ＵＲＬ

getUrlParamKeys

public String[] getUrlParamKeys()
ＵＲＬ引数(MAP)のキーの一覧を取得します。

戻り値:
urlParams Mapのキーの一覧

setUrlParam

public void setUrlParam(String key,
                        String value)
ＵＲＬ引数(MAP)をセットする。

パラメータ:
key - Mapのキー
value - Mapの値

getUrlParam

public String getUrlParam(String key)
ＵＲＬ引数(Map)の値を取得します。

パラメータ:
key - Mapのキー
戻り値:
this.urlParams.get(key) Mapの値

removeUrlParam

public void removeUrlParam(String key)
ＵＲＬ引数(Map)を削除します。

パラメータ:
key - Mapのキー

getAllowsUsers

public String[] getAllowsUsers()
許可ユーザを取得します。

戻り値:
allowsUsers 許可ユーザ

isAuth

public boolean isAuth()
認証フラグを取得します。

戻り値:
isAuth 認証フラグ

getValidEndDate

public Date getValidEndDate()
有効終了日を取得します。

戻り値:
validEndDate 有効終了日

setUrl

public void setUrl(String url)
ＵＲＬを設定します。

パラメータ:
url - ＵＲＬ

setAllowsUsers

public void setAllowsUsers(String[] allowsUsers)
許可ユーザを設定します。

パラメータ:
allowsUsers - 許可ユーザ

setIsAuth

public void setIsAuth(boolean isAuth)
認証フラグを設定します。

パラメータ:
isAuth - 認証フラグ

setValidEndDate

public void setValidEndDate(Date validEndDate)
有効終了日を設定します。

設定できる最大日付は9999/12/31です。
nullを指定した場合は、SYSTEM日付が設定されます。

パラメータ:
validEndDate - 有効終了日
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ShortCutManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.shortcut
クラス ShortCutManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.shortcut.ShortCutManager
public class ShortCutManager
extends Object

ショートカットマネージャクラス

ServerManager/conf/short-cut-config.xmlからショートカット情報に関するパラメータを取得します。

以下はshort-cut-config.xmlのタグの説明です。

<short-cut-config>
  <short-cut-accessor>
     <short-cut-accessor-class>ShortCutAccessor</short-cut-accessor-class>
     <error-page>error.jssp</error-page>
     <main-page>main.jssp</main-page>
  <short-cut-accessor>
<short-cut-config>

その他のタグに関してはこちらを参照してください。StandardShortCutAccessor

タグ名 | 説明 | デフォルト値
accessor-class | ショートカットのデフォルトパラメータ | jp.co.intra_mart.foundation. security.shortcut. StandardShortCutAccessor

コンストラクタの概要
ShortCutManager(String groupId)
メソッドの概要
Date | addValidEndDate(int countDays) SYSTEM日付に指定した日数を加えた日付を取得します。
static void | clearInstance()
String | createShortCut(ShortCutInfo shortCutInfo) ショートカットＩＤ作成。
void | deleteShortCut(String shortCutId) ショートカットＩＤ削除。
String | getErrorPage() ショートカットエラーページ取得。
String | getMainPage() ショートカットメインページ取得。
ShortCutInfo | getShortCutInfo(String shortCutId) ショートカット情報取得。
int | verifyShortCut(Date verifyDate) ショートカット検証。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ShortCutManager

public ShortCutManager(String groupId)
メソッドの詳細

clearInstance

public static void clearInstance()

createShortCut

public String createShortCut(ShortCutInfo shortCutInfo)
                      throws AccessSecurityException
ショートカットＩＤ作成。

ショートカット情報を元に固有のＩＤをキーとしてショートカット情報を登録し、そのＩＤを返却します。

パラメータ:
shortCutInfo - ショートカット情報
戻り値:
shortCutId ショートカットＩＤ
例外:
AccessSecurityException - ショートカット情報の登録に失敗した場合にスローされます。

deleteShortCut

public void deleteShortCut(String shortCutId)
                    throws AccessSecurityException
ショートカットＩＤ削除。

ショートカットＩＤを削除します。

パラメータ:
shortCutId - ショートカットＩＤ
例外:
AccessSecurityException - ショートカット情報の削除に失敗した場合にスローされます。

verifyShortCut

public int verifyShortCut(Date verifyDate)
                   throws AccessSecurityException
ショートカット検証。

指定された日付において無効なショートカットＩＤを削除します。

パラメータ:
verifyDate - 検証日付
戻り値:
削除件数
例外:
AccessSecurityException - ショートカット情報の削除に失敗した場合にスローされます。

getShortCutInfo

public ShortCutInfo getShortCutInfo(String shortCutId)
                             throws AccessSecurityException
ショートカット情報取得。

指定されたショートカットＩＤからショートカット情報を取得します。

パラメータ:
shortCutId - ショートカットＩＤ
戻り値:
ショートカット情報
例外:
AccessSecurityException - ショートカット検証、またはショートカット情報の取得に失敗した場合にスローされます。

getErrorPage

public String getErrorPage()
                    throws AccessSecurityException
ショートカットエラーページ取得。

ショートカットが表示できない場合のエラーページパス

戻り値:
エラーページパス
例外:
AccessSecurityException - ショートカットエラーページ取得に失敗した場合にスローされます。

getMainPage

public String getMainPage()
                   throws AccessSecurityException
ショートカットメインページ取得。

ショートカット表示用のメインページパス

戻り値:
メインページパス
例外:
AccessSecurityException - ショートカットメインページ取得に失敗した場合にスローされます。

addValidEndDate

public Date addValidEndDate(int countDays)
                     throws AccessSecurityException
SYSTEM日付に指定した日数を加えた日付を取得します。

指定日数を加算した日付

パラメータ:
countDays - 指定日数
戻り値:
SYSTEM日付に指定した日数を加えた日付
例外:
日付の取得に失敗した場合、スローされます。
AccessSecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardShortCutAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.shortcut
クラス StandardShortCutAccessor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor
すべての実装インタフェース:
ShortCutAccessor
public class StandardShortCutAccessor
extends Object
implements ShortCutAccessor

ショートカットアクセッサクラス。

ショートカット情報の読み込みおよび書き込みのクラスです。

タグ名 | 説明
error-page | ショートカット情報が存在しない場合に表示するページパスを指定します。
main-page | ショートカットページを表示するためのメインページパスを設定します。

フィールドの概要
String | errorPagePath クラス変数
String | mainPagePath
コンストラクタの概要
StandardShortCutAccessor()
メソッドの概要
Date | addValidEndDate(int countDays) SYSTEM日付に指定した日数を加えた日付を取得します。
String | createShortCut(String groupId, ShortCutInfo shortCutInfo) ショートカットIDを作成します。
void | deleteShortCut(String groupId, String shortCutId) ショートカットIDを削除します。
String | getErrorPage(String groupId) エラーページのパスを取得します。
String | getMainPage(String groupId) ショートカット表示用のパスを取得します。
ShortCutInfo | getShortCutInfo(String groupId, String shortCutId) ショートカット情報を取得します。
void | init(Node node) ショートカットアクセッサを初期化します。
int | verifyShortCut(String groupId, Date verifyDate) ショートカットIDを検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

errorPagePath

public String errorPagePath
クラス変数

mainPagePath

public String mainPagePath
コンストラクタの詳細

StandardShortCutAccessor

public StandardShortCutAccessor()
メソッドの詳細

init

public void init(Node node)
ショートカットアクセッサを初期化します。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース ShortCutAccessor 内の init
パラメータ:
node - 初期化パラメータのDOM

createShortCut

public String createShortCut(String groupId,
                             ShortCutInfo shortCutInfo)
                      throws AccessSecurityException
ショートカットIDを作成します。
ショートカット情報の許可ユーザを複数指定した場合、認証フラグは必ずONになります。

定義:
インタフェース ShortCutAccessor 内の createShortCut
パラメータ:
groupId - ログイングループID
shortCutInfo - ショートカット情報
戻り値:
ショートカットID
例外:
ショートカット情報の登録に失敗した場合、スローされます。
AccessSecurityException

deleteShortCut

public void deleteShortCut(String groupId,
                           String shortCutId)
                    throws AccessSecurityException
ショートカットIDを削除します。

定義:
インタフェース ShortCutAccessor 内の deleteShortCut
パラメータ:
groupId - ログイングループID
shortCutId - ショートカットID
例外:
ショートカット情報の削除に失敗した場合、スローされます。
AccessSecurityException

verifyShortCut

public int verifyShortCut(String groupId,
                          Date verifyDate)
                   throws AccessSecurityException
ショートカットIDを検証します。

定義:
インタフェース ShortCutAccessor 内の verifyShortCut
パラメータ:
groupId - ログイングループID
verifyDate - 検証日付
戻り値:
削除件数
例外:
過去のショートカット情報の削除に失敗した場合、スローされます。
AccessSecurityException

getShortCutInfo

public ShortCutInfo getShortCutInfo(String groupId,
                                    String shortCutId)
                             throws AccessSecurityException
ショートカット情報を取得します。

定義:
インタフェース ShortCutAccessor 内の getShortCutInfo
パラメータ:
groupId - ログイングループID
shortCutId - ショートカットID
戻り値:
ショートカット情報(取得できなかった場合、NULLを返却)
例外:
ショートカット情報の取得に失敗した場合、スローされます。
AccessSecurityException

getErrorPage

public String getErrorPage(String groupId)
エラーページのパスを取得します。

定義:
インタフェース ShortCutAccessor 内の getErrorPage
パラメータ:
groupId - ログイングループID
戻り値:
エラーページパス

getMainPage

public String getMainPage(String groupId)
ショートカット表示用のパスを取得します。

定義:
インタフェース ShortCutAccessor 内の getMainPage
パラメータ:
groupId - ログイングループID
戻り値:
メインページパス

addValidEndDate

public Date addValidEndDate(int countDays)
                     throws AccessSecurityException
SYSTEM日付に指定した日数を加えた日付を取得します。

SYSTEM日付に指定した日数を加えた日付が9999/12/31を超えた場合は9999/12/31を返却します。
日数に負の数を与えた場合はSYSTEM日付を返却します。

定義:
インタフェース ShortCutAccessor 内の addValidEndDate
パラメータ:
countDays - 指定日数
戻り値:
SYSTEM日付に指定した日数を加えた日付
例外:
AccessSecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス AccessSecurityManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.AccessSecurityManager
public class AccessSecurityManager
extends Object

アクセスセキュリティマネージャクラス。

アクセスセキュリティの認証処理をするためのクラスです。
アクセスセキュリティの認証処理を行う場合は、必ずこのクラスを利用します。
また、システムセッション情報を取得する場合は、このクラスを利用して取得します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
static void | clearInstance() アクセスセキュリティマネージャのインスタンスを初期化します。
LoginRequestInfo | createLoginRequestInfo(String loginType) ログイン情報を作成します。
String | createUrlSignature(String url, String groupId, String userId) ダイレクトＵＲＬ署名を作成します。
String | decrypt(String secret) デフォルトの暗号化アルゴリズムカテゴリを利用して暗号化された文字列を復号します。
String | decrypt(String category, String secret) 指定された暗号化アルゴリズムカテゴリを利用して暗号化された文字列を復号します。
String | encrypt(String plane) デフォルトの暗号化アルゴリズムカテゴリを利用して文字列を暗号化します。
String | encrypt(String category, String plane) 指定された暗号化アルゴリズムカテゴリを利用して文字列を暗号化します。
int | forceLogin(LoginRequestInfo loginRequestInfo) 強制ログイン処理を行います。
int | forceLogin(LoginRequestInfo loginRequestInfo, HttpServletRequest request, HttpServletResponse response) 強制ログイン処理を行います。
void | forward(HttpServletRequest request, HttpServletResponse response, String url) 指定したURLにフォワードします。
void | forward(String url) 指定したURLにフォワードします。
SessionInfo | getCookieSessionInfo() カレントスレッド情報のクッキーからintra-martセッション情報を取得します。
SessionInfo | getCookieSessionInfo(HttpServletRequest request) クッキーからintra-martセッション情報を取得します。
String | getErrorPage(int errorCode) カレントスレッド情報からエラーページＵＲＬを取得します。
String | getErrorPage(int errorCode, HttpServletRequest request, HttpServletResponse response) エラーページＵＲＬを取得します。
int | getInitialCertification(LoginRequestInfo loginInfo) カレントスレッドの情報から初期アクセス処理を行います。
int | getInitialCertification(LoginRequestInfo loginInfo, HttpServletRequest request, HttpServletResponse response) 初期アクセス処理を行います。
String | getInitialPage() カレントスレッド情報から初期アクセスページURLを取得します。
String | getInitialPage(SessionInfo sessionInfo) カレントスレッド情報から初期アクセスページURLを取得します。
String | getInitialPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期アクセスページURLを取得します。
static AccessSecurityManager | getInstance() セキュリティマネージャのインスタンスを取得します。
int | getLicense(LoginInfo loginInfo) アカウントライセンスチェックを行います。
int | getLoginCertification() カレントスレッド情報からログイン処理を行います。
int | getLoginCertification(HttpServletRequest request, HttpServletResponse response) ログイン処理を行います。
String | getMainPage() カレントスレッド情報からメインページURLを取得します。
String | getMainPage(SessionInfo sessionInfo) カレントスレッド情報からメインページURLを取得します。
String | getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得します。
String | getMobileUserAgent() モバイル端末の固体識別番号を取得します。
String | getMobileUserAgent(HttpServletRequest request, HttpServletResponse response) モバイル端末の固体識別番号を取得します。
SessionConfig | getSessionConfig() セッション情報保管パラメータを取得します。
SessionInfo | getSessionInfo() カレントスレッド情報からintra-martセッション情報を取得します。
SessionInfo | getSessionInfo(HttpServletRequest request, HttpServletResponse response) intra-martセッション情報を取得します。
int | getSessionMode() intra-martセッションの状態を取得します。
int | getSessionMode(SessionInfo sessionInfo) intra-martセッションの状態を取得します。
int | login(LoginRequestInfo loginRequestInfo) ログイン処理を行います。
int | login(LoginRequestInfo loginRequestInfo, HttpServletRequest request, HttpServletResponse response) ログイン処理を行います。
void | logout() ログアウト処理を行います。
void | logout(HttpServletRequest request, HttpServletResponse response) ログアウト処理を行います。
void | secureRedirect(HttpServletRequest request, HttpServletResponse response, String url, Map args) 呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。
void | secureRedirect(String url, Map args) 呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

clearInstance

public static void clearInstance()
アクセスセキュリティマネージャのインスタンスを初期化します。

アクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。
通常、このメソッドを使用する必要はありません。

getInstance

public static AccessSecurityManager getInstance()
                                         throws AccessSecurityException
セキュリティマネージャのインスタンスを取得します。

戻り値:
セキュリティマネージャインスタンス
例外:
AccessSecurityException - アクセスセキュリティ設定またはシステム設定に誤りがあった場合にスローします。

createLoginRequestInfo

public LoginRequestInfo createLoginRequestInfo(String loginType)
ログイン情報を作成します。

パラメータ:
loginType - ログインタイプ
システム管理者 | SecurityConstraint.LT_SUPER
グループ管理者 | SecurityConstraint.LT_GROUP
ユーザ | SecurityConstraint.LT_USER
戻り値:
ログイン情報

createUrlSignature

public String createUrlSignature(String url,
                                 String groupId,
                                 String userId)
                          throws AccessSecurityException
ダイレクトＵＲＬ署名を作成します。

パラメータ:
url - ダイレクトＵＲＬ
groupId - ログイングループＩＤ
userId - ユーザＩＤ
戻り値:
ダイレクトURL署名
例外:
AccessSecurityException - 引数が不正だった場合に例外がスローされます。

forceLogin

public int forceLogin(LoginRequestInfo loginRequestInfo)
               throws NoFilterException,
                      AccessSecurityException
強制ログイン処理を行います。

パスワード認証を行わずに強制的にログインします。
ただし、引数のログイン情報に存在しないログイングループを設定した場合は、ログインできません。

パラメータ:
loginRequestInfo - ログイン情報
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

forceLogin

public int forceLogin(LoginRequestInfo loginRequestInfo,
                      HttpServletRequest request,
                      HttpServletResponse response)
               throws AccessSecurityException
強制ログイン処理を行います。

パスワード認証を行わずに強制的にログインします。
ただし、引数のログイン情報に存在しないログイングループを設定した場合は、ログインできません。

パラメータ:
loginRequestInfo - ログイン情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

forward

public void forward(HttpServletRequest request,
                    HttpServletResponse response,
                    String url)
             throws ServletException,
                    IOException,
                    AccessSecurityException
指定したURLにフォワードします。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
url - ＵＲＬ
例外:
IOException - 最終的なフォワード先となるリソースがこの例外をスローした場合にスローします。
ServletException - 最終的なフォワード先となるリソースがこの例外をスローした場合にスローします。
AccessSecurityException - 引数が不正だった場合にスローされます。

forward

public void forward(String url)
             throws NoFilterException,
                    ServletException,
                    IOException,
                    AccessSecurityException
指定したURLにフォワードします。

パラメータ:
url - ＵＲＬ
例外:
IOException - 最終的なフォワード先となるリソースがこの例外をスローした場合にスローします。
ServletException - 最終的なフォワード先となるリソースがこの例外をスローした場合にスローします。
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 引数が不正だった場合にスローされます。

getCookieSessionInfo

public SessionInfo getCookieSessionInfo()
                                 throws NoFilterException
カレントスレッド情報のクッキーからintra-martセッション情報を取得します。

このメソッドを利用するためには、jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestManagementFilterを
web.xmlにフィルタとして設定する必要があります。

戻り値:
クッキーに保管されているintra-martセッション情報
セッション情報保管用のクッキーが存在しない場合はnullを返します。
例外:
NoFilterException - カレントスレッドからサーブレットリクエストが取得できなかった場合にスローします。

getCookieSessionInfo

public SessionInfo getCookieSessionInfo(HttpServletRequest request)
クッキーからintra-martセッション情報を取得します。

パラメータ:
request - サーブレットリクエスト
戻り値:
クッキーに保管されているintra-martセッション情報
セッション情報保管用のクッキーが存在しない場合はnullを返します。

getErrorPage

public String getErrorPage(int errorCode)
                    throws NoFilterException,
                           AccessSecurityException
カレントスレッド情報からエラーページＵＲＬを取得します。

引数で指定したエラーページＵＲＬを返却します。

パラメータ:
errorCode - ログインエラーコード (SecurityConstraint.CR_* を参照)
戻り値:
エラーページのＵＲＬ
ページが存在しなかった場合はnullを返します。
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - アクセスセキュリティ設定またはシステム設定に誤りがあった場合にスローします。

getErrorPage

public String getErrorPage(int errorCode,
                           HttpServletRequest request,
                           HttpServletResponse response)
                    throws AccessSecurityException
エラーページＵＲＬを取得します。

引数で指定したエラーページＵＲＬを返却します。

パラメータ:
errorCode - ログインエラーコード (SecurityConstraint.CR_* を参照)
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
エラーページのURL
ページが存在しなかった場合はnullを返します。
例外:
AccessSecurityException - アクセスセキュリティ設定またはシステム設定に誤りがあった場合にスローします。

getInitialCertification

public int getInitialCertification(LoginRequestInfo loginInfo)
                            throws NoFilterException,
                                   AccessSecurityException
カレントスレッドの情報から初期アクセス処理を行います。

パラメータ:
loginInfo - ログインリクエスト情報
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getInitialCertification

public int getInitialCertification(LoginRequestInfo loginInfo,
                                   HttpServletRequest request,
                                   HttpServletResponse response)
                            throws AccessSecurityException
初期アクセス処理を行います。

パラメータ:
loginInfo - ログインリクエスト情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getInitialPage

public String getInitialPage()
                      throws NoFilterException,
                             AccessSecurityException
カレントスレッド情報から初期アクセスページURLを取得します。

現在のセッション情報から初期アクセスページURLを取得します。

戻り値:
初期アクセスページURL
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getInitialPage

public String getInitialPage(SessionInfo sessionInfo)
                      throws NoFilterException,
                             AccessSecurityException
カレントスレッド情報から初期アクセスページURLを取得します。

パラメータ:
sessionInfo - intra-martセッション情報
戻り値:
初期アクセスページURL
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getInitialPage

public String getInitialPage(SessionInfo sessionInfo,
                             HttpServletRequest request,
                             HttpServletResponse response)
                      throws AccessSecurityException
初期アクセスページURLを取得します。

パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getLicense

public int getLicense(LoginInfo loginInfo)
               throws AccessSecurityException
アカウントライセンスチェックを行います。

パラメータ:
loginInfo - ログインリクエスト情報
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getLoginCertification

public int getLoginCertification()
                          throws NoFilterException,
                                 AccessSecurityException
カレントスレッド情報からログイン処理を行います。

ログイン処理後のページを取得します。

戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getLoginCertification

public int getLoginCertification(HttpServletRequest request,
                                 HttpServletResponse response)
                          throws AccessSecurityException
ログイン処理を行います。

ログイン処理後のページを取得します。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getMainPage

public String getMainPage()
                   throws NoFilterException,
                          AccessSecurityException
カレントスレッド情報からメインページURLを取得します。

現在のセッション情報からログイン後のメインページを取得します。

戻り値:
メインページURL
ページが存在しなかった場合は、nullを返却します。
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getMainPage

public String getMainPage(SessionInfo sessionInfo)
                   throws NoFilterException,
                          AccessSecurityException
カレントスレッド情報からメインページURLを取得します。

ログイン後のメインページを取得します。

パラメータ:
sessionInfo - intra-martセッション情報
戻り値:
メインページURL
ページが存在しなかった場合はnullを返します。
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getMainPage

public String getMainPage(SessionInfo sessionInfo,
                          HttpServletRequest request,
                          HttpServletResponse response)
                   throws AccessSecurityException
メインページURLを取得します。

ログイン後のメインページを取得します。

パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
メインページURL
ページが存在しなかった場合は、nullを返します。
例外:
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getSessionConfig

public SessionConfig getSessionConfig()
                               throws AccessSecurityException
セッション情報保管パラメータを取得します。

戻り値:
セッション情報保管パラメータ情報
例外:
AccessSecurityException - アクセスセキュリティ設定またはシステム設定に誤りがあった場合にスローします。

getSessionInfo

public SessionInfo getSessionInfo()
                           throws NoFilterException,
                                  AccessSecurityException
カレントスレッド情報からintra-martセッション情報を取得します。

このメソッドを利用するためには、jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilterを
web.xmlにフィルタとして設定する必要があります。

戻り値:
intra-martセッション情報
セッションが存在しない場合はnullを返します。
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 引数が不正だった場合にスローされます。

getSessionInfo

public SessionInfo getSessionInfo(HttpServletRequest request,
                                  HttpServletResponse response)
                           throws AccessSecurityException
intra-martセッション情報を取得します。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
intra-martセッション情報
セッションが存在しない場合はnullを返します。
例外:
AccessSecurityException - 引数が不正だった場合にスローされます。

getSessionMode

public int getSessionMode()
                   throws AccessSecurityException,
                          NoFilterException
intra-martセッションの状態を取得します。

戻り値:
セッション状態
初期状態 | SecurityConstraint.CR_SESSION_INITIAL
ログオン状態 | SecurityConstraint.CR_SESSION_LOGON
セッション不整合状態 | SecurityConstraint.CR_SESSION_UNMATCH
セッションタイムアウト状態 | SecurityConstraint.CR_SESSION_TIMEOUT
例外:
AccessSecurityException - アクセスセキュリティ設定またはシステム設定に誤りがあった場合にスローします。
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。

getSessionMode

public int getSessionMode(SessionInfo sessionInfo)
                   throws AccessSecurityException
intra-martセッションの状態を取得します。

パラメータ:
sessionInfo - intra-martセッション情報
戻り値:
セッション状態
初期状態 | SecurityConstraint.CR_SESSION_INITIAL
ログオン状態 | SecurityConstraint.CR_SESSION_LOGON
セッション不整合状態 | SecurityConstraint.CR_SESSION_UNMATCH
セッションタイムアウト状態 | SecurityConstraint.CR_SESSION_TIMEOUT
例外:
AccessSecurityException - アクセスセキュリティ設定またはシステム設定に誤りがあった場合にスローします。

login

public int login(LoginRequestInfo loginRequestInfo)
          throws NoFilterException,
                 AccessSecurityException
ログイン処理を行います。

引数のログイン情報を使用して通常のログイン処理を行います。

パラメータ:
loginRequestInfo - ログイン情報
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

login

public int login(LoginRequestInfo loginRequestInfo,
                 HttpServletRequest request,
                 HttpServletResponse response)
          throws AccessSecurityException
ログイン処理を行います。

引数のログイン情報を使用して通常のログイン処理を行います。

パラメータ:
loginRequestInfo - ログイン情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

logout

public void logout()
            throws NoFilterException,
                   AccessSecurityException
ログアウト処理を行います。

セッション情報を初期化します。

例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

logout

public void logout(HttpServletRequest request,
                   HttpServletResponse response)
            throws AccessSecurityException
ログアウト処理を行います。

セッション情報を初期化します。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ログインエラーコード
例外:
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

secureRedirect

public void secureRedirect(HttpServletRequest request,
                           HttpServletResponse response,
                           String url,
                           Map args)
                    throws ServletException,
                           IOException
呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。

外部のURLの場合は、プロトコルから指定します。

内部のURLの場合は以下の通りです。
スクリプト開発モデルプログラムのパスにリダイレクトする場合は、最後に拡張子".jssp"が必要です。
その他のパスにダイレクトする場合は、コンテキストパスからの相対URLとなります。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
url - リダイレクトURL
args - リダイレクトURLの引数(マップ形式)
例外:
IOException
ServletException

secureRedirect

public void secureRedirect(String url,
                           Map args)
                    throws NoFilterException,
                           ServletException,
                           IOException
呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。

外部のURLの場合は、プロトコルから指定します。

内部のURLの場合は以下の通りです。
スクリプト開発モデルプログラムのパスにリダイレクトする場合は、最後に拡張子".jssp"が必要です。
その他のパスにダイレクトする場合は、コンテキストパスからの相対URLとなります。

パラメータ:
url - リダイレクトURL（コンテキストパスからの相対URL）
args - リダイレクトURLの引数(マップ形式)
例外:
ServletException
IOException
NoFilterException

getMobileUserAgent

public String getMobileUserAgent(HttpServletRequest request,
                                 HttpServletResponse response)
モバイル端末の固体識別番号を取得します。

モバイル端末の固体識別番号が取得できなかった場合はnullを返却します。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
モバイル端末固体識別番号

getMobileUserAgent

public String getMobileUserAgent()
                          throws NoFilterException
モバイル端末の固体識別番号を取得します。

モバイル端末の固体識別番号が取得できなかった場合はnullを返却します。

戻り値:
モバイル端末固体識別番号
例外:
NoFilterException

decrypt

public String decrypt(String secret)
デフォルトの暗号化アルゴリズムカテゴリを利用して暗号化された文字列を復号します。

暗号化アルゴリズムカテゴリを「default」として処理を行います。

cryption-config.xmlに「default」カテゴリの設定が存在しない場合は、
「default」カテゴリを自動的に作成します。
自動的に作成される「default」カテゴリの暗号化アルゴリズムはStandardCryptionが設定されます。

パラメータ:
secret - 暗号化された文字列
戻り値:
復号化された文字列

encrypt

public String encrypt(String plane)
デフォルトの暗号化アルゴリズムカテゴリを利用して文字列を暗号化します。

暗号化アルゴリズムカテゴリを「default」として処理を行います。

cryption-config.xmlに「default」カテゴリの設定が存在しない場合は、
「default」カテゴリを自動的に作成します。
自動的に作成される「default」カテゴリの暗号化アルゴリズムはStandardCryptionが設定されます。

パラメータ:
plane - 暗号化する文字列
戻り値:
暗号化された文字列

decrypt

public String decrypt(String category,
                      String secret)
指定された暗号化アルゴリズムカテゴリを利用して暗号化された文字列を復号します。

暗号化アルゴリズムカテゴリは,サーバマネージャ/conf/cryption-config.xmlの
cryptionタグのcategory属性に指定した名称を指定します。

暗号化アルゴリズムカテゴリが存在しない場合は、
暗号化アルゴリズムカテゴリに「default」を指定して再度試みます。

cryption-config.xmlに「default」カテゴリの設定が存在しない場合は、
「default」カテゴリを自動的に作成します。
自動的に作成される「default」カテゴリの暗号化アルゴリズムはStandardCryptionが設定されます。

パラメータ:
category - 暗号化アルゴリズムカテゴリ
secret - 暗号化された文字列
戻り値:
復号化された文字列

encrypt

public String encrypt(String category,
                      String plane)
指定された暗号化アルゴリズムカテゴリを利用して文字列を暗号化します。

暗号化アルゴリズムカテゴリは,サーバマネージャ/conf/cryption-config.xmlの
cryptionタグのcategory属性に指定した名称を指定します。

暗号化アルゴリズムカテゴリが存在しない場合は、
暗号化アルゴリズムカテゴリに「default」を指定して再度試みます。

cryption-config.xmlに「default」カテゴリの設定が存在しない場合は、
「default」カテゴリを自動的に作成します。
自動的に作成される「default」カテゴリの暗号化ロジックはStandardCryptionが設定されます。

パラメータ:
category - 暗号化アルゴリズムカテゴリ
plane - 暗号化する文字列
戻り値:
暗号化された文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ClientTypeInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース ClientTypeInfo

public interface ClientTypeInfo

クライアントタイプ情報インタフェース。

クライアントタイプの情報を参照するインタフェース。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getClientType() クライアントタイプを取得する。
String | getDisplayName() クライアントタイプ表示名を取得する。

メソッドの詳細

getClientType

public String getClientType()
クライアントタイプを取得する。

戻り値:
クライアントタイプ

getDisplayName

public String getDisplayName()
クライアントタイプ表示名を取得する。

戻り値:
クライアントタイプの表示名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ColorPatternInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース ColorPatternInfo

public interface ColorPatternInfo

カラーパターン情報を取得するインタフェース。

カラーパターン情報を参照する場合はこのインタフェースを利用して取得する。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getColorCode() カラーパターンコードを取得します。
String | getColorPatternId() カラーパターンIDを取得します。
String | getCssFile() カラーパターンのCSSファイルパスを取得します。
String[] | getCssFiles() カラーパターンのCSSファイルパスの一覧を取得します。
String | getDisplayName() カラーパターン表示名を取得します。
String | getImageFolder() カラーパターンのイメージファイルのフォルダを取得します。
String | getProperty(String key) カラーパターンのプロパティ情報を取得します。
String[] | getPropertyKeys() カラーパターンのプロパティ情報のキー一覧を取得します。

メソッドの詳細

getColorCode

public String getColorCode()
カラーパターンコードを取得します。

カラーパターンをイメージするカラーコード
#rrggbb形式で返却する。

戻り値:
カラーパターンコード

getColorPatternId

public String getColorPatternId()
カラーパターンIDを取得します。

戻り値:
カラーパターンID

getCssFile

public String getCssFile()
カラーパターンのCSSファイルパスを取得します。

先頭の１つを返却します。 コンテキストパスからの相対パス。（'/'から始まります。）

戻り値:
cssPath CSSファイルパス

getCssFiles

public String[] getCssFiles()
カラーパターンのCSSファイルパスの一覧を取得します。

コンテキストパスからの相対パス。（'/'から始まります。）

戻り値:
cssPath CSSファイルパスの一覧

getDisplayName

public String getDisplayName()
カラーパターン表示名を取得します。

戻り値:
カラーパターンの表示名

getImageFolder

public String getImageFolder()
カラーパターンのイメージファイルのフォルダを取得します。

コンテキストパスからの相対パス。（'/'から始まります。）

戻り値:
imagePath イメージファイルのフォルダ

getProperty

public String getProperty(String key)
カラーパターンのプロパティ情報を取得します。

パラメータ:
key - プロパティキー
戻り値:
プロパティ情報

getPropertyKeys

public String[] getPropertyKeys()
カラーパターンのプロパティ情報のキー一覧を取得します。

戻り値:
カラーパターンのプロパティ情報のキー一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DepartmentInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス DepartmentInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.DepartmentInfo
すべての実装インタフェース:
Serializable
public class DepartmentInfo
extends Object
implements Serializable

組織情報クラス。

組織情報を保管するクラスです。
メニュー、アクセスコントロールの組織設定情報として利用します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DepartmentInfo(String companyCode, String departmentCode)
コンストラクタ。
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
String | getKeyString() 組織情報の識別子を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DepartmentInfo

public DepartmentInfo(String companyCode,
                      String departmentCode)
コンストラクタ。

メソッドの詳細

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
companyCode 会社コード

getDepartmentCode

public String getDepartmentCode()
組織コードを取得します。

戻り値:
departmentCode 組織コード

getKeyString

public String getKeyString()
組織情報の識別子を取得します。

戻り値:
組織情報の識別子
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendsImport (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース ExtendsImport

public interface ExtendsImport

拡張インポート処理インターフェース。

拡張インポート処理を行うためのインターフェース。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
 void doImport(String groupId)
拡張インポート処理を行います。

メソッドの詳細

doImport

public void doImport(String groupId)
拡張インポート処理を行います。

トランザクションが必要な場合は、内部でトランザクション処理を行ってください。

パラメータ:
groupId - 対象のログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendsImportManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス ExtendsImportManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.ExtendsImportManager
public class ExtendsImportManager
extends Object

拡張インポートマネージャクラス。

拡張インポート処理を実行するマネージャクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | doImport(String groupId, String module) 拡張インポート処理を実行します。
static ExtendsImportManager | getInstance()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getInstance

public static ExtendsImportManager getInstance()

doImport

public void doImport(String groupId,
                     String module)
              throws AccessSecurityException
拡張インポート処理を実行します。

引数moduleには、クラスまたはJSのパスを指定できます。
クラスを指定する場合は、ExtendsImportを継承したクラスのフルパッケージ名を指定してください。

JSのパスを指定する場合は、指定するJSファイルに記述されている"doImport""関数をコールします。
"doImport""関数の第一引数にログイングループIDを引き渡します。
パスの指定は、pagesからの相対パスで、最後に".js"を含んだものである必要があります。
例：
function doImport(group){
......

}

パラメータ:
groupId - ログイングループID
module - 拡張インポート処理を行うクラス名またはJSのパス
例外:
AccessSecurityException - クラス名のインスタンスの生成に失敗した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


INonTransaction (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース INonTransaction

public interface INonTransaction

分散トランザクション未対応のアクセッサに実装するインターフェース。

分散トランザクション未対応のアクセッサに実装する。

導入されたバージョン:
5.0
バージョン:
1.0

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LocaleInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース LocaleInfo

すべてのスーパーインタフェース:
LocaleProvider
public interface LocaleInfo
extends LocaleProvider

ロケｰル情報・モデルインタフェース。

ロケールのデータモデルのインタフェースを定義

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getDisplayName() ロケ－ル表示名取得。
String | getEncoding() デフォルトエンコーディングの取得。
String[] | getEncodings() ロケ－ルに対応しているエンコーディングの一覧の取得。
Locale | getLocale() ロケ－ル取得。

メソッドの詳細

getDisplayName

public String getDisplayName()
ロケ－ル表示名取得。

ロケ－ル表示名を取得する

戻り値:
ロケｰル表示名

getEncoding

public String getEncoding()
デフォルトエンコーディングの取得。

定義:
インタフェース LocaleProvider 内の getEncoding
戻り値:
デフォルトエンコーディング

getEncodings

public String[] getEncodings()
ロケ－ルに対応しているエンコーディングの一覧の取得。

ロケ－ルに対応しているエンコーディングの一覧の取得

戻り値:
対応しているエンコーディングの一覧

getLocale

public Locale getLocale()
ロケ－ル取得。

ロケ－ルを取得する

定義:
インタフェース LocaleProvider 内の getLocale
戻り値:
ロケｰル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LocaleProvider (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース LocaleProvider

既知のサブインタフェースの一覧:
LocaleInfo, LoginInfo, LoginRequestInfo, SessionInfo
既知の実装クラスの一覧:
Account, LoginGroup, SuperUser
public interface LocaleProvider

ロケール取得プロバイダーインタフェース。 ロケール情報を取得するためのインタフェース。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getEncoding() エンコーディングを取得する。
Locale | getLocale() ロケールを取得する。

メソッドの詳細

getLocale

public Locale getLocale()
ロケールを取得する。

戻り値:
ロケール

getEncoding

public String getEncoding()
エンコーディングを取得する。

戻り値:
エンコーディング
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.security
インタフェース
ClientTypeInfo
ColorPatternInfo
ExtendsImport
INonTransaction
LocaleInfo
LocaleProvider
SecurityConstraint
SessionConfig
SessionInfo
SystemSourceProvider
クラス
AccessSecurityManager
DepartmentInfo
ExtendsImportManager
PostInfo
PublicGroupInfo
StandardAccessControllerAccessor
StandardAccountAccessor
StandardBatchAccessor
StandardCalendarAccessor
StandardMenuAccessor
StandardRoleAccessor
SystemManager


jp.co.intra_mart.foundation.security (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security

アクセスセキュリティに関連するクラスを提供します。

参照:
説明

インタフェースの概要
ClientTypeInfo | クライアントタイプ情報インタフェース。
ColorPatternInfo | カラーパターン情報を取得するインタフェース。
ExtendsImport | 拡張インポート処理インターフェース。
INonTransaction | 分散トランザクション未対応のアクセッサに実装するインターフェース。
LocaleInfo | ロケｰル情報・モデルインタフェース。
LocaleProvider | ロケール取得プロバイダーインタフェース。
SecurityConstraint | アクセスセキュリティ定数インタフェース。
SessionConfig | セッションに関する設定情報を取得するインタフェース。
SessionInfo | intra-martセッション情報参照インタフェース。
SystemSourceProvider | ロケール情報取得インターフェース。

クラスの概要
AccessSecurityManager | アクセスセキュリティマネージャクラス。
DepartmentInfo | 組織情報クラス。
ExtendsImportManager | 拡張インポートマネージャクラス。
PostInfo | 役職情報クラス。
PublicGroupInfo | パブリックグループ情報クラス。
StandardAccessControllerAccessor |
StandardAccountAccessor | アカウントアクセッサクラス。
StandardBatchAccessor | バッチアクセッサクラス。
StandardCalendarAccessor | カレンダーアクセッサクラス。
StandardMenuAccessor | メニューアクセッサクラス。
StandardRoleAccessor | ロールアクセッサクラス。
SystemManager | システムマネージャクラス。

パッケージ jp.co.intra_mart.foundation.security の説明

アクセスセキュリティに関連するクラスを提供します。


jp.co.intra_mart.foundation.security クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.AccessSecurityManager
    • class jp.co.intra_mart.foundation.security.DepartmentInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.ExtendsImportManager
    • class jp.co.intra_mart.foundation.security.PostInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.PublicGroupInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor (implements jp.co.intra_mart.foundation.security.access.AccessControllerAccessor)
    • class jp.co.intra_mart.foundation.security.StandardAccountAccessor (implements jp.co.intra_mart.foundation.security.account.AccountAccessor)
    • class jp.co.intra_mart.foundation.security.StandardBatchAccessor (implements jp.co.intra_mart.foundation.security.batch.BatchAccessor)
    • class jp.co.intra_mart.foundation.security.StandardCalendarAccessor (implements jp.co.intra_mart.foundation.security.calendar.CalendarAccessor)
    • class jp.co.intra_mart.foundation.security.StandardMenuAccessor (implements jp.co.intra_mart.foundation.security.menu.MenuAccessor)
    • class jp.co.intra_mart.foundation.security.StandardRoleAccessor (implements jp.co.intra_mart.foundation.security.role.RoleAccessor)
    • class jp.co.intra_mart.foundation.security.SystemManager

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.ClientTypeInfo
  • interface jp.co.intra_mart.foundation.security.ColorPatternInfo
  • interface jp.co.intra_mart.foundation.security.ExtendsImport
  • interface jp.co.intra_mart.foundation.security.INonTransaction
  • interface jp.co.intra_mart.foundation.security.LocaleProvider
    • interface jp.co.intra_mart.foundation.security.LocaleInfo
    • interface jp.co.intra_mart.foundation.security.SessionInfo
  • interface jp.co.intra_mart.foundation.security.SecurityConstraint
  • interface jp.co.intra_mart.foundation.security.SessionConfig
  • interface jp.co.intra_mart.foundation.security.SystemSourceProvider


パッケージ jp.co.intra_mart.foundation.security の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security の使用

jp.co.intra_mart.foundation.security を使用しているパッケージ
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession |
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.duplication |
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.password |

jp.co.intra_mart.foundation.navigator により使用される jp.co.intra_mart.foundation.security のクラス
DepartmentInfo
組織情報クラス。
PostInfo
役職情報クラス。
PublicGroupInfo
パブリックグループ情報クラス。

jp.co.intra_mart.foundation.security により使用される jp.co.intra_mart.foundation.security のクラス
AccessSecurityManager
アクセスセキュリティマネージャクラス。
ClientTypeInfo
クライアントタイプ情報インタフェース。
ColorPatternInfo
カラーパターン情報を取得するインタフェース。
DepartmentInfo
組織情報クラス。
ExtendsImportManager
拡張インポートマネージャクラス。
LocaleInfo
ロケｰル情報・モデルインタフェース。
LocaleProvider
ロケール取得プロバイダーインタフェース。
PostInfo
役職情報クラス。
PublicGroupInfo
パブリックグループ情報クラス。
SessionConfig
セッションに関する設定情報を取得するインタフェース。
SessionInfo
intra-martセッション情報参照インタフェース。
SystemManager
システムマネージャクラス。
SystemSourceProvider
ロケール情報取得インターフェース。

jp.co.intra_mart.foundation.security.access により使用される jp.co.intra_mart.foundation.security のクラス
DepartmentInfo
組織情報クラス。
PostInfo
役職情報クラス。
PublicGroupInfo
パブリックグループ情報クラス。

jp.co.intra_mart.foundation.security.account により使用される jp.co.intra_mart.foundation.security のクラス
LocaleProvider
ロケール取得プロバイダーインタフェース。

jp.co.intra_mart.foundation.security.activesession により使用される jp.co.intra_mart.foundation.security のクラス
SessionInfo
intra-martセッション情報参照インタフェース。

jp.co.intra_mart.foundation.security.admin により使用される jp.co.intra_mart.foundation.security のクラス
LocaleProvider
ロケール取得プロバイダーインタフェース。

jp.co.intra_mart.foundation.security.certification により使用される jp.co.intra_mart.foundation.security のクラス
LocaleProvider
ロケール取得プロバイダーインタフェース。
SessionInfo
intra-martセッション情報参照インタフェース。

jp.co.intra_mart.foundation.security.duplication により使用される jp.co.intra_mart.foundation.security のクラス
SessionInfo
intra-martセッション情報参照インタフェース。

jp.co.intra_mart.foundation.security.group により使用される jp.co.intra_mart.foundation.security のクラス
LocaleProvider
ロケール取得プロバイダーインタフェース。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.security のクラス
DepartmentInfo
組織情報クラス。
PostInfo
役職情報クラス。
PublicGroupInfo
パブリックグループ情報クラス。

jp.co.intra_mart.foundation.security.password により使用される jp.co.intra_mart.foundation.security のクラス
SessionInfo
intra-martセッション情報参照インタフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PostInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス PostInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.PostInfo
すべての実装インタフェース:
Serializable
public class PostInfo
extends Object
implements Serializable

役職情報クラス。

役職情報を保管するクラスです。
メニュー、アクセスコントロールの役職設定情報として利用します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
PostInfo(String companyCode, String postCode)
コンストラクタ。
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getKeyString() 役職情報の識別子を取得します。
String | getPostCode() 役職コードを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PostInfo

public PostInfo(String companyCode,
                String postCode)
コンストラクタ。

メソッドの詳細

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
companyCode 会社コード

getPostCode

public String getPostCode()
役職コードを取得します。

戻り値:
postCode 役職コード

getKeyString

public String getKeyString()
役職情報の識別子を取得します。

戻り値:
役職情報の識別子
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PublicGroupInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス PublicGroupInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.PublicGroupInfo
すべての実装インタフェース:
Serializable
public class PublicGroupInfo
extends Object
implements Serializable

パブリックグループ情報クラス。

パブリックグループ情報を保管するクラスです。
メニュー、アクセスコントロールのパブリックグループ設定情報として利用します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupInfo(String groupSetCode, String groupCode)
コンストラクタ。
メソッドの概要
String | getGroupCode() グループコードを取得します。
String | getGroupSetCode() グループセットコードを取得します。
String | getKeyString() パブリックグループ情報の識別子を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupInfo

public PublicGroupInfo(String groupSetCode,
                       String groupCode)
コンストラクタ。

メソッドの詳細

getGroupSetCode

public String getGroupSetCode()
グループセットコードを取得します。

戻り値:
groupSetCode グループセットコード

getGroupCode

public String getGroupCode()
グループコードを取得します。

戻り値:
groupCode グループコード

getKeyString

public String getKeyString()
パブリックグループ情報の識別子を取得します。

戻り値:
パブリックグループ情報の識別子
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SecurityConstraint (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース SecurityConstraint

public interface SecurityConstraint

アクセスセキュリティ定数インタフェース。 アクセスセキュリティで使用する定数値を定義したインターフェース。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String | ATTR_CERTIFICATION_MODE 認証モード制御パラメータ名。
static String | ATTR_DO_FILTER セッションフィルター制御パラメータ名。
static String | CP_COOKIE セッション情報をクッキーに保管するパラメータ名。
static int | CR_ERROR 認証処理エラーの返却値。
static int | CR_LOCKED アカウントロック状態の返却値。
static int | CR_NG ログインエラーの返却値。
static int | CR_NO_GROUP ログイングループ未登録状態の返却値。
static int | CR_NO_LICENSE ライセンスなし、または有効期間外状態の返却値。
static int | CR_NO_PERMISSION 無許可ページへのアクセスの返却値。
static int | CR_NO_USER ユーザ未登録状態の返却値。
static int | CR_OK 認証成功の返却値。
static int | CR_SESSION_INITIAL セッション初期状態の返却値。
static int | CR_SESSION_LOGON セッションログオン状態の返却値。
static int | CR_SESSION_TIMEOUT セッションタイムアウト状態の返却値。
static int | CR_SESSION_UNMATCH セッション不整合状態の返却値。
static String | LT_GROUP グループマネージャー（ログインタイプ）。
static String | LT_SUPER スーパーユーザ（ログインタイプ）。
static String | LT_USER ユーザ（ログインタイプ）。
static String | RP_CLIENT_TYPE クライアントタイプのデフォルトＵＲＬ引数名。
static String | RP_ENCODING ログインエンコーディングのデフォルトＵＲＬ引数名。
static String | RP_INITIAL_URL 初期ＵＲＬのデフォルトＵＲＬ引数名。
static String | RP_LOCALE ログインロケールのデフォルトＵＲＬ引数名。
static String | RP_LOGIN_GROUP ログイングループIDのデフォルトＵＲＬ引数名。
static String | RP_LOGIN_TYPE ログインタイプのデフォルトＵＲＬ引数名。
static String | RP_PASSWORD パスワードのデフォルトＵＲＬ引数名。
static String | RP_SHORTCUT ショートカットＵＲＬパラメータのデフォルト値
static String | RP_URL ダイレクトＵＲＬのデフォルトＵＲＬ引数名。
static String | RP_URL_SIGN ダイレクトＵＲＬ署名のデフォルトＵＲＬ引数名。
static String | RP_USER ログインユーザＩＤのデフォルトＵＲＬ引数名。
static String | SP_CLIENT_TYPE クライアントタイプをセッションに保管するパラメータ名。
static String | SP_COLOR_PATTERN_ID カラーパターンIDをセッションに保管するパラメータ名。
static String | SP_ENCODING ログインエンコーディングをセッションに保管するパラメータ名。
static String | SP_INITIAL_URL 初期ページURLを属性に保管するパラメータ名。
static String | SP_LOCALE ログインロケールをセッションに保管するパラメータ名。
static String | SP_LOGIN_GROUP ログイングループIDをセッションに保管するパラメータ名。
static String | SP_LOGIN_TIME ログインした時間をセッションに保管するパラメータ名。
static String | SP_LOGIN_TYPE ログインタイプをセッションに保管するパラメータ名。
static String | SP_SHORTCUT ショートカットIDをセッションに保管するパラメータ名
static String | SP_SIGNATURE ログイン署名をセッションに保管するパラメータ名。
static String | SP_URL 認証後表示するメインページをセッションに保管するパラメータ名。
static String | SP_URL_SIGN ダイレクトＵＲＬの署名をセッションに保管するパラメータ名。
static String | SP_USER ログインユーザＩＤをセッションに保管するパラメータ名。

フィールドの詳細

SP_LOGIN_TYPE

public static final String SP_LOGIN_TYPE
ログインタイプをセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_CLIENT_TYPE

public static final String SP_CLIENT_TYPE
クライアントタイプをセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_COLOR_PATTERN_ID

public static final String SP_COLOR_PATTERN_ID
カラーパターンIDをセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_LOCALE

public static final String SP_LOCALE
ログインロケールをセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_ENCODING

public static final String SP_ENCODING
ログインエンコーディングをセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_LOGIN_GROUP

public static final String SP_LOGIN_GROUP
ログイングループIDをセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_USER

public static final String SP_USER
ログインユーザＩＤをセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_SIGNATURE

public static final String SP_SIGNATURE
ログイン署名をセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_LOGIN_TIME

public static final String SP_LOGIN_TIME
ログインした時間をセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_URL

public static final String SP_URL
認証後表示するメインページをセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_URL_SIGN

public static final String SP_URL_SIGN
ダイレクトＵＲＬの署名をセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_INITIAL_URL

public static final String SP_INITIAL_URL
初期ページURLを属性に保管するパラメータ名。

関連項目:
定数フィールド値

CP_COOKIE

public static final String CP_COOKIE
セッション情報をクッキーに保管するパラメータ名。

関連項目:
定数フィールド値

RP_LOGIN_TYPE

public static final String RP_LOGIN_TYPE
ログインタイプのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_CLIENT_TYPE

public static final String RP_CLIENT_TYPE
クライアントタイプのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_LOCALE

public static final String RP_LOCALE
ログインロケールのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_ENCODING

public static final String RP_ENCODING
ログインエンコーディングのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_LOGIN_GROUP

public static final String RP_LOGIN_GROUP
ログイングループIDのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_USER

public static final String RP_USER
ログインユーザＩＤのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_PASSWORD

public static final String RP_PASSWORD
パスワードのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_URL

public static final String RP_URL
ダイレクトＵＲＬのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_URL_SIGN

public static final String RP_URL_SIGN
ダイレクトＵＲＬ署名のデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_INITIAL_URL

public static final String RP_INITIAL_URL
初期ＵＲＬのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

LT_SUPER

public static final String LT_SUPER
スーパーユーザ（ログインタイプ）。

関連項目:
定数フィールド値

LT_GROUP

public static final String LT_GROUP
グループマネージャー（ログインタイプ）。

関連項目:
定数フィールド値

LT_USER

public static final String LT_USER
ユーザ（ログインタイプ）。

関連項目:
定数フィールド値

CR_OK

public static final int CR_OK
認証成功の返却値。

関連項目:
定数フィールド値

CR_NG

public static final int CR_NG
ログインエラーの返却値。

関連項目:
定数フィールド値

CR_NO_LICENSE

public static final int CR_NO_LICENSE
ライセンスなし、または有効期間外状態の返却値。

関連項目:
定数フィールド値

CR_NO_GROUP

public static final int CR_NO_GROUP
ログイングループ未登録状態の返却値。

関連項目:
定数フィールド値

CR_LOCKED

public static final int CR_LOCKED
アカウントロック状態の返却値。

関連項目:
定数フィールド値

CR_NO_USER

public static final int CR_NO_USER
ユーザ未登録状態の返却値。

関連項目:
定数フィールド値

CR_SESSION_INITIAL

public static final int CR_SESSION_INITIAL
セッション初期状態の返却値。

関連項目:
定数フィールド値

CR_SESSION_LOGON

public static final int CR_SESSION_LOGON
セッションログオン状態の返却値。

関連項目:
定数フィールド値

CR_SESSION_UNMATCH

public static final int CR_SESSION_UNMATCH
セッション不整合状態の返却値。

関連項目:
定数フィールド値

CR_SESSION_TIMEOUT

public static final int CR_SESSION_TIMEOUT
セッションタイムアウト状態の返却値。

関連項目:
定数フィールド値

CR_NO_PERMISSION

public static final int CR_NO_PERMISSION
無許可ページへのアクセスの返却値。

関連項目:
定数フィールド値

CR_ERROR

public static final int CR_ERROR
認証処理エラーの返却値。

関連項目:
定数フィールド値

ATTR_DO_FILTER

public static final String ATTR_DO_FILTER
セッションフィルター制御パラメータ名。

関連項目:
定数フィールド値

ATTR_CERTIFICATION_MODE

public static final String ATTR_CERTIFICATION_MODE
認証モード制御パラメータ名。

関連項目:
定数フィールド値

RP_SHORTCUT

public static final String RP_SHORTCUT
ショートカットＵＲＬパラメータのデフォルト値

関連項目:
定数フィールド値

SP_SHORTCUT

public static final String SP_SHORTCUT
ショートカットIDをセッションに保管するパラメータ名

関連項目:
定数フィールド値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionConfig (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース SessionConfig

public interface SessionConfig

セッションに関する設定情報を取得するインタフェース。

セッションに関する設定情報を取得するためのインタフェースです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getClientTypeName() クライアントタイプをセッションに保管するためのパラメータ名を取得する。
String | getColorPatternIdName() カラーパターンIDをセッションに保管するためのパラメータ名を取得する。
String | getEncodingName() エンコーディングをセッションに保管するためのパラメータ名を取得する。
String | getInitialUrlName() 初期ページURLをセッションに保管するためパラメータ名を取得する。
String | getLocaleName() ロケールをセッションに保管するためのパラメータ名を取得する。
String | getLoginGroupName() ログイングループをセッションに保管するためのパラメータ名を取得する。
String | getLoginTimeName() ログイン時間をセッションに保管するためのパラメータ名を取得する。
String | getLoginTypeName() ログインタイプをセッションに保管するためのパラメータ名を取得する。
String | getSessionCookieName() クッキーにセッション情報を保管するためパラメータ名を取得する。
String | getShortcutName() ショートカットＩＤをセッションに保管するためのパラメータ名を取得する。
String | getSignatureName() ログイン署名をセッションに保管するためのパラメータ名を取得する。
String | getUrlName() ダイレクトＵＲＬをセッションに保管するためパラメータ名を取得する。
String | getUrlSignatureName() ダイレクトＵＲＬ署名をセッションに保管するためパラメータ名を取得する。
String | getUserName() ユーザＩＤをセッションに保管するためのパラメータ名を取得する。

メソッドの詳細

getClientTypeName

public String getClientTypeName()
クライアントタイプをセッションに保管するためのパラメータ名を取得する。

戻り値:
ログインタイプをセッションに保管するためのパラメータ名

getColorPatternIdName

public String getColorPatternIdName()
カラーパターンIDをセッションに保管するためのパラメータ名を取得する。

戻り値:
カラーパターンIDをセッションに保管するためのパラメータ名

getEncodingName

public String getEncodingName()
エンコーディングをセッションに保管するためのパラメータ名を取得する。

戻り値:
エンコーディングをセッションに保管するためのパラメータ名

getInitialUrlName

public String getInitialUrlName()
初期ページURLをセッションに保管するためパラメータ名を取得する。

戻り値:
初期ページURLをセッションに保管するためパラメータ名

getLocaleName

public String getLocaleName()
ロケールをセッションに保管するためのパラメータ名を取得する。

戻り値:
ロケールをセッションに保管するためのパラメータ名

getLoginGroupName

public String getLoginGroupName()
ログイングループをセッションに保管するためのパラメータ名を取得する。

戻り値:
ログイングループをセッションに保管するためのパラメータ名

getLoginTimeName

public String getLoginTimeName()
ログイン時間をセッションに保管するためのパラメータ名を取得する。

戻り値:
ログイン時間をセッションに保管するためのパラメータ名

getLoginTypeName

public String getLoginTypeName()
ログインタイプをセッションに保管するためのパラメータ名を取得する。

戻り値:
ログインタイプをセッションに保管するためのパラメータ名

getSessionCookieName

public String getSessionCookieName()
クッキーにセッション情報を保管するためパラメータ名を取得する。

戻り値:
クッキーにセッション情報を保管するためパラメータ名

getSignatureName

public String getSignatureName()
ログイン署名をセッションに保管するためのパラメータ名を取得する。

戻り値:
ログイン署名をセッションに保管するためのパラメータ名

getUrlName

public String getUrlName()
ダイレクトＵＲＬをセッションに保管するためパラメータ名を取得する。

戻り値:
ログイン署名をセッションに保管するためのパラメータ名

getUrlSignatureName

public String getUrlSignatureName()
ダイレクトＵＲＬ署名をセッションに保管するためパラメータ名を取得する。

戻り値:
ログイン署名をセッションに保管するためのパラメータ名

getUserName

public String getUserName()
ユーザＩＤをセッションに保管するためのパラメータ名を取得する。

戻り値:
ユーザＩＤをセッションに保管するためのパラメータ名

getShortcutName

public String getShortcutName()
ショートカットＩＤをセッションに保管するためのパラメータ名を取得する。

戻り値:
ショートカットＩＤをセッションに保管するためのパラメータ名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionInfo (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース SessionInfo

すべてのスーパーインタフェース:
LocaleProvider
public interface SessionInfo
extends LocaleProvider

intra-martセッション情報参照インタフェース。

intra-martセッション情報を参照するためのインタフェース
intra-martセッション情報を参照する場合は、必ずこのインターフェースを利用して行う。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String COOKIE_SEPARATOR
セッション情報をクッキーに保管する際のセパレータ。
メソッドの概要
void | clearUrl() ダイレクトＵＲＬを削除する。
Object | getAttribute(String key) セッションから指定した属性の値を取得します。
String | getClientType() クライアントタイプを取得する。
String | getColorPatternId() カラーパターンIDを取得する。
String | getEncoding() エンコーディングを取得する。
String | getInitialUrl() 初期ページURLを取得します。
Locale | getLocale() ロケールを取得する。
String | getLoginGroup() ログイングループIDを取得する。
Date | getLoginTime() ログインした時間を取得する。
String | getLoginType() ログインタイプを取得する。
String | getSignature() ログイン署名を取得する。
String | getUrl() ダイレクトＵＲＬを取得する。
String | getUrlSignature() ダイレクトＵＲＬ署名を取得する。
String | getUser() ログインユーザIDを取得する。
Object | removeAttribute(String key) セッションから指定された属性を削除します。
Object | setAttribute(String key, Object value) セッションから指定した属性に値を保管します。

フィールドの詳細

COOKIE_SEPARATOR

public static final String COOKIE_SEPARATOR
セッション情報をクッキーに保管する際のセパレータ。

同じパッケージ内のみ使用可能。

関連項目:
定数フィールド値
メソッドの詳細

clearUrl

public void clearUrl()
ダイレクトＵＲＬを削除する。
セッション情報のダイレクトURLとダイレクトＵＲＬ署名を初期化します。

getClientType

public String getClientType()
クライアントタイプを取得する。
セッション情報にクライアントタイプが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
クライアントタイプ

getColorPatternId

public String getColorPatternId()
カラーパターンIDを取得する。
セッション情報にログインユーザIDが存在しない場合、および空文字列の場合はデフォルトのカラーパターンIDを返却する。

戻り値:
カラーパターンID

getEncoding

public String getEncoding()
エンコーディングを取得する。
セッション情報にエンコーディングが存在しない場合、および空文字列の場合は空文字列を返却する。

定義:
インタフェース LocaleProvider 内の getEncoding
戻り値:
エンコーディング

getInitialUrl

public String getInitialUrl()
初期ページURLを取得します。
セッション情報に初期ページURLが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
初期ページURL

getLocale

public Locale getLocale()
ロケールを取得する。
セッション情報にロケールが存在しない場合、および空文字列の場合はnullを返却する。

定義:
インタフェース LocaleProvider 内の getLocale
戻り値:
ロケール

getLoginGroup

public String getLoginGroup()
ログイングループIDを取得する。
セッション情報にログイングループIDが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
ログイングループID

getLoginTime

public Date getLoginTime()
ログインした時間を取得する。
セッション情報にログイン時間が存在しない場合、nullを返却する。

戻り値:
ログイン時間

getLoginType

public String getLoginType()
ログインタイプを取得する。
セッション情報にログインタイプが存在しない場合、および空文字列の場合は SecurityConstraint.LT_USER を返却する。

戻り値:
ログインタイプ
関連項目:
SecurityConstraint.LT_SUPER, SecurityConstraint.LT_GROUP, SecurityConstraint.LT_USER

getSignature

public String getSignature()
ログイン署名を取得する。
セッション情報にログイン署名が存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
ログイン署名

getUrl

public String getUrl()
ダイレクトＵＲＬを取得する。
セッション情報にダイレクトURLが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
ダイレクトＵＲＬ

getUrlSignature

public String getUrlSignature()
ダイレクトＵＲＬ署名を取得する。
セッション情報にダイレクトURL署名が存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
ダイレクトＵＲＬ署名

getUser

public String getUser()
ログインユーザIDを取得する。
セッション情報にログインユーザIDが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
ログインユーザID

getAttribute

public Object getAttribute(String key)
セッションから指定した属性の値を取得します。

パラメータ:
key - 属性名
戻り値:
属性値
導入されたバージョン:
6.1

setAttribute

public Object setAttribute(String key,
                           Object value)
セッションから指定した属性に値を保管します。

パラメータ:
key - 属性名
value - 属性値
戻り値:
保管されていた属性値
導入されたバージョン:
6.1

removeAttribute

public Object removeAttribute(String key)
セッションから指定された属性を削除します。

パラメータ:
key - 属性名
戻り値:
削除された属性値
導入されたバージョン:
6.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardAccessControllerAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス StandardAccessControllerAccessor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor
すべての実装インタフェース:
AccessControllerAccessor
public class StandardAccessControllerAccessor
extends Object
implements AccessControllerAccessor

フィールドの概要
static String | APPLICATION_NAME アプリケーション名
static String | ENTITY_CONTROLLER_DEPARTMENT_NAME
static String | ENTITY_CONTROLLER_NAME エンティティ名
static String | ENTITY_CONTROLLER_POST_NAME
static String | ENTITY_CONTROLLER_PUBLIC_GROUP_NAME
static String | ENTITY_CONTROLLER_ROLE_NAME
コンストラクタの概要
StandardAccessControllerAccessor()
メソッドの概要
void | deleteController(String groupId, String controllerId) アクセスコントローラを削除します。
void | deleteControllerDepartment(String groupId, String id, DepartmentInfo departmentInfo) アクセスコントローラ組織を削除します。
void | deleteControllerDepartments(String groupId, String id) すべてのアクセスコントローラ組織を削除します。
void | deleteControllerPost(String groupId, String id, PostInfo postInfo) アクセスコントローラ役職を削除します。
void | deleteControllerPosts(String groupId, String id) すべてのアクセスコントローラ役職を削除します。
void | deleteControllerPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) アクセスコントローラパブリックグループを削除します。
void | deleteControllerPublicGroups(String groupId, String id) すべてのアクセスコントローラパブリックグループを削除します。
void | deleteControllerRole(String groupId, String id, String roleId) アクセスコントローラロールを削除します。
void | deleteControllerRoles(String groupId, String id) すべてのアクセスコントローラロールを削除します。
AccessController | getController(String groupId, String controllerId) アクセスコントローラ情報を取得します。
DepartmentInfo[] | getControllerDepartments(String groupId, String id) すべてのアクセスコントローラ組織を取得します。
String[] | getControllerIds(String groupId) すべてのアクセスコントローラIDを取得します。
String[] | getControllerIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つコントローラIDをすべて取得します。
String[] | getControllerIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つコントローラIDをすべて取得します。
String[] | getControllerIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つコントローラIDをすべて取得します。
String[] | getControllerIdsByRole(String groupId, String[] roleIds) 指定されたロールIDを持つコントローラIDをすべて取得します。
PostInfo[] | getControllerPosts(String groupId, String id) すべてのアクセスコントローラ役職を取得します。
PublicGroupInfo[] | getControllerPublicGroups(String groupId, String id) すべてのアクセスコントローラパブリックグループを取得します。
String[] | getControllerRoles(String groupId, String id) すべてのアクセスコントローラロールを取得します。
AccessController[] | getControllers(String groupId) すべてのアクセスコントローラ情報を取得します。
protected String | getLoginUser() ログインユーザを取得します。
void | init(Map params) アクセスコントローラアクセッサの初期化。
void | insertAccessController(String groupId, AccessController controller) アクセスコントローラを作成します。
void | insertControllerDepartment(String groupId, String id, DepartmentInfo departmentInfo) アクセスコントローラ組織を新規に作成します。
void | insertControllerPost(String groupId, String id, PostInfo postInfo) アクセスコントローラ役職を新規に作成します。
void | insertControllerPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) アクセスコントローラパブリックグループを新規に作成します。
void | insertControllerRole(String groupId, String id, String roleId) アクセスコントローラロールを新規に作成します。
void | updateController(String groupId, AccessController controller) アクセスコントローラを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

APPLICATION_NAME

public static final String APPLICATION_NAME
アプリケーション名

関連項目:
定数フィールド値

ENTITY_CONTROLLER_DEPARTMENT_NAME

public static final String ENTITY_CONTROLLER_DEPARTMENT_NAME
関連項目:
定数フィールド値

ENTITY_CONTROLLER_NAME

public static final String ENTITY_CONTROLLER_NAME
エンティティ名

関連項目:
定数フィールド値

ENTITY_CONTROLLER_POST_NAME

public static final String ENTITY_CONTROLLER_POST_NAME
関連項目:
定数フィールド値

ENTITY_CONTROLLER_PUBLIC_GROUP_NAME

public static final String ENTITY_CONTROLLER_PUBLIC_GROUP_NAME
関連項目:
定数フィールド値

ENTITY_CONTROLLER_ROLE_NAME

public static final String ENTITY_CONTROLLER_ROLE_NAME
関連項目:
定数フィールド値
コンストラクタの詳細

StandardAccessControllerAccessor

public StandardAccessControllerAccessor()
メソッドの詳細

deleteController

public void deleteController(String groupId,
                             String controllerId)
                      throws AccessSecurityWriteException
アクセスコントローラを削除します。

定義:
インタフェース AccessControllerAccessor 内の deleteController
パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException

deleteControllerDepartment

public void deleteControllerDepartment(String groupId,
                                       String id,
                                       DepartmentInfo departmentInfo)
                                throws AccessSecurityWriteException
アクセスコントローラ組織を削除します。

定義:
インタフェース AccessControllerAccessor 内の deleteControllerDepartment
パラメータ:
groupId - ログイングループID
id - コントローラID
departmentInfo - 組織情報
例外:
AccessSecurityWriteException

deleteControllerDepartments

public void deleteControllerDepartments(String groupId,
                                        String id)
                                 throws AccessSecurityWriteException
すべてのアクセスコントローラ組織を削除します。

定義:
インタフェース AccessControllerAccessor 内の deleteControllerDepartments
パラメータ:
groupId - ログイングループID
id - アクセスコントローラID
例外:
AccessSecurityWriteException

deleteControllerPost

public void deleteControllerPost(String groupId,
                                 String id,
                                 PostInfo postInfo)
                          throws AccessSecurityWriteException
アクセスコントローラ役職を削除します。

定義:
インタフェース AccessControllerAccessor 内の deleteControllerPost
パラメータ:
groupId - ログイングループID
id - コントローラID
postInfo - 役職情報
例外:
AccessSecurityWriteException

deleteControllerPosts

public void deleteControllerPosts(String groupId,
                                  String id)
                           throws AccessSecurityWriteException
すべてのアクセスコントローラ役職を削除します。

定義:
インタフェース AccessControllerAccessor 内の deleteControllerPosts
パラメータ:
groupId - ログイングループID
id - コントローラID
例外:
AccessSecurityWriteException

deleteControllerPublicGroup

public void deleteControllerPublicGroup(String groupId,
                                        String id,
                                        PublicGroupInfo publicGroupInfo)
                                 throws AccessSecurityWriteException
アクセスコントローラパブリックグループを削除します。

定義:
インタフェース AccessControllerAccessor 内の deleteControllerPublicGroup
パラメータ:
groupId - ログイングループID
id - コントローラID
publicGroupInfo - パブリックグループ情報
例外:
AccessSecurityWriteException

deleteControllerPublicGroups

public void deleteControllerPublicGroups(String groupId,
                                         String id)
                                  throws AccessSecurityWriteException
すべてのアクセスコントローラパブリックグループを削除します。

定義:
インタフェース AccessControllerAccessor 内の deleteControllerPublicGroups
パラメータ:
groupId - ログイングループID
id - コントローラID
例外:
AccessSecurityWriteException

deleteControllerRole

public void deleteControllerRole(String groupId,
                                 String id,
                                 String roleId)
                          throws AccessSecurityWriteException
アクセスコントローラロールを削除します。

定義:
インタフェース AccessControllerAccessor 内の deleteControllerRole
パラメータ:
groupId - ログイングループID
id - コントローラID
roleId - ロールID
例外:
AccessSecurityWriteException

deleteControllerRoles

public void deleteControllerRoles(String groupId,
                                  String id)
                           throws AccessSecurityWriteException
すべてのアクセスコントローラロールを削除します。

定義:
インタフェース AccessControllerAccessor 内の deleteControllerRoles
パラメータ:
groupId - ログイングループID
id - コントローラID
例外:
AccessSecurityWriteException

getController

public AccessController getController(String groupId,
                                      String controllerId)
                               throws AccessSecurityReadException
アクセスコントローラ情報を取得します。

存在しない場合は、nullを返却します。

定義:
インタフェース AccessControllerAccessor 内の getController
パラメータ:
groupId - ログイングループID
controllerId - コントローラID
戻り値:
アクセスコントローラ情報
例外:
AccessSecurityReadException

getControllers

public AccessController[] getControllers(String groupId)
                                  throws AccessSecurityReadException
すべてのアクセスコントローラ情報を取得します。

一件も存在しない場合は、空の配列を返却します。

定義:
インタフェース AccessControllerAccessor 内の getControllers
パラメータ:
groupId - ログイングループID
戻り値:
アクセスコントローラ情報の配列
例外:
AccessSecurityReadException

getControllerDepartments

public DepartmentInfo[] getControllerDepartments(String groupId,
                                                 String id)
                                          throws AccessSecurityReadException
すべてのアクセスコントローラ組織を取得します。

一件も存在しない場合は、空の配列を返却します。

定義:
インタフェース AccessControllerAccessor 内の getControllerDepartments
パラメータ:
groupId - ログイングループID
id - コントローラID
戻り値:
組織情報の配列
例外:
AccessSecurityReadException

getControllerIds

public String[] getControllerIds(String groupId)
                          throws AccessSecurityReadException
すべてのアクセスコントローラIDを取得します。

一件も存在しない場合は、空の配列を返却します。

定義:
インタフェース AccessControllerAccessor 内の getControllerIds
パラメータ:
groupId - ログイングループID
戻り値:
クセスコントローラIDの配列
例外:
AccessSecurityReadException

getControllerIdsByDepartment

public String[] getControllerIdsByDepartment(String groupId,
                                             DepartmentInfo[] departments)
                                      throws AccessSecurityReadException
指定された組織を持つコントローラIDをすべて取得します。

定義:
インタフェース AccessControllerAccessor 内の getControllerIdsByDepartment
パラメータ:
groupId - ログイングループID
departments - 組織情報の配列
戻り値:
コントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerIdsByPost

public String[] getControllerIdsByPost(String groupId,
                                       PostInfo[] posts)
                                throws AccessSecurityReadException
指定された役職を持つコントローラIDをすべて取得します。

定義:
インタフェース AccessControllerAccessor 内の getControllerIdsByPost
パラメータ:
groupId - ログイングループID
posts - 役職情報の配列
戻り値:
コントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerIdsByPublicGroup

public String[] getControllerIdsByPublicGroup(String groupId,
                                              PublicGroupInfo[] publicGroups)
                                       throws AccessSecurityReadException
指定されたパブリックグループを持つコントローラIDをすべて取得します。

定義:
インタフェース AccessControllerAccessor 内の getControllerIdsByPublicGroup
パラメータ:
groupId - ログイングループID
publicGroups - パブリックグループの配列
戻り値:
コントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerIdsByRole

public String[] getControllerIdsByRole(String groupId,
                                       String[] roleIds)
                                throws AccessSecurityReadException
指定されたロールIDを持つコントローラIDをすべて取得します。

定義:
インタフェース AccessControllerAccessor 内の getControllerIdsByRole
パラメータ:
groupId - ログイングループID
roleIds - ロールIDの配列
戻り値:
コントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - アクセスコントローラ情報取得に失敗した場合スローされます。

getControllerPosts

public PostInfo[] getControllerPosts(String groupId,
                                     String id)
                              throws AccessSecurityReadException
すべてのアクセスコントローラ役職を取得します。

一件も存在しない場合は、空の配列を返却します。

定義:
インタフェース AccessControllerAccessor 内の getControllerPosts
パラメータ:
groupId - ログイングループID
id - コントローラID
戻り値:
役職情報の配列
例外:
AccessSecurityReadException

getControllerPublicGroups

public PublicGroupInfo[] getControllerPublicGroups(String groupId,
                                                   String id)
                                            throws AccessSecurityReadException
すべてのアクセスコントローラパブリックグループを取得します。

一件も存在しない場合は、空の配列を返却します。

定義:
インタフェース AccessControllerAccessor 内の getControllerPublicGroups
パラメータ:
groupId - ログイングループID
id - コントローラID
戻り値:
パブリックグループ情報の配列
例外:
AccessSecurityReadException

getControllerRoles

public String[] getControllerRoles(String groupId,
                                   String id)
                            throws AccessSecurityReadException
すべてのアクセスコントローラロールを取得します。

一件も存在しない場合は、空の配列を返却します。

定義:
インタフェース AccessControllerAccessor 内の getControllerRoles
パラメータ:
groupId - ログイングループID
id - コントローラID
戻り値:
アクセスコントローラロールIDの配列
例外:
AccessSecurityReadException

getLoginUser

protected String getLoginUser()
ログインユーザを取得します。
ログインユーザの取得に失敗した場合は空文字列を返却します。

戻り値:
ログインユーザID

init

public void init(Map params)
アクセスコントローラアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース AccessControllerAccessor 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

insertAccessController

public void insertAccessController(String groupId,
                                   AccessController controller)
                            throws AccessSecurityWriteException
アクセスコントローラを作成します。

定義:
インタフェース AccessControllerAccessor 内の insertAccessController
パラメータ:
groupId - ログイングループID
controller - アクセスコントローラ情報
例外:
AccessSecurityWriteException

insertControllerDepartment

public void insertControllerDepartment(String groupId,
                                       String id,
                                       DepartmentInfo departmentInfo)
                                throws AccessSecurityWriteException
アクセスコントローラ組織を新規に作成します。

定義:
インタフェース AccessControllerAccessor 内の insertControllerDepartment
パラメータ:
groupId - ログイングループID
id - コントローラID
departmentInfo - 組織情報
例外:
AccessSecurityWriteException

insertControllerPost

public void insertControllerPost(String groupId,
                                 String id,
                                 PostInfo postInfo)
                          throws AccessSecurityWriteException
アクセスコントローラ役職を新規に作成します。

定義:
インタフェース AccessControllerAccessor 内の insertControllerPost
パラメータ:
groupId - ログイングループID
id - コントローラID
postInfo - 役職情報
例外:
AccessSecurityWriteException

insertControllerPublicGroup

public void insertControllerPublicGroup(String groupId,
                                        String id,
                                        PublicGroupInfo publicGroupInfo)
                                 throws AccessSecurityWriteException
アクセスコントローラパブリックグループを新規に作成します。

定義:
インタフェース AccessControllerAccessor 内の insertControllerPublicGroup
パラメータ:
groupId - ログイングループID
id - コントローラID
publicGroupInfo - パブリックグループ情報
例外:
AccessSecurityWriteException

insertControllerRole

public void insertControllerRole(String groupId,
                                 String id,
                                 String roleId)
                          throws AccessSecurityWriteException
アクセスコントローラロールを新規に作成します。

定義:
インタフェース AccessControllerAccessor 内の insertControllerRole
パラメータ:
groupId - ログイングループID
id - コントローラID
roleId - ロールID
例外:
AccessSecurityWriteException

updateController

public void updateController(String groupId,
                             AccessController controller)
                      throws AccessSecurityWriteException
アクセスコントローラを更新します。

定義:
インタフェース AccessControllerAccessor 内の updateController
パラメータ:
groupId - ログイングループID
controller - アクセスコントローラ情報
例外:
AccessSecurityWriteException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardAccountAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス StandardAccountAccessor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.StandardAccountAccessor
すべての実装インタフェース:
AccountAccessor
public class StandardAccountAccessor
extends Object
implements AccountAccessor

アカウントアクセッサクラス。

アカウント情報の読み込みおよび書き込みのクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String | APPLICATION_NAME アプリケーション名
static String | ENTITY_NAME_ACCOUNT エンティティ名
static String | ENTITY_NAME_ACCOUNT_ATTRIBUTE
static String | ENTITY_NAME_ACCOUNT_ROLE
static String | ENTITY_NAME_FAVORITE_MENU
static String | ID_CRYPTION_CLASS 暗号化クラス名
コンストラクタの概要
StandardAccountAccessor()
コンストラクタ。
メソッドの概要
void | deleteAccount(String groupId, String userId) アカウント情報を削除する。
void | deleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報を削除する。
void | deleteAttribute(String groupId, String userId, String name) アカウント属性情報を削除する。
void | deleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を削除する。
Account | getAccount(String groupId, String userId) アカウント情報を取得する。
int | getAccountCount(String groupId) アカウント数を取得する。
AccountRole | getAccountRole(String groupId, String userId, String roleId) アカウントロール情報を取得する。
String[] | getAccountRoleIds(String groupId, String userId) アカウントロールIDをすべて取得する。
AccountRole[] | getAccountRoles(String groupId, String userId) アカウントロール情報をすべて取得する。
Account[] | getAccountsByUserIds(String groupId, String[] userIds) 指定されたユーザIDのアカウント情報をすべて取得する。
String | getAttribute(String groupId, String userId, String name) アカウント属性情報を取得する。
String[] | getAttributeNames(String groupId, String userId) アカウント属性名の一覧を取得する。
FavoriteMenu | getFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を取得する。
String[] | getFavoriteMenuIds(String groupId, String userId) マイメニューIDをすべて取得する。
FavoriteMenu[] | getFavoriteMenus(String groupId, String userId) マイメニュー情報をすべて取得する。
protected String | getLoginUser() ログインユーザを取得します。
String[] | getUserIds(String groupId) ユーザIDの一覧を取得する。
String[] | getUserIdsByAccountRole(String groupId, String roleId) 引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
String[] | getUserIdsByAttribute(String groupId, String key, String value) アカウント属性情報の値と一致するユーザIDを取得する。
String[] | getUserIdsByRoles(String groupId, String[] roleIds, Date date) 指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
protected String[] | getUserIdsByRolesIn(String groupId, String[] roleIds, Date date) 指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
protected String[] | getUserIdsByRolesPlural(String groupId, String[] roleIds, Date date) 指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
void | init(Map params) アカウントアクセッサの初期化。
void | insertAccount(String groupId, Account account) アカウント情報を新規追加する。
void | insertAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を新規追加する。
void | insertFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を新規追加する。
Account[] | searchAccounts(String groupId, String userId) アカウント情報の読み込みます。
void | setAttribute(String groupId, String userId, String name, String value) アカウント属性情報を設定する。
void | updateAccount(String groupId, Account account) アカウント情報を更新する。
void | updateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を更新する。
void | updateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を更新する。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

APPLICATION_NAME

public static final String APPLICATION_NAME
アプリケーション名

関連項目:
定数フィールド値

ENTITY_NAME_ACCOUNT

public static final String ENTITY_NAME_ACCOUNT
エンティティ名

関連項目:
定数フィールド値

ENTITY_NAME_ACCOUNT_ROLE

public static final String ENTITY_NAME_ACCOUNT_ROLE
関連項目:
定数フィールド値

ENTITY_NAME_FAVORITE_MENU

public static final String ENTITY_NAME_FAVORITE_MENU
関連項目:
定数フィールド値

ENTITY_NAME_ACCOUNT_ATTRIBUTE

public static final String ENTITY_NAME_ACCOUNT_ATTRIBUTE
関連項目:
定数フィールド値

ID_CRYPTION_CLASS

public static final String ID_CRYPTION_CLASS
暗号化クラス名

関連項目:
定数フィールド値
コンストラクタの詳細

StandardAccountAccessor

public StandardAccountAccessor()
コンストラクタ。

メソッドの詳細

getUserIdsByRolesIn

protected String[] getUserIdsByRolesIn(String groupId,
                                       String[] roleIds,
                                       Date date)
                                throws AccessSecurityReadException
指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。

ロールID一覧を条件につなげてSQL一回発行版

パラメータ:
groupId - ログイングループID
roleIds - 検証用ロールIDの一覧
date - 有効期間判定用の日付
戻り値:
有効なアカウントロールを持つアカウントのユーザIDの配列
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

getUserIdsByRolesPlural

protected String[] getUserIdsByRolesPlural(String groupId,
                                           String[] roleIds,
                                           Date date)
                                    throws AccessSecurityReadException
指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。

ロールID一覧分SQL発行版

パラメータ:
groupId - ログイングループID
roleIds - 検証用ロールIDの一覧
date - 有効期間判定用の日付
戻り値:
有効なアカウントロールを持つアカウントのユーザIDの配列
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

getLoginUser

protected String getLoginUser()
ログインユーザを取得します。
ログインユーザの取得に失敗した場合は空文字列を返却します。

戻り値:
ログインユーザID

deleteAccount

public void deleteAccount(String groupId,
                          String userId)
                   throws AccessSecurityWriteException,
                          NotExistException
アカウント情報を削除する。

定義:
インタフェース AccountAccessor 内の deleteAccount
パラメータ:
groupId - ログイングループID
userId - 削除するユーザコード
例外:
AccessSecurityWriteException - アカウント情報の削除に失敗した場合スローされます。
NotExistException - 削除するアカウント情報が存在しない場合にスローされます。

deleteAccountRole

public void deleteAccountRole(String groupId,
                              String userId,
                              String roleId)
                       throws AccessSecurityWriteException,
                              NotExistException
アカウントロール情報を削除する。

アカウントに紐付くアカウントロール情報を削除します。

定義:
インタフェース AccountAccessor 内の deleteAccountRole
パラメータ:
groupId - ログイングループID
userId - ユーザID
roleId - ロールID
例外:
AccessSecurityWriteException - アカウントロール情報の削除に失敗した場合スローされます。
NotExistException - 削除するアカウントロール情報が存在しない場合にスローされます。

deleteFavoriteMenu

public void deleteFavoriteMenu(String groupId,
                               String userId,
                               String menuId)
                        throws AccessSecurityWriteException,
                               NotExistException
マイメニュー情報を削除する。

アカウントに紐付くマイメニュー情報を削除します。

定義:
インタフェース AccountAccessor 内の deleteFavoriteMenu
パラメータ:
groupId - ログイングループID
userId - ユーザID
menuId - メニューID
例外:
AccessSecurityWriteException - マイメニュー情報の削除に失敗した場合スローされます。
NotExistException - 削除するマイメニュー情報が存在しない場合にスローされます。

getAccount

public Account getAccount(String groupId,
                          String userId)
                   throws AccessSecurityReadException
アカウント情報を取得する。

定義:
インタフェース AccountAccessor 内の getAccount
パラメータ:
groupId - ログイングループID
userId - ユーザIDの完全一致名
戻り値:
ユーザアカウントオブジェクト
存在しない場合は、nullを返却します。
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

getAccountCount

public int getAccountCount(String groupId)
                    throws AccessSecurityReadException
アカウント数を取得する。

定義:
インタフェース AccountAccessor 内の getAccountCount
パラメータ:
groupId - ログイングループID
戻り値:
ユーザアカウント数
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

getAccountRole

public AccountRole getAccountRole(String groupId,
                                  String userId,
                                  String roleId)
                           throws AccessSecurityReadException
アカウントロール情報を取得する。

アカウントに紐付くアカウントロール情報を取得します。

定義:
インタフェース AccountAccessor 内の getAccountRole
パラメータ:
groupId - ログイングループID
userId - ユーザID
roleId - ロールID
戻り値:
ユーザアカウントロール情報
存在しない場合は、nullを返却します。
例外:
AccessSecurityReadException - アカウントロール情報取得に失敗した場合スローされます。

getAccountRoleIds

public String[] getAccountRoleIds(String groupId,
                                  String userId)
                           throws AccessSecurityReadException
アカウントロールIDをすべて取得する。

アカウントに紐付くアカウントロールIDをすべて取得します。

定義:
インタフェース AccountAccessor 内の getAccountRoleIds
パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
ユーザアカウントロール情報の配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - アカウントロール情報取得に失敗した場合スローされます。

getAccountRoles

public AccountRole[] getAccountRoles(String groupId,
                                     String userId)
                              throws AccessSecurityReadException
アカウントロール情報をすべて取得する。

アカウントに紐付くアカウントロール情報をすべて取得します。

定義:
インタフェース AccountAccessor 内の getAccountRoles
パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
ユーザアカウントロール情報の配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - アカウントロール情報取得に失敗した場合スローされます。

getAccountsByUserIds

public Account[] getAccountsByUserIds(String groupId,
                                      String[] userIds)
                               throws AccessSecurityReadException
指定されたユーザIDのアカウント情報をすべて取得する。

定義:
インタフェース AccountAccessor 内の getAccountsByUserIds
パラメータ:
groupId - ログイングループID
userIds - ユーザIDの配列
戻り値:
ユーザアカウントオブジェクトの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

getFavoriteMenu

public FavoriteMenu getFavoriteMenu(String groupId,
                                    String userId,
                                    String menuId)
                             throws AccessSecurityReadException
マイメニュー情報を取得する。

アカウントに紐付くマイメニュー情報を取得します。

定義:
インタフェース AccountAccessor 内の getFavoriteMenu
パラメータ:
groupId - ログイングループID
userId - ユーザID
menuId - メニューID
戻り値:
マイメニュー情報
存在しない場合は、nullを返却します。
例外:
AccessSecurityReadException - マイメニュー情報取得に失敗した場合スローされます。

getFavoriteMenuIds

public String[] getFavoriteMenuIds(String groupId,
                                   String userId)
                            throws AccessSecurityReadException
マイメニューIDをすべて取得する。

アカウントに紐付くマイメニューIDをすべて取得します。

定義:
インタフェース AccountAccessor 内の getFavoriteMenuIds
パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
マイメニュー情報の配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - マイメニュー情報取得に失敗した場合スローされます。

getFavoriteMenus

public FavoriteMenu[] getFavoriteMenus(String groupId,
                                       String userId)
                                throws AccessSecurityReadException
マイメニュー情報をすべて取得する。

アカウントに紐付くマイメニュー情報をすべて取得します。

定義:
インタフェース AccountAccessor 内の getFavoriteMenus
パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
マイメニュー情報の配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - マイメニュー情報取得に失敗した場合スローされます。

getUserIds

public String[] getUserIds(String groupId)
                    throws AccessSecurityReadException
ユーザIDの一覧を取得する。

定義:
インタフェース AccountAccessor 内の getUserIds
パラメータ:
groupId - ログイングループID
戻り値:
ユーザIDの配列
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

getUserIdsByAccountRole

public String[] getUserIdsByAccountRole(String groupId,
                                        String roleId)
                                 throws AccessSecurityReadException
引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。 引数で指定したアカウントロールを持つアカウントのユーザIDの一覧を返却します。
指定したアカウントロールの階層のチェックはお行いません。

定義:
インタフェース AccountAccessor 内の getUserIdsByAccountRole
パラメータ:
groupId - ログイングループID
roleId - String アカウントロールのロールID
戻り値:
ユーザIDの配列（データがない場合は空の配列を返します）
例外:
AccessSecurityReadException - アカウント情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getUserIdsByRoles

public String[] getUserIdsByRoles(String groupId,
                                  String[] roleIds,
                                  Date date)
                           throws AccessSecurityReadException
指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。

定義:
インタフェース AccountAccessor 内の getUserIdsByRoles
パラメータ:
groupId - ログイングループID
roleIds - 検証用ロールIDの一覧
date - 有効期間判定用の日付
戻り値:
有効なアカウントロールを持つアカウントのユーザIDの配列
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

init

public void init(Map params)
アカウントアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース AccountAccessor 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

insertAccount

public void insertAccount(String groupId,
                          Account account)
                   throws AccessSecurityWriteException,
                          DuplicateException
アカウント情報を新規追加する。

定義:
インタフェース AccountAccessor 内の insertAccount
パラメータ:
groupId - ログイングループID
account - アカウント情報
例外:
AccessSecurityWriteException - アカウント情報の作成に失敗した場合スローされます。
DuplicateException - 追加するアカウント情報が既に存在した場合スローされます。

insertAccountRole

public void insertAccountRole(String groupId,
                              String userId,
                              AccountRole accountRole)
                       throws AccessSecurityWriteException,
                              DuplicateException
アカウントロール情報を新規追加する。

アカウントに紐付くアカウントロール情報を新規に追加します。

定義:
インタフェース AccountAccessor 内の insertAccountRole
パラメータ:
groupId - ログイングループID
userId - ユーザID
accountRole - アカウントロール情報
例外:
AccessSecurityWriteException - アカウントロール情報の作成に失敗した場合スローされます。
DuplicateException - 追加するアカウントロール情報が既に存在した場合スローされます。

insertFavoriteMenu

public void insertFavoriteMenu(String groupId,
                               String userId,
                               FavoriteMenu favoriteMenu)
                        throws AccessSecurityWriteException,
                               DuplicateException
マイメニュー情報を新規追加する。

アカウントに紐付くマイメニュー情報を新規に追加します。

定義:
インタフェース AccountAccessor 内の insertFavoriteMenu
パラメータ:
groupId - ログイングループID
userId - ユーザID
favoriteMenu - マイメニュー情報
例外:
AccessSecurityWriteException - マイメニュー情報の作成に失敗した場合スローされます。
DuplicateException - 追加するマイメニュー情報が既に存在した場合スローされます。

searchAccounts

public Account[] searchAccounts(String groupId,
                                String userId)
                         throws AccessSecurityReadException
アカウント情報の読み込みます。 ユーザIDまたはユーザIDの一部をキーとして検索し、マッチしたアカウント情報を返します。
ただし、以下の文字列を特殊文字列として扱う。
* 0以上の長さの文字列とマッチ
? 1文字の文字列とマッチ

定義:
インタフェース AccountAccessor 内の searchAccounts
パラメータ:
groupId - ログイングループID
userId - ユーザID（検索キー）
戻り値:
アカウント情報配列
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

updateAccount

public void updateAccount(String groupId,
                          Account account)
                   throws AccessSecurityWriteException,
                          NotExistException
アカウント情報を更新する。

定義:
インタフェース AccountAccessor 内の updateAccount
パラメータ:
groupId - ログイングループID
account - アカウント情報
例外:
AccessSecurityWriteException - アカウント情報の更新に失敗した場合スローされます。
NotExistException - 更新するアカウント情報が存在しない場合にスローされます。

updateAccountRole

public void updateAccountRole(String groupId,
                              String userId,
                              AccountRole accountRole)
                       throws AccessSecurityWriteException,
                              NotExistException
アカウントロール情報を更新する。

アカウントに紐付くアカウントロール情報を更新します。

定義:
インタフェース AccountAccessor 内の updateAccountRole
パラメータ:
groupId - ログイングループID
userId - ユーザID
accountRole - アカウントロール情報
例外:
AccessSecurityWriteException - アカウントロール情報の更新に失敗した場合スローされます。
NotExistException - 更新するアカウントロール情報が存在しない場合にスローされます。

updateFavoriteMenu

public void updateFavoriteMenu(String groupId,
                               String userId,
                               FavoriteMenu favoriteMenu)
                        throws AccessSecurityWriteException,
                               NotExistException
マイメニュー情報を更新する。

アカウントに紐付くマイメニュー情報を更新します。

定義:
インタフェース AccountAccessor 内の updateFavoriteMenu
パラメータ:
groupId - ログイングループID
userId - ユーザID
favoriteMenu - マイメニュー情報
例外:
AccessSecurityWriteException - マイメニュー情報の更新に失敗した場合スローされます。
NotExistException - 更新するマイメニュー情報が存在しない場合にスローされます。

getAttribute

public String getAttribute(String groupId,
                           String userId,
                           String name)
                    throws AccessSecurityReadException
アカウント属性情報を取得する。

定義:
インタフェース AccountAccessor 内の getAttribute
パラメータ:
groupId - ログイングループID
userId - ユーザID
name - 属性名
戻り値:
アカウント属性値
存在しない場合は、nullを返却します。
例外:
AccessSecurityReadException - アカウント属性情報の取得に失敗した場合スローされます。

getAttributeNames

public String[] getAttributeNames(String groupId,
                                  String userId)
                           throws AccessSecurityReadException
アカウント属性名の一覧を取得する。

定義:
インタフェース AccountAccessor 内の getAttributeNames
パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
アカウント属性の名前の一覧
存在しない場合は空の配列を返却します。
例外:
AccessSecurityReadException - アカウント属性情報の取得に失敗した場合スローされます。

setAttribute

public void setAttribute(String groupId,
                         String userId,
                         String name,
                         String value)
                  throws AccessSecurityWriteException
アカウント属性情報を設定する。
引数で指定した属性名に一致する属性情報が存在しない場合は、新規登録します。
引数で指定した属性名に一致する属性情報がすでに存在する場合は、指定された属性値で更新します。

定義:
インタフェース AccountAccessor 内の setAttribute
パラメータ:
groupId - ログイングループID
userId - ユーザID
name - 属性名
value - 属性値
例外:
AccessSecurityWriteException - アカウント情報の設定に失敗した場合スローされます。

deleteAttribute

public void deleteAttribute(String groupId,
                            String userId,
                            String name)
                     throws AccessSecurityWriteException,
                            NotExistException
アカウント属性情報を削除する。

定義:
インタフェース AccountAccessor 内の deleteAttribute
パラメータ:
groupId - ログイングループID
userId - ユーザID
name - 属性名
例外:
AccessSecurityWriteException - アカウント属性情報の削除に失敗した場合スローされます。
NotExistException - 削除するアカウント情報が存在しない場合にスローされます。

getUserIdsByAttribute

public String[] getUserIdsByAttribute(String groupId,
                                      String key,
                                      String value)
                               throws AccessSecurityReadException
アカウント属性情報の値と一致するユーザIDを取得する。

定義:
インタフェース AccountAccessor 内の getUserIdsByAttribute
パラメータ:
groupId - ログイングループID
key - 検索対象の属性キー名
value - 検索値
戻り値:
ユーザIDの一覧
存在しない場合は空の配列を返却します。
例外:
AccessSecurityReadException - アカウント属性情報の取得に失敗した場合スローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardBatchAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス StandardBatchAccessor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.StandardBatchAccessor
すべての実装インタフェース:
BatchAccessor
public class StandardBatchAccessor
extends Object
implements BatchAccessor

バッチアクセッサクラス。

バッチ情報の読み込みおよび書き込みクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String | APPLICATION_NAME アプリケーション名
static String | ENTITY_NAME エンティティ名
コンストラクタの概要
StandardBatchAccessor()
コンストラクタ。
メソッドの概要
void | deleteBatch(String groupId, String batchId) バッチを削除します。
Batch | getBatch(String groupId, String batchId) バッチを取得します。
Batch[] | getBatches(String groupId) バッチの一覧を取得します。
Batch[] | getBatchesByIds(String groupId, String[] batchIds) 引数に指定したバッチIDのバッチ情報をすべて取得します。
String[] | getBatchIds(String groupId) バッチIDの一覧を取得します。
protected String | getLoginUser() ログインユーザを取得します。
void | init(Map params) 初期化します。
void | insertBatch(String groupId, Batch batch) バッチを登録します。
void | updateBatch(String groupId, Batch batch) バッチを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

APPLICATION_NAME

public static final String APPLICATION_NAME
アプリケーション名

関連項目:
定数フィールド値

ENTITY_NAME

public static final String ENTITY_NAME
エンティティ名

関連項目:
定数フィールド値
コンストラクタの詳細

StandardBatchAccessor

public StandardBatchAccessor()
コンストラクタ。

メソッドの詳細

getLoginUser

protected String getLoginUser()
ログインユーザを取得します。
ログインユーザの取得に失敗した場合は空文字列を返却します。

戻り値:
ログインユーザID

deleteBatch

public void deleteBatch(String groupId,
                        String batchId)
                 throws AccessSecurityWriteException,
                        NotExistException
バッチを削除します。

定義:
インタフェース BatchAccessor 内の deleteBatch
パラメータ:
groupId - グル－プID
batchId - バッチID
例外:
AccessSecurityWriteException - データの削除に失敗した場合にスローされます。
NotExistException - 削除対象のデータが存在しない場合スローされます。

getBatch

public Batch getBatch(String groupId,
                      String batchId)
               throws AccessSecurityReadException
バッチを取得します。

定義:
インタフェース BatchAccessor 内の getBatch
パラメータ:
groupId - グループID
batchId - バッチID
戻り値:
バッチ情報
例外:
AccessSecurityReadException - データの読み込みに失敗した場合にスローされます。

getBatches

public Batch[] getBatches(String groupId)
                   throws AccessSecurityReadException
バッチの一覧を取得します。

バッチIDで昇順でソートされたバッチの一覧を取得します。

定義:
インタフェース BatchAccessor 内の getBatches
パラメータ:
groupId - グループID
戻り値:
バッチ配列
例外:
AccessSecurityReadException - データの読み込みに失敗した場合にスローされます。

getBatchesByIds

public Batch[] getBatchesByIds(String groupId,
                               String[] batchIds)
                        throws AccessSecurityReadException
引数に指定したバッチIDのバッチ情報をすべて取得します。

引数に指定したバッチIDの順でソートされたバッチ情報を取得します。 一件も存在しない場合は、空の配列を返却します。

定義:
インタフェース BatchAccessor 内の getBatchesByIds
パラメータ:
groupId - ログイングループID
batchIds - バッチIDの配列
戻り値:
取得されたバッチの配列
例外:
AccessSecurityReadException - バッチ情報の取得に失敗した場合スローされます。

getBatchIds

public String[] getBatchIds(String groupId)
                     throws AccessSecurityReadException
バッチIDの一覧を取得します。

バッチIDで昇順でソートされたバッチIDの一覧を取得します。

定義:
インタフェース BatchAccessor 内の getBatchIds
パラメータ:
groupId - グループID
戻り値:
バッチID配列
例外:
AccessSecurityReadException - データの取得に失敗した場合にスローされます。

init

public void init(Map params)
初期化します。

定義:
インタフェース BatchAccessor 内の init
パラメータ:
params - 初期化パラメータ

insertBatch

public void insertBatch(String groupId,
                        Batch batch)
                 throws AccessSecurityWriteException,
                        DuplicateException
バッチを登録します。

定義:
インタフェース BatchAccessor 内の insertBatch
パラメータ:
groupId - バッチID
batch - バッチ情報
例外:
AccessSecurityWriteException - データの登録に失敗した場合にスローされます。
DuplicateException - キーが重複した場合にスローされます。

updateBatch

public void updateBatch(String groupId,
                        Batch batch)
                 throws AccessSecurityWriteException,
                        NotExistException
バッチを更新します。

定義:
インタフェース BatchAccessor 内の updateBatch
パラメータ:
groupId - グループID
batch - バッチ情報
例外:
AccessSecurityWriteException - データの更新に失敗した場合にスローされます。
NotExistException - 更新データがない場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardCalendarAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス StandardCalendarAccessor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.StandardCalendarAccessor
すべての実装インタフェース:
CalendarAccessor
public class StandardCalendarAccessor
extends Object
implements CalendarAccessor

カレンダーアクセッサクラス。

カレンダー情報の読み込みおよび書き込みクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String | APPLICATION_NAME アプリケーション名
static String | ENTITY_NAME エンティティ名
コンストラクタの概要
StandardCalendarAccessor()
コンストラクタ。
メソッドの概要
void | deleteCalendar(String groupId, String calendarId) カレンダーを削除します。
void | deleteCalendarInfo(String groupId, String calendarId, String dataId) 指定されたカレンダーデータを削除します。
String[] | getCalendarIds(String groupId) すべてのカレンダーIDを取得します。
CalendarInfo | getCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータを取得します。
String[] | getCalendarInfoIds(String groupId, String calendarId) すべてのカレンダーデータIDを取得します。
CalendarInfo[] | getCalendarInfos(String groupId, String calendarId) すべてのカレンダーデータを取得します。
CalendarInfo[] | getCalendarInfosByIds(String groupId, String calendarId, String[] calendarInfoIds) 指定されたカレンダーデータIDのカレンダー情報をすべて取得する。
protected String | getLoginUser() ログインユーザを取得します。
void | init(Map params) カレンダーアクセッサの初期化。
void | insertCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に作成します。
void | updateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

APPLICATION_NAME

public static final String APPLICATION_NAME
アプリケーション名

関連項目:
定数フィールド値

ENTITY_NAME

public static final String ENTITY_NAME
エンティティ名

関連項目:
定数フィールド値
コンストラクタの詳細

StandardCalendarAccessor

public StandardCalendarAccessor()
コンストラクタ。

メソッドの詳細

getLoginUser

protected String getLoginUser()
ログインユーザを取得します。
ログインユーザの取得に失敗した場合は空文字列を返却します。

戻り値:
ログインユーザID

deleteCalendar

public void deleteCalendar(String groupId,
                           String calendarId)
                    throws AccessSecurityWriteException,
                           NotExistException
カレンダーを削除します。

定義:
インタフェース CalendarAccessor 内の deleteCalendar
パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
例外:
AccessSecurityWriteException
NotExistException

deleteCalendarInfo

public void deleteCalendarInfo(String groupId,
                               String calendarId,
                               String dataId)
                        throws AccessSecurityWriteException,
                               NotExistException
指定されたカレンダーデータを削除します。

定義:
インタフェース CalendarAccessor 内の deleteCalendarInfo
パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
dataId - カレンダーデータID
例外:
AccessSecurityWriteException
NotExistException

getCalendarIds

public String[] getCalendarIds(String groupId)
                        throws AccessSecurityReadException
すべてのカレンダーIDを取得します。
カレンダーIDが存在しない場合は空の配列を返却します。

定義:
インタフェース CalendarAccessor 内の getCalendarIds
パラメータ:
groupId - ログイングループID
戻り値:
カレンダーIDの配列
例外:
AccessSecurityReadException

getCalendarInfo

public CalendarInfo getCalendarInfo(String groupId,
                                    String calendarId,
                                    String dataId)
                             throws AccessSecurityReadException
カレンダーデータを取得します。

定義:
インタフェース CalendarAccessor 内の getCalendarInfo
パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
dataId - カレンダーデータID
戻り値:
カレンダーデータ
例外:
AccessSecurityReadException

getCalendarInfoIds

public String[] getCalendarInfoIds(String groupId,
                                   String calendarId)
                            throws AccessSecurityReadException
すべてのカレンダーデータIDを取得します。

カレンダーデータIDが存在しない場合は空の配列を返却します。

定義:
インタフェース CalendarAccessor 内の getCalendarInfoIds
パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
戻り値:
カレンダーデータIDの配列
例外:
AccessSecurityReadException

getCalendarInfos

public CalendarInfo[] getCalendarInfos(String groupId,
                                       String calendarId)
                                throws AccessSecurityReadException
すべてのカレンダーデータを取得します。

カレンダーデータが存在しない場合は空の配列を返却します。

定義:
インタフェース CalendarAccessor 内の getCalendarInfos
パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
戻り値:
カレンダーデータの配列
例外:
AccessSecurityReadException

getCalendarInfosByIds

public CalendarInfo[] getCalendarInfosByIds(String groupId,
                                            String calendarId,
                                            String[] calendarInfoIds)
                                     throws AccessSecurityReadException
指定されたカレンダーデータIDのカレンダー情報をすべて取得する。

定義:
インタフェース CalendarAccessor 内の getCalendarInfosByIds
パラメータ:
groupId - ログイングループID
calendarId - カレンダーIDの配列
calendarInfoIds - カレンダーデータIDの配列
戻り値:
カレンダーオブジェクトの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - カレンダー情報取得に失敗した場合スローされます。

init

public void init(Map params)
カレンダーアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース CalendarAccessor 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

insertCalendarInfo

public void insertCalendarInfo(String groupId,
                               String calendarId,
                               CalendarInfo calendarInfo)
                        throws AccessSecurityWriteException,
                               DuplicateException
カレンダーデータを新規に作成します。

定義:
インタフェース CalendarAccessor 内の insertCalendarInfo
パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfo - カレンダーデータ
例外:
AccessSecurityWriteException
DuplicateException

updateCalendarInfo

public void updateCalendarInfo(String groupId,
                               String calendarId,
                               CalendarInfo calendarInfo)
                        throws AccessSecurityWriteException,
                               NotExistException
カレンダーデータを更新します。

定義:
インタフェース CalendarAccessor 内の updateCalendarInfo
パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfo - カレンダーデータ
例外:
AccessSecurityWriteException
NotExistException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardMenuAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス StandardMenuAccessor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.StandardMenuAccessor
すべての実装インタフェース:
MenuAccessor
public class StandardMenuAccessor
extends Object
implements MenuAccessor

メニューアクセッサクラス。

メニュー情報の読み込みおよび書き込みクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String | APPLICATION_NAME アプリケーション名
static String | ENTITY_NAME_MENU メニュー エンティティ名
static String | ENTITY_NAME_MENU_ARGUMENT メニュー引数 エンティティ名
static String | ENTITY_NAME_MENU_DEPARTMENT メニュー組織 エンティティ名
static String | ENTITY_NAME_MENU_POST メニュー役職 エンティティ名
static String | ENTITY_NAME_MENU_PUBLIC_GROUP メニューパブリックグループ エンティティ名
static String | ENTITY_NAME_MENU_ROLE メニューロール エンティティ名
コンストラクタの概要
StandardMenuAccessor()
コンストラクタ。
メソッドの概要
void | deleteMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を削除します。
void | deleteMenuDepartments(String groupId, String id) すべてのメニュー組織を削除します。
void | deleteMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を削除します。
void | deleteMenuItem(String groupId, String id) 引数で渡されたノードを削除します。
void | deleteMenuPost(String groupId, String id, PostInfo postInfo) メニュー役職を削除します。
void | deleteMenuPosts(String groupId, String id) すべてのメニュー役職を削除します。
void | deleteMenuPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) メニューパブリックグループを削除します。
void | deleteMenuPublicGroups(String groupId, String id) すべてのメニューパブリックグループを削除します。
void | deleteMenuRole(String groupId, String id, String roleId) メニューロールを削除します。
void | deleteMenuRoles(String groupId, String menuId) すべてのメニューロールを削除します。
String[] | getChildMenuIds(String groupId, String menuId) 引数で指定されたノードの直下の子メニューIDを配列で取得します。
String[] | getFirstMenuIds(String groupId) 第一階層に属するメニューIDを配列で取得します。
protected String | getLoginUser() ログインユーザを取得します。
DepartmentInfo[] | getMenuDepartments(String groupId, String id) すべてのメニュー組織を取得します。
String[] | getMenuIds(String groupId) すべてのメニューIDを取得します。
String[] | getMenuIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つメニューIDをすべて取得します。
String[] | getMenuIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つメニューIDをすべて取得します。
String[] | getMenuIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つメニューIDをすべて取得します。
String[] | getMenuIdsByRole(String groupId, String[] roleIds) 指定されたロールIDを持つメニューIDをすべて取得します。
MenuInclusion[] | getMenuInclusions(String groupId) すべてのメニュー構成を取得します。
MenuItem | getMenuItem(String groupId, String menuId) 指定されたメニューIDに対するノードを取得します。
MenuItem[] | getMenuItems(String groupId) すべてのノードを取得します。
MenuItem[] | getMenuItemsByIds(String groupId, String[] menuIds) 指定されたメニューIDのメニュー情報をすべて取得します。
PostInfo[] | getMenuPosts(String groupId, String id) すべてのメニュー役職を取得します。
PublicGroupInfo[] | getMenuPublicGroups(String groupId, String id) すべてのメニューパブリックグループを取得します。
String[] | getMenuRoles(String groupId, String menuId) すべてのメニューロールを取得します。
String | getParentMenuId(String groupId, String menuId) 引数で指定されたノードの親ノードを取得します。
void | init(Map params) メニューアクセッサの初期化。
void | insertMenuDepartment(String groupId, String menuId, DepartmentInfo departmentInfo) メニュー組織を新規に作成します。
void | insertMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を新規に作成します。
void | insertMenuItem(String groupId, MenuItem menuItem, String parentId) 引数で渡されたノードを新規追加します。
void | insertMenuPost(String groupId, String menuId, PostInfo postInfo) メニュー役職を新規に作成します。
void | insertMenuPublicGroup(String groupId, String menuId, PublicGroupInfo publicGroupInfo) メニューパブリックグループを新規に作成します。
void | insertMenuRole(String groupId, String menuId, String roleId) メニューロールを新規に作成します。
void | updateMenuItem(String groupId, MenuItem menuItem) 引数で渡されたノードを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

APPLICATION_NAME

public static final String APPLICATION_NAME
アプリケーション名

関連項目:
定数フィールド値

ENTITY_NAME_MENU

public static final String ENTITY_NAME_MENU
メニュー エンティティ名

関連項目:
定数フィールド値

ENTITY_NAME_MENU_ARGUMENT

public static final String ENTITY_NAME_MENU_ARGUMENT
メニュー引数 エンティティ名

関連項目:
定数フィールド値

ENTITY_NAME_MENU_DEPARTMENT

public static final String ENTITY_NAME_MENU_DEPARTMENT
メニュー組織 エンティティ名

関連項目:
定数フィールド値

ENTITY_NAME_MENU_POST

public static final String ENTITY_NAME_MENU_POST
メニュー役職 エンティティ名

関連項目:
定数フィールド値

ENTITY_NAME_MENU_PUBLIC_GROUP

public static final String ENTITY_NAME_MENU_PUBLIC_GROUP
メニューパブリックグループ エンティティ名

関連項目:
定数フィールド値

ENTITY_NAME_MENU_ROLE

public static final String ENTITY_NAME_MENU_ROLE
メニューロール エンティティ名

関連項目:
定数フィールド値
コンストラクタの詳細

StandardMenuAccessor

public StandardMenuAccessor()
コンストラクタ。

メソッドの詳細

getLoginUser

protected String getLoginUser()
ログインユーザを取得します。
ログインユーザの取得に失敗した場合は空文字列を返却します。

戻り値:
ログインユーザID

deleteMenuDepartment

public void deleteMenuDepartment(String groupId,
                                 String id,
                                 DepartmentInfo departmentInfo)
                          throws AccessSecurityWriteException,
                                 NotExistException
メニュー組織を削除します。

定義:
インタフェース MenuAccessor 内の deleteMenuDepartment
パラメータ:
groupId - ログイングループID
id - メニューID
departmentInfo - 組織情報
例外:
AccessSecurityWriteException - メニュー組織の削除に失敗した場合にスローされます。
NotExistException

deleteMenuDepartments

public void deleteMenuDepartments(String groupId,
                                  String id)
                           throws AccessSecurityWriteException
すべてのメニュー組織を削除します。

定義:
インタフェース MenuAccessor 内の deleteMenuDepartments
パラメータ:
groupId - ログイングループID
id - メニューID
例外:
AccessSecurityWriteException - メニュー組織の削除に失敗した場合にスローされます。

deleteMenuInclusion

public void deleteMenuInclusion(String groupId,
                                MenuInclusion menuInclusion)
                         throws AccessSecurityWriteException
メニュー構成を削除します。

定義:
インタフェース MenuAccessor 内の deleteMenuInclusion
パラメータ:
groupId - ログイングループID
menuInclusion - メニュー構成
例外:
AccessSecurityWriteException - メニュー構成の削除に失敗した場合にスローされます。

deleteMenuItem

public void deleteMenuItem(String groupId,
                           String id)
                    throws AccessSecurityWriteException
引数で渡されたノードを削除します。

定義:
インタフェース MenuAccessor 内の deleteMenuItem
パラメータ:
groupId - グループID
id - メニューID
例外:
AccessSecurityWriteException - メニューの削除に失敗した場合にスローされます。

deleteMenuPost

public void deleteMenuPost(String groupId,
                           String id,
                           PostInfo postInfo)
                    throws AccessSecurityWriteException
メニュー役職を削除します。

定義:
インタフェース MenuAccessor 内の deleteMenuPost
パラメータ:
groupId - ログイングループID
id - メニューID
postInfo - 役職情報
例外:
AccessSecurityWriteException - メニュー役職の削除に失敗した場合にスローされます。

deleteMenuPosts

public void deleteMenuPosts(String groupId,
                            String id)
                     throws AccessSecurityWriteException
すべてのメニュー役職を削除します。

定義:
インタフェース MenuAccessor 内の deleteMenuPosts
パラメータ:
groupId - ログイングループID
id - メニューID
例外:
AccessSecurityWriteException - メニュー役職の削除に失敗した場合にスローされます。

deleteMenuPublicGroup

public void deleteMenuPublicGroup(String groupId,
                                  String id,
                                  PublicGroupInfo publicGroupInfo)
                           throws AccessSecurityWriteException
メニューパブリックグループを削除します。

定義:
インタフェース MenuAccessor 内の deleteMenuPublicGroup
パラメータ:
groupId - ログイングループID
id - メニューID
publicGroupInfo - パブリックグループ情報
例外:
AccessSecurityWriteException - メニューパブリックグループの削除に失敗した場合にスローされます。

deleteMenuPublicGroups

public void deleteMenuPublicGroups(String groupId,
                                   String id)
                            throws AccessSecurityWriteException
すべてのメニューパブリックグループを削除します。

定義:
インタフェース MenuAccessor 内の deleteMenuPublicGroups
パラメータ:
groupId - ログイングループID
id - メニューID
例外:
AccessSecurityWriteException - メニューパブリックグループの削除に失敗した場合にスローされます。

deleteMenuRole

public void deleteMenuRole(String groupId,
                           String id,
                           String roleId)
                    throws AccessSecurityWriteException
メニューロールを削除します。

定義:
インタフェース MenuAccessor 内の deleteMenuRole
パラメータ:
groupId - ログイングループID
id - メニューID
roleId - ロールID
例外:
AccessSecurityWriteException - メニューロールの削除に失敗した場合にスローされます。

deleteMenuRoles

public void deleteMenuRoles(String groupId,
                            String menuId)
                     throws AccessSecurityWriteException
すべてのメニューロールを削除します。

定義:
インタフェース MenuAccessor 内の deleteMenuRoles
パラメータ:
groupId - ログイングループID
menuId - メニューID
例外:
AccessSecurityWriteException - メニューロールの削除に失敗した場合にスローされます。

getChildMenuIds

public String[] getChildMenuIds(String groupId,
                                String menuId)
                         throws AccessSecurityReadException
引数で指定されたノードの直下の子メニューIDを配列で取得します。

定義:
インタフェース MenuAccessor 内の getChildMenuIds
パラメータ:
groupId - グループID
menuId - メニューID
戻り値:
子メニューIDの配列
例外:
AccessSecurityReadException - メニューIDの取得に失敗した場合にスローされます。

getFirstMenuIds

public String[] getFirstMenuIds(String groupId)
                         throws AccessSecurityReadException
第一階層に属するメニューIDを配列で取得します。

定義:
インタフェース MenuAccessor 内の getFirstMenuIds
パラメータ:
groupId - グループID
戻り値:
第一階層に属するメニューIDの配列
例外:
AccessSecurityReadException - メニューIDの取得に失敗した場合にスローされます。

getMenuDepartments

public DepartmentInfo[] getMenuDepartments(String groupId,
                                           String id)
                                    throws AccessSecurityReadException
すべてのメニュー組織を取得します。

一件も存在しない場合は、空の配列を返却します。

定義:
インタフェース MenuAccessor 内の getMenuDepartments
パラメータ:
groupId - ログイングループID
id - メニューID
戻り値:
組織情報の配列
例外:
AccessSecurityReadException - メニュー組織の取得に失敗した場合にスローされます。

getMenuIds

public String[] getMenuIds(String groupId)
                    throws AccessSecurityReadException
すべてのメニューIDを取得します。

定義:
インタフェース MenuAccessor 内の getMenuIds
パラメータ:
groupId - グループID
戻り値:
メニューIDの配列
例外:
AccessSecurityReadException - メニューIDの取得に失敗した場合にスローされます。

getMenuIdsByDepartment

public String[] getMenuIdsByDepartment(String groupId,
                                       DepartmentInfo[] departments)
                                throws AccessSecurityReadException
指定された組織を持つメニューIDをすべて取得します。

定義:
インタフェース MenuAccessor 内の getMenuIdsByDepartment
パラメータ:
groupId - ログイングループID
departments - 組織情報の配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - メニュー情報取得に失敗した場合スローされます。

getMenuIdsByPost

public String[] getMenuIdsByPost(String groupId,
                                 PostInfo[] posts)
                          throws AccessSecurityReadException
指定された役職を持つメニューIDをすべて取得します。

定義:
インタフェース MenuAccessor 内の getMenuIdsByPost
パラメータ:
groupId - ログイングループID
posts - 役職情報の配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - メニュー情報取得に失敗した場合スローされます。

getMenuIdsByPublicGroup

public String[] getMenuIdsByPublicGroup(String groupId,
                                        PublicGroupInfo[] publicGroups)
                                 throws AccessSecurityReadException
指定されたパブリックグループを持つメニューIDをすべて取得します。

定義:
インタフェース MenuAccessor 内の getMenuIdsByPublicGroup
パラメータ:
groupId - ログイングループID
publicGroups - パブリックグループの配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - メニュー情報取得に失敗した場合スローされます。

getMenuIdsByRole

public String[] getMenuIdsByRole(String groupId,
                                 String[] roleIds)
                          throws AccessSecurityReadException
指定されたロールIDを持つメニューIDをすべて取得します。

定義:
インタフェース MenuAccessor 内の getMenuIdsByRole
パラメータ:
groupId - ログイングループID
roleIds - ロールIDの配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - メニュー情報取得に失敗した場合スローされます。

getMenuInclusions

public MenuInclusion[] getMenuInclusions(String groupId)
                                  throws AccessSecurityReadException
すべてのメニュー構成を取得します。

定義:
インタフェース MenuAccessor 内の getMenuInclusions
パラメータ:
groupId - ログイングループID
戻り値:
メニュー構成の配列
例外:
AccessSecurityReadException - メニュー構成の取得に失敗した場合にスローされます。

getMenuItem

public MenuItem getMenuItem(String groupId,
                            String menuId)
                     throws AccessSecurityReadException
指定されたメニューIDに対するノードを取得します。

定義:
インタフェース MenuAccessor 内の getMenuItem
パラメータ:
groupId - グループID
menuId - メニューID
戻り値:
ノード
例外:
AccessSecurityReadException - メニューIDの取得に失敗した場合にスローされます。

getMenuItems

public MenuItem[] getMenuItems(String groupId)
                        throws AccessSecurityReadException
すべてのノードを取得します。

定義:
インタフェース MenuAccessor 内の getMenuItems
パラメータ:
groupId - グループID
戻り値:
ノード配列
例外:
AccessSecurityReadException - メニューの取得に失敗した場合にスローされます。

getMenuItemsByIds

public MenuItem[] getMenuItemsByIds(String groupId,
                                    String[] menuIds)
                             throws AccessSecurityReadException
指定されたメニューIDのメニュー情報をすべて取得します。

定義:
インタフェース MenuAccessor 内の getMenuItemsByIds
パラメータ:
groupId - ログイングループID
menuIds - メニューIDの配列
戻り値:
メニューオブジェクトの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - メニュー情報取得に失敗した場合スローされます。

getMenuPosts

public PostInfo[] getMenuPosts(String groupId,
                               String id)
                        throws AccessSecurityReadException
すべてのメニュー役職を取得します。

一件も存在しない場合は、空の配列を返却します。

定義:
インタフェース MenuAccessor 内の getMenuPosts
パラメータ:
groupId - ログイングループID
id - メニューID
戻り値:
役職情報の配列
例外:
AccessSecurityReadException - メニュー役職の取得に失敗した場合にスローされます。

getMenuPublicGroups

public PublicGroupInfo[] getMenuPublicGroups(String groupId,
                                             String id)
                                      throws AccessSecurityReadException
すべてのメニューパブリックグループを取得します。

一件も存在しない場合は、空の配列を返却します。

定義:
インタフェース MenuAccessor 内の getMenuPublicGroups
パラメータ:
groupId - ログイングループID
id - メニューID
戻り値:
パブリックグループ情報の配列
例外:
AccessSecurityReadException - メニューパブリックグループの取得に失敗した場合にスローされます。

getMenuRoles

public String[] getMenuRoles(String groupId,
                             String menuId)
                      throws AccessSecurityReadException
すべてのメニューロールを取得します。

一件も存在しない場合は、空の配列を返却します。

定義:
インタフェース MenuAccessor 内の getMenuRoles
パラメータ:
groupId - ログイングループID
menuId - メニューID
戻り値:
メニューロールIDの配列
例外:
AccessSecurityReadException - メニューロールの取得に失敗した場合にスローされます。

getParentMenuId

public String getParentMenuId(String groupId,
                              String menuId)
                       throws AccessSecurityReadException
引数で指定されたノードの親ノードを取得します。

定義:
インタフェース MenuAccessor 内の getParentMenuId
パラメータ:
groupId - グループID
menuId - メニューID
戻り値:
親メニューID
例外:
AccessSecurityReadException - メニューIDの取得に失敗した場合にスローされます。

init

public void init(Map params)
メニューアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース MenuAccessor 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

insertMenuDepartment

public void insertMenuDepartment(String groupId,
                                 String menuId,
                                 DepartmentInfo departmentInfo)
                          throws AccessSecurityWriteException
メニュー組織を新規に作成します。

定義:
インタフェース MenuAccessor 内の insertMenuDepartment
パラメータ:
groupId - ログイングループID
menuId - メニューID
departmentInfo - 組織情報
例外:
AccessSecurityWriteException - メニュー組織の追加に失敗した場合にスローされます。

insertMenuInclusion

public void insertMenuInclusion(String groupId,
                                MenuInclusion menuInclusion)
                         throws AccessSecurityWriteException
メニュー構成を新規に作成します。

定義:
インタフェース MenuAccessor 内の insertMenuInclusion
パラメータ:
groupId - ログイングループID
menuInclusion - メニュー構成
例外:
AccessSecurityWriteException - メニュー構成の追加に失敗した場合にスローされます。

insertMenuItem

public void insertMenuItem(String groupId,
                           MenuItem menuItem,
                           String parentId)
                    throws AccessSecurityWriteException
引数で渡されたノードを新規追加します。

定義:
インタフェース MenuAccessor 内の insertMenuItem
パラメータ:
groupId - グループID
menuItem - メニューアイテム
parentId - 親メニューID
例外:
AccessSecurityWriteException - メニュ－の追加に失敗した場合にスローされます。

insertMenuPost

public void insertMenuPost(String groupId,
                           String menuId,
                           PostInfo postInfo)
                    throws AccessSecurityWriteException
メニュー役職を新規に作成します。

定義:
インタフェース MenuAccessor 内の insertMenuPost
パラメータ:
groupId - ログイングループID
menuId - メニューID
postInfo - 役職情報
例外:
AccessSecurityWriteException - メニュ－役職の追加に失敗した場合にスローされます。

insertMenuPublicGroup

public void insertMenuPublicGroup(String groupId,
                                  String menuId,
                                  PublicGroupInfo publicGroupInfo)
                           throws AccessSecurityWriteException
メニューパブリックグループを新規に作成します。

定義:
インタフェース MenuAccessor 内の insertMenuPublicGroup
パラメータ:
groupId - ログイングループID
menuId - メニューID
publicGroupInfo - パブリックグループ情報
例外:
AccessSecurityWriteException - メニュ－パブリックグループの追加に失敗した場合にスローされます。

insertMenuRole

public void insertMenuRole(String groupId,
                           String menuId,
                           String roleId)
                    throws AccessSecurityWriteException
メニューロールを新規に作成します。

定義:
インタフェース MenuAccessor 内の insertMenuRole
パラメータ:
groupId - ログイングループID
menuId - メニューID
roleId - ロールID
例外:
AccessSecurityWriteException - メニュ－ロールの追加に失敗した場合にスローされます。

updateMenuItem

public void updateMenuItem(String groupId,
                           MenuItem menuItem)
                    throws AccessSecurityWriteException
引数で渡されたノードを更新します。

定義:
インタフェース MenuAccessor 内の updateMenuItem
パラメータ:
groupId - グループID
menuItem - メニューアイテム
例外:
AccessSecurityWriteException - メニュ－の更新に失敗した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardRoleAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス StandardRoleAccessor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.StandardRoleAccessor
すべての実装インタフェース:
RoleAccessor
public class StandardRoleAccessor
extends Object
implements RoleAccessor

ロールアクセッサクラス。

ロール情報の読み込みおよび書き込みを行うクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String | APPLICATION_NAME
static String | ENTITY_NAME_ROLE
static String | ENTITY_NAME_ROLE_INCLUSION
static String | ENTITY_NAME_ROLE_SUMMARY
static String | KIND_ROLE 種別 ロール。
static String | KIND_ROLE_SUB 種別 サブロール(ロール)。
コンストラクタの概要
StandardRoleAccessor()
コンストラクタ
メソッドの概要
void | createRole(String groupId, Role role) ロール情報を新規追加します。
void | deleteCategory(String groupId) すべてのカテゴリを削除します。
void | deleteCategory(String groupId, String category) カテゴリを削除します。
void | deleteRole(String groupId) すべてのロール情報を削除します。
void | deleteRole(String groupId, String roleId) ロール情報を削除します。
void | deleteSubRole(String groupId, String roleId) サブロールIDを削除します。
void | deleteSubRole(String groupId, String roleId, String subRoleId) 指定したサブロールIDを削除します。
String[] | getAllParentRoleIds(String groupId, String roleId) すべての親ロールの一覧を取得します。
String[] | getAllSubRoleIds(String groupId, String roleId) すべてのサブロールの一覧を取得します。
String[] | getCategories(String groupId) カテゴリの一覧を取得します。
protected String | getLoginUser() ログインユーザを取得します。
String[] | getParentRoleIds(String groupId, String roleId) 親ロールの一覧を取得します。
Role[] | getRoleData(String groupId) ロール情報を全件取得します。
Role | getRoleData(String groupId, String roleId) ロール情報を取得します。
Role[] | getRoleDataByCategory(String groupId, String category) カテゴリからロール情報を取得します。
Role[] | getRolesByIds(String groupId, String[] roleIds) 指定されたロールIDのロール情報をすべて取得します。
String[] | getSubRoleIds(String groupId, String roleId) サブロールIDサマリを取得します。
void | init(Map params) ロールアクセッサの初期化。
void | insertSubRole(String groupId, String roleId, String subRoleId) サブロールを作成します。
void | updateCategory(String groupId, String oldCategory, String newCategory) カテゴリを更新します。
void | updateRole(String groupId, Role role) ロール情報を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

APPLICATION_NAME

public static final String APPLICATION_NAME
関連項目:
定数フィールド値

ENTITY_NAME_ROLE

public static final String ENTITY_NAME_ROLE
関連項目:
定数フィールド値

ENTITY_NAME_ROLE_INCLUSION

public static final String ENTITY_NAME_ROLE_INCLUSION
関連項目:
定数フィールド値

ENTITY_NAME_ROLE_SUMMARY

public static final String ENTITY_NAME_ROLE_SUMMARY
関連項目:
定数フィールド値

KIND_ROLE

public static final String KIND_ROLE
種別 ロール。

関連項目:
定数フィールド値

KIND_ROLE_SUB

public static final String KIND_ROLE_SUB
種別 サブロール(ロール)。

関連項目:
定数フィールド値
コンストラクタの詳細

StandardRoleAccessor

public StandardRoleAccessor()
コンストラクタ

メソッドの詳細

getLoginUser

protected String getLoginUser()
ログインユーザを取得します。
ログインユーザの取得に失敗した場合は空文字列を返却します。

戻り値:
ログインユーザID

createRole

public void createRole(String groupId,
                       Role role)
                throws AccessSecurityWriteException
ロール情報を新規追加します。

定義:
インタフェース RoleAccessor 内の createRole
パラメータ:
groupId - ログイングループID
role - ロール情報
例外:
AccessSecurityWriteException - ロール情報の作成に失敗した場合にスローされます。

deleteCategory

public void deleteCategory(String groupId)
                    throws AccessSecurityWriteException
すべてのカテゴリを削除します。

定義:
インタフェース RoleAccessor 内の deleteCategory
パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException - カテゴリの削除に失敗した場合にスローされます。

deleteCategory

public void deleteCategory(String groupId,
                           String category)
                    throws AccessSecurityWriteException
カテゴリを削除します。

定義:
インタフェース RoleAccessor 内の deleteCategory
パラメータ:
groupId - ログイングループID
category - カテゴリ名
例外:
AccessSecurityWriteException - カテゴリの削除に失敗した場合にスローされます。

deleteRole

public void deleteRole(String groupId)
                throws AccessSecurityWriteException
すべてのロール情報を削除します。

定義:
インタフェース RoleAccessor 内の deleteRole
パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException - ロール情報の削除に失敗した場合にスローされます。

deleteRole

public void deleteRole(String groupId,
                       String roleId)
                throws AccessSecurityWriteException
ロール情報を削除します。

定義:
インタフェース RoleAccessor 内の deleteRole
パラメータ:
groupId - ログイングループID
roleId - ロール情ID
例外:
AccessSecurityWriteException - ロール情報の削除に失敗した場合にスローされます。

deleteSubRole

public void deleteSubRole(String groupId,
                          String roleId)
                   throws AccessSecurityWriteException
サブロールIDを削除します。

定義:
インタフェース RoleAccessor 内の deleteSubRole
パラメータ:
groupId - ログイングループID
roleId - ロールID
例外:
AccessSecurityWriteException - ロール情報の更新に失敗した場合にスローされます。

deleteSubRole

public void deleteSubRole(String groupId,
                          String roleId,
                          String subRoleId)
                   throws AccessSecurityWriteException
指定したサブロールIDを削除します。

定義:
インタフェース RoleAccessor 内の deleteSubRole
パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 削除するサブロールID
例外:
AccessSecurityWriteException - ロール情報の更新に失敗した場合にスローされます。

getAllParentRoleIds

public String[] getAllParentRoleIds(String groupId,
                                    String roleId)
                             throws AccessSecurityReadException
すべての親ロールの一覧を取得します。

引数に指定したロールの上位階層にあるすべての親ロールを取得します。
親ロールが一件も存在しない場合空の配列を返却します。

定義:
インタフェース RoleAccessor 内の getAllParentRoleIds
パラメータ:
groupId - ログイングループID
roleId - ロールID
戻り値:
すべての親ロールIDの配列
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getAllSubRoleIds

public String[] getAllSubRoleIds(String groupId,
                                 String roleId)
                          throws AccessSecurityReadException
すべてのサブロールの一覧を取得します。

引数に指定したロールの下位階層にあるすべてのサブロールを取得します。
サブロールが一件も存在しない場合空の配列を返却します。

定義:
インタフェース RoleAccessor 内の getAllSubRoleIds
パラメータ:
groupId - ログイングループID
roleId - ロールID
戻り値:
すべてのサブロールIDの配列
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getCategories

public String[] getCategories(String groupId)
                       throws AccessSecurityReadException
カテゴリの一覧を取得します。

指定したログイングループに属するカテゴリが存在しない場合は空の配列を返却します。

定義:
インタフェース RoleAccessor 内の getCategories
パラメータ:
groupId - ログイングループID
戻り値:
カテゴリ名の配列
例外:
AccessSecurityReadException - カテゴリの取得に失敗した場合にスローされます。

getParentRoleIds

public String[] getParentRoleIds(String groupId,
                                 String roleId)
                          throws AccessSecurityReadException
親ロールの一覧を取得します。

引数に指定したロールの１階層上位にあるすべての親ロールを取得します。
親ロールが一件も存在しない場合空の配列を返却します。

定義:
インタフェース RoleAccessor 内の getParentRoleIds
パラメータ:
groupId - ログイングループID
roleId - ロールID
戻り値:
親ロールIDの配列
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getRoleData

public Role[] getRoleData(String groupId)
                   throws AccessSecurityReadException
ロール情報を全件取得します。

指定されたログイングループに属するロールが存在しない場合は空の配列を返却します。

定義:
インタフェース RoleAccessor 内の getRoleData
パラメータ:
groupId - ログイングループID
戻り値:
ロール情報の配列
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getRoleData

public Role getRoleData(String groupId,
                        String roleId)
                 throws AccessSecurityReadException
ロール情報を取得します。

指定されたロールIDをもつロールが存在しない場合はnullを返します。

定義:
インタフェース RoleAccessor 内の getRoleData
パラメータ:
groupId - ログイングループID
roleId - ロールID
戻り値:
ロールデータ
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getRoleDataByCategory

public Role[] getRoleDataByCategory(String groupId,
                                    String category)
                             throws AccessSecurityReadException
カテゴリからロール情報を取得します。

指定されたカテゴリに属するロール情報を取得します。
指定したカテゴリーに属するロールが存在しない場合は空の配列を返却します。

定義:
インタフェース RoleAccessor 内の getRoleDataByCategory
パラメータ:
groupId - ログイングループID
category - カテゴリ名
戻り値:
ロール情報の配列
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getRolesByIds

public Role[] getRolesByIds(String groupId,
                            String[] roleIds)
                     throws AccessSecurityReadException
指定されたロールIDのロール情報をすべて取得します。

定義:
インタフェース RoleAccessor 内の getRolesByIds
パラメータ:
groupId - ログイングループID
roleIds - ロールIDの配列
戻り値:
ロールオブジェクトの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - ロール情報取得に失敗した場合スローされます。

getSubRoleIds

public String[] getSubRoleIds(String groupId,
                              String roleId)
                       throws AccessSecurityReadException
サブロールIDサマリを取得します。

定義:
インタフェース RoleAccessor 内の getSubRoleIds
パラメータ:
groupId - ログイングループID
roleId - ロールID
戻り値:
String[] サブロールID
例外:
AccessSecurityWriteException - ロール情報の更新に失敗した場合にスローされます。
AccessSecurityReadException

init

public void init(Map params)
ロールアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース RoleAccessor 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

insertSubRole

public void insertSubRole(String groupId,
                          String roleId,
                          String subRoleId)
                   throws AccessSecurityWriteException
サブロールを作成します。

定義:
インタフェース RoleAccessor 内の insertSubRole
パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 追加するサブロールID
例外:
AccessSecurityWriteException - ロール情報の更新に失敗した場合にスローされます。

updateCategory

public void updateCategory(String groupId,
                           String oldCategory,
                           String newCategory)
                    throws AccessSecurityWriteException
カテゴリを更新します。

旧カテゴリ名を新カテゴリ名に更新します。

定義:
インタフェース RoleAccessor 内の updateCategory
パラメータ:
groupId - ログイングループID
oldCategory - 旧カテゴリ名
newCategory - 新カテゴリ名
例外:
AccessSecurityWriteException - カテゴリの更新に失敗した場合にスローされます。

updateRole

public void updateRole(String groupId,
                       Role role)
                throws AccessSecurityWriteException
ロール情報を更新します。

定義:
インタフェース RoleAccessor 内の updateRole
パラメータ:
groupId - ログイングループID
role - ロール情報
例外:
AccessSecurityWriteException - ロール情報の更新に失敗した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SystemManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス SystemManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.SystemManager
public class SystemManager
extends Object

システムマネージャクラス。 システムで共通に使用する以下の情報を取得します。

  • システムで対応しているロケール情報
  • システムで対応しているクライアント情報
  • システムで対応しているカラーパターン情報

    • また、システム管理者情報の操作を行います。

    導入されたバージョン:
    5.0
    バージョン:
    1.0

    メソッドの概要
void | addSuperUser(SuperUser superUser) システム管理者情報を新規に作成します。
static void | clearInstance() システムマネージャのインスタンスを初期化を行います。
ClientTypeInfo | getClientType(Locale reqLocale, String clientType) 指定ロケールでクライアントタイプ情報を取得します。
ClientTypeInfo[] | getClientTypes(Locale reqLocale) 指定ロケールでクライアントタイプ情報の一覧を取得します。
ColorPatternInfo | getColorPattern(Locale reqLocale, String colorPatternId) 指定ロケールでカラーパターン情報を取得します。
ColorPatternInfo[] | getColorPatterns(Locale reqLocale) 指定ロケールでカラーパターン情報の一覧を取得します。
String | getDefaultClientType() システムのデフォルトクライアントタイプを取得します。
String | getDefaultColorPatternId() デフォルトカラーパターンIDを取得します。
String | getDefaultEncoding(Locale reqLocale) ロケールに対応するデフォルトエンコーディングを取得します。
Locale | getDefaultLocale() デフォルトロケールを取得します。
static SystemManager | getInstance() システムマネージャインスタンスを生成します。
LocaleInfo | getLocale(Locale reqLocale, Locale locale) 指定ロケールでロケール情報を取得します。
LocaleInfo[] | getLocales(Locale reqLocale) 指定ロケールでロケール情報の一覧を取得します。
SuperUser | getSuperUser() システム管理者情報を取得します。
Date | getSystemMaxDate() 最大の未来日を取得します。
MenuItem[] | getSystemMenu() システムメニューを取得します。
Date | getSystemMinDate() 最大の過去日を取得します。
static void | setSorucePovider(SystemSourceProvider provider) ソースプロバイダを設定します。
void | updateSuperUser(SuperUser superUser) システム管理者情報を更新します。
    クラス java.lang.Object から継承したメソッド
    clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    メソッドの詳細

    clearInstance

    public static void clearInstance()
    システムマネージャのインスタンスを初期化を行います。

    システム設定ファイルおよびアクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

    システム設定ファイルは(system.xml)は、サーバマネージャルート/confに存在します。 アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。 通常、このメソッドを使用する必要はありません。

    setSorucePovider

    public static void setSorucePovider(SystemSourceProvider provider)
                             throws AccessSecurityException
    ソースプロバイダを設定します。

    システム設定ファイルを提供するプロバイダを設定します。

    通常、このメソッドを使用する必要はありません。

    パラメータ:
    provider - ソースプロバイダ
    例外:
    AccessSecurityException - 引数が不正だった場合にスローされます。

    getInstance

    public static SystemManager getInstance()
    システムマネージャインスタンスを生成します。

    戻り値:
    システムマネージャインスタンス

    addSuperUser

    public void addSuperUser(SuperUser superUser)
                  throws AccessSecurityException
    システム管理者情報を新規に作成します。

    パラメータ:
    superUser - システム管理者情報
    例外:
    AccessSecurityException - システム管理者情報が作成できなかった場合、または引数が不正だった場合にスローされます。

    getClientType

    public ClientTypeInfo getClientType(Locale reqLocale,
                                    String clientType)
                             throws AccessSecurityException
    指定ロケールでクライアントタイプ情報を取得します。

    存在しない指定ロケールおよびクライアントタイプが指定された場合はデフォルトのクライアントタイプ情報を返却します。

    パラメータ:
    reqLocale - 指定ロケール
    clientType - クライアントタイプ
    戻り値:
    クライアントタイプ情報
    例外:
    AccessSecurityException - 引数が不正だった場合にスローされます。

    getClientTypes

    public ClientTypeInfo[] getClientTypes(Locale reqLocale)
                                throws AccessSecurityException
    指定ロケールでクライアントタイプ情報の一覧を取得します。

    存在しない指定ロケールが指定された場合はデフォルトのクライアントタイプ情報の配列を返却します。

    パラメータ:
    reqLocale - 指定ロケール
    戻り値:
    クライアントタイプ情報の配列
    例外:
    AccessSecurityException - 引数が不正だった場合にスローされます。

    getColorPattern

    public ColorPatternInfo getColorPattern(Locale reqLocale,
                                        String colorPatternId)
                                 throws AccessSecurityException
    指定ロケールでカラーパターン情報を取得します。

    存在しない指定ロケールおよびカラーパターンIDが指定された場合はデフォルトのカラーパターン情報を返却します。

    パラメータ:
    reqLocale - 指定ロケール
    colorPatternId - カラーパターンID
    戻り値:
    カラーパターン情報。
    例外:
    AccessSecurityException - 引数が不正だった場合にスローされます。

    getColorPatterns

    public ColorPatternInfo[] getColorPatterns(Locale reqLocale)
                                    throws AccessSecurityException
    指定ロケールでカラーパターン情報の一覧を取得します。

    存在しない指定ロケールが指定された場合はデフォルトのカラーパターン情報の配列を返却します。

    パラメータ:
    reqLocale - 指定ロケール
    戻り値:
    カラーパターン情報の配列。
    例外:
    AccessSecurityException - 引数が不正だった場合にスローされます。

    getDefaultClientType

    public String getDefaultClientType()
    システムのデフォルトクライアントタイプを取得します。

    戻り値:
    デフォルトクライアントタイプ

    getDefaultColorPatternId

    public String getDefaultColorPatternId()
    デフォルトカラーパターンIDを取得します。

    戻り値:
    デフォルトカラーパターンID。

    getDefaultEncoding

    public String getDefaultEncoding(Locale reqLocale)
                          throws AccessSecurityException
    ロケールに対応するデフォルトエンコーディングを取得します。

    パラメータ:
    reqLocale - 指定ロケール
    戻り値:
    デフォルトエンコーディング
    例外:
    AccessSecurityException - 引数が不正だった場合にスローされます。

    getDefaultLocale

    public Locale getDefaultLocale()
    デフォルトロケールを取得します。

    戻り値:
    デフォルトロケール

    getLocale

    public LocaleInfo getLocale(Locale reqLocale,
                            Locale locale)
                     throws AccessSecurityException
    指定ロケールでロケール情報を取得します。

    存在しない指定ロケールおよび取得ロケールが指定された場合はデフォルトのロケール情報を返却します。

    パラメータ:
    reqLocale - 指定ロケール
    locale - 取得ロケール
    戻り値:
    ロケール情報
    例外:
    AccessSecurityException - 引数が不正だった場合にスローされます。

    getLocales

    public LocaleInfo[] getLocales(Locale reqLocale)
                        throws AccessSecurityException
    指定ロケールでロケール情報の一覧を取得します。

    存在しない指定ロケールが指定された場合はデフォルトのロケール情報の配列を返却します。

    パラメータ:
    reqLocale - 指定ロケール
    戻り値:
    ロケール情報の配列
    例外:
    AccessSecurityException - 引数が不正だった場合にスローされます。

    getSuperUser

    public SuperUser getSuperUser()
                       throws AccessSecurityException
    システム管理者情報を取得します。

    システム管理者の情報モデルを取得します。

    戻り値:
    システム管理者の情報モデル
    例外:
    AccessSecurityReadException - システム管理者情報が取得できなかった場合にスローされます。
    AccessSecurityException

    updateSuperUser

    public void updateSuperUser(SuperUser superUser)
                     throws AccessSecurityException
    システム管理者情報を更新します。

    パラメータ:
    superUser - システム管理者の情報モデル
    例外:
    AccessSecurityException - システム管理者情報が更新できなかった場合にスローされます。

    getSystemMenu

    public MenuItem[] getSystemMenu()
    システムメニューを取得します。

    戻り値:
    システムメニューの配列

    getSystemMinDate

    public Date getSystemMinDate()
    最大の過去日を取得します。

    システムで取り扱う最大過去日を返却します。

    戻り値:
    システムで取り扱う最大過去日

    getSystemMaxDate

    public Date getSystemMaxDate()
    最大の未来日を取得します。

    システムで取り扱う最大未来日を返却します。

    戻り値:
    システムで取り扱う最大未来日
    概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
            intra-mart 6.1.14
    前のクラス 次のクラス | フレームあり フレームなし
    概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SystemSourceProvider (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース SystemSourceProvider

public interface SystemSourceProvider

ロケール情報取得インターフェース。

設定ファイルからロケール情報を取得するためのインターフェースを定義します

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
SystemManager

メソッドの概要
InputStream | getPropertyStreamAsClientType(Locale locale) プロパティファイル(クライアントタイプ)の内容取得。
InputStream | getPropertyStreamAsColor(Locale locale) プロパティファイル(カラーパターン)の内容取得。
InputStream | getPropertyStreamAsColorProperty(String colorId, Locale locale) プロパティファイル(カラーパターン)の内容取得。
InputStream | getPropertyStreamAsLocale(Locale locale) プロパティファイル(ロケール)の内容取得。
InputStream | getStream() システム設定ファイルの内容取得。

メソッドの詳細

getPropertyStreamAsClientType

public InputStream getPropertyStreamAsClientType(Locale locale)
プロパティファイル(クライアントタイプ)の内容取得。
与えられた引数(ロケール)からプロパティファイルのストリームを返却する。
引数がnullの場合はデフォルトのプロパティファイルのストリームを返却する。

パラメータ:
locale - ロケール

getPropertyStreamAsColorProperty

public InputStream getPropertyStreamAsColorProperty(String colorId,
                                                    Locale locale)
プロパティファイル(カラーパターン)の内容取得。
与えられた引数(カラーパターンID、ロケール)からプロパティファイルのストリームを返却する 。
引数のロケールがnullの場合はデフォルトのカラーパターンIDのプロパティファイルのストリームを返却する。

パラメータ:
colorId - カラーパターンID
locale - ロケール

getPropertyStreamAsColor

public InputStream getPropertyStreamAsColor(Locale locale)
プロパティファイル(カラーパターン)の内容取得。
与えられた引数(ロケール)からカラーパターンプロパティファイルのストリームを返却する 。
引数のロケールがnullの場合はデフォルトのカラーパターンプロパティファイルのストリームを返却する。

パラメータ:
locale - ロケール

getPropertyStreamAsLocale

public InputStream getPropertyStreamAsLocale(Locale locale)
プロパティファイル(ロケール)の内容取得。
与えられた引数(ロケール)からプロパティファイルのストリームを返却する 。
引数がnullの場合はデフォルトのプロパティファイルのストリームを返却する。

パラメータ:
locale - ロケール

getStream

public InputStream getStream()
システム設定ファイルの内容取得。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler の使用

AccountSecurityHTTPActionEventFilterHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での AccountSecurityHTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application での AccountSecurityHTTPActionEventFilterHandler のサブクラス
 class PasswordSecurityHTTPActionEventFilterHandler
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler の使用

GroupSecurityHTTPActionEventFilterHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での GroupSecurityHTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application での GroupSecurityHTTPActionEventFilterHandler のサブクラス
class | AccountSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | PasswordSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent の使用

HTTPActionEventContent を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventContent の使用

HTTPActionEventContent を返す jp.co.intra_mart.foundation.service.client.application のメソッド
 HTTPActionEventContent HTTPActionEventURL.getContent()
HTTPActionEventURL.getURL() によって表されるコンテンツのソースを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler の使用

HTTPActionEventEntityHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventEntityHandler の使用

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventEntityHandler のサブクラス
class | ActivityHTTPActionEventHandler 持続したセッションを確立するためのハンドラです。
class | ConcreteHTTPActionEventHandler 任意の HTTPActionEvent を実行するためのハンドラです。
class | ServletHTTPActionEventHandler Web-Application を実行するためのイベントハンドラです。
class | WebApplicationHTTPActionEventHandler フレームワークを実行するためのイベントハンドラの抽象実装です。

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventEntityHandler の使用

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventEntityHandler のサブクラス
class | PresentationPageHTTPActionEventHandler スクリプト開発モデルのプレゼンテーションページを実行するためのハンドラです。
class | ServiceFrameworkHTTPActionEventHandler im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler の使用

HTTPActionEventFilterHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventFilterHandler のサブクラス
class | AccountSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | GroupSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | LimitedSessionHTTPActionEventFilterHandler セッションを一時利用のみに限定するためのフィルタです。
class | PasswordSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventFilterHandler のサブクラス
class | AccessibleLinkHTTPActionEventFilterHandler 再接続の為のＵＲＬを制御するフィルタ実装です。
class | ActivityFrameworkHTTPActionEventFilterHandler 推奨されていません。 このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler の使用

HTTPActionEventHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventHandler のサブクラス
class | AccountSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | ActivityHTTPActionEventHandler 持続したセッションを確立するためのハンドラです。
class | ConcreteHTTPActionEventHandler 任意の HTTPActionEvent を実行するためのハンドラです。
class | GroupSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | HTTPActionEventEntityHandler HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
class | HTTPActionEventFilterHandler HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
class | LimitedSessionHTTPActionEventFilterHandler セッションを一時利用のみに限定するためのフィルタです。
class | PasswordSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | ServletHTTPActionEventHandler Web-Application を実行するためのイベントハンドラです。
class | WebApplicationHTTPActionEventHandler フレームワークを実行するためのイベントハンドラの抽象実装です。

HTTPActionEventHandler を返す jp.co.intra_mart.foundation.service.client.application のメソッド
 HTTPActionEventHandler HTTPActionEventFilterHandler.getParent()
このオブジェクトがフィルタリングしているハンドラを返します。

HTTPActionEventHandler 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.application のメソッド
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

HTTPActionEventHandler 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.application のコンストラクタ
PasswordSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId, String accountId, String password)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
LimitedSessionHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
セッションを一時利用に限定するためのフィルタハンドラを作成します。
HTTPActionEventFilterHandler(HTTPActionEventHandler handler)
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラを作成します。
GroupSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId)
ログイングループセッション環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
AccountSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId, String accountId)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventHandler のサブクラス
class | AccessibleLinkHTTPActionEventFilterHandler 再接続の為のＵＲＬを制御するフィルタ実装です。
class | ActivityFrameworkHTTPActionEventFilterHandler 推奨されていません。 このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。
class | PresentationPageHTTPActionEventHandler スクリプト開発モデルのプレゼンテーションページを実行するためのハンドラです。
class | ServiceFrameworkHTTPActionEventHandler im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。

HTTPActionEventHandler 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.application.content のコンストラクタ
ActivityFrameworkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
推奨されていません。 フレームワークのセッション環境を作成するためのフィルタハンドラを作成します。
AccessibleLinkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
ＵＲＬを絶対形式に変換するためのフィルタハンドラを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException の使用

HTTPActionEventHandlerException を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventHandlerException の使用

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventHandlerException のサブクラス
 class HTTPActionEventHandlerParameterException
HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。

HTTPActionEventHandlerException をスローする jp.co.intra_mart.foundation.service.client.application のメソッド
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventResult | HTTPActionEventHandler.execute(String url) 指定された URL に接続して、 イベントの実行を要求します。
HTTPActionEventResult | HTTPActionEventHandler.execute(URL url) 指定された URL に接続して、 イベントの実行を要求します。
HTTPActionEventResult | HTTPActionEventHandler.execute(HttpURLConnection connection) 指定された URL コネクションを利用してにサーバに接続し、 イベントの実行を要求します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException の使用

HTTPActionEventHandlerParameterException を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventHandlerParameterException の使用

HTTPActionEventHandlerParameterException をスローする jp.co.intra_mart.foundation.service.client.application のメソッド
protected abstract Properties | WebApplicationHTTPActionEventHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected Properties | ServletHTTPActionEventHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected abstract Properties | HTTPActionEventHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected Properties | HTTPActionEventFilterHandler.getFilterParameterMap() このハンドラによって実行されるフィルタイベントに対する 設定済みパラメータのマップを返します。
protected Properties | HTTPActionEventFilterHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected Properties | HTTPActionEventEntityHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected Properties | ActivityHTTPActionEventHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventHandlerParameterException の使用

HTTPActionEventHandlerParameterException をスローする jp.co.intra_mart.foundation.service.client.application.content のメソッド
protected Properties | ServiceFrameworkHTTPActionEventHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected Properties | PresentationPageHTTPActionEventHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult の使用

HTTPActionEventResult を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventResult の使用

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventResult のサブインタフェース
interface | HTTPActionEventContent Web コンテンツを取得するための共通インターフェースです。
interface | HTTPActionEventURL Web コンテンツへのアクセスＵＲＬを取得するための共通インターフェースです。

HTTPActionEventResult を実装している jp.co.intra_mart.foundation.service.client.application のクラス
 class HTTPActionEventResultWrapper
HTTPActionEventResult のラッパーオブジェクトです。

HTTPActionEventResult を返す jp.co.intra_mart.foundation.service.client.application のメソッド
protected HTTPActionEventResult | HTTPActionEventResultWrapper.getParent() ラップしている親オブジェクトを返します。
HTTPActionEventResult | HTTPActionEventHandler.execute(String url) 指定された URL に接続して、 イベントの実行を要求します。
HTTPActionEventResult | HTTPActionEventHandler.execute(URL url) 指定された URL に接続して、 イベントの実行を要求します。
HTTPActionEventResult | HTTPActionEventHandler.execute(HttpURLConnection connection) 指定された URL コネクションを利用してにサーバに接続し、 イベントの実行を要求します。

HTTPActionEventResult 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.application のコンストラクタ
HTTPActionEventResultWrapper(HTTPActionEventResult parent)
指定の結果オブジェクトをラップする新しい結果オブジェクトを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper の使用

jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL の使用

HTTPActionEventURL を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventURL の使用

HTTPActionEventURL を返す jp.co.intra_mart.foundation.service.client.application のメソッド
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler の使用

ServletHTTPActionEventHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での ServletHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application での ServletHTTPActionEventHandler のサブクラス
 class ActivityHTTPActionEventHandler
持続したセッションを確立するためのハンドラです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の使用

WebApplicationHTTPActionEventHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での WebApplicationHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application での WebApplicationHTTPActionEventHandler のサブクラス
class | ActivityHTTPActionEventHandler 持続したセッションを確立するためのハンドラです。
class | ServletHTTPActionEventHandler Web-Application を実行するためのイベントハンドラです。

jp.co.intra_mart.foundation.service.client.application.content での WebApplicationHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.content での WebApplicationHTTPActionEventHandler のサブクラス
class | PresentationPageHTTPActionEventHandler スクリプト開発モデルのプレゼンテーションページを実行するためのハンドラです。
class | ServiceFrameworkHTTPActionEventHandler im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AccessibleLinkHTTPActionEventFilterHandler (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application.content
クラス AccessibleLinkHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler
public class AccessibleLinkHTTPActionEventFilterHandler
extends HTTPActionEventFilterHandler

再接続の為のＵＲＬを制御するフィルタ実装です。

このフィルタを利用する事で、同じセッション内でのその他のリクエストにおいて、 AbsoluteLinkFilter を経由した場合、全ての再接続リクエストのためのＵＲＬが 絶対形式の表現となります。
つまり、返される画面ソース(HTML)内の、 <FORM> の action 属性や、<A> の href 属性に指定する URL が、プロトコルおよびサーバアドレス等を含む絶対形式となります (javax.servlet.HttpServletResponse#encodeURL(java.lang.String) を利用して URL をエンコードしなかった場合は除く)。

これにより、例えばポータルサーバが別サイトとして運用されている場合においても、 各ポートレット内に配置されたリンクやフォームからシステムに直接アクセス できるようになります。

このフィルタは、サーバでの処理実行時に HttpSession が開始されていなかった場合、 HttpSession を新しく開始するように働きます。 それでもセッションを取得できなかった場合、将来の予期せぬエラーを防ぐため、 例外をスローしてサーバ処理をエラー終了します。 結果として、ハンドラの #execute() メソッドは、エラーを示す結果オブジェクトを 返す事になります。

導入されたバージョン:
version 4.3

コンストラクタの概要
AccessibleLinkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
ＵＲＬを絶対形式に変換するためのフィルタハンドラを作成します。
メソッドの概要
 String getName()
フィルタイベント名を返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AccessibleLinkHTTPActionEventFilterHandler

public AccessibleLinkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
ＵＲＬを絶対形式に変換するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventFilterHandler 内の getName
戻り値:
イベント名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ActivityFrameworkHTTPActionEventFilterHandler (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application.content
クラス ActivityFrameworkHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler
推奨されていません。 このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。

public class ActivityFrameworkHTTPActionEventFilterHandler
extends HTTPActionEventFilterHandler

サービスフレームワークおよびプレゼンテーションフレームワークの実行環境を作成するためのフィルタ実装です。

このフィルタを利用する場合、事前にログイン環境を作成しておく必要があります。 したがって、AccountSecurityHTTPActionEventFilterHandler も 併用するようにしてください。

導入されたバージョン:
version 4.3

コンストラクタの概要
ActivityFrameworkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
推奨されていません。 フレームワークのセッション環境を作成するためのフィルタハンドラを作成します。
メソッドの概要
 String getName()
推奨されていません。 フィルタイベント名を返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ActivityFrameworkHTTPActionEventFilterHandler

public ActivityFrameworkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
推奨されていません。
フレームワークのセッション環境を作成するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
推奨されていません。
フィルタイベント名を返します。

実際には、Application Runtime で実行される FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventFilterHandler 内の getName
戻り値:
イベント名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.client.application.content (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.service.client.application.content
クラス
AccessibleLinkHTTPActionEventFilterHandler
ActivityFrameworkHTTPActionEventFilterHandler
PresentationPageHTTPActionEventHandler
ServiceFrameworkHTTPActionEventHandler


jp.co.intra_mart.foundation.service.client.application.content (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.application.content

このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

参照:
説明

クラスの概要
AccessibleLinkHTTPActionEventFilterHandler | 再接続の為のＵＲＬを制御するフィルタ実装です。
ActivityFrameworkHTTPActionEventFilterHandler | 推奨されていません。 このフィルタは、何もしません。
PresentationPageHTTPActionEventHandler | スクリプト開発モデルのプレゼンテーションページを実行するためのハンドラです。
ServiceFrameworkHTTPActionEventHandler | im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。

パッケージ jp.co.intra_mart.foundation.service.client.application.content の説明

このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

導入されたバージョン:
version 4.0


jp.co.intra_mart.foundation.service.client.application.content クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.application.content の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
        • class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler


パッケージ jp.co.intra_mart.foundation.service.client.application.content の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client.application.content の使用

jp.co.intra_mart.foundation.service.client.application.content はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PresentationPageHTTPActionEventHandler (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application.content
クラス PresentationPageHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler
public class PresentationPageHTTPActionEventHandler
extends WebApplicationHTTPActionEventHandler

スクリプト開発モデルのプレゼンテーションページを実行するためのハンドラです。

このハンドラを利用する事により、指定のプレゼンテーションページを実行して、 画面ソースを取得する事ができます。
主にポータルサーバなどと連携してスクリプト開発モデルによる画面を １つのポートレットとして表示する場合に利用できます。 なお、 セッションタイムアウト後の 取得した画面ソース内のリンクやフォームによるリクエストは 無効となりますので注意してください。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected | PresentationPageHTTPActionEventHandler() ハンドラを作成します。
 | PresentationPageHTTPActionEventHandler(String path) ハンドラを作成します。
メソッドの概要
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
String | getName() イベント名を返します。
String | getPagePath() 設定されているページパスを返します。
protected void | setPagePath(String url) 実行するスクリプト開発モデルのページパスを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler から継承したメソッド
getQueryString, getURL, getURL, getURL, getURL, getURL, getURL
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PresentationPageHTTPActionEventHandler

protected PresentationPageHTTPActionEventHandler()
ハンドラを作成します。
このコンストラクタでは、必要な情報が設定されません。

実行するプレゼンテーションページのパスは、 setPagePath(String) で設定してください。

PresentationPageHTTPActionEventHandler

public PresentationPageHTTPActionEventHandler(String path)
ハンドラを作成します。
引数 path には、実行するプレゼンテーションページのパスを設定してください。

パラメータ:
path - スクリプト開発モデルのプログラムパス
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getName
戻り値:
イベント名

setPagePath

protected void setPagePath(String url)
実行するスクリプト開発モデルのページパスを設定します。

ページパスは、Resource Service のスクリプト開発モデルの プログラムルート（標準では pages/）からの相対パス指定になります。

パラメータ:
url - 接続ＵＲＬ

getPagePath

public String getPagePath()
設定されているページパスを返します。

戻り値:
ページパス

getEventRequestParameterMap

protected Properties getEventRequestParameterMap()
                                          throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServiceFrameworkHTTPActionEventHandler (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application.content
クラス ServiceFrameworkHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler
public class ServiceFrameworkHTTPActionEventHandler
extends WebApplicationHTTPActionEventHandler

im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。

このハンドラを利用する事により、指定のサービスフレームワークを実行して、 画面のソースを取得する事ができます。
主にポータルサーバなどと連携してサービスフレームワークによる画面を １つのポートレットとして表示する場合に利用できます。

なお、 セッションタイムアウト後の 取得した画面ソース内のリンクやフォームによるリクエストは 無効となりますので注意してください。

このクラスは、プレゼンテーションフレームワークに必要な各引数値に関する 共通インターフェースを提供しているだけの抽象実装です。 したがって、このクラスを単独で使用しても正しい結果を得る事はできません。 サブクラスを作成して、適切な実装を追加しなければいけません。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected | ServiceFrameworkHTTPActionEventHandler() サービスフレームワークを実行するためのハンドラを作成します。
 | ServiceFrameworkHTTPActionEventHandler(String application, String service) サービスフレームワークを実行するためのハンドラを作成します。
メソッドの概要
String | getApplication() 設定されているアプリケーションＩＤを返します。
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
String | getName() イベント名を返します。
String | getService() 設定されているサービスＩＤを返します。
protected void | setApplication(String id) 実行するフレームワークのアプリケーションＩＤを設定します。
protected void | setService(String id) 実行するフレームワークのサービスＩＤを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler から継承したメソッド
getQueryString, getURL, getURL, getURL, getURL, getURL, getURL
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ServiceFrameworkHTTPActionEventHandler

protected ServiceFrameworkHTTPActionEventHandler()
サービスフレームワークを実行するためのハンドラを作成します。

このコンストラクタでは、特に設定を行いません。 イベント実行要求前に、必要な情報の設定を行ってください。

ServiceFrameworkHTTPActionEventHandler

public ServiceFrameworkHTTPActionEventHandler(String application,
                                              String service)
サービスフレームワークを実行するためのハンドラを作成します。

このコンストラクタでは、特に設定を行いません。 イベント実行要求前に、必要な情報の設定を行ってください。

パラメータ:
application - アプリケーションＩＤ
service - サービスＩＤ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getName
戻り値:
イベント名

setApplication

protected void setApplication(String id)
実行するフレームワークのアプリケーションＩＤを設定します。

パラメータ:
id - アプリケーションＩＤ
例外:
NullPointerException - 引数が null の場合

getApplication

public String getApplication()
設定されているアプリケーションＩＤを返します。

戻り値:
アプリケーションＩＤ

setService

protected void setService(String id)
実行するフレームワークのサービスＩＤを設定します。

パラメータ:
id - サービスＩＤ
例外:
NullPointerException - 引数が null の場合

getService

public String getService()
設定されているサービスＩＤを返します。

戻り値:
サービスＩＤ

getEventRequestParameterMap

protected Properties getEventRequestParameterMap()
                                          throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccountSecurityHTTPActionEventFilterHandler (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス AccountSecurityHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
直系の既知のサブクラス:
PasswordSecurityHTTPActionEventFilterHandler
public class AccountSecurityHTTPActionEventFilterHandler
extends GroupSecurityHTTPActionEventFilterHandler

ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

このフィルタを利用する事により、任意のログイングループ内の任意のアカウントで ログインした状態の環境を作る事ができます。 ログイン環境でイベントを動作させる事により、 イベントプログラム中でログインセッションを必要とするＡＰＩを 利用可能になります。

このフィルタを利用する場合は、 必ずログイン環境を作れるアカウントを作成しておく必要があります。 実在しないアカウントを指定した場合、 未来の予測できないエラーを回避するために、 フィルタ処理の途中で即座に例外がスローされてます。 結果として、イベント実行はエラー終了します。
フィルタがエラー終了した場合、セキュリティホールとならないために セッションを破棄(javax.servlet.http.HttpSession#invalidate())します。 したがって、認証前にセッションに保存した情報にはアクセスできなくなります。 認証エラー後にセッション内の情報が必要な場合は、 事前に取得して別な場所へ保管するなどの対策が必要です。

導入されたバージョン:
version 4.3

フィールドの概要
protected static String ID_SECURITY_ACCOUNT
クラス jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler から継承したフィールド
ID_SECURITY_GROUP
コンストラクタの概要
AccountSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId, String accountId)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
メソッドの概要
String | getAccount() 設定されているアカウントＩＤを返します。
String | getName() フィルタイベント名を返します。
protected void | setAccount(String accountId) アカウントＩＤを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler から継承したメソッド
getGroup, setGroup
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_SECURITY_ACCOUNT

protected static final String ID_SECURITY_ACCOUNT
関連項目:
定数フィールド値
コンストラクタの詳細

AccountSecurityHTTPActionEventFilterHandler

public AccountSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler,
                                                   String groupId,
                                                   String accountId)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
groupId - グループＩＤ
accountId - アカウントＩＤ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

オーバーライド:
クラス GroupSecurityHTTPActionEventFilterHandler 内の getName
戻り値:
イベント名

setAccount

protected void setAccount(String accountId)
アカウントＩＤを設定します。

パラメータ:
accountId - アカウントＩＤ

getAccount

public String getAccount()
設定されているアカウントＩＤを返します。

戻り値:
アカウントＩＤ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ActivityHTTPActionEventHandler (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス ActivityHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler
                    拡張 jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler
public class ActivityHTTPActionEventHandler
extends ServletHTTPActionEventHandler

持続したセッションを確立するためのハンドラです。

このハンドラを利用すると、結果として同一のセッションを維持したまま 他のハンドラでサーバに再接続するためのＵＲＬを取得する事ができます。
セッションとは、HTTP セッションであり、 セッションを維持する事によりイベントは javax.servlet.http.HttpSession を 通してセッションデータを共有する事ができます。

複数のハンドラを利用して、同一のセッションでいくつかのイベントを 実行する必要がある場合、まずこのハンドラを利用して セッションを維持しながらイベント実行を要求できるＵＲＬを 取得してください。

このハンドラは、セッションを維持する事を目的としているため、 LimitedSessionHTTPActionEventFilterHandler と併用しても 意味がありません。
また、取得されたＵＲＬを利用する事により維持されたセッションに アクセスする事になるため、毎回ログインセッション環境を作る事も 意味を持ちません。ログインセッション環境を利用する場合は、 このハンドラを実行するときに AccountSecurityHTTPActionEventFilterHandler と併用して環境を作成してしまう方法が最も効率的です。 一度ログインセッション環境を作成してしまえば、以後の呼び出しでは ログイン環境を作成するためのフィルタを利用する必要はありません。

導入されたバージョン:
version 4.3

コンストラクタの概要
ActivityHTTPActionEventHandler()
新しいイベントハンドラを作成します。
ActivityHTTPActionEventHandler(String url)
指定のＵＲＬに再接続するための新しいイベントハンドラを作成します。
メソッドの概要
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
String | getName() イベント名を返します。
クラス jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler から継承したメソッド
getLocation, setLocation
クラス jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler から継承したメソッド
getQueryString, getURL, getURL, getURL, getURL, getURL, getURL
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ActivityHTTPActionEventHandler

public ActivityHTTPActionEventHandler()
新しいイベントハンドラを作成します。

このコンストラクタを利用して作成されたハンドラでは、 再接続ＵＲＬはサーバ内で自動解決されます。 明示的にＵＲＬを指定したい場合は、 ServletHTTPActionEventHandler.setLocation(java.lang.String) メソッドを利用して 再接続 URL を設定してください。

ActivityHTTPActionEventHandler

public ActivityHTTPActionEventHandler(String url)
指定のＵＲＬに再接続するための新しいイベントハンドラを作成します。

引数 url には、HTTPActionEvent のリスナーとなっている サーブレットへアクセスするためのＵＲＬを指定してください。

パラメータ:
url - URL
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
イベント名を返します。

実際には、Application Runtime で実行される jp.co.intra_mart.foundation.service.client.application.HTTPActionEvent を 実装したクラスのクラス名を返します。

オーバーライド:
クラス ServletHTTPActionEventHandler 内の getName
戻り値:
イベント名

getEventRequestParameterMap

protected Properties getEventRequestParameterMap()
                                          throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

オーバーライド:
クラス ServletHTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ConcreteHTTPActionEventHandler (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス ConcreteHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler
public class ConcreteHTTPActionEventHandler
extends HTTPActionEventEntityHandler

任意の HTTPActionEvent を実行するためのハンドラです。

このハンドラを利用する事により、作成したイベントに 対応するハンドラを特別に作成することなく、 任意のイベントを実行する事ができます。
このハンドラは、HTTPActionEvent の汎用ハンドラのため、 HTTPActionEvent 呼び出し時のパラメータを隠蔽化したい場合などは、 独自のハンドラを定義する必要がありますが、通常はこのハンドラで ほとんどの要件を満たせると思われます。

導入されたバージョン:
version 4.3

コンストラクタの概要
ConcreteHTTPActionEventHandler(String name)
指定のイベント名で表されるイベントを実行するためのハンドラを作成します。
メソッドの概要
 String getName()
イベント名を返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getEventRequestParameterMap, getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ConcreteHTTPActionEventHandler

public ConcreteHTTPActionEventHandler(String name)
指定のイベント名で表されるイベントを実行するためのハンドラを作成します。

パラメータ:
name - イベント名
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventEntityHandler 内の getName
戻り値:
イベント名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GroupSecurityHTTPActionEventFilterHandler (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス GroupSecurityHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
直系の既知のサブクラス:
AccountSecurityHTTPActionEventFilterHandler
public class GroupSecurityHTTPActionEventFilterHandler
extends HTTPActionEventFilterHandler

ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

このフィルタを利用する事により、任意のログイングループによる ログインセッション環境を作る事ができます。 このフィルタを利用する事により、 イベントプログラム中でログイングループを自動解決するＡＰＩを 利用可能になります。

実在しないグループを指定した場合、 未来の予測できないエラーを回避するために、 フィルタ処理の途中で即座に例外がスローされてます。 結果として、イベント実行はエラー終了します。
フィルタがエラー終了した場合、セキュリティホールとならないために セッションを破棄(javax.servlet.http.HttpSession#invalidate())します。 したがって、認証前にセッションに保存した情報にはアクセスできなくなります。 認証エラー後にセッション内の情報が必要な場合は、 事前に取得して別な場所へ保管するなどの対策が必要です。

導入されたバージョン:
version 4.3

フィールドの概要
protected static String ID_SECURITY_GROUP
コンストラクタの概要
GroupSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId)
ログイングループセッション環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
メソッドの概要
String | getGroup() 設定されているグループＩＤを返します。
String | getName() フィルタイベント名を返します。
protected void | setGroup(String groupId) グループＩＤを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_SECURITY_GROUP

protected static final String ID_SECURITY_GROUP
関連項目:
定数フィールド値
コンストラクタの詳細

GroupSecurityHTTPActionEventFilterHandler

public GroupSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler,
                                                 String groupId)
ログイングループセッション環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
groupId - グループＩＤ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventFilterHandler 内の getName
戻り値:
イベント名

setGroup

protected void setGroup(String groupId)
グループＩＤを設定します。

パラメータ:
groupId - グループＩＤ

getGroup

public String getGroup()
設定されているグループＩＤを返します。

戻り値:
グループＩＤ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventContent (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
インタフェース HTTPActionEventContent

すべてのスーパーインタフェース:
HTTPActionEventResult
public interface HTTPActionEventContent
extends HTTPActionEventResult

Web コンテンツを取得するための共通インターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
byte[] | getBytes() サーバからレスポンスされたコンテンツのソースをバイト列として返します。
URL | getRequestURL() このコンテンツを取得するために使用した URL を返します。
インタフェース jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult から継承したメソッド
getConnection, getInputStream, getResponseCode, getResponseMessage, isError

メソッドの詳細

getRequestURL

public URL getRequestURL()
このコンテンツを取得するために使用した URL を返します。

戻り値:
URL

getBytes

public byte[] getBytes()
                throws IOException
サーバからレスポンスされたコンテンツのソースをバイト列として返します。

何らかのエラーによりソースを受信できなかった場合、 このメソッドは null を返します。

戻り値:
コンテンツソースのバイト列。または null。
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventEntityHandler (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventEntityHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
直系の既知のサブクラス:
ConcreteHTTPActionEventHandler, WebApplicationHTTPActionEventHandler
public abstract class HTTPActionEventEntityHandler
extends HTTPActionEventHandler

HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。

この抽象実装は、すべての HTTPActionEvent ハンドラの スーパークラスになります。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected HTTPActionEventEntityHandler()
新しいイベントハンドラを作成します。
メソッドの概要
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
abstract String | getName() イベント名を返します。
String | getParameter(String key) 設定したパラメータ値を取得します。
Set | getParameterKeySet() 現在、パラメータとして設定されているキーの一覧を返します。
Properties | getParameterMap() 設定済みパラメータのマップのコピーを返します。
boolean | hasParameter(String key) 設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
void | removeParameter(String key) 指定のキーのマップを削除します。
void | setParameter(String key, String value) イベントへのパラメータを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPActionEventEntityHandler

protected HTTPActionEventEntityHandler()
新しいイベントハンドラを作成します。

メソッドの詳細

getName

public abstract String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventHandler 内の getName
戻り値:
イベント名

setParameter

public void setParameter(String key,
                         String value)
イベントへのパラメータを設定します。 ここで設定した値は、Application Runtime で実行されるイベントにて、 通常のＵＲＬ引数として受け取ることができます。 値を取得するには、サーブレットプログラムにおいてＵＲＬパラメータを 取得する一般的な方法と同様に、HttpServletRequest#getParameter(String) を利用してください。

定義:
クラス HTTPActionEventHandler 内の setParameter
パラメータ:
key - キー
value - 値

getParameter

public String getParameter(String key)
設定したパラメータ値を取得します。 指定のキーにマップされている値が存在しない場合、null を返します。

定義:
クラス HTTPActionEventHandler 内の getParameter
パラメータ:
key - キー
戻り値:
キーにマップされているパラメータ値

hasParameter

public boolean hasParameter(String key)
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。

定義:
クラス HTTPActionEventHandler 内の hasParameter
パラメータ:
key - キー
戻り値:
キーにパラメータ値がマップされている場合 true。

getParameterKeySet

public Set getParameterKeySet()
現在、パラメータとして設定されているキーの一覧を返します。

定義:
クラス HTTPActionEventHandler 内の getParameterKeySet
戻り値:
キーのセット

removeParameter

public void removeParameter(String key)
指定のキーのマップを削除します。 削除されたキーおよびそのキーにマップされた値は、Application Runtime に送信されなくなります。

定義:
クラス HTTPActionEventHandler 内の removeParameter
パラメータ:
key - キー

getParameterMap

public Properties getParameterMap()
設定済みパラメータのマップのコピーを返します。 パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。

定義:
クラス HTTPActionEventHandler 内の getParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

getEventRequestParameterMap

protected Properties getEventRequestParameterMap()
                                          throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

定義:
クラス HTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventFilterHandler (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
直系の既知のサブクラス:
AccessibleLinkHTTPActionEventFilterHandler, ActivityFrameworkHTTPActionEventFilterHandler, GroupSecurityHTTPActionEventFilterHandler, LimitedSessionHTTPActionEventFilterHandler
public abstract class HTTPActionEventFilterHandler
extends HTTPActionEventHandler

HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。

HTTPActionEventHandler をフィルタリングする HTTPActionEventHandler は、 このクラスをスーパークラスとして実装する事を推奨します。

ユーザプログラムでは、フィルタリングしたいハンドラを基礎ハンドラとして フィルタハンドラを作成し、フィルタハンドラの HTTPActionEventHandler.execute(java.net.HttpURLConnection) を呼び出すことで、 Application Runtime でフィルタされた効果を得ながら 基礎ハンドラが指定するイベントを実行する事ができます。
なお、このハンドラを利用して呼び出すフィルターイベントは、 FilterHTTPActionEvent を実装しているクラスでなければいけません。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected HTTPActionEventFilterHandler(HTTPActionEventHandler handler)
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラを作成します。
メソッドの概要
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected String | getFilterParameter(String key) このフィルタのパラメータを返します。
protected Properties | getFilterParameterMap() このハンドラによって実行されるフィルタイベントに対する 設定済みパラメータのマップを返します。
abstract String | getName() フィルタイベント名を返します。
String | getParameter(String key) 設定したパラメータ値を取得します。
Set | getParameterKeySet() 現在、パラメータとして設定されているキーの一覧を返します。
Properties | getParameterMap() 設定済みパラメータのマップのコピーを返します。
HTTPActionEventHandler | getParent() このオブジェクトがフィルタリングしているハンドラを返します。
boolean | hasParameter(String key) 設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
protected String | removeFilterParameter(String key) このフィルタのパラメータを削除します。
void | removeParameter(String key) 指定のキーのマップを削除します。
protected void | setFilterParameter(String key, String value) このフィルタのパラメータを設定します。
void | setParameter(String key, String value) イベントへのパラメータを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPActionEventFilterHandler

protected HTTPActionEventFilterHandler(HTTPActionEventHandler handler)
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getParent

public HTTPActionEventHandler getParent()
このオブジェクトがフィルタリングしているハンドラを返します。

戻り値:
ハンドラ

getName

public abstract String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventHandler 内の getName
戻り値:
イベント名

setParameter

public void setParameter(String key,
                         String value)
イベントへのパラメータを設定します。 ここで設定した値は、Application Runtime で実行されるイベントにて、 通常のＵＲＬ引数として受け取ることができます。 値を取得するには、サーブレットプログラムにおいてＵＲＬパラメータを 取得する一般的な方法と同様に、HttpServletRequest#getParameter(String) を利用してください。

このメソッドは、単純のラップしている親ハンドラの #getParameter(String, String) を呼び出します。

定義:
クラス HTTPActionEventHandler 内の setParameter
パラメータ:
key - キー
value - 値

getParameter

public String getParameter(String key)
設定したパラメータ値を取得します。 指定のキーにマップされている値が存在しない場合、null を返します。

このメソッドは、単純のラップしている親ハンドラの #getParameter(String) を呼び出します。

定義:
クラス HTTPActionEventHandler 内の getParameter
パラメータ:
key - キー
戻り値:
キーにマップされているパラメータ値

hasParameter

public boolean hasParameter(String key)
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。

このメソッドは、単純のラップしている親ハンドラの #hasParameter(String) を呼び出します。

定義:
クラス HTTPActionEventHandler 内の hasParameter
パラメータ:
key - キー
戻り値:
キーにパラメータ値がマップされている場合 true。

getParameterKeySet

public Set getParameterKeySet()
現在、パラメータとして設定されているキーの一覧を返します。

このメソッドは、単純のラップしている親ハンドラの #getParameterKeySet() を呼び出します。

定義:
クラス HTTPActionEventHandler 内の getParameterKeySet
戻り値:
キーのセット

removeParameter

public void removeParameter(String key)
指定のキーのマップを削除します。 削除されたキーおよびそのキーにマップされた値は、Application Runtime に送信されなくなります。

このメソッドは、単純のラップしている親ハンドラの #removeParameter(String) を 呼び出します。

定義:
クラス HTTPActionEventHandler 内の removeParameter
パラメータ:
key - キー

getParameterMap

public Properties getParameterMap()
設定済みパラメータのマップのコピーを返します。 パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。

このメソッドは、単純のラップしている親ハンドラの #getParameterMap() を 呼び出します。

定義:
クラス HTTPActionEventHandler 内の getParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

setFilterParameter

protected void setFilterParameter(String key,
                                  String value)
このフィルタのパラメータを設定します。

パラメータ:
key - パラメータ名
value - パラメータの値

getFilterParameter

protected String getFilterParameter(String key)
このフィルタのパラメータを返します。

パラメータ:
key - パラメータ名
戻り値:
パラメータの値

removeFilterParameter

protected String removeFilterParameter(String key)
このフィルタのパラメータを削除します。

パラメータ:
key - パラメータ名
戻り値:
設定されていたパラメータの値

getFilterParameterMap

protected Properties getFilterParameterMap()
                                    throws HTTPActionEventHandlerParameterException
このハンドラによって実行されるフィルタイベントに対する 設定済みパラメータのマップを返します。 パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。

戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

getEventRequestParameterMap

protected final Properties getEventRequestParameterMap()
                                                throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。

定義:
クラス HTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventHandler (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
直系の既知のサブクラス:
HTTPActionEventEntityHandler, HTTPActionEventFilterHandler
public abstract class HTTPActionEventHandler
extends Object

HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。

この抽象実装は、すべての HTTPActionEvent ハンドラの スーパークラスになります。

ハンドラを作成してイベント実行を要求する場合、execute(String) または execute(java.net.URL) を利用します。 execute(java.net.HttpURLConnection) も利用できますが、 通常はこの方法を使わない方が良いと思われます。

イベント実行を要求するＵＲＬは、 HTTPActionEventListener へ接続できるものを指定します。 標準では、下記のようになります。
http://<サーバアドレス>[:<ポート番号>]/imart/HTTPActionEventListener

外部ソフトウェア接続モジュールでは、HTTPS プロトコルを利用した通信が可能です。
以下に、簡単にHTTPSプロトコルを利用した通信を行う方法を記します。

  1. 証明書の追加

    2. JDK 付属のツール keytool の -import コマンドを使って、信頼できる証明書をリストに追加します。
    例えば、サーバ証明書「C:¥temp¥server.crt」を、 別名「sample_alias」でキーストアエントリに格納するには、以下のコマンドを実行します。
     >keytool -import -alias sample_alias -file C:¥temp¥server.crt
    上記コマンドを実行すると、ユーザのホームディレクトリの「.keystore」ファイルに、キーストアが作成されます。
    （keytoolの詳細は、 keytool - 鍵と証明書の管理ツール を参照してください）

  2. キーストアを指定して、クライアントを実行

    3. 外部ソフトウェア接続モジュールのクライアントが、証明書ファイルを利用できる状態に設定します。
    java コマンドを実行する際、次のオプションをコマンド行に追加し、手順1 で追加したキーストアを指定します。
    ここでは、ユーザのホームディレクトリを「 /home/user_name 」とします。
    -Djavax.net.ssl.trustStore=/home/user_name/.keystore

    Windows環境の例 （ホームディレクトリが「 C:¥Documents and Settings¥user_name 」の場合）
    -Djavax.net.ssl.trustStore="C:¥¥Documents and Settings¥¥user_name¥¥.keystore"
簡単にHTTPSプロトコルを利用した通信を行う方法は 以上です。

外部ソフトウェア接続モジュールは、HTTPS プロトコルを利用した通信を行う際に、 HttpsURLConnection を利用して通信を行います。
そのため、デフォルト動作をオーバライドしたい場合、以下の二つを設定する必要があります。

  • javax.net.ssl.HostnameVerifier

    • 外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の HostnameVerifier を setHostnameVerifier(HostnameVerifier) メソッドで設定します。
    （この HostnameVerifier は、URL ホスト名のデフォルトの検証規則が失敗した場合に使用されます）
    HostnameVerifier が設定されていない場合、
    ホスト名が認証方式に準拠しているかどうかに関わらず、接続を許可します。

  • javax.net.ssl.SSLContext

    • 外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の SSLSocketFactory を生成する SSLContextを、setSSLContext(SSLContext) メソッドで設定します。
    SSLContext が設定されていない場合、
    HttpsURLConnection に対して SSLSocketFactory の設定を行いません。
HTTPS プロトコルを利用した通信を行うには、Java Secure Socket Extension (JSSE) の知識が必要です。
詳しくは、 Java Secure Socket Extension (JSSE) リファレンスガイド を参照してください。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected HTTPActionEventHandler()
新しいイベントハンドラを作成します。
メソッドの概要
HTTPActionEventResult | execute(HttpURLConnection connection) 指定された URL コネクションを利用してにサーバに接続し、 イベントの実行を要求します。
HTTPActionEventResult | execute(String url) 指定された URL に接続して、 イベントの実行を要求します。
HTTPActionEventResult | execute(URL url) 指定された URL に接続して、 イベントの実行を要求します。
String | getCharacterEncoding() パラメータを符号化するためのエンコーディング名を返します。
protected abstract Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
abstract String | getName() イベント名を返します。
abstract String | getParameter(String key) 設定したパラメータ値を取得します。
abstract Set | getParameterKeySet() 現在、パラメータとして設定されているキーの一覧を返します。
abstract Properties | getParameterMap() 設定済みパラメータのマップのコピーを返します。
abstract boolean | hasParameter(String key) 設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
abstract void | removeParameter(String key) 指定のキーのマップを削除します。
void | setCharacterEncoding(String enc) パラメータを符号化するためのエンコーディング名を指定します。
void | setHostnameVerifier(HostnameVerifier hostnameVerifier) 外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の HostnameVerifier を設定します。
abstract void | setParameter(String key, String value) イベントへのパラメータを設定します。
void | setSSLContext(SSLContext sslContext) 外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の SSLSocketFactory を生成する SSLContextを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPActionEventHandler

protected HTTPActionEventHandler()
新しいイベントハンドラを作成します。

メソッドの詳細

getName

public abstract String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

戻り値:
イベント名

setParameter

public abstract void setParameter(String key,
                                  String value)
イベントへのパラメータを設定します。 ここで設定した値は、Application Runtime で実行されるイベントにて、 通常のＵＲＬ引数として受け取ることができます。 値を取得するには、サーブレットプログラムにおいてＵＲＬパラメータを 取得する一般的な方法と同様に、HttpServletRequest#getParameter(String) を利用してください。

パラメータ:
key - キー
value - 値

getParameter

public abstract String getParameter(String key)
設定したパラメータ値を取得します。 指定のキーにマップされている値が存在しない場合、null を返します。

パラメータ:
key - キー
戻り値:
キーにマップされているパラメータ値

hasParameter

public abstract boolean hasParameter(String key)
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。

パラメータ:
key - キー
戻り値:
キーにパラメータ値がマップされている場合 true。

getParameterKeySet

public abstract Set getParameterKeySet()
現在、パラメータとして設定されているキーの一覧を返します。

戻り値:
キーのセット

removeParameter

public abstract void removeParameter(String key)
指定のキーのマップを削除します。 削除されたキーおよびそのキーにマップされた値は、Application Runtime に送信されなくなります。

パラメータ:
key - キー

getParameterMap

public abstract Properties getParameterMap()
設定済みパラメータのマップのコピーを返します。 パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。

戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

getEventRequestParameterMap

protected abstract Properties getEventRequestParameterMap()
                                                   throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

getCharacterEncoding

public String getCharacterEncoding()
パラメータを符号化するためのエンコーディング名を返します。

戻り値:
文字エンコーディング名

setCharacterEncoding

public void setCharacterEncoding(String enc)
                          throws UnsupportedEncodingException
パラメータを符号化するためのエンコーディング名を指定します。

デフォルトでは UTF-8 を用いてパラメータを符号化します。 また、イベントへの各パラメータ値は Unicode のまま扱われますので、 通常は文字エンコーディングを変更する必要はありません。

パラメータ:
enc - 文字エンコーディング名
例外:
UnsupportedEncodingException - 指定のエンコーディング名がサポートされない場合

execute

public HTTPActionEventResult execute(String url)
                              throws MalformedURLException,
                                     IOException,
                                     HTTPActionEventHandlerException
指定された URL に接続して、 イベントの実行を要求します。

このメソッドは、指定の URL 文字列から java.net.URL のインスタンスを 作成して execute(java.net.URL) メソッドを呼び出します。

パラメータ:
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
HTTPActionEventHandlerException - 実行時エラー
MalformedURLException
IOException

execute

public HTTPActionEventResult execute(URL url)
                              throws IOException,
                                     HTTPActionEventHandlerException
指定された URL に接続して、 イベントの実行を要求します。

このメソッドは、指定の java.net.URL から java.net.HttpURLConnection を取得して execute(java.net.HttpURLConnection) メソッドを呼び出します。

パラメータ:
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
HTTPActionEventHandlerException - 実行時エラー
IOException

execute

public HTTPActionEventResult execute(HttpURLConnection connection)
                              throws IOException,
                                     HTTPActionEventHandlerException
指定された URL コネクションを利用してにサーバに接続し、 イベントの実行を要求します。

このメソッドは、 getParameterMap() の返り値をイベントの引数として サーバに対して getName() が表すイベントの 実行を要求します。

パラメータ:
connection - コネクション
戻り値:
実行結果オブジェクト
例外:
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー

setHostnameVerifier

public void setHostnameVerifier(HostnameVerifier hostnameVerifier)
外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の HostnameVerifier を設定します。
（このHostnameVerifierは、URL ホスト名のデフォルトの検証規則が失敗した場合に使用されます）

HostnameVerifier が設定されていない場合、
ホスト名が認証方式に準拠しているかどうかに関わらず、接続を許可します。

パラメータ:
hostnameVerifier - 外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の HostnameVerifier
導入されたバージョン:
version 6.1

setSSLContext

public void setSSLContext(SSLContext sslContext)
外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の SSLSocketFactory を生成する SSLContextを設定します。
SSLContext が設定されていない場合、
HttpsURLConnection に対して SSLSocketFactory の設定を行いません。

デフォルト動作をオーバライドする場合を除き、 SSLContext オブジェクトを直接作成したり初期化したりする必要はありません。

パラメータ:
sslContext - SSLContext
導入されたバージョン:
version 6.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventHandlerException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventHandlerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
HTTPActionEventHandlerParameterException
public class HTTPActionEventHandlerException
extends Exception

HTTPActionEventHandler 内で発生したエラーを通知するための例外です。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
HTTPActionEventHandlerException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerException(String msg, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HTTPActionEventHandlerException

public HTTPActionEventHandlerException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

HTTPActionEventHandlerException

public HTTPActionEventHandlerException(String msg,
                                       Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventHandlerParameterException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventHandlerParameterException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException
                拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException
すべての実装インタフェース:
Serializable
public class HTTPActionEventHandlerParameterException
extends HTTPActionEventHandlerException

HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
HTTPActionEventHandlerParameterException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerParameterException(String msg, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HTTPActionEventHandlerParameterException

public HTTPActionEventHandlerParameterException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

HTTPActionEventHandlerParameterException

public HTTPActionEventHandlerParameterException(String msg,
                                                Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventResult (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
インタフェース HTTPActionEventResult

既知のサブインタフェースの一覧:
HTTPActionEventContent, HTTPActionEventURL
既知の実装クラスの一覧:
HTTPActionEventResultWrapper
public interface HTTPActionEventResult

HTTPActionEvent 実行要求の結果に関する共通インターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
HttpURLConnection | getConnection() 接続に利用したコネクションを返します。
InputStream | getInputStream() サーバからの入力を受け付ける入力ストリームを返します。
int | getResponseCode() サーバからのHTTPレスポンスコードを返します。
String | getResponseMessage() サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。
boolean | isError() 処理要求が成功したかどうかを判定します。

メソッドの詳細

getConnection

public HttpURLConnection getConnection()
接続に利用したコネクションを返します。

戻り値:
コネクション

getResponseCode

public int getResponseCode()
                    throws IOException
サーバからのHTTPレスポンスコードを返します。

返されるレスポンスコードについては、 HttpURLConnection の 仕様に準じます。

接続そのものに失敗した場合など、サーバから HTTP レスポンスコードを 受け取れなかった場合、 このメソッドは java.io.IOException をスローします。

戻り値:
レスポンスコード
例外:
IOException - 入出力エラーが発生した場合

getResponseMessage

public String getResponseMessage()
                          throws IOException
サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。

このメソッドは、java.net.HttpURLConnection の #getResponseMessage() メソッドの仕様に準じます。

戻り値:
HTTP 応答メッセージまたは null
例外:
IOException - サーバへの接続でエラーが発生した場合

getInputStream

public InputStream getInputStream()
                           throws IOException
サーバからの入力を受け付ける入力ストリームを返します。 この入力ストリームによりレスポンスデータを得る事ができます。

戻り値:
入力ストリーム
例外:
IOException - 入力ストリームの作成中に入出力エラーが発生した場合
UnknownServiceException - プロトコルが入力をサポートしていない場合

isError

public boolean isError()
処理要求が成功したかどうかを判定します。

このメソッドでは、HTTP のレスポンスコードが 200 かどうかで、 判定しています。

戻り値:
エラーなく処理終了しなかった場合 true。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventResultWrapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventResultWrapper

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper
すべての実装インタフェース:
HTTPActionEventResult
public class HTTPActionEventResultWrapper
extends Object
implements HTTPActionEventResult

HTTPActionEventResult のラッパーオブジェクトです。
このクラスでは、基本的にラップしているオブジェクトからの 返り値をそのままリターンします。 必要に応じてサブクラスを作成し、サブクラス側で必要な処理を メソッドをオーバーライドすることにより実装してください。

導入されたバージョン:
version 4.3

コンストラクタの概要
HTTPActionEventResultWrapper(HTTPActionEventResult parent)
指定の結果オブジェクトをラップする新しい結果オブジェクトを作成します。
メソッドの概要
HttpURLConnection | getConnection() 接続に利用したコネクションを返します。
InputStream | getInputStream() サーバからの入力を受け付ける入力ストリームを返します。
protected HTTPActionEventResult | getParent() ラップしている親オブジェクトを返します。
int | getResponseCode() サーバからのHTTPレスポンスコードを返します。
String | getResponseMessage() サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。
boolean | isError() 処理要求が成功したかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPActionEventResultWrapper

public HTTPActionEventResultWrapper(HTTPActionEventResult parent)
指定の結果オブジェクトをラップする新しい結果オブジェクトを作成します。

パラメータ:
parent - ラップする結果オブジェクト
メソッドの詳細

getConnection

public HttpURLConnection getConnection()
接続に利用したコネクションを返します。

定義:
インタフェース HTTPActionEventResult 内の getConnection
戻り値:
コネクション

getResponseCode

public int getResponseCode()
                    throws IOException
サーバからのHTTPレスポンスコードを返します。

返されるレスポンスコードについては、 javax.servlet.http.HttpURLConnection#getResponseCode() の 仕様に準じます。

接続そのものに失敗した場合など、サーバから HTTP レスポンスコードを 受け取れなかった場合、 このメソッドは java.io.IOException をスローします。

定義:
インタフェース HTTPActionEventResult 内の getResponseCode
戻り値:
レスポンスコード
例外:
IOException - 入出力エラーが発生した場合

getResponseMessage

public String getResponseMessage()
                          throws IOException
サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。

このメソッドは、java.net.HttpURLConnection の #getResponseMessage() メソッドの仕様に準じます。

定義:
インタフェース HTTPActionEventResult 内の getResponseMessage
戻り値:
HTTP 応答メッセージまたは null
例外:
IOException - サーバへの接続でエラーが発生した場合

getInputStream

public InputStream getInputStream()
                           throws IOException
サーバからの入力を受け付ける入力ストリームを返します。 この入力ストリームによりレスポンスデータを得る事ができます。

定義:
インタフェース HTTPActionEventResult 内の getInputStream
戻り値:
入力ストリーム
例外:
IOException - 入力ストリームの作成中に入出力エラーが発生した場合
UnknownServiceException - プロトコルが入力をサポートしていない場合

isError

public boolean isError()
処理要求が成功したかどうかを判定します。

定義:
インタフェース HTTPActionEventResult 内の isError
戻り値:
エラーなく処理終了した場合 false。

getParent

protected HTTPActionEventResult getParent()
ラップしている親オブジェクトを返します。

戻り値:
ラップしている結果オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventURL (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
インタフェース HTTPActionEventURL

すべてのスーパーインタフェース:
HTTPActionEventResult
public interface HTTPActionEventURL
extends HTTPActionEventResult

Web コンテンツへのアクセスＵＲＬを取得するための共通インターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
 HTTPActionEventContent getContent()
getURL() によって表されるコンテンツのソースを取得します。
 String getURL()
サーバから返されたＵＲＬを返します。
インタフェース jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult から継承したメソッド
getConnection, getInputStream, getResponseCode, getResponseMessage, isError

メソッドの詳細

getURL

public String getURL()
              throws IOException
サーバから返されたＵＲＬを返します。

戻り値:
ＵＲＬ
例外:
IOException - 入出力エラー

getContent

public HTTPActionEventContent getContent()
                                  throws MalformedURLException,
                                         IOException
getURL() によって表されるコンテンツのソースを取得します。

戻り値:
サーバからの応答オブジェクト
例外:
MalformedURLException - URL のフォーマットエラー
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LimitedSessionHTTPActionEventFilterHandler (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス LimitedSessionHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler
public class LimitedSessionHTTPActionEventFilterHandler
extends HTTPActionEventFilterHandler

セッションを一時利用のみに限定するためのフィルタです。

イベント HTTPActionEvent では、セッション情報を扱う場合 javax.servlet.http.HttpSession を利用します。 したがって、明示的にセッション(javax.servlet.http.HttpSession)を破棄しない場合、 セッションのタイムアウトが発生するまで、サーバのメモリリソースを 消費したままの状態が維持されてしまいます。
このフィルタは、イベント処理終了時に javax.servlet.http.HttpSession#invalidate() を 実行してセッションを明示的に破棄します。 セッションを維持する必要のないイベント実行では、 このフィルタを利用することにより、サーバリソースの無駄な利用を 回避する事ができます。

導入されたバージョン:
version 4.3

コンストラクタの概要
LimitedSessionHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
セッションを一時利用に限定するためのフィルタハンドラを作成します。
メソッドの概要
 String getName()
フィルタイベント名を返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LimitedSessionHTTPActionEventFilterHandler

public LimitedSessionHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
セッションを一時利用に限定するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventFilterHandler 内の getName
戻り値:
イベント名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.client.application (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.service.client.application
インタフェース
HTTPActionEventContent
HTTPActionEventResult
HTTPActionEventURL
クラス
AccountSecurityHTTPActionEventFilterHandler
ActivityHTTPActionEventHandler
ConcreteHTTPActionEventHandler
GroupSecurityHTTPActionEventFilterHandler
HTTPActionEventEntityHandler
HTTPActionEventFilterHandler
HTTPActionEventHandler
HTTPActionEventResultWrapper
LimitedSessionHTTPActionEventFilterHandler
PasswordSecurityHTTPActionEventFilterHandler
ServletHTTPActionEventHandler
WebApplicationHTTPActionEventHandler
例外
HTTPActionEventHandlerException
HTTPActionEventHandlerParameterException


jp.co.intra_mart.foundation.service.client.application (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.application

このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

参照:
説明

インタフェースの概要
HTTPActionEventContent | Web コンテンツを取得するための共通インターフェースです。
HTTPActionEventResult | HTTPActionEvent 実行要求の結果に関する共通インターフェースです。
HTTPActionEventURL | Web コンテンツへのアクセスＵＲＬを取得するための共通インターフェースです。

クラスの概要
AccountSecurityHTTPActionEventFilterHandler | ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
ActivityHTTPActionEventHandler | 持続したセッションを確立するためのハンドラです。
ConcreteHTTPActionEventHandler | 任意の HTTPActionEvent を実行するためのハンドラです。
GroupSecurityHTTPActionEventFilterHandler | ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
HTTPActionEventEntityHandler | HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventFilterHandler | HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
HTTPActionEventHandler | HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventResultWrapper | HTTPActionEventResult のラッパーオブジェクトです。
LimitedSessionHTTPActionEventFilterHandler | セッションを一時利用のみに限定するためのフィルタです。
PasswordSecurityHTTPActionEventFilterHandler | ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
ServletHTTPActionEventHandler | Web-Application を実行するためのイベントハンドラです。
WebApplicationHTTPActionEventHandler | フレームワークを実行するためのイベントハンドラの抽象実装です。

例外の概要
HTTPActionEventHandlerException | HTTPActionEventHandler 内で発生したエラーを通知するための例外です。
HTTPActionEventHandlerParameterException | HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。

パッケージ jp.co.intra_mart.foundation.service.client.application の説明

このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
このパッケージを利用することにより、intra-mart ではない環境から intra-mart 内のプログラム実行を行うことができるようになりますので、例えばユーザ情報の同期など、様々なことを実現することができます。

導入されたバージョン:
version 4.0


jp.co.intra_mart.foundation.service.client.application クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.application の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
        • class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler
        • class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler
            • class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
          • class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
            • class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper (implements jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException
          • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException

インタフェース階層

  • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult
    • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent
    • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL


パッケージ jp.co.intra_mart.foundation.service.client.application の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client.application の使用

jp.co.intra_mart.foundation.service.client.application を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application により使用される jp.co.intra_mart.foundation.service.client.application のクラス
AccountSecurityHTTPActionEventFilterHandler
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
GroupSecurityHTTPActionEventFilterHandler
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
HTTPActionEventContent
Web コンテンツを取得するための共通インターフェースです。
HTTPActionEventEntityHandler
HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventFilterHandler
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
HTTPActionEventHandler
HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventHandlerException
HTTPActionEventHandler 内で発生したエラーを通知するための例外です。
HTTPActionEventHandlerParameterException
HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。
HTTPActionEventResult
HTTPActionEvent 実行要求の結果に関する共通インターフェースです。
HTTPActionEventURL
Web コンテンツへのアクセスＵＲＬを取得するための共通インターフェースです。
ServletHTTPActionEventHandler
Web-Application を実行するためのイベントハンドラです。
WebApplicationHTTPActionEventHandler
フレームワークを実行するためのイベントハンドラの抽象実装です。

jp.co.intra_mart.foundation.service.client.application.content により使用される jp.co.intra_mart.foundation.service.client.application のクラス
HTTPActionEventEntityHandler
HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventFilterHandler
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
HTTPActionEventHandler
HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventHandlerParameterException
HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。
WebApplicationHTTPActionEventHandler
フレームワークを実行するためのイベントハンドラの抽象実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PasswordSecurityHTTPActionEventFilterHandler (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス PasswordSecurityHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
                    拡張 jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler
public class PasswordSecurityHTTPActionEventFilterHandler
extends AccountSecurityHTTPActionEventFilterHandler

ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

このフィルタを利用する事により、任意のログイングループ内の任意のアカウントで ログインした状態の環境を作る事ができます。 ログイン環境でイベントを動作させる事により、 イベントプログラム中でログインセッションを必要とするＡＰＩを 利用可能になります。

このフィルタは、AccountSecurityHTTPActionEventFilterHandler の機能に加えて パスワード認証も行います。したがって、AccountSecurityHTTPActionEventFilterHandler よりも 高度なセキュリティを実現しながらイベントを実行する事が可能となります。

このフィルタを利用する場合は、 必ずログイン環境を作れるアカウントを作成しておく必要があります。 実在しないアカウントを指定したりパスワードが正しくない場合、 未来の予測できないエラーを回避するために、 フィルタ処理の途中で即座に例外がスローされてます。 結果として、イベント実行はエラー終了します。
フィルタがエラー終了した場合、セキュリティホールとならないために セッションを破棄(javax.servlet.http.HttpSession#invalidate())します。 したがって、認証前にセッションに保存した情報にはアクセスできなくなります。 認証エラー後にセッション内の情報が必要な場合は、 事前に取得して別な場所へ保管するなどの対策が必要です。

導入されたバージョン:
version 4.3

フィールドの概要
protected static String ID_SECURITY_PASSWORD
クラス jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler から継承したフィールド
ID_SECURITY_ACCOUNT
クラス jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler から継承したフィールド
ID_SECURITY_GROUP
コンストラクタの概要
PasswordSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId, String accountId, String password)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
メソッドの概要
String | getName() フィルタイベント名を返します。
String | getPassword() 設定されているパスワードを返します。
protected void | setPassword(String password) パスワードを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler から継承したメソッド
getAccount, setAccount
クラス jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler から継承したメソッド
getGroup, setGroup
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_SECURITY_PASSWORD

protected static final String ID_SECURITY_PASSWORD
関連項目:
定数フィールド値
コンストラクタの詳細

PasswordSecurityHTTPActionEventFilterHandler

public PasswordSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler,
                                                    String groupId,
                                                    String accountId,
                                                    String password)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
groupId - グループＩＤ
accountId - アカウントＩＤ
password - パスワード
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

オーバーライド:
クラス AccountSecurityHTTPActionEventFilterHandler 内の getName
戻り値:
イベント名

setPassword

protected void setPassword(String password)
パスワードを設定します。

パラメータ:
password - パスワード

getPassword

public String getPassword()
設定されているパスワードを返します。

戻り値:
パスワード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServletHTTPActionEventHandler (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス ServletHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler
直系の既知のサブクラス:
ActivityHTTPActionEventHandler
public class ServletHTTPActionEventHandler
extends WebApplicationHTTPActionEventHandler

Web-Application を実行するためのイベントハンドラです。

このハンドラは、指定の Web-Application を実行するための URL を作成して 返します。 ユーザプログラムでは、このハンドラを利用して取得した URL を用いて、 サーバにリクエストすることにより目的のコンテンツのソースを 取得する事ができます。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected | ServletHTTPActionEventHandler() Web-Application をイベント実行するためのハンドラを作成します。
 | ServletHTTPActionEventHandler(String location) 指定のパスで表される Web-Application をイベント実行するためのハンドラを作成します。
メソッドの概要
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
String | getLocation() 設定されている遷移先パスを返します。
String | getName() イベント名を返します。
protected void | setLocation(String location) 遷移先のページパスを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler から継承したメソッド
getQueryString, getURL, getURL, getURL, getURL, getURL, getURL
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ServletHTTPActionEventHandler

protected ServletHTTPActionEventHandler()
Web-Application をイベント実行するためのハンドラを作成します。
このコンストラクタでは表示する画面のパスが設定されません。 サブクラスで setLocation(String) を利用して 画面パスを設定しなければいけません。

ServletHTTPActionEventHandler

public ServletHTTPActionEventHandler(String location)
指定のパスで表される Web-Application をイベント実行するためのハンドラを作成します。

パラメータ:
location - Web-Application のパス
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getName
戻り値:
イベント名

setLocation

protected void setLocation(String location)
遷移先のページパスを設定します。

パラメータ:
location - ページパス
例外:
NullPointerException - 引数が null の場合

getLocation

public String getLocation()
設定されている遷移先パスを返します。

戻り値:
遷移先を表すパス

getEventRequestParameterMap

protected Properties getEventRequestParameterMap()
                                          throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

このメソッドが返す値は、イベントに対するパラメータであって、 getLocation() によって表される画面プログラムに対する リクエストパラメータではない点に注意してください。 getLocation() によって表される画面プログラムに対する リクエストパラメータに関しては、HTTPActionEventEntityHandler.getParameterMap() によって 取得できます。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


WebApplicationHTTPActionEventHandler (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス WebApplicationHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
直系の既知のサブクラス:
PresentationPageHTTPActionEventHandler, ServiceFrameworkHTTPActionEventHandler, ServletHTTPActionEventHandler
public abstract class WebApplicationHTTPActionEventHandler
extends HTTPActionEventEntityHandler

フレームワークを実行するためのイベントハンドラの抽象実装です。

このハンドラは、指定のフレームワークを実行するための URL を作成して 返します。 ユーザプログラムでは、このハンドラを利用して取得した URL を用いて、 サーバにリクエストすることにより目的のコンテンツのソースを 取得する事ができます。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected WebApplicationHTTPActionEventHandler()
Web-Application をイベント実行するためのハンドラを作成します。
メソッドの概要
protected abstract Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
abstract String | getName() イベント名を返します。
protected String | getQueryString() 設定されているパラメータ情報からクエリ文字列を作成して返します。
static HTTPActionEventURL | getURL(HTTPActionEventHandler handler, HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | getURL(HTTPActionEventHandler handler, String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | getURL(HTTPActionEventHandler handler, URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | getURL(HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | getURL(String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | getURL(URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

WebApplicationHTTPActionEventHandler

protected WebApplicationHTTPActionEventHandler()
Web-Application をイベント実行するためのハンドラを作成します。
このコンストラクタでは表示する画面のパスが設定されません。 サブクラスで #setLocation(String) を利用して 画面パスを設定しなければいけません。

メソッドの詳細

getURL

public static HTTPActionEventURL getURL(HTTPActionEventHandler handler,
                                        String url)
                                 throws MalformedURLException,
                                        IOException,
                                        HTTPActionEventHandlerException
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

このメソッドは、HTTPActionEventHandler.execute(String) の結果を HTTPActionEventURL インターフェースでラップして返します。

引数 handler には、このクラスと代入互換のあるオブジェクトまたは、 代入互換のあるオブジェクトをラップしているフィルタハンドラを 指定してください。他のハンドラを指定した場合、正しく結果を得られません。

パラメータ:
handler - ハンドラ
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
MalformedURLException - URL のフォーマットエラー
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー

getURL

public static HTTPActionEventURL getURL(HTTPActionEventHandler handler,
                                        URL url)
                                 throws IOException,
                                        HTTPActionEventHandlerException
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

このメソッドは、HTTPActionEventHandler.execute(URL) の結果を HTTPActionEventURL インターフェースでラップして返します。

引数 handler には、このクラスと代入互換のあるオブジェクトまたは、 代入互換のあるオブジェクトをラップしているフィルタハンドラを 指定してください。他のハンドラを指定した場合、正しく結果を得られません。

パラメータ:
handler - ハンドラ
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー

getURL

public static HTTPActionEventURL getURL(HTTPActionEventHandler handler,
                                        HttpURLConnection connection)
                                 throws IOException,
                                        HTTPActionEventHandlerException
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

このメソッドは、HTTPActionEventHandler.execute(HttpURLConnection) の結果を HTTPActionEventURL インターフェースでラップして返します。

引数 handler には、このクラスと代入互換のあるオブジェクトまたは、 代入互換のあるオブジェクトをラップしているフィルタハンドラを 指定してください。他のハンドラを指定した場合、正しく結果を得られません。

パラメータ:
handler - ハンドラ
戻り値:
実行結果オブジェクト
例外:
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー

getName

public abstract String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventEntityHandler 内の getName
戻り値:
イベント名

getEventRequestParameterMap

protected abstract Properties getEventRequestParameterMap()
                                                   throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。

オーバーライド:
クラス HTTPActionEventEntityHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

getQueryString

protected String getQueryString()
                         throws UnsupportedEncodingException
設定されているパラメータ情報からクエリ文字列を作成して返します。

戻り値:
クエリ。パラメータが設定されていない場合は null。
例外:
UnsupportedEncodingException - 設定されている文字エンコーディング名がサポート外

getURL

public HTTPActionEventURL getURL(String url)
                          throws MalformedURLException,
                                 IOException,
                                 HTTPActionEventHandlerException
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

このメソッドは、HTTPActionEventHandler.execute(String) の結果を HTTPActionEventURL インターフェースでラップして返します。

パラメータ:
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
MalformedURLException - URL のフォーマットエラー
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー

getURL

public HTTPActionEventURL getURL(URL url)
                          throws IOException,
                                 HTTPActionEventHandlerException
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

このメソッドは、HTTPActionEventHandler.execute(URL) の結果を HTTPActionEventURL インターフェースでラップして返します。

パラメータ:
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー

getURL

public HTTPActionEventURL getURL(HttpURLConnection connection)
                          throws IOException,
                                 HTTPActionEventHandlerException
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

このメソッドは、HTTPActionEventHandler.execute(HttpURLConnection) の結果を HTTPActionEventURL インターフェースでラップして返します。

戻り値:
実行結果オブジェクト
例外:
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.service.client.batch.Scheduler の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.batch.Scheduler の使用

jp.co.intra_mart.foundation.service.client.batch.Scheduler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.service.client.batch (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.service.client.batch
クラス
Scheduler


jp.co.intra_mart.foundation.service.client.batch (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.batch

Schedule Service を利用するためのクラスを提供します。

参照:
説明

クラスの概要
Scheduler Schedule Service の制御をするオブジェクトです。

パッケージ jp.co.intra_mart.foundation.service.client.batch の説明

Schedule Service を利用するためのクラスを提供します。

Schedule Service の情報を取得したり、Schedule Service でプログラムを実行することの できるクラスが用意されています。

導入されたバージョン:
version 3.1


jp.co.intra_mart.foundation.service.client.batch クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.batch の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.client.NetworkConnector (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.service.client.NetworkAgent (implements jp.co.intra_mart.foundation.service.client.ActionListener)
        • class jp.co.intra_mart.foundation.service.client.batch.Scheduler (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.service.client.batch の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client.batch の使用

jp.co.intra_mart.foundation.service.client.batch はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Scheduler (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.batch
クラス Scheduler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
            拡張 jp.co.intra_mart.foundation.service.client.batch.Scheduler
すべての実装インタフェース:
ActionListener, Serializable
public class Scheduler
extends NetworkAgent
implements Serializable

Schedule Service の制御をするオブジェクトです。

このオブジェクトのすべてのメソッドは、Schedule Service に対する オペレーションになります。
このオブジェクトの各メソッド実行時は、Schedule Service と通信を行います。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したフィールド
NULL_DATA
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
Scheduler()
新しいオブジェクトを構築します。
メソッドの概要
Object | action(Object args) 推奨されていません。
protected SocketConnection | connection() サーバに接続するためのコネクションを取得します。
boolean | defineInitializeTime(int hour, int minute, int second) バッチ初期化時間の設定。
void | executeBatchProgram(String loginGroupId, String batchId) バッチプログラムを実行します。
String | initializeTime() バッチ初期化時間の取得。
boolean | isAlive() スケジューラが動作しているかどうかをチェックします。
boolean | restart() スケジューラの再開通知。
boolean | start() スケジューラの開始通知。
boolean | stop() スケジューラの停止通知。
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したメソッド
execute
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Scheduler

public Scheduler()
新しいオブジェクトを構築します。

メソッドの詳細

connection

protected SocketConnection connection()
                               throws IOException
サーバに接続するためのコネクションを取得します。

定義:
クラス NetworkConnector 内の connection
戻り値:
コネクション
例外:
IOException - 入出力エラー

start

public boolean start()
              throws IOException
スケジューラの開始通知。

スケジューラが動作を開始すると、バッチ設定に基づいて、 指定時刻に指定されたバッチプログラムを実行します。
Schedule Service は開始通知を受けると、バッチ初期化時間まで待機状態となり、 バッチプログラムの実行は現在に最も近い未来のバッチ初期化時間以降と なります。

restart() メソッドとの違いは、start() メソッドの場合、 現在から現在に最も近い未来のバッチ初期化時間までのバッチ設定を 無視します。

戻り値:
スケジューラが動作を開始した場合 true、そうでない場合 false。
例外:
IOException - 入出力エラー
関連項目:
restart()

restart

public boolean restart()
                throws IOException
スケジューラの再開通知。

スケジューラが動作を開始すると、バッチ設定に基づいて、 指定時刻に指定されたバッチプログラムを実行します。
Schedule Service は再開通知を受けると、即時に スケジューラとして動作を開始します。

start() メソッドとの違いは、restart() メソッドの場合、 現在から現在に最も近い未来のバッチ初期化時間までのバッチ設定を 読み込んで即時に実行可能状態になる点にあります。

戻り値:
スケジューラが動作を開始した場合 true、そうでない場合 false。
例外:
IOException - 入出力エラー
関連項目:
start()

stop

public boolean stop()
             throws IOException
スケジューラの停止通知。

Schedule Serviceは停止通知を受けると、 スケジューラとして動作を停止します。

通知前に実行状態に入ったバッチプログラムは、そのバッチプログラムが 終了するまで実行を継続します。

戻り値:
スケジューラが動作を停止した場合 true、そうでない場合 false。
例外:
IOException - 入出力エラー
関連項目:
start(), restart()

isAlive

public boolean isAlive()
                throws IOException
スケジューラが動作しているかどうかをチェックします。

戻り値:
スケジューラが動作している場合 true、そうでない場合 false。
例外:
IOException - 入出力エラー
関連項目:
start(),
restart(),
stop()

defineInitializeTime

public boolean defineInitializeTime(int hour,
                                    int minute,
                                    int second)
                             throws IOException
バッチ初期化時間の設定。

パラメータ:
hour - 初期化時間（時間）
minute - 初期化時間（分）
second - 初期化時間（秒）
戻り値:
設定が正しく行われた場合 true、そうでない場合 false。
例外:
IOException - 入出力エラー

initializeTime

public String initializeTime()
                      throws IOException
バッチ初期化時間の取得。

バッチ初期化時間は『00:00:00』というフォーマットされた文字列で 返されます。 初期化時間設定の文字列化に失敗した場合 null が返されます。

戻り値:
バッチ初期化時間
例外:
IOException - 入出力エラー

executeBatchProgram

public void executeBatchProgram(String loginGroupId,
                                String batchId)
                         throws IOException
バッチプログラムを実行します。
ログイングループIDとバッチIDで特定されるバッチプログラムを実行します。

本メソッドを実行すると、Schedule Serviceにバッチプログラムの実行開始要求を送信します。
その要求を受け付けたSchedule Serviceでは、 新しいスレッドを作成してバッチプログラムの実行を開始します。
バッチプログラムの実行結果は、バッチログを参照してください。

なお、本メソッドは、バッチプログラムの実行開始要求を送信するためのものであり、 バッチプログラムのテスト用に用意されたものではありません。
（つまり、本メソッドを利用してバッチプログラムの実行結果を取得することは出来ません）

パラメータ:
loginGroupId - ログイングループID
batchId - バッチID
例外:
IOException - 入出力エラー

action

public final Object action(Object args)
推奨されていません。

処理ロジックの実行。

定義:
インタフェース ActionListener 内の action
定義:
クラス NetworkAgent 内の action
パラメータ:
args - 実行時引数
戻り値:
任意の実行結果
例外:
IllegalArgumentException - 想定外の通信（プロトコル違反）
関連項目:
NetworkAgent.execute(Object)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.service.client.ActionListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.client.ActionListener の使用

ActionListener を使用しているパッケージ
jp.co.intra_mart.foundation.service.client | このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.client.batch | Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file | Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client での ActionListener の使用

ActionListener を実装している jp.co.intra_mart.foundation.service.client のクラス
 class NetworkAgent
このクラスは、他のサーバで実行されるロジックを実装する ためのスケルトンを提供します。

ActionListener 型のパラメータを持つ jp.co.intra_mart.foundation.service.client のメソッド
 Object NetworkConnector.execute(ActionListener target, Object arg)
サーバに対して実行要求をします。

jp.co.intra_mart.foundation.service.client.batch での ActionListener の使用

ActionListener を実装している jp.co.intra_mart.foundation.service.client.batch のクラス
 class Scheduler
Schedule Service の制御をするオブジェクトです。

jp.co.intra_mart.foundation.service.client.file での ActionListener の使用

ActionListener を実装している jp.co.intra_mart.foundation.service.client.file のクラス
class | AbstractComponent このクラスは、Storage Service で実行される ロジックを実装するためのスケルトンを提供します。
class | NetworkFile Storage Service のファイルを扱う事の出来るオブジェクトです。

jp.co.intra_mart.foundation.service.client.information での ActionListener の使用

ActionListener を実装している jp.co.intra_mart.foundation.service.client.information のクラス
class | ExternalDirectory 共有データグループを管理するオブジェクトです。
class | ExternalMemory 共有データを管理するオブジェクトです。
class | Lock アプリケーションロックをするための機能を提供します。
class | PermanentDirectory ファイルベースでデータを保存します。
class | PermanentFile ファイルベースでデータを保存します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.NetworkAgent の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.NetworkAgent の使用

NetworkAgent を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.batch | Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file | Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.batch での NetworkAgent の使用

jp.co.intra_mart.foundation.service.client.batch での NetworkAgent のサブクラス
 class Scheduler
Schedule Service の制御をするオブジェクトです。

jp.co.intra_mart.foundation.service.client.file での NetworkAgent の使用

jp.co.intra_mart.foundation.service.client.file での NetworkAgent のサブクラス
class | AbstractComponent このクラスは、Storage Service で実行される ロジックを実装するためのスケルトンを提供します。
class | NetworkFile Storage Service のファイルを扱う事の出来るオブジェクトです。

jp.co.intra_mart.foundation.service.client.information での NetworkAgent の使用

jp.co.intra_mart.foundation.service.client.information での NetworkAgent のサブクラス
class | ExternalDirectory 共有データグループを管理するオブジェクトです。
class | ExternalMemory 共有データを管理するオブジェクトです。
class | Lock アプリケーションロックをするための機能を提供します。
class | PermanentDirectory ファイルベースでデータを保存します。
class | PermanentFile ファイルベースでデータを保存します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.NetworkConnector の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.NetworkConnector の使用

NetworkConnector を使用しているパッケージ
jp.co.intra_mart.foundation.service.client | このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.client.batch | Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file | Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.manager | このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。

jp.co.intra_mart.foundation.service.client での NetworkConnector の使用

jp.co.intra_mart.foundation.service.client での NetworkConnector のサブクラス
 class NetworkAgent
このクラスは、他のサーバで実行されるロジックを実装する ためのスケルトンを提供します。

jp.co.intra_mart.foundation.service.client.batch での NetworkConnector の使用

jp.co.intra_mart.foundation.service.client.batch での NetworkConnector のサブクラス
 class Scheduler
Schedule Service の制御をするオブジェクトです。

jp.co.intra_mart.foundation.service.client.file での NetworkConnector の使用

jp.co.intra_mart.foundation.service.client.file での NetworkConnector のサブクラス
class | AbstractComponent このクラスは、Storage Service で実行される ロジックを実装するためのスケルトンを提供します。
class | NetworkFile Storage Service のファイルを扱う事の出来るオブジェクトです。

jp.co.intra_mart.foundation.service.client.information での NetworkConnector の使用

jp.co.intra_mart.foundation.service.client.information での NetworkConnector のサブクラス
class | ExternalDirectory 共有データグループを管理するオブジェクトです。
class | ExternalMemory 共有データを管理するオブジェクトです。
class | Lock アプリケーションロックをするための機能を提供します。
class | PermanentDirectory ファイルベースでデータを保存します。
class | PermanentFile ファイルベースでデータを保存します。

jp.co.intra_mart.foundation.service.client.manager での NetworkConnector の使用

jp.co.intra_mart.foundation.service.client.manager での NetworkConnector のサブクラス
 class ServerConnector
このクラスは、Server-Manager にリクエストを送信して 処理を要求するためのオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.file.AbstractComponent の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.file.AbstractComponent の使用

AbstractComponent を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.file Storage Service を利用するためのクラスを提供します。

jp.co.intra_mart.foundation.service.client.file での AbstractComponent の使用

jp.co.intra_mart.foundation.service.client.file での AbstractComponent のサブクラス
 class NetworkFile
Storage Service のファイルを扱う事の出来るオブジェクトです。

AbstractComponent を返す jp.co.intra_mart.foundation.service.client.file のメソッド
static AbstractComponent AbstractComponent.getInstance()
このクラスの新しいインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.file.NetworkFile の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.file.NetworkFile の使用

NetworkFile を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database での NetworkFile の使用

NetworkFile 型のパラメータを持つ jp.co.intra_mart.foundation.database のメソッド
int | DatabaseExport.exportCSV(PreparedStatement stmt, NetworkFile file, boolean isTitle) 推奨されていません。 CSVファイルをストレージに出力します。
int | DatabaseExport.exportCSV(PreparedStatement stmt, NetworkFile file, int startIndex, int maxRow, boolean isTitle) 推奨されていません。 CSVファイルをストレージに出力します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AbstractComponent (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.file
クラス AbstractComponent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
            拡張 jp.co.intra_mart.foundation.service.client.file.AbstractComponent
すべての実装インタフェース:
ActionListener, Serializable
直系の既知のサブクラス:
NetworkFile
public abstract class AbstractComponent
extends NetworkAgent
implements Serializable

このクラスは、Storage Service で実行される ロジックを実装するためのスケルトンを提供します。
このクラスを継承したサブクラスでは、他のサーバでロジックを実行するための メソッドと実際にサーバで実行されるロジックを定義する必要があります。
また、サブクラスは直列化可能なクラスである必要があります。 サブクラスが直列化できない場合、ロジックの呼び出し時に例外がスローされます。

関連項目:
NetworkAgent, 直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したフィールド
NULL_DATA
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
protected AbstractComponent()
唯一のコンストラクタ。
メソッドの概要
protected SocketConnection | connection() サーバに接続するためのコネクションを取得します。
static AbstractComponent | getInstance() このクラスの新しいインスタンスを取得します。
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したメソッド
action, execute
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractComponent

protected AbstractComponent()
唯一のコンストラクタ。

メソッドの詳細

connection

protected SocketConnection connection()
                               throws IOException
サーバに接続するためのコネクションを取得します。

定義:
クラス NetworkConnector 内の connection
戻り値:
コネクション
例外:
IOException - 入出力エラーが発生した場合

getInstance

public static AbstractComponent getInstance()
このクラスの新しいインスタンスを取得します。

戻り値:
このクラスから生成されるインスタンス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


NetworkFile (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.file
クラス NetworkFile

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
            拡張 jp.co.intra_mart.foundation.service.client.file.AbstractComponent
                拡張 jp.co.intra_mart.foundation.service.client.file.NetworkFile
すべての実装インタフェース:
ActionListener, Serializable
public class NetworkFile
extends AbstractComponent
implements Serializable

Storage Service のファイルを扱う事の出来るオブジェクトです。

このオブジェクトのすべてのメソッドは、Storage Service に対する オペレーションになります。
分散サーバ形態で運用している場合、他のコンピュータに 保管されているファイルを扱う事が出来ます。 このオブジェクトの各メソッド実行時は、Storage Service と通信を行います。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したフィールド
NULL_DATA
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
NetworkFile(String path)
新しいオブジェクトを構築します。
メソッドの概要
Object | action(Object args) 推奨されていません。
boolean | append(String src) ファイルにテキストを追記します。
Collection | directories() ディレクトリ中のサブディレクトリの一覧を取得します。
boolean | exists() このパス名が示すファイルが存在するかどうかを判定します。
Collection | files() ディレクトリ中のファイルの一覧を取得します。
String | getPath() このオブジェクトが表すパスを返します。
boolean | isDirectory() このパス名が示すファイルがディレクトリであるかどうかを判定します。
boolean | isFile() このパス名が示すファイルが普通のファイルかどうかを判定します。
long | lastModified() このパス名が示すファイルが最後に変更された時刻を返します。
long | length() このパス名が示すファイルの長さを返します。
Collection | lists() ディレクトリ中のファイルの一覧を取得します。
byte[] | load() ファイルの内容を取得します。
boolean | makeDirectories() このパス名が示すディレクトリを生成します。
boolean | move(String newPath) このパス名が示すファイルの名前を変更します。
String | read() ファイルの内容を取得します。
boolean | remove() このパス名が示すファイルまたはディレクトリを削除します。
boolean | save(byte[] byteStream) ファイルにバイトを出力します。
boolean | write(String src) ファイルにテキストを出力します。
クラス jp.co.intra_mart.foundation.service.client.file.AbstractComponent から継承したメソッド
connection, getInstance
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したメソッド
execute
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NetworkFile

public NetworkFile(String path)
新しいオブジェクトを構築します。

このインスタンスは、Storage Service のファイル管理ディレクトリ(標準では storage/)以下の path で アクセスできるファイルまたはディレクトリを扱う事が出来ます。

パラメータ:
path - パス名
例外:
NullPointerException - 引数が null
メソッドの詳細

getPath

public String getPath()
このオブジェクトが表すパスを返します。 このメソッドは、コンストラクタで指定されたパスをそのまま返します。

戻り値:
パス

files

public Collection files()
                 throws IOException
ディレクトリ中のファイルの一覧を取得します。

コレクションの各要素は String です。

戻り値:
ファイル名一覧
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

directories

public Collection directories()
                       throws IOException
ディレクトリ中のサブディレクトリの一覧を取得します。

コレクションの各要素は String です。

戻り値:
サブディレクトリ名一覧
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

lists

public Collection lists()
                 throws IOException
ディレクトリ中のファイルの一覧を取得します。

ディレクトリに含まれるすべてのファイルを検索します。
ファイル名の取得対象は、サブディレクトリに存在するファイルも含まれます。
ディレクトリは取得対象ではありません。
コレクションの各要素は String です。

戻り値:
ファイル一覧
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

read

public String read()
            throws IOException
ファイルの内容を取得します。

ファイル内のテキストを Unicode に変換して返します。
テキストは、Storage Service の動作している Service Platform のサーバ側文字コードに設定されている文字コードで あるものとして読み込みます。

以下の場合は、空文字列が返却されます。
・対象パスのファイルが存在しない
・対象パスがディレクトリ
・対象パスのファイルの内容が空

戻り値:
ファイルの内容
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

write

public boolean write(String src)
              throws IOException
ファイルにテキストを出力します。

指定の内容のテキストファイルを作成します。 すでにファイルが存在している場合は、上書きされます。
ファイルに書き出されたテキストは、Storage Service の動作している Service Platform のサーバ側文字コードに設定されている文字コードに 変換されています。

このメソッドは、ファイルに出力する文字を文字コード変換する際に、 AdvancedOutputStreamWriter を利用しています。 これにより、Java-VM が持つ文字コード間のマッピングに起因した文字化けに 対して、いくつかの文字の文字化けを回避しています。 文字化けを回避できる文字については、 CharacterEncoder の仕様を参照してください。

パラメータ:
src - ファイルに書き出すテキスト
戻り値:
ファイルへのテキストの書き出しに成功した場合 true
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

append

public boolean append(String src)
               throws IOException
ファイルにテキストを追記します。

指定の内容をテキストファイルに追記します。 すでにファイルが存在している場合は、追記されます。 ファイルが存在していない場合、新しいファイルを作成します。
ファイルに書き出されたテキストは、Storage Service の動作している Service Platform のサーバ側文字コードに設定されている文字コードに 変換されています。

このメソッドは、ファイルに出力する文字を文字コード変換する際に、 AdvancedOutputStreamWriter を利用しています。 これにより、Java-VM が持つ文字コード間のマッピングに起因した文字化けに 対して、いくつかの文字の文字化けを回避しています。 文字化けを回避できる文字については、 CharacterEncoder の仕様を参照してください。

パラメータ:
src - ファイルに書き出すテキスト
戻り値:
ファイルへのテキストの書き出しに成功した場合 true
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

load

public byte[] load()
            throws IOException
ファイルの内容を取得します。

ファイルデータはバイナリ形式で取得されます。

以下の場合は、空の配列が返却されます。
・対象パスのファイルの内容が空

また以下の場合は、nullが返却されます。
・対象パスのファイルが存在しない
・対象パスがディレクトリ

戻り値:
バイト列
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

save

public boolean save(byte[] byteStream)
             throws IOException
ファイルにバイトを出力します。

指定の内容のファイルを作成します。 すでにファイルが存在している場合は、上書きされます。 ファイルが存在していない場合、新しいファイルを作成します。

パラメータ:
byteStream - ファイルに書き出すバイト
戻り値:
ファイルへのバイト列の書き出しに成功した場合 true
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

makeDirectories

public boolean makeDirectories()
                        throws IOException
このパス名が示すディレクトリを生成します。

存在していないが必要な親ディレクトリも一緒に作成されます。 このオペレーションが失敗した場合でも、いくつかの必要な 親ディレクトリの生成には成功した場合があります。

戻り値:
必要なすべての親ディレクトリを含めてディレクトリが作成された場合 は true、そうでない場合は false
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

remove

public boolean remove()
               throws IOException
このパス名が示すファイルまたはディレクトリを削除します。

このパス名がディレクトリを示す場合、 そのディレクトリが削除されるためには空である必要があります。

戻り値:
ファイルまたはディレクトリが正常に削除された場合は true、そうでない場合は false
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

move

public boolean move(String newPath)
             throws IOException
このパス名が示すファイルの名前を変更します。

パラメータ:
newPath - 示されたファイルの新しいパス名
戻り値:
名前の変更が成功した場合は true、そうでない場合は false
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

exists

public boolean exists()
               throws IOException
このパス名が示すファイルが存在するかどうかを判定します。

戻り値:
このパス名が示すファイルが存在する場合は true、 そうでない場合は false
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

isFile

public boolean isFile()
               throws IOException
このパス名が示すファイルが普通のファイルかどうかを判定します。

ファイルは、それがディレクトリではなく、システムに依存するほかの 基準を満たす場合に「普通」のファイルと見なされます。 このオブジェクトにより生成されたディレクトリ以外のファイルは、 必ず普通のファイルです。

戻り値:
このパス名が示すファイルが存在し、 それが普通のファイルである場合は true、 そうでない場合は false
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

isDirectory

public boolean isDirectory()
                    throws IOException
このパス名が示すファイルがディレクトリであるかどうかを判定します。

戻り値:
このパス名が示すファイルが存在し、 それがディレクトリである場合は true、 そうでない場合は false
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

lastModified

public long lastModified()
                  throws IOException
このパス名が示すファイルが最後に変更された時刻を返します。

戻り値:
ファイルが最後に変更された時刻を表す long 値。 エポック (00:00:00 GMT, January 1, 1970) からミリ秒単位で測定。 ファイルが存在しないか、入出力エラーが発生した場合は 0L
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

length

public long length()
            throws IOException
このパス名が示すファイルの長さを返します。

戻り値:
このパス名が示すファイルの長さ (バイト単位)、 ファイルが存在しない場合は 0L
例外:
IOException - 入出力エラーまたは対象パスに使用できない文字が使用されていた場合

action

public Object action(Object args)
推奨されていません。

処理ロジックの実行。

定義:
インタフェース ActionListener 内の action
定義:
クラス NetworkAgent 内の action
パラメータ:
args - 実行時引数
戻り値:
実行結果
関連項目:
NetworkAgent.execute(Object)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.client.file (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.service.client.file
クラス
AbstractComponent
NetworkFile


jp.co.intra_mart.foundation.service.client.file (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.file

Storage Service を利用するためのクラスを提供します。

参照:
説明

クラスの概要
AbstractComponent | このクラスは、Storage Service で実行される ロジックを実装するためのスケルトンを提供します。
NetworkFile | Storage Service のファイルを扱う事の出来るオブジェクトです。

パッケージ jp.co.intra_mart.foundation.service.client.file の説明

Storage Service を利用するためのクラスを提供します。

Storage Service の情報を取得したり、Storage Service でプログラムを実行することの できるクラスが用意されています。
Storage Service が別なプロセスとしてサービスを提供している場合、 このパッケージのクラスは、ネットワークにより Storage Service に対して アクセスを試みます。 これにより、intra-mart サーバの運用形態が変更されても、 プログラマはまったく意識することなく、 Storage Service を利用することができます。


jp.co.intra_mart.foundation.service.client.file クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.file の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.client.NetworkConnector (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.service.client.NetworkAgent (implements jp.co.intra_mart.foundation.service.client.ActionListener)
        • class jp.co.intra_mart.foundation.service.client.file.AbstractComponent (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.service.client.file.NetworkFile (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.service.client.file の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client.file の使用

jp.co.intra_mart.foundation.service.client.file を使用しているパッケージ
jp.co.intra_mart.foundation.database | データベースへアクセスするためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file | Storage Service を利用するためのクラスを提供します。

jp.co.intra_mart.foundation.database により使用される jp.co.intra_mart.foundation.service.client.file のクラス
NetworkFile
Storage Service のファイルを扱う事の出来るオブジェクトです。

jp.co.intra_mart.foundation.service.client.file により使用される jp.co.intra_mart.foundation.service.client.file のクラス
AbstractComponent
このクラスは、Storage Service で実行される ロジックを実装するためのスケルトンを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.ExternalDirectory の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.ExternalDirectory の使用

ExternalDirectory を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.information このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.information での ExternalDirectory の使用

ExternalDirectory を返す jp.co.intra_mart.foundation.service.client.information のメソッド
static ExternalDirectory ExternalDirectory.getInstance(String dir)
共有データを扱うためのオブジェクトを取得します。

ExternalDirectory 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.information のコンストラクタ
ExternalMemory(ExternalDirectory parent, String id)
共有データを扱うための新しいオブジェクトを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.ExternalMemory の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.ExternalMemory の使用

jp.co.intra_mart.foundation.service.client.information.ExternalMemory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.Identifier の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.Identifier の使用

jp.co.intra_mart.foundation.service.client.information.Identifier はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.InitialFile の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.InitialFile の使用

jp.co.intra_mart.foundation.service.client.information.InitialFile はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.Lock の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.Lock の使用

jp.co.intra_mart.foundation.service.client.information.Lock はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.PermanentDirectory の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.PermanentDirectory の使用

PermanentDirectory を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.information このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.information での PermanentDirectory の使用

PermanentDirectory を返す jp.co.intra_mart.foundation.service.client.information のメソッド
static PermanentDirectory PermanentDirectory.getInstance(String dir)
共有データを扱うためのオブジェクトを取得します。

PermanentDirectory 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.information のコンストラクタ
PermanentFile(PermanentDirectory parent, String id)
共有データを扱うための新しいオブジェクトを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.PermanentFile の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.PermanentFile の使用

jp.co.intra_mart.foundation.service.client.information.PermanentFile はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.SessionFactory の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.SessionFactory の使用

jp.co.intra_mart.foundation.service.client.information.SessionFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.SessionMemory の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.SessionMemory の使用

SessionMemory を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.information このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.information での SessionMemory の使用

SessionMemory を返す jp.co.intra_mart.foundation.service.client.information のメソッド
SessionMemory | SessionFactory.getFile() 現在有効なセッションを扱う SessionMemory インスタンスを取得します。
SessionMemory | SessionFactory.entry() 新しい空のセッションを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.client.information.TreasureDirectory の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.client.information.TreasureDirectory の使用

TreasureDirectory を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.information このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.information での TreasureDirectory の使用

TreasureDirectory を実装している jp.co.intra_mart.foundation.service.client.information のクラス
class | ExternalDirectory 共有データグループを管理するオブジェクトです。
class | PermanentDirectory ファイルベースでデータを保存します。
class | SessionFactory 共有データグループを管理するオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.client.information.TreasureFile の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.client.information.TreasureFile の使用

TreasureFile を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.information このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.information での TreasureFile の使用

TreasureFile を実装している jp.co.intra_mart.foundation.service.client.information のクラス
class | ExternalMemory 共有データを管理するオブジェクトです。
class | PermanentFile ファイルベースでデータを保存します。
class | SessionMemory 共有データを管理するオブジェクトです。

TreasureFile を返す jp.co.intra_mart.foundation.service.client.information のメソッド
TreasureFile | TreasureDirectory.getFile(String id) このオブジェクトの表すディレクトリにキー id でマップされた TreasureFile インスタンスを取得します。
TreasureFile | TreasureDirectory.entry(String id) 空のグループを作成します。
TreasureFile | SessionFactory.getFile(String id) このオブジェクトの表すディレクトリにキー id でマップされた SessionMemory インスタンスを取得します。
TreasureFile | SessionFactory.entry(String id) 新しい空のセッションを作成します。
TreasureFile | PermanentDirectory.getFile(String id) このオブジェクトの表すディレクトリにキー id でマップされた PermanentFile インスタンスを取得します。
TreasureFile | PermanentDirectory.entry(String id) 空のグループを作成します。
TreasureFile | ExternalDirectory.getFile(String id) このオブジェクトの表すディレクトリにキー id でマップされた ExternalMemory インスタンスを取得します。
TreasureFile | ExternalDirectory.entry(String id) 空のグループを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ExternalDirectory (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス ExternalDirectory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
            拡張 jp.co.intra_mart.foundation.service.client.information.ExternalDirectory
すべての実装インタフェース:
ActionListener, Serializable, TreasureDirectory
public class ExternalDirectory
extends NetworkAgent
implements Serializable, TreasureDirectory

共有データグループを管理するオブジェクトです。

グループ化された共有データのグループに関する情報を操作します。 各グループに保存されているデータの取得や各グループへのデータの保存には、 ExternalMemory クラスを利用します。
このオブジェクトにより扱うデータは、Shared Memory Service で一元管理されます。 そのため、intra-mart の各サーバモジュールを分散は位置している場合、 このオブジェクトの各メソッド実行時は、Shared Memory Service と通信を行います。

このオブジェクトで保管されるデータは、Shared Memory Service のメモリ中で 管理され、Shared Memory Service が動作している間、その存在が保証されます。

導入されたバージョン:
version 3.1
関連項目:
ExternalMemory, 直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したフィールド
NULL_DATA
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
protected ExternalDirectory(String dir)
共有データを扱うための新しいオブジェクトを構築します。
メソッドの概要
Object | action(Object argV) 推奨されていません。
protected SocketConnection | connection() サーバに接続するためのコネクションを取得します。
Map | destroy(String id) グループデータを削除します。
List | entries() このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。
TreasureFile | entry(String id) 空のグループを作成します。
TreasureFile | getFile(String id) このオブジェクトの表すディレクトリにキー id でマップされた ExternalMemory インスタンスを取得します。
static ExternalDirectory | getInstance(String dir) 共有データを扱うためのオブジェクトを取得します。
String | getName() このオブジェクトの表すディレクトリ名称を取得します。
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したメソッド
execute
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExternalDirectory

protected ExternalDirectory(String dir)
共有データを扱うための新しいオブジェクトを構築します。

このインスタンスは、dir に保存されている共有データ に関する情報を扱えます。

メソッドの詳細

getInstance

public static ExternalDirectory getInstance(String dir)
共有データを扱うためのオブジェクトを取得します。

このインスタンスは、dir に保存されている共有データ に関する情報を扱えます。

パラメータ:
dir - 保存ディレクトリ
例外:
NullPointerException - 引数が null

connection

protected SocketConnection connection()
                               throws IOException
サーバに接続するためのコネクションを取得します。

定義:
クラス NetworkConnector 内の connection
戻り値:
コネクション
例外:
IOException - 入出力エラーが発生した場合

getName

public String getName()
このオブジェクトの表すディレクトリ名称を取得します。

定義:
インタフェース TreasureDirectory 内の getName
戻り値:
このオブジェクトの表すディレクトリ名称

getFile

public TreasureFile getFile(String id)
このオブジェクトの表すディレクトリにキー id でマップされた ExternalMemory インスタンスを取得します。

定義:
インタフェース TreasureDirectory 内の getFile
戻り値:
ExternalMemory インスタンス

entries

public List entries()
             throws IOException,
                    ClassNotFoundException
このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。

コレクションの各要素は String です。

定義:
インタフェース TreasureDirectory 内の entries
戻り値:
グループＩＤのリスト
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー

entry

public TreasureFile entry(String id)
                   throws IOException
空のグループを作成します。

すでにグループが存在していた場合、このメソッドは何もしません。
このメソッドで作成されたグループにはデータが存在しません。
グループを作成する事により、entries() で取得できるグループリストに このオブジェクトが表すグループが含まれます。
返却値としてグループ id のデータを扱うためのオブジェクトを返します。

定義:
インタフェース TreasureDirectory 内の entry
パラメータ:
id - グループ
戻り値:
TreasureFile インスタンス
例外:
NullPointerException - 引数が null
IOException - 入出力エラー
関連項目:
entries()

destroy

public Map destroy(String id)
            throws IOException,
                   ClassNotFoundException
グループデータを削除します。

id に属する共有データをすべて削除し、 共有データ領域から id に属するデータを保管する領域も削除します。 このメソッドが実行されると entries() で取得できるグループリストに このオブジェクトが示すグループが含まれなくなります。

返却値は、id に属していたデータ一覧になります。返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureDirectory 内の destroy
戻り値:
id に属するデータ一覧
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

action

public Object action(Object argV)
推奨されていません。

処理ロジック。

定義:
インタフェース ActionListener 内の action
定義:
クラス NetworkAgent 内の action
パラメータ:
argV - 引数
戻り値:
実行結果
関連項目:
NetworkAgent.action(Object), NetworkAgent.execute(Object)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExternalMemory (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス ExternalMemory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
            拡張 jp.co.intra_mart.foundation.service.client.information.ExternalMemory
すべての実装インタフェース:
ActionListener, Serializable, TreasureFile
public class ExternalMemory
extends NetworkAgent
implements Serializable, TreasureFile

共有データを管理するオブジェクトです。

共有データはグループ化させて保存することができます。 グループ化にはグループＩＤを用い、このグループＩＤがそれぞれの グループ間でユニークである必要があります。 グループ化された共有データのグループ情報に関しては、 ExternalDirectory クラスを利用することによりアクセスすることができます。
このオブジェクトにより扱うデータは、Shared Memory Service で一元管理されます。 そのため、intra-mart の各サーバモジュールを分散配置している場合、 このオブジェクトの各メソッド実行時は、Shared Memory Service と通信を行います。

このオブジェクトで保管されるデータは、Shared Memory Service のメモリ中で 管理され、Shared Memory Service が動作している間、その存在が保証されます。

導入されたバージョン:
version 3.1
関連項目:
ExternalDirectory, 直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したフィールド
NULL_DATA
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
protected | ExternalMemory(ExternalDirectory parent, String id) 共有データを扱うための新しいオブジェクトを構築します。
protected | ExternalMemory(String parent, String id) 共有データを扱うための新しいオブジェクトを構築します。
メソッドの概要
Object | action(Object argV) 推奨されていません。
void | clear() データを削除します。
protected SocketConnection | connection() サーバに接続するためのコネクションを取得します。
Map | entryMap() グループデータを取得します。
Object | get(String key) データを取得します。
String | getName() このインスタンスが表すグループＩＤを取得します。
List | keyList() キー一覧を取得します。
Object | put(String key, Object value) データを保存します。
void | putAll(Map list) データを保存します。
Object | remove(String key) データを削除します。
Map | subMap(String[] keys) データを取得します。
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したメソッド
execute
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExternalMemory

protected ExternalMemory(String parent,
                         String id)
                  throws NullPointerException
共有データを扱うための新しいオブジェクトを構築します。

このインスタンスは、parent に保存されている共有データの中の id に属するデータを扱えます。 domain に保存されているデータや、他の id に属するデータを扱う事は できません。

パラメータ:
parent - 親ディレクトリ名称
id - グループ
例外:
NullPointerException - 引数が null

ExternalMemory

protected ExternalMemory(ExternalDirectory parent,
                         String id)
                  throws NullPointerException
共有データを扱うための新しいオブジェクトを構築します。

このインスタンスは、parent に保存されている共有データの中の id に属するデータを扱えます。 domain に保存されているデータや、他の id に属するデータを扱う事は できません。

パラメータ:
parent - 親ディレクトリ
id - グループ
例外:
NullPointerException - 引数が null
メソッドの詳細

connection

protected SocketConnection connection()
                               throws IOException
サーバに接続するためのコネクションを取得します。

定義:
クラス NetworkConnector 内の connection
戻り値:
コネクション
例外:
IOException - 入出力エラーが発生した場合

getName

public String getName()
このインスタンスが表すグループＩＤを取得します。

定義:
インタフェース TreasureFile 内の getName
戻り値:
グループＩＤ

put

public Object put(String key,
                  Object value)
           throws IOException,
                  ClassNotFoundException,
                  OptionalDataException
データを保存します。

id に属する共有データとして key と value をマップします。 id が存在していない場合、新しいグループが作成されます。
返却値は、key にマップされていたデータになります。返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の put
パラメータ:
key - データを保存するキー
value - 保存するデータ
戻り値:
key にマップされていた値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

putAll

public void putAll(Map list)
            throws IOException
データを保存します。

id に属する共有データとして list をマップに追加します。 id が存在していない場合、新しいグループが作成されます。
list 内のキーがすでにマップに存在している場合、list のマップ情報で 上書きされます。

定義:
インタフェース TreasureFile 内の putAll
パラメータ:
list - データ
例外:
IOException - 入出力エラー

get

public Object get(String key)
           throws IOException,
                  ClassNotFoundException
データを取得します。

id に属する共有データの中から key にマップされているデータを 取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の get
パラメータ:
key - キー
戻り値:
key にマップされている値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

subMap

public Map subMap(String[] keys)
           throws IOException,
                  ClassNotFoundException
データを取得します。

id に属する共有データの中から keys の各要素にマップされているデータ群を取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の subMap
パラメータ:
keys - キーの配列
戻り値:
指定されたキーとそのキーにマップされている値を持つマップ。指定したキーが存在しなかった場合、マップはそのキーを持ちません。
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー
NullPointerException - 引数が null の場合
導入されたバージョン:
version 5.0

entryMap

public Map entryMap()
             throws IOException,
                    ClassNotFoundException
グループデータを取得します。

このマップのデータ一覧を取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の entryMap
戻り値:
このマップの全データ
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

clear

public void clear()
           throws IOException
データを削除します。

id に属する共有データをすべて削除します。

定義:
インタフェース TreasureFile 内の clear
例外:
IOException - 入出力エラー

remove

public Object remove(String key)
              throws IOException,
                     ClassNotFoundException
データを削除します。

id に属するデータの中から key にマップされているデータを 削除します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の remove
パラメータ:
key - キー
戻り値:
key にマップされている値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

keyList

public List keyList()
             throws IOException,
                    ClassNotFoundException
キー一覧を取得します。

id に属するデータとしてマップされている key のリストを 取得します。

実行環境のバージョン等が異なると ClassNotFoundException がスロー される事があります。
コレクションの各要素は String です。

定義:
インタフェース TreasureFile 内の keyList
戻り値:
マップされているキーのリスト
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー

action

public Object action(Object argV)
推奨されていません。

処理ロジック。

定義:
インタフェース ActionListener 内の action
定義:
クラス NetworkAgent 内の action
パラメータ:
argV - 引数
戻り値:
実行結果
関連項目:
NetworkAgent.action(Object), NetworkAgent.execute(Object)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Identifier (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス Identifier

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.information.Identifier
public final class Identifier
extends Object

ユニークなＩＤを生成する機能を提供します。

このオブジェクトは、システム全体で一意性が保証されるＩＤを生成します。 そのため、intra-mart の各サーバモジュールを分散は位置している場合、 このオブジェクトのget() メソッド実行時は、 共通の Server Manager に管理されているすべてのプロセスで一意性を保証 されたＩＤを扱うことができます。

コンストラクタの概要
Identifier()
唯一のコンストラクタ。
メソッドの概要
String | get() 一意性を保証されたＩＤを取得します。
static String | make()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Identifier

public Identifier()
唯一のコンストラクタ。

メソッドの詳細

get

public String get()
           throws IOException
一意性を保証されたＩＤを取得します。 生成される文字列の長さは 15 バイトです。

戻り値:
ＩＤ
例外:
IOException - Server Manager との通信エラー

make

public static String make()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InitialFile (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス InitialFile

java.lang.Object
    拡張 java.util.Dictionary
        拡張 java.util.Hashtable
            拡張 java.util.Properties
                拡張 jp.co.intra_mart.foundation.service.client.information.InitialFile
すべての実装インタフェース:
Cloneable, Map, Serializable
public final class InitialFile
extends Properties

設定ファイル(*.ini)の内容を読み込むためのクラスです。

このクラスは、Resource Service のリソースディレクトリ(標準では pages/)に 保存されている設定ファイル(*.ini)を読み込んで Properties インターフェースで 値へのアクセスを可能にします。
このクラスを利用することにより、スクリプト開発モデルで作成された プログラムと設定ファイルを共有することが可能となり、 異なるモデル間において共通的な設定内容に基づいたアプリケーションを 作成できます。

関連項目:
直列化された形式

フィールドの概要
クラス java.util.Properties から継承したフィールド
defaults
コンストラクタの概要
InitialFile(String path)
リソースサービスが動作しているサーバのリソースディレクトリ内にある 指定の ini ファイルを読み込みます。
クラス java.util.Properties から継承したメソッド
getProperty, getProperty, list, list, load, propertyNames, save, setProperty, store
クラス java.util.Hashtable から継承したメソッド
clear, clone, contains, containsKey, containsValue, elements, entrySet, equals, get, hashCode, isEmpty, keys, keySet, put, putAll, rehash, remove, size, toString, values
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

InitialFile

public InitialFile(String path)
            throws IOException
リソースサービスが動作しているサーバのリソースディレクトリ内にある 指定の ini ファイルを読み込みます。

パラメータ:
path - ini ファイルのパス
例外:
FileNotFoundException - 指定ファイルが存在しないか、指定ファイルの読み込みに失敗した場合
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Lock (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス Lock

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
            拡張 jp.co.intra_mart.foundation.service.client.information.Lock
すべての実装インタフェース:
ActionListener, Serializable
public class Lock
extends NetworkAgent
implements Serializable

アプリケーションロックをするための機能を提供します。

このクラスでは、ロックのフラグ情報を Serialization Servive において 一元的に管理するため、異なる Application Runtime プロセス間における プログラム実行の直列化を実現することができます。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したフィールド
NULL_DATA
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
Lock(String id)
ロックをするためのインスタンスを作ります。
メソッドの概要
Object | action(Object args) 推奨されていません。
void | begin() ロックフラグを立てます。
boolean | begin(long timeout) ロックフラグを立てます。
void | beginRequestScope() ロックフラグを立てます。
boolean | beginRequestScope(long timeout) ロックフラグを立てます。
protected SocketConnection | connection() サーバに接続するためのコネクションを取得します。
boolean | end() ロックを解除します。
String | getName() このインスタンスの表すロックＩＤを返します。
boolean | isLocked() ロックの状態を確認します。
static List | releaseCurrentThread() 現在のスレッドに紐付いたロックを全て解除します。
static List | releaseRequestScope() 推奨されていません。 このメソッドは、RequestScopeLockReleaseFilter 専用です。
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したメソッド
execute
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Lock

public Lock(String id)
     throws NullPointerException
ロックをするためのインスタンスを作ります。 コンストラクタの引数に指定したキーに対するロック機構を提供します。 ロックの機能は Serialization Servive 上に実装されているので このＡＰＩが分散の環境において実行された場合においても同一のキーに マッピングされたロックとして排他制御を行う事が出来ます。

パラメータ:
id - ロックＩＤ
例外:
NullPointerException - 引数が null
メソッドの詳細

connection

protected SocketConnection connection()
                               throws IOException
サーバに接続するためのコネクションを取得します。

定義:
クラス NetworkConnector 内の connection
戻り値:
コネクション
例外:
IOException - 入出力エラーが発生した場合

getName

public String getName()
このインスタンスの表すロックＩＤを返します。

戻り値:
ロックＩＤ

begin

public void begin()
           throws IOException
ロックフラグを立てます。 このオブジェクトが表すキーに対してロックフラグを立てます。 既にロックフラグが設定されている場合には、ロックフラグが解除されるまで 待機します。このＡＰＩによりロックフラグが設定された場合、ロックフラグを 解除するまで他の begin() 要求は待機状態となります。

例外:
IOException - 入出力エラー

begin

public boolean begin(long timeout)
              throws IOException
ロックフラグを立てます。 このオブジェクトが表すキーに対してロックフラグを立てます。 既にロックフラグが設定されている場合には、ロックフラグが解除されるまで 待機します。このＡＰＩによりロックフラグが設定された場合、ロックフラグを 解除するまで他の begin() 要求は待機状態となります。 既にロック状態であり、引数 timeout 秒経過してもロックが解除されなかった 場合、このメソッドは false を返します。

パラメータ:
timeout - ロック開始要求の待ち時間（秒）
戻り値:
ロックの設定に成功した場合 true
例外:
IOException - 入出力エラー

beginRequestScope

public void beginRequestScope()
                       throws IOException
ロックフラグを立てます。

このメソッドは、begin()と同様の機能を提供しますが、 現在のリクエストが終了する際（＝レスポンスを返却する際）に、ロックの解除が自動的に行われる点が異なります。
自動的なロックの解除は、RequestScopeLockReleaseFilter にて行われます。

例外:
IOException - 入出力エラー
導入されたバージョン:
6.1.7

beginRequestScope

public boolean beginRequestScope(long timeout)
                          throws IOException
ロックフラグを立てます。 このメソッドは、begin(long)と同様の機能を提供しますが、 現在のリクエストが終了する際（＝レスポンスを返却する際）に、ロックの解除が自動的に行われる点が異なります。
自動的なロックの解除は、RequestScopeLockReleaseFilter にて行われます。

パラメータ:
timeout - ロック開始要求の待ち時間（秒）
戻り値:
ロックの設定に成功した場合 true
例外:
IOException - 入出力エラー
導入されたバージョン:
6.1.7

end

public boolean end()
            throws IOException
ロックを解除します。 このオブジェクトが表すキーに対してロックを解除します。

戻り値:
ロック解除に成功した場合 true
例外:
IOException - 入出力エラー

isLocked

public boolean isLocked()
                 throws IOException
ロックの状態を確認します。 このオブジェクトが表すキーに対するロックの状態を確認します。 このオブジェクトが表すキーに対して begin() メソッドが実行されていて また、ロックセッション時間内であって end() メソッドが実行されていない場合、このメソッドは true を 返します。

戻り値:
すでにロック状態である場合 true
例外:
IOException - 入出力エラー

action

public Object action(Object args)
推奨されていません。

処理ロジックの実行。

定義:
インタフェース ActionListener 内の action
定義:
クラス NetworkAgent 内の action
パラメータ:
args - 実行時引数
戻り値:
処理結果
関連項目:
NetworkAgent.execute(Object)

releaseCurrentThread

public static List releaseCurrentThread()
現在のスレッドに紐付いたロックを全て解除します。

戻り値:
現在のスレッドに紐づいたロックが存在しない場合は null を返却します。
上記以外の場合、ロックの解除に失敗したロックID(String)を格納したListを返却します。
（ロック解除に全て成功した際には、要素が空のListが返却されます）

releaseRequestScope

public static List releaseRequestScope()
推奨されていません。 このメソッドは、RequestScopeLockReleaseFilter 専用です。

現在のリクエストに紐付いたロックを全て解除します。
具体的には、beginRequestScope()で行ったロックを全て解除します。

戻り値:
現在のリクエストに紐づいたロックが存在しない場合は null を返却します。
上記以外の場合、ロックの解除に失敗したロックID(String)を格納したListを返却します。
（ロック解除に全て成功した際には、要素が空のListが返却されます）
導入されたバージョン:
6.1.7
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.client.information (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.service.client.information
インタフェース
TreasureDirectory
TreasureFile
クラス
ExternalDirectory
ExternalMemory
Identifier
InitialFile
Lock
PermanentDirectory
PermanentFile
SessionFactory
SessionMemory


jp.co.intra_mart.foundation.service.client.information (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.information

このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

参照:
説明

インタフェースの概要
TreasureDirectory | 情報データベースのディレクトリを操作するためのインターフェースを定義します。
TreasureFile | 情報データベースのファイルを操作するためのインターフェースを定義します。

クラスの概要
ExternalDirectory | 共有データグループを管理するオブジェクトです。
ExternalMemory | 共有データを管理するオブジェクトです。
Identifier | ユニークなＩＤを生成する機能を提供します。
InitialFile | 設定ファイル(*.ini)の内容を読み込むためのクラスです。
Lock | アプリケーションロックをするための機能を提供します。
PermanentDirectory | ファイルベースでデータを保存します。
PermanentFile | ファイルベースでデータを保存します。
SessionFactory | 共有データグループを管理するオブジェクトです。
SessionMemory | 共有データを管理するオブジェクトです。

パッケージ jp.co.intra_mart.foundation.service.client.information の説明

このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

このパッケージに含まれるクラスにより利用可能なサービスは、以下のとおりです。

  • Permanent Data Service
  • Resource Service
  • Serialization Service
  • Sharead Memory Service


jp.co.intra_mart.foundation.service.client.information クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.information の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.util.Dictionary
      • class java.util.Hashtable (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class java.util.Properties
          • class jp.co.intra_mart.foundation.service.client.information.InitialFile
    • class jp.co.intra_mart.foundation.service.client.information.Identifier
    • class jp.co.intra_mart.foundation.service.client.NetworkConnector (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.service.client.NetworkAgent (implements jp.co.intra_mart.foundation.service.client.ActionListener)
        • class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureDirectory)
        • class jp.co.intra_mart.foundation.service.client.information.ExternalMemory (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureFile)
        • class jp.co.intra_mart.foundation.service.client.information.Lock (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureDirectory)
        • class jp.co.intra_mart.foundation.service.client.information.PermanentFile (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureFile)
    • class jp.co.intra_mart.foundation.service.client.information.SessionFactory (implements jp.co.intra_mart.foundation.service.client.information.TreasureDirectory)
    • class jp.co.intra_mart.foundation.service.client.information.SessionMemory (implements jp.co.intra_mart.foundation.service.client.information.TreasureFile)

インタフェース階層

  • interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory
  • interface jp.co.intra_mart.foundation.service.client.information.TreasureFile


パッケージ jp.co.intra_mart.foundation.service.client.information の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client.information の使用

jp.co.intra_mart.foundation.service.client.information を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.information このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.information により使用される jp.co.intra_mart.foundation.service.client.information のクラス
ExternalDirectory
共有データグループを管理するオブジェクトです。
PermanentDirectory
ファイルベースでデータを保存します。
SessionMemory
共有データを管理するオブジェクトです。
TreasureDirectory
情報データベースのディレクトリを操作するためのインターフェースを定義します。
TreasureFile
情報データベースのファイルを操作するためのインターフェースを定義します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PermanentDirectory (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス PermanentDirectory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
            拡張 jp.co.intra_mart.foundation.service.client.information.PermanentDirectory
すべての実装インタフェース:
ActionListener, Serializable, TreasureDirectory
public class PermanentDirectory
extends NetworkAgent
implements Serializable, TreasureDirectory

ファイルベースでデータを保存します。

データをそのままファイルに保存して、サーバの再起動後も保存したデータを 扱うためのＡＰＩを提供します。
保存するデータは、直列化可能なオブジェクトに限ります。 また、保存した時の環境と取り出した時の環境において、そのデータに関連する クラスの構造が異なっている場合、正常に値をやりとりできません。

このオブジェクトにより扱うデータは、Permanent Data Service で一元管理されます。 そのため、intra-mart の各サーバモジュールを分散配置している場合、 このオブジェクトの各メソッド実行時は、Permanent Data Service と通信を行います。 また、データファイルが保存されるディレクトリは、 treasure/ 以下の getDomain() メソッドで示されるディレクトリになります。
サブディレクトリを任意に指定する事が可能で、そのサブディレクトリ内に グループが存在し、そのグループ内にデータがキーにマップされる形で 保存されます。

getDomain() メソッドで表される情報保存ディレクトリには、 すでに用法が定められているものがあります。
ベースモジュールの各機能が利用する情報は vault/ ディレクトリに保存され、またスクリプト開発モデルからの情報は、 articles/ ディレクトリ内に保存されます。 これらのディレクトリに情報を保存(また更新や削除)した場合、関係機能への 情報の干渉を引き起こしシステムを不安定にしてしまう危険性があります。

このオブジェクトで保管されるデータは、Permanent Data Service のファイルで 管理され、Permanent Data Service の再起動後も、その存在が保証されます。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したフィールド
NULL_DATA
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
protected PermanentDirectory(String dir)
共有データを扱うための新しいオブジェクトを構築します。
メソッドの概要
Object | action(Object argV) 推奨されていません。
protected SocketConnection | connection() サーバに接続するためのコネクションを取得します。
Map | destroy(String id) グループデータを削除します。
List | entries() このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。
TreasureFile | entry(String id) 空のグループを作成します。
TreasureFile | getFile(String id) このオブジェクトの表すディレクトリにキー id でマップされた PermanentFile インスタンスを取得します。
static PermanentDirectory | getInstance(String dir) 共有データを扱うためのオブジェクトを取得します。
String | getName() このオブジェクトの表すディレクトリ名称を取得します。
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したメソッド
execute
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PermanentDirectory

protected PermanentDirectory(String dir)
                      throws NullPointerException
共有データを扱うための新しいオブジェクトを構築します。

このインスタンスは、dir に保存されている共有データ に関する情報を扱えます。

パラメータ:
dir - 保存ディレクトリ
例外:
NullPointerException - 引数が null
メソッドの詳細

getInstance

public static PermanentDirectory getInstance(String dir)
共有データを扱うためのオブジェクトを取得します。

このインスタンスは、dir に保存されている共有データ に関する情報を扱えます。

パラメータ:
dir - 保存ディレクトリ
例外:
NullPointerException - 引数が null

connection

protected SocketConnection connection()
                               throws IOException
サーバに接続するためのコネクションを取得します。

定義:
クラス NetworkConnector 内の connection
戻り値:
コネクション
例外:
IOException - 入出力エラーが発生した場合

getName

public String getName()
このオブジェクトの表すディレクトリ名称を取得します。

定義:
インタフェース TreasureDirectory 内の getName
戻り値:
このオブジェクトの表すディレクトリ名称

getFile

public TreasureFile getFile(String id)
このオブジェクトの表すディレクトリにキー id でマップされた PermanentFile インスタンスを取得します。

定義:
インタフェース TreasureDirectory 内の getFile
戻り値:
PermanentFile インスタンス

entries

public List entries()
             throws IOException,
                    ClassNotFoundException
このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。

コレクションの各要素は String です。

定義:
インタフェース TreasureDirectory 内の entries
戻り値:
グループＩＤのリスト
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー

entry

public TreasureFile entry(String id)
                   throws IOException
空のグループを作成します。

すでにグループが存在していた場合、このメソッドは何もしません。
このメソッドで作成されたグループにはデータが存在しません。
グループを作成する事により、entries() で取得できるグループリストに このオブジェクトが表すグループが含まれます。
返却値としてグループ id のデータを扱うためのオブジェクトを返します。

定義:
インタフェース TreasureDirectory 内の entry
パラメータ:
id - グループ
戻り値:
TreasureFile インスタンス
例外:
NullPointerException - 引数が null
IOException - 入出力エラー
関連項目:
entries()

destroy

public Map destroy(String id)
            throws IOException,
                   ClassNotFoundException
グループデータを削除します。

id に属する共有データをすべて削除し、 共有データ領域から id に属するデータを保管する領域も削除します。 このメソッドが実行されると entries() で取得できるグループリストに このオブジェクトが示すグループが含まれなくなります。

返却値は、id に属していたデータ一覧になります。返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureDirectory 内の destroy
戻り値:
id に属するデータ一覧
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

action

public Object action(Object argV)
推奨されていません。

処理ロジック。

定義:
インタフェース ActionListener 内の action
定義:
クラス NetworkAgent 内の action
パラメータ:
argV - 引数
戻り値:
実行結果
関連項目:
NetworkAgent.action(Object), NetworkAgent.execute(Object)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PermanentFile (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス PermanentFile

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
            拡張 jp.co.intra_mart.foundation.service.client.information.PermanentFile
すべての実装インタフェース:
ActionListener, Serializable, TreasureFile
public class PermanentFile
extends NetworkAgent
implements Serializable, TreasureFile

ファイルベースでデータを保存します。

データをそのままファイルに保存して、サーバの再起動後も保存したデータを 扱うためのＡＰＩを提供します。
保存するデータは、直列化可能なオブジェクトに限ります。 また、保存した時の環境と取り出した時の環境において、そのデータに関連する クラスの構造が異なっている場合、正常に値をやりとりできません。

このオブジェクトにより扱うデータは、Permanent Data Service で一元管理されます。 そのため、intra-mart の各サーバモジュールを分散配置している場合、 このオブジェクトの各メソッド実行時は、Permanent Data Service と通信を行います。 また、データファイルが保存されるディレクトリは、 treasure/ 以下の getParentName() メソッドで示されるディレクトリになります。 サブディレクトリを任意に指定する事が可能で、そのサブディレクトリ内に グループが存在し、そのグループ内にデータがキーにマップされる形で 保存されます。

このオブジェクトで保管されるデータは、Permanent Data Service のファイルで 管理され、Permanent Data Service の再起動後も、その存在が保証されます。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したフィールド
NULL_DATA
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
protected | PermanentFile(PermanentDirectory parent, String id) 共有データを扱うための新しいオブジェクトを構築します。
protected | PermanentFile(String parent, String id) 共有データを扱うための新しいオブジェクトを構築します。
メソッドの概要
Object | action(Object argV) 推奨されていません。
void | clear() データを削除します。
protected SocketConnection | connection() サーバに接続するためのコネクションを取得します。
Map | entryMap() グループデータを取得します。
Object | get(String key) データを取得します。
String | getName() このインスタンスが表すグループＩＤを取得します。
String | getParentName() 保存ディレクトリを取得します。
List | keyList() キー一覧を取得します。
boolean | move(String new_id) グループキーを変更します。
Object | put(String key, Object value) データを保存します。
void | putAll(Map list) データを保存します。
Object | remove(String key) データを削除します。
Map | subMap(String[] keys) データを取得します。
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したメソッド
execute
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PermanentFile

protected PermanentFile(String parent,
                        String id)
                 throws NullPointerException
共有データを扱うための新しいオブジェクトを構築します。

このインスタンスは、parent に保存されている共有データの中の id に属するデータを扱えます。 domain に保存されているデータや、他の id に属するデータを扱う事は できません。

パラメータ:
parent - 親ディレクトリ名称
id - グループ
例外:
NullPointerException - 引数が null

PermanentFile

protected PermanentFile(PermanentDirectory parent,
                        String id)
                 throws NullPointerException
共有データを扱うための新しいオブジェクトを構築します。

このインスタンスは、parent に保存されている共有データの中の id に属するデータを扱えます。 domain に保存されているデータや、他の id に属するデータを扱う事は できません。

パラメータ:
parent - 親ディレクトリ
id - グループ
例外:
NullPointerException - 引数が null
メソッドの詳細

connection

protected SocketConnection connection()
                               throws IOException
サーバに接続するためのコネクションを取得します。

定義:
クラス NetworkConnector 内の connection
戻り値:
コネクション
例外:
IOException - 入出力エラーが発生した場合

getParentName

public String getParentName()
保存ディレクトリを取得します。

実際には、Permanent Data Service のルート直下 tresure/ ディレクトリに サブディレクトリとして、このメソッドが表すディレクトリを作成して データを保存します。

戻り値:
保存ディレクトリ名称

getName

public String getName()
このインスタンスが表すグループＩＤを取得します。

定義:
インタフェース TreasureFile 内の getName
戻り値:
グループＩＤ

put

public Object put(String key,
                  Object value)
           throws IOException,
                  ClassNotFoundException,
                  OptionalDataException
データを保存します。

id に属する共有データとして key と value をマップします。 id が存在していない場合、新しいグループが作成されます。
返却値は、key にマップされていたデータになります。返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の put
パラメータ:
key - データを保存するキー
value - 保存するデータ
戻り値:
key にマップされていた値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

putAll

public void putAll(Map list)
            throws IOException
データを保存します。

id に属する共有データとして list をマップに追加します。 id が存在していない場合、新しいグループが作成されます。
list 内のキーがすでにマップに存在している場合、list のマップ情報で 上書きされます。

定義:
インタフェース TreasureFile 内の putAll
パラメータ:
list - データ
例外:
IOException - 入出力エラー

get

public Object get(String key)
           throws IOException,
                  ClassNotFoundException
データを取得します。

id に属する共有データの中から key にマップされているデータを 取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の get
パラメータ:
key - キー
戻り値:
key にマップされている値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

subMap

public Map subMap(String[] keys)
           throws IOException,
                  ClassNotFoundException
データを取得します。

id に属する共有データの中から keys の各要素にマップされているデータ群を取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の subMap
パラメータ:
keys - キーの配列
戻り値:
指定されたキーとそのキーにマップされている値を持つマップ。指定したキーが存在しなかった場合、マップはそのキーを持ちません。
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー
NullPointerException - 引数が null の場合
導入されたバージョン:
version 5.0

entryMap

public Map entryMap()
             throws IOException,
                    ClassNotFoundException
グループデータを取得します。

このマップのデータ一覧を取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の entryMap
戻り値:
このマップの全データ
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

clear

public void clear()
           throws IOException
データを削除します。

id に属する共有データをすべて削除します。

定義:
インタフェース TreasureFile 内の clear
例外:
IOException - 入出力エラー

remove

public Object remove(String key)
              throws IOException,
                     ClassNotFoundException
データを削除します。

id に属するデータの中から key にマップされているデータを 削除します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の remove
パラメータ:
key - キー
戻り値:
key にマップされている値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

move

public boolean move(String new_id)
             throws IOException
グループキーを変更します。

現在のグループのキー(id)を新しいキー(new_id)に変更します。
new_id が、domain 内にすでに存在する場合は、変更に失敗します。

パラメータ:
new_id - 新しいグループ名
戻り値:
グループの変更ができた場合 true、失敗した場合 false
例外:
IOException - 入出力エラー

keyList

public List keyList()
             throws IOException,
                    ClassNotFoundException
キー一覧を取得します。

id に属するデータとしてマップされている key のリストを 取得します。

実行環境のバージョン等が異なると ClassNotFoundException がスロー される事があります。
コレクションの各要素は String です。

定義:
インタフェース TreasureFile 内の keyList
戻り値:
マップされているキーのリスト
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー

action

public Object action(Object argV)
推奨されていません。

処理ロジック。

定義:
インタフェース ActionListener 内の action
定義:
クラス NetworkAgent 内の action
パラメータ:
argV - 引数
戻り値:
実行結果
関連項目:
NetworkAgent.action(Object), NetworkAgent.execute(Object)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionFactory (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス SessionFactory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.information.SessionFactory
すべての実装インタフェース:
TreasureDirectory
public class SessionFactory
extends Object
implements TreasureDirectory

共有データグループを管理するオブジェクトです。

グループ化された共有データのグループに関する情報を操作します。 各グループに保存されているデータの取得や各グループへのデータの保存には、 SessionMemory クラスを利用します。
このオブジェクトにより扱うデータは、HTTP セッションにて管理されます。 情報の入出力に関する仕様は、実行環境における HTTP セッションの仕様に 準拠します。

導入されたバージョン:
version 3.1
関連項目:
SessionMemory

コンストラクタの概要
SessionFactory(HttpServletRequest request, HttpServletResponse response)
共有データを扱うための新しいオブジェクトを構築します。
メソッドの概要
void | destroy() このメソッドは、現在のセッションを破棄してしまいます。
Map | destroy(String id) id によりアクセスできるセッションデータを破棄します。
List | entries() セッションＩＤ一覧を取得します。
SessionMemory | entry() 新しい空のセッションを作成します。
TreasureFile | entry(String id) 新しい空のセッションを作成します。
Number | expiration() セッションの維持時間を取得します。
SessionMemory | getFile() 現在有効なセッションを扱う SessionMemory インスタンスを取得します。
TreasureFile | getFile(String id) このオブジェクトの表すディレクトリにキー id でマップされた SessionMemory インスタンスを取得します。
String | getName() このオブジェクトの表すディレクトリ名称を取得します。
String | newIdentifier() 新しいセッションＩＤを生成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SessionFactory

public SessionFactory(HttpServletRequest request,
                      HttpServletResponse response)
共有データを扱うための新しいオブジェクトを構築します。

このインスタンスは、dir に保存されている共有データ に関する情報を扱えます。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
メソッドの詳細

getName

public String getName()
このオブジェクトの表すディレクトリ名称を取得します。

このメソッドは常に null を返します。

定義:
インタフェース TreasureDirectory 内の getName
戻り値:
このオブジェクトの表すディレクトリ名称

getFile

public TreasureFile getFile(String id)
このオブジェクトの表すディレクトリにキー id でマップされた SessionMemory インスタンスを取得します。

ただし、id は現在有効なセッションＩＤを渡さなければなりません。 指定された id が、現在のセッションを表すものとして不適切と判断した場合、 このメソッドは null を返します。

定義:
インタフェース TreasureDirectory 内の getFile
戻り値:
SessionMemory インスタンス

getFile

public SessionMemory getFile()
現在有効なセッションを扱う SessionMemory インスタンスを取得します。

戻り値:
SessionMemory インスタンス

entries

public List entries()
セッションＩＤ一覧を取得します。

コレクションに含まれるセッションＩＤは、現在のセッションに関わるもの のみです。 したがって、コレクションに含まれる要素は常に１つだけです。 ただし、セッションを作成していない状態では、 要素を一つも持たないコレクションを返します。

コレクションの各要素は String です。

定義:
インタフェース TreasureDirectory 内の entries
戻り値:
セッションＩＤのリスト

entry

public TreasureFile entry(String id)
新しい空のセッションを作成します。

このメソッドで作成されたセッションにはデータが存在しません。 ただし、すでにセッションが作成済みの場合には、 現在のセッションが返されます。
返却値として新しいセッションのデータを扱うためのオブジェクトを 返します。

定義:
インタフェース TreasureDirectory 内の entry
パラメータ:
id - グループ
戻り値:
SessionMemory インスタンス
例外:
IllegalArgumentException - id が現在のセッションのIDとして有効ではない場合
関連項目:
TreasureDirectory.entries()

entry

public SessionMemory entry()
新しい空のセッションを作成します。

このメソッドで作成されたセッションにはデータが存在しません。 ただし、すでにセッションが作成済みの場合には、 現在のセッションが返されます。
返却値として新しいセッションのデータを扱うためのオブジェクトを 返します。

戻り値:
SessionMemory インスタンス

destroy

public Map destroy(String id)
id によりアクセスできるセッションデータを破棄します。

定義:
インタフェース TreasureDirectory 内の destroy
戻り値:
セッションの破棄に成功した場合は空の Map が返され、セッションの破棄が出来なかった場合は null が返されます。

destroy

public void destroy()
このメソッドは、現在のセッションを破棄してしまいます。 したがって、メソッド実行後はセッションが無効となり、 セッション維持が出来なくなってしまいます。

expiration

public Number expiration()
セッションの維持時間を取得します。

戻り値:
セッション時間

newIdentifier

public String newIdentifier()
新しいセッションＩＤを生成します。

このメソッドは、単純に現在の環境のセッションＩＤを返します。 HTTP セッションが未作成の場合は、新しく作成してＩＤを返します。

戻り値:
新しく作成されたセッションＩＤ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionMemory (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス SessionMemory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.information.SessionMemory
すべての実装インタフェース:
TreasureFile
public class SessionMemory
extends Object
implements TreasureFile

共有データを管理するオブジェクトです。

このオブジェクトにより扱うデータは、HTTPセッションにより管理されます。

導入されたバージョン:
version 3.1
関連項目:
SessionFactory

コンストラクタの概要
protected SessionMemory(HttpSession session)
共有データを扱うための新しいオブジェクトを構築します。
メソッドの概要
void | clear() すべてのデータを削除します。
Map | entryMap() グループデータを取得します。
Object | get(String key) データを取得します。
String | getName() このインスタンスが表すセッションＩＤを取得します。
List | keyList() キー一覧を取得します。
Object | put(String key, Object value) データを保存します。
void | putAll(Map list) データを保存します。
Object | remove(String key) データを削除します。
Map | subMap(String[] keys) データを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SessionMemory

protected SessionMemory(HttpSession session)
                 throws NullPointerException
共有データを扱うための新しいオブジェクトを構築します。

パラメータ:
session - ＨＴＴＰセッションオブジェクト
例外:
NullPointerException - 引数が null
メソッドの詳細

getName

public String getName()
このインスタンスが表すセッションＩＤを取得します。

定義:
インタフェース TreasureFile 内の getName
戻り値:
グループＩＤ
関連項目:
SessionFactory.entry(),
SessionFactory.entry(String),
SessionFactory.getFile(String)

put

public Object put(String key,
                  Object value)
データを保存します。

共有データとして key と value をマップします。 返却値は、key にマップされていたデータになります。返却データに関して、

定義:
インタフェース TreasureFile 内の put
パラメータ:
key - データを保存するキー
value - 保存するデータ
戻り値:
key にマップされていた値

putAll

public void putAll(Map list)
データを保存します。

共有データとして list をマップに追加します。 list 内のキーがすでにマップに存在している場合、list のマップ情報で 上書きされます。

定義:
インタフェース TreasureFile 内の putAll
パラメータ:
list - データ

get

public Object get(String key)
データを取得します。

共有データの中から key にマップされているデータを 取得します。

定義:
インタフェース TreasureFile 内の get
パラメータ:
key - キー
戻り値:
key にマップされている値

subMap

public Map subMap(String[] keys)
データを取得します。

セッションの中から keys の各要素にマップされているデータ群を取得します。
返却データに関して、

定義:
インタフェース TreasureFile 内の subMap
パラメータ:
keys - キーの配列
戻り値:
指定されたキーとそのキーにマップされている値を持つマップ。指定したキーが存在しなかった場合、マップはそのキーを持ちません。
例外:
NullPointerException - 引数が null の場合
導入されたバージョン:
version 5.0

entryMap

public Map entryMap()
グループデータを取得します。

このマップのデータ一覧を取得します。
返却データに関して、

定義:
インタフェース TreasureFile 内の entryMap
戻り値:
このマップの全データ

clear

public void clear()
すべてのデータを削除します。

定義:
インタフェース TreasureFile 内の clear

remove

public Object remove(String key)
データを削除します。

共有データの中から key にマップされているデータを 削除します。

定義:
インタフェース TreasureFile 内の remove
パラメータ:
key - キー
戻り値:
key にマップされている値

keyList

public List keyList()
キー一覧を取得します。

コレクションの各要素は String です。

定義:
インタフェース TreasureFile 内の keyList
戻り値:
マップされているキーのリスト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


TreasureDirectory (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
インタフェース TreasureDirectory

既知の実装クラスの一覧:
ExternalDirectory, PermanentDirectory, SessionFactory
public interface TreasureDirectory

情報データベースのディレクトリを操作するためのインターフェースを定義します。

このインターフェースを継承するクラスでは、情報データベースの ディレクトリ情報へのアクセスを実装して下さい。

メソッドの概要
Map | destroy(String id) グループデータを削除します。
List | entries() このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。
TreasureFile | entry(String id) 空のグループを作成します。
TreasureFile | getFile(String id) このオブジェクトの表すディレクトリにキー id でマップされた TreasureFile インスタンスを取得します。
String | getName() このオブジェクトの表す名称を取得します。

メソッドの詳細

getFile

public TreasureFile getFile(String id)
このオブジェクトの表すディレクトリにキー id でマップされた TreasureFile インスタンスを取得します。

戻り値:
TreasureFile インスタンス

getName

public String getName()
このオブジェクトの表す名称を取得します。

戻り値:
このオブジェクトの名称

entries

public List entries()
             throws IOException,
                    ClassNotFoundException
このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。

コレクションの各要素は String です。

戻り値:
グループＩＤのリスト
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー

entry

public TreasureFile entry(String id)
                   throws IOException
空のグループを作成します。

すでにグループが存在していた場合、このメソッドは何もしません。
このメソッドで作成されたグループにはデータが存在しません。
グループを作成する事により、entries() で取得できるグループリストに このオブジェクトが表すグループが含まれます。
返却値としてグループ id のデータを扱うためのオブジェクトを返します。

パラメータ:
id - グループ
戻り値:
TreasureFile インスタンス
例外:
NullPointerException - 引数が null
IOException - 入出力エラー
関連項目:
entries()

destroy

public Map destroy(String id)
            throws IOException,
                   ClassNotFoundException
グループデータを削除します。

id に属する共有データをすべて削除し、 共有データ領域から id に属するデータを保管する領域も削除します。 このメソッドが実行されると entries() で取得できるグループリストに このオブジェクトが示すグループが含まれなくなります。

返却値は、id に属していたデータ一覧になります。返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

戻り値:
id に属するデータ一覧
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


TreasureFile (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
インタフェース TreasureFile

既知の実装クラスの一覧:
ExternalMemory, PermanentFile, SessionMemory
public interface TreasureFile

情報データベースのファイルを操作するためのインターフェースを定義します。

このインターフェースを継承するクラスでは、情報データベースの ファイル情報へのアクセスを実装して下さい。

メソッドの概要
void | clear() このオブジェクトのマップからマッピングをすべて削除します。
Map | entryMap() グループデータを取得します。
Object | get(String key) データを取得します。
String | getName() このオブジェクトの表す名称を取得します。
List | keyList() キー一覧を取得します。
Object | put(String key, Object value) データを保存します。
void | putAll(Map list) データを保存します。
Object | remove(String key) データを削除します。
Map | subMap(String[] keys) データを取得します。

メソッドの詳細

getName

public String getName()
このオブジェクトの表す名称を取得します。

戻り値:
このオブジェクトの名称

clear

public void clear()
           throws IOException
このオブジェクトのマップからマッピングをすべて削除します。

例外:
IOException

put

public Object put(String key,
                  Object value)
           throws IOException,
                  ClassNotFoundException,
                  OptionalDataException
データを保存します。

このオブジェクトに key と value をマップします。 返却値は、key にマップされていたデータになります。返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

パラメータ:
key - データを保存するキー
value - 保存するデータ
戻り値:
key にマップされていた値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

putAll

public void putAll(Map list)
            throws IOException
データを保存します。

このオブジェクトに list をマップに追加します。 list 内のキーがすでにマップに存在している場合、list のマップ情報で 上書きされます。

パラメータ:
list - データ
例外:
IOException - 入出力エラー

get

public Object get(String key)
           throws IOException,
                  ClassNotFoundException
データを取得します。

このマップの中から key にマップされているデータを取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

パラメータ:
key - キー
戻り値:
key にマップされている値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

subMap

public Map subMap(String[] keys)
           throws IOException,
                  ClassNotFoundException
データを取得します。

このマップの中から keys の各要素にマップされているデータ群を取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

パラメータ:
keys - キーの配列
戻り値:
指定されたキーとそのキーにマップされている値を持つマップ。指定したキーが存在しなかった場合、マップはそのキーを持ちません。
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー
導入されたバージョン:
version 5.0

entryMap

public Map entryMap()
             throws IOException,
                    ClassNotFoundException
グループデータを取得します。

このマップのデータ一覧を取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

戻り値:
このマップの全データ
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

remove

public Object remove(String key)
              throws IOException,
                     ClassNotFoundException
データを削除します。

マップの中から key にマップされているデータを削除します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

パラメータ:
key - キー
戻り値:
key にマップされている値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

keyList

public List keyList()
             throws IOException,
                    ClassNotFoundException
キー一覧を取得します。

マップされている key のリストを取得します。

実行環境のバージョン等が異なると ClassNotFoundException がスロー される事があります。
コレクションの各要素は String です。

戻り値:
マップされているキーのリスト
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException の使用

IllegalPasswordException を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.manager このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。

jp.co.intra_mart.foundation.service.client.manager での IllegalPasswordException の使用

IllegalPasswordException をスローする jp.co.intra_mart.foundation.service.client.manager のメソッド
 SocketConnectionDistributor SocketConnectionDistributorFactory.createSocketConnectionDistributor(String passwd)
Server-Manager に接続するためのネットワークコネクション管理 オブジェクトを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.manager.ServerConnector の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.manager.ServerConnector の使用

jp.co.intra_mart.foundation.service.client.manager.ServerConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory の使用

jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


IllegalPasswordException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.manager
クラス IllegalPasswordException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException
すべての実装インタフェース:
Serializable
public class IllegalPasswordException
extends Exception

パスワードが認証されなかったことを通知するための例外です。

パスワードが間違っている場合にスローされます。

導入されたバージョン:
intra-mart Version 4.1
関連項目:
直列化された形式

コンストラクタの概要
IllegalPasswordException(String message)
指定のメッセージで例外を作成します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalPasswordException

public IllegalPasswordException(String message)
指定のメッセージで例外を作成します。

メッセージは、java.lang.Throwable クラスの getMessage メソッドから取得することができます。

パラメータ:
message - メッセージ
関連項目:
Throwable.getMessage()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.client.manager (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.service.client.manager
クラス
ServerConnector
SocketConnectionDistributorFactory
例外
IllegalPasswordException


jp.co.intra_mart.foundation.service.client.manager (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.manager

このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。

参照:
説明

クラスの概要
ServerConnector | このクラスは、Server-Manager にリクエストを送信して 処理を要求するためのオブジェクトです。
SocketConnectionDistributorFactory | このクラスは、Server-Manager に接続するための ネットワークコネクション管理オブジェクトを作成するためのクラスです。

例外の概要
IllegalPasswordException パスワードが認証されなかったことを通知するための例外です。

パッケージ jp.co.intra_mart.foundation.service.client.manager の説明

このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。
それぞれのサーバの持つ機能を利用するための具体的なＡＰＩに関しては、 サブパッケージを参照してください。


jp.co.intra_mart.foundation.service.client.manager クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.manager の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.client.NetworkConnector (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.service.client.manager.ServerConnector (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException


パッケージ jp.co.intra_mart.foundation.service.client.manager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client.manager の使用

jp.co.intra_mart.foundation.service.client.manager を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.manager このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。

jp.co.intra_mart.foundation.service.client.manager により使用される jp.co.intra_mart.foundation.service.client.manager のクラス
IllegalPasswordException
パスワードが認証されなかったことを通知するための例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ServerConnector (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.manager
クラス ServerConnector

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.manager.ServerConnector
すべての実装インタフェース:
Serializable
public class ServerConnector
extends NetworkConnector
implements Serializable

このクラスは、Server-Manager にリクエストを送信して 処理を要求するためのオブジェクトです。

導入されたバージョン:
intra-mart Version 4.1
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
ServerConnector(SocketConnectionDistributor socketConnectionDistributor)
オブジェクトを作成します。
メソッドの概要
protected SocketConnection | connection() サーバに接続するためのコネクションを取得します。
SocketConnectionDistributor | getSocketConnectionDistributor() このオブジェクトが保持しているネットワークのコネクションプールを 返します。
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ServerConnector

public ServerConnector(SocketConnectionDistributor socketConnectionDistributor)
オブジェクトを作成します。

socketConnectionDistributor には、SocketConnectionDistributorFactory クラスから 作成されたオブジェクトを渡してください。

パラメータ:
socketConnectionDistributor - ネットワークコネクション管理オブジェクト
関連項目:
SocketConnectionDistributorFactory.createSocketConnectionDistributor(String)
メソッドの詳細

getSocketConnectionDistributor

public SocketConnectionDistributor getSocketConnectionDistributor()
このオブジェクトが保持しているネットワークのコネクションプールを 返します。

connection

protected SocketConnection connection()
                               throws IOException
サーバに接続するためのコネクションを取得します。

定義:
クラス NetworkConnector 内の connection
戻り値:
コネクション
例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SocketConnectionDistributorFactory (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.manager
クラス SocketConnectionDistributorFactory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory
public class SocketConnectionDistributorFactory
extends Object

このクラスは、Server-Manager に接続するための ネットワークコネクション管理オブジェクトを作成するためのクラスです。

導入されたバージョン:
intra-mart Version 4.1

コンストラクタの概要
SocketConnectionDistributorFactory(String address, int port)
オブジェクトを作成します。
SocketConnectionDistributorFactory(String address, int port, int timeout)
オブジェクトを作成します。
メソッドの概要
 SocketConnectionDistributor createSocketConnectionDistributor(String passwd)
Server-Manager に接続するためのネットワークコネクション管理 オブジェクトを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SocketConnectionDistributorFactory

public SocketConnectionDistributorFactory(String address,
                                          int port)
オブジェクトを作成します。

パラメータ:
address - Server-Manager が動作しているコンピュータのアドレス
port - Server-Manager がサービスを提供しているネットワークポート番号

SocketConnectionDistributorFactory

public SocketConnectionDistributorFactory(String address,
                                          int port,
                                          int timeout)
オブジェクトを作成します。

timeout には、リクエストに対する Server-Manager からの応答 タイムアウトをミリ秒で指定します。 タイムアウトを設定することにより、Server-Manager から応答がない場合に、 デットロックしてしまう可能性を回避することができます。 逆に、タイムアウトを設定することによって、 正常に動作している場合に置いてもタイムアウトが発生してしまうと、 リクエストはエラー終了扱いとなってしまいます。

パラメータ:
address - Server-Manager が動作しているコンピュータのアドレス
port - Server-Manager がサービスを提供しているネットワークポート番号
timeout - リクエストのタイムアウト時間
メソッドの詳細

createSocketConnectionDistributor

public SocketConnectionDistributor createSocketConnectionDistributor(String passwd)
                                                              throws IllegalPasswordException,
                                                                     IOException
Server-Manager に接続するためのネットワークコネクション管理 オブジェクトを取得します。 引数のパスワードには、Administrator を利用するためのパスワードとして 設定されている文字列を指定してください。

パラメータ:
passwd - パスワード
戻り値:
ネットワークコネクション管理オブジェクト
例外:
IllegalPasswordException - パスワード違反
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ActionListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client
インタフェース ActionListener

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
NetworkAgent
public interface ActionListener
extends Serializable

このクラスは、主にイベントにより処理されるリスナーを実装する ためのスケルトンを提供します。

導入されたバージョン:
version 4.0

メソッドの概要
 Object action(Object arg)
このメソッドは、特定のイベント発生時に実行されます。

メソッドの詳細

action

public Object action(Object arg)
              throws RuntimeException,
                     Error
このメソッドは、特定のイベント発生時に実行されます。

どのイベントに対してのリスナーになるかということは、 このインターフェースを扱うオブジェクトに依存します。 したがって、このインターフェースは様々な種類のリスナーとして動作する 可能性があり、サブクラスは目的と動作を十分に認識した上で 実装する必要があります。

パラメータ:
arg - 引数オブジェクト
戻り値:
実行結果
例外:
RuntimeException - 実行時エラー
Error - 致命的なエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


NetworkAgent (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client
クラス NetworkAgent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
すべての実装インタフェース:
ActionListener, Serializable
直系の既知のサブクラス:
AbstractComponent, ExternalDirectory, ExternalMemory, Lock, PermanentDirectory, PermanentFile, Scheduler
public abstract class NetworkAgent
extends NetworkConnector
implements ActionListener

このクラスは、他のサーバで実行されるロジックを実装する ためのスケルトンを提供します。

サーバがネットワーク型構成で動作している場合は、ネットワーク通信を行い 目的のサーバでロジックを実行します。サーバがスタンドアロン型構成で動作 している場合は、そのサーバ内で直接ロジックを実行します。
このクラスを継承したサブクラスでは、他のサーバでロジックを実行するための メソッドと実際にサーバで実行されるロジックを定義する必要があります。
また、サブクラスは直列化可能なクラスである必要があります。 サブクラスが直列化できない場合、ロジックの呼び出し時に例外がスローされます。

関連項目:
直列化された形式

フィールドの概要
protected static Object NULL_DATA
NULL を表します。
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
protected NetworkAgent()
唯一のコンストラクタ。
メソッドの概要
abstract Object | action(Object arg) このオブジェクトの実行ロジック。
protected Object | execute(Object arg) サーバに対して実行要求をします。
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, connection, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

NULL_DATA

protected static final Object NULL_DATA
NULL を表します。 値は null です。

コンストラクタの詳細

NetworkAgent

protected NetworkAgent()
唯一のコンストラクタ。

メソッドの詳細

action

public abstract Object action(Object arg)
                       throws RuntimeException,
                              Error
このオブジェクトの実行ロジック。

このメソッドは、execute(Object) を実行すると リスナーを実行する対象となっているサーバにより呼び出されます。 このメソッドの引数 arg は execute(Object) に渡された引数が そのまま渡されます。
このメソッドは、サブクラスでオーバーライドする必要があります。

サーバがスタンドアロン型で運用されている場合、現在動作しているサーバ内で 実行されます。 また、サーバがネットワーク型で運用されている場合、 NetworkConnector.connection() から取得したコネクションにより 接続されたサーバで実行されます。
サーバがネットワーク型で運用されている場合、このメソッドの実行結果は 直列化されてサーバ間を転送されるため、このメソッドの返却値は 直列化可能なオブジェクトである必要があります。
このメソッドの返却値が直列化ができなくて、サーバがネットワーク型で 運用されていた場合、実行要求をしたサーバ側で例外がスローされます。

定義:
インタフェース ActionListener 内の action
パラメータ:
arg - 引数オブジェクト
戻り値:
実行結果
例外:
RuntimeException - 実行時エラー
Error - 致命的なエラー
関連項目:
execute(Object)

execute

protected final Object execute(Object arg)
                        throws IOException,
                               RuntimeException,
                               Error
サーバに対して実行要求をします。

サーバがスタンドアロン型で運用されている場合、現在動作しているサーバ内で サブクラスによりオーバーライドされた action(Object) を 実行し、その結果を返します。
サーバがネットワーク型で運用されている場合、 NetworkConnector.connection() から取得したコネクションにより 接続されたサーバにこのインスタンスを転送して実行を依頼します。 接続先サーバでは、このオブジェクトを復元して サブクラスによりオーバーライドされた action(Object) を 実行します。実行結果はネットワークにより転送され、復元した後に、 このメソッドの実行結果として返します。

このメソッドに渡す引数は、直列化可能なオブジェクトに限ります。 引数を直列化できない場合、このメソッドは例外をスローします。

パラメータ:
arg - action() に渡す引数
戻り値:
action() の実行結果
例外:
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
StreamCorruptedException - ストリームの制御情報に一貫性がない場合
OptionalDataException - プリミティブデータが、オブジェクトではなくストリームに見つかった場合
NotSerializableException - 直列化の対象が java.io.Serializable インタフェースを実装していない場合
IOException - 入出力エラーが発生した場合
RuntimeException - 実行時エラー
Error - 致命的なエラー
関連項目:
action(Object)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


NetworkConnector (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client
クラス NetworkConnector

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
NetworkAgent, ServerConnector
public abstract class NetworkConnector
extends Object
implements Serializable

このクラスは、他のサーバで実行されるロジックを転送する ためのスケルトンを提供します。

サーバがネットワーク型構成で動作している場合は、ネットワーク通信を行い 目的のサーバにロジックを転送します。サーバがスタンドアロン型構成で動作 している場合は、そのサーバ内で直接ロジックを実行します。
このクラスを継承したサブクラスでは、他のサーバでロジックを実行するための ネットワークコネクションを定義する必要があります。
また、サブクラスは直列化可能なクラスである必要があります。 サブクラスが直列化できない場合、ロジックの呼び出し時に例外がスローされます。

導入されたバージョン:
version 4.0
関連項目:
直列化された形式

フィールドの概要
protected static int | GET
protected static int | GET_ENTIRETY
protected static int | GET_ENTIRETY_KEY
protected static int | GET_ITEM
protected static int | GET_ITEM_KEY
protected static int | GET_SUBSET
protected static int | MOVE
protected static int | MOVE_ENTIRETY
protected static int | MOVE_ITEM
protected static int | REMOVE
protected static int | REMOVE_ENTIRETY
protected static int | REMOVE_ITEM
protected static int | SET
protected static int | SET_ENTIRETY
protected static int | SET_ITEM
コンストラクタの概要
protected NetworkConnector()
唯一のコンストラクタ。
メソッドの概要
void | close() ネットワークを切断します。
protected abstract SocketConnection | connection() サーバに接続するためのコネクションを取得します。
Object | execute(ActionListener target, Object arg) サーバに対して実行要求をします。
long | freeMemory() サーバシステムの空きメモリの量を返します。
boolean | isConnected() サーバとの接続状態をチェックします。
long | serverTime() サーバのミリ秒で表される現在の時間を返します。
long | totalMemory() サーバプロセスの Java Virtual Machine のメモリの総容量を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

SET

protected static final int SET
関連項目:
定数フィールド値

SET_ITEM

protected static final int SET_ITEM
関連項目:
定数フィールド値

SET_ENTIRETY

protected static final int SET_ENTIRETY
関連項目:
定数フィールド値

GET

protected static final int GET
関連項目:
定数フィールド値

GET_ITEM

protected static final int GET_ITEM
関連項目:
定数フィールド値

GET_ENTIRETY

protected static final int GET_ENTIRETY
関連項目:
定数フィールド値

GET_SUBSET

protected static final int GET_SUBSET
導入されたバージョン:
version 5.0
関連項目:
定数フィールド値

GET_ITEM_KEY

protected static final int GET_ITEM_KEY
関連項目:
定数フィールド値

GET_ENTIRETY_KEY

protected static final int GET_ENTIRETY_KEY
関連項目:
定数フィールド値

REMOVE

protected static final int REMOVE
関連項目:
定数フィールド値

REMOVE_ITEM

protected static final int REMOVE_ITEM
関連項目:
定数フィールド値

REMOVE_ENTIRETY

protected static final int REMOVE_ENTIRETY
関連項目:
定数フィールド値

MOVE

protected static final int MOVE
関連項目:
定数フィールド値

MOVE_ITEM

protected static final int MOVE_ITEM
関連項目:
定数フィールド値

MOVE_ENTIRETY

protected static final int MOVE_ENTIRETY
関連項目:
定数フィールド値
コンストラクタの詳細

NetworkConnector

protected NetworkConnector()
唯一のコンストラクタ。

メソッドの詳細

connection

protected abstract SocketConnection connection()
                                        throws UnsupportedNetworkConnectException,
                                               IOException
サーバに接続するためのコネクションを取得します。
ネットワーク接続が必要ではない場合は、 UnsupportedNetworkConnectException をスローします。

このメソッドは、サブクラスでオーバーライドする必要があります。

戻り値:
コネクション
例外:
UnsupportedNetworkConnectException - ネットワーク接続が許可されていない場合
IOException - 入出力エラーが発生した場合

execute

public Object execute(ActionListener target,
                      Object arg)
               throws IOException,
                      RuntimeException,
                      Error
サーバに対して実行要求をします。

サーバがスタンドアロン型で運用されている場合、 現在動作しているサーバ内で リスナー ActionListener.action(Object) を 実行し、その結果を返します。
サーバがネットワーク型で運用されている場合、connection() メソッドにより取得したコネクションを利用してサーバに接続し、 リスナーオブジェクトを直列化して転送します。 接続先サーバでは、転送したリスナーオブジェクトを復元して リスナーオブジェクトの ActionListener.action(Object) を 実行します。実行結果はネットワークにより転送され、復元した後に、 このメソッドの実行結果として返します。

このメソッドに渡す引数は、直列化可能なオブジェクトに限ります。 引数を直列化できない場合、このメソッドは例外をスローします。

パラメータ:
target - サーバで実行するリスナーオブジェクト
arg - action() に渡す引数
戻り値:
action() の実行結果
例外:
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
StreamCorruptedException - ストリームの制御情報に一貫性がない場合
OptionalDataException - プリミティブデータが、オブジェクトではなくストリームに見つかった場合
NotSerializableException - 直列化の対象が java.io.Serializable インタフェースを実装していない場合
IOException - 入出力エラーが発生した場合
RuntimeException - 実行時エラー
Error - 致命的なエラー
関連項目:
NetworkAgent.action(Object)

isConnected

public boolean isConnected()
サーバとの接続状態をチェックします。

このメソッド実行時に取得したネットワークコネクションについて接続確認を します。他のコネクションに関してはチェックしないため、このメソッドの 結果接続を確認できたとしても次のリクエストで取得したコネクションで 接続エラーが発生する場合があります。

戻り値:
接続に成功した場合は true、そうでない場合は false。

serverTime

public long serverTime()
                throws IOException
サーバのミリ秒で表される現在の時間を返します。

戻り値:
ミリ秒で測定した、現在時刻と UTC 1970 年 1 月 1 日午前 0 時との差
例外:
IOException - 入出力エラーが発生した場合
関連項目:
System.currentTimeMillis()

totalMemory

public long totalMemory()
                 throws IOException
サーバプロセスの Java Virtual Machine のメモリの総容量を返します。

戻り値:
現在および将来のオブジェクトに利用可能なメモリの総容量 (バイト単位)
例外:
IOException - 入出力エラーが発生した場合
関連項目:
Runtime.totalMemory()

freeMemory

public long freeMemory()
                throws IOException
サーバシステムの空きメモリの量を返します。

戻り値:
将来のオブジェクトに利用可能なメモリの推定総容量 (バイト単位)
例外:
IOException - 入出力エラーが発生した場合
関連項目:
Runtime.freeMemory()

close

public void close()
           throws IOException
ネットワークを切断します。

切断されるネットワークコネクションは、このメソッドを実行した時に、 このメソッド内でこのオブジェクトの connection() メソッドから 取得したコネクションに関してのみです。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.client (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.service.client
インタフェース
ActionListener
クラス
NetworkAgent
NetworkConnector


jp.co.intra_mart.foundation.service.client (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client

このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。

参照:
説明

インタフェースの概要
ActionListener このクラスは、主にイベントにより処理されるリスナーを実装する ためのスケルトンを提供します。

クラスの概要
NetworkAgent | このクラスは、他のサーバで実行されるロジックを実装する ためのスケルトンを提供します。
NetworkConnector | このクラスは、他のサーバで実行されるロジックを転送する ためのスケルトンを提供します。

パッケージ jp.co.intra_mart.foundation.service.client の説明

このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
それぞれのサーバの持つ機能を利用するための具体的なＡＰＩに関しては、 サブパッケージを参照してください。

関連項目:
jp.co.intra_mart.foundation.service.client.batch, jp.co.intra_mart.foundation.service.client.file, jp.co.intra_mart.foundation.service.client.information


jp.co.intra_mart.foundation.service.client クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.client.NetworkConnector (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.service.client.NetworkAgent (implements jp.co.intra_mart.foundation.service.client.ActionListener)

インタフェース階層

  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.service.client.ActionListener


パッケージ jp.co.intra_mart.foundation.service.client の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client の使用

jp.co.intra_mart.foundation.service.client を使用しているパッケージ
jp.co.intra_mart.foundation.service.client | このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.client.batch | Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file | Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.manager | このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。

jp.co.intra_mart.foundation.service.client により使用される jp.co.intra_mart.foundation.service.client のクラス
ActionListener
このクラスは、主にイベントにより処理されるリスナーを実装する ためのスケルトンを提供します。
NetworkConnector
このクラスは、他のサーバで実行されるロジックを転送する ためのスケルトンを提供します。

jp.co.intra_mart.foundation.service.client.batch により使用される jp.co.intra_mart.foundation.service.client のクラス
ActionListener
このクラスは、主にイベントにより処理されるリスナーを実装する ためのスケルトンを提供します。
NetworkAgent
このクラスは、他のサーバで実行されるロジックを実装する ためのスケルトンを提供します。
NetworkConnector
このクラスは、他のサーバで実行されるロジックを転送する ためのスケルトンを提供します。

jp.co.intra_mart.foundation.service.client.file により使用される jp.co.intra_mart.foundation.service.client のクラス
ActionListener
このクラスは、主にイベントにより処理されるリスナーを実装する ためのスケルトンを提供します。
NetworkAgent
このクラスは、他のサーバで実行されるロジックを実装する ためのスケルトンを提供します。
NetworkConnector
このクラスは、他のサーバで実行されるロジックを転送する ためのスケルトンを提供します。

jp.co.intra_mart.foundation.service.client.information により使用される jp.co.intra_mart.foundation.service.client のクラス
ActionListener
このクラスは、主にイベントにより処理されるリスナーを実装する ためのスケルトンを提供します。
NetworkAgent
このクラスは、他のサーバで実行されるロジックを実装する ためのスケルトンを提供します。
NetworkConnector
このクラスは、他のサーバで実行されるロジックを転送する ためのスケルトンを提供します。

jp.co.intra_mart.foundation.service.client.manager により使用される jp.co.intra_mart.foundation.service.client のクラス
NetworkConnector
このクラスは、他のサーバで実行されるロジックを転送する ためのスケルトンを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent の使用

jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain の使用

FilterHTTPActionEventChain を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

jp.co.intra_mart.foundation.service.provider.application での FilterHTTPActionEventChain の使用

FilterHTTPActionEventChain 型のパラメータを持つ jp.co.intra_mart.foundation.service.provider.application のメソッド
protected abstract  void FilterHTTPActionEvent.doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain)
イベントのフィルタ処理です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の使用

HTTPActionEvent を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

jp.co.intra_mart.foundation.service.provider.application での HTTPActionEvent の使用

HTTPActionEvent を実装している jp.co.intra_mart.foundation.service.provider.application のクラス
 class FilterHTTPActionEvent
Application Runtime で実行されるイベントのための フィルターイベントの抽象実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext の使用

HTTPActionEventClientContext を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

jp.co.intra_mart.foundation.service.provider.application での HTTPActionEventClientContext の使用

HTTPActionEventClientContext を返す jp.co.intra_mart.foundation.service.provider.application のメソッド
 HTTPActionEventClientContext HTTPActionEventContext.getClientContext()
イベントの実行を要求したクライアントに関する情報オブジェクトを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext の使用

HTTPActionEventContext を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

jp.co.intra_mart.foundation.service.provider.application での HTTPActionEventContext の使用

HTTPActionEventContext 型のパラメータを持つ jp.co.intra_mart.foundation.service.provider.application のメソッド
void | HTTPActionEvent.action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response) イベント処理メソッドです。
void | FilterHTTPActionEvent.action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response) イベント処理メソッドです。
protected abstract void | FilterHTTPActionEvent.doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain) イベントのフィルタ処理です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException の使用

HTTPActionEventException を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

jp.co.intra_mart.foundation.service.provider.application での HTTPActionEventException の使用

HTTPActionEventException をスローする jp.co.intra_mart.foundation.service.provider.application のメソッド
 long HTTPActionEventContext.getRequestTime()
イベントの実行を要求した時刻を返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext の使用

HTTPActionEventListenerContext を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

jp.co.intra_mart.foundation.service.provider.application での HTTPActionEventListenerContext の使用

HTTPActionEventListenerContext を返す jp.co.intra_mart.foundation.service.provider.application のメソッド
 HTTPActionEventListenerContext HTTPActionEventContext.getListenerContext()
イベントの実行要求を受け付けたリスナーに関する情報オブジェクトを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


FilterHTTPActionEvent (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
クラス FilterHTTPActionEvent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent
すべての実装インタフェース:
HTTPActionEvent
public abstract class FilterHTTPActionEvent
extends Object
implements HTTPActionEvent

Application Runtime で実行されるイベントのための フィルターイベントの抽象実装です。
実際のイベントをフィルタリングしてラップする場合に利用します。

フィルターイベントを作成する場合は、この抽象実装をスーパークラスとして サブクラスを作成します。 その際、引数を１つも持たない public なコンストラクタを持つ必要があります。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected FilterHTTPActionEvent()
指定のイベントをラップするためのフィルターを作成します。
メソッドの概要
void | action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response) イベント処理メソッドです。
protected abstract void | doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain) イベントのフィルタ処理です。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FilterHTTPActionEvent

protected FilterHTTPActionEvent()
指定のイベントをラップするためのフィルターを作成します。

メソッドの詳細

action

public final void action(HTTPActionEventContext context,
                         HttpServletRequest request,
                         HttpServletResponse response)
                  throws ServletException
イベント処理メソッドです。

Application Runtime で HTTPActionEventListenerServlet により 実行されます。 このメソッドは、Application Runtime 内で実行されるため、 このメソッド内で使用するすべてのクラスは、Application Runtime の 動作する環境内においてアクセスできる必要があります。

このメソッドは、リクエストを適切に処理した後に、 doFilter(HTTPActionEventContext, HttpServletRequest, HttpServletResponse, FilterHTTPActionEventChain) を呼び出します。 サブクラスは、doFilter(HTTPActionEventContext, HttpServletRequest, HttpServletResponse, FilterHTTPActionEventChain) をオーバーライドして、 フィルタとして処理したい内容を実装してください。

定義:
インタフェース HTTPActionEvent 内の action
パラメータ:
context - イベントに関する情報
request - HTTPリクエストオブジェクト
response - HTTPレスポンスオブジェクト
例外:
ServletException - 実行時エラー

doFilter

protected abstract void doFilter(HTTPActionEventContext context,
                                 HttpServletRequest request,
                                 HttpServletResponse response,
                                 FilterHTTPActionEventChain chain)
                          throws ServletException
イベントのフィルタ処理です。

パラメータ:
context - イベントに関する情報
request - HTTPリクエストオブジェクト
response - HTTPレスポンスオブジェクト
chain - チェーン内の次のエンティティ
例外:
ServletException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


FilterHTTPActionEventChain (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
インタフェース FilterHTTPActionEventChain

public interface FilterHTTPActionEventChain

FilterHTTPActionEventChain は、FilterHTTPActionEvent によって提供され、 FilterHTTPActionEvent へのフィルタリングされた要求のチェーンに対する ビューを提供します。
FilterHTTPActionEvent は、チェーン内の次のフィルタを呼び出す時、 あるいは FilterHTTPActionEvent がチェーン内の最後のフィルタの場合は イベント(HTTPActionEvent)を呼び出す時に、 FilterHTTPActionEventChain を利用します。

導入されたバージョン:
version 4.3

メソッドの概要
void | doChain() チェーン内の次のフィルタまたはイベントを デフォルトのリクエストとレスポンスを利用して呼び出します。
void | doChain(HttpServletRequest request, HttpServletResponse response) チェーン内の次のフィルタまたはイベントを 指定のリクエストとレスポンスを利用して呼び出します。
HttpServletRequest | getRequest() チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのリクエストを 返します。
HttpServletResponse | getResponse() チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのレスポンスを 返します。

メソッドの詳細

getRequest

public HttpServletRequest getRequest()
チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのリクエストを 返します。

戻り値:
リクエスト

getResponse

public HttpServletResponse getResponse()
チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのレスポンスを 返します。

戻り値:
リクエスト

doChain

public void doChain()
             throws ServletException
チェーン内の次のフィルタまたはイベントを デフォルトのリクエストとレスポンスを利用して呼び出します。
このメソッドの呼び出しは、以下の呼び出しと同様です。

doChain(getRequest(), getResponse())

例外:
ServletException - 実行時エラー

doChain

public void doChain(HttpServletRequest request,
                    HttpServletResponse response)
             throws ServletException
チェーン内の次のフィルタまたはイベントを 指定のリクエストとレスポンスを利用して呼び出します。

パラメータ:
request - HTTPリクエストオブジェクト
response - HTTPレスポンスオブジェクト
例外:
ServletException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEvent (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
インタフェース HTTPActionEvent

既知の実装クラスの一覧:
FilterHTTPActionEvent
public interface HTTPActionEvent

Application Runtime で実行されるイベントのためのインターフェースです。
このインターフェースを実装したクラスは、 Application Runtime でインスタンス化されます。 したがって、通常は WEB-INF 内にクラスを配置する事になります。

また、イベントはイベントリスナーにより引数を持たないコンストラクタを 利用してインスタンス化されます。 したがって、このインターフェースを実装するクラスは、 引数を持たない public なコンストラクタが必要になります。

導入されたバージョン:
version 4.3

メソッドの概要
 void action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response)
イベント処理メソッドです。

メソッドの詳細

action

public void action(HTTPActionEventContext context,
                   HttpServletRequest request,
                   HttpServletResponse response)
            throws ServletException
イベント処理メソッドです。

Application Runtime で HTTPActionEventListenerServlet により 実行されます。 このメソッドは、Application Runtime 内で実行されるため、 このメソッド内で使用するすべてのクラスは、Application Runtime の 動作する環境内においてアクセスできる必要があります。

パラメータ:
context - イベントに関する情報
request - HTTPリクエストオブジェクト
response - HTTPレスポンスオブジェクト
例外:
ServletException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventClientContext (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
インタフェース HTTPActionEventClientContext

public interface HTTPActionEventClientContext

Application Runtime で実行されるイベントの実行を要求した クライアントに関する情報インターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
String | getRemoteHostAddress() イベント実行要求をしたクライアントのアドレスを返します。
String | getRemoteHostName() イベント実行要求をしたクライアントのホスト名を返します。
String | getSystemProperty(String name) クライアントの Java 実行環境のシステムプロパティの値を返します。
Set | getSystemPropertyNameSet() クライアントの Java 実行環境のシステムプロパティの名前のセットを返します。

メソッドの詳細

getRemoteHostAddress

public String getRemoteHostAddress()
イベント実行要求をしたクライアントのアドレスを返します。

戻り値:
アドレスを表す文字列

getRemoteHostName

public String getRemoteHostName()
イベント実行要求をしたクライアントのホスト名を返します。

戻り値:
ホスト名

getSystemProperty

public String getSystemProperty(String name)
クライアントの Java 実行環境のシステムプロパティの値を返します。

パラメータ:
name - プロパティ名
戻り値:
プロパティ名に対する値。指定のプロパティ名に関する定義値が見つからない場合は null。

getSystemPropertyNameSet

public Set getSystemPropertyNameSet()
クライアントの Java 実行環境のシステムプロパティの名前のセットを返します。 セットの各要素はプロパティ名を表す java.lang.String 型の値です。

戻り値:
プロパティ名のセット
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventContext (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
インタフェース HTTPActionEventContext

public interface HTTPActionEventContext

Application Runtime で実行されるイベントに関する情報インターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
long | getAcceptTime() イベント実行要求を受け付けたおよその時刻を返します。
String | getCharacterEncoding() リクエストパラメータの文字エンコーディングを返します。
HTTPActionEventClientContext | getClientContext() イベントの実行を要求したクライアントに関する情報オブジェクトを返します。
HttpServletRequest | getHttpServletRequest() 現在のイベントを要求したリクエストを返します。
HTTPActionEventListenerContext | getListenerContext() イベントの実行要求を受け付けたリスナーに関する情報オブジェクトを返します。
long | getRequestTime() イベントの実行を要求した時刻を返します。

メソッドの詳細

getAcceptTime

public long getAcceptTime()
イベント実行要求を受け付けたおよその時刻を返します。
Servlet コンテナによって、リスナーとなっている Servlet が実行される 以前に javax.servlet.Filter 等が実行されたりします。 したがって、このメソッドの返す値はサーバがリクエストを受け付けた時刻と 一致するとは限りません。

返す時刻の単位はミリ秒で、java.lang.System#currentTimeMillis() の仕様に 準じます。

戻り値:
時刻を表すミリ秒

getCharacterEncoding

public String getCharacterEncoding()
リクエストパラメータの文字エンコーディングを返します。

戻り値:
文字エンコーディング名

getRequestTime

public long getRequestTime()
                    throws HTTPActionEventException
イベントの実行を要求した時刻を返します。 このメソッドの返す時刻は、 1970/1/1 を基準から現在までのミリ秒です。

戻り値:
1970/1/1 を基準から現在までのミリ秒
例外:
HTTPActionEventException - 要求時刻が不明な場合

getHttpServletRequest

public HttpServletRequest getHttpServletRequest()
現在のイベントを要求したリクエストを返します。

戻り値:
リクエスト

getClientContext

public HTTPActionEventClientContext getClientContext()
イベントの実行を要求したクライアントに関する情報オブジェクトを返します。

戻り値:
クライアント情報オブジェクト

getListenerContext

public HTTPActionEventListenerContext getListenerContext()
イベントの実行要求を受け付けたリスナーに関する情報オブジェクトを返します。

戻り値:
リスナー情報オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
クラス HTTPActionEventException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException
すべての実装インタフェース:
Serializable
public class HTTPActionEventException
extends Exception

HTTPActionEvent に関するエラーを通知するための例外です。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
HTTPActionEventException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventException(String msg, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HTTPActionEventException

public HTTPActionEventException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

HTTPActionEventException

public HTTPActionEventException(String msg,
                                Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventListenerContext (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
インタフェース HTTPActionEventListenerContext

public interface HTTPActionEventListenerContext

Application Runtime でイベントの実行制御を行うリスナーに関する情報インターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
Class | getListenerClass() リスナーとなっている Servlet の実行時クラスを返します。
ServletConfig | getServletConfig() イベントを制御したリスナー となっている Servlet が初期化された時に Servlet コンテナから渡された設定オブジェクトが返されます。

メソッドの詳細

getServletConfig

public ServletConfig getServletConfig()
イベントを制御したリスナー となっている Servlet が初期化された時に Servlet コンテナから渡された設定オブジェクトが返されます。

戻り値:
Servlet 設定情報を含んでいる ServletConfig オブジェクト

getListenerClass

public Class getListenerClass()
リスナーとなっている Servlet の実行時クラスを返します。

戻り値:
java.lang.Class 型オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.provider.application (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.service.provider.application
インタフェース
FilterHTTPActionEventChain
HTTPActionEvent
HTTPActionEventClientContext
HTTPActionEventContext
HTTPActionEventListenerContext
クラス
FilterHTTPActionEvent
例外
HTTPActionEventException


jp.co.intra_mart.foundation.service.provider.application (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.application

このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

参照:
説明

インタフェースの概要
FilterHTTPActionEventChain | FilterHTTPActionEventChain は、FilterHTTPActionEvent によって提供され、 FilterHTTPActionEvent へのフィルタリングされた要求のチェーンに対する ビューを提供します。
HTTPActionEvent | Application Runtime で実行されるイベントのためのインターフェースです。
HTTPActionEventClientContext | Application Runtime で実行されるイベントの実行を要求した クライアントに関する情報インターフェースです。
HTTPActionEventContext | Application Runtime で実行されるイベントに関する情報インターフェースです。
HTTPActionEventListenerContext | Application Runtime でイベントの実行制御を行うリスナーに関する情報インターフェースです。

クラスの概要
FilterHTTPActionEvent Application Runtime で実行されるイベントのための フィルターイベントの抽象実装です。

例外の概要
HTTPActionEventException HTTPActionEvent に関するエラーを通知するための例外です。

パッケージ jp.co.intra_mart.foundation.service.provider.application の説明

このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

導入されたバージョン:
version 4.0


jp.co.intra_mart.foundation.service.provider.application クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.application の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent (implements jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException

インタフェース階層

  • interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext


パッケージ jp.co.intra_mart.foundation.service.provider.application の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.provider.application の使用

jp.co.intra_mart.foundation.service.provider.application を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

jp.co.intra_mart.foundation.service.provider.application により使用される jp.co.intra_mart.foundation.service.provider.application のクラス
FilterHTTPActionEventChain
FilterHTTPActionEventChain は、FilterHTTPActionEvent によって提供され、 FilterHTTPActionEvent へのフィルタリングされた要求のチェーンに対する ビューを提供します。
HTTPActionEvent
Application Runtime で実行されるイベントのためのインターフェースです。
HTTPActionEventClientContext
Application Runtime で実行されるイベントの実行を要求した クライアントに関する情報インターフェースです。
HTTPActionEventContext
Application Runtime で実行されるイベントに関する情報インターフェースです。
HTTPActionEventException
HTTPActionEvent に関するエラーを通知するための例外です。
HTTPActionEventListenerContext
Application Runtime でイベントの実行制御を行うリスナーに関する情報インターフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory の使用

jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent の使用

ProcedureComponent を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.batch このパッケージには、スケジュール実行されるバッチプログラム機能を利用するための共通的な機能を提供します。

jp.co.intra_mart.foundation.service.provider.batch での ProcedureComponent の使用

ProcedureComponent を実装している jp.co.intra_mart.foundation.service.provider.batch のクラス
 class PermanentDataArchiveFactory
推奨されていません。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.service.provider.batch (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.service.provider.batch
インタフェース
ProcedureComponent
クラス
PermanentDataArchiveFactory


jp.co.intra_mart.foundation.service.provider.batch (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.batch

このパッケージには、スケジュール実行されるバッチプログラム機能を利用するための共通的な機能を提供します。

参照:
説明

インタフェースの概要
ProcedureComponent スケジュール実行されるバッチプログラムのためのインターフェースを定義します。

クラスの概要
PermanentDataArchiveFactory 推奨されていません。

パッケージ jp.co.intra_mart.foundation.service.provider.batch の説明

このパッケージには、スケジュール実行されるバッチプログラム機能を利用するための共通的な機能を提供します。
このパッケージに含まれるクラスは、現在動作しているApplication Runtimeプロセス環境において実行されます。また、バッチプログラムを作成する場合に必要なインターフェースを提供しています。


jp.co.intra_mart.foundation.service.provider.batch クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.batch の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory (implements jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent)

インタフェース階層

  • interface jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent


パッケージ jp.co.intra_mart.foundation.service.provider.batch の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.provider.batch の使用

jp.co.intra_mart.foundation.service.provider.batch を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.batch このパッケージには、スケジュール実行されるバッチプログラム機能を利用するための共通的な機能を提供します。

jp.co.intra_mart.foundation.service.provider.batch により使用される jp.co.intra_mart.foundation.service.provider.batch のクラス
ProcedureComponent
スケジュール実行されるバッチプログラムのためのインターフェースを定義します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PermanentDataArchiveFactory (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.batch
クラス PermanentDataArchiveFactory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory
すべての実装インタフェース:
ProcedureComponent

public class PermanentDataArchiveFactory
extends Object
implements ProcedureComponent

Permanent-data Service に保存されている永続データをバックアップするための バッチプログラムです。
このクラスをバッチプログラムとして登録することで、 定期的にデータをバックアップすることができます。

なお、このバッチプログラムは、マルチログイングループ環境を サポートしておりません。 バッチとして実行されると、すべてのデータをバックアップします。 したがって、複数のログイングループでバッチ設定をしても ログイングループ単位でのデータバックアップ等を行うことはできません。

導入されたバージョン:
Version 4.2

コンストラクタの概要
PermanentDataArchiveFactory()
推奨されていません。 バッチプログラム実行環境からインスタンス化されるためのコンストラクタ。
メソッドの概要
 void execute(Properties arg)
推奨されていません。 インタフェース ProcedureComponent を実装したオブジェクトの実行クラスを Application Runtime に登録することで、 Application Runtime はこのクラスをインスタンス化し、 execute() メソッドをバッチプログラムとして実行します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PermanentDataArchiveFactory

public PermanentDataArchiveFactory()
推奨されていません。
バッチプログラム実行環境からインスタンス化されるためのコンストラクタ。

メソッドの詳細

execute

public void execute(Properties arg)
             throws RuntimeException,
                    Error
推奨されていません。
インタフェース ProcedureComponent の記述:
インタフェース ProcedureComponent を実装したオブジェクトの実行クラスを Application Runtime に登録することで、 Application Runtime はこのクラスをインスタンス化し、 execute() メソッドをバッチプログラムとして実行します。

バッチとして動作するロジック。

バッチ起動引数は、バッチの設定がバッチ設定画面で登録されている場合、 以下のような項目を持ちます。

group | バッチ設定グループ名（通常はログイングループＩＤ） | String
name | バッチ名称 | String

定義:
インタフェース ProcedureComponent 内の execute
パラメータ:
arg - バッチ起動引数
例外:
Error - 致命的なエラー
RuntimeException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ProcedureComponent (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.batch
インタフェース ProcedureComponent

既知の実装クラスの一覧:
PermanentDataArchiveFactory
public interface ProcedureComponent

スケジュール実行されるバッチプログラムのためのインターフェースを定義します。

このインターフェースを継承するクラスでは、Application Runtime により呼び出された際のバッチ処理を実装して下さい。 また、実装クラスはパラメータを持たない public 宣言されたコンストラクタを 定義しておく必要があります。 バッチサーバは、このゼロパラメータ・コンストラクタを 利用して実装クラスをインスタンス化して execute() メソッドを実行します。

    public class MyBatch implements ProcedureComponent{

        // バッチサーバにインスタンス化されるためのコンストラクタ

        public MyBatch(){

            super();

        }

        public void execute(Properties arg) throws java.lang.RuntimeException, java.lang.Error{

            // バッチのロジック

            System.out.println("Hello. my batch program !");
        }

    }

バッチプログラムを作成したら、コンパイルをしてクラスファイルを作成します。
できあがったクラスファイルをApplication Runtimeが実行可能な環境（ クラスパスの設定されているディレクトリ内）に保存して下さい。 なお、Application Runtime は Webアプリケーションとして動作していますので、 クラスファイルの保存場所には十分注意してください。

バッチ設定画面で MyBatch クラスを登録することで設定した時刻に execute() メソッドがApplication Runtimeにより実行されます。
上記プログラムでは、コンソール画面に「Hello. my batch program !」と 表示されます。

メソッドの概要
 void execute(Properties arg)
インタフェース ProcedureComponent を実装したオブジェクトの実行クラスを Application Runtime に登録することで、 Application Runtime はこのクラスをインスタンス化し、 execute() メソッドをバッチプログラムとして実行します。

メソッドの詳細

execute

public void execute(Properties arg)
             throws RuntimeException,
                    Error
インタフェース ProcedureComponent を実装したオブジェクトの実行クラスを Application Runtime に登録することで、 Application Runtime はこのクラスをインスタンス化し、 execute() メソッドをバッチプログラムとして実行します。

バッチとして動作するロジック。

バッチ起動引数は、バッチの設定がバッチ設定画面で登録されている場合、 以下のような項目を持ちます。

group | バッチ設定グループ名（通常はログイングループＩＤ） | String
name | バッチ名称 | String

パラメータ:
arg - バッチ起動引数
例外:
RuntimeException - 実行時エラー
Error - 致命的なエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.service.provider.Environment の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.Environment の使用

Environment を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

jp.co.intra_mart.foundation.service.provider での Environment の使用

Environment を返す jp.co.intra_mart.foundation.service.provider のメソッド
static Environment Platform.getEnvironment()
システムの設定値を持つオブジェクトを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.GarbageController の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.GarbageController の使用

jp.co.intra_mart.foundation.service.provider.GarbageController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.GCConditioner の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.GCConditioner の使用

GCConditioner を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

jp.co.intra_mart.foundation.service.provider での GCConditioner の使用

GCConditioner 型のパラメータを持つ jp.co.intra_mart.foundation.service.provider のメソッド
static void | GarbageController.addConditioner(GCConditioner conditioner) 推奨されていません。
static void | GarbageController.removeConditioner(GCConditioner conditioner) 推奨されていません。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.HomeDirectory の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.HomeDirectory の使用

HomeDirectory を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

jp.co.intra_mart.foundation.service.provider での HomeDirectory の使用

HomeDirectory を返す jp.co.intra_mart.foundation.service.provider のメソッド
static HomeDirectory HomeDirectory.instance()
ホームディレクトリを表すオブジェクトを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.Platform の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.Platform の使用

jp.co.intra_mart.foundation.service.provider.Platform はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.SystemErrorReporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.SystemErrorReporter の使用

SystemErrorReporter を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

jp.co.intra_mart.foundation.service.provider での SystemErrorReporter の使用

SystemErrorReporter として宣言されている jp.co.intra_mart.foundation.service.provider のフィールド
static SystemErrorReporter Platform.err
エラーログに対するメッセージ出力ストリームです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.SystemReporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.SystemReporter の使用

SystemReporter を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

jp.co.intra_mart.foundation.service.provider での SystemReporter の使用

jp.co.intra_mart.foundation.service.provider での SystemReporter のサブインタフェース
 interface SystemErrorReporter
エラーログ出力用のインターフェースです。

SystemReporter として宣言されている jp.co.intra_mart.foundation.service.provider のフィールド
static SystemReporter Platform.out
システムログに対するメッセージ出力ストリームです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.TemporaryDirectory の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.TemporaryDirectory の使用

TemporaryDirectory を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

jp.co.intra_mart.foundation.service.provider での TemporaryDirectory の使用

TemporaryDirectory を返す jp.co.intra_mart.foundation.service.provider のメソッド
static TemporaryDirectory TemporaryDirectory.instance()
一時ファイル保存用ディレクトリを表すオブジェクトを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.TemporaryFile の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.TemporaryFile の使用

jp.co.intra_mart.foundation.service.provider.TemporaryFile はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.file.StorageDirectory の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.file.StorageDirectory の使用

StorageDirectory を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.file このパッケージには、Storage Service 環境内で利用可能な機能を提供します。

jp.co.intra_mart.foundation.service.provider.file での StorageDirectory の使用

StorageDirectory を返す jp.co.intra_mart.foundation.service.provider.file のメソッド
static StorageDirectory StorageDirectory.instance()
ファイルコンテンツの保存ディレクトリを表すオブジェクトを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.service.provider.file (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.service.provider.file
クラス
StorageDirectory


jp.co.intra_mart.foundation.service.provider.file (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.file

このパッケージには、Storage Service 環境内で利用可能な機能を提供します。

参照:
説明

クラスの概要
StorageDirectory Storage Service の基準ディレクトリを表すクラスです。

パッケージ jp.co.intra_mart.foundation.service.provider.file の説明

このパッケージには、Storage Service 環境内で利用可能な機能を提供します。


jp.co.intra_mart.foundation.service.provider.file クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.file の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.io.File (implements java.lang.Comparable, java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.file.Directory
        • class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
          • class jp.co.intra_mart.foundation.service.provider.file.StorageDirectory


パッケージ jp.co.intra_mart.foundation.service.provider.file の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.provider.file の使用

jp.co.intra_mart.foundation.service.provider.file を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.file このパッケージには、Storage Service 環境内で利用可能な機能を提供します。

jp.co.intra_mart.foundation.service.provider.file により使用される jp.co.intra_mart.foundation.service.provider.file のクラス
StorageDirectory
Storage Service の基準ディレクトリを表すクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StorageDirectory (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.file
クラス StorageDirectory

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.foundation.utility.file.Directory
            拡張 jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
                拡張 jp.co.intra_mart.foundation.service.provider.file.StorageDirectory
すべての実装インタフェース:
Comparable, Serializable
public class StorageDirectory
extends ExtendedDirectory

Storage Service の基準ディレクトリを表すクラスです。

Storage Service は、このクラスが表すパスを基準ディレクトリとして、 各コンテンツのファイルパスを解決します。 標準では、サーバインストールディレクトリの storage ディレクトリが 基準ディレクトリとなります。

関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
メソッドの概要
static StorageDirectory instance()
ファイルコンテンツの保存ディレクトリを表すオブジェクトを取得します。
クラス jp.co.intra_mart.foundation.utility.file.ExtendedDirectory から継承したメソッド
archive, archive, archive, archive, archive, archive, childDirectory, childFile, childPath, findDirectory, findFile, findPath, reset
クラス jp.co.intra_mart.foundation.utility.file.Directory から継承したメソッド
childDirectories, childFiles, files, paths
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

メソッドの詳細

instance

public static StorageDirectory instance()
ファイルコンテンツの保存ディレクトリを表すオブジェクトを取得します。

戻り値:
File クラスのインスタンス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory の使用

PermanentDataDirectory を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.information このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。

jp.co.intra_mart.foundation.service.provider.information での PermanentDataDirectory の使用

PermanentDataDirectory を返す jp.co.intra_mart.foundation.service.provider.information のメソッド
static PermanentDataDirectory PermanentDataDirectory.instance()
データ保存ディレクトリを表すオブジェクトを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.service.provider.information (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.service.provider.information
クラス
PermanentDataDirectory


jp.co.intra_mart.foundation.service.provider.information (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.information

このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。

参照:
説明

クラスの概要
PermanentDataDirectory Permanent-data を保存するディレクトリを表すオブジェクトです。

パッケージ jp.co.intra_mart.foundation.service.provider.information の説明

このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。 このパッケージに含まれるクラスは、特定の実行環境内でのみ利用可能であり、クラスと各種サービスが密接に関わりあっています。したがって、このパッケージのクラスを利用する場合は、プログラムの実行環境に関して十分に注意をしてください。


jp.co.intra_mart.foundation.service.provider.information クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.information の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.io.File (implements java.lang.Comparable, java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.file.Directory
        • class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
          • class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory


パッケージ jp.co.intra_mart.foundation.service.provider.information の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.provider.information の使用

jp.co.intra_mart.foundation.service.provider.information を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.information このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。

jp.co.intra_mart.foundation.service.provider.information により使用される jp.co.intra_mart.foundation.service.provider.information のクラス
PermanentDataDirectory
Permanent-data を保存するディレクトリを表すオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PermanentDataDirectory (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.information
クラス PermanentDataDirectory

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.foundation.utility.file.Directory
            拡張 jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
                拡張 jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory
すべての実装インタフェース:
Comparable, Serializable
public class PermanentDataDirectory
extends ExtendedDirectory

Permanent-data を保存するディレクトリを表すオブジェクトです。 このオブジェクトが表すパスにデータファイルが作成されます。

導入されたバージョン:
Version 4.2
関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
メソッドの概要
void | backup(File f) このデータを指定のファイルにバックアップします。
ExtendedDirectory | entityDirectory() データファイルを保存しておくための ディレクトリを表すオブジェクトを取得します。
static PermanentDataDirectory | instance() データ保存ディレクトリを表すオブジェクトを取得します。
ExtendedDirectory | temporaryDirectory() 削除対象のデータファイルを一時的に保存しておくための ディレクトリを表すオブジェクトを取得します。
クラス jp.co.intra_mart.foundation.utility.file.ExtendedDirectory から継承したメソッド
archive, archive, archive, archive, archive, archive, childDirectory, childFile, childPath, findDirectory, findFile, findPath, reset
クラス jp.co.intra_mart.foundation.utility.file.Directory から継承したメソッド
childDirectories, childFiles, files, paths
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

メソッドの詳細

instance

public static PermanentDataDirectory instance()
データ保存ディレクトリを表すオブジェクトを取得します。

戻り値:
File クラスのインスタンス

entityDirectory

public ExtendedDirectory entityDirectory()
データファイルを保存しておくための ディレクトリを表すオブジェクトを取得します。

戻り値:
ディレクトリを表すオブジェクト

temporaryDirectory

public ExtendedDirectory temporaryDirectory()
削除対象のデータファイルを一時的に保存しておくための ディレクトリを表すオブジェクトを取得します。

このディレクトリには、データを更新する直前のデータファイルが 保存されます。

戻り値:
ディレクトリを表すオブジェクト

backup

public void backup(File f)
            throws IOException
このデータを指定のファイルにバックアップします。 作成されるファイルは、ZIP ファイル形式となります。

パラメータ:
f - 出力ファイルパス
例外:
IOException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Environment (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
インタフェース Environment

public interface Environment

このクラスは、 システムプロパティへアクセスするためのインターフェースです。

システムプロパティとは、サーバが動作するために必要な環境設定値のことです。 このクラスでアクセスできるプロパティは、Java-VM の持つシステムプロパティ とは異なります。Java-VM のシステムプロパティ値を取得する場合は、 java.lang.System クラスを利用して下さい。
このシステムプロパティのセットには、必ず以下のキーに対応する値が 含まれています。

キー | 対応する値の説明
system/server-charset | サーバが外部(ファイルなど)にアクセスする際に標準で利用する文字エンコーディング名
system/root | サーバのインストールディレクトリ

導入されたバージョン:
version4.0
関連項目:
System,
System.getProperty(String),
System.getProperty(String key, String),
System.getProperties()

メソッドの概要
String | getProperty(String key) 指定されたキーによって示されるシステムプロパティを取得します。
String | getProperty(String key, String defaultValue) 指定されたキーによって示されるシステムプロパティを取得します。
Enumeration | propertyNames() システムプロパティリストにあるすべてのキーのリストを返します。

メソッドの詳細

getProperty

public String getProperty(String key)
指定されたキーによって示されるシステムプロパティを取得します。 Enumeration から取得できる各要素は、すべて String クラスのインスタンス になります。

パラメータ:
key - システムプロパティの名前
戻り値:
システムプロパティの文字列値。そのキーにプロパティがない場合は null。
導入されたバージョン:
version4.0

getProperty

public String getProperty(String key,
                          String defaultValue)
指定されたキーによって示されるシステムプロパティを取得します。 Enumeration から取得できる各要素は、すべて String クラスのインスタンス になります。

パラメータ:
key - システムプロパティの名前
defaultValue - デフォルト値
戻り値:
システムプロパティの文字列値。そのキーにプロパティがない場合はデフォルト値。
導入されたバージョン:
version4.0

propertyNames

public Enumeration propertyNames()
システムプロパティリストにあるすべてのキーのリストを返します。 Enumeration から取得できる各要素は、すべて String クラスのインスタンス になります。

戻り値:
プロパティリストにあるすべてのキーのリスト。
導入されたバージョン:
version4.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


GarbageController (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
クラス GarbageController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.provider.GarbageController
public class GarbageController
extends Object

ガーベージコレクタを実行するクラスです。

このクラスにリスナーを登録しておくことにより、 gc メソッドが呼び出された時に任意のロジックを実行させることができます。 この機能を利用することにより、ガーベージコレクタ実行前に キャッシュデータなどを削除して、効率的にメモリ空間を開放することができます。

導入されたバージョン:
Version 3.2

メソッドの概要
static void | addConditioner(GCConditioner conditioner) 推奨されていません。
static void | addListener(EventListener listener) リスナーを登録します。
static void | clean() システムのガベージコレクタを実行します。
static void | removeConditioner(GCConditioner conditioner) 推奨されていません。
static boolean | removeListener(EventListener listener) 指定されたリスナーを削除します。
static void | startAutomaticExecution(long millis) 推奨されていません。 gc によるシステム停止や監視スレッドを停止処理しないことによるメモリリークなどの問題を引き起こす危険性があります。
static void | stopAutomaticExecution() 推奨されていません。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

addListener

public static void addListener(EventListener listener)
                        throws NullPointerException
リスナーを登録します。
clean メソッドが呼び出された時に、登録されているすべてのリスナーの handleEvent メソッドを呼び出します。 リスナーの実行順は、保証されません。
このメソッドは、listener が既に登録済みの場合は何もしません。

例外:
NullPointerException - listener が null の場合
関連項目:
clean(), EventListener.handleEvent()

removeListener

public static boolean removeListener(EventListener listener)
指定されたリスナーを削除します。

戻り値:
指定されたリスナーを格納していた場合 true

startAutomaticExecution

public static void startAutomaticExecution(long millis)
推奨されていません。 gc によるシステム停止や監視スレッドを停止処理しないことによるメモリリークなどの問題を引き起こす危険性があります。

gc の自動実行を行うモードを開始します。

この機能は、新しい専用のスレッドで millis ミリ秒おきに addConditioner メソッドで登録されたコンディショナオブジェクトを 実行して gc 実行の必要があると判断された場合に clean メソッドを実行します。 この自動実行スレッドは、stopAutomaticExecution メソッドが 呼び出されるまで上記処理を継続実行します。

gc 実行をするかどうかの判定をするためのコンディショナオブジェクトが 一つも登録されていない場合、このメソッドは何も行いません。
gc 自動実行モードが有効な状態でも、clean メソッドを呼び出すことによって 明示的に gc を実行することができます。

パラメータ:
millis - gc 自動実行のための監視間隔

stopAutomaticExecution

public static void stopAutomaticExecution()
推奨されていません。

gc 自動実行モードを終了します。

addConditioner

public static void addConditioner(GCConditioner conditioner)
推奨されていません。

gc 自動実行において gc を実行するかどうかを判断するための コンディショナを登録します。

パラメータ:
conditioner - コンディショナ
例外:
NullPointerException - conditioner が null の場合

removeConditioner

public static void removeConditioner(GCConditioner conditioner)
推奨されていません。

コンディショナを削除します。

パラメータ:
conditioner - コンディショナ

clean

public static void clean()
システムのガベージコレクタを実行します。

このメソッドは、addListener メソッドで登録された全てのイベントリスナーを 呼び出した後に、ＶＭのガーベージコレクタを実行します。
ガーベージコレクタの実行は、以下の呼出とおなじです。

System.gc()

このメソッドは、複数のスレッドからの多重処理を行いません。 あるスレッドによる実行中に他のスレッドでこのメソッドが呼び出された場合、 このメソッドは何もせずにリターンします。

関連項目:
System.gc()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


GCConditioner (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
インタフェース GCConditioner

public interface GCConditioner

GarbageController クラスが gc を実行するかどうか判断するための インターフェースを提供します。
GarbageController クラスは、startAutomaticExecution メソッドにより 自動実行されている場合、gc を実行するかどうか判断するために このインターフェースのサブクラスを呼び出します。 GarbageController クラスに登録されている GCConditioner のサブクラスのうち、 １つ以上のオブジェクトの cleanUp メソッドが true を返した場合、 GarbageController クラスは gc を実行します。

関連項目:
GarbageController

メソッドの概要
 boolean cleanUp()
gc を実行するかどうかを判断します。

メソッドの詳細

cleanUp

public boolean cleanUp()
gc を実行するかどうかを判断します。
このメソッドは、GarbageController クラスの自動実行プログラムにより gc を実行する前に呼び出されます。

戻り値:
gc を実行させたい場合 true
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HomeDirectory (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
クラス HomeDirectory

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory
                拡張 jp.co.intra_mart.foundation.service.provider.HomeDirectory
すべての実装インタフェース:
Comparable, Serializable
public class HomeDirectory
extends jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory

このクラスは、サーバ実行システムのホームディレクトリに関する機能を 提供します。

導入されたバージョン:
version 4.0
関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
メソッドの概要
static void | definePath(String path) 推奨されていません。
static String | findPath() システムのホームディレクトリを返します。
static HomeDirectory | instance() ホームディレクトリを表すオブジェクトを取得します。
クラス jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory から継承したメソッド
archive, archive, archive, archive, archive, archive, childDirectory, childFile, childPath, findDirectory, findFile, findPath, reset
クラス jp.co.intra_mart.common.aid.jdk.java.io.file.Directory から継承したメソッド
childDirectories, childFiles, deleteAll, deleteChilds, files, paths
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

メソッドの詳細

instance

public static HomeDirectory instance()
ホームディレクトリを表すオブジェクトを取得します。

戻り値:
ホームディレクトリを表す File クラスのインスタンス

definePath

public static void definePath(String path)
推奨されていません。

システムのホームディレクトリを設定します。 ホームディレクトリは、インストールディレクトリと同義です。

このメソッドは、システム全体を不安定にしてしまう危険性があるため、 通常は使用してはいけません。

パラメータ:
path - ホームディレクトリを表すパス名
例外:
NullPointerException - 引数が null の場合

findPath

public static String findPath()
システムのホームディレクトリを返します。 ホームディレクトリは、インストールディレクトリと同義です。

通常は、インストールされた環境と設定値から自動的にホームディレクトリが 決定されます。例外として、definePath() メソッドを使用して 意図的にホームディレクトリの情報を書き換えてしまった場合は、 書き換えられたパス情報が返されます。

戻り値:
ホームディレクトリを表すパス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.provider (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.service.provider
インタフェース
Environment
GCConditioner
SystemErrorReporter
SystemReporter
クラス
GarbageController
HomeDirectory
Platform
TemporaryDirectory
TemporaryFile


jp.co.intra_mart.foundation.service.provider (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider

このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

参照:
説明

インタフェースの概要
Environment | このクラスは、 システムプロパティへアクセスするためのインターフェースです。
GCConditioner | GarbageController クラスが gc を実行するかどうか判断するための インターフェースを提供します。
SystemErrorReporter | エラーログ出力用のインターフェースです。
SystemReporter | システムログの共通インターフェースです。

クラスの概要
GarbageController | ガーベージコレクタを実行するクラスです。
HomeDirectory | このクラスは、サーバ実行システムのホームディレクトリに関する機能を 提供します。
Platform | Platform クラスには、システム動作に関わる有用な情報を持つ フィールドおよびメソッドがあります。
TemporaryDirectory | このクラスは、一時ファイル保存用ディレクトリに関する機能を 提供します。
TemporaryFile | このクラスは、一時ファイルに関する機能を提供します。

パッケージ jp.co.intra_mart.foundation.service.provider の説明

このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
このパッケージまたはサブパッケージに含まれるクラスは、現在動作しているサーバプロセス環境において実行されます。他のサーバプロセスに対してリモートアクセスするためには、jp.co.intra_mart.foundation.service.client パッケージおよびそのサブパッケージに含まれるクラスを利用して下さい。

関連項目:
jp.co.intra_mart.foundation.service.client


jp.co.intra_mart.foundation.service.provider クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.io.File (implements java.lang.Comparable, java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.file.Directory
        • class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
          • class jp.co.intra_mart.foundation.service.provider.TemporaryDirectory
      • class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory
        • class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory
          • class jp.co.intra_mart.foundation.service.provider.HomeDirectory
      • class jp.co.intra_mart.foundation.utility.file.ExtendedFile
        • class jp.co.intra_mart.foundation.service.provider.TemporaryFile
    • class jp.co.intra_mart.foundation.service.provider.GarbageController
    • class jp.co.intra_mart.foundation.service.provider.Platform

インタフェース階層

  • interface jp.co.intra_mart.foundation.service.provider.Environment
  • interface jp.co.intra_mart.foundation.service.provider.GCConditioner
  • interface jp.co.intra_mart.foundation.service.provider.SystemReporter
    • interface jp.co.intra_mart.foundation.service.provider.SystemErrorReporter


パッケージ jp.co.intra_mart.foundation.service.provider の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.provider の使用

jp.co.intra_mart.foundation.service.provider を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

jp.co.intra_mart.foundation.service.provider により使用される jp.co.intra_mart.foundation.service.provider のクラス
Environment
このクラスは、 システムプロパティへアクセスするためのインターフェースです。
GCConditioner
GarbageController クラスが gc を実行するかどうか判断するための インターフェースを提供します。
HomeDirectory
このクラスは、サーバ実行システムのホームディレクトリに関する機能を 提供します。
SystemErrorReporter
エラーログ出力用のインターフェースです。
SystemReporter
システムログの共通インターフェースです。
TemporaryDirectory
このクラスは、一時ファイル保存用ディレクトリに関する機能を 提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Platform (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
クラス Platform

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.provider.Platform
public final class Platform
extends Object

Platform クラスには、システム動作に関わる有用な情報を持つ フィールドおよびメソッドがあります。 インスタンスを生成することはできません。

導入されたバージョン:
version 4.2

フィールドの概要
static SystemErrorReporter | err エラーログに対するメッセージ出力ストリームです。
static SystemReporter | out システムログに対するメッセージ出力ストリームです。
メソッドの概要
static Environment | getEnvironment() システムの設定値を持つオブジェクトを取得します。
static String | getEnvironmentProperty(String key) 指定のキーに対応するシステムの設定値を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

out

public static SystemReporter out
システムログに対するメッセージ出力ストリームです。 この出力に対して書き込まれたメッセージは、 システムログの設定に指定された出力先に書き出されます。

err

public static SystemErrorReporter err
エラーログに対するメッセージ出力ストリームです。 この出力に対して書き込まれたメッセージは、 エラーログの設定に指定された出力先に書き出されます。

メソッドの詳細

getEnvironmentProperty

public static String getEnvironmentProperty(String key)
指定のキーに対応するシステムの設定値を取得します。 このメソッドは該当するキーが存在しない場合 null を返します。

このメソッドの呼び出しは、以下の呼び出しと同じです。
Platform.getEnvironment().getProperty(key)

パラメータ:
key - 設定値へのキー名
戻り値:
キーに対応する設定値

getEnvironment

public static Environment getEnvironment()
システムの設定値を持つオブジェクトを取得します。 このメソッドにより返される設定値オブジェクトの状態は、 設定ファイル(conf/imart.xml)の状態に影響されます。

戻り値:
設定値オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SystemErrorReporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
インタフェース SystemErrorReporter

すべてのスーパーインタフェース:
SystemReporter
public interface SystemErrorReporter
extends SystemReporter

エラーログ出力用のインターフェースです。

メソッドの概要
 void write(String message, Throwable t)
メッセージをログに書き込みます。
インタフェース jp.co.intra_mart.foundation.service.provider.SystemReporter から継承したメソッド
flush, write

メソッドの詳細

write

public void write(String message,
                  Throwable t)
メッセージをログに書き込みます。 例外は、個別にファイル出力されます。

パラメータ:
message - ログに書き込むエラーメッセージ
t - 発生した例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SystemReporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
インタフェース SystemReporter

既知のサブインタフェースの一覧:
SystemErrorReporter
public interface SystemReporter

システムログの共通インターフェースです。

メソッドの概要
void | flush() ストリームをフラッシュします。
void | write(String message) メッセージをログに書き込みます。

メソッドの詳細

write

public void write(String message)
メッセージをログに書き込みます。

パラメータ:
message - ログに書き込むメッセージ

flush

public void flush()
           throws IOException
ストリームをフラッシュします。

現在バッファに保存されているデータが置換対象の文字データと 比較途中である場合、比較中のデータはフラッシュされません。 このストリームの持つすべてのバッファをフラッシュするためには、 finish() メソッドを呼び出したあとにこのメソッドを呼び出して下さい。
宛先が別の文字またはバイトストリームの場合は、 この宛先をフラッシュします。つまり 1 つの flush() の呼び出しで、 関連する Writer および OutputStream のすべてのバッファを フラッシュします。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


TemporaryDirectory (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
クラス TemporaryDirectory

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.foundation.utility.file.Directory
            拡張 jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
                拡張 jp.co.intra_mart.foundation.service.provider.TemporaryDirectory
すべての実装インタフェース:
Comparable, Serializable
public class TemporaryDirectory
extends ExtendedDirectory

このクラスは、一時ファイル保存用ディレクトリに関する機能を 提供します。

アプリケーション実行時に利用する一時ファイルを保存するための ディレクトリとして利用することができます。

導入されたバージョン:
version 4.0
関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
メソッドの概要
static File | getSystemTemporaryDirectory() システムが使用する一時ファイル保存ディレクトリを表す オブジェクトを返します。
static TemporaryDirectory | instance() 一時ファイル保存用ディレクトリを表すオブジェクトを取得します。
クラス jp.co.intra_mart.foundation.utility.file.ExtendedDirectory から継承したメソッド
archive, archive, archive, archive, archive, archive, childDirectory, childFile, childPath, findDirectory, findFile, findPath, reset
クラス jp.co.intra_mart.foundation.utility.file.Directory から継承したメソッド
childDirectories, childFiles, files, paths
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

メソッドの詳細

getSystemTemporaryDirectory

public static File getSystemTemporaryDirectory()
システムが使用する一時ファイル保存ディレクトリを表す オブジェクトを返します。
このメソッドが返すディレクトリに対してサブディレクトリや ファイルを作成すると、システムが不安定になる可能性があります。 ユーザプログラムで一時ファイルを利用する場合は、 instance() メソッドにて得られるパスに 作成するようにしてください。

戻り値:
一時ファイル保存用ディレクトリを表す File クラスのインスタンス

instance

public static TemporaryDirectory instance()
一時ファイル保存用ディレクトリを表すオブジェクトを取得します。

戻り値:
一時ファイル保存用ディレクトリを表す File クラスのインスタンス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TemporaryFile (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
クラス TemporaryFile

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.foundation.utility.file.ExtendedFile
            拡張 jp.co.intra_mart.foundation.service.provider.TemporaryFile
すべての実装インタフェース:
Comparable, Serializable
public class TemporaryFile
extends ExtendedFile

このクラスは、一時ファイルに関する機能を提供します。

アプリケーション実行時に一時的にデータを保存するための ファイルとして利用することができます。
このクラスは、インスタンス化されるたびに、新しいファイルのパスを 作成します。そのパスは、インスタンス化の時点ではディスク上に ファイルとして存在していません。

このクラスは、インスタンス化のたびに新しいファイルのパスを作成するため、 作成したファイルを削除しない場合、ディスク上に不要ファイルとして 残りつづけてしまう可能性がありますので、使用の際には十分に注意してください。

導入されたバージョン:
version 4.2
関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
コンストラクタの概要
TemporaryFile()
一時ファイルのパスを作成します。
クラス jp.co.intra_mart.foundation.utility.file.ExtendedFile から継承したメソッド
append, append, append, getBytes, readLines, readLines, readString, readString, write, write, write
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

TemporaryFile

public TemporaryFile()
一時ファイルのパスを作成します。 このコンストラクタを呼び出した時点では、ファイルとして 存在していないため、インスタンス化の後に新規ファイルとして 作成する必要があります。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.smtp.Mail の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.smtp.Mail の使用

jp.co.intra_mart.foundation.smtp.Mail はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Mail (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.smtp
クラス Mail

java.lang.Object
    拡張 jp.co.intra_mart.system.mail.smtp.InetMail
        拡張 jp.co.intra_mart.foundation.smtp.Mail
すべての実装インタフェース:
jp.co.intra_mart.system.javascript.imapi.MailSendErrDef, Serializable
推奨されていません。 MailSenderに置き換えられました。

public class Mail
extends jp.co.intra_mart.system.mail.smtp.InetMail
implements jp.co.intra_mart.system.javascript.imapi.MailSendErrDef, Serializable

SMTPサーバに対し、メールを送信します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.system.mail.smtp.InetMail から継承したフィールド
MAILER_NAME
インタフェース jp.co.intra_mart.system.javascript.imapi.MailSendErrDef から継承したフィールド
ERR_MAIL_CONFIG, ERR_MAIL_CONNECT, ERR_MAIL_FROM, ERR_MAIL_SERVER, ERR_MAIL_TO, ERR_UNEXPECTED, MAIL_SENDED
コンストラクタの概要
Mail()
推奨されていません。 メール送信オブジェクトの生成。
Mail(String server)
推奨されていません。 メール送信オブジェクトの生成。
Mail(String server, int port)
推奨されていません。 メール送信オブジェクトの生成。
メソッドの概要
void | attachFile(String fName, String b64Body) 推奨されていません。 添付ファイルの内容をセットする。
int | getErrCode() 推奨されていません。 メール送信時のエラーコードを返す。
String | getErrMessage() 推奨されていません。 メール送信時のエラーメッセージを返す。
boolean | send() 推奨されていません。 指定されたSMTPサーバへメールを送信する。
boolean | setBcc(String bcc) 推奨されていません。 Bccをセットする。
boolean | setBcc(String bcc, String alias) 推奨されていません。 Bccをセットする。
boolean | setBody(String body) 推奨されていません。 本文をセットする。
boolean | setCc(String cc) 推奨されていません。 Ccをセットする。
boolean | setCc(String cc, String alias) 推奨されていません。 Ccをセットする。
boolean | setFrom(String from) 推奨されていません。 Fromをセットする。
boolean | setFrom(String from, String alias) 推奨されていません。 Fromをセットする。
boolean | setHeader(String key, String value) 推奨されていません。 メールヘッダを設定する。
boolean | setReplyTo(String replyto) 推奨されていません。 リプライをセットする。
boolean | setReplyTo(String replyto, String alias) 推奨されていません。 リプライをセットする。
boolean | setSubject(String subject) 推奨されていません。 タイトルをセットする。
boolean | setTo(String to) 推奨されていません。 To(宛先)をセットする。
boolean | setTo(String to, String alias) 推奨されていません。 To(宛先)をセットする。
クラス jp.co.intra_mart.system.mail.smtp.InetMail から継承したメソッド
addBcc, addCc, addFile, addReplyTo, addTo, getBody, getHead, removeBcc, removeCc, removeReplyTo, removeTo, sendMail, setAnyHeader, setMailerName
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Mail

public Mail(String server,
            int port)
推奨されていません。
メール送信オブジェクトの生成。

パラメータ:
server - SMTPサーバアドレス

Mail

public Mail(String server)
推奨されていません。
メール送信オブジェクトの生成。

パラメータ:
server - SMTPサーバアドレス
ポート番号は 25 を使用します。

Mail

public Mail()
推奨されていません。
メール送信オブジェクトの生成。 SMTPサーバは conf/imart.confで設定されたサーバ を使用します。

メソッドの詳細

getErrMessage

public String getErrMessage()
推奨されていません。
メール送信時のエラーメッセージを返す。

戻り値:
エラーメッセージ

getErrCode

public int getErrCode()
推奨されていません。
メール送信時のエラーコードを返す。

戻り値:
エラーコード

attachFile

public void attachFile(String fName,
                       String b64Body)
                throws UnsupportedEncodingException,
                       IOException
推奨されていません。
添付ファイルの内容をセットする。

パラメータ:
fName - ファイル名
b64Body - BASE64エンコードされたファイルの内容
戻り値:
成功 true/失敗 false
例外:
UnsupportedEncodingException,IOException
UnsupportedEncodingException
IOException

setHeader

public boolean setHeader(String key,
                         String value)
推奨されていません。
メールヘッダを設定する。

送信するメールヘッダ情報を設定する。 設定可能なメールヘッダの種類は以下の通り。
Sender : 送った人のメールアドレス
Reply-To: 返信先メールアドレス
(その他にも任意にヘッダ情報を追加できますが、任意のヘッダを追加した場合の動作は 未検証です。)

パラメータ:
key - 設定するメールヘッダの種類
value - メールヘッダへの情報
戻り値:
成功 true/失敗 false

setBody

public boolean setBody(String body)
推奨されていません。
本文をセットする。

パラメータ:
body - 本文文字列
戻り値:
成功 true/失敗 false

setFrom

public boolean setFrom(String from,
                       String alias)
推奨されていません。
Fromをセットする。

パラメータ:
from - 送信者アドレス
alias - 送信者ニックネーム
戻り値:
成功 true/失敗 false

setFrom

public boolean setFrom(String from)
推奨されていません。
Fromをセットする。

パラメータ:
from - 送信者アドレス
戻り値:
成功 true/失敗 false

setSubject

public boolean setSubject(String subject)
推奨されていません。
タイトルをセットする。

パラメータ:
subject - タイトル文字列
戻り値:
成功 true/失敗 false

setReplyTo

public boolean setReplyTo(String replyto,
                          String alias)
推奨されていません。
リプライをセットする。

パラメータ:
replyto - リプライアドレス文字列
alias - リプライニックネーム
戻り値:
成功 true/失敗 false

setReplyTo

public boolean setReplyTo(String replyto)
推奨されていません。
リプライをセットする。

パラメータ:
replyto - リプライアドレス文字列
戻り値:
成功 true/失敗 false

setBcc

public boolean setBcc(String bcc,
                      String alias)
推奨されていません。
Bccをセットする。

パラメータ:
bcc - Bccアドレス文字列
alias - Bccニックネーム
戻り値:
成功 true/失敗 false

setBcc

public boolean setBcc(String bcc)
推奨されていません。
Bccをセットする。

パラメータ:
bcc - Bccアドレス文字列
戻り値:
成功 true/失敗 false

setCc

public boolean setCc(String cc,
                     String alias)
推奨されていません。
Ccをセットする。

パラメータ:
cc - Ccアドレス文字列
alias - Ccニックネーム
戻り値:
成功 true/失敗 false

setCc

public boolean setCc(String cc)
推奨されていません。
Ccをセットする。

パラメータ:
cc - Ccアドレス文字列
戻り値:
成功 true/失敗 false

setTo

public boolean setTo(String to,
                     String alias)
推奨されていません。
To(宛先)をセットする。

パラメータ:
to - Toアドレス文字列
alias - Toニックネーム
戻り値:
成功 true/失敗 false

setTo

public boolean setTo(String to)
推奨されていません。
To(宛先)をセットする。

パラメータ:
to - Toアドレス文字列
戻り値:
成功 true/失敗 false

send

public boolean send()
推奨されていません。
指定されたSMTPサーバへメールを送信する。

他のメソッドで設定した情報をもとにメールを送信する。 最低限必要な設定は宛先と送信者（setTo(),setFrom()メソッドで設定）

戻り値:
成功 true/失敗 false
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.smtp (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.smtp
クラス
Mail


jp.co.intra_mart.foundation.smtp (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.smtp

メール連携モジュール。

参照:
説明

クラスの概要
Mail 推奨されていません。 MailSenderに置き換えられました。

パッケージ jp.co.intra_mart.foundation.smtp の説明

メール連携モジュール。 メール送信のためのAPI群。


jp.co.intra_mart.foundation.smtp クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.smtp の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.system.mail.smtp.InetMail (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.smtp.Mail (implements jp.co.intra_mart.system.javascript.imapi.MailSendErrDef, java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.smtp の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.smtp の使用

jp.co.intra_mart.foundation.smtp はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.update.StandardUpdateAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.update.StandardUpdateAccessor の使用

jp.co.intra_mart.foundation.update.StandardUpdateAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.update.UpdateAccessor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.update.UpdateAccessor の使用

UpdateAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.update

jp.co.intra_mart.foundation.update での UpdateAccessor の使用

UpdateAccessor を実装している jp.co.intra_mart.foundation.update のクラス
 class StandardUpdateAccessor
情報更新管理アクセッサ標準実装クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.update.UpdateManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.update.UpdateManager の使用

jp.co.intra_mart.foundation.update.UpdateManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.update (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.update
インタフェース
UpdateAccessor
クラス
StandardUpdateAccessor
UpdateManager


jp.co.intra_mart.foundation.update (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.update

インタフェースの概要
UpdateAccessor 情報更新管理アクセッサインタフェース。

クラスの概要
StandardUpdateAccessor | 情報更新管理アクセッサ標準実装クラス。
UpdateManager | 情報更新管理マネージャ。


jp.co.intra_mart.foundation.update クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.update の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.update.StandardUpdateAccessor (implements jp.co.intra_mart.foundation.update.UpdateAccessor)
    • class jp.co.intra_mart.foundation.update.UpdateManager

インタフェース階層

  • interface jp.co.intra_mart.foundation.update.UpdateAccessor


パッケージ jp.co.intra_mart.foundation.update の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.update の使用

jp.co.intra_mart.foundation.update を使用しているパッケージ
jp.co.intra_mart.foundation.update

jp.co.intra_mart.foundation.update により使用される jp.co.intra_mart.foundation.update のクラス
UpdateAccessor
情報更新管理アクセッサインタフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardUpdateAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.update
クラス StandardUpdateAccessor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.update.StandardUpdateAccessor
すべての実装インタフェース:
UpdateAccessor
public class StandardUpdateAccessor
extends Object
implements UpdateAccessor

情報更新管理アクセッサ標準実装クラス。

情報更新の情報をＤＢに対して操作するアクセッサ実装クラスです。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
StandardUpdateAccessor()
メソッドの概要
void | delete(String groupId, String key) キーを削除します。
void | deleteAll(String groupId) すべてのキーを削除します。
String[] | getKeys(String groupId) 保存されているキーの一覧を取得します。
void | insert(String groupId, String key, Date date) キーを取得します。
Date | select(String groupId, String key) 更新日付を取得します。
void | update(String groupId, String key, Date date) キーの更新日付を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardUpdateAccessor

public StandardUpdateAccessor()
メソッドの詳細

delete

public void delete(String groupId,
                   String key)
            throws FoundationException
キーを削除します。

定義:
インタフェース UpdateAccessor 内の delete
パラメータ:
groupId - ログイングループID
key - 削除するキー
例外:
FoundationException

deleteAll

public void deleteAll(String groupId)
               throws FoundationException
すべてのキーを削除します。

定義:
インタフェース UpdateAccessor 内の deleteAll
パラメータ:
groupId - ログイングループID
例外:
FoundationException

getKeys

public String[] getKeys(String groupId)
                 throws FoundationException
保存されているキーの一覧を取得します。

定義:
インタフェース UpdateAccessor 内の getKeys
パラメータ:
groupId - ログイングループID
戻り値:
キーの一覧
例外:
FoundationException

insert

public void insert(String groupId,
                   String key,
                   Date date)
            throws FoundationException
キーを取得します。

定義:
インタフェース UpdateAccessor 内の insert
パラメータ:
groupId - ログイングループID
key - 作成するキー
例外:
FoundationException

select

public Date select(String groupId,
                   String key)
            throws FoundationException
更新日付を取得します。

定義:
インタフェース UpdateAccessor 内の select
パラメータ:
groupId - ログイングループID
key - 対象となるキー
戻り値:
更新日付
キーが存在しない場合はnullを返却します。
例外:
FoundationException

update

public void update(String groupId,
                   String key,
                   Date date)
            throws FoundationException
キーの更新日付を更新します。

定義:
インタフェース UpdateAccessor 内の update
パラメータ:
groupId - ログイングループID
key - 更新するキー
例外:
FoundationException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UpdateAccessor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.update
インタフェース UpdateAccessor

既知の実装クラスの一覧:
StandardUpdateAccessor
public interface UpdateAccessor

情報更新管理アクセッサインタフェース。

情報更新の情報を操作するアクセッサインタフェースです。
UpdateManagerでこのインタフェースを利用して情報にアクセスしています。

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
void | delete(String groupId, String key) キーを削除します。
void | deleteAll(String groupId) すべてのキーを削除します。
String[] | getKeys(String groupId) 保存されているキーの一覧を取得します。
void | insert(String groupId, String key, Date date) キーを取得します。
Date | select(String groupId, String key) 更新日付を取得します。
void | update(String groupId, String key, Date date) キーの更新日付を更新します。

メソッドの詳細

delete

public void delete(String groupId,
                   String key)
            throws FoundationException
キーを削除します。

パラメータ:
groupId - ログイングループID
key - 削除するキー
例外:
FoundationException

deleteAll

public void deleteAll(String groupId)
               throws FoundationException
すべてのキーを削除します。

パラメータ:
groupId - ログイングループID
例外:
FoundationException

getKeys

public String[] getKeys(String groupId)
                 throws FoundationException
保存されているキーの一覧を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
キーの一覧
例外:
FoundationException

insert

public void insert(String groupId,
                   String key,
                   Date date)
            throws FoundationException
キーを取得します。

パラメータ:
groupId - ログイングループID
key - 作成するキー
例外:
FoundationException

select

public Date select(String groupId,
                   String key)
            throws FoundationException
更新日付を取得します。

パラメータ:
groupId - ログイングループID
key - 対象となるキー
戻り値:
更新日付
キーが存在しない場合はnullを返却します。
例外:
FoundationException

update

public void update(String groupId,
                   String key,
                   Date date)
            throws FoundationException
キーの更新日付を更新します。

パラメータ:
groupId - ログイングループID
key - 更新するキー
例外:
FoundationException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UpdateManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.update
クラス UpdateManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.update.UpdateManager
public class UpdateManager
extends Object

情報更新管理マネージャ。

マスタデータなどの最終更新操作の日付を管理します。
マスタデータをメモリ上でプールする場合、
マスタデータの更新と同時にmodifyメソッドを利用して、更新管理を行っておくことにより、
getLastModifiedメソッドを用いて効果的にメモリ上にプールされているデータを更新できます。 データの種類によってユニークな更新管理キーを用いて管理できます。

なお、更新管理キーが 'im_' から始まるキーは、システム用として予約されています。
上記のキーを用いての更新系API（modfiy,remove など)を使用しないでください。

導入されたバージョン:
6.1
バージョン:
1.0

コンストラクタの概要
UpdateManager(String groupId)
コンストラクタ。
メソッドの概要
String | getGroupId() ログイングループIDを取得します。
String[] | getKeys() 保存されている更新管理キーの一覧を取得します。
Date | getLastModified(String key) 更新日付を取得します。
boolean | isUpDate(String key, Date now) 更新管理キーの更新日付が検証日付より新しいか検証します。
Date | modify(String key) 対象となる更新管理キーの更新日付を更新します。
void | remove(String key) 更新管理キーを削除します。
void | removeAll() すべての更新管理キーを削除します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UpdateManager

public UpdateManager(String groupId)
              throws FoundationException
コンストラクタ。

パラメータ:
groupId - ログイングループID。
例外:
FoundationException
メソッドの詳細

getKeys

public String[] getKeys()
                 throws FoundationException
保存されている更新管理キーの一覧を取得します。

戻り値:
更新管理キーの一覧
例外:
FoundationException

getLastModified

public Date getLastModified(String key)
                     throws FoundationException
更新日付を取得します。

パラメータ:
key - 対象となる更新管理キー
戻り値:
更新日付
更新管理キーが存在しない場合はnullを返却します。
例外:
FoundationException

isUpDate

public boolean isUpDate(String key,
                        Date now)
                 throws FoundationException
更新管理キーの更新日付が検証日付より新しいか検証します。

パラメータ:
key - 対象となる更新管理キー
now - 検証する日付
戻り値:
検証日付以降更新されていない：false
検証日付以降更新された：true
更新管理キーが存在しない場合： true
例外:
FoundationException

modify

public Date modify(String key)
            throws FoundationException
対象となる更新管理キーの更新日付を更新します。

更新日付にはこのメソッドが呼び出された時の日付が自動的に設定されます。
更新管理キーが存在しない場合は、新規に設定します。

パラメータ:
key - 対象となる更新管理キー
戻り値:
設定された更新日付
例外:
FoundationException

remove

public void remove(String key)
            throws FoundationException
更新管理キーを削除します。

パラメータ:
key - 削除対象の更新管理キー
例外:
FoundationException

removeAll

public void removeAll()
               throws FoundationException
すべての更新管理キーを削除します。

例外:
FoundationException

getGroupId

public String getGroupId()
ログイングループIDを取得します。

コンストラクタで指定したログイングループIDを返却します。

戻り値:
ログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter の使用

jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.charset.CharacterEncoder の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.charset.CharacterEncoder の使用

jp.co.intra_mart.foundation.utility.charset.CharacterEncoder はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.charset.ResourceFormatException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.charset.ResourceFormatException の使用

ResourceFormatException を使用しているパッケージ
jp.co.intra_mart.foundation.utility.charset このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.charset での ResourceFormatException の使用

ResourceFormatException をスローする jp.co.intra_mart.foundation.utility.charset のメソッド
protected void | CharacterEncoder.setCharacterEncoding(String enc) 推奨されていません。 このオブジェクトが対象とする文字エンコーディングを設定します。
static jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter | AdvancedOutputStreamWriter.createWriter(OutputStreamWriter writer) 推奨されていません。 AdvancedOutputStreamWriter のスーパークラス AdvancedOutputStreamWriter を作成します。

ResourceFormatException をスローする jp.co.intra_mart.foundation.utility.charset のコンストラクタ
CharacterEncoder(String enc)
推奨されていません。 文字コード変換のためのエンコーダを作成します。
AdvancedOutputStreamWriter(OutputStream out, String charsetName)
推奨されていません。 指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out)
推奨されていません。 デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, Charset cs)
推奨されていません。 与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, CharsetEncoder enc)
推奨されていません。 与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter writer)
推奨されていません。 OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException の使用

ResourceNotFoundException を使用しているパッケージ
jp.co.intra_mart.foundation.utility.charset このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.charset での ResourceNotFoundException の使用

ResourceNotFoundException をスローする jp.co.intra_mart.foundation.utility.charset のメソッド
protected void | CharacterEncoder.setCharacterEncoding(String enc) 推奨されていません。 このオブジェクトが対象とする文字エンコーディングを設定します。
static jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter | AdvancedOutputStreamWriter.createWriter(OutputStreamWriter writer) 推奨されていません。 AdvancedOutputStreamWriter のスーパークラス AdvancedOutputStreamWriter を作成します。

ResourceNotFoundException をスローする jp.co.intra_mart.foundation.utility.charset のコンストラクタ
CharacterEncoder(String enc)
推奨されていません。 文字コード変換のためのエンコーダを作成します。
AdvancedOutputStreamWriter(OutputStream out, String charsetName)
推奨されていません。 指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out)
推奨されていません。 デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, Charset cs)
推奨されていません。 与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, CharsetEncoder enc)
推奨されていません。 与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter writer)
推奨されていません。 OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AdvancedOutputStreamWriter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.charset
クラス AdvancedOutputStreamWriter

java.lang.Object
    拡張 java.io.Writer
        拡張 java.io.FilterWriter
            拡張 jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter クラスを使用してください。

public class AdvancedOutputStreamWriter
extends FilterWriter

このクラスは、基礎となる java.io.OutputStreamWriter をフィルタリングした Writer 機能を提供します。

通常、ASCII の範囲に含まれない文字は、java.io.OutputStreamWriter を 利用して相互に文字コード変換した場合、各文字エンコーディングの Unicode に対するマッピングの相違により、本来その文字エンコーディングにおいて 存在する文字であってもコード不明を意味する「?」に置き換えられてしまう ことがあります。 いわゆる、この文字化けに対して、文字コード変換前に、 対象となる文字エンコーディングに対する Unicode の正しい文字に 置換することで、いくつかの文字については正しく文字コード変換することが できます。
このクラスでは、この方式により文字化けを回避します。

文字化けに対する文字のマッピングおよび対応する文字エンコーディングに 関しては、CharacterEncoder クラスの仕様に準じます。

導入されたバージョン:
version4.3
関連項目:
jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter, jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException, jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException, CharacterEncoder

フィールドの概要
クラス java.io.FilterWriter から継承したフィールド
out
クラス java.io.Writer から継承したフィールド
lock
コンストラクタの概要
AdvancedOutputStreamWriter(OutputStream out)
推奨されていません。 デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, Charset cs)
推奨されていません。 与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, CharsetEncoder enc)
推奨されていません。 与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, String charsetName)
推奨されていません。 指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter writer)
推奨されていません。 OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。
メソッドの概要
static jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter | createWriter(OutputStreamWriter writer) 推奨されていません。 AdvancedOutputStreamWriter のスーパークラス AdvancedOutputStreamWriter を作成します。
String | getCharacterEncoding() 推奨されていません。 このオブジェクトが対象としている文字エンコーディング名を返します。
OutputStreamWriter | getOutputStreamWriter() 推奨されていません。 このオブジェクトの基礎出力となっている java.io.OutputStreamWriter を返します。
void | write(char[] cbuf, int off, int len) 推奨されていません。 文字の配列の一部を書き込みます。
void | write(int c) 推奨されていません。 単一の文字を書き込みます。
void | write(String str, int off, int len) 推奨されていません。 文字列の一部を書き込みます。
クラス java.io.FilterWriter から継承したメソッド
close, flush
クラス java.io.Writer から継承したメソッド
write, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStream out,
                                  String charsetName)
                           throws UnsupportedEncodingException,
                                  ResourceNotFoundException,
                                  ResourceFormatException,
                                  IOException
推奨されていません。
指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。

パラメータ:
out - 基礎となる出力ストリーム
charsetName - サポートされる charset の名前
例外:
UnsupportedEncodingException - 指定された文字エンコーディングがサポートされていない場合
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
IOException - 設定の読み込みエラー
ResourceFormatException - 設定に不整合がある場合

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStream out)
                           throws ResourceFormatException,
                                  ResourceNotFoundException,
                                  IOException
推奨されていません。
デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。

パラメータ:
out - 基礎となる出力ストリーム
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
IOException - 設定の読み込みエラー
ResourceFormatException - 設定に不整合がある場合

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStream out,
                                  Charset cs)
                           throws IOException,
                                  ResourceFormatException,
                                  ResourceNotFoundException
推奨されていません。
与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。

パラメータ:
out - 基礎となる出力ストリーム
cs - サポートされる Charset
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
IOException - 入出力エラー
ResourceFormatException - 設定に不整合がある場合

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStream out,
                                  CharsetEncoder enc)
                           throws ResourceFormatException,
                                  IOException,
                                  ResourceNotFoundException
推奨されていません。
与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。

パラメータ:
out - 基礎となる出力ストリーム
enc - 文字エンコーディングエンコーダ
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
IOException - 設定の読み込みエラー
ResourceFormatException - 設定に不整合がある場合

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStreamWriter writer)
                           throws ResourceNotFoundException,
                                  IOException,
                                  ResourceFormatException
推奨されていません。
OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。

なお、このオブジェクトが対応する文字エンコーディングは、 java.io.OutputStreamWriter#getEncoding() の返す値によって 決定します。 java.io.OutputStreamWriter#getEncoding() が null を返す場合、 このコンストラクタは NUllPointerException をスローして オブジェクトの作成に失敗します。

パラメータ:
writer - 基本となるストリームを提供する java.io.OutputStreamWriter オブジェクト
例外:
NullPointerException - 引数が null の場合
jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException - 設定に不整合がある場合
IOException - 設定の読み込みエラー
ResourceNotFoundException
ResourceFormatException
メソッドの詳細

createWriter

public static jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter createWriter(OutputStreamWriter writer)
                                                                                throws IOException,
                                                                                ResourceNotFoundException,
                                                                                ResourceFormatException
推奨されていません。
AdvancedOutputStreamWriter のスーパークラス AdvancedOutputStreamWriter を作成します。

パラメータ:
writer -
戻り値:
jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter
例外:
IOException
ResourceNotFoundException
ResourceFormatException

getCharacterEncoding

public String getCharacterEncoding()
推奨されていません。
このオブジェクトが対象としている文字エンコーディング名を返します。

戻り値:
文字エンコーディング名

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
推奨されていません。
文字の配列の一部を書き込みます。

パラメータ:
cbuf - き込む文字のバッファ
off - 文字の読み込み開始オフセット
len - 書き込む文字数
例外:
IOException - 入出力エラーが発生した場合

write

public void write(int c)
           throws IOException
推奨されていません。
単一の文字を書き込みます。

パラメータ:
c - 書き込む文字を指定する int
例外:
IOException - 入出力エラーが発生した場合

write

public void write(String str,
                  int off,
                  int len)
           throws IOException
推奨されていません。
文字列の一部を書き込みます。

パラメータ:
str - 書き込まれる文字列
off - 文字の読み込み開始オフセット
len - 書き込む文字数
例外:
IOException - 入出力エラーが発生した場合

getOutputStreamWriter

public OutputStreamWriter getOutputStreamWriter()
推奨されていません。
このオブジェクトの基礎出力となっている java.io.OutputStreamWriter を返します。

戻り値:
基礎となっている java.io.OutputStreamWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CharacterEncoder (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.charset
クラス CharacterEncoder

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.charset.CharacterEncoder
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder クラスを使用してください。

public class CharacterEncoder
extends Object

このクラスは、文字エンコードの機能を提供します。

このクラスは、Java runtime が提供する通常の文字コード変換において 文字のマッピング定義の相違に起因して文字化けしてしまう現象を解決するための 一つの方法となります。 実際には、定義ファイルに設定されている文字をネイティブコードへ変換する前に 他の文字へ変更する事により、文字化けを防ぎます。

例えば、EUC_JP における文字「～」は、 Unicode へ変換した際 0x301C(Wave Dash) にマッピングされます。 これに対して、SJIS では文字「～」は、 Unicode の 0xFF5E(Fullwidth Tilde) にマッピングされています。 このため、相互に文字コード変換をすると、 文字「?」に置き換わると言う現象(いわゆる文字化け)が発生します。
このクラスでは、Unicode から SJIS へ変換する際に Unicode の文字 0x301C(Wave Dash) を 0xFF5E(Fullwidth Tilde) へ変更してから 文字コード変換を行います。

定義ファイルは、クラスローダを利用して検索および読み込まれます。 したがって、定義ファイルはクラスパスに設定されているディレクトリまたは アーカイブファイル内に配置する必要があります。
各文字エンコーディングと文字の変換テーブルの関連については、 定義ファイル jp/co/intra_mart/resources/charset/encoding/mapping.xml に記載されています。

導入されたバージョン:
version4.3
関連項目:
CharacterEncoder, ResourceNotFoundException, ResourceFormatException

コンストラクタの概要
CharacterEncoder(String enc)
推奨されていません。 文字コード変換のためのエンコーダを作成します。
メソッドの概要
byte[] | encode(char c) 推奨されていません。 指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。
byte[] | encode(char[] c) 推奨されていません。 指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。
byte[] | encode(String str) 推奨されていません。 指定の文字列を getCharacterEncoding() で表される文字コードへ エンコードします。
String | getCharacterEncoding() 推奨されていません。 このオブジェクトが対象としている文字エンコーディング名を返します。
String | newString(char[] c) 推奨されていません。 getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
String | newString(String str) 推奨されていません。 getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
protected void | setCharacterEncoding(String enc) 推奨されていません。 このオブジェクトが対象とする文字エンコーディングを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CharacterEncoder

public CharacterEncoder(String enc)
                 throws ResourceNotFoundException,
                        ResourceFormatException,
                        IOException
推奨されていません。
文字コード変換のためのエンコーダを作成します。

パラメータ:
enc - エンコーディング名
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 設定が見つからなかった場合
ResourceFormatException - 設定情報が不適切だった場合
IOException - 入出力エラー
メソッドの詳細

getCharacterEncoding

public String getCharacterEncoding()
推奨されていません。
このオブジェクトが対象としている文字エンコーディング名を返します。

戻り値:
文字エンコーディング名

setCharacterEncoding

protected void setCharacterEncoding(String enc)
                             throws ResourceFormatException,
                                    ResourceNotFoundException,
                                    IOException
推奨されていません。
このオブジェクトが対象とする文字エンコーディングを設定します。

パラメータ:
enc - エンコーディング名
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 設定が見つからなかった場合
ResourceFormatException - 設定情報が不適切だった場合
IOException - 入出力エラー

encode

public byte[] encode(char c)
              throws UnsupportedEncodingException,
                     IOException
推奨されていません。
指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。

パラメータ:
c - 文字
戻り値:
エンコードされたバイト列
例外:
UnsupportedEncodingException
IOException

encode

public byte[] encode(char[] c)
              throws UnsupportedEncodingException,
                     IOException
推奨されていません。
指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。

パラメータ:
c - 文字配列
戻り値:
エンコードされたバイト列
例外:
UnsupportedEncodingException
IOException

encode

public byte[] encode(String str)
              throws UnsupportedEncodingException,
                     IOException
推奨されていません。
指定の文字列を getCharacterEncoding() で表される文字コードへ エンコードします。

パラメータ:
str - 文字列
戻り値:
エンコードされたバイト列
例外:
UnsupportedEncodingException
IOException

newString

public String newString(String str)
推奨されていません。
getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。

返される文字列は、引数 str のマッピングを修正した 新しい文字列です。

パラメータ:
str - 文字列
戻り値:
マッピングを修正された新しい文字列

newString

public String newString(char[] c)
推奨されていません。
getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。

返される文字列は、引数 c のマッピングを修正した 新しい文字列です。
引数の配列 c は変化しません。

パラメータ:
c - 文字配列
戻り値:
新しい文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.utility.charset (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.utility.charset
クラス
AdvancedOutputStreamWriter
CharacterEncoder
例外
ResourceFormatException
ResourceNotFoundException


jp.co.intra_mart.foundation.utility.charset (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.charset

このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

参照:
説明

クラスの概要
AdvancedOutputStreamWriter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter クラスを使用してください。
CharacterEncoder | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder クラスを使用してください。

例外の概要
ResourceFormatException | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException クラスを使用してください。
ResourceNotFoundException | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException クラスを使用してください。

パッケージ jp.co.intra_mart.foundation.utility.charset の説明

このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。


jp.co.intra_mart.foundation.utility.charset クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.charset の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException
          • class jp.co.intra_mart.foundation.utility.charset.ResourceFormatException
        • class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException
          • class jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException
    • class java.io.Writer
      • class java.io.FilterWriter
        • class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter


パッケージ jp.co.intra_mart.foundation.utility.charset の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.utility.charset の使用

jp.co.intra_mart.foundation.utility.charset を使用しているパッケージ
jp.co.intra_mart.foundation.utility.charset このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.charset により使用される jp.co.intra_mart.foundation.utility.charset のクラス
ResourceFormatException
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException クラスを使用してください。
ResourceNotFoundException
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ResourceFormatException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.charset
クラス ResourceFormatException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException
                拡張 jp.co.intra_mart.foundation.utility.charset.ResourceFormatException
すべての実装インタフェース:
Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException クラスを使用してください。

public class ResourceFormatException
extends jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException

リソースの内容が不適切であることを通知する例外です。

設定の内容に誤りがあるか、または定義の書式が正しくない場合にスローされます。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
ResourceFormatException(String msg)
推奨されていません。 指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceFormatException(String msg, Throwable cause)
推奨されていません。 指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ResourceFormatException

public ResourceFormatException(String msg)
推奨されていません。
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

ResourceFormatException

public ResourceFormatException(String msg,
                               Throwable cause)
推奨されていません。
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ResourceNotFoundException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.charset
クラス ResourceNotFoundException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException
                拡張 jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException
すべての実装インタフェース:
Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException クラスを使用してください。

public class ResourceNotFoundException
extends jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException

リソースがないことを通知する例外です。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
ResourceNotFoundException(String msg)
推奨されていません。 指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceNotFoundException(String msg, Throwable cause)
推奨されていません。 指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ResourceNotFoundException

public ResourceNotFoundException(String msg)
推奨されていません。
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

ResourceNotFoundException

public ResourceNotFoundException(String msg,
                                 Throwable cause)
推奨されていません。
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.utility.AbstractDualComparator の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.AbstractDualComparator の使用

AbstractDualComparator を使用しているパッケージ
jp.co.intra_mart.foundation.page | ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.utility | このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.page での AbstractDualComparator の使用

jp.co.intra_mart.foundation.page での AbstractDualComparator のサブクラス
 class NodeTypeComparator
ツリービューのノードを種類順にソートするためのコンパレータです。

jp.co.intra_mart.foundation.utility での AbstractDualComparator の使用

jp.co.intra_mart.foundation.utility での AbstractDualComparator のサブクラス
 class MultiComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.Counter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.Counter の使用

jp.co.intra_mart.foundation.utility.Counter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.DualComparator の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.DualComparator の使用

DualComparator を使用しているパッケージ
jp.co.intra_mart.foundation.page | ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.utility | このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.page での DualComparator の使用

DualComparator を実装している jp.co.intra_mart.foundation.page のクラス
 class NodeTypeComparator
ツリービューのノードを種類順にソートするためのコンパレータです。

jp.co.intra_mart.foundation.utility での DualComparator の使用

DualComparator を実装している jp.co.intra_mart.foundation.utility のクラス
class | AbstractDualComparator 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator クラスを使用してください。
class | MultiComparator 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.ErrorEvent の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.ErrorEvent の使用

ErrorEvent を使用しているパッケージ
jp.co.intra_mart.foundation.utility このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility での ErrorEvent の使用

ErrorEvent 型のパラメータを持つ jp.co.intra_mart.foundation.utility のメソッド
 void ErrorEventListener.reportError(ErrorEvent err)
推奨されていません。 発生した例外を通知します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.ErrorEventListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.ErrorEventListener の使用

ErrorEventListener を使用しているパッケージ
jp.co.intra_mart.foundation.utility.io このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.io での ErrorEventListener の使用

ErrorEventListener 型のパラメータを持つ jp.co.intra_mart.foundation.utility.io のコンストラクタ
ExtendedOutputStream(OutputStream out, ErrorEventListener listener)
推奨されていません。 出力ストリームを構築します。
ExtendedInputStream(InputStream in, ErrorEventListener listener)
推奨されていません。 入力ストリームを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.EventListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.EventListener の使用

EventListener を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.utility | このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.service.provider での EventListener の使用

EventListener 型のパラメータを持つ jp.co.intra_mart.foundation.service.provider のメソッド
static void | GarbageController.addListener(EventListener listener) リスナーを登録します。
static boolean | GarbageController.removeListener(EventListener listener) 指定されたリスナーを削除します。

jp.co.intra_mart.foundation.utility での EventListener の使用

EventListener 型のパラメータを持つ jp.co.intra_mart.foundation.utility のメソッド
 void EventQueueController.entry(EventListener listener)
推奨されていません。 イベントリスナーの登録。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.EventQueueController の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.EventQueueController の使用

EventQueueController を使用しているパッケージ
jp.co.intra_mart.foundation.utility.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.report での EventQueueController の使用

EventQueueController 型のパラメータを持つ jp.co.intra_mart.foundation.utility.report のコンストラクタ
RepresentativeReporter(MessageReporter out, EventQueueController queue)
推奨されていません。 指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.ExtendedThread の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.ExtendedThread の使用

jp.co.intra_mart.foundation.utility.ExtendedThread はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.FilterComparator の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.FilterComparator の使用

FilterComparator を使用しているパッケージ
jp.co.intra_mart.foundation.utility このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility での FilterComparator の使用

jp.co.intra_mart.foundation.utility での FilterComparator のサブクラス
 class ReverseComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.FixedSizeMap の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.FixedSizeMap の使用

jp.co.intra_mart.foundation.utility.FixedSizeMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.LockMonitor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.LockMonitor の使用

jp.co.intra_mart.foundation.utility.LockMonitor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.MultiComparator の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.MultiComparator の使用

jp.co.intra_mart.foundation.utility.MultiComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions の使用

MultipurposeInternetMailExtensions を使用しているパッケージ
jp.co.intra_mart.foundation.http ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.http での MultipurposeInternetMailExtensions の使用

MultipurposeInternetMailExtensions 型のパラメータを持つ jp.co.intra_mart.foundation.http のコンストラクタ
FileSender(HttpServletResponse httpResponse, MultipurposeInternetMailExtensions mimeType)
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSender(HttpServletResponse httpResponse, MultipurposeInternetMailExtensions mimeType, String filename)
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.ResourceBundleProperties の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.ResourceBundleProperties の使用

jp.co.intra_mart.foundation.utility.ResourceBundleProperties はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.ReverseComparator の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.ReverseComparator の使用

jp.co.intra_mart.foundation.utility.ReverseComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.SequenceComparator の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.SequenceComparator の使用

jp.co.intra_mart.foundation.utility.SequenceComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.ThreadStopListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.ThreadStopListener の使用

ThreadStopListener を使用しているパッケージ
jp.co.intra_mart.foundation.utility このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility での ThreadStopListener の使用

ThreadStopListener 型のパラメータを持つ jp.co.intra_mart.foundation.utility のメソッド
 void ExtendedThread.addThreadStopListener(ThreadStopListener listener)
推奨されていません。 このスレッドが終了したときに呼び出されるイベントリスナーを登録します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.file.Directory の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.file.Directory の使用

Directory を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.service.provider.file | このパッケージには、Storage Service 環境内で利用可能な機能を提供します。
jp.co.intra_mart.foundation.service.provider.information | このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。
jp.co.intra_mart.foundation.utility.file | このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

jp.co.intra_mart.foundation.service.provider での Directory の使用

jp.co.intra_mart.foundation.service.provider での Directory のサブクラス
 class TemporaryDirectory
このクラスは、一時ファイル保存用ディレクトリに関する機能を 提供します。

jp.co.intra_mart.foundation.service.provider.file での Directory の使用

jp.co.intra_mart.foundation.service.provider.file での Directory のサブクラス
 class StorageDirectory
Storage Service の基準ディレクトリを表すクラスです。

jp.co.intra_mart.foundation.service.provider.information での Directory の使用

jp.co.intra_mart.foundation.service.provider.information での Directory のサブクラス
 class PermanentDataDirectory
Permanent-data を保存するディレクトリを表すオブジェクトです。

jp.co.intra_mart.foundation.utility.file での Directory の使用

jp.co.intra_mart.foundation.utility.file での Directory のサブクラス
 class ExtendedDirectory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.file.ExtendedDirectory の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.file.ExtendedDirectory の使用

ExtendedDirectory を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.service.provider.file | このパッケージには、Storage Service 環境内で利用可能な機能を提供します。
jp.co.intra_mart.foundation.service.provider.information | このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。
jp.co.intra_mart.foundation.utility.file | このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

jp.co.intra_mart.foundation.service.provider での ExtendedDirectory の使用

jp.co.intra_mart.foundation.service.provider での ExtendedDirectory のサブクラス
 class TemporaryDirectory
このクラスは、一時ファイル保存用ディレクトリに関する機能を 提供します。

jp.co.intra_mart.foundation.service.provider.file での ExtendedDirectory の使用

jp.co.intra_mart.foundation.service.provider.file での ExtendedDirectory のサブクラス
 class StorageDirectory
Storage Service の基準ディレクトリを表すクラスです。

jp.co.intra_mart.foundation.service.provider.information での ExtendedDirectory の使用

jp.co.intra_mart.foundation.service.provider.information での ExtendedDirectory のサブクラス
 class PermanentDataDirectory
Permanent-data を保存するディレクトリを表すオブジェクトです。

ExtendedDirectory を返す jp.co.intra_mart.foundation.service.provider.information のメソッド
ExtendedDirectory | PermanentDataDirectory.entityDirectory() データファイルを保存しておくための ディレクトリを表すオブジェクトを取得します。
ExtendedDirectory | PermanentDataDirectory.temporaryDirectory() 削除対象のデータファイルを一時的に保存しておくための ディレクトリを表すオブジェクトを取得します。

jp.co.intra_mart.foundation.utility.file での ExtendedDirectory の使用

ExtendedDirectory を返す jp.co.intra_mart.foundation.utility.file のメソッド
ExtendedDirectory | ExtendedDirectory.childDirectory(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
protected ExtendedDirectory | ExtendedDirectory.findDirectory(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.file.ExtendedFile の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.file.ExtendedFile の使用

ExtendedFile を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.utility.file | このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

jp.co.intra_mart.foundation.service.provider での ExtendedFile の使用

jp.co.intra_mart.foundation.service.provider での ExtendedFile のサブクラス
 class TemporaryFile
このクラスは、一時ファイルに関する機能を提供します。

jp.co.intra_mart.foundation.utility.file での ExtendedFile の使用

ExtendedFile を返す jp.co.intra_mart.foundation.utility.file のメソッド
ExtendedFile | ExtendedDirectory.childFile(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
protected ExtendedFile | ExtendedDirectory.findFile(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Directory (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.file
クラス Directory

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.foundation.utility.file.Directory
すべての実装インタフェース:
Comparable, Serializable
直系の既知のサブクラス:
ExtendedDirectory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。

public class Directory
extends File

このクラスは、ディレクトリを扱う時に便利な機能を提供します。

このクラスは java.io.File クラスをベースに、オブジェクトが表す抽象パスが ディレクトリである場合に利用することができます。

関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
コンストラクタの概要
Directory(File parent, String child)
推奨されていません。 親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
Directory(String pathname)
推奨されていません。 指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
Directory(String parent, String child)
推奨されていません。 親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
メソッドの概要
Collection | childDirectories() 推奨されていません。 この抽象パス名が示すディレクトリにあるサブディレクトリの抽象パスを 繰り返し処理する反復子を作成します。
Collection | childFiles() 推奨されていません。 この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
Collection | files(int depth) 推奨されていません。 この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
Collection | paths(int depth) 推奨されていません。 この抽象パス名が示すディレクトリにあるファイルおよびディレクトリの 抽象パスを繰り返し処理する反復子を作成します。
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Directory

public Directory(String pathname)
推奨されていません。
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。 指定された文字列が空の文字列の場合、結果は空の抽象パス名になります。

パラメータ:
pathname - パス名文字列
例外:
NullPointerException - pathname 引数が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合
関連項目:
File.File(File, String)

Directory

public Directory(File parent,
                 String child)
推奨されていません。
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。

parent が null の場合、新しい File のインスタンスは、 指定された child パス名文字列で単一引数の File コンストラクタを 呼び出したように生成されます。

そうでない場合、parent 抽象パス名はディレクトリを示し、 child パス名文字列はディレクトリまたはファイルを示します。 child パス名文字列が絶対の場合、 それはシステムに依存する方法で相対パス名に変換されます。 parent が空の抽象パス名の場合、新しい File のインスタンスは、 child を抽象パス名に変換し、その結果をシステムに依存する デフォルトディレクトリを基準に解決することで生成されます。 そうでない場合、各パス名文字列は抽象パス名に変換され、 子抽象パス名は親を基準に解決されます。

パラメータ:
parent - 親抽象パス名
child - 子パス名文字列
例外:
NullPointerException - child が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合
関連項目:
File.File(File, String)

Directory

public Directory(String parent,
                 String child)
推奨されていません。
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。

parent が null の場合、新しい File のインスタンスは、 指定された child パス名文字列で単一引数の File コンストラクタを 呼び出したように生成されます。 そうでない場合、parent パス名文字列はディレクトリを示し、 child パス名文字列はディレクトリまたはファイルを示します。 child パス名文字列が絶対の場合、 それはシステムに依存する方法で相対パス名に変換されます。 parent が空の文字列の場合、新しい File のインスタンスは、 child を抽象パス名に変換し、 その結果をシステムに依存するデフォルトディレクトリを基準に 解決することで生成されます。 そうでない場合、各パス名文字列は抽象パス名に変換され、 子抽象パス名は親を基準に解決されます。

パラメータ:
parent - 親パス名文字列
child - 子パス名文字列
例外:
NullPointerException - child が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合
関連項目:
File.File(File, String)
メソッドの詳細

childDirectories

public Collection childDirectories()
推奨されていません。
この抽象パス名が示すディレクトリにあるサブディレクトリの抽象パスを 繰り返し処理する反復子を作成します。 反復子が返す各要素は、ディレクトリを表す java.io.File クラスのインスタンスです。

戻り値:
ディレクトリパスを繰り返し処理する反復子

childFiles

public Collection childFiles()
推奨されていません。
この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。 反復子が返す各要素は、ファイルを表す java.io.File クラスのインスタンスです。

戻り値:
ファイルパスを繰り返し処理する反復子

paths

public Collection paths(int depth)
推奨されていません。
この抽象パス名が示すディレクトリにあるファイルおよびディレクトリの 抽象パスを繰り返し処理する反復子を作成します。 反復子が返す各要素は、ファイルまたはディレクトリを表す java.io.File クラスのインスタンスです。

パラメータ:
depth - 検索をするサブディレクトリの深さ
戻り値:
ファイルパスを繰り返し処理する反復子
例外:
IllegalArgumentException - depth 引数が 1 よりも小さい場合

files

public Collection files(int depth)
推奨されていません。
この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。 反復子が返す各要素は、ファイルを表す java.io.File クラスのインスタンスです。

パラメータ:
depth - 検索をするサブディレクトリの深さ
戻り値:
ファイルパスを繰り返し処理する反復子
例外:
IllegalArgumentException - depth 引数が 1 よりも小さい場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedDirectory (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.file
クラス ExtendedDirectory

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.foundation.utility.file.Directory
            拡張 jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
すべての実装インタフェース:
Comparable, Serializable
直系の既知のサブクラス:
PermanentDataDirectory, StorageDirectory, TemporaryDirectory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。

public class ExtendedDirectory
extends Directory

File インスタンスを作成するためのファクトリクラスです。

このクラスは、指定のディレクトリを親とすして、相対パスにより解決される 抽象パスを表す File インスタンスを生成する機能を提供します。 生成された File インスタンスは、オブジェクト内にプールされるため、 同じパスを繰り返し利用ようなプログラムで利用することにより、 メモリリソースを節約することができます。

関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
コンストラクタの概要
ExtendedDirectory(File parent, String path, int size)
推奨されていません。 File オブジェクトを作成するためのファクトリオブジェクトを作成します。
ExtendedDirectory(String pathname, int size)
推奨されていません。 File オブジェクトを作成するためのファクトリオブジェクトを作成します。
メソッドの概要
void | archive(File f) 推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
void | archive(File f, FileFilter filter) 推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
void | archive(OutputStream out) 推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
void | archive(OutputStream out, FileFilter filter) 推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
void | archive(ZipOutputStream out) 推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
void | archive(ZipOutputStream out, FileFilter filter) 推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
ExtendedDirectory | childDirectory(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
ExtendedFile | childFile(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
File | childPath(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
protected ExtendedDirectory | findDirectory(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
protected ExtendedFile | findFile(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
protected File | findPath(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
void | reset() 推奨されていません。 キャッシュ領域をクリアします。
クラス jp.co.intra_mart.foundation.utility.file.Directory から継承したメソッド
childDirectories, childFiles, files, paths
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtendedDirectory

public ExtendedDirectory(String pathname,
                         int size)
推奨されていません。
File オブジェクトを作成するためのファクトリオブジェクトを作成します。

このオブジェクトは、File インスタンスのプール機能を実装しています。 引数 size はプールのサイズを指定して下さい。プールは、最大で size 個のインスタンスをキャッシュするように動作します。

パラメータ:
pathname - ディレクトリパス
size - キャッシュサイズ
例外:
NullPointerException - 引数 parent が null の場合
IllegalArgumentException - 引数 size が 1 よりも小さい場合

ExtendedDirectory

public ExtendedDirectory(File parent,
                         String path,
                         int size)
推奨されていません。
File オブジェクトを作成するためのファクトリオブジェクトを作成します。

このオブジェクトは、File インスタンスのプール機能を実装しています。 このオブジェクトのパスは、parent を親ディレクトリとした 子抽象パス path により解決されます。
引数 size はプールのサイズを指定して下さい。プールは、最大で size 個のインスタンスをキャッシュするように動作します。

パラメータ:
parent - 親ディレクトリ
path - パス
size - キャッシュサイズ
例外:
NullPointerException - 引数 parent が null の場合
IllegalArgumentException - 引数 size が 1 よりも小さい場合
メソッドの詳細

childFile

public ExtendedFile childFile(String path)
推奨されていません。
このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合

findFile

protected ExtendedFile findFile(String path)
推奨されていません。
このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。

このメソッドは、childFile メソッドが要求されたファイルオブジェクトを プールしていなかった場合に、新しいファイルオブジェクトを作成するために 呼び出します。 サブクラスは、このメソッドをオーバーライドすることにより、 ファイルインスタンスを任意に作成することができます。

このメソッドは、単純にこのオブジェクトを親ディレクトリとして 引数 path を解決したファイルオブジェクトを作成して返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合

childDirectory

public ExtendedDirectory childDirectory(String path)
推奨されていません。
このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。 このメソッドは、このオブジェクトのプール許容値と等しい プール許容値を持つ ExtendedDirectory のインスタンスを返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合

findDirectory

protected ExtendedDirectory findDirectory(String path)
推奨されていません。
このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。

このメソッドは、childDirectory メソッドが要求されたファイルオブジェクトを プールしていなかった場合に、新しいファイルオブジェクトを作成するために 呼び出します。 サブクラスは、このメソッドをオーバーライドすることにより、 ファイルインスタンスを任意に作成することができます。

このメソッドは、単純にこのオブジェクトを親ディレクトリとして 引数 path を解決したファイルオブジェクトを作成して返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合

childPath

public File childPath(String path)
推奨されていません。
このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合

findPath

protected File findPath(String path)
推奨されていません。
このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。

このメソッドは、childPath メソッドが要求されたファイルオブジェクトを プールしていなかった場合に、新しいファイルオブジェクトを作成するために 呼び出します。 サブクラスは、このメソッドをオーバーライドすることにより、 ファイルインスタンスを任意に作成することができます。

このメソッドは、単純にこのオブジェクトを親ディレクトリとして 引数 path を解決したファイルオブジェクトを作成して返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合

reset

public void reset()
推奨されていません。
キャッシュ領域をクリアします。

archive

public void archive(File f)
             throws IOException
推奨されていません。
このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。 作成されるファイルは、ZIP ファイル形式となります。

パラメータ:
f - 出力ファイルパス
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(File f,
                    FileFilter filter)
             throws IOException
推奨されていません。
このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。 作成されるファイルは、ZIP ファイル形式となります。 ファイルに出力されるファイルは、フィルタの基準を満たす必要があります。 圧縮されるファイルは、 FileFilter.accept(java.io.File) メソッドが呼び出されたときに true が返される場合だけです。

パラメータ:
f - 出力ファイルパス
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(OutputStream out)
             throws IOException
推奨されていません。
このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。

パラメータ:
out - 出力ストリーム
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(OutputStream out,
                    FileFilter filter)
             throws IOException
推奨されていません。
このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。 ストリームに出力されるファイルは、フィルタの基準を満たす必要があります。 ストリームにファイルの内容が出力されるのは、 FileFilter.accept(java.io.File) メソッドが呼び出されたときに true が返される場合だけです。

パラメータ:
out - 出力ストリーム
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(ZipOutputStream out)
             throws IOException
推奨されていません。
このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。

パラメータ:
out - 出力ストリーム
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(ZipOutputStream out,
                    FileFilter filter)
             throws IOException
推奨されていません。
このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。 ストリームに出力されるファイルは、フィルタの基準を満たす必要があります。 ストリームにファイルの内容が出力されるのは、 FileFilter.accept(java.io.File) メソッドが呼び出されたときに true が返される場合だけです。

パラメータ:
out - 出力ストリーム
filter - ファイル名フィルタ
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedFile (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.file
クラス ExtendedFile

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.foundation.utility.file.ExtendedFile
すべての実装インタフェース:
Comparable, Serializable
直系の既知のサブクラス:
TemporaryFile
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile クラスを使用してください。

public class ExtendedFile
extends File

このクラスは、ファイルを扱う時に便利な機能を提供します。

このクラスは java.io.File クラスをベースに、オブジェクトが表す抽象パスが ファイルである場合に利用することができます。

関連項目:
File, ExtendedDirectory, 直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
コンストラクタの概要
ExtendedFile(File parent, String child)
推奨されていません。 親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
ExtendedFile(String pathname)
推奨されていません。 指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
ExtendedFile(String parent, String child)
推奨されていません。 親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
メソッドの概要
void | append(byte[] b) 推奨されていません。 指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
void | append(String str) 推奨されていません。 デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
void | append(String str, String enc) 推奨されていません。 指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
byte[] | getBytes() 推奨されていません。 この抽象パスが表すファイルからデータを読み込みます。
Iterator | readLines() 推奨されていません。 ファイルの行を繰り返し処理する反復子を作成します。
Iterator | readLines(String enc) 推奨されていません。 ファイルの行を繰り返し処理する反復子を作成します。
String | readString() 推奨されていません。 このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
String | readString(String enc) 推奨されていません。 このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
void | write(byte[] b) 推奨されていません。 指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
void | write(String str) 推奨されていません。 デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
void | write(String str, String enc) 推奨されていません。 指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtendedFile

public ExtendedFile(String pathname)
推奨されていません。
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。 指定された文字列が空の文字列の場合、結果は空の抽象パス名になります。

パラメータ:
pathname - パス名文字列
例外:
NullPointerException - pathname 引数が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合
関連項目:
File.File(File, String)

ExtendedFile

public ExtendedFile(File parent,
                    String child)
推奨されていません。
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。

parent が null の場合、新しい File のインスタンスは、 指定された child パス名文字列で単一引数の File コンストラクタを 呼び出したように生成されます。

そうでない場合、parent 抽象パス名はディレクトリを示し、 child パス名文字列はディレクトリまたはファイルを示します。 child パス名文字列が絶対の場合、 それはシステムに依存する方法で相対パス名に変換されます。 parent が空の抽象パス名の場合、新しい File のインスタンスは、 child を抽象パス名に変換し、その結果をシステムに依存する デフォルトディレクトリを基準に解決することで生成されます。 そうでない場合、各パス名文字列は抽象パス名に変換され、 子抽象パス名は親を基準に解決されます。

パラメータ:
parent - 親抽象パス名
child - 子パス名文字列
例外:
NullPointerException - child が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合
関連項目:
File.File(File, String)

ExtendedFile

public ExtendedFile(String parent,
                    String child)
推奨されていません。
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。

parent が null の場合、新しい File のインスタンスは、 指定された child パス名文字列で単一引数の File コンストラクタを 呼び出したように生成されます。 そうでない場合、parent パス名文字列はディレクトリを示し、 child パス名文字列はディレクトリまたはファイルを示します。 child パス名文字列が絶対の場合、 それはシステムに依存する方法で相対パス名に変換されます。 parent が空の文字列の場合、新しい File のインスタンスは、 child を抽象パス名に変換し、 その結果をシステムに依存するデフォルトディレクトリを基準に 解決することで生成されます。 そうでない場合、各パス名文字列は抽象パス名に変換され、 子抽象パス名は親を基準に解決されます。

パラメータ:
parent - 親パス名文字列
child - 子パス名文字列
例外:
NullPointerException - child が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合
関連項目:
File.File(File, String)
メソッドの詳細

getBytes

public byte[] getBytes()
                throws FileNotFoundException,
                       IOException
推奨されていません。
この抽象パスが表すファイルからデータを読み込みます。

戻り値:
ファイルの内容
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
IOException - 入出力エラーが発生した場合

readString

public String readString()
                  throws FileNotFoundException,
                         IOException
推奨されていません。
このオブジェクトの抽象パスが表すファイルからデータを読み込みます。

データはテキストとして扱い、デフォルトの文字エンコーディングから Unicode に変換して返します。

戻り値:
ファイルのデータ
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
IOException - 入出力エラーが発生した場合

readString

public String readString(String enc)
                  throws FileNotFoundException,
                         UnsupportedEncodingException,
                         IOException
推奨されていません。
このオブジェクトの抽象パスが表すファイルからデータを読み込みます。

データはテキストとして扱い、指定の文字エンコーディングから Unicode に変換して返します。

パラメータ:
enc - 文字エンコーディング名
戻り値:
ファイルのデータ
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
UnsupportedEncodingException - 指定の文字のエンコーディングがサポートされていない場合
IOException - 入出力エラーが発生した場合

readLines

public Iterator readLines()
                   throws FileNotFoundException,
                          IOException
推奨されていません。
ファイルの行を繰り返し処理する反復子を作成します。

データはテキストとして扱い、デフォルトの文字エンコーディングを使って Unicode に変換されます。 反復子が返す各要素は、ファイル内の 1 行のテキストです。 1 つの行は、改行 ('\n')、復帰 ('\r')、 または復帰とその直後に続く改行のどれかにより終了したと見なされます。

戻り値:
ファイルの行を繰り返し処理する反復子
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
IOException - 入出力エラーが発生した場合

readLines

public Iterator readLines(String enc)
                   throws FileNotFoundException,
                          UnsupportedEncodingException,
                          IOException
推奨されていません。
ファイルの行を繰り返し処理する反復子を作成します。

データはテキストとして扱い、指定の文字エンコーディングを使って Unicode に変換されます。 反復子が返す各要素は、ファイル内の 1 行のテキストです。 1 つの行は、改行 ('\n')、復帰 ('\r')、 または復帰とその直後に続く改行のどれかにより終了したと見なされます。

パラメータ:
enc - 文字エンコーディング名
戻り値:
ファイルの行を繰り返し処理する反復子
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
UnsupportedEncodingException - 指定の文字のエンコーディングがサポートされていない場合
IOException - 入出力エラーが発生した場合

write

public void write(String str)
           throws IOException
推奨されていません。
デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。

パラメータ:
str - 書き込む文字列
例外:
IOException - 入出力エラーが発生した場合

write

public void write(String str,
                  String enc)
           throws UnsupportedEncodingException,
                  IOException
推奨されていません。
指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。

パラメータ:
str - 書き込む文字列
enc - 使用するエンコーディングの名前
例外:
UnsupportedEncodingException - 指定の文字のエンコーディングがサポートされていない場合
IOException - 入出力エラーが発生した場合

append

public void append(String str)
            throws IOException
推奨されていません。
デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。

文字列は、ファイルの先頭ではなくファイルの最後に書き込まれます。 したがって、すでに存在するファイルに対して文字列を追記する場合に、 このメソッドを利用します。 このメソッドは、ファイルが存在しなかった場合、新しくファイルを 作成して文字列をファイルの先頭に書き込みます。

パラメータ:
str - 書き込む文字列
例外:
IOException - 入出力エラーが発生した場合

append

public void append(String str,
                   String enc)
            throws UnsupportedEncodingException,
                   IOException
推奨されていません。
指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。

文字列は、ファイルの先頭ではなくファイルの最後に書き込まれます。 したがって、すでに存在するファイルに対して文字列を追記する場合に、 このメソッドを利用します。 このメソッドは、ファイルが存在しなかった場合、新しくファイルを 作成して文字列をファイルの先頭に書き込みます。

パラメータ:
str - 書き込む文字列
enc - 使用するエンコーディングの名前
例外:
UnsupportedEncodingException - 指定の文字のエンコーディングがサポートされていない場合
IOException - 入出力エラーが発生した場合

append

public void append(byte[] b)
            throws IOException
推奨されていません。
指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。

バイトは、ファイルの先頭ではなくファイルの最後に書き込まれます。 したがって、すでに存在するファイルに対してバイトを追記する場合に、 このメソッドを利用します。 このメソッドは、ファイルが存在しなかった場合、新しくファイルを 作成してバイトをファイルの先頭に書き込みます。

パラメータ:
b - データ
例外:
IOException - 入出力エラーが発生した場合

write

public void write(byte[] b)
           throws IOException
推奨されていません。
指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。

パラメータ:
b - データ
例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.utility.file (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.utility.file
クラス
Directory
ExtendedDirectory
ExtendedFile


jp.co.intra_mart.foundation.utility.file (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.file

このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

参照:
説明

クラスの概要
Directory | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。
ExtendedDirectory | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。
ExtendedFile | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile クラスを使用してください。

パッケージ jp.co.intra_mart.foundation.utility.file の説明

このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。


jp.co.intra_mart.foundation.utility.file クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.file の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.io.File (implements java.lang.Comparable, java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.file.Directory
        • class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
      • class jp.co.intra_mart.foundation.utility.file.ExtendedFile


パッケージ jp.co.intra_mart.foundation.utility.file の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.utility.file の使用

jp.co.intra_mart.foundation.utility.file を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.service.provider.file | このパッケージには、Storage Service 環境内で利用可能な機能を提供します。
jp.co.intra_mart.foundation.service.provider.information | このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。
jp.co.intra_mart.foundation.utility.file | このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

jp.co.intra_mart.foundation.service.provider により使用される jp.co.intra_mart.foundation.utility.file のクラス
Directory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。
ExtendedDirectory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。
ExtendedFile
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile クラスを使用してください。

jp.co.intra_mart.foundation.service.provider.file により使用される jp.co.intra_mart.foundation.utility.file のクラス
Directory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。
ExtendedDirectory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。

jp.co.intra_mart.foundation.service.provider.information により使用される jp.co.intra_mart.foundation.utility.file のクラス
Directory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。
ExtendedDirectory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。

jp.co.intra_mart.foundation.utility.file により使用される jp.co.intra_mart.foundation.utility.file のクラス
Directory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。
ExtendedDirectory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。
ExtendedFile
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream の使用

jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream の使用

jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream の使用

jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.ExtendedInputStream の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.ExtendedInputStream の使用

ExtendedInputStream を使用しているパッケージ
jp.co.intra_mart.foundation.utility.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.utility.net での ExtendedInputStream の使用

ExtendedInputStream を返す jp.co.intra_mart.foundation.utility.net のメソッド
 ExtendedInputStream ExtendedSocket.getInputStream()
推奨されていません。 入力ストリームの取得。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream の使用

ExtendedOutputStream を使用しているパッケージ
jp.co.intra_mart.foundation.utility.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.utility.net での ExtendedOutputStream の使用

ExtendedOutputStream を返す jp.co.intra_mart.foundation.utility.net のメソッド
 ExtendedOutputStream ExtendedSocket.getOutputStream()
推奨されていません。 出力ストリームの取得。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.HexInputStream の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.HexInputStream の使用

jp.co.intra_mart.foundation.utility.io.HexInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.HexOutputStream の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.HexOutputStream の使用

jp.co.intra_mart.foundation.utility.io.HexOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.ReplaceWriter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.ReplaceWriter の使用

jp.co.intra_mart.foundation.utility.io.ReplaceWriter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream の使用

jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream の使用

jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream の使用

jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.XORInputStream の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.XORInputStream の使用

jp.co.intra_mart.foundation.utility.io.XORInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.XOROutputStream の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.XOROutputStream の使用

jp.co.intra_mart.foundation.utility.io.XOROutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BASE64DecodeInputStream (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス BASE64DecodeInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 java.io.FilterInputStream
            拡張 jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream クラスを使用してください。

public class BASE64DecodeInputStream
extends FilterInputStream

このクラスは、BASE64 エンコードされたデータを読み込むための ストリームフィルタを実装します。
入力ストリームより読み込まれたバイトは、BASE64 デコードされ read() メソッドにより返されます。

関連項目:
InputStream

フィールドの概要
クラス java.io.FilterInputStream から継承したフィールド
in
コンストラクタの概要
BASE64DecodeInputStream(InputStream in)
推奨されていません。 指定された InputStream から読み込む BASE64 デコード入力ストリームを作成します。
メソッドの概要
int | read() 推奨されていません。 デコードデータのバイトを読み込みます。
int | read(byte[] b, int off, int len) 推奨されていません。 入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
クラス java.io.FilterInputStream から継承したメソッド
available, close, mark, markSupported, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BASE64DecodeInputStream

public BASE64DecodeInputStream(InputStream in)
推奨されていません。
指定された InputStream から読み込む BASE64 デコード入力ストリームを作成します。

パラメータ:
in - 入力ストリーム
メソッドの詳細

read

public int read()
         throws IOException
推奨されていません。
デコードデータのバイトを読み込みます。

このメソッドは、BASE64 のデコードに十分な入力が利用できるようになるまで ブロックします。

戻り値:
読み込まれたバイト。圧縮された入力の最後に達した場合は -1
例外:
IOException - 入出力エラーが発生した場合

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
推奨されていません。
入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。 このメソッドは入力データが読み込み可能になるまでブロックします。

パラメータ:
b - データが読み込まれるバッファ
off - データの開始オフセット
len - 読み込むバイトの最大値
戻り値:
バッファに読み込まれたバイト数。ストリームの終わりに達して読み込むデータがない場合は -1
例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BASE64DecodeOutputStream (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス BASE64DecodeOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream クラスを使用してください。

public class BASE64DecodeOutputStream
extends FilterOutputStream

このクラスは、BASE64 デコードされたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、BASE64 デコードされ 基礎出力ストリームに書き込まれます。

関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
BASE64DecodeOutputStream(OutputStream out)
推奨されていません。 指定された OutputStream に書き込む BASE64デコーダーを作成します。
メソッドの概要
void | write(byte[] b, int off, int len) 推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) 推奨されていません。 バイトをデコードして出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
close, flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BASE64DecodeOutputStream

public BASE64DecodeOutputStream(OutputStream out)
推奨されていません。
指定された OutputStream に書き込む BASE64デコーダーを作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
推奨されていません。
バイトをデコードして出力ストリームに書き込みます。

このメソッドは、デコード結果が出力可能な 1 バイトのデータになるまで、 バッファに溜め込みます。 バッファに溜め込まれたデータは、flush メソッドや close メソッドを 実行しても基礎出力ストリームに書き出されることはありません。 バッファにデータが溜まった状態で、flush メソッドや close メソッドを 実行した場合、バッファ内のデータは破棄されます。

パラメータ:
b - 書き込まれるバイト
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が ASCII 文字の範囲に含まれない場合（ASCII のコントロールコードの場合も含む）や不正なコードが指定された場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
推奨されていません。
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。
このメソッドは、配列 b 内の off から len バイトについて、 int 型引数をひとつだけとる write メソッドを呼び出します。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BASE64EncodeOutputStream (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス BASE64EncodeOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream クラスを使用してください。

public class BASE64EncodeOutputStream
extends FilterOutputStream

このクラスは、BASE64 エンコードされたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、BASE64 エンコードされ 基礎出力ストリームに書き込まれます。

関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
BASE64EncodeOutputStream(OutputStream out)
推奨されていません。 指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。
BASE64EncodeOutputStream(OutputStream out, boolean isAppnendReturnCodePer76chars)
推奨されていません。 指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。
メソッドの概要
void | close() 推奨されていません。 ストリームを閉じます。
void | finish() 推奨されていません。 出力ストリームへのエンコードデータの書き込みを終了します。
void | write(byte[] b, int off, int len) 推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) 推奨されていません。 バイトをエンコード出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BASE64EncodeOutputStream

public BASE64EncodeOutputStream(OutputStream out)
推奨されていません。
指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。

パラメータ:
out - 出力ストリーム

BASE64EncodeOutputStream

public BASE64EncodeOutputStream(OutputStream out,
                                boolean isAppnendReturnCodePer76chars)
推奨されていません。
指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。

パラメータ:
out - 出力ストリーム
isAppnendReturnCodePer76chars - 76文字ごとに改行コード(=LF)を追加する場合は true、 改行コードを追加しない場合は、 falseを指定してください。
メソッドの詳細

write

public void write(int b)
           throws IOException
推奨されていません。
バイトをエンコード出力ストリームに書き込みます。

このメソッドは、3 バイトのデータを受け取るとエンコードされたバイトを 出力ストリームに書き込みます。入力されたバイトが 3 バイトに満たない 場合は、入力されたバイトが合計で 3 バイトになるまでバッファに 溜め込みます。

パラメータ:
b - 書き込まれるバイト
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
推奨されていません。
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

finish

public void finish()
            throws IOException
推奨されていません。
出力ストリームへのエンコードデータの書き込みを終了します。

このときストリームは閉じられません。 複数のフィルタを同じ出力ストリームに連続して適用するときに このメソッドを使用します。

例外:
IOException - 入出力エラーが発生した場合

close

public void close()
           throws IOException
推奨されていません。
ストリームを閉じます。

ストリームを閉じ、これに関連するすべての システムリソースを解放します。 もし、このストリームがバッファ内に出力バイトを保持している場合、 それらを終端処理をして出力ストリームに強制的に書き込みます。
このメソッドは、finish メソッドを呼び出した後、 スーパークラス(java.io.FilterOutputStream)の close メソッドを呼び出します。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedInputStream (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス ExtendedInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 jp.co.intra_mart.foundation.utility.io.ExtendedInputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream クラスを使用してください。

public class ExtendedInputStream
extends InputStream

このクラスは、標準の入力ストリームを拡張した機能を提供します。

このクラスは、jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream により 書き出されたストリームを読み込むための実装を提供します。
このクラスの各メソッドは、データをストリームから読み込むときに、 java.io.DataInputStream または java.io.ObjectInputStream の 適切なメソッドを使います。

データをストリームに書き出したときに使ったメソッドに対応した 適切なメソッドを利用することにより、データを読み込むことができます。

このクラスを jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream と対で使うことにより、 データをファイルに保存したり、ネットワークにより他のプロセスへ データを転送することができます。

jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream の writeObject メソッドにより 書き出されたオブジェクトは、readObject メソッドにより インスタンス化することができます。 この時、インスタンスに必要なクラスが存在している必要があります。

コンストラクタの概要
ExtendedInputStream(InputStream in)
推奨されていません。 入力ストリームを構築します。
ExtendedInputStream(InputStream in, ErrorEventListener listener)
推奨されていません。 入力ストリームを構築します。
メソッドの概要
void | close() 推奨されていません。 入出力ストリームおよびソケットを閉じます。
boolean | isClosed() 推奨されていません。 この入出力ストリームが閉じられているかチェックします。
int | read() 推奨されていません。 データ取得。
int | read(byte[] b, int off, int len) 推奨されていません。 データ取得。
boolean | readBoolean() 推奨されていません。 boolean 型データ取得。
int | readInt() 推奨されていません。 int 型データ取得。
long | readLong() 推奨されていません。 long 型データ取得。
Object | readObject() 推奨されていません。 Object の取得。
String | readString() 推奨されていません。 文字列の取得。
クラス java.io.InputStream から継承したメソッド
available, mark, markSupported, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedInputStream

public ExtendedInputStream(InputStream in)
                    throws IOException
推奨されていません。
入力ストリームを構築します。

パラメータ:
in - 基礎入力ストリーム
例外:
IOException - 入出力ストリームの作成時エラー

ExtendedInputStream

public ExtendedInputStream(InputStream in,
                           ErrorEventListener listener)
                    throws IOException
推奨されていません。
入力ストリームを構築します。

パラメータ:
in - 基礎入力ストリーム
listener - エラーイベントのリスナーオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー
メソッドの詳細

read

public int read()
         throws IOException
推奨されていません。
データ取得。

入力ストリームから次のバイトのデータを取得します。

戻り値:
取得したバイトデータ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
InputStream.read(), ExtendedOutputStream.write(int)

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
推奨されていません。
データ取得。

入力ストリームから len バイトまでのデータをバイト配列に 読み込みます。

パラメータ:
b - バイト配列
off - データの開始オフセット
len - 読み込むバイト数
戻り値:
取得したバイト数
例外:
IOException - 入出力エラーが発生した場合
関連項目:
InputStream.read(byte[], int, int), ExtendedOutputStream.write(int)

readInt

public int readInt()
            throws IOException
推奨されていません。
int 型データ取得。

基本データ型の整数データを読み込みます。

戻り値:
int 型数値データ
例外:
EOFException - データ受信完了前にストリームの終わりに達した場合
IOException - 入出力エラーが発生した場合
関連項目:
DataInputStream.readInt(), ExtendedOutputStream.writeInt(int)

readLong

public long readLong()
              throws IOException
推奨されていません。
long 型データ取得。

基本データ型の長整数データを読み込みます。

戻り値:
long 型数値データ
例外:
EOFException - データ受信完了前にストリームの終わりに達した場合
IOException - 入出力エラーが発生した場合
関連項目:
DataInputStream.readLong(), ExtendedOutputStream.writeLong(long)

readBoolean

public boolean readBoolean()
                    throws IOException
推奨されていません。
boolean 型データ取得。

基本データ型の真偽値データを読み込みます。

戻り値:
long 型数値データ
例外:
EOFException - データ受信完了前にストリームの終わりに達した場合
IOException - 入出力エラーが発生した場合
関連項目:
DataInputStream.readBoolean(), ExtendedOutputStream.writeBoolean(boolean)

readObject

public Object readObject()
                  throws OptionalDataException,
                         ClassNotFoundException,
                         IOException
推奨されていません。
Object の取得。

戻り値:
入力して復元したオブジェクト
例外:
ClassNotFoundException - 直列化されたオブジェクトのクラスが見つからなかった場合
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
StreamCorruptedException - ストリームの制御情報に一貫性がない場合
OptionalDataException - プリミティブデータが、オブジェクトではなくストリームに見つかった場合
IOException - 通常の入出力関連の例外
関連項目:
ObjectInputStream.readObject(), ExtendedOutputStream.writeObject(Object)

readString

public String readString()
                  throws OptionalDataException,
                         ClassNotFoundException,
                         IOException
推奨されていません。
文字列の取得。

このメソッドは、jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream クラスの writeString メソッドを使って書き込んだデータを読み込むための メソッドです。他の方法で書き込んだデータを読み込むことはできません。

戻り値:
入力した文字列
例外:
ClassNotFoundException - 直列化されたオブジェクトのクラスが見つからなかった場合
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
StreamCorruptedException - ストリームの制御情報に一貫性がない場合
OptionalDataException - プリミティブデータが、オブジェクトではなくストリームに見つかった場合
IOException - 通常の入出力関連の例外
関連項目:
ExtendedOutputStream.writeString(String)

close

public void close()
           throws IOException
推奨されていません。
入出力ストリームおよびソケットを閉じます。
入出力ストリームを閉じる前にバッファに溜められているデータをすべて 出力ストリームに書き出します。

例外:
IOException - 入出力エラーが発生した場合

isClosed

public boolean isClosed()
推奨されていません。
この入出力ストリームが閉じられているかチェックします。

戻り値:
すでに閉じられている場合 true、そうでない場合 false。
関連項目:
close()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedOutputStream (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス ExtendedOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream クラスを使用してください。

public class ExtendedOutputStream
extends OutputStream

このクラスは、標準の出力ストリームを拡張した機能を提供します。

このクラスの各メソッドは、データをストリームに書き出すときに、 java.io.DataOutputStream または java.io.ObjectOutputStream の 適切なメソッドを使います。
writeObject メソッドを使ってオブジェクトをストリームに書き出す 場合、ストリームに書き込めるのは java.io.Serializable インタフェースを サポートするオブジェクトに限ります。それ以外のオブジェクトを ストリームに書き込もうとした場合、例外がスローされます。

この出力ストリームに書き込んだデータを入力する場合、 jp.co.intra_mart.foundation.utility.io.ExtendedInputStream を利用する必要があります。 他の入力ストリームから読み込んだ場合例外がスローされることがあります。

関連項目:
ExtendedInputStream

コンストラクタの概要
ExtendedOutputStream(OutputStream out)
推奨されていません。 出力ストリームを構築します。
ExtendedOutputStream(OutputStream out, ErrorEventListener listener)
推奨されていません。 出力ストリームを構築します。
メソッドの概要
void | close() 推奨されていません。 入出力ストリームおよびソケットを閉じます。
void | flush() 推奨されていません。 書き出しストリーム内のデータをすべて出力。
boolean | isClosed() 推奨されていません。 この入出力ストリームが閉じられているかチェックします。
void | write(byte[] b, int off, int len) 推奨されていません。 オフセット off から始まる指定のバイト配列から この出力ストリームに len バイトを書き込みます。
void | write(int data) 推奨されていません。 指定されたバイトを書き込みます。
void | writeBoolean(boolean data) 推奨されていません。 boolean 型データの送信。
void | writeInt(int data) 推奨されていません。 int 型データの送信。
void | writeLong(long data) 推奨されていません。 long 型データの送信。
void | writeObject(Object data) 推奨されていません。 オブジェクトの送信。
void | writeString(String data) 推奨されていません。 文字列の送信。
クラス java.io.OutputStream から継承したメソッド
write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedOutputStream

public ExtendedOutputStream(OutputStream out)
                     throws IOException
推奨されていません。
出力ストリームを構築します。

パラメータ:
out - 基礎出力ストリーム
例外:
IOException - 入出力ストリームの作成時エラー

ExtendedOutputStream

public ExtendedOutputStream(OutputStream out,
                            ErrorEventListener listener)
                     throws IOException
推奨されていません。
出力ストリームを構築します。

パラメータ:
out - 基礎出力ストリーム
listener - エラーイベントのリスナーオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー
メソッドの詳細

write

public void write(int data)
           throws IOException
推奨されていません。
指定されたバイトを書き込みます。

パラメータ:
data - バイトデータ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
OutputStream.write(int), ExtendedInputStream.read()

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
推奨されていません。
オフセット off から始まる指定のバイト配列から この出力ストリームに len バイトを書き込みます。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラーが発生した場合
関連項目:
OutputStream.write(byte[],int,int), ExtendedInputStream.read()

writeInt

public void writeInt(int data)
              throws IOException
推奨されていません。
int 型データの送信。
基本データ型の整数データを基礎出力ストリームに書き込みます。

パラメータ:
data - データ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
DataOutputStream.writeInt(int), ExtendedInputStream.readInt()

writeLong

public void writeLong(long data)
               throws IOException
推奨されていません。
long 型データの送信。
基本データ型の長整数データを基礎出力ストリームに書き込みます。

パラメータ:
data - データ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
DataOutputStream.writeLong(long), ExtendedInputStream.readLong()

writeBoolean

public void writeBoolean(boolean data)
                  throws IOException
推奨されていません。
boolean 型データの送信。
基本データ型の真偽値データを基礎出力ストリームに書き込みます。

パラメータ:
data - データ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
DataOutputStream.writeBoolean(boolean), ExtendedInputStream.readBoolean()

writeObject

public void writeObject(Object data)
                 throws IOException
推奨されていません。
オブジェクトの送信。

java.io.Serializable インタフェースを実装している オブジェクトを基礎出力ストリームに書き込みます。
このメソッドはオブジェクトをストリームに書き込む際に、 java.io.ObjectOutputStream の writeObject メソッドを使います。

パラメータ:
data - オブジェクト
例外:
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
NotSerializableException - 直列化の対象が java.io.Serializable インタフェースを実装していない場合
IOException - 基礎の OutputStream に例外が発生した場合
関連項目:
ObjectOutputStream.writeObject(Object), Serializable, ExtendedInputStream.readObject()

writeString

public void writeString(String data)
                 throws IOException
推奨されていません。
文字列の送信。
このメソッドは、writeObject() メソッドを使い文字列をストリームに 書き込みます。 java.io.DataOutputStream や java.io.ObjectOutputStream の writeUTF メソッドとの違いは、ストリームに書き込める文字列の 長さに制約がないことです。

パラメータ:
data - ストリームに書き込む文字列
例外:
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
NotSerializableException - 直列化の対象が java.io.Serializable インタフェースを実装していない場合
IOException - 基礎の OutputStream に例外が発生した場合
関連項目:
DataOutputStream.writeUTF(String),
ObjectOutputStream.writeUTF(String),
ExtendedInputStream.readString()

flush

public void flush()
           throws IOException
推奨されていません。
書き出しストリーム内のデータをすべて出力。

例外:
IOException - 入出力エラーが発生した場合

close

public void close()
           throws IOException
推奨されていません。
入出力ストリームおよびソケットを閉じます。
入出力ストリームを閉じる前にバッファに溜められているデータをすべて 出力ストリームに書き出します。

例外:
IOException - 入出力エラーが発生した場合

isClosed

public boolean isClosed()
推奨されていません。
この入出力ストリームが閉じられているかチェックします。

戻り値:
すでに閉じられている場合 true、そうでない場合 false。
関連項目:
close()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HexInputStream (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス HexInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 jp.co.intra_mart.foundation.utility.io.HexInputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream クラスを使用してください。

public class HexInputStream
extends InputStream

このクラスは、16進数表現されたデータを読み込むための ストリームフィルタを実装します。
入力ストリームより読み込まれたバイトは、16進数表現からバイトに変換され read() メソッドにより返されます。

関連項目:
InputStream

フィールドの概要
protected  InputStream in
推奨されていません。 フィルタ処理される入力ストリームです。
コンストラクタの概要
HexInputStream(InputStream in)
推奨されていません。 指定された InputStream から読み込む HexInputStream を作成します。
メソッドの概要
void | close() 推奨されていません。 ストリームを閉じます。
int | read() 推奨されていません。 デコードデータのバイトを読み込みます。
クラス java.io.InputStream から継承したメソッド
available, mark, markSupported, read, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

in

protected InputStream in
推奨されていません。
フィルタ処理される入力ストリームです。

コンストラクタの詳細

HexInputStream

public HexInputStream(InputStream in)
推奨されていません。
指定された InputStream から読み込む HexInputStream を作成します。

パラメータ:
in - 入力ストリーム
メソッドの詳細

read

public int read()
         throws IOException,
                NumberFormatException
推奨されていません。
デコードデータのバイトを読み込みます。

２バイトの 16進数表現されたキャラクタデータを 読み込んで１バイトの数値として返します。 このメソッドは、２バイトの入力があるまでブロックします。

戻り値:
読み込まれたバイト。
例外:
IOException - 入出力エラーが発生した場合
NumberFormatException - 16進数として有効ではない文字を読み込んだ場合

close

public void close()
           throws IOException
推奨されていません。
ストリームを閉じます。

入力ストリームを閉じ、これに関連するすべての システムリソースを解放します。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HexOutputStream (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス HexOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 jp.co.intra_mart.foundation.utility.io.HexOutputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream クラスを使用してください。

public class HexOutputStream
extends OutputStream

このクラスは、16進数表現されたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、16進数表現され 基礎出力ストリームに書き込まれます。
フィルタリングされた結果、基礎ストリームに書き込まれるデータは、 [0-9a-f] の範囲のキャラクタで構成されます。

関連項目:
OutputStream

フィールドの概要
protected  OutputStream out
推奨されていません。 フィルタ処理される基礎出力ストリームです。
コンストラクタの概要
HexOutputStream(OutputStream out)
推奨されていません。 指定された OutputStream に書き込む HexOutputStream を作成します。
メソッドの概要
void | close() 推奨されていません。 ストリームを閉じます。
void | write(byte[] b, int off, int len) 推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) 推奨されていません。 バイトをエンコード出力ストリームに書き込みます。
クラス java.io.OutputStream から継承したメソッド
flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

out

protected OutputStream out
推奨されていません。
フィルタ処理される基礎出力ストリームです。

コンストラクタの詳細

HexOutputStream

public HexOutputStream(OutputStream out)
推奨されていません。
指定された OutputStream に書き込む HexOutputStream を作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
推奨されていません。
バイトをエンコード出力ストリームに書き込みます。

このメソッドは、バイトを上位４ビットと下位ビットに分け、 それぞれ16進数表現されたキャラクターコードに置き換えて、 計２バイトのデータを基礎ストリームに書き込みます。

パラメータ:
b - 書き込まれるバイト
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
推奨されていません。
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

close

public void close()
           throws IOException
推奨されていません。
ストリームを閉じます。

ストリームを閉じ、これに関連するすべての システムリソースを解放します。
もし、このストリームがバッファ内に出力バイトを保持している場合、 それらを終端処理をして出力ストリームに強制的に書き込みます。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.utility.io (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.utility.io
クラス
BASE64DecodeInputStream
BASE64DecodeOutputStream
BASE64EncodeOutputStream
ExtendedInputStream
ExtendedOutputStream
HexInputStream
HexOutputStream
ReplaceWriter
URLDecodeInputStream
URLDecodeOutputStream
URLEncodeOutputStream
XORInputStream
XOROutputStream


jp.co.intra_mart.foundation.utility.io (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.io

このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。

参照:
説明

クラスの概要
BASE64DecodeInputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream クラスを使用してください。
BASE64DecodeOutputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream クラスを使用してください。
BASE64EncodeOutputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream クラスを使用してください。
ExtendedInputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream クラスを使用してください。
ExtendedOutputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream クラスを使用してください。
HexInputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream クラスを使用してください。
HexOutputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream クラスを使用してください。
ReplaceWriter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter クラスを使用してください。
URLDecodeInputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream クラスを使用してください。
URLDecodeOutputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream クラスを使用してください。
URLEncodeOutputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream クラスを使用してください。
XORInputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream クラスを使用してください。
XOROutputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream クラスを使用してください。

パッケージ jp.co.intra_mart.foundation.utility.io の説明

このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
このパッケージには、java.io パッケージに含まれるクラスを拡張したものが多く含まれています。


jp.co.intra_mart.foundation.utility.io クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.io の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.io.InputStream
      • class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream
      • class java.io.FilterInputStream
        • class jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream
        • class jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream
        • class jp.co.intra_mart.foundation.utility.io.XORInputStream
      • class jp.co.intra_mart.foundation.utility.io.HexInputStream
    • class java.io.OutputStream
      • class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream
      • class java.io.FilterOutputStream
        • class jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.XOROutputStream
      • class jp.co.intra_mart.foundation.utility.io.HexOutputStream
    • class java.io.Writer
      • class jp.co.intra_mart.foundation.utility.io.ReplaceWriter


パッケージ jp.co.intra_mart.foundation.utility.io の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.utility.io の使用

jp.co.intra_mart.foundation.utility.io を使用しているパッケージ
jp.co.intra_mart.foundation.utility.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.utility.net により使用される jp.co.intra_mart.foundation.utility.io のクラス
ExtendedInputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream クラスを使用してください。
ExtendedOutputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ReplaceWriter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス ReplaceWriter

java.lang.Object
    拡張 java.io.Writer
        拡張 jp.co.intra_mart.foundation.utility.io.ReplaceWriter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter クラスを使用してください。

public class ReplaceWriter
extends Writer

このクラスは、部分文字列を別な部分文字列へ置換しながら ストリームに文字列を書き込むためのストリームフィルタを実装します。
置換対象となる部分文字列と置換する文字列の長さは同じ必要はありません。 置換対象となる文字データと異なる長さの文字データを置換後のデータとして 指定することも可能です。この場合、 このクラスによって基礎ストリームに書き込まれるデータ量は、 元のデータ量と変化します。

   java.io.StringWriter sw = new java.io.StringWriter();

   ReplaceWriter rw = new ReplaceWriter(sw, "abc", "xyz");

   rw.write("abc");
   String result = sw.toString();
文字データ "abc" は、"xyz" に変化します。この場合、以下のように 記述しても同様の結果が得られます。
   java.io.StringWriter sw = new java.io.StringWriter();

   ReplaceWriter rw = new ReplaceWriter(sw, "abc", "xyz");

   rw.write("a");
   rw.write("b");
   rw.write("c");
   String result = sw.toString();

導入されたバージョン:
version 3.2

フィールドの概要
クラス java.io.Writer から継承したフィールド
lock
コンストラクタの概要
ReplaceWriter(Writer out, char[] oldChars)
推奨されていません。 文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer out, char[] oldChars, char[] newChars)
推奨されていません。 文字列置換のためのストリームフィルタを作成します。
ReplaceWriter(Writer out, String oldString)
推奨されていません。 文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer out, String oldString, String newString)
推奨されていません。 文字列置換のためのストリームフィルタを作成します。
メソッドの概要
void | close() 推奨されていません。 ストリームを閉じてフラッシュします。
void | finish() 推奨されていません。 バッファに保存してあるデータを書き出します。
void | flush() 推奨されていません。 ストリームをフラッシュします。
void | write(char[] cbuf, int off, int len) 推奨されていません。 文字列の一部を基礎ストリームに書き込みます。
void | write(int c) 推奨されていません。 単一文字を書き込みます。
クラス java.io.Writer から継承したメソッド
write, write, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ReplaceWriter

public ReplaceWriter(Writer out,
                     char[] oldChars)
推奨されていません。
文字列削除のためのストリームフィルタを作成します。
このインスタンスに書き込まれた文字データは部分文字列の削除を行いながら 基礎ストリームに書き込まれます。

パラメータ:
out - 基礎ストリーム
oldChars - 削除対象となる文字の配列

ReplaceWriter

public ReplaceWriter(Writer out,
                     String oldString)
推奨されていません。
文字列削除のためのストリームフィルタを作成します。
このインスタンスに書き込まれた文字データは部分文字列の削除を行いながら 基礎ストリームに書き込まれます。

パラメータ:
out - 基礎ストリーム
oldString - 削除対象となる文字列

ReplaceWriter

public ReplaceWriter(Writer out,
                     char[] oldChars,
                     char[] newChars)
推奨されていません。
文字列置換のためのストリームフィルタを作成します。
このインスタンスに書き込まれた文字データは適切な置換を行いながら 基礎ストリームに書き込まれます。

パラメータ:
out - 基礎ストリーム
oldChars - 置換対象となる文字の配列
newChars - 置換する文字の配列

ReplaceWriter

public ReplaceWriter(Writer out,
                     String oldString,
                     String newString)
推奨されていません。
文字列置換のためのストリームフィルタを作成します。

パラメータ:
out - 基礎ストリーム
oldString - 置換対象となる文字列
newString - 置換する文字列
メソッドの詳細

write

public void write(int c)
           throws IOException
推奨されていません。
単一文字を書き込みます。 書き込まれる文字は、指定された整数値の下位 16 ビットに格納されます。 上位 16 ビットは無視されます。

パラメータ:
c - 文字
例外:
IOException - 入出力エラーが発生した場合

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
推奨されていません。
文字列の一部を基礎ストリームに書き込みます。

パラメータ:
cbuf - 文字の配列
off - 文字の書き込み開始オフセット
len - 書き込む文字数
例外:
IOException - 入出力エラーが発生した場合

finish

public void finish()
            throws IOException
推奨されていません。
バッファに保存してあるデータを書き出します。

ストリームがさまざまな write() メソッドからの文字をバッファに 保存してある場合、これらの文字を基礎ストリームへただちに 書き込みます。
このメソッドは、このストリームの持つ置換対象データと比較中の 文字データを含むすべてのバッファを基礎ストリームに書き込みます。 このメソッドを呼び出し後は、write() メソッドによって与えられる データを改めて検索し直します。この機能のより、このストリームフィルタの 複数のストリームでの再利用が可能となります。

このときストリームは閉じられません。 複数のフィルタを同じ出力ストリームに連続して適用するときに このメソッドを使用します。

例外:
IOException - 入出力エラーが発生した場合

flush

public void flush()
           throws IOException
推奨されていません。
ストリームをフラッシュします。

現在バッファに保存されているデータが置換対象の文字データと 比較途中である場合、比較中のデータはフラッシュされません。 このストリームの持つすべてのバッファをフラッシュするためには、 finish() メソッドを呼び出したあとにこのメソッドを呼び出して下さい。
宛先が別の文字またはバイトストリームの場合は、 この宛先をフラッシュします。つまり 1 つの flush() の呼び出しで、 関連する Writer および OutputStream のすべてのバッファを フラッシュします。

例外:
IOException - 入出力エラーが発生した場合

close

public void close()
           throws IOException
推奨されていません。
ストリームを閉じてフラッシュします。
ストリームを一度閉じると、以降 write() または flush() を呼び出すと、 IOException がスローされます。 ただし、前に閉じたストリームを閉じても効果はありません。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


URLDecodeInputStream (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス URLDecodeInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 java.io.FilterInputStream
            拡張 jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream クラスを使用してください。

public class URLDecodeInputStream
extends FilterInputStream

このクラスは、URL デコードされたデータを読み込むための ストリームフィルタを実装します。
この入力ストリームに読み込まれたバイトは、URL デコードされ 基礎入力ストリームに読み込まれます。

導入されたバージョン:
version 4.0

フィールドの概要
クラス java.io.FilterInputStream から継承したフィールド
in
コンストラクタの概要
URLDecodeInputStream(InputStream in)
推奨されていません。 指定された InputStream から URL デコードしながらバイトを読み込む 入力ストリームを作成します。
メソッドの概要
int | read() 推奨されていません。 デコードデータのバイトを読み込みます。
int | read(byte[] b, int off, int len) 推奨されていません。 入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
クラス java.io.FilterInputStream から継承したメソッド
available, close, mark, markSupported, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLDecodeInputStream

public URLDecodeInputStream(InputStream in)
推奨されていません。
指定された InputStream から URL デコードしながらバイトを読み込む 入力ストリームを作成します。

パラメータ:
in - 入力ストリーム
メソッドの詳細

read

public int read()
         throws IOException
推奨されていません。
デコードデータのバイトを読み込みます。

このメソッドは、BASE64 のデコードに十分な入力が利用できるようになるまで ブロックします。

戻り値:
読み込まれたバイト。圧縮された入力の最後に達した場合は -1
例外:
EOFException - デコード途中で入力が終了した場合
IOException - 入出力エラーが発生した場合

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
推奨されていません。
入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。 このメソッドは入力データが読み込み可能になるまでブロックします。

パラメータ:
b - データが読み込まれるバッファ
off - データの開始オフセット
len - 読み込むバイトの最大値
戻り値:
バッファに読み込まれたバイト数。ストリームの終わりに達して読み込むデータがない場合は -1
例外:
EOFException - デコード途中で入力が終了した場合
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


URLDecodeOutputStream (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス URLDecodeOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream クラスを使用してください。

public class URLDecodeOutputStream
extends FilterOutputStream

このクラスは、URL デコードされたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、URL デコードされ 基礎出力ストリームに書き込まれます。

関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
URLDecodeOutputStream(OutputStream out)
推奨されていません。 指定された OutputStream に書き込む BASE64デコーダーを作成します。
メソッドの概要
void | write(byte[] b, int off, int len) 推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) 推奨されていません。 バイトをデコードして出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
close, flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLDecodeOutputStream

public URLDecodeOutputStream(OutputStream out)
推奨されていません。
指定された OutputStream に書き込む BASE64デコーダーを作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
推奨されていません。
バイトをデコードして出力ストリームに書き込みます。

このメソッドは、デコード結果が出力可能な 1 バイトのデータになるまで、 バッファに溜め込みます。 バッファに溜め込まれたデータは、flush メソッドや close メソッドを 実行しても基礎出力ストリームに書き出されることはありません。 バッファにデータが溜まった状態で、flush メソッドや close メソッドを 実行した場合、バッファ内のデータは破棄されます。

パラメータ:
b - 書き込まれるバイト
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
推奨されていません。
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。
このメソッドは、配列 b 内の off から len バイトについて、 int 型引数をひとつだけとる write メソッドを呼び出します。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


URLEncodeOutputStream (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス URLEncodeOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream クラスを使用してください。

public class URLEncodeOutputStream
extends FilterOutputStream

このクラスは、URL エンコードされたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、URL エンコードされ 基礎出力ストリームに書き込まれます。

関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
URLEncodeOutputStream(OutputStream out)
推奨されていません。 指定された OutputStream に書き込む BASE64デコーダーを作成します。
メソッドの概要
void | write(byte[] b, int off, int len) 推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) 推奨されていません。 バイトをデコードして出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
close, flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLEncodeOutputStream

public URLEncodeOutputStream(OutputStream out)
推奨されていません。
指定された OutputStream に書き込む BASE64デコーダーを作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
推奨されていません。
バイトをデコードして出力ストリームに書き込みます。

このメソッドは、デコード結果が出力可能な 1 バイトのデータになるまで、 バッファに溜め込みます。 バッファに溜め込まれたデータは、flush メソッドや close メソッドを 実行しても基礎出力ストリームに書き出されることはありません。 バッファにデータが溜まった状態で、flush メソッドや close メソッドを 実行した場合、バッファ内のデータは破棄されます。

パラメータ:
b - 書き込まれるバイト
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
推奨されていません。
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。
このメソッドは、配列 b 内の off から len バイトについて、 int 型引数をひとつだけとる write メソッドを呼び出します。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XORInputStream (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス XORInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 java.io.FilterInputStream
            拡張 jp.co.intra_mart.foundation.utility.io.XORInputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream クラスを使用してください。

public class XORInputStream
extends FilterInputStream

このクラスは、指定されたバイトとの排他論理和計算された結果の データを読み込むためのストリームフィルタを実装します。
入力ストリームより読み込まれたバイトは、 指定されたバイトデータとの排他論理和を計算した結果として read() メソッドにより返されます。

導入されたバージョン:
version4.0
関連項目:
InputStream

フィールドの概要
クラス java.io.FilterInputStream から継承したフィールド
in
コンストラクタの概要
XORInputStream(InputStream in, int b)
推奨されていません。 指定された InputStream から指定されたバイトとの排他論理和を 取りながら読み込む XORInputStream を作成します。
メソッドの概要
int | read() 推奨されていません。 デコードデータのバイトを読み込みます。
int | read(byte[] b, int off, int len) 推奨されていません。 入力ストリームからバイト配列へ最大 len バイトのデータを読み込みます。
クラス java.io.FilterInputStream から継承したメソッド
available, close, mark, markSupported, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

XORInputStream

public XORInputStream(InputStream in,
                      int b)
推奨されていません。
指定された InputStream から指定されたバイトとの排他論理和を 取りながら読み込む XORInputStream を作成します。

パラメータ:
in - 入力ストリーム
b - 排他論理和を取るためのバイト
メソッドの詳細

read

public int read()
         throws IOException,
                NumberFormatException
推奨されていません。
デコードデータのバイトを読み込みます。

２バイトの 16進数表現されたキャラクタデータを 読み込んで１バイトの数値として返します。 このメソッドは、２バイトの入力があるまでブロックします。

戻り値:
読み込まれたバイト。
例外:
IOException - 入出力エラーが発生した場合
NumberFormatException - 16進数として有効ではない文字を読み込んだ場合

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
推奨されていません。
入力ストリームからバイト配列へ最大 len バイトのデータを読み込みます。このメソッドは、入力が可能になるまでブロックします。

パラメータ:
b - データの読み込み先のバッファ
off - データの開始オフセット
len - 読み込まれる最大バイト数
戻り値:
バッファに読み込まれたバイトの合計数。ストリームの終わりに達してデータがない場合は -1
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XOROutputStream (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス XOROutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.foundation.utility.io.XOROutputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream クラスを使用してください。

public class XOROutputStream
extends FilterOutputStream

このクラスは、指定のバイトデータとの排他論理和を計算した結果の バイトデータを書き込むためのストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、指定のバイトデータとの 排他論理和を計算して、その結果のバイトデータが 基礎出力ストリームに書き込まれます。
フィルタリングされた結果、基礎ストリームに書き込まれるデータは、 同じバイトデータによって排他論理和を取ることにより、 もとのバイトデータに戻すことができます。

導入されたバージョン:
version4.0
関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
XOROutputStream(OutputStream out, int b)
推奨されていません。 指定された OutputStream に対して b との排他論理和を取ったバイトデータを書き込む XOROutputStream を作成します。
メソッドの概要
void | write(byte[] b, int off, int len) 推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) 推奨されていません。 バイトをエンコード出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
close, flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

XOROutputStream

public XOROutputStream(OutputStream out,
                       int b)
推奨されていません。
指定された OutputStream に対して b との排他論理和を取ったバイトデータを書き込む XOROutputStream を作成します。

パラメータ:
out - 出力ストリーム
b - 排他論理和を取るためのバイト
メソッドの詳細

write

public void write(int b)
           throws IOException
推奨されていません。
バイトをエンコード出力ストリームに書き込みます。

パラメータ:
b - 書き込まれるバイト
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
推奨されていません。
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor の使用

AbstractSocketConnectionDistributor を使用しているパッケージ
jp.co.intra_mart.foundation.utility.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.utility.net での AbstractSocketConnectionDistributor の使用

jp.co.intra_mart.foundation.utility.net での AbstractSocketConnectionDistributor のサブクラス
 class SocketPool
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketPool クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.net.ExtendedSocket の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.net.ExtendedSocket の使用

ExtendedSocket を使用しているパッケージ
jp.co.intra_mart.foundation.utility.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.utility.net での ExtendedSocket の使用

jp.co.intra_mart.foundation.utility.net での ExtendedSocket のサブクラス
 class SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。

ExtendedSocket 型のパラメータを持つ jp.co.intra_mart.foundation.utility.net のメソッド
 void SocketEventListener.handleSocketEvent(ExtendedSocket socket)
推奨されていません。 ソケットに関するイベント発生時に呼び出されるメソッド。

ExtendedSocket 型のパラメータを持つ jp.co.intra_mart.foundation.utility.net のコンストラクタ
SocketConnection(ExtendedSocket socket)
推奨されていません。 ソケット入出力インスタンスを構築します。
ExtendedSocket(ExtendedSocket socket)
推奨されていません。 ソケットを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.net.Localhost の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.net.Localhost の使用

Localhost を使用しているパッケージ
jp.co.intra_mart.foundation.utility.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.utility.net での Localhost の使用

Localhost を返す jp.co.intra_mart.foundation.utility.net のメソッド
static Localhost Localhost.instance()
推奨されていません。 このクラスから生成される唯一のインスタンスを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.net.SocketConnection の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.net.SocketConnection の使用

SocketConnection を使用しているパッケージ
jp.co.intra_mart.foundation.service.client | このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.client.batch | Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file | Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.manager | このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.utility.net | ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.service.client での SocketConnection の使用

SocketConnection を返す jp.co.intra_mart.foundation.service.client のメソッド
protected abstract  SocketConnection NetworkConnector.connection()
サーバに接続するためのコネクションを取得します。

jp.co.intra_mart.foundation.service.client.batch での SocketConnection の使用

SocketConnection を返す jp.co.intra_mart.foundation.service.client.batch のメソッド
protected  SocketConnection Scheduler.connection()
サーバに接続するためのコネクションを取得します。

jp.co.intra_mart.foundation.service.client.file での SocketConnection の使用

SocketConnection を返す jp.co.intra_mart.foundation.service.client.file のメソッド
protected  SocketConnection AbstractComponent.connection()
サーバに接続するためのコネクションを取得します。

jp.co.intra_mart.foundation.service.client.information での SocketConnection の使用

SocketConnection を返す jp.co.intra_mart.foundation.service.client.information のメソッド
protected SocketConnection | PermanentFile.connection() サーバに接続するためのコネクションを取得します。
protected SocketConnection | PermanentDirectory.connection() サーバに接続するためのコネクションを取得します。
protected SocketConnection | Lock.connection() サーバに接続するためのコネクションを取得します。
protected SocketConnection | ExternalMemory.connection() サーバに接続するためのコネクションを取得します。
protected SocketConnection | ExternalDirectory.connection() サーバに接続するためのコネクションを取得します。

jp.co.intra_mart.foundation.service.client.manager での SocketConnection の使用

SocketConnection を返す jp.co.intra_mart.foundation.service.client.manager のメソッド
protected  SocketConnection ServerConnector.connection()
サーバに接続するためのコネクションを取得します。

jp.co.intra_mart.foundation.utility.net での SocketConnection の使用

SocketConnection を返す jp.co.intra_mart.foundation.utility.net のメソッド
SocketConnection | SocketPool.connection() 推奨されていません。 コネクションの取得。
SocketConnection | SocketConnectionDistributor.connection() 推奨されていません。 コネクションの取得。

SocketConnection 型のパラメータを持つ jp.co.intra_mart.foundation.utility.net のメソッド
 boolean SocketPool.eject(SocketConnection connection)
推奨されていません。 指定コネクションをこのプールの管理から切り離します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor の使用

SocketConnectionDistributor を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.manager | このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.utility.net | ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.service.client.manager での SocketConnectionDistributor の使用

SocketConnectionDistributor を返す jp.co.intra_mart.foundation.service.client.manager のメソッド
SocketConnectionDistributor | SocketConnectionDistributorFactory.createSocketConnectionDistributor(String passwd) Server-Manager に接続するためのネットワークコネクション管理 オブジェクトを取得します。
SocketConnectionDistributor | ServerConnector.getSocketConnectionDistributor() このオブジェクトが保持しているネットワークのコネクションプールを 返します。

SocketConnectionDistributor 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.manager のコンストラクタ
ServerConnector(SocketConnectionDistributor socketConnectionDistributor)
オブジェクトを作成します。

jp.co.intra_mart.foundation.utility.net での SocketConnectionDistributor の使用

jp.co.intra_mart.foundation.utility.net での SocketConnectionDistributor のサブインタフェース
 interface SocketConnectionManager
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager クラスを使用してください。

SocketConnectionDistributor を実装している jp.co.intra_mart.foundation.utility.net のクラス
class | AbstractSocketConnectionDistributor 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor クラスを使用してください。
class | SocketPool 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketPool クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.net.SocketConnectionManager の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.net.SocketConnectionManager の使用

SocketConnectionManager を使用しているパッケージ
jp.co.intra_mart.foundation.utility.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.utility.net での SocketConnectionManager の使用

SocketConnectionManager を実装している jp.co.intra_mart.foundation.utility.net のクラス
 class SocketPool
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketPool クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.net.SocketEventListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.net.SocketEventListener の使用

SocketEventListener を使用しているパッケージ
jp.co.intra_mart.foundation.utility.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.utility.net での SocketEventListener の使用

SocketEventListener 型のパラメータを持つ jp.co.intra_mart.foundation.utility.net のメソッド
void | SocketPool.addCreateSocketEventListener(SocketEventListener listener) 推奨されていません。 ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。
void | SocketPool.addCloseSocketEventListener(SocketEventListener listener) 推奨されていません。 ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
void | ExtendedSocket.addCloseSocketEventListener(SocketEventListener listener) 推奨されていません。 ソケットをクローズしたイベントを通知するためのリスナーを 設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.net.SocketPool の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.net.SocketPool の使用

jp.co.intra_mart.foundation.utility.net.SocketPool はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException の使用

UnsupportedNetworkConnectException を使用しているパッケージ
jp.co.intra_mart.foundation.service.client このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。

jp.co.intra_mart.foundation.service.client での UnsupportedNetworkConnectException の使用

UnsupportedNetworkConnectException をスローする jp.co.intra_mart.foundation.service.client のメソッド
protected abstract  SocketConnection NetworkConnector.connection()
サーバに接続するためのコネクションを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AbstractSocketConnectionDistributor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
クラス AbstractSocketConnectionDistributor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor
すべての実装インタフェース:
SocketConnectionDistributor
直系の既知のサブクラス:
SocketPool
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor クラスを使用してください。

public abstract class AbstractSocketConnectionDistributor
extends Object
implements SocketConnectionDistributor

このクラスは、通信ソケットを作成する機能を提供します。

このクラスを継承してソケットプールを作成することができます。

コンストラクタの概要
protected AbstractSocketConnectionDistributor(String address, int port)
推奨されていません。 ソケット作成オブジェクトを構築します。
メソッドの概要
protected Socket | createSocket() 推奨されていません。 新しいソケットを作成します。
String | getAddress() 推奨されていません。 アドレスを返します。
int | getPort() 推奨されていません。 ポートを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor から継承したメソッド
clean, connection, destroy

コンストラクタの詳細

AbstractSocketConnectionDistributor

protected AbstractSocketConnectionDistributor(String address,
                                              int port)
推奨されていません。
ソケット作成オブジェクトを構築します。

パラメータ:
address - 接続するサーバのアドレス
port - 接続するサーバがサービスを提供しているポート
メソッドの詳細

createSocket

protected Socket createSocket()
                       throws UnknownHostException,
                              IOException
推奨されていません。
新しいソケットを作成します。

戻り値:
ソケット
例外:
UnknownHostException - ホストの IP アドレスを判定できなかった場合
IOException - ソケットの生成中に入出力エラーが発生した場合

getAddress

public String getAddress()
推奨されていません。
アドレスを返します。

戻り値:
このプールのネットワーク接続先サーバアドレス

getPort

public int getPort()
推奨されていません。
ポートを返します。

戻り値:
このプールのネットワーク接続先サーバポート
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedSocket (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
クラス ExtendedSocket

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.net.ExtendedSocket
直系の既知のサブクラス:
SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket クラスを使用してください。

public class ExtendedSocket
extends Object

このクラスは、ソケット通信用の入出力機能を提供します。

このクラスの提供している独自機能や、このクラスの持つメソッドから 取得したオブジェクトを使っている最中に例外がスローされた場合、 このクラスのインスタンスは発生した例外を保存します。 保存された例外は、lastError メソッドにより知ることができます。
ただし、このクラスが継承しているスーパークラスのメソッドの 呼び出し時にスローされた例外に関しては感知することはできません。

コンストラクタの概要
protected | ExtendedSocket(ExtendedSocket socket) 推奨されていません。 ソケットを構築します。
 | ExtendedSocket(Socket socket) 推奨されていません。 ソケットを構築します。
 | ExtendedSocket(String address, int port) 推奨されていません。 ソケットを構築します。
メソッドの概要
void | addCloseSocketEventListener(SocketEventListener listener) 推奨されていません。 ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
void | clearError() 推奨されていません。 このインスタンスのメソッド実行中に発生した例外をすべて破棄します。
void | close() 推奨されていません。 入出力ストリームおよびソケットを閉じます。
Iterator | errorIterator() 推奨されていません。 このインスタンスのメソッド実行中に発生した例外を返します。
Collection | getCloseSocketEventListeners() 推奨されていません。 このソケットに登録されているクローズ・イベント・リスナーを返します。
ExtendedInputStream | getInputStream() 推奨されていません。 入力ストリームの取得。
ExtendedOutputStream | getOutputStream() 推奨されていません。 出力ストリームの取得。
Socket | getSocket() 推奨されていません。 このオブジェクトの持つソケットオブジェクトを返します。
boolean | isClosed() 推奨されていません。 このソケットが閉じられているかどうかをチェックします。
Throwable | lastError() 推奨されていません。 このインスタンスのメソッド中で最後に発生した例外を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedSocket

public ExtendedSocket(String address,
                      int port)
               throws UnknownHostException,
                      IOException
推奨されていません。
ソケットを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
address - 接続先アドレス
port - 接続先ポート
例外:
UnknownHostException - ホストの IP アドレスが判定できなかった場合にスローされます。
IOException - 入出力ストリームの作成時エラー

ExtendedSocket

public ExtendedSocket(Socket socket)
               throws IOException
推奨されていません。
ソケットを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
socket - ソケットオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー

ExtendedSocket

protected ExtendedSocket(ExtendedSocket socket)
推奨されていません。
ソケットを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
socket - ソケットオブジェクト
メソッドの詳細

getSocket

public Socket getSocket()
推奨されていません。
このオブジェクトの持つソケットオブジェクトを返します。 このメソッドから取得したソケットオブジェクトの入出力ストリームと このオブジェクト自身から取得した入出力ストリームを 同時に利用した場合、データ送受信の整合性が失われてしまう可能性が あります。

戻り値:
ソケットオブジェクト

getInputStream

public ExtendedInputStream getInputStream()
推奨されていません。
入力ストリームの取得。

戻り値:
入力ストリーム

getOutputStream

public ExtendedOutputStream getOutputStream()
推奨されていません。
出力ストリームの取得。

戻り値:
出力ストリーム

addCloseSocketEventListener

public void addCloseSocketEventListener(SocketEventListener listener)
推奨されていません。
ソケットをクローズしたイベントを通知するためのリスナーを 設定します。 このメソッドで追加したリスナーには、このソケットが クローズされたときに、そのソケットをメソッド引数として handleSocketEventメソッドが実行されます。

パラメータ:
listener - ソケットイベントリスナー
導入されたバージョン:
version 4.2

getCloseSocketEventListeners

public Collection getCloseSocketEventListeners()
推奨されていません。
このソケットに登録されているクローズ・イベント・リスナーを返します。 このメソッドの戻り値となる Collection の各要素は SocketEventListener 型オブジェクトです。

戻り値:
SocketEventListener を要素とする Collection
導入されたバージョン:
version 4.2

lastError

public Throwable lastError()
推奨されていません。
このインスタンスのメソッド中で最後に発生した例外を返します。

戻り値:
最後に発生した例外

clearError

public void clearError()
推奨されていません。
このインスタンスのメソッド実行中に発生した例外をすべて破棄します。

このメソッドを実行すると、次に例外が発生するまで lastError()メソッドは null を返し、 errorIterator()メソッドは空の反復子を返します。

導入されたバージョン:
version 4.0

errorIterator

public Iterator errorIterator()
推奨されていません。
このインスタンスのメソッド実行中に発生した例外を返します。 このメソッドの返す反復子は発生時間順に例外オブジェクトを返します。 反復子の返すオブジェクトは、Throwable クラスと代入互換のある オブジェクトになります。

戻り値:
例外の反復子

close

public void close()
           throws IOException
推奨されていません。
入出力ストリームおよびソケットを閉じます。
入出力ストリームを閉じる前にバッファに溜められているデータをすべて 出力ストリームに書き出します。

例外:
IOException - 入出力エラーが発生した場合

isClosed

public boolean isClosed()
推奨されていません。
このソケットが閉じられているかどうかをチェックします。

戻り値:
ソケットが閉じられている場合は true
導入されたバージョン:
version4.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Localhost (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
クラス Localhost

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.net.Localhost
すべての実装インタフェース:
Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.Localhost クラスを使用してください。

public class Localhost
extends Object
implements Serializable

このクラスは、サーバプロセスの基礎情報を管理します。

導入されたバージョン:
version 4.0
関連項目:
直列化された形式

メソッドの概要
byte[] | getAddress() 推奨されていません。 このコンピュータのＩＰアドレスを返します。
String | getHostAddress() 推奨されていません。 このコンピュータのアドレスを返します。
String | getHostName() 推奨されていません。 このコンピュータのホスト名を返します。
static Localhost | instance() 推奨されていません。 このクラスから生成される唯一のインスタンスを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

instance

public static Localhost instance()
推奨されていません。
このクラスから生成される唯一のインスタンスを返します。 このメソッドが返すインスタンスは、常に一定で、 VM 内で共有されます。

戻り値:
このクラスのインスタンス

getAddress

public byte[] getAddress()
推奨されていません。
このコンピュータのＩＰアドレスを返します。

戻り値:
IPアドレス

getHostAddress

public String getHostAddress()
推奨されていません。
このコンピュータのアドレスを返します。

戻り値:
アドレス

getHostName

public String getHostName()
推奨されていません。
このコンピュータのホスト名を返します。

戻り値:
ホスト名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.utility.net (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.utility.net
インタフェース
SocketConnectionDistributor
SocketConnectionManager
SocketEventListener
クラス
AbstractSocketConnectionDistributor
ExtendedSocket
Localhost
SocketConnection
SocketPool
例外
UnsupportedNetworkConnectException


jp.co.intra_mart.foundation.utility.net (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.net

ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

参照:
説明

インタフェースの概要
SocketConnectionDistributor | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor クラスを使用してください。
SocketConnectionManager | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager クラスを使用してください。
SocketEventListener | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener クラスを使用してください。

クラスの概要
AbstractSocketConnectionDistributor | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor クラスを使用してください。
ExtendedSocket | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket クラスを使用してください。
Localhost | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.Localhost クラスを使用してください。
SocketConnection | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。
SocketPool | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketPool クラスを使用してください。

例外の概要
UnsupportedNetworkConnectException 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException クラスを使用してください。

パッケージ jp.co.intra_mart.foundation.utility.net の説明

ソケットによるネットワーク対応機能を実装するためのクラスを提供します。


jp.co.intra_mart.foundation.utility.net クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.net の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor (implements jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor)
      • class jp.co.intra_mart.foundation.utility.net.SocketPool (implements jp.co.intra_mart.foundation.utility.net.SocketConnectionManager)
    • class jp.co.intra_mart.foundation.utility.net.ExtendedSocket
      • class jp.co.intra_mart.foundation.utility.net.SocketConnection
    • class jp.co.intra_mart.foundation.utility.net.Localhost (implements java.io.Serializable)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.io.IOException
          • class jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException

インタフェース階層

  • interface jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor
    • interface jp.co.intra_mart.foundation.utility.net.SocketConnectionManager
  • interface jp.co.intra_mart.foundation.utility.net.SocketEventListener


パッケージ jp.co.intra_mart.foundation.utility.net の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.utility.net の使用

jp.co.intra_mart.foundation.utility.net を使用しているパッケージ
jp.co.intra_mart.foundation.service.client | このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.client.batch | Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file | Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.manager | このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.utility.net | ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.service.client により使用される jp.co.intra_mart.foundation.utility.net のクラス
SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。
UnsupportedNetworkConnectException
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException クラスを使用してください。

jp.co.intra_mart.foundation.service.client.batch により使用される jp.co.intra_mart.foundation.utility.net のクラス
SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。

jp.co.intra_mart.foundation.service.client.file により使用される jp.co.intra_mart.foundation.utility.net のクラス
SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。

jp.co.intra_mart.foundation.service.client.information により使用される jp.co.intra_mart.foundation.utility.net のクラス
SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。

jp.co.intra_mart.foundation.service.client.manager により使用される jp.co.intra_mart.foundation.utility.net のクラス
SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。
SocketConnectionDistributor
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor クラスを使用してください。

jp.co.intra_mart.foundation.utility.net により使用される jp.co.intra_mart.foundation.utility.net のクラス
AbstractSocketConnectionDistributor
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor クラスを使用してください。
ExtendedSocket
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket クラスを使用してください。
Localhost
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.Localhost クラスを使用してください。
SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。
SocketConnectionDistributor
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor クラスを使用してください。
SocketConnectionManager
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager クラスを使用してください。
SocketEventListener
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SocketConnection (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
クラス SocketConnection

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.net.ExtendedSocket
        拡張 jp.co.intra_mart.foundation.utility.net.SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。

public abstract class SocketConnection
extends ExtendedSocket

ソケットプール用のスケルトン実装を提供します。

関連項目:
SocketPool

コンストラクタの概要
protected | SocketConnection(ExtendedSocket socket) 推奨されていません。 ソケット入出力インスタンスを構築します。
protected | SocketConnection(Socket socket) 推奨されていません。 ソケット入出力インスタンスを構築します。
protected | SocketConnection(String address, int port) 推奨されていません。 ソケット入出力インスタンスを構築します。
メソッドの概要
abstract  void release()
推奨されていません。 ソケットおよび入出力ストリームの利用を中止します。
クラス jp.co.intra_mart.foundation.utility.net.ExtendedSocket から継承したメソッド
addCloseSocketEventListener, clearError, close, errorIterator, getCloseSocketEventListeners, getInputStream, getOutputStream, getSocket, isClosed, lastError
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SocketConnection

protected SocketConnection(String address,
                           int port)
                    throws IOException
推奨されていません。
ソケット入出力インスタンスを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
address - 接続先アドレス
port - 接続先ポート
例外:
IOException - 入出力ストリームの作成時エラー

SocketConnection

protected SocketConnection(Socket socket)
                    throws IOException
推奨されていません。
ソケット入出力インスタンスを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
socket - ソケットオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー

SocketConnection

protected SocketConnection(ExtendedSocket socket)
                    throws IOException
推奨されていません。
ソケット入出力インスタンスを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
socket - ソケットオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー
メソッドの詳細

release

public abstract void release()
                      throws IOException
推奨されていません。
ソケットおよび入出力ストリームの利用を中止します。

このインスタンスの利用が終了したら、必ず呼び出して下さい。
このメソッドを呼び出さないと、プール領域中のリソースが完全には 開放されません。
また、スーパークラス ExtendedSocket の close メソッドを呼び出した場合も プール中のリソースが完全に開放されない可能性があります。

リソースの開放は、プールオブジェクトが必要に応じて行います。

例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SocketConnectionDistributor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
インタフェース SocketConnectionDistributor

既知のサブインタフェースの一覧:
SocketConnectionManager
既知の実装クラスの一覧:
AbstractSocketConnectionDistributor, SocketPool
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor クラスを使用してください。

public interface SocketConnectionDistributor

このクラスは、通信ソケットをプールする機能を提供します。

プール機能を利用することにより少ないソケットを複数のプログラムから 利用できるようになります。
このプールは、１つのインスタンスに付き１つの専用スレッドを持ちます。 プールは専用のスレッドにより管理され、一定時間に１つのコネクションが 順に破棄されていきます。したがって、コネクションを全く使用しないまま 長い時間が経過すると、このプール中にプールされているソケット・コネクションは ０個になります。

メソッドの概要
void | clean() 推奨されていません。 プール中のコネクションをすべて破棄します。
SocketConnection | connection() 推奨されていません。 コネクションの取得。
void | destroy() 推奨されていません。 このプールを破棄します。

メソッドの詳細

connection

public SocketConnection connection()
                            throws IOException
推奨されていません。
コネクションの取得。

プール中にコネクションが待機している場合にはプールの中から 待機中のコネクションを返却します。 プール中にコネクションが存在しない場合には、 新しいコネクションを生成して返します。

戻り値:
通信用インスタンス
例外:
IOException - ソケットの接続エラー
関連項目:
SocketConnection

destroy

public void destroy()
推奨されていません。
このプールを破棄します。

clean

public void clean()
推奨されていません。
プール中のコネクションをすべて破棄します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SocketConnectionManager (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
インタフェース SocketConnectionManager

すべてのスーパーインタフェース:
SocketConnectionDistributor
既知の実装クラスの一覧:
SocketPool
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager クラスを使用してください。

public interface SocketConnectionManager
extends SocketConnectionDistributor

通信ソケットをプールする機能のインターフェースです。

導入されたバージョン:
version 4.2

メソッドの概要
int | getCapacity() 推奨されていません。 コネクション作成最大数の取得。
int | getSize() 推奨されていません。 このプールが現在管理しているコネクション数です。
int | usableConnection() 推奨されていません。 現在待機中のコネクションをです。
インタフェース jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor から継承したメソッド
clean, connection, destroy

メソッドの詳細

getCapacity

public int getCapacity()
推奨されていません。
コネクション作成最大数の取得。

戻り値:
このプールにより作成されるコネクションの最大数

getSize

public int getSize()
推奨されていません。
このプールが現在管理しているコネクション数です。

この数は、最小が 0 で最大が getCapacity() メソッドにより得られる値の 間で変動します。

戻り値:
有効なコネクション数
導入されたバージョン:
version 4.2

usableConnection

public int usableConnection()
推奨されていません。
現在待機中のコネクションをです。

戻り値:
待機中のコネクション数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SocketEventListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
インタフェース SocketEventListener

推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener クラスを使用してください。

public interface SocketEventListener

通信ソケットに関するイベント発生を受け取るためのスケルトン実装です。

ソケットに関するイベント通知側と組み合わせて利用することにより、 ソケットに関する特定のイベント発生時に独自の処理を実行することができます。

メソッドの概要
 void handleSocketEvent(ExtendedSocket socket)
推奨されていません。 ソケットに関するイベント発生時に呼び出されるメソッド。

メソッドの詳細

handleSocketEvent

public void handleSocketEvent(ExtendedSocket socket)
                       throws IOException
推奨されていません。
ソケットに関するイベント発生時に呼び出されるメソッド。 サブクラスは、このメソッドを実装することにより、特定のソケットに関する イベントの発生を知ることができます。

パラメータ:
socket - イベントの発生したソケット
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SocketPool (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
クラス SocketPool

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor
        拡張 jp.co.intra_mart.foundation.utility.net.SocketPool
すべての実装インタフェース:
SocketConnectionDistributor, SocketConnectionManager
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketPool クラスを使用してください。

public class SocketPool
extends AbstractSocketConnectionDistributor
implements SocketConnectionManager

このクラスは、通信ソケットをプールする機能を提供します。

プール機能を利用することにより少ないソケットを複数のプログラムから 利用できるようになります。
このプールは、１つのインスタンスに付き１つの専用スレッドを持ちます。 プールは専用のスレッドにより管理され、一定時間に１つのコネクションが 順に破棄されていきます。したがって、コネクションを全く使用しないまま 長い時間が経過すると、このプール中にプールされているソケット・コネクションは ０個になります。

コンストラクタの概要
SocketPool(String address, int port)
推奨されていません。 ソケットプールを構築します。
SocketPool(String address, int port, int capacity)
推奨されていません。 ソケットプールを構築します。
メソッドの概要
void | addCloseSocketEventListener(SocketEventListener listener) 推奨されていません。 ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
void | addCreateSocketEventListener(SocketEventListener listener) 推奨されていません。 ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。
void | clean() 推奨されていません。 プール中のコネクションをすべて破棄します。
SocketConnection | connection() 推奨されていません。 コネクションの取得。
void | destroy() 推奨されていません。 このプールを破棄します。
boolean | eject(SocketConnection connection) 推奨されていません。 指定コネクションをこのプールの管理から切り離します。
protected void | finalize() 推奨されていません。 このオブジェクトへの参照はもうないとガーベージコレクションによって 判断されたときに、ガーベージコレクタによって呼び出されます。
int | getCapacity() 推奨されていません。 コネクション作成最大数の取得。
Collection | getCloseSocketEventListeners() 推奨されていません。 このプールに登録されている ソケットをクローズしたイベントを通知するためのリスナーを 返します。
Collection | getCreateSocketEventListeners() 推奨されていません。 このプールに登録されている ソケットを新規に作成したイベントを通知するためのリスナーを 返します。
int | getSize() 推奨されていません。 このプールが現在管理しているコネクション数です。
int | usableConnection() 推奨されていません。 現在待機中のコネクションをです。
クラス jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor から継承したメソッド
createSocket, getAddress, getPort
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SocketPool

public SocketPool(String address,
                  int port)
推奨されていません。
ソケットプールを構築します。

このプールで管理できるソケットコネクションは 1 個になります。

パラメータ:
address - 接続するサーバのアドレス
port - 接続するサーバがサービスを提供しているポート

SocketPool

public SocketPool(String address,
                  int port,
                  int capacity)
推奨されていません。
ソケットプールを構築します。

コネクションは動的に生成されます。 capacity 個よりも多くのコネクション要求があった場合、 コネクションが開放されるまで待ち状態になります。
capacity にはプールの性質上、 1 以上の値を指定して下さい。 capacity に 1 より小さな値を指定した場合、プール数は 1 になります。

パラメータ:
address - 接続するサーバのアドレス
port - 接続するサーバがサービスを提供しているポート
capacity - 接続コネクションの最大数
メソッドの詳細

addCreateSocketEventListener

public void addCreateSocketEventListener(SocketEventListener listener)
推奨されていません。
ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。 このメソッドで追加したリスナーには、このプールで新規にソケットが 作成されたときに、そのソケットをメソッド引数として handleSocketEventメソッドが実行されます。

パラメータ:
listener - ソケットイベントリスナー

getCreateSocketEventListeners

public Collection getCreateSocketEventListeners()
推奨されていません。
このプールに登録されている ソケットを新規に作成したイベントを通知するためのリスナーを 返します。 このメソッドの戻り値となる Collection の各要素は SocketEventListener 型オブジェクトです。

戻り値:
SocketEventListener を要素とする Collection

addCloseSocketEventListener

public void addCloseSocketEventListener(SocketEventListener listener)
推奨されていません。
ソケットをクローズしたイベントを通知するためのリスナーを 設定します。 このメソッドで追加したリスナーには、このプールのソケットが クローズされたときに、そのソケットをメソッド引数として handleSocketEventメソッドが実行されます。

パラメータ:
listener - ソケットイベントリスナー

getCloseSocketEventListeners

public Collection getCloseSocketEventListeners()
推奨されていません。
このプールに登録されている ソケットをクローズしたイベントを通知するためのリスナーを 返します。 このメソッドの戻り値となる Collection の各要素は SocketEventListener 型オブジェクトです。

戻り値:
SocketEventListener を要素とする Collection

getCapacity

public int getCapacity()
推奨されていません。
コネクション作成最大数の取得。

定義:
インタフェース SocketConnectionManager 内の getCapacity
戻り値:
このプールにより作成されるコネクションの最大数

getSize

public int getSize()
推奨されていません。
このプールが現在管理しているコネクション数です。

この数は、最小が 0 で最大が getCapacity() メソッドにより得られる値の 間で変動します。

定義:
インタフェース SocketConnectionManager 内の getSize
戻り値:
有効なコネクション数
導入されたバージョン:
version 4.2

usableConnection

public int usableConnection()
推奨されていません。
現在待機中のコネクションをです。

定義:
インタフェース SocketConnectionManager 内の usableConnection
戻り値:
待機中のコネクション数

connection

public SocketConnection connection()
                            throws IOException
推奨されていません。
コネクションの取得。

プール中にコネクションが待機している場合にはプールの中から 待機中のコネクションを返却します。 プール中にコネクションが存在しない場合には、 新しいコネクションを生成して返します。

定義:
インタフェース SocketConnectionDistributor 内の connection
戻り値:
通信用インスタンス
例外:
IOException - ソケットの接続エラー
関連項目:
SocketConnection

eject

public boolean eject(SocketConnection connection)
推奨されていません。
指定コネクションをこのプールの管理から切り離します。

指定コネクションがこのプールに管理されていたものなら、 このメソッド実行後はこのプールの管理するコネクションが１つ減少するので、 新たにコネクションを作成することができるようになります。

指定のコネクションをこのプールが管理していて他のスレッドによって 使用（connection() メソッドにより取得）されていない場合 true を 返します。指定のコネクションがこのプールにより管理されているもの であった場合でも、他のスレッドにより使用中の場合は false を返します。

パラメータ:
connection - 管理から切り離すコネクション
戻り値:
コネクションの切り離しに成功した場合 true

destroy

public void destroy()
推奨されていません。
このプールを破棄します。

定義:
インタフェース SocketConnectionDistributor 内の destroy

clean

public void clean()
推奨されていません。
プール中のコネクションをすべて破棄します。

定義:
インタフェース SocketConnectionDistributor 内の clean

finalize

protected void finalize()
                 throws Throwable
推奨されていません。
このオブジェクトへの参照はもうないとガーベージコレクションによって 判断されたときに、ガーベージコレクタによって呼び出されます。 SocketPool クラスは、このメソッドによりオブジェクトの破棄前に リソースのクリーンアップをします。

例外:
Throwable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UnsupportedNetworkConnectException (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
クラス UnsupportedNetworkConnectException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.io.IOException
                拡張 jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException
すべての実装インタフェース:
Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException クラスを使用してください。

public class UnsupportedNetworkConnectException
extends IOException

関連項目:
直列化された形式

コンストラクタの概要
UnsupportedNetworkConnectException()
推奨されていません。 Constructor for UnsupportedNetworkConnectException.
UnsupportedNetworkConnectException(String arg0)
推奨されていません。 Constructor for UnsupportedNetworkConnectException.
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UnsupportedNetworkConnectException

public UnsupportedNetworkConnectException()
推奨されていません。
Constructor for UnsupportedNetworkConnectException.

UnsupportedNetworkConnectException

public UnsupportedNetworkConnectException(String arg0)
推奨されていません。
Constructor for UnsupportedNetworkConnectException.

パラメータ:
arg0 -
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter の使用

AbstractMessageReporter を使用しているパッケージ
jp.co.intra_mart.foundation.utility.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.report での AbstractMessageReporter の使用

jp.co.intra_mart.foundation.utility.report での AbstractMessageReporter のサブクラス
class | FileReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileReporter クラスを使用してください。
class | MultiCastReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter クラスを使用してください。
class | PrintStreamReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.EverydayConditioner の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.EverydayConditioner の使用

jp.co.intra_mart.foundation.utility.report.EverydayConditioner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.FileReporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.FileReporter の使用

jp.co.intra_mart.foundation.utility.report.FileReporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.FileSizeConditioner の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.FileSizeConditioner の使用

jp.co.intra_mart.foundation.utility.report.FileSizeConditioner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.FilterMessageReporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.FilterMessageReporter の使用

FilterMessageReporter を使用しているパッケージ
jp.co.intra_mart.foundation.utility.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.report での FilterMessageReporter の使用

jp.co.intra_mart.foundation.utility.report での FilterMessageReporter のサブクラス
class | LineReportFilter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter クラスを使用してください。
class | ReportLevelFilter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter クラスを使用してください。
class | RepresentativeReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.LineReportFilter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.LineReportFilter の使用

jp.co.intra_mart.foundation.utility.report.LineReportFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.report.MessageReporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.report.MessageReporter の使用

MessageReporter を使用しているパッケージ
jp.co.intra_mart.foundation.utility.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.report での MessageReporter の使用

MessageReporter を実装している jp.co.intra_mart.foundation.utility.report のクラス
class | AbstractMessageReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter クラスを使用してください。
class | FileReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileReporter クラスを使用してください。
class | FilterMessageReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter クラスを使用してください。
class | LineReportFilter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter クラスを使用してください。
class | MultiCastReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter クラスを使用してください。
class | PrintStreamReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter クラスを使用してください。
class | ReportLevelFilter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter クラスを使用してください。
class | RepresentativeReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter クラスを使用してください。

MessageReporter として宣言されている jp.co.intra_mart.foundation.utility.report のフィールド
protected  MessageReporter FilterMessageReporter.out
推奨されていません。 基礎出力ストリームです。

MessageReporter 型のパラメータを持つ jp.co.intra_mart.foundation.utility.report のメソッド
void | MultiCastReporter.addReporter(MessageReporter reporter) 推奨されていません。 指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。
boolean | MultiCastReporter.hasReporter(MessageReporter reporter) 推奨されていません。 指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。
boolean | MultiCastReporter.removeReporter(MessageReporter reporter) 推奨されていません。 指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。

MessageReporter 型のパラメータを持つ jp.co.intra_mart.foundation.utility.report のコンストラクタ
RepresentativeReporter(MessageReporter out, EventQueueController queue)
推奨されていません。 指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。
ReportLevelFilter(MessageReporter out, int level)
推奨されていません。 指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。
LineReportFilter(MessageReporter out)
推奨されていません。 指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。
FilterMessageReporter(MessageReporter out)
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.MultiCastReporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.MultiCastReporter の使用

jp.co.intra_mart.foundation.utility.report.MultiCastReporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner の使用

jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.PeriodicConditioner の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.PeriodicConditioner の使用

jp.co.intra_mart.foundation.utility.report.PeriodicConditioner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.PrintStreamReporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.PrintStreamReporter の使用

jp.co.intra_mart.foundation.utility.report.PrintStreamReporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.report.ReportFileConditioner の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.report.ReportFileConditioner の使用

ReportFileConditioner を使用しているパッケージ
jp.co.intra_mart.foundation.utility.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.report での ReportFileConditioner の使用

ReportFileConditioner を実装している jp.co.intra_mart.foundation.utility.report のクラス
class | EverydayConditioner 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner クラスを使用してください。
class | FileSizeConditioner 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner クラスを使用してください。
class | OutputSizeConditioner 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner クラスを使用してください。
class | PeriodicConditioner 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner クラスを使用してください。

ReportFileConditioner 型のパラメータを持つ jp.co.intra_mart.foundation.utility.report のメソッド
void | FileReporter.addConditioner(ReportFileConditioner conditioner) 推奨されていません。 ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
boolean | FileReporter.removeConditioner(ReportFileConditioner conditioner) 推奨されていません。 ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.ReportFileWriter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.ReportFileWriter の使用

ReportFileWriter を使用しているパッケージ
jp.co.intra_mart.foundation.utility.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.report での ReportFileWriter の使用

ReportFileWriter として宣言されている jp.co.intra_mart.foundation.utility.report のフィールド
protected  ReportFileWriter FileReporter.out
推奨されていません。 基礎出力ストリームです。

ReportFileWriter 型のパラメータを持つ jp.co.intra_mart.foundation.utility.report のメソッド
boolean | ReportFileConditioner.expiration(ReportFileWriter writer) 推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
boolean | PeriodicConditioner.expiration(ReportFileWriter writer) 推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
boolean | OutputSizeConditioner.expiration(ReportFileWriter writer) 推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
boolean | FileSizeConditioner.expiration(ReportFileWriter writer) 推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
boolean | EverydayConditioner.expiration(ReportFileWriter writer) 推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。

ReportFileWriter 型のパラメータを持つ jp.co.intra_mart.foundation.utility.report のコンストラクタ
FileReporter(ReportFileWriter out)
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.report.ReportLevel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.report.ReportLevel の使用

ReportLevel を使用しているパッケージ
jp.co.intra_mart.foundation.utility.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.report での ReportLevel の使用

ReportLevel を実装している jp.co.intra_mart.foundation.utility.report のクラス
 class ReportLevelFilter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.ReportLevelFilter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.ReportLevelFilter の使用

jp.co.intra_mart.foundation.utility.report.ReportLevelFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.RepresentativeReporter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.RepresentativeReporter の使用

jp.co.intra_mart.foundation.utility.report.RepresentativeReporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AbstractMessageReporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス AbstractMessageReporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter
すべての実装インタフェース:
MessageReporter
直系の既知のサブクラス:
FileReporter, MultiCastReporter, PrintStreamReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter クラスを使用してください。

public abstract class AbstractMessageReporter
extends Object
implements MessageReporter

メッセージ出力用のスケルトンクラスです。

サブクラスでは、report メソッドをオーバーライドして、 任意の出力先にメッセージを出力する機能を実装する必要があります。

導入されたバージョン:
version 3.2

コンストラクタの概要
protected AbstractMessageReporter()
推奨されていません。 唯一のコンストラクタ。
メソッドの概要
void | close() 推奨されていません。 このオブジェクトを閉じます。
void | flush() 推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
void | report(Object data) 推奨されていません。 data をメッセージとして出力します。
abstract void | report(String message) 推奨されていません。 メッセージを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractMessageReporter

protected AbstractMessageReporter()
推奨されていません。
唯一のコンストラクタ。

メソッドの詳細

report

public abstract void report(String message)
推奨されていません。
メッセージを出力します。

定義:
インタフェース MessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
推奨されていません。
data をメッセージとして出力します。
このメソッドは、以下の呼出と同じです。

report(String.valueOf(data))

定義:
インタフェース MessageReporter 内の report
パラメータ:
data - データ

close

public void close()
           throws IOException
推奨されていません。
このオブジェクトを閉じます。 オブジェクトが閉じられると、report メソッドは何もしなくなります。 必要に応じてサブクラスでオーバーライドしてください。

定義:
インタフェース MessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
推奨されていません。
このオブジェクトのバッファの情報をすべて出力します。 このメソッドは、何も行いません。 必要に応じてサブクラスでオーバーライドしてください。

定義:
インタフェース MessageReporter 内の flush
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EverydayConditioner (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス EverydayConditioner

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.EverydayConditioner
すべての実装インタフェース:
ReportFileConditioner
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner クラスを使用してください。

public class EverydayConditioner
extends Object
implements ReportFileConditioner

このクラスは、時間によりリフレッシュイベントを 発生させるためのヘルパークラスです。
このクラスは、FileReporter と組み合わせて利用します。 このクラスのオブジェクトを FileReporter オブジェクトにセットすることで、 指定時間になった(指定時間を経過した)ときに、 メッセージファイルのローテイト機能イベントを発生させることができます。 時間のチェックは時および分によるものなので、FileReporter の中で リフレッシュイベントは毎日発生することになります。

導入されたバージョン:
version 3.2
関連項目:
FileReporter, ReportFileWriter

コンストラクタの概要
EverydayConditioner(int hours, int minutes)
推奨されていません。 毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
EverydayConditioner(int hours, int minutes, TimeZone timeZone)
推奨されていません。 毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
メソッドの概要
 boolean expiration(ReportFileWriter writer)
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EverydayConditioner

public EverydayConditioner(int hours,
                           int minutes,
                           TimeZone timeZone)
                    throws IllegalArgumentException
推奨されていません。
毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
このオブジェクトは、毎日指定された時刻に なった場合にリフレッシュイベント発生を通知します。
時刻の計算は、指定されたタイムゾーンに基づきます。

パラメータ:
hours - 時間(0 ～ 23)
minutes - 分(0 ～ 59)
timeZone - タイムゾーン
例外:
IllegalArgumentException - 引数が有効範囲外の場合

EverydayConditioner

public EverydayConditioner(int hours,
                           int minutes)
                    throws IllegalArgumentException
推奨されていません。
毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
このオブジェクトは、毎日指定された時刻に なった場合にリフレッシュイベント発生を通知します。
時刻の計算は、デフォルトタイムゾーンに基づきます。

パラメータ:
hours - 時間(0 ～ 23)
minutes - 分(0 ～ 59)
例外:
IllegalArgumentException - 引数が有効範囲外の場合
メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
推奨されていません。
メッセージファイルを再作成する必要があるかどうかを判定します。
このオブジェクトの作成時に指定された時刻を経過して最初の呼び出し時 の場合 true を返します。

定義:
インタフェース ReportFileConditioner 内の expiration
パラメータ:
writer - 出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
関連項目:
FileReporter, ReportFileWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FileReporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス FileReporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter
        拡張 jp.co.intra_mart.foundation.utility.report.FileReporter
すべての実装インタフェース:
MessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileReporter クラスを使用してください。

public class FileReporter
extends AbstractMessageReporter

メッセージのファイル出力機能を提供します。

このクラスは、report メソッドで渡されたメッセージを指定のファイルに 出力します。

導入されたバージョン:
version 3.2

フィールドの概要
protected  ReportFileWriter out
推奨されていません。 基礎出力ストリームです。
コンストラクタの概要
FileReporter(ReportFileWriter out)
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
メソッドの概要
void | addConditioner(ReportFileConditioner conditioner) 推奨されていません。 ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
void | close() 推奨されていません。 このオブジェクトを閉じます。
protected void | finalize() 推奨されていません。 このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
void | flush() 推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
boolean | removeConditioner(ReportFileConditioner conditioner) 推奨されていません。 ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。
void | report(String message) 推奨されていません。 メッセージを出力します。
クラス jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter から継承したメソッド
report
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

out

protected ReportFileWriter out
推奨されていません。
基礎出力ストリームです。

コンストラクタの詳細

FileReporter

public FileReporter(ReportFileWriter out)
推奨されていません。
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。

パラメータ:
out - 基礎出力ストリーム
メソッドの詳細

addConditioner

public void addConditioner(ReportFileConditioner conditioner)
推奨されていません。
ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
引数が null の場合は、何の効果もありません。 また、conditioner が既に登録済みのインスタンスである場合、 追加登録はされません。

パラメータ:
conditioner - 追加する ReportFileConditioner のインスタンス

removeConditioner

public boolean removeConditioner(ReportFileConditioner conditioner)
推奨されていません。
ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。
引数が null の場合は、何の効果もありません。

パラメータ:
conditioner - 削除する ReportFileConditioner のインスタンス
戻り値:
指定のオブジェクトを削除できた場合 true。

report

public void report(String message)
推奨されていません。
メッセージを出力します。 このオブジェクトが既に閉じられている場合、このメソッドは 何も行いません。

定義:
インタフェース MessageReporter 内の report
定義:
クラス AbstractMessageReporter 内の report
パラメータ:
message - メッセージ

close

public void close()
           throws IOException
推奨されていません。
このオブジェクトを閉じます。 このオブジェクトに関わる全てのリソースを開放します。 オブジェクトが閉じられると、report メソッドは何もしなくなります。

定義:
インタフェース MessageReporter 内の close
オーバーライド:
クラス AbstractMessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
推奨されていません。
このオブジェクトのバッファの情報をすべて出力します。 また、このメソッドは基礎ストリームも同時にフラッシュします。

定義:
インタフェース MessageReporter 内の flush
オーバーライド:
クラス AbstractMessageReporter 内の flush
例外:
IOException - 入出力エラー

finalize

protected void finalize()
                 throws Throwable
推奨されていません。
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
このオブジェクトの全てのリソースを破棄します。

例外:
Throwable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FileSizeConditioner (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス FileSizeConditioner

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.FileSizeConditioner
すべての実装インタフェース:
ReportFileConditioner
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner クラスを使用してください。

public class FileSizeConditioner
extends Object
implements ReportFileConditioner

このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
このクラスは、FileReporter と組み合わせて利用します。 このクラスのオブジェクトを FileReporter オブジェクトにセットすることで、 メッセージファイルが一定サイズ以上になったときに、 メッセージファイルのローテイト機能イベントを発生させることができます。

導入されたバージョン:
version 3.2
関連項目:
FileReporter, ReportFileWriter

コンストラクタの概要
FileSizeConditioner(long max)
推奨されていません。 メッセージファイルのサイズによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
メソッドの概要
 boolean expiration(ReportFileWriter writer)
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FileSizeConditioner

public FileSizeConditioner(long max)
                    throws IllegalArgumentException
推奨されていません。
メッセージファイルのサイズによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
このオブジェクトは、メッセージファイルが指定の大きさ(max)以上に なった場合にリフレッシュイベント発生を通知します。

例外:
IllegalArgumentException - max がゼロ以下の場合
メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
推奨されていません。
メッセージファイルを再作成する必要があるかどうかを判定します。
ファイルサイズが、このオブジェクトの作成時に指定された 値以上の場合 true を返します。

定義:
インタフェース ReportFileConditioner 内の expiration
パラメータ:
writer - 出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
関連項目:
FileReporter, ReportFileWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FilterMessageReporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス FilterMessageReporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.FilterMessageReporter
すべての実装インタフェース:
MessageReporter
直系の既知のサブクラス:
LineReportFilter, ReportLevelFilter, RepresentativeReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter クラスを使用してください。

public class FilterMessageReporter
extends Object
implements MessageReporter

メッセージ出力ストリームをフィルタ処理するクラスのスーパークラスです。

基礎出力ストリームにメッセージを出力する前にメッセージを加工したりする 追加機能を提供するクラスを作成するために利用することができます。

このクラスは、単に MessageReporter の全てのメソッドを オーバーライドし、各要求を基礎出力ストリームに渡す機能を提供しています。 サブクラスでは、メソッドを追加したり、必要に応じてメソッドをオーバーライド することがあります。

導入されたバージョン:
version 3.2

フィールドの概要
protected  MessageReporter out
推奨されていません。 基礎出力ストリームです。
コンストラクタの概要
FilterMessageReporter(MessageReporter out)
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。
メソッドの概要
void | close() 推奨されていません。 このオブジェクトを閉じます。
void | flush() 推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
void | report(Object data) 推奨されていません。 基礎出力ストリームに対してメッセージを出力します。
void | report(String message) 推奨されていません。 基礎出力ストリームに対してメッセージを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

out

protected MessageReporter out
推奨されていません。
基礎出力ストリームです。

コンストラクタの詳細

FilterMessageReporter

public FilterMessageReporter(MessageReporter out)
推奨されていません。
指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。

パラメータ:
out - 基礎出力リポーター
メソッドの詳細

report

public void report(String message)
推奨されていません。
基礎出力ストリームに対してメッセージを出力します。
このメソッドは、単純に message を基礎出力ストリームに渡します。 サブクラスで、このメソッドをオーバーライドすることにより、 データの加工などのフィルタリング処理を追加することができます。

定義:
インタフェース MessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
推奨されていません。
基礎出力ストリームに対してメッセージを出力します。
このメソッドは、単純に data を基礎出力ストリームに渡します。 サブクラスで、このメソッドをオーバーライドすることにより、 データの加工などのフィルタリング処理を追加することができます。

定義:
インタフェース MessageReporter 内の report
パラメータ:
data - データ

close

public void close()
           throws IOException
推奨されていません。
このオブジェクトを閉じます。 オブジェクトが閉じられると、report メソッドは何もしなくなります。

定義:
インタフェース MessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
推奨されていません。
このオブジェクトのバッファの情報をすべて出力します。 このメソッドでは、基礎出力リポートオブジェクトも同時にフラッシュします。

定義:
インタフェース MessageReporter 内の flush
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LineReportFilter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス LineReportFilter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.FilterMessageReporter
        拡張 jp.co.intra_mart.foundation.utility.report.LineReportFilter
すべての実装インタフェース:
MessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter クラスを使用してください。

public class LineReportFilter
extends FilterMessageReporter

メッセージを行出力するためのフィルタークラスです。

このクラスを利用すると、report メソッドに渡されたメッセージ文字列に 改行コードを付加して、行出力することができます。
以下のようなプログラムにより、ログファイルをログファイルを作成することが できます。

FIle logFile = new File("test.log");
ReportFileWriter writer = new ReportFileWriter(logFile);
FileReporter writer = new FileReporter(writer);
MessageReporter reporter = new LineReportFilter(writer);
これで、変数 reporter の report メソッドを呼び出す毎に、 ファイル test.log に report メソッド指定したメッセージが １行として出力されます。

導入されたバージョン:
version 3.2
関連項目:
ReportLevel

フィールドの概要
クラス jp.co.intra_mart.foundation.utility.report.FilterMessageReporter から継承したフィールド
out
コンストラクタの概要
LineReportFilter(MessageReporter out)
推奨されていません。 指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。
メソッドの概要
void | report(Object data) 推奨されていません。 基礎出力ストリームに対してメッセージを出力します。
void | report(String message) 推奨されていません。 メッセージを出力します。
クラス jp.co.intra_mart.foundation.utility.report.FilterMessageReporter から継承したメソッド
close, flush
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LineReportFilter

public LineReportFilter(MessageReporter out)
推奨されていません。
指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。

パラメータ:
out - 基礎出力ストリーム
メソッドの詳細

report

public void report(String message)
推奨されていません。
メッセージを出力します。
このメソッドは、基礎出力ストリームに対して、message に 改行コードを付加してメッセージを１行出力します。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
推奨されていません。
基礎出力ストリームに対してメッセージを出力します。
このメソッドは、単純に data を基礎出力ストリームに渡します。 サブクラスで、このメソッドをオーバーライドすることにより、 データの加工などのフィルタリング処理を追加することができます。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
data - データ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MessageReporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
インタフェース MessageReporter

既知の実装クラスの一覧:
AbstractMessageReporter, FilterMessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter クラスを使用してください。

public interface MessageReporter

メッセージ出力のためのインターフェースです。

このインターフェースを実装したクラスでは、report メソッドで 指定されたメッセージを任意の出力先に対して出力する機能を提供します。

導入されたバージョン:
version 3.2

メソッドの概要
void | close() 推奨されていません。 このオブジェクトを閉じます。
void | flush() 推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
void | report(Object data) 推奨されていません。 data をメッセージとして出力します。
void | report(String message) 推奨されていません。 メッセージを出力します。

メソッドの詳細

report

public void report(String message)
推奨されていません。
メッセージを出力します。

パラメータ:
message - メッセージ

report

public void report(Object data)
推奨されていません。
data をメッセージとして出力します。

パラメータ:
data - データ

close

public void close()
           throws IOException
推奨されていません。
このオブジェクトを閉じます。 オブジェクトが閉じられると、report メソッドは何もしなくなります。 このメソッドは、任意のオペレーションです。

例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
推奨されていません。
このオブジェクトのバッファの情報をすべて出力します。 このメソッドは、任意のオペレーションです。

例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MultiCastReporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス MultiCastReporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter
        拡張 jp.co.intra_mart.foundation.utility.report.MultiCastReporter
すべての実装インタフェース:
MessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter クラスを使用してください。

public class MultiCastReporter
extends AbstractMessageReporter

メッセージを複数のストリームに出力するためのフィルタークラスです。

このクラスは、MessageReporter インターフェースを実装したクラスに対する フィルタークラスとして働きます。 report メソッドに渡されたメッセージデータは、指定された複数の MessageReporter インターフェースすべてに渡されます。
このフィルタークラスを利用することにより、複数の MessageReporter に 対して同じメッセージを渡すことができるため、メッセージ出力プログラムを 効率的に記述することができます。

メッセージの出力先となる MessageReporter は、addReporter メソッドで 定義します。addReporter メソッドでの定義順と、実際の実行順は 保証されません。

導入されたバージョン:
version 3.2

コンストラクタの概要
MultiCastReporter()
推奨されていません。 唯一のコンストラクタ。
メソッドの概要
void | addReporter(MessageReporter reporter) 推奨されていません。 指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。
void | close() 推奨されていません。 このオブジェクトを閉じます。
void | flush() 推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
Iterator | getReporters() 推奨されていません。 セット内の要素についての反復子を返します。
boolean | hasReporter(MessageReporter reporter) 推奨されていません。 指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。
boolean | removeReporter(MessageReporter reporter) 推奨されていません。 指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。
void | report(Object data) 推奨されていません。 data をメッセージとして出力します。
void | report(String message) 推奨されていません。 メッセージを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MultiCastReporter

public MultiCastReporter()
推奨されていません。
唯一のコンストラクタ。

メソッドの詳細

addReporter

public void addReporter(MessageReporter reporter)
推奨されていません。
指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。 すでに指定のオブジェクトを要素としてもっていた場合、 このメソッドは何も行いません。

パラメータ:
reporter - セットに追加される要素

hasReporter

public boolean hasReporter(MessageReporter reporter)
推奨されていません。
指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。

パラメータ:
reporter - セットに含まれているかチェックする要素
戻り値:
セット内に指定された要素がある場合は true

removeReporter

public boolean removeReporter(MessageReporter reporter)
推奨されていません。
指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。

パラメータ:
reporter - セットにあった場合に削除されるオブジェクト
戻り値:
指定された要素がセット内にあった場合は true

getReporters

public Iterator getReporters()
推奨されていません。
セット内の要素についての反復子を返します。 反復子から取得される各要素は、addReporter メソッドにより追加された リポーターオブジェクトになります。 各要素の取得順は保証されません。 このオブジェクトが閉じられている場合 null を返します。

戻り値:
セット内の要素についての反復子

report

public void report(String message)
推奨されていません。
メッセージを出力します。

定義:
インタフェース MessageReporter 内の report
定義:
クラス AbstractMessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
推奨されていません。
data をメッセージとして出力します。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス AbstractMessageReporter 内の report
パラメータ:
data - データ

close

public void close()
           throws IOException
推奨されていません。
このオブジェクトを閉じます。 オブジェクトが閉じられると、report メソッドは何もしなくなります。 このオブジェクトの持つすべての Reporter オブジェクトを閉じて、 リソースを開放します。

定義:
インタフェース MessageReporter 内の close
オーバーライド:
クラス AbstractMessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
推奨されていません。
このオブジェクトのバッファの情報をすべて出力します。 このメソッドは、何も行いません。 このオブジェクトの持つすべての Reporter オブジェクトをフラッシュします。

定義:
インタフェース MessageReporter 内の flush
オーバーライド:
クラス AbstractMessageReporter 内の flush
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


OutputSizeConditioner (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス OutputSizeConditioner

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner
すべての実装インタフェース:
ReportFileConditioner
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner クラスを使用してください。

public class OutputSizeConditioner
extends Object
implements ReportFileConditioner

このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
このクラスは、FileReporter と組み合わせて利用します。 このクラスのオブジェクトを FileReporter オブジェクトにセットすることで、 メッセージファイルが一定サイズ以上になったときに、 メッセージファイルのローテイト機能イベントを発生させることができます。

導入されたバージョン:
version 3.2
関連項目:
FileReporter, ReportFileWriter

コンストラクタの概要
OutputSizeConditioner(long max)
推奨されていません。 メッセージファイルへのデータ出力量によりリフレッシュイベントを 発生させるためのヘルパーオブジェクトを構築します。
メソッドの概要
 boolean expiration(ReportFileWriter writer)
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

OutputSizeConditioner

public OutputSizeConditioner(long max)
                      throws IllegalArgumentException
推奨されていません。
メッセージファイルへのデータ出力量によりリフレッシュイベントを 発生させるためのヘルパーオブジェクトを構築します。
このオブジェクトは、ログファイルへ書き出したメッセージの量が 一定(max)以上の大きさに なった場合にリフレッシュイベント発生を通知します。

例外:
IllegalArgumentException - max がゼロ以下の場合
メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
推奨されていません。
メッセージファイルを再作成する必要があるかどうかを判定します。
ファイルへの出力文字数が、このオブジェクトの作成時に指定された 値以上の場合 true を返します。

定義:
インタフェース ReportFileConditioner 内の expiration
パラメータ:
writer - 出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
関連項目:
FileReporter, ReportFileWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.utility.report (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.utility.report
インタフェース
MessageReporter
ReportFileConditioner
ReportLevel
クラス
AbstractMessageReporter
EverydayConditioner
FileReporter
FileSizeConditioner
FilterMessageReporter
LineReportFilter
MultiCastReporter
OutputSizeConditioner
PeriodicConditioner
PrintStreamReporter
ReportFileWriter
ReportLevelFilter
RepresentativeReporter


jp.co.intra_mart.foundation.utility.report (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.report

このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

参照:
説明

インタフェースの概要
MessageReporter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter クラスを使用してください。
ReportFileConditioner | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner クラスを使用してください。
ReportLevel | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel クラスを使用してください。

クラスの概要
AbstractMessageReporter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter クラスを使用してください。
EverydayConditioner | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner クラスを使用してください。
FileReporter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileReporter クラスを使用してください。
FileSizeConditioner | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner クラスを使用してください。
FilterMessageReporter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter クラスを使用してください。
LineReportFilter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter クラスを使用してください。
MultiCastReporter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter クラスを使用してください。
OutputSizeConditioner | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner クラスを使用してください。
PeriodicConditioner | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner クラスを使用してください。
PrintStreamReporter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter クラスを使用してください。
ReportFileWriter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter クラスを使用してください。
ReportLevelFilter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter クラスを使用してください。
RepresentativeReporter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter クラスを使用してください。

パッケージ jp.co.intra_mart.foundation.utility.report の説明

このパッケージには、ログ機能を実装するための汎用クラスが含まれています。


jp.co.intra_mart.foundation.utility.report クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.report の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter (implements jp.co.intra_mart.foundation.utility.report.MessageReporter)
      • class jp.co.intra_mart.foundation.utility.report.FileReporter
      • class jp.co.intra_mart.foundation.utility.report.MultiCastReporter
      • class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter
    • class jp.co.intra_mart.foundation.utility.report.EverydayConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.utility.report.FileSizeConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter (implements jp.co.intra_mart.foundation.utility.report.MessageReporter)
      • class jp.co.intra_mart.foundation.utility.report.LineReportFilter
      • class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter (implements jp.co.intra_mart.foundation.utility.report.ReportLevel)
      • class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter
    • class jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.utility.report.PeriodicConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class java.io.Writer
      • class jp.co.intra_mart.foundation.utility.report.ReportFileWriter

インタフェース階層

  • interface jp.co.intra_mart.foundation.utility.report.MessageReporter
  • interface jp.co.intra_mart.foundation.utility.report.ReportFileConditioner
  • interface jp.co.intra_mart.foundation.utility.report.ReportLevel


パッケージ jp.co.intra_mart.foundation.utility.report の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.utility.report の使用

jp.co.intra_mart.foundation.utility.report を使用しているパッケージ
jp.co.intra_mart.foundation.utility.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.report により使用される jp.co.intra_mart.foundation.utility.report のクラス
AbstractMessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter クラスを使用してください。
FilterMessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter クラスを使用してください。
MessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter クラスを使用してください。
ReportFileConditioner
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner クラスを使用してください。
ReportFileWriter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter クラスを使用してください。
ReportLevel
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PeriodicConditioner (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス PeriodicConditioner

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.PeriodicConditioner
すべての実装インタフェース:
ReportFileConditioner
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner クラスを使用してください。

public class PeriodicConditioner
extends Object
implements ReportFileConditioner

このクラスは、タイマーによりリフレッシュイベントを 発生させるためのヘルパークラスです。
このクラスは、FileReporter と組み合わせて利用します。 このクラスのオブジェクトを FileReporter オブジェクトにセットすることで、 一定期間の経過に合わせてに、 メッセージファイルのローテイト機能イベントを発生させることができます。

導入されたバージョン:
version 3.2
関連項目:
FileReporter, ReportFileWriter

コンストラクタの概要
PeriodicConditioner(long millis)
推奨されていません。 タイマーによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
メソッドの概要
 boolean expiration(ReportFileWriter writer)
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PeriodicConditioner

public PeriodicConditioner(long millis)
                    throws IllegalArgumentException
推奨されていません。
タイマーによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
このオブジェクトは、指定の時間が経過した時に リフレッシュイベント発生を通知します。

例外:
IllegalArgumentException - millis がゼロ以下の場合
メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
推奨されていません。
メッセージファイルを再作成する必要があるかどうかを判定します。
引数 outputSize の値が、このオブジェクトの作成時に指定された 値以上の場合 true を返します。

定義:
インタフェース ReportFileConditioner 内の expiration
パラメータ:
writer - 出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
関連項目:
FileReporter, ReportFileWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PrintStreamReporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス PrintStreamReporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter
        拡張 jp.co.intra_mart.foundation.utility.report.PrintStreamReporter
すべての実装インタフェース:
MessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter クラスを使用してください。

public class PrintStreamReporter
extends AbstractMessageReporter

メッセージ出力用クラスです。

このクラスは、指定の PrintStream に対してメッセージを出力するための 機能を実装しています。 例えば、このクラスのコンストラクタの引数に java.lang.System.out を指定した 場合、標準出力に対してメッセージを出力することができます。
このクラスの特徴は、report メソッドに渡されたメッセージを PrintStream の println メソッドに渡します。 これにより、report メソッドの呼び出し毎にメッセージを改行付きで 指定の PrintStream に出力することができます（１行毎に出力）。

導入されたバージョン:
version 3.2

コンストラクタの概要
PrintStreamReporter(PrintStream out)
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
メソッドの概要
void | close() 推奨されていません。 このオブジェクトを閉じます。
void | flush() 推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
void | report(String message) 推奨されていません。 メッセージを出力します。
クラス jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter から継承したメソッド
report
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PrintStreamReporter

public PrintStreamReporter(PrintStream out)
推奨されていません。
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。

パラメータ:
out - 基礎出力ストリーム
メソッドの詳細

report

public void report(String message)
推奨されていません。
メッセージを出力します。 このオブジェクトが既に閉じられている場合、このメソッドは 何も行いません。

定義:
インタフェース MessageReporter 内の report
定義:
クラス AbstractMessageReporter 内の report
パラメータ:
message - メッセージ

close

public void close()
           throws IOException
推奨されていません。
このオブジェクトを閉じます。 このオブジェクトに関わる全てのリソースを開放します。 オブジェクトが閉じられると、report メソッドは何もしなくなります。

定義:
インタフェース MessageReporter 内の close
オーバーライド:
クラス AbstractMessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
推奨されていません。
このオブジェクトのバッファの情報をすべて出力します。 また、このメソッドは基礎ストリームも同時にフラッシュします。

定義:
インタフェース MessageReporter 内の flush
オーバーライド:
クラス AbstractMessageReporter 内の flush
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReportFileConditioner (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
インタフェース ReportFileConditioner

既知の実装クラスの一覧:
EverydayConditioner, FileSizeConditioner, OutputSizeConditioner, PeriodicConditioner
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner クラスを使用してください。

public interface ReportFileConditioner

このクラスは、ReportFileWriter の初期化チェックのインターフェースです。

このクラスは FileReporter クラスにより ReportFileWriter へのメッセージ 書き出し前に呼び出されます。
このクラスは、FileReporter および ReportFileWriter オブジェクトと 組み合わせて使います。 これらのクラスと連携することにより、メッセージファイルの ローテイト機能などを実装することができます。

導入されたバージョン:
version 3.2

メソッドの概要
 boolean expiration(ReportFileWriter writer)
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。

メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
推奨されていません。
メッセージファイルを再作成する必要があるかどうかを判定します。
このメソッドは、FileReporter クラスにより呼び出されます。 真値(true)を返すと、ReportFileWriter は現在のログファイルに対して 初期化処理を行います。 メッセージファイルの初期化処理に関しては、 ReportFileWriter クラス(または、そのサブクラス)により行われます。

パラメータ:
writer - メッセージファイルへの出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReportFileWriter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス ReportFileWriter

java.lang.Object
    拡張 java.io.Writer
        拡張 jp.co.intra_mart.foundation.utility.report.ReportFileWriter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter クラスを使用してください。

public class ReportFileWriter
extends Writer

メッセージをファイルに出力するストリームクラスです。

このクラスは、メッセージを指定のファイルに対して出力するための スケルトンです。 また、このクラスは reset メソッドをオーバーライドすることにより、 ファイルのローテイト機能などを実装することができます。

導入されたバージョン:
version 3.2

フィールドの概要
クラス java.io.Writer から継承したフィールド
lock
コンストラクタの概要
ReportFileWriter(File f)
推奨されていません。 ファイルへメッセージを書き出すためのライターオブジェクトを作成します。
メソッドの概要
void | close() 推奨されていません。 ストリームを閉じてフラッシュします。
protected Writer | createWriter() 推奨されていません。 メッセージをファイルへ書き出すための出力ストリームを作成します。
Writer | currentWriter() 推奨されていません。 このオブジェクトが文字を書き出している基礎 Writer を返します。
protected void | finalize() 推奨されていません。 このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
void | flush() 推奨されていません。 ストリームをフラッシュします。
File | getFile() 推奨されていません。 このオブジェクトが文字を書き出すファイルを取得します。
long | length() 推奨されていません。 このライターの出力文字数を取得します。
protected void | reconstruction() 推奨されていません。 現在使用中の Writer をリセットします。
protected Writer | reset(Writer writer) 推奨されていません。 文字の出力ストリームをリセットします。
void | write(char[] cbuf, int off, int len) 推奨されていません。 基礎ストリームに文字を出力します。
クラス java.io.Writer から継承したメソッド
write, write, write, write
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ReportFileWriter

public ReportFileWriter(File f)
                 throws IOException
推奨されていません。
ファイルへメッセージを書き出すためのライターオブジェクトを作成します。

パラメータ:
f - このライターで書き出すファイル
例外:
IOException - 入出力エラー
メソッドの詳細

getFile

public File getFile()
推奨されていません。
このオブジェクトが文字を書き出すファイルを取得します。
このメソッドは、このオブジェクトの作成時にコンストラクタの引数として 与えられた File オブジェクトへの参照を返します。

戻り値:
このライターで書き出すファイル

createWriter

protected Writer createWriter()
                       throws IOException
推奨されていません。
メッセージをファイルへ書き出すための出力ストリームを作成します。

このメソッドは、単に getFile メソッドが返すファイルに対して 文字を書き出すための出力ストリームを作成して返します。 このメソッドの返す出力ストリームを使うことで、 getFile メソッドの返す ファイルに対してメッセージを追記していくことができます。
メッセージを任意の文字コードに変換したり、出力バッファを備えた Writer オブジェクトを作成する必要がある場合には、サブクラスで このメソッドをオーバーライドして実装して下さい。

戻り値:
出力ストリーム
例外:
IOException

length

public long length()
推奨されていません。
このライターの出力文字数を取得します。
このメソッドで返される文字数は、このファイルに対して 現在までに出力した文字数です。 文字数カウンタは、reset メソッドを実行することにより 0 (ゼロ)にリセットされます。

戻り値:
出力文字数

currentWriter

public Writer currentWriter()
推奨されていません。
このオブジェクトが文字を書き出している基礎 Writer を返します。

戻り値:
基礎 Writer オブジェクト

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
推奨されていません。
基礎ストリームに文字を出力します。
このメソッドをサブクラスがオーバーライドすることにより、 バッファ機能などを実装することができます。 ただし、このメソッドをオーバーライドしたサブクラスは、 同時に length メソッドもオーバーライドする必要があります。

パラメータ:
cbuf - 文字の配列
off - 文字の書き込み開始オフセット
len - 書き込む文字数
例外:
IOException

reconstruction

protected void reconstruction()
                       throws IOException
推奨されていません。
現在使用中の Writer をリセットします。
このメソッドは、FileReporter クラスにより呼び出されます。 FileReporter オブジェクトでは、ReportFileConditioner オブジェクトが ファイルの初期化を必要と判断した場合に、このメソッドを呼び出して、 Writer の初期化を求めてきます。 これにより、リポートファイルのローテイト機能などを 実装することができます。

例外:
IOException

reset

protected Writer reset(Writer writer)
                throws IOException
推奨されていません。
文字の出力ストリームをリセットします。

このメソッドは reset メソッドに呼び出されます。
このメソッドは、単に引数のストリーム(writer)をそのまま リターンします。ファイルのローテイト機能などを実装する場合、 サブクラスでこのメソッドをオーバーライドして下さい。

パラメータ:
writer - 現在のストリーム
戻り値:
新しいストリーム
例外:
IOException

close

public void close()
           throws IOException
推奨されていません。
ストリームを閉じてフラッシュします。
ストリームを一度閉じると、以降 write() または flush() を呼び出すと、 IOException がスローされます。 ただし、前に閉じたストリームを閉じても効果はありません。

例外:
IOException - 入出力エラーが発生した場合

flush

public void flush()
           throws IOException
推奨されていません。
ストリームをフラッシュします。
ストリームがさまざまな write() メソッドからの文字をバッファに 保存してある場合、これらの文字の目的の宛先にただちに文字を書き込みます。 宛先が別の文字またはバイトストリームの場合は、 この宛先をフラッシュします。 つまり 1 つの flush() の呼び出しで、 関連する Writer および OutputStream の すべてのバッファをフラッシュします。

サブクラスで、文字のバッファリング機能を実装している場合、 このメソッドをオーバーライドしてバッファに保存している 文字をフラッシュするように実装しなければいけません。

例外:
IOException - 入出力エラーが発生した場合

finalize

protected void finalize()
                 throws Throwable
推奨されていません。
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
このオブジェクトの全てのリソースを破棄します。

例外:
Throwable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReportLevel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
インタフェース ReportLevel

既知の実装クラスの一覧:
ReportLevelFilter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel クラスを使用してください。

public interface ReportLevel

メッセージレベルのインターフェースです。

このインターフェースは、定数値化したメッセージレベルを示します。 すべてのメッセージに関して、必ずしもこのインターフェースで定義されている レベル値を使う必要はありませんが、このインターフェースを利用することにより プログラム全体でレベル値を統一することができます。

導入されたバージョン:
version 3.2

フィールドの概要
static int | MAX_VALUE 推奨されていません。 レベル値として使用可能な最大値 この値は、java.lang.Integer.MAX_VALUE と同じです。
static int | MIN_VALUE 推奨されていません。 レベル値として使用可能な最小値 この値は、java.lang.Integer.MIN_VALUE と同じです。
static int | TYPE_DEBUG 推奨されていません。 デバッグレベル。
static int | TYPE_ERROR 推奨されていません。 エラーレベル。
static int | TYPE_REPORT 推奨されていません。 通常の情報レベル。
static int | TYPE_WARNING 推奨されていません。 警告レベル。

フィールドの詳細

MIN_VALUE

public static final int MIN_VALUE
推奨されていません。
レベル値として使用可能な最小値 この値は、java.lang.Integer.MIN_VALUE と同じです。

関連項目:
定数フィールド値

MAX_VALUE

public static final int MAX_VALUE
推奨されていません。
レベル値として使用可能な最大値 この値は、java.lang.Integer.MAX_VALUE と同じです。

関連項目:
定数フィールド値

TYPE_DEBUG

public static final int TYPE_DEBUG
推奨されていません。
デバッグレベル。 デバッグ情報を出力する場合に利用します。

関連項目:
定数フィールド値

TYPE_REPORT

public static final int TYPE_REPORT
推奨されていません。
通常の情報レベル。
常に以下の関係が成り立ちます。

TYPE_DEBUG < TYPE_REPORT

関連項目:
定数フィールド値

TYPE_WARNING

public static final int TYPE_WARNING
推奨されていません。
警告レベル。 警告メッセージ出力時に利用します。
常に以下の関係が成り立ちます。

TYPE_REPORT < TYPE_WARNING

関連項目:
定数フィールド値

TYPE_ERROR

public static final int TYPE_ERROR
推奨されていません。
エラーレベル。 エラーメッセージ出力時に利用します。
常に以下の関係が成り立ちます。

TYPE_WARNING < TYPE_ERROR

関連項目:
定数フィールド値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ReportLevelFilter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス ReportLevelFilter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.FilterMessageReporter
        拡張 jp.co.intra_mart.foundation.utility.report.ReportLevelFilter
すべての実装インタフェース:
MessageReporter, ReportLevel
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter クラスを使用してください。

public class ReportLevelFilter
extends FilterMessageReporter
implements ReportLevel

メッセージの出力制御を行うためのフィルタークラスです。

このクラスを利用することにより、メッセージをメッセージレベルにより、 出力制御を行うことができます。

導入されたバージョン:
version 3.2
関連項目:
ReportLevel

フィールドの概要
protected  int datumpoint
推奨されていません。 このリポーターがフィルタリングする基準レベル値
クラス jp.co.intra_mart.foundation.utility.report.FilterMessageReporter から継承したフィールド
out
インタフェース jp.co.intra_mart.foundation.utility.report.ReportLevel から継承したフィールド
MAX_VALUE, MIN_VALUE, TYPE_DEBUG, TYPE_ERROR, TYPE_REPORT, TYPE_WARNING
コンストラクタの概要
ReportLevelFilter(MessageReporter out, int level)
推奨されていません。 指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。
メソッドの概要
void | report(Object data) 推奨されていません。 data をメッセージとして出力します。
void | report(Object data, int level) 推奨されていません。 指定のメッセージレベルが基準値以上のメッセージを出力します。
void | report(String message) 推奨されていません。 メッセージを出力します。
void | report(String message, int level) 推奨されていません。 指定のメッセージレベルが基準値以上のメッセージを出力します。
クラス jp.co.intra_mart.foundation.utility.report.FilterMessageReporter から継承したメソッド
close, flush
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

datumpoint

protected int datumpoint
推奨されていません。
このリポーターがフィルタリングする基準レベル値

コンストラクタの詳細

ReportLevelFilter

public ReportLevelFilter(MessageReporter out,
                         int level)
推奨されていません。
指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。

パラメータ:
out - 基礎出力リポーター
メソッドの詳細

report

public void report(String message)
推奨されていません。
メッセージを出力します。
このメソッドは、以下の呼出と同じです。

report(message, ReportLevel.MAX_VALUE)

つまり、メッセージ message は必ず基礎出力リポーターに出力されます。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(String message,
                   int level)
推奨されていません。
指定のメッセージレベルが基準値以上のメッセージを出力します。
メッセージレベルは以下の式で判定されます。

this.datumpoint <= level

判定式が true の場合、基礎出力リポーターに対して メッセージが出力されます。逆に判定結果が false の場合、 このメソッドは何も行いません。

パラメータ:
message - メッセージ
level - メッセージレベル

report

public void report(Object data)
推奨されていません。
data をメッセージとして出力します。
このメソッドは、以下の呼出と同じです。

report(data, ReportLevel.MAX_VALUE)

つまり、メッセージデータ data は必ず基礎出力リポーターに出力されます。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
data - データ

report

public void report(Object data,
                   int level)
推奨されていません。
指定のメッセージレベルが基準値以上のメッセージを出力します。
メッセージレベルは以下の式で判定されます。

this.datumpoint <= level

判定式が true の場合、基礎出力リポーターに対して メッセージが出力されます。逆に判定結果が false の場合、 このメソッドは何も行いません。

パラメータ:
data - データ
level - メッセージレベル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RepresentativeReporter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス RepresentativeReporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.FilterMessageReporter
        拡張 jp.co.intra_mart.foundation.utility.report.RepresentativeReporter
すべての実装インタフェース:
MessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter クラスを使用してください。

public class RepresentativeReporter
extends FilterMessageReporter

メッセージ出力をイベント処理するためのフィルタークラスです。

このクラスを利用することにより、メッセージの MessageReporter における 処理を現在のスレッドと並列実行させることができます。 これにより、このクラスの report メソッドと、出力先となる MessageReporter の report メソッドの実行は非同期に処理されます。

このクラスを利用することのメリットは、メッセージの出力処理を 待たなくても、現在のスレッドの実行を継続できることにあります。 逆に、このクラスを利用することにより、メッセージ出力処理と現在のスレッド処理 がスレッドセーフであることが保証されなければなりません。
report メソッドで指定されたメッセージはキューに蓄積され、 現在のスレッドと異なるメッセージ処理専用のスレッドで 基礎出力ストリームに渡されます。 メッセージの出力処理は、現在のスレッドと非同期ですが、 report メソッドの実行順とメッセージの出力順は保証されます。

導入されたバージョン:
version 3.2

フィールドの概要
クラス jp.co.intra_mart.foundation.utility.report.FilterMessageReporter から継承したフィールド
out
コンストラクタの概要
RepresentativeReporter(MessageReporter out, EventQueueController queue)
推奨されていません。 指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。
メソッドの概要
boolean | canReport() 推奨されていません。 このストリームが書き込み可能かどうかをチェックします。
void | close() 推奨されていません。 ストリームを閉じます。
void | flush() 推奨されていません。 ストリームをフラッシュします。
void | report(Object data) 推奨されていません。 data をメッセージとして出力します。
void | report(String message) 推奨されていません。 メッセージを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RepresentativeReporter

public RepresentativeReporter(MessageReporter out,
                              EventQueueController queue)
推奨されていません。
指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。

パラメータ:
out - 基礎出力リポーター
メソッドの詳細

canReport

public boolean canReport()
推奨されていません。
このストリームが書き込み可能かどうかをチェックします。

戻り値:
ストリームの書き込みが可能な場合 true、そうでない場合 false。

report

public void report(String message)
推奨されていません。
メッセージを出力します。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
推奨されていません。
data をメッセージとして出力します。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
data - データ

close

public void close()
           throws IOException
推奨されていません。
ストリームを閉じます。
このメソッドは、ストリームを閉じる前に flush メソッドを実行します。 オブジェクトが閉じられると、report メソッドは何もしなくなります。

定義:
インタフェース MessageReporter 内の close
オーバーライド:
クラス FilterMessageReporter 内の close
例外:
IOException - 入出力エラーが発生した場合

flush

public void flush()
           throws IOException
推奨されていません。
ストリームをフラッシュします。

ストリームに蓄積されているすべてのメッセージイベントを処理します。 このメソッドを実行した場合、現在のスレッドで メッセージが処理されます。また、このメソッドはすべてのメッセージ出力 処理が完了するまでブロックします。

定義:
インタフェース MessageReporter 内の flush
オーバーライド:
クラス FilterMessageReporter 内の flush
例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AbstractDualComparator (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス AbstractDualComparator

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.AbstractDualComparator
すべての実装インタフェース:
Comparator, DualComparator, Serializable
直系の既知のサブクラス:
MultiComparator, NodeTypeComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator クラスを使用してください。

public abstract class AbstractDualComparator
extends Object
implements DualComparator

２つのコンパレータを使用してソートを行うクラスです。
比較の順番は、指定された第１コンパレータ、第２コンパレータの順に行われます。まず、第１コンパレータで比較を行います。 もし、その比較の結果が０の時は第２コンパレータで比較を行いその結果を返します。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
AbstractDualComparator()
推奨されていません。 新しいオブジェクトを生成します。
メソッドの概要
 int compare(Object arg0, Object arg1)
推奨されていません。 順序付けのために ２ つの引数を比較するメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.foundation.utility.DualComparator から継承したメソッド
getPrimaryComparator, getSecondaryComparator
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

AbstractDualComparator

public AbstractDualComparator()
推奨されていません。
新しいオブジェクトを生成します。

メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
推奨されていません。
順序付けのために ２ つの引数を比較するメソッドです。
最初の引数が ２ 番目の引数より小さ い場合は負の整数、両方が等しい場合は ０、最初の引数が ２ 番目の引 数より大きい場合は正の整数を返します。
このメソッドは ２ つのコンパレータを使用して比較を行いその結果を返します。 比較の順番は、指定された第１コンパレータ、第２コンパレータの順に行われます。まず、第１コンパレータで比較を行います。 比較の結果が０でないときは、その比較した結果を返します。もし比較の結果が０の時は第２コンパレータで比較を行いその結果を返します。

定義:
インタフェース Comparator 内の compare
パラメータ:
arg0 - 引数１
arg1 - 引数２
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Counter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス Counter

java.lang.Object
    拡張 java.lang.Number
        拡張 jp.co.intra_mart.foundation.utility.Counter
すべての実装インタフェース:
Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.Counter クラスを使用してください。

public class Counter
extends Number
implements Serializable

このクラスは、カウンター機能を提供します。

ある数値を基準として１ずつ増やしたり１ずつ減らしたりすることができます。

導入されたバージョン:
version4.2
関連項目:
直列化された形式

コンストラクタの概要
Counter()
推奨されていません。 カウンターオブジェクトを作成します。
Counter(long initValue)
推奨されていません。 指定の初期値でカウンターオブジェクトを作成します。
メソッドの概要
long | decrement() 推奨されていません。 カウンターの値を１だけ減少させます。
double | doubleValue() 推奨されていません。 カウンターの現在の値を double 型として返します。
float | floatValue() 推奨されていません。 カウンターの現在の値を float 型として返します。
long | increment() 推奨されていません。 カウンターの値を１だけ増加させます。
int | intValue() 推奨されていません。 カウンターの現在の値を int 型として返します。
long | longValue() 推奨されていません。 カウンターの現在の値を long 型として返します。
クラス java.lang.Number から継承したメソッド
byteValue, shortValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Counter

public Counter()
推奨されていません。
カウンターオブジェクトを作成します。

初期値は０です。したがって、このコンストラクタの呼び出しは、 以下の呼び出しと同義です。
new Counter(0)

Counter

public Counter(long initValue)
推奨されていません。
指定の初期値でカウンターオブジェクトを作成します。

パラメータ:
initValue - カウンターの初期値
メソッドの詳細

increment

public long increment()
推奨されていません。
カウンターの値を１だけ増加させます。

戻り値:
変化後のカウンターの値

decrement

public long decrement()
推奨されていません。
カウンターの値を１だけ減少させます。

戻り値:
変化後のカウンターの値

intValue

public int intValue()
推奨されていません。
カウンターの現在の値を int 型として返します。 値を丸めたり切り捨てたりすることもあります。

戻り値:
このオブジェクトが表す数値を int 型に変換した値;

longValue

public long longValue()
推奨されていません。
カウンターの現在の値を long 型として返します。

戻り値:
このオブジェクトが表す数値を long 型に変換した値

floatValue

public float floatValue()
推奨されていません。
カウンターの現在の値を float 型として返します。 値を丸めることもあります。

戻り値:
このオブジェクトが表す数値を float 型に変換した値

doubleValue

public double doubleValue()
推奨されていません。
カウンターの現在の値を double 型として返します。 値を丸めることもあります。

戻り値:
このオブジェクトが表す数値を double 型に変換した値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DualComparator (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
インタフェース DualComparator

すべてのスーパーインタフェース:
Comparator, Serializable
既知の実装クラスの一覧:
AbstractDualComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.DualComparator クラスを使用してください。

public interface DualComparator
extends Serializable, Comparator

２つのコンパレータを使用してソートを行うためのインターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
Comparator | getPrimaryComparator() 推奨されていません。 １番目コンパレータを取得します。
Comparator | getSecondaryComparator() 推奨されていません。 ２番目コンパレータを取得します。
インタフェース java.util.Comparator から継承したメソッド
compare, equals

メソッドの詳細

getPrimaryComparator

public Comparator getPrimaryComparator()
推奨されていません。
１番目コンパレータを取得します。

戻り値:
１番目のコンパレータ

getSecondaryComparator

public Comparator getSecondaryComparator()
推奨されていません。
２番目コンパレータを取得します。

戻り値:
２番目のコンパレータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ErrorEvent (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス ErrorEvent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.ErrorEvent
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEvent クラスを使用してください。

public class ErrorEvent
extends Object

例外をイベントとして扱うためのプロトコルです。

イベントリスナー(インターフェース ErrorEventListener を実装したクラス) のオーナーオブジェクトは、例外の発生時にこのクラスのインスタンスを 生成して各リスナーに通知する義務があります。

関連項目:
ErrorEventListener

コンストラクタの概要
ErrorEvent(Throwable t, Object obj)
推奨されていません。 エラーを通知するためのイベントを構築します。
ErrorEvent(Throwable t, String msg, Object obj)
推奨されていません。 エラーを通知するためのイベントを構築します。
メソッドの概要
Throwable | getException() 推奨されていません。 通知されたエラーまたは例外を取得します。
String | getMessage() 推奨されていません。 通知されたエラーメッセージを取得します。
Object | getObject() 推奨されていません。 通知されたエラー発生オブジェクトを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ErrorEvent

public ErrorEvent(Throwable t,
                  Object obj)
推奨されていません。
エラーを通知するためのイベントを構築します。

obj パラメータはエラーの発生したクラスまたはインスタンスです。

パラメータ:
t - 発生した例外
obj - エラーの発生したオブジェクト

ErrorEvent

public ErrorEvent(Throwable t,
                  String msg,
                  Object obj)
推奨されていません。
エラーを通知するためのイベントを構築します。

obj パラメータはエラーの発生したクラスまたはインスタンスです。

パラメータ:
t - 発生した例外
msg - エラーメッセージ
obj - エラーの発生したオブジェクト
メソッドの詳細

getObject

public Object getObject()
推奨されていません。
通知されたエラー発生オブジェクトを取得します。

戻り値:
通知されたエラーオブジェクト

getMessage

public String getMessage()
推奨されていません。
通知されたエラーメッセージを取得します。 メッセージが通知されていない場合、通知されたエラーのメッセージを 返します。

戻り値:
通知されたエラーメッセージ
関連項目:
Throwable.getMessage()

getException

public Throwable getException()
推奨されていません。
通知されたエラーまたは例外を取得します。

戻り値:
通知されたエラーまたは例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ErrorEventListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
インタフェース ErrorEventListener

推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener クラスを使用してください。

public interface ErrorEventListener

例外をイベントとして扱うためのスケルトン実装を提供します。

このインターフェースを実装したクラスのインスタンスは例外の発生に伴い その例外をイベントとして受け取ることができます。 このインターフェースを実装しているクラスから生成されたインスタンスの オーナーオブジェクトは、 例外発生をイベントとしてインスタンスに対して通知する義務があります。

メソッドの概要
 void reportError(ErrorEvent err)
推奨されていません。 発生した例外を通知します。

メソッドの詳細

reportError

public void reportError(ErrorEvent err)
推奨されていません。
発生した例外を通知します。

パラメータ:
err - 発生したエラーイベント
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
インタフェース EventListener

推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventListener クラスを使用してください。

public interface EventListener

このクラスは、イベントリスナーのインターフェースです。

イベントコントローラと組み合わせて使うことにより、 様々なイベント機能を実装することができます。

導入されたバージョン:
version 3.2
関連項目:
EventQueueController

メソッドの概要
 void handleEvent()
推奨されていません。 イベントが発生した時にコントローラから呼び出されます。

メソッドの詳細

handleEvent

public void handleEvent()
推奨されていません。
イベントが発生した時にコントローラから呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventQueueController (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス EventQueueController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.EventQueueController
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventQueueController クラスを使用してください。

public class EventQueueController
extends Object

このクラスは、イベントリスナーを実行するイベント機能を実装します。

イベントコントローラは、指定された時間間隔に従ってリスナー登録状況を確認し、 リスナーの登録が１つ以上あった場合、これらを専用スレッドで実行します。 このとき、イベントリスナーの実行順と実行の直列化が保証されます。
これらの機能により、通常の関数実行や java.lang.Thread クラスを利用した 並列処理などと異なった機能を実装することができます。

このクラスを利用することにより、現在の処理とイベント処理を並列化することが できます。また、一つのコントローラは同時に一つのイベントリスナーしか 実行しないため、それぞれのリスナーの処理が並列処理されることはありません。 従って、リスナーはマルチスレッドを意識したプログラムにする必要がありますが、 リスナー間でマルチスレッドを意識する必要はありません。

導入されたバージョン:
version 3.2
関連項目:
EventListener

コンストラクタの概要
EventQueueController()
推奨されていません。 イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
EventQueueController(long millis)
推奨されていません。 イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
メソッドの概要
void | destroy() 推奨されていません。 このイベントコントローラの破棄処理を行います。
void | entry(EventListener listener) 推奨されていません。 イベントリスナーの登録。
void | eventGenerating() 推奨されていません。 キューに登録されているイベントリスナーを一つ実行します。
protected void | finalize() 推奨されていません。 このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
void | flush() 推奨されていません。 キューに溜まっているすべてのイベントリスナーを実行します。
boolean | isAlive() 推奨されていません。 このイベントコントローラが有効かどうかチェックします。
void | setCapacity(int max) 推奨されていません。 キューの容量を変更します。
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventQueueController

public EventQueueController()
推奨されていません。
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。 コントローラがリスナー登録状況を監視する時間間隔はデフォルト値(60秒)が 適用されます。

EventQueueController

public EventQueueController(long millis)
                     throws IllegalArgumentException
推奨されていません。
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。 millis は、リスナーの登録状況を監視する時間間隔です。 コントローラは、リスナーが一つも登録されていない状態になると、 millis ミリ秒間隔でリスナー登録の有無を確認します。

パラメータ:
millis - イベントの監視間隔(ミリ秒)
例外:
IllegalArgumentException - millis が 0 以下の場合
メソッドの詳細

setCapacity

public void setCapacity(int max)
                 throws IllegalStateException,
                        IllegalArgumentException
推奨されていません。
キューの容量を変更します。

パラメータ:
max - イベントをプールできる最大量
例外:
IllegalStateException - max 個以上のリスナーが登録されている場合
IllegalArgumentException - max が 0 以下の場合

entry

public void entry(EventListener listener)
           throws NullPointerException,
                  IndexOutOfBoundsException,
                  IllegalStateException
推奨されていません。
イベントリスナーの登録。
イベントリスナーは、一旦キューに溜められます。 キューに保管されたリスナーは、 このコントローラにより現在実行中のスレッドとは 別のスレッドで登録順に呼び出されます。

実行されたリスナーは、処理が終了すると破棄されます。

通常のスレッドクラスを利用した並列処理との違いは、 イベントリスナーが登録順に実行される点と、 イベントリスナーの実行が直列化される点にあります。

パラメータ:
listener - イベントリスナー
例外:
NullPointerException - listener が null の場合
IndexOutOfBoundsException - キューが飽和状態の場合
IllegalStateException - コントローラが破棄処理済の場合

isAlive

public boolean isAlive()
推奨されていません。
このイベントコントローラが有効かどうかチェックします。

戻り値:
イベントコントローラが有効な場合は true、すでに破棄処理済の場合は false。

destroy

public void destroy()
推奨されていません。
このイベントコントローラの破棄処理を行います。 破棄処理を行うと、それ以上リスナーを登録することができなくなります。

このメソッドによる破棄処理と、登録済みリスナーの実行は非同期に 行われます。そのため、このメソッドがリターンしても 実行されないリスナーが残ることがあります。
すでに登録済みのリスナーの実行は破棄処理後も保証されます (登録済みのリスナーは非同期にすべて実行されます)。

flush

public void flush()
推奨されていません。
キューに溜まっているすべてのイベントリスナーを実行します。

このメソッドは、現在実行中のスレッドで すべてのイベント処理を行います。

eventGenerating

public void eventGenerating()
                     throws NoSuchElementException
推奨されていません。
キューに登録されているイベントリスナーを一つ実行します。 実行されるリスナーは、現在キューに保管されているリスナーの中で 最も過去に登録されたリスナーです。 このメソッドは、現在実行中のスレッドで 登録順で最も過去のイベントを１つ実行します。

例外:
NoSuchElementException - 登録リスナーがない場合

finalize

protected void finalize()
                 throws Throwable
推奨されていません。
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
このオブジェクトの全てのリソースを破棄します。

例外:
Throwable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedThread (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス ExtendedThread

java.lang.Object
    拡張 java.lang.Thread
        拡張 jp.co.intra_mart.foundation.utility.ExtendedThread
すべての実装インタフェース:
Runnable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread クラスを使用してください。

public class ExtendedThread
extends Thread

フィールドの概要
クラス java.lang.Thread から継承したフィールド
MAX_PRIORITY, MIN_PRIORITY, NORM_PRIORITY
コンストラクタの概要
ExtendedThread()
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(Runnable target)
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(Runnable target, String name)
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(String name)
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(ThreadGroup group, Runnable target)
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(ThreadGroup group, Runnable target, String name)
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(ThreadGroup group, String name)
推奨されていません。 Constructor for ExtendedThread.
メソッドの概要
void | addThreadStopListener(ThreadStopListener listener) 推奨されていません。 このスレッドが終了したときに呼び出されるイベントリスナーを登録します。
void | fire() 推奨されていません。 スレッド実行されるロジック。
void | run() 推奨されていません。 このオブジェクトのスレッド実行ロジックです。
クラス java.lang.Thread から継承したメソッド
activeCount, checkAccess, countStackFrames, currentThread, destroy, dumpStack, enumerate, getContextClassLoader, getName, getPriority, getThreadGroup, holdsLock, interrupt, interrupted, isAlive, isDaemon, isInterrupted, join, join, join, resume, setContextClassLoader, setDaemon, setName, setPriority, sleep, sleep, start, stop, stop, suspend, toString, yield
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtendedThread

public ExtendedThread()
推奨されていません。
Constructor for ExtendedThread.

ExtendedThread

public ExtendedThread(Runnable target)
推奨されていません。
Constructor for ExtendedThread.

パラメータ:
target -

ExtendedThread

public ExtendedThread(ThreadGroup group,
                      Runnable target)
推奨されていません。
Constructor for ExtendedThread.

パラメータ:
group -
target -

ExtendedThread

public ExtendedThread(String name)
推奨されていません。
Constructor for ExtendedThread.

パラメータ:
name -

ExtendedThread

public ExtendedThread(ThreadGroup group,
                      String name)
推奨されていません。
Constructor for ExtendedThread.

パラメータ:
group -
name -

ExtendedThread

public ExtendedThread(Runnable target,
                      String name)
推奨されていません。
Constructor for ExtendedThread.

パラメータ:
target -
name -

ExtendedThread

public ExtendedThread(ThreadGroup group,
                      Runnable target,
                      String name)
推奨されていません。
Constructor for ExtendedThread.

パラメータ:
group -
target -
name -
メソッドの詳細

run

public final void run()
推奨されていません。
このオブジェクトのスレッド実行ロジックです。 このメソッドをサブクラスがオーバーライドすることはできません。 サブクラスがスレッド実行ロジックを定義するためには、fireメソッドを オーバーライドしてください。

fire

public void fire()
推奨されていません。
スレッド実行されるロジック。 Thread クラスを継承したサブクラスにおいて、通常 run メソッドに 記述する内容をこのメソッドに定義してください。

addThreadStopListener

public void addThreadStopListener(ThreadStopListener listener)
推奨されていません。
このスレッドが終了したときに呼び出されるイベントリスナーを登録します。

パラメータ:
listener - スレッド終了イベントリスナー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FilterComparator (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス FilterComparator

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.FilterComparator
すべての実装インタフェース:
Comparator, Serializable
直系の既知のサブクラス:
ReverseComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator クラスを使用してください。

public abstract class FilterComparator
extends Object
implements Comparator, Serializable

コンパレータのフィルターとして機能する抽象クラスです。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
FilterComparator(Comparator comparator)
推奨されていません。 指定されれたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
メソッドの概要
int | compare(Object arg0, Object arg1) 推奨されていません。 順序付けのために 2 つの引数を比較するメソッドです。
Comparator | getParentComparator() 推奨されていません。 フィルター対象のコンパレータを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

FilterComparator

public FilterComparator(Comparator comparator)
推奨されていません。
指定されれたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。

パラメータ:
comparator - フィルター対象のコンパレータ
メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
推奨されていません。
順序付けのために 2 つの引数を比較するメソッドです。
最初の引数が 2 番目の引数より小さ い場合は負の整数、両方が等しい場合は 0、最初の引数が 2 番目の引 数より大きい場合は正の整数を返します。

定義:
インタフェース Comparator 内の compare
パラメータ:
arg0 - 引数１
arg1 - 引数２
戻り値:
比較した結果

getParentComparator

public Comparator getParentComparator()
推奨されていません。
フィルター対象のコンパレータを返します。

戻り値:
フィルター対象のコンパレータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FixedSizeMap (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス FixedSizeMap

java.lang.Object
    拡張 java.util.AbstractMap
        拡張 jp.co.intra_mart.foundation.utility.FixedSizeMap
すべての実装インタフェース:
Map
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap クラスを使用してください。

public class FixedSizeMap
extends AbstractMap

LRU(Least Recently Used) アルゴリズムによる Map インターフェースの実装を提供します。

このクラスのマップは、決められたサイズの領域持ちます。 キーはコンストラクタで指定された マップのサイズに等しい個数しか、このマップに関連付けることはできません。 すでにマップのサイズに等しい個数のキーが関連付けられている状態で、 別の新しいキーを関連付けようとした場合、LRU アルゴリズムに従い 最も古くに使われたキーが削除され、全体のキー数がマップのサイズに 等しくなるように調整されます。
このオブジェクトは、Thread safe となっています。
このマップは LRU アルゴリズムにより動作するため、 マッピングの追加や更新をしたり、キーにマッピングされている値の取得を した時に、キーのアクセス順をチェックします。 したがって、マップのサイズが大きさに比例して put() や get() メソッドの レスポンス時間が長くなります。 このハッシュテーブルは、適度な大きさで利用することを推奨します。

導入されたバージョン:
Version 3.2
関連項目:
Hashtable

入れ子クラスの概要
クラス java.util.Map から継承した入れ子クラス
Map.Entry
コンストラクタの概要
FixedSizeMap(int size)
推奨されていません。 指定されたサイズの領域を持つマップを構築します。
メソッドの概要
int | capacity() 推奨されていません。 このマップに対してマップできるキーの最大個数を返します。
void | clear() 推奨されていません。 マップからマッピングをすべて削除します。
boolean | containsKey(Object key) 推奨されていません。 指定されたキーへのマッピングをこのマップが格納する場合に true を返します。
Set | entrySet() 推奨されていません。 このマップに格納されているマッピングのセットビューを返します。
Object | get(Object key) 推奨されていません。 マップが、指定されたキーにマッピングしている値を返します。
Object | put(Object key, Object value) 推奨されていません。 指定された値を、マップ内の指定されたキーに関連付けます 。
Object | remove(Object key) 推奨されていません。 このキーにマッピングがある場合に、そのマッピングをマップから削除します。
クラス java.util.AbstractMap から継承したメソッド
clone, containsValue, equals, hashCode, isEmpty, keySet, putAll, size, toString, values
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

FixedSizeMap

public FixedSizeMap(int size)
             throws IllegalArgumentException
推奨されていません。
指定されたサイズの領域を持つマップを構築します。

パラメータ:
size - ハッシュテーブルの容量
例外:
IllegalArgumentException - 容量が 1 より小さい場合
メソッドの詳細

capacity

public int capacity()
推奨されていません。
このマップに対してマップできるキーの最大個数を返します。 このメソッドの返す値は、コンストラクタで指定されたハッシュテーブルの 容量値をそのまま返すものです。

戻り値:
このマップにエントリできるキーの最大個数

clear

public void clear()
推奨されていません。
マップからマッピングをすべて削除します。

containsKey

public boolean containsKey(Object key)
推奨されていません。
指定されたキーへのマッピングをこのマップが格納する場合に true を返します。

パラメータ:
key - このマップにあるかどうかを判定するキー
戻り値:
指定されたキーへのマッピングをこのマップが含む場合は true

entrySet

public Set entrySet()
推奨されていません。
このマップに格納されているマッピングのセットビューを返します。 このセットの各要素は Map.Entry です。セットはこのマップを 基にしているので、マップへの変更、およびセットへの変更は、 互いに反映されます。 セットでの繰り返し処理が進行中にマップが変更された場合、 反復の結果は保証されません。セットは要素の削除をサポートしており、 対応するエントリをマップから削除することができます。 削除には、Iterator.remove、Set.remove、removeAll、retainAll、 および clear オペレーションが使えます。 add または addAll オペレーションはサポートされません。

戻り値:
このマップに格納されているマッピングのセットビュー

get

public Object get(Object key)
推奨されていません。
マップが、指定されたキーにマッピングしている値を返します。 マップに、このキーに対するマッピングがない場合は null を返します。

パラメータ:
key - 関連付けられている値が返されるキー
戻り値:
マップが、指定されたキーにマッピングしている値。このキーに対するマッピングがマップにない場合は null
関連項目:
containsKey(Object)

put

public Object put(Object key,
                  Object value)
推奨されていません。
指定された値を、マップ内の指定されたキーに関連付けます 。 マップにすでにこのキーに対するマッピングがある場合、 古い値は置き換えられます。

パラメータ:
key - 指定された値が関連付けられるキー
value - 指定されたキーに関連付けられる値
戻り値:
指定されたキーに関連付けられていた以前の値。key にマッピングがなかった場合は null。
例外:
NullPointerException - キーまたは値が null の場合

remove

public Object remove(Object key)
推奨されていません。
このキーにマッピングがある場合に、そのマッピングをマップから削除します。

パラメータ:
key - マッピングがマップから削除されるキー
戻り値:
指定されたキーに関連付けられていた以前の値。key にマッピングがなかった場合は null。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LockMonitor (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス LockMonitor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.LockMonitor
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.LockMonitor クラスを使用してください。

public class LockMonitor
extends Object

このクラスはモニター機能を提供します。
このクラスでは、複数個のモニターを管理することができます。 アプリケーションでは、entry() メソッドによりモニターを取得し、 release() メソッドでモニターを開放します。

コンストラクタの概要
LockMonitor(int max)
推奨されていません。 モニターを構築します。
メソッドの概要
int | activeCount() 推奨されていません。 現在取得済みモニターの数を取得します。
void | entry() 推奨されていません。 モニターの取得。
int | queue() 推奨されていません。 モニターを取得するための待ち行列に入っているスレッドの数です。
void | release() 推奨されていません。 モニターの開放。
int | size() 推奨されていません。 このオブジェクトの管理するモニターの数を取得します。
int | total() 推奨されていません。 モニターを利用中、または利用しようとしているスレッドの数です。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LockMonitor

public LockMonitor(int max)
推奨されていません。
モニターを構築します。

パラメータ:
max - 管理するモニターの個数
メソッドの詳細

entry

public void entry()
推奨されていません。
モニターの取得。

モニターを取得できるまでブロックします。 モニターの取得＝動作の権利を取得

size

public int size()
推奨されていません。
このオブジェクトの管理するモニターの数を取得します。

戻り値:
モニターの数

activeCount

public int activeCount()
推奨されていません。
現在取得済みモニターの数を取得します。

戻り値:
取得済みモニターの数

total

public int total()
推奨されていません。
モニターを利用中、または利用しようとしているスレッドの数です。

戻り値:
entry() メソッドを実行して release() メソッドを実行していないスレッドの数
導入されたバージョン:
version 4.2

queue

public int queue()
推奨されていません。
モニターを取得するための待ち行列に入っているスレッドの数です。

戻り値:
entry() メソッドを実行して、ブロック状態になっているスレッドの数
導入されたバージョン:
version 4.2

release

public void release()
推奨されていません。
モニターの開放。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MultiComparator (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス MultiComparator

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.AbstractDualComparator
        拡張 jp.co.intra_mart.foundation.utility.MultiComparator
すべての実装インタフェース:
Comparator, DualComparator, Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator クラスを使用してください。

public class MultiComparator
extends AbstractDualComparator

複数のコンパレータを使用してソートを行うためにクラスです。
実行したコンパレータの compare() メソッドの戻り値が０でなくなるか、全てのコンパレータの実行が完了するまで下記の順番でコンパレータの実行が行われます。

・コンストラクタで指定された第１コンパレータ
・コンストラクタで指定された第２コンパレータ
・addComparator()で追加されたコンパレータ

このクラスは同じインスタンスのコンパレータを２つ以上持つことを想定されていません。 そのような操作を行うと、正しい結果が得られない可能性があります。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
MultiComparator(Comparator primaryComparator, Comparator secondaryComparator)
推奨されていません。 第１コンパレータ 、第２コンパレータを指定して、新しいオブジェクトを生成します。
メソッドの概要
void | addComparator(Comparator comparator) 推奨されていません。 指定されたコンパレータ comparator を追加します。
Collection | getComparators() 推奨されていません。 設定されている全てのコンパレータを取得します。
Comparator | getPrimaryComparator() 推奨されていません。 第１コンパレータを返します。
Comparator | getSecondaryComparator() 推奨されていません。 第２コンパレータを返します。
boolean | removeComparator(Comparator comparator) 推奨されていません。 指定されたコンパレータ comparatorを削除します。
クラス jp.co.intra_mart.foundation.utility.AbstractDualComparator から継承したメソッド
compare
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

MultiComparator

public MultiComparator(Comparator primaryComparator,
                       Comparator secondaryComparator)
                throws NullPointerException
推奨されていません。
第１コンパレータ 、第２コンパレータを指定して、新しいオブジェクトを生成します。
もし primaryComparator がnullで、 secondaryComparator がnullでない時は、secondaryComparator が第１コンパレータとして扱われます。
primaryComparator 、secondaryComparator がともにnullの時は例外を発生させます。

パラメータ:
primaryComparator - 第１コンパレータ
secondaryComparator - 第２コンパレータ
例外:
NullPointerException - primaryComparator 、 secondaryComparator がともにnullの時発生します。
メソッドの詳細

getPrimaryComparator

public Comparator getPrimaryComparator()
推奨されていません。
第１コンパレータを返します。

戻り値:
第１コンパレータ

getSecondaryComparator

public Comparator getSecondaryComparator()
推奨されていません。
第２コンパレータを返します。 このメソッドの戻り値は、設定された第２コンパレータをラップしたMultiComparatorのオブジェクトになります。 もし、第２コンパレータが設定されていないときはnullを返します。

戻り値:
第２コンパレータ

addComparator

public void addComparator(Comparator comparator)
                   throws NullPointerException
推奨されていません。
指定されたコンパレータ comparator を追加します。 指定されたコンパレータ comparatorがnullの時は例外を発生させます。

パラメータ:
comparator - コンパレータ
例外:
NullPointerException - 指定されたcomparatorがnullの時に発生します。

removeComparator

public boolean removeComparator(Comparator comparator)
                         throws IllegalArgumentException
推奨されていません。
指定されたコンパレータ comparatorを削除します。 指定されたコンパレータの削除に成功したときはtrue、失敗したときはfalseを返します。 このクラスのオブジェクトが持つ全てのコンパレータを削除しようとすると例外が発生します。

パラメータ:
comparator - 削除対象のコンパレータ
戻り値:
削除に成功したときはtrue、失敗したときはfalseを返す。
例外:
IllegalArgumentException - 全てのコンパレータを削除しようとした時に発生します。

getComparators

public Collection getComparators()
推奨されていません。
設定されている全てのコンパレータを取得します。

戻り値:
設定されている全てのコンパレータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MultipurposeInternetMailExtensions (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス MultipurposeInternetMailExtensions

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions クラスを使用してください。

public class MultipurposeInternetMailExtensions
extends Object

MIME タイプを持つオブジェクトです。

コンストラクタの概要
MultipurposeInternetMailExtensions(File path)
推奨されていません。 MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(String filename)
推奨されていません。 MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(String mediaType, String subType)
推奨されていません。 指定のMIMEタイプを表すオブジェクトを構築します。
メソッドの概要
String | getMediaType() 推奨されていません。 このオブジェクトが表す MIME タイプの Media Type を返します。
String | getSubType() 推奨されていません。 このオブジェクトが表す MIME タイプの subtype を返します。
String | getType() 推奨されていません。 このオブジェクトが表す MIME タイプを返します。
String | toString() 推奨されていません。 このオブジェクトの文字列表現を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MultipurposeInternetMailExtensions

public MultipurposeInternetMailExtensions(String filename)
推奨されていません。
MIMEタイプを表すオブジェクトを構築します。

MIME タイプは引数 filename の拡張子により解決されます。
引数 filename に拡張子がない場合や、拡張子から MIME タイプを解決 出来なかった場合には、オブジェクトの表す MIME タイプは application/octet-stream となります。

パラメータ:
filename - ファイル名

MultipurposeInternetMailExtensions

public MultipurposeInternetMailExtensions(File path)
推奨されていません。
MIMEタイプを表すオブジェクトを構築します。

MIME タイプは引数 path の表すファイル名の拡張子により解決されます。
引数 path の表すファイル名に拡張子がない場合や、拡張子から MIME タイプを 解決出来なかった場合には、オブジェクトの表す MIME タイプは application/octet-stream となります。

パラメータ:
path - ファイル名を表す File クラスのインスタンス

MultipurposeInternetMailExtensions

public MultipurposeInternetMailExtensions(String mediaType,
                                          String subType)
推奨されていません。
指定のMIMEタイプを表すオブジェクトを構築します。

このコンストラクタにより構築されたオブジェクトの表す MIME タイプは、 mediaType "/" subType となります。

パラメータ:
mediaType - メディアタイプを表すキーワード
subType - サブタイプを表すキーワード
メソッドの詳細

getMediaType

public String getMediaType()
推奨されていません。
このオブジェクトが表す MIME タイプの Media Type を返します。

戻り値:
Media Type を表す文字列

getSubType

public String getSubType()
推奨されていません。
このオブジェクトが表す MIME タイプの subtype を返します。

戻り値:
subtype を表す文字列

getType

public String getType()
推奨されていません。
このオブジェクトが表す MIME タイプを返します。

戻り値:
MIME タイプを表す文字列

toString

public String toString()
推奨されていません。
このオブジェクトの文字列表現を返します。

戻り値:
MIME タイプを表す文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.utility (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.utility
インタフェース
DualComparator
ErrorEventListener
EventListener
ThreadStopListener
クラス
AbstractDualComparator
Counter
ErrorEvent
EventQueueController
ExtendedThread
FilterComparator
FixedSizeMap
LockMonitor
MultiComparator
MultipurposeInternetMailExtensions
ResourceBundleProperties
ReverseComparator
SequenceComparator


jp.co.intra_mart.foundation.utility (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility

このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

参照:
説明

インタフェースの概要
DualComparator | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.DualComparator クラスを使用してください。
ErrorEventListener | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener クラスを使用してください。
EventListener | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventListener クラスを使用してください。
ThreadStopListener | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener クラスを使用してください。

クラスの概要
AbstractDualComparator | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator クラスを使用してください。
Counter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.Counter クラスを使用してください。
ErrorEvent | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEvent クラスを使用してください。
EventQueueController | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventQueueController クラスを使用してください。
ExtendedThread | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread クラスを使用してください。
FilterComparator | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator クラスを使用してください。
FixedSizeMap | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap クラスを使用してください。
LockMonitor | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.LockMonitor クラスを使用してください。
MultiComparator | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator クラスを使用してください。
MultipurposeInternetMailExtensions | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions クラスを使用してください。
ResourceBundleProperties | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties クラスを使用してください。
ReverseComparator | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator クラスを使用してください。
SequenceComparator | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator クラスを使用してください。

パッケージ jp.co.intra_mart.foundation.utility の説明

このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。


jp.co.intra_mart.foundation.utility クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.utility.AbstractDualComparator (implements jp.co.intra_mart.foundation.utility.DualComparator)
      • class jp.co.intra_mart.foundation.utility.MultiComparator
    • class java.util.AbstractMap (implements java.util.Map)
      • class jp.co.intra_mart.foundation.utility.FixedSizeMap
    • class java.util.Dictionary
      • class java.util.Hashtable (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class java.util.Properties
          • class jp.co.intra_mart.foundation.utility.ResourceBundleProperties
    • class jp.co.intra_mart.foundation.utility.ErrorEvent
    • class jp.co.intra_mart.foundation.utility.EventQueueController
    • class jp.co.intra_mart.foundation.utility.FilterComparator (implements java.util.Comparator, java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.ReverseComparator
    • class jp.co.intra_mart.foundation.utility.LockMonitor
    • class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions
    • class java.lang.Number (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.Counter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.utility.SequenceComparator (implements java.util.Comparator, java.io.Serializable)
    • class java.lang.Thread (implements java.lang.Runnable)
      • class jp.co.intra_mart.foundation.utility.ExtendedThread

インタフェース階層

  • interface java.util.Comparator
    • interface jp.co.intra_mart.foundation.utility.DualComparator (同様に extends java.io.Serializable)
  • interface jp.co.intra_mart.foundation.utility.ErrorEventListener
  • interface jp.co.intra_mart.foundation.utility.EventListener
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.utility.DualComparator (同様に extends java.util.Comparator)
  • interface jp.co.intra_mart.foundation.utility.ThreadStopListener


パッケージ jp.co.intra_mart.foundation.utility の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.utility の使用

jp.co.intra_mart.foundation.utility を使用しているパッケージ
jp.co.intra_mart.foundation.http | ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.page | ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.utility | このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.io | このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.report | このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.http により使用される jp.co.intra_mart.foundation.utility のクラス
MultipurposeInternetMailExtensions
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions クラスを使用してください。

jp.co.intra_mart.foundation.page により使用される jp.co.intra_mart.foundation.utility のクラス
AbstractDualComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator クラスを使用してください。
DualComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.DualComparator クラスを使用してください。

jp.co.intra_mart.foundation.service.provider により使用される jp.co.intra_mart.foundation.utility のクラス
EventListener
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventListener クラスを使用してください。

jp.co.intra_mart.foundation.utility により使用される jp.co.intra_mart.foundation.utility のクラス
AbstractDualComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator クラスを使用してください。
DualComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.DualComparator クラスを使用してください。
ErrorEvent
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEvent クラスを使用してください。
EventListener
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventListener クラスを使用してください。
FilterComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator クラスを使用してください。
ThreadStopListener
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener クラスを使用してください。

jp.co.intra_mart.foundation.utility.io により使用される jp.co.intra_mart.foundation.utility のクラス
ErrorEventListener
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener クラスを使用してください。

jp.co.intra_mart.foundation.utility.report により使用される jp.co.intra_mart.foundation.utility のクラス
EventQueueController
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventQueueController クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ResourceBundleProperties (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス ResourceBundleProperties

java.lang.Object
    拡張 java.util.Dictionary
        拡張 java.util.Hashtable
            拡張 java.util.Properties
                拡張 jp.co.intra_mart.foundation.utility.ResourceBundleProperties
すべての実装インタフェース:
Cloneable, Map, Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties クラスを使用してください。

public class ResourceBundleProperties
extends Properties

このクラスは、java.util.Properties クラスのインターフェースを実装した、 プロパティ管理クラスです。プロパティデータは、java.util.ResourceBundle により取得されます。
ロードできるリソースに関しては、java.util.ResourceBundle の 説明を参照して下さい。
このクラスのコンストラクタが、java.util.ResourceBundle クラスの getBundle() メソッドと同様の機能を提供しています。 各コンストラクタは、引数の同じ getBundle() メソッドに対応しています。

導入されたバージョン:
version 4.0
関連項目:
Properties, ResourceBundle, 直列化された形式

フィールドの概要
クラス java.util.Properties から継承したフィールド
defaults
コンストラクタの概要
ResourceBundleProperties(String baseName)
推奨されていません。 リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String baseName, Locale locale)
推奨されていません。 リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String baseName, Locale locale, ClassLoader loader)
推奨されていません。 リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
メソッドの概要
 Locale getLocale()
推奨されていません。 ResourceBundle の Locale を返します。
クラス java.util.Properties から継承したメソッド
getProperty, getProperty, list, list, load, propertyNames, save, setProperty, store
クラス java.util.Hashtable から継承したメソッド
clear, clone, contains, containsKey, containsValue, elements, entrySet, equals, get, hashCode, isEmpty, keys, keySet, put, putAll, rehash, remove, size, toString, values
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ResourceBundleProperties

public ResourceBundleProperties(String baseName)
                         throws MissingResourceException
推奨されていません。
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。

パラメータ:
baseName - 目的のオブジェクトを含むリソースバンドルのファミリ名
例外:
MissingResourceException - リソースの照合に失敗した場合

ResourceBundleProperties

public ResourceBundleProperties(String baseName,
                                Locale locale)
                         throws MissingResourceException
推奨されていません。
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。

パラメータ:
baseName - 目的のオブジェクトを含むリソースバンドルのファミリ名
locale - 目的のロケール
例外:
MissingResourceException - リソースの照合に失敗した場合

ResourceBundleProperties

public ResourceBundleProperties(String baseName,
                                Locale locale,
                                ClassLoader loader)
                         throws MissingResourceException
推奨されていません。
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。

パラメータ:
baseName - 目的のオブジェクトを含むリソースバンドルのファミリ名
locale - 目的のロケール
loader - リソースをロードする ClassLoader
例外:
MissingResourceException - リソースの照合に失敗した場合
メソッドの詳細

getLocale

public Locale getLocale()
推奨されていません。
ResourceBundle の Locale を返します。
この関数は、このオブジェクトが本当に要求されたロケールに対応しているか、 またはフォールバックであるかを判定するために、このオブジェクトが 構築されたあとで使用できます。

この関数は、java.util.ResourceBundle クラスの getLocale() と 同じであり、java.util.ResourceBundle クラスとインターフェースを 合わせるために提供されています。 java.util.ResourceBundle クラスの getLocale() の説明を参照して下さい。

戻り値:
ロケール
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReverseComparator (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス ReverseComparator

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.FilterComparator
        拡張 jp.co.intra_mart.foundation.utility.ReverseComparator
すべての実装インタフェース:
Comparator, Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator クラスを使用してください。

public class ReverseComparator
extends FilterComparator

コンパレータのフィルタとして機能します。
フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
ReverseComparator(Comparator comparator)
推奨されていません。 指定されたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
メソッドの概要
 int compare(Object arg0, Object arg1)
推奨されていません。 フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。
クラス jp.co.intra_mart.foundation.utility.FilterComparator から継承したメソッド
getParentComparator
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

ReverseComparator

public ReverseComparator(Comparator comparator)
推奨されていません。
指定されたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。

パラメータ:
comparator - フィルター対象のコンパレータ
メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
推奨されていません。
フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。

定義:
インタフェース Comparator 内の compare
オーバーライド:
クラス FilterComparator 内の compare
パラメータ:
arg0 - 引数１
arg1 - 引数２
戻り値:
フィルタ対象のコンパレータの compare() メソッドの結果を反転させた値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SequenceComparator (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス SequenceComparator

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.SequenceComparator
すべての実装インタフェース:
Comparator, Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator クラスを使用してください。

public class SequenceComparator
extends Object
implements Comparator, Serializable

挿入順にソートするためのコンパレータです。
このコンパレータは挿入が早い物から遅い物の順に並べます。
このコンパレータは、挿入されたオブジェクトの順番をインスタンス変数として持っています。 そのため、複数のオブジェクトでこのコンパレータを共有使用すると正しく動作しない可能性があります。
またこのクラスは、java.lang.TreeSet、java.lang.TreeMapで使用されることを想定して作られています。 そのため、他のクラスのコンパレータとして使用すると正しく動作しない可能性があります。 クラスで管理できるオブジェクトの数は、２の３１乗-１までのみ管理できます。

導入されたバージョン:
version 4.3
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SequenceComparator()
推奨されていません。 新しいオブジェクトを生成します。
メソッドの概要
 int compare(Object arg0, Object arg1)
推奨されていません。 順序付けのために ２ つの引数を比較するメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

SequenceComparator

public SequenceComparator()
推奨されていません。
新しいオブジェクトを生成します。

メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
推奨されていません。
順序付けのために ２ つの引数を比較するメソッドです。
最初の引数が ２ 番目の引数より小さ い場合は負の整数、両方が等しい場合は 0、最初の引数が 2 番目の引 数より大きい場合は正の整数を返します。
このメソッドの目的は、挿入順にソートすることです。 引数１と引数２を比較したとき、引数１の方が挿入が遅いときは正の数、早い時は負の数を返します。
引数１と引数２が同じインスタンスの時は０を返します

定義:
インタフェース Comparator 内の compare
パラメータ:
arg0 - 引き数１
arg1 - 引き数２
戻り値:
比較した結果
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ThreadStopListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
インタフェース ThreadStopListener

推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener クラスを使用してください。

public interface ThreadStopListener

メソッドの概要
 void handleThreadStop()
推奨されていません。 監視していたスレッドが終了したときに実行されるメソッドです。

メソッドの詳細

handleThreadStop

public void handleThreadStop()
推奨されていません。
監視していたスレッドが終了したときに実行されるメソッドです。 このメソッドをサブクラスが実行することで、特定のスレッド終了時に プログラムを実行することができます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.jssp.net.GenericURLBuilder の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.jssp.net.GenericURLBuilder の使用

GenericURLBuilder を使用しているパッケージ
jp.co.intra_mart.jssp.net

jp.co.intra_mart.jssp.net での GenericURLBuilder の使用

jp.co.intra_mart.jssp.net での GenericURLBuilder のサブクラス
 class URLBuilder
スクリプト開発モデルの画面を呼び出すための URL を作成するビルダです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.jssp.net.URLBuilder の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.jssp.net.URLBuilder の使用

jp.co.intra_mart.jssp.net.URLBuilder はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


GenericURLBuilder (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.jssp.net
クラス GenericURLBuilder

java.lang.Object
    拡張 jp.co.intra_mart.jssp.net.GenericURLBuilder
直系の既知のサブクラス:
URLBuilder
public class GenericURLBuilder
extends Object

スクリプト開発モデルの画面を呼び出すための URL を作成するビルダです。

このクラスを利用する事により、 スクリプト開発モデルの画面へアクセスする URL を作成できます。 また、このクラスが生成する URL は、セッションチェック機能を持ったものに なるため、異なるセッションに対して生成された URL を用いてアクセスすると、 セッションエラーとなります。 つまり、このクラスが生成する URL は、セキュリティの強固なリンクとなります。

以下は「sample/example/string/main」を呼び出すためのURLを作成するサンプルコードです。

 HttpServletRequest request   = ... ;
 HttpServletResponse response = ... ;

 GenericURLBuilder urlBuilder = new GenericURLBuilder(request, response);
 URL urlContext = jp.co.intra_mart.common.aid.jsdk.utility.URLUtil.getContextURL(request);

 URL url = urlBuilder.createURL(urlContext, "sample/example/string/main");
 String urlString = url.toExternalForm();

 URL sessionURL = new URL(response.encodeURL(urlString));
 String pageURL = sessionURL.toExternalForm();

バージョン:
Version 5.0

コンストラクタの概要
GenericURLBuilder(HttpServletRequest request, HttpServletResponse response)
新しいビルダを作成します。
メソッドの概要
String | createFilePath(String path) 指定のページパスからリンクの為のページパスを作成して返します。
URL | createURL(String path) 現在のリクエストを元にして、指定の画面へリンクするための URL を作成します。
URL | createURL(URL context, String path) 指定の URL を仕様解析のコンテキストとして スクリプト開発モデルの画面への URL を解決した URL を返します。
protected HttpServletRequest | getRequest() 現在のリクエストを返します。
protected HttpServletResponse | getResponse() 現在のレスポンスを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericURLBuilder

public GenericURLBuilder(HttpServletRequest request,
                         HttpServletResponse response)
新しいビルダを作成します。

このオブジェクトでは、指定のリクエストおよびレスポンスにを利用して、 スクリプト開発モデルの画面へリンクするための情報を操作します。

パラメータ:
request - リクエスト
response - レスポンス
例外:
NullPointerException - 引数が null
メソッドの詳細

getRequest

protected HttpServletRequest getRequest()
現在のリクエストを返します。 返すリクエストは、コンストラクタの引数に渡されたリクエストです。

戻り値:
リクエスト

getResponse

protected HttpServletResponse getResponse()
現在のレスポンスを返します。 返すレスポンスは、コンストラクタの引数に渡されたレスポンスです。

戻り値:
レスポンス

createURL

public URL createURL(String path)
              throws MalformedURLException
現在のリクエストを元にして、指定の画面へリンクするための URL を作成します。

現在のリクエストを生成するのに使用した URL をコンテキストＵＲＬとして 絶対形式のＵＲＬを自動解決します。 コンテキストＵＲＬを任意に指定したい場合は、 createURL(URL context, String path)を利用してください。

パラメータ:
path - スクリプト開発モデルのプログラムパス
戻り値:
指定の画面へリンクするためのＵＲＬ
例外:
MalformedURLException - URL が無効な書式の場合

createURL

public URL createURL(URL context,
                     String path)
              throws MalformedURLException
指定の URL を仕様解析のコンテキストとして スクリプト開発モデルの画面への URL を解決した URL を返します。

このメソッドは、以下の動作と同じです。
new java.net.URL(context, this.createURL(path))

パラメータ:
context - 仕様を解析するコンテキスト
path - スクリプト開発モデルのプログラムパス
戻り値:
指定の画面へリンクするためのＵＲＬ
例外:
MalformedURLException - URL が無効な書式の場合

createFilePath

public String createFilePath(String path)
指定のページパスからリンクの為のページパスを作成して返します。

パラメータ:
path - スクリプト開発モデルの画面プログラムのパス
戻り値:
リンクの為のパス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.jssp.net (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.jssp.net
クラス
GenericURLBuilder
URLBuilder


jp.co.intra_mart.jssp.net (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.jssp.net

クラスの概要
GenericURLBuilder | スクリプト開発モデルの画面を呼び出すための URL を作成するビルダです。
URLBuilder | スクリプト開発モデルの画面を呼び出すための URL を作成するビルダです。


jp.co.intra_mart.jssp.net クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.jssp.net の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.jssp.net.GenericURLBuilder
      • class jp.co.intra_mart.jssp.net.URLBuilder


パッケージ jp.co.intra_mart.jssp.net の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.jssp.net の使用

jp.co.intra_mart.jssp.net を使用しているパッケージ
jp.co.intra_mart.jssp.net

jp.co.intra_mart.jssp.net により使用される jp.co.intra_mart.jssp.net のクラス
GenericURLBuilder
スクリプト開発モデルの画面を呼び出すための URL を作成するビルダです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


URLBuilder (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.jssp.net
クラス URLBuilder

java.lang.Object
    拡張 jp.co.intra_mart.jssp.net.GenericURLBuilder
        拡張 jp.co.intra_mart.jssp.net.URLBuilder
public class URLBuilder
extends GenericURLBuilder

スクリプト開発モデルの画面を呼び出すための URL を作成するビルダです。

このクラスを利用する事により、セッションを維持したまま スクリプト開発モデルの画面へリンクさせる事ができます。 また、このクラスが生成する URL は、セッションチェック機能を持ったものに なるため、異なるセッションに対して生成された URL を用いてアクセスすると、 セッションエラーとなります。 つまり、このクラスが生成する URL は、セキュリティの強固なリンクとなります。

以下は「sample/example/string/main」を呼び出すためのURLを作成するサンプルコードです。

 HttpServletRequest request   = ... ;
 HttpServletResponse response = ... ;

 URLBuilder urlBuilder = new URLBuilder(request, response);
 URL urlContext = jp.co.intra_mart.common.aid.jsdk.utility.URLUtil.getContextURL(request);

 URL sessionURL = urlBuilder.createURLonSession(urlContext, "sample/example/string/main");
 String pageURL = sessionURL.toExternalForm();

バージョン:
Version 5.0

コンストラクタの概要
URLBuilder(HttpServletRequest request, HttpServletResponse response)
新しいビルダを作成します。
メソッドの概要
URL | createURLonSession(String path) HTTP セッションを維持したまま指定のスクリプト開発モデルの画面へ リンクするための URL を返します。
URL | createURLonSession(URL context, String path) HTTP セッションを維持したまま指定のスクリプト開発モデルの画面へ リンクするための URL を返します。
クラス jp.co.intra_mart.jssp.net.GenericURLBuilder から継承したメソッド
createFilePath, createURL, createURL, getRequest, getResponse
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLBuilder

public URLBuilder(HttpServletRequest request,
                  HttpServletResponse response)
新しいビルダを作成します。

このオブジェクトでは、指定のリクエストおよびレスポンスにを利用して、 スクリプト開発モデルの画面へリンクするための情報を操作します。

パラメータ:
request - リクエスト
response - レスポンス
例外:
NullPointerException - 引数が null
メソッドの詳細

createURLonSession

public URL createURLonSession(String path)
                       throws MalformedURLException
HTTP セッションを維持したまま指定のスクリプト開発モデルの画面へ リンクするための URL を返します。

このメソッドは、 GenericURLBuilder.createURL(String path)が返す URL に対して、 HttpServletResponse.encodeURL(String url)を 実行した結果を返します。

パラメータ:
path - スクリプト開発モデルのプログラムパス
戻り値:
指定の画面へリンクするためのＵＲＬ
例外:
MalformedURLException - URL が無効な書式の場合

createURLonSession

public URL createURLonSession(URL context,
                              String path)
                       throws MalformedURLException
HTTP セッションを維持したまま指定のスクリプト開発モデルの画面へ リンクするための URL を返します。

このメソッドは、 GenericURLBuilder.createURL(URL context, String path)が返す URL に対して、 HttpServletResponse.encodeURL(String url)を 実行した結果を返します。

なお、このメソッドの引数 context の生成に便利なユーティリティクラス jp.co.intra_mart.common.aid.jsdk.utility.URLUtilが存在します。

パラメータ:
context - 仕様を解析するコンテキスト
path - スクリプト開発モデルのプログラムパス
戻り値:
指定の画面へリンクするためのＵＲＬ
例外:
MalformedURLException - URL が無効な書式の場合
関連項目:
jp.co.intra_mart.common.aid.jsdk.utility.URLUtil
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel の使用

AccessControllerBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での AccessControllerBaseModel の使用

AccessControllerBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
AccessControllerBaseModel | AccessControllerMapper.create(String accessControllerId) プライマリキーに該当するアクセスコントローラ情報を生成します。
AccessControllerBaseModel | AccessControllerMapper.select(String accessControllerId) プライマリーキーで特定されるアクセスコントローラ情報の基本モデルを取得します。

AccessControllerBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | AccessControllerMapper.insert(AccessControllerBaseModel model) アクセスコントローラ情報の基本モデルを1つだけ挿入します。
void | AccessControllerMapper.update(AccessControllerBaseModel model) アクセスコントローラ情報の基本モデルを1つだけ更新します。
void | AccessControllerMapper.delete(AccessControllerBaseModel model) アクセスコントローラ情報の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel の使用

AccessControllerDepartmentBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での AccessControllerDepartmentBaseModel の使用

AccessControllerDepartmentBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
AccessControllerDepartmentBaseModel | AccessControllerDepartmentMapper.create(String accessControllerId, String companyCd, String departmentCd) プライマリキーに該当するアクセスコントローラの利用権限を保有する組織を生成します。
AccessControllerDepartmentBaseModel | AccessControllerDepartmentMapper.select(String accessControllerId, String companyCd, String departmentCd) プライマリーキーで特定されるアクセスコントローラの利用権限を保有する組織の基本モデルを取得します。

AccessControllerDepartmentBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | AccessControllerDepartmentMapper.insert(AccessControllerDepartmentBaseModel model) アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ挿入します。
void | AccessControllerDepartmentMapper.update(AccessControllerDepartmentBaseModel model) アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ更新します。
void | AccessControllerDepartmentMapper.delete(AccessControllerDepartmentBaseModel model) アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper の使用

jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper の使用

jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel の使用

AccessControllerPostBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での AccessControllerPostBaseModel の使用

AccessControllerPostBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
AccessControllerPostBaseModel | AccessControllerPostMapper.create(String accessControllerId, String companyCd, String postCd) プライマリキーに該当するアクセスコントローラの利用権限を保有する役職を生成します。
AccessControllerPostBaseModel | AccessControllerPostMapper.select(String accessControllerId, String companyCd, String postCd) プライマリーキーで特定されるアクセスコントローラの利用権限を保有する役職の基本モデルを取得します。

AccessControllerPostBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | AccessControllerPostMapper.insert(AccessControllerPostBaseModel model) アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ挿入します。
void | AccessControllerPostMapper.update(AccessControllerPostBaseModel model) アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ更新します。
void | AccessControllerPostMapper.delete(AccessControllerPostBaseModel model) アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper の使用

jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel の使用

AccessControllerPublicGroupBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での AccessControllerPublicGroupBaseModel の使用

AccessControllerPublicGroupBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
AccessControllerPublicGroupBaseModel | AccessControllerPublicGroupMapper.create(String accessControllerId, String publicGroupSetCd, String publicGroupCd) プライマリキーに該当するアクセスコントローラの利用権限を保有するパブリックグループを生成します。
AccessControllerPublicGroupBaseModel | AccessControllerPublicGroupMapper.select(String accessControllerId, String publicGroupSetCd, String publicGroupCd) プライマリーキーで特定されるアクセスコントローラの利用権限を保有するパブリックグループの基本モデルを取得します。

AccessControllerPublicGroupBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | AccessControllerPublicGroupMapper.insert(AccessControllerPublicGroupBaseModel model) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ挿入します。
void | AccessControllerPublicGroupMapper.update(AccessControllerPublicGroupBaseModel model) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ更新します。
void | AccessControllerPublicGroupMapper.delete(AccessControllerPublicGroupBaseModel model) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper の使用

jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel の使用

AccessControllerRoleBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での AccessControllerRoleBaseModel の使用

AccessControllerRoleBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
AccessControllerRoleBaseModel | AccessControllerRoleMapper.create(String accessControllerId, String roleId) プライマリキーに該当するアクセスコントローラの利用権限を保有するロールを生成します。
AccessControllerRoleBaseModel | AccessControllerRoleMapper.select(String accessControllerId, String roleId) プライマリーキーで特定されるアクセスコントローラの利用権限を保有するロールの基本モデルを取得します。

AccessControllerRoleBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | AccessControllerRoleMapper.insert(AccessControllerRoleBaseModel model) アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ挿入します。
void | AccessControllerRoleMapper.update(AccessControllerRoleBaseModel model) アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ更新します。
void | AccessControllerRoleMapper.delete(AccessControllerRoleBaseModel model) アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper の使用

jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel の使用

AccountAttributeBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での AccountAttributeBaseModel の使用

AccountAttributeBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
AccountAttributeBaseModel | AccountAttributeMapper.create(String userId, String attributeName) プライマリキーに該当するアカウントが保有する属性を生成します。
AccountAttributeBaseModel | AccountAttributeMapper.select(String userId, String attributeName) プライマリーキーで特定されるアカウントが保有する属性の基本モデルを取得します。

AccountAttributeBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | AccountAttributeMapper.insert(AccountAttributeBaseModel model) アカウントが保有する属性の基本モデルを1つだけ挿入します。
void | AccountAttributeMapper.update(AccountAttributeBaseModel model) アカウントが保有する属性の基本モデルを1つだけ更新します。
void | AccountAttributeMapper.delete(AccountAttributeBaseModel model) アカウントが保有する属性の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper の使用

jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の使用

AccountBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での AccountBaseModel の使用

AccountBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
AccountBaseModel | AccountMapper.create(String userId) プライマリキーに該当するアカウントを生成します。
AccountBaseModel | AccountMapper.select(String userId) プライマリーキーで特定されるアカウントの基本モデルを取得します。

AccountBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | AccountMapper.insert(AccountBaseModel model) アカウントの基本モデルを1つだけ挿入します。
void | AccountMapper.update(AccountBaseModel model) アカウントの基本モデルを1つだけ更新します。
void | AccountMapper.delete(AccountBaseModel model) アカウントの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccountMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccountMapper の使用

jp.co.intra_mart.system.security.datastore.inf.AccountMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel の使用

AccountRoleBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での AccountRoleBaseModel の使用

AccountRoleBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
AccountRoleBaseModel | AccountRoleMapper.create(String userId, String roleId) プライマリキーに該当するアカウントが保有するロールを生成します。
AccountRoleBaseModel | AccountRoleMapper.select(String userId, String roleId) プライマリーキーで特定されるアカウントが保有するロールの基本モデルを取得します。

AccountRoleBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | AccountRoleMapper.insert(AccountRoleBaseModel model) アカウントが保有するロールの基本モデルを1つだけ挿入します。
void | AccountRoleMapper.update(AccountRoleBaseModel model) アカウントが保有するロールの基本モデルを1つだけ更新します。
void | AccountRoleMapper.delete(AccountRoleBaseModel model) アカウントが保有するロールの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper の使用

jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の使用

BatchBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での BatchBaseModel の使用

BatchBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
BatchBaseModel | BatchMapper.create(String batchId) プライマリキーに該当するバッチ情報を生成します。
BatchBaseModel | BatchMapper.select(String batchId) プライマリーキーで特定されるバッチ情報の基本モデルを取得します。

BatchBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | BatchMapper.insert(BatchBaseModel model) バッチ情報の基本モデルを1つだけ挿入します。
void | BatchMapper.update(BatchBaseModel model) バッチ情報の基本モデルを1つだけ更新します。
void | BatchMapper.delete(BatchBaseModel model) バッチ情報の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.BatchMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.BatchMapper の使用

jp.co.intra_mart.system.security.datastore.inf.BatchMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の使用

CalendarInfoBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での CalendarInfoBaseModel の使用

CalendarInfoBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
CalendarInfoBaseModel | CalendarInfoMapper.create(String calendarId, String dataId) プライマリキーに該当するカレンダーが保有するデータを生成します。
CalendarInfoBaseModel | CalendarInfoMapper.select(String calendarId, String dataId) プライマリーキーで特定されるカレンダーが保有するデータの基本モデルを取得します。

CalendarInfoBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | CalendarInfoMapper.insert(CalendarInfoBaseModel model) カレンダーが保有するデータの基本モデルを1つだけ挿入します。
void | CalendarInfoMapper.update(CalendarInfoBaseModel model) カレンダーが保有するデータの基本モデルを1つだけ更新します。
void | CalendarInfoMapper.delete(CalendarInfoBaseModel model) カレンダーが保有するデータの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.CalendarInfoInternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.CalendarInfoInternationalModel の使用

CalendarInfoInternationalModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での CalendarInfoInternationalModel の使用

CalendarInfoInternationalModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
 CalendarInfoInternationalModel CalendarInfoBaseModel.selectCalendarInfoInternationalModel(Locale locale)
指定された言語に該当するカレンダーが保有するデータの国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper の使用

jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の使用

jp.co.intra_mart.system.security.datastore.inf.DataStoreConst はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel の使用

FavoriteMenuBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での FavoriteMenuBaseModel の使用

FavoriteMenuBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
FavoriteMenuBaseModel | FavoriteMenuMapper.create(String userId, String menuId) プライマリキーに該当するアカウントが保有するメニューを生成します。
FavoriteMenuBaseModel | FavoriteMenuMapper.select(String userId, String menuId) プライマリーキーで特定されるアカウントが保有するメニューの基本モデルを取得します。

FavoriteMenuBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | FavoriteMenuMapper.insert(FavoriteMenuBaseModel model) アカウントが保有するメニューの基本モデルを1つだけ挿入します。
void | FavoriteMenuMapper.update(FavoriteMenuBaseModel model) アカウントが保有するメニューの基本モデルを1つだけ更新します。
void | FavoriteMenuMapper.delete(FavoriteMenuBaseModel model) アカウントが保有するメニューの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper の使用

jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel の使用

MenuArgumentBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での MenuArgumentBaseModel の使用

MenuArgumentBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
MenuArgumentBaseModel | MenuArgumentMapper.create(String menuId, String argumentName) プライマリキーに該当するメニューの保有する引数を生成します。
MenuArgumentBaseModel | MenuArgumentMapper.select(String menuId, String argumentName) プライマリーキーで特定されるメニューの保有する引数の基本モデルを取得します。

MenuArgumentBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | MenuArgumentMapper.insert(MenuArgumentBaseModel model) メニューの保有する引数の基本モデルを1つだけ挿入します。
void | MenuArgumentMapper.update(MenuArgumentBaseModel model) メニューの保有する引数の基本モデルを1つだけ更新します。
void | MenuArgumentMapper.delete(MenuArgumentBaseModel model) メニューの保有する引数の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper の使用

jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の使用

MenuBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での MenuBaseModel の使用

MenuBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
MenuBaseModel | MenuMapper.create(String menuId) プライマリキーに該当するメニュー情報を生成します。
MenuBaseModel | MenuMapper.select(String menuId) プライマリーキーで特定されるメニュー情報の基本モデルを取得します。

MenuBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | MenuMapper.insert(MenuBaseModel model) メニュー情報の基本モデルを1つだけ挿入します。
void | MenuMapper.update(MenuBaseModel model) メニュー情報の基本モデルを1つだけ更新します。
void | MenuMapper.delete(MenuBaseModel model) メニュー情報の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel の使用

MenuDepartmentBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での MenuDepartmentBaseModel の使用

MenuDepartmentBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
MenuDepartmentBaseModel | MenuDepartmentMapper.create(String menuId, String companyCd, String departmentCd) プライマリキーに該当するメニューの利用権限を保有する組織を生成します。
MenuDepartmentBaseModel | MenuDepartmentMapper.select(String menuId, String companyCd, String departmentCd) プライマリーキーで特定されるメニューの利用権限を保有する組織の基本モデルを取得します。

MenuDepartmentBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | MenuDepartmentMapper.insert(MenuDepartmentBaseModel model) メニューの利用権限を保有する組織の基本モデルを1つだけ挿入します。
void | MenuDepartmentMapper.update(MenuDepartmentBaseModel model) メニューの利用権限を保有する組織の基本モデルを1つだけ更新します。
void | MenuDepartmentMapper.delete(MenuDepartmentBaseModel model) メニューの利用権限を保有する組織の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper の使用

jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuInternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuInternationalModel の使用

MenuInternationalModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での MenuInternationalModel の使用

MenuInternationalModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
 MenuInternationalModel MenuBaseModel.selectMenuInternationalModel(Locale locale)
指定された言語に該当するメニュー情報の国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuMapper の使用

jp.co.intra_mart.system.security.datastore.inf.MenuMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel の使用

MenuPostBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での MenuPostBaseModel の使用

MenuPostBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
MenuPostBaseModel | MenuPostMapper.create(String menuId, String companyCd, String postCd) プライマリキーに該当するメニューの利用権限を保有する役職を生成します。
MenuPostBaseModel | MenuPostMapper.select(String menuId, String companyCd, String postCd) プライマリーキーで特定されるメニューの利用権限を保有する役職の基本モデルを取得します。

MenuPostBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | MenuPostMapper.insert(MenuPostBaseModel model) メニューの利用権限を保有する役職の基本モデルを1つだけ挿入します。
void | MenuPostMapper.update(MenuPostBaseModel model) メニューの利用権限を保有する役職の基本モデルを1つだけ更新します。
void | MenuPostMapper.delete(MenuPostBaseModel model) メニューの利用権限を保有する役職の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper の使用

jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel の使用

MenuPublicGroupBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での MenuPublicGroupBaseModel の使用

MenuPublicGroupBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
MenuPublicGroupBaseModel | MenuPublicGroupMapper.create(String menuId, String publicGroupSetCd, String publicGroupCd) プライマリキーに該当するメニューの利用権限を保有するパブリックグループを生成します。
MenuPublicGroupBaseModel | MenuPublicGroupMapper.select(String menuId, String publicGroupSetCd, String publicGroupCd) プライマリーキーで特定されるメニューの利用権限を保有するパブリックグループの基本モデルを取得します。

MenuPublicGroupBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | MenuPublicGroupMapper.insert(MenuPublicGroupBaseModel model) メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ挿入します。
void | MenuPublicGroupMapper.update(MenuPublicGroupBaseModel model) メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ更新します。
void | MenuPublicGroupMapper.delete(MenuPublicGroupBaseModel model) メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper の使用

jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel の使用

MenuRoleBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での MenuRoleBaseModel の使用

MenuRoleBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
MenuRoleBaseModel | MenuRoleMapper.create(String menuId, String roleId) プライマリキーに該当するメニューの利用権限を保有するロールを生成します。
MenuRoleBaseModel | MenuRoleMapper.select(String menuId, String roleId) プライマリーキーで特定されるメニューの利用権限を保有するロールの基本モデルを取得します。

MenuRoleBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | MenuRoleMapper.insert(MenuRoleBaseModel model) メニューの利用権限を保有するロールの基本モデルを1つだけ挿入します。
void | MenuRoleMapper.update(MenuRoleBaseModel model) メニューの利用権限を保有するロールの基本モデルを1つだけ更新します。
void | MenuRoleMapper.delete(MenuRoleBaseModel model) メニューの利用権限を保有するロールの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper の使用

jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel の使用

RoleBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での RoleBaseModel の使用

RoleBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
RoleBaseModel | RoleMapper.create(String roleId) プライマリキーに該当するロールを生成します。
RoleBaseModel | RoleMapper.select(String roleId) プライマリーキーで特定されるロールの基本モデルを取得します。

RoleBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | RoleMapper.insert(RoleBaseModel model) ロールの基本モデルを1つだけ挿入します。
void | RoleMapper.update(RoleBaseModel model) ロールの基本モデルを1つだけ更新します。
void | RoleMapper.delete(RoleBaseModel model) ロールの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel の使用

RoleInclusionBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での RoleInclusionBaseModel の使用

RoleInclusionBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
RoleInclusionBaseModel | RoleInclusionMapper.create(String parentRoleId, String childRoleId) プライマリキーに該当するロール内包を生成します。
RoleInclusionBaseModel | RoleInclusionMapper.select(String parentRoleId, String childRoleId) プライマリーキーで特定されるロール内包の基本モデルを取得します。

RoleInclusionBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | RoleInclusionMapper.insert(RoleInclusionBaseModel model) ロール内包の基本モデルを1つだけ挿入します。
void | RoleInclusionMapper.update(RoleInclusionBaseModel model) ロール内包の基本モデルを1つだけ更新します。
void | RoleInclusionMapper.delete(RoleInclusionBaseModel model) ロール内包の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper の使用

jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.RoleInternationalModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.RoleInternationalModel の使用

RoleInternationalModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での RoleInternationalModel の使用

RoleInternationalModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
 RoleInternationalModel RoleBaseModel.selectRoleInternationalModel(Locale locale)
指定された言語に該当するロールの国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.RoleMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.RoleMapper の使用

jp.co.intra_mart.system.security.datastore.inf.RoleMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel の使用

RoleSummaryBaseModel を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf での RoleSummaryBaseModel の使用

RoleSummaryBaseModel を返す jp.co.intra_mart.system.security.datastore.inf のメソッド
RoleSummaryBaseModel | RoleSummaryMapper.create(String roleId, String summaryRoleId) プライマリキーに該当するロールサマリを生成します。
RoleSummaryBaseModel | RoleSummaryMapper.select(String roleId, String summaryRoleId) プライマリーキーで特定されるロールサマリの基本モデルを取得します。

RoleSummaryBaseModel 型のパラメータを持つ jp.co.intra_mart.system.security.datastore.inf のメソッド
void | RoleSummaryMapper.insert(RoleSummaryBaseModel model) ロールサマリの基本モデルを1つだけ挿入します。
void | RoleSummaryMapper.update(RoleSummaryBaseModel model) ロールサマリの基本モデルを1つだけ更新します。
void | RoleSummaryMapper.delete(RoleSummaryBaseModel model) ロールサマリの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper の使用

jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AccessControllerBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccessControllerBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface AccessControllerBaseModel
extends BaseModel

アクセスコントローラ情報の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | ACCESS_CONTROLLER_ID アクセスコントローラID
static String | ACCESS_CONTROLLER_NAME アクセスコントローラ名
static String | NOTES 説明
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getAccessControllerId() アクセスコントローラIDを取得します。
String | getAccessControllerName() アクセスコントローラ名を取得します。
String | getNotes() 説明を取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
void | setAccessControllerName(String accessControllerName) アクセスコントローラ名を設定します。
void | setNotes(String notes) 説明を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ACCESS_CONTROLLER_ID

public static final String ACCESS_CONTROLLER_ID
アクセスコントローラID

関連項目:
定数フィールド値

ACCESS_CONTROLLER_NAME

public static final String ACCESS_CONTROLLER_NAME
アクセスコントローラ名

関連項目:
定数フィールド値

NOTES

public static final String NOTES
説明

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getAccessControllerId

public String getAccessControllerId()
                             throws AccessorException
アクセスコントローラIDを取得します。

戻り値:
アクセスコントローラID
例外:
AccessorException - データの取得に失敗した場合

getAccessControllerName

public String getAccessControllerName()
                               throws AccessorException
アクセスコントローラ名を取得します。

戻り値:
アクセスコントローラ名
例外:
AccessorException - データの取得に失敗した場合

setAccessControllerName

public void setAccessControllerName(String accessControllerName)
                             throws AccessorException
アクセスコントローラ名を設定します。

パラメータ:
accessControllerName - アクセスコントローラ名
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
説明を取得します。

戻り値:
説明
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
説明を設定します。

パラメータ:
notes - 説明
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccessControllerDepartmentBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccessControllerDepartmentBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface AccessControllerDepartmentBaseModel
extends BaseModel

アクセスコントローラの利用権限を保有する組織の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | ACCESS_CONTROLLER_ID アクセスコントローラID
static String | COMPANY_CD 会社CD
static String | DEPARTMENT_CD 組織CD
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getAccessControllerId() アクセスコントローラIDを取得します。
String | getCompanyCd() 会社CDを取得します。
String | getDepartmentCd() 組織CDを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ACCESS_CONTROLLER_ID

public static final String ACCESS_CONTROLLER_ID
アクセスコントローラID

関連項目:
定数フィールド値

COMPANY_CD

public static final String COMPANY_CD
会社CD

関連項目:
定数フィールド値

DEPARTMENT_CD

public static final String DEPARTMENT_CD
組織CD

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getAccessControllerId

public String getAccessControllerId()
                             throws AccessorException
アクセスコントローラIDを取得します。

戻り値:
アクセスコントローラID
例外:
AccessorException - データの取得に失敗した場合

getCompanyCd

public String getCompanyCd()
                    throws AccessorException
会社CDを取得します。

戻り値:
会社CD
例外:
AccessorException - データの取得に失敗した場合

getDepartmentCd

public String getDepartmentCd()
                       throws AccessorException
組織CDを取得します。

戻り値:
組織CD
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerDepartmentMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccessControllerDepartmentMapper

すべてのスーパーインタフェース:
Mapper
public interface AccessControllerDepartmentMapper
extends Mapper

アクセスコントローラの利用権限を保有する組織に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
AccessControllerDepartmentBaseModel | create(String accessControllerId, String companyCd, String departmentCd) プライマリキーに該当するアクセスコントローラの利用権限を保有する組織を生成します。
void | delete(AccessControllerDepartmentBaseModel model) アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ削除します。
void | delete(Collection models) アクセスコントローラの利用権限を保有する組織の基本モデルを複数削除します。
void | insert(AccessControllerDepartmentBaseModel model) アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ挿入します。
void | insert(Collection models) アクセスコントローラの利用権限を保有する組織の基本モデルを複数挿入します。
AccessControllerDepartmentBaseModel | select(String accessControllerId, String companyCd, String departmentCd) プライマリーキーで特定されるアクセスコントローラの利用権限を保有する組織の基本モデルを取得します。
void | update(AccessControllerDepartmentBaseModel model) アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ更新します。
void | update(Collection models) アクセスコントローラの利用権限を保有する組織の基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public AccessControllerDepartmentBaseModel create(String accessControllerId,
                                                  String companyCd,
                                                  String departmentCd)
                                           throws MapperException
プライマリキーに該当するアクセスコントローラの利用権限を保有する組織を生成します。

パラメータ:
accessControllerId - アクセスコントローラID
companyCd - 会社CD
departmentCd - 組織CD
戻り値:
プライマリキーに該当するアクセスコントローラの利用権限を保有する組織の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public AccessControllerDepartmentBaseModel select(String accessControllerId,
                                                  String companyCd,
                                                  String departmentCd)
                                           throws MapperException
プライマリーキーで特定されるアクセスコントローラの利用権限を保有する組織の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
accessControllerId - アクセスコントローラID
companyCd - 会社CD
departmentCd - 組織CD
戻り値:
アクセスコントローラの利用権限を保有する組織の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(AccessControllerDepartmentBaseModel model)
            throws MapperException
アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ挿入します。 引数に指定するアクセスコントローラの利用権限を保有する組織の基本モデルは同一の AccessControllerDepartmentMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するアクセスコントローラの利用権限を保有する組織の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
アクセスコントローラの利用権限を保有する組織の基本モデルを複数挿入します。 引数に指定するものは同一の AccessControllerDepartmentMapperの create(String,String,String) で生成されたアクセスコントローラの利用権限を保有する組織の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するアクセスコントローラの利用権限を保有する組織の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(AccessControllerDepartmentBaseModel model)
            throws MapperException
アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ更新します。 引数に指定するアクセスコントローラの利用権限を保有する組織の基本モデルは同一の AccessControllerDepartmentMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するアクセスコントローラの利用権限を保有する組織の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
アクセスコントローラの利用権限を保有する組織の基本モデルを複数更新します。 引数に指定するものは同一の AccessControllerDepartmentMapperの select 系メソッド から取得されたものかで生成されたアクセスコントローラの利用権限を保有する組織の基本モデルの集合である必要があります。

パラメータ:
models - 更新するアクセスコントローラの利用権限を保有する組織の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(AccessControllerDepartmentBaseModel model)
            throws MapperException
アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ削除します。 引数で指定されたアクセスコントローラの利用権限を保有する組織の基本モデルに該当するデータのすべての情報を削除します。引数に指定するアクセスコントローラの利用権限を保有する組織の基本モデルは同一の AccessControllerDepartmentMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するアクセスコントローラの利用権限を保有する組織の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
アクセスコントローラの利用権限を保有する組織の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するアクセスコントローラの利用権限を保有する組織の基本モデルは同一の AccessControllerDepartmentMapperの select 系メソッド から取得されたアクセスコントローラの利用権限を保有する組織の基本モデルの集合である必要があります。

パラメータ:
models - 削除するアクセスコントローラの利用権限を保有する組織の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccessControllerMapper

すべてのスーパーインタフェース:
Mapper
public interface AccessControllerMapper
extends Mapper

アクセスコントローラ情報に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
AccessControllerBaseModel | create(String accessControllerId) プライマリキーに該当するアクセスコントローラ情報を生成します。
void | delete(AccessControllerBaseModel model) アクセスコントローラ情報の基本モデルを1つだけ削除します。
void | delete(Collection models) アクセスコントローラ情報の基本モデルを複数削除します。
void | insert(AccessControllerBaseModel model) アクセスコントローラ情報の基本モデルを1つだけ挿入します。
void | insert(Collection models) アクセスコントローラ情報の基本モデルを複数挿入します。
AccessControllerBaseModel | select(String accessControllerId) プライマリーキーで特定されるアクセスコントローラ情報の基本モデルを取得します。
void | update(AccessControllerBaseModel model) アクセスコントローラ情報の基本モデルを1つだけ更新します。
void | update(Collection models) アクセスコントローラ情報の基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public AccessControllerBaseModel create(String accessControllerId)
                                 throws MapperException
プライマリキーに該当するアクセスコントローラ情報を生成します。

パラメータ:
accessControllerId - アクセスコントローラID
戻り値:
プライマリキーに該当するアクセスコントローラ情報の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public AccessControllerBaseModel select(String accessControllerId)
                                 throws MapperException
プライマリーキーで特定されるアクセスコントローラ情報の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
accessControllerId - アクセスコントローラID
戻り値:
アクセスコントローラ情報の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(AccessControllerBaseModel model)
            throws MapperException
アクセスコントローラ情報の基本モデルを1つだけ挿入します。 引数に指定するアクセスコントローラ情報の基本モデルは同一の AccessControllerMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入するアクセスコントローラ情報の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
アクセスコントローラ情報の基本モデルを複数挿入します。 引数に指定するものは同一の AccessControllerMapperの create(String) で生成されたアクセスコントローラ情報の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するアクセスコントローラ情報の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(AccessControllerBaseModel model)
            throws MapperException
アクセスコントローラ情報の基本モデルを1つだけ更新します。 引数に指定するアクセスコントローラ情報の基本モデルは同一の AccessControllerMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するアクセスコントローラ情報の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
アクセスコントローラ情報の基本モデルを複数更新します。 引数に指定するものは同一の AccessControllerMapperの select 系メソッド から取得されたものかで生成されたアクセスコントローラ情報の基本モデルの集合である必要があります。

パラメータ:
models - 更新するアクセスコントローラ情報の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(AccessControllerBaseModel model)
            throws MapperException
アクセスコントローラ情報の基本モデルを1つだけ削除します。 引数で指定されたアクセスコントローラ情報の基本モデルに該当するデータのすべての情報を削除します。引数に指定するアクセスコントローラ情報の基本モデルは同一の AccessControllerMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するアクセスコントローラ情報の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
アクセスコントローラ情報の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するアクセスコントローラ情報の基本モデルは同一の AccessControllerMapperの select 系メソッド から取得されたアクセスコントローラ情報の基本モデルの集合である必要があります。

パラメータ:
models - 削除するアクセスコントローラ情報の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerPostBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccessControllerPostBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface AccessControllerPostBaseModel
extends BaseModel

アクセスコントローラの利用権限を保有する役職の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | ACCESS_CONTROLLER_ID アクセスコントローラID
static String | COMPANY_CD 会社CD
static String | POST_CD 役職CD
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getAccessControllerId() アクセスコントローラIDを取得します。
String | getCompanyCd() 会社CDを取得します。
String | getPostCd() 役職CDを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ACCESS_CONTROLLER_ID

public static final String ACCESS_CONTROLLER_ID
アクセスコントローラID

関連項目:
定数フィールド値

COMPANY_CD

public static final String COMPANY_CD
会社CD

関連項目:
定数フィールド値

POST_CD

public static final String POST_CD
役職CD

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getAccessControllerId

public String getAccessControllerId()
                             throws AccessorException
アクセスコントローラIDを取得します。

戻り値:
アクセスコントローラID
例外:
AccessorException - データの取得に失敗した場合

getCompanyCd

public String getCompanyCd()
                    throws AccessorException
会社CDを取得します。

戻り値:
会社CD
例外:
AccessorException - データの取得に失敗した場合

getPostCd

public String getPostCd()
                 throws AccessorException
役職CDを取得します。

戻り値:
役職CD
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerPostMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccessControllerPostMapper

すべてのスーパーインタフェース:
Mapper
public interface AccessControllerPostMapper
extends Mapper

アクセスコントローラの利用権限を保有する役職に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
AccessControllerPostBaseModel | create(String accessControllerId, String companyCd, String postCd) プライマリキーに該当するアクセスコントローラの利用権限を保有する役職を生成します。
void | delete(AccessControllerPostBaseModel model) アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ削除します。
void | delete(Collection models) アクセスコントローラの利用権限を保有する役職の基本モデルを複数削除します。
void | insert(AccessControllerPostBaseModel model) アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ挿入します。
void | insert(Collection models) アクセスコントローラの利用権限を保有する役職の基本モデルを複数挿入します。
AccessControllerPostBaseModel | select(String accessControllerId, String companyCd, String postCd) プライマリーキーで特定されるアクセスコントローラの利用権限を保有する役職の基本モデルを取得します。
void | update(AccessControllerPostBaseModel model) アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ更新します。
void | update(Collection models) アクセスコントローラの利用権限を保有する役職の基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public AccessControllerPostBaseModel create(String accessControllerId,
                                            String companyCd,
                                            String postCd)
                                     throws MapperException
プライマリキーに該当するアクセスコントローラの利用権限を保有する役職を生成します。

パラメータ:
accessControllerId - アクセスコントローラID
companyCd - 会社CD
postCd - 役職CD
戻り値:
プライマリキーに該当するアクセスコントローラの利用権限を保有する役職の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public AccessControllerPostBaseModel select(String accessControllerId,
                                            String companyCd,
                                            String postCd)
                                     throws MapperException
プライマリーキーで特定されるアクセスコントローラの利用権限を保有する役職の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
accessControllerId - アクセスコントローラID
companyCd - 会社CD
postCd - 役職CD
戻り値:
アクセスコントローラの利用権限を保有する役職の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(AccessControllerPostBaseModel model)
            throws MapperException
アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ挿入します。 引数に指定するアクセスコントローラの利用権限を保有する役職の基本モデルは同一の AccessControllerPostMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するアクセスコントローラの利用権限を保有する役職の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
アクセスコントローラの利用権限を保有する役職の基本モデルを複数挿入します。 引数に指定するものは同一の AccessControllerPostMapperの create(String,String,String) で生成されたアクセスコントローラの利用権限を保有する役職の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するアクセスコントローラの利用権限を保有する役職の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(AccessControllerPostBaseModel model)
            throws MapperException
アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ更新します。 引数に指定するアクセスコントローラの利用権限を保有する役職の基本モデルは同一の AccessControllerPostMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するアクセスコントローラの利用権限を保有する役職の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
アクセスコントローラの利用権限を保有する役職の基本モデルを複数更新します。 引数に指定するものは同一の AccessControllerPostMapperの select 系メソッド から取得されたものかで生成されたアクセスコントローラの利用権限を保有する役職の基本モデルの集合である必要があります。

パラメータ:
models - 更新するアクセスコントローラの利用権限を保有する役職の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(AccessControllerPostBaseModel model)
            throws MapperException
アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ削除します。 引数で指定されたアクセスコントローラの利用権限を保有する役職の基本モデルに該当するデータのすべての情報を削除します。引数に指定するアクセスコントローラの利用権限を保有する役職の基本モデルは同一の AccessControllerPostMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するアクセスコントローラの利用権限を保有する役職の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
アクセスコントローラの利用権限を保有する役職の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するアクセスコントローラの利用権限を保有する役職の基本モデルは同一の AccessControllerPostMapperの select 系メソッド から取得されたアクセスコントローラの利用権限を保有する役職の基本モデルの集合である必要があります。

パラメータ:
models - 削除するアクセスコントローラの利用権限を保有する役職の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerPublicGroupBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccessControllerPublicGroupBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface AccessControllerPublicGroupBaseModel
extends BaseModel

アクセスコントローラの利用権限を保有するパブリックグループの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | ACCESS_CONTROLLER_ID アクセスコントローラID
static String | PUBLIC_GROUP_CD グルーピングCD
static String | PUBLIC_GROUP_SET_CD グループセットCD
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getAccessControllerId() アクセスコントローラIDを取得します。
String | getPublicGroupCd() グルーピングCDを取得します。
String | getPublicGroupSetCd() グループセットCDを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ACCESS_CONTROLLER_ID

public static final String ACCESS_CONTROLLER_ID
アクセスコントローラID

関連項目:
定数フィールド値

PUBLIC_GROUP_SET_CD

public static final String PUBLIC_GROUP_SET_CD
グループセットCD

関連項目:
定数フィールド値

PUBLIC_GROUP_CD

public static final String PUBLIC_GROUP_CD
グルーピングCD

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getAccessControllerId

public String getAccessControllerId()
                             throws AccessorException
アクセスコントローラIDを取得します。

戻り値:
アクセスコントローラID
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupSetCd

public String getPublicGroupSetCd()
                           throws AccessorException
グループセットCDを取得します。

戻り値:
グループセットCD
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupCd

public String getPublicGroupCd()
                        throws AccessorException
グルーピングCDを取得します。

戻り値:
グルーピングCD
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerPublicGroupMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccessControllerPublicGroupMapper

すべてのスーパーインタフェース:
Mapper
public interface AccessControllerPublicGroupMapper
extends Mapper

アクセスコントローラの利用権限を保有するパブリックグループに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
AccessControllerPublicGroupBaseModel | create(String accessControllerId, String publicGroupSetCd, String publicGroupCd) プライマリキーに該当するアクセスコントローラの利用権限を保有するパブリックグループを生成します。
void | delete(AccessControllerPublicGroupBaseModel model) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ削除します。
void | delete(Collection models) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを複数削除します。
void | insert(AccessControllerPublicGroupBaseModel model) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ挿入します。
void | insert(Collection models) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを複数挿入します。
AccessControllerPublicGroupBaseModel | select(String accessControllerId, String publicGroupSetCd, String publicGroupCd) プライマリーキーで特定されるアクセスコントローラの利用権限を保有するパブリックグループの基本モデルを取得します。
void | update(AccessControllerPublicGroupBaseModel model) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ更新します。
void | update(Collection models) アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public AccessControllerPublicGroupBaseModel create(String accessControllerId,
                                                   String publicGroupSetCd,
                                                   String publicGroupCd)
                                            throws MapperException
プライマリキーに該当するアクセスコントローラの利用権限を保有するパブリックグループを生成します。

パラメータ:
accessControllerId - アクセスコントローラID
publicGroupSetCd - グループセットCD
publicGroupCd - グルーピングCD
戻り値:
プライマリキーに該当するアクセスコントローラの利用権限を保有するパブリックグループの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public AccessControllerPublicGroupBaseModel select(String accessControllerId,
                                                   String publicGroupSetCd,
                                                   String publicGroupCd)
                                            throws MapperException
プライマリーキーで特定されるアクセスコントローラの利用権限を保有するパブリックグループの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
accessControllerId - アクセスコントローラID
publicGroupSetCd - グループセットCD
publicGroupCd - グルーピングCD
戻り値:
アクセスコントローラの利用権限を保有するパブリックグループの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(AccessControllerPublicGroupBaseModel model)
            throws MapperException
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ挿入します。 引数に指定するアクセスコントローラの利用権限を保有するパブリックグループの基本モデルは同一の AccessControllerPublicGroupMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するアクセスコントローラの利用権限を保有するパブリックグループの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを複数挿入します。 引数に指定するものは同一の AccessControllerPublicGroupMapperの create(String,String,String) で生成されたアクセスコントローラの利用権限を保有するパブリックグループの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するアクセスコントローラの利用権限を保有するパブリックグループの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(AccessControllerPublicGroupBaseModel model)
            throws MapperException
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ更新します。 引数に指定するアクセスコントローラの利用権限を保有するパブリックグループの基本モデルは同一の AccessControllerPublicGroupMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するアクセスコントローラの利用権限を保有するパブリックグループの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを複数更新します。 引数に指定するものは同一の AccessControllerPublicGroupMapperの select 系メソッド から取得されたものかで生成されたアクセスコントローラの利用権限を保有するパブリックグループの基本モデルの集合である必要があります。

パラメータ:
models - 更新するアクセスコントローラの利用権限を保有するパブリックグループの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(AccessControllerPublicGroupBaseModel model)
            throws MapperException
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ削除します。 引数で指定されたアクセスコントローラの利用権限を保有するパブリックグループの基本モデルに該当するデータのすべての情報を削除します。引数に指定するアクセスコントローラの利用権限を保有するパブリックグループの基本モデルは同一の AccessControllerPublicGroupMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するアクセスコントローラの利用権限を保有するパブリックグループの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するアクセスコントローラの利用権限を保有するパブリックグループの基本モデルは同一の AccessControllerPublicGroupMapperの select 系メソッド から取得されたアクセスコントローラの利用権限を保有するパブリックグループの基本モデルの集合である必要があります。

パラメータ:
models - 削除するアクセスコントローラの利用権限を保有するパブリックグループの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerRoleBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccessControllerRoleBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface AccessControllerRoleBaseModel
extends BaseModel

アクセスコントローラの利用権限を保有するロールの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | ACCESS_CONTROLLER_ID アクセスコントローラID
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | ROLE_ID ロールCD
メソッドの概要
String | getAccessControllerId() アクセスコントローラIDを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getRoleId() ロールCDを取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ACCESS_CONTROLLER_ID

public static final String ACCESS_CONTROLLER_ID
アクセスコントローラID

関連項目:
定数フィールド値

ROLE_ID

public static final String ROLE_ID
ロールCD

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getAccessControllerId

public String getAccessControllerId()
                             throws AccessorException
アクセスコントローラIDを取得します。

戻り値:
アクセスコントローラID
例外:
AccessorException - データの取得に失敗した場合

getRoleId

public String getRoleId()
                 throws AccessorException
ロールCDを取得します。

戻り値:
ロールCD
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessControllerRoleMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccessControllerRoleMapper

すべてのスーパーインタフェース:
Mapper
public interface AccessControllerRoleMapper
extends Mapper

アクセスコントローラの利用権限を保有するロールに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
AccessControllerRoleBaseModel | create(String accessControllerId, String roleId) プライマリキーに該当するアクセスコントローラの利用権限を保有するロールを生成します。
void | delete(AccessControllerRoleBaseModel model) アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ削除します。
void | delete(Collection models) アクセスコントローラの利用権限を保有するロールの基本モデルを複数削除します。
void | insert(AccessControllerRoleBaseModel model) アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ挿入します。
void | insert(Collection models) アクセスコントローラの利用権限を保有するロールの基本モデルを複数挿入します。
AccessControllerRoleBaseModel | select(String accessControllerId, String roleId) プライマリーキーで特定されるアクセスコントローラの利用権限を保有するロールの基本モデルを取得します。
void | update(AccessControllerRoleBaseModel model) アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ更新します。
void | update(Collection models) アクセスコントローラの利用権限を保有するロールの基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public AccessControllerRoleBaseModel create(String accessControllerId,
                                            String roleId)
                                     throws MapperException
プライマリキーに該当するアクセスコントローラの利用権限を保有するロールを生成します。

パラメータ:
accessControllerId - アクセスコントローラID
roleId - ロールCD
戻り値:
プライマリキーに該当するアクセスコントローラの利用権限を保有するロールの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public AccessControllerRoleBaseModel select(String accessControllerId,
                                            String roleId)
                                     throws MapperException
プライマリーキーで特定されるアクセスコントローラの利用権限を保有するロールの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
accessControllerId - アクセスコントローラID
roleId - ロールCD
戻り値:
アクセスコントローラの利用権限を保有するロールの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(AccessControllerRoleBaseModel model)
            throws MapperException
アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ挿入します。 引数に指定するアクセスコントローラの利用権限を保有するロールの基本モデルは同一の AccessControllerRoleMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するアクセスコントローラの利用権限を保有するロールの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
アクセスコントローラの利用権限を保有するロールの基本モデルを複数挿入します。 引数に指定するものは同一の AccessControllerRoleMapperの create(String,String) で生成されたアクセスコントローラの利用権限を保有するロールの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するアクセスコントローラの利用権限を保有するロールの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(AccessControllerRoleBaseModel model)
            throws MapperException
アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ更新します。 引数に指定するアクセスコントローラの利用権限を保有するロールの基本モデルは同一の AccessControllerRoleMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するアクセスコントローラの利用権限を保有するロールの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
アクセスコントローラの利用権限を保有するロールの基本モデルを複数更新します。 引数に指定するものは同一の AccessControllerRoleMapperの select 系メソッド から取得されたものかで生成されたアクセスコントローラの利用権限を保有するロールの基本モデルの集合である必要があります。

パラメータ:
models - 更新するアクセスコントローラの利用権限を保有するロールの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(AccessControllerRoleBaseModel model)
            throws MapperException
アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ削除します。 引数で指定されたアクセスコントローラの利用権限を保有するロールの基本モデルに該当するデータのすべての情報を削除します。引数に指定するアクセスコントローラの利用権限を保有するロールの基本モデルは同一の AccessControllerRoleMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するアクセスコントローラの利用権限を保有するロールの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
アクセスコントローラの利用権限を保有するロールの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するアクセスコントローラの利用権限を保有するロールの基本モデルは同一の AccessControllerRoleMapperの select 系メソッド から取得されたアクセスコントローラの利用権限を保有するロールの基本モデルの集合である必要があります。

パラメータ:
models - 削除するアクセスコントローラの利用権限を保有するロールの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountAttributeBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccountAttributeBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface AccountAttributeBaseModel
extends BaseModel

アカウントが保有する属性の基本モデルです。

導入されたバージョン:
5.2

フィールドの概要
static String | ATTRIBUTE_NAME 属性キー
static String | ATTRIBUTE_VALUE 属性値
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | USER_ID ユーザID
メソッドの概要
String | getAttributeName() 属性キーを取得します。
String | getAttributeValue() 属性値を取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getUserId() ユーザIDを取得します。
void | setAttributeValue(String attributeValue) 属性値を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

USER_ID

public static final String USER_ID
ユーザID

関連項目:
定数フィールド値

ATTRIBUTE_NAME

public static final String ATTRIBUTE_NAME
属性キー

関連項目:
定数フィールド値

ATTRIBUTE_VALUE

public static final String ATTRIBUTE_VALUE
属性値

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getUserId

public String getUserId()
                 throws AccessorException
ユーザIDを取得します。

戻り値:
ユーザID
例外:
AccessorException - データの取得に失敗した場合

getAttributeName

public String getAttributeName()
                        throws AccessorException
属性キーを取得します。

戻り値:
属性キー
例外:
AccessorException - データの取得に失敗した場合

getAttributeValue

public String getAttributeValue()
                         throws AccessorException
属性値を取得します。

戻り値:
属性値
例外:
AccessorException - データの取得に失敗した場合

setAttributeValue

public void setAttributeValue(String attributeValue)
                       throws AccessorException
属性値を設定します。

パラメータ:
attributeValue - 属性値
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountAttributeMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccountAttributeMapper

すべてのスーパーインタフェース:
Mapper
public interface AccountAttributeMapper
extends Mapper

アカウントが保有する属性に関連するマッパです。

導入されたバージョン:
5.2

メソッドの概要
AccountAttributeBaseModel | create(String userId, String attributeName) プライマリキーに該当するアカウントが保有する属性を生成します。
void | delete(AccountAttributeBaseModel model) アカウントが保有する属性の基本モデルを1つだけ削除します。
void | delete(Collection models) アカウントが保有する属性の基本モデルを複数削除します。
void | insert(AccountAttributeBaseModel model) アカウントが保有する属性の基本モデルを1つだけ挿入します。
void | insert(Collection models) アカウントが保有する属性の基本モデルを複数挿入します。
AccountAttributeBaseModel | select(String userId, String attributeName) プライマリーキーで特定されるアカウントが保有する属性の基本モデルを取得します。
void | update(AccountAttributeBaseModel model) アカウントが保有する属性の基本モデルを1つだけ更新します。
void | update(Collection models) アカウントが保有する属性の基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public AccountAttributeBaseModel create(String userId,
                                        String attributeName)
                                 throws MapperException
プライマリキーに該当するアカウントが保有する属性を生成します。

パラメータ:
userId - ユーザID
attributeName - 属性キー
戻り値:
プライマリキーに該当するアカウントが保有する属性の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public AccountAttributeBaseModel select(String userId,
                                        String attributeName)
                                 throws MapperException
プライマリーキーで特定されるアカウントが保有する属性の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
userId - ユーザID
attributeName - 属性キー
戻り値:
アカウントが保有する属性の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(AccountAttributeBaseModel model)
            throws MapperException
アカウントが保有する属性の基本モデルを1つだけ挿入します。 引数に指定するアカウントが保有する属性の基本モデルは同一の AccountAttributeMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するアカウントが保有する属性の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
アカウントが保有する属性の基本モデルを複数挿入します。 引数に指定するものは同一の AccountAttributeMapperの create(String,String) で生成されたアカウントが保有する属性の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するアカウントが保有する属性の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(AccountAttributeBaseModel model)
            throws MapperException
アカウントが保有する属性の基本モデルを1つだけ更新します。 引数に指定するアカウントが保有する属性の基本モデルは同一の AccountAttributeMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するアカウントが保有する属性の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
アカウントが保有する属性の基本モデルを複数更新します。 引数に指定するものは同一の AccountAttributeMapperの select 系メソッド から取得されたものかで生成されたアカウントが保有する属性の基本モデルの集合である必要があります。

パラメータ:
models - 更新するアカウントが保有する属性の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(AccountAttributeBaseModel model)
            throws MapperException
アカウントが保有する属性の基本モデルを1つだけ削除します。 引数で指定されたアカウントが保有する属性の基本モデルに該当するデータのすべての情報を削除します。引数に指定するアカウントが保有する属性の基本モデルは同一の AccountAttributeMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するアカウントが保有する属性の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
アカウントが保有する属性の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するアカウントが保有する属性の基本モデルは同一の AccountAttributeMapperの select 系メソッド から取得されたアカウントが保有する属性の基本モデルの集合である必要があります。

パラメータ:
models - 削除するアカウントが保有する属性の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccountBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface AccountBaseModel
extends BaseModel

アカウントの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | COLOR_PATTERN_ID ページカラーパターン
static String | ENCODING エンコーディング
static String | GO_OUT 外出フラグ
static String | LOCALE ロケール
static String | LOCK_DATE アカウントロック日付
static String | LOGIN_FAILURE_COUNT ログイン失敗回数
static String | MOBILE_PASSWORD モバイル用パスワード
static String | NOTES 説明
static String | PAGE_PATTERN_ID メインページパターン
static String | PASSWORD パスワード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | USER_ID ユーザID
static String | VALID_END_DATE 有効終了日
static String | VALID_START_DATE 有効開始日
メソッドの概要
String | getColorPatternId() ページカラーパターンを取得します。
String | getEncoding() エンコーディングを取得します。
String | getGoOut() 外出フラグを取得します。
String | getLocale() ロケールを取得します。
String | getLockDate() アカウントロック日付を取得します。
int | getLoginFailureCount() ログイン失敗回数を取得します。
String | getMobilePassword() モバイル用パスワードを取得します。
String | getNotes() 説明を取得します。
String | getPagePatternId() メインページパターンを取得します。
String | getPassword() パスワードを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getUserId() ユーザIDを取得します。
String | getValidEndDate() 有効終了日を取得します。
String | getValidStartDate() 有効開始日を取得します。
void | setColorPatternId(String colorPatternId) ページカラーパターンを設定します。
void | setEncoding(String encoding) エンコーディングを設定します。
void | setGoOut(String goOut) 外出フラグを設定します。
void | setLocale(String locale) ロケールを設定します。
void | setLockDate(String lockDate) アカウントロック日付を設定します。
void | setLoginFailureCount(int loginFailureCount) ログイン失敗回数を設定します。
void | setMobilePassword(String mobilePassword) モバイル用パスワードを設定します。
void | setNotes(String notes) 説明を設定します。
void | setPagePatternId(String pagePatternId) メインページパターンを設定します。
void | setPassword(String password) パスワードを設定します。
void | setValidEndDate(String validEndDate) 有効終了日を設定します。
void | setValidStartDate(String validStartDate) 有効開始日を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

USER_ID

public static final String USER_ID
ユーザID

関連項目:
定数フィールド値

LOCALE

public static final String LOCALE
ロケール

関連項目:
定数フィールド値

ENCODING

public static final String ENCODING
エンコーディング

関連項目:
定数フィールド値

PASSWORD

public static final String PASSWORD
パスワード

関連項目:
定数フィールド値

MOBILE_PASSWORD

public static final String MOBILE_PASSWORD
モバイル用パスワード

関連項目:
定数フィールド値

NOTES

public static final String NOTES
説明

関連項目:
定数フィールド値

VALID_START_DATE

public static final String VALID_START_DATE
有効開始日

関連項目:
定数フィールド値

VALID_END_DATE

public static final String VALID_END_DATE
有効終了日

関連項目:
定数フィールド値

GO_OUT

public static final String GO_OUT
外出フラグ

関連項目:
定数フィールド値

LOCK_DATE

public static final String LOCK_DATE
アカウントロック日付

関連項目:
定数フィールド値

LOGIN_FAILURE_COUNT

public static final String LOGIN_FAILURE_COUNT
ログイン失敗回数

関連項目:
定数フィールド値

PAGE_PATTERN_ID

public static final String PAGE_PATTERN_ID
メインページパターン

関連項目:
定数フィールド値

COLOR_PATTERN_ID

public static final String COLOR_PATTERN_ID
ページカラーパターン

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getUserId

public String getUserId()
                 throws AccessorException
ユーザIDを取得します。

戻り値:
ユーザID
例外:
AccessorException - データの取得に失敗した場合

getLocale

public String getLocale()
                 throws AccessorException
ロケールを取得します。

戻り値:
ロケール
例外:
AccessorException - データの取得に失敗した場合

setLocale

public void setLocale(String locale)
               throws AccessorException
ロケールを設定します。

パラメータ:
locale - ロケール
例外:
AccessorException - データの設定に失敗した場合

getEncoding

public String getEncoding()
                   throws AccessorException
エンコーディングを取得します。

戻り値:
エンコーディング
例外:
AccessorException - データの取得に失敗した場合

setEncoding

public void setEncoding(String encoding)
                 throws AccessorException
エンコーディングを設定します。

パラメータ:
encoding - エンコーディング
例外:
AccessorException - データの設定に失敗した場合

getPassword

public String getPassword()
                   throws AccessorException
パスワードを取得します。

戻り値:
パスワード
例外:
AccessorException - データの取得に失敗した場合

setPassword

public void setPassword(String password)
                 throws AccessorException
パスワードを設定します。

パラメータ:
password - パスワード
例外:
AccessorException - データの設定に失敗した場合

getMobilePassword

public String getMobilePassword()
                         throws AccessorException
モバイル用パスワードを取得します。

戻り値:
モバイル用パスワード
例外:
AccessorException - データの取得に失敗した場合

setMobilePassword

public void setMobilePassword(String mobilePassword)
                       throws AccessorException
モバイル用パスワードを設定します。

パラメータ:
mobilePassword - モバイル用パスワード
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
説明を取得します。

戻り値:
説明
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
説明を設定します。

パラメータ:
notes - 説明
例外:
AccessorException - データの設定に失敗した場合

getValidStartDate

public String getValidStartDate()
                         throws AccessorException
有効開始日を取得します。

戻り値:
有効開始日
例外:
AccessorException - データの取得に失敗した場合

setValidStartDate

public void setValidStartDate(String validStartDate)
                       throws AccessorException
有効開始日を設定します。

パラメータ:
validStartDate - 有効開始日
例外:
AccessorException - データの設定に失敗した場合

getValidEndDate

public String getValidEndDate()
                       throws AccessorException
有効終了日を取得します。

戻り値:
有効終了日
例外:
AccessorException - データの取得に失敗した場合

setValidEndDate

public void setValidEndDate(String validEndDate)
                     throws AccessorException
有効終了日を設定します。

パラメータ:
validEndDate - 有効終了日
例外:
AccessorException - データの設定に失敗した場合

getGoOut

public String getGoOut()
                throws AccessorException
外出フラグを取得します。

戻り値:
外出フラグ
例外:
AccessorException - データの取得に失敗した場合

setGoOut

public void setGoOut(String goOut)
              throws AccessorException
外出フラグを設定します。

パラメータ:
goOut - 外出フラグ
例外:
AccessorException - データの設定に失敗した場合

getLockDate

public String getLockDate()
                   throws AccessorException
アカウントロック日付を取得します。

戻り値:
アカウントロック日付
例外:
AccessorException - データの取得に失敗した場合

setLockDate

public void setLockDate(String lockDate)
                 throws AccessorException
アカウントロック日付を設定します。

パラメータ:
lockDate - アカウントロック日付
例外:
AccessorException - データの設定に失敗した場合

getLoginFailureCount

public int getLoginFailureCount()
                         throws AccessorException
ログイン失敗回数を取得します。

戻り値:
ログイン失敗回数
例外:
AccessorException - データの取得に失敗した場合

setLoginFailureCount

public void setLoginFailureCount(int loginFailureCount)
                          throws AccessorException
ログイン失敗回数を設定します。

パラメータ:
loginFailureCount - ログイン失敗回数
例外:
AccessorException - データの設定に失敗した場合

getPagePatternId

public String getPagePatternId()
                        throws AccessorException
メインページパターンを取得します。

戻り値:
メインページパターン
例外:
AccessorException - データの取得に失敗した場合

setPagePatternId

public void setPagePatternId(String pagePatternId)
                      throws AccessorException
メインページパターンを設定します。

パラメータ:
pagePatternId - メインページパターン
例外:
AccessorException - データの設定に失敗した場合

getColorPatternId

public String getColorPatternId()
                         throws AccessorException
ページカラーパターンを取得します。

戻り値:
ページカラーパターン
例外:
AccessorException - データの取得に失敗した場合

setColorPatternId

public void setColorPatternId(String colorPatternId)
                       throws AccessorException
ページカラーパターンを設定します。

パラメータ:
colorPatternId - ページカラーパターン
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccountMapper

すべてのスーパーインタフェース:
Mapper
public interface AccountMapper
extends Mapper

アカウントに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
AccountBaseModel | create(String userId) プライマリキーに該当するアカウントを生成します。
void | delete(AccountBaseModel model) アカウントの基本モデルを1つだけ削除します。
void | delete(Collection models) アカウントの基本モデルを複数削除します。
void | insert(AccountBaseModel model) アカウントの基本モデルを1つだけ挿入します。
void | insert(Collection models) アカウントの基本モデルを複数挿入します。
AccountBaseModel | select(String userId) プライマリーキーで特定されるアカウントの基本モデルを取得します。
void | update(AccountBaseModel model) アカウントの基本モデルを1つだけ更新します。
void | update(Collection models) アカウントの基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public AccountBaseModel create(String userId)
                        throws MapperException
プライマリキーに該当するアカウントを生成します。

パラメータ:
userId - ユーザID
戻り値:
プライマリキーに該当するアカウントの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public AccountBaseModel select(String userId)
                        throws MapperException
プライマリーキーで特定されるアカウントの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
userId - ユーザID
戻り値:
アカウントの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(AccountBaseModel model)
            throws MapperException
アカウントの基本モデルを1つだけ挿入します。 引数に指定するアカウントの基本モデルは同一の AccountMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入するアカウントの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
アカウントの基本モデルを複数挿入します。 引数に指定するものは同一の AccountMapperの create(String) で生成されたアカウントの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するアカウントの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(AccountBaseModel model)
            throws MapperException
アカウントの基本モデルを1つだけ更新します。 引数に指定するアカウントの基本モデルは同一の AccountMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するアカウントの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
アカウントの基本モデルを複数更新します。 引数に指定するものは同一の AccountMapperの select 系メソッド から取得されたものかで生成されたアカウントの基本モデルの集合である必要があります。

パラメータ:
models - 更新するアカウントの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(AccountBaseModel model)
            throws MapperException
アカウントの基本モデルを1つだけ削除します。 引数で指定されたアカウントの基本モデルに該当するデータのすべての情報を削除します。引数に指定するアカウントの基本モデルは同一の AccountMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するアカウントの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
アカウントの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するアカウントの基本モデルは同一の AccountMapperの select 系メソッド から取得されたアカウントの基本モデルの集合である必要があります。

パラメータ:
models - 削除するアカウントの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountRoleBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccountRoleBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface AccountRoleBaseModel
extends BaseModel

アカウントが保有するロールの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | ROLE_ID メニューID
static String | USER_ID ユーザID
static String | VALID_END_DATE 有効終了日
static String | VALID_START_DATE 有効開始日
メソッドの概要
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getRoleId() メニューIDを取得します。
String | getUserId() ユーザIDを取得します。
String | getValidEndDate() 有効終了日を取得します。
String | getValidStartDate() 有効開始日を取得します。
void | setValidEndDate(String validEndDate) 有効終了日を設定します。
void | setValidStartDate(String validStartDate) 有効開始日を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

USER_ID

public static final String USER_ID
ユーザID

関連項目:
定数フィールド値

ROLE_ID

public static final String ROLE_ID
メニューID

関連項目:
定数フィールド値

VALID_START_DATE

public static final String VALID_START_DATE
有効開始日

関連項目:
定数フィールド値

VALID_END_DATE

public static final String VALID_END_DATE
有効終了日

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getUserId

public String getUserId()
                 throws AccessorException
ユーザIDを取得します。

戻り値:
ユーザID
例外:
AccessorException - データの取得に失敗した場合

getRoleId

public String getRoleId()
                 throws AccessorException
メニューIDを取得します。

戻り値:
メニューID
例外:
AccessorException - データの取得に失敗した場合

getValidStartDate

public String getValidStartDate()
                         throws AccessorException
有効開始日を取得します。

戻り値:
有効開始日
例外:
AccessorException - データの取得に失敗した場合

setValidStartDate

public void setValidStartDate(String validStartDate)
                       throws AccessorException
有効開始日を設定します。

パラメータ:
validStartDate - 有効開始日
例外:
AccessorException - データの設定に失敗した場合

getValidEndDate

public String getValidEndDate()
                       throws AccessorException
有効終了日を取得します。

戻り値:
有効終了日
例外:
AccessorException - データの取得に失敗した場合

setValidEndDate

public void setValidEndDate(String validEndDate)
                     throws AccessorException
有効終了日を設定します。

パラメータ:
validEndDate - 有効終了日
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountRoleMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース AccountRoleMapper

すべてのスーパーインタフェース:
Mapper
public interface AccountRoleMapper
extends Mapper

アカウントが保有するロールに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
AccountRoleBaseModel | create(String userId, String roleId) プライマリキーに該当するアカウントが保有するロールを生成します。
void | delete(AccountRoleBaseModel model) アカウントが保有するロールの基本モデルを1つだけ削除します。
void | delete(Collection models) アカウントが保有するロールの基本モデルを複数削除します。
void | insert(AccountRoleBaseModel model) アカウントが保有するロールの基本モデルを1つだけ挿入します。
void | insert(Collection models) アカウントが保有するロールの基本モデルを複数挿入します。
AccountRoleBaseModel | select(String userId, String roleId) プライマリーキーで特定されるアカウントが保有するロールの基本モデルを取得します。
void | update(AccountRoleBaseModel model) アカウントが保有するロールの基本モデルを1つだけ更新します。
void | update(Collection models) アカウントが保有するロールの基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public AccountRoleBaseModel create(String userId,
                                   String roleId)
                            throws MapperException
プライマリキーに該当するアカウントが保有するロールを生成します。

パラメータ:
userId - ユーザID
roleId - メニューID
戻り値:
プライマリキーに該当するアカウントが保有するロールの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public AccountRoleBaseModel select(String userId,
                                   String roleId)
                            throws MapperException
プライマリーキーで特定されるアカウントが保有するロールの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
userId - ユーザID
roleId - メニューID
戻り値:
アカウントが保有するロールの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(AccountRoleBaseModel model)
            throws MapperException
アカウントが保有するロールの基本モデルを1つだけ挿入します。 引数に指定するアカウントが保有するロールの基本モデルは同一の AccountRoleMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するアカウントが保有するロールの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
アカウントが保有するロールの基本モデルを複数挿入します。 引数に指定するものは同一の AccountRoleMapperの create(String,String) で生成されたアカウントが保有するロールの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するアカウントが保有するロールの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(AccountRoleBaseModel model)
            throws MapperException
アカウントが保有するロールの基本モデルを1つだけ更新します。 引数に指定するアカウントが保有するロールの基本モデルは同一の AccountRoleMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するアカウントが保有するロールの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
アカウントが保有するロールの基本モデルを複数更新します。 引数に指定するものは同一の AccountRoleMapperの select 系メソッド から取得されたものかで生成されたアカウントが保有するロールの基本モデルの集合である必要があります。

パラメータ:
models - 更新するアカウントが保有するロールの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(AccountRoleBaseModel model)
            throws MapperException
アカウントが保有するロールの基本モデルを1つだけ削除します。 引数で指定されたアカウントが保有するロールの基本モデルに該当するデータのすべての情報を削除します。引数に指定するアカウントが保有するロールの基本モデルは同一の AccountRoleMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するアカウントが保有するロールの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
アカウントが保有するロールの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するアカウントが保有するロールの基本モデルは同一の AccountRoleMapperの select 系メソッド から取得されたアカウントが保有するロールの基本モデルの集合である必要があります。

パラメータ:
models - 削除するアカウントが保有するロールの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BatchBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース BatchBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface BatchBaseModel
extends BaseModel

バッチ情報の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | BATCH_ID バッチID
static String | BATCH_NAME バッチ名
static String | PROGRAM_LANGUAGE 実行プログラム言語
static String | PROGRAM_PATH 実行プログラムパス
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | RUN_DAY 実行日
static String | RUN_DAY_WEEK 実行曜日
static String | RUN_HOUR 実行時
static String | RUN_MINUTE 実行分
static String | RUN_MONTH 実行月
static String | RUN_SECOND 実行秒
static String | RUN_YEAR 実行年
static String | VALID_FLG 有効フラグ
メソッドの概要
String | getBatchId() バッチIDを取得します。
String | getBatchName() バッチ名を取得します。
String | getProgramLanguage() 実行プログラム言語を取得します。
String | getProgramPath() 実行プログラムパスを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getRunDay() 実行日を取得します。
int | getRunDayWeek() 実行曜日を取得します。
int | getRunHour() 実行時を取得します。
int | getRunMinute() 実行分を取得します。
int | getRunMonth() 実行月を取得します。
int | getRunSecond() 実行秒を取得します。
int | getRunYear() 実行年を取得します。
String | getValidFlg() 有効フラグを取得します。
void | setBatchName(String batchName) バッチ名を設定します。
void | setProgramLanguage(String programLanguage) 実行プログラム言語を設定します。
void | setProgramPath(String programPath) 実行プログラムパスを設定します。
void | setRunDay(int runDay) 実行日を設定します。
void | setRunDayWeek(int runDayWeek) 実行曜日を設定します。
void | setRunHour(int runHour) 実行時を設定します。
void | setRunMinute(int runMinute) 実行分を設定します。
void | setRunMonth(int runMonth) 実行月を設定します。
void | setRunSecond(int runSecond) 実行秒を設定します。
void | setRunYear(int runYear) 実行年を設定します。
void | setValidFlg(String validFlg) 有効フラグを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

BATCH_ID

public static final String BATCH_ID
バッチID

関連項目:
定数フィールド値

BATCH_NAME

public static final String BATCH_NAME
バッチ名

関連項目:
定数フィールド値

PROGRAM_LANGUAGE

public static final String PROGRAM_LANGUAGE
実行プログラム言語

関連項目:
定数フィールド値

PROGRAM_PATH

public static final String PROGRAM_PATH
実行プログラムパス

関連項目:
定数フィールド値

RUN_YEAR

public static final String RUN_YEAR
実行年

関連項目:
定数フィールド値

RUN_MONTH

public static final String RUN_MONTH
実行月

関連項目:
定数フィールド値

RUN_DAY

public static final String RUN_DAY
実行日

関連項目:
定数フィールド値

RUN_DAY_WEEK

public static final String RUN_DAY_WEEK
実行曜日

関連項目:
定数フィールド値

RUN_HOUR

public static final String RUN_HOUR
実行時

関連項目:
定数フィールド値

RUN_MINUTE

public static final String RUN_MINUTE
実行分

関連項目:
定数フィールド値

RUN_SECOND

public static final String RUN_SECOND
実行秒

関連項目:
定数フィールド値

VALID_FLG

public static final String VALID_FLG
有効フラグ

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getBatchId

public String getBatchId()
                  throws AccessorException
バッチIDを取得します。

戻り値:
バッチID
例外:
AccessorException - データの取得に失敗した場合

getBatchName

public String getBatchName()
                    throws AccessorException
バッチ名を取得します。

戻り値:
バッチ名
例外:
AccessorException - データの取得に失敗した場合

setBatchName

public void setBatchName(String batchName)
                  throws AccessorException
バッチ名を設定します。

パラメータ:
batchName - バッチ名
例外:
AccessorException - データの設定に失敗した場合

getProgramLanguage

public String getProgramLanguage()
                          throws AccessorException
実行プログラム言語を取得します。

戻り値:
実行プログラム言語
例外:
AccessorException - データの取得に失敗した場合

setProgramLanguage

public void setProgramLanguage(String programLanguage)
                        throws AccessorException
実行プログラム言語を設定します。

パラメータ:
programLanguage - 実行プログラム言語
例外:
AccessorException - データの設定に失敗した場合

getProgramPath

public String getProgramPath()
                      throws AccessorException
実行プログラムパスを取得します。

戻り値:
実行プログラムパス
例外:
AccessorException - データの取得に失敗した場合

setProgramPath

public void setProgramPath(String programPath)
                    throws AccessorException
実行プログラムパスを設定します。

パラメータ:
programPath - 実行プログラムパス
例外:
AccessorException - データの設定に失敗した場合

getRunYear

public int getRunYear()
               throws AccessorException
実行年を取得します。

戻り値:
実行年
例外:
AccessorException - データの取得に失敗した場合

setRunYear

public void setRunYear(int runYear)
                throws AccessorException
実行年を設定します。

パラメータ:
runYear - 実行年
例外:
AccessorException - データの設定に失敗した場合

getRunMonth

public int getRunMonth()
                throws AccessorException
実行月を取得します。

戻り値:
実行月
例外:
AccessorException - データの取得に失敗した場合

setRunMonth

public void setRunMonth(int runMonth)
                 throws AccessorException
実行月を設定します。

パラメータ:
runMonth - 実行月
例外:
AccessorException - データの設定に失敗した場合

getRunDay

public int getRunDay()
              throws AccessorException
実行日を取得します。

戻り値:
実行日
例外:
AccessorException - データの取得に失敗した場合

setRunDay

public void setRunDay(int runDay)
               throws AccessorException
実行日を設定します。

パラメータ:
runDay - 実行日
例外:
AccessorException - データの設定に失敗した場合

getRunDayWeek

public int getRunDayWeek()
                  throws AccessorException
実行曜日を取得します。

戻り値:
実行曜日
例外:
AccessorException - データの取得に失敗した場合

setRunDayWeek

public void setRunDayWeek(int runDayWeek)
                   throws AccessorException
実行曜日を設定します。

パラメータ:
runDayWeek - 実行曜日
例外:
AccessorException - データの設定に失敗した場合

getRunHour

public int getRunHour()
               throws AccessorException
実行時を取得します。

戻り値:
実行時
例外:
AccessorException - データの取得に失敗した場合

setRunHour

public void setRunHour(int runHour)
                throws AccessorException
実行時を設定します。

パラメータ:
runHour - 実行時
例外:
AccessorException - データの設定に失敗した場合

getRunMinute

public int getRunMinute()
                 throws AccessorException
実行分を取得します。

戻り値:
実行分
例外:
AccessorException - データの取得に失敗した場合

setRunMinute

public void setRunMinute(int runMinute)
                  throws AccessorException
実行分を設定します。

パラメータ:
runMinute - 実行分
例外:
AccessorException - データの設定に失敗した場合

getRunSecond

public int getRunSecond()
                 throws AccessorException
実行秒を取得します。

戻り値:
実行秒
例外:
AccessorException - データの取得に失敗した場合

setRunSecond

public void setRunSecond(int runSecond)
                  throws AccessorException
実行秒を設定します。

パラメータ:
runSecond - 実行秒
例外:
AccessorException - データの設定に失敗した場合

getValidFlg

public String getValidFlg()
                   throws AccessorException
有効フラグを取得します。

戻り値:
有効フラグ
例外:
AccessorException - データの取得に失敗した場合

setValidFlg

public void setValidFlg(String validFlg)
                 throws AccessorException
有効フラグを設定します。

パラメータ:
validFlg - 有効フラグ
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BatchMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース BatchMapper

すべてのスーパーインタフェース:
Mapper
public interface BatchMapper
extends Mapper

バッチ情報に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
BatchBaseModel | create(String batchId) プライマリキーに該当するバッチ情報を生成します。
void | delete(BatchBaseModel model) バッチ情報の基本モデルを1つだけ削除します。
void | delete(Collection models) バッチ情報の基本モデルを複数削除します。
void | insert(BatchBaseModel model) バッチ情報の基本モデルを1つだけ挿入します。
void | insert(Collection models) バッチ情報の基本モデルを複数挿入します。
BatchBaseModel | select(String batchId) プライマリーキーで特定されるバッチ情報の基本モデルを取得します。
void | update(BatchBaseModel model) バッチ情報の基本モデルを1つだけ更新します。
void | update(Collection models) バッチ情報の基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public BatchBaseModel create(String batchId)
                      throws MapperException
プライマリキーに該当するバッチ情報を生成します。

パラメータ:
batchId - バッチID
戻り値:
プライマリキーに該当するバッチ情報の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public BatchBaseModel select(String batchId)
                      throws MapperException
プライマリーキーで特定されるバッチ情報の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
batchId - バッチID
戻り値:
バッチ情報の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(BatchBaseModel model)
            throws MapperException
バッチ情報の基本モデルを1つだけ挿入します。 引数に指定するバッチ情報の基本モデルは同一の BatchMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入するバッチ情報の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
バッチ情報の基本モデルを複数挿入します。 引数に指定するものは同一の BatchMapperの create(String) で生成されたバッチ情報の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するバッチ情報の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(BatchBaseModel model)
            throws MapperException
バッチ情報の基本モデルを1つだけ更新します。 引数に指定するバッチ情報の基本モデルは同一の BatchMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するバッチ情報の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
バッチ情報の基本モデルを複数更新します。 引数に指定するものは同一の BatchMapperの select 系メソッド から取得されたものかで生成されたバッチ情報の基本モデルの集合である必要があります。

パラメータ:
models - 更新するバッチ情報の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(BatchBaseModel model)
            throws MapperException
バッチ情報の基本モデルを1つだけ削除します。 引数で指定されたバッチ情報の基本モデルに該当するデータのすべての情報を削除します。引数に指定するバッチ情報の基本モデルは同一の BatchMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するバッチ情報の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
バッチ情報の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するバッチ情報の基本モデルは同一の BatchMapperの select 系メソッド から取得されたバッチ情報の基本モデルの集合である必要があります。

パラメータ:
models - 削除するバッチ情報の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarInfoBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース CalendarInfoBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface CalendarInfoBaseModel
extends BaseModel

カレンダーが保有するデータの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | CALENDAR_ID カレンダーID
static String | COLOR 表示色
static String | DATA_ID データID
static String | DATA_NAME データ名称
static String | DATA_TYPE データタイプ
static String | DAY 日
static String | DAY_WEEK 曜日
static String | DISPLAY_NAME データ表示名
static String | MONTH 月
static String | PLUGIN_METHOD プラグイン関数
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | TIMES 次
static String | VALID_END_YEAR 有効終了年
static String | VALID_START_YEAR 有効開始年
static String | WEEK 週
static String | YEAR 年
メソッドの概要
String | getCalendarId() カレンダーIDを取得します。
String | getColor() 表示色を取得します。
String | getDataId() データIDを取得します。
String | getDataName() データ名称を取得します。
String | getDataType() データタイプを取得します。
int | getDay() 日を取得します。
int | getDayWeek() 曜日を取得します。
String | getDisplayName() データ表示名を取得します。
String | getDisplayName(Locale locale) データ表示名を取得します。
int | getMonth() 月を取得します。
String | getPluginMethod() プラグイン関数を取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getTimes() 次を取得します。
int | getValidEndYear() 有効終了年を取得します。
int | getValidStartYear() 有効開始年を取得します。
int | getWeek() 週を取得します。
int | getYear() 年を取得します。
CalendarInfoInternationalModel | selectCalendarInfoInternationalModel(Locale locale) 指定された言語に該当するカレンダーが保有するデータの国際化モデルを取得します。
void | setColor(String color) 表示色を設定します。
void | setDataName(String dataName) データ名称を設定します。
void | setDataType(String dataType) データタイプを設定します。
void | setDay(int day) 日を設定します。
void | setDayWeek(int dayWeek) 曜日を設定します。
void | setDisplayName(String displayName) データ表示名を設定します。
void | setDisplayName(String displayName, Locale locale) データ表示名を設定します。
void | setMonth(int month) 月を設定します。
void | setPluginMethod(String pluginMethod) プラグイン関数を設定します。
void | setTimes(int times) 次を設定します。
void | setValidEndYear(int validEndYear) 有効終了年を設定します。
void | setValidStartYear(int validStartYear) 有効開始年を設定します。
void | setWeek(int week) 週を設定します。
void | setYear(int year) 年を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

CALENDAR_ID

public static final String CALENDAR_ID
カレンダーID

関連項目:
定数フィールド値

DATA_ID

public static final String DATA_ID
データID

関連項目:
定数フィールド値

DATA_TYPE

public static final String DATA_TYPE
データタイプ

関連項目:
定数フィールド値

DATA_NAME

public static final String DATA_NAME
データ名称

関連項目:
定数フィールド値

YEAR

public static final String YEAR
年

関連項目:
定数フィールド値

MONTH

public static final String MONTH
月

関連項目:
定数フィールド値

DAY

public static final String DAY
日

関連項目:
定数フィールド値

WEEK

public static final String WEEK
週

関連項目:
定数フィールド値

TIMES

public static final String TIMES
次

関連項目:
定数フィールド値

DAY_WEEK

public static final String DAY_WEEK
曜日

関連項目:
定数フィールド値

VALID_START_YEAR

public static final String VALID_START_YEAR
有効開始年

関連項目:
定数フィールド値

VALID_END_YEAR

public static final String VALID_END_YEAR
有効終了年

関連項目:
定数フィールド値

PLUGIN_METHOD

public static final String PLUGIN_METHOD
プラグイン関数

関連項目:
定数フィールド値

COLOR

public static final String COLOR
表示色

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

DISPLAY_NAME

public static final String DISPLAY_NAME
データ表示名

関連項目:
定数フィールド値
メソッドの詳細

getCalendarId

public String getCalendarId()
                     throws AccessorException
カレンダーIDを取得します。

戻り値:
カレンダーID
例外:
AccessorException - データの取得に失敗した場合

getDataId

public String getDataId()
                 throws AccessorException
データIDを取得します。

戻り値:
データID
例外:
AccessorException - データの取得に失敗した場合

getDataType

public String getDataType()
                   throws AccessorException
データタイプを取得します。

戻り値:
データタイプ
例外:
AccessorException - データの取得に失敗した場合

setDataType

public void setDataType(String dataType)
                 throws AccessorException
データタイプを設定します。

パラメータ:
dataType - データタイプ
例外:
AccessorException - データの設定に失敗した場合

getDataName

public String getDataName()
                   throws AccessorException
データ名称を取得します。

戻り値:
データ名称
例外:
AccessorException - データの取得に失敗した場合

setDataName

public void setDataName(String dataName)
                 throws AccessorException
データ名称を設定します。

パラメータ:
dataName - データ名称
例外:
AccessorException - データの設定に失敗した場合

getYear

public int getYear()
            throws AccessorException
年を取得します。

戻り値:
年
例外:
AccessorException - データの取得に失敗した場合

setYear

public void setYear(int year)
             throws AccessorException
年を設定します。

パラメータ:
year - 年
例外:
AccessorException - データの設定に失敗した場合

getMonth

public int getMonth()
             throws AccessorException
月を取得します。

戻り値:
月
例外:
AccessorException - データの取得に失敗した場合

setMonth

public void setMonth(int month)
              throws AccessorException
月を設定します。

パラメータ:
month - 月
例外:
AccessorException - データの設定に失敗した場合

getDay

public int getDay()
           throws AccessorException
日を取得します。

戻り値:
日
例外:
AccessorException - データの取得に失敗した場合

setDay

public void setDay(int day)
            throws AccessorException
日を設定します。

パラメータ:
day - 日
例外:
AccessorException - データの設定に失敗した場合

getWeek

public int getWeek()
            throws AccessorException
週を取得します。

戻り値:
週
例外:
AccessorException - データの取得に失敗した場合

setWeek

public void setWeek(int week)
             throws AccessorException
週を設定します。

パラメータ:
week - 週
例外:
AccessorException - データの設定に失敗した場合

getTimes

public int getTimes()
             throws AccessorException
次を取得します。

戻り値:
次
例外:
AccessorException - データの取得に失敗した場合

setTimes

public void setTimes(int times)
              throws AccessorException
次を設定します。

パラメータ:
times - 次
例外:
AccessorException - データの設定に失敗した場合

getDayWeek

public int getDayWeek()
               throws AccessorException
曜日を取得します。

戻り値:
曜日
例外:
AccessorException - データの取得に失敗した場合

setDayWeek

public void setDayWeek(int dayWeek)
                throws AccessorException
曜日を設定します。

パラメータ:
dayWeek - 曜日
例外:
AccessorException - データの設定に失敗した場合

getValidStartYear

public int getValidStartYear()
                      throws AccessorException
有効開始年を取得します。

戻り値:
有効開始年
例外:
AccessorException - データの取得に失敗した場合

setValidStartYear

public void setValidStartYear(int validStartYear)
                       throws AccessorException
有効開始年を設定します。

パラメータ:
validStartYear - 有効開始年
例外:
AccessorException - データの設定に失敗した場合

getValidEndYear

public int getValidEndYear()
                    throws AccessorException
有効終了年を取得します。

戻り値:
有効終了年
例外:
AccessorException - データの取得に失敗した場合

setValidEndYear

public void setValidEndYear(int validEndYear)
                     throws AccessorException
有効終了年を設定します。

パラメータ:
validEndYear - 有効終了年
例外:
AccessorException - データの設定に失敗した場合

getPluginMethod

public String getPluginMethod()
                       throws AccessorException
プラグイン関数を取得します。

戻り値:
プラグイン関数
例外:
AccessorException - データの取得に失敗した場合

setPluginMethod

public void setPluginMethod(String pluginMethod)
                     throws AccessorException
プラグイン関数を設定します。

パラメータ:
pluginMethod - プラグイン関数
例外:
AccessorException - データの設定に失敗した場合

getColor

public String getColor()
                throws AccessorException
表示色を取得します。

戻り値:
表示色
例外:
AccessorException - データの取得に失敗した場合

setColor

public void setColor(String color)
              throws AccessorException
表示色を設定します。

パラメータ:
color - 表示色
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getDisplayName

public String getDisplayName()
                      throws AccessorException
データ表示名を取得します。

戻り値:
データ表示名
例外:
AccessorException - データの取得に失敗した場合

getDisplayName

public String getDisplayName(Locale locale)
                      throws AccessorException
データ表示名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
データ表示名
例外:
AccessorException - データの取得に失敗した場合

setDisplayName

public void setDisplayName(String displayName)
                    throws AccessorException
データ表示名を設定します。

パラメータ:
displayName - データ表示名
例外:
AccessorException - データの設定に失敗した場合

setDisplayName

public void setDisplayName(String displayName,
                           Locale locale)
                    throws AccessorException
データ表示名を設定します。

パラメータ:
displayName - データ表示名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectCalendarInfoInternationalModel

public CalendarInfoInternationalModel selectCalendarInfoInternationalModel(Locale locale)
                                                                    throws IllegalLocaleException
指定された言語に該当するカレンダーが保有するデータの国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
カレンダーが保有するデータの国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarInfoInternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース CalendarInfoInternationalModel

すべてのスーパーインタフェース:
InternationalModel, Serializable
public interface CalendarInfoInternationalModel
extends InternationalModel

カレンダーが保有するデータの国際化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getDisplayName() データ表示名を取得します。
void | setDisplayName(String displayName) データ表示名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModel から継承したメソッド
getExtendedInternationalModelMap, getLocale, init

メソッドの詳細

getDisplayName

public String getDisplayName()
                      throws AccessorException
データ表示名を取得します。

戻り値:
データ表示名
例外:
AccessorException - データの取得に失敗した場合

setDisplayName

public void setDisplayName(String displayName)
                    throws AccessorException
データ表示名を設定します。

パラメータ:
displayName - データ表示名
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarInfoMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース CalendarInfoMapper

すべてのスーパーインタフェース:
Mapper
public interface CalendarInfoMapper
extends Mapper

カレンダーが保有するデータに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
CalendarInfoBaseModel | create(String calendarId, String dataId) プライマリキーに該当するカレンダーが保有するデータを生成します。
void | delete(CalendarInfoBaseModel model) カレンダーが保有するデータの基本モデルを1つだけ削除します。
void | delete(Collection models) カレンダーが保有するデータの基本モデルを複数削除します。
void | insert(CalendarInfoBaseModel model) カレンダーが保有するデータの基本モデルを1つだけ挿入します。
void | insert(Collection models) カレンダーが保有するデータの基本モデルを複数挿入します。
CalendarInfoBaseModel | select(String calendarId, String dataId) プライマリーキーで特定されるカレンダーが保有するデータの基本モデルを取得します。
void | update(CalendarInfoBaseModel model) カレンダーが保有するデータの基本モデルを1つだけ更新します。
void | update(Collection models) カレンダーが保有するデータの基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public CalendarInfoBaseModel create(String calendarId,
                                    String dataId)
                             throws MapperException
プライマリキーに該当するカレンダーが保有するデータを生成します。

パラメータ:
calendarId - カレンダーID
dataId - データID
戻り値:
プライマリキーに該当するカレンダーが保有するデータの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public CalendarInfoBaseModel select(String calendarId,
                                    String dataId)
                             throws MapperException
プライマリーキーで特定されるカレンダーが保有するデータの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
calendarId - カレンダーID
dataId - データID
戻り値:
カレンダーが保有するデータの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(CalendarInfoBaseModel model)
            throws MapperException
カレンダーが保有するデータの基本モデルを1つだけ挿入します。 引数に指定するカレンダーが保有するデータの基本モデルは同一の CalendarInfoMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するカレンダーが保有するデータの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
カレンダーが保有するデータの基本モデルを複数挿入します。 引数に指定するものは同一の CalendarInfoMapperの create(String,String) で生成されたカレンダーが保有するデータの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するカレンダーが保有するデータの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(CalendarInfoBaseModel model)
            throws MapperException
カレンダーが保有するデータの基本モデルを1つだけ更新します。 引数に指定するカレンダーが保有するデータの基本モデルは同一の CalendarInfoMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するカレンダーが保有するデータの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
カレンダーが保有するデータの基本モデルを複数更新します。 引数に指定するものは同一の CalendarInfoMapperの select 系メソッド から取得されたものかで生成されたカレンダーが保有するデータの基本モデルの集合である必要があります。

パラメータ:
models - 更新するカレンダーが保有するデータの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(CalendarInfoBaseModel model)
            throws MapperException
カレンダーが保有するデータの基本モデルを1つだけ削除します。 引数で指定されたカレンダーが保有するデータの基本モデルに該当するデータのすべての情報を削除します。引数に指定するカレンダーが保有するデータの基本モデルは同一の CalendarInfoMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するカレンダーが保有するデータの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
カレンダーが保有するデータの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するカレンダーが保有するデータの基本モデルは同一の CalendarInfoMapperの select 系メソッド から取得されたカレンダーが保有するデータの基本モデルの集合である必要があります。

パラメータ:
models - 削除するカレンダーが保有するデータの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataStoreConst (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース DataStoreConst

すべてのスーパーインタフェース:
Serializable
public interface DataStoreConst
extends Serializable

データストアの定数クラス

導入されたバージョン:
5.0

フィールドの概要
static String | ACCESS_CONTROLLER アクセスコントローラ情報
static String | ACCESS_CONTROLLER_DEPARTMENT アクセスコントローラの利用権限を保有する組織
static String | ACCESS_CONTROLLER_POST アクセスコントローラの利用権限を保有する役職
static String | ACCESS_CONTROLLER_PUBLIC_GROUP アクセスコントローラの利用権限を保有するパブリックグループ
static String | ACCESS_CONTROLLER_ROLE アクセスコントローラの利用権限を保有するロール
static String | ACCOUNT アカウント
static String | ACCOUNT_ATTRIBUTE アカウント属性
static String | ACCOUNT_ROLE アカウントが保有するロール
static String | APPLICATION_NAME アプリケーション
static String | BATCH バッチ情報
static String | CALENDAR_INFO カレンダーが保有するデータ
static String | FAVORITE_MENU アカウントが保有するメニュー
static String | MENU メニュー情報
static String | MENU_ARGUMENT メニューの保有する引数
static String | MENU_DEPARTMENT メニューの利用権限を保有する組織
static String | MENU_POST メニューの利用権限を保有する役職
static String | MENU_PUBLIC_GROUP メニューの利用権限を保有するパブリックグループ
static String | MENU_ROLE メニューの利用権限を保有するロール
static String | ROLE ロール
static String | ROLE_INCLUSION ロール内包
static String | ROLE_SUMMARY ロールサマリ

フィールドの詳細

APPLICATION_NAME

public static final String APPLICATION_NAME
アプリケーション

関連項目:
定数フィールド値

ROLE

public static final String ROLE
ロール

関連項目:
定数フィールド値

ROLE_INCLUSION

public static final String ROLE_INCLUSION
ロール内包

関連項目:
定数フィールド値

ROLE_SUMMARY

public static final String ROLE_SUMMARY
ロールサマリ

関連項目:
定数フィールド値

ACCOUNT

public static final String ACCOUNT
アカウント

関連項目:
定数フィールド値

FAVORITE_MENU

public static final String FAVORITE_MENU
アカウントが保有するメニュー

関連項目:
定数フィールド値

ACCOUNT_ROLE

public static final String ACCOUNT_ROLE
アカウントが保有するロール

関連項目:
定数フィールド値

MENU

public static final String MENU
メニュー情報

関連項目:
定数フィールド値

MENU_ARGUMENT

public static final String MENU_ARGUMENT
メニューの保有する引数

関連項目:
定数フィールド値

MENU_DEPARTMENT

public static final String MENU_DEPARTMENT
メニューの利用権限を保有する組織

関連項目:
定数フィールド値

MENU_POST

public static final String MENU_POST
メニューの利用権限を保有する役職

関連項目:
定数フィールド値

MENU_PUBLIC_GROUP

public static final String MENU_PUBLIC_GROUP
メニューの利用権限を保有するパブリックグループ

関連項目:
定数フィールド値

MENU_ROLE

public static final String MENU_ROLE
メニューの利用権限を保有するロール

関連項目:
定数フィールド値

CALENDAR_INFO

public static final String CALENDAR_INFO
カレンダーが保有するデータ

関連項目:
定数フィールド値

BATCH

public static final String BATCH
バッチ情報

関連項目:
定数フィールド値

ACCESS_CONTROLLER

public static final String ACCESS_CONTROLLER
アクセスコントローラ情報

関連項目:
定数フィールド値

ACCESS_CONTROLLER_DEPARTMENT

public static final String ACCESS_CONTROLLER_DEPARTMENT
アクセスコントローラの利用権限を保有する組織

関連項目:
定数フィールド値

ACCESS_CONTROLLER_POST

public static final String ACCESS_CONTROLLER_POST
アクセスコントローラの利用権限を保有する役職

関連項目:
定数フィールド値

ACCESS_CONTROLLER_PUBLIC_GROUP

public static final String ACCESS_CONTROLLER_PUBLIC_GROUP
アクセスコントローラの利用権限を保有するパブリックグループ

関連項目:
定数フィールド値

ACCESS_CONTROLLER_ROLE

public static final String ACCESS_CONTROLLER_ROLE
アクセスコントローラの利用権限を保有するロール

関連項目:
定数フィールド値

ACCOUNT_ATTRIBUTE

public static final String ACCOUNT_ATTRIBUTE
アカウント属性

関連項目:
定数フィールド値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FavoriteMenuBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース FavoriteMenuBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface FavoriteMenuBaseModel
extends BaseModel

アカウントが保有するメニューの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | DISPLAY_NAME メニュー表示名
static String | IMAGE_PATH イメージパス
static String | MENU_ID メニューID
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_NUMBER ソート番号
static String | USER_ID ユーザID
メソッドの概要
String | getDisplayName() メニュー表示名を取得します。
String | getImagePath() イメージパスを取得します。
String | getMenuId() メニューIDを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortNumber() ソート番号を取得します。
String | getUserId() ユーザIDを取得します。
void | setDisplayName(String displayName) メニュー表示名を設定します。
void | setImagePath(String imagePath) イメージパスを設定します。
void | setSortNumber(int sortNumber) ソート番号を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

USER_ID

public static final String USER_ID
ユーザID

関連項目:
定数フィールド値

MENU_ID

public static final String MENU_ID
メニューID

関連項目:
定数フィールド値

DISPLAY_NAME

public static final String DISPLAY_NAME
メニュー表示名

関連項目:
定数フィールド値

IMAGE_PATH

public static final String IMAGE_PATH
イメージパス

関連項目:
定数フィールド値

SORT_NUMBER

public static final String SORT_NUMBER
ソート番号

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getUserId

public String getUserId()
                 throws AccessorException
ユーザIDを取得します。

戻り値:
ユーザID
例外:
AccessorException - データの取得に失敗した場合

getMenuId

public String getMenuId()
                 throws AccessorException
メニューIDを取得します。

戻り値:
メニューID
例外:
AccessorException - データの取得に失敗した場合

getDisplayName

public String getDisplayName()
                      throws AccessorException
メニュー表示名を取得します。

戻り値:
メニュー表示名
例外:
AccessorException - データの取得に失敗した場合

setDisplayName

public void setDisplayName(String displayName)
                    throws AccessorException
メニュー表示名を設定します。

パラメータ:
displayName - メニュー表示名
例外:
AccessorException - データの設定に失敗した場合

getImagePath

public String getImagePath()
                    throws AccessorException
イメージパスを取得します。

戻り値:
イメージパス
例外:
AccessorException - データの取得に失敗した場合
導入されたバージョン:
6.0

setImagePath

public void setImagePath(String imagePath)
                  throws AccessorException
イメージパスを設定します。

パラメータ:
imagePath - イメージパス
例外:
AccessorException - データの設定に失敗した場合
導入されたバージョン:
6.0

getSortNumber

public int getSortNumber()
                  throws AccessorException
ソート番号を取得します。

戻り値:
ソート番号
例外:
AccessorException - データの取得に失敗した場合

setSortNumber

public void setSortNumber(int sortNumber)
                   throws AccessorException
ソート番号を設定します。

パラメータ:
sortNumber - ソート番号
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FavoriteMenuMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース FavoriteMenuMapper

すべてのスーパーインタフェース:
Mapper
public interface FavoriteMenuMapper
extends Mapper

アカウントが保有するメニューに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
FavoriteMenuBaseModel | create(String userId, String menuId) プライマリキーに該当するアカウントが保有するメニューを生成します。
void | delete(Collection models) アカウントが保有するメニューの基本モデルを複数削除します。
void | delete(FavoriteMenuBaseModel model) アカウントが保有するメニューの基本モデルを1つだけ削除します。
void | insert(Collection models) アカウントが保有するメニューの基本モデルを複数挿入します。
void | insert(FavoriteMenuBaseModel model) アカウントが保有するメニューの基本モデルを1つだけ挿入します。
FavoriteMenuBaseModel | select(String userId, String menuId) プライマリーキーで特定されるアカウントが保有するメニューの基本モデルを取得します。
void | update(Collection models) アカウントが保有するメニューの基本モデルを複数更新します。
void | update(FavoriteMenuBaseModel model) アカウントが保有するメニューの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public FavoriteMenuBaseModel create(String userId,
                                    String menuId)
                             throws MapperException
プライマリキーに該当するアカウントが保有するメニューを生成します。

パラメータ:
userId - ユーザID
menuId - メニューID
戻り値:
プライマリキーに該当するアカウントが保有するメニューの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public FavoriteMenuBaseModel select(String userId,
                                    String menuId)
                             throws MapperException
プライマリーキーで特定されるアカウントが保有するメニューの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
userId - ユーザID
menuId - メニューID
戻り値:
アカウントが保有するメニューの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(FavoriteMenuBaseModel model)
            throws MapperException
アカウントが保有するメニューの基本モデルを1つだけ挿入します。 引数に指定するアカウントが保有するメニューの基本モデルは同一の FavoriteMenuMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するアカウントが保有するメニューの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
アカウントが保有するメニューの基本モデルを複数挿入します。 引数に指定するものは同一の FavoriteMenuMapperの create(String,String) で生成されたアカウントが保有するメニューの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するアカウントが保有するメニューの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(FavoriteMenuBaseModel model)
            throws MapperException
アカウントが保有するメニューの基本モデルを1つだけ更新します。 引数に指定するアカウントが保有するメニューの基本モデルは同一の FavoriteMenuMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するアカウントが保有するメニューの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
アカウントが保有するメニューの基本モデルを複数更新します。 引数に指定するものは同一の FavoriteMenuMapperの select 系メソッド から取得されたものかで生成されたアカウントが保有するメニューの基本モデルの集合である必要があります。

パラメータ:
models - 更新するアカウントが保有するメニューの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(FavoriteMenuBaseModel model)
            throws MapperException
アカウントが保有するメニューの基本モデルを1つだけ削除します。 引数で指定されたアカウントが保有するメニューの基本モデルに該当するデータのすべての情報を削除します。引数に指定するアカウントが保有するメニューの基本モデルは同一の FavoriteMenuMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するアカウントが保有するメニューの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
アカウントが保有するメニューの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するアカウントが保有するメニューの基本モデルは同一の FavoriteMenuMapperの select 系メソッド から取得されたアカウントが保有するメニューの基本モデルの集合である必要があります。

パラメータ:
models - 削除するアカウントが保有するメニューの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuArgumentBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuArgumentBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface MenuArgumentBaseModel
extends BaseModel

メニューの保有する引数の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | ARGUMENT_NAME 引数名
static String | ARGUMENT_VALUE 引数値
static String | MENU_ID メニューID
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getArgumentName() 引数名を取得します。
String | getArgumentValue() 引数値を取得します。
String | getMenuId() メニューIDを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
void | setArgumentValue(String argumentValue) 引数値を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

MENU_ID

public static final String MENU_ID
メニューID

関連項目:
定数フィールド値

ARGUMENT_NAME

public static final String ARGUMENT_NAME
引数名

関連項目:
定数フィールド値

ARGUMENT_VALUE

public static final String ARGUMENT_VALUE
引数値

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getMenuId

public String getMenuId()
                 throws AccessorException
メニューIDを取得します。

戻り値:
メニューID
例外:
AccessorException - データの取得に失敗した場合

getArgumentName

public String getArgumentName()
                       throws AccessorException
引数名を取得します。

戻り値:
引数名
例外:
AccessorException - データの取得に失敗した場合

getArgumentValue

public String getArgumentValue()
                        throws AccessorException
引数値を取得します。

戻り値:
引数値
例外:
AccessorException - データの取得に失敗した場合

setArgumentValue

public void setArgumentValue(String argumentValue)
                      throws AccessorException
引数値を設定します。

パラメータ:
argumentValue - 引数値
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuArgumentMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuArgumentMapper

すべてのスーパーインタフェース:
Mapper
public interface MenuArgumentMapper
extends Mapper

メニューの保有する引数に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
MenuArgumentBaseModel | create(String menuId, String argumentName) プライマリキーに該当するメニューの保有する引数を生成します。
void | delete(Collection models) メニューの保有する引数の基本モデルを複数削除します。
void | delete(MenuArgumentBaseModel model) メニューの保有する引数の基本モデルを1つだけ削除します。
void | insert(Collection models) メニューの保有する引数の基本モデルを複数挿入します。
void | insert(MenuArgumentBaseModel model) メニューの保有する引数の基本モデルを1つだけ挿入します。
MenuArgumentBaseModel | select(String menuId, String argumentName) プライマリーキーで特定されるメニューの保有する引数の基本モデルを取得します。
void | update(Collection models) メニューの保有する引数の基本モデルを複数更新します。
void | update(MenuArgumentBaseModel model) メニューの保有する引数の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public MenuArgumentBaseModel create(String menuId,
                                    String argumentName)
                             throws MapperException
プライマリキーに該当するメニューの保有する引数を生成します。

パラメータ:
menuId - メニューID
argumentName - 引数名
戻り値:
プライマリキーに該当するメニューの保有する引数の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public MenuArgumentBaseModel select(String menuId,
                                    String argumentName)
                             throws MapperException
プライマリーキーで特定されるメニューの保有する引数の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
menuId - メニューID
argumentName - 引数名
戻り値:
メニューの保有する引数の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(MenuArgumentBaseModel model)
            throws MapperException
メニューの保有する引数の基本モデルを1つだけ挿入します。 引数に指定するメニューの保有する引数の基本モデルは同一の MenuArgumentMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するメニューの保有する引数の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
メニューの保有する引数の基本モデルを複数挿入します。 引数に指定するものは同一の MenuArgumentMapperの create(String,String) で生成されたメニューの保有する引数の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するメニューの保有する引数の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(MenuArgumentBaseModel model)
            throws MapperException
メニューの保有する引数の基本モデルを1つだけ更新します。 引数に指定するメニューの保有する引数の基本モデルは同一の MenuArgumentMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するメニューの保有する引数の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
メニューの保有する引数の基本モデルを複数更新します。 引数に指定するものは同一の MenuArgumentMapperの select 系メソッド から取得されたものかで生成されたメニューの保有する引数の基本モデルの集合である必要があります。

パラメータ:
models - 更新するメニューの保有する引数の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(MenuArgumentBaseModel model)
            throws MapperException
メニューの保有する引数の基本モデルを1つだけ削除します。 引数で指定されたメニューの保有する引数の基本モデルに該当するデータのすべての情報を削除します。引数に指定するメニューの保有する引数の基本モデルは同一の MenuArgumentMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するメニューの保有する引数の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
メニューの保有する引数の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するメニューの保有する引数の基本モデルは同一の MenuArgumentMapperの select 系メソッド から取得されたメニューの保有する引数の基本モデルの集合である必要があります。

パラメータ:
models - 削除するメニューの保有する引数の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface MenuBaseModel
extends BaseModel

メニュー情報の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | CLIENT_TYPE クライアントタイプ
static String | CONTENTS コンテンツの種類
static String | DISPLAY_NAME メニュー表示名
static String | IMAGE_PATH イメージパス
static String | MENU_ID メニューID
static String | MENU_TYPE メニュータイプ
static String | NOTES 説明
static String | PARENT_MENU_ID 親メニューID
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_NUMBER ソート番号
static String | URL URL
メソッドの概要
String | getClientType() クライアントタイプを取得します。
String | getContents() コンテンツの種類を取得します。
String | getDisplayName() メニュー表示名を取得します。
String | getDisplayName(Locale locale) メニュー表示名を取得します。
String | getImagePath() イメージパスを取得します。
String | getMenuId() メニューIDを取得します。
String | getMenuType() メニュータイプを取得します。
String | getNotes() 説明を取得します。
String | getParentMenuId() 親メニューIDを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortNumber() ソート番号を取得します。
String | getUrl() URLを取得します。
MenuInternationalModel | selectMenuInternationalModel(Locale locale) 指定された言語に該当するメニュー情報の国際化モデルを取得します。
void | setClientType(String clientType) クライアントタイプを設定します。
void | setContents(String contents) コンテンツの種類を設定します。
void | setDisplayName(String displayName) メニュー表示名を設定します。
void | setDisplayName(String displayName, Locale locale) メニュー表示名を設定します。
void | setImagePath(String imagePath) イメージパスを設定します。
void | setMenuType(String menuType) メニュータイプを設定します。
void | setNotes(String notes) 説明を設定します。
void | setParentMenuId(String parentMenuId) 親メニューIDを設定します。
void | setSortNumber(int sortNumber) ソート番号を設定します。
void | setUrl(String url) URLを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

MENU_ID

public static final String MENU_ID
メニューID

関連項目:
定数フィールド値

MENU_TYPE

public static final String MENU_TYPE
メニュータイプ

関連項目:
定数フィールド値

NOTES

public static final String NOTES
説明

関連項目:
定数フィールド値

SORT_NUMBER

public static final String SORT_NUMBER
ソート番号

関連項目:
定数フィールド値

CLIENT_TYPE

public static final String CLIENT_TYPE
クライアントタイプ

関連項目:
定数フィールド値

CONTENTS

public static final String CONTENTS
コンテンツの種類

関連項目:
定数フィールド値

URL

public static final String URL
URL

関連項目:
定数フィールド値

PARENT_MENU_ID

public static final String PARENT_MENU_ID
親メニューID

関連項目:
定数フィールド値

IMAGE_PATH

public static final String IMAGE_PATH
イメージパス

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

DISPLAY_NAME

public static final String DISPLAY_NAME
メニュー表示名

関連項目:
定数フィールド値
メソッドの詳細

getMenuId

public String getMenuId()
                 throws AccessorException
メニューIDを取得します。

戻り値:
メニューID
例外:
AccessorException - データの取得に失敗した場合

getMenuType

public String getMenuType()
                   throws AccessorException
メニュータイプを取得します。

戻り値:
メニュータイプ
例外:
AccessorException - データの取得に失敗した場合

setMenuType

public void setMenuType(String menuType)
                 throws AccessorException
メニュータイプを設定します。

パラメータ:
menuType - メニュータイプ
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
説明を取得します。

戻り値:
説明
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
説明を設定します。

パラメータ:
notes - 説明
例外:
AccessorException - データの設定に失敗した場合

getSortNumber

public int getSortNumber()
                  throws AccessorException
ソート番号を取得します。

戻り値:
ソート番号
例外:
AccessorException - データの取得に失敗した場合

setSortNumber

public void setSortNumber(int sortNumber)
                   throws AccessorException
ソート番号を設定します。

パラメータ:
sortNumber - ソート番号
例外:
AccessorException - データの設定に失敗した場合

getClientType

public String getClientType()
                     throws AccessorException
クライアントタイプを取得します。

戻り値:
クライアントタイプ
例外:
AccessorException - データの取得に失敗した場合

setClientType

public void setClientType(String clientType)
                   throws AccessorException
クライアントタイプを設定します。

パラメータ:
clientType - クライアントタイプ
例外:
AccessorException - データの設定に失敗した場合

getContents

public String getContents()
                   throws AccessorException
コンテンツの種類を取得します。

戻り値:
コンテンツの種類
例外:
AccessorException - データの取得に失敗した場合

setContents

public void setContents(String contents)
                 throws AccessorException
コンテンツの種類を設定します。

パラメータ:
contents - コンテンツの種類
例外:
AccessorException - データの設定に失敗した場合

getUrl

public String getUrl()
              throws AccessorException
URLを取得します。

戻り値:
URL
例外:
AccessorException - データの取得に失敗した場合

setUrl

public void setUrl(String url)
            throws AccessorException
URLを設定します。

パラメータ:
url - URL
例外:
AccessorException - データの設定に失敗した場合

getParentMenuId

public String getParentMenuId()
                       throws AccessorException
親メニューIDを取得します。

戻り値:
親メニューID
例外:
AccessorException - データの取得に失敗した場合

setParentMenuId

public void setParentMenuId(String parentMenuId)
                     throws AccessorException
親メニューIDを設定します。

パラメータ:
parentMenuId - 親メニューID
例外:
AccessorException - データの設定に失敗した場合

getImagePath

public String getImagePath()
                    throws AccessorException
イメージパスを取得します。

戻り値:
イメージパス
例外:
AccessorException - データの取得に失敗した場合

setImagePath

public void setImagePath(String imagePath)
                  throws AccessorException
イメージパスを設定します。

パラメータ:
imagePath - イメージパス
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getDisplayName

public String getDisplayName()
                      throws AccessorException
メニュー表示名を取得します。

戻り値:
メニュー表示名
例外:
AccessorException - データの取得に失敗した場合

getDisplayName

public String getDisplayName(Locale locale)
                      throws AccessorException
メニュー表示名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
メニュー表示名
例外:
AccessorException - データの取得に失敗した場合

setDisplayName

public void setDisplayName(String displayName)
                    throws AccessorException
メニュー表示名を設定します。

パラメータ:
displayName - メニュー表示名
例外:
AccessorException - データの設定に失敗した場合

setDisplayName

public void setDisplayName(String displayName,
                           Locale locale)
                    throws AccessorException
メニュー表示名を設定します。

パラメータ:
displayName - メニュー表示名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectMenuInternationalModel

public MenuInternationalModel selectMenuInternationalModel(Locale locale)
                                                    throws IllegalLocaleException
指定された言語に該当するメニュー情報の国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
メニュー情報の国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuDepartmentBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuDepartmentBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface MenuDepartmentBaseModel
extends BaseModel

メニューの利用権限を保有する組織の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | COMPANY_CD 会社CD
static String | DEPARTMENT_CD 組織CD
static String | MENU_ID メニューID
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getCompanyCd() 会社CDを取得します。
String | getDepartmentCd() 組織CDを取得します。
String | getMenuId() メニューIDを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

MENU_ID

public static final String MENU_ID
メニューID

関連項目:
定数フィールド値

COMPANY_CD

public static final String COMPANY_CD
会社CD

関連項目:
定数フィールド値

DEPARTMENT_CD

public static final String DEPARTMENT_CD
組織CD

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getMenuId

public String getMenuId()
                 throws AccessorException
メニューIDを取得します。

戻り値:
メニューID
例外:
AccessorException - データの取得に失敗した場合

getCompanyCd

public String getCompanyCd()
                    throws AccessorException
会社CDを取得します。

戻り値:
会社CD
例外:
AccessorException - データの取得に失敗した場合

getDepartmentCd

public String getDepartmentCd()
                       throws AccessorException
組織CDを取得します。

戻り値:
組織CD
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuDepartmentMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuDepartmentMapper

すべてのスーパーインタフェース:
Mapper
public interface MenuDepartmentMapper
extends Mapper

メニューの利用権限を保有する組織に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
MenuDepartmentBaseModel | create(String menuId, String companyCd, String departmentCd) プライマリキーに該当するメニューの利用権限を保有する組織を生成します。
void | delete(Collection models) メニューの利用権限を保有する組織の基本モデルを複数削除します。
void | delete(MenuDepartmentBaseModel model) メニューの利用権限を保有する組織の基本モデルを1つだけ削除します。
void | insert(Collection models) メニューの利用権限を保有する組織の基本モデルを複数挿入します。
void | insert(MenuDepartmentBaseModel model) メニューの利用権限を保有する組織の基本モデルを1つだけ挿入します。
MenuDepartmentBaseModel | select(String menuId, String companyCd, String departmentCd) プライマリーキーで特定されるメニューの利用権限を保有する組織の基本モデルを取得します。
void | update(Collection models) メニューの利用権限を保有する組織の基本モデルを複数更新します。
void | update(MenuDepartmentBaseModel model) メニューの利用権限を保有する組織の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public MenuDepartmentBaseModel create(String menuId,
                                      String companyCd,
                                      String departmentCd)
                               throws MapperException
プライマリキーに該当するメニューの利用権限を保有する組織を生成します。

パラメータ:
menuId - メニューID
companyCd - 会社CD
departmentCd - 組織CD
戻り値:
プライマリキーに該当するメニューの利用権限を保有する組織の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public MenuDepartmentBaseModel select(String menuId,
                                      String companyCd,
                                      String departmentCd)
                               throws MapperException
プライマリーキーで特定されるメニューの利用権限を保有する組織の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
menuId - メニューID
companyCd - 会社CD
departmentCd - 組織CD
戻り値:
メニューの利用権限を保有する組織の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(MenuDepartmentBaseModel model)
            throws MapperException
メニューの利用権限を保有する組織の基本モデルを1つだけ挿入します。 引数に指定するメニューの利用権限を保有する組織の基本モデルは同一の MenuDepartmentMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するメニューの利用権限を保有する組織の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
メニューの利用権限を保有する組織の基本モデルを複数挿入します。 引数に指定するものは同一の MenuDepartmentMapperの create(String,String,String) で生成されたメニューの利用権限を保有する組織の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するメニューの利用権限を保有する組織の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(MenuDepartmentBaseModel model)
            throws MapperException
メニューの利用権限を保有する組織の基本モデルを1つだけ更新します。 引数に指定するメニューの利用権限を保有する組織の基本モデルは同一の MenuDepartmentMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するメニューの利用権限を保有する組織の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
メニューの利用権限を保有する組織の基本モデルを複数更新します。 引数に指定するものは同一の MenuDepartmentMapperの select 系メソッド から取得されたものかで生成されたメニューの利用権限を保有する組織の基本モデルの集合である必要があります。

パラメータ:
models - 更新するメニューの利用権限を保有する組織の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(MenuDepartmentBaseModel model)
            throws MapperException
メニューの利用権限を保有する組織の基本モデルを1つだけ削除します。 引数で指定されたメニューの利用権限を保有する組織の基本モデルに該当するデータのすべての情報を削除します。引数に指定するメニューの利用権限を保有する組織の基本モデルは同一の MenuDepartmentMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するメニューの利用権限を保有する組織の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
メニューの利用権限を保有する組織の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するメニューの利用権限を保有する組織の基本モデルは同一の MenuDepartmentMapperの select 系メソッド から取得されたメニューの利用権限を保有する組織の基本モデルの集合である必要があります。

パラメータ:
models - 削除するメニューの利用権限を保有する組織の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuInternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuInternationalModel

すべてのスーパーインタフェース:
InternationalModel, Serializable
public interface MenuInternationalModel
extends InternationalModel

メニュー情報の国際化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getDisplayName() メニュー表示名を取得します。
void | setDisplayName(String displayName) メニュー表示名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModel から継承したメソッド
getExtendedInternationalModelMap, getLocale, init

メソッドの詳細

getDisplayName

public String getDisplayName()
                      throws AccessorException
メニュー表示名を取得します。

戻り値:
メニュー表示名
例外:
AccessorException - データの取得に失敗した場合

setDisplayName

public void setDisplayName(String displayName)
                    throws AccessorException
メニュー表示名を設定します。

パラメータ:
displayName - メニュー表示名
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuMapper

すべてのスーパーインタフェース:
Mapper
public interface MenuMapper
extends Mapper

メニュー情報に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
MenuBaseModel | create(String menuId) プライマリキーに該当するメニュー情報を生成します。
void | delete(Collection models) メニュー情報の基本モデルを複数削除します。
void | delete(MenuBaseModel model) メニュー情報の基本モデルを1つだけ削除します。
void | insert(Collection models) メニュー情報の基本モデルを複数挿入します。
void | insert(MenuBaseModel model) メニュー情報の基本モデルを1つだけ挿入します。
MenuBaseModel | select(String menuId) プライマリーキーで特定されるメニュー情報の基本モデルを取得します。
void | update(Collection models) メニュー情報の基本モデルを複数更新します。
void | update(MenuBaseModel model) メニュー情報の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public MenuBaseModel create(String menuId)
                     throws MapperException
プライマリキーに該当するメニュー情報を生成します。

パラメータ:
menuId - メニューID
戻り値:
プライマリキーに該当するメニュー情報の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public MenuBaseModel select(String menuId)
                     throws MapperException
プライマリーキーで特定されるメニュー情報の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
menuId - メニューID
戻り値:
メニュー情報の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(MenuBaseModel model)
            throws MapperException
メニュー情報の基本モデルを1つだけ挿入します。 引数に指定するメニュー情報の基本モデルは同一の MenuMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入するメニュー情報の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
メニュー情報の基本モデルを複数挿入します。 引数に指定するものは同一の MenuMapperの create(String) で生成されたメニュー情報の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するメニュー情報の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(MenuBaseModel model)
            throws MapperException
メニュー情報の基本モデルを1つだけ更新します。 引数に指定するメニュー情報の基本モデルは同一の MenuMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するメニュー情報の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
メニュー情報の基本モデルを複数更新します。 引数に指定するものは同一の MenuMapperの select 系メソッド から取得されたものかで生成されたメニュー情報の基本モデルの集合である必要があります。

パラメータ:
models - 更新するメニュー情報の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(MenuBaseModel model)
            throws MapperException
メニュー情報の基本モデルを1つだけ削除します。 引数で指定されたメニュー情報の基本モデルに該当するデータのすべての情報を削除します。引数に指定するメニュー情報の基本モデルは同一の MenuMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するメニュー情報の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
メニュー情報の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するメニュー情報の基本モデルは同一の MenuMapperの select 系メソッド から取得されたメニュー情報の基本モデルの集合である必要があります。

パラメータ:
models - 削除するメニュー情報の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuPostBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuPostBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface MenuPostBaseModel
extends BaseModel

メニューの利用権限を保有する役職の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | COMPANY_CD 会社CD
static String | MENU_ID メニューID
static String | POST_CD 役職CD
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getCompanyCd() 会社CDを取得します。
String | getMenuId() メニューIDを取得します。
String | getPostCd() 役職CDを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

MENU_ID

public static final String MENU_ID
メニューID

関連項目:
定数フィールド値

COMPANY_CD

public static final String COMPANY_CD
会社CD

関連項目:
定数フィールド値

POST_CD

public static final String POST_CD
役職CD

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getMenuId

public String getMenuId()
                 throws AccessorException
メニューIDを取得します。

戻り値:
メニューID
例外:
AccessorException - データの取得に失敗した場合

getCompanyCd

public String getCompanyCd()
                    throws AccessorException
会社CDを取得します。

戻り値:
会社CD
例外:
AccessorException - データの取得に失敗した場合

getPostCd

public String getPostCd()
                 throws AccessorException
役職CDを取得します。

戻り値:
役職CD
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuPostMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuPostMapper

すべてのスーパーインタフェース:
Mapper
public interface MenuPostMapper
extends Mapper

メニューの利用権限を保有する役職に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
MenuPostBaseModel | create(String menuId, String companyCd, String postCd) プライマリキーに該当するメニューの利用権限を保有する役職を生成します。
void | delete(Collection models) メニューの利用権限を保有する役職の基本モデルを複数削除します。
void | delete(MenuPostBaseModel model) メニューの利用権限を保有する役職の基本モデルを1つだけ削除します。
void | insert(Collection models) メニューの利用権限を保有する役職の基本モデルを複数挿入します。
void | insert(MenuPostBaseModel model) メニューの利用権限を保有する役職の基本モデルを1つだけ挿入します。
MenuPostBaseModel | select(String menuId, String companyCd, String postCd) プライマリーキーで特定されるメニューの利用権限を保有する役職の基本モデルを取得します。
void | update(Collection models) メニューの利用権限を保有する役職の基本モデルを複数更新します。
void | update(MenuPostBaseModel model) メニューの利用権限を保有する役職の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public MenuPostBaseModel create(String menuId,
                                String companyCd,
                                String postCd)
                         throws MapperException
プライマリキーに該当するメニューの利用権限を保有する役職を生成します。

パラメータ:
menuId - メニューID
companyCd - 会社CD
postCd - 役職CD
戻り値:
プライマリキーに該当するメニューの利用権限を保有する役職の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public MenuPostBaseModel select(String menuId,
                                String companyCd,
                                String postCd)
                         throws MapperException
プライマリーキーで特定されるメニューの利用権限を保有する役職の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
menuId - メニューID
companyCd - 会社CD
postCd - 役職CD
戻り値:
メニューの利用権限を保有する役職の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(MenuPostBaseModel model)
            throws MapperException
メニューの利用権限を保有する役職の基本モデルを1つだけ挿入します。 引数に指定するメニューの利用権限を保有する役職の基本モデルは同一の MenuPostMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するメニューの利用権限を保有する役職の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
メニューの利用権限を保有する役職の基本モデルを複数挿入します。 引数に指定するものは同一の MenuPostMapperの create(String,String,String) で生成されたメニューの利用権限を保有する役職の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するメニューの利用権限を保有する役職の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(MenuPostBaseModel model)
            throws MapperException
メニューの利用権限を保有する役職の基本モデルを1つだけ更新します。 引数に指定するメニューの利用権限を保有する役職の基本モデルは同一の MenuPostMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するメニューの利用権限を保有する役職の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
メニューの利用権限を保有する役職の基本モデルを複数更新します。 引数に指定するものは同一の MenuPostMapperの select 系メソッド から取得されたものかで生成されたメニューの利用権限を保有する役職の基本モデルの集合である必要があります。

パラメータ:
models - 更新するメニューの利用権限を保有する役職の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(MenuPostBaseModel model)
            throws MapperException
メニューの利用権限を保有する役職の基本モデルを1つだけ削除します。 引数で指定されたメニューの利用権限を保有する役職の基本モデルに該当するデータのすべての情報を削除します。引数に指定するメニューの利用権限を保有する役職の基本モデルは同一の MenuPostMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するメニューの利用権限を保有する役職の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
メニューの利用権限を保有する役職の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するメニューの利用権限を保有する役職の基本モデルは同一の MenuPostMapperの select 系メソッド から取得されたメニューの利用権限を保有する役職の基本モデルの集合である必要があります。

パラメータ:
models - 削除するメニューの利用権限を保有する役職の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuPublicGroupBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuPublicGroupBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface MenuPublicGroupBaseModel
extends BaseModel

メニューの利用権限を保有するパブリックグループの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | MENU_ID メニューID
static String | PUBLIC_GROUP_CD グルーピングCD
static String | PUBLIC_GROUP_SET_CD グループセットCD
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getMenuId() メニューIDを取得します。
String | getPublicGroupCd() グルーピングCDを取得します。
String | getPublicGroupSetCd() グループセットCDを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

MENU_ID

public static final String MENU_ID
メニューID

関連項目:
定数フィールド値

PUBLIC_GROUP_SET_CD

public static final String PUBLIC_GROUP_SET_CD
グループセットCD

関連項目:
定数フィールド値

PUBLIC_GROUP_CD

public static final String PUBLIC_GROUP_CD
グルーピングCD

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getMenuId

public String getMenuId()
                 throws AccessorException
メニューIDを取得します。

戻り値:
メニューID
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupSetCd

public String getPublicGroupSetCd()
                           throws AccessorException
グループセットCDを取得します。

戻り値:
グループセットCD
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupCd

public String getPublicGroupCd()
                        throws AccessorException
グルーピングCDを取得します。

戻り値:
グルーピングCD
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuPublicGroupMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuPublicGroupMapper

すべてのスーパーインタフェース:
Mapper
public interface MenuPublicGroupMapper
extends Mapper

メニューの利用権限を保有するパブリックグループに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
MenuPublicGroupBaseModel | create(String menuId, String publicGroupSetCd, String publicGroupCd) プライマリキーに該当するメニューの利用権限を保有するパブリックグループを生成します。
void | delete(Collection models) メニューの利用権限を保有するパブリックグループの基本モデルを複数削除します。
void | delete(MenuPublicGroupBaseModel model) メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ削除します。
void | insert(Collection models) メニューの利用権限を保有するパブリックグループの基本モデルを複数挿入します。
void | insert(MenuPublicGroupBaseModel model) メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ挿入します。
MenuPublicGroupBaseModel | select(String menuId, String publicGroupSetCd, String publicGroupCd) プライマリーキーで特定されるメニューの利用権限を保有するパブリックグループの基本モデルを取得します。
void | update(Collection models) メニューの利用権限を保有するパブリックグループの基本モデルを複数更新します。
void | update(MenuPublicGroupBaseModel model) メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public MenuPublicGroupBaseModel create(String menuId,
                                       String publicGroupSetCd,
                                       String publicGroupCd)
                                throws MapperException
プライマリキーに該当するメニューの利用権限を保有するパブリックグループを生成します。

パラメータ:
menuId - メニューID
publicGroupSetCd - グループセットCD
publicGroupCd - グルーピングCD
戻り値:
プライマリキーに該当するメニューの利用権限を保有するパブリックグループの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public MenuPublicGroupBaseModel select(String menuId,
                                       String publicGroupSetCd,
                                       String publicGroupCd)
                                throws MapperException
プライマリーキーで特定されるメニューの利用権限を保有するパブリックグループの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
menuId - メニューID
publicGroupSetCd - グループセットCD
publicGroupCd - グルーピングCD
戻り値:
メニューの利用権限を保有するパブリックグループの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(MenuPublicGroupBaseModel model)
            throws MapperException
メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ挿入します。 引数に指定するメニューの利用権限を保有するパブリックグループの基本モデルは同一の MenuPublicGroupMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するメニューの利用権限を保有するパブリックグループの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
メニューの利用権限を保有するパブリックグループの基本モデルを複数挿入します。 引数に指定するものは同一の MenuPublicGroupMapperの create(String,String,String) で生成されたメニューの利用権限を保有するパブリックグループの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するメニューの利用権限を保有するパブリックグループの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(MenuPublicGroupBaseModel model)
            throws MapperException
メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ更新します。 引数に指定するメニューの利用権限を保有するパブリックグループの基本モデルは同一の MenuPublicGroupMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するメニューの利用権限を保有するパブリックグループの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
メニューの利用権限を保有するパブリックグループの基本モデルを複数更新します。 引数に指定するものは同一の MenuPublicGroupMapperの select 系メソッド から取得されたものかで生成されたメニューの利用権限を保有するパブリックグループの基本モデルの集合である必要があります。

パラメータ:
models - 更新するメニューの利用権限を保有するパブリックグループの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(MenuPublicGroupBaseModel model)
            throws MapperException
メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ削除します。 引数で指定されたメニューの利用権限を保有するパブリックグループの基本モデルに該当するデータのすべての情報を削除します。引数に指定するメニューの利用権限を保有するパブリックグループの基本モデルは同一の MenuPublicGroupMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するメニューの利用権限を保有するパブリックグループの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
メニューの利用権限を保有するパブリックグループの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するメニューの利用権限を保有するパブリックグループの基本モデルは同一の MenuPublicGroupMapperの select 系メソッド から取得されたメニューの利用権限を保有するパブリックグループの基本モデルの集合である必要があります。

パラメータ:
models - 削除するメニューの利用権限を保有するパブリックグループの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuRoleBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuRoleBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface MenuRoleBaseModel
extends BaseModel

メニューの利用権限を保有するロールの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | MENU_ID メニューID
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | ROLE_ID ロールCD
メソッドの概要
String | getMenuId() メニューIDを取得します。
String | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getRoleId() ロールCDを取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

MENU_ID

public static final String MENU_ID
メニューID

関連項目:
定数フィールド値

ROLE_ID

public static final String ROLE_ID
ロールCD

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getMenuId

public String getMenuId()
                 throws AccessorException
メニューIDを取得します。

戻り値:
メニューID
例外:
AccessorException - データの取得に失敗した場合

getRoleId

public String getRoleId()
                 throws AccessorException
ロールCDを取得します。

戻り値:
ロールCD
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public String getRecordDate()
                     throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuRoleMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース MenuRoleMapper

すべてのスーパーインタフェース:
Mapper
public interface MenuRoleMapper
extends Mapper

メニューの利用権限を保有するロールに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
MenuRoleBaseModel | create(String menuId, String roleId) プライマリキーに該当するメニューの利用権限を保有するロールを生成します。
void | delete(Collection models) メニューの利用権限を保有するロールの基本モデルを複数削除します。
void | delete(MenuRoleBaseModel model) メニューの利用権限を保有するロールの基本モデルを1つだけ削除します。
void | insert(Collection models) メニューの利用権限を保有するロールの基本モデルを複数挿入します。
void | insert(MenuRoleBaseModel model) メニューの利用権限を保有するロールの基本モデルを1つだけ挿入します。
MenuRoleBaseModel | select(String menuId, String roleId) プライマリーキーで特定されるメニューの利用権限を保有するロールの基本モデルを取得します。
void | update(Collection models) メニューの利用権限を保有するロールの基本モデルを複数更新します。
void | update(MenuRoleBaseModel model) メニューの利用権限を保有するロールの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public MenuRoleBaseModel create(String menuId,
                                String roleId)
                         throws MapperException
プライマリキーに該当するメニューの利用権限を保有するロールを生成します。

パラメータ:
menuId - メニューID
roleId - ロールCD
戻り値:
プライマリキーに該当するメニューの利用権限を保有するロールの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public MenuRoleBaseModel select(String menuId,
                                String roleId)
                         throws MapperException
プライマリーキーで特定されるメニューの利用権限を保有するロールの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
menuId - メニューID
roleId - ロールCD
戻り値:
メニューの利用権限を保有するロールの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(MenuRoleBaseModel model)
            throws MapperException
メニューの利用権限を保有するロールの基本モデルを1つだけ挿入します。 引数に指定するメニューの利用権限を保有するロールの基本モデルは同一の MenuRoleMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するメニューの利用権限を保有するロールの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
メニューの利用権限を保有するロールの基本モデルを複数挿入します。 引数に指定するものは同一の MenuRoleMapperの create(String,String) で生成されたメニューの利用権限を保有するロールの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するメニューの利用権限を保有するロールの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(MenuRoleBaseModel model)
            throws MapperException
メニューの利用権限を保有するロールの基本モデルを1つだけ更新します。 引数に指定するメニューの利用権限を保有するロールの基本モデルは同一の MenuRoleMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するメニューの利用権限を保有するロールの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
メニューの利用権限を保有するロールの基本モデルを複数更新します。 引数に指定するものは同一の MenuRoleMapperの select 系メソッド から取得されたものかで生成されたメニューの利用権限を保有するロールの基本モデルの集合である必要があります。

パラメータ:
models - 更新するメニューの利用権限を保有するロールの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(MenuRoleBaseModel model)
            throws MapperException
メニューの利用権限を保有するロールの基本モデルを1つだけ削除します。 引数で指定されたメニューの利用権限を保有するロールの基本モデルに該当するデータのすべての情報を削除します。引数に指定するメニューの利用権限を保有するロールの基本モデルは同一の MenuRoleMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するメニューの利用権限を保有するロールの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
メニューの利用権限を保有するロールの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するメニューの利用権限を保有するロールの基本モデルは同一の MenuRoleMapperの select 系メソッド から取得されたメニューの利用権限を保有するロールの基本モデルの集合である必要があります。

パラメータ:
models - 削除するメニューの利用権限を保有するロールの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.system.security.datastore.inf (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.system.security.datastore.inf
インタフェース
AccessControllerBaseModel
AccessControllerDepartmentBaseModel
AccessControllerDepartmentMapper
AccessControllerMapper
AccessControllerPostBaseModel
AccessControllerPostMapper
AccessControllerPublicGroupBaseModel
AccessControllerPublicGroupMapper
AccessControllerRoleBaseModel
AccessControllerRoleMapper
AccountAttributeBaseModel
AccountAttributeMapper
AccountBaseModel
AccountMapper
AccountRoleBaseModel
AccountRoleMapper
BatchBaseModel
BatchMapper
CalendarInfoBaseModel
CalendarInfoInternationalModel
CalendarInfoMapper
DataStoreConst
FavoriteMenuBaseModel
FavoriteMenuMapper
MenuArgumentBaseModel
MenuArgumentMapper
MenuBaseModel
MenuDepartmentBaseModel
MenuDepartmentMapper
MenuInternationalModel
MenuMapper
MenuPostBaseModel
MenuPostMapper
MenuPublicGroupBaseModel
MenuPublicGroupMapper
MenuRoleBaseModel
MenuRoleMapper
RoleBaseModel
RoleInclusionBaseModel
RoleInclusionMapper
RoleInternationalModel
RoleMapper
RoleSummaryBaseModel
RoleSummaryMapper


jp.co.intra_mart.system.security.datastore.inf (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.system.security.datastore.inf

インタフェースの概要
AccessControllerBaseModel | アクセスコントローラ情報の基本モデルです。
AccessControllerDepartmentBaseModel | アクセスコントローラの利用権限を保有する組織の基本モデルです。
AccessControllerDepartmentMapper | アクセスコントローラの利用権限を保有する組織に関連するマッパです。
AccessControllerMapper | アクセスコントローラ情報に関連するマッパです。
AccessControllerPostBaseModel | アクセスコントローラの利用権限を保有する役職の基本モデルです。
AccessControllerPostMapper | アクセスコントローラの利用権限を保有する役職に関連するマッパです。
AccessControllerPublicGroupBaseModel | アクセスコントローラの利用権限を保有するパブリックグループの基本モデルです。
AccessControllerPublicGroupMapper | アクセスコントローラの利用権限を保有するパブリックグループに関連するマッパです。
AccessControllerRoleBaseModel | アクセスコントローラの利用権限を保有するロールの基本モデルです。
AccessControllerRoleMapper | アクセスコントローラの利用権限を保有するロールに関連するマッパです。
AccountAttributeBaseModel | アカウントが保有する属性の基本モデルです。
AccountAttributeMapper | アカウントが保有する属性に関連するマッパです。
AccountBaseModel | アカウントの基本モデルです。
AccountMapper | アカウントに関連するマッパです。
AccountRoleBaseModel | アカウントが保有するロールの基本モデルです。
AccountRoleMapper | アカウントが保有するロールに関連するマッパです。
BatchBaseModel | バッチ情報の基本モデルです。
BatchMapper | バッチ情報に関連するマッパです。
CalendarInfoBaseModel | カレンダーが保有するデータの基本モデルです。
CalendarInfoInternationalModel | カレンダーが保有するデータの国際化モデルです。
CalendarInfoMapper | カレンダーが保有するデータに関連するマッパです。
DataStoreConst | データストアの定数クラス
FavoriteMenuBaseModel | アカウントが保有するメニューの基本モデルです。
FavoriteMenuMapper | アカウントが保有するメニューに関連するマッパです。
MenuArgumentBaseModel | メニューの保有する引数の基本モデルです。
MenuArgumentMapper | メニューの保有する引数に関連するマッパです。
MenuBaseModel | メニュー情報の基本モデルです。
MenuDepartmentBaseModel | メニューの利用権限を保有する組織の基本モデルです。
MenuDepartmentMapper | メニューの利用権限を保有する組織に関連するマッパです。
MenuInternationalModel | メニュー情報の国際化モデルです。
MenuMapper | メニュー情報に関連するマッパです。
MenuPostBaseModel | メニューの利用権限を保有する役職の基本モデルです。
MenuPostMapper | メニューの利用権限を保有する役職に関連するマッパです。
MenuPublicGroupBaseModel | メニューの利用権限を保有するパブリックグループの基本モデルです。
MenuPublicGroupMapper | メニューの利用権限を保有するパブリックグループに関連するマッパです。
MenuRoleBaseModel | メニューの利用権限を保有するロールの基本モデルです。
MenuRoleMapper | メニューの利用権限を保有するロールに関連するマッパです。
RoleBaseModel | ロールの基本モデルです。
RoleInclusionBaseModel | ロール内包の基本モデルです。
RoleInclusionMapper | ロール内包に関連するマッパです。
RoleInternationalModel | ロールの国際化モデルです。
RoleMapper | ロールに関連するマッパです。
RoleSummaryBaseModel | ロールサマリの基本モデルです。
RoleSummaryMapper | ロールサマリに関連するマッパです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.system.security.datastore.inf クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.system.security.datastore.inf の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccountMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.BatchMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.RoleMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel
      • interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoInternationalModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuInternationalModel
      • interface jp.co.intra_mart.system.security.datastore.inf.RoleInternationalModel
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.system.security.datastore.inf の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.system.security.datastore.inf の使用

jp.co.intra_mart.system.security.datastore.inf を使用しているパッケージ
jp.co.intra_mart.system.security.datastore.inf

jp.co.intra_mart.system.security.datastore.inf により使用される jp.co.intra_mart.system.security.datastore.inf のクラス
AccessControllerBaseModel
アクセスコントローラ情報の基本モデルです。
AccessControllerDepartmentBaseModel
アクセスコントローラの利用権限を保有する組織の基本モデルです。
AccessControllerPostBaseModel
アクセスコントローラの利用権限を保有する役職の基本モデルです。
AccessControllerPublicGroupBaseModel
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルです。
AccessControllerRoleBaseModel
アクセスコントローラの利用権限を保有するロールの基本モデルです。
AccountAttributeBaseModel
アカウントが保有する属性の基本モデルです。
AccountBaseModel
アカウントの基本モデルです。
AccountRoleBaseModel
アカウントが保有するロールの基本モデルです。
BatchBaseModel
バッチ情報の基本モデルです。
CalendarInfoBaseModel
カレンダーが保有するデータの基本モデルです。
CalendarInfoInternationalModel
カレンダーが保有するデータの国際化モデルです。
FavoriteMenuBaseModel
アカウントが保有するメニューの基本モデルです。
MenuArgumentBaseModel
メニューの保有する引数の基本モデルです。
MenuBaseModel
メニュー情報の基本モデルです。
MenuDepartmentBaseModel
メニューの利用権限を保有する組織の基本モデルです。
MenuInternationalModel
メニュー情報の国際化モデルです。
MenuPostBaseModel
メニューの利用権限を保有する役職の基本モデルです。
MenuPublicGroupBaseModel
メニューの利用権限を保有するパブリックグループの基本モデルです。
MenuRoleBaseModel
メニューの利用権限を保有するロールの基本モデルです。
RoleBaseModel
ロールの基本モデルです。
RoleInclusionBaseModel
ロール内包の基本モデルです。
RoleInternationalModel
ロールの国際化モデルです。
RoleSummaryBaseModel
ロールサマリの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


RoleBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース RoleBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface RoleBaseModel
extends BaseModel

ロールの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | CATEGORY カテゴリ
static String | DISPLAY_NAME ロール表示名
static String | NAME ロール名
static String | NOTES 備考
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | ROLE_ID ロールID
メソッドの概要
String | getCategory() カテゴリを取得します。
String | getDisplayName() ロール表示名を取得します。
String | getDisplayName(Locale locale) ロール表示名を取得します。
String | getName() ロール名を取得します。
String | getNotes() 備考を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getRoleId() ロールIDを取得します。
RoleInternationalModel | selectRoleInternationalModel(Locale locale) 指定された言語に該当するロールの国際化モデルを取得します。
void | setCategory(String category) カテゴリを設定します。
void | setDisplayName(String displayName) ロール表示名を設定します。
void | setDisplayName(String displayName, Locale locale) ロール表示名を設定します。
void | setName(String name) ロール名を設定します。
void | setNotes(String notes) 備考を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ROLE_ID

public static final String ROLE_ID
ロールID

関連項目:
定数フィールド値

NAME

public static final String NAME
ロール名

関連項目:
定数フィールド値

CATEGORY

public static final String CATEGORY
カテゴリ

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

DISPLAY_NAME

public static final String DISPLAY_NAME
ロール表示名

関連項目:
定数フィールド値
メソッドの詳細

getRoleId

public String getRoleId()
                 throws AccessorException
ロールIDを取得します。

戻り値:
ロールID
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName()
               throws AccessorException
ロール名を取得します。

戻り値:
ロール名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
ロール名を設定します。

パラメータ:
name - ロール名
例外:
AccessorException - データの設定に失敗した場合

getCategory

public String getCategory()
                   throws AccessorException
カテゴリを取得します。

戻り値:
カテゴリ
例外:
AccessorException - データの取得に失敗した場合

setCategory

public void setCategory(String category)
                 throws AccessorException
カテゴリを設定します。

パラメータ:
category - カテゴリ
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getDisplayName

public String getDisplayName()
                      throws AccessorException
ロール表示名を取得します。

戻り値:
ロール表示名
例外:
AccessorException - データの取得に失敗した場合

getDisplayName

public String getDisplayName(Locale locale)
                      throws AccessorException
ロール表示名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ロール表示名
例外:
AccessorException - データの取得に失敗した場合

setDisplayName

public void setDisplayName(String displayName)
                    throws AccessorException
ロール表示名を設定します。

パラメータ:
displayName - ロール表示名
例外:
AccessorException - データの設定に失敗した場合

setDisplayName

public void setDisplayName(String displayName,
                           Locale locale)
                    throws AccessorException
ロール表示名を設定します。

パラメータ:
displayName - ロール表示名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectRoleInternationalModel

public RoleInternationalModel selectRoleInternationalModel(Locale locale)
                                                    throws IllegalLocaleException
指定された言語に該当するロールの国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ロールの国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleInclusionBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース RoleInclusionBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface RoleInclusionBaseModel
extends BaseModel

ロール内包の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | CHILD_ROLE_ID 子ロールコード
static String | PARENT_ROLE_ID 親ロールコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getChildRoleId() 子ロールコードを取得します。
String | getParentRoleId() 親ロールコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

PARENT_ROLE_ID

public static final String PARENT_ROLE_ID
親ロールコード

関連項目:
定数フィールド値

CHILD_ROLE_ID

public static final String CHILD_ROLE_ID
子ロールコード

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getParentRoleId

public String getParentRoleId()
                       throws AccessorException
親ロールコードを取得します。

戻り値:
親ロールコード
例外:
AccessorException - データの取得に失敗した場合

getChildRoleId

public String getChildRoleId()
                      throws AccessorException
子ロールコードを取得します。

戻り値:
子ロールコード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleInclusionMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース RoleInclusionMapper

すべてのスーパーインタフェース:
Mapper
public interface RoleInclusionMapper
extends Mapper

ロール内包に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
RoleInclusionBaseModel | create(String parentRoleId, String childRoleId) プライマリキーに該当するロール内包を生成します。
void | delete(Collection models) ロール内包の基本モデルを複数削除します。
void | delete(RoleInclusionBaseModel model) ロール内包の基本モデルを1つだけ削除します。
void | insert(Collection models) ロール内包の基本モデルを複数挿入します。
void | insert(RoleInclusionBaseModel model) ロール内包の基本モデルを1つだけ挿入します。
RoleInclusionBaseModel | select(String parentRoleId, String childRoleId) プライマリーキーで特定されるロール内包の基本モデルを取得します。
void | update(Collection models) ロール内包の基本モデルを複数更新します。
void | update(RoleInclusionBaseModel model) ロール内包の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public RoleInclusionBaseModel create(String parentRoleId,
                                     String childRoleId)
                              throws MapperException
プライマリキーに該当するロール内包を生成します。

パラメータ:
parentRoleId - 親ロールコード
childRoleId - 子ロールコード
戻り値:
プライマリキーに該当するロール内包の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public RoleInclusionBaseModel select(String parentRoleId,
                                     String childRoleId)
                              throws MapperException
プライマリーキーで特定されるロール内包の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
parentRoleId - 親ロールコード
childRoleId - 子ロールコード
戻り値:
ロール内包の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(RoleInclusionBaseModel model)
            throws MapperException
ロール内包の基本モデルを1つだけ挿入します。 引数に指定するロール内包の基本モデルは同一の RoleInclusionMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するロール内包の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
ロール内包の基本モデルを複数挿入します。 引数に指定するものは同一の RoleInclusionMapperの create(String,String) で生成されたロール内包の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するロール内包の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(RoleInclusionBaseModel model)
            throws MapperException
ロール内包の基本モデルを1つだけ更新します。 引数に指定するロール内包の基本モデルは同一の RoleInclusionMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するロール内包の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
ロール内包の基本モデルを複数更新します。 引数に指定するものは同一の RoleInclusionMapperの select 系メソッド から取得されたものかで生成されたロール内包の基本モデルの集合である必要があります。

パラメータ:
models - 更新するロール内包の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(RoleInclusionBaseModel model)
            throws MapperException
ロール内包の基本モデルを1つだけ削除します。 引数で指定されたロール内包の基本モデルに該当するデータのすべての情報を削除します。引数に指定するロール内包の基本モデルは同一の RoleInclusionMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するロール内包の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
ロール内包の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するロール内包の基本モデルは同一の RoleInclusionMapperの select 系メソッド から取得されたロール内包の基本モデルの集合である必要があります。

パラメータ:
models - 削除するロール内包の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleInternationalModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース RoleInternationalModel

すべてのスーパーインタフェース:
InternationalModel, Serializable
public interface RoleInternationalModel
extends InternationalModel

ロールの国際化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getDisplayName() ロール表示名を取得します。
void | setDisplayName(String displayName) ロール表示名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModel から継承したメソッド
getExtendedInternationalModelMap, getLocale, init

メソッドの詳細

getDisplayName

public String getDisplayName()
                      throws AccessorException
ロール表示名を取得します。

戻り値:
ロール表示名
例外:
AccessorException - データの取得に失敗した場合

setDisplayName

public void setDisplayName(String displayName)
                    throws AccessorException
ロール表示名を設定します。

パラメータ:
displayName - ロール表示名
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース RoleMapper

すべてのスーパーインタフェース:
Mapper
public interface RoleMapper
extends Mapper

ロールに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
RoleBaseModel | create(String roleId) プライマリキーに該当するロールを生成します。
void | delete(Collection models) ロールの基本モデルを複数削除します。
void | delete(RoleBaseModel model) ロールの基本モデルを1つだけ削除します。
void | insert(Collection models) ロールの基本モデルを複数挿入します。
void | insert(RoleBaseModel model) ロールの基本モデルを1つだけ挿入します。
RoleBaseModel | select(String roleId) プライマリーキーで特定されるロールの基本モデルを取得します。
void | update(Collection models) ロールの基本モデルを複数更新します。
void | update(RoleBaseModel model) ロールの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public RoleBaseModel create(String roleId)
                     throws MapperException
プライマリキーに該当するロールを生成します。

パラメータ:
roleId - ロールID
戻り値:
プライマリキーに該当するロールの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public RoleBaseModel select(String roleId)
                     throws MapperException
プライマリーキーで特定されるロールの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
roleId - ロールID
戻り値:
ロールの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(RoleBaseModel model)
            throws MapperException
ロールの基本モデルを1つだけ挿入します。 引数に指定するロールの基本モデルは同一の RoleMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入するロールの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
ロールの基本モデルを複数挿入します。 引数に指定するものは同一の RoleMapperの create(String) で生成されたロールの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するロールの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(RoleBaseModel model)
            throws MapperException
ロールの基本モデルを1つだけ更新します。 引数に指定するロールの基本モデルは同一の RoleMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するロールの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
ロールの基本モデルを複数更新します。 引数に指定するものは同一の RoleMapperの select 系メソッド から取得されたものかで生成されたロールの基本モデルの集合である必要があります。

パラメータ:
models - 更新するロールの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(RoleBaseModel model)
            throws MapperException
ロールの基本モデルを1つだけ削除します。 引数で指定されたロールの基本モデルに該当するデータのすべての情報を削除します。引数に指定するロールの基本モデルは同一の RoleMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するロールの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
ロールの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するロールの基本モデルは同一の RoleMapperの select 系メソッド から取得されたロールの基本モデルの集合である必要があります。

パラメータ:
models - 削除するロールの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleSummaryBaseModel (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース RoleSummaryBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface RoleSummaryBaseModel
extends BaseModel

ロールサマリの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | ROLE_ID ロールID
static String | SUMMARY_ROLE_ID サマリロールID
メソッドの概要
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getRoleId() ロールIDを取得します。
String | getSummaryRoleId() サマリロールIDを取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

ROLE_ID

public static final String ROLE_ID
ロールID

関連項目:
定数フィールド値

SUMMARY_ROLE_ID

public static final String SUMMARY_ROLE_ID
サマリロールID

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getRoleId

public String getRoleId()
                 throws AccessorException
ロールIDを取得します。

戻り値:
ロールID
例外:
AccessorException - データの取得に失敗した場合

getSummaryRoleId

public String getSummaryRoleId()
                        throws AccessorException
サマリロールIDを取得します。

戻り値:
サマリロールID
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleSummaryMapper (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.security.datastore.inf
インタフェース RoleSummaryMapper

すべてのスーパーインタフェース:
Mapper
public interface RoleSummaryMapper
extends Mapper

ロールサマリに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
RoleSummaryBaseModel | create(String roleId, String summaryRoleId) プライマリキーに該当するロールサマリを生成します。
void | delete(Collection models) ロールサマリの基本モデルを複数削除します。
void | delete(RoleSummaryBaseModel model) ロールサマリの基本モデルを1つだけ削除します。
void | insert(Collection models) ロールサマリの基本モデルを複数挿入します。
void | insert(RoleSummaryBaseModel model) ロールサマリの基本モデルを1つだけ挿入します。
RoleSummaryBaseModel | select(String roleId, String summaryRoleId) プライマリーキーで特定されるロールサマリの基本モデルを取得します。
void | update(Collection models) ロールサマリの基本モデルを複数更新します。
void | update(RoleSummaryBaseModel model) ロールサマリの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public RoleSummaryBaseModel create(String roleId,
                                   String summaryRoleId)
                            throws MapperException
プライマリキーに該当するロールサマリを生成します。

パラメータ:
roleId - ロールID
summaryRoleId - サマリロールID
戻り値:
プライマリキーに該当するロールサマリの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public RoleSummaryBaseModel select(String roleId,
                                   String summaryRoleId)
                            throws MapperException
プライマリーキーで特定されるロールサマリの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。

パラメータ:
roleId - ロールID
summaryRoleId - サマリロールID
戻り値:
ロールサマリの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(RoleSummaryBaseModel model)
            throws MapperException
ロールサマリの基本モデルを1つだけ挿入します。 引数に指定するロールサマリの基本モデルは同一の RoleSummaryMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するロールサマリの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
ロールサマリの基本モデルを複数挿入します。 引数に指定するものは同一の RoleSummaryMapperの create(String,String) で生成されたロールサマリの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するロールサマリの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(RoleSummaryBaseModel model)
            throws MapperException
ロールサマリの基本モデルを1つだけ更新します。 引数に指定するロールサマリの基本モデルは同一の RoleSummaryMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するロールサマリの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
ロールサマリの基本モデルを複数更新します。 引数に指定するものは同一の RoleSummaryMapperの select 系メソッド から取得されたものかで生成されたロールサマリの基本モデルの集合である必要があります。

パラメータ:
models - 更新するロールサマリの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(RoleSummaryBaseModel model)
            throws MapperException
ロールサマリの基本モデルを1つだけ削除します。 引数で指定されたロールサマリの基本モデルに該当するデータのすべての情報を削除します。引数に指定するロールサマリの基本モデルは同一の RoleSummaryMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するロールサマリの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
ロールサマリの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するロールサマリの基本モデルは同一の RoleSummaryMapperの select 系メソッド から取得されたロールサマリの基本モデルの集合である必要があります。

パラメータ:
models - 削除するロールサマリの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


すべてのクラス (javadoc_foundation 6.1.14 API)

 すべてのクラス
AbstractComponent
AbstractDrawer
AbstractDualComparator
AbstractExportManagerClient
AbstractImportManagerClient
AbstractMessageReporter
AbstractSocketConnectionDistributor
AbstractTreeNodeContainer
AccessController
AccessControllerAccessor
AccessControllerBaseModel
AccessControllerDepartmentBaseModel
AccessControllerDepartmentMapper
AccessControllerExporter
AccessControllerImporter
AccessControllerManager
AccessControllerMapper
AccessControllerPermissionSelector
AccessControllerPostBaseModel
AccessControllerPostMapper
AccessControllerPostWriterListener
AccessControllerPublicGroupBaseModel
AccessControllerPublicGroupMapper
AccessControllerQueryWriterListener
AccessControllerReaderDecorator
AccessControllerRoleBaseModel
AccessControllerRoleMapper
AccessSecurityConfigException
AccessSecurityCreateException
AccessSecurityDeleteException
AccessSecurityException
AccessSecurityExportException
AccessSecurityImportException
AccessSecurityListenerExcpetion
AccessSecurityManager
AccessSecurityReadException
AccessSecurityRuntimeException
AccessSecurityUpdateException
AccessSecurityWriteException
AccessibleLinkHTTPActionEventFilterHandler
AccessorClosedException
AccessorException
AccessorIllegalPropertyValueException
AccessorSystemException
Account
AccountAccessor
AccountAttributeBaseModel
AccountAttributeMapper
AccountBaseModel
AccountChangedListener
AccountExporter
AccountImporter
AccountManager
AccountManager
AccountMapper
AccountPostWriterListener
AccountQueryWriterListener
AccountReaderDecorator
AccountRole
AccountRoleBaseModel
AccountRoleMapper
AccountRolePermissionSelector
AccountSecurityHTTPActionEventFilterHandler
AcsData
AcssecurityException
ActionListener
ActivationKey
ActiveSessionAccessor
ActiveSessionBindingListener
ActiveSessionException
ActiveSessionFilter
ActiveSessionInfo
ActiveSessionInvalidatedByForceException
ActiveSessionManager
ActiveSessionNotExistException
ActivityFrameworkHTTPActionEventFilterHandler
ActivityHTTPActionEventHandler
AdminMenuAccessor
AdminMenuExporter
AdminMenuImporter
AdminMenuInclusion
AdminMenuManager
AdminMenuPermissionSelector
AdminMenuPostWriterListener
AdminMenuQueryWriterListener
AdminMenuReaderDecorator
AdvancedOutputStreamWriter
Application
ApplicationInfo
AttachmentFile
Attribute
AttributeType
BASE64DecodeInputStream
BASE64DecodeOutputStream
BASE64EncodeOutputStream
BarGraphDrawer
BarGraphObject
BaseAccessor
BaseModel
BaseModel
BaseModelContext
BaseTable
Batch
BatchAccessor
BatchBaseModel
BatchExporter
BatchImporter
BatchManager
BatchMapper
BatchPostWriterListener
BatchProcessException
BatchQueryWriterListener
BatchReaderDecorator
BatchSystemException
CGIEnvironment
CalendarAccessor
CalendarExporter
CalendarImporter
CalendarInfo
CalendarInfoBaseModel
CalendarInfoInternationalModel
CalendarInfoMapper
CalendarManager
CalendarPlugin
CalendarPluginAutumnalEquinox
CalendarPluginEndOfTheMonth
CalendarPluginInfo
CalendarPluginLastDayInTheMonth
CalendarPluginMondayMakeupHoliday
CalendarPluginVernalEquinox
CalendarPostWriterListener
CalendarQueryWriterListener
CalendarReaderDecorator
CategorizedCalendarInfo
CategoryDetail
CategoryDetailBaseModel
CategoryDetailInternational
CategoryDetailInternationalModel
CategoryDetailMapper
CategoryManager
CateogryClass
CateogryClassBaseModel
CateogryClassInternational
CateogryClassInternationalModel
CateogryClassMapper
ChangedListenerException
CharacterEncoder
CircleGraphDrawer
CircleGraphObject
ClientTypeInfo
ColorPatternInfo
Column
ColumnMapping
Company
CompanyBaseModel
CompanyCategory
CompanyCategoryBaseModel
CompanyCategoryMapper
CompanyCategoryTerminable
CompanyCategoryTerminableModel
CompanyChangedControllerListener
CompanyChangedListener
CompanyChangedMenuListener
CompanyExportManager
CompanyExportManagerClient
CompanyImportManager
CompanyImportManagerClient
CompanyImporter
CompanyManager
CompanyMapper
CompanyPost
CompanyPostBaseModel
CompanyPostExportManager
CompanyPostExportManagerClient
CompanyPostImportManager
CompanyPostImportManagerClient
CompanyPostImporter
CompanyPostMapper
CompanyPostTerminable
CompanyPostTerminableInternational
CompanyPostTerminableInternationalModel
CompanyPostTerminableModel
CompanyTerminable
CompanyTerminableInternational
CompanyVersion
CompanyVersionBaseModel
CompanyVersionMapper
ConInfo
ConcreteHTTPActionEventHandler
Configuration
ConfigurationFactory
Counter
Cryption
CsvAccountBackup
CurrencyManager
DBResultAdapter
DBResultArrayAdapter
DBResultBigDecimalAdapter
DBResultBigIntAdapter
DBResultBinaryAdapter
DBResultBlobAdapter
DBResultBooleanAdapter
DBResultByteAdapter
DBResultClobAdapter
DBResultDateAdapter
DBResultDoubleAdapter
DBResultImTimestampAdapter
DBResultIntegerAdapter
DBResultNullAdapter
DBResultObjectAdapter
DBResultRealAdapter
DBResultRefAdapter
DBResultShortAdapter
DBResultStringAdapter
DBResultStructAdapter
DBResultTimeAdapter
DBResultTimestampAdapter
DataNotFoundException
DataSourceProvider
DataStoreApplicationException
DataStoreConfigException
DataStoreConst
DataStoreSystemException
DatabaseAccessor
DatabaseColumn
DatabaseExport
DatabaseExportException
DatabaseManager
DatabaseSQLException
DayInfo
DbManager
DbTypes
DbsConnection
Deal
DealBaseModel
DealDetail
DealDetailBaseModel
DealDetailMapper
DealDetailTerminableModel
DealManager
DealMapper
DealPermissionManager
DealTerminable
DealTerminableModel
DealerDepartment
DealerDepartmentBaseModel
DealerDepartmentMapper
DealerPublicGroup
DealerPublicGroupBaseModel
DealerPublicGroupMapper
DealerRole
DealerRoleBaseModel
DealerRoleMapper
Delete
DeleteType
Department
DepartmentAttach
DepartmentAttachBaseModel
DepartmentAttachMapper
DepartmentAttachTerminable
DepartmentAttachTerminableModel
DepartmentBaseModel
DepartmentInclusionBaseModel
DepartmentInclusionMapper
DepartmentInfo
DepartmentMain
DepartmentMainBaseModel
DepartmentMainMapper
DepartmentMainTerminable
DepartmentMainTerminableModel
DepartmentMapper
DepartmentStruct
DepartmentTerminable
DepartmentTerminableInternational
DepartmentTerminableInternationalModel
DepartmentTerminableModel
Directory
DualComparator
DuplicateException
DuplicateImageIconCodeException
DuplicateImageIconSrcException
DuplicateLoginAccessor
DuplicateLoginDetectedException
DuplicateLoginException
DuplicateLoginHandlingFilter
DuplicateLoginManager
EnCodeInterface
Entity
Environment
ErrorEvent
ErrorEventListener
ErrorPageProvider
EventAccessInfo
EventFlow
EventFlowInfo
EventHistoryInfo
EventItem
EventItemInfo
EventListener
EventNavigatorAccessor
EventNavigatorConst
EventNavigatorException
EventNavigatorExporter
EventNavigatorHandler
EventNavigatorImporter
EventNavigatorManager
EventNavigatorPermissionSelector
EventNavigatorReaderDecorator
EventQueueController
EventResultItem
EventResultItemInfo
EventScript
EverydayConditioner
ExpirationKey
ExportConfigurationReader
ExportConfigurationReaderException
ExportInitializeException
ExportManager
ExportManagerClient
ExportManagerImpl
ExtendedBaseAccessor
ExtendedBaseAccessorMap
ExtendedBaseModel
ExtendedBaseModel
ExtendedBaseModelMap
ExtendedBaseTable
ExtendedDirectory
ExtendedEntity
ExtendedFile
ExtendedGenericBaseModel
ExtendedGenericBaseModelMap
ExtendedGenericInternationalModel
ExtendedGenericInternationalModelMap
ExtendedGenericTerminableInternationalModel
ExtendedGenericTerminableInternationalModelMap
ExtendedGenericTerminableModel
ExtendedGenericTerminableModelMap
ExtendedInputStream
ExtendedInternationalAccessor
ExtendedInternationalAccessorMap
ExtendedInternationalModel
ExtendedInternationalModel
ExtendedInternationalModelMap
ExtendedInternationalTable
ExtendedModel
ExtendedOutputStream
ExtendedSocket
ExtendedTable
ExtendedTerminableAccessor
ExtendedTerminableAccessorMap
ExtendedTerminableInternationalAccessor
ExtendedTerminableInternationalAccessorMap
ExtendedTerminableInternationalModel
ExtendedTerminableInternationalModel
ExtendedTerminableInternationalModelMap
ExtendedTerminableInternationalTable
ExtendedTerminableModel
ExtendedTerminableModel
ExtendedTerminableModelMap
ExtendedTerminableTable
ExtendedThread
ExtendsImport
ExtendsImportManager
ExternalDirectory
ExternalMemory
FavoriteMenu
FavoriteMenuBaseModel
FavoriteMenuMapper
FileReporter
FileSender
FileSizeConditioner
Filter
FilterComparator
FilterHTTPActionEvent
FilterHTTPActionEventChain
FilterMessageReporter
FixedSizeMap
FoundationException
FoundationRuntimeException
FunctionContainer
FunctionContainerFile
GCConditioner
GarbageController
GenericBaseModel
GenericInternationalModel
GenericInternationalModelMap
GenericTerminableInternationalModel
GenericTerminableInternationalModelMap
GenericTerminableModel
GenericTerminableModelMap
GenericURLBuilder
GroupActiveSessionRegister
GroupSecurityHTTPActionEventFilterHandler
GroupSuperUserAccessor
GroupSuperUserInitialServlet
GroupSuperUserPostWriterListener
GroupSuperUserQueryWriterListener
GroupSuperUserReaderDecorator
HTTPActionEvent
HTTPActionEventClientContext
HTTPActionEventContent
HTTPActionEventContext
HTTPActionEventEntityHandler
HTTPActionEventException
HTTPActionEventFilterHandler
HTTPActionEventHandler
HTTPActionEventHandlerException
HTTPActionEventHandlerParameterException
HTTPActionEventListenerContext
HTTPActionEventResult
HTTPActionEventResultWrapper
HTTPActionEventURL
HalfKanaTransrateListener
HexInputStream
HexOutputStream
HomeDirectory
INonTransaction
Identifier
IllegalArgumentException
IllegalExtensionException
IllegalLocaleException
IllegalPasswordException
IllegalRelationshipException
IllegalTermException
ImAjaxUtil
ImageIconException
ImageIconInfo
ImageIconManager
ImageIconMessageBundle
ImportConfigurationReader
ImportConfigurationReaderException
ImportException
ImportInitializeException
ImportManager
ImportManagerClient
ImportManagerImpl
InitialFile
InitialPageSessionHandlingFilter
InputCheck
InternationalAccessor
InternationalAccessorMap
InternationalKey
InternationalModel
InternationalModel
InternationalModelContext
InternationalModelMap
InternationalTable
InternetPortlet
IntramartDBMapper
Item
ItemAttach
ItemAttachBaseModel
ItemAttachImporter
ItemAttachMapper
ItemAttribute
ItemAttributeBaseModel
ItemAttributeInternational
ItemAttributeInternationalModel
ItemAttributeMapper
ItemBaseModel
ItemCatalogue
ItemCatalogueBaseModel
ItemCatalogueMapper
ItemCatalogueMediaManager
ItemCategory
ItemCategoryBaseModel
ItemCategoryImporter
ItemCategoryInternational
ItemCategoryInternationalModel
ItemCategoryManager
ItemCategoryMapper
ItemCategoryStruct
ItemCategoryType
ItemCategoryTypeBaseModel
ItemCategoryTypeMapper
ItemImporter
ItemManager
ItemMapper
ItemTemplate
ItemTemplateBaseModel
ItemTemplateDetail
ItemTemplateDetailBaseModel
ItemTemplateDetailInternational
ItemTemplateDetailInternationalModel
ItemTemplateDetailMapper
ItemTemplateImporter
ItemTemplateInternational
ItemTemplateInternationalModel
ItemTemplateManager
ItemTemplateMapper
ItemTerminable
ItemTerminableInternational
ItemTerminableInternationalModel
ItemTerminableModel
ItemUnitManager
J2eeFwPortlet
JavaMailPropertyException
JavaMailPropertyHandler
JavaMailPropertyHandlerInitializerImpl
JavaMailSender
JspPortlet
LDAPContextInfoBuilder
LDAPContextInfoModel
LDAPUserCertification
LDAPUserCertification
LicenseManager
Lifetime
LifetimeType
LimitedSessionHTTPActionEventFilterHandler
LineGraphDrawer
LineGraphObject
LineReportFilter
LinkPageInfo
LocaleInfo
LocaleProvider
Localhost
Lock
LockMonitor
LogConstraint
LoginGroup
LoginGroupAccessor
LoginGroupManager
LoginGroupPostWriterListener
LoginGroupQueryWriterListener
LoginGroupReaderDecorator
LoginInfo
LoginRequestInfo
Logingp
LogoutInitialUrlValidator
LogoutServlet
Mail
MailAddress
MailSendEvent
MailSendListener
MailSender
MailSenderException
MainPageImportLoginGroupPostWriterListener
MainPagePatternInfo
ManagerException
Mapper
MapperDAOException
MapperException
MapperFactory
MenuAccessor
MenuArgumentBaseModel
MenuArgumentMapper
MenuBaseModel
MenuDepartmentBaseModel
MenuDepartmentMapper
MenuExporter
MenuImporter
MenuInclusion
MenuInternationalModel
MenuItem
MenuLinkSetPortlet
MenuManager
MenuMapper
MenuPermissionSelector
MenuPostBaseModel
MenuPostMapper
MenuPostWriterListener
MenuPublicGroupBaseModel
MenuPublicGroupMapper
MenuQueryWriterListener
MenuReaderDecorator
MenuRoleBaseModel
MenuRoleMapper
MenuServlet
MenuTree
MessageManager
MessageReporter
MobileEasyLoginAuAnalyzer
MobileEasyLoginAuHdmlAnalyzer
MobileEasyLoginDocomoAnalyzer
MobileEasyLoginDocomoMoveAnalyzer
MobileEasyLoginJphoneAnalyzer
MobileEasyLoginSoftBankAnalyzer
MobileEasyLoginUtil
MobileEasyLoginVodafoneAnalyzer
MobileUserAgentProvider
Model
MultiCastReporter
MultiComparator
MultipartFormData
MultipartFormData.Entity
MultipurposeInternetMailExtensions
NavigatorAuthenticateItem
NavigatorInfo
NavigatorItem
NetworkAgent
NetworkConnector
NetworkFile
NewArrived
NewArrivedManager
NewArrivedProvider
NoCryption
NoFilterException
NoSessionCookieException
NoSessionException
NoSuchPropertyException
NodeNameComparator
NodeTypeComparator
NonceResetListener4MobileEasyLogin
NotExistException
NotExistImageIconException
NotFoundDataSourceException
NotSupportMethodException
OutputSizeConditioner
PageBaseCallProvider
ParameterManager
ParameterSourceProvider
PasswordHistory
PasswordHistoryAccessor
PasswordHistoryAccountChangedListener
PasswordHistoryException
PasswordHistoryManager
PasswordHistoryManagerInitializerImpl
PasswordHistoryNewArrivedProvider
PasswordHistoryResult
PasswordHistoryUserPageProvider
PasswordSecurityHTTPActionEventFilterHandler
PeriodicConditioner
PermanentDataArchiveFactory
PermanentDataDirectory
PermanentDirectory
PermanentFile
PermissionManager
PermissionSelector
PlainCompanyPost
Platform
PortFolioDrawer
PortFolioObject
PortalStandardUserPageProvider
Portlet
PortletManager
PortletManagerException
PortletMapping
PostInfo
PresentationPage
PresentationPageHTTPActionEventHandler
PresentationPagePortlet
PrimaryKeyMapping
PrintStreamReporter
PrivateGroup
PrivateGroupAttach
PrivateGroupAttachBaseModel
PrivateGroupAttachMapper
PrivateGroupBaseModel
PrivateGroupChangedListener
PrivateGroupManager
PrivateGroupMapper
ProcedureComponent
Property
PublicGroup
PublicGroupAttach
PublicGroupAttachBaseModel
PublicGroupAttachMapper
PublicGroupAttachTerminable
PublicGroupAttachTerminableModel
PublicGroupBaseModel
PublicGroupCategory
PublicGroupCategoryBaseModel
PublicGroupCategoryMapper
PublicGroupCategoryTerminable
PublicGroupCategoryTerminableModel
PublicGroupChangedControllerListener
PublicGroupChangedListener
PublicGroupChangedMenuListener
PublicGroupExportManager
PublicGroupExportManagerClient
PublicGroupImportManager
PublicGroupImportManagerClient
PublicGroupImporter
PublicGroupInclusionBaseModel
PublicGroupInclusionMapper
PublicGroupInfo
PublicGroupManager
PublicGroupMapper
PublicGroupSet
PublicGroupSetBaseModel
PublicGroupSetMapper
PublicGroupSetTerminable
PublicGroupSetTerminableInternational
PublicGroupStruct
PublicGroupTerminable
PublicGroupTerminableInternational
PublicGroupTerminableInternationalModel
PublicGroupTerminableModel
PublicGroupVersion
PublicGroupVersionBaseModel
PublicGroupVersionMapper
RSSParserIF
RadarChartDrawer
RadarChartObject
Relationship
ReplaceWriter
ReportFileConditioner
ReportFileWriter
ReportLevel
ReportLevelFilter
RepresentativeReporter
RequestAnalyzer
RequestCharacterEncodingFilter
ResourceBundleProperties
ResourceFormatException
ResourceNotFoundException
ResponseCharacterEncodingFilter
ResultPageItem
ResultPageItemInfo
ReverseComparator
Role
RoleAccessor
RoleBaseModel
RoleChangedAccountListener
RoleChangedControllerListener
RoleChangedListener
RoleChangedMenuListener
RoleExporter
RoleImporter
RoleInclusionBaseModel
RoleInclusionMapper
RoleInternationalModel
RoleManager
RoleManager
RoleMapper
RolePostWriterListener
RoleQueryWriterListener
RoleReaderDecorator
RoleSummaryBaseModel
RoleSummaryMapper
RssPortlet
SSORequestAnalyzer
SaveEventHistoryInfo
SaveEventResultItemInfo
Scheduler
ScriptCompileException
ScriptRuntimeException
ScriptValue
SecurityConstraint
SelectItem
SelectItemInfo
SequenceComparator
ServerConnector
ServiceFrameworkHTTPActionEventHandler
ServletHTTPActionEventHandler
SessionConfig
SessionFactory
SessionFilter
SessionInfo
SessionMemory
SessionQuery
ShortCutAccessor
ShortCutInfo
ShortCutManager
SocketConnection
SocketConnectionDistributor
SocketConnectionDistributorFactory
SocketConnectionManager
SocketEventListener
SocketPool
SourceProviderHandler
StandardAccessControllerAccessor
StandardAccessControllerBackup
StandardAccountAccessor
StandardAccountBackup
StandardActiveSessionAccessor
StandardAdminMenuBackup
StandardBatchAccessor
StandardBatchBackup
StandardCalendarAccessor
StandardCalendarBackup
StandardCompanyImporter
StandardCompanyPostImporter
StandardCryption
StandardDuplicateLoginAccessor
StandardErrorPageProvider
StandardEventNavigatorAccessor
StandardEventNavigatorExporter
StandardEventNavigatorImporter
StandardGroupSuperUserPageProvider
StandardItemAttachImporter
StandardItemCategoryImporter
StandardItemImporter
StandardItemTemplateImporter
StandardMail
StandardMenuAccessor
StandardMenuBackup
StandardPasswordHistoryAccessor
StandardPortlet
StandardPublicGroupImporter
StandardRequestAnalyzer
StandardRoleAccessor
StandardRoleBackup
StandardShortCutAccessor
StandardSuperUserCertification
StandardSuperUserPageProvider
StandardUpdateAccessor
StandardUserCertification
StandardUserImporter
StandardUserPageProvider
StorageDirectory
SuperCertification
SuperCertificationListener
SuperUser
SuperUserAccessor
SuperUserInitialServlet
SuperUserNoCertification
SuperUserPostWriterListener
SuperUserQueryWriterListener
SuperUserReaderDecorator
SystemConfigException
SystemErrorReporter
SystemManager
SystemReporter
SystemSourceProvider
Table
TemporaryDirectory
TemporaryFile
Term
TermManager
TermManagerException
TerminableAccessor
TerminableAccessorMap
TerminableInternationalAccessor
TerminableInternationalAccessorMap
TerminableInternationalModel
TerminableInternationalModel
TerminableInternationalModelContext
TerminableInternationalModelMap
TerminableInternationalTable
TerminableKey
TerminableModel
TerminableModel
TerminableModelContext
TerminableModelMap
TerminableTable
ThreadStopListener
TitleInfo
TreasureDirectory
TreasureFile
TreeBranch
TreeLeaf
TreeNode
TreeNodeContainer
TreeNodeProvider
TreeRoot
URLAccessFilter
URLBuilder
URLDecodeInputStream
URLDecodeOutputStream
URLEncodeOutputStream
UnitBaseModel
UnitMapper
UnsupportedNetworkConnectException
UpdateAccessor
UpdateInfo
UpdateManager
User
UserActiveSessionRegister
UserAttachExportManager
UserAttachExportManagerClient
UserAttachImportManager
UserAttachImportManagerClient
UserBaseModel
UserCertification
UserCertificationListener
UserCertificationServlet
UserChangedListener
UserImporter
UserInitialServlet
UserManager
UserMapper
UserPageProvider
UserProfileExportManager
UserProfileExportManagerClient
UserProfileImportManager
UserProfileImportManagerClient
UserTerminable
UserTerminableInternational
UserTerminableInternationalModel
UserTerminableModel
VariableScope
WebApplicationHTTPActionEventHandler
XORInputStream
XOROutputStream


定数フィールド値 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
  • jp.co.*
jp.co.*

jp.co.intra_mart.foundation.database.ConInfo
public static final String | TYPE_DATA_SOURCE | "DataSource"
public static final String | TYPE_GROUP | "Group"
public static final String | TYPE_JDBC | "Jdbc"
public static final String | TYPE_SYSTEM | "System"

jp.co.intra_mart.foundation.database.DatabaseColumn
public static final int | INDEX_UNDEFINED | -2
public static final int | TYPE_DATE | 3
public static final int | TYPE_NUMBER | 2
public static final int | TYPE_STRING | 1
public static final int | TYPE_UNDEFINED | -1

jp.co.intra_mart.foundation.database.DatabaseExport
public static final int | DBTYPE_DB2 | 2
public static final int | DBTYPE_ORACLE | 1
public static final int | DBTYPE_POSTGRESQL | 3
public static final int | DBTYPE_SQLSERVER | 4

jp.co.intra_mart.foundation.database.exception.DatabaseExportException
public static final int | PROCESS_BUSY | 1
public static final int | WRITE_TIMEOUT | 2

jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel
public static final String | CATEGORY_CLASS_CODE | "categoryClassCode"
public static final String | NAME | "name"
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel
public static final String | CATEGORY_CLASS_CODE | "categoryClassCode"
public static final String | CATEGORY_CODE | "categoryCode"
public static final String | NAME | "name"
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | DEPARTMENT_CODE | "departmentCode"
public static final String | POST_CODE | "postCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"
public static final String | USER_CODE | "userCode"

jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel
public static final String | CATEGORY_CLASS_CODE | "categoryClassCode"
public static final String | CATEGORY_CODE | "categoryCode"
public static final String | COMPANY_CODE | "companyCode"
public static final String | DEPARTMENT_CODE | "departmentCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel
public static final String | ADDRESS1 | "address1"
public static final String | ADDRESS2 | "address2"
public static final String | COMPANY_CODE | "companyCode"
public static final String | COUNTRY_CODE | "countryCode"
public static final String | DEPARTMENT_CODE | "departmentCode"
public static final String | EMAIL_ADDRESS1 | "emailAddress1"
public static final String | EMAIL_ADDRESS2 | "emailAddress2"
public static final String | EXTENSION_FAX_NUMBER | "extensionFaxNumber"
public static final String | EXTENSION_NUMBER | "extensionNumber"
public static final String | FAX_NUMBER | "faxNumber"
public static final String | NAME | "name"
public static final String | NAME_ENGLISH | "nameEnglish"
public static final String | NAME_SYLLABARY | "nameSyllabary"
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"
public static final String | TELEPHONE_NUMBER | "telephoneNumber"
public static final String | URL | "url"
public static final String | ZIP_CODE | "zipCode"

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | DEPARTMENT_CODE | "departmentCode"
public static final String | DEPTH | "depth"
public static final String | PARENT_DEPARTMENT_CODE | "parentDepartmentCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | VERSION_CODE | "versionCode"

jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | DEPARTMENT_CODE | "departmentCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | USER_CODE | "userCode"

jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | NAME | "name"
public static final String | NOTES | "notes"
public static final String | POST_CODE | "postCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"

jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | END_DATE | "endDate"
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | START_DATE | "startDate"
public static final String | VERSION_CODE | "versionCode"

jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel
public static final String | CURRENCY_CODE | "currencyCode"
public static final String | CUSTOMER_COMPANY_CODE | "customerCompanyCode"
public static final String | CUSTOMER_DEPARTMENT_CODE | "customerDepartmentCode"
public static final String | DEAL_CODE | "dealCode"
public static final String | DEAL_NAME | "dealName"
public static final String | DEAL_TYPE | "dealType"
public static final int | DEAL_TYPE_BUY | 0
public static final int | DEAL_TYPE_SELL | 1
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | UNIT_PRICE | "unitPrice"

jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | CUSTOMER_COMPANY_CODE | "customerCompanyCode"
public static final String | CUSTOMER_DEPARTMENT_CODE | "customerDepartmentCode"
public static final String | DEAL_CODE | "dealCode"
public static final String | DEPARTMENT_CODE | "departmentCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel
public static final String | AMOUNT | "amount"
public static final String | CUSTOMER_COMPANY_CODE | "customerCompanyCode"
public static final String | CUSTOMER_DEPARTMENT_CODE | "customerDepartmentCode"
public static final String | DEAL_CODE | "dealCode"
public static final String | ITEM_CODE | "itemCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | UNIT_CODE | "unitCode"
public static final String | UNIT_PRICE | "unitPrice"

jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel
public static final String | CUSTOMER_COMPANY_CODE | "customerCompanyCode"
public static final String | CUSTOMER_DEPARTMENT_CODE | "customerDepartmentCode"
public static final String | DEAL_CODE | "dealCode"
public static final String | PUBLIC_GROUP_CODE | "publicGroupCode"
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel
public static final String | CUSTOMER_COMPANY_CODE | "customerCompanyCode"
public static final String | CUSTOMER_DEPARTMENT_CODE | "customerDepartmentCode"
public static final String | DEAL_CODE | "dealCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | ROLE_ID | "roleId"

jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel
public static final String | ITEM_CATEGORY_CODE | "itemCategoryCode"
public static final String | ITEM_CATEGORY_TYPE_CODE | "itemCategoryTypeCode"
public static final String | ITEM_CODE | "itemCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CD | "recordUserCd"

jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel
public static final String | ITEM_CATEGORY_CODE | "itemCategoryCode"
public static final String | ITEM_CATEGORY_NAME | "itemCategoryName"
public static final String | ITEM_CATEGORY_TYPE_CODE | "itemCategoryTypeCode"
public static final String | NOTES | "notes"
public static final String | PARENT_ITEM_CATEGORY_CODE | "parentItemCategoryCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"

jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel
public static final String | ITEM_CATEGORY_TYPE_CODE | "itemCategoryTypeCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel
public static final String | DATA_TYPE | "dataType"
public static final int | DATA_TYPE_NUMBER | 0
public static final int | DATA_TYPE_STRING | 1
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CD | "recordUserCd"
public static final String | SORT_KEY | "sortKey"
public static final String | TEMPLATE_CODE | "templateCode"
public static final String | TEMPLATE_DETAIL_CODE | "templateDetailCode"
public static final String | TEMPLATE_DETAIL_NAME | "templateDetailName"

jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CD | "recordUserCd"
public static final String | TEMPLATE_CODE | "templateCode"
public static final String | TEMPLATE_NAME | "templateName"

jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel
public static final String | ITEM_CODE | "itemCode"
public static final String | NUMBER_VALUE | "numberValue"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | STRING_VALUE | "stringValue"
public static final String | TEMPLATE_CODE | "templateCode"
public static final String | TEMPLATE_DETAIL_CODE | "templateDetailCode"

jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel
public static final String | ITEM_CATALOGUE_CODE | "itemCatalogueCode"
public static final String | ITEM_CODE | "itemCode"
public static final String | MEDIA | "media"
public static final String | MEDIA_CLS | "mediaCls"
public static final int | MEDIA_CLS_FILE | 0
public static final int | MEDIA_CLS_URL | 1
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "SortKey"

jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel
public static final String | ITEM_CAPTION | "itemCaption"
public static final String | ITEM_CODE | "itemCode"
public static final String | ITEM_NAME | "itemName"
public static final String | NOTES | "notes"
public static final String | PRODUCT_MODEL_CODE | "productModelCode"
public static final String | PURCHASE_UNIT_PRICE | "purchaseUnitPrice"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SALES_UNIT_PRICE | "salesUnitPrice"

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel
public static final String | OWNER_CODE | "ownerCode"
public static final String | PRIVATE_GROUP_CODE | "privateGroupCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"
public static final String | USER_CODE | "userCode"

jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel
public static final String | NAME | "name"
public static final String | NAME_ENGLISH | "nameEnglish"
public static final String | NAME_SYLLABARY | "nameSyllabary"
public static final String | NOTES | "notes"
public static final String | OWNER_CODE | "ownerCode"
public static final String | PRIVATE_GROUP_CODE | "privateGroupCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel
public static final String | PUBLIC_GROUP_CODE | "publicGroupCode"
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"
public static final String | USER_CODE | "userCode"

jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel
public static final String | CATEGORY_CLASS_CODE | "categoryClassCode"
public static final String | CATEGORY_CODE | "categoryCode"
public static final String | PUBLIC_GROUP_CODE | "publicGroupCode"
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel
public static final String | NAME | "name"
public static final String | NAME_ENGLISH | "nameEnglish"
public static final String | NAME_SYLLABARY | "nameSyllabary"
public static final String | NOTES | "notes"
public static final String | PUBLIC_GROUP_CODE | "publicGroupCode"
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel
public static final String | DEPTH | "depth"
public static final String | PARENT_PUBLIC_GROUP_CODE | "parentPublicGroupCode"
public static final String | PUBLIC_GROUP_CODE | "publicGroupCode"
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | VERSION_CODE | "versionCode"

jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel
public static final String | END_DATE | "endDate"
public static final String | NOTES | "notes"
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | START_DATE | "startDate"
public static final String | VERSION_CODE | "versionCode"

jp.co.intra_mart.foundation.datastore.application.model.unit.UnitBaseModel
public static final String | UNIT_CODE | "unitCode"
public static final String | UNIT_NAME | "unitName"

jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel
public static final String | ACCOUNT_FLAG | "accountFlag"
public static final String | ADDRESS | "address"
public static final String | AVALIABLE_LOGIN_USER | "1"
public static final String | COUNTRY_CODE | "countryCode"
public static final String | EMAIL_ADDRESS1 | "emailAddress1"
public static final String | EMAIL_ADDRESS2 | "emailAddress2"
public static final String | EXTENSION_FAX_NUMBER | "extensionFaxNumber"
public static final String | EXTENSION_NUMBER | "extensionNumber"
public static final String | FAX_NUMBER | "faxNumber"
public static final String | MOBILE_EMAIL_ADDRESS | "mobileEmailAddress"
public static final String | MOBILE_NUMBER | "mobileNumber"
public static final String | NAME | "name"
public static final String | NAME_ENGLISH | "nameEnglish"
public static final String | NAME_SYLLABARY | "nameSyllabary"
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"
public static final String | TELEPHONE_NUMBER | "telephoneNumber"
public static final String | UNAVALIABLE_LOGIN_USER | "0"
public static final String | URL | "url"
public static final String | USER_CODE | "userCode"
public static final String | ZIP_CODE | "zipCode"

jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil
public static final String | IM_AJAX_USER_AGENT_FIREFOX | "Firefox"
public static final String | IM_AJAX_USER_AGENT_IE | "IE"
public static final String | IM_AJAX_USER_AGENT_NETSCAPE | "Netscape"
public static final String | IM_AJAX_USER_AGENT_OPERA | "Opera"
public static final String | IM_AJAX_USER_AGENT_SAFARI | "Safari"
public static final String | REQUEST_HEADER_NAME_IM_AJAX_REQUEST | "x-jp-co-intra-mart-ajax-request"
public static final String | REQUEST_HEADER_NAME_IM_AJAX_USER_AGENT | "x-jp-co-intra-mart-ajax-user-agent"
public static final String | RESPONSE_HEADER_NAME_IM_AJAX_ERROR_CODE | "x-jp-co-intra-mart-ajax-error-code"
public static final String | RESPONSE_HEADER_NAME_IM_AJAX_ERROR_MESSAGE | "x-jp-co-intra-mart-ajax-error-message"

jp.co.intra_mart.foundation.image.ImageIconInfo
public static final int DEFAULT_SORT_KEY 0

jp.co.intra_mart.foundation.log.LogConstraint
public static final String RESPONSE_HEADER_NAME_NEXT_PAGE_TITLE "x-jp-co-intra-mart-log-next-page-title"

jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener
public static final int | CONTINUE | 0
public static final int | SKIP_LISTENER | 1
public static final int | STOP_MAILSEND | 2

jp.co.intra_mart.foundation.navigator.EventNavigatorConst
public static final String | ATTRIBUTE_TYPE_HISTORY_COUNT | "history_count"
public static final String | COLUMN_NAVIGATOR_ACTION_TYPE | "action_type"
public static final String | COLUMN_NAVIGATOR_ANSWER | "answer"
public static final String | COLUMN_NAVIGATOR_COMPANY_CD | "company_cd"
public static final String | COLUMN_NAVIGATOR_DEPARTMENT_CD | "department_cd"
public static final String | COLUMN_NAVIGATOR_DESCRIPTION | "description"
public static final String | COLUMN_NAVIGATOR_EVENT_FLOW_ID | "event_flow_id"
public static final String | COLUMN_NAVIGATOR_EVENT_ITEM_ID | "event_item_id"
public static final String | COLUMN_NAVIGATOR_EVENT_RESULT_ID | "event_result_id"
public static final String | COLUMN_NAVIGATOR_IDENTIFICATION_ID | "identification_id"
public static final String | COLUMN_NAVIGATOR_LOCALE | "locale"
public static final String | COLUMN_NAVIGATOR_MAX_SORT_NUM | "max_sort_num"
public static final String | COLUMN_NAVIGATOR_NEXT_ITEM_ID | "next_item_id"
public static final String | COLUMN_NAVIGATOR_OPEN | "open_flag"
public static final String | COLUMN_NAVIGATOR_PAGE_URL | "page_url"
public static final String | COLUMN_NAVIGATOR_PARAM_KEY | "param_key"
public static final String | COLUMN_NAVIGATOR_PARAM_VALUE | "param_value"
public static final String | COLUMN_NAVIGATOR_PERMISSION_CHECK_FLAG | "permission_check_flag"
public static final String | COLUMN_NAVIGATOR_POST_CD | "post_cd"
public static final String | COLUMN_NAVIGATOR_PUBLIC_GROUP_CD | "public_group_cd"
public static final String | COLUMN_NAVIGATOR_PUBLIC_GROUP_SET_CD | "public_group_set_cd"
public static final String | COLUMN_NAVIGATOR_QUESTION | "question"
public static final String | COLUMN_NAVIGATOR_RECORD_DATE | "record_date"
public static final String | COLUMN_NAVIGATOR_RECORD_USER | "record_user_cd"
public static final String | COLUMN_NAVIGATOR_RESULT_PAGE_ID | "result_page_id"
public static final String | COLUMN_NAVIGATOR_ROLE_ID | "role_id"
public static final String | COLUMN_NAVIGATOR_SELECT_ITEM_ID | "select_item_id"
public static final String | COLUMN_NAVIGATOR_SORT_NUMBER | "sort_number"
public static final String | COLUMN_NAVIGATOR_START_EVENT_ITEM_ID | "start_event_item_id"
public static final String | COLUMN_NAVIGATOR_TITLE | "title"
public static final String | COLUMN_NAVIGATOR_TYPE | "type"
public static final String | COLUMN_NAVIGATOR_USER_ID | "user_id"
public static final String | CONFIG_FILE | "conf/event-navigator-config.xml"
public static final String | DB_DB2 | "db2"
public static final String | DB_ORACLE | "oracle"
public static final String | DB_POSTGRE | "postgresql"
public static final String | DEFAULT_ACCESSOR | "jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor"
public static final String | DEFAULT_COMMENT | "\u8cea\u554f\u5185\u5bb9\uff11"
public static final String | DEFAULT_CONFIG_PAGE_COUNT | "5"
public static final String | DEFAULT_EXPORTER | "jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter"
public static final String | DEFAULT_IMPORTER | "jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter"
public static final String | DEFAULT_TITLE | "\u8cea\u554f\u5185\u5bb9\uff11"
public static final String | ESCAPE_LEFT_PARENTHESIS | "["
public static final String | ESCAPE_PERCENTAGE | "%"
public static final String | ESCAPE_RIGHT_PARENTHESIS | "]"
public static final String | ESCAPE_STRING | "@"
public static final String | ESCAPE_UNDER_SCORE | "_"
public static final String | EVENT_NAVIGATOR_PERMISSION_SELECTOR | "event-navigator"
public static final String | ID_NAVIGATOR_ACCESS_INFO | "access-info"
public static final String | ID_NAVIGATOR_COMMENT | "comment"
public static final String | ID_NAVIGATOR_COMPANY_ID | "company-cd"
public static final String | ID_NAVIGATOR_DEPARTMENT | "department"
public static final String | ID_NAVIGATOR_DEPARTMENT_ID | "department-cd"
public static final String | ID_NAVIGATOR_EVENT_FLOW | "event-flow"
public static final String | ID_NAVIGATOR_EVENT_FLOW_ID | "event-flow-id"
public static final String | ID_NAVIGATOR_EVENT_FLOW_OPEN | "event-flow-open"
public static final String | ID_NAVIGATOR_EVENT_FLOW_SORT_NUMBER | "event-flow-sort-number"
public static final String | ID_NAVIGATOR_EVENT_ITEM | "event-item"
public static final String | ID_NAVIGATOR_EVENT_ITEM_ID | "event-item_id"
public static final String | ID_NAVIGATOR_EVENT_RESULT | "event-result"
public static final String | ID_NAVIGATOR_EVENT_RESULT_ID | "event-result_id"
public static final String | ID_NAVIGATOR_GROUP_ID | "group-cd"
public static final String | ID_NAVIGATOR_GROUP_SET_ID | "group-set-cd"
public static final String | ID_NAVIGATOR_ITEM_TYPE | "item-type"
public static final String | ID_NAVIGATOR_LINK_PAGE | "link-page"
public static final String | ID_NAVIGATOR_LOCALE | "locale"
public static final String | ID_NAVIGATOR_PARAM | "param"
public static final String | ID_NAVIGATOR_PARAM_KEY | "param-key"
public static final String | ID_NAVIGATOR_PARAM_VALUE | "param-value"
public static final String | ID_NAVIGATOR_POST | "post"
public static final String | ID_NAVIGATOR_POST_ID | "post-cd"
public static final String | ID_NAVIGATOR_PUBLIC_GROUP | "public-group"
public static final String | ID_NAVIGATOR_RESULT_PAGE | "result-page"
public static final String | ID_NAVIGATOR_RESULT_PAGE_ID | "result-page-id"
public static final String | ID_NAVIGATOR_RESULT_PAGE_LIST | "result-page-list"
public static final String | ID_NAVIGATOR_ROLE | "role"
public static final String | ID_NAVIGATOR_ROLE_ID | "role-id"
public static final String | ID_NAVIGATOR_SELECT_ITEM | "select-item"
public static final String | ID_NAVIGATOR_SELECT_ITEM_ID | "select-item_id"
public static final String | ID_NAVIGATOR_SELECT_ITEM_LIST | "select-item-list"
public static final String | ID_NAVIGATOR_TITLE | "title"
public static final String | ID_NAVIGATOR_TITLE_INFO | "title-info"
public static final String | ID_NAVIGATOR_URL | "url"
public static final String | ID_ROOT | "intra-mart"
public static final String | ID_ROOT_NAVIGATOR | "navigator"
public static final String | KIND_NAVIGATOR | "EventNavigator "
public static final String | OPEN_FLG_CLOSE | "close"
public static final String | OPEN_FLG_EDIT | "edit"
public static final String | OPEN_FLG_OPEN | "open"
public static final String | ROOT_FOLDER | "conf/"
public static final String | SAVE_TYPE_FAVORITE | "favorite"
public static final String | SAVE_TYPE_HISTORY | "history"
public static final String | TABLE_B_M_EVENT_DEPARTMENT | "b_m_event_department"
public static final String | TABLE_B_M_EVENT_FLOW | "b_m_event_flow"
public static final String | TABLE_B_M_EVENT_ITEM | "b_m_event_item"
public static final String | TABLE_B_M_EVENT_PAGE | "b_m_event_page"
public static final String | TABLE_B_M_EVENT_PAGE_PARAM | "b_m_event_page_param"
public static final String | TABLE_B_M_EVENT_POST | "b_m_event_post"
public static final String | TABLE_B_M_EVENT_PUBLIC_GROUP | "b_m_event_public_group"
public static final String | TABLE_B_M_EVENT_RESULT | "b_m_event_result"
public static final String | TABLE_B_M_EVENT_ROLE | "b_m_event_role"
public static final String | TABLE_B_M_EVENT_SAVE_RESULT | "b_m_event_save_result"
public static final String | TABLE_B_M_EVENT_SELECT | "b_m_event_select"
public static final String | TABLE_B_M_EVENT_TITLE_INFO | "b_m_event_title_info"
public static final String | TYPE_EVENT | "event"
public static final String | TYPE_RESULT | "result"

jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor
public static final String | DEFAULT_COMMENT | "\u8cea\u554f\u5185\u5bb9\uff11"
public static final String | DEFAULT_FAVORITE | "favorite"
public static final String | DEFAULT_HISTORY | "history"
public static final String | DEFAULT_TITLE | "\u8cea\u554f\u5185\u5bb9\uff11"
public static final String | KIND_NAVIGATOR | "EventNavigator "

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider
public static final String PAGE_PATH "pagePath"

jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet
public static final String PAGE_KIND "internet"

jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet
public static final String PAGE_KIND "framework"

jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet
public static final String PAGE_KIND "jsp"

jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet
public static final String PAGE_KIND "menu"

jp.co.intra_mart.foundation.portal.portlet.model.Portlet
public static final String | DISPLAY_PERCENT | "c"
public static final String | DISPLAY_PIXCEL | "p"

jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet
public static final String PAGE_KIND "pagebase"

jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet
public static final String PAGE_KIND "rss"

jp.co.intra_mart.foundation.security.SecurityConstraint
public static final String | ATTR_CERTIFICATION_MODE | "jp.co.intr_mart.certification.do"
public static final String | ATTR_DO_FILTER | "jp.co.intr_mart.session.filter.do"
public static final String | CP_COOKIE | "jp.co.intra_mart.session.cookie"
public static final int | CR_ERROR | -7
public static final int | CR_LOCKED | -3
public static final int | CR_NG | 0
public static final int | CR_NO_GROUP | -2
public static final int | CR_NO_LICENSE | -1
public static final int | CR_NO_PERMISSION | -6
public static final int | CR_NO_USER | -8
public static final int | CR_OK | 1
public static final int | CR_SESSION_INITIAL | 2
public static final int | CR_SESSION_LOGON | 3
public static final int | CR_SESSION_TIMEOUT | -5
public static final int | CR_SESSION_UNMATCH | -4
public static final String | LT_GROUP | "group"
public static final String | LT_SUPER | "super"
public static final String | LT_USER | "user"
public static final String | RP_CLIENT_TYPE | "im_client_type"
public static final String | RP_ENCODING | "im_encoding"
public static final String | RP_INITIAL_URL | "im_initial_url"
public static final String | RP_LOCALE | "im_locale"
public static final String | RP_LOGIN_GROUP | "im_login_group"
public static final String | RP_LOGIN_TYPE | "im_login_type"
public static final String | RP_PASSWORD | "im_password"
public static final String | RP_SHORTCUT | "im_shortcut"
public static final String | RP_URL | "im_url"
public static final String | RP_URL_SIGN | "im_url_sign"
public static final String | RP_USER | "im_user"
public static final String | SP_CLIENT_TYPE | "jp.co.intra_mart.session.client_type"
public static final String | SP_COLOR_PATTERN_ID | "jp.co.intra_mart.session.color_pattern_id"
public static final String | SP_ENCODING | "jp.co.intra_mart.session.encoding"
public static final String | SP_INITIAL_URL | "jp.co.intra_mart.session.initial.url"
public static final String | SP_LOCALE | "jp.co.intra_mart.session.locale"
public static final String | SP_LOGIN_GROUP | "jp.co.intra_mart.session.group"
public static final String | SP_LOGIN_TIME | "jp.co.intra_mart.session.login_time"
public static final String | SP_LOGIN_TYPE | "jp.co.intra_mart.session.login_type"
public static final String | SP_SHORTCUT | "jp.co.intra_mart.session.shortcut"
public static final String | SP_SIGNATURE | "jp.co.intra_mart.session.signature"
public static final String | SP_URL | "jp.co.intra_mart.session.url"
public static final String | SP_URL_SIGN | "jp.co.intra_mart.session.url.signature"
public static final String | SP_USER | "jp.co.intra_mart.session.user"

jp.co.intra_mart.foundation.security.SessionInfo
public static final String COOKIE_SEPARATOR "|"

jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor
public static final String | APPLICATION_NAME | "jp.co.intramart.foundation.datastore.common"
public static final String | ENTITY_CONTROLLER_DEPARTMENT_NAME | "AccessControllerDepartment"
public static final String | ENTITY_CONTROLLER_NAME | "AccessController"
public static final String | ENTITY_CONTROLLER_POST_NAME | "AccessControllerPost"
public static final String | ENTITY_CONTROLLER_PUBLIC_GROUP_NAME | "AccessControllerPublicGroup"
public static final String | ENTITY_CONTROLLER_ROLE_NAME | "AccessControllerRole"

jp.co.intra_mart.foundation.security.StandardAccountAccessor
public static final String | APPLICATION_NAME | "jp.co.intramart.foundation.datastore.common"
public static final String | ENTITY_NAME_ACCOUNT | "Account"
public static final String | ENTITY_NAME_ACCOUNT_ATTRIBUTE | "AccountAttribute"
public static final String | ENTITY_NAME_ACCOUNT_ROLE | "AccountRole"
public static final String | ENTITY_NAME_FAVORITE_MENU | "FavoriteMenu"
public static final String | ID_CRYPTION_CLASS | "cryption-class"

jp.co.intra_mart.foundation.security.StandardBatchAccessor
public static final String | APPLICATION_NAME | "jp.co.intramart.foundation.datastore.common"
public static final String | ENTITY_NAME | "Batch"

jp.co.intra_mart.foundation.security.StandardCalendarAccessor
public static final String | APPLICATION_NAME | "jp.co.intramart.foundation.datastore.common"
public static final String | ENTITY_NAME | "CalendarInfo"

jp.co.intra_mart.foundation.security.StandardMenuAccessor
public static final String | APPLICATION_NAME | "jp.co.intramart.foundation.datastore.common"
public static final String | ENTITY_NAME_MENU | "Menu"
public static final String | ENTITY_NAME_MENU_ARGUMENT | "MenuArgument"
public static final String | ENTITY_NAME_MENU_DEPARTMENT | "MenuDepartment"
public static final String | ENTITY_NAME_MENU_POST | "MenuPost"
public static final String | ENTITY_NAME_MENU_PUBLIC_GROUP | "MenuPublicGroup"
public static final String | ENTITY_NAME_MENU_ROLE | "MenuRole"

jp.co.intra_mart.foundation.security.StandardRoleAccessor
public static final String | APPLICATION_NAME | "jp.co.intramart.foundation.datastore.common"
public static final String | ENTITY_NAME_ROLE | "Role"
public static final String | ENTITY_NAME_ROLE_INCLUSION | "RoleInclusion"
public static final String | ENTITY_NAME_ROLE_SUMMARY | "RoleSummary"
public static final String | KIND_ROLE | "Role"
public static final String | KIND_ROLE_SUB | "SubRole"

jp.co.intra_mart.foundation.security.account.AccountManager
public static final String | ACCOUNT_ROLE_PERMISSION_SELECTOR | "account-role"
public static final String | ATTR_MENU_DISPLAY | "im_menu_display"
public static final String | ATTR_MENU_FOLDER_DISPLAY_METHOD | "im_menu_folder_display_method"
public static final String | ATTR_MOBILE_EASY_LOGIN | "im_mobile_easy_login"
public static final String | ATTR_MOBILE_EASY_LOGIN_NONCE | "im_mobile_easy_login_nonce"
public static final String | ATTR_MY_MENU_POSITION | "im_my_menu_position"
public static final String | ATTR_REPORT_LIMIT_DAYS | "im_report_limit_days"
public static final String | CRYPTION_CATEGORY_MOBILE_USER_AGENT | "mobile-user-agent"

jp.co.intra_mart.foundation.security.account.CsvAccountBackup
public static final String ID_CRYPTION_CLASS "cryption-class"

jp.co.intra_mart.foundation.security.account.StandardAccountBackup
public static final String ID_CRYPTION_CLASS "cryption-class"

jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager
public static final String | DEFAULT_ACTIVE_SESSION_ACCESSOR | "jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor"
public static final String | DEFAULT_SP_ACTIVE_SESSION_BINDING_LISTENER | "jp.co.intra_mart.session.active.session.binding.listener"

jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor
public static final String | DEFAULT_ACCESS_SECURITY_PAGE_PROVIDER_CLASS | "jp.co.intra_mart.system.security.AccessSecurityPageProviderImpl"
public static final String | DEFAULT_PAGE_LOCATION | "system/security/error/active_session_invalidated_page.jssp"

jp.co.intra_mart.foundation.security.batch.Batch
public static final String | LANG_JAVA | "JAVA"
public static final String | LANG_JAVA_SCRIPT | "JavaScript"

jp.co.intra_mart.foundation.security.calendar.CalendarInfo
public static final String | TYPE_CONFIG | "config"
public static final String | TYPE_HOLIDAY | "holiday"
public static final String | TYPE_NATIONAL_HOLDAY | "nationalHoliday"
public static final String | TYPE_WEEKDAY | "weekday"

jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer
public static final String | DEFAULT_AUTH_COOKIE_NAME | "comauth"
public static final String | DEFAULT_LOGIN_KEY | "comid"
public static final String | KEY_AUTH_COOKIE_NAME | "comauth"
public static final String | KEY_LOGIN_KEY | "comid"
public static final String | SSO_LOGOUT_URL | "sso-logout-url"

jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager
public static final String | DEFAULT_ATTR_INVALIDATE_OTHER_SESSIONS | "jp.co.intra_mart.request.duplicate.login.invalidate.other.sessions"
public static final String | DEFAULT_ATTR_REQUESTED_PAGE | "jp.co.intra_mart.request.duplicate.login.requested.page"
public static final String | DEFAULT_DUPLICATE_LOGIN_ACCESSOR | "jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor"

jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor
public static final String | DEFAULT_ACCESS_SECURITY_PAGE_PROVIDER_CLASS | "jp.co.intra_mart.system.security.AccessSecurityPageProviderImpl"
public static final String | DEFAULT_DUPLICATE_LOGIN_DETECT_ENABLE | "false"
public static final String | DEFAULT_INVALIDATABLE_BY_USER | "false"
public static final String | DEFAULT_PAGE_LOCATION | "system/security/error/duplicate_login_detection_page.jssp"

jp.co.intra_mart.foundation.security.exception.AccessSecurityException
public static final String | KIND_ROLE | "Role"
public static final String | KIND_ROLE_SUB | "SubRole"

jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter
public static final String DEFAULT_ATTR_REQUESTED_PAGE "jp.co.intra_mart.request.active.session.requested.page"

jp.co.intra_mart.foundation.security.filter.SessionFilter
public static final String SESSION_TIMEOUT_HEADER_KEY "x-jp-co-intra-mart-session-timeout"

jp.co.intra_mart.foundation.security.menu.MenuItem
public static final String | CONTENT_TYPE_IN | "in"
public static final String | CONTENT_TYPE_OUT | "out"
public static final String | MENU_TYPE_FOLDER | "folder"
public static final String | MENU_TYPE_ITEM | "item"

jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil
public static final String REQUEST_PARAM_NAME_4_EASYLOGIN_ACCESS_KEY "eak"

jp.co.intra_mart.foundation.security.role.StandardRoleBackup
public static final String KIND_ROLE "Role"

jp.co.intra_mart.foundation.service.client.NetworkConnector
protected static final int | GET | 32
protected static final int | GET_ENTIRETY | 34
protected static final int | GET_ENTIRETY_KEY | 40
protected static final int | GET_ITEM | 33
protected static final int | GET_ITEM_KEY | 36
protected static final int | GET_SUBSET | 35
protected static final int | MOVE | 128
protected static final int | MOVE_ENTIRETY | 130
protected static final int | MOVE_ITEM | 129
protected static final int | REMOVE | 64
protected static final int | REMOVE_ENTIRETY | 66
protected static final int | REMOVE_ITEM | 65
protected static final int | SET | 16
protected static final int | SET_ENTIRETY | 18
protected static final int | SET_ITEM | 17

jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
protected static final String ID_SECURITY_ACCOUNT "filter-security-account"

jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
protected static final String ID_SECURITY_GROUP "filter-security-group"

jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler
protected static final String ID_SECURITY_PASSWORD "filter-security-password"

jp.co.intra_mart.foundation.utility.report.ReportLevel
public static final int | MAX_VALUE | 2147483647
public static final int | MIN_VALUE | -2147483648
public static final int | TYPE_DEBUG | 0
public static final int | TYPE_ERROR | 3
public static final int | TYPE_REPORT | 1
public static final int | TYPE_WARNING | 2

jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel
public static final String | ACCESS_CONTROLLER_ID | "accessControllerId"
public static final String | ACCESS_CONTROLLER_NAME | "accessControllerName"
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel
public static final String | ACCESS_CONTROLLER_ID | "accessControllerId"
public static final String | COMPANY_CD | "companyCd"
public static final String | DEPARTMENT_CD | "departmentCd"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel
public static final String | ACCESS_CONTROLLER_ID | "accessControllerId"
public static final String | COMPANY_CD | "companyCd"
public static final String | POST_CD | "postCd"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel
public static final String | ACCESS_CONTROLLER_ID | "accessControllerId"
public static final String | PUBLIC_GROUP_CD | "publicGroupCd"
public static final String | PUBLIC_GROUP_SET_CD | "publicGroupSetCd"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel
public static final String | ACCESS_CONTROLLER_ID | "accessControllerId"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | ROLE_ID | "roleId"

jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel
public static final String | ATTRIBUTE_NAME | "attributeName"
public static final String | ATTRIBUTE_VALUE | "attributeValue"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | USER_ID | "userId"

jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel
public static final String | COLOR_PATTERN_ID | "colorPatternId"
public static final String | ENCODING | "encoding"
public static final String | GO_OUT | "goOut"
public static final String | LOCALE | "locale"
public static final String | LOCK_DATE | "lockDate"
public static final String | LOGIN_FAILURE_COUNT | "loginFailureCount"
public static final String | MOBILE_PASSWORD | "mobilePassword"
public static final String | NOTES | "notes"
public static final String | PAGE_PATTERN_ID | "pagePatternId"
public static final String | PASSWORD | "password"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | USER_ID | "userId"
public static final String | VALID_END_DATE | "validEndDate"
public static final String | VALID_START_DATE | "validStartDate"

jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | ROLE_ID | "roleId"
public static final String | USER_ID | "userId"
public static final String | VALID_END_DATE | "validEndDate"
public static final String | VALID_START_DATE | "validStartDate"

jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel
public static final String | BATCH_ID | "batchId"
public static final String | BATCH_NAME | "batchName"
public static final String | PROGRAM_LANGUAGE | "programLanguage"
public static final String | PROGRAM_PATH | "programPath"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | RUN_DAY | "runDay"
public static final String | RUN_DAY_WEEK | "runDayWeek"
public static final String | RUN_HOUR | "runHour"
public static final String | RUN_MINUTE | "runMinute"
public static final String | RUN_MONTH | "runMonth"
public static final String | RUN_SECOND | "runSecond"
public static final String | RUN_YEAR | "runYear"
public static final String | VALID_FLG | "validFlg"

jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel
public static final String | CALENDAR_ID | "calendarId"
public static final String | COLOR | "color"
public static final String | DATA_ID | "dataId"
public static final String | DATA_NAME | "dataName"
public static final String | DATA_TYPE | "dataType"
public static final String | DAY | "day"
public static final String | DAY_WEEK | "dayWeek"
public static final String | DISPLAY_NAME | "displayName"
public static final String | MONTH | "month"
public static final String | PLUGIN_METHOD | "pluginMethod"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | TIMES | "times"
public static final String | VALID_END_YEAR | "validEndYear"
public static final String | VALID_START_YEAR | "validStartYear"
public static final String | WEEK | "week"
public static final String | YEAR | "year"

jp.co.intra_mart.system.security.datastore.inf.DataStoreConst
public static final String | ACCESS_CONTROLLER | "AccessController"
public static final String | ACCESS_CONTROLLER_DEPARTMENT | "AccessControllerDepartment"
public static final String | ACCESS_CONTROLLER_POST | "AccessControllerPost"
public static final String | ACCESS_CONTROLLER_PUBLIC_GROUP | "AccessControllerPublicGroup"
public static final String | ACCESS_CONTROLLER_ROLE | "AccessControllerRole"
public static final String | ACCOUNT | "Account"
public static final String | ACCOUNT_ATTRIBUTE | "AccountAttribute"
public static final String | ACCOUNT_ROLE | "AccountRole"
public static final String | APPLICATION_NAME | "jp.co.intramart.foundation.datastore.common"
public static final String | BATCH | "Batch"
public static final String | CALENDAR_INFO | "CalendarInfo"
public static final String | FAVORITE_MENU | "FavoriteMenu"
public static final String | MENU | "Menu"
public static final String | MENU_ARGUMENT | "MenuArgument"
public static final String | MENU_DEPARTMENT | "MenuDepartment"
public static final String | MENU_POST | "MenuPost"
public static final String | MENU_PUBLIC_GROUP | "MenuPublicGroup"
public static final String | MENU_ROLE | "MenuRole"
public static final String | ROLE | "Role"
public static final String | ROLE_INCLUSION | "RoleInclusion"
public static final String | ROLE_SUMMARY | "RoleSummary"

jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel
public static final String | DISPLAY_NAME | "displayName"
public static final String | IMAGE_PATH | "imagePath"
public static final String | MENU_ID | "menuId"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_NUMBER | "sortNumber"
public static final String | USER_ID | "userId"

jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel
public static final String | ARGUMENT_NAME | "argumentName"
public static final String | ARGUMENT_VALUE | "argumentValue"
public static final String | MENU_ID | "menuId"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel
public static final String | CLIENT_TYPE | "clientType"
public static final String | CONTENTS | "contents"
public static final String | DISPLAY_NAME | "displayName"
public static final String | IMAGE_PATH | "imagePath"
public static final String | MENU_ID | "menuId"
public static final String | MENU_TYPE | "menuType"
public static final String | NOTES | "notes"
public static final String | PARENT_MENU_ID | "parentMenuId"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_NUMBER | "sortNumber"
public static final String | URL | "url"

jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel
public static final String | COMPANY_CD | "companyCd"
public static final String | DEPARTMENT_CD | "departmentCd"
public static final String | MENU_ID | "menuId"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel
public static final String | COMPANY_CD | "companyCd"
public static final String | MENU_ID | "menuId"
public static final String | POST_CD | "postCd"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel
public static final String | MENU_ID | "menuId"
public static final String | PUBLIC_GROUP_CD | "publicGroupCd"
public static final String | PUBLIC_GROUP_SET_CD | "publicGroupSetCd"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel
public static final String | MENU_ID | "menuId"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | ROLE_ID | "roleId"

jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel
public static final String | CATEGORY | "category"
public static final String | DISPLAY_NAME | "displayName"
public static final String | NAME | "name"
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | ROLE_ID | "roleId"

jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel
public static final String | CHILD_ROLE_ID | "childRoleId"
public static final String | PARENT_ROLE_ID | "parentRoleId"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | ROLE_ID | "roleId"
public static final String | SUMMARY_ROLE_ID | "summaryRoleId"

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


非推奨 API のリスト (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

推奨されていない API

推奨されていないクラス
jp.co.intra_mart.foundation.utility.AbstractDualComparator
jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter
jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor
jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor クラスを使用してください。
jp.co.intra_mart.foundation.acssecurity.AccountManager
jp.co.intra_mart.foundation.security.account.AccountManagerに置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData
jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler
このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。
jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter
jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream
jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream
jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream
jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.charset.CharacterEncoder
jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder クラスを使用してください。
jp.co.intra_mart.foundation.utility.Counter
jp.co.intra_mart.common.aid.jdk.util.Counter クラスを使用してください。
jp.co.intra_mart.foundation.database.DatabaseExport
システム内部で利用しているクラスです。
jp.co.intra_mart.foundation.database.DbManager
DatabaseManagerを使用してください。
jp.co.intra_mart.foundation.utility.file.Directory
jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。
jp.co.intra_mart.foundation.utility.ErrorEvent
jp.co.intra_mart.common.aid.jdk.util.ErrorEvent クラスを使用してください。
jp.co.intra_mart.foundation.utility.EventQueueController
jp.co.intra_mart.common.aid.jdk.util.EventQueueController クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.EverydayConditioner
jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner クラスを使用してください。
jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。
jp.co.intra_mart.foundation.utility.file.ExtendedFile
jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.ExtendedInputStream
jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream
jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.ExtendedSocket
jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket クラスを使用してください。
jp.co.intra_mart.foundation.utility.ExtendedThread
jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.FileReporter
jp.co.intra_mart.common.aid.jdk.util.report.FileReporter クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.FileSizeConditioner
jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner クラスを使用してください。
jp.co.intra_mart.foundation.utility.FilterComparator
jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.FilterMessageReporter
jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter クラスを使用してください。
jp.co.intra_mart.foundation.utility.FixedSizeMap
jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.HexInputStream
jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.HexOutputStream
jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.LineReportFilter
jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.Localhost
jp.co.intra_mart.common.aid.jdk.java.net.Localhost クラスを使用してください。
jp.co.intra_mart.foundation.utility.LockMonitor
jp.co.intra_mart.common.aid.jdk.util.LockMonitor クラスを使用してください。
jp.co.intra_mart.foundation.acssecurity.Logingp
jp.co.intra_mart.foundation.smtp.Mail
MailSenderに置き換えられました。
jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuHdmlAnalyzer
jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoMoveAnalyzer
jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginJphoneAnalyzer
jp.co.intra_mart.foundation.utility.report.MultiCastReporter
jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter クラスを使用してください。
jp.co.intra_mart.foundation.utility.MultiComparator
jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator クラスを使用してください。
jp.co.intra_mart.foundation.http.MultipartFormData
jp.co.intra_mart.common.aid.javaee.http.MultipartFormData クラスを使用してください。
jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions
jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner
jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.PeriodicConditioner
jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner クラスを使用してください。
jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory
jp.co.intra_mart.foundation.utility.report.PrintStreamReporter
jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.ReplaceWriter
jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.ReportFileWriter
jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.ReportLevelFilter
jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.RepresentativeReporter
jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter クラスを使用してください。
jp.co.intra_mart.foundation.utility.ResourceBundleProperties
jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties クラスを使用してください。
jp.co.intra_mart.foundation.utility.ReverseComparator
jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator クラスを使用してください。
jp.co.intra_mart.foundation.acssecurity.RoleManager
jp.co.intra_mart.foundation.utility.SequenceComparator
jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator クラスを使用してください。
jp.co.intra_mart.foundation.http.SessionQuery
GenericURLBuilder および URLBuilder に置き替えられました。
jp.co.intra_mart.foundation.utility.net.SocketConnection
jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.SocketPool
jp.co.intra_mart.common.aid.jdk.java.net.SocketPool クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream
jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream
jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream
jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.XORInputStream
jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.XOROutputStream
jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream クラスを使用してください。

推奨されていないインタフェース
jp.co.intra_mart.foundation.database.DbsConnection
Connectionを利用してください。
jp.co.intra_mart.foundation.utility.DualComparator
jp.co.intra_mart.common.aid.jdk.java.util.DualComparator クラスを使用してください。
jp.co.intra_mart.foundation.utility.ErrorEventListener
jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener クラスを使用してください。
jp.co.intra_mart.foundation.utility.EventListener
jp.co.intra_mart.common.aid.jdk.util.EventListener クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.MessageReporter
jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter クラスを使用してください。
jp.co.intra_mart.foundation.http.MultipartFormData.Entity
jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity インタフェースを使用してください。
jp.co.intra_mart.foundation.utility.report.ReportFileConditioner
jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.ReportLevel
jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor
jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.SocketConnectionManager
jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.SocketEventListener
jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener クラスを使用してください。
jp.co.intra_mart.foundation.utility.ThreadStopListener
jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener クラスを使用してください。

推奨されていない例外
jp.co.intra_mart.foundation.database.exception.DatabaseExportException
システム内部で利用しているクラスです。
jp.co.intra_mart.foundation.utility.charset.ResourceFormatException
jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException クラスを使用してください。
jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException
jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException
jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException クラスを使用してください。

推奨されていないメソッド
jp.co.intra_mart.foundation.acssecurity.AcsData.acntFromDBToIS(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.acntFromISToDB(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.service.client.batch.Scheduler.action(Object)
jp.co.intra_mart.foundation.service.client.file.NetworkFile.action(Object)
jp.co.intra_mart.foundation.service.client.information.PermanentFile.action(Object)
jp.co.intra_mart.foundation.service.client.information.PermanentDirectory.action(Object)
jp.co.intra_mart.foundation.service.client.information.Lock.action(Object)
jp.co.intra_mart.foundation.service.client.information.ExternalMemory.action(Object)
jp.co.intra_mart.foundation.service.client.information.ExternalDirectory.action(Object)
jp.co.intra_mart.foundation.service.provider.GarbageController.addConditioner(GCConditioner)
jp.co.intra_mart.foundation.http.SessionQuery.addURL(String)
GenericURLBuilder.createFilePath(String) および URLBuilder.createURLonSession(String)に置き替えられました。
jp.co.intra_mart.foundation.database.DbManager.contact()
代替えメソッドはありません。
jp.co.intra_mart.foundation.database.DbManager.contact(ConInfo)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.RoleManager.contains(String)
jp.co.intra_mart.foundation.security.role.RoleManager.contains(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.contains(String)
jp.co.intra_mart.foundation.security.account.AccountManager.contains(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.RoleManager.count()
jp.co.intra_mart.foundation.security.role.RoleManager.count()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.Logingp.count()
LoginGroupManager.countLoginGroups()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.count()
jp.co.intra_mart.foundation.security.account.AccountManager.count()に置き換えられました。
jp.co.intra_mart.foundation.database.DbManager.dateToString(Date)
DatabaseManager.dateToString(Date)を使用してください。
jp.co.intra_mart.foundation.acssecurity.AcsData.dbConsistChk(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.service.provider.HomeDirectory.definePath(String)
jp.co.intra_mart.foundation.acssecurity.Logingp.del(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.delAllAccount(String)
AccountManager.deleteAccounts()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.delAllLink(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.delAllMenu(String)
MenuManager.deleteMenuItems()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.delAllMessage(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.delAllRole(String)
RoleManager.deleteRoles()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.delAllSchedule(String)
BatchManager.deleteBatches()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.RoleManager.delData(String)
jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.delData(String)
jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.RoleManager.delData(String, boolean)
jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.delData(String, boolean)
jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.Logingp.entries()
LoginGroupManager.getLoginGroupIds()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.Logingp.get(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.getAccount(String, String)
AccountManager.exportData(String category, OutputStream outputStream)に置き換えられました。
jp.co.intra_mart.foundation.database.DbManager.getConnectIDs()
DatabaseManager.getConnectIdsBySystem()を使用してください。
jp.co.intra_mart.foundation.database.DbManager.getConnectInfo()
代替えメソッドはありません。
jp.co.intra_mart.foundation.database.DbManager.getConnection()
DatabaseManager.getLoginGroupConnection(String) および DatabaseManager.getSystemConnection(String)を使用してください。
jp.co.intra_mart.foundation.acssecurity.RoleManager.getData(String)
jp.co.intra_mart.foundation.security.role.RoleManager.getRole(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.getData(String)
jp.co.intra_mart.foundation.security.account.AccountManager.getAccount(String)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.isRegisteredAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.model.user.UserMapperを利用して取得してください。
jp.co.intra_mart.foundation.acssecurity.RoleManager.getIdByName(String)
jp.co.intra_mart.foundation.security.role.RoleManager.searchRolesByName(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.RoleManager.getIDs()
jp.co.intra_mart.foundation.security.role.RoleManager.getRoleIds()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.getIDs()
jp.co.intra_mart.foundation.security.account.AccountManager.getUserIds()に置き換えられました。
jp.co.intra_mart.foundation.graph.RadarChartDrawer.getImgaeBackgroundColor()
jp.co.intra_mart.foundation.graph.PortFolioDrawer.getImgaeBackgroundColor()
jp.co.intra_mart.foundation.graph.LineGraphDrawer.getImgaeBackgroundColor()
jp.co.intra_mart.foundation.graph.CircleGraphDrawer.getImgaeBackgroundColor()
jp.co.intra_mart.foundation.graph.BarGraphDrawer.getImgaeBackgroundColor()
jp.co.intra_mart.foundation.graph.RadarChartDrawer.getImgaeBorderColor()
jp.co.intra_mart.foundation.graph.PortFolioDrawer.getImgaeBorderColor()
jp.co.intra_mart.foundation.graph.LineGraphDrawer.getImgaeBorderColor()
jp.co.intra_mart.foundation.graph.CircleGraphDrawer.getImgaeBorderColor()
jp.co.intra_mart.foundation.graph.BarGraphDrawer.getImgaeBorderColor()
jp.co.intra_mart.foundation.acssecurity.AcsData.getLink(String, String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.RoleManager.getListData(String)
jp.co.intra_mart.foundation.security.role.RoleManager.getAllSubRoleIds(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.getMenu(String, String)
MenuManager.exportData(String category, OutputStream outputStream)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.getMessage(String, String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.RoleManager.getParentData(String)
jp.co.intra_mart.foundation.security.role.RoleManager.getParentRoleIds(String)に置き換えられました。
jp.co.intra_mart.foundation.http.SessionQuery.getQuery()
代替えメソッドはありません。
jp.co.intra_mart.foundation.http.SessionQuery.getQueryName()
代替えメソッドはありません。
jp.co.intra_mart.foundation.http.SessionQuery.getQueryValue()
GenericURLBuilder.createFilePath(String) に置き替えられました。
jp.co.intra_mart.foundation.http.MultipartFormData.Entity.getReader()
MultipartFormData.Entity.getReader(String) に置き換えられました。
jp.co.intra_mart.foundation.database.DbManager.getReference()
DatabaseManager.getConnectIdsBySystem()を使用してください。
jp.co.intra_mart.foundation.acssecurity.AcsData.getRole(String, String)
RoleManager.exportData(String category, OutputStream outputStream)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.getSchedule(String, String)
BatchManager.exportData(String category, OutputStream outputStream)に置き換えられました。
jp.co.intra_mart.foundation.database.DbManager.isConnect()
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.Logingp.isGroup(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.commons.validation.InputCheck.isValidDate(String, String, String)
この関数は使用できません。次期バージョンにて削除されます。
jp.co.intra_mart.foundation.commons.validation.InputCheck.isWeekDate(String, int)
この関数は使用できません。次期バージョンにて削除されます。
jp.co.intra_mart.foundation.commons.validation.InputCheck.isWeekDate(String, Integer)
この関数は使用できません。次期バージョンにて削除されます。
jp.co.intra_mart.foundation.service.client.information.Lock.releaseRequestScope()
このメソッドは、RequestScopeLockReleaseFilter 専用です。
jp.co.intra_mart.foundation.service.provider.GarbageController.removeConditioner(GCConditioner)
jp.co.intra_mart.foundation.acssecurity.Logingp.set(String, Number)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.Logingp.set(String, String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.setAccount(String, String)
AccountManager.importData(String category, InputStream inputStream)に置き換えられました。
jp.co.intra_mart.foundation.database.DbsConnection.setAutoCommit(boolean)
jp.co.intra_mart.foundation.acssecurity.RoleManager.setData(Map)
jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.setData(Map)
jp.co.intra_mart.foundation.security.account.AccountManager.addAcount(Account) およびupdateAccount(Account)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.registerAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.domain.user.UserManagerを利用して、更新してください。
jp.co.intra_mart.foundation.acssecurity.RoleManager.setData(Map, boolean)
jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.setData(Map, boolean)
jp.co.intra_mart.foundation.graph.RadarChartDrawer.setImgaeBackgroundColor(Color)
jp.co.intra_mart.foundation.graph.PortFolioDrawer.setImgaeBackgroundColor(Color)
jp.co.intra_mart.foundation.graph.LineGraphDrawer.setImgaeBackgroundColor(Color)
jp.co.intra_mart.foundation.graph.CircleGraphDrawer.setImgaeBackgroundColor(Color)
jp.co.intra_mart.foundation.graph.BarGraphDrawer.setImgaeBackgroundColor(Color)
jp.co.intra_mart.foundation.graph.RadarChartDrawer.setImgaeBorderColor(Color)
jp.co.intra_mart.foundation.graph.PortFolioDrawer.setImgaeBorderColor(Color)
jp.co.intra_mart.foundation.graph.LineGraphDrawer.setImgaeBorderColor(Color)
jp.co.intra_mart.foundation.graph.CircleGraphDrawer.setImgaeBorderColor(Color)
jp.co.intra_mart.foundation.graph.BarGraphDrawer.setImgaeBorderColor(Color)
jp.co.intra_mart.foundation.acssecurity.AcsData.setLink(String, String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.setMenu(String, String)
MenuManager.importData(String category, InputStream inputStream)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.setMessage(String, String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.setRole(String, String)
RoleManager.importData(String category, InputStream inputStream)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.setSchedule(String, String)
BatchManager.importData(String category, InputStream inputStream)に置き換えられました。
jp.co.intra_mart.foundation.http.SessionQuery.setTo(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.service.provider.GarbageController.startAutomaticExecution(long)
gc によるシステム停止や監視スレッドを停止処理しないことによるメモリリークなどの問題を引き起こす危険性があります。
jp.co.intra_mart.foundation.service.provider.GarbageController.stopAutomaticExecution()
jp.co.intra_mart.foundation.database.DbManager.stringToDate(String)
DatabaseManager.stringToDate(String)を使用してください。

推奨されていないコンストラクタ
jp.co.intra_mart.foundation.acssecurity.AccountManager(String)
jp.co.intra_mart.foundation.database.DbManager(String)
DatabaseManagerを使用してください。
jp.co.intra_mart.foundation.acssecurity.Logingp(String)
LoginGroupManagerに置き換えられました。
jp.co.intra_mart.foundation.acssecurity.RoleManager(String)
jp.co.intra_mart.foundation.security.role.RoleManagerに置き換えられました。
jp.co.intra_mart.foundation.http.SessionQuery(HttpServletRequest, HttpServletResponse)
GenericURLBuilder および URLBuilder に置き替えられました。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


API ヘルプ (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

API ドキュメントの構成

この API (Application Programming Interface) ドキュメントには、次に説明するナビゲーションバーにある項目に対応するページが含まれます。

概要

概要 ページは API ドキュメントのフロントページで、各パッケージの概要を含む全パッケージの一覧が表示されます。一連のパッケージの概要説明も表示されます。

パッケージ

各パッケージは、そのパッケージのクラスとインタフェースへのリンクを含むページを持ちます。このページは 4 つのカテゴリで構成されます:

  • インタフェース (イタリック)
  • クラス
  • 例外
  • エラー

クラスまたはインタフェース

各クラス、インタフェース、入れ子クラス、および入れ子インタフェースは個別のページを持ちます。各ページには次のように、クラスまたはインタフェースの説明と、概要テーブル、およびメンバの詳細説明が含まれます:

  • クラス階層表示
  • 直系のサブクラス
  • 既知のサブインタフェースの一覧
  • 既知の実装クラスの一覧
  • クラスまたはインタフェースの宣言
  • クラスまたはインタフェースの記述

  • 入れ子クラスの概要
  • フィールドの概要
  • コンストラクタの概要
  • メソッドの概要

  • フィールドの詳細
  • コンストラクタの詳細
  • メソッドの詳細
各概要エントリには、その項目の詳細な記述の中から 1 行目の文が表示されます。詳細な記述はソースコードに現われる順に並べられますが、概要エントリはアルファベット順に並べられます。これによって、プログラマが設定した論理的なグループ分けが保持されます。

使用

各ドキュメント化されたパッケージ、クラス、およびインタフェースはそれぞれ [使用] ページを持っています。このページには、どのようなパッケージ、クラス、メソッド、コンストラクタ、およびフィールドが、特定のクラスまたはパッケージの一部を使用しているかが記述されています。たとえば、クラス A またはインタフェース A の場合、その [使用] ページには、A のサブクラス、A として宣言されるフィールド、A を返すメソッド、および、型 A を持つメソッドとコンストラクタが含まれます。このページにアクセスするには、まずそのパッケージ、クラス、またはインタフェースに移動し、ナビゲーションバーの [使用] リンクをクリックしてください。

階層ツリー (クラス階層)

すべてのパッケージには クラス階層 ページがあり、さらに各パッケージの階層があります。各階層ページは、クラスのリストとインタフェースのリストを含みます。クラスは java.lang.Object を開始点とする継承構造で編成されます。インタフェースは、java.lang.Object からは継承しません。
  • 概要ページを表示しているときに [ツリー] をクリックすると、全パッケージの階層が表示されます。
  • 特定のパッケージ、クラス、またはインタフェースを表示しているときに [ツリー] をクリックすると、該当するパッケージだけの階層が表示されます。

推奨されていない API

推奨されていない API ページは、推奨されていないすべての API のリストを表示します。非推奨 API とは、機能改良などの理由から使用をお勧めできなくなった API のことで、通常はそれに代わる API が提供されます。非推奨 API は今後の実装で削除される可能性があります。

索引

索引 には、すべてのクラス、インタフェース、コンストラクタ、メソッド、およびフィールドのアルファベット順のリストが含まれます。

前/次

これらのリンクにより、前または次のクラス、インタフェース、パッケージ、または関連ページへ移動できます。

フレームあり/フレームなし

これらのリンクは HTML フレームを表示したり隠したりします。すべてのページはフレームありでも、フレームなしでも表示できます。

直列化された形式

直列化可能、または外部化可能な各クラスは、直列化フィールドとメソッドの記述を含みます。この情報は、API を使用する開発者ではなく、再実装を行う担当者に役立ちます。ナビゲーションバーにリンクがない場合、直列化されたクラスに移動して、クラス記述の [関連項目] セクションにある [直列化された形式] をクリックすることにより、この情報を表示できます。

このヘルプファイルは、標準の doclet によって生成された API ドキュメントに適用されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


索引 (javadoc_foundation 6.1.14 API)

概要

パッケージ

クラス

使用

階層ツリー

非推奨 API

索引

ヘルプ

intra-mart 6.1.14

前 次

フレームあり フレームなし

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

A

ACCESS_CONTROLLER - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
アクセスコントローラ情報
ACCESS_CONTROLLER_DEPARTMENT - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
アクセスコントローラの利用権限を保有する組織
ACCESS_CONTROLLER_ID - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel の static 変数
アクセスコントローラID
ACCESS_CONTROLLER_ID - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel の static 変数
アクセスコントローラID
ACCESS_CONTROLLER_ID - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel の static 変数
アクセスコントローラID
ACCESS_CONTROLLER_ID - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel の static 変数
アクセスコントローラID
ACCESS_CONTROLLER_ID - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel の static 変数
アクセスコントローラID
ACCESS_CONTROLLER_NAME - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel の static 変数
アクセスコントローラ名
ACCESS_CONTROLLER_POST - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
アクセスコントローラの利用権限を保有する役職
ACCESS_CONTROLLER_PUBLIC_GROUP - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
アクセスコントローラの利用権限を保有するパブリックグループ
ACCESS_CONTROLLER_ROLE - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
アクセスコントローラの利用権限を保有するロール
ACCOUNT - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
アカウント
ACCOUNT_ATTRIBUTE - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
アカウント属性
ACCOUNT_FLAG - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
アカウントフラグ
ACCOUNT_ROLE - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
アカウントが保有するロール
ACCOUNT_ROLE_PERMISSION_SELECTOR - class jp.co.intra_mart.foundation.security.account.AccountManager の static 変数
パーミッションセレクタ: ユーザが保有するすべてのロール取得用ID。
ADDRESS - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
住所
ADDRESS1 - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
住所1
ADDRESS2 - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
住所2
AMOUNT - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel の static 変数
数量
APPLICATION_NAME - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor の static 変数
アプリケーション名
APPLICATION_NAME - class jp.co.intra_mart.foundation.security.StandardAccountAccessor の static 変数
アプリケーション名
APPLICATION_NAME - class jp.co.intra_mart.foundation.security.StandardBatchAccessor の static 変数
アプリケーション名
APPLICATION_NAME - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor の static 変数
アプリケーション名
APPLICATION_NAME - class jp.co.intra_mart.foundation.security.StandardMenuAccessor の static 変数
アプリケーション名
APPLICATION_NAME - class jp.co.intra_mart.foundation.security.StandardRoleAccessor の static 変数

APPLICATION_NAME - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
アプリケーション
ARGUMENT_NAME - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel の static 変数
引数名
ARGUMENT_VALUE - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel の static 変数
引数値
ATTRIBUTE_NAME - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel の static 変数
属性キー
ATTRIBUTE_TYPE_HISTORY_COUNT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
属性タイプ ：履歴表示件数
ATTRIBUTE_VALUE - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel の static 変数
属性値
ATTR_CERTIFICATION_MODE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
認証モード制御パラメータ名。
ATTR_DO_FILTER - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
セッションフィルター制御パラメータ名。
ATTR_MENU_DISPLAY - class jp.co.intra_mart.foundation.security.account.AccountManager の static 変数
ユーザ属性名: ログイン時のメニュー表示・非表示用。
ATTR_MENU_FOLDER_DISPLAY_METHOD - class jp.co.intra_mart.foundation.security.account.AccountManager の static 変数
ユーザ属性名: メニューフォルダの表示方法。
ATTR_MOBILE_EASY_LOGIN - class jp.co.intra_mart.foundation.security.account.AccountManager の static 変数
ユーザ属性名: かんたんログイン用。
ATTR_MOBILE_EASY_LOGIN_NONCE - class jp.co.intra_mart.foundation.security.account.AccountManager の static 変数
ユーザ属性名: かんたんログインのアクセスキー生成時に必要なNonce用。
ATTR_MY_MENU_POSITION - class jp.co.intra_mart.foundation.security.account.AccountManager の static 変数
ユーザ属性名: マイメニュー表示位置用。
ATTR_REPORT_LIMIT_DAYS - class jp.co.intra_mart.foundation.security.account.AccountManager の static 変数
ユーザ属性名: パスワード期限切れ通知用。
AVALIABLE_LOGIN_USER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ログインできるアカウントを表す定数
AbstractComponent - class jp.co.intra_mart.foundation.service.client.file.AbstractComponent.
このクラスは、Storage Service で実行される ロジックを実装するためのスケルトンを提供します。
AbstractComponent() - class jp.co.intra_mart.foundation.service.client.file.AbstractComponent のコンストラクタ
唯一のコンストラクタ。
AbstractDrawer - class jp.co.intra_mart.foundation.drawer.AbstractDrawer.
画像ファイル出力用のスケルトンクラスです。
AbstractDrawer() - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のコンストラクタ
唯一のコンストラクタ。
AbstractDualComparator - class jp.co.intra_mart.foundation.utility.AbstractDualComparator.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator クラスを使用してください。
AbstractDualComparator() - class jp.co.intra_mart.foundation.utility.AbstractDualComparator のコンストラクタ
推奨されていません。 新しいオブジェクトを生成します。
AbstractExportManagerClient - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient.
エクスポートマネージャークライアントの汎用的な実装です。
AbstractExportManagerClient() - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のコンストラクタ

AbstractImportManagerClient - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient.
インポートマネージャークライアントの汎用的な実装です。
AbstractImportManagerClient() - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のコンストラクタ

AbstractMessageReporter - class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter クラスを使用してください。
AbstractMessageReporter() - class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter のコンストラクタ
推奨されていません。 唯一のコンストラクタ。
AbstractSocketConnectionDistributor - class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor クラスを使用してください。
AbstractSocketConnectionDistributor(String, int) - class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor のコンストラクタ
推奨されていません。 ソケット作成オブジェクトを構築します。
AbstractTreeNodeContainer - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer.
ツリービューの子ノードを扱うためのメソッドを提供する抽象クラスです。
AbstractTreeNodeContainer() - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のコンストラクタ
子ノードを追加順に並べる、新しいオブジェクトを生成します。
AbstractTreeNodeContainer(Comparator) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のコンストラクタ
指定されたコンパレータに従って子ノードを並べる、新しいオブジェクトを生成します。
AccessController - class jp.co.intra_mart.foundation.security.access.AccessController.
アクセスコントローラ・モデルクラス。
AccessController(String) - class jp.co.intra_mart.foundation.security.access.AccessController のコンストラクタ
コンストラクタ。
AccessController() - class jp.co.intra_mart.foundation.security.access.AccessController のコンストラクタ
コンストラクタ。
AccessControllerAccessor - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor.
アクセスコントローラアクセッサインタフェース。
AccessControllerBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel.
アクセスコントローラ情報の基本モデルです。
AccessControllerDepartmentBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel.
アクセスコントローラの利用権限を保有する組織の基本モデルです。
AccessControllerDepartmentMapper - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper.
アクセスコントローラの利用権限を保有する組織に関連するマッパです。
AccessControllerExporter - interface jp.co.intra_mart.foundation.security.access.AccessControllerExporter.
アクセスコントローラエクスポートインタフェースです。
AccessControllerImporter - interface jp.co.intra_mart.foundation.security.access.AccessControllerImporter.
アクセスコントローラインポートインタフェースです。
AccessControllerManager - class jp.co.intra_mart.foundation.security.access.AccessControllerManager.
アクセスコントローラマネージャクラス。
AccessControllerManager(String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のコンストラクタ
コンストラクタ。
AccessControllerMapper - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper.
アクセスコントローラ情報に関連するマッパです。
AccessControllerPermissionSelector - class jp.co.intra_mart.foundation.security.permission.AccessControllerPermissionSelector.
ユーザIDから有効なアクセスコントローラのID一覧を取得するセレクタ。
AccessControllerPermissionSelector() - class jp.co.intra_mart.foundation.security.permission.AccessControllerPermissionSelector のコンストラクタ
コンストラクタ。
AccessControllerPostBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel.
アクセスコントローラの利用権限を保有する役職の基本モデルです。
AccessControllerPostMapper - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper.
アクセスコントローラの利用権限を保有する役職に関連するマッパです。
AccessControllerPostWriterListener - interface jp.co.intra_mart.foundation.security.access.AccessControllerPostWriterListener.
アクセスコントローラ情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AccessControllerPublicGroupBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel.
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルです。
AccessControllerPublicGroupMapper - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper.
アクセスコントローラの利用権限を保有するパブリックグループに関連するマッパです。
AccessControllerQueryWriterListener - interface jp.co.intra_mart.foundation.security.access.AccessControllerQueryWriterListener.
アクセスコントローラ情報書き込み時（書き込む直前）のリスナ・インターフェースを定義します。
AccessControllerReaderDecorator - interface jp.co.intra_mart.foundation.security.access.AccessControllerReaderDecorator.
アクセスコントローラ情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
AccessControllerRoleBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel.
アクセスコントローラの利用権限を保有するロールの基本モデルです。
AccessControllerRoleMapper - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper.
アクセスコントローラの利用権限を保有するロールに関連するマッパです。
AccessSecurityConfigException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException.
アクセスセキュリティ設定に関する例外クラス。
AccessSecurityConfigException() - class jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException のコンストラクタ
コンストラクタ。
AccessSecurityConfigException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException のコンストラクタ
コンストラクタ。
AccessSecurityConfigException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException のコンストラクタ
コンストラクタ。
AccessSecurityConfigException(Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException のコンストラクタ
コンストラクタ。
AccessSecurityCreateException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException.
アクセスセキュリティ情報作成例外クラス。
AccessSecurityCreateException(String, String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException のコンストラクタ
コンストラクタ。
AccessSecurityCreateException(String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException のコンストラクタ
コンストラクタ。
AccessSecurityCreateException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException のコンストラクタ
コンストラクタ。
AccessSecurityCreateException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException のコンストラクタ
コンストラクタ。
AccessSecurityDeleteException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException.
アクセスセキュリティ情報削除例外クラス。
AccessSecurityDeleteException(String, String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException のコンストラクタ
コンストラクタ。
AccessSecurityDeleteException(String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException のコンストラクタ
コンストラクタ。
AccessSecurityDeleteException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException のコンストラクタ
コンストラクタ。
AccessSecurityDeleteException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException のコンストラクタ
コンストラクタ。
AccessSecurityException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityException.
アクセスセキュリティの基本となる例外クラス。
AccessSecurityException() - class jp.co.intra_mart.foundation.security.exception.AccessSecurityException のコンストラクタ
コンストラクタ。
AccessSecurityException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityException のコンストラクタ
コンストラクタ。
AccessSecurityException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityException のコンストラクタ
コンストラクタ。
AccessSecurityException(Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityException のコンストラクタ
コンストラクタ。
AccessSecurityExportException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException.
エクスポート時例外クラス。
AccessSecurityExportException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException のコンストラクタ
コンストラクタ。
AccessSecurityExportException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException のコンストラクタ
コンストラクタ。
AccessSecurityImportException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException.
インポート時例外クラス。
AccessSecurityImportException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException のコンストラクタ
コンストラクタ。
AccessSecurityImportException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException のコンストラクタ
コンストラクタ。
AccessSecurityListenerExcpetion - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion.
アクセスセキュリティリスナーの例外クラス。
AccessSecurityListenerExcpetion() - class jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion のコンストラクタ
コンストラクタ。
AccessSecurityListenerExcpetion(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion のコンストラクタ
コンストラクタ。
AccessSecurityListenerExcpetion(Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion のコンストラクタ
コンストラクタ。
AccessSecurityListenerExcpetion(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion のコンストラクタ
コンストラクタ。
AccessSecurityManager - class jp.co.intra_mart.foundation.security.AccessSecurityManager.
アクセスセキュリティマネージャクラス。
AccessSecurityReadException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException.
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityReadException(String, String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityReadException(String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityReadException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityReadException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityReadException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityReadException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityReadException(Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityRuntimeException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException.
アクセスセキュリティランタイム例外クラス。
AccessSecurityRuntimeException() - class jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException のコンストラクタ
コンストラクタ。
AccessSecurityRuntimeException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException のコンストラクタ
コンストラクタ。
AccessSecurityRuntimeException(Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException のコンストラクタ
コンストラクタ。
AccessSecurityRuntimeException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException のコンストラクタ
コンストラクタ。
AccessSecurityUpdateException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException.
アクセスセキュリティ情報更新例外クラス。
AccessSecurityUpdateException(String, String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException のコンストラクタ
コンストラクタ。
AccessSecurityUpdateException(String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException のコンストラクタ
コンストラクタ。
AccessSecurityUpdateException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException のコンストラクタ
コンストラクタ。
AccessSecurityUpdateException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException のコンストラクタ
コンストラクタ。
AccessSecurityWriteException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException.
アクセスセキュリティ情報の更新例外クラス。
AccessSecurityWriteException() - class jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException のコンストラクタ
コンストラクタ。
AccessSecurityWriteException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException のコンストラクタ
コンストラクタ。
AccessSecurityWriteException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException のコンストラクタ
コンストラクタ。
AccessSecurityWriteException(Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException のコンストラクタ
コンストラクタ。
AccessibleLinkHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler.
再接続の為のＵＲＬを制御するフィルタ実装です。
AccessibleLinkHTTPActionEventFilterHandler(HTTPActionEventHandler) - class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler のコンストラクタ
ＵＲＬを絶対形式に変換するためのフィルタハンドラを作成します。
AccessorClosedException - exception jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException.
アクセサのクローズ時に発生する例外クラス

アクセサがクローズされている場合に、以下のメソッドを呼び出された時にスローする。
AccessorClosedException() - class jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException のコンストラクタ
コンストラクタ
AccessorClosedException(String) - class jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException のコンストラクタ
コンストラクタ
AccessorClosedException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException のコンストラクタ
コンストラクタ
AccessorClosedException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException のコンストラクタ
コンストラクタ
AccessorException - exception jp.co.intra_mart.foundation.datastore.exception.AccessorException.
アクセサで発生する例外の基底クラス
AccessorException() - class jp.co.intra_mart.foundation.datastore.exception.AccessorException のコンストラクタ
コンストラクタ
AccessorException(String) - class jp.co.intra_mart.foundation.datastore.exception.AccessorException のコンストラクタ
コンストラクタ
AccessorException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorException のコンストラクタ
コンストラクタ
AccessorException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorException のコンストラクタ
コンストラクタ
AccessorIllegalPropertyValueException - exception jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException.
アクセサのプロパティ設定に関する例外クラス

アクセサに不正な値が設定された場合にスローする。
AccessorIllegalPropertyValueException() - class jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException のコンストラクタ
コンストラクタ
AccessorIllegalPropertyValueException(String) - class jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException のコンストラクタ
コンストラクタ
AccessorIllegalPropertyValueException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException のコンストラクタ
コンストラクタ
AccessorIllegalPropertyValueException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException のコンストラクタ
コンストラクタ
AccessorSystemException - exception jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException.
アクセサのプロパティに関する例外クラス

指定されたプロパティがアクセサに存在しない場合にスローする。
AccessorSystemException() - class jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException のコンストラクタ
コンストラクタ
AccessorSystemException(String) - class jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException のコンストラクタ
コンストラクタ
AccessorSystemException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException のコンストラクタ
コンストラクタ
AccessorSystemException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException のコンストラクタ
コンストラクタ
Account - class jp.co.intra_mart.foundation.security.account.Account.
アカウントモデル。
Account(String) - class jp.co.intra_mart.foundation.security.account.Account のコンストラクタ
コンストラクタ。
AccountAccessor - interface jp.co.intra_mart.foundation.security.account.AccountAccessor.
アカウントアクセッサインタフェース。
AccountAttributeBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel.
アカウントが保有する属性の基本モデルです。
AccountAttributeMapper - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper.
アカウントが保有する属性に関連するマッパです。
AccountBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel.
アカウントの基本モデルです。
AccountChangedListener - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener.
アカウント情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AccountExporter - interface jp.co.intra_mart.foundation.security.account.AccountExporter.
アカウントエクスポートインタフェースです。
AccountImporter - interface jp.co.intra_mart.foundation.security.account.AccountImporter.
アカウントインポートインタフェースです。
AccountManager - class jp.co.intra_mart.foundation.acssecurity.AccountManager.
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManagerに置き換えられました。
AccountManager(String) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のコンストラクタ
推奨されていません。
AccountManager - class jp.co.intra_mart.foundation.security.account.AccountManager.
アカウントマネージャクラス。
AccountManager(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のコンストラクタ
コンストラクタ。
AccountMapper - interface jp.co.intra_mart.system.security.datastore.inf.AccountMapper.
アカウントに関連するマッパです。
AccountPostWriterListener - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener.
アカウント情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AccountQueryWriterListener - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener.
アカウント情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
AccountReaderDecorator - interface jp.co.intra_mart.foundation.security.account.AccountReaderDecorator.
アカウント情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
AccountRole - class jp.co.intra_mart.foundation.security.account.AccountRole.
アカウント用ロールモデル。
AccountRole(String) - class jp.co.intra_mart.foundation.security.account.AccountRole のコンストラクタ
コンストラクタ。
AccountRoleBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel.
アカウントが保有するロールの基本モデルです。
AccountRoleMapper - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper.
アカウントが保有するロールに関連するマッパです。
AccountRolePermissionSelector - class jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector.
ユーザIDから有効なすべてのロールを取得するセレクタ。
AccountRolePermissionSelector() - class jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector のコンストラクタ
コンストラクタ。
AccountSecurityHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler.
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
AccountSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler, String, String) - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler のコンストラクタ
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
AcsData - class jp.co.intra_mart.foundation.acssecurity.AcsData.
推奨されていません。
AcsData() - class jp.co.intra_mart.foundation.acssecurity.AcsData のコンストラクタ
推奨されていません。
AcssecurityException - exception jp.co.intra_mart.foundation.acssecurity.AcssecurityException.
アクセスセキュリティ情報操作時にエラーが発生した場合にスローされます。
ActionListener - interface jp.co.intra_mart.foundation.service.client.ActionListener.
このクラスは、主にイベントにより処理されるリスナーを実装する ためのスケルトンを提供します。
ActivationKey - interface jp.co.intra_mart.foundation.datastore.common.config.ActivationKey.
ライフタイム期間の有効開始日時を定義します。
ActiveSessionAccessor - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor.
アクティブなセッション情報操作インターフェース。
ActiveSessionBindingListener - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionBindingListener.
HttpSessionBindingListener を実装したアクティブなセッション情報を登録または削除するためのイベントトリガークラス。
ActiveSessionBindingListener() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionBindingListener のコンストラクタ
コンストラクタ。
ActiveSessionBindingListener(ActiveSessionInfo) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionBindingListener のコンストラクタ
コンストラクタ。
ActiveSessionException - exception jp.co.intra_mart.foundation.security.exception.ActiveSessionException.
アクティブなセッション情報例外の基本となる例外クラス。
ActiveSessionException(String) - class jp.co.intra_mart.foundation.security.exception.ActiveSessionException のコンストラクタ
コンストラクタ。
ActiveSessionException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.ActiveSessionException のコンストラクタ
コンストラクタ。
ActiveSessionException(Throwable) - class jp.co.intra_mart.foundation.security.exception.ActiveSessionException のコンストラクタ
コンストラクタ。
ActiveSessionException() - class jp.co.intra_mart.foundation.security.exception.ActiveSessionException のコンストラクタ
コンストラクタ。
ActiveSessionFilter - class jp.co.intra_mart.foundation.security.filter.ActiveSessionFilter.
アクティブセッションフィルタ。
ActiveSessionFilter() - class jp.co.intra_mart.foundation.security.filter.ActiveSessionFilter のコンストラクタ

ActiveSessionInfo - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo.
アクティブなセッション情報操作クラス。
ActiveSessionInfo() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のコンストラクタ
コンストラクタ。
ActiveSessionInfo(HttpServletRequest) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のコンストラクタ
コンストラクタ。
ActiveSessionInfo(SessionInfo, HttpSession, String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のコンストラクタ
コンストラクタ。
ActiveSessionInfo(SessionInfo, String, int, String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のコンストラクタ
コンストラクタ。
ActiveSessionInvalidatedByForceException - exception jp.co.intra_mart.foundation.security.exception.ActiveSessionInvalidatedByForceException.
アクティブなセッションが強制的に無効化されたことに関する例外クラス

ActiveSessionInvalidatedByForceException(String) - class jp.co.intra_mart.foundation.security.exception.ActiveSessionInvalidatedByForceException のコンストラクタ
コンストラクタ。
ActiveSessionInvalidatedByForceException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.ActiveSessionInvalidatedByForceException のコンストラクタ
コンストラクタ。
ActiveSessionInvalidatedByForceException(Throwable) - class jp.co.intra_mart.foundation.security.exception.ActiveSessionInvalidatedByForceException のコンストラクタ
コンストラクタ。
ActiveSessionInvalidatedByForceException() - class jp.co.intra_mart.foundation.security.exception.ActiveSessionInvalidatedByForceException のコンストラクタ
コンストラクタ。
ActiveSessionManager - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager.
アクティブセッション情報管理マネージャクラス。
ActiveSessionManager() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のコンストラクタ
コンストラクタ。
ActiveSessionNotExistException - exception jp.co.intra_mart.foundation.security.exception.ActiveSessionNotExistException.
アクティブなセッションが存在しない例外クラス。
ActiveSessionNotExistException(String) - class jp.co.intra_mart.foundation.security.exception.ActiveSessionNotExistException のコンストラクタ
コンストラクタ。
ActiveSessionNotExistException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.ActiveSessionNotExistException のコンストラクタ
コンストラクタ。
ActiveSessionNotExistException(Throwable) - class jp.co.intra_mart.foundation.security.exception.ActiveSessionNotExistException のコンストラクタ
コンストラクタ。
ActiveSessionNotExistException() - class jp.co.intra_mart.foundation.security.exception.ActiveSessionNotExistException のコンストラクタ
コンストラクタ。
ActivityFrameworkHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler.
推奨されていません。 このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。
ActivityFrameworkHTTPActionEventFilterHandler(HTTPActionEventHandler) - class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler のコンストラクタ
推奨されていません。 フレームワークのセッション環境を作成するためのフィルタハンドラを作成します。
ActivityHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler.
持続したセッションを確立するためのハンドラです。
ActivityHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler のコンストラクタ
新しいイベントハンドラを作成します。
ActivityHTTPActionEventHandler(String) - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler のコンストラクタ
指定のＵＲＬに再接続するための新しいイベントハンドラを作成します。
AdminMenuAccessor - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor.
メニューアクセッサインタフェース。
AdminMenuExporter - interface jp.co.intra_mart.foundation.security.menu.AdminMenuExporter.
メニューエクスポートインタフェースです。
AdminMenuImporter - interface jp.co.intra_mart.foundation.security.menu.AdminMenuImporter.
メニューインポートインタフェースです。
AdminMenuInclusion - class jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion.
メニュー内包情報クラス。
AdminMenuInclusion(String, String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion のコンストラクタ
コンストラクタ。
AdminMenuManager - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager.
管理メニューマネージャクラス。
AdminMenuPermissionSelector - class jp.co.intra_mart.foundation.security.permission.AdminMenuPermissionSelector.
ユーザIDから有効なメニューのID一覧を取得するセレクタ。
AdminMenuPermissionSelector() - class jp.co.intra_mart.foundation.security.permission.AdminMenuPermissionSelector のコンストラクタ
コンストラクタ。
AdminMenuPostWriterListener - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener.
メニュー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AdminMenuQueryWriterListener - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener.
メニュー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
AdminMenuReaderDecorator - interface jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator.
メニュー情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
AdvancedOutputStreamWriter - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter クラスを使用してください。
AdvancedOutputStreamWriter(OutputStream, String) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のコンストラクタ
推奨されていません。 指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のコンストラクタ
推奨されていません。 デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream, Charset) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のコンストラクタ
推奨されていません。 与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream, CharsetEncoder) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のコンストラクタ
推奨されていません。 与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のコンストラクタ
推奨されていません。 OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。
Application - interface jp.co.intra_mart.foundation.datastore.common.config.Application.
アプリケーションを定義します。
ApplicationInfo - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo.
アプリケーション情報のインタフェース。
AttachmentFile - interface jp.co.intra_mart.foundation.mail.javamail.model.AttachmentFile.
添付ファイルのモデルです。
Attribute - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute.
属性を定義します。
AttributeType - class jp.co.intra_mart.foundation.datastore.common.config.AttributeType.
属性で指定できる型です。
accountAdded(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウント情報をデータストアに作成した直後にコールされます。
accountAdded(String, Account) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener のメソッド
アカウント情報をデータストアに作成した直後にコールされます。
accountDeleted(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウント情報をデータストアから削除した直後にコールされます。
accountDeleted(String, String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener のメソッド
アカウント情報をデータストアから削除した直後にコールされます。
accountRoleAdded(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウントロール情報をデータストアに作成した直後にコールされます。
accountRoleAdded(String, String, AccountRole) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener のメソッド
アカウントロール情報をデータストアに作成した直後にコールされます。
accountRoleDeleted(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウントロール情報をデータストアから削除した直後にコールされます。
accountRoleDeleted(String, String, String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener のメソッド
アカウントロール情報をデータストアから削除した直後にコールされます。
accountRoleUpdated(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウントロール情報をデータストアに更新した直後にコールされます。
accountRoleUpdated(String, String, AccountRole) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener のメソッド
アカウントロール情報をデータストアに更新した直後にコールされます。
accountUpdated(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウント情報をデータストアに更新した直後にコールされます。
accountUpdated(String, Account) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener のメソッド
アカウント情報をデータストアに更新した直後にコールされます。
acntFromDBToIS(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
acntFromISToDB(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
action(Object) - interface jp.co.intra_mart.foundation.service.client.ActionListener のメソッド
このメソッドは、特定のイベント発生時に実行されます。
action(Object) - class jp.co.intra_mart.foundation.service.client.NetworkAgent のメソッド
このオブジェクトの実行ロジック。
action(Object) - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
推奨されていません。
action(Object) - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
推奨されていません。
action(Object) - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
推奨されていません。
action(Object) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
推奨されていません。
action(Object) - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
推奨されていません。
action(Object) - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
推奨されていません。
action(Object) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
推奨されていません。
action(HTTPActionEventContext, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent のメソッド
イベント処理メソッドです。
action(HTTPActionEventContext, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent のメソッド
イベント処理メソッドです。
activeCount() - class jp.co.intra_mart.foundation.utility.LockMonitor のメソッド
推奨されていません。 現在取得済みモニターの数を取得します。
add(int, Object) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リストの指定された位置に、指定された要素を挿入します。
add(Object) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リストの最後に、指定された要素を追加します。
add(SelectItem) - class jp.co.intra_mart.foundation.navigator.EventItem のメソッド
イベントノード追加
addAccount(Account) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントを新規追加します。
addAccountRole(String, AccountRole) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントロールを新規追加します。
addActiveSessionInfo(ActiveSessionInfo) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたアクティブなセッション情報を登録します。
addActiveSessionInfo(ActiveSessionInfo) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたアクティブなセッション情報を登録します。
addActiveSessionInfo(ActiveSessionInfo) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたアクティブなセッション情報を登録します。
addAll(Collection) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リストの末尾に、指定された Collection のすべての要素を追加します。
addAll(int, Collection) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リスト内の指定された位置から、指定された Collection のすべての要素を挿入します。
addAttachment(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
添付ファイルを追加します。
addBatch(Batch) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチ情報を新規登録します。
addBcc(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Bccを追加します。
addBcc(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Bccを追加します。
addCSVHeaderText(String) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 出力するCSVのヘッダ部分をセットします。
addCalendarInfo(String, CalendarInfo) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータを新規に追加します。
addCategory(ItemCategory) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のメソッド
商品カテゴリを新規登録します。
addCategoryDetail(CategoryDetail) - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のメソッド
分類区分詳細を登録します。
addCc(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Ccを追加します。
addCc(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Ccを追加します。
addChild(MenuTree) - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
子メニューを追加します。
addChildBranch(TreeBranch) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
指定されたブランチ branchを子ノードとして追加します。
addChildLeaf(TreeLeaf) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
指定されたリーフ leafを子ノードとして追加します。
addChildNode(TreeNode) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
指定されたノード node を子ノードとして追加します。
addCloseSocketEventListener(SocketEventListener) - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
addCloseSocketEventListener(SocketEventListener) - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
addCompany(Company) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
会社を登録します。
addComparator(Comparator) - class jp.co.intra_mart.foundation.utility.MultiComparator のメソッド
推奨されていません。 指定されたコンパレータ comparator を追加します。
addConditioner(GCConditioner) - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
推奨されていません。
addConditioner(ReportFileConditioner) - class jp.co.intra_mart.foundation.utility.report.FileReporter のメソッド
推奨されていません。 ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
addController(AccessController) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
アクセスコントローラを追加します。
addControllerDepartment(String, DepartmentInfo) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
組織をアクセスコントローラに紐付けます。
addControllerPost(String, PostInfo) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
役職をアクセスコントローラに紐付けます。
addControllerPublicGroup(String, PublicGroupInfo) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
パブリックグループをアクセスコントローラに紐付けます。
addControllerRole(String, String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
ロールをアクセスコントローラに紐付けます。
addCreateSocketEventListener(SocketEventListener) - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。
addData(BarGraphObject) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
描画オブジェクトに新しいデータを追加します。
addData(int, BarGraphObject) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
指定された位置に、指定された描画オブジェクトを追加します。
addData(double) - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
値を追加します。
addData(int) - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
値を追加します。
addData(CircleGraphObject) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
描画オブジェクトに新しいデータを追加します。
addData(int, CircleGraphObject) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
指定された位置に、指定された描画オブジェクトを追加します。
addData(LineGraphObject) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
描画オブジェクトに新しいデータを追加します。
addData(int, LineGraphObject) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
指定された位置に、指定された描画オブジェクトを追加します。
addData(double) - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
値を追加します。
addData(int) - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
値を追加します。
addData(PortFolioObject) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
描画オブジェクトに新しいデータを追加します。
addData(int, PortFolioObject) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
指定された位置に、指定された描画オブジェクトを追加します。
addData(RadarChartObject) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
描画オブジェクトに新しいデータを追加します。
addData(int, RadarChartObject) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
指定された位置に、指定された描画オブジェクトを追加します。
addData(double) - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
値を追加します。
addData(int) - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
値を追加します。
addDeal(Deal) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
取扱情報を新規登録します。
addDepartment(Department) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織を登録します。
addDepartment(DepartmentInfo) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

addDetail(DealDetail) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable のメソッド
取扱詳細を追加します。
addEventResultItemInfo(EventNavigatorManager, String, String, EventResultItemInfo) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
addEventResultItemInfo(String, String, EventResultItemInfo) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
addEventResultItemInfo(EventNavigatorManager, String, String, EventResultItemInfo) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
保存ナビゲート結果情報の登録（履歴） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（履歴）をDBに登録する。
addFavoriteMenu(String, FavoriteMenu) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
マイメニューを新規追加します。
addFavoriteSaveEventResultItemInfo(EventNavigatorManager, String, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。
addFavoriteSaveEventResultItemInfo(String, String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。
addFavoriteSaveEventResultItemInfo(EventNavigatorManager, String, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
保存ナビゲート結果情報お気に入りへ追加 ユーザID、保存ナビゲート結果IDをキーとして対象保存ナビゲート結果情報をお気に入りへ追加。
addGroupImageIcon(ImageIconInfo) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
グループのイメージアイコン情報を新規登録します。
addGroupSet(PublicGroupSet) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループセットを登録します。
addHeader(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
ヘッダーを追加します。
addItem(Item) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
商品情報を新規登録します。
addListener(EventListener) - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
リスナーを登録します。
addLoginGroup(LoginGroup) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループを新規追加します。
addMainPagePattern(String, MainPagePatternInfo) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンを新規追加します。
addMenuDepartment(String, DepartmentInfo) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
組織をメニューに紐付けます。
addMenuItem(String, MenuItem) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニューを追加します。
addMenuItem(String, MenuItem) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューを追加します。
addMenuLoginGroup(String, String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
管理メニューにアクセス権を設定します。
addMenuLoginGroup(String, String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
指定したログイングループのアクセス権をメニューに設定します。
addMenuPost(String, PostInfo) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
役職をメニューに紐付けます。
addMenuPublicGroup(String, PublicGroupInfo) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
パブリックグループをメニューに紐付けます。
addMenuRole(String, String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
ロールをメニューに紐付けます。
addOtherInfo(Object, Object) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
その他情報を追加する。
addPage(ResultPageItem) - class jp.co.intra_mart.foundation.navigator.EventResultItem のメソッド
リンクページ情報追加
addPasswordHistory(String, String, String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
パスワード履歴の追加。
addPasswordHistory(String, String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
パスワード履歴の追加。
addPasswordHistory(String, String, String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
パスワード履歴の追加。
addPost(CompanyPost) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
役職を登録します。
addPost(PostInfo) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

addPrivateGroup(PrivateGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
プライベートグループを登録します。
addPublicGroup(PublicGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループを登録します。
addPublicGroup(PublicGroupInfo) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

addReplyTo(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
ReplyToを追加します。
addReporter(MessageReporter) - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。
addRole(Role) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

addRole(Role) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール情報を新規登録します。
addSubRole(String, String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
サブロールIDを追加します。
addSuperUser(SuperUser) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
システム管理者情報を新規に作成します。
addSuperUser(String, SuperUser) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
グループ管理者を新規追加します。
addTemplate(ItemTemplate) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager のメソッド
商品属性テンプレート情報を新規登録します。
addThreadStopListener(ThreadStopListener) - class jp.co.intra_mart.foundation.utility.ExtendedThread のメソッド
推奨されていません。 このスレッドが終了したときに呼び出されるイベントリスナーを登録します。
addTo(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Toを追加します。
addTo(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Toを追加します。
addURL(String) - class jp.co.intra_mart.foundation.http.SessionQuery のメソッド
推奨されていません。 GenericURLBuilder.createFilePath(String) および URLBuilder.createURLonSession(String)に置き替えられました。
addUnit(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager のメソッド
単位を追加します。
addUser(User) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager のメソッド
ユーザを登録します。
addUserImageIcon(ImageIconInfo, String) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
ユーザのイメージアイコン情報を新規登録します。
addValidEndDate(int) - interface jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor のメソッド
SYSTEM日付に指定した日数を加えた日付を取得します。
addValidEndDate(int) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutManager のメソッド
SYSTEM日付に指定した日数を加えた日付を取得します。
addValidEndDate(int) - class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor のメソッド
SYSTEM日付に指定した日数を加えた日付を取得します。
addVersion(CompanyVersion) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
会社構成バージョンを新規に登録します。
addVersion(PublicGroupVersion) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループセット構成バージョンを新規に登録します。
append(String) - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ファイルにテキストを追記します。
append(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
append(String, String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
append(byte[]) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
archive(File) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
archive(File, FileFilter) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
archive(OutputStream) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
archive(OutputStream, FileFilter) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
archive(ZipOutputStream) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
archive(ZipOutputStream, FileFilter) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
attachFile(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 添付ファイルの内容をセットする。

B

BASE64DecodeInputStream - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream クラスを使用してください。
BASE64DecodeInputStream(InputStream) - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream のコンストラクタ
推奨されていません。 指定された InputStream から読み込む BASE64 デコード入力ストリームを作成します。
BASE64DecodeOutputStream - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream クラスを使用してください。
BASE64DecodeOutputStream(OutputStream) - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に書き込む BASE64デコーダーを作成します。
BASE64EncodeOutputStream - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream クラスを使用してください。
BASE64EncodeOutputStream(OutputStream) - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。
BASE64EncodeOutputStream(OutputStream, boolean) - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。
BATCH - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
バッチ情報
BATCH_ID - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
バッチID
BATCH_NAME - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
バッチ名
BarGraphDrawer - class jp.co.intra_mart.foundation.graph.BarGraphDrawer.
棒グラフを描画します。
BarGraphDrawer(int, int, int) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のコンストラクタ
ｙ軸の目盛値をint表現で棒グラフを作成します。
BarGraphDrawer(double, double, double) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のコンストラクタ
ｙ軸の目盛値をdouble表現で棒グラフを作成します。
BarGraphObject - class jp.co.intra_mart.foundation.graph.BarGraphObject.
BarGraphDrawerクラスのデータを保存するオブジェクトです。
BarGraphObject() - class jp.co.intra_mart.foundation.graph.BarGraphObject のコンストラクタ
デフォルトのデータオブジェクトを作成します。
BarGraphObject(Color) - class jp.co.intra_mart.foundation.graph.BarGraphObject のコンストラクタ
線の色を指定して、データオブジェクトを作成します。
BaseAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor.
基本エンティティに対する情報操作用のインタフェースです。
BaseModel - interface jp.co.intra_mart.foundation.datastore.common.config.BaseModel.
基本モデルを定義します。
BaseModel - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel.
基本モデルの情報です。
BaseModelContext - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext.
基本モデルの初期化に必要な設定を持ちます。
BaseTable - interface jp.co.intra_mart.foundation.datastore.common.config.BaseTable.
基本テーブルを定義します。
Batch - class jp.co.intra_mart.foundation.security.batch.Batch.
バッチ・モデルクラス
Batch() - class jp.co.intra_mart.foundation.security.batch.Batch のコンストラクタ
コンストラクタ。
Batch(String) - class jp.co.intra_mart.foundation.security.batch.Batch のコンストラクタ
コンストラクタ。
BatchAccessor - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor.

BatchBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel.
バッチ情報の基本モデルです。
BatchExporter - interface jp.co.intra_mart.foundation.security.batch.BatchExporter.
バッチバックアップインタフェースです。
BatchImporter - interface jp.co.intra_mart.foundation.security.batch.BatchImporter.
バッチバックアップインタフェースです。
BatchManager - class jp.co.intra_mart.foundation.security.batch.BatchManager.
バッチマネージャクラス。
BatchManager(String) - class jp.co.intra_mart.foundation.security.batch.BatchManager のコンストラクタ
コンストラクタ。
BatchMapper - interface jp.co.intra_mart.system.security.datastore.inf.BatchMapper.
バッチ情報に関連するマッパです。
BatchPostWriterListener - interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener.

BatchProcessException - exception jp.co.intra_mart.foundation.datastore.exception.BatchProcessException.
バッチ実行時に処理エラーが発生したことを示すためにスローされます。
BatchProcessException() - class jp.co.intra_mart.foundation.datastore.exception.BatchProcessException のコンストラクタ
コンストラクタ
BatchProcessException(String) - class jp.co.intra_mart.foundation.datastore.exception.BatchProcessException のコンストラクタ
コンストラクタ
BatchProcessException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.BatchProcessException のコンストラクタ
コンストラクタ
BatchProcessException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.BatchProcessException のコンストラクタ
コンストラクタ
BatchQueryWriterListener - interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener.

BatchReaderDecorator - interface jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator.

BatchSystemException - exception jp.co.intra_mart.foundation.datastore.exception.BatchSystemException.
バッチ実行時にシステムエラーが発生したことを示すためにスローされます。
BatchSystemException() - class jp.co.intra_mart.foundation.datastore.exception.BatchSystemException のコンストラクタ
コンストラクタ
BatchSystemException(String) - class jp.co.intra_mart.foundation.datastore.exception.BatchSystemException のコンストラクタ
コンストラクタ
BatchSystemException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.BatchSystemException のコンストラクタ
コンストラクタ
BatchSystemException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.BatchSystemException のコンストラクタ
コンストラクタ
backup(File) - class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory のメソッド
このデータを指定のファイルにバックアップします。
begin() - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
ロックフラグを立てます。
begin(long) - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
ロックフラグを立てます。
beginRequestScope() - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
ロックフラグを立てます。
beginRequestScope(long) - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
ロックフラグを立てます。
beginTransaction() - interface jp.co.intra_mart.foundation.database.DatabaseAccessor のメソッド
データベースアクセスのトランザクションを開始します。
beginTransaction() - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
データベースアクセスのトランザクションを開始します。
booleanValue() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値の真偽値表現を取得します。
buildLDAPContextInfo(Map) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoBuilder の static メソッド
設定情報モデルをログイングループID毎に作成し、Mapで返す。

C

CALENDAR_ID - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
カレンダーID
CALENDAR_INFO - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
カレンダーが保有するデータ
CASCADE - class jp.co.intra_mart.foundation.datastore.common.config.DeleteType の static 変数
削除 ターゲットエンティティのデータを参照しているソースエンティティのデータを削除します。
CASCADE - class jp.co.intra_mart.foundation.datastore.common.config.LifetimeType の static 変数
削除 ターゲットエンティティの期間を参照しているソースエンティティのデータを削除します。
CATEGORY - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel の static 変数
カテゴリ
CATEGORY_CLASS_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の static 変数
分類区分コード
CATEGORY_CLASS_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の static 変数
分類区分コード
CATEGORY_CLASS_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の static 変数
分類区分コード
CATEGORY_CLASS_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の static 変数
分類区分コード
CATEGORY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の static 変数
分類コード
CATEGORY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の static 変数
分類コード
CATEGORY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の static 変数
分類コード
CGIEnvironment - class jp.co.intra_mart.foundation.http.CGIEnvironment.
このクラスは、サーブレットクラス内で CGI 環境変数を扱えるように 各パラメータを CGI 環境変数で定義されているキーワードにマップします。
CGIEnvironment(HttpServletRequest) - class jp.co.intra_mart.foundation.http.CGIEnvironment のコンストラクタ
HTTP リクエストヘッダおよび Web サーバ情報から CGI 環境変数情報を構築します。
CHILD_ROLE_ID - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel の static 変数
子ロールコード
CLIENT_TYPE - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の static 変数
クライアントタイプ
COLOR - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
表示色
COLOR_PATTERN_ID - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
ページカラーパターン
COLUMN_NAVIGATOR_ACTION_TYPE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_ANSWER - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_COMPANY_CD - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_DEPARTMENT_CD - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_DESCRIPTION - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_EVENT_FLOW_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
イベントフロー
COLUMN_NAVIGATOR_EVENT_ITEM_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
イベントアイテム
COLUMN_NAVIGATOR_EVENT_RESULT_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
ナビゲート結果
COLUMN_NAVIGATOR_IDENTIFICATION_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
タイトル情報
COLUMN_NAVIGATOR_LOCALE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_MAX_SORT_NUM - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_NEXT_ITEM_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_OPEN - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_PAGE_URL - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_PARAM_KEY - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
ページパラメータ
COLUMN_NAVIGATOR_PARAM_VALUE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_PERMISSION_CHECK_FLAG - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_POST_CD - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_PUBLIC_GROUP_CD - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_PUBLIC_GROUP_SET_CD - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_QUESTION - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
保存イベント履歴
COLUMN_NAVIGATOR_RECORD_DATE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_RECORD_USER - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
共通
COLUMN_NAVIGATOR_RESULT_PAGE_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
結果ページ
COLUMN_NAVIGATOR_ROLE_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
権限情報
COLUMN_NAVIGATOR_SELECT_ITEM_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
選択アイテム
COLUMN_NAVIGATOR_SORT_NUMBER - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_START_EVENT_ITEM_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_TITLE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_TYPE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

COLUMN_NAVIGATOR_USER_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
保存ナビゲート結果
COMPANY_CD - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel の static 変数
会社CD
COMPANY_CD - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel の static 変数
会社CD
COMPANY_CD - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel の static 変数
会社CD
COMPANY_CD - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel の static 変数
会社CD
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel の static 変数
会社コード
CONFIG_FILE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

CONTENTS - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の static 変数
コンテンツの種類
CONTENT_TYPE_IN - class jp.co.intra_mart.foundation.security.menu.MenuItem の static 変数
メニューコンテンツの種類（内部URL）。
CONTENT_TYPE_OUT - class jp.co.intra_mart.foundation.security.menu.MenuItem の static 変数
メニューコンテンツの種類（外部URL）。
CONTINUE - interface jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener の static 変数
リスナー処理を続行し、メール送信を行います。
COOKIE_SEPARATOR - interface jp.co.intra_mart.foundation.security.SessionInfo の static 変数
セッション情報をクッキーに保管する際のセパレータ。
COUNTRY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
国コード
COUNTRY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
国コード
CP_COOKIE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
セッション情報をクッキーに保管するパラメータ名。
CRYPTION_CATEGORY_MOBILE_USER_AGENT - class jp.co.intra_mart.foundation.security.account.AccountManager の static 変数
暗号化アルゴリズムカテゴリ: モバイル端末個体識別番号用。
CR_ERROR - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
認証処理エラーの返却値。
CR_LOCKED - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
アカウントロック状態の返却値。
CR_NG - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインエラーの返却値。
CR_NO_GROUP - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログイングループ未登録状態の返却値。
CR_NO_LICENSE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ライセンスなし、または有効期間外状態の返却値。
CR_NO_PERMISSION - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
無許可ページへのアクセスの返却値。
CR_NO_USER - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ユーザ未登録状態の返却値。
CR_OK - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
認証成功の返却値。
CR_SESSION_INITIAL - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
セッション初期状態の返却値。
CR_SESSION_LOGON - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
セッションログオン状態の返却値。
CR_SESSION_TIMEOUT - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
セッションタイムアウト状態の返却値。
CR_SESSION_UNMATCH - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
セッション不整合状態の返却値。
CURRENCY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の static 変数
通貨コード
CUSTOMER_COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の static 変数
取引先会社コード
CUSTOMER_COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel の static 変数
取引先会社コード
CUSTOMER_COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel の static 変数
取引先会社コード
CUSTOMER_COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel の static 変数
取引先会社コード
CUSTOMER_COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel の static 変数
取引先会社コード
CUSTOMER_DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の static 変数
取引先組織コード
CUSTOMER_DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel の static 変数
取引先組織コード
CUSTOMER_DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel の static 変数
取引先組織コード
CUSTOMER_DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel の static 変数
取引先組織コード
CUSTOMER_DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel の static 変数
取引先組織コード
CalendarAccessor - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor.
カレンダーアクセッサインタフェース。
CalendarExporter - interface jp.co.intra_mart.foundation.security.calendar.CalendarExporter.
カレンダーバックアップインタフェースです。
CalendarImporter - interface jp.co.intra_mart.foundation.security.calendar.CalendarImporter.
カレンダーバックアップインタフェースです。
CalendarInfo - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo.
カレンダーデータ・モデルクラス
CalendarInfo() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のコンストラクタ
コンストラクタ。
CalendarInfo(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のコンストラクタ
コンストラクタ。
CalendarInfoBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel.
カレンダーが保有するデータの基本モデルです。
CalendarInfoInternationalModel - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoInternationalModel.
カレンダーが保有するデータの国際化モデルです。
CalendarInfoMapper - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper.
カレンダーが保有するデータに関連するマッパです。
CalendarManager - class jp.co.intra_mart.foundation.security.calendar.CalendarManager.
カレンダーマネージャクラス

カレンダー情報の操作を行います。
CalendarManager(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のコンストラクタ
コンストラクタ。
CalendarPlugin - interface jp.co.intra_mart.foundation.security.calendar.CalendarPlugin.
カレンダデータプラグインインターフェース。
CalendarPluginAutumnalEquinox - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox.
カレンダデータプラグインクラス。
CalendarPluginAutumnalEquinox() - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox のコンストラクタ

CalendarPluginEndOfTheMonth - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth.
カレンダデータプラグインクラス。
CalendarPluginEndOfTheMonth() - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth のコンストラクタ

CalendarPluginInfo - interface jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo.
カレンダーデータプラグイン情報のインターフェース。
CalendarPluginLastDayInTheMonth - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth.
カレンダデータプラグインクラス。
CalendarPluginLastDayInTheMonth() - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth のコンストラクタ

CalendarPluginMondayMakeupHoliday - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday.
カレンダデータプラグインクラス。
CalendarPluginMondayMakeupHoliday() - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday のコンストラクタ

CalendarPluginVernalEquinox - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox.
カレンダデータプラグインクラス。
CalendarPluginVernalEquinox() - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox のコンストラクタ

CalendarPostWriterListener - interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener.
カレンダー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
CalendarQueryWriterListener - interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener.
カレンダー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
CalendarReaderDecorator - interface jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator.
アカウント情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
CategorizedCalendarInfo - class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo.
カテゴライズカレンダーデータクラス。
CategorizedCalendarInfo(CalendarInfo[]) - class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo のコンストラクタ
コンストラクタ。
CategoryDetail - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail.
分類区分詳細の基本属性のデータを取り扱います。
CategoryDetail() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のコンストラクタ
分類区分詳細に関連する情報を新規に生成します。
CategoryDetail(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のコンストラクタ
分類区分詳細に関連する情報を新規に生成します。
CategoryDetailBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel.
分類区分詳細の基本モデルです。
CategoryDetailInternational - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational.
分類区分詳細の国際化属性のデータを取り扱います。
CategoryDetailInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational のコンストラクタ

CategoryDetailInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel.
分類区分詳細の国際化モデルです。
CategoryDetailMapper - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper.
分類区分詳細に関連するマッパです。
CategoryManager - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager.
分類に関連する情報を管理します。
CategoryManager() - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のコンストラクタ

CateogryClass - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass.
分類区分の基本属性のデータを取り扱います。
CateogryClass() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のコンストラクタ
分類区分に関連する情報を新規に生成します。
CateogryClass(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のコンストラクタ
分類区分に関連する情報を新規に生成します。
CateogryClassBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel.
分類区分の基本モデルです。
CateogryClassInternational - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational.
分類区分の国際化属性のデータを取り扱います。
CateogryClassInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational のコンストラクタ

CateogryClassInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel.
分類区分の国際化モデルです。
CateogryClassMapper - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper.
分類区分に関連するマッパです。
ChangedListenerException - exception jp.co.intra_mart.foundation.exception.ChangedListenerException.
更新リスナーの例外クラス。
ChangedListenerException() - class jp.co.intra_mart.foundation.exception.ChangedListenerException のコンストラクタ
コンストラクタ。
ChangedListenerException(String) - class jp.co.intra_mart.foundation.exception.ChangedListenerException のコンストラクタ
コンストラクタ。
ChangedListenerException(Throwable) - class jp.co.intra_mart.foundation.exception.ChangedListenerException のコンストラクタ
コンストラクタ。
ChangedListenerException(String, Throwable) - class jp.co.intra_mart.foundation.exception.ChangedListenerException のコンストラクタ
コンストラクタ。
CharacterEncoder - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder クラスを使用してください。
CharacterEncoder(String) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のコンストラクタ
推奨されていません。 文字コード変換のためのエンコーダを作成します。
CircleGraphDrawer - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer.
円グラフを描画します。
CircleGraphDrawer() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のコンストラクタ
ｙ軸の目盛値をint表現で円グラフを作成します。
CircleGraphObject - class jp.co.intra_mart.foundation.graph.CircleGraphObject.
CircleGraphDrawerクラスのデータを保存するオブジェクトです。
CircleGraphObject(double, Color) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のコンストラクタ
グラフ値と色を指定して、データオブジェクトを作成します。
CircleGraphObject(int, Color) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のコンストラクタ
グラフ値と色を指定して、データオブジェクトを作成します。
CircleGraphObject(double, Color, String) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のコンストラクタ
グラフ値と色とキャプションを指定して、データオブジェクトを作成します。
CircleGraphObject(int, Color, String) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のコンストラクタ
グラフ値と色とキャプションを指定して、データオブジェクトを作成します。
ClientTypeInfo - interface jp.co.intra_mart.foundation.security.ClientTypeInfo.
クライアントタイプ情報インタフェース。
ColorPatternInfo - interface jp.co.intra_mart.foundation.security.ColorPatternInfo.
カラーパターン情報を取得するインタフェース。
Column - interface jp.co.intra_mart.foundation.datastore.common.config.Column.
属性に対応するカラムの型を定義します。
ColumnMapping - interface jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping.
分割されたテーブルに割り当てられるカラムを定義します。
Company - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company.
会社の基本属性のデータを取り扱います。
Company() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のコンストラクタ
会社に関連する情報を新規に生成します。
Company(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のコンストラクタ
会社に関連する情報を新規に生成します。
Company(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のコンストラクタ
会社に関連する情報を新規に生成します。
Company(Locale, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のコンストラクタ
会社に関連する情報を新規に生成します。
CompanyBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel.
会社の基本モデルです。
CompanyCategory - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory.
会社組織分類の基本属性のデータを取り扱います。
CompanyCategory() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のコンストラクタ
会社組織分類に関連する情報を新規に生成します。
CompanyCategory(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のコンストラクタ
会社組織分類に関連する情報を新規に生成します。
CompanyCategoryBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel.
会社組織分類の基本モデルです。
CompanyCategoryMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper.
会社組織分類に関連するマッパです。
CompanyCategoryTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable.
会社組織分類の期間化属性のデータを取り扱います。
CompanyCategoryTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable のコンストラクタ

CompanyCategoryTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryTerminableModel.
会社組織分類の期間化モデルです。
CompanyChangedControllerListener - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener.
会社・組織・役職が削除された場合にアクセスコントローラに紐付く会社・組織・役職を削除するリスナークラスです。
CompanyChangedControllerListener() - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のコンストラクタ

CompanyChangedListener - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener.
会社・組織に関する情報の変更時のリスナーです。
CompanyChangedMenuListener - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener.
会社・組織に関する情報の変更時のリスナーです。
CompanyChangedMenuListener() - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のコンストラクタ

CompanyExportManager - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager.
会社情報のエクスポートを行います。
CompanyExportManager() - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager のコンストラクタ
コンストラクタ 会社情報エクスポートマネージャーのインスタンスを生成します。
CompanyExportManagerClient - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient.
会社情報のエクスポートを行います。
CompanyExportManagerClient() - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient のコンストラクタ

CompanyImportManager - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager.
会社情報のインポートを行います。
CompanyImportManager() - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager のコンストラクタ
コンストラクタ 会社インポートマネージャーのインスタンスを生成します。
CompanyImportManagerClient - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient.
会社情報のインポートを行います。
CompanyImportManagerClient() - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient のコンストラクタ

CompanyImporter - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter.
会社のインポートのインターフェースです。
CompanyManager - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager.
会社や組織に関連する情報を管理します。
CompanyManager() - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のコンストラクタ

CompanyMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper.
会社に関連するマッパです。
CompanyPost - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost.
役職の基本属性のデータを取り扱います。
CompanyPost() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のコンストラクタ
役職に関連する情報を新規に生成します。
CompanyPost(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のコンストラクタ
役職に関連する情報を新規に生成します。
CompanyPost(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のコンストラクタ
役職に関連する情報を新規に生成します。
CompanyPost(Locale, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のコンストラクタ
役職に関連する情報を新規に生成します。
CompanyPostBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel.
役職の基本モデルです。
CompanyPostExportManager - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager.
会社役職情報のエクスポートを行います。
CompanyPostExportManager() - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager のコンストラクタ
コンストラクタ 会社役職エクスポートマネージャーのインスタンスを生成します。
CompanyPostExportManagerClient - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient.
会社役職情報のエクスポートを行います。
CompanyPostExportManagerClient() - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient のコンストラクタ

CompanyPostImportManager - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager.
会社役職情報のインポートを行います。
CompanyPostImportManager() - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager のコンストラクタ
コンストラクタ 会社役職インポートマネージャーのインスタンスを生成します。
CompanyPostImportManagerClient - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient.
会社役職情報のインポートを行います。
CompanyPostImportManagerClient() - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient のコンストラクタ

CompanyPostImporter - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter.
役職のインポートのインターフェースです。
CompanyPostMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper.
役職に関連するマッパです。
CompanyPostTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable.
役職の期間化属性のデータを取り扱います。
CompanyPostTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable のコンストラクタ

CompanyPostTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational.
役職の期間国際化属性のデータを取り扱います。
CompanyPostTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational のコンストラクタ

CompanyPostTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel.
役職の期間国際化モデルです。
CompanyPostTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel.
役職の期間化モデルです。
CompanyTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable.
会社の期間化属性のデータを取り扱います。
CompanyTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のコンストラクタ

CompanyTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational.
会社の期間国際化属性のデータを取り扱います。
CompanyTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のコンストラクタ

CompanyVersion - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion.
会社構成バージョンの基本属性のデータを取り扱います。
CompanyVersion() - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のコンストラクタ

CompanyVersionBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel.
会社構成バージョンの基本モデルです。
CompanyVersionMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper.
会社構成バージョンに関連するマッパです。
ConInfo - interface jp.co.intra_mart.foundation.database.ConInfo.

ConcreteHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler.
任意の HTTPActionEvent を実行するためのハンドラです。
ConcreteHTTPActionEventHandler(String) - class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler のコンストラクタ
指定のイベント名で表されるイベントを実行するためのハンドラを作成します。
Configuration - interface jp.co.intra_mart.foundation.datastore.common.config.Configuration.
設定内容を取得します。
ConfigurationFactory - class jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory.
Configurationを生成します。
ConfigurationFactory() - class jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory のコンストラクタ

Counter - class jp.co.intra_mart.foundation.utility.Counter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.Counter クラスを使用してください。
Counter() - class jp.co.intra_mart.foundation.utility.Counter のコンストラクタ
推奨されていません。 カウンターオブジェクトを作成します。
Counter(long) - class jp.co.intra_mart.foundation.utility.Counter のコンストラクタ
推奨されていません。 指定の初期値でカウンターオブジェクトを作成します。
Cryption - interface jp.co.intra_mart.foundation.security.cryption.Cryption.
文字列の暗号化・復号化インタフェース。
CsvAccountBackup - class jp.co.intra_mart.foundation.security.account.CsvAccountBackup.
CSVアカウントバックアップクラスです。
CsvAccountBackup() - class jp.co.intra_mart.foundation.security.account.CsvAccountBackup のコンストラクタ

CurrencyManager - class jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager.
通貨情報を取り扱います。
CurrencyManager() - class jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager のコンストラクタ

canReport() - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter のメソッド
推奨されていません。 このストリームが書き込み可能かどうかをチェックします。
capacity() - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 このマップに対してマップできるキーの最大個数を返します。
categoryDetailRemoved(String, CompanyCategory) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
分類区分情報がデータストアから削除された後に呼び出されます。
categoryDetailRemoved(String, PublicGroupCategory) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
分類区分情報がデータストアから削除された後に呼び出されます。
categoryDetailRemoved(String, CompanyCategory) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
分類区分情報がデータストアから削除された後に呼び出されます。
categoryDetailRemoved(String, PublicGroupCategory) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
分類区分情報がデータストアから削除された後に呼び出されます。
categoryDetailRemoved(String, CompanyCategory) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
分類区分情報がデータストアから削除された後に呼び出されます。
categoryDetailRemoved(String, PublicGroupCategory) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
分類区分情報がデータストアから削除された後に呼び出されます。
categoryDetailSet(String, CompanyCategory) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
分類区分情報がデータストアに登録された後に呼び出されます。
categoryDetailSet(String, PublicGroupCategory) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
分類区分情報がデータストアに登録された後に呼び出されます。
categoryDetailSet(String, CompanyCategory) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
分類区分情報がデータストアに登録された後に呼び出されます。
categoryDetailSet(String, PublicGroupCategory) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
分類区分情報がデータストアに登録された後に呼び出されます。
categoryDetailSet(String, CompanyCategory) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
分類区分情報がデータストアに登録された後に呼び出されます。
categoryDetailSet(String, PublicGroupCategory) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
分類区分情報がデータストアに登録された後に呼び出されます。
certification(LoginInfo, Account, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.LDAPUserCertification のメソッド
ユーザを認証する。
certification(LoginInfo, SuperUser, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification のメソッド
管理者を認証します。
certification(LoginInfo, Account, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardUserCertification のメソッド
ユーザを認証します。
certification(LoginInfo, SuperUser, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.SuperCertification のメソッド
管理者を認証する。
certification(LoginInfo, SuperUser, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification のメソッド
管理者を認証します。
certification(LoginInfo, Account, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.UserCertification のメソッド
ユーザを認証する。
certification(LoginInfo, Account, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPUserCertification のメソッド
LDAPに対してユーザを認証します。
certify(String[], String[]) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール内包を認証します。
checkByBaseProperty(Relationship[], BaseModel, BaseModel) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
基準項目によるリレーションシップの整合性制約をチェックします。
checkByBaseProperty(Relationship[], BaseModel, BaseModel) - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
基準項目によるリレーションシップの整合性制約をチェックします。
checkDigitOfNumber(Number, int, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
数値の整数部、小数部の桁数チェック。
checkDigitOfNumber(Number, Integer, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
数値の整数部、小数部の桁数チェック（引数がクラス版）。
checkDigitOfNumberString(String, int, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
数値（文字型）の整数部、小数部の桁数チェック
※数値かどうかのチェックも行う。
checkDigitOfNumberString(String, Integer, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
数値（文字型）の整数部、小数部の桁数チェック（引数がクラス版）

checkLocale(String, String[]) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter のメソッド
ロケールチェック（共通）

checkLocale(String, String[]) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter のメソッド
ロケールチェック（共通）

checkMobile(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuAnalyzer のメソッド
モバイル端末の種別をチェックします。
checkMobile(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuHdmlAnalyzer のメソッド
推奨されていません。 モバイル端末の種別をチェックします。
checkMobile(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoAnalyzer のメソッド
モバイル端末の種別をチェックします。
checkMobile(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoMoveAnalyzer のメソッド
推奨されていません。 モバイル端末の種別をチェックします。
checkMobile(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginJphoneAnalyzer のメソッド
推奨されていません。 モバイル端末の種別をチェックします。
checkMobile(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginSoftBankAnalyzer のメソッド
モバイル端末の種別をチェックします。
checkMobile(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginVodafoneAnalyzer のメソッド
モバイル端末の種別をチェックします。
checkMobile(String, HttpServletRequest) - interface jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider のメソッド
モバイル端末の種別をチェックします。
checkPasswordHistory(String, String, String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
パスワードの入力チェック。
checkPasswordHistory(String, String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
パスワードの入力チェック。
checkPasswordHistory(String, String, String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
入力パスワードのチェック。
checkStrLength(String, int) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter のメソッド
文字列チェック（共通）

checkTitleInfo(NavigatorItem, String[], String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter のメソッド
タイトル情報のロケールマッチング（共通）

childDirectories() - class jp.co.intra_mart.foundation.utility.file.Directory のメソッド
推奨されていません。 この抽象パス名が示すディレクトリにあるサブディレクトリの抽象パスを 繰り返し処理する反復子を作成します。
childDirectory(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
childFile(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
childFiles() - class jp.co.intra_mart.foundation.utility.file.Directory のメソッド
推奨されていません。 この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
childPath(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
clean() - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
システムのガベージコレクタを実行します。
clean() - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor のメソッド
推奨されていません。 プール中のコネクションをすべて破棄します。
clean() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 プール中のコネクションをすべて破棄します。
cleanUp() - interface jp.co.intra_mart.foundation.service.provider.GCConditioner のメソッド
gc を実行するかどうかを判断します。
clear() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
すべてのデータを削除します。
clear() - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
すべての値を削除します。
clear() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
すべてのデータを削除します。
clear() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
すべてのデータを削除します。
clear() - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
すべての値を削除します。
clear() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
すべてのデータを削除します。
clear() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
すべてのデータを削除します。
clear() - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
すべての値を削除します。
clear() - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リストからすべての要素を削除します。
clear() - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
データを削除します。
clear() - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
データを削除します。
clear() - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
すべてのデータを削除します。
clear() - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
このオブジェクトのマップからマッピングをすべて削除します。
clear() - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 マップからマッピングをすべて削除します。
clearError() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 このインスタンスのメソッド実行中に発生した例外をすべて破棄します。
clearInstance() - class jp.co.intra_mart.foundation.database.DatabaseExport の static メソッド
推奨されていません。 DatabaseExportインスタンスを開放します。
clearInstance() - class jp.co.intra_mart.foundation.security.AccessSecurityManager の static メソッド
アクセスセキュリティマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.SystemManager の static メソッド
システムマネージャのインスタンスを初期化を行います。
clearInstance() - class jp.co.intra_mart.foundation.security.access.AccessControllerManager の static メソッド
アクセスコントローラマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.account.AccountManager の static メソッド
アカウントマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.batch.BatchManager の static メソッド
バッチマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager の static メソッド
カレンダーマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.group.LoginGroupManager の static メソッド
ログイングループマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager の static メソッド
ログイングループマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.menu.MenuManager の static メソッド
メニューマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager の static メソッド

clearInstance() - class jp.co.intra_mart.foundation.security.shortcut.ShortCutManager の static メソッド

clearPasswordHistories(String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
パスワード履歴の消去。
clearPasswordHistories() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
パスワード履歴の消去。
clearPasswordHistories(String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
パスワード履歴の消去。
clearPasswordHistory(String, String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
指定ユーザのパスワード履歴の消去。
clearPasswordHistory(String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
指定ユーザのパスワード履歴の消去。
clearPasswordHistory(String, String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
指定ユーザのパスワード履歴の消去。
clearUrl() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ダイレクトＵＲＬを削除する。
clearWarnings() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection オブジェクトに関して通知されたすべての警告をクリアします。
close(Connection, PreparedStatement) - class jp.co.intra_mart.foundation.database.DatabaseExport の static メソッド
推奨されていません。
close() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 releaseメソッドと同等です。
close() - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
マッパーをクローズします。
close() - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
マッパーをクローズします。
close() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
ネットワークを切断します。
close() - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream のメソッド
推奨されていません。 ストリームを閉じます。
close() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 入出力ストリームおよびソケットを閉じます。
close() - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 入出力ストリームおよびソケットを閉じます。
close() - class jp.co.intra_mart.foundation.utility.io.HexInputStream のメソッド
推奨されていません。 ストリームを閉じます。
close() - class jp.co.intra_mart.foundation.utility.io.HexOutputStream のメソッド
推奨されていません。 ストリームを閉じます。
close() - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のメソッド
推奨されていません。 ストリームを閉じてフラッシュします。
close() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 入出力ストリームおよびソケットを閉じます。
close() - class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter のメソッド
推奨されていません。 このオブジェクトを閉じます。
close() - class jp.co.intra_mart.foundation.utility.report.FileReporter のメソッド
推奨されていません。 このオブジェクトを閉じます。
close() - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter のメソッド
推奨されていません。 このオブジェクトを閉じます。
close() - interface jp.co.intra_mart.foundation.utility.report.MessageReporter のメソッド
推奨されていません。 このオブジェクトを閉じます。
close() - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 このオブジェクトを閉じます。
close() - class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter のメソッド
推奨されていません。 このオブジェクトを閉じます。
close() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 ストリームを閉じてフラッシュします。
close() - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter のメソッド
推奨されていません。 ストリームを閉じます。
commit() - interface jp.co.intra_mart.foundation.database.DatabaseAccessor のメソッド
データベースのトランザクションをコミットします。
commit() - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
データベースのトランザクションをコミットします。
commit() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースアクセスの確定処理を行います。
companyAdded(String, Company) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
会社情報がデータストアに登録された後に呼び出されます。
companyAdded(String, Company) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
会社情報がデータストアに登録された後に呼び出されます。
companyAdded(String, Company) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
会社情報がデータストアに登録された後に呼び出されます。
companyDeleted(String, Company) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
会社情報がデータストアから削除された後に呼び出されます。
companyDeleted(String, Company) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
会社情報がデータストアから削除された後に呼び出されます。
companyDeleted(String, Company) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
会社情報がデータストアから削除された後に呼び出されます。
compare(Object, Object) - class jp.co.intra_mart.foundation.page.NodeNameComparator のメソッド
順序付けのために 2 つの引数を比較するメソッドです。
compare(Object, Object) - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
順序付けのために 2 つの引数を比較します。
compare(Object, Object) - class jp.co.intra_mart.foundation.utility.AbstractDualComparator のメソッド
推奨されていません。 順序付けのために ２ つの引数を比較するメソッドです。
compare(Object, Object) - class jp.co.intra_mart.foundation.utility.FilterComparator のメソッド
推奨されていません。 順序付けのために 2 つの引数を比較するメソッドです。
compare(Object, Object) - class jp.co.intra_mart.foundation.utility.ReverseComparator のメソッド
推奨されていません。 フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。
compare(Object, Object) - class jp.co.intra_mart.foundation.utility.SequenceComparator のメソッド
推奨されていません。 順序付けのために ２ つの引数を比較するメソッドです。
compareTo(Object) - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
この期間と指定された期間を比較します。
compileReader(Reader) - class jp.co.intra_mart.foundation.scenario.FunctionContainer のメソッド
スクリプトのソースをコンパイルします。
compileString(String) - class jp.co.intra_mart.foundation.scenario.FunctionContainer のメソッド
スクリプトのソースをコンパイルします。
connection() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.file.AbstractComponent のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.manager.ServerConnector のメソッド
サーバに接続するためのコネクションを取得します。
connection() - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor のメソッド
推奨されていません。 コネクションの取得。
connection() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 コネクションの取得。
contact(ConInfo) - class jp.co.intra_mart.foundation.database.DbManager の static メソッド
推奨されていません。 代替えメソッドはありません。
contact() - class jp.co.intra_mart.foundation.database.DbManager のメソッド
推奨されていません。 代替えメソッドはありません。
contains(String) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.contains(String)に置き換えられました。
contains(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.contains(String)に置き換えられました。
contains(Object) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リストに指定の要素がある場合に true を返します。
contains(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントの存在チェックを行います。
contains(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロールの存在チェックを行います。
containsAll(Collection) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 このコレクション内に、指定されたコレクションのすべての要素がある場合に true を返します。
containsCategory(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
カテゴリーの存在チェックをします。
containsDate(Date) - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
指定された日時が期間内に入っているかどうかを指定します。
containsHeader(String) - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
推奨されていません。 指定された文字列がヘッダの名称かどうかを判定します。
containsKey(Object) - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 指定されたキーへのマッピングをこのマップが格納する場合に true を返します。
copyEventFlow(EventNavigatorManager, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
copyEventFlow(String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
copyEventFlow(EventNavigatorManager, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
イベントフローのコピー コピー元イベントフローＩＤからイベントフローを取得し、全ての情報をコピーして新規にイベントフローを作成する。
copyVersion(String, String, String, Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の会社構成バージョンの内容をコピーします。
copyVersion(String, String, String, Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループセット構成バージョンの内容をコピーします。
count() - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.count()に置き換えられました。
count() - class jp.co.intra_mart.foundation.acssecurity.Logingp の static メソッド
推奨されていません。 LoginGroupManager.countLoginGroups()に置き換えられました。
count() - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.count()に置き換えられました。
count() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントの登録数を取得します。
count(String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
アクティブなすべてのセッション数を取得します。
count(String, String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたユーザのアクティブなすべてのセッション数を取得します。
count(String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。
count(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
アクティブなすべてのセッション数を取得します。
count(String, String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたユーザのアクティブなすべてのセッション数を取得します。
count(String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。
count(String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
アクティブなすべてのセッション数を取得します。
count(String, String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたユーザのアクティブなすべてのセッション数を取得します。
count(String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。
count() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール数を取得します。
countByCategory(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
カテゴリーに属するロール数を取得します。
countLoginGroups() - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループ数を取得します。
counter - class jp.co.intra_mart.foundation.page.EventScript の static 変数
このクラスからインスタンスが生成された回数。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
プライマリキーに該当する分類区分を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
プライマリキーに該当する分類区分詳細を生成します。
create(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
プライマリキーに該当する組織所属を生成します。
create(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
プライマリキーに該当する会社組織分類を生成します。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
プライマリキーに該当する会社を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
プライマリキーに該当する組織を生成します。
create(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
プライマリキーに該当する組織内包を生成します。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
プライマリキーに該当する主所属を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
プライマリキーに該当する役職を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
プライマリキーに該当する会社構成バージョンを生成します。
create(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper のメソッド
プライマリキーに該当する取扱を生成します。
create(String, String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper のメソッド
プライマリキーに該当する組織毎取扱パーミッションを生成します。
create(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper のメソッド
プライマリキーに該当する取扱詳細を生成します。
create(String, String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper のメソッド
プライマリキーに該当するパブリックグループ毎取扱パーミッションを生成します。
create(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper のメソッド
プライマリキーに該当するロール毎取扱パーミッションを生成します。
create(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper のメソッド
プライマリキーに該当する商品属性を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper のメソッド
プライマリキーに該当する商品カタログを生成します。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper のメソッド
プライマリキーに該当する商品を生成します。
create(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper のメソッド
プライマリキーに該当する商品分類を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper のメソッド
プライマリキーに該当する商品カテゴリを生成します。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper のメソッド
プライマリキーに該当する商品カテゴリ種別を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper のメソッド
プライマリキーに該当する商品属性テンプレート明細を生成します。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper のメソッド
プライマリキーに該当する商品属性テンプレートを生成します。
create(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライマリキーに該当するプライベートグループ所属を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライマリキーに該当するプライベートグループを生成します。
create(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
プライマリキーに該当するパブリックグループ所属を生成します。
create(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
プライマリキーに該当するパブリックグループ分類を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
プライマリキーに該当するパブリックグループを生成します。
create(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
プライマリキーに該当するパブリックグループ内包を生成します。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
プライマリキーに該当するパブリックグループセットを生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
プライマリキーに該当するパブリックグループ構成バージョンを生成します。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper のメソッド
プライマリキーに該当する単位を生成します。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
プライマリキーに該当するユーザを生成します。
create(String, String, String) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper のメソッド
プライマリキーに該当するアクセスコントローラの利用権限を保有する組織を生成します。
create(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper のメソッド
プライマリキーに該当するアクセスコントローラ情報を生成します。
create(String, String, String) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper のメソッド
プライマリキーに該当するアクセスコントローラの利用権限を保有する役職を生成します。
create(String, String, String) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper のメソッド
プライマリキーに該当するアクセスコントローラの利用権限を保有するパブリックグループを生成します。
create(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper のメソッド
プライマリキーに該当するアクセスコントローラの利用権限を保有するロールを生成します。
create(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper のメソッド
プライマリキーに該当するアカウントが保有する属性を生成します。
create(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountMapper のメソッド
プライマリキーに該当するアカウントを生成します。
create(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper のメソッド
プライマリキーに該当するアカウントが保有するロールを生成します。
create(String) - interface jp.co.intra_mart.system.security.datastore.inf.BatchMapper のメソッド
プライマリキーに該当するバッチ情報を生成します。
create(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper のメソッド
プライマリキーに該当するカレンダーが保有するデータを生成します。
create(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper のメソッド
プライマリキーに該当するアカウントが保有するメニューを生成します。
create(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper のメソッド
プライマリキーに該当するメニューの保有する引数を生成します。
create(String, String, String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper のメソッド
プライマリキーに該当するメニューの利用権限を保有する組織を生成します。
create(String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuMapper のメソッド
プライマリキーに該当するメニュー情報を生成します。
create(String, String, String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper のメソッド
プライマリキーに該当するメニューの利用権限を保有する役職を生成します。
create(String, String, String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper のメソッド
プライマリキーに該当するメニューの利用権限を保有するパブリックグループを生成します。
create(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper のメソッド
プライマリキーに該当するメニューの利用権限を保有するロールを生成します。
create(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper のメソッド
プライマリキーに該当するロール内包を生成します。
create(String) - interface jp.co.intra_mart.system.security.datastore.inf.RoleMapper のメソッド
プライマリキーに該当するロールを生成します。
create(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper のメソッド
プライマリキーに該当するロールサマリを生成します。
createBaseAccessor(Map) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
このマッパーに該当する基本アクセサを新規に生成します。
createBaseModel(Map) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
このマッパーに該当する基本モデルを新規に生成します。
createBaseModel(Map) - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
このマッパーに該当する基本モデルを新規に生成します。
createConfiguration() - class jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory のメソッド
Configurationを生成します。
createExtendedBaseAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap のメソッド
拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を生成します。
createExtendedBaseModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap のメソッド
拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
createExtendedBaseModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap のメソッド
拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
createExtendedInternationalAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap のメソッド
拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を生成します。
createExtendedInternationalModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap のメソッド
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
createExtendedInternationalModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap のメソッド
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
createExtendedTerminableAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap のメソッド
拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を生成します。
createExtendedTerminableInternationalAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap のメソッド
拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を生成します。
createExtendedTerminableInternationalModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap のメソッド
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
createExtendedTerminableInternationalModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap のメソッド
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
createExtendedTerminableModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap のメソッド
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
createExtendedTerminableModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap のメソッド
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
createFilePath(String) - class jp.co.intra_mart.jssp.net.GenericURLBuilder のメソッド
指定のページパスからリンクの為のページパスを作成して返します。
createImage(Graphics) - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルを描画します。
createImage(Graphics) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
棒グラフを描画します。
createImage(Graphics) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
円グラフを描画します。
createImage(Graphics) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
折れ線グラフを描画します。
createImage(Graphics) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ポートフォリオを描画します。
createImage(Graphics) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
レーダーチャートを描画します。
createInternationalAccessor(Locale) - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap のメソッド
国際化アクセサを生成します。
createInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
国際化モデルを生成します。
createInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap のメソッド
国際化モデルを生成します。
createLoginRequestInfo(String) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ログイン情報を作成します。
createMapper(String, String, String, String) - class jp.co.intra_mart.foundation.datastore.common.model.MapperFactory のメソッド
マッパーを生成します。
createPassword(int) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
パスワードをランダムに生成。
createPassword(int) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド

createPassword(int) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
パスワードをランダムに生成。
createRole(String, Role) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
ロール情報を新規追加します。
createRole(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
ロール情報を新規に追加する。
createSession(Properties) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
SMTPセッションを構築します。
createShortCut(String, ShortCutInfo) - interface jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor のメソッド
ショートカットIDを作成します。
createShortCut(ShortCutInfo) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutManager のメソッド
ショートカットＩＤ作成。
createShortCut(String, ShortCutInfo) - class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor のメソッド
ショートカットIDを作成します。
createSocket() - class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor のメソッド
推奨されていません。 新しいソケットを作成します。
createSocketConnectionDistributor(String) - class jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory のメソッド
Server-Manager に接続するためのネットワークコネクション管理 オブジェクトを取得します。
createStatement() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 SQL 文をデータベースに送るための Statement オブジェクトを生成します。
createStatement(int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定されたタイプと並行処理で ResultSet オブジェクトを生成する Statement オブジェクトを生成します。
createStatement(int, int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された型、並行処理、および holdability で ResultSet オブジェクトを生成する Statement オブジェクトを生成します。
createTerminableAccessor(Term) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap のメソッド
指定した期間に期間化アクセサを生成します。
createTerminableInternationalAccessor(Locale) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap のメソッド
期間国際化アクセサを生成します。
createTerminableInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
期間国際化モデルを生成します。
createTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap のメソッド
期間国際化モデルを生成します。
createTerminableModel(Term) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
指定した期間を満たす期間化モデルを生成します。
createTerminableModel(Term) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap のメソッド
指定した期間を満たす期間化モデルを生成します。
createURL(String) - class jp.co.intra_mart.jssp.net.GenericURLBuilder のメソッド
現在のリクエストを元にして、指定の画面へリンクするための URL を作成します。
createURL(URL, String) - class jp.co.intra_mart.jssp.net.GenericURLBuilder のメソッド
指定の URL を仕様解析のコンテキストとして スクリプト開発モデルの画面への URL を解決した URL を返します。
createURLonSession(String) - class jp.co.intra_mart.jssp.net.URLBuilder のメソッド
HTTP セッションを維持したまま指定のスクリプト開発モデルの画面へ リンクするための URL を返します。
createURLonSession(URL, String) - class jp.co.intra_mart.jssp.net.URLBuilder のメソッド
HTTP セッションを維持したまま指定のスクリプト開発モデルの画面へ リンクするための URL を返します。
createUrlSignature(String, String, String) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ダイレクトＵＲＬ署名を作成します。
createWriter(OutputStreamWriter) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter の static メソッド
推奨されていません。 AdvancedOutputStreamWriter のスーパークラス AdvancedOutputStreamWriter を作成します。
createWriter() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 メッセージをファイルへ書き出すための出力ストリームを作成します。
currentWriter() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 このオブジェクトが文字を書き出している基礎 Writer を返します。

D

DATA_ID - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
データID
DATA_NAME - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
データ名称
DATA_TYPE - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel の static 変数
データ型
DATA_TYPE - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
データタイプ
DATA_TYPE_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel の static 変数
データ型が数値を表す定数
DATA_TYPE_STRING - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel の static 変数
データ型が文字列型を表す定数
DATE - class jp.co.intra_mart.foundation.datastore.common.config.AttributeType の static 変数
日時型
DAY - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
日
DAY_WEEK - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
曜日
DB2 - class jp.co.intra_mart.foundation.database.DbTypes の static 変数

DBResultAdapter - interface jp.co.intra_mart.foundation.database.DBResultAdapter.
スクリプト開発用データベースカラム取得アダプタインタフェース。
DBResultArrayAdapter - class jp.co.intra_mart.foundation.database.DBResultArrayAdapter.
スクリプト開発用データベースARRAY型カラム取得アダプタ。
DBResultArrayAdapter() - class jp.co.intra_mart.foundation.database.DBResultArrayAdapter のコンストラクタ

DBResultBigDecimalAdapter - class jp.co.intra_mart.foundation.database.DBResultBigDecimalAdapter.
スクリプト開発用データベースDECIMAL,NUMERIC型カラム取得アダプタ。
DBResultBigDecimalAdapter() - class jp.co.intra_mart.foundation.database.DBResultBigDecimalAdapter のコンストラクタ

DBResultBigIntAdapter - class jp.co.intra_mart.foundation.database.DBResultBigIntAdapter.
スクリプト開発用データベースBIGINT型カラム取得アダプタ。
DBResultBigIntAdapter() - class jp.co.intra_mart.foundation.database.DBResultBigIntAdapter のコンストラクタ

DBResultBinaryAdapter - class jp.co.intra_mart.foundation.database.DBResultBinaryAdapter.
スクリプト開発用データベースBINARY,LONGVARBINARY,VARBINARY型カラム取得アダプタ。
DBResultBinaryAdapter() - class jp.co.intra_mart.foundation.database.DBResultBinaryAdapter のコンストラクタ

DBResultBlobAdapter - class jp.co.intra_mart.foundation.database.DBResultBlobAdapter.
スクリプト開発用データベースBLOB型カラム取得アダプタ。
DBResultBlobAdapter() - class jp.co.intra_mart.foundation.database.DBResultBlobAdapter のコンストラクタ

DBResultBooleanAdapter - class jp.co.intra_mart.foundation.database.DBResultBooleanAdapter.
スクリプト開発用データベースBOOLEAN,BIT型カラム取得アダプタ。
DBResultBooleanAdapter() - class jp.co.intra_mart.foundation.database.DBResultBooleanAdapter のコンストラクタ

DBResultByteAdapter - class jp.co.intra_mart.foundation.database.DBResultByteAdapter.
スクリプト開発用データベースBYTE型カラム取得アダプタ。
DBResultByteAdapter() - class jp.co.intra_mart.foundation.database.DBResultByteAdapter のコンストラクタ

DBResultClobAdapter - class jp.co.intra_mart.foundation.database.DBResultClobAdapter.
スクリプト開発用データベースCLOB型カラム取得アダプタ。
DBResultClobAdapter() - class jp.co.intra_mart.foundation.database.DBResultClobAdapter のコンストラクタ

DBResultDateAdapter - class jp.co.intra_mart.foundation.database.DBResultDateAdapter.
スクリプト開発用データベースDATE型カラム取得アダプタ。
DBResultDateAdapter() - class jp.co.intra_mart.foundation.database.DBResultDateAdapter のコンストラクタ

DBResultDoubleAdapter - class jp.co.intra_mart.foundation.database.DBResultDoubleAdapter.
スクリプト開発用データベースDOUBLE,FLOAT型カラム取得アダプタ。
DBResultDoubleAdapter() - class jp.co.intra_mart.foundation.database.DBResultDoubleAdapter のコンストラクタ

DBResultImTimestampAdapter - class jp.co.intra_mart.foundation.database.DBResultImTimestampAdapter.
スクリプト開発用データベースTIMESTAMP型カラム取得intra-mart拡張アダプタ。
DBResultImTimestampAdapter() - class jp.co.intra_mart.foundation.database.DBResultImTimestampAdapter のコンストラクタ

DBResultIntegerAdapter - class jp.co.intra_mart.foundation.database.DBResultIntegerAdapter.
スクリプト開発用データベースINTEGER型カラム取得アダプタ。
DBResultIntegerAdapter() - class jp.co.intra_mart.foundation.database.DBResultIntegerAdapter のコンストラクタ

DBResultNullAdapter - class jp.co.intra_mart.foundation.database.DBResultNullAdapter.
スクリプト開発用データベースNULL型カラム取得アダプタ。
DBResultNullAdapter() - class jp.co.intra_mart.foundation.database.DBResultNullAdapter のコンストラクタ

DBResultObjectAdapter - class jp.co.intra_mart.foundation.database.DBResultObjectAdapter.
スクリプト開発用データベースカラムをObject型として取得するアダプタ。
DBResultObjectAdapter() - class jp.co.intra_mart.foundation.database.DBResultObjectAdapter のコンストラクタ

DBResultRealAdapter - class jp.co.intra_mart.foundation.database.DBResultRealAdapter.
スクリプト開発用データベースREAL型カラム取得アダプタ。
DBResultRealAdapter() - class jp.co.intra_mart.foundation.database.DBResultRealAdapter のコンストラクタ

DBResultRefAdapter - class jp.co.intra_mart.foundation.database.DBResultRefAdapter.
スクリプト開発用データベースREF型カラム取得アダプタ。
DBResultRefAdapter() - class jp.co.intra_mart.foundation.database.DBResultRefAdapter のコンストラクタ

DBResultShortAdapter - class jp.co.intra_mart.foundation.database.DBResultShortAdapter.
スクリプト開発用データベースSMALLINT型カラム取得アダプタ。
DBResultShortAdapter() - class jp.co.intra_mart.foundation.database.DBResultShortAdapter のコンストラクタ

DBResultStringAdapter - class jp.co.intra_mart.foundation.database.DBResultStringAdapter.
スクリプト開発用データベースカラムを文字列型として取得するアダプタ。
DBResultStringAdapter() - class jp.co.intra_mart.foundation.database.DBResultStringAdapter のコンストラクタ

DBResultStructAdapter - class jp.co.intra_mart.foundation.database.DBResultStructAdapter.
スクリプト開発用データベースSTRUCT型カラム取得アダプタ。
DBResultStructAdapter() - class jp.co.intra_mart.foundation.database.DBResultStructAdapter のコンストラクタ

DBResultTimeAdapter - class jp.co.intra_mart.foundation.database.DBResultTimeAdapter.
スクリプト開発用データベースTIME型カラム取得アダプタ。
DBResultTimeAdapter() - class jp.co.intra_mart.foundation.database.DBResultTimeAdapter のコンストラクタ

DBResultTimestampAdapter - class jp.co.intra_mart.foundation.database.DBResultTimestampAdapter.
スクリプト開発用データベースTIMESTAMP型カラム取得アダプター。
DBResultTimestampAdapter() - class jp.co.intra_mart.foundation.database.DBResultTimestampAdapter のコンストラクタ

DBTYPE_DB2 - class jp.co.intra_mart.foundation.database.DatabaseExport の static 変数
推奨されていません。
DBTYPE_ORACLE - class jp.co.intra_mart.foundation.database.DatabaseExport の static 変数
推奨されていません。
DBTYPE_POSTGRESQL - class jp.co.intra_mart.foundation.database.DatabaseExport の static 変数
推奨されていません。
DBTYPE_SQLSERVER - class jp.co.intra_mart.foundation.database.DatabaseExport の static 変数
推奨されていません。
DB_DB2 - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

DB_ORACLE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

DB_POSTGRE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

DEAL_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の static 変数
取扱コード
DEAL_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel の static 変数
取扱コード
DEAL_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel の static 変数
取扱コード
DEAL_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel の static 変数
取扱コード
DEAL_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel の static 変数
取扱コード
DEAL_NAME - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の static 変数
取扱名
DEAL_TYPE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の static 変数
取扱種別
DEAL_TYPE_BUY - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の static 変数
取引種別が仕入れを表す定数
DEAL_TYPE_SELL - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の static 変数
取引種別が売り上げを表す定数
DECIMAL - class jp.co.intra_mart.foundation.datastore.common.config.AttributeType の static 変数
整数型
DEFAULT_ACCESSOR - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

DEFAULT_ACCESS_SECURITY_PAGE_PROVIDER_CLASS - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor の static 変数

DEFAULT_ACCESS_SECURITY_PAGE_PROVIDER_CLASS - class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor の static 変数

DEFAULT_ACTIVE_SESSION_ACCESSOR - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager の static 変数

DEFAULT_ATTR_INVALIDATE_OTHER_SESSIONS - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager の static 変数

DEFAULT_ATTR_REQUESTED_PAGE - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager の static 変数

DEFAULT_ATTR_REQUESTED_PAGE - class jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter の static 変数
遷移先の警告ページにリクエストURLを渡すために利用するリクエスト属性名のデフォルト名
DEFAULT_AUTH_COOKIE_NAME - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の static 変数

DEFAULT_BOTTOM_MARGIN - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準のグラフ領域の下部マージン
DEFAULT_BOTTOM_MARGIN - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準のグラフ領域の下部マージン
DEFAULT_BOTTOM_MARGIN - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準のグラフ領域の下部マージン
DEFAULT_BOTTOM_MARGIN - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準のグラフ領域の下部マージン
DEFAULT_BOTTOM_MARGIN - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準のグラフ領域の下部マージン
DEFAULT_CAPTION_MARGIN - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準のキャプション表示位置のマージン
DEFAULT_CAPTION_MARGIN - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準のキャプション表示位置のマージン
DEFAULT_COMMENT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

DEFAULT_COMMENT - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor の static 変数
コメント
DEFAULT_CONFIG_PAGE_COUNT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
履歴表示件数 ：デフォルト件数
DEFAULT_DUPLICATE_LOGIN_ACCESSOR - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager の static 変数

DEFAULT_DUPLICATE_LOGIN_DETECT_ENABLE - class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor の static 変数

DEFAULT_EXPORTER - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

DEFAULT_FAVORITE - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor の static 変数
保存ナビゲート結果（お気に入）
DEFAULT_GRAPH_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準のグラフ領域の背景色
DEFAULT_GRAPH_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準のグラフ領域の背景色
DEFAULT_GRAPH_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準のグラフ領域の背景色
DEFAULT_GRAPH_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準のグラフ領域のボーダー色
DEFAULT_GRAPH_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準のグラフ領域のボーダー色
DEFAULT_GRAPH_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準のグラフ領域のボーダー色
DEFAULT_GRAPH_FRAME_COLOR - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準のグラフ枠の線色
DEFAULT_HISTORY - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor の static 変数
保存ナビゲート結果（履歴）
DEFAULT_IMAGE_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準の画像ファイル背景色
DEFAULT_IMAGE_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準の画像ファイル背景色
DEFAULT_IMAGE_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準の画像ファイル背景色
DEFAULT_IMAGE_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準の画像ファイル背景色
DEFAULT_IMAGE_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準の画像ファイル背景色
DEFAULT_IMAGE_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準の画像ファイルのボーダ色
DEFAULT_IMAGE_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準の画像ファイルのボーダ色
DEFAULT_IMAGE_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準の画像ファイルのボーダ色
DEFAULT_IMAGE_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準の画像ファイルのボーダ色
DEFAULT_IMAGE_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準の画像ファイルのボーダ色
DEFAULT_IMPORTER - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

DEFAULT_INVALIDATABLE_BY_USER - class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor の static 変数

DEFAULT_LEFT_MARGIN - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準のグラフ領域の左側マージン
DEFAULT_LEFT_MARGIN - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準のグラフ領域の左側マージン
DEFAULT_LEFT_MARGIN - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準のグラフ領域の左側マージン
DEFAULT_LEFT_MARGIN - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準のグラフ領域の左側マージン
DEFAULT_LEFT_MARGIN - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準のグラフ領域の左側マージン
DEFAULT_LOGIN_KEY - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の static 変数

DEFAULT_PAGE_LOCATION - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor の static 変数

DEFAULT_PAGE_LOCATION - class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor の static 変数

DEFAULT_RIGHT_MARGIN - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準のグラフ領域の右側マージン
DEFAULT_RIGHT_MARGIN - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準のグラフ領域の右側マージン
DEFAULT_RIGHT_MARGIN - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準のグラフ領域の右側マージン
DEFAULT_RIGHT_MARGIN - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準のグラフ領域の右側マージン
DEFAULT_RIGHT_MARGIN - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準のグラフ領域の右側マージン
DEFAULT_SORT_KEY - class jp.co.intra_mart.foundation.image.ImageIconInfo の static 変数
デフォルトソートキー
DEFAULT_SP_ACTIVE_SESSION_BINDING_LISTENER - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager の static 変数

DEFAULT_STROKE - class jp.co.intra_mart.foundation.graph.LineGraphObject の static 変数

DEFAULT_TITLE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

DEFAULT_TITLE - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor の static 変数
タイトル
DEFAULT_TOP_MARGIN - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準のグラフ領域の上部マージン
DEFAULT_TOP_MARGIN - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準のグラフ領域の上部マージン
DEFAULT_TOP_MARGIN - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準のグラフ領域の上部マージン
DEFAULT_TOP_MARGIN - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準のグラフ領域の上部マージン
DEFAULT_TOP_MARGIN - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準のグラフ領域の上部マージン
DEPARTMENT_CD - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel の static 変数
組織CD
DEPARTMENT_CD - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel の static 変数
組織CD
DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
組織コード
DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の static 変数
組織コード
DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
組織コード
DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
組織コード
DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の static 変数
組織コード
DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel の static 変数
組織コード
DEPTH - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
階層レベル
DEPTH - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
階層レベル
DISPLAY_NAME - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
データ表示名
DISPLAY_NAME - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel の static 変数
メニュー表示名
DISPLAY_NAME - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の static 変数
メニュー表示名
DISPLAY_NAME - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel の static 変数
ロール表示名
DISPLAY_NONE - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet の static 変数
表示単位を指定しない状態
DISPLAY_PERCENT - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet の static 変数
表示単位パーセント
DISPLAY_PIXCEL - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet の static 変数
表示単位ピクセル
DataNotFoundException - exception jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException.
アクセサのプロパティ値の取得に関する例外クラス

指定されたプロパティに対する値が設定されていない場合にスローする。
DataNotFoundException() - class jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException のコンストラクタ
コンストラクタ
DataNotFoundException(String) - class jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException のコンストラクタ
コンストラクタ
DataNotFoundException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException のコンストラクタ
コンストラクタ
DataNotFoundException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException のコンストラクタ
コンストラクタ
DataSourceProvider - interface jp.co.intra_mart.foundation.database.DataSourceProvider.
データソース設定情報取得プロバイダインタフェース。
DataStoreApplicationException - exception jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException.
アプリケーション共通マスタで発生するアプリケーション例外の基底クラス
DataStoreApplicationException() - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のコンストラクタ
コンストラクタ
DataStoreApplicationException(String) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のコンストラクタ
コンストラクタ
DataStoreApplicationException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のコンストラクタ
コンストラクタ
DataStoreApplicationException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のコンストラクタ
コンストラクタ
DataStoreConfigException - exception jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException.
アプリケーション共通マスタの設定に関する例外クラス

アプリケーション共通マスタの設定に不整合がある場合にスローする。
DataStoreConfigException() - class jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException のコンストラクタ
詳細メッセージを指定しないで DataStoreConfigException を構築します。
DataStoreConfigException(String) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException のコンストラクタ
指定された詳細メッセージを持つ DataStoreConfigException を構築します。
DataStoreConfigException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PresentationPropertyException を構築します。
DataStoreConfigException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException のコンストラクタ
この例外の発生原因となる例外を持つ PresentationPropertyException を構築します。
DataStoreConst - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst.
データストアの定数クラス
DataStoreSystemException - exception jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException.
アプリケーション共通マスタで発生するシステム例外の基底クラス
DataStoreSystemException() - class jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException のコンストラクタ
コンストラクタ
DataStoreSystemException(String) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException のコンストラクタ
コンストラクタ
DataStoreSystemException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException のコンストラクタ
コンストラクタ
DataStoreSystemException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException のコンストラクタ
コンストラクタ
DatabaseAccessor - interface jp.co.intra_mart.foundation.database.DatabaseAccessor.
データベース接続オブジェクト取得インターフェースを定義します。
DatabaseColumn - class jp.co.intra_mart.foundation.database.DatabaseColumn.

DatabaseColumn() - class jp.co.intra_mart.foundation.database.DatabaseColumn のコンストラクタ

DatabaseColumn(int) - class jp.co.intra_mart.foundation.database.DatabaseColumn のコンストラクタ

DatabaseColumn(int, int) - class jp.co.intra_mart.foundation.database.DatabaseColumn のコンストラクタ

DatabaseColumn(String, String, String, int, boolean) - class jp.co.intra_mart.foundation.database.DatabaseColumn のコンストラクタ

DatabaseExport - class jp.co.intra_mart.foundation.database.DatabaseExport.
推奨されていません。 システム内部で利用しているクラスです。
DatabaseExportException - exception jp.co.intra_mart.foundation.database.exception.DatabaseExportException.
推奨されていません。 システム内部で利用しているクラスです。
DatabaseExportException(int) - class jp.co.intra_mart.foundation.database.exception.DatabaseExportException のコンストラクタ
推奨されていません。
DatabaseExportException(String, int) - class jp.co.intra_mart.foundation.database.exception.DatabaseExportException のコンストラクタ
推奨されていません。
DatabaseManager - class jp.co.intra_mart.foundation.database.DatabaseManager.
データベースマネージャクラス。
DatabaseSQLException - exception jp.co.intra_mart.foundation.database.exception.DatabaseSQLException.
データベースSQL例外拡張クラス。
DatabaseSQLException(String) - class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException のコンストラクタ
コンストラクタ。
DatabaseSQLException(String, String) - class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException のコンストラクタ
コンストラクタ。
DatabaseSQLException(String, String, int) - class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException のコンストラクタ
コンストラクタ。
DatabaseSQLException(String, Throwable) - class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException のコンストラクタ
コンストラクタ。
DatabaseSQLException(String, String, Throwable) - class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException のコンストラクタ
コンストラクタ。
DatabaseSQLException(String, String, int, Throwable) - class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException のコンストラクタ
コンストラクタ。
DayInfo - interface jp.co.intra_mart.foundation.security.calendar.DayInfo.
日付に対するカレンダーデータ情報の取得インターフェース。
DbManager - class jp.co.intra_mart.foundation.database.DbManager.
推奨されていません。 DatabaseManagerを使用してください。
DbManager(String) - class jp.co.intra_mart.foundation.database.DbManager のコンストラクタ
推奨されていません。 DatabaseManagerを使用してください。
DbTypes - class jp.co.intra_mart.foundation.database.DbTypes.

DbsConnection - interface jp.co.intra_mart.foundation.database.DbsConnection.
推奨されていません。 Connectionを利用してください。
Deal - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal.
取扱の基本属性のデータを取り扱います。
Deal() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のコンストラクタ
取扱に関連する情報を新規に生成します。
Deal(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のコンストラクタ
取扱に関連する情報を新規に生成します。
DealBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel.
取扱の基本モデルです。
DealDetail - class jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail.
取扱詳細の基本属性のデータを取り扱います。
DealDetail() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail のコンストラクタ

DealDetailBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel.
取扱詳細の基本モデルです。
DealDetailMapper - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper.
取扱詳細に関連するマッパです。
DealDetailTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailTerminableModel.
取扱詳細の期間化モデルです。
DealManager - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager.
取扱に関する情報を管理します。
DealManager() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のコンストラクタ

DealMapper - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper.
取扱に関連するマッパです。
DealPermissionManager - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager.
取扱情報に対するアクセス権を操作します。
DealPermissionManager() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager のコンストラクタ

DealTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable.
取扱の期間化属性のデータを取り扱います。
DealTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable のコンストラクタ

DealTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealTerminableModel.
取扱の期間化モデルです。
DealerDepartment - class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment.
組織毎取扱パーミッションの基本属性のデータを取り扱います。
DealerDepartment() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment のコンストラクタ

DealerDepartmentBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel.
組織毎取扱パーミッションの基本モデルです。
DealerDepartmentMapper - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper.
組織毎取扱パーミッションに関連するマッパです。
DealerPublicGroup - class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup.
パブリックグループ毎取扱パーミッションの基本属性のデータを取り扱います。
DealerPublicGroup() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup のコンストラクタ

DealerPublicGroupBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel.
パブリックグループ毎取扱パーミッションの基本モデルです。
DealerPublicGroupMapper - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper.
パブリックグループ毎取扱パーミッションに関連するマッパです。
DealerRole - class jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole.
ロール毎取扱パーミッションの基本属性のデータを取り扱います。
DealerRole() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole のコンストラクタ

DealerRoleBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel.
ロール毎取扱パーミッションの基本モデルです。
DealerRoleMapper - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper.
ロール毎取扱パーミッションに関連するマッパです。
Delete - interface jp.co.intra_mart.foundation.datastore.common.config.Delete.
削除時の整合性制約です。
DeleteType - class jp.co.intra_mart.foundation.datastore.common.config.DeleteType.
削除時の整合性制約のタイプです。
Department - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department.
組織の基本属性のデータを取り扱います。
Department() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のコンストラクタ
組織に関連する情報を新規に生成します。
Department(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のコンストラクタ
組織に関連する情報を新規に生成します。
Department(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のコンストラクタ
組織に関連する情報を新規に生成します。
Department(Locale, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のコンストラクタ
組織に関連する情報を新規に生成します。
DepartmentAttach - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach.
組織所属の基本属性のデータを取り扱います。
DepartmentAttach() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のコンストラクタ
組織所属に関連する情報を新規に生成します。
DepartmentAttach(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のコンストラクタ
組織所属に関連する情報を新規に生成します。
DepartmentAttachBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel.
組織所属の基本モデルです。
DepartmentAttachMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper.
組織所属に関連するマッパです。
DepartmentAttachTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable.
組織所属の期間化属性のデータを取り扱います。
DepartmentAttachTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable のコンストラクタ

DepartmentAttachTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel.
組織所属の期間化モデルです。
DepartmentBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel.
組織の基本モデルです。
DepartmentInclusionBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel.
組織内包の基本モデルです。
DepartmentInclusionMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper.
組織内包に関連するマッパです。
DepartmentInfo - class jp.co.intra_mart.foundation.security.DepartmentInfo.
組織情報クラス。
DepartmentInfo(String, String) - class jp.co.intra_mart.foundation.security.DepartmentInfo のコンストラクタ
コンストラクタ。
DepartmentMain - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain.
主所属の基本属性のデータを取り扱います。
DepartmentMain() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のコンストラクタ
主所属に関連する情報を新規に生成します。
DepartmentMain(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のコンストラクタ
主所属に関連する情報を新規に生成します。
DepartmentMainBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel.
主所属の基本モデルです。
DepartmentMainMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper.
主所属に関連するマッパです。
DepartmentMainTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable.
主所属の期間化属性のデータを取り扱います。
DepartmentMainTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable のコンストラクタ

DepartmentMainTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel.
主所属の期間化モデルです。
DepartmentMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper.
組織に関連するマッパです。
DepartmentStruct - interface jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct.
組織の階層です。
DepartmentTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable.
組織の期間化属性のデータを取り扱います。
DepartmentTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のコンストラクタ

DepartmentTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational.
組織の期間国際化属性のデータを取り扱います。
DepartmentTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のコンストラクタ

DepartmentTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel.
組織の期間国際化モデルです。
DepartmentTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel.
組織の期間化モデルです。
Directory - class jp.co.intra_mart.foundation.utility.file.Directory.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。
Directory(String) - class jp.co.intra_mart.foundation.utility.file.Directory のコンストラクタ
推奨されていません。 指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
Directory(File, String) - class jp.co.intra_mart.foundation.utility.file.Directory のコンストラクタ
推奨されていません。 親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
Directory(String, String) - class jp.co.intra_mart.foundation.utility.file.Directory のコンストラクタ
推奨されていません。 親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
DualComparator - interface jp.co.intra_mart.foundation.utility.DualComparator.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.DualComparator クラスを使用してください。
DuplicateException - exception jp.co.intra_mart.foundation.security.exception.DuplicateException.
作成時重複例外クラス。
DuplicateException(String, String, String) - class jp.co.intra_mart.foundation.security.exception.DuplicateException のコンストラクタ
コンストラクタ。
DuplicateException(String, String) - class jp.co.intra_mart.foundation.security.exception.DuplicateException のコンストラクタ
コンストラクタ。
DuplicateException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.DuplicateException のコンストラクタ
コンストラクタ。
DuplicateException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.DuplicateException のコンストラクタ
コンストラクタ。
DuplicateImageIconCodeException - exception jp.co.intra_mart.foundation.image.DuplicateImageIconCodeException.
登録時重複例外クラス。
DuplicateImageIconCodeException() - class jp.co.intra_mart.foundation.image.DuplicateImageIconCodeException のコンストラクタ
コンストラクタ。
DuplicateImageIconCodeException(String, String) - class jp.co.intra_mart.foundation.image.DuplicateImageIconCodeException のコンストラクタ
コンストラクタ。
DuplicateImageIconCodeException(Throwable) - class jp.co.intra_mart.foundation.image.DuplicateImageIconCodeException のコンストラクタ
コンストラクタ。
DuplicateImageIconCodeException(String, String, Throwable) - class jp.co.intra_mart.foundation.image.DuplicateImageIconCodeException のコンストラクタ
コンストラクタ。
DuplicateImageIconSrcException - exception jp.co.intra_mart.foundation.image.DuplicateImageIconSrcException.
作成/更新時URLの重複例外クラス。
DuplicateImageIconSrcException() - class jp.co.intra_mart.foundation.image.DuplicateImageIconSrcException のコンストラクタ
コンストラクタ。
DuplicateImageIconSrcException(String, String) - class jp.co.intra_mart.foundation.image.DuplicateImageIconSrcException のコンストラクタ
コンストラクタ。
DuplicateImageIconSrcException(Throwable) - class jp.co.intra_mart.foundation.image.DuplicateImageIconSrcException のコンストラクタ
コンストラクタ。
DuplicateImageIconSrcException(String, String, Throwable) - class jp.co.intra_mart.foundation.image.DuplicateImageIconSrcException のコンストラクタ
コンストラクタ。
DuplicateLoginAccessor - interface jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor.
重複ログイン操作インターフェース。
DuplicateLoginDetectedException - exception jp.co.intra_mart.foundation.security.exception.DuplicateLoginDetectedException.
重複ログイン検出例外クラス

DuplicateLoginDetectedException(String) - class jp.co.intra_mart.foundation.security.exception.DuplicateLoginDetectedException のコンストラクタ
コンストラクタ。
DuplicateLoginDetectedException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.DuplicateLoginDetectedException のコンストラクタ
コンストラクタ。
DuplicateLoginDetectedException(Throwable) - class jp.co.intra_mart.foundation.security.exception.DuplicateLoginDetectedException のコンストラクタ
コンストラクタ。
DuplicateLoginDetectedException() - class jp.co.intra_mart.foundation.security.exception.DuplicateLoginDetectedException のコンストラクタ
コンストラクタ。
DuplicateLoginException - exception jp.co.intra_mart.foundation.security.exception.DuplicateLoginException.
重複ログイン制御例外の基本となる例外クラス。
DuplicateLoginException(String) - class jp.co.intra_mart.foundation.security.exception.DuplicateLoginException のコンストラクタ
コンストラクタ。
DuplicateLoginException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.DuplicateLoginException のコンストラクタ
コンストラクタ。
DuplicateLoginException(Throwable) - class jp.co.intra_mart.foundation.security.exception.DuplicateLoginException のコンストラクタ
コンストラクタ。
DuplicateLoginException() - class jp.co.intra_mart.foundation.security.exception.DuplicateLoginException のコンストラクタ
コンストラクタ。
DuplicateLoginHandlingFilter - class jp.co.intra_mart.foundation.security.filter.DuplicateLoginHandlingFilter.
重複ログインハンドリングフィルタ。
DuplicateLoginHandlingFilter() - class jp.co.intra_mart.foundation.security.filter.DuplicateLoginHandlingFilter のコンストラクタ

DuplicateLoginManager - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager.
重複ログイン管理マネージャクラス。
DuplicateLoginManager() - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager のコンストラクタ
コンストラクタ。
dateToString(Date) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
データベース登録用文字列を取得します。
dateToString(Date) - class jp.co.intra_mart.foundation.database.DbManager の static メソッド
推奨されていません。 DatabaseManager.dateToString(Date)を使用してください。
datumpoint - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter の変数
推奨されていません。 このリポーターがフィルタリングする基準レベル値
dbConsistChk(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
decode(String) - interface jp.co.intra_mart.foundation.portal.common.encode.EnCodeInterface のメソッド
復号化を行います。
decrement() - class jp.co.intra_mart.foundation.utility.Counter のメソッド
推奨されていません。 カウンターの値を１だけ減少させます。
decrypt(String) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
デフォルトの暗号化アルゴリズムカテゴリを利用して暗号化された文字列を復号します。
decrypt(String, String) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
指定された暗号化アルゴリズムカテゴリを利用して暗号化された文字列を復号します。
decrypt(String) - interface jp.co.intra_mart.foundation.security.cryption.Cryption のメソッド
暗号化された文字列を復号するe。
decrypt(String) - class jp.co.intra_mart.foundation.security.cryption.NoCryption のメソッド
暗号化された文字列を復号するe。
decrypt(String) - class jp.co.intra_mart.foundation.security.cryption.StandardCryption のメソッド
暗号化された文字列を復号するe。
defineInitializeTime(int, int, int) - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
バッチ初期化時間の設定。
definePath(String) - class jp.co.intra_mart.foundation.service.provider.HomeDirectory の static メソッド
推奨されていません。
del(String) - class jp.co.intra_mart.foundation.acssecurity.Logingp のメソッド
推奨されていません。 代替えメソッドはありません。
delAllAccount(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 AccountManager.deleteAccounts()に置き換えられました。
delAllLink(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
delAllMenu(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 MenuManager.deleteMenuItems()に置き換えられました。
delAllMessage(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
delAllRole(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 RoleManager.deleteRoles()に置き換えられました。
delAllSchedule(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 BatchManager.deleteBatches()に置き換えられました。
delData(String) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。
delData(String, boolean) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。
delData(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
delData(String, boolean) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
delete(String) - interface jp.co.intra_mart.foundation.datastore.application.domain.item.ItemCatalogueMediaManager のメソッド
商品カタログの媒体情報を削除します。
delete(CateogryClassBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
分類区分の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
分類区分の基本モデルを複数削除します。
delete(CategoryDetailBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
分類区分詳細の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
分類区分詳細の基本モデルを複数削除します。
delete(DepartmentAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
組織所属の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
組織所属の基本モデルを複数削除します。
delete(CompanyCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
会社組織分類の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
会社組織分類の基本モデルを複数削除します。
delete(CompanyBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
会社の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
会社の基本モデルを複数削除します。
delete(DepartmentBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
組織の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
組織の基本モデルを複数削除します。
delete(DepartmentInclusionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
組織内包の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
組織内包の基本モデルを複数削除します。
delete(DepartmentMainBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
主所属の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
主所属の基本モデルを複数削除します。
delete(CompanyPostBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
役職の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
役職の基本モデルを複数削除します。
delete(CompanyVersionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
会社構成バージョンの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
会社構成バージョンの基本モデルを複数削除します。
delete(DealBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper のメソッド
取扱の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper のメソッド
取扱の基本モデルを複数削除します。
delete(DealerDepartmentBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper のメソッド
組織毎取扱パーミッションの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper のメソッド
組織毎取扱パーミッションの基本モデルを複数削除します。
delete(DealDetailBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper のメソッド
取扱詳細の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper のメソッド
取扱詳細の基本モデルを複数削除します。
delete(DealerPublicGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper のメソッド
パブリックグループ毎取扱パーミッションの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper のメソッド
パブリックグループ毎取扱パーミッションの基本モデルを複数削除します。
delete(DealerRoleBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper のメソッド
ロール毎取扱パーミッションの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper のメソッド
ロール毎取扱パーミッションの基本モデルを複数削除します。
delete(ItemAttributeBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper のメソッド
商品属性の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper のメソッド
商品属性の基本モデルを複数削除します。
delete(ItemCatalogueBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper のメソッド
商品カタログの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper のメソッド
商品カタログの基本モデルを複数削除します。
delete(ItemBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper のメソッド
商品の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper のメソッド
商品の基本モデルを複数削除します。
delete(ItemAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper のメソッド
商品分類の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper のメソッド
商品分類の基本モデルを複数削除します。
delete(ItemCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper のメソッド
商品カテゴリの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper のメソッド
商品カテゴリの基本モデルを複数削除します。
delete(ItemCategoryTypeBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper のメソッド
商品カテゴリ種別の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper のメソッド
商品カテゴリ種別の基本モデルを複数削除します。
delete(ItemTemplateDetailBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper のメソッド
商品属性テンプレート明細の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper のメソッド
商品属性テンプレート明細の基本モデルを複数削除します。
delete(ItemTemplateBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper のメソッド
商品属性テンプレートの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper のメソッド
商品属性テンプレートの基本モデルを複数削除します。
delete(PrivateGroupAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライベートグループ所属の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライベートグループ所属の基本モデルを複数削除します。
delete(PrivateGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライベートグループの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライベートグループの基本モデルを複数削除します。
delete(PublicGroupAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
パブリックグループ所属の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
パブリックグループ所属の基本モデルを複数削除します。
delete(PublicGroupCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
パブリックグループ分類の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
パブリックグループ分類の基本モデルを複数削除します。
delete(PublicGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
パブリックグループの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
パブリックグループの基本モデルを複数削除します。
delete(PublicGroupInclusionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
パブリックグループ内包の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
パブリックグループ内包の基本モデルを複数削除します。
delete(PublicGroupSetBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
パブリックグループセットの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
パブリックグループセットの基本モデルを複数削除します。
delete(PublicGroupVersionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
パブリックグループ構成バージョンの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
パブリックグループ構成バージョンの基本モデルを複数削除します。
delete(UnitBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper のメソッド
単位の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper のメソッド
単位の基本モデルを複数削除します。
delete(UserBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
ユーザの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
ユーザの基本モデルを複数削除します。
delete(BaseModel) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
基本モデルを1つだけ削除します。
delete(Collection) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
アクセサを複数削除します。
delete(String, String) - class jp.co.intra_mart.foundation.update.StandardUpdateAccessor のメソッド
キーを削除します。
delete(String, String) - interface jp.co.intra_mart.foundation.update.UpdateAccessor のメソッド
キーを削除します。
delete(AccessControllerDepartmentBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper のメソッド
アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper のメソッド
アクセスコントローラの利用権限を保有する組織の基本モデルを複数削除します。
delete(AccessControllerBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper のメソッド
アクセスコントローラ情報の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper のメソッド
アクセスコントローラ情報の基本モデルを複数削除します。
delete(AccessControllerPostBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper のメソッド
アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper のメソッド
アクセスコントローラの利用権限を保有する役職の基本モデルを複数削除します。
delete(AccessControllerPublicGroupBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper のメソッド
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper のメソッド
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを複数削除します。
delete(AccessControllerRoleBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper のメソッド
アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper のメソッド
アクセスコントローラの利用権限を保有するロールの基本モデルを複数削除します。
delete(AccountAttributeBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper のメソッド
アカウントが保有する属性の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper のメソッド
アカウントが保有する属性の基本モデルを複数削除します。
delete(AccountBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccountMapper のメソッド
アカウントの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccountMapper のメソッド
アカウントの基本モデルを複数削除します。
delete(AccountRoleBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper のメソッド
アカウントが保有するロールの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper のメソッド
アカウントが保有するロールの基本モデルを複数削除します。
delete(BatchBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.BatchMapper のメソッド
バッチ情報の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.BatchMapper のメソッド
バッチ情報の基本モデルを複数削除します。
delete(CalendarInfoBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper のメソッド
カレンダーが保有するデータの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper のメソッド
カレンダーが保有するデータの基本モデルを複数削除します。
delete(FavoriteMenuBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper のメソッド
アカウントが保有するメニューの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper のメソッド
アカウントが保有するメニューの基本モデルを複数削除します。
delete(MenuArgumentBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper のメソッド
メニューの保有する引数の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper のメソッド
メニューの保有する引数の基本モデルを複数削除します。
delete(MenuDepartmentBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper のメソッド
メニューの利用権限を保有する組織の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper のメソッド
メニューの利用権限を保有する組織の基本モデルを複数削除します。
delete(MenuBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuMapper のメソッド
メニュー情報の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuMapper のメソッド
メニュー情報の基本モデルを複数削除します。
delete(MenuPostBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper のメソッド
メニューの利用権限を保有する役職の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper のメソッド
メニューの利用権限を保有する役職の基本モデルを複数削除します。
delete(MenuPublicGroupBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper のメソッド
メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper のメソッド
メニューの利用権限を保有するパブリックグループの基本モデルを複数削除します。
delete(MenuRoleBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper のメソッド
メニューの利用権限を保有するロールの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper のメソッド
メニューの利用権限を保有するロールの基本モデルを複数削除します。
delete(RoleInclusionBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper のメソッド
ロール内包の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper のメソッド
ロール内包の基本モデルを複数削除します。
delete(RoleBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.RoleMapper のメソッド
ロールの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.RoleMapper のメソッド
ロールの基本モデルを複数削除します。
delete(RoleSummaryBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper のメソッド
ロールサマリの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper のメソッド
ロールサマリの基本モデルを複数削除します。
deleteAccount(String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウント情報を削除する。
deleteAccount(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント情報を削除する。
deleteAccount(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントを削除します。
deleteAccountLicense(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
指定されたユーザのライセンスを削除します。
deleteAccountRole(String, String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウントロール情報を削除する。
deleteAccountRole(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントロール情報を削除する。
deleteAccountRole(String, String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントロールを削除します。
deleteAccountRoles(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントロールをすべて削除します。
deleteAccounts() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントをすべて削除します。
deleteAll(String) - class jp.co.intra_mart.foundation.update.StandardUpdateAccessor のメソッド
すべてのキーを削除します。
deleteAll(String) - interface jp.co.intra_mart.foundation.update.UpdateAccessor のメソッド
すべてのキーを削除します。
deleteApplicationLicenseFromAccount(String, String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
アプリケーションライセンスをアカウントから削除します。
deleteAttribute(String, String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウント属性情報を削除する。
deleteAttribute(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント属性情報を削除する。
deleteAttribute(String, String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウント属性情報を削除する。
deleteBatch(String, String) - class jp.co.intra_mart.foundation.security.StandardBatchAccessor のメソッド
バッチを削除します。
deleteBatch(String, String) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
バッチ情報を削除します。
deleteBatch(String) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチ情報を削除します。
deleteBatches() - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
すべてのバッチ情報を削除します。
deleteCalendar(String, String) - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor のメソッド
カレンダーを削除します。
deleteCalendar(String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
カレンダーを削除します。
deleteCalendar(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーを削除します。
deleteCalendarInfo(String, String, String) - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor のメソッド
指定されたカレンダーデータを削除します。
deleteCalendarInfo(String, String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
指定されたカレンダーデータを削除します。
deleteCalendarInfo(String, String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータを削除します。
deleteCalendarInfos(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
すべてのカレンダーデータを削除します。
deleteCalendars() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
すべてのカレンダーを削除します。
deleteCatalogue(ItemCatalogue) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
商品カタログ情報を削除します。
deleteCategories() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
すべてのカテゴリーを削除します。
deleteCategory(ItemCategory) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のメソッド
商品カテゴリを削除します。
deleteCategory(String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
すべてのカテゴリを削除します。
deleteCategory(String, String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
カテゴリを削除します。
deleteCategory(String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
すべてのカテゴリを削除する。
deleteCategory(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
カテゴリを削除する。
deleteCategory(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
カテゴリーを削除します。
deleteCategoryDetail(CategoryDetail) - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のメソッド
登録済の分類区分詳細を削除します。
deleteChild(String) - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
子メニューを削除します。
deleteCompany(Company) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の会社を削除します。
deleteController(String, String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラを削除します。
deleteController(String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラを削除します。
deleteController(String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
アクセスコントローラを削除します。
deleteControllerDepartment(String, String, DepartmentInfo) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラ組織を削除します。
deleteControllerDepartment(String, String, DepartmentInfo) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラ組織を削除します。
deleteControllerDepartment(String, DepartmentInfo) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
組織の紐付けをアクセスコントローラから削除します。
deleteControllerDepartments(String, String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
すべてのアクセスコントローラ組織を削除します。
deleteControllerDepartments(String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
すべてのアクセスコントローラ組織を削除します。
deleteControllerDepartments(String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
組織の紐付けをアクセスコントローラからすべて削除します。
deleteControllerPost(String, String, PostInfo) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラ役職を削除します。
deleteControllerPost(String, String, PostInfo) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラ役職を削除します。
deleteControllerPost(String, PostInfo) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
役織の紐付けをアクセスコントローラから削除します。
deleteControllerPosts(String, String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
すべてのアクセスコントローラ役職を削除します。
deleteControllerPosts(String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
すべてのアクセスコントローラ役職を削除します。
deleteControllerPosts(String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
役織の紐付けをアクセスコントローラからすべて削除します。
deleteControllerPublicGroup(String, String, PublicGroupInfo) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラパブリックグループを削除します。
deleteControllerPublicGroup(String, String, PublicGroupInfo) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラパブリックグループを削除します。
deleteControllerPublicGroup(String, PublicGroupInfo) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
パブリックグループの紐付けをアクセスコントローラから削除します。
deleteControllerPublicGroups(String, String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
すべてのアクセスコントローラパブリックグループを削除します。
deleteControllerPublicGroups(String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
すべてのアクセスコントローラパブリックグループを削除します。
deleteControllerPublicGroups(String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
パブリックグループの紐付けをアクセスコントローラからすべて削除します。
deleteControllerRole(String, String, String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラロールを削除します。
deleteControllerRole(String, String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラロールを削除します。
deleteControllerRole(String, String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
ロールの紐付けをアクセスコントローラから削除します。
deleteControllerRoles(String, String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
すべてのアクセスコントローラロールを削除します。
deleteControllerRoles(String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
すべてのアクセスコントローラロールを削除します。
deleteControllerRoles(String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
ロールの紐付けをアクセスコントローラから削除します。
deleteControllers() - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
すべてのアクセスコントローラを削除します。
deleteDeal(Deal) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
取扱情報を削除します。
deleteDepartment(Department) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の組織情報を削除します。
deleteEventFlow(EventNavigatorManager, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
イベントフローの削除 イベントフローIDから、イベントフローを削除する。
deleteEventFlow(String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
イベントフローの削除 イベントフローIDから、イベントフローを削除する。
deleteEventFlow(EventNavigatorManager, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
イベントフローの削除 イベントフローIDから、イベントフローを削除する。
deleteFavoriteMenu(String, String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
マイメニュー情報を削除する。
deleteFavoriteMenu(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
マイメニュー情報を削除する。
deleteFavoriteMenu(String, String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
マイメニューを削除します。
deleteFavoriteMenus(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
マイメニューをすべて削除します。
deleteGroupImageIcons() - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
グループのイメージアイコン情報をすべて削除します。
deleteGroupSet(PublicGroupSet) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループセットを削除します。
deleteImageIcon(String) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
イメージアイコン情報を削除します。
deleteItem(Item) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
商品情報を削除します。
deleteLoginGroup(String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
ログイングループを削除します。
deleteLoginGroup(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループを削除します。
deleteMainPagePattern(String, String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
メインページパターンを削除します。
deleteMainPagePattern(String, String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンを削除します。
deleteMainPagePatterns(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンをすべて削除します。
deleteMember(DepartmentAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織から人員をはずします。
deleteMember(PrivateGroupAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
プライベートグループから人員をはずします。
deleteMember(PublicGroupAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループから人員をはずします。
deleteMenuDepartment(String, String, DepartmentInfo) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
メニュー組織を削除します。
deleteMenuDepartment(String, String, DepartmentInfo) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニュー組織を削除します。
deleteMenuDepartment(String, DepartmentInfo) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
組織の紐付けをメニューから削除します。
deleteMenuDepartments(String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
すべてのメニュー組織を削除します。
deleteMenuDepartments(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニュー組織を削除します。
deleteMenuDepartments(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
組織の紐付けをメニューからすべて削除します。
deleteMenuInclusion(String, MenuInclusion) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
メニュー構成を削除します。
deleteMenuInclusion(MenuInclusion) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
メニュー構成を削除します。
deleteMenuInclusion(String, MenuInclusion) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニュー構成を削除します。
deleteMenuItem(String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
引数で渡されたノードを削除します。
deleteMenuItem(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
引数で渡されたノードを削除します。
deleteMenuItem(String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニューを削除します。
deleteMenuItem(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
引数で渡されたノードを削除します。
deleteMenuItem(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューを削除します。
deleteMenuItems() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
すべてのメニューを削除します。
deleteMenuItems() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
すべてのメニューを削除します。
deleteMenuLoginGroup(String, String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
管理メニューに設定されているアクセス権を削除します。
deleteMenuLoginGroup(String, String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
指定したログイングループのアクセス権をメニューから削除します。
deleteMenuPost(String, String, PostInfo) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
メニュー役職を削除します。
deleteMenuPost(String, String, PostInfo) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニュー役職を削除します。
deleteMenuPost(String, PostInfo) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
役織の紐付けをメニューから削除します。
deleteMenuPosts(String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
すべてのメニュー役職を削除します。
deleteMenuPosts(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニュー役職を削除します。
deleteMenuPosts(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
役織の紐付けをメニューからすべて削除します。
deleteMenuPublicGroup(String, String, PublicGroupInfo) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
メニューパブリックグループを削除します。
deleteMenuPublicGroup(String, String, PublicGroupInfo) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニューパブリックグループを削除します。
deleteMenuPublicGroup(String, PublicGroupInfo) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
パブリックグループの紐付けをメニューから削除します。
deleteMenuPublicGroups(String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
すべてのメニューパブリックグループを削除します。
deleteMenuPublicGroups(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニューパブリックグループを削除します。
deleteMenuPublicGroups(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
パブリックグループの紐付けをメニューからすべて削除します。
deleteMenuRole(String, String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
メニューロールを削除します。
deleteMenuRole(String, String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニューロールを削除します。
deleteMenuRole(String, String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
ロールの紐付けをメニューから削除します。
deleteMenuRoles(String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
すべてのメニューロールを削除します。
deleteMenuRoles(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニューロールを削除します。
deleteMenuRoles(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
ロールの紐付けをメニューから削除します。
deletePortlet(Portlet) - class jp.co.intra_mart.foundation.portal.portlet.PortletManager のメソッド
ポートレット情報を削除します。
deletePost(CompanyPost) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の役職情報を削除します。
deletePrivateGroup(PrivateGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
登録済のプライベートグループ情報を削除します。
deletePublicGroup(PublicGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループ情報を削除します。
deleteRole(String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
すべてのロール情報を削除します。
deleteRole(String, String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
ロール情報を削除します。
deleteRole(String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
すべてのロール情報を削除する。
deleteRole(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
ロール情報を削除する。
deleteRole(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロールを削除します。
deleteRoles() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
すべてのロールを削除します。
deleteSaveResultHistory(EventNavigatorManager, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。
deleteSaveResultHistory(String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。
deleteSaveResultHistory(EventNavigatorManager, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
保存ナビゲート結果情報の削除（履歴） 最大件数以上を削除する。
deleteShortCut(String, String) - interface jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor のメソッド
ショートカットIDを削除します。
deleteShortCut(String) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutManager のメソッド
ショートカットＩＤ削除。
deleteShortCut(String, String) - class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor のメソッド
ショートカットIDを削除します。
deleteSubRole(String, String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
サブロールIDを削除します。
deleteSubRole(String, String, String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
指定したサブロールIDを削除します。
deleteSubRole(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
サブロールIDサマリを削除する。
deleteSubRole(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
指定したロールのサブロールIDサマリを全削除する。
deleteSubRole(String, String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
指定したサブロールIDを削除します。
deleteSubRoles(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
全てのサブロールIDを削除します。
deleteSuperUser(String) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor のメソッド
グループ管理者情報を削除します。
deleteSuperUser(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
グループ管理者情報を削除します。
deleteTemplate(ItemTemplate) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager のメソッド
商品属性テンプレート情報を削除します。
deleteTemplateDetail(ItemTemplateDetail) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager のメソッド
商品属性テンプレート明細情報を削除します。
deleteUnit(String) - class jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager のメソッド
単位を削除します。
deleteUser(User) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager のメソッド
登録済のユーザを削除します。
deleteUserImageIcons(String) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
ユーザのイメージアイコン情報をすべて削除します。
deleteVersion(CompanyVersion) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の会社構成バージョンを削除します。
deleteVersion(PublicGroupVersion) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループセット構成バージョンを削除します。
departmentAdded(String, Department) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織情報がデータストアに登録された後に呼び出されます。
departmentAdded(String, Department) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
組織情報がデータストアに登録された後に呼び出されます。
departmentAdded(String, Department) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織情報がデータストアに登録された後に呼び出されます。
departmentDeleted(String, Department) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織情報がデータストアに更新された後に呼び出されます。
departmentDeleted(String, Department) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
組織情報がデータストアに更新された後に呼び出されます。
departmentDeleted(String, Department) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織情報がデータストアに更新された後に呼び出されます。
departmentJoined(String, String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織構成がデータストアに登録された後に呼び出されます。
departmentJoined(String, String, String, String, String) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
組織構成がデータストアに登録された後に呼び出されます。
departmentJoined(String, String, String, String, String) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織構成がデータストアに登録された後に呼び出されます。
departmentLeft(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
departmentLeft(String, String, String, String) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
departmentLeft(String, String, String, String) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
departmentMoved(String, String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
departmentMoved(String, String, String, String, String) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
departmentMoved(String, String, String, String, String) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
departmentUpdated(String, Department) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織情報がデータストアから削除された後に呼び出されます。
departmentUpdated(String, Department) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
組織情報がデータストアから削除された後に呼び出されます。
departmentUpdated(String, Department) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織情報がデータストアから削除された後に呼び出されます。
destory(String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
アクティブなセッション情報をすべて破棄します。
destory(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
アクティブなセッション情報をすべて破棄します。
destory(String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
アクティブなセッション情報をすべて破棄します。
destroy() - class jp.co.intra_mart.foundation.security.filter.SessionFilter のメソッド
破棄します。
destroy() - class jp.co.intra_mart.foundation.security.filter.URLAccessFilter のメソッド
破棄します。
destroy() - class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet のメソッド
サーブレットの放棄を行います。
destroy() - class jp.co.intra_mart.foundation.security.servlet.LogoutServlet のメソッド
サーブレットの放棄を行います。
destroy() - class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet のメソッド
サーブレットの放棄を行います。
destroy() - class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet のメソッド
サーブレットの放棄を行います。
destroy() - class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet のメソッド
サーブレットの放棄を行います。
destroy(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
グループデータを削除します。
destroy(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
グループデータを削除します。
destroy(String) - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
id によりアクセスできるセッションデータを破棄します。
destroy() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
このメソッドは、現在のセッションを破棄してしまいます。
destroy(String) - interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory のメソッド
グループデータを削除します。
destroy() - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 このイベントコントローラの破棄処理を行います。
destroy() - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor のメソッド
推奨されていません。 このプールを破棄します。
destroy() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 このプールを破棄します。
directories() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ディレクトリ中のサブディレクトリの一覧を取得します。
discontinue() - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 現在実行中のエクスポート処理を中止します。
distinctNavigator(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたユーザエージェント情報から判別してナビゲータ情報を取得します。
doCertification(int, LoginInfo, SuperUser, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.activesession.GroupActiveSessionRegister のメソッド
管理者の認証後にコールされるメソッドです。
doCertification(int, LoginInfo, Account, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.activesession.UserActiveSessionRegister のメソッド
ユーザの認証後にコールされるメソッドです。
doCertification(int, LoginInfo, SuperUser, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.SuperCertificationListener のメソッド
管理者の認証後にコールされるメソッドです。
doCertification(int, LoginInfo, Account, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.UserCertificationListener のメソッド
ユーザの認証後にコールされるメソッドです。
doChain() - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain のメソッド
チェーン内の次のフィルタまたはイベントを デフォルトのリクエストとレスポンスを利用して呼び出します。
doChain(HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain のメソッド
チェーン内の次のフィルタまたはイベントを 指定のリクエストとレスポンスを利用して呼び出します。
doDecoration(EventNavigatorManager, Object) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorReaderDecorator のメソッド
イベントナビゲータのオブジェクト情報をデータストアからの読み込み直後にコールされます。
doDecoration(String, AccessController) - interface jp.co.intra_mart.foundation.security.access.AccessControllerReaderDecorator のメソッド
アクセスコントローラデータストアからの読み込み直後にコールされます。
doDecoration(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountReaderDecorator のメソッド
アカウントをデータストアからの読み込み直後にコールされます。
doDecoration(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator のメソッド
システム管理者情報をデータストアからの読み込み直後にコールされます。
doDecoration(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator のメソッド
バッチをデータストアからの読み込み直後にコールされます。
doDecoration(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator のメソッド
カレンダーデータをデータストアからの読み込み直後にコールされます。
doDecoration(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator のメソッド
アカウントをデータストアからの読み込み直後にコールされます。
doDecoration(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator のメソッド
ログイングループをデータストアからの読み込み直後にコールされます。
doDecoration(MenuItem) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator のメソッド
メニューデータストアからの読み込み直後にコールされます。
doDecoration(String, MenuItem) - interface jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator のメソッド
メニューデータストアからの読み込み直後にコールされます。
doDecoration(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleReaderDecorator のメソッド
ロール情報をデータストアから読み込んだ直後にコールされます。
doExport(EventNavigatorManager, OutputStream, boolean) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorExporter のメソッド
エクスポートを行います。
doExport(EventNavigatorManager, OutputStream, boolean) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter のメソッド
エクスポートを行います。
doExport(AccessControllerManager, OutputStream) - interface jp.co.intra_mart.foundation.security.access.AccessControllerExporter のメソッド
エクスポートを行います。
doExport(AccessControllerManager, OutputStream) - class jp.co.intra_mart.foundation.security.access.StandardAccessControllerBackup のメソッド

doExport(AccountManager, OutputStream) - interface jp.co.intra_mart.foundation.security.account.AccountExporter のメソッド
エクスポートを行います。
doExport(AccountManager, OutputStream) - class jp.co.intra_mart.foundation.security.account.CsvAccountBackup のメソッド
エクスポートを行います。
doExport(AccountManager, OutputStream) - class jp.co.intra_mart.foundation.security.account.StandardAccountBackup のメソッド
エクスポートを行います。
doExport(BatchManager, OutputStream) - interface jp.co.intra_mart.foundation.security.batch.BatchExporter のメソッド
エクスポートを行います。
doExport(BatchManager, OutputStream) - class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup のメソッド
エクスポートを行います。
doExport(CalendarManager, OutputStream) - interface jp.co.intra_mart.foundation.security.calendar.CalendarExporter のメソッド
エクスポートを行います。
doExport(CalendarManager, OutputStream) - class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup のメソッド
エクスポートを行います。
doExport(AdminMenuManager, OutputStream) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuExporter のメソッド
エクスポートを行います。
doExport(MenuManager, OutputStream) - interface jp.co.intra_mart.foundation.security.menu.MenuExporter のメソッド
エクスポートを行います。
doExport(AdminMenuManager, OutputStream) - class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup のメソッド
エクスポートを行います。
doExport(MenuManager, OutputStream) - class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup のメソッド
エクスポートを行います。
doExport(RoleManager, OutputStream) - interface jp.co.intra_mart.foundation.security.role.RoleExporter のメソッド
エクスポートを行います。
doExport(RoleManager, OutputStream) - class jp.co.intra_mart.foundation.security.role.StandardRoleBackup のメソッド
エクスポートを行います。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.foundation.security.filter.ActiveSessionFilter のメソッド
フィルタを実行します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.foundation.security.filter.DuplicateLoginHandlingFilter のメソッド
フィルタを実行します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter のメソッド
フィルタを実行します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter のメソッド
リクエストの文字エンコードをアクセスセキュリティ情報を基にエンコーディングを設定して、 次のフィルタチェーンを実行します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter のメソッド
レスポンスソースの文字エンコードをアクセスセキュリティ情報を基にして 自動解決する HttpServletResponse を作成して、 次のフィルタチェーンを実行します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.foundation.security.filter.SessionFilter のメソッド
フィルタを実行します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.foundation.security.filter.URLAccessFilter のメソッド
フィルタを実行します。
doFilter(HTTPActionEventContext, HttpServletRequest, HttpServletResponse, FilterHTTPActionEventChain) - class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent のメソッド
イベントのフィルタ処理です。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet のメソッド
GETメソッドに対するサービスを行います。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.LogoutServlet のメソッド
GETメソッドに対するサービスを行います。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.MenuServlet のメソッド
GETメソッドです。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet のメソッド
GETメソッドに対するサービスを行います。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet のメソッド
GETメソッドに対するサービスを行います。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet のメソッド
GETメソッドに対するサービスを行います。
doImport(InputStream, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.item.ItemImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.StandardItemImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemAttachImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemAttachImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemCategoryImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.StandardItemTemplateImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter のメソッド
インポートを行います。
doImport(EventNavigatorManager, InputStream) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorImporter のメソッド
インポートを行います。
doImport(EventNavigatorManager, InputStream) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter のメソッド
インポートを行います。
doImport(String) - interface jp.co.intra_mart.foundation.security.ExtendsImport のメソッド
拡張インポート処理を行います。
doImport(String, String) - class jp.co.intra_mart.foundation.security.ExtendsImportManager のメソッド
拡張インポート処理を実行します。
doImport(InputStream, AccessControllerManager) - interface jp.co.intra_mart.foundation.security.access.AccessControllerImporter のメソッド
インポートを行います。
doImport(InputStream, AccessControllerManager) - class jp.co.intra_mart.foundation.security.access.StandardAccessControllerBackup のメソッド

doImport(InputStream, AccountManager) - interface jp.co.intra_mart.foundation.security.account.AccountImporter のメソッド
インポートを行います。
doImport(InputStream, AccountManager) - class jp.co.intra_mart.foundation.security.account.CsvAccountBackup のメソッド
インポートを行います。
doImport(InputStream, AccountManager) - class jp.co.intra_mart.foundation.security.account.StandardAccountBackup のメソッド
インポートを行います。
doImport(InputStream, BatchManager) - interface jp.co.intra_mart.foundation.security.batch.BatchImporter のメソッド
インポートを行います。
doImport(InputStream, BatchManager) - class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup のメソッド
インポートを行います。
doImport(InputStream, CalendarManager) - interface jp.co.intra_mart.foundation.security.calendar.CalendarImporter のメソッド
インポートを行います。
doImport(InputStream, CalendarManager) - class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup のメソッド
インポートを行います。
doImport(InputStream, AdminMenuManager) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuImporter のメソッド
インポートを行います。
doImport(InputStream, MenuManager) - interface jp.co.intra_mart.foundation.security.menu.MenuImporter のメソッド
インポートを行います。
doImport(InputStream, AdminMenuManager) - class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup のメソッド
インポートを行います。
doImport(InputStream, MenuManager) - class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup のメソッド
インポートを行います。
doImport(InputStream, RoleManager) - interface jp.co.intra_mart.foundation.security.role.RoleImporter のメソッド
インポートを行います。
doImport(InputStream, RoleManager) - class jp.co.intra_mart.foundation.security.role.StandardRoleBackup のメソッド
インポートを行います。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet のメソッド
POSTメソッドに対するサービスを行います。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.LogoutServlet のメソッド
POSTメソッドに対するサービスを行います。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.MenuServlet のメソッド
POSTメソッドです。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet のメソッド
POSTメソッドに対するサービスを行います。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet のメソッド
POSTメソッドに対するサービスを行います。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet のメソッド
POSTメソッドに対するサービスを行います。
doSelection(String, String[]) - class jp.co.intra_mart.foundation.navigator.EventNavigatorPermissionSelector のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doSelection(String, String[]) - class jp.co.intra_mart.foundation.security.permission.AccessControllerPermissionSelector のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doSelection(String, String[]) - class jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doSelection(String, String[]) - class jp.co.intra_mart.foundation.security.permission.AdminMenuPermissionSelector のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doSelection(String, String[]) - class jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doSelection(String, String[]) - class jp.co.intra_mart.foundation.security.permission.PermissionManager のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doSelection(String, String) - class jp.co.intra_mart.foundation.security.permission.PermissionManager のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doSelection(String, String[]) - interface jp.co.intra_mart.foundation.security.permission.PermissionSelector のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doubleValue() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値の数値表現を取得します。
doubleValue() - class jp.co.intra_mart.foundation.utility.Counter のメソッド
推奨されていません。 カウンターの現在の値を double 型として返します。
downloadCSV(String, String, int, int, String, boolean, boolean) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 CSVファイルをダウンロードします。
downloadCSV(PreparedStatement, String, boolean) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 CSVファイルをダウンロードします。
downloadCSV(PreparedStatement, String, int, int, boolean) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 CSVファイルをダウンロードします。

E

EMAIL_ADDRESS1 - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
メールアドレス1
EMAIL_ADDRESS1 - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
メールアドレス１
EMAIL_ADDRESS2 - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
メールアドレス2
EMAIL_ADDRESS2 - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
メールアドレス２
ENCODING - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
エンコーディング
END_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
終了日
END_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
終了日
ENTITY_CONTROLLER_DEPARTMENT_NAME - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor の static 変数

ENTITY_CONTROLLER_NAME - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor の static 変数
エンティティ名
ENTITY_CONTROLLER_POST_NAME - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor の static 変数

ENTITY_CONTROLLER_PUBLIC_GROUP_NAME - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor の static 変数

ENTITY_CONTROLLER_ROLE_NAME - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor の static 変数

ENTITY_NAME - class jp.co.intra_mart.foundation.security.StandardBatchAccessor の static 変数
エンティティ名
ENTITY_NAME - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor の static 変数
エンティティ名
ENTITY_NAME_ACCOUNT - class jp.co.intra_mart.foundation.security.StandardAccountAccessor の static 変数
エンティティ名
ENTITY_NAME_ACCOUNT_ATTRIBUTE - class jp.co.intra_mart.foundation.security.StandardAccountAccessor の static 変数

ENTITY_NAME_ACCOUNT_ROLE - class jp.co.intra_mart.foundation.security.StandardAccountAccessor の static 変数

ENTITY_NAME_FAVORITE_MENU - class jp.co.intra_mart.foundation.security.StandardAccountAccessor の static 変数

ENTITY_NAME_MENU - class jp.co.intra_mart.foundation.security.StandardMenuAccessor の static 変数
メニュー エンティティ名
ENTITY_NAME_MENU_ARGUMENT - class jp.co.intra_mart.foundation.security.StandardMenuAccessor の static 変数
メニュー引数 エンティティ名
ENTITY_NAME_MENU_DEPARTMENT - class jp.co.intra_mart.foundation.security.StandardMenuAccessor の static 変数
メニュー組織 エンティティ名
ENTITY_NAME_MENU_POST - class jp.co.intra_mart.foundation.security.StandardMenuAccessor の static 変数
メニュー役職 エンティティ名
ENTITY_NAME_MENU_PUBLIC_GROUP - class jp.co.intra_mart.foundation.security.StandardMenuAccessor の static 変数
メニューパブリックグループ エンティティ名
ENTITY_NAME_MENU_ROLE - class jp.co.intra_mart.foundation.security.StandardMenuAccessor の static 変数
メニューロール エンティティ名
ENTITY_NAME_ROLE - class jp.co.intra_mart.foundation.security.StandardRoleAccessor の static 変数

ENTITY_NAME_ROLE_INCLUSION - class jp.co.intra_mart.foundation.security.StandardRoleAccessor の static 変数

ENTITY_NAME_ROLE_SUMMARY - class jp.co.intra_mart.foundation.security.StandardRoleAccessor の static 変数

ESCAPE_LEFT_PARENTHESIS - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ESCAPE_PERCENTAGE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ESCAPE_RIGHT_PARENTHESIS - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ESCAPE_STRING - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
エスケープ文字
ESCAPE_UNDER_SCORE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

EVENT_NAVIGATOR_PERMISSION_SELECTOR - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
アクセス権限チェッククラス取得用キー
EXCEPTION - class jp.co.intra_mart.foundation.datastore.common.config.DeleteType の static 変数
例外 例外を発生させます。
EXCEPTION - class jp.co.intra_mart.foundation.datastore.common.config.LifetimeType の static 変数
例外 例外を発生させます。
EXTENSION_FAX_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
内線FAX番号
EXTENSION_FAX_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
内線FAX番号
EXTENSION_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
内線番号
EXTENSION_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
内線番号
EnCodeInterface - interface jp.co.intra_mart.foundation.portal.common.encode.EnCodeInterface.
簡易SSOのパスワードを暗号化するインタフェース。
Entity - interface jp.co.intra_mart.foundation.datastore.common.config.Entity.
エンティティを定義します。
Environment - interface jp.co.intra_mart.foundation.service.provider.Environment.
このクラスは、 システムプロパティへアクセスするためのインターフェースです。
ErrorEvent - class jp.co.intra_mart.foundation.utility.ErrorEvent.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEvent クラスを使用してください。
ErrorEvent(Throwable, Object) - class jp.co.intra_mart.foundation.utility.ErrorEvent のコンストラクタ
推奨されていません。 エラーを通知するためのイベントを構築します。
ErrorEvent(Throwable, String, Object) - class jp.co.intra_mart.foundation.utility.ErrorEvent のコンストラクタ
推奨されていません。 エラーを通知するためのイベントを構築します。
ErrorEventListener - interface jp.co.intra_mart.foundation.utility.ErrorEventListener.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener クラスを使用してください。
ErrorPageProvider - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider.
エラーページプロバイダインタフェース。
EventAccessInfo - class jp.co.intra_mart.foundation.navigator.EventAccessInfo.
アクセス権情報
EventAccessInfo() - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のコンストラクタ

EventFlow - class jp.co.intra_mart.foundation.navigator.EventFlow.
イベントフロークラス
EventFlow() - class jp.co.intra_mart.foundation.navigator.EventFlow のコンストラクタ

EventFlowInfo - class jp.co.intra_mart.foundation.navigator.EventFlowInfo.
イベントフロー情報
EventFlowInfo() - class jp.co.intra_mart.foundation.navigator.EventFlowInfo のコンストラクタ

EventHistoryInfo - class jp.co.intra_mart.foundation.navigator.EventHistoryInfo.
イベント履歴情報
EventHistoryInfo() - class jp.co.intra_mart.foundation.navigator.EventHistoryInfo のコンストラクタ

EventItem - class jp.co.intra_mart.foundation.navigator.EventItem.
イベントアイテムクラス
EventItem() - class jp.co.intra_mart.foundation.navigator.EventItem のコンストラクタ

EventItemInfo - class jp.co.intra_mart.foundation.navigator.EventItemInfo.
イベントアイテム情報
EventItemInfo() - class jp.co.intra_mart.foundation.navigator.EventItemInfo のコンストラクタ

EventListener - interface jp.co.intra_mart.foundation.utility.EventListener.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventListener クラスを使用してください。
EventNavigatorAccessor - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor.
イベントナビゲーター管理アクセッサインタフェース。
EventNavigatorConst - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst.
イベントナビゲーターで使用する定数の一覧
EventNavigatorConst() - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst のコンストラクタ

EventNavigatorException - exception jp.co.intra_mart.foundation.navigator.EventNavigatorException.
イベントナビゲータマネージャに関する例外クラス

EventNavigatorException() - class jp.co.intra_mart.foundation.navigator.EventNavigatorException のコンストラクタ
コンストラクタ
EventNavigatorException(String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorException のコンストラクタ
コンストラクタ
EventNavigatorException(Throwable) - class jp.co.intra_mart.foundation.navigator.EventNavigatorException のコンストラクタ
コンストラクタ
EventNavigatorException(String, Throwable) - class jp.co.intra_mart.foundation.navigator.EventNavigatorException のコンストラクタ
コンストラクタ
EventNavigatorExporter - interface jp.co.intra_mart.foundation.navigator.EventNavigatorExporter.
イベントナビゲータバックアップインタフェースです。
EventNavigatorHandler - class jp.co.intra_mart.foundation.navigator.EventNavigatorHandler.

EventNavigatorHandler() - class jp.co.intra_mart.foundation.navigator.EventNavigatorHandler のコンストラクタ

EventNavigatorImporter - interface jp.co.intra_mart.foundation.navigator.EventNavigatorImporter.
イベントナビゲータバックアップインタフェースです。
EventNavigatorManager - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager.
イベントナビゲーター管理マネージャクラス。
EventNavigatorManager(String, String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のコンストラクタ
コンストラクタ。
EventNavigatorPermissionSelector - class jp.co.intra_mart.foundation.navigator.EventNavigatorPermissionSelector.
ユーザIDから有効なID一覧を取得するセレクタ。
EventNavigatorPermissionSelector() - class jp.co.intra_mart.foundation.navigator.EventNavigatorPermissionSelector のコンストラクタ
コンストラクタ。
EventNavigatorReaderDecorator - interface jp.co.intra_mart.foundation.navigator.EventNavigatorReaderDecorator.

EventQueueController - class jp.co.intra_mart.foundation.utility.EventQueueController.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventQueueController クラスを使用してください。
EventQueueController() - class jp.co.intra_mart.foundation.utility.EventQueueController のコンストラクタ
推奨されていません。 イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
EventQueueController(long) - class jp.co.intra_mart.foundation.utility.EventQueueController のコンストラクタ
推奨されていません。 イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
EventResultItem - class jp.co.intra_mart.foundation.navigator.EventResultItem.
ナビゲート結果クラス
EventResultItem() - class jp.co.intra_mart.foundation.navigator.EventResultItem のコンストラクタ

EventResultItemInfo - class jp.co.intra_mart.foundation.navigator.EventResultItemInfo.
ナビゲート結果情報
EventResultItemInfo() - class jp.co.intra_mart.foundation.navigator.EventResultItemInfo のコンストラクタ

EventScript - class jp.co.intra_mart.foundation.page.EventScript.
ブラウザでスクリプトの各変数に対する変更イベントを実装するための スクリプトコードを提供します。
EventScript(String) - class jp.co.intra_mart.foundation.page.EventScript のコンストラクタ
イベントスクリプトを作成するためのインスタンスを構築します。
EverydayConditioner - class jp.co.intra_mart.foundation.utility.report.EverydayConditioner.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner クラスを使用してください。
EverydayConditioner(int, int, TimeZone) - class jp.co.intra_mart.foundation.utility.report.EverydayConditioner のコンストラクタ
推奨されていません。 毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
EverydayConditioner(int, int) - class jp.co.intra_mart.foundation.utility.report.EverydayConditioner のコンストラクタ
推奨されていません。 毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
ExpirationKey - interface jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey.
ライフタイム期間の有効終了日時を定義します。
ExportConfigurationReader - interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader.
エクスポート設定情報の読込みを行います。
ExportConfigurationReaderException - exception jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReaderException.
エクスポート設定の読み込みでエラーが発生したことを示すためにスローされます。
ExportConfigurationReaderException(String) - class jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReaderException のコンストラクタ
コンストラクタ
ExportConfigurationReaderException(Throwable) - class jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReaderException のコンストラクタ
コンストラクタ
ExportConfigurationReaderException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReaderException のコンストラクタ
コンストラクタ
ExportInitializeException - exception jp.co.intra_mart.foundation.datastore.exporter.ExportInitializeException.
エクスポートの初期化でエラーが発生したことを示すためにスローされます。
ExportInitializeException(String) - class jp.co.intra_mart.foundation.datastore.exporter.ExportInitializeException のコンストラクタ
コンストラクタ
ExportInitializeException(Throwable) - class jp.co.intra_mart.foundation.datastore.exporter.ExportInitializeException のコンストラクタ
コンストラクタ
ExportInitializeException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exporter.ExportInitializeException のコンストラクタ
コンストラクタ
ExportManager - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager.
エクスポートを行います。
ExportManagerClient - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient.
エクスポートマネージャーの呼び出しを行うクライアントです。
ExportManagerImpl - class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl.
エクスポートマネージャーの汎用的な実装です。
ExportManagerImpl(String) - class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl のコンストラクタ
コンストラクタ
ExtendedBaseAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor.
拡張基本エンティティに対する情報操作用のインタフェースです。
ExtendedBaseAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap.
拡張基本アクセサのマッピング情報を持ちます。
ExtendedBaseModel - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseModel.
拡張基本モデルを定義します。
ExtendedBaseModel - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel.
拡張基本モデルの情報です。
ExtendedBaseModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap.
拡張基本モデルのマッピング情報を持ちます。
ExtendedBaseTable - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable.
拡張基本テーブルを定義します。
ExtendedDirectory - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。
ExtendedDirectory(String, int) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のコンストラクタ
推奨されていません。 File オブジェクトを作成するためのファクトリオブジェクトを作成します。
ExtendedDirectory(File, String, int) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のコンストラクタ
推奨されていません。 File オブジェクトを作成するためのファクトリオブジェクトを作成します。
ExtendedEntity - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity.
拡張エンティティを定義します。
ExtendedFile - class jp.co.intra_mart.foundation.utility.file.ExtendedFile.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile クラスを使用してください。
ExtendedFile(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のコンストラクタ
推奨されていません。 指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
ExtendedFile(File, String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のコンストラクタ
推奨されていません。 親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
ExtendedFile(String, String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のコンストラクタ
推奨されていません。 親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
ExtendedGenericBaseModel - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel.
拡張基本モデルの汎用的な抽象クラスです。
ExtendedGenericBaseModel() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel のコンストラクタ

ExtendedGenericBaseModelMap - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap.
拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。
ExtendedGenericBaseModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap のコンストラクタ

ExtendedGenericInternationalModel - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel.
拡張国際化モデルの汎用的な抽象クラスです。
ExtendedGenericInternationalModel() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel のコンストラクタ

ExtendedGenericInternationalModelMap - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap.
拡張国際化モデルのマッピング情報を持つ汎用的な抽象クラスです。
ExtendedGenericInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap のコンストラクタ

ExtendedGenericTerminableInternationalModel - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel.
拡張期間国際化モデルの汎用的な抽象クラスです。
ExtendedGenericTerminableInternationalModel() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel のコンストラクタ

ExtendedGenericTerminableInternationalModelMap - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap.
拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。
ExtendedGenericTerminableInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap のコンストラクタ

ExtendedGenericTerminableModel - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel.
拡張期間化モデルの汎用的な抽象クラスです。
ExtendedGenericTerminableModel() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel のコンストラクタ

ExtendedGenericTerminableModelMap - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap.
拡張期間化モデルのマッピング情報を持つ汎用的な抽象クラスです。
ExtendedGenericTerminableModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap のコンストラクタ

ExtendedInputStream - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream クラスを使用してください。
ExtendedInputStream(InputStream) - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のコンストラクタ
推奨されていません。 入力ストリームを構築します。
ExtendedInputStream(InputStream, ErrorEventListener) - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のコンストラクタ
推奨されていません。 入力ストリームを構築します。
ExtendedInternationalAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor.
拡張国際化エンティティに対する情報操作用のインタフェースです。
ExtendedInternationalAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap.
拡張国際アクセサのマッピング情報を持ちます。
ExtendedInternationalModel - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalModel.
拡張国際化モデルを定義します。
ExtendedInternationalModel - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel.
拡張国際化モデルの情報です。
ExtendedInternationalModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap.
拡張国際化モデルのマッピング情報を持ちます。
ExtendedInternationalTable - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable.
拡張国際化テーブルを定義します。
ExtendedModel - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel.
拡張モデルを定義します。
ExtendedOutputStream - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream クラスを使用してください。
ExtendedOutputStream(OutputStream) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のコンストラクタ
推奨されていません。 出力ストリームを構築します。
ExtendedOutputStream(OutputStream, ErrorEventListener) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のコンストラクタ
推奨されていません。 出力ストリームを構築します。
ExtendedSocket - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket クラスを使用してください。
ExtendedSocket(String, int) - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のコンストラクタ
推奨されていません。 ソケットを構築します。
ExtendedSocket(Socket) - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のコンストラクタ
推奨されていません。 ソケットを構築します。
ExtendedSocket(ExtendedSocket) - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のコンストラクタ
推奨されていません。 ソケットを構築します。
ExtendedTable - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable.
拡張テーブルを定義します。
ExtendedTerminableAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor.
拡張期間化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap.
拡張期間化アクセサのマッピング情報を持ちます。
ExtendedTerminableInternationalAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor.
拡張期間国際化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableInternationalAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap.
拡張期間国際化アクセサのマッピング情報を持ちます。
ExtendedTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalModel.
拡張期間国際化モデルを定義します。
ExtendedTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel.
拡張期間国際化モデルの情報です。
ExtendedTerminableInternationalModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap.
拡張期間国際化モデルのマッピング情報を持ちます。
ExtendedTerminableInternationalTable - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable.
拡張期間国際化テーブルを定義します。
ExtendedTerminableModel - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableModel.
拡張期間化モデルを定義します。
ExtendedTerminableModel - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel.
拡張期間化モデルの情報です。
ExtendedTerminableModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap.
拡張期間化モデルのマッピング情報を持ちます。
ExtendedTerminableTable - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable.
拡張期間化テーブルを定義します。
ExtendedThread - class jp.co.intra_mart.foundation.utility.ExtendedThread.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread クラスを使用してください。
ExtendedThread() - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(Runnable) - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(ThreadGroup, Runnable) - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(String) - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(ThreadGroup, String) - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(Runnable, String) - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(ThreadGroup, Runnable, String) - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendsImport - interface jp.co.intra_mart.foundation.security.ExtendsImport.
拡張インポート処理インターフェース。
ExtendsImportManager - class jp.co.intra_mart.foundation.security.ExtendsImportManager.
拡張インポートマネージャクラス。
ExternalDirectory - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory.
共有データグループを管理するオブジェクトです。
ExternalDirectory(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
ExternalMemory - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory.
共有データを管理するオブジェクトです。
ExternalMemory(String, String) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
ExternalMemory(ExternalDirectory, String) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
eject(SocketConnection) - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 指定コネクションをこのプールの管理から切り離します。
encode(String) - interface jp.co.intra_mart.foundation.portal.common.encode.EnCodeInterface のメソッド
暗号化を行います。
encode(char) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。
encode(char[]) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 指定の文字を CharacterEncoder.getCharacterEncoding() で表される文字コードへ エンコードします。
encode(String) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 指定の文字列を CharacterEncoder.getCharacterEncoding() で表される文字コードへ エンコードします。
encrypt(String) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
デフォルトの暗号化アルゴリズムカテゴリを利用して文字列を暗号化します。
encrypt(String, String) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
指定された暗号化アルゴリズムカテゴリを利用して文字列を暗号化します。
encrypt(String) - interface jp.co.intra_mart.foundation.security.cryption.Cryption のメソッド
文字列を暗号化する。
encrypt(String) - class jp.co.intra_mart.foundation.security.cryption.NoCryption のメソッド
文字列を暗号化する。
encrypt(String) - class jp.co.intra_mart.foundation.security.cryption.StandardCryption のメソッド
文字列を暗号化する。
end() - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
ロックを解除します。
ensureCapacity(int) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 必要に応じて、この ArrayList のインスタンスのサイズを拡大し、少なくとも最小サイズ引数で指定された数の要素を格納できるようにします。
entityDirectory() - class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory のメソッド
データファイルを保存しておくための ディレクトリを表すオブジェクトを取得します。
entries() - class jp.co.intra_mart.foundation.acssecurity.Logingp の static メソッド
推奨されていません。 LoginGroupManager.getLoginGroupIds()に置き換えられました。
entries() - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。
entries() - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。
entries() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
セッションＩＤ一覧を取得します。
entries() - interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory のメソッド
このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。
entry(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
空のグループを作成します。
entry(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
空のグループを作成します。
entry(String) - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
新しい空のセッションを作成します。
entry() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
新しい空のセッションを作成します。
entry(String) - interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory のメソッド
空のグループを作成します。
entry(EventListener) - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 イベントリスナーの登録。
entry() - class jp.co.intra_mart.foundation.utility.LockMonitor のメソッド
推奨されていません。 モニターの取得。
entryMap() - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
グループデータを取得します。
entryMap() - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
グループデータを取得します。
entryMap() - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
グループデータを取得します。
entryMap() - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
グループデータを取得します。
entrySet() - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 このマップに格納されているマッピングのセットビューを返します。
equals(Object) - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
この有効期間と他の有効期間が等しいかどうかを示します。
equals(Object) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 指定されたオブジェクトとリストが等しいかどうかを比較します。
equals(Object) - class jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet のメソッド
このポートレットと別のオブジェクトとが等しいかどうかを比較します。
equals(Object) - class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet のメソッド
このポートレットと別のオブジェクトとが等しいかどうかを比較します。
equals(Object) - class jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet のメソッド
このポートレットと別のオブジェクトとが等しいかどうかを比較します。
equals(Object) - class jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet のメソッド
このポートレットと別のオブジェクトとが等しいかどうかを比較します。
equals(Object) - class jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet のメソッド
このポートレットと別のオブジェクトとが等しいかどうかを比較します。
equals(Object) - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet のメソッド
このポートレットと別のオブジェクトとが等しいかどうかを比較します。
equals(Object) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
オブジェクトを比較します。
equals(Object) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
オブジェクトの比較。
equals(Object) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
オブジェクトの比較。
equals(Object) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
このオブジェクトと他のオブジェクトが等しいかどうかを示します。
equals(Object) - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
このオブジェクトと他のオブジェクトが等しいかどうかを示します。
equals(Object) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
データモデルのチェック。
err - class jp.co.intra_mart.foundation.service.provider.Platform の static 変数
エラーログに対するメッセージ出力ストリームです。
errorIterator() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 このインスタンスのメソッド実行中に発生した例外を返します。
errorPagePath - class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor の変数
クラス変数
eventGenerating() - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 キューに登録されているイベントリスナーを一つ実行します。
execute(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 任意のＳＱＬ文をデータベースに対してリクエストする

insert/update/delete文を実行する。
execute(String) - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(String) - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager のメソッド
エクスポートを実行します。
execute(OutputStream) - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager のメソッド
エクスポートを実行します。
execute(String) - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(InputStream) - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(String) - class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl のメソッド
エクスポートを実行します。
execute(OutputStream) - class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl のメソッド
エクスポートを実行します。
execute(String) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager のメソッド

execute(OutputStream) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager のメソッド

execute(String) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(String) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager のメソッド

execute(OutputStream) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager のメソッド

execute(String) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(String) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager のメソッド

execute(OutputStream) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager のメソッド

execute(String) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(String) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager のメソッド

execute(OutputStream) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager のメソッド

execute(String) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(String) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager のメソッド

execute(OutputStream) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager のメソッド

execute(String) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient のメソッド
エクスポートマネージャーを呼び出します。
execute(String) - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
インポートマネージャーを呼び出します。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
インポートマネージャーを呼び出します。
execute(String[]) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManager のメソッド
インポートを実行します。
execute(InputStream) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManager のメソッド
インポートを実行します。
execute(String) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient のメソッド
指定された定義情報をもとにインポート処理を行います。
execute(InputStream) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient のメソッド
指定された定義情報をもとにインポート処理を行います。
execute(String[]) - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl のメソッド
インポートを実行します。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl のメソッド
インポートを実行します。
execute(String[]) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager のメソッド

execute(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager のメソッド

execute(String) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient のメソッド
指定された定義情報をもとにインポート処理を行います。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient のメソッド
指定された定義情報をもとにインポート処理を行います。
execute(String[]) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager のメソッド

execute(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager のメソッド

execute(String) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient のメソッド
指定された定義情報をもとにインポート処理を行います。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient のメソッド
指定された定義情報をもとにインポート処理を行います。
execute(String[]) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager のメソッド

execute(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager のメソッド

execute(String) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient のメソッド
指定された定義情報をもとにインポート処理を行います。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient のメソッド
指定された定義情報をもとにインポート処理を行います。
execute(String[]) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager のメソッド

execute(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager のメソッド

execute(String) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient のメソッド
指定された定義情報をもとにインポート処理を行います。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient のメソッド
指定された定義情報をもとにインポート処理を行います。
execute(String[]) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager のメソッド

execute(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager のメソッド

execute(String) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient のメソッド
指定された定義情報をもとにインポート処理を行います。
execute(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient のメソッド
指定された定義情報をもとにインポート処理を行います。
execute() - class jp.co.intra_mart.foundation.scenario.FunctionContainer のメソッド
スクリプトの実行。
execute(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.scenario.FunctionContainer のメソッド
スクリプトの実行。
execute(String) - class jp.co.intra_mart.foundation.scenario.PresentationPage のメソッド
プログラム実行。
execute(String, Object[]) - class jp.co.intra_mart.foundation.scenario.PresentationPage のメソッド
プログラム実行。
execute(Object) - class jp.co.intra_mart.foundation.service.client.NetworkAgent のメソッド
サーバに対して実行要求をします。
execute(ActionListener, Object) - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
サーバに対して実行要求をします。
execute(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
指定された URL に接続して、 イベントの実行を要求します。
execute(URL) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
指定された URL に接続して、 イベントの実行を要求します。
execute(HttpURLConnection) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
指定された URL コネクションを利用してにサーバに接続し、 イベントの実行を要求します。
execute(Properties) - class jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory のメソッド
推奨されていません。
execute(Properties) - interface jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent のメソッド
インタフェース ProcedureComponent を実装したオブジェクトの実行クラスを Application Runtime に登録することで、 Application Runtime はこのクラスをインスタンス化し、 execute() メソッドをバッチプログラムとして実行します。
executeBatchProgram(String, String) - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
バッチプログラムを実行します。
existGroupImageIconBySrc(String) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
URLをもつグループイメージアイコンの存在チェックをします。
existGroupImageIcons() - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
グループイメージアイコンの存在チェックをします。
existImageIcon(String) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
イメージアイコンの存在チェックをします。
existUserImageIconBySrc(String, String) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
URLをもつユーザイメージアイコンの存在チェックをします。
existUserImageIcons(String) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
ユーザイメージアイコンの存在チェックをします。
exists(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
指定された言語に該当する国際化モデルが存在するどうか判定します。
exists(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
指定された言語に該当する期間国際化モデルが存在するかどうか判定します。
exists(Date) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
指定された日時を含む期間化モデルが存在するかどうか判定します。
exists(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap のメソッド
指定された言語に該当する国際化モデルが存在するどうか判定します。
exists(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap のメソッド
指定された言語に該当する期間国際化モデルが存在するかどうか判定します。
exists(Date) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap のメソッド
指定された日付を含む期間化モデルが存在するかどうか判定します。
exists(String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたセッションIDのアクティブなセッション情報が存在するかどうか取得します。
exists(String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたセッションIDのアクティブなセッション情報が存在するかどうか取得します。
exists() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルが存在するかどうかを判定します。
expiration() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
セッションの維持時間を取得します。
expiration(ReportFileWriter) - class jp.co.intra_mart.foundation.utility.report.EverydayConditioner のメソッド
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.foundation.utility.report.FileSizeConditioner のメソッド
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner のメソッド
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.foundation.utility.report.PeriodicConditioner のメソッド
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - interface jp.co.intra_mart.foundation.utility.report.ReportFileConditioner のメソッド
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
exportCSV(PreparedStatement, OutputStream, boolean) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 CSV形式のデータをストリームに出力します。
exportCSV(PreparedStatement, OutputStream, int, int, boolean) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 CSV形式のデータをストリームに出力します。
exportCSV(PreparedStatement, NetworkFile, boolean) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 CSVファイルをストレージに出力します。
exportCSV(PreparedStatement, NetworkFile, int, int, boolean) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 CSVファイルをストレージに出力します。
exportData(OutputStream, boolean) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
エクスポートを行います。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
アクセスコントローラ情報をエクスポートします。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウント情報をエクスポートします。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
エクスポートを行います。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
エクスポートを行います。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニュー情報・エクスポート。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニュー情報をエクスポートします。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール情報・エクスポート。

F

FAVORITE_MENU - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
アカウントが保有するメニュー
FAX_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
FAX番号
FAX_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
FAX番号
FLOAT - class jp.co.intra_mart.foundation.datastore.common.config.AttributeType の static 変数
浮動少数型
FavoriteMenu - class jp.co.intra_mart.foundation.security.account.FavoriteMenu.
マイメニューモデル。
FavoriteMenu(String, String, int) - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のコンストラクタ
コンストラクタ。
FavoriteMenu(String) - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のコンストラクタ
コンストラクタ。
FavoriteMenuBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel.
アカウントが保有するメニューの基本モデルです。
FavoriteMenuMapper - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper.
アカウントが保有するメニューに関連するマッパです。
FileReporter - class jp.co.intra_mart.foundation.utility.report.FileReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileReporter クラスを使用してください。
FileReporter(ReportFileWriter) - class jp.co.intra_mart.foundation.utility.report.FileReporter のコンストラクタ
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
FileSender - class jp.co.intra_mart.foundation.http.FileSender.
このクラスは、HTTP レスポンスに対して指定のバイトをストリームとして 出力します。
FileSender(HttpServletResponse) - class jp.co.intra_mart.foundation.http.FileSender のコンストラクタ
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSender(HttpServletResponse, MultipurposeInternetMailExtensions) - class jp.co.intra_mart.foundation.http.FileSender のコンストラクタ
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSender(HttpServletResponse, String) - class jp.co.intra_mart.foundation.http.FileSender のコンストラクタ
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSender(HttpServletResponse, MultipurposeInternetMailExtensions, String) - class jp.co.intra_mart.foundation.http.FileSender のコンストラクタ
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSizeConditioner - class jp.co.intra_mart.foundation.utility.report.FileSizeConditioner.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner クラスを使用してください。
FileSizeConditioner(long) - class jp.co.intra_mart.foundation.utility.report.FileSizeConditioner のコンストラクタ
推奨されていません。 メッセージファイルのサイズによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
Filter - class jp.co.intra_mart.foundation.datastore.exporter.Filter.
エクスポート対象のデータを絞り込むための情報を保持します。
Filter(String[]) - class jp.co.intra_mart.foundation.datastore.exporter.Filter のコンストラクタ
コンストラクタ
設定された値以外を抽出するフィルタを構築します。
Filter(String[], boolean) - class jp.co.intra_mart.foundation.datastore.exporter.Filter のコンストラクタ
コンストラクタ
設定された値に対するフィルタを構築します。
FilterComparator - class jp.co.intra_mart.foundation.utility.FilterComparator.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator クラスを使用してください。
FilterComparator(Comparator) - class jp.co.intra_mart.foundation.utility.FilterComparator のコンストラクタ
推奨されていません。 指定されれたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
FilterHTTPActionEvent - class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent.
Application Runtime で実行されるイベントのための フィルターイベントの抽象実装です。
FilterHTTPActionEvent() - class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent のコンストラクタ
指定のイベントをラップするためのフィルターを作成します。
FilterHTTPActionEventChain - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain.
FilterHTTPActionEventChain は、FilterHTTPActionEvent によって提供され、 FilterHTTPActionEvent へのフィルタリングされた要求のチェーンに対する ビューを提供します。
FilterMessageReporter - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter クラスを使用してください。
FilterMessageReporter(MessageReporter) - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter のコンストラクタ
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。
FixedSizeMap - class jp.co.intra_mart.foundation.utility.FixedSizeMap.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap クラスを使用してください。
FixedSizeMap(int) - class jp.co.intra_mart.foundation.utility.FixedSizeMap のコンストラクタ
推奨されていません。 指定されたサイズの領域を持つマップを構築します。
FoundationException - exception jp.co.intra_mart.foundation.exception.FoundationException.
システム基盤共通例外クラス。
FoundationException() - class jp.co.intra_mart.foundation.exception.FoundationException のコンストラクタ
コンストラクタ。
FoundationException(String) - class jp.co.intra_mart.foundation.exception.FoundationException のコンストラクタ
コンストラクタ。
FoundationException(Throwable) - class jp.co.intra_mart.foundation.exception.FoundationException のコンストラクタ
コンストラクタ。
FoundationException(String, Throwable) - class jp.co.intra_mart.foundation.exception.FoundationException のコンストラクタ
コンストラクタ。
FoundationRuntimeException - exception jp.co.intra_mart.foundation.exception.FoundationRuntimeException.
システム基盤共通ランタイム例外クラス。
FoundationRuntimeException() - class jp.co.intra_mart.foundation.exception.FoundationRuntimeException のコンストラクタ
コンストラクタ。
FoundationRuntimeException(String) - class jp.co.intra_mart.foundation.exception.FoundationRuntimeException のコンストラクタ
コンストラクタ。
FoundationRuntimeException(Throwable) - class jp.co.intra_mart.foundation.exception.FoundationRuntimeException のコンストラクタ
コンストラクタ。
FoundationRuntimeException(String, Throwable) - class jp.co.intra_mart.foundation.exception.FoundationRuntimeException のコンストラクタ
コンストラクタ。
FunctionContainer - class jp.co.intra_mart.foundation.scenario.FunctionContainer.
FunctionContainer クラスは、ファンクション・コンテナとなるスクリプトを コンパイルして実行可能な環境を提供します。
FunctionContainer() - class jp.co.intra_mart.foundation.scenario.FunctionContainer のコンストラクタ
新しいインスタンスを構築します。
FunctionContainer(Reader) - class jp.co.intra_mart.foundation.scenario.FunctionContainer のコンストラクタ
新しいインスタンスを構築します。
FunctionContainer(String) - class jp.co.intra_mart.foundation.scenario.FunctionContainer のコンストラクタ
新しいインスタンスを構築します。
FunctionContainerFile - class jp.co.intra_mart.foundation.scenario.FunctionContainerFile.
FunctionContainerFile クラスは、ファンクション・コンテナとなるファイルを コンパイルして実行可能な環境を提供します。
FunctionContainerFile(String, Locale) - class jp.co.intra_mart.foundation.scenario.FunctionContainerFile のコンストラクタ
ファンクション・コンテナをコンパイルします。
FunctionContainerFile(String) - class jp.co.intra_mart.foundation.scenario.FunctionContainerFile のコンストラクタ
ファンクション・コンテナをコンパイルします。
fetch(String, int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 SELECT文を発行してデータベースから指定範囲のデータを取得する

files() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ディレクトリ中のファイルの一覧を取得します。
files(int) - class jp.co.intra_mart.foundation.utility.file.Directory のメソッド
推奨されていません。 この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
finalize() - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 このオブジェクトへの参照はもうないとガーベージコレクションによって 判断されたときに、ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.foundation.utility.report.FileReporter のメソッド
推奨されていません。 このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
findDirectory(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
findExtendedBaseAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap のメソッド
拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を取得します。
findExtendedBaseModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap のメソッド
拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。
findExtendedBaseModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap のメソッド
拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。
findExtendedInternationalAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap のメソッド
拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を取得します。
findExtendedInternationalModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap のメソッド
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
findExtendedInternationalModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap のメソッド
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
findExtendedTerminableAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap のメソッド
拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を取得します。
findExtendedTerminableInternationalAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap のメソッド
拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を取得します。
findExtendedTerminableInternationalModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap のメソッド
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
findExtendedTerminableInternationalModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap のメソッド
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
findExtendedTerminableModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap のメソッド
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
findExtendedTerminableModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap のメソッド
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
findFile(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
findInternationalAccessor(Locale) - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap のメソッド
指定された言語に該当する国際化アクセサを取得します。
findInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
指定された言語に該当する国際化モデルを取得します。
findInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap のメソッド
指定された言語に該当する国際化モデルを取得します。
findPath() - class jp.co.intra_mart.foundation.service.provider.HomeDirectory の static メソッド
システムのホームディレクトリを返します。
findPath(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
findTerminableAccessor(Date) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap のメソッド
指定された日付に該当する期間化アクセサを取得します。
findTerminableInternationalAccessor(Locale) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap のメソッド
指定された言語に該当する期間国際化アクセサを取得します。
findTerminableInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
指定された言語に該当する期間国際化モデルを取得します。
findTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap のメソッド
指定された言語に該当する期間国際化モデルを取得します。
findTerminableModel(Date) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
指定された日時に該当する期間化モデルを取得します。
findTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap のメソッド
指定された日付に該当する期間化モデルを取得します。
finish() - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream のメソッド
推奨されていません。 出力ストリームへのエンコードデータの書き込みを終了します。
finish() - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のメソッド
推奨されていません。 バッファに保存してあるデータを書き出します。
fire() - class jp.co.intra_mart.foundation.utility.ExtendedThread のメソッド
推奨されていません。 スレッド実行されるロジック。
floatValue() - class jp.co.intra_mart.foundation.utility.Counter のメソッド
推奨されていません。 カウンターの現在の値を float 型として返します。
flush() - interface jp.co.intra_mart.foundation.service.provider.SystemReporter のメソッド
ストリームをフラッシュします。
flush() - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 キューに溜まっているすべてのイベントリスナーを実行します。
flush() - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 書き出しストリーム内のデータをすべて出力。
flush() - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のメソッド
推奨されていません。 ストリームをフラッシュします。
flush() - class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter のメソッド
推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.foundation.utility.report.FileReporter のメソッド
推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter のメソッド
推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
flush() - interface jp.co.intra_mart.foundation.utility.report.MessageReporter のメソッド
推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter のメソッド
推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 ストリームをフラッシュします。
flush() - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter のメソッド
推奨されていません。 ストリームをフラッシュします。
forceLogin(LoginRequestInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
強制ログイン処理を行います。
forceLogin(LoginRequestInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
強制ログイン処理を行います。
forward(HttpServletRequest, HttpServletResponse, String) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
指定したURLにフォワードします。
forward(String) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
指定したURLにフォワードします。
freeMemory() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
サーバシステムの空きメモリの量を返します。

G

GCConditioner - interface jp.co.intra_mart.foundation.service.provider.GCConditioner.
GarbageController クラスが gc を実行するかどうか判断するための インターフェースを提供します。
GET - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

GET_ENTIRETY - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

GET_ENTIRETY_KEY - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

GET_ITEM - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

GET_ITEM_KEY - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

GET_SUBSET - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

GO_OUT - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
外出フラグ
GarbageController - class jp.co.intra_mart.foundation.service.provider.GarbageController.
ガーベージコレクタを実行するクラスです。
GenericBaseModel - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel.
基本モデルの汎用的な抽象クラスです。
GenericBaseModel() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のコンストラクタ

GenericInternationalModel - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel.
国際化モデルの汎用的な抽象クラスです。
GenericInternationalModel() - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のコンストラクタ

GenericInternationalModelMap - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap.
国際化モデルマッピングの汎用的な抽象クラスです。
GenericInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のコンストラクタ

GenericTerminableInternationalModel - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel.
期間国際化モデルの汎用的な抽象クラスです。
GenericTerminableInternationalModel() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のコンストラクタ

GenericTerminableInternationalModelMap - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap.
期間国際化モデルマッピングの汎用的な抽象クラスです。
GenericTerminableInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のコンストラクタ

GenericTerminableModel - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel.
期間化モデルの汎用的な抽象クラスです。
GenericTerminableModel() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のコンストラクタ

GenericTerminableModelMap - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap.
期間化モデルマッピングの汎用的な抽象クラスです。
GenericTerminableModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のコンストラクタ

GenericURLBuilder - class jp.co.intra_mart.jssp.net.GenericURLBuilder.
スクリプト開発モデルの画面を呼び出すための URL を作成するビルダです。
GenericURLBuilder(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.jssp.net.GenericURLBuilder のコンストラクタ
新しいビルダを作成します。
GroupActiveSessionRegister - class jp.co.intra_mart.foundation.security.activesession.GroupActiveSessionRegister.
管理者ログイン認証リスナー実装クラス。
GroupActiveSessionRegister() - class jp.co.intra_mart.foundation.security.activesession.GroupActiveSessionRegister のコンストラクタ

GroupSecurityHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler.
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
GroupSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler, String) - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler のコンストラクタ
ログイングループセッション環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
GroupSuperUserAccessor - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor.
グループ管理者アクセッサインタフェース。
GroupSuperUserInitialServlet - class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet.
グループ管理者初期アクセスサーブレット。
GroupSuperUserInitialServlet() - class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet のコンストラクタ

GroupSuperUserPostWriterListener - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener.
グループ管理者情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
GroupSuperUserQueryWriterListener - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener.
グループ管理者情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
GroupSuperUserReaderDecorator - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator.
管理者情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
get(String) - class jp.co.intra_mart.foundation.acssecurity.Logingp のメソッド
推奨されていません。 代替えメソッドはありません。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel のメソッド
指定の属性が保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel のメソッド
指定の属性が保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel のメソッド
指定の属性が保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel のメソッド
指定の属性が保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性が保持する値を取得します。
get(String, Date) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性が、指定の日時に保持している値を取得します。
get(String, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性が、指定の言語で保持している値を取得します。
get(String, Date, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性が、指定の日時、言語で保持している値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のメソッド
指定の属性が保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のメソッド
指定の属性が保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
指定の属性が保持する値を取得します。
get(String, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
指定の属性が指定の言語で保持する値を取得します。
get(int) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リスト内の指定された位置にある要素を返します。
get(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
データを取得します。
get() - class jp.co.intra_mart.foundation.service.client.information.Identifier のメソッド
一意性を保証されたＩＤを取得します。
get(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
データを取得します。
get(String) - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
データを取得します。
get(String) - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
データを取得します。
get(Object) - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 マップが、指定されたキーにマッピングしている値を返します。
getAcceptTime() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
イベント実行要求を受け付けたおよその時刻を返します。
getAccessControllerId() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel のメソッド
アクセスコントローラIDを取得します。
getAccessControllerId() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel のメソッド
アクセスコントローラIDを取得します。
getAccessControllerId() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel のメソッド
アクセスコントローラIDを取得します。
getAccessControllerId() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel のメソッド
アクセスコントローラIDを取得します。
getAccessControllerId() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel のメソッド
アクセスコントローラIDを取得します。
getAccessControllerName() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel のメソッド
アクセスコントローラ名を取得します。
getAccessInfo() - class jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem のメソッド

getAccessKey(String, String) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil の static メソッド
かんたんログイン用のアクセスキーを取得します。
getAccessKeyWithRequestParameter(String, String) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil の static メソッド
かんたんログイン用のアクセスキーをリクエストパラメータの形式で取得します。
getAccount(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 AccountManager.exportData(String category, OutputStream outputStream)に置き換えられました。
getAccount(String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウント情報を取得する。
getAccount(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント情報を取得する。
getAccount(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
ユーザIDにマッチしたユーザデータを１件取得します。
getAccount() - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler のメソッド
設定されているアカウントＩＤを返します。
getAccountCount(String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウント数を取得する。
getAccountCount(String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント数を取得する。
getAccountFlag() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
アカウントフラグを取得します。
getAccountFlag() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
アカウントフラグを取得します。
getAccountMenuTree(String, String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定したアカウントのメニュー構成を取得します。
getAccountRole(String, String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウントロール情報を取得する。
getAccountRole(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントロール情報を取得する。
getAccountRoleIds(String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウントロールIDをすべて取得する。
getAccountRoleIds(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントロールIDをすべて取得する。
getAccountRoleIds(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントロールIDをすべて取得します。
getAccountRoles(String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウントロール情報をすべて取得する。
getAccountRoles(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントロール情報をすべて取得する。
getAccountRoles(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントロールをすべて取得します。
getAccountRoles(String, Date) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
有効期間内のアカウントロールをすべて取得します。
getAccounts() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
ログイングループ内のすべてのユーザアカウントを取得します。
getAccountsByUserIds(String, String[]) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
指定されたユーザIDのアカウント情報をすべて取得する。
getAccountsByUserIds(String, String[]) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
指定されたユーザIDのアカウント情報をすべて取得する。
getAccountsByUserIds(String[]) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
ログイングループ内で引数指定したユーザIDのユーザアカウントをすべて取得します。
getActivationDate() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
役職情報の有効開始日を取得します。
getActivationDate() - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
開始時間を取得します。
getActivationKey() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ソースエンティティのライフタイム期間の有効開始日時を取得します。
getActiveSessionBindingListenerSessionName() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
アクティブなセッション情報を登録・削除するために使用するセッション名を取得します。
getActiveSessionInfo(String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたセッションIDのアクティブなセッション情報を取得します。
getActiveSessionInfo(String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたセッションIDのアクティブなセッション情報を取得します。
getActiveSessionInfo(String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたセッションIDのアクティブなセッション情報を取得します。
getActiveSessionInfos(String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
アクティブなすべてのセッション情報を取得します。
getActiveSessionInfos(String, String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたユーザのアクティブなセッション情報を取得します。
getActiveSessionInfos(String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたログインタイプのアクティブなセッション情報を取得します。
getActiveSessionInfos(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
アクティブなすべてのセッション情報を取得します。
getActiveSessionInfos(String, String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたユーザのアクティブなセッション情報を取得します。
getActiveSessionInfos(String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたログインタイプのアクティブなセッション情報を取得します。
getActiveSessionInfos(String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
アクティブなすべてのセッション情報を取得します。
getActiveSessionInfos(String, String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたユーザのアクティブなセッション情報を取得します。
getActiveSessionInfos(String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたログインタイプのアクティブなセッション情報を取得します。
getActiveSessionInvalidatedPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたアクティブなセッション情報が無効化されたされていた場合の遷移先ページURLを取得します。
getActiveSessionInvalidatedPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたアクティブなセッション情報が無効化されたされていた場合の遷移先ページURLを取得します。
getActiveSessionInvalidatedPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたアクティブなセッション情報が無効化されたされていた場合の遷移先ページURLを取得します。
getAddress() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
住所を取得します。
getAddress(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
住所を取得します。
getAddress(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
住所を取得します。
getAddress(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
住所を取得します。
getAddress() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
住所を取得します。
getAddress() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を取得します。
getAddress(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を取得します。
getAddress(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を取得します。
getAddress(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を取得します。
getAddress() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
住所を取得します。
getAddress() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
住所を取得します。
getAddress(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
住所を取得します。
getAddress() - interface jp.co.intra_mart.foundation.mail.javamail.model.MailAddress のメソッド
メールアドレスを取得します。
getAddress() - class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor のメソッド
推奨されていません。 アドレスを返します。
getAddress() - class jp.co.intra_mart.foundation.utility.net.Localhost のメソッド
推奨されていません。 このコンピュータのＩＰアドレスを返します。
getAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
住所1を取得します。
getAddress1(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
住所1を取得します。
getAddress1(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
住所1を取得します。
getAddress1(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
住所1を取得します。
getAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
住所1を取得します。
getAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
住所1を取得します。
getAddress1(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
住所1を取得します。
getAddress1(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
住所1を取得します。
getAddress1(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
住所1を取得します。
getAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
住所1を取得します。
getAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を取得します。
getAddress1(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を取得します。
getAddress1(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を取得します。
getAddress1(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を取得します。
getAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
住所1を取得します。
getAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所1を取得します。
getAddress1(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所1を取得します。
getAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
住所2を取得します。
getAddress2(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
住所2を取得します。
getAddress2(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
住所2を取得します。
getAddress2(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
住所2を取得します。
getAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
住所2を取得します。
getAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
住所2を取得します。
getAddress2(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
住所2を取得します。
getAddress2(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
住所2を取得します。
getAddress2(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
住所2を取得します。
getAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
住所2を取得します。
getAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を取得します。
getAddress2(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を取得します。
getAddress2(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を取得します。
getAddress2(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を取得します。
getAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
住所2を取得します。
getAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所2を取得します。
getAddress2(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所2を取得します。
getAllAccounts(String) - class jp.co.intra_mart.foundation.security.account.CsvAccountBackup のメソッド

getAllAccounts(String) - class jp.co.intra_mart.foundation.security.account.StandardAccountBackup のメソッド

getAllCategorizedItems(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のメソッド
商品カテゴリに分類されているすべての商品の情報を返します。
getAllParentRoleIds(String, String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
すべての親ロールの一覧を取得します。
getAllParentRoleIds(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
すべての親ロールの一覧を取得する。
getAllParentRoleIds(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
全ての親ロールIDを取得します。
getAllSubRoleIds(String, String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
すべてのサブロールの一覧を取得します。
getAllSubRoleIds(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
すべてのサブロールの一覧を取得する。
getAllSubRoleIds(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
全てのサブロールサマリを取得します。
getAllowsUsers() - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のメソッド
許可ユーザを取得します。
getAmount() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail のメソッド
数量を取得します。
getAmount() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
数量を取得します。
getAmount(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
数量を取得します。
getAmount() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailTerminableModel のメソッド
数量を取得します。
getAnswer() - class jp.co.intra_mart.foundation.navigator.EventHistoryInfo のメソッド
質問取得
getAnswer() - class jp.co.intra_mart.foundation.navigator.SaveEventHistoryInfo のメソッド
質問取得
getAppName() - class jp.co.intra_mart.foundation.security.activesession.NavigatorInfo のメソッド
ブラウザ名を取得します。
getApplication(String) - interface jp.co.intra_mart.foundation.datastore.common.config.Configuration のメソッド
指定された名前に該当するアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティを定義しているアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張エンティティを定義しているアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張モデルを定義しているアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張テーブルを定義しているアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
モデルを定義しているアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
リレーションシップが定義されているアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
テーブルを定義しているアプリケーションを取得します。
getApplication() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
アプリケーション名を取得します。
getApplication(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager の static メソッド
アプリケーション情報を取得します。
getApplication() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
設定されているアプリケーションＩＤを返します。
getApplicationId() - class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet のメソッド
アプリケーションIDを取得します。
getApplicationLicense(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager の static メソッド
アプリケーションの登録ユーザ数を取得します。
getApplicationName() - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
マッパーが定義されているアプリケーション名を取得します。
getApplications() - class jp.co.intra_mart.foundation.security.license.LicenseManager の static メソッド
アプリケーション情報の一覧を取得します。
getArgument() - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
引数文字列を取得します。
getArgument() - class jp.co.intra_mart.foundation.page.TreeLeaf のメソッド
引数文字列を取得します。
getArgument() - interface jp.co.intra_mart.foundation.page.TreeNode のメソッド
引数文字列を取得します。
getArgument() - class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet のメソッド
ページ引数を取得します。
getArgument() - class jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet のメソッド
ページ引数を取得します。
getArgument(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
引数を取得します。
getArgumentKeys() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
引数キーの一覧を取得します。
getArgumentName() - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel のメソッド
引数名を取得します。
getArgumentValue() - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel のメソッド
引数値を取得します。
getAttachedDepartments(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
現在、ユーザが所属している組織の一覧を取得します。
getAttachedDepartments(String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
指定された日付にユーザが所属している組織の一覧を取得します。
getAttachedPublicGroups(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
現在、ユーザが所属しているパブリックグループの一覧を取得します。
getAttachedPublicGroups(String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
指定された日付にユーザが所属しているパブリックグループの一覧を取得します。
getAttachment() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
添付ファイルを取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.ActivationKey のメソッド
ライフタイム期間の有効開始日時となる属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.Column のメソッド
カラムに対応付ける属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping のメソッド
カラムに割り当てる属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey のメソッド
ライフタイム期間の有効終了日時となる属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalKey のメソッド
国際化基準項目となる属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping のメソッド
プライマリーキーとなる属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.Property のメソッド
プロパティに対応付ける属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableKey のメソッド
期間化基準項目となる属性を取得します。
getAttribute(String) - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
セッションから指定した属性の値を取得します。
getAttribute(String, String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウント属性情報を取得する。
getAttribute(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント属性情報を取得する。
getAttribute(String, String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウント属性情報を取得する。
getAttribute(String, String, String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウント属性情報を取得する。
getAttributeName() - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel のメソッド
属性キーを取得します。
getAttributeNames(String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウント属性名の一覧を取得する。
getAttributeNames(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント属性情報の名前の一覧を取得する。
getAttributeNames(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウント属性名の一覧を取得する。
getAttributeValue() - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel のメソッド
属性値を取得します。
getAttributes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
指定された商品の属性情報を取得します。
getAttributes() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティに含まれる属性をすべて取得します。
getAttributes() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張エンティティに含まれる属性をすべて取得します。
getAutoCommit() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 現在の自動コミットの状態を取得します。
getAvailablePageKind() - class jp.co.intra_mart.foundation.portal.portlet.PortletMapping のメソッド
利用可能なポートレット種別の一覧を取得します。
getBaseAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor のメソッド
拡張元となる基本エンティティの基本アクセサを取得します。
getBaseAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor のメソッド
この国際化アクセサが所属する基本アクセサを取得します。
getBaseAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
この期間化アクセサが所属する基本アクセサを取得します。
getBaseAccessor() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel のメソッド
基本アクセサ BaseAccessor を取得します。
getBaseAccessor() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
基本アクセサを取得します。
getBaseAccessor() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
この基本モデルに割り当てられた基本アクセサを取得します。
getBaseDn() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
ベースDNを取得する。
getBaseModel() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
基本モデルを取得します。
getBaseName() - class jp.co.intra_mart.foundation.datastore.exception.MapperException のメソッド
メッセージを取得するためのリソースバンドルの基底名を返します。
getBaseTable() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
基本テーブルを取得します。
getBatch(String, String) - class jp.co.intra_mart.foundation.security.StandardBatchAccessor のメソッド
バッチを取得します。
getBatch(String, String) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
バッチ情報を取得します。
getBatch(String) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチ情報を取得します。
getBatchId() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチＩＤを取得します。
getBatchId() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
バッチIDを取得します。
getBatchIds(String) - class jp.co.intra_mart.foundation.security.StandardBatchAccessor のメソッド
バッチIDの一覧を取得します。
getBatchIds(String) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
すべてのバッチIDを取得します。
getBatchIds() - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチIDの一覧を取得します。
getBatchName() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
バッチ名を取得します。
getBatches(String) - class jp.co.intra_mart.foundation.security.StandardBatchAccessor のメソッド
バッチの一覧を取得します。
getBatches(String) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
すべてのバッチ情報を取得します。
getBatches() - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
すべてのバッチ情報を取得します。
getBatchesByIds(String, String[]) - class jp.co.intra_mart.foundation.security.StandardBatchAccessor のメソッド
引数に指定したバッチIDのバッチ情報をすべて取得します。
getBatchesByIds(String, String[]) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
引数に指定したバッチIDのバッチ情報をすべて取得します。
getBatchesByIds(String[]) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
ログイングループ内で引数指定したバッチIDのバッチ情報をすべて取得します。
getBcc() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Bccの一覧を取得します。
getBytes() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
推奨されていません。 データ部をバイト配列として取得します。
getBytes() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent のメソッド
サーバからレスポンスされたコンテンツのソースをバイト列として返します。
getBytes() - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 この抽象パスが表すファイルからデータを読み込みます。
getCSVStrings(PreparedStatement, boolean) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 CSV形式のデータ取得します。
getCSVStrings(PreparedStatement, int, int, boolean) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 CSV形式のデータ取得します。
getCacheTime() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
キャッシュ時間を取得します。
getCalendarId() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
カレンダーIDを取得します。
getCalendarIds(String) - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor のメソッド
すべてのカレンダーIDを取得します。
getCalendarIds(String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
すべてのカレンダーIDを取得します。
getCalendarIds() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
すべてのカレンダーIDを取得します。
getCalendarInfo(String, String, String) - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor のメソッド
カレンダーデータを取得します。
getCalendarInfo(String, String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
カレンダーデータを取得します。
getCalendarInfo(String, String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータを取得します。
getCalendarInfo() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
マッチしたカレンダーデータの一覧を取得します。
getCalendarInfoIds(String, String) - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor のメソッド
すべてのカレンダーデータIDを取得します。
getCalendarInfoIds(String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
すべてのカレンダーデータIDを取得します。
getCalendarInfoIds(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
すべてのカレンダーデータIDを取得します。
getCalendarInfos(String, String) - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor のメソッド
すべてのカレンダーデータを取得します。
getCalendarInfos(String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
すべてのカレンダーデータを取得します。
getCalendarInfos(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
すべてのカレンダーデータを取得します。
getCalendarInfosByIds(String, String, String[]) - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor のメソッド
指定されたカレンダーデータIDのカレンダー情報をすべて取得する。
getCalendarInfosByIds(String, String, String[]) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
指定されたカレンダIDのカレンダ情報をすべて取得する。
getCalendarInfosByIds(String, String[]) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
ログイングループ内で引数指定したカレンダーデータIDのカレンダーをすべて取得します。
getCapacity() - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionManager のメソッド
推奨されていません。 コネクション作成最大数の取得。
getCapacity() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 コネクション作成最大数の取得。
getCaption() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
ｘ軸のキャプションを返します。
getCaption() - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
キャプション文字列を返します。
getCaption() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
ｘ軸のキャプションを返します。
getCaption() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
ｘ軸のキャプションを返します。
getCaptionColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
キャプションの文字色を返します。
getCaptionColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
キャプションの文字色を返します。
getCaptionColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
キャプションの文字色を返します。
getCaptionColor() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
キャプションの文字色を返します。
getCaptionMargin() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
キャプション表示位置のマージンを返します。
getCaptionMargin() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
キャプション表示位置のマージンを返します。
getCatalog() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 Connection の現在のカタログ名を返します。
getCatalogue(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
指定されたカタログ情報を返します。
getCatalogueMediaFileName(ItemCatalogue) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
商品カタログの媒体が保存されてるファイルパスを取得します。
getCatalogues(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
指定された商品のカタログ情報を返します。
getCategories(String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
カテゴリの一覧を取得します。
getCategories() - class jp.co.intra_mart.foundation.security.permission.PermissionManager のメソッド
設定XMLファイルで定義されているすべてのカテゴリ名を返却します。
getCategories(String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
カテゴリの一覧を取得する。
getCategories() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
カテゴリーの一覧を取得します。
getCategorizedCalendarInfos(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
すべてのカレンダーデータをデータタイプ別に分類して取得します。
getCategorizedItems(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のメソッド
商品カテゴリに分類されている商品の情報を返します。
getCategory(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のメソッド
指定されたカテゴリコードに対する商品カテゴリの情報を返します。
getCategory() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
新着情報のカテゴリ名を取得します。
getCategory() - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロールカテゴリを取得します。
getCategory() - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
カテゴリを取得します。
getCategoryClassCode() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
分類区分コードを取得します。
getCategoryClassCode() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
分類区分コードを取得します。
getCategoryClassCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
分類区分コードを取得します。
getCategoryClassCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
分類区分コードを取得します。
getCategoryClassCode() - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
分類区分コードを取得します。
getCategoryClassCode() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
分類区分コードを取得します。
getCategoryClassCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel のメソッド
分類区分コードを取得します。
getCategoryClassCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel のメソッド
分類区分コードを取得します。
getCategoryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
分類コードを取得します。
getCategoryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
分類コードを取得します。
getCategoryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
分類コードを取得します。
getCategoryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
分類コードを取得します。
getCategoryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel のメソッド
分類コードを取得します。
getCategoryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel のメソッド
分類コードを取得します。
getCategoryDetail(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のメソッド
登録済みの分類区分詳細情報を取得します。
getCategoryDetailInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
指定された言語に対する国際化情報を取得します。
getCategoryDetails() - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のメソッド
登録済みの分類区分詳細情報の一覧を取得します。
getCategoryDetails(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のメソッド
登録済みの分類区分詳細情報の一覧を取得します。
getCategoryManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager の static メソッド
CategoryManagerを取得します。
getCategoryStruct(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のメソッド
指定された商品カテゴリ種別のカテゴリ階層を取得します。
getCategoryTypes() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のメソッド
登録済の商品カテゴリ種別の一覧を返します。
getCateogryClassInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
指定された言語に対する国際化情報を取得します。
getCc() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Ccの一覧を取得します。
getCenterPointX() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｘ軸の中心値を返します。
getCenterPointY() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｙ軸の中心値を返します。
getCertificationErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
認証失敗エラーページURLを取得する。
getCertificationErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
認証失敗エラーページURLを取得します。
getCharacterEncoding() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
パラメータを符号化するためのエンコーディング名を返します。
getCharacterEncoding() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
リクエストパラメータの文字エンコーディングを返します。
getCharacterEncoding() - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のメソッド
推奨されていません。 このオブジェクトが対象としている文字エンコーディング名を返します。
getCharacterEncoding() - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 このオブジェクトが対象としている文字エンコーディング名を返します。
getCharset(Locale) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
キャラクターセットを取得します。
getChildMenuId() - class jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion のメソッド
子メニューIDを取得します。
getChildMenuId() - class jp.co.intra_mart.foundation.security.menu.MenuInclusion のメソッド
子メニューIDを取得します。
getChildMenuIds(String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
引数で指定されたノードの直下の子メニューIDを配列で取得します。
getChildMenuIds(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
引数で指定されたノードの直下の子ノードを配列で取得します。
getChildMenuIds(String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
子メニューIDを取得します。
getChildMenuIds(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
引数で指定されたノードの直下の子ノードを配列で取得します。
getChildMenuIds(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
子メニューIDを取得します。
getChildNodes() - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
このノードの子ノードをすべて含む Collectionを返します。
getChildNodes() - interface jp.co.intra_mart.foundation.page.TreeNodeContainer のメソッド
このノードの子をすべて含む Collectionを返します。
getChildRoleId() - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel のメソッド
子ロールコードを取得します。
getChildren() - interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryStruct のメソッド
このカテゴリ構成の子供の構成を取得します。
getChildren() - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
子メニューの一覧を取得します。
getClassInstance(String) - class jp.co.intra_mart.foundation.commons.SourceProviderHandler のメソッド
ソースプロバイダクラスのインスタンスを取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.BaseModel のメソッド
基本モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseModel のメソッド
拡張基本モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalModel のメソッド
拡張国際化モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalModel のメソッド
拡張期間国際化モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableModel のメソッド
拡張期間化モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalModel のメソッド
国際化モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalModel のメソッド
期間国際化モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableModel のメソッド
期間化モデルのクラス名を取得します。
getClientContext() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
イベントの実行を要求したクライアントに関する情報オブジェクトを返します。
getClientType() - interface jp.co.intra_mart.foundation.security.ClientTypeInfo のメソッド
クライアントタイプを取得する。
getClientType() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
クライアントタイプを取得する。
getClientType(Locale, String) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
指定ロケールでクライアントタイプ情報を取得します。
getClientType() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
クライアントタイプを取得する。
getClientType() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
クライアントタイプを取得する。
getClientType() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
クライアントタイプを取します。
getClientType() - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
クライアントタイプを取得します。
getClientTypeName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
クライアントタイプをセッションに保管するためのパラメータ名を取得する。
getClientTypes(Locale) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
指定ロケールでクライアントタイプ情報の一覧を取得します。
getCloseSocketEventListeners() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 このソケットに登録されているクローズ・イベント・リスナーを返します。
getCloseSocketEventListeners() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 このプールに登録されている ソケットをクローズしたイベントを通知するためのリスナーを 返します。
getCode() - class jp.co.intra_mart.foundation.acssecurity.AcssecurityException のメソッド

getColor() - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
棒の色を返します。
getColor() - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
グラフの色を返します。
getColor() - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
線の色を返します。
getColor() - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
描画する点の色を返します。
getColor() - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
グラフ線の色を返します。
getColor() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
色を取得します。
getColor() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
背景色を取得します。
getColor() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
表示色を取得します。
getColorCode() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンコードを取得します。
getColorPattern(Locale, String) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
指定ロケールでカラーパターン情報を取得します。
getColorPatternId() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンIDを取得します。
getColorPatternId() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
カラーパターンIDを取得する。
getColorPatternId() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
カラーパターンIDを取得します。
getColorPatternId() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
カラーパターンIDを取得します。
getColorPatternId() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
ページカラーパターンを取得します。
getColorPatternIdName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
カラーパターンIDをセッションに保管するためのパラメータ名を取得する。
getColorPatterns(Locale) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
指定ロケールでカラーパターン情報の一覧を取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.BaseTable のメソッド
基本テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable のメソッド
拡張基本テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable のメソッド
拡張国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable のメソッド
拡張期間国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable のメソッド
拡張期間化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable のメソッド
国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable のメソッド
期間国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable のメソッド
期間化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnName() - class jp.co.intra_mart.foundation.database.DatabaseColumn のメソッド

getColumnType() - class jp.co.intra_mart.foundation.database.DatabaseColumn のメソッド

getColumns() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張テーブルに含まれるカラムをすべて取得します。
getColumns() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
テーブルに含まれるカラムをすべて取得します。
getColumnsInfo() - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。
getComment() - class jp.co.intra_mart.foundation.navigator.TitleInfo のメソッド
コメント取得
getCommitCount() - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader のメソッド
コミット間隔を取得します。
getCompanyCategoryTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
指定された期間に対する期間化情報を取得します。
getCompanyCategoryTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
指定された日時に対する期間化情報を取得します。
getCompanyCd() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel のメソッド
会社CDを取得します。
getCompanyCd() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel のメソッド
会社CDを取得します。
getCompanyCd() - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel のメソッド
会社CDを取得します。
getCompanyCd() - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel のメソッド
会社CDを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct のメソッド
会社コードを取得する。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
会社コードを取得します。
getCompanyCode(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
会社コードを取得します。
getCompanyCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.security.DepartmentInfo のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.security.PostInfo のメソッド
会社コードを取得します。
getCompanyManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager の static メソッド
CompanyManagerを取得します。
getCompanyPostTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
指定された期間に対する期間化情報を取得します。
getCompanyPostTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
指定された日時に対する期間化情報を取得します。
getCompanyPostTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getCompanyTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
指定された期間に対する期間化情報を取得します。
getCompanyTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
指定された日時に対する期間化情報を取得します。
getCompanyTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getComparators() - class jp.co.intra_mart.foundation.utility.MultiComparator のメソッド
推奨されていません。 設定されている全てのコンパレータを取得します。
getConId() - interface jp.co.intra_mart.foundation.database.ConInfo のメソッド
接続参照名を取得します。
getConfigDayInfos() - class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo のメソッド
データタイプが名称であるカレンダーデータの一覧を取得します。
getConfigPageCount(String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
履歴表示件数の取得。
getConfigurationReader(InputStream) - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
入力ストリームからエクスポート設定情報を取得します。
getConfigurationReader(InputStream) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient のメソッド

getConfigurationReader(InputStream) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient のメソッド

getConfigurationReader(InputStream) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient のメソッド

getConfigurationReader(InputStream) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient のメソッド

getConfigurationReader(InputStream) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient のメソッド

getConfigurationReader(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
入力ストリームからポート設定情報を取得します。
getConfigurationReader(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient のメソッド

getConfigurationReader(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient のメソッド

getConfigurationReader(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient のメソッド

getConfigurationReader(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient のメソッド

getConfigurationReader(InputStream) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient のメソッド

getConnectIDs() - class jp.co.intra_mart.foundation.database.DbManager の static メソッド
推奨されていません。 DatabaseManager.getConnectIdsBySystem()を使用してください。
getConnectIdsBySystem() - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
システムに紐付くシステム接続名の一覧を取得します。
getConnectInfo() - class jp.co.intra_mart.foundation.database.DbManager のメソッド
推奨されていません。 代替えメソッドはありません。
getConnectTimeout() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
接続タイムアウト時間を取得する。
getConnectTimeoutPropertyName() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
接続タイムアウトを設定するプロパティ名を取得する。
getConnection(ConInfo) - interface jp.co.intra_mart.foundation.database.DatabaseAccessor のメソッド
Connectionオブジェクトを取得します。
getConnection(String, boolean) - class jp.co.intra_mart.foundation.database.DatabaseExport の static メソッド
推奨されていません。 データベースコネクションを取得します。
getConnection() - class jp.co.intra_mart.foundation.database.DbManager のメソッド
推奨されていません。 DatabaseManager.getLoginGroupConnection(String) および DatabaseManager.getSystemConnection(String)を使用してください。
getConnection() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
接続に利用したコネクションを返します。
getConnection() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
接続に利用したコネクションを返します。
getConnectionInfo() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベース設定情報を取得します。
getConnectionType() - interface jp.co.intra_mart.foundation.database.ConInfo のメソッド
接続の種別を取得します。
getContent() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
推奨されていません。 データ部を文字列表現として取得します。
getContent(String) - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
推奨されていません。 データ部を指定された文字コードで変換した結果を文字列表現として 取得します。
getContent() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL のメソッド
HTTPActionEventURL.getURL() によって表されるコンテンツのソースを取得します。
getContentLength() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
推奨されていません。 データ部のバイト長を取得します。
getContentTransferEncoding(Locale) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
Content-Transfer-Encodingを取得します。
getContentType() - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルのフォーマットを返却します。
getContentType(String) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
コンテントタイプを取得します。
getContents() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
新着情報の内容を取得します。
getContents() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
コンテンツの種類を取得します。
getContents() - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
コンテンツの種類を取得します。
getController(String, String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラ情報を取得します。
getController(String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラ情報を取得します。
getController(String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
指定されたアクセスコントローラIDに対応するアクセスコントローラを取得します。
getControllerDepartments(String, String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
すべてのアクセスコントローラ組織を取得します。
getControllerDepartments(String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
すべてのアクセスコントローラ組織を取得します。
getControllerDepartments(String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
アクセスコントローラに紐付いた組織の一覧を取得します。
getControllerId() - class jp.co.intra_mart.foundation.security.access.AccessController のメソッド
コントローラＩＤを取得します。
getControllerIds(String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
すべてのアクセスコントローラIDを取得します。
getControllerIds(String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
すべてのアクセスコントローラIDを取得します。
getControllerIds() - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
すべてのアクセスコントローラIDを取得します。
getControllerIdsByDepartment(String, DepartmentInfo[]) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
指定された組織を持つコントローラIDをすべて取得します。
getControllerIdsByDepartment(String, DepartmentInfo[]) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
指定された組織を持つコントローラIDをすべて取得します。
getControllerIdsByDepartment(DepartmentInfo[]) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
指定された組織を持つアクセスコントローラIDをすべて取得します。
getControllerIdsByPost(String, PostInfo[]) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
指定された役職を持つコントローラIDをすべて取得します。
getControllerIdsByPost(String, PostInfo[]) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
指定された役職を持つコントローラIDをすべて取得します。
getControllerIdsByPost(PostInfo[]) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
指定された役職を持つアクセスコントローラIDをすべて取得します。
getControllerIdsByPublicGroup(String, PublicGroupInfo[]) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
指定されたパブリックグループを持つコントローラIDをすべて取得します。
getControllerIdsByPublicGroup(String, PublicGroupInfo[]) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
指定されたパブリックグループを持つコントローラIDをすべて取得します。
getControllerIdsByPublicGroup(PublicGroupInfo[]) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
指定されたパブリックグループを持つアクセスコントローラIDをすべて取得します。
getControllerIdsByRole(String, String[]) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
指定されたロールIDを持つコントローラIDをすべて取得します。
getControllerIdsByRole(String, String[]) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
指定されたロールIDを持つコントローラIDをすべて取得します。
getControllerIdsByRole(String[]) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
指定されたロールIDを持つアクセスコントローラIDをすべて取得します。
getControllerIdsByUser(String, Date) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
指定されたユーザIDおよび日付で有効なアクセスコントローラIDをすべて取得します。
getControllerPosts(String, String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
すべてのアクセスコントローラ役職を取得します。
getControllerPosts(String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
すべてのアクセスコントローラ役職を取得します。
getControllerPosts(String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
アクセスコントローラに紐付いた役職の一覧を取得します。
getControllerPublicGroups(String, String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
すべてのアクセスコントローラパブリックグループを取得します。
getControllerPublicGroups(String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
すべてのアクセスコントローラパブリックグループを取得します。
getControllerPublicGroups(String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
アクセスコントローラに紐付いたパブリックグループの一覧を取得します。
getControllerRoles(String, String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
すべてのアクセスコントローラロールを取得します。
getControllerRoles(String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
すべてのアクセスコントローラロールを取得します。
getControllerRoles(String) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
アクセスコントローラに紐付いたロールの一覧を取得します。
getControllers(String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
すべてのアクセスコントローラ情報を取得します。
getControllers(String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
すべてのアクセスコントローラ情報を取得します。
getControllers() - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
すべてのアクセスコントローラを取得します。
getCookieSessionInfo() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報のクッキーからintra-martセッション情報を取得します。
getCookieSessionInfo(HttpServletRequest) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
クッキーからintra-martセッション情報を取得します。
getCount(String, String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定条件に該当する表内のデータ件数を取得する

getCountryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
国コードを取得します。
getCountryCode(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
国コードを取得します。
getCountryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
国コードを取得します。
getCountryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
国コードを取得します。
getCountryCode(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
国コードを取得します。
getCountryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
国コードを取得します。
getCountryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
国コードを取得します。
getCountryCode(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
国コードを取得します。
getCountryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
国コードを取得します。
getCountryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
国コードを取得します。
getCountryCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
国コードを取得します。
getCountryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
国コードを取得します。
getCountryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
国コードを取得します。
getCountryCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
国コードを取得します。
getCountryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
国コードを取得します。
getCreateSocketEventListeners() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 このプールに登録されている ソケットを新規に作成したイベントを通知するためのリスナーを 返します。
getCssFile() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンのCSSファイルパスを取得します。
getCssFiles() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンのCSSファイルパスの一覧を取得します。
getCurrencyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
通貨コードを取得します。
getCurrencyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
通貨コードを取得します。
getCurrencyCodes() - class jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager のメソッド
通貨コードの一覧を返します。
getCurrencyManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager の static メソッド
CurrencyManagerを取得します。
getCurrencyName(String, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager のメソッド
通貨コードに対する名称を指定された言語で返します。
getCurrencyName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager のメソッド
指定された通貨コードに対する名称を返します。
getCustomerCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
取引先会社コードを取得します。
getCustomerCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment のメソッド
取引先会社コードを取得します。
getCustomerCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup のメソッド
取引先会社コードを取得します。
getCustomerCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole のメソッド
取引先会社コードを取得します。
getCustomerCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
取引先会社コードを取得します。
getCustomerCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel のメソッド
取引先会社コードを取得します。
getCustomerCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
取引先会社コードを取得します。
getCustomerCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel のメソッド
取引先会社コードを取得します。
getCustomerCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel のメソッド
取引先会社コードを取得します。
getCustomerDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
取引先組織コードを取得します。
getCustomerDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment のメソッド
取引先組織コードを取得します。
getCustomerDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup のメソッド
取引先組織コードを取得します。
getCustomerDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole のメソッド
取引先組織コードを取得します。
getCustomerDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
取引先組織コードを取得します。
getCustomerDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel のメソッド
取引先組織コードを取得します。
getCustomerDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
取引先組織コードを取得します。
getCustomerDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel のメソッド
取引先組織コードを取得します。
getCustomerDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel のメソッド
取引先組織コードを取得します。
getData(String) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getAccount(String)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.isRegisteredAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.model.user.UserMapperを利用して取得してください。

getData(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRole(String)に置き換えられました。
getData(int) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
リスト内の指定された位置にあるデータを返します。
getData(int) - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
指定された位置にある値を返します。
getData(int) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
リスト内の指定された位置にあるデータを返します。
getData() - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
グラフ値を返します。
getData(int) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
リスト内の指定された位置にあるデータを返します。
getData(int) - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
指定された位置にある値を返します。
getData(int) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
リスト内の指定された位置にあるデータを返します。
getData(int) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
リスト内の指定された位置にあるデータを返します。
getData(int) - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
指定された位置にある値を返します。
getDataId() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
データＩＤを取得します。
getDataId() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
データIDを取得します。
getDataName() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
データ名称を取得します。
getDataSizeX() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｘ軸の中心値からのデータサイズを返します。
getDataSizeY() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｙ軸の中心値からのデータサイズを返します。
getDataSourceNameByLoginGroup(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
ログイングループIDからデータソース参照名を取得します。
getDataSourceNameBySystem(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
システム接続名からデータソース参照名を取得します。
getDataSourceRefName() - interface jp.co.intra_mart.foundation.database.ConInfo のメソッド
DataSourceへの参照名を取得します。
getDataType() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
データ型を取得します。
getDataType() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
データ型を取得します。
getDataType() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
データタイプを取得します。
getDataType() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
データタイプを取得します。
getDataX() - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
グラフのｘ値を返します。
getDataY() - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
グラフのｙ値を返します。
getDate() - interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader のメソッド
日付を取得します。
getDate() - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader のメソッド
日付を取得します。
getDate() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
日付を取得します。
getDate() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
対象の日付を取得します。
getDate() - class jp.co.intra_mart.foundation.security.password.PasswordHistory のメソッド
日付を取得します。
getDay() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
日を取得します。
getDay() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
日を取得します。
getDayInfo(CategorizedCalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
日付情報を取得します。
getDayWeek() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
曜日を取得します。
getDayWeek() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
曜日を取得します。
getDbName() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 このデータベース製品の名前を取得します。
getDbType(Connection) - class jp.co.intra_mart.foundation.database.DatabaseExport の static メソッド
推奨されていません。
getDbType(String) - class jp.co.intra_mart.foundation.database.DbTypes の static メソッド

getDbVersion() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 このデータベース製品のバージョンを取得します。
getDeal(String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
指定された取扱情報を返します。
getDealCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
取扱コードを取得します。
getDealCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment のメソッド
取扱コードを取得します。
getDealCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup のメソッド
取扱コードを取得します。
getDealCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole のメソッド
取扱コードを取得します。
getDealCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
取扱コードを取得します。
getDealCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel のメソッド
取扱コードを取得します。
getDealCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
取扱コードを取得します。
getDealCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel のメソッド
取扱コードを取得します。
getDealCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel のメソッド
取扱コードを取得します。
getDealManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager の static メソッド
DealManagerを取得します。
getDealName() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
取扱名を取得します。
getDealName() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
取扱名を取得します。
getDealPermissionManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager の static メソッド
DealPermissionManagerを取得します。
getDealTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
指定された期間に対する期間化情報を取得します。
getDealTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
指定された日時に対する期間化情報を取得します。
getDealType() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
取扱種別を取得します。
getDealType() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
取扱種別を取得します。
getDeals() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
現在、存在する取扱情報を返します。
getDeals(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
指定された日付に存在する取扱情報を返します。
getDealsByKey(String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
現在、存在する取扱情報の中で、商品と取引先から特定されるものを返します。
getDealsByKey(String, String, String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
指定された日時に存在する取扱情報の中で、商品と取引先から特定されるものを返します。
getDebugOption() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
JavaMailに設定するデバック設定の有無を取得します。
getDefaultCalendarId() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
デフォルトカレンダーIDを取得します。
getDefaultClientType() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
システムのデフォルトクライアントタイプを取得します。
getDefaultColorPatternId() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
デフォルトカラーパターンIDを取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
デフォルトの日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
デフォルトの日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
デフォルトの日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
デフォルトの日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
デフォルトの日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
デフォルトの日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
デフォルトの日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
デフォルトの日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
デフォルトの日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
デフォルトの日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
デフォルトの日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
デフォルトの日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
デフォルトの日時を取得します。
getDefaultDate() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
デフォルト日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
モデル生成時に設定されたデフォルト日時を取得します。
getDefaultEncoding(Locale) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
ロケールに対応するデフォルトエンコーディングを取得します。
getDefaultImportPath() - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
インポートファイルのデフォルトパス情報を取得します。
getDefaultImportPath() - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient のメソッド

getDefaultImportPath() - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient のメソッド

getDefaultImportPath() - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient のメソッド

getDefaultImportPath() - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient のメソッド

getDefaultImportPath() - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient のメソッド

getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
デフォルトのロケールを取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
デフォルトのロケールを取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
デフォルトのロケールを取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
デフォルトのロケールを取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
デフォルトのロケールを取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
デフォルトのロケールを取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
デフォルトのロケールを取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
デフォルトのロケールを取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
デフォルトのロケールを取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
デフォルトのロケールを取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
デフォルトのロケールを取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
デフォルトのロケールを取得します。
getDefaultLocale() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
デフォルト言語を取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
モデル生成時に設定されたデフォルト言語を取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
モデル生成時に指定された言語を取得します。
getDefaultLocale() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
デフォルト言語を取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
デフォルトロケールを取得します。
getDefaultPath() - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
エクスポート情報の出力ファイルのデフォルトパス情報を取得します。
getDefaultPath() - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient のメソッド

getDefaultPath() - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient のメソッド

getDefaultPath() - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient のメソッド

getDefaultPath() - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient のメソッド

getDefaultPath() - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient のメソッド

getDelete() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ターゲットエンティティのデータ削除時の整合性制約を取得します。
getDeleteType() - interface jp.co.intra_mart.foundation.datastore.common.config.Delete のメソッド
ターゲットエンティティの削除時の整合性制約のタイプを取得します。
getDepartment(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の組織を取得します。
getDepartment(int) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

getDepartmentAttach(String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
ユーザの組織への所属情報を取得します。
getDepartmentAttachTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
指定された期間に対する期間化情報を取得します。
getDepartmentAttachTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
指定された日時に対する期間化情報を取得します。
getDepartmentCd() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel のメソッド
組織CDを取得します。
getDepartmentCd() - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel のメソッド
組織CDを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct のメソッド
組織コードを取得する。
getDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
組織コードを取得します。
getDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
組織コードを取得します。
getDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織コードを取得します。
getDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
組織コードを取得します。
getDepartmentCode(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
組織コードを取得します。
getDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable のメソッド
組織コードを取得します。
getDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
組織コードを取得します。
getDepartmentCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel のメソッド
組織コードを取得します。
getDepartmentCode() - class jp.co.intra_mart.foundation.security.DepartmentInfo のメソッド
組織コードを取得します。
getDepartmentMain(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
ユーザの主所属情報を取得します。
getDepartmentMainTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
指定された期間に対する期間化情報を取得します。
getDepartmentMainTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
指定された日時に対する期間化情報を取得します。
getDepartmentStructs(String, String, Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織の階層構造を取得します。
getDepartmentTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
指定された期間に対する期間化情報を取得します。
getDepartmentTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
指定された日時に対する期間化情報を取得します。
getDepartmentTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getDepartments(Deal) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager のメソッド
取扱情報を保有するアクセス権をもつ組織を返します。
getDepartments() - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

getDepth() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
階層レベルを取得します。
getDepth() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
階層レベルを取得します。
getDescription() - class jp.co.intra_mart.foundation.security.access.AccessController のメソッド
説明を取得します。
getDescription() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
説明を取得します。
getDescription() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチ内容を取得します。
getDescription() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
データの説明を取得します。
getDescription() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
説明を取得します。
getDescription() - class jp.co.intra_mart.foundation.security.role.Role のメソッド
説明を取得します。
getDetail() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryResult のメソッド
詳細メッセージを取得します。
getDetails() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable のメソッド
取扱詳細の一覧を取得します。
getDisplayName() - interface jp.co.intra_mart.foundation.security.ClientTypeInfo のメソッド
クライアントタイプ表示名を取得する。
getDisplayName() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターン表示名を取得します。
getDisplayName() - interface jp.co.intra_mart.foundation.security.LocaleInfo のメソッド
ロケ－ル表示名取得。
getDisplayName() - class jp.co.intra_mart.foundation.security.access.AccessController のメソッド
表示名を取得します。
getDisplayName() - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
マイメニュー表示名を取得します。
getDisplayName(Locale) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
表示名を取得します。
getDisplayName(Locale) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニュー名を取得します。
getDisplayName(Locale) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロール表示名を取得します。
getDisplayName() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
データ表示名を取得します。
getDisplayName(Locale) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
データ表示名を取得します。
getDisplayName() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoInternationalModel のメソッド
データ表示名を取得します。
getDisplayName() - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel のメソッド
メニュー表示名を取得します。
getDisplayName() - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
メニュー表示名を取得します。
getDisplayName(Locale) - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
メニュー表示名を取得します。
getDisplayName() - interface jp.co.intra_mart.system.security.datastore.inf.MenuInternationalModel のメソッド
メニュー表示名を取得します。
getDisplayName() - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
ロール表示名を取得します。
getDisplayName(Locale) - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
ロール表示名を取得します。
getDisplayName() - interface jp.co.intra_mart.system.security.datastore.inf.RoleInternationalModel のメソッド
ロール表示名を取得します。
getDuplicateLoginDetectionPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor のメソッド
引数で指定されたアクティブなセッション情報が重複ログインした場合の遷移先ページURLを取得します。
getDuplicateLoginDetectionPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager のメソッド
引数で指定されたアクティブなセッション情報が重複ログインした場合の遷移先ページURLを取得します。
getDuplicateLoginDetectionPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor のメソッド
引数で指定されたアクティブなセッション情報が重複ログインした場合の遷移先ページURLを取得します。
getEmailAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
メールアドレス1を取得します。
getEmailAddress1(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
メールアドレス1を取得します。
getEmailAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
メールアドレス1を取得します。
getEmailAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
メールアドレス1を取得します。
getEmailAddress1(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
メールアドレス1を取得します。
getEmailAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
メールアドレス1を取得します。
getEmailAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
メールアドレス１を取得します。
getEmailAddress1(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
メールアドレス１を取得します。
getEmailAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
メールアドレス１を取得します。
getEmailAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス1を取得します。
getEmailAddress1(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス1を取得します。
getEmailAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
メールアドレス1を取得します。
getEmailAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス１を取得します。
getEmailAddress1(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス１を取得します。
getEmailAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
メールアドレス１を取得します。
getEmailAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
メールアドレス2を取得します。
getEmailAddress2(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
メールアドレス2を取得します。
getEmailAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
メールアドレス2を取得します。
getEmailAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
メールアドレス2を取得します。
getEmailAddress2(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
メールアドレス2を取得します。
getEmailAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
メールアドレス2を取得します。
getEmailAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
メールアドレス２を取得します。
getEmailAddress2(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
メールアドレス２を取得します。
getEmailAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
メールアドレス２を取得します。
getEmailAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス2を取得します。
getEmailAddress2(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス2を取得します。
getEmailAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
メールアドレス2を取得します。
getEmailAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス２を取得します。
getEmailAddress2(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス２を取得します。
getEmailAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
メールアドレス２を取得します。
getEncoding() - interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader のメソッド
エクスポートデータのエンコーディング情報を取得します。
getEncoding() - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader のメソッド
インポートデータのエンコーディング情報を取得します。
getEncoding() - interface jp.co.intra_mart.foundation.security.LocaleInfo のメソッド
デフォルトエンコーディングの取得。
getEncoding() - interface jp.co.intra_mart.foundation.security.LocaleProvider のメソッド
エンコーディングを取得する。
getEncoding() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
エンコーディングを取得する。
getEncoding() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
エンコーディング情報を取得します。
getEncoding() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
エンコーディングの取得。
getEncoding() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
エンコーディングを取得する。
getEncoding() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
エンコーディングを取得する。
getEncoding() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
エンコーディングを取得します。
getEncoding() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
エンコーディングを取得します。
getEncodingName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
エンコーディングをセッションに保管するためのパラメータ名を取得する。
getEncodings() - interface jp.co.intra_mart.foundation.security.LocaleInfo のメソッド
ロケ－ルに対応しているエンコーディングの一覧の取得。
getEndDate() - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
終了日を取得します。
getEndDate() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
終了日を取得します。
getEndDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
終了日を取得します。
getEndDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
終了日を取得します。
getEndDateColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable のメソッド
期間の日時に該当するカラムのカラム名を取得します。
getEntities() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義しているエンティティの一覧を取得します。
getEntities(String) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 指定の名前を持つエンティティをすべて取得します。
getEntity() - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
アクセサの基となるエンティティを取得します。
getEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性が定義されているエンティティを取得します。
getEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張対象となるエンティティを取得します。
getEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
モデル定義の基となるエンティティを取得します。
getEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
テーブル定義の基となるエンティティを取得します。
getEntity(int) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 指定のインデックスに該当するエンティティを取得します。
getEntity(String) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 指定の名前を持つエンティティを取得します。
getEntityName() - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
マッパーがアクセスするエンティティ名を取得します。
getEnvironment() - class jp.co.intra_mart.foundation.service.provider.Platform の static メソッド
システムの設定値を持つオブジェクトを取得します。
getEnvironmentProperty(String) - class jp.co.intra_mart.foundation.service.provider.Platform の static メソッド
指定のキーに対応するシステムの設定値を取得します。
getErrCode() - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 メール送信時のエラーコードを返す。
getErrMessage() - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 メール送信時のエラーメッセージを返す。
getErrorPage(int) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報からエラーページＵＲＬを取得します。
getErrorPage(int, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
エラーページＵＲＬを取得します。
getErrorPage(String) - interface jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor のメソッド
エラーページのパスを取得します。
getErrorPage() - class jp.co.intra_mart.foundation.security.shortcut.ShortCutManager のメソッド
ショートカットエラーページ取得。
getErrorPage(String) - class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor のメソッド
エラーページのパスを取得します。
getErrorType() - class jp.co.intra_mart.foundation.database.exception.DatabaseExportException のメソッド
推奨されていません。
getEscape() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 ワイルドカード文字をエスケープするのに使用できる文字列を取得します。
getEventFlow(EventNavigatorManager, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
getEventFlow(String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
getEventFlow(EventNavigatorManager, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
イベントフローの取得 イベントフローIDから、イベントフローを取得し、返却する。
getEventFlowIds(EventNavigatorManager) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
すべてのイベントフローIDを取得します。
getEventFlowIds(EventNavigatorManager) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
すべてのイベントフローIDを取得します。
getEventFlowInfos(EventNavigatorManager, String, boolean, int) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
getEventFlowInfos(String, boolean, int) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
getEventFlowInfos(EventNavigatorManager, String, boolean, int) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
イベントフロー情報一覧（検索タイトル）の取得 検索タイトル、ロケールで検索し、イベントフロー情報一覧を取得、返却する。
getEventFlows(EventNavigatorManager) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
すべてのイベントフローを取得します。
getEventFlows() - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
イベントフローの取得（全件） 全イベントフローを取得し、返却する。
getEventFlows(EventNavigatorManager) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
すべてのイベントフローを取得します。
getEventHistory() - class jp.co.intra_mart.foundation.navigator.EventItemInfo のメソッド
イベント履歴情報リスト取得
getEventHistory() - class jp.co.intra_mart.foundation.navigator.EventResultItemInfo のメソッド
イベント履歴情報リスト取得
getEventHistory() - class jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo のメソッド
イベント履歴情報リスト取得
getEventItemInfo(EventNavigatorManager, String, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
getEventItemInfo(String, String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
getEventItemInfo(EventNavigatorManager, String, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
イベントアイテム情報の取得 イベントフローIDからイベントアイテム情報を取得し、返却する。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventResultItemInfo(EventNavigatorManager, String, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
getEventResultItemInfo(String, String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
getEventResultItemInfo(EventNavigatorManager, String, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
ナビゲート結果情報の取得 イベントフローID、ナビゲート結果IDからナビゲート結果情報を取得し、返却する。
getException() - class jp.co.intra_mart.foundation.utility.ErrorEvent のメソッド
推奨されていません。 通知されたエラーまたは例外を取得します。
getExecuteUser() - interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader のメソッド
実行ユーザコードを取得します。
getExecuteUser() - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader のメソッド
実行ユーザコードを取得します。
getExecutingLineNumber() - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 現在エクスポート実行中の行番号を返します。
getExpirationDate() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
役職情報の有効終了日を取得します。
getExpirationDate() - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
終了時間を取得します。
getExpirationKey() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ソースエンティティのライフタイム期間の有効終了日時を取得します。
getExpireInterval() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
クライアントのアクセスとアクセスの間に、サーブレットコンテナがこのセッションを保ち続ける最大の時間間隔を秒数で返します。
getExpiredDate() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
試用期限の日付を取得します。
getExplain() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
説明を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
アクセスコントローラエクスポート用のカテゴリの一覧を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントエクスポート用のカテゴリの一覧を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチエクスポート用のカテゴリの一覧を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーエクスポート用のカテゴリの一覧を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
管理メニューエクスポート用のカテゴリの一覧を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューエクスポート用のカテゴリの一覧を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロールエクスポート用のカテゴリの一覧を取得します。
getExportManager() - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
エクスポートマネージャーのインスタンスを取得します。
getExportManager() - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient のメソッド

getExportManager() - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient のメソッド

getExportManager() - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient のメソッド

getExportManager() - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient のメソッド

getExportManager() - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient のメソッド

getExtendedBaseAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
基本アクセサに関連する拡張基本アクセサのマップを取得します。
getExtendedBaseModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張基本モデルを取得します。
getExtendedBaseModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel のメソッド
拡張基本エンティティに対応する拡張基本モデルのマップを取得します。
getExtendedBaseModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
拡張基本モデルマップを取得します。
getExtendedBaseModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
拡張基本モデルのマップを取得します。
getExtendedBaseTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張基本テーブルを取得します。
getExtendedDepartment(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
指定された拡張情報を取得します。
getExtendedDepartmentTerminable(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
指定された拡張情報を取得します。
getExtendedDepartmentTerminableInternational(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
指定された拡張情報を取得します。
getExtendedDepartmentTerminableInternationals() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
この組織の基本情報に対する拡張情報をすべて取得します。
getExtendedDepartmentTerminables() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
この組織の期間化情報に対する拡張情報をすべて取得します。
getExtendedDepartments() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
この組織の基本情報に対する拡張情報をすべて取得します。
getExtendedEntities() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義している拡張エンティティの一覧を取得します。
getExtendedEntities() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
このエンティティを拡張している拡張エンティティをすべて取得します。
getExtendedEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性が定義されている拡張エンティティを取得します。
getExtendedEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張モデル定義の基となる拡張エンティティを取得します。
getExtendedEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張テーブル定義の基となる拡張エンティティを取得します。
getExtendedInternationalAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor のメソッド
この国際化アクセサに対する拡張国際化アクセサのマップを取得します。
getExtendedInternationalModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張国際化モデルを取得します。
getExtendedInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のメソッド
拡張国際化モデルのマップを取得します。
getExtendedInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel のメソッド
拡張国際化エンティティに対応する拡張国際化モデルのマップを取得します。
getExtendedInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext のメソッド
拡張国際化モデルマップを取得します。
getExtendedInternationalTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張国際化テーブルを取得します。
getExtendedMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider のメソッド
拡張メインページURLを取得します。
getExtendedMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider のメソッド
拡張メインページURLを取得します。
getExtendedMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryUserPageProvider のメソッド

getExtendedModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseModel のメソッド
拡張基本モデルが定義されている拡張モデル定義を取得します。
getExtendedModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
この拡張エンティティを参照している拡張モデルを取得します。
getExtendedModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalModel のメソッド
拡張国際化モデルが定義されている拡張モデル定義を取得します。
getExtendedModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalModel のメソッド
拡張期間国際化モデルが定義されている拡張モデル定義を取得します。
getExtendedModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableModel のメソッド
拡張期間化モデルが定義されている拡張モデル定義を取得します。
getExtendedModels() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義している拡張モデル定義の一覧を取得します。
getExtendedTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable のメソッド
拡張基本テーブルが定義されている拡張テーブル定義を取得します。
getExtendedTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
この拡張エンティティを参照している拡張テーブルを取得します。
getExtendedTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable のメソッド
拡張国際化テーブルが定義されている拡張テーブル定義を取得します。
getExtendedTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable のメソッド
拡張期間国際化テーブルが定義されている拡張テーブル定義を取得します。
getExtendedTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable のメソッド
拡張期間化テーブルが定義されている拡張テーブル定義を取得します。
getExtendedTables() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義している拡張テーブル定義の一覧を取得します。
getExtendedTerminableAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
この期間化アクセサに対する拡張期間化アクセサのマップを取得します。
getExtendedTerminableInternationalAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor のメソッド
この期間国際化アクセサの拡張期間国際化アクセサのマップを取得します。
getExtendedTerminableInternationalModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張期間国際化モデルを取得します。
getExtendedTerminableInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のメソッド
拡張期間国際化モデルのマップを取得します。
getExtendedTerminableInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel のメソッド
拡張期間国際化エンティティに対応する拡張期間国際化モデルのマップを取得します。
getExtendedTerminableInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext のメソッド
拡張期間国際化モデルマップを取得します。
getExtendedTerminableInternationalTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張期間国際化テーブルを取得します。
getExtendedTerminableModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張期間化モデルを取得します。
getExtendedTerminableModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
拡張期間化モデルのマップを取得します。
getExtendedTerminableModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel のメソッド
拡張期間化エンティティに対応する拡張期間化モデルのマップを取得します。
getExtendedTerminableModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
拡張期間化モデルマップを取得します。
getExtendedTerminableTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張期間化テーブルを取得します。
getExtendedUser(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
指定された拡張情報を取得します。
getExtendedUserTerminable(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
指定された拡張情報を取得します。
getExtendedUserTerminableInternational(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
指定された拡張情報を取得します。
getExtendedUserTerminableInternationals() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
このユーザの基本情報に対する拡張情報をすべて取得します。
getExtendedUserTerminables() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
このユーザの期間化情報に対する拡張情報をすべて取得します。
getExtendedUsers() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
このユーザの基本情報に対する拡張情報をすべて取得します。
getExtensionFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
内線FAX番号を取得します。
getExtensionNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
内線番号を取得します。
getExtensionNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
内線番号を取得します。
getExtensionNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
内線番号を取得します。
getExtensionNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
内線番号を取得します。
getExtensionNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
内線番号を取得します。
getExtensionNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
内線番号を取得します。
getExtensionNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
内線番号を取得します。
getExtensionNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
内線番号を取得します。
getExtensionNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
内線番号を取得します。
getExtensionNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線番号を取得します。
getExtensionNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線番号を取得します。
getExtensionNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
内線番号を取得します。
getExtensionNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線番号を取得します。
getExtensionNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線番号を取得します。
getExtensionNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
内線番号を取得します。
getExtensionParameterNames() - interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader のメソッド
パラメータ名の一覧を取得します。
getExtensionParameterNames() - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader のメソッド
パラメータ名の一覧を取得します。
getExtensionParameterValue(String) - interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader のメソッド
指定されたキーに対するパラメータ値を取得します。
getExtensionParameterValue(String) - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader のメソッド
指定されたキーに対するパラメータ値を取得します。
getFavoriteMenu(String, String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
マイメニュー情報を取得する。
getFavoriteMenu(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
マイメニュー情報を取得する。
getFavoriteMenuIds(String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
マイメニューIDをすべて取得する。
getFavoriteMenuIds(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
マイメニューIDをすべて取得する。
getFavoriteMenuIds(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
マイメニューIDをすべて取得します。
getFavoriteMenus(String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
マイメニュー情報をすべて取得する。
getFavoriteMenus(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
マイメニュー情報をすべて取得する。
getFavoriteMenus(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
マイメニューをすべて取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
FAX番号を取得します。
getFaxNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
FAX番号を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
FAX番号を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
FAX番号を取得します。
getFaxNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
FAX番号を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
FAX番号を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
FAX番号を取得します。
getFaxNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
FAX番号を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
FAX番号を取得します。
getFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
FAX番号を取得します。
getFaxNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
FAX番号を取得します。
getFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
FAX番号を取得します。
getFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
FAX番号を取得します。
getFaxNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
FAX番号を取得します。
getFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
FAX番号を取得します。
getFile() - interface jp.co.intra_mart.foundation.mail.javamail.model.AttachmentFile のメソッド
添付ファイルを取得します。
getFile(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
このオブジェクトの表すディレクトリにキー id でマップされた ExternalMemory インスタンスを取得します。
getFile(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
このオブジェクトの表すディレクトリにキー id でマップされた PermanentFile インスタンスを取得します。
getFile(String) - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
このオブジェクトの表すディレクトリにキー id でマップされた SessionMemory インスタンスを取得します。
getFile() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
現在有効なセッションを扱う SessionMemory インスタンスを取得します。
getFile(String) - interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory のメソッド
このオブジェクトの表すディレクトリにキー id でマップされた TreasureFile インスタンスを取得します。
getFile() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 このオブジェクトが文字を書き出すファイルを取得します。
getFileName() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
推奨されていません。 アップロードされたファイルのファイル名を取得します。
getFill() - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
描画されるグラフの塗りつぶし可否を返します。
getFilter() - interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader のメソッド
エクスポートのフィルタ情報を取得します。
getFilterParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このフィルタのパラメータを返します。
getFilterParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このハンドラによって実行されるフィルタイベントに対する 設定済みパラメータのマップを返します。
getFirstMenuIds(String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
第一階層に属するメニューIDを配列で取得します。
getFirstMenuIds() - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
第一階層に属するノードを配列で取得します。
getFirstMenuIds() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
第一階層のメニューIDをすべて取得します。
getFirstMenuIds(String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
第一階層に属するノードを配列で取得します。
getFirstMenuIds() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
第一階層のメニューIDをすべて取得します。
getFontColor() - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
キャプションの文字色を返します。
getFontSize() - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
キャプションの文字サイズを返します。
getForeignKeys() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ソースエンティティの外部キーの集合を取得します。
getFormat() - class jp.co.intra_mart.foundation.database.DatabaseColumn のメソッド

getFormat() - interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader のメソッド
エクスポートデータのフォーマットを取得します。
getFormat() - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader のメソッド
インポートデータのフォーマットを取得します。
getFrom() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Fromを取得します。
getGoOut() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
外出フラグを取得します。
getGraphBackgroundColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
グラフ領域の背景色を返します。
getGraphBackgroundColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
グラフ領域の背景色を返します。
getGraphBackgroundColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
グラフ領域の背景色を返します。
getGraphBorderColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
グラフ領域のボーダーの色を返します。
getGraphBorderColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
グラフ領域のボーダーの色を返します。
getGraphBorderColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
グラフ領域のボーダーの色を返します。
getGraphFrameColor() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
グラフ枠の線色を返します。
getGroup() - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler のメソッド
設定されているグループＩＤを返します。
getGroupCode() - class jp.co.intra_mart.foundation.security.PublicGroupInfo のメソッド
グループコードを取得します。
getGroupDatabaseType(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
ログイングループデータソースおけるデータベースの種類を取得する。
getGroupErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
ログイングループエラーページURLを取得する。
getGroupErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
ログイングループエラーページURLを取得します。
getGroupId() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
ログイングループIDを取得する。
getGroupId() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド

getGroupId() - class jp.co.intra_mart.foundation.update.UpdateManager のメソッド
ログイングループIDを取得します。
getGroupImageIcons() - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
すべてのグループイメージアイコンを取得します。
getGroupSetCode() - class jp.co.intra_mart.foundation.security.PublicGroupInfo のメソッド
グループセットコードを取得します。
getHTML() - interface jp.co.intra_mart.foundation.portal.common.rss.RSSParserIF のメソッド
解析結果HTMLを返却します
getHandlerName(String) - class jp.co.intra_mart.foundation.commons.SourceProviderHandler のメソッド
ソースプロバイダクラス名を取得します。
getHeader(String) - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
推奨されていません。 ヘッダの取得。
getHeaderNames() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
推奨されていません。 ヘッダ名称一覧の取得。
getHeight() - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルの高さを返却します。
getHeight() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
表示単位に対する高さを取得します。
getHodildayInfos() - class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo のメソッド
データタイプが休日であるカレンダーデータの一覧を取得します。
getHoldability() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection オブジェクトを使用して生成された ResultSet オブジェクトの現在の保持機能を取得します。
getHostAddress() - class jp.co.intra_mart.foundation.utility.net.Localhost のメソッド
推奨されていません。 このコンピュータのアドレスを返します。
getHostName() - class jp.co.intra_mart.foundation.utility.net.Localhost のメソッド
推奨されていません。 このコンピュータのホスト名を返します。
getHttpServletRequest() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
現在のイベントを要求したリクエストを返します。
getIDs() - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getUserIds()に置き換えられました。
getIDs() - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRoleIds()に置き換えられました。
getId() - class jp.co.intra_mart.foundation.navigator.EventFlow のメソッド

getId() - class jp.co.intra_mart.foundation.navigator.EventFlowInfo のメソッド
イベントフローID取得
getId() - class jp.co.intra_mart.foundation.navigator.EventHistoryInfo のメソッド
イベントアイテムID取得
getId() - class jp.co.intra_mart.foundation.navigator.EventItemInfo のメソッド
イベントアイテムID取得
getId() - class jp.co.intra_mart.foundation.navigator.EventResultItemInfo のメソッド
ナビゲート結果ID取得
getId() - class jp.co.intra_mart.foundation.navigator.ResultPageItemInfo のメソッド
保存結果ページID取得
getId() - class jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo のメソッド
保存ナビゲート結果ID取得
getId() - class jp.co.intra_mart.foundation.navigator.SelectItemInfo のメソッド
選択アイテムID取得
getId() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニューIDを取得します。
getIdByName(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.searchRolesByName(String)に置き換えられました。
getIdentifier() - interface jp.co.intra_mart.foundation.database.ConInfo のメソッド
コネクションの識別子を取得します。
getImageBackgroundColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
画像ファイルの背景色を返します。
getImageBackgroundColor() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
画像ファイルの背景色を返します。
getImageBackgroundColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
画像ファイルの背景色を返します。
getImageBackgroundColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
画像ファイルの背景色を返します。
getImageBackgroundColor() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
画像ファイルの背景色を返します。
getImageBorderColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
画像ファイルのボーダ色を返します。
getImageBorderColor() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
画像ファイルのボーダ色を返します。
getImageBorderColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
画像ファイルのボーダ色を返します。
getImageBorderColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
画像ファイルのボーダ色を返します。
getImageBorderColor() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
画像ファイルのボーダ色を返します。
getImageFolder() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンのイメージファイルのフォルダを取得します。
getImageIcon(String) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
イメージアイコン情報を取得します。
getImageIconCd() - class jp.co.intra_mart.foundation.image.ImageIconInfo のメソッド
イメージアイコンコードを取得する。
getImagePath() - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
マイメニューイメージを取得します。
getImagePath() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニューイメージパスを取得します。
getImagePath() - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel のメソッド
イメージパスを取得します。
getImagePath() - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
イメージパスを取得します。
getImgaeBackgroundColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
推奨されていません。
getImgaeBackgroundColor() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
推奨されていません。
getImgaeBackgroundColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
推奨されていません。
getImgaeBackgroundColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
推奨されていません。
getImgaeBackgroundColor() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
推奨されていません。
getImgaeBorderColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
推奨されていません。
getImgaeBorderColor() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
推奨されていません。
getImgaeBorderColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
推奨されていません。
getImgaeBorderColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
推奨されていません。
getImgaeBorderColor() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
推奨されていません。
getImportCategories() - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
アクセスコントローラインポート用のカテゴリの一覧を取得します。
getImportCategories() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントインポート用のカテゴリの一覧を取得します。
getImportCategories() - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチインポート用のカテゴリの一覧を取得します。
getImportCategories() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーインポート用のカテゴリの一覧を取得します。
getImportCategories() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
管理メニューインポート用のカテゴリの一覧を取得します。
getImportCategories() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューインポート用のカテゴリの一覧を取得します。
getImportCategories() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロールインポート用のカテゴリの一覧を取得します。
getImportFileSet(String) - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader のメソッド
インポートデータのファイルパスの一覧を取得します。
getImportManager() - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
インポートマネージャーのインスタンスを取得します。
getImportManager() - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient のメソッド

getImportManager() - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient のメソッド

getImportManager() - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient のメソッド

getImportManager() - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient のメソッド

getImportManager() - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient のメソッド

getIndex() - class jp.co.intra_mart.foundation.database.DatabaseColumn のメソッド

getInitalPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider のメソッド
初期ページURLを取得します。
getInitalPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider のメソッド
初期ページURLを取得する。
getInitalPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider のメソッド
初期ページURLを取得する。
getInitalPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider のメソッド
初期ページURLを取得します。
getInitalPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.UserPageProvider のメソッド
初期ページURLを取得する。
getInitialCertification(LoginRequestInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッドの情報から初期アクセス処理を行います。
getInitialCertification(LoginRequestInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
初期アクセス処理を行います。
getInitialPage() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報から初期アクセスページURLを取得します。
getInitialPage(SessionInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報から初期アクセスページURLを取得します。
getInitialPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
初期アクセスページURLを取得します。
getInitialUrl() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
初期ページURLを取得します。
getInitialUrl() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
初期アクセスURLを取得する。
getInitialUrlName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
初期ページURLをセッションに保管するためパラメータ名を取得する。
getInputStream() - interface jp.co.intra_mart.foundation.database.DataSourceProvider のメソッド
データソース設定ファイルのストリームを取得します。
getInputStream() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
推奨されていません。 データ部を入力ストリームとして取得します。
getInputStream() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
サーバからの入力を受け付ける入力ストリームを返します。
getInputStream() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
サーバからの入力を受け付ける入力ストリームを返します。
getInputStream() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 入力ストリームの取得。
getInstallDate() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
インストールされた日付を取得します。
getInstance() - class jp.co.intra_mart.foundation.commons.ParameterManager の static メソッド
インスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.commons.SourceProviderHandler の static メソッド
インスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.database.DatabaseExport の static メソッド
推奨されていません。 DatabaseExportインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.database.DatabaseManager の static メソッド
データべースマネージャインスタンスを生成します。
getInstance() - class jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory の static メソッド
ConfigurationFactoryのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler の static メソッド
JavaMailPropertyHandlerのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.portal.portlet.PortletMapping の static メソッド
インスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.security.AccessSecurityManager の static メソッド
セキュリティマネージャのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.security.ExtendsImportManager の static メソッド

getInstance() - class jp.co.intra_mart.foundation.security.SystemManager の static メソッド
システムマネージャインスタンスを生成します。
getInstance() - class jp.co.intra_mart.foundation.security.group.LoginGroupManager の static メソッド
ログイングループマネージャのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager の static メソッド
ログイングループマネージャのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.security.message.MessageManager の static メソッド
メッセージマネージャのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.service.client.file.AbstractComponent の static メソッド
このクラスの新しいインスタンスを取得します。
getInstance(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory の static メソッド
共有データを扱うためのオブジェクトを取得します。
getInstance(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory の static メソッド
共有データを扱うためのオブジェクトを取得します。
getInternationalAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor のメソッド
拡張もととなる国際化アクセサを取得します。
getInternationalAccessor() - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のメソッド
この国際化モデルに割り当てられた国際化アクセサを取得します。
getInternationalAccessor() - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext のメソッド
国際化アクセサを取得します。
getInternationalAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
基本アクセサに関連する国際化アクセサのマップを取得します。
getInternationalKey() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ソースエンティティの国際化基準項目を取得します。
getInternationalModel() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
国際化モデルを取得します。
getInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel のメソッド
国際化モデルのマップを取得します。
getInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
国際化モデルマップを取得します。
getInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
国際化モデルのマップを取得します。
getInternationalTable() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
国際化テーブルを取得します。
getInvalidateLoginType() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
無効化したユーザのログインタイプを取得する。
getInvalidateOtherSessionsAttributeName() - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager のメソッド
現在のセッション以外のアクティブなセッション情報を削除するために使用する属性名を取得します。
getInvalidateTime() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
無効化された時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を取得する。
getInvalidateUserId() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
無効化したユーザのログインユーザIDを取得する。
getInvalidatedActiveSessionInfo(String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
無効化されたアクティブなセッション情報を取得します。
getInvalidatedActiveSessionInfo(String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
無効化されたアクティブなセッション情報を取得します。
getInvalidatedActiveSessionInfo(String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
無効化されたアクティブなセッション情報を取得します。
getItem(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
指定された商品コードに対する商品の情報を返します。
getItemAttributeInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
指定された言語に対する国際化情報を取得します。
getItemCaption() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
商品通称を取得します。
getItemCaption(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
商品通称を取得します。
getItemCaption(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
商品通称を取得します。
getItemCaption(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
商品通称を取得します。
getItemCaption() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminableInternational のメソッド
商品通称を取得します。
getItemCaption() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品通称を取得します。
getItemCaption(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品通称を取得します。
getItemCaption(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品通称を取得します。
getItemCaption(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品通称を取得します。
getItemCaption() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableInternationalModel のメソッド
商品通称を取得します。
getItemCaption() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
商品通称を取得します。
getItemCaption(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
商品通称を取得します。
getItemCatalogueCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のメソッド
商品カタログコードを取得します。
getItemCatalogueCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel のメソッド
商品カタログコードを取得します。
getItemCategoryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach のメソッド
商品カテゴリコードを取得します。
getItemCategoryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
商品カテゴリコードを取得します。
getItemCategoryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel のメソッド
商品カテゴリコードを取得します。
getItemCategoryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
商品カテゴリコードを取得します。
getItemCategoryInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
指定された言語に対する国際化情報を取得します。
getItemCategoryManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager の static メソッド
ItemCategoryManagerを取得します。
getItemCategoryName() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
商品カテゴリ名を取得します。
getItemCategoryName(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
商品カテゴリ名を取得します。
getItemCategoryName() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategoryInternational のメソッド
商品カテゴリ名を取得します。
getItemCategoryName() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
商品カテゴリ名を取得します。
getItemCategoryName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
商品カテゴリ名を取得します。
getItemCategoryName() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryInternationalModel のメソッド
商品カテゴリ名を取得します。
getItemCategoryTypeCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach のメソッド
商品カテゴリ種別コードを取得します。
getItemCategoryTypeCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
商品カテゴリ種別コードを取得します。
getItemCategoryTypeCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.type.ItemCategoryType のメソッド
商品カテゴリ種別コードを取得します。
getItemCategoryTypeCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel のメソッド
商品カテゴリ種別コードを取得します。
getItemCategoryTypeCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
商品カテゴリ種別コードを取得します。
getItemCategoryTypeCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel のメソッド
商品カテゴリ種別コードを取得します。
getItemCateogry() - interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryStruct のメソッド
商品カテゴリを取得します。
getItemCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail のメソッド
商品コードを取得します。
getItemCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
商品コードを取得します。
getItemCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のメソッド
商品コードを取得します。
getItemCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
商品コードを取得します。
getItemCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach のメソッド
商品コードを取得します。
getItemCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
商品コードを取得します。
getItemCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel のメソッド
商品コードを取得します。
getItemCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel のメソッド
商品コードを取得します。
getItemCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品コードを取得します。
getItemCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel のメソッド
商品コードを取得します。
getItemManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager の static メソッド
ItemManagerを取得します。
getItemName() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
商品名を取得します。
getItemName(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
商品名を取得します。
getItemName(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
商品名を取得します。
getItemName(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
商品名を取得します。
getItemName() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminableInternational のメソッド
商品名を取得します。
getItemName() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品名を取得します。
getItemName(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品名を取得します。
getItemName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品名を取得します。
getItemName(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品名を取得します。
getItemName() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableInternationalModel のメソッド
商品名を取得します。
getItemName() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
商品名を取得します。
getItemName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
商品名を取得します。
getItemTemplateDetailInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
指定された言語に対する国際化情報を取得します。
getItemTemplateManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager の static メソッド
ItemTemplateManagerを取得します。
getItemTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
指定された期間に対する期間化情報を取得します。
getItemTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
指定された日時に対する期間化情報を取得します。
getItemTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getItemUnitManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager の static メソッド
ItemUnitManagerを取得します。
getItems() - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
現在、存在する商品の情報を返します。
getItems(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
指定された日付に存在する商品の情報を返します。
getItemsByKey(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
現在、条件に合致する商品の情報を返します。
getItemsByKey(String, String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
指定された日付に条件に合致する商品の情報を返します。
getJdbcConnection(String, String, String, String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
JDBCからコネクションオブジェクトを取得します。
getKey() - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のメソッド
エラーメッセージを作成するための識別子を取得します。
getKeyString() - class jp.co.intra_mart.foundation.security.DepartmentInfo のメソッド
組織情報の識別子を取得します。
getKeyString() - class jp.co.intra_mart.foundation.security.PostInfo のメソッド
役職情報の識別子を取得します。
getKeyString() - class jp.co.intra_mart.foundation.security.PublicGroupInfo のメソッド
パブリックグループ情報の識別子を取得します。
getKeyString() - class jp.co.intra_mart.foundation.security.menu.MenuInclusion のメソッド
メニュー内包情報の識別子を取得します。
getKeys() - class jp.co.intra_mart.foundation.navigator.LinkPageInfo のメソッド
URLパラメータリストのキー配列取得
getKeys() - class jp.co.intra_mart.foundation.navigator.NavigatorItem のメソッド
タイトル情報リストのキー配列取得
getKeys(String) - class jp.co.intra_mart.foundation.update.StandardUpdateAccessor のメソッド
保存されているキーの一覧を取得します。
getKeys(String) - interface jp.co.intra_mart.foundation.update.UpdateAccessor のメソッド
保存されているキーの一覧を取得します。
getKeys() - class jp.co.intra_mart.foundation.update.UpdateManager のメソッド
保存されている更新管理キーの一覧を取得します。
getLanguage() - class jp.co.intra_mart.foundation.page.EventScript のメソッド
言語名を返します。
getLanguageVersion() - class jp.co.intra_mart.foundation.page.EventScript のメソッド
言語のバージョンを返します。
getLastModified(String) - class jp.co.intra_mart.foundation.update.UpdateManager のメソッド
更新日付を取得します。
getLastResponseTime() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
最終応答時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を取得する。
getLatestPasswordHistory(String, String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
最新のパスワードと更新日付を取得。
getLatestPasswordHistory(String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
最新のパスワードと更新日付を取得。
getLatestPasswordHistory(String, String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
最新のパスワードと更新日付を取得。
getLicenceErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
ライセンスエラーページURLを取得する。
getLicenceErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
ライセンスエラーページURLを取得します。
getLicense(LoginInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
アカウントライセンスチェックを行います。
getLicense() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
アプリケーションライセンスが登録されているアカウント数を取得する。
getLicense() - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
グループ内で登録されているライセンス数を取得します。
getLicenseKeys() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
ライセンス・キーの取得
ライセンス・キーが登録されていない場合は、空の配列を返却します。
getLifetime() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ターゲットエンティティの期間削除時の整合性制約を取得します。
getLifetimeType() - interface jp.co.intra_mart.foundation.datastore.common.config.Lifetime のメソッド
ターゲットエンティティの期間削除時の整合性制約のタイプを取得します
getLimitedDate() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
使用期限の日付を取得します。
getLink(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
getLinkPageInfo(EventNavigatorManager, String, String, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
結果ページ情報を取得します。
getLinkPageInfo(String, String, String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
結果ページ情報を取得します。
getLinkPageInfo() - class jp.co.intra_mart.foundation.navigator.ResultPageItem のメソッド

getLinkPageInfo(EventNavigatorManager, String, String, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
結果ページ情報を取得します。
getListData(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getAllSubRoleIds(String)に置き換えられました。
getListenerClass() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext のメソッド
リスナーとなっている Servlet の実行時クラスを返します。
getListenerContext() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
イベントの実行要求を受け付けたリスナーに関する情報オブジェクトを返します。
getListeners() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
メール送信リスナを取得します。
getLocale() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
役職名の言語を取得します。
getLocale() - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor のメソッド
ロケールを取得します。
getLocale() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor のメソッド
ロケールを取得します。
getLocale() - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のメソッド
国際化モデルが保持する言語 Locale を取得します。
getLocale() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のメソッド
期間国際化モデルが保持する言語 Locale を取得します。
getLocale() - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel のメソッド
国際化モデルが保持する言語 Locale を取得します。
getLocale() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel のメソッド
期間国際化モデルが保持する言語 Locale を取得します。
getLocale() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
ロケールを取得します。
getLocale() - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
ロケールを取得します。
getLocale() - interface jp.co.intra_mart.foundation.security.LocaleInfo のメソッド
ロケ－ル取得。
getLocale() - interface jp.co.intra_mart.foundation.security.LocaleProvider のメソッド
ロケールを取得する。
getLocale() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ロケールを取得する。
getLocale(Locale, Locale) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
指定ロケールでロケール情報を取得します。
getLocale() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ロケールを取得します。
getLocale() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
ロケールの取得。
getLocale() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ロケールを取得する。
getLocale() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ロケールを取得する。
getLocale() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
ロケールを取得します。
getLocale() - class jp.co.intra_mart.foundation.utility.ResourceBundleProperties のメソッド
推奨されていません。 ResourceBundle の Locale を返します。
getLocale() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
ロケールを取得します。
getLocaleColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable のメソッド
ロケールに該当するカラムのカラム名を取得します。
getLocaleColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable のメソッド
ロケールに該当するカラムのカラム名を取得します。
getLocaleColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable のメソッド
ロケールに該当するカラムのカラム名を取得します。
getLocaleColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable のメソッド
ロケールに該当するカラムのカラム名を取得します。
getLocaleName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ロケールをセッションに保管するためのパラメータ名を取得する。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
この分類区分で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
この分類区分詳細で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
この会社で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
この組織で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable のメソッド
この役職で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
この商品属性で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable のメソッド
この商品で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
この商品カテゴリで管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
この商品属性テンプレート明細で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable のメソッド
このパブリックグループで管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable のメソッド
このパブリックグループセットで管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
このユーザで管理している言語（ロケール）をすべて取得します。
getLocales() - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap のメソッド
現在管理している言語の一覧を取得します。
getLocales() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap のメソッド
現在管理している言語の一覧を取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。
getLocales() - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap のメソッド
マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。
getLocales() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap のメソッド
マッピングされている期間国際化モデル TerminableInternationalModel の言語 Locale の一覧を取得します。
getLocales(Locale) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
指定ロケールでロケール情報の一覧を取得します。
getLocales() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
表示名として保管されているロケールの一覧を取得します。
getLocales() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニュー名として保管されているロケールの一覧を取得します。
getLocales() - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロケールの一覧を取得します。
getLocation() - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のメソッド
設定されている遷移先パスを返します。
getLockCount() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
アカウントをロックするログイン失敗回数を取得します。
getLockDate() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
アカウントロック日付を取得します。
getLockDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
アカウントロック日付を取得します。
getLockTerm() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
アカウントをロックする期間を取得します。
getLockedErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
ユーザロックエラーページURLを取得する。
getLockedErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
ユーザロックエラーページURLを取得します。
getLoginCertification() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報からログイン処理を行います。
getLoginCertification(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ログイン処理を行います。
getLoginFailureCount() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ログイン失敗回数を取得します。
getLoginFailureCount() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
ログイン失敗回数を取得します。
getLoginGroup() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ログイングループIDを取得する。
getLoginGroup() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
ログイングループIDを取得する。
getLoginGroup() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ログイングループIDを取得する。
getLoginGroup() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログイングループIDを取得する。
getLoginGroup(String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
ログイングループ情報を取得します。
getLoginGroup(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループ情報を取得します。
getLoginGroupConnection(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
ログイングループIDからコネクションオブジェクトを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ログイングループIDを取得します。
getLoginGroupIds() - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
ログイングループIDの一覧を取得します。
getLoginGroupIds() - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループIDの一覧を取得します。
getLoginGroupName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ログイングループをセッションに保管するためのパラメータ名を取得する。
getLoginGroupParameterName() - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer のメソッド
ログイングループＩＤリクエストパラメータ名を取得する。
getLoginGroupParameterName() - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
ログイングループＩＤリクエストパラメータ名を取得する。
getLoginGroups() - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループの一覧を取得します。
getLoginTime() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ログインした時間を取得する。
getLoginTime() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
ログイン時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を取得する。
getLoginTimeName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ログイン時間をセッションに保管するためのパラメータ名を取得する。
getLoginType() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ログインタイプを取得する。
getLoginType() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
ログインタイプを取得する。
getLoginType() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ログインタイプを取得する。
getLoginType() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインタイプを取得する。
getLoginTypeName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ログインタイプをセッションに保管するためのパラメータ名を取得する。
getLoginUser() - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
ログインユーザを取得します。
getLoginUser() - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
ログインユーザを取得します。
getLoginUser() - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
ログインユーザを取得します。
getLoginUser() - class jp.co.intra_mart.foundation.security.StandardBatchAccessor のメソッド
ログインユーザを取得します。
getLoginUser() - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor のメソッド
ログインユーザを取得します。
getLoginUser() - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
ログインユーザを取得します。
getLoginUser() - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
ログインユーザを取得します。
getMail() - class jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent のメソッド
メールの属性を取得します。
getMailAddress() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
メールアドレス取得。
getMainPage() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報からメインページURLを取得します。
getMainPage(SessionInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報からメインページURLを取得します。
getMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
メインページURLを取得します。
getMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider のメソッド
メインページURLを取得する。
getMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider のメソッド
メインページURLを取得する。
getMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider のメソッド
メインページURLを取得します。
getMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.UserPageProvider のメソッド
メインページURLを取得する。
getMainPage(String) - interface jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor のメソッド
ショートカット表示用のパスを取得します。
getMainPage() - class jp.co.intra_mart.foundation.security.shortcut.ShortCutManager のメソッド
ショートカットメインページ取得。
getMainPage(String) - class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor のメソッド
ショートカット表示用のパスを取得します。
getMainPagePattern(String, String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
メインページパターンを取得します。
getMainPagePattern(String, String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンを取得します。
getMainPagePatternId() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
メインページパターンIDを取得します。
getMainPagePatternId() - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo のメソッド
メインページパターンIDを取得する。
getMainPagePatternIds(String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
メインページパターンIDの一覧を取得します。
getMainPagePatternIds(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンIDの一覧を取得します。
getMainPagePatternImageUrl() - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo のメソッド
メインページパターンイメージURLを取得する。
getMainPagePatternUrl() - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo のメソッド
メインページパターンURLを取得する。
getMainPagePatterns(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンの一覧を取得します。
getMapperClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
マッパのクラス名を取得します。
getMatchCount() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
名称設定以外でマッチしたカレンダーデータの数を取得します。
getMax() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
ｙ軸の最大値を返します。
getMax() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
ｙ軸の最大値を返します。
getMax() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
ｙ軸の最大値を返します。
getMaxDate() - class jp.co.intra_mart.foundation.datastore.common.structure.Term の static メソッド
システムで設定できる期間の最大日時を取得します。
getMaxDate() - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager の static メソッド
システムで設定できる期間の最大日時を取得します。
getMaxLicense() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
アプリケーションの最大登録可能なラインセンス数を取得します。
getMaxLicense() - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
ログイングループ内の最大登録可能ライセンス数を取得します。
getMaxProcess() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
アプリケーションランタイムの最大使用可能なラインセンス数を取得します。
getMedia() - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のメソッド
媒体を取得します。
getMedia() - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel のメソッド
媒体を取得します。
getMediaCls() - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のメソッド
媒体種類を取得します。
getMediaCls() - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel のメソッド
媒体種類を取得します。
getMediaType() - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のメソッド
推奨されていません。 このオブジェクトが表す MIME タイプの Media Type を返します。
getMember(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
現在、組織に所属するる人員の一覧を取得します。
getMember(String, String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
指定された日付に組織に所属する人員の一覧を取得します。
getMember(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
ログインユーザが持つ指定されたプライベートグループに所属する人員を取得します。
getMember(String, String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
指定されたプライベートグループに所属する人員を取得します。
getMember(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
現在、パブリックグループに所属するる人員の一覧を取得します。
getMember(String, String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
指定された日付にパブリックグループに所属する人員の一覧を取得します。
getMenu(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 MenuManager.exportData(String category, OutputStream outputStream)に置き換えられました。
getMenuDepartments(String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
すべてのメニュー組織を取得します。
getMenuDepartments(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニュー組織を取得します。
getMenuDepartments(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューに紐付いた組織の一覧を取得します。
getMenuId() - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
メニューIDを取得します。
getMenuId() - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel のメソッド
メニューIDを取得します。
getMenuId() - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel のメソッド
メニューIDを取得します。
getMenuId() - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
メニューIDを取得します。
getMenuId() - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel のメソッド
メニューIDを取得します。
getMenuId() - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel のメソッド
メニューIDを取得します。
getMenuId() - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel のメソッド
メニューIDを取得します。
getMenuId() - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel のメソッド
メニューIDを取得します。
getMenuIds(String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
すべてのメニューIDを取得します。
getMenuIds() - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
すべてのメニューIDを取得します。
getMenuIds() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
すべてのメニューIDを取得します。
getMenuIds(String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニューIDを取得します。
getMenuIds() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
すべてのメニューIDを取得します。
getMenuIdsByDepartment(String, DepartmentInfo[]) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
指定された組織を持つメニューIDをすべて取得します。
getMenuIdsByDepartment(String, DepartmentInfo[]) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
指定された組織を持つメニューIDをすべて取得します。
getMenuIdsByDepartment(DepartmentInfo[]) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定された組織を持つメニューIDをすべて取得します。
getMenuIdsByLoginGroup(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
ログイングループがアクセス可能な管理メニューIDの一覧を取得します。
getMenuIdsByLoginGroup(String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
引き数に指定したログイングループが参照可能なメニューIDの一覧を取得します。
getMenuIdsByPost(String, PostInfo[]) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
指定された役職を持つメニューIDをすべて取得します。
getMenuIdsByPost(String, PostInfo[]) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
指定された役職を持つメニューIDをすべて取得します。
getMenuIdsByPost(PostInfo[]) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定された役職を持つメニューIDをすべて取得します。
getMenuIdsByPublicGroup(String, PublicGroupInfo[]) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
指定されたパブリックグループを持つメニューIDをすべて取得します。
getMenuIdsByPublicGroup(String, PublicGroupInfo[]) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
指定されたパブリックグループを持つメニューIDをすべて取得します。
getMenuIdsByPublicGroup(PublicGroupInfo[]) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定されたパブリックグループを持つメニューIDをすべて取得します。
getMenuIdsByRole(String, String[]) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
指定されたロールIDを持つメニューIDをすべて取得します。
getMenuIdsByRole(String, String[]) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
指定されたロールIDを持つメニューIDをすべて取得します。
getMenuIdsByRole(String[]) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定されたロールIDを持つメニューIDをすべて取得します。
getMenuInclusions(String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
すべてのメニュー構成を取得します。
getMenuInclusions() - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
すべてのメニュー構成を取得します。
getMenuInclusions(String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニュー構成を取得します。
getMenuItem(String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
指定されたメニューIDに対するノードを取得します。
getMenuItem(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
指定されたメニューIDに対するノードを取得します。
getMenuItem(String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
指定されたメニューIDに対応するメニューを取得します。
getMenuItem(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
指定されたメニューIDに対するノードを取得します。
getMenuItem(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定されたメニューIDに対応するメニューを取得します。
getMenuItem() - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
メニューを取得します。
getMenuItems(String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
すべてのノードを取得します。
getMenuItems() - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
すべてのノードを取得します。
getMenuItems() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
すべてのメニューを取得します。
getMenuItems(String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのノードを取得します。
getMenuItems() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
すべてのメニューを取得します。
getMenuItemsByIds(String, String[]) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
指定されたメニューIDのメニュー情報をすべて取得します。
getMenuItemsByIds(String[]) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
管理メニューIDの一覧からメニューアイテムを取得します。
getMenuItemsByIds(String[]) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
引き数に指定したメニューIDに一致するメニューアイテムの一覧を取得します。
getMenuItemsByIds(String, String[]) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
指定されたユーザIDのメニュー情報をすべて取得します。
getMenuItemsByIds(String[]) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
ログイングループ内で引数指定したメニューIDのメニュー情報をすべて取得します。
getMenuLinkSetCode() - class jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet のメソッド
メニューリンクセットコードを取得します。
getMenuLoginGroups(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
管理メニューにアクセス可能なログイングループの一覧を取得します。
getMenuLoginGroups(String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
引数に指定したメニューを参照可能なログイングループIDの一覧を取得します。
getMenuPosts(String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
すべてのメニュー役職を取得します。
getMenuPosts(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニュー役職を取得します。
getMenuPosts(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューに紐付いた役職の一覧を取得します。
getMenuPublicGroups(String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
すべてのメニューパブリックグループを取得します。
getMenuPublicGroups(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニューパブリックグループを取得します。
getMenuPublicGroups(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューに紐付いたパブリックグループの一覧を取得します。
getMenuRoles(String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
すべてのメニューロールを取得します。
getMenuRoles(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニューロールを取得します。
getMenuRoles(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューに紐付いたロールの一覧を取得します。
getMenuTree() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニュー構成を取得します。
getMenuTree(String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
引数に指定したログイングループのメニュー構成を取得します。
getMenuTree() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニュー構成を取得します。
getMenuTree(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定されたクライアントタイプのみのメニュー構成を取得します。
getMenuTree(String, String[], boolean) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定されたクライアントタイプと指定されたメニューIDのみのメニュー構成を取得します。
getMenuType() - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
メニュータイプを取得します。
getMessage(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
getMessage() - class jp.co.intra_mart.foundation.acssecurity.AcssecurityException のメソッド

getMessage(Locale, String) - class jp.co.intra_mart.foundation.image.ImageIconMessageBundle の static メソッド
イメージアイコンメッセージを取得します。
getMessage(Locale, String, String) - class jp.co.intra_mart.foundation.image.ImageIconMessageBundle の static メソッド
置換文字列を挿入したイメージアイコンメッセージを取得します。
getMessage(Locale, String, String, String) - class jp.co.intra_mart.foundation.image.ImageIconMessageBundle の static メソッド
置換文字列を挿入したイメージアイコンメッセージを取得します。
getMessage(Locale, String, String, String, String) - class jp.co.intra_mart.foundation.image.ImageIconMessageBundle の static メソッド
置換文字列を挿入したイメージアイコンメッセージを取得します。
getMessage(Locale, String, String[]) - class jp.co.intra_mart.foundation.image.ImageIconMessageBundle の static メソッド
置換文字列を挿入したイメージアイコンメッセージを取得します。
getMessage(String) - class jp.co.intra_mart.foundation.image.ImageIconMessageBundle の static メソッド
イメージアイコンメッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.foundation.image.ImageIconMessageBundle の static メソッド
置換文字列を挿入したイメージアイコンメッセージを取得します。
getMessage(String, String, String) - class jp.co.intra_mart.foundation.image.ImageIconMessageBundle の static メソッド
置換文字列を挿入したイメージアイコンメッセージを取得します。
getMessage(String, String, String, String) - class jp.co.intra_mart.foundation.image.ImageIconMessageBundle の static メソッド
置換文字列を挿入したイメージアイコンメッセージを取得します。
getMessage(String, String[]) - class jp.co.intra_mart.foundation.image.ImageIconMessageBundle の static メソッド
置換文字列を挿入したイメージアイコンメッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorHandler の static メソッド
メッセージの取得。
getMessage(Locale, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(Locale, String, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(Locale, String, String, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(Locale, String, String, String, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(Locale, String, String[]) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(String, String, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(String, String, String, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(String, String[]) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryResult のメソッド
メッセージを取得します。
getMessage() - class jp.co.intra_mart.foundation.utility.ErrorEvent のメソッド
推奨されていません。 通知されたエラーメッセージを取得します。
getMetaData() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この接続のデータベースに関するメタデータを取得します。
getMimeEncoding(Locale) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
MIMEエンコードを取得します。
getMin() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
ｙ軸の最小値を返します。
getMin() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
ｙ軸の最小値を返します。
getMin() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
ｙ軸の最小値を返します。
getMinDate() - class jp.co.intra_mart.foundation.datastore.common.structure.Term の static メソッド
システムで設定できる期間の最小日時を取得します。
getMinDate() - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager の static メソッド
システムで設定できる期間の最小日時を取得します。
getMobileEasyLoginURL(String, String) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil の static メソッド
かんたんログイン用のURLを取得します。
getMobileEasyLoginURL(HttpServletRequest, String, String) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil の static メソッド
かんたんログイン用のURLを取得します。
getMobileEmailAddress() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
携帯用メールを取得します。
getMobileEmailAddress(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
携帯用メールを取得します。
getMobileEmailAddress() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
携帯用メールを取得します。
getMobileEmailAddress() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯用メールを取得します。
getMobileEmailAddress(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯用メールを取得します。
getMobileEmailAddress() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
携帯用メールを取得します。
getMobileNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
携帯電話番号を取得します。
getMobileNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
携帯電話番号を取得します。
getMobileNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
携帯電話番号を取得します。
getMobileNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯電話番号を取得します。
getMobileNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯電話番号を取得します。
getMobileNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
携帯電話番号を取得します。
getMobilePassword() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
モバイル用パスワードを取得します。
getMobilePassword() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
モバイル用パスワードを取得します。
getMobileUserAgent(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
モバイル端末の固体識別番号を取得します。
getMobileUserAgent() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
モバイル端末の固体識別番号を取得します。
getModel() - interface jp.co.intra_mart.foundation.datastore.common.config.BaseModel のメソッド
基本モデルが定義されているモデル定義を取得します。
getModel() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
このエンティティを参照しているモデルを取得します。
getModel() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalModel のメソッド
国際化モデルが定義されているモデル定義を取得します。
getModel() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalModel のメソッド
期間国際化モデルが定義されているモデル定義を取得します。
getModel() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableModel のメソッド
期間化モデルが定義されているモデル定義を取得します。
getModels() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義しているモデル定義の一覧を取得します。
getMonth() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
月を取得します。
getMonth() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
月を取得します。
getMonthInfos(CategorizedCalendarInfo, int, int) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
月情報を取得します。
getName() - class jp.co.intra_mart.foundation.database.DbTypes のメソッド

getName() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
分類区分名を取得します。
getName(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
分類区分名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational のメソッド
分類区分名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
分類名を取得します。
getName(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
分類名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational のメソッド
分類名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct のメソッド
会社名または組織名を取得する。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
組織名を取得します。
getName(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
組織名を取得します。
getName(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
組織名を取得します。
getName(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
組織名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
組織名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織名を取得します。
getName(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織名を取得します。
getName(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織名を取得します。
getName(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
組織名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
役職名を取得します。
getName(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
役職名を取得します。
getName(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
役職名を取得します。
getName(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
役職名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational のメソッド
役職名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct のメソッド
グループ名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループ名を取得します。
getName(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループ名を取得します。
getName(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループ名を取得します。
getName(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループ名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のメソッド
グループ名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループ名を取得します。
getName(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループ名を取得します。
getName(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループ名を取得します。
getName(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループ名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のメソッド
グループ名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザ名を取得します。
getName(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザ名を取得します。
getName(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザ名を取得します。
getName(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザ名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
ユーザ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
分類区分名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
分類区分名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel のメソッド
分類区分名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
分類名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
分類名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel のメソッド
分類名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を取得します。
getName(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を取得します。
getName(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
組織名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を取得します。
getName(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を取得します。
getName(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel のメソッド
役職名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel のメソッド
役職名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel のメソッド
役職名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を取得します。
getName(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を取得します。
getName(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel のメソッド
グループ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を取得します。
getName(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を取得します。
getName(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
ユーザ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーション名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.BaseTable のメソッド
基本テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping のメソッド
カラム名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable のメソッド
拡張基本テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable のメソッド
拡張国際化テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable のメソッド
拡張期間国際化テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable のメソッド
拡張期間化テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable のメソッド
国際化テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping のメソッド
プライマリーキーとなるカラム名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
リレーションシップ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable のメソッド
期間国際化テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable のメソッド
期間化テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader のメソッド
エクスポート処理名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader のメソッド
インポート処理名を取得します。
getName() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
推奨されていません。 フォームのコントロール名称の取得。
getName() - interface jp.co.intra_mart.foundation.mail.javamail.model.AttachmentFile のメソッド
添付ファイルのファイル名を取得します。
getName() - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
項目の表示名称のを取得します。
getName() - class jp.co.intra_mart.foundation.page.TreeLeaf のメソッド
項目の表示名称のを取得します。
getName() - interface jp.co.intra_mart.foundation.page.TreeNode のメソッド
項目の表示名称のを取得します。
getName() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチ名を取得します。
getName() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
アプリケーション名を取得します。
getName() - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler のメソッド
推奨されていません。 フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
このオブジェクトの表すディレクトリ名称を取得します。
getName() - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
このインスタンスが表すグループＩＤを取得します。
getName() - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
このインスタンスの表すロックＩＤを返します。
getName() - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
このオブジェクトの表すディレクトリ名称を取得します。
getName() - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
このインスタンスが表すグループＩＤを取得します。
getName() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
このオブジェクトの表すディレクトリ名称を取得します。
getName() - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
このインスタンスが表すセッションＩＤを取得します。
getName() - interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory のメソッド
このオブジェクトの表す名称を取得します。
getName() - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
このオブジェクトの表す名称を取得します。
getName() - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
ロール名を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
組織名英字を取得します。
getNameEnglish(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
組織名英字を取得します。
getNameEnglish(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
組織名英字を取得します。
getNameEnglish(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
組織名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
組織名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織名英字を取得します。
getNameEnglish(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織名英字を取得します。
getNameEnglish(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織名英字を取得します。
getNameEnglish(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
組織名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループ名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループ名英字を取得します。
getNameEnglish(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループ名英字を取得します。
getNameEnglish(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループ名英字を取得します。
getNameEnglish(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループ名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のメソッド
グループ名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループ名英字を取得します。
getNameEnglish(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループ名英字を取得します。
getNameEnglish(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループ名英字を取得します。
getNameEnglish(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループ名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のメソッド
グループ名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザ名英字を取得します。
getNameEnglish(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザ名英字を取得します。
getNameEnglish(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザ名英字を取得します。
getNameEnglish(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザ名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
ユーザ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を取得します。
getNameEnglish(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を取得します。
getNameEnglish(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を取得します。
getNameEnglish(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
組織名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名英字を取得します。
getNameEnglish(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を取得します。
getNameEnglish(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を取得します。
getNameEnglish(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を取得します。
getNameEnglish(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel のメソッド
グループ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名英字を取得します。
getNameEnglish(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を取得します。
getNameEnglish(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を取得します。
getNameEnglish(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を取得します。
getNameEnglish(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
ユーザ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名英字を取得します。
getNameEnglish(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名英字を取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
組織名カナを取得します。
getNameSyllabary(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
組織名カナを取得します。
getNameSyllabary(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
組織名カナを取得します。
getNameSyllabary(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
組織名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
組織名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織名カナを取得します。
getNameSyllabary(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織名カナを取得します。
getNameSyllabary(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織名カナを取得します。
getNameSyllabary(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
組織名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループ名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループ名カナを取得します。
getNameSyllabary(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループ名カナを取得します。
getNameSyllabary(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループ名カナを取得します。
getNameSyllabary(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループ名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のメソッド
グループ名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループ名カナを取得します。
getNameSyllabary(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループ名カナを取得します。
getNameSyllabary(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループ名カナを取得します。
getNameSyllabary(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループ名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のメソッド
グループ名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザ名カナを取得します。
getNameSyllabary(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザ名カナを取得します。
getNameSyllabary(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザ名カナを取得します。
getNameSyllabary(Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザ名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
ユーザ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを取得します。
getNameSyllabary(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを取得します。
getNameSyllabary(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを取得します。
getNameSyllabary(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
組織名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名カナを取得します。
getNameSyllabary(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを取得します。
getNameSyllabary(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを取得します。
getNameSyllabary(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを取得します。
getNameSyllabary(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel のメソッド
グループ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名カナを取得します。
getNameSyllabary(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを取得します。
getNameSyllabary(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを取得します。
getNameSyllabary(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを取得します。
getNameSyllabary(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
ユーザ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名カナを取得します。
getNameSyllabary(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名カナを取得します。
getNationalHodildayInfos() - class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo のメソッド
データタイプが祝祭日であるカレンダーデータの一覧を取得します。
getNewArrivedList(String) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager の static メソッド
汎用新着情報の一覧を取得します。
getNewArrivedList(String, String) - interface jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider のメソッド
新着情報を一覧を取得します。
getNewArrivedList(String, String) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider のメソッド
汎用新着情報を取得
getNewArrivedList(String, String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryNewArrivedProvider のメソッド
パスワード履歴管理の新着情報を一覧を取得します。
getNextEventItem() - class jp.co.intra_mart.foundation.navigator.SelectItem のメソッド

getNextEventResultItem() - class jp.co.intra_mart.foundation.navigator.SelectItem のメソッド

getNextItemId() - class jp.co.intra_mart.foundation.navigator.SelectItemInfo のメソッド
遷移先アイテムID取得
getNextType() - class jp.co.intra_mart.foundation.navigator.SelectItem のメソッド

getNextType() - class jp.co.intra_mart.foundation.navigator.SelectItemInfo のメソッド
遷移先タイプ取得
getNoPermissionErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
無許可アクセスエラーページURLを取得する。
getNoPermissionErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
無許可アクセスエラーページURLを取得する。
getNodeSet() - interface jp.co.intra_mart.foundation.page.TreeNodeProvider のメソッド
ツリービュー内の「ホーム」以外の全てのノードが含まれるSetを返します。
getNodeSet() - class jp.co.intra_mart.foundation.page.TreeRoot のメソッド
ツリービュー内の「ホーム」以外の全てのノードが含まれるSetを返します。
getNote() - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
マウスポイント時に表示されるポップアップ文字列を取得します。
getNote() - class jp.co.intra_mart.foundation.page.TreeLeaf のメソッド
マウスポイント時に表示されるポップアップ文字列を取得します。
getNote() - interface jp.co.intra_mart.foundation.page.TreeNode のメソッド
マウスポイント時に表示されるポップアップ文字列を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel のメソッド
説明を取得します。
getNotes() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
説明を取得します。
getNotes() - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
説明を取得します。
getNotes() - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
備考を取得します。
getNullKeys() - interface jp.co.intra_mart.foundation.datastore.common.config.Delete のメソッド
ターゲットエンティティのデータ削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。
getNullKeys() - interface jp.co.intra_mart.foundation.datastore.common.config.Lifetime のメソッド
ターゲットエンティティの期間削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。
getNumberValue() - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
属性数値を取得します。
getNumberValue() - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel のメソッド
属性数値を取得します。
getObject() - class jp.co.intra_mart.foundation.utility.ErrorEvent のメソッド
推奨されていません。 通知されたエラー発生オブジェクトを取得します。
getOpen() - class jp.co.intra_mart.foundation.navigator.EventFlow のメソッド

getOpen() - class jp.co.intra_mart.foundation.navigator.EventFlowInfo のメソッド
公開フラグ取得
getOutputPath() - interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader のメソッド
エクスポートデータを出力するファイルパスを取得します。
getOutputStream() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 出力ストリームの取得。
getOutputStreamWriter() - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のメソッド
推奨されていません。 このオブジェクトの基礎出力となっている java.io.OutputStreamWriter を返します。
getOverlap(Term[], Term[]) - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager の static メソッド
2つの期間配列 term1 と term2 で重なっている期間を返します。
getOwnerCode() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
所有者コードを取得します。
getOwnerCode() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
所有者コードを取得します。
getOwnerCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
所有者コードを取得します。
getOwnerCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
所有者コードを取得します。
getPackageVersion() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
パッケージバージョンを取得します。
getPageItem() - class jp.co.intra_mart.foundation.navigator.EventResultItem のメソッド

getPageKind() - class jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet のメソッド
ページ種別を取得します。
getPageKind() - class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet のメソッド
ページ種別を取得します。
getPageKind() - class jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet のメソッド
ページ種別を取得します。
getPageKind() - class jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet のメソッド
ページ種別を取得します。
getPageKind() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
ページ種別を取得します。
getPageKind() - class jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet のメソッド
ページ種別を取得します。
getPageKind() - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet のメソッド
ページ種別を取得します。
getPagePath() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のメソッド
設定されているページパスを返します。
getPagePatternId() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
メインページパターンを取得します。
getParamValue(String) - class jp.co.intra_mart.foundation.navigator.LinkPageInfo のメソッド

getParameter(String) - class jp.co.intra_mart.foundation.commons.ParameterManager のメソッド
パラメータの値を取得します。
getParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
設定したパラメータ値を取得します。
getParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
設定したパラメータ値を取得します。
getParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
設定したパラメータ値を取得します。
getParameterKeySet() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
現在、パラメータとして設定されているキーの一覧を返します。
getParameterKeySet() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
現在、パラメータとして設定されているキーの一覧を返します。
getParameterKeySet() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
現在、パラメータとして設定されているキーの一覧を返します。
getParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
設定済みパラメータのマップのコピーを返します。
getParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
設定済みパラメータのマップのコピーを返します。
getParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
設定済みパラメータのマップのコピーを返します。
getParameterNames() - class jp.co.intra_mart.foundation.commons.ParameterManager のメソッド
パラメータ名の一覧を取得します。
getParameters() - interface jp.co.intra_mart.foundation.commons.ParameterSourceProvider のメソッド
パラメータの一覧を取得します。
getParams() - class jp.co.intra_mart.foundation.security.account.CsvAccountBackup のメソッド
パラメータを取得します。
getParent() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このオブジェクトがフィルタリングしているハンドラを返します。
getParent() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
ラップしている親オブジェクトを返します。
getParentComparator() - class jp.co.intra_mart.foundation.utility.FilterComparator のメソッド
推奨されていません。 フィルター対象のコンパレータを返します。
getParentData(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getParentRoleIds(String)に置き換えられました。
getParentDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
親組織コードを取得します。
getParentItemCategoryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
親商品カテゴリコードを取得します。
getParentItemCategoryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
親商品カテゴリコードを取得します。
getParentMenuId(String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
引数で指定されたノードの親ノードを取得します。
getParentMenuId(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
引数で指定されたノードの親ノードを取得します。
getParentMenuId() - class jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion のメソッド
親メニューIDを取得します。
getParentMenuId(String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
指定されたメニューの親メニューを取得します。
getParentMenuId(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
引数で指定されたノードの親ノードを取得します。
getParentMenuId() - class jp.co.intra_mart.foundation.security.menu.MenuInclusion のメソッド
親メニューIDを取得します。
getParentMenuId(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定されたメニューの親メニューを取得します。
getParentMenuId() - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
親メニューIDを取得します。
getParentName() - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
保存ディレクトリを取得します。
getParentPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
親グループコードを取得します。
getParentRoleId() - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel のメソッド
親ロールコードを取得します。
getParentRoleIds(String, String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
親ロールの一覧を取得します。
getParentRoleIds(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
親ロールの一覧を取得する。
getParentRoleIds(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
親ロールIDを取得します。
getParserKey() - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet のメソッド
RSS解析キーを取得します。
getPassword() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
パスワードを取得します。
getPassword() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
パスワード取得。
getPassword() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ログインパスワードを取得する。
getPassword() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインパスワードを取得する。
getPassword() - class jp.co.intra_mart.foundation.security.password.PasswordHistory のメソッド
パスワードを取得します。
getPassword() - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler のメソッド
設定されているパスワードを返します。
getPassword() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
パスワードを取得します。
getPasswordExpireLimit(String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
パスワード履歴数を取得。
getPasswordExpireLimit() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
設定したパスワードの有効期限を取得。
getPasswordExpireLimit(String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
設定したパスワードの有効期限を取得。
getPasswordHistories(String, String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
パスワード履歴を取得。
getPasswordHistories(String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
パスワード履歴を取得。
getPasswordHistories(String, String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
パスワード履歴を取得。
getPasswordHistoryCount(String, String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
パスワード履歴数を取得。
getPasswordHistoryCount(String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
パスワード履歴数を取得。
getPasswordHistoryCount(String, String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
パスワード履歴数を取得。
getPasswordHistoryManagedCount(String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
世代管理数を取得。
getPasswordHistoryManagedCount() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
世代管理数を取得。
getPasswordHistoryManagedCount(String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
世代管理数を取得。
getPasswordPage(String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
パスワード変更画面のＵＲＬを取得。
getPasswordPage() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
パスワード変更画面のＵＲＬを取得。
getPasswordPage(String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
パスワード変更画面のＵＲＬを取得。
getPath() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このオブジェクトが表すパスを返します。
getPathXML(Node, Node) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter のメソッド
このノードのフルパスを取得します。
getPermissionSelector(String) - class jp.co.intra_mart.foundation.security.permission.PermissionManager のメソッド
指定されたカテゴリについて、設定XMLファイルで定義されているPermissionSelectorを返します。
getPersonal() - interface jp.co.intra_mart.foundation.mail.javamail.model.MailAddress のメソッド
名前を取得します。
getPlugin() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
プラグインIDを取得します。
getPlugin(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータプラグインを取得します。
getPluginClass() - interface jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo のメソッド
カレンダーデータプラグインクラス名を取得します。
getPluginId() - interface jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo のメソッド
カレンダーデータプラグインIDを取得します。
getPluginIds() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータプラグインIDの一覧を取得します。
getPluginMethod() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
プラグイン関数を取得します。
getPort() - class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor のメソッド
推奨されていません。 ポートを返します。
getPortlet(String, String) - class jp.co.intra_mart.foundation.portal.portlet.PortletManager のメソッド
すでに登録済のポートレット情報を取得します。
getPortlet(String) - class jp.co.intra_mart.foundation.portal.portlet.PortletMapping のメソッド
指定されたページ種別に対応するポートレットモデルのインスタンスを取得します。
getPortletCode() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
ポートレットコードを取得します。
getPortletName() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
ポートレット名を取得します。
getPortlets() - class jp.co.intra_mart.foundation.portal.portlet.PortletManager のメソッド
すでに登録されているポートレット情報の一覧を取得します。
getPost(int) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

getPostCd() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel のメソッド
役職CDを取得します。
getPostCd() - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel のメソッド
役職CDを取得します。
getPostCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
役職CDを取得します。
getPostCode(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
役職CDを取得します。
getPostCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable のメソッド
役職CDを取得します。
getPostCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
役職コードを取得します。
getPostCode() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
役職コードを取得します。
getPostCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
役職CDを取得します。
getPostCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
役職CDを取得します。
getPostCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel のメソッド
役職CDを取得します。
getPostCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職コードを取得します。
getPostCode() - class jp.co.intra_mart.foundation.security.PostInfo のメソッド
役職コードを取得します。
getPostName() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
役職名を取得します。
getPosts() - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

getPostsInCompany(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
会社に登録済の役職をすべて取得します。
getPostsInCompany(String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
会社に登録済の役職をすべて取得します。
getPostsInCompany(String, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
会社に登録済の役職をすべて取得します。
getPostsInCompany(String, Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
会社に登録済の役職をすべて取得します。
getPostsOfUser(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
ユーザに設定された役職をすべて取得します。
getPostsOfUser(String, String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
ユーザに設定された役職をすべて取得します。
getPostsOfUser(String, String, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
ユーザに設定された役職をすべて取得します。
getPostsOfUser(String, String, Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
ユーザに設定された役職をすべて取得します。
getPrimaryComparator() - class jp.co.intra_mart.foundation.page.NodeTypeComparator のメソッド
第１コンパレータを取得します。
getPrimaryComparator() - interface jp.co.intra_mart.foundation.utility.DualComparator のメソッド
推奨されていません。 １番目コンパレータを取得します。
getPrimaryComparator() - class jp.co.intra_mart.foundation.utility.MultiComparator のメソッド
推奨されていません。 第１コンパレータを返します。
getPrimaryKeyMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable のメソッド
拡張基本テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。
getPrimaryKeyMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable のメソッド
拡張国際化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。
getPrimaryKeyMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable のメソッド
拡張期間国際化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。
getPrimaryKeyMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable のメソッド
拡張期間化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。
getPrimaryKeys() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティのプライマリキーとなる属性をすべて取得します。
getPriority() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
優先度を取得します。
getPrivateGroup(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
登録済のプライベートグループを取得します。
getPrivateGroupCode() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
グループコードを取得します。
getPrivateGroupCode() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループコードを取得します。
getPrivateGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
グループコードを取得します。
getPrivateGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループコードを取得します。
getPrivateGroupManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager の static メソッド
PrivateGroupManagerを取得します。
getPrivateGroups(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
指定されたユーザが持つプライベートグループをすべて取得します。
getProduct() - class jp.co.intra_mart.foundation.security.license.LicenseManager の static メソッド
システム情報を取得します。
getProductModelCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
製品型番を取得します。
getProductModelCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
製品型番を取得します。
getProgramLanguage() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行プログラム言語を取得します。
getProgramLanguage() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行プログラム言語を取得します。
getProgramPath() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行プログラムパスを取得します。
getProgramPath() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行プログラムパスを取得します。
getProperties() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張モデルに含まれるプロパティをすべて取得します。
getProperties() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
モデルに含まれるプロパティをすべて取得します。
getProperties() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
JavaMailのSMTPセッションに渡す属性を初期化します。
getProperties(String) - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
インストール情報を取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.scenario.VariableScope のメソッド
プロパティ値を取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンのプロパティ情報を取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
インストール情報を取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.service.provider.Environment のメソッド
指定されたキーによって示されるシステムプロパティを取得します。
getProperty(String, String) - interface jp.co.intra_mart.foundation.service.provider.Environment のメソッド
指定されたキーによって示されるシステムプロパティを取得します。
getPropertyKeys() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンのプロパティ情報のキー一覧を取得します。
getPropertyStreamAsClientType(Locale) - interface jp.co.intra_mart.foundation.security.SystemSourceProvider のメソッド
プロパティファイル(クライアントタイプ)の内容取得。
getPropertyStreamAsColor(Locale) - interface jp.co.intra_mart.foundation.security.SystemSourceProvider のメソッド
プロパティファイル(カラーパターン)の内容取得。
getPropertyStreamAsColorProperty(String, Locale) - interface jp.co.intra_mart.foundation.security.SystemSourceProvider のメソッド
プロパティファイル(カラーパターン)の内容取得。
getPropertyStreamAsLocale(Locale) - interface jp.co.intra_mart.foundation.security.SystemSourceProvider のメソッド
プロパティファイル(ロケール)の内容取得。
getProxyHost() - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet のメソッド
プロキシホスト名を取得します。
getProxyPort() - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet のメソッド
プロキシポート番号を取得します。
getPublicGroup(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループを取得します。
getPublicGroup(int) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

getPublicGroupAttach(String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
ユーザのパブリックグループへの所属情報を取得します。
getPublicGroupAttachTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
指定された期間に対する期間化情報を取得します。
getPublicGroupAttachTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
指定された日時に対する期間化情報を取得します。
getPublicGroupCategoryTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
指定された期間に対する期間化情報を取得します。
getPublicGroupCategoryTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
指定された日時に対する期間化情報を取得します。
getPublicGroupCd() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel のメソッド
グルーピングCDを取得します。
getPublicGroupCd() - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel のメソッド
グルーピングCDを取得します。
getPublicGroupCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup のメソッド
グループコードを取得します。
getPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct のメソッド
グループコードを取得します。
getPublicGroupCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
グループコードを取得します。
getPublicGroupCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
グループコードを取得します。
getPublicGroupCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループコードを取得します。
getPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel のメソッド
グループコードを取得します。
getPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
グループコードを取得します。
getPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel のメソッド
グループコードを取得します。
getPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループコードを取得します。
getPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
グループコードを取得します。
getPublicGroupManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager の static メソッド
PublicGroupManagerを取得します。
getPublicGroupSetCd() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel のメソッド
グループセットCDを取得します。
getPublicGroupSetCd() - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel のメソッド
グループセットCDを取得します。
getPublicGroupSetCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
指定された期間に対する期間化情報を取得します。
getPublicGroupSetTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
指定された日時に対する期間化情報を取得します。
getPublicGroupSetTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getPublicGroupStructs(String, String, Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループの階層構造を取得します。
getPublicGroupTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
指定された期間に対する期間化情報を取得します。
getPublicGroupTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
指定された日時に対する期間化情報を取得します。
getPublicGroupTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getPublicGroups(Deal) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager のメソッド
取扱情報を保有するアクセス権をもつパブリックグループを返します。
getPublicGroups() - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

getPurchaseUnitPrice() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
仕入単価を取得します。
getPurchaseUnitPrice(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
仕入単価を取得します。
getPurchaseUnitPrice() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable のメソッド
仕入単価を取得します。
getPurchaseUnitPrice() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
仕入単価を取得します。
getPurchaseUnitPrice(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
仕入単価を取得します。
getPurchaseUnitPrice() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
仕入単価を取得します。
getQuery() - class jp.co.intra_mart.foundation.http.SessionQuery のメソッド
推奨されていません。 代替えメソッドはありません。
getQueryName() - class jp.co.intra_mart.foundation.http.SessionQuery のメソッド
推奨されていません。 代替えメソッドはありません。
getQueryString() - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
設定されているパラメータ情報からクエリ文字列を作成して返します。
getQueryValue() - class jp.co.intra_mart.foundation.http.SessionQuery のメソッド
推奨されていません。 GenericURLBuilder.createFilePath(String) に置き替えられました。
getQuestion() - class jp.co.intra_mart.foundation.navigator.EventHistoryInfo のメソッド
回答取得
getQuestion() - class jp.co.intra_mart.foundation.navigator.SaveEventHistoryInfo のメソッド
回答取得
getReader() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
推奨されていません。 MultipartFormData.Entity.getReader(String) に置き換えられました。
getReader(String) - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
推奨されていません。 データ部を Reader として取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
レコード更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel のメソッド
最終更新日を取得します。
getRecordUserCd() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel のメソッド
最終更新者を取得します。
getRecordUserCd() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
最終更新者を取得します。
getRecordUserCd() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
レコード更新ユーザコードを取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel のメソッド
最終更新者を取得します。
getRefereRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.ActivationKey のメソッド
ソースエンティティから有効開始日時を持つエンティティまでのリレーションシップを取得します。
getRefereRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey のメソッド
ソースエンティティから有効終了日時を持つエンティティまでのリレーションシップを取得します。
getRefereRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalKey のメソッド
ソースエンティティから国際化基準項目を持つエンティティまでのリレーションシップを取得します。
getRefereRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableKey のメソッド
ソースエンティティから期間化基準項目を持つエンティティまでのリレーションシップを取得します。
getReferedRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
このエンティティの属性を、国際化基準項目や期間化基準項目などを使用して参照している全てのリレーションシップを取得します。
getReference() - class jp.co.intra_mart.foundation.database.DbManager の static メソッド
推奨されていません。 DatabaseManager.getConnectIdsBySystem()を使用してください。
getRegisteredAccountLicenses() - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
ログイングループにライセンス登録されているすべてのユーザIDを返します。
getRegisteredApplicationLicensesToAccount(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
アカウントに登録されているアプリケーションライセンスの一覧を取得します。
getRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義しているリレーションシップの一覧を取得します。
getRemoteAddr() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
リクエスト元のクライアントの IP(Internet Protocol) アドレスを取得する。
getRemoteHostAddress() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext のメソッド
イベント実行要求をしたクライアントのアドレスを返します。
getRemoteHostName() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext のメソッド
イベント実行要求をしたクライアントのホスト名を返します。
getReporters() - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 セット内の要素についての反復子を返します。
getRequest() - class jp.co.intra_mart.foundation.database.DatabaseExport の static メソッド
推奨されていません。
getRequest() - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain のメソッド
チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのリクエストを 返します。
getRequest() - class jp.co.intra_mart.jssp.net.GenericURLBuilder のメソッド
現在のリクエストを返します。
getRequestTime() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
イベントの実行を要求した時刻を返します。
getRequestURL() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent のメソッド
このコンテンツを取得するために使用した URL を返します。
getRequestedPageAttributeName() - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager のメソッド
リクエストされたページURLを保持するために使用する属性名を取得します。
getResourceConnection(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
リソース参照名からコネクションオブジェクト取得を取得します。
getResponse() - class jp.co.intra_mart.foundation.database.DatabaseExport の static メソッド
推奨されていません。
getResponse() - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain のメソッド
チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのレスポンスを 返します。
getResponse() - class jp.co.intra_mart.jssp.net.GenericURLBuilder のメソッド
現在のレスポンスを返します。
getResponseCode() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
サーバからのHTTPレスポンスコードを返します。
getResponseCode() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
サーバからのHTTPレスポンスコードを返します。
getResponseMessage() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。
getResponseMessage() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。
getResultPageItemInfos() - class jp.co.intra_mart.foundation.navigator.EventResultItemInfo のメソッド
結果ページ情報リスト取得
getResultPageItemInfos() - class jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo のメソッド
結果ページ情報リスト取得
getRole(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 RoleManager.exportData(String category, OutputStream outputStream)に置き換えられました。
getRole(int) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

getRole(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール情報を取得します。
getRoleData(String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
ロール情報を全件取得します。
getRoleData(String, String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
ロール情報を取得します。
getRoleData(String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
ロール情報を全件取得する。
getRoleData(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
ロール情報を取得する。
getRoleDataByCategory(String, String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
カテゴリからロール情報を取得します。
getRoleDataByCategory(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
カテゴリからロール情報を取得する。
getRoleId() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole のメソッド
ロールIDを取得します。
getRoleId() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel のメソッド
ロールIDを取得します。
getRoleId() - class jp.co.intra_mart.foundation.security.account.AccountRole のメソッド
ロールIDを取得します。
getRoleId() - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロールIDを取得します。
getRoleId() - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel のメソッド
ロールCDを取得します。
getRoleId() - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel のメソッド
メニューIDを取得します。
getRoleId() - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel のメソッド
ロールCDを取得します。
getRoleId() - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
ロールIDを取得します。
getRoleId() - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel のメソッド
ロールIDを取得します。
getRoleIds(String, Date) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントに紐付く有効なロールIDをすべて取得します。
getRoleIds() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
すべてのロールIDを取得します。
getRoleName() - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロール名を取得します。
getRoleValidEndDate() - class jp.co.intra_mart.foundation.security.account.AccountRole のメソッド
ロール有効終了日を取得します。
getRoleValidStartDate() - class jp.co.intra_mart.foundation.security.account.AccountRole のメソッド
ロール有効開始日を取得します。
getRoles(Deal) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager のメソッド
取扱情報を保有するアクセス権をもつロールを返します。
getRoles() - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

getRoles() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
すべてのロール情報を取得します。
getRolesByCategory(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
カテゴリー検索によりロールを取得します。
getRolesByIds(String, String[]) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
指定されたロールIDのロール情報をすべて取得します。
getRolesByIds(String, String[]) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
指定されたロールIDのロール情報をすべて取得する。
getRolesByIds(String[]) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ログイングループ内で引数指定したロールIDのロール情報をすべて取得します。
getRssUrl() - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet のメソッド
URLを取得します。
getRunDay() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行日を取得します。
getRunDay() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行日を取得します。
getRunDayWeek() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行曜日を取得します。
getRunDayWeek() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行曜日を取得します。
getRunHour() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行時を取得します。
getRunHour() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行時を取得します。
getRunMinute() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行分を取得します。
getRunMinute() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行分を取得します。
getRunMonth() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行月を取得します。
getRunMonth() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行月を取得します。
getRunSecond() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行秒を取得します。
getRunSecond() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行秒を取得します。
getRunYear() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行年を取得します。
getRunYear() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行年を取得します。
getSMTPConnectionTimeout() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
SMTPサーバへのコネクションタイムアウト時間を取得します。
getSMTPPassword() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
SMTP認証のパスワードを取得します
getSMTPTimeout() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
SMTPサーバとの入出力タイムアウト時間を取得します。
getSMTPUser() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
SMTP認証のユーザを取得します
getSalesUnitPrice() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
販売単価を取得します。
getSalesUnitPrice(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
販売単価を取得します。
getSalesUnitPrice() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable のメソッド
販売単価を取得します。
getSalesUnitPrice() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
販売単価を取得します。
getSalesUnitPrice(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
販売単価を取得します。
getSalesUnitPrice() - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
販売単価を取得します。
getSaveDate() - class jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo のメソッド
保存日時取得
getSaveEventResultItemInfo(EventNavigatorManager, String, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
getSaveEventResultItemInfo(String, String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
getSaveEventResultItemInfo(EventNavigatorManager, String, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
保存ナビゲート結果情報の取得 ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報を取得。
getSaveEventResultItemInfos(EventNavigatorManager, String, String, String, String, int) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
getSaveEventResultItemInfos(String, String, String, String, int) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
getSaveEventResultItemInfos(EventNavigatorManager, String, String, String, String, int) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
保存ナビゲート結果情報一覧（ユーザ）の取得 検索タイトル、ユーザIDで検索し、保存ナビゲート結果情報一覧（ユーザ）を取得、返却する。
getSaveEventResultItemInfosHistory(EventNavigatorManager, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
getSaveEventResultItemInfosHistory(String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
getSaveEventResultItemInfosHistory(EventNavigatorManager, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
保存ナビゲート結果情報一覧（履歴）の取得 ユーザIDで検索し、保存ナビゲート結果情報一覧（履歴）を取得、返却する。
getSaveLinkPageInfo(EventNavigatorManager, String, String, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
保存結果ページ情報を取得します。
getSaveLinkPageInfo(String, String, String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
保存結果ページ情報を取得します。
getSaveLinkPageInfo(EventNavigatorManager, String, String, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
保存結果ページ情報を取得します。
getScaleCount() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
ｙ軸の目盛間隔を返します。
getScaleCount() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
ｙ軸の目盛間隔を返します。
getScaleCount() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
ｙ軸の目盛間隔を返します。
getScaleCountX() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｘ軸の目盛間隔を返します。
getScaleCountY() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｙ軸の目盛間隔を返します。
getScalePosition() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｘ軸、ｙ軸の目盛りの表示位置を返します。
getSchedule(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 BatchManager.exportData(String category, OutputStream outputStream)に置き換えられました。
getScript() - class jp.co.intra_mart.foundation.page.EventScript のメソッド
設定された情報からイベントのためのスクリプトを作成します。
getSecondaryComparator() - class jp.co.intra_mart.foundation.page.NodeTypeComparator のメソッド
第２コンパレータを取得します。
getSecondaryComparator() - interface jp.co.intra_mart.foundation.utility.DualComparator のメソッド
推奨されていません。 ２番目コンパレータを取得します。
getSecondaryComparator() - class jp.co.intra_mart.foundation.utility.MultiComparator のメソッド
推奨されていません。 第２コンパレータを返します。
getSelectItem() - class jp.co.intra_mart.foundation.navigator.EventItem のメソッド

getSelectItem(int) - class jp.co.intra_mart.foundation.navigator.EventItem のメソッド

getSelectItemInfos() - class jp.co.intra_mart.foundation.navigator.EventItemInfo のメソッド
選択アイテム情報リスト取得
getSerchFilter() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
検索フィルタを取得する。
getSerialNumbers() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
シリアル番号の取得
ライセンス・キーが登録されていない場合は、空の配列を返却します。
getService() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
設定されているサービスＩＤを返します。
getServiceId() - class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet のメソッド
サービスIDを取得します。
getServletConfig() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext のメソッド
イベントを制御したリスナー となっている Servlet が初期化された時に Servlet コンテナから渡された設定オブジェクトが返されます。
getSession() - class jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent のメソッド
メール送信のセッションを取得します。
getSessionConfig() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
セッション情報保管パラメータを取得します。
getSessionCookieName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
クッキーにセッション情報を保管するためパラメータ名を取得する。
getSessionErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
セッションエラーページURLを取得する。
getSessionErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
セッションエラーページURLを取得する。
getSessionId() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
セッションIDを取得する。
getSessionInfo() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報からintra-martセッション情報を取得します。
getSessionInfo(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
intra-martセッション情報を取得します。
getSessionMode() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
intra-martセッションの状態を取得します。
getSessionMode(SessionInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
intra-martセッションの状態を取得します。
getSessionTimeoutErrorPage(HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
セッションタイムアウトエラーページURLを取得する。
getSessionTimeoutErrorPage(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
セッションタイムアウトエラーページURLを取得する。
getShortCutInfo(String, String) - interface jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor のメソッド
ショートカット情報を取得します。
getShortCutInfo(String) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutManager のメソッド
ショートカット情報取得。
getShortCutInfo(String, String) - class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor のメソッド
ショートカット情報を取得します。
getShortCutName() - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
ショートカット用ＵＲＬパラメータ名を取得する。
getShortcutName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ショートカットＩＤをセッションに保管するためのパラメータ名を取得する。
getSignature() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ログイン署名を取得する。
getSignatureName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ログイン署名をセッションに保管するためのパラメータ名を取得する。
getSize() - interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader のメソッド
エクスポート単位のデータ数を取得します。
getSize() - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
描画する点のサイズを返します。
getSize() - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionManager のメソッド
推奨されていません。 このプールが現在管理しているコネクション数です。
getSize() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 このプールが現在管理しているコネクション数です。
getSocket() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 このオブジェクトの持つソケットオブジェクトを返します。
getSocketConnectionDistributor() - class jp.co.intra_mart.foundation.service.client.manager.ServerConnector のメソッド
このオブジェクトが保持しているネットワークのコネクションプールを 返します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.image.ImageIconInfo のメソッド
ソートキーを取得する。
getSortNumber() - class jp.co.intra_mart.foundation.navigator.EventFlow のメソッド

getSortNumber() - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
ソート番号を取得します。
getSortNumber() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
ソート番号を取得します。
getSortNumber() - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel のメソッド
ソート番号を取得します。
getSortNumber() - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
ソート番号を取得します。
getSourceEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.ActivationKey のメソッド
ライフタイム期間の有効開始日時の基点となるソースエンティティの情報を取得します。
getSourceEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey のメソッド
ライフタイム期間の有効終了日時の基点となるソースエンティティの情報を取得します。
getSourceEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalKey のメソッド
国際化基準項目の基点となるソースエンティティの情報を取得します。
getSourceEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ソースエンティティの情報を取得します。
getSourceEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableKey のメソッド
期間化基準項目の基点となるソースエンティティの情報を取得します。
getSourceRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
このエンティティをソースとしているリレーションシップをすべて取得します。
getSrc() - class jp.co.intra_mart.foundation.image.ImageIconInfo のメソッド
イメージアイコンURLを取得する。
getStartDate() - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
開始日を取得します。
getStartDate() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
開始日を取得します。
getStartDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
開始日を取得します。
getStartDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
開始日を取得します。
getStartDateColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable のメソッド
期間の開始日時に該当するカラムのカラム名を取得します。
getStartEventId() - class jp.co.intra_mart.foundation.navigator.EventFlowInfo のメソッド
スタートイベントアイテムID取得
getStartEventItem() - class jp.co.intra_mart.foundation.navigator.EventFlow のメソッド

getStream() - interface jp.co.intra_mart.foundation.security.SystemSourceProvider のメソッド
システム設定ファイルの内容取得。
getStringValue() - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
属性文字列を取得します。
getStringValue(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
属性文字列を取得します。
getStringValue() - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttributeInternational のメソッド
属性文字列を取得します。
getStringValue() - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel のメソッド
属性文字列を取得します。
getStringValue(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel のメソッド
属性文字列を取得します。
getStringValue() - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeInternationalModel のメソッド
属性文字列を取得します。
getStroke() - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
描画される線の描画属性を返します。
getSubRole(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
サブロール(一階層のみ)を取得します。
getSubRoleIds(String, String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
サブロールIDサマリを取得します。
getSubRoleIds(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
サブロールIDサマリを取得する。
getSubType() - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のメソッド
推奨されていません。 このオブジェクトが表す MIME タイプの subtype を返します。
getSubject() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Subjectを取得します。
getSummaryRoleId() - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel のメソッド
サマリロールIDを取得します。
getSuperUser() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
システム管理者情報を取得します。
getSuperUser() - interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor のメソッド
システム管理者情報を取得します。
getSuperUser(String) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor のメソッド
グループ管理者情報を取得します。
getSuperUser(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
グループ管理者情報を取得します。
getSystemConnection(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
システム接続名からコネクションオブジェクトを取得します。
getSystemCurrencyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager のメソッド
システム通貨コードを返します。
getSystemDatabaseType(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
システムデータソースにおけるデータベースの種類を取得する。
getSystemErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
認証処理エラーページURLを取得する。
getSystemErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
認証処理エラーページURLを取得する。
getSystemLicense() - class jp.co.intra_mart.foundation.security.license.LicenseManager の static メソッド
システム全体の登録ライセンス数。
getSystemMaxDate() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
最大の未来日を取得します。
getSystemMaxLicense() - class jp.co.intra_mart.foundation.security.license.LicenseManager の static メソッド
システム全体のライセンス数。
getSystemMenu() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
システムメニューを取得します。
getSystemMinDate() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
最大の過去日を取得します。
getSystemProperty(String) - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext のメソッド
クライアントの Java 実行環境のシステムプロパティの値を返します。
getSystemPropertyNameSet() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext のメソッド
クライアントの Java 実行環境のシステムプロパティの名前のセットを返します。
getSystemTemporaryDirectory() - class jp.co.intra_mart.foundation.service.provider.TemporaryDirectory の static メソッド
システムが使用する一時ファイル保存ディレクトリを表す オブジェクトを返します。
getTable() - interface jp.co.intra_mart.foundation.datastore.common.config.BaseTable のメソッド
基本テーブルが定義されているテーブル定義を取得します。
getTable() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
このエンティティを参照しているテーブルを取得します。
getTable() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable のメソッド
国際化テーブルが定義されているテーブル定義を取得します。
getTable() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable のメソッド
期間国際化テーブルが定義されているテーブル定義を取得します。
getTable() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable のメソッド
期間化テーブルが定義されているテーブル定義を取得します。
getTables() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義しているテーブル定義の一覧を取得します。
getTargetEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ターゲットエンティティの情報を取得します。
getTargetLocales() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
対象ロケールの取得。
getTargetRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
このエンティティをターゲットとしているリレーションシップをすべて取得します。
getTelNo() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
電話番号取得。
getTelephoneNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
電話番号を取得します。
getTelephoneNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
電話番号を取得します。
getTelephoneNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
電話番号を取得します。
getTelephoneNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
電話番号を取得します。
getTelephoneNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
電話番号を取得します。
getTelephoneNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
電話番号を取得します。
getTelephoneNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
電話番号を取得します。
getTelephoneNumber(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
電話番号を取得します。
getTelephoneNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
電話番号を取得します。
getTelephoneNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
電話番号を取得します。
getTelephoneNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
電話番号を取得します。
getTelephoneNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
電話番号を取得します。
getTelephoneNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
電話番号を取得します。
getTelephoneNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
電話番号を取得します。
getTelephoneNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
電話番号を取得します。
getTemplate(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager のメソッド
指定された商品属性テンプレート情報を返します。
getTemplateCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
テンプレートコードを取得します。
getTemplateCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
テンプレートコードを取得します。
getTemplateCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate のメソッド
テンプレートコードを取得します。
getTemplateCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel のメソッド
テンプレートコードを取得します。
getTemplateCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
テンプレートコードを取得します。
getTemplateCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel のメソッド
テンプレートコードを取得します。
getTemplateDetail(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager のメソッド
指定された商品属性テンプレートの明細情報を返します。
getTemplateDetailCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
テンプレート明細コードを取得します。
getTemplateDetailCode() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
テンプレート明細コードを取得します。
getTemplateDetailCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel のメソッド
テンプレート明細コードを取得します。
getTemplateDetailCode() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
テンプレート明細コードを取得します。
getTemplateDetailName() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
テンプレート明細名を取得します。
getTemplateDetailName(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
テンプレート明細名を取得します。
getTemplateDetailName() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetailInternational のメソッド
テンプレート明細名を取得します。
getTemplateDetailName() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
テンプレート明細名を取得します。
getTemplateDetailName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
テンプレート明細名を取得します。
getTemplateDetailName() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailInternationalModel のメソッド
テンプレート明細名を取得します。
getTemplateName() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate のメソッド
テンプレート名を取得します。
getTemplateName() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplateInternational のメソッド
テンプレート名を取得します。
getTemplateName() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel のメソッド
テンプレート名を取得します。
getTemplateName() - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateInternationalModel のメソッド
テンプレート名を取得します。
getTemplates(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager のメソッド
指定された検索条件に該当する商品属性テンプレート情報を返します。
getTerm() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
期間を取得します。
getTerm() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
期間化モデルが保持する期間 Term を取得します。
getTerm() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel のメソッド
期間化モデルが保持する期間 Term を取得します。
getTermCode() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
期間CDを取得します。
getTermColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable のメソッド
期間CDに該当するカラムのカラム名を取得します。
getTermColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable のメソッド
期間CDに該当するカラムのカラム名を取得します。
getTermColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable のメソッド
期間CDに該当するカラムのカラム名を取得します。
getTermColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable のメソッド
期間CDに該当するカラムのカラム名を取得します。
getTerminableAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor のメソッド
拡張もととなる期間化アクセサを取得します。
getTerminableAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor のメソッド
この期間国際化アクセサが所属する期間化アクセサを取得します。
getTerminableAccessor() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
この期間化モデルに割り当てられた期間化アクセサを取得します。
getTerminableAccessor() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
期間化アクセサを取得します。
getTerminableAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
基本アクセサに関連する期間化アクセサのマップを取得します。
getTerminableInternationalAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor のメソッド
拡張もととなる期間国際化アクセサを取得します。
getTerminableInternationalAccessor() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のメソッド
この期間国際化モデルに割り当てられた期間国際化アクセサを取得します。
getTerminableInternationalAccessor() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext のメソッド
期間国際化アクセサを取得します。
getTerminableInternationalAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
この期間化アクセサに対する期間国際化アクセサのマップを取得します。
getTerminableInternationalModel() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
期間国際化モデルを取得します。
getTerminableInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
期間国際化モデルのマップを取得します。
getTerminableInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel のメソッド
期間国際化モデルを取得します。
getTerminableInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
期間国際化モデルマップを取得します。
getTerminableInternationalTable() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
期間国際化テーブルを取得します。
getTerminableKey() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ソースエンティティの期間化基準項目を取得します。
getTerminableModel() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
期間化モデルを取得します。
getTerminableModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel のメソッド
期間化モデルのマップを取得します。
getTerminableModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
期間化モデルマップを取得します。
getTerminableModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
期間化モデルのマップを取得します。
getTerminableTable() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
期間化テーブルを取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
この組織所属で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
この会社組織分類で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
この会社で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
この組織で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
この主所属で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
この役職で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
この取扱で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
この商品で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
このパブリックグループ所属で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
このパブリックグループ分類で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
このパブリックグループで管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
このパブリックグループセットで管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
このユーザで管理している期間をすべて取得します。
getTerms() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap のメソッド
現在管理している期間の一覧を取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。
getTerms() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap のメソッド
マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。
getText() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
本文を取得します。
getTimes() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
次を取得します。
getTimes() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
次を取得します。
getTitle() - class jp.co.intra_mart.foundation.navigator.TitleInfo のメソッド
タイトル取得
getTitleInfo(Locale) - class jp.co.intra_mart.foundation.navigator.NavigatorItem のメソッド

getTo() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Toの一覧を取得します。
getTransactionIsolation() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection の現在のトランザクション遮断レベルを取得します。
getType() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性の型を取得します。
getType() - interface jp.co.intra_mart.foundation.datastore.common.config.Column のメソッド
カラムの型を取得します。
getType() - interface jp.co.intra_mart.foundation.datastore.common.config.Property のメソッド
プロパティの型を取得します。
getType() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
アプリケーションタイプを取得します。
getType() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
ノードのタイプを取得します。
getType() - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のメソッド
推奨されていません。 このオブジェクトが表す MIME タイプを返します。
getTypeMap() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この接続に関連した型マップオブジェクトを取得します。
getURL() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL のメソッド
サーバから返されたＵＲＬを返します。
getURL(HTTPActionEventHandler, String) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の static メソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(HTTPActionEventHandler, URL) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の static メソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(HTTPActionEventHandler, HttpURLConnection) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の static メソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(String) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(URL) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(HttpURLConnection) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getUnit() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
表示単位を取得します。
getUnitCode() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail のメソッド
単位コードを取得します。
getUnitCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager のメソッド
単位名に対する単位コードを取得します。
getUnitCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
単位コードを取得します。
getUnitCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
単位コードを取得します。
getUnitCode() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailTerminableModel のメソッド
単位コードを取得します。
getUnitCode() - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitBaseModel のメソッド
単位コードを取得します。
getUnitName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager のメソッド
単位コードに対する名称を返します。
getUnitName() - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitBaseModel のメソッド
単位名を取得します。
getUnitPrice() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
単価を取得します。
getUnitPrice(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
単価を取得します。
getUnitPrice() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable のメソッド
単価を取得します。
getUnitPrice() - class jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail のメソッド
単価を取得します。
getUnitPrice() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
単価を取得します。
getUnitPrice(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
単価を取得します。
getUnitPrice() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealTerminableModel のメソッド
単価を取得します。
getUnitPrice() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
単価を取得します。
getUnitPrice(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
単価を取得します。
getUnitPrice() - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailTerminableModel のメソッド
単価を取得します。
getUnits() - class jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager のメソッド
単位の一覧を取得します。
getUpdateInfo() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティの更新情報を取得します。
getUpdateTimestamp() - interface jp.co.intra_mart.foundation.datastore.common.config.UpdateInfo のメソッド
エンティティの更新日付となる属性を取得します。
getUpdateUser() - interface jp.co.intra_mart.foundation.datastore.common.config.UpdateInfo のメソッド
エンティティの更新ユーザとなる属性を取得します。
getUrl() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
URLを取得します。
getUrl(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
URLを取得します。
getUrl() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
URLを取得します。
getUrl() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
URLを取得します。
getUrl(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
URLを取得します。
getUrl() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
URLを取得します。
getUrl() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
URLを取得します。
getUrl(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
URLを取得します。
getUrl() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
URLを取得します。
getUrl() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
URLを取得します。
getUrl(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
URLを取得します。
getUrl() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
URLを取得します。
getUrl() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
URLを取得します。
getUrl(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
URLを取得します。
getUrl() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
URLを取得します。
getUrl() - class jp.co.intra_mart.foundation.navigator.LinkPageInfo のメソッド
URL取得
getUrl() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
リンク先のURLを取得します。
getUrl() - class jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet のメソッド
URLを取得します。
getUrl() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ダイレクトＵＲＬを取得する。
getUrl() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ダイレクトＵＲＬを取得する。
getUrl() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ダイレクトＵＲＬを取得する。
getUrl() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
URLを取得します。
getUrl() - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のメソッド
ＵＲＬを取得します。
getUrl() - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
URLを取得します。
getUrlName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ダイレクトＵＲＬをセッションに保管するためパラメータ名を取得する。
getUrlParam(String) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のメソッド
ＵＲＬ引数(Map)の値を取得します。
getUrlParamKeys() - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のメソッド
ＵＲＬ引数(MAP)のキーの一覧を取得します。
getUrlParameterName() - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer のメソッド
ダイレクトＵＲＬリクエストパラメータ名を取得する。
getUrlParameterName() - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
ダイレクトＵＲＬリクエストパラメータ名を取得する。
getUrlSignParameterName() - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer のメソッド
ダイレクトＵＲＬ署名リクエストパラメータ名を取得する。
getUrlSignParameterName() - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
ダイレクトＵＲＬ署名リクエストパラメータ名を取得する。
getUrlSignature() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ダイレクトＵＲＬ署名を取得する。
getUrlSignature() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ダイレクトＵＲＬ署名を取得する。
getUrlSignature() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ダイレクトＵＲＬ署名を取得する。
getUrlSignatureName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ダイレクトＵＲＬ署名をセッションに保管するためパラメータ名を取得する。
getUser(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager のメソッド
登録済のユーザを取得します。
getUser() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ログインユーザIDを取得する。
getUser() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ログインユーザIDを取得する。
getUser() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインユーザIDを取得する。
getUserAgent() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
ブラウザ情報を取得する。
getUserAgent(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuAnalyzer のメソッド
モバイル端末固体識別番号を取得します。
getUserAgent(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuHdmlAnalyzer のメソッド
推奨されていません。 モバイル端末固体識別番号を取得します。
getUserAgent(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoAnalyzer のメソッド
モバイル端末固体識別番号を取得します。
getUserAgent(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoMoveAnalyzer のメソッド
推奨されていません。 モバイル端末固体識別番号を取得します。
getUserAgent(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginJphoneAnalyzer のメソッド
推奨されていません。 モバイル端末固体識別番号を取得します。
getUserAgent(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginSoftBankAnalyzer のメソッド
モバイル端末固体識別番号を取得します。
getUserAgent(String, HttpServletRequest) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginVodafoneAnalyzer のメソッド
モバイル端末固体識別番号を取得します。
getUserAgent(String, HttpServletRequest) - interface jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider のメソッド
モバイル端末固体識別番号を取得します。
getUserCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
ユーザコードを取得します。
getUserCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
ユーザコードを取得します。
getUserCode() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
ユーザコードを取得します。
getUserCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
ユーザコードを取得します。
getUserCode() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザコードを取得します。
getUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
ユーザコードを取得します。
getUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
ユーザコードを取得します。
getUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
ユーザコードを取得します。
getUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
ユーザコードを取得します。
getUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザコードを取得します。
getUserId() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ユーザIDを取得します。
getUserId() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
ログインユーザIDを取得する。
getUserId() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
ユーザID取得。
getUserId() - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel のメソッド
ユーザIDを取得します。
getUserId() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
ユーザIDを取得します。
getUserId() - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel のメソッド
ユーザIDを取得します。
getUserId() - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel のメソッド
ユーザIDを取得します。
getUserIds(String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
ユーザIDの一覧を取得する。
getUserIds(String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
ユーザIDの一覧を取得する。
getUserIds() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
すべてのユーザIDを取得します。
getUserIdsByAccountRole(String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
getUserIdsByAccountRole(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
getUserIdsByAccountRole(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
getUserIdsByAttribute(String, String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウント属性情報の値と一致するユーザIDを取得する。
getUserIdsByAttribute(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント属性情報の値と一致するユーザIDを取得する。
getUserIdsByAttribute(String, String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウント属性情報の値と一致するユーザIDを取得します。
getUserIdsByRole(String, Date) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
有効なロールIDを持つすべてのユーザIDを取得します。
getUserIdsByRoles(String, String[], Date) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
getUserIdsByRoles(String, String[], Date) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
getUserIdsByRolesIn(String, String[], Date) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
getUserIdsByRolesPlural(String, String[], Date) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
getUserImageIcons(String) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
すべてのユーザイメージアイコンを取得します。
getUserManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager の static メソッド
UserManagerを取得します。
getUserName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ユーザＩＤをセッションに保管するためのパラメータ名を取得する。
getUserParameterName() - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer のメソッド
ユーザＩＤリクエストパラメータ名を取得する。
getUserParameterName() - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
ユーザＩＤリクエストパラメータ名を取得する。
getUserTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
指定された期間に対する期間化情報を取得します。
getUserTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
指定された日時に対する期間化情報を取得します。
getUserTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getUsersDeals(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
現在、ユーザがアクセスできる取扱情報を返します。
getUsersDeals(String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
指定された日付にユーザがアクセスできる取扱情報を返します。
getUsersDealsByKey(String, String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
現在、存在する取扱情報の中で、商品と取引先から特定されるものを返します。
getUsersDealsByKey(String, String, String, String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
指定された日時に存在する取扱情報の中で、商品と取引先から特定されるものを返します。
getValidEndDate() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
有効終了日を取得します。
getValidEndDate() - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のメソッド
有効終了日を取得します。
getValidEndDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
有効終了日を取得します。
getValidEndDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel のメソッド
有効終了日を取得します。
getValidEndYear() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
有効終了年を取得します。
getValidEndYear() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
有効終了年を取得します。
getValidFlg() - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
有効フラグを取得します。
getValidStartDate() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
有効開始日取得。
getValidStartDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
有効開始日を取得します。
getValidStartDate() - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel のメソッド
有効開始日を取得します。
getValidStartYear() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
有効開始年を取得します。
getValidStartYear() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
有効開始年を取得します。
getValue(ResultSet, int) - interface jp.co.intra_mart.foundation.database.DBResultAdapter のメソッド
カラムからデータを取得します。
getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultArrayAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultBigDecimalAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultBigIntAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultBinaryAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultBlobAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultBooleanAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultByteAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultClobAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultDateAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultDoubleAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultImTimestampAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultIntegerAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultNullAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultObjectAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultRealAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultRefAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultShortAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultStringAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultStructAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultTimeAdapter のメソッド

getValue(ResultSet, int) - class jp.co.intra_mart.foundation.database.DBResultTimestampAdapter のメソッド

getValue() - class jp.co.intra_mart.foundation.datastore.exporter.Filter のメソッド
フィルタリングされる値の配列を返します。
getValue() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値を取得します。
getValues() - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のメソッド
エラーメッセージで使用する置換用の文字列を取得します。
getVersion(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
現在の会社構成バージョン情報を取得します。
getVersion(String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
指定された日付の会社構成バージョン情報を取得します。
getVersion(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
現在のパブリックグループセット構成バージョン情報を取得します。
getVersion(String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
指定された日付のパブリックグループセット構成バージョン情報を取得します。
getVersion() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
バージョンを取得します。
getVersionCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
バージョンコードを取得します。
getVersionCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
バージョンコードを取得します。
getVersionCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
バージョンコードを取得します。
getVersionCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
バージョンコードを取得します。
getVersionCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
バージョンコードを取得します。
getVersionCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
バージョンコードを取得します。
getWarnings() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection に関する呼び出しによって通知された最初の警告を返します。
getWeek() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
週を取得します。
getWeek() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
週を取得します。
getWeekdayInfos() - class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo のメソッド
データタイプが非休日であるカレンダーデータの一覧を取得します。
getWidth() - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルの幅を返却します。
getWidth() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
表示単位に対する幅を取得します。
getXMailerHeader() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
送信メールに付加するX-Mailerヘッダを取得します。
getYear() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
年を取得します。
getYear() - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
年を取得します。
getZipCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
郵便番号を取得します。
getZipCode(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
郵便番号を取得します。
getZipCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
郵便番号を取得します。
getZipCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
郵便番号を取得します。
getZipCode(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
郵便番号を取得します。
getZipCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
郵便番号を取得します。
getZipCode() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
郵便番号を取得します。
getZipCode(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
郵便番号を取得します。
getZipCode() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
郵便番号を取得します。
getZipCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
郵便番号を取得します。
getZipCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
郵便番号を取得します。
getZipCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
郵便番号を取得します。
getZipCode() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
郵便番号を取得します。
getZipCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
郵便番号を取得します。
getZipCode() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
郵便番号を取得します。
getenv(String) - class jp.co.intra_mart.foundation.http.CGIEnvironment のメソッド
値の取得。
groupSetAdded(String, PublicGroupSet) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
グループセットがデータストアに登録された後に呼び出されます。
groupSetAdded(String, PublicGroupSet) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
グループセットがデータストアに登録された後に呼び出されます。
groupSetAdded(String, PublicGroupSet) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
グループセットがデータストアに登録された後に呼び出されます。
groupSetDeleted(String, PublicGroupSet) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
グループセットがデータストアから削除された後に呼び出されます。
groupSetDeleted(String, PublicGroupSet) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
グループセットがデータストアから削除された後に呼び出されます。
groupSetDeleted(String, PublicGroupSet) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
グループセットがデータストアから削除された後に呼び出されます。

H

HTTPActionEvent - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent.
Application Runtime で実行されるイベントのためのインターフェースです。
HTTPActionEventClientContext - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext.
Application Runtime で実行されるイベントの実行を要求した クライアントに関する情報インターフェースです。
HTTPActionEventContent - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent.
Web コンテンツを取得するための共通インターフェースです。
HTTPActionEventContext - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext.
Application Runtime で実行されるイベントに関する情報インターフェースです。
HTTPActionEventEntityHandler - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler.
HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventEntityHandler() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のコンストラクタ
新しいイベントハンドラを作成します。
HTTPActionEventException - exception jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException.
HTTPActionEvent に関するエラーを通知するための例外です。
HTTPActionEventException(String) - class jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventException(String, Throwable) - class jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
HTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler.
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
HTTPActionEventFilterHandler(HTTPActionEventHandler) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のコンストラクタ
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラを作成します。
HTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler.
HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のコンストラクタ
新しいイベントハンドラを作成します。
HTTPActionEventHandlerException - exception jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException.
HTTPActionEventHandler 内で発生したエラーを通知するための例外です。
HTTPActionEventHandlerException(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerException(String, Throwable) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerParameterException - exception jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException.
HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。
HTTPActionEventHandlerParameterException(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerParameterException(String, Throwable) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
HTTPActionEventListenerContext - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext.
Application Runtime でイベントの実行制御を行うリスナーに関する情報インターフェースです。
HTTPActionEventResult - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult.
HTTPActionEvent 実行要求の結果に関する共通インターフェースです。
HTTPActionEventResultWrapper - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper.
HTTPActionEventResult のラッパーオブジェクトです。
HTTPActionEventResultWrapper(HTTPActionEventResult) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のコンストラクタ
指定の結果オブジェクトをラップする新しい結果オブジェクトを作成します。
HTTPActionEventURL - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL.
Web コンテンツへのアクセスＵＲＬを取得するための共通インターフェースです。
HalfKanaTransrateListener - class jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener.
送信メールの件名と本文に含まれる半角カナ文字を、全角カナ文字に変換するリスナです。
HalfKanaTransrateListener() - class jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener のコンストラクタ
HalfKanaTransrateListenerを新規に生成します。
HexInputStream - class jp.co.intra_mart.foundation.utility.io.HexInputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream クラスを使用してください。
HexInputStream(InputStream) - class jp.co.intra_mart.foundation.utility.io.HexInputStream のコンストラクタ
推奨されていません。 指定された InputStream から読み込む HexInputStream を作成します。
HexOutputStream - class jp.co.intra_mart.foundation.utility.io.HexOutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream クラスを使用してください。
HexOutputStream(OutputStream) - class jp.co.intra_mart.foundation.utility.io.HexOutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に書き込む HexOutputStream を作成します。
HomeDirectory - class jp.co.intra_mart.foundation.service.provider.HomeDirectory.
このクラスは、サーバ実行システムのホームディレクトリに関する機能を 提供します。
handleEvent() - interface jp.co.intra_mart.foundation.utility.EventListener のメソッド
推奨されていません。 イベントが発生した時にコントローラから呼び出されます。
handleInit() - class jp.co.intra_mart.foundation.security.filter.ActiveSessionFilter のメソッド
初期化します。
handleInit() - class jp.co.intra_mart.foundation.security.filter.DuplicateLoginHandlingFilter のメソッド
初期化します。
handleInit() - class jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter のメソッド
初期化します。
handleInit() - class jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter のメソッド
このフィルタを初期化します。
handleSocketEvent(ExtendedSocket) - interface jp.co.intra_mart.foundation.utility.net.SocketEventListener のメソッド
推奨されていません。 ソケットに関するイベント発生時に呼び出されるメソッド。
handleThreadStop() - interface jp.co.intra_mart.foundation.utility.ThreadStopListener のメソッド
推奨されていません。 監視していたスレッドが終了したときに実行されるメソッドです。
hasActiveSessionInfo(String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたセッションIDのアクティブなセッション情報が存在するかチェックします。
hasBaseAttributes() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張エンティティが期間化も国際化もされていない従属属性を持つかどうか判定します。
hasChildNode(TreeNode) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
指定されたノード node を持っているか調べます。
hasChildNodes() - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
このノードが子ノードを持っているかどうかを判断します。
hasChildNodes() - interface jp.co.intra_mart.foundation.page.TreeNodeContainer のメソッド
このノードが子ノードを持っているかどうかを判断します。
hasChildren() - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
子メニューが存在するかどうかを取得します。
hasInternationalAttributes() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張エンティティが国際化のみされている従属属性を持つかどうか判定します。
hasParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
hasParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
hasParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
hasProperty(String) - interface jp.co.intra_mart.foundation.scenario.VariableScope のメソッド
プロパティが存在しているかをチェックします。
hasReporter(MessageReporter) - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。
hasTerminableAttributes() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張エンティティが期間化のみされている従属属性を持つかどうか判定します。
hasTerminableInternationalAttributes() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張エンティティが期間国際化されている従属属性を持つかどうか判定します。
hashCode() - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
有効期間のハッシュコード値を返します。
hashCode() - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 このリストのハッシュコード値を返します。
hashCode() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
このオブジェクトに対するハッシュコード値を返します。
hashCode() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ハッシュコードを取得します。
hashCode() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
ハッシュコード値取得。
hashCode() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
ハッシュコードを取得します。
hashCode() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
ハッシュコードを取得します。
hashCode() - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
ハッシュコードを取得します。
hashCode() - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ハッシュコードを取得します。

I

ID_CRYPTION_CLASS - class jp.co.intra_mart.foundation.security.StandardAccountAccessor の static 変数
暗号化クラス名
ID_CRYPTION_CLASS - class jp.co.intra_mart.foundation.security.account.CsvAccountBackup の static 変数
暗号化クラス名
ID_CRYPTION_CLASS - class jp.co.intra_mart.foundation.security.account.StandardAccountBackup の static 変数
暗号化クラス名
ID_NAVIGATOR_ACCESS_INFO - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
ACCESS INFO
ID_NAVIGATOR_COMMENT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_COMPANY_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_DEPARTMENT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_DEPARTMENT_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_EVENT_FLOW - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
EVENT FLOW
ID_NAVIGATOR_EVENT_FLOW_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_EVENT_FLOW_OPEN - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_EVENT_FLOW_SORT_NUMBER - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_EVENT_ITEM - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
EVENT ITEM
ID_NAVIGATOR_EVENT_ITEM_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_EVENT_RESULT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
EVENT RESULT
ID_NAVIGATOR_EVENT_RESULT_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_GROUP_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_GROUP_SET_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_ITEM_TYPE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_LINK_PAGE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
LINK PAGE
ID_NAVIGATOR_LOCALE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_PARAM - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_PARAM_KEY - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_PARAM_VALUE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_POST - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_POST_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_PUBLIC_GROUP - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_RESULT_PAGE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
RESULT PAGE
ID_NAVIGATOR_RESULT_PAGE_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_RESULT_PAGE_LIST - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_ROLE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_ROLE_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_SELECT_ITEM - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
SELECT ITEM
ID_NAVIGATOR_SELECT_ITEM_ID - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_SELECT_ITEM_LIST - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_TITLE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_NAVIGATOR_TITLE_INFO - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
TITLE INFO
ID_NAVIGATOR_URL - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_ROOT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_ROOT_NAVIGATOR - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

ID_SECURITY_ACCOUNT - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler の static 変数

ID_SECURITY_GROUP - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler の static 変数

ID_SECURITY_PASSWORD - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler の static 変数

IMAGE_PATH - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel の static 変数
イメージパス
IMAGE_PATH - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の static 変数
イメージパス
IM_AJAX_USER_AGENT_FIREFOX - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static 変数
「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Firefox
IM_AJAX_USER_AGENT_IE - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static 変数
「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Internet Explorer
IM_AJAX_USER_AGENT_NETSCAPE - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static 変数
「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Netscape
IM_AJAX_USER_AGENT_OPERA - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static 変数
「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Opera
IM_AJAX_USER_AGENT_SAFARI - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static 変数
「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Safari
INDEX_UNDEFINED - class jp.co.intra_mart.foundation.database.DatabaseColumn の static 変数

INonTransaction - interface jp.co.intra_mart.foundation.security.INonTransaction.
分散トランザクション未対応のアクセッサに実装するインターフェース。
ITEM_CAPTION - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel の static 変数
商品通称
ITEM_CATALOGUE_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel の static 変数
商品カタログコード
ITEM_CATEGORY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel の static 変数
商品カテゴリコード
ITEM_CATEGORY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel の static 変数
商品カテゴリコード
ITEM_CATEGORY_NAME - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel の static 変数
商品カテゴリ名
ITEM_CATEGORY_TYPE_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel の static 変数
商品カテゴリ種別コード
ITEM_CATEGORY_TYPE_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel の static 変数
商品カテゴリ種別コード
ITEM_CATEGORY_TYPE_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel の static 変数
商品カテゴリ種別コード
ITEM_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel の static 変数
商品コード
ITEM_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel の static 変数
商品コード
ITEM_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel の static 変数
商品コード
ITEM_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel の static 変数
商品コード
ITEM_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel の static 変数
商品コード
ITEM_NAME - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel の static 変数
商品名
Identifier - class jp.co.intra_mart.foundation.service.client.information.Identifier.
ユニークなＩＤを生成する機能を提供します。
Identifier() - class jp.co.intra_mart.foundation.service.client.information.Identifier のコンストラクタ
唯一のコンストラクタ。
IllegalArgumentException - exception jp.co.intra_mart.foundation.security.exception.IllegalArgumentException.
引数が不正の例外クラス。
IllegalArgumentException(String, String) - class jp.co.intra_mart.foundation.security.exception.IllegalArgumentException のコンストラクタ
コンストラクタ。
IllegalArgumentException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.IllegalArgumentException のコンストラクタ
コンストラクタ。
IllegalExtensionException - exception jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException.
拡張アクセサに関する例外クラス

拡張アクセサに対して不正な操作が行われた場合にスローする。
IllegalExtensionException() - class jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException のコンストラクタ
コンストラクタ
IllegalExtensionException(String) - class jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException のコンストラクタ
コンストラクタ
IllegalExtensionException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException のコンストラクタ
コンストラクタ
IllegalExtensionException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException のコンストラクタ
コンストラクタ
IllegalLocaleException - exception jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException.
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
IllegalLocaleException() - class jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException のコンストラクタ
コンストラクタ
IllegalLocaleException(String) - class jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException のコンストラクタ
コンストラクタ
IllegalLocaleException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException のコンストラクタ
コンストラクタ
IllegalLocaleException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException のコンストラクタ
コンストラクタ
IllegalPasswordException - exception jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException.
パスワードが認証されなかったことを通知するための例外です。
IllegalPasswordException(String) - class jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException のコンストラクタ
指定のメッセージで例外を作成します。
IllegalRelationshipException - exception jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException.
リレーションシップに関する例外クラス

リレーションシップの整合性が正しくない場合にスローする。
IllegalRelationshipException() - class jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException のコンストラクタ
コンストラクタ
IllegalRelationshipException(String) - class jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException のコンストラクタ
コンストラクタ
IllegalRelationshipException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException のコンストラクタ
コンストラクタ
IllegalRelationshipException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException のコンストラクタ
コンストラクタ
IllegalTermException - exception jp.co.intra_mart.foundation.datastore.exception.IllegalTermException.
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
IllegalTermException() - class jp.co.intra_mart.foundation.datastore.exception.IllegalTermException のコンストラクタ
コンストラクタ
IllegalTermException(String) - class jp.co.intra_mart.foundation.datastore.exception.IllegalTermException のコンストラクタ
コンストラクタ
IllegalTermException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalTermException のコンストラクタ
コンストラクタ
IllegalTermException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalTermException のコンストラクタ
コンストラクタ
ImAjaxUtil - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil.
CSJSライブラリ「ImAjax」で通信を行う際に有用なサーバサイドのユーティリティクラスです。
ImAjaxUtil() - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil のコンストラクタ

ImageIconException - exception jp.co.intra_mart.foundation.image.ImageIconException.
イメージアイコンの例外クラス。
ImageIconException() - class jp.co.intra_mart.foundation.image.ImageIconException のコンストラクタ
コンストラクタ。
ImageIconException(String) - class jp.co.intra_mart.foundation.image.ImageIconException のコンストラクタ
コンストラクタ。
ImageIconException(Throwable) - class jp.co.intra_mart.foundation.image.ImageIconException のコンストラクタ
コンストラクタ。
ImageIconException(String, Throwable) - class jp.co.intra_mart.foundation.image.ImageIconException のコンストラクタ
コンストラクタ。
ImageIconInfo - class jp.co.intra_mart.foundation.image.ImageIconInfo.
イメージアイコン情報クラス。
ImageIconInfo(String) - class jp.co.intra_mart.foundation.image.ImageIconInfo のコンストラクタ
コンストラクタ。
ImageIconInfo(String, int) - class jp.co.intra_mart.foundation.image.ImageIconInfo のコンストラクタ
コンストラクタ。
ImageIconInfo(String, String, int) - class jp.co.intra_mart.foundation.image.ImageIconInfo のコンストラクタ
コンストラクタ。
ImageIconManager - class jp.co.intra_mart.foundation.image.ImageIconManager.
アイコンマネージャクラス。
ImageIconManager(String) - class jp.co.intra_mart.foundation.image.ImageIconManager のコンストラクタ

ImageIconMessageBundle - class jp.co.intra_mart.foundation.image.ImageIconMessageBundle.

ImageIconMessageBundle() - class jp.co.intra_mart.foundation.image.ImageIconMessageBundle のコンストラクタ

ImportConfigurationReader - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader.
インポート設定情報の読込みを行います。
ImportConfigurationReaderException - exception jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReaderException.
インポート設定の読み込みでエラーが発生したことを示すためにスローされます。
ImportConfigurationReaderException(String) - class jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReaderException のコンストラクタ
コンストラクタ
ImportConfigurationReaderException(Throwable) - class jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReaderException のコンストラクタ
コンストラクタ
ImportConfigurationReaderException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReaderException のコンストラクタ
コンストラクタ
ImportException - exception jp.co.intra_mart.foundation.datastore.exception.ImportException.
アプリケーション共通マスタのインポートに関する例外クラス

ImportException() - class jp.co.intra_mart.foundation.datastore.exception.ImportException のコンストラクタ
コンストラクタ
ImportException(String) - class jp.co.intra_mart.foundation.datastore.exception.ImportException のコンストラクタ
コンストラクタ
ImportException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.ImportException のコンストラクタ
コンストラクタ
ImportException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.ImportException のコンストラクタ
コンストラクタ
ImportInitializeException - exception jp.co.intra_mart.foundation.datastore.importer.ImportInitializeException.
インポートの初期化で何らかのエラーが発生したことを示すためにスローされます。
ImportInitializeException(String) - class jp.co.intra_mart.foundation.datastore.importer.ImportInitializeException のコンストラクタ
コンストラクタ
ImportInitializeException(Throwable) - class jp.co.intra_mart.foundation.datastore.importer.ImportInitializeException のコンストラクタ
コンストラクタ
ImportInitializeException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.importer.ImportInitializeException のコンストラクタ
コンストラクタ
ImportManager - interface jp.co.intra_mart.foundation.datastore.importer.ImportManager.
インポートを行います。
ImportManagerClient - interface jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient.
設定ファイルを読込んで、インポートマネージャーをセットアップ、実行します。
ImportManagerImpl - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl.
インポートマネージャーの実装です。
ImportManagerImpl(String) - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl のコンストラクタ
コンストラクタ
InitialFile - class jp.co.intra_mart.foundation.service.client.information.InitialFile.
設定ファイル(*.ini)の内容を読み込むためのクラスです。
InitialFile(String) - class jp.co.intra_mart.foundation.service.client.information.InitialFile のコンストラクタ
リソースサービスが動作しているサーバのリソースディレクトリ内にある 指定の ini ファイルを読み込みます。
InitialPageSessionHandlingFilter - class jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter.
ログインしている状態にログイン画面を表示しようとした際に警告ページを表示するためのフィルタ。
InitialPageSessionHandlingFilter() - class jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter のコンストラクタ

InputCheck - class jp.co.intra_mart.foundation.commons.validation.InputCheck.
入力チェック関数ライブラリ
InputCheck() - class jp.co.intra_mart.foundation.commons.validation.InputCheck のコンストラクタ

InternationalAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor.
国際化エンティティに対する情報操作用のインタフェースです。
InternationalAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap.
国際化アクセサのマッピング情報を持ちます。
InternationalKey - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalKey.
国際化基準項目を定義します。
InternationalModel - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalModel.
国際化モデルを定義します。
InternationalModel - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel.
国際化モデルの情報です。
InternationalModelContext - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext.
国際化モデルの初期化に必要な設定を持ちます。
InternationalModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap.
国際化モデルのマッピング情報を持ちます。
InternationalTable - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable.
国際化テーブルを定義します。
InternetPortlet - class jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet.
ページ種別「インターネット」に対するポートレットのモデルです。
InternetPortlet() - class jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet のコンストラクタ

IntramartDBMapper - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper.
intra-martで管理されるデータベースにアクセスするマッパーの汎用的な抽象クラスです。
IntramartDBMapper() - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のコンストラクタ

Item - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item.
商品の基本属性のデータを取り扱います。
Item() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のコンストラクタ
商品に関連する情報を新規に生成します。
Item(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のコンストラクタ
商品に関連する情報を新規に生成します。
Item(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のコンストラクタ
商品に関連する情報を新規に生成します。
Item(Locale, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のコンストラクタ
商品に関連する情報を新規に生成します。
ItemAttach - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach.
商品分類の基本属性のデータを取り扱います。
ItemAttach() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach のコンストラクタ

ItemAttachBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel.
商品分類の基本モデルです。
ItemAttachImporter - interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemAttachImporter.
商品分類のインポートのインターフェースです。
ItemAttachMapper - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper.
商品分類に関連するマッパです。
ItemAttribute - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute.
商品属性の基本属性のデータを取り扱います。
ItemAttribute() - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のコンストラクタ
商品属性に関連する情報を新規に生成します。
ItemAttribute(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のコンストラクタ
商品属性に関連する情報を新規に生成します。
ItemAttributeBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel.
商品属性の基本モデルです。
ItemAttributeInternational - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttributeInternational.
商品属性の国際化属性のデータを取り扱います。
ItemAttributeInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttributeInternational のコンストラクタ

ItemAttributeInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeInternationalModel.
商品属性の国際化モデルです。
ItemAttributeMapper - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper.
商品属性に関連するマッパです。
ItemBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel.
商品の基本モデルです。
ItemCatalogue - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue.
商品カタログの基本属性のデータを取り扱います。
ItemCatalogue() - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のコンストラクタ

ItemCatalogueBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel.
商品カタログの基本モデルです。
ItemCatalogueMapper - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper.
商品カタログに関連するマッパです。
ItemCatalogueMediaManager - interface jp.co.intra_mart.foundation.datastore.application.domain.item.ItemCatalogueMediaManager.
商品カタログの媒体情報を管理するクラスです。
ItemCategory - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory.
商品カテゴリの基本属性のデータを取り扱います。
ItemCategory() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のコンストラクタ
商品カテゴリに関連する情報を新規に生成します。
ItemCategory(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のコンストラクタ
商品カテゴリに関連する情報を新規に生成します。
ItemCategoryBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel.
商品カテゴリの基本モデルです。
ItemCategoryImporter - interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryImporter.
商品カテゴリのインポートのインターフェースです。
ItemCategoryInternational - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategoryInternational.
商品カテゴリの国際化属性のデータを取り扱います。
ItemCategoryInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategoryInternational のコンストラクタ

ItemCategoryInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryInternationalModel.
商品カテゴリの国際化モデルです。
ItemCategoryManager - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager.
商品カテゴリに関する情報を管理します。
ItemCategoryManager() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のコンストラクタ

ItemCategoryMapper - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper.
商品カテゴリに関連するマッパです。
ItemCategoryStruct - interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryStruct.
商品カテゴリのツリー構造の構成を表すクラスです。
ItemCategoryType - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.type.ItemCategoryType.
商品カテゴリ種別の基本属性のデータを取り扱います。
ItemCategoryType() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.type.ItemCategoryType のコンストラクタ

ItemCategoryTypeBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel.
商品カテゴリ種別の基本モデルです。
ItemCategoryTypeMapper - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper.
商品カテゴリ種別に関連するマッパです。
ItemImporter - interface jp.co.intra_mart.foundation.datastore.application.domain.item.ItemImporter.
商品のインポートのインターフェースです。
ItemManager - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager.
商品に関する情報を管理します。
ItemManager() - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のコンストラクタ

ItemMapper - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper.
商品に関連するマッパです。
ItemTemplate - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate.
商品属性テンプレートの基本属性のデータを取り扱います。
ItemTemplate() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate のコンストラクタ

ItemTemplateBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel.
商品属性テンプレートの基本モデルです。
ItemTemplateDetail - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail.
商品属性テンプレート明細の基本属性のデータを取り扱います。
ItemTemplateDetail() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のコンストラクタ
商品属性テンプレート明細に関連する情報を新規に生成します。
ItemTemplateDetail(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のコンストラクタ
商品属性テンプレート明細に関連する情報を新規に生成します。
ItemTemplateDetailBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel.
商品属性テンプレート明細の基本モデルです。
ItemTemplateDetailInternational - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetailInternational.
商品属性テンプレート明細の国際化属性のデータを取り扱います。
ItemTemplateDetailInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetailInternational のコンストラクタ

ItemTemplateDetailInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailInternationalModel.
商品属性テンプレート明細の国際化モデルです。
ItemTemplateDetailMapper - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper.
商品属性テンプレート明細に関連するマッパです。
ItemTemplateImporter - interface jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateImporter.
商品属性テンプレートのインポートのインターフェースです。
ItemTemplateInternational - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplateInternational.
商品属性テンプレートの国際化属性のデータを取り扱います。
ItemTemplateInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplateInternational のコンストラクタ

ItemTemplateInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateInternationalModel.
商品属性テンプレートの国際化モデルです。
ItemTemplateManager - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager.
商品属性テンプレートの情報を管理します。
ItemTemplateManager() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager のコンストラクタ

ItemTemplateMapper - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper.
商品属性テンプレートに関連するマッパです。
ItemTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable.
商品の期間化属性のデータを取り扱います。
ItemTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable のコンストラクタ

ItemTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminableInternational.
商品の期間国際化属性のデータを取り扱います。
ItemTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminableInternational のコンストラクタ

ItemTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableInternationalModel.
商品の期間国際化モデルです。
ItemTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel.
商品の期間化モデルです。
ItemUnitManager - class jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager.
商品の単位を取り扱います。
ItemUnitManager() - class jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager のコンストラクタ

importData(InputStream) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
インポートを行います。
importData(String, InputStream) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
/** アクセスコントローラ情報をインポートします。
importData(String, InputStream) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウント情報をインポートします。
importData(String, InputStream) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
インポートを行います。
importData(String, InputStream) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
インポートを行います。
importData(String, InputStream) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニュー情報・インポート。
importData(String, InputStream) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニュー情報をインポートします。
importData(String, InputStream) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール情報・インポート。
in - class jp.co.intra_mart.foundation.utility.io.HexInputStream の変数
推奨されていません。 フィルタ処理される入力ストリームです。
increaseLoginFailureCount() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ログイン失敗回数をカウントアップします。
increment() - class jp.co.intra_mart.foundation.utility.Counter のメソッド
推奨されていません。 カウンターの値を１だけ増加させます。
indexOf(Object) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 equals メソッドを使って等しいかどうかを判定しながら、指定された引数と同じ内容の要素を先頭から検索します。
init(Node) - interface jp.co.intra_mart.foundation.database.DBResultAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultArrayAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultBigDecimalAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultBigIntAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultBinaryAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultBlobAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultBooleanAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultByteAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultClobAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultDateAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultDoubleAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultImTimestampAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultIntegerAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultNullAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultObjectAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultRealAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultRefAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultShortAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultStringAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultStructAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultTimeAdapter のメソッド
初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.database.DBResultTimestampAdapter のメソッド
初期化を行います。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のメソッド
CategoryManagerを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
会社リスナーの初期化を行います。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
CompanyManagerを初期化します。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager のメソッド
CurrencyManagerを初期化します。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
DealManagerを初期化します。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager のメソッド
DealPermissionManagerを初期化します。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
ItemManagerを初期化します。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のメソッド
ItemCategoryManagerを初期化します。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager のメソッド
ItemTemplateManagerを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
プライベートグループリスナーの初期化を行います。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
PrivateGroupManagerを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
アカウントリスナーの初期化を行います。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
PublicGroupManagerを初期化します。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager のメソッド
ItemUnitManagerを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener のメソッド
ユーザリスナーの初期化を行います。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager のメソッド
UserManagerを初期化します。
init(BaseModelContext) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel のメソッド
基本モデルを初期化します。
init(ExtendedBaseAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel のメソッド
拡張基本モデルを初期化します。
init(ExtendedBaseAccessor) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel のメソッド
拡張基本モデルを初期化します。
init(ExtendedBaseAccessorMap) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap のメソッド
初期化を行います。
init(ExtendedInternationalAccessor) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel のメソッド
拡張国際化モデルを初期化します。
init(ExtendedInternationalAccessorMap) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap のメソッド
初期化を行います。
init(ExtendedTerminableInternationalAccessor) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel のメソッド
拡張期間国際化モデルを初期化します。
init(ExtendedTerminableInternationalAccessorMap) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap のメソッド
初期化を行います。
init(ExtendedTerminableAccessor) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel のメソッド
拡張期間化モデルを初期化します。
init(ExtendedTerminableAccessorMap) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap のメソッド
初期化を行います。
init(ExtendedInternationalAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel のメソッド
拡張国際化モデルを初期化します。
init(ExtendedTerminableInternationalAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel のメソッド
拡張期間国際化モデルを初期化します。
init(ExtendedTerminableAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel のメソッド
拡張期間化モデルを初期化します。
init(BaseModelContext) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
基本モデルを初期化します。
init(InternationalModelContext) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のメソッド
国際化モデルを初期化します。
init(String, InternationalAccessorMap) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
初期化処理を行います。
init(TerminableInternationalModelContext) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のメソッド
期間国際化モデルを初期化します。
init(String, TerminableInternationalAccessorMap) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
初期化処理を行います。
init(TerminableModelContext) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
期間化モデルを初期化します。
init(String, String, TerminableAccessorMap, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
初期化処理を行います。
init(InternationalModelContext) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel のメソッド
国際化モデルを初期化します。
init(String, String) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
マッパーを初期化します。
init(String, String) - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
マッパーを初期化します。
init(TerminableInternationalModelContext) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel のメソッド
期間国際化モデルを初期化します。
init(TerminableModelContext) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel のメソッド
期間化モデルを初期化します。
init() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
StandardMailオブジェクトを初期化します。
init(String[]) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
イベントナビゲーター管理アクセッサの初期化。
init(String[]) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorExporter のメソッド
イベントナビゲータバックアップエクスポータの初期化。
init(String[]) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorImporter のメソッド
イベントナビゲータバックアップインポータの初期化。
init(Map) - class jp.co.intra_mart.foundation.navigator.EventNavigatorPermissionSelector のメソッド
インスタンスの初期化を行います。
init(String[]) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorReaderDecorator のメソッド
イベントナビゲータデコレータの初期化。
init(String[]) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
イベントナビゲーター管理アクセッサの初期化。
init(String[]) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter のメソッド

init(String[]) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter のメソッド
初期化。
init(Properties) - interface jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider のメソッド
初期化を行います。
init(Properties) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider のメソッド
初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラアクセッサの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウントアクセッサの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.StandardBatchAccessor のメソッド
初期化します。
init(Map) - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor のメソッド
カレンダーアクセッサの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
メニューアクセッサの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
ロールアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.access.AccessControllerExporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.access.AccessControllerImporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.access.AccessControllerPostWriterListener のメソッド
アクセスコントローラリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.access.AccessControllerQueryWriterListener のメソッド
アクセスコントローラリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.access.AccessControllerReaderDecorator のメソッド
アクセスコントローラデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
会社リスナーの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
アカウントリスナーの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener のメソッド
ロールリスナーの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.access.StandardAccessControllerBackup のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウントリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountExporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountImporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウントリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウントリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountReaderDecorator のメソッド
アカウントデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.account.CsvAccountBackup のメソッド
初期化。
init(Map) - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のメソッド
ロールリスナーの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.account.StandardAccountBackup のメソッド
初期化。
init(Node, Node) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
設定ファイルの情報を基に初期化します。
init(Map) - class jp.co.intra_mart.foundation.security.activesession.GroupActiveSessionRegister のメソッド
管理者ログイン認証リスナーの初期化を行います。
init(Node, Node) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
設定ファイル conf/active-session-config.xml の情報を基に初期化します。
init(Map) - class jp.co.intra_mart.foundation.security.activesession.UserActiveSessionRegister のメソッド
ユーザログイン認証リスナーの初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor のメソッド
システム管理者アクセッサを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener のメソッド
システム管理者リスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener のメソッド
システム管理者リスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator のメソッド
システム管理者デコレータの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
アクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.batch.BatchExporter のメソッド
バッチバックアップエクスポータの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.batch.BatchImporter のメソッド
バッチバックアップインポータの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener のメソッド
バッチリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener のメソッド
バッチリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator のメソッド
バッチデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup のメソッド
バッチバックアップの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
カレンダーアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.calendar.CalendarExporter のメソッド
カレンダーバックアップエクスポータの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.calendar.CalendarImporter のメソッド
カレンダーバックアップインポータの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener のメソッド
カレンダーリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener のメソッド
カレンダーリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator のメソッド
カレンダーデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup のメソッド
カレンダーバックアップの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
ページプロバイダの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.LDAPUserCertification のメソッド
ユーザログイン認証の初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider のメソッド
ページプロバイダの初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer のメソッド
ログインリクエストアナライザの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer のメソッド
ログインリクエストアナライザの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
ページプロバイダの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider のメソッド
ページプロバイダの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
ログインリクエストアナライザの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification のメソッド
管理者ログイン認証の初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider のメソッド
ページプロバイダの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardUserCertification のメソッド
ユーザログイン認証の初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider のメソッド
ページプロバイダの初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.certification.SuperCertification のメソッド
管理者ログイン認証の初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.certification.SuperCertificationListener のメソッド
管理者ログイン認証リスナーの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification のメソッド
管理者ログイン認証の初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.certification.UserCertification のメソッド
ユーザログイン認証の初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.certification.UserCertificationListener のメソッド
ユーザログイン認証リスナーの初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.certification.UserPageProvider のメソッド
ページプロバイダの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPUserCertification のメソッド
ユーザログイン認証の初期化を行います。
init(Node, Node) - interface jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor のメソッド
設定ファイルの情報を基に初期化します。
init(Node, Node) - class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor のメソッド
設定ファイル conf/duplicate-login.xml の情報を基に初期化します。
init(FilterConfig) - class jp.co.intra_mart.foundation.security.filter.SessionFilter のメソッド
初期化します。
init(FilterConfig) - class jp.co.intra_mart.foundation.security.filter.URLAccessFilter のメソッド
初期化します。
init(Map) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor のメソッド
グループ管理者アクセッサを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener のメソッド
グループ管理者リスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener のメソッド
グループ管理者リスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator のメソッド
管理者デコレータの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
ログイングアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
ログイングループ書き込み時（書き込み直前）のリスナの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
ログイングループ書き込み時（書き込み直前）のリスナの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator のメソッド
ログイングループデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
ログイングループ書き込み時（書き込み直前）のリスナの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
メニューアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuExporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuImporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
メニューリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
メニューリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator のメソッド
メニューデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
会社リスナーの初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニューアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.MenuExporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.MenuImporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener のメソッド
メニューリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener のメソッド
メニューリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator のメソッド
メニューデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
アカウントリスナーの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のメソッド
ロールリスナーの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup のメソッド
初期化。
init(Map) - class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup のメソッド
初期化。
init(Node) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuAnalyzer のメソッド
モバイル端末固体識別番号取得プロバイダの初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuHdmlAnalyzer のメソッド
推奨されていません。 モバイル端末固体識別番号取得プロバイダの初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoAnalyzer のメソッド
モバイル端末固体識別番号取得プロバイダの初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoMoveAnalyzer のメソッド
推奨されていません。 モバイル端末固体識別番号取得プロバイダの初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginJphoneAnalyzer のメソッド
推奨されていません。 モバイル端末固体識別番号取得プロバイダの初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginSoftBankAnalyzer のメソッド
モバイル端末固体識別番号取得プロバイダの初期化を行います。
init(Node) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginVodafoneAnalyzer のメソッド
モバイル端末固体識別番号取得プロバイダの初期化を行います。
init(Node) - interface jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider のメソッド
設定ファイルの情報を基に初期化します。
init(Map) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

init(Node, Node) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
パラメータを取得。
init(Map) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener のメソッド
アカウントリスナーの初期化。
init(Properties) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryNewArrivedProvider のメソッド
初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryUserPageProvider のメソッド

init(Node, Node) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
パラメータを取得。
init(Map) - class jp.co.intra_mart.foundation.security.permission.AccessControllerPermissionSelector のメソッド
インスタンスの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector のメソッド
インスタンスの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.permission.AdminMenuPermissionSelector のメソッド
インスタンスの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector のメソッド
インスタンスの初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.permission.PermissionSelector のメソッド
インスタンスの初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
ロールアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener のメソッド
ロールリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RoleExporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RoleImporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener のメソッド
ロールリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener のメソッド
ロールリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RoleReaderDecorator のメソッド
ロールデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.role.StandardRoleBackup のメソッド
初期化。
init() - class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet のメソッド
サーブレットの初期化を行います。
init() - class jp.co.intra_mart.foundation.security.servlet.LogoutServlet のメソッド
サーブレットの初期化を行います。
init() - class jp.co.intra_mart.foundation.security.servlet.MenuServlet のメソッド
メニューサーブレットの初期化を行います。
init() - class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet のメソッド
サーブレットの初期化を行います。
init() - class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet のメソッド
サーブレットの初期化を行います。
init() - class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet のメソッド
サーブレットの初期化を行います。
init(Node) - interface jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor のメソッド
ショートカットアクセッサを初期化します。
init(Node) - class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor のメソッド
ショートカットアクセッサを初期化します。
initialize(String) - interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader のメソッド
初期化を行います。
initialize(String) - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader のメソッド
初期化を行います。
initialize() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl のメソッド
初期化処理を行います。
initialize() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManagerInitializerImpl のメソッド
初期化処理を行います。
initializeTime() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
バッチ初期化時間の取得。
insert(String, Map) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースにデータを追加挿入するメソッド

データベースにインサート処理をする。
insert(CateogryClassBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
分類区分の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
分類区分の基本モデルを複数挿入します。
insert(CategoryDetailBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
分類区分詳細の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
分類区分詳細の基本モデルを複数挿入します。
insert(DepartmentAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
組織所属の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
組織所属の基本モデルを複数挿入します。
insert(CompanyCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
会社組織分類の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
会社組織分類の基本モデルを複数挿入します。
insert(CompanyBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
会社の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
会社の基本モデルを複数挿入します。
insert(DepartmentBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
組織の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
組織の基本モデルを複数挿入します。
insert(DepartmentInclusionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
組織内包の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
組織内包の基本モデルを複数挿入します。
insert(DepartmentMainBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
主所属の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
主所属の基本モデルを複数挿入します。
insert(CompanyPostBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
役職の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
役職の基本モデルを複数挿入します。
insert(CompanyVersionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
会社構成バージョンの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
会社構成バージョンの基本モデルを複数挿入します。
insert(DealBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper のメソッド
取扱の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper のメソッド
取扱の基本モデルを複数挿入します。
insert(DealerDepartmentBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper のメソッド
組織毎取扱パーミッションの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper のメソッド
組織毎取扱パーミッションの基本モデルを複数挿入します。
insert(DealDetailBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper のメソッド
取扱詳細の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper のメソッド
取扱詳細の基本モデルを複数挿入します。
insert(DealerPublicGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper のメソッド
パブリックグループ毎取扱パーミッションの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper のメソッド
パブリックグループ毎取扱パーミッションの基本モデルを複数挿入します。
insert(DealerRoleBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper のメソッド
ロール毎取扱パーミッションの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper のメソッド
ロール毎取扱パーミッションの基本モデルを複数挿入します。
insert(ItemAttributeBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper のメソッド
商品属性の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper のメソッド
商品属性の基本モデルを複数挿入します。
insert(ItemCatalogueBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper のメソッド
商品カタログの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper のメソッド
商品カタログの基本モデルを複数挿入します。
insert(ItemBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper のメソッド
商品の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper のメソッド
商品の基本モデルを複数挿入します。
insert(ItemAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper のメソッド
商品分類の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper のメソッド
商品分類の基本モデルを複数挿入します。
insert(ItemCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper のメソッド
商品カテゴリの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper のメソッド
商品カテゴリの基本モデルを複数挿入します。
insert(ItemCategoryTypeBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper のメソッド
商品カテゴリ種別の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper のメソッド
商品カテゴリ種別の基本モデルを複数挿入します。
insert(ItemTemplateDetailBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper のメソッド
商品属性テンプレート明細の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper のメソッド
商品属性テンプレート明細の基本モデルを複数挿入します。
insert(ItemTemplateBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper のメソッド
商品属性テンプレートの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper のメソッド
商品属性テンプレートの基本モデルを複数挿入します。
insert(PrivateGroupAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライベートグループ所属の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライベートグループ所属の基本モデルを複数挿入します。
insert(PrivateGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライベートグループの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライベートグループの基本モデルを複数挿入します。
insert(PublicGroupAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
パブリックグループ所属の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
パブリックグループ所属の基本モデルを複数挿入します。
insert(PublicGroupCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
パブリックグループ分類の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
パブリックグループ分類の基本モデルを複数挿入します。
insert(PublicGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
パブリックグループの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
パブリックグループの基本モデルを複数挿入します。
insert(PublicGroupInclusionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
パブリックグループ内包の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
パブリックグループ内包の基本モデルを複数挿入します。
insert(PublicGroupSetBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
パブリックグループセットの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
パブリックグループセットの基本モデルを複数挿入します。
insert(PublicGroupVersionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
パブリックグループ構成バージョンの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
パブリックグループ構成バージョンの基本モデルを複数挿入します。
insert(UnitBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper のメソッド
単位の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper のメソッド
単位の基本モデルを複数挿入します。
insert(UserBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
ユーザの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
ユーザの基本モデルを複数挿入します。
insert(BaseModel) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
基本モデルを1つだけ挿入します。
insert(Collection) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
基本モデルを複数挿入します。
insert(String, String, Date) - class jp.co.intra_mart.foundation.update.StandardUpdateAccessor のメソッド
キーを取得します。
insert(String, String, Date) - interface jp.co.intra_mart.foundation.update.UpdateAccessor のメソッド
キーを取得します。
insert(AccessControllerDepartmentBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper のメソッド
アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper のメソッド
アクセスコントローラの利用権限を保有する組織の基本モデルを複数挿入します。
insert(AccessControllerBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper のメソッド
アクセスコントローラ情報の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper のメソッド
アクセスコントローラ情報の基本モデルを複数挿入します。
insert(AccessControllerPostBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper のメソッド
アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper のメソッド
アクセスコントローラの利用権限を保有する役職の基本モデルを複数挿入します。
insert(AccessControllerPublicGroupBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper のメソッド
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper のメソッド
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを複数挿入します。
insert(AccessControllerRoleBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper のメソッド
アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper のメソッド
アクセスコントローラの利用権限を保有するロールの基本モデルを複数挿入します。
insert(AccountAttributeBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper のメソッド
アカウントが保有する属性の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper のメソッド
アカウントが保有する属性の基本モデルを複数挿入します。
insert(AccountBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccountMapper のメソッド
アカウントの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccountMapper のメソッド
アカウントの基本モデルを複数挿入します。
insert(AccountRoleBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper のメソッド
アカウントが保有するロールの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper のメソッド
アカウントが保有するロールの基本モデルを複数挿入します。
insert(BatchBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.BatchMapper のメソッド
バッチ情報の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.BatchMapper のメソッド
バッチ情報の基本モデルを複数挿入します。
insert(CalendarInfoBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper のメソッド
カレンダーが保有するデータの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper のメソッド
カレンダーが保有するデータの基本モデルを複数挿入します。
insert(FavoriteMenuBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper のメソッド
アカウントが保有するメニューの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper のメソッド
アカウントが保有するメニューの基本モデルを複数挿入します。
insert(MenuArgumentBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper のメソッド
メニューの保有する引数の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper のメソッド
メニューの保有する引数の基本モデルを複数挿入します。
insert(MenuDepartmentBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper のメソッド
メニューの利用権限を保有する組織の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper のメソッド
メニューの利用権限を保有する組織の基本モデルを複数挿入します。
insert(MenuBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuMapper のメソッド
メニュー情報の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuMapper のメソッド
メニュー情報の基本モデルを複数挿入します。
insert(MenuPostBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper のメソッド
メニューの利用権限を保有する役職の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper のメソッド
メニューの利用権限を保有する役職の基本モデルを複数挿入します。
insert(MenuPublicGroupBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper のメソッド
メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper のメソッド
メニューの利用権限を保有するパブリックグループの基本モデルを複数挿入します。
insert(MenuRoleBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper のメソッド
メニューの利用権限を保有するロールの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper のメソッド
メニューの利用権限を保有するロールの基本モデルを複数挿入します。
insert(RoleInclusionBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper のメソッド
ロール内包の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper のメソッド
ロール内包の基本モデルを複数挿入します。
insert(RoleBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.RoleMapper のメソッド
ロールの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.RoleMapper のメソッド
ロールの基本モデルを複数挿入します。
insert(RoleSummaryBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper のメソッド
ロールサマリの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper のメソッド
ロールサマリの基本モデルを複数挿入します。
insertAccessController(String, AccessController) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラを作成します。
insertAccessController(String, AccessController) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラを作成します。
insertAccount(String, Account) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウント情報を新規追加する。
insertAccount(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント情報を新規追加する。
insertAccountRole(String, String, AccountRole) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウントロール情報を新規追加する。
insertAccountRole(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントロール情報を新規追加する。
insertBatch(String, Batch) - class jp.co.intra_mart.foundation.security.StandardBatchAccessor のメソッド
バッチを登録します。
insertBatch(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
バッチ情報を新規に追加します。
insertCalendarInfo(String, String, CalendarInfo) - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor のメソッド
カレンダーデータを新規に作成します。
insertCalendarInfo(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
カレンダーデータを新規に作成します。
insertControllerDepartment(String, String, DepartmentInfo) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラ組織を新規に作成します。
insertControllerDepartment(String, String, DepartmentInfo) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラ組織を新規に作成します。
insertControllerPost(String, String, PostInfo) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラ役職を新規に作成します。
insertControllerPost(String, String, PostInfo) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラ役職を新規に作成します。
insertControllerPublicGroup(String, String, PublicGroupInfo) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラパブリックグループを新規に作成します。
insertControllerPublicGroup(String, String, PublicGroupInfo) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラパブリックグループを新規に作成します。
insertControllerRole(String, String, String) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラロールを新規に作成します。
insertControllerRole(String, String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラロールを新規に作成します。
insertFavoriteMenu(String, String, FavoriteMenu) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
マイメニュー情報を新規追加する。
insertFavoriteMenu(String, String, FavoriteMenu) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
マイメニュー情報を新規追加する。
insertLoginGroup(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
ログイングループを新規追加します。
insertMainPagePattern(String, MainPagePatternInfo) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
メインページパターンを新規追加します。
insertMenuDepartment(String, String, DepartmentInfo) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
メニュー組織を新規に作成します。
insertMenuDepartment(String, String, DepartmentInfo) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニュー組織を新規に作成します。
insertMenuInclusion(String, MenuInclusion) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
メニュー構成を新規に作成します。
insertMenuInclusion(MenuInclusion) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
メニュー構成を新規に作成します。
insertMenuInclusion(String, MenuInclusion) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニュー構成を新規に作成します。
insertMenuItem(String, MenuItem, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
引数で渡されたノードを新規追加します。
insertMenuItem(MenuItem, String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
引数で渡されたノードを新規追加します。
insertMenuItem(String, MenuItem, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
引数で渡されたノードを新規追加します。
insertMenuPost(String, String, PostInfo) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
メニュー役職を新規に作成します。
insertMenuPost(String, String, PostInfo) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニュー役職を新規に作成します。
insertMenuPublicGroup(String, String, PublicGroupInfo) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
メニューパブリックグループを新規に作成します。
insertMenuPublicGroup(String, String, PublicGroupInfo) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニューパブリックグループを新規に作成します。
insertMenuRole(String, String, String) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
メニューロールを新規に作成します。
insertMenuRole(String, String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニューロールを新規に作成します。
insertSubRole(String, String, String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
サブロールを作成します。
insertSubRole(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
サブロールを作成する。
insertSuperUser(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor のメソッド
システム管理者情報を新規追加します。
insertSuperUser(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor のメソッド
グループ管理者情報を新規追加します。
instance() - class jp.co.intra_mart.foundation.service.provider.HomeDirectory の static メソッド
ホームディレクトリを表すオブジェクトを取得します。
instance() - class jp.co.intra_mart.foundation.service.provider.TemporaryDirectory の static メソッド
一時ファイル保存用ディレクトリを表すオブジェクトを取得します。
instance() - class jp.co.intra_mart.foundation.service.provider.file.StorageDirectory の static メソッド
ファイルコンテンツの保存ディレクトリを表すオブジェクトを取得します。
instance() - class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory の static メソッド
データ保存ディレクトリを表すオブジェクトを取得します。
instance() - class jp.co.intra_mart.foundation.utility.net.Localhost の static メソッド
推奨されていません。 このクラスから生成される唯一のインスタンスを返します。
intValue() - class jp.co.intra_mart.foundation.utility.Counter のメソッド
推奨されていません。 カウンターの現在の値を int 型として返します。
invalidate(String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
invalidate(String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
invalidate(String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
invalidateOtherSessions(ActiveSessionInfo) - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager のメソッド
引数で指定されたアクティブなセッション情報以外のセッション情報をすべて無効にします。
invoke(String, String) - interface jp.co.intra_mart.foundation.scenario.VariableScope のメソッド
指定関数を実行します。
invoke(String, Number) - interface jp.co.intra_mart.foundation.scenario.VariableScope のメソッド
指定関数を実行します。
invoke(String, Object[]) - interface jp.co.intra_mart.foundation.scenario.VariableScope のメソッド
指定関数を実行します。
isAccessControlEnabled(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
メニューアイテムのアクセス権の有無を取得します。
isAccessControlEnabled(String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニューアイテムのアクセス権の有無を取得します。
isActive() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
現在の時刻と比較して、セッションが有効か無効か取得する。
isActive(long) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
引数で指定された時刻と比較して、セッションが有効か無効か取得する。
isAlive() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
スケジューラが動作しているかどうかをチェックします。
isAlive() - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 このイベントコントローラが有効かどうかチェックします。
isAttemptOnFailedAuthentication() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
LDAP認証失敗(ユーザIDまたはパスワードが不正)時に次のプロバイダURLに認証の試みを取得する。
isAuth() - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のメソッド
認証フラグを取得します。
isChangePasswordFirstLogin(String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
初回ログイン時にパスワード変更要求を行うかの判定。
isChangePasswordFirstLogin() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
初回ログイン時のパスワード変更要求を行うかの判定。
isChangePasswordFirstLogin(String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
初回ログイン時にパスワード変更要求を行うかの判定。
isClosed() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 Connection がクローズされているかどうかを判定します。
isClosed() - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
このアクセサがクローズされた状態かどうかを確認します。
isClosed() - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
マッパーがクローズされているかどうか確認します。
isClosed() - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
マッパーがクローズされているかどうか確認します。
isClosed() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 この入出力ストリームが閉じられているかチェックします。
isClosed() - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 この入出力ストリームが閉じられているかチェックします。
isClosed() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 このソケットが閉じられているかどうかをチェックします。
isColumn(String, String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースの表内に指定カラムが存在するか調べる

isConnect() - class jp.co.intra_mart.foundation.database.DbManager のメソッド
推奨されていません。 代替えメソッドはありません。
isConnected() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
サーバとの接続状態をチェックします。
isDataSource() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 このコネクションがDataSourceかを返します。
isDateString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
日付文字列が日付フォーマット（YYYYMMDD）にそっているかチェックする。
isDateTimeString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
日時文字列がフォーマット（YYYY-MM-DD HH:MM:SS）にそっているかどうかをチェックする。
isDateTimeString(String, SimpleDateFormat) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
日時文字列が指定フォーマットにそっているかどうかをチェックする。
isDenyClientType(String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
クライアントタイプの判定

パラメータdeny-client-typesに記述があるクライアントタイプの判定を行う。
isDenyClientType(String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
クライアントタイプの判定

パラメータmobile-client-typesに記述があるクライアントタイプの判定を行う。
isDenyClientType(String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
クライアントタイプの判定

パラメータdeny-client-typesに記述があるクライアントタイプの判定を行う。
isDetectEnable(ActiveSessionInfo) - interface jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor のメソッド
検出処理が有効かどうか取得します。
isDetectEnable(String, String) - interface jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor のメソッド
検出処理が有効かどうか取得します。
isDetectEnable(ActiveSessionInfo) - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager のメソッド
検出処理が有効かどうか取得します。
isDetectEnable(String, String) - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager のメソッド
検出処理が有効かどうか取得します。
isDetectEnable(ActiveSessionInfo) - class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor のメソッド
検出処理が有効かどうか取得します。
isDetectEnable(String, String) - class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor のメソッド
重複ログイン検出処理が有効かどうか取得します。
isDirectory() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルがディレクトリであるかどうかを判定します。
isDoneCertification() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
認証が終了しているかどうかを取得する。
isDouble() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
ｙ軸の目盛値がdouble表現かどうかを判定します。
isDouble() - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
グラフ値がdouble表現かどうかを判定します。
isDouble() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
ｙ軸の目盛値がdouble表現かどうかを判定します。
isDouble() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｘ軸、ｙ軸の目盛値がdouble表現かどうかを判定します。
isDouble() - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
グラフ値がdouble表現かどうかを判定します。
isDouble() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
ｙ軸の目盛値がdouble表現かどうかを判定します。
isDuplicateLogined(ActiveSessionInfo) - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager のメソッド
引数で指定されたユーザが重複してログインしているかどうか判別します。
isDuplicateLogined(String, String, String, String) - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager のメソッド
引数で指定されたユーザが重複してログインしているかどうか判別します。
isDuplicateSrc() - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
イメージアイコンのURLの重複チェックの有効/無効を取得します。
isEMailAddress(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
入力文字列がメールアドレスの形式をとっているかのチェック。
isEmpty(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
渡された文字列が、空文字列かまたはNULLかチェック。
isEmpty(Number) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
数値のNULLチェック。
isEmpty() - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リストに要素がないかどうかを判定します。
isEmpty() - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
このノードの下に子ノードがないか調べます。
isEmpty() - interface jp.co.intra_mart.foundation.page.TreeNodeContainer のメソッド
このノードが一つも子を持っていないときにtrueを返します。
isEnableSMTPAuth() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
SMTP認証の有効/無効を取得します。
isEndCategory(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のメソッド
指定されたカテゴリコードに対する商品カテゴリが末端のカテゴリか調べます。
isError() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
処理要求が成功したかどうかを判定します。
isError() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
処理要求が成功したかどうかを判定します。
isExclusive() - class jp.co.intra_mart.foundation.datastore.exporter.Filter のメソッド
フィルタリング対象の値が除外されるかどうか
isExistString(String[], String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
配列内に指定した文字列が含まれているかどうかをチェックする。
isExpired() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
試用期限が切れているかどうかを判定します。
isFile() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルが普通のファイルかどうかを判定します。
isFirstLogin(String, String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
初回ログインの判定

isFirstLogin(String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
初回ログインの判定

初回ログインかどうかを判定します。
isFirstLogin(String, String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
初回ログインの判定

isForwardInitialPage(String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
パスワード変更後の画面遷移。
isForwardInitialPage() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
パスワード変更後の画面遷移。
isForwardInitialPage(String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
パスワード変更後の画面遷移。
isFree() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
ライセンスフリーであるかどうかを判定します。
isFunction() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値が関数かどうか判定します。
isGoOut() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
外出状態を取得します。
isGroup(String) - class jp.co.intra_mart.foundation.acssecurity.Logingp の static メソッド
推奨されていません。 代替えメソッドはありません。
isHoliday(String, CategorizedCalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
休日かどうか判定します。
isHoliday() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
休日設定にマッチしているかどうかを取得します。
isInput(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの空値チェック。
isInput(Number) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの空値チェック。
isInstance(Class) - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値が c が表すオブジェクトと代入互換の 関係にあるかどうか判定します。
isInternational() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性が国際化の対象であるかどうかを取得します。
isInternational() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティが国際化の対象であるかどうかを取得します。
isInvalidatableByUser(ActiveSessionInfo) - interface jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor のメソッド
ユーザ自身のセッションの無効化が可能か取得します。
isInvalidatableByUser(String, String) - interface jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor のメソッド
ユーザ自身のセッションの無効化が可能か取得します。
isInvalidatableByUser(ActiveSessionInfo) - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager のメソッド
ユーザ自身のセッションの無効化が可能か取得します。
isInvalidatableByUser(String, String) - class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager のメソッド
ユーザ自身のセッションの無効化が可能か取得します。
isInvalidatableByUser(ActiveSessionInfo) - class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor のメソッド
ユーザ自身のセッションの無効化が可能か取得します。
isInvalidatableByUser(String, String) - class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor のメソッド
ユーザ自身のセッションの無効化が可能か取得します。
isKatakanaString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
文字列が半角カナ文字列かチェックする。
isKessaiDateString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
決済年月日(YYYYMMDD)として有効かをチェックする。
isLenEqual(String, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの入力バイト数チェック。
isLenEqual(String, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの入力バイト数チェック（引数がクラス版）。
isLenEqual(Number, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの入力桁数チェック。
isLenEqual(Number, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの入力桁数チェック（引数がクラス版）。
isLenLessThan(String, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムのバイト数が指定バイト数より小さいか(等号を含む)。
isLenLessThan(String, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムのバイト数が指定バイト数より小さいか(等号を含む)（引数がクラス版）。
isLenLessThan(Number, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの桁数が指定桁数より小さいか(等号を含む)。
isLenLessThan(Number, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの桁数が指定桁数より小さいか(等号を含む)（引数がクラス版）。
isLenMoreThan(String, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムのバイト数が指定バイト数より大きいか(等号を含まない)。
isLenMoreThan(String, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムのバイト数が指定バイト数より大きいか(等号を含まない)（引数がクラス版）。
isLenMoreThan(Number, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの桁数が指定桁数より大きいか(等号を含まない)。
isLenMoreThan(Number, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの桁数が指定桁数より大きいか(等号を含まない)（引数がクラス版）。
isLimited() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
期限付きライセンスであるかどうかを判定します。
isLoadBalancing() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
ロードバランサの有効・無効を設定を取得する。
isLock() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
アカウントロック状態を取得します。
isLocked() - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
ロックの状態を確認します。
isLogined(String, String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたユーザがログインしているかどうか判別します。
isNationalHoliday(CategorizedCalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
祝日かどうか判定します。
isNationalHoliday() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
祝祭日設定にマッチしているかどうかを取得します。。
isNengetsuString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
年月指定文字列が年月フォーマット（YYYYMM）にそっているかチェックする。
isNotNull(Object) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
not nullチェック not nullのとき true nullのとき false
isNull() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値が null かどうか判定します。
isNullAcceptable() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性にnullが設定可能であるかどうかを取得します。
isNumber() - class jp.co.intra_mart.foundation.database.DatabaseColumn のメソッド

isNumberString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
文字列が数値かどうかをチェックする。
isNumeralRange(String, Number, Number) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
指定した数値カラムが指定した数値の範囲なのかチェック
範囲最大値、または最小値と同じ値は範囲内に含まれる。
isObject() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値がオブジェクトかどうか判定します。
isObservable() - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
アクティブセッションの監視を行うかどうか取得します。
isObservable(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
アクティブセッションの監視を行うかどうか取得します。
isObservable() - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
アクティブセッションの監視を行うかどうか取得します。
isPasswordExpired(String, String, String, Date) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
パスワード変更要求の判定。
isPasswordExpired(String, String, Date) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
パスワード有効期限切れかどうかの判定。
isPasswordExpired(String, String, String, Date) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
パスワードが有効期限切れかどうかの判定。
isPasswordHistoryManaged(String) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
履歴管理の有無。
isPasswordHistoryManaged() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
履歴管理の有無。
isPasswordHistoryManaged(String) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
履歴管理の有無。
isPermissionCheck() - class jp.co.intra_mart.foundation.navigator.EventFlowInfo のメソッド
パーミッションチェックフラグ取得
isPermissionCheck() - class jp.co.intra_mart.foundation.navigator.ResultPageItemInfo のメソッド
パーミッションチェックフラグ取得
isPermissionCheck() - class jp.co.intra_mart.foundation.navigator.SelectItemInfo のメソッド
パーミッションチェックフラグ取得
isPopup() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
リンクへ参照時にポップアップを呼び出すかどうかを取得します。
isPrimaryKey() - class jp.co.intra_mart.foundation.database.DatabaseColumn のメソッド

isProcessing() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
クライアントのアクセスに対して処理中がどうか取得する。
isReadOnly() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 Connection が読み込み専用モードかどうかを判定します。
isRegisteredAccountLicense(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
指定されたユーザがライセンスに登録されているかどうかをチェックします。
isRegisteredApplicationLicenseToAccount(String, String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
アカウントにアプリケーションライセンスが登録されてるか検証します。
isRequiredCheck() - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド
権限チェック要否
isRetry() - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader のメソッド
インポート異常終了後の再実行時に、リトライ処理として実行するかどうか。
isShimebiString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
締め日(YYYYMMDD)として有効かをチェックする。
isSuccess() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryResult のメソッド
パスワードチェックの成否を取得します。
isTerminable() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性が期間化の対象であるかどうかを取得します。
isTerminable() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティが期間化の対象であるかどうかを取得します。
isTerminableInternational() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティが期間国際化の対象であるかどうかを取得します。
isTitleBar() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
タイトルバーを表示するかどうかのステータスを取得します。
isTransaction() - interface jp.co.intra_mart.foundation.database.DatabaseAccessor のメソッド
データベースアクセスのトランザクション状態を取得します。
isTransaction() - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
データベースアクセスのトランザクション状態を取得します。
isTrial() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
試用版であるかどうかを判定します。
isUndefined() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値が undefined かどうか判定します。
isUpDate(String, Date) - class jp.co.intra_mart.foundation.update.UpdateManager のメソッド
更新管理キーの更新日付が検証日付より新しいか検証します。
isUpdate(Date) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
アクセスコントローラが指定された日付よりも新しいかチェックします。
isUpdate(Date) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウント情報が指定された日付よりも新しいかチェックします。
isUpdate(Date) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチ情報が指定された日付よりも新しいかチェックします。
isUpdate(String, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータが指定された日付よりも新しいかチェックします。
isUpdate(Date) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニュー情報が指定された日付よりも新しいかチェックします。
isUpdate(Date) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール情報が指定された日付よりも新しいかチェックします。
isValid(String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
isValid() - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
アクティブなセッション情報が有効かどうか取得します。
isValid(String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
isValid(String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
isValidDate(String, String, String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。
isValidate() - interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader のメソッド
インポートデータに対してバリデーションを行うかどうか。
isValidate() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
有効・無効フラグを取得します。
isValueEqual(String, String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラム１の値とカラム２の値が同一かのチェック。
isValueEqual(Number, Number) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラム１の値とカラム２の値が同一かのチェック。
isValueLessThan(String, String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラム１の値がカラム２の値より小さいか(等号を含まず)のチェック。
isValueLessThan(Number, Number) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラム１の値がカラム２の値より小さいか(等号を含まず)のチェック。
isValueMoreThan(String, String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラム１の値がカラム２の値より大きいか(等号を含まず)のチェック。
isValueMoreThan(Number, Number) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラム１の値がカラム２の値より大きいか(等号を含まず)のチェック。
isWeekDate(String, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。
isWeekDate(String, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。
isWeekday(String, CategorizedCalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
平日かどうか判定します。
isWeekday() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
非休日設定にマッチしているかどうかを取得します。
iterator() - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 このリスト内の要素を適切な順序で繰り返し処理する反復子を返します。

J

J2eeFwPortlet - class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet.
ページ種別「J2EEフレームワーク」に対するポートレットのモデルです。
J2eeFwPortlet() - class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet のコンストラクタ

JavaMailPropertyException - exception jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException.
JavaMailSenderの設定に関する情報を提供する例外です。
JavaMailPropertyException() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException のコンストラクタ
JavaMailPropertyExceptionを構築します。
JavaMailPropertyException(String) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException のコンストラクタ
指定された詳細メッセージを使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyException(String, Throwable) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException のコンストラクタ
指定された詳細メッセージおよび原因を使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyException(Throwable) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException のコンストラクタ
指定された原因を使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyHandler - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler.
JavaMailSenderの設定を保持します。
JavaMailPropertyHandlerInitializerImpl - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl.
JavaMailPropertyHandlerの初期化クラス。
JavaMailPropertyHandlerInitializerImpl() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl のコンストラクタ

JavaMailSender - class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender.
JavaMailをラップしたメール送信オブジェクトです。
JavaMailSender(StandardMail) - class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender のコンストラクタ
JavaMailSenderを新規に作成します。
JspPortlet - class jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet.
ページ種別「Servlet/JSP」に対するポートレットのモデルです。
JspPortlet() - class jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet のコンストラクタ

joinDepartment(String, String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織構成に組織を登録します。
joinPublicGroup(String, String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループ構成にパブリックグループを登録します。
jp.co.intra_mart.foundation.acssecurity - package jp.co.intra_mart.foundation.acssecurity
アクセスセキュリティモジュールを利用するためのクラスを提供します。
jp.co.intra_mart.foundation.commons - package jp.co.intra_mart.foundation.commons

jp.co.intra_mart.foundation.commons.validation - package jp.co.intra_mart.foundation.commons.validation
このパッケージは、入力チェック関数ライブラリを提供します。
jp.co.intra_mart.foundation.database - package jp.co.intra_mart.foundation.database
データベースへアクセスするためのクラスを提供します。
jp.co.intra_mart.foundation.database.exception - package jp.co.intra_mart.foundation.database.exception
データベースＳＱＬ例外クラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category - package jp.co.intra_mart.foundation.datastore.application.domain.category
分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class - package jp.co.intra_mart.foundation.datastore.application.domain.category.category_class
分類区分情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category.detail - package jp.co.intra_mart.foundation.datastore.application.domain.category.detail
分類詳細情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company - package jp.co.intra_mart.foundation.datastore.application.domain.company
会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.attach - package jp.co.intra_mart.foundation.datastore.application.domain.company.attach
組織所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.category - package jp.co.intra_mart.foundation.datastore.application.domain.company.category
会社分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.company - package jp.co.intra_mart.foundation.datastore.application.domain.company.company
会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.department - package jp.co.intra_mart.foundation.datastore.application.domain.company.department
組織情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.main - package jp.co.intra_mart.foundation.datastore.application.domain.company.main
主所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.post - package jp.co.intra_mart.foundation.datastore.application.domain.company.post
役職情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.version - package jp.co.intra_mart.foundation.datastore.application.domain.company.version
バーション情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.currency - package jp.co.intra_mart.foundation.datastore.application.domain.currency
通貨情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal - package jp.co.intra_mart.foundation.datastore.application.domain.deal
取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.deal - package jp.co.intra_mart.foundation.datastore.application.domain.deal.deal
取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.department - package jp.co.intra_mart.foundation.datastore.application.domain.deal.department
取扱組織権限情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.detail - package jp.co.intra_mart.foundation.datastore.application.domain.deal.detail
取扱詳細情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group - package jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group
取扱パブリックグループ権限情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.role - package jp.co.intra_mart.foundation.datastore.application.domain.deal.role
取扱ロール権限情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item - package jp.co.intra_mart.foundation.datastore.application.domain.item
商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item.attribute - package jp.co.intra_mart.foundation.datastore.application.domain.item.attribute
商品属性情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue - package jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue
商品カタログ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item.item - package jp.co.intra_mart.foundation.datastore.application.domain.item.item
商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category - package jp.co.intra_mart.foundation.datastore.application.domain.item_category
商品カテゴリ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach - package jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach
商品分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category.category - package jp.co.intra_mart.foundation.datastore.application.domain.item_category.category
商品カテゴリ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category.type - package jp.co.intra_mart.foundation.datastore.application.domain.item_category.type
商品カテゴリ種別情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_template - package jp.co.intra_mart.foundation.datastore.application.domain.item_template
商品テンプレート属性情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail - package jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail
商品テンプレート属性詳細情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_template.template - package jp.co.intra_mart.foundation.datastore.application.domain.item_template.template
商品テンプレート属性情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group - package jp.co.intra_mart.foundation.datastore.application.domain.private_group
プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach - package jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach
プライベートグループ所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group.group - package jp.co.intra_mart.foundation.datastore.application.domain.private_group.group
プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group - package jp.co.intra_mart.foundation.datastore.application.domain.public_group
パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach - package jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach
パブリックグループ所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category - package jp.co.intra_mart.foundation.datastore.application.domain.public_group.category
パブリックグループ分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group - package jp.co.intra_mart.foundation.datastore.application.domain.public_group.group
パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set - package jp.co.intra_mart.foundation.datastore.application.domain.public_group.set
パブリックグループセット情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.version - package jp.co.intra_mart.foundation.datastore.application.domain.public_group.version
パブリックグループバージョン情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.unit - package jp.co.intra_mart.foundation.datastore.application.domain.unit
商品単位情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user - package jp.co.intra_mart.foundation.datastore.application.domain.user
ユーザ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.category_class - package jp.co.intra_mart.foundation.datastore.application.model.category.category_class
分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail - package jp.co.intra_mart.foundation.datastore.application.model.category.detail
分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach - package jp.co.intra_mart.foundation.datastore.application.model.company.attach
組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category - package jp.co.intra_mart.foundation.datastore.application.model.company.category
会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company - package jp.co.intra_mart.foundation.datastore.application.model.company.company
会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department - package jp.co.intra_mart.foundation.datastore.application.model.company.department
組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion - package jp.co.intra_mart.foundation.datastore.application.model.company.inclusion
組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main - package jp.co.intra_mart.foundation.datastore.application.model.company.main
組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post - package jp.co.intra_mart.foundation.datastore.application.model.company.post
会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version - package jp.co.intra_mart.foundation.datastore.application.model.company.version
会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.deal - package jp.co.intra_mart.foundation.datastore.application.model.deal.deal
取扱情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.department - package jp.co.intra_mart.foundation.datastore.application.model.deal.department
取扱組織権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.detail - package jp.co.intra_mart.foundation.datastore.application.model.deal.detail
取扱詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group - package jp.co.intra_mart.foundation.datastore.application.model.deal.public_group
取扱パブリックグループ権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.role - package jp.co.intra_mart.foundation.datastore.application.model.deal.role
取扱ロール権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.attribute - package jp.co.intra_mart.foundation.datastore.application.model.item.attribute
商品属性情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue - package jp.co.intra_mart.foundation.datastore.application.model.item.catalogue
商品カタログ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.item - package jp.co.intra_mart.foundation.datastore.application.model.item.item
商品情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach - package jp.co.intra_mart.foundation.datastore.application.model.item_category.attach
商品分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.category - package jp.co.intra_mart.foundation.datastore.application.model.item_category.category
商品カテゴリ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.type - package jp.co.intra_mart.foundation.datastore.application.model.item_category.type
商品カテゴリ種別情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail - package jp.co.intra_mart.foundation.datastore.application.model.item_template.detail
商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.template - package jp.co.intra_mart.foundation.datastore.application.model.item_template.template
商品テンプレート情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach - package jp.co.intra_mart.foundation.datastore.application.model.private_group.attach
プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group - package jp.co.intra_mart.foundation.datastore.application.model.private_group.group
プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach - package jp.co.intra_mart.foundation.datastore.application.model.public_group.attach
パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category - package jp.co.intra_mart.foundation.datastore.application.model.public_group.category
パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group - package jp.co.intra_mart.foundation.datastore.application.model.public_group.group
パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion - package jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion
パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set - package jp.co.intra_mart.foundation.datastore.application.model.public_group.set
パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version - package jp.co.intra_mart.foundation.datastore.application.model.public_group.version
パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.unit - package jp.co.intra_mart.foundation.datastore.application.model.unit
単位情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user - package jp.co.intra_mart.foundation.datastore.application.model.user
ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.accessor - package jp.co.intra_mart.foundation.datastore.common.accessor
情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.config - package jp.co.intra_mart.foundation.datastore.common.config
アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。
jp.co.intra_mart.foundation.datastore.common.model - package jp.co.intra_mart.foundation.datastore.common.model
情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.foundation.datastore.common.structure - package jp.co.intra_mart.foundation.datastore.common.structure
期間情報などを扱うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exception - package jp.co.intra_mart.foundation.datastore.exception
アプリケーション共通マスタで発生する例外クラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter - package jp.co.intra_mart.foundation.datastore.exporter
アプリケーション共通マスタのエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.common.config - package jp.co.intra_mart.foundation.datastore.exporter.common.config
エクスポート設定の解釈を行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.company - package jp.co.intra_mart.foundation.datastore.exporter.company
会社・組織関連の情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.public_group - package jp.co.intra_mart.foundation.datastore.exporter.public_group
パブリックグループ情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.user - package jp.co.intra_mart.foundation.datastore.exporter.user
ユーザ関連の情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer - package jp.co.intra_mart.foundation.datastore.importer
アプリケーション共通マスタのインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.common.config - package jp.co.intra_mart.foundation.datastore.importer.common.config
インポート定義情報の解釈を行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.company - package jp.co.intra_mart.foundation.datastore.importer.company
会社・組織関連の情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.public_group - package jp.co.intra_mart.foundation.datastore.importer.public_group
パブリックグループ情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.user - package jp.co.intra_mart.foundation.datastore.importer.user
ユーザ関連の情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.drawer - package jp.co.intra_mart.foundation.drawer
画像ファイル出力用クラスを提供します。
jp.co.intra_mart.foundation.exception - package jp.co.intra_mart.foundation.exception
システムでスローされる例外クラスを提供します。
jp.co.intra_mart.foundation.graph - package jp.co.intra_mart.foundation.graph
グラフ描画に関するクラスを提供します。
jp.co.intra_mart.foundation.http - package jp.co.intra_mart.foundation.http
ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.http.ajax - package jp.co.intra_mart.foundation.http.ajax

jp.co.intra_mart.foundation.image - package jp.co.intra_mart.foundation.image

jp.co.intra_mart.foundation.log - package jp.co.intra_mart.foundation.log

jp.co.intra_mart.foundation.mail - package jp.co.intra_mart.foundation.mail
メール送信に関するクラスを提供します。
jp.co.intra_mart.foundation.mail.javamail - package jp.co.intra_mart.foundation.mail.javamail
メール送信クラスを提供します。
jp.co.intra_mart.foundation.mail.javamail.listener - package jp.co.intra_mart.foundation.mail.javamail.listener

jp.co.intra_mart.foundation.mail.javamail.listener.impl - package jp.co.intra_mart.foundation.mail.javamail.listener.impl

jp.co.intra_mart.foundation.mail.javamail.model - package jp.co.intra_mart.foundation.mail.javamail.model

jp.co.intra_mart.foundation.mail.javamail.property - package jp.co.intra_mart.foundation.mail.javamail.property

jp.co.intra_mart.foundation.navigator - package jp.co.intra_mart.foundation.navigator

jp.co.intra_mart.foundation.page - package jp.co.intra_mart.foundation.page
ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.portal.common.encode - package jp.co.intra_mart.foundation.portal.common.encode

jp.co.intra_mart.foundation.portal.common.rss - package jp.co.intra_mart.foundation.portal.common.rss

jp.co.intra_mart.foundation.portal.general_purpose_portlet - package jp.co.intra_mart.foundation.portal.general_purpose_portlet

jp.co.intra_mart.foundation.portal.general_purpose_portlet.model - package jp.co.intra_mart.foundation.portal.general_purpose_portlet.model

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider - package jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider

jp.co.intra_mart.foundation.portal.portlet - package jp.co.intra_mart.foundation.portal.portlet

jp.co.intra_mart.foundation.portal.portlet.model - package jp.co.intra_mart.foundation.portal.portlet.model

jp.co.intra_mart.foundation.scenario - package jp.co.intra_mart.foundation.scenario
スクリプト開発モデルのプログラムと連携するＡＰＩ。
jp.co.intra_mart.foundation.security - package jp.co.intra_mart.foundation.security
アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access - package jp.co.intra_mart.foundation.security.access

jp.co.intra_mart.foundation.security.account - package jp.co.intra_mart.foundation.security.account
アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession - package jp.co.intra_mart.foundation.security.activesession

jp.co.intra_mart.foundation.security.admin - package jp.co.intra_mart.foundation.security.admin
システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch - package jp.co.intra_mart.foundation.security.batch
バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar - package jp.co.intra_mart.foundation.security.calendar
カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification - package jp.co.intra_mart.foundation.security.certification
認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification.ldap.extension - package jp.co.intra_mart.foundation.security.certification.ldap.extension
ユーザログインLDAP認証クラス(複数OU対応版)の設定方法。
jp.co.intra_mart.foundation.security.cryption - package jp.co.intra_mart.foundation.security.cryption
暗号化に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.duplication - package jp.co.intra_mart.foundation.security.duplication

jp.co.intra_mart.foundation.security.exception - package jp.co.intra_mart.foundation.security.exception
アクセスセキュリティ例外に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.filter - package jp.co.intra_mart.foundation.security.filter
アクセスセキュリティのフィルタに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group - package jp.co.intra_mart.foundation.security.group
グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.license - package jp.co.intra_mart.foundation.security.license
ライセンスに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu - package jp.co.intra_mart.foundation.security.menu
メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.message - package jp.co.intra_mart.foundation.security.message
メッセージに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.mobile - package jp.co.intra_mart.foundation.security.mobile

jp.co.intra_mart.foundation.security.password - package jp.co.intra_mart.foundation.security.password

jp.co.intra_mart.foundation.security.permission - package jp.co.intra_mart.foundation.security.permission
権限に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role - package jp.co.intra_mart.foundation.security.role
ロールに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.servlet - package jp.co.intra_mart.foundation.security.servlet
サーブレットに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.shortcut - package jp.co.intra_mart.foundation.security.shortcut

jp.co.intra_mart.foundation.service.client - package jp.co.intra_mart.foundation.service.client
このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.client.application - package jp.co.intra_mart.foundation.service.client.application
このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content - package jp.co.intra_mart.foundation.service.client.application.content
このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.batch - package jp.co.intra_mart.foundation.service.client.batch
Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file - package jp.co.intra_mart.foundation.service.client.file
Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information - package jp.co.intra_mart.foundation.service.client.information
このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.manager - package jp.co.intra_mart.foundation.service.client.manager
このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.provider - package jp.co.intra_mart.foundation.service.provider
このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.service.provider.application - package jp.co.intra_mart.foundation.service.provider.application
このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。
jp.co.intra_mart.foundation.service.provider.batch - package jp.co.intra_mart.foundation.service.provider.batch
このパッケージには、スケジュール実行されるバッチプログラム機能を利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.provider.file - package jp.co.intra_mart.foundation.service.provider.file
このパッケージには、Storage Service 環境内で利用可能な機能を提供します。
jp.co.intra_mart.foundation.service.provider.information - package jp.co.intra_mart.foundation.service.provider.information
このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。
jp.co.intra_mart.foundation.smtp - package jp.co.intra_mart.foundation.smtp
メール連携モジュール。
jp.co.intra_mart.foundation.update - package jp.co.intra_mart.foundation.update

jp.co.intra_mart.foundation.utility - package jp.co.intra_mart.foundation.utility
このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.charset - package jp.co.intra_mart.foundation.utility.charset
このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.file - package jp.co.intra_mart.foundation.utility.file
このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.io - package jp.co.intra_mart.foundation.utility.io
このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.net - package jp.co.intra_mart.foundation.utility.net
ソケットによるネットワーク対応機能を実装するためのクラスを提供します。
jp.co.intra_mart.foundation.utility.report - package jp.co.intra_mart.foundation.utility.report
このパッケージには、ログ機能を実装するための汎用クラスが含まれています。
jp.co.intra_mart.jssp.net - package jp.co.intra_mart.jssp.net

jp.co.intra_mart.system.security.datastore.inf - package jp.co.intra_mart.system.security.datastore.inf

K

KEY_AUTH_COOKIE_NAME - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の static 変数

KEY_LOGIN_KEY - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の static 変数

KIND_NAVIGATOR - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
種別 イベントナビゲーター
KIND_NAVIGATOR - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor の static 変数
種別 ロール。
KIND_ROLE - class jp.co.intra_mart.foundation.security.StandardRoleAccessor の static 変数
種別 ロール。
KIND_ROLE - class jp.co.intra_mart.foundation.security.exception.AccessSecurityException の static 変数
種別 ロール。
KIND_ROLE - class jp.co.intra_mart.foundation.security.role.StandardRoleBackup の static 変数
種別 ロール。
KIND_ROLE_SUB - class jp.co.intra_mart.foundation.security.StandardRoleAccessor の static 変数
種別 サブロール(ロール)。
KIND_ROLE_SUB - class jp.co.intra_mart.foundation.security.exception.AccessSecurityException の static 変数
種別 サブロール(ロール)。
keyList() - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
キー一覧を取得します。
keyList() - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
キー一覧を取得します。
keyList() - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
キー一覧を取得します。
keyList() - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
キー一覧を取得します。
keys() - interface jp.co.intra_mart.foundation.scenario.VariableScope のメソッド
プロパティの名称一覧を取得します。

L

LANG_JAVA - class jp.co.intra_mart.foundation.security.batch.Batch の static 変数
プログラム言語(JAVA)。
LANG_JAVA_SCRIPT - class jp.co.intra_mart.foundation.security.batch.Batch の static 変数
プログラム言語(JavaScript)。
LDAPContextInfoBuilder - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoBuilder.
ログイングループ毎の設定情報モデルを作成するビルドクラス。
LDAPContextInfoBuilder() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoBuilder のコンストラクタ

LDAPContextInfoModel - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel.
ユーザログインLDAP認証で認証情報モデルクラス(複数OU対応版)。
LDAPContextInfoModel() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のコンストラクタ

LDAPUserCertification - class jp.co.intra_mart.foundation.security.certification.LDAPUserCertification.
ユーザログインLDAP認証クラス。
LDAPUserCertification() - class jp.co.intra_mart.foundation.security.certification.LDAPUserCertification のコンストラクタ

LDAPUserCertification - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPUserCertification.
ユーザログインLDAP認証クラス(複数OU対応版)。
LDAPUserCertification() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPUserCertification のコンストラクタ

LOCALE - class jp.co.intra_mart.foundation.datastore.common.config.AttributeType の static 変数
ロケール
LOCALE - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
ロケール
LOCK_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
アカウントロック日付
LOGIN_FAILURE_COUNT - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
ログイン失敗回数
LT_GROUP - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
グループマネージャー（ログインタイプ）。
LT_SUPER - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
スーパーユーザ（ログインタイプ）。
LT_USER - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ユーザ（ログインタイプ）。
LicenseManager - class jp.co.intra_mart.foundation.security.license.LicenseManager.
ライセンス・マネージャクラス。
LicenseManager(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のコンストラクタ
コンストラクタ。
Lifetime - interface jp.co.intra_mart.foundation.datastore.common.config.Lifetime.
期間削除時の整合性制約です。
LifetimeType - class jp.co.intra_mart.foundation.datastore.common.config.LifetimeType.
期間削除時の整合性制約のタイプです。
LimitedSessionHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler.
セッションを一時利用のみに限定するためのフィルタです。
LimitedSessionHTTPActionEventFilterHandler(HTTPActionEventHandler) - class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler のコンストラクタ
セッションを一時利用に限定するためのフィルタハンドラを作成します。
LineGraphDrawer - class jp.co.intra_mart.foundation.graph.LineGraphDrawer.
折れ線グラフを描画します。
LineGraphDrawer(int, int, int) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のコンストラクタ
ｙ軸の目盛値をint表現で折れ線グラフを作成します。
LineGraphDrawer(double, double, double) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のコンストラクタ
ｙ軸の目盛値をdouble表現で折れ線グラフを作成します。
LineGraphObject - class jp.co.intra_mart.foundation.graph.LineGraphObject.
LineGraphDrawerクラスのデータを保存するオブジェクトです。
LineGraphObject() - class jp.co.intra_mart.foundation.graph.LineGraphObject のコンストラクタ
デフォルトのデータオブジェクトを作成します。
LineGraphObject(Color) - class jp.co.intra_mart.foundation.graph.LineGraphObject のコンストラクタ
線の色を指定して、データオブジェクトを作成します。
LineGraphObject(Stroke) - class jp.co.intra_mart.foundation.graph.LineGraphObject のコンストラクタ
線の描画属性を指定して、データオブジェクトを作成します。
LineGraphObject(Color, Stroke) - class jp.co.intra_mart.foundation.graph.LineGraphObject のコンストラクタ
線の色と描画属性を指定して、データオブジェクトを作成します。
LineReportFilter - class jp.co.intra_mart.foundation.utility.report.LineReportFilter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter クラスを使用してください。
LineReportFilter(MessageReporter) - class jp.co.intra_mart.foundation.utility.report.LineReportFilter のコンストラクタ
推奨されていません。 指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。
LinkPageInfo - class jp.co.intra_mart.foundation.navigator.LinkPageInfo.
リンク情報
LinkPageInfo() - class jp.co.intra_mart.foundation.navigator.LinkPageInfo のコンストラクタ

LocaleInfo - interface jp.co.intra_mart.foundation.security.LocaleInfo.
ロケｰル情報・モデルインタフェース。
LocaleProvider - interface jp.co.intra_mart.foundation.security.LocaleProvider.
ロケール取得プロバイダーインタフェース。
Localhost - class jp.co.intra_mart.foundation.utility.net.Localhost.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.Localhost クラスを使用してください。
Lock - class jp.co.intra_mart.foundation.service.client.information.Lock.
アプリケーションロックをするための機能を提供します。
Lock(String) - class jp.co.intra_mart.foundation.service.client.information.Lock のコンストラクタ
ロックをするためのインスタンスを作ります。
LockMonitor - class jp.co.intra_mart.foundation.utility.LockMonitor.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.LockMonitor クラスを使用してください。
LockMonitor(int) - class jp.co.intra_mart.foundation.utility.LockMonitor のコンストラクタ
推奨されていません。 モニターを構築します。
LogConstraint - interface jp.co.intra_mart.foundation.log.LogConstraint.
ログ定数インタフェース。
LoginGroup - class jp.co.intra_mart.foundation.security.group.LoginGroup.
ログイングループ・モデル。
LoginGroup() - class jp.co.intra_mart.foundation.security.group.LoginGroup のコンストラクタ
コンストラクタ。
LoginGroup(String) - class jp.co.intra_mart.foundation.security.group.LoginGroup のコンストラクタ
コンストラクタ。
LoginGroupAccessor - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor.
ログイングループアクセッサインタフェース。
LoginGroupManager - class jp.co.intra_mart.foundation.security.group.LoginGroupManager.
ログイングループマネージャクラス。
LoginGroupPostWriterListener - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener.
ログイングループ情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
LoginGroupQueryWriterListener - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener.
ログイングループ情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
LoginGroupReaderDecorator - interface jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator.
ログイングループ情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
LoginInfo - interface jp.co.intra_mart.foundation.security.certification.LoginInfo.
intra-martログイン情報操作インタフェース。
LoginRequestInfo - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo.
intra-martログイン情報操作インタフェース。
Logingp - class jp.co.intra_mart.foundation.acssecurity.Logingp.
推奨されていません。
Logingp(String) - class jp.co.intra_mart.foundation.acssecurity.Logingp のコンストラクタ
推奨されていません。 LoginGroupManagerに置き換えられました。
LogoutInitialUrlValidator - interface jp.co.intra_mart.foundation.security.servlet.LogoutInitialUrlValidator.
ログアウト後に遷移するURL検証インタフェース ログアウト後に遷移するURLを検証するためのインタフェースです。
LogoutServlet - class jp.co.intra_mart.foundation.security.servlet.LogoutServlet.
ログアウトサーブレット。
LogoutServlet() - class jp.co.intra_mart.foundation.security.servlet.LogoutServlet のコンストラクタ

lastError() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 このインスタンスのメソッド中で最後に発生した例外を返します。
lastIndexOf(Object) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 指定されたオブジェクトがリスト内で最後に現れるインデックスを返します。
lastModified() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルが最後に変更された時刻を返します。
leaveDepartment(String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織構成から組織情報を離脱させます。
leavePublicGroup(String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループ構成からパブリックグループ情報を離脱させます。
length() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルの長さを返します。
length() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 このライターの出力文字数を取得します。
listIterator() - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 このリスト内の要素を適切な順序で繰り返し処理する反復子を返します。
listIterator(int) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リスト内の要素を適切な順序で繰り返し処理する、リスト内の指定された位置から開始する反復子を返します。
lists() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ディレクトリ中のファイルの一覧を取得します。
load() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ファイルの内容を取得します。
login(LoginRequestInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ログイン処理を行います。
login(LoginRequestInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ログイン処理を行います。
logout() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ログアウト処理を行います。
logout(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ログアウト処理を行います。
longValue() - class jp.co.intra_mart.foundation.utility.Counter のメソッド
推奨されていません。 カウンターの現在の値を long 型として返します。

M

MAPPING_FILE_PATH - class jp.co.intra_mart.foundation.portal.portlet.PortletMapping の static 変数
ポートレットマッピングの設定ファイルのパス情報
MAX_VALUE - interface jp.co.intra_mart.foundation.utility.report.ReportLevel の static 変数
推奨されていません。 レベル値として使用可能な最大値 この値は、java.lang.Integer.MAX_VALUE と同じです。
MEDIA - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel の static 変数
媒体
MEDIA_CLS - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel の static 変数
媒体種類
MEDIA_CLS_FILE - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel の static 変数
媒体種類がFileを表す定数
MEDIA_CLS_URL - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel の static 変数
媒体種類がURLを表す定数
MENU - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
メニュー情報
MENU_ARGUMENT - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
メニューの保有する引数
MENU_DEPARTMENT - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
メニューの利用権限を保有する組織
MENU_ID - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel の static 変数
メニューID
MENU_ID - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel の static 変数
メニューID
MENU_ID - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の static 変数
メニューID
MENU_ID - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel の static 変数
メニューID
MENU_ID - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel の static 変数
メニューID
MENU_ID - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel の static 変数
メニューID
MENU_ID - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel の static 変数
メニューID
MENU_POST - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
メニューの利用権限を保有する役職
MENU_PUBLIC_GROUP - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
メニューの利用権限を保有するパブリックグループ
MENU_ROLE - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
メニューの利用権限を保有するロール
MENU_TYPE - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の static 変数
メニュータイプ
MENU_TYPE_FOLDER - class jp.co.intra_mart.foundation.security.menu.MenuItem の static 変数
メニュータイプ（フォルダ）。
MENU_TYPE_ITEM - class jp.co.intra_mart.foundation.security.menu.MenuItem の static 変数
メニュータイプ（アイテム）。
MIN_VALUE - interface jp.co.intra_mart.foundation.utility.report.ReportLevel の static 変数
推奨されていません。 レベル値として使用可能な最小値 この値は、java.lang.Integer.MIN_VALUE と同じです。
MOBILE_EMAIL_ADDRESS - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
携帯用メール
MOBILE_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
携帯電話番号
MOBILE_PASSWORD - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
モバイル用パスワード
MONTH - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
月
MOVE - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

MOVE_ENTIRETY - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

MOVE_ITEM - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

MYSQL - class jp.co.intra_mart.foundation.database.DbTypes の static 変数

Mail - class jp.co.intra_mart.foundation.smtp.Mail.
推奨されていません。 MailSenderに置き換えられました。
Mail(String, int) - class jp.co.intra_mart.foundation.smtp.Mail のコンストラクタ
推奨されていません。 メール送信オブジェクトの生成。
Mail(String) - class jp.co.intra_mart.foundation.smtp.Mail のコンストラクタ
推奨されていません。 メール送信オブジェクトの生成。
Mail() - class jp.co.intra_mart.foundation.smtp.Mail のコンストラクタ
推奨されていません。 メール送信オブジェクトの生成。
MailAddress - interface jp.co.intra_mart.foundation.mail.javamail.model.MailAddress.
メールアドレスのモデルです。
MailSendEvent - class jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent.
メール送信イベントです。
MailSendEvent() - class jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent のコンストラクタ
SendMailEventを新規に生成します。
MailSendListener - interface jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener.
メール送信イベントのListenerインタフェースです。
MailSender - interface jp.co.intra_mart.foundation.mail.MailSender.
メールを送信するためのインターフェースです。
MailSenderException - exception jp.co.intra_mart.foundation.mail.MailSenderException.
メール送信時またはその他の不正な処理に関する情報を提供する例外です。
MailSenderException() - class jp.co.intra_mart.foundation.mail.MailSenderException のコンストラクタ
MailSenderExceptionを構築します。
MailSenderException(String) - class jp.co.intra_mart.foundation.mail.MailSenderException のコンストラクタ
指定された詳細メッセージを使用してMailSenderExceptionを構築します。
MailSenderException(String, Throwable) - class jp.co.intra_mart.foundation.mail.MailSenderException のコンストラクタ
指定された詳細メッセージおよび原因を使用してMailSenderExceptionを構築します。
MailSenderException(Throwable) - class jp.co.intra_mart.foundation.mail.MailSenderException のコンストラクタ
指定された原因を使用してMailSenderExceptionを構築します。
MainPageImportLoginGroupPostWriterListener - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener.
ログイングループ作成時にメインページパターンを設定するリスナークラス。
MainPageImportLoginGroupPostWriterListener() - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のコンストラクタ
コンストラクタ。
MainPagePatternInfo - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo.
メインページパターン情報クラス。
MainPagePatternInfo(String) - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo のコンストラクタ
コンストラクタ。
ManagerException - exception jp.co.intra_mart.foundation.datastore.exception.ManagerException.
マネージャに関する例外クラス

ManagerException() - class jp.co.intra_mart.foundation.datastore.exception.ManagerException のコンストラクタ
コンストラクタ
ManagerException(String) - class jp.co.intra_mart.foundation.datastore.exception.ManagerException のコンストラクタ
コンストラクタ
ManagerException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.ManagerException のコンストラクタ
コンストラクタ
ManagerException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.ManagerException のコンストラクタ
コンストラクタ
Mapper - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper.
エンティティの情報のマッパーです。
MapperDAOException - exception jp.co.intra_mart.foundation.datastore.exception.MapperDAOException.
マッパーのデータベース接続に関する例外クラス

マッパーがデータベース接続で問題が発生した場合にスローする。
MapperDAOException() - class jp.co.intra_mart.foundation.datastore.exception.MapperDAOException のコンストラクタ
コンストラクタ
MapperDAOException(String) - class jp.co.intra_mart.foundation.datastore.exception.MapperDAOException のコンストラクタ
コンストラクタ
MapperDAOException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.MapperDAOException のコンストラクタ
コンストラクタ
MapperDAOException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.MapperDAOException のコンストラクタ
コンストラクタ
MapperException - exception jp.co.intra_mart.foundation.datastore.exception.MapperException.
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。
MapperException() - class jp.co.intra_mart.foundation.datastore.exception.MapperException のコンストラクタ
コンストラクタ
MapperException(String) - class jp.co.intra_mart.foundation.datastore.exception.MapperException のコンストラクタ
コンストラクタ
MapperException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.MapperException のコンストラクタ
コンストラクタ
MapperException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.MapperException のコンストラクタ
コンストラクタ
MapperFactory - class jp.co.intra_mart.foundation.datastore.common.model.MapperFactory.
マッパーを生成します。
MapperFactory() - class jp.co.intra_mart.foundation.datastore.common.model.MapperFactory のコンストラクタ

MenuAccessor - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor.
メニューアクセッサインタフェース。
MenuArgumentBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel.
メニューの保有する引数の基本モデルです。
MenuArgumentMapper - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper.
メニューの保有する引数に関連するマッパです。
MenuBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel.
メニュー情報の基本モデルです。
MenuDepartmentBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel.
メニューの利用権限を保有する組織の基本モデルです。
MenuDepartmentMapper - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper.
メニューの利用権限を保有する組織に関連するマッパです。
MenuExporter - interface jp.co.intra_mart.foundation.security.menu.MenuExporter.
メニューエクスポートインタフェースです。
MenuImporter - interface jp.co.intra_mart.foundation.security.menu.MenuImporter.
メニューインポートインタフェースです。
MenuInclusion - class jp.co.intra_mart.foundation.security.menu.MenuInclusion.
メニュー内包情報クラス。
MenuInclusion(String, String) - class jp.co.intra_mart.foundation.security.menu.MenuInclusion のコンストラクタ
コンストラクタ。
MenuInternationalModel - interface jp.co.intra_mart.system.security.datastore.inf.MenuInternationalModel.
メニュー情報の国際化モデルです。
MenuItem - class jp.co.intra_mart.foundation.security.menu.MenuItem.
メニュー・モデルクラス。
MenuItem() - class jp.co.intra_mart.foundation.security.menu.MenuItem のコンストラクタ
コンストラクタ。
MenuItem(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のコンストラクタ
コンストラクタ。
MenuLinkSetPortlet - class jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet.
ページ種別「メニューリンクセット」に対するポートレットのモデルです。
MenuLinkSetPortlet() - class jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet のコンストラクタ
コンストラクタ
MenuManager - class jp.co.intra_mart.foundation.security.menu.MenuManager.
メニューマネージャクラス。
MenuManager(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のコンストラクタ
コンストラクタ。
MenuMapper - interface jp.co.intra_mart.system.security.datastore.inf.MenuMapper.
メニュー情報に関連するマッパです。
MenuPermissionSelector - class jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector.
ユーザIDから有効なメニューのID一覧を取得するセレクタ。
MenuPermissionSelector() - class jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector のコンストラクタ
コンストラクタ。
MenuPostBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel.
メニューの利用権限を保有する役職の基本モデルです。
MenuPostMapper - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper.
メニューの利用権限を保有する役職に関連するマッパです。
MenuPostWriterListener - interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener.
メニュー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
MenuPublicGroupBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel.
メニューの利用権限を保有するパブリックグループの基本モデルです。
MenuPublicGroupMapper - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper.
メニューの利用権限を保有するパブリックグループに関連するマッパです。
MenuQueryWriterListener - interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener.
メニュー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
MenuReaderDecorator - interface jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator.
メニュー情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
MenuRoleBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel.
メニューの利用権限を保有するロールの基本モデルです。
MenuRoleMapper - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper.
メニューの利用権限を保有するロールに関連するマッパです。
MenuServlet - class jp.co.intra_mart.foundation.security.servlet.MenuServlet.
メニュー連携サーブレットクラス。
MenuServlet() - class jp.co.intra_mart.foundation.security.servlet.MenuServlet のコンストラクタ
コンストラクタ。
MenuTree - class jp.co.intra_mart.foundation.security.menu.MenuTree.
メニューツリークラス。
MenuTree(MenuItem) - class jp.co.intra_mart.foundation.security.menu.MenuTree のコンストラクタ
コンストラクタ。
MessageManager - class jp.co.intra_mart.foundation.security.message.MessageManager.
メッセージマネージャクラス。
MessageReporter - interface jp.co.intra_mart.foundation.utility.report.MessageReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter クラスを使用してください。
MobileEasyLoginAuAnalyzer - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuAnalyzer.
モバイル端末固体識別番号取得プロバイダクラス Au用(WAP2.0)
MobileEasyLoginAuAnalyzer() - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuAnalyzer のコンストラクタ

MobileEasyLoginAuHdmlAnalyzer - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuHdmlAnalyzer.
推奨されていません。
MobileEasyLoginAuHdmlAnalyzer() - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuHdmlAnalyzer のコンストラクタ
推奨されていません。
MobileEasyLoginDocomoAnalyzer - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoAnalyzer.
モバイル端末固体識別番号取得プロバイダクラス NTT DoCoMo用(FOMA)
MobileEasyLoginDocomoAnalyzer() - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoAnalyzer のコンストラクタ

MobileEasyLoginDocomoMoveAnalyzer - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoMoveAnalyzer.
推奨されていません。
MobileEasyLoginDocomoMoveAnalyzer() - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoMoveAnalyzer のコンストラクタ
推奨されていません。
MobileEasyLoginJphoneAnalyzer - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginJphoneAnalyzer.
推奨されていません。
MobileEasyLoginJphoneAnalyzer() - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginJphoneAnalyzer のコンストラクタ
推奨されていません。
MobileEasyLoginSoftBankAnalyzer - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginSoftBankAnalyzer.
モバイル端末固体識別番号取得プロバイダクラス SoftBank用(3GC型)
MobileEasyLoginSoftBankAnalyzer() - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginSoftBankAnalyzer のコンストラクタ

MobileEasyLoginUtil - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil.
かんたんログイン機能のユーティリティクラスです。
MobileEasyLoginUtil() - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil のコンストラクタ

MobileEasyLoginVodafoneAnalyzer - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginVodafoneAnalyzer.
モバイル端末固体識別番号取得プロバイダクラス Vodafone用(3GC型)
MobileEasyLoginVodafoneAnalyzer() - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginVodafoneAnalyzer のコンストラクタ

MobileUserAgentProvider - interface jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider.
モバイル端末固体識別番号取得プロバイダインタフェース。
Model - interface jp.co.intra_mart.foundation.datastore.common.config.Model.
モデルを定義します。
MultiCastReporter - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter クラスを使用してください。
MultiCastReporter() - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のコンストラクタ
推奨されていません。 唯一のコンストラクタ。
MultiComparator - class jp.co.intra_mart.foundation.utility.MultiComparator.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator クラスを使用してください。
MultiComparator(Comparator, Comparator) - class jp.co.intra_mart.foundation.utility.MultiComparator のコンストラクタ
推奨されていません。 第１コンパレータ 、第２コンパレータを指定して、新しいオブジェクトを生成します。
MultipartFormData - class jp.co.intra_mart.foundation.http.MultipartFormData.
推奨されていません。 jp.co.intra_mart.common.aid.javaee.http.MultipartFormData クラスを使用してください。
MultipartFormData(ServletRequest) - class jp.co.intra_mart.foundation.http.MultipartFormData のコンストラクタ
推奨されていません。 リクエストされた情報を解析して、新しいオブジェクトを構築します。
MultipartFormData.Entity - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity.
推奨されていません。 jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity インタフェースを使用してください。
MultipurposeInternetMailExtensions - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions クラスを使用してください。
MultipurposeInternetMailExtensions(String) - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のコンストラクタ
推奨されていません。 MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(File) - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のコンストラクタ
推奨されていません。 MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(String, String) - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のコンストラクタ
推奨されていません。 指定のMIMEタイプを表すオブジェクトを構築します。
mainPagePath - class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor の変数

mainRemoved(String, DepartmentMain) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
主所属情報がデータストアから削除された後に呼び出されます。
mainRemoved(String, DepartmentMain) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
主所属情報がデータストアから削除された後に呼び出されます。
mainRemoved(String, DepartmentMain) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
主所属情報がデータストアから削除された後に呼び出されます。
mainSet(String, DepartmentMain) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
主所属情報がデータストアに登録された後に呼び出されます。
mainSet(String, DepartmentMain) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
主所属情報がデータストアに登録された後に呼び出されます。
mainSet(String, DepartmentMain) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
主所属情報がデータストアに登録された後に呼び出されます。
make() - class jp.co.intra_mart.foundation.service.client.information.Identifier の static メソッド

makeCertifyEnvironment(Hashtable, String, String, String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
LDAP認証用の設定情報を作成する。
makeDirectories() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すディレクトリを生成します。
makeSearchControls() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
検索用のサーチコントローラーを作成する。
makeSerchEnvironments() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
LDAP上のユーザを検索する為の設定情報を作成する。
matchDbType(String) - class jp.co.intra_mart.foundation.database.DbTypes の static メソッド

matchSysLocales(Locale[], String[]) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter のメソッド
ロケールマッチング（共通）

memberDeleted(String, DepartmentAttach) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織からの人員の割当がデータストアから削除された後に呼び出されます。
memberDeleted(String, PrivateGroupAttach) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
プライベートグループ所属情報がデータストアから削除された後に呼び出されます。
memberDeleted(String, PublicGroupAttach) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
memberDeleted(String, DepartmentAttach) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
組織からの人員の割当がデータストアから削除された後に呼び出されます。
memberDeleted(String, PublicGroupAttach) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
memberDeleted(String, DepartmentAttach) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織からの人員の割当がデータストアから削除された後に呼び出されます。
memberDeleted(String, PublicGroupAttach) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
memberSet(String, DepartmentAttach) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織への人員の割当がデータストアに登録された後に呼び出されます。
memberSet(String, PrivateGroupAttach) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
プライベートグループ所属情報がデータストアに登録された後に呼び出されます。
memberSet(String, PublicGroupAttach) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
memberSet(String, DepartmentAttach) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
組織への人員の割当がデータストアに登録された後に呼び出されます。
memberSet(String, PublicGroupAttach) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
memberSet(String, DepartmentAttach) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織への人員の割当がデータストアに登録された後に呼び出されます。
memberSet(String, PublicGroupAttach) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
modify(String) - class jp.co.intra_mart.foundation.update.UpdateManager のメソッド
対象となる更新管理キーの更新日付を更新します。
move(String) - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルの名前を変更します。
move(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
グループキーを変更します。
moveCategory(String, String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
カテゴリーを更新します。
moveDepartment(String, String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織構成に登録済の組織情報を移動します。
moveMenuItem(MenuInclusion) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニューを移動します。
moveMenuItem(MenuInclusion) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューを移動します。
movePublicGroup(String, String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループ構成に登録済のパブリックグループ情報を移動します。

N

NAME - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の static 変数
分類区分名
NAME - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の static 変数
分類名
NAME - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
組織名
NAME - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
役職名
NAME - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
グループ名
NAME - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
グループ名
NAME - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ユーザ名
NAME - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel の static 変数
ロール名
NAME_ENGLISH - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
組織名英字
NAME_ENGLISH - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
グループ名英字
NAME_ENGLISH - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
グループ名英字
NAME_ENGLISH - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ユーザ名英字
NAME_SYLLABARY - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
組織名カナ
NAME_SYLLABARY - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
グループ名カナ
NAME_SYLLABARY - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
グループ名カナ
NAME_SYLLABARY - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ユーザ名カナ
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel の static 変数
説明
NOTES - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
説明
NOTES - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の static 変数
説明
NOTES - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel の static 変数
備考
NULL - class jp.co.intra_mart.foundation.datastore.common.config.DeleteType の static 変数
Null ターゲットエンティティのデータを参照しているソースエンティティの外部キーをnullにします。
NULL - class jp.co.intra_mart.foundation.datastore.common.config.LifetimeType の static 変数
Null ターゲットエンティティの期間を参照しているソースエンティティの外部キーをnullにします。
NULL_DATA - class jp.co.intra_mart.foundation.service.client.NetworkAgent の static 変数
NULL を表します。
NUMBER_VALUE - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel の static 変数
属性数値
NavigatorAuthenticateItem - class jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem.
選択アイテムクラス
NavigatorAuthenticateItem() - class jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem のコンストラクタ

NavigatorInfo - class jp.co.intra_mart.foundation.security.activesession.NavigatorInfo.
ナビゲータ情報クラス。
NavigatorInfo() - class jp.co.intra_mart.foundation.security.activesession.NavigatorInfo のコンストラクタ
コンストラクタ。
NavigatorItem - class jp.co.intra_mart.foundation.navigator.NavigatorItem.
イベントナビゲータアイテムクラス
NavigatorItem() - class jp.co.intra_mart.foundation.navigator.NavigatorItem のコンストラクタ

NetworkAgent - class jp.co.intra_mart.foundation.service.client.NetworkAgent.
このクラスは、他のサーバで実行されるロジックを実装する ためのスケルトンを提供します。
NetworkAgent() - class jp.co.intra_mart.foundation.service.client.NetworkAgent のコンストラクタ
唯一のコンストラクタ。
NetworkConnector - class jp.co.intra_mart.foundation.service.client.NetworkConnector.
このクラスは、他のサーバで実行されるロジックを転送する ためのスケルトンを提供します。
NetworkConnector() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のコンストラクタ
唯一のコンストラクタ。
NetworkFile - class jp.co.intra_mart.foundation.service.client.file.NetworkFile.
Storage Service のファイルを扱う事の出来るオブジェクトです。
NetworkFile(String) - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のコンストラクタ
新しいオブジェクトを構築します。
NewArrived - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived.
汎用新着情報を保持します。
NewArrived() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のコンストラクタ

NewArrivedManager - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager.
汎用新着情報の取得処理を行うクラスです。
NewArrivedManager() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager のコンストラクタ

NewArrivedProvider - interface jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider.
汎用新着情報のプロバイダのインターフェースです。
NoCryption - class jp.co.intra_mart.foundation.security.cryption.NoCryption.
暗号化処理を行わない実装クラス。
NoCryption() - class jp.co.intra_mart.foundation.security.cryption.NoCryption のコンストラクタ
コンストラクタ。
NoFilterException - exception jp.co.intra_mart.foundation.security.exception.NoFilterException.
HTTPリクエスト・レスポンス取得例外クラス。
NoFilterException(String) - class jp.co.intra_mart.foundation.security.exception.NoFilterException のコンストラクタ
コンストラクタ。
NoFilterException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.NoFilterException のコンストラクタ
コンストラクタ。
NoFilterException(Throwable) - class jp.co.intra_mart.foundation.security.exception.NoFilterException のコンストラクタ
コンストラクタ。
NoFilterException() - class jp.co.intra_mart.foundation.security.exception.NoFilterException のコンストラクタ
コンストラクタ。
NoSessionCookieException - exception jp.co.intra_mart.foundation.security.exception.NoSessionCookieException.
セッション情報クッキー取得例外クラス。
NoSessionCookieException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.NoSessionCookieException のコンストラクタ
コンストラクタ。
NoSessionCookieException(String) - class jp.co.intra_mart.foundation.security.exception.NoSessionCookieException のコンストラクタ
コンストラクタ。
NoSessionException - exception jp.co.intra_mart.foundation.security.exception.NoSessionException.
セッション取得例外クラス。
NoSessionException(String) - class jp.co.intra_mart.foundation.security.exception.NoSessionException のコンストラクタ
コンストラクタ。
NoSessionException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.NoSessionException のコンストラクタ
コンストラクタ。
NoSessionException(Throwable) - class jp.co.intra_mart.foundation.security.exception.NoSessionException のコンストラクタ
コンストラクタ。
NoSessionException() - class jp.co.intra_mart.foundation.security.exception.NoSessionException のコンストラクタ
コンストラクタ。
NoSuchPropertyException - exception jp.co.intra_mart.foundation.scenario.NoSuchPropertyException.
NoSuchPropertyException クラスは、指定されたプロパティがオブジェクトには ないことを通知します。
NoSuchPropertyException(String) - class jp.co.intra_mart.foundation.scenario.NoSuchPropertyException のコンストラクタ
詳細メッセージを指定して NoSuchPropertyException を構築します。
NodeNameComparator - class jp.co.intra_mart.foundation.page.NodeNameComparator.
ツリービューのノードを名前順にソートするためのコンパレータです。
NodeNameComparator() - class jp.co.intra_mart.foundation.page.NodeNameComparator のコンストラクタ

NodeTypeComparator - class jp.co.intra_mart.foundation.page.NodeTypeComparator.
ツリービューのノードを種類順にソートするためのコンパレータです。
NodeTypeComparator(Comparator) - class jp.co.intra_mart.foundation.page.NodeTypeComparator のコンストラクタ
第２コンパレータ secondaryComparatorを指定して、新たなオブジェクトを生成します。
NonceResetListener4MobileEasyLogin - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin.
かんたんログイン用のNonceを再設定する為のリスナーです。
NonceResetListener4MobileEasyLogin() - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のコンストラクタ

NotExistException - exception jp.co.intra_mart.foundation.security.exception.NotExistException.
アクセスセキュリティ情報が存在しなかった場合の例外クラス。
NotExistException(String, String, String) - class jp.co.intra_mart.foundation.security.exception.NotExistException のコンストラクタ
コンストラクタ。
NotExistException(String, String) - class jp.co.intra_mart.foundation.security.exception.NotExistException のコンストラクタ
コンストラクタ。
NotExistException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.NotExistException のコンストラクタ
コンストラクタ。
NotExistException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.NotExistException のコンストラクタ
コンストラクタ。
NotExistImageIconException - exception jp.co.intra_mart.foundation.image.NotExistImageIconException.
イメージアイコンが存在しなかった場合の例外クラス。
NotExistImageIconException() - class jp.co.intra_mart.foundation.image.NotExistImageIconException のコンストラクタ
コンストラクタ。
NotExistImageIconException(String, String) - class jp.co.intra_mart.foundation.image.NotExistImageIconException のコンストラクタ
コンストラクタ。
NotExistImageIconException(Throwable) - class jp.co.intra_mart.foundation.image.NotExistImageIconException のコンストラクタ
コンストラクタ。
NotExistImageIconException(String, String, Throwable) - class jp.co.intra_mart.foundation.image.NotExistImageIconException のコンストラクタ
コンストラクタ。
NotFoundDataSourceException - exception jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException.
データソースの参照名未解決例外クラス。
NotFoundDataSourceException(String, String) - class jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException のコンストラクタ
コンストラクタ。
NotFoundDataSourceException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException のコンストラクタ
コンストラクタ。
NotSupportMethodException - exception jp.co.intra_mart.foundation.security.exception.NotSupportMethodException.
アクセスセキュリティのマネージャでサポートされないメソッドがコールされた場合の例外クラス。
NotSupportMethodException(Throwable) - class jp.co.intra_mart.foundation.security.exception.NotSupportMethodException のコンストラクタ
コンストラクタ。
NotSupportMethodException() - class jp.co.intra_mart.foundation.security.exception.NotSupportMethodException のコンストラクタ
コンストラクタ。
nativeSQL(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された SQL 文をシステムの本来の SQL 文法に変換します。
newExtendedBaseModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap のメソッド
初期化されていない拡張基本モデルのインスタンスを取得します。
newExtendedInternationalModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap のメソッド
初期化されていない拡張国際化モデルのインスタンスを取得します。
newExtendedTerminableInternationalModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap のメソッド
初期化されていない拡張期間国際化モデルのインスタンスを取得します。
newExtendedTerminableModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap のメソッド
初期化されてていない拡張期間化モデルのインスタンスを取得します。
newIdentifier() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
新しいセッションＩＤを生成します。
newInstance() - class jp.co.intra_mart.foundation.datastore.common.model.MapperFactory の static メソッド
マッパーファクトリを取得します。
newInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
初期化されていない国際化モデルのインスタンスを取得します。
newString(String) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 CharacterEncoder.getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
newString(char[]) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 CharacterEncoder.getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
newTerminableInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
初期化されていない期間国際化モデルのインスタンスを取得します。
newTerminableModel(Term) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
初期化されていない期間化モデルのインスタンスを取得します。
notifyDelete(Relationship, BaseModel) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
notifyDelete(Relationship, BaseModel) - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
notifyUpdate(Relationship, BaseModel) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
notifyUpdate(Relationship, BaseModel) - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
リレーションシップで定義された参照先基本モデルが更新されたことを通知します。

O

OPEN_FLG_CLOSE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
公開フラグ：非公開
OPEN_FLG_EDIT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
公開フラグ：編集中
OPEN_FLG_OPEN - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
公開フラグ：公開
ORACLE - class jp.co.intra_mart.foundation.database.DbTypes の static 変数

OTHER - class jp.co.intra_mart.foundation.database.DbTypes の static 変数

OWNER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の static 変数
所有者コード
OWNER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
所有者コード
OutputSizeConditioner - class jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner クラスを使用してください。
OutputSizeConditioner(long) - class jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner のコンストラクタ
推奨されていません。 メッセージファイルへのデータ出力量によりリフレッシュイベントを 発生させるためのヘルパーオブジェクトを構築します。
onSendMail(MailSendEvent) - interface jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener のメソッド
メール送信が行われたことを通知します。
onSendMail(MailSendEvent) - class jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener のメソッド
メール送信が行われたことを通知します。
out - class jp.co.intra_mart.foundation.service.provider.Platform の static 変数
システムログに対するメッセージ出力ストリームです。
out - class jp.co.intra_mart.foundation.utility.io.HexOutputStream の変数
推奨されていません。 フィルタ処理される基礎出力ストリームです。
out - class jp.co.intra_mart.foundation.utility.report.FileReporter の変数
推奨されていません。 基礎出力ストリームです。
out - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter の変数
推奨されていません。 基礎出力ストリームです。

P

PAGE_KIND - class jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet の static 変数
ページ種別
PAGE_KIND - class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet の static 変数
ページ種別
PAGE_KIND - class jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet の static 変数
ページ種別
PAGE_KIND - class jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet の static 変数
ページ種別
PAGE_KIND - class jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet の static 変数
ページ種別
PAGE_KIND - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet の static 変数
ページ種別
PAGE_PATH - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider の static 変数
ページベースプログラム名を特定するキー
PAGE_PATTERN_ID - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
メインページパターン
PARENT_DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
親組織コード
PARENT_ITEM_CATEGORY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel の static 変数
親商品カテゴリコード
PARENT_MENU_ID - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の static 変数
親メニューID
PARENT_PUBLIC_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
親グループコード
PARENT_ROLE_ID - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel の static 変数
親ロールコード
PASSWORD - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
パスワード
PLUGIN_METHOD - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
プラグイン関数
POSTGRESQL - class jp.co.intra_mart.foundation.database.DbTypes の static 変数

POST_CD - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel の static 変数
役職CD
POST_CD - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel の static 変数
役職CD
POST_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
役職CD
POST_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
役職コード
PRIVATE_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の static 変数
グループコード
PRIVATE_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
グループコード
PROCESS_BUSY - class jp.co.intra_mart.foundation.database.exception.DatabaseExportException の static 変数
推奨されていません。
PRODUCT_MODEL_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel の static 変数
製品型番
PROGRAM_LANGUAGE - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
実行プログラム言語
PROGRAM_PATH - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
実行プログラムパス
PUBLIC_GROUP_CD - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel の static 変数
グルーピングCD
PUBLIC_GROUP_CD - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel の static 変数
グルーピングCD
PUBLIC_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel の static 変数
グループコード
PUBLIC_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の static 変数
グループコード
PUBLIC_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の static 変数
グループコード
PUBLIC_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
グループコード
PUBLIC_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
グループコード
PUBLIC_GROUP_SET_CD - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel の static 変数
グループセットCD
PUBLIC_GROUP_SET_CD - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel の static 変数
グループセットCD
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel の static 変数
グループセットコード
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の static 変数
グループセットコード
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の static 変数
グループセットコード
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
グループセットコード
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
グループセットコード
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel の static 変数
グループセットコード
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
グループセットコード
PURCHASE_UNIT_PRICE - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel の static 変数
仕入単価
PageBaseCallProvider - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider.
NewArrivedProvider インターフェースの実装です。
PageBaseCallProvider() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider のコンストラクタ

ParameterManager - class jp.co.intra_mart.foundation.commons.ParameterManager.
システム共通パラメータ情報の取得を行うクラスです。
ParameterSourceProvider - interface jp.co.intra_mart.foundation.commons.ParameterSourceProvider.
アプリケーション共通マスタのパラメータの管理するプロバイダーです。
PasswordHistory - class jp.co.intra_mart.foundation.security.password.PasswordHistory.
パスワード履歴管理情報クラス

PasswordHistory() - class jp.co.intra_mart.foundation.security.password.PasswordHistory のコンストラクタ

PasswordHistoryAccessor - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor.
パスワード履歴管理アクセッサインターフェース。
PasswordHistoryAccountChangedListener - class jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener.
アカウント情報変更リスナー(パスワード履歴管理)。
PasswordHistoryAccountChangedListener() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener のコンストラクタ

PasswordHistoryException - exception jp.co.intra_mart.foundation.security.password.PasswordHistoryException.
イメージアイコンの例外クラス。
PasswordHistoryException() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryException のコンストラクタ
コンストラクタ。
PasswordHistoryException(String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryException のコンストラクタ
コンストラクタ。
PasswordHistoryException(Throwable) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryException のコンストラクタ
コンストラクタ。
PasswordHistoryException(String, Throwable) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryException のコンストラクタ
コンストラクタ。
PasswordHistoryManager - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager.
パスワード履歴管理マネージャクラス

ServerManager/conf/password-history.xmlからパスワード履歴管理に関するパラメータを取得します。
PasswordHistoryManager(String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のコンストラクタ

PasswordHistoryManagerInitializerImpl - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManagerInitializerImpl.
パスワード履歴管理マネージャの初期化クラス。
PasswordHistoryManagerInitializerImpl() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManagerInitializerImpl のコンストラクタ

PasswordHistoryNewArrivedProvider - class jp.co.intra_mart.foundation.security.password.PasswordHistoryNewArrivedProvider.
パスワード履歴管理汎用新着情報のプロバイダ。
PasswordHistoryNewArrivedProvider() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryNewArrivedProvider のコンストラクタ

PasswordHistoryResult - class jp.co.intra_mart.foundation.security.password.PasswordHistoryResult.
パスワード履歴管理リザルトクラス。
PasswordHistoryResult() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryResult のコンストラクタ

PasswordHistoryResult(String, String) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryResult のコンストラクタ

PasswordHistoryUserPageProvider - class jp.co.intra_mart.foundation.security.password.PasswordHistoryUserPageProvider.
パスワード履歴管理スタンダードユーザページプロバイダクラス。
PasswordHistoryUserPageProvider() - class jp.co.intra_mart.foundation.security.password.PasswordHistoryUserPageProvider のコンストラクタ

PasswordSecurityHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler.
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
PasswordSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler, String, String, String) - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler のコンストラクタ
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
PeriodicConditioner - class jp.co.intra_mart.foundation.utility.report.PeriodicConditioner.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner クラスを使用してください。
PeriodicConditioner(long) - class jp.co.intra_mart.foundation.utility.report.PeriodicConditioner のコンストラクタ
推奨されていません。 タイマーによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
PermanentDataArchiveFactory - class jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory.
推奨されていません。
PermanentDataArchiveFactory() - class jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory のコンストラクタ
推奨されていません。 バッチプログラム実行環境からインスタンス化されるためのコンストラクタ。
PermanentDataDirectory - class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory.
Permanent-data を保存するディレクトリを表すオブジェクトです。
PermanentDirectory - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory.
ファイルベースでデータを保存します。
PermanentDirectory(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
PermanentFile - class jp.co.intra_mart.foundation.service.client.information.PermanentFile.
ファイルベースでデータを保存します。
PermanentFile(String, String) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
PermanentFile(PermanentDirectory, String) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
PermissionManager - class jp.co.intra_mart.foundation.security.permission.PermissionManager.
パーミッション・マネージャクラス。
PermissionManager(String) - class jp.co.intra_mart.foundation.security.permission.PermissionManager のコンストラクタ
コンストラクタ。
PermissionSelector - interface jp.co.intra_mart.foundation.security.permission.PermissionSelector.
パーミッション・作成クラスインタフェース。
PlainCompanyPost - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost.
役職データを扱います。
Platform - class jp.co.intra_mart.foundation.service.provider.Platform.
Platform クラスには、システム動作に関わる有用な情報を持つ フィールドおよびメソッドがあります。
PortFolioDrawer - class jp.co.intra_mart.foundation.graph.PortFolioDrawer.
ポートフォリオを描画します。
PortFolioDrawer(int, int, int, int, int, int) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のコンストラクタ
ｘ軸、ｙ軸の目盛値をint表現でポートフォリオを作成します。
PortFolioDrawer(double, double, double, double, double, double) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のコンストラクタ
ｘ軸、ｙ軸の目盛値をdouble表現でポートフォリオを作成します。
PortFolioObject - class jp.co.intra_mart.foundation.graph.PortFolioObject.
PortFolioDrawerクラスのデータを保存するオブジェクトです。
PortFolioObject(double, double) - class jp.co.intra_mart.foundation.graph.PortFolioObject のコンストラクタ
グラフのｘ値、ｙ値を指定して、データオブジェクトを作成します。
PortFolioObject(int, int) - class jp.co.intra_mart.foundation.graph.PortFolioObject のコンストラクタ
グラフのｘ値、ｙ値を指定して、データオブジェクトを作成します。
PortFolioObject(double, double, Color, int) - class jp.co.intra_mart.foundation.graph.PortFolioObject のコンストラクタ
グラフのｘ値、ｙ値と描画する点の色とサイズを指定して、データオブジェクトを作成します。
PortFolioObject(int, int, Color, int) - class jp.co.intra_mart.foundation.graph.PortFolioObject のコンストラクタ
グラフのｘ値、ｙ値と描画する点の色とサイズを指定して、データオブジェクトを作成します。
PortalStandardUserPageProvider - class jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider.
ポータルユーザページプロバイダクラス。
PortalStandardUserPageProvider() - class jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider のコンストラクタ
コンストラクタ。
Portlet - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet.
すべてのポートレットの基底となる抽象クラスです。
Portlet() - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のコンストラクタ

PortletManager - class jp.co.intra_mart.foundation.portal.portlet.PortletManager.
ポートレット情報の登録・参照を行うマネージャクラスです。
PortletManager(String) - class jp.co.intra_mart.foundation.portal.portlet.PortletManager のコンストラクタ
コンストラクタ
PortletManagerException - exception jp.co.intra_mart.foundation.portal.portlet.PortletManagerException.
ポートレットマネージャー操作時に発生するすべての例外のクラスです。
PortletManagerException() - class jp.co.intra_mart.foundation.portal.portlet.PortletManagerException のコンストラクタ
コンストラクタ
PortletManagerException(String) - class jp.co.intra_mart.foundation.portal.portlet.PortletManagerException のコンストラクタ
コンストラクタ
PortletManagerException(Throwable) - class jp.co.intra_mart.foundation.portal.portlet.PortletManagerException のコンストラクタ
コンストラクタ
PortletManagerException(String, Throwable) - class jp.co.intra_mart.foundation.portal.portlet.PortletManagerException のコンストラクタ
コンストラクタ
PortletMapping - class jp.co.intra_mart.foundation.portal.portlet.PortletMapping.
ポートレットの種別とモデルのマッピングを管理します。
PostInfo - class jp.co.intra_mart.foundation.security.PostInfo.
役職情報クラス。
PostInfo(String, String) - class jp.co.intra_mart.foundation.security.PostInfo のコンストラクタ
コンストラクタ。
PresentationPage - class jp.co.intra_mart.foundation.scenario.PresentationPage.
PresentationPage クラスは、プレゼンテーション・ページとなるスクリプトを コンパイルして実行可能な環境を提供します。
PresentationPage() - class jp.co.intra_mart.foundation.scenario.PresentationPage のコンストラクタ
セッションを持たないページ作成用オブジェクトを作成します。
PresentationPage(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.scenario.PresentationPage のコンストラクタ
任意のセッションを持つページ作成オブジェクトを構築します。
PresentationPageHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler.
スクリプト開発モデルのプレゼンテーションページを実行するためのハンドラです。
PresentationPageHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のコンストラクタ
ハンドラを作成します。
PresentationPageHTTPActionEventHandler(String) - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のコンストラクタ
ハンドラを作成します。
PresentationPagePortlet - class jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet.
ページ種別「プレゼンテーションページ」に対するポートレットのモデルです。
PresentationPagePortlet() - class jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet のコンストラクタ

PrimaryKeyMapping - interface jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping.
分割されたテーブルに割り当てられるプライマリーキーとなるカラムを定義します。
PrintStreamReporter - class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter クラスを使用してください。
PrintStreamReporter(PrintStream) - class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter のコンストラクタ
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
PrivateGroup - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup.
プライベートグループの基本属性のデータを取り扱います。
PrivateGroup() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のコンストラクタ

PrivateGroupAttach - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach.
プライベートグループ所属の基本属性のデータを取り扱います。
PrivateGroupAttach() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のコンストラクタ

PrivateGroupAttachBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel.
プライベートグループ所属の基本モデルです。
PrivateGroupAttachMapper - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper.
プライベートグループ所属に関連するマッパです。
PrivateGroupBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel.
プライベートグループの基本モデルです。
PrivateGroupChangedListener - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener.
プライベートグループに関する情報の更新時のリスナーです。
PrivateGroupManager - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager.
プライベートグループに関連する情報を管理します。
PrivateGroupManager() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のコンストラクタ

PrivateGroupMapper - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper.
プライベートグループに関連するマッパです。
ProcedureComponent - interface jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent.
スケジュール実行されるバッチプログラムのためのインターフェースを定義します。
Property - interface jp.co.intra_mart.foundation.datastore.common.config.Property.
プロパティを定義します。
PublicGroup - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup.
パブリックグループの基本属性のデータを取り扱います。
PublicGroup() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のコンストラクタ
パブリックグループに関連する情報を新規に生成します。
PublicGroup(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のコンストラクタ
パブリックグループに関連する情報を新規に生成します。
PublicGroup(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のコンストラクタ
パブリックグループに関連する情報を新規に生成します。
PublicGroup(Locale, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のコンストラクタ
パブリックグループに関連する情報を新規に生成します。
PublicGroupAttach - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach.
パブリックグループ所属の基本属性のデータを取り扱います。
PublicGroupAttach() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のコンストラクタ
パブリックグループ所属に関連する情報を新規に生成します。
PublicGroupAttach(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のコンストラクタ
パブリックグループ所属に関連する情報を新規に生成します。
PublicGroupAttachBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel.
パブリックグループ所属の基本モデルです。
PublicGroupAttachMapper - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper.
パブリックグループ所属に関連するマッパです。
PublicGroupAttachTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable.
パブリックグループ所属の期間化属性のデータを取り扱います。
PublicGroupAttachTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable のコンストラクタ

PublicGroupAttachTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachTerminableModel.
パブリックグループ所属の期間化モデルです。
PublicGroupBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel.
パブリックグループの基本モデルです。
PublicGroupCategory - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory.
パブリックグループ分類の基本属性のデータを取り扱います。
PublicGroupCategory() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のコンストラクタ
パブリックグループ分類に関連する情報を新規に生成します。
PublicGroupCategory(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のコンストラクタ
パブリックグループ分類に関連する情報を新規に生成します。
PublicGroupCategoryBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel.
パブリックグループ分類の基本モデルです。
PublicGroupCategoryMapper - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper.
パブリックグループ分類に関連するマッパです。
PublicGroupCategoryTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable.
パブリックグループ分類の期間化属性のデータを取り扱います。
PublicGroupCategoryTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable のコンストラクタ

PublicGroupCategoryTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryTerminableModel.
パブリックグループ分類の期間化モデルです。
PublicGroupChangedControllerListener - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener.
パブリックグループが削除された場合にアクセスコントローラに紐付くパブリックグループを削除するリスナークラスです。
PublicGroupChangedControllerListener() - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のコンストラクタ

PublicGroupChangedListener - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener.
パブリックグループに関する情報の更新時のリスナーです。
PublicGroupChangedMenuListener - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener.
パブリックグループに関する情報の変更時のリスナーです。
PublicGroupChangedMenuListener() - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のコンストラクタ

PublicGroupExportManager - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager.
パブリックグループ情報のエクスポートを行います。
PublicGroupExportManager() - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager のコンストラクタ
コンストラクタ パブリックグループ情報エクスポートマネージャーのインスタンスを生成します。
PublicGroupExportManagerClient - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient.
パブリックグループ情報のエクスポートを行います。
PublicGroupExportManagerClient() - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient のコンストラクタ

PublicGroupImportManager - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager.
パブリックグループ情報のインポートを行います。
PublicGroupImportManager() - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager のコンストラクタ
コンストラクタ パブリックグループインポートマネージャーのインスタンスを生成します。
PublicGroupImportManagerClient - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient.
パブリックグループ情報のインポートを行います。
PublicGroupImportManagerClient() - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient のコンストラクタ

PublicGroupImporter - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter.
パブリックグループのインポートのインターフェースです
PublicGroupInclusionBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel.
パブリックグループ内包の基本モデルです。
PublicGroupInclusionMapper - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper.
パブリックグループ内包に関連するマッパです。
PublicGroupInfo - class jp.co.intra_mart.foundation.security.PublicGroupInfo.
パブリックグループ情報クラス。
PublicGroupInfo(String, String) - class jp.co.intra_mart.foundation.security.PublicGroupInfo のコンストラクタ
コンストラクタ。
PublicGroupManager - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager.
パブリックグループに関連する情報を管理します。
PublicGroupManager() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のコンストラクタ

PublicGroupMapper - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper.
パブリックグループに関連するマッパです。
PublicGroupSet - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet.
パブリックグループセットの基本属性のデータを取り扱います。
PublicGroupSet() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のコンストラクタ
パブリックグループセットに関連する情報を新規に生成します。
PublicGroupSet(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のコンストラクタ
パブリックグループセットに関連する情報を新規に生成します。
PublicGroupSet(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のコンストラクタ
パブリックグループセットに関連する情報を新規に生成します。
PublicGroupSet(Locale, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のコンストラクタ
パブリックグループセットに関連する情報を新規に生成します。
PublicGroupSetBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel.
パブリックグループセットの基本モデルです。
PublicGroupSetMapper - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper.
パブリックグループセットに関連するマッパです。
PublicGroupSetTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable.
パブリックグループセットの期間化属性のデータを取り扱います。
PublicGroupSetTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable のコンストラクタ

PublicGroupSetTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational.
パブリックグループセットの期間国際化属性のデータを取り扱います。
PublicGroupSetTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のコンストラクタ

PublicGroupStruct - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct.
組織の階層です。
PublicGroupTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable.
パブリックグループの期間化属性のデータを取り扱います。
PublicGroupTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable のコンストラクタ

PublicGroupTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational.
パブリックグループの期間国際化属性のデータを取り扱います。
PublicGroupTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のコンストラクタ

PublicGroupTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel.
パブリックグループの期間国際化モデルです。
PublicGroupTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel.
パブリックグループの期間化モデルです。
PublicGroupVersion - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion.
パブリックグループ構成バージョンの基本属性のデータを取り扱います。
PublicGroupVersion() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のコンストラクタ

PublicGroupVersionBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel.
パブリックグループ構成バージョンの基本モデルです。
PublicGroupVersionMapper - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper.
パブリックグループ構成バージョンに関連するマッパです。
parseRequest(LoginRequestInfo, HttpServletRequest) - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer のメソッド
リクエストパラメータの解析。
parseRequest(LoginRequestInfo, HttpServletRequest) - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer のメソッド
リクエストパラメータの解析。
parseRequest(LoginRequestInfo, HttpServletRequest) - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
リクエストパラメータの解析。
paths(int) - class jp.co.intra_mart.foundation.utility.file.Directory のメソッド
推奨されていません。 この抽象パス名が示すディレクトリにあるファイルおよびディレクトリの 抽象パスを繰り返し処理する反復子を作成します。
postAddMenuLoginGroup(String, String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
アクセスを許可するログイングループを追加する直後にコールされます。
postAdded(String, CompanyPost) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
役職情報がデータストアに登録された後に呼び出されます。
postAdded(String, CompanyPost) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
役職情報がデータストアに登録された後に呼び出されます。
postAdded(String, CompanyPost) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
役職情報がデータストアに登録された後に呼び出されます。
postCreate(String, AccessController) - interface jp.co.intra_mart.foundation.security.access.AccessControllerPostWriterListener のメソッド
アクセスコントローラ情報をデータストアに作成した直後にコールされます。
postCreate(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener のメソッド
システム管理者情報をデータストアに作成した直後にコールされます。
postCreate(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener のメソッド
バッチ情報をデータストアに作成した直後にコールされます。
postCreate(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener のメソッド
グループ管理者情報をデータストアに作成した直後にコールされます。
postCreate(MenuItem) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
メニュー情報をデータストアに作成した直後にコールされます。
postCreate(String, MenuItem) - interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener のメソッド
メニュー情報をデータストアに作成した直後にコールされます。
postCreateAccount(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウント情報をデータストアに作成した直後にコールされます。
postCreateAccount(String, Account) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

postCreateAccountRole(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウントロール情報をデータストアに作成した直後にコールされます。
postCreateAccountRole(String, String, AccountRole) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

postCreateCalendarInfo(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener のメソッド
カレンダーデータをデータストアに作成した直後にコールされます。
postCreateFavoriteMenu(String, String, FavoriteMenu) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
マイメニュー情報をデータストアに作成した直後にコールされます。
postCreateFavoriteMenu(String, String, FavoriteMenu) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

postCreateLoginGroup(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
ログイングループ情報をデータストアに作成した直後にコールされます。
postCreateLoginGroup(LoginGroup) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
ログイングループ情報をデータストアに作成した直後にコールされます。
postCreateMainPagePattern(String, MainPagePatternInfo) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
メインページパターン情報をデータストアに作成した直後にコールされます。
postCreateMainPagePattern(String, MainPagePatternInfo) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
メインページパターン情報をデータストアに作成した直後にコールされます。
postCreateRole(String, Role) - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener のメソッド
ロール情報をデータストアに作成した直後にコールされます。
postCreateSubRole(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener のメソッド
ロールにサブロールを追加した直後にコールされます。
postCreateSubRole(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener のメソッド
ロールにサブロールを追加する直前にコールされます。
postDelete(String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerPostWriterListener のメソッド
アクセスコントローラ情報をデータストアから削除した直後にコールされます。
postDelete(String, String) - interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener のメソッド
バッチ情報をデータストアから削除した直後にコールされます。
postDelete(String) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener のメソッド
グループ管理者情報をデータストアから削除した直後にコールされます。
postDelete(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
メニュー情報をデータストアから削除した直後にコールされます。
postDelete(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener のメソッド
メニュー情報をデータストアから削除した直後にコールされます。
postDeleteAccount(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウント情報をデータストアから削除した直後にコールされます。
postDeleteAccount(String, String) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

postDeleteAccountRole(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウントロール情報をデータストアから削除した直後にコールされます。
postDeleteAccountRole(String, String, String) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

postDeleteCalendarInfo(String, String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener のメソッド
カレンダーデータをデータストアから削除した直後にコールされます。
postDeleteFavoriteMenu(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
マイメニュー情報をデータストアから削除した直後にコールされます。
postDeleteFavoriteMenu(String, String, String) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

postDeleteLoginGroup(String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
ログイングループ情報をデータストアから削除した直後にコールされます。
postDeleteLoginGroup(String) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
ログイングループ情報をデータストアから削除した直後にコールされます。
postDeleteMainPagePattern(String, String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
メインページパターン情報をデータストアから削除した直後にコールされます。
postDeleteMainPagePattern(String, String) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
メインページパターン情報をデータストアから削除した直後にコールされます。
postDeleteMenuLoginGroup(String, String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
アクセスを許可するログイングループを削除する直後にコールされます。
postDeleteRole(String, String) - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener のメソッド
ロール情報をデータストアから削除した直後にコールされます。
postDeleteSubRole(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener のメソッド
ロールからサブロールを削除した直後にコールされます。
postDeleteSubRole(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener のメソッド
ロールからサブロールを削除する直前にコールされます。
postDeleted(String, CompanyPost) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
役職情報がデータストアから削除された後に呼び出されます。
postDeleted(String, CompanyPost) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
役職情報がデータストアから削除された後に呼び出されます。
postDeleted(String, CompanyPost) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
役職情報がデータストアから削除された後に呼び出されます。
postMove(String, String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
メニューの親子関係を更新した直後にコールされます。
postMove(String, String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener のメソッド
メニューの親子関係を更新した直後にコールされます。
postSetAccessControlEnabled(String, boolean) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
アクセス権限を設定する直前にコールされます。
postUpdate(String, AccessController) - interface jp.co.intra_mart.foundation.security.access.AccessControllerPostWriterListener のメソッド
アクセスコントローラ情報をデータストアに更新した直後にコールされます。
postUpdate(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener のメソッド
システム管理者情報をデータストアに更新した直後にコールされます。
postUpdate(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener のメソッド
バッチ情報をデータストアに更新した直後にコールされます。
postUpdate(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener のメソッド
グループ管理者情報をデータストアに更新した直後にコールされます。
postUpdate(MenuItem) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
メニュー情報をデータストアに更新した直後にコールされます。
postUpdate(String, MenuItem) - interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener のメソッド
メニュー情報をデータストアに更新した直後にコールされます。
postUpdateAccount(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウント情報をデータストアに更新した直後にコールされます。
postUpdateAccount(String, Account) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

postUpdateAccountRole(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウントロール情報をデータストアに更新した直後にコールされます。
postUpdateAccountRole(String, String, AccountRole) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

postUpdateCalendarInfo(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener のメソッド
カレンダーデータをデータストアに更新した直後にコールされます。
postUpdateFavoriteMenu(String, String, FavoriteMenu) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
マイメニュー情報をデータストアに更新した直後にコールされます。
postUpdateFavoriteMenu(String, String, FavoriteMenu) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

postUpdateLoginGroup(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
ログイングループ情報をデータストアに更新した直後にコールされます。
postUpdateLoginGroup(LoginGroup) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
ログイングループ情報をデータストアに更新した直後にコールされます。
postUpdateMainPagePattern(String, MainPagePatternInfo) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
メインページパターン情報をデータストアに更新した直後にコールされます。
postUpdateMainPagePattern(String, MainPagePatternInfo) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
メインページパターン情報をデータストアに更新した直後にコールされます。
postUpdateRole(String, Role) - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener のメソッド
ロール情報をデータストアに更新した直後にコールされます。
postUpdated(String, CompanyPost) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
役職情報がデータストアに更新された後に呼び出されます。
postUpdated(String, CompanyPost) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
役職情報がデータストアに更新された後に呼び出されます。
postUpdated(String, CompanyPost) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
役職情報がデータストアに更新された後に呼び出されます。
prepareCall(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースのストアドプロシージャを呼び出すための CallableStatement オブジェクトを生成します。
prepareCall(String, int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定されたタイプと並行処理で ResultSet オブジェクトを生成する CallableStatement オブジェクトを生成します。
prepareCall(String, int, int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された型と並行処理で ResultSet オブジェクトを生成する CallableStatement オブジェクトを生成します。
prepareMimeMessage(MimeMessage) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
MIMEメッセージに対して操作を行います。
prepareSession(Session) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
SMTPセッションに対して操作を行います。
prepareStatement(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 パラメータ付き SQL 文をデータベースに送るための PreparedStatement オブジェクトを作成します。
prepareStatement(String, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 自動生成キーを取得する機能を持つデフォルトの PreparedStatement オブジェクトを生成します。
prepareStatement(String, int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定されたタイプと並行処理で ResultSet オブジェクトを生成する PreparedStatementオブジェクトを生成します。
prepareStatement(String, int, int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された型、並行処理、および保持機能で ResultSet オブジェクトを生成する PreparedStatement オブジェクトを生成します。
prepareStatement(String, int[]) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された配列によって指定された自動生成キーを返す機能を持つデフォルトの PreparedStatement オブジェクトを生成します。
prepareStatement(String, String[]) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された配列によって指定された自動生成キーを返す機能を持つデフォルトの PreparedStatement オブジェクトを生成します。
privateGroupAdded(String, PrivateGroup) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
プライベートグループがデータストアに登録された後に呼び出されます。
privateGroupDeleted(String, PrivateGroup) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
プライベートグループがデータストアから削除された後に呼び出されます。
privateGroupUpdated(String, PrivateGroup) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
プライベートグループがデータストアに更新された後に呼び出されます。
propertyNames() - interface jp.co.intra_mart.foundation.service.provider.Environment のメソッド
システムプロパティリストにあるすべてのキーのリストを返します。
publicGroupAdded(String, PublicGroup) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループがデータストアに登録された後に呼び出されます。
publicGroupAdded(String, PublicGroup) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
パブリックグループがデータストアに登録された後に呼び出されます。
publicGroupAdded(String, PublicGroup) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループがデータストアに登録された後に呼び出されます。
publicGroupDeleted(String, PublicGroup) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループがデータストアから削除された後に呼び出されます。
publicGroupDeleted(String, PublicGroup) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
パブリックグループがデータストアから削除された後に呼び出されます。
publicGroupDeleted(String, PublicGroup) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループがデータストアから削除された後に呼び出されます。
publicGroupJoined(String, String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
publicGroupJoined(String, String, String, String, String) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
publicGroupJoined(String, String, String, String, String) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
publicGroupLeft(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
publicGroupLeft(String, String, String, String) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
publicGroupLeft(String, String, String, String) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
publicGroupMoved(String, String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
publicGroupMoved(String, String, String, String, String) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
publicGroupMoved(String, String, String, String, String) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
publicGroupUpdated(String, PublicGroup) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループがデータストアに更新された後に呼び出されます。
publicGroupUpdated(String, PublicGroup) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
パブリックグループがデータストアに更新された後に呼び出されます。
publicGroupUpdated(String, PublicGroup) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループがデータストアに更新された後に呼び出されます。
put(String, Object) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
データを保存します。
put(String, Object) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
データを保存します。
put(String, Object) - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
データを保存します。
put(String, Object) - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
データを保存します。
put(Object, Object) - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 指定された値を、マップ内の指定されたキーに関連付けます 。
putAll(Map) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
データを保存します。
putAll(Map) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
データを保存します。
putAll(Map) - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
データを保存します。
putAll(Map) - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
データを保存します。
putCompanyCategoryTerminable(Term, CompanyCategoryTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
指定された期間に対する期間化情報を設定します。
putCompanyPostTerminable(Term, CompanyPostTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
指定された期間に対する期間化情報を設定します。
putCompanyPostTerminableInternational(Locale, CompanyPostTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。
putCompanyTerminable(Term, CompanyTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
指定された期間に対する期間化情報を設定します。
putCompanyTerminableInternational(Locale, CompanyTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。
putDealTerminable(Term, DealTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
指定された期間に対する期間化情報を設定します。
putDepartmentAttachTerminable(Term, DepartmentAttachTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
指定された期間に対する期間化情報を設定します。
putDepartmentMainTerminable(Term, DepartmentMainTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
指定された期間に対する期間化情報を設定します。
putDepartmentTerminable(Term, DepartmentTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
指定された期間に対する期間化情報を設定します。
putDepartmentTerminableInternational(Locale, DepartmentTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。
putExtendedDepartment(String, Map) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
指定された拡張情報を追加します。
putExtendedDepartmentTerminable(String, Map) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
指定された拡張情報を追加します。
putExtendedDepartmentTerminableInternational(String, Map) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
指定された拡張情報を追加します。
putExtendedUser(String, Map) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
指定された拡張情報を追加します。
putExtendedUserTerminable(String, Map) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
指定された拡張情報を追加します。
putExtendedUserTerminableInternational(String, Map) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
指定された拡張情報を追加します。
putImage(OutputStream) - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
指定のストリームにファイルを出力します。
putInternational(Locale, CateogryClassInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
指定された言語に対する国際化情報を設定します。
putInternational(Locale, CategoryDetailInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
指定された言語に対する国際化情報を設定します。
putInternational(Locale, ItemAttributeInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
指定された言語に対する国際化情報を設定します。
putInternational(Locale, ItemCategoryInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
指定された言語に対する国際化情報を設定します。
putInternational(Locale, ItemTemplateDetailInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
指定された言語に対する国際化情報を設定します。
putItemTerminable(Term, ItemTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
指定された期間に対する期間化情報を設定します。
putItemTerminableInternational(Locale, ItemTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。
putPublicGroupAttachTerminable(Term, PublicGroupAttachTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
指定された期間に対する期間化情報を設定します。
putPublicGroupCategoryTerminable(Term, PublicGroupCategoryTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
指定された期間に対する期間化情報を設定します。
putPublicGroupSetTerminable(Term, PublicGroupSetTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
指定された期間に対する期間化情報を設定します。
putPublicGroupSetTerminableInternational(Locale, PublicGroupSetTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。
putPublicGroupTerminable(Term, PublicGroupTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
指定された期間に対する期間化情報を設定します。
putPublicGroupTerminableInternational(Locale, PublicGroupTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。
putUserTerminable(Term, UserTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
指定された期間に対する期間化情報を設定します。
putUserTerminableInternational(Locale, UserTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。

Q

queryAddMenuLoginGroup(String, String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
アクセスを許可するログイングループを追加する直前にコールされます。
queryCreate(String, AccessController) - interface jp.co.intra_mart.foundation.security.access.AccessControllerQueryWriterListener のメソッド
アクセスコントローラ情報をデータストアに作成する直前にコールされます。
queryCreate(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener のメソッド
システム管理者情報をデータストアに作成する直前にコールされます。
queryCreate(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener のメソッド
バッチ情報をデータストアに作成する直前にコールされます。
queryCreate(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener のメソッド
グループ管理者情報をデータストアに作成する直前にコールされます。
queryCreate(MenuItem) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
メニュー情報をデータストアに作成する直前にコールされます。
queryCreate(String, MenuItem) - interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener のメソッド
メニュー情報をデータストアに作成する直前にコールされます。
queryCreateAccount(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウント情報をデータストアに作成する直前にコールされます。
queryCreateAccount(String, Account) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

queryCreateAccountRole(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウントロール情報をデータストアに作成した直後にコールされます。
queryCreateAccountRole(String, String, AccountRole) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

queryCreateCalendarInfo(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener のメソッド
カレンダーデータをデータストアに作成する直前にコールされます。
queryCreateFavoriteMenu(String, String, FavoriteMenu) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
マイメニュー情報をデータストアに作成する直前にコールされます。
queryCreateFavoriteMenu(String, String, FavoriteMenu) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

queryCreateLoginGroup(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
ログイングループ情報をデータストアに作成する直前にコールされます。
queryCreateMainPagePattern(String, MainPagePatternInfo) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
メインページパターン情報をデータストアに作成する前にコールされます。
queryCreateRole(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener のメソッド
ロール情報をデータストアに作成する直前にコールされます。
queryDelete(String, String) - interface jp.co.intra_mart.foundation.security.access.AccessControllerQueryWriterListener のメソッド
アクセスコントローラ情報をデータストアから削除する直前にコールされます。
queryDelete(String, String) - interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener のメソッド
バッチ情報をデータストアから削除する直前にコールされます。
queryDelete(String) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener のメソッド
グループ管理者情報をデータストアから削除する直前にコールされます。
queryDelete(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
メニュー情報をデータストアから削除する直前にコールされます。
queryDelete(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener のメソッド
メニュー情報をデータストアから削除する直前にコールされます。
queryDeleteAccount(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウント情報をデータストアから削除する直前にコールされます。
queryDeleteAccount(String, String) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

queryDeleteAccountRole(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウントロール情報をデータストアから削除する直前にコールされます。
queryDeleteAccountRole(String, String, String) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

queryDeleteCalendarInfo(String, String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener のメソッド
カレンダーデータをデータストアから削除する直前にコールされます。
queryDeleteFavoriteMenu(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
マイメニュー情報をデータストアから削除する直前にコールされます。
queryDeleteFavoriteMenu(String, String, String) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

queryDeleteLoginGroup(String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
ログイングループ情報をデータストアから削除する直前にコールされます。
queryDeleteMainPagePattern(String, String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
メインページパターン情報をデータストアから削除する前にコールされます。
queryDeleteMenuLoginGroup(String, String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
アクセスを許可するログイングループを削除する直前にコールされます。
queryDeleteRole(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener のメソッド
ロール情報をデータストアから削除する直前にコールされます。
queryMove(String, String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
メニューの親子関係を更新する直前にコールされます。
queryMove(String, String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener のメソッド
メニューの親子関係を更新する直前にコールされます。
querySetAccessControlEnabled(String, boolean) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
アクセス権限を設定する直前にコールされます。
queryUpdate(String, AccessController) - interface jp.co.intra_mart.foundation.security.access.AccessControllerQueryWriterListener のメソッド
アクセスコントローラ情報をデータストアに更新する直前にコールされます。
queryUpdate(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener のメソッド
システム管理者情報をデータストアに更新する直前にコールされます。
queryUpdate(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener のメソッド
バッチ情報をデータストアに更新する直前にコールされます。
queryUpdate(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener のメソッド
グループ管理者情報をデータストアに更新する直前にコールされます。
queryUpdate(MenuItem) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
メニュー情報をデータストアに更新する直前にコールされます。
queryUpdate(String, MenuItem) - interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener のメソッド
メニュー情報をデータストアに更新する直前にコールされます。
queryUpdateAccount(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウント情報をデータストアに更新する直前にコールされます。
queryUpdateAccount(String, Account) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

queryUpdateAccountRole(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウントロール情報をデータストアに更新する直前にコールされます。
queryUpdateAccountRole(String, String, AccountRole) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

queryUpdateCalendarInfo(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener のメソッド
カレンダーデータをデータストアに更新する直前にコールされます。
queryUpdateFavoriteMenu(String, String, FavoriteMenu) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
マイメニュー情報をデータストアに更新する直前にコールされます。
queryUpdateFavoriteMenu(String, String, FavoriteMenu) - class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin のメソッド

queryUpdateLoginGroup(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
ログイングループ情報をデータストアに更新する直前にコールされます。
queryUpdateMainPagePattern(String, MainPagePatternInfo) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
メインページパターン情報をデータストアに更新する前にコールされます。
queryUpdateRole(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener のメソッド
ロール情報をデータストアに更新する直前にコールされます。
queue() - class jp.co.intra_mart.foundation.utility.LockMonitor のメソッド
推奨されていません。 モニターを取得するための待ち行列に入っているスレッドの数です。

R

RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel の static 変数
最終更新日
RECORD_USER_CD - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel の static 変数
最終更新者
RECORD_USER_CD - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel の static 変数
最終更新者
RECORD_USER_CD - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel の static 変数
最終更新者
REMOVE - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

REMOVE_ENTIRETY - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

REMOVE_ITEM - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

REQUEST_HEADER_NAME_IM_AJAX_REQUEST - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static 変数
ImAjaxからの通信だということを判定可能にするためのリクエスト・ヘッダ名。
REQUEST_HEADER_NAME_IM_AJAX_USER_AGENT - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static 変数
ブラウザの種類を判定可能にするためのリクエスト・ヘッダ名。
REQUEST_PARAM_NAME_4_EASYLOGIN_ACCESS_KEY - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil の static 変数
かんたんログインのアクセスキー用リクエストパラメータ名。
RESPONSE_HEADER_NAME_IM_AJAX_ERROR_CODE - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static 変数
ImAjaxへエラーコードを通知するためのレスポンス・ヘッダ名。
RESPONSE_HEADER_NAME_IM_AJAX_ERROR_MESSAGE - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static 変数
ImAjaxへエラーメッセージを通知するためのレスポンス・ヘッダ名。
RESPONSE_HEADER_NAME_NEXT_PAGE_TITLE - interface jp.co.intra_mart.foundation.log.LogConstraint の static 変数
遷移先画面タイトルをレスポンスヘッダに登録するためのレスポンスヘッダ名。
ROLE - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
ロール
ROLE_ID - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel の static 変数
ロールID
ROLE_ID - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel の static 変数
ロールCD
ROLE_ID - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel の static 変数
メニューID
ROLE_ID - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel の static 変数
ロールCD
ROLE_ID - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel の static 変数
ロールID
ROLE_ID - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel の static 変数
ロールID
ROLE_INCLUSION - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
ロール内包
ROLE_SUMMARY - interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst の static 変数
ロールサマリ
ROOT_FOLDER - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

RP_CLIENT_TYPE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
クライアントタイプのデフォルトＵＲＬ引数名。
RP_ENCODING - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインエンコーディングのデフォルトＵＲＬ引数名。
RP_INITIAL_URL - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
初期ＵＲＬのデフォルトＵＲＬ引数名。
RP_LOCALE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインロケールのデフォルトＵＲＬ引数名。
RP_LOGIN_GROUP - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログイングループIDのデフォルトＵＲＬ引数名。
RP_LOGIN_TYPE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインタイプのデフォルトＵＲＬ引数名。
RP_PASSWORD - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
パスワードのデフォルトＵＲＬ引数名。
RP_SHORTCUT - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ショートカットＵＲＬパラメータのデフォルト値
RP_URL - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ダイレクトＵＲＬのデフォルトＵＲＬ引数名。
RP_URL_SIGN - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ダイレクトＵＲＬ署名のデフォルトＵＲＬ引数名。
RP_USER - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインユーザＩＤのデフォルトＵＲＬ引数名。
RSSParserIF - interface jp.co.intra_mart.foundation.portal.common.rss.RSSParserIF.
RSS解析用の共通インタフェース
RSSポートレットで、取得したRSSデータを処理するためのパーサーです。
RUN_DAY - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
実行日
RUN_DAY_WEEK - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
実行曜日
RUN_HOUR - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
実行時
RUN_MINUTE - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
実行分
RUN_MONTH - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
実行月
RUN_SECOND - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
実行秒
RUN_YEAR - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
実行年
RadarChartDrawer - class jp.co.intra_mart.foundation.graph.RadarChartDrawer.
レーダーチャートを描画します。
RadarChartDrawer(int, int, int) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のコンストラクタ
ｙ軸の目盛値をint表現でレーダーチャートを作成します。
RadarChartDrawer(double, double, double) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のコンストラクタ
ｙ軸の目盛値をdouble表現でレーダーチャートを作成します。
RadarChartObject - class jp.co.intra_mart.foundation.graph.RadarChartObject.
RadarChartDrawerクラスのデータを保存するオブジェクトです。
RadarChartObject() - class jp.co.intra_mart.foundation.graph.RadarChartObject のコンストラクタ
デフォルトのデータオブジェクトを作成します。
RadarChartObject(Color) - class jp.co.intra_mart.foundation.graph.RadarChartObject のコンストラクタ
グラフ線の色を指定して、データオブジェクトを作成します。
RadarChartObject(boolean) - class jp.co.intra_mart.foundation.graph.RadarChartObject のコンストラクタ
塗りつぶしの可否を指定して、データオブジェクトを作成します。
RadarChartObject(Color, boolean) - class jp.co.intra_mart.foundation.graph.RadarChartObject のコンストラクタ
グラフの色と塗りつぶしの可否を指定して、データオブジェクトを作成します。
Relationship - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship.
リレーションシップを定義します。
ReplaceWriter - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter クラスを使用してください。
ReplaceWriter(Writer, char[]) - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のコンストラクタ
推奨されていません。 文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer, String) - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のコンストラクタ
推奨されていません。 文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer, char[], char[]) - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のコンストラクタ
推奨されていません。 文字列置換のためのストリームフィルタを作成します。
ReplaceWriter(Writer, String, String) - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のコンストラクタ
推奨されていません。 文字列置換のためのストリームフィルタを作成します。
ReportFileConditioner - interface jp.co.intra_mart.foundation.utility.report.ReportFileConditioner.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner クラスを使用してください。
ReportFileWriter - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter クラスを使用してください。
ReportFileWriter(File) - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のコンストラクタ
推奨されていません。 ファイルへメッセージを書き出すためのライターオブジェクトを作成します。
ReportLevel - interface jp.co.intra_mart.foundation.utility.report.ReportLevel.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel クラスを使用してください。
ReportLevelFilter - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter クラスを使用してください。
ReportLevelFilter(MessageReporter, int) - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter のコンストラクタ
推奨されていません。 指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。
RepresentativeReporter - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter クラスを使用してください。
RepresentativeReporter(MessageReporter, EventQueueController) - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter のコンストラクタ
推奨されていません。 指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。
RequestAnalyzer - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer.
リクエストアナライザインタフェース。
RequestCharacterEncodingFilter - class jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter.
リクエストに対するエンコードは SessionInfo.getEncoding()が 返す値をになります。
RequestCharacterEncodingFilter() - class jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter のコンストラクタ

ResourceBundleProperties - class jp.co.intra_mart.foundation.utility.ResourceBundleProperties.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties クラスを使用してください。
ResourceBundleProperties(String) - class jp.co.intra_mart.foundation.utility.ResourceBundleProperties のコンストラクタ
推奨されていません。 リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String, Locale) - class jp.co.intra_mart.foundation.utility.ResourceBundleProperties のコンストラクタ
推奨されていません。 リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String, Locale, ClassLoader) - class jp.co.intra_mart.foundation.utility.ResourceBundleProperties のコンストラクタ
推奨されていません。 リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceFormatException - exception jp.co.intra_mart.foundation.utility.charset.ResourceFormatException.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException クラスを使用してください。
ResourceFormatException(String) - class jp.co.intra_mart.foundation.utility.charset.ResourceFormatException のコンストラクタ
推奨されていません。 指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceFormatException(String, Throwable) - class jp.co.intra_mart.foundation.utility.charset.ResourceFormatException のコンストラクタ
推奨されていません。 指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
ResourceNotFoundException - exception jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException クラスを使用してください。
ResourceNotFoundException(String) - class jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException のコンストラクタ
推奨されていません。 指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceNotFoundException(String, Throwable) - class jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException のコンストラクタ
推奨されていません。 指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
ResponseCharacterEncodingFilter - class jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter.
レスポンスの文字エンコーディングを自動解決するフィルタです。
ResponseCharacterEncodingFilter() - class jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter のコンストラクタ
新しくフィルタを作成します。
ResultPageItem - class jp.co.intra_mart.foundation.navigator.ResultPageItem.
結果ページクラス
ResultPageItem() - class jp.co.intra_mart.foundation.navigator.ResultPageItem のコンストラクタ

ResultPageItemInfo - class jp.co.intra_mart.foundation.navigator.ResultPageItemInfo.
結果ページ情報
ResultPageItemInfo() - class jp.co.intra_mart.foundation.navigator.ResultPageItemInfo のコンストラクタ

ReverseComparator - class jp.co.intra_mart.foundation.utility.ReverseComparator.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator クラスを使用してください。
ReverseComparator(Comparator) - class jp.co.intra_mart.foundation.utility.ReverseComparator のコンストラクタ
推奨されていません。 指定されたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
Role - class jp.co.intra_mart.foundation.security.role.Role.
ロール・モデルインタフェース。
Role() - class jp.co.intra_mart.foundation.security.role.Role のコンストラクタ
コンストラクタ。
Role(String) - class jp.co.intra_mart.foundation.security.role.Role のコンストラクタ
コンストラクタ。
Role(String, String) - class jp.co.intra_mart.foundation.security.role.Role のコンストラクタ
コンストラクタ。
RoleAccessor - interface jp.co.intra_mart.foundation.security.role.RoleAccessor.
ロールアクセッサインタフェース。
RoleBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel.
ロールの基本モデルです。
RoleChangedAccountListener - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener.
ロールが削除された場合にアカウントに紐付くロールを削除するリスナークラス。
RoleChangedAccountListener() - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のコンストラクタ
コンストラクタ。
RoleChangedControllerListener - class jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener.
ロールが削除された場合にアクセスコントローラに紐付くロールを削除するリスナークラスです。
RoleChangedControllerListener() - class jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener のコンストラクタ
コンストラクタ。
RoleChangedListener - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener.
ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
RoleChangedMenuListener - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener.
ロールが削除された場合にメニューに紐付くロールを削除するリスナークラス。
RoleChangedMenuListener() - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のコンストラクタ
コンストラクタ。
RoleExporter - interface jp.co.intra_mart.foundation.security.role.RoleExporter.
ロールエクスポートインタフェースです。
RoleImporter - interface jp.co.intra_mart.foundation.security.role.RoleImporter.
ロールインポートインタフェースです。
RoleInclusionBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel.
ロール内包の基本モデルです。
RoleInclusionMapper - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper.
ロール内包に関連するマッパです。
RoleInternationalModel - interface jp.co.intra_mart.system.security.datastore.inf.RoleInternationalModel.
ロールの国際化モデルです。
RoleManager - class jp.co.intra_mart.foundation.acssecurity.RoleManager.
推奨されていません。
RoleManager(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のコンストラクタ
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManagerに置き換えられました。
RoleManager - class jp.co.intra_mart.foundation.security.role.RoleManager.
ロールマネージャクラス。
RoleManager(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のコンストラクタ
コンストラクタ。
RoleMapper - interface jp.co.intra_mart.system.security.datastore.inf.RoleMapper.
ロールに関連するマッパです。
RolePostWriterListener - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener.
ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
RoleQueryWriterListener - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener.
ロール情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
RoleReaderDecorator - interface jp.co.intra_mart.foundation.security.role.RoleReaderDecorator.
ロール情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
RoleSummaryBaseModel - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel.
ロールサマリの基本モデルです。
RoleSummaryMapper - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper.
ロールサマリに関連するマッパです。
RssPortlet - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet.
ページ種別「RSS」に対するポートレットのモデルです。
RssPortlet() - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet のコンストラクタ
コンストラクタ
reGenerateNonce(String, String) - class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil の static メソッド
かんたんログイン用のNonceを新たに生成し、アカウント属性情報として保存します。
read() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ファイルの内容を取得します。
read() - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream のメソッド
推奨されていません。 デコードデータのバイトを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream のメソッド
推奨されていません。 入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
read() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 データ取得。
read(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 データ取得。
read() - class jp.co.intra_mart.foundation.utility.io.HexInputStream のメソッド
推奨されていません。 デコードデータのバイトを読み込みます。
read() - class jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream のメソッド
推奨されていません。 デコードデータのバイトを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream のメソッド
推奨されていません。 入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
read() - class jp.co.intra_mart.foundation.utility.io.XORInputStream のメソッド
推奨されていません。 デコードデータのバイトを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.XORInputStream のメソッド
推奨されていません。 入力ストリームからバイト配列へ最大 len バイトのデータを読み込みます。
readBoolean() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 boolean 型データ取得。
readInt() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 int 型データ取得。
readLines() - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 ファイルの行を繰り返し処理する反復子を作成します。
readLines(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 ファイルの行を繰り返し処理する反復子を作成します。
readLong() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 long 型データ取得。
readObject() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 Object の取得。
readString() - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
readString(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
readString() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 文字列の取得。
reconstruction() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 現在使用中の Writer をリセットします。
registEventFlow(EventNavigatorManager, EventFlow) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
registEventFlow(EventFlow) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
registEventFlow(EventNavigatorManager, EventFlow) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
イベントフローを更新します。
registerAccountLicense(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
ライセンス登録します。
registerApplicationLicenseToAccount(String, String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
アプリケーションライセンスをアカウントに登録します。
release() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースコネクションを解放します。
release() - class jp.co.intra_mart.foundation.utility.LockMonitor のメソッド
推奨されていません。 モニターの開放。
release() - class jp.co.intra_mart.foundation.utility.net.SocketConnection のメソッド
推奨されていません。 ソケットおよび入出力ストリームの利用を中止します。
releaseCurrentThread() - class jp.co.intra_mart.foundation.service.client.information.Lock の static メソッド
現在のスレッドに紐付いたロックを全て解除します。
releaseRequestScope() - class jp.co.intra_mart.foundation.service.client.information.Lock の static メソッド
推奨されていません。 このメソッドは、RequestScopeLockReleaseFilter 専用です。
releaseSavepoint(Savepoint) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 現在のトランザクションから指定された Savepoint オブジェクトを削除します。
remove(String, String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースにデータを削除するメソッド

データベースのデータを削除(デリート)する。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap のメソッド
拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap のメソッド
拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap のメソッド
拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap のメソッド
拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を削除します。
remove(Locale) - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap のメソッド
指定された言語に該当するデータを削除します。
remove(Term) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap のメソッド
指定された期間に該当するデータを削除します。
remove(Locale) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap のメソッド
指定された言語に該当するデータを削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap のメソッド
拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。
remove(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap のメソッド
拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。
remove(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap のメソッド
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。
remove(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap のメソッド
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。
remove(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap のメソッド
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap のメソッド
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap のメソッド
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap のメソッド
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。
remove(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
指定された言語に該当するデータを削除します。
remove(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
指定された言語に該当するデータを削除します。
remove(Term) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
指定された期間に該当するデータを削除します。
remove(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap のメソッド
指定された言語に該当するデータを削除します。
remove(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap のメソッド
指定された言語に該当するデータを削除します。
remove(Term) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap のメソッド
指定された期間に該当するデータを削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
指定された位置のデータを削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
指定された位置の値を削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
指定された位置のデータを削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
指定された位置のデータを削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
指定された位置の値を削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
指定された位置のデータを削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
指定された位置のデータを削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
指定された位置の値を削除します。
remove(int) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リスト内の指定された位置から要素を削除します。
remove(Object) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 指定された要素のインスタンスがこのコレクションにあれば、そのインスタンスをコレクションから 1 つ削除します。
remove() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルまたはディレクトリを削除します。
remove(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
データを削除します。
remove(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
データを削除します。
remove(String) - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
データを削除します。
remove(String) - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
データを削除します。
remove(String) - class jp.co.intra_mart.foundation.update.UpdateManager のメソッド
更新管理キーを削除します。
remove(Object) - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 このキーにマッピングがある場合に、そのマッピングをマップから削除します。
removeActiveSessionInfo(String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたセッションIDのアクティブなセッション情報を削除します。
removeActiveSessionInfo(String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたセッションIDのアクティブなセッション情報を削除します。
removeActiveSessionInfo(String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたセッションIDのアクティブなセッション情報を削除します。
removeAll(Collection) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 このコレクションから、指定されたコレクションに含まれる要素をすべて削除します。
removeAll() - class jp.co.intra_mart.foundation.update.UpdateManager のメソッド
すべての更新管理キーを削除します。
removeArgument(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
引数を削除します。
removeAttribute(ItemAttribute) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
指定された商品属性情報を削除します。
removeAttribute(String) - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
セッションから指定された属性を削除します。
removeCategoryDetail(CompanyCategory) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織に対して指定された分類区分情報を削除します。
removeCategoryDetail(PublicGroupCategory) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループに対して指定された分類区分情報を削除します。
removeChildNode(TreeNode) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
指定されたノード　node をこのノードの子から削除します。
removeChildNodes() - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
子ノードを全て削除します。
removeCompanyCategoryTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
指定された期間に対する期間化情報を削除します。
removeCompanyPostTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
指定された期間に対する期間化情報を削除します。
removeCompanyTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
指定された期間に対する期間化情報を削除します。
removeComparator(Comparator) - class jp.co.intra_mart.foundation.utility.MultiComparator のメソッド
推奨されていません。 指定されたコンパレータ comparatorを削除します。
removeConditioner(GCConditioner) - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
推奨されていません。
removeConditioner(ReportFileConditioner) - class jp.co.intra_mart.foundation.utility.report.FileReporter のメソッド
推奨されていません。 ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。
removeDealTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
指定された期間に対する期間化情報を削除します。
removeDepartmentAttachTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
指定された期間に対する期間化情報を削除します。
removeDepartmentMainTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
指定された期間に対する期間化情報を削除します。
removeDepartmentTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
指定された期間に対する期間化情報を削除します。
removeDetail(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable のメソッド
商品コードに一致する取扱詳細を削除します。
removeDisplayName(Locale) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
ロケールに対応した表示名を削除します。
removeDisplayName(Locale) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
ロケールに対応したメニュー名を削除します。
removeDisplayName(Locale) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロケールに対応したロール表示名を削除します。
removeFilterParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このフィルタのパラメータを削除します。
removeInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
指定された言語に対する国際化情報を削除します。
removeInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
指定された言語に対する国際化情報を削除します。
removeInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
指定された言語に対する国際化情報を削除します。
removeInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
指定された言語に対する国際化情報を削除します。
removeInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
指定された言語に対する国際化情報を削除します。
removeItem(ItemAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のメソッド
商品カテゴリから商品を外します。
removeItemTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
指定された期間に対する期間化情報を削除します。
removeListener(EventListener) - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
指定されたリスナーを削除します。
removeMain(DepartmentMain) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
指定されたユーザの主所属を削除します。
removeParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
指定のキーのマップを削除します。
removeParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
指定のキーのマップを削除します。
removeParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
指定のキーのマップを削除します。
removePermissionFromDepartment(DealerDepartment) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager のメソッド
組織からアクセス権を削除します。
removePermissionFromPublicGroup(DealerPublicGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager のメソッド
パブリックグループからアクセス権を削除します。
removePermissionFromRole(DealerRole) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager のメソッド
ロールからアクセス権を削除します。
removePublicGroupAttachTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
指定された期間に対する期間化情報を削除します。
removePublicGroupCategoryTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
指定された期間に対する期間化情報を削除します。
removePublicGroupSetTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
指定された期間に対する期間化情報を削除します。
removePublicGroupTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
指定された期間に対する期間化情報を削除します。
removeReporter(MessageReporter) - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。
removeSaveEventResultItemInfo(EventNavigatorManager, String, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。
removeSaveEventResultItemInfo(String, String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。
removeSaveEventResultItemInfo(EventNavigatorManager, String, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
保存ナビゲート結果情報削除 ユーザID、保存ナビゲート結果IDをキーとして保存ナビゲート結果情報をDBより削除。
removeTitleInfo(Locale) - class jp.co.intra_mart.foundation.navigator.NavigatorItem のメソッド

removeUrlParam(String) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のメソッド
ＵＲＬ引数(Map)を削除します。
removeUserTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
指定された期間に対する期間化情報を削除します。
report(String) - class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter のメソッド
推奨されていません。 メッセージを出力します。
report(Object) - class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter のメソッド
推奨されていません。 data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.FileReporter のメソッド
推奨されていません。 メッセージを出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter のメソッド
推奨されていません。 基礎出力ストリームに対してメッセージを出力します。
report(Object) - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter のメソッド
推奨されていません。 基礎出力ストリームに対してメッセージを出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.LineReportFilter のメソッド
推奨されていません。 メッセージを出力します。
report(Object) - class jp.co.intra_mart.foundation.utility.report.LineReportFilter のメソッド
推奨されていません。 基礎出力ストリームに対してメッセージを出力します。
report(String) - interface jp.co.intra_mart.foundation.utility.report.MessageReporter のメソッド
推奨されていません。 メッセージを出力します。
report(Object) - interface jp.co.intra_mart.foundation.utility.report.MessageReporter のメソッド
推奨されていません。 data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 メッセージを出力します。
report(Object) - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter のメソッド
推奨されていません。 メッセージを出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter のメソッド
推奨されていません。 メッセージを出力します。
report(String, int) - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter のメソッド
推奨されていません。 指定のメッセージレベルが基準値以上のメッセージを出力します。
report(Object) - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter のメソッド
推奨されていません。 data をメッセージとして出力します。
report(Object, int) - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter のメソッド
推奨されていません。 指定のメッセージレベルが基準値以上のメッセージを出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter のメソッド
推奨されていません。 メッセージを出力します。
report(Object) - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter のメソッド
推奨されていません。 data をメッセージとして出力します。
reportError(ErrorEvent) - interface jp.co.intra_mart.foundation.utility.ErrorEventListener のメソッド
推奨されていません。 発生した例外を通知します。
reset() - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 キャッシュ領域をクリアします。
reset(Writer) - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 文字の出力ストリームをリセットします。
resetLock() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
アカウントロックをリセットします。
restart() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
スケジューラの再開通知。
retainAll(Collection) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 このコレクションにおいて、指定されたコレクションに格納されている要素だけを保持します。
roleAdded(String, Role) - class jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener のメソッド
ロール情報をデータストアに作成した直後にコールされます。
roleAdded(String, Role) - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のメソッド
ロール情報をデータストアに作成した直後にコールされます。
roleAdded(String, Role) - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のメソッド
ロール情報をデータストアに作成した直後にコールされます。
roleAdded(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener のメソッド
ロール情報をデータストアに作成した直後にコールされます。
roleDeleted(String, String) - class jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener のメソッド
ロール情報をデータストアから削除した直後にコールされます。
roleDeleted(String, String) - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のメソッド
ロール情報をデータストアから削除した直後にコールされます。
roleDeleted(String, String) - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のメソッド
ロール情報をデータストアから削除した直後にコールされます。
roleDeleted(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener のメソッド
ロール情報をデータストアから削除した直後にコールされます。
roleUpdated(String, Role) - class jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener のメソッド
ロール情報をデータストアに更新した直後にコールされます。
roleUpdated(String, Role) - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のメソッド
ロール情報をデータストアに更新した直後にコールされます。
roleUpdated(String, Role) - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のメソッド
ロール情報をデータストアに更新した直後にコールされます。
roleUpdated(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener のメソッド
ロール情報をデータストアに更新した直後にコールされます。
rollback() - interface jp.co.intra_mart.foundation.database.DatabaseAccessor のメソッド
データベースのトランザクションをロールバックします。
rollback() - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
データベースのトランザクションをロールバックします。
rollback() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースアクセスの取り消し処理をする

トランザクションを終了(rollback)させる。
rollback(Savepoint) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された Savepoint オブジェクトが設定されたあとに行われたすべての変更を元に戻します。
run() - class jp.co.intra_mart.foundation.utility.ExtendedThread のメソッド
推奨されていません。 このオブジェクトのスレッド実行ロジックです。

S

SALES_UNIT_PRICE - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel の static 変数
販売単価
SAVE_TYPE_FAVORITE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
ナビゲート結果保存タイプ：お気に入り
SAVE_TYPE_HISTORY - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
ナビゲート結果保存タイプ：履歴
SCALE_POSITION_CENTER - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
ｘ軸、ｙ軸の目盛りの表示位置を「グラフの中心」に設定
SCALE_POSITION_SIDE - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
ｘ軸、ｙ軸の目盛りの表示位置を「グラフの枠」に設定
SESSION_TIMEOUT_HEADER_KEY - class jp.co.intra_mart.foundation.security.filter.SessionFilter の static 変数
セッションタイムアウトレスポンスヘッダーキー。
SET - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

SET_ENTIRETY - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

SET_ITEM - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

SKIP_LISTENER - interface jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener の static 変数
リスナー処理を中止し、メール送信を行います。
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ソートキー
SORT_NUMBER - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel の static 変数
ソート番号
SORT_NUMBER - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の static 変数
ソート番号
SP_CLIENT_TYPE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
クライアントタイプをセッションに保管するパラメータ名。
SP_COLOR_PATTERN_ID - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
カラーパターンIDをセッションに保管するパラメータ名。
SP_ENCODING - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインエンコーディングをセッションに保管するパラメータ名。
SP_INITIAL_URL - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
初期ページURLを属性に保管するパラメータ名。
SP_LOCALE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインロケールをセッションに保管するパラメータ名。
SP_LOGIN_GROUP - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログイングループIDをセッションに保管するパラメータ名。
SP_LOGIN_TIME - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインした時間をセッションに保管するパラメータ名。
SP_LOGIN_TYPE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインタイプをセッションに保管するパラメータ名。
SP_SHORTCUT - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ショートカットIDをセッションに保管するパラメータ名
SP_SIGNATURE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログイン署名をセッションに保管するパラメータ名。
SP_URL - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
認証後表示するメインページをセッションに保管するパラメータ名。
SP_URL_SIGN - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ダイレクトＵＲＬの署名をセッションに保管するパラメータ名。
SP_USER - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインユーザＩＤをセッションに保管するパラメータ名。
SQLSERVER - class jp.co.intra_mart.foundation.database.DbTypes の static 変数

SSORequestAnalyzer - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer.
SSOのログインリクエスト解析クラス。
SSORequestAnalyzer() - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer のコンストラクタ

SSO_LOGOUT_URL - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の static 変数

START_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
開始日
START_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
開始日
STOP_MAILSEND - interface jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener の static 変数
リスナー処理を中止し、メール送信を中止します。
STRING - class jp.co.intra_mart.foundation.datastore.common.config.AttributeType の static 変数
文字列型
STRING_VALUE - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel の static 変数
属性文字列
SUMMARY_ROLE_ID - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel の static 変数
サマリロールID
SaveEventHistoryInfo - class jp.co.intra_mart.foundation.navigator.SaveEventHistoryInfo.
保存イベント履歴情報クラス
SaveEventHistoryInfo() - class jp.co.intra_mart.foundation.navigator.SaveEventHistoryInfo のコンストラクタ

SaveEventResultItemInfo - class jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo.
保存ナビゲート結果情報
SaveEventResultItemInfo() - class jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo のコンストラクタ

Scheduler - class jp.co.intra_mart.foundation.service.client.batch.Scheduler.
Schedule Service の制御をするオブジェクトです。
Scheduler() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のコンストラクタ
新しいオブジェクトを構築します。
ScriptCompileException - exception jp.co.intra_mart.foundation.scenario.ScriptCompileException.
ScriptCompileException クラスは、スクリプトのコンパイル時にエラーが発生 場合にスローされる例外です。
ScriptCompileException(String) - class jp.co.intra_mart.foundation.scenario.ScriptCompileException のコンストラクタ
詳細メッセージを指定して ScriptCompileException を構築します。
ScriptCompileException(String, Throwable) - class jp.co.intra_mart.foundation.scenario.ScriptCompileException のコンストラクタ
詳細メッセージを指定して ScriptCompileException を構築します。
ScriptRuntimeException - exception jp.co.intra_mart.foundation.scenario.ScriptRuntimeException.
ScriptRuntimeException クラスは、スクリプトの実行時にエラーが発生 場合にスローされる例外です。
ScriptRuntimeException(String) - class jp.co.intra_mart.foundation.scenario.ScriptRuntimeException のコンストラクタ
詳細メッセージを指定して ScriptRuntimeException を構築します。
ScriptRuntimeException(String, Throwable) - class jp.co.intra_mart.foundation.scenario.ScriptRuntimeException のコンストラクタ
詳細メッセージを指定して ScriptRuntimeException を構築します。
ScriptValue - interface jp.co.intra_mart.foundation.scenario.ScriptValue.
スクリプトの値を保持するオブジェクトです。
SecurityConstraint - interface jp.co.intra_mart.foundation.security.SecurityConstraint.
アクセスセキュリティ定数インタフェース。
SelectItem - class jp.co.intra_mart.foundation.navigator.SelectItem.
選択アイテムクラス
SelectItem() - class jp.co.intra_mart.foundation.navigator.SelectItem のコンストラクタ

SelectItemInfo - class jp.co.intra_mart.foundation.navigator.SelectItemInfo.
選択アイテム情報
SelectItemInfo() - class jp.co.intra_mart.foundation.navigator.SelectItemInfo のコンストラクタ

SequenceComparator - class jp.co.intra_mart.foundation.utility.SequenceComparator.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator クラスを使用してください。
SequenceComparator() - class jp.co.intra_mart.foundation.utility.SequenceComparator のコンストラクタ
推奨されていません。 新しいオブジェクトを生成します。
ServerConnector - class jp.co.intra_mart.foundation.service.client.manager.ServerConnector.
このクラスは、Server-Manager にリクエストを送信して 処理を要求するためのオブジェクトです。
ServerConnector(SocketConnectionDistributor) - class jp.co.intra_mart.foundation.service.client.manager.ServerConnector のコンストラクタ
オブジェクトを作成します。
ServiceFrameworkHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler.
im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。
ServiceFrameworkHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のコンストラクタ
サービスフレームワークを実行するためのハンドラを作成します。
ServiceFrameworkHTTPActionEventHandler(String, String) - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のコンストラクタ
サービスフレームワークを実行するためのハンドラを作成します。
ServletHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler.
Web-Application を実行するためのイベントハンドラです。
ServletHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のコンストラクタ
Web-Application をイベント実行するためのハンドラを作成します。
ServletHTTPActionEventHandler(String) - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のコンストラクタ
指定のパスで表される Web-Application をイベント実行するためのハンドラを作成します。
SessionConfig - interface jp.co.intra_mart.foundation.security.SessionConfig.
セッションに関する設定情報を取得するインタフェース。
SessionFactory - class jp.co.intra_mart.foundation.service.client.information.SessionFactory.
共有データグループを管理するオブジェクトです。
SessionFactory(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
SessionFilter - class jp.co.intra_mart.foundation.security.filter.SessionFilter.
セッションフィルタ。
SessionFilter() - class jp.co.intra_mart.foundation.security.filter.SessionFilter のコンストラクタ

SessionInfo - interface jp.co.intra_mart.foundation.security.SessionInfo.
intra-martセッション情報参照インタフェース。
SessionMemory - class jp.co.intra_mart.foundation.service.client.information.SessionMemory.
共有データを管理するオブジェクトです。
SessionMemory(HttpSession) - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
SessionQuery - class jp.co.intra_mart.foundation.http.SessionQuery.
推奨されていません。 GenericURLBuilder および URLBuilder に置き替えられました。
SessionQuery(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.http.SessionQuery のコンストラクタ
推奨されていません。 GenericURLBuilder および URLBuilder に置き替えられました。
ShortCutAccessor - interface jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor.
ショートカットアクセッサインタフェース。
ShortCutInfo - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo.
ショートカット情報クラス。
ShortCutInfo() - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のコンストラクタ

ShortCutManager - class jp.co.intra_mart.foundation.security.shortcut.ShortCutManager.
ショートカットマネージャクラス

ServerManager/conf/short-cut-config.xmlからショートカット情報に関するパラメータを取得します。
ShortCutManager(String) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutManager のコンストラクタ

SocketConnection - class jp.co.intra_mart.foundation.utility.net.SocketConnection.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。
SocketConnection(String, int) - class jp.co.intra_mart.foundation.utility.net.SocketConnection のコンストラクタ
推奨されていません。 ソケット入出力インスタンスを構築します。
SocketConnection(Socket) - class jp.co.intra_mart.foundation.utility.net.SocketConnection のコンストラクタ
推奨されていません。 ソケット入出力インスタンスを構築します。
SocketConnection(ExtendedSocket) - class jp.co.intra_mart.foundation.utility.net.SocketConnection のコンストラクタ
推奨されていません。 ソケット入出力インスタンスを構築します。
SocketConnectionDistributor - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor クラスを使用してください。
SocketConnectionDistributorFactory - class jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory.
このクラスは、Server-Manager に接続するための ネットワークコネクション管理オブジェクトを作成するためのクラスです。
SocketConnectionDistributorFactory(String, int) - class jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory のコンストラクタ
オブジェクトを作成します。
SocketConnectionDistributorFactory(String, int, int) - class jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory のコンストラクタ
オブジェクトを作成します。
SocketConnectionManager - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionManager.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager クラスを使用してください。
SocketEventListener - interface jp.co.intra_mart.foundation.utility.net.SocketEventListener.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener クラスを使用してください。
SocketPool - class jp.co.intra_mart.foundation.utility.net.SocketPool.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketPool クラスを使用してください。
SocketPool(String, int) - class jp.co.intra_mart.foundation.utility.net.SocketPool のコンストラクタ
推奨されていません。 ソケットプールを構築します。
SocketPool(String, int, int) - class jp.co.intra_mart.foundation.utility.net.SocketPool のコンストラクタ
推奨されていません。 ソケットプールを構築します。
SourceProviderHandler - class jp.co.intra_mart.foundation.commons.SourceProviderHandler.

SourceProviderHandler() - class jp.co.intra_mart.foundation.commons.SourceProviderHandler のコンストラクタ
コンストラクタ。
StandardAccessControllerAccessor - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor.

StandardAccessControllerAccessor() - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のコンストラクタ

StandardAccessControllerBackup - class jp.co.intra_mart.foundation.security.access.StandardAccessControllerBackup.

StandardAccessControllerBackup() - class jp.co.intra_mart.foundation.security.access.StandardAccessControllerBackup のコンストラクタ

StandardAccountAccessor - class jp.co.intra_mart.foundation.security.StandardAccountAccessor.
アカウントアクセッサクラス。
StandardAccountAccessor() - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のコンストラクタ
コンストラクタ。
StandardAccountBackup - class jp.co.intra_mart.foundation.security.account.StandardAccountBackup.
アカウント情報をインポート・エクスポートするクラス。
StandardAccountBackup() - class jp.co.intra_mart.foundation.security.account.StandardAccountBackup のコンストラクタ

StandardActiveSessionAccessor - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor.
アクティブなセッション情報操作実装クラス。
StandardActiveSessionAccessor() - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のコンストラクタ

StandardAdminMenuBackup - class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup.
メニューバックアップクラスです。
StandardAdminMenuBackup() - class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup のコンストラクタ

StandardBatchAccessor - class jp.co.intra_mart.foundation.security.StandardBatchAccessor.
バッチアクセッサクラス。
StandardBatchAccessor() - class jp.co.intra_mart.foundation.security.StandardBatchAccessor のコンストラクタ
コンストラクタ。
StandardBatchBackup - class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup.
バッチバックアップクラスです。
StandardBatchBackup() - class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup のコンストラクタ

StandardCalendarAccessor - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor.
カレンダーアクセッサクラス。
StandardCalendarAccessor() - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor のコンストラクタ
コンストラクタ。
StandardCalendarBackup - class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup.
カレンダーバックアップクラスです。
StandardCalendarBackup() - class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup のコンストラクタ

StandardCompanyImporter - class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter.
会社のインポートを行います。
StandardCompanyImporter() - class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter のコンストラクタ

StandardCompanyPostImporter - class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter.
役職のインポートを行います。
StandardCompanyPostImporter() - class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter のコンストラクタ

StandardCryption - class jp.co.intra_mart.foundation.security.cryption.StandardCryption.
文字列の暗号化・復号化を行う標準の実装クラスです。
StandardCryption() - class jp.co.intra_mart.foundation.security.cryption.StandardCryption のコンストラクタ
コンストラクタ。
StandardDuplicateLoginAccessor - class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor.
重複ログイン操作インターフェース。
StandardDuplicateLoginAccessor() - class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor のコンストラクタ

StandardErrorPageProvider - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider.
標準のエラーページプロバイダクラス。
StandardErrorPageProvider() - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のコンストラクタ
デフォルトコンストラクタ

StandardEventNavigatorAccessor - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor.
イベントナビゲーター管理アクセッサクラス。
StandardEventNavigatorAccessor() - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のコンストラクタ
コンストラクタ

StandardEventNavigatorExporter - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter.

StandardEventNavigatorExporter() - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter のコンストラクタ

StandardEventNavigatorImporter - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter.
イベントナビゲーターのインポートクラス。
StandardEventNavigatorImporter() - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter のコンストラクタ

StandardGroupSuperUserPageProvider - class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider.
標準のログイングループ管理者用ページプロバイダクラス。
StandardGroupSuperUserPageProvider() - class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider のコンストラクタ
デフォルトコンストラクタ

StandardItemAttachImporter - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemAttachImporter.
商品分類のインポートを行います。
StandardItemAttachImporter() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemAttachImporter のコンストラクタ

StandardItemCategoryImporter - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemCategoryImporter.
商品カテゴリのインポートを行います。
StandardItemCategoryImporter() - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemCategoryImporter のコンストラクタ

StandardItemImporter - class jp.co.intra_mart.foundation.datastore.application.domain.item.StandardItemImporter.
商品のインポートを行います。
StandardItemImporter() - class jp.co.intra_mart.foundation.datastore.application.domain.item.StandardItemImporter のコンストラクタ

StandardItemTemplateImporter - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.StandardItemTemplateImporter.
商品テンプレートのインポートを行います。
StandardItemTemplateImporter() - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.StandardItemTemplateImporter のコンストラクタ

StandardMail - class jp.co.intra_mart.foundation.mail.javamail.StandardMail.
送信するメールの属性を保管します。
StandardMail() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のコンストラクタ
システムのロケールからメール属性オブジェクトを新規に作成します。
StandardMail(Locale) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のコンストラクタ
ロケールを指定してメール属性オブジェクトを新規に作成します。
StandardMenuAccessor - class jp.co.intra_mart.foundation.security.StandardMenuAccessor.
メニューアクセッサクラス。
StandardMenuAccessor() - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のコンストラクタ
コンストラクタ。
StandardMenuBackup - class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup.
メニューバックアップクラスです。
StandardMenuBackup() - class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup のコンストラクタ

StandardPasswordHistoryAccessor - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor.
パスワード履歴管理アクセッサクラス。
StandardPasswordHistoryAccessor() - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のコンストラクタ

StandardPortlet - class jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet.
標準ポートレットに対するモデルの抽象クラスです。
StandardPortlet() - class jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet のコンストラクタ

StandardPublicGroupImporter - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter.
パブリックグループのインポートを行います。
StandardPublicGroupImporter() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter のコンストラクタ

StandardRequestAnalyzer - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer.
標準のログインリクエスト解析クラス。
StandardRequestAnalyzer() - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のコンストラクタ
デフォルトコンストラクタ。
StandardRoleAccessor - class jp.co.intra_mart.foundation.security.StandardRoleAccessor.
ロールアクセッサクラス。
StandardRoleAccessor() - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のコンストラクタ
コンストラクタ

StandardRoleBackup - class jp.co.intra_mart.foundation.security.role.StandardRoleBackup.
ロールバックアップクラスです。
StandardRoleBackup() - class jp.co.intra_mart.foundation.security.role.StandardRoleBackup のコンストラクタ

StandardShortCutAccessor - class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor.
ショートカットアクセッサクラス。
StandardShortCutAccessor() - class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor のコンストラクタ

StandardSuperUserCertification - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification.
管理者ログイン認証の実装クラス。
StandardSuperUserCertification() - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification のコンストラクタ
デフォルトコンストラクタ

StandardSuperUserPageProvider - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider.
標準のシステム管理者用のユーザページプロバイダクラス。
StandardSuperUserPageProvider() - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider のコンストラクタ
デフォルトコンストラクタ

StandardUpdateAccessor - class jp.co.intra_mart.foundation.update.StandardUpdateAccessor.
情報更新管理アクセッサ標準実装クラス。
StandardUpdateAccessor() - class jp.co.intra_mart.foundation.update.StandardUpdateAccessor のコンストラクタ

StandardUserCertification - class jp.co.intra_mart.foundation.security.certification.StandardUserCertification.
ユーザログイン認証クラス。
StandardUserCertification() - class jp.co.intra_mart.foundation.security.certification.StandardUserCertification のコンストラクタ
デフォルトコンストラクタ。
StandardUserImporter - class jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter.
ユーザプロファイルのインポートを行います。
StandardUserImporter() - class jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter のコンストラクタ

StandardUserPageProvider - class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider.
標準のユーザページプロバイダクラス。
StandardUserPageProvider() - class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider のコンストラクタ
デフォルトコンストラクタ

StorageDirectory - class jp.co.intra_mart.foundation.service.provider.file.StorageDirectory.
Storage Service の基準ディレクトリを表すクラスです。
SuperCertification - interface jp.co.intra_mart.foundation.security.certification.SuperCertification.
管理者ログイン認証インタフェース。
SuperCertificationListener - interface jp.co.intra_mart.foundation.security.certification.SuperCertificationListener.
管理者ログイン認証リスナーインタフェース。
SuperUser - class jp.co.intra_mart.foundation.security.admin.SuperUser.
スーパーユーザ・モデルインタフェース。
SuperUser() - class jp.co.intra_mart.foundation.security.admin.SuperUser のコンストラクタ
コンストラクタ。
SuperUser(String) - class jp.co.intra_mart.foundation.security.admin.SuperUser のコンストラクタ
コンストラクタ。
SuperUserAccessor - interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor.
システム管理者アクセッサインタフェース。
SuperUserInitialServlet - class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet.
システム管理者初期アクセスサーブレット。
SuperUserInitialServlet() - class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet のコンストラクタ

SuperUserNoCertification - class jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification.
システム管理者ログイン時に強制認証を行う実装クラスです。
SuperUserNoCertification() - class jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification のコンストラクタ
デフォルトコンストラクタ

SuperUserPostWriterListener - interface jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener.
システム管理者情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
SuperUserQueryWriterListener - interface jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener.
システム管理者情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
SuperUserReaderDecorator - interface jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator.
システム管理者情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
SystemConfigException - exception jp.co.intra_mart.foundation.security.exception.SystemConfigException.
システム設定に関する例外クラス。
SystemConfigException() - class jp.co.intra_mart.foundation.security.exception.SystemConfigException のコンストラクタ
コンストラクタ。
SystemConfigException(String) - class jp.co.intra_mart.foundation.security.exception.SystemConfigException のコンストラクタ
コンストラクタ。
SystemConfigException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.SystemConfigException のコンストラクタ
コンストラクタ。
SystemConfigException(Throwable) - class jp.co.intra_mart.foundation.security.exception.SystemConfigException のコンストラクタ
コンストラクタ。
SystemErrorReporter - interface jp.co.intra_mart.foundation.service.provider.SystemErrorReporter.
エラーログ出力用のインターフェースです。
SystemManager - class jp.co.intra_mart.foundation.security.SystemManager.
システムマネージャクラス。
SystemReporter - interface jp.co.intra_mart.foundation.service.provider.SystemReporter.
システムログの共通インターフェースです。
SystemSourceProvider - interface jp.co.intra_mart.foundation.security.SystemSourceProvider.
ロケール情報取得インターフェース。
save(String, byte[]) - interface jp.co.intra_mart.foundation.datastore.application.domain.item.ItemCatalogueMediaManager のメソッド
商品カタログの媒体情報を保存します。
save(byte[]) - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ファイルにバイトを出力します。
searchAccounts(String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウント情報の読み込みます。
searchAccounts(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント情報の読み込みます。
searchAccounts(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
ユーザIDを検索してマッチしたアカウントを配列で返します。
searchActiveSessionInfosByUserId(String, String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたユーザ条件からアクティブなセッション情報を検索します。
searchActiveSessionInfosByUserId(String, String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたユーザ条件からアクティブなセッション情報を検索します。
searchActiveSessionInfosByUserId(String, String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたユーザ条件からアクティブなセッション情報を検索します。
searchRolesById(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロールID検索によりロールを取得します。
searchRolesByName(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール名称検索によりロールを取得します。
secureRedirect(HttpServletRequest, HttpServletResponse, String, Map) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。
secureRedirect(String, Map) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。
select(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 SELECT文を発行してデータベースからデータを取得する

select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
プライマリーキーで特定される分類区分の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
プライマリーキーで特定される分類区分詳細の基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
プライマリーキーで特定される組織所属の基本モデルを取得します。
select(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
プライマリーキーで特定される会社組織分類の基本モデルを取得します。
select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
プライマリーキーで特定される会社の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
プライマリーキーで特定される組織の基本モデルを取得します。
select(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
プライマリーキーで特定される組織内包の基本モデルを取得します。
select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
プライマリーキーで特定される主所属の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
プライマリーキーで特定される役職の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
プライマリーキーで特定される会社構成バージョンの基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper のメソッド
プライマリーキーで特定される取扱の基本モデルを取得します。
select(String, String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper のメソッド
プライマリーキーで特定される組織毎取扱パーミッションの基本モデルを取得します。
select(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper のメソッド
プライマリーキーで特定される取扱詳細の基本モデルを取得します。
select(String, String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper のメソッド
プライマリーキーで特定されるパブリックグループ毎取扱パーミッションの基本モデルを取得します。
select(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper のメソッド
プライマリーキーで特定されるロール毎取扱パーミッションの基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper のメソッド
プライマリーキーで特定される商品属性の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper のメソッド
プライマリーキーで特定される商品カタログの基本モデルを取得します。
select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper のメソッド
プライマリーキーで特定される商品の基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper のメソッド
プライマリーキーで特定される商品分類の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper のメソッド
プライマリーキーで特定される商品カテゴリの基本モデルを取得します。
select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper のメソッド
プライマリーキーで特定される商品カテゴリ種別の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper のメソッド
プライマリーキーで特定される商品属性テンプレート明細の基本モデルを取得します。
select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper のメソッド
プライマリーキーで特定される商品属性テンプレートの基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライマリーキーで特定されるプライベートグループ所属の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライマリーキーで特定されるプライベートグループの基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
プライマリーキーで特定されるパブリックグループ所属の基本モデルを取得します。
select(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
プライマリーキーで特定されるパブリックグループ分類の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
プライマリーキーで特定されるパブリックグループの基本モデルを取得します。
select(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
プライマリーキーで特定されるパブリックグループ内包の基本モデルを取得します。
select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
プライマリーキーで特定されるパブリックグループセットの基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
プライマリーキーで特定されるパブリックグループ構成バージョンの基本モデルを取得します。
select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper のメソッド
プライマリーキーで特定される単位の基本モデルを取得します。
select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
プライマリーキーで特定されるユーザの基本モデルを取得します。
select(Map) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
プライマリーキーで特定される基本モデルを取得します。
select(Relationship, Map) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
外部キーで特定される基本モデルをすべて取得します。
select(Map) - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
プライマリーキーで特定される基本モデルを取得します。
select(String, String) - class jp.co.intra_mart.foundation.update.StandardUpdateAccessor のメソッド
更新日付を取得します。
select(String, String) - interface jp.co.intra_mart.foundation.update.UpdateAccessor のメソッド
更新日付を取得します。
select(String, String, String) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper のメソッド
プライマリーキーで特定されるアクセスコントローラの利用権限を保有する組織の基本モデルを取得します。
select(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper のメソッド
プライマリーキーで特定されるアクセスコントローラ情報の基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper のメソッド
プライマリーキーで特定されるアクセスコントローラの利用権限を保有する役職の基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper のメソッド
プライマリーキーで特定されるアクセスコントローラの利用権限を保有するパブリックグループの基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper のメソッド
プライマリーキーで特定されるアクセスコントローラの利用権限を保有するロールの基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper のメソッド
プライマリーキーで特定されるアカウントが保有する属性の基本モデルを取得します。
select(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountMapper のメソッド
プライマリーキーで特定されるアカウントの基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper のメソッド
プライマリーキーで特定されるアカウントが保有するロールの基本モデルを取得します。
select(String) - interface jp.co.intra_mart.system.security.datastore.inf.BatchMapper のメソッド
プライマリーキーで特定されるバッチ情報の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper のメソッド
プライマリーキーで特定されるカレンダーが保有するデータの基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper のメソッド
プライマリーキーで特定されるアカウントが保有するメニューの基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper のメソッド
プライマリーキーで特定されるメニューの保有する引数の基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper のメソッド
プライマリーキーで特定されるメニューの利用権限を保有する組織の基本モデルを取得します。
select(String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuMapper のメソッド
プライマリーキーで特定されるメニュー情報の基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper のメソッド
プライマリーキーで特定されるメニューの利用権限を保有する役職の基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper のメソッド
プライマリーキーで特定されるメニューの利用権限を保有するパブリックグループの基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper のメソッド
プライマリーキーで特定されるメニューの利用権限を保有するロールの基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper のメソッド
プライマリーキーで特定されるロール内包の基本モデルを取得します。
select(String) - interface jp.co.intra_mart.system.security.datastore.inf.RoleMapper のメソッド
プライマリーキーで特定されるロールの基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper のメソッド
プライマリーキーで特定されるロールサマリの基本モデルを取得します。
selectCalendarInfoInternationalModel(Locale) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
指定された言語に該当するカレンダーが保有するデータの国際化モデルを取得します。
selectCategoryDetailInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
指定された言語に該当する分類区分詳細の国際化モデルを取得します。
selectCateogryClassInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
指定された言語に該当する分類区分の国際化モデルを取得します。
selectCompanyPostTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel のメソッド
指定された言語に該当する役職の期間国際化モデルを取得します。
selectCompanyPostTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
指定された日付に該当する役職の期間化モデルを取得します。
selectDealDetailTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
指定された日付に該当する取扱詳細の期間化モデルを取得します。
selectDealTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
指定された日付に該当する取扱の期間化モデルを取得します。
selectDepartmentAttachTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
指定された日付に該当する組織所属の期間化モデルを取得します。
selectDepartmentMainTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
指定された日付に該当する主所属の期間化モデルを取得します。
selectDepartmentTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
指定された言語に該当する組織の期間国際化モデルを取得します。
selectDepartmentTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
指定された日付に該当する組織の期間化モデルを取得します。
selectInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定された言語に該当する国際化モデルを取得します。
selectItemAttributeInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel のメソッド
指定された言語に該当する商品属性の国際化モデルを取得します。
selectItemCategoryInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
指定された言語に該当する商品カテゴリの国際化モデルを取得します。
selectItemTemplateDetailInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
指定された言語に該当する商品属性テンプレート明細の国際化モデルを取得します。
selectItemTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
指定された言語に該当する商品の期間国際化モデルを取得します。
selectItemTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
指定された日付に該当する商品の期間化モデルを取得します。
selectMenuInternationalModel(Locale) - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
指定された言語に該当するメニュー情報の国際化モデルを取得します。
selectPublicGroupTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
指定された言語に該当するパブリックグループの期間国際化モデルを取得します。
selectPublicGroupTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
指定された日付に該当するパブリックグループの期間化モデルを取得します。
selectRoleInternationalModel(Locale) - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
指定された言語に該当するロールの国際化モデルを取得します。
selectTerminableInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
指定された言語に該当する期間国際化モデルを取得します。
selectTerminableModel(Date) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定された日時に該当する期間化モデルを取得します。
selectUserTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
指定された言語に該当するユーザの期間国際化モデルを取得します。
selectUserTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
指定された日付に該当するユーザの期間化モデルを取得します。
send() - interface jp.co.intra_mart.foundation.mail.MailSender のメソッド
メールを送信します。
send() - class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender のメソッド
メールを送信します。
send() - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 指定されたSMTPサーバへメールを送信する。
serverTime() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
サーバのミリ秒で表される現在の時間を返します。
set(String, Number) - class jp.co.intra_mart.foundation.acssecurity.Logingp のメソッド
推奨されていません。 代替えメソッドはありません。
set(String, String) - class jp.co.intra_mart.foundation.acssecurity.Logingp のメソッド
推奨されていません。 代替えメソッドはありません。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel のメソッド
指定の属性に値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel のメソッド
指定の属性に値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel のメソッド
指定の属性に値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel のメソッド
指定の属性に値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性に値を設定します。
set(String, Object, Date) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性に、指定の日時で値を設定します。
set(String, Object, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性に、指定の言語で値を設定します。
set(String, Object, Date, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性に、指定の日時、言語で値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のメソッド
指定の属性に値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のメソッド
指定の属性に値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
指定の属性に値を設定します。
set(String, Object, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
指定の属性に値を設定します。
set(int, Object) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リストの指定された位置にある要素を、指定された要素で置き換えます。
setAccessControlEnabled(String, boolean) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
メニューアイテムに対するアクセス権を設定します。
setAccessControlEnabled(String, boolean) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニューアイテムに対するアクセス権を設定します。
setAccessControllerId(String) - class jp.co.intra_mart.foundation.security.access.AccessController のメソッド
コントローラＩＤを設定します。
setAccessControllerName(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel のメソッド
アクセスコントローラ名を設定します。
setAccessInfo(EventAccessInfo) - class jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem のメソッド

setAccount(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 AccountManager.importData(String category, InputStream inputStream)に置き換えられました。
setAccount(String) - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler のメソッド
アカウントＩＤを設定します。
setAccountFlag(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
このメソッドはシステム内で使用されます。
setAccountFlag(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
アカウントフラグを設定します。
setAddress(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
住所を設定します。
setAddress(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を設定します。
setAddress(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を設定します。
setAddress(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を設定します。
setAddress(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を設定します。
setAddress(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
住所を設定します。
setAddress(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
住所を設定します。
setAddress(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
住所を設定します。
setAddress1(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
住所1を設定します。
setAddress1(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
住所1を設定します。
setAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を設定します。
setAddress1(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を設定します。
setAddress1(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を設定します。
setAddress1(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を設定します。
setAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
住所1を設定します。
setAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所1を設定します。
setAddress1(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所1を設定します。
setAddress2(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
住所2を設定します。
setAddress2(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
住所2を設定します。
setAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を設定します。
setAddress2(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を設定します。
setAddress2(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を設定します。
setAddress2(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を設定します。
setAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
住所2を設定します。
setAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所2を設定します。
setAddress2(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所2を設定します。
setAll(TreeBranch) - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
指定された branch 内の表示名称、ポップアップ文字列、引数文字列をこのオブジェクトに設定します。
setAllowsUsers(String[]) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のメソッド
許可ユーザを設定します。
setAmount(int) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail のメソッド
数量を設定します。
setAmount(int) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
数量を設定します。
setAmount(int, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
数量を設定します。
setAmount(int) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailTerminableModel のメソッド
数量を設定します。
setAnswer(String) - class jp.co.intra_mart.foundation.navigator.EventHistoryInfo のメソッド
質問設定
setAnswer(String) - class jp.co.intra_mart.foundation.navigator.SaveEventHistoryInfo のメソッド
質問設定
setAppName(String) - class jp.co.intra_mart.foundation.security.activesession.NavigatorInfo のメソッド
ブラウザ名を取得します。
setApplication(String) - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
アプリケーション名を設定します。
setApplication(String) - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
実行するフレームワークのアプリケーションＩＤを設定します。
setApplicationId(String) - class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet のメソッド
アプリケーションIDを設定します。
setArgument(String) - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
引数文字列を設定します。
setArgument(String) - class jp.co.intra_mart.foundation.page.TreeLeaf のメソッド
マウスクリックイベント発生時に実行される任意の Client Side JavaScript 関数に渡される引数文字列を設定します。
setArgument(String) - class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet のメソッド
ページ引数を設定します。
setArgument(String) - class jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet のメソッド
ページ引数を設定します。
setArgument(String, String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
引数を設定します。
setArgumentValue(String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel のメソッド
引数値を設定します。
setAttemptOnFailedAuthentication(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
LDAP認証失敗(ユーザIDまたはパスワードが不正)時に次のプロバイダURLに認証の試みを設定する。
setAttribute(ItemAttribute) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
商品属性情報を設定します。
setAttribute(String, Object) - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
セッションから指定した属性に値を保管します。
setAttribute(String, String, String, String) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウント属性情報を設定する。
setAttribute(String, String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント属性情報を設定する。
setAttribute(String, String, String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウント属性情報を設定する。
setAttributeValue(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel のメソッド
属性値を設定します。
setAutoCommit(boolean) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。
setBaseAccessor(BaseAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
基本アクセサを設定します。
setBaseDn(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
ベースDNを設定する。
setBaseName(String) - class jp.co.intra_mart.foundation.datastore.exception.MapperException の static メソッド
リソースバンドルの基底名を設定します。
setBatchId(String) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチＩＤを設定します。
setBatchName(String) - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
バッチ名を設定します。
setBcc(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 Bccをセットする。
setBcc(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 Bccをセットする。
setBody(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 本文をセットする。
setCacheConfig(int) - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
キャッシュ時間を設定します。
setCapacity(int) - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 キューの容量を変更します。
setCaption(String[]) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
ｘ軸のキャプションを設定します。
setCaption(String) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
キャプション文字列を返します。
setCaption(String[]) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
ｘ軸のキャプションを設定します。
setCaption(String[]) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
ｘ軸のキャプションを設定します。
setCaptionColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
キャプションの文字色を設定します。
setCaptionColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
キャプションの文字色を設定します。
setCaptionColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
キャプションの文字色を設定します。
setCaptionColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
キャプションの文字色を設定します。
setCaptionMargin(int) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
キャプション表示位置のマージンを設定します。
setCaptionMargin(int) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
キャプション表示位置のマージンを設定します。
setCatalog(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection のデータベースに作業のためのサブスペースを選択するために、カタログ名を設定します。
setCatalogue(ItemCatalogue) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
商品カタログ情報を設定します。
setCatalogue(ItemCatalogue, byte[]) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
商品カタログ情報を設定します。
setCategory(String) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
新着情報のカテゴリ名を設定します。
setCategory(String) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロールカテゴリを設定します。
setCategory(String) - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
カテゴリを設定します。
setCategoryClassCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
分類区分コードを設定します。
setCategoryClassCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
分類区分コードを設定します。
setCategoryClassCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
分類区分コードを設定します。
setCategoryClassCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
分類区分コードを設定します。
setCategoryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
分類コードを設定します。
setCategoryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
分類コードを設定します。
setCategoryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
分類コードを設定します。
setCategoryDetail(CompanyCategory) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織に対して指定された分類区分情報を設定します。
setCategoryDetail(PublicGroupCategory) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループに対して指定された分類区分情報を設定します。
setCc(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 Ccをセットする。
setCc(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 Ccをセットする。
setCharacterEncoding(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
パラメータを符号化するためのエンコーディング名を指定します。
setCharacterEncoding(String) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 このオブジェクトが対象とする文字エンコーディングを設定します。
setClientType(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
クライアントタイプを設定する。
setClientType(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
クライアントタイプを設定します。
setClientType(String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
クライアントタイプを設定します。
setClosed() - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
このアクセサをクローズします。
setColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
棒の色を設定します。
setColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
線の色を設定します。
setColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
描画する点の色を設定します。
setColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
グラフ線の色を設定します。
setColor(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
色を設定します。
setColor(String) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
表示色を設定します。
setColorPatternId(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
カラーパターンIDを設定します。
setColorPatternId(String) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
カラーパターンIDを設定します。
setColorPatternId(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
ページカラーパターンを設定します。
setColumnName(String) - class jp.co.intra_mart.foundation.database.DatabaseColumn のメソッド

setColumnType(int) - class jp.co.intra_mart.foundation.database.DatabaseColumn のメソッド

setColumnsInfo(DatabaseColumn[]) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。
setComment(String) - class jp.co.intra_mart.foundation.navigator.TitleInfo のメソッド
コメント設定
setCommitCount(ImportManager, ImportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
インポート設定に定義されたインポートデータのコミット間隔をマネージャーに設定します。
setCommitCount(int) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManager のメソッド
コミット間隔を設定します。
setCommitCount(int) - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl のメソッド
コミット間隔を設定します。
setCommitCount(int) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager のメソッド

setCommitCount(int) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager のメソッド

setCommitCount(int) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager のメソッド

setCommitCount(int) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager のメソッド

setCommitCount(int) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager のメソッド

setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment のメソッド
会社コードを設定します。
setCompanyCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
会社コードを設定します。
setCompanyCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
会社コードを設定します。
setCompanyCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel のメソッド
会社コードを設定します。
setConfigPageCount(String, int) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
履歴表示件数の設定。
setConnectTimeout(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
接続タイムアウト時間を設定する。
setConnectTimeoutPropertyName(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
接続タイムアウトを設定するプロパティ名を設定する。
setContentType(String) - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルのフォーマットを設定します。
setContents(String) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
新着情報の内容を設定します。
setContents(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
コンテンツの種類を設定します。
setContents(String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
コンテンツの種類を設定します。
setContextFactory(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
コンテキストファクトリを設定する。
setCountLimit(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
最大検索数を設定する。
setCountryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
国コードを設定します。
setCountryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
国コードを設定します。
setCountryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
国コードを設定します。
setCountryCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
国コードを設定します。
setCountryCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
国コードを設定します。
setCountryCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
国コードを設定します。
setCountryCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
国コードを設定します。
setCountryCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
国コードを設定します。
setCountryCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
国コードを設定します。
setCurrencyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
通貨コードを設定します。
setCurrencyCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
通貨コードを設定します。
setCustomerCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
取引先会社コードを設定します。
setCustomerCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment のメソッド
取引先会社コードを設定します。
setCustomerCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup のメソッド
取引先会社コードを設定します。
setCustomerCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole のメソッド
取引先会社コードを設定します。
setCustomerDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
取引先組織コードを設定します。
setCustomerDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment のメソッド
取引先組織コードを設定します。
setCustomerDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup のメソッド
取引先組織コードを設定します。
setCustomerDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole のメソッド
取引先組織コードを設定します。
setData(Map) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.addAcount(Account) およびupdateAccount(Account)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.registerAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.domain.user.UserManagerを利用して、更新してください。

setData(Map, boolean) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。
setData(Map) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
setData(Map, boolean) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
setDataId(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
データIDを設定します。
setDataName(String) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
データ名称を設定します。
setDataSourceRefName(String) - interface jp.co.intra_mart.foundation.database.ConInfo のメソッド
DataSourceへの参照名を設定します。
setDataType(int) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
データ型を設定します。
setDataType(int) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
データ型を設定します。
setDataType(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
データタイプを設定します。
setDataType(String) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
データタイプを設定します。
setDatabaseAccessor(DatabaseAccessor) - class jp.co.intra_mart.foundation.database.DatabaseManager の static メソッド
データベースアクセッサを設定します。
setDate(ExportManager, ExportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
エクスポート設定に定義された日付をマネージャーに設定します。
setDate(Date) - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager のメソッド
日付を設定します。
setDate(Date) - class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl のメソッド
日付を設定します。
setDate(Date) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager のメソッド

setDate(Date) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager のメソッド

setDate(Date) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager のメソッド

setDate(Date) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager のメソッド

setDate(Date) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager のメソッド

setDate(ImportManager, ImportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
インポート設定に定義された日付をマネージャーに設定します。
setDate(Date) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManager のメソッド
日付を設定します。
setDate(Date) - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl のメソッド
日付を設定します。
setDate(Date) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager のメソッド

setDate(Date) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager のメソッド

setDate(Date) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager のメソッド

setDate(Date) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager のメソッド

setDate(Date) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager のメソッド

setDate(String) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
日付を設定します。
setDate(Date) - class jp.co.intra_mart.foundation.security.password.PasswordHistory のメソッド
日付を設定します。
setDay(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
日を設定します。
setDay(int) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
日を設定します。
setDayWeek(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
曜日を設定します。
setDayWeek(int) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
曜日を設定します。
setDealCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
取扱コードを設定します。
setDealCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment のメソッド
取扱コードを設定します。
setDealCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup のメソッド
取扱コードを設定します。
setDealCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole のメソッド
取扱コードを設定します。
setDealName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
取扱名を設定します。
setDealName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
取扱名を設定します。
setDealType(int) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
取扱種別を設定します。
setDealType(int) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
取扱種別を設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
デフォルトの日時を設定します。
setDefaultDate(Date) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
デフォルト日時を設定します。
setDefaultLocale(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
デフォルトのロケールを設定します。
setDefaultLocale(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
デフォルトのロケールを設定します。
setDefaultLocale(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
デフォルトのロケールを設定します。
setDefaultLocale(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
デフォルトのロケールを設定します。
setDefaultLocale(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
デフォルトのロケールを設定します。
setDefaultLocale(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
デフォルトのロケールを設定します。
setDefaultLocale(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
デフォルトのロケールを設定します。
setDefaultLocale(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
デフォルトのロケールを設定します。
setDefaultLocale(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
デフォルトのロケールを設定します。
setDefaultLocale(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
デフォルトのロケールを設定します。
setDefaultLocale(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
デフォルトのロケールを設定します。
setDefaultLocale(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
デフォルトのロケールを設定します。
setDefaultLocale(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
デフォルト言語を設定します。
setDefaultLocale(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
デフォルト言語を設定します。
setDepartment(int, DepartmentInfo) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

setDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
組織コードを設定します。
setDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
組織コードを設定します。
setDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織コードを設定します。
setDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable のメソッド
組織コードを設定します。
setDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment のメソッド
組織コードを設定します。
setDepartmentCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
組織コードを設定します。
setDepartmentCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
組織コードを設定します。
setDepartmentCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel のメソッド
組織コードを設定します。
setDepartments(DepartmentInfo[]) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

setDepth(int) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
階層レベルを設定します。
setDepth(int) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
階層レベルを設定します。
setDerefLinf(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
間接参照の有無を設定する。
setDescription(String) - class jp.co.intra_mart.foundation.security.access.AccessController のメソッド
説明を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
説明を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチ内容を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
データの説明を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
説明を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
説明を設定します。
setDetectionTimeOut(Integer) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 書き込みタイムアウト時間を設定します。
setDisplayName(String) - class jp.co.intra_mart.foundation.security.access.AccessController のメソッド
表示名を設定します。
setDisplayName(String) - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
マイメニュー表示名を設定する。
setDisplayName(Locale, String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
表示名を設定します。
setDisplayName(Locale, String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニュー名を設定します。
setDisplayName(Locale, String) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロール表示名を設定します。
setDisplayName(String) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
データ表示名を設定します。
setDisplayName(String, Locale) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
データ表示名を設定します。
setDisplayName(String) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoInternationalModel のメソッド
データ表示名を設定します。
setDisplayName(String) - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel のメソッド
メニュー表示名を設定します。
setDisplayName(String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
メニュー表示名を設定します。
setDisplayName(String, Locale) - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
メニュー表示名を設定します。
setDisplayName(String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuInternationalModel のメソッド
メニュー表示名を設定します。
setDisplayName(String) - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
ロール表示名を設定します。
setDisplayName(String, Locale) - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
ロール表示名を設定します。
setDisplayName(String) - interface jp.co.intra_mart.system.security.datastore.inf.RoleInternationalModel のメソッド
ロール表示名を設定します。
setDoneCertification(boolean) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
認証が終了しているかどうかを設定する。
setDuplicateSrc(boolean) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
イメージアイコンのURLの重複チェックの有効/無効を設定します。
setEmailAddress1(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
メールアドレス1を設定します。
setEmailAddress1(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
メールアドレス1を設定します。
setEmailAddress1(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
メールアドレス１を設定します。
setEmailAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス1を設定します。
setEmailAddress1(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス1を設定します。
setEmailAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
メールアドレス1を設定します。
setEmailAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス１を設定します。
setEmailAddress1(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス１を設定します。
setEmailAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
メールアドレス１を設定します。
setEmailAddress2(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
メールアドレス2を設定します。
setEmailAddress2(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
メールアドレス2を設定します。
setEmailAddress2(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
メールアドレス２を設定します。
setEmailAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス2を設定します。
setEmailAddress2(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス2を設定します。
setEmailAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
メールアドレス2を設定します。
setEmailAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス２を設定します。
setEmailAddress2(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス２を設定します。
setEmailAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
メールアドレス２を設定します。
setEncoding(ExportManager, ExportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
エクスポート設定に定義されたエクスポートデータのエンコーディング情報をマネージャーに設定します。
setEncoding(String) - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager のメソッド
エクスポートデータのエンコーディングを設定します。
setEncoding(String) - class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl のメソッド
エクスポートファイルのエンコーディングを設定します。
setEncoding(String) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager のメソッド

setEncoding(String) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager のメソッド

setEncoding(String) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager のメソッド

setEncoding(String) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager のメソッド

setEncoding(String) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager のメソッド

setEncoding(ImportManager, ImportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
インポート設定に定義されたインポートファイルのエンコーディング情報をマネージャーに設定します。
setEncoding(String) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManager のメソッド
インポートファイルのエンコーディングを設定します。
setEncoding(String) - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl のメソッド
インポートファイルのエンコーディングを設定します。
setEncoding(String) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager のメソッド

setEncoding(String) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager のメソッド

setEncoding(String) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager のメソッド

setEncoding(String) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager のメソッド

setEncoding(String) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager のメソッド

setEncoding(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
エンコーディング情報を設定します。
setEncoding(String) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
エンコーディングの設定。
setEncoding(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインエンコーディングを設定する。
setEncoding(String) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
エンコーディングを設定します。
setEncoding(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
エンコーディングを設定します。
setEndDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
終了日を設定します。
setEndDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
終了日を設定します。
setEndDate(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
終了日を設定します。
setEndDate(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
終了日を設定します。
setErrorResponseHeaders(String) - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static メソッド
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
setErrorResponseHeaders(String, String) - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static メソッド
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
setErrorResponseHeaders(String, String, String) - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static メソッド
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
setErrorResponseHeaders(String, String, String, String) - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static メソッド
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
setErrorResponseHeaders(String, String[]) - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static メソッド
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
setErrorResponseHeaders(HttpServletResponse, String) - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static メソッド
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
setErrorResponseHeaders(HttpServletResponse, String, String) - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static メソッド
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
setErrorResponseHeaders(HttpServletResponse, String, String, String) - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static メソッド
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
setErrorResponseHeaders(HttpServletResponse, String, String, String, String) - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static メソッド
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
setErrorResponseHeaders(HttpServletResponse, String, String[]) - class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil の static メソッド
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
setEventHistory(EventHistoryInfo[]) - class jp.co.intra_mart.foundation.navigator.EventItemInfo のメソッド
イベント履歴情報リスト設定
setEventHistory(EventHistoryInfo[]) - class jp.co.intra_mart.foundation.navigator.EventResultItemInfo のメソッド
イベント履歴情報リスト設定
setEventHistory(SaveEventHistoryInfo[]) - class jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo のメソッド
イベント履歴情報リスト設定
setExecuteUser(ExportManager, ExportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
エクスポート設定に定義された実行ユーザコードをマネージャーに設定します。
setExecuteUser(String) - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager のメソッド
実行ユーザコードを設定します。
setExecuteUser(String) - class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl のメソッド
実行ユーザを設定します。
setExecuteUser(String) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager のメソッド

setExecuteUser(String) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager のメソッド

setExecuteUser(String) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager のメソッド

setExecuteUser(String) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager のメソッド

setExecuteUser(String) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager のメソッド

setExecuteUser(ImportManager, ImportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
インポート設定に定義された実行ユーザをマネージャーに設定します。
setExecuteUser(String) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManager のメソッド
実行ユーザを設定します。
setExecuteUser(String) - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl のメソッド
実行ユーザを設定します。
setExecuteUser(String) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager のメソッド

setExecuteUser(String) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager のメソッド

setExecuteUser(String) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager のメソッド

setExecuteUser(String) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager のメソッド

setExecuteUser(String) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager のメソッド

setExpireInterval(int) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
最終応答時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を設定する。
setExplain(String) - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
説明を設定します。
setExportEncoding(String) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。
setExtendedBaseModelMap(ExtendedBaseModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
拡張基本モデルマップを設定します。
setExtendedInternationalModelMap(ExtendedInternationalModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext のメソッド
拡張国際化モデルマップを設定します。
setExtendedTerminableInternationalModelMap(ExtendedTerminableInternationalModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext のメソッド
拡張期間国際化モデルマップを設定します。
setExtendedTerminableModelMap(ExtendedTerminableModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
拡張期間化モデルマップを設定します。
setExtensionFaxNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
内線FAX番号を設定します。
setExtensionNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
内線番号を設定します。
setExtensionNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
内線番号を設定します。
setExtensionNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
内線番号を設定します。
setExtensionNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線番号を設定します。
setExtensionNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線番号を設定します。
setExtensionNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
内線番号を設定します。
setExtensionNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線番号を設定します。
setExtensionNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線番号を設定します。
setExtensionNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
内線番号を設定します。
setFaxNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
FAX番号を設定します。
setFaxNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
FAX番号を設定します。
setFaxNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
FAX番号を設定します。
setFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
FAX番号を設定します。
setFaxNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
FAX番号を設定します。
setFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
FAX番号を設定します。
setFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
FAX番号を設定します。
setFaxNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
FAX番号を設定します。
setFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
FAX番号を設定します。
setFieldNames(String[]) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。
setFill(boolean) - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
描画されるグラフの塗りつぶし可否を設定します。
setFilter(ExportManager, ExportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
エクスポート設定に定義されたフィルタの情報をマネージャーに設定します。
setFilter(Filter) - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager のメソッド
エクスポート対象を絞り込むためのフィルタを設定します。
setFilter(Filter) - class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl のメソッド
エクスポートフィルタを設定します。
setFilter(Filter) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager のメソッド

setFilter(Filter) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager のメソッド

setFilter(Filter) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager のメソッド

setFilter(Filter) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager のメソッド

setFilter(Filter) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager のメソッド

setFilterParameter(String, String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このフィルタのパラメータを設定します。
setFocus(String) - class jp.co.intra_mart.foundation.page.EventScript のメソッド
イベントとして監視する変数名を指定します。
setFontColor(Color) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
キャプションの文字色を設定します。
setFontSize(int) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
キャプションの文字サイズを設定します。
setFormat(String) - class jp.co.intra_mart.foundation.database.DatabaseColumn のメソッド

setFormat(ExportManager, ExportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
エクスポート設定に定義されたエクスポートデータのフォーマットをマネージャーに設定します。
setFormat(String) - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager のメソッド
エクスポートデータのフォーマットを設定します。
setFormat(String) - class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl のメソッド
エクスポートファイルのフォーマットを設定します。
setFormat(String) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager のメソッド

setFormat(String) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager のメソッド

setFormat(String) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager のメソッド

setFormat(String) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager のメソッド

setFormat(String) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager のメソッド

setFormat(ImportManager, ImportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
インポート設定に定義されたインポートファイルのフォーマットをマネージャーに設定します。
setFormat(String) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManager のメソッド
インポートファイルのフォーマットを設定します。
setFormat(String) - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl のメソッド
インポートファイルのフォーマットを設定します。
setFormat(String) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager のメソッド

setFormat(String) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager のメソッド

setFormat(String) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager のメソッド

setFormat(String) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager のメソッド

setFormat(String) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager のメソッド

setFrom(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Fromを設定します。
setFrom(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Fromを設定します。
setFrom(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 Fromをセットする。
setFrom(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 Fromをセットする。
setGoOut(boolean) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
外出状態を設定します。
setGoOut(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
外出フラグを設定します。
setGraphBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
グラフ領域の背景色を設定します。
setGraphBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
グラフ領域の背景色を設定します。
setGraphBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
グラフ領域の背景色を設定します。
setGraphBorderColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
グラフ領域のボーダーの色を設定します。
setGraphBorderColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
グラフ領域のボーダーの色を設定します。
setGraphBorderColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
グラフ領域のボーダーの色を設定します。
setGraphFrameColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
グラフ枠の線色を設定します。
setGroup(String) - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler のメソッド
グループＩＤを設定します。
setGroupId(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
ログイングループIDを設定する。
setHeader(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 メールヘッダを設定する。
setHeight(int) - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルの高さを設定します。
setHeight(int) - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
表示単位に対する高さを設定します。
setHoldability(int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection オブジェクトを使用して生成された ResultSet オブジェクトの保持機能を指定された保持機能へ変更します。
setHostnameVerifier(HostnameVerifier) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の HostnameVerifier を設定します。
setId(String) - class jp.co.intra_mart.foundation.navigator.EventFlow のメソッド

setId(String) - class jp.co.intra_mart.foundation.navigator.EventFlowInfo のメソッド
イベントフローID設定
setId(String) - class jp.co.intra_mart.foundation.navigator.EventHistoryInfo のメソッド
イベントアイテムID設定
setId(String) - class jp.co.intra_mart.foundation.navigator.EventItemInfo のメソッド
イベントアイテムID設定
setId(String) - class jp.co.intra_mart.foundation.navigator.EventResultItemInfo のメソッド
ナビゲート結果ID設定
setId(String) - class jp.co.intra_mart.foundation.navigator.ResultPageItemInfo のメソッド
保存結果ページID設定
setId(String) - class jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo のメソッド
保存ナビゲート結果ID設定
setId(String) - class jp.co.intra_mart.foundation.navigator.SelectItemInfo のメソッド
選択アイテムID設定
setId(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニューIDを設定します。
setImageBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
画像ファイルの背景色を設定します。
setImageBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
画像ファイルの背景色を設定します。
setImageBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
画像ファイルの背景色を設定します。
setImageBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
画像ファイルの背景色を設定します。
setImageBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
画像ファイルの背景色を設定します。
setImageBorderColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
画像ファイルのボーダ色を設定します。
setImageBorderColor(Color) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
画像ファイルのボーダ色を設定します。
setImageBorderColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
画像ファイルのボーダ色を設定します。
setImageBorderColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
画像ファイルのボーダ色を設定します。
setImageBorderColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
画像ファイルのボーダ色を設定します。
setImageIconCd(String) - class jp.co.intra_mart.foundation.image.ImageIconInfo のメソッド
イメージアイコンコードを設定する。
setImagePath(String) - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
マイメニューイメージパスを設定します。
setImagePath(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニューイメージパスを設定します。
setImagePath(String) - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel のメソッド
イメージパスを設定します。
setImagePath(String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
イメージパスを設定します。
setImgaeBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
推奨されていません。
setImgaeBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
推奨されていません。
setImgaeBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
推奨されていません。
setImgaeBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
推奨されていません。
setImgaeBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
推奨されていません。
setImgaeBorderColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
推奨されていません。
setImgaeBorderColor(Color) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
推奨されていません。
setImgaeBorderColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
推奨されていません。
setImgaeBorderColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
推奨されていません。
setImgaeBorderColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
推奨されていません。
setIndex(int) - class jp.co.intra_mart.foundation.database.DatabaseColumn のメソッド

setInitialUrl(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
初期アクセスURLを設定する。
setInitialize(String) - class jp.co.intra_mart.foundation.page.EventScript のメソッド
イベントの初期値を指定します。
setInternationalAccessor(InternationalAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext のメソッド
国際化アクセサを設定します。
setInternationalModelMap(InternationalModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
国際化モデルマップを設定します。
setInvalidateLoginType(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
無効化したユーザのログインタイプを設定する。
setInvalidateTime(long) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
無効化された時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を設定する。
setInvalidateUserId(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
無効化したユーザのログインユーザIDを設定する。
setIsAuth(boolean) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のメソッド
認証フラグを設定します。
setItem(ItemAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のメソッド
商品カテゴリに商品を設定します。
setItemCaption(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminableInternational のメソッド
商品通称を設定します。
setItemCaption(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品通称を設定します。
setItemCaption(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品通称を設定します。
setItemCaption(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品通称を設定します。
setItemCaption(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品通称を設定します。
setItemCaption(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableInternationalModel のメソッド
商品通称を設定します。
setItemCaption(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
商品通称を設定します。
setItemCaption(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
商品通称を設定します。
setItemCatalogueCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のメソッド
商品カタログコードを設定します。
setItemCatalogueMediaManager(ItemCatalogueMediaManager) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
商品カタログの媒体のマネジャーを設定します。
setItemCategoryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach のメソッド
商品カテゴリコードを設定します。
setItemCategoryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
商品カテゴリコードを設定します。
setItemCategoryName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategoryInternational のメソッド
商品カテゴリ名を設定します。
setItemCategoryName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
商品カテゴリ名を設定します。
setItemCategoryName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
商品カテゴリ名を設定します。
setItemCategoryName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryInternationalModel のメソッド
商品カテゴリ名を設定します。
setItemCategoryTypeCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach のメソッド
商品カテゴリ種別コードを設定します。
setItemCategoryTypeCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
商品カテゴリ種別コードを設定します。
setItemCategoryTypeCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.type.ItemCategoryType のメソッド
商品カテゴリ種別コードを設定します。
setItemCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail のメソッド
商品コードを設定します。
setItemCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
商品コードを設定します。
setItemCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のメソッド
商品コードを設定します。
setItemCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
商品コードを設定します。
setItemCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach のメソッド
商品コードを設定します。
setItemName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminableInternational のメソッド
商品名を設定します。
setItemName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品名を設定します。
setItemName(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品名を設定します。
setItemName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品名を設定します。
setItemName(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
商品名を設定します。
setItemName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableInternationalModel のメソッド
商品名を設定します。
setItemName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
商品名を設定します。
setItemName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
商品名を設定します。
setKey(String) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のメソッド
エラーメッセージを作成するためのキーを取得します。
setLastResponseTime(long) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
最終応答時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を設定する。
setLink(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
setLinkPageInfo(LinkPageInfo) - class jp.co.intra_mart.foundation.navigator.ResultPageItem のメソッド

setLoadBalancing(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
ロードバランサの有効・無効を設定する。
setLocale(Locale) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ロケールを設定します。
setLocale(Locale) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
ロケールの設定。
setLocale(Locale) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインロケールを設定する。
setLocale(Locale) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
ロケールを設定します。
setLocale(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
ロケールを設定します。
setLocation(String) - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のメソッド
遷移先のページパスを設定します。
setLockCount(int) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
アカウントをロックするログイン失敗回数を設定します。
setLockDate(Date) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
アカウントロック日付を設定します。
setLockDate(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
アカウントロック日付を設定します。
setLockTerm(int) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
アカウントをロックする期間を設定します。
setLoginFailureCount(int) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ログイン失敗回数を設定します。
setLoginFailureCount(int) - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
ログイン失敗回数を設定します。
setLoginGroup(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
ログイングループIDを設定する。
setLoginGroup(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログイングループIDを設定する。
setLoginGroupId(String) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
ログイングループIDを設定します。
setLoginTime(long) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
ログイン時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)を設定する。
setLoginType(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
ログインタイプを設定する。
setMail(StandardMail) - class jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent のメソッド
メールの属性を設定します。
setMailAddress(String) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
メールアドレス設定。
setMain(DepartmentMain) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
ユーザが主所属する組織を設定します。
setMainPagePatternId(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
メインページパターンIDを設定する。
setMainPagePatternImageUrl(String) - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo のメソッド
メインページパターンイメージURLを設定する。
setMainPagePatternUrl(String) - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo のメソッド
メインページパターンURLを設定する。
setMargin(int, int, int, int) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
グラフ領域のマージンを設定します。
setMargin(int, int, int, int) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
グラフ領域のマージンを設定します。
setMargin(int, int, int, int) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
グラフ領域のマージンを設定します。
setMargin(int, int, int, int) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
グラフ領域のマージンを設定します。
setMargin(int, int, int, int) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
グラフ領域のマージンを設定します。
setMaxLicense(double) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
ログイングループ内の最大登録可能ライセンス数を設定します。
setMedia(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のメソッド
媒体を設定します。
setMedia(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel のメソッド
媒体を設定します。
setMediaCls(int) - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のメソッド
媒体種類を設定します。
setMediaCls(int) - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel のメソッド
媒体種類を設定します。
setMember(DepartmentAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織に人員を割り当てます。
setMember(PrivateGroupAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
プライベートグループに人員を割り当てます。
setMember(PublicGroupAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループに人員を割り当てます。
setMenu(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 MenuManager.importData(String category, InputStream inputStream)に置き換えられました。
setMenuId(String) - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
メニューIDを設定します。
setMenuLinkSetCode(String) - class jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet のメソッド
メニューリンクセットコードを設定します。
setMenuType(String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
メニュータイプを設定します。
setMessage(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
setMobileEmailAddress(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
携帯用メールを設定します。
setMobileEmailAddress(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯用メールを設定します。
setMobileEmailAddress(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯用メールを設定します。
setMobileEmailAddress(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
携帯用メールを設定します。
setMobileNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
携帯電話番号を設定します。
setMobileNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯電話番号を設定します。
setMobileNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯電話番号を設定します。
setMobileNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
携帯電話番号を設定します。
setMobilePassword(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
モバイル用パスワードを設定します。
setMobilePassword(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
モバイル用パスワードを設定します。
setMonth(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
月を設定します。
setMonth(int) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
月を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational のメソッド
分類区分名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational のメソッド
分類名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
組織名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
組織名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational のメソッド
役職名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループ名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のメソッド
グループ名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のメソッド
グループ名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
ユーザ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
分類区分名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
分類区分名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel のメソッド
分類区分名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
分類名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
分類名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel のメソッド
分類名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を設定します。
setName(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を設定します。
setName(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
組織名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を設定します。
setName(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を設定します。
setName(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel のメソッド
役職名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel のメソッド
役職名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel のメソッド
役職名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を設定します。
setName(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を設定します。
setName(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel のメソッド
グループ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を設定します。
setName(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を設定します。
setName(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
ユーザ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名を設定します。
setName(ExportManager, ExportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
エクスポート設定に定義された処理名をマネージャーに設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager のメソッド
エクスポート処理名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl のメソッド
エクスポート処理名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager のメソッド

setName(String) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager のメソッド

setName(String) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager のメソッド

setName(String) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager のメソッド

setName(String) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager のメソッド

setName(ImportManager, ImportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
インポート設定に定義された処理名をマネージャーに設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManager のメソッド
インポート処理名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl のメソッド
インポート処理名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager のメソッド

setName(String) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager のメソッド

setName(String) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager のメソッド

setName(String) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager のメソッド

setName(String) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager のメソッド

setName(String) - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
項目の表示名称のを設定します。
setName(String) - class jp.co.intra_mart.foundation.page.TreeLeaf のメソッド
項目の表示名称を設定します。
setName(String) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチ名を設定します。
setName(String) - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
ロール名を設定します。
setNameEnglish(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
組織名英字を設定します。
setNameEnglish(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
組織名英字を設定します。
setNameEnglish(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループ名英字を設定します。
setNameEnglish(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のメソッド
グループ名英字を設定します。
setNameEnglish(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のメソッド
グループ名英字を設定します。
setNameEnglish(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
ユーザ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を設定します。
setNameEnglish(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を設定します。
setNameEnglish(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を設定します。
setNameEnglish(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
組織名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名英字を設定します。
setNameEnglish(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を設定します。
setNameEnglish(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を設定します。
setNameEnglish(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を設定します。
setNameEnglish(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel のメソッド
グループ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名英字を設定します。
setNameEnglish(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を設定します。
setNameEnglish(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を設定します。
setNameEnglish(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を設定します。
setNameEnglish(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
ユーザ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名英字を設定します。
setNameEnglish(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名英字を設定します。
setNameSyllabary(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
組織名カナを設定します。
setNameSyllabary(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
組織名カナを設定します。
setNameSyllabary(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを設定します。
setNameSyllabary(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを設定します。
setNameSyllabary(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを設定します。
setNameSyllabary(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
組織名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名カナを設定します。
setNameSyllabary(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名カナを設定します。
setNextEventItem(EventItem) - class jp.co.intra_mart.foundation.navigator.SelectItem のメソッド

setNextEventResultItem(EventResultItem) - class jp.co.intra_mart.foundation.navigator.SelectItem のメソッド

setNextItemId(String) - class jp.co.intra_mart.foundation.navigator.SelectItemInfo のメソッド
遷移先アイテムID設定
setNextType(String) - class jp.co.intra_mart.foundation.navigator.SelectItemInfo のメソッド
遷移先タイプ設定
setNote(String) - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
マウスポイント時に表示されるポップアップ文字列を設定します。
setNote(String) - class jp.co.intra_mart.foundation.page.TreeLeaf のメソッド
マウスポイント時に表示されるポップアップ文字列を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel のメソッド
説明を設定します。
setNotes(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
説明を設定します。
setNotes(String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
説明を設定します。
setNotes(String) - interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel のメソッド
備考を設定します。
setNullValue(String) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 データベースから取得されたデータがnullの場合の代替文字列を設定します。
setNumberValue(double) - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
属性数値を設定します。
setNumberValue(double) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel のメソッド
属性数値を設定します。
setOnChange(String) - class jp.co.intra_mart.foundation.page.EventScript のメソッド
監視している値に変更があった場合に実行するスクリプトを指定します。
setOpen(String) - class jp.co.intra_mart.foundation.navigator.EventFlow のメソッド

setOpen(String) - class jp.co.intra_mart.foundation.navigator.EventFlowInfo のメソッド
公開フラグ設定
setOrderSortNum(EventNavigatorManager, EventFlowInfo[]) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
setOrderSortNum(EventFlowInfo[]) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
setOrderSortNum(EventNavigatorManager, EventFlowInfo[]) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
表示順設定 イベントフロー情報配列の順番にソート番号を振りなおす。
setOwnerCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
所有者コードを設定します。
setOwnerCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
所有者コードを設定します。
setPageItem(ResultPageItem[]) - class jp.co.intra_mart.foundation.navigator.EventResultItem のメソッド

setPagePath(String) - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のメソッド
実行するスクリプト開発モデルのページパスを設定します。
setPagePatternId(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
メインページパターンを設定します。
setParamValue(String, String) - class jp.co.intra_mart.foundation.navigator.LinkPageInfo のメソッド

setParameter(String, Object) - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager のメソッド
パラメータを設定します。
setParameter(String, Object) - class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl のメソッド
パラメータを設定します。
setParameter(String, Object) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager のメソッド

setParameter(String, Object) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager のメソッド

setParameter(String, Object) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager のメソッド

setParameter(String, Object) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager のメソッド

setParameter(String, Object) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager のメソッド

setParameter(String, Object) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManager のメソッド
パラメータを設定します。
setParameter(String, Object) - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl のメソッド
パラメータを設定します。
setParameter(String, Object) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager のメソッド

setParameter(String, Object) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager のメソッド

setParameter(String, Object) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager のメソッド

setParameter(String, Object) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager のメソッド

setParameter(String, Object) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager のメソッド

setParameter(String, String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
イベントへのパラメータを設定します。
setParameter(String, String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
イベントへのパラメータを設定します。
setParameter(String, String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
イベントへのパラメータを設定します。
setParameters(ExportManager, ExportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
エクスポート設定に定義されたパラメータ情報をマネージャーに設定します。
setParameters(ImportManager, ImportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
エクスポート設定に定義されたパラメータ情報をマネージャーに設定します。
setParentItemCategoryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
親商品カテゴリコードを設定します。
setParentItemCategoryCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
親商品カテゴリコードを設定します。
setParentMenuId(String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
親メニューIDを設定します。
setParserKey(String) - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet のメソッド
RSS解析キーを設定します。
setPassword(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
パスワードを設定します。
setPassword(String) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
パスワード設定。
setPassword(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインパスワードを設定する。
setPassword(String) - class jp.co.intra_mart.foundation.security.password.PasswordHistory のメソッド
パスワードを設定します。
setPassword(String) - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler のメソッド
パスワードを設定します。
setPassword(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
パスワードを設定します。
setPermissionCheck(boolean) - class jp.co.intra_mart.foundation.navigator.EventFlowInfo のメソッド
パーミッションチェックフラグ設定
setPermissionCheck(boolean) - class jp.co.intra_mart.foundation.navigator.ResultPageItemInfo のメソッド
パーミッションチェックフラグ設定
setPermissionCheck(boolean) - class jp.co.intra_mart.foundation.navigator.SelectItemInfo のメソッド
パーミッションチェックフラグ設定
setPermissionToDepartment(DealerDepartment) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager のメソッド
組織に対してアクセス権を設定します。
setPermissionToPublicGroup(DealerPublicGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager のメソッド
パブリックグループに対してアクセス権を設定します。
setPermissionToRole(DealerRole) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager のメソッド
ロールに対してアクセス権を設定します。
setPlugin(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
プラグインIDを設定します。
setPluginMethod(String) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
プラグイン関数を設定します。
setPopup(boolean) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
リンクへ参照時にポップアップを呼び出すかどうかを設定します。
setPortlet(Portlet) - class jp.co.intra_mart.foundation.portal.portlet.PortletManager のメソッド
ポートレット情報を登録します。
setPortletCode(String) - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
ポートレットコードを設定します。
setPortletName(String) - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
ポートレット名を設定します。
setPost(int, PostInfo) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

setPostCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable のメソッド
役職CDを設定します。
setPostCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
役職コードを設定します。
setPostCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
役職CDを設定します。
setPostCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
役職CDを設定します。
setPostCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel のメソッド
役職CDを設定します。
setPosts(PostInfo[]) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

setPrivateGroupCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
グループコードを設定します。
setPrivateGroupCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループコードを設定します。
setProcessing(boolean) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
クライアントのアクセスに対して処理中がどうか設定する。
setProductModelCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item のメソッド
製品型番を設定します。
setProductModelCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
製品型番を設定します。
setProgramLanguage(String) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行プログラム言語の種類を設定します。
setProgramLanguage(String) - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行プログラム言語を設定します。
setProgramPath(String) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行プログラムパスを設定します。
setProgramPath(String) - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行プログラムパスを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor のメソッド
プロパティを設定します。
setProviderUrl(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
プロパイダーURLを設定する。
setProxyHost(String) - interface jp.co.intra_mart.foundation.portal.common.rss.RSSParserIF のメソッド
Proxyホスト名をセットします
setProxyHost(String) - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet のメソッド
プロキシホスト名を設定します。
setProxyPort(String) - interface jp.co.intra_mart.foundation.portal.common.rss.RSSParserIF のメソッド
Proxyポート番号をセットします
setProxyPort(int) - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet のメソッド
プロキシポート番号を設定します。
setPublicGroup(int, PublicGroupInfo) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

setPublicGroupCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup のメソッド
グループコードを設定します。
setPublicGroupCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
グループコードを設定します。
setPublicGroupCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
グループコードを設定します。
setPublicGroupCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループコードを設定します。
setPublicGroupSetCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup のメソッド
グループセットコードを設定します。
setPublicGroupSetCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
グループセットコードを設定します。
setPublicGroupSetCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
グループセットコードを設定します。
setPublicGroupSetCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループセットコードを設定します。
setPublicGroupSetCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループセットコードを設定します。
setPublicGroupSetCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
グループセットコードを設定します。
setPublicGroups(PublicGroupInfo[]) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

setPurchaseUnitPrice(double) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable のメソッド
仕入単価を設定します。
setPurchaseUnitPrice(double) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
仕入単価を設定します。
setPurchaseUnitPrice(double, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
仕入単価を設定します。
setPurchaseUnitPrice(double) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
仕入単価を設定します。
setQuestion(String) - class jp.co.intra_mart.foundation.navigator.EventHistoryInfo のメソッド
回答設定
setQuestion(String) - class jp.co.intra_mart.foundation.navigator.SaveEventHistoryInfo のメソッド
回答設定
setReadOnly(boolean) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection を読み込み専用モードに設定して、データベース最適化を実行するヒントとします。
setReceive(String) - class jp.co.intra_mart.foundation.page.EventScript のメソッド
イベントから値を受け取る変数名を指定します。
setRecordDate(Date) - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
レコード更新日を設定します。
setRecordUserCode(String) - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
レコード更新ユーザコードを設定します。
setRemoteAddr(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
リクエスト元のクライアントの IP(Internet Protocol) アドレスを設定する。
setReplyTo(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 リプライをセットする。
setReplyTo(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 リプライをセットする。
setResultPageItemInfos(ResultPageItemInfo[]) - class jp.co.intra_mart.foundation.navigator.EventResultItemInfo のメソッド
結果ページ情報リスト設定
setResultPageItemInfos(ResultPageItemInfo[]) - class jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo のメソッド
結果ページ情報リスト設定
setRetry(ImportManager, ImportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
インポート設定に定義されたリトライステータスをマネージャーに設定します。
setRetry(boolean) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManager のメソッド
インポート異常終了後の再実行時に、リトライ処理として実行するかどうかを設定します。
setRetry(boolean) - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl のメソッド
インポート異常終了後の再実行時に、リトライとして実行するかどうかを設定します。
setRetry(boolean) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager のメソッド

setRetry(boolean) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager のメソッド

setRetry(boolean) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager のメソッド

setRetry(boolean) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager のメソッド

setRetry(boolean) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager のメソッド

setReturningAttributes(String, String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
結果属性指定を設定する。
setReturningObj(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
結果としてオブジェクト許可を設定する。
setRole(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 RoleManager.importData(String category, InputStream inputStream)に置き換えられました。
setRole(int, Role) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

setRoleId(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole のメソッド
ロールIDを設定します。
setRoleId(String) - class jp.co.intra_mart.foundation.security.account.AccountRole のメソッド
ロールIDを設定します。
setRoleId(String) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロールIDを設定します。
setRoleName(String) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロール名を設定します。
setRoleValidEndDate(Date) - class jp.co.intra_mart.foundation.security.account.AccountRole のメソッド
ロール有効終了日を設定します。
setRoleValidStartDate(Date) - class jp.co.intra_mart.foundation.security.account.AccountRole のメソッド
ロール有効開始日を設定します。
setRoles(Role[]) - class jp.co.intra_mart.foundation.navigator.EventAccessInfo のメソッド

setRssUrl(String) - class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet のメソッド
URLを設定します。
setRunDay(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行日を設定します。
setRunDay(int) - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行日を設定します。
setRunDayWeek(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行曜日を設定します。
setRunDayWeek(int) - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行曜日を設定します。
setRunHour(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行時を設定します。
setRunHour(int) - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行時を設定します。
setRunMinute(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行分を設定します。
setRunMinute(int) - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行分を設定します。
setRunMonth(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行月を設定します。
setRunMonth(int) - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行月を設定します。
setRunSecond(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行秒を設定します。
setRunSecond(int) - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行秒を設定します。
setRunYear(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行年を設定します。
setRunYear(int) - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
実行年を設定します。
setSSLContext(SSLContext) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の SSLSocketFactory を生成する SSLContextを設定します。
setSalesUnitPrice(double) - class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable のメソッド
販売単価を設定します。
setSalesUnitPrice(double) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
販売単価を設定します。
setSalesUnitPrice(double, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel のメソッド
販売単価を設定します。
setSalesUnitPrice(double) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel のメソッド
販売単価を設定します。
setSaveDate(Date) - class jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo のメソッド
保存日時設定
setSavepoint() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 現在のトランザクションで名前のないセーブポイントを作成し、それを表す新しい Savepoint オブジェクトを返します。
setSavepoint(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 現在のトランザクションで指定された名前のセーブポイントを作成し、それを表す新しい Savepoint オブジェクトを返します。
setScalePosition(String) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｘ軸、ｙ軸の目盛りの表示位置を設定します。
setSchedule(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 BatchManager.importData(String category, InputStream inputStream)に置き換えられました。
setSelectItem(SelectItem[]) - class jp.co.intra_mart.foundation.navigator.EventItem のメソッド

setSelectItemInfos(SelectItemInfo[]) - class jp.co.intra_mart.foundation.navigator.EventItemInfo のメソッド
選択アイテム情報リスト設定
setSerchFilter(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
検索フィルタを設定する。
setSerchingDn(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
検索用ユーザDNを設定する。
setSerchingPw(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
検索用ユーザパスワードを設定する。
setService(String) - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
実行するフレームワークのサービスＩＤを設定します。
setServiceId(String) - class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet のメソッド
サービスIDを設定します。
setSession(Session) - class jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent のメソッド
メール送信のセッションを設定します。
setSessionId(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
セッションIDを設定する。
setSize(ExportManager, ExportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient のメソッド
エクスポート設定に定義されたエクスポート単位のデータ数をマネージャーに設定します。
setSize(int) - interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager のメソッド
エクスポート単位のデータ数を設定します。
setSize(int) - class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl のメソッド
エクスポート単位のデータ数を設定します。
setSize(int) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager のメソッド

setSize(int) - class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager のメソッド

setSize(int) - class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager のメソッド

setSize(int) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager のメソッド

setSize(int) - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager のメソッド

setSize(int) - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
描画する点のサイズを設定します。
setSleepInterval(int, int) - class jp.co.intra_mart.foundation.database.DatabaseExport のメソッド
推奨されていません。 指定された行数のレコードを書き出すごとに
スレッドを一定時間スリープさせます。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.image.ImageIconInfo のメソッド
ソートキーを設定する。
setSortNumber(int) - class jp.co.intra_mart.foundation.navigator.EventFlow のメソッド

setSortNumber(int) - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
ソート番号を設定します。
setSortNumber(int) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
ソート番号を設定します。
setSortNumber(int) - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel のメソッド
ソート番号を設定します。
setSortNumber(int) - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
ソート番号を設定します。
setSorucePovider(SystemSourceProvider) - class jp.co.intra_mart.foundation.security.SystemManager の static メソッド
ソースプロバイダを設定します。
setSourceProvider(DataSourceProvider) - class jp.co.intra_mart.foundation.database.DatabaseManager の static メソッド
ソースプロバイダを設定します。
setSrc(String) - class jp.co.intra_mart.foundation.image.ImageIconInfo のメソッド
イメージアイコンURLを設定する。
setStartDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
開始日を設定します。
setStartDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
開始日を設定します。
setStartDate(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
開始日を設定します。
setStartDate(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
開始日を設定します。
setStartEventId(String) - class jp.co.intra_mart.foundation.navigator.EventFlowInfo のメソッド
スタートイベントアイテムID設定
setStartEventItem(EventItem) - class jp.co.intra_mart.foundation.navigator.EventFlow のメソッド

setStringValue(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttributeInternational のメソッド
属性文字列を設定します。
setStringValue(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel のメソッド
属性文字列を設定します。
setStringValue(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel のメソッド
属性文字列を設定します。
setStringValue(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeInternationalModel のメソッド
属性文字列を設定します。
setStroke(Stroke) - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
描画される線の描画属性を設定します。
setSubject(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Subjectを設定します。
setSubject(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 タイトルをセットする。
setTelNo(String) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
電話番号設定。
setTelephoneNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
電話番号を設定します。
setTelephoneNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
電話番号を設定します。
setTelephoneNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
電話番号を設定します。
setTelephoneNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
電話番号を設定します。
setTelephoneNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
電話番号を設定します。
setTelephoneNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
電話番号を設定します。
setTelephoneNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
電話番号を設定します。
setTelephoneNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
電話番号を設定します。
setTelephoneNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
電話番号を設定します。
setTemplateCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
テンプレートコードを設定します。
setTemplateCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
テンプレートコードを設定します。
setTemplateCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate のメソッド
テンプレートコードを設定します。
setTemplateDetail(ItemTemplateDetail) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager のメソッド
商品属性テンプレート明細情報を設定します。
setTemplateDetailCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute のメソッド
テンプレート明細コードを設定します。
setTemplateDetailCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail のメソッド
テンプレート明細コードを設定します。
setTemplateDetailName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetailInternational のメソッド
テンプレート明細名を設定します。
setTemplateDetailName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
テンプレート明細名を設定します。
setTemplateDetailName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel のメソッド
テンプレート明細名を設定します。
setTemplateDetailName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailInternationalModel のメソッド
テンプレート明細名を設定します。
setTemplateName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate のメソッド
テンプレート名を設定します。
setTemplateName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplateInternational のメソッド
テンプレート名を設定します。
setTemplateName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel のメソッド
テンプレート名を設定します。
setTemplateName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateInternationalModel のメソッド
テンプレート名を設定します。
setTerminableAccessor(TerminableAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
期間化アクセサを設定します。
setTerminableInternationalAccessor(TerminableInternationalAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext のメソッド
期間国際化アクセサを設定します。
setTerminableInternationalModelMap(TerminableInternationalModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
期間国際化モデルマップを設定します。
setTerminableModelMap(TerminableModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
期間化モデルマップを設定します。
setText(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
本文を設定します。
setTimeLimit(String) - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
時間制限を設定する。
setTimer(boolean) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 トランザクション自動切断機能のタイマーをセットする（デフォルトtrue）

setTimer(int) - class jp.co.intra_mart.foundation.page.EventScript のメソッド
イベントの監視間隔を設定します。
setTimes(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
第ｎ～曜日を設定します。
setTimes(int) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
次を設定します。
setTitle(String) - class jp.co.intra_mart.foundation.navigator.TitleInfo のメソッド
タイトル設定
setTitleBar(boolean) - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
タイトルバーを表示するかどうかのステータスを設定します。
setTitleInfo(Locale, TitleInfo) - class jp.co.intra_mart.foundation.navigator.NavigatorItem のメソッド

setTo(String) - class jp.co.intra_mart.foundation.http.SessionQuery のメソッド
推奨されていません。 代替えメソッドはありません。
setTo(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 To(宛先)をセットする。
setTo(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 To(宛先)をセットする。
setTransactionIsolation(int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 トランザクション遮断レベルを指定されたものに変更することを試みます。
setType(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
ノードのタイプを設定します。
setTypeMap(Map) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この接続の型マップとして指定された型マップをインストールします。
setURL(String) - interface jp.co.intra_mart.foundation.portal.common.rss.RSSParserIF のメソッド
RSSのURLをセットします
setUesrId(String) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
ログインユーザIDを設定します。
setUesrId(String) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
ログインユーザIDを設定します。
setUesrId(String) - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener のメソッド
ログインユーザIDを設定します。
setUesrId(String) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
ログインユーザIDを設定します。
setUesrId(String) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
ログインユーザIDを設定します。
setUnit(String) - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
表示単位を設定します。
setUnitCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail のメソッド
単位コードを設定します。
setUnitCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
単位コードを設定します。
setUnitCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
単位コードを設定します。
setUnitCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailTerminableModel のメソッド
単位コードを設定します。
setUnitName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitBaseModel のメソッド
単位名を設定します。
setUnitPrice(double) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable のメソッド
単価を設定します。
setUnitPrice(double) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail のメソッド
単価を設定します。
setUnitPrice(double) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
単価を設定します。
setUnitPrice(double, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel のメソッド
単価を設定します。
setUnitPrice(double) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealTerminableModel のメソッド
単価を設定します。
setUnitPrice(double) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
単価を設定します。
setUnitPrice(double, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel のメソッド
単価を設定します。
setUnitPrice(double) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailTerminableModel のメソッド
単価を設定します。
setUrl(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
URLを設定します。
setUrl(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
URLを設定します。
setUrl(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
URLを設定します。
setUrl(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
URLを設定します。
setUrl(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
URLを設定します。
setUrl(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
URLを設定します。
setUrl(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
URLを設定します。
setUrl(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
URLを設定します。
setUrl(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
URLを設定します。
setUrl(String) - class jp.co.intra_mart.foundation.navigator.LinkPageInfo のメソッド
URL設定
setUrl(String) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
リンク先のURLを設定します。
setUrl(String) - class jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet のメソッド
URLを設定します。
setUrl(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ダイレクトＵＲＬを設定する。
setUrl(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
URLを設定します。
setUrl(String) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のメソッド
ＵＲＬを設定します。
setUrl(String) - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel のメソッド
URLを設定します。
setUrlParam(String, String) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のメソッド
ＵＲＬ引数(MAP)をセットする。
setUrlSignature(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ダイレクトＵＲＬ署名を設定する。
setUser(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインユーザIDを設定する。
setUserAgent(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
ブラウザ情報を設定する。
setUserCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
ユーザコードを設定します。
setUserCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
ユーザコードを設定します。
setUserCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
ユーザコードを設定します。
setUserCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
ユーザコードを設定します。
setUserCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザコードを設定します。
setUserId(String) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
ログインユーザIDを設定します。
setUserId(String) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
ログインユーザIDを設定します。
setUserId(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ユーザIDを設定します。
setUserId(String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
ログインユーザIDを設定する。
setUserId(String) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
ユーザID設定。
setUserId(String) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
ログインユーザIDを設定します。
setValid(boolean) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo のメソッド
アクティブなセッション情報を有効・無効化します。
setValidEndDate(Date) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
有効終了日を設定します。
setValidEndDate(Date) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo のメソッド
有効終了日を設定します。
setValidEndDate(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
有効終了日を設定します。
setValidEndDate(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel のメソッド
有効終了日を設定します。
setValidEndYear(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
有効終了年を設定します。
setValidEndYear(int) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
有効終了年を設定します。
setValidFlg(String) - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel のメソッド
有効フラグを設定します。
setValidStartDate(Date) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
有効開始日を設定します。
setValidStartDate(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel のメソッド
有効開始日を設定します。
setValidStartDate(String) - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel のメソッド
有効開始日を設定します。
setValidStartYear(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
有効開始年を設定します。
setValidStartYear(int) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
有効開始年を設定します。
setValidate(ImportManager, ImportConfigurationReader) - class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient のメソッド
インポート設定に定義されたバリデーションステータスをマネージャーに設定します。
setValidate(boolean) - interface jp.co.intra_mart.foundation.datastore.importer.ImportManager のメソッド
インポートデータに対してバリデーションを行うかどうか設定します。
setValidate(boolean) - class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl のメソッド
インポートデータに対してバリデーションを行うかどうか設定します。
setValidate(boolean) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager のメソッド

setValidate(boolean) - class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager のメソッド

setValidate(boolean) - class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager のメソッド

setValidate(boolean) - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager のメソッド

setValidate(boolean) - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager のメソッド

setValidate(boolean) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチの有効・無効を設定します。
setValues(String[]) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のメソッド
エラーメッセージで使用する置換用の文字列を設定します。
setVersionCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
バージョンコードを設定します。
setVersionCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
バージョンコードを設定します。
setViewOpen(EventNavigatorManager, String, String) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
表示設定 イベントフロー情報に表示／非表示を設定する。
setViewOpen(String, String) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
表示設定 イベントフロー情報に表示／非表示を設定する。
setViewOpen(EventNavigatorManager, String, String) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
表示設定 イベントフロー情報に表示／非表示を設定する。
setWeek(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
第ｎ週目を設定します。
setWeek(int) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
週を設定します。
setWidth(int) - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルの幅を設定します。
setWidth(int) - class jp.co.intra_mart.foundation.portal.portlet.model.Portlet のメソッド
表示単位に対する幅設定します。
setXSLT(String) - interface jp.co.intra_mart.foundation.portal.common.rss.RSSParserIF のメソッド
RSSのXMLをフォーマットするXSLスタイルシートのファイルパスをセットします
setYear(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
年を設定します。
setYear(int) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel のメソッド
年を設定します。
setZipCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
郵便番号を設定します。
setZipCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
郵便番号を設定します。
setZipCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
郵便番号を設定します。
setZipCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
郵便番号を設定します。
setZipCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
郵便番号を設定します。
setZipCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
郵便番号を設定します。
setZipCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
郵便番号を設定します。
setZipCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
郵便番号を設定します。
setZipCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
郵便番号を設定します。
size() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
データの数を返します。
size() - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
値の数を返します。
size() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
データの数を返します。
size() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
データの数を返します。
size() - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
値の数を返します。
size() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
データの数を返します。
size() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
データの数を返します。
size() - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
値の数を返します。
size() - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リスト内にある要素の数を返します。
size() - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
このノードが持つ子ノードの数を返します。
size() - interface jp.co.intra_mart.foundation.page.TreeNodeContainer のメソッド
このノードが持つ子ノードの数を返します。
size() - class jp.co.intra_mart.foundation.utility.LockMonitor のメソッド
推奨されていません。 このオブジェクトの管理するモニターの数を取得します。
sort(Comparator) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
指定されたコンパレータに従って、子ノードをソートします。
sortAll(Comparator) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
このノードの下にある、全ての子ノードを指定されたコンパレータに従ってソートします。
sourceName() - class jp.co.intra_mart.foundation.scenario.FunctionContainer のメソッド
ソース名称の取得。
sourceName() - class jp.co.intra_mart.foundation.scenario.FunctionContainerFile のメソッド
スクリプトのファイルパス名を返します。
start() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
スケジューラの開始通知。
startAutomaticExecution(long) - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
推奨されていません。 gc によるシステム停止や監視スレッドを停止処理しないことによるメモリリークなどの問題を引き起こす危険性があります。
stop() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
スケジューラの停止通知。
stopAutomaticExecution() - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
推奨されていません。
stringToDate(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
データベース登録用文字列からjava.util.Dateを取得します。
stringToDate(String) - class jp.co.intra_mart.foundation.database.DbManager の static メソッド
推奨されていません。 DatabaseManager.stringToDate(String)を使用してください。
subList(int, int) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 このリストの、fromIndex (これを含む) から toIndex (これを含まない) の範囲の部分のビューを返します。
subMap(String[]) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
データを取得します。
subMap(String[]) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
データを取得します。
subMap(String[]) - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
データを取得します。
subMap(String[]) - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
データを取得します。
subRoleAdded(String, String, String) - class jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener のメソッド
ロールにサブロールを追加した直後にコールされます。
subRoleAdded(String, String, String) - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のメソッド
ロールにサブロールを追加した直後にコールされます。
subRoleAdded(String, String, String) - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のメソッド
ロールにサブロールを追加した直後にコールされます。
subRoleAdded(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener のメソッド
ロールにサブロールを追加した直後にコールされます。
subRoleDeleted(String, String, String) - class jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener のメソッド
ロールからサブロールを削除した直後にコールされます。
subRoleDeleted(String, String, String) - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のメソッド
ロールからサブロールを削除した直後にコールされます。
subRoleDeleted(String, String, String) - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のメソッド
ロールからサブロールを削除した直後にコールされます。
subRoleDeleted(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener のメソッド
ロールからサブロールを削除した直後にコールされます。
subtract(Term[], Term[]) - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager の static メソッド
期間配列 term1 から 期間配列 term2 を差し引いた期間を返します。

T

TABLE_B_M_EVENT_DEPARTMENT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

TABLE_B_M_EVENT_FLOW - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

TABLE_B_M_EVENT_ITEM - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

TABLE_B_M_EVENT_PAGE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

TABLE_B_M_EVENT_PAGE_PARAM - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

TABLE_B_M_EVENT_POST - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

TABLE_B_M_EVENT_PUBLIC_GROUP - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

TABLE_B_M_EVENT_RESULT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

TABLE_B_M_EVENT_ROLE - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

TABLE_B_M_EVENT_SAVE_RESULT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

TABLE_B_M_EVENT_SELECT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

TABLE_B_M_EVENT_TITLE_INFO - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数

TELEPHONE_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
電話番号
TELEPHONE_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
電話番号
TEMPLATE_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel の static 変数
テンプレートコード
TEMPLATE_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel の static 変数
テンプレートコード
TEMPLATE_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel の static 変数
テンプレートコード
TEMPLATE_DETAIL_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel の static 変数
テンプレート明細コード
TEMPLATE_DETAIL_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel の static 変数
テンプレート明細コード
TEMPLATE_DETAIL_NAME - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel の static 変数
テンプレート明細名
TEMPLATE_NAME - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel の static 変数
テンプレート名
TIMES - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
次
TYPE_CONFIG - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo の static 変数
名称（データタイプの定数）。
TYPE_DATA_SOURCE - interface jp.co.intra_mart.foundation.database.ConInfo の static 変数

TYPE_DATE - class jp.co.intra_mart.foundation.database.DatabaseColumn の static 変数

TYPE_DEBUG - interface jp.co.intra_mart.foundation.utility.report.ReportLevel の static 変数
推奨されていません。 デバッグレベル。
TYPE_ERROR - interface jp.co.intra_mart.foundation.utility.report.ReportLevel の static 変数
推奨されていません。 エラーレベル。
TYPE_EVENT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
遷移先タイプ：イベントアイテム
TYPE_GROUP - interface jp.co.intra_mart.foundation.database.ConInfo の static 変数

TYPE_HOLIDAY - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo の static 変数
休日（データタイプの定数）。
TYPE_JDBC - interface jp.co.intra_mart.foundation.database.ConInfo の static 変数

TYPE_NATIONAL_HOLDAY - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo の static 変数
祝祭日（データタイプの定数）。
TYPE_NUMBER - class jp.co.intra_mart.foundation.database.DatabaseColumn の static 変数

TYPE_REPORT - interface jp.co.intra_mart.foundation.utility.report.ReportLevel の static 変数
推奨されていません。 通常の情報レベル。
TYPE_RESULT - class jp.co.intra_mart.foundation.navigator.EventNavigatorConst の static 変数
遷移先タイプ：ナビゲート結果
TYPE_STRING - class jp.co.intra_mart.foundation.database.DatabaseColumn の static 変数

TYPE_SYSTEM - interface jp.co.intra_mart.foundation.database.ConInfo の static 変数

TYPE_UNDEFINED - class jp.co.intra_mart.foundation.database.DatabaseColumn の static 変数

TYPE_WARNING - interface jp.co.intra_mart.foundation.utility.report.ReportLevel の static 変数
推奨されていません。 警告レベル。
TYPE_WEEKDAY - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo の static 変数
非休日（データタイプの定数）。
Table - interface jp.co.intra_mart.foundation.datastore.common.config.Table.
テーブルを定義します。
TemporaryDirectory - class jp.co.intra_mart.foundation.service.provider.TemporaryDirectory.
このクラスは、一時ファイル保存用ディレクトリに関する機能を 提供します。
TemporaryFile - class jp.co.intra_mart.foundation.service.provider.TemporaryFile.
このクラスは、一時ファイルに関する機能を提供します。
TemporaryFile() - class jp.co.intra_mart.foundation.service.provider.TemporaryFile のコンストラクタ
一時ファイルのパスを作成します。
Term - class jp.co.intra_mart.foundation.datastore.common.structure.Term.
有効期間を表します。
Term() - class jp.co.intra_mart.foundation.datastore.common.structure.Term のコンストラクタ
開始時間、終了時間とも指定されていない有効期間を生成します。
Term(Date) - class jp.co.intra_mart.foundation.datastore.common.structure.Term のコンストラクタ
開始時間のみが指定された有効期間を生成します。
Term(Date, Date) - class jp.co.intra_mart.foundation.datastore.common.structure.Term のコンストラクタ
開始時間と終了時間がともに指定された有効期間を生成します。
TermManager - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager.
期間 Term を取り扱うマネージャクラスです。
TermManagerException - exception jp.co.intra_mart.foundation.datastore.exception.TermManagerException.
期間に関する例外クラス

TermManagerException() - class jp.co.intra_mart.foundation.datastore.exception.TermManagerException のコンストラクタ
コンストラクタ
TermManagerException(String) - class jp.co.intra_mart.foundation.datastore.exception.TermManagerException のコンストラクタ
コンストラクタ
TermManagerException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.TermManagerException のコンストラクタ
コンストラクタ
TermManagerException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.TermManagerException のコンストラクタ
コンストラクタ
TerminableAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor.
期間化エンティティに対する情報操作用のインタフェースです。
TerminableAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap.
期間化アクセサのマッピング情報を持ちます。
TerminableInternationalAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor.
期間国際化エンティティに対する情報操作用のインタフェースです。
TerminableInternationalAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap.
期間国際化アクセサのマッピング情報を持ちます。
TerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalModel.
期間国際化モデルを定義します。
TerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel.
期間国際化モデルの情報です。
TerminableInternationalModelContext - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext.
期間国際化モデルの初期化に必要な設定を持ちます。
TerminableInternationalModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap.
期間国際化モデルのマッピング情報を持ちます。
TerminableInternationalTable - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable.
期間国際化テーブルを定義します。
TerminableKey - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableKey.
期間化基準項目を定義します。
TerminableModel - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableModel.
期間化モデルを定義します。
TerminableModel - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel.
期間化モデルの情報です。
TerminableModelContext - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext.
期間化化モデルの初期化に必要な設定を持ちます。
TerminableModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap.
期間化モデルのマッピング情報を持ちます。
TerminableTable - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable.
期間化テーブルを定義します。
ThreadStopListener - interface jp.co.intra_mart.foundation.utility.ThreadStopListener.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener クラスを使用してください。
TitleInfo - class jp.co.intra_mart.foundation.navigator.TitleInfo.
タイトル情報
TitleInfo() - class jp.co.intra_mart.foundation.navigator.TitleInfo のコンストラクタ

TreasureDirectory - interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory.
情報データベースのディレクトリを操作するためのインターフェースを定義します。
TreasureFile - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile.
情報データベースのファイルを操作するためのインターフェースを定義します。
TreeBranch - class jp.co.intra_mart.foundation.page.TreeBranch.
ツリービュー内の「フォルダ」をあらわすクラスです。
TreeBranch() - class jp.co.intra_mart.foundation.page.TreeBranch のコンストラクタ
新しいTreeBranchオブジェクトを生成します。
TreeBranch(Comparator) - class jp.co.intra_mart.foundation.page.TreeBranch のコンストラクタ
指定されたコンパレータに従って子ノードをソートする、新しいTreeBranchオブジェクトを生成します。
TreeLeaf - class jp.co.intra_mart.foundation.page.TreeLeaf.
ツリービュー内の「ページ」をあらわすクラスです。
TreeLeaf() - class jp.co.intra_mart.foundation.page.TreeLeaf のコンストラクタ
新しくTreeLeafオブジェクトを生成します。
TreeLeaf(String) - class jp.co.intra_mart.foundation.page.TreeLeaf のコンストラクタ
新しくTreeLeafオブジェクトを生成し、表示名称を設定します。
TreeLeaf(String, String) - class jp.co.intra_mart.foundation.page.TreeLeaf のコンストラクタ
新しくTreeLeafオブジェクトを生成し、表示名称と、ポップアップ文字列を設定します。
TreeNode - interface jp.co.intra_mart.foundation.page.TreeNode.
ツリービュー内の単一のノードを表すインターフェースです。
TreeNodeContainer - interface jp.co.intra_mart.foundation.page.TreeNodeContainer.
子ノードを参照するためのメソッドが定義されたインターフェースです。
TreeNodeProvider - interface jp.co.intra_mart.foundation.page.TreeNodeProvider.
ツリービューの「ホーム」をあらわすインターフェースです。
TreeRoot - class jp.co.intra_mart.foundation.page.TreeRoot.
ツリービュー内の「ホーム」をあらわすクラスです。
TreeRoot() - class jp.co.intra_mart.foundation.page.TreeRoot のコンストラクタ
新しいTreeRootオブジェクトを生成します。
TreeRoot(Comparator) - class jp.co.intra_mart.foundation.page.TreeRoot のコンストラクタ
指定されたコンパレータに従って子ノードをソートする、新しいTreeRootオブジェクトを生成します。
temporaryDirectory() - class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory のメソッド
削除対象のデータファイルを一時的に保存しておくための ディレクトリを表すオブジェクトを取得します。
toArray() - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リスト内のすべての要素が正しい順序で格納されている配列を返します。
toArray(Object[]) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 リスト内のすべての要素が正しい順序で格納されている配列を返します。
toString() - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
オブジェクトの文字列表現を返します。
toString() - class jp.co.intra_mart.foundation.datastore.exporter.Filter のメソッド
フィルタの文字列表現を返します。
toString() - class jp.co.intra_mart.foundation.image.ImageIconInfo のメソッド
この ImageIconInfo の値を表す String オブジェクトを返します。
toString() - class jp.co.intra_mart.foundation.page.EventScript のメソッド
このオブジェクトの文字列表現を返します。
toString() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値の文字列表現を取得します。
toString() - class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel のメソッド
設定情報モデルの内容を返す。
toString() - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のメソッド
推奨されていません。 このオブジェクトの文字列表現を返します。
total() - class jp.co.intra_mart.foundation.utility.LockMonitor のメソッド
推奨されていません。 モニターを利用中、または利用しようとしているスレッドの数です。
totalMemory() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
サーバプロセスの Java Virtual Machine のメモリの総容量を返します。
transaction() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースアクセスのトランザクションを開始する

トランザクションを開始させる。
transliterate(String) - class jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener のメソッド
指定した文字列のに含まれる半角カナ文字を全角カナ文字に変化して返します。
trimToSize() - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
推奨されていません。 この ArrayList のインスタンスのサイズをリストの現在のサイズに縮小します。

U

UNAVALIABLE_LOGIN_USER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ログイン出来ないアカウントを表す定数
UNIT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel の static 変数
単位コード
UNIT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitBaseModel の static 変数
単位コード
UNIT_NAME - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitBaseModel の static 変数
単位名
UNIT_PRICE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel の static 変数
単価
UNIT_PRICE - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel の static 変数
単価
URL - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
URL
URL - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
URL
URL - interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel の static 変数
URL
URLAccessFilter - class jp.co.intra_mart.foundation.security.filter.URLAccessFilter.
URLアクセスフィルタ。
URLAccessFilter() - class jp.co.intra_mart.foundation.security.filter.URLAccessFilter のコンストラクタ

URLBuilder - class jp.co.intra_mart.jssp.net.URLBuilder.
スクリプト開発モデルの画面を呼び出すための URL を作成するビルダです。
URLBuilder(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.jssp.net.URLBuilder のコンストラクタ
新しいビルダを作成します。
URLDecodeInputStream - class jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream クラスを使用してください。
URLDecodeInputStream(InputStream) - class jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream のコンストラクタ
推奨されていません。 指定された InputStream から URL デコードしながらバイトを読み込む 入力ストリームを作成します。
URLDecodeOutputStream - class jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream クラスを使用してください。
URLDecodeOutputStream(OutputStream) - class jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に書き込む BASE64デコーダーを作成します。
URLEncodeOutputStream - class jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream クラスを使用してください。
URLEncodeOutputStream(OutputStream) - class jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に書き込む BASE64デコーダーを作成します。
USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
ユーザコード
USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の static 変数
ユーザコード
USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の static 変数
ユーザコード
USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の static 変数
ユーザコード
USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ユーザコード
USER_ID - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel の static 変数
ユーザID
USER_ID - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
ユーザID
USER_ID - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel の static 変数
ユーザID
USER_ID - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel の static 変数
ユーザID
UnitBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitBaseModel.
単位の基本モデルです。
UnitMapper - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper.
単位に関連するマッパです。
UnsupportedNetworkConnectException - exception jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException クラスを使用してください。
UnsupportedNetworkConnectException() - class jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException のコンストラクタ
推奨されていません。 Constructor for UnsupportedNetworkConnectException.
UnsupportedNetworkConnectException(String) - class jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException のコンストラクタ
推奨されていません。 Constructor for UnsupportedNetworkConnectException.
UpdateAccessor - interface jp.co.intra_mart.foundation.update.UpdateAccessor.
情報更新管理アクセッサインタフェース。
UpdateInfo - interface jp.co.intra_mart.foundation.datastore.common.config.UpdateInfo.
エンティティの更新情報です。
UpdateManager - class jp.co.intra_mart.foundation.update.UpdateManager.
情報更新管理マネージャ。
UpdateManager(String) - class jp.co.intra_mart.foundation.update.UpdateManager のコンストラクタ
コンストラクタ。
User - class jp.co.intra_mart.foundation.datastore.application.domain.user.User.
ユーザの基本属性のデータを取り扱います。
User() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のコンストラクタ
ユーザに関連する情報を新規に生成します。
User(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のコンストラクタ
ユーザに関連する情報を新規に生成します。
User(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のコンストラクタ
ユーザに関連する情報を新規に生成します。
User(Locale, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のコンストラクタ
ユーザに関連する情報を新規に生成します。
UserActiveSessionRegister - class jp.co.intra_mart.foundation.security.activesession.UserActiveSessionRegister.
ユーザログイン認証リスナー実装クラス。
UserActiveSessionRegister() - class jp.co.intra_mart.foundation.security.activesession.UserActiveSessionRegister のコンストラクタ

UserAttachExportManager - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager.
ユーザ所属情報のエクスポートを行います。
UserAttachExportManager() - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager のコンストラクタ
コンストラクタ ユーザ所属情報エクスポートマネージャーのインスタンスを生成します。
UserAttachExportManagerClient - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient.
ユーザ所属情報のエクスポートを行います。
UserAttachExportManagerClient() - class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient のコンストラクタ

UserAttachImportManager - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager.
ユーザ所属情報のインポートを行います。
UserAttachImportManager() - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager のコンストラクタ
コンストラクタ ユーザ所属情報インポートマネージャーのインスタンスを生成します。
UserAttachImportManagerClient - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient.
ユーザ所属情報のインポートを行います。
UserAttachImportManagerClient() - class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient のコンストラクタ

UserBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel.
ユーザの基本モデルです。
UserCertification - interface jp.co.intra_mart.foundation.security.certification.UserCertification.
ユーザログイン認証インタフェース。
UserCertificationListener - interface jp.co.intra_mart.foundation.security.certification.UserCertificationListener.
ユーザログイン認証リスナーインタフェース。
UserCertificationServlet - class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet.
ユーザ認証サーブレット。
UserCertificationServlet() - class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet のコンストラクタ

UserChangedListener - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener.
ユーザに関する情報の変更時のリスナーです。
UserImporter - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter.
ユーザインポーターのインタフェースです。
UserInitialServlet - class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet.
ユーザ初期アクセスサーブレット。
UserInitialServlet() - class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet のコンストラクタ

UserManager - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager.
ユーザに関連する情報を管理します。
UserManager() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager のコンストラクタ

UserMapper - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper.
ユーザに関連するマッパです。
UserPageProvider - interface jp.co.intra_mart.foundation.security.certification.UserPageProvider.
ユーザページプロバイダインタフェース。
UserProfileExportManager - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager.
ユーザ情報のエクスポートを行います。
UserProfileExportManager() - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager のコンストラクタ
コンストラクタ ユーザ情報エクスポートマネージャーのインスタンスを生成します。
UserProfileExportManagerClient - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient.
ユーザ情報のエクスポートを行います。
UserProfileExportManagerClient() - class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient のコンストラクタ

UserProfileImportManager - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager.
ユーザ情報のインポートを行います。
UserProfileImportManager() - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager のコンストラクタ
コンストラクタ ユーザ情報インポートマネージャーのインスタンスを生成します。
UserProfileImportManagerClient - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient.
ユーザ情報のインポートを行います。
UserProfileImportManagerClient() - class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient のコンストラクタ

UserTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable.
ユーザの期間化属性のデータを取り扱います。
UserTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のコンストラクタ

UserTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational.
ユーザの期間国際化属性のデータを取り扱います。
UserTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のコンストラクタ

UserTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel.
ユーザの期間国際化モデルです。
UserTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel.
ユーザの期間化モデルです。
update(String, String, Map) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースにデータを更新するメソッド

データベースのデータを更新(アップデート)する。
update(CateogryClassBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
分類区分の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
分類区分の基本モデルを複数更新します。
update(CategoryDetailBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
分類区分詳細の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
分類区分詳細の基本モデルを複数更新します。
update(DepartmentAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
組織所属の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
組織所属の基本モデルを複数更新します。
update(CompanyCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
会社組織分類の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
会社組織分類の基本モデルを複数更新します。
update(CompanyBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
会社の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
会社の基本モデルを複数更新します。
update(DepartmentBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
組織の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
組織の基本モデルを複数更新します。
update(DepartmentInclusionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
組織内包の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
組織内包の基本モデルを複数更新します。
update(DepartmentMainBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
主所属の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
主所属の基本モデルを複数更新します。
update(CompanyPostBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
役職の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
役職の基本モデルを複数更新します。
update(CompanyVersionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
会社構成バージョンの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
会社構成バージョンの基本モデルを複数更新します。
update(DealBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper のメソッド
取扱の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper のメソッド
取扱の基本モデルを複数更新します。
update(DealerDepartmentBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper のメソッド
組織毎取扱パーミッションの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper のメソッド
組織毎取扱パーミッションの基本モデルを複数更新します。
update(DealDetailBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper のメソッド
取扱詳細の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper のメソッド
取扱詳細の基本モデルを複数更新します。
update(DealerPublicGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper のメソッド
パブリックグループ毎取扱パーミッションの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper のメソッド
パブリックグループ毎取扱パーミッションの基本モデルを複数更新します。
update(DealerRoleBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper のメソッド
ロール毎取扱パーミッションの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper のメソッド
ロール毎取扱パーミッションの基本モデルを複数更新します。
update(ItemAttributeBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper のメソッド
商品属性の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper のメソッド
商品属性の基本モデルを複数更新します。
update(ItemCatalogueBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper のメソッド
商品カタログの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper のメソッド
商品カタログの基本モデルを複数更新します。
update(ItemBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper のメソッド
商品の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper のメソッド
商品の基本モデルを複数更新します。
update(ItemAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper のメソッド
商品分類の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper のメソッド
商品分類の基本モデルを複数更新します。
update(ItemCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper のメソッド
商品カテゴリの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper のメソッド
商品カテゴリの基本モデルを複数更新します。
update(ItemCategoryTypeBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper のメソッド
商品カテゴリ種別の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper のメソッド
商品カテゴリ種別の基本モデルを複数更新します。
update(ItemTemplateDetailBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper のメソッド
商品属性テンプレート明細の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper のメソッド
商品属性テンプレート明細の基本モデルを複数更新します。
update(ItemTemplateBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper のメソッド
商品属性テンプレートの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper のメソッド
商品属性テンプレートの基本モデルを複数更新します。
update(PrivateGroupAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライベートグループ所属の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライベートグループ所属の基本モデルを複数更新します。
update(PrivateGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライベートグループの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライベートグループの基本モデルを複数更新します。
update(PublicGroupAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
パブリックグループ所属の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
パブリックグループ所属の基本モデルを複数更新します。
update(PublicGroupCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
パブリックグループ分類の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
パブリックグループ分類の基本モデルを複数更新します。
update(PublicGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
パブリックグループの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
パブリックグループの基本モデルを複数更新します。
update(PublicGroupInclusionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
パブリックグループ内包の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
パブリックグループ内包の基本モデルを複数更新します。
update(PublicGroupSetBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
パブリックグループセットの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
パブリックグループセットの基本モデルを複数更新します。
update(PublicGroupVersionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
パブリックグループ構成バージョンの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
パブリックグループ構成バージョンの基本モデルを複数更新します。
update(UnitBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper のメソッド
単位の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper のメソッド
単位の基本モデルを複数更新します。
update(UserBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
ユーザの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
ユーザの基本モデルを複数更新します。
update(BaseModel) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
基本モデルを1つだけ更新します。
update(Collection) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
基本モデルを複数更新します。
update(String, String, Date) - class jp.co.intra_mart.foundation.update.StandardUpdateAccessor のメソッド
キーの更新日付を更新します。
update(String, String, Date) - interface jp.co.intra_mart.foundation.update.UpdateAccessor のメソッド
キーの更新日付を更新します。
update(AccessControllerDepartmentBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper のメソッド
アクセスコントローラの利用権限を保有する組織の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper のメソッド
アクセスコントローラの利用権限を保有する組織の基本モデルを複数更新します。
update(AccessControllerBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper のメソッド
アクセスコントローラ情報の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper のメソッド
アクセスコントローラ情報の基本モデルを複数更新します。
update(AccessControllerPostBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper のメソッド
アクセスコントローラの利用権限を保有する役職の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper のメソッド
アクセスコントローラの利用権限を保有する役職の基本モデルを複数更新します。
update(AccessControllerPublicGroupBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper のメソッド
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper のメソッド
アクセスコントローラの利用権限を保有するパブリックグループの基本モデルを複数更新します。
update(AccessControllerRoleBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper のメソッド
アクセスコントローラの利用権限を保有するロールの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper のメソッド
アクセスコントローラの利用権限を保有するロールの基本モデルを複数更新します。
update(AccountAttributeBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper のメソッド
アカウントが保有する属性の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper のメソッド
アカウントが保有する属性の基本モデルを複数更新します。
update(AccountBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccountMapper のメソッド
アカウントの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccountMapper のメソッド
アカウントの基本モデルを複数更新します。
update(AccountRoleBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper のメソッド
アカウントが保有するロールの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper のメソッド
アカウントが保有するロールの基本モデルを複数更新します。
update(BatchBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.BatchMapper のメソッド
バッチ情報の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.BatchMapper のメソッド
バッチ情報の基本モデルを複数更新します。
update(CalendarInfoBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper のメソッド
カレンダーが保有するデータの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper のメソッド
カレンダーが保有するデータの基本モデルを複数更新します。
update(FavoriteMenuBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper のメソッド
アカウントが保有するメニューの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper のメソッド
アカウントが保有するメニューの基本モデルを複数更新します。
update(MenuArgumentBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper のメソッド
メニューの保有する引数の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper のメソッド
メニューの保有する引数の基本モデルを複数更新します。
update(MenuDepartmentBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper のメソッド
メニューの利用権限を保有する組織の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper のメソッド
メニューの利用権限を保有する組織の基本モデルを複数更新します。
update(MenuBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuMapper のメソッド
メニュー情報の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuMapper のメソッド
メニュー情報の基本モデルを複数更新します。
update(MenuPostBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper のメソッド
メニューの利用権限を保有する役職の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper のメソッド
メニューの利用権限を保有する役職の基本モデルを複数更新します。
update(MenuPublicGroupBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper のメソッド
メニューの利用権限を保有するパブリックグループの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper のメソッド
メニューの利用権限を保有するパブリックグループの基本モデルを複数更新します。
update(MenuRoleBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper のメソッド
メニューの利用権限を保有するロールの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper のメソッド
メニューの利用権限を保有するロールの基本モデルを複数更新します。
update(RoleInclusionBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper のメソッド
ロール内包の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper のメソッド
ロール内包の基本モデルを複数更新します。
update(RoleBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.RoleMapper のメソッド
ロールの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.RoleMapper のメソッド
ロールの基本モデルを複数更新します。
update(RoleSummaryBaseModel) - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper のメソッド
ロールサマリの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper のメソッド
ロールサマリの基本モデルを複数更新します。
updateAccount(String, Account) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウント情報を更新する。
updateAccount(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント情報を更新する。
updateAccount(Account) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントを更新します。
updateAccountRole(String, String, AccountRole) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
アカウントロール情報を更新する。
updateAccountRole(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントロール情報を更新する。
updateAccountRole(String, AccountRole) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントロールを更新します。
updateBatch(String, Batch) - class jp.co.intra_mart.foundation.security.StandardBatchAccessor のメソッド
バッチを更新します。
updateBatch(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
バッチ情報を更新します。
updateBatch(Batch) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチ情報を更新します。
updateCalendarInfo(String, String, CalendarInfo) - class jp.co.intra_mart.foundation.security.StandardCalendarAccessor のメソッド
カレンダーデータを更新します。
updateCalendarInfo(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
カレンダーデータを更新します。
updateCalendarInfo(String, CalendarInfo) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータを更新します。
updateCategory(ItemCategory) - class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager のメソッド
商品カテゴリを更新します。
updateCategory(String, String, String) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
カテゴリを更新します。
updateCategory(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
カテゴリを更新する。
updateCategoryDetail(CategoryDetail) - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のメソッド
登録済の分類区分詳細を更新します。
updateController(String, AccessController) - class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor のメソッド
アクセスコントローラを更新します。
updateController(String, AccessController) - interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor のメソッド
アクセスコントローラを更新します。
updateController(AccessController) - class jp.co.intra_mart.foundation.security.access.AccessControllerManager のメソッド
アクセスコントローラを更新します。
updateDeal(Deal) - class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager のメソッド
取扱情報を更新します。
updateDepartment(Department) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の組織情報を更新します。
updateEventFlow(EventNavigatorManager, EventFlow) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
イベントフローの更新 イベントフロー情報をDB更新する。
updateEventFlow(EventFlow) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
イベントフローの更新 イベントフロー情報をDB更新する。
updateEventFlow(EventNavigatorManager, EventFlow) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
イベントフローの登録 イベントフローIDでイベントフローを削除し、同じイベントフローIDで新しいイベントフローを登録する。
updateEventResultItemInfo(EventNavigatorManager, String, SaveEventResultItemInfo) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
updateEventResultItemInfo(String, SaveEventResultItemInfo) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
updateEventResultItemInfo(EventNavigatorManager, String, SaveEventResultItemInfo) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
保存ナビゲート結果情報の更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
updateEventResultItemInfoTitle(EventNavigatorManager, String, SaveEventResultItemInfo) - interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor のメソッド
保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
updateEventResultItemInfoTitle(String, SaveEventResultItemInfo) - class jp.co.intra_mart.foundation.navigator.EventNavigatorManager のメソッド
保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
updateEventResultItemInfoTitle(EventNavigatorManager, String, SaveEventResultItemInfo) - class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor のメソッド
保存ナビゲート結果情報のタイトル更新（ユーザ） ユーザID、ナビゲート結果IDをキーとして保存ナビゲート結果情報（ユーザ）をDB更新する。
updateFavoriteMenu(String, String, FavoriteMenu) - class jp.co.intra_mart.foundation.security.StandardAccountAccessor のメソッド
マイメニュー情報を更新する。
updateFavoriteMenu(String, String, FavoriteMenu) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
マイメニュー情報を更新する。
updateFavoriteMenu(String, FavoriteMenu) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
マイメニューを更新します。
updateGroupImageIcon(ImageIconInfo) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
グループのイメージアイコン情報を更新します。
updateItem(Item) - class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager のメソッド
商品情報を更新します。
updateLastResponseTime(String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。
updateLastResponseTime(String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。
updateLastResponseTime(String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。
updateLoginGroup(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
ログイングループを更新します。
updateLoginGroup(LoginGroup) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループ情報を更新します。
updateMainPagePattern(String, MainPagePatternInfo) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
メインページパターンを更新します。
updateMainPagePattern(String, MainPagePatternInfo) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンを更新します。
updateMenuItem(String, MenuItem) - class jp.co.intra_mart.foundation.security.StandardMenuAccessor のメソッド
引数で渡されたノードを更新します。
updateMenuItem(MenuItem) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
引数で渡されたノードを更新します。
updateMenuItem(MenuItem) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニューを更新します。
updateMenuItem(String, MenuItem) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
引数で渡されたノードを更新します。
updateMenuItem(MenuItem) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューを更新します。
updatePost(CompanyPost) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の役職情報を更新します。
updatePrivateGroup(PrivateGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
登録済のプライベートグループ情報を更新します。
updatePublicGroup(PublicGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループ情報を更新します。
updateRole(String, Role) - class jp.co.intra_mart.foundation.security.StandardRoleAccessor のメソッド
ロール情報を更新します。
updateRole(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
ロール情報を更新する。
updateRole(Role) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール情報を更新します。
updateSuperUser(SuperUser) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
システム管理者情報を更新します。
updateSuperUser(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor のメソッド
システム管理者情報を更新します。
updateSuperUser(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor のメソッド
グループ管理者情報を更新します。
updateSuperUser(String, SuperUser) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
グループ管理者情報を更新します。
updateTemplate(ItemTemplate) - class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager のメソッド
商品属性テンプレート情報を更新します。
updateToProcessing(String, String) - interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor のメソッド
引数で指定されたアクティブなセッション情報を処理中に更新します。
updateToProcessing(String, String) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager のメソッド
引数で指定されたアクティブなセッション情報を処理中に更新します。
updateToProcessing(String, String) - class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor のメソッド
引数で指定されたアクティブなセッション情報を処理中に更新します。
updateUnit(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager のメソッド
単位を更新します。
updateUser(User) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager のメソッド
登録済のユーザを更新します。
updateUserImageIcon(ImageIconInfo, String) - class jp.co.intra_mart.foundation.image.ImageIconManager のメソッド
ユーザのイメージアイコン情報を更新します。
updateVersion(CompanyVersion) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の会社構成バージョンを更新します。
updateVersion(PublicGroupVersion) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループセット構成バージョンを更新します。
usableConnection() - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionManager のメソッド
推奨されていません。 現在待機中のコネクションをです。
usableConnection() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 現在待機中のコネクションをです。
userAdded(String, User) - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener のメソッド
ユーザ情報がデータストアに登録された後に呼び出されます。
userDeleted(String, User) - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener のメソッド
ユーザ情報がデータストアから削除された後に呼び出されます。
userUpdated(String, User) - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener のメソッド
ユーザ情報がデータストアに対して更新された後に呼び出されます。

V

VALID_END_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
有効終了日
VALID_END_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel の static 変数
有効終了日
VALID_END_YEAR - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
有効終了年
VALID_FLG - interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel の static 変数
有効フラグ
VALID_START_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel の static 変数
有効開始日
VALID_START_DATE - interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel の static 変数
有効開始日
VALID_START_YEAR - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
有効開始年
VERSION_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
バージョンコード
VERSION_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
バージョンコード
VERSION_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
バージョンコード
VERSION_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
バージョンコード
VariableScope - interface jp.co.intra_mart.foundation.scenario.VariableScope.
スクリプトのスコープを表すオブジェクトです。
validate(CalendarManager, CategorizedCalendarInfo, CalendarInfo, Date) - interface jp.co.intra_mart.foundation.security.calendar.CalendarPlugin のメソッド
カレンダーデータが有効かどうか検証します。
validate(CalendarManager, CategorizedCalendarInfo, CalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox のメソッド
カレンダーデータが有効かどうか検証します。
validate(CalendarManager, CategorizedCalendarInfo, CalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth のメソッド
カレンダーデータが有効かどうか検証します。
validate(CalendarManager, CategorizedCalendarInfo, CalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth のメソッド
カレンダーデータが有効かどうか検証します。
validate(CalendarManager, CategorizedCalendarInfo, CalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday のメソッド
カレンダーデータが有効かどうか検証します。
validate(CalendarManager, CategorizedCalendarInfo, CalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox のメソッド
カレンダーデータが有効かどうか検証します。
validateTerm(Date, Date) - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager の static メソッド
指定された2つの日時が有効な期間を構成するかどうか調べます。
validateTerms(Term[]) - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager の static メソッド
指定された期間配列が有効かどうかを調べます。
validation(String) - interface jp.co.intra_mart.foundation.security.servlet.LogoutInitialUrlValidator のメソッド
ログアウト後に遷移しようとするURLを検証します。
valueBound(HttpSessionBindingEvent) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionBindingListener のメソッド
このオブジェクトがセッションに結びつけられた時に呼び出されます。
valueUnbound(HttpSessionBindingEvent) - class jp.co.intra_mart.foundation.security.activesession.ActiveSessionBindingListener のメソッド
このオブジェクトがセッションから取り外された時に呼び出されます。
values() - class jp.co.intra_mart.foundation.database.DbTypes の static メソッド

verifyPasswordHistory(String, String, int) - interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor のメソッド
ユーザのパスワードを消去。
verifyPasswordHistory(String, int) - class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager のメソッド
ユーザのパスワード履歴を消去。
verifyPasswordHistory(String, String, int) - class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor のメソッド
ユーザのパスワードを消去。
verifyShortCut(String, Date) - interface jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor のメソッド
ショートカットIDを検証します。
verifyShortCut(Date) - class jp.co.intra_mart.foundation.security.shortcut.ShortCutManager のメソッド
ショートカット検証。
verifyShortCut(String, Date) - class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor のメソッド
ショートカットIDを検証します。
versionAdded(String, CompanyVersion) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
会社構成バージョンがデータストアに登録された後に呼び出されます。
versionAdded(String, PublicGroupVersion) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
versionAdded(String, CompanyVersion) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
会社構成バージョンがデータストアに登録された後に呼び出されます。
versionAdded(String, PublicGroupVersion) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
versionAdded(String, CompanyVersion) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
会社構成バージョンがデータストアに登録された後に呼び出されます。
versionAdded(String, PublicGroupVersion) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
versionCopied(String, String, String, String, Term) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
versionCopied(String, String, String, String, Term) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
versionCopied(String, String, String, String, Term) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
versionCopied(String, String, String, String, Term) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
versionCopied(String, String, String, String, Term) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
versionCopied(String, String, String, String, Term) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
versionDeleted(String, CompanyVersion) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
会社構成バージョンがデータストアから削除された後に呼び出されます。
versionDeleted(String, PublicGroupVersion) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
versionDeleted(String, CompanyVersion) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
会社構成バージョンがデータストアから削除された後に呼び出されます。
versionDeleted(String, PublicGroupVersion) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
versionDeleted(String, CompanyVersion) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
会社構成バージョンがデータストアから削除された後に呼び出されます。
versionDeleted(String, PublicGroupVersion) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
versionUpdated(String, CompanyVersion) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
会社構成バージョンがデータストアに更新された後に呼び出されます。
versionUpdated(String, PublicGroupVersion) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
versionUpdated(String, CompanyVersion) - class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener のメソッド
会社構成バージョンがデータストアに更新された後に呼び出されます。
versionUpdated(String, PublicGroupVersion) - class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener のメソッド
パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
versionUpdated(String, CompanyVersion) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
会社構成バージョンがデータストアに更新された後に呼び出されます。
versionUpdated(String, PublicGroupVersion) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。

W

WEEK - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
週
WRITE_TIMEOUT - class jp.co.intra_mart.foundation.database.exception.DatabaseExportException の static 変数
推奨されていません。
WebApplicationHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler.
フレームワークを実行するためのイベントハンドラの抽象実装です。
WebApplicationHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のコンストラクタ
Web-Application をイベント実行するためのハンドラを作成します。
write(byte) - class jp.co.intra_mart.foundation.http.FileSender のメソッド
バイトの出力。
write(byte[]) - class jp.co.intra_mart.foundation.http.FileSender のメソッド
バイトの出力。
write(byte[], int, int) - class jp.co.intra_mart.foundation.http.FileSender のメソッド
バイトの出力。
write(String) - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ファイルにテキストを出力します。
write(String, Throwable) - interface jp.co.intra_mart.foundation.service.provider.SystemErrorReporter のメソッド
メッセージをログに書き込みます。
write(String) - interface jp.co.intra_mart.foundation.service.provider.SystemReporter のメソッド
メッセージをログに書き込みます。
write(char[], int, int) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のメソッド
推奨されていません。 文字の配列の一部を書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のメソッド
推奨されていません。 単一の文字を書き込みます。
write(String, int, int) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のメソッド
推奨されていません。 文字列の一部を書き込みます。
write(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
write(String, String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
write(byte[]) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream のメソッド
推奨されていません。 バイトをデコードして出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream のメソッド
推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream のメソッド
推奨されていません。 バイトをエンコード出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream のメソッド
推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 指定されたバイトを書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 オフセット off から始まる指定のバイト配列から この出力ストリームに len バイトを書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.HexOutputStream のメソッド
推奨されていません。 バイトをエンコード出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.HexOutputStream のメソッド
推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のメソッド
推奨されていません。 単一文字を書き込みます。
write(char[], int, int) - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のメソッド
推奨されていません。 文字列の一部を基礎ストリームに書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream のメソッド
推奨されていません。 バイトをデコードして出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream のメソッド
推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream のメソッド
推奨されていません。 バイトをデコードして出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream のメソッド
推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.XOROutputStream のメソッド
推奨されていません。 バイトをエンコード出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.XOROutputStream のメソッド
推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
write(char[], int, int) - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 基礎ストリームに文字を出力します。
writeBoolean(boolean) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 boolean 型データの送信。
writeInt(int) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 int 型データの送信。
writeLong(long) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 long 型データの送信。
writeObject(Object) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 オブジェクトの送信。
writeString(String) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 文字列の送信。

X

XORInputStream - class jp.co.intra_mart.foundation.utility.io.XORInputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream クラスを使用してください。
XORInputStream(InputStream, int) - class jp.co.intra_mart.foundation.utility.io.XORInputStream のコンストラクタ
推奨されていません。 指定された InputStream から指定されたバイトとの排他論理和を 取りながら読み込む XORInputStream を作成します。
XOROutputStream - class jp.co.intra_mart.foundation.utility.io.XOROutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream クラスを使用してください。
XOROutputStream(OutputStream, int) - class jp.co.intra_mart.foundation.utility.io.XOROutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に対して b との排他論理和を取ったバイトデータを書き込む XOROutputStream を作成します。

Y

YEAR - interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel の static 変数
年

Z

ZIP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
郵便番号
ZIP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
郵便番号
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

概要

パッケージ

クラス

使用

階層ツリー

非推奨 API

索引

ヘルプ

intra-mart 6.1.14

前 次

フレームあり フレームなし


javadoc_foundation 6.1.14 API

フレーム関連の警告

このドキュメントはフレーム機能を使って表示するように作られています。フレームを表示できない Web クライアントの場合にこのメッセージが表示されます。
リンク先フレームなしのバージョン


概要 (javadoc_foundation 6.1.14 API)

すべてのクラス

パッケージ
jp.co.intra_mart.foundation.acssecurity
jp.co.intra_mart.foundation.commons
jp.co.intra_mart.foundation.commons.validation
jp.co.intra_mart.foundation.database
jp.co.intra_mart.foundation.database.exception
jp.co.intra_mart.foundation.datastore.application.domain.category
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class
jp.co.intra_mart.foundation.datastore.application.domain.category.detail
jp.co.intra_mart.foundation.datastore.application.domain.company
jp.co.intra_mart.foundation.datastore.application.domain.company.attach
jp.co.intra_mart.foundation.datastore.application.domain.company.category
jp.co.intra_mart.foundation.datastore.application.domain.company.company
jp.co.intra_mart.foundation.datastore.application.domain.company.department
jp.co.intra_mart.foundation.datastore.application.domain.company.main
jp.co.intra_mart.foundation.datastore.application.domain.company.post
jp.co.intra_mart.foundation.datastore.application.domain.company.version
jp.co.intra_mart.foundation.datastore.application.domain.currency
jp.co.intra_mart.foundation.datastore.application.domain.deal
jp.co.intra_mart.foundation.datastore.application.domain.deal.deal
jp.co.intra_mart.foundation.datastore.application.domain.deal.department
jp.co.intra_mart.foundation.datastore.application.domain.deal.detail
jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group
jp.co.intra_mart.foundation.datastore.application.domain.deal.role
jp.co.intra_mart.foundation.datastore.application.domain.item
jp.co.intra_mart.foundation.datastore.application.domain.item_category
jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach
jp.co.intra_mart.foundation.datastore.application.domain.item_category.category
jp.co.intra_mart.foundation.datastore.application.domain.item_category.type
jp.co.intra_mart.foundation.datastore.application.domain.item_template
jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail
jp.co.intra_mart.foundation.datastore.application.domain.item_template.template
jp.co.intra_mart.foundation.datastore.application.domain.item.attribute
jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue
jp.co.intra_mart.foundation.datastore.application.domain.item.item
jp.co.intra_mart.foundation.datastore.application.domain.private_group
jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach
jp.co.intra_mart.foundation.datastore.application.domain.private_group.group
jp.co.intra_mart.foundation.datastore.application.domain.public_group
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set
jp.co.intra_mart.foundation.datastore.application.domain.public_group.version
jp.co.intra_mart.foundation.datastore.application.domain.unit
jp.co.intra_mart.foundation.datastore.application.domain.user
jp.co.intra_mart.foundation.datastore.application.model.category.category_class
jp.co.intra_mart.foundation.datastore.application.model.category.detail
jp.co.intra_mart.foundation.datastore.application.model.company.attach
jp.co.intra_mart.foundation.datastore.application.model.company.category
jp.co.intra_mart.foundation.datastore.application.model.company.company
jp.co.intra_mart.foundation.datastore.application.model.company.department
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion
jp.co.intra_mart.foundation.datastore.application.model.company.main
jp.co.intra_mart.foundation.datastore.application.model.company.post
jp.co.intra_mart.foundation.datastore.application.model.company.version
jp.co.intra_mart.foundation.datastore.application.model.deal.deal
jp.co.intra_mart.foundation.datastore.application.model.deal.department
jp.co.intra_mart.foundation.datastore.application.model.deal.detail
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group
jp.co.intra_mart.foundation.datastore.application.model.deal.role
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach
jp.co.intra_mart.foundation.datastore.application.model.item_category.category
jp.co.intra_mart.foundation.datastore.application.model.item_category.type
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail
jp.co.intra_mart.foundation.datastore.application.model.item_template.template
jp.co.intra_mart.foundation.datastore.application.model.item.attribute
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue
jp.co.intra_mart.foundation.datastore.application.model.item.item
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach
jp.co.intra_mart.foundation.datastore.application.model.private_group.group
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach
jp.co.intra_mart.foundation.datastore.application.model.public_group.category
jp.co.intra_mart.foundation.datastore.application.model.public_group.group
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion
jp.co.intra_mart.foundation.datastore.application.model.public_group.set
jp.co.intra_mart.foundation.datastore.application.model.public_group.version
jp.co.intra_mart.foundation.datastore.application.model.unit
jp.co.intra_mart.foundation.datastore.application.model.user
jp.co.intra_mart.foundation.datastore.common.accessor
jp.co.intra_mart.foundation.datastore.common.config
jp.co.intra_mart.foundation.datastore.common.model
jp.co.intra_mart.foundation.datastore.common.structure
jp.co.intra_mart.foundation.datastore.exception
jp.co.intra_mart.foundation.datastore.exporter
jp.co.intra_mart.foundation.datastore.exporter.common.config
jp.co.intra_mart.foundation.datastore.exporter.company
jp.co.intra_mart.foundation.datastore.exporter.public_group
jp.co.intra_mart.foundation.datastore.exporter.user
jp.co.intra_mart.foundation.datastore.importer
jp.co.intra_mart.foundation.datastore.importer.common.config
jp.co.intra_mart.foundation.datastore.importer.company
jp.co.intra_mart.foundation.datastore.importer.public_group
jp.co.intra_mart.foundation.datastore.importer.user
jp.co.intra_mart.foundation.drawer
jp.co.intra_mart.foundation.exception
jp.co.intra_mart.foundation.graph
jp.co.intra_mart.foundation.http
jp.co.intra_mart.foundation.http.ajax
jp.co.intra_mart.foundation.image
jp.co.intra_mart.foundation.log
jp.co.intra_mart.foundation.mail
jp.co.intra_mart.foundation.mail.javamail
jp.co.intra_mart.foundation.mail.javamail.listener
jp.co.intra_mart.foundation.mail.javamail.listener.impl
jp.co.intra_mart.foundation.mail.javamail.model
jp.co.intra_mart.foundation.mail.javamail.property
jp.co.intra_mart.foundation.navigator
jp.co.intra_mart.foundation.page
jp.co.intra_mart.foundation.portal.common.encode
jp.co.intra_mart.foundation.portal.common.rss
jp.co.intra_mart.foundation.portal.general_purpose_portlet
jp.co.intra_mart.foundation.portal.general_purpose_portlet.model
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider
jp.co.intra_mart.foundation.portal.portlet
jp.co.intra_mart.foundation.portal.portlet.model
jp.co.intra_mart.foundation.scenario
jp.co.intra_mart.foundation.security
jp.co.intra_mart.foundation.security.access
jp.co.intra_mart.foundation.security.account
jp.co.intra_mart.foundation.security.activesession
jp.co.intra_mart.foundation.security.admin
jp.co.intra_mart.foundation.security.batch
jp.co.intra_mart.foundation.security.calendar
jp.co.intra_mart.foundation.security.certification
jp.co.intra_mart.foundation.security.certification.ldap.extension
jp.co.intra_mart.foundation.security.cryption
jp.co.intra_mart.foundation.security.duplication
jp.co.intra_mart.foundation.security.exception
jp.co.intra_mart.foundation.security.filter
jp.co.intra_mart.foundation.security.group
jp.co.intra_mart.foundation.security.license
jp.co.intra_mart.foundation.security.menu
jp.co.intra_mart.foundation.security.message
jp.co.intra_mart.foundation.security.mobile
jp.co.intra_mart.foundation.security.password
jp.co.intra_mart.foundation.security.permission
jp.co.intra_mart.foundation.security.role
jp.co.intra_mart.foundation.security.servlet
jp.co.intra_mart.foundation.security.shortcut
jp.co.intra_mart.foundation.service.client
jp.co.intra_mart.foundation.service.client.application
jp.co.intra_mart.foundation.service.client.application.content
jp.co.intra_mart.foundation.service.client.batch
jp.co.intra_mart.foundation.service.client.file
jp.co.intra_mart.foundation.service.client.information
jp.co.intra_mart.foundation.service.client.manager
jp.co.intra_mart.foundation.service.provider
jp.co.intra_mart.foundation.service.provider.application
jp.co.intra_mart.foundation.service.provider.batch
jp.co.intra_mart.foundation.service.provider.file
jp.co.intra_mart.foundation.service.provider.information
jp.co.intra_mart.foundation.smtp
jp.co.intra_mart.foundation.update
jp.co.intra_mart.foundation.utility
jp.co.intra_mart.foundation.utility.charset
jp.co.intra_mart.foundation.utility.file
jp.co.intra_mart.foundation.utility.io
jp.co.intra_mart.foundation.utility.net
jp.co.intra_mart.foundation.utility.report
jp.co.intra_mart.jssp.net
jp.co.intra_mart.system.security.datastore.inf


概要 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

intra-mart 6.1.14 JavaEE-Base Programing Model API Specifications

パッケージ
jp.co.intra_mart.foundation.acssecurity | アクセスセキュリティモジュールを利用するためのクラスを提供します。
jp.co.intra_mart.foundation.commons |
jp.co.intra_mart.foundation.commons.validation | このパッケージは、入力チェック関数ライブラリを提供します。
jp.co.intra_mart.foundation.database | データベースへアクセスするためのクラスを提供します。
jp.co.intra_mart.foundation.database.exception | データベースＳＱＬ例外クラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category | 分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class | 分類区分情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category.detail | 分類詳細情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.attach | 組織所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.category | 会社分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.department | 組織情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.main | 主所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.post | 役職情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.version | バーション情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.currency | 通貨情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.deal | 取扱情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.department | 取扱組織権限情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.detail | 取扱詳細情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group | 取扱パブリックグループ権限情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.deal.role | 取扱ロール権限情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item | 商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category | 商品カテゴリ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach | 商品分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category.category | 商品カテゴリ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_category.type | 商品カテゴリ種別情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_template | 商品テンプレート属性情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail | 商品テンプレート属性詳細情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item_template.template | 商品テンプレート属性情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item.attribute | 商品属性情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue | 商品カタログ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.item.item | 商品情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group | プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach | プライベートグループ所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group.group | プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach | パブリックグループ所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category | パブリックグループ分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set | パブリックグループセット情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.version | パブリックグループバージョン情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.unit | 商品単位情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category | 会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company | 会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion | 組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version | 会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.deal | 取扱情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.department | 取扱組織権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.detail | 取扱詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.public_group | 取扱パブリックグループ権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.deal.role | 取扱ロール権限情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.attach | 商品分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.category | 商品カテゴリ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_category.type | 商品カテゴリ種別情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.detail | 商品テンプレート属性詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item_template.template | 商品テンプレート情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.attribute | 商品属性情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.catalogue | 商品カタログ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.item.item | 商品情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach | プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group | プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach | パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category | パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion | パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set | パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version | パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.unit | 単位情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.config | アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.foundation.datastore.common.structure | 期間情報などを扱うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter | アプリケーション共通マスタのエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.common.config | エクスポート設定の解釈を行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.company | 会社・組織関連の情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.public_group | パブリックグループ情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exporter.user | ユーザ関連の情報のエクスポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer | アプリケーション共通マスタのインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.common.config | インポート定義情報の解釈を行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.company | 会社・組織関連の情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.public_group | パブリックグループ情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.datastore.importer.user | ユーザ関連の情報のインポートを行うクラスを提供します。
jp.co.intra_mart.foundation.drawer | 画像ファイル出力用クラスを提供します。
jp.co.intra_mart.foundation.exception | システムでスローされる例外クラスを提供します。
jp.co.intra_mart.foundation.graph | グラフ描画に関するクラスを提供します。
jp.co.intra_mart.foundation.http | ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.http.ajax |
jp.co.intra_mart.foundation.image |
jp.co.intra_mart.foundation.log |
jp.co.intra_mart.foundation.mail | メール送信に関するクラスを提供します。
jp.co.intra_mart.foundation.mail.javamail | メール送信クラスを提供します。
jp.co.intra_mart.foundation.mail.javamail.listener |
jp.co.intra_mart.foundation.mail.javamail.listener.impl |
jp.co.intra_mart.foundation.mail.javamail.model |
jp.co.intra_mart.foundation.mail.javamail.property |
jp.co.intra_mart.foundation.navigator |
jp.co.intra_mart.foundation.page | ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.portal.common.encode |
jp.co.intra_mart.foundation.portal.common.rss |
jp.co.intra_mart.foundation.portal.general_purpose_portlet |
jp.co.intra_mart.foundation.portal.general_purpose_portlet.model |
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider |
jp.co.intra_mart.foundation.portal.portlet |
jp.co.intra_mart.foundation.portal.portlet.model |
jp.co.intra_mart.foundation.scenario | スクリプト開発モデルのプログラムと連携するＡＰＩ。
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.access |
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.activesession |
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification.ldap.extension | ユーザログインLDAP認証クラス(複数OU対応版)の設定方法。
jp.co.intra_mart.foundation.security.cryption | 暗号化に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.duplication |
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.filter | アクセスセキュリティのフィルタに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.license | ライセンスに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.message | メッセージに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.mobile |
jp.co.intra_mart.foundation.security.password |
jp.co.intra_mart.foundation.security.permission | 権限に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.servlet | サーブレットに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.shortcut |
jp.co.intra_mart.foundation.service.client | このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.batch | Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file | Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.manager | このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.service.provider.application | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。
jp.co.intra_mart.foundation.service.provider.batch | このパッケージには、スケジュール実行されるバッチプログラム機能を利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.provider.file | このパッケージには、Storage Service 環境内で利用可能な機能を提供します。
jp.co.intra_mart.foundation.service.provider.information | このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。
jp.co.intra_mart.foundation.smtp | メール連携モジュール。
jp.co.intra_mart.foundation.update |
jp.co.intra_mart.foundation.utility | このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.charset | このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.file | このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.io | このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.net | ソケットによるネットワーク対応機能を実装するためのクラスを提供します。
jp.co.intra_mart.foundation.utility.report | このパッケージには、ログ機能を実装するための汎用クラスが含まれています。
jp.co.intra_mart.jssp.net |
jp.co.intra_mart.system.security.datastore.inf |

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.foundation.acssecurity, jp.co.intra_mart.foundation.commons, jp.co.intra_mart.foundation.commons.validation, jp.co.intra_mart.foundation.database, jp.co.intra_mart.foundation.database.exception, jp.co.intra_mart.foundation.datastore.application.domain.category, jp.co.intra_mart.foundation.datastore.application.domain.category.category_class, jp.co.intra_mart.foundation.datastore.application.domain.category.detail, jp.co.intra_mart.foundation.datastore.application.domain.company, jp.co.intra_mart.foundation.datastore.application.domain.company.attach, jp.co.intra_mart.foundation.datastore.application.domain.company.category, jp.co.intra_mart.foundation.datastore.application.domain.company.company, jp.co.intra_mart.foundation.datastore.application.domain.company.department, jp.co.intra_mart.foundation.datastore.application.domain.company.main, jp.co.intra_mart.foundation.datastore.application.domain.company.post, jp.co.intra_mart.foundation.datastore.application.domain.company.version, jp.co.intra_mart.foundation.datastore.application.domain.currency, jp.co.intra_mart.foundation.datastore.application.domain.deal, jp.co.intra_mart.foundation.datastore.application.domain.deal.deal, jp.co.intra_mart.foundation.datastore.application.domain.deal.department, jp.co.intra_mart.foundation.datastore.application.domain.deal.detail, jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group, jp.co.intra_mart.foundation.datastore.application.domain.deal.role, jp.co.intra_mart.foundation.datastore.application.domain.item, jp.co.intra_mart.foundation.datastore.application.domain.item_category, jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach, jp.co.intra_mart.foundation.datastore.application.domain.item_category.category, jp.co.intra_mart.foundation.datastore.application.domain.item_category.type, jp.co.intra_mart.foundation.datastore.application.domain.item_template, jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail, jp.co.intra_mart.foundation.datastore.application.domain.item_template.template, jp.co.intra_mart.foundation.datastore.application.domain.item.attribute, jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue, jp.co.intra_mart.foundation.datastore.application.domain.item.item, jp.co.intra_mart.foundation.datastore.application.domain.private_group, jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach, jp.co.intra_mart.foundation.datastore.application.domain.private_group.group, jp.co.intra_mart.foundation.datastore.application.domain.public_group, jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach, jp.co.intra_mart.foundation.datastore.application.domain.public_group.category, jp.co.intra_mart.foundation.datastore.application.domain.public_group.group, jp.co.intra_mart.foundation.datastore.application.domain.public_group.set, jp.co.intra_mart.foundation.datastore.application.domain.public_group.version, jp.co.intra_mart.foundation.datastore.application.domain.unit, jp.co.intra_mart.foundation.datastore.application.domain.user, jp.co.intra_mart.foundation.datastore.application.model.category.category_class, jp.co.intra_mart.foundation.datastore.application.model.category.detail, jp.co.intra_mart.foundation.datastore.application.model.company.attach, jp.co.intra_mart.foundation.datastore.application.model.company.category, jp.co.intra_mart.foundation.datastore.application.model.company.company, jp.co.intra_mart.foundation.datastore.application.model.company.department, jp.co.intra_mart.foundation.datastore.application.model.company.inclusion, jp.co.intra_mart.foundation.datastore.application.model.company.main, jp.co.intra_mart.foundation.datastore.application.model.company.post, jp.co.intra_mart.foundation.datastore.application.model.company.version, jp.co.intra_mart.foundation.datastore.application.model.deal.deal, jp.co.intra_mart.foundation.datastore.application.model.deal.department, jp.co.intra_mart.foundation.datastore.application.model.deal.detail, jp.co.intra_mart.foundation.datastore.application.model.deal.public_group, jp.co.intra_mart.foundation.datastore.application.model.deal.role, jp.co.intra_mart.foundation.datastore.application.model.item_category.attach, jp.co.intra_mart.foundation.datastore.application.model.item_category.category, jp.co.intra_mart.foundation.datastore.application.model.item_category.type, jp.co.intra_mart.foundation.datastore.application.model.item_template.detail, jp.co.intra_mart.foundation.datastore.application.model.item_template.template, jp.co.intra_mart.foundation.datastore.application.model.item.attribute, jp.co.intra_mart.foundation.datastore.application.model.item.catalogue, jp.co.intra_mart.foundation.datastore.application.model.item.item, jp.co.intra_mart.foundation.datastore.application.model.private_group.attach, jp.co.intra_mart.foundation.datastore.application.model.private_group.group, jp.co.intra_mart.foundation.datastore.application.model.public_group.attach, jp.co.intra_mart.foundation.datastore.application.model.public_group.category, jp.co.intra_mart.foundation.datastore.application.model.public_group.group, jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion, jp.co.intra_mart.foundation.datastore.application.model.public_group.set, jp.co.intra_mart.foundation.datastore.application.model.public_group.version, jp.co.intra_mart.foundation.datastore.application.model.unit, jp.co.intra_mart.foundation.datastore.application.model.user, jp.co.intra_mart.foundation.datastore.common.accessor, jp.co.intra_mart.foundation.datastore.common.config, jp.co.intra_mart.foundation.datastore.common.model, jp.co.intra_mart.foundation.datastore.common.structure, jp.co.intra_mart.foundation.datastore.exception, jp.co.intra_mart.foundation.datastore.exporter, jp.co.intra_mart.foundation.datastore.exporter.common.config, jp.co.intra_mart.foundation.datastore.exporter.company, jp.co.intra_mart.foundation.datastore.exporter.public_group, jp.co.intra_mart.foundation.datastore.exporter.user, jp.co.intra_mart.foundation.datastore.importer, jp.co.intra_mart.foundation.datastore.importer.common.config, jp.co.intra_mart.foundation.datastore.importer.company, jp.co.intra_mart.foundation.datastore.importer.public_group, jp.co.intra_mart.foundation.datastore.importer.user, jp.co.intra_mart.foundation.drawer, jp.co.intra_mart.foundation.exception, jp.co.intra_mart.foundation.graph, jp.co.intra_mart.foundation.http, jp.co.intra_mart.foundation.http.ajax, jp.co.intra_mart.foundation.image, jp.co.intra_mart.foundation.log, jp.co.intra_mart.foundation.mail, jp.co.intra_mart.foundation.mail.javamail, jp.co.intra_mart.foundation.mail.javamail.listener, jp.co.intra_mart.foundation.mail.javamail.listener.impl, jp.co.intra_mart.foundation.mail.javamail.model, jp.co.intra_mart.foundation.mail.javamail.property, jp.co.intra_mart.foundation.navigator, jp.co.intra_mart.foundation.page, jp.co.intra_mart.foundation.portal.common.encode, jp.co.intra_mart.foundation.portal.common.rss, jp.co.intra_mart.foundation.portal.general_purpose_portlet, jp.co.intra_mart.foundation.portal.general_purpose_portlet.model, jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider, jp.co.intra_mart.foundation.portal.portlet, jp.co.intra_mart.foundation.portal.portlet.model, jp.co.intra_mart.foundation.scenario, jp.co.intra_mart.foundation.security, jp.co.intra_mart.foundation.security.access, jp.co.intra_mart.foundation.security.account, jp.co.intra_mart.foundation.security.activesession, jp.co.intra_mart.foundation.security.admin, jp.co.intra_mart.foundation.security.batch, jp.co.intra_mart.foundation.security.calendar, jp.co.intra_mart.foundation.security.certification, jp.co.intra_mart.foundation.security.certification.ldap.extension, jp.co.intra_mart.foundation.security.cryption, jp.co.intra_mart.foundation.security.duplication, jp.co.intra_mart.foundation.security.exception, jp.co.intra_mart.foundation.security.filter, jp.co.intra_mart.foundation.security.group, jp.co.intra_mart.foundation.security.license, jp.co.intra_mart.foundation.security.menu, jp.co.intra_mart.foundation.security.message, jp.co.intra_mart.foundation.security.mobile, jp.co.intra_mart.foundation.security.password, jp.co.intra_mart.foundation.security.permission, jp.co.intra_mart.foundation.security.role, jp.co.intra_mart.foundation.security.servlet, jp.co.intra_mart.foundation.security.shortcut, jp.co.intra_mart.foundation.service.client, jp.co.intra_mart.foundation.service.client.application, jp.co.intra_mart.foundation.service.client.application.content, jp.co.intra_mart.foundation.service.client.batch, jp.co.intra_mart.foundation.service.client.file, jp.co.intra_mart.foundation.service.client.information, jp.co.intra_mart.foundation.service.client.manager, jp.co.intra_mart.foundation.service.provider, jp.co.intra_mart.foundation.service.provider.application, jp.co.intra_mart.foundation.service.provider.batch, jp.co.intra_mart.foundation.service.provider.file, jp.co.intra_mart.foundation.service.provider.information, jp.co.intra_mart.foundation.smtp, jp.co.intra_mart.foundation.update, jp.co.intra_mart.foundation.utility, jp.co.intra_mart.foundation.utility.charset, jp.co.intra_mart.foundation.utility.file, jp.co.intra_mart.foundation.utility.io, jp.co.intra_mart.foundation.utility.net, jp.co.intra_mart.foundation.utility.report, jp.co.intra_mart.jssp.net, jp.co.intra_mart.system.security.datastore.inf

クラス階層

  • class java.lang.Object
    • class java.util.AbstractCollection (implements java.util.Collection)
      • class java.util.AbstractList (implements java.util.List)
        • class java.util.ArrayList (implements java.lang.Cloneable, java.util.List, java.util.RandomAccess, java.io.Serializable)
          • class jp.co.intra_mart.foundation.http.MultipartFormData
    • class jp.co.intra_mart.foundation.drawer.AbstractDrawer (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.graph.BarGraphDrawer
      • class jp.co.intra_mart.foundation.graph.CircleGraphDrawer
      • class jp.co.intra_mart.foundation.graph.LineGraphDrawer
      • class jp.co.intra_mart.foundation.graph.PortFolioDrawer
      • class jp.co.intra_mart.foundation.graph.RadarChartDrawer
    • class jp.co.intra_mart.foundation.utility.AbstractDualComparator (implements jp.co.intra_mart.foundation.utility.DualComparator)
      • class jp.co.intra_mart.foundation.utility.MultiComparator
      • class jp.co.intra_mart.foundation.page.NodeTypeComparator
    • class jp.co.intra_mart.foundation.datastore.exporter.AbstractExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManagerClient (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient)
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter (implements javax.servlet.Filter)
      • class jp.co.intra_mart.foundation.security.filter.ActiveSessionFilter
      • class jp.co.intra_mart.foundation.security.filter.DuplicateLoginHandlingFilter
      • class jp.co.intra_mart.foundation.security.filter.InitialPageSessionHandlingFilter
      • class jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter
      • class jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter
    • class jp.co.intra_mart.foundation.datastore.importer.AbstractImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
      • class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManagerClient (implements jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient)
    • class java.util.AbstractMap (implements java.util.Map)
      • class jp.co.intra_mart.foundation.utility.FixedSizeMap
      • class java.util.HashMap (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class jp.co.intra_mart.foundation.http.CGIEnvironment
    • class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter (implements jp.co.intra_mart.foundation.utility.report.MessageReporter)
      • class jp.co.intra_mart.foundation.utility.report.FileReporter
      • class jp.co.intra_mart.foundation.utility.report.MultiCastReporter
      • class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter
    • class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor (implements jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor)
      • class jp.co.intra_mart.foundation.utility.net.SocketPool (implements jp.co.intra_mart.foundation.utility.net.SocketConnectionManager)
    • class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer (implements jp.co.intra_mart.foundation.page.TreeNodeContainer)
      • class jp.co.intra_mart.foundation.page.TreeBranch (implements jp.co.intra_mart.foundation.page.TreeNode)
      • class jp.co.intra_mart.foundation.page.TreeRoot (implements jp.co.intra_mart.foundation.page.TreeNodeProvider)
    • class jp.co.intra_mart.foundation.security.access.AccessController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.access.AccessControllerManager
    • class jp.co.intra_mart.foundation.security.permission.AccessControllerPermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.foundation.security.AccessSecurityManager
    • class jp.co.intra_mart.foundation.security.account.Account (implements jp.co.intra_mart.foundation.security.LocaleProvider, java.io.Serializable)
    • class jp.co.intra_mart.foundation.acssecurity.AccountManager
    • class jp.co.intra_mart.foundation.security.account.AccountManager
    • class jp.co.intra_mart.foundation.security.account.AccountRole (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.foundation.acssecurity.AcsData
    • class jp.co.intra_mart.foundation.security.activesession.ActiveSessionBindingListener (implements javax.servlet.http.HttpSessionBindingListener, java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.activesession.ActiveSessionManager
    • class jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.AdminMenuManager
    • class jp.co.intra_mart.foundation.security.permission.AdminMenuPermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.foundation.datastore.common.config.AttributeType (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.graph.BarGraphObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.batch.Batch (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.batch.BatchManager
    • class jp.co.intra_mart.foundation.security.calendar.CalendarInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarManager
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder
    • class jp.co.intra_mart.foundation.graph.CircleGraphObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.access.CompanyChangedControllerListener (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener)
    • class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener)
    • class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyExportManager (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManager)
    • class jp.co.intra_mart.foundation.datastore.importer.company.CompanyImportManager (implements jp.co.intra_mart.foundation.datastore.importer.ImportManager)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.exporter.company.CompanyPostExportManager (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManager)
    • class jp.co.intra_mart.foundation.datastore.importer.company.CompanyPostImportManager (implements jp.co.intra_mart.foundation.datastore.importer.ImportManager)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory
    • class jp.co.intra_mart.foundation.security.account.CsvAccountBackup (implements jp.co.intra_mart.foundation.security.account.AccountExporter, jp.co.intra_mart.foundation.security.account.AccountImporter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.currency.CurrencyManager
    • class jp.co.intra_mart.foundation.database.DatabaseColumn
    • class jp.co.intra_mart.foundation.database.DatabaseExport
    • class jp.co.intra_mart.foundation.database.DatabaseManager
    • class jp.co.intra_mart.foundation.database.DbManager
    • class jp.co.intra_mart.foundation.database.DBResultArrayAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultBigDecimalAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultBigIntAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultBinaryAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultBlobAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultBooleanAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultByteAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultClobAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultDateAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultDoubleAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultImTimestampAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultIntegerAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultNullAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultObjectAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultRealAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultRefAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultShortAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultStringAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultStructAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultTimeAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DBResultTimestampAdapter (implements jp.co.intra_mart.foundation.database.DBResultAdapter)
    • class jp.co.intra_mart.foundation.database.DbTypes
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.DealPermissionManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.common.config.DeleteType (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.DepartmentInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational (implements java.io.Serializable)
    • class java.util.Dictionary
      • class java.util.Hashtable (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class java.util.Properties
          • class jp.co.intra_mart.foundation.service.client.information.InitialFile
          • class jp.co.intra_mart.foundation.utility.ResourceBundleProperties
    • class jp.co.intra_mart.foundation.security.duplication.DuplicateLoginManager
    • class jp.co.intra_mart.foundation.utility.ErrorEvent
    • class jp.co.intra_mart.foundation.navigator.EventAccessInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.navigator.EventHistoryInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.navigator.EventNavigatorConst
    • class jp.co.intra_mart.foundation.navigator.EventNavigatorHandler
    • class jp.co.intra_mart.foundation.navigator.EventNavigatorManager
    • class jp.co.intra_mart.foundation.navigator.EventNavigatorPermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.foundation.utility.EventQueueController
    • class jp.co.intra_mart.foundation.page.EventScript
    • class jp.co.intra_mart.foundation.utility.report.EverydayConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.datastore.exporter.ExportManagerImpl (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManager)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap)
    • class jp.co.intra_mart.foundation.utility.net.ExtendedSocket
      • class jp.co.intra_mart.foundation.utility.net.SocketConnection
    • class jp.co.intra_mart.foundation.security.ExtendsImportManager
    • class jp.co.intra_mart.foundation.security.account.FavoriteMenu (implements java.io.Serializable)
    • class java.io.File (implements java.lang.Comparable, java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.file.Directory
        • class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
          • class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory
          • class jp.co.intra_mart.foundation.service.provider.file.StorageDirectory
          • class jp.co.intra_mart.foundation.service.provider.TemporaryDirectory
      • class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory
        • class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory
          • class jp.co.intra_mart.foundation.service.provider.HomeDirectory
      • class jp.co.intra_mart.foundation.utility.file.ExtendedFile
        • class jp.co.intra_mart.foundation.service.provider.TemporaryFile
    • class jp.co.intra_mart.foundation.http.FileSender
    • class jp.co.intra_mart.foundation.utility.report.FileSizeConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.datastore.exporter.Filter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.utility.FilterComparator (implements java.util.Comparator, java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.ReverseComparator
    • class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent (implements jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent)
    • class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter (implements jp.co.intra_mart.foundation.utility.report.MessageReporter)
      • class jp.co.intra_mart.foundation.utility.report.LineReportFilter
      • class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter (implements jp.co.intra_mart.foundation.utility.report.ReportLevel)
      • class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter
    • class jp.co.intra_mart.foundation.scenario.FunctionContainer
      • class jp.co.intra_mart.foundation.scenario.FunctionContainerFile
    • class jp.co.intra_mart.foundation.service.provider.GarbageController
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel (implements jp.co.intra_mart.foundation.datastore.common.model.BaseModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.InternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap)
    • class javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • class javax.servlet.http.HttpServlet (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet
        • class jp.co.intra_mart.foundation.security.servlet.LogoutServlet
        • class jp.co.intra_mart.foundation.security.servlet.MenuServlet
        • class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet
        • class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet
        • class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap)
    • class jp.co.intra_mart.jssp.net.GenericURLBuilder
      • class jp.co.intra_mart.jssp.net.URLBuilder
    • class jp.co.intra_mart.foundation.security.activesession.GroupActiveSessionRegister (implements jp.co.intra_mart.foundation.security.certification.SuperCertificationListener)
    • class jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener (implements jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener)
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
        • class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler
        • class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler
            • class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
          • class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
            • class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper (implements jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult)
    • class jp.co.intra_mart.foundation.service.client.information.Identifier
    • class jp.co.intra_mart.foundation.image.ImageIconInfo
    • class jp.co.intra_mart.foundation.image.ImageIconManager
    • class jp.co.intra_mart.foundation.image.ImageIconMessageBundle
    • class jp.co.intra_mart.foundation.http.ajax.ImAjaxUtil
    • class jp.co.intra_mart.foundation.datastore.importer.ImportManagerImpl (implements jp.co.intra_mart.foundation.datastore.importer.ImportManager)
    • class jp.co.intra_mart.system.mail.smtp.InetMail (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.smtp.Mail (implements jp.co.intra_mart.system.javascript.imapi.MailSendErrDef, java.io.Serializable)
    • class jp.co.intra_mart.foundation.commons.validation.InputCheck
    • class java.io.InputStream
      • class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream
      • class java.io.FilterInputStream
        • class jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream
        • class jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream
        • class jp.co.intra_mart.foundation.utility.io.XORInputStream
      • class jp.co.intra_mart.foundation.utility.io.HexInputStream
    • class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper (implements jp.co.intra_mart.foundation.datastore.common.model.Mapper)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttributeInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategoryInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.type.ItemCategoryType (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.ItemManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetailInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplateInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminableInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.unit.ItemUnitManager
    • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler
    • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl (implements jp.co.intra_mart.system.service.ApplicationInitializer)
    • class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender (implements jp.co.intra_mart.foundation.mail.MailSender)
    • class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoBuilder
    • class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPContextInfoModel
    • class jp.co.intra_mart.foundation.security.license.LicenseManager
    • class jp.co.intra_mart.foundation.datastore.common.config.LifetimeType
    • class jp.co.intra_mart.foundation.graph.LineGraphObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.utility.net.Localhost (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.utility.LockMonitor
    • class jp.co.intra_mart.foundation.acssecurity.Logingp
    • class jp.co.intra_mart.foundation.security.group.LoginGroup (implements jp.co.intra_mart.foundation.security.LocaleProvider, java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.group.LoginGroupManager
    • class jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent
    • class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener (implements jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener)
    • class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.common.model.MapperFactory
    • class jp.co.intra_mart.foundation.security.menu.MenuInclusion (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.MenuItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.MenuManager
    • class jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.foundation.security.menu.MenuTree (implements java.util.Comparator)
    • class jp.co.intra_mart.foundation.security.message.MessageManager
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginAuHdmlAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginDocomoMoveAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginJphoneAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginSoftBankAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil
    • class jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginVodafoneAnalyzer (implements jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider)
    • class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions
    • class jp.co.intra_mart.foundation.security.activesession.NavigatorInfo
    • class jp.co.intra_mart.foundation.navigator.NavigatorItem (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.navigator.EventItem
      • class jp.co.intra_mart.foundation.navigator.EventResultItem
      • class jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem
        • class jp.co.intra_mart.foundation.navigator.EventFlow
        • class jp.co.intra_mart.foundation.navigator.ResultPageItem
        • class jp.co.intra_mart.foundation.navigator.SelectItem
    • class jp.co.intra_mart.foundation.service.client.NetworkConnector (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.service.client.NetworkAgent (implements jp.co.intra_mart.foundation.service.client.ActionListener)
        • class jp.co.intra_mart.foundation.service.client.file.AbstractComponent (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.service.client.file.NetworkFile (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureDirectory)
        • class jp.co.intra_mart.foundation.service.client.information.ExternalMemory (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureFile)
        • class jp.co.intra_mart.foundation.service.client.information.Lock (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureDirectory)
        • class jp.co.intra_mart.foundation.service.client.information.PermanentFile (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureFile)
        • class jp.co.intra_mart.foundation.service.client.batch.Scheduler (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.service.client.manager.ServerConnector (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager
    • class jp.co.intra_mart.foundation.security.cryption.NoCryption (implements jp.co.intra_mart.foundation.security.cryption.Cryption)
    • class jp.co.intra_mart.foundation.page.NodeNameComparator (implements java.util.Comparator, java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin (implements jp.co.intra_mart.foundation.security.account.AccountPostWriterListener, jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener)
    • class java.lang.Number (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.Counter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class java.io.OutputStream
      • class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream
      • class java.io.FilterOutputStream
        • class jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.XOROutputStream
      • class jp.co.intra_mart.foundation.utility.io.HexOutputStream
    • class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider (implements jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider)
    • class jp.co.intra_mart.foundation.commons.ParameterManager
    • class jp.co.intra_mart.foundation.security.password.PasswordHistory
    • class jp.co.intra_mart.foundation.security.password.PasswordHistoryAccountChangedListener (implements jp.co.intra_mart.foundation.security.account.AccountChangedListener)
    • class jp.co.intra_mart.foundation.security.password.PasswordHistoryManager
    • class jp.co.intra_mart.foundation.security.password.PasswordHistoryManagerInitializerImpl (implements jp.co.intra_mart.system.service.ApplicationInitializer)
    • class jp.co.intra_mart.foundation.security.password.PasswordHistoryNewArrivedProvider (implements jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider)
    • class jp.co.intra_mart.foundation.security.password.PasswordHistoryResult
    • class jp.co.intra_mart.foundation.utility.report.PeriodicConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory (implements jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent)
    • class jp.co.intra_mart.foundation.security.permission.PermissionManager
    • class jp.co.intra_mart.foundation.service.provider.Platform
    • class jp.co.intra_mart.foundation.graph.PortFolioObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.portal.portlet.model.Portlet (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet
        • class jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet
        • class jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet
      • class jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet
        • class jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet
        • class jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet
        • class jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet
    • class jp.co.intra_mart.foundation.portal.portlet.PortletManager
    • class jp.co.intra_mart.foundation.portal.portlet.PortletMapping
    • class jp.co.intra_mart.foundation.security.PostInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.scenario.PresentationPage
    • class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.access.PublicGroupChangedControllerListener (implements jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener)
    • class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener (implements jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener)
    • class jp.co.intra_mart.foundation.datastore.exporter.public_group.PublicGroupExportManager (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManager)
    • class jp.co.intra_mart.foundation.datastore.importer.public_group.PublicGroupImportManager (implements jp.co.intra_mart.foundation.datastore.importer.ImportManager)
    • class jp.co.intra_mart.foundation.security.PublicGroupInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.graph.RadarChartObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.role.Role (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener (implements jp.co.intra_mart.foundation.security.role.RoleChangedListener)
    • class jp.co.intra_mart.foundation.security.access.RoleChangedControllerListener (implements jp.co.intra_mart.foundation.security.role.RoleChangedListener)
    • class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener (implements jp.co.intra_mart.foundation.security.role.RoleChangedListener)
    • class jp.co.intra_mart.foundation.acssecurity.RoleManager
    • class jp.co.intra_mart.foundation.security.role.RoleManager
    • class jp.co.intra_mart.foundation.navigator.SaveEventHistoryInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.utility.SequenceComparator (implements java.util.Comparator, java.io.Serializable)
    • class jp.co.intra_mart.foundation.service.client.information.SessionFactory (implements jp.co.intra_mart.foundation.service.client.information.TreasureDirectory)
    • class jp.co.intra_mart.foundation.security.filter.SessionFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.foundation.service.client.information.SessionMemory (implements jp.co.intra_mart.foundation.service.client.information.TreasureFile)
    • class jp.co.intra_mart.foundation.http.SessionQuery
    • class jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.shortcut.ShortCutManager
    • class jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory
    • class jp.co.intra_mart.foundation.commons.SourceProviderHandler
    • class jp.co.intra_mart.foundation.security.StandardAccessControllerAccessor (implements jp.co.intra_mart.foundation.security.access.AccessControllerAccessor)
    • class jp.co.intra_mart.foundation.security.access.StandardAccessControllerBackup (implements jp.co.intra_mart.foundation.security.access.AccessControllerExporter, jp.co.intra_mart.foundation.security.access.AccessControllerImporter)
    • class jp.co.intra_mart.foundation.security.StandardAccountAccessor (implements jp.co.intra_mart.foundation.security.account.AccountAccessor)
    • class jp.co.intra_mart.foundation.security.account.StandardAccountBackup (implements jp.co.intra_mart.foundation.security.account.AccountExporter, jp.co.intra_mart.foundation.security.account.AccountImporter)
    • class jp.co.intra_mart.foundation.security.activesession.StandardActiveSessionAccessor (implements jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor)
    • class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup (implements jp.co.intra_mart.foundation.security.menu.AdminMenuExporter, jp.co.intra_mart.foundation.security.menu.AdminMenuImporter)
    • class jp.co.intra_mart.foundation.security.StandardBatchAccessor (implements jp.co.intra_mart.foundation.security.batch.BatchAccessor)
    • class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup (implements jp.co.intra_mart.foundation.security.batch.BatchExporter, jp.co.intra_mart.foundation.security.batch.BatchImporter)
    • class jp.co.intra_mart.foundation.security.StandardCalendarAccessor (implements jp.co.intra_mart.foundation.security.calendar.CalendarAccessor)
    • class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup (implements jp.co.intra_mart.foundation.security.calendar.CalendarExporter, jp.co.intra_mart.foundation.security.calendar.CalendarImporter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter)
    • class jp.co.intra_mart.foundation.security.cryption.StandardCryption (implements jp.co.intra_mart.foundation.security.cryption.Cryption)
    • class jp.co.intra_mart.foundation.security.duplication.StandardDuplicateLoginAccessor (implements jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor)
    • class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider (implements jp.co.intra_mart.foundation.security.certification.ErrorPageProvider)
    • class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorAccessor (implements jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor)
    • class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorExporter (implements jp.co.intra_mart.foundation.navigator.EventNavigatorExporter)
    • class jp.co.intra_mart.foundation.navigator.StandardEventNavigatorImporter (implements jp.co.intra_mart.foundation.navigator.EventNavigatorImporter)
    • class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider (implements jp.co.intra_mart.foundation.security.certification.UserPageProvider)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemAttachImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemAttachImporter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_category.StandardItemCategoryImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryImporter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item.StandardItemImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.item.ItemImporter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.item_template.StandardItemTemplateImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateImporter)
    • class jp.co.intra_mart.foundation.mail.javamail.StandardMail
    • class jp.co.intra_mart.foundation.security.StandardMenuAccessor (implements jp.co.intra_mart.foundation.security.menu.MenuAccessor)
    • class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup (implements jp.co.intra_mart.foundation.security.menu.MenuExporter, jp.co.intra_mart.foundation.security.menu.MenuImporter)
    • class jp.co.intra_mart.foundation.security.password.StandardPasswordHistoryAccessor (implements jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter)
    • class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer (implements jp.co.intra_mart.foundation.security.certification.RequestAnalyzer)
      • class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer
    • class jp.co.intra_mart.foundation.security.StandardRoleAccessor (implements jp.co.intra_mart.foundation.security.role.RoleAccessor)
    • class jp.co.intra_mart.foundation.security.role.StandardRoleBackup (implements jp.co.intra_mart.foundation.security.role.RoleExporter, jp.co.intra_mart.foundation.security.role.RoleImporter)
    • class jp.co.intra_mart.foundation.security.shortcut.StandardShortCutAccessor (implements jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor)
    • class jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification (implements jp.co.intra_mart.foundation.security.certification.SuperCertification)
    • class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider (implements jp.co.intra_mart.foundation.security.certification.UserPageProvider)
    • class jp.co.intra_mart.foundation.update.StandardUpdateAccessor (implements jp.co.intra_mart.foundation.update.UpdateAccessor)
    • class jp.co.intra_mart.foundation.security.certification.StandardUserCertification (implements jp.co.intra_mart.foundation.security.certification.UserCertification)
      • class jp.co.intra_mart.foundation.security.certification.LDAPUserCertification
      • class jp.co.intra_mart.foundation.security.certification.ldap.extension.LDAPUserCertification
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter)
    • class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider (implements jp.co.intra_mart.foundation.security.certification.UserPageProvider)
      • class jp.co.intra_mart.foundation.security.certification.PortalStandardUserPageProvider
        • class jp.co.intra_mart.foundation.security.password.PasswordHistoryUserPageProvider
    • class jp.co.intra_mart.foundation.security.admin.SuperUser (implements jp.co.intra_mart.foundation.security.LocaleProvider, java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification (implements jp.co.intra_mart.foundation.security.certification.SuperCertification)
    • class jp.co.intra_mart.foundation.security.SystemManager
    • class jp.co.intra_mart.foundation.datastore.common.structure.Term (implements java.lang.Comparable, java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.common.structure.TermManager
    • class java.lang.Thread (implements java.lang.Runnable)
      • class jp.co.intra_mart.foundation.utility.ExtendedThread
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.acssecurity.AcssecurityException
        • class jp.co.intra_mart.foundation.database.exception.DatabaseExportException
        • class jp.co.intra_mart.foundation.exception.FoundationException
          • class jp.co.intra_mart.foundation.security.exception.AccessSecurityException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException
              • class jp.co.intra_mart.foundation.security.exception.DuplicateException
              • class jp.co.intra_mart.foundation.security.exception.NotExistException
              • class jp.co.intra_mart.foundation.security.exception.NotSupportMethodException
            • class jp.co.intra_mart.foundation.security.exception.ActiveSessionException
              • class jp.co.intra_mart.foundation.security.exception.ActiveSessionInvalidatedByForceException
              • class jp.co.intra_mart.foundation.security.exception.ActiveSessionNotExistException
            • class jp.co.intra_mart.foundation.security.exception.DuplicateLoginException
              • class jp.co.intra_mart.foundation.security.exception.DuplicateLoginDetectedException
            • class jp.co.intra_mart.foundation.security.exception.IllegalArgumentException
            • class jp.co.intra_mart.foundation.security.exception.NoFilterException
            • class jp.co.intra_mart.foundation.security.exception.NoSessionCookieException
            • class jp.co.intra_mart.foundation.security.exception.NoSessionException
            • class jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException
          • class jp.co.intra_mart.foundation.exception.ChangedListenerException
          • class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
            • class jp.co.intra_mart.foundation.datastore.exception.AccessorException
              • class jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException
              • class jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException
              • class jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException
                • class jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException
                • class jp.co.intra_mart.foundation.datastore.exception.IllegalTermException
              • class jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException
            • class jp.co.intra_mart.foundation.navigator.EventNavigatorException
            • class jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException
            • class jp.co.intra_mart.foundation.datastore.exception.ManagerException
            • class jp.co.intra_mart.foundation.datastore.exception.MapperException
            • class jp.co.intra_mart.foundation.datastore.exception.TermManagerException
          • class jp.co.intra_mart.foundation.image.ImageIconException
            • class jp.co.intra_mart.foundation.image.DuplicateImageIconCodeException
            • class jp.co.intra_mart.foundation.image.DuplicateImageIconSrcException
            • class jp.co.intra_mart.foundation.image.NotExistImageIconException
          • class jp.co.intra_mart.foundation.security.password.PasswordHistoryException
        • class jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException
        • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException
          • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException
        • class jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException
        • class jp.co.intra_mart.foundation.datastore.exception.ImportException
        • class java.io.IOException
          • class jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException
        • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException
        • class jp.co.intra_mart.foundation.mail.MailSenderException
        • class jp.co.intra_mart.foundation.scenario.NoSuchPropertyException
        • class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException
          • class jp.co.intra_mart.foundation.utility.charset.ResourceFormatException
        • class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException
          • class jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.datastore.exception.BatchProcessException
            • class jp.co.intra_mart.foundation.datastore.exporter.ExportInitializeException
              • class jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReaderException
            • class jp.co.intra_mart.foundation.datastore.importer.ImportInitializeException
              • class jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReaderException
          • class jp.co.intra_mart.foundation.datastore.exception.BatchSystemException
          • class jp.co.intra_mart.foundation.exception.FoundationRuntimeException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException
              • class jp.co.intra_mart.foundation.security.exception.SystemConfigException
            • class jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException
              • class jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException
              • class jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException
              • class jp.co.intra_mart.foundation.datastore.exception.MapperDAOException
          • class jp.co.intra_mart.foundation.portal.portlet.PortletManagerException
        • class jp.co.intra_mart.foundation.scenario.ScriptCompileException
        • class jp.co.intra_mart.foundation.scenario.ScriptRuntimeException
        • class java.sql.SQLException
          • class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException
    • class jp.co.intra_mart.foundation.navigator.TitleInfo (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.navigator.EventFlowInfo
      • class jp.co.intra_mart.foundation.navigator.EventItemInfo
      • class jp.co.intra_mart.foundation.navigator.EventResultItemInfo
      • class jp.co.intra_mart.foundation.navigator.LinkPageInfo
      • class jp.co.intra_mart.foundation.navigator.ResultPageItemInfo
      • class jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo
      • class jp.co.intra_mart.foundation.navigator.SelectItemInfo
    • class jp.co.intra_mart.foundation.page.TreeLeaf (implements jp.co.intra_mart.foundation.page.TreeNode)
    • class jp.co.intra_mart.foundation.update.UpdateManager
    • class jp.co.intra_mart.foundation.security.filter.URLAccessFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.User (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.activesession.UserActiveSessionRegister (implements jp.co.intra_mart.foundation.security.certification.UserCertificationListener)
    • class jp.co.intra_mart.foundation.datastore.exporter.user.UserAttachExportManager (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManager)
    • class jp.co.intra_mart.foundation.datastore.importer.user.UserAttachImportManager (implements jp.co.intra_mart.foundation.datastore.importer.ImportManager)
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager
    • class jp.co.intra_mart.foundation.datastore.exporter.user.UserProfileExportManager (implements jp.co.intra_mart.foundation.datastore.exporter.ExportManager)
    • class jp.co.intra_mart.foundation.datastore.importer.user.UserProfileImportManager (implements jp.co.intra_mart.foundation.datastore.importer.ImportManager)
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational (implements java.io.Serializable)
    • class java.io.Writer
      • class java.io.FilterWriter
        • class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter
      • class jp.co.intra_mart.foundation.utility.io.ReplaceWriter
      • class jp.co.intra_mart.foundation.utility.report.ReportFileWriter

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.access.AccessControllerAccessor
  • interface jp.co.intra_mart.foundation.security.access.AccessControllerExporter
  • interface jp.co.intra_mart.foundation.security.access.AccessControllerImporter
  • interface jp.co.intra_mart.foundation.security.access.AccessControllerPostWriterListener
  • interface jp.co.intra_mart.foundation.security.access.AccessControllerQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.access.AccessControllerReaderDecorator
  • interface jp.co.intra_mart.foundation.security.account.AccountAccessor
  • interface jp.co.intra_mart.foundation.security.account.AccountChangedListener
  • interface jp.co.intra_mart.foundation.security.account.AccountExporter
  • interface jp.co.intra_mart.foundation.security.account.AccountImporter
  • interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener
  • interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.account.AccountReaderDecorator
  • interface jp.co.intra_mart.foundation.datastore.common.config.ActivationKey
  • interface jp.co.intra_mart.foundation.security.activesession.ActiveSessionAccessor
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuExporter
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuImporter
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator
  • interface jp.co.intra_mart.foundation.datastore.common.config.Application
  • interface jp.co.intra_mart.foundation.security.license.ApplicationInfo
  • interface jp.co.intra_mart.foundation.mail.javamail.model.AttachmentFile
  • interface jp.co.intra_mart.foundation.datastore.common.config.Attribute
  • interface jp.co.intra_mart.foundation.datastore.common.config.BaseModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext
  • interface jp.co.intra_mart.foundation.datastore.common.config.BaseTable
  • interface jp.co.intra_mart.foundation.security.batch.BatchAccessor
  • interface jp.co.intra_mart.foundation.security.batch.BatchExporter
  • interface jp.co.intra_mart.foundation.security.batch.BatchImporter
  • interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener
  • interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarExporter
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarImporter
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarPlugin
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator
  • interface jp.co.intra_mart.foundation.security.ClientTypeInfo
  • interface jp.co.intra_mart.foundation.security.ColorPatternInfo
  • interface jp.co.intra_mart.foundation.datastore.common.config.Column
  • interface jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping
  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener
  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter
  • interface java.util.Comparator
    • interface jp.co.intra_mart.foundation.utility.DualComparator (同様に extends java.io.Serializable)
  • interface jp.co.intra_mart.foundation.datastore.common.config.Configuration
  • interface jp.co.intra_mart.foundation.database.ConInfo
  • interface java.sql.Connection
    • interface jp.co.intra_mart.foundation.database.DbsConnection
  • interface jp.co.intra_mart.foundation.security.cryption.Cryption
  • interface jp.co.intra_mart.foundation.database.DatabaseAccessor
  • interface jp.co.intra_mart.foundation.database.DataSourceProvider
  • interface jp.co.intra_mart.foundation.security.calendar.DayInfo
  • interface jp.co.intra_mart.foundation.database.DBResultAdapter
  • interface jp.co.intra_mart.foundation.datastore.common.config.Delete
  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct
  • interface jp.co.intra_mart.foundation.security.duplication.DuplicateLoginAccessor
  • interface jp.co.intra_mart.foundation.portal.common.encode.EnCodeInterface
  • interface jp.co.intra_mart.foundation.datastore.common.config.Entity
  • interface jp.co.intra_mart.foundation.service.provider.Environment
  • interface jp.co.intra_mart.foundation.utility.ErrorEventListener
  • interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider
  • interface jp.co.intra_mart.foundation.utility.EventListener
  • interface jp.co.intra_mart.foundation.navigator.EventNavigatorAccessor
  • interface jp.co.intra_mart.foundation.navigator.EventNavigatorExporter
  • interface jp.co.intra_mart.foundation.navigator.EventNavigatorImporter
  • interface jp.co.intra_mart.foundation.navigator.EventNavigatorReaderDecorator
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey
  • interface jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReader
  • interface jp.co.intra_mart.foundation.datastore.exporter.ExportManager
  • interface jp.co.intra_mart.foundation.datastore.exporter.ExportManagerClient
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable
  • interface jp.co.intra_mart.foundation.security.ExtendsImport
  • interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain
  • interface jp.co.intra_mart.foundation.service.provider.GCConditioner
  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor
  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener
  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext
  • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult
    • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent
    • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL
  • interface jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReader
  • interface jp.co.intra_mart.foundation.datastore.importer.ImportManager
  • interface jp.co.intra_mart.foundation.datastore.importer.ImportManagerClient
  • interface jp.co.intra_mart.foundation.security.INonTransaction
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.InternationalKey
  • interface jp.co.intra_mart.foundation.datastore.common.config.InternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext
  • interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable
  • interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemAttachImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.item.ItemCatalogueMediaManager
  • interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.item_category.ItemCategoryStruct
  • interface jp.co.intra_mart.foundation.datastore.application.domain.item.ItemImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.item_template.ItemTemplateImporter
  • interface jp.co.intra_mart.foundation.datastore.common.config.Lifetime
  • interface jp.co.intra_mart.foundation.security.LocaleProvider
    • interface jp.co.intra_mart.foundation.security.LocaleInfo
    • interface jp.co.intra_mart.foundation.security.certification.LoginInfo
      • interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo
    • interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo
    • interface jp.co.intra_mart.foundation.security.SessionInfo
  • interface jp.co.intra_mart.foundation.log.LogConstraint
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator
  • interface jp.co.intra_mart.foundation.security.servlet.LogoutInitialUrlValidator
  • interface jp.co.intra_mart.foundation.mail.javamail.model.MailAddress
  • interface jp.co.intra_mart.foundation.mail.MailSender
  • interface jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener
  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccountMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.BatchMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuPostMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.RoleMapper
    • interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper
  • interface jp.co.intra_mart.foundation.security.menu.MenuAccessor
  • interface jp.co.intra_mart.foundation.security.menu.MenuExporter
  • interface jp.co.intra_mart.foundation.security.menu.MenuImporter
  • interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator
  • interface jp.co.intra_mart.foundation.utility.report.MessageReporter
  • interface jp.co.intra_mart.foundation.security.mobile.MobileUserAgentProvider
  • interface jp.co.intra_mart.foundation.datastore.common.config.Model
  • interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity
  • interface jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider
  • interface jp.co.intra_mart.foundation.commons.ParameterSourceProvider
  • interface jp.co.intra_mart.foundation.security.password.PasswordHistoryAccessor
  • interface jp.co.intra_mart.foundation.security.permission.PermissionSelector
  • interface jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping
  • interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener
  • interface jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent
  • interface jp.co.intra_mart.foundation.datastore.common.config.Property
  • interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener
  • interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct
  • interface jp.co.intra_mart.foundation.datastore.common.config.Relationship
  • interface jp.co.intra_mart.foundation.utility.report.ReportFileConditioner
  • interface jp.co.intra_mart.foundation.utility.report.ReportLevel
  • interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer
  • interface jp.co.intra_mart.foundation.security.role.RoleAccessor
  • interface jp.co.intra_mart.foundation.security.role.RoleChangedListener
  • interface jp.co.intra_mart.foundation.security.role.RoleExporter
  • interface jp.co.intra_mart.foundation.security.role.RoleImporter
  • interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener
  • interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.role.RoleReaderDecorator
  • interface jp.co.intra_mart.foundation.portal.common.rss.RSSParserIF
  • interface jp.co.intra_mart.foundation.scenario.ScriptValue
    • interface jp.co.intra_mart.foundation.scenario.VariableScope
  • interface jp.co.intra_mart.foundation.security.SecurityConstraint
  • interface java.io.Serializable
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel
    • interface jp.co.intra_mart.foundation.service.client.ActionListener
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerDepartmentBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPostBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerPublicGroupBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccessControllerRoleBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccountAttributeBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccountBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.AccountRoleBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel
      • interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.BatchBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.DataStoreConst
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.department.DealerDepartmentBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.public_group.DealerPublicGroupBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.role.DealerRoleBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel
    • interface jp.co.intra_mart.foundation.utility.DualComparator (同様に extends java.util.Comparator)
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel
    • interface jp.co.intra_mart.system.security.datastore.inf.FavoriteMenuBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel
      • interface jp.co.intra_mart.system.security.datastore.inf.CalendarInfoInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateInternationalModel
      • interface jp.co.intra_mart.system.security.datastore.inf.MenuInternationalModel
      • interface jp.co.intra_mart.system.security.datastore.inf.RoleInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.attach.ItemAttachBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item.attribute.ItemAttributeInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item.catalogue.ItemCatalogueBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.category.ItemCategoryInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_category.type.ItemCategoryTypeBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.detail.ItemTemplateDetailInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item_template.template.ItemTemplateInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuArgumentBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuDepartmentBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuInternationalModel
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuPostBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuPublicGroupBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.MenuRoleBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost
    • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.RoleBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.RoleInclusionBaseModel
    • interface jp.co.intra_mart.system.security.datastore.inf.RoleInternationalModel
    • interface jp.co.intra_mart.system.security.datastore.inf.RoleSummaryBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.detail.DealDetailTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.deal.deal.DealTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.item.item.ItemTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap
    • interface jp.co.intra_mart.foundation.datastore.application.model.unit.UnitBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel
  • interface jp.co.intra_mart.foundation.security.SessionConfig
  • interface jp.co.intra_mart.foundation.security.shortcut.ShortCutAccessor
  • interface jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor
    • interface jp.co.intra_mart.foundation.utility.net.SocketConnectionManager
  • interface jp.co.intra_mart.foundation.utility.net.SocketEventListener
  • interface jp.co.intra_mart.foundation.security.certification.SuperCertification
  • interface jp.co.intra_mart.foundation.security.certification.SuperCertificationListener
  • interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor
  • interface jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener
  • interface jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator
  • interface jp.co.intra_mart.foundation.service.provider.SystemReporter
    • interface jp.co.intra_mart.foundation.service.provider.SystemErrorReporter
  • interface jp.co.intra_mart.foundation.security.SystemSourceProvider
  • interface jp.co.intra_mart.foundation.datastore.common.config.Table
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableKey
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable
  • interface jp.co.intra_mart.foundation.utility.ThreadStopListener
  • interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory
  • interface jp.co.intra_mart.foundation.service.client.information.TreasureFile
  • interface jp.co.intra_mart.foundation.page.TreeNode
  • interface jp.co.intra_mart.foundation.page.TreeNodeContainer
    • interface jp.co.intra_mart.foundation.page.TreeNodeProvider
  • interface jp.co.intra_mart.foundation.update.UpdateAccessor
  • interface jp.co.intra_mart.foundation.datastore.common.config.UpdateInfo
  • interface jp.co.intra_mart.foundation.security.certification.UserCertification
  • interface jp.co.intra_mart.foundation.security.certification.UserCertificationListener
  • interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener
  • interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter
  • interface jp.co.intra_mart.foundation.security.certification.UserPageProvider
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


(javadoc_foundation 6.1.14 API)

フロントページが変更されました。次を参照してください:
フレームありのバージョン
フレームなしのバージョン


直列化された形式 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.foundation.acssecurity

クラス jp.co.intra_mart.foundation.acssecurity.AcssecurityException は Exception を拡張し、Serializable を実装しています

直列化されたフィールド

message

String message

code

int code

パッケージ jp.co.intra_mart.foundation.database.exception

クラス jp.co.intra_mart.foundation.database.exception.DatabaseExportException は Exception を拡張し、Serializable を実装しています

直列化されたフィールド

errorType

int errorType
推奨されていません。

クラス jp.co.intra_mart.foundation.database.exception.DatabaseSQLException は SQLException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.category_class

クラス jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass は Object を拡張し、Serializable を実装しています

直列化されたフィールド

categoryClassCode

String categoryClassCode
分類区分コード

notes

String notes
備考

defaultLocale

Locale defaultLocale
デフォルトのロケール

internationals

Map internationals
分類区分の国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
分類区分名

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.detail

クラス jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail は Object を拡張し、Serializable を実装しています

直列化されたフィールド

categoryClassCode

String categoryClassCode
分類区分コード

categoryCode

String categoryCode
分類コード

notes

String notes
備考

defaultLocale

Locale defaultLocale
デフォルトのロケール

internationals

Map internationals
分類区分詳細の国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
分類名

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.attach

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach は Object を拡張し、Serializable を実装しています

直列化されたフィールド

userCode

String userCode
ユーザコード

companyCode

String companyCode
会社コード

departmentCode

String departmentCode
組織コード

sortKey

int sortKey
ソートキー

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
組織所属の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

postCode

String postCode
役職CD

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.category

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

departmentCode

String departmentCode
組織コード

categoryClassCode

String categoryClassCode
分類区分コード

categoryCode

String categoryCode
分類コード

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
会社組織分類の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.company

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

notes

String notes
備考

sortKey

int sortKey
ソートキー

defaultLocale

Locale defaultLocale
デフォルトのロケール

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
会社の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

telephoneNumber

String telephoneNumber
電話番号

faxNumber

String faxNumber
FAX番号

extensionNumber

String extensionNumber
内線番号

extensionFaxNumber

String extensionFaxNumber
内線FAX番号

countryCode

String countryCode
国コード

zipCode

String zipCode
郵便番号

emailAddress1

String emailAddress1
メールアドレス1

emailAddress2

String emailAddress2
メールアドレス2

url

String url
URL

terminableInternationals

Map terminableInternationals
会社の期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
組織名

nameSyllabary

String nameSyllabary
組織名カナ

nameEnglish

String nameEnglish
組織名英字

address1

String address1
住所1

address2

String address2
住所2

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.department

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

departmentCode

String departmentCode
組織コード

notes

String notes
備考

sortKey

int sortKey
ソートキー

defaultLocale

Locale defaultLocale
デフォルトのロケール

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
組織の期間化に関連する情報のマップ

extendedDtos

Map extendedDtos
組織の基本情報に対する拡張情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

telephoneNumber

String telephoneNumber
電話番号

faxNumber

String faxNumber
FAX番号

extensionNumber

String extensionNumber
内線番号

extensionFaxNumber

String extensionFaxNumber
内線FAX番号

countryCode

String countryCode
国コード

zipCode

String zipCode
郵便番号

emailAddress1

String emailAddress1
メールアドレス1

emailAddress2

String emailAddress2
メールアドレス2

url

String url
URL

extendedDtos

Map extendedDtos
組織の期間化情報に対する拡張情報のマップ

terminableInternationals

Map terminableInternationals
組織の期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
組織名

nameSyllabary

String nameSyllabary
組織名カナ

nameEnglish

String nameEnglish
組織名英字

address1

String address1
住所1

address2

String address2
住所2

extendedDtos

Map extendedDtos
組織の期間国際化情報に対する拡張情報のマップ

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.main

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain は Object を拡張し、Serializable を実装しています

直列化されたフィールド

userCode

String userCode
ユーザコード

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
主所属の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

departmentCode

String departmentCode
組織コード

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.post

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

postCode

String postCode
役職コード

notes

String notes
備考

sortKey

int sortKey
ソートキー

defaultLocale

Locale defaultLocale
デフォルトのロケール

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
役職の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

terminableInternationals

Map terminableInternationals
役職の期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
役職名

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.version

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

versionCode

String versionCode
バージョンコード

startDate

Date startDate
開始日

endDate

Date endDate
終了日

notes

String notes
備考

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.deal

クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.Deal は Object を拡張し、Serializable を実装しています

直列化されたフィールド

customerCompanyCode

String customerCompanyCode
取引先会社コード

customerDepartmentCode

String customerDepartmentCode
取引先組織コード

dealCode

String dealCode
取扱コード

dealName

String dealName
取扱名

dealType

int dealType
取扱種別

currencyCode

String currencyCode
通貨コード

notes

String notes
備考

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
取扱の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.deal.DealTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

unitPrice

double unitPrice
単価

detailMap

Map detailMap
詳細の集合

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.department

クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.department.DealerDepartment は Object を拡張し、Serializable を実装しています

直列化されたフィールド

customerCompanyCode

String customerCompanyCode
取引先会社コード

customerDepartmentCode

String customerDepartmentCode
取引先組織コード

dealCode

String dealCode
取扱コード

companyCode

String companyCode
会社コード

departmentCode

String departmentCode
組織コード

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.detail

クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.detail.DealDetail は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itemCode

String itemCode
商品コード

unitCode

String unitCode
単位コード

amount

int amount
数量

unitPrice

double unitPrice
単価

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group

クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.public_group.DealerPublicGroup は Object を拡張し、Serializable を実装しています

直列化されたフィールド

customerCompanyCode

String customerCompanyCode
取引先会社コード

customerDepartmentCode

String customerDepartmentCode
取引先組織コード

dealCode

String dealCode
取扱コード

publicGroupSetCode

String publicGroupSetCode
グループセットコード

publicGroupCode

String publicGroupCode
グループコード

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.deal.role

クラス jp.co.intra_mart.foundation.datastore.application.domain.deal.role.DealerRole は Object を拡張し、Serializable を実装しています

直列化されたフィールド

customerCompanyCode

String customerCompanyCode
取引先会社コード

customerDepartmentCode

String customerDepartmentCode
取引先組織コード

dealCode

String dealCode
取扱コード

roleId

String roleId
ロールID

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.attribute

クラス jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttribute は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itemCode

String itemCode
商品コード

templateCode

String templateCode
テンプレートコード

templateDetailCode

String templateDetailCode
テンプレート明細コード

numberValue

double numberValue
属性数値

defaultLocale

Locale defaultLocale
デフォルトのロケール

internationals

Map internationals
商品属性の国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.item.attribute.ItemAttributeInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

stringValue

String stringValue
属性文字列

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue

クラス jp.co.intra_mart.foundation.datastore.application.domain.item.catalogue.ItemCatalogue は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itemCode

String itemCode
商品コード

itemCatalogueCode

String itemCatalogueCode
商品カタログコード

mediaCls

int mediaCls
媒体種類

media

String media
媒体

notes

String notes
備考

sortKey

int sortKey
ソートキー

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item.item

クラス jp.co.intra_mart.foundation.datastore.application.domain.item.item.Item は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itemCode

String itemCode
商品コード

productModelCode

String productModelCode
製品型番

notes

String notes
備考

defaultLocale

Locale defaultLocale
デフォルトのロケール

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
商品の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

salesUnitPrice

double salesUnitPrice
販売単価

purchaseUnitPrice

double purchaseUnitPrice
仕入単価

terminableInternationals

Map terminableInternationals
商品の期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.item.item.ItemTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itemName

String itemName
商品名

itemCaption

String itemCaption
商品通称

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach

クラス jp.co.intra_mart.foundation.datastore.application.domain.item_category.attach.ItemAttach は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itemCategoryTypeCode

String itemCategoryTypeCode
商品カテゴリ種別コード

itemCategoryCode

String itemCategoryCode
商品カテゴリコード

itemCode

String itemCode
商品コード

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.category

クラス jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategory は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itemCategoryTypeCode

String itemCategoryTypeCode
商品カテゴリ種別コード

itemCategoryCode

String itemCategoryCode
商品カテゴリコード

parentItemCategoryCode

String parentItemCategoryCode
親商品カテゴリコード

notes

String notes
備考

sortKey

int sortKey
ソートキー

defaultLocale

Locale defaultLocale
デフォルトのロケール

internationals

Map internationals
商品カテゴリの国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.item_category.category.ItemCategoryInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itemCategoryName

String itemCategoryName
商品カテゴリ名

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_category.type

クラス jp.co.intra_mart.foundation.datastore.application.domain.item_category.type.ItemCategoryType は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itemCategoryTypeCode

String itemCategoryTypeCode
商品カテゴリ種別コード

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail

クラス jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetail は Object を拡張し、Serializable を実装しています

直列化されたフィールド

templateCode

String templateCode
テンプレートコード

templateDetailCode

String templateDetailCode
テンプレート明細コード

dataType

int dataType
データ型

sortKey

int sortKey
ソートキー

notes

String notes
備考

defaultLocale

Locale defaultLocale
デフォルトのロケール

internationals

Map internationals
商品属性テンプレート明細の国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.item_template.detail.ItemTemplateDetailInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

templateDetailName

String templateDetailName
テンプレート明細名

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.item_template.template

クラス jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplate は Object を拡張し、Serializable を実装しています

直列化されたフィールド

templateCode

String templateCode
テンプレートコード

templateName

String templateName
テンプレート名

notes

String notes
備考

クラス jp.co.intra_mart.foundation.datastore.application.domain.item_template.template.ItemTemplateInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

templateName

String templateName
テンプレート名

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach

クラス jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach は Object を拡張し、Serializable を実装しています

直列化されたフィールド

ownerCode

String ownerCode
所有者コード

privateGroupCode

String privateGroupCode
グループコード

userCode

String userCode
ユーザコード

sortKey

int sortKey
ソートキー

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.group

クラス jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup は Object を拡張し、Serializable を実装しています

直列化されたフィールド

ownerCode

String ownerCode
所有者コード

privateGroupCode

String privateGroupCode
グループコード

name

String name
グループ名

nameSyllabary

String nameSyllabary
グループ名カナ

nameEnglish

String nameEnglish
グループ名英字

notes

String notes
備考

sortKey

int sortKey
ソートキー

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach は Object を拡張し、Serializable を実装しています

直列化されたフィールド

userCode

String userCode
ユーザコード

publicGroupSetCode

String publicGroupSetCode
グループセットコード

publicGroupCode

String publicGroupCode
グループコード

sortKey

int sortKey
ソートキー

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
パブリックグループ所属の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.category

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory は Object を拡張し、Serializable を実装しています

直列化されたフィールド

publicGroupSetCode

String publicGroupSetCode
グループセットコード

publicGroupCode

String publicGroupCode
グループコード

categoryClassCode

String categoryClassCode
分類区分コード

categoryCode

String categoryCode
分類コード

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
パブリックグループ分類の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.group

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup は Object を拡張し、Serializable を実装しています

直列化されたフィールド

publicGroupSetCode

String publicGroupSetCode
グループセットコード

publicGroupCode

String publicGroupCode
グループコード

notes

String notes
備考

sortKey

int sortKey
ソートキー

defaultLocale

Locale defaultLocale
デフォルトのロケール

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
パブリックグループの期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

terminableInternationals

Map terminableInternationals
パブリックグループの期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
グループ名

nameSyllabary

String nameSyllabary
グループ名カナ

nameEnglish

String nameEnglish
グループ名英字

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.set

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet は Object を拡張し、Serializable を実装しています

直列化されたフィールド

publicGroupSetCode

String publicGroupSetCode
グループセットコード

notes

String notes
備考

sortKey

int sortKey
ソートキー

defaultLocale

Locale defaultLocale
デフォルトのロケール

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
パブリックグループセットの期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

terminableInternationals

Map terminableInternationals
パブリックグループセットの期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
グループ名

nameSyllabary

String nameSyllabary
グループ名カナ

nameEnglish

String nameEnglish
グループ名英字

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.version

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion は Object を拡張し、Serializable を実装しています

直列化されたフィールド

publicGroupSetCode

String publicGroupSetCode
グループセットコード

versionCode

String versionCode
バージョンコード

startDate

Date startDate
開始日

endDate

Date endDate
終了日

notes

String notes
備考

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.user

クラス jp.co.intra_mart.foundation.datastore.application.domain.user.User は Object を拡張し、Serializable を実装しています

直列化されたフィールド

userCode

String userCode
ユーザコード

accountFlag

String accountFlag
アカウントフラグ

notes

String notes
備考

sortKey

int sortKey
ソートキー

defaultLocale

Locale defaultLocale
デフォルトのロケール

defaultDate

Date defaultDate
デフォルトの日時

terminables

SortedMap terminables
ユーザの期間化に関連する情報のマップ

extendedDtos

Map extendedDtos
ユーザの基本情報に対する拡張情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

telephoneNumber

String telephoneNumber
電話番号

mobileNumber

String mobileNumber
携帯電話番号

faxNumber

String faxNumber
FAX番号

extensionNumber

String extensionNumber
内線番号

extensionFaxNumber

String extensionFaxNumber
内線FAX番号

countryCode

String countryCode
国コード

zipCode

String zipCode
郵便番号

emailAddress1

String emailAddress1
メールアドレス１

emailAddress2

String emailAddress2
メールアドレス２

mobileEmailAddress

String mobileEmailAddress
携帯用メール

url

String url
URL

extendedDtos

Map extendedDtos
ユーザの期間化情報に対する拡張情報のマップ

terminableInternationals

Map terminableInternationals
ユーザの期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
ユーザ名

nameSyllabary

String nameSyllabary
ユーザ名カナ

nameEnglish

String nameEnglish
ユーザ名英字

address

String address
住所

extendedDtos

Map extendedDtos
ユーザの期間国際化情報に対する拡張情報のマップ

パッケージ jp.co.intra_mart.foundation.datastore.common.config

クラス jp.co.intra_mart.foundation.datastore.common.config.AttributeType は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.common.config.DeleteType は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.datastore.common.model

クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

accessor

ExtendedBaseAccessor accessor
拡張基本アクセサ

クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

accessor

ExtendedInternationalAccessor accessor
拡張国際化アクセサ

クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

accessor

ExtendedTerminableInternationalAccessor accessor
拡張期間国際化アクセサ

クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

accessor

ExtendedTerminableAccessor accessor
拡張期間化アクセサ

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

context

BaseModelContext context
コンテキスト

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

context

InternationalModelContext context
コンテキスト

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap は Object を拡張し、Serializable を実装しています

直列化されたフィールド

models

Map models
国際化モデルを管理するマップ

modelName

String modelName
国際化モデルのクラス名

accessorMap

InternationalAccessorMap accessorMap
国際化アクセサマッピング

key

String key
メッセージキー

関連項目:
定数フィールド値

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

context

TerminableInternationalModelContext context
コンテキスト

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap は Object を拡張し、Serializable を実装しています

直列化されたフィールド

models

Map models
期間国際化モデルを管理するマップ

modelName

String modelName
期間国際化モデル名

accessorMap

TerminableInternationalAccessorMap accessorMap
国際化アクセサマッピング

key

String key
メッセージキー

関連項目:
定数フィールド値

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

context

TerminableModelContext context
コンテキスト

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap は Object を拡張し、Serializable を実装しています

直列化されたフィールド

models

Map models
期間化モデルを管理するマップ

terminableName

String terminableName
期間化モデルのクラス名

terminableInternationalName

String terminableInternationalName
期間国際化モデルのクラス名

accessorMap

TerminableAccessorMap accessorMap
期間化アクセサマッピング

defaultLocale

Locale defaultLocale
デフォルト言語

helper

jp.co.intra_mart.system.datastore.common.model.GenericTerminableModelMapHelper helper
期間化モデルマッピングヘルパー

key

String key
メッセージキー

関連項目:
定数フィールド値

パッケージ jp.co.intra_mart.foundation.datastore.common.structure

クラス jp.co.intra_mart.foundation.datastore.common.structure.Term は Object を拡張し、Serializable を実装しています

直列化されたフィールド

activationCal

Calendar activationCal
有効開始時間

expirationCal

Calendar expirationCal
有効終了時間

termByString

String termByString
期間の文字列表現

パッケージ jp.co.intra_mart.foundation.datastore.exception

クラス jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException は AccessorException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.AccessorException は DataStoreApplicationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException は AccessorException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException は DataStoreSystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.BatchProcessException は RuntimeException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.BatchSystemException は RuntimeException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException は AccessorException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException は FoundationException を拡張し、Serializable を実装しています

直列化されたフィールド

key

String key
メッセージキー

values

String[] values
置換用文字列

クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException は DataStoreSystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException は FoundationRuntimeException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException は AccessorException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException は DataNotFoundException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException は DataStoreApplicationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.IllegalTermException は DataNotFoundException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.ImportException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.ManagerException は DataStoreApplicationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.MapperDAOException は DataStoreSystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.MapperException は DataStoreApplicationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.TermManagerException は DataStoreApplicationException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.datastore.exporter

クラス jp.co.intra_mart.foundation.datastore.exporter.ExportInitializeException は BatchProcessException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exporter.Filter は Object を拡張し、Serializable を実装しています

直列化されたフィールド

value

String[] value

exclusive

boolean exclusive

パッケージ jp.co.intra_mart.foundation.datastore.exporter.common.config

クラス jp.co.intra_mart.foundation.datastore.exporter.common.config.ExportConfigurationReaderException は ExportInitializeException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.datastore.importer

クラス jp.co.intra_mart.foundation.datastore.importer.ImportInitializeException は BatchProcessException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.datastore.importer.common.config

クラス jp.co.intra_mart.foundation.datastore.importer.common.config.ImportConfigurationReaderException は ImportInitializeException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.drawer

クラス jp.co.intra_mart.foundation.drawer.AbstractDrawer は Object を拡張し、Serializable を実装しています

直列化されたフィールド

width

int width

height

int height

type

String type

パッケージ jp.co.intra_mart.foundation.exception

クラス jp.co.intra_mart.foundation.exception.ChangedListenerException は FoundationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.exception.FoundationException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.exception.FoundationRuntimeException は RuntimeException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.graph

クラス jp.co.intra_mart.foundation.graph.BarGraphDrawer は AbstractDrawer を拡張し、Serializable を実装しています

直列化されたフィールド

image_background_color

Color image_background_color

image_border_color

Color image_border_color

graph_background_color

Color graph_background_color

graph_border_color

Color graph_border_color

caption_color

Color caption_color

top_margin

int top_margin

right_margin

int right_margin

bottom_margin

int bottom_margin

left_margin

int left_margin

caption

String[] caption

data

ArrayList data

max

Number max

min

Number min

count

Number count

isDouble

boolean isDouble

クラス jp.co.intra_mart.foundation.graph.BarGraphObject は Object を拡張し、Serializable を実装しています

直列化されたフィールド

color

Color color

data

ArrayList data

クラス jp.co.intra_mart.foundation.graph.CircleGraphDrawer は AbstractDrawer を拡張し、Serializable を実装しています

直列化されたフィールド

image_background_color

Color image_background_color

image_border_color

Color image_border_color

top_margin

int top_margin

right_margin

int right_margin

bottom_margin

int bottom_margin

left_margin

int left_margin

caption_margin

int caption_margin

data

ArrayList data

クラス jp.co.intra_mart.foundation.graph.CircleGraphObject は Object を拡張し、Serializable を実装しています

直列化されたフィールド

data

double data

color

Color color

caption

String caption

font_color

Color font_color

font_size

int font_size

isDouble

boolean isDouble

クラス jp.co.intra_mart.foundation.graph.LineGraphDrawer は AbstractDrawer を拡張し、Serializable を実装しています

直列化されたフィールド

image_background_color

Color image_background_color

image_border_color

Color image_border_color

graph_background_color

Color graph_background_color

graph_border_color

Color graph_border_color

caption_color

Color caption_color

top_margin

int top_margin

right_margin

int right_margin

bottom_margin

int bottom_margin

left_margin

int left_margin

caption

String[] caption

data

ArrayList data

max

Number max

min

Number min

count

Number count

isDouble

boolean isDouble

クラス jp.co.intra_mart.foundation.graph.LineGraphObject は Object を拡張し、Serializable を実装しています

直列化されたフィールド

color

Color color

data

ArrayList data

クラス jp.co.intra_mart.foundation.graph.PortFolioDrawer は AbstractDrawer を拡張し、Serializable を実装しています

直列化されたフィールド

image_background_color

Color image_background_color

image_border_color

Color image_border_color

graph_background_color

Color graph_background_color

graph_border_color

Color graph_border_color

caption_color

Color caption_color

top_margin

int top_margin

right_margin

int right_margin

bottom_margin

int bottom_margin

left_margin

int left_margin

data

ArrayList data

x_max

Number x_max

x_min

Number x_min

y_max

Number y_max

y_min

Number y_min

isDouble

boolean isDouble

x_center

Number x_center

x_size

Number x_size

x_count

Number x_count

y_center

Number y_center

y_size

Number y_size

y_count

Number y_count

scale_position

String scale_position

クラス jp.co.intra_mart.foundation.graph.PortFolioObject は Object を拡張し、Serializable を実装しています

直列化されたフィールド

x_data

double x_data

y_data

double y_data

color

Color color

size

int size

isDouble

boolean isDouble

クラス jp.co.intra_mart.foundation.graph.RadarChartDrawer は AbstractDrawer を拡張し、Serializable を実装しています

直列化されたフィールド

image_background_color

Color image_background_color

image_border_color

Color image_border_color

graph_frame_color

Color graph_frame_color

caption_color

Color caption_color

top_margin

int top_margin

right_margin

int right_margin

bottom_margin

int bottom_margin

left_margin

int left_margin

caption_margin

int caption_margin

caption

String[] caption

data

ArrayList data

max

Number max

min

Number min

count

Number count

isDouble

boolean isDouble

クラス jp.co.intra_mart.foundation.graph.RadarChartObject は Object を拡張し、Serializable を実装しています

直列化されたフィールド

color

Color color

fill

boolean fill

data

ArrayList data

パッケージ jp.co.intra_mart.foundation.http

クラス jp.co.intra_mart.foundation.http.CGIEnvironment は HashMap を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.http.MultipartFormData は ArrayList を拡張し、Serializable を実装しています

直列化されたフィールド

instance

jp.co.intra_mart.common.aid.javaee.http.MultipartFormData instance
推奨されていません。

list

ArrayList list
推奨されていません。

パッケージ jp.co.intra_mart.foundation.image

クラス jp.co.intra_mart.foundation.image.DuplicateImageIconCodeException は ImageIconException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.image.DuplicateImageIconSrcException は ImageIconException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.image.ImageIconException は FoundationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.image.NotExistImageIconException は ImageIconException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.mail.javamail.property

クラス jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException は Exception を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.mail

クラス jp.co.intra_mart.foundation.mail.MailSenderException は Exception を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.navigator

クラス jp.co.intra_mart.foundation.navigator.EventAccessInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

roles

List roles
ロール

departments

List departments
組織

posts

List posts
役職

publicGroups

List publicGroups
パブリックグループ

クラス jp.co.intra_mart.foundation.navigator.EventFlow は NavigatorAuthenticateItem を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id
イベントフローID

open

String open
公開フラグ

startEventItem

EventItem startEventItem
スタートイベント

sortNumber

int sortNumber
ソート番号

クラス jp.co.intra_mart.foundation.navigator.EventFlowInfo は TitleInfo を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

open

String open

startEventId

String startEventId

permissionCheck

boolean permissionCheck

クラス jp.co.intra_mart.foundation.navigator.EventHistoryInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

question

String question

answer

String answer

クラス jp.co.intra_mart.foundation.navigator.EventItem は NavigatorItem を拡張し、Serializable を実装しています

直列化されたフィールド

selectItem

SelectItem[] selectItem
選択アイテムリスト

クラス jp.co.intra_mart.foundation.navigator.EventItemInfo は TitleInfo を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

selectItemInfos

SelectItemInfo[] selectItemInfos

eventHistory

EventHistoryInfo[] eventHistory

クラス jp.co.intra_mart.foundation.navigator.EventNavigatorException は DataStoreApplicationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.navigator.EventResultItem は NavigatorItem を拡張し、Serializable を実装しています

直列化されたフィールド

pageItem

ResultPageItem[] pageItem
結果ページのリスト

クラス jp.co.intra_mart.foundation.navigator.EventResultItemInfo は TitleInfo を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

resultPageItemInfos

ResultPageItemInfo[] resultPageItemInfos

eventHistory

EventHistoryInfo[] eventHistory

クラス jp.co.intra_mart.foundation.navigator.LinkPageInfo は TitleInfo を拡張し、Serializable を実装しています

直列化されたフィールド

url

String url

param

Map param

クラス jp.co.intra_mart.foundation.navigator.NavigatorAuthenticateItem は NavigatorItem を拡張し、Serializable を実装しています

直列化されたフィールド

accessInfo

EventAccessInfo accessInfo
アクセス権

クラス jp.co.intra_mart.foundation.navigator.NavigatorItem は Object を拡張し、Serializable を実装しています

直列化されたフィールド

titleInfo

Map titleInfo
タイトル情報

クラス jp.co.intra_mart.foundation.navigator.ResultPageItem は NavigatorAuthenticateItem を拡張し、Serializable を実装しています

直列化されたフィールド

linkPageInfo

LinkPageInfo linkPageInfo
リンク情報

クラス jp.co.intra_mart.foundation.navigator.ResultPageItemInfo は TitleInfo を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

permissionCheck

boolean permissionCheck

クラス jp.co.intra_mart.foundation.navigator.SaveEventHistoryInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

question

String question

answer

String answer

クラス jp.co.intra_mart.foundation.navigator.SaveEventResultItemInfo は TitleInfo を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

saveDate

Date saveDate

resultPageItemInfos

ResultPageItemInfo[] resultPageItemInfos

eventHistory

SaveEventHistoryInfo[] eventHistory

クラス jp.co.intra_mart.foundation.navigator.SelectItem は NavigatorAuthenticateItem を拡張し、Serializable を実装しています

直列化されたフィールド

nextEventItem

EventItem nextEventItem
遷移先イベントアイテム

nextEventResultItem

EventResultItem nextEventResultItem
遷移先ナビゲート結果

nextType

String nextType
遷移先タイプ

クラス jp.co.intra_mart.foundation.navigator.SelectItemInfo は TitleInfo を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

nextItemId

String nextItemId

nextType

String nextType

permissionCheck

boolean permissionCheck

クラス jp.co.intra_mart.foundation.navigator.TitleInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

title

String title

comment

String comment

パッケージ jp.co.intra_mart.foundation.page

クラス jp.co.intra_mart.foundation.page.NodeNameComparator は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.page.NodeTypeComparator は AbstractDualComparator を拡張し、Serializable を実装しています

直列化されたフィールド

primaryComparator

Comparator primaryComparator

secondaryComparator

Comparator secondaryComparator

パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet.model

クラス jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived は Object を拡張し、Serializable を実装しています

直列化されたフィールド

category

String category
カテゴリ名

contents

String contents
内容

date

String date
日付

url

String url
リンク先のURL

popup

boolean popup
リンク先をポップアップ画面で呼び出すかどうか

パッケージ jp.co.intra_mart.foundation.portal.portlet.model

クラス jp.co.intra_mart.foundation.portal.portlet.model.InternetPortlet は StandardPortlet を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.portal.portlet.model.J2eeFwPortlet は Portlet を拡張し、Serializable を実装しています

直列化されたフィールド

applicationId

String applicationId
アプリケーションID

serviceId

String serviceId
サービスID

argument

String argument
ページ引数

クラス jp.co.intra_mart.foundation.portal.portlet.model.JspPortlet は StandardPortlet を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.portal.portlet.model.MenuLinkSetPortlet は J2eeFwPortlet を拡張し、Serializable を実装しています

直列化されたフィールド

menuLinkSetCode

String menuLinkSetCode
メニューリンクセットコード

クラス jp.co.intra_mart.foundation.portal.portlet.model.Portlet は Object を拡張し、Serializable を実装しています

直列化されたフィールド

portletCode

String portletCode
ポートレットコード

application

String application
アプリケーション名

portletName

String portletName
ポートレット名

titleBar

boolean titleBar
タイトルバーを表示するかどうか

cacheTime

int cacheTime
キャッシュ時間

explain

String explain
説明

unit

String unit
表示単位

width

int width
表示幅

height

int height
表示高さ

recordUserCode

String recordUserCode
最終更新ユーザコード

recordDate

Date recordDate
最終更新日

クラス jp.co.intra_mart.foundation.portal.portlet.model.PresentationPagePortlet は StandardPortlet を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.portal.portlet.model.RssPortlet は J2eeFwPortlet を拡張し、Serializable を実装しています

直列化されたフィールド

rssUrl

String rssUrl
URL

proxyHost

String proxyHost
プロキシホスト名

proxyPort

int proxyPort
プロキシポート番号

parserKey

String parserKey
RSS解析バージョンのキー情報

クラス jp.co.intra_mart.foundation.portal.portlet.model.StandardPortlet は Portlet を拡張し、Serializable を実装しています

直列化されたフィールド

url

String url
URL

argument

String argument
ページ引数

パッケージ jp.co.intra_mart.foundation.portal.portlet

クラス jp.co.intra_mart.foundation.portal.portlet.PortletManagerException は RuntimeException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.scenario

クラス jp.co.intra_mart.foundation.scenario.NoSuchPropertyException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.scenario.ScriptCompileException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.scenario.ScriptRuntimeException は Exception を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.security.access

クラス jp.co.intra_mart.foundation.security.access.AccessController は Object を拡張し、Serializable を実装しています

serialVersionUID: 318454472512899294l

直列化されたフィールド

controllerId

String controllerId

displayName

String displayName

description

String description

パッケージ jp.co.intra_mart.foundation.security

クラス jp.co.intra_mart.foundation.security.DepartmentInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード。

departmentCode

String departmentCode
組織コード。

クラス jp.co.intra_mart.foundation.security.PostInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード。

postCode

String postCode
役職コード。

クラス jp.co.intra_mart.foundation.security.PublicGroupInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

groupSetCode

String groupSetCode
グループセットコード。

groupCode

String groupCode
グループコード。

パッケージ jp.co.intra_mart.foundation.security.account

クラス jp.co.intra_mart.foundation.security.account.Account は Object を拡張し、Serializable を実装しています

直列化されたフィールド

encoding

String encoding
エンコーディング

goOut

boolean goOut
外出フラグ

locale

Locale locale
ロケール

lockdate

Date lockdate
アカウントロック日付

loginFailureCount

int loginFailureCount
ログイン失敗回数

mainPagePatternId

String mainPagePatternId
メインページパターンID

mobilePassword

String mobilePassword
モバイル用パスワード

description

String description
説明

colorPatternId

String colorPatternId
カラーパターンID

password

String password
パスワード

userId

String userId
ユーザID

validEndDate

Date validEndDate
有効終了日

validStartDate

Date validStartDate
有効開始日

クラス jp.co.intra_mart.foundation.security.account.AccountRole は Object を拡張し、Serializable を実装しています

直列化されたフィールド

roleId

String roleId
ロールID

roleValidEndDate

Date roleValidEndDate
ロール有効終了日

roleValidStartDate

Date roleValidStartDate
ロール有効開始日

クラス jp.co.intra_mart.foundation.security.account.FavoriteMenu は Object を拡張し、Serializable を実装しています

直列化されたフィールド

displayName

String displayName
マイメニュー表示名

menuId

String menuId
メニューID

imagePath

String imagePath
イメージパス

sortNumber

int sortNumber
ソート番号

パッケージ jp.co.intra_mart.foundation.security.activesession

クラス jp.co.intra_mart.foundation.security.activesession.ActiveSessionBindingListener は Object を拡張し、Serializable を実装しています

serialVersionUID: -1231301228756970262l

直列化されたフィールド

activeSessionInfo

ActiveSessionInfo activeSessionInfo

クラス jp.co.intra_mart.foundation.security.activesession.ActiveSessionInfo は Object を拡張し、Serializable を実装しています

serialVersionUID: -5974203619452886484l

直列化されたフィールド

sessionId

String sessionId
セッションID

loginType

String loginType
ログインタイプ

loginGroup

String loginGroup
ログイングループ(ID)

userId

String userId
ユーザID

loginTime

long loginTime
ログイン時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)

remoteAddr

String remoteAddr
クライアントの IP アドレス

userAgent

String userAgent
ブラウザ情報

lastResponseTime

long lastResponseTime
最終応答時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)

expireInterval

int expireInterval
セッションを保ち続ける最大の時間間隔(秒数)

processing

boolean processing
処理中フラグ

valid

boolean valid
セッションの有効性フラグ

invalidateLoginType

String invalidateLoginType
無効化したユーザのログインタイプ

invalidateUserId

String invalidateUserId
無効化したユーザのユーザID

invalidateTime

long invalidateTime
無効化した時刻(GMT 1970 年 1 月 1 日 0 時からのミリ秒数)

パッケージ jp.co.intra_mart.foundation.security.admin

クラス jp.co.intra_mart.foundation.security.admin.SuperUser は Object を拡張し、Serializable を実装しています

直列化されたフィールド

encoding

String encoding
エンコーディング

locale

Locale locale
ロケール

mailAddress

String mailAddress
メールアドレス

password

String password
パスワード

telNo

String telNo
電話番号

userId

String userId
ユーザーID

パッケージ jp.co.intra_mart.foundation.security.batch

クラス jp.co.intra_mart.foundation.security.batch.Batch は Object を拡張し、Serializable を実装しています

直列化されたフィールド

batchId

String batchId
バッチＩＤ

description

String description
バッチ内容

name

String name
バッチ名

programLanguage

String programLanguage
実行プログラム言語

programPath

String programPath
実行プログラムパス

runDay

int runDay
実行日

runDayWeek

int runDayWeek
実行曜日

runHour

int runHour
実行時

runMinute

int runMinute
実行分

runMonth

int runMonth
実行月

runSecond

int runSecond
実行秒

runYear

int runYear
実行年

validate

boolean validate
有効・無効フラグ

パッケージ jp.co.intra_mart.foundation.security.calendar

クラス jp.co.intra_mart.foundation.security.calendar.CalendarInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

color

String color
表示色

dataId

String dataId
データＩＤ（入力必須）

dataType

String dataType
データタイプ

day

int day
日

dayWeek

int dayWeek
曜日

description

String description
カレンダーデータの説明

displayName

Map displayName
表示名

month

int month
月

plugin

String plugin
プラグインID

times

int times
第ｎ～曜日

validEndYear

int validEndYear
有効終了年

validStartYear

int validStartYear
有効開始年

week

int week
第ｎ週目

year

int year
年

regExpPattern

Pattern regExpPattern
検証パターン(正規表現)

priority

int priority
優先度

パッケージ jp.co.intra_mart.foundation.security.exception

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException は AccessSecurityRuntimeException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException は AccessSecurityWriteException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException は AccessSecurityWriteException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException は FoundationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException は FoundationRuntimeException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException は AccessSecurityWriteException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.ActiveSessionException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.ActiveSessionInvalidatedByForceException は ActiveSessionException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.ActiveSessionNotExistException は ActiveSessionException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.DuplicateException は AccessSecurityWriteException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.DuplicateLoginDetectedException は DuplicateLoginException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.DuplicateLoginException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.IllegalArgumentException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.NoFilterException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.NoSessionCookieException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.NoSessionException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.NotExistException は AccessSecurityWriteException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.NotSupportMethodException は AccessSecurityWriteException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.SystemConfigException は AccessSecurityRuntimeException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.security.group

クラス jp.co.intra_mart.foundation.security.group.LoginGroup は Object を拡張し、Serializable を実装しています

直列化されたフィールド

encoding

String encoding
エンコーディング

locale

Locale locale
ロケール

lockCount

int lockCount
アカウントロックカウント

lockTerm

int lockTerm
アカウントロック時間（分）

loginGroupId

String loginGroupId
ログイングループID

colorPatternId

String colorPatternId
カラーパターンID

クラス jp.co.intra_mart.foundation.security.group.MainPagePatternInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

mainPagePatternId

String mainPagePatternId
メインページパターンID。

mainPagePatternImageUrl

String mainPagePatternImageUrl
メインページパターンイメージURL。

mainPagePatternUrl

String mainPagePatternUrl
メインページパターンURL。

パッケージ jp.co.intra_mart.foundation.security.menu

クラス jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion は Object を拡張し、Serializable を実装しています

直列化されたフィールド

childMenuId

String childMenuId
子メニューID。

parentMenuId

String parentMenuId
親メニューID。

クラス jp.co.intra_mart.foundation.security.menu.MenuInclusion は Object を拡張し、Serializable を実装しています

直列化されたフィールド

childMenuId

String childMenuId
子メニューID。

parentMenuId

String parentMenuId
親メニューID。

クラス jp.co.intra_mart.foundation.security.menu.MenuItem は Object を拡張し、Serializable を実装しています

直列化されたフィールド

arguments

Map arguments
引数

clientType

String clientType
クライアントタイプ

contents

String contents
コンテンツの種類

description

String description
説明

displayNames

Map displayNames
メニュー名 (多言語化対応、 key:ロケール、value メニュー名)

id

String id
メニューID

sortNumber

int sortNumber
ソート番号

type

String type
ノードタイプ

url

String url
URL

imagePath

String imagePath
メニューイメージパス。

パッケージ jp.co.intra_mart.foundation.security.password

クラス jp.co.intra_mart.foundation.security.password.PasswordHistoryException は FoundationException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.security.role

クラス jp.co.intra_mart.foundation.security.role.Role は Object を拡張し、Serializable を実装しています

直列化されたフィールド

category

String category
ロールカテゴリ。

description

String description
ロールの詳細。

displayName

Map displayName
ロールの表示名 (key:ロケール、value:ロール表示名)。

roleId

String roleId
ロールID。

roleName

String roleName
ロール名。

パッケージ jp.co.intra_mart.foundation.security.servlet

クラス jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

redilectClientTypes

Set redilectClientTypes
メインページをリダイレクトで返却するクライアントタイプ。

clientType

String clientType
クライアントタイプ。

クラス jp.co.intra_mart.foundation.security.servlet.LogoutServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

validator

LogoutInitialUrlValidator validator

クラス jp.co.intra_mart.foundation.security.servlet.MenuServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

redilectClientTypes

Set redilectClientTypes
メインページをリダイレクトで返却するクライアントタイプ。

クラス jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

redilectClientTypes

Set redilectClientTypes
メインページをリダイレクトで返却するクライアントタイプ。

clientType

String clientType
クライアントタイプ。

クラス jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

redilectClientTypes

Set redilectClientTypes
メインページをリダイレクトで返却するクライアントタイプ。

クラス jp.co.intra_mart.foundation.security.servlet.UserInitialServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

redilectClientTypes

Set redilectClientTypes
メインページをリダイレクトで返却するクライアントタイプ。

clientType

String clientType
クライアントタイプ。

パッケージ jp.co.intra_mart.foundation.security.shortcut

クラス jp.co.intra_mart.foundation.security.shortcut.ShortCutInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

url

String url
ＵＲＬ。

urlParams

Map urlParams
ＵＲＬ引数。

allowsUsers

String[] allowsUsers
許可ユーザ

isAuth

boolean isAuth
認証フラグ

validEndDate

Date validEndDate
有効終了日

パッケージ jp.co.intra_mart.foundation.service.client

クラス jp.co.intra_mart.foundation.service.client.NetworkAgent は NetworkConnector を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.client.NetworkConnector は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.client.application

クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException は HTTPActionEventHandlerException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.client.batch

クラス jp.co.intra_mart.foundation.service.client.batch.Scheduler は NetworkAgent を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.client.file

クラス jp.co.intra_mart.foundation.service.client.file.AbstractComponent は NetworkAgent を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.client.file.NetworkFile は AbstractComponent を拡張し、Serializable を実装しています

直列化されたフィールド

path

String path

パッケージ jp.co.intra_mart.foundation.service.client.information

クラス jp.co.intra_mart.foundation.service.client.information.ExternalDirectory は NetworkAgent を拡張し、Serializable を実装しています

直列化されたフィールド

dir

String dir

クラス jp.co.intra_mart.foundation.service.client.information.ExternalMemory は NetworkAgent を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

parent

String parent

クラス jp.co.intra_mart.foundation.service.client.information.InitialFile は Properties を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.client.information.Lock は NetworkAgent を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

クラス jp.co.intra_mart.foundation.service.client.information.PermanentDirectory は NetworkAgent を拡張し、Serializable を実装しています

直列化されたフィールド

dir

String dir

クラス jp.co.intra_mart.foundation.service.client.information.PermanentFile は NetworkAgent を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

parent

String parent

パッケージ jp.co.intra_mart.foundation.service.client.manager

クラス jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.client.manager.ServerConnector は NetworkConnector を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.provider.application

クラス jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException は Exception を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.provider

クラス jp.co.intra_mart.foundation.service.provider.HomeDirectory は jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.provider.TemporaryDirectory は ExtendedDirectory を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.provider.TemporaryFile は ExtendedFile を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.provider.file

クラス jp.co.intra_mart.foundation.service.provider.file.StorageDirectory は ExtendedDirectory を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.provider.information

クラス jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory は ExtendedDirectory を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.smtp

クラス jp.co.intra_mart.foundation.smtp.Mail は jp.co.intra_mart.system.mail.smtp.InetMail を拡張し、Serializable を実装しています

直列化されたフィールド

tempSmtpsvr

String tempSmtpsvr
推奨されていません。

badAdrs

ArrayList badAdrs
推奨されていません。

errCode

int errCode
推奨されていません。

errMsg

String errMsg
推奨されていません。

toFlg

boolean toFlg
推奨されていません。

fromFlg

boolean fromFlg
推奨されていません。

replyFlg

boolean replyFlg
推奨されていません。

パッケージ jp.co.intra_mart.foundation.utility

クラス jp.co.intra_mart.foundation.utility.AbstractDualComparator は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.utility.Counter は Number を拡張し、Serializable を実装しています

直列化されたフィールド

currentValue

long currentValue
推奨されていません。
カウンターの値

クラス jp.co.intra_mart.foundation.utility.FilterComparator は Object を拡張し、Serializable を実装しています

直列化されたフィールド

parent

Comparator parent
推奨されていません。

クラス jp.co.intra_mart.foundation.utility.MultiComparator は AbstractDualComparator を拡張し、Serializable を実装しています

直列化されたフィールド

primaryComparator

Comparator primaryComparator
推奨されていません。
第１コンパレータ

secondaryComparator

MultiComparator secondaryComparator
推奨されていません。
第２コンパレータ

クラス jp.co.intra_mart.foundation.utility.ResourceBundleProperties は Properties を拡張し、Serializable を実装しています

直列化されたフィールド

currentLocale

Locale currentLocale
推奨されていません。

クラス jp.co.intra_mart.foundation.utility.ReverseComparator は FilterComparator を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.utility.SequenceComparator は Object を拡張し、Serializable を実装しています

直列化されたフィールド

map

WeakHashMap map
推奨されていません。
map

count

long count
推奨されていません。
挿入順番

パッケージ jp.co.intra_mart.foundation.utility.charset

クラス jp.co.intra_mart.foundation.utility.charset.ResourceFormatException は jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException は jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.utility.file

クラス jp.co.intra_mart.foundation.utility.file.Directory は File を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.utility.file.ExtendedDirectory は Directory を拡張し、Serializable を実装しています

直列化されたフィールド

POOL

FixedSizeMap POOL
推奨されていません。
このディレクトリを親とするファイルオブジェクトのキャッシュ領域

クラス jp.co.intra_mart.foundation.utility.file.ExtendedFile は File を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.utility.net

クラス jp.co.intra_mart.foundation.utility.net.Localhost は Object を拡張し、Serializable を実装しています

直列化されたフィールド

localhostIPAddress

byte[] localhostIPAddress
推奨されていません。

localhostAddress

String localhostAddress
推奨されていません。

localhostName

String localhostName
推奨されていません。

クラス jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException は IOException を拡張し、Serializable を実装しています

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.ConnectorModel の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.ConnectorModel の使用

jp.co.intra_mart.framework.base.data.ConnectorModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.data.DAO の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.data.DAO の使用

DAO を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DAO の使用

DAO を実装している jp.co.intra_mart.framework.base.data のクラス
class | DAOAdapter DAOのすべてのメソッドを何もしないように実装したクラスです。
class | DBDAO データベースに特化したDAOです。
class | IntramartDBDAO 推奨されていません。 このクラスではなくLoginGroupDBDAOまたは SystemDBDAOを使用してください。
class | IntramartFileServerDAO intra-martのStorageサービスを使用する場合のDAOです。
class | LoginGroupDBDAO イントラマートで設定されたDBへアクセスするDAOです。
class | SystemDBDAO イントラマートで設定されたDBへアクセスするDAOです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DAOAdapter の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DAOAdapter の使用

jp.co.intra_mart.framework.base.data.DAOAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DAOException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DAOException の使用

DAOException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DAOException の使用

DAOException をスローする jp.co.intra_mart.framework.base.data のメソッド
 Object DataAccessController.getDAO(String application, String key, String connect)
DAOを取得します。

jp.co.intra_mart.framework.base.event での DAOException の使用

DAOException をスローする jp.co.intra_mart.framework.base.event のメソッド
protected Object | StandardEventListener.getDAO(String application, String key, String connect) DAOを取得します。
protected Object | EventTriggerAdapter.getDAO(String application, String key, String connect) DAOを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DaoModel の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DaoModel の使用

jp.co.intra_mart.framework.base.data.DaoModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataAccessController の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataAccessController の使用

DataAccessController を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.data.container |
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataAccessController の使用

DataAccessController を返す jp.co.intra_mart.framework.base.data のメソッド
 DataAccessController DataManager.getDataAccessController()
データアクセスコントローラを取得します。

jp.co.intra_mart.framework.base.data.container での DataAccessController の使用

DataAccessController を返す jp.co.intra_mart.framework.base.data.container のメソッド
DataAccessController | DataContainerImpl.getDataAccessController() データアクセスコントローラを取得します。
DataAccessController | DataContainer.getDataAccessController() データアクセスコントローラを取得します。

jp.co.intra_mart.framework.base.event での DataAccessController の使用

DataAccessController を返す jp.co.intra_mart.framework.base.event のメソッド
protected  DataAccessController StandardEventListener.getDataAccessController()
このイベントリスナで使用するデータアクセスコントローラです。

DataAccessController 型のパラメータを持つ jp.co.intra_mart.framework.base.event のメソッド
protected abstract EventResult | StandardEJBEventListenerAgentBean.fire(Event event, DataAccessController dataAccessController) イベントに対する処理です。
void | EventTriggerList.fireAll(Event event, DataAccessController controller) すべてのトリガに対してイベントの処理を行います。
void | EventTriggerAdapter.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
void | EventTrigger.fire(Event event, DataAccessController controller) イベントに対する処理を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataAccessException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataAccessException の使用

jp.co.intra_mart.framework.base.data.DataAccessException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataConnectException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataConnectException の使用

DataConnectException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataConnectException の使用

DataConnectException をスローする jp.co.intra_mart.framework.base.data のメソッド
void | SystemDBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
Connection | SystemDBDAO.getConnection() イントラマートで設定されているDBへのコネクションを取得します。
void | SystemDBConnector.commit() コミットします。
void | SystemDBConnector.rollback() ロールバックします。
void | SystemDBConnector.release() データストアの資源を解放します。
Connection | SystemDBConnector.getConnection(String connect) データベースへのコネクションを取得します。
protected Object | SystemDBConnector.getResource(String key, String connect, String resource) リソースを取得します。
void | LoginGroupDBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
Connection | LoginGroupDBDAO.getConnection() イントラマートで設定されているDBへのコネクションを取得します。
void | LoginGroupDBConnector.commit() コミットします。
void | LoginGroupDBConnector.rollback() ロールバックします。
void | LoginGroupDBConnector.release() データストアの資源を解放します。
Connection | LoginGroupDBConnector.getConnection(String connect) データベースへのコネクションを取得します。
protected Object | LoginGroupDBConnector.getResource(String key, String connect, String resource) リソースを取得します。
void | JDBCConnector.commit() 推奨されていません。 コミットします。
void | JDBCConnector.rollback() 推奨されていません。 ロールバックします。
void | JDBCConnector.release() 推奨されていません。 データストアの資源を解放します。
protected Connection | JDBCConnector.putResource(String resource, ResourceParam[] params) 推奨されていません。 接続先のリソースを追加します。
void | IntramartFileServerDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
protected Object | IntramartFileServerConnector.getResource(String key, String connect, String resource) リソースを取得します。
void | IntramartFileServerConnector.commit() コミットします。
void | IntramartFileServerConnector.rollback() ロールバックします。
void | IntramartFileServerConnector.release() データストアの資源を解放します。
void | IntramartDBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) 推奨されていません。 データリソースに接続する時の情報を設定します。
jp.co.intra_mart.foundation.database.DbsConnection | IntramartDBDAO.getConnection() 推奨されていません。 イントラマートで設定されているDBへのコネクションを取得します。
void | IntramartDBConnector.commit() 推奨されていません。 コミットします。
void | IntramartDBConnector.rollback() 推奨されていません。 ロールバックします。
void | IntramartDBConnector.release() 推奨されていません。 データストアの資源を解放します。
protected Object | IntramartDBConnector.getResource(String key, String connect, String resource) 推奨されていません。 リソースを取得します。
jp.co.intra_mart.foundation.database.DbsConnection | IntramartDBConnector.getConnection(String connect) 推奨されていません。 データベースへのコネクションを取得します。
void | DBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
protected Connection | DBDAO.getConnection() このDAOに関連づけられたコネクションを取得します。
protected abstract Connection | DBConnector.putResource(String resource, ResourceParam[] params) 接続先のリソースを追加します。
protected Object | DBConnector.getResource(String key, String connect, String resource) リソースを取得します。
Connection | DBConnector.getConnection(String resource) データベースへのコネクションを取得します。
void | DBConnector.commit() コミットします。
void | DBConnector.rollback() ロールバックします。
void | DBConnector.release() データストアの資源を解放します。
void | DataSourceConnector.commit() コミットします。
void | DataSourceConnector.rollback() ロールバックします。
void | DataSourceConnector.release() データストアの資源を解放します。
protected Connection | DataSourceConnector.putResource(String resource, ResourceParam[] params) 接続先のリソースを追加します。
protected abstract Object | DataConnector.getResource(String key, String connect, String resource) リソースを取得します。
abstract void | DataConnector.commit() コミットします。
abstract void | DataConnector.rollback() ロールバックします。
abstract void | DataConnector.release() データストアの資源を解放します。
Object | DataAccessController.getDAO(String application, String key, String connect) DAOを取得します。
void | DataAccessController.commit() すべてのデータコネクタをコミットします。
void | DataAccessController.rollback() すべてのデータコネクタをロールバックします。
void | DataAccessController.release() すべてのデータストアの資源を解放します。
void | DAOAdapter.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
void | DAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。

jp.co.intra_mart.framework.base.event での DataConnectException の使用

DataConnectException をスローする jp.co.intra_mart.framework.base.event のメソッド
protected Object | StandardEventListener.getDAO(String application, String key, String connect) DAOを取得します。
protected Object | EventTriggerAdapter.getDAO(String application, String key, String connect) DAOを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataConnector の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataConnector の使用

DataConnector を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataConnector の使用

jp.co.intra_mart.framework.base.data での DataConnector のサブクラス
class | DataSourceConnector DataSourceに関連するデータコネクタです。
class | DBConnector データベースに対するコネクタです。
class | IntramartDBConnector 推奨されていません。 このクラスではなくLoginGroupDBConnectorまたは SystemDBConnectorを使用してください。
class | IntramartFileServerConnector intra-martのStorageサービスに接続するデータコネクタです。
class | JDBCConnector 推奨されていません。 JDBCを直接扱わず、DataSourceを使用するようにしてください。
class | LoginGroupDBConnector イントラマートで設定されているDBコネクションです。
class | SystemDBConnector イントラマートで設定されているDBコネクションです。

DataConnector 型のパラメータを持つ jp.co.intra_mart.framework.base.data のメソッド
void | SystemDBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
void | LoginGroupDBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
void | IntramartFileServerDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
void | IntramartDBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) 推奨されていません。 データリソースに接続する時の情報を設定します。
void | DBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
void | DAOAdapter.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
void | DAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataConnectorException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataConnectorException の使用

DataConnectorException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataConnectorException の使用

DataConnectorException をスローする jp.co.intra_mart.framework.base.data のメソッド
protected jp.co.intra_mart.foundation.service.client.file.NetworkFile | IntramartFileServerDAO.getNetworkFile(String path) パスに該当するNetworkFileを取得します。
Object | DataAccessController.getDAO(String application, String key, String connect) DAOを取得します。

jp.co.intra_mart.framework.base.event での DataConnectorException の使用

DataConnectorException をスローする jp.co.intra_mart.framework.base.event のメソッド
protected Object | StandardEventListener.getDAO(String application, String key, String connect) DAOを取得します。
protected Object | EventTriggerAdapter.getDAO(String application, String key, String connect) DAOを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataManager の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataManager の使用

DataManager を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataManager の使用

DataManager を返す jp.co.intra_mart.framework.base.data のメソッド
static DataManager DataManager.getDataManager()
データマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataManagerException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataManagerException の使用

DataManagerException を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataManagerException の使用

DataManagerException をスローする jp.co.intra_mart.framework.base.data のメソッド
static DataManager DataManager.getDataManager()
データマネージャを取得します。

DataManagerException をスローする jp.co.intra_mart.framework.base.data のコンストラクタ
DataManager()
データマネージャを生成するコンストラクタです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataPropertyException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataPropertyException の使用

DataPropertyException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataPropertyException の使用

DataPropertyException をスローする jp.co.intra_mart.framework.base.data のメソッド
boolean | XmlDataPropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | XmlDataPropertyHandler.getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
String | XmlDataPropertyHandler.getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | XmlDataPropertyHandler.getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | XmlDataPropertyHandler.getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
ResourceParam[] | XmlDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
String | TextFileDataPropertyHandler.getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
String | TextFileDataPropertyHandler.getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | TextFileDataPropertyHandler.getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | TextFileDataPropertyHandler.getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
ResourceParam[] | TextFileDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
Connection | SystemDBDAO.getConnection() イントラマートで設定されているDBへのコネクションを取得します。
Connection | SystemDBConnector.getConnection(String connect) データベースへのコネクションを取得します。
Connection | LoginGroupDBDAO.getConnection() イントラマートで設定されているDBへのコネクションを取得します。
Connection | LoginGroupDBConnector.getConnection(String connect) データベースへのコネクションを取得します。
protected Object | IntramartFileServerConnector.getResource(String key, String connect, String resource) リソースを取得します。
jp.co.intra_mart.foundation.database.DbsConnection | IntramartDBDAO.getConnection() 推奨されていません。 イントラマートで設定されているDBへのコネクションを取得します。
protected Object | IntramartDBConnector.getResource(String key, String connect, String resource) 推奨されていません。 リソースを取得します。
jp.co.intra_mart.foundation.database.DbsConnection | IntramartDBConnector.getConnection(String connect) 推奨されていません。 データベースへのコネクションを取得します。
boolean | DistributesDataPropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | DistributesDataPropertyHandler.getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
String | DistributesDataPropertyHandler.getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | DistributesDataPropertyHandler.getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | DistributesDataPropertyHandler.getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
ResourceParam[] | DistributesDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
boolean | DefaultDataPropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | DefaultDataPropertyHandler.getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
String | DefaultDataPropertyHandler.getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | DefaultDataPropertyHandler.getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | DefaultDataPropertyHandler.getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
ResourceParam[] | DefaultDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
protected Connection | DBDAO.getConnection() このDAOに関連づけられたコネクションを取得します。
protected Object | DBConnector.getResource(String key, String connect, String resource) リソースを取得します。
Connection | DBConnector.getConnection(String resource) データベースへのコネクションを取得します。
boolean | DataPropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | DataPropertyHandler.getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
String | DataPropertyHandler.getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | DataPropertyHandler.getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | DataPropertyHandler.getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
ResourceParam[] | DataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
protected abstract Object | DataConnector.getResource(String key, String connect, String resource) リソースを取得します。
Object | DataAccessController.getDAO(String application, String key, String connect) DAOを取得します。

jp.co.intra_mart.framework.base.event での DataPropertyException の使用

DataPropertyException をスローする jp.co.intra_mart.framework.base.event のメソッド
protected Object | StandardEventListener.getDAO(String application, String key, String connect) DAOを取得します。
protected Object | EventTriggerAdapter.getDAO(String application, String key, String connect) DAOを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.data.DataPropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.data.DataPropertyHandler の使用

DataPropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.data.container |

jp.co.intra_mart.framework.base.data での DataPropertyHandler の使用

DataPropertyHandler を実装している jp.co.intra_mart.framework.base.data のクラス
class | DefaultDataPropertyHandler デフォルトのデータプロパティハンドラです。
class | DistributesDataPropertyHandler アプリケーション毎のプロパティハンドラを呼び出します。
class | TextFileDataPropertyHandler 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
class | XmlDataPropertyHandler XMLのデータプロパティハンドラです。

DataPropertyHandler を返す jp.co.intra_mart.framework.base.data のメソッド
DataPropertyHandler | DataManager.getDataPropertyHandler() データプロパティハンドラを取得します。
DataPropertyHandler | DataConnector.getDataPropertyHandler() データプロパティハンドラを取得します。
DataPropertyHandler | DataAccessController.getDataPropertyHandler() データプロパティハンドラを取得します。

DataPropertyHandler 型のパラメータを持つ jp.co.intra_mart.framework.base.data のメソッド
 void DataConnector.setDataPropertyHandler(DataPropertyHandler handler)
データプロパティハンドラを設定します。

DataPropertyHandler 型のパラメータを持つ jp.co.intra_mart.framework.base.data のコンストラクタ
DataAccessController(DataPropertyHandler handler)
データアクセスコントローラを生成します。

jp.co.intra_mart.framework.base.data.container での DataPropertyHandler の使用

DataPropertyHandler を返す jp.co.intra_mart.framework.base.data.container のメソッド
DataPropertyHandler | DataContainerImpl.getDataPropertyHandler() データプロパティハンドラを取得します。
DataPropertyHandler | DataContainer.getDataPropertyHandler() データプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataSourceConnector の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataSourceConnector の使用

jp.co.intra_mart.framework.base.data.DataSourceConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DBConnector の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DBConnector の使用

DBConnector を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DBConnector の使用

jp.co.intra_mart.framework.base.data での DBConnector のサブクラス
class | DataSourceConnector DataSourceに関連するデータコネクタです。
class | JDBCConnector 推奨されていません。 JDBCを直接扱わず、DataSourceを使用するようにしてください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DBDAO の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DBDAO の使用

jp.co.intra_mart.framework.base.data.DBDAO はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler の使用

jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の使用

jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.IntramartDBConnector の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.IntramartDBConnector の使用

jp.co.intra_mart.framework.base.data.IntramartDBConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.IntramartDBDAO の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.IntramartDBDAO の使用

jp.co.intra_mart.framework.base.data.IntramartDBDAO はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.IntramartFileServerConnector の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.IntramartFileServerConnector の使用

jp.co.intra_mart.framework.base.data.IntramartFileServerConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.IntramartFileServerDAO の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.IntramartFileServerDAO の使用

jp.co.intra_mart.framework.base.data.IntramartFileServerDAO はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.JDBCConnector の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.JDBCConnector の使用

jp.co.intra_mart.framework.base.data.JDBCConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.LoginGroupDBConnector の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.LoginGroupDBConnector の使用

jp.co.intra_mart.framework.base.data.LoginGroupDBConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.LoginGroupDBDAO の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.LoginGroupDBDAO の使用

jp.co.intra_mart.framework.base.data.LoginGroupDBDAO はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.ResourceModel の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.ResourceModel の使用

jp.co.intra_mart.framework.base.data.ResourceModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.ResourceParam の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.ResourceParam の使用

ResourceParam を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での ResourceParam の使用

ResourceParam を返す jp.co.intra_mart.framework.base.data のメソッド
ResourceParam[] | XmlDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
ResourceParam[] | TextFileDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
ResourceParam[] | DistributesDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
ResourceParam[] | DefaultDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
ResourceParam[] | DataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。

ResourceParam 型のパラメータを持つ jp.co.intra_mart.framework.base.data のメソッド
protected Connection | JDBCConnector.putResource(String resource, ResourceParam[] params) 推奨されていません。 接続先のリソースを追加します。
protected abstract Connection | DBConnector.putResource(String resource, ResourceParam[] params) 接続先のリソースを追加します。
protected Connection | DataSourceConnector.putResource(String resource, ResourceParam[] params) 接続先のリソースを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.SystemDBConnector の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.SystemDBConnector の使用

jp.co.intra_mart.framework.base.data.SystemDBConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.SystemDBDAO の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.SystemDBDAO の使用

jp.co.intra_mart.framework.base.data.SystemDBDAO はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler の使用

jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler の使用

jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.data.container.DataContainer の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.data.container.DataContainer の使用

DataContainer を使用しているパッケージ
jp.co.intra_mart.framework.base.data.container

jp.co.intra_mart.framework.base.data.container での DataContainer の使用

DataContainer を実装している jp.co.intra_mart.framework.base.data.container のクラス
 class DataContainerImpl
DataContainerの標準的な実装クラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.container.DataContainerException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.container.DataContainerException の使用

jp.co.intra_mart.framework.base.data.container.DataContainerException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.container.DataContainerImpl の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.container.DataContainerImpl の使用

jp.co.intra_mart.framework.base.data.container.DataContainerImpl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.container.factory.DataContainerFactory の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.container.factory.DataContainerFactory の使用

jp.co.intra_mart.framework.base.data.container.factory.DataContainerFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.container.factory.DefaultDataProvider の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.container.factory.DefaultDataProvider の使用

jp.co.intra_mart.framework.base.data.container.factory.DefaultDataProvider はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DataContainerFactory (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data.container.factory
クラス DataContainerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.container.factory.DataContainerFactory
すべての実装インタフェース:
IMContainerFactory
public class DataContainerFactory
extends Object
implements IMContainerFactory

DataContainerのファクトリクラスです。 生成されるデータコンテナはプロバイダーにより決定されます。

導入されたバージョン:
6.0

フィールドの概要
protected static Provider provider
コンストラクタの概要
DataContainerFactory()
メソッドの概要
IMContainer | create() DataContainerを生成します。
Provider | getProvider() プロバイダを返します。
void | setProvider(Provider p) プロバイダを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

provider

protected static Provider provider
コンストラクタの詳細

DataContainerFactory

public DataContainerFactory()
メソッドの詳細

create

public IMContainer create()
                   throws IMContainerException
DataContainerを生成します。

定義:
インタフェース IMContainerFactory 内の create
戻り値:
データコンテナ
例外:
IMContainerException - データコンテナ生成時に例外が発生。

getProvider

public Provider getProvider()
プロバイダを返します。

定義:
インタフェース IMContainerFactory 内の getProvider
戻り値:
データコンテナのプロバイダ

setProvider

public void setProvider(Provider p)
プロバイダを設定します。

定義:
インタフェース IMContainerFactory 内の setProvider
パラメータ:
p - データコンテナのプロバイダ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DefaultDataProvider (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data.container.factory
クラス DefaultDataProvider

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.container.factory.DefaultDataProvider
すべての実装インタフェース:
Provider
public class DefaultDataProvider
extends Object
implements Provider

標準的なプロバイダーです。
クラスパス上のリソースファイルを取得し、データコンテナの実装を決定します。

リソースファイル名 - imartContainer.properties
キー - dataContainer

キーにはDataContainerインターフェースの実装クラスをフルパッケージ名で指定してください。

導入されたバージョン:
6.0

コンストラクタの概要
DefaultDataProvider()
DefaultDataProviderを新規に生成します。
メソッドの概要
 IMContainer create()
DataContainerを生成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DefaultDataProvider

public DefaultDataProvider()
DefaultDataProviderを新規に生成します。

メソッドの詳細

create

public IMContainer create()
                   throws IMContainerException
DataContainerを生成します。

定義:
インタフェース Provider 内の create
戻り値:
データコンテナ
例外:
IMContainerException - データコンテナ生成時に例外が発生。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.data.container.factory (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.base.data.container.factory
クラス
DataContainerFactory
DefaultDataProvider


jp.co.intra_mart.framework.base.data.container.factory (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.data.container.factory

クラスの概要
DataContainerFactory | DataContainerのファクトリクラスです。
DefaultDataProvider | 標準的なプロバイダーです。


jp.co.intra_mart.framework.base.data.container.factory クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.data.container.factory の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.data.container.factory.DataContainerFactory (implements jp.co.intra_mart.framework.system.container.factory.IMContainerFactory)
    • class jp.co.intra_mart.framework.base.data.container.factory.DefaultDataProvider (implements jp.co.intra_mart.framework.system.container.factory.Provider)


パッケージ jp.co.intra_mart.framework.base.data.container.factory の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.data.container.factory の使用

jp.co.intra_mart.framework.base.data.container.factory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DataContainer (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data.container
インタフェース DataContainer

すべてのスーパーインタフェース:
IMContainer
既知の実装クラスの一覧:
DataContainerImpl
public interface DataContainer
extends IMContainer

データコンテナのインターフェースです。
データコンテナはDataManagerの振る舞いを決定します。 DataManagerではデータコンテナを保管し、その挙動はデータコンテナの実装クラスに依存します。 データコンテナの実装は通常DataContainerFactoryによって生成されます。

導入されたバージョン:
6.0

フィールドの概要
static String DATA_PROPERTY_HANDLER_KEY
データプロパティハンドラのキー
メソッドの概要
DataAccessController | getDataAccessController() データアクセスコントローラを取得します。
DataPropertyHandler | getDataPropertyHandler() データプロパティハンドラを取得します。
インタフェース jp.co.intra_mart.framework.system.container.IMContainer から継承したメソッド
init

フィールドの詳細

DATA_PROPERTY_HANDLER_KEY

public static final String DATA_PROPERTY_HANDLER_KEY
データプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getDataPropertyHandler

public DataPropertyHandler getDataPropertyHandler()
データプロパティハンドラを取得します。

戻り値:
データプロパティハンドラ

getDataAccessController

public DataAccessController getDataAccessController()
データアクセスコントローラを取得します。

戻り値:
データアクセスコントローラ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DataContainerException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data.container
クラス DataContainerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.container.DataContainerException
すべての実装インタフェース:
Serializable
public class DataContainerException
extends SystemException

データコンテナ設定時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DataContainerException()
詳細メッセージを指定しないで DataContainerException を構築します。
DataContainerException(String msg)
指定された詳細メッセージを持つ DataContainerException を構築します。
DataContainerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataContainerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataContainerException

public DataContainerException()
詳細メッセージを指定しないで DataContainerException を構築します。

DataContainerException

public DataContainerException(String msg)
指定された詳細メッセージを持つ DataContainerException を構築します。

パラメータ:
msg - 詳細メッセージ

DataContainerException

public DataContainerException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataContainerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DataContainerImpl (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data.container
クラス DataContainerImpl

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.container.DataContainerImpl
すべての実装インタフェース:
DataContainer, IMContainer
public class DataContainerImpl
extends Object
implements DataContainer

DataContainerの標準的な実装クラスです。

フィールドの概要
インタフェース jp.co.intra_mart.framework.base.data.container.DataContainer から継承したフィールド
DATA_PROPERTY_HANDLER_KEY
コンストラクタの概要
DataContainerImpl()
DataContainerImplを生成します。
メソッドの概要
DataAccessController | getDataAccessController() データアクセスコントローラを取得します。
DataPropertyHandler | getDataPropertyHandler() データプロパティハンドラを取得します。
void | init() DataContainerを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DataContainerImpl

public DataContainerImpl()
DataContainerImplを生成します。

メソッドの詳細

init

public void init()
          throws IMContainerException
DataContainerを初期化します。

定義:
インタフェース IMContainer 内の init
例外:
IMContainerException

getDataPropertyHandler

public DataPropertyHandler getDataPropertyHandler()
データプロパティハンドラを取得します。

定義:
インタフェース DataContainer 内の getDataPropertyHandler
戻り値:
データプロパティハンドラ

getDataAccessController

public DataAccessController getDataAccessController()
データアクセスコントローラを取得します。

定義:
インタフェース DataContainer 内の getDataAccessController
戻り値:
データアクセスコントローラ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.data.container (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.base.data.container
インタフェース
DataContainer
クラス
DataContainerImpl
例外
DataContainerException


jp.co.intra_mart.framework.base.data.container (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.data.container

インタフェースの概要
DataContainer データコンテナのインターフェースです。

クラスの概要
DataContainerImpl DataContainerの標準的な実装クラスです。

例外の概要
DataContainerException データコンテナ設定時の例外です。


jp.co.intra_mart.framework.base.data.container クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.data.container の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.data.container.DataContainerImpl (implements jp.co.intra_mart.framework.base.data.container.DataContainer)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.data.container.DataContainerException

インタフェース階層

  • interface jp.co.intra_mart.framework.system.container.IMContainer
    • interface jp.co.intra_mart.framework.base.data.container.DataContainer


パッケージ jp.co.intra_mart.framework.base.data.container の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.data.container の使用

jp.co.intra_mart.framework.base.data.container を使用しているパッケージ
jp.co.intra_mart.framework.base.data.container

jp.co.intra_mart.framework.base.data.container により使用される jp.co.intra_mart.framework.base.data.container のクラス
DataContainer
データコンテナのインターフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ConnectorModel (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス ConnectorModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.ConnectorModel
public class ConnectorModel
extends Object

コネクタ情報を管理するクラスです。

バージョン:
1.0

フィールドの概要
static String | ID
static String | P_ID_CONNECTOR_CLASS
static String | P_ID_CONNECTOR_NAME
static String | P_ID_RESOURCE_NAME
コンストラクタの概要
ConnectorModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID

public static final String ID
関連項目:
定数フィールド値

P_ID_CONNECTOR_NAME

public static final String P_ID_CONNECTOR_NAME
関連項目:
定数フィールド値

P_ID_CONNECTOR_CLASS

public static final String P_ID_CONNECTOR_CLASS
関連項目:
定数フィールド値

P_ID_RESOURCE_NAME

public static final String P_ID_RESOURCE_NAME
関連項目:
定数フィールド値
コンストラクタの詳細

ConnectorModel

public ConnectorModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DAO (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
インタフェース DAO

既知の実装クラスの一覧:
DAOAdapter, DBDAO, IntramartDBDAO, IntramartFileServerDAO, LoginGroupDBDAO, SystemDBDAO
public interface DAO

データリソースにアクセスするインタフェースです。 すべてのDAOはこのインタフェースを実装する必要があります。

バージョン:
1.0

メソッドの概要
 void setConnectInfo(DataConnector connector, String resource, String key, String connect)
データリソースに接続する時の情報を設定します。

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
データリソースに接続する時の情報を設定します。

パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DAOAdapter (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DAOAdapter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DAOAdapter
すべての実装インタフェース:
DAO
public class DAOAdapter
extends Object
implements DAO

DAOのすべてのメソッドを何もしないように実装したクラスです。 データリソースへの接続を必要としない場合や、 開発時のスタブ用のDAOとして一時的に使うDAOを作るときなどは このクラスを継承すると便利です。

導入されたバージョン:
3.2

コンストラクタの概要
DAOAdapter()
DAOAdapterを新規に生成します。
メソッドの概要
 void setConnectInfo(DataConnector connector, String resource, String key, String connect)
データリソースに接続する時の情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DAOAdapter

public DAOAdapter()
DAOAdapterを新規に生成します。

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
データリソースに接続する時の情報を設定します。 このクラスではkのメソッドは何もしません。

定義:
インタフェース DAO 内の setConnectInfo
パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DAOException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DAOException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.DAOException
すべての実装インタフェース:
Serializable
public class DAOException
extends SystemException

リソースコネクタの情報取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DAOException()
詳細メッセージを指定しないで DAOException を構築します。
DAOException(String msg)
指定された詳細メッセージを持つ DAOException を構築します。
DAOException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DAOException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DAOException

public DAOException()
詳細メッセージを指定しないで DAOException を構築します。

DAOException

public DAOException(String msg)
指定された詳細メッセージを持つ DAOException を構築します。

パラメータ:
msg - 詳細メッセージ

DAOException

public DAOException(String msg,
                    Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DAOException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DaoModel (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DaoModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DaoModel
public class DaoModel
extends Object

DaoModelを管理するクラスです。

バージョン:
1.0

フィールドの概要
static String | ID
static String | P_ID_CONNECT_NAME
static String | P_ID_DAO_CLASS
static String | P_ID_DAO_CONNECTOR_NAME
コンストラクタの概要
DaoModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID

public static final String ID
関連項目:
定数フィールド値

P_ID_CONNECT_NAME

public static final String P_ID_CONNECT_NAME
関連項目:
定数フィールド値

P_ID_DAO_CLASS

public static final String P_ID_DAO_CLASS
関連項目:
定数フィールド値

P_ID_DAO_CONNECTOR_NAME

public static final String P_ID_DAO_CONNECTOR_NAME
関連項目:
定数フィールド値
コンストラクタの詳細

DaoModel

public DaoModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataAccessController (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataAccessController

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataAccessController
public class DataAccessController
extends Object

データアクセスを制御します。 DAOの取得、コネクタの管理等を行います。 このクラスを利用して簡易トランザクションを実現することも可能ですが、この方法は推奨されません。 トランザクションはできる限りJava Transaction API(JTA)のUserTransactionを利用して行ってください。

バージョン:
1.0

コンストラクタの概要
DataAccessController(DataPropertyHandler handler)
データアクセスコントローラを生成します。
メソッドの概要
void | commit() すべてのデータコネクタをコミットします。
Object | getDAO(String application, String key, String connect) DAOを取得します。
protected Map | getDataConnectors() DataAccessControllerがキャッシュしているDataConnectorの一覧を取得します。
DataPropertyHandler | getDataPropertyHandler() データプロパティハンドラを取得します。
void | release() すべてのデータストアの資源を解放します。
void | rollback() すべてのデータコネクタをロールバックします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DataAccessController

public DataAccessController(DataPropertyHandler handler)
データアクセスコントローラを生成します。

パラメータ:
handler - データプロパティハンドラ
メソッドの詳細

getDataConnectors

protected Map getDataConnectors()
DataAccessControllerがキャッシュしているDataConnectorの一覧を取得します。

戻り値:
DataConnector

getDataPropertyHandler

public DataPropertyHandler getDataPropertyHandler()
データプロパティハンドラを取得します。

戻り値:
データプロパティハンドラ
導入されたバージョン:
6.0

getDAO

public Object getDAO(String application,
                     String key,
                     String connect)
              throws DataPropertyException,
                     DataConnectorException,
                     DAOException,
                     DataConnectException
DAOを取得します。 キーと接続情報で指定されたDAOを取得します。

パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAO
例外:
DataPropertyException - プロパティの取得に失敗
DataConnectorException - データコネクタの取得に失敗
DAOException - DAOの取得に失敗
DataConnectException - データリソースとの接続に失敗

commit

public void commit()
            throws DataConnectException
すべてのデータコネクタをコミットします。 このメソッドはこのクラスのgetDAO(String, String, String)で取得されたDAOに関連するデータコネクタのDataConnector.commit()を順に呼び出すことで簡易的なトランザクションを実現しています。 そのため、複数のデータベースにアクセスしたトランザクションの場合は2-Phaseコミットほど堅牢なトランザクションにはならない場合があります。

例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
すべてのデータコネクタをロールバックします。 このメソッドはこのクラスのgetDAO(String, String, String)で取得されたDAOに関連するデータコネクタのDataConnector.rollback()を順に呼び出すことで簡易的なトランザクションを実現しています。 そのため、複数のデータベースにアクセスしたトランザクションの場合は2-Phaseコミットほど堅牢なトランザクションにはならない場合があります。

例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
すべてのデータストアの資源を解放します。 このメソッドはこのクラスのgetDAO(String, String, String)で取得されたDAOに関連するデータコネクタのDataConnector.release()を順に呼び出しています。

例外:
DataConnectException - 資源開放に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataAccessException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataAccessException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.DataAccessException
すべての実装インタフェース:
Serializable
public class DataAccessException
extends SystemException

データアクセス時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DataAccessException()
詳細メッセージを指定しないで DataAccessException を構築します。
DataAccessException(String msg)
指定された詳細メッセージを持つ DataAccessException を構築します。
DataAccessException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataAccessException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataAccessException

public DataAccessException()
詳細メッセージを指定しないで DataAccessException を構築します。

DataAccessException

public DataAccessException(String msg)
指定された詳細メッセージを持つ DataAccessException を構築します。

パラメータ:
msg - 詳細メッセージ

DataAccessException

public DataAccessException(String msg,
                           Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataAccessException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataConnectException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataConnectException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.DataConnectException
すべての実装インタフェース:
Serializable
public class DataConnectException
extends SystemException

データ接続に関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DataConnectException()
詳細メッセージを指定しないで DataConnectException を構築します。
DataConnectException(String msg)
指定された詳細メッセージを持つ DataConnectException を構築します。
DataConnectException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataConnectException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataConnectException

public DataConnectException()
詳細メッセージを指定しないで DataConnectException を構築します。

DataConnectException

public DataConnectException(String msg)
指定された詳細メッセージを持つ DataConnectException を構築します。

パラメータ:
msg - 詳細メッセージ

DataConnectException

public DataConnectException(String msg,
                            Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataConnectException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataConnector (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
直系の既知のサブクラス:
DBConnector, IntramartDBConnector, IntramartFileServerConnector, LoginGroupDBConnector, SystemDBConnector
public abstract class DataConnector
extends Object

データストアに接続するコネクタです。

バージョン:
1.0

コンストラクタの概要
DataConnector()
新規のDataConnectorを生成します。
メソッドの概要
abstract void | commit() コミットします。
DataPropertyHandler | getDataPropertyHandler() データプロパティハンドラを取得します。
protected abstract Object | getResource(String key, String connect, String resource) リソースを取得します。
abstract void | release() データストアの資源を解放します。
abstract void | rollback() ロールバックします。
void | setDataPropertyHandler(DataPropertyHandler handler) データプロパティハンドラを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DataConnector

public DataConnector()
新規のDataConnectorを生成します。

メソッドの詳細

setDataPropertyHandler

public void setDataPropertyHandler(DataPropertyHandler handler)
データプロパティハンドラを設定します。

パラメータ:
handler - データプロパティハンドラ

getDataPropertyHandler

public DataPropertyHandler getDataPropertyHandler()
データプロパティハンドラを取得します。

戻り値:
データプロパティハンドラ

getResource

protected abstract Object getResource(String key,
                                      String connect,
                                      String resource)
                               throws DataPropertyException,
                                      DataConnectException
リソースを取得します。

パラメータ:
key - キー
connect - 接続情報
resource - リソース名
戻り値:
リソース
例外:
DataPropertyException - リソースの取得に失敗
DataConnectException - 接続に失敗

commit

public abstract void commit()
                     throws DataConnectException
コミットします。

例外:
DataConnectException - コミットに失敗

rollback

public abstract void rollback()
                       throws DataConnectException
ロールバックします。

例外:
DataConnectException - ロールバックに失敗

release

public abstract void release()
                      throws DataConnectException
データストアの資源を解放します。

例外:
DataConnectException - 資源開放に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataConnectorException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataConnectorException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.DataConnectorException
すべての実装インタフェース:
Serializable
public class DataConnectorException
extends SystemException

データコネクタ取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DataConnectorException()
詳細メッセージを指定しないで DataConnectorException を構築します。
DataConnectorException(String msg)
指定された詳細メッセージを持つ DataConnectorException を構築します。
DataConnectorException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataConnectorException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataConnectorException

public DataConnectorException()
詳細メッセージを指定しないで DataConnectorException を構築します。

DataConnectorException

public DataConnectorException(String msg)
指定された詳細メッセージを持つ DataConnectorException を構築します。

パラメータ:
msg - 詳細メッセージ

DataConnectorException

public DataConnectorException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataConnectorException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataManager (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataManager
public class DataManager
extends Object

データストアとの接続を管理します。

バージョン:
1.0

フィールドの概要
static String DATA_PROPERTY_HANDLER_KEY
データプロパティハンドラのキー
コンストラクタの概要
protected DataManager()
データマネージャを生成するコンストラクタです。
メソッドの概要
DataAccessController | getDataAccessController() データアクセスコントローラを取得します。
static DataManager | getDataManager() データマネージャを取得します。
DataPropertyHandler | getDataPropertyHandler() データプロパティハンドラを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DATA_PROPERTY_HANDLER_KEY

public static final String DATA_PROPERTY_HANDLER_KEY
データプロパティハンドラのキー

関連項目:
定数フィールド値
コンストラクタの詳細

DataManager

protected DataManager()
               throws DataManagerException
データマネージャを生成するコンストラクタです。 このコンストラクタは明示的に呼び出すことはできません。

例外:
DataManagerException - データマネージャの生成に失敗した
メソッドの詳細

getDataManager

public static DataManager getDataManager()
                                  throws DataManagerException
データマネージャを取得します。

戻り値:
データマネージャ
例外:
DataManagerException - データマネージャの設定に失敗した

getDataAccessController

public DataAccessController getDataAccessController()
データアクセスコントローラを取得します。

戻り値:
データアクセスコントローラ

getDataPropertyHandler

public DataPropertyHandler getDataPropertyHandler()
データプロパティハンドラを取得します。

戻り値:
データプロパティハンドラ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataManagerException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.DataManagerException
すべての実装インタフェース:
Serializable
public class DataManagerException
extends SystemException

データマネージャの設定時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DataManagerException()
詳細メッセージを指定しないで DataManagerException を構築します。
DataManagerException(String msg)
指定された詳細メッセージを持つ DataManagerException を構築します。
DataManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataManagerException

public DataManagerException()
詳細メッセージを指定しないで DataManagerException を構築します。

DataManagerException

public DataManagerException(String msg)
指定された詳細メッセージを持つ DataManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

DataManagerException

public DataManagerException(String msg,
                            Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataPropertyException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataPropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.DataPropertyException
すべての実装インタフェース:
Serializable
public class DataPropertyException
extends SystemException

データプロパティ取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DataPropertyException()
詳細メッセージを指定しないで DataPropertyException を構築します。
DataPropertyException(String msg)
指定された詳細メッセージを持つ DataPropertyException を構築します。
DataPropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataPropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataPropertyException

public DataPropertyException()
詳細メッセージを指定しないで DataPropertyException を構築します。

DataPropertyException

public DataPropertyException(String msg)
指定された詳細メッセージを持つ DataPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

DataPropertyException

public DataPropertyException(String msg,
                             Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DataPropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
インタフェース DataPropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultDataPropertyHandler, DistributesDataPropertyHandler, TextFileDataPropertyHandler, XmlDataPropertyHandler
public interface DataPropertyHandler
extends PropertyHandler

DAOの設定情報に接続するクラスです。

バージョン:
1.0

メソッドの概要
String | getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
String | getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
ResourceParam[] | getResourceParams(String name) リソースのパラメータを取得します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws DataPropertyException
プロパティの動的読み込みが可能かどうか調べます。

戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可
例外:
DataPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getDAOName

public String getDAOName(String application,
                         String key,
                         String connect)
                  throws DataPropertyException
DAOのクラス名を取得します。 application、keyとconnectで指定されたDAOのクラス名を取得します。

パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAOのクラス名
例外:
DataPropertyException - DAOのクラス名の取得に失敗

getConnectorName

public String getConnectorName(String application,
                               String key,
                               String connect)
                        throws DataPropertyException
DAOに対するデータコネクタ名を取得します。 application、keyとconnectで指定されたDAOのデータコネクタ名を取得します。 対応するデータコネクタ名が指定されていない場合、nullが返ります。

パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
データコネクタの名前
例外:
DataPropertyException - データコネクタ名の取得時に例外が発生

getConnectorClassName

public String getConnectorClassName(String connectorName)
                             throws DataPropertyException
データコネクタのクラス名を取得します。 application、keyとconnectで指定されたデータコネクタのクラス名を取得します。

パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのクラス名
例外:
DataPropertyException - データコネクタのクラス名の取得に失敗

getConnectorResource

public String getConnectorResource(String connectorName)
                            throws DataPropertyException
データコネクタのリソース名を取得します。 application、keyとconnectで指定されたデータコネクタのリソース名を取得します。 対応するリソース名がない場合、nullを返します。

パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのリソース名
例外:
DataPropertyException - データコネクタのリソース名の取得時に例外が発生

getResourceParams

public ResourceParam[] getResourceParams(String name)
                                  throws DataPropertyException
リソースのパラメータを取得します。 nameで指定されたリソースのパラメータを取得します。

パラメータ:
name - リソース名
戻り値:
リソースのパラメータ
例外:
DataPropertyException - リソースのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DataSourceConnector (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataSourceConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.DBConnector
            拡張 jp.co.intra_mart.framework.base.data.DataSourceConnector
public class DataSourceConnector
extends DBConnector

DataSourceに関連するデータコネクタです。 このデータコネクタはJava Transaction API(JTA)のUserTransactionの中で使うことが前提となっています。 また、KEY_JNDI_NAMEで指定されるパラメータにDataSourceのJNDI名を必ず指定してください。

バージョン:
1.0

フィールドの概要
static String KEY_JNDI_NAME
DataSourceのJNDI名のキー
クラス jp.co.intra_mart.framework.base.data.DBConnector から継承したフィールド
resources
コンストラクタの概要
DataSourceConnector()
DataSourceConnectorを新規に生成します。
メソッドの概要
void | commit() コミットします。
protected Connection | putResource(String resource, ResourceParam[] params) 接続先のリソースを追加します。
void | release() データストアの資源を解放します。
void | rollback() ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DBConnector から継承したメソッド
getConnection, getResource
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KEY_JNDI_NAME

public static final String KEY_JNDI_NAME
DataSourceのJNDI名のキー

関連項目:
定数フィールド値
コンストラクタの詳細

DataSourceConnector

public DataSourceConnector()
DataSourceConnectorを新規に生成します。

メソッドの詳細

commit

public void commit()
            throws DataConnectException
コミットします。 実際にはこのクラスではこのメソッドは何もしません。

オーバーライド:
クラス DBConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
ロールバックします。 実際にはこのクラスではこのメソッドは何もしません。

オーバーライド:
クラス DBConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
データストアの資源を解放します。

オーバーライド:
クラス DBConnector 内の release
例外:
DataConnectException - 資源開放に失敗

putResource

protected Connection putResource(String resource,
                                 ResourceParam[] params)
                          throws DataConnectException
接続先のリソースを追加します。

定義:
クラス DBConnector 内の putResource
パラメータ:
resource - リソース
params - リソースのパラメータ
戻り値:
コネクション
例外:
DataConnectException - 接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBConnector (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DBConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.DBConnector
直系の既知のサブクラス:
DataSourceConnector, JDBCConnector
public abstract class DBConnector
extends DataConnector

データベースに対するコネクタです。

バージョン:
1.0

フィールドの概要
protected  Map resources
リソース一覧
コンストラクタの概要
DBConnector()
DBConnectorを新規に生成します。
メソッドの概要
void | commit() コミットします。
Connection | getConnection(String resource) データベースへのコネクションを取得します。
protected Object | getResource(String key, String connect, String resource) リソースを取得します。
protected abstract Connection | putResource(String resource, ResourceParam[] params) 接続先のリソースを追加します。
void | release() データストアの資源を解放します。
void | rollback() ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

resources

protected Map resources
リソース一覧

コンストラクタの詳細

DBConnector

public DBConnector()
DBConnectorを新規に生成します。

メソッドの詳細

putResource

protected abstract Connection putResource(String resource,
                                          ResourceParam[] params)
                                   throws DataConnectException
接続先のリソースを追加します。

パラメータ:
resource - リソース
params - リソースのパラメータ
戻り値:
コネクション
例外:
DataConnectException - 接続に失敗

getResource

protected Object getResource(String key,
                             String connect,
                             String resource)
                      throws DataPropertyException,
                             DataConnectException
リソースを取得します。

定義:
クラス DataConnector 内の getResource
パラメータ:
key - キー
connect - 接続情報
resource - リソース名
戻り値:
リソース
例外:
DataPropertyException - リソースの取得に失敗
DataConnectException - 接続に失敗

getConnection

public Connection getConnection(String resource)
                         throws DataPropertyException,
                                DataConnectException
データベースへのコネクションを取得します。

パラメータ:
resource - リソース名
戻り値:
データベースへのコネクション
例外:
DataPropertyException - データベースへのコネクションの取得に失敗
DataConnectException - データベースへの接続に失敗

commit

public void commit()
            throws DataConnectException
コミットします。 実際にはこのクラスではこのメソッドは何もしません。

定義:
クラス DataConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
ロールバックします。 実際にはこのクラスではこのメソッドは何もしません。

定義:
クラス DataConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
データストアの資源を解放します。

定義:
クラス DataConnector 内の release
例外:
DataConnectException - 資源開放に失敗 実際にはこのクラスではこのメソッドは何もしません。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBDAO (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DBDAO

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DBDAO
すべての実装インタフェース:
DAO
public abstract class DBDAO
extends Object
implements DAO

データベースに特化したDAOです。

バージョン:
1.0

コンストラクタの概要
DBDAO()
デフォルトのコンストラクタ
メソッドの概要
protected Connection | getConnection() このDAOに関連づけられたコネクションを取得します。
void | setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBDAO

public DBDAO()
デフォルトのコンストラクタ

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
データリソースに接続する時の情報を設定します。

定義:
インタフェース DAO 内の setConnectInfo
パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗

getConnection

protected Connection getConnection()
                            throws DataConnectException,
                                   DataPropertyException
このDAOに関連づけられたコネクションを取得します。

戻り値:
コネクション
例外:
DataConnectException - コネクションの取得に失敗
DataPropertyException - データプロパティの取得に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DefaultDataPropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DefaultDataPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler
すべての実装インタフェース:
DataPropertyHandler, PropertyHandler
public class DefaultDataPropertyHandler
extends Object
implements DataPropertyHandler

デフォルトのデータプロパティハンドラです。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「プレフィックス_アプリケーションID.properties」です。また、アプリケーションに依存しない「プレフィックス.properties」があります。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにDataManager.DATA_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスはDEFAULT_BUNDLE_NAME_PARAMで示されるものです。
プロパティの検索順は、アプリケーションごとのプロパティファイル「プレフィックス_アプリケーションID.properties」が優先されます。該当するプロパティが見つからない場合、引き続いて「プレフィックス.properties」を検索します。
プロパティの設定内容は以下のとおりです。

キー | 内容 | 共通 | アプリケーション毎
dao.class.キー.接続名 | キーと接続名に対応するDAOのクラス名 | × | ○
dao.class.キー | キーに対応するデフォルトのDAOのクラス名 | × | ○
dao.connector.キー.接続名 | キーと接続名に対応するDAOのデータコネクタ名 | × | ○
dao.connector.キー | キーに対応するデフォルトのDAOのデータコネクタ名 | × | ○
connector.class.データコネクタ名 | データコネクタ名に対応するデータコネクタのクラス名 | ○ | ×
connector.resource.データコネクタ名 | データコネクタ名に対応するデータコネクタのリソース名 | ○ | ×
resource.param.リソース名.パラメータ名 | リソース名に対応するリソースのパラメータの値 | ○ | ×

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
コンストラクタの概要
DefaultDataPropertyHandler()
DefaultDataPropertyHandlerを新規に生成します。
メソッドの概要
String | getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
String | getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
ResourceParam[] | getResourceParams(String name) リソースのパラメータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultDataPropertyHandler

public DefaultDataPropertyHandler()
DefaultDataPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws DataPropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース DataPropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
DataPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getDAOName

public String getDAOName(String application,
                         String key,
                         String connect)
                  throws DataPropertyException
DAOのクラス名を取得します。 application、keyとconnectで指定されたDAOのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getDAOName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAOのクラス名
例外:
DataPropertyException - DAOのクラス名の取得に失敗

getConnectorName

public String getConnectorName(String application,
                               String key,
                               String connect)
                        throws DataPropertyException
DAOに対するデータコネクタ名を取得します。 application、keyとconnectで指定されたDAOのデータコネクタ名を取得します。 対応するデータコネクタ名が指定されていない場合、nullが返ります。

定義:
インタフェース DataPropertyHandler 内の getConnectorName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
データコネクタの名前
例外:
DataPropertyException - データコネクタ名の取得時に例外が発生

getConnectorClassName

public String getConnectorClassName(String connectorName)
                             throws DataPropertyException
データコネクタのクラス名を取得します。 application、keyとconnectで指定されたデータコネクタのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getConnectorClassName
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのクラス名
例外:
DataPropertyException - データコネクタのクラス名の取得に失敗

getConnectorResource

public String getConnectorResource(String connectorName)
                            throws DataPropertyException
データコネクタのリソース名を取得します。 application、keyとconnectで指定されたデータコネクタのリソース名を取得します。 対応するリソース名がない場合、nullを返します。

定義:
インタフェース DataPropertyHandler 内の getConnectorResource
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのリソース名
例外:
DataPropertyException - データコネクタのリソース名の取得時に例外が発生

getResourceParams

public ResourceParam[] getResourceParams(String name)
                                  throws DataPropertyException
リソースのパラメータを取得します。 nameで指定されたリソースのパラメータを取得します。

定義:
インタフェース DataPropertyHandler 内の getResourceParams
パラメータ:
name - リソース名
戻り値:
リソースのパラメータ
例外:
DataPropertyException - リソースのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DistributesDataPropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DistributesDataPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler
すべての実装インタフェース:
DataPropertyHandler, PropertyHandler
public class DistributesDataPropertyHandler
extends Object
implements DataPropertyHandler

アプリケーション毎のプロパティハンドラを呼び出します。
プロパティファイルはアプリケーション毎に分割されます。
この場合のファイル名は「プレフィックス_アプリケーションID.properties」、「プレフィックス_アプリケーションID.xml」です。
また、アプリケーションに依存しない「プレフィックス.properties」があります。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにDataManager.DATA_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスはDEFAULT_BUNDLE_NAME_PARAMで示されるものです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
static String | PARAM_APPLICATION プロパティファイルのアプリケーションのパラメータ名
static String | PARAM_APPLICATION_CLASS プロパティファイルのクラスのパラメータ名
static String | PARAM_APPLICATION_PARAM プロパティファイルのパラメータのパラメータ名
static String | PARAM_BUNDLE プロパティファイルのバンドルのパラメータ名
static String | PARAM_DEFAULT プロパティファイルのデフォルトのパラメータ名
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
コンストラクタの概要
DistributesDataPropertyHandler()
DefaultDataPropertyHandlerを新規に生成します。
メソッドの概要
String | getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
String | getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
ResourceParam[] | getResourceParams(String name) リソースのパラメータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値

PARAM_DEFAULT

public static final String PARAM_DEFAULT
プロパティファイルのデフォルトのパラメータ名

関連項目:
定数フィールド値

PARAM_APPLICATION

public static final String PARAM_APPLICATION
プロパティファイルのアプリケーションのパラメータ名

関連項目:
定数フィールド値

PARAM_APPLICATION_PARAM

public static final String PARAM_APPLICATION_PARAM
プロパティファイルのパラメータのパラメータ名

関連項目:
定数フィールド値

PARAM_APPLICATION_CLASS

public static final String PARAM_APPLICATION_CLASS
プロパティファイルのクラスのパラメータ名

関連項目:
定数フィールド値

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値

PARAM_BUNDLE

public static final String PARAM_BUNDLE
プロパティファイルのバンドルのパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DistributesDataPropertyHandler

public DistributesDataPropertyHandler()
DefaultDataPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws DataPropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース DataPropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
DataPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getDAOName

public String getDAOName(String application,
                         String key,
                         String connect)
                  throws DataPropertyException
DAOのクラス名を取得します。 application、keyとconnectで指定されたDAOのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getDAOName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAOのクラス名
例外:
DataPropertyException - DAOのクラス名の取得に失敗

getConnectorName

public String getConnectorName(String application,
                               String key,
                               String connect)
                        throws DataPropertyException
DAOに対するデータコネクタ名を取得します。 application、keyとconnectで指定されたDAOのデータコネクタ名を取得します。 対応するデータコネクタ名が指定されていない場合、nullが返ります。

定義:
インタフェース DataPropertyHandler 内の getConnectorName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
データコネクタの名前
例外:
DataPropertyException - データコネクタ名の取得時に例外が発生

getConnectorClassName

public String getConnectorClassName(String connectorName)
                             throws DataPropertyException
データコネクタのクラス名を取得します。 application、keyとconnectで指定されたデータコネクタのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getConnectorClassName
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのクラス名
例外:
DataPropertyException - データコネクタのクラス名の取得に失敗

getConnectorResource

public String getConnectorResource(String connectorName)
                            throws DataPropertyException
データコネクタのリソース名を取得します。 application、keyとconnectで指定されたデータコネクタのリソース名を取得します。 対応するリソース名がない場合、nullを返します。

定義:
インタフェース DataPropertyHandler 内の getConnectorResource
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのリソース名
例外:
DataPropertyException - データコネクタのリソース名の取得時に例外が発生

getResourceParams

public ResourceParam[] getResourceParams(String name)
                                  throws DataPropertyException
リソースのパラメータを取得します。 nameで指定されたリソースのパラメータを取得します。

定義:
インタフェース DataPropertyHandler 内の getResourceParams
パラメータ:
name - リソース名
戻り値:
リソースのパラメータ
例外:
DataPropertyException - リソースのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartDBConnector (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス IntramartDBConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.IntramartDBConnector
推奨されていません。 このクラスではなくLoginGroupDBConnectorまたは SystemDBConnectorを使用してください。

public class IntramartDBConnector
extends DataConnector

イントラマートで設定されているDBコネクションです。

バージョン:
1.0

フィールドの概要
protected  Map connections
推奨されていません。 DbsConnectionの一覧
コンストラクタの概要
IntramartDBConnector()
推奨されていません。 IntramartDBConnectorを新規に生成します。
メソッドの概要
void | commit() 推奨されていません。 コミットします。
jp.co.intra_mart.foundation.database.DbsConnection | getConnection(String connect) 推奨されていません。 データベースへのコネクションを取得します。
protected Object | getResource(String key, String connect, String resource) 推奨されていません。 リソースを取得します。
void | release() 推奨されていません。 データストアの資源を解放します。
void | rollback() 推奨されていません。 ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

connections

protected Map connections
推奨されていません。
DbsConnectionの一覧

コンストラクタの詳細

IntramartDBConnector

public IntramartDBConnector()
推奨されていません。
IntramartDBConnectorを新規に生成します。

メソッドの詳細

commit

public void commit()
            throws DataConnectException
推奨されていません。
コミットします。

定義:
クラス DataConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
推奨されていません。
ロールバックします。

定義:
クラス DataConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
推奨されていません。
データストアの資源を解放します。

定義:
クラス DataConnector 内の release
例外:
DataConnectException - 資源開放に失敗

getResource

protected Object getResource(String key,
                             String connect,
                             String resource)
                      throws DataPropertyException,
                             DataConnectException
推奨されていません。
リソースを取得します。

定義:
クラス DataConnector 内の getResource
パラメータ:
key - キー
connect - 接続情報
resource - リソース名
戻り値:
リソース
例外:
DataPropertyException - リソースの取得に失敗
DataConnectException - 接続に失敗

getConnection

public jp.co.intra_mart.foundation.database.DbsConnection getConnection(String connect)
                                                                 throws DataPropertyException,
                                                                        DataConnectException
推奨されていません。
データベースへのコネクションを取得します。

パラメータ:
connect - 接続情報
戻り値:
データベースへのコネクション
例外:
DataPropertyException - データベースへのコネクションの取得に失敗
DataConnectException - データベースへの接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartDBDAO (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス IntramartDBDAO

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.IntramartDBDAO
すべての実装インタフェース:
DAO
推奨されていません。 このクラスではなくLoginGroupDBDAOまたは SystemDBDAOを使用してください。

public class IntramartDBDAO
extends Object
implements DAO

イントラマートで設定されたDBへアクセスするDAOです。 イントラマートで設定されたDBへアクセスするDAOを作る場合、このクラスをextendsします。

バージョン:
1.0

コンストラクタの概要
IntramartDBDAO()
推奨されていません。 IntramartDBDAOを新規に生成します。
メソッドの概要
jp.co.intra_mart.foundation.database.DbsConnection | getConnection() 推奨されていません。 イントラマートで設定されているDBへのコネクションを取得します。
void | setConnectInfo(DataConnector connector, String resource, String key, String connect) 推奨されていません。 データリソースに接続する時の情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartDBDAO

public IntramartDBDAO()
推奨されていません。
IntramartDBDAOを新規に生成します。

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
推奨されていません。
データリソースに接続する時の情報を設定します。

定義:
インタフェース DAO 内の setConnectInfo
パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗

getConnection

public jp.co.intra_mart.foundation.database.DbsConnection getConnection()
                                                                 throws DataConnectException,
                                                                        DataPropertyException
推奨されていません。
イントラマートで設定されているDBへのコネクションを取得します。

戻り値:
イントラマートで設定されているDBへのコネクション
例外:
DataConnectException - データベース接続時に例外が発生
DataPropertyException - データプロパティ取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartFileServerConnector (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス IntramartFileServerConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.IntramartFileServerConnector
public class IntramartFileServerConnector
extends DataConnector

intra-martのStorageサービスに接続するデータコネクタです。 Storageサービスに対する各種のオペレーションは呼び出し終了時に書き込み等が完了するため、 実際にはトランザクションの対象とならないため注意が必要です。

導入されたバージョン:
3.2

フィールドの概要
protected  Map resources
リソース一覧
コンストラクタの概要
IntramartFileServerConnector()
IntramartFileServerConnectorを新規に生成します。
メソッドの概要
void | commit() コミットします。
jp.co.intra_mart.foundation.service.client.file.NetworkFile | getNetworkFile(String path) Storageサービス上の指定されたパスのファイルにアクセスするNetworkFileを取得します。
protected Object | getResource(String key, String connect, String resource) リソースを取得します。
void | release() データストアの資源を解放します。
void | rollback() ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

resources

protected Map resources
リソース一覧

コンストラクタの詳細

IntramartFileServerConnector

public IntramartFileServerConnector()
IntramartFileServerConnectorを新規に生成します。

メソッドの詳細

getResource

protected Object getResource(String key,
                             String connect,
                             String resource)
                      throws DataPropertyException,
                             DataConnectException
リソースを取得します。

定義:
クラス DataConnector 内の getResource
パラメータ:
key - キー
connect - 接続情報
resource - リソース名
戻り値:
リソース
例外:
DataPropertyException - リソースの取得に失敗
DataConnectException - 接続に失敗

getNetworkFile

public jp.co.intra_mart.foundation.service.client.file.NetworkFile getNetworkFile(String path)
Storageサービス上の指定されたパスのファイルにアクセスするNetworkFileを取得します。

パラメータ:
path - Storageサービス上のパス
戻り値:
Storageサービス上の指定されたパスのファイルにアクセスするNetworkFile

commit

public void commit()
            throws DataConnectException
コミットします。 注意:実際にはNetworkFileの各種のメソッド完了時に書き込み等が行われています。

定義:
クラス DataConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
ロールバックします。 注意:実際にはNetworkFileの各種のメソッド完了時に書き込み等が行われているため、既にファイルに書き込んだ情報は元に戻りません。

定義:
クラス DataConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
データストアの資源を解放します。

定義:
クラス DataConnector 内の release
例外:
DataConnectException - 資源開放に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartFileServerDAO (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス IntramartFileServerDAO

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.IntramartFileServerDAO
すべての実装インタフェース:
DAO
public class IntramartFileServerDAO
extends Object
implements DAO

intra-martのStorageサービスを使用する場合のDAOです。

導入されたバージョン:
3.2

コンストラクタの概要
IntramartFileServerDAO()
IntramartFileServerDAOを新規に生成します。
メソッドの概要
protected jp.co.intra_mart.foundation.service.client.file.NetworkFile | getNetworkFile(String path) パスに該当するNetworkFileを取得します。
void | setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartFileServerDAO

public IntramartFileServerDAO()
IntramartFileServerDAOを新規に生成します。

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
データリソースに接続する時の情報を設定します。

定義:
インタフェース DAO 内の setConnectInfo
パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗

getNetworkFile

protected jp.co.intra_mart.foundation.service.client.file.NetworkFile getNetworkFile(String path)
                                                                              throws DataConnectorException
パスに該当するNetworkFileを取得します。

パラメータ:
path - intra-martStorageサービス上のファイルパス
戻り値:
パスに該当するNetworkFile
例外:
DataConnectorException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


JDBCConnector (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス JDBCConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.DBConnector
            拡張 jp.co.intra_mart.framework.base.data.JDBCConnector
推奨されていません。 JDBCを直接扱わず、DataSourceを使用するようにしてください。

public class JDBCConnector
extends DBConnector

JDBCを利用するデータコネクタです。

バージョン:
1.0
関連項目:
DataSourceConnector

フィールドの概要
static String | KEY_DRIVER 推奨されていません。 データベースドライバのキー
static String | KEY_PASSWORD 推奨されていません。 データベース接続ユーザパスワードのキー
static String | KEY_URL 推奨されていません。 データベースURLのキー
static String | KEY_USERNAME 推奨されていません。 データベース接続ユーザ名のキー
クラス jp.co.intra_mart.framework.base.data.DBConnector から継承したフィールド
resources
コンストラクタの概要
JDBCConnector()
推奨されていません。 新規のJDBCConnectorを生成します。
メソッドの概要
void | commit() 推奨されていません。 コミットします。
protected Connection | putResource(String resource, ResourceParam[] params) 推奨されていません。 接続先のリソースを追加します。
void | release() 推奨されていません。 データストアの資源を解放します。
void | rollback() 推奨されていません。 ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DBConnector から継承したメソッド
getConnection, getResource
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KEY_DRIVER

public static final String KEY_DRIVER
推奨されていません。
データベースドライバのキー

関連項目:
定数フィールド値

KEY_URL

public static final String KEY_URL
推奨されていません。
データベースURLのキー

関連項目:
定数フィールド値

KEY_USERNAME

public static final String KEY_USERNAME
推奨されていません。
データベース接続ユーザ名のキー

関連項目:
定数フィールド値

KEY_PASSWORD

public static final String KEY_PASSWORD
推奨されていません。
データベース接続ユーザパスワードのキー

関連項目:
定数フィールド値
コンストラクタの詳細

JDBCConnector

public JDBCConnector()
推奨されていません。
新規のJDBCConnectorを生成します。

メソッドの詳細

commit

public void commit()
            throws DataConnectException
推奨されていません。
コミットします。

オーバーライド:
クラス DBConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
推奨されていません。
ロールバックします。

オーバーライド:
クラス DBConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
推奨されていません。
データストアの資源を解放します。

オーバーライド:
クラス DBConnector 内の release
例外:
DataConnectException - 資源開放に失敗

putResource

protected Connection putResource(String resource,
                                 ResourceParam[] params)
                          throws DataConnectException
推奨されていません。
接続先のリソースを追加します。

定義:
クラス DBConnector 内の putResource
パラメータ:
resource - リソース
params - リソースのパラメータ
戻り値:
リソース
例外:
DataConnectException - 接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginGroupDBConnector (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス LoginGroupDBConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.LoginGroupDBConnector
public class LoginGroupDBConnector
extends DataConnector

イントラマートで設定されているDBコネクションです。
ログイングループIDからコネクションを取得します。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
protected  Map connections
リソース一覧
コンストラクタの概要
LoginGroupDBConnector()
LoginGroupDBConnectorを新規に生成します。
メソッドの概要
void | commit() コミットします。
Connection | getConnection(String connect) データベースへのコネクションを取得します。
protected Object | getResource(String key, String connect, String resource) リソースを取得します。
void | release() データストアの資源を解放します。
void | rollback() ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

connections

protected Map connections
リソース一覧

コンストラクタの詳細

LoginGroupDBConnector

public LoginGroupDBConnector()
LoginGroupDBConnectorを新規に生成します。

メソッドの詳細

commit

public void commit()
            throws DataConnectException
コミットします。 実際にはこのクラスではこのメソッドは何もしません。

定義:
クラス DataConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
ロールバックします。 実際にはこのクラスではこのメソッドは何もしません。

定義:
クラス DataConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
データストアの資源を解放します。

定義:
クラス DataConnector 内の release
例外:
DataConnectException - 資源開放に失敗

getConnection

public Connection getConnection(String connect)
                         throws DataPropertyException,
                                DataConnectException
データベースへのコネクションを取得します。

パラメータ:
connect - 接続情報
戻り値:
データベースへのコネクション
例外:
DataPropertyException - データベースへのコネクションの取得に失敗
DataConnectException - データベースへの接続に失敗

getResource

protected Object getResource(String key,
                             String connect,
                             String resource)
                      throws DataConnectException
リソースを取得します。

定義:
クラス DataConnector 内の getResource
パラメータ:
key - キー
connect - 接続情報
resource - リソース名
戻り値:
リソース
例外:
DataPropertyException - リソースの取得に失敗
DataConnectException - 接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginGroupDBDAO (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス LoginGroupDBDAO

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.LoginGroupDBDAO
すべての実装インタフェース:
DAO
public class LoginGroupDBDAO
extends Object
implements DAO

イントラマートで設定されたDBへアクセスするDAOです。 ログイングループIDをキーとしてDBへアクセスするDAOを作る場合、このクラスをextendsします。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
LoginGroupDBDAO()
IntramartDBDAOを新規に生成します。
メソッドの概要
Connection | getConnection() イントラマートで設定されているDBへのコネクションを取得します。
void | setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LoginGroupDBDAO

public LoginGroupDBDAO()
IntramartDBDAOを新規に生成します。

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
データリソースに接続する時の情報を設定します。

定義:
インタフェース DAO 内の setConnectInfo
パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗

getConnection

public Connection getConnection()
                         throws DataConnectException,
                                DataPropertyException
イントラマートで設定されているDBへのコネクションを取得します。

戻り値:
イントラマートで設定されているDBへのコネクション
例外:
DataConnectException - データベース接続時に例外が発生
DataPropertyException - データプロパティ取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.data (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.base.data
インタフェース
DAO
DataPropertyHandler
クラス
ConnectorModel
DAOAdapter
DaoModel
DataAccessController
DataConnector
DataManager
DataSourceConnector
DBConnector
DBDAO
DefaultDataPropertyHandler
DistributesDataPropertyHandler
IntramartDBConnector
IntramartDBDAO
IntramartFileServerConnector
IntramartFileServerDAO
JDBCConnector
LoginGroupDBConnector
LoginGroupDBDAO
ResourceModel
ResourceParam
SystemDBConnector
SystemDBDAO
TextFileDataPropertyHandler
XmlDataPropertyHandler
例外
DAOException
DataAccessException
DataConnectException
DataConnectorException
DataManagerException
DataPropertyException


jp.co.intra_mart.framework.base.data (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.data

データアクセスに関連するクラスのパッケージです。

参照:
説明

インタフェースの概要
DAO | データリソースにアクセスするインタフェースです。
DataPropertyHandler | DAOの設定情報に接続するクラスです。

クラスの概要
ConnectorModel | コネクタ情報を管理するクラスです。
DAOAdapter | DAOのすべてのメソッドを何もしないように実装したクラスです。
DaoModel | DaoModelを管理するクラスです。
DataAccessController | データアクセスを制御します。
DataConnector | データストアに接続するコネクタです。
DataManager | データストアとの接続を管理します。
DataSourceConnector | DataSourceに関連するデータコネクタです。
DBConnector | データベースに対するコネクタです。
DBDAO | データベースに特化したDAOです。
DefaultDataPropertyHandler | デフォルトのデータプロパティハンドラです。
DistributesDataPropertyHandler | アプリケーション毎のプロパティハンドラを呼び出します。
IntramartDBConnector | 推奨されていません。 このクラスではなくLoginGroupDBConnectorまたは SystemDBConnectorを使用してください。
IntramartDBDAO | 推奨されていません。 このクラスではなくLoginGroupDBDAOまたは SystemDBDAOを使用してください。
IntramartFileServerConnector | intra-martのStorageサービスに接続するデータコネクタです。
IntramartFileServerDAO | intra-martのStorageサービスを使用する場合のDAOです。
JDBCConnector | 推奨されていません。 JDBCを直接扱わず、DataSourceを使用するようにしてください。
LoginGroupDBConnector | イントラマートで設定されているDBコネクションです。
LoginGroupDBDAO | イントラマートで設定されたDBへアクセスするDAOです。
ResourceModel | Resource情報を管理するクラスです。
ResourceParam | データコネクタの初期パラメータです。
SystemDBConnector | イントラマートで設定されているDBコネクションです。
SystemDBDAO | イントラマートで設定されたDBへアクセスするDAOです。
TextFileDataPropertyHandler | 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
XmlDataPropertyHandler | XMLのデータプロパティハンドラです。

例外の概要
DAOException | リソースコネクタの情報取得時の例外です。
DataAccessException | データアクセス時の例外です。
DataConnectException | データ接続に関連する例外です。
DataConnectorException | データコネクタ取得時の例外です。
DataManagerException | データマネージャの設定時の例外です。
DataPropertyException | データプロパティ取得時の例外です。

パッケージ jp.co.intra_mart.framework.base.data の説明

データアクセスに関連するクラスのパッケージです。 EIS層（データベース、基幹システムなど）にアクセスするためのクラスがあります。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.framework.base.data クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.data の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.data.ConnectorModel
    • class jp.co.intra_mart.framework.base.data.DAOAdapter (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.DaoModel
    • class jp.co.intra_mart.framework.base.data.DataAccessController
    • class jp.co.intra_mart.framework.base.data.DataConnector
      • class jp.co.intra_mart.framework.base.data.DBConnector
        • class jp.co.intra_mart.framework.base.data.DataSourceConnector
        • class jp.co.intra_mart.framework.base.data.JDBCConnector
      • class jp.co.intra_mart.framework.base.data.IntramartDBConnector
      • class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector
      • class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector
      • class jp.co.intra_mart.framework.base.data.SystemDBConnector
    • class jp.co.intra_mart.framework.base.data.DataManager
    • class jp.co.intra_mart.framework.base.data.DBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class jp.co.intra_mart.framework.base.data.IntramartDBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.IntramartFileServerDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.LoginGroupDBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.base.data.ResourceParam
    • class jp.co.intra_mart.framework.base.data.ResourceModel
    • class jp.co.intra_mart.framework.base.data.SystemDBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.data.DAOException
            • class jp.co.intra_mart.framework.base.data.DataAccessException
            • class jp.co.intra_mart.framework.base.data.DataConnectException
            • class jp.co.intra_mart.framework.base.data.DataConnectorException
            • class jp.co.intra_mart.framework.base.data.DataManagerException
            • class jp.co.intra_mart.framework.base.data.DataPropertyException
    • class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)

インタフェース階層

  • interface jp.co.intra_mart.framework.base.data.DAO
  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.base.data.DataPropertyHandler
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.framework.base.data の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.data の使用

jp.co.intra_mart.framework.base.data を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.data.container |
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data により使用される jp.co.intra_mart.framework.base.data のクラス
DAO
データリソースにアクセスするインタフェースです。
DAOException
リソースコネクタの情報取得時の例外です。
DataAccessController
データアクセスを制御します。
DataConnectException
データ接続に関連する例外です。
DataConnector
データストアに接続するコネクタです。
DataConnectorException
データコネクタ取得時の例外です。
DataManager
データストアとの接続を管理します。
DataManagerException
データマネージャの設定時の例外です。
DataPropertyException
データプロパティ取得時の例外です。
DataPropertyHandler
DAOの設定情報に接続するクラスです。
DBConnector
データベースに対するコネクタです。
ResourceParam
データコネクタの初期パラメータです。

jp.co.intra_mart.framework.base.data.container により使用される jp.co.intra_mart.framework.base.data のクラス
DataAccessController
データアクセスを制御します。
DataPropertyHandler
DAOの設定情報に接続するクラスです。

jp.co.intra_mart.framework.base.event により使用される jp.co.intra_mart.framework.base.data のクラス
DAOException
リソースコネクタの情報取得時の例外です。
DataAccessController
データアクセスを制御します。
DataConnectException
データ接続に関連する例外です。
DataConnectorException
データコネクタ取得時の例外です。
DataPropertyException
データプロパティ取得時の例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ResourceModel (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス ResourceModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.ResourceModel
public class ResourceModel
extends Object

Resource情報を管理するクラスです。

バージョン:
1.0

フィールドの概要
static String | ID
static String | P_ID_PARAM_NAME
static String | P_ID_PARAM_VALUE
static String | P_ID_RESOURCE_NAME
static String | P_ID_RESOURCE_PARAM
コンストラクタの概要
ResourceModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID

public static final String ID
関連項目:
定数フィールド値

P_ID_RESOURCE_NAME

public static final String P_ID_RESOURCE_NAME
関連項目:
定数フィールド値

P_ID_RESOURCE_PARAM

public static final String P_ID_RESOURCE_PARAM
関連項目:
定数フィールド値

P_ID_PARAM_NAME

public static final String P_ID_PARAM_NAME
関連項目:
定数フィールド値

P_ID_PARAM_VALUE

public static final String P_ID_PARAM_VALUE
関連項目:
定数フィールド値
コンストラクタの詳細

ResourceModel

public ResourceModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ResourceParam (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス ResourceParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
        拡張 jp.co.intra_mart.framework.base.data.ResourceParam
public class ResourceParam
extends PropertyParam

データコネクタの初期パラメータです。

バージョン:
1.0

コンストラクタの概要
ResourceParam()
ResourceParamを新規に生成します。
クラス jp.co.intra_mart.framework.system.property.PropertyParam から継承したメソッド
getName, getValue, setName, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ResourceParam

public ResourceParam()
ResourceParamを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SystemDBConnector (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス SystemDBConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.SystemDBConnector
public class SystemDBConnector
extends DataConnector

イントラマートで設定されているDBコネクションです。
システムに設定されている情報からコネクションを取得します。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
protected  Map connections
リソース一覧
コンストラクタの概要
SystemDBConnector()
SystemDBConnectorを新規に生成します。
メソッドの概要
void | commit() コミットします。
Connection | getConnection(String connect) データベースへのコネクションを取得します。
protected Object | getResource(String key, String connect, String resource) リソースを取得します。
void | release() データストアの資源を解放します。
void | rollback() ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

connections

protected Map connections
リソース一覧

コンストラクタの詳細

SystemDBConnector

public SystemDBConnector()
SystemDBConnectorを新規に生成します。

メソッドの詳細

commit

public void commit()
            throws DataConnectException
コミットします。 実際にはこのクラスではこのメソッドは何もしません。

定義:
クラス DataConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
ロールバックします。 実際にはこのクラスではこのメソッドは何もしません。

定義:
クラス DataConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
データストアの資源を解放します。

定義:
クラス DataConnector 内の release
例外:
DataConnectException - 資源開放に失敗

getConnection

public Connection getConnection(String connect)
                         throws DataPropertyException,
                                DataConnectException
データベースへのコネクションを取得します。

パラメータ:
connect - 接続情報
戻り値:
データベースへのコネクション
例外:
DataPropertyException - データベースへのコネクションの取得に失敗
DataConnectException - データベースへの接続に失敗

getResource

protected Object getResource(String key,
                             String connect,
                             String resource)
                      throws DataConnectException
リソースを取得します。

定義:
クラス DataConnector 内の getResource
パラメータ:
key - キー
connect - 接続情報
resource - リソース名
戻り値:
リソース
例外:
DataPropertyException - リソースの取得に失敗
DataConnectException - 接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SystemDBDAO (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス SystemDBDAO

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.SystemDBDAO
すべての実装インタフェース:
DAO
public class SystemDBDAO
extends Object
implements DAO

イントラマートで設定されたDBへアクセスするDAOです。 システム登録されているIDをキーとしてDBへアクセスするDAOを作る場合、このクラスをextendsします。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
SystemDBDAO()
IntramartDBDAOを新規に生成します。
メソッドの概要
Connection | getConnection() イントラマートで設定されているDBへのコネクションを取得します。
void | setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SystemDBDAO

public SystemDBDAO()
IntramartDBDAOを新規に生成します。

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
データリソースに接続する時の情報を設定します。

定義:
インタフェース DAO 内の setConnectInfo
パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗

getConnection

public Connection getConnection()
                         throws DataConnectException,
                                DataPropertyException
イントラマートで設定されているDBへのコネクションを取得します。

戻り値:
イントラマートで設定されているDBへのコネクション
例外:
DataConnectException - データベース接続時に例外が発生
DataPropertyException - データプロパティ取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TextFileDataPropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス TextFileDataPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler
すべての実装インタフェース:
DataPropertyHandler, PropertyHandler
public class TextFileDataPropertyHandler
extends Object
implements DataPropertyHandler

指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。 ファイルの書式はDefaultDataPropertyHandlerで示されるものと同じです。
ファイルが存在するディレクトリ名はPARAM_FILE_DIRで示されるパラメータ名で指定します。
PARAM_DYNAMICで示されるパラメータにtrueを指定した場合 アプリケーション実行時にもプロパティの変更を動的に反映させることが可能となりますが、 パラメータの取得時に毎回ファイル操作を行うためパフォーマンスに悪影響を与える可能性があります。 このオプションは、開発時やデバッグ時のようにパラメータを頻繁に変更する必要がある場合のみtrueとし、 通常はfalseに設定しておいてください。

導入されたバージョン:
3.2

フィールドの概要
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
コンストラクタの概要
TextFileDataPropertyHandler()
TextFileDataPropertyHandlerを新規に生成します。
メソッドの概要
String | getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
String | getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
ResourceParam[] | getResourceParams(String name) リソースのパラメータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

TextFileDataPropertyHandler

public TextFileDataPropertyHandler()
TextFileDataPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
プロパティの動的読み込みが可能かどうか調べます。

定義:
インタフェース DataPropertyHandler 内の isDynamic
戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可

getDAOName

public String getDAOName(String application,
                         String key,
                         String connect)
                  throws DataPropertyException
DAOのクラス名を取得します。 application、keyとconnectで指定されたDAOのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getDAOName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAOのクラス名
例外:
DataPropertyException - DAOのクラス名の取得に失敗

getConnectorName

public String getConnectorName(String application,
                               String key,
                               String connect)
                        throws DataPropertyException
DAOに対するデータコネクタ名を取得します。 application、keyとconnectで指定されたDAOのデータコネクタ名を取得します。 対応するデータコネクタ名が指定されていない場合、nullが返ります。

定義:
インタフェース DataPropertyHandler 内の getConnectorName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
データコネクタの名前
例外:
DataPropertyException - データコネクタ名の取得時に例外が発生

getConnectorClassName

public String getConnectorClassName(String connectorName)
                             throws DataPropertyException
データコネクタのクラス名を取得します。 application、keyとconnectで指定されたデータコネクタのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getConnectorClassName
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのクラス名
例外:
DataPropertyException - データコネクタのクラス名の取得に失敗

getConnectorResource

public String getConnectorResource(String connectorName)
                            throws DataPropertyException
データコネクタのリソース名を取得します。 application、keyとconnectで指定されたデータコネクタのリソース名を取得します。 対応するリソース名がない場合、nullを返します。

定義:
インタフェース DataPropertyHandler 内の getConnectorResource
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのリソース名
例外:
DataPropertyException - データコネクタのリソース名の取得時に例外が発生

getResourceParams

public ResourceParam[] getResourceParams(String name)
                                  throws DataPropertyException
リソースのパラメータを取得します。 nameで指定されたリソースのパラメータを取得します。

定義:
インタフェース DataPropertyHandler 内の getResourceParams
パラメータ:
name - リソース名
戻り値:
リソースのパラメータ
例外:
DataPropertyException - リソースのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XmlDataPropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス XmlDataPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler
すべての実装インタフェース:
DataPropertyHandler, PropertyHandler
public class XmlDataPropertyHandler
extends Object
implements DataPropertyHandler

XMLのデータプロパティハンドラです。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「プレフィックス_アプリケーションID.xml」です。また、アプリケーションに依存しない「プレフィックス.properties」があります。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにDataManager.DATA_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのXMLファイル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM XMLファイル名のパラメータ名
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
コンストラクタの概要
XmlDataPropertyHandler()
コンストラクタです。
メソッドの概要
String | getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
String | getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
ResourceParam[] | getResourceParams(String name) リソースのパラメータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのXMLファイル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
XMLファイル名のパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

XmlDataPropertyHandler

public XmlDataPropertyHandler()
コンストラクタです。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws DataPropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース DataPropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
DataPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getDAOName

public String getDAOName(String application,
                         String key,
                         String connect)
                  throws DataPropertyException
DAOのクラス名を取得します。 application、keyとconnectで指定されたDAOのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getDAOName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAOのクラス名
例外:
DataPropertyException - DAOのクラス名の取得に失敗

getConnectorName

public String getConnectorName(String application,
                               String key,
                               String connect)
                        throws DataPropertyException
DAOに対するデータコネクタ名を取得します。 application、keyとconnectで指定されたDAOのデータコネクタ名を取得します。 対応するデータコネクタ名が指定されていない場合、nullが返ります。

定義:
インタフェース DataPropertyHandler 内の getConnectorName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
データコネクタの名前
例外:
DataPropertyException - データコネクタ名の取得時に例外が発生

getConnectorClassName

public String getConnectorClassName(String connectorName)
                             throws DataPropertyException
データコネクタのクラス名を取得します。 application、keyとconnectで指定されたデータコネクタのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getConnectorClassName
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのクラス名
例外:
DataPropertyException - データコネクタのクラス名の取得に失敗

getConnectorResource

public String getConnectorResource(String connectorName)
                            throws DataPropertyException
データコネクタのリソース名を取得します。 application、keyとconnectで指定されたデータコネクタのリソース名を取得します。 対応するリソース名がない場合、nullを返します。

定義:
インタフェース DataPropertyHandler 内の getConnectorResource
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのリソース名
例外:
DataPropertyException - データコネクタのリソース名の取得時に例外が発生

getResourceParams

public ResourceParam[] getResourceParams(String name)
                                  throws DataPropertyException
リソースのパラメータを取得します。 nameで指定されたリソースのパラメータを取得します。

定義:
インタフェース DataPropertyHandler 内の getResourceParams
パラメータ:
name - リソース名
戻り値:
リソースのパラメータ
例外:
DataPropertyException - リソースのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler の使用

jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の使用

jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EJBEventListener の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EJBEventListener の使用

EJBEventListener を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EJBEventListener の使用

jp.co.intra_mart.framework.base.event での EJBEventListener のサブクラス
class | GenericEJBEventListener EJBを利用する汎用的なイベントリスナです。
class | GenericEJBEventListenerLocal ローカルEJBを利用する汎用的なイベントリスナです。
class | StandardEJBEventListener StandardEJBEventListenerAgentに接続するイベントリスナです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean の使用

EJBEventListenerAgentBean を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EJBEventListenerAgentBean の使用

jp.co.intra_mart.framework.base.event での EJBEventListenerAgentBean のサブクラス
class | GenericEJBEventListenerAgentBean EJBを利用する汎用的なイベントリスナーのBeanです。
class | StandardEJBEventListenerAgentBean EJBを利用する場合の抽象的なイベントリスナです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EJBEventListenerFactory の使用

EJBEventListenerFactory を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EJBEventListenerFactory の使用

jp.co.intra_mart.framework.base.event での EJBEventListenerFactory のサブクラス
class | GenericEJBEventListenerFactory GenericEJBEventListenerを生成します。
class | GenericEJBEventListenerLocalFactory GenericEJBEventListnerLocalを新規に生成します。
class | StandardEJBEventListenerFactory 標準的なEJB用のイベントリスナファクトリです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EmptyEvent の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EmptyEvent の使用

jp.co.intra_mart.framework.base.event.EmptyEvent はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.Event の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.Event の使用

Event を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event.container |
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での Event の使用

jp.co.intra_mart.framework.base.event での Event のサブクラス
 class EmptyEvent
情報を何も持たないイベントです。

Event を返す jp.co.intra_mart.framework.base.event のメソッド
 Event EventManager.createEvent(String application, String key, UserInfo info)
パラメータで指定された内容に該当するイベントを生成します。
 Event EventManager.createEvent(String application, String key, String loginUser, String loginGroup)
推奨されていません。 このメソッドではなくEventManager.createEvent(String, String, UserInfo)を使用してください。

Event 型のパラメータを持つ jp.co.intra_mart.framework.base.event のメソッド
EventListener | StandardEventListenerFactory.create(Event event) イベントリスナを生成します。
EventResult | StandardEventListener.execute(Event event) 処理を実行します。
protected abstract EventResult | StandardEventListener.fire(Event event) イベントに対する処理です。
protected EventResult | StandardEventListener.dispatchEvent(Event event) イベント処理を実行します。
EventListener | StandardEJBEventListenerFactory.create(Event event) イベントリスナを生成します。
EventResult | StandardEJBEventListenerAgentBean.execute(Event event) イベント処理を実行します。
protected abstract EventResult | StandardEJBEventListenerAgentBean.fire(Event event, DataAccessController dataAccessController) イベントに対する処理です。
EventResult | StandardEJBEventListenerAgent.execute(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListener.execute(Event event) 処理を実行します。
EventListener | GenericEventListenerFactory.create(Event event) イベントリスナを生成します。
EventResult | GenericEventListener.execute(Event event) 処理を実行します。
EventListener | GenericEJBEventListenerLocalFactory.create(Event event) イベントリスナを生成します。
EventResult | GenericEJBEventListenerLocal.execute(Event event) 処理を実行します。
EventListener | GenericEJBEventListenerFactory.create(Event event) イベントリスナを生成します。
EventResult | GenericEJBEventListenerAgentLocal.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListenerAgentBean.execute(Event event, String listenerName) イベント処理を実行します。
EventResult | GenericEJBEventListenerAgent.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListener.execute(Event event) 処理を実行します。
void | EventTriggerList.fireAll(Event event, DataAccessController controller) すべてのトリガに対してイベントの処理を行います。
void | EventTriggerAdapter.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
protected abstract void | EventTriggerAdapter.fire(Event event) イベントに対する処理を行います。
void | EventTrigger.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
EventResult | EventManager.dispatch(Event event) イベントに対する処理を実行します。
EventResult | EventManager.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventListener | EventListenerFactory.create(Event event) イベントリスナを生成します。
EventResult | EventListener.execute(Event event) 処理を実行します。
protected EventResult | EJBEventListenerAgentBean.dispatchEvent(Event event) イベント処理を実行します。
protected EventResult | EJBEventListener.dispatchEvent(Event event) イベント処理を実行します。

jp.co.intra_mart.framework.base.event.container での Event の使用

Event を返す jp.co.intra_mart.framework.base.event.container のメソッド
Event | EventContainerImpl.createEvent(String application, String key) パラメータで指定された内容に該当するイベントを生成します。
Event | EventContainer.createEvent(String application, String key) パラメータで指定された内容に該当するイベントを生成します。

Event 型のパラメータを持つ jp.co.intra_mart.framework.base.event.container のメソッド
EventResult | EventContainerImpl.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventResult | EventContainer.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。

jp.co.intra_mart.framework.base.service での Event の使用

Event を返す jp.co.intra_mart.framework.base.service のメソッド
protected  Event ServiceControllerAdapter.createEvent(String application, String key)
アプリケーションIDとキーに対応するイベントを取得します。

Event 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
protected  EventResult ServiceControllerAdapter.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.base.web.bean での Event の使用

Event を返す jp.co.intra_mart.framework.base.web.bean のメソッド
protected  Event HelperBean.createEvent(String application, String key)
アプリケーションIDとキーに対応するイベントを取得します。

Event 型のパラメータを持つ jp.co.intra_mart.framework.base.web.bean のメソッド
protected  EventResult HelperBean.dispatchEvent(Event event)
イベント処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventException の使用

EventException を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event.container |
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventException の使用

EventException をスローする jp.co.intra_mart.framework.base.event のメソッド
protected  EventResult StandardEventListener.dispatchEvent(Event event)
イベント処理を実行します。
 Event EventManager.createEvent(String application, String key, UserInfo info)
パラメータで指定された内容に該当するイベントを生成します。
 Event EventManager.createEvent(String application, String key, String loginUser, String loginGroup)
推奨されていません。 このメソッドではなくEventManager.createEvent(String, String, UserInfo)を使用してください。
 EventResult EventManager.dispatch(Event event)
イベントに対する処理を実行します。
 EventResult EventManager.dispatch(Event event, boolean transaction)
イベントに対する処理を実行します。
protected  EventResult EJBEventListenerAgentBean.dispatchEvent(Event event)
イベント処理を実行します。
protected  EventResult EJBEventListener.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.base.event.container での EventException の使用

EventException をスローする jp.co.intra_mart.framework.base.event.container のメソッド
Event | EventContainerImpl.createEvent(String application, String key) パラメータで指定された内容に該当するイベントを生成します。
EventResult | EventContainerImpl.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
Event | EventContainer.createEvent(String application, String key) パラメータで指定された内容に該当するイベントを生成します。
EventResult | EventContainer.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。

jp.co.intra_mart.framework.base.service での EventException の使用

EventException をスローする jp.co.intra_mart.framework.base.service のメソッド
protected  EventResult ServiceControllerAdapter.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.base.web.bean での EventException の使用

EventException をスローする jp.co.intra_mart.framework.base.web.bean のメソッド
protected  EventResult HelperBean.dispatchEvent(Event event)
イベント処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventFactoryModel の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventFactoryModel の使用

jp.co.intra_mart.framework.base.event.EventFactoryModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventGroupModel の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventGroupModel の使用

jp.co.intra_mart.framework.base.event.EventGroupModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.EventListener の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.EventListener の使用

EventListener を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventListener の使用

EventListener を実装している jp.co.intra_mart.framework.base.event のクラス
class | EJBEventListener EJBを利用する場合のイベントリスナです。
class | GenericEJBEventListener EJBを利用する汎用的なイベントリスナです。
class | GenericEJBEventListenerLocal ローカルEJBを利用する汎用的なイベントリスナです。
class | GenericEventListener 汎用的なイベントリスナです。
class | StandardEJBEventListener StandardEJBEventListenerAgentに接続するイベントリスナです。
class | StandardEventListener 汎用的なビジネスロジック用のクラスです。

EventListener を返す jp.co.intra_mart.framework.base.event のメソッド
EventListener | StandardEventListenerFactory.create(Event event) イベントリスナを生成します。
EventListener | StandardEJBEventListenerFactory.create(Event event) イベントリスナを生成します。
EventListener | GenericEventListenerFactory.create(Event event) イベントリスナを生成します。
EventListener | GenericEJBEventListenerLocalFactory.create(Event event) イベントリスナを生成します。
EventListener | GenericEJBEventListenerFactory.create(Event event) イベントリスナを生成します。
EventListener | EventListenerFactory.create(Event event) イベントリスナを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventListenerException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventListenerException の使用

EventListenerException を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventListenerException の使用

EventListenerException をスローする jp.co.intra_mart.framework.base.event のメソッド
EventListener | StandardEventListenerFactory.create(Event event) イベントリスナを生成します。
void | StandardEventListenerFactory.initParam(String name, String value) 初期パラメータを設定します。
EventListener | StandardEJBEventListenerFactory.create(Event event) イベントリスナを生成します。
void | StandardEJBEventListenerFactory.initParam(String name, String value) 初期パラメータを設定します。
EventListener | GenericEventListenerFactory.create(Event event) イベントリスナを生成します。
void | GenericEventListenerFactory.initParam(String name, String value) 初期パラメータを設定します。
EventListener | GenericEJBEventListenerLocalFactory.create(Event event) イベントリスナを生成します。
void | GenericEJBEventListenerLocalFactory.initParam(String name, String value) 初期パラメータを設定します。
EventListener | GenericEJBEventListenerFactory.create(Event event) イベントリスナを生成します。
void | GenericEJBEventListenerFactory.initParam(String name, String value) 初期パラメータを設定します。
EventListener | EventListenerFactory.create(Event event) イベントリスナを生成します。
void | EventListenerFactory.initParam(String name, String value) 初期パラメータを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.EventListenerFactory の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.EventListenerFactory の使用

EventListenerFactory を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventListenerFactory の使用

EventListenerFactory を実装している jp.co.intra_mart.framework.base.event のクラス
class | EJBEventListenerFactory EJBEventListenerFactoryを生成します。
class | GenericEJBEventListenerFactory GenericEJBEventListenerを生成します。
class | GenericEJBEventListenerLocalFactory GenericEJBEventListnerLocalを新規に生成します。
class | GenericEventListenerFactory GenericEventListenerを生成するイベントリスナファクトリです。
class | StandardEJBEventListenerFactory 標準的なEJB用のイベントリスナファクトリです。
class | StandardEventListenerFactory 通常のJavaクラスのイベントリスナを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventListenerFactoryParam の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventListenerFactoryParam の使用

EventListenerFactoryParam を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventListenerFactoryParam の使用

EventListenerFactoryParam を返す jp.co.intra_mart.framework.base.event のメソッド
EventListenerFactoryParam[] | XmlEventPropertyHandler.getEventListenerFactoryParams(String application, String key) アプリケーションIDとキーに該当するイベントリスナファクトリの初期パラメータを取得します。
EventListenerFactoryParam[] | TextFileEventPropertyHandler.getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
EventListenerFactoryParam[] | EventPropertyHandler.getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
EventListenerFactoryParam[] | DistributesEventPropertyHandler.getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
EventListenerFactoryParam[] | DefaultEventPropertyHandler.getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventManager の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventManager の使用

EventManager を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventManager の使用

EventManager を返す jp.co.intra_mart.framework.base.event のメソッド
static EventManager EventManager.getEventManager()
イベントマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventManagerException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventManagerException の使用

EventManagerException を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventManagerException の使用

EventManagerException をスローする jp.co.intra_mart.framework.base.event のメソッド
protected EventResult | StandardEventListener.dispatchEvent(Event event) イベント処理を実行します。
static EventManager | EventManager.getEventManager() イベントマネージャを取得します。
protected EventResult | EJBEventListenerAgentBean.dispatchEvent(Event event) イベント処理を実行します。
protected EventResult | EJBEventListener.dispatchEvent(Event event) イベント処理を実行します。

EventManagerException をスローする jp.co.intra_mart.framework.base.event のコンストラクタ
EventTriggerList(String application, String key)
EventTriggerListを新規に生成します。
EventTriggerList(String application, String key, boolean pre)
EventTriggerListを新規に生成します。

jp.co.intra_mart.framework.base.service での EventManagerException の使用

EventManagerException をスローする jp.co.intra_mart.framework.base.service のメソッド
protected  EventResult ServiceControllerAdapter.dispatchEvent(Event event)
イベント処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventModelProducer の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventModelProducer の使用

jp.co.intra_mart.framework.base.event.EventModelProducer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventPropertyException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventPropertyException の使用

EventPropertyException を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event.container |

jp.co.intra_mart.framework.base.event での EventPropertyException の使用

EventPropertyException をスローする jp.co.intra_mart.framework.base.event のメソッド
 boolean XmlEventPropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String XmlEventPropertyHandler.getEventName(String application, String key)
アプリケーションIDとキーに該当するイベントのクラス名を取得します。
 String XmlEventPropertyHandler.getEventListenerFactoryName(String application, String key)
アプリケーションIDとキーに該当するイベントリスナファクトリのクラス名を取得します。
 EventListenerFactoryParam[] XmlEventPropertyHandler.getEventListenerFactoryParams(String application, String key)
アプリケーションIDとキーに該当するイベントリスナファクトリの初期パラメータを取得します。
 Collection XmlEventPropertyHandler.getEventTriggerInfos(String application, String key)
アプリケーションIDとキーに該当するイベントのイベントトリガ情報をすべて取得します。
 Collection XmlEventPropertyHandler.getPostEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 String TextFileEventPropertyHandler.getEventName(String application, String key)
キーに該当するイベントのクラス名を取得します。
 String TextFileEventPropertyHandler.getEventListenerFactoryName(String application, String key)
キーに該当するイベントリスナファクトリのクラス名を取得します。
 EventListenerFactoryParam[] TextFileEventPropertyHandler.getEventListenerFactoryParams(String application, String key)
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
 Collection TextFileEventPropertyHandler.getEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 Collection TextFileEventPropertyHandler.getPostEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 boolean EventPropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String EventPropertyHandler.getEventName(String application, String key)
キーに該当するイベントのクラス名を取得します。
 String EventPropertyHandler.getEventListenerFactoryName(String application, String key)
キーに該当するイベントリスナファクトリのクラス名を取得します。
 EventListenerFactoryParam[] EventPropertyHandler.getEventListenerFactoryParams(String application, String key)
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
 Collection EventPropertyHandler.getEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 Collection EventPropertyHandler.getPostEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 Event EventManager.createEvent(String application, String key, UserInfo info)
パラメータで指定された内容に該当するイベントを生成します。
 Event EventManager.createEvent(String application, String key, String loginUser, String loginGroup)
推奨されていません。 このメソッドではなくEventManager.createEvent(String, String, UserInfo)を使用してください。
 boolean DistributesEventPropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String DistributesEventPropertyHandler.getEventName(String application, String key)
キーに該当するイベントのクラス名を取得します。
 String DistributesEventPropertyHandler.getEventListenerFactoryName(String application, String key)
キーに該当するイベントリスナファクトリのクラス名を取得します。
 EventListenerFactoryParam[] DistributesEventPropertyHandler.getEventListenerFactoryParams(String application, String key)
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
 Collection DistributesEventPropertyHandler.getEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 Collection DistributesEventPropertyHandler.getPostEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 boolean DefaultEventPropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String DefaultEventPropertyHandler.getEventName(String application, String key)
キーに該当するイベントのクラス名を取得します。
 String DefaultEventPropertyHandler.getEventListenerFactoryName(String application, String key)
キーに該当するイベントリスナファクトリのクラス名を取得します。
 EventListenerFactoryParam[] DefaultEventPropertyHandler.getEventListenerFactoryParams(String application, String key)
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
 Collection DefaultEventPropertyHandler.getEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 Collection DefaultEventPropertyHandler.getPostEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。

EventPropertyException をスローする jp.co.intra_mart.framework.base.event のコンストラクタ
EventTriggerList(String application, String key)
EventTriggerListを新規に生成します。
EventTriggerList(String application, String key, boolean pre)
EventTriggerListを新規に生成します。

jp.co.intra_mart.framework.base.event.container での EventPropertyException の使用

EventPropertyException をスローする jp.co.intra_mart.framework.base.event.container のメソッド
Event | EventContainerImpl.createEvent(String application, String key) パラメータで指定された内容に該当するイベントを生成します。
Event | EventContainer.createEvent(String application, String key) パラメータで指定された内容に該当するイベントを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.EventPropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.EventPropertyHandler の使用

EventPropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event.container |

jp.co.intra_mart.framework.base.event での EventPropertyHandler の使用

EventPropertyHandler を実装している jp.co.intra_mart.framework.base.event のクラス
class | DefaultEventPropertyHandler デフォルトのEventPropertyHandlerです。
class | DistributesEventPropertyHandler アプリケーション毎のEventPropertyHandlerを呼び出します。
class | TextFileEventPropertyHandler 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
class | XmlEventPropertyHandler XMLのEventPropertyHandlerです。

EventPropertyHandler を返す jp.co.intra_mart.framework.base.event のメソッド
 EventPropertyHandler EventManager.getEventPropertyHandler()
イベントプロパティハンドラを取得します。

jp.co.intra_mart.framework.base.event.container での EventPropertyHandler の使用

EventPropertyHandler を返す jp.co.intra_mart.framework.base.event.container のメソッド
EventPropertyHandler | EventContainerImpl.getEventPropertyHandler() イベントプロパティハンドラを取得します。
EventPropertyHandler | EventContainer.getEventPropertyHandler() イベントプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.EventResult の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.EventResult の使用

EventResult を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event.container |
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventResult の使用

EventResult を返す jp.co.intra_mart.framework.base.event のメソッド
EventResult | StandardEventListener.execute(Event event) 処理を実行します。
protected abstract EventResult | StandardEventListener.fire(Event event) イベントに対する処理です。
protected EventResult | StandardEventListener.dispatchEvent(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListenerAgentBean.execute(Event event) イベント処理を実行します。
protected abstract EventResult | StandardEJBEventListenerAgentBean.fire(Event event, DataAccessController dataAccessController) イベントに対する処理です。
EventResult | StandardEJBEventListenerAgent.execute(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListener.execute(Event event) 処理を実行します。
EventResult | GenericEventListener.execute(Event event) 処理を実行します。
EventResult | GenericEJBEventListenerLocal.execute(Event event) 処理を実行します。
EventResult | GenericEJBEventListenerAgentLocal.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListenerAgentBean.execute(Event event, String listenerName) イベント処理を実行します。
EventResult | GenericEJBEventListenerAgent.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListener.execute(Event event) 処理を実行します。
EventResult | EventManager.dispatch(Event event) イベントに対する処理を実行します。
EventResult | EventManager.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventResult | EventListener.execute(Event event) 処理を実行します。
protected EventResult | EJBEventListenerAgentBean.dispatchEvent(Event event) イベント処理を実行します。
protected EventResult | EJBEventListener.dispatchEvent(Event event) イベント処理を実行します。

jp.co.intra_mart.framework.base.event.container での EventResult の使用

EventResult を返す jp.co.intra_mart.framework.base.event.container のメソッド
EventResult | EventContainerImpl.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventResult | EventContainer.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。

jp.co.intra_mart.framework.base.service での EventResult の使用

EventResult を返す jp.co.intra_mart.framework.base.service のメソッド
protected  EventResult ServiceControllerAdapter.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.base.web.bean での EventResult の使用

EventResult を返す jp.co.intra_mart.framework.base.web.bean のメソッド
protected  EventResult HelperBean.dispatchEvent(Event event)
イベント処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.EventTrigger の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.EventTrigger の使用

EventTrigger を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventTrigger の使用

EventTrigger を実装している jp.co.intra_mart.framework.base.event のクラス
 class EventTriggerAdapter
DAOを取得するメソッドを持ったイベントトリガです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventTriggerAdapter の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventTriggerAdapter の使用

jp.co.intra_mart.framework.base.event.EventTriggerAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventTriggerException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventTriggerException の使用

EventTriggerException を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventTriggerException の使用

EventTriggerException をスローする jp.co.intra_mart.framework.base.event のコンストラクタ
EventTriggerList(String application, String key)
EventTriggerListを新規に生成します。
EventTriggerList(String application, String key, boolean pre)
EventTriggerListを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventTriggerInfo の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventTriggerInfo の使用

jp.co.intra_mart.framework.base.event.EventTriggerInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventTriggerList の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventTriggerList の使用

jp.co.intra_mart.framework.base.event.EventTriggerList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.GenericEJBEventListener の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEJBEventListener の使用

jp.co.intra_mart.framework.base.event.GenericEJBEventListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent の使用

GenericEJBEventListenerAgent を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での GenericEJBEventListenerAgent の使用

GenericEJBEventListenerAgent を返す jp.co.intra_mart.framework.base.event のメソッド
 GenericEJBEventListenerAgent GenericEJBEventListenerAgentHome.create()
リモートインタフェースGenericEJBEventListenerAgentを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean の使用

jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome の使用

GenericEJBEventListenerAgentHome を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での GenericEJBEventListenerAgentHome の使用

GenericEJBEventListenerAgentHome 型のパラメータを持つ jp.co.intra_mart.framework.base.event のコンストラクタ
GenericEJBEventListener(GenericEJBEventListenerAgentHome home, String listenerName)
GenericEJBEventListenerを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocal の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocal の使用

GenericEJBEventListenerAgentLocal を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での GenericEJBEventListenerAgentLocal の使用

GenericEJBEventListenerAgentLocal を返す jp.co.intra_mart.framework.base.event のメソッド
 GenericEJBEventListenerAgentLocal GenericEJBEventListenerAgentLocalHome.create()
ローカルインタフェース GenericEJBEventListenerAgentLocalを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocalHome の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocalHome の使用

GenericEJBEventListenerAgentLocalHome を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での GenericEJBEventListenerAgentLocalHome の使用

GenericEJBEventListenerAgentLocalHome 型のパラメータを持つ jp.co.intra_mart.framework.base.event のコンストラクタ
GenericEJBEventListenerLocal(GenericEJBEventListenerAgentLocalHome home, String listenerName)
GenericEJBEventListnerLocalを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory の使用

jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal の使用

jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory の使用

jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.GenericEventListener の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEventListener の使用

jp.co.intra_mart.framework.base.event.GenericEventListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.GenericEventListenerFactory の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEventListenerFactory の使用

jp.co.intra_mart.framework.base.event.GenericEventListenerFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.StandardEJBEventListener の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.StandardEJBEventListener の使用

jp.co.intra_mart.framework.base.event.StandardEJBEventListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent の使用

StandardEJBEventListenerAgent を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での StandardEJBEventListenerAgent の使用

StandardEJBEventListenerAgent を返す jp.co.intra_mart.framework.base.event のメソッド
 StandardEJBEventListenerAgent StandardEJBEventListenerAgentHome.create()
StandardEJBEventListenerAgentと接続します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean の使用

jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome の使用

StandardEJBEventListenerAgentHome を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での StandardEJBEventListenerAgentHome の使用

StandardEJBEventListenerAgentHome 型のパラメータを持つ jp.co.intra_mart.framework.base.event のコンストラクタ
StandardEJBEventListener(StandardEJBEventListenerAgentHome home)
StandardEJBEventListenerを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory の使用

jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.StandardEventListener の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.StandardEventListener の使用

StandardEventListener を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での StandardEventListener の使用

StandardEventListener 型のパラメータを持つ jp.co.intra_mart.framework.base.event のメソッド
 void GenericEventListener.setListener(StandardEventListener listener)
イベント処理クラスを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.StandardEventListenerFactory の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.StandardEventListenerFactory の使用

jp.co.intra_mart.framework.base.event.StandardEventListenerFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler の使用

jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler の使用

jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.container.EventContainer の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.container.EventContainer の使用

EventContainer を使用しているパッケージ
jp.co.intra_mart.framework.base.event.container

jp.co.intra_mart.framework.base.event.container での EventContainer の使用

EventContainer を実装している jp.co.intra_mart.framework.base.event.container のクラス
 class EventContainerImpl
EventContainerの標準的な実装クラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.container.EventContainerException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.container.EventContainerException の使用

jp.co.intra_mart.framework.base.event.container.EventContainerException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.container.EventContainerImpl の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.container.EventContainerImpl の使用

jp.co.intra_mart.framework.base.event.container.EventContainerImpl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.container.factory.DefaultEventProvider の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.container.factory.DefaultEventProvider の使用

jp.co.intra_mart.framework.base.event.container.factory.DefaultEventProvider はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.container.factory.EventContainerFactory の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.container.factory.EventContainerFactory の使用

jp.co.intra_mart.framework.base.event.container.factory.EventContainerFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DefaultEventProvider (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event.container.factory
クラス DefaultEventProvider

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.container.factory.DefaultEventProvider
すべての実装インタフェース:
Provider
public class DefaultEventProvider
extends Object
implements Provider

標準的なプロバイダーです。
クラスパス上のリソースファイルを取得し、イベントコンテナの実装を決定します。

リソースファイル名 - imartContainer.properties
キー - eventContainer

キーにはEventContainerインターフェースの実装クラスをフルパッケージ名で指定してください。

導入されたバージョン:
6.0

コンストラクタの概要
DefaultEventProvider()
DefaultEventProviderを新規に生成します。
メソッドの概要
 IMContainer create()
EventContainerを生成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DefaultEventProvider

public DefaultEventProvider()
DefaultEventProviderを新規に生成します。

メソッドの詳細

create

public IMContainer create()
                   throws IMContainerException
EventContainerを生成します。

定義:
インタフェース Provider 内の create
戻り値:
イベントコンテナ
例外:
IMContainerException - イベントコンテナ生成時に例外が発生。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventContainerFactory (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event.container.factory
クラス EventContainerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.container.factory.EventContainerFactory
すべての実装インタフェース:
IMContainerFactory
public class EventContainerFactory
extends Object
implements IMContainerFactory

EventContainerのファクトリクラスです。 生成されるイベントコンテナはプロバイダーにより決定されます。

導入されたバージョン:
6.0

フィールドの概要
protected static Provider provider
コンストラクタの概要
EventContainerFactory()
メソッドの概要
IMContainer | create() EventContainerを生成します。
Provider | getProvider() プロバイダを返します。
void | setProvider(Provider p) プロバイダを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

provider

protected static Provider provider
コンストラクタの詳細

EventContainerFactory

public EventContainerFactory()
メソッドの詳細

create

public IMContainer create()
                   throws IMContainerException
EventContainerを生成します。

定義:
インタフェース IMContainerFactory 内の create
戻り値:
イベントコンテナ
例外:
IMContainerException - イベントコンテナ生成時に例外が発生。

getProvider

public Provider getProvider()
プロバイダを返します。

定義:
インタフェース IMContainerFactory 内の getProvider
戻り値:
イベントコンテナのプロバイダ

setProvider

public void setProvider(Provider p)
プロバイダを設定します。

定義:
インタフェース IMContainerFactory 内の setProvider
パラメータ:
p - イベントコンテナのプロバイダ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.event.container.factory (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.base.event.container.factory
クラス
DefaultEventProvider
EventContainerFactory


jp.co.intra_mart.framework.base.event.container.factory (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.event.container.factory

クラスの概要
DefaultEventProvider | 標準的なプロバイダーです。
EventContainerFactory | EventContainerのファクトリクラスです。


jp.co.intra_mart.framework.base.event.container.factory クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.event.container.factory の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.event.container.factory.DefaultEventProvider (implements jp.co.intra_mart.framework.system.container.factory.Provider)
    • class jp.co.intra_mart.framework.base.event.container.factory.EventContainerFactory (implements jp.co.intra_mart.framework.system.container.factory.IMContainerFactory)


パッケージ jp.co.intra_mart.framework.base.event.container.factory の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.event.container.factory の使用

jp.co.intra_mart.framework.base.event.container.factory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


EventContainer (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event.container
インタフェース EventContainer

すべてのスーパーインタフェース:
IMContainer
既知の実装クラスの一覧:
EventContainerImpl
public interface EventContainer
extends IMContainer

イベントコンテナのインターフェースです。
イベントコンテナはEventManagerの振る舞いを決定します。 EventManagerではイベントコンテナを保管し、その挙動はイベントコンテナの実装クラスに依存します。 イベントコンテナの実装は通常EventContainerFactoryによって生成されます。

導入されたバージョン:
6.0

フィールドの概要
static String EVENT_PROPERTY_HANDLER_KEY
イベントプロパティハンドラのキー
メソッドの概要
Event | createEvent(String application, String key) パラメータで指定された内容に該当するイベントを生成します。
EventResult | dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventPropertyHandler | getEventPropertyHandler() イベントプロパティハンドラを取得します。
インタフェース jp.co.intra_mart.framework.system.container.IMContainer から継承したメソッド
init

フィールドの詳細

EVENT_PROPERTY_HANDLER_KEY

public static final String EVENT_PROPERTY_HANDLER_KEY
イベントプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getEventPropertyHandler

public EventPropertyHandler getEventPropertyHandler()
イベントプロパティハンドラを取得します。

戻り値:
イベントプロパティハンドラ

createEvent

public Event createEvent(String application,
                         String key)
                  throws EventPropertyException,
                         EventException
パラメータで指定された内容に該当するイベントを生成します。

パラメータ:
application - アプリケーション名
key - キー
戻り値:
パラメータに該当するイベント
例外:
EventException - イベント生成に失敗
EventPropertyException - イベントプロパティの取得に失敗
導入されたバージョン:
6.0

dispatch

public EventResult dispatch(Event event,
                            boolean transaction)
                     throws EventException,
                            SystemException,
                            ApplicationException
イベントに対する処理を実行します。

パラメータ:
event - イベント
transaction - トランザクションの中で実行されているかどうかを示すフラグ（トランザクション内の場合true、トランザクション外の場合false）
戻り値:
イベント処理結果
例外:
EventException - 不正なイベントが渡された
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生
導入されたバージョン:
6.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventContainerException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event.container
クラス EventContainerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.event.container.EventContainerException
すべての実装インタフェース:
Serializable
public class EventContainerException
extends SystemException

イベントコンテナ設定時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EventContainerException()
詳細メッセージを指定しないで EventContainerException を構築します。
EventContainerException(String msg)
指定された詳細メッセージを持つ EventContainerException を構築します。
EventContainerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventContainerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EventContainerException

public EventContainerException()
詳細メッセージを指定しないで EventContainerException を構築します。

EventContainerException

public EventContainerException(String msg)
指定された詳細メッセージを持つ EventContainerException を構築します。

パラメータ:
msg - 詳細メッセージ

EventContainerException

public EventContainerException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventContainerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventContainerImpl (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event.container
クラス EventContainerImpl

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.container.EventContainerImpl
すべての実装インタフェース:
EventContainer, IMContainer
public class EventContainerImpl
extends Object
implements EventContainer

EventContainerの標準的な実装クラスです。

導入されたバージョン:
6.0

フィールドの概要
インタフェース jp.co.intra_mart.framework.base.event.container.EventContainer から継承したフィールド
EVENT_PROPERTY_HANDLER_KEY
コンストラクタの概要
EventContainerImpl()
EventContainerImplを生成します。
メソッドの概要
Event | createEvent(String application, String key) パラメータで指定された内容に該当するイベントを生成します。
EventResult | dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventPropertyHandler | getEventPropertyHandler() イベントプロパティハンドラを取得します。
void | init() EventContainerを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventContainerImpl

public EventContainerImpl()
EventContainerImplを生成します。

メソッドの詳細

init

public void init()
          throws IMContainerException
EventContainerを初期化します。

定義:
インタフェース IMContainer 内の init
例外:
IMContainerException

getEventPropertyHandler

public EventPropertyHandler getEventPropertyHandler()
イベントプロパティハンドラを取得します。

定義:
インタフェース EventContainer 内の getEventPropertyHandler
戻り値:
イベントプロパティハンドラ

createEvent

public Event createEvent(String application,
                         String key)
                  throws EventPropertyException,
                         EventException
パラメータで指定された内容に該当するイベントを生成します。 該当するイベントがEventPropertyHandlerのパラメータで設定されていない場合、EmptyEventを返します。

定義:
インタフェース EventContainer 内の createEvent
パラメータ:
application - アプリケーション名
key - キー
戻り値:
パラメータに該当するイベント
例外:
EventException - イベント生成に失敗
EventPropertyException - イベントプロパティの取得に失敗
導入されたバージョン:
6.0

dispatch

public EventResult dispatch(Event event,
                            boolean transaction)
                     throws EventException,
                            SystemException,
                            ApplicationException
イベントに対する処理を実行します。

定義:
インタフェース EventContainer 内の dispatch
パラメータ:
event - イベント
transaction - トランザクションの中で実行されているかどうかを示すフラグ（トランザクション内の場合true、トランザクション外の場合false）
戻り値:
イベント処理結果
例外:
EventException - 不正なイベントが渡された
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生
導入されたバージョン:
6.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.event.container (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.base.event.container
インタフェース
EventContainer
クラス
EventContainerImpl
例外
EventContainerException


jp.co.intra_mart.framework.base.event.container (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.event.container

インタフェースの概要
EventContainer イベントコンテナのインターフェースです。

クラスの概要
EventContainerImpl EventContainerの標準的な実装クラスです。

例外の概要
EventContainerException イベントコンテナ設定時の例外です。


jp.co.intra_mart.framework.base.event.container クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.event.container の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.event.container.EventContainerImpl (implements jp.co.intra_mart.framework.base.event.container.EventContainer)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.event.container.EventContainerException

インタフェース階層

  • interface jp.co.intra_mart.framework.system.container.IMContainer
    • interface jp.co.intra_mart.framework.base.event.container.EventContainer


パッケージ jp.co.intra_mart.framework.base.event.container の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.event.container の使用

jp.co.intra_mart.framework.base.event.container を使用しているパッケージ
jp.co.intra_mart.framework.base.event.container

jp.co.intra_mart.framework.base.event.container により使用される jp.co.intra_mart.framework.base.event.container のクラス
EventContainer
イベントコンテナのインターフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DefaultEventPropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス DefaultEventPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler
すべての実装インタフェース:
EventPropertyHandler, PropertyHandler
public class DefaultEventPropertyHandler
extends Object
implements EventPropertyHandler

デフォルトのEventPropertyHandlerです。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「プレフィックス_アプリケーションID.properties」です。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにEventManager.EVENT_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスはDEFAULT_BUNDLE_NAME_PARAMで示されるものです。
プロパティの設定内容は以下のとおりです。

キー | 内容
event.class.キー | キーに対応するEventのクラス名
factory.class.キー | キーに対応するEventListenerFactoryのクラス名
factory.param.キー.パラメータ名 | キーに対応するEventListenerFactoryのパラメータの値
trigger.class.キー.ソート番号[.pre] | キーに対応するEventTriggerのクラス名 複数指定した場合、トリガはソート番号の順番に処理されます。 このトリガは該当するイベントリスナが処理される前に起動します。
trigger.class.キー.ソート番号.post | キーに対応するEventTriggerのクラス名 複数指定した場合、トリガはソート番号の順番に処理されます。 このトリガは該当するイベントリスナが処理された後に起動します。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
コンストラクタの概要
DefaultEventPropertyHandler()
DefaultEventPropertyHandlerを新規に生成します。
メソッドの概要
String | getEventListenerFactoryName(String application, String key) キーに該当するイベントリスナファクトリのクラス名を取得します。
EventListenerFactoryParam[] | getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
String | getEventName(String application, String key) キーに該当するイベントのクラス名を取得します。
Collection | getEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
Collection | getPostEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultEventPropertyHandler

public DefaultEventPropertyHandler()
DefaultEventPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws EventPropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース EventPropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
EventPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getEventName

public String getEventName(String application,
                           String key)
                    throws EventPropertyException
キーに該当するイベントのクラス名を取得します。 該当するイベントが存在しない場合、nullを返します。

定義:
インタフェース EventPropertyHandler 内の getEventName
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントのクラス名
例外:
EventPropertyException - イベントのクラス名の取得に失敗

getEventListenerFactoryName

public String getEventListenerFactoryName(String application,
                                          String key)
                                   throws EventPropertyException
キーに該当するイベントリスナファクトリのクラス名を取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryName
パラメータ:
application - アプリケーション
key - イベントリスナファクトリのキー
戻り値:
イベントリスナファクトリのクラス名
例外:
EventPropertyException - イベントリスナファクトリのクラス名の取得に失敗

getEventListenerFactoryParams

public EventListenerFactoryParam[] getEventListenerFactoryParams(String application,
                                                                 String key)
                                                          throws EventPropertyException
キーに該当するイベントリスナファクトリの初期パラメータを取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryParams
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントリスナファクトリの初期パラメータ
例外:
EventPropertyException - イベントリスナファクトリの初期パラメータの取得に失敗

getEventTriggerInfos

public Collection getEventTriggerInfos(String application,
                                       String key)
                                throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener

getPostEventTriggerInfos

public Collection getPostEventTriggerInfos(String application,
                                           String key)
                                    throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 ここで取得されるイベントトリガはイベントの処理後に実行されます。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getPostEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DistributesEventPropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス DistributesEventPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler
すべての実装インタフェース:
EventPropertyHandler, PropertyHandler
public class DistributesEventPropertyHandler
extends Object
implements EventPropertyHandler

アプリケーション毎のEventPropertyHandlerを呼び出します。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「プレフィックス_アプリケーションID.properties」、または「プレフィックス_アプリケーションID.xml」です。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにEventManager.EVENT_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスはDEFAULT_BUNDLE_NAME_PARAMで示されるものです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
static String | PARAM_APPLICATION アプリケーション
static String | PARAM_APPLICATION_CLASS クラス
static String | PARAM_APPLICATION_PARAM パラメータ
static String | PARAM_BUNDLE プロパティファイルのバンドルのパラメータ名
static String | PARAM_DEFAULT デフォルト
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
コンストラクタの概要
DistributesEventPropertyHandler()
DistributesEventPropertyHandlerを新規に生成します。
メソッドの概要
String | getEventListenerFactoryName(String application, String key) キーに該当するイベントリスナファクトリのクラス名を取得します。
EventListenerFactoryParam[] | getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
String | getEventName(String application, String key) キーに該当するイベントのクラス名を取得します。
Collection | getEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
Collection | getPostEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値

PARAM_DEFAULT

public static final String PARAM_DEFAULT
デフォルト

関連項目:
定数フィールド値

PARAM_APPLICATION

public static final String PARAM_APPLICATION
アプリケーション

関連項目:
定数フィールド値

PARAM_APPLICATION_PARAM

public static final String PARAM_APPLICATION_PARAM
パラメータ

関連項目:
定数フィールド値

PARAM_APPLICATION_CLASS

public static final String PARAM_APPLICATION_CLASS
クラス

関連項目:
定数フィールド値

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値

PARAM_BUNDLE

public static final String PARAM_BUNDLE
プロパティファイルのバンドルのパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DistributesEventPropertyHandler

public DistributesEventPropertyHandler()
DistributesEventPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws EventPropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース EventPropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
EventPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getEventName

public String getEventName(String application,
                           String key)
                    throws EventPropertyException
キーに該当するイベントのクラス名を取得します。 該当するイベントが存在しない場合、nullを返します。

定義:
インタフェース EventPropertyHandler 内の getEventName
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントのクラス名
例外:
EventPropertyException - イベントのクラス名の取得に失敗

getEventListenerFactoryName

public String getEventListenerFactoryName(String application,
                                          String key)
                                   throws EventPropertyException
キーに該当するイベントリスナファクトリのクラス名を取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryName
パラメータ:
application - アプリケーション
key - イベントリスナファクトリのキー
戻り値:
イベントリスナファクトリのクラス名
例外:
EventPropertyException - イベントリスナファクトリのクラス名の取得に失敗

getEventListenerFactoryParams

public EventListenerFactoryParam[] getEventListenerFactoryParams(String application,
                                                                 String key)
                                                          throws EventPropertyException
キーに該当するイベントリスナファクトリの初期パラメータを取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryParams
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントリスナファクトリの初期パラメータ
例外:
EventPropertyException - イベントリスナファクトリの初期パラメータの取得に失敗

getEventTriggerInfos

public Collection getEventTriggerInfos(String application,
                                       String key)
                                throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener

getPostEventTriggerInfos

public Collection getPostEventTriggerInfos(String application,
                                           String key)
                                    throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 ここで取得されるイベントトリガはイベントの処理後に実行されます。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getPostEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EJBEventListener (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EJBEventListener

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListener
すべての実装インタフェース:
EventListener
直系の既知のサブクラス:
GenericEJBEventListener, GenericEJBEventListenerLocal, StandardEJBEventListener
public abstract class EJBEventListener
extends Object
implements EventListener

EJBを利用する場合のイベントリスナです。

バージョン:
1.0

コンストラクタの概要
EJBEventListener()
EJBEventListenerを新規に生成します。
メソッドの概要
protected EventResult | dispatchEvent(Event event) イベント処理を実行します。
void | setInTransaction(boolean transaction) このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.framework.base.event.EventListener から継承したメソッド
execute

コンストラクタの詳細

EJBEventListener

public EJBEventListener()
EJBEventListenerを新規に生成します。

メソッドの詳細

setInTransaction

public void setInTransaction(boolean transaction)
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。 このクラスでは実際には何も行いません。

定義:
インタフェース EventListener 内の setInTransaction
パラメータ:
transaction - トランザクションの中で実行されている場合：true、そうでない場合：false
導入されたバージョン:
4.2

dispatchEvent

protected EventResult dispatchEvent(Event event)
                             throws EventManagerException,
                                    EventException,
                                    SystemException,
                                    ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventManagerException - イベントマネージャの生成に失敗
EventException - イベント処理実行に失敗
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生
導入されたバージョン:
4.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EJBEventListenerAgentBean (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EJBEventListenerAgentBean

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean
すべての実装インタフェース:
EnterpriseBean, Serializable, SessionBean
直系の既知のサブクラス:
GenericEJBEventListenerAgentBean, StandardEJBEventListenerAgentBean
public abstract class EJBEventListenerAgentBean
extends Object
implements SessionBean

Session Beanを利用したイベントリスナの抽象クラスです。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
protected  SessionContext sessionContext
セッションコンテキスト
コンストラクタの概要
EJBEventListenerAgentBean()
EJBEventListenerAgentBeanを新規に生成します。
メソッドの概要
protected EventResult | dispatchEvent(Event event) イベント処理を実行します。
void | ejbActivate() "passive"状態の時にインスタンスが活性化される時に呼ばれるメソッドです。
void | ejbPassivate() インスタンスが"passive"状態に移る前に呼ばれるメソッドです。
void | ejbRemove() Session Beanのが終了する前にEJBコンテナが呼び出すメソッドです。
void | setSessionContext(SessionContext sessionContext) 関連するSessionContextを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

sessionContext

protected SessionContext sessionContext
セッションコンテキスト

コンストラクタの詳細

EJBEventListenerAgentBean

public EJBEventListenerAgentBean()
EJBEventListenerAgentBeanを新規に生成します。

メソッドの詳細

setSessionContext

public void setSessionContext(SessionContext sessionContext)
関連するSessionContextを設定します。 コンテナはインスタンス生成後にこのメソッドを呼び出します。

定義:
インタフェース SessionBean 内の setSessionContext
パラメータ:
sessionContext - SessionContextインタフェース

ejbRemove

public void ejbRemove()
               throws EJBException
Session Beanのが終了する前にEJBコンテナが呼び出すメソッドです。

定義:
インタフェース SessionBean 内の ejbRemove
例外:
EJBException - システムレベルのエラー
RemoteException - EJB 1.0以前との互換性のための例外

ejbActivate

public void ejbActivate()
                 throws EJBException
"passive"状態の時にインスタンスが活性化される時に呼ばれるメソッドです。 ejbPassivate()メソッドで先にリリースされたすべてのリソースを再取得します。

定義:
インタフェース SessionBean 内の ejbActivate
例外:
EJBException - システムレベルのエラー
RemoteException - EJB 1.0以前との互換性のための例外

ejbPassivate

public void ejbPassivate()
                  throws EJBException
インスタンスが"passive"状態に移る前に呼ばれるメソッドです。 ejbActivate()メソッドで再取得されるリソースをすべてリリースします。

定義:
インタフェース SessionBean 内の ejbPassivate
例外:
EJBException - システムレベルのエラー
RemoteException - EJB 1.0以前との互換性のための例外

dispatchEvent

protected EventResult dispatchEvent(Event event)
                             throws EventManagerException,
                                    EventException,
                                    SystemException,
                                    ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventManagerException - イベントマネージャの生成に失敗
EventException - イベント処理実行に失敗
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生
導入されたバージョン:
4.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EJBEventListenerFactory (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EJBEventListenerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerFactory
すべての実装インタフェース:
EventListenerFactory
直系の既知のサブクラス:
GenericEJBEventListenerFactory, GenericEJBEventListenerLocalFactory, StandardEJBEventListenerFactory
public abstract class EJBEventListenerFactory
extends Object
implements EventListenerFactory

EJBEventListenerFactoryを生成します。 イベントリスナファクトリの設定では、以下の初期パラメータの設定が必須です。

バージョン:
1.0

フィールドの概要
static String HOME_PARAM
ホームインタフェースを取得するときのJNDI名のパラメータ名
コンストラクタの概要
EJBEventListenerFactory()
EJBEventListenerFactoryを新規に生成します。
メソッドの概要
String | getJNDIName() EJBEventListenerAgentHomeのJNDI名を取得します。
protected void | setJNDIName(String jndiName) EJBEventListenerAgentHomeのJNDI名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.framework.base.event.EventListenerFactory から継承したメソッド
create, initParam

フィールドの詳細

HOME_PARAM

public static final String HOME_PARAM
ホームインタフェースを取得するときのJNDI名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

EJBEventListenerFactory

public EJBEventListenerFactory()
EJBEventListenerFactoryを新規に生成します。

メソッドの詳細

setJNDIName

protected void setJNDIName(String jndiName)
EJBEventListenerAgentHomeのJNDI名を設定します。

パラメータ:
jndiName - EJBEventListenerAgentHomeのJNDI名

getJNDIName

public String getJNDIName()
EJBEventListenerAgentHomeのJNDI名を取得します。

戻り値:
EJBEventListenerAgentHomeのJNDI名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EmptyEvent (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EmptyEvent

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.Event
        拡張 jp.co.intra_mart.framework.base.event.EmptyEvent
すべての実装インタフェース:
Serializable
public class EmptyEvent
extends Event

情報を何も持たないイベントです。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EmptyEvent()
クラス jp.co.intra_mart.framework.base.event.Event から継承したメソッド
getApplication, getKey, getLoginGroup, getLoginGroupID, getLoginUser, getLoginUserID, getUserInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EmptyEvent

public EmptyEvent()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Event (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス Event

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.Event
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
EmptyEvent
public abstract class Event
extends Object
implements Serializable

処理を実行するための情報です。 処理はEventListenerで行われますが、その際に渡される情報をEventのサブクラスで定義します。 Eventのサブクラスを生成する場合はコンストラクタを使用せず、変わりにEventManager.createEvent(String, String, String, String)を使用してください。
注意：
このクラスのサブクラスでは以下のフィールドは定義しないでください。

  • applicationフィールド
  • keyフィールド
  • loginUserIDフィールド
  • loginGroupIDフィールド

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
Event()
イベントを新規に生成します。
メソッドの概要
String | getApplication() アプリケーションを取得します。
String | getKey() イベントキーを取得します。
String | getLoginGroup() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
String | getLoginGroupID() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
String | getLoginUser() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
String | getLoginUserID() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
UserInfo | getUserInfo() ログインユーザの情報を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Event

public Event()
イベントを新規に生成します。

メソッドの詳細

getKey

public final String getKey()
イベントキーを取得します。

戻り値:
イベントキー

getApplication

public final String getApplication()
アプリケーションを取得します。

戻り値:
アプリケーション

getUserInfo

public UserInfo getUserInfo()
ログインユーザの情報を取得します。
ログインセッションが存在しない場合nullを返却します。

戻り値:
ログインユーザの情報
導入されたバージョン:
5.0

getLoginUser

public final String getLoginUser()
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログインユーザIDを取得します。

戻り値:
ログインユーザID

getLoginUserID

public final String getLoginUserID()
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログインユーザIDを取得します。

戻り値:
ログインユーザID
導入されたバージョン:
3.2

getLoginGroup

public final String getLoginGroup()
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログイングループIDを取得します。

戻り値:
ログイングループID

getLoginGroupID

public final String getLoginGroupID()
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログイングループIDを取得します。

戻り値:
ログイングループID
導入されたバージョン:
3.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.event.EventException
すべての実装インタフェース:
Serializable
public class EventException
extends SystemException

イベント生成時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EventException()
詳細メッセージを指定しないで EventException を構築します。
EventException(String msg)
指定された詳細メッセージを持つ EventException を構築します。
EventException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EventException

public EventException()
詳細メッセージを指定しないで EventException を構築します。

EventException

public EventException(String msg)
指定された詳細メッセージを持つ EventException を構築します。

パラメータ:
msg - 詳細メッセージ

EventException

public EventException(String msg,
                      Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventFactoryModel (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventFactoryModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventFactoryModel
public class EventFactoryModel
extends Object

イベントリスナーファクトリー情報を管理するクラスです。

バージョン:
1.0

フィールドの概要
static String | ID
static String | P_ID_FACTORY_CLASS
static String | P_ID_FACTORY_PARAM
static String | P_ID_PARAM_NAME
static String | P_ID_PARAM_VALUE
コンストラクタの概要
EventFactoryModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID

public static final String ID
関連項目:
定数フィールド値

P_ID_FACTORY_CLASS

public static final String P_ID_FACTORY_CLASS
関連項目:
定数フィールド値

P_ID_FACTORY_PARAM

public static final String P_ID_FACTORY_PARAM
関連項目:
定数フィールド値

P_ID_PARAM_NAME

public static final String P_ID_PARAM_NAME
関連項目:
定数フィールド値

P_ID_PARAM_VALUE

public static final String P_ID_PARAM_VALUE
関連項目:
定数フィールド値
コンストラクタの詳細

EventFactoryModel

public EventFactoryModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventGroupModel (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventGroupModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventGroupModel
public class EventGroupModel
extends Object

Event情報を管理するクラスです。

バージョン:
1.0

フィールドの概要
static String | ID
static String | P_ID_EVENT_KEY
static String | P_ID_EVENT_NAME
static String | P_ID_POST_TRIGGER
static String | P_ID_PRE_TRIGGER
static String | P_ID_TRIGGER_CLASS
コンストラクタの概要
EventGroupModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID

public static final String ID
関連項目:
定数フィールド値

P_ID_EVENT_KEY

public static final String P_ID_EVENT_KEY
関連項目:
定数フィールド値

P_ID_EVENT_NAME

public static final String P_ID_EVENT_NAME
関連項目:
定数フィールド値

P_ID_PRE_TRIGGER

public static final String P_ID_PRE_TRIGGER
関連項目:
定数フィールド値

P_ID_POST_TRIGGER

public static final String P_ID_POST_TRIGGER
関連項目:
定数フィールド値

P_ID_TRIGGER_CLASS

public static final String P_ID_TRIGGER_CLASS
関連項目:
定数フィールド値
コンストラクタの詳細

EventGroupModel

public EventGroupModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventListener (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース EventListener

既知の実装クラスの一覧:
EJBEventListener, GenericEventListener, StandardEventListener
public interface EventListener

イベントリスナです。

バージョン:
1.0

メソッドの概要
EventResult | execute(Event event) 処理を実行します。
void | setInTransaction(boolean transaction) このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。

メソッドの詳細

execute

public EventResult execute(Event event)
                    throws SystemException,
                           ApplicationException
処理を実行します。 イベントを元に処理を実行します。 このインタフェースを実装するすべてのクラスは、 すべてのイベントトリガを実行した後に処理を 実行するように設計されている必要があります。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生

setInTransaction

public void setInTransaction(boolean transaction)
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。

パラメータ:
transaction - トランザクションの中で実行されている場合：true、そうでない場合：false
導入されたバージョン:
4.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventListenerException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventListenerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.event.EventListenerException
すべての実装インタフェース:
Serializable
public class EventListenerException
extends SystemException

イベントリスナ生成時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EventListenerException()
詳細メッセージを指定しないで EventListenerException を構築します。
EventListenerException(String msg)
指定された詳細メッセージを持つ EventListenerException を構築します。
EventListenerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventListenerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EventListenerException

public EventListenerException()
詳細メッセージを指定しないで EventListenerException を構築します。

EventListenerException

public EventListenerException(String msg)
指定された詳細メッセージを持つ EventListenerException を構築します。

パラメータ:
msg - 詳細メッセージ

EventListenerException

public EventListenerException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventListenerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventListenerFactory (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース EventListenerFactory

既知の実装クラスの一覧:
EJBEventListenerFactory, GenericEventListenerFactory, StandardEventListenerFactory
public interface EventListenerFactory

イベントリスナを生成します。 EventListenerFactoryは生成するEventListenerの種別ごとに必要です。

バージョン:
1.0

メソッドの概要
EventListener | create(Event event) イベントリスナを生成します。
void | initParam(String name, String value) 初期パラメータを設定します。

メソッドの詳細

create

public EventListener create(Event event)
                     throws EventListenerException
イベントリスナを生成します。

パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

パラメータ:
name - パラメータ名
value - パラメータの値
例外:
EventListenerException - パラメータの設定時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventListenerFactoryParam (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventListenerFactoryParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
        拡張 jp.co.intra_mart.framework.base.event.EventListenerFactoryParam
public class EventListenerFactoryParam
extends PropertyParam

イベントリスナファクトリの初期パラメータです。

バージョン:
1.0

コンストラクタの概要
EventListenerFactoryParam()
EventListenerFactoryParamを新規に生成します。
クラス jp.co.intra_mart.framework.system.property.PropertyParam から継承したメソッド
getName, getValue, setName, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventListenerFactoryParam

public EventListenerFactoryParam()
EventListenerFactoryParamを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventManager (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventManager
public class EventManager
extends Object

イベントマネージャです。

バージョン:
1.0

フィールドの概要
static String EVENT_PROPERTY_HANDLER_KEY
イベントプロパティハンドラのキー
メソッドの概要
Event | createEvent(String application, String key, String loginUser, String loginGroup) 推奨されていません。 このメソッドではなくcreateEvent(String, String, UserInfo)を使用してください。
Event | createEvent(String application, String key, UserInfo info) パラメータで指定された内容に該当するイベントを生成します。
EventResult | dispatch(Event event) イベントに対する処理を実行します。
EventResult | dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
static EventManager | getEventManager() イベントマネージャを取得します。
EventPropertyHandler | getEventPropertyHandler() イベントプロパティハンドラを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

EVENT_PROPERTY_HANDLER_KEY

public static final String EVENT_PROPERTY_HANDLER_KEY
イベントプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getEventManager

public static EventManager getEventManager()
                                    throws EventManagerException
イベントマネージャを取得します。

戻り値:
イベントマネージャ
例外:
EventManagerException - イベントマネージャの生成時に例外が発生

getEventPropertyHandler

public EventPropertyHandler getEventPropertyHandler()
イベントプロパティハンドラを取得します。

戻り値:
イベントプロパティハンドラ

createEvent

public Event createEvent(String application,
                         String key,
                         UserInfo info)
                  throws EventPropertyException,
                         EventException
パラメータで指定された内容に該当するイベントを生成します。 該当するイベントがEventPropertyHandlerのパラメータで設定されていない場合、EmptyEventを返します。

パラメータ:
application - アプリケーション名
key - キー
info - ログインユーザ情報
戻り値:
パラメータに該当するイベント
例外:
EventException - イベント生成に失敗
EventPropertyException - イベントプロパティの取得に失敗
導入されたバージョン:
5.0

createEvent

public Event createEvent(String application,
                         String key,
                         String loginUser,
                         String loginGroup)
                  throws EventPropertyException,
                         EventException
推奨されていません。 このメソッドではなくcreateEvent(String, String, UserInfo)を使用してください。

パラメータで指定された内容に該当するイベントを生成します。 該当するイベントがEventPropertyHandlerのパラメータで設定されていない場合、EmptyEventを返します。

パラメータ:
application - アプリケーション名
key - キー
loginUser - ログインユーザ
loginGroup - ログイングループ
戻り値:
パラメータに該当するイベント
例外:
EventException - イベント生成に失敗
EventPropertyException - イベントプロパティの取得に失敗

dispatch

public EventResult dispatch(Event event)
                     throws EventException,
                            SystemException,
                            ApplicationException
イベントに対する処理を実行します。 イベントを渡されると、イベントに関連するEventListenerFactoryから EventListenerを生成し、EventListenerに処理を依頼します。 eventには必ずcreateEvent(String, String, String, String)で取得したイベントを設定してください。 このメソッドはdispatch(event, false)を呼び出したときと同じ効果があります。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventException - 不正なイベントが渡された
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生

dispatch

public EventResult dispatch(Event event,
                            boolean transaction)
                     throws EventException,
                            SystemException,
                            ApplicationException
イベントに対する処理を実行します。 イベントを渡されると、イベントに関連するEventListenerFactoryから EventListenerを生成し、EventListenerに処理を依頼します。 eventには必ずcreateEvent(String, String, String, String)で取得したイベントを設定してください。
EventListenerに処理を依頼する際、EventListener.setInTransaction(boolean)メソッドが呼ばれます。 このときにtransactionで指定された値が渡されます。

パラメータ:
event - イベント
transaction - トランザクションの中で実行されているかどうかを示すフラグ（トランザクション内の場合true、トランザクション外の場合false）
戻り値:
イベント処理結果
例外:
EventException - 不正なイベントが渡された
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生
導入されたバージョン:
4.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventManagerException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.event.EventManagerException
すべての実装インタフェース:
Serializable
public class EventManagerException
extends SystemException

イベントマネージャ設定時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EventManagerException()
詳細メッセージを指定しないで EventManagerException を構築します。
EventManagerException(String msg)
指定された詳細メッセージを持つ EventManagerException を構築します。
EventManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EventManagerException

public EventManagerException()
詳細メッセージを指定しないで EventManagerException を構築します。

EventManagerException

public EventManagerException(String msg)
指定された詳細メッセージを持つ EventManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

EventManagerException

public EventManagerException(String msg,
                             Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventModelProducer (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventModelProducer

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventModelProducer
public class EventModelProducer
extends Object

イベント情報を作成するクラスです。

バージョン:
1.0

コンストラクタの概要
EventModelProducer()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventModelProducer

public EventModelProducer()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventPropertyException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventPropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.event.EventPropertyException
すべての実装インタフェース:
Serializable
public class EventPropertyException
extends SystemException

イベントプロパティ取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EventPropertyException()
詳細メッセージを指定しないで EventPropertyException を構築します。
EventPropertyException(String msg)
指定された詳細メッセージを持つ EventPropertyException を構築します。
EventPropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventPropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EventPropertyException

public EventPropertyException()
詳細メッセージを指定しないで EventPropertyException を構築します。

EventPropertyException

public EventPropertyException(String msg)
指定された詳細メッセージを持つ EventPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

EventPropertyException

public EventPropertyException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventPropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース EventPropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultEventPropertyHandler, DistributesEventPropertyHandler, TextFileEventPropertyHandler, XmlEventPropertyHandler
public interface EventPropertyHandler
extends PropertyHandler

イベントの設定情報に接続するクラスです。

バージョン:
1.0

メソッドの概要
String | getEventListenerFactoryName(String application, String key) キーに該当するイベントリスナファクトリのクラス名を取得します。
EventListenerFactoryParam[] | getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
String | getEventName(String application, String key) キーに該当するイベントのクラス名を取得します。
Collection | getEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
Collection | getPostEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws EventPropertyException
プロパティの動的読み込みが可能かどうか調べます。

戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可
例外:
EventPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getEventName

public String getEventName(String application,
                           String key)
                    throws EventPropertyException
キーに該当するイベントのクラス名を取得します。 該当するイベントが存在しない場合、nullを返します。

パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントのクラス名
例外:
EventPropertyException - イベントのクラス名の取得に失敗

getEventListenerFactoryName

public String getEventListenerFactoryName(String application,
                                          String key)
                                   throws EventPropertyException
キーに該当するイベントリスナファクトリのクラス名を取得します。

パラメータ:
application - アプリケーション
key - イベントリスナファクトリのキー
戻り値:
イベントリスナファクトリのクラス名
例外:
EventPropertyException - イベントリスナファクトリのクラス名の取得に失敗

getEventListenerFactoryParams

public EventListenerFactoryParam[] getEventListenerFactoryParams(String application,
                                                                 String key)
                                                          throws EventPropertyException
キーに該当するイベントリスナファクトリの初期パラメータを取得します。

パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントリスナファクトリの初期パラメータ
例外:
EventPropertyException - イベントリスナファクトリの初期パラメータの取得に失敗

getEventTriggerInfos

public Collection getEventTriggerInfos(String application,
                                       String key)
                                throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener

getPostEventTriggerInfos

public Collection getPostEventTriggerInfos(String application,
                                           String key)
                                    throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 ここで取得されるイベントトリガはイベントの処理後に実行されます。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventResult (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース EventResult

すべてのスーパーインタフェース:
Serializable
public interface EventResult
extends Serializable

イベント処理の結果です。

バージョン:
1.0

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventTrigger (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース EventTrigger

既知の実装クラスの一覧:
EventTriggerAdapter
public interface EventTrigger

イベントトリガです。 このインタフェースを実装するクラスでは、定数(static final)以外のフィールドは定義しないでください。

バージョン:
1.0

メソッドの概要
 void fire(Event event, DataAccessController controller)
イベントに対する処理を行います。

メソッドの詳細

fire

public void fire(Event event,
                 DataAccessController controller)
          throws SystemException,
                 ApplicationException
イベントに対する処理を行います。 トランザクションはcontrollerで管理されています。 このメソッドを実装するとき、内部でトランザクションのロールバックやコミットを行わないようにしてください。 メソッドが失敗した場合、またはロールバックを行いたい場合は、ApplicationExceptionのサブクラスを例外としてthrowしてください。

パラメータ:
event - イベント
controller - データアクセスコントローラ
例外:
SystemException - システム例外が発生
ApplicationException - アプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventTriggerAdapter (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventTriggerAdapter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventTriggerAdapter
すべての実装インタフェース:
EventTrigger
public abstract class EventTriggerAdapter
extends Object
implements EventTrigger

DAOを取得するメソッドを持ったイベントトリガです。

バージョン:
1.0

コンストラクタの概要
EventTriggerAdapter()
EventTriggerAdapterを新規に生成します。
メソッドの概要
protected abstract void | fire(Event event) イベントに対する処理を行います。
void | fire(Event event, DataAccessController controller) イベントに対する処理を行います。
protected Object | getDAO(String application, String key, String connect) DAOを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventTriggerAdapter

public EventTriggerAdapter()
EventTriggerAdapterを新規に生成します。

メソッドの詳細

getDAO

protected Object getDAO(String application,
                        String key,
                        String connect)
                 throws DataPropertyException,
                        DataConnectorException,
                        DAOException,
                        DataConnectException
DAOを取得します。 キーと接続情報で指定されたDAOを取得します。

パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAO
例外:
DataPropertyException - プロパティの取得に失敗
DataConnectorException - データコネクタの取得に失敗
DAOException - DAOの取得に失敗
DataConnectException - データリソースとの接続に失敗

fire

public void fire(Event event,
                 DataAccessController controller)
          throws SystemException,
                 ApplicationException
イベントに対する処理を行います。 トランザクションはcontrollerで管理されています。 このメソッドはfire(jp.co.intra_mart.framework.base.event.Event)メソッドを呼ぶように実装されています。

定義:
インタフェース EventTrigger 内の fire
パラメータ:
event - イベント
controller - データアクセスコントローラ
例外:
SystemException - システム例外が発生
ApplicationException - アプリケーション例外が発生

fire

protected abstract void fire(Event event)
                      throws SystemException,
                             ApplicationException
イベントに対する処理を行います。 このメソッドを実装するとき、内部でトランザクションのロールバックやコミットを行わないようにしてください。 メソッドが失敗した場合、またはロールバックを行いたい場合は、ApplicationExceptionのサブクラスを例外としてthrowしてください。

パラメータ:
event - イベント
例外:
SystemException - システム例外が発生
ApplicationException - アプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventTriggerException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventTriggerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.event.EventTriggerException
すべての実装インタフェース:
Serializable
public class EventTriggerException
extends SystemException

イベントトリガ生成時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EventTriggerException()
詳細メッセージを指定しないで EventTriggerException を構築します。
EventTriggerException(String msg)
指定された詳細メッセージを持つ EventTriggerException を構築します。
EventTriggerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventTriggerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EventTriggerException

public EventTriggerException()
詳細メッセージを指定しないで EventTriggerException を構築します。

EventTriggerException

public EventTriggerException(String msg)
指定された詳細メッセージを持つ EventTriggerException を構築します。

パラメータ:
msg - 詳細メッセージ

EventTriggerException

public EventTriggerException(String msg,
                             Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventTriggerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventTriggerInfo (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventTriggerInfo

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventTriggerInfo
public class EventTriggerInfo
extends Object

イベントトリガの情報です。

バージョン:
1.0

コンストラクタの概要
EventTriggerInfo()
EventTriggerInfoを新規に生成します。
メソッドの概要
String | getName() イベントトリガ名を取得します。
int | getNumber() ソート番号を取得します。
void | setName(String name) イベントトリガ名を設定します。
void | setNumber(int number) ソート番号を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventTriggerInfo

public EventTriggerInfo()
EventTriggerInfoを新規に生成します。

メソッドの詳細

setNumber

public void setNumber(int number)
ソート番号を設定します。

パラメータ:
number - ソート番号

getNumber

public int getNumber()
ソート番号を取得します。

戻り値:
ソート番号

setName

public void setName(String name)
イベントトリガ名を設定します。

パラメータ:
name - イベントトリガ名

getName

public String getName()
イベントトリガ名を取得します。

戻り値:
イベントトリガ名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventTriggerList (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventTriggerList

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventTriggerList
public class EventTriggerList
extends Object

イベントトリガの集合を扱います。 イベントトリガの生成し、順番に実行します。

バージョン:
1.0

コンストラクタの概要
EventTriggerList(String application, String key)
EventTriggerListを新規に生成します。
EventTriggerList(String application, String key, boolean pre)
EventTriggerListを新規に生成します。
メソッドの概要
 void fireAll(Event event, DataAccessController controller)
すべてのトリガに対してイベントの処理を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventTriggerList

public EventTriggerList(String application,
                        String key)
                 throws EventManagerException,
                        EventPropertyException,
                        EventTriggerException
EventTriggerListを新規に生成します。 このコンストラクタではイベントの前に処理するEventTriggerListを生成します。 このコンストラクタはEvent(application, key, true) と同じ結果となります。

パラメータ:
application - アプリケーション名
key - キー
例外:
EventManagerException - EventManager生成時に例外が発生した
EventPropertyException - イベントプロパティの取得時に例外が発生した
EventTriggerException - イベントトリガ生成時に例外が発生した

EventTriggerList

public EventTriggerList(String application,
                        String key,
                        boolean pre)
                 throws EventManagerException,
                        EventPropertyException,
                        EventTriggerException
EventTriggerListを新規に生成します。 preによってイベントの前に処理されるイベントトリガであるか イベントの後に処理されるイベントトリガであるかを指定します。

パラメータ:
application - アプリケーション名
key - キー
pre - true:イベントの前に起動するイベントトリガ、false:イベントの後に起動するイベントトリガ
例外:
EventManagerException - EventManager生成時に例外が発生した
EventPropertyException - イベントプロパティの取得時に例外が発生した
EventTriggerException - イベントトリガ生成時に例外が発生した
導入されたバージョン:
4.3
メソッドの詳細

fireAll

public void fireAll(Event event,
                    DataAccessController controller)
             throws SystemException,
                    ApplicationException
すべてのトリガに対してイベントの処理を行います。

パラメータ:
event - イベント
controller - データアクセスコントローラ
例外:
SystemException - システム例外が発生した
ApplicationException - アプリケーション例外が発生した
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListener (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEJBEventListener

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListener
        拡張 jp.co.intra_mart.framework.base.event.GenericEJBEventListener
すべての実装インタフェース:
EventListener
public class GenericEJBEventListener
extends EJBEventListener

EJBを利用する汎用的なイベントリスナです。

バージョン:
1.0

コンストラクタの概要
GenericEJBEventListener(GenericEJBEventListenerAgentHome home, String listenerName)
GenericEJBEventListenerを新規に生成します。
メソッドの概要
 EventResult execute(Event event)
処理を実行します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListener から継承したメソッド
dispatchEvent, setInTransaction
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericEJBEventListener

public GenericEJBEventListener(GenericEJBEventListenerAgentHome home,
                               String listenerName)
GenericEJBEventListenerを新規に生成します。

パラメータ:
home - ホームインタフェースGenericEJBEventListenerAgentHome
listenerName - 実際に処理を行うStandardEventListenerのクラス名
メソッドの詳細

execute

public EventResult execute(Event event)
                    throws SystemException,
                           ApplicationException
処理を実行します。 イベントを元に処理を実行します。 このインタフェースを実装するすべてのクラスは、 すべてのイベントトリガを実行した後に処理を 実行するように設計されている必要があります。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListenerAgent (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース GenericEJBEventListenerAgent

すべてのスーパーインタフェース:
EJBObject, Remote
public interface GenericEJBEventListenerAgent
extends EJBObject

汎用的なEJB用のイベントリスナのリモートインタフェースです。

バージョン:
1.0

メソッドの概要
 EventResult execute(Event event, String listenerName)
イベント処理を行います。
インタフェース javax.ejb.EJBObject から継承したメソッド
getEJBHome, getHandle, getPrimaryKey, isIdentical, remove

メソッドの詳細

execute

public EventResult execute(Event event,
                           String listenerName)
                    throws ApplicationException,
                           SystemException,
                           RemoteException,
                           EJBException
イベント処理を行います。 実際の処理はlistenerNameで定義されたクラスで行われます。 listenerNameで指定されるクラスはStandardEventListenerを継承し、引数のないコンストラクタを持つ必要があります。

パラメータ:
event - イベント
listenerName - イベントリスナのクラス名
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
EJBException - システムレベルのエラー
RemoteException - システムエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListenerAgentBean (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEJBEventListenerAgentBean

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean
        拡張 jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean
すべての実装インタフェース:
EnterpriseBean, Serializable, SessionBean
public class GenericEJBEventListenerAgentBean
extends EJBEventListenerAgentBean

EJBを利用する汎用的なイベントリスナーのBeanです。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean から継承したフィールド
sessionContext
コンストラクタの概要
GenericEJBEventListenerAgentBean()
GenericEJBEventListenerAgentBeanを新規に生成します。
メソッドの概要
void | ejbCreate() ホームインタフェースの引数なしのcreate()メソッドに対応します。
EventResult | execute(Event event, String listenerName) イベント処理を実行します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean から継承したメソッド
dispatchEvent, ejbActivate, ejbPassivate, ejbRemove, setSessionContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericEJBEventListenerAgentBean

public GenericEJBEventListenerAgentBean()
GenericEJBEventListenerAgentBeanを新規に生成します。

メソッドの詳細

ejbCreate

public void ejbCreate()
ホームインタフェースの引数なしのcreate()メソッドに対応します。

execute

public EventResult execute(Event event,
                           String listenerName)
                    throws ApplicationException,
                           SystemException,
                           EJBException
イベント処理を実行します。 listenerNameはStandardEventListenerを継承したクラスであり、引数を持たないコンストラクタが存在する必要があります。

パラメータ:
event - イベント
listenerName - リスナーのクラス名
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
EJBException - システムレベルのエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListenerAgentHome (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース GenericEJBEventListenerAgentHome

すべてのスーパーインタフェース:
EJBHome, Remote
public interface GenericEJBEventListenerAgentHome
extends EJBHome

リモートインタフェースGenericEJBEventListenerAgentを取得するホームインタフェースです。

バージョン:
1.0

メソッドの概要
 GenericEJBEventListenerAgent create()
リモートインタフェースGenericEJBEventListenerAgentを取得します。
インタフェース javax.ejb.EJBHome から継承したメソッド
getEJBMetaData, getHomeHandle, remove, remove

メソッドの詳細

create

public GenericEJBEventListenerAgent create()
                                    throws RemoteException,
                                           CreateException
リモートインタフェースGenericEJBEventListenerAgentを取得します。

戻り値:
GenericEJBEventListenerAgent
例外:
RemoteException - システムエラー
CreateException - リモートインタフェース取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListenerAgentLocal (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース GenericEJBEventListenerAgentLocal

すべてのスーパーインタフェース:
EJBLocalObject
public interface GenericEJBEventListenerAgentLocal
extends EJBLocalObject

汎用的なEJB用のイベントリスナのローカルインタフェースです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
 EventResult execute(Event event, String listenerName)
イベント処理を行います。
インタフェース javax.ejb.EJBLocalObject から継承したメソッド
getEJBLocalHome, getPrimaryKey, isIdentical, remove

メソッドの詳細

execute

public EventResult execute(Event event,
                           String listenerName)
                    throws ApplicationException,
                           SystemException,
                           EJBException
イベント処理を行います。 実際の処理はlistenerNameで定義されたクラスで行われます。 listenerNameで指定されるクラスはStandardEventListenerを継承し、引数のないコンストラクタを持つ必要があります。

パラメータ:
event - イベント
listenerName - イベントリスナのクラス名
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
EJBException - システムレベルのエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListenerAgentLocalHome (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース GenericEJBEventListenerAgentLocalHome

すべてのスーパーインタフェース:
EJBLocalHome
public interface GenericEJBEventListenerAgentLocalHome
extends EJBLocalHome

ローカルインタフェースGenericEJBEventListenerAgentLocalを取得するホームインタフェースです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
 GenericEJBEventListenerAgentLocal create()
ローカルインタフェース GenericEJBEventListenerAgentLocalを取得します。
インタフェース javax.ejb.EJBLocalHome から継承したメソッド
remove

メソッドの詳細

create

public GenericEJBEventListenerAgentLocal create()
                                         throws CreateException
ローカルインタフェース GenericEJBEventListenerAgentLocalを取得します。

戻り値:
GenericEJBEventListenerAgentLocal
例外:
RemoteException - システムエラー
CreateException - リモートインタフェース取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListenerFactory (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEJBEventListenerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerFactory
        拡張 jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory
すべての実装インタフェース:
EventListenerFactory
public class GenericEJBEventListenerFactory
extends EJBEventListenerFactory

GenericEJBEventListenerを生成します。

バージョン:
1.0

フィールドの概要
static String LISTENER_PARAM
イベントリスナーのクラス名のパラメータ名
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory から継承したフィールド
HOME_PARAM
コンストラクタの概要
GenericEJBEventListenerFactory()
GenericEJBEventListenerFactoryを新規に生成します。
メソッドの概要
EventListener | create(Event event) イベントリスナを生成します。
String | getListenerName() EJBEventListenerAgentBeanのクラス名を取得します。
void | initParam(String name, String value) 初期パラメータを設定します。
protected void | setListenerName(String listenerName) EJBEventListenerAgentBeanのクラス名を設定します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory から継承したメソッド
getJNDIName, setJNDIName
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

LISTENER_PARAM

public static final String LISTENER_PARAM
イベントリスナーのクラス名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

GenericEJBEventListenerFactory

public GenericEJBEventListenerFactory()
GenericEJBEventListenerFactoryを新規に生成します。

メソッドの詳細

create

public EventListener create(Event event)
                     throws EventListenerException
イベントリスナを生成します。

パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

パラメータ:
name - パラメータ名
value - パラメータの値
例外:
EventListenerException - パラメータの設定時に例外が発生

setListenerName

protected void setListenerName(String listenerName)
EJBEventListenerAgentBeanのクラス名を設定します。

パラメータ:
listenerName - EJBEventListenerAgentBeanのクラス名

getListenerName

public String getListenerName()
EJBEventListenerAgentBeanのクラス名を取得します。

戻り値:
EJBEventListenerAgentBeanのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListenerLocal (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEJBEventListenerLocal

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListener
        拡張 jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal
すべての実装インタフェース:
EventListener
public class GenericEJBEventListenerLocal
extends EJBEventListener

ローカルEJBを利用する汎用的なイベントリスナです。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
GenericEJBEventListenerLocal(GenericEJBEventListenerAgentLocalHome home, String listenerName)
GenericEJBEventListnerLocalを新規に生成します。
メソッドの概要
 EventResult execute(Event event)
処理を実行します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListener から継承したメソッド
dispatchEvent, setInTransaction
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericEJBEventListenerLocal

public GenericEJBEventListenerLocal(GenericEJBEventListenerAgentLocalHome home,
                                    String listenerName)
GenericEJBEventListnerLocalを新規に生成します。

パラメータ:
home - ホームインタフェース
listenerName - 実際に処理を行うStandardEventListenerのクラス名
メソッドの詳細

execute

public EventResult execute(Event event)
                    throws SystemException,
                           ApplicationException
処理を実行します。 イベントを元に処理を実行します。 このインタフェースを実装するすべてのクラスは、 すべてのイベントトリガを実行した後に処理を 実行するように設計されている必要があります。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListenerLocalFactory (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEJBEventListenerLocalFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerFactory
        拡張 jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory
すべての実装インタフェース:
EventListenerFactory
public class GenericEJBEventListenerLocalFactory
extends EJBEventListenerFactory

GenericEJBEventListnerLocalを新規に生成します。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String LISTENER_PARAM
イベントリスナーのクラス名のパラメータ名
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory から継承したフィールド
HOME_PARAM
コンストラクタの概要
GenericEJBEventListenerLocalFactory()
GenericEJBEventListnerLocalFactoryを新規に生成します。
メソッドの概要
EventListener | create(Event event) イベントリスナを生成します。
String | getListenerName() EJBEventListenerAgentBeanのクラス名を取得します。
void | initParam(String name, String value) 初期パラメータを設定します。
protected void | setListenerName(String listenerName) EJBEventListenerAgentBeanのクラス名を設定します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory から継承したメソッド
getJNDIName, setJNDIName
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

LISTENER_PARAM

public static final String LISTENER_PARAM
イベントリスナーのクラス名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

GenericEJBEventListenerLocalFactory

public GenericEJBEventListenerLocalFactory()
GenericEJBEventListnerLocalFactoryを新規に生成します。

メソッドの詳細

create

public EventListener create(Event event)
                     throws EventListenerException
イベントリスナを生成します。

パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

パラメータ:
name - パラメータ名
value - パラメータの値
例外:
EventListenerException - パラメータの設定時に例外が発生

setListenerName

protected void setListenerName(String listenerName)
EJBEventListenerAgentBeanのクラス名を設定します。

パラメータ:
listenerName - EJBEventListenerAgentBeanのクラス名

getListenerName

public String getListenerName()
EJBEventListenerAgentBeanのクラス名を取得します。

戻り値:
EJBEventListenerAgentBeanのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEventListener (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEventListener

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.GenericEventListener
すべての実装インタフェース:
EventListener
public class GenericEventListener
extends Object
implements EventListener

汎用的なイベントリスナです。

バージョン:
1.0

コンストラクタの概要
GenericEventListener()
GenericEventListenerを新規に生成します。
メソッドの概要
EventResult | execute(Event event) 処理を実行します。
void | setInTransaction(boolean transaction) このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
void | setListener(StandardEventListener listener) イベント処理クラスを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericEventListener

public GenericEventListener()
GenericEventListenerを新規に生成します。

メソッドの詳細

execute

public EventResult execute(Event event)
                    throws SystemException,
                           ApplicationException
処理を実行します。 イベントを元に処理を実行します。 このインタフェースを実装するすべてのクラスは、 すべてのイベントトリガを実行した後に処理を 実行するように設計されている必要があります。

定義:
インタフェース EventListener 内の execute
パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生

setListener

public void setListener(StandardEventListener listener)
イベント処理クラスを設定します。

パラメータ:
listener - イベント処理クラス

setInTransaction

public void setInTransaction(boolean transaction)
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。

定義:
インタフェース EventListener 内の setInTransaction
パラメータ:
transaction - トランザクションの中で実行されている場合：true、そうでない場合：false
導入されたバージョン:
4.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEventListenerFactory (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEventListenerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.GenericEventListenerFactory
すべての実装インタフェース:
EventListenerFactory
public class GenericEventListenerFactory
extends Object
implements EventListenerFactory

GenericEventListenerを生成するイベントリスナファクトリです。 このファクトリで指定できる初期パラメータは以下のとおりです。

パラメータ名 | 値
listener | 包含するイベントリスナ

バージョン:
1.0

コンストラクタの概要
GenericEventListenerFactory()
GenericEventListenerFactoryを新規に生成します。
メソッドの概要
EventListener | create(Event event) イベントリスナを生成します。
void | initParam(String name, String value) 初期パラメータを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericEventListenerFactory

public GenericEventListenerFactory()
GenericEventListenerFactoryを新規に生成します。

メソッドの詳細

create

public EventListener create(Event event)
                     throws EventListenerException
イベントリスナを生成します。

定義:
インタフェース EventListenerFactory 内の create
パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

定義:
インタフェース EventListenerFactory 内の initParam
パラメータ:
name - パラメータ名
value - パラメータの値
例外:
EventListenerException - パラメータの設定時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.event (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.base.event
インタフェース
EventListener
EventListenerFactory
EventPropertyHandler
EventResult
EventTrigger
GenericEJBEventListenerAgent
GenericEJBEventListenerAgentHome
GenericEJBEventListenerAgentLocal
GenericEJBEventListenerAgentLocalHome
StandardEJBEventListenerAgent
StandardEJBEventListenerAgentHome
クラス
DefaultEventPropertyHandler
DistributesEventPropertyHandler
EJBEventListener
EJBEventListenerAgentBean
EJBEventListenerFactory
EmptyEvent
Event
EventFactoryModel
EventGroupModel
EventListenerFactoryParam
EventManager
EventModelProducer
EventTriggerAdapter
EventTriggerInfo
EventTriggerList
GenericEJBEventListener
GenericEJBEventListenerAgentBean
GenericEJBEventListenerFactory
GenericEJBEventListenerLocal
GenericEJBEventListenerLocalFactory
GenericEventListener
GenericEventListenerFactory
StandardEJBEventListener
StandardEJBEventListenerAgentBean
StandardEJBEventListenerFactory
StandardEventListener
StandardEventListenerFactory
TextFileEventPropertyHandler
XmlEventPropertyHandler
例外
EventException
EventListenerException
EventManagerException
EventPropertyException
EventTriggerException


jp.co.intra_mart.framework.base.event (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.event

イベントフレームワークに関連するクラスのパッケージです。

参照:
説明

インタフェースの概要
EventListener | イベントリスナです。
EventListenerFactory | イベントリスナを生成します。
EventPropertyHandler | イベントの設定情報に接続するクラスです。
EventResult | イベント処理の結果です。
EventTrigger | イベントトリガです。
GenericEJBEventListenerAgent | 汎用的なEJB用のイベントリスナのリモートインタフェースです。
GenericEJBEventListenerAgentHome | リモートインタフェースGenericEJBEventListenerAgentを取得するホームインタフェースです。
GenericEJBEventListenerAgentLocal | 汎用的なEJB用のイベントリスナのローカルインタフェースです。
GenericEJBEventListenerAgentLocalHome | ローカルインタフェースGenericEJBEventListenerAgentLocalを取得するホームインタフェースです。
StandardEJBEventListenerAgent | EJBを利用するときのイベントリスナのリモートインタフェースです。
StandardEJBEventListenerAgentHome | StandardEJBEventListenerAgentのホームインタフェースです。

クラスの概要
DefaultEventPropertyHandler | デフォルトのEventPropertyHandlerです。
DistributesEventPropertyHandler | アプリケーション毎のEventPropertyHandlerを呼び出します。
EJBEventListener | EJBを利用する場合のイベントリスナです。
EJBEventListenerAgentBean | Session Beanを利用したイベントリスナの抽象クラスです。
EJBEventListenerFactory | EJBEventListenerFactoryを生成します。
EmptyEvent | 情報を何も持たないイベントです。
Event | 処理を実行するための情報です。
EventFactoryModel | イベントリスナーファクトリー情報を管理するクラスです。
EventGroupModel | Event情報を管理するクラスです。
EventListenerFactoryParam | イベントリスナファクトリの初期パラメータです。
EventManager | イベントマネージャです。
EventModelProducer | イベント情報を作成するクラスです。
EventTriggerAdapter | DAOを取得するメソッドを持ったイベントトリガです。
EventTriggerInfo | イベントトリガの情報です。
EventTriggerList | イベントトリガの集合を扱います。
GenericEJBEventListener | EJBを利用する汎用的なイベントリスナです。
GenericEJBEventListenerAgentBean | EJBを利用する汎用的なイベントリスナーのBeanです。
GenericEJBEventListenerFactory | GenericEJBEventListenerを生成します。
GenericEJBEventListenerLocal | ローカルEJBを利用する汎用的なイベントリスナです。
GenericEJBEventListenerLocalFactory | GenericEJBEventListnerLocalを新規に生成します。
GenericEventListener | 汎用的なイベントリスナです。
GenericEventListenerFactory | GenericEventListenerを生成するイベントリスナファクトリです。
StandardEJBEventListener | StandardEJBEventListenerAgentに接続するイベントリスナです。
StandardEJBEventListenerAgentBean | EJBを利用する場合の抽象的なイベントリスナです。
StandardEJBEventListenerFactory | 標準的なEJB用のイベントリスナファクトリです。
StandardEventListener | 汎用的なビジネスロジック用のクラスです。
StandardEventListenerFactory | 通常のJavaクラスのイベントリスナを生成します。
TextFileEventPropertyHandler | 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
XmlEventPropertyHandler | XMLのEventPropertyHandlerです。

例外の概要
EventException | イベント生成時の例外です。
EventListenerException | イベントリスナ生成時の例外です。
EventManagerException | イベントマネージャ設定時の例外です。
EventPropertyException | イベントプロパティ取得時の例外です。
EventTriggerException | イベントトリガ生成時の例外です。

パッケージ jp.co.intra_mart.framework.base.event の説明

イベントフレームワークに関連するクラスのパッケージです。 イベントフレームワークを利用して処理を行う手順の概要は次のとおりです。

  • アプリケーションIDとイベントキーからEventを生成する。
  • Eventに処理に必要となる情報を設定する。
  • アプリケーションIDとイベントキーに対応するEventListenerにEventを渡し、処理を行う。
  • EventListenerは処理結果となるEventResultを返す。


jp.co.intra_mart.framework.base.event クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.event の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class jp.co.intra_mart.framework.base.event.EJBEventListener (implements jp.co.intra_mart.framework.base.event.EventListener)
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListener
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal
      • class jp.co.intra_mart.framework.base.event.StandardEJBEventListener
    • class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean (implements javax.ejb.SessionBean)
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean
      • class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean
    • class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory
      • class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory
    • class jp.co.intra_mart.framework.base.event.Event (implements java.io.Serializable)
      • class jp.co.intra_mart.framework.base.event.EmptyEvent
    • class jp.co.intra_mart.framework.base.event.EventFactoryModel
    • class jp.co.intra_mart.framework.base.event.EventGroupModel
    • class jp.co.intra_mart.framework.base.event.EventManager
    • class jp.co.intra_mart.framework.base.event.EventModelProducer
    • class jp.co.intra_mart.framework.base.event.EventTriggerAdapter (implements jp.co.intra_mart.framework.base.event.EventTrigger)
    • class jp.co.intra_mart.framework.base.event.EventTriggerInfo
    • class jp.co.intra_mart.framework.base.event.EventTriggerList
    • class jp.co.intra_mart.framework.base.event.GenericEventListener (implements jp.co.intra_mart.framework.base.event.EventListener)
    • class jp.co.intra_mart.framework.base.event.GenericEventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.base.event.EventListenerFactoryParam
    • class jp.co.intra_mart.framework.base.event.StandardEventListener (implements jp.co.intra_mart.framework.base.event.EventListener)
    • class jp.co.intra_mart.framework.base.event.StandardEventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
    • class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.event.EventException
            • class jp.co.intra_mart.framework.base.event.EventListenerException
            • class jp.co.intra_mart.framework.base.event.EventManagerException
            • class jp.co.intra_mart.framework.base.event.EventPropertyException
            • class jp.co.intra_mart.framework.base.event.EventTriggerException
    • class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)

インタフェース階層

  • interface javax.ejb.EJBLocalHome
    • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocalHome
  • interface javax.ejb.EJBLocalObject
    • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocal
  • interface jp.co.intra_mart.framework.base.event.EventListener
  • interface jp.co.intra_mart.framework.base.event.EventListenerFactory
  • interface jp.co.intra_mart.framework.base.event.EventTrigger
  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.base.event.EventPropertyHandler
  • interface java.rmi.Remote
    • interface javax.ejb.EJBHome
      • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome
      • interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome
    • interface javax.ejb.EJBObject
      • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent
      • interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent
  • interface java.io.Serializable
    • interface jp.co.intra_mart.framework.base.event.EventResult


パッケージ jp.co.intra_mart.framework.base.event の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.event の使用

jp.co.intra_mart.framework.base.event を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event.container |
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event により使用される jp.co.intra_mart.framework.base.event のクラス
EJBEventListener
EJBを利用する場合のイベントリスナです。
EJBEventListenerAgentBean
Session Beanを利用したイベントリスナの抽象クラスです。
EJBEventListenerFactory
EJBEventListenerFactoryを生成します。
Event
処理を実行するための情報です。
EventException
イベント生成時の例外です。
EventListener
イベントリスナです。
EventListenerException
イベントリスナ生成時の例外です。
EventListenerFactory
イベントリスナを生成します。
EventListenerFactoryParam
イベントリスナファクトリの初期パラメータです。
EventManager
イベントマネージャです。
EventManagerException
イベントマネージャ設定時の例外です。
EventPropertyException
イベントプロパティ取得時の例外です。
EventPropertyHandler
イベントの設定情報に接続するクラスです。
EventResult
イベント処理の結果です。
EventTrigger
イベントトリガです。
EventTriggerException
イベントトリガ生成時の例外です。
GenericEJBEventListenerAgent
汎用的なEJB用のイベントリスナのリモートインタフェースです。
GenericEJBEventListenerAgentHome
リモートインタフェースGenericEJBEventListenerAgentを取得するホームインタフェースです。
GenericEJBEventListenerAgentLocal
汎用的なEJB用のイベントリスナのローカルインタフェースです。
GenericEJBEventListenerAgentLocalHome
ローカルインタフェースGenericEJBEventListenerAgentLocalを取得するホームインタフェースです。
StandardEJBEventListenerAgent
EJBを利用するときのイベントリスナのリモートインタフェースです。
StandardEJBEventListenerAgentHome
StandardEJBEventListenerAgentのホームインタフェースです。
StandardEventListener
汎用的なビジネスロジック用のクラスです。

jp.co.intra_mart.framework.base.event.container により使用される jp.co.intra_mart.framework.base.event のクラス
Event
処理を実行するための情報です。
EventException
イベント生成時の例外です。
EventPropertyException
イベントプロパティ取得時の例外です。
EventPropertyHandler
イベントの設定情報に接続するクラスです。
EventResult
イベント処理の結果です。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.base.event のクラス
Event
処理を実行するための情報です。
EventException
イベント生成時の例外です。
EventManagerException
イベントマネージャ設定時の例外です。
EventResult
イベント処理の結果です。

jp.co.intra_mart.framework.base.web.bean により使用される jp.co.intra_mart.framework.base.event のクラス
Event
処理を実行するための情報です。
EventException
イベント生成時の例外です。
EventResult
イベント処理の結果です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardEJBEventListener (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス StandardEJBEventListener

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListener
        拡張 jp.co.intra_mart.framework.base.event.StandardEJBEventListener
すべての実装インタフェース:
EventListener
public class StandardEJBEventListener
extends EJBEventListener

StandardEJBEventListenerAgentに接続するイベントリスナです。

バージョン:
1.0

コンストラクタの概要
StandardEJBEventListener(StandardEJBEventListenerAgentHome home)
StandardEJBEventListenerを新規に生成します。
メソッドの概要
 EventResult execute(Event event)
処理を実行します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListener から継承したメソッド
dispatchEvent, setInTransaction
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardEJBEventListener

public StandardEJBEventListener(StandardEJBEventListenerAgentHome home)
StandardEJBEventListenerを新規に生成します。

パラメータ:
home - ホームインタフェースStandardEJBEventListenerAgentHome
メソッドの詳細

execute

public EventResult execute(Event event)
                    throws SystemException,
                           ApplicationException
処理を実行します。 イベントを元に処理を実行します。 このインタフェースを実装するすべてのクラスは、 すべてのイベントトリガを実行した後に処理を 実行するように設計されている必要があります。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardEJBEventListenerAgent (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース StandardEJBEventListenerAgent

すべてのスーパーインタフェース:
EJBObject, Remote
public interface StandardEJBEventListenerAgent
extends EJBObject

EJBを利用するときのイベントリスナのリモートインタフェースです。

バージョン:
1.0

メソッドの概要
 EventResult execute(Event event)
イベント処理を実行します。
インタフェース javax.ejb.EJBObject から継承したメソッド
getEJBHome, getHandle, getPrimaryKey, isIdentical, remove

メソッドの詳細

execute

public EventResult execute(Event event)
                    throws ApplicationException,
                           SystemException,
                           RemoteException,
                           EJBException
イベント処理を実行します。 実際の処理はStandardEJBEventListenerAgentBean.execute(jp.co.intra_mart.framework.base.event.Event)で行われます。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
EJBException - システムレベルのエラー
RemoteException - システムエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardEJBEventListenerAgentBean (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス StandardEJBEventListenerAgentBean

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean
        拡張 jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean
すべての実装インタフェース:
EnterpriseBean, Serializable, SessionBean
public abstract class StandardEJBEventListenerAgentBean
extends EJBEventListenerAgentBean

EJBを利用する場合の抽象的なイベントリスナです。 メソッドfire(jp.co.intra_mart.framework.base.event.Event, jp.co.intra_mart.framework.base.data.DataAccessController)を実装する必要があります。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean から継承したフィールド
sessionContext
コンストラクタの概要
StandardEJBEventListenerAgentBean()
StandardEJBEventListenerAgentBeanを新規に生成します。
メソッドの概要
void | ejbCreate() ホームインタフェースの引数なしのcreate()メソッドに対応します。
EventResult | execute(Event event) イベント処理を実行します。
protected abstract EventResult | fire(Event event, DataAccessController dataAccessController) イベントに対する処理です。
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean から継承したメソッド
dispatchEvent, ejbActivate, ejbPassivate, ejbRemove, setSessionContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardEJBEventListenerAgentBean

public StandardEJBEventListenerAgentBean()
StandardEJBEventListenerAgentBeanを新規に生成します。

メソッドの詳細

ejbCreate

public void ejbCreate()
ホームインタフェースの引数なしのcreate()メソッドに対応します。

導入されたバージョン:
3.2

execute

public EventResult execute(Event event)
                    throws ApplicationException,
                           SystemException,
                           EJBException
イベント処理を実行します。 このクラスでは以下のような順番で処理を行います。
  1. イベントトリガの実行(前処理)
  2. イベント処理の実行(fire(Event, DataAccessController))
  3. イベントトリガの実行(後処理)
  4. 簡易トランザクションのコミット(DataAccessController.commit())
このクラスではStandardEventListener.execute(Event)とは違い直接UserTransactionを扱っていません。そのため、このEJBを使うためにはコンテナ管理トランザクション(Container-management Transaction:CMT)を使用してください。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
EJBException - システムレベルのエラー

fire

protected abstract EventResult fire(Event event,
                                    DataAccessController dataAccessController)
                             throws SystemException,
                                    ApplicationException
イベントに対する処理です。

パラメータ:
event - イベント
dataAccessController - データアクセスコントローラ
戻り値:
イベント処理結果
例外:
SystemException - システム例外が発生
ApplicationException - アプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardEJBEventListenerAgentHome (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース StandardEJBEventListenerAgentHome

すべてのスーパーインタフェース:
EJBHome, Remote
public interface StandardEJBEventListenerAgentHome
extends EJBHome

StandardEJBEventListenerAgentのホームインタフェースです。

バージョン:
1.0

メソッドの概要
 StandardEJBEventListenerAgent create()
StandardEJBEventListenerAgentと接続します。
インタフェース javax.ejb.EJBHome から継承したメソッド
getEJBMetaData, getHomeHandle, remove, remove

メソッドの詳細

create

public StandardEJBEventListenerAgent create()
                                     throws RemoteException,
                                            CreateException
StandardEJBEventListenerAgentと接続します。

戻り値:
StandardEJBEventListenerAgent
例外:
RemoteException - システムレベルエラー
CreateException - EJBEventListenerAgent生成時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


StandardEJBEventListenerFactory (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス StandardEJBEventListenerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerFactory
        拡張 jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory
すべての実装インタフェース:
EventListenerFactory
public class StandardEJBEventListenerFactory
extends EJBEventListenerFactory

標準的なEJB用のイベントリスナファクトリです。

バージョン:
1.0

フィールドの概要
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory から継承したフィールド
HOME_PARAM
コンストラクタの概要
StandardEJBEventListenerFactory()
StandardEJBEventListenerFactoryを新規に生成します。
メソッドの概要
EventListener | create(Event event) イベントリスナを生成します。
void | initParam(String name, String value) 初期パラメータを設定します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory から継承したメソッド
getJNDIName, setJNDIName
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardEJBEventListenerFactory

public StandardEJBEventListenerFactory()
StandardEJBEventListenerFactoryを新規に生成します。

メソッドの詳細

create

public EventListener create(Event event)
                     throws EventListenerException
イベントリスナを生成します。

パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

パラメータ:
name - パラメータ名
value - パラメータの値
例外:
EventListenerException - パラメータの設定時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardEventListener (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス StandardEventListener

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.StandardEventListener
すべての実装インタフェース:
EventListener
public abstract class StandardEventListener
extends Object
implements EventListener

汎用的なビジネスロジック用のクラスです。

バージョン:
1.0

コンストラクタの概要
StandardEventListener()
メソッドの概要
protected EventResult | dispatchEvent(Event event) イベント処理を実行します。
EventResult | execute(Event event) 処理を実行します。
protected abstract EventResult | fire(Event event) イベントに対する処理です。
protected Object | getDAO(String application, String key, String connect) DAOを取得します。
protected DataAccessController | getDataAccessController() このイベントリスナで使用するデータアクセスコントローラです。
void | setInTransaction(boolean transaction) このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardEventListener

public StandardEventListener()
メソッドの詳細

getDataAccessController

protected DataAccessController getDataAccessController()
このイベントリスナで使用するデータアクセスコントローラです。 このクラスを継承する場合、メソッドfire(jp.co.intra_mart.framework.base.event.Event)内ではデータアクセスコントローラの取得にはこのメソッドを使うようにしてください。

戻り値:
データアクセスコントローラ

getDAO

protected Object getDAO(String application,
                        String key,
                        String connect)
                 throws DataPropertyException,
                        DataConnectorException,
                        DAOException,
                        DataConnectException
DAOを取得します。 キーと接続情報で指定されたDAOを取得します。

パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAO
例外:
DataPropertyException - プロパティの取得に失敗
DataConnectorException - データコネクタの取得に失敗
DAOException - DAOの取得に失敗
DataConnectException - データリソースとの接続に失敗

execute

public EventResult execute(Event event)
                    throws SystemException,
                           ApplicationException
処理を実行します。 このクラスでは以下のような順番で処理を行います。
  1. ユーザトランザクションの開始
  2. イベントトリガの実行(前処理)
  3. イベント処理の実行(fire(jp.co.intra_mart.framework.base.event.Event))
  4. イベントトリガの実行(後処理)
  5. 簡易トランザクションのコミット(DataAccessController.commit())
  6. ユーザトランザクションのコミット

定義:
インタフェース EventListener 内の execute
パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生

fire

protected abstract EventResult fire(Event event)
                             throws SystemException,
                                    ApplicationException
イベントに対する処理です。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
SystemException - システム例外が発生
ApplicationException - アプリケーション例外が発生

setInTransaction

public void setInTransaction(boolean transaction)
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。

定義:
インタフェース EventListener 内の setInTransaction
パラメータ:
transaction - トランザクションの中で実行されている場合：true、そうでない場合：false
導入されたバージョン:
4.2

dispatchEvent

protected EventResult dispatchEvent(Event event)
                             throws EventManagerException,
                                    EventException,
                                    SystemException,
                                    ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventManagerException - イベントマネージャの生成に失敗
EventException - イベント処理実行に失敗
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生
導入されたバージョン:
4.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardEventListenerFactory (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス StandardEventListenerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.StandardEventListenerFactory
すべての実装インタフェース:
EventListenerFactory
public class StandardEventListenerFactory
extends Object
implements EventListenerFactory

通常のJavaクラスのイベントリスナを生成します。 このファクトリで指定できる初期パラメータは以下のとおりです。

パラメータ名 | 値
listener | 生成するイベントリスナ

バージョン:
1.0

コンストラクタの概要
StandardEventListenerFactory()
StandardEventListenerFactoryを新規に生成します。
メソッドの概要
EventListener | create(Event event) イベントリスナを生成します。
void | initParam(String name, String value) 初期パラメータを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardEventListenerFactory

public StandardEventListenerFactory()
StandardEventListenerFactoryを新規に生成します。

メソッドの詳細

create

public EventListener create(Event event)
                     throws EventListenerException
イベントリスナを生成します。 初期パラメータで指定されたクラスをイベントリスナとして生成します。 初期パラメータで指定されたクラスはStandardEventListenerを継承している必要があります。

定義:
インタフェース EventListenerFactory 内の create
パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

定義:
インタフェース EventListenerFactory 内の initParam
パラメータ:
name - パラメータ名
value - パラメータの値
例外:
EventListenerException - パラメータの設定時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TextFileEventPropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス TextFileEventPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler
すべての実装インタフェース:
EventPropertyHandler, PropertyHandler
public class TextFileEventPropertyHandler
extends Object
implements EventPropertyHandler

指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。 ファイルの書式はDefaultEventPropertyHandlerで示されるものと同じです。
ファイルが存在するディレクトリ名はPARAM_FILE_DIRで示されるパラメータ名で指定します。
PARAM_DYNAMICで示されるパラメータにtrueを指定した場合 アプリケーション実行時にもプロパティの変更を動的に反映させることが可能となりますが、 パラメータの取得時に毎回ファイル操作を行うためパフォーマンスに悪影響を与える可能性があります。 このオプションは、開発時やデバッグ時のようにパラメータを頻繁に変更する必要がある場合のみtrueとし、 通常はfalseに設定しておいてください。

導入されたバージョン:
3.2

フィールドの概要
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
コンストラクタの概要
TextFileEventPropertyHandler()
TextFileEventPropertyHandlerを新規に生成します。
メソッドの概要
String | getEventListenerFactoryName(String application, String key) キーに該当するイベントリスナファクトリのクラス名を取得します。
EventListenerFactoryParam[] | getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
String | getEventName(String application, String key) キーに該当するイベントのクラス名を取得します。
Collection | getEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
Collection | getPostEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

TextFileEventPropertyHandler

public TextFileEventPropertyHandler()
TextFileEventPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
プロパティの動的読み込みが可能かどうか調べます。

定義:
インタフェース EventPropertyHandler 内の isDynamic
戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可

getEventName

public String getEventName(String application,
                           String key)
                    throws EventPropertyException
キーに該当するイベントのクラス名を取得します。 該当するイベントが存在しない場合、nullを返します。

定義:
インタフェース EventPropertyHandler 内の getEventName
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントのクラス名
例外:
EventPropertyException - イベントのクラス名の取得に失敗

getEventListenerFactoryName

public String getEventListenerFactoryName(String application,
                                          String key)
                                   throws EventPropertyException
キーに該当するイベントリスナファクトリのクラス名を取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryName
パラメータ:
application - アプリケーション
key - イベントリスナファクトリのキー
戻り値:
イベントリスナファクトリのクラス名
例外:
EventPropertyException - イベントリスナファクトリのクラス名の取得に失敗

getEventListenerFactoryParams

public EventListenerFactoryParam[] getEventListenerFactoryParams(String application,
                                                                 String key)
                                                          throws EventPropertyException
キーに該当するイベントリスナファクトリの初期パラメータを取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryParams
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントリスナファクトリの初期パラメータ
例外:
EventPropertyException - イベントリスナファクトリの初期パラメータの取得に失敗

getEventTriggerInfos

public Collection getEventTriggerInfos(String application,
                                       String key)
                                throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener

getPostEventTriggerInfos

public Collection getPostEventTriggerInfos(String application,
                                           String key)
                                    throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 ここで取得されるイベントトリガはイベントの処理後に実行されます。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getPostEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XmlEventPropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス XmlEventPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler
すべての実装インタフェース:
EventPropertyHandler, PropertyHandler
public class XmlEventPropertyHandler
extends Object
implements EventPropertyHandler

XMLのEventPropertyHandlerです。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「プレフィックス_アプリケーションID.xml」です。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにEventManager.EVENT_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスはDEFAULT_BUNDLE_NAME_PARAMで示されるものです。
プロパティの設定内容は以下のとおりです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのxmlファイルのプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM xmlのパラメータ名
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
コンストラクタの概要
XmlEventPropertyHandler()
DefaultEventPropertyHandlerを新規に生成します。
メソッドの概要
String | getEventListenerFactoryName(String application, String key) アプリケーションIDとキーに該当するイベントリスナファクトリのクラス名を取得します。
EventListenerFactoryParam[] | getEventListenerFactoryParams(String application, String key) アプリケーションIDとキーに該当するイベントリスナファクトリの初期パラメータを取得します。
String | getEventName(String application, String key) アプリケーションIDとキーに該当するイベントのクラス名を取得します。
Collection | getEventTriggerInfos(String application, String key) アプリケーションIDとキーに該当するイベントのイベントトリガ情報をすべて取得します。
Collection | getPostEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのxmlファイルのプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
xmlのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

XmlEventPropertyHandler

public XmlEventPropertyHandler()
DefaultEventPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws EventPropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース EventPropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
EventPropertyException - チェック時に例外が発生

getEventName

public String getEventName(String application,
                           String key)
                    throws EventPropertyException
アプリケーションIDとキーに該当するイベントのクラス名を取得します。 該当するイベントが存在しない場合、nullを返します。

定義:
インタフェース EventPropertyHandler 内の getEventName
パラメータ:
application - アプリケーションID
key - イベントのキー
戻り値:
イベントのクラス名
例外:
EventPropertyException - イベントのクラス名の取得に失敗

getEventListenerFactoryName

public String getEventListenerFactoryName(String application,
                                          String key)
                                   throws EventPropertyException
アプリケーションIDとキーに該当するイベントリスナファクトリのクラス名を取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryName
パラメータ:
application - アプリケーションID
key - イベントリスナファクトリのキー
戻り値:
イベントリスナファクトリのクラス名
例外:
EventPropertyException - イベントリスナファクトリのクラス名の取得に失敗

getEventListenerFactoryParams

public EventListenerFactoryParam[] getEventListenerFactoryParams(String application,
                                                                 String key)
                                                          throws EventPropertyException
アプリケーションIDとキーに該当するイベントリスナファクトリの初期パラメータを取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryParams
パラメータ:
application - アプリケーションID
key - イベントのキー
戻り値:
イベントリスナファクトリの初期パラメータ
例外:
EventPropertyException - イベントリスナファクトリの初期パラメータの取得に失敗

getEventTriggerInfos

public Collection getEventTriggerInfos(String application,
                                       String key)
                                throws EventPropertyException
アプリケーションIDとキーに該当するイベントのイベントトリガ情報をすべて取得します。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getEventTriggerInfos
パラメータ:
application - アプリケーションID
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener

getPostEventTriggerInfos

public Collection getPostEventTriggerInfos(String application,
                                           String key)
                                    throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 ここで取得されるイベントトリガはイベントの処理後に実行されます。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getPostEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler の使用

jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.message.MessageManager の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.message.MessageManager の使用

MessageManager を使用しているパッケージ
jp.co.intra_mart.framework.base.message メッセージフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.message での MessageManager の使用

MessageManager を返す jp.co.intra_mart.framework.base.message のメソッド
static MessageManager MessageManager.getMessageManager()
メッセージマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.message.MessageManagerException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.message.MessageManagerException の使用

MessageManagerException を使用しているパッケージ
jp.co.intra_mart.framework.base.message メッセージフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.message での MessageManagerException の使用

MessageManagerException をスローする jp.co.intra_mart.framework.base.message のメソッド
static MessageManager MessageManager.getMessageManager()
メッセージマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.message.MessagePropertyException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.message.MessagePropertyException の使用

MessagePropertyException を使用しているパッケージ
jp.co.intra_mart.framework.base.message メッセージフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.message での MessagePropertyException の使用

MessagePropertyException をスローする jp.co.intra_mart.framework.base.message のメソッド
boolean | TextFileMessagePropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | TextFileMessagePropertyHandler.getMessage(String application, String key) メッセージを取得します。
String | TextFileMessagePropertyHandler.getMessage(String application, String key, Locale locale) メッセージを取得します。
boolean | MessagePropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | MessagePropertyHandler.getMessage(String application, String key) メッセージを取得します。
String | MessagePropertyHandler.getMessage(String application, String key, Locale locale) メッセージを取得します。
boolean | DefaultMessagePropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | DefaultMessagePropertyHandler.getMessage(String application, String key) メッセージを取得します。
String | DefaultMessagePropertyHandler.getMessage(String application, String key, Locale locale) メッセージを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.message.MessagePropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.message.MessagePropertyHandler の使用

MessagePropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.base.message メッセージフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.message での MessagePropertyHandler の使用

MessagePropertyHandler を実装している jp.co.intra_mart.framework.base.message のクラス
class | DefaultMessagePropertyHandler メッセージの設定情報に接続するデフォルトのプロパティハンドラです。
class | TextFileMessagePropertyHandler 指定されたファイルからプロパティ情報を取得するメッセージプロパティハンドラです。

MessagePropertyHandler を返す jp.co.intra_mart.framework.base.message のメソッド
 MessagePropertyHandler MessageManager.getMessagePropertyHandler()
メッセージプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler の使用

jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DefaultMessagePropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.message
クラス DefaultMessagePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler
すべての実装インタフェース:
MessagePropertyHandler, PropertyHandler
public class DefaultMessagePropertyHandler
extends Object
implements MessagePropertyHandler

メッセージの設定情報に接続するデフォルトのプロパティハンドラです。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「プレフィックス_アプリケーションID[_ロケール].properties」です。
_ロケールを追加することによってロケールごとにメッセージを変更することも可能です。ロケールによるプロパティファイルの優先順位はJavaTMのjava.util.ResourceBundleと同様のルールに従って決定されます。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにMessageManager.MESSAGE_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスはDEFAULT_BUNDLE_NAME_PARAMで示されるものです。

プロパティの内容は「キー=メッセージ」の形式で指定します。

導入されたバージョン:
4.2

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
コンストラクタの概要
DefaultMessagePropertyHandler()
DefaultMessagePropertyHandlerを新規に生成します。
メソッドの概要
String | getMessage(String application, String key) メッセージを取得します。
String | getMessage(String application, String key, Locale locale) メッセージを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultMessagePropertyHandler

public DefaultMessagePropertyHandler()
DefaultMessagePropertyHandlerを新規に生成します。

メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws MessagePropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース MessagePropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
MessagePropertyException - チェック時に例外が発生

getMessage

public String getMessage(String application,
                         String key)
                  throws MessagePropertyException
メッセージを取得します。 applicationで指定されるアプリケーション固有のプロパティから keyに該当するメッセージを取得します。 システムが稼動しているロケールをヒントにメッセージを取得します。

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
application - アプリケーションID
key - メッセージのキー
戻り値:
メッセージ
例外:
MessagePropertyException - メッセージ取得時に例外が発生

getMessage

public String getMessage(String application,
                         String key,
                         Locale locale)
                  throws MessagePropertyException
メッセージを取得します。 applicationで指定されるアプリケーション固有のプロパティから keyに該当するメッセージを取得します。 localeで指定されたロケールをヒントにメッセージを取得します。

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
application - アプリケーションID
key - メッセージのキー
locale - ロケール
戻り値:
メッセージ
例外:
MessagePropertyException - メッセージ取得時に例外が発生

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MessageManager (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.message
クラス MessageManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.message.MessageManager
public class MessageManager
extends Object

メッセージマネージャです。

導入されたバージョン:
4.2

フィールドの概要
static String MESSAGE_PROPERTY_HANDLER_KEY
メッセージプロパティハンドラのキー
メソッドの概要
String | getMessage(String application, String key, Object[] args) ロケールを指定せず、キーに該当するメッセージを取得します。
String | getMessage(String application, String key, Object[] args, Locale locale) ロケールを指定し、キーに該当するメッセージを取得します。
static MessageManager | getMessageManager() メッセージマネージャを取得します。
MessagePropertyHandler | getMessagePropertyHandler() メッセージプロパティハンドラを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

MESSAGE_PROPERTY_HANDLER_KEY

public static final String MESSAGE_PROPERTY_HANDLER_KEY
メッセージプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getMessageManager

public static MessageManager getMessageManager()
                                        throws MessageManagerException
メッセージマネージャを取得します。

戻り値:
メッセージマネージャ
例外:
MessageManagerException - メッセージマネージャの生成に失敗した

getMessage

public String getMessage(String application,
                         String key,
                         Object[] args)
ロケールを指定せず、キーに該当するメッセージを取得します。 このメソッドはgetMessage(application, key, args, java.util.Locale.getDefault())を呼んだときと同じ動作をします。

パラメータ:
application - アプリケーションID
key - キー
args - メッセージに設定するパラメータ
戻り値:
メッセージ（存在しない場合???key???）

getMessage

public String getMessage(String application,
                         String key,
                         Object[] args,
                         Locale locale)
ロケールを指定し、キーに該当するメッセージを取得します。 指定されたアプリケーションID、キー、ロケールに一致するメッセージをプロパティから取得し、 パラメータをメッセージ内部に埋め込んだ結果を返します。

このメソッドでは内部で以下のような動作をします。
  1. getMessagePropertyHandler()を呼び、MessagePropertyHandlerを取得する。
  2. MessagePropertyHandler.getMessage(application, key, locale)を呼び、メッセージを取得する。
  3. new java.text.MessageFormat(上で取得したメッセージ).format(args)を呼び、パラメータを埋め込んだメッセージを返す。

パラメータ:
application - アプリケーションID
key - キー
args - メッセージに設定するパラメータ
locale - ロケール
戻り値:
メッセージ（存在しない場合???key???）

getMessagePropertyHandler

public MessagePropertyHandler getMessagePropertyHandler()
メッセージプロパティハンドラを取得します。

戻り値:
メッセージプロパティハンドラ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MessageManagerException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.message
クラス MessageManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.message.MessageManagerException
すべての実装インタフェース:
Serializable
public class MessageManagerException
extends SystemException

サービスマネージャ設定時の例外です。

導入されたバージョン:
4.2
関連項目:
直列化された形式

コンストラクタの概要
MessageManagerException()
詳細メッセージを指定しないで MessageManagerException を構築します。
MessageManagerException(String msg)
指定された詳細メッセージを持つ MessageManagerException を構築します。
MessageManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessageManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MessageManagerException

public MessageManagerException()
詳細メッセージを指定しないで MessageManagerException を構築します。

MessageManagerException

public MessageManagerException(String msg)
指定された詳細メッセージを持つ MessageManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

MessageManagerException

public MessageManagerException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessageManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MessagePropertyException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.message
クラス MessagePropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.message.MessagePropertyException
すべての実装インタフェース:
Serializable
public class MessagePropertyException
extends SystemException

メッセージプロパティ取得時の例外です。 * @author INTRAMART

導入されたバージョン:
4.2
関連項目:
直列化された形式

コンストラクタの概要
MessagePropertyException()
詳細メッセージを指定しないで MessagePropertyException を構築します。
MessagePropertyException(String msg)
指定された詳細メッセージを持つ MessagePropertyException を構築します。
MessagePropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessagePropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MessagePropertyException

public MessagePropertyException()
詳細メッセージを指定しないで MessagePropertyException を構築します。

MessagePropertyException

public MessagePropertyException(String msg)
指定された詳細メッセージを持つ MessagePropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

MessagePropertyException

public MessagePropertyException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessagePropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MessagePropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.message
インタフェース MessagePropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultMessagePropertyHandler, TextFileMessagePropertyHandler
public interface MessagePropertyHandler
extends PropertyHandler

メッセージの設定情報に接続するクラスです。

導入されたバージョン:
4.2

メソッドの概要
String | getMessage(String application, String key) メッセージを取得します。
String | getMessage(String application, String key, Locale locale) メッセージを取得します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws MessagePropertyException
プロパティの動的読み込みが可能かどうか調べます。

戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可
例外:
MessagePropertyException - チェック時に例外が発生

getMessage

public String getMessage(String application,
                         String key)
                  throws MessagePropertyException
メッセージを取得します。 applicationで指定されるアプリケーション固有のプロパティから keyに該当するメッセージを取得します。 システムが稼動しているロケールをヒントにメッセージを取得します。

パラメータ:
application - アプリケーションID
key - メッセージのキー
戻り値:
メッセージ
例外:
MessagePropertyException - メッセージ取得時に例外が発生

getMessage

public String getMessage(String application,
                         String key,
                         Locale locale)
                  throws MessagePropertyException
メッセージを取得します。 applicationで指定されるアプリケーション固有のプロパティから keyに該当するメッセージを取得します。 localeで指定されるロケールをヒントにメッセージを取得します。

パラメータ:
application - アプリケーションID
key - メッセージのキー
locale - ロケール
戻り値:
メッセージ
例外:
MessagePropertyException - メッセージ取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.message (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.base.message
インタフェース
MessagePropertyHandler
クラス
DefaultMessagePropertyHandler
MessageManager
TextFileMessagePropertyHandler
例外
MessageManagerException
MessagePropertyException


jp.co.intra_mart.framework.base.message (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.message

メッセージフレームワークに関連するクラスのパッケージです。

参照:
説明

インタフェースの概要
MessagePropertyHandler メッセージの設定情報に接続するクラスです。

クラスの概要
DefaultMessagePropertyHandler | メッセージの設定情報に接続するデフォルトのプロパティハンドラです。
MessageManager | メッセージマネージャです。
TextFileMessagePropertyHandler | 指定されたファイルからプロパティ情報を取得するメッセージプロパティハンドラです。

例外の概要
MessageManagerException | サービスマネージャ設定時の例外です。
MessagePropertyException | メッセージプロパティ取得時の例外です。

パッケージ jp.co.intra_mart.framework.base.message の説明

メッセージフレームワークに関連するクラスのパッケージです。 国際化対応したメッセージを取得します。


jp.co.intra_mart.framework.base.message クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.message の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler (implements jp.co.intra_mart.framework.base.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.base.message.MessageManager
    • class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler (implements jp.co.intra_mart.framework.base.message.MessagePropertyHandler)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.message.MessageManagerException
            • class jp.co.intra_mart.framework.base.message.MessagePropertyException

インタフェース階層

  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.base.message.MessagePropertyHandler


パッケージ jp.co.intra_mart.framework.base.message の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.message の使用

jp.co.intra_mart.framework.base.message を使用しているパッケージ
jp.co.intra_mart.framework.base.message メッセージフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.message により使用される jp.co.intra_mart.framework.base.message のクラス
MessageManager
メッセージマネージャです。
MessageManagerException
サービスマネージャ設定時の例外です。
MessagePropertyException
メッセージプロパティ取得時の例外です。
MessagePropertyHandler
メッセージの設定情報に接続するクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


TextFileMessagePropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.message
クラス TextFileMessagePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler
すべての実装インタフェース:
MessagePropertyHandler, PropertyHandler
public class TextFileMessagePropertyHandler
extends Object
implements MessagePropertyHandler

指定されたファイルからプロパティ情報を取得するメッセージプロパティハンドラです。 ファイルの書式はDefaultMessagePropertyHandlerで示されるものと同じです。
ファイルが存在するディレクトリ名はPARAM_FILE_DIRで示されるパラメータ名で指定します。
PARAM_DYNAMICで示されるパラメータにtrueを指定した場合 アプリケーション実行時にもプロパティの変更を動的に反映させることが可能となりますが、 パラメータの取得時に毎回ファイル操作を行うためパフォーマンスに悪影響を与える可能性があります。 このオプションは、開発時やデバッグ時のようにパラメータを頻繁に変更する必要がある場合のみtrueとし、 通常はfalseに設定しておいてください。

導入されたバージョン:
4.2

フィールドの概要
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
コンストラクタの概要
TextFileMessagePropertyHandler()
メソッドの概要
String | getMessage(String application, String key) メッセージを取得します。
String | getMessage(String application, String key, Locale locale) メッセージを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

TextFileMessagePropertyHandler

public TextFileMessagePropertyHandler()
メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws MessagePropertyException
プロパティの動的読み込みが可能かどうか調べます。

定義:
インタフェース MessagePropertyHandler 内の isDynamic
戻り値:
true 再設定可能、false 再設定不可
例外:
MessagePropertyException - チェック時に例外が発生

getMessage

public String getMessage(String application,
                         String key)
                  throws MessagePropertyException
メッセージを取得します。 applicationで指定されるアプリケーション固有のプロパティから keyに該当するメッセージを取得します。 システムが稼動しているロケールをヒントにメッセージを取得します。

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
application - アプリケーションID
key - メッセージのキー
戻り値:
メッセージ
例外:
MessagePropertyException - メッセージ取得時に例外が発生

getMessage

public String getMessage(String application,
                         String key,
                         Locale locale)
                  throws MessagePropertyException
メッセージを取得します。 applicationで指定されるアプリケーション固有のプロパティから keyに該当するメッセージを取得します。 localeで指定されたロケールをヒントにメッセージを取得します。

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
application - アプリケーションID
key - メッセージのキー
locale - ロケール
戻り値:
メッセージ
例外:
MessagePropertyException - メッセージ取得時に例外が発生

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.base.service.ControllerConverterModel の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ControllerConverterModel の使用

jp.co.intra_mart.framework.base.service.ControllerConverterModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler の使用

jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.DefaultTransition の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.DefaultTransition の使用

jp.co.intra_mart.framework.base.service.DefaultTransition はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の使用

jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.EmptyServiceResult の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.EmptyServiceResult の使用

jp.co.intra_mart.framework.base.service.EmptyServiceResult はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.EncodingFilter の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.EncodingFilter の使用

jp.co.intra_mart.framework.base.service.EncodingFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.FileUploadFilter の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.FileUploadFilter の使用

jp.co.intra_mart.framework.base.service.FileUploadFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter の使用

jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.IntramartConnectFilter の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.IntramartConnectFilter の使用

jp.co.intra_mart.framework.base.service.IntramartConnectFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.IntramartConnectServlet の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.IntramartConnectServlet の使用

jp.co.intra_mart.framework.base.service.IntramartConnectServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.IntramartLocaleFilter の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.IntramartLocaleFilter の使用

jp.co.intra_mart.framework.base.service.IntramartLocaleFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition の使用

jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.LocaleFilter の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.LocaleFilter の使用

jp.co.intra_mart.framework.base.service.LocaleFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.RequestException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.RequestException の使用

RequestException を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.validator | 検証に関連するパッケージです。

jp.co.intra_mart.framework.base.service での RequestException の使用

RequestException 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
abstract String | Transition.getInputErrorPage(RequestException e) 入力エラーのページを取得します。
String | IntramartPageBaseTransition.getInputErrorPage(RequestException e) 入力エラーのページを取得します。
String | DefaultTransition.getInputErrorPage(RequestException e) 入力エラーのページを取得します。

RequestException をスローする jp.co.intra_mart.framework.base.service のメソッド
void | ServiceControllerAdapter.check() 入力内容をチェックします。
void | ServiceController.check() 入力内容をチェックします。

jp.co.intra_mart.framework.base.service.validator での RequestException の使用

jp.co.intra_mart.framework.base.service.validator での RequestException のサブクラス
 class ValidationException
検証結果が不正であるときの例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.service.RequestInfo の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.RequestInfo の使用

RequestInfo を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.controller | 入力情報に関連するパッケージです。
jp.co.intra_mart.framework.base.service.validator | 検証に関連するパッケージです。

jp.co.intra_mart.framework.base.service での RequestInfo の使用

RequestInfo 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
 ControllerObject ServiceManager.getControllerObject(String application, String service, Locale locale, RequestInfo info)
コントーラオブジェクトを取得します。

jp.co.intra_mart.framework.base.service.controller での RequestInfo の使用

RequestInfo 型のパラメータを持つ jp.co.intra_mart.framework.base.service.controller のメソッド
ControllerObject | SimpleControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
ControllerObject | ControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。

jp.co.intra_mart.framework.base.service.validator での RequestInfo の使用

RequestInfo 型のパラメータを持つ jp.co.intra_mart.framework.base.service.validator のメソッド
ValidationExceptionDetail | Validator.validate(RequestInfo info) リクエスト内容の検証をします。
ValidationExceptionDetail | NumericValidator.validate(RequestInfo info) 数値の検証をします。
ValidationExceptionDetail | NumericRangeValidator.validate(RequestInfo info) 数値の範囲を検証します。
ValidationExceptionDetail | LengthValidator.validate(RequestInfo info) 文字列の長さを検証します。
ValidationExceptionDetail | FormatValidator.validate(RequestInfo info) 文字列の不正文字（フォーマット）を検証します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.service.ServiceController の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.ServiceController の使用

ServiceController を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.container |

jp.co.intra_mart.framework.base.service での ServiceController の使用

ServiceController を実装している jp.co.intra_mart.framework.base.service のクラス
 class ServiceControllerAdapter
いくつかのユーティリティメソッドと空のメソッドを実装したサービスコントローラです。

ServiceController を返す jp.co.intra_mart.framework.base.service のメソッド
 ServiceController ServiceManager.getServiceController(String application, String service)
推奨されていません。 このメソッドではなくServiceManager.getServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
 ServiceController ServiceManager.getServiceController(String application, String service, Locale locale)
サービスコントローラを取得します。

jp.co.intra_mart.framework.base.service.container での ServiceController の使用

ServiceController を返す jp.co.intra_mart.framework.base.service.container のメソッド
ServiceController | ServiceContainerImpl.getServiceController(String application, String service, Locale locale) サービスコントローラを取得します。
ServiceController | ServiceContainer.getServiceController(String application, String service, Locale locale) サービスコントローラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ServiceControllerAdapter の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceControllerAdapter の使用

jp.co.intra_mart.framework.base.service.ServiceControllerAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ServiceControllerException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceControllerException の使用

ServiceControllerException を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.container |

jp.co.intra_mart.framework.base.service での ServiceControllerException の使用

ServiceControllerException をスローする jp.co.intra_mart.framework.base.service のメソッド
 ServiceController ServiceManager.getServiceController(String application, String service)
推奨されていません。 このメソッドではなくServiceManager.getServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
 ServiceController ServiceManager.getServiceController(String application, String service, Locale locale)
サービスコントローラを取得します。
 String ServiceControllerAdapter.getLoginUserID()
推奨されていません。 このメソッドではなくServiceControllerAdapter.getUserInfo()を使用してください。
 String ServiceControllerAdapter.getLoginGroupID()
推奨されていません。 このメソッドではなくServiceControllerAdapter.getUserInfo()を使用してください。
 UserInfo ServiceControllerAdapter.getUserInfo()
ユーザ情報を取得します。
protected  Event ServiceControllerAdapter.createEvent(String application, String key)
アプリケーションIDとキーに対応するイベントを取得します。

jp.co.intra_mart.framework.base.service.container での ServiceControllerException の使用

ServiceControllerException をスローする jp.co.intra_mart.framework.base.service.container のメソッド
ServiceController | ServiceContainerImpl.getServiceController(String application, String service, Locale locale) サービスコントローラを取得します。
ServiceController | ServiceContainer.getServiceController(String application, String service, Locale locale) サービスコントローラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ServiceManager の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceManager の使用

ServiceManager を使用しているパッケージ
jp.co.intra_mart.framework.base.service サービスフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での ServiceManager の使用

ServiceManager を返す jp.co.intra_mart.framework.base.service のメソッド
protected ServiceManager | Transition.getServiceManager() サービスマネージャを取得します。
static ServiceManager | ServiceManager.getServiceManager() サービスマネージャを取得します。
protected ServiceManager | IntramartConnectServlet.getServiceManager() 推奨されていません。 サービスマネージャを取得します。

ServiceManager 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
protected  void Transition.setServiceManager(ServiceManager manager)
サービスマネージャを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ServiceManagerException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceManagerException の使用

ServiceManagerException を使用しているパッケージ
jp.co.intra_mart.framework.base.service サービスフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での ServiceManagerException の使用

ServiceManagerException をスローする jp.co.intra_mart.framework.base.service のメソッド
static ServiceManager | ServiceManager.getServiceManager() サービスマネージャを取得します。
String | ServiceManager.getExtesion() サービスフレームワークを呼び出すための拡張子を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ServicePropertyException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServicePropertyException の使用

ServicePropertyException を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.container |

jp.co.intra_mart.framework.base.service での ServicePropertyException の使用

ServicePropertyException をスローする jp.co.intra_mart.framework.base.service のメソッド
 boolean XmlServicePropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String XmlServicePropertyHandler.getClientEncoding()
クライアントのエンコードを取得します。
 Locale XmlServicePropertyHandler.getClientLocale()
クライアントのエンコードを取得します。
 String XmlServicePropertyHandler.getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
 String XmlServicePropertyHandler.getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getInputErrorPagePath()
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
 String XmlServicePropertyHandler.getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String XmlServicePropertyHandler.getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String XmlServicePropertyHandler.getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String XmlServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
 String XmlServicePropertyHandler.getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getServiceErrorPagePath()
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
 String XmlServicePropertyHandler.getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
 String XmlServicePropertyHandler.getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getSystemErrorPagePath()
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
 String XmlServicePropertyHandler.getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getTransitionName(String application, String service)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 String XmlServicePropertyHandler.getControllerConverterName(String application, String service, Locale locale)
コントローラコンバータのクラス名を取得します。
 ControllerConverterConfig XmlServicePropertyHandler.getControllerConverterConfig(String application, String service, Locale locale)
キーに該当するコントローラコンバータの初期パラメータを取得します。
 ValidatorMapping[] XmlServicePropertyHandler.getValidators(String application, String service, Locale locale)
キーに該当するバリデータを取得します。
 String XmlServicePropertyHandler.getServiceServletPath()
サービスサーブレットのパスを取得します。
 String XmlServicePropertyHandler.getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String XmlServicePropertyHandler.getApplicationParamName()
推奨されていません。 この実装は廃止されました。
 String XmlServicePropertyHandler.getServiceParamName()
推奨されていません。 この実装は廃止されました。
 String XmlServicePropertyHandler.getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String XmlServicePropertyHandler.getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String XmlServicePropertyHandler.getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
protected  String Transition.getNextPagePath()
このトランジションに設定されているアプリケーションIDとサービスIDに該当する次ページのパスを取得します。
protected  String Transition.getNextPagePath(String key)
このトランジションに設定されているアプリケーションIDとサービスIDと、指定されたキーに該当する次ページのパスを取得します。
abstract  String Transition.getInputErrorPage(RequestException e)
入力エラーのページを取得します。
abstract  String Transition.getSystemErrorPage(Exception e)
システムエラーのページを取得します。
abstract  String Transition.getServiceErrorPage(Exception e)
処理エラーのページを取得します。
abstract  String Transition.getNextPage()
次に遷移するページを取得します。
 String TextFileServicePropertyHandler.getClientEncoding()
クライアントのエンコードを取得します。
 Locale TextFileServicePropertyHandler.getClientLocale()
クライアントのロケールを取得します。
 String TextFileServicePropertyHandler.getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getNextPagePath(String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String TextFileServicePropertyHandler.getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getNextPagePath(String, String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String TextFileServicePropertyHandler.getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getInputErrorPagePath()
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
 String TextFileServicePropertyHandler.getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getServiceErrorPagePath()
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(Locale)を使用してください。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getSystemErrorPagePath()
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceControllerName(String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String TextFileServicePropertyHandler.getTransitionName(String application, String service)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getTransitionName(String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 String TextFileServicePropertyHandler.getServiceServletPath()
サービスサーブレットのパスを取得します。
 String TextFileServicePropertyHandler.getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String TextFileServicePropertyHandler.getApplicationParamName()
推奨されていません。 この実装は廃止されました。
 String TextFileServicePropertyHandler.getServiceParamName()
推奨されていません。 この実装は廃止されました。
 String TextFileServicePropertyHandler.getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String TextFileServicePropertyHandler.getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String TextFileServicePropertyHandler.getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 String TextFileServicePropertyHandler.getControllerConverterName(String application, String service, Locale locale)
 ControllerConverterConfig TextFileServicePropertyHandler.getControllerConverterConfig(String application, String service, Locale locale)
 ValidatorMapping[] TextFileServicePropertyHandler.getValidators(String application, String service, Locale locale)
 boolean ServicePropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String ServicePropertyHandler.getClientEncoding()
クライアントのエンコードを取得します。
 String ServicePropertyHandler.getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 Locale ServicePropertyHandler.getClientLocale()
クライアントのロケールを取得します。
 String ServicePropertyHandler.getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 String ServicePropertyHandler.getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなくServicePropertyHandler.getNextPagePath(String, String, Locale)を使用してください。
 String ServicePropertyHandler.getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String ServicePropertyHandler.getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくServicePropertyHandler.getNextPagePath(String, String, String, Locale)を使用してください。
 String ServicePropertyHandler.getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String ServicePropertyHandler.getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale)を使用してください。
 String ServicePropertyHandler.getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String ServicePropertyHandler.getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, String, Locale)を使用してください。
 String ServicePropertyHandler.getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String ServicePropertyHandler.getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, Locale)を使用してください。
 String ServicePropertyHandler.getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String ServicePropertyHandler.getInputErrorPagePath()
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
 String ServicePropertyHandler.getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String ServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale)を使用してください。
 String ServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String ServicePropertyHandler.getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, String, Locale)を使用してください。
 String ServicePropertyHandler.getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String ServicePropertyHandler.getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, Locale)を使用してください。
 String ServicePropertyHandler.getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String ServicePropertyHandler.getServiceErrorPagePath()
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(Locale)を使用してください。
 String ServicePropertyHandler.getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String ServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale)を使用してください。
 String ServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String ServicePropertyHandler.getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, String, Locale)を使用してください。
 String ServicePropertyHandler.getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String ServicePropertyHandler.getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, Locale)を使用してください。
 String ServicePropertyHandler.getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String ServicePropertyHandler.getSystemErrorPagePath()
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
 String ServicePropertyHandler.getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String ServicePropertyHandler.getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceControllerName(String, String, Locale)を使用してください。
 String ServicePropertyHandler.getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String ServicePropertyHandler.getTransitionName(String application, String service)
推奨されていません。 このメソッドではなくServicePropertyHandler.getTransitionName(String, String, Locale)を使用してください。
 String ServicePropertyHandler.getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 String ServicePropertyHandler.getControllerConverterName(String application, String service, Locale locale)
コントローラコンバータのクラス名を取得します。
 ControllerConverterConfig ServicePropertyHandler.getControllerConverterConfig(String application, String service, Locale locale)
キーに該当するコントローラコンバータの初期パラメータを取得します。
 ValidatorMapping[] ServicePropertyHandler.getValidators(String application, String service, Locale locale)
キーに該当するバリデータを取得します。
 String ServicePropertyHandler.getServiceServletPath()
推奨されていません。 この実装は廃止されました。
 String ServicePropertyHandler.getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String ServicePropertyHandler.getApplicationParamName()
推奨されていません。 この実装は廃止されました。
 String ServicePropertyHandler.getServiceParamName()
推奨されていません。 この実装は廃止されました。
 String ServicePropertyHandler.getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 ServiceController ServiceManager.getServiceController(String application, String service)
推奨されていません。 このメソッドではなくServiceManager.getServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
 ServiceController ServiceManager.getServiceController(String application, String service, Locale locale)
サービスコントローラを取得します。
 Transition ServiceManager.getTransition(String application, String service)
推奨されていません。 このメソッドではなくServiceManager.getTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
 Transition ServiceManager.getTransition(String application, String service, Locale locale)
トランジションを取得します。
 ControllerObject ServiceManager.getControllerObject(String application, String service, Locale locale, RequestInfo info)
コントーラオブジェクトを取得します。
 ValidatorMapping[] ServiceManager.getValidatorMapping(String application, String service, Locale locale)
バリデータを取得します。
 String ServiceManager.getApplication(HttpServletRequest request, HttpServletResponse response)
現在のリクエストに対するアプリケーションIDを取得します。
 String ServiceManager.getService(HttpServletRequest request, HttpServletResponse response)
現在のリクエストに対するサービスIDを取得します。
 Locale ServiceManager.getLocale(HttpServletRequest request, HttpServletResponse response)
現在のリクエストに対するロケールを取得します。
 String ServiceManager.getEncoding(HttpServletRequest request, HttpServletResponse response)
現在のリクエストに対するエンコーディングを取得します。
 String IntramartPageBaseTransition.getInputErrorPage(RequestException e)
入力エラーのページを取得します。
 String IntramartPageBaseTransition.getServiceErrorPage(Exception e)
処理エラーのページを取得します。
 String IntramartPageBaseTransition.getSystemErrorPage(Exception e)
システムエラーのページを取得します。
 String IntramartPageBaseTransition.getNextPage()
次に遷移するページを取得します。
 boolean DistributesServicePropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String DistributesServicePropertyHandler.getClientEncoding()
クライアントのエンコードを取得します。
 Locale DistributesServicePropertyHandler.getClientLocale()
クライアントのエンコードを取得します。
 String DistributesServicePropertyHandler.getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getInputErrorPagePath()
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
 String DistributesServicePropertyHandler.getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String DistributesServicePropertyHandler.getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String DistributesServicePropertyHandler.getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getServiceErrorPagePath()
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getSystemErrorPagePath()
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getTransitionName(String application, String service)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 String DistributesServicePropertyHandler.getServiceServletPath()
サービスサーブレットのパスを取得します。
 String DistributesServicePropertyHandler.getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String DistributesServicePropertyHandler.getApplicationParamName()
アプリケーションIDに該当するパラメータ名を取得します。
 String DistributesServicePropertyHandler.getServiceParamName()
サービスIDに該当するパラメータ名を取得します。
 String DistributesServicePropertyHandler.getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String DistributesServicePropertyHandler.getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String DistributesServicePropertyHandler.getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 String DistributesServicePropertyHandler.getControllerConverterName(String application, String service, Locale locale)
 ControllerConverterConfig DistributesServicePropertyHandler.getControllerConverterConfig(String application, String service, Locale locale)
 ValidatorMapping[] DistributesServicePropertyHandler.getValidators(String application, String service, Locale locale)
 String DefaultTransition.getInputErrorPage(RequestException e)
入力エラーのページを取得します。
 String DefaultTransition.getSystemErrorPage(Exception e)
システムエラーのページを取得します。
 String DefaultTransition.getServiceErrorPage(Exception e)
処理エラーのページを取得します。
 String DefaultTransition.getNextPage()
次に遷移するページを取得します。
 boolean DefaultServicePropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String DefaultServicePropertyHandler.getClientEncoding()
クライアントのエンコードを取得します。
 Locale DefaultServicePropertyHandler.getClientLocale()
クライアントのエンコードを取得します。
 String DefaultServicePropertyHandler.getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getInputErrorPagePath()
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
 String DefaultServicePropertyHandler.getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String DefaultServicePropertyHandler.getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String DefaultServicePropertyHandler.getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getServiceErrorPagePath()
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getSystemErrorPagePath()
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getTransitionName(String application, String service)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 String DefaultServicePropertyHandler.getServiceServletPath()
サービスサーブレットのパスを取得します。
 String DefaultServicePropertyHandler.getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String DefaultServicePropertyHandler.getApplicationParamName()
推奨されていません。 この実装は廃止されました。
 String DefaultServicePropertyHandler.getServiceParamName()
推奨されていません。 この実装は廃止されました。
 String DefaultServicePropertyHandler.getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String DefaultServicePropertyHandler.getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String DefaultServicePropertyHandler.getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 String DefaultServicePropertyHandler.getControllerConverterName(String application, String service, Locale locale)
 ControllerConverterConfig DefaultServicePropertyHandler.getControllerConverterConfig(String application, String service, Locale locale)
 ValidatorMapping[] DefaultServicePropertyHandler.getValidators(String application, String service, Locale locale)

jp.co.intra_mart.framework.base.service.container での ServicePropertyException の使用

ServicePropertyException をスローする jp.co.intra_mart.framework.base.service.container のメソッド
ServiceController | ServiceContainerImpl.getServiceController(String application, String service, Locale locale) サービスコントローラを取得します。
Transition | ServiceContainerImpl.getTransition(String application, String service, Locale locale) トランジションを取得します。
ServiceController | ServiceContainer.getServiceController(String application, String service, Locale locale) サービスコントローラを取得します。
Transition | ServiceContainer.getTransition(String application, String service, Locale locale) トランジションを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.service.ServicePropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.ServicePropertyHandler の使用

ServicePropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.container |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での ServicePropertyHandler の使用

ServicePropertyHandler を実装している jp.co.intra_mart.framework.base.service のクラス
class | DefaultServicePropertyHandler サービスの設定情報に接続するデフォルトのプロパティハンドラです。
class | DistributesServicePropertyHandler アプリケーションごとに異なるサービスプロパティハンドラを使用するサービスプロパティハンドラです。
class | TextFileServicePropertyHandler 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
class | XmlServicePropertyHandler サービスの設定情報に接続するプロパティハンドラです。

ServicePropertyHandler を返す jp.co.intra_mart.framework.base.service のメソッド
ServicePropertyHandler | ServiceManager.getServicePropertyHandler() サービスプロパティハンドラを取得します。
protected ServicePropertyHandler | IntramartConnectServlet.getServicePropertyHandler() 推奨されていません。 サービスプロパティハンドラを取得します。

jp.co.intra_mart.framework.base.service.container での ServicePropertyHandler の使用

ServicePropertyHandler を返す jp.co.intra_mart.framework.base.service.container のメソッド
ServicePropertyHandler | ServiceContainerImpl.getServicePropertyHandler() サービスプロパティハンドラを取得します。
ServicePropertyHandler | ServiceContainer.getServicePropertyHandler() サービスプロパティハンドラを取得します。

jp.co.intra_mart.framework.base.web.bean での ServicePropertyHandler の使用

ServicePropertyHandler を返す jp.co.intra_mart.framework.base.web.bean のメソッド
 ServicePropertyHandler HelperBean.getServicePropertyHandler()
サービスプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.service.ServiceResult の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.ServiceResult の使用

ServiceResult を使用しているパッケージ
jp.co.intra_mart.framework.base.service サービスフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での ServiceResult の使用

ServiceResult を実装している jp.co.intra_mart.framework.base.service のクラス
 class EmptyServiceResult
情報を何も持たないServiceResultの実装です。

ServiceResult を返す jp.co.intra_mart.framework.base.service のメソッド
ServiceResult | Transition.getResult() サービス処理結果を取得します。
ServiceResult | ServiceControllerAdapter.service() 入力に対する処理を実行します。
ServiceResult | ServiceController.service() 入力に対する処理を実行します。
ServiceResult | RequestInfo.getResult() サービス処理結果を取得します。

ServiceResult 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
 void Transition.setResult(ServiceResult result)
サービス処理結果を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ServiceSecurityFilter の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceSecurityFilter の使用

jp.co.intra_mart.framework.base.service.ServiceSecurityFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ServiceServlet の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceServlet の使用

jp.co.intra_mart.framework.base.service.ServiceServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ServiceServletException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceServletException の使用

jp.co.intra_mart.framework.base.service.ServiceServletException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler の使用

jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.Transition の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.Transition の使用

Transition を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.container |

jp.co.intra_mart.framework.base.service での Transition の使用

jp.co.intra_mart.framework.base.service での Transition のサブクラス
class | DefaultTransition デフォルトの画面遷移をします。
class | IntramartPageBaseTransition ページベースの画面に遷移する場合に使用するトランジションです。

Transition を返す jp.co.intra_mart.framework.base.service のメソッド
 Transition ServiceManager.getTransition(String application, String service)
推奨されていません。 このメソッドではなくServiceManager.getTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
 Transition ServiceManager.getTransition(String application, String service, Locale locale)
トランジションを取得します。

jp.co.intra_mart.framework.base.service.container での Transition の使用

Transition を返す jp.co.intra_mart.framework.base.service.container のメソッド
Transition | ServiceContainerImpl.getTransition(String application, String service, Locale locale) トランジションを取得します。
Transition | ServiceContainer.getTransition(String application, String service, Locale locale) トランジションを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.TransitionException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.TransitionException の使用

TransitionException を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.container |

jp.co.intra_mart.framework.base.service での TransitionException の使用

TransitionException をスローする jp.co.intra_mart.framework.base.service のメソッド
abstract  String Transition.getInputErrorPage(RequestException e)
入力エラーのページを取得します。
abstract  String Transition.getSystemErrorPage(Exception e)
システムエラーのページを取得します。
abstract  String Transition.getServiceErrorPage(Exception e)
処理エラーのページを取得します。
abstract  void Transition.setInformation()
次の遷移先に渡す情報を設定します。
abstract  String Transition.getNextPage()
次に遷移するページを取得します。
 Transition ServiceManager.getTransition(String application, String service)
推奨されていません。 このメソッドではなくServiceManager.getTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
 Transition ServiceManager.getTransition(String application, String service, Locale locale)
トランジションを取得します。
 String IntramartPageBaseTransition.getInputErrorPage(RequestException e)
入力エラーのページを取得します。
 String IntramartPageBaseTransition.getServiceErrorPage(Exception e)
処理エラーのページを取得します。
 String IntramartPageBaseTransition.getSystemErrorPage(Exception e)
システムエラーのページを取得します。
 String IntramartPageBaseTransition.getNextPage()
次に遷移するページを取得します。
 void IntramartPageBaseTransition.setInformation()
次の遷移先に渡す情報を設定します。
 String DefaultTransition.getInputErrorPage(RequestException e)
入力エラーのページを取得します。
 String DefaultTransition.getSystemErrorPage(Exception e)
システムエラーのページを取得します。
 String DefaultTransition.getServiceErrorPage(Exception e)
処理エラーのページを取得します。
 void DefaultTransition.setInformation()
次の遷移先に渡す情報を設定します。
 String DefaultTransition.getNextPage()
次に遷移するページを取得します。

jp.co.intra_mart.framework.base.service.container での TransitionException の使用

TransitionException をスローする jp.co.intra_mart.framework.base.service.container のメソッド
Transition | ServiceContainerImpl.getTransition(String application, String service, Locale locale) トランジションを取得します。
Transition | ServiceContainer.getTransition(String application, String service, Locale locale) トランジションを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ValidatorMapping の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ValidatorMapping の使用

ValidatorMapping を使用しているパッケージ
jp.co.intra_mart.framework.base.service サービスフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での ValidatorMapping の使用

ValidatorMapping を返す jp.co.intra_mart.framework.base.service のメソッド
ValidatorMapping[] | XmlServicePropertyHandler.getValidators(String application, String service, Locale locale) キーに該当するバリデータを取得します。
ValidatorMapping[] | TextFileServicePropertyHandler.getValidators(String application, String service, Locale locale)
ValidatorMapping[] | ServicePropertyHandler.getValidators(String application, String service, Locale locale) キーに該当するバリデータを取得します。
ValidatorMapping[] | ServiceManager.getValidatorMapping(String application, String service, Locale locale) バリデータを取得します。
ValidatorMapping[] | DistributesServicePropertyHandler.getValidators(String application, String service, Locale locale)
ValidatorMapping[] | DefaultServicePropertyHandler.getValidators(String application, String service, Locale locale)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ValidatorModel の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ValidatorModel の使用

jp.co.intra_mart.framework.base.service.ValidatorModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler の使用

jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.service.container.ServiceContainer の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.container.ServiceContainer の使用

ServiceContainer を使用しているパッケージ
jp.co.intra_mart.framework.base.service.container

jp.co.intra_mart.framework.base.service.container での ServiceContainer の使用

ServiceContainer を実装している jp.co.intra_mart.framework.base.service.container のクラス
 class ServiceContainerImpl
ServiceContainerの標準的な実装クラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.container.ServiceContainerException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.container.ServiceContainerException の使用

jp.co.intra_mart.framework.base.service.container.ServiceContainerException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.container.ServiceContainerImpl の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.container.ServiceContainerImpl の使用

jp.co.intra_mart.framework.base.service.container.ServiceContainerImpl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.container.factory.DefaultServiceProvider の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.container.factory.DefaultServiceProvider の使用

jp.co.intra_mart.framework.base.service.container.factory.DefaultServiceProvider はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.container.factory.ServiceContainerFactory の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.container.factory.ServiceContainerFactory の使用

jp.co.intra_mart.framework.base.service.container.factory.ServiceContainerFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DefaultServiceProvider (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.container.factory
クラス DefaultServiceProvider

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.container.factory.DefaultServiceProvider
すべての実装インタフェース:
Provider
public class DefaultServiceProvider
extends Object
implements Provider

標準的なプロバイダーです。
クラスパス上のリソースファイルを取得し、サービスコンテナの実装を決定します。

リソースファイル名 - imartContainer.properties
キー - serviceContainer

キーにはServiceContainerインターフェースの実装クラスをフルパッケージ名で指定してください。

導入されたバージョン:
6.0

コンストラクタの概要
DefaultServiceProvider()
DefaultServiceProviderを新規に生成します。
メソッドの概要
 IMContainer create()
ServiceContainerを生成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DefaultServiceProvider

public DefaultServiceProvider()
DefaultServiceProviderを新規に生成します。

メソッドの詳細

create

public IMContainer create()
                   throws IMContainerException
ServiceContainerを生成します。

定義:
インタフェース Provider 内の create
戻り値:
サービスコンテナ
例外:
IMContainerException - サービスコンテナ生成時に例外が発生。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.service.container.factory (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.base.service.container.factory
クラス
DefaultServiceProvider
ServiceContainerFactory


jp.co.intra_mart.framework.base.service.container.factory (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.service.container.factory

クラスの概要
DefaultServiceProvider | 標準的なプロバイダーです。
ServiceContainerFactory | ServiceContainerのファクトリクラスです。


jp.co.intra_mart.framework.base.service.container.factory クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.service.container.factory の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.service.container.factory.DefaultServiceProvider (implements jp.co.intra_mart.framework.system.container.factory.Provider)
    • class jp.co.intra_mart.framework.base.service.container.factory.ServiceContainerFactory (implements jp.co.intra_mart.framework.system.container.factory.IMContainerFactory)


パッケージ jp.co.intra_mart.framework.base.service.container.factory の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.service.container.factory の使用

jp.co.intra_mart.framework.base.service.container.factory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ServiceContainerFactory (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.container.factory
クラス ServiceContainerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.container.factory.ServiceContainerFactory
すべての実装インタフェース:
IMContainerFactory
public class ServiceContainerFactory
extends Object
implements IMContainerFactory

ServiceContainerのファクトリクラスです。 生成されるサービスコンテナはプロバイダーにより決定されます。

導入されたバージョン:
6.0

フィールドの概要
protected  Provider provider
コンストラクタの概要
ServiceContainerFactory()
メソッドの概要
IMContainer | create() ServiceContainerを生成します。
Provider | getProvider() プロバイダを返します。
void | setProvider(Provider p) プロバイダを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

provider

protected Provider provider
コンストラクタの詳細

ServiceContainerFactory

public ServiceContainerFactory()
メソッドの詳細

create

public IMContainer create()
                   throws IMContainerException
ServiceContainerを生成します。

定義:
インタフェース IMContainerFactory 内の create
戻り値:
サービスコンテナ
例外:
IMContainerException - サービスコンテナ生成時に例外が発生。

getProvider

public Provider getProvider()
プロバイダを返します。

定義:
インタフェース IMContainerFactory 内の getProvider
戻り値:
サービスコンテナのプロバイダ

setProvider

public void setProvider(Provider p)
プロバイダを設定します。

定義:
インタフェース IMContainerFactory 内の setProvider
パラメータ:
p - サービスコンテナのプロバイダ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.service.container (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.base.service.container
インタフェース
ServiceContainer
クラス
ServiceContainerImpl
例外
ServiceContainerException


jp.co.intra_mart.framework.base.service.container (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.service.container

インタフェースの概要
ServiceContainer サービスコンテナのインターフェースです。

クラスの概要
ServiceContainerImpl ServiceContainerの標準的な実装クラスです。

例外の概要
ServiceContainerException サービスコンテナ設定時の例外です。


jp.co.intra_mart.framework.base.service.container クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.service.container の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.service.container.ServiceContainerImpl (implements jp.co.intra_mart.framework.base.service.container.ServiceContainer)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.service.container.ServiceContainerException

インタフェース階層

  • interface jp.co.intra_mart.framework.system.container.IMContainer
    • interface jp.co.intra_mart.framework.base.service.container.ServiceContainer


パッケージ jp.co.intra_mart.framework.base.service.container の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.service.container の使用

jp.co.intra_mart.framework.base.service.container を使用しているパッケージ
jp.co.intra_mart.framework.base.service.container

jp.co.intra_mart.framework.base.service.container により使用される jp.co.intra_mart.framework.base.service.container のクラス
ServiceContainer
サービスコンテナのインターフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ServiceContainer (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.container
インタフェース ServiceContainer

すべてのスーパーインタフェース:
IMContainer
既知の実装クラスの一覧:
ServiceContainerImpl
public interface ServiceContainer
extends IMContainer

サービスコンテナのインターフェースです。
サービスコンテナはServiceManagerの振る舞いを決定します。 ServiceManagerではサービスコンテナを保管し、その挙動はサービスコンテナの実装クラスに依存します。 サービスコンテナの実装は通常ServiceContainerFactoryによって生成されます。

導入されたバージョン:
6.0

フィールドの概要
static String SERVICE_PROPERTY_HANDLER_KEY
サービスプロパティハンドラのキー
メソッドの概要
ServiceController | getServiceController(String application, String service, Locale locale) サービスコントローラを取得します。
ServicePropertyHandler | getServicePropertyHandler() サービスプロパティハンドラを取得します。
Transition | getTransition(String application, String service, Locale locale) トランジションを取得します。
インタフェース jp.co.intra_mart.framework.system.container.IMContainer から継承したメソッド
init

フィールドの詳細

SERVICE_PROPERTY_HANDLER_KEY

public static final String SERVICE_PROPERTY_HANDLER_KEY
サービスプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getServicePropertyHandler

public ServicePropertyHandler getServicePropertyHandler()
サービスプロパティハンドラを取得します。

戻り値:
サービスプロパティハンドラ

getServiceController

public ServiceController getServiceController(String application,
                                              String service,
                                              Locale locale)
                                       throws ServicePropertyException,
                                              ServiceControllerException
サービスコントローラを取得します。 指定されたアプリケーションID、サービスID、ロケールに該当するサービスコントローラを取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

パラメータ:
application - アプリケーション
service - サービス
locale - ロケール
戻り値:
サービスコントローラ、存在しない場合はnull
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
ServiceControllerException - サービスコントローラ取得時に例外が発生

getTransition

public Transition getTransition(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException,
                                TransitionException
トランジションを取得します。 指定されたアプリケーションID、サービスID、ロケールに該当するトランジションを取得します。 該当するトランジションが存在しない場合、DefaultTransitionを返します。

パラメータ:
application - アプリケーション
service - サービス
locale - ロケール
戻り値:
トランジション
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
TransitionException - トランジション取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ServiceContainerException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.container
クラス ServiceContainerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.container.ServiceContainerException
すべての実装インタフェース:
Serializable
public class ServiceContainerException
extends SystemException

サービスコンテナ設定時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ServiceContainerException()
詳細メッセージを指定しないで ServiceContainerException を構築します。
ServiceContainerException(String msg)
指定された詳細メッセージを持つ ServiceContainerException を構築します。
ServiceContainerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceContainerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ServiceContainerException

public ServiceContainerException()
詳細メッセージを指定しないで ServiceContainerException を構築します。

ServiceContainerException

public ServiceContainerException(String msg)
指定された詳細メッセージを持つ ServiceContainerException を構築します。

パラメータ:
msg - 詳細メッセージ

ServiceContainerException

public ServiceContainerException(String msg,
                                 Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceContainerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ServiceContainerImpl (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.container
クラス ServiceContainerImpl

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.container.ServiceContainerImpl
すべての実装インタフェース:
IMContainer, ServiceContainer
public class ServiceContainerImpl
extends Object
implements ServiceContainer

ServiceContainerの標準的な実装クラスです。

フィールドの概要
インタフェース jp.co.intra_mart.framework.base.service.container.ServiceContainer から継承したフィールド
SERVICE_PROPERTY_HANDLER_KEY
コンストラクタの概要
ServiceContainerImpl()
ServiceContainerImplを生成します。
メソッドの概要
ServiceController | getServiceController(String application, String service, Locale locale) サービスコントローラを取得します。
ServicePropertyHandler | getServicePropertyHandler() サービスプロパティハンドラを取得します。
Transition | getTransition(String application, String service, Locale locale) トランジションを取得します。
void | init() ServiceContainerを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ServiceContainerImpl

public ServiceContainerImpl()
ServiceContainerImplを生成します。

メソッドの詳細

init

public void init()
          throws IMContainerException
ServiceContainerを初期化します。

定義:
インタフェース IMContainer 内の init
例外:
IMContainerException

getServiceController

public ServiceController getServiceController(String application,
                                              String service,
                                              Locale locale)
                                       throws ServicePropertyException,
                                              ServiceControllerException
サービスコントローラを取得します。 指定されたアプリケーションID、サービスID、ロケールに該当するサービスコントローラを取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

定義:
インタフェース ServiceContainer 内の getServiceController
パラメータ:
application - アプリケーション
service - サービス
locale - ロケール
戻り値:
サービスコントローラ、存在しない場合はnull
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
ServiceControllerException - サービスコントローラ取得時に例外が発生

getServicePropertyHandler

public ServicePropertyHandler getServicePropertyHandler()
サービスプロパティハンドラを取得します。

定義:
インタフェース ServiceContainer 内の getServicePropertyHandler
戻り値:
サービスプロパティハンドラ

getTransition

public Transition getTransition(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException,
                                TransitionException
トランジションを取得します。 指定されたアプリケーションID、サービスID、ロケールに該当するトランジションを取得します。 該当するトランジションが存在しない場合、DefaultTransitionを返します。

定義:
インタフェース ServiceContainer 内の getTransition
パラメータ:
application - アプリケーション
service - サービス
locale - ロケール
戻り値:
トランジション
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
TransitionException - トランジション取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.framework.base.service.controller.ControllerConverter の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.controller.ControllerConverter の使用

ControllerConverter を使用しているパッケージ
jp.co.intra_mart.framework.base.service.controller 入力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.service.controller での ControllerConverter の使用

ControllerConverter を実装している jp.co.intra_mart.framework.base.service.controller のクラス
 class SimpleControllerConverter
リクエストの内容をコントローラオブジェクトにマッピングする単純なコントローラコンバータです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfig の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfig の使用

ControllerConverterConfig を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.controller | 入力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.service での ControllerConverterConfig の使用

ControllerConverterConfig を返す jp.co.intra_mart.framework.base.service のメソッド
ControllerConverterConfig | XmlServicePropertyHandler.getControllerConverterConfig(String application, String service, Locale locale) キーに該当するコントローラコンバータの初期パラメータを取得します。
ControllerConverterConfig | TextFileServicePropertyHandler.getControllerConverterConfig(String application, String service, Locale locale)
ControllerConverterConfig | ServicePropertyHandler.getControllerConverterConfig(String application, String service, Locale locale) キーに該当するコントローラコンバータの初期パラメータを取得します。
ControllerConverterConfig | DistributesServicePropertyHandler.getControllerConverterConfig(String application, String service, Locale locale)
ControllerConverterConfig | DefaultServicePropertyHandler.getControllerConverterConfig(String application, String service, Locale locale)

jp.co.intra_mart.framework.base.service.controller での ControllerConverterConfig の使用

ControllerConverterConfig を実装している jp.co.intra_mart.framework.base.service.controller のクラス
 class ControllerConverterConfigImpl
ControllerConverterの初期化情報です。

ControllerConverterConfig 型のパラメータを持つ jp.co.intra_mart.framework.base.service.controller のメソッド
void | SimpleControllerConverter.init(ControllerConverterConfig config) SimpleControllerConverterを初期化します。
void | ControllerConverter.init(ControllerConverterConfig config) ControllerConverterを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfigImpl の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfigImpl の使用

jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfigImpl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.controller.ControllerConverterException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.controller.ControllerConverterException の使用

ControllerConverterException を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.controller | 入力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.service での ControllerConverterException の使用

ControllerConverterException をスローする jp.co.intra_mart.framework.base.service のメソッド
 ControllerObject ServiceManager.getControllerObject(String application, String service, Locale locale, RequestInfo info)
コントーラオブジェクトを取得します。

jp.co.intra_mart.framework.base.service.controller での ControllerConverterException の使用

ControllerConverterException をスローする jp.co.intra_mart.framework.base.service.controller のメソッド
void | SimpleControllerConverter.init(ControllerConverterConfig config) SimpleControllerConverterを初期化します。
void | ControllerConverter.init(ControllerConverterConfig config) ControllerConverterを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.service.controller.ControllerObject の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.controller.ControllerObject の使用

ControllerObject を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.controller | 入力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.service での ControllerObject の使用

ControllerObject を返す jp.co.intra_mart.framework.base.service のメソッド
ControllerObject | ServiceManager.getControllerObject(String application, String service, Locale locale, RequestInfo info) コントーラオブジェクトを取得します。
ControllerObject | ServiceControllerAdapter.getControllerObject() コントローラオブジェクトを取得します。
ControllerObject | ServiceController.getControllerObject() コントローラオブジェクトを取得します。
ControllerObject | RequestInfo.getControllerObject() リクエストから生成されたコントローラオブジェクトを取得します。

ControllerObject 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
void | ServiceControllerAdapter.setControllerObject(ControllerObject controllerObject) コントローラオブジェクトを設定します。
void | ServiceController.setControllerObject(ControllerObject controllerObject) コントローラオブジェクトを設定します。

jp.co.intra_mart.framework.base.service.controller での ControllerObject の使用

ControllerObject を返す jp.co.intra_mart.framework.base.service.controller のメソッド
ControllerObject | SimpleControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
ControllerObject | ControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.controller.RequestFormatException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.controller.RequestFormatException の使用

RequestFormatException を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.controller | 入力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.service での RequestFormatException の使用

RequestFormatException をスローする jp.co.intra_mart.framework.base.service のメソッド
 ControllerObject ServiceManager.getControllerObject(String application, String service, Locale locale, RequestInfo info)
コントーラオブジェクトを取得します。

jp.co.intra_mart.framework.base.service.controller での RequestFormatException の使用

RequestFormatException をスローする jp.co.intra_mart.framework.base.service.controller のメソッド
ControllerObject | SimpleControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
ControllerObject | ControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter の使用

jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ControllerConverter (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.controller
インタフェース ControllerConverter

既知の実装クラスの一覧:
SimpleControllerConverter
public interface ControllerConverter

リクエストをコントローラオブジェクトに変換します。 コントローラオブジェクトはリクエストの内容を入力情報として変換されたものです。 開発者はこのインタフェースを実装し、適切なコントローラオブジェクトを返すように convert(RequestInfo)メソッドを実装する 必要があります。

生成されるコントローラオブジェクトはJavaBeansTM の仕様に従う必要があります。

導入されたバージョン:
6.1

メソッドの概要
ControllerObject | convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
void | destroy() ControllerConverterを破棄します。
void | init(ControllerConverterConfig config) ControllerConverterを初期化します。

メソッドの詳細

init

public void init(ControllerConverterConfig config)
          throws ControllerConverterException
ControllerConverterを初期化します。

パラメータ:
config - 初期化情報
例外:
ControllerConverterException - 初期化時に例外が発生

destroy

public void destroy()
ControllerConverterを破棄します。

convert

public ControllerObject convert(RequestInfo info)
                         throws RequestFormatException,
                                ServletException,
                                IOException
リクエスト情報をもとに入力オブジェクトを生成します。

パラメータ:
info - リクエスト情報
戻り値:
リクエストの内容が含まれる入力オブジェクト
例外:
RequestFormatException - リクエストのフォーマットが不正
ServletException - 変換中にServletExceptionが発生
IOException - 変換中にIOExceptionが発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ControllerConverterConfig (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.controller
インタフェース ControllerConverterConfig

既知の実装クラスの一覧:
ControllerConverterConfigImpl
public interface ControllerConverterConfig

ControllerConverterの初期化情報です。

導入されたバージョン:
6.1

メソッドの概要
String | getInitParameter(String name) ControllerConverterを初期化するときのパラメータを取得します。
Enumeration | getInitParameterNames() 初期化パラメータの名前の一覧を取得します。

メソッドの詳細

getInitParameter

public String getInitParameter(String name)
ControllerConverterを初期化するときのパラメータを取得します。

パラメータ:
name - 初期化パラメータ名
戻り値:
初期化パラメータの値

getInitParameterNames

public Enumeration getInitParameterNames()
初期化パラメータの名前の一覧を取得します。

戻り値:
初期化パラメータの名前の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ControllerConverterConfigImpl (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.controller
クラス ControllerConverterConfigImpl

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.util.Config
        拡張 jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfigImpl
すべての実装インタフェース:
ControllerConverterConfig
public class ControllerConverterConfigImpl
extends Config
implements ControllerConverterConfig

ControllerConverterの初期化情報です。

導入されたバージョン:
6.1

フィールドの概要
クラス jp.co.intra_mart.framework.system.util.Config から継承したフィールド
parameters
コンストラクタの概要
ControllerConverterConfigImpl()
クラス jp.co.intra_mart.framework.system.util.Config から継承したメソッド
getInitParameter, getInitParameterNames, setInitParameter
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfig から継承したメソッド
getInitParameter, getInitParameterNames

コンストラクタの詳細

ControllerConverterConfigImpl

public ControllerConverterConfigImpl()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ControllerConverterException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.controller
クラス ControllerConverterException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.controller.ControllerConverterException
すべての実装インタフェース:
Serializable
public class ControllerConverterException
extends SystemException

ControllerConverterに関連する例外です。

導入されたバージョン:
6.1
関連項目:
直列化された形式

コンストラクタの概要
ControllerConverterException()
詳細メッセージを指定しないで ForwardSelectorException を構築します。
ControllerConverterException(String msg)
指定された詳細メッセージを持つ ForwardSelectorException を構築します。
ControllerConverterException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ForwardSelectorException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ControllerConverterException

public ControllerConverterException()
詳細メッセージを指定しないで ForwardSelectorException を構築します。

ControllerConverterException

public ControllerConverterException(String msg)
指定された詳細メッセージを持つ ForwardSelectorException を構築します。

パラメータ:
msg - 詳細メッセージ

ControllerConverterException

public ControllerConverterException(String msg,
                                    Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ForwardSelectorException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ControllerObject (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.controller
インタフェース ControllerObject

すべてのスーパーインタフェース:
Serializable
public interface ControllerObject
extends Serializable

コントローラオブジェクトのインタフェースです。 すべてのコントローラオブジェクトはこのインタフェースを実装する必要があります。 このインタフェースを実装するクラスはJavaBeansの仕様に沿っている必要があります。

導入されたバージョン:
6.1

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.service.controller (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.base.service.controller
インタフェース
ControllerConverter
ControllerConverterConfig
ControllerObject
クラス
ControllerConverterConfigImpl
SimpleControllerConverter
例外
ControllerConverterException
RequestFormatException


jp.co.intra_mart.framework.base.service.controller (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.service.controller

入力情報に関連するパッケージです。

参照:
説明

インタフェースの概要
ControllerConverter | リクエストをコントローラオブジェクトに変換します。
ControllerConverterConfig | ControllerConverterの初期化情報です。
ControllerObject | コントローラオブジェクトのインタフェースです。

クラスの概要
ControllerConverterConfigImpl | ControllerConverterの初期化情報です。
SimpleControllerConverter | リクエストの内容をコントローラオブジェクトにマッピングする単純なコントローラコンバータです。

例外の概要
ControllerConverterException | ControllerConverterに関連する例外です。
RequestFormatException | フォーマットが不正であるときの例外です。

パッケージ jp.co.intra_mart.framework.base.service.controller の説明

入力情報に関連するパッケージです。


jp.co.intra_mart.framework.base.service.controller クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.service.controller の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.system.util.Config
      • class jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfigImpl (implements jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfig)
    • class jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter (implements jp.co.intra_mart.framework.base.service.controller.ControllerConverter)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.service.controller.ControllerConverterException
            • class jp.co.intra_mart.framework.base.service.controller.RequestFormatException

インタフェース階層

  • interface jp.co.intra_mart.framework.base.service.controller.ControllerConverter
  • interface jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfig
  • interface java.io.Serializable
    • interface jp.co.intra_mart.framework.base.service.controller.ControllerObject


パッケージ jp.co.intra_mart.framework.base.service.controller の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.service.controller の使用

jp.co.intra_mart.framework.base.service.controller を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.controller | 入力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.base.service.controller のクラス
ControllerConverterConfig
ControllerConverterの初期化情報です。
ControllerConverterException
ControllerConverterに関連する例外です。
ControllerObject
コントローラオブジェクトのインタフェースです。
RequestFormatException
フォーマットが不正であるときの例外です。

jp.co.intra_mart.framework.base.service.controller により使用される jp.co.intra_mart.framework.base.service.controller のクラス
ControllerConverter
リクエストをコントローラオブジェクトに変換します。
ControllerConverterConfig
ControllerConverterの初期化情報です。
ControllerConverterException
ControllerConverterに関連する例外です。
ControllerObject
コントローラオブジェクトのインタフェースです。
RequestFormatException
フォーマットが不正であるときの例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


RequestFormatException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.controller
クラス RequestFormatException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.controller.RequestFormatException
すべての実装インタフェース:
Serializable
public class RequestFormatException
extends SystemException

フォーマットが不正であるときの例外です。

導入されたバージョン:
6.1
関連項目:
直列化された形式

コンストラクタの概要
RequestFormatException()
詳細メッセージを指定しないで RequestFormatException を構築します。
RequestFormatException(String msg)
指定された詳細メッセージを持つ RequestFormatException を構築します。
RequestFormatException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestFormatException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

RequestFormatException

public RequestFormatException()
詳細メッセージを指定しないで RequestFormatException を構築します。

RequestFormatException

public RequestFormatException(String msg)
指定された詳細メッセージを持つ RequestFormatException を構築します。

パラメータ:
msg - 詳細メッセージ

RequestFormatException

public RequestFormatException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestFormatException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SimpleControllerConverter (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.controller
クラス SimpleControllerConverter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter
すべての実装インタフェース:
ControllerConverter
public class SimpleControllerConverter
extends Object
implements ControllerConverter

リクエストの内容をコントローラオブジェクトにマッピングする単純なコントローラコンバータです。 ここではコントローラオブジェクトはJavaBeansとして扱われます。 リクエストのパラメータから取得される値をコントローラオブジェクトのプロパティに設定します。 ここで対応付けられるコントローラオブジェクトのプロパティはすべてStringである必要があります。 パラメータとプロパティの対応ルールは以下のとおりです。

  • リクエストのパラメータ名とコントローラオブジェクトのプロパティ名が一致するものが対応付けられる
  • ある名前に対してリクエストのパラメータが存在するがコントローラオブジェクトのプロパティが存在しない、 またはリクエストのパラメータは存在しないがコントローラオブジェクトのプロパティが存在する場合は何も行われない
  • リクエストのパラメータが同一のパラメータ名でただ1つの値を持ち、 コントローラオブジェクトが同一名のプロパティのインデックスなしのsetterメソッド （引数はStringまたはその配列）を持つ場合はそのメソッドが使用される
  • リクエストのパラメータが同一のパラメータ名でただ1つの値を持ち、 コントローラオブジェクトが同一名のプロパティのインデックスなしのsetterメソッド （引数はStringの配列）を持たない場合は インデックス付きのsetterメソッド（第1引数はint、第2引数はString）が使用される
  • リクエストのパラメータが同一のパラメータ名で複数の値を持ち、 コントローラオブジェクトが同一名のプロパティのインデックスなしのsetterメソッド （引数はStringの配列）を持つ場合はそのメソッドが使用される
  • リクエストのパラメータが同一のパラメータ名で複数の値を持ち、 コントローラオブジェクトが同一名のプロパティのインデックスなしのsetterメソッド （引数はStringの配列）を持たない場合は インデックス付きのsetterメソッド（第1引数はint、第2引数はString）が使用される （この場合設定される順番はリクエストのパラメータと同一となる）
  • リクエストのパラメータが同一のパラメータ名で複数の値を持ち、 コントローラオブジェクトが同一名のプロパティにおいて複数の値を扱うsetterメソッドを持たない場合は インデックスなしのsetterメソッド（引数はString）が使用される （この場合リクエストのパラメータの最初の値のみが設定される）
  • コントローラオブジェクトが対応するプロパティのsetterメソッドを持たない場合何も行われない

導入されたバージョン:
6.1

フィールドの概要
static String OBJECT_PARAM_NAME
コントローラオブジェクトのクラス名を設定するパラメータ名
コンストラクタの概要
SimpleControllerConverter()
メソッドの概要
ControllerObject | convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
void | destroy() SimpleControllerConverterを破棄します。
void | init(ControllerConverterConfig config) SimpleControllerConverterを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

OBJECT_PARAM_NAME

public static final String OBJECT_PARAM_NAME
コントローラオブジェクトのクラス名を設定するパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

SimpleControllerConverter

public SimpleControllerConverter()
メソッドの詳細

init

public void init(ControllerConverterConfig config)
          throws ControllerConverterException
SimpleControllerConverterを初期化します。

定義:
インタフェース ControllerConverter 内の init
パラメータ:
config - 初期化情報
例外:
ControllerConverterException - 初期化時に例外が発生

destroy

public void destroy()
SimpleControllerConverterを破棄します。

定義:
インタフェース ControllerConverter 内の destroy

convert

public ControllerObject convert(RequestInfo info)
                         throws RequestFormatException,
                                ServletException,
                                IOException
リクエスト情報をもとに入力オブジェクトを生成します。

定義:
インタフェース ControllerConverter 内の convert
パラメータ:
info - リクエスト情報
戻り値:
リクエストの内容が含まれる入力オブジェクト
例外:
RequestFormatException - リクエストのフォーマットが不正
ServletException - 変換中にServletExceptionが発生
IOException - 変換中にIOExceptionが発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.base.service.validator.FormatValidator の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.validator.FormatValidator の使用

jp.co.intra_mart.framework.base.service.validator.FormatValidator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.validator.LengthValidator の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.validator.LengthValidator の使用

jp.co.intra_mart.framework.base.service.validator.LengthValidator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator の使用

jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.validator.NumericValidator の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.validator.NumericValidator の使用

jp.co.intra_mart.framework.base.service.validator.NumericValidator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.validator.ValidationException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.validator.ValidationException の使用

jp.co.intra_mart.framework.base.service.validator.ValidationException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.validator.ValidationExceptionDetail の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.validator.ValidationExceptionDetail の使用

ValidationExceptionDetail を使用しているパッケージ
jp.co.intra_mart.framework.base.service.validator 検証に関連するパッケージです。

jp.co.intra_mart.framework.base.service.validator での ValidationExceptionDetail の使用

ValidationExceptionDetail を返す jp.co.intra_mart.framework.base.service.validator のメソッド
ValidationExceptionDetail | Validator.validate(RequestInfo info) リクエスト内容の検証をします。
ValidationExceptionDetail | NumericValidator.validate(RequestInfo info) 数値の検証をします。
ValidationExceptionDetail | NumericRangeValidator.validate(RequestInfo info) 数値の範囲を検証します。
ValidationExceptionDetail | LengthValidator.validate(RequestInfo info) 文字列の長さを検証します。
ValidationExceptionDetail | FormatValidator.validate(RequestInfo info) 文字列の不正文字（フォーマット）を検証します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.service.validator.Validator の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.validator.Validator の使用

Validator を使用しているパッケージ
jp.co.intra_mart.framework.base.service.validator 検証に関連するパッケージです。

jp.co.intra_mart.framework.base.service.validator での Validator の使用

Validator を実装している jp.co.intra_mart.framework.base.service.validator のクラス
class | FormatValidator 文字列の不正文字（フォーマット）チェックを行います。
class | LengthValidator 文字列の長さをチェックします。
class | NumericRangeValidator 数値の範囲をチェックします。
class | NumericValidator 数値（整数）として妥当であるかどうかをチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.service.validator.ValidatorConfig の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.validator.ValidatorConfig の使用

ValidatorConfig を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.validator | 検証に関連するパッケージです。

jp.co.intra_mart.framework.base.service での ValidatorConfig の使用

ValidatorConfig を返す jp.co.intra_mart.framework.base.service のメソッド
 ValidatorConfig ValidatorMapping.getValidatorConfig()
バリデータの初期化パラメータを取得します。

ValidatorConfig 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
 void ValidatorMapping.setValidatorConfig(ValidatorConfig validatorConfig)
バリデータの初期化パラメータを設定します。

jp.co.intra_mart.framework.base.service.validator での ValidatorConfig の使用

ValidatorConfig を実装している jp.co.intra_mart.framework.base.service.validator のクラス
 class ValidatorConfigImpl
ValidatorConfigの実装です。

ValidatorConfig 型のパラメータを持つ jp.co.intra_mart.framework.base.service.validator のメソッド
void | Validator.init(ValidatorConfig config) Validatorを初期化します。
void | NumericValidator.init(ValidatorConfig config) NumericValidatorを初期化します。
void | NumericRangeValidator.init(ValidatorConfig config) NumericRangeValidatorを初期化します。
void | LengthValidator.init(ValidatorConfig config) LengthValidatorを初期化します。
void | FormatValidator.init(ValidatorConfig config) FormatValidatorを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.validator.ValidatorConfigImpl の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.validator.ValidatorConfigImpl の使用

jp.co.intra_mart.framework.base.service.validator.ValidatorConfigImpl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.validator.ValidatorException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.validator.ValidatorException の使用

ValidatorException を使用しているパッケージ
jp.co.intra_mart.framework.base.service.validator 検証に関連するパッケージです。

jp.co.intra_mart.framework.base.service.validator での ValidatorException の使用

ValidatorException をスローする jp.co.intra_mart.framework.base.service.validator のメソッド
void | Validator.init(ValidatorConfig config) Validatorを初期化します。
ValidationExceptionDetail | Validator.validate(RequestInfo info) リクエスト内容の検証をします。
void | NumericValidator.init(ValidatorConfig config) NumericValidatorを初期化します。
ValidationExceptionDetail | NumericValidator.validate(RequestInfo info) 数値の検証をします。
void | NumericRangeValidator.init(ValidatorConfig config) NumericRangeValidatorを初期化します。
ValidationExceptionDetail | NumericRangeValidator.validate(RequestInfo info) 数値の範囲を検証します。
void | LengthValidator.init(ValidatorConfig config) LengthValidatorを初期化します。
ValidationExceptionDetail | LengthValidator.validate(RequestInfo info) 文字列の長さを検証します。
void | FormatValidator.init(ValidatorConfig config) FormatValidatorを初期化します。
ValidationExceptionDetail | FormatValidator.validate(RequestInfo info) 文字列の不正文字（フォーマット）を検証します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


FormatValidator (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.validator
クラス FormatValidator

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.validator.FormatValidator
すべての実装インタフェース:
Validator
public class FormatValidator
extends Object
implements Validator

文字列の不正文字（フォーマット）チェックを行います。 このクラスではControllerObjectのプロパティが、指定された正規表現に一致しているかどうかを検証します。

検証対象となるプロパティ名と正規表現のフォーマットは初期化パラメータで指定します。 プロパティ名はPARAM_PROPERTYで、フォーマットはPARAM_REGEXで与えられる名前でそれぞれ指定します。 正規表現はString.matches(java.lang.String)の引数で指定できるものと同じです。

該当するプロパティの内容がnullだった場合、 そのプロパティには空文字列が設定されているものとみなされます。

プロパティが正規表現に一致しない場合、PARAM_MESSAGEで与えられる名前のパラメータに設定されたメッセージが返されます。 このパラメータが設定されていない場合、このクラスで用意されたメッセージが返されます。

導入されたバージョン:
6.1

フィールドの概要
static String | PARAM_MESSAGE 不正文字列である場合のメッセージが設定されているパラメータ名
static String | PARAM_PROPERTY 検証対象となるコントローラオブジェクトのプロパティ名を示すパラメータ名
static String | PARAM_REGEX 正規表現によるフォーマットが設定されているパラメータ名
コンストラクタの概要
FormatValidator()
メソッドの概要
void | destroy() FormatValidatorを破棄します。
void | init(ValidatorConfig config) FormatValidatorを初期化します。
ValidationExceptionDetail | validate(RequestInfo info) 文字列の不正文字（フォーマット）を検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_PROPERTY

public static final String PARAM_PROPERTY
検証対象となるコントローラオブジェクトのプロパティ名を示すパラメータ名

関連項目:
定数フィールド値

PARAM_REGEX

public static final String PARAM_REGEX
正規表現によるフォーマットが設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MESSAGE

public static final String PARAM_MESSAGE
不正文字列である場合のメッセージが設定されているパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

FormatValidator

public FormatValidator()
メソッドの詳細

init

public void init(ValidatorConfig config)
          throws ValidatorException
FormatValidatorを初期化します。

定義:
インタフェース Validator 内の init
パラメータ:
config - 初期化情報
例外:
ValidatorException - 初期化時に例外が発生

destroy

public void destroy()
FormatValidatorを破棄します。

定義:
インタフェース Validator 内の destroy

validate

public ValidationExceptionDetail validate(RequestInfo info)
                                   throws ValidatorException
文字列の不正文字（フォーマット）を検証します。 検証の結果、リクエスト内容が不正である場合ValidationExceptionDetailを返します。 リクエスト内容が正常なものである場合、nullを返します。

定義:
インタフェース Validator 内の validate
パラメータ:
info - リクエスト情報
戻り値:
リクエスト内容が不正な場合：検証結果の詳細
正常な場合：null
例外:
ValidatorException - 該当するプロパティが存在しない、またはプロパティの取得に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LengthValidator (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.validator
クラス LengthValidator

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.validator.LengthValidator
すべての実装インタフェース:
Validator
public class LengthValidator
extends Object
implements Validator

文字列の長さをチェックします。 このクラスではControllerObjectのプロパティの文字列長が、指定された範囲に含まれるかどうかを検証します。

検証対象となるプロパティ名と長さの範囲は初期化パラメータで指定します。 プロパティ名はPARAM_PROPERTYで、長さの範囲はPARAM_MINとPARAM_MAXで与えられる名前でそれぞれ指定します。 文字列長の最小値と最大値で設定できる値は、ともに0以上の整数かつintの最大値以下です。 最大値と最小値のパラメータは0以上かつInteger.MAX_VALUE以下である必要があります。 該当するプロパティの内容がnullだった場合、 そのプロパティには空文字列が設定されているものとみなされます。

プロパティの文字列長が最小値に満たない場合、PARAM_MESSAGE_SHORTで与えられる名前のパラメータに設定されたメッセージが返されます。 プロパティの文字列長が最大値を超える場合、PARAM_MESSAGE_LONGで与えられる名前のパラメータに設定されたメッセージが返されます。 これらのパラメータが設定されていない場合、このクラスで用意されたメッセージが返されます。

導入されたバージョン:
6.1

フィールドの概要
static String | PARAM_MAX 文字列長の最大値が設定されているパラメータ名
static String | PARAM_MESSAGE_LONG 文字列長が長い場合のメッセージが設定されているパラメータ名
static String | PARAM_MESSAGE_SHORT 文字列長が短い場合のメッセージが設定されているパラメータ名
static String | PARAM_MIN 文字列長の最小値が設定されているパラメータ名
static String | PARAM_PROPERTY 検証対象のプロパティ名が設定されているパラメータ名
コンストラクタの概要
LengthValidator()
メソッドの概要
void | destroy() LengthValidatorを破棄します。
void | init(ValidatorConfig config) LengthValidatorを初期化します。
ValidationExceptionDetail | validate(RequestInfo info) 文字列の長さを検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_PROPERTY

public static final String PARAM_PROPERTY
検証対象のプロパティ名が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MIN

public static final String PARAM_MIN
文字列長の最小値が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MAX

public static final String PARAM_MAX
文字列長の最大値が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MESSAGE_SHORT

public static final String PARAM_MESSAGE_SHORT
文字列長が短い場合のメッセージが設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MESSAGE_LONG

public static final String PARAM_MESSAGE_LONG
文字列長が長い場合のメッセージが設定されているパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

LengthValidator

public LengthValidator()
メソッドの詳細

init

public void init(ValidatorConfig config)
          throws ValidatorException
LengthValidatorを初期化します。

定義:
インタフェース Validator 内の init
パラメータ:
config - 初期化情報
例外:
ValidatorException - 初期化時に例外が発生

destroy

public void destroy()
LengthValidatorを破棄します。

定義:
インタフェース Validator 内の destroy

validate

public ValidationExceptionDetail validate(RequestInfo info)
                                   throws ValidatorException
文字列の長さを検証します。 検証の結果、リクエスト内容が不正である場合ValidationExceptionDetailを返します。 リクエスト内容が正常なものである場合、nullを返します。

定義:
インタフェース Validator 内の validate
パラメータ:
info - リクエスト情報
戻り値:
リクエスト内容が不正な場合：検証結果の詳細
正常な場合：null
例外:
ValidatorException - 該当するプロパティが存在しない、またはプロパティの取得に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NumericRangeValidator (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.validator
クラス NumericRangeValidator

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator
すべての実装インタフェース:
Validator
public class NumericRangeValidator
extends Object
implements Validator

数値の範囲をチェックします。 このクラスではControllerObjectのプロパティの数値が、指定された範囲に含まれるかどうかを検証します。

検証対象となるプロパティ名と範囲は初期化パラメータで指定します。 プロパティ名はPARAM_PROPERTYで、数値の範囲はPARAM_MINとPARAM_MAXで与えられる名前でそれぞれ指定します。 数値の最小値と最大値で設定できる値は、ともに整数のみです。

最小値が省略された場合、数値の下限はチェックされません。 最大値が省略された場合、数値の上限はチェックされません。

最大値と最小値はともにチェック対象の範囲に含まれます。

最大値と最小値のパラメータはLong.parseLong(java.lang.String)の引数に指定できるものである必要があります。

プロパティの値が次のいずれかに該当する場合、 PARAM_MESSAGEで与えられる名前のパラメータに設定されたメッセージが返されます。

  • nullである
  • プロパティの数値が最小値に満たない
  • プロパティの数値が最大値を超える
  • プロパティがStringであり、その値がBigInteger.BigInteger(java.lang.String)の引数に指定できる値ではない
チェック対象のプロパティが以下のいずれかでもない場合、例外が返されます。
  • int
  • long
  • Integer
  • Long
  • BigInteger
  • String
チェック対象のプロパティが存在しない場合も、例外が返されます。

導入されたバージョン:
6.1

フィールドの概要
static String | PARAM_MAX 数値の最大値が設定されているパラメータ名
static String | PARAM_MESSAGE 数値が範囲外の場合のメッセージが設定されているパラメータ名
static String | PARAM_MIN 数値の最小値が設定されているパラメータ名
static String | PARAM_PROPERTY 検証対象のプロパティ名が設定されているパラメータ名
コンストラクタの概要
NumericRangeValidator()
メソッドの概要
void | destroy() NumericRangeValidatorを破棄します。
void | init(ValidatorConfig config) NumericRangeValidatorを初期化します。
ValidationExceptionDetail | validate(RequestInfo info) 数値の範囲を検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_MIN

public static final String PARAM_MIN
数値の最小値が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MAX

public static final String PARAM_MAX
数値の最大値が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_PROPERTY

public static final String PARAM_PROPERTY
検証対象のプロパティ名が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MESSAGE

public static final String PARAM_MESSAGE
数値が範囲外の場合のメッセージが設定されているパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

NumericRangeValidator

public NumericRangeValidator()
メソッドの詳細

init

public void init(ValidatorConfig config)
          throws ValidatorException
NumericRangeValidatorを初期化します。

定義:
インタフェース Validator 内の init
パラメータ:
config - 初期化情報
例外:
ValidatorException - 初期化時に例外が発生

destroy

public void destroy()
NumericRangeValidatorを破棄します。

定義:
インタフェース Validator 内の destroy

validate

public ValidationExceptionDetail validate(RequestInfo info)
                                   throws ValidatorException
数値の範囲を検証します。 検証の結果、リクエスト内容が不正である場合ValidationExceptionDetailを返します。 リクエスト内容が正常なものである場合、nullを返します。

定義:
インタフェース Validator 内の validate
パラメータ:
info - リクエスト情報
戻り値:
リクエスト内容が不正な場合：検証結果の詳細
正常な場合：null
例外:
ValidatorException - 該当するプロパティが存在しない、またはプロパティが数値として正しくない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NumericValidator (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.validator
クラス NumericValidator

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.validator.NumericValidator
すべての実装インタフェース:
Validator
public class NumericValidator
extends Object
implements Validator

数値（整数）として妥当であるかどうかをチェックします。 このクラスではControllerObjectのプロパティが整数として妥当であるかどうかを検証します。

検証対象となるプロパティ名は初期化パラメータで指定します。 プロパティ名はPARAM_PROPERTYで指定します。

プロパティの型が以下のものであれば無条件で整数であるとみなされます。

  • int
  • long
プロパティの型が以下のものであり、かつnullでなければ無条件で整数であるとみなされます。
  • Integer
  • Long
  • BigInteger
プロパティがStringである場合、以下の条件をすべて満たせば整数として妥当であるとみなされます。
  • nullではない
  • 先頭にはマイナス符号が1つだけ付いてもよい。
  • 以降は1つ以上の10進数字の列で構成される。
上記以外の場合、該当するプロパティは数値として妥当でないものとみなされます。 この場合、validate(RequestInfo)の戻り値であるValidationExceptionにはPARAM_MESSAGEで与えられる名前のパラメータに設定されたメッセージが返されます。 このパラメータが設定されていない場合、このクラスで用意されたメッセージが返されます。

導入されたバージョン:
6.1

フィールドの概要
static String | PARAM_MESSAGE 数値として妥当ではない場合のメッセージが設定されているパラメータ名
static String | PARAM_PROPERTY 検証対象のプロパティ名が設定されているパラメータ名
コンストラクタの概要
NumericValidator()
メソッドの概要
void | destroy() NumericValidatorを破棄します。
void | init(ValidatorConfig config) NumericValidatorを初期化します。
ValidationExceptionDetail | validate(RequestInfo info) 数値の検証をします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_PROPERTY

public static final String PARAM_PROPERTY
検証対象のプロパティ名が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MESSAGE

public static final String PARAM_MESSAGE
数値として妥当ではない場合のメッセージが設定されているパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

NumericValidator

public NumericValidator()
メソッドの詳細

init

public void init(ValidatorConfig config)
          throws ValidatorException
NumericValidatorを初期化します。

定義:
インタフェース Validator 内の init
パラメータ:
config - 初期化情報
例外:
ValidatorException - 初期化時に例外が発生

destroy

public void destroy()
NumericValidatorを破棄します。

定義:
インタフェース Validator 内の destroy

validate

public ValidationExceptionDetail validate(RequestInfo info)
                                   throws ValidatorException
数値の検証をします。 検証の結果、リクエスト内容が不正である場合ValidationExceptionDetailを返します。 リクエスト内容が正常なものである場合、nullを返します。

定義:
インタフェース Validator 内の validate
パラメータ:
info - リクエスト情報
戻り値:
リクエスト内容が不正な場合：検証結果の詳細
正常な場合：null
例外:
ValidatorException - 該当するプロパティが存在しない、またはプロパティの取得に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.service.validator (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.base.service.validator
インタフェース
Validator
ValidatorConfig
クラス
FormatValidator
LengthValidator
NumericRangeValidator
NumericValidator
ValidationExceptionDetail
ValidatorConfigImpl
例外
ValidationException
ValidatorException


jp.co.intra_mart.framework.base.service.validator (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.service.validator

検証に関連するパッケージです。

参照:
説明

インタフェースの概要
Validator | リクエスト内容の検証をします。
ValidatorConfig | Validatorの初期化情報です。

クラスの概要
FormatValidator | 文字列の不正文字（フォーマット）チェックを行います。
LengthValidator | 文字列の長さをチェックします。
NumericRangeValidator | 数値の範囲をチェックします。
NumericValidator | 数値（整数）として妥当であるかどうかをチェックします。
ValidationExceptionDetail | 検証結果の詳細情報です。
ValidatorConfigImpl | ValidatorConfigの実装です。

例外の概要
ValidationException | 検証結果が不正であるときの例外です。
ValidatorException | Validatorに関連する例外です。

パッケージ jp.co.intra_mart.framework.base.service.validator の説明

検証に関連するパッケージです。


jp.co.intra_mart.framework.base.service.validator クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.service.validator の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.system.util.Config
      • class jp.co.intra_mart.framework.base.service.validator.ValidatorConfigImpl (implements jp.co.intra_mart.framework.base.service.validator.ValidatorConfig)
    • class jp.co.intra_mart.framework.base.service.validator.FormatValidator (implements jp.co.intra_mart.framework.base.service.validator.Validator)
    • class jp.co.intra_mart.framework.base.service.validator.LengthValidator (implements jp.co.intra_mart.framework.base.service.validator.Validator)
    • class jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator (implements jp.co.intra_mart.framework.base.service.validator.Validator)
    • class jp.co.intra_mart.framework.base.service.validator.NumericValidator (implements jp.co.intra_mart.framework.base.service.validator.Validator)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.ApplicationException
            • class jp.co.intra_mart.framework.base.service.RequestException
              • class jp.co.intra_mart.framework.base.service.validator.ValidationException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.service.validator.ValidatorException
    • class jp.co.intra_mart.framework.base.service.validator.ValidationExceptionDetail

インタフェース階層

  • interface jp.co.intra_mart.framework.base.service.validator.Validator
  • interface jp.co.intra_mart.framework.base.service.validator.ValidatorConfig


パッケージ jp.co.intra_mart.framework.base.service.validator の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.service.validator の使用

jp.co.intra_mart.framework.base.service.validator を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.validator | 検証に関連するパッケージです。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.base.service.validator のクラス
ValidatorConfig
Validatorの初期化情報です。

jp.co.intra_mart.framework.base.service.validator により使用される jp.co.intra_mart.framework.base.service.validator のクラス
ValidationExceptionDetail
検証結果の詳細情報です。
Validator
リクエスト内容の検証をします。
ValidatorConfig
Validatorの初期化情報です。
ValidatorException
Validatorに関連する例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ValidationException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.validator
クラス ValidationException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.ApplicationException
                    拡張 jp.co.intra_mart.framework.base.service.RequestException
                        拡張 jp.co.intra_mart.framework.base.service.validator.ValidationException
すべての実装インタフェース:
Serializable
public class ValidationException
extends RequestException

検証結果が不正であるときの例外です。

導入されたバージョン:
6.1
関連項目:
直列化された形式

コンストラクタの概要
ValidationException()
詳細メッセージを指定しないで ValidationException を構築します。
ValidationException(String msg)
指定された詳細メッセージを持つ ValidationException を構築します。
ValidationException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestFormatException を構築します。
メソッドの概要
String | getMessage() 例外メッセージを取得します。
Iterator | getValidationExceptionDetails() 検証結果の詳細の一覧を取得します。
void | setValidationExceptionDetails(Collection details) 検証結果の詳細を設定します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ValidationException

public ValidationException()
詳細メッセージを指定しないで ValidationException を構築します。

ValidationException

public ValidationException(String msg)
指定された詳細メッセージを持つ ValidationException を構築します。

パラメータ:
msg - 詳細メッセージ

ValidationException

public ValidationException(String msg,
                           Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestFormatException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
メソッドの詳細

setValidationExceptionDetails

public void setValidationExceptionDetails(Collection details)
検証結果の詳細を設定します。 detailsはValidationExceptionDetailのコレクションである必要があります。

パラメータ:
details - 検証結果の詳細

getValidationExceptionDetails

public Iterator getValidationExceptionDetails()
検証結果の詳細の一覧を取得します。 戻り値はValidationExceptionDetailのコレクションのIteratorです。

戻り値:
検証結果の詳細の一覧

getMessage

public String getMessage()
例外メッセージを取得します。 詳細情報を含んだ形式で例外情報が取得されます。

戻り値:
例外メッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ValidationExceptionDetail (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.validator
クラス ValidationExceptionDetail

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.validator.ValidationExceptionDetail
public class ValidationExceptionDetail
extends Object

検証結果の詳細情報です。

導入されたバージョン:
6.1

コンストラクタの概要
ValidationExceptionDetail()
メッセージなしのValidatorExceptionDetailを生成します。
ValidationExceptionDetail(String message)
メッセージ付きのValidatorExceptionDetailを生成します。
メソッドの概要
void | addDetail(String detail) 検証結果の詳細を追加します。
Iterator | getDetails() 検証結果の詳細の一覧を取得します。
String | getMessage() 検証結果のメッセージを取得します。
void | setMessage(String message) 検証結果のメッセージを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ValidationExceptionDetail

public ValidationExceptionDetail()
メッセージなしのValidatorExceptionDetailを生成します。 この場合、メッセージとして空文字列が設定されたものとみなされます。

ValidationExceptionDetail

public ValidationExceptionDetail(String message)
メッセージ付きのValidatorExceptionDetailを生成します。

パラメータ:
message - メッセージ
メソッドの詳細

getMessage

public String getMessage()
検証結果のメッセージを取得します。

戻り値:
検証結果のメッセージ

setMessage

public void setMessage(String message)
検証結果のメッセージを設定します。

パラメータ:
message - 検証結果のメッセージ

addDetail

public void addDetail(String detail)
検証結果の詳細を追加します。

パラメータ:
detail - 検証結果の詳細

getDetails

public Iterator getDetails()
検証結果の詳細の一覧を取得します。 StringのCollectionのIteratorが返されます。

戻り値:
検証結果の詳細の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Validator (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.validator
インタフェース Validator

既知の実装クラスの一覧:
FormatValidator, LengthValidator, NumericRangeValidator, NumericValidator
public interface Validator

リクエスト内容の検証をします。

導入されたバージョン:
6.1

メソッドの概要
void | destroy() Validatorを破棄します。
void | init(ValidatorConfig config) Validatorを初期化します。
ValidationExceptionDetail | validate(RequestInfo info) リクエスト内容の検証をします。

メソッドの詳細

init

public void init(ValidatorConfig config)
          throws ValidatorException
Validatorを初期化します。

パラメータ:
config - 初期化情報
例外:
ValidatorException - 初期化時に例外が発生

destroy

public void destroy()
Validatorを破棄します。

validate

public ValidationExceptionDetail validate(RequestInfo info)
                                   throws ValidatorException
リクエスト内容の検証をします。 検証の結果、リクエスト内容が不正である場合ValidationExceptionDetailを返します。 リクエスト内容が正常なものである場合、nullを返します。

パラメータ:
info - リクエスト情報
戻り値:
リクエスト内容が不正な場合：検証結果の詳細
正常な場合：null
例外:
検証中に想定外の例外が発生
ValidatorException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ValidatorConfig (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.validator
インタフェース ValidatorConfig

既知の実装クラスの一覧:
ValidatorConfigImpl
public interface ValidatorConfig

Validatorの初期化情報です。

導入されたバージョン:
6.1

メソッドの概要
String | getInitParameter(String name) Validatorを初期化するときのパラメータを取得します。
Enumeration | getInitParameterNames() 初期化パラメータの名前の一覧を取得します。

メソッドの詳細

getInitParameter

public String getInitParameter(String name)
Validatorを初期化するときのパラメータを取得します。

パラメータ:
name - 初期化パラメータ名
戻り値:
初期化パラメータの値

getInitParameterNames

public Enumeration getInitParameterNames()
初期化パラメータの名前の一覧を取得します。

戻り値:
初期化パラメータの名前の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ValidatorConfigImpl (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.validator
クラス ValidatorConfigImpl

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.util.Config
        拡張 jp.co.intra_mart.framework.base.service.validator.ValidatorConfigImpl
すべての実装インタフェース:
ValidatorConfig
public class ValidatorConfigImpl
extends Config
implements ValidatorConfig

ValidatorConfigの実装です。

導入されたバージョン:
6.1

フィールドの概要
クラス jp.co.intra_mart.framework.system.util.Config から継承したフィールド
parameters
コンストラクタの概要
ValidatorConfigImpl()
クラス jp.co.intra_mart.framework.system.util.Config から継承したメソッド
getInitParameter, getInitParameterNames, setInitParameter
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.framework.base.service.validator.ValidatorConfig から継承したメソッド
getInitParameter, getInitParameterNames

コンストラクタの詳細

ValidatorConfigImpl

public ValidatorConfigImpl()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ValidatorException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service.validator
クラス ValidatorException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.validator.ValidatorException
すべての実装インタフェース:
Serializable
public class ValidatorException
extends SystemException

Validatorに関連する例外です。

導入されたバージョン:
6.1
関連項目:
直列化された形式

コンストラクタの概要
ValidatorException()
詳細メッセージを指定しないで ValidatorException を構築します。
ValidatorException(String msg)
指定された詳細メッセージを持つ ValidatorException を構築します。
ValidatorException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ValidatorException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ValidatorException

public ValidatorException()
詳細メッセージを指定しないで ValidatorException を構築します。

ValidatorException

public ValidatorException(String msg)
指定された詳細メッセージを持つ ValidatorException を構築します。

パラメータ:
msg - 詳細メッセージ

ValidatorException

public ValidatorException(String msg,
                          Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ValidatorException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ControllerConverterModel (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ControllerConverterModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.ControllerConverterModel
public class ControllerConverterModel
extends Object

コントローラコンバータ情報を管理するクラスです。

導入されたバージョン:
6.1

フィールドの概要
static String | ID
static String | P_ID_CONVERTER_CLASS
static String | P_ID_CONVERTER_PARAM
static String | P_ID_PARAM_NAME
static String | P_ID_PARAM_VALUE
コンストラクタの概要
ControllerConverterModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID

public static final String ID
関連項目:
定数フィールド値

P_ID_CONVERTER_CLASS

public static final String P_ID_CONVERTER_CLASS
関連項目:
定数フィールド値

P_ID_CONVERTER_PARAM

public static final String P_ID_CONVERTER_PARAM
関連項目:
定数フィールド値

P_ID_PARAM_NAME

public static final String P_ID_PARAM_NAME
関連項目:
定数フィールド値

P_ID_PARAM_VALUE

public static final String P_ID_PARAM_VALUE
関連項目:
定数フィールド値
コンストラクタの詳細

ControllerConverterModel

public ControllerConverterModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DefaultServicePropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス DefaultServicePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler
すべての実装インタフェース:
PropertyHandler, ServicePropertyHandler
public class DefaultServicePropertyHandler
extends Object
implements ServicePropertyHandler

サービスの設定情報に接続するデフォルトのプロパティハンドラです。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「 プレフィックス _ アプリケーションID .properties」です。また、アプリケーションに依存しない「 プレフィックス .properties」があります。
プロパティファイルのプレフィックスは PropertyManager.getPropertyHandlerParams(String) でキーに ServiceManager.SERVICE_PROPERTY_HANDLER_KEY を指定したときに取得されるパラメータのうち DEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスは DEFAULT_BUNDLE_NAME_PARAMで示されるものです。
プロパティの検索順は、アプリケーションごとのプロパティファイル「 プレフィックス _ アプリケーションID .properties」が優先されます。該当するプロパティが見つからない場合、引き続いて「 プレフィックス .properties」を検索します。
プロパティの設定内容は以下のとおりです。 プロパティの設定内容は以下のとおりです。

キー | 内容 | 共通 | アプリケーション毎
client.encoding | クライアントのエンコーディング 設定しない場合、リクエストに対する文字コードの変換は行われません。 | ○ | ×
encoding.attribute | ログインユーザのエンコーディングを保存する属性名 このプロパティは共通のプロパティファイルのみに設定します。 | ○ | ×
client.locale | クライアントのロケール クライアントからのリクエストのロケールのデフォルトです。 | ○ | ×
locale.attribute | ログインユーザのロケールを保存する属性名 このプロパティは共通のプロパティファイルのみに設定します。 | ○ | ×
context.path | 非推奨です。このプロパティは設定しないでください。コンテキストパスの取得はjavax.servlet.http.HttpServletRequestのgetContextPathメソッドを使用してください。 コンテキストパス / コンテキストパス で指定します。 パスの指定は必ず"/"で開始してください。（例：/imart） このプロパティは共通のプロパティファイルのみに設定します。 このプロパティが設定されている場合、im-J2EE Frameworkのタグライブラリを使用したときに遷移するWebアプリケーションが変更されます。 | ○ | ×
servlet.path | ServiceServletにマッピングされているパス（必須） / web.xmlで指定したサーブレットのマッピング で指定します。 パスの指定は必ず"/"で開始してください。（例：/ServiceServlet） このプロパティは共通のプロパティファイルのみに設定します。 | ○ | ×
application.param | アプリケーションIDを引き渡すときに使われる、リクエストのパラメータ名 このプロパティは共通のプロパティファイルのみに設定します。 | ○ | ×
service.param | サービスIDを引き渡すときに使われる、リクエストのパラメータ名 このプロパティは共通のプロパティファイルのみに設定します。 | ○ | ×
exception.attribute | 例外を例外ページに渡すときの属性名 このプロパティは共通のプロパティファイルのみに設定します。 | ○ | ×
controller.class. サービスID | アプリケーションID と サービスID に対応する ServiceControllerのクラス名 | × | ○
transition.class. サービスID | アプリケーションID と サービスID に対応する Transitionのクラス名 | × | ○
nextpage.path. サービスID . キー | アプリケーションID 、 サービスID と キー に対応する次の遷移先のパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） 遷移先を アプリケーションID と サービスID よりも細かく指定したい場合などに使用します。 | × | ○
nextpage.path. サービスID | アプリケーションID と サービスID に対応する次の遷移先のパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
input.error.page.path. サービスID . キー | サービスID と キー に対応する入力エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
input.error.page.path. サービスID | サービスID に対応するデフォルトの入力エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
input.error.page.path | デフォルトの入力エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | ○ | ○
service.error.page.path. サービスID . キー | サービスID と キー に対応するサービス処理エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
service.error.page.path. サービスID | サービスID に対応するデフォルトのサービス処理エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
service.error.page.path | デフォルトのサービス処理エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | ○ | ○
system.error.page.path. サービスID . キー | サービスID と キー に対応するシステム処理エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
system.error.page.path. サービスID | サービスID に対応するデフォルトのシステム処理エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
system.error.page.path | デフォルトのシステム処理エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | ○ | ○

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
インタフェース jp.co.intra_mart.framework.base.service.ServicePropertyHandler から継承したフィールド
DEFAULT_APPLICATION_PARAMETER, DEFAULT_ENCODING_ATTRIBUTE, DEFAULT_EXCEPTION_ATTRIBUTE, DEFAULT_LOCALE_ATTRIBUTE, DEFAULT_SERVICE_PARAMETER, REQUEST_INFO_ATTRIBUTE
コンストラクタの概要
DefaultServicePropertyHandler()
DefaultServicePropertyHandlerを新規に生成します。
メソッドの概要
 String getApplicationParamName()
推奨されていません。 この実装は廃止されました。
 String getClientEncoding()
クライアントのエンコードを取得します。
 Locale getClientLocale()
クライアントのエンコードを取得します。
 String getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 ControllerConverterConfig getControllerConverterConfig(String application, String service, Locale locale)
キーに該当するコントローラコンバータの初期パラメータを取得します。
 String getControllerConverterName(String application, String service, Locale locale)
コントローラコンバータのクラス名を取得します。
 String getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String getInputErrorPagePath()
推奨されていません。 このメソッドではなく getInputErrorPagePath(Locale)を使用してください。
 String getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, Locale) を使用してください。
 String getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, Locale) を使用してください。
 String getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, String, Locale) を使用してください。
 String getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 String getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなく getNextPagePath(String, String, Locale) を使用してください。
 String getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getNextPagePath(String, String, String, Locale) を使用してください。
 String getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなく getServiceControllerName(String, String, Locale) を使用してください。
 String getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String getServiceErrorPagePath()
推奨されていません。 このメソッドではなく getServiceErrorPagePath(Locale) を使用してください。
 String getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceParamName()
推奨されていません。 この実装は廃止されました。
 String getServiceServletPath()
サービスサーブレットのパスを取得します。
 String getSystemErrorPagePath()
推奨されていません。 このメソッドではなく getSystemErrorPagePath(Locale)を使用してください。
 String getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String getTransitionName(String application, String service)
推奨されていません。 このメソッドではなく getTransitionName(String, String, Locale) を使用してください。
 String getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 ValidatorMapping[] getValidators(String application, String service, Locale locale)
キーに該当するバリデータを取得します。
 void init(PropertyParam[] params)
プロパティハンドラを初期化します。
 boolean isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultServicePropertyHandler

public DefaultServicePropertyHandler()
DefaultServicePropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws ServicePropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース ServicePropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
ServicePropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getClientEncoding

public String getClientEncoding()
                         throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientEncoding
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getClientLocale

public Locale getClientLocale()
                       throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientLocale
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String, String)で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String)で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath() で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath() で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath()
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(Locale)を使用してください。

入力例外時のページのパスを取得します。 このメソッドは getInputErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getNextPagePath

public String getNextPagePath(String application,
                              String service)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなく getNextPagePath(String, String, Locale) を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。 このメソッドは getNextPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなく getNextPagePath(String, String, String, Locale) を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。 key が null の場合、 getNextPagePath(String, String) と同じ動作になります。 このメソッドは getNextPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。 key が null の場合、 getNextPagePath(String, String) と同じ動作になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service)
                                throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceControllerName(String, String, Locale) を使用してください。

サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。 このメソッドは getServiceControllerName(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service,
                                       Locale locale)
                                throws ServicePropertyException
サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, String, Locale) を使用してください。

処理例外時のページのパスを取得します。 このメソッドは getServiceErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, Locale) を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath(String)で取得されるページを返します。 このメソッドは getServiceErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, Locale) を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath()で取得されるページを返します。 このメソッドは getServiceErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath()
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(Locale) を使用してください。

処理例外時のページのパスを取得します。 このメソッドは getServiceErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String, String)で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String)で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath()で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath()
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(Locale)を使用してください。

システム例外時のページのパスを取得します。 このメソッドは getSystemErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getTransitionName

public String getTransitionName(String application,
                                String service)
                         throws ServicePropertyException
推奨されていません。 このメソッドではなく getTransitionName(String, String, Locale) を使用してください。

トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。 このメソッドは getTransitionName(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException
トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生
導入されたバージョン:
4.2

getServiceServletPath

public String getServiceServletPath()
                             throws ServicePropertyException
サービスサーブレットのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceServletPath
戻り値:
サービスサーブレットのパス
例外:
ServicePropertyException - サービスサーブレットのパスの取得時に例外が発生

getContextPath

public String getContextPath()
                      throws ServicePropertyException
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。

コンテキストパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getContextPath
戻り値:
コンテキストパス
例外:
ServicePropertyException - コンテキストパスの取得時に例外が発生

getApplicationParamName

public String getApplicationParamName()
                               throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

アプリケーションIDに該当するパラメータ名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_APPLICATION_PARAMETER で定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getApplicationParamName
戻り値:
アプリケーションIDに該当するパラメータ名
例外:
ServicePropertyException - アプリケーションIDに該当するパラメータ名の取得時に例外が発生

getServiceParamName

public String getServiceParamName()
                           throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

サービスIDに該当するパラメータ名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_SERVICE_PARAMETERで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceParamName
戻り値:
サービスIDに該当するパラメータ名
例外:
ServicePropertyException - サービスIDに該当するパラメータ名の取得時に例外が発生

getExceptionAttributeName

public String getExceptionAttributeName()
                                 throws ServicePropertyException
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_EXCEPTION_ATTRIBUTE で定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getExceptionAttributeName
戻り値:
例外の属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getEncodingAttributeName

public String getEncodingAttributeName()
                                throws ServicePropertyException
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_ENCODING_ATTRIBUTEで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getEncodingAttributeName
戻り値:
エンコードの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getLocaleAttributeName

public String getLocaleAttributeName()
                              throws ServicePropertyException
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_LOCALE_ATTRIBUTEで定義されている値を返します 。

定義:
インタフェース ServicePropertyHandler 内の getLocaleAttributeName
戻り値:
ロケールの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生
導入されたバージョン:
4.2

getControllerConverterName

public String getControllerConverterName(String application,
                                         String service,
                                         Locale locale)
                                  throws ServicePropertyException
インタフェース ServicePropertyHandler の記述:
コントローラコンバータのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するコントローラコンバータ名を取得します。 特に設定されていない場合、nullが返ります。

定義:
インタフェース ServicePropertyHandler 内の getControllerConverterName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - コントローラコンバータのクラス名の取得時に例外が発生

getControllerConverterConfig

public ControllerConverterConfig getControllerConverterConfig(String application,
                                                              String service,
                                                              Locale locale)
                                                       throws ServicePropertyException
インタフェース ServicePropertyHandler の記述:
キーに該当するコントローラコンバータの初期パラメータを取得します。

定義:
インタフェース ServicePropertyHandler 内の getControllerConverterConfig
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータの初期パラメータ
例外:
ServicePropertyException - コントローラコンバータの初期パラメータの取得に失敗

getValidators

public ValidatorMapping[] getValidators(String application,
                                        String service,
                                        Locale locale)
                                 throws ServicePropertyException
インタフェース ServicePropertyHandler の記述:
キーに該当するバリデータを取得します。

定義:
インタフェース ServicePropertyHandler 内の getValidators
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータの初期パラメータ
例外:
ServicePropertyException - バリデータの取得に失敗
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart 6.1.14
 前のクラス   次のクラス フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド 詳細:  フィールド | コンストラクタ | メソッド


DefaultTransition (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス DefaultTransition

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.Transition
        拡張 jp.co.intra_mart.framework.base.service.DefaultTransition
public class DefaultTransition
extends Transition

デフォルトの画面遷移をします。

バージョン:
1.0

コンストラクタの概要
DefaultTransition()
DefaultTransitionを新規に生成します。
メソッドの概要
String | getInputErrorPage(RequestException e) 入力エラーのページを取得します。
String | getNextPage() 次に遷移するページを取得します。
String | getServiceErrorPage(Exception e) 処理エラーのページを取得します。
String | getSystemErrorPage(Exception e) システムエラーのページを取得します。
void | setInformation() 次の遷移先に渡す情報を設定します。
void | transfer() 次のページに遷移します。
クラス jp.co.intra_mart.framework.base.service.Transition から継承したメソッド
getApplication, getEntity, getNextPagePath, getNextPagePath, getRequest, getResponse, getResult, getService, getServiceManager, getSessionObject, setRequest, setResponse, setResult, setServiceManager
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DefaultTransition

public DefaultTransition()
DefaultTransitionを新規に生成します。

メソッドの詳細

getInputErrorPage

public String getInputErrorPage(RequestException e)
                         throws ServicePropertyException,
                                TransitionException
入力エラーのページを取得します。

定義:
クラス Transition 内の getInputErrorPage
パラメータ:
e - 例外
戻り値:
入力エラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getSystemErrorPage

public String getSystemErrorPage(Exception e)
                          throws ServicePropertyException,
                                 TransitionException
システムエラーのページを取得します。

定義:
クラス Transition 内の getSystemErrorPage
パラメータ:
e - 処理時の例外
戻り値:
システムエラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getServiceErrorPage

public String getServiceErrorPage(Exception e)
                           throws ServicePropertyException,
                                  TransitionException
処理エラーのページを取得します。

定義:
クラス Transition 内の getServiceErrorPage
パラメータ:
e - 処理時の例外
戻り値:
処理エラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

setInformation

public void setInformation()
                    throws TransitionException
次の遷移先に渡す情報を設定します。 このクラスでは何も行いません。

定義:
クラス Transition 内の setInformation
例外:
TransitionException - 情報設定時に例外が発生

getNextPage

public String getNextPage()
                   throws ServicePropertyException,
                          TransitionException
次に遷移するページを取得します。

定義:
クラス Transition 内の getNextPage
戻り値:
次に遷移するページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

transfer

public void transfer()
              throws SystemException
次のページに遷移します。 getNextPage()で取得されるページにforwardされます。

定義:
クラス Transition 内の transfer
例外:
SystemException - システム例外が発生
導入されたバージョン:
3.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DistributesServicePropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス DistributesServicePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler
すべての実装インタフェース:
PropertyHandler, ServicePropertyHandler
public class DistributesServicePropertyHandler
extends Object
implements ServicePropertyHandler

アプリケーションごとに異なるサービスプロパティハンドラを使用するサービスプロパティハンドラです。
通常時に使用されるサービスプロパティハンドラは default.class で示されるパラメータ名で指定します。 ここで指定されるサービスプロパティハンドラに渡す初期値は、 default.param.パラメータ名 で示されるパラメータ名で指定します。 ある特定のアプリケーションに対して特定のサービスプロパティハンドラを割り当てたい場合、 application.class.アプリケーションID で示されるパラメータ名で指定します。 ここで指定されるサービスプロパティハンドラに渡す初期値は、 application.param.アプリケーションID.パラメータ名 で示されるパラメータ名で指定します。 ファイルが存在するディレクトリ名は PARAM_FILE_DIRで示されるパラメータ名で指定します。
PARAM_DYNAMICで示されるパラメータにtrueを指定した場合 アプリケーション実行時にもプロパティの変更を動的に反映させることが可能となりますが、 パラメータの取得時に毎回ファイル操作を行うためパフォーマンスに悪影響を与える可能性があります。 このオプションは、開発時やデバッグ時のようにパラメータを頻繁に変更する必要がある場合のみtrueとし、 通常はfalseに設定しておいてください。

導入されたバージョン:
5.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
static String | PARAM_APPLICATION アプリケーション
static String | PARAM_APPLICATION_CLASS クラス
static String | PARAM_APPLICATION_PARAM パラメータ
static String | PARAM_BUNDLE プロパティファイルのバンドルのパラメータ名
static String | PARAM_DEFAULT デフォルト
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
インタフェース jp.co.intra_mart.framework.base.service.ServicePropertyHandler から継承したフィールド
DEFAULT_APPLICATION_PARAMETER, DEFAULT_ENCODING_ATTRIBUTE, DEFAULT_EXCEPTION_ATTRIBUTE, DEFAULT_LOCALE_ATTRIBUTE, DEFAULT_SERVICE_PARAMETER, REQUEST_INFO_ATTRIBUTE
コンストラクタの概要
DistributesServicePropertyHandler()
DefaultServicePropertyHandlerを新規に生成します。
メソッドの概要
 String getApplicationParamName()
アプリケーションIDに該当するパラメータ名を取得します。
 String getClientEncoding()
クライアントのエンコードを取得します。
 Locale getClientLocale()
クライアントのエンコードを取得します。
 String getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 ControllerConverterConfig getControllerConverterConfig(String application, String service, Locale locale)
キーに該当するコントローラコンバータの初期パラメータを取得します。
 String getControllerConverterName(String application, String service, Locale locale)
コントローラコンバータのクラス名を取得します。
 String getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String getInputErrorPagePath()
推奨されていません。 このメソッドではなく getInputErrorPagePath(Locale)を使用してください。
 String getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, Locale) を使用してください。
 String getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, Locale) を使用してください。
 String getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, String, Locale) を使用してください。
 String getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 String getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなく getNextPagePath(String, String, Locale) を使用してください。
 String getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getNextPagePath(String, String, String, Locale) を使用してください。
 String getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなく getServiceControllerName(String, String, Locale) を使用してください。
 String getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String getServiceErrorPagePath()
推奨されていません。 このメソッドではなく getServiceErrorPagePath(Locale) を使用してください。
 String getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceParamName()
サービスIDに該当するパラメータ名を取得します。
 String getServiceServletPath()
サービスサーブレットのパスを取得します。
 String getSystemErrorPagePath()
推奨されていません。 このメソッドではなく getSystemErrorPagePath(Locale)を使用してください。
 String getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String getTransitionName(String application, String service)
推奨されていません。 このメソッドではなく getTransitionName(String, String, Locale) を使用してください。
 String getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 ValidatorMapping[] getValidators(String application, String service, Locale locale)
キーに該当するバリデータを取得します。
 void init(PropertyParam[] params)
プロパティハンドラを初期化します。
 boolean isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値

PARAM_DEFAULT

public static final String PARAM_DEFAULT
デフォルト

関連項目:
定数フィールド値

PARAM_APPLICATION

public static final String PARAM_APPLICATION
アプリケーション

関連項目:
定数フィールド値

PARAM_APPLICATION_PARAM

public static final String PARAM_APPLICATION_PARAM
パラメータ

関連項目:
定数フィールド値

PARAM_APPLICATION_CLASS

public static final String PARAM_APPLICATION_CLASS
クラス

関連項目:
定数フィールド値

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値

PARAM_BUNDLE

public static final String PARAM_BUNDLE
プロパティファイルのバンドルのパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DistributesServicePropertyHandler

public DistributesServicePropertyHandler()
DefaultServicePropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws ServicePropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース ServicePropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
ServicePropertyException - チェック時に例外が発生

getClientEncoding

public String getClientEncoding()
                         throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientEncoding
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getClientLocale

public Locale getClientLocale()
                       throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientLocale
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String, String)で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String)で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath() で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath() で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath()
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(Locale)を使用してください。

入力例外時のページのパスを取得します。 このメソッドは getInputErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなく getNextPagePath(String, String, Locale) を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。 このメソッドは getNextPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなく getNextPagePath(String, String, String, Locale) を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。 key が null の場合、 getNextPagePath(String, String) と同じ動作になります。 このメソッドは getNextPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。 key が null の場合、 getNextPagePath(String, String) と同じ動作になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service)
                                throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceControllerName(String, String, Locale) を使用してください。

サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。 このメソッドは getServiceControllerName(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service,
                                       Locale locale)
                                throws ServicePropertyException
サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, String, Locale) を使用してください。

処理例外時のページのパスを取得します。 このメソッドは getServiceErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, Locale) を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath(String)で取得されるページを返します。 このメソッドは getServiceErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, Locale) を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath()で取得されるページを返します。 このメソッドは getServiceErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath()
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(Locale) を使用してください。

処理例外時のページのパスを取得します。 このメソッドは getServiceErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String, String)で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String)で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath()で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath()
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(Locale)を使用してください。

システム例外時のページのパスを取得します。 このメソッドは getSystemErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service)
                         throws ServicePropertyException
推奨されていません。 このメソッドではなく getTransitionName(String, String, Locale) を使用してください。

トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。 このメソッドは getTransitionName(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException
トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getServiceServletPath

public String getServiceServletPath()
                             throws ServicePropertyException
サービスサーブレットのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceServletPath
戻り値:
サービスサーブレットのパス
例外:
ServicePropertyException - サービスサーブレットのパスの取得時に例外が発生

getContextPath

public String getContextPath()
                      throws ServicePropertyException
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。

コンテキストパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getContextPath
戻り値:
コンテキストパス
例外:
ServicePropertyException - コンテキストパスの取得時に例外が発生

getApplicationParamName

public String getApplicationParamName()
                               throws ServicePropertyException
アプリケーションIDに該当するパラメータ名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_APPLICATION_PARAMETER で定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getApplicationParamName
戻り値:
アプリケーションIDに該当するパラメータ名
例外:
ServicePropertyException - アプリケーションIDに該当するパラメータ名の取得時に例外が発生

getServiceParamName

public String getServiceParamName()
                           throws ServicePropertyException
サービスIDに該当するパラメータ名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_SERVICE_PARAMETERで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceParamName
戻り値:
サービスIDに該当するパラメータ名
例外:
ServicePropertyException - サービスIDに該当するパラメータ名の取得時に例外が発生

getExceptionAttributeName

public String getExceptionAttributeName()
                                 throws ServicePropertyException
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_EXCEPTION_ATTRIBUTE で定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getExceptionAttributeName
戻り値:
例外の属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getEncodingAttributeName

public String getEncodingAttributeName()
                                throws ServicePropertyException
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_ENCODING_ATTRIBUTEで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getEncodingAttributeName
戻り値:
エンコードの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getLocaleAttributeName

public String getLocaleAttributeName()
                              throws ServicePropertyException
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_LOCALE_ATTRIBUTEで定義されている値を返します 。

定義:
インタフェース ServicePropertyHandler 内の getLocaleAttributeName
戻り値:
ロケールの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getControllerConverterName

public String getControllerConverterName(String application,
                                         String service,
                                         Locale locale)
                                  throws ServicePropertyException
インタフェース ServicePropertyHandler の記述:
コントローラコンバータのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するコントローラコンバータ名を取得します。 特に設定されていない場合、nullが返ります。

定義:
インタフェース ServicePropertyHandler 内の getControllerConverterName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - コントローラコンバータのクラス名の取得時に例外が発生

getControllerConverterConfig

public ControllerConverterConfig getControllerConverterConfig(String application,
                                                              String service,
                                                              Locale locale)
                                                       throws ServicePropertyException
インタフェース ServicePropertyHandler の記述:
キーに該当するコントローラコンバータの初期パラメータを取得します。

定義:
インタフェース ServicePropertyHandler 内の getControllerConverterConfig
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータの初期パラメータ
例外:
ServicePropertyException - コントローラコンバータの初期パラメータの取得に失敗

getValidators

public ValidatorMapping[] getValidators(String application,
                                        String service,
                                        Locale locale)
                                 throws ServicePropertyException
インタフェース ServicePropertyHandler の記述:
キーに該当するバリデータを取得します。

定義:
インタフェース ServicePropertyHandler 内の getValidators
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータの初期パラメータ
例外:
ServicePropertyException - バリデータの取得に失敗
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart 6.1.14
 前のクラス   次のクラス フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド 詳細:  フィールド | コンストラクタ | メソッド


EmptyServiceResult (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス EmptyServiceResult

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.EmptyServiceResult
すべての実装インタフェース:
ServiceResult
public class EmptyServiceResult
extends Object
implements ServiceResult

情報を何も持たないServiceResultの実装です。

導入されたバージョン:
6.0
バージョン:
1.0

コンストラクタの概要
EmptyServiceResult()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EmptyServiceResult

public EmptyServiceResult()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EncodingFilter (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス EncodingFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.EncodingFilter
すべての実装インタフェース:
Filter
public class EncodingFilter
extends Object
implements Filter

リクエストのエンコードを設定します。 リクエストに対するエンコードは

  1. ServicePropertyHandler.getClientEncoding()で取得されるもの
  2. ServiceManager.getLocale(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)
の順位で決定されます。

この時に取得されたエンコードはServletRequest.setCharacterEncoding(java.lang.String)に設定され、 さらにHttpSessionが存在すればその中にも設定されます。この場合の属性名はServicePropertyHandler.getEncodingAttributeName()で取得されるものです。

バージョン:
1.0

コンストラクタの概要
EncodingFilter()
メソッドの概要
void | destroy() フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) リクエストのエンコードを設定します。
void | init(FilterConfig filterConfig) エンコーディング用のフィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EncodingFilter

public EncodingFilter()
メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
エンコーディング用のフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
リクエストのエンコードを設定します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FileUploadFilter (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス FileUploadFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.FileUploadFilter
すべての実装インタフェース:
Filter
public class FileUploadFilter
extends Object
implements Filter

ファイルアップロード用にリクエストを変換するフィルタです。 このフィルタは受け取ったリクエストが以下の条件をすべて満たす場合にServiceControllerAdapter.getEntity(String)でアップロードされた内容が取得できるようにします。

  • メソッドが"POST"である
  • ContentTypeが"multipart/form-data"である

    導入されたバージョン:
    3.2

    コンストラクタの概要
    FileUploadFilter()
    メソッドの概要
     void destroy()
    フィルタを破棄します。
     void doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain)
    リクエストの内容がファイルアップロードを含むかどうかによってリクエストを選択します。
     void init(FilterConfig filterConfig)
    ファイルアップロード用のフィルタを初期化します。
    クラス java.lang.Object から継承したメソッド
    clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    コンストラクタの詳細

    FileUploadFilter

    public FileUploadFilter()
    メソッドの詳細

    init

    public void init(FilterConfig filterConfig)
          throws ServletException
    ファイルアップロード用のフィルタを初期化します。

    定義:
    インタフェース Filter 内の init
    パラメータ:
    filterConfig - FilterConfig
    例外:
    ServletException - フィルタ内で例外が発生

    doFilter

    public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
    リクエストの内容がファイルアップロードを含むかどうかによってリクエストを選択します。

    定義:
    インタフェース Filter 内の doFilter
    パラメータ:
    servletRequest - リクエスト
    servletResponse - レスポンス
    filterChain - フィルタ
    例外:
    IOException - フィルタ処理実行時にIOExceptionが発生
    ServletException - フィルタ処理実行時にServletExceptionが発生

    destroy

    public void destroy()
    フィルタを破棄します。

    定義:
    インタフェース Filter 内の destroy
    概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
            intra-mart 6.1.14
    前のクラス 次のクラス フレームあり フレームなし
    概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FrameworkParameterSettingFilter (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス FrameworkParameterSettingFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter
すべての実装インタフェース:
Filter
推奨されていません。 このフィルタは下位互換のためのフィルタです。将来廃止される可能性があります。

public class FrameworkParameterSettingFilter
extends Object
implements Filter

以前のバージョンのサービスフレームワークが使用していたアプリケーションID及びサービスIDを リクエストのパラメータに設定します。
このフィルタを使用することによりServletRequest.getParameter(String)から アプリケーションID及びサービスIDを取得することができますが、この方法は正しくありません。
正しくは以下のメソッドを使用してください。

ServiceManager.getApplication(HttpServletRequest, HttpServletResponse)
ServiceManager.getService(HttpServletRequest, HttpServletResponse)

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
FrameworkParameterSettingFilter()
推奨されていません。
メソッドの概要
void | destroy() 推奨されていません。 フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) 推奨されていません。 リクエストのパラメーターを設定後、次の処理に遷移します。
void | init(FilterConfig filterConfig) 推奨されていません。 フィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FrameworkParameterSettingFilter

public FrameworkParameterSettingFilter()
推奨されていません。
メソッドの詳細

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws ServletException,
                     IOException
推奨されていません。
リクエストのパラメーターを設定後、次の処理に遷移します。
パラメータ名は以下のメソッドから取得したものを使用します。
ServicePropertyHandler.getApplicationParamName()
ServicePropertyHandler.getServiceParamName()

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタのチェーン
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

init

public void init(FilterConfig filterConfig)
          throws ServletException
推奨されていません。
フィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - フィルタ設定オブジェクト
例外:
ServletException - フィルタを初期化時に例外が発生。

destroy

public void destroy()
推奨されていません。
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartConnectFilter (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス IntramartConnectFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.IntramartConnectFilter
すべての実装インタフェース:
Filter
推奨されていません。 この機能は廃止されました。

public class IntramartConnectFilter
extends Object
implements Filter

intra-martのページベースの画面からim-J2EE Frameworkの画面に遷移する時に使うフィルタです。 intra-martから来るリクエストをim-J2EE Frameworkで扱う形式に変換します。 このフィルタで変換されたリクエストはServiceServletで扱えるようになります。

このフィルタは以下の初期化パラメータを設定することができます。

パラメータ名 | パラメータの値
referrerFormat | セッションに登録されるintramartのページベースへの画面に戻るためのURLの書式を決定します。 short（大文字と小文字は区別しない）：URLからプロトコル、ホスト名、ポート番号が省略された形式をセッションに登録 それ以外：パラメータreferrerの内容をそのままセッションに登録
securityExt | セキュリティの有効／無効を設定する拡張子です。 このパラメータが設定されるとセキュリティが有効になります。 ServiceServletに対するURLマッピングは*.拡張子とする必要があります。 拡張子（ドットは含まない）

導入されたバージョン:
4.2

フィールドの概要
static String | INTRAMART_URL_NAME 推奨されていません。 セッションに登録するintra-martのサーブレットのURLの属性名
static String | PARAM_ARGUMENT 推奨されていません。 ページ引数のリクエストパラメータ名
static String | PARAM_ARGUMENT_DELIMITER 推奨されていません。 ページ引数のデリミタ
static String | PARAM_ARGUMENT_OPERATOR 推奨されていません。 ページ引数の演算子
static String | PARAM_LOGIN_GROUP_ID 推奨されていません。 ログイングループIDのリクエストパラメータ名
static String | PARAM_LOGIN_USER_ID 推奨されていません。 ログインユーザIDのリクエストパラメータ名
static String | PARAM_REFERER 推奨されていません。 参照元URLのリクエストパラメータ名
static String | PARAM_SECURITY_EXT 推奨されていません。 セキュリティの拡張子
コンストラクタの概要
IntramartConnectFilter()
推奨されていません。
メソッドの概要
void | destroy() 推奨されていません。 フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) 推奨されていません。 intra-martから来るリクエストをim-J2EE Frameworkで扱う形式に変換します。
String | getSecurityExt() 推奨されていません。 セキュリティの拡張子を取得します。
void | init(FilterConfig filterConfig) 推奨されていません。 このフィルタを初期化します。
void | setSecurityExt(String securityExt) 推奨されていません。 セキュリティの拡張子を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_LOGIN_USER_ID

public static final String PARAM_LOGIN_USER_ID
推奨されていません。
ログインユーザIDのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_LOGIN_GROUP_ID

public static final String PARAM_LOGIN_GROUP_ID
推奨されていません。
ログイングループIDのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_ARGUMENT

public static final String PARAM_ARGUMENT
推奨されていません。
ページ引数のリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_REFERER

public static final String PARAM_REFERER
推奨されていません。
参照元URLのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_ARGUMENT_DELIMITER

public static final String PARAM_ARGUMENT_DELIMITER
推奨されていません。
ページ引数のデリミタ

関連項目:
定数フィールド値

PARAM_ARGUMENT_OPERATOR

public static final String PARAM_ARGUMENT_OPERATOR
推奨されていません。
ページ引数の演算子

関連項目:
定数フィールド値

INTRAMART_URL_NAME

public static final String INTRAMART_URL_NAME
推奨されていません。
セッションに登録するintra-martのサーブレットのURLの属性名

関連項目:
定数フィールド値

PARAM_SECURITY_EXT

public static final String PARAM_SECURITY_EXT
推奨されていません。
セキュリティの拡張子

導入されたバージョン:
4.3
関連項目:
定数フィールド値
コンストラクタの詳細

IntramartConnectFilter

public IntramartConnectFilter()
推奨されていません。
メソッドの詳細

getSecurityExt

public String getSecurityExt()
推奨されていません。
セキュリティの拡張子を取得します。

戻り値:
セキュリティの拡張子

setSecurityExt

public void setSecurityExt(String securityExt)
推奨されていません。
セキュリティの拡張子を設定します。

パラメータ:
securityExt - セキュリティの拡張子

init

public void init(FilterConfig filterConfig)
          throws ServletException
推奨されていません。
このフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
推奨されていません。
intra-martから来るリクエストをim-J2EE Frameworkで扱う形式に変換します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタチェイン
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
推奨されていません。
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartConnectServlet (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス IntramartConnectServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.framework.base.service.IntramartConnectServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
推奨されていません。 この機能は廃止されました。

public class IntramartConnectServlet
extends HttpServlet

intra-martのページベースの画面からJ2EEベースの画面に遷移する時に使うサーブレットです。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
static String | INTRAMART_URL_NAME 推奨されていません。 このパラメータではなくIntramartConnectFilter.INTRAMART_URL_NAMEを使用してください。
static String | PARAM_ARGUMENT 推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENTを使用してください。
static String | PARAM_ARGUMENT_DELIMITER 推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_DELIMITERを使用してください。
static String | PARAM_ARGUMENT_OPERATOR 推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_OPERATORを使用してください。
static String | PARAM_LOGIN_GROUP_ID 推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_GROUP_IDを使用してください。
static String | PARAM_LOGIN_USER_ID 推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_USER_IDを使用してください。
static String | PARAM_REFERER 推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_REFERERを使用してください。
コンストラクタの概要
IntramartConnectServlet()
推奨されていません。 IntramartConnectServletを新規に生成します。
メソッドの概要
protected void | doGet(HttpServletRequest request, HttpServletResponse response) 推奨されていません。 GETメソッドに対応します。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) 推奨されていません。 POSTメソッドに対応します。
protected void | execute(HttpServletRequest request, HttpServletResponse response) 推奨されていません。 intra-martベースモジュールのメニューからのリクエストを受け付けます。
protected ServiceManager | getServiceManager() 推奨されていません。 サービスマネージャを取得します。
protected ServicePropertyHandler | getServicePropertyHandler() 推奨されていません。 サービスプロパティハンドラを取得します。
protected SessionManager | getSessionManager() 推奨されていません。 セッションマネージャを取得します。
protected SessionPropertyHandler | getSessionPropertyHandler() 推奨されていません。 セッションプロパティハンドラを取得します。
void | init(ServletConfig servletConfig) 推奨されていません。 このサーブレットを初期化します。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
destroy, getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_LOGIN_USER_ID

public static final String PARAM_LOGIN_USER_ID
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_USER_IDを使用してください。

ログインユーザIDのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_LOGIN_GROUP_ID

public static final String PARAM_LOGIN_GROUP_ID
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_GROUP_IDを使用してください。

ログイングループIDのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_ARGUMENT

public static final String PARAM_ARGUMENT
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENTを使用してください。

ページ引数のリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_REFERER

public static final String PARAM_REFERER
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_REFERERを使用してください。

参照元URLのリクエストパラメータ名

導入されたバージョン:
3.2
関連項目:
定数フィールド値

PARAM_ARGUMENT_DELIMITER

public static final String PARAM_ARGUMENT_DELIMITER
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_DELIMITERを使用してください。

ページ引数のデリミタ

関連項目:
定数フィールド値

PARAM_ARGUMENT_OPERATOR

public static final String PARAM_ARGUMENT_OPERATOR
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_OPERATORを使用してください。

ページ引数の演算子

関連項目:
定数フィールド値

INTRAMART_URL_NAME

public static final String INTRAMART_URL_NAME
推奨されていません。 このパラメータではなくIntramartConnectFilter.INTRAMART_URL_NAMEを使用してください。

セッションに登録するintra-martのサーブレットのURLの属性名 （この値はVersion 4.0から変更されています）

導入されたバージョン:
3.2
関連項目:
定数フィールド値
コンストラクタの詳細

IntramartConnectServlet

public IntramartConnectServlet()
推奨されていません。
IntramartConnectServletを新規に生成します。

メソッドの詳細

getServiceManager

protected ServiceManager getServiceManager()
推奨されていません。
サービスマネージャを取得します。

戻り値:
サービスマネージャ

getServicePropertyHandler

protected ServicePropertyHandler getServicePropertyHandler()
推奨されていません。
サービスプロパティハンドラを取得します。

戻り値:
サービスプロパティハンドラ

getSessionManager

protected SessionManager getSessionManager()
推奨されていません。
セッションマネージャを取得します。

戻り値:
セッションマネージャ

getSessionPropertyHandler

protected SessionPropertyHandler getSessionPropertyHandler()
推奨されていません。
セッションプロパティハンドラを取得します。

戻り値:
セッションプロパティハンドラ

init

public void init(ServletConfig servletConfig)
          throws ServletException
推奨されていません。
このサーブレットを初期化します。

パラメータ:
servletConfig - Servlet Config
例外:
ServletException - 初期化時に例外が発生

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
推奨されていません。
GETメソッドに対応します。 詳細はexecute(HttpServletRequest, HttpServletResponse)を参照してください。

パラメータ:
request - リクエスト
response - レスポンス
例外:
ServletException - サーブレット例外が発生
IOException - 入出力例外が発生

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
推奨されていません。
POSTメソッドに対応します。 詳細はexecute(HttpServletRequest, HttpServletResponse)を参照してください。

パラメータ:
request - リクエスト
response - レスポンス
例外:
ServletException - サーブレット例外が発生
IOException - 入出力例外が発生

execute

protected void execute(HttpServletRequest request,
                       HttpServletResponse response)
                throws ServletException,
                       IOException
推奨されていません。
intra-martベースモジュールのメニューからのリクエストを受け付けます。 ページ引数に以下の情報を含める必要があります。
application=<アプリケーションＩＤ>,service=<サービスＩＤ>

パラメータ:
request - リクエスト
response - レスポンス
例外:
ServletException - サーブレット例外が発生
IOException - 入出力例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartLocaleFilter (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス IntramartLocaleFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.IntramartLocaleFilter
すべての実装インタフェース:
Filter
public class IntramartLocaleFilter
extends Object
implements Filter

セッションにロケールを設定します。
ロケールはクライアントの保持するアクセスセキュリティ情報が優先されます。

アクセスセキュリティ情報からロケールを取得できない場合はServiceManager.getLocale(HttpServletRequest, HttpServletResponse) から取得した値が設定されます。

この時に取得されたロケールはHttpSessionが存在すればその中に設定されます。この場合の属性名はServicePropertyHandler.getLocaleAttributeName()で取得されるものです。

導入されたバージョン:
5.0

コンストラクタの概要
IntramartLocaleFilter()
メソッドの概要
void | destroy() フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) リクエストのロケールを設定します。
void | init(FilterConfig filterConfig) ロケール用のフィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartLocaleFilter

public IntramartLocaleFilter()
メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
ロケール用のフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
リクエストのロケールを設定します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartPageBaseTransition (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス IntramartPageBaseTransition

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.Transition
        拡張 jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition
public class IntramartPageBaseTransition
extends Transition

ページベースの画面に遷移する場合に使用するトランジションです。

導入されたバージョン:
3.2

コンストラクタの概要
IntramartPageBaseTransition()
IntramartPageBaseTransitionを新規に生成します。
メソッドの概要
String | getInputErrorPage(RequestException e) 入力エラーのページを取得します。
String | getNextPage() 次に遷移するページを取得します。
String | getServiceErrorPage(Exception e) 処理エラーのページを取得します。
String | getSystemErrorPage(Exception e) システムエラーのページを取得します。
void | setInformation() 次の遷移先に渡す情報を設定します。
void | transfer() ページベースの画面に遷移します。
クラス jp.co.intra_mart.framework.base.service.Transition から継承したメソッド
getApplication, getEntity, getNextPagePath, getNextPagePath, getRequest, getResponse, getResult, getService, getServiceManager, getSessionObject, setRequest, setResponse, setResult, setServiceManager
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartPageBaseTransition

public IntramartPageBaseTransition()
IntramartPageBaseTransitionを新規に生成します。

メソッドの詳細

getInputErrorPage

public String getInputErrorPage(RequestException e)
                         throws ServicePropertyException,
                                TransitionException
入力エラーのページを取得します。

定義:
クラス Transition 内の getInputErrorPage
パラメータ:
e - 入力時の例外
戻り値:
入力エラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getServiceErrorPage

public String getServiceErrorPage(Exception e)
                           throws ServicePropertyException,
                                  TransitionException
処理エラーのページを取得します。

定義:
クラス Transition 内の getServiceErrorPage
パラメータ:
e - 処理時の例外
戻り値:
処理エラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getSystemErrorPage

public String getSystemErrorPage(Exception e)
                          throws ServicePropertyException,
                                 TransitionException
システムエラーのページを取得します。

定義:
クラス Transition 内の getSystemErrorPage
パラメータ:
e - 処理時の例外
戻り値:
システムエラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getNextPage

public String getNextPage()
                   throws ServicePropertyException,
                          TransitionException
次に遷移するページを取得します。

定義:
クラス Transition 内の getNextPage
戻り値:
次に遷移するページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

setInformation

public void setInformation()
                    throws TransitionException
次の遷移先に渡す情報を設定します。

定義:
クラス Transition 内の setInformation
例外:
TransitionException - 情報設定時に例外が発生

transfer

public void transfer()
              throws SystemException
ページベースの画面に遷移します。 遷移する方法は次のページで要求される形式に依存します。

定義:
クラス Transition 内の transfer
例外:
SystemException - システム例外が発生
導入されたバージョン:
3.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LocaleFilter (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス LocaleFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.LocaleFilter
すべての実装インタフェース:
Filter
public class LocaleFilter
extends Object
implements Filter

リクエストのロケールを設定します。 リクエストに対するロケールの決定方法はServiceManager.getLocale(HttpServletRequest, HttpServletResponse)と同じです。

この時に取得されたロケールはHttpSessionが存在すればその中に設定されます。この場合の属性名はServicePropertyHandler.getLocaleAttributeName()で取得されるものです。

導入されたバージョン:
4.2

コンストラクタの概要
LocaleFilter()
メソッドの概要
void | destroy() フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) リクエストのロケールを設定します。
void | init(FilterConfig filterConfig) ロケール用のフィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LocaleFilter

public LocaleFilter()
メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
ロケール用のフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
リクエストのロケールを設定します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.service (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.base.service
インタフェース
RequestInfo
ServiceController
ServicePropertyHandler
ServiceResult
クラス
ControllerConverterModel
DefaultServicePropertyHandler
DefaultTransition
DistributesServicePropertyHandler
EmptyServiceResult
EncodingFilter
FileUploadFilter
FrameworkParameterSettingFilter
IntramartConnectFilter
IntramartConnectServlet
IntramartLocaleFilter
IntramartPageBaseTransition
LocaleFilter
ServiceControllerAdapter
ServiceManager
ServiceSecurityFilter
ServiceServlet
TextFileServicePropertyHandler
Transition
ValidatorMapping
ValidatorModel
XmlServicePropertyHandler
例外
RequestException
ServiceControllerException
ServiceManagerException
ServicePropertyException
ServiceServletException
TransitionException


jp.co.intra_mart.framework.base.service (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.service

サービスフレームワークに関連するクラスのパッケージです。

参照:
説明

インタフェースの概要
RequestInfo | リクエストに対する情報を取得します。
ServiceController | クライアントからの入力に対する処理を行います。
ServicePropertyHandler | サービスの設定情報に接続するクラスです。
ServiceResult | サービスの処理結果です。

クラスの概要
ControllerConverterModel | コントローラコンバータ情報を管理するクラスです。
DefaultServicePropertyHandler | サービスの設定情報に接続するデフォルトのプロパティハンドラです。
DefaultTransition | デフォルトの画面遷移をします。
DistributesServicePropertyHandler | アプリケーションごとに異なるサービスプロパティハンドラを使用するサービスプロパティハンドラです。
EmptyServiceResult | 情報を何も持たないServiceResultの実装です。
EncodingFilter | リクエストのエンコードを設定します。
FileUploadFilter | ファイルアップロード用にリクエストを変換するフィルタです。
FrameworkParameterSettingFilter | 推奨されていません。 このフィルタは下位互換のためのフィルタです。
IntramartConnectFilter | 推奨されていません。 この機能は廃止されました。
IntramartConnectServlet | 推奨されていません。 この機能は廃止されました。
IntramartLocaleFilter | セッションにロケールを設定します。
IntramartPageBaseTransition | ページベースの画面に遷移する場合に使用するトランジションです。
LocaleFilter | リクエストのロケールを設定します。
ServiceControllerAdapter | いくつかのユーティリティメソッドと空のメソッドを実装したサービスコントローラです。
ServiceManager | サービスマネージャです。
ServiceSecurityFilter | intra-mart画面を表示するURLの詐称をチェックするためのフィルタです。
ServiceServlet | サービスを振り分けるサーブレットです。
TextFileServicePropertyHandler | 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
Transition | 画面遷移に関連するクラスのインタフェースです。
ValidatorMapping | バリデータの設定を保持します。
ValidatorModel | バリデータ情報を管理するクラスです。
XmlServicePropertyHandler | サービスの設定情報に接続するプロパティハンドラです。

例外の概要
RequestException | リクエストの内容に関連する間違いがある場合の例外です。
ServiceControllerException | サービスコントローラに関連する例外です。
ServiceManagerException | サービスマネージャ設定時の例外です。
ServicePropertyException | サービスプロパティ取得時の例外です。
ServiceServletException | サービスに関連する例外です。
TransitionException | トランジションに関連する例外です。

パッケージ jp.co.intra_mart.framework.base.service の説明

サービスフレームワークに関連するクラスのパッケージです。 画面からのアクション（Submit、リンク等）に対して処理や画面遷移の制御をします。


jp.co.intra_mart.framework.base.service クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.service の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.service.ControllerConverterModel
    • class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class jp.co.intra_mart.framework.base.service.EmptyServiceResult (implements jp.co.intra_mart.framework.base.service.ServiceResult)
    • class jp.co.intra_mart.framework.base.service.EncodingFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.service.FileUploadFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter (implements javax.servlet.Filter)
    • class javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • class javax.servlet.http.HttpServlet (implements java.io.Serializable)
        • class jp.co.intra_mart.framework.base.service.IntramartConnectServlet
        • class jp.co.intra_mart.framework.base.service.ServiceServlet
    • class jp.co.intra_mart.framework.base.service.IntramartConnectFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.service.LocaleFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter (implements jp.co.intra_mart.framework.base.service.ServiceController)
    • class jp.co.intra_mart.framework.base.service.ServiceManager
    • class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.ApplicationException
            • class jp.co.intra_mart.framework.base.service.RequestException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.service.ServiceControllerException
            • class jp.co.intra_mart.framework.base.service.ServiceManagerException
            • class jp.co.intra_mart.framework.base.service.ServicePropertyException
            • class jp.co.intra_mart.framework.base.service.ServiceServletException
            • class jp.co.intra_mart.framework.base.service.TransitionException
    • class jp.co.intra_mart.framework.base.service.Transition
      • class jp.co.intra_mart.framework.base.service.DefaultTransition
      • class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition
    • class jp.co.intra_mart.framework.base.service.ValidatorMapping
    • class jp.co.intra_mart.framework.base.service.ValidatorModel
    • class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)

インタフェース階層

  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler
  • interface jp.co.intra_mart.framework.base.service.RequestInfo
  • interface jp.co.intra_mart.framework.base.service.ServiceController
  • interface jp.co.intra_mart.framework.base.service.ServiceResult


パッケージ jp.co.intra_mart.framework.base.service の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.service の使用

jp.co.intra_mart.framework.base.service を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.container |
jp.co.intra_mart.framework.base.service.controller | 入力情報に関連するパッケージです。
jp.co.intra_mart.framework.base.service.validator | 検証に関連するパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.base.service のクラス
RequestException
リクエストの内容に関連する間違いがある場合の例外です。
RequestInfo
リクエストに対する情報を取得します。
ServiceController
クライアントからの入力に対する処理を行います。
ServiceControllerException
サービスコントローラに関連する例外です。
ServiceManager
サービスマネージャです。
ServiceManagerException
サービスマネージャ設定時の例外です。
ServicePropertyException
サービスプロパティ取得時の例外です。
ServicePropertyHandler
サービスの設定情報に接続するクラスです。
ServiceResult
サービスの処理結果です。
Transition
画面遷移に関連するクラスのインタフェースです。
TransitionException
トランジションに関連する例外です。
ValidatorMapping
バリデータの設定を保持します。

jp.co.intra_mart.framework.base.service.container により使用される jp.co.intra_mart.framework.base.service のクラス
ServiceController
クライアントからの入力に対する処理を行います。
ServiceControllerException
サービスコントローラに関連する例外です。
ServicePropertyException
サービスプロパティ取得時の例外です。
ServicePropertyHandler
サービスの設定情報に接続するクラスです。
Transition
画面遷移に関連するクラスのインタフェースです。
TransitionException
トランジションに関連する例外です。

jp.co.intra_mart.framework.base.service.controller により使用される jp.co.intra_mart.framework.base.service のクラス
RequestInfo
リクエストに対する情報を取得します。

jp.co.intra_mart.framework.base.service.validator により使用される jp.co.intra_mart.framework.base.service のクラス
RequestException
リクエストの内容に関連する間違いがある場合の例外です。
RequestInfo
リクエストに対する情報を取得します。

jp.co.intra_mart.framework.base.web.bean により使用される jp.co.intra_mart.framework.base.service のクラス
ServicePropertyHandler
サービスの設定情報に接続するクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


RequestException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス RequestException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.ApplicationException
                    拡張 jp.co.intra_mart.framework.base.service.RequestException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ValidationException
public class RequestException
extends ApplicationException

リクエストの内容に関連する間違いがある場合の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
RequestException()
詳細メッセージを指定しないで RequestException を構築します。
RequestException(String msg)
指定された詳細メッセージを持つ RequestException を構築します。
RequestException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

RequestException

public RequestException()
詳細メッセージを指定しないで RequestException を構築します。

RequestException

public RequestException(String msg)
指定された詳細メッセージを持つ RequestException を構築します。

パラメータ:
msg - 詳細メッセージ

RequestException

public RequestException(String msg,
                        Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


RequestInfo (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
インタフェース RequestInfo

public interface RequestInfo

リクエストに対する情報を取得します。

導入されたバージョン:
6.1

メソッドの概要
ControllerObject | getControllerObject() リクエストから生成されたコントローラオブジェクトを取得します。
HttpServletRequest | getRequest() リクエストを取得します。
HttpServletResponse | getResponse() レスポンスを取得します。
ServiceResult | getResult() サービス処理結果を取得します。
Throwable | getThrowable() 処理中に発生した例外を取得します。

メソッドの詳細

getRequest

public HttpServletRequest getRequest()
リクエストを取得します。

戻り値:
リクエスト

getResponse

public HttpServletResponse getResponse()
レスポンスを取得します。

戻り値:
レスポンス

getControllerObject

public ControllerObject getControllerObject()
リクエストから生成されたコントローラオブジェクトを取得します。 このメソッドはコントローラオブジェクトが生成されていないとき、 またはControllerConverterが指定されていないときはnullが戻ります。

戻り値:
リクエストから生成されたコントローラオブジェクト（コントローラオブジェクトが生成されていない、またはControllerConverterが指定されていないときはnull）

getResult

public ServiceResult getResult()
サービス処理結果を取得します。 このメソッドはサービス処理結果が生成されていないとき、 またはServiceControllerが指定されていないときはnullが戻ります。

戻り値:
サービス処理結果（サービス処理結果が生成されていない、またはServiceControllerが指定されていないときはnull）

getThrowable

public Throwable getThrowable()
処理中に発生した例外を取得します。

戻り値:
処理中に発生した例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ServiceController (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
インタフェース ServiceController

既知の実装クラスの一覧:
ServiceControllerAdapter
public interface ServiceController

クライアントからの入力に対する処理を行います。

バージョン:
1.0

メソッドの概要
void | check() 入力内容をチェックします。
ControllerObject | getControllerObject() コントローラオブジェクトを取得します。
HttpServletRequest | getRequest() リクエストを取得します。
HttpServletResponse | getResponse() レスポンスを取得します。
ServiceResult | service() 入力に対する処理を実行します。
void | setControllerObject(ControllerObject controllerObject) コントローラオブジェクトを設定します。
void | setRequest(HttpServletRequest request) リクエストを設定します。
void | setResponse(HttpServletResponse response) レスポンスを設定します。

メソッドの詳細

setRequest

public void setRequest(HttpServletRequest request)
リクエストを設定します。

パラメータ:
request - リクエスト

getRequest

public HttpServletRequest getRequest()
リクエストを取得します。

戻り値:
リクエスト

setResponse

public void setResponse(HttpServletResponse response)
レスポンスを設定します。

パラメータ:
response - レスポンス

getResponse

public HttpServletResponse getResponse()
レスポンスを取得します。

戻り値:
レスポンス

check

public void check()
           throws RequestException,
                  SystemException
入力内容をチェックします。

例外:
RequestException - 入力内容に誤りがある
SystemException - チェック時にシステム例外が発生

service

public ServiceResult service()
                      throws SystemException,
                             ApplicationException
入力に対する処理を実行します。

戻り値:
処理結果
例外:
SystemException - 処理実行時にシステム例外が発生
ApplicationException - 処理実行時にアプリケーション例外が発生

setControllerObject

public void setControllerObject(ControllerObject controllerObject)
コントローラオブジェクトを設定します。

パラメータ:
controllerObject - コントローラオブジェクト
導入されたバージョン:
6.1

getControllerObject

public ControllerObject getControllerObject()
コントローラオブジェクトを取得します。

戻り値:
コントローラオブジェクト
導入されたバージョン:
6.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServiceControllerAdapter (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceControllerAdapter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.ServiceControllerAdapter
すべての実装インタフェース:
ServiceController
public class ServiceControllerAdapter
extends Object
implements ServiceController

いくつかのユーティリティメソッドと空のメソッドを実装したサービスコントローラです。 このクラスにはいくつかのユーティリティメソッドがあります。 このクラスを継承し、必要に応じてcheck()やservice()を実装することでコーディング量を減らすことが可能です。

バージョン:
1.0

コンストラクタの概要
ServiceControllerAdapter()
ServiceControllerAdapterを新規に生成します。
メソッドの概要
void | check() 入力内容をチェックします。
protected Event | createEvent(String application, String key) アプリケーションIDとキーに対応するイベントを取得します。
protected EventResult | dispatchEvent(Event event) イベント処理を実行します。
ControllerObject | getControllerObject() コントローラオブジェクトを取得します。
jp.co.intra_mart.foundation.http.MultipartFormData.Entity | getEntity(String name) リクエストから指定された名前に該当するエンティティを取得します。
String | getLoginGroupID() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
String | getLoginUserID() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
HttpServletRequest | getRequest() リクエストを取得します。
HttpServletResponse | getResponse() レスポンスを取得します。
UserInfo | getUserInfo() ユーザ情報を取得します。
ServiceResult | service() 入力に対する処理を実行します。
void | setControllerObject(ControllerObject controllerObject) コントローラオブジェクトを設定します。
void | setRequest(HttpServletRequest request) リクエストを設定します。
void | setResponse(HttpServletResponse response) レスポンスを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ServiceControllerAdapter

public ServiceControllerAdapter()
ServiceControllerAdapterを新規に生成します。

メソッドの詳細

setRequest

public void setRequest(HttpServletRequest request)
リクエストを設定します。

定義:
インタフェース ServiceController 内の setRequest
パラメータ:
request - リクエスト

getRequest

public HttpServletRequest getRequest()
リクエストを取得します。

定義:
インタフェース ServiceController 内の getRequest
戻り値:
リクエスト

setResponse

public void setResponse(HttpServletResponse response)
レスポンスを設定します。

定義:
インタフェース ServiceController 内の setResponse
パラメータ:
response - レスポンス

getResponse

public HttpServletResponse getResponse()
レスポンスを取得します。

定義:
インタフェース ServiceController 内の getResponse
戻り値:
レスポンス

getEntity

public jp.co.intra_mart.foundation.http.MultipartFormData.Entity getEntity(String name)
                                                                    throws SystemException
リクエストから指定された名前に該当するエンティティを取得します。 このメソッドは、ファイルアップロード時にその内容を取得する場合などに使用します。 このメソッドは、ファイルアップロードのリクエストが送られた場合のみ使用できます。 それ以外のリクエストが送られた場合にこのメソッドを呼ぶと例外が発生します。

パラメータ:
name - パラメータ名
戻り値:
パラメータ名に該当するエンティティ
例外:
SystemException - エンティティの取得に失敗
導入されたバージョン:
3.2

check

public void check()
           throws RequestException,
                  SystemException
入力内容をチェックします。

定義:
インタフェース ServiceController 内の check
例外:
RequestException - 入力内容に誤りがある
SystemException - チェック時にシステム例外が発生

service

public ServiceResult service()
                      throws SystemException,
                             ApplicationException
入力に対する処理を実行します。 このサービスコントローラでは何もせず、nullを返します。

定義:
インタフェース ServiceController 内の service
戻り値:
処理結果(null)
例外:
SystemException - 処理実行時にシステム例外が発生
ApplicationException - 処理実行時にアプリケーション例外が発生

getLoginUserID

public String getLoginUserID()
                      throws ServiceControllerException
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログインユーザIDを取得します。

戻り値:
ログインユーザID
例外:
ServiceControllerException - ログインユーザID取得時に例外が発生

getLoginGroupID

public String getLoginGroupID()
                       throws ServiceControllerException
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログイングループIDを取得します。

戻り値:
ログイングループID
例外:
ServiceControllerException - ログイングループID取得時に例外が発生

getUserInfo

public UserInfo getUserInfo()
                     throws ServiceControllerException
ユーザ情報を取得します。

戻り値:
ログインユーザ情報
例外:
ServiceControllerException - ユーザ情報取得時に例外が発生
導入されたバージョン:
5.0

createEvent

protected Event createEvent(String application,
                            String key)
                     throws ServiceControllerException
アプリケーションIDとキーに対応するイベントを取得します。 イベントにはログイン時のログイングループIDが自動的に登録されます。

パラメータ:
application - アプリケーションID
key - キー
戻り値:
イベント
例外:
ServiceControllerException - イベント取得時に例外が発生

dispatchEvent

protected EventResult dispatchEvent(Event event)
                             throws EventManagerException,
                                    EventException,
                                    SystemException,
                                    ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventManagerException - イベントマネージャの生成に失敗
EventException - イベント処理実行に失敗
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生

setControllerObject

public void setControllerObject(ControllerObject controllerObject)
コントローラオブジェクトを設定します。

定義:
インタフェース ServiceController 内の setControllerObject
パラメータ:
controllerObject - コントローラオブジェクト
導入されたバージョン:
6.1

getControllerObject

public ControllerObject getControllerObject()
コントローラオブジェクトを取得します。

定義:
インタフェース ServiceController 内の getControllerObject
戻り値:
コントローラオブジェクト
導入されたバージョン:
6.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServiceControllerException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceControllerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.ServiceControllerException
すべての実装インタフェース:
Serializable
public class ServiceControllerException
extends SystemException

サービスコントローラに関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ServiceControllerException()
詳細メッセージを指定しないで ServiceControllerException を構築します。
ServiceControllerException(String msg)
指定された詳細メッセージを持つ ServiceControllerException を構築します。
ServiceControllerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceControllerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ServiceControllerException

public ServiceControllerException()
詳細メッセージを指定しないで ServiceControllerException を構築します。

ServiceControllerException

public ServiceControllerException(String msg)
指定された詳細メッセージを持つ ServiceControllerException を構築します。

パラメータ:
msg - 詳細メッセージ

ServiceControllerException

public ServiceControllerException(String msg,
                                  Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceControllerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServiceManager (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.ServiceManager
public class ServiceManager
extends Object

サービスマネージャです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_SERVICE_EXTENSION サービスフレームワークをコールするためのデフォルトの拡張子
static String | SERVICE_EXTENSION_KEY 拡張子を指定するキー
static String | SERVICE_PROPERTY_HANDLER_KEY サービスプロパティハンドラのキー
メソッドの概要
String | getApplication(HttpServletRequest request, HttpServletResponse response) 現在のリクエストに対するアプリケーションIDを取得します。
ControllerObject | getControllerObject(String application, String service, Locale locale, RequestInfo info) コントーラオブジェクトを取得します。
String | getEncoding(HttpServletRequest request, HttpServletResponse response) 現在のリクエストに対するエンコーディングを取得します。
String | getExtesion() サービスフレームワークを呼び出すための拡張子を取得します。
Locale | getLocale(HttpServletRequest request, HttpServletResponse response) 現在のリクエストに対するロケールを取得します。
String | getService(HttpServletRequest request, HttpServletResponse response) 現在のリクエストに対するサービスIDを取得します。
ServiceController | getServiceController(String application, String service) 推奨されていません。 このメソッドではなくgetServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
ServiceController | getServiceController(String application, String service, Locale locale) サービスコントローラを取得します。
static ServiceManager | getServiceManager() サービスマネージャを取得します。
ServicePropertyHandler | getServicePropertyHandler() サービスプロパティハンドラを取得します。
Transition | getTransition(String application, String service) 推奨されていません。 このメソッドではなくgetTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
Transition | getTransition(String application, String service, Locale locale) トランジションを取得します。
ValidatorMapping[] | getValidatorMapping(String application, String service, Locale locale) バリデータを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

SERVICE_PROPERTY_HANDLER_KEY

public static final String SERVICE_PROPERTY_HANDLER_KEY
サービスプロパティハンドラのキー

関連項目:
定数フィールド値

SERVICE_EXTENSION_KEY

public static final String SERVICE_EXTENSION_KEY
拡張子を指定するキー

導入されたバージョン:
5.0
関連項目:
getExtesion(), 定数フィールド値

DEFAULT_SERVICE_EXTENSION

public static final String DEFAULT_SERVICE_EXTENSION
サービスフレームワークをコールするためのデフォルトの拡張子

導入されたバージョン:
5.0
関連項目:
getExtesion(), 定数フィールド値
メソッドの詳細

getServiceManager

public static ServiceManager getServiceManager()
                                        throws ServiceManagerException
サービスマネージャを取得します。

戻り値:
サービスマネージャ
例外:
ServiceManagerException - サービスマネージャの生成に失敗した

getServicePropertyHandler

public ServicePropertyHandler getServicePropertyHandler()
サービスプロパティハンドラを取得します。

戻り値:
サービスプロパティハンドラ

getServiceController

public ServiceController getServiceController(String application,
                                              String service)
                                       throws ServicePropertyException,
                                              ServiceControllerException
推奨されていません。 このメソッドではなくgetServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。

サービスコントローラを取得します。 該当するサービスコントローラが存在しない場合、nullを返します。 このメソッドはgetServiceController(application, service, null)を呼んだときと同じ結果を返します。

パラメータ:
application - アプリケーション
service - サービス
戻り値:
サービスコントローラ、存在しない場合はnull
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
ServiceControllerException - サービスコントローラ取得時に例外が発生

getServiceController

public ServiceController getServiceController(String application,
                                              String service,
                                              Locale locale)
                                       throws ServicePropertyException,
                                              ServiceControllerException
サービスコントローラを取得します。 指定されたアプリケーションID、サービスID、ロケールに該当するサービスコントローラを取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

パラメータ:
application - アプリケーション
service - サービス
locale - ロケール
戻り値:
サービスコントローラ、存在しない場合はnull
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
ServiceControllerException - サービスコントローラ取得時に例外が発生
導入されたバージョン:
4.2

getTransition

public Transition getTransition(String application,
                                String service)
                         throws ServicePropertyException,
                                TransitionException
推奨されていません。 このメソッドではなくgetTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。

トランジションを取得します。 該当するトランジションが存在しない場合、DefaultTransitionを返します。 このメソッドはgetTransition(application, service, null)を呼んだときと同じ結果を返します。

パラメータ:
application - アプリケーション
service - サービス
戻り値:
トランジション
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
TransitionException - トランジション取得時に例外が発生

getTransition

public Transition getTransition(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException,
                                TransitionException
トランジションを取得します。 指定されたアプリケーションID、サービスID、ロケールに該当するトランジションを取得します。 該当するトランジションが存在しない場合、DefaultTransitionを返します。

パラメータ:
application - アプリケーション
service - サービス
locale - ロケール
戻り値:
トランジション
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
TransitionException - トランジション取得時に例外が発生
導入されたバージョン:
4.2

getControllerObject

public ControllerObject getControllerObject(String application,
                                            String service,
                                            Locale locale,
                                            RequestInfo info)
                                     throws ServletException,
                                            ServicePropertyException,
                                            ControllerConverterException,
                                            RequestFormatException,
                                            IOException
コントーラオブジェクトを取得します。 指定されたアプリケーションID、サービスID、ロケールに該当するコントーラオブジェクトを取得します。 コントーラオブジェクトは設定されたコントローラコンバータによって生成されます。 コントローラコンバータが設定されていない場合nullが返されます。

パラメータ:
application - アプリケーション
service - サービス
locale - ロケール
info - リクエスト情報
戻り値:
コントーラオブジェクト
例外:
ServletException - 変換中にServletExceptionが発生
IOException - 変換中にIOExceptionが発生
ServicePropertyException - サービスプロパティの取得時に例外が発生
ControllerConverterException - コントローラオブジェクト生成時に例外が発生
RequestFormatException - リクエストのフォーマットが不正
IOException - 変換中にIOExceptionが発生
導入されたバージョン:
6.1

getValidatorMapping

public ValidatorMapping[] getValidatorMapping(String application,
                                              String service,
                                              Locale locale)
                                       throws ServicePropertyException
バリデータを取得します。

パラメータ:
application - アプリケーション
service - サービス
locale - ロケール
戻り値:
バリデータ
例外:
ServicePropertyException - バリデータ取得時に例外が発生
導入されたバージョン:
6.1

getApplication

public String getApplication(HttpServletRequest request,
                             HttpServletResponse response)
                      throws ServicePropertyException
現在のリクエストに対するアプリケーションIDを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
現在のリクエストに対するアプリケーションID
例外:
ServicePropertyException - アプリケーションID取得時に例外が発生
導入されたバージョン:
4.2

getService

public String getService(HttpServletRequest request,
                         HttpServletResponse response)
                  throws ServicePropertyException
現在のリクエストに対するサービスIDを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
現在のリクエストに対するサービスID
例外:
ServicePropertyException - サービスID取得時に例外が発生
導入されたバージョン:
4.2

getLocale

public Locale getLocale(HttpServletRequest request,
                        HttpServletResponse response)
                 throws ServicePropertyException
現在のリクエストに対するロケールを取得します。 ロケールの取得は以下の優先順位に従います。
  1. セッション内のServicePropertyHandler.getLocaleAttributeName()で取得される属性名で登録されたロケール
  2. ServicePropertyHandler.getClientLocale()で取得されるロケール
  3. ServletRequest.getLocale()で取得されるロケール
  4. Locale.getDefault()で取得されるロケール

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ロケール
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
導入されたバージョン:
4.2

getEncoding

public String getEncoding(HttpServletRequest request,
                          HttpServletResponse response)
                   throws ServicePropertyException
現在のリクエストに対するエンコーディングを取得します。 エンコーディングの取得は以下の優先順位に従います。
  1. セッション内のServicePropertyHandler.getEncodingAttributeName()で取得される属性名で登録されたエンコーディング
  2. ServicePropertyHandler.getClientEncoding()で取得されるエンコーディング
  3. ServletRequest.getCharacterEncoding()で取得されるエンコーディング
  4. null

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
エンコーディング
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
導入されたバージョン:
4.2

getExtesion

public String getExtesion()
                   throws ServiceManagerException
サービスフレームワークを呼び出すための拡張子を取得します。
#SERVICE_EXTESION_KEYをキーとしたシステムプロパティを検索し、 存在しない場合は#DEFAULT_SERVICE_EXTを返却します。

戻り値:
サービスフレームワークを呼び出すための拡張子
例外:
ServiceManagerException
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServiceManagerException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.ServiceManagerException
すべての実装インタフェース:
Serializable
public class ServiceManagerException
extends SystemException

サービスマネージャ設定時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ServiceManagerException()
詳細メッセージを指定しないで ServiceManagerException を構築します。
ServiceManagerException(String msg)
指定された詳細メッセージを持つ ServiceManagerException を構築します。
ServiceManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ServiceManagerException

public ServiceManagerException()
詳細メッセージを指定しないで ServiceManagerException を構築します。

ServiceManagerException

public ServiceManagerException(String msg)
指定された詳細メッセージを持つ ServiceManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

ServiceManagerException

public ServiceManagerException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServicePropertyException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServicePropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.ServicePropertyException
すべての実装インタフェース:
Serializable
public class ServicePropertyException
extends SystemException

サービスプロパティ取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ServicePropertyException()
詳細メッセージを指定しないで ServicePropertyException を構築します。
ServicePropertyException(String msg)
指定された詳細メッセージを持つ ServicePropertyException を構築します。
ServicePropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServicePropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ServicePropertyException

public ServicePropertyException()
詳細メッセージを指定しないで ServicePropertyException を構築します。

ServicePropertyException

public ServicePropertyException(String msg)
指定された詳細メッセージを持つ ServicePropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

ServicePropertyException

public ServicePropertyException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServicePropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServicePropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
インタフェース ServicePropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultServicePropertyHandler, DistributesServicePropertyHandler, TextFileServicePropertyHandler, XmlServicePropertyHandler
public interface ServicePropertyHandler
extends PropertyHandler

サービスの設定情報に接続するクラスです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_APPLICATION_PARAMETER 推奨されていません。 この実装は廃止されました。
static String | DEFAULT_ENCODING_ATTRIBUTE ログインユーザのエンコーディングのデフォルトの属性名
static String | DEFAULT_EXCEPTION_ATTRIBUTE 例外属性のデフォルトの属性名
static String | DEFAULT_LOCALE_ATTRIBUTE ログインユーザのロケールのデフォルトの属性名
static String | DEFAULT_SERVICE_PARAMETER 推奨されていません。 この実装は廃止されました。
static String | REQUEST_INFO_ATTRIBUTE リクエスト情報の属性地
メソッドの概要
String | getApplicationParamName() 推奨されていません。 この実装は廃止されました。
String | getClientEncoding() クライアントのエンコードを取得します。
Locale | getClientLocale() クライアントのロケールを取得します。
String | getContextPath() 推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
ControllerConverterConfig | getControllerConverterConfig(String application, String service, Locale locale) キーに該当するコントローラコンバータの初期パラメータを取得します。
String | getControllerConverterName(String application, String service, Locale locale) コントローラコンバータのクラス名を取得します。
String | getEncodingAttributeName() ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
String | getExceptionAttributeName() 例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
String | getInputErrorPagePath() 推奨されていません。 このメソッドではなくgetInputErrorPagePath(Locale)を使用してください。
String | getInputErrorPagePath(Locale locale) 入力例外時のページのパスを取得します。
String | getInputErrorPagePath(String application) 推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, Locale)を使用してください。
String | getInputErrorPagePath(String application, Locale locale) 入力例外時のページのパスを取得します。
String | getInputErrorPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, Locale)を使用してください。
String | getInputErrorPagePath(String application, String service, Locale locale) 入力例外時のページのパスを取得します。
String | getInputErrorPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, String, Locale)を使用してください。
String | getInputErrorPagePath(String application, String service, String key, Locale locale) 入力例外時のページのパスを取得します。
String | getLocaleAttributeName() ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
String | getNextPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetNextPagePath(String, String, Locale)を使用してください。
String | getNextPagePath(String application, String service, Locale locale) 遷移先のページのパスを取得します。
String | getNextPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetNextPagePath(String, String, String, Locale)を使用してください。
String | getNextPagePath(String application, String service, String key, Locale locale) 遷移先のページのパスを取得します。
String | getServiceControllerName(String application, String service) 推奨されていません。 このメソッドではなくgetServiceControllerName(String, String, Locale)を使用してください。
String | getServiceControllerName(String application, String service, Locale locale) サービスコントローラのクラス名を取得します。
String | getServiceErrorPagePath() 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(Locale)を使用してください。
String | getServiceErrorPagePath(Locale locale) 処理例外時のページのパスを取得します。
String | getServiceErrorPagePath(String application) 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, Locale)を使用してください。
String | getServiceErrorPagePath(String application, Locale locale) 処理例外時のページのパスを取得します。
String | getServiceErrorPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, Locale)を使用してください。
String | getServiceErrorPagePath(String application, String service, Locale locale) 処理例外時のページのパスを取得します。
String | getServiceErrorPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, String, Locale)を使用してください。
String | getServiceErrorPagePath(String application, String service, String key, Locale locale) 処理例外時のページのパスを取得します。
String | getServiceParamName() 推奨されていません。 この実装は廃止されました。
String | getServiceServletPath() 推奨されていません。 この実装は廃止されました。
String | getSystemErrorPagePath() 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(Locale)を使用してください。
String | getSystemErrorPagePath(Locale locale) システム例外時のページのパスを取得します。
String | getSystemErrorPagePath(String application) 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, Locale)を使用してください。
String | getSystemErrorPagePath(String application, Locale locale) システム例外時のページのパスを取得します。
String | getSystemErrorPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, Locale)を使用してください。
String | getSystemErrorPagePath(String application, String service, Locale locale) システム例外時のページのパスを取得します。
String | getSystemErrorPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, String, Locale)を使用してください。
String | getSystemErrorPagePath(String application, String service, String key, Locale locale) システム例外時のページのパスを取得します。
String | getTransitionName(String application, String service) 推奨されていません。 このメソッドではなくgetTransitionName(String, String, Locale)を使用してください。
String | getTransitionName(String application, String service, Locale locale) トランジションのクラス名を取得します。
ValidatorMapping[] | getValidators(String application, String service, Locale locale) キーに該当するバリデータを取得します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

フィールドの詳細

DEFAULT_APPLICATION_PARAMETER

public static final String DEFAULT_APPLICATION_PARAMETER
推奨されていません。 この実装は廃止されました。

アプリケーションIDのデフォルトのパラメータ名

関連項目:
定数フィールド値

DEFAULT_SERVICE_PARAMETER

public static final String DEFAULT_SERVICE_PARAMETER
推奨されていません。 この実装は廃止されました。

サービスIDのデフォルトのパラメータ名

関連項目:
定数フィールド値

DEFAULT_EXCEPTION_ATTRIBUTE

public static final String DEFAULT_EXCEPTION_ATTRIBUTE
例外属性のデフォルトの属性名

関連項目:
定数フィールド値

DEFAULT_ENCODING_ATTRIBUTE

public static final String DEFAULT_ENCODING_ATTRIBUTE
ログインユーザのエンコーディングのデフォルトの属性名

関連項目:
定数フィールド値

DEFAULT_LOCALE_ATTRIBUTE

public static final String DEFAULT_LOCALE_ATTRIBUTE
ログインユーザのロケールのデフォルトの属性名

関連項目:
定数フィールド値

REQUEST_INFO_ATTRIBUTE

public static final String REQUEST_INFO_ATTRIBUTE
リクエスト情報の属性地

関連項目:
定数フィールド値
メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws ServicePropertyException
プロパティの動的読み込みが可能かどうか調べます。

戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可
例外:
ServicePropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getClientEncoding

public String getClientEncoding()
                         throws ServicePropertyException
クライアントのエンコードを取得します。

戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getEncodingAttributeName

public String getEncodingAttributeName()
                                throws ServicePropertyException
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。 設定されていない場合、DEFAULT_ENCODING_ATTRIBUTEで定義されている値を返します。

戻り値:
エンコードの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getClientLocale

public Locale getClientLocale()
                       throws ServicePropertyException
クライアントのロケールを取得します。

戻り値:
クライアントのロケール（設定されていない場合はnull）
例外:
ServicePropertyException - クライアントのロケールの取得時に例外が発生
導入されたバージョン:
4.2

getLocaleAttributeName

public String getLocaleAttributeName()
                              throws ServicePropertyException
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。 設定されていない場合、DEFAULT_LOCALE_ATTRIBUTEで定義されている値を返します。

戻り値:
ロケールの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生
導入されたバージョン:
4.2

getNextPagePath

public String getNextPagePath(String application,
                              String service)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなくgetNextPagePath(String, String, Locale)を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。 このメソッドはgetNextPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなくgetNextPagePath(String, String, String, Locale)を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。keyがnullの場合、getNextPagePath(String, String)と同じ動作になります。 このメソッドはgetNextPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。keyがnullの場合、getNextPagePath(String, String)と同じ動作になります。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, String, Locale)を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String, String)で取得されるページを返します。 このメソッドはgetInputErrorPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String, String)で取得されるページを返します。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, Locale)を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String)で取得されるページを返します。 このメソッドはgetInputErrorPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String)で取得されるページを返します。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, Locale)を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath()で取得されるページを返します。 このメソッドはgetInputErrorPagePath(application, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath()で取得されるページを返します。

パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath()
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(Locale)を使用してください。

入力例外時のページのパスを取得します。 このメソッドはgetInputErrorPagePath((java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。

パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, String, Locale)を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String, String)で取得されるページを返します。 このメソッドはgetServiceErrorPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String, String)で取得されるページを返します。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, Locale)を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String)で取得されるページを返します。 このメソッドはgetServiceErrorPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String)で取得されるページを返します。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, Locale)を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath()で取得されるページを返します。 このメソッドはgetServiceErrorPagePath(application, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath()で取得されるページを返します。

パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath()
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(Locale)を使用してください。

処理例外時のページのパスを取得します。 このメソッドはgetServiceErrorPagePath((java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, String, Locale)を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String, String)で取得されるページを返します。 このメソッドはgetSystemErrorPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String, String)で取得されるページを返します。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, Locale)を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String)で取得されるページを返します。 このメソッドはgetSystemErrorPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String)で取得されるページを返します。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, Locale)を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath()で取得されるページを返します。 このメソッドはgetSystemErrorPagePath(application, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath()で取得されるページを返します。

パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath()
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(Locale)を使用してください。

システム例外時のページのパスを取得します。 このメソッドはgetSystemErrorPagePath((java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。

パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service)
                                throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceControllerName(String, String, Locale)を使用してください。

サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。 このメソッドはgetServiceControllerName(application, service, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service,
                                       Locale locale)
                                throws ServicePropertyException
サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生
導入されたバージョン:
4.2

getTransitionName

public String getTransitionName(String application,
                                String service)
                         throws ServicePropertyException
推奨されていません。 このメソッドではなくgetTransitionName(String, String, Locale)を使用してください。

トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。 このメソッドはgetTransitionName(application, service, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException
トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生
導入されたバージョン:
4.2

getControllerConverterName

public String getControllerConverterName(String application,
                                         String service,
                                         Locale locale)
                                  throws ServicePropertyException
コントローラコンバータのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するコントローラコンバータ名を取得します。 特に設定されていない場合、nullが返ります。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - コントローラコンバータのクラス名の取得時に例外が発生
導入されたバージョン:
6.1

getControllerConverterConfig

public ControllerConverterConfig getControllerConverterConfig(String application,
                                                              String service,
                                                              Locale locale)
                                                       throws ServicePropertyException
キーに該当するコントローラコンバータの初期パラメータを取得します。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータの初期パラメータ
例外:
ServicePropertyException - コントローラコンバータの初期パラメータの取得に失敗
導入されたバージョン:
6.1

getValidators

public ValidatorMapping[] getValidators(String application,
                                        String service,
                                        Locale locale)
                                 throws ServicePropertyException
キーに該当するバリデータを取得します。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータの初期パラメータ
例外:
ServicePropertyException - バリデータの取得に失敗
導入されたバージョン:
6.1

getServiceServletPath

public String getServiceServletPath()
                             throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

サービスサーブレットのパスを取得します。

戻り値:
サービスサーブレットのパス
例外:
ServicePropertyException - サービスサーブレットのパスの取得時に例外が発生

getContextPath

public String getContextPath()
                      throws ServicePropertyException
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。

コンテキストパスを取得します。

戻り値:
コンテキストパス(設定されていない場合はnull)
例外:
ServicePropertyException - コンテキストパスの取得時に例外が発生

getApplicationParamName

public String getApplicationParamName()
                               throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

アプリケーションIDに該当するパラメータ名を取得します。 設定されていない場合、DEFAULT_APPLICATION_PARAMETERで定義されている値を返します。

戻り値:
アプリケーションIDに該当するパラメータ名
例外:
ServicePropertyException - アプリケーションIDに該当するパラメータ名の取得時に例外が発生

getServiceParamName

public String getServiceParamName()
                           throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

サービスIDに該当するパラメータ名を取得します。 設定されていない場合、DEFAULT_SERVICE_PARAMETERで定義されている値を返します。

戻り値:
サービスIDに該当するパラメータ名
例外:
ServicePropertyException - サービスIDに該当するパラメータ名の取得時に例外が発生

getExceptionAttributeName

public String getExceptionAttributeName()
                                 throws ServicePropertyException
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。

戻り値:
例外の属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart 6.1.14
 前のクラス   次のクラス フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド 詳細:  フィールド | コンストラクタ | メソッド


ServiceResult (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
インタフェース ServiceResult

既知の実装クラスの一覧:
EmptyServiceResult
public interface ServiceResult

サービスの処理結果です。

バージョン:
1.0

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ServiceSecurityFilter (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceSecurityFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.ServiceSecurityFilter
すべての実装インタフェース:
Filter
public class ServiceSecurityFilter
extends Object
implements Filter

intra-mart画面を表示するURLの詐称をチェックするためのフィルタです。 このフィルタは次の初期化パラメータを設定する必要があります。

パラメータ名 | 値
error-page | セキュリティ違反時に遷移するページのパス。 コンテキストパスからの相対パスで指定する必要がある。 パスの先頭は"/"で指定する。

このフィルタを設定する場合、ServiceServletは拡張子によるマッピングが行われる必要があります。

導入されたバージョン:
4.3

フィールドの概要
static String | ID_SERVICE_SECURITY_FILTER リクエストに登録するServiceServletFilterの属性名
static String | PARAM_ERROR_PAGE エラーページパスのパラメータ名
コンストラクタの概要
ServiceSecurityFilter()
メソッドの概要
void | destroy() フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) sessionに登録された情報と、parameterの情報を比較します。
void | init(FilterConfig filterConfig) このフィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_SERVICE_SECURITY_FILTER

public static final String ID_SERVICE_SECURITY_FILTER
リクエストに登録するServiceServletFilterの属性名

関連項目:
定数フィールド値

PARAM_ERROR_PAGE

public static final String PARAM_ERROR_PAGE
エラーページパスのパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

ServiceSecurityFilter

public ServiceSecurityFilter()
メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
このフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws ServletException,
                     IOException
sessionに登録された情報と、parameterの情報を比較します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタチェイン
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServiceServlet (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.framework.base.service.ServiceServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
public class ServiceServlet
extends HttpServlet

サービスを振り分けるサーブレットです。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
static String REQUEST_SEPARATOR
リクエストの情報を分割するセパレータ
コンストラクタの概要
ServiceServlet()
ServiceServletを新規に生成します。
メソッドの概要
void | destroy() サーブレットを解放します。
protected void | doGet(HttpServletRequest request, HttpServletResponse response) GETメソッドに対するサービスを行います。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) POSTメソッドに対するサービスを行います。
void | init(ServletConfig servletConfig) サーブレットを初期化します。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

REQUEST_SEPARATOR

public static final String REQUEST_SEPARATOR
リクエストの情報を分割するセパレータ

導入されたバージョン:
5.0
関連項目:
定数フィールド値
コンストラクタの詳細

ServiceServlet

public ServiceServlet()
ServiceServletを新規に生成します。

メソッドの詳細

init

public void init(ServletConfig servletConfig)
          throws ServletException
サーブレットを初期化します。

パラメータ:
servletConfig - ServletConfig
例外:
ServletException - サーブレット初期化時に例外が発生

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
GETメソッドに対するサービスを行います。 このメソッドでは対応するサービスコントローラを呼び、次の画面に遷移します。

パラメータ:
request - リクエスト
response - レスポンス
例外:
ServletException - サーブレット例外が発生
IOException - 入出力例外が発生

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
POSTメソッドに対するサービスを行います。 このメソッドでは対応するサービスコントローラを呼び、次の画面に遷移します。

パラメータ:
request - リクエスト
response - レスポンス
例外:
ServletException - サーブレット例外が発生
IOException - 入出力例外が発生

destroy

public void destroy()
サーブレットを解放します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServiceServletException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceServletException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.ServiceServletException
すべての実装インタフェース:
Serializable
public class ServiceServletException
extends SystemException

サービスに関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ServiceServletException()
詳細メッセージを指定しないで ServiceServletException を構築します。
ServiceServletException(String msg)
指定された詳細メッセージを持つ ServiceServletException を構築します。
ServiceServletException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceServletException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ServiceServletException

public ServiceServletException()
詳細メッセージを指定しないで ServiceServletException を構築します。

ServiceServletException

public ServiceServletException(String msg)
指定された詳細メッセージを持つ ServiceServletException を構築します。

パラメータ:
msg - 詳細メッセージ

ServiceServletException

public ServiceServletException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceServletException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TextFileServicePropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス TextFileServicePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler
すべての実装インタフェース:
PropertyHandler, ServicePropertyHandler
public class TextFileServicePropertyHandler
extends Object
implements ServicePropertyHandler

指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。 ファイルの書式はDefaultServicePropertyHandlerで示されるものと同じです。
ファイルが存在するディレクトリ名はPARAM_FILE_DIRで示されるパラメータ名で指定します。
PARAM_DYNAMICで示されるパラメータにtrueを指定した場合 アプリケーション実行時にもプロパティの変更を動的に反映させることが可能となりますが、 パラメータの取得時に毎回ファイル操作を行うためパフォーマンスに悪影響を与える可能性があります。 このオプションは、開発時やデバッグ時のようにパラメータを頻繁に変更する必要がある場合のみtrueとし、 通常はfalseに設定しておいてください。

導入されたバージョン:
3.2

フィールドの概要
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
インタフェース jp.co.intra_mart.framework.base.service.ServicePropertyHandler から継承したフィールド
DEFAULT_APPLICATION_PARAMETER, DEFAULT_ENCODING_ATTRIBUTE, DEFAULT_EXCEPTION_ATTRIBUTE, DEFAULT_LOCALE_ATTRIBUTE, DEFAULT_SERVICE_PARAMETER, REQUEST_INFO_ATTRIBUTE
コンストラクタの概要
TextFileServicePropertyHandler()
TextFileServicePropertyHandlerを新規に生成します。
メソッドの概要
String | getApplicationParamName() 推奨されていません。 この実装は廃止されました。
String | getClientEncoding() クライアントのエンコードを取得します。
Locale | getClientLocale() クライアントのロケールを取得します。
String | getContextPath() 推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
ControllerConverterConfig | getControllerConverterConfig(String application, String service, Locale locale) キーに該当するコントローラコンバータの初期パラメータを取得します。
String | getControllerConverterName(String application, String service, Locale locale) コントローラコンバータのクラス名を取得します。
String | getEncodingAttributeName() ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
String | getExceptionAttributeName() 例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
String | getInputErrorPagePath() 推奨されていません。 このメソッドではなくgetInputErrorPagePath(Locale)を使用してください。
String | getInputErrorPagePath(Locale locale) 入力例外時のページのパスを取得します。
String | getInputErrorPagePath(String application) 推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, Locale)を使用してください。
String | getInputErrorPagePath(String application, Locale locale) 入力例外時のページのパスを取得します。
String | getInputErrorPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, Locale)を使用してください。
String | getInputErrorPagePath(String application, String service, Locale locale) 入力例外時のページのパスを取得します。
String | getInputErrorPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, String, Locale)を使用してください。
String | getInputErrorPagePath(String application, String service, String key, Locale locale) 入力例外時のページのパスを取得します。
String | getLocaleAttributeName() ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
String | getNextPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetNextPagePath(String, String, Locale)を使用してください。
String | getNextPagePath(String application, String service, Locale locale) 遷移先のページのパスを取得します。
String | getNextPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetNextPagePath(String, String, String, Locale)を使用してください。
String | getNextPagePath(String application, String service, String key, Locale locale) 遷移先のページのパスを取得します。
String | getServiceControllerName(String application, String service) 推奨されていません。 このメソッドではなくgetServiceControllerName(String, String, Locale)を使用してください。
String | getServiceControllerName(String application, String service, Locale locale) サービスコントローラのクラス名を取得します。
String | getServiceErrorPagePath() 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(Locale)を使用してください。
String | getServiceErrorPagePath(Locale locale) 処理例外時のページのパスを取得します。
String | getServiceErrorPagePath(String application) 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, Locale)を使用してください。
String | getServiceErrorPagePath(String application, Locale locale) 処理例外時のページのパスを取得します。
String | getServiceErrorPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, Locale)を使用してください。
String | getServiceErrorPagePath(String application, String service, Locale locale) 処理例外時のページのパスを取得します。
String | getServiceErrorPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, String, Locale)を使用してください。
String | getServiceErrorPagePath(String application, String service, String key, Locale locale) 処理例外時のページのパスを取得します。
String | getServiceParamName() 推奨されていません。 この実装は廃止されました。
String | getServiceServletPath() サービスサーブレットのパスを取得します。
String | getSystemErrorPagePath() 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(Locale)を使用してください。
String | getSystemErrorPagePath(Locale locale) システム例外時のページのパスを取得します。
String | getSystemErrorPagePath(String application) 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, Locale)を使用してください。
String | getSystemErrorPagePath(String application, Locale locale) システム例外時のページのパスを取得します。
String | getSystemErrorPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, Locale)を使用してください。
String | getSystemErrorPagePath(String application, String service, Locale locale) システム例外時のページのパスを取得します。
String | getSystemErrorPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, String, Locale)を使用してください。
String | getSystemErrorPagePath(String application, String service, String key, Locale locale) システム例外時のページのパスを取得します。
String | getTransitionName(String application, String service) 推奨されていません。 このメソッドではなくgetTransitionName(String, String, Locale)を使用してください。
String | getTransitionName(String application, String service, Locale locale) トランジションのクラス名を取得します。
ValidatorMapping[] | getValidators(String application, String service, Locale locale) キーに該当するバリデータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() 再設定可能かどうかをチェックします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

TextFileServicePropertyHandler

public TextFileServicePropertyHandler()
TextFileServicePropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
再設定可能かどうかをチェックします。

定義:
インタフェース ServicePropertyHandler 内の isDynamic
戻り値:
true 再設定可能、false 再設定不可

getClientEncoding

public String getClientEncoding()
                         throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientEncoding
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getClientLocale

public Locale getClientLocale()
                       throws ServicePropertyException
クライアントのロケールを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientLocale
戻り値:
クライアントのロケール
例外:
ServicePropertyException - クライアントのロケールの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなくgetNextPagePath(String, String, Locale)を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。 このメソッドはgetNextPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなくgetNextPagePath(String, String, String, Locale)を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。keyがnullの場合、getNextPagePath(String, String)と同じ動作になります。 このメソッドはgetNextPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。keyがnullの場合、getNextPagePath(String, String)と同じ動作になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, String, Locale)を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String, String)で取得されるページを返します。 このメソッドはgetInputErrorPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, Locale)を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String)で取得されるページを返します。 このメソッドはgetInputErrorPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, Locale)を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath()で取得されるページを返します。 このメソッドはgetInputErrorPagePath(application, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath()
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(Locale)を使用してください。

入力例外時のページのパスを取得します。 このメソッドはgetInputErrorPagePath((java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, String, Locale)を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String, String)で取得されるページを返します。 このメソッドはgetServiceErrorPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, Locale)を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String)で取得されるページを返します。 このメソッドはgetServiceErrorPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, Locale)を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath()で取得されるページを返します。 このメソッドはgetServiceErrorPagePath(application, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath()
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(Locale)を使用してください。

処理例外時のページのパスを取得します。 このメソッドはgetServiceErrorPagePath((java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, String, Locale)を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String, String)で取得されるページを返します。 このメソッドはgetSystemErrorPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, Locale)を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String)で取得されるページを返します。 このメソッドはgetSystemErrorPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, Locale)を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath()で取得されるページを返します。 このメソッドはgetSystemErrorPagePath(application, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath()
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(Locale)を使用してください。

システム例外時のページのパスを取得します。 このメソッドはgetSystemErrorPagePath((java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service)
                                throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceControllerName(String, String, Locale)を使用してください。

サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。 このメソッドはgetServiceControllerName(application, service, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service,
                                       Locale locale)
                                throws ServicePropertyException
サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生
導入されたバージョン:
4.2

getTransitionName

public String getTransitionName(String application,
                                String service)
                         throws ServicePropertyException
推奨されていません。 このメソッドではなくgetTransitionName(String, String, Locale)を使用してください。

トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。 このメソッドはgetTransitionName(application, service, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException
トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生
導入されたバージョン:
4.2

getServiceServletPath

public String getServiceServletPath()
                             throws ServicePropertyException
サービスサーブレットのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceServletPath
戻り値:
サービスサーブレットのパス
例外:
ServicePropertyException - サービスサーブレットのパスの取得時に例外が発生

getContextPath

public String getContextPath()
                      throws ServicePropertyException
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。

コンテキストパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getContextPath
戻り値:
コンテキストパス
例外:
ServicePropertyException - コンテキストパスの取得時に例外が発生

getApplicationParamName

public String getApplicationParamName()
                               throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

アプリケーションIDに該当するパラメータ名を取得します。 設定されていない場合、ServicePropertyHandler.DEFAULT_APPLICATION_PARAMETERで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getApplicationParamName
戻り値:
アプリケーションIDに該当するパラメータ名
例外:
ServicePropertyException - アプリケーションIDに該当するパラメータ名の取得時に例外が発生

getServiceParamName

public String getServiceParamName()
                           throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

サービスIDに該当するパラメータ名を取得します。 設定されていない場合、ServicePropertyHandler.DEFAULT_SERVICE_PARAMETERで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceParamName
戻り値:
サービスIDに該当するパラメータ名
例外:
ServicePropertyException - サービスIDに該当するパラメータ名の取得時に例外が発生

getExceptionAttributeName

public String getExceptionAttributeName()
                                 throws ServicePropertyException
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。

定義:
インタフェース ServicePropertyHandler 内の getExceptionAttributeName
戻り値:
例外の属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getEncodingAttributeName

public String getEncodingAttributeName()
                                throws ServicePropertyException
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。 設定されていない場合、ServicePropertyHandler.DEFAULT_ENCODING_ATTRIBUTEで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getEncodingAttributeName
戻り値:
エンコードの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getLocaleAttributeName

public String getLocaleAttributeName()
                              throws ServicePropertyException
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。 設定されていない場合、ServicePropertyHandler.DEFAULT_LOCALE_ATTRIBUTEで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getLocaleAttributeName
戻り値:
ロケールの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生
導入されたバージョン:
4.2

getControllerConverterName

public String getControllerConverterName(String application,
                                         String service,
                                         Locale locale)
                                  throws ServicePropertyException
インタフェース ServicePropertyHandler の記述:
コントローラコンバータのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するコントローラコンバータ名を取得します。 特に設定されていない場合、nullが返ります。

定義:
インタフェース ServicePropertyHandler 内の getControllerConverterName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - コントローラコンバータのクラス名の取得時に例外が発生

getControllerConverterConfig

public ControllerConverterConfig getControllerConverterConfig(String application,
                                                              String service,
                                                              Locale locale)
                                                       throws ServicePropertyException
インタフェース ServicePropertyHandler の記述:
キーに該当するコントローラコンバータの初期パラメータを取得します。

定義:
インタフェース ServicePropertyHandler 内の getControllerConverterConfig
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータの初期パラメータ
例外:
ServicePropertyException - コントローラコンバータの初期パラメータの取得に失敗

getValidators

public ValidatorMapping[] getValidators(String application,
                                        String service,
                                        Locale locale)
                                 throws ServicePropertyException
インタフェース ServicePropertyHandler の記述:
キーに該当するバリデータを取得します。

定義:
インタフェース ServicePropertyHandler 内の getValidators
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータの初期パラメータ
例外:
ServicePropertyException - バリデータの取得に失敗
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart 6.1.14
 前のクラス   次のクラス フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド 詳細:  フィールド | コンストラクタ | メソッド


Transition (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス Transition

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.Transition
直系の既知のサブクラス:
DefaultTransition, IntramartPageBaseTransition
public abstract class Transition
extends Object

画面遷移に関連するクラスのインタフェースです。

バージョン:
1.0

コンストラクタの概要
Transition()
Transitionを新規に生成します。
メソッドの概要
protected String | getApplication() アプリケーションIDを取得します。
jp.co.intra_mart.foundation.http.MultipartFormData.Entity | getEntity(String name) リクエストから指定された名前に該当するエンティティを取得します。
abstract String | getInputErrorPage(RequestException e) 入力エラーのページを取得します。
abstract String | getNextPage() 次に遷移するページを取得します。
protected String | getNextPagePath() このトランジションに設定されているアプリケーションIDとサービスIDに該当する次ページのパスを取得します。
protected String | getNextPagePath(String key) このトランジションに設定されているアプリケーションIDとサービスIDと、指定されたキーに該当する次ページのパスを取得します。
HttpServletRequest | getRequest() リクエストを取得します。
HttpServletResponse | getResponse() レスポンスを取得します。
ServiceResult | getResult() サービス処理結果を取得します。
protected String | getService() サービスIDを取得します。
abstract String | getServiceErrorPage(Exception e) 処理エラーのページを取得します。
protected ServiceManager | getServiceManager() サービスマネージャを取得します。
SessionObject | getSessionObject() 推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
abstract String | getSystemErrorPage(Exception e) システムエラーのページを取得します。
abstract void | setInformation() 次の遷移先に渡す情報を設定します。
void | setRequest(HttpServletRequest request) リクエストを設定します。
void | setResponse(HttpServletResponse response) レスポンスを設定します。
void | setResult(ServiceResult result) サービス処理結果を設定します。
protected void | setServiceManager(ServiceManager manager) サービスマネージャを設定します。
abstract void | transfer() 次のページに遷移します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Transition

public Transition()
Transitionを新規に生成します。

メソッドの詳細

setServiceManager

protected void setServiceManager(ServiceManager manager)
サービスマネージャを設定します。

パラメータ:
manager - サービスマネージャ

getServiceManager

protected ServiceManager getServiceManager()
サービスマネージャを取得します。

戻り値:
サービスマネージャ

getApplication

protected String getApplication()
アプリケーションIDを取得します。

戻り値:
アプリケーションID

getService

protected String getService()
サービスIDを取得します。

戻り値:
サービスID

setRequest

public void setRequest(HttpServletRequest request)
リクエストを設定します。

パラメータ:
request - リクエスト

getRequest

public HttpServletRequest getRequest()
リクエストを取得します。

戻り値:
リクエスト

setResponse

public void setResponse(HttpServletResponse response)
レスポンスを設定します。

パラメータ:
response - レスポンス

getResponse

public HttpServletResponse getResponse()
レスポンスを取得します。

戻り値:
レスポンス

getEntity

public jp.co.intra_mart.foundation.http.MultipartFormData.Entity getEntity(String name)
                                                                    throws SystemException
リクエストから指定された名前に該当するエンティティを取得します。 このメソッドは、ファイルアップロード時にその内容を取得する場合などに使用します。 このメソッドは、ファイルアップロードのリクエストが送られた場合のみ使用できます。 それ以外のリクエストが送られた場合にこのメソッドを呼ぶと例外が発生します。

パラメータ:
name - パラメータ名
戻り値:
パラメータ名に該当するエンティティ
例外:
SystemException - エンティティの取得に失敗
導入されたバージョン:
3.2

getSessionObject

public SessionObject getSessionObject()
                               throws SessionManagerException,
                                      SessionPropertyException,
                                      SessionFactoryException
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

セッションオブジェクトを取得します。

戻り値:
セッションオブジェクト
例外:
SessionManagerException - セッションマネージャの取得時に例外が発生
SessionPropertyException - セッションのプロパティ情報取得時に例外が発生
SessionFactoryException - セッションオブジェクトの生成時に例外が発生

setResult

public void setResult(ServiceResult result)
サービス処理結果を設定します。

パラメータ:
result - サービス処理結果

getResult

public ServiceResult getResult()
サービス処理結果を取得します。

戻り値:
サービス処理結果

getNextPagePath

protected String getNextPagePath()
                          throws ServicePropertyException
このトランジションに設定されているアプリケーションIDとサービスIDに該当する次ページのパスを取得します。

戻り値:
次ページのパス
例外:
ServicePropertyException - プロパティの取得時に例外が発生

getNextPagePath

protected String getNextPagePath(String key)
                          throws ServicePropertyException
このトランジションに設定されているアプリケーションIDとサービスIDと、指定されたキーに該当する次ページのパスを取得します。

パラメータ:
key - キー
戻り値:
次ページのパス
例外:
ServicePropertyException - プロパティの取得時に例外が発生

getInputErrorPage

public abstract String getInputErrorPage(RequestException e)
                                  throws ServicePropertyException,
                                         TransitionException
入力エラーのページを取得します。

パラメータ:
e - 入力時の例外
戻り値:
入力エラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getSystemErrorPage

public abstract String getSystemErrorPage(Exception e)
                                   throws ServicePropertyException,
                                          TransitionException
システムエラーのページを取得します。

パラメータ:
e - 処理時の例外
戻り値:
システムエラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getServiceErrorPage

public abstract String getServiceErrorPage(Exception e)
                                    throws ServicePropertyException,
                                           TransitionException
処理エラーのページを取得します。

パラメータ:
e - 処理時の例外
戻り値:
処理エラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

setInformation

public abstract void setInformation()
                             throws TransitionException
次の遷移先に渡す情報を設定します。

例外:
TransitionException - 情報設定時に例外が発生

getNextPage

public abstract String getNextPage()
                            throws ServicePropertyException,
                                   TransitionException
次に遷移するページを取得します。

戻り値:
次に遷移するページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

transfer

public abstract void transfer()
                       throws SystemException
次のページに遷移します。 遷移する方法は次のページで要求される形式に依存します。

例外:
SystemException - システム例外が発生
導入されたバージョン:
3.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TransitionException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス TransitionException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.TransitionException
すべての実装インタフェース:
Serializable
public class TransitionException
extends SystemException

トランジションに関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
TransitionException()
詳細メッセージを指定しないで TransitionException を構築します。
TransitionException(String msg)
指定された詳細メッセージを持つ TransitionException を構築します。
TransitionException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ TransitionException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

TransitionException

public TransitionException()
詳細メッセージを指定しないで TransitionException を構築します。

TransitionException

public TransitionException(String msg)
指定された詳細メッセージを持つ TransitionException を構築します。

パラメータ:
msg - 詳細メッセージ

TransitionException

public TransitionException(String msg,
                           Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ TransitionException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ValidatorMapping (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ValidatorMapping

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.ValidatorMapping
public class ValidatorMapping
extends Object

バリデータの設定を保持します。

導入されたバージョン:
6.1

コンストラクタの概要
ValidatorMapping()
ValidatorMappingを新規に生成します。
メソッドの概要
String | getValidatorClassName() バリデータ名を取得します。
ValidatorConfig | getValidatorConfig() バリデータの初期化パラメータを取得します。
void | setValidatorClassName(String validatorClassName) バリデータ名を設定します。
void | setValidatorConfig(ValidatorConfig validatorConfig) バリデータの初期化パラメータを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ValidatorMapping

public ValidatorMapping()
ValidatorMappingを新規に生成します。

メソッドの詳細

getValidatorClassName

public String getValidatorClassName()
バリデータ名を取得します。

戻り値:

setValidatorClassName

public void setValidatorClassName(String validatorClassName)
バリデータ名を設定します。

パラメータ:
validatorClassName -

getValidatorConfig

public ValidatorConfig getValidatorConfig()
バリデータの初期化パラメータを取得します。

戻り値:

setValidatorConfig

public void setValidatorConfig(ValidatorConfig validatorConfig)
バリデータの初期化パラメータを設定します。

パラメータ:
validatorConfig -
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ValidatorModel (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ValidatorModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.ValidatorModel
public class ValidatorModel
extends Object

バリデータ情報を管理するクラスです。

バージョン:
1.0

フィールドの概要
static String | ID
static String | P_ID_PARAM_NAME
static String | P_ID_PARAM_VALUE
static String | P_ID_VALIDATOR_CLASS
static String | P_ID_VALIDATOR_PARAM
コンストラクタの概要
ValidatorModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID

public static final String ID
関連項目:
定数フィールド値

P_ID_VALIDATOR_CLASS

public static final String P_ID_VALIDATOR_CLASS
関連項目:
定数フィールド値

P_ID_VALIDATOR_PARAM

public static final String P_ID_VALIDATOR_PARAM
関連項目:
定数フィールド値

P_ID_PARAM_NAME

public static final String P_ID_PARAM_NAME
関連項目:
定数フィールド値

P_ID_PARAM_VALUE

public static final String P_ID_PARAM_VALUE
関連項目:
定数フィールド値
コンストラクタの詳細

ValidatorModel

public ValidatorModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XmlServicePropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス XmlServicePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler
すべての実装インタフェース:
PropertyHandler, ServicePropertyHandler
public class XmlServicePropertyHandler
extends Object
implements ServicePropertyHandler

サービスの設定情報に接続するプロパティハンドラです。
XML形式で記述されたプロパティ情報を読み取ります。XMLファイルはアプリケーション毎に分割されます。この場合のファイル名は「 プレフィックス _ アプリケーションID .xml」です。また、アプリケーションに依存しない「 プレフィックス .xml」があります。
XMLファイルのプレフィックスは PropertyManager.getPropertyHandlerParams(String) でキーに ServiceManager.SERVICE_PROPERTY_HANDLER_KEY を指定したときに取得されるパラメータのうち DEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスは DEFAULT_BUNDLE_NAME_PARAMで示されるものです。
プロパティの検索順は、アプリケーションごとのプロパティファイル「 プレフィックス _ アプリケーションID .xml」が優先されます。該当するプロパティが見つからない場合、引き続いて「 プレフィックス .xml」を検索します。

導入されたバージョン:
5.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
インタフェース jp.co.intra_mart.framework.base.service.ServicePropertyHandler から継承したフィールド
DEFAULT_APPLICATION_PARAMETER, DEFAULT_ENCODING_ATTRIBUTE, DEFAULT_EXCEPTION_ATTRIBUTE, DEFAULT_LOCALE_ATTRIBUTE, DEFAULT_SERVICE_PARAMETER, REQUEST_INFO_ATTRIBUTE
コンストラクタの概要
XmlServicePropertyHandler()
XmlServicePropertyHandlerを新規に生成します。
メソッドの概要
 String getApplicationParamName()
推奨されていません。 この実装は廃止されました。
 String getClientEncoding()
クライアントのエンコードを取得します。
 Locale getClientLocale()
クライアントのエンコードを取得します。
 String getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 ControllerConverterConfig getControllerConverterConfig(String application, String service, Locale locale)
キーに該当するコントローラコンバータの初期パラメータを取得します。
 String getControllerConverterName(String application, String service, Locale locale)
コントローラコンバータのクラス名を取得します。
 String getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String getInputErrorPagePath()
推奨されていません。 このメソッドではなく getInputErrorPagePath(Locale)を使用してください。
 String getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, Locale) を使用してください。
 String getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, Locale) を使用してください。
 String getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, String, Locale) を使用してください。
 String getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 String getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなく getNextPagePath(String, String, Locale) を使用してください。
 String getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getNextPagePath(String, String, String, Locale) を使用してください。
 String getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなく getServiceControllerName(String, String, Locale) を使用してください。
 String getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String getServiceErrorPagePath()
推奨されていません。 このメソッドではなく getServiceErrorPagePath(Locale) を使用してください。
 String getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceParamName()
推奨されていません。 この実装は廃止されました。
 String getServiceServletPath()
サービスサーブレットのパスを取得します。
 String getSystemErrorPagePath()
推奨されていません。 このメソッドではなく getSystemErrorPagePath(Locale)を使用してください。
 String getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String getTransitionName(String application, String service)
推奨されていません。 このメソッドではなく getTransitionName(String, String, Locale) を使用してください。
 String getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 ValidatorMapping[] getValidators(String application, String service, Locale locale)
キーに該当するバリデータを取得します。
 void init(PropertyParam[] params)
プロパティハンドラを初期化します。
 boolean isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

XmlServicePropertyHandler

public XmlServicePropertyHandler()
XmlServicePropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws ServicePropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース ServicePropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
ServicePropertyException - チェック時に例外が発生

getClientEncoding

public String getClientEncoding()
                         throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientEncoding
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getClientLocale

public Locale getClientLocale()
                       throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientLocale
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String, String)で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String)で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath() で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath() で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath()
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(Locale)を使用してください。

入力例外時のページのパスを取得します。 このメソッドは getInputErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなく getNextPagePath(String, String, Locale) を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。 このメソッドは getNextPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなく getNextPagePath(String, String, String, Locale) を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。 key が null の場合、 getNextPagePath(String, String) と同じ動作になります。 このメソッドは getNextPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。 key が null の場合、 getNextPagePath(String, String) と同じ動作になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service)
                                throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceControllerName(String, String, Locale) を使用してください。

サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。 このメソッドは getServiceControllerName(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service,
                                       Locale locale)
                                throws ServicePropertyException
サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, String, Locale) を使用してください。

処理例外時のページのパスを取得します。 このメソッドは getServiceErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, Locale) を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath(String)で取得されるページを返します。 このメソッドは getServiceErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, Locale) を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath()で取得されるページを返します。 このメソッドは getServiceErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath()
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(Locale) を使用してください。

処理例外時のページのパスを取得します。 このメソッドは getServiceErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String, String)で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String)で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath()で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath()
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(Locale)を使用してください。

システム例外時のページのパスを取得します。 このメソッドは getSystemErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service)
                         throws ServicePropertyException
推奨されていません。 このメソッドではなく getTransitionName(String, String, Locale) を使用してください。

トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。 このメソッドは getTransitionName(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException
トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getControllerConverterName

public String getControllerConverterName(String application,
                                         String service,
                                         Locale locale)
                                  throws ServicePropertyException
コントローラコンバータのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するコントローラコンバータ名を取得します。 特に設定されていない場合、nullが返ります。

定義:
インタフェース ServicePropertyHandler 内の getControllerConverterName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - コントローラコンバータのクラス名の取得時に例外が発生
導入されたバージョン:
6.1

getControllerConverterConfig

public ControllerConverterConfig getControllerConverterConfig(String application,
                                                              String service,
                                                              Locale locale)
                                                       throws ServicePropertyException
キーに該当するコントローラコンバータの初期パラメータを取得します。

定義:
インタフェース ServicePropertyHandler 内の getControllerConverterConfig
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータの初期パラメータ
例外:
ServicePropertyException - コントローラコンバータの初期パラメータの取得に失敗
導入されたバージョン:
6.1

getValidators

public ValidatorMapping[] getValidators(String application,
                                        String service,
                                        Locale locale)
                                 throws ServicePropertyException
キーに該当するバリデータを取得します。

定義:
インタフェース ServicePropertyHandler 内の getValidators
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
コントローラコンバータの初期パラメータ
例外:
ServicePropertyException - バリデータの取得に失敗
導入されたバージョン:
6.1

getServiceServletPath

public String getServiceServletPath()
                             throws ServicePropertyException
サービスサーブレットのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceServletPath
戻り値:
サービスサーブレットのパス
例外:
ServicePropertyException - サービスサーブレットのパスの取得時に例外が発生

getContextPath

public String getContextPath()
                      throws ServicePropertyException
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。

コンテキストパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getContextPath
戻り値:
コンテキストパス
例外:
ServicePropertyException - コンテキストパスの取得時に例外が発生

getApplicationParamName

public String getApplicationParamName()
                               throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

アプリケーションIDに該当するパラメータ名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_APPLICATION_PARAMETER で定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getApplicationParamName
戻り値:
アプリケーションIDに該当するパラメータ名
例外:
ServicePropertyException - アプリケーションIDに該当するパラメータ名の取得時に例外が発生

getServiceParamName

public String getServiceParamName()
                           throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

サービスIDに該当するパラメータ名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_SERVICE_PARAMETERで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceParamName
戻り値:
サービスIDに該当するパラメータ名
例外:
ServicePropertyException - サービスIDに該当するパラメータ名の取得時に例外が発生

getExceptionAttributeName

public String getExceptionAttributeName()
                                 throws ServicePropertyException
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_EXCEPTION_ATTRIBUTE で定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getExceptionAttributeName
戻り値:
例外の属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getEncodingAttributeName

public String getEncodingAttributeName()
                                throws ServicePropertyException
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_ENCODING_ATTRIBUTEで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getEncodingAttributeName
戻り値:
エンコードの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getLocaleAttributeName

public String getLocaleAttributeName()
                              throws ServicePropertyException
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_LOCALE_ATTRIBUTEで定義されている値を返します 。

定義:
インタフェース ServicePropertyHandler 内の getLocaleAttributeName
戻り値:
ロケールの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart 6.1.14
 前のクラス   次のクラス | フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド | 詳細:  フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler の使用

jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.HttpSessionFactory の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.HttpSessionFactory の使用

jp.co.intra_mart.framework.base.session.HttpSessionFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.HttpSessionObject の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.HttpSessionObject の使用

jp.co.intra_mart.framework.base.session.HttpSessionObject はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.IllegalSessionException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.IllegalSessionException の使用

jp.co.intra_mart.framework.base.session.IllegalSessionException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.IntramartSessionFactory の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.IntramartSessionFactory の使用

jp.co.intra_mart.framework.base.session.IntramartSessionFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.IntramartSessionObject の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.IntramartSessionObject の使用

jp.co.intra_mart.framework.base.session.IntramartSessionObject はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.session.SessionFactory の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.session.SessionFactory の使用

SessionFactory を使用しているパッケージ
jp.co.intra_mart.framework.base.session セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.session での SessionFactory の使用

SessionFactory を実装している jp.co.intra_mart.framework.base.session のクラス
class | HttpSessionFactory 推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
class | IntramartSessionFactory 推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。

SessionFactory を返す jp.co.intra_mart.framework.base.session のメソッド
 SessionFactory SessionManager.getSessionFactory()
セッションファクトリを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.SessionFactoryException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.SessionFactoryException の使用

SessionFactoryException を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での SessionFactoryException の使用

SessionFactoryException をスローする jp.co.intra_mart.framework.base.service のメソッド
 SessionObject Transition.getSessionObject()
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

jp.co.intra_mart.framework.base.session での SessionFactoryException の使用

SessionFactoryException をスローする jp.co.intra_mart.framework.base.session のメソッド
SessionObject | SessionManager.getSessionObject(ServletRequest request) セッションオブジェクトを取得します。
SessionObject | SessionFactory.createSessionObject(ServletRequest request) セッションオブジェクトを新規に生成します。
String | SessionFactory.encodeURL(ServletRequest request, ServletResponse response, String url) セッションIDをエンコードしてURLに追加します。
SessionObject | IntramartSessionFactory.createSessionObject(ServletRequest request) 推奨されていません。 セッションオブジェクトを新規に生成します。
String | IntramartSessionFactory.encodeURL(ServletRequest request, ServletResponse response, String url) 推奨されていません。 セッションIDをエンコードしてURLに追加します。
SessionObject | HttpSessionFactory.createSessionObject(ServletRequest request) 推奨されていません。 セッションオブジェクトを新規に生成します。
String | HttpSessionFactory.encodeURL(ServletRequest request, ServletResponse response, String url) 推奨されていません。 セッションIDをエンコードしてURLに追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.SessionFilter の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.SessionFilter の使用

jp.co.intra_mart.framework.base.session.SessionFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.SessionManager の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.SessionManager の使用

SessionManager を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での SessionManager の使用

SessionManager を返す jp.co.intra_mart.framework.base.service のメソッド
protected  SessionManager IntramartConnectServlet.getSessionManager()
推奨されていません。 セッションマネージャを取得します。

jp.co.intra_mart.framework.base.session での SessionManager の使用

SessionManager を返す jp.co.intra_mart.framework.base.session のメソッド
static SessionManager SessionManager.getSessionManager()
セッションマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.SessionManagerException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.SessionManagerException の使用

SessionManagerException を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での SessionManagerException の使用

SessionManagerException をスローする jp.co.intra_mart.framework.base.service のメソッド
 SessionObject Transition.getSessionObject()
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

jp.co.intra_mart.framework.base.session での SessionManagerException の使用

SessionManagerException をスローする jp.co.intra_mart.framework.base.session のメソッド
static SessionManager SessionManager.getSessionManager()
セッションマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.session.SessionObject の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.session.SessionObject の使用

SessionObject を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での SessionObject の使用

SessionObject を返す jp.co.intra_mart.framework.base.service のメソッド
 SessionObject Transition.getSessionObject()
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

jp.co.intra_mart.framework.base.session での SessionObject の使用

SessionObject を実装している jp.co.intra_mart.framework.base.session のクラス
class | HttpSessionObject 推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
class | IntramartSessionObject 推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。

SessionObject を返す jp.co.intra_mart.framework.base.session のメソッド
SessionObject | SessionManager.getSessionObject(ServletRequest request) セッションオブジェクトを取得します。
SessionObject | SessionFactory.createSessionObject(ServletRequest request) セッションオブジェクトを新規に生成します。
SessionObject | IntramartSessionFactory.createSessionObject(ServletRequest request) 推奨されていません。 セッションオブジェクトを新規に生成します。
SessionObject | HttpSessionFactory.createSessionObject(ServletRequest request) 推奨されていません。 セッションオブジェクトを新規に生成します。

jp.co.intra_mart.framework.base.web.bean での SessionObject の使用

SessionObject を返す jp.co.intra_mart.framework.base.web.bean のメソッド
 SessionObject HelperBean.getSession()
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.SessionObjectException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.SessionObjectException の使用

SessionObjectException を使用しているパッケージ
jp.co.intra_mart.framework.base.session セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.session での SessionObjectException の使用

SessionObjectException をスローする jp.co.intra_mart.framework.base.session のメソッド
void | SessionObject.setAttribute(String name, Object value) 指定された名前に対応するオブジェクトを追加します。
Object | SessionObject.getAttribute(String name) 指定された名前に対応するオブジェクトを取得します。
void | SessionObject.removeAttribute(String name) 指定された名前に対応するオブジェクトを削除します。
Enumeration | SessionObject.getAttributeNames() セッション内に存在する名前の一覧を取得します。
void | SessionObject.clear() セッション内に存在するすべてのオブジェクトを削除します。
void | IntramartSessionObject.setAttribute(String name, Object value) 推奨されていません。 指定された名前に対応するオブジェクトを追加します。
Object | IntramartSessionObject.getAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを取得します。
Enumeration | IntramartSessionObject.getAttributeNames() 推奨されていません。 セッション内に存在する名前の一覧を取得します。
void | IntramartSessionObject.removeAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを削除します。
void | IntramartSessionObject.clear() 推奨されていません。 セッション内に存在するすべてのオブジェクトを削除します。
void | HttpSessionObject.setAttribute(String name, Object value) 推奨されていません。 指定された名前に対応するオブジェクトを追加します。
void | HttpSessionObject.removeAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを削除します。
Object | HttpSessionObject.getAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを取得します。
Enumeration | HttpSessionObject.getAttributeNames() 推奨されていません。 セッション内に存在する名前の一覧を取得します。
void | HttpSessionObject.clear() 推奨されていません。 セッション内に存在するすべてのオブジェクトを削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.SessionPropertyException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.SessionPropertyException の使用

SessionPropertyException を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での SessionPropertyException の使用

SessionPropertyException をスローする jp.co.intra_mart.framework.base.service のメソッド
 SessionObject Transition.getSessionObject()
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

jp.co.intra_mart.framework.base.session での SessionPropertyException の使用

SessionPropertyException をスローする jp.co.intra_mart.framework.base.session のメソッド
String | XmlSessionPropertyHandler.getSessionFactoryName() 推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
String | XmlSessionPropertyHandler.getSessionParameter() 推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
String | XmlSessionPropertyHandler.getSessionObjectKey() 推奨されていません。 HttpSessionを直接取得するようにしてください。
String | XmlSessionPropertyHandler.getLoginUserIDKey() セッションに登録されているログインユーザIDのキーを取得します。
String | XmlSessionPropertyHandler.getLoginGroupIDKey() セッションに登録されているログイングループIDのキーを取得します。
String | XmlSessionPropertyHandler.getSessionErrorPagePath() セッションエラーページのパスを取得します。
String | SessionPropertyHandler.getSessionObjectKey() 推奨されていません。 HttpSessionを直接取得するようにしてください。
String | SessionPropertyHandler.getSessionParameter() 推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
String | SessionPropertyHandler.getSessionFactoryName() 推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
String | SessionPropertyHandler.getLoginUserIDKey() セッションに登録されているログインユーザIDのキーを取得します。
String | SessionPropertyHandler.getLoginGroupIDKey() セッションに登録されているログイングループIDのキーを取得します。
String | SessionPropertyHandler.getSessionErrorPagePath() セッションエラーページのパスを取得します。
SessionObject | SessionManager.getSessionObject(ServletRequest request) セッションオブジェクトを取得します。
String | DefaultSessionPropertyHandler.getSessionFactoryName() 推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
String | DefaultSessionPropertyHandler.getSessionParameter() 推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
String | DefaultSessionPropertyHandler.getSessionObjectKey() 推奨されていません。 HttpSessionを直接取得するようにしてください。
String | DefaultSessionPropertyHandler.getLoginUserIDKey() セッションに登録されているログインユーザIDのキーを取得します。
String | DefaultSessionPropertyHandler.getLoginGroupIDKey() セッションに登録されているログイングループIDのキーを取得します。
String | DefaultSessionPropertyHandler.getSessionErrorPagePath() セッションエラーページのパスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.session.SessionPropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.session.SessionPropertyHandler の使用

SessionPropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での SessionPropertyHandler の使用

SessionPropertyHandler を返す jp.co.intra_mart.framework.base.service のメソッド
protected  SessionPropertyHandler IntramartConnectServlet.getSessionPropertyHandler()
推奨されていません。 セッションプロパティハンドラを取得します。

jp.co.intra_mart.framework.base.session での SessionPropertyHandler の使用

SessionPropertyHandler を実装している jp.co.intra_mart.framework.base.session のクラス
class | DefaultSessionPropertyHandler セッションに関連するデフォルトのプロパティハンドラです。
class | XmlSessionPropertyHandler セッションに関連するXMLのプロパティハンドラです。

SessionPropertyHandler を返す jp.co.intra_mart.framework.base.session のメソッド
 SessionPropertyHandler SessionManager.getSessionPropertyHandler()
セッションプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler の使用

jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DefaultSessionPropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス DefaultSessionPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler
すべての実装インタフェース:
PropertyHandler, SessionPropertyHandler
public class DefaultSessionPropertyHandler
extends Object
implements SessionPropertyHandler

セッションに関連するデフォルトのプロパティハンドラです。 プロパティの設定内容は以下のとおりです。

キー | 内容
factory.name | SessionFactoryのクラス名
object.param | リクエストに渡すセッションIDのパラメータ名
error.page.path | セッションエラー（セッションタイムアウト等）のときに表示するページのパス
object.key | リクエストの属性にSessionObjectを保存する時のキー
reserved.user.key | SessionObjectの属性に設定されているユーザIDのキー
reserved.group.key | SessionObjectの属性に設定されているログイングループIDのキー

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
コンストラクタの概要
DefaultSessionPropertyHandler()
DefaultSessionPropertyHandlerを新規に生成します。
メソッドの概要
String | getLoginGroupIDKey() セッションに登録されているログイングループIDのキーを取得します。
String | getLoginUserIDKey() セッションに登録されているログインユーザIDのキーを取得します。
String | getSessionErrorPagePath() セッションエラーページのパスを取得します。
String | getSessionFactoryName() 推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
String | getSessionObjectKey() 推奨されていません。 HttpSessionを直接取得するようにしてください。
String | getSessionParameter() 推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultSessionPropertyHandler

public DefaultSessionPropertyHandler()
DefaultSessionPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

getSessionFactoryName

public String getSessionFactoryName()
                             throws SessionPropertyException
推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。

セッションファクトリのクラス名を取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース SessionPropertyHandler 内の getSessionFactoryName
戻り値:
セッションファクトリのクラス名（設定されていない場合null）
例外:
SessionPropertyException - セッションファクトリのクラス名の取得時に例外が発生

getSessionParameter

public String getSessionParameter()
                           throws SessionPropertyException
推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。

セッションIDのパラメータ名を取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース SessionPropertyHandler 内の getSessionParameter
戻り値:
セッションIDのパラメータ名（設定されていない場合null）
例外:
SessionPropertyException - セッションIDのパラメータ名の取得時に例外が発生

getSessionObjectKey

public String getSessionObjectKey()
                           throws SessionPropertyException
推奨されていません。 HttpSessionを直接取得するようにしてください。

セッションオブジェクトのキーを取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース SessionPropertyHandler 内の getSessionObjectKey
戻り値:
セッションオブジェクトのキー（設定されていない場合null）
例外:
SessionPropertyException - セッションオブジェクトのキーの取得時に例外が発生

getLoginUserIDKey

public String getLoginUserIDKey()
                         throws SessionPropertyException
セッションに登録されているログインユーザIDのキーを取得します。

定義:
インタフェース SessionPropertyHandler 内の getLoginUserIDKey
戻り値:
ログインユーザIDのキー
例外:
SessionPropertyException - 属性名の取得時に例外が発生

getLoginGroupIDKey

public String getLoginGroupIDKey()
                          throws SessionPropertyException
セッションに登録されているログイングループIDのキーを取得します。

定義:
インタフェース SessionPropertyHandler 内の getLoginGroupIDKey
戻り値:
ログイングループIDのキー
例外:
SessionPropertyException - 属性名の取得時に例外が発生

getSessionErrorPagePath

public String getSessionErrorPagePath()
                               throws SessionPropertyException
セッションエラーページのパスを取得します。

定義:
インタフェース SessionPropertyHandler 内の getSessionErrorPagePath
戻り値:
セッションエラーページのパス
例外:
SessionPropertyException - セッションエラーページのパスの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HttpSessionFactory (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス HttpSessionFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.HttpSessionFactory
すべての実装インタフェース:
SessionFactory
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。

public class HttpSessionFactory
extends Object
implements SessionFactory

HTTPセッションに関連するセッションファクトリです。

バージョン:
1.0

コンストラクタの概要
HttpSessionFactory()
推奨されていません。 HttpSessionFactoryを新規に生成します。
メソッドの概要
SessionObject | createSessionObject(ServletRequest request) 推奨されていません。 セッションオブジェクトを新規に生成します。
String | encodeURL(ServletRequest request, ServletResponse response, String url) 推奨されていません。 セッションIDをエンコードしてURLに追加します。
boolean | isEncodeRequired() 推奨されていません。 セッション情報をURLに含めてエンコードする必要があるかどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HttpSessionFactory

public HttpSessionFactory()
推奨されていません。
HttpSessionFactoryを新規に生成します。

メソッドの詳細

createSessionObject

public SessionObject createSessionObject(ServletRequest request)
                                  throws SessionFactoryException
推奨されていません。
セッションオブジェクトを新規に生成します。 HttpSessionObjectを生成します。

定義:
インタフェース SessionFactory 内の createSessionObject
パラメータ:
request - リクエスト
戻り値:
セッションオブジェクト
例外:
SessionFactoryException - セッションオブジェクトの取得に失敗
関連項目:
HttpSessionObject

isEncodeRequired

public boolean isEncodeRequired()
推奨されていません。
セッション情報をURLに含めてエンコードする必要があるかどうか調べます。

定義:
インタフェース SessionFactory 内の isEncodeRequired
戻り値:
エンコードが必要な場合true、そうでない場合false

encodeURL

public String encodeURL(ServletRequest request,
                        ServletResponse response,
                        String url)
                 throws SessionFactoryException
推奨されていません。
セッションIDをエンコードしてURLに追加します。 追加される内容はセッションオブジェクトの実装に依存します。

定義:
インタフェース SessionFactory 内の encodeURL
パラメータ:
request - リクエスト
response - レスポンス
url - リクエストのURL
戻り値:
セッションIDが反映されたURL
例外:
SessionFactoryException - URLの生成時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpSessionObject (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス HttpSessionObject

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.HttpSessionObject
すべての実装インタフェース:
SessionObject
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。

public class HttpSessionObject
extends Object
implements SessionObject

HttpSessionを利用したSessionObjectです。

バージョン:
1.0

コンストラクタの概要
HttpSessionObject(HttpSession session)
推奨されていません。 HttpSessionObjectを新規に生成します。
メソッドの概要
void | clear() 推奨されていません。 セッション内に存在するすべてのオブジェクトを削除します。
Object | getAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを取得します。
Enumeration | getAttributeNames() 推奨されていません。 セッション内に存在する名前の一覧を取得します。
String | getSessionID() 推奨されていません。 セッションを一意に識別するIDを取得します。
void | removeAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを削除します。
void | setAttribute(String name, Object value) 推奨されていません。 指定された名前に対応するオブジェクトを追加します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HttpSessionObject

public HttpSessionObject(HttpSession session)
推奨されていません。
HttpSessionObjectを新規に生成します。

パラメータ:
session - HttpSession
メソッドの詳細

getSessionID

public String getSessionID()
推奨されていません。
セッションを一意に識別するIDを取得します。

定義:
インタフェース SessionObject 内の getSessionID
戻り値:
セッションを識別するID

setAttribute

public void setAttribute(String name,
                         Object value)
                  throws SessionObjectException
推奨されていません。
指定された名前に対応するオブジェクトを追加します。

定義:
インタフェース SessionObject 内の setAttribute
パラメータ:
name - オブジェクトに関連付けられる名前
value - オブジェクト
例外:
SessionObjectException - オブジェクトの追加時に例外が発生

removeAttribute

public void removeAttribute(String name)
                     throws SessionObjectException
推奨されていません。
指定された名前に対応するオブジェクトを削除します。 指定された名前で登録されていない場合、何もしません。

定義:
インタフェース SessionObject 内の removeAttribute
パラメータ:
name - オブジェクトに関連付けられる名前
例外:
SessionObjectException - オブジェクトの削除時に例外が発生

getAttribute

public Object getAttribute(String name)
                    throws SessionObjectException
推奨されていません。
指定された名前に対応するオブジェクトを取得します。 対応するオブジェクトがない場合、nullが返ります。

定義:
インタフェース SessionObject 内の getAttribute
パラメータ:
name - オブジェクトに関連付けられる名前
戻り値:
キーに対応するオブジェクト
例外:
SessionObjectException - オブジェクトの取得時に例外が発生

getAttributeNames

public Enumeration getAttributeNames()
                              throws SessionObjectException
推奨されていません。
セッション内に存在する名前の一覧を取得します。

定義:
インタフェース SessionObject 内の getAttributeNames
戻り値:
名前のコレクション
例外:
SessionObjectException - 名前の一覧取得時に例外が発生

clear

public void clear()
           throws SessionObjectException
推奨されていません。
セッション内に存在するすべてのオブジェクトを削除します。

定義:
インタフェース SessionObject 内の clear
例外:
SessionObjectException - オブジェクトの削除時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IllegalSessionException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス IllegalSessionException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.session.IllegalSessionException
すべての実装インタフェース:
Serializable
public class IllegalSessionException
extends SystemException

セッション情報取得の失敗や不正なセッションを検出した場合にスローされます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
IllegalSessionException()
詳細メッセージを指定しないで IllegalSessionException を構築します。
IllegalSessionException(String msg)
指定された詳細メッセージを持つ IllegalSessionException を構築します。
IllegalSessionException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IllegalSessionException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalSessionException

public IllegalSessionException()
詳細メッセージを指定しないで IllegalSessionException を構築します。

IllegalSessionException

public IllegalSessionException(String msg)
指定された詳細メッセージを持つ IllegalSessionException を構築します。

パラメータ:
msg - 詳細メッセージ

IllegalSessionException

public IllegalSessionException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IllegalSessionException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


IntramartSessionFactory (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス IntramartSessionFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.IntramartSessionFactory
すべての実装インタフェース:
SessionFactory
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。

public class IntramartSessionFactory
extends Object
implements SessionFactory

intra-martのセッションを利用するセッションオブジェクトを生成します。 このクラスを利用するためには、intra-martをインストールする必要があります。

バージョン:
1.0

コンストラクタの概要
IntramartSessionFactory()
推奨されていません。 IntramartSessionFactoryを新規に生成します。
メソッドの概要
SessionObject | createSessionObject(ServletRequest request) 推奨されていません。 セッションオブジェクトを新規に生成します。
String | encodeURL(ServletRequest request, ServletResponse response, String url) 推奨されていません。 セッションIDをエンコードしてURLに追加します。
boolean | isEncodeRequired() 推奨されていません。 セッション情報をURLに含めてエンコードする必要があるかどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartSessionFactory

public IntramartSessionFactory()
推奨されていません。
IntramartSessionFactoryを新規に生成します。

メソッドの詳細

createSessionObject

public SessionObject createSessionObject(ServletRequest request)
                                  throws SessionFactoryException
推奨されていません。
セッションオブジェクトを新規に生成します。

定義:
インタフェース SessionFactory 内の createSessionObject
パラメータ:
request - リクエスト
戻り値:
セッションオブジェクト
例外:
SessionFactoryException - セッションオブジェクトの取得に失敗

isEncodeRequired

public boolean isEncodeRequired()
推奨されていません。
セッション情報をURLに含めてエンコードする必要があるかどうか調べます。

定義:
インタフェース SessionFactory 内の isEncodeRequired
戻り値:
エンコードが必要な場合true、そうでない場合false

encodeURL

public String encodeURL(ServletRequest request,
                        ServletResponse response,
                        String url)
                 throws SessionFactoryException
推奨されていません。
セッションIDをエンコードしてURLに追加します。 追加される内容はセッションオブジェクトの実装に依存します。

定義:
インタフェース SessionFactory 内の encodeURL
パラメータ:
request - リクエスト
response - レスポンス
url - リクエストのURL
戻り値:
セッションIDが反映されたURL
例外:
SessionFactoryException - URLの生成時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartSessionObject (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス IntramartSessionObject

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.IntramartSessionObject
すべての実装インタフェース:
SessionObject
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。

public class IntramartSessionObject
extends Object
implements SessionObject

intra-martのSessionを利用したSessionObjectです。 このクラスを利用するためには、intra-martをインストールする必要があります。

バージョン:
1.0

コンストラクタの概要
IntramartSessionObject(jp.co.intra_mart.foundation.service.client.information.SessionMemory session)
推奨されていません。 IntramartSessionObjectを生成します。
メソッドの概要
void | clear() 推奨されていません。 セッション内に存在するすべてのオブジェクトを削除します。
Object | getAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを取得します。
Enumeration | getAttributeNames() 推奨されていません。 セッション内に存在する名前の一覧を取得します。
String | getSessionID() 推奨されていません。 セッションを一意に識別するIDを取得します。
void | removeAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを削除します。
void | setAttribute(String name, Object value) 推奨されていません。 指定された名前に対応するオブジェクトを追加します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartSessionObject

public IntramartSessionObject(jp.co.intra_mart.foundation.service.client.information.SessionMemory session)
推奨されていません。
IntramartSessionObjectを生成します。

パラメータ:
session - intra-martの共有データオブジェクト
メソッドの詳細

getSessionID

public String getSessionID()
推奨されていません。
セッションを一意に識別するIDを取得します。

定義:
インタフェース SessionObject 内の getSessionID
戻り値:
セッションを識別するID

setAttribute

public void setAttribute(String name,
                         Object value)
                  throws SessionObjectException
推奨されていません。
指定された名前に対応するオブジェクトを追加します。

定義:
インタフェース SessionObject 内の setAttribute
パラメータ:
name - オブジェクトに関連付けられる名前
value - オブジェクト
例外:
SessionObjectException - オブジェクトの追加時に例外が発生

getAttribute

public Object getAttribute(String name)
                    throws SessionObjectException
推奨されていません。
指定された名前に対応するオブジェクトを取得します。 対応するオブジェクトがない場合、nullが返ります。

定義:
インタフェース SessionObject 内の getAttribute
パラメータ:
name - オブジェクトに関連付けられる名前
戻り値:
キーに対応するオブジェクト
例外:
SessionObjectException - オブジェクトの取得時に例外が発生

getAttributeNames

public Enumeration getAttributeNames()
                              throws SessionObjectException
推奨されていません。
セッション内に存在する名前の一覧を取得します。

定義:
インタフェース SessionObject 内の getAttributeNames
戻り値:
名前のコレクション
例外:
SessionObjectException - 名前の一覧取得時に例外が発生

removeAttribute

public void removeAttribute(String name)
                     throws SessionObjectException
推奨されていません。
指定された名前に対応するオブジェクトを削除します。 指定された名前で登録されていない場合、何もしません。

定義:
インタフェース SessionObject 内の removeAttribute
パラメータ:
name - オブジェクトに関連付けられる名前
例外:
SessionObjectException - オブジェクトの削除時に例外が発生

clear

public void clear()
           throws SessionObjectException
推奨されていません。
セッション内に存在するすべてのオブジェクトを削除します。

定義:
インタフェース SessionObject 内の clear
例外:
SessionObjectException - オブジェクトの削除時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.session (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.base.session
インタフェース
SessionFactory
SessionObject
SessionPropertyHandler
クラス
DefaultSessionPropertyHandler
HttpSessionFactory
HttpSessionObject
IntramartSessionFactory
IntramartSessionObject
SessionFilter
SessionManager
XmlSessionPropertyHandler
例外
IllegalSessionException
SessionFactoryException
SessionManagerException
SessionObjectException
SessionPropertyException


jp.co.intra_mart.framework.base.session (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.session

セッションに関連するクラスのパッケージです。

参照:
説明

インタフェースの概要
SessionFactory | セッションに関連するファクトリクラスとなるインタフェースです。
SessionObject | セッションに関連する情報を持つオブジェクトです。
SessionPropertyHandler | セッションに関連するプロパティを取得します。

クラスの概要
DefaultSessionPropertyHandler | セッションに関連するデフォルトのプロパティハンドラです。
HttpSessionFactory | 推奨されていません。 このクラスは互換性のために残されています。
HttpSessionObject | 推奨されていません。 このクラスは互換性のために残されています。
IntramartSessionFactory | 推奨されていません。 このクラスは互換性のために残されています。
IntramartSessionObject | 推奨されていません。 このクラスは互換性のために残されています。
SessionFilter | セッション管理をします。
SessionManager | セッションマネージャです。
XmlSessionPropertyHandler | セッションに関連するXMLのプロパティハンドラです。

例外の概要
IllegalSessionException | セッション情報取得の失敗や不正なセッションを検出した場合にスローされます。
SessionFactoryException | セッションファクトリ内の例外です。
SessionManagerException | セッションマネージャ内の例外です。
SessionObjectException | セッションオブジェクト内の例外です。
SessionPropertyException | セッションプロパティ取得時の例外です。

パッケージ jp.co.intra_mart.framework.base.session の説明

セッションに関連するクラスのパッケージです。


jp.co.intra_mart.framework.base.session クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.session の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler (implements jp.co.intra_mart.framework.base.session.SessionPropertyHandler)
    • class jp.co.intra_mart.framework.base.session.HttpSessionFactory (implements jp.co.intra_mart.framework.base.session.SessionFactory)
    • class jp.co.intra_mart.framework.base.session.HttpSessionObject (implements jp.co.intra_mart.framework.base.session.SessionObject)
    • class jp.co.intra_mart.framework.base.session.IntramartSessionFactory (implements jp.co.intra_mart.framework.base.session.SessionFactory)
    • class jp.co.intra_mart.framework.base.session.IntramartSessionObject (implements jp.co.intra_mart.framework.base.session.SessionObject)
    • class jp.co.intra_mart.framework.base.session.SessionFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.session.SessionManager
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.session.IllegalSessionException
            • class jp.co.intra_mart.framework.base.session.SessionFactoryException
            • class jp.co.intra_mart.framework.base.session.SessionManagerException
            • class jp.co.intra_mart.framework.base.session.SessionObjectException
            • class jp.co.intra_mart.framework.base.session.SessionPropertyException
    • class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler (implements jp.co.intra_mart.framework.base.session.SessionPropertyHandler)

インタフェース階層

  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler
  • interface jp.co.intra_mart.framework.base.session.SessionFactory
  • interface jp.co.intra_mart.framework.base.session.SessionObject


パッケージ jp.co.intra_mart.framework.base.session の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.session の使用

jp.co.intra_mart.framework.base.session を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.base.session のクラス
SessionFactoryException
セッションファクトリ内の例外です。
SessionManager
セッションマネージャです。
SessionManagerException
セッションマネージャ内の例外です。
SessionObject
セッションに関連する情報を持つオブジェクトです。
SessionPropertyException
セッションプロパティ取得時の例外です。
SessionPropertyHandler
セッションに関連するプロパティを取得します。

jp.co.intra_mart.framework.base.session により使用される jp.co.intra_mart.framework.base.session のクラス
SessionFactory
セッションに関連するファクトリクラスとなるインタフェースです。
SessionFactoryException
セッションファクトリ内の例外です。
SessionManager
セッションマネージャです。
SessionManagerException
セッションマネージャ内の例外です。
SessionObject
セッションに関連する情報を持つオブジェクトです。
SessionObjectException
セッションオブジェクト内の例外です。
SessionPropertyException
セッションプロパティ取得時の例外です。
SessionPropertyHandler
セッションに関連するプロパティを取得します。

jp.co.intra_mart.framework.base.web.bean により使用される jp.co.intra_mart.framework.base.session のクラス
SessionObject
セッションに関連する情報を持つオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SessionFactory (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
インタフェース SessionFactory

既知の実装クラスの一覧:
HttpSessionFactory, IntramartSessionFactory
public interface SessionFactory

セッションに関連するファクトリクラスとなるインタフェースです。

バージョン:
1.0

メソッドの概要
SessionObject | createSessionObject(ServletRequest request) セッションオブジェクトを新規に生成します。
String | encodeURL(ServletRequest request, ServletResponse response, String url) セッションIDをエンコードしてURLに追加します。
boolean | isEncodeRequired() セッション情報をURLに含めてエンコードする必要があるかどうか調べます。

メソッドの詳細

createSessionObject

public SessionObject createSessionObject(ServletRequest request)
                                  throws SessionFactoryException
セッションオブジェクトを新規に生成します。

パラメータ:
request - リクエスト
戻り値:
セッションオブジェクト
例外:
SessionFactoryException - セッションオブジェクトの取得に失敗

isEncodeRequired

public boolean isEncodeRequired()
セッション情報をURLに含めてエンコードする必要があるかどうか調べます。

戻り値:
エンコードが必要な場合true、そうでない場合false

encodeURL

public String encodeURL(ServletRequest request,
                        ServletResponse response,
                        String url)
                 throws SessionFactoryException
セッションIDをエンコードしてURLに追加します。 追加される内容はセッションオブジェクトの実装に依存します。

パラメータ:
request - リクエスト
response - レスポンス
url - リクエストのURL
戻り値:
セッションIDが反映されたURL
例外:
SessionFactoryException - URLの生成時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SessionFactoryException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス SessionFactoryException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.session.SessionFactoryException
すべての実装インタフェース:
Serializable
public class SessionFactoryException
extends SystemException

セッションファクトリ内の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SessionFactoryException()
詳細メッセージを指定しないで SessionFactoryException を構築します。
SessionFactoryException(String msg)
指定された詳細メッセージを持つ SessionFactoryException を構築します。
SessionFactoryException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionFactoryException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SessionFactoryException

public SessionFactoryException()
詳細メッセージを指定しないで SessionFactoryException を構築します。

SessionFactoryException

public SessionFactoryException(String msg)
指定された詳細メッセージを持つ SessionFactoryException を構築します。

パラメータ:
msg - 詳細メッセージ

SessionFactoryException

public SessionFactoryException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionFactoryException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionFilter (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス SessionFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.SessionFilter
すべての実装インタフェース:
Filter
public class SessionFilter
extends Object
implements Filter

セッション管理をします。

バージョン:
1.0

コンストラクタの概要
SessionFilter()
メソッドの概要
void | destroy() フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) リクエストのセッション管理をします。
void | init(FilterConfig filterConfig) セッション用のフィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SessionFilter

public SessionFilter()
メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
セッション用のフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
リクエストのセッション管理をします。 SessionFactoryを利用しない場合、以下の条件がすべて満たされるときセッションが継続しているものとみなされます。
  • セッションが存在する
SessionFactoryを利用する場合、以下の条件がすべて満たされるときセッションが継続しているものとみなされます。
  • sessionにSessionPropertyHandler.getLoginUserIDKey()で指定された属性（ログインユーザID）が登録されている
  • sessionにSessionPropertyHandler.getLoginGroupIDKey()で指定された属性（ログイングループID）が登録されている

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionManager (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス SessionManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.SessionManager
public class SessionManager
extends Object

セッションマネージャです。

バージョン:
1.0

フィールドの概要
static String SESSION_PROPERTY_HANDLER_KEY
セッションプロパティハンドラのキー
メソッドの概要
SessionFactory | getSessionFactory() セッションファクトリを取得します。
static SessionManager | getSessionManager() セッションマネージャを取得します。
SessionObject | getSessionObject(ServletRequest request) セッションオブジェクトを取得します。
SessionPropertyHandler | getSessionPropertyHandler() セッションプロパティハンドラを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

SESSION_PROPERTY_HANDLER_KEY

public static final String SESSION_PROPERTY_HANDLER_KEY
セッションプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getSessionManager

public static SessionManager getSessionManager()
                                        throws SessionManagerException
セッションマネージャを取得します。

戻り値:
セッションマネージャ
例外:
SessionManagerException - セッションマネージャの生成に失敗した

getSessionPropertyHandler

public SessionPropertyHandler getSessionPropertyHandler()
セッションプロパティハンドラを取得します。

戻り値:
セッションプロパティハンドラ

getSessionFactory

public SessionFactory getSessionFactory()
セッションファクトリを取得します。 セッションプロパティにSessionFactoryが指定されていない場合、nullが返ります。

戻り値:
セッションファクトリ（プロパティが設定されていない場合null）

getSessionObject

public SessionObject getSessionObject(ServletRequest request)
                               throws SessionPropertyException,
                                      SessionFactoryException
セッションオブジェクトを取得します。 指定されたリクエスト内にあるセッションオブジェクトを取得します。 セッションが存在しない場合、新規にセッションを生成します。 このメソッドはセッションプロパティにSessionFactoryを指定したときに有効になります。

パラメータ:
request - リクエスト
戻り値:
セッションオブジェクト
例外:
SessionPropertyException - セッションプロパティの取得に失敗
SessionFactoryException - セッションオブジェクトの生成に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionManagerException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス SessionManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.session.SessionManagerException
すべての実装インタフェース:
Serializable
public class SessionManagerException
extends SystemException

セッションマネージャ内の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SessionManagerException()
詳細メッセージを指定しないで SessionManagerException を構築します。
SessionManagerException(String msg)
指定された詳細メッセージを持つ SessionManagerException を構築します。
SessionManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SessionManagerException

public SessionManagerException()
詳細メッセージを指定しないで SessionManagerException を構築します。

SessionManagerException

public SessionManagerException(String msg)
指定された詳細メッセージを持つ SessionManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

SessionManagerException

public SessionManagerException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionObject (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
インタフェース SessionObject

既知の実装クラスの一覧:
HttpSessionObject, IntramartSessionObject
public interface SessionObject

セッションに関連する情報を持つオブジェクトです。 セッション管理の方法に応じてこのインタフェースを実装してください。

バージョン:
1.0

メソッドの概要
void | clear() セッション内に存在するすべてのオブジェクトを削除します。
Object | getAttribute(String name) 指定された名前に対応するオブジェクトを取得します。
Enumeration | getAttributeNames() セッション内に存在する名前の一覧を取得します。
String | getSessionID() セッションを一意に識別するIDを取得します。
void | removeAttribute(String name) 指定された名前に対応するオブジェクトを削除します。
void | setAttribute(String name, Object value) 指定された名前に対応するオブジェクトを追加します。

メソッドの詳細

getSessionID

public String getSessionID()
セッションを一意に識別するIDを取得します。

戻り値:
セッションを識別するID

setAttribute

public void setAttribute(String name,
                         Object value)
                  throws SessionObjectException
指定された名前に対応するオブジェクトを追加します。

パラメータ:
name - オブジェクトに関連付けられる名前
value - オブジェクト
例外:
SessionObjectException - オブジェクトの追加時に例外が発生

getAttribute

public Object getAttribute(String name)
                    throws SessionObjectException
指定された名前に対応するオブジェクトを取得します。 対応するオブジェクトがない場合、nullが返ります。

パラメータ:
name - オブジェクトに関連付けられる名前
戻り値:
キーに対応するオブジェクト
例外:
SessionObjectException - オブジェクトの取得時に例外が発生

removeAttribute

public void removeAttribute(String name)
                     throws SessionObjectException
指定された名前に対応するオブジェクトを削除します。 指定された名前で登録されていない場合、何もしません。

パラメータ:
name - オブジェクトに関連付けられる名前
例外:
SessionObjectException - オブジェクトの削除時に例外が発生

getAttributeNames

public Enumeration getAttributeNames()
                              throws SessionObjectException
セッション内に存在する名前の一覧を取得します。

戻り値:
名前のコレクション
例外:
SessionObjectException - 名前の一覧取得時に例外が発生

clear

public void clear()
           throws SessionObjectException
セッション内に存在するすべてのオブジェクトを削除します。

例外:
SessionObjectException - オブジェクトの削除時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionObjectException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス SessionObjectException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.session.SessionObjectException
すべての実装インタフェース:
Serializable
public class SessionObjectException
extends SystemException

セッションオブジェクト内の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SessionObjectException()
詳細メッセージを指定しないで SessionObjectException を構築します。
SessionObjectException(String msg)
指定された詳細メッセージを持つ SessionObjectException を構築します。
SessionObjectException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionObjectException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SessionObjectException

public SessionObjectException()
詳細メッセージを指定しないで SessionObjectException を構築します。

SessionObjectException

public SessionObjectException(String msg)
指定された詳細メッセージを持つ SessionObjectException を構築します。

パラメータ:
msg - 詳細メッセージ

SessionObjectException

public SessionObjectException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionObjectException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionPropertyException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス SessionPropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.session.SessionPropertyException
すべての実装インタフェース:
Serializable
public class SessionPropertyException
extends SystemException

セッションプロパティ取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SessionPropertyException()
詳細メッセージを指定しないで SessionPropertyException を構築します。
SessionPropertyException(String msg)
指定された詳細メッセージを持つ SessionPropertyException を構築します。
SessionPropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionPropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SessionPropertyException

public SessionPropertyException()
詳細メッセージを指定しないで SessionPropertyException を構築します。

SessionPropertyException

public SessionPropertyException(String msg)
指定された詳細メッセージを持つ SessionPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

SessionPropertyException

public SessionPropertyException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SessionPropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
インタフェース SessionPropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultSessionPropertyHandler, XmlSessionPropertyHandler
public interface SessionPropertyHandler
extends PropertyHandler

セッションに関連するプロパティを取得します。

バージョン:
1.0

メソッドの概要
String | getLoginGroupIDKey() セッションに登録されているログイングループIDのキーを取得します。
String | getLoginUserIDKey() セッションに登録されているログインユーザIDのキーを取得します。
String | getSessionErrorPagePath() セッションエラーページのパスを取得します。
String | getSessionFactoryName() 推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
String | getSessionObjectKey() 推奨されていません。 HttpSessionを直接取得するようにしてください。
String | getSessionParameter() 推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

getSessionObjectKey

public String getSessionObjectKey()
                           throws SessionPropertyException
推奨されていません。 HttpSessionを直接取得するようにしてください。

セッションオブジェクトのキーを取得します。 何も設定されていない場合nullが返ります。

戻り値:
セッションオブジェクトのキー
例外:
SessionPropertyException - セッションオブジェクトのキーの取得時に例外が発生

getSessionParameter

public String getSessionParameter()
                           throws SessionPropertyException
推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。

セッションIDのパラメータ名を取得します。 何も設定されていない場合nullが返ります。

戻り値:
セッションIDのパラメータ名
例外:
SessionPropertyException - セッションIDのパラメータ名の取得時に例外が発生

getSessionFactoryName

public String getSessionFactoryName()
                             throws SessionPropertyException
推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。

セッションファクトリのクラス名を取得します。 何も設定されていない場合nullが返ります。

戻り値:
セッションファクトリのクラス名
例外:
SessionPropertyException - セッションファクトリのクラス名の取得時に例外が発生

getLoginUserIDKey

public String getLoginUserIDKey()
                         throws SessionPropertyException
セッションに登録されているログインユーザIDのキーを取得します。

戻り値:
ログインユーザIDのキー
例外:
SessionPropertyException - 属性名の取得時に例外が発生

getLoginGroupIDKey

public String getLoginGroupIDKey()
                          throws SessionPropertyException
セッションに登録されているログイングループIDのキーを取得します。

戻り値:
ログイングループIDのキー
例外:
SessionPropertyException - 属性名の取得時に例外が発生

getSessionErrorPagePath

public String getSessionErrorPagePath()
                               throws SessionPropertyException
セッションエラーページのパスを取得します。

戻り値:
セッションエラーページのパス
例外:
SessionPropertyException - セッションエラーページのパスの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


XmlSessionPropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス XmlSessionPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler
すべての実装インタフェース:
PropertyHandler, SessionPropertyHandler
public class XmlSessionPropertyHandler
extends Object
implements SessionPropertyHandler

セッションに関連するXMLのプロパティハンドラです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのxmlファイル名
static String | DEFAULT_BUNDLE_NAME_PARAM xmlファイル名のパラメータ名
コンストラクタの概要
XmlSessionPropertyHandler()
メソッドの概要
String | getLoginGroupIDKey() セッションに登録されているログイングループIDのキーを取得します。
String | getLoginUserIDKey() セッションに登録されているログインユーザIDのキーを取得します。
String | getSessionErrorPagePath() セッションエラーページのパスを取得します。
String | getSessionFactoryName() 推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
String | getSessionObjectKey() 推奨されていません。 HttpSessionを直接取得するようにしてください。
String | getSessionParameter() 推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのxmlファイル名

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
xmlファイル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

XmlSessionPropertyHandler

public XmlSessionPropertyHandler()
メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

getSessionFactoryName

public String getSessionFactoryName()
                             throws SessionPropertyException
推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。

セッションファクトリのクラス名を取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース SessionPropertyHandler 内の getSessionFactoryName
戻り値:
セッションファクトリのクラス名（設定されていない場合null）
例外:
SessionPropertyException - セッションファクトリのクラス名の取得時に例外が発生

getSessionParameter

public String getSessionParameter()
                           throws SessionPropertyException
推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。

セッションIDのパラメータ名を取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース SessionPropertyHandler 内の getSessionParameter
戻り値:
セッションIDのパラメータ名（設定されていない場合null）
例外:
SessionPropertyException - セッションパラメータ取得時に例外が発生

getSessionObjectKey

public String getSessionObjectKey()
                           throws SessionPropertyException
推奨されていません。 HttpSessionを直接取得するようにしてください。

セッションオブジェクトのキーを取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース SessionPropertyHandler 内の getSessionObjectKey
戻り値:
セッションオブジェクトのキー（設定されていない場合null）
例外:
SessionPropertyException - セッションオブジェクトキー取得時に例外が発生

getLoginUserIDKey

public String getLoginUserIDKey()
                         throws SessionPropertyException
セッションに登録されているログインユーザIDのキーを取得します。

定義:
インタフェース SessionPropertyHandler 内の getLoginUserIDKey
戻り値:
ログインユーザIDのキー
例外:
SessionPropertyException - 属性名の取得時に例外が発生

getLoginGroupIDKey

public String getLoginGroupIDKey()
                          throws SessionPropertyException
セッションに登録されているログイングループIDのキーを取得します。

定義:
インタフェース SessionPropertyHandler 内の getLoginGroupIDKey
戻り値:
ログイングループIDのキー
例外:
SessionPropertyException - 属性名の取得時に例外が発生

getSessionErrorPagePath

public String getSessionErrorPagePath()
                               throws SessionPropertyException
セッションエラーページのパスを取得します。

定義:
インタフェース SessionPropertyHandler 内の getSessionErrorPagePath
戻り値:
セッションエラーページのパス
例外:
SessionPropertyException - セッションエラーページのパスの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.base.util.ConfigurationUserInfo の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.util.ConfigurationUserInfo の使用

jp.co.intra_mart.framework.base.util.ConfigurationUserInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.util.EmptyUserInfo の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.util.EmptyUserInfo の使用

jp.co.intra_mart.framework.base.util.EmptyUserInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.util.UserInfo の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.util.UserInfo の使用

UserInfo を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での UserInfo の使用

UserInfo を返す jp.co.intra_mart.framework.base.event のメソッド
 UserInfo Event.getUserInfo()
ログインユーザの情報を取得します。

UserInfo 型のパラメータを持つ jp.co.intra_mart.framework.base.event のメソッド
 Event EventManager.createEvent(String application, String key, UserInfo info)
パラメータで指定された内容に該当するイベントを生成します。

jp.co.intra_mart.framework.base.service での UserInfo の使用

UserInfo を返す jp.co.intra_mart.framework.base.service のメソッド
 UserInfo ServiceControllerAdapter.getUserInfo()
ユーザ情報を取得します。

jp.co.intra_mart.framework.base.util での UserInfo の使用

UserInfo を実装している jp.co.intra_mart.framework.base.util のクラス
class | ConfigurationUserInfo 情報を自由に設定可能なUserInfoです。
class | EmptyUserInfo 情報を何も持たないUserInfoです。
class | UserInfoWrapper UserInfoを拡張するための実装です。

UserInfo を返す jp.co.intra_mart.framework.base.util のメソッド
protected UserInfo | UserInfoWrapper.getRealUserInfo() このオブジェクトがラップしているUserInfoの実装を返します。
static UserInfo | UserInfoUtil.createUserInfo(HttpServletRequest request, HttpServletResponse response) intra-martのセッション情報からUserInfoを新規に生成します。

UserInfo 型のパラメータを持つ jp.co.intra_mart.framework.base.util のメソッド
protected  void UserInfoWrapper.setRealUserInfo(UserInfo userInfo)
このオブジェクトがラップするUserInfoの実装を設定します。

jp.co.intra_mart.framework.base.web.bean での UserInfo の使用

UserInfo を返す jp.co.intra_mart.framework.base.web.bean のメソッド
 UserInfo HelperBean.getUserInfo()
ログインユーザ情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.util.UserInfoException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.util.UserInfoException の使用

UserInfoException を使用しているパッケージ
jp.co.intra_mart.framework.base.util

jp.co.intra_mart.framework.base.util での UserInfoException の使用

UserInfoException をスローする jp.co.intra_mart.framework.base.util のメソッド
static UserInfo UserInfoUtil.createUserInfo(HttpServletRequest request, HttpServletResponse response)
intra-martのセッション情報からUserInfoを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.util.UserInfoUtil の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.util.UserInfoUtil の使用

jp.co.intra_mart.framework.base.util.UserInfoUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.util.UserInfoWrapper の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.util.UserInfoWrapper の使用

jp.co.intra_mart.framework.base.util.UserInfoWrapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ConfigurationUserInfo (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.util
クラス ConfigurationUserInfo

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.util.ConfigurationUserInfo
すべての実装インタフェース:
Serializable, UserInfo
public class ConfigurationUserInfo
extends Object
implements UserInfo, Serializable

情報を自由に設定可能なUserInfoです。
アクセスセキュリティと連動したユーザ情報が必要ではない場合、このクラスを利用して 任意のUserInfoを生成することが可能です。
バッチ処理などログインセッションに依存しない環境でのイベント実行時にも利用可能です。

 ConfigurationUserInfo info = new ConfigurationUserInfo();
 info.setUserID("user_id");
 info.setLoginGroupID("group_id");

 EventManager manager = EventManager.getEventManager();
 FooEvent event = (FooEvent)manager.createEvent("foo", "bar", info);
 event.doSomething();

 manager.dispatch(event);
アクセスセキュリティと連動したユーザ情報が必要な場合は UserInfoUtil.createUserInfo(HttpServletRequest, HttpServletResponse) を使用してください。

導入されたバージョン:
5.0.5
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ConfigurationUserInfo()
メソッドの概要
String | getClientType() クライアントタイプを取得する。
String | getColorPatternID() カラーパターンIDを取得する。
String | getEncoding() エンコーディングを取得する。
Locale | getLocale() ユーザのロケールを取得する。
String | getLoginGroupID() ログイングループIDを取得する。
Date | getLoginTime() ログインした時間を取得する。
String | getLoginType() ログインタイプを取得する。
String | getUserID() ログインユーザIDを取得する。
void | setClientType(String clientType) クライアントタイプを設定する。
void | setColorPatternID(String colorPatternID) カラーパターンIDを設定する。
void | setEncoding(String encoding) エンコーディングを設定する。
void | setLocale(Locale locale) ユーザのロケールを設定する。
void | setLoginGroupID(String loginGroupID) ログイングループIDを設定する。
void | setLoginTime(Date loginTime) ログインした時間を設定する。
void | setLoginType(String loginType) ログインタイプを設定する。
void | setUserID(String userID) ログインユーザIDを設定する。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ConfigurationUserInfo

public ConfigurationUserInfo()
メソッドの詳細

getClientType

public String getClientType()
クライアントタイプを取得する。
値が未設定の場合は空文字列を返却します。

定義:
インタフェース UserInfo 内の getClientType
戻り値:
クライアントタイプ

setClientType

public void setClientType(String clientType)
クライアントタイプを設定する。

パラメータ:
clientType - クライアントタイプ

getColorPatternID

public String getColorPatternID()
カラーパターンIDを取得する。
値が未設定の場合は空文字列を返却します。

定義:
インタフェース UserInfo 内の getColorPatternID
戻り値:
カラーパターンID

setColorPatternID

public void setColorPatternID(String colorPatternID)
カラーパターンIDを設定する。

パラメータ:
colorPatternID - カラーパターンID

getEncoding

public String getEncoding()
エンコーディングを取得する。
値が未設定の場合は空文字列を返却します。

定義:
インタフェース UserInfo 内の getEncoding
戻り値:
エンコーディング

setEncoding

public void setEncoding(String encoding)
エンコーディングを設定する。

パラメータ:
encoding - エンコーディング

getLocale

public Locale getLocale()
ユーザのロケールを取得する。 値が未設定の場合はnullを返却します。

定義:
インタフェース UserInfo 内の getLocale
戻り値:
ロケール

setLocale

public void setLocale(Locale locale)
ユーザのロケールを設定する。

パラメータ:
locale - ロケール

getLoginGroupID

public String getLoginGroupID()
ログイングループIDを取得する。
値が未設定の場合は空文字列を返却します。

定義:
インタフェース UserInfo 内の getLoginGroupID
戻り値:
ログイングループID

setLoginGroupID

public void setLoginGroupID(String loginGroupID)
ログイングループIDを設定する。

パラメータ:
loginGroupID - ログイングループID

getLoginTime

public Date getLoginTime()
ログインした時間を取得する。
値が未設定の場合はnullを返却します。

定義:
インタフェース UserInfo 内の getLoginTime
戻り値:
ログイン時間

setLoginTime

public void setLoginTime(Date loginTime)
ログインした時間を設定する。

パラメータ:
loginTime - ログインした時間

getLoginType

public String getLoginType()
ログインタイプを取得する。
値が未設定の場合はUserInfoUtil.LT_USERを返却します。

定義:
インタフェース UserInfo 内の getLoginType
戻り値:
ログインタイプ
関連項目:
UserInfoUtil.LT_SUPER, UserInfoUtil.LT_GROUP, UserInfoUtil.LT_USER

setLoginType

public void setLoginType(String loginType)
ログインタイプを設定する。

パラメータ:
loginType - ログインタイプ

getUserID

public String getUserID()
ログインユーザIDを取得する。
値が未設定の場合は空文字列を返却します。

定義:
インタフェース UserInfo 内の getUserID
戻り値:
ログインユーザID

setUserID

public void setUserID(String userID)
ログインユーザIDを設定する。

パラメータ:
userID - ログインユーザID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EmptyUserInfo (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.util
クラス EmptyUserInfo

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.util.EmptyUserInfo
すべての実装インタフェース:
Serializable, UserInfo
public class EmptyUserInfo
extends Object
implements UserInfo, Serializable

情報を何も持たないUserInfoです。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EmptyUserInfo()
メソッドの概要
String | getClientType() クライアントタイプを取得する。
String | getColorPatternID() カラーパターンIDを取得する。
String | getEncoding() エンコーディングを取得する。
Locale | getLocale() ユーザのロケールを取得する。
String | getLoginGroupID() ログイングループIDを取得する。
Date | getLoginTime() ログインした時間を取得する。
String | getLoginType() ログインタイプを取得する。
String | getUserID() ログインユーザIDを取得する。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EmptyUserInfo

public EmptyUserInfo()
メソッドの詳細

getClientType

public String getClientType()
クライアントタイプを取得する。
このメソッドは常に空文字列を返却します。

定義:
インタフェース UserInfo 内の getClientType
戻り値:
クライアントタイプ

getColorPatternID

public String getColorPatternID()
カラーパターンIDを取得する。
このメソッドは常に空文字列を返却します。

定義:
インタフェース UserInfo 内の getColorPatternID
戻り値:
カラーパターンID

getEncoding

public String getEncoding()
エンコーディングを取得する。
このメソッドは常に空文字列を返却します。

定義:
インタフェース UserInfo 内の getEncoding
戻り値:
エンコーディング

getLocale

public Locale getLocale()
ユーザのロケールを取得する。 このメソッドは常にnullを返却します。

定義:
インタフェース UserInfo 内の getLocale
戻り値:
ロケール

getLoginGroupID

public String getLoginGroupID()
ログイングループIDを取得する。
このメソッドは常に空文字列を返却します。

定義:
インタフェース UserInfo 内の getLoginGroupID
戻り値:
ログイングループID

getLoginTime

public Date getLoginTime()
ログインした時間を取得する。
このメソッドは常にnullを返却します。

定義:
インタフェース UserInfo 内の getLoginTime
戻り値:
ログイン時間

getLoginType

public String getLoginType()
ログインタイプを取得する。
このメソッドは常にUserInfoUtil.LT_USERを返却します。

定義:
インタフェース UserInfo 内の getLoginType
戻り値:
ログインタイプ
関連項目:
UserInfoUtil.LT_SUPER, UserInfoUtil.LT_GROUP, UserInfoUtil.LT_USER

getUserID

public String getUserID()
ログインユーザIDを取得する。 このメソッドは常に空文字列を返却します。

定義:
インタフェース UserInfo 内の getUserID
戻り値:
ログインユーザID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.util (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.base.util
インタフェース
UserInfo
クラス
ConfigurationUserInfo
EmptyUserInfo
UserInfoUtil
UserInfoWrapper
例外
UserInfoException


jp.co.intra_mart.framework.base.util (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.util

インタフェースの概要
UserInfo ログインユーザの情報を管理します。

クラスの概要
ConfigurationUserInfo | 情報を自由に設定可能なUserInfoです。
EmptyUserInfo | 情報を何も持たないUserInfoです。
UserInfoUtil | ログインユーザの情報に関するユーティリティクラスです。
UserInfoWrapper | UserInfoを拡張するための実装です。

例外の概要
UserInfoException ユーザ情報に関連する例外です。


jp.co.intra_mart.framework.base.util クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo (implements java.io.Serializable, jp.co.intra_mart.framework.base.util.UserInfo)
    • class jp.co.intra_mart.framework.base.util.EmptyUserInfo (implements java.io.Serializable, jp.co.intra_mart.framework.base.util.UserInfo)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.util.UserInfoException
    • class jp.co.intra_mart.framework.base.util.UserInfoUtil
    • class jp.co.intra_mart.framework.base.util.UserInfoWrapper (implements jp.co.intra_mart.framework.base.util.UserInfo)

インタフェース階層

  • interface java.io.Serializable
    • interface jp.co.intra_mart.framework.base.util.UserInfo


パッケージ jp.co.intra_mart.framework.base.util の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.util の使用

jp.co.intra_mart.framework.base.util を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event により使用される jp.co.intra_mart.framework.base.util のクラス
UserInfo
ログインユーザの情報を管理します。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.base.util のクラス
UserInfo
ログインユーザの情報を管理します。

jp.co.intra_mart.framework.base.util により使用される jp.co.intra_mart.framework.base.util のクラス
UserInfo
ログインユーザの情報を管理します。
UserInfoException
ユーザ情報に関連する例外です。

jp.co.intra_mart.framework.base.web.bean により使用される jp.co.intra_mart.framework.base.util のクラス
UserInfo
ログインユーザの情報を管理します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


UserInfo (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.util
インタフェース UserInfo

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
ConfigurationUserInfo, EmptyUserInfo, UserInfoWrapper
public interface UserInfo
extends Serializable

ログインユーザの情報を管理します。 イントラマートにアクセスしたクライアント情報をラップしたオブジェクトです。
このオブジェクトは通常UserInfoUtil.createUserInfo(HttpServletRequest, HttpServletResponse) から生成されます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
UserInfoUtil

メソッドの概要
String | getClientType() クライアントタイプを取得する。
String | getColorPatternID() カラーパターンIDを取得する。
String | getEncoding() エンコーディングを取得する。
Locale | getLocale() ユーザのロケールを取得する。
String | getLoginGroupID() ログイングループIDを取得する。
Date | getLoginTime() ログインした時間を取得する。
String | getLoginType() ログインタイプを取得する。
String | getUserID() ログインユーザIDを取得する。

メソッドの詳細

getClientType

public String getClientType()
クライアントタイプを取得する。
セッション情報にクライアントタイプが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
クライアントタイプ

getColorPatternID

public String getColorPatternID()
カラーパターンIDを取得する。
セッション情報にログインユーザIDが存在しない場合、および空文字列の場合はデフォルトのカラーパターンIDを返却する。

戻り値:
カラーパターンID

getEncoding

public String getEncoding()
エンコーディングを取得する。
セッション情報にエンコーディングが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
エンコーディング

getLocale

public Locale getLocale()
ユーザのロケールを取得する。
セッション情報にロケールが存在しない場合、および空文字列の場合はnullを返却する。

戻り値:
ロケール

getLoginGroupID

public String getLoginGroupID()
ログイングループIDを取得する。
セッション情報にログイングループIDが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
ログイングループID

getLoginTime

public Date getLoginTime()
ログインした時間を取得する。
セッション情報にログイン時間が存在しない場合、nullを返却する。

戻り値:
ログイン時間

getLoginType

public String getLoginType()
ログインタイプを取得する。
セッション情報にログインタイプが存在しない場合、および空文字列の場合は UserInfoUtil.LT_USER を返却する。

戻り値:
ログインタイプ
関連項目:
UserInfoUtil.LT_SUPER, UserInfoUtil.LT_GROUP, UserInfoUtil.LT_USER

getUserID

public String getUserID()
ログインユーザIDを取得する。
セッション情報にログインユーザIDが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
ログインユーザID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UserInfoException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.util
クラス UserInfoException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.util.UserInfoException
すべての実装インタフェース:
Serializable
public class UserInfoException
extends SystemException

ユーザ情報に関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
UserInfoException()
詳細メッセージを指定しないで UserInfoException を構築します。
UserInfoException(String msg)
指定された詳細メッセージを持つ UserInfoException を構築します。
UserInfoException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ UserInfoException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UserInfoException

public UserInfoException()
詳細メッセージを指定しないで UserInfoException を構築します。

UserInfoException

public UserInfoException(String msg)
指定された詳細メッセージを持つ UserInfoException を構築します。

パラメータ:
msg - 詳細メッセージ

UserInfoException

public UserInfoException(String msg,
                         Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ UserInfoException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UserInfoUtil (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.util
クラス UserInfoUtil

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.util.UserInfoUtil
public class UserInfoUtil
extends Object

ログインユーザの情報に関するユーティリティクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String | LT_GROUP グループマネージャ
static String | LT_SUPER スーパーユーザ
static String | LT_USER ユーザ
メソッドの概要
static UserInfo createUserInfo(HttpServletRequest request, HttpServletResponse response)
intra-martのセッション情報からUserInfoを新規に生成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

LT_SUPER

public static final String LT_SUPER
スーパーユーザ

関連項目:
定数フィールド値

LT_GROUP

public static final String LT_GROUP
グループマネージャ

関連項目:
定数フィールド値

LT_USER

public static final String LT_USER
ユーザ

関連項目:
定数フィールド値
メソッドの詳細

createUserInfo

public static UserInfo createUserInfo(HttpServletRequest request,
                                      HttpServletResponse response)
                               throws UserInfoException
intra-martのセッション情報からUserInfoを新規に生成します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ログインユーザの情報
例外:
UserInfoException - UserInfo生成時に例外が発生。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserInfoWrapper (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.util
クラス UserInfoWrapper

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.util.UserInfoWrapper
すべての実装インタフェース:
Serializable, UserInfo
public class UserInfoWrapper
extends Object
implements UserInfo

UserInfoを拡張するための実装です。 デフォルトではEmptyUserInfoをラップします。

導入されたバージョン:
6.0
関連項目:
直列化された形式

フィールドの概要
static Class BLANK_USER_INFO
デフォルトでラップされているクラスです。
コンストラクタの概要
UserInfoWrapper()
UserInfoWrapperを新規に生成します。
メソッドの概要
String | getClientType() ラップされたUserInfoのgetClientType()を呼び出します。
String | getColorPatternID() ラップされたUserInfoのgetColorPatternID()を呼び出します。
String | getEncoding() ラップされたUserInfoのgetEncoding()を呼び出します。
Locale | getLocale() ラップされたUserInfoのgetLocale()を呼び出します。
String | getLoginGroupID() ラップされたUserInfoのgetLoginGroupID()を呼び出します。
Date | getLoginTime() ラップされたUserInfoのgetLoginTime()を呼び出します。
String | getLoginType() ラップされたUserInfoのgetLoginType()を呼び出します。
protected UserInfo | getRealUserInfo() このオブジェクトがラップしているUserInfoの実装を返します。
String | getUserID() ラップされたUserInfoのgetUserID()を呼び出します。
protected void | setRealUserInfo(UserInfo userInfo) このオブジェクトがラップするUserInfoの実装を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

BLANK_USER_INFO

public static Class BLANK_USER_INFO
デフォルトでラップされているクラスです。

コンストラクタの詳細

UserInfoWrapper

public UserInfoWrapper()
UserInfoWrapperを新規に生成します。

メソッドの詳細

setRealUserInfo

protected void setRealUserInfo(UserInfo userInfo)
このオブジェクトがラップするUserInfoの実装を設定します。

パラメータ:
userInfo - UserInfoの実装

getRealUserInfo

protected UserInfo getRealUserInfo()
このオブジェクトがラップしているUserInfoの実装を返します。

戻り値:
UserInfoの実装

getClientType

public String getClientType()
ラップされたUserInfoのgetClientType()を呼び出します。

定義:
インタフェース UserInfo 内の getClientType
戻り値:
クライアントタイプ

getColorPatternID

public String getColorPatternID()
ラップされたUserInfoのgetColorPatternID()を呼び出します。

定義:
インタフェース UserInfo 内の getColorPatternID
戻り値:
カラーパターンID

getEncoding

public String getEncoding()
ラップされたUserInfoのgetEncoding()を呼び出します。

定義:
インタフェース UserInfo 内の getEncoding
戻り値:
エンコーディング

getLocale

public Locale getLocale()
ラップされたUserInfoのgetLocale()を呼び出します。

定義:
インタフェース UserInfo 内の getLocale
戻り値:
ロケール

getLoginGroupID

public String getLoginGroupID()
ラップされたUserInfoのgetLoginGroupID()を呼び出します。

定義:
インタフェース UserInfo 内の getLoginGroupID
戻り値:
ログイングループID

getLoginTime

public Date getLoginTime()
ラップされたUserInfoのgetLoginTime()を呼び出します。

定義:
インタフェース UserInfo 内の getLoginTime
戻り値:
ログインした時間

getLoginType

public String getLoginType()
ラップされたUserInfoのgetLoginType()を呼び出します。

定義:
インタフェース UserInfo 内の getLoginType
戻り値:
ログインタイプ
関連項目:
UserInfoUtil.LT_SUPER, UserInfoUtil.LT_GROUP, UserInfoUtil.LT_USER

getUserID

public String getUserID()
ラップされたUserInfoのgetUserID()を呼び出します。

定義:
インタフェース UserInfo 内の getUserID
戻り値:
ログインユーザID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean の使用

jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.bean.HelperBean の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.bean.HelperBean の使用

HelperBean を使用しているパッケージ
jp.co.intra_mart.framework.base.web.bean JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.web.bean での HelperBean の使用

jp.co.intra_mart.framework.base.web.bean での HelperBean のサブクラス
 class ErrorHelperBean
例外ページで使用するHelperBeanです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.bean.HelperBeanException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.bean.HelperBeanException の使用

HelperBeanException を使用しているパッケージ
jp.co.intra_mart.framework.base.web.bean JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.web.bean での HelperBeanException の使用

HelperBeanException をスローする jp.co.intra_mart.framework.base.web.bean のメソッド
 void HelperBean.init()
HelperBeanを初期化します。
 SessionObject HelperBean.getSession()
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
 String HelperBean.getLoginUserID()
推奨されていません。 このメソッドではなくHelperBean.getUserInfo()を使用してください。
 String HelperBean.getLoginGroupID()
推奨されていません。 このメソッドではなくHelperBean.getUserInfo()を使用してください。
 UserInfo HelperBean.getUserInfo()
ログインユーザ情報を取得します。
protected  Event HelperBean.createEvent(String application, String key)
アプリケーションIDとキーに対応するイベントを取得します。
 Throwable ErrorHelperBean.getException()
例外を取得します。

HelperBeanException をスローする jp.co.intra_mart.framework.base.web.bean のコンストラクタ
HelperBean()
HelperBeanを新規に生成します。
ErrorHelperBean()
ErrorHelperBeanを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ErrorHelperBean (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.bean
クラス ErrorHelperBean

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.bean.HelperBean
        拡張 jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean
すべての実装インタフェース:
Serializable
public class ErrorHelperBean
extends HelperBean

例外ページで使用するHelperBeanです。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ErrorHelperBean()
ErrorHelperBeanを新規に生成します。
メソッドの概要
 Throwable getException()
例外を取得します。
クラス jp.co.intra_mart.framework.base.web.bean.HelperBean から継承したメソッド
createEvent, dispatchEvent, getLoginGroupID, getLoginUserID, getRequest, getResponse, getServicePropertyHandler, getSession, getUserInfo, init, setRequest, setResponse
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ErrorHelperBean

public ErrorHelperBean()
                throws HelperBeanException
ErrorHelperBeanを新規に生成します。

例外:
HelperBeanException - ErrorHelperBean生成時に例外が発生
メソッドの詳細

getException

public Throwable getException()
                       throws HelperBeanException
例外を取得します。

戻り値:
例外
例外:
HelperBeanException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HelperBean (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.bean
クラス HelperBean

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.bean.HelperBean
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ErrorHelperBean
public abstract class HelperBean
extends Object
implements Serializable

画面表示をする時のヘルパークラスです。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
HelperBean()
HelperBeanを新規に生成します。
メソッドの概要
protected Event | createEvent(String application, String key) アプリケーションIDとキーに対応するイベントを取得します。
protected EventResult | dispatchEvent(Event event) イベント処理を実行します。
String | getLoginGroupID() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
String | getLoginUserID() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
HttpServletRequest | getRequest() リクエストを取得します。
HttpServletResponse | getResponse() レスポンスを取得します。
ServicePropertyHandler | getServicePropertyHandler() サービスプロパティハンドラを取得します。
SessionObject | getSession() 推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
UserInfo | getUserInfo() ログインユーザ情報を取得します。
void | init() HelperBeanを初期化します。
void | setRequest(HttpServletRequest request) リクエストを設定します。
void | setResponse(HttpServletResponse response) レスポンスを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HelperBean

public HelperBean()
           throws HelperBeanException
HelperBeanを新規に生成します。

例外:
HelperBeanException - HelperBean生成時に例外が発生
メソッドの詳細

init

public void init()
          throws HelperBeanException
HelperBeanを初期化します。

例外:
HelperBeanException - 初期化時に例外が発生
導入されたバージョン:
3.2

setRequest

public void setRequest(HttpServletRequest request)
リクエストを設定します。

パラメータ:
request - リクエスト

getRequest

public HttpServletRequest getRequest()
リクエストを取得します。

戻り値:
リクエスト

setResponse

public void setResponse(HttpServletResponse response)
レスポンスを設定します。

パラメータ:
response - レスポンス

getResponse

public HttpServletResponse getResponse()
レスポンスを取得します。

戻り値:
レスポンス

getSession

public SessionObject getSession()
                         throws HelperBeanException
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

セッションオブジェクトを取得します。 このメソッドはセッションプロパティにSessionFactoryとSessionObjectKeyを指定したときに有効になります。

戻り値:
セッションオブジェクト
例外:
HelperBeanException - セッションオブジェクト取得時に例外が発生

getLoginUserID

public String getLoginUserID()
                      throws HelperBeanException
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログインユーザIDを取得します。

戻り値:
ログインユーザID
例外:
HelperBeanException - ログインユーザID取得時に例外が発生
導入されたバージョン:
3.2

getLoginGroupID

public String getLoginGroupID()
                       throws HelperBeanException
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログイングループIDを取得します。

戻り値:
ログイングループID
例外:
HelperBeanException - ログイングループID取得時に例外が発生
導入されたバージョン:
3.2

getUserInfo

public UserInfo getUserInfo()
                     throws HelperBeanException
ログインユーザ情報を取得します。
ログインセッションが存在しない場合はnullを返却します。

戻り値:
ログインユーザ情報
例外:
ServiceControllerException - ログインユーザ情報取得時に例外が発生
HelperBeanException
導入されたバージョン:
5.0

createEvent

protected Event createEvent(String application,
                            String key)
                     throws HelperBeanException
アプリケーションIDとキーに対応するイベントを取得します。 イベントにはログイン時のログイングループIDが自動的に登録されます。

パラメータ:
application - アプリケーションID
key - キー
戻り値:
イベント
例外:
HelperBeanException - イベント生成時に例外が発生

dispatchEvent

protected EventResult dispatchEvent(Event event)
                             throws EventException,
                                    SystemException,
                                    ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventException - イベント処理時に例外が発生
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生

getServicePropertyHandler

public ServicePropertyHandler getServicePropertyHandler()
サービスプロパティハンドラを取得します。

戻り値:
サービスプロパティハンドラ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HelperBeanException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.bean
クラス HelperBeanException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.web.bean.HelperBeanException
すべての実装インタフェース:
Serializable
public class HelperBeanException
extends SystemException

HelperBean内で発生した例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
HelperBeanException()
詳細メッセージを指定しないで HelperBeanException を構築します。
HelperBeanException(String msg)
指定された詳細メッセージを持つ HelperBeanException を構築します。
HelperBeanException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ HelperBeanException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HelperBeanException

public HelperBeanException()
詳細メッセージを指定しないで HelperBeanException を構築します。

HelperBeanException

public HelperBeanException(String msg)
指定された詳細メッセージを持つ HelperBeanException を構築します。

パラメータ:
msg - 詳細メッセージ

HelperBeanException

public HelperBeanException(String msg,
                           Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ HelperBeanException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.web.bean (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.base.web.bean
クラス
ErrorHelperBean
HelperBean
例外
HelperBeanException


jp.co.intra_mart.framework.base.web.bean (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.bean

JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

参照:
説明

クラスの概要
ErrorHelperBean | 例外ページで使用するHelperBeanです。
HelperBean | 画面表示をする時のヘルパークラスです。

例外の概要
HelperBeanException HelperBean内で発生した例外です。

パッケージ jp.co.intra_mart.framework.base.web.bean の説明

JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。


jp.co.intra_mart.framework.base.web.bean クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.bean の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.web.bean.HelperBean (implements java.io.Serializable)
      • class jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.web.bean.HelperBeanException


パッケージ jp.co.intra_mart.framework.base.web.bean の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.web.bean の使用

jp.co.intra_mart.framework.base.web.bean を使用しているパッケージ
jp.co.intra_mart.framework.base.web.bean JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.web.bean により使用される jp.co.intra_mart.framework.base.web.bean のクラス
HelperBean
画面表示をする時のヘルパークラスです。
HelperBeanException
HelperBean内で発生した例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes の使用

jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes の使用

jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes の使用

GenericAttributes を使用しているパッケージ
jp.co.intra_mart.framework.base.web.tag.attribute タグ属性のパッケージです。

jp.co.intra_mart.framework.base.web.tag.attribute での GenericAttributes の使用

jp.co.intra_mart.framework.base.web.tag.attribute での GenericAttributes のサブクラス
class | CoreAttributes コア属性です。
class | EventsAttributes ブラウザのイベントに関連するタグの属性情報です。
class | I18nAttributes 国際化の属性です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes の使用

jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CoreAttributes (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag.attribute
クラス CoreAttributes

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes
        拡張 jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes
public class CoreAttributes
extends GenericAttributes

コア属性です。

バージョン:
1.0

コンストラクタの概要
CoreAttributes()
CoreAttributesを新規に生成します。
メソッドの概要
String | getStyle() 属性styleの値を取得します。
String | getTagClass() 属性classの値を取得します。
String | getTitle() 属性titleの値を取得します。
void | printAttributes() 属性の内容を表示します。
void | setStyle(String style) 属性styleの値を設定します。
void | setTagClass(String tagClass) 属性classの値を設定します。
void | setTitle(String title) 属性titleの値を設定します。
クラス jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes から継承したメソッド
getTagWriter, setTagWriter
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CoreAttributes

public CoreAttributes()
CoreAttributesを新規に生成します。

メソッドの詳細

getTagClass

public String getTagClass()
属性classの値を取得します。

戻り値:
class

setTagClass

public void setTagClass(String tagClass)
属性classの値を設定します。

パラメータ:
tagClass - class

getStyle

public String getStyle()
属性styleの値を取得します。

戻り値:
style

setStyle

public void setStyle(String style)
属性styleの値を設定します。

パラメータ:
style - style

getTitle

public String getTitle()
属性titleの値を取得します。

戻り値:
title

setTitle

public void setTitle(String title)
属性titleの値を設定します。

パラメータ:
title - title

printAttributes

public void printAttributes()
                     throws IOException
属性の内容を表示します。

定義:
クラス GenericAttributes 内の printAttributes
例外:
IOException - 出力中に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventsAttributes (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag.attribute
クラス EventsAttributes

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes
        拡張 jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes
public class EventsAttributes
extends GenericAttributes

ブラウザのイベントに関連するタグの属性情報です。

バージョン:
1.0

コンストラクタの概要
EventsAttributes()
EventsAttributesを新規に生成します。
メソッドの概要
String | getOnClick() 属性onClickの値を取得します。
String | getOnDblClick() 属性onDblClickの値を取得します。
String | getOnKeyDown() 属性onKeyDownの値を取得します。
String | getOnKeyPress() 属性onKeyPressの値を取得します。
String | getOnKeyUp() 属性onKeyUpの値を取得します。
String | getOnMouseDown() 属性onMouseDownの値を取得します。
String | getOnMouseMove() 属性onMouseMoveの値を取得します。
String | getOnMouseOut() 属性onMouseOutの値を取得します。
String | getOnMouseOver() 属性onMouseOverの値を取得します。
String | getOnMouseUp() 属性onMouseUpの値を取得します。
void | printAttributes() 属性の内容を表示します。
protected void | printOnClick() 属性onClickを出力します。
protected void | printOnDblClick() 属性onDblClickを出力します。
protected void | printOnKeyDown() 属性onKeyDownを出力します。
protected void | printOnKeyPress() 属性onKeyPressを出力します。
protected void | printOnKeyUp() 属性onKeyUpを出力します。
protected void | printOnMouseDown() 属性onMouseDownを出力します。
protected void | printOnMouseMove() 属性onMouseMoveを出力します。
protected void | printOnMouseOut() 属性onMouseOutを出力します。
protected void | printOnMouseOver() 属性onMouseOverを出力します。
protected void | printOnMouseUp() 属性onMouseUpを出力します。
void | setOnClick(String onClick) 属性onClickの値を設定します。
void | setOnDblClick(String onDblClick) 属性obDblClickの値を設定します。
void | setOnKeyDown(String onKeyDown) 属性onKeyDownの値を設定します。
void | setOnKeyPress(String onKeyPress) 属性onKeyPressの値を設定します。
void | setOnKeyUp(String onKeyUp) 属性onKeyUpの値を設定します。
void | setOnMouseDown(String onMouseDown) 属性onMouseDownの値を設定します。
void | setOnMouseMove(String onMouseMove) 属性onMouseMoveの値を設定します。
void | setOnMouseOut(String onMouseOut) 属性onMouseOutの値を設定します。
void | setOnMouseOver(String onMouseOver) 属性onMouseOverの値を設定します。
void | setOnMouseUp(String onMouseUp) 属性onMouseUpの値を設定します。
クラス jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes から継承したメソッド
getTagWriter, setTagWriter
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventsAttributes

public EventsAttributes()
EventsAttributesを新規に生成します。

メソッドの詳細

getOnClick

public String getOnClick()
属性onClickの値を取得します。

戻り値:
onClick

setOnClick

public void setOnClick(String onClick)
属性onClickの値を設定します。

パラメータ:
onClick - onClick

getOnDblClick

public String getOnDblClick()
属性onDblClickの値を取得します。

戻り値:
onDblClick

setOnDblClick

public void setOnDblClick(String onDblClick)
属性obDblClickの値を設定します。

パラメータ:
onDblClick - onDblClick

getOnMouseDown

public String getOnMouseDown()
属性onMouseDownの値を取得します。

戻り値:
onMouseDown

setOnMouseDown

public void setOnMouseDown(String onMouseDown)
属性onMouseDownの値を設定します。

パラメータ:
onMouseDown - onMouseDown

getOnMouseUp

public String getOnMouseUp()
属性onMouseUpの値を取得します。

戻り値:
onMouseUp

setOnMouseUp

public void setOnMouseUp(String onMouseUp)
属性onMouseUpの値を設定します。

パラメータ:
onMouseUp - onMouseUp

getOnMouseOver

public String getOnMouseOver()
属性onMouseOverの値を取得します。

戻り値:
onMouseOver

setOnMouseOver

public void setOnMouseOver(String onMouseOver)
属性onMouseOverの値を設定します。

パラメータ:
onMouseOver - onMouseOver

getOnMouseMove

public String getOnMouseMove()
属性onMouseMoveの値を取得します。

戻り値:
onMouseMove

setOnMouseMove

public void setOnMouseMove(String onMouseMove)
属性onMouseMoveの値を設定します。

パラメータ:
onMouseMove - onMouseMove

getOnMouseOut

public String getOnMouseOut()
属性onMouseOutの値を取得します。

戻り値:
onMouseOut

setOnMouseOut

public void setOnMouseOut(String onMouseOut)
属性onMouseOutの値を設定します。

パラメータ:
onMouseOut - onMouseOut

getOnKeyPress

public String getOnKeyPress()
属性onKeyPressの値を取得します。

戻り値:
onKeyPress

setOnKeyPress

public void setOnKeyPress(String onKeyPress)
属性onKeyPressの値を設定します。

パラメータ:
onKeyPress - onKeyPress

getOnKeyDown

public String getOnKeyDown()
属性onKeyDownの値を取得します。

戻り値:
onKeyDown

setOnKeyDown

public void setOnKeyDown(String onKeyDown)
属性onKeyDownの値を設定します。

パラメータ:
onKeyDown - onKeyDown

getOnKeyUp

public String getOnKeyUp()
属性onKeyUpの値を取得します。

戻り値:
onKeyUp

setOnKeyUp

public void setOnKeyUp(String onKeyUp)
属性onKeyUpの値を設定します。

パラメータ:
onKeyUp - onKeyUp

printOnClick

protected void printOnClick()
                     throws IOException
属性onClickを出力します。

例外:
IOException - 出力中に例外が発生

printOnDblClick

protected void printOnDblClick()
                        throws IOException
属性onDblClickを出力します。

例外:
IOException - 出力中に例外が発生

printOnMouseDown

protected void printOnMouseDown()
                         throws IOException
属性onMouseDownを出力します。

例外:
IOException - 出力中に例外が発生

printOnMouseUp

protected void printOnMouseUp()
                       throws IOException
属性onMouseUpを出力します。

例外:
IOException - 出力中に例外が発生

printOnMouseOver

protected void printOnMouseOver()
                         throws IOException
属性onMouseOverを出力します。

例外:
IOException - 出力中に例外が発生

printOnMouseMove

protected void printOnMouseMove()
                         throws IOException
属性onMouseMoveを出力します。

例外:
IOException - 出力中に例外が発生

printOnMouseOut

protected void printOnMouseOut()
                        throws IOException
属性onMouseOutを出力します。

例外:
IOException - 出力中に例外が発生

printOnKeyPress

protected void printOnKeyPress()
                        throws IOException
属性onKeyPressを出力します。

例外:
IOException - 出力中に例外が発生

printOnKeyDown

protected void printOnKeyDown()
                       throws IOException
属性onKeyDownを出力します。

例外:
IOException - 出力中に例外が発生

printOnKeyUp

protected void printOnKeyUp()
                     throws IOException
属性onKeyUpを出力します。

例外:
IOException - 出力中に例外が発生

printAttributes

public void printAttributes()
                     throws IOException
属性の内容を表示します。

定義:
クラス GenericAttributes 内の printAttributes
例外:
IOException - 出力中に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericAttributes (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag.attribute
クラス GenericAttributes

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes
直系の既知のサブクラス:
CoreAttributes, EventsAttributes, I18nAttributes
public abstract class GenericAttributes
extends Object

汎用属性の集合です。

バージョン:
1.0

コンストラクタの概要
GenericAttributes()
GenericAttributesを新規に生成します。
メソッドの概要
TagWriter | getTagWriter() TagWriterを取得します。
abstract void | printAttributes() 属性の内容を表示します。
void | setTagWriter(TagWriter writer) TagWriterを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericAttributes

public GenericAttributes()
GenericAttributesを新規に生成します。

メソッドの詳細

getTagWriter

public TagWriter getTagWriter()
TagWriterを取得します。

戻り値:
TagWriter

setTagWriter

public void setTagWriter(TagWriter writer)
TagWriterを設定します。

パラメータ:
writer - TagWriter

printAttributes

public abstract void printAttributes()
                              throws IOException
属性の内容を表示します。

例外:
IOException - 出力中に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


I18nAttributes (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag.attribute
クラス I18nAttributes

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes
        拡張 jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes
public class I18nAttributes
extends GenericAttributes

国際化の属性です。

バージョン:
1.0

コンストラクタの概要
I18nAttributes()
I18nAttributesを新規に生成します。
メソッドの概要
String | getDir() 属性dirの値を取得します。
String | getLang() 属性langの値を取得します。
void | printAttributes() 属性の内容を表示します。
void | setDir(String dir) 属性dirの値を取得します。
void | setLang(String lang) 属性langの値を設定します。
クラス jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes から継承したメソッド
getTagWriter, setTagWriter
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

I18nAttributes

public I18nAttributes()
I18nAttributesを新規に生成します。

メソッドの詳細

getLang

public String getLang()
属性langの値を取得します。

戻り値:
lang

setLang

public void setLang(String lang)
属性langの値を設定します。

パラメータ:
lang - lang

getDir

public String getDir()
属性dirの値を取得します。

戻り値:
dir

setDir

public void setDir(String dir)
属性dirの値を取得します。

パラメータ:
dir - dir

printAttributes

public void printAttributes()
                     throws IOException
属性の内容を表示します。

定義:
クラス GenericAttributes 内の printAttributes
例外:
IOException - 出力中に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.web.tag.attribute (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.base.web.tag.attribute
クラス
CoreAttributes
EventsAttributes
GenericAttributes
I18nAttributes


jp.co.intra_mart.framework.base.web.tag.attribute (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.tag.attribute

タグ属性のパッケージです。

参照:
説明

クラスの概要
CoreAttributes | コア属性です。
EventsAttributes | ブラウザのイベントに関連するタグの属性情報です。
GenericAttributes | 汎用属性の集合です。
I18nAttributes | 国際化の属性です。

パッケージ jp.co.intra_mart.framework.base.web.tag.attribute の説明

タグ属性のパッケージです。


jp.co.intra_mart.framework.base.web.tag.attribute クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.tag.attribute の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes
      • class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes
      • class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes
      • class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes


パッケージ jp.co.intra_mart.framework.base.web.tag.attribute の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.web.tag.attribute の使用

jp.co.intra_mart.framework.base.web.tag.attribute を使用しているパッケージ
jp.co.intra_mart.framework.base.web.tag.attribute タグ属性のパッケージです。

jp.co.intra_mart.framework.base.web.tag.attribute により使用される jp.co.intra_mart.framework.base.web.tag.attribute のクラス
GenericAttributes
汎用属性の集合です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.FormTag の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FormTag の使用

jp.co.intra_mart.framework.base.web.tag.FormTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo の使用

jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.FormTEI の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FormTEI の使用

jp.co.intra_mart.framework.base.web.tag.FormTEI はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.FrameTag の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FrameTag の使用

jp.co.intra_mart.framework.base.web.tag.FrameTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo の使用

jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.FrameTEI の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FrameTEI の使用

jp.co.intra_mart.framework.base.web.tag.FrameTEI はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.FrameworkTagException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FrameworkTagException の使用

jp.co.intra_mart.framework.base.web.tag.FrameworkTagException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam の使用

jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.HelperBeanTag の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.HelperBeanTag の使用

jp.co.intra_mart.framework.base.web.tag.HelperBeanTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo の使用

jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI の使用

jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.LinkTag の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.LinkTag の使用

jp.co.intra_mart.framework.base.web.tag.LinkTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo の使用

jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.LinkTEI の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.LinkTEI の使用

jp.co.intra_mart.framework.base.web.tag.LinkTEI はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.MessageParamTag の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.MessageParamTag の使用

jp.co.intra_mart.framework.base.web.tag.MessageParamTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.MessageTag の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.MessageTag の使用

jp.co.intra_mart.framework.base.web.tag.MessageTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.MessageTEI の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.MessageTEI の使用

jp.co.intra_mart.framework.base.web.tag.MessageTEI はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.web.tag.ParameterSendable の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.web.tag.ParameterSendable の使用

ParameterSendable を使用しているパッケージ
jp.co.intra_mart.framework.base.web.tag J2EEフレームワークで使用する各種のタグのパッケージです。

jp.co.intra_mart.framework.base.web.tag での ParameterSendable の使用

ParameterSendable を実装している jp.co.intra_mart.framework.base.web.tag のクラス
class | FrameTag FRAMEタグです。
class | LinkTag LINKタグです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.ParamTag の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.ParamTag の使用

jp.co.intra_mart.framework.base.web.tag.ParamTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag の使用

jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo の使用

jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.SubmitTag の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.SubmitTag の使用

jp.co.intra_mart.framework.base.web.tag.SubmitTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo の使用

jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.SubmitTEI の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.SubmitTEI の使用

jp.co.intra_mart.framework.base.web.tag.SubmitTEI はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.TagWriter の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.TagWriter の使用

TagWriter を使用しているパッケージ
jp.co.intra_mart.framework.base.web.tag.attribute タグ属性のパッケージです。

jp.co.intra_mart.framework.base.web.tag.attribute での TagWriter の使用

TagWriter を返す jp.co.intra_mart.framework.base.web.tag.attribute のメソッド
 TagWriter GenericAttributes.getTagWriter()
TagWriterを取得します。

TagWriter 型のパラメータを持つ jp.co.intra_mart.framework.base.web.tag.attribute のメソッド
 void GenericAttributes.setTagWriter(TagWriter writer)
TagWriterを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


FormTag (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FormTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.FormTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class FormTag
extends BodyTagSupport

FORMタグです。 intra-martフレームワークを使用する場合のセッションフレームワーク、サービスフレームワークの一部となります。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
FormTag()
FormTagを新規に生成します。
メソッドの概要
int | doEndTag() 終了タグを検知したときにJSPエンジンから呼ばれます。
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getAccept() 属性acceptの値を取得します。
String | getAcceptcharset() 属性accept-charsetの値を取得します。
String | getApplication() 属性applicationの値を取得します。
String | getDir() 属性dirの値を取得します。
String | getEnctype() 属性enctypeの値を取得します。
String | getFormclass() 属性classの値を取得します。
String | getLang() 属性langの値を取得します。
String | getMethod() 属性methodの値を取得します。
String | getName() 属性nameの値を取得します。
String | getOnclick() 属性onClickの値を取得します。
String | getOndblclick() 属性onDblClickの値を取得します。
String | getOnkeydown() 属性onKeyDownの値を取得します。
String | getOnkeypress() 属性onKeyPressの値を取得します。
String | getOnkeyup() 属性onKeyUpの値を取得します。
String | getOnmousedown() 属性onMouseDownの値を取得します。
String | getOnmousemove() 属性onMouseMoveの値を取得します。
String | getOnmouseout() 属性onMouseOutの値を取得します。
String | getOnmouseover() 属性onMouseOverの値を取得します。
String | getOnmouseup() 属性onMouseUpの値を取得します。
String | getOnreset() 属性onResetの値を取得します。
String | getOnsubmit() 属性onSubmitの値を取得します。
String | getService() 属性serviceの値を取得します。
String | getStyle() 属性styleの値を取得します。
String | getTarget() 属性targetの値を取得します。
String | getTitle() 属性titleの値を取得します。
void | setAccept(String accept) 属性acceptの値を設定します。
void | setAcceptcharset(String acceptCharset) 属性accept-charsetの値を設定します。
void | setApplication(String application) 属性applicationの値を設定します。
void | setDir(String dir) 属性dirの値を設定します。
void | setEnctype(String enctype) 属性enctypeの値を設定します。
void | setFormclass(String formClass) 属性classの値を設定します。
void | setLang(String lang) 属性langの値を設定します。
void | setMethod(String method) 属性methodの値を設定します。
void | setName(String name) 属性nameの値を設定します。
void | setOnclick(String onClick) 属性onClickの値を設定します。
void | setOndblclick(String onDblClick) 属性obDblClickの値を設定します。
void | setOnkeydown(String onKeyDown) 属性onKeyDownの値を設定します。
void | setOnkeypress(String onKeyPress) 属性onKeyPressの値を設定します。
void | setOnkeyup(String onKeyUp) 属性onKeyUpの値を設定します。
void | setOnmousedown(String onMouseDown) 属性onMouseDownの値を設定します。
void | setOnmousemove(String onMouseMove) 属性onMouseMoveの値を設定します。
void | setOnmouseout(String onMouseOut) 属性onMouseOutの値を設定します。
void | setOnmouseover(String onMouseOver) 属性onMouseOverの値を設定します。
void | setOnmouseup(String onMouseUp) 属性onMouseUpの値を設定します。
void | setOnreset(String onReset) 属性onResetの値を設定します。
void | setOnsubmit(String onSubmit) 属性onSubmitの値を設定します。
void | setService(String service) 属性serviceの値を設定します。
void | setStyle(String style) 属性styleの値を設定します。
void | setTarget(String target) 属性targetの値を設定します。
void | setTitle(String title) 属性titleの値を設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

FormTag

public FormTag()
FormTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 FORMタグを解釈します。

戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - タグの解釈時に例外が発生

doEndTag

public int doEndTag()
             throws JspException
終了タグを検知したときにJSPエンジンから呼ばれます。 FORMタグを終了します。

戻り値:
EVAL_PAGE
例外:
JspException - タグの終了時に例外が発生

getApplication

public String getApplication()
属性applicationの値を取得します。

戻り値:
アプリケーション

setApplication

public void setApplication(String application)
属性applicationの値を設定します。

パラメータ:
application - アプリケーション

getService

public String getService()
属性serviceの値を取得します。

戻り値:
サービス

setService

public void setService(String service)
属性serviceの値を設定します。

パラメータ:
service - サービス

getMethod

public String getMethod()
属性methodの値を取得します。

戻り値:
method

setMethod

public void setMethod(String method)
属性methodの値を設定します。

パラメータ:
method - method

getEnctype

public String getEnctype()
属性enctypeの値を取得します。

戻り値:
enctype

getTarget

public String getTarget()
属性targetの値を取得します。

戻り値:
target

setTarget

public void setTarget(String target)
属性targetの値を設定します。

パラメータ:
target - target

setEnctype

public void setEnctype(String enctype)
属性enctypeの値を設定します。

パラメータ:
enctype - enctype

getAccept

public String getAccept()
属性acceptの値を取得します。

戻り値:
accept

setAccept

public void setAccept(String accept)
属性acceptの値を設定します。

パラメータ:
accept - accept

getName

public String getName()
属性nameの値を取得します。

戻り値:
name

setName

public void setName(String name)
属性nameの値を設定します。

パラメータ:
name - name

getOnsubmit

public String getOnsubmit()
属性onSubmitの値を取得します。

戻り値:
onSubmit

setOnsubmit

public void setOnsubmit(String onSubmit)
属性onSubmitの値を設定します。

パラメータ:
onSubmit - onSubmit

getOnreset

public String getOnreset()
属性onResetの値を取得します。

戻り値:
onReset

setOnreset

public void setOnreset(String onReset)
属性onResetの値を設定します。

パラメータ:
onReset - onReset

getAcceptcharset

public String getAcceptcharset()
属性accept-charsetの値を取得します。

戻り値:
accept-charset

setAcceptcharset

public void setAcceptcharset(String acceptCharset)
属性accept-charsetの値を設定します。

パラメータ:
acceptCharset - accept-charset

getFormclass

public String getFormclass()
属性classの値を取得します。

戻り値:
class

setFormclass

public void setFormclass(String formClass)
属性classの値を設定します。

パラメータ:
formClass - class

getStyle

public String getStyle()
属性styleの値を取得します。

戻り値:
style

setStyle

public void setStyle(String style)
属性styleの値を設定します。

パラメータ:
style - style

getTitle

public String getTitle()
属性titleの値を取得します。

戻り値:
title

setTitle

public void setTitle(String title)
属性titleの値を設定します。

パラメータ:
title - title

getLang

public String getLang()
属性langの値を取得します。

戻り値:
lang

setLang

public void setLang(String lang)
属性langの値を設定します。

パラメータ:
lang - lang

getDir

public String getDir()
属性dirの値を取得します。

戻り値:
dir

setDir

public void setDir(String dir)
属性dirの値を設定します。

パラメータ:
dir - dir

getOnclick

public String getOnclick()
属性onClickの値を取得します。

戻り値:
onClick

setOnclick

public void setOnclick(String onClick)
属性onClickの値を設定します。

パラメータ:
onClick - onClick

getOndblclick

public String getOndblclick()
属性onDblClickの値を取得します。

戻り値:
onDblClick

setOndblclick

public void setOndblclick(String onDblClick)
属性obDblClickの値を設定します。

パラメータ:
onDblClick - onDblClick

getOnmousedown

public String getOnmousedown()
属性onMouseDownの値を取得します。

戻り値:
onMouseDown

setOnmousedown

public void setOnmousedown(String onMouseDown)
属性onMouseDownの値を設定します。

パラメータ:
onMouseDown - onMouseDown

getOnmouseup

public String getOnmouseup()
属性onMouseUpの値を取得します。

戻り値:
onMouseUp

setOnmouseup

public void setOnmouseup(String onMouseUp)
属性onMouseUpの値を設定します。

パラメータ:
onMouseUp - onMouseUp

getOnmouseover

public String getOnmouseover()
属性onMouseOverの値を取得します。

戻り値:
onMouseOver

setOnmouseover

public void setOnmouseover(String onMouseOver)
属性onMouseOverの値を設定します。

パラメータ:
onMouseOver - onMouseOver

getOnmousemove

public String getOnmousemove()
属性onMouseMoveの値を取得します。

戻り値:
onMouseMove

setOnmousemove

public void setOnmousemove(String onMouseMove)
属性onMouseMoveの値を設定します。

パラメータ:
onMouseMove - onMouseMove

getOnmouseout

public String getOnmouseout()
属性onMouseOutの値を取得します。

戻り値:
onMouseOut

setOnmouseout

public void setOnmouseout(String onMouseOut)
属性onMouseOutの値を設定します。

パラメータ:
onMouseOut - onMouseOut

getOnkeypress

public String getOnkeypress()
属性onKeyPressの値を取得します。

戻り値:
onKeyPress

setOnkeypress

public void setOnkeypress(String onKeyPress)
属性onKeyPressの値を設定します。

パラメータ:
onKeyPress - onKeyPress

getOnkeydown

public String getOnkeydown()
属性onKeyDownの値を取得します。

戻り値:
onKeyDown

setOnkeydown

public void setOnkeydown(String onKeyDown)
属性onKeyDownの値を設定します。

パラメータ:
onKeyDown - onKeyDown

getOnkeyup

public String getOnkeyup()
属性onKeyUpの値を取得します。

戻り値:
onKeyUp

setOnkeyup

public void setOnkeyup(String onKeyUp)
属性onKeyUpの値を設定します。

パラメータ:
onKeyUp - onKeyUp
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


FormTagBeanInfo (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FormTagBeanInfo

java.lang.Object
    拡張 java.beans.SimpleBeanInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo
すべての実装インタフェース:
BeanInfo
public class FormTagBeanInfo
extends SimpleBeanInfo

FormTagのBeanInfoです。

導入されたバージョン:
4.0

フィールドの概要
インタフェース java.beans.BeanInfo から継承したフィールド
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
コンストラクタの概要
FormTagBeanInfo()
FormTagBeanInfoを新規に生成します。
メソッドの概要
 PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。
クラス java.beans.SimpleBeanInfo から継承したメソッド
getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, loadImage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FormTagBeanInfo

public FormTagBeanInfo()
FormTagBeanInfoを新規に生成します。

メソッドの詳細

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。

戻り値:
PropertyDescriptor
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FormTEI (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FormTEI

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagExtraInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.FormTEI
public class FormTEI
extends TagExtraInfo

Formタグの拡張情報です。

導入されたバージョン:
4.0

コンストラクタの概要
FormTEI()
FormTEIを新規に生成します。
メソッドの概要
 boolean isValid(TagData tagData)
Formタグに指定された内容の正当性を検証します。
クラス javax.servlet.jsp.tagext.TagExtraInfo から継承したメソッド
getTagInfo, getVariableInfo, setTagInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FormTEI

public FormTEI()
FormTEIを新規に生成します。

メソッドの詳細

isValid

public boolean isValid(TagData tagData)
Formタグに指定された内容の正当性を検証します。 検証内容は以下のとおりです。
  • class属性またはformclass属性がある場合、いずれかのみが設定されている
  • acceptcharset属性またはaccept-charset属性がある場合、いずれかのみが設定されている

パラメータ:
tagData - タグ情報
戻り値:
タグが正当な場合true、それ以外の場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FrameTag (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FrameTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.FrameTag
すべての実装インタフェース:
BodyTag, IterationTag, ParameterSendable, Serializable, Tag
public class FrameTag
extends BodyTagSupport
implements ParameterSendable

FRAMEタグです。 intra-martフレームワークを使用する場合のセッションフレームワーク、サービスフレームワークの一部となります。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
FrameTag()
FrameTagを新規に生成します。
メソッドの概要
void | addParameter(String name, String value) パラメータを追加します。
int | doEndTag() 終了タグを検知したときにJSPエンジンから呼ばれます。
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getApplication() アプリケーションを取得します。
String | getFrameborder() frameborderを取得します。
String | getFrameclass() frameClassを取得します。
String | getFrameClass() 推奨されていません。 このメソッドではなくgetFrameclass()メソッドを使用してください。
String | getLongdesc() longdescを取得します。
String | getMarginheight() marginheightを取得します。
String | getMarginwidth() marginwidthを取得します。
String | getName() nameを取得します。
String | getNoresize() noresizeを取得します。
String | getScrolling() scrollingを取得します。
String | getService() サービスを取得します。
String | getStyle() styleを取得します。
String | getTitle() titleを取得します。
void | setApplication(String application) アプリケーションを設定します。
void | setFrameborder(String frameborder) frameborderを設定します。
void | setFrameclass(String frameClass) frameClassを設定します。
void | setFrameClass(String frameClass) 推奨されていません。 このメソッドではなくsetFrameclass(String)メソッドを使用してください。
void | setLongdesc(String longdesc) longdescを設定します。
void | setMarginheight(String marginheight) marginheightを設定します。
void | setMarginwidth(String marginwidth) marginwidthを設定します。
void | setName(String name) nameを設定します。
void | setNoresize(String noresize) noresizeを設定します。
void | setScrolling(String scrolling) scrollingを設定します。
void | setService(String service) serviceを設定します。
void | setStyle(String style) styleを設定します。
void | setTitle(String title) titleを設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

FrameTag

public FrameTag()
FrameTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 FRAMEタグを解釈します。

定義:
インタフェース Tag 内の doStartTag
戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - タグの解釈時に例外が発生

doEndTag

public int doEndTag()
             throws JspException
終了タグを検知したときにJSPエンジンから呼ばれます。 FRAMEタグを終了します。

定義:
インタフェース Tag 内の doEndTag
戻り値:
EVAL_PAGE
例外:
JspException - タグの終了時に例外が発生

addParameter

public void addParameter(String name,
                         String value)
パラメータを追加します。

定義:
インタフェース ParameterSendable 内の addParameter
パラメータ:
name - パラメータ名
value - パラメータの値

getApplication

public String getApplication()
アプリケーションを取得します。

戻り値:
アプリケーション

setApplication

public void setApplication(String application)
アプリケーションを設定します。

パラメータ:
application - アプリケーション

getService

public String getService()
サービスを取得します。

戻り値:
サービス

setService

public void setService(String service)
serviceを設定します。

パラメータ:
service - サービス

getLongdesc

public String getLongdesc()
longdescを取得します。

戻り値:
longdesc

setLongdesc

public void setLongdesc(String longdesc)
longdescを設定します。

パラメータ:
longdesc - longdesc

getName

public String getName()
nameを取得します。

戻り値:
name

setName

public void setName(String name)
nameを設定します。

パラメータ:
name - name

getFrameborder

public String getFrameborder()
frameborderを取得します。

戻り値:
frameborder

setFrameborder

public void setFrameborder(String frameborder)
frameborderを設定します。

パラメータ:
frameborder - frameborder

getMarginwidth

public String getMarginwidth()
marginwidthを取得します。

戻り値:
marginwidth

setMarginwidth

public void setMarginwidth(String marginwidth)
marginwidthを設定します。

パラメータ:
marginwidth - marginwidth

getMarginheight

public String getMarginheight()
marginheightを取得します。

戻り値:
marginheight

setMarginheight

public void setMarginheight(String marginheight)
marginheightを設定します。

パラメータ:
marginheight - marginheight

getNoresize

public String getNoresize()
noresizeを取得します。

戻り値:
noresize

setNoresize

public void setNoresize(String noresize)
noresizeを設定します。

パラメータ:
noresize - noresize

getScrolling

public String getScrolling()
scrollingを取得します。

戻り値:
scrolling

setScrolling

public void setScrolling(String scrolling)
scrollingを設定します。

パラメータ:
scrolling - scrolling

getFrameClass

public String getFrameClass()
推奨されていません。 このメソッドではなくgetFrameclass()メソッドを使用してください。

frameClassを取得します。

戻り値:
frameClass

setFrameClass

public void setFrameClass(String frameClass)
推奨されていません。 このメソッドではなくsetFrameclass(String)メソッドを使用してください。

frameClassを設定します。

パラメータ:
frameClass - frameClass

getFrameclass

public String getFrameclass()
frameClassを取得します。

戻り値:
frameClass

setFrameclass

public void setFrameclass(String frameClass)
frameClassを設定します。

パラメータ:
frameClass - frameClass

getStyle

public String getStyle()
styleを取得します。

戻り値:
style

setStyle

public void setStyle(String style)
styleを設定します。

パラメータ:
style - style

getTitle

public String getTitle()
titleを取得します。

戻り値:
title

setTitle

public void setTitle(String title)
titleを設定します。

パラメータ:
title - title
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FrameTagBeanInfo (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FrameTagBeanInfo

java.lang.Object
    拡張 java.beans.SimpleBeanInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo
すべての実装インタフェース:
BeanInfo
public class FrameTagBeanInfo
extends SimpleBeanInfo

FrameTagのBeanInfoです。

導入されたバージョン:
4.0

フィールドの概要
インタフェース java.beans.BeanInfo から継承したフィールド
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
コンストラクタの概要
FrameTagBeanInfo()
FrameTagBeanInfoを新規に生成します。
メソッドの概要
 PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。
クラス java.beans.SimpleBeanInfo から継承したメソッド
getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, loadImage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FrameTagBeanInfo

public FrameTagBeanInfo()
FrameTagBeanInfoを新規に生成します。

メソッドの詳細

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。

戻り値:
PropertyDescriptor
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FrameTEI (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FrameTEI

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagExtraInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.FrameTEI
public class FrameTEI
extends TagExtraInfo

Frameタグの拡張情報です。

導入されたバージョン:
4.0

コンストラクタの概要
FrameTEI()
FrameTEIを新規に生成します。
メソッドの概要
 boolean isValid(TagData tagData)
Frameタグに指定された内容の正当性を検証します。
クラス javax.servlet.jsp.tagext.TagExtraInfo から継承したメソッド
getTagInfo, getVariableInfo, setTagInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FrameTEI

public FrameTEI()
FrameTEIを新規に生成します。

メソッドの詳細

isValid

public boolean isValid(TagData tagData)
Frameタグに指定された内容の正当性を検証します。 検証内容は以下のとおりです。
  • class属性またはframeclass属性がある場合、いずれかのみが設定されている

パラメータ:
tagData - タグ情報
戻り値:
タグが正当な場合true、それ以外の場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FrameworkTagException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FrameworkTagException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.jsp.JspException
                拡張 jp.co.intra_mart.framework.base.web.tag.FrameworkTagException
すべての実装インタフェース:
Serializable
public class FrameworkTagException
extends JspException

拡張タグの例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
FrameworkTagException()
詳細メッセージを指定しないで FrameworkTagException を構築します。
FrameworkTagException(String msg)
指定された詳細メッセージを持つ FrameworkTagException を構築します。
FrameworkTagException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkTagException を構築します。
FrameworkTagException(Throwable throwable)
この例外の発生原因となる例外を持つ FrameworkTagException を構築します。
メソッドの概要
void | printStackTrace()
void | printStackTrace(PrintStream printStream)
void | printStackTrace(PrintWriter printWriter)
クラス javax.servlet.jsp.JspException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

FrameworkTagException

public FrameworkTagException()
詳細メッセージを指定しないで FrameworkTagException を構築します。

FrameworkTagException

public FrameworkTagException(String msg)
指定された詳細メッセージを持つ FrameworkTagException を構築します。

パラメータ:
msg - 詳細メッセージ

FrameworkTagException

public FrameworkTagException(String msg,
                             Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkTagException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外

FrameworkTagException

public FrameworkTagException(Throwable throwable)
この例外の発生原因となる例外を持つ FrameworkTagException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外
メソッドの詳細

printStackTrace

public void printStackTrace()

printStackTrace

public void printStackTrace(PrintStream printStream)

printStackTrace

public void printStackTrace(PrintWriter printWriter)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


FrameworkTagParam (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FrameworkTagParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
        拡張 jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam
public class FrameworkTagParam
extends PropertyParam

タグに追加されるパラメータです。

バージョン:
1.0

コンストラクタの概要
FrameworkTagParam()
FrameworkTagParamを新規に生成します。
クラス jp.co.intra_mart.framework.system.property.PropertyParam から継承したメソッド
getName, getValue, setName, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FrameworkTagParam

public FrameworkTagParam()
FrameworkTagParamを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HelperBeanTag (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス HelperBeanTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.HelperBeanTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class HelperBeanTag
extends BodyTagSupport

HelperBeanタグです。

導入されたバージョン:
3.2
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
HelperBeanTag()
HelperBeanTagを新規に生成します。
メソッドの概要
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getHelperclass() クラス名を取得します。
void | setClass(String className) 推奨されていません。 このメソッドではなくsetHelperclass(java.lang.String)メソッドを使用してください。
void | setHelperclass(String helperclass) クラス名を設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doEndTag, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

HelperBeanTag

public HelperBeanTag()
HelperBeanTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 HelperBeanタグを解釈します。

戻り値:
SKIP_BODY
例外:
JspException - タグの解釈時に例外が発生

setClass

public void setClass(String className)
推奨されていません。 このメソッドではなくsetHelperclass(java.lang.String)メソッドを使用してください。

クラス名を設定します。

パラメータ:
className - クラス名

setHelperclass

public void setHelperclass(String helperclass)
クラス名を設定します。

パラメータ:
helperclass - クラス名
導入されたバージョン:
4.0

getHelperclass

public String getHelperclass()
クラス名を取得します。

戻り値:
クラス名
導入されたバージョン:
4.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HelperBeanTagBeanInfo (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス HelperBeanTagBeanInfo

java.lang.Object
    拡張 java.beans.SimpleBeanInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo
すべての実装インタフェース:
BeanInfo
public class HelperBeanTagBeanInfo
extends SimpleBeanInfo

HelperBeanTagのBeanInfoです。

導入されたバージョン:
4.0

フィールドの概要
インタフェース java.beans.BeanInfo から継承したフィールド
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
コンストラクタの概要
HelperBeanTagBeanInfo()
HelperBeanTagBeanInfoを新規に生成します。
メソッドの概要
 PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。
クラス java.beans.SimpleBeanInfo から継承したメソッド
getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, loadImage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HelperBeanTagBeanInfo

public HelperBeanTagBeanInfo()
HelperBeanTagBeanInfoを新規に生成します。

メソッドの詳細

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。

戻り値:
PropertyDescriptor
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HelperBeanTEI (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス HelperBeanTEI

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagExtraInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI
public class HelperBeanTEI
extends TagExtraInfo

HelperBeanタグの拡張情報です。

導入されたバージョン:
3.2

コンストラクタの概要
HelperBeanTEI()
HelperBeanTEIを新規に生成します。
メソッドの概要
VariableInfo[] | getVariableInfo(TagData tagData) スクリプティング変数に関連付けたHelperBeanの情報を取得します。
boolean | isValid(TagData tagData) HelperBeanタグに指定された内容の正当性を検証します。
クラス javax.servlet.jsp.tagext.TagExtraInfo から継承したメソッド
getTagInfo, setTagInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HelperBeanTEI

public HelperBeanTEI()
HelperBeanTEIを新規に生成します。

メソッドの詳細

getVariableInfo

public VariableInfo[] getVariableInfo(TagData tagData)
スクリプティング変数に関連付けたHelperBeanの情報を取得します。 属性idで指定された変数に属性class（またはhelperclass）で指定されたHelperBeanを割り当てます。

パラメータ:
tagData - タグデータ
戻り値:
スクリプティング変数の情報

isValid

public boolean isValid(TagData tagData)
HelperBeanタグに指定された内容の正当性を検証します。 検証内容は以下のとおりです。
  • class属性またはhelperclass属性のいずれかのみが設定されている

パラメータ:
tagData - タグ情報
戻り値:
タグが正当な場合true、それ以外の場合はfalse
導入されたバージョン:
4.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LinkTag (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス LinkTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.LinkTag
すべての実装インタフェース:
BodyTag, IterationTag, ParameterSendable, Serializable, Tag
public class LinkTag
extends BodyTagSupport
implements ParameterSendable

LINKタグです。 intra-martフレームワークを使用する場合のセッションフレームワーク、サービスフレームワークの一部となります。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
LinkTag()
LinkTagを新規に生成します。
メソッドの概要
void | addParameter(String name, String value) パラメータを追加します。
int | doEndTag() 終了タグを検知したときにJSPエンジンから呼ばれます。
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getAccesskey() accesskeyを取得します。
String | getApplication() アプリケーションを取得します。
String | getCharset() charsetを取得します。
String | getCoords() coordsを取得します。
String | getDir() dirを取得します。
String | getHreflang() hreflangを取得します。
String | getLang() langを取得します。
String | getLinkclass() linkClassを取得します。
String | getLinkClass() 推奨されていません。 このメソッドではなくgetLinkclass()メソッドを使用してください。
String | getName() nameを取得します。
String | getOnblur() onblurを取得します。
String | getOnclick() 属性onClickの値を取得します。
String | getOndblclick() 属性onDblClickの値を取得します。
String | getOnfocus() onfocusを取得します。
String | getOnkeydown() 属性onKeyDownの値を取得します。
String | getOnkeypress() 属性onKeyPressの値を取得します。
String | getOnkeyup() 属性onKeyUpの値を取得します。
String | getOnmousedown() 属性onMouseDownの値を取得します。
String | getOnmousemove() 属性onMouseMoveの値を取得します。
String | getOnmouseout() 属性onMouseOutの値を取得します。
String | getOnmouseover() 属性onMouseOverの値を取得します。
String | getOnmouseup() 属性onMouseUpの値を取得します。
String | getRel() relを取得します。
String | getRev() revを取得します。
String | getService() サービスを取得します。
String | getShape() shapeを取得します。
String | getStyle() styleを取得します。
String | getTabindex() tabindexを取得します。
String | getTarget() targetを取得します。
String | getTitle() titleを取得します。
String | getType() typeを取得します。
void | setAccesskey(String accesskey) accesskeyを設定します。
void | setApplication(String application) アプリケーションを設定します。
void | setCharset(String charset) charsetを設定します。
void | setCoords(String coords) coordsを設定します。
void | setDir(String dir) dirを設定します。
void | setHreflang(String hreflang) hreflangを設定します。
void | setLang(String lang) langを設定します。
void | setLinkclass(String linkClass) linkClassを設定します。
void | setLinkClass(String linkClass) 推奨されていません。 このメソッドではなくsetLinkclass(String)メソッドを使用してください。
void | setName(String name) nameを設定します。
void | setOnblur(String onblur) onblurを設定します。
void | setOnclick(String onClick) 属性onClickの値を設定します。
void | setOndblclick(String onDblClick) 属性obDblClickの値を設定します。
void | setOnfocus(String onfocus) onfocusを設定します。
void | setOnkeydown(String onKeyDown) 属性onKeyDownの値を設定します。
void | setOnkeypress(String onKeyPress) 属性onKeyPressの値を設定します。
void | setOnkeyup(String onKeyUp) 属性onKeyUpの値を設定します。
void | setOnmousedown(String onMouseDown) 属性onMouseDownの値を設定します。
void | setOnmousemove(String onMouseMove) 属性onMouseMoveの値を設定します。
void | setOnmouseout(String onMouseOut) 属性onMouseOutの値を設定します。
void | setOnmouseover(String onMouseOver) 属性onMouseOverの値を設定します。
void | setOnmouseup(String onMouseUp) 属性onMouseUpの値を設定します。
void | setRel(String rel) relを設定します。
void | setRev(String rev) relを設定します。
void | setService(String service) serviceを設定します。
void | setShape(String shape) shapeを設定します。
void | setStyle(String style) styleを設定します。
void | setTabindex(String tabindex) tabindexを設定します。
void | setTarget(String target) targetを設定します。
void | setTitle(String title) titleを設定します。
void | setType(String type) typeを設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

LinkTag

public LinkTag()
LinkTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 LINKタグを解釈します。

定義:
インタフェース Tag 内の doStartTag
戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - タグの解釈時に例外が発生

doEndTag

public int doEndTag()
             throws JspException
終了タグを検知したときにJSPエンジンから呼ばれます。 LINKタグを終了します。

定義:
インタフェース Tag 内の doEndTag
戻り値:
EVAL_PAGE
例外:
JspException - タグの終了時に例外が発生

addParameter

public void addParameter(String name,
                         String value)
パラメータを追加します。

定義:
インタフェース ParameterSendable 内の addParameter
パラメータ:
name - パラメータ名
value - パラメータの値

getCharset

public String getCharset()
charsetを取得します。

戻り値:
charset

setCharset

public void setCharset(String charset)
charsetを設定します。

パラメータ:
charset - charset

getType

public String getType()
typeを取得します。

戻り値:
type

setType

public void setType(String type)
typeを設定します。

パラメータ:
type - type

getName

public String getName()
nameを取得します。

戻り値:
name

setName

public void setName(String name)
nameを設定します。

パラメータ:
name - name

getApplication

public String getApplication()
アプリケーションを取得します。

戻り値:
アプリケーション

setApplication

public void setApplication(String application)
アプリケーションを設定します。

パラメータ:
application - アプリケーション

getService

public String getService()
サービスを取得します。

戻り値:
サービス

setService

public void setService(String service)
serviceを設定します。

パラメータ:
service - サービス

getHreflang

public String getHreflang()
hreflangを取得します。

戻り値:
hreflang

setHreflang

public void setHreflang(String hreflang)
hreflangを設定します。

パラメータ:
hreflang - hreflang

getRel

public String getRel()
relを取得します。

戻り値:
rel

setRel

public void setRel(String rel)
relを設定します。

パラメータ:
rel - rel

getRev

public String getRev()
revを取得します。

戻り値:
rev

setRev

public void setRev(String rev)
relを設定します。

パラメータ:
rev - rev

getAccesskey

public String getAccesskey()
accesskeyを取得します。

戻り値:
accesskey

setAccesskey

public void setAccesskey(String accesskey)
accesskeyを設定します。

パラメータ:
accesskey - accesskey

getShape

public String getShape()
shapeを取得します。

戻り値:
shape

setShape

public void setShape(String shape)
shapeを設定します。

パラメータ:
shape - shape

getCoords

public String getCoords()
coordsを取得します。

戻り値:
coords

setCoords

public void setCoords(String coords)
coordsを設定します。

パラメータ:
coords - coords

getTarget

public String getTarget()
targetを取得します。

戻り値:
target
導入されたバージョン:
3.2

setTarget

public void setTarget(String target)
targetを設定します。

パラメータ:
target - target
導入されたバージョン:
3.2

getTabindex

public String getTabindex()
tabindexを取得します。

戻り値:
tabindex

setTabindex

public void setTabindex(String tabindex)
tabindexを設定します。

パラメータ:
tabindex - tabindex

getOnfocus

public String getOnfocus()
onfocusを取得します。

戻り値:
onfocus

setOnfocus

public void setOnfocus(String onfocus)
onfocusを設定します。

パラメータ:
onfocus - onfocus

getOnblur

public String getOnblur()
onblurを取得します。

戻り値:
onblur

setOnblur

public void setOnblur(String onblur)
onblurを設定します。

パラメータ:
onblur - onblur

getLinkClass

public String getLinkClass()
推奨されていません。 このメソッドではなくgetLinkclass()メソッドを使用してください。

linkClassを取得します。

戻り値:
linkClass

setLinkClass

public void setLinkClass(String linkClass)
推奨されていません。 このメソッドではなくsetLinkclass(String)メソッドを使用してください。

linkClassを設定します。

パラメータ:
linkClass - class

getLinkclass

public String getLinkclass()
linkClassを取得します。

戻り値:
linkClass

setLinkclass

public void setLinkclass(String linkClass)
linkClassを設定します。

パラメータ:
linkClass - class

getStyle

public String getStyle()
styleを取得します。

戻り値:
style

setStyle

public void setStyle(String style)
styleを設定します。

パラメータ:
style - style

getTitle

public String getTitle()
titleを取得します。

戻り値:
title

setTitle

public void setTitle(String title)
titleを設定します。

パラメータ:
title - title

getLang

public String getLang()
langを取得します。

戻り値:
lang

setLang

public void setLang(String lang)
langを設定します。

パラメータ:
lang - lang

getDir

public String getDir()
dirを取得します。

戻り値:
dir

setDir

public void setDir(String dir)
dirを設定します。

パラメータ:
dir - dir

getOnclick

public String getOnclick()
属性onClickの値を取得します。

戻り値:
onClick

setOnclick

public void setOnclick(String onClick)
属性onClickの値を設定します。

パラメータ:
onClick - onClick

getOndblclick

public String getOndblclick()
属性onDblClickの値を取得します。

戻り値:
onDblClick

setOndblclick

public void setOndblclick(String onDblClick)
属性obDblClickの値を設定します。

パラメータ:
onDblClick - onDblClick

getOnmousedown

public String getOnmousedown()
属性onMouseDownの値を取得します。

戻り値:
onMouseDown

setOnmousedown

public void setOnmousedown(String onMouseDown)
属性onMouseDownの値を設定します。

パラメータ:
onMouseDown - onMouseDown

getOnmouseup

public String getOnmouseup()
属性onMouseUpの値を取得します。

戻り値:
onMouseUp

setOnmouseup

public void setOnmouseup(String onMouseUp)
属性onMouseUpの値を設定します。

パラメータ:
onMouseUp - onMouseUp

getOnmouseover

public String getOnmouseover()
属性onMouseOverの値を取得します。

戻り値:
onMouseOver

setOnmouseover

public void setOnmouseover(String onMouseOver)
属性onMouseOverの値を設定します。

パラメータ:
onMouseOver - onMouseOver

getOnmousemove

public String getOnmousemove()
属性onMouseMoveの値を取得します。

戻り値:
onMouseMove

setOnmousemove

public void setOnmousemove(String onMouseMove)
属性onMouseMoveの値を設定します。

パラメータ:
onMouseMove - onMouseMove

getOnmouseout

public String getOnmouseout()
属性onMouseOutの値を取得します。

戻り値:
onMouseOut

setOnmouseout

public void setOnmouseout(String onMouseOut)
属性onMouseOutの値を設定します。

パラメータ:
onMouseOut - onMouseOut

getOnkeypress

public String getOnkeypress()
属性onKeyPressの値を取得します。

戻り値:
onKeyPress

setOnkeypress

public void setOnkeypress(String onKeyPress)
属性onKeyPressの値を設定します。

パラメータ:
onKeyPress - onKeyPress

getOnkeydown

public String getOnkeydown()
属性onKeyDownの値を取得します。

戻り値:
onKeyDown

setOnkeydown

public void setOnkeydown(String onKeyDown)
属性onKeyDownの値を設定します。

パラメータ:
onKeyDown - onKeyDown

getOnkeyup

public String getOnkeyup()
属性onKeyUpの値を取得します。

戻り値:
onKeyUp

setOnkeyup

public void setOnkeyup(String onKeyUp)
属性onKeyUpの値を設定します。

パラメータ:
onKeyUp - onKeyUp
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LinkTagBeanInfo (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス LinkTagBeanInfo

java.lang.Object
    拡張 java.beans.SimpleBeanInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo
すべての実装インタフェース:
BeanInfo
public class LinkTagBeanInfo
extends SimpleBeanInfo

LinkTagのBeanInfoです。

導入されたバージョン:
4.0

フィールドの概要
インタフェース java.beans.BeanInfo から継承したフィールド
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
コンストラクタの概要
LinkTagBeanInfo()
LinkTagBeanInfoを新規に生成します。
メソッドの概要
 PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。
クラス java.beans.SimpleBeanInfo から継承したメソッド
getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, loadImage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LinkTagBeanInfo

public LinkTagBeanInfo()
LinkTagBeanInfoを新規に生成します。

メソッドの詳細

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。

戻り値:
PropertyDescriptor
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LinkTEI (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス LinkTEI

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagExtraInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.LinkTEI
public class LinkTEI
extends TagExtraInfo

Linkタグの拡張情報です。

導入されたバージョン:
4.0

コンストラクタの概要
LinkTEI()
LinkTEIを新規に生成します。
メソッドの概要
 boolean isValid(TagData tagData)
Linkタグに指定された内容の正当性を検証します。
クラス javax.servlet.jsp.tagext.TagExtraInfo から継承したメソッド
getTagInfo, getVariableInfo, setTagInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LinkTEI

public LinkTEI()
LinkTEIを新規に生成します。

メソッドの詳細

isValid

public boolean isValid(TagData tagData)
Linkタグに指定された内容の正当性を検証します。 検証内容は以下のとおりです。
  • class属性またはlinkclass属性がある場合、いずれかのみが設定されている

パラメータ:
tagData - タグ情報
戻り値:
タグが正当な場合true、それ以外の場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MessageParamTag (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス MessageParamTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.MessageParamTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class MessageParamTag
extends BodyTagSupport

メッセージの生成で使用するパラメータを設定します。

導入されたバージョン:
4.2
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
MessageParamTag()
ParamTagを新規に生成します。
メソッドの概要
int | doStartTag() 外側の一番近いMessageTagにパラメータを設定します。
Object | getValue() パラメータの値を取得します。
void | setValue(Object value) パラメータの値を設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doEndTag, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

MessageParamTag

public MessageParamTag()
ParamTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
外側の一番近いMessageTagにパラメータを設定します。

戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - JSP出力時に例外が発生

getValue

public Object getValue()
パラメータの値を取得します。

戻り値:
パラメータの値

setValue

public void setValue(Object value)
パラメータの値を設定します。

パラメータ:
value - パラメータの値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MessageTag (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス MessageTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.MessageTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class MessageTag
extends BodyTagSupport

Messageタグです。 im-J2EE Frameworkを使用する場合のMessageフレームワークの一部となります。

導入されたバージョン:
4.2
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
MessageTag()
MessageTagを新規に生成します。
メソッドの概要
void | addParameter(Object value) パラメータを追加します。
int | doEndTag() 終了タグを検知したときにJSPエンジンから呼ばれます。
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getApplication() applicationを取得します。
String | getKey() keyを取得します。
String | getLocale() localeを取得します。
void | setApplication(String application) applicationを設定します。
void | setKey(String key) keyを設定します。
void | setLocale(String locale) localeを設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

MessageTag

public MessageTag()
MessageTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 Messageタグを解釈します。

戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - タグの解釈時に例外が発生

doEndTag

public int doEndTag()
             throws JspException
終了タグを検知したときにJSPエンジンから呼ばれます。 Messageタグを終了します。

戻り値:
EVAL_PAGE
例外:
JspException - タグの終了時に例外が発生

addParameter

public void addParameter(Object value)
パラメータを追加します。

パラメータ:
value - パラメータの値

getApplication

public String getApplication()
applicationを取得します。

戻り値:
application

setApplication

public void setApplication(String application)
applicationを設定します。

パラメータ:
application - application

getKey

public String getKey()
keyを取得します。

戻り値:
key

setKey

public void setKey(String key)
keyを設定します。

パラメータ:
key - key

getLocale

public String getLocale()
localeを取得します。

戻り値:
locale

setLocale

public void setLocale(String locale)
localeを設定します。

パラメータ:
locale - locale
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MessageTEI (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス MessageTEI

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagExtraInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.MessageTEI
public class MessageTEI
extends TagExtraInfo

Messageタグの拡張情報です。

導入されたバージョン:
4.2

コンストラクタの概要
MessageTEI()
メソッドの概要
 boolean isValid(TagData tagData)
Messageタグに指定された内容の正当性を検証します。
クラス javax.servlet.jsp.tagext.TagExtraInfo から継承したメソッド
getTagInfo, getVariableInfo, setTagInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MessageTEI

public MessageTEI()
メソッドの詳細

isValid

public boolean isValid(TagData tagData)
Messageタグに指定された内容の正当性を検証します。 検証内容は以下のとおりです。
  • locale属性が指定されている場合、書式が言語_国[_バリアント]となっていること
    ロケール文字列のアンダーバー(_)はハイフン(-)であってもかまいません。
locale属性が指定されていない場合、trueが返されます。

パラメータ:
tagData - タグ情報
戻り値:
タグが正当な場合true、それ以外の場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.web.tag (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.base.web.tag
インタフェース
ParameterSendable
クラス
FormTag
FormTagBeanInfo
FormTEI
FrameTag
FrameTagBeanInfo
FrameTEI
FrameworkTagParam
HelperBeanTag
HelperBeanTagBeanInfo
HelperBeanTEI
LinkTag
LinkTagBeanInfo
LinkTEI
MessageParamTag
MessageTag
MessageTEI
ParamTag
SubmitLinkTag
SubmitLinkTagBeanInfo
SubmitTag
SubmitTagBeanInfo
SubmitTEI
TagWriter
例外
FrameworkTagException


jp.co.intra_mart.framework.base.web.tag (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.tag

J2EEフレームワークで使用する各種のタグのパッケージです。

参照:
説明

インタフェースの概要
ParameterSendable パラメータを渡すことができるタグです。

クラスの概要
FormTag | FORMタグです。
FormTagBeanInfo | FormTagのBeanInfoです。
FormTEI | Formタグの拡張情報です。
FrameTag | FRAMEタグです。
FrameTagBeanInfo | FrameTagのBeanInfoです。
FrameTEI | Frameタグの拡張情報です。
FrameworkTagParam | タグに追加されるパラメータです。
HelperBeanTag | HelperBeanタグです。
HelperBeanTagBeanInfo | HelperBeanTagのBeanInfoです。
HelperBeanTEI | HelperBeanタグの拡張情報です。
LinkTag | LINKタグです。
LinkTagBeanInfo | LinkTagのBeanInfoです。
LinkTEI | Linkタグの拡張情報です。
MessageParamTag | メッセージの生成で使用するパラメータを設定します。
MessageTag | Messageタグです。
MessageTEI | Messageタグの拡張情報です。
ParamTag | リンク先、遷移先に渡すパラメータを設定します。
SubmitLinkTag | サブミット専用のLINKタグです。
SubmitLinkTagBeanInfo | SubmitLinkTagのBeanInfoです。
SubmitTag | Submitタグです。
SubmitTagBeanInfo | SubmitTagのBeanInfoです。
SubmitTEI | Submitタグの拡張情報です。
TagWriter | タグの出力を行います。

例外の概要
FrameworkTagException 拡張タグの例外です。

パッケージ jp.co.intra_mart.framework.base.web.tag の説明

J2EEフレームワークで使用する各種のタグのパッケージです。 セッション情報を保ったまま画面遷移することが可能になります。


jp.co.intra_mart.framework.base.web.tag クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.tag の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam
    • class java.beans.SimpleBeanInfo (implements java.beans.BeanInfo)
      • class jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo
    • class javax.servlet.jsp.tagext.TagExtraInfo
      • class jp.co.intra_mart.framework.base.web.tag.FormTEI
      • class jp.co.intra_mart.framework.base.web.tag.FrameTEI
      • class jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI
      • class jp.co.intra_mart.framework.base.web.tag.LinkTEI
      • class jp.co.intra_mart.framework.base.web.tag.MessageTEI
      • class jp.co.intra_mart.framework.base.web.tag.SubmitTEI
    • class javax.servlet.jsp.tagext.TagSupport (implements javax.servlet.jsp.tagext.IterationTag, java.io.Serializable)
      • class javax.servlet.jsp.tagext.BodyTagSupport (implements javax.servlet.jsp.tagext.BodyTag)
        • class jp.co.intra_mart.framework.base.web.tag.FormTag
        • class jp.co.intra_mart.framework.base.web.tag.FrameTag (implements jp.co.intra_mart.framework.base.web.tag.ParameterSendable)
        • class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag
        • class jp.co.intra_mart.framework.base.web.tag.LinkTag (implements jp.co.intra_mart.framework.base.web.tag.ParameterSendable)
        • class jp.co.intra_mart.framework.base.web.tag.MessageParamTag
        • class jp.co.intra_mart.framework.base.web.tag.MessageTag
        • class jp.co.intra_mart.framework.base.web.tag.ParamTag
        • class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag
        • class jp.co.intra_mart.framework.base.web.tag.SubmitTag
    • class jp.co.intra_mart.framework.base.web.tag.TagWriter
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.servlet.jsp.JspException
          • class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException

インタフェース階層

  • interface jp.co.intra_mart.framework.base.web.tag.ParameterSendable


パッケージ jp.co.intra_mart.framework.base.web.tag の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.web.tag の使用

jp.co.intra_mart.framework.base.web.tag を使用しているパッケージ
jp.co.intra_mart.framework.base.web.tag | J2EEフレームワークで使用する各種のタグのパッケージです。
jp.co.intra_mart.framework.base.web.tag.attribute | タグ属性のパッケージです。

jp.co.intra_mart.framework.base.web.tag により使用される jp.co.intra_mart.framework.base.web.tag のクラス
ParameterSendable
パラメータを渡すことができるタグです。

jp.co.intra_mart.framework.base.web.tag.attribute により使用される jp.co.intra_mart.framework.base.web.tag のクラス
TagWriter
タグの出力を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParameterSendable (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
インタフェース ParameterSendable

既知の実装クラスの一覧:
FrameTag, LinkTag
public interface ParameterSendable

パラメータを渡すことができるタグです。

バージョン:
1.0

メソッドの概要
 void addParameter(String name, String value)
パラメータを追加します。

メソッドの詳細

addParameter

public void addParameter(String name,
                         String value)
パラメータを追加します。

パラメータ:
name - パラメータ名
value - パラメータの値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ParamTag (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス ParamTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.ParamTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class ParamTag
extends BodyTagSupport

リンク先、遷移先に渡すパラメータを設定します。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
ParamTag()
ParamTagを新規に生成します。
メソッドの概要
int | doStartTag() 外側の一番近いParameterSendableにパラメータを設定します。
String | getName() パラメータ名を取得します。
String | getValue() パラメータの値を取得します。
void | setName(String name) パラメータ名を設定します。
void | setValue(String value) パラメータの値を設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doEndTag, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

ParamTag

public ParamTag()
ParamTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
外側の一番近いParameterSendableにパラメータを設定します。

戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - JSP出力時に例外が発生

getName

public String getName()
パラメータ名を取得します。

戻り値:
パラメータ名

setName

public void setName(String name)
パラメータ名を設定します。

パラメータ:
name - パラメータ名

getValue

public String getValue()
パラメータの値を取得します。

戻り値:
パラメータの値

setValue

public void setValue(String value)
パラメータの値を設定します。

パラメータ:
value - パラメータの値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SubmitLinkTag (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス SubmitLinkTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class SubmitLinkTag
extends BodyTagSupport

サブミット専用のLINKタグです。 im-J2EE Frameworkを使用する場合のセッションフレームワーク、サービスフレームワークの一部となります。

導入されたバージョン:
4.2
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
SubmitLinkTag()
SubmitLinkTagを新規に生成します。
メソッドの概要
int | doEndTag() 終了タグを検知したときにJSPエンジンから呼ばれます。
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getAccesskey() accesskeyを取得します。
String | getApplication() アプリケーションを取得します。
String | getCoords() coordsを取得します。
String | getDir() dirを取得します。
String | getForm() ターゲットとなるフォーム名を取得します。
String | getLang() langを取得します。
String | getLinkclass() linkClassを取得します。
String | getName() nameを取得します。
String | getOnblur() onblurを取得します。
String | getOnclick() 属性onClickの値を取得します。
String | getOndblclick() 属性onDblClickの値を取得します。
String | getOnfocus() onfocusを取得します。
String | getOnkeydown() 属性onKeyDownの値を取得します。
String | getOnkeypress() 属性onKeyPressの値を取得します。
String | getOnkeyup() 属性onKeyUpの値を取得します。
String | getOnmousedown() 属性onMouseDownの値を取得します。
String | getOnmousemove() 属性onMouseMoveの値を取得します。
String | getOnmouseout() 属性onMouseOutの値を取得します。
String | getOnmouseover() 属性onMouseOverの値を取得します。
String | getOnmouseup() 属性onMouseUpの値を取得します。
String | getService() サービスを取得します。
String | getShape() shapeを取得します。
String | getStyle() styleを取得します。
String | getTabindex() tabindexを取得します。
String | getTitle() titleを取得します。
void | setAccesskey(String accesskey) accesskeyを設定します。
void | setApplication(String application) アプリケーションを設定します。
void | setCoords(String coords) coordsを設定します。
void | setDir(String dir) dirを設定します。
void | setForm(String form) ターゲットとなるフォーム名を設定します。
void | setLang(String lang) langを設定します。
void | setLinkclass(String linkClass) linkClassを設定します。
void | setName(String name) nameを設定します。
void | setOnblur(String onblur) onblurを設定します。
void | setOnclick(String onClick) 属性onClickの値を設定します。
void | setOndblclick(String onDblClick) 属性obDblClickの値を設定します。
void | setOnfocus(String onfocus) onfocusを設定します。
void | setOnkeydown(String onKeyDown) 属性onKeyDownの値を設定します。
void | setOnkeypress(String onKeyPress) 属性onKeyPressの値を設定します。
void | setOnkeyup(String onKeyUp) 属性onKeyUpの値を設定します。
void | setOnmousedown(String onMouseDown) 属性onMouseDownの値を設定します。
void | setOnmousemove(String onMouseMove) 属性onMouseMoveの値を設定します。
void | setOnmouseout(String onMouseOut) 属性onMouseOutの値を設定します。
void | setOnmouseover(String onMouseOver) 属性onMouseOverの値を設定します。
void | setOnmouseup(String onMouseUp) 属性onMouseUpの値を設定します。
void | setService(String service) サービスを設定します。
void | setShape(String shape) shapeを設定します。
void | setStyle(String style) styleを設定します。
void | setTabindex(String tabindex) tabindexを設定します。
void | setTitle(String title) titleを設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

SubmitLinkTag

public SubmitLinkTag()
SubmitLinkTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 SUBMIT LINKタグを解釈します。

戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - タグの解釈時に例外が発生

doEndTag

public int doEndTag()
             throws JspException
終了タグを検知したときにJSPエンジンから呼ばれます。 SUBMIT LINKタグを終了します。

戻り値:
EVAL_PAGE
例外:
JspException - タグの終了時に例外が発生

getName

public String getName()
nameを取得します。

戻り値:
name

setName

public void setName(String name)
nameを設定します。

パラメータ:
name - name

getApplication

public String getApplication()
アプリケーションを取得します。

戻り値:
アプリケーション

setApplication

public void setApplication(String application)
アプリケーションを設定します。

パラメータ:
application - アプリケーション

getService

public String getService()
サービスを取得します。

戻り値:
サービス

setService

public void setService(String service)
サービスを設定します。

パラメータ:
service - サービス

getForm

public String getForm()
ターゲットとなるフォーム名を取得します。

戻り値:
ターゲットとなるフォーム名

setForm

public void setForm(String form)
ターゲットとなるフォーム名を設定します。

パラメータ:
form - ターゲットとなるフォーム名

getAccesskey

public String getAccesskey()
accesskeyを取得します。

戻り値:
accesskey

setAccesskey

public void setAccesskey(String accesskey)
accesskeyを設定します。

パラメータ:
accesskey - accesskey

getShape

public String getShape()
shapeを取得します。

戻り値:
shape

setShape

public void setShape(String shape)
shapeを設定します。

パラメータ:
shape - shape

getCoords

public String getCoords()
coordsを取得します。

戻り値:
coords

setCoords

public void setCoords(String coords)
coordsを設定します。

パラメータ:
coords - coords

getTabindex

public String getTabindex()
tabindexを取得します。

戻り値:
tabindex

setTabindex

public void setTabindex(String tabindex)
tabindexを設定します。

パラメータ:
tabindex - tabindex

getOnfocus

public String getOnfocus()
onfocusを取得します。

戻り値:
onfocus

setOnfocus

public void setOnfocus(String onfocus)
onfocusを設定します。

パラメータ:
onfocus - onfocus

getOnblur

public String getOnblur()
onblurを取得します。

戻り値:
onblur

setOnblur

public void setOnblur(String onblur)
onblurを設定します。

パラメータ:
onblur - onblur

getLinkclass

public String getLinkclass()
linkClassを取得します。

戻り値:
linkClass

setLinkclass

public void setLinkclass(String linkClass)
linkClassを設定します。

パラメータ:
linkClass - class

getStyle

public String getStyle()
styleを取得します。

戻り値:
style

setStyle

public void setStyle(String style)
styleを設定します。

パラメータ:
style - style

getTitle

public String getTitle()
titleを取得します。

戻り値:
title

setTitle

public void setTitle(String title)
titleを設定します。

パラメータ:
title - title

getLang

public String getLang()
langを取得します。

戻り値:
lang

setLang

public void setLang(String lang)
langを設定します。

パラメータ:
lang - lang

getDir

public String getDir()
dirを取得します。

戻り値:
dir

setDir

public void setDir(String dir)
dirを設定します。

パラメータ:
dir - dir

getOnclick

public String getOnclick()
属性onClickの値を取得します。

戻り値:
onClick

setOnclick

public void setOnclick(String onClick)
属性onClickの値を設定します。

パラメータ:
onClick - onClick

getOndblclick

public String getOndblclick()
属性onDblClickの値を取得します。

戻り値:
onDblClick

setOndblclick

public void setOndblclick(String onDblClick)
属性obDblClickの値を設定します。

パラメータ:
onDblClick - onDblClick

getOnmousedown

public String getOnmousedown()
属性onMouseDownの値を取得します。

戻り値:
onMouseDown

setOnmousedown

public void setOnmousedown(String onMouseDown)
属性onMouseDownの値を設定します。

パラメータ:
onMouseDown - onMouseDown

getOnmouseup

public String getOnmouseup()
属性onMouseUpの値を取得します。

戻り値:
onMouseUp

setOnmouseup

public void setOnmouseup(String onMouseUp)
属性onMouseUpの値を設定します。

パラメータ:
onMouseUp - onMouseUp

getOnmouseover

public String getOnmouseover()
属性onMouseOverの値を取得します。

戻り値:
onMouseOver

setOnmouseover

public void setOnmouseover(String onMouseOver)
属性onMouseOverの値を設定します。

パラメータ:
onMouseOver - onMouseOver

getOnmousemove

public String getOnmousemove()
属性onMouseMoveの値を取得します。

戻り値:
onMouseMove

setOnmousemove

public void setOnmousemove(String onMouseMove)
属性onMouseMoveの値を設定します。

パラメータ:
onMouseMove - onMouseMove

getOnmouseout

public String getOnmouseout()
属性onMouseOutの値を取得します。

戻り値:
onMouseOut

setOnmouseout

public void setOnmouseout(String onMouseOut)
属性onMouseOutの値を設定します。

パラメータ:
onMouseOut - onMouseOut

getOnkeypress

public String getOnkeypress()
属性onKeyPressの値を取得します。

戻り値:
onKeyPress

setOnkeypress

public void setOnkeypress(String onKeyPress)
属性onKeyPressの値を設定します。

パラメータ:
onKeyPress - onKeyPress

getOnkeydown

public String getOnkeydown()
属性onKeyDownの値を取得します。

戻り値:
onKeyDown

setOnkeydown

public void setOnkeydown(String onKeyDown)
属性onKeyDownの値を設定します。

パラメータ:
onKeyDown - onKeyDown

getOnkeyup

public String getOnkeyup()
属性onKeyUpの値を取得します。

戻り値:
onKeyUp

setOnkeyup

public void setOnkeyup(String onKeyUp)
属性onKeyUpの値を設定します。

パラメータ:
onKeyUp - onKeyUp
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SubmitLinkTagBeanInfo (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス SubmitLinkTagBeanInfo

java.lang.Object
    拡張 java.beans.SimpleBeanInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo
すべての実装インタフェース:
BeanInfo
public class SubmitLinkTagBeanInfo
extends SimpleBeanInfo

SubmitLinkTagのBeanInfoです。

導入されたバージョン:
4.2

フィールドの概要
インタフェース java.beans.BeanInfo から継承したフィールド
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
コンストラクタの概要
SubmitLinkTagBeanInfo()
SubmitLinkTagBeanInfoを新規に生成します。
メソッドの概要
 PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。
クラス java.beans.SimpleBeanInfo から継承したメソッド
getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, loadImage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SubmitLinkTagBeanInfo

public SubmitLinkTagBeanInfo()
SubmitLinkTagBeanInfoを新規に生成します。

メソッドの詳細

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。

戻り値:
PropertyDescriptor
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SubmitTag (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス SubmitTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.SubmitTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class SubmitTag
extends BodyTagSupport

Submitタグです。 intra-martフレームワークのFormタグ内でのみ使用できるタグです。

導入されたバージョン:
3.2
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
SubmitTag()
SubmitTagを新規に生成します。
メソッドの概要
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getApplication() 属性applicationの値を取得します。
String | getDir() 属性dirの値を取得します。
String | getLang() 属性langの値を取得します。
String | getName() 属性nameを取得します。
String | getOnblur() 属性onBlurを取得します。
String | getOnclick() 属性onClickの値を取得します。
String | getOndblclick() 属性onDblClickの値を取得します。
String | getOnfocus() 属性onFocusを取得します。
String | getOnkeydown() 属性onKeyDownの値を取得します。
String | getOnkeypress() 属性onKeyPressの値を取得します。
String | getOnkeyup() 属性onKeyUpの値を取得します。
String | getOnmousedown() 属性onMouseDownの値を取得します。
String | getOnmousemove() 属性onMouseMoveの値を取得します。
String | getOnmouseout() 属性onMouseOutの値を取得します。
String | getOnmouseover() 属性onMouseOverの値を取得します。
String | getOnmouseup() 属性onMouseUpの値を取得します。
String | getService() 属性serviceの値を取得します。
String | getStyle() 属性styleの値を取得します。
String | getSubmitclass() 属性classの値を取得します。
String | getTabindex() tabindexを取得します。
String | getTitle() 属性titleの値を取得します。
String | getValue() 属性valueを取得します。
void | setApplication(String application) 属性applicationの値を設定します。
void | setDir(String dir) 属性dirの値を設定します。
void | setLang(String lang) 属性langの値を設定します。
void | setName(String name) 属性nameを設定します。
void | setOnblur(String onBlur) 属性onBlurを設定します。
void | setOnclick(String onClick) 属性onClickの値を設定します。
void | setOndblclick(String onDblClick) 属性obDblClickの値を設定します。
void | setOnfocus(String onFocus) 属性onFocusを設定します。
void | setOnkeydown(String onKeyDown) 属性onKeyDownの値を設定します。
void | setOnkeypress(String onKeyPress) 属性onKeyPressの値を設定します。
void | setOnkeyup(String onKeyUp) 属性onKeyUpの値を設定します。
void | setOnmousedown(String onMouseDown) 属性onMouseDownの値を設定します。
void | setOnmousemove(String onMouseMove) 属性onMouseMoveの値を設定します。
void | setOnmouseout(String onMouseOut) 属性onMouseOutの値を設定します。
void | setOnmouseover(String onMouseOver) 属性onMouseOverの値を設定します。
void | setOnmouseup(String onMouseUp) 属性onMouseUpの値を設定します。
void | setService(String service) 属性serviceの値を設定します。
void | setStyle(String style) 属性styleの値を設定します。
void | setSubmitclass(String submitClass) 属性classの値を設定します。
void | setTabindex(String tabindex) tabindexを設定します。
void | setTitle(String title) 属性titleの値を設定します。
void | setValue(String value) 属性valueを設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doEndTag, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

SubmitTag

public SubmitTag()
SubmitTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 Submitタグを解釈します。

戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - JSP出力時に例外が発生

getApplication

public String getApplication()
属性applicationの値を取得します。

戻り値:
アプリケーション

setApplication

public void setApplication(String application)
属性applicationの値を設定します。

パラメータ:
application - アプリケーション

getService

public String getService()
属性serviceの値を取得します。

戻り値:
サービス

setService

public void setService(String service)
属性serviceの値を設定します。

パラメータ:
service - サービス

getName

public String getName()
属性nameを取得します。

戻り値:
name

setName

public void setName(String name)
属性nameを設定します。

パラメータ:
name - name

getValue

public String getValue()
属性valueを取得します。

戻り値:
value

setValue

public void setValue(String value)
属性valueを設定します。

パラメータ:
value - value

getTabindex

public String getTabindex()
tabindexを取得します。

戻り値:
tabindex

setTabindex

public void setTabindex(String tabindex)
tabindexを設定します。

パラメータ:
tabindex - tabindex

getOnfocus

public String getOnfocus()
属性onFocusを取得します。

戻り値:
onFocus

setOnfocus

public void setOnfocus(String onFocus)
属性onFocusを設定します。

パラメータ:
onFocus - onFocus

getOnblur

public String getOnblur()
属性onBlurを取得します。

戻り値:
onBlur

setOnblur

public void setOnblur(String onBlur)
属性onBlurを設定します。

パラメータ:
onBlur - onBlur

getSubmitclass

public String getSubmitclass()
属性classの値を取得します。

戻り値:
class

setSubmitclass

public void setSubmitclass(String submitClass)
属性classの値を設定します。

パラメータ:
submitClass - class

getStyle

public String getStyle()
属性styleの値を取得します。

戻り値:
style

setStyle

public void setStyle(String style)
属性styleの値を設定します。

パラメータ:
style - style

getTitle

public String getTitle()
属性titleの値を取得します。

戻り値:
title

setTitle

public void setTitle(String title)
属性titleの値を設定します。

パラメータ:
title - title

getLang

public String getLang()
属性langの値を取得します。

戻り値:
lang

setLang

public void setLang(String lang)
属性langの値を設定します。

パラメータ:
lang - lang

getDir

public String getDir()
属性dirの値を取得します。

戻り値:
dir

setDir

public void setDir(String dir)
属性dirの値を設定します。

パラメータ:
dir - dir

getOnclick

public String getOnclick()
属性onClickの値を取得します。

戻り値:
onClick

setOnclick

public void setOnclick(String onClick)
属性onClickの値を設定します。

パラメータ:
onClick - onClick

getOndblclick

public String getOndblclick()
属性onDblClickの値を取得します。

戻り値:
onDblClick

setOndblclick

public void setOndblclick(String onDblClick)
属性obDblClickの値を設定します。

パラメータ:
onDblClick - onDblClick

getOnmousedown

public String getOnmousedown()
属性onMouseDownの値を取得します。

戻り値:
onMouseDown

setOnmousedown

public void setOnmousedown(String onMouseDown)
属性onMouseDownの値を設定します。

パラメータ:
onMouseDown - onMouseDown

getOnmouseup

public String getOnmouseup()
属性onMouseUpの値を取得します。

戻り値:
onMouseUp

setOnmouseup

public void setOnmouseup(String onMouseUp)
属性onMouseUpの値を設定します。

パラメータ:
onMouseUp - onMouseUp

getOnmouseover

public String getOnmouseover()
属性onMouseOverの値を取得します。

戻り値:
onMouseOver

setOnmouseover

public void setOnmouseover(String onMouseOver)
属性onMouseOverの値を設定します。

パラメータ:
onMouseOver - onMouseOver

getOnmousemove

public String getOnmousemove()
属性onMouseMoveの値を取得します。

戻り値:
onMouseMove

setOnmousemove

public void setOnmousemove(String onMouseMove)
属性onMouseMoveの値を設定します。

パラメータ:
onMouseMove - onMouseMove

getOnmouseout

public String getOnmouseout()
属性onMouseOutの値を取得します。

戻り値:
onMouseOut

setOnmouseout

public void setOnmouseout(String onMouseOut)
属性onMouseOutの値を設定します。

パラメータ:
onMouseOut - onMouseOut

getOnkeypress

public String getOnkeypress()
属性onKeyPressの値を取得します。

戻り値:
onKeyPress

setOnkeypress

public void setOnkeypress(String onKeyPress)
属性onKeyPressの値を設定します。

パラメータ:
onKeyPress - onKeyPress

getOnkeydown

public String getOnkeydown()
属性onKeyDownの値を取得します。

戻り値:
onKeyDown

setOnkeydown

public void setOnkeydown(String onKeyDown)
属性onKeyDownの値を設定します。

パラメータ:
onKeyDown - onKeyDown

getOnkeyup

public String getOnkeyup()
属性onKeyUpの値を取得します。

戻り値:
onKeyUp

setOnkeyup

public void setOnkeyup(String onKeyUp)
属性onKeyUpの値を設定します。

パラメータ:
onKeyUp - onKeyUp
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SubmitTagBeanInfo (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス SubmitTagBeanInfo

java.lang.Object
    拡張 java.beans.SimpleBeanInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo
すべての実装インタフェース:
BeanInfo
public class SubmitTagBeanInfo
extends SimpleBeanInfo

SubmitTagのBeanInfoです。

導入されたバージョン:
4.0

フィールドの概要
インタフェース java.beans.BeanInfo から継承したフィールド
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
コンストラクタの概要
SubmitTagBeanInfo()
SubmitTagBeanInfoを新規に生成します。
メソッドの概要
 PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。
クラス java.beans.SimpleBeanInfo から継承したメソッド
getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, loadImage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SubmitTagBeanInfo

public SubmitTagBeanInfo()
SubmitTagBeanInfoを新規に生成します。

メソッドの詳細

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。

戻り値:
PropertyDescriptor
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SubmitTEI (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス SubmitTEI

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagExtraInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.SubmitTEI
public class SubmitTEI
extends TagExtraInfo

Submitタグの拡張情報です。

導入されたバージョン:
4.0

コンストラクタの概要
SubmitTEI()
SubmitTEIを新規に生成します。
メソッドの概要
 boolean isValid(TagData tagData)
Linkタグに指定された内容の正当性を検証します。
クラス javax.servlet.jsp.tagext.TagExtraInfo から継承したメソッド
getTagInfo, getVariableInfo, setTagInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SubmitTEI

public SubmitTEI()
SubmitTEIを新規に生成します。

メソッドの詳細

isValid

public boolean isValid(TagData tagData)
Linkタグに指定された内容の正当性を検証します。 検証内容は以下のとおりです。
  • class属性またはsubmitclass属性がある場合、いずれかのみが設定されている

パラメータ:
tagData - タグ情報
戻り値:
タグが正当な場合true、それ以外の場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TagWriter (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス TagWriter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.tag.TagWriter
public class TagWriter
extends Object

タグの出力を行います。

バージョン:
1.0

コンストラクタの概要
TagWriter(JspWriter writer)
TagWriterを新規に生成します。
メソッドの概要
static String | createURL(String url, Collection params) 推奨されていません。 このメソッドではなくcreateURL(String, Collection, String)を使用してください。
static String | createURL(String url, Collection params, String encoding) 複数のパラメータをURLに追加します。
void | printAttribute(String name, String value) 属性を出力します。
void | printURL(String url) URLを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

TagWriter

public TagWriter(JspWriter writer)
TagWriterを新規に生成します。

パラメータ:
writer - JSP出力子
メソッドの詳細

createURL

public static String createURL(String url,
                               Collection params)
                        throws IOException
推奨されていません。 このメソッドではなくcreateURL(String, Collection, String)を使用してください。

複数のパラメータをURLに追加します。 paramsはFrameworkTagParamの集合（java.util.Collection）である必要があります。

パラメータ:
url - 元のURL
params - 追加するパラメータ
戻り値:
パラメータが追加されたURL
例外:
IOException - 出力時に例外が発生

createURL

public static String createURL(String url,
                               Collection params,
                               String encoding)
                        throws IOException
複数のパラメータをURLに追加します。 paramsはFrameworkTagParamの集合（java.util.Collection）である必要があります。

パラメータ:
url - 元のURL
params - 追加するパラメータ
encoding - エンコーディング
戻り値:
パラメータが追加されたURL
例外:
IOException - 出力時に例外が発生
導入されたバージョン:
4.3

printURL

public void printURL(String url)
              throws IOException
URLを出力します。 このurlは<FORM>タグのaction属性、<A>タグのhref属性、<FRAME>タグのsrc属性などに定義するものと同じです。

パラメータ:
url - 出力するURL
例外:
IOException - 出力時に例外が発生

printAttribute

public void printAttribute(String name,
                           String value)
                    throws IOException
属性を出力します。 タグの属性として属性名="属性値"の形式で出力します。 属性値がnullまたは空文字列である場合、何も出力しません。

パラメータ:
name - 属性名
value - 属性値
例外:
IOException - 出力時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.base.web.util.HTMLEncoder の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.util.HTMLEncoder の使用

jp.co.intra_mart.framework.base.web.util.HTMLEncoder はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


HTMLEncoder (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.util
クラス HTMLEncoder

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.util.HTMLEncoder
public class HTMLEncoder
extends Object

文字列をHTML形式で表示するための変換を行うユーティリティクラスです。

バージョン:
1.0

コンストラクタの概要
HTMLEncoder()
メソッドの概要
static String | encodeCaption(String caption) キャプションを変換します。
static String | encodeValue(String value) <TEXTAREA>タグまたはvalue属性に入る文字列を変換します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTMLEncoder

public HTMLEncoder()
メソッドの詳細

encodeCaption

public static String encodeCaption(String caption)
キャプションを変換します。 HTML中で特殊な扱いを受ける文字（>,<等）を変換します。
ここでは以下の変換が行われます。
変換前 | 変換後
> &gt;
< &lt;
& &amp;
" &quot;
(半角空白) | &nbsp;
(改行)(*) | <BR>

(*)変換ルールは以下のとおりです。
"\n" -> "\n"
"\r" -> "\n"
ただし、"\r"と"\n"が連続して続く箇所は"\r\n" -> "\n"となります。

パラメータ:
caption - 変換前のキャプション
戻り値:
変換後のキャプション

encodeValue

public static String encodeValue(String value)
<TEXTAREA>タグまたはvalue属性に入る文字列を変換します。 ここでは以下の変換が行われます。
変換前 変換後
> &gt;
< &lt;
& &amp;
" &quot;

パラメータ:
value - 変換前の値
戻り値:
変換後の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.web.util (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.base.web.util
クラス
HTMLEncoder


jp.co.intra_mart.framework.base.web.util (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.util

Web上で使用するユーティリティのパッケージです。

参照:
説明

クラスの概要
HTMLEncoder 文字列をHTML形式で表示するための変換を行うユーティリティクラスです。

パッケージ jp.co.intra_mart.framework.base.web.util の説明

Web上で使用するユーティリティのパッケージです。


jp.co.intra_mart.framework.base.web.util クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.web.util.HTMLEncoder


パッケージ jp.co.intra_mart.framework.base.web.util の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.web.util の使用

jp.co.intra_mart.framework.base.web.util はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.system.container.IMContainer の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.container.IMContainer の使用

IMContainer を使用しているパッケージ
jp.co.intra_mart.framework.base.data.container
jp.co.intra_mart.framework.base.data.container.factory
jp.co.intra_mart.framework.base.event.container
jp.co.intra_mart.framework.base.event.container.factory
jp.co.intra_mart.framework.base.service.container
jp.co.intra_mart.framework.base.service.container.factory
jp.co.intra_mart.framework.system.container.factory

jp.co.intra_mart.framework.base.data.container での IMContainer の使用

jp.co.intra_mart.framework.base.data.container での IMContainer のサブインタフェース
 interface DataContainer
データコンテナのインターフェースです。

IMContainer を実装している jp.co.intra_mart.framework.base.data.container のクラス
 class DataContainerImpl
DataContainerの標準的な実装クラスです。

jp.co.intra_mart.framework.base.data.container.factory での IMContainer の使用

IMContainer を返す jp.co.intra_mart.framework.base.data.container.factory のメソッド
IMContainer | DefaultDataProvider.create() DataContainerを生成します。
IMContainer | DataContainerFactory.create() DataContainerを生成します。

jp.co.intra_mart.framework.base.event.container での IMContainer の使用

jp.co.intra_mart.framework.base.event.container での IMContainer のサブインタフェース
 interface EventContainer
イベントコンテナのインターフェースです。

IMContainer を実装している jp.co.intra_mart.framework.base.event.container のクラス
 class EventContainerImpl
EventContainerの標準的な実装クラスです。

jp.co.intra_mart.framework.base.event.container.factory での IMContainer の使用

IMContainer を返す jp.co.intra_mart.framework.base.event.container.factory のメソッド
IMContainer | EventContainerFactory.create() EventContainerを生成します。
IMContainer | DefaultEventProvider.create() EventContainerを生成します。

jp.co.intra_mart.framework.base.service.container での IMContainer の使用

jp.co.intra_mart.framework.base.service.container での IMContainer のサブインタフェース
 interface ServiceContainer
サービスコンテナのインターフェースです。

IMContainer を実装している jp.co.intra_mart.framework.base.service.container のクラス
 class ServiceContainerImpl
ServiceContainerの標準的な実装クラスです。

jp.co.intra_mart.framework.base.service.container.factory での IMContainer の使用

IMContainer を返す jp.co.intra_mart.framework.base.service.container.factory のメソッド
IMContainer | ServiceContainerFactory.create() ServiceContainerを生成します。
IMContainer | DefaultServiceProvider.create() ServiceContainerを生成します。

jp.co.intra_mart.framework.system.container.factory での IMContainer の使用

IMContainer を返す jp.co.intra_mart.framework.system.container.factory のメソッド
IMContainer | Provider.create() IMContainerを生成します
IMContainer | IMContainerFactory.create()

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.system.container.factory.IMContainerFactory の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.container.factory.IMContainerFactory の使用

IMContainerFactory を使用しているパッケージ
jp.co.intra_mart.framework.base.data.container.factory
jp.co.intra_mart.framework.base.event.container.factory
jp.co.intra_mart.framework.base.service.container.factory

jp.co.intra_mart.framework.base.data.container.factory での IMContainerFactory の使用

IMContainerFactory を実装している jp.co.intra_mart.framework.base.data.container.factory のクラス
 class DataContainerFactory
DataContainerのファクトリクラスです。

jp.co.intra_mart.framework.base.event.container.factory での IMContainerFactory の使用

IMContainerFactory を実装している jp.co.intra_mart.framework.base.event.container.factory のクラス
 class EventContainerFactory
EventContainerのファクトリクラスです。

jp.co.intra_mart.framework.base.service.container.factory での IMContainerFactory の使用

IMContainerFactory を実装している jp.co.intra_mart.framework.base.service.container.factory のクラス
 class ServiceContainerFactory
ServiceContainerのファクトリクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.system.container.factory.Provider の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.container.factory.Provider の使用

Provider を使用しているパッケージ
jp.co.intra_mart.framework.base.data.container.factory
jp.co.intra_mart.framework.base.event.container.factory
jp.co.intra_mart.framework.base.service.container.factory
jp.co.intra_mart.framework.system.container.factory

jp.co.intra_mart.framework.base.data.container.factory での Provider の使用

Provider を実装している jp.co.intra_mart.framework.base.data.container.factory のクラス
 class DefaultDataProvider
標準的なプロバイダーです。

Provider として宣言されている jp.co.intra_mart.framework.base.data.container.factory のフィールド
protected static Provider DataContainerFactory.provider

Provider を返す jp.co.intra_mart.framework.base.data.container.factory のメソッド
 Provider DataContainerFactory.getProvider()
プロバイダを返します。

Provider 型のパラメータを持つ jp.co.intra_mart.framework.base.data.container.factory のメソッド
 void DataContainerFactory.setProvider(Provider p)
プロバイダを設定します。

jp.co.intra_mart.framework.base.event.container.factory での Provider の使用

Provider を実装している jp.co.intra_mart.framework.base.event.container.factory のクラス
 class DefaultEventProvider
標準的なプロバイダーです。

Provider として宣言されている jp.co.intra_mart.framework.base.event.container.factory のフィールド
protected static Provider EventContainerFactory.provider

Provider を返す jp.co.intra_mart.framework.base.event.container.factory のメソッド
 Provider EventContainerFactory.getProvider()
プロバイダを返します。

Provider 型のパラメータを持つ jp.co.intra_mart.framework.base.event.container.factory のメソッド
 void EventContainerFactory.setProvider(Provider p)
プロバイダを設定します。

jp.co.intra_mart.framework.base.service.container.factory での Provider の使用

Provider を実装している jp.co.intra_mart.framework.base.service.container.factory のクラス
 class DefaultServiceProvider
標準的なプロバイダーです。

Provider として宣言されている jp.co.intra_mart.framework.base.service.container.factory のフィールド
protected  Provider ServiceContainerFactory.provider

Provider を返す jp.co.intra_mart.framework.base.service.container.factory のメソッド
 Provider ServiceContainerFactory.getProvider()
プロバイダを返します。

Provider 型のパラメータを持つ jp.co.intra_mart.framework.base.service.container.factory のメソッド
 void ServiceContainerFactory.setProvider(Provider p)
プロバイダを設定します。

jp.co.intra_mart.framework.system.container.factory での Provider の使用

Provider を返す jp.co.intra_mart.framework.system.container.factory のメソッド
 Provider IMContainerFactory.getProvider()

Provider 型のパラメータを持つ jp.co.intra_mart.framework.system.container.factory のメソッド
 void IMContainerFactory.setProvider(Provider p)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


IMContainerFactory (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.container.factory
インタフェース IMContainerFactory

既知の実装クラスの一覧:
DataContainerFactory, EventContainerFactory, ServiceContainerFactory
public interface IMContainerFactory

ServiceContainerのクラスです。

導入されたバージョン:
6.0

メソッドの概要
IMContainer | create()
Provider | getProvider()
void | setProvider(Provider p)

メソッドの詳細

create

public IMContainer create()
                   throws IMContainerException
例外:
IMContainerException

getProvider

public Provider getProvider()

setProvider

public void setProvider(Provider p)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.system.container.factory (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.system.container.factory
インタフェース
IMContainerFactory
Provider


jp.co.intra_mart.framework.system.container.factory (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.container.factory

インタフェースの概要
IMContainerFactory | ServiceContainerのクラスです。
Provider | IMContainerのファクトリクラスです。


jp.co.intra_mart.framework.system.container.factory クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.container.factory の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.framework.system.container.factory.IMContainerFactory
  • interface jp.co.intra_mart.framework.system.container.factory.Provider


パッケージ jp.co.intra_mart.framework.system.container.factory の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.system.container.factory の使用

jp.co.intra_mart.framework.system.container.factory を使用しているパッケージ
jp.co.intra_mart.framework.base.data.container.factory
jp.co.intra_mart.framework.base.event.container.factory
jp.co.intra_mart.framework.base.service.container.factory
jp.co.intra_mart.framework.system.container.factory

jp.co.intra_mart.framework.base.data.container.factory により使用される jp.co.intra_mart.framework.system.container.factory のクラス
IMContainerFactory
ServiceContainerのクラスです。
Provider
IMContainerのファクトリクラスです。

jp.co.intra_mart.framework.base.event.container.factory により使用される jp.co.intra_mart.framework.system.container.factory のクラス
IMContainerFactory
ServiceContainerのクラスです。
Provider
IMContainerのファクトリクラスです。

jp.co.intra_mart.framework.base.service.container.factory により使用される jp.co.intra_mart.framework.system.container.factory のクラス
IMContainerFactory
ServiceContainerのクラスです。
Provider
IMContainerのファクトリクラスです。

jp.co.intra_mart.framework.system.container.factory により使用される jp.co.intra_mart.framework.system.container.factory のクラス
Provider
IMContainerのファクトリクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Provider (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.container.factory
インタフェース Provider

既知の実装クラスの一覧:
DefaultDataProvider, DefaultEventProvider, DefaultServiceProvider
public interface Provider

IMContainerのファクトリクラスです。

導入されたバージョン:
6.0

メソッドの概要
 IMContainer create()
IMContainerを生成します

メソッドの詳細

create

public IMContainer create()
                   throws IMContainerException
IMContainerを生成します

戻り値:
IMContainer
例外:
IMContainerException - IMContainer生成時に例外が発生。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


IMContainer (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.container
インタフェース IMContainer

既知のサブインタフェースの一覧:
DataContainer, EventContainer, ServiceContainer
既知の実装クラスの一覧:
DataContainerImpl, EventContainerImpl, ServiceContainerImpl
public interface IMContainer

イントラマートコンテナのインターフェースです。

メソッドの概要
 void init()
IMContainerを初期化します。

メソッドの詳細

init

public void init()
          throws IMContainerException
IMContainerを初期化します。

例外:
IMContainerException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.system.container (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.system.container
インタフェース
IMContainer


jp.co.intra_mart.framework.system.container (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.container

インタフェースの概要
IMContainer イントラマートコンテナのインターフェースです。


jp.co.intra_mart.framework.system.container クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.container の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.framework.system.container.IMContainer


パッケージ jp.co.intra_mart.framework.system.container の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.system.container の使用

jp.co.intra_mart.framework.system.container を使用しているパッケージ
jp.co.intra_mart.framework.base.data.container
jp.co.intra_mart.framework.base.data.container.factory
jp.co.intra_mart.framework.base.event.container
jp.co.intra_mart.framework.base.event.container.factory
jp.co.intra_mart.framework.base.service.container
jp.co.intra_mart.framework.base.service.container.factory
jp.co.intra_mart.framework.system.container.factory

jp.co.intra_mart.framework.base.data.container により使用される jp.co.intra_mart.framework.system.container のクラス
IMContainer
イントラマートコンテナのインターフェースです。

jp.co.intra_mart.framework.base.data.container.factory により使用される jp.co.intra_mart.framework.system.container のクラス
IMContainer
イントラマートコンテナのインターフェースです。

jp.co.intra_mart.framework.base.event.container により使用される jp.co.intra_mart.framework.system.container のクラス
IMContainer
イントラマートコンテナのインターフェースです。

jp.co.intra_mart.framework.base.event.container.factory により使用される jp.co.intra_mart.framework.system.container のクラス
IMContainer
イントラマートコンテナのインターフェースです。

jp.co.intra_mart.framework.base.service.container により使用される jp.co.intra_mart.framework.system.container のクラス
IMContainer
イントラマートコンテナのインターフェースです。

jp.co.intra_mart.framework.base.service.container.factory により使用される jp.co.intra_mart.framework.system.container のクラス
IMContainer
イントラマートコンテナのインターフェースです。

jp.co.intra_mart.framework.system.container.factory により使用される jp.co.intra_mart.framework.system.container のクラス
IMContainer
イントラマートコンテナのインターフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.exception.ApplicationException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.exception.ApplicationException の使用

ApplicationException を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event.container |
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.validator | 検証に関連するパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での ApplicationException の使用

ApplicationException をスローする jp.co.intra_mart.framework.base.event のメソッド
EventResult | StandardEventListener.execute(Event event) 処理を実行します。
protected abstract EventResult | StandardEventListener.fire(Event event) イベントに対する処理です。
protected EventResult | StandardEventListener.dispatchEvent(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListenerAgentBean.execute(Event event) イベント処理を実行します。
protected abstract EventResult | StandardEJBEventListenerAgentBean.fire(Event event, DataAccessController dataAccessController) イベントに対する処理です。
EventResult | StandardEJBEventListenerAgent.execute(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListener.execute(Event event) 処理を実行します。
EventResult | GenericEventListener.execute(Event event) 処理を実行します。
EventResult | GenericEJBEventListenerLocal.execute(Event event) 処理を実行します。
EventResult | GenericEJBEventListenerAgentLocal.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListenerAgentBean.execute(Event event, String listenerName) イベント処理を実行します。
EventResult | GenericEJBEventListenerAgent.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListener.execute(Event event) 処理を実行します。
void | EventTriggerList.fireAll(Event event, DataAccessController controller) すべてのトリガに対してイベントの処理を行います。
void | EventTriggerAdapter.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
protected abstract void | EventTriggerAdapter.fire(Event event) イベントに対する処理を行います。
void | EventTrigger.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
EventResult | EventManager.dispatch(Event event) イベントに対する処理を実行します。
EventResult | EventManager.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventResult | EventListener.execute(Event event) 処理を実行します。
protected EventResult | EJBEventListenerAgentBean.dispatchEvent(Event event) イベント処理を実行します。
protected EventResult | EJBEventListener.dispatchEvent(Event event) イベント処理を実行します。

jp.co.intra_mart.framework.base.event.container での ApplicationException の使用

ApplicationException をスローする jp.co.intra_mart.framework.base.event.container のメソッド
EventResult | EventContainerImpl.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventResult | EventContainer.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。

jp.co.intra_mart.framework.base.service での ApplicationException の使用

jp.co.intra_mart.framework.base.service での ApplicationException のサブクラス
 class RequestException
リクエストの内容に関連する間違いがある場合の例外です。

ApplicationException をスローする jp.co.intra_mart.framework.base.service のメソッド
ServiceResult | ServiceControllerAdapter.service() 入力に対する処理を実行します。
protected EventResult | ServiceControllerAdapter.dispatchEvent(Event event) イベント処理を実行します。
ServiceResult | ServiceController.service() 入力に対する処理を実行します。

jp.co.intra_mart.framework.base.service.validator での ApplicationException の使用

jp.co.intra_mart.framework.base.service.validator での ApplicationException のサブクラス
 class ValidationException
検証結果が不正であるときの例外です。

jp.co.intra_mart.framework.base.web.bean での ApplicationException の使用

ApplicationException をスローする jp.co.intra_mart.framework.base.web.bean のメソッド
protected  EventResult HelperBean.dispatchEvent(Event event)
イベント処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.exception.FrameworkException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.exception.FrameworkException の使用

FrameworkException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.data.container |
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event.container |
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.container |
jp.co.intra_mart.framework.base.service.controller | 入力情報に関連するパッケージです。
jp.co.intra_mart.framework.base.service.validator | 検証に関連するパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.system.exception | J2EEフレームワークの例外に関連するパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.base.data での FrameworkException の使用

jp.co.intra_mart.framework.base.data での FrameworkException のサブクラス
class | DAOException リソースコネクタの情報取得時の例外です。
class | DataAccessException データアクセス時の例外です。
class | DataConnectException データ接続に関連する例外です。
class | DataConnectorException データコネクタ取得時の例外です。
class | DataManagerException データマネージャの設定時の例外です。
class | DataPropertyException データプロパティ取得時の例外です。

jp.co.intra_mart.framework.base.data.container での FrameworkException の使用

jp.co.intra_mart.framework.base.data.container での FrameworkException のサブクラス
 class DataContainerException
データコンテナ設定時の例外です。

jp.co.intra_mart.framework.base.event での FrameworkException の使用

jp.co.intra_mart.framework.base.event での FrameworkException のサブクラス
class | EventException イベント生成時の例外です。
class | EventListenerException イベントリスナ生成時の例外です。
class | EventManagerException イベントマネージャ設定時の例外です。
class | EventPropertyException イベントプロパティ取得時の例外です。
class | EventTriggerException イベントトリガ生成時の例外です。

jp.co.intra_mart.framework.base.event.container での FrameworkException の使用

jp.co.intra_mart.framework.base.event.container での FrameworkException のサブクラス
 class EventContainerException
イベントコンテナ設定時の例外です。

jp.co.intra_mart.framework.base.message での FrameworkException の使用

jp.co.intra_mart.framework.base.message での FrameworkException のサブクラス
class | MessageManagerException サービスマネージャ設定時の例外です。
class | MessagePropertyException メッセージプロパティ取得時の例外です。

jp.co.intra_mart.framework.base.service での FrameworkException の使用

jp.co.intra_mart.framework.base.service での FrameworkException のサブクラス
class | RequestException リクエストの内容に関連する間違いがある場合の例外です。
class | ServiceControllerException サービスコントローラに関連する例外です。
class | ServiceManagerException サービスマネージャ設定時の例外です。
class | ServicePropertyException サービスプロパティ取得時の例外です。
class | ServiceServletException サービスに関連する例外です。
class | TransitionException トランジションに関連する例外です。

jp.co.intra_mart.framework.base.service.container での FrameworkException の使用

jp.co.intra_mart.framework.base.service.container での FrameworkException のサブクラス
 class ServiceContainerException
サービスコンテナ設定時の例外です。

jp.co.intra_mart.framework.base.service.controller での FrameworkException の使用

jp.co.intra_mart.framework.base.service.controller での FrameworkException のサブクラス
class | ControllerConverterException ControllerConverterに関連する例外です。
class | RequestFormatException フォーマットが不正であるときの例外です。

jp.co.intra_mart.framework.base.service.validator での FrameworkException の使用

jp.co.intra_mart.framework.base.service.validator での FrameworkException のサブクラス
class | ValidationException 検証結果が不正であるときの例外です。
class | ValidatorException Validatorに関連する例外です。

jp.co.intra_mart.framework.base.session での FrameworkException の使用

jp.co.intra_mart.framework.base.session での FrameworkException のサブクラス
class | IllegalSessionException セッション情報取得の失敗や不正なセッションを検出した場合にスローされます。
class | SessionFactoryException セッションファクトリ内の例外です。
class | SessionManagerException セッションマネージャ内の例外です。
class | SessionObjectException セッションオブジェクト内の例外です。
class | SessionPropertyException セッションプロパティ取得時の例外です。

jp.co.intra_mart.framework.base.util での FrameworkException の使用

jp.co.intra_mart.framework.base.util での FrameworkException のサブクラス
 class UserInfoException
ユーザ情報に関連する例外です。

jp.co.intra_mart.framework.base.web.bean での FrameworkException の使用

jp.co.intra_mart.framework.base.web.bean での FrameworkException のサブクラス
 class HelperBeanException
HelperBean内で発生した例外です。

jp.co.intra_mart.framework.system.exception での FrameworkException の使用

jp.co.intra_mart.framework.system.exception での FrameworkException のサブクラス
class | ApplicationException フレームワーク内で発生したアプリケーション例外です。
class | IllegalSystemException 想定外の例外が発生したときの例外です。
class | IMContainerException イントラマートコンテナ内で発生した例外です。
class | SystemException フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.system.log での FrameworkException の使用

jp.co.intra_mart.framework.system.log での FrameworkException のサブクラス
 class LogPropertyException
ログプロパティ取得時の例外です。

jp.co.intra_mart.framework.system.property での FrameworkException の使用

jp.co.intra_mart.framework.system.property での FrameworkException のサブクラス
class | PropertyHandlerException プロパティハンドラの情報取得時の例外です。
class | PropertyManagerException プロパティマネージャの設定時の例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.exception.FrameworkRuntimeException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.exception.FrameworkRuntimeException の使用

jp.co.intra_mart.framework.system.exception.FrameworkRuntimeException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.exception.IllegalSystemException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.exception.IllegalSystemException の使用

jp.co.intra_mart.framework.system.exception.IllegalSystemException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.exception.IMContainerException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.exception.IMContainerException の使用

IMContainerException を使用しているパッケージ
jp.co.intra_mart.framework.base.data.container
jp.co.intra_mart.framework.base.data.container.factory
jp.co.intra_mart.framework.base.event.container
jp.co.intra_mart.framework.base.event.container.factory
jp.co.intra_mart.framework.base.service.container
jp.co.intra_mart.framework.base.service.container.factory
jp.co.intra_mart.framework.system.container
jp.co.intra_mart.framework.system.container.factory

jp.co.intra_mart.framework.base.data.container での IMContainerException の使用

IMContainerException をスローする jp.co.intra_mart.framework.base.data.container のメソッド
 void DataContainerImpl.init()
DataContainerを初期化します。

jp.co.intra_mart.framework.base.data.container.factory での IMContainerException の使用

IMContainerException をスローする jp.co.intra_mart.framework.base.data.container.factory のメソッド
IMContainer | DefaultDataProvider.create() DataContainerを生成します。
IMContainer | DataContainerFactory.create() DataContainerを生成します。

jp.co.intra_mart.framework.base.event.container での IMContainerException の使用

IMContainerException をスローする jp.co.intra_mart.framework.base.event.container のメソッド
 void EventContainerImpl.init()
EventContainerを初期化します。

jp.co.intra_mart.framework.base.event.container.factory での IMContainerException の使用

IMContainerException をスローする jp.co.intra_mart.framework.base.event.container.factory のメソッド
IMContainer | EventContainerFactory.create() EventContainerを生成します。
IMContainer | DefaultEventProvider.create() EventContainerを生成します。

jp.co.intra_mart.framework.base.service.container での IMContainerException の使用

IMContainerException をスローする jp.co.intra_mart.framework.base.service.container のメソッド
 void ServiceContainerImpl.init()
ServiceContainerを初期化します。

jp.co.intra_mart.framework.base.service.container.factory での IMContainerException の使用

IMContainerException をスローする jp.co.intra_mart.framework.base.service.container.factory のメソッド
IMContainer | ServiceContainerFactory.create() ServiceContainerを生成します。
IMContainer | DefaultServiceProvider.create() ServiceContainerを生成します。

jp.co.intra_mart.framework.system.container での IMContainerException の使用

IMContainerException をスローする jp.co.intra_mart.framework.system.container のメソッド
 void IMContainer.init()
IMContainerを初期化します。

jp.co.intra_mart.framework.system.container.factory での IMContainerException の使用

IMContainerException をスローする jp.co.intra_mart.framework.system.container.factory のメソッド
IMContainer | Provider.create() IMContainerを生成します
IMContainer | IMContainerFactory.create()

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.exception.SystemException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.exception.SystemException の使用

SystemException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.data.container |
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event.container |
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.container |
jp.co.intra_mart.framework.base.service.controller | 入力情報に関連するパッケージです。
jp.co.intra_mart.framework.base.service.validator | 検証に関連するパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.system.exception | J2EEフレームワークの例外に関連するパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.base.data での SystemException の使用

jp.co.intra_mart.framework.base.data での SystemException のサブクラス
class | DAOException リソースコネクタの情報取得時の例外です。
class | DataAccessException データアクセス時の例外です。
class | DataConnectException データ接続に関連する例外です。
class | DataConnectorException データコネクタ取得時の例外です。
class | DataManagerException データマネージャの設定時の例外です。
class | DataPropertyException データプロパティ取得時の例外です。

jp.co.intra_mart.framework.base.data.container での SystemException の使用

jp.co.intra_mart.framework.base.data.container での SystemException のサブクラス
 class DataContainerException
データコンテナ設定時の例外です。

jp.co.intra_mart.framework.base.event での SystemException の使用

jp.co.intra_mart.framework.base.event での SystemException のサブクラス
class | EventException イベント生成時の例外です。
class | EventListenerException イベントリスナ生成時の例外です。
class | EventManagerException イベントマネージャ設定時の例外です。
class | EventPropertyException イベントプロパティ取得時の例外です。
class | EventTriggerException イベントトリガ生成時の例外です。

SystemException をスローする jp.co.intra_mart.framework.base.event のメソッド
EventResult | StandardEventListener.execute(Event event) 処理を実行します。
protected abstract EventResult | StandardEventListener.fire(Event event) イベントに対する処理です。
protected EventResult | StandardEventListener.dispatchEvent(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListenerAgentBean.execute(Event event) イベント処理を実行します。
protected abstract EventResult | StandardEJBEventListenerAgentBean.fire(Event event, DataAccessController dataAccessController) イベントに対する処理です。
EventResult | StandardEJBEventListenerAgent.execute(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListener.execute(Event event) 処理を実行します。
EventResult | GenericEventListener.execute(Event event) 処理を実行します。
EventResult | GenericEJBEventListenerLocal.execute(Event event) 処理を実行します。
EventResult | GenericEJBEventListenerAgentLocal.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListenerAgentBean.execute(Event event, String listenerName) イベント処理を実行します。
EventResult | GenericEJBEventListenerAgent.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListener.execute(Event event) 処理を実行します。
void | EventTriggerList.fireAll(Event event, DataAccessController controller) すべてのトリガに対してイベントの処理を行います。
void | EventTriggerAdapter.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
protected abstract void | EventTriggerAdapter.fire(Event event) イベントに対する処理を行います。
void | EventTrigger.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
EventResult | EventManager.dispatch(Event event) イベントに対する処理を実行します。
EventResult | EventManager.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventResult | EventListener.execute(Event event) 処理を実行します。
protected EventResult | EJBEventListenerAgentBean.dispatchEvent(Event event) イベント処理を実行します。
protected EventResult | EJBEventListener.dispatchEvent(Event event) イベント処理を実行します。

jp.co.intra_mart.framework.base.event.container での SystemException の使用

jp.co.intra_mart.framework.base.event.container での SystemException のサブクラス
 class EventContainerException
イベントコンテナ設定時の例外です。

SystemException をスローする jp.co.intra_mart.framework.base.event.container のメソッド
EventResult | EventContainerImpl.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventResult | EventContainer.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。

jp.co.intra_mart.framework.base.message での SystemException の使用

jp.co.intra_mart.framework.base.message での SystemException のサブクラス
class | MessageManagerException サービスマネージャ設定時の例外です。
class | MessagePropertyException メッセージプロパティ取得時の例外です。

jp.co.intra_mart.framework.base.service での SystemException の使用

jp.co.intra_mart.framework.base.service での SystemException のサブクラス
class | ServiceControllerException サービスコントローラに関連する例外です。
class | ServiceManagerException サービスマネージャ設定時の例外です。
class | ServicePropertyException サービスプロパティ取得時の例外です。
class | ServiceServletException サービスに関連する例外です。
class | TransitionException トランジションに関連する例外です。

SystemException をスローする jp.co.intra_mart.framework.base.service のメソッド
jp.co.intra_mart.foundation.http.MultipartFormData.Entity | Transition.getEntity(String name) リクエストから指定された名前に該当するエンティティを取得します。
abstract void | Transition.transfer() 次のページに遷移します。
jp.co.intra_mart.foundation.http.MultipartFormData.Entity | ServiceControllerAdapter.getEntity(String name) リクエストから指定された名前に該当するエンティティを取得します。
void | ServiceControllerAdapter.check() 入力内容をチェックします。
ServiceResult | ServiceControllerAdapter.service() 入力に対する処理を実行します。
protected EventResult | ServiceControllerAdapter.dispatchEvent(Event event) イベント処理を実行します。
void | ServiceController.check() 入力内容をチェックします。
ServiceResult | ServiceController.service() 入力に対する処理を実行します。
void | IntramartPageBaseTransition.transfer() ページベースの画面に遷移します。
void | DefaultTransition.transfer() 次のページに遷移します。

jp.co.intra_mart.framework.base.service.container での SystemException の使用

jp.co.intra_mart.framework.base.service.container での SystemException のサブクラス
 class ServiceContainerException
サービスコンテナ設定時の例外です。

jp.co.intra_mart.framework.base.service.controller での SystemException の使用

jp.co.intra_mart.framework.base.service.controller での SystemException のサブクラス
class | ControllerConverterException ControllerConverterに関連する例外です。
class | RequestFormatException フォーマットが不正であるときの例外です。

jp.co.intra_mart.framework.base.service.validator での SystemException の使用

jp.co.intra_mart.framework.base.service.validator での SystemException のサブクラス
 class ValidatorException
Validatorに関連する例外です。

jp.co.intra_mart.framework.base.session での SystemException の使用

jp.co.intra_mart.framework.base.session での SystemException のサブクラス
class | IllegalSessionException セッション情報取得の失敗や不正なセッションを検出した場合にスローされます。
class | SessionFactoryException セッションファクトリ内の例外です。
class | SessionManagerException セッションマネージャ内の例外です。
class | SessionObjectException セッションオブジェクト内の例外です。
class | SessionPropertyException セッションプロパティ取得時の例外です。

jp.co.intra_mart.framework.base.util での SystemException の使用

jp.co.intra_mart.framework.base.util での SystemException のサブクラス
 class UserInfoException
ユーザ情報に関連する例外です。

jp.co.intra_mart.framework.base.web.bean での SystemException の使用

jp.co.intra_mart.framework.base.web.bean での SystemException のサブクラス
 class HelperBeanException
HelperBean内で発生した例外です。

SystemException をスローする jp.co.intra_mart.framework.base.web.bean のメソッド
protected  EventResult HelperBean.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.system.exception での SystemException の使用

jp.co.intra_mart.framework.system.exception での SystemException のサブクラス
class | IllegalSystemException 想定外の例外が発生したときの例外です。
class | IMContainerException イントラマートコンテナ内で発生した例外です。

jp.co.intra_mart.framework.system.log での SystemException の使用

jp.co.intra_mart.framework.system.log での SystemException のサブクラス
 class LogPropertyException
ログプロパティ取得時の例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ApplicationException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.exception
クラス ApplicationException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.ApplicationException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
RequestException
public class ApplicationException
extends FrameworkException

フレームワーク内で発生したアプリケーション例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ApplicationException()
詳細メッセージを指定しないで ApplicationException を構築します。
ApplicationException(String msg)
指定された詳細メッセージを持つ ApplicationException を構築します。
ApplicationException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ApplicationException を構築します。
ApplicationException(Throwable throwable)
この例外の発生原因となる例外を持つ ApplicationException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ApplicationException

public ApplicationException()
詳細メッセージを指定しないで ApplicationException を構築します。

ApplicationException

public ApplicationException(String msg)
指定された詳細メッセージを持つ ApplicationException を構築します。

パラメータ:
msg - 詳細メッセージ

ApplicationException

public ApplicationException(Throwable throwable)
この例外の発生原因となる例外を持つ ApplicationException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外

ApplicationException

public ApplicationException(String msg,
                            Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ApplicationException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


FrameworkException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.exception
クラス FrameworkException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ApplicationException, PropertyHandlerException, PropertyManagerException, SystemException
public class FrameworkException
extends Exception

フレームワークに共通するの例外のスーパークラスです。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
FrameworkException()
詳細メッセージを指定しないで FrameworkException を構築します。
FrameworkException(String msg)
指定された詳細メッセージを持つ FrameworkException を構築します。
FrameworkException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkException を構築します。
FrameworkException(Throwable throwable)
この例外の発生原因となる例外を持つ FrameworkException を構築します。
メソッドの概要
Throwable | getException() この例外が発生した原因となる例外を取得します。
void | printStackTrace()
void | printStackTrace(PrintStream printStream)
void | printStackTrace(PrintWriter printWriter)
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

FrameworkException

public FrameworkException()
詳細メッセージを指定しないで FrameworkException を構築します。

FrameworkException

public FrameworkException(String msg)
指定された詳細メッセージを持つ FrameworkException を構築します。

パラメータ:
msg - 詳細メッセージ

FrameworkException

public FrameworkException(Throwable throwable)
この例外の発生原因となる例外を持つ FrameworkException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外

FrameworkException

public FrameworkException(String msg,
                          Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
メソッドの詳細

getException

public Throwable getException()
この例外が発生した原因となる例外を取得します。

戻り値:
この例外が発生した原因となる例外

printStackTrace

public void printStackTrace()

printStackTrace

public void printStackTrace(PrintStream printStream)

printStackTrace

public void printStackTrace(PrintWriter printWriter)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FrameworkRuntimeException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.exception
クラス FrameworkRuntimeException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.framework.system.exception.FrameworkRuntimeException
すべての実装インタフェース:
Serializable
public class FrameworkRuntimeException
extends RuntimeException

フレームワーク内で発生したランタイム例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
FrameworkRuntimeException()
詳細メッセージを指定しないで FrameworkRuntimeException を構築します。
FrameworkRuntimeException(String msg)
指定された詳細メッセージを持つ FrameworkRuntimeException を構築します。
FrameworkRuntimeException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkRuntimeException を構築します。
FrameworkRuntimeException(Throwable throwable)
この例外の発生原因となる例外を持つ FrameworkRuntimeException を構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

FrameworkRuntimeException

public FrameworkRuntimeException()
詳細メッセージを指定しないで FrameworkRuntimeException を構築します。

FrameworkRuntimeException

public FrameworkRuntimeException(String msg)
指定された詳細メッセージを持つ FrameworkRuntimeException を構築します。

パラメータ:
msg - 詳細メッセージ

FrameworkRuntimeException

public FrameworkRuntimeException(Throwable throwable)
この例外の発生原因となる例外を持つ FrameworkRuntimeException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外

FrameworkRuntimeException

public FrameworkRuntimeException(String msg,
                                 Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkRuntimeException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IllegalSystemException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.exception
クラス IllegalSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.system.exception.IllegalSystemException
すべての実装インタフェース:
Serializable
public class IllegalSystemException
extends SystemException

想定外の例外が発生したときの例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
IllegalSystemException()
詳細メッセージを指定しないで IllegalSystemException を構築します。
IllegalSystemException(String msg)
指定された詳細メッセージを持つ IllegalSystemException を構築します。
IllegalSystemException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IllegalSystemException を構築します。
IllegalSystemException(Throwable throwable)
この例外の発生原因となる例外を持つ IllegalSystemException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalSystemException

public IllegalSystemException()
詳細メッセージを指定しないで IllegalSystemException を構築します。

IllegalSystemException

public IllegalSystemException(String msg)
指定された詳細メッセージを持つ IllegalSystemException を構築します。

パラメータ:
msg - 詳細メッセージ

IllegalSystemException

public IllegalSystemException(Throwable throwable)
この例外の発生原因となる例外を持つ IllegalSystemException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外

IllegalSystemException

public IllegalSystemException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IllegalSystemException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IMContainerException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.exception
クラス IMContainerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.system.exception.IMContainerException
すべての実装インタフェース:
Serializable
public class IMContainerException
extends SystemException

イントラマートコンテナ内で発生した例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
IMContainerException()
詳細メッセージを指定しないで IMContainerException を構築します。
IMContainerException(String msg)
指定された詳細メッセージを持つ IMContainerException を構築します。
IMContainerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IMContainerException を構築します。
IMContainerException(Throwable throwable)
この例外の発生原因となる例外を持つ IMContainerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IMContainerException

public IMContainerException()
詳細メッセージを指定しないで IMContainerException を構築します。

IMContainerException

public IMContainerException(String msg)
指定された詳細メッセージを持つ IMContainerException を構築します。

パラメータ:
msg - 詳細メッセージ

IMContainerException

public IMContainerException(Throwable throwable)
この例外の発生原因となる例外を持つ IMContainerException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外

IMContainerException

public IMContainerException(String msg,
                            Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IMContainerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.system.exception (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.system.exception
例外
ApplicationException
FrameworkException
FrameworkRuntimeException
IllegalSystemException
IMContainerException
SystemException


jp.co.intra_mart.framework.system.exception (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.exception

J2EEフレームワークの例外に関連するパッケージです。

参照:
説明

例外の概要
ApplicationException | フレームワーク内で発生したアプリケーション例外です。
FrameworkException | フレームワークに共通するの例外のスーパークラスです。
FrameworkRuntimeException | フレームワーク内で発生したランタイム例外です。
IllegalSystemException | 想定外の例外が発生したときの例外です。
IMContainerException | イントラマートコンテナ内で発生した例外です。
SystemException | フレームワーク内で発生したシステム例外です。

パッケージ jp.co.intra_mart.framework.system.exception の説明

J2EEフレームワークの例外に関連するパッケージです。


jp.co.intra_mart.framework.system.exception クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.ApplicationException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.system.exception.IllegalSystemException
            • class jp.co.intra_mart.framework.system.exception.IMContainerException
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.framework.system.exception.FrameworkRuntimeException


パッケージ jp.co.intra_mart.framework.system.exception の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.system.exception の使用

jp.co.intra_mart.framework.system.exception を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.data.container |
jp.co.intra_mart.framework.base.data.container.factory |
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event.container |
jp.co.intra_mart.framework.base.event.container.factory |
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.container |
jp.co.intra_mart.framework.base.service.container.factory |
jp.co.intra_mart.framework.base.service.controller | 入力情報に関連するパッケージです。
jp.co.intra_mart.framework.base.service.validator | 検証に関連するパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.system.container |
jp.co.intra_mart.framework.system.container.factory |
jp.co.intra_mart.framework.system.exception | J2EEフレームワークの例外に関連するパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.base.data により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.data.container により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
IMContainerException
イントラマートコンテナ内で発生した例外です。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.data.container.factory により使用される jp.co.intra_mart.framework.system.exception のクラス
IMContainerException
イントラマートコンテナ内で発生した例外です。

jp.co.intra_mart.framework.base.event により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.event.container により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
IMContainerException
イントラマートコンテナ内で発生した例外です。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.event.container.factory により使用される jp.co.intra_mart.framework.system.exception のクラス
IMContainerException
イントラマートコンテナ内で発生した例外です。

jp.co.intra_mart.framework.base.message により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.service.container により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
IMContainerException
イントラマートコンテナ内で発生した例外です。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.service.container.factory により使用される jp.co.intra_mart.framework.system.exception のクラス
IMContainerException
イントラマートコンテナ内で発生した例外です。

jp.co.intra_mart.framework.base.service.controller により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.service.validator により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.session により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.util により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.web.bean により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.system.container により使用される jp.co.intra_mart.framework.system.exception のクラス
IMContainerException
イントラマートコンテナ内で発生した例外です。

jp.co.intra_mart.framework.system.container.factory により使用される jp.co.intra_mart.framework.system.exception のクラス
IMContainerException
イントラマートコンテナ内で発生した例外です。

jp.co.intra_mart.framework.system.exception により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.system.log により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.system.property により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SystemException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.exception
クラス SystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ControllerConverterException, DAOException, DataAccessException, DataConnectException, DataConnectorException, DataContainerException, DataManagerException, DataPropertyException, EventContainerException, EventException, EventListenerException, EventManagerException, EventPropertyException, EventTriggerException, HelperBeanException, IllegalSessionException, IllegalSystemException, IMContainerException, LogPropertyException, MessageManagerException, MessageManagerException, MessagePropertyException, MessagePropertyException, RequestFormatException, ServiceContainerException, ServiceControllerException, ServiceManagerException, ServicePropertyException, ServiceServletException, SessionFactoryException, SessionManagerException, SessionObjectException, SessionPropertyException, TransitionException, UserInfoException, ValidatorException
public class SystemException
extends FrameworkException

フレームワーク内で発生したシステム例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SystemException()
詳細メッセージを指定しないで SystemException を構築します。
SystemException(String msg)
指定された詳細メッセージを持つ SystemException を構築します。
SystemException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SystemException を構築します。
SystemException(Throwable throwable)
この例外の発生原因となる例外を持つ SystemException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SystemException

public SystemException()
詳細メッセージを指定しないで SystemException を構築します。

SystemException

public SystemException(String msg)
指定された詳細メッセージを持つ SystemException を構築します。

パラメータ:
msg - 詳細メッセージ

SystemException

public SystemException(Throwable throwable)
この例外の発生原因となる例外を持つ SystemException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外

SystemException

public SystemException(String msg,
                       Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SystemException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.system.log.DefaultLogAgent の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.DefaultLogAgent の使用

jp.co.intra_mart.framework.system.log.DefaultLogAgent はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler の使用

jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.log.IntramartLogAgent の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.IntramartLogAgent の使用

jp.co.intra_mart.framework.system.log.IntramartLogAgent はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.system.log.LogAgent の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.log.LogAgent の使用

LogAgent を使用しているパッケージ
jp.co.intra_mart.framework.system.log J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.system.log での LogAgent の使用

LogAgent を実装している jp.co.intra_mart.framework.system.log のクラス
class | DefaultLogAgent デフォルトのログエージェントです。
class | IntramartLogAgent intra-mart で管理されているログに出力するログエージェントです。

LogAgent を返す jp.co.intra_mart.framework.system.log のメソッド
 LogAgent LogManager.getLogAgent()
ログエージェントを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.log.LogAgentParam の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.LogAgentParam の使用

LogAgentParam を使用しているパッケージ
jp.co.intra_mart.framework.system.log J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.system.log での LogAgentParam の使用

LogAgentParam を返す jp.co.intra_mart.framework.system.log のメソッド
LogAgentParam[] | XmlLogPropertyHandler.getLogAgentParams() ログエージェントのパラメータを取得します。
LogAgentParam[] | LogPropertyHandler.getLogAgentParams() ログエージェントのパラメータを取得します。
LogAgentParam[] | DefaultLogPropertyHandler.getLogAgentParams() ログエージェントのパラメータを取得します。

LogAgentParam 型のパラメータを持つ jp.co.intra_mart.framework.system.log のメソッド
void | LogAgent.init(LogAgentParam[] params) 初期化します。
void | IntramartLogAgent.init(LogAgentParam[] params) 初期化します。
void | DefaultLogAgent.init(LogAgentParam[] params) 初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.system.log.LogConstant の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.log.LogConstant の使用

jp.co.intra_mart.framework.system.log.LogConstant はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.log.LogManager の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.LogManager の使用

LogManager を使用しているパッケージ
jp.co.intra_mart.framework.system.log J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.system.log での LogManager の使用

LogManager を返す jp.co.intra_mart.framework.system.log のメソッド
static LogManager LogManager.getLogManager()
ログマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.log.LogPropertyException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.LogPropertyException の使用

LogPropertyException を使用しているパッケージ
jp.co.intra_mart.framework.system.log J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.system.log での LogPropertyException の使用

LogPropertyException をスローする jp.co.intra_mart.framework.system.log のメソッド
String | XmlLogPropertyHandler.getLogAgentName() ログエージェントのクラス名を取得します。
LogAgentParam[] | XmlLogPropertyHandler.getLogAgentParams() ログエージェントのパラメータを取得します。
String | LogPropertyHandler.getLogAgentName() ログエージェントのクラス名を取得します。
LogAgentParam[] | LogPropertyHandler.getLogAgentParams() ログエージェントのパラメータを取得します。
String | DefaultLogPropertyHandler.getLogAgentName() ログエージェントのクラス名を取得します。
LogAgentParam[] | DefaultLogPropertyHandler.getLogAgentParams() ログエージェントのパラメータを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.system.log.LogPropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.log.LogPropertyHandler の使用

LogPropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.system.log J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.system.log での LogPropertyHandler の使用

LogPropertyHandler を実装している jp.co.intra_mart.framework.system.log のクラス
class | DefaultLogPropertyHandler ログに関連するデフォルトのプロパティハンドラです。
class | XmlLogPropertyHandler リソースからログプロパティ情報を取得するプロパティハンドラです。

LogPropertyHandler を返す jp.co.intra_mart.framework.system.log のメソッド
 LogPropertyHandler LogManager.getLogPropertyHandler()
ログプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler の使用

jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DefaultLogAgent (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス DefaultLogAgent

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.log.DefaultLogAgent
すべての実装インタフェース:
LogAgent
public class DefaultLogAgent
extends Object
implements LogAgent

デフォルトのログエージェントです。 標準出力にログを出力します。 出力されるメッセージは以下のような形式になります。
[カテゴリ][レベル]メッセージ

導入されたバージョン:
4.2

コンストラクタの概要
DefaultLogAgent()

メソッドの概要
void | init(LogAgentParam[] params) 初期化します。
void | sendMessage(String category, String level, String message) メッセージを出力します。
void | sendMessage(String category, String level, String message, Object detail) メッセージを出力します。

クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DefaultLogAgent

public DefaultLogAgent()
メソッドの詳細

init

public void init(LogAgentParam[] params)
初期化します。 このクラスでは実際には何も行われません。

定義:
インタフェース LogAgent 内の init
パラメータ:
params - ログエージェントのパラメータ

sendMessage

public void sendMessage(String category,
                        String level,
                        String message)
メッセージを出力します。 このクラスでは通常、messageを標準出力にログとして出力します。 ただし、levelがLogConstant.LEVEL_ERRORである場合は 標準例外出力にログを出力します。

定義:
インタフェース LogAgent 内の sendMessage
パラメータ:
category - ログのカテゴリ
level - メッセージのレベル
message - メッセージ

sendMessage

public void sendMessage(String category,
                        String level,
                        String message,
                        Object detail)
メッセージを出力します。 このクラスでは通常、messageはそのまま、 detailはObject.toString()の値を標準出力にログとして出力します。 ただし、levelがLogConstant.LEVEL_ERRORである場合は 標準例外出力にログを出力します。

detailがThrowableのサブクラスである場合、 Throwable.printStackTrace(java.io.PrintWriter)を使用して スタックトレースが出力されます。出力先はdetailによる出力先に従います。

定義:
インタフェース LogAgent 内の sendMessage
パラメータ:
category - ログのカテゴリ
level - メッセージのレベル
message - メッセージ
detail - 詳細
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart 6.1.14
 前のクラス   次のクラス | フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド | 詳細:  フィールド | コンストラクタ | メソッド


DefaultLogPropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス DefaultLogPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler
すべての実装インタフェース:
LogPropertyHandler, PropertyHandler
public class DefaultLogPropertyHandler
extends Object
implements LogPropertyHandler

ログに関連するデフォルトのプロパティハンドラです。 プロパティの設定内容は以下のとおりです。

キー | 内容
agent.class | LogAgentのクラス名
agent.param.パラメータ名 | ログエージェントに渡すパラメータ

導入されたバージョン:
4.2

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
コンストラクタの概要
DefaultLogPropertyHandler()
DefaultLogPropertyHandlerを新規に生成します。
メソッドの概要
String | getLogAgentName() ログエージェントのクラス名を取得します。
LogAgentParam[] | getLogAgentParams() ログエージェントのパラメータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultLogPropertyHandler

public DefaultLogPropertyHandler()
DefaultLogPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

getLogAgentName

public String getLogAgentName()
                       throws LogPropertyException
ログエージェントのクラス名を取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース LogPropertyHandler 内の getLogAgentName
戻り値:
ログエージェントのクラス名（設定されていない場合null）
例外:
LogPropertyException - ログエージェントのクラス名の取得時に例外が発生

getLogAgentParams

public LogAgentParam[] getLogAgentParams()
                                  throws LogPropertyException
ログエージェントのパラメータを取得します。 何も設定されていない場合大きさが0の配列が返ります。

定義:
インタフェース LogPropertyHandler 内の getLogAgentParams
戻り値:
ログエージェントのパラメータの配列
例外:
LogPropertyException - ログエージェントのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartLogAgent (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス IntramartLogAgent

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.log.IntramartLogAgent
すべての実装インタフェース:
LogAgent
public class IntramartLogAgent
extends Object
implements LogAgent

intra-mart で管理されているログに出力するログエージェントです。 出力先は intra-mart の設定に依存します。 出力されるメッセージは以下のような形式になります。
[レベル]メッセージ
init(LogAgentParam[])に渡すパラメータは以下のように解釈されます。

パラメータ名 | パラメータの値
カテゴリ | カテゴリの種類

カテゴリの種類にTYPE_DBの値を指定するとデータベースログとして出力されます。

導入されたバージョン:
4.2

フィールドの概要
static String TYPE_DB
          データベースログに出力する場合のカテゴリの種類

コンストラクタの概要
IntramartLogAgent()
          IntramartLogAgentを新規に生成します。

メソッドの概要
void | init(LogAgentParam[] params) 初期化します。
void | sendMessage(String category, String level, String message) メッセージを出力します。
void | sendMessage(String category, String level, String message, Object detail) メッセージを出力します。

クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

TYPE_DB

public static final String TYPE_DB
データベースログに出力する場合のカテゴリの種類

関連項目:
定数フィールド値
コンストラクタの詳細

IntramartLogAgent

public IntramartLogAgent()
IntramartLogAgentを新規に生成します。

メソッドの詳細

init

public void init(LogAgentParam[] params)
初期化します。 パラメータで指定されたカテゴリを登録します。

定義:
インタフェース LogAgent 内の init
パラメータ:
params - ログエージェントのパラメータ

sendMessage

public void sendMessage(String category,
                        String level,
                        String message)
メッセージを出力します。 levelがLogConstant.LEVEL_ERROR以外の場合はメッセージをintra-martのシステムログとして出力します。 levelがLogConstant.LEVEL_ERRORである場合、 categoryをもとに取得されるカテゴリの種類によって以下のようにさらに出力先が分かれます。
  • カテゴリの種類がTYPE_DBである場合、データベースログとして出力
  • カテゴリの種類がTYPE_DB以外である場合、エラーログとして出力

定義:
インタフェース LogAgent 内の sendMessage
パラメータ:
category - ログのカテゴリ
level - メッセージのレベル
message - メッセージ

sendMessage

public void sendMessage(String category,
                        String level,
                        String message,
                        Object detail)
メッセージを出力します。 levelがLogConstant.LEVEL_ERROR以外の場合はメッセージをintra-martのシステムログとして出力します。 levelがLogConstant.LEVEL_ERRORである場合、以下のように出力先が異なります。
  • detailがThrowableのインスタンスであり
    • カテゴリがDBに関連するものはデータベースログとして出力
    • カテゴリがDBに関連するもの以外であるときはエラーログとして出力
  • detailがThrowable以外のインスタンスであり
    • 詳細文字列が存在し
      • カテゴリの種類がTYPE_DBである場合データベースログとして詳細ごと出力
      • カテゴリの種類がTYPE_DB以外であるときはエラーログとして詳細ごと出力
    • 詳細文字列が存在しないで
      • カテゴリがDBに関連するものはデータベースログとして詳細なしで出力
      • カテゴリがDBに関連するもの以外であるときはエラーログとして詳細なしで出力

定義:
インタフェース LogAgent 内の sendMessage
パラメータ:
category - ログのカテゴリ
level - メッセージのレベル
message - メッセージ
detail - 詳細
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart 6.1.14
 前のクラス   次のクラス フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド 詳細:  フィールド | コンストラクタ | メソッド


LogAgent (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
インタフェース LogAgent

既知の実装クラスの一覧:
DefaultLogAgent, IntramartLogAgent
public interface LogAgent

ログに出力するエージェントです。 im-J2EE Framework から出るログの出力先を変更したい場合、 このインタフェースを実装したクラスを設定します。

導入されたバージョン:
4.2

メソッドの概要
void | init(LogAgentParam[] params) 初期化します。
void | sendMessage(String category, String level, String message) メッセージを出力します。
void | sendMessage(String category, String level, String message, Object detail) メッセージを出力します。

メソッドの詳細

init

public void init(LogAgentParam[] params)
初期化します。

パラメータ:
params - ログエージェントのパラメータ

sendMessage

public void sendMessage(String category,
                        String level,
                        String message)
メッセージを出力します。

パラメータ:
category - ログのカテゴリ
level - メッセージのレベル
message - メッセージ

sendMessage

public void sendMessage(String category,
                        String level,
                        String message,
                        Object detail)
メッセージを出力します。 詳細な情報が添付されたメッセージを出力します。

パラメータ:
category - ログのカテゴリ
level - メッセージのレベル
message - メッセージ
detail - 詳細
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LogAgentParam (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス LogAgentParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
        拡張 jp.co.intra_mart.framework.system.log.LogAgentParam
public class LogAgentParam
extends PropertyParam

ログエージェントの初期パラメータです。

導入されたバージョン:
4.2

コンストラクタの概要
LogAgentParam()
LogAgentParamを新規に生成します。
クラス jp.co.intra_mart.framework.system.property.PropertyParam から継承したメソッド
getName, getValue, setName, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LogAgentParam

public LogAgentParam()
LogAgentParamを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LogConstant (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
インタフェース LogConstant

public interface LogConstant

ログフレームワークで使用される定数値です。

導入されたバージョン:
4.2

フィールドの概要
static String | CATEGORY_BEGIN_TRANSACTION トランザクションを開始するタイプです。
static String | CATEGORY_COMMIT_TRANSACTION トランザクションをコミットするタイプです。
static String | CATEGORY_ROLLBACK_TRANSACTION トランザクションをロールバックするタイプです。
static String | LEVEL_DEBUG DEBUG時に出力するレベルです。
static String | LEVEL_ERROR 例外を出力するレベルです。
static String | LEVEL_INFO 情報を出力するレベルです。
static String | LEVEL_WARNNING 警告を出力するレベルです。

フィールドの詳細

LEVEL_DEBUG

public static final String LEVEL_DEBUG
DEBUG時に出力するレベルです。

関連項目:
定数フィールド値

LEVEL_INFO

public static final String LEVEL_INFO
情報を出力するレベルです。

関連項目:
定数フィールド値

LEVEL_WARNNING

public static final String LEVEL_WARNNING
警告を出力するレベルです。

関連項目:
定数フィールド値

LEVEL_ERROR

public static final String LEVEL_ERROR
例外を出力するレベルです。

関連項目:
定数フィールド値

CATEGORY_BEGIN_TRANSACTION

public static final String CATEGORY_BEGIN_TRANSACTION
トランザクションを開始するタイプです。

導入されたバージョン:
6.1
関連項目:
定数フィールド値

CATEGORY_COMMIT_TRANSACTION

public static final String CATEGORY_COMMIT_TRANSACTION
トランザクションをコミットするタイプです。

導入されたバージョン:
6.1
関連項目:
定数フィールド値

CATEGORY_ROLLBACK_TRANSACTION

public static final String CATEGORY_ROLLBACK_TRANSACTION
トランザクションをロールバックするタイプです。

導入されたバージョン:
6.1
関連項目:
定数フィールド値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LogManager (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス LogManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.log.LogManager
public class LogManager
extends Object

ログマネージャです。

導入されたバージョン:
4.2

フィールドの概要
static String LOG_PROPERTY_HANDLER_KEY
ログプロパティハンドラのキー
メソッドの概要
LogAgent | getLogAgent() ログエージェントを取得します。
static LogManager | getLogManager() ログマネージャを取得します。
LogPropertyHandler | getLogPropertyHandler() ログプロパティハンドラを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

LOG_PROPERTY_HANDLER_KEY

public static final String LOG_PROPERTY_HANDLER_KEY
ログプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getLogManager

public static LogManager getLogManager()
ログマネージャを取得します。

戻り値:
ログマネージャ

getLogPropertyHandler

public LogPropertyHandler getLogPropertyHandler()
ログプロパティハンドラを取得します。

戻り値:
ログプロパティハンドラ

getLogAgent

public LogAgent getLogAgent()
ログエージェントを取得します。

戻り値:
ログエージェント
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LogPropertyException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス LogPropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.system.log.LogPropertyException
すべての実装インタフェース:
Serializable
public class LogPropertyException
extends SystemException

ログプロパティ取得時の例外です。

導入されたバージョン:
4.2
関連項目:
直列化された形式

コンストラクタの概要
LogPropertyException()
詳細メッセージを指定しないで LogPropertyException を構築します。
LogPropertyException(String msg)
指定された詳細メッセージを持つ LogPropertyException を構築します。
LogPropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ LogPropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

LogPropertyException

public LogPropertyException()
詳細メッセージを指定しないで LogPropertyException を構築します。

LogPropertyException

public LogPropertyException(String msg)
指定された詳細メッセージを持つ LogPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

LogPropertyException

public LogPropertyException(String msg,
                            Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ LogPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LogPropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
インタフェース LogPropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultLogPropertyHandler, XmlLogPropertyHandler
public interface LogPropertyHandler
extends PropertyHandler

ログフレームワークで使用するプロパティハンドラです。

導入されたバージョン:
4.2

メソッドの概要
String | getLogAgentName() ログエージェントのクラス名を取得します。
LogAgentParam[] | getLogAgentParams() ログエージェントのパラメータを取得します。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

getLogAgentName

public String getLogAgentName()
                       throws LogPropertyException
ログエージェントのクラス名を取得します。 何も設定されていない場合nullを返すように実装する必要があります。

戻り値:
ログエージェントのクラス名（設定されていない場合null）
例外:
LogPropertyException - ログエージェントのクラス名の取得時に例外が発生

getLogAgentParams

public LogAgentParam[] getLogAgentParams()
                                  throws LogPropertyException
ログエージェントのパラメータを取得します。 何も設定されていない場合大きさが0の配列を返すように実装する必要があります。

戻り値:
ログエージェントのパラメータの配列
例外:
LogPropertyException - ログエージェントのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.system.log (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.system.log
インタフェース
LogAgent
LogConstant
LogPropertyHandler
クラス
DefaultLogAgent
DefaultLogPropertyHandler
IntramartLogAgent
LogAgentParam
LogManager
XmlLogPropertyHandler
例外
LogPropertyException


jp.co.intra_mart.framework.system.log (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.log

J2EEフレームワークのログに関連するパッケージです。

参照:
説明

インタフェースの概要
LogAgent | ログに出力するエージェントです。
LogConstant | ログフレームワークで使用される定数値です。
LogPropertyHandler | ログフレームワークで使用するプロパティハンドラです。

クラスの概要
DefaultLogAgent | デフォルトのログエージェントです。
DefaultLogPropertyHandler | ログに関連するデフォルトのプロパティハンドラです。
IntramartLogAgent | intra-mart で管理されているログに出力するログエージェントです。
LogAgentParam | ログエージェントの初期パラメータです。
LogManager | ログマネージャです。
XmlLogPropertyHandler | リソースからログプロパティ情報を取得するプロパティハンドラです。

例外の概要
LogPropertyException ログプロパティ取得時の例外です。

パッケージ jp.co.intra_mart.framework.system.log の説明

J2EEフレームワークのログに関連するパッケージです。


jp.co.intra_mart.framework.system.log クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.log の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.system.log.DefaultLogAgent (implements jp.co.intra_mart.framework.system.log.LogAgent)
    • class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler (implements jp.co.intra_mart.framework.system.log.LogPropertyHandler)
    • class jp.co.intra_mart.framework.system.log.IntramartLogAgent (implements jp.co.intra_mart.framework.system.log.LogAgent)
    • class jp.co.intra_mart.framework.system.log.LogManager
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.system.log.LogAgentParam
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.system.log.LogPropertyException
    • class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler (implements jp.co.intra_mart.framework.system.log.LogPropertyHandler)

インタフェース階層

  • interface jp.co.intra_mart.framework.system.log.LogAgent
  • interface jp.co.intra_mart.framework.system.log.LogConstant
  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.system.log.LogPropertyHandler


パッケージ jp.co.intra_mart.framework.system.log の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.system.log の使用

jp.co.intra_mart.framework.system.log を使用しているパッケージ
jp.co.intra_mart.framework.system.log J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.system.log により使用される jp.co.intra_mart.framework.system.log のクラス
LogAgent
ログに出力するエージェントです。
LogAgentParam
ログエージェントの初期パラメータです。
LogManager
ログマネージャです。
LogPropertyException
ログプロパティ取得時の例外です。
LogPropertyHandler
ログフレームワークで使用するプロパティハンドラです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


XmlLogPropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス XmlLogPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler
すべての実装インタフェース:
LogPropertyHandler, PropertyHandler
public class XmlLogPropertyHandler
extends Object
implements LogPropertyHandler

リソースからログプロパティ情報を取得するプロパティハンドラです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのXMLファイル名
static String | DEFAULT_BUNDLE_NAME_PARAM XMLファイル名のパラメータ名
コンストラクタの概要
XmlLogPropertyHandler()
XMLLogPropertyHandlerを新規に生成します。
メソッドの概要
String | getLogAgentName() ログエージェントのクラス名を取得します。
LogAgentParam[] | getLogAgentParams() ログエージェントのパラメータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのXMLファイル名

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
XMLファイル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

XmlLogPropertyHandler

public XmlLogPropertyHandler()
XMLLogPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

getLogAgentName

public String getLogAgentName()
                       throws LogPropertyException
ログエージェントのクラス名を取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース LogPropertyHandler 内の getLogAgentName
戻り値:
ログエージェントのクラス名（設定されていない場合null）
例外:
LogPropertyException - ログエージェントのクラス名の取得時に例外が発生

getLogAgentParams

public LogAgentParam[] getLogAgentParams()
                                  throws LogPropertyException
ログエージェントのパラメータを取得します。 何も設定されていない場合大きさが0の配列が返ります。

定義:
インタフェース LogPropertyHandler 内の getLogAgentParams
戻り値:
ログエージェントのパラメータの配列
例外:
LogPropertyException - ログエージェントのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler の使用

jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler の使用

jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.message.MessageManager の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.message.MessageManager の使用

MessageManager を使用しているパッケージ
jp.co.intra_mart.framework.system.message メッセージに関連するパッケージです。

jp.co.intra_mart.framework.system.message での MessageManager の使用

MessageManager を返す jp.co.intra_mart.framework.system.message のメソッド
static MessageManager MessageManager.getMessageManager()
MessageManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.message.MessageManagerException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.message.MessageManagerException の使用

MessageManagerException を使用しているパッケージ
jp.co.intra_mart.framework.system.message メッセージに関連するパッケージです。

jp.co.intra_mart.framework.system.message での MessageManagerException の使用

MessageManagerException をスローする jp.co.intra_mart.framework.system.message のメソッド
static MessageManager MessageManager.getMessageManager()
MessageManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.message.MessagePropertyException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.message.MessagePropertyException の使用

jp.co.intra_mart.framework.system.message.MessagePropertyException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.system.message.MessagePropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.message.MessagePropertyHandler の使用

MessagePropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.system.message メッセージに関連するパッケージです。

jp.co.intra_mart.framework.system.message での MessagePropertyHandler の使用

MessagePropertyHandler を返す jp.co.intra_mart.framework.system.message のメソッド
 MessagePropertyHandler MessageManager.getMessagePropertyHandler()
メッセージプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.message.MessagePropertyParam の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.message.MessagePropertyParam の使用

jp.co.intra_mart.framework.system.message.MessagePropertyParam はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DefaultMessagePropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
クラス DefaultMessagePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler
すべての実装インタフェース:
MessagePropertyHandler, PropertyHandler
public class DefaultMessagePropertyHandler
extends Object
implements MessagePropertyHandler

デフォルトのメッセージプロパティハンドラです。 プロパティの設定内容は以下のとおりです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
コンストラクタの概要
DefaultMessagePropertyHandler()
DefaultMessagePropertyHandlerを新規に生成します。
メソッドの概要
String | getMessage(String key) キーに該当するメッセージを取得します。
String | getMessage(String key, String loginGroup) 推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。 getMessage(String)を使用してください。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultMessagePropertyHandler

public DefaultMessagePropertyHandler()
DefaultMessagePropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

getMessage

public String getMessage(String key,
                         String loginGroup)
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
getMessage(String)を使用してください。

キーに該当するメッセージを取得します。 該当するキーが存在しない場合、空文字列を返します。 プロパティの設定内容は以下のとおりです。
キー | 内容
ログイングループID.キー | ログイングループIDとキーに対応するメッセージ

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
key - メッセージのキー
loginGroup - ログイングループ
戻り値:
メッセージ

getMessage

public String getMessage(String key)
キーに該当するメッセージを取得します。 該当するキーが存在しない場合、空文字列を返します。 プロパティの設定内容は以下のとおりです。
キー | 内容
キー | キーに対応するメッセージ

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
key - メッセージのキー
戻り値:
メッセージ
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


IntramartMessagePropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
クラス IntramartMessagePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler
すべての実装インタフェース:
MessagePropertyHandler, PropertyHandler
public class IntramartMessagePropertyHandler
extends Object
implements MessagePropertyHandler

イントラマートで設定されたメッセージにアクセスするメッセージプロパティハンドラです。

バージョン:
1.0

コンストラクタの概要
IntramartMessagePropertyHandler()
IntramartMessagePropertyHandlerを新規に生成します。
メソッドの概要
String | getMessage(String key) キーに該当するメッセージを取得します。
String | getMessage(String key, String loginGroup) 推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。 パラメータloginGroupは実際には使用しません。getMessage(String)を使用してください。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartMessagePropertyHandler

public IntramartMessagePropertyHandler()
IntramartMessagePropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

getMessage

public String getMessage(String key,
                         String loginGroup)
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
パラメータloginGroupは実際には使用しません。getMessage(String)を使用してください。

キーに該当するメッセージを取得します。 該当するキーが存在しない場合、空文字列を返します。

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
key - メッセージのキー
loginGroup - ログイングループ
戻り値:
メッセージ

getMessage

public String getMessage(String key)
キーに該当するメッセージを取得します。 該当するキーが存在しない場合、空文字列を返します。

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
key - メッセージのキー
戻り値:
メッセージ
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MessageManager (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
クラス MessageManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.message.MessageManager
public class MessageManager
extends Object

メッセージを制御します。

バージョン:
1.0

フィールドの概要
static String MESSAGE_PROPERTY_HANDLER_KEY
メッセージプロパティハンドラのキー
メソッドの概要
String | getMessage(String key) キーに該当するメッセージを取得します。
String | getMessage(String key, String loginGroup) 推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。 設定されているMessagePropertyHandlerによっては、 パラメータloginGroupは実際には使用しない可能性があります。getMessage(String)を使用してください。
static MessageManager | getMessageManager() MessageManagerを取得します。
MessagePropertyHandler | getMessagePropertyHandler() メッセージプロパティハンドラを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

MESSAGE_PROPERTY_HANDLER_KEY

public static final String MESSAGE_PROPERTY_HANDLER_KEY
メッセージプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getMessageManager

public static MessageManager getMessageManager()
                                        throws MessageManagerException
MessageManagerを取得します。

戻り値:
メッセージマネージャ
例外:
MessageManagerException - メッセージマネージャの取得時に例外が発生

getMessagePropertyHandler

public MessagePropertyHandler getMessagePropertyHandler()
メッセージプロパティハンドラを取得します。

戻り値:
メッセージプロパティハンドラ

getMessage

public String getMessage(String key,
                         String loginGroup)
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
設定されているMessagePropertyHandlerによっては、 パラメータloginGroupは実際には使用しない可能性があります。getMessage(String)を使用してください。

キーに該当するメッセージを取得します。 キーがnullの場合、またはキーに該当するメッセージが存在しない場合、空文字列を返します。

パラメータ:
key - キー
loginGroup - ログイングループ
戻り値:
メッセージ

getMessage

public String getMessage(String key)
キーに該当するメッセージを取得します。 キーがnullの場合、またはキーに該当するメッセージが存在しない場合、空文字列を返します。

パラメータ:
key - キー
戻り値:
メッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MessageManagerException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
クラス MessageManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.system.message.MessageManagerException
すべての実装インタフェース:
Serializable
public class MessageManagerException
extends SystemException

メッセージマネージャに関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
MessageManagerException()
詳細メッセージを指定しないで MessageManagerException を構築します。
MessageManagerException(String msg)
指定された詳細メッセージを持つ MessageManagerException を構築します。
MessageManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessageManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MessageManagerException

public MessageManagerException()
詳細メッセージを指定しないで MessageManagerException を構築します。

MessageManagerException

public MessageManagerException(String msg)
指定された詳細メッセージを持つ MessageManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

MessageManagerException

public MessageManagerException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessageManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MessagePropertyException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
クラス MessagePropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.system.message.MessagePropertyException
すべての実装インタフェース:
Serializable
public class MessagePropertyException
extends SystemException

メッセージプロパティハンドラに関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
MessagePropertyException()
詳細メッセージを指定しないで MessagePropertyException を構築します。
MessagePropertyException(String msg)
指定された詳細メッセージを持つ MessagePropertyException を構築します。
MessagePropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessagePropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MessagePropertyException

public MessagePropertyException()
詳細メッセージを指定しないで MessagePropertyException を構築します。

MessagePropertyException

public MessagePropertyException(String msg)
指定された詳細メッセージを持つ MessagePropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

MessagePropertyException

public MessagePropertyException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessagePropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MessagePropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
インタフェース MessagePropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultMessagePropertyHandler, IntramartMessagePropertyHandler
public interface MessagePropertyHandler
extends PropertyHandler

メッセージに関連するプロパティを取得します。

バージョン:
1.0

メソッドの概要
String | getMessage(String key) キーに該当するメッセージを取得します。
String | getMessage(String key, String loginGroup) 推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。 getMessage(String)を使用してください。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

getMessage

public String getMessage(String key,
                         String loginGroup)
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
getMessage(String)を使用してください。

キーに該当するメッセージを取得します。 該当するキーが存在しない場合、空文字列を返します。

パラメータ:
key - メッセージのキー
loginGroup - ログイングループ
戻り値:
メッセージ

getMessage

public String getMessage(String key)
キーに該当するメッセージを取得します。 該当するキーが存在しない場合、空文字列を返します。

パラメータ:
key - メッセージのキー
戻り値:
メッセージ
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MessagePropertyParam (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
クラス MessagePropertyParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
        拡張 jp.co.intra_mart.framework.system.message.MessagePropertyParam
public class MessagePropertyParam
extends PropertyParam

メッセージプロパティハンドラの初期パラメータです。

バージョン:
1.0

コンストラクタの概要
MessagePropertyParam()
MessagePropertyParamを新規に生成します。
クラス jp.co.intra_mart.framework.system.property.PropertyParam から継承したメソッド
getName, getValue, setName, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MessagePropertyParam

public MessagePropertyParam()
MessagePropertyParamを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.system.message (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.system.message
インタフェース
MessagePropertyHandler
クラス
DefaultMessagePropertyHandler
IntramartMessagePropertyHandler
MessageManager
MessagePropertyParam
例外
MessageManagerException
MessagePropertyException


jp.co.intra_mart.framework.system.message (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.message

メッセージに関連するパッケージです。

参照:
説明

インタフェースの概要
MessagePropertyHandler メッセージに関連するプロパティを取得します。

クラスの概要
DefaultMessagePropertyHandler | デフォルトのメッセージプロパティハンドラです。
IntramartMessagePropertyHandler | イントラマートで設定されたメッセージにアクセスするメッセージプロパティハンドラです。
MessageManager | メッセージを制御します。
MessagePropertyParam | メッセージプロパティハンドラの初期パラメータです。

例外の概要
MessageManagerException | メッセージマネージャに関連する例外です。
MessagePropertyException | メッセージプロパティハンドラに関連する例外です。

パッケージ jp.co.intra_mart.framework.system.message の説明

メッセージに関連するパッケージです。


jp.co.intra_mart.framework.system.message クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.message の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler (implements jp.co.intra_mart.framework.system.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler (implements jp.co.intra_mart.framework.system.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.system.message.MessageManager
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.system.message.MessagePropertyParam
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.system.message.MessageManagerException
            • class jp.co.intra_mart.framework.system.message.MessagePropertyException

インタフェース階層

  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.system.message.MessagePropertyHandler


パッケージ jp.co.intra_mart.framework.system.message の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.system.message の使用

jp.co.intra_mart.framework.system.message を使用しているパッケージ
jp.co.intra_mart.framework.system.message メッセージに関連するパッケージです。

jp.co.intra_mart.framework.system.message により使用される jp.co.intra_mart.framework.system.message のクラス
MessageManager
メッセージを制御します。
MessageManagerException
メッセージマネージャに関連する例外です。
MessagePropertyHandler
メッセージに関連するプロパティを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.DefaultPropertyManager の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.DefaultPropertyManager の使用

jp.co.intra_mart.framework.system.property.DefaultPropertyManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.PropertyConfigModel の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyConfigModel の使用

jp.co.intra_mart.framework.system.property.PropertyConfigModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.property.PropertyHandler の使用

PropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.message | メッセージに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.base.data での PropertyHandler の使用

jp.co.intra_mart.framework.base.data での PropertyHandler のサブインタフェース
 interface DataPropertyHandler
DAOの設定情報に接続するクラスです。

PropertyHandler を実装している jp.co.intra_mart.framework.base.data のクラス
class | DefaultDataPropertyHandler デフォルトのデータプロパティハンドラです。
class | DistributesDataPropertyHandler アプリケーション毎のプロパティハンドラを呼び出します。
class | TextFileDataPropertyHandler 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
class | XmlDataPropertyHandler XMLのデータプロパティハンドラです。

jp.co.intra_mart.framework.base.event での PropertyHandler の使用

jp.co.intra_mart.framework.base.event での PropertyHandler のサブインタフェース
 interface EventPropertyHandler
イベントの設定情報に接続するクラスです。

PropertyHandler を実装している jp.co.intra_mart.framework.base.event のクラス
class | DefaultEventPropertyHandler デフォルトのEventPropertyHandlerです。
class | DistributesEventPropertyHandler アプリケーション毎のEventPropertyHandlerを呼び出します。
class | TextFileEventPropertyHandler 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
class | XmlEventPropertyHandler XMLのEventPropertyHandlerです。

jp.co.intra_mart.framework.base.message での PropertyHandler の使用

jp.co.intra_mart.framework.base.message での PropertyHandler のサブインタフェース
 interface MessagePropertyHandler
メッセージの設定情報に接続するクラスです。

PropertyHandler を実装している jp.co.intra_mart.framework.base.message のクラス
class | DefaultMessagePropertyHandler メッセージの設定情報に接続するデフォルトのプロパティハンドラです。
class | TextFileMessagePropertyHandler 指定されたファイルからプロパティ情報を取得するメッセージプロパティハンドラです。

jp.co.intra_mart.framework.base.service での PropertyHandler の使用

jp.co.intra_mart.framework.base.service での PropertyHandler のサブインタフェース
 interface ServicePropertyHandler
サービスの設定情報に接続するクラスです。

PropertyHandler を実装している jp.co.intra_mart.framework.base.service のクラス
class | DefaultServicePropertyHandler サービスの設定情報に接続するデフォルトのプロパティハンドラです。
class | DistributesServicePropertyHandler アプリケーションごとに異なるサービスプロパティハンドラを使用するサービスプロパティハンドラです。
class | TextFileServicePropertyHandler 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
class | XmlServicePropertyHandler サービスの設定情報に接続するプロパティハンドラです。

jp.co.intra_mart.framework.base.session での PropertyHandler の使用

jp.co.intra_mart.framework.base.session での PropertyHandler のサブインタフェース
 interface SessionPropertyHandler
セッションに関連するプロパティを取得します。

PropertyHandler を実装している jp.co.intra_mart.framework.base.session のクラス
class | DefaultSessionPropertyHandler セッションに関連するデフォルトのプロパティハンドラです。
class | XmlSessionPropertyHandler セッションに関連するXMLのプロパティハンドラです。

jp.co.intra_mart.framework.system.log での PropertyHandler の使用

jp.co.intra_mart.framework.system.log での PropertyHandler のサブインタフェース
 interface LogPropertyHandler
ログフレームワークで使用するプロパティハンドラです。

PropertyHandler を実装している jp.co.intra_mart.framework.system.log のクラス
class | DefaultLogPropertyHandler ログに関連するデフォルトのプロパティハンドラです。
class | XmlLogPropertyHandler リソースからログプロパティ情報を取得するプロパティハンドラです。

jp.co.intra_mart.framework.system.message での PropertyHandler の使用

PropertyHandler を実装している jp.co.intra_mart.framework.system.message のクラス
 class IntramartMessagePropertyHandler
イントラマートで設定されたメッセージにアクセスするメッセージプロパティハンドラです。

jp.co.intra_mart.framework.system.property での PropertyHandler の使用

PropertyHandler を返す jp.co.intra_mart.framework.system.property のメソッド
 PropertyHandler PropertyManager.getPropertyHandler(String key)
キーで指定されたプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.PropertyHandlerException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyHandlerException の使用

PropertyHandlerException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.message | メッセージに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.base.data での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.base.data のメソッド
void | XmlDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | TextFileDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DistributesDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.event での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.base.event のメソッド
void | XmlEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | TextFileEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DistributesEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.message での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.base.message のメソッド
void | TextFileMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.service での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.base.service のメソッド
void | XmlServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | TextFileServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DistributesServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.session での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.base.session のメソッド
void | XmlSessionPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultSessionPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.system.log での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.system.log のメソッド
void | XmlLogPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultLogPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.system.message での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.system.message のメソッド
void | IntramartMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.system.property での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.system.property のメソッド
protected String | XmlPropertyManager.getPropertyHandlerName(String key) キーで指定されたプロパティハンドラのクラス名を取得します。
protected abstract String | PropertyManager.getPropertyHandlerName(String key) キーで指定されたプロパティハンドラのクラス名を取得します。
PropertyHandler | PropertyManager.getPropertyHandler(String key) キーで指定されたプロパティハンドラを取得します。
void | PropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
protected String | DefaultPropertyManager.getPropertyHandlerName(String key) キーで指定されたプロパティハンドラのクラス名を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.PropertyHandlerParam の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyHandlerParam の使用

PropertyHandlerParam を使用しているパッケージ
jp.co.intra_mart.framework.system.property プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.system.property での PropertyHandlerParam の使用

PropertyHandlerParam を返す jp.co.intra_mart.framework.system.property のメソッド
protected PropertyHandlerParam[] | XmlPropertyManager.getPropertyHandlerParams(String key) キーで指定されたプロパティハンドラの初期化データを取得します。
protected abstract PropertyHandlerParam[] | PropertyManager.getPropertyHandlerParams(String key) キーで指定されたプロパティハンドラの初期化データを取得します。
protected PropertyHandlerParam[] | PropertyConfigModel.getPropertyParams(String key) 指定されたキーのプロパティのパラメータを取得します。
protected PropertyHandlerParam[] | DefaultPropertyManager.getPropertyHandlerParams(String key) キーで指定されたプロパティハンドラの初期化データを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.PropertyManager の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyManager の使用

PropertyManager を使用しているパッケージ
jp.co.intra_mart.framework.system.property プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.system.property での PropertyManager の使用

jp.co.intra_mart.framework.system.property での PropertyManager のサブクラス
class | DefaultPropertyManager デフォルトのプロパティマネージャです。
class | XmlPropertyManager xmlのプロパティマネージャです。

PropertyManager を返す jp.co.intra_mart.framework.system.property のメソッド
static PropertyManager PropertyManager.getPropertyManager()
プロパティマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.PropertyManagerException の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyManagerException の使用

PropertyManagerException を使用しているパッケージ
jp.co.intra_mart.framework.system.property プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.system.property での PropertyManagerException の使用

PropertyManagerException をスローする jp.co.intra_mart.framework.system.property のメソッド
static PropertyManager PropertyManager.getPropertyManager()
プロパティマネージャを取得します。

PropertyManagerException をスローする jp.co.intra_mart.framework.system.property のコンストラクタ
XmlPropertyManager()
コンストラクタです。
DefaultPropertyManager()
コンストラクタです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.PropertyModel の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyModel の使用

jp.co.intra_mart.framework.system.property.PropertyModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.PropertyParam の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyParam の使用

PropertyParam を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.tag | J2EEフレームワークで使用する各種のタグのパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.message | メッセージに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.base.data での PropertyParam の使用

jp.co.intra_mart.framework.base.data での PropertyParam のサブクラス
 class ResourceParam
データコネクタの初期パラメータです。

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.base.data のメソッド
void | XmlDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | TextFileDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DistributesDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.event での PropertyParam の使用

jp.co.intra_mart.framework.base.event での PropertyParam のサブクラス
 class EventListenerFactoryParam
イベントリスナファクトリの初期パラメータです。

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.base.event のメソッド
void | XmlEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | TextFileEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DistributesEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.message での PropertyParam の使用

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.base.message のメソッド
void | TextFileMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.service での PropertyParam の使用

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
void | XmlServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | TextFileServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DistributesServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.session での PropertyParam の使用

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.base.session のメソッド
void | XmlSessionPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultSessionPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.web.tag での PropertyParam の使用

jp.co.intra_mart.framework.base.web.tag での PropertyParam のサブクラス
 class FrameworkTagParam
タグに追加されるパラメータです。

jp.co.intra_mart.framework.system.log での PropertyParam の使用

jp.co.intra_mart.framework.system.log での PropertyParam のサブクラス
 class LogAgentParam
ログエージェントの初期パラメータです。

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.system.log のメソッド
void | XmlLogPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultLogPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.system.message での PropertyParam の使用

jp.co.intra_mart.framework.system.message での PropertyParam のサブクラス
 class MessagePropertyParam
メッセージプロパティハンドラの初期パラメータです。

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.system.message のメソッド
void | IntramartMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.system.property での PropertyParam の使用

jp.co.intra_mart.framework.system.property での PropertyParam のサブクラス
 class PropertyHandlerParam
プロパティハンドラを生成する時の初期パラメータです。

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.system.property のメソッド
 void PropertyHandler.init(PropertyParam[] params)
プロパティハンドラを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.XmlPropertyManager の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.XmlPropertyManager の使用

jp.co.intra_mart.framework.system.property.XmlPropertyManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DefaultPropertyManager (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス DefaultPropertyManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyManager
        拡張 jp.co.intra_mart.framework.system.property.DefaultPropertyManager
public class DefaultPropertyManager
extends PropertyManager

デフォルトのプロパティマネージャです。 リソースバンドルで設定されたプロパティ情報を管理します。 プロパティ情報のリソースバンドルは以下の順番で決定されます。

 1.システムプロパティKEYで設定されているリソースバンドル
 2.デフォルトのプロパティマネージャDEFAULT_BUNDLE_NAMEで設定されているリソースバンドル

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名
static String | KEY プロパティマネージャを指定するキー
クラス jp.co.intra_mart.framework.system.property.PropertyManager から継承したフィールド
DEFAULT_SYSTEM_MANAGER
コンストラクタの概要
DefaultPropertyManager()
コンストラクタです。
メソッドの概要
protected String | getPropertyHandlerName(String key) キーで指定されたプロパティハンドラのクラス名を取得します。
protected PropertyHandlerParam[] | getPropertyHandlerParams(String key) キーで指定されたプロパティハンドラの初期化データを取得します。
クラス jp.co.intra_mart.framework.system.property.PropertyManager から継承したメソッド
getPropertyHandler, getPropertyManager
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KEY

public static final String KEY
プロパティマネージャを指定するキー

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultPropertyManager

public DefaultPropertyManager()
                       throws PropertyManagerException
コンストラクタです。

例外:
PropertyManagerException - プロパティマネージャの設定に失敗
メソッドの詳細

getPropertyHandlerName

protected String getPropertyHandlerName(String key)
                                 throws PropertyHandlerException
キーで指定されたプロパティハンドラのクラス名を取得します。

定義:
クラス PropertyManager 内の getPropertyHandlerName
パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラのクラス名
例外:
PropertyHandlerException - クラス名の取得に失敗

getPropertyHandlerParams

protected PropertyHandlerParam[] getPropertyHandlerParams(String key)
キーで指定されたプロパティハンドラの初期化データを取得します。 初期化データが存在しない場合、nullが返ります。

定義:
クラス PropertyManager 内の getPropertyHandlerParams
パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラの初期化データ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.system.property (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.system.property
インタフェース
PropertyHandler
クラス
DefaultPropertyManager
PropertyConfigModel
PropertyHandlerParam
PropertyManager
PropertyModel
PropertyParam
XmlPropertyManager
例外
PropertyHandlerException
PropertyManagerException


jp.co.intra_mart.framework.system.property (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.property

プロパティ取得に関連するパッケージです。

参照:
説明

インタフェースの概要
PropertyHandler プロパティにアクセスするインタフェースです。

クラスの概要
DefaultPropertyManager | デフォルトのプロパティマネージャです。
PropertyConfigModel | データモデルクラスです。
PropertyHandlerParam | プロパティハンドラを生成する時の初期パラメータです。
PropertyManager | システム設定の情報を管理します。
PropertyModel | プロパティモデルクラスです。
PropertyParam | プロパティのパラメータを表現する汎用的なクラスです。
XmlPropertyManager | xmlのプロパティマネージャです。

例外の概要
PropertyHandlerException | プロパティハンドラの情報取得時の例外です。
PropertyManagerException | プロパティマネージャの設定時の例外です。

パッケージ jp.co.intra_mart.framework.system.property の説明

プロパティ取得に関連するパッケージです。


jp.co.intra_mart.framework.system.property クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.property の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.system.property.PropertyConfigModel
    • class jp.co.intra_mart.framework.system.property.PropertyManager
      • class jp.co.intra_mart.framework.system.property.DefaultPropertyManager
      • class jp.co.intra_mart.framework.system.property.XmlPropertyManager
    • class jp.co.intra_mart.framework.system.property.PropertyModel
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.system.property.PropertyHandlerParam
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.property.PropertyHandlerException
          • class jp.co.intra_mart.framework.system.property.PropertyManagerException

インタフェース階層

  • interface jp.co.intra_mart.framework.system.property.PropertyHandler


パッケージ jp.co.intra_mart.framework.system.property の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.system.property の使用

jp.co.intra_mart.framework.system.property を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.tag | J2EEフレームワークで使用する各種のタグのパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.message | メッセージに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.base.data により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.base.event により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.base.message により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.base.session により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.base.web.tag により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.system.log により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.system.message により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.system.property により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyHandlerParam
プロパティハンドラを生成する時の初期パラメータです。
PropertyManager
システム設定の情報を管理します。
PropertyManagerException
プロパティマネージャの設定時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PropertyConfigModel (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyConfigModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyConfigModel
public class PropertyConfigModel
extends Object

データモデルクラスです。

バージョン:
1.0

コンストラクタの概要
PropertyConfigModel()
メソッドの概要
protected String | getPropertyHandlerName(String key) 指定されたキーのプロパティハンドラ名を取得します。
protected PropertyHandlerParam[] | getPropertyParams(String key) 指定されたキーのプロパティのパラメータを取得します。
protected void | setProperties(Map map) パラメータを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PropertyConfigModel

public PropertyConfigModel()
メソッドの詳細

setProperties

protected void setProperties(Map map)
パラメータを設定します。

パラメータ:
map -

getPropertyHandlerName

protected String getPropertyHandlerName(String key)
指定されたキーのプロパティハンドラ名を取得します。

戻り値:
String

getPropertyParams

protected PropertyHandlerParam[] getPropertyParams(String key)
指定されたキーのプロパティのパラメータを取得します。

戻り値:
PropertyParam[]
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PropertyHandler (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
インタフェース PropertyHandler

既知のサブインタフェースの一覧:
DataPropertyHandler, EventPropertyHandler, LogPropertyHandler, MessagePropertyHandler, MessagePropertyHandler, ServicePropertyHandler, SessionPropertyHandler
既知の実装クラスの一覧:
DefaultDataPropertyHandler, DefaultEventPropertyHandler, DefaultLogPropertyHandler, DefaultMessagePropertyHandler, DefaultMessagePropertyHandler, DefaultServicePropertyHandler, DefaultSessionPropertyHandler, DistributesDataPropertyHandler, DistributesEventPropertyHandler, DistributesServicePropertyHandler, IntramartMessagePropertyHandler, TextFileDataPropertyHandler, TextFileEventPropertyHandler, TextFileMessagePropertyHandler, TextFileServicePropertyHandler, XmlDataPropertyHandler, XmlEventPropertyHandler, XmlLogPropertyHandler, XmlServicePropertyHandler, XmlSessionPropertyHandler
public interface PropertyHandler

プロパティにアクセスするインタフェースです。 このインタフェースを実装するすべてのクラスは、引数なしのコンストラクタが必要です。

バージョン:
1.0

メソッドの概要
 void init(PropertyParam[] params)
プロパティハンドラを初期化します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PropertyHandlerException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyHandlerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.property.PropertyHandlerException
すべての実装インタフェース:
Serializable
public class PropertyHandlerException
extends FrameworkException

プロパティハンドラの情報取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
PropertyHandlerException()
詳細メッセージを指定しないで PropertyHandlerException を構築します。
PropertyHandlerException(String msg)
指定された詳細メッセージを持つ PropertyHandlerException を構築します。
PropertyHandlerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PropertyHandlerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PropertyHandlerException

public PropertyHandlerException()
詳細メッセージを指定しないで PropertyHandlerException を構築します。

PropertyHandlerException

public PropertyHandlerException(String msg)
指定された詳細メッセージを持つ PropertyHandlerException を構築します。

パラメータ:
msg - 詳細メッセージ

PropertyHandlerException

public PropertyHandlerException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PropertyHandlerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PropertyHandlerParam (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyHandlerParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
        拡張 jp.co.intra_mart.framework.system.property.PropertyHandlerParam
public class PropertyHandlerParam
extends PropertyParam

プロパティハンドラを生成する時の初期パラメータです。

バージョン:
1.0

コンストラクタの概要
PropertyHandlerParam()
PropertyHandlerParamを新規に生成します。
クラス jp.co.intra_mart.framework.system.property.PropertyParam から継承したメソッド
getName, getValue, setName, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PropertyHandlerParam

public PropertyHandlerParam()
PropertyHandlerParamを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PropertyManager (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyManager
直系の既知のサブクラス:
DefaultPropertyManager, XmlPropertyManager
public abstract class PropertyManager
extends Object

システム設定の情報を管理します。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_SYSTEM_MANAGER デフォルトのプロパティマネージャクラス
static String | KEY プロパティマネージャを指定するキー
コンストラクタの概要
protected PropertyManager()
プロパティマネージャのコンストラクタです。
メソッドの概要
PropertyHandler | getPropertyHandler(String key) キーで指定されたプロパティハンドラを取得します。
protected abstract String | getPropertyHandlerName(String key) キーで指定されたプロパティハンドラのクラス名を取得します。
protected abstract PropertyHandlerParam[] | getPropertyHandlerParams(String key) キーで指定されたプロパティハンドラの初期化データを取得します。
static PropertyManager | getPropertyManager() プロパティマネージャを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KEY

public static final String KEY
プロパティマネージャを指定するキー

関連項目:
定数フィールド値

DEFAULT_SYSTEM_MANAGER

public static final String DEFAULT_SYSTEM_MANAGER
デフォルトのプロパティマネージャクラス

関連項目:
定数フィールド値
コンストラクタの詳細

PropertyManager

protected PropertyManager()
プロパティマネージャのコンストラクタです。 コンストラクタの明示的な使用はできません。

メソッドの詳細

getPropertyManager

public static PropertyManager getPropertyManager()
                                          throws PropertyManagerException
プロパティマネージャを取得します。 プロパティマネージャは常に１つだけ存在します。 プロパティマネージャが未設定の状態でこのメソッドが呼ばれた場合、以下の順番でプロパティマネージャを取得します。
 1.システムプロパティKEYで設定されているプロパティマネージャ
 2.デフォルトのプロパティマネージャ

戻り値:
プロパティマネージャ
例外:
PropertyManagerException - プロパティマネージャの設定時に発生する例外

getPropertyHandlerName

protected abstract String getPropertyHandlerName(String key)
                                          throws PropertyHandlerException
キーで指定されたプロパティハンドラのクラス名を取得します。

パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラのクラス名
例外:
PropertyHandlerException - プロパティハンドラのクラス名を取得できなかった場合に発生する例外

getPropertyHandlerParams

protected abstract PropertyHandlerParam[] getPropertyHandlerParams(String key)
キーで指定されたプロパティハンドラの初期化データを取得します。 初期化データが存在しない場合、nullが返ります。

パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラの初期化データ

getPropertyHandler

public PropertyHandler getPropertyHandler(String key)
                                   throws PropertyHandlerException
キーで指定されたプロパティハンドラを取得します。

パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラ
例外:
PropertyHandlerException - プロパティハンドラの取得に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PropertyManagerException (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.property.PropertyManagerException
すべての実装インタフェース:
Serializable
public class PropertyManagerException
extends FrameworkException

プロパティマネージャの設定時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
PropertyManagerException()
詳細メッセージを指定しないで PropertyManagerException を構築します。
PropertyManagerException(String msg)
指定された詳細メッセージを持つ PropertyManagerException を構築します。
PropertyManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PropertyManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PropertyManagerException

public PropertyManagerException()
詳細メッセージを指定しないで PropertyManagerException を構築します。

PropertyManagerException

public PropertyManagerException(String msg)
指定された詳細メッセージを持つ PropertyManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

PropertyManagerException

public PropertyManagerException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PropertyManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PropertyModel (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyModel
public class PropertyModel
extends Object

プロパティモデルクラスです。

バージョン:
1.0

コンストラクタの概要
PropertyModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PropertyModel

public PropertyModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PropertyParam (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
直系の既知のサブクラス:
EventListenerFactoryParam, FrameworkTagParam, LogAgentParam, MessagePropertyParam, PropertyHandlerParam, ResourceParam
public class PropertyParam
extends Object

プロパティのパラメータを表現する汎用的なクラスです。 このクラスのインスタンス１つがパラメータ名とパラメータの値という１つのペアに対応します。

バージョン:
1.0

コンストラクタの概要
PropertyParam()
PropertyParamを新規に生成します。
メソッドの概要
String | getName() パラメータ名を取得します。
String | getValue() パラメータの値を取得します。
void | setName(String name) パラメータ名を設定します。
void | setValue(String value) パラメータの値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PropertyParam

public PropertyParam()
PropertyParamを新規に生成します。

メソッドの詳細

setName

public void setName(String name)
パラメータ名を設定します。

パラメータ:
name - パラメータ名

getName

public String getName()
パラメータ名を取得します。

戻り値:
パラメータ名

setValue

public void setValue(String value)
パラメータの値を設定します。

パラメータ:
value - パラメータの値

getValue

public String getValue()
パラメータの値を取得します。

戻り値:
パラメータの値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XmlPropertyManager (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス XmlPropertyManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyManager
        拡張 jp.co.intra_mart.framework.system.property.XmlPropertyManager
public class XmlPropertyManager
extends PropertyManager

xmlのプロパティマネージャです。 プロパティ情報を管理します。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名
static String | KEY プロパティマネージャを指定するキー
クラス jp.co.intra_mart.framework.system.property.PropertyManager から継承したフィールド
DEFAULT_SYSTEM_MANAGER
コンストラクタの概要
XmlPropertyManager()
コンストラクタです。
メソッドの概要
protected String | getPropertyHandlerName(String key) キーで指定されたプロパティハンドラのクラス名を取得します。
protected PropertyHandlerParam[] | getPropertyHandlerParams(String key) キーで指定されたプロパティハンドラの初期化データを取得します。
クラス jp.co.intra_mart.framework.system.property.PropertyManager から継承したメソッド
getPropertyHandler, getPropertyManager
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KEY

public static final String KEY
プロパティマネージャを指定するキー

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名

関連項目:
定数フィールド値
コンストラクタの詳細

XmlPropertyManager

public XmlPropertyManager()
                   throws PropertyManagerException
コンストラクタです。

例外:
PropertyManagerException - プロパティマネージャの設定に失敗
メソッドの詳細

getPropertyHandlerName

protected String getPropertyHandlerName(String key)
                                 throws PropertyHandlerException
キーで指定されたプロパティハンドラのクラス名を取得します。

定義:
クラス PropertyManager 内の getPropertyHandlerName
パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラのクラス名
例外:
PropertyHandlerException - クラス名の取得に失敗

getPropertyHandlerParams

protected PropertyHandlerParam[] getPropertyHandlerParams(String key)
キーで指定されたプロパティハンドラの初期化データを取得します。 初期化データが存在しない場合、nullが返ります。

定義:
クラス PropertyManager 内の getPropertyHandlerParams
パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラの初期化データ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.system.util.Config の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.util.Config の使用

Config を使用しているパッケージ
jp.co.intra_mart.framework.base.service.controller | 入力情報に関連するパッケージです。
jp.co.intra_mart.framework.base.service.validator | 検証に関連するパッケージです。

jp.co.intra_mart.framework.base.service.controller での Config の使用

jp.co.intra_mart.framework.base.service.controller での Config のサブクラス
 class ControllerConverterConfigImpl
ControllerConverterの初期化情報です。

jp.co.intra_mart.framework.base.service.validator での Config の使用

jp.co.intra_mart.framework.base.service.validator での Config のサブクラス
 class ValidatorConfigImpl
ValidatorConfigの実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Config (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.util
クラス Config

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.util.Config
直系の既知のサブクラス:
ControllerConverterConfigImpl, ValidatorConfigImpl
public abstract class Config
extends Object

標準的な初期化情報です。

導入されたバージョン:
6.1

フィールドの概要
protected  Map parameters
パラメータの集合
コンストラクタの概要
Config()
メソッドの概要
String | getInitParameter(String name) Validatorを初期化するときのパラメータを取得します。
Enumeration | getInitParameterNames() 初期化パラメータの名前の一覧を取得します。
void | setInitParameter(String name, String value) Validatorを初期化するときのパラメータを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

parameters

protected Map parameters
パラメータの集合

コンストラクタの詳細

Config

public Config()
メソッドの詳細

getInitParameter

public String getInitParameter(String name)
Validatorを初期化するときのパラメータを取得します。

パラメータ:
name - 初期化パラメータ名
戻り値:
初期化パラメータの値

setInitParameter

public void setInitParameter(String name,
                             String value)
Validatorを初期化するときのパラメータを設定します。

パラメータ:
name - 初期化パラメータ名
value - 初期化パラメータの値

getInitParameterNames

public Enumeration getInitParameterNames()
初期化パラメータの名前の一覧を取得します。

戻り値:
初期化パラメータの名前の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.system.util (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.system.util
クラス
Config


jp.co.intra_mart.framework.system.util (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.util

クラスの概要
Config 標準的な初期化情報です。


jp.co.intra_mart.framework.system.util クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.system.util.Config


パッケージ jp.co.intra_mart.framework.system.util の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.system.util の使用

jp.co.intra_mart.framework.system.util を使用しているパッケージ
jp.co.intra_mart.framework.base.service.controller | 入力情報に関連するパッケージです。
jp.co.intra_mart.framework.base.service.validator | 検証に関連するパッケージです。

jp.co.intra_mart.framework.base.service.controller により使用される jp.co.intra_mart.framework.system.util のクラス
Config
標準的な初期化情報です。

jp.co.intra_mart.framework.base.service.validator により使用される jp.co.intra_mart.framework.system.util のクラス
Config
標準的な初期化情報です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.util.FileResourceBundle の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.util.FileResourceBundle の使用

jp.co.intra_mart.framework.util.FileResourceBundle はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.util.IntramartConnectUtil の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.util.IntramartConnectUtil の使用

jp.co.intra_mart.framework.util.IntramartConnectUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.util.IntramartConnectUtil.RequestInfo の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.util.IntramartConnectUtil.RequestInfo の使用

IntramartConnectUtil.RequestInfo を使用しているパッケージ
jp.co.intra_mart.framework.util J2EEフレームワークで使用する各種のユーティリティです。

jp.co.intra_mart.framework.util での IntramartConnectUtil.RequestInfo の使用

IntramartConnectUtil.RequestInfo を返す jp.co.intra_mart.framework.util のメソッド
static IntramartConnectUtil.RequestInfo IntramartConnectUtil.getRequestInfo(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 リクエスト情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.util.SecurityUtil の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.util.SecurityUtil の使用

jp.co.intra_mart.framework.util.SecurityUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.util.XMLDocumentProducer の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.util.XMLDocumentProducer の使用

jp.co.intra_mart.framework.util.XMLDocumentProducer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.util.XMLNode の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.util.XMLNode の使用

XMLNode を使用しているパッケージ
jp.co.intra_mart.framework.util J2EEフレームワークで使用する各種のユーティリティです。

jp.co.intra_mart.framework.util での XMLNode の使用

XMLNode を返す jp.co.intra_mart.framework.util のメソッド
XMLNode | XMLNode.lookup(String tags) XMLNodeを返却します。
XMLNode | XMLNode.lookup(Vector tags) XMLNodeを返却します。
XMLNode[] | XMLNode.select(String tags) ノードの配列を返却します。
XMLNode | XMLNode.addAttr(String attr, String value) Attributeを追加します。
XMLNode | XMLNode.delAttr(String attr) Attributeを削除します。
XMLNode | XMLNode.addNode(String name) Nodeを追加します。
XMLNode | XMLNode.addNode(String name, String target) Nodeを追加します。
XMLNode | XMLNode.delNode(String tag) Nodeを削除します。
XMLNode | XMLNode.delNode(XMLNode child) Nodeを削除します。
XMLNode | XMLNode.delNode() Nodeを削除します。
XMLNode[] | XMLNode.getNodeList() NodeListを返却します。
XMLNode[] | XMLNode.getChildNode() 子NodeListを返却します。

XMLNode 型のパラメータを持つ jp.co.intra_mart.framework.util のメソッド
 XMLNode XMLNode.delNode(XMLNode child)
Nodeを削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


FileResourceBundle (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.util
クラス FileResourceBundle

java.lang.Object
    拡張 java.util.ResourceBundle
        拡張 jp.co.intra_mart.framework.util.FileResourceBundle
public class FileResourceBundle
extends ResourceBundle

java.util.ResourceBundle のファイル版です。 クラスパスではなく実際のファイルパスに依存した方法でプロパティを取得します。

導入されたバージョン:
4.2

フィールドの概要
クラス java.util.ResourceBundle から継承したフィールド
parent
コンストラクタの概要
FileResourceBundle(String path)
プロパティリソースを作成します。
FileResourceBundle(String path, Locale locale)
プロパティリソースを作成します。
メソッドの概要
Enumeration | getKeys() キーの列挙を返します。
Locale | getLocale() ResourceBundle の Locale を返します。
protected Object | handleGetObject(String key)
クラス java.util.ResourceBundle から継承したメソッド
getBundle, getBundle, getBundle, getObject, getString, getStringArray, setParent
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FileResourceBundle

public FileResourceBundle(String path)
                   throws MissingResourceException,
                          IOException
プロパティリソースを作成します。

パラメータ:
path - ファイルパス
例外:
IOException
MissingResourceException

FileResourceBundle

public FileResourceBundle(String path,
                          Locale locale)
                   throws MissingResourceException,
                          IOException
プロパティリソースを作成します。

パラメータ:
path - ファイルパス
locale - ロケール
例外:
IOException
MissingResourceException
メソッドの詳細

getKeys

public Enumeration getKeys()
キーの列挙を返します。

戻り値:
キーの列挙

getLocale

public Locale getLocale()
ResourceBundle の Locale を返します。

戻り値:
ロケール

handleGetObject

protected Object handleGetObject(String key)
                          throws MissingResourceException
パラメータ:
key -
戻り値:
例外:
MissingResourceException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


IntramartConnectUtil (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.util
クラス IntramartConnectUtil

java.lang.Object
    拡張 jp.co.intra_mart.framework.util.IntramartConnectUtil
推奨されていません。 この機能は廃止されました。

public class IntramartConnectUtil
extends Object

intra-martページベースからの接続用のユーティリティです。

導入されたバージョン:
4.2

入れ子クラスの概要
static class IntramartConnectUtil.RequestInfo
推奨されていません。 リクエスト情報です。
フィールドの概要
static String | INTRAMART_URL_NAME 推奨されていません。 セッションに登録するintra-martのサーブレットのURLの属性名
static String | PARAM_ARGUMENT 推奨されていません。 ページ引数のリクエストパラメータ名
static String | PARAM_LOGIN_GROUP_ID 推奨されていません。 ログイングループIDのリクエストパラメータ名
static String | PARAM_LOGIN_USER_ID 推奨されていません。 ログインユーザIDのリクエストパラメータ名
static String | PARAM_REFERER 推奨されていません。 参照元URLのリクエストパラメータ名
static String | PARAM_REFERER_FORMAT 推奨されていません。 URL指定タイプのパラメータ名
static String | PARAM_WINDOW_NAME 推奨されていません。 基本ウィンドウ名
コンストラクタの概要
IntramartConnectUtil()
推奨されていません。
メソッドの概要
static boolean | configSession(HttpServletRequest request, HttpServletResponse response, String loginUserIDKey, String loginUserID, String loginGroupIDKey, String loginGroupID, boolean referrerFormatShort) 推奨されていません。 セッションにさまざまな情報を設定します。
static IntramartConnectUtil.RequestInfo | getRequestInfo(HttpServletRequest request, HttpServletResponse response) 推奨されていません。 リクエスト情報を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_LOGIN_USER_ID

public static final String PARAM_LOGIN_USER_ID
推奨されていません。
ログインユーザIDのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_LOGIN_GROUP_ID

public static final String PARAM_LOGIN_GROUP_ID
推奨されていません。
ログイングループIDのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_ARGUMENT

public static final String PARAM_ARGUMENT
推奨されていません。
ページ引数のリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_REFERER

public static final String PARAM_REFERER
推奨されていません。
参照元URLのリクエストパラメータ名

関連項目:
定数フィールド値

INTRAMART_URL_NAME

public static final String INTRAMART_URL_NAME
推奨されていません。
セッションに登録するintra-martのサーブレットのURLの属性名

関連項目:
定数フィールド値

PARAM_REFERER_FORMAT

public static final String PARAM_REFERER_FORMAT
推奨されていません。
URL指定タイプのパラメータ名

関連項目:
定数フィールド値

PARAM_WINDOW_NAME

public static final String PARAM_WINDOW_NAME
推奨されていません。
基本ウィンドウ名

関連項目:
定数フィールド値
コンストラクタの詳細

IntramartConnectUtil

public IntramartConnectUtil()
推奨されていません。
メソッドの詳細

getRequestInfo

public static IntramartConnectUtil.RequestInfo getRequestInfo(HttpServletRequest request,
                                                              HttpServletResponse response)
                                                       throws IOException,
                                                              ServletException
推奨されていません。
リクエスト情報を取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
リクエスト情報
例外:
IOException - 入出力例外が発生
ServletException - サーブレット例外が発生

configSession

public static boolean configSession(HttpServletRequest request,
                                    HttpServletResponse response,
                                    String loginUserIDKey,
                                    String loginUserID,
                                    String loginGroupIDKey,
                                    String loginGroupID,
                                    boolean referrerFormatShort)
                             throws IOException,
                                    ServletException
推奨されていません。
セッションにさまざまな情報を設定します。

パラメータ:
request - リクエスト
response - レスポンス
loginUserIDKey - ログインユーザIDのキー
loginUserID - ログインユーザID
loginGroupIDKey - ログイングループIDのキー
loginGroupID - ログイングループID
referrerFormatShort - intramartへのURLを省略式にするかどうかのフラグ
戻り値:
true:セッションへの登録に成功、false:セッションへの登録に失敗
例外:
IOException - 入出力例外が発生
ServletException - サーブレット例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartConnectUtil.RequestInfo (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.util
クラス IntramartConnectUtil.RequestInfo

java.lang.Object
    拡張 jp.co.intra_mart.framework.util.IntramartConnectUtil.RequestInfo
含まれているクラス:
IntramartConnectUtil
public static class IntramartConnectUtil.RequestInfo
extends Object

リクエスト情報です。

導入されたバージョン:
4.2

コンストラクタの概要
IntramartConnectUtil.RequestInfo(String application, String service)
メソッドの概要
String | getApplication() アプリケーションIDを取得します。
String | getService() サービスIDを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartConnectUtil.RequestInfo

public IntramartConnectUtil.RequestInfo(String application,
                                        String service)
メソッドの詳細

getApplication

public String getApplication()
アプリケーションIDを取得します。

戻り値:
アプリケーションID

getService

public String getService()
サービスIDを取得します。

戻り値:
サービスID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.util (j2ee_framework 6.1.14 API)

 jp.co.intra_mart.framework.util
クラス
FileResourceBundle
IntramartConnectUtil
IntramartConnectUtil.RequestInfo
SecurityUtil
XMLDocumentProducer
XMLNode


jp.co.intra_mart.framework.util (j2ee_framework 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.util

J2EEフレームワークで使用する各種のユーティリティです。

参照:
説明

クラスの概要
FileResourceBundle | java.util.ResourceBundle のファイル版です。
IntramartConnectUtil | 推奨されていません。 この機能は廃止されました。
IntramartConnectUtil.RequestInfo | リクエスト情報です。
SecurityUtil | セキュリティに関連するユーティリティです。
XMLDocumentProducer | XmlNodeを取得するクラスです。
XMLNode |

パッケージ jp.co.intra_mart.framework.util の説明

J2EEフレームワークで使用する各種のユーティリティです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.framework.util クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.util.IntramartConnectUtil
    • class jp.co.intra_mart.framework.util.IntramartConnectUtil.RequestInfo
    • class java.util.ResourceBundle
      • class jp.co.intra_mart.framework.util.FileResourceBundle
    • class jp.co.intra_mart.framework.util.SecurityUtil
    • class jp.co.intra_mart.framework.util.XMLDocumentProducer
    • class jp.co.intra_mart.framework.util.XMLNode
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.framework.util の使用 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.util の使用

jp.co.intra_mart.framework.util を使用しているパッケージ
jp.co.intra_mart.framework.util J2EEフレームワークで使用する各種のユーティリティです。

jp.co.intra_mart.framework.util により使用される jp.co.intra_mart.framework.util のクラス
IntramartConnectUtil.RequestInfo
推奨されていません。 リクエスト情報です。
XMLNode

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SecurityUtil (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.util
クラス SecurityUtil

java.lang.Object
    拡張 jp.co.intra_mart.framework.util.SecurityUtil
public class SecurityUtil
extends Object

セキュリティに関連するユーティリティです。

導入されたバージョン:
4.3

コンストラクタの概要
SecurityUtil()
メソッドの概要
static String createCheckSum(String applicationID, String serviceID, HttpSession httpSession)
暗号を作成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SecurityUtil

public SecurityUtil()
メソッドの詳細

createCheckSum

public static String createCheckSum(String applicationID,
                                    String serviceID,
                                    HttpSession httpSession)
                             throws ServletException
暗号を作成します。

パラメータ:
applicationID - アプリケーションID
serviceID - サービスID
httpSession - セッション情報
戻り値:
暗号化クエリー
例外:
ServletException - フィルタ内で例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XMLDocumentProducer (j2ee_framework 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.util
クラス XMLDocumentProducer

java.lang.Object
    拡張 jp.co.intra_mart.framework.util.XMLDocumentProducer
public class XMLDocumentProducer
extends Object

XmlNodeを取得するクラスです。

コンストラクタの概要
XMLDocumentProducer()
メソッドの概要
Document | getDocument(String fileName) プロパティハンドラを初期化します。
static String | getFileName(String name, Locale locale) ファイル名を取得します。
Node | getRoot(Document doc_node) ノードを取得します。
static boolean | isFileExist(String name, Locale locale) ファイルが存在するか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

XMLDocumentProducer

public XMLDocumentProducer()
メソッドの詳細

getDocument

public Document getDocument(String fileName)
                     throws ParserConfigurationException,
                            SAXException,
                            IOException,
                            IllegalArgumentException
プロパティハンドラを初期化します。

パラメータ:
fileName - xmlファイルの名前
例外:
ParserConfigurationException
SAXException
IOException
IllegalArgumentException

getRoot

public Node getRoot(Document doc_node)
ノードを取得します。

パラメータ:
doc_node - ドキュメントノード
戻り値:
Node ノード

isFileExist

public static boolean isFileExist(String name,
                                  Locale locale)
ファイルが存在するか調べます。

パラメータ:
name - アプリケーション名
locale - ロケール
戻り値:
boolean ファイルの存在有無

getFileName

public static String getFileName(String name,
                                 Locale locale)
ファイル名を取得します。

パラメータ:
name - アプリケーション名
locale - ロケール
戻り値:
String ファイル名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XMLNode (j2ee_framework 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.util
クラス XMLNode

java.lang.Object
    拡張 jp.co.intra_mart.framework.util.XMLNode
public class XMLNode
extends Object

コンストラクタの概要
XMLNode(Attr n)
コンストラクタです。
XMLNode(Document d)
コンストラクタです。
XMLNode(Element n)
コンストラクタです。
XMLNode(Node n)
コンストラクタです。
XMLNode(Node p, Node n)
コンストラクタです。
メソッドの概要
XMLNode | addAttr(String attr, String value) Attributeを追加します。
XMLNode | addNode(String name) Nodeを追加します。
XMLNode | addNode(String name, String target) Nodeを追加します。
XMLNode | delAttr(String attr) Attributeを削除します。
XMLNode | delNode() Nodeを削除します。
XMLNode | delNode(String tag) Nodeを削除します。
XMLNode | delNode(XMLNode child) Nodeを削除します。
XMLNode[] | getChildNode() 子NodeListを返却します。
double | getDouble(String sName) 指定項目に設定されている値を数値に変換して返します。
double | getDouble(String sName, double nInit) 指定項目に設定されている値を数値に変換して返します。
float | getFloat(String sName) 指定項目に設定されている値を数値に変換して返します。
float | getFloat(String sName, float nInit) 指定項目に設定されている値を数値に変換して返します。
int | getInteger(String sName) 指定項目に設定されている値を整数に変換して返します。
int | getInteger(String sName, int nInit) 指定項目に設定されている値を整数に変換して返します。
long | getLong(String sName) 指定項目に設定されている値を整数に変換して返します。
long | getLong(String sName, long nInit) 指定項目に設定されている値を整数に変換して返します。
Node | getNode() Nodeを取得します。
XMLNode[] | getNodeList() NodeListを返却します。
String | getNodeName() ノード名を返却します。
String | getString(String aName) プロパティを取得します。
String | getString(String sName, String def) プロパティを取得します。
String | getURI() URIを返却します。
String | getURI(String root) URIを取得します。
String | getValue() 値を取得します。
String | getValue(String def) 値を取得します。
boolean | isFalse(String sName) 設定データが偽値判定であるかをチェックします。
boolean | isTrue(String sName) 設定データが真値判定であるかをチェックします。
boolean | isValid(String sName) 設定ファイル内に指定項目が定義されているかどうかを チェックします。
XMLNode | lookup(String tags) XMLNodeを返却します。
XMLNode | lookup(Vector tags) XMLNodeを返却します。
void | removeValue() 値を削除します。
XMLNode[] | select(String tags) ノードの配列を返却します。
void | setNodeName(String name) ノード名を設定します。
void | setValue(String str) 値を設定します。
void | setValue(String tags, String str) 値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

XMLNode

public XMLNode(Document d)
コンストラクタです。

パラメータ:
d - Document

XMLNode

public XMLNode(Element n)
コンストラクタです。

パラメータ:
n - Element

XMLNode

public XMLNode(Attr n)
コンストラクタです。

パラメータ:
n - Attr

XMLNode

public XMLNode(Node n)
コンストラクタです。

XMLNode

public XMLNode(Node p,
               Node n)
コンストラクタです。

メソッドの詳細

getNodeName

public String getNodeName()
ノード名を返却します。

戻り値:
String ノード名

setNodeName

public void setNodeName(String name)
ノード名を設定します。

lookup

public XMLNode lookup(String tags)
XMLNodeを返却します。

戻り値:
XMLNode

lookup

public XMLNode lookup(Vector tags)
XMLNodeを返却します。

戻り値:
XMLNode

select

public XMLNode[] select(String tags)
ノードの配列を返却します。

戻り値:
XMLNode[] ノード配列

addAttr

public XMLNode addAttr(String attr,
                       String value)
Attributeを追加します。

戻り値:
XMLNode

delAttr

public XMLNode delAttr(String attr)
Attributeを削除します。

戻り値:
XMLNode

addNode

public XMLNode addNode(String name)
Nodeを追加します。

戻り値:
XMLNode

addNode

public XMLNode addNode(String name,
                       String target)
Nodeを追加します。

パラメータ:
name -
target -
戻り値:
XMLNode

delNode

public XMLNode delNode(String tag)
Nodeを削除します。

パラメータ:
tag -
戻り値:
XMLNode

delNode

public XMLNode delNode(XMLNode child)
Nodeを削除します。

パラメータ:
child -
戻り値:
XMLNode

delNode

public XMLNode delNode()
Nodeを削除します。

戻り値:
XMLNode

getNode

public Node getNode()
Nodeを取得します。

戻り値:
Node

getValue

public String getValue()
値を取得します。

戻り値:
String

getValue

public String getValue(String def)
値を取得します。

パラメータ:
def -
戻り値:
String

setValue

public void setValue(String str)
値を設定します。

パラメータ:
str -

setValue

public void setValue(String tags,
                     String str)
値を設定します。

パラメータ:
tags -
str -

removeValue

public void removeValue()
値を削除します。

getNodeList

public XMLNode[] getNodeList()
NodeListを返却します。

戻り値:
XMLNode[]

getChildNode

public XMLNode[] getChildNode()
子NodeListを返却します。

戻り値:
XMLNode[]

getURI

public String getURI()
URIを返却します。

戻り値:
String

getURI

public String getURI(String root)
URIを取得します。

パラメータ:
root -
戻り値:
String URI

getString

public String getString(String aName)
プロパティを取得します。

パラメータ:
aName - キー
戻り値:
String キーに対する値

getString

public String getString(String sName,
                        String def)
プロパティを取得します。

パラメータ:
sName - キー
def - デフォルト値
戻り値:
String キーに対する値

getFloat

public float getFloat(String sName,
                      float nInit)
指定項目に設定されている値を数値に変換して返します。 返却値は浮動小数点数として返します。 値を正しく数値に変換できなかった場合には、初期値(第二引数)を 返します。 初期値とは、その項目が未設定時に返却する値のことです。 指定初期値の型はチェックしません。

パラメータ:
sName - 設定項目名
nInit - 初期値
戻り値:
float 設定値（数値）または指定初期値

getFloat

public float getFloat(String sName)
指定項目に設定されている値を数値に変換して返します。 返却値は浮動小数点数として返します。 値を正しく数値に変換できなかった場合には、“0”(ZERO)を 返します。

パラメータ:
sName - 設定項目名
戻り値:
float 設定値（数値）

getDouble

public double getDouble(String sName,
                        double nInit)
指定項目に設定されている値を数値に変換して返します。 返却値は浮動小数点数として返します。 値を正しく数値に変換できなかった場合には、初期値(第二引数)を 返します。 初期値とは、その項目が未設定時に返却する値のことです。 指定初期値の型はチェックしません。

パラメータ:
sName - 設定項目名
nInit - 初期値
戻り値:
double 設定値（数値）または指定初期値

getDouble

public double getDouble(String sName)
指定項目に設定されている値を数値に変換して返します。 返却値は浮動小数点数として返します。 値を正しく数値に変換できなかった場合には、“0”(ZERO)を 返します。

パラメータ:
sName - 設定項目名
戻り値:
double 設定値（数値）

getInteger

public int getInteger(String sName,
                      int nInit)
指定項目に設定されている値を整数に変換して返します。 返却値は整数として返します。 値を正しく整数に変換できなかった場合には、初期値(第二引数)を 返します。 初期値とは、その項目が未設定時に返却する値のことです。 指定初期値の型はチェックしません。

パラメータ:
sName - 設定項目名
nInit - 初期値
戻り値:
int 設定値（数値）または指定初期値

getInteger

public int getInteger(String sName)
指定項目に設定されている値を整数に変換して返します。 返却値は整数として返します。 値を正しく整数に変換できなかった場合には、“0”(ZERO)を 返します。

パラメータ:
sName - 設定項目名
戻り値:
int 設定値（数値）

getLong

public long getLong(String sName,
                    long nInit)
指定項目に設定されている値を整数に変換して返します。 返却値は整数として返します。 値を正しく整数に変換できなかった場合には、初期値(第二引数)を 返します。 初期値とは、その項目が未設定時に返却する値のことです。 指定初期値の型はチェックしません。

パラメータ:
sName - 設定項目名
nInit - 初期値
戻り値:
long 設定値（数値）または指定初期値

getLong

public long getLong(String sName)
指定項目に設定されている値を整数に変換して返します。 返却値は整数として返します。 値を正しく整数に変換できなかった場合には、“0”(ZERO)を 返します。

パラメータ:
sName - 設定項目名
戻り値:
long 設定値（数値）

isValid

public boolean isValid(String sName)
設定ファイル内に指定項目が定義されているかどうかを チェックします。

パラメータ:
sName - imart.ini 内の設定項目名
戻り値:
boolean 設定ファイル内の情報定義有無

isTrue

public boolean isTrue(String sName)
設定データが真値判定であるかをチェックします。 設定データが真値である条件は以下のとおり。 値が、“ON”または“TRUE”の場合。 大文字・小文字の区別あり。 指定項目が未定義の場合には偽値を返します。

パラメータ:
sName - 設定項目名
戻り値:
boolean 設定データ真偽値

isFalse

public boolean isFalse(String sName)
設定データが偽値判定であるかをチェックします。 設定データが偽値である条件は以下のとおり。 値が、“OFF”または“FALSE”の場合。 大文字・小文字の区別あり。 指定項目が未定義の場合には偽値を返します。

パラメータ:
sName - 設定項目名
戻り値:
boolean 設定データ真偽値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


すべてのクラス (j2ee_framework 6.1.14 API)

 すべてのクラス
ApplicationException
Config
ConfigurationUserInfo
ConnectorModel
ControllerConverter
ControllerConverterConfig
ControllerConverterConfigImpl
ControllerConverterException
ControllerConverterModel
ControllerObject
CoreAttributes
DAO
DAOAdapter
DAOException
DBConnector
DBDAO
DaoModel
DataAccessController
DataAccessException
DataConnectException
DataConnector
DataConnectorException
DataContainer
DataContainerException
DataContainerFactory
DataContainerImpl
DataManager
DataManagerException
DataPropertyException
DataPropertyHandler
DataSourceConnector
DefaultDataPropertyHandler
DefaultDataProvider
DefaultEventPropertyHandler
DefaultEventProvider
DefaultLogAgent
DefaultLogPropertyHandler
DefaultMessagePropertyHandler
DefaultMessagePropertyHandler
DefaultPropertyManager
DefaultServicePropertyHandler
DefaultServiceProvider
DefaultSessionPropertyHandler
DefaultTransition
DistributesDataPropertyHandler
DistributesEventPropertyHandler
DistributesServicePropertyHandler
EJBEventListener
EJBEventListenerAgentBean
EJBEventListenerFactory
EmptyEvent
EmptyServiceResult
EmptyUserInfo
EncodingFilter
ErrorHelperBean
Event
EventContainer
EventContainerException
EventContainerFactory
EventContainerImpl
EventException
EventFactoryModel
EventGroupModel
EventListener
EventListenerException
EventListenerFactory
EventListenerFactoryParam
EventManager
EventManagerException
EventModelProducer
EventPropertyException
EventPropertyHandler
EventResult
EventTrigger
EventTriggerAdapter
EventTriggerException
EventTriggerInfo
EventTriggerList
EventsAttributes
FileResourceBundle
FileUploadFilter
FormTEI
FormTag
FormTagBeanInfo
FormatValidator
FrameTEI
FrameTag
FrameTagBeanInfo
FrameworkException
FrameworkParameterSettingFilter
FrameworkRuntimeException
FrameworkTagException
FrameworkTagParam
GenericAttributes
GenericEJBEventListener
GenericEJBEventListenerAgent
GenericEJBEventListenerAgentBean
GenericEJBEventListenerAgentHome
GenericEJBEventListenerAgentLocal
GenericEJBEventListenerAgentLocalHome
GenericEJBEventListenerFactory
GenericEJBEventListenerLocal
GenericEJBEventListenerLocalFactory
GenericEventListener
GenericEventListenerFactory
HTMLEncoder
HelperBean
HelperBeanException
HelperBeanTEI
HelperBeanTag
HelperBeanTagBeanInfo
HttpSessionFactory
HttpSessionObject
I18nAttributes
IMContainer
IMContainerException
IMContainerFactory
IllegalSessionException
IllegalSystemException
IntramartConnectFilter
IntramartConnectServlet
IntramartConnectUtil
IntramartConnectUtil.RequestInfo
IntramartDBConnector
IntramartDBDAO
IntramartFileServerConnector
IntramartFileServerDAO
IntramartLocaleFilter
IntramartLogAgent
IntramartMessagePropertyHandler
IntramartPageBaseTransition
IntramartSessionFactory
IntramartSessionObject
JDBCConnector
LengthValidator
LinkTEI
LinkTag
LinkTagBeanInfo
LocaleFilter
LogAgent
LogAgentParam
LogConstant
LogManager
LogPropertyException
LogPropertyHandler
LoginGroupDBConnector
LoginGroupDBDAO
MessageManager
MessageManager
MessageManagerException
MessageManagerException
MessageParamTag
MessagePropertyException
MessagePropertyException
MessagePropertyHandler
MessagePropertyHandler
MessagePropertyParam
MessageTEI
MessageTag
NumericRangeValidator
NumericValidator
ParamTag
ParameterSendable
PropertyConfigModel
PropertyHandler
PropertyHandlerException
PropertyHandlerParam
PropertyManager
PropertyManagerException
PropertyModel
PropertyParam
Provider
RequestException
RequestFormatException
RequestInfo
ResourceModel
ResourceParam
SecurityUtil
ServiceContainer
ServiceContainerException
ServiceContainerFactory
ServiceContainerImpl
ServiceController
ServiceControllerAdapter
ServiceControllerException
ServiceManager
ServiceManagerException
ServicePropertyException
ServicePropertyHandler
ServiceResult
ServiceSecurityFilter
ServiceServlet
ServiceServletException
SessionFactory
SessionFactoryException
SessionFilter
SessionManager
SessionManagerException
SessionObject
SessionObjectException
SessionPropertyException
SessionPropertyHandler
SimpleControllerConverter
StandardEJBEventListener
StandardEJBEventListenerAgent
StandardEJBEventListenerAgentBean
StandardEJBEventListenerAgentHome
StandardEJBEventListenerFactory
StandardEventListener
StandardEventListenerFactory
SubmitLinkTag
SubmitLinkTagBeanInfo
SubmitTEI
SubmitTag
SubmitTagBeanInfo
SystemDBConnector
SystemDBDAO
SystemException
TagWriter
TextFileDataPropertyHandler
TextFileEventPropertyHandler
TextFileMessagePropertyHandler
TextFileServicePropertyHandler
Transition
TransitionException
UserInfo
UserInfoException
UserInfoUtil
UserInfoWrapper
ValidationException
ValidationExceptionDetail
Validator
ValidatorConfig
ValidatorConfigImpl
ValidatorException
ValidatorMapping
ValidatorModel
XMLDocumentProducer
XMLNode
XmlDataPropertyHandler
XmlEventPropertyHandler
XmlLogPropertyHandler
XmlPropertyManager
XmlServicePropertyHandler
XmlSessionPropertyHandler


定数フィールド値 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
  • jp.co.*
jp.co.*

jp.co.intra_mart.framework.base.data.ConnectorModel
public static final String | ID | "connector"
public static final String | P_ID_CONNECTOR_CLASS | "connector-class"
public static final String | P_ID_CONNECTOR_NAME | "connector-name"
public static final String | P_ID_RESOURCE_NAME | "resource-name"

jp.co.intra_mart.framework.base.data.DaoModel
public static final String | ID | "dao"
public static final String | P_ID_CONNECT_NAME | "connect-name"
public static final String | P_ID_DAO_CLASS | "dao-class"
public static final String | P_ID_DAO_CONNECTOR_NAME | "connector-name"

jp.co.intra_mart.framework.base.data.DataManager
public static final String DATA_PROPERTY_HANDLER_KEY "data"

jp.co.intra_mart.framework.base.data.DataSourceConnector
public static final String KEY_JNDI_NAME "jndi"

jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "DataConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "DataConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"
public static final String | PARAM_APPLICATION | "application"
public static final String | PARAM_APPLICATION_CLASS | "class"
public static final String | PARAM_APPLICATION_PARAM | "param"
public static final String | PARAM_BUNDLE | "bundle"
public static final String | PARAM_DEFAULT | "default"
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.data.JDBCConnector
public static final String | KEY_DRIVER | "driver"
public static final String | KEY_PASSWORD | "password"
public static final String | KEY_URL | "url"
public static final String | KEY_USERNAME | "username"

jp.co.intra_mart.framework.base.data.ResourceModel
public static final String | ID | "resource"
public static final String | P_ID_PARAM_NAME | "param-name"
public static final String | P_ID_PARAM_VALUE | "param-value"
public static final String | P_ID_RESOURCE_NAME | "resource-name"
public static final String | P_ID_RESOURCE_PARAM | "init-param"

jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "data-config"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"
public static final String | PARAM_DYNAMIC | "dynamic"

jp.co.intra_mart.framework.base.data.container.DataContainer
public static final String DATA_PROPERTY_HANDLER_KEY "data"

jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "EventConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "EventConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"
public static final String | PARAM_APPLICATION | "application"
public static final String | PARAM_APPLICATION_CLASS | "class"
public static final String | PARAM_APPLICATION_PARAM | "param"
public static final String | PARAM_BUNDLE | "bundle"
public static final String | PARAM_DEFAULT | "default"
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.event.EJBEventListenerFactory
public static final String HOME_PARAM "home"

jp.co.intra_mart.framework.base.event.EventFactoryModel
public static final String | ID | "event-factory"
public static final String | P_ID_FACTORY_CLASS | "factory-class"
public static final String | P_ID_FACTORY_PARAM | "init-param"
public static final String | P_ID_PARAM_NAME | "param-name"
public static final String | P_ID_PARAM_VALUE | "param-value"

jp.co.intra_mart.framework.base.event.EventGroupModel
public static final String | ID | "event-group"
public static final String | P_ID_EVENT_KEY | "event-key"
public static final String | P_ID_EVENT_NAME | "event-class"
public static final String | P_ID_POST_TRIGGER | "post-trigger"
public static final String | P_ID_PRE_TRIGGER | "pre-trigger"
public static final String | P_ID_TRIGGER_CLASS | "trigger-class"

jp.co.intra_mart.framework.base.event.EventManager
public static final String EVENT_PROPERTY_HANDLER_KEY "event"

jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory
public static final String LISTENER_PARAM "listener"

jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory
public static final String LISTENER_PARAM "listener"

jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "event-config"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"
public static final String | PARAM_DYNAMIC | "dynamic"

jp.co.intra_mart.framework.base.event.container.EventContainer
public static final String EVENT_PROPERTY_HANDLER_KEY "event"

jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "MessageConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.base.message.MessageManager
public static final String MESSAGE_PROPERTY_HANDLER_KEY "i18n_message"

jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.service.ControllerConverterModel
public static final String | ID | "controller-converter"
public static final String | P_ID_CONVERTER_CLASS | "converter-class"
public static final String | P_ID_CONVERTER_PARAM | "init-param"
public static final String | P_ID_PARAM_NAME | "param-name"
public static final String | P_ID_PARAM_VALUE | "param-value"

jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "ServiceConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "ServiceConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"
public static final String | PARAM_APPLICATION | "application"
public static final String | PARAM_APPLICATION_CLASS | "class"
public static final String | PARAM_APPLICATION_PARAM | "param"
public static final String | PARAM_BUNDLE | "bundle"
public static final String | PARAM_DEFAULT | "default"
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.service.IntramartConnectFilter
public static final String | INTRAMART_URL_NAME | "jp.co.intra_mart.framework.base.service.IntramartConnectServlet.intramart"
public static final String | PARAM_ARGUMENT | "argument"
public static final String | PARAM_ARGUMENT_DELIMITER | ","
public static final String | PARAM_ARGUMENT_OPERATOR | "="
public static final String | PARAM_LOGIN_GROUP_ID | "group"
public static final String | PARAM_LOGIN_USER_ID | "account"
public static final String | PARAM_REFERER | "referrer"
public static final String | PARAM_SECURITY_EXT | "securityExt"

jp.co.intra_mart.framework.base.service.IntramartConnectServlet
public static final String | INTRAMART_URL_NAME | "jp.co.intra_mart.framework.base.service.IntramartConnectServlet.intramart"
public static final String | PARAM_ARGUMENT | "argument"
public static final String | PARAM_ARGUMENT_DELIMITER | ","
public static final String | PARAM_ARGUMENT_OPERATOR | "="
public static final String | PARAM_LOGIN_GROUP_ID | "group"
public static final String | PARAM_LOGIN_USER_ID | "account"
public static final String | PARAM_REFERER | "referrer"

jp.co.intra_mart.framework.base.service.ServiceManager
public static final String | DEFAULT_SERVICE_EXTENSION | "service"
public static final String | SERVICE_EXTENSION_KEY | "jp.co.intra_mart.framework.base.service.ServiceManager.extesion"
public static final String | SERVICE_PROPERTY_HANDLER_KEY | "service"

jp.co.intra_mart.framework.base.service.ServicePropertyHandler
public static final String | DEFAULT_APPLICATION_PARAMETER | "application"
public static final String | DEFAULT_ENCODING_ATTRIBUTE | "jp.co.intra_mart.framework.base.service.encoding"
public static final String | DEFAULT_EXCEPTION_ATTRIBUTE | "exception"
public static final String | DEFAULT_LOCALE_ATTRIBUTE | "jp.co.intra_mart.framework.base.service.locale"
public static final String | DEFAULT_SERVICE_PARAMETER | "service"
public static final String | REQUEST_INFO_ATTRIBUTE | "REQUEST_INFO_ATTRIBUTE"

jp.co.intra_mart.framework.base.service.ServiceSecurityFilter
public static final String | ID_SERVICE_SECURITY_FILTER | "jp.co.intra_mart.framework.base.service.ServiceSecurityFilter"
public static final String | PARAM_ERROR_PAGE | "error-page"

jp.co.intra_mart.framework.base.service.ServiceServlet
public static final String REQUEST_SEPARATOR "-"

jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.service.ValidatorModel
public static final String | ID | "validator"
public static final String | P_ID_PARAM_NAME | "param-name"
public static final String | P_ID_PARAM_VALUE | "param-value"
public static final String | P_ID_VALIDATOR_CLASS | "validator-class"
public static final String | P_ID_VALIDATOR_PARAM | "init-param"

jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "service-config"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"
public static final String | PARAM_DYNAMIC | "dynamic"

jp.co.intra_mart.framework.base.service.container.ServiceContainer
public static final String SERVICE_PROPERTY_HANDLER_KEY "service"

jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter
public static final String OBJECT_PARAM_NAME "object"

jp.co.intra_mart.framework.base.service.validator.FormatValidator
public static final String | PARAM_MESSAGE | "message"
public static final String | PARAM_PROPERTY | "property"
public static final String | PARAM_REGEX | "regex"

jp.co.intra_mart.framework.base.service.validator.LengthValidator
public static final String | PARAM_MAX | "max"
public static final String | PARAM_MESSAGE_LONG | "message_long"
public static final String | PARAM_MESSAGE_SHORT | "message_short"
public static final String | PARAM_MIN | "min"
public static final String | PARAM_PROPERTY | "property"

jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator
public static final String | PARAM_MAX | "max"
public static final String | PARAM_MESSAGE | "message"
public static final String | PARAM_MIN | "min"
public static final String | PARAM_PROPERTY | "property"

jp.co.intra_mart.framework.base.service.validator.NumericValidator
public static final String | PARAM_MESSAGE | "message"
public static final String | PARAM_PROPERTY | "property"

jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "SessionConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.base.session.SessionManager
public static final String SESSION_PROPERTY_HANDLER_KEY "session"

jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "session-config"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.base.util.UserInfoUtil
public static final String | LT_GROUP | "group"
public static final String | LT_SUPER | "super"
public static final String | LT_USER | "user"

jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "LogConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.system.log.IntramartLogAgent
public static final String TYPE_DB "DB"

jp.co.intra_mart.framework.system.log.LogConstant
public static final String | CATEGORY_BEGIN_TRANSACTION | "BEGIN_TRANSACTION"
public static final String | CATEGORY_COMMIT_TRANSACTION | "COMMIT_TRANSACTION"
public static final String | CATEGORY_ROLLBACK_TRANSACTION | "ROLLBACK_TRANSACTION"
public static final String | LEVEL_DEBUG | "DEBUG"
public static final String | LEVEL_ERROR | "ERROR"
public static final String | LEVEL_INFO | "INFO"
public static final String | LEVEL_WARNNING | "WARNNING"

jp.co.intra_mart.framework.system.log.LogManager
public static final String LOG_PROPERTY_HANDLER_KEY "log"

jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "log-config"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "MessageConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.system.message.MessageManager
public static final String MESSAGE_PROPERTY_HANDLER_KEY "message"

jp.co.intra_mart.framework.system.property.DefaultPropertyManager
public static final String | DEFAULT_BUNDLE_NAME | "/PropertyConfig.properties"
public static final String | KEY | "jp.co.intra_mart.framework.system.property.DefaultPropertyManager"

jp.co.intra_mart.framework.system.property.PropertyManager
public static final String | DEFAULT_SYSTEM_MANAGER | "jp.co.intra_mart.framework.system.property.XmlPropertyManager"
public static final String | KEY | "jp.co.intra_mart.framework.system.property.PropertyManager"

jp.co.intra_mart.framework.system.property.XmlPropertyManager
public static final String | DEFAULT_BUNDLE_NAME | "property-config.xml"
public static final String | KEY | "jp.co.intra_mart.framework.system.property.XmlPropertyManager"

jp.co.intra_mart.framework.util.IntramartConnectUtil
public static final String | INTRAMART_URL_NAME | "jp.co.intra_mart.framework.base.service.IntramartConnectServlet.intramart"
public static final String | PARAM_ARGUMENT | "argument"
public static final String | PARAM_LOGIN_GROUP_ID | "group"
public static final String | PARAM_LOGIN_USER_ID | "account"
public static final String | PARAM_REFERER | "referrer"
public static final String | PARAM_REFERER_FORMAT | "referrerFormat"
public static final String | PARAM_WINDOW_NAME | "IM_MAIN"

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


非推奨 API のリスト (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

推奨されていない API

推奨されていないクラス
jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter
このフィルタは下位互換のためのフィルタです。将来廃止される可能性があります。
jp.co.intra_mart.framework.base.session.HttpSessionFactory
このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.session.HttpSessionObject
このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.service.IntramartConnectFilter
この機能は廃止されました。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet
この機能は廃止されました。
jp.co.intra_mart.framework.util.IntramartConnectUtil
この機能は廃止されました。
jp.co.intra_mart.framework.base.data.IntramartDBConnector
このクラスではなくLoginGroupDBConnectorまたは SystemDBConnectorを使用してください。
jp.co.intra_mart.framework.base.data.IntramartDBDAO
このクラスではなくLoginGroupDBDAOまたは SystemDBDAOを使用してください。
jp.co.intra_mart.framework.base.session.IntramartSessionFactory
このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.session.IntramartSessionObject
このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.data.JDBCConnector
JDBCを直接扱わず、DataSourceを使用するようにしてください。

推奨されていないフィールド
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.DEFAULT_APPLICATION_PARAMETER
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.DEFAULT_SERVICE_PARAMETER
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.INTRAMART_URL_NAME
このパラメータではなくIntramartConnectFilter.INTRAMART_URL_NAMEを使用してください。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.PARAM_ARGUMENT
このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENTを使用してください。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.PARAM_ARGUMENT_DELIMITER
このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_DELIMITERを使用してください。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.PARAM_ARGUMENT_OPERATOR
このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_OPERATORを使用してください。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.PARAM_LOGIN_GROUP_ID
このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_GROUP_IDを使用してください。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.PARAM_LOGIN_USER_ID
このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_USER_IDを使用してください。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.PARAM_REFERER
このパラメータではなくIntramartConnectFilter.PARAM_REFERERを使用してください。

推奨されていないメソッド
jp.co.intra_mart.framework.base.event.EventManager.createEvent(String, String, String, String)
このメソッドではなくEventManager.createEvent(String, String, UserInfo)を使用してください。
jp.co.intra_mart.framework.base.web.tag.TagWriter.createURL(String, Collection)
このメソッドではなくTagWriter.createURL(String, Collection, String)を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getApplicationParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getApplicationParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getApplicationParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getApplicationParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getContextPath()
このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getContextPath()
このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getContextPath()
このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getContextPath()
このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getContextPath()
このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
jp.co.intra_mart.framework.base.web.tag.FrameTag.getFrameClass()
このメソッドではなくFrameTag.getFrameclass()メソッドを使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getInputErrorPagePath()
このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getInputErrorPagePath()
このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getInputErrorPagePath()
このメソッドではなくServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getInputErrorPagePath()
このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getInputErrorPagePath()
このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getInputErrorPagePath(String)
このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getInputErrorPagePath(String)
このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getInputErrorPagePath(String)
このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getInputErrorPagePath(String)
このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getInputErrorPagePath(String)
このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getInputErrorPagePath(String, String)
このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getInputErrorPagePath(String, String)
このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getInputErrorPagePath(String, String)
このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getInputErrorPagePath(String, String)
このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getInputErrorPagePath(String, String)
このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getInputErrorPagePath(String, String, String)
このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getInputErrorPagePath(String, String, String)
このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getInputErrorPagePath(String, String, String)
このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getInputErrorPagePath(String, String, String)
このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getInputErrorPagePath(String, String, String)
このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.web.tag.LinkTag.getLinkClass()
このメソッドではなくLinkTag.getLinkclass()メソッドを使用してください。
jp.co.intra_mart.framework.base.event.Event.getLoginGroup()
このメソッドではなくEvent.getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.event.Event.getLoginGroupID()
このメソッドではなくEvent.getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.service.ServiceControllerAdapter.getLoginGroupID()
このメソッドではなくServiceControllerAdapter.getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.web.bean.HelperBean.getLoginGroupID()
このメソッドではなくHelperBean.getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.event.Event.getLoginUser()
このメソッドではなくEvent.getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.event.Event.getLoginUserID()
このメソッドではなくEvent.getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.service.ServiceControllerAdapter.getLoginUserID()
このメソッドではなくServiceControllerAdapter.getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.web.bean.HelperBean.getLoginUserID()
このメソッドではなくHelperBean.getUserInfo()を使用してください。
jp.co.intra_mart.framework.system.message.MessagePropertyHandler.getMessage(String, String)
intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
MessagePropertyHandler.getMessage(String)を使用してください。
jp.co.intra_mart.framework.system.message.MessageManager.getMessage(String, String)
intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
設定されているMessagePropertyHandlerによっては、 パラメータloginGroupは実際には使用しない可能性があります。MessageManager.getMessage(String)を使用してください。
jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler.getMessage(String, String)
intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
パラメータloginGroupは実際には使用しません。IntramartMessagePropertyHandler.getMessage(String)を使用してください。
jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler.getMessage(String, String)
intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
DefaultMessagePropertyHandler.getMessage(String)を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getNextPagePath(String, String)
このメソッドではなく XmlServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getNextPagePath(String, String)
このメソッドではなくTextFileServicePropertyHandler.getNextPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getNextPagePath(String, String)
このメソッドではなくServicePropertyHandler.getNextPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getNextPagePath(String, String)
このメソッドではなく DistributesServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getNextPagePath(String, String)
このメソッドではなく DefaultServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getNextPagePath(String, String, String)
このメソッドではなく XmlServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getNextPagePath(String, String, String)
このメソッドではなくTextFileServicePropertyHandler.getNextPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getNextPagePath(String, String, String)
このメソッドではなくServicePropertyHandler.getNextPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getNextPagePath(String, String, String)
このメソッドではなく DistributesServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getNextPagePath(String, String, String)
このメソッドではなく DefaultServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.ServiceManager.getServiceController(String, String)
このメソッドではなくServiceManager.getServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getServiceControllerName(String, String)
このメソッドではなく XmlServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getServiceControllerName(String, String)
このメソッドではなくTextFileServicePropertyHandler.getServiceControllerName(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceControllerName(String, String)
このメソッドではなくServicePropertyHandler.getServiceControllerName(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getServiceControllerName(String, String)
このメソッドではなく DistributesServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getServiceControllerName(String, String)
このメソッドではなく DefaultServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getServiceErrorPagePath()
このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getServiceErrorPagePath()
このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceErrorPagePath()
このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getServiceErrorPagePath()
このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getServiceErrorPagePath()
このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getServiceErrorPagePath(String)
このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getServiceErrorPagePath(String)
このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceErrorPagePath(String)
このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getServiceErrorPagePath(String)
このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getServiceErrorPagePath(String)
このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getServiceErrorPagePath(String, String)
このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getServiceErrorPagePath(String, String)
このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceErrorPagePath(String, String)
このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getServiceErrorPagePath(String, String)
このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getServiceErrorPagePath(String, String)
このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getServiceErrorPagePath(String, String, String)
このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getServiceErrorPagePath(String, String, String)
このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceErrorPagePath(String, String, String)
このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, String)
このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, String)
このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getServiceParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getServiceParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getServiceParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceServletPath()
この実装は廃止されました。
jp.co.intra_mart.framework.base.web.bean.HelperBean.getSession()
このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler.getSessionFactoryName()
セッションとしてはHttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.session.SessionPropertyHandler.getSessionFactoryName()
セッションとしてはHttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler.getSessionFactoryName()
セッションとしてはHttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.service.Transition.getSessionObject()
このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler.getSessionObjectKey()
HttpSessionを直接取得するようにしてください。
jp.co.intra_mart.framework.base.session.SessionPropertyHandler.getSessionObjectKey()
HttpSessionを直接取得するようにしてください。
jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler.getSessionObjectKey()
HttpSessionを直接取得するようにしてください。
jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler.getSessionParameter()
HttpSessionを直接使用する場合、このメソッドは不要になります。
jp.co.intra_mart.framework.base.session.SessionPropertyHandler.getSessionParameter()
HttpSessionを直接使用する場合、このメソッドは不要になります。
jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler.getSessionParameter()
HttpSessionを直接使用する場合、このメソッドは不要になります。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getSystemErrorPagePath()
このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getSystemErrorPagePath()
このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getSystemErrorPagePath()
このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getSystemErrorPagePath()
このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getSystemErrorPagePath()
このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getSystemErrorPagePath(String)
このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getSystemErrorPagePath(String)
このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getSystemErrorPagePath(String)
このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getSystemErrorPagePath(String)
このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getSystemErrorPagePath(String)
このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getSystemErrorPagePath(String, String)
このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getSystemErrorPagePath(String, String)
このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getSystemErrorPagePath(String, String)
このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getSystemErrorPagePath(String, String)
このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getSystemErrorPagePath(String, String)
このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getSystemErrorPagePath(String, String, String)
このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getSystemErrorPagePath(String, String, String)
このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getSystemErrorPagePath(String, String, String)
このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, String)
このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, String)
このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.ServiceManager.getTransition(String, String)
このメソッドではなくServiceManager.getTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getTransitionName(String, String)
このメソッドではなく XmlServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getTransitionName(String, String)
このメソッドではなくTextFileServicePropertyHandler.getTransitionName(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getTransitionName(String, String)
このメソッドではなくServicePropertyHandler.getTransitionName(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getTransitionName(String, String)
このメソッドではなく DistributesServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getTransitionName(String, String)
このメソッドではなく DefaultServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.web.tag.HelperBeanTag.setClass(String)
このメソッドではなくHelperBeanTag.setHelperclass(java.lang.String)メソッドを使用してください。
jp.co.intra_mart.framework.base.web.tag.FrameTag.setFrameClass(String)
このメソッドではなくFrameTag.setFrameclass(String)メソッドを使用してください。
jp.co.intra_mart.framework.base.web.tag.LinkTag.setLinkClass(String)
このメソッドではなくLinkTag.setLinkclass(String)メソッドを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


API ヘルプ (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

API ドキュメントの構成

この API (Application Programming Interface) ドキュメントには、次に説明するナビゲーションバーにある項目に対応するページが含まれます。

概要

概要 ページは API ドキュメントのフロントページで、各パッケージの概要を含む全パッケージの一覧が表示されます。一連のパッケージの概要説明も表示されます。

パッケージ

各パッケージは、そのパッケージのクラスとインタフェースへのリンクを含むページを持ちます。このページは 4 つのカテゴリで構成されます:

  • インタフェース (イタリック)
  • クラス
  • 例外
  • エラー

クラスまたはインタフェース

各クラス、インタフェース、入れ子クラス、および入れ子インタフェースは個別のページを持ちます。各ページには次のように、クラスまたはインタフェースの説明と、概要テーブル、およびメンバの詳細説明が含まれます:

  • クラス階層表示
  • 直系のサブクラス
  • 既知のサブインタフェースの一覧
  • 既知の実装クラスの一覧
  • クラスまたはインタフェースの宣言
  • クラスまたはインタフェースの記述

  • 入れ子クラスの概要
  • フィールドの概要
  • コンストラクタの概要
  • メソッドの概要

  • フィールドの詳細
  • コンストラクタの詳細
  • メソッドの詳細
各概要エントリには、その項目の詳細な記述の中から 1 行目の文が表示されます。詳細な記述はソースコードに現われる順に並べられますが、概要エントリはアルファベット順に並べられます。これによって、プログラマが設定した論理的なグループ分けが保持されます。

使用

各ドキュメント化されたパッケージ、クラス、およびインタフェースはそれぞれ [使用] ページを持っています。このページには、どのようなパッケージ、クラス、メソッド、コンストラクタ、およびフィールドが、特定のクラスまたはパッケージの一部を使用しているかが記述されています。たとえば、クラス A またはインタフェース A の場合、その [使用] ページには、A のサブクラス、A として宣言されるフィールド、A を返すメソッド、および、型 A を持つメソッドとコンストラクタが含まれます。このページにアクセスするには、まずそのパッケージ、クラス、またはインタフェースに移動し、ナビゲーションバーの [使用] リンクをクリックしてください。

階層ツリー (クラス階層)

すべてのパッケージには クラス階層 ページがあり、さらに各パッケージの階層があります。各階層ページは、クラスのリストとインタフェースのリストを含みます。クラスは java.lang.Object を開始点とする継承構造で編成されます。インタフェースは、java.lang.Object からは継承しません。
  • 概要ページを表示しているときに [ツリー] をクリックすると、全パッケージの階層が表示されます。
  • 特定のパッケージ、クラス、またはインタフェースを表示しているときに [ツリー] をクリックすると、該当するパッケージだけの階層が表示されます。

推奨されていない API

推奨されていない API ページは、推奨されていないすべての API のリストを表示します。非推奨 API とは、機能改良などの理由から使用をお勧めできなくなった API のことで、通常はそれに代わる API が提供されます。非推奨 API は今後の実装で削除される可能性があります。

索引

索引 には、すべてのクラス、インタフェース、コンストラクタ、メソッド、およびフィールドのアルファベット順のリストが含まれます。

前/次

これらのリンクにより、前または次のクラス、インタフェース、パッケージ、または関連ページへ移動できます。

フレームあり/フレームなし

これらのリンクは HTML フレームを表示したり隠したりします。すべてのページはフレームありでも、フレームなしでも表示できます。

直列化された形式

直列化可能、または外部化可能な各クラスは、直列化フィールドとメソッドの記述を含みます。この情報は、API を使用する開発者ではなく、再実装を行う担当者に役立ちます。ナビゲーションバーにリンクがない場合、直列化されたクラスに移動して、クラス記述の [関連項目] セクションにある [直列化された形式] をクリックすることにより、この情報を表示できます。

このヘルプファイルは、標準の doclet によって生成された API ドキュメントに適用されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


索引 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし
A B C D E F G H I J K L M N O P R S T U V X

A

ApplicationException - exception jp.co.intra_mart.framework.system.exception.ApplicationException.
フレームワーク内で発生したアプリケーション例外です。
ApplicationException() - class jp.co.intra_mart.framework.system.exception.ApplicationException のコンストラクタ
詳細メッセージを指定しないで ApplicationException を構築します。
ApplicationException(String) - class jp.co.intra_mart.framework.system.exception.ApplicationException のコンストラクタ
指定された詳細メッセージを持つ ApplicationException を構築します。
ApplicationException(Throwable) - class jp.co.intra_mart.framework.system.exception.ApplicationException のコンストラクタ
この例外の発生原因となる例外を持つ ApplicationException を構築します。
ApplicationException(String, Throwable) - class jp.co.intra_mart.framework.system.exception.ApplicationException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ApplicationException を構築します。
addAttr(String, String) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
Attributeを追加します。
addDetail(String) - class jp.co.intra_mart.framework.base.service.validator.ValidationExceptionDetail のメソッド
検証結果の詳細を追加します。
addNode(String) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
Nodeを追加します。
addNode(String, String) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
Nodeを追加します。
addParameter(String, String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
パラメータを追加します。
addParameter(String, String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
パラメータを追加します。
addParameter(Object) - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
パラメータを追加します。
addParameter(String, String) - interface jp.co.intra_mart.framework.base.web.tag.ParameterSendable のメソッド
パラメータを追加します。

B

BLANK_USER_INFO - class jp.co.intra_mart.framework.base.util.UserInfoWrapper の static 変数
デフォルトでラップされているクラスです。

C

CATEGORY_BEGIN_TRANSACTION - interface jp.co.intra_mart.framework.system.log.LogConstant の static 変数
トランザクションを開始するタイプです。
CATEGORY_COMMIT_TRANSACTION - interface jp.co.intra_mart.framework.system.log.LogConstant の static 変数
トランザクションをコミットするタイプです。
CATEGORY_ROLLBACK_TRANSACTION - interface jp.co.intra_mart.framework.system.log.LogConstant の static 変数
トランザクションをロールバックするタイプです。
Config - class jp.co.intra_mart.framework.system.util.Config.
標準的な初期化情報です。
Config() - class jp.co.intra_mart.framework.system.util.Config のコンストラクタ
ConfigurationUserInfo - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo.
情報を自由に設定可能なUserInfoです。
ConfigurationUserInfo() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のコンストラクタ
ConnectorModel - class jp.co.intra_mart.framework.base.data.ConnectorModel.
コネクタ情報を管理するクラスです。
ConnectorModel() - class jp.co.intra_mart.framework.base.data.ConnectorModel のコンストラクタ
ControllerConverter - interface jp.co.intra_mart.framework.base.service.controller.ControllerConverter.
リクエストをコントローラオブジェクトに変換します。
ControllerConverterConfig - interface jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfig.
ControllerConverterの初期化情報です。
ControllerConverterConfigImpl - class jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfigImpl.
ControllerConverterの初期化情報です。
ControllerConverterConfigImpl() - class jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfigImpl のコンストラクタ
ControllerConverterException - exception jp.co.intra_mart.framework.base.service.controller.ControllerConverterException.
ControllerConverterに関連する例外です。
ControllerConverterException() - class jp.co.intra_mart.framework.base.service.controller.ControllerConverterException のコンストラクタ
詳細メッセージを指定しないで ForwardSelectorException を構築します。
ControllerConverterException(String) - class jp.co.intra_mart.framework.base.service.controller.ControllerConverterException のコンストラクタ
指定された詳細メッセージを持つ ForwardSelectorException を構築します。
ControllerConverterException(String, Throwable) - class jp.co.intra_mart.framework.base.service.controller.ControllerConverterException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ForwardSelectorException を構築します。
ControllerConverterModel - class jp.co.intra_mart.framework.base.service.ControllerConverterModel.
コントローラコンバータ情報を管理するクラスです。
ControllerConverterModel() - class jp.co.intra_mart.framework.base.service.ControllerConverterModel のコンストラクタ
ControllerObject - interface jp.co.intra_mart.framework.base.service.controller.ControllerObject.
コントローラオブジェクトのインタフェースです。
CoreAttributes - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes.
コア属性です。
CoreAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のコンストラクタ
CoreAttributesを新規に生成します。
check() - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
入力内容をチェックします。
check() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
入力内容をチェックします。
clear() - class jp.co.intra_mart.framework.base.session.HttpSessionObject のメソッド
推奨されていません。 セッション内に存在するすべてのオブジェクトを削除します。
clear() - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のメソッド
推奨されていません。 セッション内に存在するすべてのオブジェクトを削除します。
clear() - interface jp.co.intra_mart.framework.base.session.SessionObject のメソッド
セッション内に存在するすべてのオブジェクトを削除します。
commit() - class jp.co.intra_mart.framework.base.data.DBConnector のメソッド
コミットします。
commit() - class jp.co.intra_mart.framework.base.data.DataAccessController のメソッド
すべてのデータコネクタをコミットします。
commit() - class jp.co.intra_mart.framework.base.data.DataConnector のメソッド
コミットします。
commit() - class jp.co.intra_mart.framework.base.data.DataSourceConnector のメソッド
コミットします。
commit() - class jp.co.intra_mart.framework.base.data.IntramartDBConnector のメソッド
推奨されていません。 コミットします。
commit() - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector のメソッド
コミットします。
commit() - class jp.co.intra_mart.framework.base.data.JDBCConnector のメソッド
推奨されていません。 コミットします。
commit() - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector のメソッド
コミットします。
commit() - class jp.co.intra_mart.framework.base.data.SystemDBConnector のメソッド
コミットします。
configSession(HttpServletRequest, HttpServletResponse, String, String, String, String, boolean) - class jp.co.intra_mart.framework.util.IntramartConnectUtil の static メソッド
推奨されていません。 セッションにさまざまな情報を設定します。
connections - class jp.co.intra_mart.framework.base.data.IntramartDBConnector の変数
推奨されていません。 DbsConnectionの一覧
connections - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector の変数
リソース一覧
connections - class jp.co.intra_mart.framework.base.data.SystemDBConnector の変数
リソース一覧
convert(RequestInfo) - interface jp.co.intra_mart.framework.base.service.controller.ControllerConverter のメソッド
リクエスト情報をもとに入力オブジェクトを生成します。
convert(RequestInfo) - class jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter のメソッド
リクエスト情報をもとに入力オブジェクトを生成します。
create() - class jp.co.intra_mart.framework.base.data.container.factory.DataContainerFactory のメソッド
DataContainerを生成します。
create() - class jp.co.intra_mart.framework.base.data.container.factory.DefaultDataProvider のメソッド
DataContainerを生成します。
create(Event) - interface jp.co.intra_mart.framework.base.event.EventListenerFactory のメソッド
イベントリスナを生成します。
create() - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome のメソッド
リモートインタフェースGenericEJBEventListenerAgentを取得します。
create() - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocalHome のメソッド
ローカルインタフェース GenericEJBEventListenerAgentLocalを取得します。
create(Event) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory のメソッド
イベントリスナを生成します。
create(Event) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory のメソッド
イベントリスナを生成します。
create(Event) - class jp.co.intra_mart.framework.base.event.GenericEventListenerFactory のメソッド
イベントリスナを生成します。
create() - interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome のメソッド
StandardEJBEventListenerAgentと接続します。
create(Event) - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory のメソッド
イベントリスナを生成します。
create(Event) - class jp.co.intra_mart.framework.base.event.StandardEventListenerFactory のメソッド
イベントリスナを生成します。
create() - class jp.co.intra_mart.framework.base.event.container.factory.DefaultEventProvider のメソッド
EventContainerを生成します。
create() - class jp.co.intra_mart.framework.base.event.container.factory.EventContainerFactory のメソッド
EventContainerを生成します。
create() - class jp.co.intra_mart.framework.base.service.container.factory.DefaultServiceProvider のメソッド
ServiceContainerを生成します。
create() - class jp.co.intra_mart.framework.base.service.container.factory.ServiceContainerFactory のメソッド
ServiceContainerを生成します。
create() - interface jp.co.intra_mart.framework.system.container.factory.IMContainerFactory のメソッド
create() - interface jp.co.intra_mart.framework.system.container.factory.Provider のメソッド
IMContainerを生成します
createCheckSum(String, String, HttpSession) - class jp.co.intra_mart.framework.util.SecurityUtil の static メソッド
暗号を作成します。
createEvent(String, String, UserInfo) - class jp.co.intra_mart.framework.base.event.EventManager のメソッド
パラメータで指定された内容に該当するイベントを生成します。
createEvent(String, String, String, String) - class jp.co.intra_mart.framework.base.event.EventManager のメソッド
推奨されていません。 このメソッドではなくEventManager.createEvent(String, String, UserInfo)を使用してください。
createEvent(String, String) - interface jp.co.intra_mart.framework.base.event.container.EventContainer のメソッド
パラメータで指定された内容に該当するイベントを生成します。
createEvent(String, String) - class jp.co.intra_mart.framework.base.event.container.EventContainerImpl のメソッド
パラメータで指定された内容に該当するイベントを生成します。
createEvent(String, String) - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
アプリケーションIDとキーに対応するイベントを取得します。
createEvent(String, String) - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
アプリケーションIDとキーに対応するイベントを取得します。
createSessionObject(ServletRequest) - class jp.co.intra_mart.framework.base.session.HttpSessionFactory のメソッド
推奨されていません。 セッションオブジェクトを新規に生成します。
createSessionObject(ServletRequest) - class jp.co.intra_mart.framework.base.session.IntramartSessionFactory のメソッド
推奨されていません。 セッションオブジェクトを新規に生成します。
createSessionObject(ServletRequest) - interface jp.co.intra_mart.framework.base.session.SessionFactory のメソッド
セッションオブジェクトを新規に生成します。
createURL(String, Collection) - class jp.co.intra_mart.framework.base.web.tag.TagWriter の static メソッド
推奨されていません。 このメソッドではなくTagWriter.createURL(String, Collection, String)を使用してください。
createURL(String, Collection, String) - class jp.co.intra_mart.framework.base.web.tag.TagWriter の static メソッド
複数のパラメータをURLに追加します。
createUserInfo(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.util.UserInfoUtil の static メソッド
intra-martのセッション情報からUserInfoを新規に生成します。

D

DAO - interface jp.co.intra_mart.framework.base.data.DAO.
データリソースにアクセスするインタフェースです。
DAOAdapter - class jp.co.intra_mart.framework.base.data.DAOAdapter.
DAOのすべてのメソッドを何もしないように実装したクラスです。
DAOAdapter() - class jp.co.intra_mart.framework.base.data.DAOAdapter のコンストラクタ
DAOAdapterを新規に生成します。
DAOException - exception jp.co.intra_mart.framework.base.data.DAOException.
リソースコネクタの情報取得時の例外です。
DAOException() - class jp.co.intra_mart.framework.base.data.DAOException のコンストラクタ
詳細メッセージを指定しないで DAOException を構築します。
DAOException(String) - class jp.co.intra_mart.framework.base.data.DAOException のコンストラクタ
指定された詳細メッセージを持つ DAOException を構築します。
DAOException(String, Throwable) - class jp.co.intra_mart.framework.base.data.DAOException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DAOException を構築します。
DATA_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.base.data.DataManager の static 変数
データプロパティハンドラのキー
DATA_PROPERTY_HANDLER_KEY - interface jp.co.intra_mart.framework.base.data.container.DataContainer の static 変数
データプロパティハンドラのキー
DBConnector - class jp.co.intra_mart.framework.base.data.DBConnector.
データベースに対するコネクタです。
DBConnector() - class jp.co.intra_mart.framework.base.data.DBConnector のコンストラクタ
DBConnectorを新規に生成します。
DBDAO - class jp.co.intra_mart.framework.base.data.DBDAO.
データベースに特化したDAOです。
DBDAO() - class jp.co.intra_mart.framework.base.data.DBDAO のコンストラクタ
デフォルトのコンストラクタ
DEFAULT_APPLICATION_PARAMETER - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler の static 変数
推奨されていません。 この実装は廃止されました。
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler の static 変数
デフォルトのXMLファイル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler の static 変数
デフォルトのxmlファイルのプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler の static 変数
デフォルトのリソースバンドル名
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler の static 変数
デフォルトのxmlファイル名
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler の static 変数
デフォルトのリソースバンドル名
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler の static 変数
デフォルトのXMLファイル名
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler の static 変数
デフォルトのリソースバンドル名
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.system.property.DefaultPropertyManager の static 変数
デフォルトのリソースバンドル名
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.system.property.XmlPropertyManager の static 変数
デフォルトのリソースバンドル名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler の static 変数
XMLファイル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler の static 変数
xmlのパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler の static 変数
xmlファイル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler の static 変数
XMLファイル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_ENCODING_ATTRIBUTE - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler の static 変数
ログインユーザのエンコーディングのデフォルトの属性名
DEFAULT_EXCEPTION_ATTRIBUTE - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler の static 変数
例外属性のデフォルトの属性名
DEFAULT_LOCALE_ATTRIBUTE - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler の static 変数
ログインユーザのロケールのデフォルトの属性名
DEFAULT_SERVICE_EXTENSION - class jp.co.intra_mart.framework.base.service.ServiceManager の static 変数
サービスフレームワークをコールするためのデフォルトの拡張子
DEFAULT_SERVICE_PARAMETER - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler の static 変数
推奨されていません。 この実装は廃止されました。
DEFAULT_SYSTEM_MANAGER - class jp.co.intra_mart.framework.system.property.PropertyManager の static 変数
デフォルトのプロパティマネージャクラス
DaoModel - class jp.co.intra_mart.framework.base.data.DaoModel.
DaoModelを管理するクラスです。
DaoModel() - class jp.co.intra_mart.framework.base.data.DaoModel のコンストラクタ
DataAccessController - class jp.co.intra_mart.framework.base.data.DataAccessController.
データアクセスを制御します。
DataAccessController(DataPropertyHandler) - class jp.co.intra_mart.framework.base.data.DataAccessController のコンストラクタ
データアクセスコントローラを生成します。
DataAccessException - exception jp.co.intra_mart.framework.base.data.DataAccessException.
データアクセス時の例外です。
DataAccessException() - class jp.co.intra_mart.framework.base.data.DataAccessException のコンストラクタ
詳細メッセージを指定しないで DataAccessException を構築します。
DataAccessException(String) - class jp.co.intra_mart.framework.base.data.DataAccessException のコンストラクタ
指定された詳細メッセージを持つ DataAccessException を構築します。
DataAccessException(String, Throwable) - class jp.co.intra_mart.framework.base.data.DataAccessException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataAccessException を構築します。
DataConnectException - exception jp.co.intra_mart.framework.base.data.DataConnectException.
データ接続に関連する例外です。
DataConnectException() - class jp.co.intra_mart.framework.base.data.DataConnectException のコンストラクタ
詳細メッセージを指定しないで DataConnectException を構築します。
DataConnectException(String) - class jp.co.intra_mart.framework.base.data.DataConnectException のコンストラクタ
指定された詳細メッセージを持つ DataConnectException を構築します。
DataConnectException(String, Throwable) - class jp.co.intra_mart.framework.base.data.DataConnectException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataConnectException を構築します。
DataConnector - class jp.co.intra_mart.framework.base.data.DataConnector.
データストアに接続するコネクタです。
DataConnector() - class jp.co.intra_mart.framework.base.data.DataConnector のコンストラクタ
新規のDataConnectorを生成します。
DataConnectorException - exception jp.co.intra_mart.framework.base.data.DataConnectorException.
データコネクタ取得時の例外です。
DataConnectorException() - class jp.co.intra_mart.framework.base.data.DataConnectorException のコンストラクタ
詳細メッセージを指定しないで DataConnectorException を構築します。
DataConnectorException(String) - class jp.co.intra_mart.framework.base.data.DataConnectorException のコンストラクタ
指定された詳細メッセージを持つ DataConnectorException を構築します。
DataConnectorException(String, Throwable) - class jp.co.intra_mart.framework.base.data.DataConnectorException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataConnectorException を構築します。
DataContainer - interface jp.co.intra_mart.framework.base.data.container.DataContainer.
データコンテナのインターフェースです。
DataContainerException - exception jp.co.intra_mart.framework.base.data.container.DataContainerException.
データコンテナ設定時の例外です。
DataContainerException() - class jp.co.intra_mart.framework.base.data.container.DataContainerException のコンストラクタ
詳細メッセージを指定しないで DataContainerException を構築します。
DataContainerException(String) - class jp.co.intra_mart.framework.base.data.container.DataContainerException のコンストラクタ
指定された詳細メッセージを持つ DataContainerException を構築します。
DataContainerException(String, Throwable) - class jp.co.intra_mart.framework.base.data.container.DataContainerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataContainerException を構築します。
DataContainerFactory - class jp.co.intra_mart.framework.base.data.container.factory.DataContainerFactory.
DataContainerのファクトリクラスです。
DataContainerFactory() - class jp.co.intra_mart.framework.base.data.container.factory.DataContainerFactory のコンストラクタ
DataContainerImpl - class jp.co.intra_mart.framework.base.data.container.DataContainerImpl.
DataContainerの標準的な実装クラスです。
DataContainerImpl() - class jp.co.intra_mart.framework.base.data.container.DataContainerImpl のコンストラクタ
DataContainerImplを生成します。
DataManager - class jp.co.intra_mart.framework.base.data.DataManager.
データストアとの接続を管理します。
DataManager() - class jp.co.intra_mart.framework.base.data.DataManager のコンストラクタ
データマネージャを生成するコンストラクタです。
DataManagerException - exception jp.co.intra_mart.framework.base.data.DataManagerException.
データマネージャの設定時の例外です。
DataManagerException() - class jp.co.intra_mart.framework.base.data.DataManagerException のコンストラクタ
詳細メッセージを指定しないで DataManagerException を構築します。
DataManagerException(String) - class jp.co.intra_mart.framework.base.data.DataManagerException のコンストラクタ
指定された詳細メッセージを持つ DataManagerException を構築します。
DataManagerException(String, Throwable) - class jp.co.intra_mart.framework.base.data.DataManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataManagerException を構築します。
DataPropertyException - exception jp.co.intra_mart.framework.base.data.DataPropertyException.
データプロパティ取得時の例外です。
DataPropertyException() - class jp.co.intra_mart.framework.base.data.DataPropertyException のコンストラクタ
詳細メッセージを指定しないで DataPropertyException を構築します。
DataPropertyException(String) - class jp.co.intra_mart.framework.base.data.DataPropertyException のコンストラクタ
指定された詳細メッセージを持つ DataPropertyException を構築します。
DataPropertyException(String, Throwable) - class jp.co.intra_mart.framework.base.data.DataPropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataPropertyException を構築します。
DataPropertyHandler - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler.
DAOの設定情報に接続するクラスです。
DataSourceConnector - class jp.co.intra_mart.framework.base.data.DataSourceConnector.
DataSourceに関連するデータコネクタです。
DataSourceConnector() - class jp.co.intra_mart.framework.base.data.DataSourceConnector のコンストラクタ
DataSourceConnectorを新規に生成します。
DefaultDataPropertyHandler - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler.
デフォルトのデータプロパティハンドラです。
DefaultDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のコンストラクタ
DefaultDataPropertyHandlerを新規に生成します。
DefaultDataProvider - class jp.co.intra_mart.framework.base.data.container.factory.DefaultDataProvider.
標準的なプロバイダーです。
DefaultDataProvider() - class jp.co.intra_mart.framework.base.data.container.factory.DefaultDataProvider のコンストラクタ
DefaultDataProviderを新規に生成します。
DefaultEventPropertyHandler - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler.
デフォルトのEventPropertyHandlerです。
DefaultEventPropertyHandler() - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のコンストラクタ
DefaultEventPropertyHandlerを新規に生成します。
DefaultEventProvider - class jp.co.intra_mart.framework.base.event.container.factory.DefaultEventProvider.
標準的なプロバイダーです。
DefaultEventProvider() - class jp.co.intra_mart.framework.base.event.container.factory.DefaultEventProvider のコンストラクタ
DefaultEventProviderを新規に生成します。
DefaultLogAgent - class jp.co.intra_mart.framework.system.log.DefaultLogAgent.
デフォルトのログエージェントです。
DefaultLogAgent() - class jp.co.intra_mart.framework.system.log.DefaultLogAgent のコンストラクタ
DefaultLogPropertyHandler - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler.
ログに関連するデフォルトのプロパティハンドラです。
DefaultLogPropertyHandler() - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler のコンストラクタ
DefaultLogPropertyHandlerを新規に生成します。
DefaultMessagePropertyHandler - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler.
メッセージの設定情報に接続するデフォルトのプロパティハンドラです。
DefaultMessagePropertyHandler() - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler のコンストラクタ
DefaultMessagePropertyHandlerを新規に生成します。
DefaultMessagePropertyHandler - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler.
デフォルトのメッセージプロパティハンドラです。
DefaultMessagePropertyHandler() - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler のコンストラクタ
DefaultMessagePropertyHandlerを新規に生成します。
DefaultPropertyManager - class jp.co.intra_mart.framework.system.property.DefaultPropertyManager.
デフォルトのプロパティマネージャです。
DefaultPropertyManager() - class jp.co.intra_mart.framework.system.property.DefaultPropertyManager のコンストラクタ
コンストラクタです。
DefaultServicePropertyHandler - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.
サービスの設定情報に接続するデフォルトのプロパティハンドラです。
DefaultServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のコンストラクタ
DefaultServicePropertyHandlerを新規に生成します。
DefaultServiceProvider - class jp.co.intra_mart.framework.base.service.container.factory.DefaultServiceProvider.
標準的なプロバイダーです。
DefaultServiceProvider() - class jp.co.intra_mart.framework.base.service.container.factory.DefaultServiceProvider のコンストラクタ
DefaultServiceProviderを新規に生成します。
DefaultSessionPropertyHandler - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler.
セッションに関連するデフォルトのプロパティハンドラです。
DefaultSessionPropertyHandler() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のコンストラクタ
DefaultSessionPropertyHandlerを新規に生成します。
DefaultTransition - class jp.co.intra_mart.framework.base.service.DefaultTransition.
デフォルトの画面遷移をします。
DefaultTransition() - class jp.co.intra_mart.framework.base.service.DefaultTransition のコンストラクタ
DefaultTransitionを新規に生成します。
DistributesDataPropertyHandler - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler.
アプリケーション毎のプロパティハンドラを呼び出します。
DistributesDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のコンストラクタ
DefaultDataPropertyHandlerを新規に生成します。
DistributesEventPropertyHandler - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler.
アプリケーション毎のEventPropertyHandlerを呼び出します。
DistributesEventPropertyHandler() - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のコンストラクタ
DistributesEventPropertyHandlerを新規に生成します。
DistributesServicePropertyHandler - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.
アプリケーションごとに異なるサービスプロパティハンドラを使用するサービスプロパティハンドラです。
DistributesServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のコンストラクタ
DefaultServicePropertyHandlerを新規に生成します。
delAttr(String) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
Attributeを削除します。
delNode(String) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
Nodeを削除します。
delNode(XMLNode) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
Nodeを削除します。
delNode() - class jp.co.intra_mart.framework.util.XMLNode のメソッド
Nodeを削除します。
destroy() - class jp.co.intra_mart.framework.base.service.EncodingFilter のメソッド
フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.FileUploadFilter のメソッド
フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter のメソッド
推奨されていません。 フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter のメソッド
推奨されていません。 フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter のメソッド
フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.LocaleFilter のメソッド
フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter のメソッド
フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.ServiceServlet のメソッド
サーブレットを解放します。
destroy() - interface jp.co.intra_mart.framework.base.service.controller.ControllerConverter のメソッド
ControllerConverterを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter のメソッド
SimpleControllerConverterを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.validator.FormatValidator のメソッド
FormatValidatorを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.validator.LengthValidator のメソッド
LengthValidatorを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator のメソッド
NumericRangeValidatorを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.validator.NumericValidator のメソッド
NumericValidatorを破棄します。
destroy() - interface jp.co.intra_mart.framework.base.service.validator.Validator のメソッド
Validatorを破棄します。
destroy() - class jp.co.intra_mart.framework.base.session.SessionFilter のメソッド
フィルタを破棄します。
dispatch(Event) - class jp.co.intra_mart.framework.base.event.EventManager のメソッド
イベントに対する処理を実行します。
dispatch(Event, boolean) - class jp.co.intra_mart.framework.base.event.EventManager のメソッド
イベントに対する処理を実行します。
dispatch(Event, boolean) - interface jp.co.intra_mart.framework.base.event.container.EventContainer のメソッド
イベントに対する処理を実行します。
dispatch(Event, boolean) - class jp.co.intra_mart.framework.base.event.container.EventContainerImpl のメソッド
イベントに対する処理を実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.base.event.EJBEventListener のメソッド
イベント処理を実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean のメソッド
イベント処理を実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.base.event.StandardEventListener のメソッド
イベント処理を実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
イベント処理を実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
イベント処理を実行します。
doEndTag() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
終了タグを検知したときにJSPエンジンから呼ばれます。
doEndTag() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
終了タグを検知したときにJSPエンジンから呼ばれます。
doEndTag() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
終了タグを検知したときにJSPエンジンから呼ばれます。
doEndTag() - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
終了タグを検知したときにJSPエンジンから呼ばれます。
doEndTag() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
終了タグを検知したときにJSPエンジンから呼ばれます。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.EncodingFilter のメソッド
リクエストのエンコードを設定します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.FileUploadFilter のメソッド
リクエストの内容がファイルアップロードを含むかどうかによってリクエストを選択します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter のメソッド
推奨されていません。 リクエストのパラメーターを設定後、次の処理に遷移します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter のメソッド
推奨されていません。 intra-martから来るリクエストをim-J2EE Frameworkで扱う形式に変換します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter のメソッド
リクエストのロケールを設定します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.LocaleFilter のメソッド
リクエストのロケールを設定します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter のメソッド
sessionに登録された情報と、parameterの情報を比較します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.session.SessionFilter のメソッド
リクエストのセッション管理をします。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 GETメソッドに対応します。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceServlet のメソッド
GETメソッドに対するサービスを行います。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 POSTメソッドに対応します。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceServlet のメソッド
POSTメソッドに対するサービスを行います。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.MessageParamTag のメソッド
外側の一番近いMessageTagにパラメータを設定します。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.ParamTag のメソッド
外側の一番近いParameterSendableにパラメータを設定します。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。

E

EJBEventListener - class jp.co.intra_mart.framework.base.event.EJBEventListener.
EJBを利用する場合のイベントリスナです。
EJBEventListener() - class jp.co.intra_mart.framework.base.event.EJBEventListener のコンストラクタ
EJBEventListenerを新規に生成します。
EJBEventListenerAgentBean - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean.
Session Beanを利用したイベントリスナの抽象クラスです。
EJBEventListenerAgentBean() - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean のコンストラクタ
EJBEventListenerAgentBeanを新規に生成します。
EJBEventListenerFactory - class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory.
EJBEventListenerFactoryを生成します。
EJBEventListenerFactory() - class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory のコンストラクタ
EJBEventListenerFactoryを新規に生成します。
EVENT_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.base.event.EventManager の static 変数
イベントプロパティハンドラのキー
EVENT_PROPERTY_HANDLER_KEY - interface jp.co.intra_mart.framework.base.event.container.EventContainer の static 変数
イベントプロパティハンドラのキー
EmptyEvent - class jp.co.intra_mart.framework.base.event.EmptyEvent.
情報を何も持たないイベントです。
EmptyEvent() - class jp.co.intra_mart.framework.base.event.EmptyEvent のコンストラクタ
EmptyServiceResult - class jp.co.intra_mart.framework.base.service.EmptyServiceResult.
情報を何も持たないServiceResultの実装です。
EmptyServiceResult() - class jp.co.intra_mart.framework.base.service.EmptyServiceResult のコンストラクタ
EmptyUserInfo - class jp.co.intra_mart.framework.base.util.EmptyUserInfo.
情報を何も持たないUserInfoです。
EmptyUserInfo() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のコンストラクタ
EncodingFilter - class jp.co.intra_mart.framework.base.service.EncodingFilter.
リクエストのエンコードを設定します。
EncodingFilter() - class jp.co.intra_mart.framework.base.service.EncodingFilter のコンストラクタ
ErrorHelperBean - class jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean.
例外ページで使用するHelperBeanです。
ErrorHelperBean() - class jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean のコンストラクタ
ErrorHelperBeanを新規に生成します。
Event - class jp.co.intra_mart.framework.base.event.Event.
処理を実行するための情報です。
Event() - class jp.co.intra_mart.framework.base.event.Event のコンストラクタ
イベントを新規に生成します。
EventContainer - interface jp.co.intra_mart.framework.base.event.container.EventContainer.
イベントコンテナのインターフェースです。
EventContainerException - exception jp.co.intra_mart.framework.base.event.container.EventContainerException.
イベントコンテナ設定時の例外です。
EventContainerException() - class jp.co.intra_mart.framework.base.event.container.EventContainerException のコンストラクタ
詳細メッセージを指定しないで EventContainerException を構築します。
EventContainerException(String) - class jp.co.intra_mart.framework.base.event.container.EventContainerException のコンストラクタ
指定された詳細メッセージを持つ EventContainerException を構築します。
EventContainerException(String, Throwable) - class jp.co.intra_mart.framework.base.event.container.EventContainerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventContainerException を構築します。
EventContainerFactory - class jp.co.intra_mart.framework.base.event.container.factory.EventContainerFactory.
EventContainerのファクトリクラスです。
EventContainerFactory() - class jp.co.intra_mart.framework.base.event.container.factory.EventContainerFactory のコンストラクタ
EventContainerImpl - class jp.co.intra_mart.framework.base.event.container.EventContainerImpl.
EventContainerの標準的な実装クラスです。
EventContainerImpl() - class jp.co.intra_mart.framework.base.event.container.EventContainerImpl のコンストラクタ
EventContainerImplを生成します。
EventException - exception jp.co.intra_mart.framework.base.event.EventException.
イベント生成時の例外です。
EventException() - class jp.co.intra_mart.framework.base.event.EventException のコンストラクタ
詳細メッセージを指定しないで EventException を構築します。
EventException(String) - class jp.co.intra_mart.framework.base.event.EventException のコンストラクタ
指定された詳細メッセージを持つ EventException を構築します。
EventException(String, Throwable) - class jp.co.intra_mart.framework.base.event.EventException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventException を構築します。
EventFactoryModel - class jp.co.intra_mart.framework.base.event.EventFactoryModel.
イベントリスナーファクトリー情報を管理するクラスです。
EventFactoryModel() - class jp.co.intra_mart.framework.base.event.EventFactoryModel のコンストラクタ
EventGroupModel - class jp.co.intra_mart.framework.base.event.EventGroupModel.
Event情報を管理するクラスです。
EventGroupModel() - class jp.co.intra_mart.framework.base.event.EventGroupModel のコンストラクタ
EventListener - interface jp.co.intra_mart.framework.base.event.EventListener.
イベントリスナです。
EventListenerException - exception jp.co.intra_mart.framework.base.event.EventListenerException.
イベントリスナ生成時の例外です。
EventListenerException() - class jp.co.intra_mart.framework.base.event.EventListenerException のコンストラクタ
詳細メッセージを指定しないで EventListenerException を構築します。
EventListenerException(String) - class jp.co.intra_mart.framework.base.event.EventListenerException のコンストラクタ
指定された詳細メッセージを持つ EventListenerException を構築します。
EventListenerException(String, Throwable) - class jp.co.intra_mart.framework.base.event.EventListenerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventListenerException を構築します。
EventListenerFactory - interface jp.co.intra_mart.framework.base.event.EventListenerFactory.
イベントリスナを生成します。
EventListenerFactoryParam - class jp.co.intra_mart.framework.base.event.EventListenerFactoryParam.
イベントリスナファクトリの初期パラメータです。
EventListenerFactoryParam() - class jp.co.intra_mart.framework.base.event.EventListenerFactoryParam のコンストラクタ
EventListenerFactoryParamを新規に生成します。
EventManager - class jp.co.intra_mart.framework.base.event.EventManager.
イベントマネージャです。
EventManagerException - exception jp.co.intra_mart.framework.base.event.EventManagerException.
イベントマネージャ設定時の例外です。
EventManagerException() - class jp.co.intra_mart.framework.base.event.EventManagerException のコンストラクタ
詳細メッセージを指定しないで EventManagerException を構築します。
EventManagerException(String) - class jp.co.intra_mart.framework.base.event.EventManagerException のコンストラクタ
指定された詳細メッセージを持つ EventManagerException を構築します。
EventManagerException(String, Throwable) - class jp.co.intra_mart.framework.base.event.EventManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventManagerException を構築します。
EventModelProducer - class jp.co.intra_mart.framework.base.event.EventModelProducer.
イベント情報を作成するクラスです。
EventModelProducer() - class jp.co.intra_mart.framework.base.event.EventModelProducer のコンストラクタ
EventPropertyException - exception jp.co.intra_mart.framework.base.event.EventPropertyException.
イベントプロパティ取得時の例外です。
EventPropertyException() - class jp.co.intra_mart.framework.base.event.EventPropertyException のコンストラクタ
詳細メッセージを指定しないで EventPropertyException を構築します。
EventPropertyException(String) - class jp.co.intra_mart.framework.base.event.EventPropertyException のコンストラクタ
指定された詳細メッセージを持つ EventPropertyException を構築します。
EventPropertyException(String, Throwable) - class jp.co.intra_mart.framework.base.event.EventPropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventPropertyException を構築します。
EventPropertyHandler - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler.
イベントの設定情報に接続するクラスです。
EventResult - interface jp.co.intra_mart.framework.base.event.EventResult.
イベント処理の結果です。
EventTrigger - interface jp.co.intra_mart.framework.base.event.EventTrigger.
イベントトリガです。
EventTriggerAdapter - class jp.co.intra_mart.framework.base.event.EventTriggerAdapter.
DAOを取得するメソッドを持ったイベントトリガです。
EventTriggerAdapter() - class jp.co.intra_mart.framework.base.event.EventTriggerAdapter のコンストラクタ
EventTriggerAdapterを新規に生成します。
EventTriggerException - exception jp.co.intra_mart.framework.base.event.EventTriggerException.
イベントトリガ生成時の例外です。
EventTriggerException() - class jp.co.intra_mart.framework.base.event.EventTriggerException のコンストラクタ
詳細メッセージを指定しないで EventTriggerException を構築します。
EventTriggerException(String) - class jp.co.intra_mart.framework.base.event.EventTriggerException のコンストラクタ
指定された詳細メッセージを持つ EventTriggerException を構築します。
EventTriggerException(String, Throwable) - class jp.co.intra_mart.framework.base.event.EventTriggerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventTriggerException を構築します。
EventTriggerInfo - class jp.co.intra_mart.framework.base.event.EventTriggerInfo.
イベントトリガの情報です。
EventTriggerInfo() - class jp.co.intra_mart.framework.base.event.EventTriggerInfo のコンストラクタ
EventTriggerInfoを新規に生成します。
EventTriggerList - class jp.co.intra_mart.framework.base.event.EventTriggerList.
イベントトリガの集合を扱います。
EventTriggerList(String, String) - class jp.co.intra_mart.framework.base.event.EventTriggerList のコンストラクタ
EventTriggerListを新規に生成します。
EventTriggerList(String, String, boolean) - class jp.co.intra_mart.framework.base.event.EventTriggerList のコンストラクタ
EventTriggerListを新規に生成します。
EventsAttributes - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes.
ブラウザのイベントに関連するタグの属性情報です。
EventsAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のコンストラクタ
EventsAttributesを新規に生成します。
ejbActivate() - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean のメソッド
"passive"状態の時にインスタンスが活性化される時に呼ばれるメソッドです。
ejbCreate() - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean のメソッド
ホームインタフェースの引数なしのcreate()メソッドに対応します。
ejbCreate() - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean のメソッド
ホームインタフェースの引数なしのcreate()メソッドに対応します。
ejbPassivate() - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean のメソッド
インスタンスが"passive"状態に移る前に呼ばれるメソッドです。
ejbRemove() - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean のメソッド
Session Beanのが終了する前にEJBコンテナが呼び出すメソッドです。
encodeCaption(String) - class jp.co.intra_mart.framework.base.web.util.HTMLEncoder の static メソッド
キャプションを変換します。
encodeURL(ServletRequest, ServletResponse, String) - class jp.co.intra_mart.framework.base.session.HttpSessionFactory のメソッド
推奨されていません。 セッションIDをエンコードしてURLに追加します。
encodeURL(ServletRequest, ServletResponse, String) - class jp.co.intra_mart.framework.base.session.IntramartSessionFactory のメソッド
推奨されていません。 セッションIDをエンコードしてURLに追加します。
encodeURL(ServletRequest, ServletResponse, String) - interface jp.co.intra_mart.framework.base.session.SessionFactory のメソッド
セッションIDをエンコードしてURLに追加します。
encodeValue(String) - class jp.co.intra_mart.framework.base.web.util.HTMLEncoder の static メソッド
<TEXTAREA>タグまたはvalue属性に入る文字列を変換します。
execute(Event) - interface jp.co.intra_mart.framework.base.event.EventListener のメソッド
処理を実行します。
execute(Event) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListener のメソッド
処理を実行します。
execute(Event, String) - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent のメソッド
イベント処理を行います。
execute(Event, String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean のメソッド
イベント処理を実行します。
execute(Event, String) - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocal のメソッド
イベント処理を行います。
execute(Event) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal のメソッド
処理を実行します。
execute(Event) - class jp.co.intra_mart.framework.base.event.GenericEventListener のメソッド
処理を実行します。
execute(Event) - class jp.co.intra_mart.framework.base.event.StandardEJBEventListener のメソッド
処理を実行します。
execute(Event) - interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent のメソッド
イベント処理を実行します。
execute(Event) - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean のメソッド
イベント処理を実行します。
execute(Event) - class jp.co.intra_mart.framework.base.event.StandardEventListener のメソッド
処理を実行します。
execute(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 intra-martベースモジュールのメニューからのリクエストを受け付けます。

F

FileResourceBundle - class jp.co.intra_mart.framework.util.FileResourceBundle.
java.util.ResourceBundle のファイル版です。
FileResourceBundle(String) - class jp.co.intra_mart.framework.util.FileResourceBundle のコンストラクタ
プロパティリソースを作成します。
FileResourceBundle(String, Locale) - class jp.co.intra_mart.framework.util.FileResourceBundle のコンストラクタ
プロパティリソースを作成します。
FileUploadFilter - class jp.co.intra_mart.framework.base.service.FileUploadFilter.
ファイルアップロード用にリクエストを変換するフィルタです。
FileUploadFilter() - class jp.co.intra_mart.framework.base.service.FileUploadFilter のコンストラクタ
FormTEI - class jp.co.intra_mart.framework.base.web.tag.FormTEI.
Formタグの拡張情報です。
FormTEI() - class jp.co.intra_mart.framework.base.web.tag.FormTEI のコンストラクタ
FormTEIを新規に生成します。
FormTag - class jp.co.intra_mart.framework.base.web.tag.FormTag.
FORMタグです。
FormTag() - class jp.co.intra_mart.framework.base.web.tag.FormTag のコンストラクタ
FormTagを新規に生成します。
FormTagBeanInfo - class jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo.
FormTagのBeanInfoです。
FormTagBeanInfo() - class jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo のコンストラクタ
FormTagBeanInfoを新規に生成します。
FormatValidator - class jp.co.intra_mart.framework.base.service.validator.FormatValidator.
文字列の不正文字（フォーマット）チェックを行います。
FormatValidator() - class jp.co.intra_mart.framework.base.service.validator.FormatValidator のコンストラクタ
FrameTEI - class jp.co.intra_mart.framework.base.web.tag.FrameTEI.
Frameタグの拡張情報です。
FrameTEI() - class jp.co.intra_mart.framework.base.web.tag.FrameTEI のコンストラクタ
FrameTEIを新規に生成します。
FrameTag - class jp.co.intra_mart.framework.base.web.tag.FrameTag.
FRAMEタグです。
FrameTag() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のコンストラクタ
FrameTagを新規に生成します。
FrameTagBeanInfo - class jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo.
FrameTagのBeanInfoです。
FrameTagBeanInfo() - class jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo のコンストラクタ
FrameTagBeanInfoを新規に生成します。
FrameworkException - exception jp.co.intra_mart.framework.system.exception.FrameworkException.
フレームワークに共通するの例外のスーパークラスです。
FrameworkException() - class jp.co.intra_mart.framework.system.exception.FrameworkException のコンストラクタ
詳細メッセージを指定しないで FrameworkException を構築します。
FrameworkException(String) - class jp.co.intra_mart.framework.system.exception.FrameworkException のコンストラクタ
指定された詳細メッセージを持つ FrameworkException を構築します。
FrameworkException(Throwable) - class jp.co.intra_mart.framework.system.exception.FrameworkException のコンストラクタ
この例外の発生原因となる例外を持つ FrameworkException を構築します。
FrameworkException(String, Throwable) - class jp.co.intra_mart.framework.system.exception.FrameworkException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkException を構築します。
FrameworkParameterSettingFilter - class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter.
推奨されていません。 このフィルタは下位互換のためのフィルタです。将来廃止される可能性があります。
FrameworkParameterSettingFilter() - class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter のコンストラクタ
推奨されていません。
FrameworkRuntimeException - exception jp.co.intra_mart.framework.system.exception.FrameworkRuntimeException.
フレームワーク内で発生したランタイム例外です。
FrameworkRuntimeException() - class jp.co.intra_mart.framework.system.exception.FrameworkRuntimeException のコンストラクタ
詳細メッセージを指定しないで FrameworkRuntimeException を構築します。
FrameworkRuntimeException(String) - class jp.co.intra_mart.framework.system.exception.FrameworkRuntimeException のコンストラクタ
指定された詳細メッセージを持つ FrameworkRuntimeException を構築します。
FrameworkRuntimeException(Throwable) - class jp.co.intra_mart.framework.system.exception.FrameworkRuntimeException のコンストラクタ
この例外の発生原因となる例外を持つ FrameworkRuntimeException を構築します。
FrameworkRuntimeException(String, Throwable) - class jp.co.intra_mart.framework.system.exception.FrameworkRuntimeException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkRuntimeException を構築します。
FrameworkTagException - exception jp.co.intra_mart.framework.base.web.tag.FrameworkTagException.
拡張タグの例外です。
FrameworkTagException() - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のコンストラクタ
詳細メッセージを指定しないで FrameworkTagException を構築します。
FrameworkTagException(String) - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のコンストラクタ
指定された詳細メッセージを持つ FrameworkTagException を構築します。
FrameworkTagException(String, Throwable) - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkTagException を構築します。
FrameworkTagException(Throwable) - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のコンストラクタ
この例外の発生原因となる例外を持つ FrameworkTagException を構築します。
FrameworkTagParam - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam.
タグに追加されるパラメータです。
FrameworkTagParam() - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam のコンストラクタ
FrameworkTagParamを新規に生成します。
fire(Event, DataAccessController) - interface jp.co.intra_mart.framework.base.event.EventTrigger のメソッド
イベントに対する処理を行います。
fire(Event, DataAccessController) - class jp.co.intra_mart.framework.base.event.EventTriggerAdapter のメソッド
イベントに対する処理を行います。
fire(Event) - class jp.co.intra_mart.framework.base.event.EventTriggerAdapter のメソッド
イベントに対する処理を行います。
fire(Event, DataAccessController) - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean のメソッド
イベントに対する処理です。
fire(Event) - class jp.co.intra_mart.framework.base.event.StandardEventListener のメソッド
イベントに対する処理です。
fireAll(Event, DataAccessController) - class jp.co.intra_mart.framework.base.event.EventTriggerList のメソッド
すべてのトリガに対してイベントの処理を行います。

G

GenericAttributes - class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes.
汎用属性の集合です。
GenericAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes のコンストラクタ
GenericAttributesを新規に生成します。
GenericEJBEventListener - class jp.co.intra_mart.framework.base.event.GenericEJBEventListener.
EJBを利用する汎用的なイベントリスナです。
GenericEJBEventListener(GenericEJBEventListenerAgentHome, String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListener のコンストラクタ
GenericEJBEventListenerを新規に生成します。
GenericEJBEventListenerAgent - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent.
汎用的なEJB用のイベントリスナのリモートインタフェースです。
GenericEJBEventListenerAgentBean - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean.
EJBを利用する汎用的なイベントリスナーのBeanです。
GenericEJBEventListenerAgentBean() - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean のコンストラクタ
GenericEJBEventListenerAgentBeanを新規に生成します。
GenericEJBEventListenerAgentHome - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome.
リモートインタフェースGenericEJBEventListenerAgentを取得するホームインタフェースです。
GenericEJBEventListenerAgentLocal - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocal.
汎用的なEJB用のイベントリスナのローカルインタフェースです。
GenericEJBEventListenerAgentLocalHome - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocalHome.
ローカルインタフェースGenericEJBEventListenerAgentLocalを取得するホームインタフェースです。
GenericEJBEventListenerFactory - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory.
GenericEJBEventListenerを生成します。
GenericEJBEventListenerFactory() - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory のコンストラクタ
GenericEJBEventListenerFactoryを新規に生成します。
GenericEJBEventListenerLocal - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal.
ローカルEJBを利用する汎用的なイベントリスナです。
GenericEJBEventListenerLocal(GenericEJBEventListenerAgentLocalHome, String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal のコンストラクタ
GenericEJBEventListnerLocalを新規に生成します。
GenericEJBEventListenerLocalFactory - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory.
GenericEJBEventListnerLocalを新規に生成します。
GenericEJBEventListenerLocalFactory() - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory のコンストラクタ
GenericEJBEventListnerLocalFactoryを新規に生成します。
GenericEventListener - class jp.co.intra_mart.framework.base.event.GenericEventListener.
汎用的なイベントリスナです。
GenericEventListener() - class jp.co.intra_mart.framework.base.event.GenericEventListener のコンストラクタ
GenericEventListenerを新規に生成します。
GenericEventListenerFactory - class jp.co.intra_mart.framework.base.event.GenericEventListenerFactory.
GenericEventListenerを生成するイベントリスナファクトリです。
GenericEventListenerFactory() - class jp.co.intra_mart.framework.base.event.GenericEventListenerFactory のコンストラクタ
GenericEventListenerFactoryを新規に生成します。
getAccept() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性acceptの値を取得します。
getAcceptcharset() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性accept-charsetの値を取得します。
getAccesskey() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
accesskeyを取得します。
getAccesskey() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
accesskeyを取得します。
getApplication() - class jp.co.intra_mart.framework.base.event.Event のメソッド
アプリケーションを取得します。
getApplication(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
現在のリクエストに対するアプリケーションIDを取得します。
getApplication() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
アプリケーションIDを取得します。
getApplication() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性applicationの値を取得します。
getApplication() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
アプリケーションを取得します。
getApplication() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
アプリケーションを取得します。
getApplication() - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
applicationを取得します。
getApplication() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
アプリケーションを取得します。
getApplication() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性applicationの値を取得します。
getApplication() - class jp.co.intra_mart.framework.util.IntramartConnectUtil.RequestInfo のメソッド
推奨されていません。 アプリケーションIDを取得します。
getApplicationParamName() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getApplicationParamName() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
アプリケーションIDに該当するパラメータ名を取得します。
getApplicationParamName() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getApplicationParamName() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getApplicationParamName() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getAttribute(String) - class jp.co.intra_mart.framework.base.session.HttpSessionObject のメソッド
推奨されていません。 指定された名前に対応するオブジェクトを取得します。
getAttribute(String) - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のメソッド
推奨されていません。 指定された名前に対応するオブジェクトを取得します。
getAttribute(String) - interface jp.co.intra_mart.framework.base.session.SessionObject のメソッド
指定された名前に対応するオブジェクトを取得します。
getAttributeNames() - class jp.co.intra_mart.framework.base.session.HttpSessionObject のメソッド
推奨されていません。 セッション内に存在する名前の一覧を取得します。
getAttributeNames() - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のメソッド
推奨されていません。 セッション内に存在する名前の一覧を取得します。
getAttributeNames() - interface jp.co.intra_mart.framework.base.session.SessionObject のメソッド
セッション内に存在する名前の一覧を取得します。
getCharset() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
charsetを取得します。
getChildNode() - class jp.co.intra_mart.framework.util.XMLNode のメソッド
子NodeListを返却します。
getClientEncoding() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientEncoding() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientEncoding() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientEncoding() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientEncoding() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientLocale() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientLocale() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientLocale() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
クライアントのロケールを取得します。
getClientLocale() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
クライアントのロケールを取得します。
getClientLocale() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientType() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
クライアントタイプを取得する。
getClientType() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
クライアントタイプを取得する。
getClientType() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
クライアントタイプを取得する。
getClientType() - class jp.co.intra_mart.framework.base.util.UserInfoWrapper のメソッド
ラップされたUserInfoのgetClientType()を呼び出します。
getColorPatternID() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
カラーパターンIDを取得する。
getColorPatternID() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
カラーパターンIDを取得する。
getColorPatternID() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
カラーパターンIDを取得する。
getColorPatternID() - class jp.co.intra_mart.framework.base.util.UserInfoWrapper のメソッド
ラップされたUserInfoのgetColorPatternID()を呼び出します。
getConnection(String) - class jp.co.intra_mart.framework.base.data.DBConnector のメソッド
データベースへのコネクションを取得します。
getConnection() - class jp.co.intra_mart.framework.base.data.DBDAO のメソッド
このDAOに関連づけられたコネクションを取得します。
getConnection(String) - class jp.co.intra_mart.framework.base.data.IntramartDBConnector のメソッド
推奨されていません。 データベースへのコネクションを取得します。
getConnection() - class jp.co.intra_mart.framework.base.data.IntramartDBDAO のメソッド
推奨されていません。 イントラマートで設定されているDBへのコネクションを取得します。
getConnection(String) - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector のメソッド
データベースへのコネクションを取得します。
getConnection() - class jp.co.intra_mart.framework.base.data.LoginGroupDBDAO のメソッド
イントラマートで設定されているDBへのコネクションを取得します。
getConnection(String) - class jp.co.intra_mart.framework.base.data.SystemDBConnector のメソッド
データベースへのコネクションを取得します。
getConnection() - class jp.co.intra_mart.framework.base.data.SystemDBDAO のメソッド
イントラマートで設定されているDBへのコネクションを取得します。
getConnectorClassName(String) - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler のメソッド
データコネクタのクラス名を取得します。
getConnectorClassName(String) - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
データコネクタのクラス名を取得します。
getConnectorClassName(String) - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
データコネクタのクラス名を取得します。
getConnectorClassName(String) - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
データコネクタのクラス名を取得します。
getConnectorClassName(String) - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
データコネクタのクラス名を取得します。
getConnectorName(String, String, String) - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler のメソッド
DAOに対するデータコネクタ名を取得します。
getConnectorName(String, String, String) - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
DAOに対するデータコネクタ名を取得します。
getConnectorName(String, String, String) - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
DAOに対するデータコネクタ名を取得します。
getConnectorName(String, String, String) - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
DAOに対するデータコネクタ名を取得します。
getConnectorName(String, String, String) - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
DAOに対するデータコネクタ名を取得します。
getConnectorResource(String) - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler のメソッド
データコネクタのリソース名を取得します。
getConnectorResource(String) - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
データコネクタのリソース名を取得します。
getConnectorResource(String) - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
データコネクタのリソース名を取得します。
getConnectorResource(String) - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
データコネクタのリソース名を取得します。
getConnectorResource(String) - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
データコネクタのリソース名を取得します。
getContextPath() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
getContextPath() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
getContextPath() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
getContextPath() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
getContextPath() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
getControllerConverterConfig(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
getControllerConverterConfig(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
getControllerConverterConfig(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
キーに該当するコントローラコンバータの初期パラメータを取得します。
getControllerConverterConfig(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
getControllerConverterConfig(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
キーに該当するコントローラコンバータの初期パラメータを取得します。
getControllerConverterName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
getControllerConverterName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
getControllerConverterName(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
コントローラコンバータのクラス名を取得します。
getControllerConverterName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
getControllerConverterName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
コントローラコンバータのクラス名を取得します。
getControllerObject() - interface jp.co.intra_mart.framework.base.service.RequestInfo のメソッド
リクエストから生成されたコントローラオブジェクトを取得します。
getControllerObject() - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
コントローラオブジェクトを取得します。
getControllerObject() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
コントローラオブジェクトを取得します。
getControllerObject(String, String, Locale, RequestInfo) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
コントーラオブジェクトを取得します。
getCoords() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
coordsを取得します。
getCoords() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
coordsを取得します。
getDAO(String, String, String) - class jp.co.intra_mart.framework.base.data.DataAccessController のメソッド
DAOを取得します。
getDAO(String, String, String) - class jp.co.intra_mart.framework.base.event.EventTriggerAdapter のメソッド
DAOを取得します。
getDAO(String, String, String) - class jp.co.intra_mart.framework.base.event.StandardEventListener のメソッド
DAOを取得します。
getDAOName(String, String, String) - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler のメソッド
DAOのクラス名を取得します。
getDAOName(String, String, String) - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
DAOのクラス名を取得します。
getDAOName(String, String, String) - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
DAOのクラス名を取得します。
getDAOName(String, String, String) - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
DAOのクラス名を取得します。
getDAOName(String, String, String) - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
DAOのクラス名を取得します。
getDataAccessController() - class jp.co.intra_mart.framework.base.data.DataManager のメソッド
データアクセスコントローラを取得します。
getDataAccessController() - interface jp.co.intra_mart.framework.base.data.container.DataContainer のメソッド
データアクセスコントローラを取得します。
getDataAccessController() - class jp.co.intra_mart.framework.base.data.container.DataContainerImpl のメソッド
データアクセスコントローラを取得します。
getDataAccessController() - class jp.co.intra_mart.framework.base.event.StandardEventListener のメソッド
このイベントリスナで使用するデータアクセスコントローラです。
getDataConnectors() - class jp.co.intra_mart.framework.base.data.DataAccessController のメソッド
DataAccessControllerがキャッシュしているDataConnectorの一覧を取得します。
getDataManager() - class jp.co.intra_mart.framework.base.data.DataManager の static メソッド
データマネージャを取得します。
getDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.DataAccessController のメソッド
データプロパティハンドラを取得します。
getDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.DataConnector のメソッド
データプロパティハンドラを取得します。
getDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.DataManager のメソッド
データプロパティハンドラを取得します。
getDataPropertyHandler() - interface jp.co.intra_mart.framework.base.data.container.DataContainer のメソッド
データプロパティハンドラを取得します。
getDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.container.DataContainerImpl のメソッド
データプロパティハンドラを取得します。
getDetails() - class jp.co.intra_mart.framework.base.service.validator.ValidationExceptionDetail のメソッド
検証結果の詳細の一覧を取得します。
getDir() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性dirの値を取得します。
getDir() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
dirを取得します。
getDir() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
dirを取得します。
getDir() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性dirの値を取得します。
getDir() - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes のメソッド
属性dirの値を取得します。
getDocument(String) - class jp.co.intra_mart.framework.util.XMLDocumentProducer のメソッド
プロパティハンドラを初期化します。
getDouble(String, double) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
指定項目に設定されている値を数値に変換して返します。
getDouble(String) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
指定項目に設定されている値を数値に変換して返します。
getEncoding(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
現在のリクエストに対するエンコーディングを取得します。
getEncoding() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
エンコーディングを取得する。
getEncoding() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
エンコーディングを取得する。
getEncoding() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
エンコーディングを取得する。
getEncoding() - class jp.co.intra_mart.framework.base.util.UserInfoWrapper のメソッド
ラップされたUserInfoのgetEncoding()を呼び出します。
getEncodingAttributeName() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
getEncodingAttributeName() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
getEncodingAttributeName() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
getEncodingAttributeName() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
getEncodingAttributeName() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
getEnctype() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性enctypeの値を取得します。
getEntity(String) - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
リクエストから指定された名前に該当するエンティティを取得します。
getEntity(String) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
リクエストから指定された名前に該当するエンティティを取得します。
getEventListenerFactoryName(String, String) - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリのクラス名を取得します。
getEventListenerFactoryName(String, String) - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリのクラス名を取得します。
getEventListenerFactoryName(String, String) - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリのクラス名を取得します。
getEventListenerFactoryName(String, String) - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリのクラス名を取得します。
getEventListenerFactoryName(String, String) - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
アプリケーションIDとキーに該当するイベントリスナファクトリのクラス名を取得します。
getEventListenerFactoryParams(String, String) - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
getEventListenerFactoryParams(String, String) - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
getEventListenerFactoryParams(String, String) - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
getEventListenerFactoryParams(String, String) - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
getEventListenerFactoryParams(String, String) - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
アプリケーションIDとキーに該当するイベントリスナファクトリの初期パラメータを取得します。
getEventManager() - class jp.co.intra_mart.framework.base.event.EventManager の static メソッド
イベントマネージャを取得します。
getEventName(String, String) - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
キーに該当するイベントのクラス名を取得します。
getEventName(String, String) - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
キーに該当するイベントのクラス名を取得します。
getEventName(String, String) - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler のメソッド
キーに該当するイベントのクラス名を取得します。
getEventName(String, String) - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
キーに該当するイベントのクラス名を取得します。
getEventName(String, String) - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
アプリケーションIDとキーに該当するイベントのクラス名を取得します。
getEventPropertyHandler() - class jp.co.intra_mart.framework.base.event.EventManager のメソッド
イベントプロパティハンドラを取得します。
getEventPropertyHandler() - interface jp.co.intra_mart.framework.base.event.container.EventContainer のメソッド
イベントプロパティハンドラを取得します。
getEventPropertyHandler() - class jp.co.intra_mart.framework.base.event.container.EventContainerImpl のメソッド
イベントプロパティハンドラを取得します。
getEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getEventTriggerInfos(String, String) - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
アプリケーションIDとキーに該当するイベントのイベントトリガ情報をすべて取得します。
getException() - class jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean のメソッド
例外を取得します。
getException() - class jp.co.intra_mart.framework.system.exception.FrameworkException のメソッド
この例外が発生した原因となる例外を取得します。
getExceptionAttributeName() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
getExceptionAttributeName() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
getExceptionAttributeName() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
getExceptionAttributeName() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
getExceptionAttributeName() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
getExtesion() - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
サービスフレームワークを呼び出すための拡張子を取得します。
getFileName(String, Locale) - class jp.co.intra_mart.framework.util.XMLDocumentProducer の static メソッド
ファイル名を取得します。
getFloat(String, float) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
指定項目に設定されている値を数値に変換して返します。
getFloat(String) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
指定項目に設定されている値を数値に変換して返します。
getForm() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
ターゲットとなるフォーム名を取得します。
getFormclass() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性classの値を取得します。
getFrameClass() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
推奨されていません。 このメソッドではなくFrameTag.getFrameclass()メソッドを使用してください。
getFrameborder() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
frameborderを取得します。
getFrameclass() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
frameClassを取得します。
getHelperclass() - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag のメソッド
クラス名を取得します。
getHreflang() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
hreflangを取得します。
getInitParameter(String) - interface jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfig のメソッド
ControllerConverterを初期化するときのパラメータを取得します。
getInitParameter(String) - interface jp.co.intra_mart.framework.base.service.validator.ValidatorConfig のメソッド
Validatorを初期化するときのパラメータを取得します。
getInitParameter(String) - class jp.co.intra_mart.framework.system.util.Config のメソッド
Validatorを初期化するときのパラメータを取得します。
getInitParameterNames() - interface jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfig のメソッド
初期化パラメータの名前の一覧を取得します。
getInitParameterNames() - interface jp.co.intra_mart.framework.base.service.validator.ValidatorConfig のメソッド
初期化パラメータの名前の一覧を取得します。
getInitParameterNames() - class jp.co.intra_mart.framework.system.util.Config のメソッド
初期化パラメータの名前の一覧を取得します。
getInputErrorPage(RequestException) - class jp.co.intra_mart.framework.base.service.DefaultTransition のメソッド
入力エラーのページを取得します。
getInputErrorPage(RequestException) - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のメソッド
入力エラーのページを取得します。
getInputErrorPage(RequestException) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
入力エラーのページを取得します。
getInputErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
getInputErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
getInputErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
getInputErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
getInputErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
getInputErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
getInputErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
getInputErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
getInputErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale)を使用してください。
getInputErrorPagePath(String, String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, String, Locale)を使用してください。
getInputErrorPagePath(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, Locale)を使用してください。
getInputErrorPagePath(String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
getInputErrorPagePath(Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale)を使用してください。
getInputErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, String, Locale)を使用してください。
getInputErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, Locale)を使用してください。
getInputErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
getInputErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
getInputErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
getInputErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
getInputErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
getInputErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInteger(String, int) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
指定項目に設定されている値を整数に変換して返します。
getInteger(String) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
指定項目に設定されている値を整数に変換して返します。
getJNDIName() - class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory のメソッド
EJBEventListenerAgentHomeのJNDI名を取得します。
getKey() - class jp.co.intra_mart.framework.base.event.Event のメソッド
イベントキーを取得します。
getKey() - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
keyを取得します。
getKeys() - class jp.co.intra_mart.framework.util.FileResourceBundle のメソッド
キーの列挙を返します。
getLang() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性langの値を取得します。
getLang() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
langを取得します。
getLang() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
langを取得します。
getLang() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性langの値を取得します。
getLang() - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes のメソッド
属性langの値を取得します。
getLinkClass() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
推奨されていません。 このメソッドではなくLinkTag.getLinkclass()メソッドを使用してください。
getLinkclass() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
linkClassを取得します。
getLinkclass() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
linkClassを取得します。
getListenerName() - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory のメソッド
EJBEventListenerAgentBeanのクラス名を取得します。
getListenerName() - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory のメソッド
EJBEventListenerAgentBeanのクラス名を取得します。
getLocale(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
現在のリクエストに対するロケールを取得します。
getLocale() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ユーザのロケールを取得する。
getLocale() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
ユーザのロケールを取得する。
getLocale() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
ユーザのロケールを取得する。
getLocale() - class jp.co.intra_mart.framework.base.util.UserInfoWrapper のメソッド
ラップされたUserInfoのgetLocale()を呼び出します。
getLocale() - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
localeを取得します。
getLocale() - class jp.co.intra_mart.framework.util.FileResourceBundle のメソッド
ResourceBundle の Locale を返します。
getLocaleAttributeName() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
getLocaleAttributeName() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
getLocaleAttributeName() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
getLocaleAttributeName() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
getLocaleAttributeName() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
getLogAgent() - class jp.co.intra_mart.framework.system.log.LogManager のメソッド
ログエージェントを取得します。
getLogAgentName() - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler のメソッド
ログエージェントのクラス名を取得します。
getLogAgentName() - interface jp.co.intra_mart.framework.system.log.LogPropertyHandler のメソッド
ログエージェントのクラス名を取得します。
getLogAgentName() - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler のメソッド
ログエージェントのクラス名を取得します。
getLogAgentParams() - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler のメソッド
ログエージェントのパラメータを取得します。
getLogAgentParams() - interface jp.co.intra_mart.framework.system.log.LogPropertyHandler のメソッド
ログエージェントのパラメータを取得します。
getLogAgentParams() - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler のメソッド
ログエージェントのパラメータを取得します。
getLogManager() - class jp.co.intra_mart.framework.system.log.LogManager の static メソッド
ログマネージャを取得します。
getLogPropertyHandler() - class jp.co.intra_mart.framework.system.log.LogManager のメソッド
ログプロパティハンドラを取得します。
getLoginGroup() - class jp.co.intra_mart.framework.base.event.Event のメソッド
推奨されていません。 このメソッドではなくEvent.getUserInfo()を使用してください。
getLoginGroupID() - class jp.co.intra_mart.framework.base.event.Event のメソッド
推奨されていません。 このメソッドではなくEvent.getUserInfo()を使用してください。
getLoginGroupID() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
推奨されていません。 このメソッドではなくServiceControllerAdapter.getUserInfo()を使用してください。
getLoginGroupID() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログイングループIDを取得する。
getLoginGroupID() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
ログイングループIDを取得する。
getLoginGroupID() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
ログイングループIDを取得する。
getLoginGroupID() - class jp.co.intra_mart.framework.base.util.UserInfoWrapper のメソッド
ラップされたUserInfoのgetLoginGroupID()を呼び出します。
getLoginGroupID() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
推奨されていません。 このメソッドではなくHelperBean.getUserInfo()を使用してください。
getLoginGroupIDKey() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
セッションに登録されているログイングループIDのキーを取得します。
getLoginGroupIDKey() - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler のメソッド
セッションに登録されているログイングループIDのキーを取得します。
getLoginGroupIDKey() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
セッションに登録されているログイングループIDのキーを取得します。
getLoginTime() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログインした時間を取得する。
getLoginTime() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
ログインした時間を取得する。
getLoginTime() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
ログインした時間を取得する。
getLoginTime() - class jp.co.intra_mart.framework.base.util.UserInfoWrapper のメソッド
ラップされたUserInfoのgetLoginTime()を呼び出します。
getLoginType() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログインタイプを取得する。
getLoginType() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
ログインタイプを取得する。
getLoginType() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
ログインタイプを取得する。
getLoginType() - class jp.co.intra_mart.framework.base.util.UserInfoWrapper のメソッド
ラップされたUserInfoのgetLoginType()を呼び出します。
getLoginUser() - class jp.co.intra_mart.framework.base.event.Event のメソッド
推奨されていません。 このメソッドではなくEvent.getUserInfo()を使用してください。
getLoginUserID() - class jp.co.intra_mart.framework.base.event.Event のメソッド
推奨されていません。 このメソッドではなくEvent.getUserInfo()を使用してください。
getLoginUserID() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
推奨されていません。 このメソッドではなくServiceControllerAdapter.getUserInfo()を使用してください。
getLoginUserID() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
推奨されていません。 このメソッドではなくHelperBean.getUserInfo()を使用してください。
getLoginUserIDKey() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
セッションに登録されているログインユーザIDのキーを取得します。
getLoginUserIDKey() - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler のメソッド
セッションに登録されているログインユーザIDのキーを取得します。
getLoginUserIDKey() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
セッションに登録されているログインユーザIDのキーを取得します。
getLong(String, long) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
指定項目に設定されている値を整数に変換して返します。
getLong(String) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
指定項目に設定されている値を整数に変換して返します。
getLongdesc() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
longdescを取得します。
getMarginheight() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
marginheightを取得します。
getMarginwidth() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
marginwidthを取得します。
getMessage(String, String) - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler のメソッド
メッセージを取得します。
getMessage(String, String, Locale) - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler のメソッド
メッセージを取得します。
getMessage(String, String, Object[]) - class jp.co.intra_mart.framework.base.message.MessageManager のメソッド
ロケールを指定せず、キーに該当するメッセージを取得します。
getMessage(String, String, Object[], Locale) - class jp.co.intra_mart.framework.base.message.MessageManager のメソッド
ロケールを指定し、キーに該当するメッセージを取得します。
getMessage(String, String) - interface jp.co.intra_mart.framework.base.message.MessagePropertyHandler のメソッド
メッセージを取得します。
getMessage(String, String, Locale) - interface jp.co.intra_mart.framework.base.message.MessagePropertyHandler のメソッド
メッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler のメソッド
メッセージを取得します。
getMessage(String, String, Locale) - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler のメソッド
メッセージを取得します。
getMessage() - class jp.co.intra_mart.framework.base.service.validator.ValidationException のメソッド
例外メッセージを取得します。
getMessage() - class jp.co.intra_mart.framework.base.service.validator.ValidationExceptionDetail のメソッド
検証結果のメッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler のメソッド
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
DefaultMessagePropertyHandler.getMessage(String)を使用してください。
getMessage(String) - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler のメソッド
キーに該当するメッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler のメソッド
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
パラメータloginGroupは実際には使用しません。IntramartMessagePropertyHandler.getMessage(String)を使用してください。
getMessage(String) - class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler のメソッド
キーに該当するメッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.framework.system.message.MessageManager のメソッド
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
設定されているMessagePropertyHandlerによっては、 パラメータloginGroupは実際には使用しない可能性があります。MessageManager.getMessage(String)を使用してください。
getMessage(String) - class jp.co.intra_mart.framework.system.message.MessageManager のメソッド
キーに該当するメッセージを取得します。
getMessage(String, String) - interface jp.co.intra_mart.framework.system.message.MessagePropertyHandler のメソッド
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
MessagePropertyHandler.getMessage(String)を使用してください。
getMessage(String) - interface jp.co.intra_mart.framework.system.message.MessagePropertyHandler のメソッド
キーに該当するメッセージを取得します。
getMessageManager() - class jp.co.intra_mart.framework.base.message.MessageManager の static メソッド
メッセージマネージャを取得します。
getMessageManager() - class jp.co.intra_mart.framework.system.message.MessageManager の static メソッド
MessageManagerを取得します。
getMessagePropertyHandler() - class jp.co.intra_mart.framework.base.message.MessageManager のメソッド
メッセージプロパティハンドラを取得します。
getMessagePropertyHandler() - class jp.co.intra_mart.framework.system.message.MessageManager のメソッド
メッセージプロパティハンドラを取得します。
getMethod() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性methodの値を取得します。
getName() - class jp.co.intra_mart.framework.base.event.EventTriggerInfo のメソッド
イベントトリガ名を取得します。
getName() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性nameの値を取得します。
getName() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
nameを取得します。
getName() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
nameを取得します。
getName() - class jp.co.intra_mart.framework.base.web.tag.ParamTag のメソッド
パラメータ名を取得します。
getName() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
nameを取得します。
getName() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性nameを取得します。
getName() - class jp.co.intra_mart.framework.system.property.PropertyParam のメソッド
パラメータ名を取得します。
getNetworkFile(String) - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector のメソッド
Storageサービス上の指定されたパスのファイルにアクセスするNetworkFileを取得します。
getNetworkFile(String) - class jp.co.intra_mart.framework.base.data.IntramartFileServerDAO のメソッド
パスに該当するNetworkFileを取得します。
getNextPage() - class jp.co.intra_mart.framework.base.service.DefaultTransition のメソッド
次に遷移するページを取得します。
getNextPage() - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のメソッド
次に遷移するページを取得します。
getNextPage() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
次に遷移するページを取得します。
getNextPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
getNextPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
getNextPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
getNextPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
getNextPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getNextPagePath(String, String, Locale)を使用してください。
getNextPagePath(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getNextPagePath(String, String, String, Locale)を使用してください。
getNextPagePath(String, String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getNextPagePath(String, String, Locale)を使用してください。
getNextPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getNextPagePath(String, String, String, Locale)を使用してください。
getNextPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
このトランジションに設定されているアプリケーションIDとサービスIDに該当する次ページのパスを取得します。
getNextPagePath(String) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
このトランジションに設定されているアプリケーションIDとサービスIDと、指定されたキーに該当する次ページのパスを取得します。
getNextPagePath(String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
getNextPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
getNextPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNode() - class jp.co.intra_mart.framework.util.XMLNode のメソッド
Nodeを取得します。
getNodeList() - class jp.co.intra_mart.framework.util.XMLNode のメソッド
NodeListを返却します。
getNodeName() - class jp.co.intra_mart.framework.util.XMLNode のメソッド
ノード名を返却します。
getNoresize() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
noresizeを取得します。
getNumber() - class jp.co.intra_mart.framework.base.event.EventTriggerInfo のメソッド
ソート番号を取得します。
getOnClick() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onClickの値を取得します。
getOnDblClick() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onDblClickの値を取得します。
getOnKeyDown() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyDownの値を取得します。
getOnKeyPress() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyPressの値を取得します。
getOnKeyUp() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyUpの値を取得します。
getOnMouseDown() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseDownの値を取得します。
getOnMouseMove() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseMoveの値を取得します。
getOnMouseOut() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseOutの値を取得します。
getOnMouseOver() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseOverの値を取得します。
getOnMouseUp() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseUpの値を取得します。
getOnblur() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
onblurを取得します。
getOnblur() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
onblurを取得します。
getOnblur() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onBlurを取得します。
getOnclick() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onClickの値を取得します。
getOnclick() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onClickの値を取得します。
getOnclick() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onClickの値を取得します。
getOnclick() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onClickの値を取得します。
getOndblclick() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onDblClickの値を取得します。
getOndblclick() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onDblClickの値を取得します。
getOndblclick() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onDblClickの値を取得します。
getOndblclick() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onDblClickの値を取得します。
getOnfocus() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
onfocusを取得します。
getOnfocus() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
onfocusを取得します。
getOnfocus() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onFocusを取得します。
getOnkeydown() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onKeyDownの値を取得します。
getOnkeydown() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onKeyDownの値を取得します。
getOnkeydown() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onKeyDownの値を取得します。
getOnkeydown() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onKeyDownの値を取得します。
getOnkeypress() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onKeyPressの値を取得します。
getOnkeypress() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onKeyPressの値を取得します。
getOnkeypress() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onKeyPressの値を取得します。
getOnkeypress() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onKeyPressの値を取得します。
getOnkeyup() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onKeyUpの値を取得します。
getOnkeyup() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onKeyUpの値を取得します。
getOnkeyup() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onKeyUpの値を取得します。
getOnkeyup() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onKeyUpの値を取得します。
getOnmousedown() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseDownの値を取得します。
getOnmousedown() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseDownの値を取得します。
getOnmousedown() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseDownの値を取得します。
getOnmousedown() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseDownの値を取得します。
getOnmousemove() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseMoveの値を取得します。
getOnmousemove() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseMoveの値を取得します。
getOnmousemove() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseMoveの値を取得します。
getOnmousemove() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseMoveの値を取得します。
getOnmouseout() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseOutの値を取得します。
getOnmouseout() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseOutの値を取得します。
getOnmouseout() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseOutの値を取得します。
getOnmouseout() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseOutの値を取得します。
getOnmouseover() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseOverの値を取得します。
getOnmouseover() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseOverの値を取得します。
getOnmouseover() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseOverの値を取得します。
getOnmouseover() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseOverの値を取得します。
getOnmouseup() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseUpの値を取得します。
getOnmouseup() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseUpの値を取得します。
getOnmouseup() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseUpの値を取得します。
getOnmouseup() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseUpの値を取得します。
getOnreset() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onResetの値を取得します。
getOnsubmit() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onSubmitの値を取得します。
getPostEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getPostEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getPostEventTriggerInfos(String, String) - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getPostEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getPostEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getPropertyDescriptors() - class jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo のメソッド
PropertyDescriptorを取得します。
getPropertyDescriptors() - class jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo のメソッド
PropertyDescriptorを取得します。
getPropertyDescriptors() - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo のメソッド
PropertyDescriptorを取得します。
getPropertyDescriptors() - class jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo のメソッド
PropertyDescriptorを取得します。
getPropertyDescriptors() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo のメソッド
PropertyDescriptorを取得します。
getPropertyDescriptors() - class jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo のメソッド
PropertyDescriptorを取得します。
getPropertyHandler(String) - class jp.co.intra_mart.framework.system.property.PropertyManager のメソッド
キーで指定されたプロパティハンドラを取得します。
getPropertyHandlerName(String) - class jp.co.intra_mart.framework.system.property.DefaultPropertyManager のメソッド
キーで指定されたプロパティハンドラのクラス名を取得します。
getPropertyHandlerName(String) - class jp.co.intra_mart.framework.system.property.PropertyConfigModel のメソッド
指定されたキーのプロパティハンドラ名を取得します。
getPropertyHandlerName(String) - class jp.co.intra_mart.framework.system.property.PropertyManager のメソッド
キーで指定されたプロパティハンドラのクラス名を取得します。
getPropertyHandlerName(String) - class jp.co.intra_mart.framework.system.property.XmlPropertyManager のメソッド
キーで指定されたプロパティハンドラのクラス名を取得します。
getPropertyHandlerParams(String) - class jp.co.intra_mart.framework.system.property.DefaultPropertyManager のメソッド
キーで指定されたプロパティハンドラの初期化データを取得します。
getPropertyHandlerParams(String) - class jp.co.intra_mart.framework.system.property.PropertyManager のメソッド
キーで指定されたプロパティハンドラの初期化データを取得します。
getPropertyHandlerParams(String) - class jp.co.intra_mart.framework.system.property.XmlPropertyManager のメソッド
キーで指定されたプロパティハンドラの初期化データを取得します。
getPropertyManager() - class jp.co.intra_mart.framework.system.property.PropertyManager の static メソッド
プロパティマネージャを取得します。
getPropertyParams(String) - class jp.co.intra_mart.framework.system.property.PropertyConfigModel のメソッド
指定されたキーのプロパティのパラメータを取得します。
getProvider() - class jp.co.intra_mart.framework.base.data.container.factory.DataContainerFactory のメソッド
プロバイダを返します。
getProvider() - class jp.co.intra_mart.framework.base.event.container.factory.EventContainerFactory のメソッド
プロバイダを返します。
getProvider() - class jp.co.intra_mart.framework.base.service.container.factory.ServiceContainerFactory のメソッド
プロバイダを返します。
getProvider() - interface jp.co.intra_mart.framework.system.container.factory.IMContainerFactory のメソッド
getRealUserInfo() - class jp.co.intra_mart.framework.base.util.UserInfoWrapper のメソッド
このオブジェクトがラップしているUserInfoの実装を返します。
getRel() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
relを取得します。
getRequest() - interface jp.co.intra_mart.framework.base.service.RequestInfo のメソッド
リクエストを取得します。
getRequest() - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
リクエストを取得します。
getRequest() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
リクエストを取得します。
getRequest() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
リクエストを取得します。
getRequest() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
リクエストを取得します。
getRequestInfo(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.util.IntramartConnectUtil の static メソッド
推奨されていません。 リクエスト情報を取得します。
getResource(String, String, String) - class jp.co.intra_mart.framework.base.data.DBConnector のメソッド
リソースを取得します。
getResource(String, String, String) - class jp.co.intra_mart.framework.base.data.DataConnector のメソッド
リソースを取得します。
getResource(String, String, String) - class jp.co.intra_mart.framework.base.data.IntramartDBConnector のメソッド
推奨されていません。 リソースを取得します。
getResource(String, String, String) - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector のメソッド
リソースを取得します。
getResource(String, String, String) - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector のメソッド
リソースを取得します。
getResource(String, String, String) - class jp.co.intra_mart.framework.base.data.SystemDBConnector のメソッド
リソースを取得します。
getResourceParams(String) - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler のメソッド
リソースのパラメータを取得します。
getResourceParams(String) - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
リソースのパラメータを取得します。
getResourceParams(String) - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
リソースのパラメータを取得します。
getResourceParams(String) - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
リソースのパラメータを取得します。
getResourceParams(String) - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
リソースのパラメータを取得します。
getResponse() - interface jp.co.intra_mart.framework.base.service.RequestInfo のメソッド
レスポンスを取得します。
getResponse() - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
レスポンスを取得します。
getResponse() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
レスポンスを取得します。
getResponse() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
レスポンスを取得します。
getResponse() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
レスポンスを取得します。
getResult() - interface jp.co.intra_mart.framework.base.service.RequestInfo のメソッド
サービス処理結果を取得します。
getResult() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
サービス処理結果を取得します。
getRev() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
revを取得します。
getRoot(Document) - class jp.co.intra_mart.framework.util.XMLDocumentProducer のメソッド
ノードを取得します。
getScrolling() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
scrollingを取得します。
getSecurityExt() - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter のメソッド
推奨されていません。 セキュリティの拡張子を取得します。
getService(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
現在のリクエストに対するサービスIDを取得します。
getService() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
サービスIDを取得します。
getService() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性serviceの値を取得します。
getService() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
サービスを取得します。
getService() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
サービスを取得します。
getService() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
サービスを取得します。
getService() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性serviceの値を取得します。
getService() - class jp.co.intra_mart.framework.util.IntramartConnectUtil.RequestInfo のメソッド
推奨されていません。 サービスIDを取得します。
getServiceController(String, String) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
推奨されていません。 このメソッドではなくServiceManager.getServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
getServiceController(String, String, Locale) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
サービスコントローラを取得します。
getServiceController(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.container.ServiceContainer のメソッド
サービスコントローラを取得します。
getServiceController(String, String, Locale) - class jp.co.intra_mart.framework.base.service.container.ServiceContainerImpl のメソッド
サービスコントローラを取得します。
getServiceControllerName(String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
getServiceControllerName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
サービスコントローラのクラス名を取得します。
getServiceControllerName(String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
getServiceControllerName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
サービスコントローラのクラス名を取得します。
getServiceControllerName(String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceControllerName(String, String, Locale)を使用してください。
getServiceControllerName(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
サービスコントローラのクラス名を取得します。
getServiceControllerName(String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceControllerName(String, String, Locale)を使用してください。
getServiceControllerName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
サービスコントローラのクラス名を取得します。
getServiceControllerName(String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
getServiceControllerName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
サービスコントローラのクラス名を取得します。
getServiceErrorPage(Exception) - class jp.co.intra_mart.framework.base.service.DefaultTransition のメソッド
処理エラーのページを取得します。
getServiceErrorPage(Exception) - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のメソッド
処理エラーのページを取得します。
getServiceErrorPage(Exception) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
処理エラーのページを取得します。
getServiceErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
getServiceErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
getServiceErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
getServiceErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
getServiceErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
getServiceErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
getServiceErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
getServiceErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
getServiceErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale)を使用してください。
getServiceErrorPagePath(String, String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, String, Locale)を使用してください。
getServiceErrorPagePath(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, Locale)を使用してください。
getServiceErrorPagePath(String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(Locale)を使用してください。
getServiceErrorPagePath(Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale)を使用してください。
getServiceErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, String, Locale)を使用してください。
getServiceErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, Locale)を使用してください。
getServiceErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(Locale)を使用してください。
getServiceErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
getServiceErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
getServiceErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
getServiceErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
getServiceErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceManager() - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 サービスマネージャを取得します。
getServiceManager() - class jp.co.intra_mart.framework.base.service.ServiceManager の static メソッド
サービスマネージャを取得します。
getServiceManager() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
サービスマネージャを取得します。
getServiceParamName() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getServiceParamName() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
サービスIDに該当するパラメータ名を取得します。
getServiceParamName() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getServiceParamName() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getServiceParamName() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 サービスプロパティハンドラを取得します。
getServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
サービスプロパティハンドラを取得します。
getServicePropertyHandler() - interface jp.co.intra_mart.framework.base.service.container.ServiceContainer のメソッド
サービスプロパティハンドラを取得します。
getServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.container.ServiceContainerImpl のメソッド
サービスプロパティハンドラを取得します。
getServicePropertyHandler() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
サービスプロパティハンドラを取得します。
getServiceServletPath() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
サービスサーブレットのパスを取得します。
getServiceServletPath() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
サービスサーブレットのパスを取得します。
getServiceServletPath() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getServiceServletPath() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
サービスサーブレットのパスを取得します。
getServiceServletPath() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
サービスサーブレットのパスを取得します。
getSession() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
getSessionErrorPagePath() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
セッションエラーページのパスを取得します。
getSessionErrorPagePath() - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler のメソッド
セッションエラーページのパスを取得します。
getSessionErrorPagePath() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
セッションエラーページのパスを取得します。
getSessionFactory() - class jp.co.intra_mart.framework.base.session.SessionManager のメソッド
セッションファクトリを取得します。
getSessionFactoryName() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
getSessionFactoryName() - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler のメソッド
推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
getSessionFactoryName() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
getSessionID() - class jp.co.intra_mart.framework.base.session.HttpSessionObject のメソッド
推奨されていません。 セッションを一意に識別するIDを取得します。
getSessionID() - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のメソッド
推奨されていません。 セッションを一意に識別するIDを取得します。
getSessionID() - interface jp.co.intra_mart.framework.base.session.SessionObject のメソッド
セッションを一意に識別するIDを取得します。
getSessionManager() - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 セッションマネージャを取得します。
getSessionManager() - class jp.co.intra_mart.framework.base.session.SessionManager の static メソッド
セッションマネージャを取得します。
getSessionObject() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
getSessionObject(ServletRequest) - class jp.co.intra_mart.framework.base.session.SessionManager のメソッド
セッションオブジェクトを取得します。
getSessionObjectKey() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
推奨されていません。 HttpSessionを直接取得するようにしてください。
getSessionObjectKey() - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler のメソッド
推奨されていません。 HttpSessionを直接取得するようにしてください。
getSessionObjectKey() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
推奨されていません。 HttpSessionを直接取得するようにしてください。
getSessionParameter() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
getSessionParameter() - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler のメソッド
推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
getSessionParameter() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
getSessionPropertyHandler() - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 セッションプロパティハンドラを取得します。
getSessionPropertyHandler() - class jp.co.intra_mart.framework.base.session.SessionManager のメソッド
セッションプロパティハンドラを取得します。
getShape() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
shapeを取得します。
getShape() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
shapeを取得します。
getString(String) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
プロパティを取得します。
getString(String, String) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
プロパティを取得します。
getStyle() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性styleの値を取得します。
getStyle() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
styleを取得します。
getStyle() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
styleを取得します。
getStyle() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
styleを取得します。
getStyle() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性styleの値を取得します。
getStyle() - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性styleの値を取得します。
getSubmitclass() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性classの値を取得します。
getSystemErrorPage(Exception) - class jp.co.intra_mart.framework.base.service.DefaultTransition のメソッド
システムエラーのページを取得します。
getSystemErrorPage(Exception) - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のメソッド
システムエラーのページを取得します。
getSystemErrorPage(Exception) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
システムエラーのページを取得します。
getSystemErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
getSystemErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
getSystemErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
getSystemErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
getSystemErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
getSystemErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
getSystemErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
getSystemErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
getSystemErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale)を使用してください。
getSystemErrorPagePath(String, String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, String, Locale)を使用してください。
getSystemErrorPagePath(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, Locale)を使用してください。
getSystemErrorPagePath(String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
getSystemErrorPagePath(Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale)を使用してください。
getSystemErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, String, Locale)を使用してください。
getSystemErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, Locale)を使用してください。
getSystemErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
getSystemErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
getSystemErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
getSystemErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
getSystemErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
getSystemErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getTabindex() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
tabindexを取得します。
getTabindex() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
tabindexを取得します。
getTabindex() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
tabindexを取得します。
getTagClass() - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性classの値を取得します。
getTagWriter() - class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes のメソッド
TagWriterを取得します。
getTarget() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性targetの値を取得します。
getTarget() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
targetを取得します。
getThrowable() - interface jp.co.intra_mart.framework.base.service.RequestInfo のメソッド
処理中に発生した例外を取得します。
getTitle() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性titleの値を取得します。
getTitle() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
titleを取得します。
getTitle() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
titleを取得します。
getTitle() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
titleを取得します。
getTitle() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性titleの値を取得します。
getTitle() - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性titleの値を取得します。
getTransition(String, String) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
推奨されていません。 このメソッドではなくServiceManager.getTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
getTransition(String, String, Locale) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
トランジションを取得します。
getTransition(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.container.ServiceContainer のメソッド
トランジションを取得します。
getTransition(String, String, Locale) - class jp.co.intra_mart.framework.base.service.container.ServiceContainerImpl のメソッド
トランジションを取得します。
getTransitionName(String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
getTransitionName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
トランジションのクラス名を取得します。
getTransitionName(String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
getTransitionName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
トランジションのクラス名を取得します。
getTransitionName(String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getTransitionName(String, String, Locale)を使用してください。
getTransitionName(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
トランジションのクラス名を取得します。
getTransitionName(String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getTransitionName(String, String, Locale)を使用してください。
getTransitionName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
トランジションのクラス名を取得します。
getTransitionName(String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
getTransitionName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
トランジションのクラス名を取得します。
getType() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
typeを取得します。
getURI() - class jp.co.intra_mart.framework.util.XMLNode のメソッド
URIを返却します。
getURI(String) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
URIを取得します。
getUserID() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログインユーザIDを取得する。
getUserID() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
ログインユーザIDを取得する。
getUserID() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
ログインユーザIDを取得する。
getUserID() - class jp.co.intra_mart.framework.base.util.UserInfoWrapper のメソッド
ラップされたUserInfoのgetUserID()を呼び出します。
getUserInfo() - class jp.co.intra_mart.framework.base.event.Event のメソッド
ログインユーザの情報を取得します。
getUserInfo() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
ユーザ情報を取得します。
getUserInfo() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
ログインユーザ情報を取得します。
getValidationExceptionDetails() - class jp.co.intra_mart.framework.base.service.validator.ValidationException のメソッド
検証結果の詳細の一覧を取得します。
getValidatorClassName() - class jp.co.intra_mart.framework.base.service.ValidatorMapping のメソッド
バリデータ名を取得します。
getValidatorConfig() - class jp.co.intra_mart.framework.base.service.ValidatorMapping のメソッド
バリデータの初期化パラメータを取得します。
getValidatorMapping(String, String, Locale) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
バリデータを取得します。
getValidators(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
getValidators(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
getValidators(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
キーに該当するバリデータを取得します。
getValidators(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
getValidators(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
キーに該当するバリデータを取得します。
getValue() - class jp.co.intra_mart.framework.base.web.tag.MessageParamTag のメソッド
パラメータの値を取得します。
getValue() - class jp.co.intra_mart.framework.base.web.tag.ParamTag のメソッド
パラメータの値を取得します。
getValue() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性valueを取得します。
getValue() - class jp.co.intra_mart.framework.system.property.PropertyParam のメソッド
パラメータの値を取得します。
getValue() - class jp.co.intra_mart.framework.util.XMLNode のメソッド
値を取得します。
getValue(String) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
値を取得します。
getVariableInfo(TagData) - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI のメソッド
スクリプティング変数に関連付けたHelperBeanの情報を取得します。

H

HOME_PARAM - class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory の static 変数
ホームインタフェースを取得するときのJNDI名のパラメータ名
HTMLEncoder - class jp.co.intra_mart.framework.base.web.util.HTMLEncoder.
文字列をHTML形式で表示するための変換を行うユーティリティクラスです。
HTMLEncoder() - class jp.co.intra_mart.framework.base.web.util.HTMLEncoder のコンストラクタ
HelperBean - class jp.co.intra_mart.framework.base.web.bean.HelperBean.
画面表示をする時のヘルパークラスです。
HelperBean() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のコンストラクタ
HelperBeanを新規に生成します。
HelperBeanException - exception jp.co.intra_mart.framework.base.web.bean.HelperBeanException.
HelperBean内で発生した例外です。
HelperBeanException() - class jp.co.intra_mart.framework.base.web.bean.HelperBeanException のコンストラクタ
詳細メッセージを指定しないで HelperBeanException を構築します。
HelperBeanException(String) - class jp.co.intra_mart.framework.base.web.bean.HelperBeanException のコンストラクタ
指定された詳細メッセージを持つ HelperBeanException を構築します。
HelperBeanException(String, Throwable) - class jp.co.intra_mart.framework.base.web.bean.HelperBeanException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ HelperBeanException を構築します。
HelperBeanTEI - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI.
HelperBeanタグの拡張情報です。
HelperBeanTEI() - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI のコンストラクタ
HelperBeanTEIを新規に生成します。
HelperBeanTag - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag.
HelperBeanタグです。
HelperBeanTag() - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag のコンストラクタ
HelperBeanTagを新規に生成します。
HelperBeanTagBeanInfo - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo.
HelperBeanTagのBeanInfoです。
HelperBeanTagBeanInfo() - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo のコンストラクタ
HelperBeanTagBeanInfoを新規に生成します。
HttpSessionFactory - class jp.co.intra_mart.framework.base.session.HttpSessionFactory.
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
HttpSessionFactory() - class jp.co.intra_mart.framework.base.session.HttpSessionFactory のコンストラクタ
推奨されていません。 HttpSessionFactoryを新規に生成します。
HttpSessionObject - class jp.co.intra_mart.framework.base.session.HttpSessionObject.
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
HttpSessionObject(HttpSession) - class jp.co.intra_mart.framework.base.session.HttpSessionObject のコンストラクタ
推奨されていません。 HttpSessionObjectを新規に生成します。
handleGetObject(String) - class jp.co.intra_mart.framework.util.FileResourceBundle のメソッド

I

I18nAttributes - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes.
国際化の属性です。
I18nAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes のコンストラクタ
I18nAttributesを新規に生成します。
ID - class jp.co.intra_mart.framework.base.data.ConnectorModel の static 変数
ID - class jp.co.intra_mart.framework.base.data.DaoModel の static 変数
ID - class jp.co.intra_mart.framework.base.data.ResourceModel の static 変数
ID - class jp.co.intra_mart.framework.base.event.EventFactoryModel の static 変数
ID - class jp.co.intra_mart.framework.base.event.EventGroupModel の static 変数
ID - class jp.co.intra_mart.framework.base.service.ControllerConverterModel の static 変数
ID - class jp.co.intra_mart.framework.base.service.ValidatorModel の static 変数
ID_SERVICE_SECURITY_FILTER - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter の static 変数
リクエストに登録するServiceServletFilterの属性名
IMContainer - interface jp.co.intra_mart.framework.system.container.IMContainer.
イントラマートコンテナのインターフェースです。
IMContainerException - exception jp.co.intra_mart.framework.system.exception.IMContainerException.
イントラマートコンテナ内で発生した例外です。
IMContainerException() - class jp.co.intra_mart.framework.system.exception.IMContainerException のコンストラクタ
詳細メッセージを指定しないで IMContainerException を構築します。
IMContainerException(String) - class jp.co.intra_mart.framework.system.exception.IMContainerException のコンストラクタ
指定された詳細メッセージを持つ IMContainerException を構築します。
IMContainerException(Throwable) - class jp.co.intra_mart.framework.system.exception.IMContainerException のコンストラクタ
この例外の発生原因となる例外を持つ IMContainerException を構築します。
IMContainerException(String, Throwable) - class jp.co.intra_mart.framework.system.exception.IMContainerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IMContainerException を構築します。
IMContainerFactory - interface jp.co.intra_mart.framework.system.container.factory.IMContainerFactory.
ServiceContainerのクラスです。
INTRAMART_URL_NAME - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 セッションに登録するintra-martのサーブレットのURLの属性名
INTRAMART_URL_NAME - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.INTRAMART_URL_NAMEを使用してください。
INTRAMART_URL_NAME - class jp.co.intra_mart.framework.util.IntramartConnectUtil の static 変数
推奨されていません。 セッションに登録するintra-martのサーブレットのURLの属性名
IllegalSessionException - exception jp.co.intra_mart.framework.base.session.IllegalSessionException.
セッション情報取得の失敗や不正なセッションを検出した場合にスローされます。
IllegalSessionException() - class jp.co.intra_mart.framework.base.session.IllegalSessionException のコンストラクタ
詳細メッセージを指定しないで IllegalSessionException を構築します。
IllegalSessionException(String) - class jp.co.intra_mart.framework.base.session.IllegalSessionException のコンストラクタ
指定された詳細メッセージを持つ IllegalSessionException を構築します。
IllegalSessionException(String, Throwable) - class jp.co.intra_mart.framework.base.session.IllegalSessionException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IllegalSessionException を構築します。
IllegalSystemException - exception jp.co.intra_mart.framework.system.exception.IllegalSystemException.
想定外の例外が発生したときの例外です。
IllegalSystemException() - class jp.co.intra_mart.framework.system.exception.IllegalSystemException のコンストラクタ
詳細メッセージを指定しないで IllegalSystemException を構築します。
IllegalSystemException(String) - class jp.co.intra_mart.framework.system.exception.IllegalSystemException のコンストラクタ
指定された詳細メッセージを持つ IllegalSystemException を構築します。
IllegalSystemException(Throwable) - class jp.co.intra_mart.framework.system.exception.IllegalSystemException のコンストラクタ
この例外の発生原因となる例外を持つ IllegalSystemException を構築します。
IllegalSystemException(String, Throwable) - class jp.co.intra_mart.framework.system.exception.IllegalSystemException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IllegalSystemException を構築します。
IntramartConnectFilter - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter.
推奨されていません。 この機能は廃止されました。
IntramartConnectFilter() - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter のコンストラクタ
推奨されていません。
IntramartConnectServlet - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet.
推奨されていません。 この機能は廃止されました。
IntramartConnectServlet() - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のコンストラクタ
推奨されていません。 IntramartConnectServletを新規に生成します。
IntramartConnectUtil - class jp.co.intra_mart.framework.util.IntramartConnectUtil.
推奨されていません。 この機能は廃止されました。
IntramartConnectUtil() - class jp.co.intra_mart.framework.util.IntramartConnectUtil のコンストラクタ
推奨されていません。
IntramartConnectUtil.RequestInfo - class jp.co.intra_mart.framework.util.IntramartConnectUtil.RequestInfo.
推奨されていません。 リクエスト情報です。
IntramartConnectUtil.RequestInfo(String, String) - class jp.co.intra_mart.framework.util.IntramartConnectUtil.RequestInfo のコンストラクタ
推奨されていません。
IntramartDBConnector - class jp.co.intra_mart.framework.base.data.IntramartDBConnector.
推奨されていません。 このクラスではなくLoginGroupDBConnectorまたは SystemDBConnectorを使用してください。
IntramartDBConnector() - class jp.co.intra_mart.framework.base.data.IntramartDBConnector のコンストラクタ
推奨されていません。 IntramartDBConnectorを新規に生成します。
IntramartDBDAO - class jp.co.intra_mart.framework.base.data.IntramartDBDAO.
推奨されていません。 このクラスではなくLoginGroupDBDAOまたは SystemDBDAOを使用してください。
IntramartDBDAO() - class jp.co.intra_mart.framework.base.data.IntramartDBDAO のコンストラクタ
推奨されていません。 IntramartDBDAOを新規に生成します。
IntramartFileServerConnector - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector.
intra-martのStorageサービスに接続するデータコネクタです。
IntramartFileServerConnector() - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector のコンストラクタ
IntramartFileServerConnectorを新規に生成します。
IntramartFileServerDAO - class jp.co.intra_mart.framework.base.data.IntramartFileServerDAO.
intra-martのStorageサービスを使用する場合のDAOです。
IntramartFileServerDAO() - class jp.co.intra_mart.framework.base.data.IntramartFileServerDAO のコンストラクタ
IntramartFileServerDAOを新規に生成します。
IntramartLocaleFilter - class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter.
セッションにロケールを設定します。
IntramartLocaleFilter() - class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter のコンストラクタ
IntramartLogAgent - class jp.co.intra_mart.framework.system.log.IntramartLogAgent.
intra-mart で管理されているログに出力するログエージェントです。
IntramartLogAgent() - class jp.co.intra_mart.framework.system.log.IntramartLogAgent のコンストラクタ
IntramartLogAgentを新規に生成します。
IntramartMessagePropertyHandler - class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler.
イントラマートで設定されたメッセージにアクセスするメッセージプロパティハンドラです。
IntramartMessagePropertyHandler() - class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler のコンストラクタ
IntramartMessagePropertyHandlerを新規に生成します。
IntramartPageBaseTransition - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition.
ページベースの画面に遷移する場合に使用するトランジションです。
IntramartPageBaseTransition() - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のコンストラクタ
IntramartPageBaseTransitionを新規に生成します。
IntramartSessionFactory - class jp.co.intra_mart.framework.base.session.IntramartSessionFactory.
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
IntramartSessionFactory() - class jp.co.intra_mart.framework.base.session.IntramartSessionFactory のコンストラクタ
推奨されていません。 IntramartSessionFactoryを新規に生成します。
IntramartSessionObject - class jp.co.intra_mart.framework.base.session.IntramartSessionObject.
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
IntramartSessionObject(SessionMemory) - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のコンストラクタ
推奨されていません。 IntramartSessionObjectを生成します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
プロパティハンドラを初期化します。
init() - class jp.co.intra_mart.framework.base.data.container.DataContainerImpl のメソッド
DataContainerを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
プロパティハンドラを初期化します。
init() - class jp.co.intra_mart.framework.base.event.container.EventContainerImpl のメソッド
EventContainerを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.EncodingFilter のメソッド
エンコーディング用のフィルタを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.FileUploadFilter のメソッド
ファイルアップロード用のフィルタを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter のメソッド
推奨されていません。 フィルタを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter のメソッド
推奨されていません。 このフィルタを初期化します。
init(ServletConfig) - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 このサーブレットを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter のメソッド
ロケール用のフィルタを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.LocaleFilter のメソッド
ロケール用のフィルタを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter のメソッド
このフィルタを初期化します。
init(ServletConfig) - class jp.co.intra_mart.framework.base.service.ServiceServlet のメソッド
サーブレットを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
プロパティハンドラを初期化します。
init() - class jp.co.intra_mart.framework.base.service.container.ServiceContainerImpl のメソッド
ServiceContainerを初期化します。
init(ControllerConverterConfig) - interface jp.co.intra_mart.framework.base.service.controller.ControllerConverter のメソッド
ControllerConverterを初期化します。
init(ControllerConverterConfig) - class jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter のメソッド
SimpleControllerConverterを初期化します。
init(ValidatorConfig) - class jp.co.intra_mart.framework.base.service.validator.FormatValidator のメソッド
FormatValidatorを初期化します。
init(ValidatorConfig) - class jp.co.intra_mart.framework.base.service.validator.LengthValidator のメソッド
LengthValidatorを初期化します。
init(ValidatorConfig) - class jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator のメソッド
NumericRangeValidatorを初期化します。
init(ValidatorConfig) - class jp.co.intra_mart.framework.base.service.validator.NumericValidator のメソッド
NumericValidatorを初期化します。
init(ValidatorConfig) - interface jp.co.intra_mart.framework.base.service.validator.Validator のメソッド
Validatorを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.session.SessionFilter のメソッド
セッション用のフィルタを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
プロパティハンドラを初期化します。
init() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
HelperBeanを初期化します。
init() - interface jp.co.intra_mart.framework.system.container.IMContainer のメソッド
IMContainerを初期化します。
init(LogAgentParam[]) - class jp.co.intra_mart.framework.system.log.DefaultLogAgent のメソッド
初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(LogAgentParam[]) - class jp.co.intra_mart.framework.system.log.IntramartLogAgent のメソッド
初期化します。
init(LogAgentParam[]) - interface jp.co.intra_mart.framework.system.log.LogAgent のメソッド
初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - interface jp.co.intra_mart.framework.system.property.PropertyHandler のメソッド
プロパティハンドラを初期化します。
initParam(String, String) - interface jp.co.intra_mart.framework.base.event.EventListenerFactory のメソッド
初期パラメータを設定します。
initParam(String, String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory のメソッド
初期パラメータを設定します。
initParam(String, String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory のメソッド
初期パラメータを設定します。
initParam(String, String) - class jp.co.intra_mart.framework.base.event.GenericEventListenerFactory のメソッド
初期パラメータを設定します。
initParam(String, String) - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory のメソッド
初期パラメータを設定します。
initParam(String, String) - class jp.co.intra_mart.framework.base.event.StandardEventListenerFactory のメソッド
初期パラメータを設定します。
isDynamic() - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - interface jp.co.intra_mart.framework.base.message.MessagePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
再設定可能かどうかをチェックします。
isDynamic() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isEncodeRequired() - class jp.co.intra_mart.framework.base.session.HttpSessionFactory のメソッド
推奨されていません。 セッション情報をURLに含めてエンコードする必要があるかどうか調べます。
isEncodeRequired() - class jp.co.intra_mart.framework.base.session.IntramartSessionFactory のメソッド
推奨されていません。 セッション情報をURLに含めてエンコードする必要があるかどうか調べます。
isEncodeRequired() - interface jp.co.intra_mart.framework.base.session.SessionFactory のメソッド
セッション情報をURLに含めてエンコードする必要があるかどうか調べます。
isFalse(String) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
設定データが偽値判定であるかをチェックします。
isFileExist(String, Locale) - class jp.co.intra_mart.framework.util.XMLDocumentProducer の static メソッド
ファイルが存在するか調べます。
isTrue(String) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
設定データが真値判定であるかをチェックします。
isValid(TagData) - class jp.co.intra_mart.framework.base.web.tag.FormTEI のメソッド
Formタグに指定された内容の正当性を検証します。
isValid(TagData) - class jp.co.intra_mart.framework.base.web.tag.FrameTEI のメソッド
Frameタグに指定された内容の正当性を検証します。
isValid(TagData) - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI のメソッド
HelperBeanタグに指定された内容の正当性を検証します。
isValid(TagData) - class jp.co.intra_mart.framework.base.web.tag.LinkTEI のメソッド
Linkタグに指定された内容の正当性を検証します。
isValid(TagData) - class jp.co.intra_mart.framework.base.web.tag.MessageTEI のメソッド
Messageタグに指定された内容の正当性を検証します。
isValid(TagData) - class jp.co.intra_mart.framework.base.web.tag.SubmitTEI のメソッド
Linkタグに指定された内容の正当性を検証します。
isValid(String) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
設定ファイル内に指定項目が定義されているかどうかを チェックします。

J

JDBCConnector - class jp.co.intra_mart.framework.base.data.JDBCConnector.
推奨されていません。 JDBCを直接扱わず、DataSourceを使用するようにしてください。
JDBCConnector() - class jp.co.intra_mart.framework.base.data.JDBCConnector のコンストラクタ
推奨されていません。 新規のJDBCConnectorを生成します。
jp.co.intra_mart.framework.base.data - package jp.co.intra_mart.framework.base.data
データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.data.container - package jp.co.intra_mart.framework.base.data.container
jp.co.intra_mart.framework.base.data.container.factory - package jp.co.intra_mart.framework.base.data.container.factory
jp.co.intra_mart.framework.base.event - package jp.co.intra_mart.framework.base.event
イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event.container - package jp.co.intra_mart.framework.base.event.container
jp.co.intra_mart.framework.base.event.container.factory - package jp.co.intra_mart.framework.base.event.container.factory
jp.co.intra_mart.framework.base.message - package jp.co.intra_mart.framework.base.message
メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service - package jp.co.intra_mart.framework.base.service
サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.container - package jp.co.intra_mart.framework.base.service.container
jp.co.intra_mart.framework.base.service.container.factory - package jp.co.intra_mart.framework.base.service.container.factory
jp.co.intra_mart.framework.base.service.controller - package jp.co.intra_mart.framework.base.service.controller
入力情報に関連するパッケージです。
jp.co.intra_mart.framework.base.service.validator - package jp.co.intra_mart.framework.base.service.validator
検証に関連するパッケージです。
jp.co.intra_mart.framework.base.session - package jp.co.intra_mart.framework.base.session
セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util - package jp.co.intra_mart.framework.base.util
jp.co.intra_mart.framework.base.web.bean - package jp.co.intra_mart.framework.base.web.bean
JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.tag - package jp.co.intra_mart.framework.base.web.tag
J2EEフレームワークで使用する各種のタグのパッケージです。
jp.co.intra_mart.framework.base.web.tag.attribute - package jp.co.intra_mart.framework.base.web.tag.attribute
タグ属性のパッケージです。
jp.co.intra_mart.framework.base.web.util - package jp.co.intra_mart.framework.base.web.util
Web上で使用するユーティリティのパッケージです。
jp.co.intra_mart.framework.system.container - package jp.co.intra_mart.framework.system.container
jp.co.intra_mart.framework.system.container.factory - package jp.co.intra_mart.framework.system.container.factory
jp.co.intra_mart.framework.system.exception - package jp.co.intra_mart.framework.system.exception
J2EEフレームワークの例外に関連するパッケージです。
jp.co.intra_mart.framework.system.log - package jp.co.intra_mart.framework.system.log
J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.message - package jp.co.intra_mart.framework.system.message
メッセージに関連するパッケージです。
jp.co.intra_mart.framework.system.property - package jp.co.intra_mart.framework.system.property
プロパティ取得に関連するパッケージです。
jp.co.intra_mart.framework.system.util - package jp.co.intra_mart.framework.system.util
jp.co.intra_mart.framework.util - package jp.co.intra_mart.framework.util
J2EEフレームワークで使用する各種のユーティリティです。

K

KEY - class jp.co.intra_mart.framework.system.property.DefaultPropertyManager の static 変数
プロパティマネージャを指定するキー
KEY - class jp.co.intra_mart.framework.system.property.PropertyManager の static 変数
プロパティマネージャを指定するキー
KEY - class jp.co.intra_mart.framework.system.property.XmlPropertyManager の static 変数
プロパティマネージャを指定するキー
KEY_DRIVER - class jp.co.intra_mart.framework.base.data.JDBCConnector の static 変数
推奨されていません。 データベースドライバのキー
KEY_JNDI_NAME - class jp.co.intra_mart.framework.base.data.DataSourceConnector の static 変数
DataSourceのJNDI名のキー
KEY_PASSWORD - class jp.co.intra_mart.framework.base.data.JDBCConnector の static 変数
推奨されていません。 データベース接続ユーザパスワードのキー
KEY_URL - class jp.co.intra_mart.framework.base.data.JDBCConnector の static 変数
推奨されていません。 データベースURLのキー
KEY_USERNAME - class jp.co.intra_mart.framework.base.data.JDBCConnector の static 変数
推奨されていません。 データベース接続ユーザ名のキー

L

LEVEL_DEBUG - interface jp.co.intra_mart.framework.system.log.LogConstant の static 変数
DEBUG時に出力するレベルです。
LEVEL_ERROR - interface jp.co.intra_mart.framework.system.log.LogConstant の static 変数
例外を出力するレベルです。
LEVEL_INFO - interface jp.co.intra_mart.framework.system.log.LogConstant の static 変数
情報を出力するレベルです。
LEVEL_WARNNING - interface jp.co.intra_mart.framework.system.log.LogConstant の static 変数
警告を出力するレベルです。
LISTENER_PARAM - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory の static 変数
イベントリスナーのクラス名のパラメータ名
LISTENER_PARAM - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory の static 変数
イベントリスナーのクラス名のパラメータ名
LOG_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.system.log.LogManager の static 変数
ログプロパティハンドラのキー
LT_GROUP - class jp.co.intra_mart.framework.base.util.UserInfoUtil の static 変数
グループマネージャ
LT_SUPER - class jp.co.intra_mart.framework.base.util.UserInfoUtil の static 変数
スーパーユーザ
LT_USER - class jp.co.intra_mart.framework.base.util.UserInfoUtil の static 変数
ユーザ
LengthValidator - class jp.co.intra_mart.framework.base.service.validator.LengthValidator.
文字列の長さをチェックします。
LengthValidator() - class jp.co.intra_mart.framework.base.service.validator.LengthValidator のコンストラクタ
LinkTEI - class jp.co.intra_mart.framework.base.web.tag.LinkTEI.
Linkタグの拡張情報です。
LinkTEI() - class jp.co.intra_mart.framework.base.web.tag.LinkTEI のコンストラクタ
LinkTEIを新規に生成します。
LinkTag - class jp.co.intra_mart.framework.base.web.tag.LinkTag.
LINKタグです。
LinkTag() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のコンストラクタ
LinkTagを新規に生成します。
LinkTagBeanInfo - class jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo.
LinkTagのBeanInfoです。
LinkTagBeanInfo() - class jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo のコンストラクタ
LinkTagBeanInfoを新規に生成します。
LocaleFilter - class jp.co.intra_mart.framework.base.service.LocaleFilter.
リクエストのロケールを設定します。
LocaleFilter() - class jp.co.intra_mart.framework.base.service.LocaleFilter のコンストラクタ
LogAgent - interface jp.co.intra_mart.framework.system.log.LogAgent.
ログに出力するエージェントです。
LogAgentParam - class jp.co.intra_mart.framework.system.log.LogAgentParam.
ログエージェントの初期パラメータです。
LogAgentParam() - class jp.co.intra_mart.framework.system.log.LogAgentParam のコンストラクタ
LogAgentParamを新規に生成します。
LogConstant - interface jp.co.intra_mart.framework.system.log.LogConstant.
ログフレームワークで使用される定数値です。
LogManager - class jp.co.intra_mart.framework.system.log.LogManager.
ログマネージャです。
LogPropertyException - exception jp.co.intra_mart.framework.system.log.LogPropertyException.
ログプロパティ取得時の例外です。
LogPropertyException() - class jp.co.intra_mart.framework.system.log.LogPropertyException のコンストラクタ
詳細メッセージを指定しないで LogPropertyException を構築します。
LogPropertyException(String) - class jp.co.intra_mart.framework.system.log.LogPropertyException のコンストラクタ
指定された詳細メッセージを持つ LogPropertyException を構築します。
LogPropertyException(String, Throwable) - class jp.co.intra_mart.framework.system.log.LogPropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ LogPropertyException を構築します。
LogPropertyHandler - interface jp.co.intra_mart.framework.system.log.LogPropertyHandler.
ログフレームワークで使用するプロパティハンドラです。
LoginGroupDBConnector - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector.
イントラマートで設定されているDBコネクションです。
LoginGroupDBConnector() - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector のコンストラクタ
LoginGroupDBConnectorを新規に生成します。
LoginGroupDBDAO - class jp.co.intra_mart.framework.base.data.LoginGroupDBDAO.
イントラマートで設定されたDBへアクセスするDAOです。
LoginGroupDBDAO() - class jp.co.intra_mart.framework.base.data.LoginGroupDBDAO のコンストラクタ
IntramartDBDAOを新規に生成します。
lookup(String) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
XMLNodeを返却します。
lookup(Vector) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
XMLNodeを返却します。

M

MESSAGE_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.base.message.MessageManager の static 変数
メッセージプロパティハンドラのキー
MESSAGE_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.system.message.MessageManager の static 変数
メッセージプロパティハンドラのキー
MessageManager - class jp.co.intra_mart.framework.base.message.MessageManager.
メッセージマネージャです。
MessageManager - class jp.co.intra_mart.framework.system.message.MessageManager.
メッセージを制御します。
MessageManagerException - exception jp.co.intra_mart.framework.base.message.MessageManagerException.
サービスマネージャ設定時の例外です。
MessageManagerException() - class jp.co.intra_mart.framework.base.message.MessageManagerException のコンストラクタ
詳細メッセージを指定しないで MessageManagerException を構築します。
MessageManagerException(String) - class jp.co.intra_mart.framework.base.message.MessageManagerException のコンストラクタ
指定された詳細メッセージを持つ MessageManagerException を構築します。
MessageManagerException(String, Throwable) - class jp.co.intra_mart.framework.base.message.MessageManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessageManagerException を構築します。
MessageManagerException - exception jp.co.intra_mart.framework.system.message.MessageManagerException.
メッセージマネージャに関連する例外です。
MessageManagerException() - class jp.co.intra_mart.framework.system.message.MessageManagerException のコンストラクタ
詳細メッセージを指定しないで MessageManagerException を構築します。
MessageManagerException(String) - class jp.co.intra_mart.framework.system.message.MessageManagerException のコンストラクタ
指定された詳細メッセージを持つ MessageManagerException を構築します。
MessageManagerException(String, Throwable) - class jp.co.intra_mart.framework.system.message.MessageManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessageManagerException を構築します。
MessageParamTag - class jp.co.intra_mart.framework.base.web.tag.MessageParamTag.
メッセージの生成で使用するパラメータを設定します。
MessageParamTag() - class jp.co.intra_mart.framework.base.web.tag.MessageParamTag のコンストラクタ
ParamTagを新規に生成します。
MessagePropertyException - exception jp.co.intra_mart.framework.base.message.MessagePropertyException.
メッセージプロパティ取得時の例外です。
MessagePropertyException() - class jp.co.intra_mart.framework.base.message.MessagePropertyException のコンストラクタ
詳細メッセージを指定しないで MessagePropertyException を構築します。
MessagePropertyException(String) - class jp.co.intra_mart.framework.base.message.MessagePropertyException のコンストラクタ
指定された詳細メッセージを持つ MessagePropertyException を構築します。
MessagePropertyException(String, Throwable) - class jp.co.intra_mart.framework.base.message.MessagePropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessagePropertyException を構築します。
MessagePropertyException - exception jp.co.intra_mart.framework.system.message.MessagePropertyException.
メッセージプロパティハンドラに関連する例外です。
MessagePropertyException() - class jp.co.intra_mart.framework.system.message.MessagePropertyException のコンストラクタ
詳細メッセージを指定しないで MessagePropertyException を構築します。
MessagePropertyException(String) - class jp.co.intra_mart.framework.system.message.MessagePropertyException のコンストラクタ
指定された詳細メッセージを持つ MessagePropertyException を構築します。
MessagePropertyException(String, Throwable) - class jp.co.intra_mart.framework.system.message.MessagePropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessagePropertyException を構築します。
MessagePropertyHandler - interface jp.co.intra_mart.framework.base.message.MessagePropertyHandler.
メッセージの設定情報に接続するクラスです。
MessagePropertyHandler - interface jp.co.intra_mart.framework.system.message.MessagePropertyHandler.
メッセージに関連するプロパティを取得します。
MessagePropertyParam - class jp.co.intra_mart.framework.system.message.MessagePropertyParam.
メッセージプロパティハンドラの初期パラメータです。
MessagePropertyParam() - class jp.co.intra_mart.framework.system.message.MessagePropertyParam のコンストラクタ
MessagePropertyParamを新規に生成します。
MessageTEI - class jp.co.intra_mart.framework.base.web.tag.MessageTEI.
Messageタグの拡張情報です。
MessageTEI() - class jp.co.intra_mart.framework.base.web.tag.MessageTEI のコンストラクタ
MessageTag - class jp.co.intra_mart.framework.base.web.tag.MessageTag.
Messageタグです。
MessageTag() - class jp.co.intra_mart.framework.base.web.tag.MessageTag のコンストラクタ
MessageTagを新規に生成します。

N

NumericRangeValidator - class jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator.
数値の範囲をチェックします。
NumericRangeValidator() - class jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator のコンストラクタ
NumericValidator - class jp.co.intra_mart.framework.base.service.validator.NumericValidator.
数値（整数）として妥当であるかどうかをチェックします。
NumericValidator() - class jp.co.intra_mart.framework.base.service.validator.NumericValidator のコンストラクタ

O

OBJECT_PARAM_NAME - class jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter の static 変数
コントローラオブジェクトのクラス名を設定するパラメータ名

P

PARAM_APPLICATION - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルのアプリケーションのパラメータ名
PARAM_APPLICATION - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
アプリケーション
PARAM_APPLICATION - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
アプリケーション
PARAM_APPLICATION_CLASS - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルのクラスのパラメータ名
PARAM_APPLICATION_CLASS - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
クラス
PARAM_APPLICATION_CLASS - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
クラス
PARAM_APPLICATION_PARAM - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルのパラメータのパラメータ名
PARAM_APPLICATION_PARAM - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
パラメータ
PARAM_APPLICATION_PARAM - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
パラメータ
PARAM_ARGUMENT - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 ページ引数のリクエストパラメータ名
PARAM_ARGUMENT - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENTを使用してください。
PARAM_ARGUMENT - class jp.co.intra_mart.framework.util.IntramartConnectUtil の static 変数
推奨されていません。 ページ引数のリクエストパラメータ名
PARAM_ARGUMENT_DELIMITER - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 ページ引数のデリミタ
PARAM_ARGUMENT_DELIMITER - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_DELIMITERを使用してください。
PARAM_ARGUMENT_OPERATOR - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 ページ引数の演算子
PARAM_ARGUMENT_OPERATOR - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_OPERATORを使用してください。
PARAM_BUNDLE - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルのバンドルのパラメータ名
PARAM_BUNDLE - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
プロパティファイルのバンドルのパラメータ名
PARAM_BUNDLE - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
プロパティファイルのバンドルのパラメータ名
PARAM_DEFAULT - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルのデフォルトのパラメータ名
PARAM_DEFAULT - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
デフォルト
PARAM_DEFAULT - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
デフォルト
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_ERROR_PAGE - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter の static 変数
エラーページパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_LOGIN_GROUP_ID - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 ログイングループIDのリクエストパラメータ名
PARAM_LOGIN_GROUP_ID - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_GROUP_IDを使用してください。
PARAM_LOGIN_GROUP_ID - class jp.co.intra_mart.framework.util.IntramartConnectUtil の static 変数
推奨されていません。 ログイングループIDのリクエストパラメータ名
PARAM_LOGIN_USER_ID - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 ログインユーザIDのリクエストパラメータ名
PARAM_LOGIN_USER_ID - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_USER_IDを使用してください。
PARAM_LOGIN_USER_ID - class jp.co.intra_mart.framework.util.IntramartConnectUtil の static 変数
推奨されていません。 ログインユーザIDのリクエストパラメータ名
PARAM_MAX - class jp.co.intra_mart.framework.base.service.validator.LengthValidator の static 変数
文字列長の最大値が設定されているパラメータ名
PARAM_MAX - class jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator の static 変数
数値の最大値が設定されているパラメータ名
PARAM_MESSAGE - class jp.co.intra_mart.framework.base.service.validator.FormatValidator の static 変数
不正文字列である場合のメッセージが設定されているパラメータ名
PARAM_MESSAGE - class jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator の static 変数
数値が範囲外の場合のメッセージが設定されているパラメータ名
PARAM_MESSAGE - class jp.co.intra_mart.framework.base.service.validator.NumericValidator の static 変数
数値として妥当ではない場合のメッセージが設定されているパラメータ名
PARAM_MESSAGE_LONG - class jp.co.intra_mart.framework.base.service.validator.LengthValidator の static 変数
文字列長が長い場合のメッセージが設定されているパラメータ名
PARAM_MESSAGE_SHORT - class jp.co.intra_mart.framework.base.service.validator.LengthValidator の static 変数
文字列長が短い場合のメッセージが設定されているパラメータ名
PARAM_MIN - class jp.co.intra_mart.framework.base.service.validator.LengthValidator の static 変数
文字列長の最小値が設定されているパラメータ名
PARAM_MIN - class jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator の static 変数
数値の最小値が設定されているパラメータ名
PARAM_PROPERTY - class jp.co.intra_mart.framework.base.service.validator.FormatValidator の static 変数
検証対象となるコントローラオブジェクトのプロパティ名を示すパラメータ名
PARAM_PROPERTY - class jp.co.intra_mart.framework.base.service.validator.LengthValidator の static 変数
検証対象のプロパティ名が設定されているパラメータ名
PARAM_PROPERTY - class jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator の static 変数
検証対象のプロパティ名が設定されているパラメータ名
PARAM_PROPERTY - class jp.co.intra_mart.framework.base.service.validator.NumericValidator の static 変数
検証対象のプロパティ名が設定されているパラメータ名
PARAM_REFERER - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 参照元URLのリクエストパラメータ名
PARAM_REFERER - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_REFERERを使用してください。
PARAM_REFERER - class jp.co.intra_mart.framework.util.IntramartConnectUtil の static 変数
推奨されていません。 参照元URLのリクエストパラメータ名
PARAM_REFERER_FORMAT - class jp.co.intra_mart.framework.util.IntramartConnectUtil の static 変数
推奨されていません。 URL指定タイプのパラメータ名
PARAM_REGEX - class jp.co.intra_mart.framework.base.service.validator.FormatValidator の static 変数
正規表現によるフォーマットが設定されているパラメータ名
PARAM_SECURITY_EXT - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 セキュリティの拡張子
PARAM_WINDOW_NAME - class jp.co.intra_mart.framework.util.IntramartConnectUtil の static 変数
推奨されていません。 基本ウィンドウ名
P_ID_CONNECTOR_CLASS - class jp.co.intra_mart.framework.base.data.ConnectorModel の static 変数
P_ID_CONNECTOR_NAME - class jp.co.intra_mart.framework.base.data.ConnectorModel の static 変数
P_ID_CONNECT_NAME - class jp.co.intra_mart.framework.base.data.DaoModel の static 変数
P_ID_CONVERTER_CLASS - class jp.co.intra_mart.framework.base.service.ControllerConverterModel の static 変数
P_ID_CONVERTER_PARAM - class jp.co.intra_mart.framework.base.service.ControllerConverterModel の static 変数
P_ID_DAO_CLASS - class jp.co.intra_mart.framework.base.data.DaoModel の static 変数
P_ID_DAO_CONNECTOR_NAME - class jp.co.intra_mart.framework.base.data.DaoModel の static 変数
P_ID_EVENT_KEY - class jp.co.intra_mart.framework.base.event.EventGroupModel の static 変数
P_ID_EVENT_NAME - class jp.co.intra_mart.framework.base.event.EventGroupModel の static 変数
P_ID_FACTORY_CLASS - class jp.co.intra_mart.framework.base.event.EventFactoryModel の static 変数
P_ID_FACTORY_PARAM - class jp.co.intra_mart.framework.base.event.EventFactoryModel の static 変数
P_ID_PARAM_NAME - class jp.co.intra_mart.framework.base.data.ResourceModel の static 変数
P_ID_PARAM_NAME - class jp.co.intra_mart.framework.base.event.EventFactoryModel の static 変数
P_ID_PARAM_NAME - class jp.co.intra_mart.framework.base.service.ControllerConverterModel の static 変数
P_ID_PARAM_NAME - class jp.co.intra_mart.framework.base.service.ValidatorModel の static 変数
P_ID_PARAM_VALUE - class jp.co.intra_mart.framework.base.data.ResourceModel の static 変数
P_ID_PARAM_VALUE - class jp.co.intra_mart.framework.base.event.EventFactoryModel の static 変数
P_ID_PARAM_VALUE - class jp.co.intra_mart.framework.base.service.ControllerConverterModel の static 変数
P_ID_PARAM_VALUE - class jp.co.intra_mart.framework.base.service.ValidatorModel の static 変数
P_ID_POST_TRIGGER - class jp.co.intra_mart.framework.base.event.EventGroupModel の static 変数
P_ID_PRE_TRIGGER - class jp.co.intra_mart.framework.base.event.EventGroupModel の static 変数
P_ID_RESOURCE_NAME - class jp.co.intra_mart.framework.base.data.ConnectorModel の static 変数
P_ID_RESOURCE_NAME - class jp.co.intra_mart.framework.base.data.ResourceModel の static 変数
P_ID_RESOURCE_PARAM - class jp.co.intra_mart.framework.base.data.ResourceModel の static 変数
P_ID_TRIGGER_CLASS - class jp.co.intra_mart.framework.base.event.EventGroupModel の static 変数
P_ID_VALIDATOR_CLASS - class jp.co.intra_mart.framework.base.service.ValidatorModel の static 変数
P_ID_VALIDATOR_PARAM - class jp.co.intra_mart.framework.base.service.ValidatorModel の static 変数
ParamTag - class jp.co.intra_mart.framework.base.web.tag.ParamTag.
リンク先、遷移先に渡すパラメータを設定します。
ParamTag() - class jp.co.intra_mart.framework.base.web.tag.ParamTag のコンストラクタ
ParamTagを新規に生成します。
ParameterSendable - interface jp.co.intra_mart.framework.base.web.tag.ParameterSendable.
パラメータを渡すことができるタグです。
PropertyConfigModel - class jp.co.intra_mart.framework.system.property.PropertyConfigModel.
データモデルクラスです。
PropertyConfigModel() - class jp.co.intra_mart.framework.system.property.PropertyConfigModel のコンストラクタ
PropertyHandler - interface jp.co.intra_mart.framework.system.property.PropertyHandler.
プロパティにアクセスするインタフェースです。
PropertyHandlerException - exception jp.co.intra_mart.framework.system.property.PropertyHandlerException.
プロパティハンドラの情報取得時の例外です。
PropertyHandlerException() - class jp.co.intra_mart.framework.system.property.PropertyHandlerException のコンストラクタ
詳細メッセージを指定しないで PropertyHandlerException を構築します。
PropertyHandlerException(String) - class jp.co.intra_mart.framework.system.property.PropertyHandlerException のコンストラクタ
指定された詳細メッセージを持つ PropertyHandlerException を構築します。
PropertyHandlerException(String, Throwable) - class jp.co.intra_mart.framework.system.property.PropertyHandlerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PropertyHandlerException を構築します。
PropertyHandlerParam - class jp.co.intra_mart.framework.system.property.PropertyHandlerParam.
プロパティハンドラを生成する時の初期パラメータです。
PropertyHandlerParam() - class jp.co.intra_mart.framework.system.property.PropertyHandlerParam のコンストラクタ
PropertyHandlerParamを新規に生成します。
PropertyManager - class jp.co.intra_mart.framework.system.property.PropertyManager.
システム設定の情報を管理します。
PropertyManager() - class jp.co.intra_mart.framework.system.property.PropertyManager のコンストラクタ
プロパティマネージャのコンストラクタです。
PropertyManagerException - exception jp.co.intra_mart.framework.system.property.PropertyManagerException.
プロパティマネージャの設定時の例外です。
PropertyManagerException() - class jp.co.intra_mart.framework.system.property.PropertyManagerException のコンストラクタ
詳細メッセージを指定しないで PropertyManagerException を構築します。
PropertyManagerException(String) - class jp.co.intra_mart.framework.system.property.PropertyManagerException のコンストラクタ
指定された詳細メッセージを持つ PropertyManagerException を構築します。
PropertyManagerException(String, Throwable) - class jp.co.intra_mart.framework.system.property.PropertyManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PropertyManagerException を構築します。
PropertyModel - class jp.co.intra_mart.framework.system.property.PropertyModel.
プロパティモデルクラスです。
PropertyModel() - class jp.co.intra_mart.framework.system.property.PropertyModel のコンストラクタ
PropertyParam - class jp.co.intra_mart.framework.system.property.PropertyParam.
プロパティのパラメータを表現する汎用的なクラスです。
PropertyParam() - class jp.co.intra_mart.framework.system.property.PropertyParam のコンストラクタ
PropertyParamを新規に生成します。
Provider - interface jp.co.intra_mart.framework.system.container.factory.Provider.
IMContainerのファクトリクラスです。
parameters - class jp.co.intra_mart.framework.system.util.Config の変数
パラメータの集合
printAttribute(String, String) - class jp.co.intra_mart.framework.base.web.tag.TagWriter のメソッド
属性を出力します。
printAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性の内容を表示します。
printAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性の内容を表示します。
printAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes のメソッド
属性の内容を表示します。
printAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes のメソッド
属性の内容を表示します。
printOnClick() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onClickを出力します。
printOnDblClick() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onDblClickを出力します。
printOnKeyDown() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyDownを出力します。
printOnKeyPress() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyPressを出力します。
printOnKeyUp() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyUpを出力します。
printOnMouseDown() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseDownを出力します。
printOnMouseMove() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseMoveを出力します。
printOnMouseOut() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseOutを出力します。
printOnMouseOver() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseOverを出力します。
printOnMouseUp() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseUpを出力します。
printStackTrace() - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のメソッド
printStackTrace(PrintStream) - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のメソッド
printStackTrace(PrintWriter) - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のメソッド
printStackTrace() - class jp.co.intra_mart.framework.system.exception.FrameworkException のメソッド
printStackTrace(PrintStream) - class jp.co.intra_mart.framework.system.exception.FrameworkException のメソッド
printStackTrace(PrintWriter) - class jp.co.intra_mart.framework.system.exception.FrameworkException のメソッド
printURL(String) - class jp.co.intra_mart.framework.base.web.tag.TagWriter のメソッド
URLを出力します。
provider - class jp.co.intra_mart.framework.base.data.container.factory.DataContainerFactory の static 変数
provider - class jp.co.intra_mart.framework.base.event.container.factory.EventContainerFactory の static 変数
provider - class jp.co.intra_mart.framework.base.service.container.factory.ServiceContainerFactory の変数
putResource(String, ResourceParam[]) - class jp.co.intra_mart.framework.base.data.DBConnector のメソッド
接続先のリソースを追加します。
putResource(String, ResourceParam[]) - class jp.co.intra_mart.framework.base.data.DataSourceConnector のメソッド
接続先のリソースを追加します。
putResource(String, ResourceParam[]) - class jp.co.intra_mart.framework.base.data.JDBCConnector のメソッド
推奨されていません。 接続先のリソースを追加します。

R

REQUEST_INFO_ATTRIBUTE - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler の static 変数
リクエスト情報の属性地
REQUEST_SEPARATOR - class jp.co.intra_mart.framework.base.service.ServiceServlet の static 変数
リクエストの情報を分割するセパレータ
RequestException - exception jp.co.intra_mart.framework.base.service.RequestException.
リクエストの内容に関連する間違いがある場合の例外です。
RequestException() - class jp.co.intra_mart.framework.base.service.RequestException のコンストラクタ
詳細メッセージを指定しないで RequestException を構築します。
RequestException(String) - class jp.co.intra_mart.framework.base.service.RequestException のコンストラクタ
指定された詳細メッセージを持つ RequestException を構築します。
RequestException(String, Throwable) - class jp.co.intra_mart.framework.base.service.RequestException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestException を構築します。
RequestFormatException - exception jp.co.intra_mart.framework.base.service.controller.RequestFormatException.
フォーマットが不正であるときの例外です。
RequestFormatException() - class jp.co.intra_mart.framework.base.service.controller.RequestFormatException のコンストラクタ
詳細メッセージを指定しないで RequestFormatException を構築します。
RequestFormatException(String) - class jp.co.intra_mart.framework.base.service.controller.RequestFormatException のコンストラクタ
指定された詳細メッセージを持つ RequestFormatException を構築します。
RequestFormatException(String, Throwable) - class jp.co.intra_mart.framework.base.service.controller.RequestFormatException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestFormatException を構築します。
RequestInfo - interface jp.co.intra_mart.framework.base.service.RequestInfo.
リクエストに対する情報を取得します。
ResourceModel - class jp.co.intra_mart.framework.base.data.ResourceModel.
Resource情報を管理するクラスです。
ResourceModel() - class jp.co.intra_mart.framework.base.data.ResourceModel のコンストラクタ
ResourceParam - class jp.co.intra_mart.framework.base.data.ResourceParam.
データコネクタの初期パラメータです。
ResourceParam() - class jp.co.intra_mart.framework.base.data.ResourceParam のコンストラクタ
ResourceParamを新規に生成します。
release() - class jp.co.intra_mart.framework.base.data.DBConnector のメソッド
データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.DataAccessController のメソッド
すべてのデータストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.DataConnector のメソッド
データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.DataSourceConnector のメソッド
データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.IntramartDBConnector のメソッド
推奨されていません。 データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector のメソッド
データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.JDBCConnector のメソッド
推奨されていません。 データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector のメソッド
データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.SystemDBConnector のメソッド
データストアの資源を解放します。
removeAttribute(String) - class jp.co.intra_mart.framework.base.session.HttpSessionObject のメソッド
推奨されていません。 指定された名前に対応するオブジェクトを削除します。
removeAttribute(String) - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のメソッド
推奨されていません。 指定された名前に対応するオブジェクトを削除します。
removeAttribute(String) - interface jp.co.intra_mart.framework.base.session.SessionObject のメソッド
指定された名前に対応するオブジェクトを削除します。
removeValue() - class jp.co.intra_mart.framework.util.XMLNode のメソッド
値を削除します。
resources - class jp.co.intra_mart.framework.base.data.DBConnector の変数
リソース一覧
resources - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector の変数
リソース一覧
rollback() - class jp.co.intra_mart.framework.base.data.DBConnector のメソッド
ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.DataAccessController のメソッド
すべてのデータコネクタをロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.DataConnector のメソッド
ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.DataSourceConnector のメソッド
ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.IntramartDBConnector のメソッド
推奨されていません。 ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector のメソッド
ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.JDBCConnector のメソッド
推奨されていません。 ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector のメソッド
ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.SystemDBConnector のメソッド
ロールバックします。

S

SERVICE_EXTENSION_KEY - class jp.co.intra_mart.framework.base.service.ServiceManager の static 変数
拡張子を指定するキー
SERVICE_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.base.service.ServiceManager の static 変数
サービスプロパティハンドラのキー
SERVICE_PROPERTY_HANDLER_KEY - interface jp.co.intra_mart.framework.base.service.container.ServiceContainer の static 変数
サービスプロパティハンドラのキー
SESSION_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.base.session.SessionManager の static 変数
セッションプロパティハンドラのキー
SecurityUtil - class jp.co.intra_mart.framework.util.SecurityUtil.
セキュリティに関連するユーティリティです。
SecurityUtil() - class jp.co.intra_mart.framework.util.SecurityUtil のコンストラクタ
ServiceContainer - interface jp.co.intra_mart.framework.base.service.container.ServiceContainer.
サービスコンテナのインターフェースです。
ServiceContainerException - exception jp.co.intra_mart.framework.base.service.container.ServiceContainerException.
サービスコンテナ設定時の例外です。
ServiceContainerException() - class jp.co.intra_mart.framework.base.service.container.ServiceContainerException のコンストラクタ
詳細メッセージを指定しないで ServiceContainerException を構築します。
ServiceContainerException(String) - class jp.co.intra_mart.framework.base.service.container.ServiceContainerException のコンストラクタ
指定された詳細メッセージを持つ ServiceContainerException を構築します。
ServiceContainerException(String, Throwable) - class jp.co.intra_mart.framework.base.service.container.ServiceContainerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceContainerException を構築します。
ServiceContainerFactory - class jp.co.intra_mart.framework.base.service.container.factory.ServiceContainerFactory.
ServiceContainerのファクトリクラスです。
ServiceContainerFactory() - class jp.co.intra_mart.framework.base.service.container.factory.ServiceContainerFactory のコンストラクタ
ServiceContainerImpl - class jp.co.intra_mart.framework.base.service.container.ServiceContainerImpl.
ServiceContainerの標準的な実装クラスです。
ServiceContainerImpl() - class jp.co.intra_mart.framework.base.service.container.ServiceContainerImpl のコンストラクタ
ServiceContainerImplを生成します。
ServiceController - interface jp.co.intra_mart.framework.base.service.ServiceController.
クライアントからの入力に対する処理を行います。
ServiceControllerAdapter - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter.
いくつかのユーティリティメソッドと空のメソッドを実装したサービスコントローラです。
ServiceControllerAdapter() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のコンストラクタ
ServiceControllerAdapterを新規に生成します。
ServiceControllerException - exception jp.co.intra_mart.framework.base.service.ServiceControllerException.
サービスコントローラに関連する例外です。
ServiceControllerException() - class jp.co.intra_mart.framework.base.service.ServiceControllerException のコンストラクタ
詳細メッセージを指定しないで ServiceControllerException を構築します。
ServiceControllerException(String) - class jp.co.intra_mart.framework.base.service.ServiceControllerException のコンストラクタ
指定された詳細メッセージを持つ ServiceControllerException を構築します。
ServiceControllerException(String, Throwable) - class jp.co.intra_mart.framework.base.service.ServiceControllerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceControllerException を構築します。
ServiceManager - class jp.co.intra_mart.framework.base.service.ServiceManager.
サービスマネージャです。
ServiceManagerException - exception jp.co.intra_mart.framework.base.service.ServiceManagerException.
サービスマネージャ設定時の例外です。
ServiceManagerException() - class jp.co.intra_mart.framework.base.service.ServiceManagerException のコンストラクタ
詳細メッセージを指定しないで ServiceManagerException を構築します。
ServiceManagerException(String) - class jp.co.intra_mart.framework.base.service.ServiceManagerException のコンストラクタ
指定された詳細メッセージを持つ ServiceManagerException を構築します。
ServiceManagerException(String, Throwable) - class jp.co.intra_mart.framework.base.service.ServiceManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceManagerException を構築します。
ServicePropertyException - exception jp.co.intra_mart.framework.base.service.ServicePropertyException.
サービスプロパティ取得時の例外です。
ServicePropertyException() - class jp.co.intra_mart.framework.base.service.ServicePropertyException のコンストラクタ
詳細メッセージを指定しないで ServicePropertyException を構築します。
ServicePropertyException(String) - class jp.co.intra_mart.framework.base.service.ServicePropertyException のコンストラクタ
指定された詳細メッセージを持つ ServicePropertyException を構築します。
ServicePropertyException(String, Throwable) - class jp.co.intra_mart.framework.base.service.ServicePropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServicePropertyException を構築します。
ServicePropertyHandler - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler.
サービスの設定情報に接続するクラスです。
ServiceResult - interface jp.co.intra_mart.framework.base.service.ServiceResult.
サービスの処理結果です。
ServiceSecurityFilter - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter.
intra-mart画面を表示するURLの詐称をチェックするためのフィルタです。
ServiceSecurityFilter() - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter のコンストラクタ
ServiceServlet - class jp.co.intra_mart.framework.base.service.ServiceServlet.
サービスを振り分けるサーブレットです。
ServiceServlet() - class jp.co.intra_mart.framework.base.service.ServiceServlet のコンストラクタ
ServiceServletを新規に生成します。
ServiceServletException - exception jp.co.intra_mart.framework.base.service.ServiceServletException.
サービスに関連する例外です。
ServiceServletException() - class jp.co.intra_mart.framework.base.service.ServiceServletException のコンストラクタ
詳細メッセージを指定しないで ServiceServletException を構築します。
ServiceServletException(String) - class jp.co.intra_mart.framework.base.service.ServiceServletException のコンストラクタ
指定された詳細メッセージを持つ ServiceServletException を構築します。
ServiceServletException(String, Throwable) - class jp.co.intra_mart.framework.base.service.ServiceServletException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceServletException を構築します。
SessionFactory - interface jp.co.intra_mart.framework.base.session.SessionFactory.
セッションに関連するファクトリクラスとなるインタフェースです。
SessionFactoryException - exception jp.co.intra_mart.framework.base.session.SessionFactoryException.
セッションファクトリ内の例外です。
SessionFactoryException() - class jp.co.intra_mart.framework.base.session.SessionFactoryException のコンストラクタ
詳細メッセージを指定しないで SessionFactoryException を構築します。
SessionFactoryException(String) - class jp.co.intra_mart.framework.base.session.SessionFactoryException のコンストラクタ
指定された詳細メッセージを持つ SessionFactoryException を構築します。
SessionFactoryException(String, Throwable) - class jp.co.intra_mart.framework.base.session.SessionFactoryException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionFactoryException を構築します。
SessionFilter - class jp.co.intra_mart.framework.base.session.SessionFilter.
セッション管理をします。
SessionFilter() - class jp.co.intra_mart.framework.base.session.SessionFilter のコンストラクタ
SessionManager - class jp.co.intra_mart.framework.base.session.SessionManager.
セッションマネージャです。
SessionManagerException - exception jp.co.intra_mart.framework.base.session.SessionManagerException.
セッションマネージャ内の例外です。
SessionManagerException() - class jp.co.intra_mart.framework.base.session.SessionManagerException のコンストラクタ
詳細メッセージを指定しないで SessionManagerException を構築します。
SessionManagerException(String) - class jp.co.intra_mart.framework.base.session.SessionManagerException のコンストラクタ
指定された詳細メッセージを持つ SessionManagerException を構築します。
SessionManagerException(String, Throwable) - class jp.co.intra_mart.framework.base.session.SessionManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionManagerException を構築します。
SessionObject - interface jp.co.intra_mart.framework.base.session.SessionObject.
セッションに関連する情報を持つオブジェクトです。
SessionObjectException - exception jp.co.intra_mart.framework.base.session.SessionObjectException.
セッションオブジェクト内の例外です。
SessionObjectException() - class jp.co.intra_mart.framework.base.session.SessionObjectException のコンストラクタ
詳細メッセージを指定しないで SessionObjectException を構築します。
SessionObjectException(String) - class jp.co.intra_mart.framework.base.session.SessionObjectException のコンストラクタ
指定された詳細メッセージを持つ SessionObjectException を構築します。
SessionObjectException(String, Throwable) - class jp.co.intra_mart.framework.base.session.SessionObjectException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionObjectException を構築します。
SessionPropertyException - exception jp.co.intra_mart.framework.base.session.SessionPropertyException.
セッションプロパティ取得時の例外です。
SessionPropertyException() - class jp.co.intra_mart.framework.base.session.SessionPropertyException のコンストラクタ
詳細メッセージを指定しないで SessionPropertyException を構築します。
SessionPropertyException(String) - class jp.co.intra_mart.framework.base.session.SessionPropertyException のコンストラクタ
指定された詳細メッセージを持つ SessionPropertyException を構築します。
SessionPropertyException(String, Throwable) - class jp.co.intra_mart.framework.base.session.SessionPropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionPropertyException を構築します。
SessionPropertyHandler - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler.
セッションに関連するプロパティを取得します。
SimpleControllerConverter - class jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter.
リクエストの内容をコントローラオブジェクトにマッピングする単純なコントローラコンバータです。
SimpleControllerConverter() - class jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter のコンストラクタ
StandardEJBEventListener - class jp.co.intra_mart.framework.base.event.StandardEJBEventListener.
StandardEJBEventListenerAgentに接続するイベントリスナです。
StandardEJBEventListener(StandardEJBEventListenerAgentHome) - class jp.co.intra_mart.framework.base.event.StandardEJBEventListener のコンストラクタ
StandardEJBEventListenerを新規に生成します。
StandardEJBEventListenerAgent - interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent.
EJBを利用するときのイベントリスナのリモートインタフェースです。
StandardEJBEventListenerAgentBean - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean.
EJBを利用する場合の抽象的なイベントリスナです。
StandardEJBEventListenerAgentBean() - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean のコンストラクタ
StandardEJBEventListenerAgentBeanを新規に生成します。
StandardEJBEventListenerAgentHome - interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome.
StandardEJBEventListenerAgentのホームインタフェースです。
StandardEJBEventListenerFactory - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory.
標準的なEJB用のイベントリスナファクトリです。
StandardEJBEventListenerFactory() - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory のコンストラクタ
StandardEJBEventListenerFactoryを新規に生成します。
StandardEventListener - class jp.co.intra_mart.framework.base.event.StandardEventListener.
汎用的なビジネスロジック用のクラスです。
StandardEventListener() - class jp.co.intra_mart.framework.base.event.StandardEventListener のコンストラクタ
StandardEventListenerFactory - class jp.co.intra_mart.framework.base.event.StandardEventListenerFactory.
通常のJavaクラスのイベントリスナを生成します。
StandardEventListenerFactory() - class jp.co.intra_mart.framework.base.event.StandardEventListenerFactory のコンストラクタ
StandardEventListenerFactoryを新規に生成します。
SubmitLinkTag - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag.
サブミット専用のLINKタグです。
SubmitLinkTag() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のコンストラクタ
SubmitLinkTagを新規に生成します。
SubmitLinkTagBeanInfo - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo.
SubmitLinkTagのBeanInfoです。
SubmitLinkTagBeanInfo() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo のコンストラクタ
SubmitLinkTagBeanInfoを新規に生成します。
SubmitTEI - class jp.co.intra_mart.framework.base.web.tag.SubmitTEI.
Submitタグの拡張情報です。
SubmitTEI() - class jp.co.intra_mart.framework.base.web.tag.SubmitTEI のコンストラクタ
SubmitTEIを新規に生成します。
SubmitTag - class jp.co.intra_mart.framework.base.web.tag.SubmitTag.
Submitタグです。
SubmitTag() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のコンストラクタ
SubmitTagを新規に生成します。
SubmitTagBeanInfo - class jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo.
SubmitTagのBeanInfoです。
SubmitTagBeanInfo() - class jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo のコンストラクタ
SubmitTagBeanInfoを新規に生成します。
SystemDBConnector - class jp.co.intra_mart.framework.base.data.SystemDBConnector.
イントラマートで設定されているDBコネクションです。
SystemDBConnector() - class jp.co.intra_mart.framework.base.data.SystemDBConnector のコンストラクタ
SystemDBConnectorを新規に生成します。
SystemDBDAO - class jp.co.intra_mart.framework.base.data.SystemDBDAO.
イントラマートで設定されたDBへアクセスするDAOです。
SystemDBDAO() - class jp.co.intra_mart.framework.base.data.SystemDBDAO のコンストラクタ
IntramartDBDAOを新規に生成します。
SystemException - exception jp.co.intra_mart.framework.system.exception.SystemException.
フレームワーク内で発生したシステム例外です。
SystemException() - class jp.co.intra_mart.framework.system.exception.SystemException のコンストラクタ
詳細メッセージを指定しないで SystemException を構築します。
SystemException(String) - class jp.co.intra_mart.framework.system.exception.SystemException のコンストラクタ
指定された詳細メッセージを持つ SystemException を構築します。
SystemException(Throwable) - class jp.co.intra_mart.framework.system.exception.SystemException のコンストラクタ
この例外の発生原因となる例外を持つ SystemException を構築します。
SystemException(String, Throwable) - class jp.co.intra_mart.framework.system.exception.SystemException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SystemException を構築します。
select(String) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
ノードの配列を返却します。
sendMessage(String, String, String) - class jp.co.intra_mart.framework.system.log.DefaultLogAgent のメソッド
メッセージを出力します。
sendMessage(String, String, String, Object) - class jp.co.intra_mart.framework.system.log.DefaultLogAgent のメソッド
メッセージを出力します。
sendMessage(String, String, String) - class jp.co.intra_mart.framework.system.log.IntramartLogAgent のメソッド
メッセージを出力します。
sendMessage(String, String, String, Object) - class jp.co.intra_mart.framework.system.log.IntramartLogAgent のメソッド
メッセージを出力します。
sendMessage(String, String, String) - interface jp.co.intra_mart.framework.system.log.LogAgent のメソッド
メッセージを出力します。
sendMessage(String, String, String, Object) - interface jp.co.intra_mart.framework.system.log.LogAgent のメソッド
メッセージを出力します。
service() - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
入力に対する処理を実行します。
service() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
入力に対する処理を実行します。
sessionContext - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean の変数
セッションコンテキスト
setAccept(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性acceptの値を設定します。
setAcceptcharset(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性accept-charsetの値を設定します。
setAccesskey(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
accesskeyを設定します。
setAccesskey(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
accesskeyを設定します。
setApplication(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性applicationの値を設定します。
setApplication(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
アプリケーションを設定します。
setApplication(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
アプリケーションを設定します。
setApplication(String) - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
applicationを設定します。
setApplication(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
アプリケーションを設定します。
setApplication(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性applicationの値を設定します。
setAttribute(String, Object) - class jp.co.intra_mart.framework.base.session.HttpSessionObject のメソッド
推奨されていません。 指定された名前に対応するオブジェクトを追加します。
setAttribute(String, Object) - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のメソッド
推奨されていません。 指定された名前に対応するオブジェクトを追加します。
setAttribute(String, Object) - interface jp.co.intra_mart.framework.base.session.SessionObject のメソッド
指定された名前に対応するオブジェクトを追加します。
setCharset(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
charsetを設定します。
setClass(String) - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag のメソッド
推奨されていません。 このメソッドではなくHelperBeanTag.setHelperclass(java.lang.String)メソッドを使用してください。
setClientType(String) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
クライアントタイプを設定する。
setColorPatternID(String) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
カラーパターンIDを設定する。
setConnectInfo(DataConnector, String, String, String) - interface jp.co.intra_mart.framework.base.data.DAO のメソッド
データリソースに接続する時の情報を設定します。
setConnectInfo(DataConnector, String, String, String) - class jp.co.intra_mart.framework.base.data.DAOAdapter のメソッド
データリソースに接続する時の情報を設定します。
setConnectInfo(DataConnector, String, String, String) - class jp.co.intra_mart.framework.base.data.DBDAO のメソッド
データリソースに接続する時の情報を設定します。
setConnectInfo(DataConnector, String, String, String) - class jp.co.intra_mart.framework.base.data.IntramartDBDAO のメソッド
推奨されていません。 データリソースに接続する時の情報を設定します。
setConnectInfo(DataConnector, String, String, String) - class jp.co.intra_mart.framework.base.data.IntramartFileServerDAO のメソッド
データリソースに接続する時の情報を設定します。
setConnectInfo(DataConnector, String, String, String) - class jp.co.intra_mart.framework.base.data.LoginGroupDBDAO のメソッド
データリソースに接続する時の情報を設定します。
setConnectInfo(DataConnector, String, String, String) - class jp.co.intra_mart.framework.base.data.SystemDBDAO のメソッド
データリソースに接続する時の情報を設定します。
setControllerObject(ControllerObject) - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
コントローラオブジェクトを設定します。
setControllerObject(ControllerObject) - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
コントローラオブジェクトを設定します。
setCoords(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
coordsを設定します。
setCoords(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
coordsを設定します。
setDataPropertyHandler(DataPropertyHandler) - class jp.co.intra_mart.framework.base.data.DataConnector のメソッド
データプロパティハンドラを設定します。
setDir(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性dirの値を設定します。
setDir(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
dirを設定します。
setDir(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
dirを設定します。
setDir(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性dirの値を設定します。
setDir(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes のメソッド
属性dirの値を取得します。
setEncoding(String) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
エンコーディングを設定する。
setEnctype(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性enctypeの値を設定します。
setForm(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
ターゲットとなるフォーム名を設定します。
setFormclass(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性classの値を設定します。
setFrameClass(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
推奨されていません。 このメソッドではなくFrameTag.setFrameclass(String)メソッドを使用してください。
setFrameborder(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
frameborderを設定します。
setFrameclass(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
frameClassを設定します。
setHelperclass(String) - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag のメソッド
クラス名を設定します。
setHreflang(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
hreflangを設定します。
setInTransaction(boolean) - class jp.co.intra_mart.framework.base.event.EJBEventListener のメソッド
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
setInTransaction(boolean) - interface jp.co.intra_mart.framework.base.event.EventListener のメソッド
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
setInTransaction(boolean) - class jp.co.intra_mart.framework.base.event.GenericEventListener のメソッド
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
setInTransaction(boolean) - class jp.co.intra_mart.framework.base.event.StandardEventListener のメソッド
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
setInformation() - class jp.co.intra_mart.framework.base.service.DefaultTransition のメソッド
次の遷移先に渡す情報を設定します。
setInformation() - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のメソッド
次の遷移先に渡す情報を設定します。
setInformation() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
次の遷移先に渡す情報を設定します。
setInitParameter(String, String) - class jp.co.intra_mart.framework.system.util.Config のメソッド
Validatorを初期化するときのパラメータを設定します。
setJNDIName(String) - class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory のメソッド
EJBEventListenerAgentHomeのJNDI名を設定します。
setKey(String) - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
keyを設定します。
setLang(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性langの値を設定します。
setLang(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
langを設定します。
setLang(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
langを設定します。
setLang(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性langの値を設定します。
setLang(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes のメソッド
属性langの値を設定します。
setLinkClass(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
推奨されていません。 このメソッドではなくLinkTag.setLinkclass(String)メソッドを使用してください。
setLinkclass(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
linkClassを設定します。
setLinkclass(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
linkClassを設定します。
setListener(StandardEventListener) - class jp.co.intra_mart.framework.base.event.GenericEventListener のメソッド
イベント処理クラスを設定します。
setListenerName(String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory のメソッド
EJBEventListenerAgentBeanのクラス名を設定します。
setListenerName(String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory のメソッド
EJBEventListenerAgentBeanのクラス名を設定します。
setLocale(Locale) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ユーザのロケールを設定する。
setLocale(String) - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
localeを設定します。
setLoginGroupID(String) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログイングループIDを設定する。
setLoginTime(Date) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログインした時間を設定する。
setLoginType(String) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログインタイプを設定する。
setLongdesc(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
longdescを設定します。
setMarginheight(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
marginheightを設定します。
setMarginwidth(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
marginwidthを設定します。
setMessage(String) - class jp.co.intra_mart.framework.base.service.validator.ValidationExceptionDetail のメソッド
検証結果のメッセージを設定します。
setMethod(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性methodの値を設定します。
setName(String) - class jp.co.intra_mart.framework.base.event.EventTriggerInfo のメソッド
イベントトリガ名を設定します。
setName(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性nameの値を設定します。
setName(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
nameを設定します。
setName(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
nameを設定します。
setName(String) - class jp.co.intra_mart.framework.base.web.tag.ParamTag のメソッド
パラメータ名を設定します。
setName(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
nameを設定します。
setName(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性nameを設定します。
setName(String) - class jp.co.intra_mart.framework.system.property.PropertyParam のメソッド
パラメータ名を設定します。
setNodeName(String) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
ノード名を設定します。
setNoresize(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
noresizeを設定します。
setNumber(int) - class jp.co.intra_mart.framework.base.event.EventTriggerInfo のメソッド
ソート番号を設定します。
setOnClick(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onClickの値を設定します。
setOnDblClick(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性obDblClickの値を設定します。
setOnKeyDown(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyDownの値を設定します。
setOnKeyPress(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyPressの値を設定します。
setOnKeyUp(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyUpの値を設定します。
setOnMouseDown(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseDownの値を設定します。
setOnMouseMove(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseMoveの値を設定します。
setOnMouseOut(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseOutの値を設定します。
setOnMouseOver(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseOverの値を設定します。
setOnMouseUp(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseUpの値を設定します。
setOnblur(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
onblurを設定します。
setOnblur(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
onblurを設定します。
setOnblur(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onBlurを設定します。
setOnclick(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onClickの値を設定します。
setOnclick(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onClickの値を設定します。
setOnclick(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onClickの値を設定します。
setOnclick(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onClickの値を設定します。
setOndblclick(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性obDblClickの値を設定します。
setOndblclick(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性obDblClickの値を設定します。
setOndblclick(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性obDblClickの値を設定します。
setOndblclick(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性obDblClickの値を設定します。
setOnfocus(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
onfocusを設定します。
setOnfocus(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
onfocusを設定します。
setOnfocus(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onFocusを設定します。
setOnkeydown(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onKeyDownの値を設定します。
setOnkeydown(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onKeyDownの値を設定します。
setOnkeydown(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onKeyDownの値を設定します。
setOnkeydown(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onKeyDownの値を設定します。
setOnkeypress(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onKeyPressの値を設定します。
setOnkeypress(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onKeyPressの値を設定します。
setOnkeypress(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onKeyPressの値を設定します。
setOnkeypress(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onKeyPressの値を設定します。
setOnkeyup(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onKeyUpの値を設定します。
setOnkeyup(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onKeyUpの値を設定します。
setOnkeyup(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onKeyUpの値を設定します。
setOnkeyup(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onKeyUpの値を設定します。
setOnmousedown(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseDownの値を設定します。
setOnmousedown(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseDownの値を設定します。
setOnmousedown(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseDownの値を設定します。
setOnmousedown(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseDownの値を設定します。
setOnmousemove(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseMoveの値を設定します。
setOnmousemove(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseMoveの値を設定します。
setOnmousemove(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseMoveの値を設定します。
setOnmousemove(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseMoveの値を設定します。
setOnmouseout(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseOutの値を設定します。
setOnmouseout(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseOutの値を設定します。
setOnmouseout(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseOutの値を設定します。
setOnmouseout(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseOutの値を設定します。
setOnmouseover(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseOverの値を設定します。
setOnmouseover(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseOverの値を設定します。
setOnmouseover(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseOverの値を設定します。
setOnmouseover(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseOverの値を設定します。
setOnmouseup(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseUpの値を設定します。
setOnmouseup(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseUpの値を設定します。
setOnmouseup(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseUpの値を設定します。
setOnmouseup(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseUpの値を設定します。
setOnreset(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onResetの値を設定します。
setOnsubmit(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onSubmitの値を設定します。
setProperties(Map) - class jp.co.intra_mart.framework.system.property.PropertyConfigModel のメソッド
パラメータを設定します。
setProvider(Provider) - class jp.co.intra_mart.framework.base.data.container.factory.DataContainerFactory のメソッド
プロバイダを設定します。
setProvider(Provider) - class jp.co.intra_mart.framework.base.event.container.factory.EventContainerFactory のメソッド
プロバイダを設定します。
setProvider(Provider) - class jp.co.intra_mart.framework.base.service.container.factory.ServiceContainerFactory のメソッド
プロバイダを設定します。
setProvider(Provider) - interface jp.co.intra_mart.framework.system.container.factory.IMContainerFactory のメソッド
setRealUserInfo(UserInfo) - class jp.co.intra_mart.framework.base.util.UserInfoWrapper のメソッド
このオブジェクトがラップするUserInfoの実装を設定します。
setRel(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
relを設定します。
setRequest(HttpServletRequest) - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
リクエストを設定します。
setRequest(HttpServletRequest) - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
リクエストを設定します。
setRequest(HttpServletRequest) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
リクエストを設定します。
setRequest(HttpServletRequest) - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
リクエストを設定します。
setResponse(HttpServletResponse) - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
レスポンスを設定します。
setResponse(HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
レスポンスを設定します。
setResponse(HttpServletResponse) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
レスポンスを設定します。
setResponse(HttpServletResponse) - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
レスポンスを設定します。
setResult(ServiceResult) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
サービス処理結果を設定します。
setRev(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
relを設定します。
setScrolling(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
scrollingを設定します。
setSecurityExt(String) - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter のメソッド
推奨されていません。 セキュリティの拡張子を設定します。
setService(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性serviceの値を設定します。
setService(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
serviceを設定します。
setService(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
serviceを設定します。
setService(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
サービスを設定します。
setService(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性serviceの値を設定します。
setServiceManager(ServiceManager) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
サービスマネージャを設定します。
setSessionContext(SessionContext) - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean のメソッド
関連するSessionContextを設定します。
setShape(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
shapeを設定します。
setShape(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
shapeを設定します。
setStyle(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性styleの値を設定します。
setStyle(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
styleを設定します。
setStyle(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
styleを設定します。
setStyle(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
styleを設定します。
setStyle(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性styleの値を設定します。
setStyle(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性styleの値を設定します。
setSubmitclass(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性classの値を設定します。
setTabindex(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
tabindexを設定します。
setTabindex(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
tabindexを設定します。
setTabindex(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
tabindexを設定します。
setTagClass(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性classの値を設定します。
setTagWriter(TagWriter) - class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes のメソッド
TagWriterを設定します。
setTarget(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性targetの値を設定します。
setTarget(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
targetを設定します。
setTitle(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性titleの値を設定します。
setTitle(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
titleを設定します。
setTitle(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
titleを設定します。
setTitle(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
titleを設定します。
setTitle(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性titleの値を設定します。
setTitle(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性titleの値を設定します。
setType(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
typeを設定します。
setUserID(String) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログインユーザIDを設定する。
setValidationExceptionDetails(Collection) - class jp.co.intra_mart.framework.base.service.validator.ValidationException のメソッド
検証結果の詳細を設定します。
setValidatorClassName(String) - class jp.co.intra_mart.framework.base.service.ValidatorMapping のメソッド
バリデータ名を設定します。
setValidatorConfig(ValidatorConfig) - class jp.co.intra_mart.framework.base.service.ValidatorMapping のメソッド
バリデータの初期化パラメータを設定します。
setValue(Object) - class jp.co.intra_mart.framework.base.web.tag.MessageParamTag のメソッド
パラメータの値を設定します。
setValue(String) - class jp.co.intra_mart.framework.base.web.tag.ParamTag のメソッド
パラメータの値を設定します。
setValue(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性valueを設定します。
setValue(String) - class jp.co.intra_mart.framework.system.property.PropertyParam のメソッド
パラメータの値を設定します。
setValue(String) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
値を設定します。
setValue(String, String) - class jp.co.intra_mart.framework.util.XMLNode のメソッド
値を設定します。

T

TYPE_DB - class jp.co.intra_mart.framework.system.log.IntramartLogAgent の static 変数
データベースログに出力する場合のカテゴリの種類
TagWriter - class jp.co.intra_mart.framework.base.web.tag.TagWriter.
タグの出力を行います。
TagWriter(JspWriter) - class jp.co.intra_mart.framework.base.web.tag.TagWriter のコンストラクタ
TagWriterを新規に生成します。
TextFileDataPropertyHandler - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler.
指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
TextFileDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のコンストラクタ
TextFileDataPropertyHandlerを新規に生成します。
TextFileEventPropertyHandler - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler.
指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
TextFileEventPropertyHandler() - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のコンストラクタ
TextFileEventPropertyHandlerを新規に生成します。
TextFileMessagePropertyHandler - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler.
指定されたファイルからプロパティ情報を取得するメッセージプロパティハンドラです。
TextFileMessagePropertyHandler() - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler のコンストラクタ
TextFileServicePropertyHandler - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.
指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
TextFileServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のコンストラクタ
TextFileServicePropertyHandlerを新規に生成します。
Transition - class jp.co.intra_mart.framework.base.service.Transition.
画面遷移に関連するクラスのインタフェースです。
Transition() - class jp.co.intra_mart.framework.base.service.Transition のコンストラクタ
Transitionを新規に生成します。
TransitionException - exception jp.co.intra_mart.framework.base.service.TransitionException.
トランジションに関連する例外です。
TransitionException() - class jp.co.intra_mart.framework.base.service.TransitionException のコンストラクタ
詳細メッセージを指定しないで TransitionException を構築します。
TransitionException(String) - class jp.co.intra_mart.framework.base.service.TransitionException のコンストラクタ
指定された詳細メッセージを持つ TransitionException を構築します。
TransitionException(String, Throwable) - class jp.co.intra_mart.framework.base.service.TransitionException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ TransitionException を構築します。
transfer() - class jp.co.intra_mart.framework.base.service.DefaultTransition のメソッド
次のページに遷移します。
transfer() - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のメソッド
ページベースの画面に遷移します。
transfer() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
次のページに遷移します。

U

UserInfo - interface jp.co.intra_mart.framework.base.util.UserInfo.
ログインユーザの情報を管理します。
UserInfoException - exception jp.co.intra_mart.framework.base.util.UserInfoException.
ユーザ情報に関連する例外です。
UserInfoException() - class jp.co.intra_mart.framework.base.util.UserInfoException のコンストラクタ
詳細メッセージを指定しないで UserInfoException を構築します。
UserInfoException(String) - class jp.co.intra_mart.framework.base.util.UserInfoException のコンストラクタ
指定された詳細メッセージを持つ UserInfoException を構築します。
UserInfoException(String, Throwable) - class jp.co.intra_mart.framework.base.util.UserInfoException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ UserInfoException を構築します。
UserInfoUtil - class jp.co.intra_mart.framework.base.util.UserInfoUtil.
ログインユーザの情報に関するユーティリティクラスです。
UserInfoWrapper - class jp.co.intra_mart.framework.base.util.UserInfoWrapper.
UserInfoを拡張するための実装です。
UserInfoWrapper() - class jp.co.intra_mart.framework.base.util.UserInfoWrapper のコンストラクタ
UserInfoWrapperを新規に生成します。

V

ValidationException - exception jp.co.intra_mart.framework.base.service.validator.ValidationException.
検証結果が不正であるときの例外です。
ValidationException() - class jp.co.intra_mart.framework.base.service.validator.ValidationException のコンストラクタ
詳細メッセージを指定しないで ValidationException を構築します。
ValidationException(String) - class jp.co.intra_mart.framework.base.service.validator.ValidationException のコンストラクタ
指定された詳細メッセージを持つ ValidationException を構築します。
ValidationException(String, Throwable) - class jp.co.intra_mart.framework.base.service.validator.ValidationException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestFormatException を構築します。
ValidationExceptionDetail - class jp.co.intra_mart.framework.base.service.validator.ValidationExceptionDetail.
検証結果の詳細情報です。
ValidationExceptionDetail() - class jp.co.intra_mart.framework.base.service.validator.ValidationExceptionDetail のコンストラクタ
メッセージなしのValidatorExceptionDetailを生成します。
ValidationExceptionDetail(String) - class jp.co.intra_mart.framework.base.service.validator.ValidationExceptionDetail のコンストラクタ
メッセージ付きのValidatorExceptionDetailを生成します。
Validator - interface jp.co.intra_mart.framework.base.service.validator.Validator.
リクエスト内容の検証をします。
ValidatorConfig - interface jp.co.intra_mart.framework.base.service.validator.ValidatorConfig.
Validatorの初期化情報です。
ValidatorConfigImpl - class jp.co.intra_mart.framework.base.service.validator.ValidatorConfigImpl.
ValidatorConfigの実装です。
ValidatorConfigImpl() - class jp.co.intra_mart.framework.base.service.validator.ValidatorConfigImpl のコンストラクタ
ValidatorException - exception jp.co.intra_mart.framework.base.service.validator.ValidatorException.
Validatorに関連する例外です。
ValidatorException() - class jp.co.intra_mart.framework.base.service.validator.ValidatorException のコンストラクタ
詳細メッセージを指定しないで ValidatorException を構築します。
ValidatorException(String) - class jp.co.intra_mart.framework.base.service.validator.ValidatorException のコンストラクタ
指定された詳細メッセージを持つ ValidatorException を構築します。
ValidatorException(String, Throwable) - class jp.co.intra_mart.framework.base.service.validator.ValidatorException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ValidatorException を構築します。
ValidatorMapping - class jp.co.intra_mart.framework.base.service.ValidatorMapping.
バリデータの設定を保持します。
ValidatorMapping() - class jp.co.intra_mart.framework.base.service.ValidatorMapping のコンストラクタ
ValidatorMappingを新規に生成します。
ValidatorModel - class jp.co.intra_mart.framework.base.service.ValidatorModel.
バリデータ情報を管理するクラスです。
ValidatorModel() - class jp.co.intra_mart.framework.base.service.ValidatorModel のコンストラクタ
validate(RequestInfo) - class jp.co.intra_mart.framework.base.service.validator.FormatValidator のメソッド
文字列の不正文字（フォーマット）を検証します。
validate(RequestInfo) - class jp.co.intra_mart.framework.base.service.validator.LengthValidator のメソッド
文字列の長さを検証します。
validate(RequestInfo) - class jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator のメソッド
数値の範囲を検証します。
validate(RequestInfo) - class jp.co.intra_mart.framework.base.service.validator.NumericValidator のメソッド
数値の検証をします。
validate(RequestInfo) - interface jp.co.intra_mart.framework.base.service.validator.Validator のメソッド
リクエスト内容の検証をします。

X

XMLDocumentProducer - class jp.co.intra_mart.framework.util.XMLDocumentProducer.
XmlNodeを取得するクラスです。
XMLDocumentProducer() - class jp.co.intra_mart.framework.util.XMLDocumentProducer のコンストラクタ
XMLNode - class jp.co.intra_mart.framework.util.XMLNode.
XMLNode(Document) - class jp.co.intra_mart.framework.util.XMLNode のコンストラクタ
コンストラクタです。
XMLNode(Element) - class jp.co.intra_mart.framework.util.XMLNode のコンストラクタ
コンストラクタです。
XMLNode(Attr) - class jp.co.intra_mart.framework.util.XMLNode のコンストラクタ
コンストラクタです。
XMLNode(Node) - class jp.co.intra_mart.framework.util.XMLNode のコンストラクタ
コンストラクタです。
XMLNode(Node, Node) - class jp.co.intra_mart.framework.util.XMLNode のコンストラクタ
コンストラクタです。
XmlDataPropertyHandler - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler.
XMLのデータプロパティハンドラです。
XmlDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のコンストラクタ
コンストラクタです。
XmlEventPropertyHandler - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler.
XMLのEventPropertyHandlerです。
XmlEventPropertyHandler() - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のコンストラクタ
DefaultEventPropertyHandlerを新規に生成します。
XmlLogPropertyHandler - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler.
リソースからログプロパティ情報を取得するプロパティハンドラです。
XmlLogPropertyHandler() - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler のコンストラクタ
XMLLogPropertyHandlerを新規に生成します。
XmlPropertyManager - class jp.co.intra_mart.framework.system.property.XmlPropertyManager.
xmlのプロパティマネージャです。
XmlPropertyManager() - class jp.co.intra_mart.framework.system.property.XmlPropertyManager のコンストラクタ
コンストラクタです。
XmlServicePropertyHandler - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.
サービスの設定情報に接続するプロパティハンドラです。
XmlServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のコンストラクタ
XmlServicePropertyHandlerを新規に生成します。
XmlSessionPropertyHandler - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler.
セッションに関連するXMLのプロパティハンドラです。
XmlSessionPropertyHandler() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のコンストラクタ
A B C D E F G H I J K L M N O P R S T U V X
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


j2ee_framework 6.1.14 API

フレーム関連の警告

このドキュメントはフレーム機能を使って表示するように作られています。フレームを表示できない Web クライアントの場合にこのメッセージが表示されます。
リンク先フレームなしのバージョン


概要 (j2ee_framework 6.1.14 API)

すべてのクラス

パッケージ
jp.co.intra_mart.framework.base.data
jp.co.intra_mart.framework.base.data.container
jp.co.intra_mart.framework.base.data.container.factory
jp.co.intra_mart.framework.base.event
jp.co.intra_mart.framework.base.event.container
jp.co.intra_mart.framework.base.event.container.factory
jp.co.intra_mart.framework.base.message
jp.co.intra_mart.framework.base.service
jp.co.intra_mart.framework.base.service.container
jp.co.intra_mart.framework.base.service.container.factory
jp.co.intra_mart.framework.base.service.controller
jp.co.intra_mart.framework.base.service.validator
jp.co.intra_mart.framework.base.session
jp.co.intra_mart.framework.base.util
jp.co.intra_mart.framework.base.web.bean
jp.co.intra_mart.framework.base.web.tag
jp.co.intra_mart.framework.base.web.tag.attribute
jp.co.intra_mart.framework.base.web.util
jp.co.intra_mart.framework.system.container
jp.co.intra_mart.framework.system.container.factory
jp.co.intra_mart.framework.system.exception
jp.co.intra_mart.framework.system.log
jp.co.intra_mart.framework.system.message
jp.co.intra_mart.framework.system.property
jp.co.intra_mart.framework.system.util
jp.co.intra_mart.framework.util


概要 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

intra-mart 6.1.14 JavaEE Framework API Specifications

パッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.data.container |
jp.co.intra_mart.framework.base.data.container.factory |
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event.container |
jp.co.intra_mart.framework.base.event.container.factory |
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service.container |
jp.co.intra_mart.framework.base.service.container.factory |
jp.co.intra_mart.framework.base.service.controller | 入力情報に関連するパッケージです。
jp.co.intra_mart.framework.base.service.validator | 検証に関連するパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.tag | J2EEフレームワークで使用する各種のタグのパッケージです。
jp.co.intra_mart.framework.base.web.tag.attribute | タグ属性のパッケージです。
jp.co.intra_mart.framework.base.web.util | Web上で使用するユーティリティのパッケージです。
jp.co.intra_mart.framework.system.container |
jp.co.intra_mart.framework.system.container.factory |
jp.co.intra_mart.framework.system.exception | J2EEフレームワークの例外に関連するパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.message | メッセージに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。
jp.co.intra_mart.framework.system.util |
jp.co.intra_mart.framework.util | J2EEフレームワークで使用する各種のユーティリティです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス階層 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.framework.base.data, jp.co.intra_mart.framework.base.data.container, jp.co.intra_mart.framework.base.data.container.factory, jp.co.intra_mart.framework.base.event, jp.co.intra_mart.framework.base.event.container, jp.co.intra_mart.framework.base.event.container.factory, jp.co.intra_mart.framework.base.message, jp.co.intra_mart.framework.base.service, jp.co.intra_mart.framework.base.service.container, jp.co.intra_mart.framework.base.service.container.factory, jp.co.intra_mart.framework.base.service.controller, jp.co.intra_mart.framework.base.service.validator, jp.co.intra_mart.framework.base.session, jp.co.intra_mart.framework.base.util, jp.co.intra_mart.framework.base.web.bean, jp.co.intra_mart.framework.base.web.tag, jp.co.intra_mart.framework.base.web.tag.attribute, jp.co.intra_mart.framework.base.web.util, jp.co.intra_mart.framework.system.container, jp.co.intra_mart.framework.system.container.factory, jp.co.intra_mart.framework.system.exception, jp.co.intra_mart.framework.system.log, jp.co.intra_mart.framework.system.message, jp.co.intra_mart.framework.system.property, jp.co.intra_mart.framework.system.util, jp.co.intra_mart.framework.util

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.system.util.Config
      • class jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfigImpl (implements jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfig)
      • class jp.co.intra_mart.framework.base.service.validator.ValidatorConfigImpl (implements jp.co.intra_mart.framework.base.service.validator.ValidatorConfig)
    • class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo (implements java.io.Serializable, jp.co.intra_mart.framework.base.util.UserInfo)
    • class jp.co.intra_mart.framework.base.data.ConnectorModel
    • class jp.co.intra_mart.framework.base.service.ControllerConverterModel
    • class jp.co.intra_mart.framework.base.data.DAOAdapter (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.DaoModel
    • class jp.co.intra_mart.framework.base.data.DataAccessController
    • class jp.co.intra_mart.framework.base.data.DataConnector
      • class jp.co.intra_mart.framework.base.data.DBConnector
        • class jp.co.intra_mart.framework.base.data.DataSourceConnector
        • class jp.co.intra_mart.framework.base.data.JDBCConnector
      • class jp.co.intra_mart.framework.base.data.IntramartDBConnector
      • class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector
      • class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector
      • class jp.co.intra_mart.framework.base.data.SystemDBConnector
    • class jp.co.intra_mart.framework.base.data.container.factory.DataContainerFactory (implements jp.co.intra_mart.framework.system.container.factory.IMContainerFactory)
    • class jp.co.intra_mart.framework.base.data.container.DataContainerImpl (implements jp.co.intra_mart.framework.base.data.container.DataContainer)
    • class jp.co.intra_mart.framework.base.data.DataManager
    • class jp.co.intra_mart.framework.base.data.DBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class jp.co.intra_mart.framework.base.data.container.factory.DefaultDataProvider (implements jp.co.intra_mart.framework.system.container.factory.Provider)
    • class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class jp.co.intra_mart.framework.base.event.container.factory.DefaultEventProvider (implements jp.co.intra_mart.framework.system.container.factory.Provider)
    • class jp.co.intra_mart.framework.system.log.DefaultLogAgent (implements jp.co.intra_mart.framework.system.log.LogAgent)
    • class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler (implements jp.co.intra_mart.framework.system.log.LogPropertyHandler)
    • class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler (implements jp.co.intra_mart.framework.base.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler (implements jp.co.intra_mart.framework.system.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class jp.co.intra_mart.framework.base.service.container.factory.DefaultServiceProvider (implements jp.co.intra_mart.framework.system.container.factory.Provider)
    • class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler (implements jp.co.intra_mart.framework.base.session.SessionPropertyHandler)
    • class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class jp.co.intra_mart.framework.base.event.EJBEventListener (implements jp.co.intra_mart.framework.base.event.EventListener)
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListener
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal
      • class jp.co.intra_mart.framework.base.event.StandardEJBEventListener
    • class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean (implements javax.ejb.SessionBean)
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean
      • class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean
    • class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory
      • class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory
    • class jp.co.intra_mart.framework.base.service.EmptyServiceResult (implements jp.co.intra_mart.framework.base.service.ServiceResult)
    • class jp.co.intra_mart.framework.base.util.EmptyUserInfo (implements java.io.Serializable, jp.co.intra_mart.framework.base.util.UserInfo)
    • class jp.co.intra_mart.framework.base.service.EncodingFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.event.Event (implements java.io.Serializable)
      • class jp.co.intra_mart.framework.base.event.EmptyEvent
    • class jp.co.intra_mart.framework.base.event.container.factory.EventContainerFactory (implements jp.co.intra_mart.framework.system.container.factory.IMContainerFactory)
    • class jp.co.intra_mart.framework.base.event.container.EventContainerImpl (implements jp.co.intra_mart.framework.base.event.container.EventContainer)
    • class jp.co.intra_mart.framework.base.event.EventFactoryModel
    • class jp.co.intra_mart.framework.base.event.EventGroupModel
    • class jp.co.intra_mart.framework.base.event.EventManager
    • class jp.co.intra_mart.framework.base.event.EventModelProducer
    • class jp.co.intra_mart.framework.base.event.EventTriggerAdapter (implements jp.co.intra_mart.framework.base.event.EventTrigger)
    • class jp.co.intra_mart.framework.base.event.EventTriggerInfo
    • class jp.co.intra_mart.framework.base.event.EventTriggerList
    • class jp.co.intra_mart.framework.base.service.FileUploadFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.service.validator.FormatValidator (implements jp.co.intra_mart.framework.base.service.validator.Validator)
    • class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes
      • class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes
      • class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes
      • class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes
    • class jp.co.intra_mart.framework.base.event.GenericEventListener (implements jp.co.intra_mart.framework.base.event.EventListener)
    • class jp.co.intra_mart.framework.base.event.GenericEventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
    • class javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • class javax.servlet.http.HttpServlet (implements java.io.Serializable)
        • class jp.co.intra_mart.framework.base.service.IntramartConnectServlet
        • class jp.co.intra_mart.framework.base.service.ServiceServlet
    • class jp.co.intra_mart.framework.base.web.bean.HelperBean (implements java.io.Serializable)
      • class jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean
    • class jp.co.intra_mart.framework.base.web.util.HTMLEncoder
    • class jp.co.intra_mart.framework.base.session.HttpSessionFactory (implements jp.co.intra_mart.framework.base.session.SessionFactory)
    • class jp.co.intra_mart.framework.base.session.HttpSessionObject (implements jp.co.intra_mart.framework.base.session.SessionObject)
    • class jp.co.intra_mart.framework.base.service.IntramartConnectFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.util.IntramartConnectUtil
    • class jp.co.intra_mart.framework.util.IntramartConnectUtil.RequestInfo
    • class jp.co.intra_mart.framework.base.data.IntramartDBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.IntramartFileServerDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.system.log.IntramartLogAgent (implements jp.co.intra_mart.framework.system.log.LogAgent)
    • class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler (implements jp.co.intra_mart.framework.system.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.base.session.IntramartSessionFactory (implements jp.co.intra_mart.framework.base.session.SessionFactory)
    • class jp.co.intra_mart.framework.base.session.IntramartSessionObject (implements jp.co.intra_mart.framework.base.session.SessionObject)
    • class jp.co.intra_mart.framework.base.service.validator.LengthValidator (implements jp.co.intra_mart.framework.base.service.validator.Validator)
    • class jp.co.intra_mart.framework.base.service.LocaleFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.data.LoginGroupDBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.system.log.LogManager
    • class jp.co.intra_mart.framework.base.message.MessageManager
    • class jp.co.intra_mart.framework.system.message.MessageManager
    • class jp.co.intra_mart.framework.base.service.validator.NumericRangeValidator (implements jp.co.intra_mart.framework.base.service.validator.Validator)
    • class jp.co.intra_mart.framework.base.service.validator.NumericValidator (implements jp.co.intra_mart.framework.base.service.validator.Validator)
    • class jp.co.intra_mart.framework.system.property.PropertyConfigModel
    • class jp.co.intra_mart.framework.system.property.PropertyManager
      • class jp.co.intra_mart.framework.system.property.DefaultPropertyManager
      • class jp.co.intra_mart.framework.system.property.XmlPropertyManager
    • class jp.co.intra_mart.framework.system.property.PropertyModel
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.base.event.EventListenerFactoryParam
      • class jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam
      • class jp.co.intra_mart.framework.system.log.LogAgentParam
      • class jp.co.intra_mart.framework.system.message.MessagePropertyParam
      • class jp.co.intra_mart.framework.system.property.PropertyHandlerParam
      • class jp.co.intra_mart.framework.base.data.ResourceParam
    • class java.util.ResourceBundle
      • class jp.co.intra_mart.framework.util.FileResourceBundle
    • class jp.co.intra_mart.framework.base.data.ResourceModel
    • class jp.co.intra_mart.framework.util.SecurityUtil
    • class jp.co.intra_mart.framework.base.service.container.factory.ServiceContainerFactory (implements jp.co.intra_mart.framework.system.container.factory.IMContainerFactory)
    • class jp.co.intra_mart.framework.base.service.container.ServiceContainerImpl (implements jp.co.intra_mart.framework.base.service.container.ServiceContainer)
    • class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter (implements jp.co.intra_mart.framework.base.service.ServiceController)
    • class jp.co.intra_mart.framework.base.service.ServiceManager
    • class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.session.SessionFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.session.SessionManager
    • class java.beans.SimpleBeanInfo (implements java.beans.BeanInfo)
      • class jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo
    • class jp.co.intra_mart.framework.base.service.controller.SimpleControllerConverter (implements jp.co.intra_mart.framework.base.service.controller.ControllerConverter)
    • class jp.co.intra_mart.framework.base.event.StandardEventListener (implements jp.co.intra_mart.framework.base.event.EventListener)
    • class jp.co.intra_mart.framework.base.event.StandardEventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
    • class jp.co.intra_mart.framework.base.data.SystemDBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class javax.servlet.jsp.tagext.TagExtraInfo
      • class jp.co.intra_mart.framework.base.web.tag.FormTEI
      • class jp.co.intra_mart.framework.base.web.tag.FrameTEI
      • class jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI
      • class jp.co.intra_mart.framework.base.web.tag.LinkTEI
      • class jp.co.intra_mart.framework.base.web.tag.MessageTEI
      • class jp.co.intra_mart.framework.base.web.tag.SubmitTEI
    • class javax.servlet.jsp.tagext.TagSupport (implements javax.servlet.jsp.tagext.IterationTag, java.io.Serializable)
      • class javax.servlet.jsp.tagext.BodyTagSupport (implements javax.servlet.jsp.tagext.BodyTag)
        • class jp.co.intra_mart.framework.base.web.tag.FormTag
        • class jp.co.intra_mart.framework.base.web.tag.FrameTag (implements jp.co.intra_mart.framework.base.web.tag.ParameterSendable)
        • class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag
        • class jp.co.intra_mart.framework.base.web.tag.LinkTag (implements jp.co.intra_mart.framework.base.web.tag.ParameterSendable)
        • class jp.co.intra_mart.framework.base.web.tag.MessageParamTag
        • class jp.co.intra_mart.framework.base.web.tag.MessageTag
        • class jp.co.intra_mart.framework.base.web.tag.ParamTag
        • class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag
        • class jp.co.intra_mart.framework.base.web.tag.SubmitTag
    • class jp.co.intra_mart.framework.base.web.tag.TagWriter
    • class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler (implements jp.co.intra_mart.framework.base.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.ApplicationException
            • class jp.co.intra_mart.framework.base.service.RequestException
              • class jp.co.intra_mart.framework.base.service.validator.ValidationException
          • class jp.co.intra_mart.framework.system.property.PropertyHandlerException
          • class jp.co.intra_mart.framework.system.property.PropertyManagerException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.service.controller.ControllerConverterException
            • class jp.co.intra_mart.framework.base.data.DAOException
            • class jp.co.intra_mart.framework.base.data.DataAccessException
            • class jp.co.intra_mart.framework.base.data.DataConnectException
            • class jp.co.intra_mart.framework.base.data.DataConnectorException
            • class jp.co.intra_mart.framework.base.data.container.DataContainerException
            • class jp.co.intra_mart.framework.base.data.DataManagerException
            • class jp.co.intra_mart.framework.base.data.DataPropertyException
            • class jp.co.intra_mart.framework.base.event.container.EventContainerException
            • class jp.co.intra_mart.framework.base.event.EventException
            • class jp.co.intra_mart.framework.base.event.EventListenerException
            • class jp.co.intra_mart.framework.base.event.EventManagerException
            • class jp.co.intra_mart.framework.base.event.EventPropertyException
            • class jp.co.intra_mart.framework.base.event.EventTriggerException
            • class jp.co.intra_mart.framework.base.web.bean.HelperBeanException
            • class jp.co.intra_mart.framework.base.session.IllegalSessionException
            • class jp.co.intra_mart.framework.system.exception.IllegalSystemException
            • class jp.co.intra_mart.framework.system.exception.IMContainerException
            • class jp.co.intra_mart.framework.system.log.LogPropertyException
            • class jp.co.intra_mart.framework.base.message.MessageManagerException
            • class jp.co.intra_mart.framework.system.message.MessageManagerException
            • class jp.co.intra_mart.framework.base.message.MessagePropertyException
            • class jp.co.intra_mart.framework.system.message.MessagePropertyException
            • class jp.co.intra_mart.framework.base.service.controller.RequestFormatException
            • class jp.co.intra_mart.framework.base.service.container.ServiceContainerException
            • class jp.co.intra_mart.framework.base.service.ServiceControllerException
            • class jp.co.intra_mart.framework.base.service.ServiceManagerException
            • class jp.co.intra_mart.framework.base.service.ServicePropertyException
            • class jp.co.intra_mart.framework.base.service.ServiceServletException
            • class jp.co.intra_mart.framework.base.session.SessionFactoryException
            • class jp.co.intra_mart.framework.base.session.SessionManagerException
            • class jp.co.intra_mart.framework.base.session.SessionObjectException
            • class jp.co.intra_mart.framework.base.session.SessionPropertyException
            • class jp.co.intra_mart.framework.base.service.TransitionException
            • class jp.co.intra_mart.framework.base.util.UserInfoException
            • class jp.co.intra_mart.framework.base.service.validator.ValidatorException
        • class javax.servlet.jsp.JspException
          • class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.framework.system.exception.FrameworkRuntimeException
    • class jp.co.intra_mart.framework.base.service.Transition
      • class jp.co.intra_mart.framework.base.service.DefaultTransition
      • class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition
    • class jp.co.intra_mart.framework.base.util.UserInfoUtil
    • class jp.co.intra_mart.framework.base.util.UserInfoWrapper (implements jp.co.intra_mart.framework.base.util.UserInfo)
    • class jp.co.intra_mart.framework.base.service.validator.ValidationExceptionDetail
    • class jp.co.intra_mart.framework.base.service.ValidatorMapping
    • class jp.co.intra_mart.framework.base.service.ValidatorModel
    • class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class jp.co.intra_mart.framework.util.XMLDocumentProducer
    • class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler (implements jp.co.intra_mart.framework.system.log.LogPropertyHandler)
    • class jp.co.intra_mart.framework.util.XMLNode
    • class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler (implements jp.co.intra_mart.framework.base.session.SessionPropertyHandler)

インタフェース階層

  • interface jp.co.intra_mart.framework.base.service.controller.ControllerConverter
  • interface jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfig
  • interface jp.co.intra_mart.framework.base.data.DAO
  • interface javax.ejb.EJBLocalHome
    • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocalHome
  • interface javax.ejb.EJBLocalObject
    • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocal
  • interface jp.co.intra_mart.framework.base.event.EventListener
  • interface jp.co.intra_mart.framework.base.event.EventListenerFactory
  • interface jp.co.intra_mart.framework.base.event.EventTrigger
  • interface jp.co.intra_mart.framework.system.container.IMContainer
    • interface jp.co.intra_mart.framework.base.data.container.DataContainer
    • interface jp.co.intra_mart.framework.base.event.container.EventContainer
    • interface jp.co.intra_mart.framework.base.service.container.ServiceContainer
  • interface jp.co.intra_mart.framework.system.container.factory.IMContainerFactory
  • interface jp.co.intra_mart.framework.system.log.LogAgent
  • interface jp.co.intra_mart.framework.system.log.LogConstant
  • interface jp.co.intra_mart.framework.base.web.tag.ParameterSendable
  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.base.data.DataPropertyHandler
    • interface jp.co.intra_mart.framework.base.event.EventPropertyHandler
    • interface jp.co.intra_mart.framework.system.log.LogPropertyHandler
    • interface jp.co.intra_mart.framework.base.message.MessagePropertyHandler
    • interface jp.co.intra_mart.framework.system.message.MessagePropertyHandler
    • interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler
    • interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler
  • interface jp.co.intra_mart.framework.system.container.factory.Provider
  • interface java.rmi.Remote
    • interface javax.ejb.EJBHome
      • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome
      • interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome
    • interface javax.ejb.EJBObject
      • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent
      • interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent
    • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent
    • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome
    • interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent
    • interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome
  • interface jp.co.intra_mart.framework.base.service.RequestInfo
  • interface java.io.Serializable
    • interface jp.co.intra_mart.framework.base.service.controller.ControllerObject
    • interface jp.co.intra_mart.framework.base.event.EventResult
    • interface jp.co.intra_mart.framework.base.util.UserInfo
  • interface jp.co.intra_mart.framework.base.service.ServiceController
  • interface jp.co.intra_mart.framework.base.service.ServiceResult
  • interface jp.co.intra_mart.framework.base.session.SessionFactory
  • interface jp.co.intra_mart.framework.base.session.SessionObject
  • interface jp.co.intra_mart.framework.base.service.validator.Validator
  • interface jp.co.intra_mart.framework.base.service.validator.ValidatorConfig
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


(j2ee_framework 6.1.14 API)

フロントページが変更されました。次を参照してください:
フレームありのバージョン
フレームなしのバージョン


直列化された形式 (j2ee_framework 6.1.14 API)

前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.framework.base.data

クラス jp.co.intra_mart.framework.base.data.DAOException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.data.DataAccessException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.data.DataConnectException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.data.DataConnectorException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.data.DataManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.data.DataPropertyException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.data.container

クラス jp.co.intra_mart.framework.base.data.container.DataContainerException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.event.container

クラス jp.co.intra_mart.framework.base.event.container.EventContainerException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.event

クラス jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sessionContext

SessionContext sessionContext
セッションコンテキスト

クラス jp.co.intra_mart.framework.base.event.EmptyEvent は Event を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.Event は Object を拡張し、Serializable を実装しています

直列化されたフィールド

application

String application
アプリケーション

key

String key
イベントキー

loginUserID

String loginUserID
ログインユーザ

loginGroupID

String loginGroupID
ログイングループ

info

UserInfo info
ユーザ情報

クラス jp.co.intra_mart.framework.base.event.EventException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.EventListenerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.EventManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.EventPropertyException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.EventTriggerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean は EJBEventListenerAgentBean を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean は EJBEventListenerAgentBean を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.message

クラス jp.co.intra_mart.framework.base.message.MessageManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.message.MessagePropertyException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.service

クラス jp.co.intra_mart.framework.base.service.IntramartConnectServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

serviceManager

ServiceManager serviceManager
推奨されていません。
サービスマネージャ

serviceHandler

ServicePropertyHandler serviceHandler
推奨されていません。
サービスプロパティハンドラ

sessionManager

SessionManager sessionManager
推奨されていません。
セッションマネージャ

sessionHandler

SessionPropertyHandler sessionHandler
推奨されていません。
セッションプロパティハンドラ

referrerFormatShort

boolean referrerFormatShort
推奨されていません。
referrerのフォーマット

導入されたバージョン:
4.1.5

クラス jp.co.intra_mart.framework.base.service.RequestException は ApplicationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.service.ServiceControllerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.service.ServiceManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.service.ServicePropertyException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.service.ServiceServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

manager

ServiceManager manager
サービスマネージャ

handler

ServicePropertyHandler handler
サービスプロパティハンドラ

クラス jp.co.intra_mart.framework.base.service.ServiceServletException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.service.TransitionException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.service.container

クラス jp.co.intra_mart.framework.base.service.container.ServiceContainerException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.service.controller

クラス jp.co.intra_mart.framework.base.service.controller.ControllerConverterException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.service.controller.RequestFormatException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.service.validator

クラス jp.co.intra_mart.framework.base.service.validator.ValidationException は RequestException を拡張し、Serializable を実装しています

直列化されたフィールド

validationExceptionDetails

Collection validationExceptionDetails
検証例外の詳細

クラス jp.co.intra_mart.framework.base.service.validator.ValidatorException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.session

クラス jp.co.intra_mart.framework.base.session.IllegalSessionException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.session.SessionFactoryException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.session.SessionManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.session.SessionObjectException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.session.SessionPropertyException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.util

クラス jp.co.intra_mart.framework.base.util.ConfigurationUserInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

clientType

String clientType

colorPatternID

String colorPatternID

encoding

String encoding

language

String language

country

String country

variant

String variant

loginGroupID

String loginGroupID

loginTime

Date loginTime

loginType

String loginType

userID

String userID

クラス jp.co.intra_mart.framework.base.util.EmptyUserInfo は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.util.UserInfoException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.util.UserInfoWrapper は Object を拡張し、Serializable を実装しています

直列化されたフィールド

userInfo

UserInfo userInfo

パッケージ jp.co.intra_mart.framework.base.web.bean

クラス jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean は HelperBean を拡張し、Serializable を実装しています

直列化されたフィールド

exception

Throwable exception
例外

クラス jp.co.intra_mart.framework.base.web.bean.HelperBean は Object を拡張し、Serializable を実装しています

直列化されたフィールド

eventManager

EventManager eventManager
イベントマネージャ

serviceHandler

ServicePropertyHandler serviceHandler
サービスプロパティハンドラ

sessionHandler

SessionPropertyHandler sessionHandler
セッションプロパティハンドラ

request

HttpServletRequest request
リクエスト

response

HttpServletResponse response
レスポンス

userInfo

UserInfo userInfo
ユーザ情報

クラス jp.co.intra_mart.framework.base.web.bean.HelperBeanException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.web.tag

クラス jp.co.intra_mart.framework.base.web.tag.FormTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

sessionManager

SessionManager sessionManager
セッションマネージャ

sessionHandler

SessionPropertyHandler sessionHandler
セッションプロパティハンドラ

serviceManager

ServiceManager serviceManager
サービスマネージャ

serviceHandler

ServicePropertyHandler serviceHandler
サービスプロパティハンドラ

coreAttrs

CoreAttributes coreAttrs
コア属性

i18n

I18nAttributes i18n
国際化属性

events

EventsAttributes events
イベント属性

application

String application
アプリケーション

service

String service
サービス

method

String method
method

enctype

String enctype
enctype

accept

String accept
accept

name

String name
name

onSubmit

String onSubmit
onSubmit

onReset

String onReset
onReset

acceptCharset

String acceptCharset
accept-charset

target

String target
target

クラス jp.co.intra_mart.framework.base.web.tag.FrameTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

sessionManager

SessionManager sessionManager
セッションマネージャ

sessionHandler

SessionPropertyHandler sessionHandler
セッションプロパティハンドラ

serviceManager

ServiceManager serviceManager
サービスマネージャ

serviceHandler

ServicePropertyHandler serviceHandler
サービスプロパティハンドラ

coreAttrs

CoreAttributes coreAttrs
コア属性

params

Collection params
パラメータの集合

application

String application
アプリケーション

service

String service
サービス

longdesc

String longdesc
longdesc

name

String name
name

frameborder

String frameborder
frameborder

marginwidth

String marginwidth
marginwidth

marginheight

String marginheight
marginheight

noresize

String noresize
noresize

scrolling

String scrolling
scrolling

クラス jp.co.intra_mart.framework.base.web.tag.FrameworkTagException は JspException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.web.tag.HelperBeanTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

helperclass

String helperclass
クラス名

クラス jp.co.intra_mart.framework.base.web.tag.LinkTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

sessionManager

SessionManager sessionManager
セッションマネージャ

sessionHandler

SessionPropertyHandler sessionHandler
セッションプロパティハンドラ

serviceManager

ServiceManager serviceManager
サービスマネージャ

serviceHandler

ServicePropertyHandler serviceHandler
サービスプロパティハンドラ

coreAttrs

CoreAttributes coreAttrs
コア属性

i18n

I18nAttributes i18n
国際化属性

events

EventsAttributes events
イベント属性

params

Collection params
パラメータの集合

application

String application
アプリケーション

service

String service
サービス

charset

String charset
charset

type

String type
type

name

String name
name

hreflang

String hreflang
hreflang

rel

String rel
rel

rev

String rev
rev

accesskey

String accesskey
accesskey

shape

String shape
shape

coords

String coords
coords

target

String target
target

導入されたバージョン:
3.2

tabindex

String tabindex
tabindex

onfocus

String onfocus
onfocus

onblur

String onblur
onblur

クラス jp.co.intra_mart.framework.base.web.tag.MessageParamTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

value

Object value
パラメータの値

クラス jp.co.intra_mart.framework.base.web.tag.MessageTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

messageManager

MessageManager messageManager
MessageManager

serviceManager

ServiceManager serviceManager
ServiceManager

params

Vector params
パラメータの集合

application

String application
アプリケーション

key

String key
キー

locale

String locale
ロケール

クラス jp.co.intra_mart.framework.base.web.tag.ParamTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
パラメータ名

value

String value
パラメータの値

クラス jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

serviceHandler

ServicePropertyHandler serviceHandler
サービスプロパティハンドラ

coreAttrs

CoreAttributes coreAttrs
コア属性

i18n

I18nAttributes i18n
国際化属性

events

jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag.SubmitLinkEventsAttributes events
イベント属性

application

String application
アプリケーション

service

String service
サービス

form

String form
フォーム名

name

String name
name

accesskey

String accesskey
accesskey

shape

String shape
shape

coords

String coords
coords

tabindex

String tabindex
tabindex

onfocus

String onfocus
onfocus

onblur

String onblur
onblur

serviceManager

ServiceManager serviceManager
サービスマネージャ

導入されたバージョン:
4.3

sessionManager

SessionManager sessionManager
セッションマネージャ

導入されたバージョン:
4.3

クラス jp.co.intra_mart.framework.base.web.tag.SubmitTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

serviceHandler

ServicePropertyHandler serviceHandler
サービスプロパティハンドラ

coreAttrs

CoreAttributes coreAttrs
コア属性

i18n

I18nAttributes i18n
国際化属性

events

jp.co.intra_mart.framework.base.web.tag.SubmitTag.SubmitEventsAttributes events
イベント属性

application

String application
アプリケーション

service

String service
サービス

name

String name
name

value

String value
value

tabindex

String tabindex
tabindex

onFocus

String onFocus
onFocus

onBlur

String onBlur
onBlur

serviceManager

ServiceManager serviceManager
サービスマネージャ

導入されたバージョン:
4.3

sessionManager

SessionManager sessionManager
セッションマネージャ

導入されたバージョン:
4.3

sessionHandler

SessionPropertyHandler sessionHandler
セッションプロパティハンドラ

導入されたバージョン:
4.3

パッケージ jp.co.intra_mart.framework.system.exception

クラス jp.co.intra_mart.framework.system.exception.ApplicationException は FrameworkException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.system.exception.FrameworkException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.system.exception.FrameworkRuntimeException は RuntimeException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.system.exception.IllegalSystemException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.system.exception.IMContainerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.system.exception.SystemException は FrameworkException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.system.log

クラス jp.co.intra_mart.framework.system.log.LogPropertyException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.system.message

クラス jp.co.intra_mart.framework.system.message.MessageManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.system.message.MessagePropertyException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.system.property

クラス jp.co.intra_mart.framework.system.property.PropertyHandlerException は FrameworkException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.system.property.PropertyManagerException は FrameworkException を拡張し、Serializable を実装しています

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


 CurlFieldBean オブジェクト

CurlFieldBeanオブジェクト。
CurlのRecordFieldクラスの属性情報を格納するオブジェクトです。
設定できる属性情報は以下の通りです。なお、各項目の詳細はCurlのドキュメントを参照してください。

CurlFieldBeanオブジェクト
name [必須] 名前 (String)
caption − キャプション (String)
domain − ドメイン (String)
modifiable − 編集可否フラグ (String)
nullable − Null許容可否フラグ (String)
default-value − デフォルト値 (String)
index-type − インデックスタイプ (String)
required − 明示的設定の可否フラグ (String)
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
CurlFieldBean ()
コンストラクタ。
メソッドの概要
String | getCaption () キャプションを取得します。
String | getDefault_value () デフォルト値を取得します。
String | getDomain () ドメインを取得します。
String | getIndex_type () インデックスタイプを取得します。
String | getModifiable () 編集可能フラグを取得します。
String | getName () 名前を取得します。
String | getNullable () Null許容フラグを取得します。
String | getRequired () 必須フラグを取得します。
void | setCaption (String value) キャプションを設定します。
void | setDefault_value (String value) デフォルト値を設定します。
void | setDomain (String value) ドメインを設定します。
void | setIndex_type (String value) インデックスタイプを設定します。
void | setModifiable (String value) 編集可能フラグを設定します。
void | setName (String value) 名前を設定します。
void | setNullable (String value) Null許容フラグを設定します。
void | setRequired (String value) 必須フラグを設定します。
コンストラクタの詳細
CurlFieldBean

CurlFieldBean ()
コンストラクタ。

CurlFieldBeanオブジェクトを生成します。

メソッドの詳細
getCaption

String getCaption ()

キャプションを取得します。

返却値
String キャプション
getDefault_value

String getDefault_value ()

デフォルト値を取得します。

返却値
String デフォルト値
getDomain

String getDomain ()

ドメインを取得します。

返却値
String ドメイン
getIndex_type

String getIndex_type ()

インデックスタイプを取得します。

返却値
String インデックスタイプ
getModifiable

String getModifiable ()

編集可能フラグを取得します。

返却値
String 編集可能フラグ(true/false)
getName

String getName ()

名前を取得します。

返却値
String 名前
getNullable

String getNullable ()

Null許容フラグを取得します。

返却値
String Null許容フラグ(true/false)
getRequired

String getRequired ()

必須フラグを取得します。

返却値
String 必須フラグ(true/false)
setCaption

void setCaption (String value)

キャプションを設定します。

パラメータ
value String キャプション
返却値
void
setDefault_value

void setDefault_value (String value)

デフォルト値を設定します。

パラメータ
value String デフォルト値
返却値
void
setDomain

void setDomain (String value)

ドメインを設定します。

パラメータ
value String ドメイン
返却値
void
setIndex_type

void setIndex_type (String value)

インデックスタイプを設定します。

パラメータ
value String インデックスタイプ
返却値
void
setModifiable

void setModifiable (String value)

編集可能フラグを設定します。

パラメータ
value String 編集可能フラグ(true/false)
返却値
void
setName

void setName (String value)

名前を設定します。

パラメータ
value String 名前
返却値
void
setNullable

void setNullable (String value)

Null許容フラグを設定します。

パラメータ
value String Null許容フラグ(true/false)
返却値
void
setRequired

void setRequired (String value)

必須フラグを設定します。

パラメータ
value String 必須フラグ(true/false)
返却値
void


 CurlXMLComposer オブジェクト

CurlXMLComposerオブジェクト。
Curlのelaborate-recordsetで解釈可能なXMLを生成するオブジェクトです。
このオブジェクトに対して、CurlFieldBeanオブジェクトとそれに対応するレコード情報を セットしたオブジェクトをセットすることでCurlのRecordSetに変換可能なXMLデータを 生成します。

CurlFieldBeanオブジェクトとレコード情報をセットしたオブジェクトを結びつけるためには、 CurlFieldBeanオブジェクトのsetName()で指定した文字列をオブジェクトのプロパティ名に 指定する必要があります。
 var curlFieldBean = new CurlFieldBean();
 curlFieldBean.setName("fieldName");
 ...
 var record = new Object();
 record.fieldName = "value";
 ...
 var curlXMLComposer = new CurlXMLComposer();
 curlXMLComposer.addField(curlFieldBean);
 curlXMLComposer.addRecord(record);

 xmlString = curlXMLComposer.toXML();
この実行結果(xmlString)の内容は次のようになります。
 <RecordSet>
 <Fields>
 <Field name="fieldName" ...>
 </Fields>
 <Record fieldName="value">
 </RecordSet>
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
CurlXMLComposer ()
コンストラクタ。
メソッドの概要
void | addField (Object obj) CurlFieldBeanをパラメータとして指定した場合、 フィールド一覧リストにフィールドとして追加します。
void | addRecord (Object obj) レコード一覧リストにレコードを追加します。
void | setFieldList (Object obj) フィールド一覧リストをセットします。
String | toXML () 指定されたフィールド定義、レコードからCurlで入力可能なXML(elaborate-xmlで 入力可能)を生成します。
コンストラクタの詳細
CurlXMLComposer

CurlXMLComposer ()
コンストラクタ。

CurlXMLComposerオブジェクトを生成します。
メソッドの詳細
addField

void addField (Object obj)

CurlFieldBeanをパラメータとして指定した場合、 フィールド一覧リストにフィールドとして追加します。
パラメータ
obj Object CurlFieldBeanObject
返却値
void
addRecord

void addRecord (Object obj)

レコード一覧リストにレコードを追加します。
パラメータ
obj Object レコード
返却値
void
setFieldList

void setFieldList (Object obj)

フィールド一覧リストをセットします。
主にCurlXMLParser.getFieldsList()の結果を使用したい場合に使用します。
パラメータ
obj Object フィールド一覧リスト
返却値
void
toXML

String toXML ()

指定されたフィールド定義、レコードからCurlで入力可能なXML(elaborate-xmlで 入力可能)を生成します。
通常、このメソッドの結果をHTMLへ引き渡し、Curlアプレットへの入力とします。
返却値
String Curlのelaborate-xmlで解釈可能なXML


 CurlXMLParser オブジェクト

CurlXMLParserオブジェクト。
Curlで出力されたXML(recordset-to-xmlでの出力)を解釈し、CurlFieldBeanおよびレコード情報を 含むオブジェクトを生成します。
Curlアプレットから送信されたRecordSetの情報を取得するには、このオブジェクトの生成時に パラメータとして送信された文字列を与え、生成されたオブジェクトからgetRecordList()、 getFieldList()を呼び出します。
それぞれのメソッドの返り値はObject、CurlFieldBeanが格納されたArrayとなっています。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
CurlXMLParser (String xml)
コンストラクタ。
メソッドの概要
Array | getFieldList () パースした結果のフィールド一覧リストを返します。
Array | getRecordList () パースした結果のレコード一覧リストを返します。
コンストラクタの詳細
CurlXMLParser

CurlXMLParser (String xml)
コンストラクタ。

RecordSetから変換されたXMLを解釈した結果を持つオブジェクトを生成します。
生成に失敗した場合は、nullを返却します。
パラメータ
xml String RecordSetを変換したXML
メソッドの詳細
getFieldList

Array getFieldList ()

パースした結果のフィールド一覧リストを返します。
返却値
Array CurlFieldBeanの配列
getRecordList

Array getRecordList ()

パースした結果のレコード一覧リストを返します。

次のようなXMLをコンストラクタのパラメータに指定した場合
 <RecordSet>
 <Fields>
 <Field name="fieldName" ...>
 </Fields>
 <Record fieldName="value">
 </RecordSet>

getRecordListの結果、および内容は次のようになります。
 var curlXMLParser = new CurlXMLParser(xmlString);
 var recordList = curlXMLParser.getRecordList();

 var record = recordList[0];
 var value = record.fieldName; // valueの内容は"value"
 var length = record.length;  // length(配列の要素数)は1
返却値
Array Objectの配列


JavaScript API リスト概要

 JavaScript API リスト 概要

スクリプト開発モデルで利用可能なJavaScript API の概要です。

オブジェクトの概要
CurlFieldBean | CurlFieldBeanオブジェクト。
CurlXMLComposer | CurlXMLComposerオブジェクト。
CurlXMLParser | CurlXMLParserオブジェクト。


JavaScript API リスト

 オブジェクト
CurlFieldBean
CurlXMLComposer
CurlXMLParser


JavaScript API リスト概要

 JavaScript API リスト 概要

スクリプト開発モデルで利用可能なJavaScript API の概要です。

オブジェクトの概要
MKError | マスカットへ送信するエラー要素です。
MKErrors | マスカットへ送信するエラー要素群です。


JavaScript API リスト

 オブジェクト
MKError
MKErrors


 MKError オブジェクト

マスカットへ送信するエラー要素です。
導入されたバージョン：6.1
コンストラクタの概要
MKError ()
コンストラクタ
メソッドの概要
void | setErrorCode (String errorCode) errorCodeを設定します。
void | setInfo (String info) infoを設定します。
void | setMessage (String message) messageを設定します。
void | setMessageCode (String messageCode) messageCodeを設定します。
void | setSystemErrorMessage (String systemErrorMessage) systemErrorMessageを設定します。
コンストラクタの詳細
MKError

MKError ()
コンストラクタ
メソッドの詳細
setErrorCode

void setErrorCode (String errorCode)

errorCodeを設定します。
パラメータ
errorCode String クライアントに送信するerrorCode
返却値
void
setInfo

void setInfo (String info)

infoを設定します。
パラメータ
info String クライアントに送信するinfo
返却値
void
setMessage

void setMessage (String message)

messageを設定します。
パラメータ
message String クライアントに送信するmessage
返却値
void
setMessageCode

void setMessageCode (String messageCode)

messageCodeを設定します。
パラメータ
messageCode String クライアントに送信するmessageCode
返却値
void
setSystemErrorMessage

void setSystemErrorMessage (String systemErrorMessage)

systemErrorMessageを設定します。
パラメータ
systemErrorMessage String クライアントに送信するsystemErrorMessage
返却値
void


 MKErrors オブジェクト

マスカットへ送信するエラー要素群です。
MKErrorsはマスカットが認識するエラー電文を構築します。

通常マスカットは以下の電文をエラーとして認識します。

 <?xml version="1.0" encoding="UTF-8"?>
 <errors>
   <error>
     <errorCode>・・・</errorCode>
     <messageCode>・・・</messageCode>
     <message>・・・</message>
     <info>・・・</info>
     <systemErrorMessage>・・・</systemErrorMessage>
   </error>
 </errors>

MKErrorsはthrowされることで、設定されたエラー情報をマスカットに送信します。
 function onclick(xmlString) {

   ・・・

   var error = new MKError();
   error.setErrorCode("・・・");

   var errors = new MKErrors();
   errors.addError(error);
   throw errors;

   ・・・
 }
導入されたバージョン：6.1
コンストラクタの概要
MKErrors ()
コンストラクタ
メソッドの概要
void | addError (MKError error) errorを追加します。
Number | size () error要素の個数を取得します。
コンストラクタの詳細
MKErrors

MKErrors ()
コンストラクタ
メソッドの詳細
addError

void addError (MKError error)

errorを追加します。
パラメータ
error MKError MKErrorのインスタンス
返却値
void
size

Number size ()

error要素の個数を取得します。
返却値
Number error要素の個数


 AccEmployeePayPostController オブジェクト

伝票登録コントローラクラス。

会計伝票を登録します。
バージョン：1.1
導入されたバージョン：5.0
コンストラクタの概要
AccEmployeePayPostController ()
コンストラクタ。
AccEmployeePayPostController (ConnectionManager connectionManager)
コンストラクタ。
AccEmployeePayPostController (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより会計伝票を登録します。
Object | getAccountGlList () G/L 勘定明細一覧を取得します｡
Object | getAccountPayableList () 仕入先明細一覧を取得します｡
Object | getAccountTaxList () 税明細一覧を取得します｡
String | getBapiReturnErrMessage () ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage () プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。
Object | getCurrencyAmountList () 明細通貨項目一覧を取得します｡
Object | getExtension1List () カスタマ拡張テーブル一覧を取得します｡
Object | getObjKey () 参照キーを取得します｡
Object | getObjSys () 参照システムを取得します｡
Object | getObjType () 参照処理を取得します｡
Object | getTravelAmountList () 旅費資金計画通貨項目一覧を取得します｡
Object | getTravelList () 旅費資金予算明細一覧を取得します｡
void | setCuAmtBase (String value ,Number recNo) 明細通貨項目の課税基準額に値を設定します。
void | setCuAmtDoccur (String value ,Number recNo) 明細通貨項目の伝票通貨額に値を設定します。
void | setCuCurrency (String value ,Number recNo) 明細通貨項目の通貨コードに値を設定します。
void | setCuItemnoAcc (String value ,Number recNo) 明細通貨項目の会計伝票明細番号に値を設定します。
void | setDocAcDocNo (String value) 伝票ヘッダの会計伝票番号に値を設定します。
void | setDocCompCode (String value) 伝票ヘッダの会社コードに値を設定します。
void | setDocDocDate (String value) 伝票ヘッダの伝票の伝票日付に値を設定します。
void | setDocDocType (String value) 伝票ヘッダの伝票タイプに値を設定します。
void | setDocFisPeriod (String value) 伝票ヘッダの会計期間に値を設定します。
void | setDocFiscYear (String value) 伝票ヘッダの会計年度に値を設定します。
void | setDocHeaderTxt (String value) 伝票ヘッダの伝票ヘッダテキストに値を設定します。
void | setDocObjKey (String value) 伝票ヘッダのオブジェクトキーに値を設定します。
void | setDocObjType (String value) 伝票ヘッダの参照処理に値を設定します。
void | setDocPstngDate (String value) 伝票ヘッダの伝票の転記日付に値を設定します。
void | setDocRefDocNo (String value) 伝票ヘッダの参照伝票番号に値を設定します。
void | setDocUsername (String value) 伝票ヘッダのユーザ名に値を設定します。
void | setGlAllocNmbr (String value ,Number recNo) G/L 勘定明細のソートキーに値を設定します。
void | setGlBusArea (String value ,Number recNo) G/L 勘定明細の事業領域に値を設定します。
void | setGlCompCode (String value ,Number recNo) G/L 勘定明細の会社コードに値を設定します。
void | setGlCostcenter (String value ,Number recNo) G/L 勘定明細の原価センタに値を設定します。
void | setGlDocType (String value ,Number recNo) G/L 勘定明細の伝票タイプに値を設定します。
void | setGlFiscYear (String value ,Number recNo) G/L 勘定明細の会計年度に値を設定します。
void | setGlGlAccount (String value ,Number recNo) G/L 勘定明細の総勘定元帳勘定に値を設定します。
void | setGlItemText (String value ,Number recNo) G/L 勘定明細の明細テキストに値を設定します。
void | setGlItemnoAcc (String value ,Number recNo) G/L 勘定明細の会計伝票明細番号に値を設定します。
void | setGlOrderid (String value ,Number recNo) G/L 勘定明細の指図番号に値を設定します。
void | setGlPstngDate (String value ,Number recNo) G/L 勘定明細の伝票の転記日付に値を設定します。
void | setGlRefKey1 (String value ,Number recNo) G/L 勘定明細の取引先参照キーに値を設定します。
void | setGlTaxCode (String value ,Number recNo) G/L 勘定明細の消費税コードに値を設定します。
void | setGlWbsElement (String value ,Number recNo) G/L 勘定明細のWBS 要素に値を設定します。
void | setPaAllocNmbr (String value ,Number recNo) 仕入先明細のソートキーに値を設定します。
void | setPaBlineDate (String value ,Number recNo) 仕入先明細の期日計算の支払基準日に値を設定します。
void | setPaGlAccount (String value ,Number recNo) 仕入先明細の総勘定元帳勘定に値を設定します。
void | setPaItemText (String value ,Number recNo) 仕入先明細の明細テキストに値を設定します。
void | setPaItemnoAcc (String value ,Number recNo) 仕入先明細の会計伝票明細番号に値を設定します。
void | setPaPymtMeth (String value ,Number recNo) 仕入先明細の支払方法に値を設定します。
void | setPaVendorNo (String value ,Number recNo) 仕入先明細の仕入先または債権者の勘定コードに値を設定します。
void | setStrParam (String paramStr ,String paramName ,String value) 構造型の項目に値をセットします。
void | setTaGlAccount (String value ,Number recNo) 税明細の総勘定元帳勘定に値を設定します。
void | setTaItemnoAcc (String value ,Number recNo) 税明細の会計伝票明細番号に値を設定します。
void | setTaTaxCode (String value ,Number recNo) 税明細の消費税コードに値を設定します。
void | setTblParam (String paramTable ,String paramName ,String value ,int index) テーブル型の項目に値をセットします。
コンストラクタの詳細
AccEmployeePayPostController

AccEmployeePayPostController ()
コンストラクタ。

AccEmployeePayPostController

AccEmployeePayPostController (ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、AccEmployeePayPostController#executeBapi()実行後に 必ずConnectionManager#commit()またはConnectionManager#rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。
パラメータ
connectionManager ConnectionManager コネクションマネージャー
AccEmployeePayPostController

AccEmployeePayPostController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより会計伝票を登録します。

返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getAccountGlList

Object getAccountGlList ()

G/L 勘定明細一覧を取得します｡
返却値
Object G/L 勘定明細一覧

G/L 勘定明細情報オブジェクトの構成は以下のとおりです。
G/L 勘定明細情報
オブジェクト
(Object)
ITEMNO_ACC 会計伝票明細番号 (String)
GL_ACCOUNT 総勘定元帳勘定 (String)
COMP_CODE 会社コード (String)
PSTNG_DATE 伝票の転記日付 (String)
DOC_TYPE 伝票タイプ (String)
AC_DOC_NO 会計伝票番号 (String)
FISC_YEAR 会計年度 (String)
FIS_PERIOD 会計期間 (String)
STLMNT_PER 決済期間 (String)
REF_KEY_1 取引先参照キー (String)
REF_KEY_2 取引先参照キー (String)
REF_KEY_3 明細の参照キー (String)
ITEM_TEXT 明細テキスト (String)
TAX_CODE 売上税コード (String)
ACCT_KEY 内部処理キー (String)
TAXJURCODE 税管轄 (String)
ALLOC_NMBR ソートキー (String)
BUS_AREA 事業領域 (String)
PERSON_NO 従業員番号 (String)
COSTCENTER 原価センタ (String)
ORDERID 指図番号 (String)
COST_OBJ 原価対象 (String)
ACTIVITY 作業/活動番号 (String)
QUANTITY 数量 (String)
BASE_UOM 基本数量単位 (String)
BASE_UOM_ISO ISO コードでの基本数量単位 (String)
WBS_ELEMENT WBS 要素 (String)
NETWORK 勘定割当のネットワーク番号 (String)
CMMT_ITEM 予算コード (String)
FUNDS_CTR 予算センタ (String)
FUND ファンド (String)
SALES_ORD 受注伝票番号 (String)
S_ORD_ITEM 受注明細番号 (String)
ACTTYPE 活動タイプ (String)
OBJ_TYP_P 前伝票: 参照処理 (String)
OBJ_KEY_P 前伝票: オブジェクトキー (AWREF_REV と AWORG_REV) (String)
OBJ_POS_P 前伝票: 参照明細 (String)
TRADE_ID 取引先の会社 ID (String)
CMMT_ITEM_LONG 予算コード (String)
GRANT_NBR 補助金 (String)
FUNC_AREA_LONG 機能領域 (String)
PROFIT_CTR 利益センタ (String)
PART_PRCTR パートナ利益センタ (String)
SEGMENT セグメントレポートのセグメント (String)
PARTNER_SEGMENT セグメントレポートのパートナセグメント (String)
PARTNER_FUND パートナファンド (String)
PARTNER_GRANT_NBR パートナ補助金 (String)
TR_PART_BA 取引先事業領域 (String)
NEG_POSTNG フラグ: マイナス転記 (String)

取得したG/L 勘定明細情報オブジェクトの配列は、２次元配列になっています。
値を取得する際に指定する配列のキー値は以下の通りです。

[idx]["ITEMNO_ACC"]　→　配列内のidx番目のG/L 勘定明細の「会計伝票明細番号」
[idx]["GL_ACCOUNT"]　→　配列内のidx番目のG/L 勘定明細の「総勘定元帳勘定」
[idx]["COMP_CODE"]　→　配列内のidx番目のG/L 勘定明細の「会社コード」
[idx]["PSTNG_DATE"]　→　配列内のidx番目のG/L 勘定明細の「伝票の転記日付」
[idx]["DOC_TYPE"]　→　配列内のidx番目のG/L 勘定明細の「伝票タイプ」
[idx]["AC_DOC_NO"]　→　配列内のidx番目のG/L 勘定明細の「会計伝票番号」
[idx]["FISC_YEAR"]　→　配列内のidx番目のG/L 勘定明細の「会計年度」
[idx]["FIS_PERIOD"]　→　配列内のidx番目のG/L 勘定明細の「会計期間」
[idx]["STLMNT_PER"]　→　配列内のidx番目のG/L 勘定明細の「決済期間」
[idx]["REF_KEY_1"]　→　配列内のidx番目のG/L 勘定明細の「取引先参照キー」
[idx]["REF_KEY_2"]　→　配列内のidx番目のG/L 勘定明細の「取引先参照キー」
[idx]["REF_KEY_3"]　→　配列内のidx番目のG/L 勘定明細の「明細の参照キー」
[idx]["ITEM_TEXT"]　→　配列内のidx番目のG/L 勘定明細の「明細テキスト」
[idx]["TAX_CODE"]　→　配列内のidx番目のG/L 勘定明細の「売上税コード」
[idx]["ACCT_KEY"]　→　配列内のidx番目のG/L 勘定明細の「内部処理キー」
[idx]["TAXJURCODE"]　→　配列内のidx番目のG/L 勘定明細の「税管轄」
[idx]["ALLOC_NMBR"]　→　配列内のidx番目のG/L 勘定明細の「ソートキー」
[idx]["BUS_AREA"]　→　配列内のidx番目のG/L 勘定明細の「事業領域」
[idx]["PERSON_NO"]　→　配列内のidx番目のG/L 勘定明細の「従業員番号」
[idx]["COSTCENTER"]　→　配列内のidx番目のG/L 勘定明細の「原価センタ」
[idx]["ORDERID"]　→　配列内のidx番目のG/L 勘定明細の「指図番号」
[idx]["COST_OBJ"]　→　配列内のidx番目のG/L 勘定明細の「原価対象」
[idx]["ACTIVITY"]　→　配列内のidx番目のG/L 勘定明細の「作業/活動番号」
[idx]["QUANTITY"]　→　配列内のidx番目のG/L 勘定明細の「数量」
[idx]["BASE_UOM"]　→　配列内のidx番目のG/L 勘定明細の「基本数量単位」
[idx]["BASE_UOM_ISO"]　→　配列内のidx番目のG/L 勘定明細の「ISO コードでの基本数量単位」
[idx]["WBS_ELEMENT"]　→　配列内のidx番目のG/L 勘定明細の「WBS 要素」
[idx]["NETWORK"]　→　配列内のidx番目のG/L 勘定明細の「勘定割当のネットワーク番号」
[idx]["CMMT_ITEM"]　→　配列内のidx番目のG/L 勘定明細の「予算コード」
[idx]["FUNDS_CTR"]　→　配列内のidx番目のG/L 勘定明細の「予算センタ」
[idx]["FUND"]　→　配列内のidx番目のG/L 勘定明細の「ファンド」
[idx]["SALES_ORD"]　→　配列内のidx番目のG/L 勘定明細の「受注伝票番号」
[idx]["S_ORD_ITEM"]　→　配列内のidx番目のG/L 勘定明細の「受注明細番号」
[idx]["ACTTYPE"]　→　配列内のidx番目のG/L 勘定明細の「活動タイプ」
[idx]["OBJ_TYP_P"]　→　配列内のidx番目のG/L 勘定明細の「前伝票: 参照処理」
[idx]["OBJ_KEY_P"]　→　配列内のidx番目のG/L 勘定明細の「前伝票: オブジェクトキー (AWREF_REV と AWORG_REV)」
[idx]["OBJ_POS_P"]　→　配列内のidx番目のG/L 勘定明細の「前伝票: 参照明細」
[idx]["TRADE_ID"]　→　配列内のidx番目のG/L 勘定明細の「取引先の会社 ID」
[idx]["CMMT_ITEM_LONG"]　→　配列内のidx番目のG/L 勘定明細の「予算コード」
[idx]["GRANT_NBR"]　→　配列内のidx番目のG/L 勘定明細の「補助金」
[idx]["FUNC_AREA_LONG"]　→　配列内のidx番目のG/L 勘定明細の「機能領域」
[idx]["PROFIT_CTR"]　→　配列内のidx番目のG/L 勘定明細の「利益センタ」
[idx]["PART_PRCTR"]　→　配列内のidx番目のG/L 勘定明細の「パートナ利益センタ」
[idx]["SEGMENT"]　→　配列内のidx番目のG/L 勘定明細の「セグメントレポートのセグメント」
[idx]["PARTNER_SEGMENT"]　→　配列内のidx番目のG/L 勘定明細の「セグメントレポートのパートナセグメント」
[idx]["PARTNER_FUND"]　→　配列内のidx番目のG/L 勘定明細の「パートナファンド」
[idx]["PARTNER_GRANT_NBR"]　→　配列内のidx番目のG/L 勘定明細の「パートナ補助金」
[idx]["TR_PART_BA"]　→　配列内のidx番目のG/L 勘定明細の「取引先事業領域」
[idx]["NEG_POSTNG"]　→　配列内のidx番目のG/L 勘定明細の「フラグ: マイナス転記」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 財務会計業務系システムエラー
8： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getAccountPayableList

Object getAccountPayableList ()

仕入先明細一覧を取得します｡
返却値
Object 仕入先明細一覧

仕入先明細情報オブジェクトの構成は以下のとおりです。
仕入先明細情報
オブジェクト
(Object)
ITEMNO_ACC 会計伝票明細番号 (String)
VENDOR_NO 仕入先または債権者の勘定コード (String)
REF_KEY_1 取引先参照キー (String)
REF_KEY_2 取引先参照キー (String)
REF_KEY_3 明細の参照キー (String)
GL_ACCOUNT 総勘定元帳勘定 (String)
BLINE_DATE 期日計算の支払基準日 (String)
PMTMTHSUPL 支払方法追加 (String)
PYMT_METH 支払方法 (String)
BLLSRV_IND サービスコード (外貨支払) (String)
ALLOC_NMBR ソートキー (String)
ITEM_TEXT 明細テキスト (String)
ACCT_KEY 内部処理キー (String)
SCBANK_IND 中央銀行コード (String)
PYMT_AMT 支払通貨額 (String)
PYMT_CUR 自動支払通貨 (String)
PYMT_CUR_ISO ISO コード通貨 (String)
PROFIT_CTR 利益センタ (String)
PART_PRCTR パートナ利益センタ (String)
SEGMENT セグメントレポートのセグメント (String)
PARTNER_SEGMENT セグメントレポートのパートナセグメント (String)
FUND ファンド (String)
PARTNER_FUND パートナファンド (String)
GRANT_NBR 補助金 (String)
PARTNER_GRANT_NBR パートナ補助金 (String)
BUS_AREA 事業領域 (String)
TR_PART_BA 取引先事業領域 (String)
NEG_POSTNG フラグ: マイナス転記 (String)

取得した仕入先明細情報オブジェクトの配列は、２次元配列になっています。
値を取得する際に指定する配列のキー値は以下の通りです。

[idx]["ITEMNO_ACC"]　→　配列内のidx番目の仕入先明細の「会計伝票明細番号」
[idx]["VENDOR_NO"]　→　配列内のidx番目の仕入先明細の「仕入先または債権者の勘定コード」
[idx]["REF_KEY_1"]　→　配列内のidx番目の仕入先明細の「取引先参照キー」
[idx]["REF_KEY_2"]　→　配列内のidx番目の仕入先明細の「取引先参照キー」
[idx]["REF_KEY_3"]　→　配列内のidx番目の仕入先明細の「明細の参照キー」
[idx]["GL_ACCOUNT"]　→　配列内のidx番目の仕入先明細の「総勘定元帳勘定」
[idx]["BLINE_DATE"]　→　配列内のidx番目の仕入先明細の「期日計算の支払基準日」
[idx]["PMTMTHSUPL"]　→　配列内のidx番目の仕入先明細の「支払方法追加」
[idx]["PYMT_METH"]　→　配列内のidx番目の仕入先明細の「支払方法」
[idx]["BLLSRV_IND"]　→　配列内のidx番目の仕入先明細の「サービスコード (外貨支払)」
[idx]["ALLOC_NMBR"]　→　配列内のidx番目の仕入先明細の「ソートキー」
[idx]["ITEM_TEXT"]　→　配列内のidx番目の仕入先明細の「明細テキスト」
[idx]["ACCT_KEY"]　→　配列内のidx番目の仕入先明細の「内部処理キー」
[idx]["SCBANK_IND"]　→　配列内のidx番目の仕入先明細の「中央銀行コード」
[idx]["PYMT_AMT"]　→　配列内のidx番目の仕入先明細の「支払通貨額」
[idx]["PYMT_CUR"]　→　配列内のidx番目の仕入先明細の「自動支払通貨」
[idx]["PYMT_CUR_ISO"]　→　配列内のidx番目の仕入先明細の「ISO コード通貨」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の仕入先明細の「利益センタ」
[idx]["PART_PRCTR"]　→　配列内のidx番目の仕入先明細の「パートナ利益センタ」
[idx]["SEGMENT"]　→　配列内のidx番目の仕入先明細の「セグメントレポートのセグメント」
[idx]["PARTNER_SEGMENT"]　→　配列内のidx番目の仕入先明細の「セグメントレポートのパートナセグメント」
[idx]["FUND"]　→　配列内のidx番目の仕入先明細の「ファンド」
[idx]["PARTNER_FUND"]　→　配列内のidx番目の仕入先明細の「パートナファンド」
[idx]["GRANT_NBR"]　→　配列内のidx番目の仕入先明細の「補助金」
[idx]["PARTNER_GRANT_NBR"]　→　配列内のidx番目の仕入先明細の「パートナ補助金」
[idx]["BUS_AREA"]　→　配列内のidx番目の仕入先明細の「事業領域」
[idx]["TR_PART_BA"]　→　配列内のidx番目の仕入先明細の「取引先事業領域」
[idx]["NEG_POSTNG"]　→　配列内のidx番目の仕入先明細の「フラグ: マイナス転記」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 財務会計業務系システムエラー
8： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getAccountTaxList

Object getAccountTaxList ()

税明細一覧を取得します｡
返却値
Object 税明細一覧

税明細情報オブジェクトの構成は以下のとおりです。
税明細情報
オブジェクト
(Object)
ITEMNO_ACC 会計伝票明細番号 (String)
GL_ACCOUNT 総勘定元帳勘定 (String)
TAX_CODE 売上税コード (String)
ACCT_KEY 内部処理キー (String)
TAXJURCODE 税管轄 (String)
COND_KEY 条件タイプ (String)
TAX_RATE 税率 (String)
TAX_DATE 税率定義の日付 (String)
STAT_CON 統計に適用する条件 (String)
TAXJURCODE_DEEP 税管轄コード - 最下位レベル税管轄 (String)
TAXJURCODE_LEVEL 税管轄コードレベル (String)
NEG_POSTNG フラグ: マイナス転記 (String)

取得した税明細情報オブジェクトの配列は、２次元配列になっています。
値を取得する際に指定する配列のキー値は以下の通りです。

[idx]["ITEMNO_ACC"]　→　配列内のidx番目の税明細の「会計伝票明細番号」
[idx]["GL_ACCOUNT"]　→　配列内のidx番目の税明細の「総勘定元帳勘定」
[idx]["TAX_CODE"]　→　配列内のidx番目の税明細の「売上税コード」
[idx]["ACCT_KEY"]　→　配列内のidx番目の税明細の「内部処理キー」
[idx]["TAXJURCODE"]　→　配列内のidx番目の税明細の「税管轄」
[idx]["COND_KEY"]　→　配列内のidx番目の税明細の「条件タイプ」
[idx]["TAX_RATE"]　→　配列内のidx番目の税明細の「税率」
[idx]["TAX_DATE"]　→　配列内のidx番目の税明細の「税率定義の日付」
[idx]["STAT_CON"]　→　配列内のidx番目の税明細の「統計に適用する条件」
[idx]["TAXJURCODE_DEEP"]　→　配列内のidx番目の税明細の「税管轄コード - 最下位レベル税管轄」
[idx]["TAXJURCODE_LEVEL"]　→　配列内のidx番目の税明細の「税管轄コードレベル」
[idx]["NEG_POSTNG"]　→　配列内のidx番目の税明細の「フラグ: マイナス転記」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 財務会計業務系システムエラー
8： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getBapiReturnErrMessage

String getBapiReturnErrMessage ()

ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡
返却値
String BAPI実行結果エラーとなった全てのメッセージ情報
getBapiReturnMessage

String getBapiReturnMessage ()

プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡
返却値
String プロパティファイルでオートコミット条件に一致したType情報のメッセージ情報
getCurrencyAmountList

Object getCurrencyAmountList ()

明細通貨項目一覧を取得します｡
返却値
Object 明細通貨項目一覧

明細通貨項目情報オブジェクトの構成は以下のとおりです。
明細通貨項目情報
オブジェクト
(Object)
ITEMNO_ACC 会計伝票明細番号 (String)
CURR_TYPE 通貨タイプおよび評価ビュー (String)
CURRENCY 通貨コード (String)
AMT_DOCCUR 伝票通貨額 (String)
EXCH_RATE 換算レート (String)
AMT_BASE 課税基準額 (伝票通貨建て) (String)
EXCH_RATE_V 間接呼び値換算レート (String)
CURRENCY_ISO ISO コード通貨 (String)

取得した明細通貨項目情報オブジェクトの配列は、２次元配列になっています。
値を取得する際に指定する配列のキー値は以下の通りです。

[idx]["ITEMNO_ACC"]　→　配列内のidx番目の明細通貨項目の「会計伝票明細番号」
[idx]["CURR_TYPE"]　→　配列内のidx番目の明細通貨項目の「通貨タイプおよび評価ビュー」
[idx]["CURRENCY"]　→　配列内のidx番目の明細通貨項目の「通貨コード」
[idx]["AMT_DOCCUR"]　→　配列内のidx番目の明細通貨項目の「伝票通貨額」
[idx]["EXCH_RATE"]　→　配列内のidx番目の明細通貨項目の「換算レート」
[idx]["AMT_BASE"]　→　配列内のidx番目の明細通貨項目の「課税基準額 (伝票通貨建て)」
[idx]["EXCH_RATE_V"]　→　配列内のidx番目の明細通貨項目の「間接呼び値換算レート」
[idx]["CURRENCY_ISO"]　→　配列内のidx番目の明細通貨項目の「ISO コード通貨」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 財務会計業務系システムエラー
8： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getExtension1List

Object getExtension1List ()

カスタマ拡張テーブル一覧を取得します｡
返却値
Object カスタマ拡張テーブル一覧

カスタマ拡張テーブル情報オブジェクトの構成は以下のとおりです。
カスタマ拡張テーブル情報
オブジェクト
(Object)
FIELD1 文字項目長 250 (String)
FIELD2 文字項目長 250 (String)
FIELD3 文字項目長 250 (String)
FIELD4 文字項目長 250 (String)

取得したカスタマ拡張テーブル情報オブジェクトの配列は、２次元配列になっています。
値を取得する際に指定する配列のキー値は以下の通りです。

[idx]["FIELD1"]　→　配列内のidx番目のカスタマ拡張テーブルの「文字項目長 250」
[idx]["FIELD2"]　→　配列内のidx番目のカスタマ拡張テーブルの「文字項目長 250」
[idx]["FIELD3"]　→　配列内のidx番目のカスタマ拡張テーブルの「文字項目長 250」
[idx]["FIELD4"]　→　配列内のidx番目のカスタマ拡張テーブルの「文字項目長 250」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 財務会計業務系システムエラー
8： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getObjKey

Object getObjKey ()

参照キーを取得します｡

返却値
Object 参照キー
getObjSys

Object getObjSys ()

参照システムを取得します｡

返却値
Object 参照システム
getObjType

Object getObjType ()

参照処理を取得します｡

返却値
Object 参照処理
getTravelAmountList

Object getTravelAmountList ()

旅費資金計画通貨項目一覧を取得します｡
返却値
Object 旅費資金計画通貨項目一覧

旅費資金計画通貨項目情報オブジェクトの構成は以下のとおりです。
旅費資金計画通貨項目情報
オブジェクト
(Object)
OBJ_TYPE 参照処理 (String)
OBJ_KEY オブジェクトキー (String)
OBJ_SYS 元伝票の論理システム (String)
OBJ_POS 参照明細 (String)
OBJ_ID 参照伝票: 現在の ID (String)
ORVALTYPE 購買発注額/受注額の金額タイプ (String)
CURR_TYPE 通貨タイプおよび評価ビュー (String)
CURRENCY 通貨コード (String)
CURRENCY_ISO ISO コード通貨 (String)
AMT_ORIGIN 元金額 (String)
AMT_OPEN 未決済金額 (String)
AMT_ACTUAL 削減額 (String)
EXCH_RATE 換算レート (String)
EXCH_RATE_V 間接呼び値換算レート (String)

取得した旅費資金計画通貨項目情報オブジェクトの配列は、２次元配列になっています。
値を取得する際に指定する配列のキー値は以下の通りです。

[idx]["OBJ_TYPE"]　→　配列内のidx番目の旅費資金計画通貨項目の「参照処理」
[idx]["OBJ_KEY"]　→　配列内のidx番目の旅費資金計画通貨項目の「オブジェクトキー」
[idx]["OBJ_SYS"]　→　配列内のidx番目の旅費資金計画通貨項目の「元伝票の論理システム」
[idx]["OBJ_POS"]　→　配列内のidx番目の旅費資金計画通貨項目の「参照明細」
[idx]["OBJ_ID"]　→　配列内のidx番目の旅費資金計画通貨項目の「参照伝票: 現在の ID」
[idx]["ORVALTYPE"]　→　配列内のidx番目の旅費資金計画通貨項目の「購買発注額/受注額の金額タイプ」
[idx]["CURR_TYPE"]　→　配列内のidx番目の旅費資金計画通貨項目の「通貨タイプおよび評価ビュー」
[idx]["CURRENCY"]　→　配列内のidx番目の旅費資金計画通貨項目の「通貨コード」
[idx]["CURRENCY_ISO"]　→　配列内のidx番目の旅費資金計画通貨項目の「ISO コード通貨」
[idx]["AMT_ORIGIN"]　→　配列内のidx番目の旅費資金計画通貨項目の「元金額」
[idx]["AMT_OPEN"]　→　配列内のidx番目の旅費資金計画通貨項目の「未決済金額」
[idx]["AMT_ACTUAL"]　→　配列内のidx番目の旅費資金計画通貨項目の「削減額」
[idx]["EXCH_RATE"]　→　配列内のidx番目の旅費資金計画通貨項目の「換算レート」
[idx]["EXCH_RATE_V"]　→　配列内のidx番目の旅費資金計画通貨項目の「間接呼び値換算レート」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 財務会計業務系システムエラー
8： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getTravelList

Object getTravelList ()

旅費資金予算明細一覧を取得します｡
返却値
Object 旅費資金予算明細一覧

旅費資金予算明細情報オブジェクトの構成は以下のとおりです。
旅費資金予算明細情報
オブジェクト
(Object)
OBJ_TYPE 参照処理 (String)
OBJ_KEY オブジェクトキー (String)
OBJ_SYS 元伝票の論理システム (String)
OBJ_POS 参照明細 (String)
OBJ_ID 参照伝票: 現在の ID (String)
PSTNG_DATE 伝票の転記日付 (String)
COMP_CODE 会社コード (String)
GL_ACCOUNT G/L 勘定コード (String)
NETWORK 勘定割当のネットワーク番号 (String)
ORDERID 指図番号 (String)
WBS_ELEMENT WBS 要素 (String)
COSTCENTER 原価センタ (String)
SEG_TEXT セグメントテキスト (String)
DELETE_IND 資金計画削除フラグ (String)
CMMT_ITEM 予算コード (String)
FUND ファンド (String)
FUNDS_CTR 予算センタ (String)
APPROVED 出張申請または出張承認済 (区分) (String)
CMMT_ITEM_LONG 予算コード (String)
GRANT_NBR 補助金 (String)
FUNC_AREA_LONG 機能領域 (String)
FM_TRANS_DATE FM 取引日付 (String)

取得した旅費資金予算明細情報オブジェクトの配列は、２次元配列になっています。
値を取得する際に指定する配列のキー値は以下の通りです。

[idx]["OBJ_TYPE"]　→　配列内のidx番目の旅費資金予算明細の「参照処理」
[idx]["OBJ_KEY"]　→　配列内のidx番目の旅費資金予算明細の「オブジェクトキー」
[idx]["OBJ_SYS"]　→　配列内のidx番目の旅費資金予算明細の「元伝票の論理システム」
[idx]["OBJ_POS"]　→　配列内のidx番目の旅費資金予算明細の「参照明細」
[idx]["OBJ_ID"]　→　配列内のidx番目の旅費資金予算明細の「参照伝票: 現在の ID」
[idx]["PSTNG_DATE"]　→　配列内のidx番目の旅費資金予算明細の「伝票の転記日付」
[idx]["COMP_CODE"]　→　配列内のidx番目の旅費資金予算明細の「会社コード」
[idx]["GL_ACCOUNT"]　→　配列内のidx番目の旅費資金予算明細の「G/L 勘定コード」
[idx]["NETWORK"]　→　配列内のidx番目の旅費資金予算明細の「勘定割当のネットワーク番号」
[idx]["ORDERID"]　→　配列内のidx番目の旅費資金予算明細の「指図番号」
[idx]["WBS_ELEMENT"]　→　配列内のidx番目の旅費資金予算明細の「WBS 要素」
[idx]["COSTCENTER"]　→　配列内のidx番目の旅費資金予算明細の「原価センタ」
[idx]["SEG_TEXT"]　→　配列内のidx番目の旅費資金予算明細の「セグメントテキスト」
[idx]["DELETE_IND"]　→　配列内のidx番目の旅費資金予算明細の「資金計画削除フラグ」
[idx]["CMMT_ITEM"]　→　配列内のidx番目の旅費資金予算明細の「予算コード」
[idx]["FUND"]　→　配列内のidx番目の旅費資金予算明細の「ファンド」
[idx]["FUNDS_CTR"]　→　配列内のidx番目の旅費資金予算明細の「予算センタ」
[idx]["APPROVED"]　→　配列内のidx番目の旅費資金予算明細の「出張申請または出張承認済 (区分)」
[idx]["CMMT_ITEM_LONG"]　→　配列内のidx番目の旅費資金予算明細の「予算コード」
[idx]["GRANT_NBR"]　→　配列内のidx番目の旅費資金予算明細の「補助金」
[idx]["FUNC_AREA_LONG"]　→　配列内のidx番目の旅費資金予算明細の「機能領域」
[idx]["FM_TRANS_DATE"]　→　配列内のidx番目の旅費資金予算明細の「FM 取引日付」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 財務会計業務系システムエラー
8： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

setCuAmtBase

void setCuAmtBase (String value ,Number recNo)

明細通貨項目の課税基準額に値を設定します。

パラメータ
value | String | 課税基準額
recNo | Number | レコード番号
返却値
void
setCuAmtDoccur

void setCuAmtDoccur (String value ,Number recNo)

明細通貨項目の伝票通貨額に値を設定します。

パラメータ
value | String | 伝票通貨額
recNo | Number | レコード番号
返却値
void
setCuCurrency

void setCuCurrency (String value ,Number recNo)

明細通貨項目の通貨コードに値を設定します。

パラメータ
value | String | 通貨コード
recNo | Number | レコード番号
返却値
void
setCuItemnoAcc

void setCuItemnoAcc (String value ,Number recNo)

明細通貨項目の会計伝票明細番号に値を設定します。

パラメータ
value | String | 会計伝票明細番号
recNo | Number | レコード番号
返却値
void
setDocAcDocNo

void setDocAcDocNo (String value)

伝票ヘッダの会計伝票番号に値を設定します。

パラメータ
value String 会計伝票番号
返却値
void
setDocCompCode

void setDocCompCode (String value)

伝票ヘッダの会社コードに値を設定します。

パラメータ
value String 会社コード
返却値
void
setDocDocDate

void setDocDocDate (String value)

伝票ヘッダの伝票の伝票日付に値を設定します。

パラメータ
value String 伝票の伝票日付
返却値
void
setDocDocType

void setDocDocType (String value)

伝票ヘッダの伝票タイプに値を設定します。

パラメータ
value String 伝票タイプ
返却値
void
setDocFisPeriod

void setDocFisPeriod (String value)

伝票ヘッダの会計期間に値を設定します。

パラメータ
value String 会計期間
返却値
void
setDocFiscYear

void setDocFiscYear (String value)

伝票ヘッダの会計年度に値を設定します。

パラメータ
value String 会計年度
返却値
void
setDocHeaderTxt

void setDocHeaderTxt (String value)

伝票ヘッダの伝票ヘッダテキストに値を設定します。

パラメータ
value String 伝票ヘッダテキスト
返却値
void
setDocObjKey

void setDocObjKey (String value)

伝票ヘッダのオブジェクトキーに値を設定します。

パラメータ
value String オブジェクトキー
返却値
void
setDocObjType

void setDocObjType (String value)

伝票ヘッダの参照処理に値を設定します。

パラメータ
value String 参照処理
返却値
void
setDocPstngDate

void setDocPstngDate (String value)

伝票ヘッダの伝票の転記日付に値を設定します。

パラメータ
value String 伝票の転記日付
返却値
void
setDocRefDocNo

void setDocRefDocNo (String value)

伝票ヘッダの参照伝票番号に値を設定します。

パラメータ
value String 参照伝票番号
返却値
void
setDocUsername

void setDocUsername (String value)

伝票ヘッダのユーザ名に値を設定します。

パラメータ
value String ユーザ名
返却値
void
setGlAllocNmbr

void setGlAllocNmbr (String value ,Number recNo)

G/L 勘定明細のソートキーに値を設定します。

パラメータ
value | String | ソートキー
recNo | Number | レコード番号
返却値
void
setGlBusArea

void setGlBusArea (String value ,Number recNo)

G/L 勘定明細の事業領域に値を設定します。

パラメータ
value | String | 事業領域
recNo | Number | レコード番号
返却値
void
setGlCompCode

void setGlCompCode (String value ,Number recNo)

G/L 勘定明細の会社コードに値を設定します。

パラメータ
value | String | 会社コード
recNo | Number | レコード番号
返却値
void
setGlCostcenter

void setGlCostcenter (String value ,Number recNo)

G/L 勘定明細の原価センタに値を設定します。

パラメータ
value | String | 原価センタ
recNo | Number | レコード番号
返却値
void
setGlDocType

void setGlDocType (String value ,Number recNo)

G/L 勘定明細の伝票タイプに値を設定します。

パラメータ
value | String | 伝票タイプ
recNo | Number | レコード番号
返却値
void
setGlFiscYear

void setGlFiscYear (String value ,Number recNo)

G/L 勘定明細の会計年度に値を設定します。

パラメータ
value | String | 会計年度
recNo | Number | レコード番号
返却値
void
setGlGlAccount

void setGlGlAccount (String value ,Number recNo)

G/L 勘定明細の総勘定元帳勘定に値を設定します。

パラメータ
value | String | 総勘定元帳勘定
recNo | Number | レコード番号
返却値
void
setGlItemText

void setGlItemText (String value ,Number recNo)

G/L 勘定明細の明細テキストに値を設定します。

パラメータ
value | String | 明細テキスト
recNo | Number | レコード番号
返却値
void
setGlItemnoAcc

void setGlItemnoAcc (String value ,Number recNo)

G/L 勘定明細の会計伝票明細番号に値を設定します。

パラメータ
value | String | 会計伝票明細番号
recNo | Number | レコード番号
返却値
void
setGlOrderid

void setGlOrderid (String value ,Number recNo)

G/L 勘定明細の指図番号に値を設定します。

パラメータ
value | String | 指図番号
recNo | Number | レコード番号
返却値
void
setGlPstngDate

void setGlPstngDate (String value ,Number recNo)

G/L 勘定明細の伝票の転記日付に値を設定します。

パラメータ
value | String | 伝票の転記日付
recNo | Number | レコード番号
返却値
void
setGlRefKey1

void setGlRefKey1 (String value ,Number recNo)

G/L 勘定明細の取引先参照キーに値を設定します。

パラメータ
value | String | 取引先参照キー
recNo | Number | レコード番号
返却値
void
setGlTaxCode

void setGlTaxCode (String value ,Number recNo)

G/L 勘定明細の消費税コードに値を設定します。

パラメータ
value | String | 消費税コード
recNo | Number | レコード番号
返却値
void
setGlWbsElement

void setGlWbsElement (String value ,Number recNo)

G/L 勘定明細のWBS 要素に値を設定します。

パラメータ
value | String | WBS要素
recNo | Number | レコード番号
返却値
void
setPaAllocNmbr

void setPaAllocNmbr (String value ,Number recNo)

仕入先明細のソートキーに値を設定します。

パラメータ
value | String | ソートキー
recNo | Number | レコード番号
返却値
void
setPaBlineDate

void setPaBlineDate (String value ,Number recNo)

仕入先明細の期日計算の支払基準日に値を設定します。

パラメータ
value | String | 期日計算の支払基準日
recNo | Number | レコード番号
返却値
void
setPaGlAccount

void setPaGlAccount (String value ,Number recNo)

仕入先明細の総勘定元帳勘定に値を設定します。

パラメータ
value | String | 総勘定元帳勘定
recNo | Number | レコード番号
返却値
void
setPaItemText

void setPaItemText (String value ,Number recNo)

仕入先明細の明細テキストに値を設定します。

パラメータ
value | String | 明細テキスト
recNo | Number | レコード番号
返却値
void
setPaItemnoAcc

void setPaItemnoAcc (String value ,Number recNo)

仕入先明細の会計伝票明細番号に値を設定します。

パラメータ
value | String | 会計伝票明細番号
recNo | Number | レコード番号
返却値
void
setPaPymtMeth

void setPaPymtMeth (String value ,Number recNo)

仕入先明細の支払方法に値を設定します。

パラメータ
value | String | 支払方法
recNo | Number | レコード番号
返却値
void
setPaVendorNo

void setPaVendorNo (String value ,Number recNo)

仕入先明細の仕入先または債権者の勘定コードに値を設定します。

パラメータ
value | String | 仕入先または債権者の勘定コード
recNo | Number | レコード番号
返却値
void
setStrParam

void setStrParam (String paramStr ,String paramName ,String value)

構造型の項目に値をセットします。
伝票ヘッダ構造型の設定方法は以下のとおりです。
構造名：「DocumentHeader」
項目名：伝票ヘッダの項目は以下のとおりです。
伝票ヘッダ
オブジェクト
(Object)
OBJ_TYPE 参照処理 (String)
OBJ_KEY オブジェクトキー (String)
OBJ_SYS 元伝票の論理システム (String)
USERNAME ユーザ名 (String)
HEADER_TXT 伝票ヘッダテキスト (String)
OBJ_KEY_R 取消: オブジェクトキー (AWREF_REV と AWORG_REV) (String)
BUS_ACT 取引 (String)
COMP_CODE 会社コード (String)
AC_DOC_NO 会計伝票番号 (String)
FISC_YEAR 会計年度 (String)
DOC_DATE 伝票の伝票日付 (String)
PSTNG_DATE 伝票の転記日付 (String)
FIS_PERIOD 会計期間 (String)
DOC_TYPE 伝票タイプ (String)
REF_DOC_NO 参照伝票番 (String)
COMPO_ACC ACC インタフェースの構成要素 (String)
TAX_COMP_CODE 税会社コード(String)
REASON_REV 反対仕訳理由 (String)
REF_DOC_NO_LONG 参照伝票番号 (依存性についてはテキスト長参照) (String)
NEG_POSTNG フラグ: マイナス転記 (String)

パラメータ
paramStr | String | 構造名
paramName | String | 項目名
value | String | セットする値
返却値
void
setTaGlAccount

void setTaGlAccount (String value ,Number recNo)

税明細の総勘定元帳勘定に値を設定します。

パラメータ
value | String | 総勘定元帳勘定
recNo | Number | レコード番号
返却値
void
setTaItemnoAcc

void setTaItemnoAcc (String value ,Number recNo)

税明細の会計伝票明細番号に値を設定します。

パラメータ
value | String | 会計伝票明細番号
recNo | Number | レコード番号
返却値
void
setTaTaxCode

void setTaTaxCode (String value ,Number recNo)

税明細の消費税コードに値を設定します。

パラメータ
value | String | 消費税コード
recNo | Number | レコード番号
返却値
void
setTblParam

void setTblParam (String paramTable ,String paramName ,String value ,int index)

テーブル型の項目に値をセットします。
仕入先明細テーブルの設定方法は以下のとおりです。
テーブル名：「AccountPayable」
項目名：仕入先明細の項目は以下のとおりです。
仕入先明細
オブジェクト
(Object)
ITEMNO_ACC 会計伝票明細番号 (String)
VENDOR_NO 仕入先または債権者の勘定コード (String)
REF_KEY_1 取引先参照キー (String)
REF_KEY_2 取引先参照キー (String)
REF_KEY_3 明細の参照キー (String)
GL_ACCOUNT 総勘定元帳勘定 (String)
BLINE_DATE 期日計算の支払基準日 (String)
PMTMTHSUPL 支払方法追加 (String)
PYMT_METH 支払方法 (String)
BLLSRV_IND サービスコード (外貨支払) (String)
ALLOC_NMBR ソートキー (String)
ITEM_TEXT 明細テキスト (String)
ACCT_KEY 内部処理キー (String)
SCBANK_IND 中央銀行コード (String)
PYMT_AMT 支払通貨額 (String)
PYMT_CUR 自動支払通貨 (String)
PYMT_CUR_ISO ISO コード通貨(String)
PROFIT_CTR 利益センタ (String)
PART_PRCTR パートナ利益センタ(String)
SEGMENT セグメントレポートのセグメント (String)
PARTNER_SEGMENT セグメントレポートのパートナセグメント(String)
FUND ファンド(String)
PARTNER_FUND パートナファンド(String)
GRANT_NBR 補助金(String)
PARTNER_GRANT_NBR パートナ補助金(String)
BUS_AREA 事業領域(String)
TR_PART_BA 取引先事業領域 (String)
NEG_POSTNG フラグ: マイナス転記(String)

G/L勘定明細テーブルの設定方法は以下のとおりです。
テーブル名：「AccountGl」
項目名：G/L勘定明細の項目は以下のとおりです。
G/L勘定明細
オブジェクト
(Object)
ITEMNO_ACC 会計伝票明細番号 (String)
GL_ACCOUNT 総勘定元帳勘定 (String)
COMP_CODE 会社コード (String)
PSTNG_DATE 伝票の転記日付 (String)
DOC_TYPE 伝票タイプ (String)
AC_DOC_NO 会計伝票番号 (String)
FISC_YEAR 会計年度 (String)
FIS_PERIOD 会計期間 (String)
STLMNT_PER 決済期間 (String)
REF_KEY_1 取引先参照キー(String)
REF_KEY_2 取引先参照キー (String)
REF_KEY_3 明細の参照キー (String)
ACCT_KEY 内部処理キー (String)
ITEM_TEXT 明細テキスト (String)
TAX_CODE 売上税コード (String)
TAXJURCODE 税管轄(String)
ALLOC_NMBR ソートキー (String)
BUS_AREA 事業領域(String)
PERSON_NO 従業員番号 (String)
COSTCENTER 原価センタ(String)
ORDERID 指図番号(String)
COST_OBJ 原価対象(String)
ACTIVITY 作業/活動番号(String)
QUANTITY 数量 (String)
BASE_UOM 基本数量単位(String)
WBS_ELEMENT WBS 要素 (String)
NETWORK 勘定割当のネットワーク番号(String)
CMMT_ITEM 予算コード(String)
FUNDS_CTR 予算センタ(String)
FUND ファンド(String)
SALES_ORD 受注伝票番号(String)
S_ORD_ITEM 受注明細番号(String)
ACTTYPE 活動タイプ(String)
OBJ_TYP_P 前伝票: 参照処理(String)
OBJ_KEY_P 前伝票: オブジェクトキー (AWREF_REV と AWORG_REV)(String)
OBJ_POS_P 前伝票: 参照明細(String)
TRADE_ID 取引先の会社 ID(String)
CMMT_ITEM_LONG 前伝票: 参照明細(String)
OBJ_POS_P 予算コード(String)
GRANT_NBR 補助金(String)
FUNC_AREA_LONG 前機能領域(String)
PROFIT_CTR 利益センタ(String)
PART_PRCTR パートナ利益センタ(String)
SEGMENT セグメントレポートのセグメント(String)
PARTNER_SEGMENT セグメントレポートのパートナセグメント(String)
PARTNER_FUND パートナファンド(String)
PARTNER_GRANT_NBR パートナ補助金(String)
TR_PART_BA 取引先事業領域(String)
NEG_POSTNG フラグ: マイナス転記(String)

税明細テーブルの設定方法は以下のとおりです。
テーブル名：「AccountTax」
項目名：税明細の項目は以下のとおりです。
税明細
オブジェクト
(Object)
ITEMNO_ACC 会計伝票明細番号 (String)
GL_ACCOUNT 総勘定元帳勘定 (String)
TAX_CODE 売上税コード (String)
ACCT_KEY 内部処理キー (String)
TAXJURCODE 税管轄 (String)
COND_KEY 条件タイプ (String)
TAX_RATE 税率 (String)
TAX_DATE 税率定義の日付 (String)
STAT_CON 統計に適用する条件 (String)
TAXJURCODE_DEEP 税管轄コード - 最下位レベル税管轄(String)
TAXJURCODE_LEVEL 税管轄コードレベル (String)
NEG_POSTNG フラグ: マイナス転記 (String)

明細通貨項目テーブルの設定方法は以下のとおりです。
テーブル名：「CurrencyAmount」
項目名：/明細通貨項目の項目は以下のとおりです。
明細通貨項目
オブジェクト
(Object)
ITEMNO_ACC 会計伝票明細番号 (String)
CURR_TYPE 通貨タイプおよび評価ビュー (String)
CURRENCY 通貨コード(String)
AMT_DOCCUR 伝票通貨額 (String)
EXCH_RATE 換算レート (String)
AMT_BASE 課税基準額 (伝票通貨建て) (String)
EXCH_RATE_V 間接呼び値換算レート (String)
CURRENCY_ISO ISO コード通貨 (String)

明細通貨項目テーブルの設定方法は以下のとおりです。
テーブル名：「CurrencyAmount」
項目名：/明細通貨項目の項目は以下のとおりです。
明細通貨項目
オブジェクト
(Object)
ITEMNO_ACC 会計伝票明細番号 (String)
CURR_TYPE 通貨タイプおよび評価ビュー (String)
CURRENCY 通貨コード(String)
AMT_DOCCUR 伝票通貨額 (String)
EXCH_RATE 換算レート (String)
AMT_BASE 課税基準額 (伝票通貨建て) (String)
EXCH_RATE_V 間接呼び値換算レート (String)
CURRENCY_ISO ISO コード通貨 (String)

パラメータ
paramTable | String | テーブル名
paramName | String | 項目名
value | String | セットする値
index | int | レコード番号
返却値
void


 BankController オブジェクト

銀行コントローラクラス。

銀行の情報を取得します。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
BankController ()
コンストラクタ。
BankController (SapClient sapClient)
コンストラクタ。
BankController (String bankCtry ,String maxRows)
コンストラクタ。
BankController (String bankCtry ,String maxRows ,SapClient sapClient)
コンストラクタ。
メソッドの概要
Array | getBankList () 銀行一覧を取得します。
Object | getBankName (String bankKey) 銀行コードを指定して銀行名を取得します。
Object | getCity (String bankKey) 銀行コードを指定して市区町村名を取得します。
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
コンストラクタの詳細
BankController

BankController ()
コンストラクタ。

引数なしのコンストラクタです。
銀行国コード"JP"で有効な銀行情報が抽出対象となります。
BankController

BankController (SapClient sapClient)
コンストラクタ。

引数１つのコンストラクタです。
SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
BankController

BankController (String bankCtry ,String maxRows)
コンストラクタ。

引数２つのコンストラクタです。
指定した銀行国コードで有効な銀行情報が抽出対象となります。
パラメータ
bankCtry | String | 銀行国コード
maxRows | String | 最大該当行数
BankController

BankController (String bankCtry ,String maxRows ,SapClient sapClient)
コンストラクタ。

引数３つのコンストラクタです。
指定した銀行国コードで有効な銀行情報が抽出対象となります。
SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
bankCtry | String | 銀行国コード
maxRows | String | 最大該当行数
sapClient | SapClient | Sapクライアント
メソッドの詳細
getBankList

Array getBankList ()

銀行一覧を取得します。
返却値
Array 銀行情報が格納された配列

銀行情報オブジェクトの構成は以下のとおりです。
銀行情報
オブジェクト
(Object)
BANK_KEY 銀行コード (String)
BANK_NAME 銀行名 (String)
CITY 市区町村名 (String)

取得した銀行情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["BANK_KEY"]　→　配列内のidx番目の銀行の「銀行コード」
[idx]["BANK_NAME"]　→　配列内のidx番目の銀行の「銀行名」
[idx]["CITY"]　→　配列内のidx番目の銀行の「市区町村名」

※ idxは0〜n （配列サイズ-1）

getBankName

Object getBankName (String bankKey)

銀行コードを指定して銀行名を取得します。

パラメータ
bankKey String SAP上に存在する銀行コード
返却値
Object 指定した銀行コードに対応する銀行名
（成功時の返却値は String になります。）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getCity

Object getCity (String bankKey)

銀行コードを指定して市区町村名を取得します。

パラメータ
bankKey String SAP上に存在する銀行コード
返却値
Object 指定した銀行コードに対応する市区町村名
（成功時の返却値は String になります。）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ


 BillingDocCreateMultipleController オブジェクト

請求伝票登録コントローラクラス。

機能は以下の通り
  • 請求伝票を登録します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
BillingDocCreateMultipleController ()
コンストラクタ｡
BillingDocCreateMultipleController (ConnectionManager connectionManager)
コンストラクタ。
BillingDocCreateMultipleController (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより請求伝票を登録します。
String | getBapiReturnErrMessage () ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage () プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。
Array | getBillingDataInList () 処理予定明細データのテーブルを取得します。
Array | getCCardDataInList () 処理予定支払方法のテーブルを取得します。
Array | getConditionDataInList () 処理予定条件のテーブルを取得します。
Object | getCreatorDataIn () 取り込まれる日付の順序を取得します｡
Array | getErrorsList () 前明細の不正処理に関する情報を取得します。
Object | getPosting () Posting category:post directlyを取得します。
Array | getSuccessList () 正常に処理された明細のテーブルを取得します。
Object | getTestrun () シミュレーション実行 ('X')、更新実行 (' ')を取得します。
Array | getTextDataInList () 処理予定明細データのテーブルを取得します。
void | setPosting (Object value) Posting category:post directlyを設定します｡
void | setStrParam (String paramStr ,String paramName ,Object value) 構造型の項目に値をセットします。
void | setTblParam (String paramTable ,String paramName ,Object value ,int index) テーブル型の項目に値をセットします。
void | setTestrun (Object value) シミュレーション実行 ('X')、更新実行 (' ')を設定します｡
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
BillingDocCreateMultipleController

BillingDocCreateMultipleController ()
コンストラクタ｡
BillingDocCreateMultipleController

BillingDocCreateMultipleController (ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、BillingDocCreateMultipleController#executeBapi()実行後に必ず ConnectionManager#commit()またはConnectionManager#rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。
パラメータ
connectionManager ConnectionManager コネクションマネージャー
BillingDocCreateMultipleController

BillingDocCreateMultipleController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより請求伝票を登録します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getBapiReturnErrMessage

String getBapiReturnErrMessage ()

ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡
返却値
String BAPI実行結果エラーとなった全てのメッセージ情報
getBapiReturnMessage

String getBapiReturnMessage ()

プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡
返却値
String プロパティファイルでオートコミット条件に一致したType情報のメッセージ情報
getBillingDataInList

Array getBillingDataInList ()

処理予定明細データのテーブルを取得します。
返却値
Array 処理予定明細データのテーブル

処理予定明細データのテーブル情報オブジェクトの構成は以下のとおりです。
処理予定明細データのテーブル情報
オブジェクト
(Object)
SALESORG販売組織(String)
DISTR_CHAN流通チャネル(String)
DIVISION製品部門(String)
DOC_TYPE販売伝票タイプ(String)
ORDBILLTYP受注関連請求伝票に対する提案請求伝票タイプ(String)
BILL_DATE請求索引および印刷に対する請求日(String)
SOLD_TO受注先(String)
ITEM_CATEG明細カテゴリ (販売伝票)(String)
ACCTASGNMT品目の勘定設定グループ(String)
PRICE_DATE価格設定/外貨換算の実行日付(String)
COUNTRY出荷国 (商品発送国)(String)
PLANTプラント(String)
BILL_TO請求先(String)
PAYER支払人(String)
SHIP_TO出荷先(String)
REF_DOC参照伝票番号(String)
MATERIAL品目コード(String)
REQ_QTY累積受注数量 (販売単位)(String)
CURRENCY販売伝票通貨(String)
SHORT_TEXTテキスト (短): 受注明細(String)
TAXCL_1MAT品目の税分類(String)
REF_ITEM参照明細番号(String)
STAT_GROUP統計グループ(String)
NO_MATMAST品目マスタ確認禁止(String)
ADDR_NOアドレス: アドレス番号(String)
TITLE敬称(String)
NAME名称 1(String)
NAME_2名称 2(String)
POSTL_CODE郵便番号(String)
CONSUMCTRY消費者の国キー(String)
CITY市区町村(String)
DISTRICT所在地(String)
STREET地名/番地-号(String)
REGION地域 (都道府県)(String)
PROD_HIER品目階層(String)
SALES_UNIT販売単位(String)
PROFIT_CTR利益センタ(String)
TAXJURCODE税計算管轄コード - 税管轄コード(String)
PURCH_ORD出荷先発注番号(String)
DOC_NUMBER販売伝票(String)
ITM_NUMBER販売伝票明細(String)
ORIGINDOC開始伝票(String)
ITEM開始明細(String)
CREATED_BYオブジェクト登録者名(String)
MATERIAL_EXTERNAL項目 MATERIAL の品目コード (長) (今後のリリースで開発)(String)
MATERIAL_GUID項目 MATERIAL の外部 GUID (今後のリリースで開発)(String)
MATERIAL_VERSION項目 MATERIAL のバージョン番号 (今後のリリースで開発)(String)
INCOTERMS1インコタームズ (1)(String)
INCOTERMS2インコタームズ (2)(String)
EXCHANGE_RATE価格設定/統計用換算レート(String)
PAYMENT_TERMS支払条件キー(String)
HG_LV_ITEMBOM 構成の上位レベル明細(String)
REF_DOC_CA先行販売管理伝票の伝票カテゴリ(String)
ORDERID指図番号(String)
PROFIT_SEGM_NO収益性セグメント番号 (CO-PA) (String)
COSTCENTER原価センタ(String)
WBS_ELEMWBS 要素(String)
TAX_DEPART_CTY税出荷国(String)
TAX_DEST_CTY税仕向国(String)
SERV_DATEサービス提供日(String)
PARALLEL_QTYQuantity in Parallel Unit of Measure(String)
PARALLEL_UOMParallel Unit of Measure(String)

取得した管理情報設定ヘッダセグメント情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["SALESORG"]　→　配列内のidx番目の処理予定明細データのテーブルの「販売組織」
[idx]["DISTR_CHAN"]　→　配列内のidx番目の処理予定明細データのテーブルの「流通チャネル」
[idx]["DIVISION"]　→　配列内のidx番目の処理予定明細データのテーブルの「製品部門」
[idx]["DOC_TYPE"]　→　配列内のidx番目の処理予定明細データのテーブルの「販売伝票タイプ」
[idx]["ORDBILLTYP"]　→　配列内のidx番目の処理予定明細データのテーブルの 「受注関連請求伝票に対する提案請求伝票タイプ」
[idx]["BILL_DATE"]　→　配列内のidx番目の処理予定明細データのテーブルの 「請求索引および印刷に対する請求日」
[idx]["SOLD_TO"]　→　配列内のidx番目の処理予定明細データのテーブルの「受注先」
[idx]["ITEM_CATEG"]　→　配列内のidx番目の処理予定明細データのテーブルの 「明細カテゴリ (販売伝票)」
[idx]["ACCTASGNMT"]　→　配列内のidx番目の処理予定明細データのテーブルの 「品目の勘定設定グループ」
[idx]["PRICE_DATE"]　→　配列内のidx番目の処理予定明細データのテーブルの 「価格設定/外貨換算の実行日付」
[idx]["COUNTRY"]　→　配列内のidx番目の処理予定明細データのテーブルの「出荷国 (商品発送国)」
[idx]["PLANT"]　→　配列内のidx番目の処理予定明細データのテーブルの「プラント」
[idx]["BILL_TO"]　→　配列内のidx番目の処理予定明細データのテーブルの「請求先」
[idx]["PAYER"]　→　配列内のidx番目の処理予定明細データのテーブルの「支払人」
[idx]["SHIP_TO"]　→　配列内のidx番目の処理予定明細データのテーブルの「出荷先」
[idx]["REF_DOC"]　→　配列内のidx番目の処理予定明細データのテーブルの「参照伝票番号」
[idx]["MATERIAL"]　→　配列内のidx番目の処理予定明細データのテーブルの「品目コード」
[idx]["REQ_QTY"]　→　配列内のidx番目の処理予定明細データのテーブルの「累積受注数量 (販売単位)」
[idx]["CURRENCY"]　→　配列内のidx番目の処理予定明細データのテーブルの「販売伝票通貨」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の処理予定明細データのテーブルの 「テキスト (短): 受注明細」
[idx]["TAXCL_1MAT"]　→　配列内のidx番目の処理予定明細データのテーブルの「品目の税分類」
[idx]["REF_ITEM"]　→　配列内のidx番目の処理予定明細データのテーブルの「参照明細番号」
[idx]["STAT_GROUP"]　→　配列内のidx番目の処理予定明細データのテーブルの「統計グループ」
[idx]["NO_MATMAST"]　→　配列内のidx番目の処理予定明細データのテーブルの「品目マスタ確認禁止」
[idx]["ADDR_NO"]　→　配列内のidx番目の処理予定明細データのテーブルの「アドレス: アドレス番号」
[idx]["TITLE"]　→　配列内のidx番目の処理予定明細データのテーブルの「敬称」
[idx]["NAME"]　→　配列内のidx番目の処理予定明細データのテーブルの「名称 1」
[idx]["NAME_2"]　→　配列内のidx番目の処理予定明細データのテーブルの「名称 2」
[idx]["POSTL_CODE"]　→　配列内のidx番目の処理予定明細データのテーブルの「郵便番号」
[idx]["CONSUMCTRY"]　→　配列内のidx番目の処理予定明細データのテーブルの「消費者の国キー」
[idx]["CITY"]　→　配列内のidx番目の処理予定明細データのテーブルの「市区町村」
[idx]["DISTRICT"]　→　配列内のidx番目の処理予定明細データのテーブルの「所在地」
[idx]["STREET"]　→　配列内のidx番目の処理予定明細データのテーブルの「地名/番地-号」
[idx]["REGION"]　→　配列内のidx番目の処理予定明細データのテーブルの「地域 (都道府県)」
[idx]["PROD_HIER"]　→　配列内のidx番目の処理予定明細データのテーブルの「品目階層」
[idx]["SALES_UNIT"]　→　配列内のidx番目の処理予定明細データのテーブルの「販売単位」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の処理予定明細データのテーブルの「利益センタ」
[idx]["TAXJURCODE"]　→　配列内のidx番目の処理予定明細データのテーブルの 「税計算管轄コード - 税管轄コード」
[idx]["PURCH_ORD"]　→　配列内のidx番目の処理予定明細データのテーブルの「出荷先発注番号」
[idx]["DOC_NUMBER"]　→　配列内のidx番目の処理予定明細データのテーブルの「販売伝票」
[idx]["ITM_NUMBER"]　→　配列内のidx番目の処理予定明細データのテーブルの「販売伝票明細」
[idx]["ORIGINDOC"]　→　配列内のidx番目の処理予定明細データのテーブルの「開始伝票」
[idx]["ITEM"]　→　配列内のidx番目の処理予定明細データのテーブルの「開始明細」
[idx]["CREATED_BY"]　→　配列内のidx番目の処理予定明細データのテーブルの「オブジェクト登録者名」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の処理予定明細データのテーブルの 「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の処理予定明細データのテーブルの 「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の処理予定明細データのテーブルの 「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」
[idx]["INCOTERMS1"]　→　配列内のidx番目の処理予定明細データのテーブルの 「インコタームズ (1)」
[idx]["INCOTERMS2"]　→　配列内のidx番目の処理予定明細データのテーブルの 「インコタームズ (2)」
[idx]["EXCHANGE_RATE"]　→　配列内のidx番目の処理予定明細データのテーブルの 「価格設定/統計用換算レート」
[idx]["PAYMENT_TERMS"]　→　配列内のidx番目の処理予定明細データのテーブルの「支払条件キー」
[idx]["HG_LV_ITEM"]　→　配列内のidx番目の処理予定明細データのテーブルの 「BOM 構成の上位レベル明細」
[idx]["REF_DOC_CA"]　→　配列内のidx番目の処理予定明細データのテーブルの 「先行販売管理伝票の伝票カテゴリ」
[idx]["ORDERID"]　→　配列内のidx番目の処理予定明細データのテーブルの「指図番号」
[idx]["PROFIT_SEGM_NO"]　→　配列内のidx番目の処理予定明細データのテーブルの 「収益性セグメント番号 (CO-PA)」
[idx]["COSTCENTER"]　→　配列内のidx番目の処理予定明細データのテーブルの「原価センタ」
[idx]["WBS_ELEM"]　→　配列内のidx番目の処理予定明細データのテーブルの「WBS 要素」
[idx]["TAX_DEPART_CTY"]　→　配列内のidx番目の処理予定明細データのテーブルの「税出荷国」
[idx]["TAX_DEST_CTY"]　→　配列内のidx番目の処理予定明細データのテーブルの「税仕向国」
[idx]["SERV_DATE"]　→　配列内のidx番目の処理予定明細データのテーブルの「サービス提供日」
[idx]["PARALLEL_QTY"]　→　配列内のidx番目の処理予定明細データのテーブルの「Quantity in Parallel Unit of Measure」
[idx]["PARALLEL_UOM"]　→　配列内のidx番目の処理予定明細データのテーブルの「Parallel Unit of Measure」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11: 販売管理システムエラー
12: 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getCCardDataInList

Array getCCardDataInList ()

処理予定支払方法のテーブルを取得します。
返却値
Array 処理予定支払方法のテーブル

処理予定支払方法のテーブル情報オブジェクトの構成は以下のとおりです。
処理予定支払方法のテーブル情報
オブジェクト
(Object)
PAYTYPE支払手段: 支払カード計画の明細分類(String)
CC_TYPE支払カードタイプ: カードタイプ(String)
CC_NUMBER支払カード: カード番号(String)
CC_SEQ_NO支払カード: 支払カード - 接尾辞(String)
CC_VALID_F支払カード: 使用有効開始日付(String)
CC_VALID_T支払カード: 有効終了日(String)
CC_NAME支払カード: カード所有者の氏名(String)
AUTHAMOUNT支払カード: 承認額(String)
CURRENCY通貨コード(String)
CURRENCY_ISOISO コード通貨(String)
AUTH_FLAG支払カード: 振替権限(String)
AUTH_DATE支払カード: 承認日(String)
AUTH_TIME支払カード: 承認時刻(String)
CC_AUTH_NO支払カード: 承認番号(String)
AUTH_REFNO支払カード: 決済代行会社の権限参照コード(String)
MERCHIDCL支払カード: 決済代行会社のマーチャント ID (String)
TERMINAL支払カード: 端末(String)
DATAORIGIN支払カード: 入力モード(String)
CC_SETTLED支払カード: 決済終了(String)
CC_LOC_ID支払カード: トランザクション (入庫時点)(String)
BILL_PLAN請求計画番号(String)
BILL_PLANI明細: 請求計画/支払計画/支払カード(String)
BILL_VALUE請求金額: 請求計画に請求日付が指定されている場合 (String)

取得した管理情報設定ヘッダセグメント情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PAYTYPE"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「支払手段: 支払カード計画の明細分類」
[idx]["CC_TYPE"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「支払カードタイプ: カードタイプ」
[idx]["CC_NUMBER"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「支払カード: カード番号」
[idx]["CC_SEQ_NO"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「支払カード: 支払カード - 接尾辞」
[idx]["CC_VALID_F"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「支払カード: 使用有効開始日付」
[idx]["CC_VALID_T"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「支払カード: 有効終了日」
[idx]["CC_NAME"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「支払カード: カード所有者の氏名」
[idx]["AUTHAMOUNT"]　→　配列内のidx番目の処理予定支払方法のテーブルの「支払カード: 承認額」
[idx]["CURRENCY"]　→　配列内のidx番目の処理予定支払方法のテーブルの「通貨コード」
[idx]["CURRENCY_ISO"]　→　配列内のidx番目の処理予定支払方法のテーブルの「ISO コード通貨」
[idx]["AUTH_FLAG"]　→　配列内のidx番目の処理予定支払方法のテーブルの「支払カード: 振替権限」
[idx]["AUTH_DATE"]　→　配列内のidx番目の処理予定支払方法のテーブルの「支払カード: 承認日」
[idx]["AUTH_TIME"]　→　配列内のidx番目の処理予定支払方法のテーブルの「支払カード: 承認時刻」
[idx]["CC_AUTH_NO"]　→　配列内のidx番目の処理予定支払方法のテーブルの「支払カード: 承認番号」
[idx]["AUTH_REFNO"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「支払カード: 決済代行会社の権限参照コード」
[idx]["MERCHIDCL"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「支払カード: 決済代行会社のマーチャント ID」
[idx]["TERMINAL"]　→　配列内のidx番目の処理予定支払方法のテーブルの「支払カード: 端末」
[idx]["DATAORIGIN"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「支払カード: 入力モード」
[idx]["CC_SETTLED"]　→　配列内のidx番目の処理予定支払方法のテーブルの「支払カード: 決済終了」
[idx]["CC_LOC_ID"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「支払カード: トランザクション (入庫時点)」
[idx]["BILL_PLAN"]　→　配列内のidx番目の処理予定支払方法のテーブルの「請求計画番号」
[idx]["BILL_PLANI"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「明細: 請求計画/支払計画/支払カード」
[idx]["BILL_VALUE"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「請求金額: 請求計画に請求日付が指定されている場合」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11: 販売管理システムエラー
12: 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getConditionDataInList

Array getConditionDataInList ()

処理予定条件のテーブルを取得します。
返却値
Array 処理予定条件のテーブル

処理予定条件のテーブル情報オブジェクトの構成は以下のとおりです。
処理予定条件のテーブル情報
オブジェクト
(Object)
DATA_INDEX別の構成のテーブル入力へのポインタ(String)
COND_TYPE条件タイプ(String)
COND_VALUE条件金額/率(String)
COND_CURR条件通貨 (累積項目用)(String)
COND_P_UNT価格条件単位(String)
COND_D_UNT伝票の条件単位(String)

取得した管理情報設定ヘッダセグメント情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["DATA_INDEX"]　→　配列内のidx番目の処理予定条件のテーブルの 「別の構成のテーブル入力へのポインタ」
[idx]["COND_TYPE"]　→　配列内のidx番目の処理予定条件のテーブルの「条件タイプ」
[idx]["COND_VALUE"]　→　配列内のidx番目の処理予定条件のテーブルの「条件金額/率」
[idx]["COND_CURR"]　→　配列内のidx番目の処理予定条件のテーブルの「条件通貨 (累積項目用)」
[idx]["COND_P_UNT"]　→　配列内のidx番目の処理予定条件のテーブルの「価格条件単位」
[idx]["COND_D_UNT"]　→　配列内のidx番目の処理予定条件のテーブルの「伝票の条件単位」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11: 販売管理システムエラー
12: 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getCreatorDataIn

Object getCreatorDataIn ()

取り込まれる日付の順序を取得します｡
返却値
Object 取り込まれる日付の順序

取り込まれる日付の順序情報オブジェクトの構成は以下のとおりです。
取り込まれる日付の順序情報
オブジェクト
(Object)
CREATED_BYオブジェクト登録者名(String)
CREATED_ONレコード登録日(String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getErrorsList

Array getErrorsList ()

前明細の不正処理に関する情報を取得します。
返却値
Array 前明細の不正処理に関する情報

前明細の不正処理に関する情報オブジェクトの構成は以下のとおりです。
前明細の不正処理に関する情報
オブジェクト
(Object)
REF_DOC参照伝票番号(String)
REF_DOC_ITEM参照明細番号(String)
TYPEメッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了 (String)
IDメッセージ、メッセージクラス(String)
NUMBERメッセージ、メッセージ番号(String)
MESSAGEメッセージテキスト(String)
LOG_NOアプリケーションログ: ログ番号(String)
LOG_MSG_NOアプリケーションログ: メッセージシリアル番号 (String)
MESSAGE_V1メッセージ、メッセージ変数(String)
MESSAGE_V2メッセージ、メッセージ変数(String)
MESSAGE_V3メッセージ、メッセージ変数(String)
MESSAGE_V4メッセージ、メッセージ変数(String)

取得した管理情報設定ヘッダセグメント情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["REF_DOC"]　→　配列内のidx番目の前明細の不正処理に関する情報の「参照伝票番号」
[idx]["REF_DOC_ITEM"]　→　配列内のidx番目の前明細の不正処理に関する情報の「参照明細番号」
[idx]["TYPE"]　→　配列内のidx番目の前明細の不正処理に関する情報の 「メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了」
[idx]["ID"]　→　配列内のidx番目の前明細の不正処理に関する情報の「メッセージ、メッセージクラス」
[idx]["NUMBER"]　→　配列内のidx番目の前明細の不正処理に関する情報の「メッセージ、メッセージ番号」
[idx]["MESSAGE"]　→　配列内のidx番目の前明細の不正処理に関する情報の「メッセージテキスト」
[idx]["LOG_NO"]　→　配列内のidx番目の前明細の不正処理に関する情報の 「アプリケーションログ: ログ番号」
[idx]["LOG_MSG_NO"]　→　配列内のidx番目の前明細の不正処理に関する情報の 「アプリケーションログ: メッセージシリアル番号」
[idx]["MESSAGE_V1"]　→　配列内のidx番目の前明細の不正処理に関する情報の 「メッセージ、メッセージ変数」
[idx]["MESSAGE_V2"]　→　配列内のidx番目の前明細の不正処理に関する情報の 「メッセージ、メッセージ変数」
[idx]["MESSAGE_V3"]　→　配列内のidx番目の前明細の不正処理に関する情報の 「メッセージ、メッセージ変数」
[idx]["MESSAGE_V4"]　→　配列内のidx番目の前明細の不正処理に関する情報の 「メッセージ、メッセージ変数」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11: 販売管理システムエラー
12: 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPosting

Object getPosting ()

Posting category:post directlyを取得します。

返却値
Object Posting category:post directly
getSuccessList

Array getSuccessList ()

正常に処理された明細のテーブルを取得します。
返却値
Array 正常に処理された明細のテーブル

正常に処理された明細のテーブル情報オブジェクトの構成は以下のとおりです。
正常に処理された明細のテーブル情報
オブジェクト
(Object)
REF_DOC参照伝票番号(String)
REF_DOC_ITEM参照明細番号(String)
BILL_DOC請求伝票(String)
BILL_DOC_ITEM請求伝票明細(String)
NET_VALUE正味金額(String)
TAX_VALUE税額(String)
CURRENCY通貨コード(String)
CURRENCY_ISOISO コード通貨(String)
NET_VALUE_ITEM正味金額(String)
TAX_VALUE_ITEM税額(String)
GRO_VALUE_ITEM総額(String)

取得した管理情報設定ヘッダセグメント情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["REF_DOC"]　→　配列内のidx番目の正常に処理された明細のテーブルの「参照伝票番号」
[idx]["REF_DOC_ITEM"]　→　配列内のidx番目の正常に処理された明細のテーブルの「参照明細番号」
[idx]["BILL_DOC"]　→　配列内のidx番目の正常に処理された明細のテーブルの「請求伝票」
[idx]["BILL_DOC_ITEM"]　→　配列内のidx番目の正常に処理された明細のテーブルの「請求伝票明細」
[idx]["NET_VALUE"]　→　配列内のidx番目の正常に処理された明細のテーブルの「正味金額」
[idx]["TAX_VALUE"]　→　配列内のidx番目の正常に処理された明細のテーブルの「税額」
[idx]["CURRENCY"]　→　配列内のidx番目の正常に処理された明細のテーブルの「通貨コード」
[idx]["CURRENCY_ISO"]　→　配列内のidx番目の正常に処理された明細のテーブルの 「ISO コード通貨」
[idx]["NET_VALUE_ITEM"]　→　配列内のidx番目の正常に処理された明細のテーブルの「正味金額」
[idx]["TAX_VALUE_ITEM"]　→　配列内のidx番目の正常に処理された明細のテーブルの「税額」
[idx]["GRO_VALUE_ITEM"]　→　配列内のidx番目の正常に処理された明細のテーブルの「総額」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11: 販売管理システムエラー
12: 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getTestrun

Object getTestrun ()

シミュレーション実行 ('X')、更新実行 (' ')を取得します。

返却値
Object シミュレーション実行 ('X')、更新実行 (' ')
getTextDataInList

Array getTextDataInList ()

処理予定明細データのテーブルを取得します。
返却値
Array 処理予定明細データのテーブル

処理予定明細データのテーブル情報オブジェクトの構成は以下のとおりです。
処理予定明細データのテーブル情報
オブジェクト
(Object)
REF_DOC参照伝票番号(String)
REF_ITEM参照明細番号(String)
APPLOBJECTテキスト: アプリケーションオブジェクト(String)
TEXT_IDテキスト ID(String)
LANGU言語キー(String)
FORMAT_COLタグ列(String)
TEXT_LINEテキスト行(String)

取得した管理情報設定ヘッダセグメント情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["REF_DOC"]　→　配列内のidx番目の請求インタフェースの通信構造テキストの「参照伝票番号」
[idx]["REF_ITEM"]　→　配列内のidx番目の請求インタフェースの通信構造テキストの「参照明細番号」
[idx]["APPLOBJECT"]　→　配列内のidx番目の請求インタフェースの通信構造テキストの 「テキスト: アプリケーションオブジェクト」
[idx]["TEXT_ID"]　→　配列内のidx番目の請求インタフェースの通信構造テキストの「テキスト ID」
[idx]["LANGU"]　→　配列内のidx番目の請求インタフェースの通信構造テキストの「言語キー」
[idx]["FORMAT_COL"]　→　配列内のidx番目の請求インタフェースの通信構造テキストの「タグ列」
[idx]["TEXT_LINE"]　→　配列内のidx番目の請求インタフェースの通信構造テキストの「テキスト行」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11: 販売管理システムエラー
12: 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

setPosting

void setPosting (Object value)

Posting category:post directlyを設定します｡
パラメータ
value Object Posting category:post directly
返却値
void
setStrParam

void setStrParam (String paramStr ,String paramName ,Object value)

構造型の項目に値をセットします。
パラメータ
paramStr | String | 構造名
paramName | String | 項目名
value | Object | セットする値
返却値
void
setTblParam

void setTblParam (String paramTable ,String paramName ,Object value ,int index)

テーブル型の項目に値をセットします。
パラメータ
paramTable | String | テーブル名
paramName | String | 項目名
value | Object | セットする値
index | int | レコード番号
返却値
void
setTestrun

void setTestrun (Object value)

シミュレーション実行 ('X')、更新実行 (' ')を設定します｡
パラメータ
value Object シミュレーション実行 ('X')、更新実行 (' ')
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 BillingDocGetDetailController オブジェクト

後続請求伝票詳細照会コントローラクラス。

機能は以下の通り
  • 後続請求伝票詳細を照会します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
BillingDocGetDetailController (String billingDocument ,SapClient sapClient)
コンストラクタ｡
BillingDocGetDetailController (String billingDocument ,SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | getBillingDocumentDetail () 請求伝票詳細情報を取得します。
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
コンストラクタの詳細
BillingDocGetDetailController

BillingDocGetDetailController (String billingDocument ,SapClient sapClient)
コンストラクタ｡
パラメータ
billingDocument | String | 処理予定の請求伝票数
sapClient | SapClient | SAPへの接続情報が格納されたオブジェクト
BillingDocGetDetailController

BillingDocGetDetailController (String billingDocument ,SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
billingDocument | String | 処理予定の請求伝票数
sapClient | SapClient | Sapクライアント
メソッドの詳細
getBillingDocumentDetail

Object getBillingDocumentDetail ()

請求伝票詳細情報を取得します。
返却値
Object 請求伝票詳細

請求伝票詳細情報オブジェクトの構成は以下のとおりです。
請求伝票詳細情報
オブジェクト
(Object)
BILLINGDOC 請求伝票 (String)
BILL_TYPE 請求タイプ (String)
BILLCATEG 請求カテゴリ (String)
SD_DOC_CAT 販売管理伝票カテゴリ (String)
CURRENCY 販売伝票通貨 (String)
CURRENCY_ISO ISO通貨コード (String)
ACCTSTATUS 会計への転記ステータス (String)
NET_VALUE 正味金額 (String)
TAX_VALUE 税額 (String)
CANCELLED 中止区分 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11: 販売管理システムエラー
12: 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ


 BillingDocGetListController オブジェクト

後続請求伝票一覧照会コントローラクラス。

機能は以下の通り
  • 後続請求伝票一覧を照会します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
BillingDocGetListController (String sign ,String option ,SapClient sapClient)
コンストラクタ｡
BillingDocGetListController (String sign ,String option ,SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより後続請求伝票一覧を取得します。
Array | getBillingDocumentDetailListList () 後続請求伝票情報一覧を取得します。
Array | getSuccessList () 後続請求伝票明細一覧を取得します。
void | setTblParam (String paramTable ,String paramName ,Object value ,int index) テーブル型の項目に値をセットします。
コンストラクタの詳細
BillingDocGetListController

BillingDocGetListController (String sign ,String option ,SapClient sapClient)
コンストラクタ｡
パラメータ
sign | String | 選択演算子(範囲テーブル)
option | String | 選択演算子(テーブル範囲)
sapClient | SapClient | SAPへの接続情報が格納されたオブジェクト
BillingDocGetListController

BillingDocGetListController (String sign ,String option ,SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sign | String | 選択演算子（範囲テーブル）
option | String | 選択演算子（テーブル範囲）
sapClient | SapClient | Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより後続請求伝票一覧を取得します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getBillingDocumentDetailListList

Array getBillingDocumentDetailListList ()

後続請求伝票情報一覧を取得します。
返却値
Array 後続請求伝票情報が格納された配列

後続請求伝票情報オブジェクトの構成は以下のとおりです。
請求伝票情報
オブジェクト
(Object)
BILLINGDOC 請求伝票 (String)
BILL_TYPE 請求タイプ (String)
BILLCATEG 請求カテゴリ (String)
SD_DOC_CAT 販売管理伝票カテゴリ (String)
CURRENCY 販売伝票通貨 (String)
CURRENCY_ISO ISO通貨コード (String)
ACCTSTATUS 会計への転記ステータス (String)
NET_VALUE 正味金額 (String)
TAX_VALUE 税額 (String)
CANCELLED 中止区分 (String)

取得した請求伝票情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["BILLINGDOC"]　→　配列内のidx番目の後続請求伝票情報の「請求伝票」
[idx]["BILL_TYPE"]　→　配列内のidx番目の後続請求伝票情報の「請求タイプ」
[idx]["BILLCATEG"]　→　配列内のidx番目の後続請求伝票情報の「請求カテゴリ」
[idx]["SD_DOC_CAT"]　→　配列内のidx番目の後続請求伝票情報の「販売管理伝票カテゴリ」
[idx]["CURRENCY"]　→　配列内のidx番目の後続請求伝票情報の「販売伝票通貨」
[idx]["CURRENCY_ISO"]　→　配列内のidx番目の後続請求伝票情報の「ISO通貨コード」
[idx]["ACCTSTATUS"]　→　配列内のidx番目の後続請求伝票情報の「会計への転記ステータス」
[idx]["NET_VALUE"]　→　配列内のidx番目の後続請求伝票情報の「正味金額」
[idx]["TAX_VALUE"]　→　配列内のidx番目の後続請求伝票情報の「税額」
[idx]["CANCELLED"]　→　配列内のidx番目の後続請求伝票情報の「中止区分」

※ idxは0〜n （配列サイズ-1）

getSuccessList

Array getSuccessList ()

後続請求伝票明細一覧を取得します。
返却値
Array 後続請求伝票明細情報が格納された配列

後続請求伝票明細情報オブジェクトの構成は以下のとおりです。
請求伝票明細
オブジェクト
(Object)
REF_DOC 参照伝票番号 (String)
REF_DOC_ITEM 参照明細番号 (String)
BILL_DOC 請求伝票 (String)
BILL_DOC_ITEM 請求伝票明細 (String)
NET_VALUE 正味金額 (String)
TAX_VALUE 税額 (String)
CURRENCY 通貨コード (String)
CURRENCY_ISO ISOコード通貨 (String)
NET_VALUE_ITEM 正味金額 (String)
TAX_VALUE_ITEM 税額 (String)
GRO_VALUE_ITEM 総額 (String)

取得した後続請求伝票明細情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["REF_DOC"]　→　配列内のidx番目の後続請求伝票明細情報の「参照伝票番号」
[idx]["REF_DOC_ITEM"]　→　配列内のidx番目の後続請求伝票明細情報の「参照明細番号」
[idx]["BILL_DOC"]　→　配列内のidx番目の後続請求伝票明細情報の「請求伝票」
[idx]["BILL_DOC_ITEM"]　→　配列内のidx番目の後続請求伝票明細情報の「請求伝票明細」
[idx]["NET_VALUE"]　→　配列内のidx番目の後続請求伝票明細情報の「正味金額」
[idx]["TAX_VALUE"]　→　配列内のidx番目の後続請求伝票明細情報の「税額」
[idx]["CURRENCY"]　→　配列内のidx番目の後続請求伝票明細情報の「通貨コード」
[idx]["CURRENCY_ISO"]　→　配列内のidx番目の後続請求伝票明細情報の「ISOコード通貨」
[idx]["NET_VALUE_ITEM"]　→　配列内のidx番目の後続請求伝票明細情報の「正味金額」
[idx]["TAX_VALUE_ITEM"]　→　配列内のidx番目の後続請求伝票明細情報の「税額」
[idx]["GRO_VALUE_ITEM"]　→　配列内のidx番目の後続請求伝票明細情報の「総額」

※ idxは0〜n （配列サイズ-1）

setTblParam

void setTblParam (String paramTable ,String paramName ,Object value ,int index)

テーブル型の項目に値をセットします。
パラメータ
paramTable | String | テーブル名
paramName | String | 項目名
value | Object | セットする値
index | int | レコード番号
返却値
void


 BusinessAreaController オブジェクト

事業領域コントローラクラス。

事業領域の情報を取得します。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
BusinessAreaController ()
コンストラクタ。
BusinessAreaController (SapClient sapClient)
コンストラクタ。
BusinessAreaController (String language ,String languageIso)
コンストラクタ。
BusinessAreaController (String language ,String languageIso ,SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | getBusArDes (String busArea) 事業領域を指定して事業領域名を取得します。
Array | getBusinessAreaList () 事業領域一覧を取得します。
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
コンストラクタの詳細
BusinessAreaController

BusinessAreaController ()
コンストラクタ。

引数なしのコンストラクタです。
言語・ISO639準拠の言語の値が「JA」のものが抽出対象となります。
BusinessAreaController

BusinessAreaController (SapClient sapClient)
コンストラクタ。

引数１つのコンストラクタです。
SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
BusinessAreaController

BusinessAreaController (String language ,String languageIso)
コンストラクタ。

引数２つのコンストラクタです。
指定した言語・ISO639準拠の言語で有効な事業領域が抽出対象となります。
パラメータ
language | String | 言語
languageIso | String | ISO639準拠の言語
BusinessAreaController

BusinessAreaController (String language ,String languageIso ,SapClient sapClient)
コンストラクタ。

引数３つのコンストラクタです。
指定した言語・ISO639準拠の言語で有効な事業領域が抽出対象となります。
SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
language | String | 言語
languageIso | String | ISO639準拠の言語
sapClient | SapClient | Sapクライアント
メソッドの詳細
getBusArDes

Object getBusArDes (String busArea)

事業領域を指定して事業領域名を取得します。

パラメータ
busArea String SAP上に存在する事業領域コード
返却値
Object 指定した事業領域コードに対応する事業領域名
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getBusinessAreaList

Array getBusinessAreaList ()

事業領域一覧を取得します。

返却値
Array 事業領域情報が格納された配列

事業領域情報オブジェクトの構成は以下のとおりです。
事業領域情報
オブジェクト
(Object)
BUS_AREA 事業領域コード (String)
BUS_AREA_DES 事業領域名 (String)

取得した事業領域情報の配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["BUS_AREA"]　→　配列内のidx番目の事業領域の「事業領域コード」
[idx]["BUS_AREA_DES"]　→　配列内のidx番目の事業領域の「事業領域名」

※ idxは0〜n （配列サイズ-1）

getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ


 CompanyController オブジェクト

会社コントローラクラス。

会社の情報を取得します｡
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
CompanyController ()
コンストラクタ。
CompanyController (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | getCompName (String compCode) 会社コードを指定して会社名を取得します。
Array | getCompanyList () 会社一覧を取得します。
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
コンストラクタの詳細
CompanyController

CompanyController ()
コンストラクタ。

CompanyController

CompanyController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
getCompName

Object getCompName (String compCode)

会社コードを指定して会社名を取得します。

パラメータ
compCode String SAP上に存在する会社コード
返却値
Object 指定した会社コードに対応する会社名
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getCompanyList

Array getCompanyList ()

会社一覧を取得します。

返却値
Array 会社情報が格納された配列

会社情報オブジェクトの構成は以下のとおりです。
会社情報
オブジェクト
(Object)
COMP_CODE 会社コード (String)
COMP_NAME 会社名 (String)

取得した会社情報の配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["COMP_CODE"]　→　配列内のidx番目の会社の「会社コード」
[idx]["COMP_NAME"]　→　配列内のidx番目の会社の「会社名」

※ idxは0〜n （配列サイズ-1）

getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ


 ControllingAreaController オブジェクト

管理領域コントローラクラス。

管理領域の情報を取得します。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
ControllingAreaController ()
コンストラクタ。
ControllingAreaController (SapClient sapClient)
コンストラクタ。
メソッドの概要
Array | getControllingAreaList () 管理領域一覧を取得します。
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
Object | getName (String coArea) 管理領域を指定して管理領域名を取得します。
コンストラクタの詳細
ControllingAreaController

ControllingAreaController ()
コンストラクタ。

ControllingAreaController

ControllingAreaController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
getControllingAreaList

Array getControllingAreaList ()

管理領域一覧を取得します。

返却値
Array 管理領域情報が格納された配列

管理領域情報オブジェクトの構成は以下のとおりです。
管理領域情報
オブジェクト
(Object)
CO_AREA 管理領域コード (String)
NAME 管理領域名 (String)

取得した管理領域情報の配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CO_AREA"]　→　配列内のidx番目の管理領域の「管理領域コード」
[idx]["NAME"]　→　配列内のidx番目の管理領域の「管理領域名」

※ idxは0〜n （配列サイズ-1）

getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getName

Object getName (String coArea)

管理領域を指定して管理領域名を取得します。

パラメータ
coArea String SAP上に存在する管理領域コード
返却値
Object 指定した管理領域コードに対応する管理領域名
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)


 CostCenterController オブジェクト

原価センタコントローラクラス。

原価センタの情報を取得します。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
CostCenterController (String controllingArea)
コンストラクタ。
CostCenterController (String controllingArea ,String date)
コンストラクタ。
CostCenterController (String controllingArea ,SapClient sapClient)
コンストラクタ。
CostCenterController (String controllingArea ,String date ,SapClient sapClient)
コンストラクタ。
CostCenterController ()
コンストラクタ。
CostCenterController (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより原価センタを取得します。
Object | getBusinessAreaFrom () 事業領域を取得します。
Object | getBusinessAreaTo () 事業領域を取得します。
Object | getCompanycodeFrom () 会社コード（開始値）を取得します。
Object | getCompanycodeTo () 会社コード（終了値）を取得します。
Object | getControllingarea () 管理領域を取得します。
Array | getCostCenterList () 原価センタ一覧を取得します。
Object | getCostcenterFrom () 原価センタ（開始値）を取得します。
Object | getCostcenterTo () 原価センタ（終了値）を取得します。
Object | getCostcentergroup () 原価センタグループを取得します。
Object | getDateFrom () 有効期間：開始を取得します。
Object | getDateTo () 有効期間：終了を取得します。
Object | getDescript (SAP上に存在する原価センタコード costCenter) 原価センタを指定してテキストを取得します。
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
Array | getExtensionIn () ExtensionInの参照構造を取得します。
Array | getExtensionOut () ExtensionOutの参照構造を取得します。
Object | getMasterDataInactive () マスタレコードの無効化を取得します。
Object | getName (String costCenter) 原価センタを指定して一般名称を取得します。
Object | getPersonInChargeFrom () 責任者（開始値）を取得します。
Object | getPersonInChargeTo () 責任者（終了値）を取得します。
Object | getPersonInChargeUserFrom () 担当ユーザ（開始値）を取得します。
Object | getPersonInChargeUserTo () 担当ユーザ（終了値）を取得します。
void | setBusinessAreaFrom (Object value) 事業領域を設定します。
void | setBusinessAreaTo (Object value) 事業領域を設定します。
void | setCompanycodeFrom (Object value) 会社コード（開始値）を設定します。
void | setCompanycodeTo (Object value) 会社コード（終了値）を設定します。
void | setControllingarea (Object value) 管理領域を設定します。
void | setCostcenterFrom (Object value) 原価センタ（開始値）を設定します。
void | setCostcenterTo (Object value) 原価センタ（終了値）を設定します。
void | setCostcentergroup (Object value) 原価センタグループを設定します。
void | setDateFrom (Object value) 有効期間：開始を設定します。
void | setDateTo (Object value) 有効期間：終了を設定します。
void | setMasterDataInactive (Object value) マスタレコードの無効化を設定します。
void | setPersonInChargeFrom (Object value) 責任者（開始値）を設定します。
void | setPersonInChargeTo (Object value) 責任者（終了値）を設定します。
void | setPersonInChargeUserFrom (Object value) 担当ユーザ（開始値）を設定します。
void | setPersonInChargeUserTo (Object value) 担当ユーザ（終了値）を設定します。
void | setTblParam (String tableName ,String paramName ,Object value ,int index) テーブル型の項目に値をセットします。
コンストラクタの詳細
CostCenterController

CostCenterController (String controllingArea)
コンストラクタ。

引数１つのコンストラクタです。
システム日付で有効な原価センタ情報が抽出対象となります。
パラメータ
controllingArea String SAP上に存在する管理領域コード
CostCenterController

CostCenterController (String controllingArea ,String date)
コンストラクタ。

引数２つのコンストラクタです。
指定したYYYYMMDDの日付で有効な原価センタ情報が抽出対象となります。
パラメータ
controllingArea | String | 管理領域
date | String | 有効期間: 開始
CostCenterController

CostCenterController (String controllingArea ,SapClient sapClient)
コンストラクタ。

引数２つのコンストラクタです。
SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
controllingArea | String | 管理領域
sapClient | SapClient | Sapクライアント
CostCenterController

CostCenterController (String controllingArea ,String date ,SapClient sapClient)
コンストラクタ。

引数３つのコンストラクタです。
指定したYYYYMMDDの日付で有効な原価センタ情報が抽出対象となります。
SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
controllingArea | String | 管理領域
date | String | 有効期間: 開始
sapClient | SapClient | Sapクライアント
CostCenterController

CostCenterController ()
コンストラクタ。

引数なしのコンストラクタです。
CostCenterController

CostCenterController (SapClient sapClient)
コンストラクタ。

引数１つのコンストラクタです。
SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより原価センタを取得します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計システムエラー
6： 財務会計アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getBusinessAreaFrom

Object getBusinessAreaFrom ()

事業領域を取得します。
返却値
Object 事業領域
getBusinessAreaTo

Object getBusinessAreaTo ()

事業領域を取得します。
返却値
Object 事業領域
getCompanycodeFrom

Object getCompanycodeFrom ()

会社コード（開始値）を取得します。
返却値
Object 会社コード（開始値）
getCompanycodeTo

Object getCompanycodeTo ()

会社コード（終了値）を取得します。
返却値
Object 会社コード（終了値）
getControllingarea

Object getControllingarea ()

管理領域を取得します。
返却値
Object 管理領域
getCostCenterList

Array getCostCenterList ()

原価センタ一覧を取得します。

返却値
Array 原価センタ情報が格納された配列

原価センタ情報オブジェクトの構成は以下のとおりです。
原価センタ情報
オブジェクト
(Object)
CONTROLLING_AREA 管理領域コード (String)
COST_CENTER 原価センタコード (String)
DESCRIPT 一般名称 (String)
NAME テキスト (String)
ACT_STATE 一般マスタレコードの有効化ステータス (String)

取得した原価センタ情報の配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONTROLLING_AREA"]　→　配列内のidx番目の原価センタの「管理領域コード」
[idx]["COST_CENTER"]　→　配列内のidx番目の原価センタの「原価センタコード」
[idx]["DESCRIPT"]　→　配列内のidx番目の原価センタの「一般名称」
[idx]["NAME"]　→　配列内のidx番目の原価センタの「テキスト」
[idx]["ACT_STATE"]　→　配列内のidx番目の原価センタの 「一般マスタレコードの有効化ステータス」

※ idxは0〜n （配列サイズ-1）

getCostcenterFrom

Object getCostcenterFrom ()

原価センタ（開始値）を取得します。
返却値
Object 原価センタ（開始値）
getCostcenterTo

Object getCostcenterTo ()

原価センタ（終了値）を取得します。
返却値
Object 原価センタ（終了値）
getCostcentergroup

Object getCostcentergroup ()

原価センタグループを取得します。
返却値
Object 原価センタグループ
getDateFrom

Object getDateFrom ()

有効期間：開始を取得します。
返却値
Object 有効期間：開始
getDateTo

Object getDateTo ()

有効期間：終了を取得します。
返却値
Object 有効期間：終了
getDescript

Object getDescript (SAP上に存在する原価センタコード costCenter)

原価センタを指定してテキストを取得します。

パラメータ
costCenter SAP上に存在する原価センタコード
返却値
Object 指定した原価センタコードに対応するテキスト
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getExtensionIn

Array getExtensionIn ()

ExtensionInの参照構造を取得します。

返却値
Array ExtensionInの参照構造が格納された配列

ExtensionInの参照構造オブジェクトの構成は以下のとおりです。
ExtensionInの参照構造
オブジェクト
(Object)
STRUCTURE BAPI テーブル拡張の構造名 (String)
VALUEPART1 BAPI　拡張パラメータのデータ部分 (String)
VALUEPART2 BAPI　拡張パラメータのデータ部分 (String)
VALUEPART3 BAPI　拡張パラメータのデータ部分 (String)
VALUEPART4 BAPI　拡張パラメータのデータ部分 (String)

取得したExtensionInの参照構造情報の配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["STRUCTURE"]　→　配列内のidx番目のExtensionInの参照構造の「BAPI テーブル拡張の構造名」
[idx]["VALUEPART1"]　→　配列内のidx番目のExtensionInの参照構造の「BAPI　拡張パラメータのデータ部分」
[idx]["VALUEPART2"]　→　配列内のidx番目のExtensionInの参照構造の「BAPI　拡張パラメータのデータ部分」
[idx]["VALUEPART3"]　→　配列内のidx番目のExtensionInの参照構造の「BAPI　拡張パラメータのデータ部分」
[idx]["VALUEPART4"]　→　配列内のidx番目のExtensionInの参照構造の「BAPI　拡張パラメータのデータ部分」

※ idxは0〜n （配列サイズ-1）

getExtensionOut

Array getExtensionOut ()

ExtensionOutの参照構造を取得します。

返却値
Array ExtensionOutの参照構造が格納された配列

ExtensionInの参照構造オブジェクトの構成は以下のとおりです。
ExtensionOutの参照構造
オブジェクト
(Object)
STRUCTURE BAPI テーブル拡張の構造名 (String)
VALUEPART1 BAPI　拡張パラメータのデータ部分 (String)
VALUEPART2 BAPI　拡張パラメータのデータ部分 (String)
VALUEPART3 BAPI　拡張パラメータのデータ部分 (String)
VALUEPART4 BAPI　拡張パラメータのデータ部分 (String)

取得したExtensionOutの参照構造情報の配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["STRUCTURE"]　→　配列内のidx番目のExtensionOutの参照構造の「BAPI テーブル拡張の構造名」
[idx]["VALUEPART1"]　→　配列内のidx番目のExtensionOutの参照構造の「BAPI　拡張パラメータのデータ部分」
[idx]["VALUEPART2"]　→　配列内のidx番目のExtensionOutの参照構造の「BAPI　拡張パラメータのデータ部分」
[idx]["VALUEPART3"]　→　配列内のidx番目のExtensionOutの参照構造の「BAPI　拡張パラメータのデータ部分」
[idx]["VALUEPART4"]　→　配列内のidx番目のExtensionOutの参照構造の「BAPI　拡張パラメータのデータ部分」

※ idxは0〜n （配列サイズ-1）

getMasterDataInactive

Object getMasterDataInactive ()

マスタレコードの無効化を取得します。
返却値
Object マスタレコードの無効化
getName

Object getName (String costCenter)

原価センタを指定して一般名称を取得します。

パラメータ
costCenter String SAP上に存在する原価センタコード
返却値
Object 指定した原価センタコードに対応する一般名称
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPersonInChargeFrom

Object getPersonInChargeFrom ()

責任者（開始値）を取得します。
返却値
Object 責任者（開始値）
getPersonInChargeTo

Object getPersonInChargeTo ()

責任者（終了値）を取得します。
返却値
Object 責任者（終了値）
getPersonInChargeUserFrom

Object getPersonInChargeUserFrom ()

担当ユーザ（開始値）を取得します。
返却値
Object 担当ユーザ（開始値）
getPersonInChargeUserTo

Object getPersonInChargeUserTo ()

担当ユーザ（終了値）を取得します。
返却値
Object 担当ユーザ（終了値）
setBusinessAreaFrom

void setBusinessAreaFrom (Object value)

事業領域を設定します。
パラメータ
value Object 事業領域
返却値
void
setBusinessAreaTo

void setBusinessAreaTo (Object value)

事業領域を設定します。
パラメータ
value Object 事業領域
返却値
void
setCompanycodeFrom

void setCompanycodeFrom (Object value)

会社コード（開始値）を設定します。
パラメータ
value Object 会社コード（開始値）
返却値
void
setCompanycodeTo

void setCompanycodeTo (Object value)

会社コード（終了値）を設定します。
パラメータ
value Object 会社コード（終了値）
返却値
void
setControllingarea

void setControllingarea (Object value)

管理領域を設定します。
パラメータ
value Object 管理領域
返却値
void
setCostcenterFrom

void setCostcenterFrom (Object value)

原価センタ（開始値）を設定します。
パラメータ
value Object 原価センタ（開始値）
返却値
void
setCostcenterTo

void setCostcenterTo (Object value)

原価センタ（終了値）を設定します。
パラメータ
value Object 原価センタ（終了値）
返却値
void
setCostcentergroup

void setCostcentergroup (Object value)

原価センタグループを設定します。
パラメータ
value Object 原価センタグループ
返却値
void
setDateFrom

void setDateFrom (Object value)

有効期間：開始を設定します。
パラメータ
value Object 有効期間：開始
返却値
void
setDateTo

void setDateTo (Object value)

有効期間：終了を設定します。
パラメータ
value Object 有効期間：終了
返却値
void
setMasterDataInactive

void setMasterDataInactive (Object value)

マスタレコードの無効化を設定します。
パラメータ
value Object マスタレコードの無効化
返却値
void
setPersonInChargeFrom

void setPersonInChargeFrom (Object value)

責任者（開始値）を設定します。
パラメータ
value Object 責任者（開始値）
返却値
void
setPersonInChargeTo

void setPersonInChargeTo (Object value)

責任者（終了値）を設定します。
パラメータ
value Object 責任者（終了値）
返却値
void
setPersonInChargeUserFrom

void setPersonInChargeUserFrom (Object value)

担当ユーザ（開始値）を設定します。
パラメータ
value Object 担当ユーザ（開始値）
返却値
void
setPersonInChargeUserTo

void setPersonInChargeUserTo (Object value)

担当ユーザ（終了値）を設定します。
パラメータ
value Object 担当ユーザ（終了値）
返却値
void
setTblParam

void setTblParam (String tableName ,String paramName ,Object value ,int index)

テーブル型の項目に値をセットします。
パラメータ
tableName | String | テーブル名
paramName | String | 項目名
value | Object | セットする値
index | int | レコード番号
返却値
void


 CostCenterGroupGetDetailController オブジェクト

原価センタグループ情報取得コントローラクラス。

機能は以下の通り
  • 原価センタグループ情報を取得します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
CostCenterGroupGetDetailController (String controllingarea ,String groupname ,言語キー langu ,ISO639準拠の言語 languIso)
コンストラクタ｡
CostCenterGroupGetDetailController (String controllingarea ,String groupname ,SapClient sapClient)
コンストラクタ。
CostCenterGroupGetDetailController (String controllingarea ,String groupname ,String langu ,String languIso ,SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | getControllingarea () 原価センタグループの管理領域から値を取得します。
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
Object | getGroupname () 原価センタグループのグループ名から値を取得します。
Array | getHierarchyNodesList () 階層ノード一覧を取得します。
Array | getHierarchyValuesList () 階層値一覧を取得します。
Object | getLanguage () 言語情報を取得します。
void | setControllingarea (String value) 原価センタグループの管理領域に値を設定します。
void | setGroupname (String value) 原価センタグループのグループ名に値を設定します。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
CostCenterGroupGetDetailController

CostCenterGroupGetDetailController (String controllingarea ,String groupname ,言語キー langu ,ISO639準拠の言語 languIso)
コンストラクタ｡
パラメータ
controllingarea | String | 管理領域
groupname | String | グループ名
langu | 言語キー
languIso | ISO639準拠の言語
CostCenterGroupGetDetailController

CostCenterGroupGetDetailController (String controllingarea ,String groupname ,SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
controllingarea | String | 管理領域
groupname | String | グループ名
sapClient | SapClient | Sapクライアント
CostCenterGroupGetDetailController

CostCenterGroupGetDetailController (String controllingarea ,String groupname ,String langu ,String languIso ,SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
controllingarea | String | 管理領域
groupname | String | グループ名
langu | String | 言語キー
languIso | String | ISO639準拠の言語
sapClient | SapClient | Sapクライアント
メソッドの詳細
getControllingarea

Object getControllingarea ()

原価センタグループの管理領域から値を取得します。

返却値
Object 管理領域
getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getGroupname

Object getGroupname ()

原価センタグループのグループ名から値を取得します。

返却値
Object グループ名
getHierarchyNodesList

Array getHierarchyNodesList ()

階層ノード一覧を取得します。
返却値
Array 階層ノード情報が格納された配列

階層ノード情報オブジェクトの構成は以下のとおりです。
階層ノード情報
オブジェクト
(Object)
GROUPNAME グループ名 (String)
HIERLEVEL 階層のエントリレベル (String)
VALCOUNT 階層ノード内の値の値数 (String)
DESCRIPT グループテキスト (短) (String)

取得した階層ノード情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["GROUPNAME"]　→　配列内のidx番目の階層ノードの「グループ名」
[idx]["HIERLEVEL"]　→　配列内のidx番目の階層ノードの「階層のエントリレベル」
[idx]["VALCOUNT"]　→　配列内のidx番目の階層ノードの「階層ノード内の値の値数」
[idx]["DESCRIPT"]　→　配列内のidx番目の階層ノードの「グループテキスト (短)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getHierarchyValuesList

Array getHierarchyValuesList ()

階層値一覧を取得します。
返却値
Array 階層値情報が格納された配列

階層値情報オブジェクトの構成は以下のとおりです。
階層値情報
オブジェクト
(Object)
VALFROM 原価センタ (String)
VALTO 原価センタ (String)

取得した階層値情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["VALFROM"]　→　配列内のidx番目の階層値の「利益センタ」
[idx]["VALTO"]　→　配列内のidx番目の階層値の「利益センタ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getLanguage

Object getLanguage ()

言語情報を取得します。
返却値
Object 言語情報

言語情報オブジェクトの構成は以下のとおりです。
言語情報
オブジェクト
(Object)
LANGU言語キー(String)
LANGU_ISOISO準拠の言語(String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9: 管理会計業務システムエラー
10: 管理会計業務アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

setControllingarea

void setControllingarea (String value)

原価センタグループの管理領域に値を設定します。
パラメータ
value String 管理領域
返却値
void
setGroupname

void setGroupname (String value)

原価センタグループのグループ名に値を設定します。
パラメータ
value String グループ名
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 CreditorGetDetailController オブジェクト

仕入先詳細情報取得コントローラクラス。

機能は以下の通り
  • 仕入先詳細情報を取得します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
CreditorGetDetailController (String creditorid ,String companycode ,SapClient sapClient)
コンストラクタ｡
CreditorGetDetailController (String creditorid ,String companycode ,SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | getBankDataList () 銀行データ情報を取得します。
Object | getCompanyDataInfo () 会社コード依存データ情報を取得します｡
Object | getCompanycode () 仕入先詳細の会社コードから値を取得します。
Object | getCreditorid () 仕入先詳細の仕入先コードから値を取得します。
Object | getDebtorGetDetail () 仕入先コード詳細情報を取得します｡
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
Object | getGeneralDataInfo () 一般データ情報を取得します｡
コンストラクタの詳細
CreditorGetDetailController

CreditorGetDetailController (String creditorid ,String companycode ,SapClient sapClient)
コンストラクタ｡
パラメータ
creditorid | String | 仕入先コード
companycode | String | 会社コード
sapClient | SapClient | SAPへの接続情報が格納されたオブジェクト
CreditorGetDetailController

CreditorGetDetailController (String creditorid ,String companycode ,SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
creditorid | String | 仕入先コード
companycode | String | 会社コード
sapClient | SapClient | Sapクライアント
メソッドの詳細
getBankDataList

Object getBankDataList ()

銀行データ情報を取得します。
返却値
Object 銀行国コード(銀行データ情報)

銀行データ情報オブジェクトの構成は以下のとおりです。
銀行データ情報
オブジェクト
(Object)
VENDOR 仕入先または債権者の勘定コード (String)
BANK_CTRY 銀行国コード (String)
BANK_KEY 銀行コード (String)
BANK_ACCT 口座番号 (String)
CTRL_KEY 預金種別 (String)
PARTNER_BK 取引先銀行タイプ (String)
COLL_AUTH フラグ：回収権限 (String)
BANK_REF 銀行詳細の参照詳細 (String)

取得した銀行データ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["VENDOR"]　→　配列内のidx番目の銀行データの「仕入先または債権者の勘定コード」
[idx]["BANK_CTRY"]　→　配列内のidx番目の銀行データの「銀行国コード」
[idx]["BANK_KEY"]　→　配列内のidx番目の銀行データの「銀行コード」
[idx]["BANK_ACCT"]　→　配列内のidx番目の銀行データの「口座番号」
[idx]["CTRL_KEY"]　→　配列内のidx番目の銀行データの「預金種別」
[idx]["PARTNER_BK"]　→　配列内のidx番目の銀行データの「取引先銀行タイプ」
[idx]["COLL_AUTH"]　→　配列内のidx番目の銀行データの「フラグ：回収権限」
[idx]["BANK_REF"]　→　配列内のidx番目の銀行データの「銀行詳細の参照詳細」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getCompanyDataInfo

Object getCompanyDataInfo ()

会社コード依存データ情報を取得します｡
返却値
Object 会社コード依存データ

会社コード依存データ情報オブジェクトの構成は以下のとおりです。
会社コード依存データ情報
オブジェクト
(Object)
VENDOR 仕入先または債権者の勘定コード (String)
COMP_CODE 会社コード (String)
CLERK 記帳担当者 (String)
HD_OFFICE 本店勘定コード (String)
ALT_PAYEE 代理受取人勘定コード (String)
CUVD_CLEAR フラグ：得意先と仕入先間の相殺決済 (String)
PMNTTRMS 支払条件キー (String)
ACT_AT_VEN 仕入先での自社勘定コード (String)
VEND_USER 仕入先担当者 (String)
INTERNET 関係会社担当者のインターネットアドレス (String)
FAX 得意先/仕入先の経理担当者のファックス No. (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getCompanycode

Object getCompanycode ()

仕入先詳細の会社コードから値を取得します。

返却値
Object 会社コード
getCreditorid

Object getCreditorid ()

仕入先詳細の仕入先コードから値を取得します。

返却値
Object 仕入先コード
getDebtorGetDetail

Object getDebtorGetDetail ()

仕入先コード詳細情報を取得します｡

返却値
Object 仕入先マスタ
getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getGeneralDataInfo

Object getGeneralDataInfo ()

一般データ情報を取得します｡
返却値
Object 一般データ

一般データ情報オブジェクトの構成は以下のとおりです。
一般データ情報
オブジェクト
(Object)
VENDOR 仕入先または債権者の勘定コード (String)
NAME 名称 1 (String)
NAME_2 名称 2 (String)
NAME_3 名称 3 (String)
NAME_4 名称 4 (String)
CITY 市区町村 (String)
DISTRICT 所在地 (String)
PO_BOX 私書箱 (String)
POBX_PCD 私書箱番号 (String)
POSTL_CODE 郵便番号 (String)
REGION 地域 (都道府県) (String)
STREET 地名/番地-号 (String)
COUNTRY 国コード (String)
POBX_CTY 私書箱住所 (String)
LANGU 言語キー (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)


 DebtorGetDetailController オブジェクト

得意先コードの詳細コントローラクラス。

機能は以下の通り
  • 得意先コードの詳細情報を取得します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
DebtorGetDetailController (String Debtorid ,String Companycode ,SapClient sapClient)
コンストラクタ｡
DebtorGetDetailController (String Debtorid ,String Companycode ,SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | getBankDataList () 銀行データ情報を取得します。
Object | getCompanyDataInfo () 会社コード依存データ情報を取得します｡
Object | getCompanycode () 得意先詳細の会社コードから値を取得します。
Object | getDebtorGetDetail () 得意先コード詳細情報を取得します｡
Object | getDebtorid () 得意先詳細の得意先コードから値を取得します。
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
Object | getGeneralDataInfo () 一般データ情報を取得します｡
コンストラクタの詳細
DebtorGetDetailController

DebtorGetDetailController (String Debtorid ,String Companycode ,SapClient sapClient)
コンストラクタ｡
パラメータ
Debtorid | String | 得意先コード
Companycode | String | 会社コード
sapClient | SapClient | SAPへの接続情報が格納されたオブジェクト
DebtorGetDetailController

DebtorGetDetailController (String Debtorid ,String Companycode ,SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
Debtorid | String | 得意先コード
Companycode | String | 会社コード
sapClient | SapClient | Sapクライアント
メソッドの詳細
getBankDataList

Object getBankDataList ()

銀行データ情報を取得します。
返却値
Object 銀行国コード(銀行データ情報)

銀行データ情報オブジェクトの構成は以下のとおりです。
銀行データ情報
オブジェクト
(Object)
CUSTOMER 得意先コード 1 (String)
BANK_CTRY 銀行国コード (String)
BANK_KEY 銀行コード (String)
BANK_ACCT 口座番号 (String)
CTRL_KEY 預金種別 (String)
PARTNER_BK 取引先銀行タイプ (String)
COLL_AUTH フラグ：回収権限 (String)
BANK_REF 銀行詳細の参照詳細 (String)

取得した銀行データ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CUSTOMER"]　→　配列内のidx番目の銀行データの「得意先コード 1」
[idx]["BANK_CTRY"]　→　配列内のidx番目の銀行データの「銀行国コード」
[idx]["BANK_KEY"]　→　配列内のidx番目の銀行データの「銀行コード」
[idx]["BANK_ACCT"]　→　配列内のidx番目の銀行データの「口座番号」
[idx]["CTRL_KEY"]　→　配列内のidx番目の銀行データの「預金種別」
[idx]["PARTNER_BK"]　→　配列内のidx番目の銀行データの「取引先銀行タイプ」
[idx]["COLL_AUTH"]　→　配列内のidx番目の銀行データの「フラグ：回収権限」
[idx]["BANK_REF"]　→　配列内のidx番目の銀行データの「銀行詳細の参照詳細」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getCompanyDataInfo

Object getCompanyDataInfo ()

会社コード依存データ情報を取得します｡
返却値
Object 会社コード依存データ

会社コード依存データ情報オブジェクトの構成は以下のとおりです。
会社コード依存データ情報
オブジェクト
(Object)
CUSTOMER 得意先コード 1 (String)
COMP_CODE 会社コード (String)
CLERK 記帳担当者 (String)
HD_OFFICE 支店勘定に登録されている本店勘定コード (String)
ALT_PAYER 代理支払人の勘定コード (String)
CUVD_CLEAR フラグ：得意先と仕入先間の相殺決済 (String)
PMNTTRMS 支払条件キー (String)
ACT_AT_CUS 得意先での自社勘定コード (String)
CUST_USER 得意先担当者 (String)
NEXT_PAYEE 次受取人 (String)
BUYING_GRP 購買グループの勘定コード (String)
INTERNET 関係会社担当者のインターネットアドレス (String)
FAX 得意先/仕入先の経理担当者のファックス No. (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getCompanycode

Object getCompanycode ()

得意先詳細の会社コードから値を取得します。

返却値
Object 会社コード
getDebtorGetDetail

Object getDebtorGetDetail ()

得意先コード詳細情報を取得します｡

返却値
Object 得意先マスタ
getDebtorid

Object getDebtorid ()

得意先詳細の得意先コードから値を取得します。

返却値
Object 得意先コード
getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getGeneralDataInfo

Object getGeneralDataInfo ()

一般データ情報を取得します｡
返却値
Object 一般データ

一般データ情報オブジェクトの構成は以下のとおりです。
一般データ情報
オブジェクト
(Object)
CUSTOMER 得意先コード 1 (String)
NAME 名称 1 (String)
NAME_2 名称 2 (String)
NAME_3 名称 3 (String)
NAME_4 名称 4 (String)
CITY 市区町村 (String)
DISTRICT 所在地 (String)
PO_BOX 私書箱 (String)
POBX_PCD 私書箱番号 (String)
POSTL_CODE 郵便番号 (String)
REGION 地域 (都道府県) (String)
COUNTYCODE 地域コード (String)
CITY_CODE 市区町村コード (String)
STREET 地名/番地-号 (String)
COUNTRY 国コード (String)
POBX_CTY 私書箱住所 (String)
LANGU 言語キー (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)


 ExchangeRateGetDetailController オブジェクト

為替換算レートコントローラクラス。

機能は以下の通り
  • 為替換算レート情報を取得します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
ExchangeRateGetDetailController (String rateType ,String fromCurr ,String toCurrncy ,String date)
コンストラクタ｡
ExchangeRateGetDetailController (String rateType ,String fromCurr ,String toCurrncy ,String date ,SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | getDate () 為替換算レートの起算日から値を取得します。
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
Object | getExchRate () 為替換算レートの換算レート、係数 (通貨ペア)から値を取得します。
Object | getFromCurr () 為替換算レートの換算前通貨から値を取得します。
Object | getRateType () 為替換算レートの換算レートタイプから値を取得します。
Object | getToCurrncy () 為替換算レートの換算後通貨から値を取得します。
void | setDate (String value) 為替換算レートの起算日に値を設定します。
void | setFromCurr (String value) 為替換算レートの換算前通貨に値を設定します。
void | setRateType (String value) 為替換算レートの換算レートタイプに値を設定します。
void | setTo_Currncy (String value) 為替換算レートの換算後通貨に値を設定します。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
ExchangeRateGetDetailController

ExchangeRateGetDetailController (String rateType ,String fromCurr ,String toCurrncy ,String date)
コンストラクタ｡
パラメータ
rateType | String | 換算レートタイプ
fromCurr | String | 換算前通貨
toCurrncy | String | 換算後通貨
date | String | 起算日
ExchangeRateGetDetailController

ExchangeRateGetDetailController (String rateType ,String fromCurr ,String toCurrncy ,String date ,SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
rateType | String | 換算レートタイプ
fromCurr | String | 換算前通貨
toCurrncy | String | 換算後通貨
date | String | 起算日
sapClient | SapClient | Sapクライアント
メソッドの詳細
getDate

Object getDate ()

為替換算レートの起算日から値を取得します。

返却値
Object 起算日
getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getExchRate

Object getExchRate ()

為替換算レートの換算レート、係数 (通貨ペア)から値を取得します。
返却値
Object 換算レート、係数 (通貨ペア)

為替換算レートの換算レート、係数 (通貨ペア)情報オブジェクトの構成は以下のとおりです。
為替換算レートの換算レート、係数 (通貨ペア)情報
オブジェクト
(Object)
RATE_TYPE 換算レートタイプ (String)
FROM_CURR 換算前通貨 (String)
TO_CURRNCY 換算後通貨 (String)
VALID_FROM エントリの有効開始日 (String)
EXCH_RATE 直接呼び値換算レート (String)
FROM_FACTOR 換算前 通貨単位の係数 (String)
TO_FACTOR 換算後 通貨単位の係数 (String)
EXCH_RATE_V 間接呼び値換算レート (String)
FROM_FACTOR_V 換算前 通貨単位の係数 (String)
TO_FACTOR_V 換算後 通貨単位の係数 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getFromCurr

Object getFromCurr ()

為替換算レートの換算前通貨から値を取得します。

返却値
Object 換算前通貨
getRateType

Object getRateType ()

為替換算レートの換算レートタイプから値を取得します。

返却値
Object 換算レートタイプ
getToCurrncy

Object getToCurrncy ()

為替換算レートの換算後通貨から値を取得します。

返却値
Object 換算後通貨
setDate

void setDate (String value)

為替換算レートの起算日に値を設定します。
パラメータ
value String 起算日
返却値
void
setFromCurr

void setFromCurr (String value)

為替換算レートの換算前通貨に値を設定します。
パラメータ
value String 換算前通貨
返却値
void
setRateType

void setRateType (String value)

為替換算レートの換算レートタイプに値を設定します。
パラメータ
value String 換算レートタイプ
返却値
void
setTo_Currncy

void setTo_Currncy (String value)

為替換算レートの換算後通貨に値を設定します。
パラメータ
value String 換算後通貨
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 GlAccController オブジェクト

勘定科目コントローラクラス。

勘定科目の情報を取得します。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
GlAccController (String companyCode)
コンストラクタ。
GlAccController (String companyCode ,SapClient sapClient)
コンストラクタ。
GlAccController (String companyCode ,String language ,String languageIso)
コンストラクタ。
GlAccController (String companyCode ,String language ,String languageIso ,SapClient sapClient)
コンストラクタ。
メソッドの概要
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
Array | getGlAccList () 勘定科目一覧を取得します。
Object | getLongText (String glAccount) 総勘定元帳勘定テキスト(長)を取得します。
Object | getShortText (String glAccount) G/L勘定コードテキスト(短)を取得します。
コンストラクタの詳細
GlAccController

GlAccController (String companyCode)
コンストラクタ。

引数１つのコンストラクタです。
指定した会社コードで有効な勘定科目が抽出対象となります。
パラメータ
companyCode String 会社コード String SAP上に存在する会社コード
GlAccController

GlAccController (String companyCode ,SapClient sapClient)
コンストラクタ。

引数２つのコンストラクタです。
指定した会社コードで有効な勘定科目が抽出対象となります。
SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
companyCode | String | 会社コード
sapClient | SapClient | Sapクライアント
GlAccController

GlAccController (String companyCode ,String language ,String languageIso)
コンストラクタ。

引数３つのコンストラクタです。
指定した会社コード・言語・ISO639準拠の言語 で有効な勘定科目が抽出対象となります。
パラメータ
companyCode | String | 会社コード
language | String | 言語
languageIso | String | ISO639準拠の言語
GlAccController

GlAccController (String companyCode ,String language ,String languageIso ,SapClient sapClient)
コンストラクタ。

引数４つのコンストラクタです。
指定した会社コード・言語・ISO639準拠の言語 で有効な勘定科目が抽出対象となります。
SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
companyCode | String | 会社コード
language | String | 言語
languageIso | String | ISO639準拠の言語
sapClient | SapClient | Sapクライアント
メソッドの詳細
getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getGlAccList

Array getGlAccList ()

勘定科目一覧を取得します。

返却値
Array 勘定科目情報が格納された配列

勘定科目情報オブジェクトの構成は以下のとおりです。
勘定科目情報
オブジェクト
(Object)
COMPANY_CODE 会社コード (String)
GL_ACCOUNT G/L勘定コード (String)
SHORT_TEXT G/L勘定コードテキスト(短) (String)
LONG_TEXT 総勘定元帳勘定テキスト(長) (String)

取得した勘定科目情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["COMPANY_CODE"]　→　配列内のidx番目の勘定科目の「会社コード」
[idx]["GL_ACCOUNT"]　→　配列内のidx番目の勘定科目の「G/L勘定コード」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の勘定科目の「G/L勘定コードテキスト(短)」
[idx]["LONG_TEXT"]　→　配列内のidx番目の勘定科目の「総勘定元帳勘定テキスト(長)」

※ idxは0〜n （配列サイズ-1）

getLongText

Object getLongText (String glAccount)

総勘定元帳勘定テキスト(長)を取得します。

G/L勘定コードを指定して総勘定元帳勘定テキスト(長)を取得します。
パラメータ
glAccount String SAP上に存在するG/L勘定コード
返却値
Object 指定したG/L勘定コードに対応する総勘定元帳勘定テキスト(長)
（成功時の返却値は String になります。）
（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getShortText

Object getShortText (String glAccount)

G/L勘定コードテキスト(短)を取得します。

G/L勘定コードを指定してG/L勘定コードテキスト(短)を取得します。
パラメータ
glAccount String SAP上に存在するG/L勘定コード
返却値
Object 指定したG/L勘定コードに対応するG/L勘定コードテキスト(短)
（成功時の返却値は String になります。）
（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)


 GoodsMvtCreateController オブジェクト

入出庫伝票登録コントローラクラス。

機能は以下の通り
  • 入出庫伝票を登録します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
GoodsMvtCreateController ()
コンストラクタ｡
GoodsMvtCreateController (ConnectionManager connectionManager)
コンストラクタ。
GoodsMvtCreateController (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより入出庫伝票を登録します。
String | getBapiReturnErrMessage () ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage () プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。
Object | getExtensioninList () Reference Structureを取得します。
Object | getGoodsMvtCode () 在庫移動に対するコードのトランザクションへの割当を取得します。
Object | getGoodsMvtHeader () 入出庫伝票ヘッダデータを取得します｡
Object | getGoodsMvtHeadret () 入出庫伝票番号/入出庫伝票会計年度を取得します。
Object | getGoodsMvtItemList () 入出庫伝票一覧を取得します。
Object | getGoodsMvtRefEwm () BAdI 通信構造: 入出庫伝票 EWM 照会を取得します。
Object | getGoodsMvtSerialNumberList () シリアル番号を取得します。
Object | getGoodsMvtServPartDataList () サービスパーツデータを取得します。
String | getMatdocumentyear () 入出庫伝票会計年度を取得します。
value | getTestrun () 在庫移動シミュレーションを取得します｡
void | setStrParam (String paramStr ,String paramName ,Object value) 構造型の項目に値をセットします。
void | setTblParam (String paramTable ,String paramName ,Object value ,int index) テーブル型の項目に値をセットします。
void | setTestrun (Object value) 在庫移動シミュレーションを設定します｡
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
GoodsMvtCreateController

GoodsMvtCreateController ()
コンストラクタ｡
GoodsMvtCreateController

GoodsMvtCreateController (ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、GoodsMvtCreateController#executeBapi()実行後に必ず ConnectionManager#commit()またはConnectionManager#rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。
パラメータ
connectionManager ConnectionManager コネクションマネージャー
GoodsMvtCreateController

GoodsMvtCreateController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより入出庫伝票を登録します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getBapiReturnErrMessage

String getBapiReturnErrMessage ()

ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡
返却値
String BAPI実行結果エラーとなった全てのメッセージ情報
getBapiReturnMessage

String getBapiReturnMessage ()

プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡
返却値
String プロパティファイルでオートコミット条件に一致したType情報のメッセージ情報
getExtensioninList

Object getExtensioninList ()

Reference Structureを取得します。
返却値
Object Reference Structure

Reference Structure情報オブジェクトの構成は以下のとおりです。
Reference Structure
オブジェクト
(Object)
STRUCTURE BAPI テーブル拡張の構造名 (String)
VALUEPART1 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART2 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART3 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART4 BAPI 拡張パラメータのデータ部分 (String)

取得した需要予測パラメータ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["STRUCTURE"]　→　配列内のidx番目のシリアル番号の「入出庫伝票の明細」
[idx]["VALUEPART1"]　→　配列内のidx番目のシリアル番号の「シリアル番号」
[idx]["VALUEPART2"]　→　配列内のidx番目のシリアル番号の「入出庫伝票の明細」
[idx]["VALUEPART3"]　→　配列内のidx番目のシリアル番号の「シリアル番号」
[idx]["VALUEPART4"]　→　配列内のidx番目のシリアル番号の「入出庫伝票の明細」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getGoodsMvtCode

Object getGoodsMvtCode ()

在庫移動に対するコードのトランザクションへの割当を取得します。
返却値
Object 在庫移動に対するコードのトランザクションへの割当

在庫移動に対するコードのトランザクションへの割当の順序情報オブジェクトの構成は以下のとおりです。
在庫移動に対するコードのトランザクションへの割当の順序情報
オブジェクト
(Object)
GM_CODEBAPI 在庫移動トランザクションのコード割当(String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getGoodsMvtHeader

Object getGoodsMvtHeader ()

入出庫伝票ヘッダデータを取得します｡
返却値
Object 入出庫伝票ヘッダデータ

入出庫伝票ヘッダデータの順序情報オブジェクトの構成は以下のとおりです。
入出庫伝票ヘッダデータの順序情報
オブジェクト
(Object)
PSTNG_DATE伝票の転記日付(String)
DOC_DATE伝票の伝票日付(String)
REF_DOC_NO参照伝票番号(String)
BILL_OF_LADING入庫時に登録した B/L 番号(String)
GR_GI_SLIP_NO入出庫票番号(String)
PR_UNAMEユーザ名(String)
HEADER_TXT伝票ヘッダテキスト(String)
VER_GR_GI_SLIP入出庫票の印刷バ−ジョン(String)
VER_GR_GI_SLIPX関連ユーザデータ項目の更新情報(String)
EXT_WMS外部倉庫管理の転記の制御(String)
REF_DOC_NO_LONG参照伝票番号 (依存性についてはテキスト長参照)(String)
BILL_OF_LADING_LONG入庫の船荷証券番号 (依存: テキスト (長) 参照)(String)
BAR_CODEバーコードエントリ(String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getGoodsMvtHeadret

Object getGoodsMvtHeadret ()

入出庫伝票番号/入出庫伝票会計年度を取得します。
返却値
Object 入出庫伝票番号/入出庫伝票会計年度

入出庫伝票番号/入出庫伝票会計年度オブジェクトの構成は以下のとおりです。
入出庫伝票番号/入出庫伝票会計年度
オブジェクト
(Object)
MAT_DOC 入出庫伝票番号 (String)
DOC_YEAR 入出庫伝票年度 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getGoodsMvtItemList

Object getGoodsMvtItemList ()

入出庫伝票一覧を取得します。
返却値
Object 入出庫伝票一覧

入出庫伝票一覧情報オブジェクトの構成は以下のとおりです。
入出庫伝票一覧
オブジェクト
(Object)
MATERIAL 品目コード (String)
PLANT プラント (String)
STGE_LOC 保管場所 (String)
BATCH ロット番号 (String)
MOVE_TYPE 移動タイプ (在庫管理) (String)
STCK_TYPE 在庫タイプ (String)
SPEC_STOCK 特殊在庫区分 (String)
VENDOR 仕入先勘定コード (String)
CUSTOMER 得意先コード (String)
SALES_ORD 受注伝票番号 (String)
S_ORD_ITEM 受注明細番号 (String)
SCHED_LINE 受注納入日程 (String)
VAL_TYPE 評価タイプ (String)
ENTRY_QNT 入力単位での数量 (String)
ENTRY_UOM 入力単位 (String)
ENTRY_UOM_ISO 単位の ISO コード (String)
PO_PR_QNT 数量 (購買発注価格単位) (String)
ORDERPR_UN 購買発注価格単位 (購買管理) (String)
ORDERPR_UN_ISO 単位の ISO コード (String)
PO_NUMBER 購買発注番号 (String)
PO_ITEM 購買伝票の明細番号 (String)
SHIPPING 出荷指示 (String)
COMP_SHIP 出荷指示順守 (String)
NO_MORE_GR 納入完了 区分 (String)
ITEM_TEXT 明細テキスト (String)
GR_RCPT 受領者 (String)
UNLOAD_PT 荷渡ポイント (String)
COSTCENTER 原価センタ (String)
ORDERID 指図番号 (String)
ORDER_ITNO 指図明細番号 (String)
CALC_MOTIVE 計算区分 (String)
ASSET_NO 資産番号 (String)
SUB_NUMBER 資産補助番号 (String)
RESERV_NO 入出庫予定/従属所要量の番号 (String)
RES_ITEM 入出庫予定/従属所要量の明細番号 (String)
RES_TYPE レコードタイプ (String)
WITHDRAWN 入出庫予定に対する出庫完了 (String)
MOVE_MAT 入庫/出庫品目 (String)
MOVE_PLANT 入庫/出庫プラント (String)
MOVE_STLOC 入庫/出庫保管場所 (String)
MOVE_BATCH 入庫/出庫ロット (String)
MOVE_VAL_TYPE 転送ロットの評価タイプ (String)
MVT_IND 移動区分 (String)
MOVE_REAS 移動理由 (String)
RL_EST_KEY 不動産管理対象の内部キー (String)
REF_DATE 決済の参照日付 (String)
COST_OBJ 原価対象 (String)
PROFIT_SEGM_NO 収益性セグメント番号 (CO-PA) (String)
PROFIT_CTR 利益センタ (String)
WBS_ELEM WBS 要素 (String)
NETWORK 勘定割当のネットワーク番号 (String)
ACTIVITY 作業番号 (String)
PART_ACCT 取引先勘定コード (String)
AMOUNT_LC マニュアル入力による転記金額 (国内通貨) (String)
AMOUNT_SV 外部入力による販売金額 (国内通貨) (String)
REF_DOC_YR 参照伝票の会計年度 (String)
REF_DOC 参照伝票の伝票番号 (String)
REF_DOC_IT 参照伝票の明細番号 (String)
EXPIRYDATE 有効期間期限日 (String)
PROD_DATE ロット製造日付 (String)
FUND 会計区分 (String)
FUNDS_CTR 予算センタ (String)
CMMT_ITEM 資金予算コード (String)
VAL_SALES_ORD 評価受注在庫の受注番号 (String)
VAL_S_ORD_ITEM 評価受注在庫の受注明細 (String)
VAL_WBS_ELEM WBS 要素 (String)
GL_ACCOUNT G/L 勘定コード (String)
IND_PROPOSE_QUANX 提案数量 (初期数量) (String)
XSTOB 取消移動タイプ区分の使用 (String)
EAN_UPC 国際商品コード (EAN/UPC) (String)
DELIV_NUMB_TO_SEARCH 出荷伝票 (String)
DELIV_ITEM_TO_SEARCH 出荷明細 (String)
SERIALNO_AUTO_NUMBERASSIGNMENT シリアル番号の自動登録 (String)
VENDRBATCH 仕入先ロット番号 (String)
STGE_TYPE 保管域タイプ (String)
STGE_BIN 棚番 (String)
SU_PL_STCK_1 在庫受入予定の保管単位数 (String)
ST_UN_QTYY_1 代替数量単位での在庫受入予定保管単位別数量 (String)
ST_UN_QTYY_1_ISO 単位の ISO コード (String)
UNITTYPE_1 保管単位タイプ (String)
SU_PL_STCK_2 在庫受入予定の保管単位数 (String)
ST_UN_QTYY_2 代替数量単位での在庫受入予定保管単位別数量 (String)
ST_UN_QTYY_2_ISO 単位の ISO コード (String)
UNITTYPE_2 保管単位タイプ (String)
STGE_TYPE_PC 在庫転送の保管域タイプ (String)
STGE_BIN_PC 在庫転送棚番 (String)
NO_PST_CHGNT 区分: 振替要求通知登録禁止 (String)
GR_NUMBER 入庫番号 (String)
STGE_TYPE_ST 在庫転送の保管域タイプ (String)
STGE_BIN_ST 在庫転送棚番 (String)
MATDOC_TR_CANCEL 取消予定の転送要求の入出庫伝票番号 (String)
MATITEM_TR_CANCEL 取消予定の転送数量入出庫伝票明細 (String)
MATYEAR_TR_CANCEL 取消予定の転送要求入出庫伝票年度 (String)
NO_TRANSFER_REQ 区分: 転送要求未登録 (String)
CO_BUSPROC 業務プロセス (String)
ACTTYPE 活動タイプ (String)
SUPPL_VEND 供給仕入先 (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード (長) (今後のリリースで開発) (String)
MATERIAL_GUID 項目 MATERIAL の外部 GUID (今後のリリースで開発) (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (今後のリリースで開発) (String)
MOVE_MAT_EXTERNAL 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発) (String)
MOVE_MAT_GUID 項目 MOVE_MAT の外部 GUID (今後のリリースで開発) (String)
MOVE_MAT_VERSION 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発) (String)
FUNC_AREA 機能領域 (String)
TR_PART_BA 取引会社事業領域 (String)
PAR_COMPCO 決済会社コード (String)
DELIV_NUMB 出荷伝票 (String)
DELIV_ITEM 出荷明細 (String)
NB_SLIPS 入庫/出庫票の印刷部数 (String)
NB_SLIPSX 関連ユーザデータ項目の更新情報 (String)
GR_RCPTX 関連ユーザデータ項目の更新情報 (String)
UNLOAD_PTX 関連ユーザデータ項目の更新情報 (String)
SPEC_MVMT 倉庫管理の特殊移動区分 (String)
GRANT_NBR 補助金 (String)
CMMT_ITEM_LONG 資金予算コード (String)
FUNC_AREA_LONG 機能領域 (String)
LINE_ID 伝票明細行の一意 ID (String)
PARENT_ID 1 レベル上位の行 ID (String)
LINE_DEPTH 伝票での明細行階層レベル (String)
QUANTITY 数量 (String)
BASE_UOM 基本数量単位 (String)
LONGNUM Long Procurement Document Number (String)

取得した入出庫伝票情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["MATERIAL"]　→　配列内のidx番目の入出庫伝票の「品目コード」
[idx]["PLANT"]　→　配列内のidx番目の入出庫伝票の「プラント」
[idx]["STGE_LOC"]　→　配列内のidx番目の入出庫伝票の「保管場所」
[idx]["BATCH"]　→　配列内のidx番目の入出庫伝票の「ロット番号」
[idx]["MOVE_TYPE"]　→　配列内のidx番目の入出庫伝票の「移動タイプ (在庫管理)」
[idx]["STCK_TYPE"]　→　配列内のidx番目の入出庫伝票の「在庫タイプ」
[idx]["SPEC_STOCK"]　→　配列内のidx番目の入出庫伝票の「特殊在庫区分」
[idx]["VENDOR"]　→　配列内のidx番目の入出庫伝票の「仕入先勘定コード」
[idx]["CUSTOMER"]　→　配列内のidx番目の入出庫伝票の「得意先コード」
[idx]["SALES_ORD"]　→　配列内のidx番目の入出庫伝票の「受注伝票番号」
[idx]["S_ORD_ITEM"]　→　配列内のidx番目の入出庫伝票の「受注明細番号」
[idx]["SCHED_LINE"]　→　配列内のidx番目の入出庫伝票の「受注納入日程」
[idx]["VAL_TYPE"]　→　配列内のidx番目の入出庫伝票の「評価タイプ」
[idx]["ENTRY_QNT"]　→　配列内のidx番目の入出庫伝票の「入力単位での数量」
[idx]["ENTRY_UOM"]　→　配列内のidx番目の入出庫伝票の「入力単位」
[idx]["ENTRY_UOM_ISO"]　→　配列内のidx番目の入出庫伝票の「単位の ISO コード」
[idx]["PO_PR_QNT"]　→　配列内のidx番目の入出庫伝票の「数量 (購買発注価格単位)」
[idx]["ORDERPR_UN"]　→　配列内のidx番目の入出庫伝票の「購買発注価格単位 (購買管理)」
[idx]["ORDERPR_UN_ISO"]　→　配列内のidx番目の入出庫伝票の「単位の ISO コード」
[idx]["PO_NUMBER"]　→　配列内のidx番目の入出庫伝票の「購買発注番号」
[idx]["PO_ITEM"]　→　配列内のidx番目の入出庫伝票の「購買伝票の明細番号」
[idx]["SHIPPING"]　→　配列内のidx番目の入出庫伝票の「出荷指示」
[idx]["COMP_SHIP"]　→　配列内のidx番目の入出庫伝票の「出荷指示順守」
[idx]["NO_MORE_GR"]　→　配列内のidx番目の入出庫伝票の「納入完了 区分」
[idx]["ITEM_TEXT"]　→　配列内のidx番目の入出庫伝票の「明細テキスト」
[idx]["GR_RCPT"]　→　配列内のidx番目の入出庫伝票の「受領者」
[idx]["UNLOAD_PT"]　→　配列内のidx番目の入出庫伝票の「荷渡ポイント」
[idx]["COSTCENTER"]　→　配列内のidx番目の入出庫伝票の「原価センタ」
[idx]["ORDERID"]　→　配列内のidx番目の入出庫伝票の「指図番号」
[idx]["ORDER_ITNO"]　→　配列内のidx番目の入出庫伝票の「指図明細番号」
[idx]["CALC_MOTIVE"]　→　配列内のidx番目の入出庫伝票の「計算区分」
[idx]["ASSET_NO"]　→　配列内のidx番目の入出庫伝票の「資産番号」
[idx]["SUB_NUMBER"]　→　配列内のidx番目の入出庫伝票の「資産補助番号」
[idx]["RESERV_NO"]　→　配列内のidx番目の入出庫伝票の「入出庫予定/従属所要量の番号」
[idx]["RES_ITEM"]　→　配列内のidx番目の入出庫伝票の「入出庫予定/従属所要量の明細番号」
[idx]["RES_TYPE"]　→　配列内のidx番目の入出庫伝票の「レコードタイプ」
[idx]["WITHDRAWN"]　→　配列内のidx番目の入出庫伝票の「入出庫予定に対する出庫完了」
[idx]["MOVE_MAT"]　→　配列内のidx番目の入出庫伝票の「入庫/出庫品目」
[idx]["MOVE_PLANT"]　→　配列内のidx番目の入出庫伝票の「入庫/出庫プラント」
[idx]["MOVE_STLOC"]　→　配列内のidx番目の入出庫伝票の「入庫/出庫保管場所」
[idx]["MOVE_BATCH"]　→　配列内のidx番目の入出庫伝票の「入庫/出庫ロット」
[idx]["MOVE_VAL_TYPE"]　→　配列内のidx番目の入出庫伝票の「転送ロットの評価タイプ」
[idx]["MVT_IND"]　→　配列内のidx番目の入出庫伝票の「移動区分」
[idx]["MOVE_REAS"]　→　配列内のidx番目の入出庫伝票の「移動理由」
[idx]["RL_EST_KEY"]　→　配列内のidx番目の入出庫伝票の「不動産管理対象の内部キー」
[idx]["REF_DATE"]　→　配列内のidx番目の入出庫伝票の「決済の参照日付」
[idx]["COST_OBJ"]　→　配列内のidx番目の入出庫伝票の「原価対象」
[idx]["PROFIT_SEGM_NO"]　→ 　配列内のidx番目の入出庫伝票の「収益性セグメント番号 (CO-PA)」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の入出庫伝票の「利益センタ」
[idx]["WBS_ELEM"]　→　配列内のidx番目の入出庫伝票の「WBS 要素」
[idx]["NETWORK"]　→　配列内のidx番目の入出庫伝票の「勘定割当のネットワーク番号」
[idx]["ACTIVITY"]　→　配列内のidx番目の入出庫伝票の「作業番号」
[idx]["PART_ACCT"]　→　配列内のidx番目の入出庫伝票の「取引先勘定コード」
[idx]["AMOUNT_LC"]　→ 　配列内のidx番目の入出庫伝票の「マニュアル入力による転記金額 (国内通貨)」
[idx]["AMOUNT_SV"]　→ 　配列内のidx番目の入出庫伝票の「外部入力による販売金額 (国内通貨)」
[idx]["REF_DOC_YR"]　→　配列内のidx番目の入出庫伝票の「参照伝票の会計年度」
[idx]["REF_DOC"]　→　配列内のidx番目の入出庫伝票の「参照伝票の伝票番号」
[idx]["REF_DOC_IT"]　→　配列内のidx番目の入出庫伝票の「参照伝票の明細番号」
[idx]["EXPIRYDATE"]　→　配列内のidx番目の入出庫伝票の「有効期間期限日」
[idx]["PROD_DATE"]　→　配列内のidx番目の入出庫伝票の「ロット製造日付」
[idx]["FUND"]　→　配列内のidx番目の入出庫伝票の「会計区分」
[idx]["FUNDS_CTR"]　→　配列内のidx番目の入出庫伝票の「予算センタ」
[idx]["CMMT_ITEM"]　→　配列内のidx番目の入出庫伝票の「資金予算コード」
[idx]["VAL_SALES_ORD"]　→　配列内のidx番目の入出庫伝票の「評価受注在庫の受注番号」
[idx]["VAL_S_ORD_ITEM"]　→　配列内のidx番目の入出庫伝票の「評価受注在庫の受注明細」
[idx]["VAL_WBS_ELEM"]　→　配列内のidx番目の入出庫伝票の「WBS 要素」
[idx]["GL_ACCOUNT"]　→　配列内のidx番目の入出庫伝票の「G/L 勘定コード」
[idx]["IND_PROPOSE_QUANX"]　→ 　配列内のidx番目の入出庫伝票の「提案数量 (初期数量)」
[idx]["XSTOB"]　→　配列内のidx番目の入出庫伝票の「取消移動タイプ区分の使用」
[idx]["EAN_UPC"]　→　配列内のidx番目の入出庫伝票の「国際商品コード (EAN/UPC)」
[idx]["DELIV_NUMB_TO_SEARCH"]　→　配列内のidx番目の入出庫伝票の「出荷伝票」
[idx]["DELIV_ITEM_TO_SEARCH"]　→　配列内のidx番目の入出庫伝票の「出荷明細」
[idx]["SERIALNO_AUTO_NUMBERASSIGNMENT"]　→ 　配列内のidx番目の入出庫伝票の「シリアル番号の自動登録」
[idx]["VENDRBATCH"]　→　配列内のidx番目の入出庫伝票の「仕入先ロット番号」
[idx]["STGE_TYPE"]　→　配列内のidx番目の入出庫伝票の「保管域タイプ」
[idx]["STGE_BIN"]　→　配列内のidx番目の入出庫伝票の「棚番」
[idx]["SU_PL_STCK_1"]　→　配列内のidx番目の入出庫伝票の「在庫受入予定の保管単位数」
[idx]["ST_UN_QTYY_1"]　→ 　配列内のidx番目の入出庫伝票の「代替数量単位での在庫受入予定保管単位別数量」
[idx]["ST_UN_QTYY_1_ISO"]　→ 　配列内のidx番目の入出庫伝票の「単位の ISO コード」
[idx]["UNITTYPE_1"]　→　配列内のidx番目の入出庫伝票の「保管単位タイプ」
[idx]["SU_PL_STCK_2"]　→　配列内のidx番目の入出庫伝票の「在庫受入予定の保管単位数」
[idx]["ST_UN_QTYY_2"]　→ 　配列内のidx番目の入出庫伝票の「代替数量単位での在庫受入予定保管単位別数量」
[idx]["ST_UN_QTYY_2_ISO"]　→ 　配列内のidx番目の入出庫伝票の「単位の ISO コード」
[idx]["UNITTYPE_2"]　→　配列内のidx番目の入出庫伝票の「保管単位タイプ」
[idx]["STGE_TYPE_PC"]　→　配列内のidx番目の入出庫伝票の「在庫転送の保管域タイプ」
[idx]["STGE_BIN_PC"]　→　配列内のidx番目の入出庫伝票の「在庫転送棚番」
[idx]["NO_PST_CHGNT"]　→　配列内のidx番目の入出庫伝票の「区分: 振替要求通知登録禁止」
[idx]["GR_NUMBER"]　→　配列内のidx番目の入出庫伝票の「入庫番号」
[idx]["STGE_TYPE_ST"]　→　配列内のidx番目の入出庫伝票の「在庫転送の保管域タイプ」
[idx]["STGE_BIN_ST"]　→　配列内のidx番目の入出庫伝票の「在庫転送棚番」
[idx]["MATDOC_TR_CANCEL"]　→ 　配列内のidx番目の入出庫伝票の「取消予定の転送要求の入出庫伝票番号」
[idx]["MATITEM_TR_CANCEL"]　→ 　配列内のidx番目の入出庫伝票の「取消予定の転送数量入出庫伝票明細」
[idx]["MATYEAR_TR_CANCEL"]　→ 　配列内のidx番目の入出庫伝票の「取消予定の転送要求入出庫伝票年度」
[idx]["NO_TRANSFER_REQ"]　→　配列内のidx番目の入出庫伝票の「区分: 転送要求未登録」
[idx]["CO_BUSPROC"]　→　配列内のidx番目の入出庫伝票の「業務プロセス」
[idx]["ACTTYPE"]　→　配列内のidx番目の入出庫伝票の「活動タイプ」
[idx]["SUPPL_VEND"]　→　配列内のidx番目の入出庫伝票の「供給仕入先」
[idx]["MATERIAL_EXTERNAL"]　→ 　配列内のidx番目の入出庫伝票の「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["MATERIAL_GUID"]　→ 　配列内のidx番目の入出庫伝票の「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["MATERIAL_VERSION"]　→ 　配列内のidx番目の入出庫伝票の「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」
[idx]["MOVE_MAT_EXTERNAL"]　→ 　配列内のidx番目の入出庫伝票の「項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)」
[idx]["MOVE_MAT_GUID"]　→ 　配列内のidx番目の入出庫伝票の「項目 MOVE_MAT の外部 GUID (今後のリリースで開発)」
[idx]["MOVE_MAT_VERSION"]　→ 　配列内のidx番目の入出庫伝票の「項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)」
[idx]["FUNC_AREA"]　→　配列内のidx番目の入出庫伝票の「機能領域」
[idx]["TR_PART_BA"]　→　配列内のidx番目の入出庫伝票の「取引会社事業領域」
[idx]["PAR_COMPCO"]　→　配列内のidx番目の入出庫伝票の「決済会社コード」
[idx]["DELIV_NUMB"]　→　配列内のidx番目の入出庫伝票の「出荷伝票」
[idx]["DELIV_ITEM"]　→　配列内のidx番目の入出庫伝票の「出荷明細」
[idx]["NB_SLIPS"]　→　配列内のidx番目の入出庫伝票の「入庫/出庫票の印刷部数」
[idx]["NB_SLIPSX"]　→　配列内のidx番目の入出庫伝票の「関連ユーザデータ項目の更新情報」
[idx]["GR_RCPTX"]　→　配列内のidx番目の入出庫伝票の「関連ユーザデータ項目の更新情報」
[idx]["UNLOAD_PTX"]　→　配列内のidx番目の入出庫伝票の「関連ユーザデータ項目の更新情報」
[idx]["SPEC_MVMT"]　→　配列内のidx番目の入出庫伝票の「倉庫管理の特殊移動区分」
[idx]["GRANT_NBR"]　→　配列内のidx番目の入出庫伝票の「補助金」
[idx]["CMMT_ITEM_LONG"]　→　配列内のidx番目の入出庫伝票の「資金予算コード」
[idx]["FUNC_AREA_LONG"]　→　配列内のidx番目の入出庫伝票の「機能領域」
[idx]["LINE_ID"]　→　配列内のidx番目の入出庫伝票の「伝票明細行の一意 ID」
[idx]["PARENT_ID"]　→　配列内のidx番目の入出庫伝票の「1 レベル上位の行 ID」
[idx]["LINE_DEPTH"]　→　配列内のidx番目の入出庫伝票の「伝票での明細行階層レベル」
[idx]["QUANTITY"]　→　配列内のidx番目の入出庫伝票の「数量」
[idx]["BASE_UOM"]　→　配列内のidx番目の入出庫伝票の「基本数量単位」
[idx]["LONGNUM"]　→　配列内のidx番目の入出庫伝票の「Long Procurement Document Number」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getGoodsMvtRefEwm

Object getGoodsMvtRefEwm ()

BAdI 通信構造: 入出庫伝票 EWM 照会を取得します。
返却値
Object BAdI 通信構造: 入出庫伝票 EWM 照会

BAdI 通信構造: 入出庫伝票 EWM 照会の順序情報オブジェクトの構成は以下のとおりです。
BAdI 通信構造: 入出庫伝票 EWM 照会の順序情報
オブジェクト
(Object)
REF_DOC_EWMEWM 入出庫伝票番号(String)
LOGSYSEWM 入出庫伝票番号(String)
GTS_SCRAP_NO廃棄処理の税関参照番号(String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getGoodsMvtSerialNumberList

Object getGoodsMvtSerialNumberList ()

シリアル番号を取得します。
返却値
Object シリアル番号

シリアル番号情報オブジェクトの構成は以下のとおりです。
シリアル番号
オブジェクト
(Object)
MATDOC_ITM 入出庫伝票の明細 (String)
SERIALNO シリアル番号 (String)

取得した需要予測パラメータ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["MATDOC_ITM"]　→　配列内のidx番目のシリアル番号の「入出庫伝票の明細」
[idx]["SERIALNO"]　→　配列内のidx番目のシリアル番号の「シリアル番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getGoodsMvtServPartDataList

Object getGoodsMvtServPartDataList ()

サービスパーツデータを取得します。
返却値
Object

オブジェクトの構成は以下のとおりです。

オブジェクト
(Object)
LINE_ID 伝票明細行の一意 ID (String)
RET_AUTH_NUMBER 返品権限番号 (String)
DELIV_NUMBER 出荷伝票 (String)
DELIV_ITEM 出荷明細 (String)
HU_NUMBER 外部荷役単位 ID (String)
INSPOUT_GUID 品質検査結果: EWM 設定の在庫 GUID (String)
EVENT 論理時間 (String)
DATE 日付 (String)
TIME 時刻 (String)
ZONLE 現在のユーザのタイムゾーン (String)
TIMESTAMP 取引開始時刻 (UTCタイムスタンプ) (String)
SCRAP_INDICATOR EWM 処理の廃棄区分 (String)
KEEP_QUANTITY EWM での廃棄処理の保持数量 (String)
GTS_STOCK_TYPE GTS在庫タイプ (String)
MOVE_GTS_STOCK_TYPE GTS在庫タイプ (String)

取得した需要予測パラメータ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["LINE_ID"]　→　配列内のidx番目の「伝票明細行の一意 ID」
[idx]["RET_AUTH_NUMBER"]　→　配列内のidx番目の「返品権限番号」
[idx]["DELIV_NUMBER"]　→　配列内のidx番目の「出荷伝票」
[idx]["DELIV_ITEM"]　→　配列内のidx番目の「出荷明細」
[idx]["HU_NUMBER"]　→　配列内のidx番目の「外部荷役単位 ID」
[idx]["INSPOUT_GUID"]　→　配列内のidx番目の「品質検査結果: EWM 設定の在庫 GUID」
[idx]["EVENT"]　→　配列内のidx番目の「論理時間」
[idx]["DATE"]　→　配列内のidx番目の「日付」
[idx]["TIME"]　→　配列内のidx番目の「時刻」
[idx]["ZONLE"]　→　配列内のidx番目の「現在のユーザのタイムゾーン」
[idx]["TIMESTAMP"]　→　配列内のidx番目の「取引開始時刻 (UTCタイムスタンプ)」
[idx]["SCRAP_INDICATOR"]　→　配列内のidx番目の「EWM 処理の廃棄区」
[idx]["KEEP_QUANTITY"]　→　配列内のidx番目の「EWM での廃棄処理の保持数量」
[idx]["GTS_STOCK_TYPE"]　→　配列内のidx番目の「GTS在庫タイプ」
[idx]["MOVE_GTS_STOCK_TYPE"]　→　配列内のidx番目の「 GTS在庫タイプ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getMatdocumentyear

String getMatdocumentyear ()

入出庫伝票会計年度を取得します。
返却値
String 入出庫伝票会計年度
getTestrun

value getTestrun ()

在庫移動シミュレーションを取得します｡
返却値
value Object 在庫移動シミュレーション
setStrParam

void setStrParam (String paramStr ,String paramName ,Object value)

構造型の項目に値をセットします。
パラメータ
paramStr | String | 構造名
paramName | String | 項目名
value | Object | セットする値
返却値
void
setTblParam

void setTblParam (String paramTable ,String paramName ,Object value ,int index)

テーブル型の項目に値をセットします。
パラメータ
paramTable | String | テーブル名
paramName | String | 項目名
value | Object | セットする値
index | int | レコード番号
返却値
void
setTestrun

void setTestrun (Object value)

在庫移動シミュレーションを設定します｡
パラメータ
value Object 在庫移動シミュレーション
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 GoodsMvtGetItemsController オブジェクト

入出庫伝票一覧照会コントローラクラス。

機能は以下の通り
  • 入出庫伝票一覧を取得します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
GoodsMvtGetItemsController ()
コンストラクタ｡
GoodsMvtGetItemsController (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより入出庫伝票一覧を取得します。
Array | getBatchRaList () ロット番号の範囲を取得します。
Array | getGoodsMvtHeaderList () 入出庫伝票ヘッダを取得します。
Array | getGoodsMvtItemsList () 入出庫伝票一覧を取得します。
Array | getMaterialRaList () 品目コードの範囲を取得します。
Array | getMoveTypeRaList () 移動タイプ範囲を取得します。
Array | getPlantRaList () プラントの範囲を取得します。
Array | getPstngDateRaList () 登録日付の範囲を取得します。
Array | getSpecStockRaList () 特殊在庫区分の範囲を取得します。
Array | getStgeLocRaList () 保管場所の範囲を取得します。
Array | getTrEvTypeRaList () トランザクション/イベントタイプの範囲を取得します。
Array | getUserNameRaList () ユーザ名の範囲を取得します。
Array | getVendorRaList () 仕入先の範囲を取得します。
void | setTblParam (String paramTable ,String paramName ,Object value ,int index) テーブル型の項目に値をセットします。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
GoodsMvtGetItemsController

GoodsMvtGetItemsController ()
コンストラクタ｡
GoodsMvtGetItemsController

GoodsMvtGetItemsController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより入出庫伝票一覧を取得します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getBatchRaList

Array getBatchRaList ()

ロット番号の範囲を取得します。
返却値
Array ロット番号の範囲

ロット番号の範囲情報オブジェクトの構成は以下のとおりです。
ロット番号の範囲情報
オブジェクト
(Object)
SIGN 選択演算子 SIGN (テーブル範囲) (String)
OPTION 選択演算子 OPTION (範囲テーブル) (String)
LOW ロット番号 (String)
HIGH ロット番号 (String)

取得したロットの範囲情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["SIGN"]　→　配列内のidx番目のロット範囲の「選択演算子 SIGN (テーブル範囲)」
[idx]["OPTION"]　→　配列内のidx番目のロット範囲の「選択演算子 OPTION (範囲テーブル)」
[idx]["LOW"]　→　配列内のidx番目のロット範囲の「ロット番号」
[idx]["HIGH"]　→　配列内のidx番目のロット範囲の「ロット番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getGoodsMvtHeaderList

Array getGoodsMvtHeaderList ()

入出庫伝票ヘッダを取得します。
返却値
Array 入出庫伝票ヘッダの範囲

入出庫伝票ヘッダ情報オブジェクトの構成は以下のとおりです。
入出庫伝票ヘッダ情報
オブジェクト
(Object)
MAT_DOC 入出庫伝票番号 (String)
DOC_YEAR 入出庫伝票年度 (String)
TR_EV_TYPE トランザクション/イベントタイプ (String)
DOC_DATE 伝票の伝票日付 (String)
PSTNG_DATE 伝票の転記日付 (String)
ENTRY_DATE 会計伝票登録日 (String)
ENTRY_TIME 登録時刻 (String)
USERNAME ユーザ名 (String)
VER_GR_GI_SLIP 入出庫票の印刷バ−ジョン (String)
EXPIMP_NO 貿易データ番号: MM/SD 伝票 (String)
REF_DOC_NO 参照伝票番号 (String)
HEADER_TXT 伝票ヘッダテキスト (String)
REF_DOC_NO_LONG 参照伝票番号 (依存性についてはテキスト長参照) (String)

入出庫伝票ヘッダ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["MAT_DOC"]　→　配列内のidx番目の入出庫伝票の「入出庫伝票番号」
[idx]["DOC_YEAR"]　→　配列内のidx番目の入出庫伝票の「入出庫伝票年度」
[idx]["TR_EV_TYPE"]　→　配列内のidx番目の入出庫伝票の「トランザクション/イベントタイプ」
[idx]["DOC_DATE"]　→　配列内のidx番目の入出庫伝票の「伝票の伝票日付」
[idx]["PSTNG_DATE"]　→　配列内のidx番目の入出庫伝票の「伝票の転記日付」
[idx]["ENTRY_DATE"]　→　配列内のidx番目の入出庫伝票の「会計伝票登録日」
[idx]["ENTRY_TIME"]　→　配列内のidx番目の入出庫伝票の「登録時刻」
[idx]["USERNAME"]　→　配列内のidx番目の入出庫伝票の「ユーザ名」
[idx]["VER_GR_GI_SLIP"]　→　配列内のidx番目の入出庫伝票の「入出庫票の印刷バ−ジョン」
[idx]["EXPIMP_NO"]　→　配列内のidx番目の入出庫伝票の「貿易データ番号: MM/SD 伝票」
[idx]["REF_DOC_NO"]　→　配列内のidx番目の入出庫伝票の「参照伝票番号」
[idx]["HEADER_TXT"]　→　配列内のidx番目の入出庫伝票の「伝票ヘッダテキスト」
[idx]["REF_DOC_NO_LONG"]　→ 　配列内のidx番目の入出庫伝票の「参照伝票番号 (依存性についてはテキスト長参照)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getGoodsMvtItemsList

Array getGoodsMvtItemsList ()

入出庫伝票一覧を取得します。
返却値
Array 入出庫伝票一覧

入出庫伝票オブジェクトの構成は以下のとおりです。
入出庫伝票
オブジェクト
(Object)
MAT_DOC 入出庫伝票番号 (String)
DOC_YEAR 入出庫伝票年度 (String)
MATDOC_ITM 入出庫伝票の明細 (String)
MATERIAL 品目コード (String)
PLANT プラント (String)
STGE_LOC 保管場所 (String)
BATCH ロット番号 (String)
MOVE_TYPE 移動タイプ (在庫管理) (String)
STCK_TYPE 在庫タイプ (String)
SPEC_STOCK 特殊在庫区分 (String)
VENDOR 仕入先勘定コード (String)
CUSTOMER 得意先コード (String)
SALES_ORD 受注伝票番号 (String)
S_ORD_ITEM 受注明細番号 (String)
SCHED_LINE 受注納入日程 (String)
VAL_TYPE 評価タイプ (String)
ENTRY_QNT 入力単位での数量 (String)
ENTRY_UOM 入力単位 (String)
ENTRY_UOM_ISO 単位の ISO コード (String)
PO_PR_QNT 数量 (購買発注価格単位) (String)
ORDERPR_UN 購買発注価格単位 (購買管理) (String)
ORDERPR_UN_ISO 単位の ISO コード (String)
PO_NUMBER 購買発注番号 (String)
PO_ITEM 購買伝票の明細番号 (String)
SHIPPING 出荷指示 (String)
COMP_SHIP 出荷指示順守 (String)
NO_MORE_GR 納入完了 区分 (String)
ITEM_TEXT 明細テキスト (String)
GR_RCPT 受領者 (String)
UNLOAD_PT 荷渡ポイント (String)
COSTCENTER 原価センタ (String)
ORDERID 指図番号 (String)
ORDER_ITNO 指図明細番号 (String)
CALC_MOTIVE 計算区分 (String)
ASSET_NO 資産番号 (String)
SUB_NUMBER 資産補助番号 (String)
RESERV_NO 入出庫予定/従属所要量の番号 (String)
RES_ITEM 入出庫予定/従属所要量の明細番号 (String)
RES_TYPE レコードタイプ (String)
WITHDRAWN 入出庫予定に対する出庫完了 (String)
MOVE_MAT 入庫/出庫品目 (String)
MOVE_PLANT 入庫/出庫プラント (String)
MOVE_STLOC 入庫/出庫保管場所 (String)
MOVE_BATCH 入庫/出庫ロット (String)
MOVE_VAL_TYPE 転送ロットの評価タイプ (String)
MVT_IND 移動区分 (String)
MOVE_REAS 移動理由 (String)
RL_EST_KEY 不動産管理対象の内部キー (String)
REF_DATE 決済の参照日付 (String)
COST_OBJ 原価対象 (String)
PROFIT_SEGM_NO 収益性セグメント番号 (CO-PA) (String)
PROFIT_CTR 利益センタ (String)
WBS_ELEM WBS 要素 (String)
NETWORK 勘定割当のネットワーク番号 (String)
ACTIVITY 作業番号 (String)
PART_ACCT 取引先勘定コード (String)
AMOUNT_LC マニュアル入力による転記金額 (国内通貨) (String)
AMOUNT_SV 外部入力による販売金額 (国内通貨) (String)
CURRENCY 通貨コード (String)
CURRENCY_ISO ISO 通貨コード (String)
REF_DOC_YR 参照伝票の会計年度 (String)
REF_DOC 参照伝票の伝票番号 (String)
REF_DOC_IT 参照伝票の明細番号 (String)
EXPIRYDATE 有効期間期限日 (String)
PROD_DATE ロット製造日付 (String)
FUND 会計区分 (String)
FUNDS_CTR 予算センタ (String)
CMMT_ITEM 資金予算コード (String)
VAL_SALES_ORD 評価受注在庫の受注番号 (String)
VAL_S_ORD_ITEM 評価受注在庫の受注明細 (String)
VAL_WBS_ELEM WBS 要素 (String)
CO_BUSPROC 業務プロセス (String)
ACTTYPE 活動タイプ (String)
SUPPL_VEND 供給仕入先 (String)
X_AUTO_CRE 自動登録済み明細 (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード (長) (String)
MATERIAL_GUID 項目 MATERIAL の外部 GUID (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (String)
MOVE_MAT_EXTERNAL 項目 MOVE_MAT の品目コード (長) (String)
MOVE_MAT_GUID 項目 MOVE_MAT の外部 GUID (String)
MOVE_MAT_VERSION 項目 MOVE_MAT のバージョン番号 (String)
GRANT_NBR 補助金 (String)
CMMT_ITEM_LONG 資金予算コード (String)
FUNC_AREA_LONG 機能領域 (String)
LINE_ID 伝票明細行の一意 ID (String)
PARENT_ID 1 レベル上位の行 ID (String)
LINE_DEPTH 伝票での明細行階層レベル (String)

取得した入出庫伝票情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["MAT_DOC"]　→　配列内のidx番目の入出庫伝票の「入出庫伝票番号」
[idx]["DOC_YEAR"]　→　配列内のidx番目の入出庫伝票の「入出庫伝票年度」
[idx]["MATDOC_ITM"]　→　配列内のidx番目の入出庫伝票の「入出庫伝票の明細」
[idx]["MATERIAL"]　→　配列内のidx番目の入出庫伝票の「品目コード」
[idx]["PLANT"]　→　配列内のidx番目の入出庫伝票の「プラント」
[idx]["STGE_LOC"]　→　配列内のidx番目の入出庫伝票の「保管場所」
[idx]["BATCH"]　→　配列内のidx番目の入出庫伝票の「ロット番号」
[idx]["MOVE_TYPE"]　→　配列内のidx番目の入出庫伝票の「移動タイプ (在庫管理)」
[idx]["STCK_TYPE"]　→　配列内のidx番目の入出庫伝票の「在庫タイプ」
[idx]["SPEC_STOCK"]　→　配列内のidx番目の入出庫伝票の「特殊在庫区分」
[idx]["VENDOR"]　→　配列内のidx番目の入出庫伝票の「仕入先勘定コード」
[idx]["CUSTOMER"]　→　配列内のidx番目の入出庫伝票の「得意先コード」
[idx]["SALES_ORD"]　→　配列内のidx番目の入出庫伝票の「受注伝票番号」
[idx]["S_ORD_ITEM"]　→　配列内のidx番目の入出庫伝票の「受注明細番号」
[idx]["SCHED_LINE"]　→　配列内のidx番目の入出庫伝票の「受注納入日程」
[idx]["VAL_TYPE"]　→　配列内のidx番目の入出庫伝票の「評価タイプ」
[idx]["ENTRY_QNT"]　→　配列内のidx番目の入出庫伝票の「入力単位での数量」
[idx]["ENTRY_UOM"]　→　配列内のidx番目の入出庫伝票の「入力単位」
[idx]["ENTRY_UOM_ISO"]　→　配列内のidx番目の入出庫伝票の「単位の ISO コード」
[idx]["PO_PR_QNT"]　→　配列内のidx番目の入出庫伝票の「数量 (購買発注価格単位)」
[idx]["ORDERPR_UN"]　→　配列内のidx番目の入出庫伝票の「購買発注価格単位 (購買管理)」
[idx]["ORDERPR_UN_ISO"]　→　配列内のidx番目の入出庫伝票の「単位の ISO コード」
[idx]["PO_NUMBER"]　→　配列内のidx番目の入出庫伝票の「購買発注番号」
[idx]["PO_ITEM"]　→　配列内のidx番目の入出庫伝票の「購買伝票の明細番号」
[idx]["SHIPPING"]　→　配列内のidx番目の入出庫伝票の「出荷指示」
[idx]["COMP_SHIP"]　→　配列内のidx番目の入出庫伝票の「出荷指示順守」
[idx]["NO_MORE_GR"]　→　配列内のidx番目の入出庫伝票の「納入完了 区分」
[idx]["ITEM_TEXT"]　→　配列内のidx番目の入出庫伝票の「明細テキスト」
[idx]["GR_RCPT"]　→　配列内のidx番目の入出庫伝票の「受領者」
[idx]["UNLOAD_PT"]　→　配列内のidx番目の入出庫伝票の「荷渡ポイント」
[idx]["COSTCENTER"]　→　配列内のidx番目の入出庫伝票の「原価センタ」
[idx]["ORDERID"]　→　配列内のidx番目の入出庫伝票の「指図番号」
[idx]["ORDER_ITNO"]　→　配列内のidx番目の入出庫伝票の「指図明細番号」
[idx]["CALC_MOTIVE"]　→　配列内のidx番目の入出庫伝票の「計算区分」
[idx]["ASSET_NO"]　→　配列内のidx番目の入出庫伝票の「資産番号」
[idx]["SUB_NUMBER"]　→　配列内のidx番目の入出庫伝票の「資産補助番号」
[idx]["RESERV_NO"]　→　配列内のidx番目の入出庫伝票の「入出庫予定/従属所要量の番号」
[idx]["RES_ITEM"]　→　配列内のidx番目の入出庫伝票の「入出庫予定/従属所要量の明細番号」
[idx]["RES_TYPE"]　→　配列内のidx番目の入出庫伝票の「レコードタイプ」
[idx]["WITHDRAWN"]　→　配列内のidx番目の入出庫伝票の「入出庫予定に対する出庫完了」
[idx]["MOVE_MAT"]　→　配列内のidx番目の入出庫伝票の「入庫/出庫品目」
[idx]["MOVE_PLANT"]　→　配列内のidx番目の入出庫伝票の「入庫/出庫プラント」
[idx]["MOVE_STLOC"]　→　配列内のidx番目の入出庫伝票の「入庫/出庫保管場所」
[idx]["MOVE_BATCH"]　→　配列内のidx番目の入出庫伝票の「入庫/出庫ロット」
[idx]["MOVE_VAL_TYPE"]　→　配列内のidx番目の入出庫伝票の「転送ロットの評価タイプ」
[idx]["MVT_IND"]　→　配列内のidx番目の入出庫伝票の「移動区分」
[idx]["MOVE_REAS"]　→　配列内のidx番目の入出庫伝票の「移動理由」
[idx]["RL_EST_KEY"]　→　配列内のidx番目の入出庫伝票の「不動産管理対象の内部キー」
[idx]["REF_DATE"]　→　配列内のidx番目の入出庫伝票の「決済の参照日付」
[idx]["COST_OBJ"]　→　配列内のidx番目の入出庫伝票の「原価対象」
[idx]["PROFIT_SEGM_NO"]　→　配列内のidx番目の入出庫伝票の 「収益性セグメント番号 (CO-PA)」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の入出庫伝票の「利益センタ」
[idx]["WBS_ELEM"]　→　配列内のidx番目の入出庫伝票の「WBS 要素」
[idx]["NETWORK"]　→　配列内のidx番目の入出庫伝票の「勘定割当のネットワーク番号」
[idx]["ACTIVITY"]　→　配列内のidx番目の入出庫伝票の「作業番号」
[idx]["PART_ACCT"]　→　配列内のidx番目の入出庫伝票の「取引先勘定コード」
[idx]["AMOUNT_LC"]　→　配列内のidx番目の入出庫伝票の 「マニュアル入力による転記金額 (国内通貨)」
[idx]["AMOUNT_SV"]　→　配列内のidx番目の入出庫伝票の「外部入力による販売金額 (国内通貨)」
[idx]["CURRENCY"]　→　配列内のidx番目の入出庫伝票の「通貨コード」
[idx]["CURRENCY_ISO"]　→　配列内のidx番目の入出庫伝票の「ISO 通貨コード」
[idx]["REF_DOC_YR"]　→　配列内のidx番目の入出庫伝票の「参照伝票の会計年度」
[idx]["REF_DOC"]　→　配列内のidx番目の入出庫伝票の「参照伝票の伝票番号」
[idx]["REF_DOC_IT"]　→　配列内のidx番目の入出庫伝票の「参照伝票の明細番号」
[idx]["EXPIRYDATE"]　→　配列内のidx番目の入出庫伝票の「有効期間期限日」
[idx]["PROD_DATE"]　→　配列内のidx番目の入出庫伝票の「ロット製造日付」
[idx]["FUND"]　→　配列内のidx番目の入出庫伝票の「会計区分」
[idx]["FUNDS_CTR"]　→　配列内のidx番目の入出庫伝票の「予算センタ」
[idx]["CMMT_ITEM"]　→　配列内のidx番目の入出庫伝票の「資金予算コード」
[idx]["VAL_SALES_ORD"]　→　配列内のidx番目の入出庫伝票の「評価受注在庫の受注番号」
[idx]["VAL_S_ORD_ITEM"]　→　配列内のidx番目の入出庫伝票の「評価受注在庫の受注明細」
[idx]["VAL_WBS_ELEM"]　→　配列内のidx番目の入出庫伝票の「WBS 要素」
[idx]["CO_BUSPROC"]　→　配列内のidx番目の入出庫伝票の「業務プロセス」
[idx]["ACTTYPE"]　→　配列内のidx番目の入出庫伝票の「活動タイプ」
[idx]["SUPPL_VEND"]　→　配列内のidx番目の入出庫伝票の「供給仕入先」
[idx]["X_AUTO_CRE"]　→　配列内のidx番目の入出庫伝票の「自動登録済み明細」
[idx]["MATERIAL_EXTERNAL"]　→ 　配列内のidx番目の入出庫伝票の「項目 MATERIAL の品目コード (長)」
[idx]["MATERIAL_GUID"]　→ 　配列内のidx番目の入出庫伝票の「項目 MATERIAL の外部 GUID」
[idx]["MATERIAL_VERSION"]　→ 　配列内のidx番目の入出庫伝票の「項目 MATERIAL のバージョン番号」
[idx]["MOVE_MAT_EXTERNAL"]　→ 　配列内のidx番目の入出庫伝票の「項目 MOVE_MAT の品目コード (長)」
[idx]["MOVE_MAT_GUID"]　→ 　配列内のidx番目の入出庫伝票の「項目 MOVE_MAT の外部 GUID」
[idx]["MOVE_MAT_VERSION"]　→ 　配列内のidx番目の入出庫伝票の「項目 MOVE_MAT のバージョン番号」
[idx]["GRANT_NBR"]　→　配列内のidx番目の入出庫伝票の「補助金」
[idx]["CMMT_ITEM_LONG"]　→　配列内のidx番目の入出庫伝票の「資金予算コード」
[idx]["FUNC_AREA_LONG"]　→　配列内のidx番目の入出庫伝票の「機能領域」
[idx]["LINE_ID"]　→　配列内のidx番目の入出庫伝票の「伝票明細行の一意 ID」
[idx]["PARENT_ID"]　→　配列内のidx番目の入出庫伝票の「1 レベル上位の行 ID」
[idx]["LINE_DEPTH"]　→　配列内のidx番目の入出庫伝票の「伝票での明細行階層レベル」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getMaterialRaList

Array getMaterialRaList ()

品目コードの範囲を取得します。
返却値
Array 品目コードの範囲

品目コードの範囲情報オブジェクトの構成は以下のとおりです。
品目コードの範囲情報
オブジェクト
(Object)
SIGN 選択演算子 SIGN (テーブル範囲) (String)
OPTION 選択演算子 OPTION (範囲テーブル) (String)
LOW 品目コード (String)
HIGH 品目コード (String)

取得した品目コードの範囲情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["SIGN"]　→　配列内のidx番目の移動タイプ範囲の「選択演算子 SIGN (テーブル範囲)」
[idx]["OPTION"]　→　配列内のidx番目の移動タイプ範囲の「選択演算子 OPTION (範囲テーブル)」
[idx]["LOW"]　→　配列内のidx番目の移動タイプ範囲の「品目コード」
[idx]["HIGH"]　→　配列内のidx番目の移動タイプ範囲の「品目コード」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getMoveTypeRaList

Array getMoveTypeRaList ()

移動タイプ範囲を取得します。
返却値
Array 移動タイプの範囲

移動タイプの範囲情報オブジェクトの構成は以下のとおりです。
プラントの範囲情報
オブジェクト
(Object)
SIGN 選択演算子 SIGN (テーブル範囲) (String)
OPTION 選択演算子 OPTION (範囲テーブル) (String)
LOW 移動タイプ (String)
HIGH 移動タイプ (String)

取得した移動タイプの範囲情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["SIGN"]　→　配列内のidx番目の移動タイプ範囲の「選択演算子 SIGN (テーブル範囲)」
[idx]["OPTION"]　→　配列内のidx番目の移動タイプ範囲の「選択演算子 OPTION (範囲テーブル)」
[idx]["LOW"]　→　配列内のidx番目の移動タイプ範囲の「移動タイプ」
[idx]["HIGH"]　→　配列内のidx番目の移動タイプ範囲の「移動タイプ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPlantRaList

Array getPlantRaList ()

プラントの範囲を取得します。
返却値
Array プラントの範囲

プラントの範囲情報オブジェクトの構成は以下のとおりです。
プラントの範囲情報
オブジェクト
(Object)
SIGN 選択演算子 SIGN (テーブル範囲) (String)
OPTION 選択演算子 OPTION (範囲テーブル) (String)
LOW プラント (String)
HIGH プラント (String)

取得したプラントの範囲情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["SIGN"]　→　配列内のidx番目のプラント範囲の「選択演算子 SIGN (テーブル範囲)」
[idx]["OPTION"]　→　配列内のidx番目のプラント範囲の「選択演算子 OPTION (範囲テーブル)」
[idx]["LOW"]　→　配列内のidx番目のプラント範囲の「プラント」
[idx]["HIGH"]　→　配列内のidx番目のプラント範囲の「プラント」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPstngDateRaList

Array getPstngDateRaList ()

登録日付の範囲を取得します。
返却値
Array 登録日付の範囲

登録日付の範囲情報オブジェクトの構成は以下のとおりです。
登録日付の範囲情報
オブジェクト
(Object)
SIGN 選択演算子 SIGN (テーブル範囲) (String)
OPTION 選択演算子 OPTION (範囲テーブル) (String)
LOW 伝票の転記日付 (String)
HIGH 伝票の転記日付 (String)

取得した登録日付の範囲情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["SIGN"]　→　配列内のidx番目の登録日付範囲の「選択演算子 SIGN (テーブル範囲)」
[idx]["OPTION"]　→　配列内のidx番目の登録日付範囲の「選択演算子 OPTION (範囲テーブル)」
[idx]["LOW"]　→　配列内のidx番目の登録日付範囲の「伝票の転記日付」
[idx]["HIGH"]　→　配列内のidx番目の登録日付範囲の「伝票の転記日付」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getSpecStockRaList

Array getSpecStockRaList ()

特殊在庫区分の範囲を取得します。
返却値
Array 特殊在庫区分の範囲

特殊在庫区分の範囲情報オブジェクトの構成は以下のとおりです。
特殊在庫区分の範囲情報
オブジェクト
(Object)
SIGN 選択演算子 SIGN (テーブル範囲) (String)
OPTION 選択演算子 OPTION (範囲テーブル) (String)
LOW 特殊在庫区分 (String)
HIGH 特殊在庫区分 (String)

取得した特殊在庫区分の範囲情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["SIGN"]　→　配列内のidx番目の特殊在庫区分範囲の「選択演算子 SIGN (テーブル範囲)」
[idx]["OPTION"]　→　配列内のidx番目の特殊在庫区分範囲の 「選択演算子 OPTION (範囲テーブル)」
[idx]["LOW"]　→　配列内のidx番目の特殊在庫区分範囲の「特殊在庫区分」
[idx]["HIGH"]　→　配列内のidx番目の特殊在庫区分範囲の「特殊在庫区分」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getStgeLocRaList

Array getStgeLocRaList ()

保管場所の範囲を取得します。
返却値
Array 保管場所の範囲

保管場所の範囲情報オブジェクトの構成は以下のとおりです。
ユーザ名の範囲情報
オブジェクト
(Object)
SIGN 選択演算子 SIGN (テーブル範囲) (String)
OPTION 選択演算子 OPTION (範囲テーブル) (String)
LOW 保管場所 (String)
HIGH 保管場所 (String)

取得した保管場所の範囲情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["SIGN"]　→　配列内のidx番目の保管場所範囲の「選択演算子 SIGN (テーブル範囲)」
[idx]["OPTION"]　→　配列内のidx番目の保管場所範囲の「選択演算子 OPTION (範囲テーブル)」
[idx]["LOW"]　→　配列内のidx番目の保管場所範囲の「保管場所」
[idx]["HIGH"]　→　配列内のidx番目の保管場所範囲の「保管場所」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getTrEvTypeRaList

Array getTrEvTypeRaList ()

トランザクション/イベントタイプの範囲を取得します。
返却値
Array トランザクション/イベントタイプの範囲

トランザクション/イベントタイプの範囲情報オブジェクトの構成は以下のとおりです。
ユーザ名の範囲情報
オブジェクト
(Object)
SIGN 選択演算子 SIGN (テーブル範囲) (String)
OPTION 選択演算子 OPTION (範囲テーブル) (String)
LOW トランザクション/イベントタイプ (String)
HIGH トランザクション/イベントタイプ (String)

取得したトランザクション/イベントタイプの範囲情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["SIGN"]　→　配列内のidx番目の仕入先範囲の「選択演算子 SIGN (テーブル範囲)」
[idx]["OPTION"]　→　配列内のidx番目の仕入先範囲の「選択演算子 OPTION (範囲テーブル)」
[idx]["LOW"]　→　配列内のidx番目のトランザクション/イベントタイプ範囲の 「トランザクション/イベントタイプ」
[idx]["HIGH"]　→　配列内のidx番目のトランザクション/イベントタイプ範囲の 「トランザクション/イベントタイプ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getUserNameRaList

Array getUserNameRaList ()

ユーザ名の範囲を取得します。
返却値
Array ユーザ名の範囲

ユーザ名の範囲情報オブジェクトの構成は以下のとおりです。
ユーザ名の範囲情報
オブジェクト
(Object)
SIGN 選択演算子 SIGN (テーブル範囲) (String)
OPTION 選択演算子 OPTION (範囲テーブル) (String)
LOW ユーザ名 (String)
HIGH ユーザ名 (String)

取得したユーザ名の範囲情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["SIGN"]　→　配列内のidx番目の仕入先範囲の「選択演算子 SIGN (テーブル範囲)」
[idx]["OPTION"]　→　配列内のidx番目の仕入先範囲の「選択演算子 OPTION (範囲テーブル)」
[idx]["LOW"]　→　配列内のidx番目の仕入先範囲の「ユーザ名」
[idx]["HIGH"]　→　配列内のidx番目の仕入先範囲の「ユーザ名」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getVendorRaList

Array getVendorRaList ()

仕入先の範囲を取得します。
返却値
Array 仕入先の範囲

仕入先の範囲情報オブジェクトの構成は以下のとおりです。
仕入先の範囲情報
オブジェクト
(Object)
SIGN 選択演算子 SIGN (テーブル範囲) (String)
OPTION 選択演算子 OPTION (範囲テーブル) (String)
LOW 仕入先勘定コード (String)
HIGH 仕入先勘定コード (String)

取得した仕入先の範囲情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["SIGN"]　→　配列内のidx番目の仕入先範囲の「選択演算子 SIGN (テーブル範囲)」
[idx]["OPTION"]　→　配列内のidx番目の仕入先範囲の「選択演算子 OPTION (範囲テーブル)」
[idx]["LOW"]　→　配列内のidx番目の仕入先範囲の「トランザクション/イベントタイプ」
[idx]["HIGH"]　→　配列内のidx番目の仕入先範囲の「トランザクション/イベントタイプ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

setTblParam

void setTblParam (String paramTable ,String paramName ,Object value ,int index)

テーブル型の項目に値をセットします。
パラメータ
paramTable | String | テーブル名
paramName | String | 項目名
value | Object | セットする値
index | int | レコード番号
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 InquiryCreateFromData2Controller オブジェクト

引合伝票登録コントローラクラス。

機能は以下の通り
  • 引合伝票を登録します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
InquiryCreateFromData2Controller ()
コンストラクタ｡
InquiryCreateFromData2Controller (ConnectionManager connectionManager)
コンストラクタ。
InquiryCreateFromData2Controller (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより引合伝票を登録します。
String | getBapiReturnErrMessage () ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage () プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。
Object | getBinaryRelationshiptype () バイナリ関連タイプ (専用)を取得します。
Object | getConvert () 変換: 取引先機能 + 受注伝票タイプを取得します。
Array | getExtensionInList () VBAK、VBAP、VBEP のカスタマ拡張を取得します。
Array | getInquiryCfgsBlobList () 選定: BLOB 内部データ (SCE)を取得します。
Array | getInquiryCfgsInstList () 選定: インスタンスを取得します。
Array | getInquiryCfgsPartOfList () 選定: 部分設定を取得します。
Array | getInquiryCfgsRefInstList () 選定: 参照明細/インスタンスを取得します。
Array | getInquiryCfgsRefList () 選定: 参照データを取得します。
Array | getInquiryCfgsValueList () 選定: 特性値を取得します。
Array | getInquiryCfgsVkList () 選定: バリアント条件キーを取得します。
Array | getInquiryConditionsInList () 条件を取得します。
Array | getInquiryConditionsInXList () 受注における条件更新の通信項目を取得します。
Object | getInquiryHeaderIn () 引合伝票ヘッダデータを取得します。
Object | getInquiryHeaderInX () ヘッダデータチェックボックスを取得します。
Array | getInquiryItemsInList () 明細データを取得します。
Array | getInquiryItemsInXList () 明細データチェックボックスを取得します。
Array | getInquiryKeysList () 参照キーの出力を取得します。
Array | getInquiryPartnersList () 伝票取引先を取得します。
Array | getInquirySchedulesInList () 納入日程行を取得します。
Array | getInquirySchedulesInXList () 納入日程行チェックボックスを取得します。
Array | getInquiryTextList () テキストを取得します。
Object | getIntNumberAssignment () 明細番号内部採番を取得します。
Object | getLogicSwitch () 内部制御パラメータを取得します。
Array | getPartnerAddressesList () アドレス (組織/会社) 用 BAPI 参照構造を取得します。
Object | getSalesdocument () 販売伝票番号を取得します。
Object | getSalesdocumentin () 販売管理伝票番号を取得します。
Object | getSender () 論理システム - 送信者を取得します。
Object | getTestrun () テスト実行を取得します。
void | setBehaveWhenError (Object value) エラー処理を設定します｡
void | setBinaryRelationshiptype (Object value) バイナリ関連タイプ (専用)を設定します｡
void | setConvert (Object value) 変換: 取引先機能 + 受注伝票タイプを設定します｡
void | setIntNumberAssignment (Object value) 明細番号内部採番を設定します｡
void | setSalesdocumentin (Object value) 販売管理伝票番号を設定します｡
void | setStrParam (String paramStr ,String paramName ,Object value) 構造型の項目に値をセットします。
void | setTblParam (String paramTable ,String paramName ,Object value ,int index) テーブル型の項目に値をセットします。
void | setTestrun (Object value) テスト実行を設定します｡
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
InquiryCreateFromData2Controller

InquiryCreateFromData2Controller ()
コンストラクタ｡
InquiryCreateFromData2Controller

InquiryCreateFromData2Controller (ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、InquiryCreateFromData2Controller#executeBapi()実行後に必ず ConnectionManager#commit()またはConnectionManager#rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。
パラメータ
connectionManager ConnectionManager コネクションマネージャー
InquiryCreateFromData2Controller

InquiryCreateFromData2Controller (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより引合伝票を登録します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getBapiReturnErrMessage

String getBapiReturnErrMessage ()

ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡
返却値
String BAPI実行結果エラーとなった全てのメッセージ情報
getBapiReturnMessage

String getBapiReturnMessage ()

プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡
返却値
String プロパティファイルでオートコミット条件に一致したType情報のメッセージ情報
getBinaryRelationshiptype

Object getBinaryRelationshiptype ()

バイナリ関連タイプ (専用)を取得します。
返却値
Object バイナリ関連タイプ（専用）
getConvert

Object getConvert ()

変換: 取引先機能 + 受注伝票タイプを取得します。
返却値
Object 変換: 取引先機能 + 受注伝票タイプ
getExtensionInList

Array getExtensionInList ()

VBAK、VBAP、VBEP のカスタマ拡張を取得します。
返却値
Array VBAK、VBAP、VBEP のカスタマ拡張

VBAK、VBAP、VBEP のカスタマ拡張の構成は以下のとおりです。
VBAK、VBAP、VBEP のカスタマ拡張
オブジェクト
(Object)
STRUCTURE BAPI テーブル拡張の構造名 (String)
VALUEPART1 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART2 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART3 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART4 BAPI 拡張パラメータのデータ部分 (String)

VBAK、VBAP、VBEP のカスタマ拡張オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["STRUCTURE"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI テーブル拡張の構造名」
[idx]["VALUEPART1"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART2"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART3"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART4"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI 拡張パラメータのデータ部分」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryCfgsBlobList

Array getInquiryCfgsBlobList ()

選定: BLOB 内部データ (SCE)を取得します。
返却値
Array 選定: BLOB 内部データ (SCE)

選定: BLOB 内部データ (SCE)オブジェクトの構成は以下のとおりです。
選定: BLOB 内部データ (SCE)
オブジェクト
(Object)
CONFIG_ID 外部選定 ID (仮) (String)
CONTEXT CU: 選定の BLOB. (SCE) (String)

選定: BLOB 内部データ (SCE)オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: BLOB 内部データ (SCE)の 「外部選定 ID (仮)」
[idx]["CONTEXT"]　→　配列内のidx番目の選定: BLOB 内部データ (SCE)の 「CU: 選定の BLOB. (SCE)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryCfgsInstList

Array getInquiryCfgsInstList ()

選定: インスタンスを取得します。
返却値
Array 選定: インスタンス

選定: インスタンスオブジェクトの構成は以下のとおりです。
選定: インスタンス
オブジェクト
(Object)
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)
OBJ_TYPE 対象タイプ (String)
CLASS_TYPE クラスタイプ (String)
OBJ_KEY 対象キー (String)
OBJ_TXT 言語依存対象テキスト (String)
QUANTITY インスタンス数量 (String)
AUTHOR 報告書提案済 (String)
QUANTITY_UNIT 数量単位 (String)
COMPLETE 一般区分 (String)
CONSISTENT 一般区分 (String)
OBJECT_GUID インスタンス用 TYPE_OF ステートメントの GUID (String)
PERSIST_ID インスタンス番号 (固定) (String)
PERSIST_ID_TYPE インスタンス番号タイプ (固定) (String)

選定: インスタンスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: インスタンスの「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の選定: インスタンスの「選定におけるインスタンス番号」
[idx]["OBJ_TYPE"]　→　配列内のidx番目の選定: インスタンスの「対象タイプ」
[idx]["CLASS_TYPE"]　→　配列内のidx番目の選定: インスタンスの「クラスタイプ」
[idx]["OBJ_KEY"]　→　配列内のidx番目の選定: インスタンスの「対象キー」
[idx]["OBJ_TXT"]　→　配列内のidx番目の選定: インスタンスの「言語依存対象テキスト」
[idx]["QUANTITY"]　→　配列内のidx番目の選定: インスタンスの「インスタンス数量」
[idx]["AUTHOR"]　→　配列内のidx番目の選定: インスタンスの「報告書提案済」
[idx]["QUANTITY_UNIT"]　→　配列内のidx番目の選定: インスタンスの「数量単位」
[idx]["COMPLETE"]　→　配列内のidx番目の選定: インスタンスの「一般区分」
[idx]["CONSISTENT"]　→　配列内のidx番目の選定: インスタンスの「一般区分」
[idx]["OBJECT_GUID"]　→　配列内のidx番目の選定: インスタンスの 「インスタンス用 TYPE_OF ステートメントの GUID」
[idx]["PERSIST_ID"]　→　配列内のidx番目の選定: インスタンスの「インスタンス番号 (固定)」
[idx]["PERSIST_ID_TYPE"]　→　配列内のidx番目の選定: インスタンスの 「インスタンス番号タイプ (固定)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryCfgsPartOfList

Array getInquiryCfgsPartOfList ()

選定: 部分設定を取得します。
返却値
Array 選定: 部分設定

選定: 部分設定オブジェクトの構成は以下のとおりです。
選定: 部分設定
オブジェクト
(Object)
CONFIG_ID 外部選定 ID (仮) (String)
PARENT_ID 選定におけるインスタンス番号 (String)
INST_ID 選定におけるインスタンス番号 (String)
PART_OF_NO Part_of 明細番号 (String)
OBJ_TYPE 対象タイプ (String)
CLASS_TYPE クラスタイプ (String)
OBJ_KEY 対象キー (String)
AUTHOR 報告書提案済 (String)
SALES_RELEVANT この部品は販売に関連しています (String)
PART_OF_GUID インスタンス用 PART_OF ステートメントの GUID (String)

選定: 部分設定オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: 部分設定の「外部選定 ID (仮)」
[idx]["PARENT_ID"]　→　配列内のidx番目の選定: 部分設定の「選定におけるインスタンス番号」
[idx]["INST_ID"]　→　配列内のidx番目の選定: 部分設定の「選定におけるインスタンス番号」
[idx]["PART_OF_NO"]　→　配列内のidx番目の選定: 部分設定の「Part_of 明細番号」
[idx]["OBJ_TYPE"]　→　配列内のidx番目の選定: 部分設定の「対象タイプ」
[idx]["CLASS_TYPE"]　→　配列内のidx番目の選定: 部分設定の「クラスタイプ」
[idx]["OBJ_KEY"]　→　配列内のidx番目の選定: 部分設定の「対象キー」
[idx]["AUTHOR"]　→　配列内のidx番目の選定: 部分設定の「報告書提案済」
[idx]["SALES_RELEVANT"]　→　配列内のidx番目の選定: 部分設定の 「この部品は販売に関連しています」
[idx]["PART_OF_GUID"]　→　配列内のidx番目の選定: 部分設定の 「インスタンス用 PART_OF ステートメントの GUID」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryCfgsRefInstList

Array getInquiryCfgsRefInstList ()

選定: 参照明細/インスタンスを取得します。
返却値
Array 選定: 参照明細/インスタンス

選定: 参照明細/インスタンスオブジェクトの構成は以下のとおりです。
選定: 参照明細/インスタンス
オブジェクト
(Object)
POSEX 外部明細番号 (String)
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)

選定: 参照明細/インスタンスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["POSEX"]　→　配列内のidx番目の選定: 参照明細/インスタンスの「外部明細番号」
[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: 参照明細/インスタンスの 「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の選定: 参照明細/インスタンスの 「選定におけるインスタンス番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryCfgsRefList

Array getInquiryCfgsRefList ()

選定: 参照データを取得します。
返却値
Array 選定: 参照データ

選定: 参照データオブジェクトの構成は以下のとおりです。
選定: 参照データ
オブジェクト
(Object)
POSEX 外部明細番号 (String)
CONFIGconfig_id 外部選定 ID (仮) (String)
ROOT_Iroot_id 選定におけるインスタンス番号 (String)
SCE scCUX: 選定タイプ (String)
KBNAMEkbname ナレッジベースオブジェクト (String)
KBVERSkbversion SCE ナレッジベースの実行時バージョン (String)
COMPLEcomplete 一般区分 (String)
CONSISconsistent 一般区分 (String)
CFGINFcfginfo CU: 選定の BLOB (SCE) (String)
KBPROFkbprofile ナレッジベースプロファイル (String)
KBLANGkblanguage システム設定の言語 (String)
CBASE_cbase_id インスタンス番号 (固定) (String)
CBASE_cbase_id_type インスタンス番号タイプ (固定) (String)

選定: 参照データオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["POSEX"]　→　配列内のidx番目の選定: 参照データの「外部明細番号」
[idx]["CONFIGconfig_id"]　→　配列内のidx番目の選定: 参照データの 「外部選定 ID (仮)」
[idx]["ROOT_Iroot_id"]　→　配列内のidx番目の選定: 参照データの 「選定におけるインスタンス番号」
[idx]["SCE"]　→　配列内のidx番目の選定: 参照データの「scCUX: 選定タイプ」
[idx]["KBNAMEkbname"]　→　配列内のidx番目の選定: 参照データの「ナレッジベースオブジェクト」
[idx]["KBVERSkbversion"]　→　配列内のidx番目の選定: 参照データの 「SCE ナレッジベースの実行時バージョン」
[idx]["COMPLEcomplete"]　→　配列内のidx番目の選定: 参照データの「一般区分」
[idx]["CONSISconsistent"]　→　配列内のidx番目の選定: 参照データの「一般区分」
[idx]["CFGINFcfginfo"]　→　配列内のidx番目の選定: 参照データの 「CU: 選定の BLOB (SCE)」
[idx]["KBPROFkbprofile"]　→　配列内のidx番目の選定: 参照データの 「ナレッジベースプロファイル」
[idx]["KBLANGkblanguage"]　→　配列内のidx番目の選定: 参照データの「システム設定の言語」
[idx]["CBASE_cbase_id"]　→　配列内のidx番目の選定: 参照データの 「インスタンス番号 (固定)」
[idx]["CBASE_cbase_id_type"]　→　配列内のidx番目の選定: 参照データの 「インスタンス番号タイプ (固定)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryCfgsValueList

Array getInquiryCfgsValueList ()

選定: 特性値を取得します。
返却値
Array 選定: 特性値

選定: 特性値オブジェクトの構成は以下のとおりです。
選定: 特性値
オブジェクト
(Object)
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)
CHARC 特性名 (String)
CHARC_TXT 言語依存特性テキスト (String)
VALUE 特性値 (String)
VALUE_TXT 特性値の言語依存テキスト (String)
AUTHOR 報告書提案済 (String)
VALUE_TO 特性値 (String)
VALCODE 値タイプ: 範囲制限 - 単一値 (String)

選定: 特性値オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: 特性値の「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の選定: 特性値の「選定におけるインスタンス番号」
[idx]["CHARC"]　→　配列内のidx番目の選定: 特性値の「特性名」
[idx]["CHARC_TXT"]　→　配列内のidx番目の選定: 特性値の「言語依存特性テキスト」
[idx]["VALUE"]　→　配列内のidx番目の選定: 特性値の「特性値」
[idx]["VALUE_TXT"]　→　配列内のidx番目の選定: 特性値の「特性値の言語依存テキスト」
[idx]["AUTHOR"]　→　配列内のidx番目の選定: 特性値の「報告書提案済」
[idx]["VALUE_TO"]　→　配列内のidx番目の選定: 特性値の「特性値」
[idx]["VALCODE"]　→　配列内のidx番目の選定: 特性値の「値タイプ: 範囲制限 - 単一値」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryCfgsVkList

Array getInquiryCfgsVkList ()

選定: バリアント条件キーを取得します。
返却値
Array 選定: バリアント条件キー

選定: バリアント条件キーオブジェクトの構成は以下のとおりです。
選定: バリアント条件キー
オブジェクト
(Object)
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)
VKEY バリアント条件名 (String)
FACTOR バリアント条件の加重係数 (String)

選定: バリアント条件キーオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: バリアント条件キーの「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の選定: バリアント条件キーの「選定におけるインスタンス番号」
[idx]["VKEY"]　→　配列内のidx番目の選定: バリアント条件キーの「バリアント条件名」
[idx]["FACTOR"]　→　配列内のidx番目の選定: バリアント条件キーの「バリアント条件の加重係数」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryConditionsInList

Array getInquiryConditionsInList ()

条件を取得します。
返却値
Array 条件

条件オブジェクトの構成は以下のとおりです。
条件
オブジェクト
(Object)
ITM_NUMBER 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件カウンタ (String)
COND_TYPE 条件タイプ (String)
COND_VALUE 条件レート (String)
CURRENCY 通貨コード (String)
COND_UNIT 条件単位 (String)
COND_P_UNT 価格条件単位 (String)
CURR_ISO ISO コード通貨 (String)
CD_UNT_ISO 条件数量単位 (ISO コード) (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)
APPLICATIO アプリケーション (String)
CONPRICDAT 条件価格設定日付 (String)
CALCTYPCON 条件計算タイプ (String)
CONBASEVAL 条件基礎値 (String)
CONEXCHRAT 現地通貨への換算レートに対する条件 (String)
NUMCONVERT 条件単位を基本単位へ変換する分子 (String)
DENOMINATO 条件単位を基本単位へ変換する分母 (String)
CONDTYPE 条件カテゴリ (例: 税、運賃、価格、原価) (String)
STAT_CON 統計に適用する条件 (String)
SCALETYPE スケールタイプ (String)
ACCRUALS 見越額関連条件 (運賃など) (String)
CONINVOLST 請求書一覧条件 (String)
CONDORIGIN 条件生成区分 (String)
GROUPCOND グループ条件区分 (String)
COND_UPDAT 条件更新 (String)
ACCESS_SEQ 検索順序 - 検索番号 (String)
CONDCOUNT 条件連続番号 (String)
ROUNDOFFDI BAPI の通貨額 (小数点以下９桁) (String)
CONDVALUE 条件金額 (String)
CURRENCY_2 販売伝票通貨 (String)
CURR_ISO_2 ISO コード通貨 (String)
CONDCNTRL 条件管理 (String)
CONDISACTI 無効条件 (String)
CONDCLASS 条件クラス (String)
FACTBASVAL 条件基礎値に対する要因 (String)
SCALEBASIN スケール基準区分 (String)
SCALBASVAL 条件のスケール基準値 (String)
UNITMEASUR 条件スケール単位 (String)
ISO_UNIT 単位の ISO コード (String)
CURRENCKEY スケール通貨 (String)
CURRENISO ISO コード通貨 (String)
CONDINCOMP 会社間請求の条件 (String)
CONDCONFIG システム設定の条件 (String)
CONDCHAMAN 条件 (マニュアル変更済) (String)
COND_NO 条件レコード番号 (String)
TAX_CODE 消費税コード (String)
VARCOND バリアント条件 (String)
ACCOUNTKEY 勘定キー (String)
ACCOUNT_KE 勘定キー 見越/引当 (String)
WT_WITHCD 源泉徴収税コード (String)
STRUCTCOND 構造条件 (String)
FACTCONBAS 条件基準の係数 (期間) (String)
CONDCOINHD 条件カウンタ (ヘッダ条件) (String)

条件オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の条件の「条件明細番号」
[idx]["COND_ST_NO"]　→　配列内のidx番目の条件の「ステップ番号」
[idx]["COND_COUNT"]　→　配列内のidx番目の条件の「条件カウンタ」
[idx]["COND_TYPE"]　→　配列内のidx番目の条件の「条件タイプ」
[idx]["COND_VALUE"]　→　配列内のidx番目の条件の「条件レート」
[idx]["CURRENCY"]　→　配列内のidx番目の条件の「通貨コード」
[idx]["COND_UNIT"]　→　配列内のidx番目の条件の「条件単位」
[idx]["COND_P_UNT"]　→　配列内のidx番目の条件の「価格条件単位」
[idx]["CURR_ISO"]　→　配列内のidx番目の条件の「ISO コード通貨」
[idx]["CD_UNT_ISO"]　→　配列内のidx番目の条件の「条件数量単位 (ISO コード)」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の条件の「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の条件の「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の条件の「論理システム」
[idx]["APPLICATIO"]　→　配列内のidx番目の条件の「アプリケーション」
[idx]["CONPRICDAT"]　→　配列内のidx番目の条件の「条件価格設定日付」
[idx]["CALCTYPCON"]　→　配列内のidx番目の条件の「条件計算タイプ」
[idx]["CONBASEVAL"]　→　配列内のidx番目の条件の「条件基礎値」
[idx]["CONEXCHRAT"]　→　配列内のidx番目の条件の「現地通貨への換算レートに対する条件」
[idx]["NUMCONVERT"]　→　配列内のidx番目の条件の「条件単位を基本単位へ変換する分子」
[idx]["DENOMINATO"]　→　配列内のidx番目の条件の「条件単位を基本単位へ変換する分母」
[idx]["CONDTYPE"]　→　配列内のidx番目の条件の「条件カテゴリ (例: 税、運賃、価格、原価)」
[idx]["STAT_CON"]　→　配列内のidx番目の条件の「統計に適用する条件」
[idx]["SCALETYPE"]　→　配列内のidx番目の条件の「スケールタイプ」
[idx]["ACCRUALS"]　→　配列内のidx番目の条件の「見越額関連条件 (運賃など)」
[idx]["CONINVOLST"]　→　配列内のidx番目の条件の「請求書一覧条件」
[idx]["CONDORIGIN"]　→　配列内のidx番目の条件の「条件生成区分」
[idx]["GROUPCOND"]　→　配列内のidx番目の条件の「グループ条件区分」
[idx]["COND_UPDAT"]　→　配列内のidx番目の条件の「条件更新」
[idx]["ACCESS_SEQ"]　→　配列内のidx番目の条件の「検索順序 - 検索番号」
[idx]["CONDCOUNT"]　→　配列内のidx番目の条件の「条件連続番号」
[idx]["ROUNDOFFDI"]　→　配列内のidx番目の条件の「BAPI の通貨額 (小数点以下９桁)」
[idx]["CONDVALUE"]　→　配列内のidx番目の条件の「条件金額」
[idx]["CURRENCY_2"]　→　配列内のidx番目の条件の「販売伝票通貨」
[idx]["CURR_ISO_2"]　→　配列内のidx番目の条件の「ISO コード通貨」
[idx]["CONDCNTRL"]　→　配列内のidx番目の条件の「条件管理」
[idx]["CONDISACTI"]　→　配列内のidx番目の条件の「無効条件」
[idx]["CONDCLASS"]　→　配列内のidx番目の条件の「条件クラス」
[idx]["FACTBASVAL"]　→　配列内のidx番目の条件の「条件基礎値に対する要因」
[idx]["SCALEBASIN"]　→　配列内のidx番目の条件の「スケール基準区分」
[idx]["SCALBASVAL"]　→　配列内のidx番目の条件の「条件のスケール基準値」
[idx]["UNITMEASUR"]　→　配列内のidx番目の条件の「条件スケール単位」
[idx]["ISO_UNIT"]　→　配列内のidx番目の条件の「単位の ISO コード」
[idx]["CURRENCKEY"]　→　配列内のidx番目の条件の「スケール通貨」
[idx]["CURRENISO"]　→　配列内のidx番目の条件の「ISO コード通貨」
[idx]["CONDINCOMP"]　→　配列内のidx番目の条件の「会社間請求の条件」
[idx]["CONDCONFIG"]　→　配列内のidx番目の条件の「システム設定の条件」
[idx]["CONDCHAMAN"]　→　配列内のidx番目の条件の「条件 (マニュアル変更済)」
[idx]["COND_NO"]　→　配列内のidx番目の条件の「条件レコード番号」
[idx]["TAX_CODE"]　→　配列内のidx番目の条件の「消費税コード」
[idx]["VARCOND"]　→　配列内のidx番目の条件の「バリアント条件」
[idx]["ACCOUNTKEY"]　→　配列内のidx番目の条件の「勘定キー」
[idx]["ACCOUNT_KE"]　→　配列内のidx番目の条件の「勘定キー 見越/引当」
[idx]["WT_WITHCD"]　→　配列内のidx番目の条件の「源泉徴収税コード」
[idx]["STRUCTCOND"]　→　配列内のidx番目の条件の「構造条件」
[idx]["FACTCONBAS"]　→　配列内のidx番目の条件の「条件基準の係数 (期間)」
[idx]["CONDCOINHD"]　→　配列内のidx番目の条件の「条件カウンタ (ヘッダ条件)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryConditionsInXList

Array getInquiryConditionsInXList ()

受注における条件更新の通信項目を取得します。
返却値
Array 受注における条件更新の通信項目

受注における条件更新の通信項目オブジェクトの構成は以下のとおりです。
受注における条件更新の通信項目
オブジェクト
(Object)
ITM_NUMBER 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件連続番号 (String)
COND_TYPE 条件タイプ (String)
UPDATEFLAG 更新区分 (String)
COND_VALUE 関連ユーザデータ項目の更新情報 (String)
CURRENCY 関連ユーザデータ項目の更新情報 (String)
COND_UNIT 関連ユーザデータ項目の更新情報 (String)
COND_P_UNT 関連ユーザデータ項目の更新情報 (String)
VARCOND バリアント条件 (String)

受注における条件更新の通信項目オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の受注における条件更新の通信項目の「条件明細番号」
[idx]["COND_ST_NO"]　→　配列内のidx番目の受注における条件更新の通信項目の「ステップ番号」
[idx]["COND_COUNT"]　→　配列内のidx番目の受注における条件更新の通信項目の「条件連続番号」
[idx]["COND_TYPE"]　→　配列内のidx番目の受注における条件更新の通信項目の「条件タイプ」
[idx]["UPDATEFLAG"]　→　配列内のidx番目の受注における条件更新の通信項目の「更新区分」
[idx]["COND_VALUE"]　→　配列内のidx番目の受注における条件更新の通信項目の 「関連ユーザデータ項目の更新情報」
[idx]["CURRENCY"]　→　配列内のidx番目の受注における条件更新の通信項目の 「関連ユーザデータ項目の更新情報」
[idx]["COND_UNIT"]　→　配列内のidx番目の受注における条件更新の通信項目の 「関連ユーザデータ項目の更新情報」
[idx]["COND_P_UNT"]　→　配列内のidx番目の受注における条件更新の通信項目の 「関連ユーザデータ項目の更新情報」
[idx]["VARCOND"]　→　配列内のidx番目の受注における条件更新の通信項目の「バリアント条件」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryHeaderIn

Object getInquiryHeaderIn ()

引合伝票ヘッダデータを取得します。
返却値
Object 引合伝票ヘッダデータ

引合伝票ヘッダデータオブジェクトの構成は以下のとおりです。
引合伝票ヘッダデータ
オブジェクト
(Object)
REFOBJTYPE オブジェクトタイプ(String)
REFOBJKEY オブジェクトキー(String)
REFDOCTYPE 参照オブジェクトの伝票タイプ(String)
DOC_TYPE 販売伝票タイプ(String)
COLLECT_NO 一括番号(String)
SALES_ORG 販売組織(String)
DISTR_CHAN 流通チャネル(String)
DIVISION 製品部門(String)
SALES_GRP 営業グループ(String)
SALES_OFF 営業所(String)
REQ_DATE_H 指定納入期日(String)
DATE_TYPE 提案日付タイプ(String)
PURCH_DATE 得意先発注日付(String)
PO_METHOD 得意先発注タイプ(String)
PO_SUPPLEM 得意先発注番号補足(String)
REF_1 得意先/仕入先の内部参照コード(String)
NAME 発注者名称(String)
TELEPHONE 電話番号(String)
PRICE_GRP 価格グループ (得意先)(String)
CUST_GROUP 得意先グループ(String)
SALES_DIST 販売地域(String)
PRICE_LIST 価格表タイプ(String)
INCOTERMS1 インコタームズ (1)(String)
INCOTERMS2 インコタームズ 2(String)
PMNTTRMS 支払条件キー(String)
DLV_BLOCK 出荷ブロック (伝票ヘッダ)(String)
BILL_BLOCK 販売管理伝票の請求ブロック(String)
ORD_REASON 受注理由 (取引理由)(String)
COMPL_DLV 一括納入区分(String)
PRICE_DATE 価格設定/外貨換算の実行日付(String)
QT_VALID_F 見積/引合有効開始日(String)
QT_VALID_T 見積の有効終了日(String)
CT_VALID_F 有効開始日付 (販売契約/品目提案)(String)
CT_VALID_T 有効終了日付 (販売契約/品目提案)(String)
CUST_GRP1 得意先グループ 1(String)
CUST_GRP2 得意先グループ 2(String)
CUST_GRP3 得意先グループ 3(String)
CUST_GRP4 得意先グループ 4(String)
CUST_GRP5 得意先グループ 5(String)
PURCH_NO_C 出荷先発注番号(String)
PURCH_NO_S 出荷先の得意先発注番号(String)
PO_DAT_S 出荷先の出荷先発注日付(String)
PO_METH_S 出荷先の出荷先発注タイプ(String)
REF_1_S 出荷先文字(String)
SD_DOC_CAT 販売管理伝票カテゴリ(String)
DOC_DATE 伝票日付 (受信日/送信日)(String)
WAR_DATE 保証期間の開始日付(String)
SHIP_COND 出荷条件(String)
PP_SEARCH 品目提案検索条件(String)
DUN_COUNT 得意先商談回数(String)
DUN_DATE 得意先との前回の商談日(String)
DLVSCHDUSE 用途区分(String)
PLDLVSTYP MRP: 出荷計画タイプ(String)
REF_DOC 参照伝票番号(String)
COMP_CDE_B 請求対象会社コード(String)
ALTTAX_CLS 代替税分類(String)
TAX_CLASS2 得意先税分類 2(String)
TAX_CLASS3 得意先税分類 3(String)
TAX_CLASS4 得意先に対する税クラス 4(String)
TAX_CLASS5 得意先に対する税クラス 5(String)
TAX_CLASS6 得意先に対する税クラス 6(String)
TAX_CLASS7 得意先に対する税クラス 7(String)
TAX_CLASS8 得意先に対する税クラス 8(String)
TAX_CLASS9 得意先に対する税クラス 9(String)
REF_DOC_L 参照伝票番号(String)
ASS_NUMBER 割当番号(String)
REFDOC_CAT 先行販売管理伝票の伝票カテゴリ(String)
ORDCOMB_IN 受注結合出荷区分(String)
BILL_SCHED 請求日程 (稼働日カレンダ指定)(String)
INVO_SCHED 請求書一覧日程 (稼働日カレンダ指定)(String)
MN_INVOICE マニュアル請求書更新(String)
EXRATE_FI FI 転記の換算レート (直接相場)(String)
ADD_VAL_DY 有効日からの日数(String)
FIX_VAL_DY 有効日日付(String)
PYMT_METH 支払方法(String)
ACCNT_ASGN 得意先の勘定設定グループ(String)
EXCHG_RATE 価格設定/統計の換算レート (直接引用)(String)
BILL_DATE 請求索引および印刷に対する請求日(String)
SERV_DATE サービス提供日(String)
DUNN_KEY 督促処理キー(String)
DUNN_BLOCK 督促処理保留(String)
PMTGAR_PRO 支払保証決定表(String)
DEPARTM_NO 部門コード(String)
REC_POINT 入荷ポイント(String)
DOC_NUM_FI ドキュメンタリクレジット処理: 内部番号(String)
CSTCNDGRP1 得意先条件グループ１(String)
CSTCNDGRP2 得意先条件グループ２(String)
CSTCNDGRP3 得意先条件グループ３(String)
CSTCNDGRP4 得意先条件グループ４(String)
CSTCNDGRP5 得意先条件グループ５(String)
DLV_TIME 契約出荷期間(String)
CURRENCY 販売伝票通貨(String)
CURR_ISO ISO コード通貨(String)
CREATED_BY オブジェクト登録者名(String)
TAXDEP_CTY 税出荷国(String)
TAXDST_CTY 税仕向国(String)
EUTRI_DEAL フラグ: EC 内三角取引(String)
MAST_CONTR グループマスタ契約番号(String)
REF_PROC 参照限定条件: 決定区分(String)
CHKPRTAUTH 取引先権限チェック(String)
CMLQTY_DAT 累積出荷数量日付(String)
VERSION 販売伝票バージョン番号(String)
NOTIF_NO 通知番号(String)
WBS_ELEM WBS 要素(String)
EXCH_RATE_FI_V FI 転記の換算レート (間接相場)(String)
EXCHG_RATE_V 価格設定/統計の換算レート (間接引用)(String)
FKK_CONACCT 長さ 12 の文字項目(String)
CAMPAIGN 総括プロジェクト計画: 外部 SAP システムの GUID(String)
DOC_CLASS リリースおよびトランザクション管理 を備えた元システム(String)
H_CURR 通貨コード(String)
H_CURR_ISO ISO 通貨コード(String)
SHIP_TYPE 出荷タイプ(String)
S_PROC_IND 特別処理区分(String)
REF_DOC_L_LONG 参照伝票番号 (依存関係についてはテキスト (長) を参照)(String)
LINE_TIME 納入日程の提案時刻 (現地時間: 販売組織参照)
CALC_MOTIVE 計算区分

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryHeaderInX

Object getInquiryHeaderInX ()

ヘッダデータチェックボックスを取得します。
返却値
Object ヘッダデータチェックボックス

ヘッダデータチェックボックスオブジェクトの構成は以下のとおりです。
ヘッダデータチェックボックス
オブジェクト
(Object)
UPDATEFLAG 更新区分 (String)
DOC_TYPE 関連ユーザデータ項目の更新情報 (String)
COLLECT_NO 関連ユーザデータ項目の更新情報 (String)
SALES_ORG 関連ユーザデータ項目の更新情報 (String)
DISTR_CHAN 関連ユーザデータ項目の更新情報 (String)
DIVISION 関連ユーザデータ項目の更新情報 (String)
SALES_GRP 関連ユーザデータ項目の更新情報 (String)
SALES_OFF 関連ユーザデータ項目の更新情報 (String)
REQ_DATE_H 関連ユーザデータ項目の更新情報 (String)
DATE_TYPE 関連ユーザデータ項目の更新情報 (String)
PURCH_DATE 関連ユーザデータ項目の更新情報 (String)
PO_METHOD 関連ユーザデータ項目の更新情報 (String)
PO_SUPPLEM 関連ユーザデータ項目の更新情報 (String)
REF_1 関連ユーザデータ項目の更新情報 (String)
NAME 関連ユーザデータ項目の更新情報 (String)
TELEPHONE 関連ユーザデータ項目の更新情報 (String)
PRICE_GRP 関連ユーザデータ項目の更新情報 (String)
CUST_GROUP 関連ユーザデータ項目の更新情報 (String)
SALES_DIST 関連ユーザデータ項目の更新情報 (String)
PRICE_LIST 関連ユーザデータ項目の更新情報 (String)
INCOTERMS1 関連ユーザデータ項目の更新情報 (String)
INCOTERMS2 関連ユーザデータ項目の更新情報 (String)
PMNTTRMS 関連ユーザデータ項目の更新情報 (String)
DLV_BLOCK 関連ユーザデータ項目の更新情報 (String)
BILL_BLOCK 関連ユーザデータ項目の更新情報 (String)
ORD_REASON 関連ユーザデータ項目の更新情報 (String)
COMPL_DLV 関連ユーザデータ項目の更新情報 (String)
PRICE_DATE 関連ユーザデータ項目の更新情報 (String)
QT_VALID_F 関連ユーザデータ項目の更新情報 (String)
QT_VALID_T 関連ユーザデータ項目の更新情報 (String)
CT_VALID_F 関連ユーザデータ項目の更新情報 (String)
CT_VALID_T 関連ユーザデータ項目の更新情報 (String)
CUST_GRP1 関連ユーザデータ項目の更新情報 (String)
CUST_GRP2 関連ユーザデータ項目の更新情報 (String)
CUST_GRP3 関連ユーザデータ項目の更新情報 (String)
CUST_GRP4 関連ユーザデータ項目の更新情報 (String)
CUST_GRP5 関連ユーザデータ項目の更新情報 (String)
PURCH_NO_C 関連ユーザデータ項目の更新情報 (String)
PURCH_NO_S 関連ユーザデータ項目の更新情報 (String)
PO_DAT_S 関連ユーザデータ項目の更新情報 (String)
PO_METH_S 関連ユーザデータ項目の更新情報 (String)
REF_1_S 関連ユーザデータ項目の更新情報 (String)
SD_DOC_CAT 関連ユーザデータ項目の更新情報 (String)
DOC_DATE 関連ユーザデータ項目の更新情報 (String)
WAR_DATE 関連ユーザデータ項目の更新情報 (String)
SHIP_COND 関連ユーザデータ項目の更新情報 (String)
PP_SEARCH 関連ユーザデータ項目の更新情報 (String)
DUN_COUNT 関連ユーザデータ項目の更新情報 (String)
DUN_DATE 関連ユーザデータ項目の更新情報 (String)
DLVSCHDUSE 関連ユーザデータ項目の更新情報 (String)
PLDLVSTYP 関連ユーザデータ項目の更新情報 (String)
REF_DOC 関連ユーザデータ項目の更新情報 (String)
COMP_CDE_B 関連ユーザデータ項目の更新情報 (String)
ALTTAX_CLS 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS2 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS3 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS4 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS5 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS6 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS7 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS8 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS9 関連ユーザデータ項目の更新情報 (String)
REF_DOC_L 関連ユーザデータ項目の更新情報 (String)
ASS_NUMBER 関連ユーザデータ項目の更新情報 (String)
REFDOC_CAT 関連ユーザデータ項目の更新情報 (String)
ORDCOMB_IN 関連ユーザデータ項目の更新情報 (String)
BILL_SCHED 関連ユーザデータ項目の更新情報 (String)
INVO_SCHED 関連ユーザデータ項目の更新情報 (String)
MN_INVOICE 関連ユーザデータ項目の更新情報 (String)
EXRATE_FI 関連ユーザデータ項目の更新情報 (String)
ADD_VAL_DY 関連ユーザデータ項目の更新情報 (String)
FIX_VAL_DY 関連ユーザデータ項目の更新情報 (String)
PYMT_METH 関連ユーザデータ項目の更新情報 (String)
ACCNT_ASGN 関連ユーザデータ項目の更新情報 (String)
EXCHG_RATE 関連ユーザデータ項目の更新情報 (String)
BILL_DATE 関連ユーザデータ項目の更新情報 (String)
SERV_DATE 関連ユーザデータ項目の更新情報 (String)
DUNN_KEY 関連ユーザデータ項目の更新情報 (String)
DUNN_BLOCK 関連ユーザデータ項目の更新情報 (String)
PROMOTION 関連ユーザデータ項目の更新情報 (String)
PMTGAR_PRO 関連ユーザデータ項目の更新情報 (String)
DEPARTM_NO 関連ユーザデータ項目の更新情報 (String)
REC_POINT 関連ユーザデータ項目の更新情報 (String)
POITM_NO_S 関連ユーザデータ項目の更新情報 (String)
DOC_NUM_FI 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP1 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP2 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP3 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP4 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP5 関連ユーザデータ項目の更新情報 (String)
DLV_TIME 関連ユーザデータ項目の更新情報 (String)
CURRENCY 関連ユーザデータ項目の更新情報 (String)
TAXDEP_CTY 関連ユーザデータ項目の更新情報 (String)
TAXDST_CTY 関連ユーザデータ項目の更新情報 (String)
EUTRI_DEAL 関連ユーザデータ項目の更新情報 (String)
MAST_CONTR 関連ユーザデータ項目の更新情報 (String)
REF_PROC 関連ユーザデータ項目の更新情報 (String)
CHKPRTAUTH 関連ユーザデータ項目の更新情報 (String)
CMLQTY_DAT 関連ユーザデータ項目の更新情報 (String)
VERSION 関連ユーザデータ項目の更新情報 (String)
NOTIF_NO 関連ユーザデータ項目の更新情報 (String)
WBS_ELEM 関連ユーザデータ項目の更新情報 (String)
EXCH_RATE_FI_V 関連ユーザデータ項目の更新情報 (String)
EXCHG_RATE_V 関連ユーザデータ項目の更新情報 (String)
FKK_CONACCT 関連ユーザデータ項目の更新情報 (String)
CAMPAIGN 関連ユーザデータ項目の更新情報 (String)
DOC_CLASS 関連ユーザデータ項目の更新情報 (String)
H_CURR 関連ユーザデータ項目の更新情報 (String)
SHIP_TYPE 関連ユーザデータ項目の更新情報 (String)
S_PROC_IND 関連ユーザデータ項目の更新情報 (String)
LINE_TIME 関連ユーザデータ項目の更新情報
CALC_MOTIVE 関連ユーザデータ項目の更新情報

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryItemsInList

Array getInquiryItemsInList ()

明細データを取得します。
返却値
Array 明細データ

明細データオブジェクトの構成は以下のとおりです。
明細データ
オブジェクト
(Object)
ITM_NUMBER 販売伝票明細 (String)
HG_LV_ITEM 上位レベル明細 (String)
PO_ITM_NO 元となる購買発注の明細番号 (String)
MATERIAL 品目コード (String)
ALT_TO_ITM 代替明細 (String)
CUST_MAT22 得意先品目コード (無効) (String)
BATCH ロット番号 (String)
DLV_GROUP 出荷グループ (明細一括出荷) (String)
PART_DLV 明細レベルの分納納入 (String)
REASON_REJ 見積および受注の拒否理由 (String)
BILL_BLOCK ブロック (String)
BILL_DATE 請求索引および印刷に対する請求日 (String)
PLANT プラント (String)
STORE_LOC 保管場所 (String)
TARGET_QTY 目標数量（販売単位） (String)
TARGET_QU 目標数量 (数量単位) (String)
T_UNIT_ISO 目標数量単位 (ISO コード) (String)
ITEM_CATEG 明細カテゴリ (販売伝票) (String)
SHORT_TEXT テキスト (短): 受注明細 (String)
PRC_GROUP1 品目グループ 1 (String)
PRC_GROUP2 品目グループ 2 (String)
PRC_GROUP3 品目グループ 3 (String)
PRC_GROUP4 品目グループ 4 (String)
PRC_GROUP5 品目グループ 5 (String)
PROD_HIERA 品目階層 (String)
MATL_GROUP 品目グループ (String)
PURCH_NO_C 出荷先発注番号 (String)
PURCH_DATE 得意先発注日付 (String)
PO_METHOD 得意先発注タイプ (String)
REF_1 得意先/仕入先の内部参照コード (String)
PURCH_NO_S 出荷先の得意先発注番号 (String)
PO_DAT_S 出荷先の出荷先発注日付 (String)
PO_METH_S 出荷先の出荷先発注タイプ (String)
REF_1_S 出荷先文字 (String)
POITM_NO_S 元となる購買発注の明細番号 (String)
PRICE_GRP 価格グループ (得意先) (String)
CUST_GROUP 得意先グループ (String)
SALES_DIST 販売地域 (String)
PRICE_LIST 価格表タイプ (String)
INCOTERMS1 インコタームズ (1) (String)
INCOTERMS2 インコタームズ 2 (String)
ORDCOMP_IN 受注結合出荷区分 (String)
BILL_SCHED 請求日程 (稼働日カレンダ指定) (String)
INVO_SCHED 請求書一覧日程 (稼働日カレンダ指定) (String)
MN_INVOICE マニュアル請求書更新 (String)
EX_RATE_FI FI 転記の換算レート (直接相場) (String)
ADD_VAL_DY 有効日からの日数 (String)
FIX_VAL_DY 有効日日付 (String)
PMNTTRMS 支払条件キー (String)
PYMT_METH 支払方法 (String)
ACCNT_ASGN 得意先の勘定設定グループ (String)
EXCHG_RATE 価格設定/統計の換算レート (直接引用) (String)
PRICE_DATE 価格設定/外貨換算の実行日付 (String)
SERV_DATE サービス提供日 (String)
DUNN_KEY 督促処理キー (String)
DUNN_BLOCK 督促処理保留 (String)
PROMOTION プロモーション (String)
PMTGAR_PRO 支払保証決定表 (String)
DOC_NUM_FI ドキュメンタリクレジット処理: 内部番号 (String)
DEPARTM_NO 部門コード (String)
REC_POINT 入荷ポイント (String)
CSTCNDGRP1 得意先条件グループ１ (String)
CSTCNDGRP2 得意先条件グループ２ (String)
CSTCNDGRP3 得意先条件グループ３ (String)
CSTCNDGRP4 得意先条件グループ４ (String)
CSTCNDGRP5 得意先条件グループ５ (String)
DLV_TIME 契約出荷期間 (String)
SALES_UNIT 販売単位 (String)
S_UNIT_ISO 単位の ISO コード (String)
TRG_QTY_NO 販売単位から基本単位への換算係数 (String)
TRGQTY_DEN 販売単位から基本単位への換算係数 (String)
RNDDLV_QTY 丸め数量: 出荷 (String)
MAXDEVAMNT 数量に関する許容偏差 (絶対値) (String)
MAXDEVPER 数量に関する許容偏差 (%) (String)
MAXDEV_DAY シフト所要日数 (String)
USAGE_IND 未使用 - 予約長 3 (String)
FIXED_QUAN 数量固定区分 (String)
UNLMT_DLV 区分: 無制限過剰納入可能 (String)
OVERDLVTOL 過剰納入許容範囲 (String)
UNDDLV_TOL 不足納入許容範囲リミット (String)
DIVISION 製品部門 (String)
SALQTYNUM 販売数量単位から基本数量単位への変換係数の分子 (String)
SALQTYDEN 販売数量単位を SKU に換算するための分母 (除数) (String)
GROSS_WGHT 明細の総重量 (String)
NET_WEIGHT 明細の正味重量 (String)
UNTOF_WGHT 重量単位 (String)
UNOF_WTISO ISO コードでの重量単位 (String)
VOLUME 明細の総数量 (String)
VOLUNIT 容積単位 (String)
VOLUNITISO ISO コードでの容積単位 (String)
DLV_PRIO 出荷優先順位 (String)
SHIP_POINT 出荷ポイント/入荷ポイント (String)
ROUTE 輸送経路 (String)
CREATED_BY オブジェクト登録者名 (String)
TAX_CLASS1 品目の税分類 (String)
TAX_CLASS2 品目の税分類 (String)
TAX_CLASS3 品目の税分類 (String)
TAX_CLASS4 品目の税分類 (String)
TAX_CLASS5 品目の税分類 (String)
TAX_CLASS6 品目の税分類 (String)
TAX_CLASS7 品目の税分類 (String)
TAX_CLASS8 品目の税分類 (String)
TAX_CLASS9 品目の税分類 (String)
MAT_PR_GRP 品目価格設定グループ (String)
VAL_TYPE 評価タイプ (String)
FIXDAT_QTY 納期と出荷数量の固定 (String)
BOMEXPL_NO BOM 展開番号 (String)
RESANALKEY 結果分析キー (String)
REQMTS_TYP 所要量タイプ (String)
NO_GR_POST 得意先が入庫を転記していません (String)
BUS_TRANST 貿易管理の取引タイプ (String)
OVERHD_KEY 間接費キー (String)
CSTG_SHEET 原価計算表 (String)
MATFRGTGRP 品目運賃グループ (String)
PLDLVSHDIN 出荷計画に関する指示 (String)
SEQ_NO KANBAN/連続番号 (String)
BIL_FORM 請求書式 (String)
DLI_PROFIL 動的明細プロセッサプロファイル (String)
REV_TYPE 収益承認カテゴリ (String)
BEGDEM_PER 見越期間の提案開始日付 (String)
PR_REF_MAT 価格設定参照品目 (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)
ORDER_PROB 明細の受注可能性 (String)
MAX_PL_DLV 明細ごとの分割納入可能な最大回数 (String)
CFOP_CODE CFOP code and extension (old 5 char version) (String)
TAXLAWICMS 税法: ICMS (String)
TAXLAWIPI 税法: IPI (String)
SD_TAXCODE 0 (String)
ASSORT_MOD 品揃モジュール (String)
COMP_QUANT 構成品目数量 (String)
TARGET_VAL BAPI の通貨額 (小数点以下９桁) (String)
CURRENCY 販売伝票通貨 (String)
CURR_ISO ISO コード通貨 (String)
PROFIT_CTR 利益センタ (String)
ORDERID 指図番号 (String)
WBS_ELEM WBS 要素 (String)
DEPREC_PER ドキュメンタリクレジット処理に関する償却率 (%) (String)
REF_DOC 参照伝票番号 (String)
REF_DOC_IT 参照明細番号 (String)
REF_DOC_CA 先行販売管理伝票の伝票カテゴリ (String)
CUST_MAT35 得意先品目 (String)
EXCH_RATE_FI_V FI 転記の換算レート (間接相場) (String)
EXCHG_RATE_V 価格設定/統計の換算レート (間接引用) (String)
ITEMGUID_ATP ATP: 暗号 - DELNR および DELPS (String)
VAL_CONTR 金額契約番号 (String)
VAL_CON_I 金額契約明細 (String)
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)
MAT_EXT 項目 MATERIAL の品目コード (長) (今後のリリースで開発) (String)
MAT_GUID 項目 MATERIAL の外部 GUID (今後のリリースで開発) (String)
MAT_VERS 項目 MATERIAL のバージョン番号 (今後のリリースで開発) (String)
P_MAT_EXT 項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発) (String)
P_MAT_GUID 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発) (String)
P_MAT_VERS 項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発) (String)
FUNC_AREA 機能領域 (String)
ALTERN_BOM 代替 BOM (String)
FKK_CONACCT 長さ 12 の文字項目 (String)
EAN_UPC 国際商品コード (EAN/UPC) (String)
PRODCAT 製品カタログ番号 (String)
SHIP_TYPE 出荷タイプ (String)
S_PROC_IND 特別処理区分 (String)
FUNC_AREA_LONG 機能領域 (String)
BILL_REL 請求関連 (CRM) (String)
VW_UEPOS 上位レベル明細用途 ID (String)
CAMPAIGN 総括プロジェクト計画: 外部 SAP システムの GUID (String)
DLVSCHDUSE 用途区分 (String)
CFOP_LONG CFOP code and extension (String)
SELECTION 選択 ID (永続) (String)
MAT_ENTRD 入力品目 (String)
LOG_SYSTEM_OWN 論理システム (String)
ITM_TYPE_USAGE 明細用途 (String)
TAXLAWISS ISS Tax Law (String)
MAT_ENTRD_EXTERNAL 項目 MAT_ENTRD の品目コード (長) (String)
MAT_ENTRD_GUID 項目 MAT_ENTRD の外部 GUID (String)
MAT_ENTRD_VERSION 項目 MAT_ENTRD のバージョン番号 (String)
LOC_TAXCAT 税タイプ (String)
LOC_ZEROVAT LOC_ZEROVAT (String)
LOC_ACTCODE 総所得税の活動コード (String)
LOC_DISTTYPE 所得税の配賦タイプ (String)
LOC_TXRELCLAS 税関連分類 (String)
CALC_MOTIVE 計算区分 (String)

明細データオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の明細データの「販売伝票明細」
[idx]["HG_LV_ITEM"]　→　配列内のidx番目の明細データの「上位レベル明細」
[idx]["PO_ITM_NO"]　→　配列内のidx番目の明細データの「元となる購買発注の明細番号」
[idx]["MATERIAL"]　→　配列内のidx番目の明細データの「品目コード」
[idx]["ALT_TO_ITM"]　→　配列内のidx番目の明細データの「代替明細」
[idx]["CUST_MAT22"]　→　配列内のidx番目の明細データの「得意先品目コード (無効)」
[idx]["BATCH"]　→　配列内のidx番目の明細データの「ロット番号」
[idx]["DLV_GROUP"]　→　配列内のidx番目の明細データの「出荷グループ (明細一括出荷)」
[idx]["PART_DLV"]　→　配列内のidx番目の明細データの「明細レベルの分納納入」
[idx]["REASON_REJ"]　→　配列内のidx番目の明細データの「見積および受注の拒否理由」
[idx]["BILL_BLOCK"]　→　配列内のidx番目の明細データの「ブロック」
[idx]["BILL_DATE"]　→　配列内のidx番目の明細データの「請求索引および印刷に対する請求日」
[idx]["PLANT"]　→　配列内のidx番目の明細データの「プラント」
[idx]["STORE_LOC"]　→　配列内のidx番目の明細データの「保管場所」
[idx]["TARGET_QTY"]　→　配列内のidx番目の明細データの「目標数量（販売単位）」
[idx]["TARGET_QU"]　→　配列内のidx番目の明細データの「目標数量 (数量単位)」
[idx]["T_UNIT_ISO"]　→　配列内のidx番目の明細データの「目標数量単位 (ISO コード)」
[idx]["ITEM_CATEG"]　→　配列内のidx番目の明細データの「明細カテゴリ (販売伝票)」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の明細データの「テキスト (短): 受注明細」
[idx]["PRC_GROUP1"]　→　配列内のidx番目の明細データの「品目グループ 1」
[idx]["PRC_GROUP2"]　→　配列内のidx番目の明細データの「品目グループ 2」
[idx]["PRC_GROUP3"]　→　配列内のidx番目の明細データの「品目グループ 3」
[idx]["PRC_GROUP4"]　→　配列内のidx番目の明細データの「品目グループ 4」
[idx]["PRC_GROUP5"]　→　配列内のidx番目の明細データの「品目グループ 5」
[idx]["PROD_HIERA"]　→　配列内のidx番目の明細データの「品目階層」
[idx]["MATL_GROUP"]　→　配列内のidx番目の明細データの「品目グループ」
[idx]["PURCH_NO_C"]　→　配列内のidx番目の明細データの「出荷先発注番号」
[idx]["PURCH_DATE"]　→　配列内のidx番目の明細データの「得意先発注日付」
[idx]["PO_METHOD"]　→　配列内のidx番目の明細データの「得意先発注タイプ」
[idx]["REF_1"]　→　配列内のidx番目の明細データの「得意先/仕入先の内部参照コード」
[idx]["PURCH_NO_S"]　→　配列内のidx番目の明細データの「出荷先の得意先発注番号」
[idx]["PO_DAT_S"]　→　配列内のidx番目の明細データの「出荷先の出荷先発注日付」
[idx]["PO_METH_S"]　→　配列内のidx番目の明細データの「出荷先の出荷先発注タイプ」
[idx]["REF_1_S"]　→　配列内のidx番目の明細データの「出荷先文字」
[idx]["POITM_NO_S"]　→　配列内のidx番目の明細データの「元となる購買発注の明細番号」
[idx]["PRICE_GRP"]　→　配列内のidx番目の明細データの「価格グループ (得意先)」
[idx]["CUST_GROUP"]　→　配列内のidx番目の明細データの「得意先グループ」
[idx]["SALES_DIST"]　→　配列内のidx番目の明細データの「販売地域」
[idx]["PRICE_LIST"]　→　配列内のidx番目の明細データの「価格表タイプ」
[idx]["INCOTERMS1"]　→　配列内のidx番目の明細データの「インコタームズ (1)」
[idx]["INCOTERMS2"]　→　配列内のidx番目の明細データの「インコタームズ 2」
[idx]["ORDCOMP_IN"]　→　配列内のidx番目の明細データの「受注結合出荷区分」
[idx]["BILL_SCHED"]　→　配列内のidx番目の明細データの「請求日程 (稼働日カレンダ指定)」
[idx]["INVO_SCHED"]　→　配列内のidx番目の明細データの「請求書一覧日程 (稼働日カレンダ指定)」
[idx]["MN_INVOICE"]　→　配列内のidx番目の明細データの「マニュアル請求書更新」
[idx]["EX_RATE_FI"]　→　配列内のidx番目の明細データの「FI 転記の換算レート (直接相場)」
[idx]["ADD_VAL_DY"]　→　配列内のidx番目の明細データの「有効日からの日数」
[idx]["FIX_VAL_DY"]　→　配列内のidx番目の明細データの「有効日日付」
[idx]["PMNTTRMS"]　→　配列内のidx番目の明細データの「支払条件キー」
[idx]["PYMT_METH"]　→　配列内のidx番目の明細データの「支払方法」
[idx]["ACCNT_ASGN"]　→　配列内のidx番目の明細データの「得意先の勘定設定グループ」
[idx]["EXCHG_RATE"]　→　配列内のidx番目の明細データの 「価格設定/統計の換算レート (直接引用)」
[idx]["PRICE_DATE"]　→　配列内のidx番目の明細データの「価格設定/外貨換算の実行日付」
[idx]["SERV_DATE"]　→　配列内のidx番目の明細データの「サービス提供日」
[idx]["DUNN_KEY"]　→　配列内のidx番目の明細データの「督促処理キー」
[idx]["DUNN_BLOCK"]　→　配列内のidx番目の明細データの「督促処理保留」
[idx]["PROMOTION"]　→　配列内のidx番目の明細データの「プロモーション」
[idx]["PMTGAR_PRO"]　→　配列内のidx番目の明細データの「支払保証決定表」
[idx]["DOC_NUM_FI"]　→　配列内のidx番目の明細データの 「ドキュメンタリクレジット処理: 内部番号」
[idx]["DEPARTM_NO"]　→　配列内のidx番目の明細データの「部門コード」
[idx]["REC_POINT"]　→　配列内のidx番目の明細データの「入荷ポイント」
[idx]["CSTCNDGRP1"]　→　配列内のidx番目の明細データの「得意先条件グループ１」
[idx]["CSTCNDGRP2"]　→　配列内のidx番目の明細データの「得意先条件グループ２」
[idx]["CSTCNDGRP3"]　→　配列内のidx番目の明細データの「得意先条件グループ３」
[idx]["CSTCNDGRP4"]　→　配列内のidx番目の明細データの「得意先条件グループ４」
[idx]["CSTCNDGRP5"]　→　配列内のidx番目の明細データの「得意先条件グループ５」
[idx]["DLV_TIME"]　→　配列内のidx番目の明細データの「契約出荷期間」
[idx]["SALES_UNIT"]　→　配列内のidx番目の明細データの「販売単位」
[idx]["S_UNIT_ISO"]　→　配列内のidx番目の明細データの「単位の ISO コード」
[idx]["TRG_QTY_NO"]　→　配列内のidx番目の明細データの「販売単位から基本単位への換算係数」
[idx]["TRGQTY_DEN"]　→　配列内のidx番目の明細データの「販売単位から基本単位への換算係数」
[idx]["RNDDLV_QTY"]　→　配列内のidx番目の明細データの「丸め数量: 出荷」
[idx]["MAXDEVAMNT"]　→　配列内のidx番目の明細データの「数量に関する許容偏差 (絶対値)」
[idx]["MAXDEVPER"]　→　配列内のidx番目の明細データの「数量に関する許容偏差 (%)」
[idx]["MAXDEV_DAY"]　→　配列内のidx番目の明細データの「シフト所要日数」
[idx]["USAGE_IND"]　→　配列内のidx番目の明細データの「未使用 - 予約長 3」
[idx]["FIXED_QUAN"]　→　配列内のidx番目の明細データの「数量固定区分」
[idx]["UNLMT_DLV"]　→　配列内のidx番目の明細データの「区分: 無制限過剰納入可能」
[idx]["OVERDLVTOL"]　→　配列内のidx番目の明細データの「過剰納入許容範囲」
[idx]["UNDDLV_TOL"]　→　配列内のidx番目の明細データの「不足納入許容範囲リミット」
[idx]["DIVISION"]　→　配列内のidx番目の明細データの「製品部門」
[idx]["SALQTYNUM"]　→　配列内のidx番目の明細データの 「販売数量単位から基本数量単位への変換係数の分子」
[idx]["SALQTYDEN"]　→　配列内のidx番目の明細データの 「販売数量単位を SKU に換算するための分母 (除数)」
[idx]["GROSS_WGHT"]　→　配列内のidx番目の明細データの「明細の総重量」
[idx]["NET_WEIGHT"]　→　配列内のidx番目の明細データの「明細の正味重量」
[idx]["UNTOF_WGHT"]　→　配列内のidx番目の明細データの「重量単位」
[idx]["UNOF_WTISO"]　→　配列内のidx番目の明細データの「ISO コードでの重量単位」
[idx]["VOLUME"]　→　配列内のidx番目の明細データの「明細の総数量」
[idx]["VOLUNIT"]　→　配列内のidx番目の明細データの「容積単位」
[idx]["VOLUNITISO"]　→　配列内のidx番目の明細データの「ISO コードでの容積単位」
[idx]["DLV_PRIO"]　→　配列内のidx番目の明細データの「出荷優先順位」
[idx]["SHIP_POINT"]　→　配列内のidx番目の明細データの「出荷ポイント/入荷ポイント」
[idx]["ROUTE"]　→　配列内のidx番目の明細データの「輸送経路」
[idx]["CREATED_BY"]　→　配列内のidx番目の明細データの「オブジェクト登録者名」
[idx]["TAX_CLASS1"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS2"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS3"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS4"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS5"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS6"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS7"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS8"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS9"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["MAT_PR_GRP"]　→　配列内のidx番目の明細データの「品目価格設定グループ」
[idx]["VAL_TYPE"]　→　配列内のidx番目の明細データの「評価タイプ」
[idx]["FIXDAT_QTY"]　→　配列内のidx番目の明細データの「納期と出荷数量の固定」
[idx]["BOMEXPL_NO"]　→　配列内のidx番目の明細データの「BOM 展開番号」
[idx]["RESANALKEY"]　→　配列内のidx番目の明細データの「結果分析キー」
[idx]["REQMTS_TYP"]　→　配列内のidx番目の明細データの「所要量タイプ」
[idx]["NO_GR_POST"]　→　配列内のidx番目の明細データの「得意先が入庫を転記していません」
[idx]["BUS_TRANST"]　→　配列内のidx番目の明細データの「貿易管理の取引タイプ」
[idx]["OVERHD_KEY"]　→　配列内のidx番目の明細データの「間接費キー」
[idx]["CSTG_SHEET"]　→　配列内のidx番目の明細データの「原価計算表」
[idx]["MATFRGTGRP"]　→　配列内のidx番目の明細データの「品目運賃グループ」
[idx]["PLDLVSHDIN"]　→　配列内のidx番目の明細データの「出荷計画に関する指示」
[idx]["SEQ_NO"]　→　配列内のidx番目の明細データの「KANBAN/連続番号」
[idx]["BIL_FORM"]　→　配列内のidx番目の明細データの「請求書式」
[idx]["DLI_PROFIL"]　→　配列内のidx番目の明細データの「動的明細プロセッサプロファイル」
[idx]["REV_TYPE"]　→　配列内のidx番目の明細データの「収益承認カテゴリ」
[idx]["BEGDEM_PER"]　→　配列内のidx番目の明細データの「見越期間の提案開始日付」
[idx]["PR_REF_MAT"]　→　配列内のidx番目の明細データの「価格設定参照品目」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の明細データの「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の明細データの「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の明細データの「論理システム」
[idx]["ORDER_PROB"]　→　配列内のidx番目の明細データの「明細の受注可能性」
[idx]["MAX_PL_DLV"]　→　配列内のidx番目の明細データの「明細ごとの分割納入可能な最大回数」
[idx]["CFOP_CODE"]　→　配列内のidx番目の明細データの 「CFOP code and extension (old 5 char version)」
[idx]["TAXLAWICMS"]　→　配列内のidx番目の明細データの「税法: ICMS」
[idx]["TAXLAWIPI"]　→　配列内のidx番目の明細データの「税法: IPI」
[idx]["SD_TAXCODE"]　→　配列内のidx番目の明細データの「0」
[idx]["ASSORT_MOD"]　→　配列内のidx番目の明細データの「品揃モジュール」
[idx]["COMP_QUANT"]　→　配列内のidx番目の明細データの「構成品目数量」
[idx]["TARGET_VAL"]　→　配列内のidx番目の明細データの「BAPI の通貨額 (小数点以下９桁)」
[idx]["CURRENCY"]　→　配列内のidx番目の明細データの「販売伝票通貨」
[idx]["CURR_ISO"]　→　配列内のidx番目の明細データの「ISO コード通貨」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の明細データの「利益センタ」
[idx]["ORDERID"]　→　配列内のidx番目の明細データの「指図番号」
[idx]["WBS_ELEM"]　→　配列内のidx番目の明細データの「WBS 要素」
[idx]["DEPREC_PER"]　→　配列内のidx番目の明細データの 「ドキュメンタリクレジット処理に関する償却率 (%)」
[idx]["REF_DOC"]　→　配列内のidx番目の明細データの「参照伝票番号」
[idx]["REF_DOC_IT"]　→　配列内のidx番目の明細データの「参照明細番号」
[idx]["REF_DOC_CA"]　→　配列内のidx番目の明細データの「先行販売管理伝票の伝票カテゴリ」
[idx]["CUST_MAT35"]　→　配列内のidx番目の明細データの「得意先品目」
[idx]["EXCH_RATE_FI_V"]　→　配列内のidx番目の明細データの 「FI 転記の換算レート (間接相場)」
[idx]["EXCHG_RATE_V"]　→　配列内のidx番目の明細データの 「価格設定/統計の換算レート (間接引用)」
[idx]["ITEMGUID_ATP"]　→　配列内のidx番目の明細データの 「ATP: 暗号 - DELNR および DELPS」
[idx]["VAL_CONTR"]　→　配列内のidx番目の明細データの「金額契約番号」
[idx]["VAL_CON_I"]　→　配列内のidx番目の明細データの「金額契約明細」
[idx]["CONFIG_ID"]　→　配列内のidx番目の明細データの「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の明細データの「選定におけるインスタンス番号」
[idx]["MAT_EXT"]　→　配列内のidx番目の明細データの 「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["MAT_GUID"]　→　配列内のidx番目の明細データの 「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["MAT_VERS"]　→　配列内のidx番目の明細データの 「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」
[idx]["P_MAT_EXT"]　→　配列内のidx番目の明細データの 「項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)」
[idx]["P_MAT_GUID"]　→　配列内のidx番目の明細データの 「項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)」
[idx]["P_MAT_VERS"]　→　配列内のidx番目の明細データの 「項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)」
[idx]["FUNC_AREA"]　→　配列内のidx番目の明細データの「機能領域」
[idx]["ALTERN_BOM"]　→　配列内のidx番目の明細データの「代替 BOM」
[idx]["FKK_CONACCT"]　→　配列内のidx番目の明細データの「長さ 12 の文字項目」
[idx]["EAN_UPC"]　→　配列内のidx番目の明細データの「国際商品コード (EAN/UPC)」
[idx]["PRODCAT"]　→　配列内のidx番目の明細データの「製品カタログ番号」
[idx]["SHIP_TYPE"]　→　配列内のidx番目の明細データの「出荷タイプ」
[idx]["S_PROC_IND"]　→　配列内のidx番目の明細データの「特別処理区分」
[idx]["FUNC_AREA_LONG"]　→　配列内のidx番目の明細データの「機能領域」
[idx]["BILL_REL"]　→　配列内のidx番目の明細データの「請求関連 (CRM)」
[idx]["VW_UEPOS"]　→　配列内のidx番目の明細データの「上位レベル明細用途 ID」
[idx]["CAMPAIGN"]　→　配列内のidx番目の明細データの 「総括プロジェクト計画: 外部 SAP システムの GUID」
[idx]["DLVSCHDUSE"]　→　配列内のidx番目の明細データの「用途区分」
[idx]["CFOP_LONG"]　→　配列内のidx番目の明細データの 「CFOP code and extension」
[idx]["SELECTION"]　→　配列内のidx番目の明細データの「選択 ID (永続)」
[idx]["MAT_ENTRD"]　→　配列内のidx番目の明細データの「入力品目」
[idx]["LOG_SYSTEM_OWN"]　→　配列内のidx番目の明細データの「論理システム」
[idx]["ITM_TYPE_USAGE"]　→　配列内のidx番目の明細データの「明細用途」
[idx]["TAXLAWISS"]　→　配列内のidx番目の明細データの「ISS Tax Law」
[idx]["MAT_ENTRD_EXTERNAL"]　→　配列内のidx番目の明細データの 「項目 MAT_ENTRD の品目コード (長)」
[idx]["MAT_ENTRD_GUID"]　→　配列内のidx番目の明細データの 「項目 MAT_ENTRD の外部 GUID」
[idx]["MAT_ENTRD_VERSION"]　→　配列内のidx番目の明細データの 「項目 MAT_ENTRD のバージョン番号」
[idx]["LOC_TAXCAT"]　→　配列内のidx番目の明細データの「税タイプ」
[idx]["LOC_ZEROVAT"]　→　配列内のidx番目の明細データの「LOC_ZEROVAT」
[idx]["LOC_ACTCODE"]　→　配列内のidx番目の明細データの「総所得税の活動コード」
[idx]["LOC_DISTTYPE"]　→　配列内のidx番目の明細データの「所得税の配賦タイプ」
[idx]["LOC_TXRELCLAS"]　→　配列内のidx番目の明細データの「税関連分類」
[idx]["CALC_MOTIVE"]　→　配列内のidx番目の明細データの「計算区分」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryItemsInXList

Array getInquiryItemsInXList ()

明細データチェックボックスを取得します。
返却値
Array 明細データチェックボックス

明細データチェックボックスオブジェクトの構成は以下のとおりです。
明細データチェックボックス
オブジェクト
(Object)
ITM_NUMBER 販売伝票明細 (String)
UPDATEFLAG 更新区分 (String)
HG_LV_ITEM 関連ユーザデータ項目の更新情報 (String)
PO_ITM_NO 関連ユーザデータ項目の更新情報 (String)
MATERIAL 関連ユーザデータ項目の更新情報 (String)
ALT_TO_ITM 関連ユーザデータ項目の更新情報 (String)
CUST_MAT22 関連ユーザデータ項目の更新情報 (String)
BATCH 関連ユーザデータ項目の更新情報 (String)
DLV_GROUP 関連ユーザデータ項目の更新情報 (String)
PART_DLV 関連ユーザデータ項目の更新情報 (String)
REASON_REJ 関連ユーザデータ項目の更新情報 (String)
BILL_BLOCK 関連ユーザデータ項目の更新情報 (String)
BILL_DATE 関連ユーザデータ項目の更新情報 (String)
PLANT 関連ユーザデータ項目の更新情報 (String)
STORE_LOC 関連ユーザデータ項目の更新情報 (String)
TARGET_QTY 関連ユーザデータ項目の更新情報 (String)
TARGET_QU 関連ユーザデータ項目の更新情報 (String)
T_UNIT_ISO 関連ユーザデータ項目の更新情報 (String)
ITEM_CATEG 関連ユーザデータ項目の更新情報 (String)
SHORT_TEXT 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP1 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP2 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP3 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP4 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP5 関連ユーザデータ項目の更新情報 (String)
PROD_HIERA 関連ユーザデータ項目の更新情報 (String)
MATL_GROUP 関連ユーザデータ項目の更新情報 (String)
PURCH_NO_C 関連ユーザデータ項目の更新情報 (String)
PURCH_DATE 関連ユーザデータ項目の更新情報 (String)
PO_METHOD 関連ユーザデータ項目の更新情報 (String)
REF_1 関連ユーザデータ項目の更新情報 (String)
PURCH_NO_S 関連ユーザデータ項目の更新情報 (String)
PO_DAT_S 関連ユーザデータ項目の更新情報 (String)
PO_METH_S 関連ユーザデータ項目の更新情報 (String)
REF_1_S 関連ユーザデータ項目の更新情報 (String)
POITM_NO_S 関連ユーザデータ項目の更新情報 (String)
PRICE_GRP 関連ユーザデータ項目の更新情報 (String)
CUST_GROUP 関連ユーザデータ項目の更新情報 (String)
SALES_DIST 関連ユーザデータ項目の更新情報 (String)
PRICE_LIST 関連ユーザデータ項目の更新情報 (String)
INCOTERMS1 関連ユーザデータ項目の更新情報 (String)
INCOTERMS2 関連ユーザデータ項目の更新情報 (String)
ORDCOMP_IN 関連ユーザデータ項目の更新情報 (String)
BILL_SCHED 関連ユーザデータ項目の更新情報 (String)
INVO_SCHED 関連ユーザデータ項目の更新情報 (String)
MN_INVOICE 関連ユーザデータ項目の更新情報 (String)
EX_RATE_FI 関連ユーザデータ項目の更新情報 (String)
ADD_VAL_DY 関連ユーザデータ項目の更新情報 (String)
FIX_VAL_DY 関連ユーザデータ項目の更新情報 (String)
PMNTTRMS 関連ユーザデータ項目の更新情報 (String)
PYMT_METH 関連ユーザデータ項目の更新情報 (String)
ACCNT_ASGN 関連ユーザデータ項目の更新情報 (String)
EXCHG_RATE 関連ユーザデータ項目の更新情報 (String)
PRICE_DATE 関連ユーザデータ項目の更新情報 (String)
SERV_DATE 関連ユーザデータ項目の更新情報 (String)
DUNN_KEY 関連ユーザデータ項目の更新情報 (String)
DUNN_BLOCK 関連ユーザデータ項目の更新情報 (String)
PROMOTION 関連ユーザデータ項目の更新情報 (String)
PMTGAR_PRO 関連ユーザデータ項目の更新情報 (String)
DOC_NUM_FI 関連ユーザデータ項目の更新情報 (String)
DEPARTM_NO 関連ユーザデータ項目の更新情報 (String)
REC_POINT 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP1 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP2 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP3 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP4 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP5 関連ユーザデータ項目の更新情報 (String)
DLV_TIME 関連ユーザデータ項目の更新情報 (String)
SALES_UNIT 関連ユーザデータ項目の更新情報 (String)
TRG_QTY_NO 関連ユーザデータ項目の更新情報 (String)
TRGQTY_DEN 関連ユーザデータ項目の更新情報 (String)
RNDDLV_QTY 関連ユーザデータ項目の更新情報 (String)
MAXDEVAMNT 関連ユーザデータ項目の更新情報 (String)
MAXDEVPER 関連ユーザデータ項目の更新情報 (String)
MAXDEV_DAY 関連ユーザデータ項目の更新情報 (String)
USAGE_IND 関連ユーザデータ項目の更新情報 (String)
FIXED_QUAN 関連ユーザデータ項目の更新情報 (String)
UNLMT_DLV 関連ユーザデータ項目の更新情報 (String)
OVERDLVTOL 関連ユーザデータ項目の更新情報 (String)
UNDDLV_TOL 関連ユーザデータ項目の更新情報 (String)
DIVISION 関連ユーザデータ項目の更新情報 (String)
SALQTYNUM 関連ユーザデータ項目の更新情報 (String)
SALQTYDEN 関連ユーザデータ項目の更新情報 (String)
GROSS_WGHT 関連ユーザデータ項目の更新情報 (String)
NET_WEIGHT 関連ユーザデータ項目の更新情報 (String)
UNTOF_WGHT 関連ユーザデータ項目の更新情報 (String)
VOLUME 関連ユーザデータ項目の更新情報 (String)
VOLUNIT 関連ユーザデータ項目の更新情報 (String)
DLV_PRIO 関連ユーザデータ項目の更新情報 (String)
SHIP_POINT 関連ユーザデータ項目の更新情報 (String)
ROUTE 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS1 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS2 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS3 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS4 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS5 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS6 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS7 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS8 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS9 関連ユーザデータ項目の更新情報 (String)
MAT_PR_GRP 関連ユーザデータ項目の更新情報 (String)
VAL_TYPE 関連ユーザデータ項目の更新情報 (String)
FIXDAT_QTY 関連ユーザデータ項目の更新情報 (String)
BOMEXPL_NO 関連ユーザデータ項目の更新情報 (String)
RESANALKEY 関連ユーザデータ項目の更新情報 (String)
REQMTS_TYP 関連ユーザデータ項目の更新情報 (String)
NO_GR_POST 関連ユーザデータ項目の更新情報 (String)
BUS_TRANST 関連ユーザデータ項目の更新情報 (String)
OVERHD_KEY 関連ユーザデータ項目の更新情報 (String)
CSTG_SHEET 関連ユーザデータ項目の更新情報 (String)
MATFRGTGRP 関連ユーザデータ項目の更新情報 (String)
PLDLVSHDIN 関連ユーザデータ項目の更新情報 (String)
SEQ_NO 関連ユーザデータ項目の更新情報 (String)
BIL_FORM 関連ユーザデータ項目の更新情報 (String)
DLI_PROFIL 関連ユーザデータ項目の更新情報 (String)
REV_TYPE 関連ユーザデータ項目の更新情報 (String)
BEGDEM_PER 関連ユーザデータ項目の更新情報 (String)
PR_REF_MAT 関連ユーザデータ項目の更新情報 (String)
REFOBJTYPE 関連ユーザデータ項目の更新情報 (String)
REFOBJKEY 関連ユーザデータ項目の更新情報 (String)
REFLOGSYS 関連ユーザデータ項目の更新情報 (String)
ORDER_PROB 関連ユーザデータ項目の更新情報 (String)
MAX_PL_DLV 関連ユーザデータ項目の更新情報 (String)
CFOP_CODE 関連ユーザデータ項目の更新情報 (String)
TAXLAWICMS 関連ユーザデータ項目の更新情報 (String)
TAXLAWIPI 関連ユーザデータ項目の更新情報 (String)
SD_TAXCODE 関連ユーザデータ項目の更新情報 (String)
ASSORT_MOD 関連ユーザデータ項目の更新情報 (String)
COMP_QUANT 関連ユーザデータ項目の更新情報 (String)
TARGET_VAL 関連ユーザデータ項目の更新情報 (String)
PROFIT_CTR 関連ユーザデータ項目の更新情報 (String)
ORDERID 関連ユーザデータ項目の更新情報 (String)
WBS_ELEM 関連ユーザデータ項目の更新情報 (String)
DEPREC_PER 関連ユーザデータ項目の更新情報 (String)
REF_DOC 関連ユーザデータ項目の更新情報 (String)
REF_DOC_IT 関連ユーザデータ項目の更新情報 (String)
REF_DOC_CA 関連ユーザデータ項目の更新情報 (String)
CUST_MAT35 関連ユーザデータ項目の更新情報 (String)
EXCH_RATE_FI_V 関連ユーザデータ項目の更新情報 (String)
EXCHG_RATE_V 関連ユーザデータ項目の更新情報 (String)
ITEMGUID_ATP 関連ユーザデータ項目の更新情報 (String)
VAL_CONTR 関連ユーザデータ項目の更新情報 (String)
VAL_CON_I 関連ユーザデータ項目の更新情報 (String)
CONFIG_ID 関連ユーザデータ項目の更新情報 (String)
INST_ID 関連ユーザデータ項目の更新情報 (String)
MAT_EXT 関連ユーザデータ項目の更新情報 (String)
MAT_GUID 関連ユーザデータ項目の更新情報 (String)
MAT_VERS 関連ユーザデータ項目の更新情報 (String)
P_MAT_EXT 関連ユーザデータ項目の更新情報 (String)
P_MAT_GUID 関連ユーザデータ項目の更新情報 (String)
P_MAT_VERS 関連ユーザデータ項目の更新情報 (String)
FUNC_AREA 関連ユーザデータ項目の更新情報 (String)
ALTERN_BOM 関連ユーザデータ項目の更新情報 (String)
FKK_CONACCT 関連ユーザデータ項目の更新情報 (String)
EAN_UPC 関連ユーザデータ項目の更新情報 (String)
PRODCAT 関連ユーザデータ項目の更新情報 (String)
SHIP_TYPE 関連ユーザデータ項目の更新情報 (String)
S_PROC_IND 関連ユーザデータ項目の更新情報 (String)
BILL_REL 関連ユーザデータ項目の更新情報 (String)
VW_UEPOS 関連ユーザデータ項目の更新情報 (String)
CAMPAIGN 関連ユーザデータ項目の更新情報 (String)
DLVSCHDUSE 関連ユーザデータ項目の更新情報 (String)
SELECTION 関連ユーザデータ項目の更新情報 (String)
MAT_ENTRD 関連ユーザデータ項目の更新情報 (String)
LOG_SYSTEM_OWN 関連ユーザデータ項目の更新情報 (String)
ITM_TYPE_USAGE 関連ユーザデータ項目の更新情報 (String)
MAT_ENTRD_EXTERNAL 関連ユーザデータ項目の更新情報 (String)
MAT_ENTRD_GUID 関連ユーザデータ項目の更新情報 (String)
MAT_ENTRD_VERSION 関連ユーザデータ項目の更新情報 (String)
LOC_TAXCAT 関連ユーザデータ項目の更新情報 (String)
LOC_ZEROVAT 関連ユーザデータ項目の更新情報 (String)
LOC_ACTCODE 関連ユーザデータ項目の更新情報 (String)
LOC_DISTTYPE 関連ユーザデータ項目の更新情報 (String)
LOC_TXRELCLAS 関連ユーザデータ項目の更新情報 (String)
CALC_MOTIVE 関連ユーザデータ項目の更新情報 (String)

明細データチェックボックスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の明細データチェックボックスの「販売伝票明細」
[idx]["UPDATEFLAG"]　→　配列内のidx番目の明細データチェックボックスの「更新区分
[idx]["HG_LV_ITEM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_ITM_NO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["MATERIAL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["ALT_TO_ITM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["CUST_MAT22"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["BATCH"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報
[idx]["DLV_GROUP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["PART_DLV"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["REASON_REJ"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_BLOCK"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_DATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PLANT"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["STORE_LOC"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TARGET_QTY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["TARGET_QU"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["T_UNIT_ISO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ITEM_CATEG"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP1"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP2"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP3"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP4"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP5"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PROD_HIERA"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["MATL_GROUP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PURCH_NO_C"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PURCH_DATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_METHOD"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_1"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["PURCH_NO_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_DAT_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_METH_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_1_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["POITM_NO_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_GRP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["CUST_GROUP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SALES_DIST"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_LIST"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INCOTERMS1"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INCOTERMS2"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ORDCOMP_IN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_SCHED"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INVO_SCHED"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MN_INVOICE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EX_RATE_FI"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ADD_VAL_DY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FIX_VAL_DY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["PMNTTRMS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["PYMT_METH"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ACCNT_ASGN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCHG_RATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_DATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SERV_DATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DUNN_KEY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DUNN_BLOCK"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PROMOTION"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PMTGAR_PRO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DOC_NUM_FI"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DEPARTM_NO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REC_POINT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP1"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP2"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["CSTCNDGRP3"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["CSTCNDGRP4"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP5"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLV_TIME"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SALES_UNIT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TRG_QTY_NO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TRGQTY_DEN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["RNDDLV_QTY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAXDEVAMNT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAXDEVPER"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAXDEV_DAY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["USAGE_IND"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FIXED_QUAN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["UNLMT_DLV"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["OVERDLVTOL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["UNDDLV_TOL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DIVISION"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["SALQTYNUM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["SALQTYDEN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["GROSS_WGHT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["NET_WEIGHT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["UNTOF_WGHT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["VOLUME"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["VOLUNIT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLV_PRIO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SHIP_POINT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ROUTE"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS1"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS2"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS3"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS4"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS5"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS6"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS7"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS8"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS9"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["MAT_PR_GRP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["VAL_TYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FIXDAT_QTY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BOMEXPL_NO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["RESANALKEY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REQMTS_TYP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["NO_GR_POST"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BUS_TRANST"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["OVERHD_KEY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTG_SHEET"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MATFRGTGRP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PLDLVSHDIN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SEQ_NO"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["BIL_FORM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLI_PROFIL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REV_TYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BEGDEM_PER"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PR_REF_MAT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REFOBJKEY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REFLOGSYS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["ORDER_PROB"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAX_PL_DLV"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CFOP_CODE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAXLAWICMS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAXLAWIPI"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SD_TAXCODE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ASSORT_MOD"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["COMP_QUANT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TARGET_VAL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ORDERID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["WBS_ELEM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DEPREC_PER"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_DOC"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_DOC_IT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_DOC_CA"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CUST_MAT35"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCH_RATE_FI_V"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCHG_RATE_V"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ITEMGUID_ATP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["VAL_CONTR"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["VAL_CON_I"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CONFIG_ID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INST_ID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_EXT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_GUID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_VERS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["P_MAT_EXT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["P_MAT_GUID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["P_MAT_VERS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FUNC_AREA"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ALTERN_BOM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FKK_CONACCT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EAN_UPC"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRODCAT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SHIP_TYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["S_PROC_IND"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_REL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["VW_UEPOS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CAMPAIGN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLVSCHDUSE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SELECTION"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_ENTRD"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["LOG_SYSTEM_OWN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ITM_TYPE_USAGE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_ENTRD_EXTERNAL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_ENTRD_GUID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_ENTRD_VERSION"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["LOC_TAXCAT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["LOC_ZEROVAT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["LOC_ACTCODE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["LOC_DISTTYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["LOC_TXRELCLAS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CALC_MOTIVE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryKeysList

Array getInquiryKeysList ()

参照キーの出力を取得します。
返却値
Array 参照キーの出力

参照キーの出力オブジェクトの構成は以下のとおりです。
伝票取引先
オブジェクト
(Object)
REFOBJTYP オブジェクトタイプ (String)
REFOBJECT オブジェクト名 (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)
DOC_NUMBER 販売管理伝票番号 (String)
ITM_NUMBER 販売伝票明細 (String)
SCHED_LIN 納入日程行 (String)
COND_NO 伝票条件番号 (String)
CONDITEMNO 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件カウンタ (String)
COND_TYPE 条件タイプ (String)
STATUS 単一文字フラグ (String)
TINDEX 数値項目: 長さ 6 (String)
ADDRESS 住所 (String)
ABRLI 内部納入日程番号 (String)
ABART 承認タイプ (String)

参照キーの出力オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["REFOBJTYP"]　→　配列内のidx番目の参照キーの出力の「オブジェクトタイプ」
[idx]["REFOBJECT"]　→　配列内のidx番目の参照キーの出力の「オブジェクト名
[idx]["REFOBJKEY"]　→　配列内のidx番目の参照キーの出力の「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の参照キーの出力の「論理システム
[idx]["DOC_NUMBER"]　→　配列内のidx番目の参照キーの出力の「販売管理伝票番号
[idx]["ITM_NUMBER"]　→　配列内のidx番目の参照キーの出力の「販売伝票明細
[idx]["SCHED_LIN"]　→　配列内のidx番目の参照キーの出力の「納入日程行
[idx]["COND_NO"]　→　配列内のidx番目の参照キーの出力の「伝票条件番号
[idx]["CONDITEMNO"]　→　配列内のidx番目の参照キーの出力の「条件明細番号
[idx]["COND_ST_NO"]　→　配列内のidx番目の参照キーの出力の「ステップ番号
[idx]["COND_COUNT"]　→　配列内のidx番目の参照キーの出力の「条件カウンタ」
[idx]["COND_TYPE"]　→　配列内のidx番目の参照キーの出力の「条件タイプ」
[idx]["STATUS"]　→　配列内のidx番目の参照キーの出力の「単一文字フラグ」
[idx]["TINDEX"]　→　配列内のidx番目の参照キーの出力の「数値項目: 長さ 6」
[idx]["ADDRESS"]　→　配列内のidx番目の参照キーの出力の「住所」
[idx]["ABRLI"]　→　配列内のidx番目の参照キーの出力の「内部納入日程番号
[idx]["ABART"]　→　配列内のidx番目の参照キーの出力の「承認タイプ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryPartnersList

Array getInquiryPartnersList ()

伝票取引先を取得します。
返却値
Array 伝票取引先

伝票取引先オブジェクトの構成は以下のとおりです。
伝票取引先
オブジェクト
(Object)
PARTN_ROLE 取引先機能 (String)
PARTN_NUMB 得意先コード 1 (String)
ITM_NUMBER 明細番号 (販売管理伝票) (String)
TITLE 敬称 (String)
NAME 名称 1 (String)
NAME_2 名称 2 (String)
NAME_3 名称 3 (String)
NAME_4 名称 4 (String)
STREET 地名/番地-号 (String)
COUNTRY 国コード (String)
COUNTR_ISO 国キー (ISO コード) (String)
POSTL_CODE 郵便番号 (String)
POBX_PCD 私書箱番号 (String)
POBX_CTY 私書箱住所 (String)
CITY 市区町村 (String)
DISTRICT 所在地 (String)
REGION 地域 (都道府県) (String)
PO_BOX 私書箱 (String)
TELEPHONE 電話番号 1 (String)
TELEPHONE2 電話番号 2 (String)
TELEBOX テレボックス番号 (String)
FAX_NUMBER FAX 番号 (String)
TELETEX_NO テレテクス番号 (String)
TELEX_NO テレックス番号 (String)
LANGU 言語キー (String)
LANGU_ISO ISO 639 準拠の言語 (String)
UNLOAD_PT 荷渡ポイント (String)
TRANSPZONE 商品の納入区域 (String)
TAXJURCODE 税計算管轄コード - 税管轄コード (String)
ADDRESS 住所 (String)
PRIV_ADDR 自宅住所 (String)
ADDR_TYPE アドレスタイプ (1=組織、2=個人、3=取引先担当者) (String)
ADDR_ORIG コピー元住所 (String)
ADDR_LINK 住所コードへのリンク (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)

伝票取引先オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PARTN_ROLE"]　→　配列内のidx番目の伝票取引先の「取引先機能」
[idx]["PARTN_NUMB"]　→　配列内のidx番目の伝票取引先の「得意先コード 1
[idx]["ITM_NUMBER"]　→　配列内のidx番目の伝票取引先の「明細番号 (販売管理伝票)」
[idx]["TITLE"]　→　配列内のidx番目の伝票取引先の「敬称
[idx]["NAME"]　→　配列内のidx番目の伝票取引先の「名称 1
[idx]["NAME_2"]　→　配列内のidx番目の伝票取引先の「名称 2
[idx]["NAME_3"]　→　配列内のidx番目の伝票取引先の「名称 3
[idx]["NAME_4"]　→　配列内のidx番目の伝票取引先の「名称 4
[idx]["STREET"]　→　配列内のidx番目の伝票取引先の「地名/番地-号
[idx]["COUNTRY"]　→　配列内のidx番目の伝票取引先の「国コード
[idx]["COUNTR_ISO"]　→　配列内のidx番目の伝票取引先の「国キー (ISO コード)」
[idx]["POSTL_CODE"]　→　配列内のidx番目の伝票取引先の「郵便番号」
[idx]["POBX_PCD"]　→　配列内のidx番目の伝票取引先の「私書箱番号」
[idx]["POBX_CTY"]　→　配列内のidx番目の伝票取引先の「私書箱住所」
[idx]["CITY"]　→　配列内のidx番目の伝票取引先の「市区町村」
[idx]["DISTRICT"]　→　配列内のidx番目の伝票取引先の「所在地
[idx]["REGION"]　→　配列内のidx番目の伝票取引先の「地域 (都道府県)」
[idx]["PO_BOX"]　→　配列内のidx番目の伝票取引先の「私書箱」
[idx]["TELEPHONE"]　→　配列内のidx番目の伝票取引先の「電話番号 1」
[idx]["TELEPHONE2"]　→　配列内のidx番目の伝票取引先の「電話番号 2」
[idx]["TELEBOX"]　→　配列内のidx番目の伝票取引先の「テレボックス番号」
[idx]["FAX_NUMBER"]　→　配列内のidx番目の伝票取引先の「FAX 番号」
[idx]["TELETEX_NO"]　→　配列内のidx番目の伝票取引先の「テレテクス番号」
[idx]["TELEX_NO"]　→　配列内のidx番目の伝票取引先の「テレックス番号」
[idx]["LANGU"]　→　配列内のidx番目の伝票取引先の「言語キー」
[idx]["LANGU_ISO"]　→　配列内のidx番目の伝票取引先の「ISO 639 準拠の言語
[idx]["UNLOAD_PT"]　→　配列内のidx番目の伝票取引先の「荷渡ポイント」
[idx]["TRANSPZONE"]　→　配列内のidx番目の伝票取引先の「商品の納入区域」
[idx]["TAXJURCODE"]　→　配列内のidx番目の伝票取引先の「税計算管轄コード - 税管轄コード」
[idx]["ADDRESS"]　→　配列内のidx番目の伝票取引先の「住所」
[idx]["PRIV_ADDR"]　→　配列内のidx番目の伝票取引先の「自宅住所」
[idx]["ADDR_TYPE"]　→　配列内のidx番目の伝票取引先の 「アドレスタイプ (1=組織、2=個人、3=取引先担当者)」
[idx]["ADDR_ORIG"]　→　配列内のidx番目の伝票取引先の「コピー元住所」
[idx]["ADDR_LINK"]　→　配列内のidx番目の伝票取引先の「住所コードへのリンク」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の伝票取引先の「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の伝票取引先の「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の伝票取引先の「論理システム

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquirySchedulesInList

Array getInquirySchedulesInList ()

納入日程行を取得します。
返却値
Array 納入日程行

納入日程行オブジェクトの構成は以下のとおりです。
納入日程行
オブジェクト
(Object)
ITM_NUMBER 販売伝票明細 (String)
SCHED_LINE 納入日程行 (String)
REQ_DATE 納入日程日付 (String)
DATE_TYPE 日付タイプ (日、週、月、期間) (String)
REQ_TIME 納入時間 (String)
REQ_QTY 販売単位による受注数量 (String)
REQ_DLV_BL 出荷ブロック中の納入日程行 (String)
SCHED_TYPE 納入日程カテゴリ (String)
TP_DATE 輸送計画日付 (String)
MS_DATE 品目利用可能日 (String)
LOAD_DATE 積載日付 (String)
GI_DATE 出庫日付 (String)
TP_TIME 輸送計画 - 時間 (現地時間/出荷ポイント参照) (String)
MS_TIME 品目供給ステージ (現地時刻: プラント参照) (String)
LOAD_TIME 積載時刻 (現地時間: 出荷ポイント) (String)
GI_TIME 出庫時刻 (現地時間 - プラント参照) (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)
DLV_DATE 納入日程日付 (String)
DLV_TIME 納入時間 (String)
REL_TYPE 承認タイプ (String)
PLAN_SCHED_TYPE 納入日程行タイプ EDI (String)

納入日程行オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の納入日程行の「販売伝票明細」
[idx]["SCHED_LINE"]　→　配列内のidx番目の納入日程行の「納入日程行」
[idx]["REQ_DATE"]　→　配列内のidx番目の納入日程行の「納入日程日付」
[idx]["DATE_TYPE"]　→　配列内のidx番目の納入日程行の「日付タイプ (日、週、月、期間)」
[idx]["REQ_TIME"]　→　配列内のidx番目の納入日程行の「納入時間」
[idx]["REQ_QTY"]　→　配列内のidx番目の納入日程行の「販売単位による受注数量」
[idx]["REQ_DLV_BL"]　→　配列内のidx番目の納入日程行の「出荷ブロック中の納入日程行」
[idx]["SCHED_TYPE"]　→　配列内のidx番目の納入日程行の「納入日程カテゴリ」
[idx]["TP_DATE"]　→　配列内のidx番目の納入日程行の「輸送計画日付」
[idx]["MS_DATE"]　→　配列内のidx番目の納入日程行の「品目利用可能日」
[idx]["LOAD_DATE"]　→　配列内のidx番目の納入日程行の「積載日付」
[idx]["GI_DATE"]　→　配列内のidx番目の納入日程行の「出庫日付」
[idx]["TP_TIME"]　→　配列内のidx番目の納入日程行の 「輸送計画 - 時間 (現地時間/出荷ポイント参照)」
[idx]["MS_TIME"]　→　配列内のidx番目の納入日程行の 「品目供給ステージ (現地時刻: プラント参照)」
[idx]["LOAD_TIME"]　→　配列内のidx番目の納入日程行の「積載時刻 (現地時間: 出荷ポイント)」
[idx]["GI_TIME"]　→　配列内のidx番目の納入日程行の「出庫時刻 (現地時間 - プラント参照)」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の納入日程行の「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の納入日程行の「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の納入日程行の「論理システム」
[idx]["DLV_DATE"]　→　配列内のidx番目の納入日程行の「納入日程日付」
[idx]["DLV_TIME"]　→　配列内のidx番目の納入日程行の「納入時間」
[idx]["REL_TYPE"]　→　配列内のidx番目の納入日程行の「承認タイプ」
[idx]["PLAN_SCHED_TYPE"]　→　配列内のidx番目の納入日程行の「納入日程行タイプ EDI」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquirySchedulesInXList

Array getInquirySchedulesInXList ()

納入日程行チェックボックスを取得します。
返却値
Array 納入日程行チェックボックス

納入日程行チェックボックスオブジェクトの構成は以下のとおりです。
納入日程行チェックボックス
オブジェクト
(Object)
ITM_NUMBER 販売伝票明細 (String)
SCHED_LINE 納入日程行 (String)
UPDATEFLAG 更新区分 (String)
REQ_DATE 関連ユーザデータ項目の更新情報 (String)
DATE_TYPE 関連ユーザデータ項目の更新情報 (String)
REQ_TIME 関連ユーザデータ項目の更新情報 (String)
REQ_QTY 関連ユーザデータ項目の更新情報 (String)
REQ_DLV_BL 関連ユーザデータ項目の更新情報 (String)
SCHED_TYPE 関連ユーザデータ項目の更新情報 (String)
TP_DATE 関連ユーザデータ項目の更新情報 (String)
MS_DATE 関連ユーザデータ項目の更新情報 (String)
LOAD_DATE 関連ユーザデータ項目の更新情報 (String)
GI_DATE 関連ユーザデータ項目の更新情報 (String)
TP_TIME 関連ユーザデータ項目の更新情報 (String)
MS_TIME 関連ユーザデータ項目の更新情報 (String)
LOAD_TIME 関連ユーザデータ項目の更新情報 (String)
GI_TIME 関連ユーザデータ項目の更新情報 (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
DLV_DATE 関連ユーザデータ項目の更新情報 (String)
DLV_TIME 関連ユーザデータ項目の更新情報 (String)
REL_TYPE 関連ユーザデータ項目の更新情報 (String)
PLAN_SCHED_TYPE 関連ユーザデータ項目の更新情報 (String)

納入日程行チェックボックスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の納入日程行チェックボックスの「販売伝票明細」
[idx]["SCHED_LINE"]　→　配列内のidx番目の納入日程行チェックボックスの「納入日程行」
[idx]["UPDATEFLAG"]　→　配列内のidx番目の納入日程行チェックボックスの「更新区分」
[idx]["REQ_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["DATE_TYPE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REQ_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REQ_QTY 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REQ_DLV_BL 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["SCHED_TYPE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["TP_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["MS_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["LOAD_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["GI_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["TP_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["MS_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["LOAD_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["GI_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の納入日程行チェックボックスの「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の納入日程行チェックボックスの「オブジェクトキー」
[idx]["DLV_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["DLV_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REL_TYPE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["PLAN_SCHED_TYPE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryTextList

Array getInquiryTextList ()

テキストを取得します。
返却値
Array テキスト

テキストオブジェクトの構成は以下のとおりです。
テキスト
オブジェクト
(Object)
DOC_NUMBE 販売伝票 (String)
ITM_NUMBE 販売伝票明細 (String)
TEXT_ID テキスト ID (String)
LANGU 言語キー (String)
LANGU_ISO ISO 639 準拠の言語 (String)
FORMAT_COL タグ列 (String)
TEXT_LINE テキスト行 (String)
FUNCTION 機能 (String)

テキストオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["DOC_NUMBE"]　→　配列内のidx番目のテキストの「販売伝票」
[idx]["ITM_NUMBE"]　→　配列内のidx番目のテキストの「販売伝票明細」
[idx]["TEXT_ID"]　→　配列内のidx番目のテキストの「テキスト ID」
[idx]["LANGU"]　→　配列内のidx番目のテキストの「言語キー」
[idx]["LANGU_ISO"]　→　配列内のidx番目のテキストの「ISO 639 準拠の言語」
[idx]["FORMAT_COL"]　→　配列内のidx番目のテキストの「タグ列」
[idx]["TEXT_LINE"]　→　配列内のidx番目のテキストの「テキスト行」
[idx]["FUNCTION"]　→　配列内のidx番目のテキストの「機能」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getIntNumberAssignment

Object getIntNumberAssignment ()

明細番号内部採番を取得します。
返却値
Object 明細番号内部採番
getLogicSwitch

Object getLogicSwitch ()

内部制御パラメータを取得します。
返却値
Object 内部制御パラメータ

内部制御パラメータオブジェクトの構成は以下のとおりです。
内部制御パラメータ
オブジェクト
(Object)
PRICING 価格設定タイプ (String)
ATP_WRKMOD ATP セッション: 結果取得/新規決定 APO-ATP (String)
SCHEDULING 単一文字フラグ (String)
NOSTRUCTURE チェックボックス (String)
COND_HANDL 選択: 条件行処理 (SD 伝票変更) (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPartnerAddressesList

Array getPartnerAddressesList ()

アドレス (組織/会社) 用 BAPI 参照構造を取得します。
返却値
Array アドレス (組織/会社) 用 BAPI 参照構造

アドレス (組織/会社) 用 BAPI 参照構造オブジェクトの構成は以下のとおりです。
アドレス (組織/会社) 用 BAPI 参照構造
オブジェクト
(Object)
ADDR_NO アドレス番号 (String)
FORMOFADDR 敬称テキスト (String)
NAME 名称 1 (String)
NAME_2 名称 2 (String)
NAME_3 名称 3 (String)
NAME_4 名称 4 (String)
C_O_NAME 気付 (String)
CITY 市区町村 (String)
DISTRICT 所在地 (String)
CITY_NO 市区町村/地名ファイルの市区町村コード (String)
POSTL_COD1 市区町村の郵便番号 (String)
POSTL_COD2 私書箱郵便番号 (String)
POSTL_COD3 会社郵便番号 (大規模なユーザ用) (String)
PO_BOX 私書箱 (String)
PO_BOX_CIT 私書箱住所 (String)
DELIV_DIS 郵便配達地域 (String)
STREET 地名 (String)
STREET_NO 市区町村/地名ファイルの地名コード (String)
STR_ABBR 地名の略称 (例: スペイン) (String)
HOUSE_NO 番地-号 (String)
STR_SUPPL1 地名 2 (String)
STR_SUPPL2 地名 3 (String)
LOCATION 地名 5 (String)
BUILDING 旧: 建物 (番号または略称) (String)
FLOOR 建物の階 (String)
ROOM_NO 部屋/アパート番号 (String)
COUNTRY 国コード (String)
LANGU 言語キー (String)
REGION 地域 (都道府県) (String)
SORT1 検索条件 1 (String)
SORT2 検索条件 2 (String)
TIME_ZONE アドレスタイムゾーン (String)
TAXJURCODE 税管轄コード (String)
ADR_NOTES 住所注記 (String)
COMM_TYPE 通信方法 (キー) (アドレス管理) (String)
TEL1_NUMBR 第一電話番号: ダイヤルコード + 番号 (String)
TEL1_EXT 第 1 電話番号: 内線 (String)
FAX_NUMBER 第一 FAX 番号: ダイヤルコード + 番号 (String)
FAX_EXTENS 第一 FAX 番号: 内線 (String)
STREET_LNG 地名 (String)
DISTRCT_NO 市区町村/地名ファイルの所在地コード (String)
CHCKSTATUS 市区町村ファイルテストステータス (String)
PBOXCIT_NO 市区町村私書箱コード (市ファイル) (String)
TRANSPZONE 商品の納入区域 (String)
HOUSE_NO2 番地補足 (String)
E_MAIL 電子メールアドレス (String)
STR_SUPPL3 地名 4 (String)
TITLE タイトル (敬称) (String)
COUNTRYISO ISO 国コード (String)
LANGU_ISO ISO 639 準拠の言語 (String)
BUILD_LONG 建物 (番号またはコード) (String)
REGIOGROUP 地域構造グループ化 (String)
HOME_CITY 市区町村 (郵便用市区町村と異なる場合) (String)
HOMECITYNO 別の市区町村 (市区町村/地名ファイル) (String)
PCODE1_EXT 市区町村郵便番号の拡張子 例: 郵便番号 +4+2 (String)
PCODE2_EXT 私書箱郵便番号拡張子 例: 郵便番号 +4+2 (String)
PCODE3_EXT 主要得意先郵便番号拡張子 例: 郵便番号 +4+2 (String)
PO_W_O_NO フラグ: 郵便私書箱 (番号なし) (String)
PO_BOX_REG 私書箱の地域 (国、都道府県、地域、...) (String)
POBOX_CTRY 私書箱の国指定 (String)
PO_CTRYISO ISO 国コード (String)
HOMEPAGE URI 例: ホームページ、FTP アドレス (String)
DONT_USE_S 地名住所配達不可フラグ (String)
DONT_USE_P 私書箱住所配達不可フラグ (String)
HOUSE_NO3 番地範囲 (String)
LANGU_CR アドレスレコード登録オリジナル言語 (String)
LANGUCRISO ISO 639 準拠の言語 (String)

アドレス (組織/会社) 用 BAPI 参照構造オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ADDR_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「アドレス番号」
[idx]["FORMOFADDR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「敬称テキスト」
[idx]["NAME"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「名称 1」
[idx]["NAME_2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「名称 2」
[idx]["NAME_3"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「名称 3」
[idx]["NAME_4"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「名称 4」
[idx]["C_O_NAME"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「気付」
[idx]["CITY"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「市区町村」
[idx]["DISTRICT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「所在地」
[idx]["CITY_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村/地名ファイルの市区町村コード」
[idx]["POSTL_COD1"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村の郵便番号」
[idx]["POSTL_COD2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱郵便番号」
[idx]["POSTL_COD3"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「会社郵便番号 (大規模なユーザ用)」
[idx]["PO_BOX"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「私書箱」
[idx]["PO_BOX_CIT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱住所」
[idx]["DELIV_DIS"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「郵便配達地域」
[idx]["STREET"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「地名」
[idx]["STREET_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村/地名ファイルの地名コード」
[idx]["STR_ABBR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名の略称 (例: スペイン)」
[idx]["HOUSE_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「番地-号」
[idx]["STR_SUPPL1"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名 2」
[idx]["STR_SUPPL2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名 3」
[idx]["LOCATION"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「地名 5」
[idx]["BUILDING"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「旧: 建物 (番号または略称)」
[idx]["FLOOR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「建物の階」
[idx]["ROOM_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「部屋/アパート番号」
[idx]["COUNTRY"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「国コード」
[idx]["LANGU"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「言語キー」
[idx]["REGION"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地域 (都道府県)」
[idx]["SORT1"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「検索条件 1」
[idx]["SORT2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「検索条件 2」
[idx]["TIME_ZONE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「アドレスタイムゾーン」
[idx]["TAXJURCODE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「税管轄コード」
[idx]["ADR_NOTES"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「住所注記」
[idx]["COMM_TYPE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「通信方法 (キー) (アドレス管理)」
[idx]["TEL1_NUMBR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「第一電話番号: ダイヤルコード + 番号」
[idx]["TEL1_EXT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「第 1 電話番号: 内線」
[idx]["FAX_NUMBER"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「第一 FAX 番号: ダイヤルコード + 番号」
[idx]["FAX_EXTENS"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「第一 FAX 番号: 内線」
[idx]["STREET_LNG"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「地名」
[idx]["DISTRCT_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村/地名ファイルの所在地コード」
[idx]["CHCKSTATUS"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村ファイルテストステータス」
[idx]["PBOXCIT_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村私書箱コード (市ファイル)」
[idx]["TRANSPZONE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「商品の納入区域」
[idx]["HOUSE_NO2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「番地補足」
[idx]["E_MAIL"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「電子メールアドレス」
[idx]["STR_SUPPL3"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名 4」
[idx]["TITLE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「タイトル (敬称)」
[idx]["COUNTRYISO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「ISO 国コード」
[idx]["LANGU_ISO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「ISO 639 準拠の言語」
[idx]["BUILD_LONG"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「建物 (番号またはコード)」
[idx]["REGIOGROUP"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地域構造グループ化」
[idx]["HOME_CITY"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村 (郵便用市区町村と異なる場合)」
[idx]["HOMECITYNO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「別の市区町村 (市区町村/地名ファイル)」
[idx]["PCODE1_EXT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村郵便番号の拡張子 例: 郵便番号 +4+2」
[idx]["PCODE2_EXT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱郵便番号拡張子 例: 郵便番号 +4+2」
[idx]["PCODE3_EXT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「主要得意先郵便番号拡張子 例: 郵便番号 +4+2」
[idx]["PO_W_O_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「フラグ: 郵便私書箱 (番号なし)」
[idx]["PO_BOX_REG"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱の地域 (国、都道府県、地域、...)」
[idx]["POBOX_CTRY"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱の国指定」
[idx]["PO_CTRYISO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「ISO 国コード」
[idx]["HOMEPAGE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「URI 例: ホームページ、FTP アドレス」
[idx]["DONT_USE_S"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名住所配達不可フラグ」
[idx]["DONT_USE_P"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱住所配達不可フラグ」
[idx]["HOUSE_NO3"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「番地範囲」
[idx]["LANGU_CR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「アドレスレコード登録オリジナル言語」
[idx]["LANGUCRISO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「ISO 639 準拠の言語」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getSalesdocument

Object getSalesdocument ()

販売伝票番号を取得します。

返却値
Object 販売伝票番号
getSalesdocumentin

Object getSalesdocumentin ()

販売管理伝票番号を取得します。

返却値
Object 販売管理伝票番号
getSender

Object getSender ()

論理システム - 送信者を取得します。
返却値
Object 論理システム - 送信者

論理システム - 送信者オブジェクトの構成は以下のとおりです。
論理システム - 送信者
オブジェクト
(Object)
LOG_SYSTEM 論理システム (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getTestrun

Object getTestrun ()

テスト実行を取得します。
返却値
Object テスト実行
setBehaveWhenError

void setBehaveWhenError (Object value)

エラー処理を設定します｡
パラメータ
value Object エラー処理
返却値
void
setBinaryRelationshiptype

void setBinaryRelationshiptype (Object value)

バイナリ関連タイプ (専用)を設定します｡
パラメータ
value Object バイナリ関連タイプ (専用)
返却値
void
setConvert

void setConvert (Object value)

変換: 取引先機能 + 受注伝票タイプを設定します｡
パラメータ
value Object 変換: 取引先機能 + 受注伝票タイプ
返却値
void
setIntNumberAssignment

void setIntNumberAssignment (Object value)

明細番号内部採番を設定します｡
パラメータ
value Object 明細番号内部採番
返却値
void
setSalesdocumentin

void setSalesdocumentin (Object value)

販売管理伝票番号を設定します｡
パラメータ
value Object 販売管理伝票番号
返却値
void
setStrParam

void setStrParam (String paramStr ,String paramName ,Object value)

構造型の項目に値をセットします。
パラメータ
paramStr | String | 構造名
paramName | String | 項目名
value | Object | セットする値
返却値
void
setTblParam

void setTblParam (String paramTable ,String paramName ,Object value ,int index)

テーブル型の項目に値をセットします。
パラメータ
paramTable | String | テーブル名
paramName | String | 項目名
value | Object | セットする値
index | int | レコード番号
返却値
void
setTestrun

void setTestrun (Object value)

テスト実行を設定します｡
パラメータ
value Object テスト実行
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 InternalOrderGetDetailController オブジェクト

内部指図書詳細コントローラクラス。

機能は以下の通り
  • 内部指図書詳細情報を取得します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
InternalOrderGetDetailController (String orderid ,String language)
コンストラクタ｡
InternalOrderGetDetailController (String orderid ,String language ,SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | getAllowedBusTractList () 内部指図書詳細の使用可能業務トランザクションのテーブルから値を取得します。
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
Object | getLanguage () 内部指図書詳細のステータスおよび業務トランザクションテキストの言語から値を取得します。
Object | getMasterData () 内部指図書詳細の指図のマスタデータ構造から値を取得します。
Object | getOrderid () 内部指図書詳細の指図番号から値を取得します。
Object | getSystemStatusList () 内部指図書詳細のシステムステータステーブルから値を取得します。
Object | getUserStatusList () 内部指図書詳細のユーザステータス/指図ステータステーブルから値を取得します。
void | setLanguage (String value) 内部指図書詳細のステータスおよび業務トランザクションテキストの言語に値を設定します。
void | setOrderid (String value) 内部指図書詳細の指図番号に値を設定します。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
InternalOrderGetDetailController

InternalOrderGetDetailController (String orderid ,String language)
コンストラクタ｡
パラメータ
orderid | String | 指図番号
language | String | ステータスおよび業務トランザクションテキストの言語
InternalOrderGetDetailController

InternalOrderGetDetailController (String orderid ,String language ,SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
orderid | String | 指図番号
language | String | ステータスおよび業務トランザクションテキストの言語
sapClient | SapClient | Sapクライアント
メソッドの詳細
getAllowedBusTractList

Object getAllowedBusTractList ()

内部指図書詳細の使用可能業務トランザクションのテーブルから値を取得します。
返却値
Object 使用可能業務トランザクションのテーブル

内部指図書詳細の使用可能業務トランザクション情報オブジェクトの構成は以下のとおりです。
内部指図書詳細の使用可能業務トランザクション情報
オブジェクト
(Object)
TRANS 取引 (String)
DESCRIPT テキスト (30 文字) (String)

取得した内部指図書詳細の使用可能業務トランザクション情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["TRANS"]　→　配列内のidx番目の内部指図書詳細の使用可能業務トランザクションの「取引」
[idx]["DESCRIPT"]　→　配列内のidx番目の内部指図書詳細の使用可能業務トランザクションの 「テキスト (30 文字)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getLanguage

Object getLanguage ()

内部指図書詳細のステータスおよび業務トランザクションテキストの言語から値を取得します。

返却値
Object ステータスおよび業務トランザクションテキストの言語
getMasterData

Object getMasterData ()

内部指図書詳細の指図のマスタデータ構造から値を取得します。
返却値
Object 指図のマスタデータ構造

内部指図書詳細の指図のマスタデータ構造情報オブジェクトの構成は以下のとおりです。
内部指図書詳細の指図のマスタデータ構造情報
オブジェクト
(Object)
ORDER 指図番号 (String)
ORDER_TYPE 販売伝票タイプ (String)
ORDER_NAME テキスト (String)
EXT_ORD_NO 外部指図番号 (String)
OBJECT_NO 対象番号 (String)
CO_AREA 管理領域 (String)
COMP_CODE 会社コード (String)
BUS_AREA 事業領域 (String)
PLANT プラント (String)
PROFIT_CTR 利益センタ (String)
RESPCCTR 責任原価センタ (String)
WBS_ELEM 作業詳細項目要素 (WBS 要素) (String)
WBS_ELEMENT_EXT WBS 要素 (String)
REQUEST_CCTR 申請原価センタ (String)
REQU_COMP_CODE 会社コード要求 (String)
SALES_ORD 受注伝票番号 (String)
S_ORD_ITEM 受注明細番号 (String)
TAXJURCODE 税計算管轄コード - 税管轄コード (String)
CCTR_POSTED 原価が実際に転記された原価センタ (String)
CURRENCY 購買発注通貨 (String)
CSTG_SHEET 原価計算表 (String)
OVERHEAD_KEY 間接費キー (String)
RES_ANAL_KEY 結果分析キー (String)
INTEREST_PROF プロジェクト/指図金利計算の金利プロファイル (String)
APPLICANT 申請者 (String)
APPLICANT_PHONE 申請者の電話番号 (String)
PERSON_RESP 責任者 (String)
PERSON_RESP_PHONE 責任者の電話番号 (String)
ESTIMATED_COSTS 指図の見積原価合計 (String)
APPLICATION_DATE 申請日 (String)
DEPARTMENT 部署 (String)
DATE_WORK_BEGINS 作業開始 (String)
DATE_WORK_ENDS 作業終了 (String)
WORK_PERMIT 仕事許可済フラグ (String)
PROCESSING_GROUP 処理グループ (String)
PLN_RELEASE 計画リリース日付 (String)
PLN_COMPLETION 計画完了日 (String)
PLN_CLOSE 計画終了日付 (String)
REQUEST_ORDER 申請指図 (String)
FUNC_AREA 機能領域 (String)
FUNC_AREA_LONG 機能領域 (String)
IN_CHARGE_USER CO 内部指図の責任者 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderid

Object getOrderid ()

内部指図書詳細の指図番号から値を取得します。

返却値
Object 指図番号
getSystemStatusList

Object getSystemStatusList ()

内部指図書詳細のシステムステータステーブルから値を取得します。
返却値
Object システムステータステーブル

内部指図書詳細のシステムステータス情報オブジェクトの構成は以下のとおりです。
内部指図書詳細のシステムステータス情報
オブジェクト
(Object)
SYS_STATUS システムステータス (String)
SY_ST_TEXT オブジェクトの個別ステータス (簡略形式) (String)
SY_ST_DSCR オブジェクトステータス (String)

取得した内部指図書詳細のシステムステータス情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["SYS_STATUS"] 　→　配列内のidx番目の内部指図書詳細のシステムステータスの「システムステータス」
[idx]["SY_ST_TEXT"] 　→　配列内のidx番目の内部指図書詳細のシステムステータスの「オブジェクトの個別ステータス (簡略形式)」
[idx]["SY_ST_DSCR"] 　→　配列内のidx番目の内部指図書詳細のシステムステータスの「オブジェクトステータス」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getUserStatusList

Object getUserStatusList ()

内部指図書詳細のユーザステータス/指図ステータステーブルから値を取得します。
返却値
Object ユーザステータス/指図ステータステーブル

内部指図書詳細のユーザステータス/指図ステータス情報オブジェクトの構成は以下のとおりです。
内部指図書詳細のユーザステータス/指図ステータス情報
オブジェクト
(Object)
STAT_PROF ステータスプロファイル (String)
USR_STATUS ユーザステータス (String)
US_ST_NUMB ステータス番号 (String)
US_ST_TEXT オブジェクトの個別ステータス (簡略形式) (String)
US_ST_DSCR オブジェクトステータス (String)

取得した内部指図書詳細のユーザステータス/指図ステータス情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["STAT_PROF"] 　→　配列内のidx番目の内部指図書詳細のユーザステータス/指図ステータスの「ステータスプロファイル」
[idx]["USR_STATUS"] 　→　配列内のidx番目の内部指図書詳細のユーザステータス/指図ステータスの「ユーザステータス」
[idx]["US_ST_NUMB"] 　→　配列内のidx番目の内部指図書詳細のユーザステータス/指図ステータスの「ステータス番号」
[idx]["US_ST_TEXT"] 　→　配列内のidx番目の内部指図書詳細のユーザステータス/指図ステータスの 「オブジェクトの個別ステータス (簡略形式)」
[idx]["US_ST_DSCR"] 　→　配列内のidx番目の内部指図書詳細のユーザステータス/指図ステータスの「オブジェクトステータス」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

setLanguage

void setLanguage (String value)

内部指図書詳細のステータスおよび業務トランザクションテキストの言語に値を設定します。
パラメータ
value String ステータスおよび業務トランザクションテキストの言語
返却値
void
setOrderid

void setOrderid (String value)

内部指図書詳細の指図番号に値を設定します。
パラメータ
value String 指図番号
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 InternalOrderGetListController オブジェクト

内部指図書(一覧)取得コントローラクラス。

機能は以下の通り
  • 内部指図書(一覧)を取得します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
InternalOrderGetListController (String controllingArea ,String respCostCenter ,String orderType ,String order ,String orderTo ,String orderExternalNo ,String orderExternalNoTo)
コンストラクタ｡
InternalOrderGetListController (String controllingArea ,String respCostCenter ,String orderType ,String order ,String orderTo ,String orderExternalNo ,String orderExternalNoTo ,SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | getControllingArea () 内部指図書（一覧）の管理領域から値を取得します。
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
Object | getOrder () 内部指図書（一覧）の指図番号 (個別値、または下限値)から値を取得します。
Object | getOrderExternalNo () 内部指図書（一覧）の外部指図番号 (個別値、または下限値)から値を取得します。
Object | getOrderExternalNoTo () 内部指図書（一覧）の外部指図番号 (上限値)から値を取得します。
Object | getOrderListList () 内部指図書（一覧）の選択指図一覧から値を取得します。
Object | getOrderTo () 内部指図書（一覧）の指図番号 (上限値)から値を取得します。
Object | getOrderType () 内部指図書（一覧）の指図タイプから値を取得します。
Object | getRespCostCenter () 内部指図書（一覧）の責任原価センタから値を取得します。
void | setControllingArea (String value) 内部指図書（一覧）の管理領域に値を設定します。
void | setOrder (String value) 内部指図書（一覧）の指図番号 (個別値、または下限値)に値を設定します。
void | setOrderExternalNo (String value) 内部指図書（一覧）の外部指図番号 (個別値、または下限値)に値を設定します。
void | setOrderExternalNoTo (String value) 内部指図書（一覧）の外部指図番号 (上限値)に値を設定します。
void | setOrderTo (String value) 内部指図書（一覧）の指図番号 (上限値)に値を設定します。
void | setOrderType (String value) 内部指図書（一覧）の指図タイプに値を設定します。
void | setRespCostCenter (String value) 内部指図書（一覧）の責任原価センタに値を設定します。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
InternalOrderGetListController

InternalOrderGetListController (String controllingArea ,String respCostCenter ,String orderType ,String order ,String orderTo ,String orderExternalNo ,String orderExternalNoTo)
コンストラクタ｡
パラメータ
controllingArea | String | 管理領域
respCostCenter | String | 責任原価センタ
orderType | String | 指図タイプ
order | String | 指図番号 (個別値、または下限値)
orderTo | String | 指図番号 (上限値)
orderExternalNo | String | 外部指図番号 (個別値、または下限値)
orderExternalNoTo | String | 外部指図番号 (上限値)
InternalOrderGetListController

InternalOrderGetListController (String controllingArea ,String respCostCenter ,String orderType ,String order ,String orderTo ,String orderExternalNo ,String orderExternalNoTo ,SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
controllingArea | String | 管理領域
respCostCenter | String | 責任原価センタ
orderType | String | 指図タイプ
order | String | 指図番号 (個別値、または下限値)
orderTo | String | 指図番号 (上限値)
orderExternalNo | String | 外部指図番号 (個別値、または下限値)
orderExternalNoTo | String | 外部指図番号 (上限値)
sapClient | SapClient | Sapクライアント
メソッドの詳細
getControllingArea

Object getControllingArea ()

内部指図書（一覧）の管理領域から値を取得します。

返却値
Object 管理領域
getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getOrder

Object getOrder ()

内部指図書（一覧）の指図番号 (個別値、または下限値)から値を取得します。

返却値
Object 指図番号 (個別値、または下限値)
getOrderExternalNo

Object getOrderExternalNo ()

内部指図書（一覧）の外部指図番号 (個別値、または下限値)から値を取得します。

返却値
Object 外部指図番号 (個別値、または下限値)
getOrderExternalNoTo

Object getOrderExternalNoTo ()

内部指図書（一覧）の外部指図番号 (上限値)から値を取得します。

返却値
Object 外部指図番号 (上限値)
getOrderListList

Object getOrderListList ()

内部指図書（一覧）の選択指図一覧から値を取得します。
返却値
Object 選択指図一覧

内部指図書情報オブジェクトの構成は以下のとおりです。
内部指図書情報
オブジェクト
(Object)
ORDER 指図番号 (String)
OBJECT_NO 対象番号 (String)
ORDER_TYPE 販売伝票タイプ (String)
ORDER_NAME テキスト (String)

取得した内部指図書情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ORDER"]　→　配列内のidx番目の内部指図書の「指図番号」
[idx]["OBJECT_NO"]　→　配列内のidx番目の内部指図書の「対象番号」
[idx]["ORDER_TYPE"]　→　配列内のidx番目の内部指図書の「販売伝票タイプ」
[idx]["ORDER_NAME"]　→　配列内のidx番目の内部指図書の「テキスト」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderTo

Object getOrderTo ()

内部指図書（一覧）の指図番号 (上限値)から値を取得します。

返却値
Object 指図番号 (上限値)
getOrderType

Object getOrderType ()

内部指図書（一覧）の指図タイプから値を取得します。

返却値
Object 指図タイプ
getRespCostCenter

Object getRespCostCenter ()

内部指図書（一覧）の責任原価センタから値を取得します。

返却値
Object 責任原価センタ
setControllingArea

void setControllingArea (String value)

内部指図書（一覧）の管理領域に値を設定します。
パラメータ
value String 管理領域
返却値
void
setOrder

void setOrder (String value)

内部指図書（一覧）の指図番号 (個別値、または下限値)に値を設定します。
パラメータ
value String 指図番号 (個別値、または下限値)
返却値
void
setOrderExternalNo

void setOrderExternalNo (String value)

内部指図書（一覧）の外部指図番号 (個別値、または下限値)に値を設定します。
パラメータ
value String 外部指図番号 (個別値、または下限値)
返却値
void
setOrderExternalNoTo

void setOrderExternalNoTo (String value)

内部指図書（一覧）の外部指図番号 (上限値)に値を設定します。
パラメータ
value String 外部指図番号 (上限値)
返却値
void
setOrderTo

void setOrderTo (String value)

内部指図書（一覧）の指図番号 (上限値)に値を設定します。
パラメータ
value String 指図番号 (上限値)
返却値
void
setOrderType

void setOrderType (String value)

内部指図書（一覧）の指図タイプに値を設定します。
パラメータ
value String 指図タイプ
返却値
void
setRespCostCenter

void setRespCostCenter (String value)

内部指図書（一覧）の責任原価センタに値を設定します。
パラメータ
value String 責任原価センタ
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


JavaScript API リスト概要

 JavaScript API リスト 概要

スクリプト開発モデルで利用可能なJavaScript API の概要です。

オブジェクトの概要
AccEmployeePayPostController | 伝票登録コントローラクラス。
BankController | 銀行コントローラクラス。
BillingDocCreateMultipleController | 請求伝票登録コントローラクラス。
BillingDocGetDetailController | 後続請求伝票詳細照会コントローラクラス。
BillingDocGetListController | 後続請求伝票一覧照会コントローラクラス。
BusinessAreaController | 事業領域コントローラクラス。
CompanyController | 会社コントローラクラス。
ControllingAreaController | 管理領域コントローラクラス。
CostCenterController | 原価センタコントローラクラス。
CostCenterGroupGetDetailController | 原価センタグループ情報取得コントローラクラス。
CreditorGetDetailController | 仕入先詳細情報取得コントローラクラス。
DebtorGetDetailController | 得意先コードの詳細コントローラクラス。
ExchangeRateGetDetailController | 為替換算レートコントローラクラス。
GlAccController | 勘定科目コントローラクラス。
GoodsMvtCreateController | 入出庫伝票登録コントローラクラス。
GoodsMvtGetItemsController | 入出庫伝票一覧照会コントローラクラス。
InquiryCreateFromData2Controller | 引合伝票登録コントローラクラス。
InternalOrderGetDetailController | 内部指図書詳細コントローラクラス。
InternalOrderGetListController | 内部指図書(一覧)取得コントローラクラス。
MaterialAvailabilityController | 品目在庫確認クラス。
MaterialGetAllController | 品目マスタ照会クラス。
MaterialGetListController | 品目コード検索クラス。
MaterialSaveReplicaController | 品目マスタ更新クラス。
ProfitCenterController | 利益センタコントローラクラス。
ProfitCenterGrpGetDetailController | 利益センタグループ情報取得コントローラクラス。
ProjectGetInfoController | WBS詳細情報取得コントローラクラス。
PurchaseGetItemSrelController | 伝票承認対象一覧取得コントローラクラス。
PurchaseOrderPayPostController | 伝票登録コントローラクラス。
PurchaseOrderPostChangeController | 伝票登録変更コントローラクラス。
PurchaseReleaseController | 伝票承認コントローラクラス。
PurchaseResetReleaseController | 伝票承認取消コントローラクラス。
QuotationCreateFromData2Controller | 見積伝票登録コントローラクラス。
SalesOrderCreateFromDat2Controller | 受注伝票登録コントローラクラス。
SalesOrderGetListController | 販売伝票一覧照会コントローラクラス。
SalesOrderGetStatusController | 販売伝票ステータス一覧照会コントローラクラス。
StdMaterialGetIntNumberController | 品目コード割当済照会コントローラクラス。
SupplierExistenceCheckController | 仕入先コード存在チェックコントローラクラス。
SupplierGetDetailController | 仕入先マスタの詳細照会コントローラクラス。


JavaScript API リスト

 オブジェクト
AccEmployeePayPostController
BankController
BillingDocCreateMultipleController
BillingDocGetDetailController
BillingDocGetListController
BusinessAreaController
CompanyController
ControllingAreaController
CostCenterController
CostCenterGroupGetDetailController
CreditorGetDetailController
DebtorGetDetailController
ExchangeRateGetDetailController
GlAccController
GoodsMvtCreateController
GoodsMvtGetItemsController
InquiryCreateFromData2Controller
InternalOrderGetDetailController
InternalOrderGetListController
MaterialAvailabilityController
MaterialGetAllController
MaterialGetListController
MaterialSaveReplicaController
ProfitCenterController
ProfitCenterGrpGetDetailController
ProjectGetInfoController
PurchaseGetItemSrelController
PurchaseOrderPayPostController
PurchaseOrderPostChangeController
PurchaseReleaseController
PurchaseResetReleaseController
QuotationCreateFromData2Controller
SalesOrderCreateFromDat2Controller
SalesOrderGetListController
SalesOrderGetStatusController
StdMaterialGetIntNumberController
SupplierExistenceCheckController
SupplierGetDetailController


 MaterialAvailabilityController オブジェクト

品目在庫確認クラス。

機能は以下の通り
  • 品目在庫を照会します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
MaterialAvailabilityController ()
コンストラクタ｡
MaterialAvailabilityController (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより品目在庫を検索します。
Object | getAvQtyPlt () プラントレベル利用可能数量を取得します。
Object | getBatch () ロットを取得します。
Object | getCheckRule () 確認規則を取得します。
Object | getCustomer () 得意先コードを取得します。
Object | getDecForRounding () 小数点位置 (その位置まで丸める)を取得します。
Object | getDecForRoundingX () 関連ユーザデータ項目の更新情報を取得します。
Object | getDialogflag () 区分 (X = 利用不可 /N = 確認なし)を取得します。
Object | getDocNumber () 伝票番号を取得します。
Object | getEndleadtme () 補充リードタイムの終了日付を取得します。
Object | getItmNumber () 明細番号を取得します。
Object | getMaterial () 品目コードを取得します。
Object | getMaterialEvg () 品目コード(長)を取得します｡
Object | getPlant () プラントを取得します。
Object | getReadAtpLock () 管理区分:利用可能在庫確認を取得します。
Object | getReadAtpLockX () 関連ユーザデータ項目の更新情報を取得します。
Object | getStgeLoc () 保管場所を取得します。
Object | getUnit () 表示数量単位を取得します。
Object | getWbsElem () WBS 要素を取得します。
Object | getWmdvexList () 出力テーブル (日付および ATP 数量)を取得します。
Object | getWmdvsxList () 入力テーブル (日付/数量)を取得します。
void | setAvQtyPlt (Object value) プラントレベル利用可能数量を設定します。
void | setBatch (Object value) ロットを設定します。
void | setCheckRule (Object value) 確認規則を設定します。
void | setCustomer (Object value) 得意先コードを設定します。
void | setDecForRounding (Object value) 小数点位置 (その位置まで丸める)を設定します。
void | setDecForRoundingX (Object value) 関連ユーザデータ項目の更新情報を設定します。
void | setDialogflag (Object value) 区分 (X = 利用不可 /N = 確認なし)を設定します。
void | setDocNumber (Object value) 伝票番号を設定します。
void | setEndleadtme (Object value) 補充リードタイムの終了日付を設定します。
void | setItmNumber (Object value) 明細番号を設定します。
void | setMaterial (Object value) 品目コードを設定します。
void | setPlant (Object value) プラントを設定します。
void | setReadAtpLock (Object value) 管理区分:利用可能在庫確認を設定します。
void | setReadAtpLockX (Object value) 関連ユーザデータ項目の更新情報を設定します。
void | setStgeLoc (Object value) 保管場所を設定します。
void | setStockInd (Object value) 特殊在庫区分を設定します。
void | setStrParam (String paramStr ,String paramName ,Object value) 構造型の項目に値をセットします。
void | setTblParam (String paramTable ,String paramName ,Object value ,int index) テーブル型の項目に値をセットします。
void | setUnit (Object value) 表示数量単位を設定します。
void | setWbsElem (Object value) WBS 要素を設定します。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
MaterialAvailabilityController

MaterialAvailabilityController ()
コンストラクタ｡
MaterialAvailabilityController

MaterialAvailabilityController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより品目在庫を検索します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getAvQtyPlt

Object getAvQtyPlt ()

プラントレベル利用可能数量を取得します。
返却値
Object プラントレベル利用可能数量
getBatch

Object getBatch ()

ロットを取得します。
返却値
Object ロット
getCheckRule

Object getCheckRule ()

確認規則を取得します。
返却値
Object 確認規則
getCustomer

Object getCustomer ()

得意先コードを取得します。
返却値
Object 得意先コード
getDecForRounding

Object getDecForRounding ()

小数点位置 (その位置まで丸める)を取得します。
返却値
Object 小数点位置 (その位置まで丸める)
getDecForRoundingX

Object getDecForRoundingX ()

関連ユーザデータ項目の更新情報を取得します。
返却値
Object 関連ユーザデータ項目の更新情報
getDialogflag

Object getDialogflag ()

区分 (X = 利用不可 /N = 確認なし)を取得します。
返却値
Object 区分 (X = 利用不可 /N = 確認なし)
getDocNumber

Object getDocNumber ()

伝票番号を取得します。
返却値
Object 伝票番号
getEndleadtme

Object getEndleadtme ()

補充リードタイムの終了日付を取得します。
返却値
Object 補充リードタイムの終了日付
getItmNumber

Object getItmNumber ()

明細番号を取得します。
返却値
Object 明細番号
getMaterial

Object getMaterial ()

品目コードを取得します。
返却値
Object 品目コード
getMaterialEvg

Object getMaterialEvg ()

品目コード(長)を取得します｡
返却値
Object 品目コード(長)

品目コード(長)情報オブジェクトの構成は以下のとおりです。
品目コード(長)
オブジェクト
(Object)
MATERIAL_EXT外部品目コード(長)(String)
MATERIAL_VERS品目バージョン番号(String)
MATERIAL_GUID品目コード(外部GUID)(String)

取得した出力テーブル情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["MATERIAL_EXT"]　→　配列内のidx番目の出力テーブルの「外部品目コード(長)」
[idx]["MATERIAL_VERS"]　→　配列内のidx番目の出力テーブルの「品目バージョン番号」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の出力テーブルの「品目コード(外部GUID)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPlant

Object getPlant ()

プラントを取得します。
返却値
Object プラント
getReadAtpLock

Object getReadAtpLock ()

管理区分:利用可能在庫確認を取得します。
返却値
Object 管理区分:利用可能在庫確認
getReadAtpLockX

Object getReadAtpLockX ()

関連ユーザデータ項目の更新情報を取得します。
返却値
Object 関連ユーザデータ項目の更新情報
getStgeLoc

Object getStgeLoc ()

保管場所を取得します。
返却値
Object 保管場所
getUnit

Object getUnit ()

表示数量単位を取得します。
返却値
Object 表示数量単位
getWbsElem

Object getWbsElem ()

WBS 要素を取得します。
返却値
Object WBS 要素
getWmdvexList

Object getWmdvexList ()

出力テーブル (日付および ATP 数量)を取得します。
返却値
Object 出力テーブル (日付および ATP 数量)

出力テーブル (日付および ATP 数量)情報オブジェクトの構成は以下のとおりです。
出力テーブル (日付および ATP 数量)情報
オブジェクト
(Object)
BDCNT 5 文字数値 NUMC (String)
REQ_DATE 所要日付 (String)
REQ_QTY 利用可能在庫確認の所要量 (String)
COM_DATE 確認日 (String)
COM_QTY 確認数量 (String)

取得した出力テーブル情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["BDCNT"]　→　配列内のidx番目の出力テーブルの「5 文字数値 NUMC」
[idx]["REQ_DATE"]　→　配列内のidx番目の出力テーブルの「所要日付」
[idx]["REQ_QTY"]　→　配列内のidx番目の出力テーブルの「利用可能在庫確認の所要量」
[idx]["COM_DATE"]　→　配列内のidx番目の出力テーブルの「確認日」
[idx]["COM_QTY"]　→　配列内のidx番目の出力テーブルの「確認数量」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getWmdvsxList

Object getWmdvsxList ()

入力テーブル (日付/数量)を取得します。
返却値
Object 入力テーブル (日付/数量)

入力テーブル (日付/数量)情報オブジェクトの構成は以下のとおりです。
入力テーブル (日付/数量)情報
オブジェクト
(Object)
REQ_DATE 所要日付 (String)
REQ_QTY 所要量 (String)
DELKZ MRP 要素区分 (String)
YLINE 内部テ−ブル処理の行索引 (String)

取得した入力テーブル情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["REQ_DATE"]　→　配列内のidx番目の出力テーブルの「所要日付」
[idx]["REQ_QTY"]　→　配列内のidx番目の出力テーブルの「所要量」
[idx]["DELKZ"]　→　配列内のidx番目の出力テーブルの「MRP 要素区分」
[idx]["YLINE"]　→　配列内のidx番目の出力テーブルの「内部テ−ブル処理の行索引」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

setAvQtyPlt

void setAvQtyPlt (Object value)

プラントレベル利用可能数量を設定します。
パラメータ
value Object プラントレベル利用可能数量
返却値
void
setBatch

void setBatch (Object value)

ロットを設定します。
パラメータ
value Object ロット
返却値
void
setCheckRule

void setCheckRule (Object value)

確認規則を設定します。
パラメータ
value Object 確認規則
返却値
void
setCustomer

void setCustomer (Object value)

得意先コードを設定します。
パラメータ
value Object 得意先コード
返却値
void
setDecForRounding

void setDecForRounding (Object value)

小数点位置 (その位置まで丸める)を設定します。
パラメータ
value Object 小数点位置 (その位置まで丸める)
返却値
void
setDecForRoundingX

void setDecForRoundingX (Object value)

関連ユーザデータ項目の更新情報を設定します。
パラメータ
value Object 関連ユーザデータ項目の更新情報
返却値
void
setDialogflag

void setDialogflag (Object value)

区分 (X = 利用不可 /N = 確認なし)を設定します。
パラメータ
value Object 区分 (X = 利用不可 /N = 確認なし)
返却値
void
setDocNumber

void setDocNumber (Object value)

伝票番号を設定します。
パラメータ
value Object 伝票番号
返却値
void
setEndleadtme

void setEndleadtme (Object value)

補充リードタイムの終了日付を設定します。
パラメータ
value Object 補充リードタイムの終了日付
返却値
void
setItmNumber

void setItmNumber (Object value)

明細番号を設定します。
パラメータ
value Object 明細番号
返却値
void
setMaterial

void setMaterial (Object value)

品目コードを設定します。
パラメータ
value Object 品目コード
返却値
void
setPlant

void setPlant (Object value)

プラントを設定します。
パラメータ
value Object プラント
返却値
void
setReadAtpLock

void setReadAtpLock (Object value)

管理区分:利用可能在庫確認を設定します。
パラメータ
value Object 管理区分:利用可能在庫確認
返却値
void
setReadAtpLockX

void setReadAtpLockX (Object value)

関連ユーザデータ項目の更新情報を設定します。
パラメータ
value Object 関連ユーザデータ項目の更新情報
返却値
void
setStgeLoc

void setStgeLoc (Object value)

保管場所を設定します。
パラメータ
value Object 保管場所
返却値
void
setStockInd

void setStockInd (Object value)

特殊在庫区分を設定します。
パラメータ
value Object 特殊在庫区分
返却値
void
setStrParam

void setStrParam (String paramStr ,String paramName ,Object value)

構造型の項目に値をセットします。
パラメータ
paramStr | String | 構造名
paramName | String | 項目名
value | Object | セットする値
返却値
void
setTblParam

void setTblParam (String paramTable ,String paramName ,Object value ,int index)

テーブル型の項目に値をセットします。
パラメータ
paramTable | String | テーブル名
paramName | String | 項目名
value | Object | セットする値
index | int | レコード番号
返却値
void
setUnit

void setUnit (Object value)

表示数量単位を設定します。
パラメータ
value Object 表示数量単位
返却値
void
setWbsElem

void setWbsElem (Object value)

WBS 要素を設定します。
パラメータ
value Object WBS 要素
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 MaterialGetAllController オブジェクト

品目マスタ照会クラス。

機能は以下の通り
  • 品目マスタを照会します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
MaterialGetAllController ()
コンストラクタ
メソッドの概要
Object | executeBapi () BapiControllerにより品目コードを検索します。
Object | getClientData () 品目データ (クライアントレベル)を取得します。
Object | getCompanycode () 会社コードを取得します。
Object | getDistributionchannel () 流通チャネルを取得します。
Object | getExtensionOutList () BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。
Object | getForecastParameters () 予測パラメータを取得します。
Array | getInternationArticleNumbersList () EANを取得します。
Object | getLifoValuationData () LIFO 関連品目データを取得します。
Object | getLifovaluationlevel () LIFO 評価レベルを取得します。
Object | getMaterial () 品目コードを取得します。
Array | getMaterialDescriptionList () 品目テキストを取得します。
Object | getMaterialEvg () 品目コード(長)を取得します。
Array | getMaterialTextList () テキスト (長)を取得します。
Object | getPlanningData () 品目マスタ/製品グループの変更伝票構造を取得します。
Object | getPlant () プラントを取得します。
Object | getPlantData () 品目データ (プラントレベル)を取得します。
Object | getProductionResourceToolData () 品目マスタの生産資源/治工具 (PRT) 項目を取得します。
Object | getSalesData () 販売データを取得します。
Object | getSalesorganisation () 販売組織を取得します。
Object | getStorageLocationData () 品目データ (保管場所レベル)を取得します。
Object | getStorageTypeData () 保管域タイプデータを取得します。
Object | getStoragelocation () 保管場所を取得します。
Object | getStoragetype () 保管域タイプを取得します。
Array | getTaxClassificationsList () 制御デ−タを取得します。
Array | getUnitSofmeasureList () 数量単位を取得します。
Object | getValuationData () 評価データを取得します。
Object | getValuationarea () 評価レベルを取得します。
Object | getValuationtype () 評価タイプを取得します。
Object | getWarehouseNumberData () 倉庫番号データを取得します。
Object | getWarehousenumber () 倉庫番号/複合倉庫を取得します。
void | setCompanycode (Object value) 会社コードを設定します。
void | setDistributionchannel (Object value) 流通チャネルを設定します。
void | setLifovaluationlevel (Object value) LIFO 評価レベルを設定します。
void | setMaterial (Object value) 品目コードを設定します。
void | setPlant (Object value) プラントを設定します。
void | setSalesorganisation (Object value) 販売組織を設定します。
void | setStoragelocation (Object value) 保管場所を設定します。
void | setStoragetype (Object value) 保管域タイプを設定します。
void | setStrParam (String paramStr ,String paramName ,Object value) 構造型の項目に値をセットします。
void | setTblParam (String tableName ,String paramName ,Object value ,int index) テーブル型の項目に値をセットします。
void | setValuationarea (Object value) 評価レベルを設定します。
void | setValuationtype (Object value) 評価タイプを設定します。
void | setWarehousenumber (Object value) 倉庫番号/複合倉庫を設定します。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
MaterialGetAllController

MaterialGetAllController ()
コンストラクタ
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより品目コードを検索します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getClientData

Object getClientData ()

品目データ (クライアントレベル)を取得します。
返却値
Object 品目データ (クライアントレベル)

品目データ (クライアントレベル)情報オブジェクトの構成は以下のとおりです。
品目データ (クライアントレベル)
オブジェクト
(Object)
MATERIAL 品目コード (String)
IND_SECTOR 産業コード (String)
MATL_TYPE 品目タイプ (String)
CREATED_ON 登録日付 (String)
CREATED_BY オブジェクト登録者名 (String)
LAST_CHNGE 最終変更日付 (String)
CHANGED_BY オブジェクトの変更者名 (String)
MAT_STATUS 品目更新完了ステータス (String)
MAINT_STAT 更新ステータス (String)
DEL_FLAG クライアントレベルでの品目削除フラグ (String)
MATL_GROUP 品目グループ (String)
OLD_MAT_NO 旧品目コード (String)
BASE_UOM 基本数量単位 (String)
BASE_UOM_ISO ISO コードでの基本数量単位 (String)
PO_UNIT 発注単位 (String)
PO_UNIT_ISO ISO コードによる発注単位 (String)
DOCUMENT 文書番号 (文書管理システムによらない) (String)
DOC_TYPE 文書タイプ (文書管理システムによらない) (String)
DOC_VERS 文書バージョン (文書管理システムによらない) (String)
DOC_FORMAT 文書のページ書式 (文書管理システムによらない) (String)
DOC_CHG_NO 文書変更番号 (文書管理システム外) (String)
PAGE_NO 文書ページ番号 (文書管理システムによらない) (String)
NO_SHEETS 文書枚数 (文書管理システムによらない) (String)
PROD_MEMO 製造/検査メモ (String)
PAGEFORMAT 製造メモのページ書式 (String)
SIZE_DIM サイズ/寸法 (String)
BASIC_MATL 主構成物質 (String)
STD_DESCR 標準テキスト (ANSI、ISO など) (String)
DSN_OFFICE 研究室/設計室 (String)
PUR_VALKEY 購買許容値キー (String)
NET_WEIGHT 正味重量 (String)
UNIT_OF_WT 重量単位 (String)
UNIT_OF_WT_ISO ISO コードでの重量単位 (String)
CONTAINER 容器条件 (String)
STOR_CONDS 保管条件 (String)
TEMP_CONDS 温度条件区分 (String)
TRANS_GRP 輸送グループ (String)
HAZ_MAT_NO 危険物コード (String)
DIVISION 製品部門 (String)
COMPETITOR 競合会社 (String)
QTY_GR_GI 数量: 印刷予定入出庫票数 (String)
PROC_RULE 調達規則 (String)
SUP_SOURCE 供給元 (String)
SEASON 季節カテゴリ (String)
LABEL_TYPE ラベルタイプ (String)
LABEL_FORM ラベル書式 (String)
PROD_HIER 品目階層 (String)
CAD_ID CAD 区分 (String)
ALLOWED_WT 許容梱包重量 (String)
PACK_WT_UN 重量単位 (許容梱包重量) (String)
PACK_WT_UN_ISO ISO コードでの重量単位 (許容梱包重量) (String)
ALLWD_VOL 許容梱包容積 (String)
PACK_VO_UN 容積単位 (許容梱包容積) (String)
PACK_VO_UN_ISO ISO コードでの容積単位 (許容梱包容積) (String)
WT_TOL_LT 荷役単位の重量超過許容量 (String)
VOL_TOL_LT 荷役単位の容積超過許容量 (String)
VAR_ORD_UN 可変購買発注単位有効 (String)
CONFIGURED 選定可能品目 (String)
BATCH_MGMT ロット管理所要量区分 (String)
SH_MAT_TYP 梱包材タイプ (String)
FILL_LEVEL 最大レベル (容積別) (String)
STACK_FACT 山積係数 (String)
MAT_GRP_SM 品目グループ: 梱包材 (String)
AUTHORITYGROUP 権限グループ (String)
QM_PROCMNT 調達における品質管理有効 (String)
CATPROFILE カタログプロファイル (String)
MINREMLIFE 最低有効期間残 (String)
SHELF_LIFE 総有効期間 (String)
STOR_PCT 残存有効期間割合 % (String)
CONF_MATL プラント共通選定可能品目 (String)
CO_PRODUCT 区分: 連産品としても使用可能な品目 (String)
PR_REF_MAT 価格設定参照品目 (String)
PUR_STATUS プラント共通品目ステータス (String)
SAL_STATUS 流通チェーン間品目ステータス (String)
PVALIDFROM プラント共通品目のステータス有効開始日付 (String)
SVALIDFROM 流通チェーン間品目ステータスの有効開始日付 (String)
ENVT_RLVT 区分: 環境関連 (String)
PROD_ALLOC 製品割当決定手順 (String)
QUAL_DIK 無償納入による割引対象品目 (String)
MANU_MAT 製造者製品コード (String)
MFR_NO 製造者番号 (String)
INV_MAT_NO 会社固有 (内部) 在庫管理品目コード (String)
MANUF_PROF 製造者製品プロファイル (String)
HAZMATPROF 危険物インジケータプロファイル (String)
HIGH_VISC 区分: 高粘性 (String)
LOOSEORLIQ 区分: バルク/液体 (String)
CLOSED_BOX 完了した梱包材 (String)
APPD_B_REC 区分: バッチ製造記録の承認必須 (String)
MATCMPLLVL 品目完了レベル (String)
PAR_EFF 有効性パラメータへの値割当/変更番号よりも優先 (String)
ROUND_UP_RULE_EXPIRATION_DATE 有効期間期限日 計算の丸め規則 (String)
PERIOD_IND_EXPIRATION_DATE 有効期間期限日 の期間区分 (String)
PROD_COMPOSITION_ON_PACKAGING 区分: 梱包材にプリントされた生産構造 (String)
ITEM_CAT 一般明細カテゴリグループ (String)
HAZ_MAT_NO_EXTERNAL 項目 HAZ_MAT_NO の 品目コード (長) (今後のリリースで開発) (String)
HAZ_MAT_NO_GUID 項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発) (String)
HAZ_MAT_NO_VERSION 項目 HAZ_MAT_NO の バージョン番号 (今後のリリースで開発) (String)
INV_MAT_NO_EXTERNAL 項目 INV_MAT_NO の 品目コード (長) (今後のリリースで開発) (String)
INV_MAT_NO_GUID 項目 INV_MAT_NO の外部 GUID (今後のリリースで開発) (String)
INV_MAT_NO_VERSION 項目 INV_MAT_NO の バージョン番号 (今後のリリースで開発) (String)
MATERIAL_FIXED ロックされている品目 (String)
CM_RELEVANCE_FLAG 構成管理関連 (String)
SLED_BBD 有効期限 (String)
GTIN_VARIANT グローバルトレード明細番号バリアント (String)
SERIALIZATION_LEVEL シリアル番号の指定レベル (String)
PL_REF_MAT 梱包方法が同じ品目の参照品目 (String)
EXTMATLGRP 外部品目グループ (String)
UOMUSAGE 使用数量単位 (String)
GDS_RELEVANT 区分:グローバルデータ同期関連 (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード(長) (String)
MATERIAL_GUID 項目 MATERIAL の外部GUID (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (String)
CONF_MATL_EXTERNAL 項目 CONF_MATL の品目コード(長) (String)
CONF_MATL_GUID 項目 CONF_MATL の外部GUID (String)
CONF_MATL_VERSION 項目 CONF_MATL のバージョン番号 (String)
PL_REF_MAT_EXTERNAL 項目 PL_REF の品目コード(長) (String)
PL_REF_MAT_GUID 項目 PL_REF の外部GUID (String)
PL_REF_MAT_VERSION 項目 PL_REF のバージョン番号 (String)
PR_REF_MAT_EXTERNAL 項目 PR_REF の品目コード(長) (String)
PR_REF_MAT_GUID 項目 PR_REF の外部GUID (String)
PR_REF_MAT_VERSION 項目 PR_REF のバージョン番号 (String)
WE_ORIGIN_ACCEPUANCE 仕入先構内での受領 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getCompanycode

Object getCompanycode ()

会社コードを取得します。
返却値
Object 会社コード
getDistributionchannel

Object getDistributionchannel ()

流通チャネルを取得します。
返却値
Object 流通チャネル
getExtensionOutList

Object getExtensionOutList ()

BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。
返却値
Object BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造

BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報オブジェクト の構成は以下のとおりです。
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報
オブジェクト
(Object)
STRUCTURE BAPI テーブル拡張の構造名 (String)
VALUEPART1 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART2 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART3 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART4 BAPI 拡張パラメータのデータ部分 (String)

取得したBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報 オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["STRUCTURE"]　→　配列内のidx番目のBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の「BAPI テーブル拡張の構造名」
[idx]["VALUEPART1"]　→　配列内のidx番目のBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART2"]　→　配列内のidx番目のBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART3"]　→　配列内のidx番目のBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART4"]　→　配列内のidx番目のBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の「BAPI 拡張パラメータのデータ部分」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getForecastParameters

Object getForecastParameters ()

予測パラメータを取得します。
返却値
Object 予測パラメータ

予測パラメータ情報オブジェクトの構成は以下のとおりです。
予測パラメータ
オブジェクト
(Object)
PLANT プラント (String)
FORE_PROF 需要予測プロファイル (String)
MODEL_SI モデル選択区分 (String)
MODEL_SP モデル選択方式 (String)
PARAM_OPT パラメータ最適化用の区分 (String)
OPTIM_LEV 最適化レベル (String)
INITIALIZE 初期化区分 (String)
FORE_MODEL 予測モデル (String)
ALPHA_FACT アルファ係数使用による基本値の平滑化 (String)
BETA_FACT ベータ係数による傾向値平準化 (String)
GAMMA_FACT ガンマ係数使用の平滑化のための 季節指数 (String)
DELTA_FACT デルタ係数使用による MAD (絶対平均偏差) 平準化 (String)
TRACKLIMIT 警告限界 (String)
FORE_DATE 最終需要予測日 (String)
HIST_VALS 履歴値の数 (String)
INIT_PDS 初期化で使用する履歴値の数 (String)
SEASON_PDS 季節周期ごとの期間数 (String)
EXPOST_PDS 事後的需要予測に含む履歴値の数 (String)
FORE_PDS 需要予測期間 (String)
FIXED_PDS 固定期間 (String)
BASIC_VALUE 基準値 (String)
BASIC_VALUE1 第二指図の基準値 (String)
BASIC_VALUE2 第二指図の基準値 (String)
BASIC_VALUE_PP 前期間の基準値 (String)
BASIC_VALUE_PP1 前期間における第二指図の基準値 (String)
BASIC_VALUE_PP2 前期間における第二指図の基準値 (String)
TREND_VALUE 傾向値 (String)
TREND_VALUE_PP 前期間の傾向値 (String)
MEAN_ABSOL_DEV 絶対平均偏差 (MAD) (String)
MEAN_ABSOL_DEV_PP 前期間の平均絶対偏差 (String)
ERROR_TOTAL エラー合計 (String)
ERROR_TOTAL_PP 前期間のエラー合計 (String)
WTG_GROUP 加重グループ (String)
COEFF_THEIL タイル係数 (String)
EXCEPT_LIST 例外メッセージバー (String)
FOREC_FLOW_CONT 予測フロー管理 (String)
PERIOD_IND 期間区分 (String)
FY_VARIANT 会計年度バリアント (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInternationArticleNumbersList

Array getInternationArticleNumbersList ()

EANを取得します。
返却値
Array EAN

EAN情報オブジェクトの構成は以下のとおりです。
EAN情報
オブジェクト
(Object)
UNIT 表示数量単位 (String)
UNIT_ISO ISO コードでの表示数量単位 (String)
EAN_UPC 国際商品コード (EAN/UPC) (String)
EAN_CAT 国際商品コード (EAN) のカテゴリ (String)
MAIN_EAN 区分: 主要 EAN (String)

取得したEAN情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["UNIT"]　→　配列内のidx番目のEANの「表示数量単位」
[idx]["UNIT_ISO"]　→　配列内のidx番目のEANの「ISO コードでの表示数量単位」
[idx]["EAN_UPC"]　→　配列内のidx番目のEANの「国際商品コード (EAN/UPC)」
[idx]["EAN_CAT"]　→　配列内のidx番目のEANの「国際商品コード (EAN) のカテゴリ」
[idx]["MAIN_EAN"]　→　配列内のidx番目のEANの「区分: 主要 EAN」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getLifoValuationData

Object getLifoValuationData ()

LIFO 関連品目データを取得します。
返却値
Object LIFO 関連品目データ

LIFO 関連品目データ情報オブジェクトの構成は以下のとおりです。
LIFO 関連品目データ
オブジェクト
(Object)
LIFO_VALUATION_LEVEL LIFO 評価レベル (String)
POOLNUMBER LIFO 評価でのプール番号 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getLifovaluationlevel

Object getLifovaluationlevel ()

LIFO 評価レベルを取得します。
返却値
Object LIFO 評価レベル
getMaterial

Object getMaterial ()

品目コードを取得します。
返却値
Object 品目コード
getMaterialDescriptionList

Array getMaterialDescriptionList ()

品目テキストを取得します。
返却値
Array 品目テキスト

品目テキスト情報オブジェクトの構成は以下のとおりです。
品目テキスト情報
オブジェクト
(Object)
LANGU 言語キー (String)
LANGU_ISO ISO 639 準拠の言語 (String)
MATL_DESC 品目テキスト (String)

取得した品目テキスト情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["LANGU"]　→　配列内のidx番目の品目テキストの「言語キー」
[idx]["LANGU_ISO"]　→　配列内のidx番目の品目テキストの「ISO 639 準拠の言語」
[idx]["MATL_DESC"]　→　配列内のidx番目の品目テキストの「品目テキスト」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getMaterialEvg

Object getMaterialEvg ()

品目コード(長)を取得します。
返却値
Object 品目コード(長)

品目コード(長)情報オブジェクトの構成は以下のとおりです。
品目コード(長)
オブジェクト
(Object)
MATERIAL_EXT 外部品目コード(長) (String)
MATERIAL_VERS 品目バージョン番号 (String)
MATERIAL_GUID 品目コード(外部GUID) (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getMaterialTextList

Array getMaterialTextList ()

テキスト (長)を取得します。
返却値
Array テキスト (長)

テキスト (長)情報オブジェクトの構成は以下のとおりです。
テキスト (長)情報
オブジェクト
(Object)
APPLOBJECT テキスト : アプリケーションオブジェクト (String)
TEXT_NAME 名称 (String)
TEXT_ID テキスト ID (String)
LANGU 言語キー (String)
LANGU_ISO ISO 639 準拠の言語 (String)
FORMAT_COL タグ列 (String)
TEXT_LINE テキスト行 (String)

取得したテキスト (長)情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["APPLOBJECT"]　→　配列内のidx番目のテキスト (長)の 「テキスト: アプリケーションオブジェクト」
[idx]["TEXT_NAME"]　→　配列内のidx番目のテキスト (長)の「名称」
[idx]["TEXT_ID"]　→　配列内のidx番目のテキスト (長)の「テキスト ID」
[idx]["LANGU"]　→　配列内のidx番目のテキスト (長)の「言語キー」
[idx]["LANGU_ISO"]　→　配列内のidx番目のテキスト (長)の「ISO 639 準拠の言語」
[idx]["FORMAT_COL"]　→　配列内のidx番目のテキスト (長)の「タグ列」
[idx]["TEXT_LINE"]　→　配列内のidx番目のテキスト (長)の「テキスト行」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPlanningData

Object getPlanningData ()

品目マスタ/製品グループの変更伝票構造を取得します。
返却値
Object 品目マスタ/製品グループの変更伝票構造

品目マスタ/製品グループの変更伝票構造情報オブジェクトの構成は以下のとおりです。
品目マスタ/製品グループの変更伝票構造
オブジェクト
(Object)
PLANT プラント (String)
PLNG_MATL 計画品目 (String)
PLNG_PLANT 計画プラント (String)
CONVFACTOR 計画品目用変換係数 (String)
PLNG_MATL_EXTERNAL 項目 PLNG_MATL の品目コード (長) (今後のリリースで開発) (String)
PLNG_MATL_GUID 項目 PLNG_MATL の外部 GUID (今後のリリースで開発) (String)
PLNG_MATL_VERSION 項目 PLNG_MATL の バージョン番号 (今後のリリースで開発) (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPlant

Object getPlant ()

プラントを取得します。
返却値
Object プラント
getPlantData

Object getPlantData ()

品目データ (プラントレベル)を取得します。
返却値
Object 品目データ (プラントレベル)

品目データ (プラントレベル)情報オブジェクトの構成は以下のとおりです。
品目データ (プラントレベル)
オブジェクト
(Object)
PLANT プラント (String)
MAINT_STAT 更新ステータス (String)
DEL_FLAG プラントレベルでの品目削除フラグ (String)
ABC_ID ABC 区分 (String)
CRIT_PART 区分: 重要品目 (String)
PUR_GROUP 購買グループ (String)
ISSUE_UNIT 出庫単位 (String)
ISSUE_UNIT_ISO ISO コードでの出庫単位 (String)
MRPPROFILE 品目: MRP プロファイル (String)
MRP_TYPE MRP タイプ (String)
MRP_CTRLER MRP 管理者 (String)
PLND_DELRY 予定納入時間 (単位: 日) (String)
GR_PR_TIME 入庫処理日数 (String)
PERIOD_IND 期間区分 (String)
ASSY_SCRAP 組立不良率 (String)
LOTSIZEKEY ロットサイズ (品目計画) (String)
PROC_TYPE 調達タイプ (String)
SPPROCTYPE 特殊調達タイプ (String)
REORDER_PT 発注点 (String)
SAFETY_STK 安全在庫 (String)
MINLOTSIZE 最小ロットサイズ (String)
MAXLOTSIZE 最大ロットサイズ (String)
FIXED_LOT 固定ロットサイズ (String)
ROUND_VAL 購買発注数量の丸め数量 (String)
MAX_STOCK 最大在庫レベル (String)
ORD_COSTS 発注原価 (BAPI インタフェース) (String)
DEP_REQ_ID 個別所要量と包括所要量に対する従属所要量区分 (String)
STOR_COSTS 保管経費区分 (String)
ALT_BOM_ID 代替 BOM 選択の方法 (String)
DISCONTINU 打切区分 (String)
EFF_O_DAY 有効終了日 (String)
FOLLOW_UP フォローアップ品目 (String)
GRP_REQMTS 区分: 所要量グループ化 (String)
MIXED_MRP 二重 MRP 区分 (String)
SM_KEY 日程計画余裕キー (String)
BACKFLUSH 区分: バックフラッシュ (String)
PRODUCTION_SCHEDULER 製造計画担当 (String)
PROC_TIME 処理時間 (String)
SETUPTIME 段取時間と片付け時間 (String)
INTEROP 移動時間 (String)
BASE_QTY 基本数量 (String)
INHSEPRODT 内製日数 (String)
STGEPERIOD 最長保管期間 (String)
STGE_PD_UN 最長保管期間の単位 (String)
STGE_PD_UN_ISO ISO コードでの最長保管期間単位 (String)
OVER_TOL 過剰納入許容範囲リミット (String)
UNLIMITED 区分: 無制限過剰納入可能 (String)
UNDER_TOL 不足納入許容範囲リミット (String)
REPLENTIME 補充リードタイム合計 (稼動日数) (String)
REPLACE_PT 取替部品 (String)
IND_POST_TO_INSP_STOCK 品質検査中在庫への転記 (String)
CTRL_KEY 調達における品質管理の管理キー (String)
DOC_REQD 文書必須フラグ (String)
LOADINGGRP 積載グループ (String)
BATCH_MGMT ロット管理所要量区分 (String)
QUOTAUSAGE 供給量割当の使用 (String)
SERV_LEVEL サービスレベル (String)
SPLIT_IND 分割区分 (String)
AVAILCHECK 利用可能在庫確認の確認グループ (String)
FY_VARIANT 会計年度バリアント (String)
CORR_FACT 区分: 修正係数を需要予測値計算に使用 (String)
SETUP_TIME 出荷準備時間 (String)
BASE_QTY_PLAN 出荷の能力計画のための基本数量 (String)
SHIP_PROC_TIME 出荷処理時間 (String)
SUP_SOURCE 供給元 (String)
AUTO_P_ORD 区分: 購買発注自動生成 (String)
SOURCELIST 区分: 供給元一覧必須 (String)
COMM_CODE 貿易: 統計品目コード/輸入コード番号 (String)
COUNTRYORI 品目の原産国 (String)
COUNTRYORI_ISO ISO コードでの品目原産国 (String)
REGIONORIG 品目の原産地 (非特恵対象地区の原産) (String)
COMM_CO_UN 物品コード (貿易) の数量単位 (String)
COMM_CO_UN_ISO ISO コードによる物品コード (貿易管理) の数量単位 (String)
EXPIMPGRP 輸出/輸入品目グループ (String)
PROFIT_CTR 利益センタ (String)
PPC_PL_CAL PPC 計画カレンダ (String)
REP_MANUF 区分: 繰返生産許可 (String)
PL_TI_FNCE 計画タイムフェンス (String)
CONSUMMODE 消費モード (String)
BWD_CONS 消費期間: 後方 (String)
FWD_CONS 消費期間: 前方 (String)
VERSION_FLAG バージョン区分 (String)
ALTERNATIVE_BOM 代替 BOM (String)
BOM_USAGE BOM 用途 (String)
PLANLISTGRP タスクリストグループのキー (String)
PLANLISTCNT グループカウンタ (String)
LOT_SIZE 原価計算ロットサイズ (String)
SPECPROCTY 原価計算の特殊調達タイプ (String)
PROD_UNIT 製造単位 (String)
PROD_UNIT_ISO 製造単位 (ISO コード) (String)
ISS_ST_LOC 出庫保管場所 (String)
MRP_GROUP MRP グループ (String)
COMP_SCRAP 構成品目不良率 (String)
CERT_TYPE 証明書タイプ (String)
CYCLE_TIME タクトタイム (String)
INSP_SETUP_FLAG 品目/プラントに QM 検査データ設定 (String)
COVPROFILE 在庫日数プロファイル (String)
CC_PH_INV 循環棚卸の実地棚卸区分 (String)
VARIANCE_KEY 差異キー (String)
SERNO_PROF シリアル番号プロファイル (String)
PS_CONF_MAT 選定可能品目 (String)
REPMANPROF 繰返生産プロファイル (String)
NEG_STOCKS プラントにおけるマイナス在庫許可 (String)
QM_RGMTS 仕入先の必須 QM システム (String)
PLNG_CYCLE 計画サイクル (String)
ROUND_PROF 丸めプロファイル (String)
REFMATCONS 消費参照品目 (String)
REFPLTCONS 消費参照プラント (String)
D_TO_REF_M 消費データ参照の有効終了日 (String)
MULT_REF_M 消費データ参照品目の乗数 (String)
AUTO_RESET 予測モデル自動リセット (String)
PREF_STAT_FLAG 区分: 特恵関税 - 輸出/輸入 (String)
EX_CERT_ID 法令管理: 認定書区分 (String)
EX_CERT_NO_NEW 非該当証明書番号 - 法令管理 (String)
EX_CERT_DT 非該当証明書発行日 (String)
DECL_STAT_FLAG 区分: 仕入先申告あり (String)
MILIT_ID ID: 武器 (String)
INSP_INT 次回再検査までの間隔 (String)
CO_PRODUCT 区分: 連産品としても使用可能な品目 (String)
PLAN_STRGP 計画方針グループ (String)
SLOC_EXPRC 外部調達の初期保管場所 (String)
BULK_MAT 区分: バルク品目 (String)
CC_FIXED 循環棚卸区分固定 (String)
DETERM_GRP 在庫決定グループ (String)
QM_AUTHGRP QM における活動の品目権限グループ (String)
TASK_LIST_TYPE タスクリストタイプ (String)
PUR_STATUS プラント特有品目ステータス (String)
PRODPROF 製造計画プロファイル (String)
SAFTY_T_ID 安全時間区分（安全リードタイムあり/なし) (String)
SAFETYTIME 安全時間 (稼動日数) (String)
PLORD_CTRL アクション管理: 計画手配処理 (String)
BATCHENTRY 製造/プロセス指図でのロット入力設定 (String)
PVALIDFROM プラント品目ステータス有効期間開始日 (String)
MATFRGTGRP 品目運賃グループ (String)
PRODVERSCS 原価計算を行う製造バージョン (String)
MAT_CFOP 品目 CFOP カテゴリ (String)
EU_LIST_NO CAP: CAP 製品一覧番号 (String)
EU_MAT_GRP EEC 農産物政策: CAP 生産品グループ - 貿易 (String)
CAS_NO CAS 番号： 薬事品目 - 貿易 (String)
PRODCOM_NO 生産統計: 貿易における PRODCOM コード (String)
CTRL_CODE 貿易: 消費税の管理コード (String)
JIT_RELVT 区分: JIT 納入日程の関連明細 (String)
MAT_GRP_TRANS 段取替えマトリクスに対する品目のグループ (String)
HANDLG_GRP ワークロード計算のロジスティクス処理グループ (String)
SUPPLY_AREA 品目マスタレコードで提案される供給場所 (String)
FAIR_SHARE_RULE 均等配賦ルール (String)
PUSH_DISTRIB 区分: プッシュ配賦 (String)
DEPLOY_HORIZ 供給分配期間の日数 (String)
MIN_LOT_SIZE 需要と供給を一致させるための最小ロットサイズ (String)
MAX_LOT_SIZE 需要と供給を一致させるための最大ロットサイズ (String)
FIX_LOT_SIZE 需要供給の一致に対する固定ロットサイズ (String)
LOT_INCREMENT 需要と供給を一致させるためのロットサイズ増分 (String)
PROD_CONV_TYPE 生産値の変換タイプ (String)
DISTR_PROF サイトの商品の物流プロファイル (String)
PERIOD_PROFILE_SAFETY_TIME 安全時間の期間プロファイル (String)
FXD_PRICE 固定価格連産品 (String)
AVAIL_CHECK_ALL_PROJ_SEGMENTS プロジェクト間品目区分 (String)
OVERALLPRF 指図変更管理の全体プロファイル (String)
MRP_RELEVANCY_DEP_REQUIREMENTS 従属所要量と MRP の関連性 (String)
MRP_AREA_EXISTS 区分: MRP エリア登録済 (String)
MIN_SAFETY_STK 最小安全在庫 (String)
NO_COSTING 原価計算なし (String)
UNIT_GROUP 数量単位グループ (String)
FOLLOW_UP_EXTERNAL 項目 FOLLOW_UP の 品目コード (長) (今後のリリースで開発) (String)
FOLLOW_UP_GUID 項目 FOLLOW_UP の外部 GUID (今後のリリースで開発) (String)
FOLLOW_UP_VERSION 項目 FOLLOW_UP の バージョン番号 (今後のリリースで開発) (String)
REFMATCONS_EXTERNAL 項目 REFMATCONS の 品目コード (長) (今後のリリースで開発) (String)
REFMATCONS_GUID 項目 REFMATCONS の外部 GUID (今後のリリースで開発) (String)
REFMATCONS_VERSION 項目 REFMATCONS の バージョン番号 (今後のリリースで開発) (String)
ROTATION_DATE 項目 REFMATCONS の バージョン番号 (今後のリリースで開発) (String)
ORIGINAL_BATCH_FLAG 元ロット管理区分 (String)
ORIGINAL_BATCH_REF_MATERIAL 元ロットの参照品目 (String)
PS_CONF_MAT_EXTERNAL PS_CO 項目の (将来の開発用) 品目コード(長) (String)
PS_CONF_MAT_GUID PS_CONF_MAT 項目の外部 GUID (将来の開発用) (String)
PS_CONF_MAT_VERSION PS_CONF_MAT 項目のバージョン番号 (将来の開発用) (String)
ORIGINAL_BATCH_REF_MATERIAL_E オリジナルロット参照品目 (String)
ORIGINAL_BATCH_REF_MATERIAL_V オリジナルロット参照品目 (String)
ORIGINAL_BATCH_REF_MATERIAL_G オリジナルロット参照品目 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getProductionResourceToolData

Object getProductionResourceToolData ()

品目マスタの生産資源/治工具 (PRT) 項目を取得します。
返却値
Object 品目マスタの生産資源/治工具 (PRT) 項目

品目マスタの生産資源/治工具 (PRT) 項目情報オブジェクトの構成は以下のとおりです。
品目データ (クライアントレベル)
オブジェクト
(Object)
PLANT プラント (String)
CREATE_LOAD_RECS 区分: 生産資源/治工具の負荷レコード登録 (String)
CTRL_KEY 生産資源/治工具管理の管理キー (String)
CTRL_KEY_NO_CHG 管理キーは変更できません (String)
GRP_KEY_1 生産資源/治工具のグループキー 1 (String)
GRP_KEY_2 生産資源/治工具のグループキー 2 (String)
PRT_USAGE 生産資源/治工具用途 (String)
STD_TEXT_KEY 生産資源/治工具の標準テキストキー (String)
REF_KEY_NO_CHG 参照キーは変更できません (String)
START_REF_DATE 生産資源/治工具使用開始の参照日付 (String)
ST_REF_DATE_NO_CHG 開始参照日付は変更できません (String)
START_OFFSET 生産資源/治工具使用の開始オフセット (String)
START_OFFSET_UNIT 生産資源/治工具使用開始の オフセット単位 (String)
START_OFFSET_UNIT_ISO PRT 用途開始決定の 間隔時間単位 (ISO) (String)
START_OFFSET_NO_CHG 開始オフセットは変更できません (String)
END_REF_DATE 生産資源/治工具使用終了日の参照日付 (String)
END_REF_DATE_NO_CHG 終了参照日付は変更できません (String)
END_OFFSET 生産資源/治工具用途の終了オフセット (String)
END_OFFSET_UNIT 生産資源/治工具使用終了 オフセット単位 (String)
END_OFFSET_UNIT_ISO PRT 用途終了決定の 間隔時間単位 (ISO) (String)
END_OFFSET_NO_CHG 終了オフセットは変更できません (String)
FORMULA_TOT_QTY 生産資源/治工具の合計数量 の計算式 (String)
FORMULA_TOT_QTY_NO_CHG 合計数量の計算式は 変更できません (String)
FORMULA_TOT_USAGE 生産資源/治工具の総用途値 の計算式 (String)
FORMULA_TOT_USAGE_NO_CHG すべての用途値を 計算する計算式は変更できません (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getSalesData

Object getSalesData ()

販売データを取得します。
返却値
Object 販売データ

販売データ情報オブジェクトの構成は以下のとおりです。
販売データ
オブジェクト
(Object)
SALES_ORG 販売組織 (String)
DISTR_CHAN 流通チャネル (String)
DEL_FLAG 区分: 流通チャネルレベルでの 品目削除フラグ (String)
MATL_STATS 品目統計グループ (String)
REBATE_GRP 取引量リベートグループ (String)
COMM_GROUP 手数料グループ (String)
CASH_DISC 現金値引区分 (String)
SAL_STATUS 販売ビューからの品目ステータス (String)
VALID_FROM 流通チェーン別品目ステータスの 有効期間開始日 (String)
MIN_ORDER 基本数量単位での最小受注数量 (String)
MIN_DELY 納品書処理時の最小納入数量 (String)
MIN_MTO 受注製造品最少受注数量 (String)
DELY_UNIT 出荷単位 (String)
DELY_UOM 出荷数量単位 (String)
DELY_UOM_ISO ISO コードでの出荷単位の 数量単位 (String)
SALES_UNIT 販売単位 (String)
SALES_UNIT_ISO ISO コードによる販売単位 (String)
ITEM_CAT 品目マスタの明細カテゴリグループ (String)
DELYG_PLNT 出荷プラント (String)
PROD_HIER 品目階層 (String)
PR_REF_MAT 価格設定参照品目 (String)
MAT_PR_GRP 品目価格設定グループ (String)
ACCT_ASSGT 品目の勘定設定グループ (String)
MATL_GRP_1 品目グループ 1 (String)
MATL_GRP_2 品目グループ 2 (String)
MATL_GRP_3 品目グループ 3 (String)
MATL_GRP_4 品目グループ 4 (String)
MATL_GRP_5 品目グループ 5 (String)
PROD_ATT_1 ID: 製品属性 1 (String)
PROD_ATT_2 品目属性 2 用 ID (String)
PROD_ATT_3 品目属性 3 用 ID (String)
PROD_ATT_4 品目属性 4 用 ID (String)
PROD_ATT_5 品目属性 5 用 ID (String)
PROD_ATT_6 品目属性 6 の ID (String)
PROD_ATT_7 品目属性 7 用 ID (String)
PROD_ATT_8 品目属性 8 用 ID (String)
PROD_ATT_9 品目属性 9 (String)
PROD_ATT10 品目属性 10 用 ID (String)
ROUND_PROF 丸めプロファイル (String)
VAR_SALES_UN 可変販売単位の使用不可 (String)
UNIT_GROUP 数量単位グループ (String)
PR_REF_MAT_EXTERNAL 項目 PR_REF_MAT の 品目コード (長) (今後のリリースで開発) (String)
PR_REF_MAT_GUID 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発) (String)
PR_REF_MAT_VERSION 項目 PR_REF_MAT の バージョン番号 (今後のリリースで開発) (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getSalesorganisation

Object getSalesorganisation ()

販売組織を取得します。
返却値
Object 販売組織
getStorageLocationData

Object getStorageLocationData ()

品目データ (保管場所レベル)を取得します。
返却値
Object 品目データ (保管場所レベル)

品目データ (保管場所レベル)情報オブジェクトの構成は以下のとおりです。
品目データ (保管場所レベル)
オブジェクト
(Object)
PLANT プラント (String)
STGE_LOC 保管場所 (String)
MAINT_STAT 更新ステータス (String)
DEL_FLAG 保管場所レベルでの品目削除フラグ (String)
FISC_YEAR 当会計年度 (String)
CURR_PERIOD 当期 (転記期間) (String)
MRP_IND 保管場所 MRP 区分 (String)
SPEC_PROC 保管場所レベルでの特殊調達タイプ (String)
REORDER_PT 保管場所 MRP に対する発注点 (String)
REPL_QTY 保管場所 MRP に対する補充数量 (String)
STGE_BIN 棚番 (String)
PICKG_AREA 簡易倉庫管理のピッキングエリア (String)
INV_CORR_FAC 在庫修正係数 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getStorageTypeData

Object getStorageTypeData ()

保管域タイプデータを取得します。
返却値
Object 保管域タイプデータ

保管域タイプデータ情報オブジェクトの構成は以下のとおりです。
保管域タイプデータ
オブジェクト
(Object)
WHSE_NO 倉庫番号/複合倉庫 (String)
STGE_TYPE 保管域タイプ (String)
DEL_FLAG 保管タイプに該当する 全品目データ削除フラグ (String)
STGE_BIN 棚番 (String)
MAX_SB_QTY 最大棚番在庫数量 (String)
MIN_SB_QTY 最小棚番在庫数量 (String)
CTRL_QTY 管理数量 (String)
REPLEN_QTY 補充数量 (String)
PICK_AREA ピッキングエリア (String)
ROUND_QTY 丸め数量 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getStoragelocation

Object getStoragelocation ()

保管場所を取得します。
返却値
Object 保管場所
getStoragetype

Object getStoragetype ()

保管域タイプを取得します。
返却値
Object 保管域タイプ
getTaxClassificationsList

Array getTaxClassificationsList ()

制御デ−タを取得します。
返却値
Array 制御デ−タ

制御デ−タ情報オブジェクトの構成は以下のとおりです。
制御デ−タ情報
オブジェクト
(Object)
DEPCOUNTRY 出荷国 (商品発送国) (String)
DEPCOUNTRY_ISO 出荷国の ISO コード (String)
TAX_TYPE_1 税カテゴリ (消費税等) (String)
TAXCLASS_1 品目の税分類 (String)

取得した制御デ−タ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["DEPCOUNTRY"]　→　配列内のidx番目の制御デ−タの「出荷国 (商品発送国)」
[idx]["DEPCOUNTRY_ISO"]　→　配列内のidx番目の制御デ−タの「出荷国の ISO コード」
[idx]["TAX_TYPE_1"]　→　配列内のidx番目の制御デ−タの「税カテゴリ (消費税等)」
[idx]["TAXCLASS_1"]　→　配列内のidx番目の制御デ−タの「品目の税分類」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getUnitSofmeasureList

Array getUnitSofmeasureList ()

数量単位を取得します。
返却値
Array 数量単位

数量単位情報オブジェクトの構成は以下のとおりです。
数量単位情報
オブジェクト
(Object)
ALT_UNIT 在庫保管単位の代替数量単位 (String)
ALT_UNIT_ISO ISO コードによる 在庫単位の代替数量単位 (String)
NUMERATOR 基本数量単位への換算分子 (String)
DENOMINATR 分母: 基本数量単位へ変換する場合 (String)
EAN_UPC 国際商品コード (EAN/UPC) (String)
EAN_CAT 国際商品コード (EAN) のカテゴリ (String)
LENGTH 長さ (String)
WIDTH 幅 (String)
HEIGHT 高さ (String)
UNIT_DIM 寸法単位 (長さ/幅/高さ) (String)
UNIT_DIM_ISO ISO コードでの 長さ、幅、高さの単位 (String)
VOLUME 容積 (String)
VOLUMEUNIT 容積単位 (String)
VOLUMEUNIT_ISO ISO コードでの容積単位 (String)
GROSS_WT 総重量 (String)
UNIT_OF_WT 重量単位 (String)
UNIT_OF_WT_ISO ISO コードでの重量単位 (String)
SUB_UOM 梱包階層の下位レベル数量単位 (String)
SUB_UOM_ISO 下位レベル数量単位 (ISO コード) (String)
INTERNAL_CHAR 内部特性 (String)
UOMSORTNUMBER 数量単位ソート番号 (String)
LEADINGUOM 主要ロット特定数量単位 (String)
VALUEDUOM ロット特定数量単位での評価 (String)
CHAR_UNIT 特性の数量単位 (String)
CHAR_UNIT_ISO 下位レベル数量単位 (ISO コード) (String)
GTIN_VARIANT グローバルトレード明細番号 バリアント (String)
NET_WEIGHT 正味重量 (String)
ME_ANZ_SUB 下位レベル数量単位数 (String)

取得した数量単位情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ALT_UNIT"]　→　配列内のidx番目の数量単位の「在庫保管単位の代替数量単位」
[idx]["ALT_UNIT_ISO"]　→　配列内のidx番目の数量単位の 「ISO コードによる在庫単位の代替数量単位」
[idx]["NUMERATOR"]　→　配列内のidx番目の数量単位の「基本数量単位への換算分子」
[idx]["DENOMINATR"]　→　配列内のidx番目の数量単位の「分母: 基本数量単位へ変換する場合」
[idx]["EAN_UPC"]　→　配列内のidx番目の数量単位の「国際商品コード (EAN/UPC)」
[idx]["EAN_CAT"]　→　配列内のidx番目の数量単位の「国際商品コード (EAN) のカテゴリ」
[idx]["LENGTH"]　→　配列内のidx番目の数量単位の「長さ」
[idx]["WIDTH"]　→　配列内のidx番目の数量単位の「幅」
[idx]["HEIGHT"]　→　配列内のidx番目の数量単位の「高さ」
[idx]["UNIT_DIM"]　→　配列内のidx番目の数量単位の「寸法単位 (長さ/幅/高さ)」
[idx]["UNIT_DIM_ISO"]　→　配列内のidx番目の数量単位の 「ISO コードでの長さ、幅、高さの単位」
[idx]["VOLUME"]　→　配列内のidx番目の数量単位の「容積」
[idx]["VOLUMEUNIT"]　→　配列内のidx番目の数量単位の「容積単位」
[idx]["VOLUMEUNIT_ISO"]　→　配列内のidx番目の数量単位の「ISO コードでの容積単位」
[idx]["GROSS_WT"]　→　配列内のidx番目の数量単位の「総重量」
[idx]["UNIT_OF_WT"]　→　配列内のidx番目の数量単位の「重量単位」
[idx]["UNIT_OF_WT_ISO"]　→　配列内のidx番目の数量単位の「ISO コードでの重量単位」
[idx]["SUB_UOM"]　→　配列内のidx番目の数量単位の「梱包階層の下位レベル数量単位」
[idx]["SUB_UOM_ISO"]　→　配列内のidx番目の数量単位の「下位レベル数量単位 (ISO コード)」
[idx]["INTERNAL_CHAR"]　→　配列内のidx番目の数量単位の「内部特性」
[idx]["UOMSORTNUMBER"]　→　配列内のidx番目の数量単位の「数量単位ソート番号」
[idx]["LEADINGUOM"]　→　配列内のidx番目の数量単位の「主要ロット特定数量単位」
[idx]["VALUEDUOM"]　→　配列内のidx番目の数量単位の「ロット特定数量単位での評価」
[idx]["CHAR_UNIT"]　→　配列内のidx番目の数量単位の「特性の数量単位」
[idx]["CHAR_UNIT_ISO"]　→　配列内のidx番目の数量単位の 「下位レベル数量単位 (ISO コード)」
[idx]["GTIN_VARIANT"]　→　配列内のidx番目の数量単位の「グローバルトレード明細番号バリアント」
[idx]["NET_WEIGHT"]　→　配列内のidx番目の数量単位の「正味重量」
[idx]["ME_ANZ_SUB"]　→　配列内のidx番目の数量単位の「下位レベル数量単位数」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getValuationData

Object getValuationData ()

評価データを取得します。
返却値
Object 評価データ

評価データ情報オブジェクトの構成は以下のとおりです。
評価データ
オブジェクト
(Object)
VAL_AREA 評価レベル (String)
VAL_TYPE 評価タイプ (String)
MAINT_STAT 更新ステータス (String)
DEL_FLAG 評価タイプに該当する 全品目データ削除フラグ (String)
PRICE_CTRL 原価管理区分 (String)
MOVING_PR 移動平均原価/期間単位価格 (String)
STD_PRICE 標準原価 (String)
PRICE_UNIT 価格単位 (String)
VAL_CLASS 評価クラス (String)
PR_CTRL_PP 前期間の原価管理区分 (String)
MOV_PR_PP 前期移動平均原価/期間平均原価 (String)
STD_PR_PP 前期標準標準原価 (String)
PR_UNIT_PP 前期価格単位 (String)
VCLASS_PP 前期評価クラス (String)
PR_CTRL_PY 前年度の原価管理区分 (String)
MOV_PR_PY 前年度の移動平均原価/期間単価 (String)
STD_PR_PY 前年度標準原価 (String)
VCLASS_PY 前年度の評価クラス (String)
PR_UNIT_PY 前年度価格単位 (String)
FISC_YEAR 当会計年度 (String)
CURR_PERIOD 当期 (転記期間) (String)
VAL_CAT 評価カテゴリ (String)
FUTURE_PR 次期標準原価 (String)
VALID_FROM 原価有効開始日 (String)
TAXPRICE_1 税法による評価額: レベル 1 (String)
COMMPRICE1 商法による評価額: レベル 1 (String)
TAXPRICE_3 税法基準評価額: レベル 3 (String)
COMMPRICE3 商法基準評価額: レベル 3 (String)
PLND_PRICE 予定計画原価 (String)
PLNDPRICE1 予定計画原価 1 (String)
PLNDPRICE2 予定計画原価 2 (String)
PLNDPRICE3 予定計画原価 3 (String)
PLNDPRDATE1 予定原価 1 の有効開始日 (String)
PLNDPRDATE2 予定原価 2 の有効開始日 (String)
PLNDPRDATE3 予定原価 3 の有効開始日 (String)
LIFO_FIFO LIFO/FIFO 関連 (String)
POOLNUMBER LIFO 評価でのプール番号 (String)
TAXPRICE_2 税法による評価額: レベル 2 (String)
COMMPRICE2 商法による評価額: レベル 2 (String)
DEVAL_IND 低価法: 評価減区分 (String)
ORIG_GROUP 発生源グループ (原価要素の下位区分) (String)
OVERHEAD_GRP 原価計算間接費グループ (String)
PER_FUT_COST_EST 将来標準原価見積期間 (String)
PER_CUR_COST_EST 現行標準原価見積期間 (String)
PER_PRE_COST_EST 前標準原価見積期間 (String)
FIJ_FUT_COST_EST 将来標準原価見積の 会計年度 (String)
FIJ_CUR_COST_EST 当期標準原価見積の 会計年度 (String)
FIJ_PRE_COST_EST 前期標準原価見積の 会計年度 (String)
QTY_STRUCT 数量構成により原価計算を行う品目 (String)
PREV_PLAN_PRICE 税法基準評価額: レベル 2 (String)
ML_ACTIVE 品目レベルで有効な品目元帳 (String)
ML_SETTLE 品目元帳決済: 管理 (String)
CURR_PLAN_PRICE 税法基準評価額: レベル 2 (String)
ORIG_MAT 品目発生源 (String)
VM_SO_STK 受注在庫の評価クラス (String)
VM_P_STOCK プロジェクト在庫の評価クラス (String)
MATL_USAGE 品目の用途 (String)
MAT_ORIGIN 品目の原産地 (String)
IN_HOUSE 内部生産 (String)
TAX_CML_UN 税法/商法にもとづく評価額価格単位 (String)
CURRENCY 通貨コード (String)
CURRENCY_ISO ISO コード通貨 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getValuationarea

Object getValuationarea ()

評価レベルを取得します。
返却値
Object 評価レベル
getValuationtype

Object getValuationtype ()

評価タイプを取得します。
返却値
Object 評価タイプ
getWarehouseNumberData

Object getWarehouseNumberData ()

倉庫番号データを取得します。
返却値
Object 倉庫番号データ

倉庫番号データ情報オブジェクトの構成は以下のとおりです。
倉庫番号データ
オブジェクト
(Object)
WHSE_NO 倉庫番号/複合倉庫 (String)
DEL_FLAG WM 倉庫内の全品目データ削除フラグ (String)
STGESECTOR 保管区画区分 (String)
PLACEMENT 在庫受入に対する保管域タイプ検索区分 (String)
WITHDRAWAL 在庫払出に対する保管域タイプ区分 (String)
L_EQUIP_1 積載装置数量 1 (String)
L_EQUIP_2 積載装置数量 2 (String)
L_EQUIP_3 積載装置数量 3 (String)
LEQ_UNIT_1 積載装置数量 1 の数量単位 (String)
LEQ_UNIT_1_ISO ISO コードによる 積載装置数量 1 の数量単位 (String)
LEQ_UNIT_2 積載装置数量 2 の数量単位 (String)
LEQ_UNIT_2_ISO ISO コードによる 積載装置数量 2 の数量単位 (String)
LEQ_UNIT_3 積載装置数量 3 の数量単位 (String)
LEQ_UNIT_3_ISO ISO コードによる 積載装置数量 3 の数量単位 (String)
UNITTYPE_1 第１保管単位タイプ (String)
UNITTYPE_2 第２保管単位タイプ (String)
UNITTYPE_3 第３保管単位タイプ (String)
WM_UNIT 倉庫管理の数量単位 (String)
WM_UNIT_ISO ISO コードでの倉庫管理単位 (String)
ADD_TO_STK 既存在庫への追加許可 (String)
BLOCK_STGE 平置保管域区分 (String)
MSG_TO_IM 区分: 在庫管理への出力 (String)
SPEC_MVMT 倉庫管理の特殊移動区分 (String)
CAPY_USAGE 保管容量使用 (String)
PROCURE_UN 保管容量消費の数量単位 (String)
PROCURE_UN_ISO ISO コードでの 保管容量消費の数量単位 (String)
STGE_TYPE 概略計画および詳細計画の ピッキング保管域タイプ (String)
REF_UNIT 品目マスタレコードの数量単位初期値 (String)
2STEP_PICK ツーステップピッキング適用品目 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getWarehousenumber

Object getWarehousenumber ()

倉庫番号/複合倉庫を取得します。
返却値
Object 倉庫番号/複合倉庫
setCompanycode

void setCompanycode (Object value)

会社コードを設定します。
パラメータ
value Object 会社コード
返却値
void
setDistributionchannel

void setDistributionchannel (Object value)

流通チャネルを設定します。
パラメータ
value Object 流通チャネル
返却値
void
setLifovaluationlevel

void setLifovaluationlevel (Object value)

LIFO 評価レベルを設定します。
パラメータ
value Object LIFO 評価レベル
返却値
void
setMaterial

void setMaterial (Object value)

品目コードを設定します。
パラメータ
value Object 品目コード
返却値
void
setPlant

void setPlant (Object value)

プラントを設定します。
パラメータ
value Object プラント
返却値
void
setSalesorganisation

void setSalesorganisation (Object value)

販売組織を設定します。
パラメータ
value Object 販売組織
返却値
void
setStoragelocation

void setStoragelocation (Object value)

保管場所を設定します。
パラメータ
value Object 保管場所
返却値
void
setStoragetype

void setStoragetype (Object value)

保管域タイプを設定します。
パラメータ
value Object 保管域タイプ
返却値
void
setStrParam

void setStrParam (String paramStr ,String paramName ,Object value)

構造型の項目に値をセットします。
パラメータ
paramStr | String | 構造名
paramName | String | 項目名
value | Object | セットする値
返却値
void
setTblParam

void setTblParam (String tableName ,String paramName ,Object value ,int index)

テーブル型の項目に値をセットします。
パラメータ
tableName | String | テーブル名
paramName | String | 項目名
value | Object | セットする値
index | int | レコード番号
返却値
void
setValuationarea

void setValuationarea (Object value)

評価レベルを設定します。
パラメータ
value Object 評価レベル
返却値
void
setValuationtype

void setValuationtype (Object value)

評価タイプを設定します。
パラメータ
value Object 評価タイプ
返却値
void
setWarehousenumber

void setWarehousenumber (Object value)

倉庫番号/複合倉庫を設定します。
パラメータ
value Object 倉庫番号/複合倉庫
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 MaterialGetListController オブジェクト

品目コード検索クラス。

機能は以下の通り
  • 品目コード、テキストを検索します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
MaterialGetListController ()
コンストラクタ｡
MaterialGetListController (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより品目コードを検索します。
Object | getDistributionchannelselectionlist () 流通チャネルの選択オプション一覧を取得します。
Object | getManufacturerpartnumblist () 製造業者と製造者製品コード一覧を取得します。
Object | getMaterialshortdescsellist () 品目テキストの選択オプション一覧を取得します。
Object | getMatnrlistlist () 品目コードと品目テキストの一覧を取得します。
Object | getMatnrselectionlist () 品目コードの選択オプション一覧を取得します。
Object | getMaxRows () 選択予定品目の最大数に値を取得します。
Object | getPlantselectionlist () プラントの選択オプション一覧を取得します。
Object | getSalesorganisationselectionlist () 販売組織の選択オプション一覧を取得します。
Object | getStoragelocationselectlist () 保管場所の選択オプション一覧を取得します。
void | setMaxRows (String value) 選択予定品目の最大数を設定します。
void | setTblParam (String paramTable ,String paramName ,String value ,int index) テーブル型の項目に値をセットします。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
MaterialGetListController

MaterialGetListController ()
コンストラクタ｡
MaterialGetListController

MaterialGetListController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより品目コードを検索します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getDistributionchannelselectionlist

Object getDistributionchannelselectionlist ()

流通チャネルの選択オプション一覧を取得します。
返却値
Object 流通チャネルの選択オプション一覧

流通チャネルの選択オプション情報オブジェクトの構成は以下のとおりです。
流通チャネルの選択オプション情報
オブジェクト
(Object)
DISTR_CHAN_SIGN 選択演算子 SIGN (テーブル範囲) (String)
DISTR_CHAN_OPTION 選択演算子 OPTION (範囲テーブル) (String)
DISTR_CHAN_LOW 流通チャネルの範囲開始 (String)
DISTR_CHAN_HIGH 流通チャネルの範囲終了 (String)

取得した流通チャネルの選択オプション情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["DISTR_CHAN_SIGN"]　→ 　配列内のidx番目の流通チャネルの選択オプションの「選択演算子 SIGN (テーブル範囲)」
[idx]["DISTR_CHAN_OPTION"]　→ 　配列内のidx番目の流通チャネルの選択オプションの「選択演算子 OPTION (範囲テーブル)」
[idx]["DISTR_CHAN_LOW"]　→ 　配列内のidx番目の流通チャネルの選択オプションの「流通チャネルの範囲開始」
[idx]["DISTR_CHAN_HIGH"]　→ 　配列内のidx番目の流通チャネルの選択オプションの「流通チャネルの範囲終了」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getManufacturerpartnumblist

Object getManufacturerpartnumblist ()

製造業者と製造者製品コード一覧を取得します。
返却値
Object 製造業者と製造者製品コード一覧

製造業者と製造者製品コード情報オブジェクトの構成は以下のとおりです。
製造業者と製造者製品コード情報
オブジェクト
(Object)
MANU_MAT 製造者製品コード (String)
MFR_NO 製造者番号 (String)

取得した製造業者と製造者製品コード情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["MANU_MAT"]　→　配列内のidx番目の製造業者と製造者製品コードの「製造者製品コード」
[idx]["MFR_NO"]　→　配列内のidx番目の製造業者と製造者製品コードの「製造者番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getMaterialshortdescsellist

Object getMaterialshortdescsellist ()

品目テキストの選択オプション一覧を取得します。
返却値
Object 品目テキストの選択オプション一覧

品目テキストの選択オプション情報オブジェクトの構成は以下のとおりです。
品目テキストの選択オプション情報
オブジェクト
(Object)
DESCR_SIGN 選択演算子 SIGN (テーブル範囲) (String)
DESCR_OPTION 選択演算子 OPTION (範囲テーブル) (String)
DESCR_LOW 開始品目テキスト (String)
DESCR_HIGH 品目テキスト (String)

取得した品目テキストの選択オプション情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["DESCR_SIGN"]　→ 　配列内のidx番目の品目テキストの選択オプションの「選択演算子 SIGN (テーブル範囲)」
[idx]["DESCR_OPTION"]　→ 　配列内のidx番目の品目テキストの選択オプションの「選択演算子 OPTION (範囲テーブル)」
[idx]["DESCR_LOW"]　→　配列内のidx番目の品目テキストの選択オプションの「開始品目テキスト」
[idx]["DESCR_HIGH"]　→　配列内のidx番目の品目テキストの選択オプションの「品目テキスト」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getMatnrlistlist

Object getMatnrlistlist ()

品目コードと品目テキストの一覧を取得します。
返却値
Object 品目コードと品目テキストの一覧

品目コードと品目テキスト情報オブジェクトの構成は以下のとおりです。
品目コードと品目テキスト情報
オブジェクト
(Object)
MATERIAL 品目コード (String)
MATL_DESC 品目テキスト (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード (長) (今後のリリースで開発) (String)
MATERIAL_GUID 項目 MATERIAL の外部 GUID (今後のリリースで開発) (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (今後のリリースで開発) (String)

取得した品目コードと品目テキスト情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["MATERIAL"]　→　配列内のidx番目の品目コードと品目テキストの「品目コード」
[idx]["MATL_DESC"]　→　配列内のidx番目の品目コードと品目テキストの「品目テキスト」
[idx]["MATERIAL_EXTERNAL"]　→ 　配列内のidx番目の品目コードと品目テキストの 「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["MATERIAL_GUID"]　→ 　配列内のidx番目の品目コードと品目テキストの「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["MATERIAL_VERSION"]　→ 　配列内のidx番目の品目コードと品目テキストの「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getMatnrselectionlist

Object getMatnrselectionlist ()

品目コードの選択オプション一覧を取得します。
返却値
Object 品目コードの選択オプション一覧

品目コードの選択オプション情報オブジェクトの構成は以下のとおりです。
品目コードの選択オプション情報
オブジェクト
(Object)
MANTNR_SIGN 選択演算子 SIGN (テーブル範囲) (String)
MANTNR_OPTION 選択演算子 OPTION (範囲テーブル) (String)
MATNR_LOW 開始品目コード (String)
MATNR_HIGH 終了品目コード (String)

取得した品目コードの選択オプション情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["MANTNR_SIGN"]　→ 　配列内のidx番目の品目コードの選択オプションの「選択演算子 SIGN (テーブル範囲)」
[idx]["MANTNR_OPTION"]　→ 　配列内のidx番目の品目コードの選択オプションの「選択演算子 OPTION (範囲テーブル)」
[idx]["MATNR_LOW"]　→　配列内のidx番目の品目コードの選択オプションの「開始品目コード」
[idx]["MATNR_HIGH"]　→　配列内のidx番目の品目コードの選択オプションの「終了品目コード」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getMaxRows

Object getMaxRows ()

選択予定品目の最大数に値を取得します。

返却値
Object 選択予定品目の最大数
getPlantselectionlist

Object getPlantselectionlist ()

プラントの選択オプション一覧を取得します。
返却値
Object プラントの選択オプション一覧

プラントの選択オプション情報オブジェクトの構成は以下のとおりです。
プラントの選択オプション情報
オブジェクト
(Object)
PLANT_SIGN 選択演算子 SIGN (テーブル範囲) (String)
PLANT_OPTION 選択演算子 OPTION (範囲テーブル) (String)
PLANT_LOW 対象プラント 開始 (String)
PLANT_HIGH 対象プラント 終了 (String)

取得したプラントの選択オプション情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PLANT_SIGN"]　→ 　配列内のidx番目のプラントの選択オプションの「選択演算子 SIGN (テーブル範囲)」
[idx]["PLANT_OPTION"]　→ 　配列内のidx番目のプラントの選択オプションの「選択演算子 OPTION (範囲テーブル)」
[idx]["PLANT_LOW"]　→　配列内のidx番目のプラントの選択オプションの「対象プラント 開始」
[idx]["PLANT_HIGH"]　→　配列内のidx番目のプラントの選択オプションの「対象プラント 終了」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getSalesorganisationselectionlist

Object getSalesorganisationselectionlist ()

販売組織の選択オプション一覧を取得します。
返却値
Object 販売組織の選択オプション一覧

販売組織の選択オプション情報オブジェクトの構成は以下のとおりです。
販売組織の選択オプション情報
オブジェクト
(Object)
SALESORG_SIGN 選択演算子 SIGN (テーブル範囲) (String)
SALESORG_OPTION 選択演算子 OPTION (範囲テーブル) (String)
SALESORG_LOW 販売組織の範囲開始 (String)
SALESORG_HIGH 販売組織の範囲終了 (String)

取得した販売組織の選択オプション情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["SALESORG_SIGN"]　→ 　配列内のidx番目の販売組織の選択オプションの「選択演算子 SIGN (テーブル範囲)」
[idx]["SALESORG_OPTION"]　→ 　配列内のidx番目の販売組織の選択オプションの「選択演算子 OPTION (範囲テーブル)」
[idx]["SALESORG_LOW"]　→　配列内のidx番目の販売組織の選択オプションの「販売組織の範囲開始」
[idx]["SALESORG_HIGH"]　→　配列内のidx番目の販売組織の選択オプションの「販売組織の範囲終了」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getStoragelocationselectlist

Object getStoragelocationselectlist ()

保管場所の選択オプション一覧を取得します。
返却値
Object 保管場所の選択オプション一覧

保管場所の選択オプション情報オブジェクトの構成は以下のとおりです。
保管場所の選択オプション情報
オブジェクト
(Object)
STLOC_SIGN 選択演算子 SIGN (テーブル範囲) (String)
STLOC_OPTION 選択演算子 OPTION (範囲テーブル) (String)
STLOC_LOW 開始保管場所 (String)
STLOC_HIGH 終了保管場所 (String)

取得した保管場所の選択オプション情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["STLOC_SIGN"]　→ 　配列内のidx番目の保管場所の選択オプションの「選択演算子 SIGN (テーブル範囲)」
[idx]["STLOC_OPTION"]　→ 　配列内のidx番目の保管場所の選択オプションの「選択演算子 OPTION (範囲テーブル)」
[idx]["STLOC_LOW"]　→　配列内のidx番目の保管場所の選択オプションの「開始保管場所」
[idx]["STLOC_HIGH"]　→　配列内のidx番目の保管場所の選択オプションの「終了保管場所」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

setMaxRows

void setMaxRows (String value)

選択予定品目の最大数を設定します。
パラメータ
value String 選択予定品目の最大数
返却値
void
setTblParam

void setTblParam (String paramTable ,String paramName ,String value ,int index)

テーブル型の項目に値をセットします。
パラメータ
paramTable | String | テーブル名
paramName | String | 項目名
value | String | セットする値
index | int | レコード番号
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 MaterialSaveReplicaController オブジェクト

品目マスタ更新クラス。

機能は以下の通り
  • 品目マスタを更新します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
MaterialSaveReplicaController ()
コンストラクタ。
MaterialSaveReplicaController (ConnectionManager connectionManager)
コンストラクタ。
MaterialSaveReplicaController (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより品目マスタを更新します。
Array | getClientDataList () 品目データ (クライアントレベル)を取得します。
Array | getExtensionInList () BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。
Array | getExtensionInXList () 拡張イン/拡張アウトのチェックボックス構造を取得します。
Object | getFlagCadCall () CAD システムからコールを取得します。
Object | getFlagOnline () No ALE Field Selectionを取得します。
Array | getForecastParametersList () 需要予測パラメータを取得します。
Object | getForecastValuesList () 需要予測値のデータ転送を取得します。
Array | getHeadDataList () 管理情報設定ヘッダセグメントを取得します。
Object | getInpfldcheck () 項目無効時の応答を取得します。
Array | getInternationalArtnosList () 国際商品コード (EAN)を取得します。
Object | getMaterialDescriptionList () 品目テキストを取得します。
Array | getMaterialLongTextList () テキスト (長)を取得します。
Object | getNoRollbackWork () Override Rollback Workを取得します。
Object | getNoappllog () アプリケーションログ書込なしを取得します。
Object | getNochangedoc () 変更伝票書込なしを取得します。
Array | getPlanningDataList () 品目マスタ/製品グループの変更伝票構造を取得します。
Array | getPlantDataList () 品目データ (プラントレベル)を取得します。
Array | getPrtDataList () 品目マスタの生産資源/治工具 (PRT) 項目を取得します。
Array | getReturnMessagesList () リターンパラメータ BAPIRET2 の代替構造のデータ転送を取得します。
Array | getSalesDataList () 販売データを取得します。
Array | getStorageLocationDataList () 品目データ (保管場所レベル)を取得します。
Array | getStorageTypeDataList () 保管域タイプデータを取得します。
Array | getTaxClassificationsList () 制御デ−タを取得します。
Object | getTestrun () 書込 BAPI のシミュレーションセッションへの切替を取得します。
Array | getTotalConsumptionList () 品目総消費量のデータ転送を取得します。
Array | getUnitSofmeasureList () 数量単位を取得します。
Array | getUnplndConsumptionList () 計画外消費のデータ転送を取得します。
Array | getValuationDataList () 評価データを取得します。
Array | getWarehouseNumberDataList () 倉庫番号データを取得します。
void | setFlagCadCall (Object value) CAD システムからコールを設定します。
void | setFlagOnline (Object value) No ALE Field Selectionを設定します。
void | setInpfldcheck (Object value) 項目無効時の応答を設定します。
void | setNoRollbackWork (Object value) Override Rollback Workを設定します。
void | setNoappllog (Object value) アプリケーションログ書込なしを設定します。
void | setNochangedoc (Object value) 変更伝票書込なしを設定します。
void | setTblParam (String tableName ,String paramName ,Object value ,int index) テーブル型の項目に値をセットします。
void | setTestrun (Object value) 書込 BAPI のシミュレーションセッションへの切替を設定します。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
MaterialSaveReplicaController

MaterialSaveReplicaController ()
コンストラクタ。
MaterialSaveReplicaController

MaterialSaveReplicaController (ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、MaterialSaveReplicaController#executeBapi()実行後に必ず ConnectionManager#commit()またはConnectionManager#rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。
パラメータ
connectionManager ConnectionManager コネクションマネージャー
MaterialSaveReplicaController

MaterialSaveReplicaController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより品目マスタを更新します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getClientDataList

Array getClientDataList ()

品目データ (クライアントレベル)を取得します。
返却値
Array 品目データ (クライアントレベル)

品目データ (クライアントレベル)情報オブジェクトの構成は以下のとおりです。
品目データ (クライアントレベル)情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
DEL_FLAG クライアントレベルでの品目削除フラグ (String)
MATL_GROUP 品目グループ (String)
OLD_MAT_NO 旧品目コード (String)
BASE_UOM 基本数量単位 (String)
BASE_UOM_ISO ISO コードでの基本数量単位 (String)
PO_UNIT 発注単位 (String)
PO_UNIT_ISO ISO コードによる発注単位 (String)
DOCUMENT 文書番号 (文書管理システムによらない) (String)
DOC_TYPE 文書タイプ (文書管理システムによらない) (String)
DOC_VERS 文書バージョン (文書管理システムによらない) (String)
DOC_FORMAT 文書のページ書式 (文書管理システムによらない) (String)
DOC_CHG_NO 文書変更番号 (文書管理システム外) (String)
PAGE_NO 文書ページ番号 (文書管理システムによらない) (String)
NO_SHEETS 文書枚数 (文書管理システムによらない) (String)
PROD_MEMO 製造/検査メモ (String)
PAGEFORMAT 製造メモのページ書式 (String)
SIZE_DIM サイズ/寸法 (String)
BASIC_MATL 主構成物質 (String)
STD_DESCR 標準テキスト (ANSI、ISO など) (String)
DSN_OFFICE 研究室/設計室 (String)
PUR_VALKEY 購買許容値キー (String)
NET_WEIGHT 正味重量 (String)
UNIT_OF_WT 重量単位 (String)
UNIT_OF_WT_ISO ISO コードでの重量単位 (String)
CONTAINER 容器条件 (String)
STOR_CONDS 保管条件 (String)
TEMP_CONDS 温度条件区分 (String)
TRANS_GRP 輸送グループ (String)
HAZ_MAT_NO 危険物コード (String)
DIVISION 製品部門 (String)
COMPETITOR 競合会社 (String)
QTY_GR_GI 数量: 印刷予定入出庫票数 (String)
PROC_RULE 調達規則 (String)
SUP_SOURCE 供給元 (String)
SEASON 季節カテゴリ (String)
LABEL_TYPE ラベルタイプ (String)
LABEL_FORM ラベル書式 (String)
PROD_HIER 品目階層 (String)
CAD_ID CAD 区分 (String)
ALLOWED_WT 許容梱包重量 (String)
PACK_WT_UN 重量単位 (許容梱包重量) (String)
PACK_WT_UN_ISO ISO コードでの重量単位 (許容梱包重量) (String)
ALLWD_VOL 許容梱包容積 (String)
PACK_VO_UN 容積単位 (許容梱包容積) (String)
PACK_VO_UN_ISO ISO コードでの容積単位 (許容梱包容積) (String)
WT_TOL_LT 荷役単位の重量超過許容量 (String)
VOL_TOL_LT 荷役単位の容積超過許容量 (String)
VAR_ORD_UN 可変購買発注単位有効 (String)
BATCH_MGMT ロット管理所要量区分 (String)
SH_MAT_TYP 梱包材タイプ (String)
FILL_LEVEL 最大レベル (容積別) (String)
STACK_FACT 山積係数 (String)
MAT_GRP_SM 品目グループ: 梱包材 (String)
AUTHORITYGROUP 権限グループ (String)
QM_PROCMNT 調達における品質管理有効 (String)
CATPROFILE カタログプロファイル (String)
MINREMLIFE 最低有効期間残 (String)
SHELF_LIFE 総有効期間 (String)
STOR_PCT 残存有効期間割合 % (String)
PUR_STATUS プラント共通品目ステータス (String)
SAL_STATUS 流通チェーン間品目ステータス (String)
PVALIDFROM プラント共通品目のステータス有効開始日付 (String)
SVALIDFROM 流通チェーン間品目ステータスの有効開始日付 (String)
ENVT_RLVT 区分: 環境関連 (String)
PROD_ALLOC 製品割当決定手順 (String)
QUAL_DIK 無償納入による割引対象品目 (String)
MANU_MAT 製造者製品コード (String)
MFR_NO 製造者番号 (String)
INV_MAT_NO 会社固有 (内部) 在庫管理品目コード (String)
MANUF_PROF 製造者製品プロファイル (String)
HAZMATPROF 危険物インジケータプロファイル (String)
HIGH_VISC 区分: 高粘性 (String)
LOOSEORLIQ 区分: バルク/液体 (String)
CLOSED_BOX 完了した梱包材 (String)
APPD_B_REC 区分: バッチ製造記録の承認必須 (String)
MATCMPLLVL 品目完了レベル (String)
PAR_EFF 有効性パラメータへの値割当/変更番号よりも優先 (String)
ROUND_UP_RULE_EXPIRATION_DATE 有効期間期限日 計算の丸め規則 (String)
PERIOD_IND_EXPIRATION_DATE 有効期間期限日の期間区分 (String)
PROD_COMPOSITION_ON_PACKAGING 区分: 梱包材にプリントされた生産構造 (String)
ITEM_CAT 一般明細カテゴリグループ (String)
HAZ_MAT_NO_EXTERNAL 項目 HAZ_MAT_NO の 品目コード (長) (今後のリリースで開発) (String)
HAZ_MAT_NO_GUID 項目 HAZ_MAT_NO の 外部 GUID (今後のリリースで開発) (String)
HAZ_MAT_NO_VERSION 項目 HAZ_MAT_NO の バージョン番号 (今後のリリースで開発) (String)
INV_MAT_NO_EXTERNAL 項目 INV_MAT_NO の 品目コード (長) (今後のリリースで開発) (String)
INV_MAT_NO_GUID 項目 INV_MAT_NO の 外部 GUID (今後のリリースで開発) (String)
INV_MAT_NO_VERSION 項目 INV_MAT_NO の バージョン番号 (今後のリリースで開発) (String)
MATERIAL_FIXED ロックされている品目 (String)
CM_RELEVANCE_FLAG 構成管理関連 (String)
SLED_BBD 有効期限 (String)
GTIN_VARIANT グローバルトレード明細番号 バリアント (String)
SERIALIZATION_LEVEL シリアル番号の指定レベル (String)
PL_REF_MAT 梱包方法が同じ品目の参照品目 (String)
EXTMATLGRP 外部品目グループ (String)
UOMUSAGE 使用数量単位 (String)
GDS_RELEVANT 区分:グローバルデータ同期関連 (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード(長) (String)
MATERIAL_GUID 項目 MATERIAL の外部GUID (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (String)
PL_REF_MAT_EXTERNAL 項目 PL_REF_MAT の品目コード(長) (String)
PL_REF_MAT_GUID 項目 PL_REF_MAT の外部GUID (String)
PL_REF_MAT_VERSION 項目 PL_REF_MAT のバージョン番号 (String)
WE_ORIGIN_ACCEPTANCE 仕入先構内での受領 (String)

取得した品目データ (クライアントレベル)情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「品目コード」
[idx]["DEL_FLAG"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「クライアントレベルでの品目削除フラグ」
[idx]["MATL_GROUP"]　→　配列内のidx番目の品目データ (クライアントレベル)の「品目グループ」
[idx]["OLD_MAT_NO"]　→　配列内のidx番目の品目データ (クライアントレベル)の「旧品目コード」
[idx]["BASE_UOM"]　→　配列内のidx番目の品目データ (クライアントレベル)の「基本数量単位」
[idx]["BASE_UOM_ISO"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「ISO コードでの基本数量単位」
[idx]["PO_UNIT"]　→　配列内のidx番目の品目データ (クライアントレベル)の「発注単位」
[idx]["PO_UNIT_ISO"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「ISO コードによる発注単位」
[idx]["DOCUMENT"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「文書番号 (文書管理システムによらない)」
[idx]["DOC_TYPE"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「文書タイプ (文書管理システムによらない)」
[idx]["DOC_VERS"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「文書バージョン (文書管理システムによらない)」
[idx]["DOC_FORMAT"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「文書のページ書式 (文書管理システムによらない)」
[idx]["DOC_CHG_NO"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「文書変更番号 (文書管理システム外)」
[idx]["PAGE_NO"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「文書ページ番号 (文書管理システムによらない)」
[idx]["NO_SHEETS"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「文書枚数 (文書管理システムによらない)」
[idx]["PROD_MEMO"]　→　配列内のidx番目の品目データ (クライアントレベル)の「製造/検査メモ」
[idx]["PAGEFORMAT"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「製造メモのページ書式」
[idx]["SIZE_DIM"]　→　配列内のidx番目の品目データ (クライアントレベル)の「サイズ/寸法」
[idx]["BASIC_MATL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「主構成物質」
[idx]["STD_DESCR"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「標準テキスト (ANSI、ISO など)」
[idx]["DSN_OFFICE"]　→　配列内のidx番目の品目データ (クライアントレベル)の「研究室/設計室」
[idx]["PUR_VALKEY"]　→　配列内のidx番目の品目データ (クライアントレベル)の「購買許容値キー」
[idx]["NET_WEIGHT"]　→　配列内のidx番目の品目データ (クライアントレベル)の「正味重量」
[idx]["UNIT_OF_WT"]　→　配列内のidx番目の品目データ (クライアントレベル)の「重量単位」
[idx]["UNIT_OF_WT_ISO"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「ISO コードでの重量単位」
[idx]["CONTAINER"]　→　配列内のidx番目の品目データ (クライアントレベル)の「容器条件」
[idx]["STOR_CONDS"]　→　配列内のidx番目の品目データ (クライアントレベル)の「保管条件」
[idx]["TEMP_CONDS"]　→　配列内のidx番目の品目データ (クライアントレベル)の「温度条件区分」
[idx]["TRANS_GRP"]　→　配列内のidx番目の品目データ (クライアントレベル)の「輸送グループ」
[idx]["HAZ_MAT_NO"]　→　配列内のidx番目の品目データ (クライアントレベル)の「危険物コード」
[idx]["DIVISION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「製品部門」
[idx]["COMPETITOR"]　→　配列内のidx番目の品目データ (クライアントレベル)の「競合会社」
[idx]["QTY_GR_GI"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「数量: 印刷予定入出庫票数」
[idx]["PROC_RULE"]　→　配列内のidx番目の品目データ (クライアントレベル)の「調達規則」
[idx]["SUP_SOURCE"]　→　配列内のidx番目の品目データ (クライアントレベル)の「供給元」
[idx]["SEASON"]　→　配列内のidx番目の品目データ (クライアントレベル)の「季節カテゴリ」
[idx]["LABEL_TYPE"]　→　配列内のidx番目の品目データ (クライアントレベル)の「ラベルタイプ」
[idx]["LABEL_FORM"]　→　配列内のidx番目の品目データ (クライアントレベル)の「ラベル書式」
[idx]["PROD_HIER"]　→　配列内のidx番目の品目データ (クライアントレベル)の「品目階層」
[idx]["CAD_ID"]　→　配列内のidx番目の品目データ (クライアントレベル)の「CAD 区分」
[idx]["ALLOWED_WT"]　→　配列内のidx番目の品目データ (クライアントレベル)の「許容梱包重量」
[idx]["PACK_WT_UN"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「重量単位 (許容梱包重量)」
[idx]["PACK_WT_UN_ISO"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「ISO コードでの重量単位 (許容梱包重量)」
[idx]["ALLWD_VOL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「許容梱包容積」
[idx]["PACK_VO_UN"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「容積単位 (許容梱包容積)」
[idx]["PACK_VO_UN_ISO"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「ISO コードでの容積単位 (許容梱包容積)」
[idx]["WT_TOL_LT"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「荷役単位の重量超過許容量」
[idx]["VOL_TOL_LT"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「荷役単位の容積超過許容量」
[idx]["VAR_ORD_UN"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「可変購買発注単位有効」
[idx]["BATCH_MGMT"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「ロット管理所要量区分」
[idx]["SH_MAT_TYP"]　→　配列内のidx番目の品目データ (クライアントレベル)の「梱包材タイプ」
[idx]["FILL_LEVEL"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「最大レベル (容積別)」
[idx]["STACK_FACT"]　→　配列内のidx番目の品目データ (クライアントレベル)の「山積係数」
[idx]["MAT_GRP_SM"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「品目グループ: 梱包材」
[idx]["AUTHORITYGROUP"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「権限グループ」
[idx]["QM_PROCMNT"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「調達における品質管理有効」
[idx]["CATPROFILE"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「カタログプロファイル」
[idx]["MINREMLIFE"]　→　配列内のidx番目の品目データ (クライアントレベル)の「最低有効期間残」
[idx]["SHELF_LIFE"]　→　配列内のidx番目の品目データ (クライアントレベル)の「総有効期間」
[idx]["STOR_PCT"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「残存有効期間割合 %」
[idx]["PUR_STATUS"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「プラント共通品目ステータス」
[idx]["SAL_STATUS"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「流通チェーン間品目ステータス」
[idx]["PVALIDFROM"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「プラント共通品目のステータス有効開始日付」
[idx]["SVALIDFROM"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「流通チェーン間品目ステータスの有効開始日付」
[idx]["ENVT_RLVT"]　→　配列内のidx番目の品目データ (クライアントレベル)の「区分: 環境関連」
[idx]["PROD_ALLOC"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「製品割当決定手順」
[idx]["QUAL_DIK"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「無償納入による割引対象品目」
[idx]["MANU_MAT"]　→　配列内のidx番目の品目データ (クライアントレベル)の「製造者製品コード」
[idx]["MFR_NO"]　→　配列内のidx番目の品目データ (クライアントレベル)の「製造者番号」
[idx]["INV_MAT_NO"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「会社固有 (内部) 在庫管理品目コード」
[idx]["MANUF_PROF"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「製造者製品プロファイル」
[idx]["HAZMATPROF"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「危険物インジケータプロファイル」
[idx]["HIGH_VISC"]　→　配列内のidx番目の品目データ (クライアントレベル)の「区分: 高粘性」
[idx]["LOOSEORLIQ"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「区分: バルク/液体」
[idx]["CLOSED_BOX"]　→　配列内のidx番目の品目データ (クライアントレベル)の「完了した梱包材」
[idx]["APPD_B_REC"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「区分: バッチ製造記録の承認必須」
[idx]["MATCMPLLVL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「品目完了レベル」
[idx]["PAR_EFF"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「有効性パラメータへの値割当/変更番号よりも優先」
[idx]["ROUND_UP_RULE_EXPIRATION_DATE"]　→　配列内のidx番目の品目データ (クライアントレベル)の「有効期間期限日計算の丸め規則」
[idx]["PERIOD_IND_EXPIRATION_DATE"]　→　配列内のidx番目の品目データ (クライアントレベル)の「有効期間期限日の期間区分」
[idx]["PROD_COMPOSITION_ON_PACKAGING"]　→　配列内のidx番目の品目データ (クライアントレベル)の「区分: 梱包材にプリントされた生産構造」
[idx]["ITEM_CAT"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「一般明細カテゴリグループ」
[idx]["HAZ_MAT_NO_EXTERNAL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 HAZ_MAT_NO の品目コード (長) (今後のリリースで開発)」
[idx]["HAZ_MAT_NO_GUID"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)」
[idx]["HAZ_MAT_NO_VERSION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 HAZ_MAT_NO のバージョン番号 (今後のリリースで開発)」
[idx]["INV_MAT_NO_EXTERNAL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 INV_MAT_NO の品目コード (長) (今後のリリースで開発)」
[idx]["INV_MAT_NO_GUID"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)」
[idx]["INV_MAT_NO_VERSION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 INV_MAT_NO のバージョン番号 (今後のリリースで開発)」
[idx]["MATERIAL_FIXED"]　→　配列内のidx番目の品目データ (クライアントレベル)の「ロックされている品目」
[idx]["CM_RELEVANCE_FLAG"]　→　配列内のidx番目の品目データ (クライアントレベル)の「構成管理関連」
[idx]["SLED_BBD"]　→　配列内のidx番目の品目データ (クライアントレベル)の「有効期限」
[idx]["GTIN_VARIANT"]　→　配列内のidx番目の品目データ (クライアントレベル)の「グローバルトレード明細番号バリアント」
[idx]["SERIALIZATION_LEVEL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「シリアル番号の指定レベル」
[idx]["PL_REF_MAT"]　→　配列内のidx番目の品目データ (クライアントレベル)の「梱包方法が同じ品目の参照品目」
[idx]["EXTMATLGRP"]　→　配列内のidx番目の品目データ (クライアントレベル)の「外部品目グループ」
[idx]["UOMUSAGE"]　→　配列内のidx番目の品目データ (クライアントレベル)の「使用数量単位」
[idx]["GDS_RELEVANT"]　→　配列内のidx番目の品目データ (クライアントレベル)の「区分:グローバルデータ同期関連」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の品目コード(長)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の外部GUID」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL のバージョン番号」
[idx]["PL_REF_MAT_EXTERNAL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 PL_REF_MAT の品目コード(長)」
[idx]["PL_REF_MAT_GUID"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 PL_REF_MAT の外部GUID」
[idx]["PL_REF_MAT_VERSION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 PL_REF_MAT のバージョン番号」
[idx]["WE_ORIGIN_ACCEPTANCE"]　→　配列内のidx番目の品目データ (クライアントレベル)の「仕入先構内での受領」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getExtensionInList

Array getExtensionInList ()

BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。
返却値
Array BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造

BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報オブジェクト の構成は以下のとおりです。
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
STRUCTURE BAPI テーブル拡張の構造名 (String)
VALUEPART1 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART2 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART3 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART4 長さ 229 の文字データのコンテナ (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード(長) (String)
MATERIAL_GUID 項目 MATERIAL の外部GUID (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (String)

取得したBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の 参照構造情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目のBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目のBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の「品目コード」
[idx]["STRUCTURE"]　→　配列内のidx番目のBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の「BAPI テーブル拡張の構造名」
[idx]["VALUEPART1"]　→　配列内のidx番目のBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART2"]　→　配列内のidx番目のBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART3"]　→　配列内のidx番目のBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART4"]　→　配列内のidx番目のBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の「長さ 229 の文字データのコンテナ」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の品目コード(長)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の外部GUID」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL のバージョン番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getExtensionInXList

Array getExtensionInXList ()

拡張イン/拡張アウトのチェックボックス構造を取得します。
返却値
Array 拡張イン/拡張アウトのチェックボックス構造

拡張イン/拡張アウトのチェックボックス構造情報オブジェクトの構成は以下のとおりです。
拡張イン/拡張アウトの チェックボックス構造情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
STRUCTURE BAPI テーブル拡張の構造名 (String)
VALUEPART1 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART2 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART3 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART4 長さ 229 の文字データのコンテナ (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード(長) (String)
MATERIAL_GUID 項目 MATERIAL の外部GUID (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (String)

取得した拡張イン/拡張アウトのチェックボックス構造情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の拡張イン/拡張アウトの チェックボックス構造の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の拡張イン/拡張アウトのチェックボックス構造の「品目コード」
[idx]["STRUCTURE"]　→　配列内のidx番目の拡張イン/拡張アウトの チェックボックス構造の「BAPI テーブル拡張の構造名」
[idx]["VALUEPART1"]　→　配列内のidx番目の拡張イン/拡張アウトの チェックボックス構造の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART2"]　→　配列内のidx番目の拡張イン/拡張アウトの チェックボックス構造の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART3"]　→　配列内のidx番目の拡張イン/拡張アウトの チェックボックス構造の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART4"]　→　配列内のidx番目の拡張イン/拡張アウトの チェックボックス構造の「長さ 229 の文字データのコンテナ」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の品目コード(長)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の外部GUID」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL のバージョン番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getFlagCadCall

Object getFlagCadCall ()

CAD システムからコールを取得します。
返却値
Object CAD システムからコール
getFlagOnline

Object getFlagOnline ()

No ALE Field Selectionを取得します。
返却値
Object No ALE Field Selection
getForecastParametersList

Array getForecastParametersList ()

需要予測パラメータを取得します。
返却値
Array 需要予測パラメータ

需要予測パラメータ情報オブジェクトの構成は以下のとおりです。
需要予測パラメータ情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
PLANT プラント (String)
FORE_PROF 需要予測プロファイル (String)
MODEL_SI モデル選択区分 (String)
MODEL_SP モデル選択方式 (String)
PARAM_OPT パラメータ最適化用の区分 (String)
OPTIM_LEV 最適化レベル (String)
INITIALIZE 初期化区分 (String)
FORE_MODEL 予測モデル (String)
ALPHA_FACT アルファ係数使用による基本値の平滑化 (String)
BETA_FACT ベータ係数による傾向値平準化 (String)
GAMMA_FACT ガンマ係数使用の平滑化の ための季節指数 (String)
DELTA_FACT デルタ係数使用による MAD (絶対平均偏差) 平準化 (String)
TRACKLIMIT 警告限界 (String)
FORE_DATE 最終需要予測日 (String)
HIST_VALS 履歴値の数 (String)
INIT_PDS 初期化で使用する履歴値の数 (String)
SEASON_PDS 季節周期ごとの期間数 (String)
EXPOST_PDS 事後的需要予測に含む履歴値の数 (String)
FORE_PDS 需要予測期間 (String)
FIXED_PDS 固定期間 (String)
WTG_GROUP 加重グループ (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード(長) (String)
MATERIAL_GUID 項目 MATERIAL の外部GUID (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (String)

取得した需要予測パラメータ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の需要予測パラメータの「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の需要予測パラメータの「品目コード」
[idx]["PLANT"]　→　配列内のidx番目の需要予測パラメータの「プラント」
[idx]["FORE_PROF"]　→　配列内のidx番目の需要予測パラメータの「需要予測プロファイル」
[idx]["MODEL_SI"]　→　配列内のidx番目の需要予測パラメータの「モデル選択区分」
[idx]["MODEL_SP"]　→　配列内のidx番目の需要予測パラメータの「モデル選択方式」
[idx]["PARAM_OPT"]　→　配列内のidx番目の需要予測パラメータの「パラメータ最適化用の区分」
[idx]["OPTIM_LEV"]　→　配列内のidx番目の需要予測パラメータの「最適化レベル」
[idx]["INITIALIZE"]　→　配列内のidx番目の需要予測パラメータの「初期化区分」
[idx]["FORE_MODEL"]　→　配列内のidx番目の需要予測パラメータの「予測モデル」
[idx]["ALPHA_FACT"]　→　配列内のidx番目の需要予測パラメータの 「アルファ係数使用による基本値の平滑化」
[idx]["BETA_FACT"]　→　配列内のidx番目の需要予測パラメータの「ベータ係数による傾向値平準化」
[idx]["GAMMA_FACT"]　→　配列内のidx番目の需要予測パラメータの 「ガンマ係数使用の平滑化のための季節指数」
[idx]["DELTA_FACT"]　→　配列内のidx番目の需要予測パラメータの 「デルタ係数使用による MAD (絶対平均偏差) 平準化」
[idx]["TRACKLIMIT"]　→　配列内のidx番目の需要予測パラメータの「警告限界」
[idx]["FORE_DATE"]　→　配列内のidx番目の需要予測パラメータの「最終需要予測日」
[idx]["HIST_VALS"]　→　配列内のidx番目の需要予測パラメータの「履歴値の数」
[idx]["INIT_PDS"]　→　配列内のidx番目の需要予測パラメータの「初期化で使用する履歴値の数」
[idx]["SEASON_PDS"]　→　配列内のidx番目の需要予測パラメータの「季節周期ごとの期間数」
[idx]["EXPOST_PDS"]　→　配列内のidx番目の需要予測パラメータの「事後的需要予測に含む履歴値の数」
[idx]["FORE_PDS"]　→　配列内のidx番目の需要予測パラメータの「需要予測期間」
[idx]["FIXED_PDS"]　→　配列内のidx番目の需要予測パラメータの「固定期間」
[idx]["WTG_GROUP"]　→　配列内のidx番目の需要予測パラメータの「加重グループ」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の品目コード(長)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の外部GUID」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL のバージョン番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getForecastValuesList

Object getForecastValuesList ()

需要予測値のデータ転送を取得します。
返却値
Object 需要予測値のデータ転送

需要予測値のデータ転送情報オブジェクトの構成は以下のとおりです。
需要予測値のデータ転送
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
PLANT プラント (String)
FIRST_DAY 値参照期間の第一日目 (String)
FORE_VALUE 予測値 (String)
CORR_VALUE 需要予測に対する修正値 (String)
SEAS_INDEX 季節指数 (String)
CVALUE_FXD 区分: 消費金額の確定 (String)
EXPOST_VAL 事後的需要予測値 (String)
VAL_RATIO 元値に対する修正値の比率 (修正値: 元値) (String)
MATERIAL_EXTERNAL 項目 MATERIAL の 品目コード (長) (今後のリリースで開発) (String)
MATERIAL_GUID 項目 MATERIAL の外部 GUID (今後のリリースで開発) (String)
MATERIAL_VERSION 項目 MATERIAL の バージョン番号 (今後のリリースで開発) (String)

取得した需要予測値のデータ転送情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の需要予測値のデータ転送の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の需要予測値のデータ転送の「品目コード」
[idx]["PLANT"]　→　配列内のidx番目の需要予測値のデータ転送の「プラント」
[idx]["FIRST_DAY"]　→　配列内のidx番目の需要予測値のデータ転送の「値参照期間の第一日目」
[idx]["FORE_VALUE"]　→　配列内のidx番目の需要予測値のデータ転送の「予測値」
[idx]["CORR_VALUE"]　→　配列内のidx番目の需要予測値のデータ転送の「需要予測に対する修正値」
[idx]["SEAS_INDEX"]　→　配列内のidx番目の需要予測値のデータ転送の「季節指数」
[idx]["CVALUE_FXD"]　→　配列内のidx番目の需要予測値のデータ転送の「区分: 消費金額の確定」
[idx]["EXPOST_VAL"]　→　配列内のidx番目の需要予測値のデータ転送の「事後的需要予測値」
[idx]["VAL_RATIO"]　→　配列内のidx番目の需要予測値のデータ転送の 「元値に対する修正値の比率 (修正値: 元値)」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の需要予測値のデータ転送の 「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の需要予測値のデータ転送の 「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の需要予測値のデータ転送の 「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getHeadDataList

Array getHeadDataList ()

管理情報設定ヘッダセグメントを取得します。
返却値
Array 管理情報設定ヘッダセグメント

管理情報設定ヘッダセグメント情報オブジェクトの構成は以下のとおりです。
管理情報設定ヘッダセグメント情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
IND_SECTOR 産業コード (String)
MATL_TYPE 品目タイプ (String)
BASIC_VIEW 基本データビュー (String)
SALES_VIEW 販売ビュー (String)
PURCHASE_VIEW 購買管理ビュー (String)
MRP_VIEW 資材所要量計画 (MRP) ビュー (String)
FORECAST_VIEW 需要予測ビュー (String)
WORK_SCHED_VIEW 作業計画ビュー (String)
PRT_VIEW 生産資源/治工具 (PRT) ビュー (String)
STORAGE_VIEW 保管ビュー (String)
WAREHOUSE_VIEW 倉庫管理ビュー (String)
QUALITY_VIEW 品質管理ビュー (String)
ACCOUNT_VIEW 会計ビュー (String)
COST_VIEW 原価計算ビュー (String)
MATERIAL_EXTERNAL 項目 MATERIAL の 品目コード (長) (今後のリリースで開発) (String)
MATERIAL_GUID 項目 MATERIAL の 外部 GUID (今後のリリースで開発) (String)
MATERIAL_VERSION 項目 MATERIAL の バージョン番号 (今後のリリースで開発) (String)

取得した管理情報設定ヘッダセグメント情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの「品目コード」
[idx]["IND_SECTOR"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの「産業コード」
[idx]["MATL_TYPE"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの「品目タイプ」
[idx]["BASIC_VIEW"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの「基本データビュー」
[idx]["SALES_VIEW"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの「販売ビュー」
[idx]["PURCHASE_VIEW"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの「購買管理ビュー」
[idx]["MRP_VIEW"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの 「資材所要量計画 (MRP) ビュー」
[idx]["FORECAST_VIEW"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの「需要予測ビュー」
[idx]["WORK_SCHED_VIEW"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの 「作業計画ビュー」
[idx]["PRT_VIEW"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの 「生産資源/治工具 (PRT) ビュー」
[idx]["STORAGE_VIEW"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの「保管ビュー」
[idx]["WAREHOUSE_VIEW"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの 「倉庫管理ビュー」
[idx]["QUALITY_VIEW"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの「品質管理ビュー」
[idx]["ACCOUNT_VIEW"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの「会計ビュー」
[idx]["COST_VIEW"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの「原価計算ビュー」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの 「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの 「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの 「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInpfldcheck

Object getInpfldcheck ()

項目無効時の応答を取得します。
返却値
Object 項目無効時の応答
getInternationalArtnosList

Array getInternationalArtnosList ()

国際商品コード (EAN)を取得します。
返却値
Array 国際商品コード (EAN)

国際商品コード (EAN)情報オブジェクトの構成は以下のとおりです。
国際商品コード (EAN)情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
UNIT 表示数量単位 (String)
UNIT_ISO ISO コードでの表示数量単位 (String)
EAN_UPC 国際商品コード (EAN/UPC) (String)
EAN_CAT 国際商品コード (EAN) のカテゴリ (String)
DEL_FLAG データレコード削除 (テーブル繰返し) (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード(長) (String)
MATERIAL_GUID 項目 MATERIAL の外部GUID (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (String)

取得した国際商品コード (EAN)情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の国際商品コード (EAN)の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の国際商品コード (EAN)の「品目コード」
[idx]["UNIT"]　→　配列内のidx番目の国際商品コード (EAN)の「表示数量単位」
[idx]["UNIT_ISO"]　→　配列内のidx番目の国際商品コード (EAN)の 「ISO コードでの表示数量単位」
[idx]["EAN_UPC"]　→　配列内のidx番目の国際商品コード (EAN)の 「国際商品コード (EAN/UPC)」
[idx]["EAN_CAT"]　→　配列内のidx番目の国際商品コード (EAN)の 「国際商品コード (EAN) のカテゴリ」
[idx]["DEL_FLAG"]　→　配列内のidx番目の国際商品コード (EAN)の 「データレコード削除 (テーブル繰返し)」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の品目コード(長)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の外部GUID」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL のバージョン番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getMaterialDescriptionList

Object getMaterialDescriptionList ()

品目テキストを取得します。
返却値
Object 品目テキスト

品目テキスト情報オブジェクトの構成は以下のとおりです。
品目テキスト
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
LANGU 言語キー (String)
LANGU_ISO ISO 639 準拠の言語 (String)
MATL_DESC 品目テキスト (String)
DEL_FLAG データレコード削除 (テーブル繰返し) (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード(長) (String)
MATERIAL_GUID 項目 MATERIAL の外部GUID (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (String)

取得した品目テキスト情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の品目テキストの「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の品目テキストの「品目コード」
[idx]["LANGU"]　→　配列内のidx番目の品目テキストの「言語キー」
[idx]["LANGU_ISO"]　→　配列内のidx番目の品目テキストの「ISO 639 準拠の言語」
[idx]["MATL_DESC"]　→　配列内のidx番目の品目テキストの「品目テキスト」
[idx]["DEL_FLAG"]　→　配列内のidx番目の品目テキストの「データレコード削除 (テーブル繰返し)」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の品目コード(長)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の外部GUID」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL のバージョン番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getMaterialLongTextList

Array getMaterialLongTextList ()

テキスト (長)を取得します。
返却値
Array テキスト (長)

テキスト (長)情報オブジェクトの構成は以下のとおりです。
テキスト (長)情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
APPLOBJECT テキスト: アプリケーションオブジェクト (String)
TEXT_NAME 名称 (String)
TEXT_ID テキスト ID (String)
LANGU 言語キー (String)
LANGU_ISO ISO 639 準拠の言語 (String)
FORMAT_COL タグ列 (String)
TEXT_LINE テキスト行 (String)
DEL_FLAG データレコード削除 (テーブル繰返し) (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード(長) (String)
MATERIAL_GUID 項目 MATERIAL の外部GUID (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (String)

取得したテキスト (長)情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目のテキスト (長)の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目のテキスト (長)の「品目コード」
[idx]["APPLOBJECT"]　→　配列内のidx番目のテキスト (長)の 「テキスト: アプリケーションオブジェクト」
[idx]["TEXT_NAME"]　→　配列内のidx番目のテキスト (長)の「名称」
[idx]["TEXT_ID"]　→　配列内のidx番目のテキスト (長)の「テキスト ID」
[idx]["LANGU"]　→　配列内のidx番目のテキスト (長)の「言語キー」
[idx]["LANGU_ISO"]　→　配列内のidx番目のテキスト (長)の「ISO 639 準拠の言語」
[idx]["FORMAT_COL"]　→　配列内のidx番目のテキスト (長)の「タグ列」
[idx]["TEXT_LINE"]　→　配列内のidx番目のテキスト (長)の「テキスト行」
[idx]["DEL_FLAG"]　→　配列内のidx番目のテキスト (長)の 「データレコード削除 (テーブル繰返し)」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の品目コード(長)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の外部GUID」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL のバージョン番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getNoRollbackWork

Object getNoRollbackWork ()

Override Rollback Workを取得します。
返却値
Object Override Rollback Work
getNoappllog

Object getNoappllog ()

アプリケーションログ書込なしを取得します。
返却値
Object アプリケーションログ書込なし
getNochangedoc

Object getNochangedoc ()

変更伝票書込なしを取得します。
返却値
Object 変更伝票書込なし
getPlanningDataList

Array getPlanningDataList ()

品目マスタ/製品グループの変更伝票構造を取得します。
返却値
Array 品目マスタ/製品グループの変更伝票構造

品目マスタ/製品グループの変更伝票構造情報オブジェクトの構成は以下のとおりです。
品目マスタ/製品グループの変更伝票構造情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
PLANT プラント (String)
PLNG_MATL 計画品目 (String)
PLNG_PLANT 計画プラント (String)
CONVFACTOR 計画品目用変換係数 (String)
PLNG_MATL_EXTERNAL 項目 PLNG_MATL の 品目コード (長) (今後のリリースで開発) (String)
PLNG_MATL_GUID 項目 PLNG_MATL の外部 GUID (今後のリリースで開発) (String)
PLNG_MATL_VERSION 項目 PLNG_MATL の バージョン番号 (今後のリリースで開発) (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード(長) (String)
MATERIAL_GUID 項目 MATERIAL の外部GUID (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (String)

取得した品目マスタ/製品グループの変更伝票構造情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の品目マスタ/製品グループの変更伝票構造の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の品目マスタ/製品グループの変更伝票構造の「品目コード」
[idx]["PLANT"]　→　配列内のidx番目の品目マスタ/製品グループの変更伝票構造の「プラント」
[idx]["PLNG_MATL"]　→　配列内のidx番目の品目マスタ/製品グループの変更伝票構造の「計画品目」
[idx]["PLNG_PLANT"]　→　配列内のidx番目の品目マスタ/製品グループ の変更伝票構造の「計画プラント」
[idx]["CONVFACTOR"]　→　配列内のidx番目の品目マスタ/製品グループ の変更伝票構造の「計画品目用変換係数」
[idx]["PLNG_MATL_EXTERNAL"]　→　配列内のidx番目の品目マスタ/製品グループ の変更伝票構造の「項目 PLNG_MATL の品目コード (長) (今後のリリースで開発)」
[idx]["PLNG_MATL_GUID"]　→　配列内のidx番目の品目マスタ/製品グループ の変更伝票構造の「項目 PLNG_MATL の外部 GUID (今後のリリースで開発)」
[idx]["PLNG_MATL_VERSION"]　→　配列内のidx番目の品目マスタ/製品グループ の変更伝票構造の「項目 PLNG_MATL のバージョン番号 (今後のリリースで開発)」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の品目コード(長)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の外部GUID」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL のバージョン番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPlantDataList

Array getPlantDataList ()

品目データ (プラントレベル)を取得します。
返却値
Array 品目データ (プラントレベル)

品目データ (プラントレベル)情報オブジェクトの構成は以下のとおりです。
品目データ (プラントレベル)情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
PLANT プラント (String)
DEL_FLAG プラントレベルでの品目削除フラグ (String)
ABC_ID ABC 区分 (String)
CRIT_PART 区分: 重要品目 (String)
PUR_GROUP 購買グループ (String)
ISSUE_UNIT 出庫単位 (String)
ISSUE_UNIT_ISO ISO コードでの出庫単位 (String)
MRPPROFILE 品目: MRP プロファイル (String)
MRP_TYPE MRP タイプ (String)
MRP_CTRLER MRP 管理者 (String)
PLND_DELRY 予定納入時間 (単位: 日) (String)
GR_PR_TIME 入庫処理日数 (String)
PERIOD_IND 期間区分 (String)
ASSY_SCRAP 組立不良率 (String)
LOTSIZEKEY ロットサイズ (品目計画) (String)
PROC_TYPE 調達タイプ (String)
SPPROCTYPE 特殊調達タイプ (String)
REORDER_PT 発注点 (String)
SAFETY_STK 安全在庫 (String)
MINLOTSIZE 最小ロットサイズ (String)
MAXLOTSIZE 最大ロットサイズ (String)
FIXED_LOT 固定ロットサイズ (String)
ROUND_VAL 購買発注数量の丸め数量 (String)
MAX_STOCK 最大在庫レベル (String)
ORD_COSTS 発注原価 (BAPI インタフェース) (String)
DEP_REQ_ID 個別所要量と包括所要量に 対する従属所要量区分 (String)
STOR_COSTS 保管経費区分 (String)
ALT_BOM_ID 代替 BOM 選択の方法 (String)
DISCONTINU 打切区分 (String)
EFF_O_DAY 有効終了日 (String)
FOLLOW_UP フォローアップ品目 (String)
GRP_REQMTS 区分: 所要量グループ化 (String)
MIXED_MRP 二重 MRP 区分 (String)
SM_KEY 日程計画余裕キー (String)
BACKFLUSH 区分: バックフラッシュ (String)
PRODUCTION_SCHEDULER 製造計画担当 (String)
PROC_TIME 処理時間 (String)
SETUPTIME 段取時間と片付け時間 (String)
INTEROP 移動時間 (String)
BASE_QTY 基本数量 (String)
INHSEPRODT 内製日数 (String)
STGEPERIOD 最長保管期間 (String)
STGE_PD_UN 最長保管期間の単位 (String)
STGE_PD_UN_ISO ISO コードでの 最長保管期間単位 (String)
OVER_TOL 過剰納入許容範囲リミット (String)
UNLIMITED 区分: 無制限過剰納入可能 (String)
UNDER_TOL 不足納入許容範囲リミット (String)
REPLENTIME 補充リードタイム合計 (稼動日数) (String)
REPLACE_PT 取替部品 (String)
IND_POST_TO_INSP_STOCK 品質検査中在庫への転記 (String)
CTRL_KEY 調達における品質管理の管理キー (String)
DOC_REQD 文書必須フラグ (String)
LOADINGGRP 積載グループ (String)
BATCH_MGMT ロット管理所要量区分 (String)
QUOTAUSAGE 供給量割当の使用 (String)
SERV_LEVEL サービスレベル (String)
SPLIT_IND 分割区分 (String)
AVAILCHECK 利用可能在庫確認の確認グループ (String)
FY_VARIANT 会計年度バリアント (String)
CORR_FACT 区分: 修正係数を需要予測値計算に使用 (String)
SETUP_TIME 出荷準備時間 (String)
BASE_QTY_PLAN 出荷の能力計画のための基本数量 (String)
SHIP_PROC_TIME 出荷処理時間 (String)
SUP_SOURCE 供給元 (String)
AUTO_P_ORD 区分: 購買発注自動生成 (String)
SOURCELIST 区分: 供給元一覧必須 (String)
COMM_CODE 貿易: 統計品目コード/輸入コード番号 (String)
COUNTRYORI 品目の原産国 (String)
COUNTRYORI_ISO ISO コードでの品目原産国 (String)
REGIONORIG 品目の原産地 (非特恵対象地区の原産) (String)
COMM_CO_UN 物品コード (貿易) の数量単位 (String)
COMM_CO_UN_ISO ISO コードによる物品コード (貿易管理) の数量単位 (String)
EXPIMPGRP 輸出/輸入品目グループ (String)
PROFIT_CTR 利益センタ (String)
PPC_PL_CAL PPC 計画カレンダ (String)
REP_MANUF 区分: 繰返生産許可 (String)
PL_TI_FNCE 計画タイムフェンス (String)
CONSUMMODE 消費モード (String)
BWD_CONS 消費期間: 後方 (String)
FWD_CONS 消費期間: 前方 (String)
ALTERNATIVE_BOM 代替 BOM (String)
BOM_USAGE BOM 用途 (String)
PLANLISTGRP タスクリストグループのキー (String)
PLANLISTCNT グループカウンタ (String)
LOT_SIZE 原価計算ロットサイズ (String)
SPECPROCTY 原価計算の特殊調達タイプ (String)
PROD_UNIT 製造単位 (String)
PROD_UNIT_ISO 製造単位 (ISO コード) (String)
ISS_ST_LOC 出庫保管場所 (String)
MRP_GROUP MRP グループ (String)
COMP_SCRAP 構成品目不良率 (String)
CERT_TYPE 証明書タイプ (String)
CYCLE_TIME タクトタイム (String)
COVPROFILE 在庫日数プロファイル (String)
CC_PH_INV 循環棚卸の実地棚卸区分 (String)
VARIANCE_KEY 差異キー (String)
SERNO_PROF シリアル番号プロファイル (String)
REPMANPROF 繰返生産プロファイル (String)
NEG_STOCKS プラントにおけるマイナス在庫許可 (String)
QM_RGMTS 仕入先の必須 QM システム (String)
PLNG_CYCLE 計画サイクル (String)
ROUND_PROF 丸めプロファイル (String)
REFMATCONS 消費参照品目 (String)
D_TO_REF_M 消費データ参照の有効終了日 (String)
MULT_REF_M 消費データ参照品目の乗数 (String)
AUTO_RESET 予測モデル自動リセット (String)
EX_CERT_ID 法令管理: 認定書区分 (String)
EX_CERT_NO_NEW 非該当証明書番号 - 法令管理 (String)
EX_CERT_DT 非該当証明書発行日 (String)
MILIT_ID ID: 武器 (String)
INSP_INT 次回再検査までの間隔 (String)
CO_PRODUCT 区分: 連産品としても使用可能な品目 (String)
PLAN_STRGP 計画方針グループ (String)
SLOC_EXPRC 外部調達の初期保管場所 (String)
BULK_MAT 区分: バルク品目 (String)
CC_FIXED 循環棚卸区分固定 (String)
DETERM_GRP 在庫決定グループ (String)
QM_AUTHGRP QM における活動の品目権限グループ (String)
TASK_LIST_TYPE タスクリストタイプ (String)
PUR_STATUS プラント特有品目ステータス (String)
PRODPROF 製造計画プロファイル (String)
SAFTY_T_ID 安全時間区分 （安全リードタイムあり/なし) (String)
SAFETYTIME 安全時間 (稼動日数) (String)
PLORD_CTRL アクション管理: 計画手配処理 (String)
BATCHENTRY 製造/プロセス指図でのロット入力設定 (String)
PVALIDFROM プラント品目ステータス有効期間開始日 (String)
MATFRGTGRP 品目運賃グループ (String)
PRODVERSCS 原価計算を行う製造バージョン (String)
MAT_CFOP 品目 CFOP カテゴリ (String)
EU_LIST_NO CAP: CAP 製品一覧番号 (String)
EU_MAT_GRP EEC 農産物政策: CAP 生産品グループ - 貿易 (String)
CAS_NO CAS 番号： 薬事品目 - 貿易 (String)
PRODCOM_NO 生産統計: 貿易における PRODCOM コード (String)
CTRL_CODE 貿易: 消費税の管理コード (String)
JIT_RELVT 区分: JIT 納入日程の関連明細 (String)
MAT_GRP_TRANS 段取替えマトリクスに対する 品目のグループ (String)
HANDLG_GRP ワークロード計算の ロジスティクス処理グループ (String)
SUPPLY_AREA 品目マスタレコードで 提案される供給場所 (String)
FAIR_SHARE_RULE 均等配賦ルール (String)
PUSH_DISTRIB 区分: プッシュ配賦 (String)
DEPLOY_HORIZ 供給分配期間の日数 (String)
MIN_LOT_SIZE 需要と供給を一致させるための 最小ロットサイズ (String)
MAX_LOT_SIZE 需要と供給を一致させるための 最大ロットサイズ (String)
FIX_LOT_SIZE 需要供給の一致に対する 固定ロットサイズ (String)
LOT_INCREMENT 需要と供給を一致させるための ロットサイズ増分 (String)
PROD_CONV_TYPE 生産値の変換タイプ (String)
DISTR_PROF サイトの商品の物流プロファイル (String)
PERIOD_PROFILE_SAFETY_TIME 安全時間の 期間プロファイル (String)
FXD_PRICE 固定価格連産品 (String)
AVAIL_CHECK_ALL_PROJ_SEGMENTS プロジェクト間品目区分 (String)
OVERALLPRF 指図変更管理の全体プロファイル (String)
MRP_RELEVANCY_DEP_REQUIREMENTS 従属所要量と MRP の関連性 (String)
MIN_SAFETY_STK 最小安全在庫 (String)
NO_COSTING 原価計算なし (String)
UNIT_GROUP 数量単位グループ (String)
FOLLOW_UP_EXTERNAL 項目 FOLLOW_UP の 品目コード (長) (今後のリリースで開発) (String)
FOLLOW_UP_GUID 項目 FOLLOW_UP の 外部 GUID (今後のリリースで開発) (String)
FOLLOW_UP_VERSION 項目 FOLLOW_UP の バージョン番号 (今後のリリースで開発) (String)
REFMATCONS_EXTERNAL 項目 REFMATCONS の 品目コード (長) (今後のリリースで開発) (String)
REFMATCONS_GUID 項目 REFMATCONS の 外部 GUID (今後のリリースで開発) (String)
REFMATCONS_VERSION 項目 REFMATCONS の バージョン番号 (今後のリリースで開発) (String)
SALES_VIEW 販売ビュー (String)
PURCH_VIEW 購買管理ビュー (String)
MRP_VIEW 資材所要量計画 (MRP) ビュー (String)
FORECAST_VIEW 需要予測ビュー (String)
WORK_SCHED_VIEW 作業計画ビュー (String)
PRT_VIEW 生産資源/治工具 (PRT) ビュー (String)
STORAGE_VIEW 保管ビュー (String)
WAREHOUSE_VIEW 倉庫管理ビュー (String)
QUALITY_VIEW 品質管理ビュー (String)
ACCOUNT_VIEW 会計ビュー (String)
COST_VIEW 原価計算ビュー (String)
ROTATION_DATE 原価計算ビュー (String)
ORIGINAL_BATCH_FLAG 元ロット管理区分 (String)
ORIGINAL_BATCH_REF_MATERIAL 元ロットの 参照品目 (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード(長) (String)
MATERIAL_GUID 項目 MATERIAL の外部GUID (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (String)
ORIGINAL_BATCH_REF_MATERIAL_E オリジナルロット 参照品目 (String)
ORIGINAL_BATCH_REF_MATERIAL_G オリジナルロット 参照品目 (String)
ORIGINAL_BATCH_REF_MATERIAL_V オリジナルロット 参照品目 (String)

取得した品目データ (プラントレベル)情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の品目データ (プラントレベル)の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の品目データ (プラントレベル)の「品目コード」
[idx]["PLANT"]　→　配列内のidx番目の品目データ (プラントレベル)の「プラント」
[idx]["DEL_FLAG"]　→　配列内のidx番目の品目データ (プラントレベル)の「プラントレベルでの品目削除フラグ」
[idx]["ABC_ID"]　→　配列内のidx番目の品目データ (プラントレベル)の「ABC 区分」
[idx]["CRIT_PART"]　→　配列内のidx番目の品目データ (プラントレベル)の「区分: 重要品目」
[idx]["PUR_GROUP"]　→　配列内のidx番目の品目データ (プラントレベル)の「購買グループ」
[idx]["ISSUE_UNIT"]　→　配列内のidx番目の品目データ (プラントレベル)の「出庫単位」
[idx]["ISSUE_UNIT_ISO"]　→　配列内のidx番目の品目データ (プラントレベル)の「ISO コードでの出庫単位」
[idx]["MRPPROFILE"]　→　配列内のidx番目の品目データ (プラントレベル)の「品目: MRP プロファイル」
[idx]["MRP_TYPE"]　→　配列内のidx番目の品目データ (プラントレベル)の「MRP タイプ」
[idx]["MRP_CTRLER"]　→　配列内のidx番目の品目データ (プラントレベル)の「MRP 管理者」
[idx]["PLND_DELRY"]　→　配列内のidx番目の品目データ (プラントレベル)の「予定納入時間 (単位: 日)」
[idx]["GR_PR_TIME"]　→　配列内のidx番目の品目データ (プラントレベル)の「入庫処理日数」
[idx]["PERIOD_IND"]　→　配列内のidx番目の品目データ (プラントレベル)の「期間区分」
[idx]["ASSY_SCRAP"]　→　配列内のidx番目の品目データ (プラントレベル)の「組立不良率」
[idx]["LOTSIZEKEY"]　→　配列内のidx番目の品目データ (プラントレベル)の「ロットサイズ (品目計画)」
[idx]["PROC_TYPE"]　→　配列内のidx番目の品目データ (プラントレベル)の「調達タイプ」
[idx]["SPPROCTYPE"]　→　配列内のidx番目の品目データ (プラントレベル)の「特殊調達タイプ」
[idx]["REORDER_PT"]　→　配列内のidx番目の品目データ (プラントレベル)の「発注点」
[idx]["SAFETY_STK"]　→　配列内のidx番目の品目データ (プラントレベル)の「安全在庫」
[idx]["MINLOTSIZE"]　→　配列内のidx番目の品目データ (プラントレベル)の「最小ロットサイズ」
[idx]["MAXLOTSIZE"]　→　配列内のidx番目の品目データ (プラントレベル)の「最大ロットサイズ」
[idx]["FIXED_LOT"]　→　配列内のidx番目の品目データ (プラントレベル)の「固定ロットサイズ」
[idx]["ROUND_VAL"]　→　配列内のidx番目の品目データ (プラントレベル)の「購買発注数量の丸め数量」
[idx]["MAX_STOCK"]　→　配列内のidx番目の品目データ (プラントレベル)の「最大在庫レベル」
[idx]["ORD_COSTS"]　→　配列内のidx番目の品目データ (プラントレベル)の「発注原価 (BAPI インタフェース)」
[idx]["DEP_REQ_ID"]　→　配列内のidx番目の品目データ (プラントレベル)の「個別所要量と包括所要量に対する従属所要量区分」
[idx]["STOR_COSTS"]　→　配列内のidx番目の品目データ (プラントレベル)の「保管経費区分」
[idx]["ALT_BOM_ID"]　→　配列内のidx番目の品目データ (プラントレベル)の「代替 BOM 選択の方法」
[idx]["DISCONTINU"]　→　配列内のidx番目の品目データ (プラントレベル)の「打切区分」
[idx]["EFF_O_DAY"]　→　配列内のidx番目の品目データ (プラントレベル)の「有効終了日」
[idx]["FOLLOW_UP"]　→　配列内のidx番目の品目データ (プラントレベル)の「フォローアップ品目」
[idx]["GRP_REQMTS"]　→　配列内のidx番目の品目データ (プラントレベル)の「区分: 所要量グループ化」
[idx]["MIXED_MRP"]　→　配列内のidx番目の品目データ (プラントレベル)の「二重 MRP 区分」
[idx]["SM_KEY"]　→　配列内のidx番目の品目データ (プラントレベル)の「日程計画余裕キー」
[idx]["BACKFLUSH"]　→　配列内のidx番目の品目データ (プラントレベル)の「区分: バックフラッシュ」
[idx]["PRODUCTION_SCHEDULER"]　→　配列内のidx番目の品目データ (プラントレベル)の「製造計画担当」
[idx]["PROC_TIME"]　→　配列内のidx番目の品目データ (プラントレベル)の「処理時間」
[idx]["SETUPTIME"]　→　配列内のidx番目の品目データ (プラントレベル)の「段取時間と片付け時間」
[idx]["INTEROP"]　→　配列内のidx番目の品目データ (プラントレベル)の「移動時間」
[idx]["BASE_QTY"]　→　配列内のidx番目の品目データ (プラントレベル)の「基本数量」
[idx]["INHSEPRODT"]　→　配列内のidx番目の品目データ (プラントレベル)の「内製日数」
[idx]["STGEPERIOD"]　→　配列内のidx番目の品目データ (プラントレベル)の「最長保管期間」
[idx]["STGE_PD_UN"]　→　配列内のidx番目の品目データ (プラントレベル)の「最長保管期間の単位」
[idx]["STGE_PD_UN_ISO"]　→　配列内のidx番目の品目データ (プラントレベル)の「ISO コードでの最長保管期間単位」
[idx]["OVER_TOL"]　→　配列内のidx番目の品目データ (プラントレベル)の「過剰納入許容範囲リミット」
[idx]["UNLIMITED"]　→　配列内のidx番目の品目データ (プラントレベル)の「区分: 無制限過剰納入可能」
[idx]["UNDER_TOL"]　→　配列内のidx番目の品目データ (プラントレベル)の「不足納入許容範囲リミット」
[idx]["REPLENTIME"]　→　配列内のidx番目の品目データ (プラントレベル)の「補充リードタイム合計 (稼動日数)」
[idx]["REPLACE_PT"]　→　配列内のidx番目の品目データ (プラントレベル)の「取替部品」
[idx]["IND_POST_TO_INSP_STOCK"]　→　配列内のidx番目の品目データ (プラントレベル)の「品質検査中在庫への転記」
[idx]["CTRL_KEY"]　→　配列内のidx番目の品目データ (プラントレベル)の「調達における品質管理の管理キー」
[idx]["DOC_REQD"]　→　配列内のidx番目の品目データ (プラントレベル)の「文書必須フラグ」
[idx]["LOADINGGRP"]　→　配列内のidx番目の品目データ (プラントレベル)の「積載グループ」
[idx]["BATCH_MGMT"]　→　配列内のidx番目の品目データ (プラントレベル)の「ロット管理所要量区分」
[idx]["QUOTAUSAGE"]　→　配列内のidx番目の品目データ (プラントレベル)の「供給量割当の使用」
[idx]["SERV_LEVEL"]　→　配列内のidx番目の品目データ (プラントレベル)の「サービスレベル」
[idx]["SPLIT_IND"]　→　配列内のidx番目の品目データ (プラントレベル)の「分割区分」
[idx]["AVAILCHECK"]　→　配列内のidx番目の品目データ (プラントレベル)の「利用可能在庫確認の確認グループ」
[idx]["FY_VARIANT"]　→　配列内のidx番目の品目データ (プラントレベル)の「会計年度バリアント」
[idx]["CORR_FACT"]　→　配列内のidx番目の品目データ (プラントレベル)の「区分: 修正係数を需要予測値計算に使用」
[idx]["SETUP_TIME"]　→　配列内のidx番目の品目データ (プラントレベル)の「出荷準備時間」
[idx]["BASE_QTY_PLAN"]　→　配列内のidx番目の品目データ (プラントレベル)の「出荷の能力計画のための基本数量」
[idx]["SHIP_PROC_TIME"]　→　配列内のidx番目の品目データ (プラントレベル)の「出荷処理時間」
[idx]["SUP_SOURCE"]　→　配列内のidx番目の品目データ (プラントレベル)の「供給元」
[idx]["AUTO_P_ORD"]　→　配列内のidx番目の品目データ (プラントレベル)の「区分: "購買発注自動生成"」
[idx]["SOURCELIST"]　→　配列内のidx番目の品目データ (プラントレベル)の「区分: 供給元一覧必須」
[idx]["COMM_CODE"]　→　配列内のidx番目の品目データ (プラントレベル)の「貿易: 統計品目コード/輸入コード番号」
[idx]["COUNTRYORI"]　→　配列内のidx番目の品目データ (プラントレベル)の「品目の原産国」
[idx]["COUNTRYORI_ISO"]　→　配列内のidx番目の品目データ (プラントレベル)の「ISO コードでの品目原産国」
[idx]["REGIONORIG"]　→　配列内のidx番目の品目データ (プラントレベル)の「品目の原産地 (非特恵対象地区の原産)」
[idx]["COMM_CO_UN"]　→　配列内のidx番目の品目データ (プラントレベル)の「物品コード (貿易) の数量単位」
[idx]["COMM_CO_UN_ISO"]　→　配列内のidx番目の品目データ (プラントレベル)の「ISO コードによる物品コード (貿易管理) の数量単位」
[idx]["EXPIMPGRP"]　→　配列内のidx番目の品目データ (プラントレベル)の「輸出/輸入品目グループ」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の品目データ (プラントレベル)の「利益センタ」
[idx]["PPC_PL_CAL"]　→　配列内のidx番目の品目データ (プラントレベル)の「PPC 計画カレンダ」
[idx]["REP_MANUF"]　→　配列内のidx番目の品目データ (プラントレベル)の「区分: 繰返生産許可」
[idx]["PL_TI_FNCE"]　→　配列内のidx番目の品目データ (プラントレベル)の「計画タイムフェンス」
[idx]["CONSUMMODE"]　→　配列内のidx番目の品目データ (プラントレベル)の「消費モード」
[idx]["BWD_CONS"]　→　配列内のidx番目の品目データ (プラントレベル)の「消費期間: 後方」
[idx]["FWD_CONS"]　→　配列内のidx番目の品目データ (プラントレベル)の「消費期間: 前方」
[idx]["ALTERNATIVE_BOM"]　→　配列内のidx番目の品目データ (プラントレベル)の「代替 BOM」
[idx]["BOM_USAGE"]　→　配列内のidx番目の品目データ (プラントレベル)の「BOM 用途」
[idx]["PLANLISTGRP"]　→　配列内のidx番目の品目データ (プラントレベル)の「タスクリストグループのキー」
[idx]["PLANLISTCNT"]　→　配列内のidx番目の品目データ (プラントレベル)の「グループカウンタ」
[idx]["LOT_SIZE"]　→　配列内のidx番目の品目データ (プラントレベル)の「原価計算ロットサイズ」
[idx]["SPECPROCTY"]　→　配列内のidx番目の品目データ (プラントレベル)の「原価計算の特殊調達タイプ」
[idx]["PROD_UNIT"]　→　配列内のidx番目の品目データ (プラントレベル)の「製造単位」
[idx]["PROD_UNIT_ISO"]　→　配列内のidx番目の品目データ (プラントレベル)の「製造単位 (ISO コード)」
[idx]["ISS_ST_LOC"]　→　配列内のidx番目の品目データ (プラントレベル)の「出庫保管場所」
[idx]["MRP_GROUP"]　→　配列内のidx番目の品目データ (プラントレベル)の「MRP グループ」
[idx]["COMP_SCRAP"]　→　配列内のidx番目の品目データ (プラントレベル)の「構成品目不良率」
[idx]["CERT_TYPE"]　→　配列内のidx番目の品目データ (プラントレベル)の「証明書タイプ」
[idx]["CYCLE_TIME"]　→　配列内のidx番目の品目データ (プラントレベル)の「タクトタイム」
[idx]["COVPROFILE"]　→　配列内のidx番目の品目データ (プラントレベル)の「在庫日数プロファイル」
[idx]["CC_PH_INV"]　→　配列内のidx番目の品目データ (プラントレベル)の「循環棚卸の実地棚卸区分」
[idx]["VARIANCE_KEY"]　→　配列内のidx番目の品目データ (プラントレベル)の「差異キー」
[idx]["SERNO_PROF"]　→　配列内のidx番目の品目データ (プラントレベル)の「シリアル番号プロファイル」
[idx]["REPMANPROF"]　→　配列内のidx番目の品目データ (プラントレベル)の「繰返生産プロファイル」
[idx]["NEG_STOCKS"]　→　配列内のidx番目の品目データ (プラントレベル)の「プラントにおけるマイナス在庫許可」
[idx]["QM_RGMTS"]　→　配列内のidx番目の品目データ (プラントレベル)の「仕入先の必須 QM システム」
[idx]["PLNG_CYCLE"]　→　配列内のidx番目の品目データ (プラントレベル)の「計画サイクル」
[idx]["ROUND_PROF"]　→　配列内のidx番目の品目データ (プラントレベル)の「丸めプロファイル」
[idx]["REFMATCONS"]　→　配列内のidx番目の品目データ (プラントレベル)の「消費参照品目」
[idx]["D_TO_REF_M"]　→　配列内のidx番目の品目データ (プラントレベル)の「消費データ参照の有効終了日」
[idx]["MULT_REF_M"]　→　配列内のidx番目の品目データ (プラントレベル)の「消費データ参照品目の乗数」
[idx]["AUTO_RESET"]　→　配列内のidx番目の品目データ (プラントレベル)の「予測モデル自動リセット」
[idx]["EX_CERT_ID"]　→　配列内のidx番目の品目データ (プラントレベル)の「法令管理: 認定書区分」
[idx]["EX_CERT_NO_NEW"]　→　配列内のidx番目の品目データ (プラントレベル)の「非該当証明書番号 - 法令管理」
[idx]["EX_CERT_DT"]　→　配列内のidx番目の品目データ (プラントレベル)の「非該当証明書発行日」
[idx]["MILIT_ID"]　→　配列内のidx番目の品目データ (プラントレベル)の「ID: 武器」
[idx]["INSP_INT"]　→　配列内のidx番目の品目データ (プラントレベル)の「次回再検査までの間隔」
[idx]["CO_PRODUCT"]　→　配列内のidx番目の品目データ (プラントレベル)の「区分: 連産品としても使用可能な品目」
[idx]["PLAN_STRGP"]　→　配列内のidx番目の品目データ (プラントレベル)の「計画方針グループ」
[idx]["SLOC_EXPRC"]　→　配列内のidx番目の品目データ (プラントレベル)の「外部調達の初期保管場所」
[idx]["BULK_MAT"]　→　配列内のidx番目の品目データ (プラントレベル)の「区分: バルク品目」
[idx]["CC_FIXED"]　→　配列内のidx番目の品目データ (プラントレベル)の「循環棚卸区分固定」
[idx]["DETERM_GRP"]　→　配列内のidx番目の品目データ (プラントレベル)の「在庫決定グループ」
[idx]["QM_AUTHGRP"]　→　配列内のidx番目の品目データ (プラントレベル)の「QM における活動の品目権限グループ」
[idx]["TASK_LIST_TYPE"]　→　配列内のidx番目の品目データ (プラントレベル)の「タスクリストタイプ」
[idx]["PUR_STATUS"]　→　配列内のidx番目の品目データ (プラントレベル)の「プラント特有品目ステータス」
[idx]["PRODPROF"]　→　配列内のidx番目の品目データ (プラントレベル)の「製造計画プロファイル」
[idx]["SAFTY_T_ID"]　→　配列内のidx番目の品目データ (プラントレベル)の「安全時間区分（安全リードタイムあり/なし)」
[idx]["SAFETYTIME"]　→　配列内のidx番目の品目データ (プラントレベル)の「安全時間 (稼動日数)」
[idx]["PLORD_CTRL"]　→　配列内のidx番目の品目データ (プラントレベル)の「アクション管理: 計画手配処理」
[idx]["BATCHENTRY"]　→　配列内のidx番目の品目データ (プラントレベル)の「製造/プロセス指図でのロット入力設定」
[idx]["PVALIDFROM"]　→　配列内のidx番目の品目データ (プラントレベル)の「プラント品目ステータス有効期間開始日」
[idx]["MATFRGTGRP"]　→　配列内のidx番目の品目データ (プラントレベル)の「品目運賃グループ」
[idx]["PRODVERSCS"]　→　配列内のidx番目の品目データ (プラントレベル)の「原価計算を行う製造バージョン」
[idx]["MAT_CFOP"]　→　配列内のidx番目の品目データ (プラントレベル)の「品目 CFOP カテゴリ」
[idx]["EU_LIST_NO"]　→　配列内のidx番目の品目データ (プラントレベル)の「CAP: CAP 製品一覧番号」
[idx]["EU_MAT_GRP"]　→　配列内のidx番目の品目データ (プラントレベル)の「EEC 農産物政策: CAP 生産品グループ - 貿易」
[idx]["CAS_NO"]　→　配列内のidx番目の品目データ (プラントレベル)の「CAS 番号： 薬事品目 - 貿易」
[idx]["PRODCOM_NO"]　→　配列内のidx番目の品目データ (プラントレベル)の「生産統計: 貿易における PRODCOM コード」
[idx]["CTRL_CODE"]　→　配列内のidx番目の品目データ (プラントレベル)の「貿易: 消費税の管理コード」
[idx]["JIT_RELVT"]　→　配列内のidx番目の品目データ (プラントレベル)の「区分: JIT 納入日程の関連明細」
[idx]["MAT_GRP_TRANS"]　→　配列内のidx番目の品目データ (プラントレベル)の「段取替えマトリクスに対する品目のグループ」
[idx]["HANDLG_GRP"]　→　配列内のidx番目の品目データ (プラントレベル)の「ワークロード計算のロジスティクス処理グループ」
[idx]["SUPPLY_AREA"]　→　配列内のidx番目の品目データ (プラントレベル)の「品目マスタレコードで提案される供給場所」
[idx]["FAIR_SHARE_RULE"]　→　配列内のidx番目の品目データ (プラントレベル)の「均等配賦ルール」
[idx]["PUSH_DISTRIB"]　→　配列内のidx番目の品目データ (プラントレベル)の「区分: プッシュ配賦」
[idx]["DEPLOY_HORIZ"]　→　配列内のidx番目の品目データ (プラントレベル)の「供給分配期間の日数」
[idx]["MIN_LOT_SIZE"]　→　配列内のidx番目の品目データ (プラントレベル)の「需要と供給を一致させるための最小ロットサイズ」
[idx]["MAX_LOT_SIZE"]　→　配列内のidx番目の品目データ (プラントレベル)の「需要と供給を一致させるための最大ロットサイズ」
[idx]["FIX_LOT_SIZE"]　→　配列内のidx番目の品目データ (プラントレベル)の「需要供給の一致に対する固定ロットサイズ」
[idx]["LOT_INCREMENT"]　→　配列内のidx番目の品目データ (プラントレベル)の「需要と供給を一致させるためのロットサイズ増分」
[idx]["PROD_CONV_TYPE"]　→　配列内のidx番目の品目データ (プラントレベル)の「生産値の変換タイプ」
[idx]["DISTR_PROF"]　→　配列内のidx番目の品目データ (プラントレベル)の「サイトの商品の物流プロファイル」
[idx]["PERIOD_PROFILE_SAFETY_TIME"]　→　配列内のidx番目の品目データ (プラントレベル)の「安全時間の期間プロファイル」
[idx]["FXD_PRICE"]　→　配列内のidx番目の品目データ (プラントレベル)の「固定価格連産品」
[idx]["AVAIL_CHECK_ALL_PROJ_SEGMENTS"]　→　配列内のidx番目の品目データ (プラントレベル)の「プロジェクト間品目区分」
[idx]["OVERALLPRF"]　→　配列内のidx番目の品目データ (プラントレベル)の「指図変更管理の全体プロファイル」
[idx]["MRP_RELEVANCY_DEP_REQUIREMENTS"]　→　配列内のidx番目の品目データ (プラントレベル)の「従属所要量と MRP の関連性」
[idx]["MIN_SAFETY_STK"]　→　配列内のidx番目の品目データ (プラントレベル)の「最小安全在庫」
[idx]["NO_COSTING"]　→　配列内のidx番目の品目データ (プラントレベル)の「原価計算なし」
[idx]["UNIT_GROUP"]　→　配列内のidx番目の品目データ (プラントレベル)の「数量単位グループ」
[idx]["FOLLOW_UP_EXTERNAL"]　→　配列内のidx番目の品目データ (プラントレベル)の「項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)」
[idx]["FOLLOW_UP_GUID"]　→　配列内のidx番目の品目データ (プラントレベル)の「項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)」
[idx]["FOLLOW_UP_VERSION"]　→　配列内のidx番目の品目データ (プラントレベル)の「項目 FOLLOW_UP のバージョン番号 (今後のリリースで開発)」
[idx]["REFMATCONS_EXTERNAL"]　→　配列内のidx番目の品目データ (プラントレベル)の「項目 REFMATCONS の品目コード (長) (今後のリリースで開発)」
[idx]["REFMATCONS_GUID"]　→　配列内のidx番目の品目データ (プラントレベル)の「項目 REFMATCONS の外部 GUID (今後のリリースで開発)」
[idx]["REFMATCONS_VERSION"]　→　配列内のidx番目の品目データ (プラントレベル)の「項目 REFMATCONS のバージョン番号 (今後のリリースで開発)」
[idx]["SALES_VIEW"]　→　配列内のidx番目の品目データ (プラントレベル)の「販売ビュー」
[idx]["PURCH_VIEW"]　→　配列内のidx番目の品目データ (プラントレベル)の「購買管理ビュー」
[idx]["MRP_VIEW"]　→　配列内のidx番目の品目データ (プラントレベル)の「資材所要量計画 (MRP) ビュー」
[idx]["FORECAST_VIEW"]　→　配列内のidx番目の品目データ (プラントレベル)の「需要予測ビュー」
[idx]["WORK_SCHED_VIEW"]　→　配列内のidx番目の品目データ (プラントレベル)の「作業計画ビュー」
[idx]["PRT_VIEW"]　→　配列内のidx番目の品目データ (プラントレベル)の「生産資源/治工具 (PRT) ビュー」
[idx]["STORAGE_VIEW"]　→　配列内のidx番目の品目データ (プラントレベル)の「保管ビュー」
[idx]["WAREHOUSE_VIEW"]　→　配列内のidx番目の品目データ (プラントレベル)の「倉庫管理ビュー」
[idx]["QUALITY_VIEW"]　→　配列内のidx番目の品目データ (プラントレベル)の「品質管理ビュー」
[idx]["ACCOUNT_VIEW"]　→　配列内のidx番目の品目データ (プラントレベル)の「会計ビュー」
[idx]["COST_VIEW"]　→　配列内のidx番目の品目データ (プラントレベル)の「原価計算ビュー」
[idx]["ROTATION_DATE"]　→　配列内のidx番目の品目データ (プラントレベル)の「原価計算ビュー」
[idx]["ORIGINAL_BATCH_FLAG"]　→　配列内のidx番目の品目データ (プラントレベル)の「元ロット管理区分」
[idx]["ORIGINAL_BATCH_REF_MATERIAL"]　→　配列内のidx番目の品目データ (プラントレベル)の「元ロットの参照品目」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の品目コード(長)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の外部GUID」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL のバージョン番号」
[idx]["ORIGINAL_BATCH_REF_MATERIAL_E"]　→　配列内のidx番目の品目データ (プラントレベル)の「オリジナルロット参照品目」
[idx]["ORIGINAL_BATCH_REF_MATERIAL_V"]　→　配列内のidx番目の品目データ (プラントレベル)の「オリジナルロット参照品目」
[idx]["ORIGINAL_BATCH_REF_MATERIAL_G"]　→　配列内のidx番目の品目データ (プラントレベル)の「オリジナルロット参照品目」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPrtDataList

Array getPrtDataList ()

品目マスタの生産資源/治工具 (PRT) 項目を取得します。
返却値
Array 品目マスタの生産資源/治工具 (PRT) 項目

品目マスタの生産資源/治工具 (PRT) 項目情報オブジェクトの構成は以下のとおりです。
品目マスタの生産資源/治工具 (PRT) 項目
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
PLANT プラント (String)
CREATE_LOAD_RECS 区分: 生産資源/治工具の 負荷レコード登録 (String)
CTRL_KEY 生産資源/治工具管理の管理キー (String)
CTRL_KEY_NO_CHG 管理キーは変更できません (String)
GRP_KEY_1 生産資源/治工具のグループキー 1 (String)
GRP_KEY_2 生産資源/治工具のグループキー 2 (String)
PRT_USAGE 生産資源/治工具用途 (String)
STD_TEXT_KEY 生産資源/治工具の 標準テキストキー (String)
REF_KEY_NO_CHG 参照キーは変更できません (String)
START_REF_DATE 生産資源/治工具使用開始の 参照日付 (String)
ST_REF_DATE_NO_CHG 開始参照日付は 変更できません (String)
START_OFFSET 生産資源/治工具使用の 開始オフセット (String)
START_OFFSET_UNIT 生産資源/治工具使用開始の オフセット単位 (String)
START_OFFSET_UNIT_ISO PRT 用途開始決定の 間隔時間単位 (ISO) (String)
START_OFFSET_NO_CHG 開始オフセットは 変更できません (String)
END_REF_DATE 生産資源/治工具使用終了日の 参照日付 (String)
END_REF_DATE_NO_CHG 終了参照日付は 変更できません (String)
END_OFFSET 生産資源/治工具用途の終了オフセット (String)
END_OFFSET_UNIT 生産資源/治工具使用終了 オフセット単位 (String)
END_OFFSET_UNIT_ISO PRT 用途終了決定の 間隔時間単位 (ISO) (String)
END_OFFSET_NO_CHG 終了オフセットは 変更できません (String)
FORMULA_TOT_QTY 生産資源/治工具の合計数量の 計算式 (String)
FORMULA_TOT_QTY_NO_CHG 合計数量の計算式は 変更できません (String)
FORMULA_TOT_USAGE 生産資源/治工具の総用途値 の計算式 (String)
FORMULA_TOT_USAGE_NO_CHG すべての用途値を 計算する計算式は変更できません (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード(長) (String)
MATERIAL_GUID 項目 MATERIAL の外部GUID (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (String)

取得した品目マスタの生産資源/治工具 (PRT) 項目情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「品目コード」
[idx]["PLANT"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「プラント」
[idx]["CREATE_LOAD_RECS"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「区分: 生産資源/治工具の負荷レコード登録」
[idx]["CTRL_KEY"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具管理の管理キー」
[idx]["CTRL_KEY_NO_CHG"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「管理キーは変更できません」
[idx]["GRP_KEY_1"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具のグループキー 1」
[idx]["GRP_KEY_2"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具のグループキー 2」
[idx]["PRT_USAGE"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具用途」
[idx]["STD_TEXT_KEY"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具の標準テキストキー」
[idx]["REF_KEY_NO_CHG"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「参照キーは変更できません」
[idx]["START_REF_DATE"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具使用開始の参照日付」
[idx]["ST_REF_DATE_NO_CHG"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「開始参照日付は変更できません」
[idx]["START_OFFSET"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具使用の開始オフセット」
[idx]["START_OFFSET_UNIT"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具使用開始のオフセット単位」
[idx]["START_OFFSET_UNIT_ISO"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「PRT 用途開始決定の間隔時間単位 (ISO)」
[idx]["START_OFFSET_NO_CHG"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「開始オフセットは変更できません」
[idx]["END_REF_DATE"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具使用終了日の参照日付」
[idx]["END_REF_DATE_NO_CHG"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「終了参照日付は変更できません」
[idx]["END_OFFSET"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具用途の終了オフセット」
[idx]["END_OFFSET_UNIT"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具使用終了オフセット単位」
[idx]["END_OFFSET_UNIT_ISO"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「PRT 用途終了決定の間隔時間単位 (ISO)」
[idx]["END_OFFSET_NO_CHG"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「終了オフセットは変更できません」
[idx]["FORMULA_TOT_QTY"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具の合計数量の計算式」
[idx]["FORMULA_TOT_QTY_NO_CHG"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「合計数量の計算式は変更できません」
[idx]["FORMULA_TOT_USAGE"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具の総用途値の計算式」
[idx]["FORMULA_TOT_USAGE_NO_CHG"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「すべての用途値を計算する計算式は変更できません」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の品目コード(長)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の外部GUID」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL のバージョン番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getReturnMessagesList

Array getReturnMessagesList ()

リターンパラメータ BAPIRET2 の代替構造のデータ転送を取得します。
返却値
Array リターンパラメータ BAPIRET2 の代替構造

リターンパラメータ BAPIRET2 の代替構造情報オブジェクトの構成は以下のとおりです。
リターンパラメータ BAPIRET2 の代替構造情報
オブジェクト
(Object)
TYPE メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了 (String)
ID メッセージ、メッセージクラス (String)
NUMBER メッセージ、メッセージ番号 (String)
MESSAGE メッセージテキスト (String)
LOG_NO アプリケーションログ: ログ番号 (String)
LOG_MSG_NO アプリケーションログ: メッセージシリアル番号 (String)
MESSAGE_V1 メッセージ、メッセージ変数 (String)
MESSAGE_V2 メッセージ、メッセージ変数 (String)
MESSAGE_V3 メッセージ、メッセージ変数 (String)
MESSAGE_V4 メッセージ、メッセージ変数 (String)
PARAMETER パラメータ名 (String)
ROW パラメータの行 (String)
FIELD パラメータの項目 (String)
SYSTEM メッセージが発行された論理システム (String)

取得したリターンパラメータ BAPIRET2 の代替構造情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["TYPE"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了」
[idx]["ID"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「メッセージ、メッセージクラス」
[idx]["NUMBER"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「メッセージ、メッセージ番号」
[idx]["MESSAGE"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「メッセージテキスト」
[idx]["LOG_NO"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「アプリケーションログ: ログ番号」
[idx]["LOG_MSG_NO"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「アプリケーションログ: メッセージシリアル番号」
[idx]["MESSAGE_V1"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「メッセージ、メッセージ変数」
[idx]["MESSAGE_V2"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「メッセージ、メッセージ変数」
[idx]["MESSAGE_V3"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「メッセージ、メッセージ変数」
[idx]["MESSAGE_V4"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「メッセージ、メッセージ変数」
[idx]["PARAMETER"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「パラメータ名」
[idx]["ROW"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「パラメータの行」
[idx]["FIELD"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「パラメータの項目」
[idx]["SYSTEM"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「メッセージが発行された論理システム」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getSalesDataList

Array getSalesDataList ()

販売データを取得します。
返却値
Array 販売データ

販売データ情報オブジェクトの構成は以下のとおりです。
販売データ情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
SALES_ORG 販売組織 (String)
DISTR_CHAN 流通チャネル (String)
DEL_FLAG 区分: 流通チャネルレベルでの 品目削除フラグ (String)
MATL_STATS 品目統計グループ (String)
REBATE_GRP 取引量リベートグループ (String)
COMM_GROUP 手数料グループ (String)
CASH_DISC 現金値引区分 (String)
SAL_STATUS 販売ビューからの品目ステータス (String)
VALID_FROM 流通チェーン別品目ステータスの 有効期間開始日 (String)
MIN_ORDER 基本数量単位での最小受注数量 (String)
MIN_DELY 納品書処理時の最小納入数量 (String)
MIN_MTO 受注製造品最少受注数量 (String)
DELY_UNIT 出荷単位 (String)
DELY_UOM 出荷数量単位 (String)
DELY_UOM_ISO ISO コードでの出荷単位の 数量単位 (String)
SALES_UNIT 販売単位 (String)
SALES_UNIT_ISO ISO コードによる販売単位 (String)
ITEM_CAT 品目マスタの明細カテゴリグループ (String)
DELYG_PLNT 出荷プラント (String)
PROD_HIER 品目階層 (String)
PR_REF_MAT 価格設定参照品目 (String)
MAT_PR_GRP 品目価格設定グループ (String)
ACCT_ASSGT 品目の勘定設定グループ (String)
MATL_GRP_1 品目グループ 1 (String)
MATL_GRP_2 品目グループ 2 (String)
MATL_GRP_3 品目グループ 3 (String)
MATL_GRP_4 品目グループ 4 (String)
MATL_GRP_5 品目グループ 5 (String)
PROD_ATT_1 ID: 製品属性 1 (String)
PROD_ATT_2 品目属性 2 用 ID (String)
PROD_ATT_3 品目属性 3 用 ID (String)
PROD_ATT_4 品目属性 4 用 ID (String)
PROD_ATT_5 品目属性 5 用 ID (String)
PROD_ATT_6 品目属性 6 の ID (String)
PROD_ATT_7 品目属性 7 用 ID (String)
PROD_ATT_8 品目属性 8 用 ID (String)
PROD_ATT_9 品目属性 9 (String)
PROD_ATT10 品目属性 10 用 ID (String)
ROUND_PROF 丸めプロファイル (String)
VAR_SALES_UN 可変販売単位の使用不可 (String)
UNIT_GROUP 数量単位グループ (String)
PR_REF_MAT_EXTERNAL 項目 PR_REF_MAT の 品目コード (長) (今後のリリースで開発) (String)
PR_REF_MAT_GUID 項目 PR_REF_MAT の 外部 GUID (今後のリリースで開発) (String)
PR_REF_MAT_VERSION 項目 PR_REF_MAT の バージョン番号 (今後のリリースで開発) (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード(長) (String)
MATERIAL_GUID 項目 MATERIAL の外部GUID (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (String)

取得した販売データ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の販売データの「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の販売データの「品目コード」
[idx]["SALES_ORG"]　→　配列内のidx番目の販売データの「販売組織」
[idx]["DISTR_CHAN"]　→　配列内のidx番目の販売データの「流通チャネル」
[idx]["DEL_FLAG"]　→　配列内のidx番目の販売データの 「区分: 流通チャネルレベルでの品目削除フラグ」
[idx]["MATL_STATS"]　→　配列内のidx番目の販売データの「品目統計グループ」
[idx]["REBATE_GRP"]　→　配列内のidx番目の販売データの「取引量リベートグループ」
[idx]["COMM_GROUP"]　→　配列内のidx番目の販売データの「手数料グループ」
[idx]["CASH_DISC"]　→　配列内のidx番目の販売データの「現金値引区分」
[idx]["SAL_STATUS"]　→　配列内のidx番目の販売データの「販売ビューからの品目ステータス」
[idx]["VALID_FROM"]　→　配列内のidx番目の販売データの 「流通チェーン別品目ステータスの有効期間開始日」
[idx]["MIN_ORDER"]　→　配列内のidx番目の販売データの「基本数量単位での最小受注数量」
[idx]["MIN_DELY"]　→　配列内のidx番目の販売データの「納品書処理時の最小納入数量」
[idx]["MIN_MTO"]　→　配列内のidx番目の販売データの「受注製造品最少受注数量」
[idx]["DELY_UNIT"]　→　配列内のidx番目の販売データの「出荷単位」
[idx]["DELY_UOM"]　→　配列内のidx番目の販売データの「出荷数量単位」
[idx]["DELY_UOM_ISO"]　→　配列内のidx番目の販売データの 「ISO コードでの出荷単位の数量単位」
[idx]["SALES_UNIT"]　→　配列内のidx番目の販売データの「販売単位」
[idx]["SALES_UNIT_ISO"]　→　配列内のidx番目の販売データの「ISO コードによる販売単位」
[idx]["ITEM_CAT"]　→　配列内のidx番目の販売データの「品目マスタの明細カテゴリグループ」
[idx]["DELYG_PLNT"]　→　配列内のidx番目の販売データの「出荷プラント」
[idx]["PROD_HIER"]　→　配列内のidx番目の販売データの「品目階層」
[idx]["PR_REF_MAT"]　→　配列内のidx番目の販売データの「価格設定参照品目」
[idx]["MAT_PR_GRP"]　→　配列内のidx番目の販売データの「品目価格設定グループ」
[idx]["ACCT_ASSGT"]　→　配列内のidx番目の販売データの「品目の勘定設定グループ」
[idx]["MATL_GRP_1"]　→　配列内のidx番目の販売データの「品目グループ 1」
[idx]["MATL_GRP_2"]　→　配列内のidx番目の販売データの「品目グループ 2」
[idx]["MATL_GRP_3"]　→　配列内のidx番目の販売データの「品目グループ 3」
[idx]["MATL_GRP_4"]　→　配列内のidx番目の販売データの「品目グループ 4」
[idx]["MATL_GRP_5"]　→　配列内のidx番目の販売データの「品目グループ 5」
[idx]["PROD_ATT_1"]　→　配列内のidx番目の販売データの「ID: 製品属性 1」
[idx]["PROD_ATT_2"]　→　配列内のidx番目の販売データの「品目属性 2 用 ID」
[idx]["PROD_ATT_3"]　→　配列内のidx番目の販売データの「品目属性 3 用 ID」
[idx]["PROD_ATT_4"]　→　配列内のidx番目の販売データの「品目属性 4 用 ID」
[idx]["PROD_ATT_5"]　→　配列内のidx番目の販売データの「品目属性 5 用 ID」
[idx]["PROD_ATT_6"]　→　配列内のidx番目の販売データの「品目属性 6 の ID」
[idx]["PROD_ATT_7"]　→　配列内のidx番目の販売データの「品目属性 7 用 ID」
[idx]["PROD_ATT_8"]　→　配列内のidx番目の販売データの「品目属性 8 用 ID」
[idx]["PROD_ATT_9"]　→　配列内のidx番目の販売データの「品目属性 9」
[idx]["PROD_ATT10"]　→　配列内のidx番目の販売データの「品目属性 10 用 ID」
[idx]["ROUND_PROF"]　→　配列内のidx番目の販売データの「丸めプロファイル」
[idx]["VAR_SALES_UN"]　→　配列内のidx番目の販売データの「可変販売単位の使用不可」
[idx]["UNIT_GROUP"]　→　配列内のidx番目の販売データの「数量単位グループ」
[idx]["PR_REF_MAT_EXTERNAL"]　→　配列内のidx番目の販売データの 「項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)」
[idx]["PR_REF_MAT_GUID"]　→　配列内のidx番目の販売データの 「項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)」
[idx]["PR_REF_MAT_VERSION"]　→　配列内のidx番目の販売データの 「項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の品目コード(長)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の外部GUID」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL のバージョン番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getStorageLocationDataList

Array getStorageLocationDataList ()

品目データ (保管場所レベル)を取得します。
返却値
Array 品目データ (保管場所レベル)

品目データ (保管場所レベル)情報オブジェクトの構成は以下のとおりです。
品目データ (保管場所レベル)
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
PLANT プラント (String)
STGE_LOC 保管場所 (String)
DEL_FLAG 保管場所レベルでの品目削除フラグ (String)
MRP_IND 保管場所 MRP 区分 (String)
SPEC_PROC 保管場所レベルでの特殊調達タイプ (String)
REORDER_PT 保管場所 MRP に対する発注点 (String)
REPL_QTY 保管場所 MRP に対する補充数量 (String)
STGE_BIN 棚番 (String)
PICKG_AREA 簡易倉庫管理のピッキングエリア (String)
INV_CORR_FAC 在庫修正係数 (String)
MRP_VIEW 資材所要量計画 (MRP) ビュー (String)
STORAGE_VIEW 保管ビュー (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード(長) (String)
MATERIAL_GUID 項目 MATERIAL の外部GUID (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (String)

取得した品目データ (保管場所レベル)情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の品目データ (保管場所レベル)の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の品目データ (保管場所レベル)の「品目コード」
[idx]["PLANT"]　→　配列内のidx番目の品目データ (保管場所レベル)の「プラント」
[idx]["STGE_LOC"]　→　配列内のidx番目の品目データ (保管場所レベル)の「保管場所」
[idx]["DEL_FLAG"]　→　配列内のidx番目の品目データ (保管場所レベル)の「保管場所レベルでの品目削除フラグ」
[idx]["MRP_IND"]　→　配列内のidx番目の品目データ (保管場所レベル)の「保管場所 MRP 区分」
[idx]["SPEC_PROC"]　→　配列内のidx番目の品目データ (保管場所レベル)の「保管場所レベルでの特殊調達タイプ」
[idx]["REORDER_PT"]　→　配列内のidx番目の品目データ (保管場所レベル)の「保管場所 MRP に対する発注点」
[idx]["REPL_QTY"]　→　配列内のidx番目の品目データ (保管場所レベル)の「保管場所 MRP に対する補充数量」
[idx]["STGE_BIN"]　→　配列内のidx番目の品目データ (保管場所レベル)の「棚番」
[idx]["PICKG_AREA"]　→　配列内のidx番目の品目データ (保管場所レベル)の「簡易倉庫管理のピッキングエリア」
[idx]["INV_CORR_FAC"]　→　配列内のidx番目の品目データ (保管場所レベル)の「在庫修正係数」
[idx]["MRP_VIEW"]　→　配列内のidx番目の品目データ (保管場所レベル)の「資材所要量計画 (MRP) ビュー」
[idx]["STORAGE_VIEW"]　→　配列内のidx番目の品目データ (保管場所レベル)の「保管ビュー」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の品目コード(長)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の外部GUID」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL のバージョン番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getStorageTypeDataList

Array getStorageTypeDataList ()

保管域タイプデータを取得します。
返却値
Array 保管域タイプデータ

保管域タイプデータ情報オブジェクトの構成は以下のとおりです。
保管域タイプデータ情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
WHSE_NO 倉庫番号/複合倉庫 (String)
STGE_TYPE 保管域タイプ (String)
DEL_FLAG 保管タイプに該当する全品目データ 削除フラグ (String)
STGE_BIN 棚番 (String)
MAX_SB_QTY 最大棚番在庫数量 (String)
MIN_SB_QTY 最小棚番在庫数量 (String)
CTRL_QTY 管理数量 (String)
REPLEN_QTY 補充数量 (String)
PICK_AREA ピッキングエリア (String)
ROUND_QTY 丸め数量 (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード(長) (String)
MATERIAL_GUID 項目 MATERIAL の外部GUID (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (String)

取得した保管域タイプデータ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の保管域タイプデータの「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の保管域タイプデータの「品目コード」
[idx]["WHSE_NO"]　→　配列内のidx番目の保管域タイプデータの「倉庫番号/複合倉庫」
[idx]["STGE_TYPE"]　→　配列内のidx番目の保管域タイプデータの「保管域タイプ」
[idx]["DEL_FLAG"]　→　配列内のidx番目の保管域タイプデータの 「保管タイプに該当する全品目データ削除フラグ」
[idx]["STGE_BIN"]　→　配列内のidx番目の保管域タイプデータの「棚番」
[idx]["MAX_SB_QTY"]　→　配列内のidx番目の保管域タイプデータの「最大棚番在庫数量」
[idx]["MIN_SB_QTY"]　→　配列内のidx番目の保管域タイプデータの「最小棚番在庫数量」
[idx]["CTRL_QTY"]　→　配列内のidx番目の保管域タイプデータの「管理数量」
[idx]["REPLEN_QTY"]　→　配列内のidx番目の保管域タイプデータの「補充数量」
[idx]["PICK_AREA"]　→　配列内のidx番目の保管域タイプデータの「ピッキングエリア」
[idx]["ROUND_QTY"]　→　配列内のidx番目の保管域タイプデータの「丸め数量」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の品目コード(長)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の外部GUID」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL のバージョン番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getTaxClassificationsList

Array getTaxClassificationsList ()

制御デ−タを取得します。
返却値
Array 制御デ−タ

制御デ−タ情報オブジェクトの構成は以下のとおりです。
制御デ−タ
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
DEPCOUNTRY 出荷国 (商品発送国) (String)
DEPCOUNTRY_ISO 出荷国の ISO コード (String)
TAX_TYPE_1 税カテゴリ (消費税等) (String)
TAXCLASS_1 品目の税分類 (String)
TAX_TYPE_2 税カテゴリ (消費税等) (String)
TAXCLASS_2 品目の税分類 (String)
TAX_TYPE_3 税カテゴリ (消費税等) (String)
TAXCLASS_3 品目の税分類 (String)
TAX_TYPE_4 税カテゴリ (消費税等) (String)
TAXCLASS_4 品目の税分類 (String)
TAX_TYPE_5 税カテゴリ (消費税等) (String)
TAXCLASS_5 品目の税分類 (String)
TAX_TYPE_6 税カテゴリ (消費税等) (String)
TAXCLASS_6 品目の税分類 (String)
TAX_TYPE_7 税カテゴリ (消費税等) (String)
TAXCLASS_7 品目の税分類 (String)
TAX_TYPE_8 税カテゴリ (消費税等) (String)
TAXCLASS_8 品目の税分類 (String)
TAX_TYPE_9 税カテゴリ (消費税等) (String)
TAXCLASS_9 品目の税分類 (String)
TAX_IND 税区分: 品目 (購買管理) (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード(長) (String)
MATERIAL_GUID 項目 MATERIAL の外部GUID (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (String)

取得した制御デ−タ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の制御デ−タの「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の制御デ−タの「品目コード」
[idx]["DEPCOUNTRY"]　→　配列内のidx番目の制御デ−タの「出荷国 (商品発送国)」
[idx]["DEPCOUNTRY_ISO"]　→　配列内のidx番目の制御デ−タの「出荷国の ISO コード」
[idx]["TAX_TYPE_1"]　→　配列内のidx番目の制御デ−タの「税カテゴリ (消費税等)」
[idx]["TAXCLASS_1"]　→　配列内のidx番目の制御デ−タの「品目の税分類」
[idx]["TAX_TYPE_2"]　→　配列内のidx番目の制御デ−タの「税カテゴリ (消費税等)」
[idx]["TAXCLASS_2"]　→　配列内のidx番目の制御デ−タの「品目の税分類」
[idx]["TAX_TYPE_3"]　→　配列内のidx番目の制御デ−タの「税カテゴリ (消費税等)」
[idx]["TAXCLASS_3"]　→　配列内のidx番目の制御デ−タの「品目の税分類」
[idx]["TAX_TYPE_4"]　→　配列内のidx番目の制御デ−タの「税カテゴリ (消費税等)」
[idx]["TAXCLASS_4"]　→　配列内のidx番目の制御デ−タの「品目の税分類」
[idx]["TAX_TYPE_5"]　→　配列内のidx番目の制御デ−タの「税カテゴリ (消費税等)」
[idx]["TAXCLASS_5"]　→　配列内のidx番目の制御デ−タの「品目の税分類」
[idx]["TAX_TYPE_6"]　→　配列内のidx番目の制御デ−タの「税カテゴリ (消費税等)」
[idx]["TAXCLASS_6"]　→　配列内のidx番目の制御デ−タの「品目の税分類」
[idx]["TAX_TYPE_7"]　→　配列内のidx番目の制御デ−タの「税カテゴリ (消費税等)」
[idx]["TAXCLASS_7"]　→　配列内のidx番目の制御デ−タの「品目の税分類」
[idx]["TAX_TYPE_8"]　→　配列内のidx番目の制御デ−タの「税カテゴリ (消費税等)」
[idx]["TAXCLASS_8"]　→　配列内のidx番目の制御デ−タの「品目の税分類」
[idx]["TAX_TYPE_9"]　→　配列内のidx番目の制御デ−タの「税カテゴリ (消費税等)」
[idx]["TAXCLASS_9"]　→　配列内のidx番目の制御デ−タの「品目の税分類」
[idx]["TAX_IND"]　→　配列内のidx番目の制御デ−タの「税区分: 品目 (購買管理)」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の品目コード(長)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の外部GUID」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL のバージョン番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getTestrun

Object getTestrun ()

書込 BAPI のシミュレーションセッションへの切替を取得します。
返却値
Object 書込 BAPI のシミュレーションセッションへの切替
getTotalConsumptionList

Array getTotalConsumptionList ()

品目総消費量のデータ転送を取得します。
返却値
Array 品目総消費量のデータ転送

品目総消費量のデータ転送情報オブジェクトの構成は以下のとおりです。
品目総消費量のデータ転送情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
PLANT プラント (String)
FIRST_DAY 値参照期間の第一日目 (String)
CONS_VALUE 消費量 (String)
CORR_VALUE 修正消費量 (String)
VAL_RATIO 元値に対する修正値の比率 (修正値: 元値) (String)
MATERIAL_EXTERNAL 項目 MATERIAL の 品目コード (長) (今後のリリースで開発) (String)
MATERIAL_GUID 項目 MATERIAL の外部 GUID (今後のリリースで開発) (String)
MATERIAL_VERSION 項目 MATERIAL の バージョン番号 (今後のリリースで開発) (String)

取得した品目総消費量のデータ転送情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の品目総消費量のデータ転送の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の品目総消費量のデータ転送の「品目コード」
[idx]["PLANT"]　→　配列内のidx番目の品目総消費量のデータ転送の「プラント」
[idx]["FIRST_DAY"]　→　配列内のidx番目の品目総消費量のデータ転送の「値参照期間の第一日目」
[idx]["CONS_VALUE"]　→　配列内のidx番目の品目総消費量のデータ転送の「消費量」
[idx]["CORR_VALUE"]　→　配列内のidx番目の品目総消費量のデータ転送の「修正消費量」
[idx]["VAL_RATIO"]　→　配列内のidx番目の品目総消費量の データ転送の「元値に対する修正値の比率 (修正値: 元値)」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の品目総消費量の データ転送の「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の品目総消費量の データ転送の「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の品目総消費量の データ転送の「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getUnitSofmeasureList

Array getUnitSofmeasureList ()

数量単位を取得します。
返却値
Array 数量単位

数量単位オブジェクトの構成は以下のとおりです。
数量単位
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
ALT_UNIT 在庫保管単位の代替数量単位 (String)
ALT_UNIT_ISO ISO コードによる在庫単位の 代替数量単位 (String)
NUMERATOR 基本数量単位への換算分子 (String)
DENOMINATR 分母: 基本数量単位へ変換する場合 (String)
EAN_UPC 国際商品コード (EAN/UPC) (String)
EAN_CAT 国際商品コード (EAN) のカテゴリ (String)
LENGTH 長さ (String)
WIDTH 幅 (String)
HEIGHT 高さ (String)
UNIT_DIM 寸法単位 (長さ/幅/高さ) (String)
UNIT_DIM_ISO ISO コードでの 長さ、幅、高さの単位 (String)
VOLUME 容積 (String)
VOLUMEUNIT 容積単位 (String)
VOLUMEUNIT_ISO ISO コードでの容積単位 (String)
GROSS_WT 総重量 (String)
UNIT_OF_WT 重量単位 (String)
UNIT_OF_WT_ISO ISO コードでの重量単位 (String)
DEL_FLAG データレコード削除 (テーブル繰返し) (String)
SUB_UOM 梱包階層の下位レベル数量単位 (String)
SUB_UOM_ISO 下位レベル数量単位 (ISO コード) (String)
GTIN_VARIANT グローバルトレード明細番号 バリアント (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード(長) (String)
MATERIAL_GUID 項目 MATERIAL の外部GUID (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (String)

取得した数量単位情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の数量単位の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の数量単位の「品目コード」
[idx]["ALT_UNIT"]　→　配列内のidx番目の数量単位の「在庫保管単位の代替数量単位」
[idx]["ALT_UNIT_ISO"]　→　配列内のidx番目の数量単位の 「ISO コードによる在庫単位の代替数量単位」
[idx]["NUMERATOR"]　→　配列内のidx番目の数量単位の「基本数量単位への換算分子」
[idx]["DENOMINATR"]　→　配列内のidx番目の数量単位の「分母: 基本数量単位へ変換する場合」
[idx]["EAN_UPC"]　→　配列内のidx番目の数量単位の「国際商品コード (EAN/UPC)」
[idx]["EAN_CAT"]　→　配列内のidx番目の数量単位の「国際商品コード (EAN) のカテゴリ」
[idx]["LENGTH"]　→　配列内のidx番目の数量単位の「長さ」
[idx]["WIDTH"]　→　配列内のidx番目の数量単位の「幅」
[idx]["HEIGHT"]　→　配列内のidx番目の数量単位の「高さ」
[idx]["UNIT_DIM"]　→　配列内のidx番目の数量単位の「寸法単位 (長さ/幅/高さ)」
[idx]["UNIT_DIM_ISO"]　→　配列内のidx番目の数量単位の 「ISO コードでの長さ、幅、高さの単位」
[idx]["VOLUME"]　→　配列内のidx番目の数量単位の「容積」
[idx]["VOLUMEUNIT"]　→　配列内のidx番目の数量単位の「容積単位」
[idx]["VOLUMEUNIT_ISO"]　→　配列内のidx番目の数量単位の「ISO コードでの容積単位」
[idx]["GROSS_WT"]　→　配列内のidx番目の数量単位の「総重量」
[idx]["UNIT_OF_WT"]　→　配列内のidx番目の数量単位の「重量単位」
[idx]["UNIT_OF_WT_ISO"]　→　配列内のidx番目の数量単位の「ISO コードでの重量単位」
[idx]["DEL_FLAG"]　→　配列内のidx番目の数量単位の「データレコード削除 (テーブル繰返し)」
[idx]["SUB_UOM"]　→　配列内のidx番目の数量単位の「梱包階層の下位レベル数量単位」
[idx]["SUB_UOM_ISO"]　→　配列内のidx番目の数量単位の「下位レベル数量単位 (ISO コード)」
[idx]["GTIN_VARIANT"]　→　配列内のidx番目の数量単位の「グローバルトレード明細番号バリアント」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の品目コード(長)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の外部GUID」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL のバージョン番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getUnplndConsumptionList

Array getUnplndConsumptionList ()

計画外消費のデータ転送を取得します。
返却値
Array 計画外消費のデータ転送

計画外消費のデータ転送情報オブジェクトの構成は以下のとおりです。
計画外消費のデータ転送情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
PLANT プラント (String)
FIRST_DAY 値参照期間の第一日目 (String)
CONS_VALUE 消費量 (String)
CORR_VALUE 修正消費量 (String)
VAL_RATIO 元値に対する修正値の比率 (修正値: 元値) (String)
MATERIAL_EXTERNAL 項目 MATERIAL の 品目コード (長) (今後のリリースで開発) (String)
MATERIAL_GUID 項目 MATERIAL の外部 GUID (今後のリリースで開発) (String)
MATERIAL_VERSION 項目 MATERIAL の バージョン番号 (今後のリリースで開発) (String)

取得した計画外消費のデータ転送情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の計画外消費のデータ転送の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の計画外消費のデータ転送の「品目コード」
[idx]["PLANT"]　→　配列内のidx番目の計画外消費のデータ転送の「プラント」
[idx]["FIRST_DAY"]　→　配列内のidx番目の計画外消費のデータ転送の「値参照期間の第一日目」
[idx]["CONS_VALUE"]　→　配列内のidx番目の計画外消費のデータ転送の「消費量」
[idx]["CORR_VALUE"]　→　配列内のidx番目の計画外消費のデータ転送の「修正消費量」
[idx]["VAL_RATIO"]　→　配列内のidx番目の計画外消費のデータ転送の 「元値に対する修正値の比率 (修正値: 元値)」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の計画外消費のデータ転送の 「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の計画外消費のデータ転送の 「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の計画外消費のデータ転送の 「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getValuationDataList

Array getValuationDataList ()

評価データを取得します。
返却値
Array 評価データ

評価データ情報オブジェクトの構成は以下のとおりです。
評価データ
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
VAL_AREA 評価レベル (String)
VAL_TYPE 評価タイプ (String)
DEL_FLAG 評価タイプに該当する 全品目データ削除フラグ (String)
PRICE_CTRL 原価管理区分 (String)
MOVING_PR 移動平均原価/期間単位価格 (String)
STD_PRICE 標準原価 (String)
PRICE_UNIT 価格単位 (String)
VAL_CLASS 評価クラス (String)
PR_CTRL_PP 前期間の原価管理区分 (String)
MOV_PR_PP 前期移動平均原価/期間平均原価 (String)
STD_PR_PP 前期標準標準原価 (String)
PR_UNIT_PP 前期価格単位 (String)
VCLASS_PP 前期評価クラス (String)
PR_CTRL_PY 前年度の原価管理区分 (String)
MOV_PR_PY 前年度の移動平均原価/期間単価 (String)
STD_PR_PY 前年度標準原価 (String)
VCLASS_PY 前年度の評価クラス (String)
PR_UNIT_PY 前年度価格単位 (String)
VAL_CAT 評価カテゴリ (String)
FUTURE_PR 次期標準原価 (String)
VALID_FROM 原価有効開始日 (String)
TAXPRICE_1 税法による評価額: レベル 1 (String)
COMMPRICE1 商法による評価額: レベル 1 (String)
TAXPRICE_3 税法基準評価額: レベル 3 (String)
COMMPRICE3 商法基準評価額: レベル 3 (String)
PLND_PRICE 予定計画原価 (String)
PLNDPRICE1 予定計画原価 1 (String)
PLNDPRICE2 予定計画原価 2 (String)
PLNDPRICE3 予定計画原価 3 (String)
PLNDPRDATE1 予定原価 1 の有効開始日 (String)
PLNDPRDATE2 予定原価 2 の有効開始日 (String)
PLNDPRDATE3 予定原価 3 の有効開始日 (String)
LIFO_FIFO LIFO/FIFO 関連 (String)
POOLNUMBER LIFO 評価でのプール番号 (String)
TAXPRICE_2 税法による評価額: レベル 2 (String)
COMMPRICE2 商法による評価額: レベル 2 (String)
DEVAL_IND 低価法: 評価減区分 (String)
ORIG_GROUP 発生源グループ (原価要素の下位区分) (String)
OVERHEAD_GRP 原価計算間接費グループ (String)
QTY_STRUCT 数量構成により原価計算を行う品目 (String)
ML_ACTIVE 品目レベルで有効な品目元帳 (String)
ML_SETTLE 品目元帳決済: 管理 (String)
ORIG_MAT 品目発生源 (String)
VM_SO_STK 受注在庫の評価クラス (String)
VM_P_STOCK プロジェクト在庫の評価クラス (String)
MATL_USAGE 品目の用途 (String)
MAT_ORIGIN 品目の原産地 (String)
IN_HOUSE 内部生産 (String)
TAX_CML_UN 税法/商法にもとづく評価額価格単位 (String)
ACCOUNT_VIEW 会計ビュー (String)
COST_VIEW 原価計算ビュー (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード(長) (String)
MATERIAL_GUID 項目 MATERIAL の外部GUID (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (String)

取得した評価データ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の評価データの「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の評価データの「品目コード」
[idx]["VAL_AREA"]　→　配列内のidx番目の評価データの「評価レベル」
[idx]["VAL_TYPE"]　→　配列内のidx番目の評価データの「評価タイプ」
[idx]["DEL_FLAG"]　→　配列内のidx番目の評価データの「評価タイプに該当する全品目データ削除フラグ」
[idx]["PRICE_CTRL"]　→　配列内のidx番目の評価データの「原価管理区分」
[idx]["MOVING_PR"]　→　配列内のidx番目の評価データの「移動平均原価/期間単位価格」
[idx]["STD_PRICE"]　→　配列内のidx番目の評価データの「標準原価」
[idx]["PRICE_UNIT"]　→　配列内のidx番目の評価データの「価格単位」
[idx]["VAL_CLASS"]　→　配列内のidx番目の評価データの「評価クラス」
[idx]["PR_CTRL_PP"]　→　配列内のidx番目の評価データの「前期間の原価管理区分」
[idx]["MOV_PR_PP"]　→　配列内のidx番目の評価データの「前期移動平均原価/期間平均原価」
[idx]["STD_PR_PP"]　→　配列内のidx番目の評価データの「前期標準標準原価」
[idx]["PR_UNIT_PP"]　→　配列内のidx番目の評価データの「前期価格単位」
[idx]["VCLASS_PP"]　→　配列内のidx番目の評価データの「前期評価クラス」
[idx]["PR_CTRL_PY"]　→　配列内のidx番目の評価データの「前年度の原価管理区分」
[idx]["MOV_PR_PY"]　→　配列内のidx番目の評価データの「前年度の移動平均原価/期間単価」
[idx]["STD_PR_PY"]　→　配列内のidx番目の評価データの「前年度標準原価」
[idx]["VCLASS_PY"]　→　配列内のidx番目の評価データの「前年度の評価クラス」
[idx]["PR_UNIT_PY"]　→　配列内のidx番目の評価データの「前年度価格単位」
[idx]["VAL_CAT"]　→　配列内のidx番目の評価データの「評価カテゴリ」
[idx]["FUTURE_PR"]　→　配列内のidx番目の評価データの「次期標準原価」
[idx]["VALID_FROM"]　→　配列内のidx番目の評価データの「原価有効開始日」
[idx]["TAXPRICE_1"]　→　配列内のidx番目の評価データの「税法による評価額: レベル 1」
[idx]["COMMPRICE1"]　→　配列内のidx番目の評価データの「商法による評価額: レベル 1」
[idx]["TAXPRICE_3"]　→　配列内のidx番目の評価データの「税法基準評価額: レベル 3」
[idx]["COMMPRICE3"]　→　配列内のidx番目の評価データの「商法基準評価額: レベル 3」
[idx]["PLND_PRICE"]　→　配列内のidx番目の評価データの「予定計画原価」
[idx]["PLNDPRICE1"]　→　配列内のidx番目の評価データの「予定計画原価 1」
[idx]["PLNDPRICE2"]　→　配列内のidx番目の評価データの「予定計画原価 2」
[idx]["PLNDPRICE3"]　→　配列内のidx番目の評価データの「予定計画原価 3」
[idx]["PLNDPRDATE1"]　→　配列内のidx番目の評価データの「予定原価 1 の有効開始日」
[idx]["PLNDPRDATE2"]　→　配列内のidx番目の評価データの「予定原価 2 の有効開始日」
[idx]["PLNDPRDATE3"]　→　配列内のidx番目の評価データの「予定原価 3 の有効開始日」
[idx]["LIFO_FIFO"]　→　配列内のidx番目の評価データの「LIFO/FIFO 関連」
[idx]["POOLNUMBER"]　→　配列内のidx番目の評価データの「LIFO 評価でのプール番号」
[idx]["TAXPRICE_2"]　→　配列内のidx番目の評価データの「税法による評価額: レベル 2」
[idx]["COMMPRICE2"]　→　配列内のidx番目の評価データの「商法による評価額: レベル 2」
[idx]["DEVAL_IND"]　→　配列内のidx番目の評価データの「低価法: 評価減区分」
[idx]["ORIG_GROUP"]　→　配列内のidx番目の評価データの「発生源グループ (原価要素の下位区分)」
[idx]["OVERHEAD_GRP"]　→　配列内のidx番目の評価データの「原価計算間接費グループ」
[idx]["QTY_STRUCT"]　→　配列内のidx番目の評価データの「数量構成により原価計算を行う品目」
[idx]["ML_ACTIVE"]　→　配列内のidx番目の評価データの「品目レベルで有効な品目元帳」
[idx]["ML_SETTLE"]　→　配列内のidx番目の評価データの「品目元帳決済: 管理」
[idx]["ORIG_MAT"]　→　配列内のidx番目の評価データの「品目発生源」
[idx]["VM_SO_STK"]　→　配列内のidx番目の評価データの「受注在庫の評価クラス」
[idx]["VM_P_STOCK"]　→　配列内のidx番目の評価データの「プロジェクト在庫の評価クラス」
[idx]["MATL_USAGE"]　→　配列内のidx番目の評価データの「品目の用途」
[idx]["MAT_ORIGIN"]　→　配列内のidx番目の評価データの「品目の原産地」
[idx]["IN_HOUSE"]　→　配列内のidx番目の評価データの「内部生産」
[idx]["TAX_CML_UN"]　→　配列内のidx番目の評価データの「税法/商法にもとづく評価額価格単位」
[idx]["ACCOUNT_VIEW"]　→　配列内のidx番目の評価データの「会計ビュー」
[idx]["COST_VIEW"]　→　配列内のidx番目の評価データの「原価計算ビュー」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の品目コード(長)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の外部GUID」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL のバージョン番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getWarehouseNumberDataList

Array getWarehouseNumberDataList ()

倉庫番号データを取得します。
返却値
Array 倉庫番号データ

倉庫番号データ情報オブジェクトの構成は以下のとおりです。
倉庫番号データ情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
WHSE_NO 倉庫番号/複合倉庫 (String)
DEL_FLAG WM 倉庫内の全品目データ削除フラグ (String)
STGESECTOR 保管区画区分 (String)
PLACEMENT 在庫受入に対する保管域タイプ検索区分 (String)
WITHDRAWAL 在庫払出に対する保管域タイプ区分 (String)
L_EQUIP_1 積載装置数量 1 (String)
L_EQUIP_2 積載装置数量 2 (String)
L_EQUIP_3 積載装置数量 3 (String)
LEQ_UNIT_1 積載装置数量 1 の数量単位 (String)
LEQ_UNIT_1_ISO ISO コードによる 積載装置数量 1 の数量単位 (String)
LEQ_UNIT_2 積載装置数量 2 の数量単位 (String)
LEQ_UNIT_2_ISO ISO コードによる 積載装置数量 2 の数量単位 (String)
LEQ_UNIT_3 積載装置数量 3 の数量単位 (String)
LEQ_UNIT_3_ISO ISO コードによる 積載装置数量 3 の数量単位 (String)
UNITTYPE_1 第１保管単位タイプ (String)
UNITTYPE_2 第２保管単位タイプ (String)
UNITTYPE_3 第３保管単位タイプ (String)
WM_UNIT 倉庫管理の数量単位 (String)
WM_UNIT_ISO ISO コードでの倉庫管理単位 (String)
ADD_TO_STK 既存在庫への追加許可 (String)
BLOCK_STGE 平置保管域区分 (String)
MSG_TO_IM 区分: 在庫管理への出力 (String)
SPEC_MVMT 倉庫管理の特殊移動区分 (String)
CAPY_USAGE 保管容量使用 (String)
PROCURE_UN 保管容量消費の数量単位 (String)
PROCURE_UN_ISO ISO コードでの 保管容量消費の数量単位 (String)
STGE_TYPE 概略計画および詳細計画の ピッキング保管域タイプ (String)
REF_UNIT 品目マスタレコードの数量単位初期値 (String)
2STEP_PICK ツーステップピッキング適用品目 (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード(長) (String)
MATERIAL_GUID 項目 MATERIAL の外部GUID (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (String)

取得した倉庫番号データ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の倉庫番号データの「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の倉庫番号データの「品目コード」
[idx]["WHSE_NO"]　→　配列内のidx番目の倉庫番号データの「倉庫番号/複合倉庫」
[idx]["DEL_FLAG"]　→　配列内のidx番目の倉庫番号データの「WM 倉庫内の全品目データ削除フラグ」
[idx]["STGESECTOR"]　→　配列内のidx番目の倉庫番号データの「保管区画区分」
[idx]["PLACEMENT"]　→　配列内のidx番目の倉庫番号データの「在庫受入に対する保管域タイプ検索区分」
[idx]["WITHDRAWAL"]　→　配列内のidx番目の倉庫番号データの「在庫払出に対する保管域タイプ区分」
[idx]["L_EQUIP_1"]　→　配列内のidx番目の倉庫番号データの「積載装置数量 1」
[idx]["L_EQUIP_2"]　→　配列内のidx番目の倉庫番号データの「積載装置数量 2」
[idx]["L_EQUIP_3"]　→　配列内のidx番目の倉庫番号データの「積載装置数量 3」
[idx]["LEQ_UNIT_1"]　→　配列内のidx番目の倉庫番号データの「積載装置数量 1 の数量単位」
[idx]["LEQ_UNIT_1_ISO"]　→　配列内のidx番目の倉庫番号データの 「ISO コードによる積載装置数量 1 の数量単位」
[idx]["LEQ_UNIT_2"]　→　配列内のidx番目の倉庫番号データの「積載装置数量 2 の数量単位」
[idx]["LEQ_UNIT_2_ISO"]　→　配列内のidx番目の倉庫番号データの 「ISO コードによる積載装置数量 2 の数量単位」
[idx]["LEQ_UNIT_3"]　→　配列内のidx番目の倉庫番号データの「積載装置数量 3 の数量単位」
[idx]["LEQ_UNIT_3_ISO"]　→　配列内のidx番目の倉庫番号データの 「ISO コードによる積載装置数量 3 の数量単位」
[idx]["UNITTYPE_1"]　→　配列内のidx番目の倉庫番号データの「第１保管単位タイプ」
[idx]["UNITTYPE_2"]　→　配列内のidx番目の倉庫番号データの「第２保管単位タイプ」
[idx]["UNITTYPE_3"]　→　配列内のidx番目の倉庫番号データの「第３保管単位タイプ」
[idx]["WM_UNIT"]　→　配列内のidx番目の倉庫番号データの「倉庫管理の数量単位」
[idx]["WM_UNIT_ISO"]　→　配列内のidx番目の倉庫番号データの「ISO コードでの倉庫管理単位」
[idx]["ADD_TO_STK"]　→　配列内のidx番目の倉庫番号データの「既存在庫への追加許可」
[idx]["BLOCK_STGE"]　→　配列内のidx番目の倉庫番号データの「平置保管域区分」
[idx]["MSG_TO_IM"]　→　配列内のidx番目の倉庫番号データの「区分: 在庫管理への出力」
[idx]["SPEC_MVMT"]　→　配列内のidx番目の倉庫番号データの「倉庫管理の特殊移動区分」
[idx]["CAPY_USAGE"]　→　配列内のidx番目の倉庫番号データの「保管容量使用」
[idx]["PROCURE_UN"]　→　配列内のidx番目の倉庫番号データの「保管容量消費の数量単位」
[idx]["PROCURE_UN_ISO"]　→　配列内のidx番目の倉庫番号データの 「ISO コードでの保管容量消費の数量単位」
[idx]["STGE_TYPE"]　→　配列内のidx番目の倉庫番号データの 「概略計画および詳細計画のピッキング保管域タイプ」
[idx]["REF_UNIT"]　→　配列内のidx番目の倉庫番号データの「品目マスタレコードの数量単位初期値」
[idx]["2STEP_PICK"]　→　配列内のidx番目の倉庫番号データの「ツーステップピッキング適用品目」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の品目コード(長)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL の外部GUID」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 MATERIAL のバージョン番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

setFlagCadCall

void setFlagCadCall (Object value)

CAD システムからコールを設定します。
パラメータ
value Object CAD システムからコール
返却値
void
setFlagOnline

void setFlagOnline (Object value)

No ALE Field Selectionを設定します。
パラメータ
value Object No ALE Field Selection
返却値
void
setInpfldcheck

void setInpfldcheck (Object value)

項目無効時の応答を設定します。
パラメータ
value Object 項目無効時の応答
返却値
void
setNoRollbackWork

void setNoRollbackWork (Object value)

Override Rollback Workを設定します。
パラメータ
value Object Override Rollback Work
返却値
void
setNoappllog

void setNoappllog (Object value)

アプリケーションログ書込なしを設定します。
パラメータ
value Object アプリケーションログ書込なし
返却値
void
setNochangedoc

void setNochangedoc (Object value)

変更伝票書込なしを設定します。
パラメータ
value Object 変更伝票書込なし
返却値
void
setTblParam

void setTblParam (String tableName ,String paramName ,Object value ,int index)

テーブル型の項目に値をセットします。
パラメータ
tableName | String | テーブル名
paramName | String | 項目名
value | Object | セットする値
index | int | レコード番号
返却値
void
setTestrun

void setTestrun (Object value)

書込 BAPI のシミュレーションセッションへの切替を設定します。
パラメータ
value Object 書込 BAPI のシミュレーションセッションへの切替
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 ProfitCenterController オブジェクト

利益センタコントローラクラス。

利益センタの情報を取得します。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
ProfitCenterController (String controllingArea)
コンストラクタ。
ProfitCenterController (String controllingArea ,String date)
コンストラクタ。
ProfitCenterController (String controllingArea ,SapClient sapClient)
コンストラクタ。
ProfitCenterController (String controllingArea ,String date ,SapClient sapClient)
コンストラクタ。
ProfitCenterController (String controllingArea ,String personincharge ,String inChargeUser ,String date)
コンストラクタ。
ProfitCenterController (String controllingArea ,String personincharge ,String inChargeUser ,String date ,SapClient sapClient)
コンストラクタ。
メソッドの概要
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
Object | getInCharge (String profitCtr) 利益センタ責任者を取得します。
Object | getInChargeUser (String profitCtr) 利益センタの責任ユーザを取得します。
Object | getPctrName (String profitCtr) 一般名称を取得します。
Array | getProfitCenterList () 利益センタ情報一覧を取得します。
Object | getValidTo (String profitCtr) 有効終了日を取得します。
コンストラクタの詳細
ProfitCenterController

ProfitCenterController (String controllingArea)
コンストラクタ。

引数１つのコンストラクタです。
システム日付で有効な利益センタ情報が抽出対象となります。
パラメータ
controllingArea String SAP上に存在する管理領域コード
ProfitCenterController

ProfitCenterController (String controllingArea ,String date)
コンストラクタ。

引数２つコンストラクタです。
指定したYYYYMMDDの日付で有効な利益センタ情報が抽出対象となります。
パラメータ
controllingArea String SAP上に存在する管理領域コード
date String 日付 ※日付書式「YYYYMMDD」
ProfitCenterController

ProfitCenterController (String controllingArea ,SapClient sapClient)
コンストラクタ。

引数２つコンストラクタです。
システム日付で有効な利益センタ情報が抽出対象となります。
SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
controllingArea String SAP上に存在する管理領域コード
sapClient SapClient Sapクライアント
ProfitCenterController

ProfitCenterController (String controllingArea ,String date ,SapClient sapClient)
コンストラクタ。

引数３つコンストラクタです。
指定したYYYYMMDDの日付で有効な利益センタ情報が抽出対象となります。
SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
controllingArea | String | SAP上に存在する管理領域コード
date | String | 日付
sapClient | SapClient | Sapクライアント
ProfitCenterController

ProfitCenterController (String controllingArea ,String personincharge ,String inChargeUser ,String date)
コンストラクタ。

引数４つコンストラクタです。
指定したYYYYMMDDの日付で有効な利益センタ情報が抽出対象となります。
パラメータ
controllingArea | String | SAP上に存在する管理領域コード
personincharge | String | 利益センタ責任者
inChargeUser | String | 利益センタに責任のあるユーザ
date | String | 日付
ProfitCenterController

ProfitCenterController (String controllingArea ,String personincharge ,String inChargeUser ,String date ,SapClient sapClient)
コンストラクタ。

引数５つコンストラクタです。
指定したYYYYMMDDの日付で有効な利益センタ情報が抽出対象となります。
SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
controllingArea | String | SAP上に存在する管理領域コード
personincharge | String | 利益センタ責任者
inChargeUser | String | 利益センタに責任のあるユーザ
date | String | 日付
sapClient | SapClient | Sapクライアント
メソッドの詳細
getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getInCharge

Object getInCharge (String profitCtr)

利益センタ責任者を取得します。

利益センタコードを指定して利益センタ責任者を取得します。
パラメータ
profitCtr String SAP上に存在する利益センタコード
返却値
Object 指定した利益センタコードに対応する利益センタ責任者
（成功時の返却値は String になります。）
（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInChargeUser

Object getInChargeUser (String profitCtr)

利益センタの責任ユーザを取得します。

利益センタコードを指定して利益センタの責任ユーザを取得します。
パラメータ
profitCtr String SAP上に存在する利益センタコード
返却値
Object 指定した利益センタコードに対応する利益センタの責任ユーザ
（成功時の返却値は String になります。）
（失敗時）Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPctrName

Object getPctrName (String profitCtr)

一般名称を取得します。

利益センタコードを指定して一般名称を取得します。
パラメータ
profitCtr String SAP上に存在する利益センタコード
返却値
Object 指定した利益センタコードに対応する一般名称
（成功時の返却値は String になります。）
（失敗時）Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getProfitCenterList

Array getProfitCenterList ()

利益センタ情報一覧を取得します。

返却値
Array 利益センタ情報が格納された配列

利益センタ情報オブジェクトの構成は以下のとおりです。
利益センタ情報
オブジェクト
(Object)
CONTROLLING_AREA 管理領域コードコード (String)
PROFIT_CTR 利益センタコード (String)
VALID_TO 有効終了日 (String)
IN_CHARGE 利益センタ責任者 (String)
PCTR_NAME 一般名称 (String)
IN_CHARGE_USER 利益センタの責任ユーザ (String)

取得した利益センタ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONTROLLING_AREA"]　→　配列内のidx番目の利益センタの「管理領域コード」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の利益センタの「利益センタコード」
[idx]["VALID_TO"]　→　配列内のidx番目の利益センタの「有効終了日」
[idx]["IN_CHARGE"]　→　配列内のidx番目の利益センタの「利益センタ責任者」
[idx]["PCTR_NAME"]　→　配列内のidx番目の利益センタの「一般名称」
[idx]["IN_CHARGE_USER"]　→　配列内のidx番目の利益センタの「利益センタの責任ユーザ」

※ idxは0〜n （配列サイズ-1）

getValidTo

Object getValidTo (String profitCtr)

有効終了日を取得します。

利益センタコードを指定して有効終了日を取得します。
パラメータ
profitCtr String SAP上に存在する利益センタコード
返却値
Object 指定した利益センタコードに対応する有効終了日
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)


 ProfitCenterGrpGetDetailController オブジェクト

利益センタグループ情報取得コントローラクラス。

機能は以下の通り
  • 利益センタグループ情報を取得します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
ProfitCenterGrpGetDetailController (String controllingarea ,String groupname)
コンストラクタ｡
ProfitCenterGrpGetDetailController (String controllingarea ,String groupname ,SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | getControllingarea () 利益センタグループの管理領域から値を取得します。
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
Object | getGroupname () 利益センタグループのグループ名から値を取得します。
Array | getHierarchyNodesList () 階層ノード一覧を取得します。
Array | getHierarchyValuesList () 階層値一覧を取得します。
void | setControllingarea (String value) 利益センタグループの管理領域に値を設定します。
void | setGroupname (String value) 利益センタグループのグループ名に値を設定します。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
ProfitCenterGrpGetDetailController

ProfitCenterGrpGetDetailController (String controllingarea ,String groupname)
コンストラクタ｡
パラメータ
controllingarea | String | 管理領域
groupname | String | グループ名
ProfitCenterGrpGetDetailController

ProfitCenterGrpGetDetailController (String controllingarea ,String groupname ,SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
controllingarea | String | 管理領域
groupname | String | グループ名
sapClient | SapClient | Sapクライアント
メソッドの詳細
getControllingarea

Object getControllingarea ()

利益センタグループの管理領域から値を取得します。

返却値
Object 管理領域
getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getGroupname

Object getGroupname ()

利益センタグループのグループ名から値を取得します。

返却値
Object グループ名
getHierarchyNodesList

Array getHierarchyNodesList ()

階層ノード一覧を取得します。
返却値
Array 階層ノード情報が格納された配列

階層ノード情報オブジェクトの構成は以下のとおりです。
階層ノード情報
オブジェクト
(Object)
GROUPNAME グループ名 (String)
HIERLEVEL 階層のエントリレベル (String)
VALCOUNT 階層ノード内の値の値数 (String)
DESCRIPT グループテキスト (短) (String)

取得した階層ノード情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["GROUPNAME"]　→　配列内のidx番目の階層ノードの「グループ名」
[idx]["HIERLEVEL"]　→　配列内のidx番目の階層ノードの「階層のエントリレベル」
[idx]["VALCOUNT"]　→　配列内のidx番目の階層ノードの「階層ノード内の値の値数」
[idx]["DESCRIPT"]　→　配列内のidx番目の階層ノードの「グループテキスト (短)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getHierarchyValuesList

Array getHierarchyValuesList ()

階層値一覧を取得します。
返却値
Array 階層値情報が格納された配列

階層値情報オブジェクトの構成は以下のとおりです。
階層値情報
オブジェクト
(Object)
VALFROM 利益センタ (String)
VALTO 利益センタ (String)

取得した階層値情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["VALFROM"]　→　配列内のidx番目の階層値の「利益センタ」
[idx]["VALTO"]　→　配列内のidx番目の階層値の「利益センタ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

setControllingarea

void setControllingarea (String value)

利益センタグループの管理領域に値を設定します。
パラメータ
value String 管理領域
返却値
void
setGroupname

void setGroupname (String value)

利益センタグループのグループ名に値を設定します。
パラメータ
value String グループ名
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 ProjectGetInfoController オブジェクト

WBS詳細情報取得コントローラクラス。

機能は以下の通り
  • WBS詳細情報を取得します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
ProjectGetInfoController ()
コンストラクタ｡
ProjectGetInfoController (SapClient sapClient)
コンストラクタ。
ProjectGetInfoControllerObject (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerによりWBS情報を取得します。
Object | getExpActivityList () WBS情報取得の活動に関する詳細情報から値を取得します。
Object | getExpMessageList () WBS情報取得の詳細情報を読み込みエラーから値を取得します。
Object | getExpWbsElementList () WBS情報取得のWBS 要素についての詳細情報から値を取得します。
Object | getExpWbsHierarchieList () WBS情報取得のWBS 階層についての情報から値を取得します。
Object | getExpWbsMilestoneList () WBS情報取得のWBS マイルストーンに関する詳細情報から値を取得します。
Object | getImpWbsElementList () WBS情報取得の詳細情報を必要とする WBS 要素から値を取得します。
Object | getProjectDefinition () WBS情報取得のプロジェクト定義を識別するキーから値を取得します。
Object | getProjectDefinitionInfo () プロジェクトについての詳細情報を取得します。
Object | getWithActivities () WBS情報取得の従属活動がエクスポートから値を取得します。
Object | getWithMilestones () WBS情報取得の従属 WBS マイルストーンがエクスポートから値を取得します。
Object | getWithSubtree () WBS情報取得のサブプロジェクトがエクスポートから値を取得します。
void | setProjectDefinition (String value) WBS情報取得のプロジェクト定義を識別するキーに値を設定します。
void | setTblParam (String paramTable ,String paramName ,String value ,int index) テーブル型の項目に値をセットします。
void | setWithActivities (String value) WBS情報取得の従属活動がエクスポートに値を設定します。
void | setWithMilestones (String value) WBS情報取得の従属 WBS マイルストーンがエクスポートに値を設定します。
void | setWithSubtree (String value) WBS情報取得のサブプロジェクトがエクスポートに値を設定します。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
ProjectGetInfoController

ProjectGetInfoController ()
コンストラクタ｡
ProjectGetInfoController

ProjectGetInfoController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
ProjectGetInfoControllerObject

ProjectGetInfoControllerObject (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerによりWBS情報を取得します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getExpActivityList

Object getExpActivityList ()

WBS情報取得の活動に関する詳細情報から値を取得します。
返却値
Object 活動に関する詳細情報

WBS情報取得の活動に関する詳細情報オブジェクトの構成は以下のとおりです。
WBS情報取得の活動に関する詳細情報
オブジェクト
(Object)
NETWORK ネットワーク番号 (String)
ACTIVITY ネットワーク/標準ネットワークの活動番号 (String)
CONTROL_KEY 管理キー (String)
WORK_CNTR 作業区 (String)
PLANT プラント (String)
DESCRIPTION 作業テキスト (短) (String)
VENDOR_NO 仕入先または債権者の勘定コード (String)
PRICE 価格 (String)
PRICE_UNIT 価格単位 (String)
COST_ELEM 原価要素 (String)
CURRENCY 通貨コード (String)
CURRENCY_ISO ISO 通貨コード (String)
INFO_REC 購買情報番号 (String)
PURCH_ORG 購買組織 (String)
PUR_GROUP 購買グループ (String)
MATL_GROUP 品目グループ (String)
FLEXIBLE_DURATION 区分：可変期間 (String)
NUMBER_OF_CAPACITIES 所要能力数 (String)
PERCENT_OF_WORK 作業の比率 (%) (String)
MILESTONE 用途 (String)
ACTTYPE 活動タイプ (String)
ACTIVITY_COSTS 活動の原価 (String)
PROJECT_DEFINITION プロジェクト定義 (String)
WBS_ELEMENT WBS 要素 (String)
FACTORY_CALENDAR 稼働日カレンダ (String)
DISTRIBUTING_KEY 能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク) (String)
PRIORITY 優先度 (String)
TAXJURCODE 税計算管轄コード - 税管轄コード (String)
OBJECTCLASS オブジェクトクラス (言語非依存) (String)
PROFIT_CTR 利益センタ (String)
NOT_MRP_APPLICABLE 区分：MRP への入出庫予定の適用不可と購買依頼未登録 (String)
PROJECT_SUMMARIZATION 区分：プロジェクト集計用に活動を考慮 (String)
OPERATION_MEASURE_UNIT 活動単位 (String)
OPERATION_MEASURE_UNIT_ISO 単位の ISO コード (String)
PLND_DELRY 予定納入時間 (単位：日) (String)
DURATION_NORMAL 標準活動期間 (String)
DURATION_NORMAL_UNIT 標準期間/単位 (String)
DURATION_NORMAL_UNIT_ISO 単位の ISO コード (String)
DURATION_MINIMUM 最短活動期間 (String)
DURATION_MINIMUM_UNIT 最短期間の単位 (String)
DURATION_MINIMUM_UNIT_ISO 単位の ISO コード (String)
CONSTRAINT_TYPE_START 活動の基準開始日に対する制約 (String)
CONSTRAINT_TYPE_FINISH 活動の終了日に対する制約 (String)
WORK_ACTIVITY 活動に含まれる作業 (String)
UN_WORK 作業単位 (String)
UN_WORK_ISO 単位の ISO コード (String)
EARLY_START_DATE 最早計画開始：実行 (日) (String)
EARLY_START_TIME 最早計画開始：作業実施(時間) (String)
EARLY_FINISH_DATE 最早計画終了：実行 (日) (String)
EARLY_FINISH_TIME 最早計画終了：実行 (時刻) (String)
LATEST_START_DATE 計画最遅開始：作業(日付) (String)
LATEST_START_TIME 計画最遅開始：作業(時間) (String)
LATEST_FINISH_DATE 計画最遅終了：作業(日付) (String)
LATEST_FINISH_TIME 計画最遅終了：作業(時間) (String)
FLOAT_FREE 自由余裕 (String)
FLOAT_TOTAL 余裕合計 (String)
CONSTRAINT_START_DATE 活動の基準開始日に対する制約 (String)
CONSTRAINT_START_TIME 活動の基準開始時間の制約 (String)
CONSTRAINT_FINISH_DATE 活動の基準終了日に対する制約 (String)
CONSTRAINT_FINISH_TIME 活動の基準終了時間 (String)
USER_FIELD_KEY ユーザ定義項目のキーワード ID (String)
USER_FIELD_CHAR20_1 20 文字のユーザ項目 (String)
USER_FIELD_CHAR20_2 20 文字のユーザ項目 (String)
USER_FIELD_CHAR10_1 ユーザ定義項目 (10 文字) (String)
USER_FIELD_CHAR10_2 ユーザ定義項目 (10 文字) (String)
USER_FIELD_QUAN1 数量のユーザ項目 (長さ 10,3) (String)
USER_FIELD_UNIT1 ユーザ項目：数量項目の単位 (String)
USER_FIELD_UNIT1_ISO 単位の ISO コード (String)
USER_FIELD_QUAN2 数量のユーザ項目 (長さ 10,3) (String)
USER_FIELD_UNIT2 ユーザ項目：数量項目の単位 (String)
USER_FIELD_UNIT2_ISO 単位の ISO コード (String)
USER_FIELD_CURR1 値のユーザ定義項目 (長さ 10,3) (String)
USER_FIELD_CUKY1 ユーザ項目：値項目の単位 (String)
USER_FIELD_CUKY1_ISO ISO 通貨コード (String)
USER_FIELD_CURR2 値のユーザ定義項目 (長さ 10,3) (String)
USER_FIELD_CUKY2 ユーザ項目：値項目の単位 (String)
USER_FIELD_CUKY2_ISO ISO 通貨コード (String)
USER_FIELD_DATE1 日付のユーザ項目 (String)
USER_FIELD_DATE2 日付のユーザ項目 (String)
USER_FIELD_FLAG1 ユーザ定義項目：レポート区分 (String)
USER_FIELD_FLAG2 ユーザ定義項目：レポート区分 (String)
DELETION_FLAG 削除フラグ (String)
DURATION_NORMAL_FC 標準活動期間 (予測) (String)
DURATION_NORMAL_FC_UNIT 標準予測期間の単位 (String)
DURATION_NORMAL_FC_UNIT_ISO 単位の ISO コード (String)
DURATION_MINIMUM_FC 活動の最小期間(需要予測より) (String)
DURATION_MINIMUM_FC_UNIT 予測最短期間の単位 (String)
DURATION_MINIMUM_FC_UNIT_ISO 単位の ISO コード (String)
CONSTRAINT_TYPE_FINISH_FC 活動終了の制約条件付き需要予測日付 (String)
CONSTRAINT_TYPE_START_FC 活動開始の制約条件付き需要予測日付 (String)
CONSTRAINT_START_DATE_FC 活動の予測開始日 (String)
CONSTRAINT_START_TIME_FC 活動の需要予測開始時間 (String)
CONSTRAINT_FINISH_DATE_FC 予測終了日付 (String)
CONSTRAINT_FINISH_TIME_FC 活動の予測終了時間 (String)
EARLY_START_DATE_FC 最早計画開始日付(需要予測) (String)
EARLY_START_TIME_FC 最早計画開始時間(需要予測) (String)
EARLY_FINISH_DATE_FC 最早計画終了日 (予測) (String)
EARLY_FINISH_TIME_FC 最早計画終了時間(需要予測) (String)
LATEST_START_DATE_FC 最遅計画済開始日付(需要予測) (String)
LATEST_START_TIME_FC 最遅計画済開始時間(需要予測) (String)
LATEST_FINISH_DATE_FC 最遅計画済終了日付(需要予測) (String)
LATEST_FINISH_TIME_FC 最遅計画終了時間 (予測) (String)
FLOAT_FREE_FC 自由余裕 (予測) (String)
FLOAT_TOTAL_FC 余裕合計 (予測) (String)
WORK_FORECAST 予測作業 (実績 + 残存) (String)
WORK_ACTUAL 実績作業 (String)
DURATION_SCHEDULED 処理時間 (String)
DURATION_SCHEDULED_FC 処理時間の長さ (予測値) (String)
DURATION_SCHEDULED_UNIT 処理時間単位 (String)
DURATION_SCHEDULED_UNIT_ISO 単位の ISO コード (String)
DURATION_CONFIRM_FC 確認の予測活動期間 (String)
DURATION_CONFIRM_FC_UNIT 確認の予測期間単位 (String)
DURATION_CONFIRM_FC_UNIT_ISO 単位の ISO コード (String)
OBJECTCLASS_EXT オブジェクトクラス、言語依存 (String)
FUNC_AREA 機能領域 (String)
FUNC_AREA_LONG 機能領域 (String)
PLANNED_COST 計画原価 (String)
ACTUAL_COST 実際原価 (String)
CONTROLLING_AREA_CURRENCY 通貨コード (String)
ACTUAL_START_DATE 実績開始日：実行 (日付) (String)
ACTUAL_FINISH_DATE 実績終了日：実行 (日付) (String)
FORECAST_FINISH_DATE 予測終了日 (String)
COMPLETE 最終確認の有効化 (String)
REFERENCE_POINT BOM 転送の参照ポイント (String)

取得したWBS情報取得の活動に関する詳細情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["NETWORK"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「ネットワーク番号」
[idx]["ACTIVITY"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「ネットワーク/標準ネットワークの活動番号」
[idx]["CONTROL_KEY"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「管理キー」
[idx]["WORK_CNTR"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「作業区」
[idx]["PLANT"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「プラント」
[idx]["DESCRIPTION"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「作業テキスト (短)」
[idx]["VENDOR_NO"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「仕入先または債権者の勘定コード」
[idx]["PRICE"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「価格」
[idx]["PRICE_UNIT"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「価格単位」
[idx]["COST_ELEM"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「原価要素」
[idx]["CURRENCY"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「通貨コード」
[idx]["CURRENCY_ISO"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「ISO 通貨コード」
[idx]["INFO_REC"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「購買情報番号」
[idx]["PURCH_ORG"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「購買組織」
[idx]["PUR_GROUP"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「購買グループ」
[idx]["MATL_GROUP"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「品目グループ」
[idx]["FLEXIBLE_DURATION"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「区分：可変期間」
[idx]["NUMBER_OF_CAPACITIES"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「所要能力数」
[idx]["PERCENT_OF_WORK"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「作業の比率 (%)」
[idx]["MILESTONE"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「用途」
[idx]["ACTTYPE"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「活動タイプ」
[idx]["ACTIVITY_COSTS"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「活動の原価」
[idx]["PROJECT_DEFINITION"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「プロジェクト定義」
[idx]["WBS_ELEMENT"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「WBS 要素」
[idx]["FACTORY_CALENDAR" ]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「稼働日カレンダ」
[idx]["DISTRIBUTING_KEY"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の 「能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)」
[idx]["PRIORITY"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「優先度」
[idx]["TAXJURCODE"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「税計算管轄コード - 税管轄コード」
[idx]["OBJECTCLASS"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「オブジェクトクラス (言語非依存)」
[idx]["PROFIT_CTR"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「利益センタ」
[idx]["NOT_MRP_APPLICABLE"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「区分：MRP への入出庫予定の適用不可と購買依頼未登録」
[idx]["PROJECT_SUMMARIZATION"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「区分：プロジェクト集計用に活動を考慮」
[idx]["OPERATION_MEASURE_UNIT"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「活動単位」
[idx]["OPERATION_MEASURE_UNIT_ISO"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「単位の ISO コード」
[idx]["PLND_DELRY"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「予定納入時間 (単位：日)」
[idx]["DURATION_NORMAL"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「標準活動期間」
[idx]["DURATION_NORMAL_UNIT"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「標準期間/単位」
[idx]["DURATION_NORMAL_UNIT_ISO"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「単位の ISO コード」
[idx]["DURATION_MINIMUM"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「最短活動期間」
[idx]["DURATION_MINIMUM_UNIT"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「最短期間の単位」
[idx]["DURATION_MINIMUM_UNIT_ISO"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「単位の ISO コード」
[idx]["CONSTRAINT_TYPE_START"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「活動の基準開始日に対する制約」
[idx]["CONSTRAINT_TYPE_FINISH"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「活動の終了日に対する制約」
[idx]["WORK_ACTIVITY"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「活動に含まれる作業」
[idx]["UN_WORK"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「作業単位」
[idx]["UN_WORK_ISO"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「単位の ISO コード」
[idx]["EARLY_START_DATE"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「最早計画開始：実行 (日)」
[idx]["EARLY_START_TIME"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「最早計画開始：作業実施(時間)」
[idx]["EARLY_FINISH_DATE"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「最早計画終了：実行 (日)」
[idx]["EARLY_FINISH_TIME"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「最早計画終了：実行 (時刻)」
[idx]["LATEST_START_DATE"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「計画最遅開始：作業(日付)」
[idx]["LATEST_START_TIME"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「計画最遅開始：作業(時間)」
[idx]["LATEST_FINISH_DATE"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「計画最遅終了：作業(日付)」
[idx]["LATEST_FINISH_TIME"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「計画最遅終了：作業(時間)」
[idx]["FLOAT_FREE"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「自由余裕」
[idx]["FLOAT_TOTAL"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「余裕合計」
[idx]["CONSTRAINT_START_DATE"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「活動の基準開始日に対する制約」
[idx]["CONSTRAINT_START_TIME"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「活動の基準開始時間の制約」
[idx]["CONSTRAINT_FINISH_DATE"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「活動の基準終了日に対する制約」
[idx]["CONSTRAINT_FINISH_TIME"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「活動の基準終了時間」
[idx]["USER_FIELD_KEY"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「ユーザ定義項目のキーワード ID」
[idx]["USER_FIELD_CHAR20_1"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「20 文字のユーザ項目」
[idx]["USER_FIELD_CHAR20_2"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「20 文字のユーザ項目」
[idx]["USER_FIELD_CHAR10_1"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「ユーザ定義項目 (10 文字)」
[idx]["USER_FIELD_CHAR10_2"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「ユーザ定義項目 (10 文字)」
[idx]["USER_FIELD_QUAN1"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「数量のユーザ項目 (長さ 10,3)」
[idx]["USER_FIELD_UNIT1"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「ユーザ項目：数量項目の単位」
[idx]["USER_FIELD_UNIT1_ISO"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「単位の ISO コード」
[idx]["USER_FIELD_QUAN2"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「数量のユーザ項目 (長さ 10,3)」
[idx]["USER_FIELD_UNIT2"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「ユーザ項目：数量項目の単位」
[idx]["USER_FIELD_UNIT2_ISO"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「単位の ISO コード」
[idx]["USER_FIELD_CURR1"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「値のユーザ定義項目 (長さ 10,3)」
[idx]["USER_FIELD_CUKY1"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「ユーザ項目：値項目の単位」
[idx]["USER_FIELD_CUKY1_ISO"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「ISO 通貨コード」
[idx]["USER_FIELD_CURR2"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「値のユーザ定義項目 (長さ 10,3)」
[idx]["USER_FIELD_CUKY2"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「ユーザ項目：値項目の単位」
[idx]["USER_FIELD_CUKY2_ISO"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「ISO 通貨コード」
[idx]["USER_FIELD_DATE1"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「日付のユーザ項目」
[idx]["USER_FIELD_DATE2"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「日付のユーザ項目」
[idx]["USER_FIELD_FLAG1"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「ユーザ定義項目：レポート区分」
[idx]["USER_FIELD_FLAG2"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「ユーザ定義項目：レポート区分」
[idx]["DELETION_FLAG"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「削除フラグ」
[idx]["DURATION_NORMAL_FC"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「標準活動期間 (予測)」
[idx]["DURATION_NORMAL_FC_UNIT"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「標準予測期間の単位」
[idx]["DURATION_NORMAL_FC_UNIT_ISO"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「単位の ISO コード」
[idx]["DURATION_MINIMUM_FC"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「活動の最小期間(需要予測より)」
[idx]["DURATION_MINIMUM_FC_UNIT"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「予測最短期間の単位」
[idx]["DURATION_MINIMUM_FC_UNIT_ISO"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「単位の ISO コード」
[idx]["CONSTRAINT_TYPE_FINISH_FC"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「活動終了の制約条件付き需要予測日付」
[idx]["CONSTRAINT_TYPE_START_FC"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「活動開始の制約条件付き需要予測日付」
[idx]["CONSTRAINT_START_DATE_FC"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「活動の予測開始日」
[idx]["CONSTRAINT_START_TIME_FC"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「活動の需要予測開始時間」
[idx]["CONSTRAINT_FINISH_DATE_FC"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「予測終了日付」
[idx]["CONSTRAINT_FINISH_TIME_FC"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「活動の予測終了時間」
[idx]["EARLY_START_DATE_FC"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「最早計画開始日付(需要予測)」
[idx]["EARLY_START_TIME_FC"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「最早計画開始時間(需要予測)」
[idx]["EARLY_FINISH_DATE_FC"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「最早計画終了日 (予測)」
[idx]["EARLY_FINISH_TIME_FC"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「最早計画終了時間(需要予測)」
[idx]["LATEST_START_DATE_FC"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「最遅計画済開始日付(需要予測)」
[idx]["LATEST_START_TIME_FC"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「最遅計画済開始時間(需要予測)」
[idx]["LATEST_FINISH_DATE_FC"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「最遅計画済終了日付(需要予測)」
[idx]["LATEST_FINISH_TIME_FC"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「最遅計画終了時間 (予測)」
[idx]["FLOAT_FREE_FC"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「自由余裕 (予測)」
[idx]["FLOAT_TOTAL_FC"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「余裕合計 (予測)」
[idx]["WORK_FORECAST"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「予測作業 (実績 + 残存)」
[idx]["WORK_ACTUAL"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「実績作業」
[idx]["DURATION_SCHEDULED"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「処理時間」
[idx]["DURATION_SCHEDULED_FC"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「処理時間の長さ (予測値)」
[idx]["DURATION_SCHEDULED_UNIT"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「処理時間単位」
[idx]["DURATION_SCHEDULED_UNIT_ISO"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「単位の ISO コード」
[idx]["DURATION_CONFIRM_FC"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「確認の予測活動期間」
[idx]["DURATION_CONFIRM_FC_UNIT"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「確認の予測期間単位」
[idx]["DURATION_CONFIRM_FC_UNIT_ISO"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「単位の ISO コード」
[idx]["OBJECTCLASS_EXT"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「オブジェクトクラス、言語依存」
[idx]["FUNC_AREA"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「機能領域」
[idx]["FUNC_AREA_LONG"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「機能領域」
[idx]["PLANNED_COST"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「計画原価」
[idx]["ACTUAL_COST"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「実際原価」
[idx]["CONTROLLING_AREA_CURRENCY"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「通貨コード」
[idx]["ACTUAL_START_DATE"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「実績開始日：実行 (日付)」
[idx]["ACTUAL_FINISH_DATE"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「実績終了日：実行 (日付)」
[idx]["FORECAST_FINISH_DATE"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「予測終了日」
[idx]["COMPLETE"]　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「最終確認の有効化」
[idx]["REFERENCE_POINT"] 　→　配列内のidx番目のWBS情報取得の活動に関する詳細の「BOM 転送の参照ポイント」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getExpMessageList

Object getExpMessageList ()

WBS情報取得の詳細情報を読み込みエラーから値を取得します。
返却値
Object 詳細情報を読み込みエラー

WBS情報取得の詳細情報を読み込みエラー情報オブジェクトの構成は以下のとおりです。
WBS情報取得の詳細情報を読み込みエラー情報
オブジェクト
(Object)
METHOD メソッド (String)
OBJECT_TYPE オブジェクトタイプ (String)
INTERNAL_OBJECT_ID SAP 内部対象キー (String)
EXTERNAL_OBJECT_ID SAP 外部対象キー (String)
MESSAGE_ID メッセージ ID (String)
MESSAGE_NUMBER システムメッセージ番号 (String)
MESSAGE_TYPE メッセージタイプ (String)
MESSAGE_TEXT メッセージのテキスト行 (String)

取得したWBS情報取得の詳細情報を読み込みエラー情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["METHOD"]　→　配列内のidx番目のWBS情報取得の詳細情報を読み込みエラーの「メソッド」
[idx]["OBJECT_TYPE"] 　→　配列内のidx番目のWBS情報取得の詳細情報を読み込みエラーの「オブジェクトタイプ」
[idx]["INTERNAL_OBJECT_ID"] 　→　配列内のidx番目のWBS情報取得の詳細情報を読み込みエラーの「SAP 内部対象キー」
[idx]["EXTERNAL_OBJECT_ID"] 　→　配列内のidx番目のWBS情報取得の詳細情報を読み込みエラーの「SAP 外部対象キー」
[idx]["MESSAGE_ID"] 　→　配列内のidx番目のWBS情報取得の詳細情報を読み込みエラーの「メッセージ ID」
[idx]["MESSAGE_NUMBER"] 　→　配列内のidx番目のWBS情報取得の詳細情報を読み込みエラーの「システムメッセージ番号」
[idx]["MESSAGE_TYPE"] 　→　配列内のidx番目のWBS情報取得の詳細情報を読み込みエラーの「メッセージタイプ」
[idx]["MESSAGE_TEXT"] 　→　配列内のidx番目のWBS情報取得の詳細情報を読み込みエラーの「メッセージのテキスト行」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getExpWbsElementList

Object getExpWbsElementList ()

WBS情報取得のWBS 要素についての詳細情報から値を取得します。
返却値
Object WBS 要素についての詳細情報

WBS情報取得のWBS 要素についての詳細情報オブジェクトの構成は以下のとおりです。
WBS情報取得のWBS 要素についての詳細情報
オブジェクト
(Object)
WBS_ELEMENT WBS 要素 (String)
PROJECT_DEFINITION プロジェクト定義 (String)
DESCRIPTION PS：テキスト(短)(第一テキスト行) (String)
SHORT_ID WBS 要素 ショート ID (String)
RESPONSIBLE_NO 責任者番号 (プロジェクト責任者) (String)
APPLICANT_NO 申請者番号 (String)
COMP_CODE 会社コード (String)
BUS_AREA 事業領域 (String)
CO_AREA 管理領域 (String)
PROFIT_CTR 利益センタ (String)
PROJ_TYPE プロジェクトタイプ (String)
NETWORK_ASSIGNMENT ネットワーク割当 (String)
COSTING_SHEET 原価計算表 (String)
OVERHEAD_KEY 間接費キー (String)
CALENDAR 稼動日カレンダ (String)
PRIORITY 優先度 (String)
EQUIPMENT 設備番号 (String)
FUNCTIONAL_LOCATION 機能場所 (String)
CURRENCY 通貨コード (String)
CURRENCY_ISO ISO 通貨コード (String)
PLANT プラント (String)
USER_FIELD_KEY ユーザ定義項目のキーワード ID (String)
USER_FIELD_CHAR20_1 20 文字の第 1 ユーザ項目 - WBS 要素 - (String)
USER_FIELD_CHAR20_2 20 桁の第 2 ユーザ項目 - WBS 要素 (String)
USER_FIELD_CHAR10_1 10 桁の第 3 ユーザ項目 - WBS 要素 (String)
USER_FIELD_CHAR10_2 10 桁の第 4 ユーザ項目 - WBS 要素 (String)
USER_FIELD_QUAN1 数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素 (String)
USER_FIELD_UNIT1 数量項目単位の第１ユーザ定義項目 - WBS 要素 (String)
USER_FIELD_UNIT1_ISO 単位の ISO コード (String)
USER_FIELD_QUAN2 数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素 (String)
USER_FIELD_UNIT2 数量項目単位の第２ユーザ定義項目 - WBS 要素 (String)
USER_FIELD_UNIT2_ISO 単位の ISO コード (String)
USER_FIELD_CURR1 値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素 (String)
USER_FIELD_CUKY1 値項目単位の第１ユーザ定義項目 - WBS 要素 (String)
USER_FIELD_CUKY1_ISO ISO 通貨コード (String)
USER_FIELD_CURR2 値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素 (String)
USER_FIELD_CUKY2 値項目単位の第２ユーザ定義項目 - WBS 要素 (String)
USER_FIELD_CUKY2_ISO ISO 通貨コード (String)
USER_FIELD_DATE1 日付の第 1 ユーザ項目 - WBS 要素 (String)
USER_FIELD_DATE2 日付の第 2 ユーザ項目 - WBS 要素 (String)
USER_FIELD_FLAG1 '評価区分' の第 1 ユーザ項目 - WBS 要素 (String)
USER_FIELD_FLAG2 '評価区分' の第 2 ユーザ項目 - WBS 要素 (String)
OBJECTCLASS 対象クラス (String)
STATISTICAL 統計 WBS 要素 (String)
TAXJURCODE 税計算管轄コード - 税管轄コード (String)
INT_PROFILE プロジェクト/指図金利計算の金利プロファイル (String)
JOINT_VENTURE ジョイントベンチャ (String)
RECOVERY_IND リカバリフラグ (String)
EQUITY_TYPE 持分タイプ (String)
JV_OBJECT_TYPE ジョイントベンチャ対象タイプ (String)
JV_JIB_CLASS JIB/JIBE クラス (String)
JV_JIB_SUB_CLASS_A JIB/JIBE サブクラスA (String)
DELETION_FLAG 削除フラグ (String)
OBJECTCLASS_EXT オブジェクトクラス、言語依存 (String)
WBS_PLANNING_ELEMENT 区分：計画要素 (String)
WBS_ACCOUNT_ASSIGNMENT_ELEMENT 区分：勘定設定要素 (String)
WBS_BILLING_ELEMENT 区分：請求要素 (String)
RESPSBL_CCTR 責任原価センタ (String)
RESPSBL_CCTR_CONTROLLING_AREA 責任原価センタの管理領域 (String)
REQUEST_CCTR 申請原価センタ (String)
REQUEST_COMP_CODE 会社コード要求 (String)
REQUEST_CCTR_CONTROLLING_AREA 依頼原価センタの管理領域 (String)
LOCATION 場所 (String)
CHANGE_NO 変更番号 (String)
INVEST_PROFILE 設備投資案件プロファイル (String)
RES_ANAL_KEY 結果分析キー (String)
WBS_CCTR_POSTED_ACTUAL 原価が実際に転記される原価センタ (String)
WBS_BASIC_START_DATE WBS 要素：基本開始日 (String)
WBS_BASIC_FINISH_DATE WBS 要素：基本終了日付 (String)
WBS_FORECAST_START_DATE WBS 要素の予測開始日 (String)
WBS_FORECAST_FINISH_DATE WBS 要素の予測済終了日付 (String)
WBS_ACTUAL_START_DATE WBS 要素の実績開始日付 (String)
WBS_ACTUAL_FINISH_DATE WBS 要素の実績終了日 (String)
WBS_BASIC_DURATION WBS 要素の基準日の長さ(期間) (String)
WBS_BASIC_DUR_UNIT 基準 WBS 要素日付の期間単位 (String)
WBS_BASIC_DUR_UNIT_ISO 単位の ISO コード (String)
WBS_FORECAST_DURATION WBS 要素の予測期間 (String)
WBS_FORCAST_DUR_UNIT WBS 要素計画日付の単位 (String)
WBS_FORECAST_DUR_UNIT_ISO 単位の ISO コード (String)
WBS_ACTUAL_DURATION WBS 要素の実績長(期間) (String)
WBS_ACTUAL_DUR_UNIT 実績 WBS 要素日付の期間単位 (String)
WBS_ACTUAL_DUR_UNIT_ISO 単位の ISO コード (String)
WBS_SCD_BASIC_START_DATE 最早計画開始日 (基準) (String)
WBS_SCD_BASIC_FINISH_DATE 最遅計画終了日 (基準) (String)
WBS_SCD_FORECAST_START_DATE 計画開始日 (予測) (String)
WBS_SCD_FORECAST_FINISH_DATE 最遅計画終了日 (予測) (String)
WBS_SCD_ACTUAL_START_DATE WBS 要素の仮実績開始日 (String)
WBS_SCD_ACTUAL_FINISH_DATE WBS 要素の仮実績終了日 (String)
FUNC_AREA 機能領域 (String)
FUNC_AREA_LONG 機能領域 (String)

取得したWBS情報取得のWBS 要素についての詳細情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["WBS_ELEMENT"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「WBS 要素」
[idx]["PROJECT_DEFINITION"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「プロジェクト定義」
[idx]["DESCRIPTION"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「PS：テキスト(短)(第一テキスト行)」
[idx]["SHORT_ID"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「WBS 要素 ショート ID」
[idx]["RESPONSIBLE_NO"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「責任者番号 (プロジェクト責任者)」
[idx]["APPLICANT_NO"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「申請者番号」
[idx]["COMP_CODE"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「会社コード」
[idx]["BUS_AREA"]　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「事業領域」
[idx]["CO_AREA"]　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「管理領域」
[idx]["PROFIT_CTR"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「利益センタ」
[idx]["PROJ_TYPE"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「プロジェクトタイプ」
[idx]["NETWORK_ASSIGNMENT"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「ネットワーク割当」
[idx]["COSTING_SHEET"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「原価計算表」
[idx]["OVERHEAD_KEY"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「間接費キー」
[idx]["CALENDAR"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「稼動日カレンダ」
[idx]["PRIORITY"]　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「優先度」
[idx]["EQUIPMENT"]　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「設備番号」
[idx]["FUNCTIONAL_LOCATION"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「機能場所」
[idx]["CURRENCY"]　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「通貨コード」
[idx]["CURRENCY_ISO"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「ISO 通貨コード」
[idx]["PLANT"]　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「プラント」
[idx]["USER_FIELD_KEY"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「ユーザ定義項目のキーワード ID」
[idx]["USER_FIELD_CHAR20_1"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の 「20 文字の第 1 ユーザ項目 - WBS 要素 -」
[idx]["USER_FIELD_CHAR20_2"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の 「20 桁の第 2 ユーザ項目 - WBS 要素」
[idx]["USER_FIELD_CHAR10_1"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の 「10 桁の第 3 ユーザ項目 - WBS 要素」
[idx]["USER_FIELD_CHAR10_2"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の 「10 桁の第 4 ユーザ項目 - WBS 要素」
[idx]["USER_FIELD_QUAN1"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の 「数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素」
[idx]["USER_FIELD_UNIT1"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の 「数量項目単位の第１ユーザ定義項目 - WBS 要素」
[idx]["USER_FIELD_UNIT1_ISO"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「単位の ISO コード」
[idx]["USER_FIELD_QUAN2"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の 「数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素」
[idx]["USER_FIELD_UNIT2"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の 「数量項目単位の第２ユーザ定義項目 - WBS 要素」
[idx]["USER_FIELD_UNIT2_ISO"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「単位の ISO コード」
[idx]["USER_FIELD_CURR1"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の 「値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素」
[idx]["USER_FIELD_CUKY1"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の 「値項目単位の第１ユーザ定義項目 - WBS 要素」
[idx]["USER_FIELD_CUKY1_ISO"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「ISO 通貨コード」
[idx]["USER_FIELD_CURR2"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の 「値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素」
[idx]["USER_FIELD_CUKY2"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の 「値項目単位の第２ユーザ定義項目 - WBS 要素」
[idx]["USER_FIELD_CUKY2_ISO"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「ISO 通貨コード」
[idx]["USER_FIELD_DATE1"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「日付の第 1 ユーザ項目 - WBS 要素」
[idx]["USER_FIELD_DATE2"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「日付の第 2 ユーザ項目 - WBS 要素」
[idx]["USER_FIELD_FLAG1"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の 「'評価区分' の第 1 ユーザ項目 - WBS 要素」
[idx]["USER_FIELD_FLAG2"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の 「'評価区分' の第 2 ユーザ項目 - WBS 要素」
[idx]["OBJECTCLASS"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「対象クラス」
[idx]["STATISTICAL"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「統計 WBS 要素」
[idx]["TAXJURCODE"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「税計算管轄コード - 税管轄コード」
[idx]["INT_PROFILE"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の 「プロジェクト/指図金利計算の金利プロファイル」
[idx]["JOINT_VENTURE"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「ジョイントベンチャ」
[idx]["RECOVERY_IND"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「リカバリフラグ」
[idx]["EQUITY_TYPE"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「持分タイプ」
[idx]["JV_OBJECT_TYPE"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「ジョイントベンチャ対象タイプ」
[idx]["JV_JIB_CLASS"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「JIB/JIBE クラス」
[idx]["JV_JIB_SUB_CLASS_A"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「JIB/JIBE サブクラスA」
[idx]["DELETION_FLAG"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「削除フラグ」
[idx]["OBJECTCLASS_EXT"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「オブジェクトクラス、言語依存」
[idx]["WBS_PLANNING_ELEMENT"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「区分：計画要素」
[idx]["WBS_ACCOUNT_ASSIGNMENT_ELEMENT"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「区分：勘定設定要素」
[idx]["WBS_BILLING_ELEMENT"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「区分：請求要素」
[idx]["RESPSBL_CCTR"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「責任原価センタ」
[idx]["RESPSBL_CCTR_CONTROLLING_AREA"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「責任原価センタの管理領域」
[idx]["REQUEST_CCTR"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「申請原価センタ」
[idx]["REQUEST_COMP_CODE"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「会社コード要求」
[idx]["REQUEST_CCTR_CONTROLLING_AREA"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「依頼原価センタの管理領域」
[idx]["LOCATION"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「場所」
[idx]["CHANGE_NO"]　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「変更番号」
[idx]["INVEST_PROFILE"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「設備投資案件プロファイル」
[idx]["RES_ANAL_KEY"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「結果分析キー」
[idx]["WBS_CCTR_POSTED_ACTUAL"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「原価が実際に転記される原価センタ」
[idx]["WBS_BASIC_START_DATE"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「WBS 要素：基本開始日」
[idx]["WBS_BASIC_FINISH_DATE"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「WBS 要素：基本終了日付」
[idx]["WBS_FORECAST_START_DATE"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「WBS 要素の予測開始日」
[idx]["WBS_FORECAST_FINISH_DATE"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「WBS 要素の予測済終了日付」
[idx]["WBS_ACTUAL_START_DATE"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「WBS 要素の実績開始日付」
[idx]["WBS_ACTUAL_FINISH_DATE"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「WBS 要素の実績終了日」
[idx]["WBS_BASIC_DURATION"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「WBS 要素の基準日の長さ(期間)」
[idx]["WBS_BASIC_DUR_UNIT"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「基準 WBS 要素日付の期間単位」
[idx]["WBS_BASIC_DUR_UNIT_ISO"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「単位の ISO コード」
[idx]["WBS_FORECAST_DURATION"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「WBS 要素の予測期間」
[idx]["WBS_FORCAST_DUR_UNIT"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「WBS 要素計画日付の単位」
[idx]["WBS_FORECAST_DUR_UNIT_ISO"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「単位の ISO コード」
[idx]["WBS_ACTUAL_DURATION"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「WBS 要素の実績長(期間)」
[idx]["WBS_ACTUAL_DUR_UNIT"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「実績 WBS 要素日付の期間単位」
[idx]["WBS_ACTUAL_DUR_UNIT_ISO"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「単位の ISO コード」
[idx]["WBS_SCD_BASIC_START_DATE"] 　→　配列内のidx番目のWBS情報取得 のWBS 要素についての詳細の「最早計画開始日 (基準)」
[idx]["WBS_SCD_BASIC_FINISH_DATE"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「最遅計画終了日 (基準)」
[idx]["WBS_SCD_FORECAST_START_DATE"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「計画開始日 (予測)」
[idx]["WBS_SCD_FORECAST_FINISH_DATE"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「最遅計画終了日 (予測)」
[idx]["WBS_SCD_ACTUAL_START_DATE"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「WBS 要素の仮実績開始日」
[idx]["WBS_SCD_ACTUAL_FINISH_DATE"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「WBS 要素の仮実績終了日」
[idx]["FUNC_AREA"]　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「機能領域」
[idx]["FUNC_AREA_LONG"] 　→　配列内のidx番目のWBS情報取得のWBS 要素についての詳細の「機能領域」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getExpWbsHierarchieList

Object getExpWbsHierarchieList ()

WBS情報取得のWBS 階層についての情報から値を取得します。
返却値
Object WBS 階層についての情報

WBS情報取得のWBS 階層についての情報オブジェクトの構成は以下のとおりです。
WBS情報取得のWBS 階層についての情報
オブジェクト
(Object)
WBS_ELEMENT WBS 要素 (String)
PROJECT_DEFINITION プロジェクト定義 (String)
UP WBS 要素 (String)
DOWN WBS 要素 (String)
LEFT WBS 要素 (String)
RIGHT WBS 要素 (String)

取得したWBS情報取得のWBS 階層情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["WBS_ELEMENT"]　→　配列内のidx番目のWBS情報取得のWBS 階層の「WBS 要素」
[idx]["PROJECT_DEFINITION"] 　→　配列内のidx番目のWBS情報取得のWBS 階層の「プロジェクト定義」
[idx]["UP"]　→　配列内のidx番目のWBS情報取得のWBS 階層の「WBS 要素」
[idx]["DOWN"]　→　配列内のidx番目のWBS情報取得のWBS 階層の「WBS 要素」
[idx]["LEFT"]　→　配列内のidx番目のWBS情報取得のWBS 階層の「WBS 要素」
[idx]["RIGHT"]　→　配列内のidx番目のWBS情報取得のWBS 階層の「WBS 要素」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getExpWbsMilestoneList

Object getExpWbsMilestoneList ()

WBS情報取得のWBS マイルストーンに関する詳細情報から値を取得します。
返却値
Object WBS マイルストーンに関する詳細情報

WBS情報取得のWBS マイルストーンに関する詳細情報オブジェクトの構成は以下のとおりです。
WBS情報取得のWBS マイルストーンに関する詳細情報
オブジェクト
(Object)
MILESTONE_NUMBER マイルストーン番号 (String)
WBS_ELEMENT WBS 要素 (String)
MILESTONE_USAGE マイルストーン用途 (String)
DESCRIPTION テキスト (String)
SCHED_MILESTONE_DATE_BASIC マイルストーン計画日(基準) (String)
SCHED_MILESTONE_TIME_BASIC マイルストーン計画時間(基準) (String)
SCHED_MILESTONE_DATE_FORECAST マイルストーン計画日(予測) (String)
SCHED_MILESTONE_TIME_FORECAST マイルストーン計画時間(予測) (String)
FIXED_MILESTONE_DATE_BASIC 固定マイルストーン日付(基準) (String)
FIXED_MILESTONE_TIME_BASIC 固定マイルストーン時間(基準) (String)
FIXED_MILESTONE_DATE_FORECAST マイルストーン固定日付 (String)
FIXED_MILESTONE_TIME_FORECAST マイルストーン固定時間 (F) (String)
ACTUAL_DATE 実績日付(マイルストーン通過) (String)
ACTUAL_TIME 実績日/時間(マイルストーン適合) (String)
LATEST_DATES_INDICATOR 区分：最遅日 (String)
OFFSET_START_END_INDICATOR 区分：オフセット用の参照（開始/終了活動日） (String)
OFFSET_MILESTONE_DATE マイルストーン日付のオフセット (String)
OFFSET_MILESTONE_DATE_UNIT マイルストーンのオフセットのための時間単位 (String)
OFFSET_MILESTONE_DATE_UNIT_ISO 単位の ISO コード (String)
OFFSET_PERCENTAGE 活動日に対するマイルストーンの百分率によるオフセット (String)
TREND_ANALYSIS_INDICATOR 傾向分析の関連マイルストーン (String)
EARNED_VALUE_INDICATOR 進捗分析関連のマイルストーン (String)
PERCENTAGE_OF_COMPLETION 進捗度 (%) (String)
SALES_DOC_DATE_INIDICATOR 販売伝票の日付に関連するマイルストーン (String)
INVOICE_PERCENTAGE 請求金額率 (%) (String)
DELETION_FLAG 削除フラグ (String)

取得したWBS情報取得のWBS マイルストーンに関する詳細情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["MILESTONE_NUMBER"] 　→　配列内のidx番目のWBS情報取得のWBS マイルストーンに関する詳細の「マイルストーン番号」
[idx]["WBS_ELEMENT"] 　→　配列内のidx番目のWBS情報取得のWBS マイルストーンに関する詳細の「WBS 要素」
[idx]["MILESTONE_USAGE"] 　→　配列内のidx番目のWBS情報取得のWBS マイルストーンに関する詳細の「マイルストーン用途」
[idx]["DESCRIPTION"] 　→　配列内のidx番目のxxxxxの「テキスト」
[idx]["SCHED_MILESTONE_DATE_BASIC"] 　→　配列内のidx番目のWBS情報取得のWBS マイルストーンに関する詳細の「マイルストーン計画日(基準)」
[idx]["SCHED_MILESTONE_TIME_BASIC"] 　→　配列内のidx番目のWBS情報取得のWBS マイルストーンに関する詳細の「マイルストーン計画時間(基準)」
[idx]["SCHED_MILESTONE_DATE_FORECAST"] 　→　配列内のidx番目のWBS情報取得のWBS マイルストーンに関する詳細の「マイルストーン計画日(予測)」
[idx]["SCHED_MILESTONE_TIME_FORECAST"] 　→　配列内のidx番目のWBS情報取得のWBS マイルストーンに関する詳細の「マイルストーン計画時間(予測)」
[idx]["FIXED_MILESTONE_DATE_BASIC"] 　→　配列内のidx番目のWBS情報取得のWBS マイルストーンに関する詳細の「固定マイルストーン日付(基準)」
[idx]["FIXED_MILESTONE_TIME_BASIC"] 　→　配列内のidx番目のWBS情報取得のWBS マイルストーンに関する詳細の「固定マイルストーン時間(基準)」
[idx]["FIXED_MILESTONE_DATE_FORECAST"] 　→　配列内のidx番目のWBS情報取得のWBS マイルストーンに関する詳細の「マイルストーン固定日付」
[idx]["FIXED_MILESTONE_TIME_FORECAST"] 　→　配列内のidx番目のWBS情報取得のWBS マイルストーンに関する詳細の「マイルストーン固定時間 (F)」
[idx]["ACTUAL_DATE"] 　→　配列内のidx番目のWBS情報取得のWBS マイルストーンに関する詳細の「実績日付(マイルストーン通過)」
[idx]["ACTUAL_TIME"] 　→　配列内のidx番目のWBS情報取得のWBS マイルストーンに関する詳細の「実績日/時間(マイルストーン適合)」
[idx]["LATEST_DATES_INDICATOR"] 　→　配列内のidx番目のWBS情報取得のWBS マイルストーンに関する詳細の「区分：最遅日」
[idx]["OFFSET_START_END_INDICATOR"] 　→　配列内のidx番目のWBS情報取得のWBS マイルストーンに関する詳細の 「区分：オフセット用の参照（開始/終了活動日）」
[idx]["OFFSET_MILESTONE_DATE"] 　→　配列内のidx番目のWBS情報取得のWBS マイルストーンに関する詳細の「マイルストーン日付のオフセット」
[idx]["OFFSET_MILESTONE_DATE_UNIT"] 　→　配列内のidx番目のWBS情報取得のWBS マイルストーンに関する詳細の 「マイルストーンのオフセットのための時間単位」
[idx]["OFFSET_MILESTONE_DATE_UNIT_ISO"] 　→　配列内のidx番目のWBS情報取得のWBS マイルストーンに関する詳細の「単位の ISO コード」
[idx]["OFFSET_PERCENTAGE"] 　→　配列内のidx番目のWBS情報取得のWBS マイルストーンに関する詳細の 「活動日に対するマイルストーンの百分率によるオフセット」
[idx]["TREND_ANALYSIS_INDICATOR"] 　→　配列内のidx番目のWBS情報取得のWBS マイルストーンに関する詳細の「傾向分析の関連マイルストーン」
[idx]["EARNED_VALUE_INDICATOR"] 　→　配列内のidx番目のWBS情報取得のWBS マイルストーンに関する詳細の「進捗分析関連のマイルストーン」
[idx]["PERCENTAGE_OF_COMPLETION"] 　→　配列内のidx番目のWBS情報取得のWBS マイルストーンに関する詳細の「進捗度 (%)」
[idx]["SALES_DOC_DATE_INIDICATOR"] 　→　配列内のidx番目のWBS情報取得のWBS マイルストーンに関する詳細の 「販売伝票の日付に関連するマイルストーン」
[idx]["INVOICE_PERCENTAGE"] 　→　配列内のidx番目のWBS情報取得のWBS マイルストーンに関する詳細の「請求金額率 (%)」
[idx]["DELETION_FLAG"] 　→　配列内のidx番目のWBS情報取得のWBS マイルストーンに関する詳細の「削除フラグ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getImpWbsElementList

Object getImpWbsElementList ()

WBS情報取得の詳細情報を必要とする WBS 要素から値を取得します。
返却値
Object 詳細情報を必要とする WBS 要素

WBS情報取得の詳細情報オブジェクトの構成は以下のとおりです。
WBS情報取得の詳細情報
オブジェクト
(Object)
WBS_ELEMENT WBS 要素 (String)

取得したWBS情報取得の詳細情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["WBS_ELEMENT"]　→　配列内のidx番目のWBS情報取得の詳細の「WBS 要素」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getProjectDefinition

Object getProjectDefinition ()

WBS情報取得のプロジェクト定義を識別するキーから値を取得します。
返却値
Object プロジェクト定義を識別するキー
(成功時の返却値は String になります。)

(失敗時)　エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1:　認証系システムエラー
2:　認証系アプリケーションエラー
3:　汎用系システムエラー
4:　汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getProjectDefinitionInfo

Object getProjectDefinitionInfo ()

プロジェクトについての詳細情報を取得します。
返却値
Object プロジェクトについての詳細情報

プロジェクトについての詳細情報オブジェクトの構成は以下のとおりです。
プロジェクトについての詳細情報
オブジェクト
(Object)
PROJECT_DEFINITION プロジェクト定義 (String)
DESCRIPTION PS：テキスト(短)(第一テキスト行) (String)
MASK_ID WBS 要素 ID(短)の選択マスク (String)
RESPONSIBLE_NO 責任者番号 (プロジェクト責任者) (String)
APPLICANT_NO 申請者番号 (String)
COMP_CODE 会社コード (String)
BUS_AREA 事業領域 (String)
CONTROLLING_AREA 管理領域 (String)
PROFIT_CTR 利益センタ (String)
PROJECT_CURRENCY WBS 通貨(プロジェクト定義) (String)
PROJECT_CURRENCY_ISO ISO 通貨コード (String)
NETWORK_ASSIGNMENT ネットワーク割当 (String)
START プロジェクト計画開始日付 (String)
FINISH プロジェクトの計画終了日 (String)
PLANT プラント (String)
CALENDAR 稼動日カレンダ (String)
PLAN_BASIC プロジェクト基準日付計画方法 (String)
PLAN_FCST プロジェクト予測日付の計画方法 (String)
TIME_UNIT 時間計画単位 (String)
TIME_UNIT_ISO 単位の ISO コード (String)
NETWORK_PROFILE ネットワークプロファイル (String)
PROJECT_PROFILE プロジェクトプロファイル (String)
BUDGET_PROFILE 予算プロファイル (String)
PROJECT_STOCK プロジェクト在庫 (String)
OBJECTCLASS 対象クラス (String)
STATISTICAL 統計 WBS 要素 (String)
TAXJURCODE 税計算管轄コード - 税管轄コード (String)
INT_PROFILE プロジェクト/指図金利計算の金利プロファイル (String)
WBS_SCHED_PROFILE WBS 日程計画のプロファイル (String)
CSH_BDGT_PROFILE 資金計画プロファイル (String)
PLAN_PROFILE 計画プロファイル (String)
JOINT_VENTURE ジョイントベンチャ (String)
RECOVERY_IND リカバリフラグ (String)
EQUITY_TYPE 持分タイプ (String)
JV_OBJECT_TYPE ジョイントベンチャ対象タイプ (String)
JV_JIB_CLASS JIB/JIBE クラス (String)
JV_JIB_SUB_CLASS_A JIB/JIBE サブクラスA (String)
DELETION_FLAG 削除フラグ (String)
OBJECTCLASS_EXT オブジェクトクラス、言語依存 (String)
FUNC_AREA 機能領域 (String)
FUNC_AREA_LONG 機能領域 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getWithActivities

Object getWithActivities ()

WBS情報取得の従属活動がエクスポートから値を取得します。
返却値
Object 従属活動がエクスポート
(成功時の返却値は String になります。)

(失敗時)　エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1:　認証系システムエラー
2:　認証系アプリケーションエラー
3:　汎用系システムエラー
4:　汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getWithMilestones

Object getWithMilestones ()

WBS情報取得の従属 WBS マイルストーンがエクスポートから値を取得します。
返却値
Object 従属 WBS マイルストーンがエクスポート
(成功時の返却値は String になります。)

(失敗時)　エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1:　認証系システムエラー
2:　認証系アプリケーションエラー
3:　汎用系システムエラー
4:　汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getWithSubtree

Object getWithSubtree ()

WBS情報取得のサブプロジェクトがエクスポートから値を取得します。
返却値
Object サブプロジェクトがエクスポート
(成功時の返却値は String になります。)

(失敗時)　エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1:　認証系システムエラー
2:　認証系アプリケーションエラー
3:　汎用系システムエラー
4:　汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

setProjectDefinition

void setProjectDefinition (String value)

WBS情報取得のプロジェクト定義を識別するキーに値を設定します。
パラメータ
value String プロジェクト定義を識別するキー
返却値
void
setTblParam

void setTblParam (String paramTable ,String paramName ,String value ,int index)

テーブル型の項目に値をセットします。
パラメータ
paramTable | String | テーブル名
paramName | String | 項目名
value | String | セットする値
index | int | レコード番号
返却値
void
setWithActivities

void setWithActivities (String value)

WBS情報取得の従属活動がエクスポートに値を設定します。
パラメータ
value String 従属活動がエクスポート
返却値
void
setWithMilestones

void setWithMilestones (String value)

WBS情報取得の従属 WBS マイルストーンがエクスポートに値を設定します。
パラメータ
value String 従属 WBS マイルストーンがエクスポート
返却値
void
setWithSubtree

void setWithSubtree (String value)

WBS情報取得のサブプロジェクトがエクスポートに値を設定します。
パラメータ
value String サブプロジェクトがエクスポート
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 PurchaseGetItemSrelController オブジェクト

伝票承認対象一覧取得コントローラクラス。

機能は以下の通り
  • 伝票承認対象一覧を取得します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
PurchaseGetItemSrelController (String relGroup ,String relCode ,String itemForRelease)
コンストラクタ｡
PurchaseGetItemSrelController (String relGroup ,String relCode ,String itemForRelease ,SapClient sapClient)
コンストラクタ。
メソッドの概要
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
Object | getItemsForRelease () 区分：承認待ち購買発注のみ照会を取得します。
Object | getPurchaseGetItemSrel () 承認対象一覧情報を取得します｡
Object | getPurchaseHeadersList () ヘッダ一覧を取得します｡
Object | getPurchaseItemsList () 明細一覧を取得します｡
Object | getRelCode () 承認コードを取得します。
Object | getRelGroup () 承認グループを取得します。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
PurchaseGetItemSrelController

PurchaseGetItemSrelController (String relGroup ,String relCode ,String itemForRelease)
コンストラクタ｡
パラメータ
relGroup | String | 承認グループ
relCode | String | 承認コード
itemForRelease | String | 照会区分
PurchaseGetItemSrelController

PurchaseGetItemSrelController (String relGroup ,String relCode ,String itemForRelease ,SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
relGroup | String | 承認グループ
relCode | String | 承認コード
itemForRelease | String | 照会区分
sapClient | SapClient | Sapクライアント
メソッドの詳細
getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getItemsForRelease

Object getItemsForRelease ()

区分：承認待ち購買発注のみ照会を取得します。

返却値
Object 区分：承認待ち購買発注のみ照会
getPurchaseGetItemSrel

Object getPurchaseGetItemSrel ()

承認対象一覧情報を取得します｡

返却値
Object 承認対象一覧
getPurchaseHeadersList

Object getPurchaseHeadersList ()

ヘッダ一覧を取得します｡
返却値
Object ヘッダ一覧

ヘッダ情報オブジェクトの構成は以下のとおりです。
ヘッダ情報
オブジェクト
(Object)
PO_NUMBER 購買伝票番号 (String)
CO_CODE 会社コード (String)
DOC_CAT 購買伝票カテゴリ (String)
DOC_TYPE 購買伝票タイプ (String)
CNTRL_IND 購買伝票タイプに対する管理区分 (String)
DELETE_IND 購買伝票の削除フラグ (String)
STATUS 購買伝票のステータス (String)
CREATED_ON レコード登録日 (String)
CREATED_BY オブジェクト登録者名 (String)
ITEM_INTVL 明細番号間隔 (String)
LAST_ITEM 最終明細番号 (String)
VENDOR 仕入先勘定コード (String)
LANGUAGE 言語キー (String)
PMNTTRMS 支払条件キー (String)
DSCNT1_TO 現金割引日数 1 (String)
DSCNT2_TO 現金割引期間 2 (日数) (String)
DSCNT3_TO 現金値引期間 3 (String)
CASH_DISC1 割引率 1 (String)
CASH_DISC2 割引率 2 (String)
PURCH_ORG 購買組織 (String)
PUR_GROUP 購買グループ (String)
CURRENCY 通貨コード (String)
EXCH_RATE 直接呼び値換算レート (String)
EX_RATE_FX 区分：換算レート固定 (String)
DOC_DATE 購買伝票日付 (String)
VPER_START 有効期間開始日 (String)
VPER_END 有効期間の終了日 (String)
APPLIC_BY 見積提出期限 (String)
QUOT_DEAD 見積提出期限 (String)
BINDG_PER 見積有効期間 (String)
WARRANTY 保証日 (String)
BIDINV_NO 見積管理番号 (String)
QUOTATION 見積番号 (String)
QUOT_DATE 見積提出日 (String)
REF_1 得意先/仕入先の内部参照コード (String)
SALES_PERS 仕入先営業担当者 (String)
TELEPHONE 仕入先電話番号 (String)
SUPPL_VEND 供給仕入先 (String)
CUSTOMER 得意先コード 1 (String)
AGREEMENT 購買契約番号 (String)
REJ_REASON 見積および受注の拒否理由 (String)
COMPL_DLV 全購買発注に対する一括納入指定 (String)
GR_MESSAGE 区分：入庫メッセージ (String)
SUPPL_PLNT 在庫転送オーダーにおける供給 (出庫) プラント (String)
RCVG_VEND 未使用項目 (String)
INCOTERMS1 インコタームズ (1) (String)
INCOTERMS2 インコタームズ 2 (String)
TARGET_VAL 累積計画金額 (String)
COLL_NO 一括番号 (String)
DOC_COND 伝票条件番号 (String)
PROCEDURE 決定表 (価格設定/出力管理/勘定設定/原価計算など) (String)
UPDATE_GRP 統計更新の更新グループ (String)
DIFF_INV 仕入先と請求元が異なる場合の請求元のコード (String)
EXPORT_NO 貿易データ番号：MM/SD 伝票 (String)
OUR_REF 社内参照番号 (String)
LOGSYSTEM 論理システム (String)
SUBITEMINT 副明細の明細間隔 (String)
MAST_COND 期間依存条件伝票 (String)
REL_GROUP 承認グループ (String)
REL_STRAT 承認方針 (String)
REL_IND 承認区分：購買伝票 (String)
REL_STATUS 承認状況 (String)
SUBJ_TO_R 承認未完了 (String)
TAXR_CNTRY 納税申告書の国 (String)
SCHED_IND 分納契約のリリース伝票区分 (String)
VEND_NAME 名称 1 (String)
CURRENCY_ISO ISO 通貨コード (String)
EXCH_RATE_CM 間接呼び値換算レート (String)
HOLD 購買発注の不完全 (String)

取得したヘッダ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_NUMBER"]　→　配列内のidx番目のヘッダの「購買伝票番号」
[idx]["CO_CODE"]　→　配列内のidx番目のヘッダの「会社コード」
[idx]["DOC_CAT"]　→　配列内のidx番目のヘッダの「購買伝票カテゴリ」
[idx]["DOC_TYPE"]　→　配列内のidx番目のヘッダの「購買伝票タイプ」
[idx]["CNTRL_IND"]　→　配列内のidx番目のヘッダの「購買伝票タイプに対する管理区分」
[idx]["DELETE_IND"]　→　配列内のidx番目のヘッダの「購買伝票の削除フラグ」
[idx]["STATUS"]　→　配列内のidx番目のヘッダの「購買伝票のステータス」
[idx]["CREATED_ON"]　→　配列内のidx番目のヘッダの「レコード登録日」
[idx]["CREATED_BY"]　→　配列内のidx番目のヘッダの「オブジェクト登録者名」
[idx]["ITEM_INTVL"]　→　配列内のidx番目のヘッダの「明細番号間隔」
[idx]["LAST_ITEM"]　→　配列内のidx番目のヘッダの「最終明細番号」
[idx]["VENDOR"]　→　配列内のidx番目のヘッダの「仕入先勘定コード」
[idx]["LANGUAGE"]　→　配列内のidx番目のヘッダの「言語キー」
[idx]["PMNTTRMS"]　→　配列内のidx番目のヘッダの「支払条件キー」
[idx]["DSCNT1_TO"]　→　配列内のidx番目のヘッダの「現金割引日数 1」
[idx]["DSCNT2_TO"]　→　配列内のidx番目のヘッダの「現金割引期間 2 (日数)」
[idx]["DSCNT3_TO"]　→　配列内のidx番目のヘッダの「現金値引期間 3」
[idx]["CASH_DISC1"]　→　配列内のidx番目のヘッダの「割引率 1」
[idx]["CASH_DISC2"]　→　配列内のidx番目のヘッダの「割引率 2」
[idx]["PURCH_ORG"]　→　配列内のidx番目のヘッダの「購買組織」
[idx]["PUR_GROUP"]　→　配列内のidx番目のヘッダの「購買グループ」
[idx]["CURRENCY"]　→　配列内のidx番目のヘッダの「通貨コード」
[idx]["EXCH_RATE"]　→　配列内のidx番目のヘッダの「直接呼び値換算レート」
[idx]["EX_RATE_FX"]　→　配列内のidx番目のヘッダの「区分：換算レート固定」
[idx]["DOC_DATE"]　→　配列内のidx番目のヘッダの「購買伝票日付」
[idx]["VPER_START"]　→　配列内のidx番目のヘッダの「有効期間開始日」
[idx]["VPER_END"]　→　配列内のidx番目のヘッダの「有効期間の終了日」
[idx]["APPLIC_BY"]　→　配列内のidx番目のヘッダの「見積提出期限」
[idx]["QUOT_DEAD"]　→　配列内のidx番目のヘッダの「見積提出期限」
[idx]["BINDG_PER"]　→　配列内のidx番目のヘッダの「見積有効期間」
[idx]["WARRANTY"]　→　配列内のidx番目のヘッダの「保証日」
[idx]["BIDINV_NO"]　→　配列内のidx番目のヘッダの「見積管理番号」
[idx]["QUOTATION"]　→　配列内のidx番目のヘッダの「見積番号」
[idx]["QUOT_DATE"]　→　配列内のidx番目のヘッダの「見積提出日」
[idx]["REF_1"]　→　配列内のidx番目のヘッダの「得意先/仕入先の内部参照コード」
[idx]["SALES_PERS"]　→　配列内のidx番目のヘッダの「仕入先営業担当者」
[idx]["TELEPHONE"]　→　配列内のidx番目のヘッダの「仕入先電話番号」
[idx]["SUPPL_VEND"]　→　配列内のidx番目のヘッダの「供給仕入先」
[idx]["CUSTOMER"]　→　配列内のidx番目のヘッダの「得意先コード 1」
[idx]["AGREEMENT"]　→　配列内のidx番目のヘッダの「購買契約番号」
[idx]["REJ_REASON"]　→　配列内のidx番目のヘッダの「見積および受注の拒否理由」
[idx]["COMPL_DLV"]　→　配列内のidx番目のヘッダの「全購買発注に対する一括納入指定」
[idx]["GR_MESSAGE"]　→　配列内のidx番目のヘッダの「区分：入庫メッセージ」
[idx]["SUPPL_PLNT"]　→ 　配列内のidx番目のヘッダの「在庫転送オーダーにおける供給 (出庫) プラント」
[idx]["RCVG_VEND"]　→　配列内のidx番目のヘッダの「未使用項目」
[idx]["INCOTERMS1"]　→　配列内のidx番目のヘッダの「インコタームズ (1)」
[idx]["INCOTERMS2"]　→　配列内のidx番目のヘッダの「インコタームズ 2」
[idx]["TARGET_VAL"]　→　配列内のidx番目のヘッダの「累積計画金額」
[idx]["COLL_NO"]　→　配列内のidx番目のヘッダの「一括番号」
[idx]["DOC_COND"]　→　配列内のidx番目のヘッダの「伝票条件番号」
[idx]["PROCEDURE"]　→ 　配列内のidx番目のヘッダの「決定表 (価格設定/出力管理/勘定設定/原価計算など)」
[idx]["UPDATE_GRP"]　→　配列内のidx番目のヘッダの「統計更新の更新グループ」
[idx]["DIFF_INV"]　→　配列内のidx番目のヘッダの「仕入先と請求元が異なる場合の請求元のコード」
[idx]["EXPORT_NO"]　→　配列内のidx番目のヘッダの「貿易データ番号：MM/SD 伝票」
[idx]["OUR_REF"]　→　配列内のidx番目のヘッダの「社内参照番号」
[idx]["LOGSYSTEM"]　→　配列内のidx番目のヘッダの「論理システム」
[idx]["SUBITEMINT"]　→　配列内のidx番目のヘッダの「副明細の明細間隔」
[idx]["MAST_COND"]　→　配列内のidx番目のヘッダの「期間依存条件伝票」
[idx]["REL_GROUP"]　→　配列内のidx番目のヘッダの「承認グループ」
[idx]["REL_STRAT"]　→　配列内のidx番目のヘッダの「承認方針」
[idx]["REL_IND"]　→　配列内のidx番目のヘッダの「承認区分：購買伝票」
[idx]["REL_STATUS"]　→　配列内のidx番目のヘッダの「承認状況」
[idx]["SUBJ_TO_R"]　→　配列内のidx番目のヘッダの「承認未完了」
[idx]["TAXR_CNTRY"]　→　配列内のidx番目のヘッダの「納税申告書の国」
[idx]["SCHED_IND"]　→　配列内のidx番目のヘッダの「分納契約のリリース伝票区分」
[idx]["VEND_NAME"]　→　配列内のidx番目のヘッダの「名称 1」
[idx]["CURRENCY_ISO"]　→　配列内のidx番目のヘッダの「ISO 通貨コード」
[idx]["EXCH_RATE_CM"]　→　配列内のidx番目のヘッダの「間接呼び値換算レート」
[idx]["HOLD"]　→　配列内のidx番目のヘッダの「購買発注の不完全」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPurchaseItemsList

Object getPurchaseItemsList ()

明細一覧を取得します｡
返却値
Object 明細一覧

明細情報オブジェクトの構成は以下のとおりです。
明細情報
オブジェクト
(Object)
PO_NUMBER 購買伝票番号 (String)
PO_ITEM 購買伝票の明細番号 (String)
ADDRESS 住所 (String)
MATERIAL 品目コード (String)
PUR_MAT 品目コード (String)
INFO_REC 購買情報番号 (String)
ITEM_CAT 購買伝票の明細カテゴリ (String)
ACCTASSCAT 勘定設定カテゴリ (String)
AGREEMENT 購買契約番号 (String)
AGMT_ITEM 購買契約の明細番号 (String)
STORE_LOC 保管場所 (String)
MAT_GRP 品目グループ (String)
SHORT_TEXT テキスト (短) (String)
DISTRIB 複数勘定設定の配賦区分 (String)
PART_INV 一部請求区分 (String)
KANBAN_IND かんばん区分 (String)
PLANT プラント (String)
ALLOC_TBL 商品配分表番号 (String)
AT_ITEM 割当テーブルの明細番号 (String)
UNIT 発注単位 (String)
NET_PRICE 購買伝票における正味価格 (伝票通貨) (String)
PRICE_UNIT 価格単位 (String)
CONV_NUM1 購買価格単位から購買発注単位への変換分子 (String)
CONV_DEN1 購買価格単位から購買発注単位への変換分母 (String)
ORDERPR_UN 購買発注価格単位 (購買管理) (String)
PCKG_NO パッケージ番号 (String)
PROMOTION プロモーション (String)
ACKN_REQD 購買発注請書依頼 (String)
TRACKINGNO 購買依頼追跡番号 (String)
PLAN_DEL 予定納入日数 (String)
RET_ITEM 返品明細 (String)
AT_RELEV 割当テーブル関連 (String)
VEND_MAT 仕入先の品目コード (String)
MANUF_PROF 製造者製品プロファイル (String)
MANU_MAT 製造者製品コード (String)
MFR_NO 製造者番号 (String)
MFR_NO_EXT 外部製造者コード名または番号 (String)
PO_PRICE 区分：価格採用 - 購買情報不使用 (String)
SHIPPING 出荷指示 (String)
ITEM_CAT_EXT 購買伝票の明細カテゴリ (String)
PO_UNIT_ISO ISO コードによる発注単位 (String)
ORDERPR_UN_ISO 購買発注価格単位の ISO コード (String)
PREQ_NAME 購買依頼者名/要求者名 (String)
DISP_QUAN 購買発注数量：表示目的全納入日程合計 (String)
QUAL_INSP 在庫タイプ (String)
NO_MORE_GR 納入完了 区分 (String)
DELETE_IND 購買伝票の削除フラグ (String)
NO_ROUNDING 区分：購買発注明細での非表示丸め (String)
TAX_CODE 消費税コード (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード (長) (今後のリリースで開発) (String)
MATERIAL_GUID 項目 MATERIAL の外部 GUID (今後のリリースで開発) (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (今後のリリースで開発) (String)
PUR_MAT_EXTERNAL 項目 PUR_MAT の品目コード (長) (今後のリリースで開発) (String)
PUR_MAT_GUID 項目 PUR_MAT の外部 GUID (今後のリリースで開発) (String)
PUR_MAT_VERSION 項目 PUR_MAT のバージョン番号 (今後のリリースで開発) (String)
VAL_TYPE 評価タイプ (String)
PR_CLOSED 購買依頼処理済 (String)
ACKNOWL_NO 購買発注請書番号 (String)

取得した明細情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_NUMBER"]　→　配列内のidx番目の明細の「購買伝票番号」
[idx]["PO_ITEM"]　→　配列内のidx番目の明細の「購買伝票の明細番号」
[idx]["ADDRESS"]　→　配列内のidx番目の明細の「住所」
[idx]["MATERIAL"]　→　配列内のidx番目の明細の「品目コード」
[idx]["PUR_MAT"]　→　配列内のidx番目の明細の「品目コード」
[idx]["INFO_REC"]　→　配列内のidx番目の明細の「購買情報番号」
[idx]["ITEM_CAT"]　→　配列内のidx番目の明細の「購買伝票の明細カテゴリ」
[idx]["ACCTASSCAT"]　→　配列内のidx番目の明細の「勘定設定カテゴリ」
[idx]["AGREEMENT"]　→　配列内のidx番目の明細の「購買契約番号」
[idx]["AGMT_ITEM"]　→　配列内のidx番目の明細の「購買契約の明細番号」
[idx]["STORE_LOC"]　→　配列内のidx番目の明細の「保管場所」
[idx]["MAT_GRP"]　→　配列内のidx番目の明細の「品目グループ」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の明細の「テキスト (短)」
[idx]["DISTRIB"]　→　配列内のidx番目の明細の「複数勘定設定の配賦区分」
[idx]["PART_INV"]　→　配列内のidx番目の明細の「一部請求区分」
[idx]["KANBAN_IND"]　→　配列内のidx番目の明細の「かんばん区分」
[idx]["PLANT"]　→　配列内のidx番目の明細の「プラント」
[idx]["ALLOC_TBL"]　→　配列内のidx番目の明細の「商品配分表番号」
[idx]["AT_ITEM"]　→　配列内のidx番目の明細の「割当テーブルの明細番号」
[idx]["UNIT"]　→　配列内のidx番目の明細の「発注単位」
[idx]["NET_PRICE"]　→　配列内のidx番目の明細の「購買伝票における正味価格 (伝票通貨)」
[idx]["PRICE_UNIT"]　→　配列内のidx番目の明細の「価格単位」
[idx]["CONV_NUM1"]　→　配列内のidx番目の明細の「購買価格単位から購買発注単位への変換分子」
[idx]["CONV_DEN1"]　→　配列内のidx番目の明細の「購買価格単位から購買発注単位への変換分母」
[idx]["ORDERPR_UN"]　→　配列内のidx番目の明細の「購買発注価格単位 (購買管理)」
[idx]["PCKG_NO"]　→　配列内のidx番目の明細の「パッケージ番号」
[idx]["PROMOTION"]　→　配列内のidx番目の明細の「プロモーション」
[idx]["ACKN_REQD"]　→　配列内のidx番目の明細の「購買発注請書依頼」
[idx]["TRACKINGNO"]　→　配列内のidx番目の明細の「購買依頼追跡番号」
[idx]["PLAN_DEL"]　→　配列内のidx番目の明細の「予定納入日数」
[idx]["RET_ITEM"]　→　配列内のidx番目の明細の「返品明細」
[idx]["AT_RELEV"]　→　配列内のidx番目の明細の「割当テーブル関連」
[idx]["VEND_MAT"]　→　配列内のidx番目の明細の「仕入先の品目コード」
[idx]["MANUF_PROF"]　→　配列内のidx番目の明細の「製造者製品プロファイル」
[idx]["MANU_MAT"]　→　配列内のidx番目の明細の「製造者製品コード」
[idx]["MFR_NO"]　→　配列内のidx番目の明細の「製造者番号」
[idx]["MFR_NO_EXT"]　→　配列内のidx番目の明細の「外部製造者コード名または番号」
[idx]["PO_PRICE"]　→　配列内のidx番目の明細の「区分：価格採用 - 購買情報不使用」
[idx]["SHIPPING"]　→　配列内のidx番目の明細の「出荷指示」
[idx]["ITEM_CAT_EXT"]　→　配列内のidx番目の明細の「購買伝票の明細カテゴリ」
[idx]["PO_UNIT_ISO"]　→　配列内のidx番目の明細の「ISO コードによる発注単位」
[idx]["ORDERPR_UN_ISO"]　→　配列内のidx番目の明細の「購買発注価格単位の ISO コード」
[idx]["PREQ_NAME"]　→　配列内のidx番目の明細の「購買依頼者名/要求者名」
[idx]["DISP_QUAN"]　→　配列内のidx番目の明細の「購買発注数量：表示目的全納入日程合計」
[idx]["QUAL_INSP"]　→　配列内のidx番目の明細の「在庫タイプ」
[idx]["NO_MORE_GR"]　→　配列内のidx番目の明細の「納入完了 区分」
[idx]["DELETE_IND"]　→　配列内のidx番目の明細の「購買伝票の削除フラグ」
[idx]["NO_ROUNDING"]　→　配列内のidx番目の明細の「区分：購買発注明細での非表示丸め」
[idx]["TAX_CODE"]　→　配列内のidx番目の明細の「消費税コード」
[idx]["MATERIAL_EXTERNAL"]　→ 　配列内のidx番目の明細の「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["MATERIAL_GUID"]　→ 　配列内のidx番目の明細の「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["MATERIAL_VERSION"]　→ 　配列内のidx番目の明細の「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」
[idx]["PUR_MAT_EXTERNAL"]　→ 　配列内のidx番目の明細の「項目 PUR_MAT の品目コード (長) (今後のリリースで開発)」
[idx]["PUR_MAT_GUID"]　→ 　配列内のidx番目の明細の「項目 PUR_MAT の外部 GUID (今後のリリースで開発)」
[idx]["PUR_MAT_VERSION"]　→ 　配列内のidx番目の明細の「項目 PUR_MAT のバージョン番号 (今後のリリースで開発)」
[idx]["VAL_TYPE"]　→　配列内のidx番目の明細の「評価タイプ」
[idx]["PR_CLOSED"]　→　配列内のidx番目の明細の「購買依頼処理済」
[idx]["ACKNOWL_NO"]　→　配列内のidx番目の明細の「購買発注請書番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getRelCode

Object getRelCode ()

承認コードを取得します。

返却値
Object 承認コード
getRelGroup

Object getRelGroup ()

承認グループを取得します。

返却値
Object 承認グループ
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 PurchaseOrderPayPostController オブジェクト

伝票登録コントローラクラス。

機能は以下の通り
  • 伝票を登録します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
PurchaseOrderPayPostController ()
コンストラクタ｡
PurchaseOrderPayPostController (ConnectionManager connectionManager)
コンストラクタ。
PurchaseOrderPayPostController (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより購買伝票を登録します。
Object | getAllVersionsList () 全バージョン一覧を取得します｡
String | getBapiReturnErrMessage () ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage () プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。
Object | getCondHeaderList () 条件ヘッダ一覧を取得します｡
Object | getCondItemList () 条件明細一覧を取得します｡
Object | getContractLimitsList () 外注基本契約制限一覧を取得します｡
Object | getContractServiceAccountList () 外注サービス勘定設定一覧を取得します｡
Object | getContractServiceList () 外注サービス一覧を取得します｡
Object | getContractServiceTextList () 外注サービステキスト一覧を取得します｡
Object | getDeliverryAddressList () 出荷伝票アドレス一覧を取得します｡
Object | getDocumentHeader () 伝票ヘッダを取得します。
Object | getExportHeader () 貿易管理ヘッダを取得します｡
Object | getExportItemList () 貿易管理明細一覧を取得します｡
Object | getExtensionList () 拡張得意先項目一覧を取得します｡
Object | getHeaderTextList () ヘッダテキスト一覧を取得します｡
Object | getItemTextList () 明細テキスト一覧を取得します｡
Object | getLimitsList () 外注制限一覧を取得します｡
Object | getMemoryComplete () エラーがない場合に購買発注を保留にする区分を取得します｡
Object | getMemoryUnComplete () エラーがある場合に購買発注を保留にする区分を取得します｡
Object | getNoAuthority () 権限チェックなし区分を取得します｡
Object | getNoMessageReq () メッセージ不要区分を取得します｡
Object | getNoMessaging () 出力決定なし区分を取得します。
Object | getNoPriceFromPo () 最終伝票からの価格転送なし区分を取得します｡
Object | getPartnerList () 得意先一覧を取得します｡
Object | getPoNumber () 購買伝票番号を取得します｡
Object | getProfitSegmentList () 入出庫予定一覧を取得します｡
Object | getPurchaseAccountList () 勘定設定一覧を取得します｡
Object | getPurchaseComponentsList () コンポーネント一覧を取得します｡
Object | getPurchaseItemPostList () 明細一覧を取得します｡
Object | getPurchaseScheduleList () 納入日程一覧を取得します｡
Object | getPurchaseShippingExpList () 出荷データエクスポート一覧を取得します｡
Object | getPurchaseShippingList () 出荷データ一覧を取得します｡
Object | getSupplierInfo () 仕入先住所を取得します｡
Object | getTestRun () テスト区分を取得します。
Object | getVersions () バージョン管理を取得します｡
void | setMemoryComplete (String value) エラーがない場合に購買発注を保留する区分を設定します｡
void | setMemoryUnComplete (String value) エラーがある場合に購買発注を保留する区分を設定します｡
void | setNoAuthority (String value) 権限チェックなし区分を設定します｡
void | setNoMessage (String value) 出力決定なし区分に購買発注を保留する区分を設定します｡
void | setNoMessageReq (String value) メッセージ不要区分を設定します｡
void | setNoPriceFromPo (String value) 最終伝票からの価格転送なし区分を設定します｡
void | setStrParam (String paramStr ,String paramName ,String value) 構造型の項目に値をセットします。
void | setTblParam (String paramTable ,String paramName ,String value ,int index) テーブル型の項目に値をセットします。
void | setTestRun (String value) テスト区分を設定します｡
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
PurchaseOrderPayPostController

PurchaseOrderPayPostController ()
コンストラクタ｡
PurchaseOrderPayPostController

PurchaseOrderPayPostController (ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、PurchaseOrderPayPostController#executeBapi()実行後に必ず ConnectionManager#commit()またはConnectionManager#rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。
パラメータ
connectionManager ConnectionManager コネクションマネージャー
PurchaseOrderPayPostController

PurchaseOrderPayPostController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより購買伝票を登録します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getAllVersionsList

Object getAllVersionsList ()

全バージョン一覧を取得します｡
返却値
Object 全バージョン一覧

全バージョン情報オブジェクトの構成は以下のとおりです。
全バージョン情報
オブジェクト
(Object)
DOC_TYPE 購買伝票カテゴリ (String)
DOC_NUMBER 購買管理におけるオブジェクト番号 (String)
ITEM_NUMBER 購買管理オブジェクト：明細 (String)
VERSION 購買管理におけるバージョン番号 (String)
CREATED_BY オブジェクト登録者名 (String)
CR_ON レコード登録日 (String)
REC_TIME 登録時刻 (String)
RELEASED_BY 承認者名 (String)
RELEASE_DATE 承認日 (String)
RELEASE_TIME 承認時刻 (String)
RELEASEBY_PUR 承認購買担当者名 (String)
RELEASEDATE_PUR 購買担当者承認日付 (String)
RELEASETIME_PUR 購買担当者承認時刻 (String)
REASON 変更理由 (String)
DESCRIPTION バージョンテキスト（長） (String)
REQ_BY_EXT バージョンの外部変更番号 (String)
REQ_BY 変更を依頼した従業員 (String)
NET_VALUE 購買発注通貨による正味発注額 (String)
VALUE_CHANGED バージョンによる金額変更 (String)
CURRENCY 通貨コード (String)
CURRENCY_ISO ISO コード通貨 (String)
POST_DATE バージョンの転記日付 (String)
COMPLETED ステータス ""バージョン完了済"" (String)
STATUS バージョンステータス (String)
DELETE_IND 購買伝票の削除フラグ (String)
STATUS_DOC_OLD このバージョンの前の旧処理状況 (購買伝票内) (String)

取得した全バージョン情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["DOC_TYPE"]　→　配列内のidx番目の全バージョンの「購買伝票カテゴリ」
[idx]["DOC_NUMBER"]　→　配列内のidx番目の全バージョンの「購買管理におけるオブジェクト番号」
[idx]["ITEM_NUMBER"]　→　配列内のidx番目の全バージョンの「購買管理オブジェクト：明細」
[idx]["VERSION"]　→　配列内のidx番目の全バージョンの「購買管理におけるバージョン番号」
[idx]["CREATED_BY"]　→　配列内のidx番目の全バージョンの「オブジェクト登録者名」
[idx]["CR_ON"]　→　配列内のidx番目の全バージョンの「レコード登録日」
[idx]["REC_TIME"]　→　配列内のidx番目の全バージョンの「登録時刻」
[idx]["RELEASED_BY"]　→　配列内のidx番目の全バージョンの「承認者名」
[idx]["RELEASE_DATE"]　→　配列内のidx番目の全バージョンの「承認日」
[idx]["RELEASE_TIME"]　→　配列内のidx番目の全バージョンの「承認時刻」
[idx]["RELEASEBY_PUR"]　→　配列内のidx番目の全バージョンの「承認購買担当者名」
[idx]["RELEASEDATE_PUR"]　→　配列内のidx番目の全バージョンの「購買担当者承認日付」
[idx]["RELEASETIME_PUR"]　→　配列内のidx番目の全バージョンの「購買担当者承認時刻」
[idx]["REASON"]　→　配列内のidx番目の全バージョンの「変更理由」
[idx]["DESCRIPTION"]　→　配列内のidx番目の全バージョンの「バージョンテキスト（長）」
[idx]["REQ_BY_EXT"]　→　配列内のidx番目の全バージョンの「バージョンの外部変更番号」
[idx]["REQ_BY"]　→　配列内のidx番目の全バージョンの「変更を依頼した従業員」
[idx]["NET_VALUE"]　→　配列内のidx番目の全バージョンの「購買発注通貨による正味発注額」
[idx]["VALUE_CHANGED"]　→　配列内のidx番目の全バージョンの「バージョンによる金額変更」
[idx]["CURRENCY"]　→　配列内のidx番目の全バージョンの「通貨コード」
[idx]["CURRENCY_ISO"]　→　配列内のidx番目の全バージョンの「ISO コード通貨」
[idx]["POST_DATE"]　→　配列内のidx番目の全バージョンの「バージョンの転記日付」
[idx]["COMPLETED"]　→　配列内のidx番目の全バージョンの「ステータス "バージョン完了済"」
[idx]["STATUS"]　→　配列内のidx番目の全バージョンの「バージョンステータス」
[idx]["DELETE_IND"]　→　配列内のidx番目の全バージョンの「購買伝票の削除フラグ」
[idx]["STATUS_DOC_OLD"] 　→　配列内のidx番目の全バージョンの「このバージョンの前の旧処理状況 (購買伝票内)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getBapiReturnErrMessage

String getBapiReturnErrMessage ()

ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡
返却値
String BAPI実行結果エラーとなった全てのメッセージ情報
getBapiReturnMessage

String getBapiReturnMessage ()

プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡
返却値
String プロパティファイルでオートコミット条件に一致したType情報のメッセージ情報
getCondHeaderList

Object getCondHeaderList ()

条件ヘッダ一覧を取得します｡
返却値
Object 条件ヘッダ一覧

条件ヘッダ情報オブジェクトの構成は以下のとおりです。
条件ヘッダ情報
オブジェクト
(Object)
CONDITION_NO 伝票条件番号 (String)
ITM_NUMBER 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件カウンタ (String)
COND_TYPE 条件タイプ (String)
COND_VALUE 条件レート (String)
CURRENCY 通貨コード (String)
CURRENCY_ISO ISO コード通貨 (String)
COND_UNIT 条件単位 (String)
COND_UNIT_ISO 条件数量単位 (ISO コード) (String)
COND_P_UNT 価格条件単位 (String)
APPLICATIO アプリケーション (String)
CONPRICDAT 条件価格設定日付 (String)
CALCTYPCON 条件計算タイプ (String)
CONBASEVAL 条件基礎値 (String)
CONEXCHRAT 現地通貨への換算レートに対する条件 (String)
NUMCONVERT 条件単位を基本単位へ変換する分子 (String)
DENOMINATO 条件単位を基本単位へ変換する分母 (String)
CONDTYPE 条件カテゴリ (例：税、運賃、価格、原価) (String)
STAT_CON 統計に適用する条件 (String)
SCALETYPE スケールタイプ (String)
ACCRUALS 見越額関連条件 (運賃など) (String)
CONINVOLST 請求書一覧条件 (String)
CONDORIGIN 条件生成区分 (String)
GROUPCOND グループ条件区分 (String)
COND_UPDAT 条件更新 (String)
ACCESS_SEQ 検索順序 - 検索番号 (String)
CONDCOUNT 条件連続番号 (String)
CONDCNTRL 条件管理 (String)
CONDISACTI 無効条件 (String)
CONDCLASS 条件クラス (String)
FACTBASVAL 条件基礎値に対する要因 (String)
SCALEBASIN スケール基準区分 (String)
SCALBASVAL 条件のスケール基準値 (String)
UNITMEASUR 条件スケール単位 (String)
UNITMEASUR_ISO 単位の ISO コード (String)
CURRENCKEY スケール通貨 (String)
CURRENCKEY_ISO ISO コード通貨 (String)
CONDINCOMP 会社間請求の条件 (String)
CONDCONFIG システム設定の条件 (String)
CONDCHAMAN 条件 (マニュアル変更済) (String)
COND_NO 条件レコード番号 (String)
CHANGE_ID 変更タイプ(U、I、E、D) (String)
VENDOR_NO 仕入先または債権者の勘定コード (String)

取得した条件ヘッダ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONDITION_NO"]　→　配列内のidx番目の条件ヘッダの「伝票条件番号」
[idx]["ITM_NUMBER"]　→　配列内のidx番目の条件ヘッダの「条件明細番号」
[idx]["COND_ST_NO"]　→　配列内のidx番目の条件ヘッダの「ステップ番号」
[idx]["COND_COUNT"]　→　配列内のidx番目の条件ヘッダの「条件カウンタ」
[idx]["COND_TYPE"]　→　配列内のidx番目の条件ヘッダの「条件タイプ」
[idx]["COND_VALUE"]　→　配列内のidx番目の条件ヘッダの「条件レート」
[idx]["CURRENCY"]　→　配列内のidx番目の条件ヘッダの「通貨コード」
[idx]["CURRENCY_ISO"]　→　配列内のidx番目の条件ヘッダの「ISO コード通貨」
[idx]["COND_UNIT"]　→　配列内のidx番目の条件ヘッダの「条件単位」
[idx]["COND_UNIT_ISO"]　→　配列内のidx番目の条件ヘッダの「条件数量単位 (ISO コード)」
[idx]["COND_P_UNT"]　→　配列内のidx番目の条件ヘッダの「価格条件単位」
[idx]["APPLICATIO"]　→　配列内のidx番目の条件ヘッダの「アプリケーション」
[idx]["CONPRICDAT"]　→　配列内のidx番目の条件ヘッダの「条件価格設定日付」
[idx]["CALCTYPCON"]　→　配列内のidx番目の条件ヘッダの「条件計算タイプ」
[idx]["CONBASEVAL"]　→　配列内のidx番目の条件ヘッダの「条件基礎値」
[idx]["CONEXCHRAT"]　→　配列内のidx番目の条件ヘッダの「現地通貨への換算レートに対する条件」
[idx]["NUMCONVERT"]　→　配列内のidx番目の条件ヘッダの「条件単位を基本単位へ変換する分子」
[idx]["DENOMINATO"]　→　配列内のidx番目の条件ヘッダの「条件単位を基本単位へ変換する分母」
[idx]["CONDTYPE"]　→　配列内のidx番目の条件ヘッダの「条件カテゴリ (例：税、運賃、価格、原価)」
[idx]["STAT_CON"]　→　配列内のidx番目の条件ヘッダの「統計に適用する条件」
[idx]["SCALETYPE"]　→　配列内のidx番目の条件ヘッダの「スケールタイプ」
[idx]["ACCRUALS"]　→　配列内のidx番目の条件ヘッダの「見越額関連条件 (運賃など)」
[idx]["CONINVOLST"]　→　配列内のidx番目の条件ヘッダの「請求書一覧条件」
[idx]["CONDORIGIN"]　→　配列内のidx番目の条件ヘッダの「条件生成区分」
[idx]["GROUPCOND"]　→　配列内のidx番目の条件ヘッダの「グループ条件区分」
[idx]["COND_UPDAT"]　→　配列内のidx番目の条件ヘッダの「条件更新」
[idx]["ACCESS_SEQ"]　→　配列内のidx番目の条件ヘッダの「検索順序 - 検索番号」
[idx]["CONDCOUNT"]　→　配列内のidx番目の条件ヘッダの「条件連続番号」
[idx]["CONDCNTRL"]　→　配列内のidx番目の条件ヘッダの「条件管理」
[idx]["CONDISACTI"]　→　配列内のidx番目の条件ヘッダの「無効条件」
[idx]["CONDCLASS"]　→　配列内のidx番目の条件ヘッダの「条件クラス」
[idx]["FACTBASVAL"]　→　配列内のidx番目の条件ヘッダの「条件基礎値に対する要因」
[idx]["SCALEBASIN"]　→　配列内のidx番目の条件ヘッダの「スケール基準区分」
[idx]["SCALBASVAL"]　→　配列内のidx番目の条件ヘッダの「条件のスケール基準値」
[idx]["UNITMEASUR"]　→　配列内のidx番目の条件ヘッダの「条件スケール単位」
[idx]["UNITMEASUR_ISO"]　→　配列内のidx番目の条件ヘッダの「単位の ISO コード」
[idx]["CURRENCKEY"]　→　配列内のidx番目の条件ヘッダの「スケール通貨」
[idx]["CURRENCKEY_ISO"]　→　配列内のidx番目の条件ヘッダの「ISO コード通貨」
[idx]["CONDINCOMP"]　→　配列内のidx番目の条件ヘッダの「会社間請求の条件」
[idx]["CONDCONFIG"]　→　配列内のidx番目の条件ヘッダの「システム設定の条件」
[idx]["CONDCHAMAN"]　→　配列内のidx番目の条件ヘッダの「条件 (マニュアル変更済)」
[idx]["COND_NO"]　→　配列内のidx番目の条件ヘッダの「条件レコード番号」
[idx]["CHANGE_ID"]　→　配列内のidx番目の条件ヘッダの「変更タイプ(U、I、E、D)」
[idx]["VENDOR_NO"]　→　配列内のidx番目の条件ヘッダの「仕入先または債権者の勘定コード」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getCondItemList

Object getCondItemList ()

条件明細一覧を取得します｡
返却値
Object 条件明細一覧

条件明細情報オブジェクトの構成は以下のとおりです。
条件明細情報
オブジェクト
(Object)
CONDITION_NO 伝票条件番号 (String)
ITM_NUMBER 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件カウンタ (String)
COND_TYPE 条件タイプ (String)
COND_VALUE 条件レート (String)
CURRENCY 通貨コード (String)
CURRENCY_ISO ISO コード通貨 (String)
COND_UNIT 条件単位 (String)
COND_UNIT_ISO 条件数量単位 (ISO コード) (String)
COND_P_UNT 価格条件単位 (String)
APPLICATIO アプリケーション (String)
CONPRICDAT 条件価格設定日付 (String)
CALCTYPCON 条件計算タイプ (String)
CONBASEVAL 条件基礎値 (String)
CONEXCHRAT 現地通貨への換算レートに対する条件 (String)
NUMCONVERT 条件単位を基本単位へ変換する分子 (String)
DENOMINATO 条件単位を基本単位へ変換する分母 (String)
CONDTYPE 条件カテゴリ (例：税、運賃、価格、原価) (String)
STAT_CON 統計に適用する条件 (String)
SCALETYPE スケールタイプ (String)
ACCRUALS 見越額関連条件 (運賃など) (String)
CONINVOLST 請求書一覧条件 (String)
CONDORIGIN 条件生成区分 (String)
GROUPCOND グループ条件区分 (String)
COND_UPDAT 条件更新 (String)
ACCESS_SEQ 検索順序 - 検索番号 (String)
CONDCOUNT 条件連続番号 (String)
CONDCNTRL 条件管理 (String)
CONDISACTI 無効条件 (String)
CONDCLASS 条件クラス (String)
FACTBASVAL 条件基礎値に対する要因 (String)
SCALEBASIN スケール基準区分 (String)
SCALBASVAL 条件のスケール基準値 (String)
UNITMEASUR 条件スケール単位 (String)
UNITMEASUR_ISO 単位の ISO コード (String)
CURRENCKEY スケール通貨 (String)
CURRENCKEY_ISO ISO コード通貨 (String)
CONDINCOMP 会社間請求の条件 (String)
CONDCONFIG システム設定の条件 (String)
CONDCHAMAN 条件 (マニュアル変更済) (String)
COND_NO 条件レコード番号 (String)
CHANGE_ID 変更タイプ(U、I、E、D) (String)
VENDOR_NO 仕入先または債権者の勘定コード (String)

取得した条件明細情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONDITION_NO"]　→　配列内のidx番目の条件明細の「伝票条件番号」
[idx]["ITM_NUMBER"]　→　配列内のidx番目の条件明細の「条件明細番号」
[idx]["COND_ST_NO"]　→　配列内のidx番目の条件明細の「ステップ番号」
[idx]["COND_COUNT"]　→　配列内のidx番目の条件明細の「条件カウンタ」
[idx]["COND_TYPE"]　→　配列内のidx番目の条件明細の「条件タイプ」
[idx]["COND_VALUE"]　→　配列内のidx番目の条件明細の「条件レート」
[idx]["CURRENCY"]　→　配列内のidx番目の条件明細の「通貨コード」
[idx]["CURRENCY_ISO"]　→　配列内のidx番目の条件明細の「ISO コード通貨」
[idx]["COND_UNIT"]　→　配列内のidx番目の条件明細の「条件単位」
[idx]["COND_UNIT_ISO"]　→　配列内のidx番目の条件明細の「条件数量単位 (ISO コード)」
[idx]["COND_P_UNT"]　→　配列内のidx番目の条件明細の「価格条件単位」
[idx]["APPLICATIO"]　→　配列内のidx番目の条件明細の「アプリケーション」
[idx]["CONPRICDAT"]　→　配列内のidx番目の条件明細の「条件価格設定日付」
[idx]["CALCTYPCON"]　→　配列内のidx番目の条件明細の「条件計算タイプ」
[idx]["CONBASEVAL"]　→　配列内のidx番目の条件明細の「条件基礎値」
[idx]["CONEXCHRAT"]　→　配列内のidx番目の条件明細の「現地通貨への換算レートに対する条件」
[idx]["NUMCONVERT"]　→　配列内のidx番目の条件明細の「条件単位を基本単位へ変換する分子」
[idx]["DENOMINATO"]　→　配列内のidx番目の条件明細の「条件単位を基本単位へ変換する分母」
[idx]["CONDTYPE"]　→　配列内のidx番目の条件明細の「条件カテゴリ (例：税、運賃、価格、原価)」
[idx]["STAT_CON"]　→　配列内のidx番目の条件明細の「統計に適用する条件」
[idx]["SCALETYPE"]　→　配列内のidx番目の条件明細の「スケールタイプ」
[idx]["ACCRUALS"]　→　配列内のidx番目の条件明細の「見越額関連条件 (運賃など)」
[idx]["CONINVOLST"]　→　配列内のidx番目の条件明細の「請求書一覧条件」
[idx]["CONDORIGIN"]　→　配列内のidx番目の条件明細の「条件生成区分」
[idx]["GROUPCOND"]　→　配列内のidx番目の条件明細の「グループ条件区分」
[idx]["COND_UPDAT"]　→　配列内のidx番目の条件明細の「条件更新」
[idx]["ACCESS_SEQ"]　→　配列内のidx番目の条件明細の「検索順序 - 検索番号」
[idx]["CONDCOUNT"]　→　配列内のidx番目の条件明細の「条件連続番号」
[idx]["CONDCNTRL"]　→　配列内のidx番目の条件明細の「条件管理」
[idx]["CONDISACTI"]　→　配列内のidx番目の条件明細の「無効条件」
[idx]["CONDCLASS"]　→　配列内のidx番目の条件明細の「条件クラス」
[idx]["FACTBASVAL"]　→　配列内のidx番目の条件明細の「条件基礎値に対する要因」
[idx]["SCALEBASIN"]　→　配列内のidx番目の条件明細の「スケール基準区分」
[idx]["SCALBASVAL"]　→　配列内のidx番目の条件明細の「条件のスケール基準値」
[idx]["UNITMEASUR"]　→　配列内のidx番目の条件明細の「条件スケール単位」
[idx]["UNITMEASUR_ISO"]　→　配列内のidx番目の条件明細の「単位の ISO コード」
[idx]["CURRENCKEY"]　→　配列内のidx番目の条件明細の「スケール通貨」
[idx]["CURRENCKEY_ISO"]　→　配列内のidx番目の条件明細の「ISO コード通貨」
[idx]["CONDINCOMP"]　→　配列内のidx番目の条件明細の「会社間請求の条件」
[idx]["CONDCONFIG"]　→　配列内のidx番目の条件明細の「システム設定の条件」
[idx]["CONDCHAMAN"]　→　配列内のidx番目の条件明細の「条件 (マニュアル変更済)」
[idx]["COND_NO"]　→　配列内のidx番目の条件明細の「条件レコード番号」
[idx]["CHANGE_ID"]　→　配列内のidx番目の条件明細の「変更タイプ(U、I、E、D)」
[idx]["VENDOR_NO"]　→　配列内のidx番目の条件明細の「仕入先または債権者の勘定コード」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getContractLimitsList

Object getContractLimitsList ()

外注基本契約制限一覧を取得します｡
返却値
Object 外注基本契約制限一覧

外注基本契約制限情報オブジェクトの構成は以下のとおりです。
外注基本契約制限情報
オブジェクト
(Object)
PCKG_NO パッケージ番号 (String)
LINE_NO 制限の内部明細番号 (String)
CON_NUMBER 基本契約番号 (String)
CON_ITEM 明細番号、契約 (String)
LIMIT 全体制限 (String)
NO_LIMIT 制限なし (String)
PRICE_CHG 入力シートの価格変更 (String)
SHORT_TEXT テキスト 1 (短) (String)
DELETE_IND 削除フラグ (String)

取得した外注基本契約制限情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PCKG_NO"]　→　配列内のidx番目の外注基本契約制限の「パッケージ番号」
[idx]["LINE_NO"]　→　配列内のidx番目の外注基本契約制限の「制限の内部明細番号」
[idx]["CON_NUMBER"]　→　配列内のidx番目の外注基本契約制限の「基本契約番号」
[idx]["CON_ITEM"]　→　配列内のidx番目の外注基本契約制限の「明細番号、契約」
[idx]["LIMIT"]　→　配列内のidx番目の外注基本契約制限の「全体制限」
[idx]["NO_LIMIT"]　→　配列内のidx番目の外注基本契約制限の「制限なし」
[idx]["PRICE_CHG"]　→　配列内のidx番目の外注基本契約制限の「入力シートの価格変更」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の外注基本契約制限の「テキスト 1 (短)」
[idx]["DELETE_IND"]　→　配列内のidx番目の外注基本契約制限の「削除フラグ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getContractServiceAccountList

Object getContractServiceAccountList ()

外注サービス勘定設定一覧を取得します｡
返却値
Object 外注サービス勘定設定一覧

外注サービス勘定設定情報オブジェクトの構成は以下のとおりです。
外注サービス勘定設定情報
オブジェクト
(Object)
PCKG_NO パッケージ番号 (String)
LINE_NO 明細行番号 (String)
SERNO_LINE 勘定コード設定のシリアル番号、サービス明細 (String)
PERCENTAGE 勘定設定金額配賦のパーセント (String)
SERIAL_NO 勘定設定の連続番号 (String)
QUANTITY +/- 記号あり/なし数量 (String)
NET_VALUE 明細の正味額 (String)

取得した外注サービス勘定設定情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PCKG_NO"]　→　配列内のidx番目の外注サービス勘定設定の「パッケージ番号」
[idx]["LINE_NO"]　→　配列内のidx番目の外注サービス勘定設定の「明細行番号」
[idx]["SERNO_LINE"] 　→　配列内のidx番目の外注サービス勘定設定の「勘定コード設定のシリアル番号、サービス明細」
[idx]["PERCENTAGE"]　→　配列内のidx番目の外注サービス勘定設定の「勘定設定金額配賦のパーセント」
[idx]["SERIAL_NO"]　→　配列内のidx番目の外注サービス勘定設定の「勘定設定の連続番号」
[idx]["QUANTITY"]　→　配列内のidx番目の外注サービス勘定設定の「+/- 記号あり/なし数量」
[idx]["NET_VALUE"]　→　配列内のidx番目の外注サービス勘定設定の「明細の正味額」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getContractServiceList

Object getContractServiceList ()

外注サービス一覧を取得します｡
返却値
Object 外注サービス一覧

外注サービス情報オブジェクトの構成は以下のとおりです。
外注サービス情報
オブジェクト
(Object)
PCKG_NO パッケージ番号 (String)
LINE_NO 内部明細番号 (String)
EXT_LINE 明細番号 (String)
OUTL_LEVEL グループの階層レベル (String)
OUTL_NO アウトラインレベル (String)
OUTL_IND 区分：出力行 (String)
SUBPCKG_NO サブパッケージ番号 (String)
SERVICE 活動番号 (String)
SERV_TYPE サービスタイプのテキスト (短) (String)
EDITION サービスタイプのバージョン (String)
SSC_ITEM 標準サービスカタログ：明細 (String)
EXT_SERV 仕入先のサービス番号 (String)
QUANTITY +/- 記号あり/なし数量 (String)
BASE_UOM 基本数量単位 (String)
UOM_ISO 単位の ISO コード (String)
OVF_TOL 超過許容値 (String)
OVF_UNLIM 契約外サービス制限なし (String)
PRICE_UNIT 価格単位 (String)
GR_PRICE 基準額 (String)
FROM_LINE 下限 (String)
TO_LINE 上限 (String)
SHORT_TEXT テキスト(短) (String)
DISTRIB 複数勘定設定の配賦区分 (String)
PERS_NO 従業員番号 (String)
WAGETYPE ウェイジタイプ (String)
PLN_PCKG パッケージ番号供給元一覧 (String)
PLN_LINE 入力：計画梱包明細行 (String)
CON_PCKG 入力：基本契約の計画外 (String)
CON_LINE 入力：基本契約の計画外 (String)
TMP_PCKG 入力：モデル仕様からの計画外サービス (String)
TMP_LINE 入力：モデル仕様からの計画外サービス (String)
SSC_LIM 標準サービスカタログ制限参照のサービス行 (String)
LIMIT_LINE 入力：計画外、明細制限 (String)
TARGET_VAL 目標値 (String)
BASLINE_NO 代替：基本明細参照 (String)
BASIC_LINE 基本明細 (String)
ALTERNAT 代替明細 (String)
BIDDER 入札者の明細 (String)
SUPP_LINE 補足明細 (String)
OPEN_QTY 未処理数量のある明細 (String)
INFORM 情報行 (String)
BLANKET 包括明細 (String)
EVENTUAL 偶発的明細 (String)
TAX_CODE 消費税コード (String)
TAXJURCODE 税計算管轄コード - 税管轄コード (String)
PRICE_CHG 入力シートの価格変更 (String)
MATL_GROUP 品目グループ (String)
DATE 日付 (String)
BEGINTIME 開始時刻 (String)
ENDTIME 終了時刻 (String)
EXTPERS_NO 外部従業員番号 (String)
FORMULA 計算式番号 (String)
FORM_VAL1 計算式値 (String)
FORM_VAL2 計算式値 (String)
FORM_VAL3 計算式値 (String)
FORM_VAL4 計算式値 (String)
FORM_VAL5 計算式値 (String)
USERF1_NUM ユーザ定義項目 (String)
USERF2_NUM ユーザ定義項目 (String)
USERF1_TXT ユーザ定義項目 (String)
USERF2_TXT ユーザ定義項目 (String)
HI_LINE_NO 上位階層明細番号 (String)
EXTREFKEY サービスの外部参照キー (String)
DELETE_IND 削除フラグ (String)

取得した外注サービス情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PCKG_NO"]　→　配列内のidx番目の外注サービスの「パッケージ番号」
[idx]["LINE_NO"]　→　配列内のidx番目の外注サービスの「内部明細番号」
[idx]["EXT_LINE"]　→　配列内のidx番目の外注サービスの「明細番号」
[idx]["OUTL_LEVEL"]　→　配列内のidx番目の外注サービスの「グループの階層レベル」
[idx]["OUTL_NO"]　→　配列内のidx番目の外注サービスの「アウトラインレベル」
[idx]["OUTL_IND"]　→　配列内のidx番目の外注サービスの「区分：出力行」
[idx]["SUBPCKG_NO"]　→　配列内のidx番目の外注サービスの「サブパッケージ番号」
[idx]["SERVICE"]　→　配列内のidx番目の外注サービスの「活動番号」
[idx]["SERV_TYPE"]　→　配列内のidx番目の外注サービスの「サービスタイプのテキスト (短)」
[idx]["EDITION"]　→　配列内のidx番目の外注サービスの「サービスタイプのバージョン」
[idx]["SSC_ITEM"]　→　配列内のidx番目の外注サービスの「標準サービスカタログ：明細」
[idx]["EXT_SERV"]　→　配列内のidx番目の外注サービスの「仕入先のサービス番号」
[idx]["QUANTITY"]　→　配列内のidx番目の外注サービスの「+/- 記号あり/なし数量」
[idx]["BASE_UOM"]　→　配列内のidx番目の外注サービスの「基本数量単位」
[idx]["UOM_ISO"]　→　配列内のidx番目の外注サービスの「単位の ISO コード」
[idx]["OVF_TOL"]　→　配列内のidx番目の外注サービスの「超過許容値」
[idx]["OVF_UNLIM"]　→　配列内のidx番目の外注サービスの「契約外サービス制限なし」
[idx]["PRICE_UNIT"]　→　配列内のidx番目の外注サービスの「価格単位」
[idx]["GR_PRICE"]　→　配列内のidx番目の外注サービスの「基準額」
[idx]["FROM_LINE"]　→　配列内のidx番目の外注サービスの「下限」
[idx]["TO_LINE"]　→　配列内のidx番目の外注サービスの「上限」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の外注サービスの「テキスト(短)」
[idx]["DISTRIB"]　→　配列内のidx番目の外注サービスの「複数勘定設定の配賦区分」
[idx]["PERS_NO"]　→　配列内のidx番目の外注サービスの「従業員番号」
[idx]["WAGETYPE"]　→　配列内のidx番目の外注サービスの「ウェイジタイプ」
[idx]["PLN_PCKG"]　→　配列内のidx番目の外注サービスの「パッケージ番号供給元一覧」
[idx]["PLN_LINE"]　→　配列内のidx番目の外注サービスの「入力：計画梱包明細行」
[idx]["CON_PCKG"]　→　配列内のidx番目の外注サービスの「入力：基本契約の計画外」
[idx]["CON_LINE"]　→　配列内のidx番目の外注サービスの「入力：基本契約の計画外」
[idx]["TMP_PCKG"]　→　配列内のidx番目の外注サービスの「入力：モデル仕様からの計画外サービス」
[idx]["TMP_LINE"]　→　配列内のidx番目の外注サービスの「入力：モデル仕様からの計画外サービス」
[idx]["SSC_LIM"]　→　配列内のidx番目の外注サービスの「標準サービスカタログ制限参照のサービス行」
[idx]["LIMIT_LINE"]　→　配列内のidx番目の外注サービスの「入力：計画外、明細制限」
[idx]["TARGET_VAL"]　→　配列内のidx番目の外注サービスの「目標値」
[idx]["BASLINE_NO"]　→　配列内のidx番目の外注サービスの「代替：基本明細参照」
[idx]["BASIC_LINE"]　→　配列内のidx番目の外注サービスの「基本明細」
[idx]["ALTERNAT"]　→　配列内のidx番目の外注サービスの「代替明細」
[idx]["BIDDER"]　→　配列内のidx番目の外注サービスの「入札者の明細」
[idx]["SUPP_LINE"]　→　配列内のidx番目の外注サービスの「補足明細」
[idx]["OPEN_QTY"]　→　配列内のidx番目の外注サービスの「未処理数量のある明細」
[idx]["INFORM"]　→　配列内のidx番目の外注サービスの「情報行」
[idx]["BLANKET"]　→　配列内のidx番目の外注サービスの「包括明細」
[idx]["EVENTUAL"]　→　配列内のidx番目の外注サービスの「偶発的明細」
[idx]["TAX_CODE"]　→　配列内のidx番目の外注サービスの「消費税コード」
[idx]["TAXJURCODE"]　→　配列内のidx番目の外注サービスの「税計算管轄コード - 税管轄コード」
[idx]["PRICE_CHG"]　→　配列内のidx番目の外注サービスの「入力シートの価格変更」
[idx]["MATL_GROUP"]　→　配列内のidx番目の外注サービスの「品目グループ」
[idx]["DATE"]　→　配列内のidx番目の外注サービスの「日付」
[idx]["BEGINTIME"]　→　配列内のidx番目の外注サービスの「開始時刻」
[idx]["ENDTIME"]　→　配列内のidx番目の外注サービスの「終了時刻」
[idx]["EXTPERS_NO"]　→　配列内のidx番目の外注サービスの「外部従業員番号」
[idx]["FORMULA"]　→　配列内のidx番目の外注サービスの「計算式番号」
[idx]["FORM_VAL1"]　→　配列内のidx番目の外注サービスの「計算式値」
[idx]["FORM_VAL2"]　→　配列内のidx番目の外注サービスの「計算式値」
[idx]["FORM_VAL3"]　→　配列内のidx番目の外注サービスの「計算式値」
[idx]["FORM_VAL4"]　→　配列内のidx番目の外注サービスの「計算式値」
[idx]["FORM_VAL5"]　→　配列内のidx番目の外注サービスの「計算式値」
[idx]["USERF1_NUM"]　→　配列内のidx番目の外注サービスの「ユーザ定義項目」
[idx]["USERF2_NUM"]　→　配列内のidx番目の外注サービスの「ユーザ定義項目」
[idx]["USERF1_TXT"]　→　配列内のidx番目の外注サービスの「ユーザ定義項目」
[idx]["USERF2_TXT"]　→　配列内のidx番目の外注サービスの「ユーザ定義項目」
[idx]["HI_LINE_NO"]　→　配列内のidx番目の外注サービスの「上位階層明細番号」
[idx]["EXTREFKEY"]　→　配列内のidx番目の外注サービスの「サービスの外部参照キー」
[idx]["DELETE_IND"]　→　配列内のidx番目の外注サービスの「削除フラグ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getContractServiceTextList

Object getContractServiceTextList ()

外注サービステキスト一覧を取得します｡
返却値
Object 外注サービステキスト一覧

外注サービステキスト情報オブジェクトの構成は以下のとおりです。
外注サービステキスト情報
オブジェクト
(Object)
PCKG_NO パッケージ番号 (String)
LINE_NO 内部明細番号 (String)
TEXT_ID テキスト ID (String)
FORMAT_COL タグ列 (String)
TEXT_LINE テキスト行 (String)

取得した外注サービステキスト情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PCKG_NO"]　→　配列内のidx番目の外注サービステキストの「パッケージ番号」
[idx]["LINE_NO"]　→　配列内のidx番目の外注サービステキストの「内部明細番号」
[idx]["TEXT_ID"]　→　配列内のidx番目の外注サービステキストの「テキスト ID」
[idx]["FORMAT_COL"]　→　配列内のidx番目の外注サービステキストの「タグ列」
[idx]["TEXT_LINE"]　→　配列内のidx番目の外注サービステキストの「テキスト行」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getDeliverryAddressList

Object getDeliverryAddressList ()

出荷伝票アドレス一覧を取得します｡
返却値
Object 出荷伝票アドレス一覧

出荷伝票アドレス情報オブジェクトの構成は以下のとおりです。
出荷伝票アドレス情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号 (String)
ADDR_NO アドレス番号 (String)
FORMOFADDR 敬称テキスト (String)
NAME 名称 1 (String)
NAME_2 名称 2 (String)
NAME_3 名称 3 (String)
NAME_4 名称 4 (String)
C_O_NAME 気付 (String)
CITY 市区町村 (String)
DISTRICT 所在地 (String)
CITY_NO 市区町村/地名ファイルの市区町村コード (String)
POSTL_COD1 市区町村の郵便番号 (String)
POSTL_COD2 私書箱郵便番号 (String)
POSTL_COD3 会社郵便番号 (大規模なユーザ用) (String)
PO_BOX 私書箱 (String)
PO_BOX_CIT 私書箱住所 (String)
DELIV_DIS 郵便配達地域 (String)
STREET 地名 (String)
STREET_NO 市区町村/地名ファイルの地名コード (String)
STR_ABBR 地名の略称 (例：スペイン) (String)
HOUSE_NO 番地-号 (String)
STR_SUPPL1 地名 2 (String)
STR_SUPPL2 地名 3 (String)
LOCATION 地名 5 (String)
BUILDING 旧：建物 (番号または略称) (String)
FLOOR 建物の階 (String)
ROOM_NO 部屋/アパート番号 (String)
COUNTRY 国コード (String)
LANGU 言語キー (String)
REGION 地域 (都道府県) (String)
SORT1 検索条件 1 (String)
SORT2 検索条件 2 (String)
TIME_ZONE アドレスタイムゾーン (String)
TAXJURCODE 税管轄コード (String)
ADR_NOTES 住所注記 (String)
COMM_TYPE 通信方法 (キー) (アドレス管理) (String)
TEL1_NUMBR 第一電話番号：ダイヤルコード + 番号 (String)
TEL1_EXT 第 1 電話番号：内線 (String)
FAX_NUMBER 第一 FAX 番号：ダイヤルコード + 番号 (String)
FAX_EXTENS 第一 FAX 番号：内線 (String)
STREET_LNG 地名 (String)
DISTRCT_NO 市区町村/地名ファイルの所在地コード (String)
CHCKSTATUS 市区町村ファイルテストステータス (String)
PBOXCIT_NO 市区町村私書箱コード (市ファイル) (String)
TRANSPZONE 商品の納入区域 (String)
HOUSE_NO2 番地補足 (String)
E_MAIL 電子メールアドレス (String)
STR_SUPPL3 地名 4 (String)
TITLE タイトル (敬称) (String)
COUNTRYISO ISO 国コード (String)
LANGU_ISO ISO 639 準拠の言語 (String)
BUILD_LONG 建物 (番号またはコード) (String)
REGIOGROUP 地域構造グループ化 (String)

取得した出荷伝票アドレス情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の出荷伝票アドレスの「購買伝票の明細番号」
[idx]["ADDR_NO"]　→　配列内のidx番目の出荷伝票アドレスの「アドレス番号」
[idx]["FORMOFADDR"]　→　配列内のidx番目の出荷伝票アドレスの「敬称テキスト」
[idx]["NAME"]　→　配列内のidx番目の出荷伝票アドレスの「名称 1」
[idx]["NAME_2"]　→　配列内のidx番目の出荷伝票アドレスの「名称 2」
[idx]["NAME_3"]　→　配列内のidx番目の出荷伝票アドレスの「名称 3」
[idx]["NAME_4"]　→　配列内のidx番目の出荷伝票アドレスの「名称 4」
[idx]["C_O_NAME"]　→　配列内のidx番目の出荷伝票アドレスの「気付」
[idx]["CITY"]　→　配列内のidx番目の出荷伝票アドレスの「市区町村」
[idx]["DISTRICT"]　→　配列内のidx番目の出荷伝票アドレスの「所在地」
[idx]["CITY_NO"]　→　配列内のidx番目の出荷伝票アドレスの「市区町村/地名ファイルの市区町村コード」
[idx]["POSTL_COD1"]　→　配列内のidx番目の出荷伝票アドレスの「市区町村の郵便番号」
[idx]["POSTL_COD2"]　→　配列内のidx番目の出荷伝票アドレスの「私書箱郵便番号」
[idx]["POSTL_COD3"] 　→　配列内のidx番目の出荷伝票アドレスの「会社郵便番号 (大規模なユーザ用)」
[idx]["PO_BOX"]　→　配列内のidx番目の出荷伝票アドレスの「私書箱」
[idx]["PO_BOX_CIT"]　→　配列内のidx番目の出荷伝票アドレスの「私書箱住所」
[idx]["DELIV_DIS"]　→　配列内のidx番目の出荷伝票アドレスの「郵便配達地域」
[idx]["STREET"]　→　配列内のidx番目の出荷伝票アドレスの「地名」
[idx]["STREET_NO"]　→　配列内のidx番目の出荷伝票アドレスの「市区町村/地名ファイルの地名コード」
[idx]["STR_ABBR"]　→　配列内のidx番目の出荷伝票アドレスの「地名の略称 (例：スペイン)」
[idx]["HOUSE_NO"]　→　配列内のidx番目の出荷伝票アドレスの「番地-号」
[idx]["STR_SUPPL1"]　→　配列内のidx番目の出荷伝票アドレスの「地名 2」
[idx]["STR_SUPPL2"]　→　配列内のidx番目の出荷伝票アドレスの「地名 3」
[idx]["LOCATION"]　→　配列内のidx番目の出荷伝票アドレスの「地名 5」
[idx]["BUILDING"]　→　配列内のidx番目の出荷伝票アドレスの「旧：建物 (番号または略称)」
[idx]["FLOOR"]　→　配列内のidx番目の出荷伝票アドレスの「建物の階」
[idx]["ROOM_NO"]　→　配列内のidx番目の出荷伝票アドレスの「部屋/アパート番号」
[idx]["COUNTRY"]　→　配列内のidx番目の出荷伝票アドレスの「国コード」
[idx]["LANGU"]　→　配列内のidx番目の出荷伝票アドレスの「言語キー」
[idx]["REGION"]　→　配列内のidx番目の出荷伝票アドレスの「地域 (都道府県)」
[idx]["SORT1"]　→　配列内のidx番目の出荷伝票アドレスの「検索条件 1」
[idx]["SORT2"]　→　配列内のidx番目の出荷伝票アドレスの「検索条件 2」
[idx]["TIME_ZONE"]　→　配列内のidx番目の出荷伝票アドレスの「アドレスタイムゾーン」
[idx]["TAXJURCODE"]　→　配列内のidx番目の出荷伝票アドレスの「税管轄コード」
[idx]["ADR_NOTES"]　→　配列内のidx番目の出荷伝票アドレスの「住所注記」
[idx]["COMM_TYPE"] 　→　配列内のidx番目の出荷伝票アドレスの「通信方法 (キー) (アドレス管理)」
[idx]["TEL1_NUMBR"] 　→　配列内のidx番目の出荷伝票アドレスの「第一電話番号：ダイヤルコード + 番号」
[idx]["TEL1_EXT"]　→　配列内のidx番目の出荷伝票アドレスの「第 1 電話番号：内線」
[idx]["FAX_NUMBER"] 　→　配列内のidx番目の出荷伝票アドレスの「第一 FAX 番号：ダイヤルコード + 番号」
[idx]["FAX_EXTENS"]　→　配列内のidx番目の出荷伝票アドレスの「第一 FAX 番号：内線」
[idx]["STREET_LNG"]　→　配列内のidx番目の出荷伝票アドレスの「地名」
[idx]["DISTRCT_NO"] 　→　配列内のidx番目の出荷伝票アドレスの「市区町村/地名ファイルの所在地コード」
[idx]["CHCKSTATUS"]　→　配列内のidx番目の出荷伝票アドレスの「市区町村ファイルテストステータス」
[idx]["PBOXCIT_NO"] 　→　配列内のidx番目の出荷伝票アドレスの「市区町村私書箱コード (市ファイル)」
[idx]["TRANSPZONE"]　→　配列内のidx番目の出荷伝票アドレスの「商品の納入区域」
[idx]["HOUSE_NO2"]　→　配列内のidx番目の出荷伝票アドレスの「番地補足」
[idx]["E_MAIL"]　→　配列内のidx番目の出荷伝票アドレスの「電子メールアドレス」
[idx]["STR_SUPPL3"]　→　配列内のidx番目の出荷伝票アドレスの「地名 4」
[idx]["TITLE"]　→　配列内のidx番目の出荷伝票アドレスの「タイトル (敬称)」
[idx]["COUNTRYISO"]　→　配列内のidx番目の出荷伝票アドレスの「ISO 国コード」
[idx]["LANGU_ISO"]　→　配列内のidx番目の出荷伝票アドレスの「ISO 639 準拠の言語」
[idx]["BUILD_LONG"]　→　配列内のidx番目の出荷伝票アドレスの「建物 (番号またはコード)」
[idx]["REGIOGROUP"]　→　配列内のidx番目の出荷伝票アドレスの「地域構造グループ化」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getDocumentHeader

Object getDocumentHeader ()

伝票ヘッダを取得します。
返却値
Object 伝票ヘッダオブジェクト

伝票ヘッダオブジェクトの構成は以下のとおりです。
伝票ヘッダ情報
オブジェクト
(Object)
PO_NUMBER 購買伝票番号 (String)
COMP_CODE 会社コード (String)
DOC_TYPE 購買伝票タイプ (String)
DELETE_IND 購買伝票の削除フラグ (String)
STATUS 購買伝票のステータス (String)
CREAT_DATE レコード登録日 (String)
CREATED_BY オブジェクト登録者名 (String)
ITEM_INTVL 明細番号間隔 (String)
VENDOR 仕入先勘定コード (String)
LANGU 言語キー (String)
LANGU_ISO 言語キーの ISO コード (String)
PMNTTRMS 支払条件キー (String)
DSCNT1_TO 現金割引日数 (早期支払) (String)
DSCNT2_TO 現金割引日数 (早期支払) (String)
DSCNT3_TO 現金割引日数 (早期支払) (String)
DSCT_PCT1 割引率 1 (String)
DSCT_PCT2 割引率 2 (String)
PURCH_ORG 購買組織 (String)
PUR_GROUP 購買グループ (String)
CURRENCY 通貨コード (String)
CURRENCY_ISO ISO コード通貨 (String)
EXCH_RATE 換算レート (String)
EX_RATE_FX 区分：換算レート固定 (String)
DOC_DATE 購買伝票日付 (String)
VPER_START 有効期間開始日 (String)
VPER_END 有効期間の終了日 (String)
WARRANTY 保証日 (String)
QUOTATION 見積番号 (String)
QUOT_DATE 見積提出日 (String)
REF_1 得意先/仕入先の内部参照コード (String)
SALES_PERS 仕入先営業担当者 (String)
TELEPHONE 仕入先電話番号 (String)
SUPPL_VEND 供給仕入先 (String)
CUSTOMER 得意先コード 1 (String)
AGREEMENT 購買契約番号 (String)
GR_MESSAGE 区分：入庫メッセージ (String)
SUPPL_PLNT 在庫転送オーダーにおける供給 (出庫) プラント (String)
INCOTERMS1 インコタームズ (1) (String)
INCOTERMS2 インコタームズ 2 (String)
COLLECT_NO 一括番号 (String)
DIFF_INV 仕入先と請求元が異なる場合の請求元のコード (String)
OUR_REF 社内参照番号 (String)
LOGSYSTEM 論理システム (String)
SUBITEMINT 副明細の明細間隔 (String)
PO_REL_IND 承認区分：購買伝票 (String)
REL_STATUS 承認状況 (String)
VAT_CNTRY 売上税 ID 番号国 (String)
VAT_CNTRY_ISO 消費税登録番号の ISO 国コード (String)
REASON_CANCEL 取消理由 (String)
REASON_CODE Goods Receipt Reason Code

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getExportHeader

Object getExportHeader ()

貿易管理ヘッダを取得します｡
返却値
Object 貿易管理ヘッダ

貿易管理ヘッダ情報オブジェクトの構成は以下のとおりです。
貿易管理ヘッダ情報
オブジェクト
(Object)
TRANSPORT_MODE 貿易管理の輸送モード (String)
CUSTOMS 税関：税関 (出国時) (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getExportItemList

Object getExportItemList ()

貿易管理明細一覧を取得します｡
返却値
Object 貿易管理明細一覧

貿易管理明細情報オブジェクトの構成は以下のとおりです。
貿易管理明細情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号 (String)
BUSINESS_TRANSACTION_TYPE 貿易管理の取引タイプ (String)
EXPORT_IMPORT_PROCEDURE 貿易の輸出入手続 (String)
COUNTRYORI 品目の原産国 (String)
COUNTRYORI_ISO ISO 国コード (String)
REGIONORIG 品目の原産地 (非特恵対象地区の原産) (String)
COMM_CODE 貿易：統計品目コード/輸入コード番号 (String)
SHIPPING_COUNTRY 貿易：出荷国 (String)
SHIPPING_COUNTRY_ISO ISO 国コード (String)

取得した貿易管理明細情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の貿易管理明細の「購買伝票の明細番号」
[idx]["BUSINESS_TRANSACTION_TYPE"] →　配列内のidx番目の貿易管理明細の「貿易管理の取引タイプ」
[idx]["EXPORT_IMPORT_PROCEDURE"] 　→　配列内のidx番目の貿易管理明細の「貿易の輸出入手続」
[idx]["COUNTRYORI"]　→　配列内のidx番目の貿易管理明細の「品目の原産国」
[idx]["COUNTRYORI_ISO"]　→　配列内のidx番目の貿易管理明細の「ISO 国コード」
[idx]["REGIONORIG"] 　→　配列内のidx番目の貿易管理明細の「品目の原産地 (非特恵対象地区の原産)」
[idx]["COMM_CODE"]　→　配列内のidx番目の貿易管理明細の「貿易：統計品目コード/輸入コード番号」
[idx]["SHIPPING_COUNTRY"]　→　配列内のidx番目の貿易管理明細の「貿易：出荷国」
[idx]["SHIPPING_COUNTRY_ISO"]　→　配列内のidx番目の貿易管理明細の「ISO 国コード」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getExtensionList

Object getExtensionList ()

拡張得意先項目一覧を取得します｡
返却値
Object 拡張得意先項目一覧

拡張得意先項目情報オブジェクトの構成は以下のとおりです。
拡張得意先項目情報
オブジェクト
(Object)
STRUCTURE BAPI テーブル拡張の構造名 (String)
VALUEPART1 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART2 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART3 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART4 BAPI 拡張パラメータのデータ部分 (String)

取得した拡張得意先項目情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["STRUCTURE"]　→　配列内のidx番目の拡張得意先項目の「BAPI テーブル拡張の構造名」
[idx]["VALUEPART1"] 　→　配列内のidx番目の拡張得意先項目の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART2"] 　→　配列内のidx番目の拡張得意先項目の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART3"] 　→　配列内のidx番目の拡張得意先項目の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART4"] 　→　配列内のidx番目の拡張得意先項目の「BAPI 拡張パラメータのデータ部分」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getHeaderTextList

Object getHeaderTextList ()

ヘッダテキスト一覧を取得します｡
返却値
Object ヘッダテキスト一覧

ヘッダテキスト情報オブジェクトの構成は以下のとおりです。
ヘッダテキスト情報
オブジェクト
(Object)
PO_NUMBER 購買伝票番号 (String)
PO_ITEM 購買伝票の明細番号 (String)
TEXT_ID テキスト ID (String)
TEXT_FORM タグ列 (String)
TEXT_LINE テキスト行 (String)

取得したヘッダテキスト情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_NUMBER"]　→　配列内のidx番目のヘッダテキストの「購買伝票番号」
[idx]["PO_ITEM"]　→　配列内のidx番目のヘッダテキストの「購買伝票の明細番号」
[idx]["TEXT_ID"]　→　配列内のidx番目のヘッダテキストの「テキスト ID」
[idx]["TEXT_FORM"]　→　配列内のidx番目のヘッダテキストの「タグ列」
[idx]["TEXT_LINE"]　→　配列内のidx番目のヘッダテキストの「テキスト行」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getItemTextList

Object getItemTextList ()

明細テキスト一覧を取得します｡
返却値
Object 明細テキスト

明細テキスト情報オブジェクトの構成は以下のとおりです。
明細テキスト情報
オブジェクト
(Object)
PO_NUMBER 購買伝票番号 (String)
PO_ITEM 購買伝票の明細番号 (String)
TEXT_ID テキスト ID (String)
TEXT_FORM タグ列 (String)
TEXT_LINE テキスト行 (String)

取得した明細テキスト情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_NUMBER"]　→　配列内のidx番目の明細テキストの「購買伝票番号」
[idx]["PO_ITEM"]　→　配列内のidx番目の明細テキストの「購買伝票の明細番号」
[idx]["TEXT_ID"]　→　配列内のidx番目の明細テキストの「テキスト ID」
[idx]["TEXT_FORM"]　→　配列内のidx番目の明細テキストの「タグ列」
[idx]["TEXT_LINE"]　→　配列内のidx番目の明細テキストの「テキスト行」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getLimitsList

Object getLimitsList ()

外注制限一覧を取得します｡
返却値
Object 外注制限一覧

外注制限情報オブジェクトの構成は以下のとおりです。
外注制限情報
オブジェクト
(Object)
PCKG_NO パッケージ番号 (String)
LIMIT 全体制限 (String)
NO_LIMIT 制限なし (String)
EXP_VALUE 見込金額 (String)
SSC_EXIST サービスタイプの制限 (String)
CON_EXIST 基本契約明細の制限 (String)
TMP_EXIST サービスパッケージの制限 (String)
PRICE_CHG 入力シートの価格変更 (String)
FREE_LIMIT 自由制限 (String)
NO_FRLIMIT 制限なし (String)
SERV_TYPE サービスタイプのテキスト (短) (String)
EDITION サービスタイプのバージョン (String)
SSC_LIMIT サービスタイプの金額制限 (String)
SSC_NOLIM 標準サービスタイプの制限なし (String)
SSC_PRSCHG 入力シートの価格変更 (String)
SSC_PERC 価格決定率 (String)
TMP_NUMBER モデルサービス明細セット番号 (String)
TMP_LIMIT モデルサービス明細制限 (String)
TMP_NOLIM モデル仕様の制限なし (String)
TMP_PRSCHG 入力シートの価格変更 (String)
TMP_PERC 価格決定率 (String)
CONT_PERC 価格決定率 (String)

取得した外注制限情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PCKG_NO"]　→　配列内のidx番目の外注制限の「パッケージ番号」
[idx]["LIMIT"]　→　配列内のidx番目の外注制限の「全体制限」
[idx]["NO_LIMIT"]　→　配列内のidx番目の外注制限の「制限なし」
[idx]["EXP_VALUE"]　→　配列内のidx番目の外注制限の「見込金額」
[idx]["SSC_EXIST"]　→　配列内のidx番目の外注制限の「サービスタイプの制限」
[idx]["CON_EXIST"]　→　配列内のidx番目の外注制限の「基本契約明細の制限」
[idx]["TMP_EXIST"]　→　配列内のidx番目の外注制限の「サービスパッケージの制限」
[idx]["PRICE_CHG"]　→　配列内のidx番目の外注制限の「入力シートの価格変更」
[idx]["FREE_LIMIT"]　→　配列内のidx番目の外注制限の「自由制限」
[idx]["NO_FRLIMIT"]　→　配列内のidx番目の外注制限の「制限なし」
[idx]["SERV_TYPE"]　→　配列内のidx番目の外注制限の「サービスタイプのテキスト (短)」
[idx]["EDITION"]　→　配列内のidx番目の外注制限の「サービスタイプのバージョン」
[idx]["SSC_LIMIT"]　→　配列内のidx番目の外注制限の「サービスタイプの金額制限」
[idx]["SSC_NOLIM"]　→　配列内のidx番目の外注制限の「標準サービスタイプの制限なし」
[idx]["SSC_PRSCHG"]　→　配列内のidx番目の外注制限の「入力シートの価格変更」
[idx]["SSC_PERC"]　→　配列内のidx番目の外注制限の「価格決定率」
[idx]["TMP_NUMBER"]　→　配列内のidx番目の外注制限の「モデルサービス明細セット番号」
[idx]["TMP_LIMIT"]　→　配列内のidx番目の外注制限の「モデルサービス明細制限」
[idx]["TMP_NOLIM"]　→　配列内のidx番目の外注制限の「モデル仕様の制限なし」
[idx]["TMP_PRSCHG"]　→　配列内のidx番目の外注制限の「入力シートの価格変更」
[idx]["TMP_PERC"]　→　配列内のidx番目の外注制限の「価格決定率」
[idx]["CONT_PERC"]　→　配列内のidx番目の外注制限の「価格決定率」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getMemoryComplete

Object getMemoryComplete ()

エラーがない場合に購買発注を保留にする区分を取得します｡

返却値
Object エラーがない場合に購買発注を保留にする区分
getMemoryUnComplete

Object getMemoryUnComplete ()

エラーがある場合に購買発注を保留にする区分を取得します｡

返却値
Object エラーがある場合に購買発注を保留にする区分
getNoAuthority

Object getNoAuthority ()

権限チェックなし区分を取得します｡

返却値
Object 権限チェックなし区分
getNoMessageReq

Object getNoMessageReq ()

メッセージ不要区分を取得します｡

返却値
Object メッセージ不要区分
getNoMessaging

Object getNoMessaging ()

出力決定なし区分を取得します。

返却値
Object 出力決定なし区分
getNoPriceFromPo

Object getNoPriceFromPo ()

最終伝票からの価格転送なし区分を取得します｡

返却値
Object 最終伝票からの価格転送なし区分
getPartnerList

Object getPartnerList ()

得意先一覧を取得します｡
返却値
Object 得意先一覧

得意先情報オブジェクトの構成は以下のとおりです。
得意先情報
オブジェクト
(Object)
PARTNERDESC 言語別取引先機能テキスト (String)
LANGU 言語キー (String)
BUSPARTNO 取引先の仕入先マスタコード (String)
DELETE_IND 削除フラグ (String)

取得した得意先情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PARTNERDESC"]　→　配列内のidx番目の得意先の「言語別取引先機能テキスト」
[idx]["LANGU"]　→　配列内のidx番目の得意先の「言語キー」
[idx]["BUSPARTNO"]　→　配列内のidx番目の得意先の「取引先の仕入先マスタコード」
[idx]["DELETE_IND"]　→　配列内のidx番目の得意先の「削除フラグ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPoNumber

Object getPoNumber ()

購買伝票番号を取得します｡

返却値
Object 購買伝票番号
getProfitSegmentList

Object getProfitSegmentList ()

入出庫予定一覧を取得します｡
返却値
Object 入出庫予定一覧

入出庫予定情報オブジェクトの構成は以下のとおりです。
入出庫予定情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号 (String)
SERIAL_NO 勘定設定の連続番号 (String)
FIELDNAME 項目名 (String)
VALUE CO-PA 特性値 (String)

取得した入出庫予定情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の入出庫予定の「購買伝票の明細番号」
[idx]["SERIAL_NO"]　→　配列内のidx番目の入出庫予定の「勘定設定の連続番号」
[idx]["FIELDNAME"]　→　配列内のidx番目の入出庫予定の「項目名」
[idx]["VALUE"]　→　配列内のidx番目の入出庫予定の「CO-PA 特性値」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPurchaseAccountList

Object getPurchaseAccountList ()

勘定設定一覧を取得します｡
返却値
Object 勘定設定一覧

勘定設定情報オブジェクトの構成は以下のとおりです。
勘定設定情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号 (String)
SERIAL_NO 勘定設定の連続番号 (String)
DELETE_IND 削除フラグ：購買伝票勘定設定 (String)
CREAT_DATE レコード登録日 (String)
QUANTITY 数量 (String)
DISTR_PERC 配賦率 % (複数勘定設定) (String)
NET_VALUE BAPI の通貨額 (小数点以下９桁) (String)
GL_ACCOUNT G/L 勘定コード (String)
BUS_AREA 事業領域 (String)
COSTCENTER 原価センタ (String)
SD_DOC 販売管理伝票番号 (String)
ITM_NUMBER 販売伝票明細 (String)
SCHED_LINE 納入日程行 (String)
ASSET_NO 資産番号 (String)
SUB_NUMBER 資産補助番号 (String)
ORDERID 指図番号 (String)
GR_RCPT 受領者 (String)
UNLOAD_PT 荷渡ポイント (String)
CO_AREA 管理領域 (String)
COSTOBJECT 原価対象 (String)
PROFIT_CTR 利益センタ (String)
WBS_ELEMENT WBS 要素 (String)
NETWORK 勘定割当のネットワーク番号 (String)
RL_EST_KEY 不動産管理対象の内部キー (String)
PART_ACCT 取引先勘定コード (String)
CMMT_ITEM 資金予算コード (String)
REC_IND リカバリフラグ (String)
FUNDS_CTR 予算センタ (String)
FUND 会計区分 (String)
FUNC_AREA 機能領域 (String)
REF_DATE 決済の参照日付 (String)
TAX_CODE 消費税コード (String)
TAXJURCODE 税計算管轄コード - 税管轄コード (String)
NOND_ITAX BAPI の通貨額 (小数点以下９桁) (String)
ACTTYPE 活動タイプ (String)
CO_BUSPROC 業務プロセス (String)
RES_DOC 用途指定予算の伝票番号 (String)
RES_ITEM 用途指定予算：伝票明細 (String)
ACTIVITY 作業番号 (String)
GRANT_NBR 補助金 (String)
CMMT_ITEM_LONG 資金予算コード (String)
FUNC_AREA_LONG 機能領域 (String)

取得した勘定設定情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の勘定設定の「購買伝票の明細番号」
[idx]["SERIAL_NO"]　→　配列内のidx番目の勘定設定の「勘定設定の連続番号」
[idx]["DELETE_IND"]　→　配列内のidx番目の勘定設定の「削除フラグ：購買伝票勘定設定」
[idx]["CREAT_DATE"]　→　配列内のidx番目の勘定設定の「レコード登録日」
[idx]["QUANTITY"]　→　配列内のidx番目の勘定設定の「数量」
[idx]["DISTR_PERC"]　→　配列内のidx番目の勘定設定の「配賦率 % (複数勘定設定)」
[idx]["NET_VALUE"]　→　配列内のidx番目の勘定設定の「BAPI の通貨額 (小数点以下９桁)」
[idx]["GL_ACCOUNT"]　→　配列内のidx番目の勘定設定の「G/L 勘定コード」
[idx]["BUS_AREA"]　→　配列内のidx番目の勘定設定の「事業領域」
[idx]["COSTCENTER"]　→　配列内のidx番目の勘定設定の「原価センタ」
[idx]["SD_DOC"]　→　配列内のidx番目の勘定設定の「販売管理伝票番号」
[idx]["ITM_NUMBER"]　→　配列内のidx番目の勘定設定の「販売伝票明細」
[idx]["SCHED_LINE"]　→　配列内のidx番目の勘定設定の「納入日程行」
[idx]["ASSET_NO"]　→　配列内のidx番目の勘定設定の「資産番号」
[idx]["SUB_NUMBER"]　→　配列内のidx番目の勘定設定の「資産補助番号」
[idx]["ORDERID"]　→　配列内のidx番目の勘定設定の「指図番号」
[idx]["GR_RCPT"]　→　配列内のidx番目の勘定設定の「受領者」
[idx]["UNLOAD_PT"]　→　配列内のidx番目の勘定設定の「荷渡ポイント」
[idx]["CO_AREA"]　→　配列内のidx番目の勘定設定の「管理領域」
[idx]["COSTOBJECT"]　→　配列内のidx番目の勘定設定の「原価対象」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の勘定設定の「利益センタ」
[idx]["WBS_ELEMENT"]　→　配列内のidx番目の勘定設定の「WBS 要素」
[idx]["NETWORK"]　→　配列内のidx番目の勘定設定の「勘定割当のネットワーク番号」
[idx]["RL_EST_KEY"]　→　配列内のidx番目の勘定設定の「不動産管理対象の内部キー」
[idx]["PART_ACCT"]　→　配列内のidx番目の勘定設定の「取引先勘定コード」
[idx]["CMMT_ITEM"]　→　配列内のidx番目の勘定設定の「資金予算コード」
[idx]["REC_IND"]　→　配列内のidx番目の勘定設定の「リカバリフラグ」
[idx]["FUNDS_CTR"]　→　配列内のidx番目の勘定設定の「予算センタ」
[idx]["FUND"]　→　配列内のidx番目の勘定設定の「会計区分」
[idx]["FUNC_AREA"]　→　配列内のidx番目の勘定設定の「機能領域」
[idx]["REF_DATE"]　→　配列内のidx番目の勘定設定の「決済の参照日付」
[idx]["TAX_CODE"]　→　配列内のidx番目の勘定設定の「消費税コード」
[idx]["TAXJURCODE"]　→　配列内のidx番目の勘定設定の「税計算管轄コード - 税管轄コード」
[idx]["NOND_ITAX"]　→　配列内のidx番目の勘定設定の「BAPI の通貨額 (小数点以下９桁)」
[idx]["ACTTYPE"]　→　配列内のidx番目の勘定設定の「活動タイプ」
[idx]["CO_BUSPROC"]　→　配列内のidx番目の勘定設定の「業務プロセス」
[idx]["RES_DOC"]　→　配列内のidx番目の勘定設定の「用途指定予算の伝票番号」
[idx]["RES_ITEM"]　→　配列内のidx番目の勘定設定の「用途指定予算：伝票明細」
[idx]["ACTIVITY"]　→　配列内のidx番目の勘定設定の「作業番号」
[idx]["GRANT_NBR"]　→　配列内のidx番目の勘定設定の「補助金」
[idx]["CMMT_ITEM_LONG"]　→　配列内のidx番目の勘定設定の「資金予算コード」
[idx]["FUNC_AREA_LONG"]　→　配列内のidx番目の勘定設定の「機能領域」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPurchaseComponentsList

Object getPurchaseComponentsList ()

コンポーネント一覧を取得します｡
返却値
Object コンポーネント一覧

コンポーネント情報オブジェクトの構成は以下のとおりです。
コンポーネント情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号
SCHED_LINE 納入日程行
ITEM_NO 入出庫予定/従属所要量の明細番号
MATERIAL 品目コード
ENTRY_QUANTITY 構成品目の所要量
ENTRY_UOM 入力単位
ENTRY_UOM_ISO 入力単位 (ISO コード)
FIXED_QUAN 数量固定
PLANT プラント
REQ_DATE 構成品目の所要日付
CHANGE_ID 変更タイプ(U、I、E、D)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード (長)
MATERIAL_GUID 項目 MATERIAL の外部 GUID
MATERIAL_VERSION 項目 MATERIAL のバージョン番号

取得したコンポーネント情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の出荷データの「購買伝票の明細番号」
[idx]["SCHED_LINE"]　→　配列内のidx番目の出荷データの「納入日程行」
[idx]["ITEM_NO"]　→　配列内のidx番目の出荷データの「入出庫予定/従属所要量の明細番号」
[idx]["MATERIAL"]　→　配列内のidx番目の出荷データの「品目コード」
[idx]["ENTRY_QUANTITY"]　→　配列内のidx番目の出荷データの「構成品目の所要量」
[idx]["ENTRY_UOM"]　→　配列内のidx番目の出荷データの「入力単位」
[idx]["ENTRY_UOM_ISO"] 　→　配列内のidx番目の出荷データの「入力単位 (ISO コード)」
[idx]["FIXED_QUAN"]　→　配列内のidx番目の出荷データの「数量固定」
[idx]["PLANT"]　→　配列内のidx番目の出荷データの「プラント」
[idx]["REQ_DATE"]　→　配列内のidx番目の出荷データの「構成品目の所要日付」
[idx]["CHANGE_ID"]　→　配列内のidx番目の出荷データの「変更タイプ(U、I、E、D)」
[idx]["MATERIAL_EXTERNAL"] 　→　配列内のidx番目の出荷データの「項目 MATERIAL の品目コード (長)」
[idx]["MATERIAL_GUID"] 　→　配列内のidx番目の出荷データの「項目 MATERIAL の外部 GUID」
[idx]["MATERIAL_VERSION"] 　→　配列内のidx番目の出荷データの「項目 MATERIAL のバージョン番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPurchaseItemPostList

Object getPurchaseItemPostList ()

明細一覧を取得します｡
返却値
Object 明細一覧

明細情報オブジェクトの構成は以下のとおりです。
明細情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号 (String)
DELETE_IND 購買伝票の削除フラグ (String)
SHORT_TEXT テキスト (短) (String)
MATERIAL 品目コード (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード (長) (今後のリリースで開発) (String)
MATERIAL_GUID 項目 MATERIAL の外部 GUID (今後のリリースで開発) (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (今後のリリースで開発) (String)
EMATERIAL 品目コード (String)
EMATERIAL_EXTERNAL 項目 MATERIAL の品目コード (長) (今後のリリースで開発) (String)
EMATERIAL_GUID 項目 MATERIAL の外部 GUID (今後のリリースで開発) (String)
EMATERIAL_VERSION 項目 MATERIAL のバージョン番号 (今後のリリースで開発) (String)
PLANT プラント (String)
STGE_LOC 保管場所 (String)
TRACKINGNO 購買依頼追跡番号 (String)
MATL_GROUP 品目グループ (String)
INFO_REC 購買情報番号 (String)
VEND_MAT 仕入先が使用している品目コード (String)
QUANTITY 購買発注数量 (String)
PO_UNIT 発注単位 (String)
PO_UNIT_ISO ISO コードによる発注単位 (String)
ORDERPR_UN 購買発注価格単位 (購買管理) (String)
ORDERPR_UN_ISO 購買発注価格単位の ISO コード (String)
CONV_NUM1 購買価格単位から購買発注単位への変換分子 (String)
CONV_DEN1 購買価格単位から購買発注単位への変換分母 (String)
NET_PRICE BAPI の通貨額 (小数点以下９桁) (String)
PRICE_UNIT 価格単位 (String)
GR_PR_TIME 入庫処理日数 (String)
TAX_CODE 消費税コード (String)
BON_GRP1 決済グループ 1（購買） (String)
QUAL_INSP 在庫タイプ (String)
INFO_UPD 区分：購買情報更新 (String)
PRNT_PRICE 価格印刷 (String)
EST_PRICE 区分：概算価格 (String)
REMINDER1 第一回催促状/督促状の日数 (String)
REMINDER2 第二回催促状/督促状の日数 (String)
REMINDER3 第三回催促状/督促状の日数 (String)
OVER_DLV_TOL 過剰納入許容範囲 (String)
UNLIMITED_DLV 区分：無制限過剰納入可能 (String)
UNDER_DLV_TOL 不足納入許容範囲リミット (String)
VAL_TYPE 評価タイプ (String)
NO_MORE_GR 納入完了 区分 (String)
FINAL_INV 請求書処理完了区分 (String)
ITEM_CAT 購買伝票の明細カテゴリ (String)
ACCTASSCAT 勘定設定カテゴリ (String)
DISTRIB 複数勘定設定の配賦区分 (String)
PART_INV 一部請求区分 (String)
GR_IND 入庫区分 (String)
GR_NON_VAL 非評価入庫 (String)
IR_IND 請求書受領区分 (String)
FREE_ITEM 無償明細 (String)
GR_BASEDIV 区分：入庫基準の請求書照合 (String)
ACKN_REQD 購買発注請書依頼 (String)
ACKNOWL_NO 購買発注請書番号 (String)
AGREEMENT 購買契約番号 (String)
AGMT_ITEM 購買契約の明細番号 (String)
SHIPPING 出荷指示 (String)
CUSTOMER 得意先 (String)
COND_GROUP 仕入先条件グループ (String)
NO_DISCT 現金値引対象外明細 (String)
PLAN_DEL 予定納入日数 (String)
NET_WEIGHT 正味重量 (String)
WEIGHTUNIT 重量単位 (String)
WEIGHTUNIT_ISO 重量単位の ISO コード (String)
TAXJURCODE 税計算管轄コード - 税管轄コード (String)
CTRL_KEY 調達における品質管理の管理キー (String)
CONF_CTRL 確認管理キー (String)
REV_LEV 改訂レベル (String)
FUND 会計区分 (String)
FUNDS_CTR 予算センタ (String)
CMMT_ITEM 資金予算コード (String)
PRICEDATE 価格設定日カテゴリ (価格設定日管理) (String)
PRICE_DATE 価格設定日 (String)
GROSS_WT 総重量 (String)
VOLUME 容積 (String)
VOLUMEUNIT 容積単位 (String)
VOLUMEUNIT_ISO ISO コードでの容積単位 (String)
INCOTERMS1 インコタームズ (1) (String)
INCOTERMS2 インコタームズ 2 (String)
PRE_VENDOR 製造元/販売元 (String)
VEND_PART 仕入先部門 (String)
HL_ITEM 購買伝票中の上位明細 (String)
GR_TO_DATE 納入最終期限 (String)
SUPP_VENDOR 供給仕入先/仕入入庫 (String)
SC_VENDOR 外注仕入先 (String)
KANBAN_IND かんばん区分 (String)
ERS ERS（入庫/請求自動決済） (String)
R_PROMO プロモーション (String)
POINTS リベートポイント数 (String)
POINT_UNIT ポイント単位 (String)
POINT_UNIT_ISO ポイント単位の ISO コード (String)
SEASON 季節カテゴリ (String)
SEASON_YR シーズン年度 (String)
BON_GRP2 決済グループ 2 (リベート決済、購買) (String)
BON_GRP3 決済グループ 3 (リベート決済、購買) (String)
SETT_ITEM リベート (期末) 決済対象の明細 (String)
MINREMLIFE 最低有効期間残 (String)
RFQ_NO 見積依頼番号 (String)
RFQ_ITEM 見積依頼明細番号 (String)
PREQ_NO 購買依頼番号 (String)
PREQ_ITEM 購買依頼の明細番号 (String)
REF_DOC 参照伝票番号 (String)
REF_ITEM 参照伝票の明細 (String)
SI_CAT 補助明細カテゴリ、購買伝票 (String)
RET_ITEM 返品明細 (String)
AT_RELEV 割当テーブル関連 (String)
ORDER_REASON 発注理由 (String)
BRAS_NBM Brazilian NCM Code (String)
MATL_USAGE 品目の用途 (String)
MAT_ORIGIN 品目の原産地 (String)
IN_HOUSE 内部生産 (String)
INDUS3 品目 CFOP カテゴリ (String)
INF_INDEX インフレーション指数 (String)
UNTIL_DATE インフレーション指数日付 (String)
DELIV_COMPL 出荷完了 区分 (String)
PART_DELIV 明細レベルでの分割納入 (在庫転送) (String)
SHIP_BLOCKED SD 出荷伝票の明細ブロック (String)
PREQ_NAME 購買依頼者名/要求者名 (String)
PERIOD_IND_EXPIRATION_DATE 有効期間期限日の期間区分 (String)
INT_OBJ_NO 選定 (内部オブジェクト番号) (String)
PCKG_NO パッケージ番号 (String)
BATCH ロット番号 (String)
VENDRBATCH 仕入先ロット番号 (String)
CALCTYPE 価格設定タイプ (String)
GRANT_NBR 補助金 (String)
CMMT_ITEM_LONG 資金予算コード (String)
FUNC_AREA_LONG 機能領域 (String)
NO_ROUNDING 区分：購買発注明細での非表示丸め (String)
PO_PRICE 区分：価格採用：1 = 総額、2 = 正味額 (String)
SUPPL_STLOC 出庫保管場所：在庫転送オーダー (String)
SRV_BASED_IV サービス基準請求書照合の区分 (String)
FUNDS_RES 予算執行伝票の伝票番号 (String)
RES_ITEM 用途指定予算: 伝票明細 (String)
ORIG_ACCEPT 仕入先構内での受領 (String)
ALLOC_TBL 商品配分表番号 (String)
ALLOC_TBL_ITEM 割当テーブルの明細番号 (String)
SRC_STOCK_TYPE 在庫転送オーダーの元保管場所在庫タイプ (String)
REASON_REJ 見積および受注の拒否理由 (String)
CRM_SALES_ORDER_NO 仕入先直送発注処理の CRM 受注番号 (String)
CRM_SALES_ORDER_ITEM_NO 仕入先直送発注処理での CRM 受注明細番号 (String)
CRM_REF_SALES_ORDER_NO 仕入先直送発注処理の CRM 参照受注番号 (String)
CRM_REF_SO_ITEM_NO 仕入先直送発注処理での CRM 参照受注明細番号 (String)
PRIO_URGENCY 所要量の緊急度 (String)
PRIO_REQUIREMENT 所要量の優先順位 (String)
REASON_CODE Goods Receipt Reason Code (String)

取得した明細情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の明細の「購買伝票の明細番号」
[idx]["DELETE_IND"]　→　配列内のidx番目の明細の「購買伝票の削除フラグ」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の明細の「テキスト (短)」
[idx]["MATERIAL"] 　→　配列内のidx番目の明細の「品目コード」
[idx]["MATERIAL_EXTERNAL"] 　→　配列内のidx番目の明細の「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["MATERIAL_GUID"] 　→　配列内のidx番目の明細の「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["MATERIAL_VERSION"] 　→　配列内のidx番目の明細の「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」
[idx]["EMATERIAL"]　→　配列内のidx番目の明細の「品目コード」
[idx]["EMATERIAL_EXTERNAL"] 　→　配列内のidx番目の明細の「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["EMATERIAL_GUID"] 　→　配列内のidx番目の明細の「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["EMATERIAL_VERSION"] 　→　配列内のidx番目の明細の「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」
[idx]["PLANT"]　→　配列内のidx番目の明細の「プラント」
[idx]["STGE_LOC"]　→　配列内のidx番目の明細の「保管場所」
[idx]["TRACKINGNO"]　→　配列内のidx番目の明細の「購買依頼追跡番号」
[idx]["MATL_GROUP"]　→　配列内のidx番目の明細の「品目グループ」
[idx]["INFO_REC"]　→　配列内のidx番目の明細の「購買情報番号」
[idx]["VEND_MAT"]　→　配列内のidx番目の明細の「仕入先が使用している品目コード」
[idx]["QUANTITY"]　→　配列内のidx番目の明細の「購買発注数量」
[idx]["PO_UNIT"]　→　配列内のidx番目の明細の「発注単位」
[idx]["PO_UNIT_ISO"]　→　配列内のidx番目の明細の「ISO コードによる発注単位」
[idx]["ORDERPR_UN"]　→　配列内のidx番目の明細の「購買発注価格単位 (購買管理)」
[idx]["ORDERPR_UN_ISO"]　→　配列内のidx番目の明細の「購買発注価格単位の ISO コード」
[idx]["CONV_NUM1"]　→　配列内のidx番目の明細の「購買価格単位から購買発注単位への変換分子」
[idx]["CONV_DEN1"]　→　配列内のidx番目の明細の「購買価格単位から購買発注単位への変換分母」
[idx]["NET_PRICE"]　→　配列内のidx番目の明細の「BAPI の通貨額 (小数点以下９桁)」
[idx]["PRICE_UNIT"]　→　配列内のidx番目の明細の「価格単位」
[idx]["GR_PR_TIME"]　→　配列内のidx番目の明細の「入庫処理日数」
[idx]["TAX_CODE"]　→　配列内のidx番目の明細の「消費税コード」
[idx]["BON_GRP1"]　→　配列内のidx番目の明細の「決済グループ 1（購買）」
[idx]["QUAL_INSP"]　→　配列内のidx番目の明細の「在庫タイプ」
[idx]["INFO_UPD"]　→　配列内のidx番目の明細の「区分：購買情報更新」
[idx]["PRNT_PRICE"]　→　配列内のidx番目の明細の「価格印刷」
[idx]["EST_PRICE"]　→　配列内のidx番目の明細の「区分：概算価格」
[idx]["REMINDER1"]　→　配列内のidx番目の明細の「第一回催促状/督促状の日数」
[idx]["REMINDER2"]　→　配列内のidx番目の明細の「第二回催促状/督促状の日数」
[idx]["REMINDER3"]　→　配列内のidx番目の明細の「第三回催促状/督促状の日数」
[idx]["OVER_DLV_TOL"]　→　配列内のidx番目の明細の「過剰納入許容範囲」
[idx]["UNLIMITED_DLV"]　→　配列内のidx番目の明細の「区分：無制限過剰納入可能」
[idx]["UNDER_DLV_TOL"]　→　配列内のidx番目の明細の「不足納入許容範囲リミット」
[idx]["VAL_TYPE"]　→　配列内のidx番目の明細の「評価タイプ」
[idx]["NO_MORE_GR"]　→　配列内のidx番目の明細の「納入完了 区分」
[idx]["FINAL_INV"]　→　配列内のidx番目の明細の「請求書処理完了区分」
[idx]["ITEM_CAT"]　→　配列内のidx番目の明細の「購買伝票の明細カテゴリ」
[idx]["ACCTASSCAT"]　→　配列内のidx番目の明細の「勘定設定カテゴリ」
[idx]["DISTRIB"]　→　配列内のidx番目の明細の「複数勘定設定の配賦区分」
[idx]["PART_INV"]　→　配列内のidx番目の明細の「一部請求区分」
[idx]["GR_IND"]　→　配列内のidx番目の明細の「入庫区分」
[idx]["GR_NON_VAL"]　→　配列内のidx番目の明細の「非評価入庫」
[idx]["IR_IND"]　→　配列内のidx番目の明細の「請求書受領区分」
[idx]["FREE_ITEM"]　→　配列内のidx番目の明細の「無償明細」
[idx]["GR_BASEDIV"]　→　配列内のidx番目の明細の「区分：入庫基準の請求書照合」
[idx]["ACKN_REQD"]　→　配列内のidx番目の明細の「購買発注請書依頼」
[idx]["ACKNOWL_NO"]　→　配列内のidx番目の明細の「購買発注請書番号」
[idx]["AGREEMENT"]　→　配列内のidx番目の明細の「購買契約番号」
[idx]["AGMT_ITEM"]　→　配列内のidx番目の明細の「購買契約の明細番号」
[idx]["SHIPPING"]　→　配列内のidx番目の明細の「出荷指示」
[idx]["CUSTOMER"]　→　配列内のidx番目の明細の「得意先」
[idx]["COND_GROUP"]　→　配列内のidx番目の明細の「仕入先条件グループ」
[idx]["NO_DISCT"]　→　配列内のidx番目の明細の「現金値引対象外明細」
[idx]["PLAN_DEL"]　→　配列内のidx番目の明細の「予定納入日数」
[idx]["NET_WEIGHT"]　→　配列内のidx番目の明細の「正味重量」
[idx]["WEIGHTUNIT"]　→　配列内のidx番目の明細の「重量単位」
[idx]["WEIGHTUNIT_ISO"]　→　配列内のidx番目の明細の「重量単位の ISO コード」
[idx]["TAXJURCODE"]　→　配列内のidx番目の明細の「税計算管轄コード - 税管轄コード」
[idx]["CTRL_KEY"]　→　配列内のidx番目の明細の「調達における品質管理の管理キー」
[idx]["CONF_CTRL"]　→　配列内のidx番目の明細の「確認管理キー」
[idx]["REV_LEV"]　→　配列内のidx番目の明細の「改訂レベル」
[idx]["FUND"]　→　配列内のidx番目の明細の「会計区分」
[idx]["FUNDS_CTR"]　→　配列内のidx番目の明細の「予算センタ」
[idx]["CMMT_ITEM"]　→　配列内のidx番目の明細の「資金予算コード」
[idx]["PRICEDATE"]　→　配列内のidx番目の明細の「価格設定日カテゴリ (価格設定日管理)」
[idx]["PRICE_DATE"]　→　配列内のidx番目の明細の「価格設定日」
[idx]["GROSS_WT"]　→　配列内のidx番目の明細の「総重量」
[idx]["VOLUME"]　→　配列内のidx番目の明細の「容積」
[idx]["VOLUMEUNIT"]　→　配列内のidx番目の明細の「容積単位」
[idx]["VOLUMEUNIT_ISO"]　→　配列内のidx番目の明細の「ISO コードでの容積単位」
[idx]["INCOTERMS1"]　→　配列内のidx番目の明細の「インコタームズ (1)」
[idx]["INCOTERMS2"]　→　配列内のidx番目の明細の「インコタームズ 2」
[idx]["PRE_VENDOR"]　→　配列内のidx番目の明細の「製造元/販売元」
[idx]["VEND_PART"]　→　配列内のidx番目の明細の「仕入先部門」
[idx]["HL_ITEM"]　→　配列内のidx番目の明細の「購買伝票中の上位明細」
[idx]["GR_TO_DATE"]　→　配列内のidx番目の明細の「納入最終期限」
[idx]["SUPP_VENDOR"]　→　配列内のidx番目の明細の「供給仕入先/仕入入庫」
[idx]["SC_VENDOR"]　→　配列内のidx番目の明細の「外注仕入先」
[idx]["KANBAN_IND"]　→　配列内のidx番目の明細の「かんばん区分」
[idx]["ERS"]　→　配列内のidx番目の明細の「ERS（入庫/請求自動決済）」
[idx]["R_PROMO"]　→　配列内のidx番目の明細の「プロモーション」
[idx]["POINTS"]　→　配列内のidx番目の明細の「リベートポイント数」
[idx]["POINT_UNIT"]　→　配列内のidx番目の明細の「ポイント単位」
[idx]["POINT_UNIT_ISO"]　→　配列内のidx番目の明細の「ポイント単位の ISO コード」
[idx]["SEASON"]　→　配列内のidx番目の明細の「季節カテゴリ」
[idx]["SEASON_YR"]　→　配列内のidx番目の明細の「シーズン年度」
[idx]["BON_GRP2"]　→　配列内のidx番目の明細の「決済グループ 2 (リベート決済、購買)」
[idx]["BON_GRP3"]　→　配列内のidx番目の明細の「決済グループ 3 (リベート決済、購買)」
[idx]["SETT_ITEM"]　→　配列内のidx番目の明細の「リベート (期末) 決済対象の明細」
[idx]["MINREMLIFE"]　→　配列内のidx番目の明細の「最低有効期間残」
[idx]["RFQ_NO"]　→　配列内のidx番目の明細の「見積依頼番号」
[idx]["RFQ_ITEM"]　→　配列内のidx番目の明細の「見積依頼明細番号」
[idx]["PREQ_NO"]　→　配列内のidx番目の明細の「購買依頼番号」
[idx]["PREQ_ITEM"]　→　配列内のidx番目の明細の「購買依頼の明細番号」
[idx]["REF_DOC"]　→　配列内のidx番目の明細の「参照伝票番号」
[idx]["REF_ITEM"]　→　配列内のidx番目の明細の「参照伝票の明細」
[idx]["SI_CAT"]　→　配列内のidx番目の明細の「補助明細カテゴリ、購買伝票」
[idx]["RET_ITEM"]　→　配列内のidx番目の明細の「返品明細」
[idx]["AT_RELEV"]　→　配列内のidx番目の明細の「割当テーブル関連」
[idx]["ORDER_REASON"]　→　配列内のidx番目の明細の「発注理由」
[idx]["BRAS_NBM"]　→　配列内のidx番目の明細の「Brazilian NCM Code」
[idx]["MATL_USAGE"]　→　配列内のidx番目の明細の「品目の用途」
[idx]["MAT_ORIGIN"]　→　配列内のidx番目の明細の「品目の原産地」
[idx]["IN_HOUSE"]　→　配列内のidx番目の明細の「内部生産」
[idx]["INDUS3"]　→　配列内のidx番目の明細の「品目 CFOP カテゴリ」
[idx]["INF_INDEX"]　→　配列内のidx番目の明細の「インフレーション指数」
[idx]["UNTIL_DATE"]　→　配列内のidx番目の明細の「インフレーション指数日付」
[idx]["DELIV_COMPL"]　→　配列内のidx番目の明細の「出荷完了 区分」
[idx]["PART_DELIV"]　→　配列内のidx番目の明細の「明細レベルでの分割納入 (在庫転送)」
[idx]["SHIP_BLOCKED"]　→　配列内のidx番目の明細の「SD 出荷伝票の明細ブロック」
[idx]["PREQ_NAME"]　→　配列内のidx番目の明細の「購買依頼者名/要求者名」
[idx]["PERIOD_IND_EXPIRATION_DATE"] 　→　配列内のidx番目の明細の「有効期間期限日の期間区分」
[idx]["INT_OBJ_NO"]　→　配列内のidx番目の明細の「選定 (内部オブジェクト番号)」
[idx]["PCKG_NO"]　→　配列内のidx番目の明細の「パッケージ番号」
[idx]["BATCH"]　→　配列内のidx番目の明細の「ロット番号」
[idx]["VENDRBATCH"]　→　配列内のidx番目の明細の「仕入先ロット番号」
[idx]["CALCTYPE"]　→　配列内のidx番目の明細の「価格設定タイプ」
[idx]["GRANT_NBR"]　→　配列内のidx番目の明細の「補助金」
[idx]["CMMT_ITEM_LONG"]　→　配列内のidx番目の明細の「資金予算コード」
[idx]["FUNC_AREA_LONG"]　→　配列内のidx番目の明細の「機能領域」
[idx]["NO_ROUNDING"]　→　配列内のidx番目の明細の「区分：購買発注明細での非表示丸め」
[idx]["PO_PRICE"]　→　配列内のidx番目の明細の「区分：価格採用：1 = 総額、2 = 正味額」
[idx]["SUPPL_STLOC"]　→　配列内のidx番目の明細の「出庫保管場所：在庫転送オーダー」
[idx]["SRV_BASED_IV"]　→　配列内のidx番目の明細の「サービス基準請求書照合の区分」
[idx]["FUNDS_RES"]　→　配列内のidx番目の明細の「予算執行伝票の伝票番号」
[idx]["RES_ITEM"]　→　配列内のidx番目の明細の「用途指定予算: 伝票明細」
[idx]["ORIG_ACCEPT"]　→　配列内のidx番目の明細の「仕入先構内での受領」
[idx]["ALLOC_TBL"]　→　配列内のidx番目の明細の「商品配分表番号」
[idx]["ALLOC_TBL_ITEM"]　→　配列内のidx番目の明細の「割当テーブルの明細番号」
[idx]["SRC_STOCK_TYPE"]　→　配列内のidx番目の明細の「在庫転送オーダーの元保管場所在庫タイプ」
[idx]["REASON_REJ"]　→　配列内のidx番目の明細の「見積および受注の拒否理由」
[idx]["CRM_SALES_ORDER_NO"]　→　配列内のidx番目の明細の「仕入先直送発注処理の CRM 受注番号」
[idx]["CRM_SALES_ORDER_ITEM_NO"]　→　配列内のidx番目の明細の「仕入先直送発注処理での CRM 受注明細番号」
[idx]["CRM_REF_SALES_ORDER_NO"]　→　配列内のidx番目の明細の「仕入先直送発注処理の CRM 参照受注番号」
[idx]["CRM_REF_SO_ITEM_NO"]　→　配列内のidx番目の明細の「仕入先直送発注処理での CRM 参照受注明細番号」
[idx]["PRIO_URGENCY"]　→　配列内のidx番目の明細の「所要量の緊急度」
[idx]["PRIO_REQUIREMENT"]　→　配列内のidx番目の明細の「所要量の優先順位」
[idx]["REASON_CODE"]　→　配列内のidx番目の明細の「Goods Receipt Reason Code」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPurchaseScheduleList

Object getPurchaseScheduleList ()

納入日程一覧を取得します｡
返却値
Object 納入日程一覧

納入日程情報オブジェクトの構成は以下のとおりです。
納入日程情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号 (String)
SCHED_LINE 納入日程行 (String)
DEL_DATCAT_EXT 納入期日カテゴリ (String)
DELIVERY_DATE 納入期日 (String)
QUANTITY 計画数量 (String)
DELIV_TIME 納入期日における指定時間 (String)
STAT_DATE 統計的納入期日 (String)
PREQ_NO 購買依頼番号 (String)
PREQ_ITEM 購買依頼の明細番号 (String)
PO_DATE 納入日程の購買発注日付 (String)
ROUTESCHED 輸送経路計画 (String)
MS_DATE 品目利用可能日 (String)
MS_TIME 品目供給ステージ (現地時刻：プラント参照) (String)
LOAD_DATE 積載日付 (String)
LOAD_TIME 積載時刻 (現地時間：出荷ポイント) (String)
TP_DATE 輸送計画日付 (String)
TP_TIME 輸送計画 - 時間 (現地時間/出荷ポイント参照) (String)
GI_DATE 出庫日付 (String)
GI_TIME 出庫時刻 (現地時間 - プラント参照) (String)
DELETE_IND 購買伝票の削除フラグ (String)
REQ_CLOSED 購買依頼処理済 (String)
GR_END_DATE 入庫終了日付 (String)
GR_END_TIME 入庫終了時刻 (ローカル、プラントに関連) (String)
COM_QTY 確認数量 (String)
COM_DATE 確認日 (String)

取得した納入日程情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の納入日程の「購買伝票の明細番号」
[idx]["SCHED_LINE"]　→　配列内のidx番目の納入日程の「納入日程行」
[idx]["DEL_DATCAT_EXT"]　→　配列内のidx番目の納入日程の「納入期日カテゴリ」
[idx]["DELIVERY_DATE"]　→　配列内のidx番目の納入日程の「納入期日」
[idx]["QUANTITY"]　→　配列内のidx番目の納入日程の「計画数量」
[idx]["DELIV_TIME"]　→　配列内のidx番目の納入日程の「納入期日における指定時間」
[idx]["STAT_DATE"]　→　配列内のidx番目の納入日程の「統計的納入期日」
[idx]["PREQ_NO"]　→　配列内のidx番目の納入日程の「購買依頼番号」
[idx]["PREQ_ITEM"]　→　配列内のidx番目の納入日程の「購買依頼の明細番号」
[idx]["PO_DATE"]　→　配列内のidx番目の納入日程の「納入日程の購買発注日付」
[idx]["ROUTESCHED"]　→　配列内のidx番目の納入日程の「輸送経路計画」
[idx]["MS_DATE"]　→　配列内のidx番目の納入日程の「品目利用可能日」
[idx]["MS_TIME"]　→　配列内のidx番目の納入日程の「品目供給ステージ (現地時刻：プラント参照)」
[idx]["LOAD_DATE"]　→　配列内のidx番目の納入日程の「積載日付」
[idx]["LOAD_TIME"]　→　配列内のidx番目の納入日程の「積載時刻 (現地時間：出荷ポイント)」
[idx]["TP_DATE"]　→　配列内のidx番目の納入日程の「輸送計画日付」
[idx]["TP_TIME"] 　→　配列内のidx番目の納入日程の「輸送計画 - 時間 (現地時間/出荷ポイント参照)」
[idx]["GI_DATE"]　→　配列内のidx番目の納入日程の「出庫日付」
[idx]["GI_TIME"]　→　配列内のidx番目の納入日程の「出庫時刻 (現地時間 - プラント参照)」
[idx]["DELETE_IND"]　→　配列内のidx番目の納入日程の「購買伝票の削除フラグ」
[idx]["REQ_CLOSED"]　→　配列内のidx番目の納入日程の「購買依頼処理済」
[idx]["GR_END_DATE"]　→　配列内のidx番目の納入日程の「入庫終了日付」
[idx]["GR_END_TIME"]　→　配列内のidx番目の納入日程の「入庫終了時刻 (ローカル、プラントに関連)」
[idx]["COM_QTY"]　→　配列内のidx番目の納入日程の「確認数量」
[idx]["COM_DATE"]　→　配列内のidx番目の納入日程の「確認日」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPurchaseShippingExpList

Object getPurchaseShippingExpList ()

出荷データエクスポート一覧を取得します｡
返却値
Object 出荷データエクスポート一覧

出荷データエクスポート情報オブジェクトの構成は以下のとおりです。
出荷データエクスポート情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号
SHIP_POINT 出荷ポイント/入荷ポイント
SHIP_COND 出荷条件
DLV_PRIO 出荷優先順位
ROUTE 輸送経路
CUSTOMER 得意先コード 1
SOLD_TO 受注先
FWDAGENT 海貨業者
SALESORG 販売組織
DISTR_CHAN 流通チャネル
DIVISION 製品部門
DEL_CREATE_DATE 出荷登録日付
PLND_DELRY 予定納入時間 (単位: 日)
LANGU 言語キー
LANGU_ISO 言語キーの ISO コード
LOADINGGRP 積載グループ
TRANS_GRP 輸送グループ
UNLOAD_PT 荷渡ポイント
ORDCOMBIND 受注結合区分
TIME_ZONE 出荷場所のタイムゾーン
AUTH_NUMBER 返品権限番号
SRC_DLV_NO 元出荷番号
SRC_HANDLG_UNIT 元/先 荷役単位 (外部 ID)
INSPOUT_GUID 品質検査結果： EWM 設定の在庫 GUID
FOLLOW_UP デフォルト後続アクティビティコード

取得した出荷データエクスポート情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の出荷データの「購買伝票の明細番号」
[idx]["SHIP_POINT"]　→　配列内のidx番目の出荷データの「出荷ポイント/入荷ポイント」
[idx]["SHIP_COND"]　→　配列内のidx番目の出荷データの「出荷条件」
[idx]["DLV_PRIO"]　→　配列内のidx番目の出荷データの「出荷優先順位」
[idx]["ROUTE"]　→　配列内のidx番目の出荷データの「輸送経路」
[idx]["CUSTOMER"]　→　配列内のidx番目の出荷データの「得意先コード 1」
[idx]["SOLD_TO"]　→　配列内のidx番目の出荷データの「受注先」
[idx]["FWDAGENT"]　→　配列内のidx番目の出荷データの「海貨業者」
[idx]["SALESORG"]　→　配列内のidx番目の出荷データの「販売組織」
[idx]["DISTR_CHAN"]　→　配列内のidx番目の出荷データの「流通チャネル」
[idx]["DIVISION"]　→　配列内のidx番目の出荷データの「製品部門」
[idx]["DEL_CREATE_DATE"]　→　配列内のidx番目の出荷データの「出荷登録日付」
[idx]["PLND_DELRY"]　→　配列内のidx番目の出荷データの「予定納入時間 (単位: 日)」
[idx]["LANGU"]　→　配列内のidx番目の出荷データの「言語キー」
[idx]["LANGU_ISO"]　→　配列内のidx番目の出荷データの「言語キーの ISO コード」
[idx]["LOADINGGRP"]　→　配列内のidx番目の出荷データの「積載グループ」
[idx]["TRANS_GRP"]　→　配列内のidx番目の出荷データの「輸送グループ」
[idx]["UNLOAD_PT"]　→　配列内のidx番目の出荷データの「荷渡ポイント」
[idx]["ORDCOMBIND"]　→　配列内のidx番目の出荷データの「受注結合区分」
[idx]["TIME_ZONE"]　→　配列内のidx番目の出荷データの「出荷場所のタイムゾーン」
[idx]["AUTH_NUMBER"]　→　配列内のidx番目の出荷データの「返品権限番号」
[idx]["SRC_DLV_NO"]　→　配列内のidx番目の出荷データの「元出荷番号」
[idx]["SRC_HANDLG_UNIT"] 　→　配列内のidx番目の出荷データの「元/先 荷役単位 (外部 ID)」
[idx]["INSPOUT_GUID"] 　→　配列内のidx番目の出荷データの「品質検査結果： EWM 設定の在庫 GUID」
[idx]["FOLLOW_UP"] 　→　配列内のidx番目の出荷データの「デフォルト後続アクティビティコード」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPurchaseShippingList

Object getPurchaseShippingList ()

出荷データ一覧を取得します｡
返却値
Object 出荷データ一覧

出荷データ情報オブジェクトの構成は以下のとおりです。
出荷データ情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号
SHIP_POINT 出荷ポイント/入荷ポイント
SHIP_COND 出荷条件
DLV_PRIO 出荷優先順位
ROUTE 輸送経路
UNLOAD_PT 荷渡ポイント
AUTH_NUMBER 返品権限番号
SRC_DLV_NO 元出荷番号
SRC_HANDLG_UNIT 元/先 荷役単位 (外部 ID)
INSPOUT_GUID 品質検査結果： EWM 設定の在庫 GUID
FOLLOW_UP デフォルト後続アクティビティコード

取得した出荷データ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の出荷データの「購買伝票の明細番号」
[idx]["SHIP_POINT"]　→　配列内のidx番目の出荷データの「出荷ポイント/入荷ポイント」
[idx]["SHIP_COND"]　→　配列内のidx番目の出荷データの「出荷条件」
[idx]["DLV_PRIO"]　→　配列内のidx番目の出荷データの「出荷優先順位」
[idx]["ROUTE"]　→　配列内のidx番目の出荷データの「輸送経路」
[idx]["UNLOAD_PT"]　→　配列内のidx番目の出荷データの「荷渡ポイント」
[idx]["AUTH_NUMBER"]　→　配列内のidx番目の出荷データの「返品権限番号」
[idx]["SRC_DLV_NO"]　→　配列内のidx番目の出荷データの「元出荷番号」
[idx]["SRC_HANDLG_UNIT"] 　→　配列内のidx番目の出荷データの「元/先 荷役単位 (外部 ID)」
[idx]["INSPOUT_GUID"] 　→　配列内のidx番目の出荷データの「品質検査結果： EWM 設定の在庫 GUID」
[idx]["FOLLOW_UP"]　→　配列内のidx番目の出荷データの「デフォルト後続アクティビティコード」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getSupplierInfo

Object getSupplierInfo ()

仕入先住所を取得します｡
返却値
Object 仕入先住所

仕入先住所情報オブジェクトの構成は以下のとおりです。
仕入先住所情報
オブジェクト
(Object)
PO_NUMBER 購買伝票番号 (String)
ADDR_NO アドレス番号 (String)
FORMOFADDR 敬称テキスト (String)
NAME 名称 1 (String)
NAME_2 名称 2 (String)
NAME_3 名称 3 (String)
NAME_4 名称 4 (String)
C_O_NAME 気付 (String)
CITY 市区町村 (String)
DISTRICT 所在地 (String)
CITY_NO 市区町村/地名ファイルの市区町村コード (String)
POSTL_COD1 市区町村の郵便番号 (String)
POSTL_COD2 私書箱郵便番号 (String)
POSTL_COD3 会社郵便番号 (大規模なユーザ用) (String)
PO_BOX 私書箱 (String)
PO_BOX_CIT 私書箱住所 (String)
DELIV_DIS 郵便配達地域 (String)
STREET 地名 (String)
STREET_NO 市区町村/地名ファイルの地名コード (String)
STR_ABBR 地名の略称 (例：スペイン) (String)
HOUSE_NO 番地-号 (String)
STR_SUPPL1 地名 2 (String)
STR_SUPPL2 地名 3 (String)
LOCATION 地名 5 (String)
BUILDING 旧：建物 (番号または略称) (String)
FLOOR 建物の階 (String)
ROOM_NO 部屋/アパート番号 (String)
COUNTRY 国コード (String)
LANGU 言語キー (String)
REGION 地域 (都道府県) (String)
SORT1 検索条件 1 (String)
SORT2 検索条件 2 (String)
TIME_ZONE アドレスタイムゾーン (String)
TAXJURCODE 税管轄コード (String)
ADR_NOTES 住所注記 (String)
COMM_TYPE 通信方法 (キー) (アドレス管理) (String)
TEL1_NUMBR 第一電話番号：ダイヤルコード + 番号 (String)
TEL1_EXT 第 1 電話番号：内線 (String)
FAX_NUMBER 第一 FAX 番号：ダイヤルコード + 番号 (String)
FAX_EXTENS 第一 FAX 番号：内線 (String)
STREET_LNG 地名 (String)
DISTRCT_NO 市区町村/地名ファイルの所在地コード (String)
CHCKSTATUS 市区町村ファイルテストステータス (String)
PBOXCIT_NO 市区町村私書箱コード (市ファイル) (String)
TRANSPZONE 商品の納入区域 (String)
HOUSE_NO2 番地補足 (String)
E_MAIL 電子メールアドレス (String)
STR_SUPPL3 地名 4 (String)
TITLE タイトル (敬称) (String)
COUNTRYISO ISO 国コード (String)
LANGU_ISO ISO 639 準拠の言語 (String)
BUILD_LONG 建物 (番号またはコード) (String)
REGIOGROUP 地域構造グループ化 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getTestRun

Object getTestRun ()

テスト区分を取得します。

返却値
Object テスト区分
getVersions

Object getVersions ()

バージョン管理を取得します｡
返却値
Object バージョン管理

バージョン管理情報オブジェクトの構成は以下のとおりです。
バージョン管理情報
オブジェクト
(Object)
POST_DATE バージョンの転記日付 (String)
COMPLETED ステータス ""バージョン完了済"" (String)
REASON 変更理由 (String)
DESCRIPTION バージョンテキスト（長） (String)
REQ_BY 変更を依頼した従業員 (String)
REQ_BY_EXT バージョンの外部変更番号 (String)
ACTIVITY 処理タイプ（SAP ERP6.0 では使用されない項目です。）(String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

setMemoryComplete

void setMemoryComplete (String value)

エラーがない場合に購買発注を保留する区分を設定します｡
パラメータ
value String エラーがない場合に購買発注を保留する区分
返却値
void
setMemoryUnComplete

void setMemoryUnComplete (String value)

エラーがある場合に購買発注を保留する区分を設定します｡
パラメータ
value String エラーがある場合に購買発注を保留する区分
返却値
void
setNoAuthority

void setNoAuthority (String value)

権限チェックなし区分を設定します｡
パラメータ
value String 権限チェックなし区分
返却値
void
setNoMessage

void setNoMessage (String value)

出力決定なし区分に購買発注を保留する区分を設定します｡
パラメータ
value String 出力決定なし区分に購買発注を保留する区分
返却値
void
setNoMessageReq

void setNoMessageReq (String value)

メッセージ不要区分を設定します｡
パラメータ
value String メッセージ不要区分
返却値
void
setNoPriceFromPo

void setNoPriceFromPo (String value)

最終伝票からの価格転送なし区分を設定します｡
パラメータ
value String 最終伝票からの価格転送なし区分
返却値
void
setStrParam

void setStrParam (String paramStr ,String paramName ,String value)

構造型の項目に値をセットします。
パラメータ
paramStr | String | 構造名
paramName | String | 項目名
value | String | セットする値
返却値
void
setTblParam

void setTblParam (String paramTable ,String paramName ,String value ,int index)

テーブル型の項目に値をセットします。
パラメータ
paramTable | String | テーブル名
paramName | String | 項目名
value | String | セットする値
index | int | レコード番号
返却値
void
setTestRun

void setTestRun (String value)

テスト区分を設定します｡
パラメータ
value String テスト区分
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 PurchaseOrderPostChangeController オブジェクト

伝票登録変更コントローラクラス。

機能は以下の通り
  • 伝票を更新します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
PurchaseOrderPostChangeController ()
コンストラクタ｡
PurchaseOrderPostChangeController (ConnectionManager connectionManager)
コンストラクタ。
PurchaseOrderPostChangeController (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより購買伝票を登録します。
Object | getAllVersionsList () 全バージョン一覧を取得します｡
String | getBapiReturnErrMessage () ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage () プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。
Object | getCondHeaderList () 条件ヘッダ一覧を取得します｡
Object | getCondItemList () 条件明細一覧を取得します｡
Object | getContractLimitsList () 外注基本契約制限一覧を取得します｡
Object | getContractServiceAccountList () 外注サービス勘定設定一覧を取得します｡
Object | getContractServiceList () 外注サービス一覧を取得します｡
Object | getContractServiceTextList () 外注サービステキスト一覧を取得します｡
Object | getDeliverryAddressList () 出荷伝票アドレス一覧を取得します｡
Object | getDocumentHeader () 伝票ヘッダを取得します。
Object | getExportHeader () 貿易管理ヘッダを取得します｡
Object | getExportItemList () 貿易管理明細一覧を取得します｡
Object | getExtensionList () 拡張得意先項目一覧を取得します｡
Object | getHeaderTextList () ヘッダテキスト一覧を取得します｡
Object | getItemTextList () 明細テキスト一覧を取得します｡
Object | getLimitsList () 外注制限一覧を取得します｡
Object | getMemoryComplete () エラーがない場合に購買発注を保留にする区分を取得します｡
Object | getMemoryUnComplete () エラーがある場合に購買発注を保留にする区分を取得します｡
Object | getNoAuthority () 権限チェックなし区分を取得します｡
Object | getNoMessageReq () メッセージ不要区分を取得します｡
Object | getNoMessaging () 出力決定なし区分を取得します。
Object | getNoPriceFromPo () 最終伝票からの価格転送なし区分を取得します｡。
Object | getPartnerList () 得意先一覧を取得します｡
Object | getPoNumber () 購買伝票番号を取得します｡
Object | getProfitSegmentList () 入出庫予定一覧を取得します｡
Object | getPurchaseAccountList () 勘定設定一覧を取得します｡
Object | getPurchaseComponentsList () コンポーネント一覧を取得します｡
Object | getPurchaseConfirmationList () 転送構造: 照会/一覧 - 仕入先確認一覧を取得します｡
Object | getPurchaseHistoryList () 購買発注履歴一覧を取得します｡
Object | getPurchaseHistoryTotalsList () 購買発注履歴(合計)一覧を取得します｡
Object | getPurchaseItemPostList () 明細一覧を取得します｡
Object | getPurchaseScheduleList () 納入日程一覧を取得します｡
Object | getPurchaseShippingExpList () 出荷データエクスポート一覧を取得します｡
Object | getPurchaseShippingList () 出荷データ一覧を取得します｡
Object | getSupplierInfo () 仕入先住所を取得します｡
Object | getTestRun () テスト区分を取得します。
Object | getVersions () バージョン管理を取得します｡
void | setMemoryComplete (String value) エラーがない場合に購買発注を保留する区分を設定します｡を設定します｡
void | setMemoryUnComplete (String value) エラーがある場合に購買発注を保留する区分を設定します｡を設定します｡
void | setNoAuthority (String value) 権限チェックなし区分を設定します｡を設定します｡
void | setNoMessage (String value) 出力決定なし区分に購買発注を保留する区分を設定します｡を設定します｡
void | setNoMessageReq (String value) メッセージ不要区分を設定します｡を設定します｡
void | setNoPriceFromPo (String value) 最終伝票からの価格転送なし区分を設定します｡を設定します｡
void | setPoNumber (String value) 購買伝票番号を設定します｡
void | setStrParam (String paramStr ,String paramName ,String value) 構造型の項目に値をセットします。
void | setTblParam (String paramTable ,String paramName ,String value ,int index) テーブル型の項目に値をセットします。
void | setTestRun (String value) テスト区分を設定します｡
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
PurchaseOrderPostChangeController

PurchaseOrderPostChangeController ()
コンストラクタ｡
PurchaseOrderPostChangeController

PurchaseOrderPostChangeController (ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の更新処理を実行することができます。
なお、PurchaseOrderPostChangeController#executeBapi()実行後に 必ずConnectionManager#commit()またはConnectionManager#rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。
パラメータ
connectionManager ConnectionManager コネクションマネージャー
PurchaseOrderPostChangeController

PurchaseOrderPostChangeController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより購買伝票を登録します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getAllVersionsList

Object getAllVersionsList ()

全バージョン一覧を取得します｡
返却値
Object 全バージョン一覧

全バージョン情報オブジェクトの構成は以下のとおりです。
全バージョン情報
オブジェクト
(Object)
DOC_TYPE 購買伝票カテゴリ (String)
DOC_NUMBER 購買管理におけるオブジェクト番号 (String)
ITEM_NUMBER 購買管理オブジェクト：明細 (String)
VERSION 購買管理におけるバージョン番号 (String)
CREATED_BY オブジェクト登録者名 (String)
CR_ON レコード登録日 (String)
REC_TIME 登録時刻 (String)
RELEASED_BY 承認者名 (String)
RELEASE_DATE 承認日 (String)
RELEASE_TIME 承認時刻 (String)
RELEASEBY_PUR 承認購買担当者名 (String)
RELEASEDATE_PUR 購買担当者承認日付 (String)
RELEASETIME_PUR 購買担当者承認時刻 (String)
REASON 変更理由 (String)
DESCRIPTION バージョンテキスト（長） (String)
REQ_BY_EXT バージョンの外部変更番号 (String)
REQ_BY 変更を依頼した従業員 (String)
NET_VALUE 購買発注通貨による正味発注額 (String)
VALUE_CHANGED バージョンによる金額変更 (String)
CURRENCY 通貨コード (String)
CURRENCY_ISO ISO コード通貨 (String)
POST_DATE バージョンの転記日付 (String)
COMPLETED ステータス ""バージョン完了済"" (String)
STATUS バージョンステータス (String)
DELETE_IND 購買伝票の削除フラグ (String)
STATUS_DOC_OLD このバージョンの前の旧処理状況 (購買伝票内) (String)

取得した全バージョン情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["DOC_TYPE"]　→　配列内のidx番目の全バージョンの「購買伝票カテゴリ」
[idx]["DOC_NUMBER"]　→　配列内のidx番目の全バージョンの「購買管理におけるオブジェクト番号」
[idx]["ITEM_NUMBER"]　→　配列内のidx番目の全バージョンの「購買管理オブジェクト：明細」
[idx]["VERSION"]　→　配列内のidx番目の全バージョンの「購買管理におけるバージョン番号」
[idx]["CREATED_BY"]　→　配列内のidx番目の全バージョンの「オブジェクト登録者名」
[idx]["CR_ON"]　→　配列内のidx番目の全バージョンの「レコード登録日」
[idx]["REC_TIME"]　→　配列内のidx番目の全バージョンの「登録時刻」
[idx]["RELEASED_BY"]　→　配列内のidx番目の全バージョンの「承認者名」
[idx]["RELEASE_DATE"]　→　配列内のidx番目の全バージョンの「承認日」
[idx]["RELEASE_TIME"]　→　配列内のidx番目の全バージョンの「承認時刻」
[idx]["RELEASEBY_PUR"]　→　配列内のidx番目の全バージョンの「承認購買担当者名」
[idx]["RELEASEDATE_PUR"]　→　配列内のidx番目の全バージョンの「購買担当者承認日付」
[idx]["RELEASETIME_PUR"]　→　配列内のidx番目の全バージョンの「購買担当者承認時刻」
[idx]["REASON"]　→　配列内のidx番目の全バージョンの「変更理由」
[idx]["DESCRIPTION"]　→　配列内のidx番目の全バージョンの「バージョンテキスト（長）」
[idx]["REQ_BY_EXT"]　→　配列内のidx番目の全バージョンの「バージョンの外部変更番号」
[idx]["REQ_BY"]　→　配列内のidx番目の全バージョンの「変更を依頼した従業員」
[idx]["NET_VALUE"]　→　配列内のidx番目の全バージョンの「購買発注通貨による正味発注額」
[idx]["VALUE_CHANGED"]　→　配列内のidx番目の全バージョンの「バージョンによる金額変更」
[idx]["CURRENCY"]　→　配列内のidx番目の全バージョンの「通貨コード」
[idx]["CURRENCY_ISO"]　→　配列内のidx番目の全バージョンの「ISO コード通貨」
[idx]["POST_DATE"]　→　配列内のidx番目の全バージョンの「バージョンの転記日付」
[idx]["COMPLETED"]　→　配列内のidx番目の全バージョンの「ステータス "バージョン完了済"」
[idx]["STATUS"]　→　配列内のidx番目の全バージョンの「バージョンステータス」
[idx]["DELETE_IND"]　→　配列内のidx番目の全バージョンの「購買伝票の削除フラグ」
[idx]["STATUS_DOC_OLD"] 　→　配列内のidx番目の全バージョンの「このバージョンの前の旧処理状況 (購買伝票内)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getBapiReturnErrMessage

String getBapiReturnErrMessage ()

ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡
返却値
String BAPI実行結果エラーとなった全てのメッセージ情報
getBapiReturnMessage

String getBapiReturnMessage ()

プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡
返却値
String プロパティファイルでオートコミット条件に一致したType情報のメッセージ情報
getCondHeaderList

Object getCondHeaderList ()

条件ヘッダ一覧を取得します｡
返却値
Object 条件ヘッダ一覧

条件ヘッダ情報オブジェクトの構成は以下のとおりです。
条件ヘッダ情報
オブジェクト
(Object)
CONDITION_NO 伝票条件番号 (String)
ITM_NUMBER 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件カウンタ (String)
COND_TYPE 条件タイプ (String)
COND_VALUE 条件レート (String)
CURRENCY 通貨コード (String)
CURRENCY_ISO ISO コード通貨 (String)
COND_UNIT 条件単位 (String)
COND_UNIT_ISO 条件数量単位 (ISO コード) (String)
COND_P_UNT 価格条件単位 (String)
APPLICATIO アプリケーション (String)
CONPRICDAT 条件価格設定日付 (String)
CALCTYPCON 条件計算タイプ (String)
CONBASEVAL 条件基礎値 (String)
CONEXCHRAT 現地通貨への換算レートに対する条件 (String)
NUMCONVERT 条件単位を基本単位へ変換する分子 (String)
DENOMINATO 条件単位を基本単位へ変換する分母 (String)
CONDTYPE 条件カテゴリ (例：税、運賃、価格、原価) (String)
STAT_CON 統計に適用する条件 (String)
SCALETYPE スケールタイプ (String)
ACCRUALS 見越額関連条件 (運賃など) (String)
CONINVOLST 請求書一覧条件 (String)
CONDORIGIN 条件生成区分 (String)
GROUPCOND グループ条件区分 (String)
COND_UPDAT 条件更新 (String)
ACCESS_SEQ 検索順序 - 検索番号 (String)
CONDCOUNT 条件連続番号 (String)
CONDCNTRL 条件管理 (String)
CONDISACTI 無効条件 (String)
CONDCLASS 条件クラス (String)
FACTBASVAL 条件基礎値に対する要因 (String)
SCALEBASIN スケール基準区分 (String)
SCALBASVAL 条件のスケール基準値 (String)
UNITMEASUR 条件スケール単位 (String)
UNITMEASUR_ISO 単位の ISO コード (String)
CURRENCKEY スケール通貨 (String)
CURRENCKEY_ISO ISO コード通貨 (String)
CONDINCOMP 会社間請求の条件 (String)
CONDCONFIG システム設定の条件 (String)
CONDCHAMAN 条件 (マニュアル変更済) (String)
COND_NO 条件レコード番号 (String)
CHANGE_ID 変更タイプ(U、I、E、D) (String)
VENDOR_NO 仕入先または債権者の勘定コード (String)

取得した条件ヘッダ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONDITION_NO"]　→　配列内のidx番目の条件ヘッダの「伝票条件番号」
[idx]["ITM_NUMBER"]　→　配列内のidx番目の条件ヘッダの「条件明細番号」
[idx]["COND_ST_NO"]　→　配列内のidx番目の条件ヘッダの「ステップ番号」
[idx]["COND_COUNT"]　→　配列内のidx番目の条件ヘッダの「条件カウンタ」
[idx]["COND_TYPE"]　→　配列内のidx番目の条件ヘッダの「条件タイプ」
[idx]["COND_VALUE"]　→　配列内のidx番目の条件ヘッダの「条件レート」
[idx]["CURRENCY"]　→　配列内のidx番目の条件ヘッダの「通貨コード」
[idx]["CURRENCY_ISO"]　→　配列内のidx番目の条件ヘッダの「ISO コード通貨」
[idx]["COND_UNIT"]　→　配列内のidx番目の条件ヘッダの「条件単位」
[idx]["COND_UNIT_ISO"] 　→　配列内のidx番目の条件ヘッダの「条件数量単位 (ISO コード)」
[idx]["COND_P_UNT"]　→　配列内のidx番目の条件ヘッダの「価格条件単位」
[idx]["APPLICATIO"]　→　配列内のidx番目の条件ヘッダの「アプリケーション」
[idx]["CONPRICDAT"]　→　配列内のidx番目の条件ヘッダの「条件価格設定日付」
[idx]["CALCTYPCON"]　→　配列内のidx番目の条件ヘッダの「条件計算タイプ」
[idx]["CONBASEVAL"]　→　配列内のidx番目の条件ヘッダの「条件基礎値」
[idx]["CONEXCHRAT"]　→　配列内のidx番目の条件ヘッダの「現地通貨への換算レートに対する条件」
[idx]["NUMCONVERT"]　→　配列内のidx番目の条件ヘッダの「条件単位を基本単位へ変換する分子」
[idx]["DENOMINATO"]　→　配列内のidx番目の条件ヘッダの「条件単位を基本単位へ変換する分母」
[idx]["CONDTYPE"] 　→　配列内のidx番目の条件ヘッダの「条件カテゴリ (例：税、運賃、価格、原価)」
[idx]["STAT_CON"]　→　配列内のidx番目の条件ヘッダの「統計に適用する条件」
[idx]["SCALETYPE"]　→　配列内のidx番目の条件ヘッダの「スケールタイプ」
[idx]["ACCRUALS"]　→　配列内のidx番目の条件ヘッダの「見越額関連条件 (運賃など)」
[idx]["CONINVOLST"]　→　配列内のidx番目の条件ヘッダの「請求書一覧条件」
[idx]["CONDORIGIN"]　→　配列内のidx番目の条件ヘッダの「条件生成区分」
[idx]["GROUPCOND"]　→　配列内のidx番目の条件ヘッダの「グループ条件区分」
[idx]["COND_UPDAT"]　→　配列内のidx番目の条件ヘッダの「条件更新」
[idx]["ACCESS_SEQ"]　→　配列内のidx番目の条件ヘッダの「検索順序 - 検索番号」
[idx]["CONDCOUNT"]　→　配列内のidx番目の条件ヘッダの「条件連続番号」
[idx]["CONDCNTRL"]　→　配列内のidx番目の条件ヘッダの「条件管理」
[idx]["CONDISACTI"]　→　配列内のidx番目の条件ヘッダの「無効条件」
[idx]["CONDCLASS"]　→　配列内のidx番目の条件ヘッダの「条件クラス」
[idx]["FACTBASVAL"]　→　配列内のidx番目の条件ヘッダの「条件基礎値に対する要因」
[idx]["SCALEBASIN"]　→　配列内のidx番目の条件ヘッダの「スケール基準区分」
[idx]["SCALBASVAL"]　→　配列内のidx番目の条件ヘッダの「条件のスケール基準値」
[idx]["UNITMEASUR"]　→　配列内のidx番目の条件ヘッダの「条件スケール単位」
[idx]["UNITMEASUR_ISO"]　→　配列内のidx番目の条件ヘッダの「単位の ISO コード」
[idx]["CURRENCKEY"]　→　配列内のidx番目の条件ヘッダの「スケール通貨」
[idx]["CURRENCKEY_ISO"]　→　配列内のidx番目の条件ヘッダの「ISO コード通貨」
[idx]["CONDINCOMP"]　→　配列内のidx番目の条件ヘッダの「会社間請求の条件」
[idx]["CONDCONFIG"]　→　配列内のidx番目の条件ヘッダの「システム設定の条件」
[idx]["CONDCHAMAN"]　→　配列内のidx番目の条件ヘッダの「条件 (マニュアル変更済)」
[idx]["COND_NO"]　→　配列内のidx番目の条件ヘッダの「条件レコード番号」
[idx]["CHANGE_ID"]　→　配列内のidx番目の条件ヘッダの「変更タイプ(U、I、E、D)」
[idx]["VENDOR_NO"]　→　配列内のidx番目の条件ヘッダの「仕入先または債権者の勘定コード」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getCondItemList

Object getCondItemList ()

条件明細一覧を取得します｡
返却値
Object 条件明細一覧

条件明細情報オブジェクトの構成は以下のとおりです。
条件明細情報
オブジェクト
(Object)
CONDITION_NO 伝票条件番号 (String)
ITM_NUMBER 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件カウンタ (String)
COND_TYPE 条件タイプ (String)
COND_VALUE 条件レート (String)
CURRENCY 通貨コード (String)
CURRENCY_ISO ISO コード通貨 (String)
COND_UNIT 条件単位 (String)
COND_UNIT_ISO 条件数量単位 (ISO コード) (String)
COND_P_UNT 価格条件単位 (String)
APPLICATIO アプリケーション (String)
CONPRICDAT 条件価格設定日付 (String)
CALCTYPCON 条件計算タイプ (String)
CONBASEVAL 条件基礎値 (String)
CONEXCHRAT 現地通貨への換算レートに対する条件 (String)
NUMCONVERT 条件単位を基本単位へ変換する分子 (String)
DENOMINATO 条件単位を基本単位へ変換する分母 (String)
CONDTYPE 条件カテゴリ (例：税、運賃、価格、原価) (String)
STAT_CON 統計に適用する条件 (String)
SCALETYPE スケールタイプ (String)
ACCRUALS 見越額関連条件 (運賃など) (String)
CONINVOLST 請求書一覧条件 (String)
CONDORIGIN 条件生成区分 (String)
GROUPCOND グループ条件区分 (String)
COND_UPDAT 条件更新 (String)
ACCESS_SEQ 検索順序 - 検索番号 (String)
CONDCOUNT 条件連続番号 (String)
CONDCNTRL 条件管理 (String)
CONDISACTI 無効条件 (String)
CONDCLASS 条件クラス (String)
FACTBASVAL 条件基礎値に対する要因 (String)
SCALEBASIN スケール基準区分 (String)
SCALBASVAL 条件のスケール基準値 (String)
UNITMEASUR 条件スケール単位 (String)
UNITMEASUR_ISO 単位の ISO コード (String)
CURRENCKEY スケール通貨 (String)
CURRENCKEY_ISO ISO コード通貨 (String)
CONDINCOMP 会社間請求の条件 (String)
CONDCONFIG システム設定の条件 (String)
CONDCHAMAN 条件 (マニュアル変更済) (String)
COND_NO 条件レコード番号 (String)
CHANGE_ID 変更タイプ(U、I、E、D) (String)
VENDOR_NO 仕入先または債権者の勘定コード (String)

取得した条件明細情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONDITION_NO"]　→　配列内のidx番目の条件明細の「伝票条件番号」
[idx]["ITM_NUMBER"]　→　配列内のidx番目の条件明細の「条件明細番号」
[idx]["COND_ST_NO"]　→　配列内のidx番目の条件明細の「ステップ番号」
[idx]["COND_COUNT"]　→　配列内のidx番目の条件明細の「条件カウンタ」
[idx]["COND_TYPE"]　→　配列内のidx番目の条件明細の「条件タイプ」
[idx]["COND_VALUE"]　→　配列内のidx番目の条件明細の「条件レート」
[idx]["CURRENCY"]　→　配列内のidx番目の条件明細の「通貨コード」
[idx]["CURRENCY_ISO"]　→　配列内のidx番目の条件明細の「ISO コード通貨」
[idx]["COND_UNIT"]　→　配列内のidx番目の条件明細の「条件単位」
[idx]["COND_UNIT_ISO"]　→　配列内のidx番目の条件明細の「条件数量単位 (ISO コード)」
[idx]["COND_P_UNT"]　→　配列内のidx番目の条件明細の「価格条件単位」
[idx]["APPLICATIO"]　→　配列内のidx番目の条件明細の「アプリケーション」
[idx]["CONPRICDAT"]　→　配列内のidx番目の条件明細の「条件価格設定日付」
[idx]["CALCTYPCON"]　→　配列内のidx番目の条件明細の「条件計算タイプ」
[idx]["CONBASEVAL"]　→　配列内のidx番目の条件明細の「条件基礎値」
[idx]["CONEXCHRAT"]　→　配列内のidx番目の条件明細の「現地通貨への換算レートに対する条件」
[idx]["NUMCONVERT"]　→　配列内のidx番目の条件明細の「条件単位を基本単位へ変換する分子」
[idx]["DENOMINATO"]　→　配列内のidx番目の条件明細の「条件単位を基本単位へ変換する分母」
[idx]["CONDTYPE"]　→　配列内のidx番目の条件明細の「条件カテゴリ (例：税、運賃、価格、原価)」
[idx]["STAT_CON"]　→　配列内のidx番目の条件明細の「統計に適用する条件」
[idx]["SCALETYPE"]　→　配列内のidx番目の条件明細の「スケールタイプ」
[idx]["ACCRUALS"]　→　配列内のidx番目の条件明細の「見越額関連条件 (運賃など)」
[idx]["CONINVOLST"]　→　配列内のidx番目の条件明細の「請求書一覧条件」
[idx]["CONDORIGIN"]　→　配列内のidx番目の条件明細の「条件生成区分」
[idx]["GROUPCOND"]　→　配列内のidx番目の条件明細の「グループ条件区分」
[idx]["COND_UPDAT"]　→　配列内のidx番目の条件明細の「条件更新」
[idx]["ACCESS_SEQ"]　→　配列内のidx番目の条件明細の「検索順序 - 検索番号」
[idx]["CONDCOUNT"]　→　配列内のidx番目の条件明細の「条件連続番号」
[idx]["CONDCNTRL"]　→　配列内のidx番目の条件明細の「条件管理」
[idx]["CONDISACTI"]　→　配列内のidx番目の条件明細の「無効条件」
[idx]["CONDCLASS"]　→　配列内のidx番目の条件明細の「条件クラス」
[idx]["FACTBASVAL"]　→　配列内のidx番目の条件明細の「条件基礎値に対する要因」
[idx]["SCALEBASIN"]　→　配列内のidx番目の条件明細の「スケール基準区分」
[idx]["SCALBASVAL"]　→　配列内のidx番目の条件明細の「条件のスケール基準値」
[idx]["UNITMEASUR"]　→　配列内のidx番目の条件明細の「条件スケール単位」
[idx]["UNITMEASUR_ISO"]　→　配列内のidx番目の条件明細の「単位の ISO コード」
[idx]["CURRENCKEY"]　→　配列内のidx番目の条件明細の「スケール通貨」
[idx]["CURRENCKEY_ISO"]　→　配列内のidx番目の条件明細の「ISO コード通貨」
[idx]["CONDINCOMP"]　→　配列内のidx番目の条件明細の「会社間請求の条件」
[idx]["CONDCONFIG"]　→　配列内のidx番目の条件明細の「システム設定の条件」
[idx]["CONDCHAMAN"]　→　配列内のidx番目の条件明細の「条件 (マニュアル変更済)」
[idx]["COND_NO"]　→　配列内のidx番目の条件明細の「条件レコード番号」
[idx]["CHANGE_ID"]　→　配列内のidx番目の条件明細の「変更タイプ(U、I、E、D)」
[idx]["VENDOR_NO"]　→　配列内のidx番目の条件明細の「仕入先または債権者の勘定コード」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getContractLimitsList

Object getContractLimitsList ()

外注基本契約制限一覧を取得します｡
返却値
Object 外注基本契約制限一覧

外注基本契約制限情報オブジェクトの構成は以下のとおりです。
外注基本契約制限情報
オブジェクト
(Object)
PCKG_NO パッケージ番号 (String)
LINE_NO 制限の内部明細番号 (String)
CON_NUMBER 基本契約番号 (String)
CON_ITEM 明細番号、契約 (String)
LIMIT 全体制限 (String)
NO_LIMIT 制限なし (String)
PRICE_CHG 入力シートの価格変更 (String)
SHORT_TEXT テキスト 1 (短) (String)
DELETE_IND 削除フラグ (String)

取得した外注基本契約制限情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PCKG_NO"]　→　配列内のidx番目の外注基本契約制限の「パッケージ番号」
[idx]["LINE_NO"]　→　配列内のidx番目の外注基本契約制限の「制限の内部明細番号」
[idx]["CON_NUMBER"]　→　配列内のidx番目の外注基本契約制限の「基本契約番号」
[idx]["CON_ITEM"]　→　配列内のidx番目の外注基本契約制限の「明細番号、契約」
[idx]["LIMIT"]　→　配列内のidx番目の外注基本契約制限の「全体制限」
[idx]["NO_LIMIT"]　→　配列内のidx番目の外注基本契約制限の「制限なし」
[idx]["PRICE_CHG"]　→　配列内のidx番目の外注基本契約制限の「入力シートの価格変更」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の外注基本契約制限の「テキスト 1 (短)」
[idx]["DELETE_IND"]　→　配列内のidx番目の外注基本契約制限の「削除フラグ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getContractServiceAccountList

Object getContractServiceAccountList ()

外注サービス勘定設定一覧を取得します｡
返却値
Object 外注サービス勘定設定一覧

外注サービス勘定設定情報オブジェクトの構成は以下のとおりです。
外注サービス勘定設定情報
オブジェクト
(Object)
PCKG_NO パッケージ番号 (String)
LINE_NO 明細行番号 (String)
SERNO_LINE 勘定コード設定のシリアル番号、サービス明細 (String)
PERCENTAGE 勘定設定金額配賦のパーセント (String)
SERIAL_NO 勘定設定の連続番号 (String)
QUANTITY +/- 記号あり/なし数量 (String)
NET_VALUE 明細の正味額 (String)

取得した外注サービス勘定設定情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PCKG_NO"]　→　配列内のidx番目の外注サービス勘定設定の「パッケージ番号」
[idx]["LINE_NO"]　→　配列内のidx番目の外注サービス勘定設定の「明細行番号」
[idx]["SERNO_LINE"] 　→　配列内のidx番目の外注サービス勘定設定の「勘定コード設定のシリアル番号、サービス明細」
[idx]["PERCENTAGE"] 　→　配列内のidx番目の外注サービス勘定設定の「勘定設定金額配賦のパーセント」
[idx]["SERIAL_NO"]　→　配列内のidx番目の外注サービス勘定設定の「勘定設定の連続番号」
[idx]["QUANTITY"]　→　配列内のidx番目の外注サービス勘定設定の「+/- 記号あり/なし数量」
[idx]["NET_VALUE"]　→　配列内のidx番目の外注サービス勘定設定の「明細の正味額」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getContractServiceList

Object getContractServiceList ()

外注サービス一覧を取得します｡
返却値
Object 外注サービス一覧

外注サービス情報オブジェクトの構成は以下のとおりです。
外注サービス情報
オブジェクト
(Object)
PCKG_NO パッケージ番号 (String)
LINE_NO 内部明細番号 (String)
EXT_LINE 明細番号 (String)
OUTL_LEVEL グループの階層レベル (String)
OUTL_NO アウトラインレベル (String)
OUTL_IND 区分：出力行 (String)
SUBPCKG_NO サブパッケージ番号 (String)
SERVICE 活動番号 (String)
SERV_TYPE サービスタイプのテキスト (短) (String)
EDITION サービスタイプのバージョン (String)
SSC_ITEM 標準サービスカタログ：明細 (String)
EXT_SERV 仕入先のサービス番号 (String)
QUANTITY +/- 記号あり/なし数量 (String)
BASE_UOM 基本数量単位 (String)
UOM_ISO 単位の ISO コード (String)
OVF_TOL 超過許容値 (String)
OVF_UNLIM 契約外サービス制限なし (String)
PRICE_UNIT 価格単位 (String)
GR_PRICE 基準額 (String)
FROM_LINE 下限 (String)
TO_LINE 上限 (String)
SHORT_TEXT テキスト(短) (String)
DISTRIB 複数勘定設定の配賦区分 (String)
PERS_NO 従業員番号 (String)
WAGETYPE ウェイジタイプ (String)
PLN_PCKG パッケージ番号供給元一覧 (String)
PLN_LINE 入力：計画梱包明細行 (String)
CON_PCKG 入力：基本契約の計画外 (String)
CON_LINE 入力：基本契約の計画外 (String)
TMP_PCKG 入力：モデル仕様からの計画外サービス (String)
TMP_LINE 入力：モデル仕様からの計画外サービス (String)
SSC_LIM 標準サービスカタログ制限参照のサービス行 (String)
LIMIT_LINE 入力：計画外、明細制限 (String)
TARGET_VAL 目標値 (String)
BASLINE_NO 代替：基本明細参照 (String)
BASIC_LINE 基本明細 (String)
ALTERNAT 代替明細 (String)
BIDDER 入札者の明細 (String)
SUPP_LINE 補足明細 (String)
OPEN_QTY 未処理数量のある明細 (String)
INFORM 情報行 (String)
BLANKET 包括明細 (String)
EVENTUAL 偶発的明細 (String)
TAX_CODE 消費税コード (String)
TAXJURCODE 税計算管轄コード - 税管轄コード (String)
PRICE_CHG 入力シートの価格変更 (String)
MATL_GROUP 品目グループ (String)
DATE 日付 (String)
BEGINTIME 開始時刻 (String)
ENDTIME 終了時刻 (String)
EXTPERS_NO 外部従業員番号 (String)
FORMULA 計算式番号 (String)
FORM_VAL1 計算式値 (String)
FORM_VAL2 計算式値 (String)
FORM_VAL3 計算式値 (String)
FORM_VAL4 計算式値 (String)
FORM_VAL5 計算式値 (String)
USERF1_NUM ユーザ定義項目 (String)
USERF2_NUM ユーザ定義項目 (String)
USERF1_TXT ユーザ定義項目 (String)
USERF2_TXT ユーザ定義項目 (String)
HI_LINE_NO 上位階層明細番号 (String)
EXTREFKEY サービスの外部参照キー (String)
DELETE_IND 削除フラグ (String)

取得した外注サービス情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PCKG_NO"]　→　配列内のidx番目の外注サービスの「パッケージ番号」
[idx]["LINE_NO"]　→　配列内のidx番目の外注サービスの「内部明細番号」
[idx]["EXT_LINE"]　→　配列内のidx番目の外注サービスの「明細番号」
[idx]["OUTL_LEVEL"]　→　配列内のidx番目の外注サービスの「グループの階層レベル」
[idx]["OUTL_NO"]　→　配列内のidx番目の外注サービスの「アウトラインレベル」
[idx]["OUTL_IND"]　→　配列内のidx番目の外注サービスの「区分：出力行」
[idx]["SUBPCKG_NO"]　→　配列内のidx番目の外注サービスの「サブパッケージ番号」
[idx]["SERVICE"]　→　配列内のidx番目の外注サービスの「活動番号」
[idx]["SERV_TYPE"]　→　配列内のidx番目の外注サービスの「サービスタイプのテキスト (短)」
[idx]["EDITION"]　→　配列内のidx番目の外注サービスの「サービスタイプのバージョン」
[idx]["SSC_ITEM"]　→　配列内のidx番目の外注サービスの「標準サービスカタログ：明細」
[idx]["EXT_SERV"]　→　配列内のidx番目の外注サービスの「仕入先のサービス番号」
[idx]["QUANTITY"]　→　配列内のidx番目の外注サービスの「+/- 記号あり/なし数量」
[idx]["BASE_UOM"]　→　配列内のidx番目の外注サービスの「基本数量単位」
[idx]["UOM_ISO"]　→　配列内のidx番目の外注サービスの「単位の ISO コード」
[idx]["OVF_TOL"]　→　配列内のidx番目の外注サービスの「超過許容値」
[idx]["OVF_UNLIM"]　→　配列内のidx番目の外注サービスの「契約外サービス制限なし」
[idx]["PRICE_UNIT"]　→　配列内のidx番目の外注サービスの「価格単位」
[idx]["GR_PRICE"]　→　配列内のidx番目の外注サービスの「基準額」
[idx]["FROM_LINE"]　→　配列内のidx番目の外注サービスの「下限」
[idx]["TO_LINE"]　→　配列内のidx番目の外注サービスの「上限」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の外注サービスの「テキスト(短)」
[idx]["DISTRIB"]　→　配列内のidx番目の外注サービスの「複数勘定設定の配賦区分」
[idx]["PERS_NO"]　→　配列内のidx番目の外注サービスの「従業員番号」
[idx]["WAGETYPE"]　→　配列内のidx番目の外注サービスの「ウェイジタイプ」
[idx]["PLN_PCKG"]　→　配列内のidx番目の外注サービスの「パッケージ番号供給元一覧」
[idx]["PLN_LINE"]　→　配列内のidx番目の外注サービスの「入力：計画梱包明細行」
[idx]["CON_PCKG"]　→　配列内のidx番目の外注サービスの「入力：基本契約の計画外」
[idx]["CON_LINE"]　→　配列内のidx番目の外注サービスの「入力：基本契約の計画外」
[idx]["TMP_PCKG"]　→　配列内のidx番目の外注サービスの「入力：モデル仕様からの計画外サービス」
[idx]["TMP_LINE"]　→　配列内のidx番目の外注サービスの「入力：モデル仕様からの計画外サービス」
[idx]["SSC_LIM"]　→　配列内のidx番目の外注サービスの「標準サービスカタログ制限参照のサービス行」
[idx]["LIMIT_LINE"]　→　配列内のidx番目の外注サービスの「入力：計画外、明細制限」
[idx]["TARGET_VAL"]　→　配列内のidx番目の外注サービスの「目標値」
[idx]["BASLINE_NO"]　→　配列内のidx番目の外注サービスの「代替：基本明細参照」
[idx]["BASIC_LINE"]　→　配列内のidx番目の外注サービスの「基本明細」
[idx]["ALTERNAT"]　→　配列内のidx番目の外注サービスの「代替明細」
[idx]["BIDDER"]　→　配列内のidx番目の外注サービスの「入札者の明細」
[idx]["SUPP_LINE"]　→　配列内のidx番目の外注サービスの「補足明細」
[idx]["OPEN_QTY"]　→　配列内のidx番目の外注サービスの「未処理数量のある明細」
[idx]["INFORM"]　→　配列内のidx番目の外注サービスの「情報行」
[idx]["BLANKET"]　→　配列内のidx番目の外注サービスの「包括明細」
[idx]["EVENTUAL"]　→　配列内のidx番目の外注サービスの「偶発的明細」
[idx]["TAX_CODE"]　→　配列内のidx番目の外注サービスの「消費税コード」
[idx]["TAXJURCODE"]　→　配列内のidx番目の外注サービスの「税計算管轄コード - 税管轄コード」
[idx]["PRICE_CHG"]　→　配列内のidx番目の外注サービスの「入力シートの価格変更」
[idx]["MATL_GROUP"]　→　配列内のidx番目の外注サービスの「品目グループ」
[idx]["DATE"]　→　配列内のidx番目の外注サービスの「日付」
[idx]["BEGINTIME"]　→　配列内のidx番目の外注サービスの「開始時刻」
[idx]["ENDTIME"]　→　配列内のidx番目の外注サービスの「終了時刻」
[idx]["EXTPERS_NO"]　→　配列内のidx番目の外注サービスの「外部従業員番号」
[idx]["FORMULA"]　→　配列内のidx番目の外注サービスの「計算式番号」
[idx]["FORM_VAL1"]　→　配列内のidx番目の外注サービスの「計算式値」
[idx]["FORM_VAL2"]　→　配列内のidx番目の外注サービスの「計算式値」
[idx]["FORM_VAL3"]　→　配列内のidx番目の外注サービスの「計算式値」
[idx]["FORM_VAL4"]　→　配列内のidx番目の外注サービスの「計算式値」
[idx]["FORM_VAL5"]　→　配列内のidx番目の外注サービスの「計算式値」
[idx]["USERF1_NUM"]　→　配列内のidx番目の外注サービスの「ユーザ定義項目」
[idx]["USERF2_NUM"]　→　配列内のidx番目の外注サービスの「ユーザ定義項目」
[idx]["USERF1_TXT"]　→　配列内のidx番目の外注サービスの「ユーザ定義項目」
[idx]["USERF2_TXT"]　→　配列内のidx番目の外注サービスの「ユーザ定義項目」
[idx]["HI_LINE_NO"]　→　配列内のidx番目の外注サービスの「上位階層明細番号」
[idx]["EXTREFKEY"]　→　配列内のidx番目の外注サービスの「サービスの外部参照キー」
[idx]["DELETE_IND"]　→　配列内のidx番目の外注サービスの「削除フラグ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getContractServiceTextList

Object getContractServiceTextList ()

外注サービステキスト一覧を取得します｡
返却値
Object 外注サービステキスト一覧

外注サービステキスト情報オブジェクトの構成は以下のとおりです。
外注サービステキスト情報
オブジェクト
(Object)
PCKG_NO パッケージ番号 (String)
LINE_NO 内部明細番号 (String)
TEXT_ID テキスト ID (String)
FORMAT_COL タグ列 (String)
TEXT_LINE テキスト行 (String)

取得した外注サービステキスト情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PCKG_NO"]　→　配列内のidx番目の外注サービステキストの「パッケージ番号」
[idx]["LINE_NO"]　→　配列内のidx番目の外注サービステキストの「内部明細番号」
[idx]["TEXT_ID"]　→　配列内のidx番目の外注サービステキストの「テキスト ID」
[idx]["FORMAT_COL"]　→　配列内のidx番目の外注サービステキストの「タグ列」
[idx]["TEXT_LINE"]　→　配列内のidx番目の外注サービステキストの「テキスト行」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getDeliverryAddressList

Object getDeliverryAddressList ()

出荷伝票アドレス一覧を取得します｡
返却値
Object 出荷伝票アドレス一覧

出荷伝票アドレス情報オブジェクトの構成は以下のとおりです。
出荷伝票アドレス情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号 (String)
ADDR_NO アドレス番号 (String)
FORMOFADDR 敬称テキスト (String)
NAME 名称 1 (String)
NAME_2 名称 2 (String)
NAME_3 名称 3 (String)
NAME_4 名称 4 (String)
C_O_NAME 気付 (String)
CITY 市区町村 (String)
DISTRICT 所在地 (String)
CITY_NO 市区町村/地名ファイルの市区町村コード (String)
POSTL_COD1 市区町村の郵便番号 (String)
POSTL_COD2 私書箱郵便番号 (String)
POSTL_COD3 会社郵便番号 (大規模なユーザ用) (String)
PO_BOX 私書箱 (String)
PO_BOX_CIT 私書箱住所 (String)
DELIV_DIS 郵便配達地域 (String)
STREET 地名 (String)
STREET_NO 市区町村/地名ファイルの地名コード (String)
STR_ABBR 地名の略称 (例：スペイン) (String)
HOUSE_NO 番地-号 (String)
STR_SUPPL1 地名 2 (String)
STR_SUPPL2 地名 3 (String)
LOCATION 地名 5 (String)
BUILDING 旧：建物 (番号または略称) (String)
FLOOR 建物の階 (String)
ROOM_NO 部屋/アパート番号 (String)
COUNTRY 国コード (String)
LANGU 言語キー (String)
REGION 地域 (都道府県) (String)
SORT1 検索条件 1 (String)
SORT2 検索条件 2 (String)
TIME_ZONE アドレスタイムゾーン (String)
TAXJURCODE 税管轄コード (String)
ADR_NOTES 住所注記 (String)
COMM_TYPE 通信方法 (キー) (アドレス管理) (String)
TEL1_NUMBR 第一電話番号：ダイヤルコード + 番号 (String)
TEL1_EXT 第 1 電話番号：内線 (String)
FAX_NUMBER 第一 FAX 番号：ダイヤルコード + 番号 (String)
FAX_EXTENS 第一 FAX 番号：内線 (String)
STREET_LNG 地名 (String)
DISTRCT_NO 市区町村/地名ファイルの所在地コード (String)
CHCKSTATUS 市区町村ファイルテストステータス (String)
PBOXCIT_NO 市区町村私書箱コード (市ファイル) (String)
TRANSPZONE 商品の納入区域 (String)
HOUSE_NO2 番地補足 (String)
E_MAIL 電子メールアドレス (String)
STR_SUPPL3 地名 4 (String)
TITLE タイトル (敬称) (String)
COUNTRYISO ISO 国コード (String)
LANGU_ISO ISO 639 準拠の言語 (String)
BUILD_LONG 建物 (番号またはコード) (String)
REGIOGROUP 地域構造グループ化 (String)

取得した出荷伝票アドレス情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の出荷伝票アドレスの「購買伝票の明細番号」
[idx]["ADDR_NO"]　→　配列内のidx番目の出荷伝票アドレスの「アドレス番号」
[idx]["FORMOFADDR"]　→　配列内のidx番目の出荷伝票アドレスの「敬称テキスト」
[idx]["NAME"]　→　配列内のidx番目の出荷伝票アドレスの「名称 1」
[idx]["NAME_2"]　→　配列内のidx番目の出荷伝票アドレスの「名称 2」
[idx]["NAME_3"]　→　配列内のidx番目の出荷伝票アドレスの「名称 3」
[idx]["NAME_4"]　→　配列内のidx番目の出荷伝票アドレスの「名称 4」
[idx]["C_O_NAME"]　→　配列内のidx番目の出荷伝票アドレスの「気付」
[idx]["CITY"]　→　配列内のidx番目の出荷伝票アドレスの「市区町村」
[idx]["DISTRICT"]　→　配列内のidx番目の出荷伝票アドレスの「所在地」
[idx]["CITY_NO"] 　→　配列内のidx番目の出荷伝票アドレスの「市区町村/地名ファイルの市区町村コード」
[idx]["POSTL_COD1"]　→　配列内のidx番目の出荷伝票アドレスの「市区町村の郵便番号」
[idx]["POSTL_COD2"]　→　配列内のidx番目の出荷伝票アドレスの「私書箱郵便番号」
[idx]["POSTL_COD3"] 　→　配列内のidx番目の出荷伝票アドレスの「会社郵便番号 (大規模なユーザ用)」
[idx]["PO_BOX"]　→　配列内のidx番目の出荷伝票アドレスの「私書箱」
[idx]["PO_BOX_CIT"]　→　配列内のidx番目の出荷伝票アドレスの「私書箱住所」
[idx]["DELIV_DIS"]　→　配列内のidx番目の出荷伝票アドレスの「郵便配達地域」
[idx]["STREET"]　→　配列内のidx番目の出荷伝票アドレスの「地名」
[idx]["STREET_NO"] 　→　配列内のidx番目の出荷伝票アドレスの「市区町村/地名ファイルの地名コード」
[idx]["STR_ABBR"]　→　配列内のidx番目の出荷伝票アドレスの「地名の略称 (例：スペイン)」
[idx]["HOUSE_NO"]　→　配列内のidx番目の出荷伝票アドレスの「番地-号」
[idx]["STR_SUPPL1"]　→　配列内のidx番目の出荷伝票アドレスの「地名 2」
[idx]["STR_SUPPL2"]　→　配列内のidx番目の出荷伝票アドレスの「地名 3」
[idx]["LOCATION"]　→　配列内のidx番目の出荷伝票アドレスの「地名 5」
[idx]["BUILDING"]　→　配列内のidx番目の出荷伝票アドレスの「旧：建物 (番号または略称)」
[idx]["FLOOR"]　→　配列内のidx番目の出荷伝票アドレスの「建物の階」
[idx]["ROOM_NO"]　→　配列内のidx番目の出荷伝票アドレスの「部屋/アパート番号」
[idx]["COUNTRY"]　→　配列内のidx番目の出荷伝票アドレスの「国コード」
[idx]["LANGU"]　→　配列内のidx番目の出荷伝票アドレスの「言語キー」
[idx]["REGION"]　→　配列内のidx番目の出荷伝票アドレスの「地域 (都道府県)」
[idx]["SORT1"]　→　配列内のidx番目の出荷伝票アドレスの「検索条件 1」
[idx]["SORT2"]　→　配列内のidx番目の出荷伝票アドレスの「検索条件 2」
[idx]["TIME_ZONE"]　→　配列内のidx番目の出荷伝票アドレスの「アドレスタイムゾーン」
[idx]["TAXJURCODE"]　→　配列内のidx番目の出荷伝票アドレスの「税管轄コード」
[idx]["ADR_NOTES"]　→　配列内のidx番目の出荷伝票アドレスの「住所注記」
[idx]["COMM_TYPE"] 　→　配列内のidx番目の出荷伝票アドレスの「通信方法 (キー) (アドレス管理)」
[idx]["TEL1_NUMBR"] 　→　配列内のidx番目の出荷伝票アドレスの「第一電話番号：ダイヤルコード + 番号」
[idx]["TEL1_EXT"]　→　配列内のidx番目の出荷伝票アドレスの「第 1 電話番号：内線」
[idx]["FAX_NUMBER"] 　→　配列内のidx番目の出荷伝票アドレスの「第一 FAX 番号：ダイヤルコード + 番号」
[idx]["FAX_EXTENS"]　→　配列内のidx番目の出荷伝票アドレスの「第一 FAX 番号：内線」
[idx]["STREET_LNG"]　→　配列内のidx番目の出荷伝票アドレスの「地名」
[idx]["DISTRCT_NO"] 　→　配列内のidx番目の出荷伝票アドレスの「市区町村/地名ファイルの所在地コード」
[idx]["CHCKSTATUS"] 　→　配列内のidx番目の出荷伝票アドレスの「市区町村ファイルテストステータス」
[idx]["PBOXCIT_NO"] 　→　配列内のidx番目の出荷伝票アドレスの「市区町村私書箱コード (市ファイル)」
[idx]["TRANSPZONE"]　→　配列内のidx番目の出荷伝票アドレスの「商品の納入区域」
[idx]["HOUSE_NO2"]　→　配列内のidx番目の出荷伝票アドレスの「番地補足」
[idx]["E_MAIL"]　→　配列内のidx番目の出荷伝票アドレスの「電子メールアドレス」
[idx]["STR_SUPPL3"]　→　配列内のidx番目の出荷伝票アドレスの「地名 4」
[idx]["TITLE"]　→　配列内のidx番目の出荷伝票アドレスの「タイトル (敬称)」
[idx]["COUNTRYISO"]　→　配列内のidx番目の出荷伝票アドレスの「ISO 国コード」
[idx]["LANGU_ISO"]　→　配列内のidx番目の出荷伝票アドレスの「ISO 639 準拠の言語」
[idx]["BUILD_LONG"]　→　配列内のidx番目の出荷伝票アドレスの「建物 (番号またはコード)」
[idx]["REGIOGROUP"]　→　配列内のidx番目の出荷伝票アドレスの「地域構造グループ化」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getDocumentHeader

Object getDocumentHeader ()

伝票ヘッダを取得します。
返却値
Object 伝票ヘッダオブジェクト

伝票ヘッダオブジェクトの構成は以下のとおりです。
伝票ヘッダ情報
オブジェクト
(Object)
PO_NUMBER 購買伝票番号 (String)
COMP_CODE 会社コード (String)
DOC_TYPE 購買伝票タイプ (String)
DELETE_IND 購買伝票の削除フラグ (String)
STATUS 購買伝票のステータス (String)
CREAT_DATE レコード登録日 (String)
CREATED_BY オブジェクト登録者名 (String)
ITEM_INTVL 明細番号間隔 (String)
VENDOR 仕入先勘定コード (String)
LANGU 言語キー (String)
LANGU_ISO 言語キーの ISO コード (String)
PMNTTRMS 支払条件キー (String)
DSCNT1_TO 現金割引日数 (早期支払) (String)
DSCNT2_TO 現金割引日数 (早期支払) (String)
DSCNT3_TO 現金割引日数 (早期支払) (String)
DSCT_PCT1 割引率 1 (String)
DSCT_PCT2 割引率 2 (String)
PURCH_ORG 購買組織 (String)
PUR_GROUP 購買グループ (String)
CURRENCY 通貨コード (String)
CURRENCY_ISO ISO コード通貨 (String)
EXCH_RATE 換算レート (String)
EX_RATE_FX 区分：換算レート固定 (String)
DOC_DATE 購買伝票日付 (String)
VPER_START 有効期間開始日 (String)
VPER_END 有効期間の終了日 (String)
WARRANTY 保証日 (String)
QUOTATION 見積番号 (String)
QUOT_DATE 見積提出日 (String)
REF_1 得意先/仕入先の内部参照コード (String)
SALES_PERS 仕入先営業担当者 (String)
TELEPHONE 仕入先電話番号 (String)
SUPPL_VEND 供給仕入先 (String)
CUSTOMER 得意先コード 1 (String)
AGREEMENT 購買契約番号 (String)
GR_MESSAGE 区分：入庫メッセージ (String)
SUPPL_PLNT 在庫転送オーダーにおける供給 (出庫) プラント (String)
INCOTERMS1 インコタームズ (1) (String)
INCOTERMS2 インコタームズ 2 (String)
COLLECT_NO 一括番号 (String)
DIFF_INV 仕入先と請求元が異なる場合の請求元のコード (String)
OUR_REF 社内参照番号 (String)
LOGSYSTEM 論理システム (String)
SUBITEMINT 副明細の明細間隔 (String)
PO_REL_IND 承認区分：購買伝票 (String)
REL_STATUS 承認状況 (String)
VAT_CNTRY 売上税 ID 番号国 (String)
VAT_CNTRY_ISO 消費税登録番号の ISO 国コード (String)
REASON_CANCEL 取消理由 (String)
REASON_CODE Goods Receipt Reason Code

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getExportHeader

Object getExportHeader ()

貿易管理ヘッダを取得します｡
返却値
Object 貿易管理ヘッダ

貿易管理ヘッダ情報オブジェクトの構成は以下のとおりです。
貿易管理ヘッダ情報
オブジェクト
(Object)
TRANSPORT_MODE 貿易管理の輸送モード (String)
CUSTOMS 税関：税関 (出国時) (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getExportItemList

Object getExportItemList ()

貿易管理明細一覧を取得します｡
返却値
Object 貿易管理明細一覧

貿易管理明細情報オブジェクトの構成は以下のとおりです。
貿易管理明細情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号 (String)
BUSINESS_TRANSACTION_TYPE 貿易管理の取引タイプ (String)
EXPORT_IMPORT_PROCEDURE 貿易の輸出入手続 (String)
COUNTRYORI 品目の原産国 (String)
COUNTRYORI_ISO ISO 国コード (String)
REGIONORIG 品目の原産地 (非特恵対象地区の原産) (String)
COMM_CODE 貿易：統計品目コード/輸入コード番号 (String)
SHIPPING_COUNTRY 貿易：出荷国 (String)
SHIPPING_COUNTRY_ISO ISO 国コード (String)

取得した貿易管理明細情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の貿易管理明細の「購買伝票の明細番号」
[idx]["BUSINESS_TRANSACTION_TYPE"] 　→　配列内のidx番目の貿易管理明細の「貿易管理の取引タイプ」
[idx]["EXPORT_IMPORT_PROCEDURE"] 　→　配列内のidx番目の貿易管理明細の「貿易の輸出入手続」
[idx]["COUNTRYORI"]　→　配列内のidx番目の貿易管理明細の「品目の原産国」
[idx]["COUNTRYORI_ISO"]　→　配列内のidx番目の貿易管理明細の「ISO 国コード」
[idx]["REGIONORIG"] 　→　配列内のidx番目の貿易管理明細の「品目の原産地 (非特恵対象地区の原産)」
[idx]["COMM_CODE"]　→　配列内のidx番目の貿易管理明細の「貿易：統計品目コード/輸入コード番号」
[idx]["SHIPPING_COUNTRY"]　→　配列内のidx番目の貿易管理明細の「貿易：出荷国」
[idx]["SHIPPING_COUNTRY_ISO"] 　→　配列内のidx番目の貿易管理明細の「ISO 国コード」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getExtensionList

Object getExtensionList ()

拡張得意先項目一覧を取得します｡
返却値
Object 拡張得意先項目一覧

拡張得意先項目情報オブジェクトの構成は以下のとおりです。
拡張得意先項目情報
オブジェクト
(Object)
STRUCTURE BAPI テーブル拡張の構造名 (String)
VALUEPART1 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART2 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART3 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART4 BAPI 拡張パラメータのデータ部分 (String)

取得した拡張得意先項目情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["STRUCTURE"]　→　配列内のidx番目の拡張得意先項目の「BAPI テーブル拡張の構造名」
[idx]["VALUEPART1"] 　→　配列内のidx番目の拡張得意先項目の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART2"] 　→　配列内のidx番目の拡張得意先項目の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART3"] 　→　配列内のidx番目の拡張得意先項目の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART4"] 　→　配列内のidx番目の拡張得意先項目の「BAPI 拡張パラメータのデータ部分」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getHeaderTextList

Object getHeaderTextList ()

ヘッダテキスト一覧を取得します｡
返却値
Object ヘッダテキスト一覧

ヘッダテキスト情報オブジェクトの構成は以下のとおりです。
ヘッダテキスト情報
オブジェクト
(Object)
PO_NUMBER 購買伝票番号 (String)
PO_ITEM 購買伝票の明細番号 (String)
TEXT_ID テキスト ID (String)
TEXT_FORM タグ列 (String)
TEXT_LINE テキスト行 (String)

取得したヘッダテキスト情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_NUMBER"]　→　配列内のidx番目のヘッダテキストの「購買伝票番号」
[idx]["PO_ITEM"]　→　配列内のidx番目のヘッダテキストの「購買伝票の明細番号」
[idx]["TEXT_ID"]　→　配列内のidx番目のヘッダテキストの「テキスト ID」
[idx]["TEXT_FORM"]　→　配列内のidx番目のヘッダテキストの「タグ列」
[idx]["TEXT_LINE"]　→　配列内のidx番目のヘッダテキストの「テキスト行」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getItemTextList

Object getItemTextList ()

明細テキスト一覧を取得します｡
返却値
Object 明細テキスト

明細テキスト情報オブジェクトの構成は以下のとおりです。
明細テキスト情報
オブジェクト
(Object)
PO_NUMBER 購買伝票番号 (String)
PO_ITEM 購買伝票の明細番号 (String)
TEXT_ID テキスト ID (String)
TEXT_FORM タグ列 (String)
TEXT_LINE テキスト行 (String)

取得した明細テキスト情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_NUMBER"]　→　配列内のidx番目の明細テキストの「購買伝票番号」
[idx]["PO_ITEM"]　→　配列内のidx番目の明細テキストの「購買伝票の明細番号」
[idx]["TEXT_ID"]　→　配列内のidx番目の明細テキストの「テキスト ID」
[idx]["TEXT_FORM"]　→　配列内のidx番目の明細テキストの「タグ列」
[idx]["TEXT_LINE"]　→　配列内のidx番目の明細テキストの「テキスト行」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getLimitsList

Object getLimitsList ()

外注制限一覧を取得します｡
返却値
Object 外注制限一覧

外注制限情報オブジェクトの構成は以下のとおりです。
外注制限情報
オブジェクト
(Object)
PCKG_NO パッケージ番号 (String)
LIMIT 全体制限 (String)
NO_LIMIT 制限なし (String)
EXP_VALUE 見込金額 (String)
SSC_EXIST サービスタイプの制限 (String)
CON_EXIST 基本契約明細の制限 (String)
TMP_EXIST サービスパッケージの制限 (String)
PRICE_CHG 入力シートの価格変更 (String)
FREE_LIMIT 自由制限 (String)
NO_FRLIMIT 制限なし (String)
SERV_TYPE サービスタイプのテキスト (短) (String)
EDITION サービスタイプのバージョン (String)
SSC_LIMIT サービスタイプの金額制限 (String)
SSC_NOLIM 標準サービスタイプの制限なし (String)
SSC_PRSCHG 入力シートの価格変更 (String)
SSC_PERC 価格決定率 (String)
TMP_NUMBER モデルサービス明細セット番号 (String)
TMP_LIMIT モデルサービス明細制限 (String)
TMP_NOLIM モデル仕様の制限なし (String)
TMP_PRSCHG 入力シートの価格変更 (String)
TMP_PERC 価格決定率 (String)
CONT_PERC 価格決定率 (String)

取得した外注制限情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PCKG_NO"]　→　配列内のidx番目の外注制限の「パッケージ番号」
[idx]["LIMIT"]　→　配列内のidx番目の外注制限の「全体制限」
[idx]["NO_LIMIT"]　→　配列内のidx番目の外注制限の「制限なし」
[idx]["EXP_VALUE"]　→　配列内のidx番目の外注制限の「見込金額」
[idx]["SSC_EXIST"]　→　配列内のidx番目の外注制限の「サービスタイプの制限」
[idx]["CON_EXIST"]　→　配列内のidx番目の外注制限の「基本契約明細の制限」
[idx]["TMP_EXIST"]　→　配列内のidx番目の外注制限の「サービスパッケージの制限」
[idx]["PRICE_CHG"]　→　配列内のidx番目の外注制限の「入力シートの価格変更」
[idx]["FREE_LIMIT"]　→　配列内のidx番目の外注制限の「自由制限」
[idx]["NO_FRLIMIT"]　→　配列内のidx番目の外注制限の「制限なし」
[idx]["SERV_TYPE"]　→　配列内のidx番目の外注制限の「サービスタイプのテキスト (短)」
[idx]["EDITION"]　→　配列内のidx番目の外注制限の「サービスタイプのバージョン」
[idx]["SSC_LIMIT"]　→　配列内のidx番目の外注制限の「サービスタイプの金額制限」
[idx]["SSC_NOLIM"]　→　配列内のidx番目の外注制限の「標準サービスタイプの制限なし」
[idx]["SSC_PRSCHG"]　→　配列内のidx番目の外注制限の「入力シートの価格変更」
[idx]["SSC_PERC"]　→　配列内のidx番目の外注制限の「価格決定率」
[idx]["TMP_NUMBER"]　→　配列内のidx番目の外注制限の「モデルサービス明細セット番号」
[idx]["TMP_LIMIT"]　→　配列内のidx番目の外注制限の「モデルサービス明細制限」
[idx]["TMP_NOLIM"]　→　配列内のidx番目の外注制限の「モデル仕様の制限なし」
[idx]["TMP_PRSCHG"]　→　配列内のidx番目の外注制限の「入力シートの価格変更」
[idx]["TMP_PERC"]　→　配列内のidx番目の外注制限の「価格決定率」
[idx]["CONT_PERC"]　→　配列内のidx番目の外注制限の「価格決定率」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getMemoryComplete

Object getMemoryComplete ()

エラーがない場合に購買発注を保留にする区分を取得します｡

返却値
Object エラーがない場合に購買発注を保留にする区分
getMemoryUnComplete

Object getMemoryUnComplete ()

エラーがある場合に購買発注を保留にする区分を取得します｡

返却値
Object エラーがある場合に購買発注を保留にする区分
getNoAuthority

Object getNoAuthority ()

権限チェックなし区分を取得します｡

返却値
Object 権限チェックなし区分
getNoMessageReq

Object getNoMessageReq ()

メッセージ不要区分を取得します｡

返却値
Object メッセージ不要区分
getNoMessaging

Object getNoMessaging ()

出力決定なし区分を取得します。

返却値
Object 出力決定なし区分
getNoPriceFromPo

Object getNoPriceFromPo ()

最終伝票からの価格転送なし区分を取得します｡。

返却値
Object 最終伝票からの価格転送なし区分
getPartnerList

Object getPartnerList ()

得意先一覧を取得します｡
返却値
Object 得意先一覧

得意先情報オブジェクトの構成は以下のとおりです。
得意先情報
オブジェクト
(Object)
PARTNERDESC 言語別取引先機能テキスト (String)
LANGU 言語キー (String)
BUSPARTNO 取引先の仕入先マスタコード (String)
DELETE_IND 削除フラグ (String)

取得した得意先情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PARTNERDESC"]　→　配列内のidx番目の得意先の「言語別取引先機能テキスト」
[idx]["LANGU"]　→　配列内のidx番目の得意先の「言語キー」
[idx]["BUSPARTNO"]　→　配列内のidx番目の得意先の「取引先の仕入先マスタコード」
[idx]["DELETE_IND"]　→　配列内のidx番目の得意先の「削除フラグ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPoNumber

Object getPoNumber ()

購買伝票番号を取得します｡

返却値
Object 購買伝票番号
getProfitSegmentList

Object getProfitSegmentList ()

入出庫予定一覧を取得します｡
返却値
Object 入出庫予定一覧

入出庫予定情報オブジェクトの構成は以下のとおりです。
入出庫予定情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号 (String)
SERIAL_NO 勘定設定の連続番号 (String)
FIELDNAME 項目名 (String)
VALUE CO-PA 特性値 (String)

取得した入出庫予定情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の入出庫予定の「購買伝票の明細番号」
[idx]["SERIAL_NO"]　→　配列内のidx番目の入出庫予定の「勘定設定の連続番号」
[idx]["FIELDNAME"]　→　配列内のidx番目の入出庫予定の「項目名」
[idx]["VALUE"]　→　配列内のidx番目の入出庫予定の「CO-PA 特性値」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPurchaseAccountList

Object getPurchaseAccountList ()

勘定設定一覧を取得します｡
返却値
Object 勘定設定一覧

勘定設定情報オブジェクトの構成は以下のとおりです。
勘定設定情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号 (String)
SERIAL_NO 勘定設定の連続番号 (String)
DELETE_IND 削除フラグ：購買伝票勘定設定 (String)
CREAT_DATE レコード登録日 (String)
QUANTITY 数量 (String)
DISTR_PERC 配賦率 % (複数勘定設定) (String)
NET_VALUE BAPI の通貨額 (小数点以下９桁) (String)
GL_ACCOUNT G/L 勘定コード (String)
BUS_AREA 事業領域 (String)
COSTCENTER 原価センタ (String)
SD_DOC 販売管理伝票番号 (String)
ITM_NUMBER 販売伝票明細 (String)
SCHED_LINE 納入日程行 (String)
ASSET_NO 資産番号 (String)
SUB_NUMBER 資産補助番号 (String)
ORDERID 指図番号 (String)
GR_RCPT 受領者 (String)
UNLOAD_PT 荷渡ポイント (String)
CO_AREA 管理領域 (String)
COSTOBJECT 原価対象 (String)
PROFIT_CTR 利益センタ (String)
WBS_ELEMENT WBS 要素 (String)
NETWORK 勘定割当のネットワーク番号 (String)
RL_EST_KEY 不動産管理対象の内部キー (String)
PART_ACCT 取引先勘定コード (String)
CMMT_ITEM 資金予算コード (String)
REC_IND リカバリフラグ (String)
FUNDS_CTR 予算センタ (String)
FUND 会計区分 (String)
FUNC_AREA 機能領域 (String)
REF_DATE 決済の参照日付 (String)
TAX_CODE 消費税コード (String)
TAXJURCODE 税計算管轄コード - 税管轄コード (String)
NOND_ITAX BAPI の通貨額 (小数点以下９桁) (String)
ACTTYPE 活動タイプ (String)
CO_BUSPROC 業務プロセス (String)
RES_DOC 用途指定予算の伝票番号 (String)
RES_ITEM 用途指定予算：伝票明細 (String)
ACTIVITY 作業番号 (String)
GRANT_NBR 補助金 (String)
CMMT_ITEM_LONG 資金予算コード (String)
FUNC_AREA_LONG 機能領域 (String)

取得した勘定設定情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の勘定設定の「購買伝票の明細番号」
[idx]["SERIAL_NO"]　→　配列内のidx番目の勘定設定の「勘定設定の連続番号」
[idx]["DELETE_IND"]　→　配列内のidx番目の勘定設定の「削除フラグ：購買伝票勘定設定」
[idx]["CREAT_DATE"]　→　配列内のidx番目の勘定設定の「レコード登録日」
[idx]["QUANTITY"]　→　配列内のidx番目の勘定設定の「数量」
[idx]["DISTR_PERC"]　→　配列内のidx番目の勘定設定の「配賦率 % (複数勘定設定)」
[idx]["NET_VALUE"]　→　配列内のidx番目の勘定設定の「BAPI の通貨額 (小数点以下９桁)」
[idx]["GL_ACCOUNT"]　→　配列内のidx番目の勘定設定の「G/L 勘定コード」
[idx]["BUS_AREA"]　→　配列内のidx番目の勘定設定の「事業領域」
[idx]["COSTCENTER"]　→　配列内のidx番目の勘定設定の「原価センタ」
[idx]["SD_DOC"]　→　配列内のidx番目の勘定設定の「販売管理伝票番号」
[idx]["ITM_NUMBER"]　→　配列内のidx番目の勘定設定の「販売伝票明細」
[idx]["SCHED_LINE"]　→　配列内のidx番目の勘定設定の「納入日程行」
[idx]["ASSET_NO"]　→　配列内のidx番目の勘定設定の「資産番号」
[idx]["SUB_NUMBER"]　→　配列内のidx番目の勘定設定の「資産補助番号」
[idx]["ORDERID"]　→　配列内のidx番目の勘定設定の「指図番号」
[idx]["GR_RCPT"]　→　配列内のidx番目の勘定設定の「受領者」
[idx]["UNLOAD_PT"]　→　配列内のidx番目の勘定設定の「荷渡ポイント」
[idx]["CO_AREA"]　→　配列内のidx番目の勘定設定の「管理領域」
[idx]["COSTOBJECT"]　→　配列内のidx番目の勘定設定の「原価対象」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の勘定設定の「利益センタ」
[idx]["WBS_ELEMENT"]　→　配列内のidx番目の勘定設定の「WBS 要素」
[idx]["NETWORK"]　→　配列内のidx番目の勘定設定の「勘定割当のネットワーク番号」
[idx]["RL_EST_KEY"]　→　配列内のidx番目の勘定設定の「不動産管理対象の内部キー」
[idx]["PART_ACCT"]　→　配列内のidx番目の勘定設定の「取引先勘定コード」
[idx]["CMMT_ITEM"]　→　配列内のidx番目の勘定設定の「資金予算コード」
[idx]["REC_IND"]　→　配列内のidx番目の勘定設定の「リカバリフラグ」
[idx]["FUNDS_CTR"]　→　配列内のidx番目の勘定設定の「予算センタ」
[idx]["FUND"]　→　配列内のidx番目の勘定設定の「会計区分」
[idx]["FUNC_AREA"]　→　配列内のidx番目の勘定設定の「機能領域」
[idx]["REF_DATE"]　→　配列内のidx番目の勘定設定の「決済の参照日付」
[idx]["TAX_CODE"]　→　配列内のidx番目の勘定設定の「消費税コード」
[idx]["TAXJURCODE"]　→　配列内のidx番目の勘定設定の「税計算管轄コード - 税管轄コード」
[idx]["NOND_ITAX"]　→　配列内のidx番目の勘定設定の「BAPI の通貨額 (小数点以下９桁)」
[idx]["ACTTYPE"]　→　配列内のidx番目の勘定設定の「活動タイプ」
[idx]["CO_BUSPROC"]　→　配列内のidx番目の勘定設定の「業務プロセス」
[idx]["RES_DOC"]　→　配列内のidx番目の勘定設定の「用途指定予算の伝票番号」
[idx]["RES_ITEM"]　→　配列内のidx番目の勘定設定の「用途指定予算：伝票明細」
[idx]["ACTIVITY"]　→　配列内のidx番目の勘定設定の「作業番号」
[idx]["GRANT_NBR"]　→　配列内のidx番目の勘定設定の「補助金」
[idx]["CMMT_ITEM_LONG"]　→　配列内のidx番目の勘定設定の「資金予算コード」
[idx]["FUNC_AREA_LONG"]　→　配列内のidx番目の勘定設定の「機能領域」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPurchaseComponentsList

Object getPurchaseComponentsList ()

コンポーネント一覧を取得します｡
返却値
Object コンポーネント一覧

コンポーネント情報オブジェクトの構成は以下のとおりです。
コンポーネント情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号
SCHED_LINE 納入日程行
ITEM_NO 入出庫予定/従属所要量の明細番号
MATERIAL 品目コード
ENTRY_QUANTITY 構成品目の所要量
ENTRY_UOM 入力単位
ENTRY_UOM_ISO 入力単位 (ISO コード)
FIXED_QUAN 数量固定
PLANT プラント
REQ_DATE 構成品目の所要日付
CHANGE_ID 変更タイプ(U、I、E、D)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード (長)
MATERIAL_GUID 項目 MATERIAL の外部 GUID
MATERIAL_VERSION 項目 MATERIAL のバージョン番号

取得したコンポーネント情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の出荷データの「購買伝票の明細番号」
[idx]["SCHED_LINE"]　→　配列内のidx番目の出荷データの「納入日程行」
[idx]["ITEM_NO"]　→　配列内のidx番目の出荷データの「入出庫予定/従属所要量の明細番号」
[idx]["MATERIAL"]　→　配列内のidx番目の出荷データの「品目コード」
[idx]["ENTRY_QUANTITY"]　→　配列内のidx番目の出荷データの「構成品目の所要量」
[idx]["ENTRY_UOM"]　→　配列内のidx番目の出荷データの「入力単位」
[idx]["ENTRY_UOM_ISO"] 　→　配列内のidx番目の出荷データの「入力単位 (ISO コード)」
[idx]["FIXED_QUAN"]　→　配列内のidx番目の出荷データの「数量固定」
[idx]["PLANT"]　→　配列内のidx番目の出荷データの「プラント」
[idx]["REQ_DATE"]　→　配列内のidx番目の出荷データの「構成品目の所要日付」
[idx]["CHANGE_ID"]　→　配列内のidx番目の出荷データの「変更タイプ(U、I、E、D)」
[idx]["MATERIAL_EXTERNAL"] 　→　配列内のidx番目の出荷データの「項目 MATERIAL の品目コード (長)」
[idx]["MATERIAL_GUID"] 　→　配列内のidx番目の出荷データの「項目 MATERIAL の外部 GUID」
[idx]["MATERIAL_VERSION"] 　→　配列内のidx番目の出荷データの「項目 MATERIAL のバージョン番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPurchaseConfirmationList

Object getPurchaseConfirmationList ()

転送構造: 照会/一覧 - 仕入先確認一覧を取得します｡
返却値
Object 転送構造: 照会/一覧 - 仕入先確認一覧

転送構造: 照会/一覧 - 仕入先確認情報オブジェクトの構成は以下のとおりです。
転送構造: 照会/一覧 - 仕入先確認情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号
CONF_SER 仕入先確認の連続番号
CONF_TYPE 確認カテゴリ
CONF_NAME 確認カテゴリ: テキスト
DEL_DATCAT 仕入先確認における納入期日の日付カテゴリ
DEL_DATCAT_EXT 納入期日カテゴリ
DELIV_DATE 仕入先確認の納入日付
DELIV_TIME 仕入先確認の納入日時
QUANTITY 仕入先確認による数量
DELETE_IND 区分: 仕入先確認削除
DISPO_REL 区分: MRP 関連の確認
RECEIPT_REL 区分: 入庫関連の確認
EXT_DOC 仕入先確認の外部伝票番号
DELIV_NUMB 出荷伝票
DELIV_ITEM 出荷明細
EXT_DOC_LONG 参照伝票番号 (依存性についてはテキスト長参照)

取得した転送構造: 照会/一覧 - 仕入先確認情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の出荷データの「購買伝票の明細番号」
[idx]["CONF_SER"]　→　配列内のidx番目の出荷データの「仕入先確認の連続番号」
[idx]["CONF_TYPE"]　→　配列内のidx番目の出荷データの「確認カテゴリ」
[idx]["CONF_NAME"]　→　配列内のidx番目の出荷データの「確認カテゴリ: テキスト」
[idx]["DEL_DATCAT"]　→　配列内のidx番目の出荷データの「仕入先確認における納入期日の日付カテゴリ」
[idx]["DEL_DATCAT_EXT"]　→　配列内のidx番目の出荷データの「納入期日カテゴリ」
[idx]["DELIV_DATE"]　→　配列内のidx番目の出荷データの「仕入先確認の納入日付」
[idx]["DELIV_TIME"]　→　配列内のidx番目の出荷データの「仕入先確認の納入日時」
[idx]["QUANTITY"]　→　配列内のidx番目の出荷データの「仕入先確認による数量」
[idx]["DELETE_IND"]　→　配列内のidx番目の出荷データの「区分: 仕入先確認削除」
[idx]["DISPO_REL"]　→　配列内のidx番目の出荷データの「区分: MRP 関連の確認」
[idx]["RECEIPT_REL"]　→　配列内のidx番目の出荷データの「区分: 入庫関連の確認」
[idx]["EXT_DOC"]　→　配列内のidx番目の出荷データの「仕入先確認の外部伝票番号」
[idx]["DELIV_NUMB"]　→　配列内のidx番目の出荷データの「出荷伝票」
[idx]["DELIV_ITEM"]　→　配列内のidx番目の出荷データの「出荷明細」
[idx]["EXT_DOC_LONG"]　→　配列内のidx番目の出荷データの「参照伝票番号 (依存性についてはテキスト長参照)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPurchaseHistoryList

Object getPurchaseHistoryList ()

購買発注履歴一覧を取得します｡
返却値
Object 購買発注履歴一覧

購買発注履歴情報オブジェクトの構成は以下のとおりです。
購買発注履歴情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号
SERIAL_NO 勘定設定の連続番号
PROCESS_ID 購買発注履歴取引タイプ
DOC_YEAR 入出庫伝票年
MAT_DOC 入出庫伝票番号
MATDOC_ITM 入出庫伝票の明細
HIST_TYPE 購買発注履歴カテゴリ
MOVE_TYPE 移動タイプ (在庫管理)
PSTNG_DATE 伝票の転記日付
QUANTITY 数量
VAL_LOCCUR 国内通貨額
VAL_FORCUR 伝票通貨額
CURRENCY 通貨コード
CL_VAL_LOC 国内通貨による入庫/請求仮勘定決済金額
BLOCKED_QY 発注単位の入庫保留在庫
BL_QTY 入庫保留在庫数量 (発注価格単位)
DB_CR_IND 借方/貸方フラグ
VAL_TYPE 評価タイプ
NO_MORE_GR 納入完了 区分
REF_DOC_NO 参照伝票番号
REF_DOC_YR 参照伝票の会計年度
REF_DOC 参照伝票の伝票番号
REF_DOC_IT 参照伝票の明細
MOVE_REAS 移動理由
ENTRY_DATE 会計伝票登録日付
ENTRY_TIME 登録時刻
IVVAL_LOC 国内通貨での入力請求額
IVVAL_FOR 外貨での入力済請求額
MATERIAL 品目コード
PLANT プラント
CONF_SER 仕入先確認の連続番号
CONDITION 伝票条件番号
TAX_CODE 売上税コード
DELIV_QTY 納品書数量単位の数量
DELIV_UNIT 納品書の数量単位
PUR_MAT 品目コード
LOC_CURR 国内通貨コード
BATCH ロット番号
DOC_DATE 伝票の伝票日付
CURRENCY_ISO ISO 通貨コード
LOC_CURR_ISO 国内通貨の ISO コード
DELIV_UNIT_ISO 納品書数量単位の ISO コード
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード (長)
MATERIAL_GUID 項目 MATERIAL の外部 GUID
MATERIAL_VERSION 項目 MATERIAL のバージョン番号
PUR_MAT_EXTERNAL 項目 PUR_MAT の品目コード (長)
PUR_MAT_GUID 項目 PUR_MAT の外部 GUID
PUR_MAT_VERSION 項目 PUR_MAT のバージョン番号
REF_DOC_NO_LONG 参照伝票番号 (依存性についてはテキスト長参照)

取得した購買発注履歴情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の出荷データの「購買伝票の明細番号」
[idx]["SERIAL_NO"]　→　配列内のidx番目の出荷データの「勘定設定の連続番号」
[idx]["PROCESS_ID"]　→　配列内のidx番目の出荷データの「購買発注履歴取引タイプ」
[idx]["DOC_YEAR"]　→　配列内のidx番目の出荷データの「入出庫伝票年」
[idx]["MAT_DOC"]　→　配列内のidx番目の出荷データの「入出庫伝票番号」
[idx]["MATDOC_ITM"]　→　配列内のidx番目の出荷データの「入出庫伝票の明細」
[idx]["HIST_TYPE"]　→　配列内のidx番目の出荷データの「購買発注履歴カテゴリ」
[idx]["MOVE_TYPE"]　→　配列内のidx番目の出荷データの「移動タイプ (在庫管理)」
[idx]["PSTNG_DATE"]　→　配列内のidx番目の出荷データの「伝票の転記日付」
[idx]["QUANTITY"]　→　配列内のidx番目の出荷データの「数量」
[idx]["VAL_LOCCUR"]　→　配列内のidx番目の出荷データの「国内通貨額」
[idx]["VAL_FORCUR"]　→　配列内のidx番目の出荷データの「伝票通貨額」
[idx]["CURRENCY"]　→　配列内のidx番目の出荷データの「通貨コード」
[idx]["CL_VAL_LOC"]　→　配列内のidx番目の出荷データの「国内通貨による入庫/請求仮勘定決済金額」
[idx]["BLOCKED_QY"]　→　配列内のidx番目の出荷データの「発注単位の入庫保留在庫」
[idx]["BL_QTY"]　→　配列内のidx番目の出荷データの「入庫保留在庫数量 (発注価格単位)」
[idx]["DB_CR_IND"]　→　配列内のidx番目の出荷データの「借方/貸方フラグ」
[idx]["VAL_TYPE"]　→　配列内のidx番目の出荷データの「評価タイプ」
[idx]["NO_MORE_GR"]　→　配列内のidx番目の出荷データの「納入完了 区分」
[idx]["REF_DOC_NO"]　→　配列内のidx番目の出荷データの「参照伝票番号」
[idx]["REF_DOC_YR"]　→　配列内のidx番目の出荷データの「参照伝票の会計年度」
[idx]["REF_DOC"]　→　配列内のidx番目の出荷データの「参照伝票の伝票番号」
[idx]["REF_DOC_IT"]　→　配列内のidx番目の出荷データの「参照伝票の明細」
[idx]["MOVE_REAS"]　→　配列内のidx番目の出荷データの「移動理由」
[idx]["ENTRY_DATE"]　→　配列内のidx番目の出荷データの「会計伝票登録日付」
[idx]["ENTRY_TIME"]　→　配列内のidx番目の出荷データの「登録時刻」
[idx]["IVVAL_LOC"]　→　配列内のidx番目の出荷データの「国内通貨での入力請求額」
[idx]["IVVAL_FOR"]　→　配列内のidx番目の出荷データの「外貨での入力済請求額」
[idx]["MATERIAL"]　→　配列内のidx番目の出荷データの「品目コード」
[idx]["PLANT"]　→　配列内のidx番目の出荷データの「プラント」
[idx]["CONF_SER"]　→　配列内のidx番目の出荷データの「仕入先確認の連続番号」
[idx]["CONDITION"]　→　配列内のidx番目の出荷データの「伝票条件番号」
[idx]["TAX_CODE"]　→　配列内のidx番目の出荷データの「売上税コード」
[idx]["DELIV_QTY"]　→　配列内のidx番目の出荷データの「納品書数量単位の数量」
[idx]["DELIV_UNIT"]　→　配列内のidx番目の出荷データの「納品書の数量単位」
[idx]["PUR_MAT"]　→　配列内のidx番目の出荷データの「品目コード」
[idx]["LOC_CURR"]　→　配列内のidx番目の出荷データの「国内通貨コード」
[idx]["BATCH"]　→　配列内のidx番目の出荷データの「ロット番号」
[idx]["DOC_DATE"]　→　配列内のidx番目の出荷データの「伝票の伝票日付」
[idx]["CURRENCY_ISO"]　→　配列内のidx番目の出荷データの「ISO 通貨コード」
[idx]["LOC_CURR_ISO"]　→　配列内のidx番目の出荷データの「国内通貨の ISO コード」
[idx]["DELIV_UNIT_ISO"]　→　配列内のidx番目の出荷データの「納品書数量単位の ISO コード」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の出荷データの「項目 MATERIAL の品目コード (長)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の出荷データの「項目 MATERIAL の外部 GUID」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の出荷データの「項目 MATERIAL のバージョン番号」
[idx]["PUR_MAT_EXTERNAL"]　→　配列内のidx番目の出荷データの「項目 PUR_MAT の品目コード (長)」
[idx]["PUR_MAT_GUID"]　→　配列内のidx番目の出荷データの「項目 PUR_MAT の外部 GUID」
[idx]["PUR_MAT_VERSION"]　→　配列内のidx番目の出荷データの「項目 PUR_MAT のバージョン番号」
[idx]["REF_DOC_NO_LONG"]　→　配列内のidx番目の出荷データの「参照伝票番号 (依存性についてはテキスト長参照)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPurchaseHistoryTotalsList

Object getPurchaseHistoryTotalsList ()

購買発注履歴(合計)一覧を取得します｡
返却値
Object 購買発注履歴(合計)一覧

購買発注履歴(合計)情報オブジェクトの構成は以下のとおりです。
購買発注履歴(合計)情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号
SERIAL_NO 勘定設定の連続番号
WITHDR_QTY 出庫量
BLOCKED_QY 発注単位の入庫保留在庫
BL_QTY 入庫保留在庫数量 (発注価格単位)
DELIV_QTY 入庫数量
PO_PR_QNT 購買発注価格単位での数量
VAL_GR_LOC 国内通貨による入庫額
VAL_GR_FOR 外国通貨での入庫額
IV_QTY 請求数量
IV_QTY_PO 購買価格数量単位による請求数量
VAL_IV_LOC 国内通貨による請求額
VAL_IV_FOR 外貨による請求額
CL_VAL_LOC 国内通貨による入庫/請求仮勘定決済金額
CL_VAL_FOR 外貨による入庫/請求仮勘定決済金額
DOP_VL_LOC 国内通貨による前払金合計
IVVAL_LOC 国内通貨での入力請求額
IVVAL_FOR 外貨での入力済請求額
DL_QTY_TRSP 納入済数量 (在庫転送)
BL_QTY_TOTAL 発注単位による入庫保留在庫 (絶対額)
DL_QTY_TOTAL 入庫数量: 絶対額
IV_QTY_TOTAL 請求書受領数量: 絶対額
CURRENCY 通貨コード
CURRENCY_ISO ISO 通貨コード

取得した購買発注履歴(合計)情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の出荷データの「購買伝票の明細番号」
[idx]["SERIAL_NO"]　→　配列内のidx番目の出荷データの「勘定設定の連続番号」
[idx]["WITHDR_QTY"]　→　配列内のidx番目の出荷データの「出庫量」
[idx]["BLOCKED_QY"]　→　配列内のidx番目の出荷データの「発注単位の入庫保留在庫」
[idx]["BL_QTY"]　→　配列内のidx番目の出荷データの「入庫保留在庫数量 (発注価格単位)」
[idx]["DELIV_QTY"]　→　配列内のidx番目の出荷データの「入庫数量」
[idx]["PO_PR_QNT"]　→　配列内のidx番目の出荷データの「購買発注価格単位での数量」
[idx]["VAL_GR_LOC"]　→　配列内のidx番目の出荷データの「国内通貨による入庫額」
[idx]["VAL_GR_FOR"]　→　配列内のidx番目の出荷データの「外国通貨での入庫額」
[idx]["IV_QTY"]　→　配列内のidx番目の出荷データの「請求数量」
[idx]["IV_QTY_PO"]　→　配列内のidx番目の出荷データの「購買価格数量単位による請求数量」
[idx]["VAL_IV_LOC"]　→　配列内のidx番目の出荷データの「国内通貨による請求額」
[idx]["VAL_IV_FOR"]　→　配列内のidx番目の出荷データの「外貨による請求額」
[idx]["CL_VAL_LOC"]　→　配列内のidx番目の出荷データの「国内通貨による入庫/請求仮勘定決済金額」
[idx]["CL_VAL_FOR"]　→　配列内のidx番目の出荷データの「外貨による入庫/請求仮勘定決済金額」
[idx]["DOP_VL_LOC"]　→　配列内のidx番目の出荷データの「国内通貨による前払金合計」
[idx]["IVVAL_LOC"]　→　配列内のidx番目の出荷データの「国内通貨での入力請求額」
[idx]["IVVAL_FOR"]　→　配列内のidx番目の出荷データの「外貨での入力済請求額」
[idx]["DL_QTY_TRSP"]　→　配列内のidx番目の出荷データの「納入済数量 (在庫転送)」
[idx]["BL_QTY_TOTAL"]　→　配列内のidx番目の出荷データの「発注単位による入庫保留在庫 (絶対額)」
[idx]["DL_QTY_TOTAL"]　→　配列内のidx番目の出荷データの「入庫数量: 絶対額」
[idx]["IV_QTY_TOTAL"]　→　配列内のidx番目の出荷データの「請求書受領数量: 絶対額」
[idx]["CURRENCY"]　→　配列内のidx番目の出荷データの「通貨コード」
[idx]["CURRENCY_ISO"]　→　配列内のidx番目の出荷データの「ISO 通貨コード」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPurchaseItemPostList

Object getPurchaseItemPostList ()

明細一覧を取得します｡
返却値
Object 明細一覧

明細情報オブジェクトの構成は以下のとおりです。
明細情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号 (String)
DELETE_IND 購買伝票の削除フラグ (String)
SHORT_TEXT テキスト (短) (String)
MATERIAL 品目コード (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード (長) (今後のリリースで開発) (String)
MATERIAL_GUID 項目 MATERIAL の外部 GUID (今後のリリースで開発) (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (今後のリリースで開発) (String)
EMATERIAL 品目コード (String)
EMATERIAL_EXTERNAL 項目 MATERIAL の品目コード (長) (今後のリリースで開発) (String)
EMATERIAL_GUID 項目 MATERIAL の外部 GUID (今後のリリースで開発) (String)
EMATERIAL_VERSION 項目 MATERIAL のバージョン番号 (今後のリリースで開発) (String)
PLANT プラント (String)
STGE_LOC 保管場所 (String)
TRACKINGNO 購買依頼追跡番号 (String)
MATL_GROUP 品目グループ (String)
INFO_REC 購買情報番号 (String)
VEND_MAT 仕入先が使用している品目コード (String)
QUANTITY 購買発注数量 (String)
PO_UNIT 発注単位 (String)
PO_UNIT_ISO ISO コードによる発注単位 (String)
ORDERPR_UN 購買発注価格単位 (購買管理) (String)
ORDERPR_UN_ISO 購買発注価格単位の ISO コード (String)
CONV_NUM1 購買価格単位から購買発注単位への変換分子 (String)
CONV_DEN1 購買価格単位から購買発注単位への変換分母 (String)
NET_PRICE BAPI の通貨額 (小数点以下９桁) (String)
PRICE_UNIT 価格単位 (String)
GR_PR_TIME 入庫処理日数 (String)
TAX_CODE 消費税コード (String)
BON_GRP1 決済グループ 1（購買） (String)
QUAL_INSP 在庫タイプ (String)
INFO_UPD 区分：購買情報更新 (String)
PRNT_PRICE 価格印刷 (String)
EST_PRICE 区分：概算価格 (String)
REMINDER1 第一回催促状/督促状の日数 (String)
REMINDER2 第二回催促状/督促状の日数 (String)
REMINDER3 第三回催促状/督促状の日数 (String)
OVER_DLV_TOL 過剰納入許容範囲 (String)
UNLIMITED_DLV 区分：無制限過剰納入可能 (String)
UNDER_DLV_TOL 不足納入許容範囲リミット (String)
VAL_TYPE 評価タイプ (String)
NO_MORE_GR 納入完了 区分 (String)
FINAL_INV 請求書処理完了区分 (String)
ITEM_CAT 購買伝票の明細カテゴリ (String)
ACCTASSCAT 勘定設定カテゴリ (String)
DISTRIB 複数勘定設定の配賦区分 (String)
PART_INV 一部請求区分 (String)
GR_IND 入庫区分 (String)
GR_NON_VAL 非評価入庫 (String)
IR_IND 請求書受領区分 (String)
FREE_ITEM 無償明細 (String)
GR_BASEDIV 区分：入庫基準の請求書照合 (String)
ACKN_REQD 購買発注請書依頼 (String)
ACKNOWL_NO 購買発注請書番号 (String)
AGREEMENT 購買契約番号 (String)
AGMT_ITEM 購買契約の明細番号 (String)
SHIPPING 出荷指示 (String)
CUSTOMER 得意先 (String)
COND_GROUP 仕入先条件グループ (String)
NO_DISCT 現金値引対象外明細 (String)
PLAN_DEL 予定納入日数 (String)
NET_WEIGHT 正味重量 (String)
WEIGHTUNIT 重量単位 (String)
WEIGHTUNIT_ISO 重量単位の ISO コード (String)
TAXJURCODE 税計算管轄コード - 税管轄コード (String)
CTRL_KEY 調達における品質管理の管理キー (String)
CONF_CTRL 確認管理キー (String)
REV_LEV 改訂レベル (String)
FUND 会計区分 (String)
FUNDS_CTR 予算センタ (String)
CMMT_ITEM 資金予算コード (String)
PRICEDATE 価格設定日カテゴリ (価格設定日管理) (String)
PRICE_DATE 価格設定日 (String)
GROSS_WT 総重量 (String)
VOLUME 容積 (String)
VOLUMEUNIT 容積単位 (String)
VOLUMEUNIT_ISO ISO コードでの容積単位 (String)
INCOTERMS1 インコタームズ (1) (String)
INCOTERMS2 インコタームズ 2 (String)
PRE_VENDOR 製造元/販売元 (String)
VEND_PART 仕入先部門 (String)
HL_ITEM 購買伝票中の上位明細 (String)
GR_TO_DATE 納入最終期限 (String)
SUPP_VENDOR 供給仕入先/仕入入庫 (String)
SC_VENDOR 外注仕入先 (String)
KANBAN_IND かんばん区分 (String)
ERS ERS（入庫/請求自動決済） (String)
R_PROMO プロモーション (String)
POINTS リベートポイント数 (String)
POINT_UNIT ポイント単位 (String)
POINT_UNIT_ISO ポイント単位の ISO コード (String)
SEASON 季節カテゴリ (String)
SEASON_YR シーズン年度 (String)
BON_GRP2 決済グループ 2 (リベート決済、購買) (String)
BON_GRP3 決済グループ 3 (リベート決済、購買) (String)
SETT_ITEM リベート (期末) 決済対象の明細 (String)
MINREMLIFE 最低有効期間残 (String)
RFQ_NO 見積依頼番号 (String)
RFQ_ITEM 見積依頼明細番号 (String)
PREQ_NO 購買依頼番号 (String)
PREQ_ITEM 購買依頼の明細番号 (String)
REF_DOC 参照伝票番号 (String)
REF_ITEM 参照伝票の明細 (String)
SI_CAT 補助明細カテゴリ、購買伝票 (String)
RET_ITEM 返品明細 (String)
AT_RELEV 割当テーブル関連 (String)
ORDER_REASON 発注理由 (String)
BRAS_NBM Brazilian NCM Code (String)
MATL_USAGE 品目の用途 (String)
MAT_ORIGIN 品目の原産地 (String)
IN_HOUSE 内部生産 (String)
INDUS3 品目 CFOP カテゴリ (String)
INF_INDEX インフレーション指数 (String)
UNTIL_DATE インフレーション指数日付 (String)
DELIV_COMPL 出荷完了 区分 (String)
PART_DELIV 明細レベルでの分割納入 (在庫転送) (String)
SHIP_BLOCKED SD 出荷伝票の明細ブロック (String)
PREQ_NAME 購買依頼者名/要求者名 (String)
PERIOD_IND_EXPIRATION_DATE 有効期間期限日の期間区分 (String)
INT_OBJ_NO 選定 (内部オブジェクト番号) (String)
PCKG_NO パッケージ番号 (String)
BATCH ロット番号 (String)
VENDRBATCH 仕入先ロット番号 (String)
CALCTYPE 価格設定タイプ (String)
GRANT_NBR 補助金 (String)
CMMT_ITEM_LONG 資金予算コード (String)
FUNC_AREA_LONG 機能領域 (String)
NO_ROUNDING 区分：購買発注明細での非表示丸め (String)
PO_PRICE 区分：価格採用：1 = 総額、2 = 正味額 (String)
SUPPL_STLOC 出庫保管場所：在庫転送オーダー (String)
SRV_BASED_IV サービス基準請求書照合の区分 (String)
FUNDS_RES 予算執行伝票の伝票番号 (String)
RES_ITEM 用途指定予算: 伝票明細 (String)
ORIG_ACCEPT 仕入先構内での受領 (String)
ALLOC_TBL 商品配分表番号 (String)
ALLOC_TBL_ITEM 割当テーブルの明細番号 (String)
SRC_STOCK_TYPE 在庫転送オーダーの元保管場所在庫タイプ (String)
REASON_REJ 見積および受注の拒否理由 (String)
CRM_SALES_ORDER_NO 仕入先直送発注処理の CRM 受注番号 (String)
CRM_SALES_ORDER_ITEM_NO 仕入先直送発注処理での CRM 受注明細番号 (String)
CRM_REF_SALES_ORDER_NO 仕入先直送発注処理の CRM 参照受注番号 (String)
CRM_REF_SO_ITEM_NO 仕入先直送発注処理での CRM 参照受注明細番号 (String)
PRIO_URGENCY 所要量の緊急度 (String)
PRIO_REQUIREMENT 所要量の優先順位 (String)
REASON_CODE Goods Receipt Reason Code (String)

取得した明細情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の明細の「購買伝票の明細番号」
[idx]["DELETE_IND"]　→　配列内のidx番目の明細の「購買伝票の削除フラグ」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の明細の「テキスト (短)」
[idx]["MATERIAL"]　→　配列内のidx番目の明細の「品目コード」
[idx]["MATERIAL_EXTERNAL"] 　→　配列内のidx番目の明細の「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["MATERIAL_GUID"] 　→　配列内のidx番目の明細の「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["MATERIAL_VERSION"] 　→　配列内のidx番目の明細の「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」
[idx]["EMATERIAL"]　→　配列内のidx番目の明細の「品目コード」
[idx]["EMATERIAL_EXTERNAL"] 　→　配列内のidx番目の明細の「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["EMATERIAL_GUID"] 　→　配列内のidx番目の明細の「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["EMATERIAL_VERSION"] 　→　配列内のidx番目の明細の「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」
[idx]["PLANT"]　→　配列内のidx番目の明細の「プラント」
[idx]["STGE_LOC"]　→　配列内のidx番目の明細の「保管場所」
[idx]["TRACKINGNO"]　→　配列内のidx番目の明細の「購買依頼追跡番号」
[idx]["MATL_GROUP"]　→　配列内のidx番目の明細の「品目グループ」
[idx]["INFO_REC"]　→　配列内のidx番目の明細の「購買情報番号」
[idx]["VEND_MAT"]　→　配列内のidx番目の明細の「仕入先が使用している品目コード」
[idx]["QUANTITY"]　→　配列内のidx番目の明細の「購買発注数量」
[idx]["PO_UNIT"]　→　配列内のidx番目の明細の「発注単位」
[idx]["PO_UNIT_ISO"]　→　配列内のidx番目の明細の「ISO コードによる発注単位」
[idx]["ORDERPR_UN"]　→　配列内のidx番目の明細の「購買発注価格単位 (購買管理)」
[idx]["ORDERPR_UN_ISO"]　→　配列内のidx番目の明細の「購買発注価格単位の ISO コード」
[idx]["CONV_NUM1"]　→　配列内のidx番目の明細の「購買価格単位から購買発注単位への変換分子」
[idx]["CONV_DEN1"]　→　配列内のidx番目の明細の「購買価格単位から購買発注単位への変換分母」
[idx]["NET_PRICE"]　→　配列内のidx番目の明細の「BAPI の通貨額 (小数点以下９桁)」
[idx]["PRICE_UNIT"]　→　配列内のidx番目の明細の「価格単位」
[idx]["GR_PR_TIME"]　→　配列内のidx番目の明細の「入庫処理日数」
[idx]["TAX_CODE"]　→　配列内のidx番目の明細の「消費税コード」
[idx]["BON_GRP1"]　→　配列内のidx番目の明細の「決済グループ 1（購買）」
[idx]["QUAL_INSP"]　→　配列内のidx番目の明細の「在庫タイプ」
[idx]["INFO_UPD"]　→　配列内のidx番目の明細の「区分：購買情報更新」
[idx]["PRNT_PRICE"]　→　配列内のidx番目の明細の「価格印刷」
[idx]["EST_PRICE"]　→　配列内のidx番目の明細の「区分：概算価格」
[idx]["REMINDER1"]　→　配列内のidx番目の明細の「第一回催促状/督促状の日数」
[idx]["REMINDER2"]　→　配列内のidx番目の明細の「第二回催促状/督促状の日数」
[idx]["REMINDER3"]　→　配列内のidx番目の明細の「第三回催促状/督促状の日数」
[idx]["OVER_DLV_TOL"]　→　配列内のidx番目の明細の「過剰納入許容範囲」
[idx]["UNLIMITED_DLV"]　→　配列内のidx番目の明細の「区分：無制限過剰納入可能」
[idx]["UNDER_DLV_TOL"]　→　配列内のidx番目の明細の「不足納入許容範囲リミット」
[idx]["VAL_TYPE"]　→　配列内のidx番目の明細の「評価タイプ」
[idx]["NO_MORE_GR"]　→　配列内のidx番目の明細の「納入完了 区分」
[idx]["FINAL_INV"]　→　配列内のidx番目の明細の「請求書処理完了区分」
[idx]["ITEM_CAT"]　→　配列内のidx番目の明細の「購買伝票の明細カテゴリ」
[idx]["ACCTASSCAT"]　→　配列内のidx番目の明細の「勘定設定カテゴリ」
[idx]["DISTRIB"]　→　配列内のidx番目の明細の「複数勘定設定の配賦区分」
[idx]["PART_INV"]　→　配列内のidx番目の明細の「一部請求区分」
[idx]["GR_IND"]　→　配列内のidx番目の明細の「入庫区分」
[idx]["GR_NON_VAL"]　→　配列内のidx番目の明細の「非評価入庫」
[idx]["IR_IND"]　→　配列内のidx番目の明細の「請求書受領区分」
[idx]["FREE_ITEM"]　→　配列内のidx番目の明細の「無償明細」
[idx]["GR_BASEDIV"]　→　配列内のidx番目の明細の「区分：入庫基準の請求書照合」
[idx]["ACKN_REQD"]　→　配列内のidx番目の明細の「購買発注請書依頼」
[idx]["ACKNOWL_NO"]　→　配列内のidx番目の明細の「購買発注請書番号」
[idx]["AGREEMENT"]　→　配列内のidx番目の明細の「購買契約番号」
[idx]["AGMT_ITEM"]　→　配列内のidx番目の明細の「購買契約の明細番号」
[idx]["SHIPPING"]　→　配列内のidx番目の明細の「出荷指示」
[idx]["CUSTOMER"]　→　配列内のidx番目の明細の「得意先」
[idx]["COND_GROUP"]　→　配列内のidx番目の明細の「仕入先条件グループ」
[idx]["NO_DISCT"]　→　配列内のidx番目の明細の「現金値引対象外明細」
[idx]["PLAN_DEL"]　→　配列内のidx番目の明細の「予定納入日数」
[idx]["NET_WEIGHT"]　→　配列内のidx番目の明細の「正味重量」
[idx]["WEIGHTUNIT"]　→　配列内のidx番目の明細の「重量単位」
[idx]["WEIGHTUNIT_ISO"]　→　配列内のidx番目の明細の「重量単位の ISO コード」
[idx]["TAXJURCODE"]　→　配列内のidx番目の明細の「税計算管轄コード - 税管轄コード」
[idx]["CTRL_KEY"]　→　配列内のidx番目の明細の「調達における品質管理の管理キー」
[idx]["CONF_CTRL"]　→　配列内のidx番目の明細の「確認管理キー」
[idx]["REV_LEV"]　→　配列内のidx番目の明細の「改訂レベル」
[idx]["FUND"]　→　配列内のidx番目の明細の「会計区分」
[idx]["FUNDS_CTR"]　→　配列内のidx番目の明細の「予算センタ」
[idx]["CMMT_ITEM"]　→　配列内のidx番目の明細の「資金予算コード」
[idx]["PRICEDATE"]　→　配列内のidx番目の明細の「価格設定日カテゴリ (価格設定日管理)」
[idx]["PRICE_DATE"]　→　配列内のidx番目の明細の「価格設定日」
[idx]["GROSS_WT"]　→　配列内のidx番目の明細の「総重量」
[idx]["VOLUME"]　→　配列内のidx番目の明細の「容積」
[idx]["VOLUMEUNIT"]　→　配列内のidx番目の明細の「容積単位」
[idx]["VOLUMEUNIT_ISO"]　→　配列内のidx番目の明細の「ISO コードでの容積単位」
[idx]["INCOTERMS1"]　→　配列内のidx番目の明細の「インコタームズ (1)」
[idx]["INCOTERMS2"]　→　配列内のidx番目の明細の「インコタームズ 2」
[idx]["PRE_VENDOR"]　→　配列内のidx番目の明細の「製造元/販売元」
[idx]["VEND_PART"]　→　配列内のidx番目の明細の「仕入先部門」
[idx]["HL_ITEM"]　→　配列内のidx番目の明細の「購買伝票中の上位明細」
[idx]["GR_TO_DATE"]　→　配列内のidx番目の明細の「納入最終期限」
[idx]["SUPP_VENDOR"]　→　配列内のidx番目の明細の「供給仕入先/仕入入庫」
[idx]["SC_VENDOR"]　→　配列内のidx番目の明細の「外注仕入先」
[idx]["KANBAN_IND"]　→　配列内のidx番目の明細の「かんばん区分」
[idx]["ERS"]　→　配列内のidx番目の明細の「ERS（入庫/請求自動決済）」
[idx]["R_PROMO"]　→　配列内のidx番目の明細の「プロモーション」
[idx]["POINTS"]　→　配列内のidx番目の明細の「リベートポイント数」
[idx]["POINT_UNIT"]　→　配列内のidx番目の明細の「ポイント単位」
[idx]["POINT_UNIT_ISO"]　→　配列内のidx番目の明細の「ポイント単位の ISO コード」
[idx]["SEASON"]　→　配列内のidx番目の明細の「季節カテゴリ」
[idx]["SEASON_YR"]　→　配列内のidx番目の明細の「シーズン年度」
[idx]["BON_GRP2"]　→　配列内のidx番目の明細の「決済グループ 2 (リベート決済、購買)」
[idx]["BON_GRP3"]　→　配列内のidx番目の明細の「決済グループ 3 (リベート決済、購買)」
[idx]["SETT_ITEM"]　→　配列内のidx番目の明細の「リベート (期末) 決済対象の明細」
[idx]["MINREMLIFE"]　→　配列内のidx番目の明細の「最低有効期間残」
[idx]["RFQ_NO"]　→　配列内のidx番目の明細の「見積依頼番号」
[idx]["RFQ_ITEM"]　→　配列内のidx番目の明細の「見積依頼明細番号」
[idx]["PREQ_NO"]　→　配列内のidx番目の明細の「購買依頼番号」
[idx]["PREQ_ITEM"]　→　配列内のidx番目の明細の「購買依頼の明細番号」
[idx]["REF_DOC"]　→　配列内のidx番目の明細の「参照伝票番号」
[idx]["REF_ITEM"]　→　配列内のidx番目の明細の「参照伝票の明細」
[idx]["SI_CAT"]　→　配列内のidx番目の明細の「補助明細カテゴリ、購買伝票」
[idx]["RET_ITEM"]　→　配列内のidx番目の明細の「返品明細」
[idx]["AT_RELEV"]　→　配列内のidx番目の明細の「割当テーブル関連」
[idx]["ORDER_REASON"]　→　配列内のidx番目の明細の「発注理由」
[idx]["BRAS_NBM"]　→　配列内のidx番目の明細の「Brazilian NCM Code」
[idx]["MATL_USAGE"]　→　配列内のidx番目の明細の「品目の用途」
[idx]["MAT_ORIGIN"]　→　配列内のidx番目の明細の「品目の原産地」
[idx]["IN_HOUSE"]　→　配列内のidx番目の明細の「内部生産」
[idx]["INDUS3"]　→　配列内のidx番目の明細の「品目 CFOP カテゴリ」
[idx]["INF_INDEX"]　→　配列内のidx番目の明細の「インフレーション指数」
[idx]["UNTIL_DATE"]　→　配列内のidx番目の明細の「インフレーション指数日付」
[idx]["DELIV_COMPL"]　→　配列内のidx番目の明細の「出荷完了 区分」
[idx]["PART_DELIV"]　→　配列内のidx番目の明細の「明細レベルでの分割納入 (在庫転送)」
[idx]["SHIP_BLOCKED"]　→　配列内のidx番目の明細の「SD 出荷伝票の明細ブロック」
[idx]["PREQ_NAME"]　→　配列内のidx番目の明細の「購買依頼者名/要求者名」
[idx]["PERIOD_IND_EXPIRATION_DATE"] 　→　配列内のidx番目の明細の「有効期間期限日の期間区分」
[idx]["INT_OBJ_NO"]　→　配列内のidx番目の明細の「選定 (内部オブジェクト番号)」
[idx]["PCKG_NO"]　→　配列内のidx番目の明細の「パッケージ番号」
[idx]["BATCH"]　→　配列内のidx番目の明細の「ロット番号」
[idx]["VENDRBATCH"]　→　配列内のidx番目の明細の「仕入先ロット番号」
[idx]["CALCTYPE"]　→　配列内のidx番目の明細の「価格設定タイプ」
[idx]["GRANT_NBR"]　→　配列内のidx番目の明細の「補助金」
[idx]["CMMT_ITEM_LONG"]　→　配列内のidx番目の明細の「資金予算コード」
[idx]["FUNC_AREA_LONG"]　→　配列内のidx番目の明細の「機能領域」
[idx]["NO_ROUNDING"]　→　配列内のidx番目の明細の「区分：購買発注明細での非表示丸め」
[idx]["PO_PRICE"]　→　配列内のidx番目の明細の「区分：価格採用：1 = 総額、2 = 正味額」
[idx]["SUPPL_STLOC"]　→　配列内のidx番目の明細の「出庫保管場所：在庫転送オーダー」
[idx]["SRV_BASED_IV"]　→　配列内のidx番目の明細の「サービス基準請求書照合の区分」
[idx]["FUNDS_RES"]　→　配列内のidx番目の明細の「予算執行伝票の伝票番号」
[idx]["RES_ITEM"]　→　配列内のidx番目の明細の「用途指定予算: 伝票明細」
[idx]["ORIG_ACCEPT"]　→　配列内のidx番目の明細の「仕入先構内での受領」
[idx]["ALLOC_TBL"]　→　配列内のidx番目の明細の「商品配分表番号」
[idx]["ALLOC_TBL_ITEM"]　→　配列内のidx番目の明細の「割当テーブルの明細番号」
[idx]["SRC_STOCK_TYPE"]　→　配列内のidx番目の明細の「在庫転送オーダーの元保管場所在庫タイプ」
[idx]["REASON_REJ"]　→　配列内のidx番目の明細の「見積および受注の拒否理由」
[idx]["CRM_SALES_ORDER_NO"]　→　配列内のidx番目の明細の「仕入先直送発注処理の CRM 受注番号」
[idx]["CRM_SALES_ORDER_ITEM_NO"]　→　配列内のidx番目の明細の「仕入先直送発注処理での CRM 受注明細番号」
[idx]["CRM_REF_SALES_ORDER_NO"]　→　配列内のidx番目の明細の「仕入先直送発注処理の CRM 参照受注番号」
[idx]["CRM_REF_SO_ITEM_NO"]　→　配列内のidx番目の明細の「仕入先直送発注処理での CRM 参照受注明細番号」
[idx]["PRIO_URGENCY"]　→　配列内のidx番目の明細の「所要量の緊急度」
[idx]["PRIO_REQUIREMENT"]　→　配列内のidx番目の明細の「所要量の優先順位」
[idx]["REASON_CODE"]　→　配列内のidx番目の明細の「Goods Receipt Reason Code」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPurchaseScheduleList

Object getPurchaseScheduleList ()

納入日程一覧を取得します｡
返却値
Object 納入日程一覧

納入日程情報オブジェクトの構成は以下のとおりです。
納入日程情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号 (String)
SCHED_LINE 納入日程行 (String)
DEL_DATCAT_EXT 納入期日カテゴリ (String)
DELIVERY_DATE 納入期日 (String)
QUANTITY 計画数量 (String)
DELIV_TIME 納入期日における指定時間 (String)
STAT_DATE 統計的納入期日 (String)
PREQ_NO 購買依頼番号 (String)
PREQ_ITEM 購買依頼の明細番号 (String)
PO_DATE 納入日程の購買発注日付 (String)
ROUTESCHED 輸送経路計画 (String)
MS_DATE 品目利用可能日 (String)
MS_TIME 品目供給ステージ (現地時刻：プラント参照) (String)
LOAD_DATE 積載日付 (String)
LOAD_TIME 積載時刻 (現地時間：出荷ポイント) (String)
TP_DATE 輸送計画日付 (String)
TP_TIME 輸送計画 - 時間 (現地時間/出荷ポイント参照) (String)
GI_DATE 出庫日付 (String)
GI_TIME 出庫時刻 (現地時間 - プラント参照) (String)
DELETE_IND 購買伝票の削除フラグ (String)
REQ_CLOSED 購買依頼処理済 (String)
GR_END_DATE 入庫終了日付 (String)
GR_END_TIME 入庫終了時刻 (ローカル、プラントに関連) (String)
COM_QTY 確認数量 (String)
COM_DATE 確認日 (String)

取得した納入日程情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の納入日程の「購買伝票の明細番号」
[idx]["SCHED_LINE"]　→　配列内のidx番目の納入日程の「納入日程行」
[idx]["DEL_DATCAT_EXT"]　→　配列内のidx番目の納入日程の「納入期日カテゴリ」
[idx]["DELIVERY_DATE"]　→　配列内のidx番目の納入日程の「納入期日」
[idx]["QUANTITY"]　→　配列内のidx番目の納入日程の「計画数量」
[idx]["DELIV_TIME"]　→　配列内のidx番目の納入日程の「納入期日における指定時間」
[idx]["STAT_DATE"]　→　配列内のidx番目の納入日程の「統計的納入期日」
[idx]["PREQ_NO"]　→　配列内のidx番目の納入日程の「購買依頼番号」
[idx]["PREQ_ITEM"]　→　配列内のidx番目の納入日程の「購買依頼の明細番号」
[idx]["PO_DATE"]　→　配列内のidx番目の納入日程の「納入日程の購買発注日付」
[idx]["ROUTESCHED"]　→　配列内のidx番目の納入日程の「輸送経路計画」
[idx]["MS_DATE"]　→　配列内のidx番目の納入日程の「品目利用可能日」
[idx]["MS_TIME"]　→　配列内のidx番目の納入日程の「品目供給ステージ (現地時刻：プラント参照)」
[idx]["LOAD_DATE"]　→　配列内のidx番目の納入日程の「積載日付」
[idx]["LOAD_TIME"]　→　配列内のidx番目の納入日程の「積載時刻 (現地時間：出荷ポイント)」
[idx]["TP_DATE"]　→　配列内のidx番目の納入日程の「輸送計画日付」
[idx]["TP_TIME"] 　→　配列内のidx番目の納入日程の「輸送計画 - 時間 (現地時間/出荷ポイント参照)」
[idx]["GI_DATE"]　→　配列内のidx番目の納入日程の「出庫日付」
[idx]["GI_TIME"]　→　配列内のidx番目の納入日程の「出庫時刻 (現地時間 - プラント参照)」
[idx]["DELETE_IND"]　→　配列内のidx番目の納入日程の「購買伝票の削除フラグ」
[idx]["REQ_CLOSED"]　→　配列内のidx番目の納入日程の「購買依頼処理済」
[idx]["GR_END_DATE"]　→　配列内のidx番目の納入日程の「入庫終了日付」
[idx]["GR_END_TIME"]　→　配列内のidx番目の納入日程の「入庫終了時刻 (ローカル、プラントに関連)」
[idx]["COM_QTY"]　→　配列内のidx番目の納入日程の「確認数量」
[idx]["COM_DATE"]　→　配列内のidx番目の納入日程の「確認日」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPurchaseShippingExpList

Object getPurchaseShippingExpList ()

出荷データエクスポート一覧を取得します｡
返却値
Object 出荷データエクスポート一覧

出荷データエクスポート情報オブジェクトの構成は以下のとおりです。
出荷データエクスポート情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号
SHIP_POINT 出荷ポイント/入荷ポイント
DLV_PRIO 出荷優先順位
DLV_PRIO 出荷優先順位
ROUTE 輸送経路
CUSTOMER 得意先コード 1
SOLD_TO 受注先
FWDAGENT 海貨業者
SALESORG 販売組織
DISTR_CHAN 流通チャネル
DIVISION 製品部門
DEL_CREATE_DATE 出荷登録日付
PLND_DELRY 予定納入時間 (単位: 日)
LANGU 言語キー
LANGU_ISO 言語キーの ISO コード
SHIP_COND 出荷条件
LOADINGGRP 積載グループ
TRANS_GRP 輸送グループ
UNLOAD_PT 荷渡ポイント
ORDCOMBIND 受注結合区分
TIME_ZONE 出荷場所のタイムゾーン
AUTH_NUMBER 返品権限番号
SRC_DLV_NO 元出荷番号
SRC_HANDLG_UNIT 元/先 荷役単位 (外部 ID)
INSPOUT_GUID 品質検査結果： EWM 設定の在庫 GUID
FOLLOW_UP デフォルト後続アクティビティコード

取得した出荷データエクスポート情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の出荷データの「購買伝票の明細番号」
[idx]["SHIP_POINT"]　→　配列内のidx番目の出荷データの「出荷ポイント/入荷ポイント」
[idx]["SHIP_COND"]　→　配列内のidx番目の出荷データの「出荷条件」
[idx]["DLV_PRIO"]　→　配列内のidx番目の出荷データの「出荷優先順位」
[idx]["ROUTE"]　→　配列内のidx番目の出荷データの「輸送経路」
[idx]["CUSTOMER"]　→　配列内のidx番目の出荷データの「得意先コード 1」
[idx]["SOLD_TO"]　→　配列内のidx番目の出荷データの「受注先」
[idx]["FWDAGENT"]　→　配列内のidx番目の出荷データの「海貨業者」
[idx]["SALESORG"]　→　配列内のidx番目の出荷データの「販売組織」
[idx]["DISTR_CHAN"]　→　配列内のidx番目の出荷データの「流通チャネル」
[idx]["DIVISION"]　→　配列内のidx番目の出荷データの「製品部門」
[idx]["DEL_CREATE_DATE"]　→　配列内のidx番目の出荷データの「出荷登録日付」
[idx]["PLND_DELRY"]　→　配列内のidx番目の出荷データの「予定納入時間 (単位: 日)」
[idx]["LANGU"]　→　配列内のidx番目の出荷データの「言語キー」
[idx]["LANGU_ISO"]　→　配列内のidx番目の出荷データの「言語キーの ISO コード」
[idx]["LOADINGGRP"]　→　配列内のidx番目の出荷データの「積載グループ」
[idx]["TRANS_GRP"]　→　配列内のidx番目の出荷データの「輸送グループ」
[idx]["UNLOAD_PT"]　→　配列内のidx番目の出荷データの「荷渡ポイント」
[idx]["ORDCOMBIND"]　→　配列内のidx番目の出荷データの「受注結合区分」
[idx]["TIME_ZONE"]　→　配列内のidx番目の出荷データの「出荷場所のタイムゾーン」
[idx]["AUTH_NUMBER"]　→　配列内のidx番目の出荷データの「返品権限番号」
[idx]["SRC_DLV_NO"]　→　配列内のidx番目の出荷データの「元出荷番号」
[idx]["SRC_HANDLG_UNIT"] 　→　配列内のidx番目の出荷データの「元/先 荷役単位 (外部 ID)」
[idx]["INSPOUT_GUID"] 　→　配列内のidx番目の出荷データの「品質検査結果： EWM 設定の在庫 GUID」
[idx]["FOLLOW_UP"] 　→　配列内のidx番目の出荷データの「デフォルト後続アクティビティコード」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPurchaseShippingList

Object getPurchaseShippingList ()

出荷データ一覧を取得します｡
返却値
Object 出荷データ一覧

出荷データ情報オブジェクトの構成は以下のとおりです。
出荷データ情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号
SHIP_POINT 出荷ポイント/入荷ポイント
SHIP_COND 出荷条件
DLV_PRIO 出荷優先順位
ROUTE 輸送経路
UNLOAD_PT 荷渡ポイント
AUTH_NUMBER 返品権限番号
SRC_DLV_NO 元出荷番号
SRC_HANDLG_UNIT 元/先 荷役単位 (外部 ID)
INSPOUT_GUID 品質検査結果： EWM 設定の在庫 GUID
FOLLOW_UP デフォルト後続アクティビティコード

取得した出荷データ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の出荷データの「購買伝票の明細番号」
[idx]["SHIP_POINT"]　→　配列内のidx番目の出荷データの「出荷ポイント/入荷ポイント」
[idx]["SHIP_COND"]　→　配列内のidx番目の出荷データの「出荷条件」
[idx]["DLV_PRIO"]　→　配列内のidx番目の出荷データの「出荷優先順位」
[idx]["ROUTE"]　→　配列内のidx番目の出荷データの「輸送経路」
[idx]["UNLOAD_PT"]　→　配列内のidx番目の出荷データの「荷渡ポイント」
[idx]["AUTH_NUMBER"]　→　配列内のidx番目の出荷データの「返品権限番号」
[idx]["SRC_DLV_NO"]　→　配列内のidx番目の出荷データの「元出荷番号」
[idx]["SRC_HANDLG_UNIT"] 　→　配列内のidx番目の出荷データの「元/先 荷役単位 (外部 ID)」
[idx]["INSPOUT_GUID"] 　→　配列内のidx番目の出荷データの「品質検査結果： EWM 設定の在庫 GUID」
[idx]["FOLLOW_UP"]　→　配列内のidx番目の出荷データの「デフォルト後続アクティビティコード」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getSupplierInfo

Object getSupplierInfo ()

仕入先住所を取得します｡
返却値
Object 仕入先住所

仕入先住所情報オブジェクトの構成は以下のとおりです。
仕入先住所情報
オブジェクト
(Object)
PO_NUMBER 購買伝票番号 (String)
ADDR_NO アドレス番号 (String)
FORMOFADDR 敬称テキスト (String)
NAME 名称 1 (String)
NAME_2 名称 2 (String)
NAME_3 名称 3 (String)
NAME_4 名称 4 (String)
C_O_NAME 気付 (String)
CITY 市区町村 (String)
DISTRICT 所在地 (String)
CITY_NO 市区町村/地名ファイルの市区町村コード (String)
POSTL_COD1 市区町村の郵便番号 (String)
POSTL_COD2 私書箱郵便番号 (String)
POSTL_COD3 会社郵便番号 (大規模なユーザ用) (String)
PO_BOX 私書箱 (String)
PO_BOX_CIT 私書箱住所 (String)
DELIV_DIS 郵便配達地域 (String)
STREET 地名 (String)
STREET_NO 市区町村/地名ファイルの地名コード (String)
STR_ABBR 地名の略称 (例：スペイン) (String)
HOUSE_NO 番地-号 (String)
STR_SUPPL1 地名 2 (String)
STR_SUPPL2 地名 3 (String)
LOCATION 地名 5 (String)
BUILDING 旧：建物 (番号または略称) (String)
FLOOR 建物の階 (String)
ROOM_NO 部屋/アパート番号 (String)
COUNTRY 国コード (String)
LANGU 言語キー (String)
REGION 地域 (都道府県) (String)
SORT1 検索条件 1 (String)
SORT2 検索条件 2 (String)
TIME_ZONE アドレスタイムゾーン (String)
TAXJURCODE 税管轄コード (String)
ADR_NOTES 住所注記 (String)
COMM_TYPE 通信方法 (キー) (アドレス管理) (String)
TEL1_NUMBR 第一電話番号：ダイヤルコード + 番号 (String)
TEL1_EXT 第 1 電話番号：内線 (String)
FAX_NUMBER 第一 FAX 番号：ダイヤルコード + 番号 (String)
FAX_EXTENS 第一 FAX 番号：内線 (String)
STREET_LNG 地名 (String)
DISTRCT_NO 市区町村/地名ファイルの所在地コード (String)
CHCKSTATUS 市区町村ファイルテストステータス (String)
PBOXCIT_NO 市区町村私書箱コード (市ファイル) (String)
TRANSPZONE 商品の納入区域 (String)
HOUSE_NO2 番地補足 (String)
E_MAIL 電子メールアドレス (String)
STR_SUPPL3 地名 4 (String)
TITLE タイトル (敬称) (String)
COUNTRYISO ISO 国コード (String)
LANGU_ISO ISO 639 準拠の言語 (String)
BUILD_LONG 建物 (番号またはコード) (String)
REGIOGROUP 地域構造グループ化 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getTestRun

Object getTestRun ()

テスト区分を取得します。

返却値
Object テスト区分
getVersions

Object getVersions ()

バージョン管理を取得します｡
返却値
Object バージョン管理

バージョン管理情報オブジェクトの構成は以下のとおりです。
バージョン管理情報
オブジェクト
(Object)
POST_DATE バージョンの転記日付 (String)
COMPLETED ステータス ""バージョン完了済"" (String)
REASON 変更理由 (String)
DESCRIPTION バージョンテキスト（長） (String)
REQ_BY 変更を依頼した従業員 (String)
REQ_BY_EXT バージョンの外部変更番号 (String)
ACTIVITY 処理タイプ（SAP ERP6.0 では使用されない項目です。）(String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

setMemoryComplete

void setMemoryComplete (String value)

エラーがない場合に購買発注を保留する区分を設定します｡を設定します｡
パラメータ
value String エラーがない場合に購買発注を保留する区分を設定します｡
返却値
void
setMemoryUnComplete

void setMemoryUnComplete (String value)

エラーがある場合に購買発注を保留する区分を設定します｡を設定します｡
パラメータ
value String エラーがある場合に購買発注を保留する区分を設定します｡
返却値
void
setNoAuthority

void setNoAuthority (String value)

権限チェックなし区分を設定します｡を設定します｡
パラメータ
value String 権限チェックなし区分を設定します｡
返却値
void
setNoMessage

void setNoMessage (String value)

出力決定なし区分に購買発注を保留する区分を設定します｡を設定します｡
パラメータ
value String 出力決定なし区分に購買発注を保留する区分を設定します｡
返却値
void
setNoMessageReq

void setNoMessageReq (String value)

メッセージ不要区分を設定します｡を設定します｡
パラメータ
value String メッセージ不要区分を設定します｡
返却値
void
setNoPriceFromPo

void setNoPriceFromPo (String value)

最終伝票からの価格転送なし区分を設定します｡を設定します｡
パラメータ
value String 最終伝票からの価格転送なし区分を設定します｡
返却値
void
setPoNumber

void setPoNumber (String value)

購買伝票番号を設定します｡
パラメータ
value String 購買伝票番号
返却値
void
setStrParam

void setStrParam (String paramStr ,String paramName ,String value)

構造型の項目に値をセットします。
パラメータ
paramStr | String | 構造名
paramName | String | 項目名
value | String | セットする値
返却値
void
setTblParam

void setTblParam (String paramTable ,String paramName ,String value ,int index)

テーブル型の項目に値をセットします。
パラメータ
paramTable | String | テーブル名
paramName | String | 項目名
value | String | セットする値
index | int | レコード番号
返却値
void
setTestRun

void setTestRun (String value)

テスト区分を設定します｡
パラメータ
value String テスト区分
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 PurchaseReleaseController オブジェクト

伝票承認コントローラクラス。

機能は以下の通り
  • 伝票を承認します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
PurchaseReleaseController (String purchaseorder ,String poRelCode ,String useExceptions ,コミットワーク noCommit)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
PurchaseReleaseController (String purchaseorder ,String poRelCode ,String useExceptions ,コミットワーク noCommit)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
PurchaseReleaseController (String purchaseorder ,String poRelCode ,String useExceptions ,コミットワーク noCommit ,ConnectionManager connectionManager)
コンストラクタ。
PurchaseReleaseController (String purchaseorder ,String poRelCode ,String useExceptions ,コミットワーク noCommit ,SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより伝票の承認処理を実行します。
String | getBapiReturnErrMessage () ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage () プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。
Object | getRelIndicatorNew () 伝票承認の新規承認区分を取得します。
Object | getRelStatusNew () 伝票承認の新承認状況を取得します。
Object | getRetCode () リターン値、ABAP 命令後のリターン値を取得します。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
PurchaseReleaseController

PurchaseReleaseController (String purchaseorder ,String poRelCode ,String useExceptions ,コミットワーク noCommit)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
noCommit(コミットワーク)の設定方法は以下のとおりです。
指定しない：コミット処理が実行されます。
「X」を指定：コミット処理が実行されません。
パラメータ
purchaseorder | String | 購買発注番号
poRelCode | String | 承認コード
useExceptions | String | 例外メッセージ設定とエラーメッセージ出力
noCommit | コミットワーク | はい/いいえ
PurchaseReleaseController

PurchaseReleaseController (String purchaseorder ,String poRelCode ,String useExceptions ,コミットワーク noCommit)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。

SapClientを使用することで、任意の接続先のコネクションを取得します。
noCommit(コミットワーク)の設定方法は以下のとおりです。
指定しない：コミット処理が実行されます。
「X」を指定：コミット処理が実行されません。
パラメータ
purchaseorder | String | 購買発注番号
poRelCode | String | 承認コード
useExceptions | String | 例外メッセージ設定とエラーメッセージ出力
noCommit | コミットワーク | はい/いいえ
PurchaseReleaseController

PurchaseReleaseController (String purchaseorder ,String poRelCode ,String useExceptions ,コミットワーク noCommit ,ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の更新処理を実行することができます。
なお、PurchaseReleaseController#executeBapi()実行後に 必ずConnectionManager#commit()またはConnectionManager#rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

【注意】このAPIが使用する標準のBAPI(BAPI_PO_RELEASE)では、BAPI実行時にコミット処理が実行されます。 つまり、PurchaseReleaseController#executeBapi()実行後に ここまでのコネクションマネージャーで実行したすべての処理がコミットされます。
※ただし、コネクションはリリースされませんので、リリースされるようにConnectionManager#commit()または ConnectionManager#rollback()を実行してください。
この振る舞いを変更するには、BAPI自体をカスタマイズする必要があります。

noCommit(コミットワーク)の設定方法は以下のとおりです。
指定しない：コミット処理が実行されます。
「X」を指定：コミット処理が実行されません。
パラメータ
purchaseorder | String | 購買発注番号
poRelCode | String | 承認コード
useExceptions | String | 例外メッセージ設定とエラーメッセージ出力
noCommit | コミットワーク | はい/いいえ
connectionManager | ConnectionManager | コネクションマネージャー
PurchaseReleaseController

PurchaseReleaseController (String purchaseorder ,String poRelCode ,String useExceptions ,コミットワーク noCommit ,SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
noCommit(コミットワーク)の設定方法は以下のとおりです。
指定しない：コミット処理が実行されます。
「X」を指定：コミット処理が実行されません。
パラメータ
purchaseorder | String | 購買発注番号
poRelCode | String | 承認コード
useExceptions | String | 例外メッセージ設定とエラーメッセージ出力
noCommit | コミットワーク | はい/いいえ
sapClient | SapClient | Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより伝票の承認処理を実行します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getBapiReturnErrMessage

String getBapiReturnErrMessage ()

ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡
返却値
String BAPI実行結果エラーとなった全てのメッセージ情報
getBapiReturnMessage

String getBapiReturnMessage ()

プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡
返却値
String プロパティファイルでオートコミット条件に一致したType情報のメッセージ情報
getRelIndicatorNew

Object getRelIndicatorNew ()

伝票承認の新規承認区分を取得します。

返却値
Object 新規承認区分
getRelStatusNew

Object getRelStatusNew ()

伝票承認の新承認状況を取得します。

返却値
Object 新承認状況
getRetCode

Object getRetCode ()

リターン値、ABAP 命令後のリターン値を取得します。

返却値
Object リターン値、ABAP 命令後のリターン値
(成功時の返却値は String になります。)

(失敗時)　エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1:　認証系システムエラー
2:　認証系アプリケーションエラー
3:　汎用系システムエラー
4:　汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 PurchaseResetReleaseController オブジェクト

伝票承認取消コントローラクラス。

機能は以下の通り
  • 伝票承認取消をします。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
PurchaseResetReleaseController (String purchaseorder ,String poRelCode ,String useExceptions)
コンストラクタ｡
PurchaseResetReleaseController (String purchaseorder ,String poRelCode ,String useExceptions)
コンストラクタ。
PurchaseResetReleaseController (String purchaseorder ,String poRelCode ,String useExceptions ,ConnectionManager connectionManager)
コンストラクタ。
PurchaseResetReleaseController (String purchaseorder ,String poRelCode ,String useExceptions ,SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより伝票の承認取消処理を実行します。
String | getBapiReturnErrMessage () ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage () プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。
Object | getRelIndicatorNew () 伝票承認取消の前回承認区分に値を取得します。
Object | getRelStatusNew () 伝票承認取消の前回承認状況に値を取得します。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
PurchaseResetReleaseController

PurchaseResetReleaseController (String purchaseorder ,String poRelCode ,String useExceptions)
コンストラクタ｡
パラメータ
purchaseorder | String | 購買発注番号
poRelCode | String | 承認コード
useExceptions | String | 例外メッセージ設定とエラーメッセージ出力
PurchaseResetReleaseController

PurchaseResetReleaseController (String purchaseorder ,String poRelCode ,String useExceptions)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
purchaseorder | String | 購買発注番号
poRelCode | String | 承認コード
useExceptions | String | 例外メッセージ設定とエラーメッセージ出力
PurchaseResetReleaseController

PurchaseResetReleaseController (String purchaseorder ,String poRelCode ,String useExceptions ,ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の更新処理を実行することができます。
なお、PurchaseReleaseController#executeBapi()実行後に 必ずConnectionManager#commit()またはConnectionManager#rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

【注意】このAPIが使用する標準のBAPI(BAPI_PO_RELEASE)では、BAPI実行時にコミット処理が実行されます。 つまり、PurchaseReleaseController#executeBapi()実行後に ここまでのコネクションマネージャーで実行したすべての処理がコミットされます。
※ただし、コネクションはリリースされませんので、リリースされるようにConnectionManager#commit()または ConnectionManager#rollback()を実行してください。
この振る舞いを変更するには、BAPI自体をカスタマイズする必要があります。
パラメータ
purchaseorder | String | 購買発注番号
poRelCode | String | 承認コード
useExceptions | String | 例外メッセージ設定とエラーメッセージ出力
connectionManager | ConnectionManager | コネクションマネージャー
PurchaseResetReleaseController

PurchaseResetReleaseController (String purchaseorder ,String poRelCode ,String useExceptions ,SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
purchaseorder | String | 購買発注番号
poRelCode | String | 承認コード
useExceptions | String | 例外メッセージ設定とエラーメッセージ出力
sapClient | SapClient | Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより伝票の承認取消処理を実行します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getBapiReturnErrMessage

String getBapiReturnErrMessage ()

ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡
返却値
String BAPI実行結果エラーとなった全てのメッセージ情報
getBapiReturnMessage

String getBapiReturnMessage ()

プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡
返却値
String プロパティファイルでオートコミット条件に一致したType情報のメッセージ情報
getRelIndicatorNew

Object getRelIndicatorNew ()

伝票承認取消の前回承認区分に値を取得します。

返却値
Object 前回承認区分
getRelStatusNew

Object getRelStatusNew ()

伝票承認取消の前回承認状況に値を取得します。

返却値
Object 前回承認状況
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 QuotationCreateFromData2Controller オブジェクト

見積伝票登録コントローラクラス。

機能は以下の通り
  • 見積伝票を登録します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
QuotationCreateFromData2Controller ()
コンストラクタ｡
QuotationCreateFromData2Controller (ConnectionManager connectionManager)
コンストラクタ。
QuotationCreateFromData2Controller (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより見積伝票を登録します。
String | getBapiReturnErrMessage () ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage () プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。
Object | getBinaryRelationshiptype () バイナリ関連タイプ (専用)を取得します。
Object | getConvert () 変換: 取引先機能 + 受注伝票タイプを取得します。
Array | getExtensionInList () VBAK、VBAP、VBEP のカスタマ拡張を取得します。
Object | getIntNumberAssignment () 明細番号内部採番を取得します。
Object | getLogicSwitch () 内部制御パラメータを取得します。
Array | getPartnerAddressesList () アドレス (組織/会社) 用 BAPI 参照構造を取得します。
Array | getQuotationCfgsBlobList () 選定: BLOB 内部データ (SCE)を取得します。
Array | getQuotationCfgsInstList () 選定: インスタンスを取得します。
Array | getQuotationCfgsPartOfList () 選定: 部分設定を取得します。
Array | getQuotationCfgsRefInstList () 選定: 参照明細/インスタンスを取得します。
Array | getQuotationCfgsRefList () 選定: 参照データを取得します。
Array | getQuotationCfgsValueList () 選定: 特性値を取得します。
Array | getQuotationCfgsVkList () 選定: バリアント条件キーを取得します。
Array | getQuotationConditionsInList () 条件を取得します。
Array | getQuotationConditionsInXList () 受注における条件更新の通信項目を取得します。
Object | getQuotationHeaderIn () 見積伝票ヘッダデータを取得します。
Object | getQuotationHeaderInX () ヘッダデータチェックボックスを取得します。
Array | getQuotationItemsInList () 明細データを取得します。
Array | getQuotationItemsInXList () 明細データチェックボックスを取得します。
Array | getQuotationKeysList () 参照キーの出力を取得します。
Array | getQuotationPartnersList () 伝票取引先を取得します。
Array | getQuotationSchedulesInList () 納入日程行を取得します。
Array | getQuotationSchedulesInXList () 納入日程行チェックボックスを取得します。
Array | getQuotationTextList () テキストを取得します。
Object | getSalesdocument () 販売管理伝票番号を取得します。
Object | getSalesdocumentin () 販売管理伝票番号を取得します。
Object | getSender () 論理システム - 送信者を取得します。
Object | getTestrun () テスト実行を取得します。
void | setBehaveWhenError (Object value) エラー処理を設定します｡
void | setBinaryRelationshiptype (Object value) バイナリ関連タイプ (専用)を設定します｡
void | setConvert (Object value) 取引先機能/受注伝票タイプの変換を設定します｡
void | setIntNumberAssignment (Object value) 明細番号内部採番を設定します｡
void | setSalesdocumentin (Object value) 見積伝票番号を設定します｡
void | setStrParam (String paramStr ,String paramName ,Object value) 構造型の項目に値をセットします。
void | setTblParam (String paramTable ,String paramName ,Object value ,int index) テーブル型の項目に値をセットします。
void | setTestrun (Object value) テスト実行を設定します｡
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
QuotationCreateFromData2Controller

QuotationCreateFromData2Controller ()
コンストラクタ｡
QuotationCreateFromData2Controller

QuotationCreateFromData2Controller (ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、QuotationCreateFromData2Controller#executeBapi()実行後に必ず ConnectionManager#commit()またはConnectionManager#rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。
パラメータ
connectionManager ConnectionManager コネクションマネージャー
QuotationCreateFromData2Controller

QuotationCreateFromData2Controller (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより見積伝票を登録します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getBapiReturnErrMessage

String getBapiReturnErrMessage ()

ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡
返却値
String BAPI実行結果エラーとなった全てのメッセージ情報
getBapiReturnMessage

String getBapiReturnMessage ()

プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡
返却値
String プロパティファイルでオートコミット条件に一致したType情報のメッセージ情報
getBinaryRelationshiptype

Object getBinaryRelationshiptype ()

バイナリ関連タイプ (専用)を取得します。
返却値
Object バイナリ関連タイプ（専用）
getConvert

Object getConvert ()

変換: 取引先機能 + 受注伝票タイプを取得します。
返却値
Object 変換: 取引先機能 + 受注伝票タイプ
getExtensionInList

Array getExtensionInList ()

VBAK、VBAP、VBEP のカスタマ拡張を取得します。
返却値
Array VBAK、VBAP、VBEP のカスタマ拡張

VBAK、VBAP、VBEP のカスタマ拡張の構成は以下のとおりです。
VBAK、VBAP、VBEP のカスタマ拡張
オブジェクト
(Object)
STRUCTURE BAPI テーブル拡張の構造名 (String)
VALUEPART1 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART2 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART3 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART4 BAPI 拡張パラメータのデータ部分 (String)

VBAK、VBAP、VBEP のカスタマ拡張オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["STRUCTURE"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI テーブル拡張の構造名」
[idx]["VALUEPART1"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART2"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART3"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART4"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI 拡張パラメータのデータ部分」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getIntNumberAssignment

Object getIntNumberAssignment ()

明細番号内部採番を取得します。
返却値
Object 明細番号内部採番
getLogicSwitch

Object getLogicSwitch ()

内部制御パラメータを取得します。
返却値
Object 内部制御パラメータ

内部制御パラメータオブジェクトの構成は以下のとおりです。
内部制御パラメータ
オブジェクト
(Object)
PRICING 価格設定タイプ (String)
ATP_WRKMOD ATP セッション: 結果取得/新規決定 APO-ATP (String)
SCHEDULING 単一文字フラグ (String)
NOSTRUCTURE チェックボックス (String)
COND_HANDL 選択: 条件行処理 (SD 伝票変更) (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPartnerAddressesList

Array getPartnerAddressesList ()

アドレス (組織/会社) 用 BAPI 参照構造を取得します。
返却値
Array アドレス (組織/会社) 用 BAPI 参照構造

アドレス (組織/会社) 用 BAPI 参照構造オブジェクトの構成は以下のとおりです。
アドレス (組織/会社) 用 BAPI 参照構造
オブジェクト
(Object)
ADDR_NO アドレス番号 (String)
FORMOFADDR 敬称テキスト (String)
NAME 名称 1 (String)
NAME_2 名称 2 (String)
NAME_3 名称 3 (String)
NAME_4 名称 4 (String)
C_O_NAME 気付 (String)
CITY 市区町村 (String)
DISTRICT 所在地 (String)
CITY_NO 市区町村/地名ファイルの市区町村コード (String)
POSTL_COD1 市区町村の郵便番号 (String)
POSTL_COD2 私書箱郵便番号 (String)
POSTL_COD3 会社郵便番号 (大規模なユーザ用) (String)
PO_BOX 私書箱 (String)
PO_BOX_CIT 私書箱住所 (String)
DELIV_DIS 郵便配達地域 (String)
STREET 地名 (String)
STREET_NO 市区町村/地名ファイルの地名コード (String)
STR_ABBR 地名の略称 (例: スペイン) (String)
HOUSE_NO 番地-号 (String)
STR_SUPPL1 地名 2 (String)
STR_SUPPL2 地名 3 (String)
LOCATION 地名 5 (String)
BUILDING 旧: 建物 (番号または略称) (String)
FLOOR 建物の階 (String)
ROOM_NO 部屋/アパート番号 (String)
COUNTRY 国コード (String)
LANGU 言語キー (String)
REGION 地域 (都道府県) (String)
SORT1 検索条件 1 (String)
SORT2 検索条件 2 (String)
TIME_ZONE アドレスタイムゾーン (String)
TAXJURCODE 税管轄コード (String)
ADR_NOTES 住所注記 (String)
COMM_TYPE 通信方法 (キー) (アドレス管理) (String)
TEL1_NUMBR 第一電話番号: ダイヤルコード + 番号 (String)
TEL1_EXT 第 1 電話番号: 内線 (String)
FAX_NUMBER 第一 FAX 番号: ダイヤルコード + 番号 (String)
FAX_EXTENS 第一 FAX 番号: 内線 (String)
STREET_LNG 地名 (String)
DISTRCT_NO 市区町村/地名ファイルの所在地コード (String)
CHCKSTATUS 市区町村ファイルテストステータス (String)
PBOXCIT_NO 市区町村私書箱コード (市ファイル) (String)
TRANSPZONE 商品の納入区域 (String)
HOUSE_NO2 番地補足 (String)
E_MAIL 電子メールアドレス (String)
STR_SUPPL3 地名 4 (String)
TITLE タイトル (敬称) (String)
COUNTRYISO ISO 国コード (String)
LANGU_ISO ISO 639 準拠の言語 (String)
BUILD_LONG 建物 (番号またはコード) (String)
REGIOGROUP 地域構造グループ化 (String)
HOME_CITY 市区町村 (郵便用市区町村と異なる場合) (String)
HOMECITYNO 別の市区町村 (市区町村/地名ファイル) (String)
PCODE1_EXT 市区町村郵便番号の拡張子 例: 郵便番号 +4+2 (String)
PCODE2_EXT 私書箱郵便番号拡張子 例: 郵便番号 +4+2 (String)
PCODE3_EXT 主要得意先郵便番号拡張子 例: 郵便番号 +4+2 (String)
PO_W_O_NO フラグ: 郵便私書箱 (番号なし) (String)
PO_BOX_REG 私書箱の地域 (国、都道府県、地域、...) (String)
POBOX_CTRY 私書箱の国指定 (String)
PO_CTRYISO ISO 国コード (String)
HOMEPAGE URI 例: ホームページ、FTP アドレス (String)
DONT_USE_S 地名住所配達不可フラグ (String)
DONT_USE_P 私書箱住所配達不可フラグ (String)
HOUSE_NO3 番地範囲 (String)
LANGU_CR アドレスレコード登録オリジナル言語 (String)
LANGUCRISO ISO 639 準拠の言語 (String)

アドレス (組織/会社) 用 BAPI 参照構造オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ADDR_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「アドレス番号」
[idx]["FORMOFADDR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「敬称テキスト」
[idx]["NAME"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「名称 1」
[idx]["NAME_2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「名称 2」
[idx]["NAME_3"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「名称 3」
[idx]["NAME_4"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「名称 4」
[idx]["C_O_NAME"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「気付」
[idx]["CITY"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「市区町村」
[idx]["DISTRICT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「所在地」
[idx]["CITY_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村/地名ファイルの市区町村コード」
[idx]["POSTL_COD1"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村の郵便番号」
[idx]["POSTL_COD2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱郵便番号」
[idx]["POSTL_COD3"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「会社郵便番号 (大規模なユーザ用)」
[idx]["PO_BOX"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「私書箱」
[idx]["PO_BOX_CIT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱住所」
[idx]["DELIV_DIS"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「郵便配達地域」
[idx]["STREET"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「地名」
[idx]["STREET_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村/地名ファイルの地名コード」
[idx]["STR_ABBR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名の略称 (例: スペイン)」
[idx]["HOUSE_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「番地-号」
[idx]["STR_SUPPL1"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名 2」
[idx]["STR_SUPPL2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名 3」
[idx]["LOCATION"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「地名 5」
[idx]["BUILDING"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「旧: 建物 (番号または略称)」
[idx]["FLOOR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「建物の階」
[idx]["ROOM_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「部屋/アパート番号」
[idx]["COUNTRY"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「国コード」
[idx]["LANGU"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「言語キー」
[idx]["REGION"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地域 (都道府県)」
[idx]["SORT1"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「検索条件 1」
[idx]["SORT2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「検索条件 2」
[idx]["TIME_ZONE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「アドレスタイムゾーン」
[idx]["TAXJURCODE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「税管轄コード」
[idx]["ADR_NOTES"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「住所注記」
[idx]["COMM_TYPE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「通信方法 (キー) (アドレス管理)」
[idx]["TEL1_NUMBR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「第一電話番号: ダイヤルコード + 番号」
[idx]["TEL1_EXT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「第 1 電話番号: 内線」
[idx]["FAX_NUMBER"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「第一 FAX 番号: ダイヤルコード + 番号」
[idx]["FAX_EXTENS"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「第一 FAX 番号: 内線」
[idx]["STREET_LNG"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「地名」
[idx]["DISTRCT_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村/地名ファイルの所在地コード」
[idx]["CHCKSTATUS"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村ファイルテストステータス」
[idx]["PBOXCIT_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村私書箱コード (市ファイル)」
[idx]["TRANSPZONE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「商品の納入区域」
[idx]["HOUSE_NO2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「番地補足」
[idx]["E_MAIL"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「電子メールアドレス」
[idx]["STR_SUPPL3"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名 4」
[idx]["TITLE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「タイトル (敬称)」
[idx]["COUNTRYISO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「ISO 国コード」
[idx]["LANGU_ISO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「ISO 639 準拠の言語」
[idx]["BUILD_LONG"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「建物 (番号またはコード)」
[idx]["REGIOGROUP"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地域構造グループ化」
[idx]["HOME_CITY"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村 (郵便用市区町村と異なる場合)」
[idx]["HOMECITYNO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「別の市区町村 (市区町村/地名ファイル)」
[idx]["PCODE1_EXT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村郵便番号の拡張子 例: 郵便番号 +4+2」
[idx]["PCODE2_EXT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱郵便番号拡張子 例: 郵便番号 +4+2」
[idx]["PCODE3_EXT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「主要得意先郵便番号拡張子 例: 郵便番号 +4+2」
[idx]["PO_W_O_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「フラグ: 郵便私書箱 (番号なし)」
[idx]["PO_BOX_REG"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱の地域 (国、都道府県、地域、...)」
[idx]["POBOX_CTRY"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱の国指定」
[idx]["PO_CTRYISO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「ISO 国コード」
[idx]["HOMEPAGE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「URI 例: ホームページ、FTP アドレス」
[idx]["DONT_USE_S"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名住所配達不可フラグ」
[idx]["DONT_USE_P"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱住所配達不可フラグ」
[idx]["HOUSE_NO3"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「番地範囲」
[idx]["LANGU_CR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「アドレスレコード登録オリジナル言語」
[idx]["LANGUCRISO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「ISO 639 準拠の言語」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationCfgsBlobList

Array getQuotationCfgsBlobList ()

選定: BLOB 内部データ (SCE)を取得します。
返却値
Array 選定: BLOB 内部データ (SCE)

選定: BLOB 内部データ (SCE)オブジェクトの構成は以下のとおりです。
選定: BLOB 内部データ (SCE)
オブジェクト
(Object)
CONFIG_ID 外部選定 ID (仮) (String)
CONTEXT CU: 選定の BLOB. (SCE) (String)

選定: BLOB 内部データ (SCE)オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: BLOB 内部データ (SCE)の 「外部選定 ID (仮)」
[idx]["CONTEXT"]　→　配列内のidx番目の選定: BLOB 内部データ (SCE)の 「CU: 選定の BLOB. (SCE)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationCfgsInstList

Array getQuotationCfgsInstList ()

選定: インスタンスを取得します。
返却値
Array 選定: インスタンス

選定: インスタンスオブジェクトの構成は以下のとおりです。
選定: インスタンス
オブジェクト
(Object)
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)
OBJ_TYPE 対象タイプ (String)
CLASS_TYPE クラスタイプ (String)
OBJ_KEY 対象キー (String)
OBJ_TXT 言語依存対象テキスト (String)
QUANTITY インスタンス数量 (String)
AUTHOR 報告書提案済 (String)
QUANTITY_UNIT 数量単位 (String)
COMPLETE 一般区分 (String)
CONSISTENT 一般区分 (String)
OBJECT_GUID インスタンス用 TYPE_OF ステートメントの GUID (String)
PERSIST_ID インスタンス番号 (固定) (String)
PERSIST_ID_TYPE インスタンス番号タイプ (固定) (String)

選定: インスタンスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: インスタンスの「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の選定: インスタンスの「選定におけるインスタンス番号」
[idx]["OBJ_TYPE"]　→　配列内のidx番目の選定: インスタンスの「対象タイプ」
[idx]["CLASS_TYPE"]　→　配列内のidx番目の選定: インスタンスの「クラスタイプ」
[idx]["OBJ_KEY"]　→　配列内のidx番目の選定: インスタンスの「対象キー」
[idx]["OBJ_TXT"]　→　配列内のidx番目の選定: インスタンスの「言語依存対象テキスト」
[idx]["QUANTITY"]　→　配列内のidx番目の選定: インスタンスの「インスタンス数量」
[idx]["AUTHOR"]　→　配列内のidx番目の選定: インスタンスの「報告書提案済」
[idx]["QUANTITY_UNIT"]　→　配列内のidx番目の選定: インスタンスの「数量単位」
[idx]["COMPLETE"]　→　配列内のidx番目の選定: インスタンスの「一般区分」
[idx]["CONSISTENT"]　→　配列内のidx番目の選定: インスタンスの「一般区分」
[idx]["OBJECT_GUID"]　→　配列内のidx番目の選定: インスタンスの 「インスタンス用 TYPE_OF ステートメントの GUID」
[idx]["PERSIST_ID"]　→　配列内のidx番目の選定: インスタンスの「インスタンス番号 (固定)」
[idx]["PERSIST_ID_TYPE"]　→　配列内のidx番目の選定: インスタンスの 「インスタンス番号タイプ (固定)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationCfgsPartOfList

Array getQuotationCfgsPartOfList ()

選定: 部分設定を取得します。
返却値
Array 選定: 部分設定

選定: 部分設定オブジェクトの構成は以下のとおりです。
引合伝票ヘッダデータ
オブジェクト
(Object)
CONFIG_ID 外部選定 ID (仮) (String)
PARENT_ID 選定におけるインスタンス番号 (String)
INST_ID 選定におけるインスタンス番号 (String)
PART_OF_NO Part_of 明細番号 (String)
OBJ_TYPE 対象タイプ (String)
CLASS_TYPE クラスタイプ (String)
OBJ_KEY 対象キー (String)
AUTHOR 報告書提案済 (String)
SALES_RELEVANT この部品は販売に関連しています (String)
PART_OF_GUID インスタンス用 PART_OF ステートメントの GUID (String)

選定: 部分設定オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: 部分設定の「外部選定 ID (仮)」
[idx]["PARENT_ID"]　→　配列内のidx番目の選定: 部分設定の「選定におけるインスタンス番号」
[idx]["INST_ID"]　→　配列内のidx番目の選定: 部分設定の「選定におけるインスタンス番号」
[idx]["PART_OF_NO"]　→　配列内のidx番目の選定: 部分設定の「Part_of 明細番号」
[idx]["OBJ_TYPE"]　→　配列内のidx番目の選定: 部分設定の「対象タイプ」
[idx]["CLASS_TYPE"]　→　配列内のidx番目の選定: 部分設定の「クラスタイプ」
[idx]["OBJ_KEY"]　→　配列内のidx番目の選定: 部分設定の「対象キー」
[idx]["AUTHOR"]　→　配列内のidx番目の選定: 部分設定の「報告書提案済」
[idx]["SALES_RELEVANT"]　→　配列内のidx番目の選定: 部分設定の 「この部品は販売に関連しています」
[idx]["PART_OF_GUID"]　→　配列内のidx番目の選定: 部分設定の 「インスタンス用 PART_OF ステートメントの GUID」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationCfgsRefInstList

Array getQuotationCfgsRefInstList ()

選定: 参照明細/インスタンスを取得します。
返却値
Array 選定: 参照明細/インスタンス

選定: 参照明細/インスタンスオブジェクトの構成は以下のとおりです。
選定: 参照明細/インスタンス
オブジェクト
(Object)
POSEX 外部明細番号 (String)
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)

選定: 参照明細/インスタンスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["POSEX"]　→　配列内のidx番目の選定: 参照明細/インスタンスの「外部明細番号」
[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: 参照明細/インスタンスの 「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の選定: 参照明細/インスタンスの 「選定におけるインスタンス番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationCfgsRefList

Array getQuotationCfgsRefList ()

選定: 参照データを取得します。
返却値
Array 選定: 参照データ

選定: 参照データオブジェクトの構成は以下のとおりです。
選定: 参照データ
オブジェクト
(Object)
POSEX 外部明細番号 (String)
CONFIGconfig_id 外部選定 ID (仮) (String)
ROOT_Iroot_id 選定におけるインスタンス番号 (String)
SCE scCUX: 選定タイプ (String)
KBNAMEkbname ナレッジベースオブジェクト (String)
KBVERSkbversion SCE ナレッジベースの実行時バージョン (String)
COMPLEcomplete 一般区分 (String)
CONSISconsistent 一般区分 (String)
CFGINFcfginfo CU: 選定の BLOB (SCE) (String)
KBPROFkbprofile ナレッジベースプロファイル (String)
KBLANGkblanguage システム設定の言語 (String)
CBASE_cbase_id インスタンス番号 (固定) (String)
CBASE_cbase_id_type インスタンス番号タイプ (固定) (String)

選定: 参照データオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["POSEX"]　→　配列内のidx番目の選定: 参照データの「外部明細番号」
[idx]["CONFIGconfig_id"]　→　配列内のidx番目の選定: 参照データの 「外部選定 ID (仮)」
[idx]["ROOT_Iroot_id"]　→　配列内のidx番目の選定: 参照データの 「選定におけるインスタンス番号」
[idx]["SCE"]　→　配列内のidx番目の選定: 参照データの「scCUX: 選定タイプ」
[idx]["KBNAMEkbname"]　→　配列内のidx番目の選定: 参照データの「ナレッジベースオブジェクト」
[idx]["KBVERSkbversion"]　→　配列内のidx番目の選定: 参照データの 「SCE ナレッジベースの実行時バージョン」
[idx]["COMPLEcomplete"]　→　配列内のidx番目の選定: 参照データの「一般区分」
[idx]["CONSISconsistent"]　→　配列内のidx番目の選定: 参照データの「一般区分」
[idx]["CFGINFcfginfo"]　→　配列内のidx番目の選定: 参照データの 「CU: 選定の BLOB (SCE)」
[idx]["KBPROFkbprofile"]　→　配列内のidx番目の選定: 参照データの 「ナレッジベースプロファイル」
[idx]["KBLANGkblanguage"]　→　配列内のidx番目の選定: 参照データの「システム設定の言語」
[idx]["CBASE_cbase_id"]　→　配列内のidx番目の選定: 参照データの 「インスタンス番号 (固定)」
[idx]["CBASE_cbase_id_type"]　→　配列内のidx番目の選定: 参照データの 「インスタンス番号タイプ (固定)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationCfgsValueList

Array getQuotationCfgsValueList ()

選定: 特性値を取得します。
返却値
Array 選定: 特性値

選定: 特性値オブジェクトの構成は以下のとおりです。
選定: 特性値
オブジェクト
(Object)
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)
CHARC 特性名 (String)
CHARC_TXT 言語依存特性テキスト (String)
VALUE 特性値 (String)
VALUE_TXT 特性値の言語依存テキスト (String)
AUTHOR 報告書提案済 (String)
VALUE_TO 特性値 (String)
VALCODE 値タイプ: 範囲制限 - 単一値 (String)

選定: 特性値オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: 特性値の「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の選定: 特性値の「選定におけるインスタンス番号」
[idx]["CHARC"]　→　配列内のidx番目の選定: 特性値の「特性名」
[idx]["CHARC_TXT"]　→　配列内のidx番目の選定: 特性値の「言語依存特性テキスト」
[idx]["VALUE"]　→　配列内のidx番目の選定: 特性値の「特性値」
[idx]["VALUE_TXT"]　→　配列内のidx番目の選定: 特性値の「特性値の言語依存テキスト」
[idx]["AUTHOR"]　→　配列内のidx番目の選定: 特性値の「報告書提案済」
[idx]["VALUE_TO"]　→　配列内のidx番目の選定: 特性値の「特性値」
[idx]["VALCODE"]　→　配列内のidx番目の選定: 特性値の「値タイプ: 範囲制限 - 単一値」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationCfgsVkList

Array getQuotationCfgsVkList ()

選定: バリアント条件キーを取得します。
返却値
Array 選定: バリアント条件キー

選定: バリアント条件キーオブジェクトの構成は以下のとおりです。
選定: バリアント条件キー
オブジェクト
(Object)
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)
VKEY バリアント条件名 (String)
FACTOR バリアント条件の加重係数 (String)

選定: バリアント条件キーオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: バリアント条件キーの「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の選定: バリアント条件キーの「選定におけるインスタンス番号」
[idx]["VKEY"]　→　配列内のidx番目の選定: バリアント条件キーの「バリアント条件名」
[idx]["FACTOR"]　→　配列内のidx番目の選定: バリアント条件キーの「バリアント条件の加重係数」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationConditionsInList

Array getQuotationConditionsInList ()

条件を取得します。
返却値
Array 条件

条件オブジェクトの構成は以下のとおりです。
条件
オブジェクト
(Object)
ITM_NUMBER 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件カウンタ (String)
COND_TYPE 条件タイプ (String)
COND_VALUE 条件レート (String)
CURRENCY 通貨コード (String)
COND_UNIT 条件単位 (String)
COND_P_UNT 価格条件単位 (String)
CURR_ISO ISO コード通貨 (String)
CD_UNT_ISO 条件数量単位 (ISO コード) (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)
APPLICATIO アプリケーション (String)
CONPRICDAT 条件価格設定日付 (String)
CALCTYPCON 条件計算タイプ (String)
CONBASEVAL 条件基礎値 (String)
CONEXCHRAT 現地通貨への換算レートに対する条件 (String)
NUMCONVERT 条件単位を基本単位へ変換する分子 (String)
DENOMINATO 条件単位を基本単位へ変換する分母 (String)
CONDTYPE 条件カテゴリ (例: 税、運賃、価格、原価) (String)
STAT_CON 統計に適用する条件 (String)
SCALETYPE スケールタイプ (String)
ACCRUALS 見越額関連条件 (運賃など) (String)
CONINVOLST 請求書一覧条件 (String)
CONDORIGIN 条件生成区分 (String)
GROUPCOND グループ条件区分 (String)
COND_UPDAT 条件更新 (String)
ACCESS_SEQ 検索順序 - 検索番号 (String)
CONDCOUNT 条件連続番号 (String)
ROUNDOFFDI BAPI の通貨額 (小数点以下９桁) (String)
CONDVALUE 条件金額 (String)
CURRENCY_2 販売伝票通貨 (String)
CURR_ISO_2 ISO コード通貨 (String)
CONDCNTRL 条件管理 (String)
CONDISACTI 無効条件 (String)
CONDCLASS 条件クラス (String)
FACTBASVAL 条件基礎値に対する要因 (String)
SCALEBASIN スケール基準区分 (String)
SCALBASVAL 条件のスケール基準値 (String)
UNITMEASUR 条件スケール単位 (String)
ISO_UNIT 単位の ISO コード (String)
CURRENCKEY スケール通貨 (String)
CURRENISO ISO コード通貨 (String)
CONDINCOMP 会社間請求の条件 (String)
CONDCONFIG システム設定の条件 (String)
CONDCHAMAN 条件 (マニュアル変更済) (String)
COND_NO 条件レコード番号 (String)
TAX_CODE 消費税コード (String)
VARCOND バリアント条件 (String)
ACCOUNTKEY 勘定キー (String)
ACCOUNT_KE 勘定キー 見越/引当 (String)
WT_WITHCD 源泉徴収税コード (String)
STRUCTCOND 構造条件 (String)
FACTCONBAS 条件基準の係数 (期間) (String)
CONDCOINHD 条件カウンタ (ヘッダ条件) (String)

条件オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の条件の「条件明細番号」
[idx]["COND_ST_NO"]　→　配列内のidx番目の条件の「ステップ番号」
[idx]["COND_COUNT"]　→　配列内のidx番目の条件の「条件カウンタ」
[idx]["COND_TYPE"]　→　配列内のidx番目の条件の「条件タイプ」
[idx]["COND_VALUE"]　→　配列内のidx番目の条件の「条件レート」
[idx]["CURRENCY"]　→　配列内のidx番目の条件の「通貨コード」
[idx]["COND_UNIT"]　→　配列内のidx番目の条件の「条件単位」
[idx]["COND_P_UNT"]　→　配列内のidx番目の条件の「価格条件単位」
[idx]["CURR_ISO"]　→　配列内のidx番目の条件の「ISO コード通貨」
[idx]["CD_UNT_ISO"]　→　配列内のidx番目の条件の「条件数量単位 (ISO コード)」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の条件の「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の条件の「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の条件の「論理システム」
[idx]["APPLICATIO"]　→　配列内のidx番目の条件の「アプリケーション」
[idx]["CONPRICDAT"]　→　配列内のidx番目の条件の「条件価格設定日付」
[idx]["CALCTYPCON"]　→　配列内のidx番目の条件の「条件計算タイプ」
[idx]["CONBASEVAL"]　→　配列内のidx番目の条件の「条件基礎値」
[idx]["CONEXCHRAT"]　→　配列内のidx番目の条件の「現地通貨への換算レートに対する条件」
[idx]["NUMCONVERT"]　→　配列内のidx番目の条件の「条件単位を基本単位へ変換する分子」
[idx]["DENOMINATO"]　→　配列内のidx番目の条件の「条件単位を基本単位へ変換する分母」
[idx]["CONDTYPE"]　→　配列内のidx番目の条件の「条件カテゴリ (例: 税、運賃、価格、原価)」
[idx]["STAT_CON"]　→　配列内のidx番目の条件の「統計に適用する条件」
[idx]["SCALETYPE"]　→　配列内のidx番目の条件の「スケールタイプ」
[idx]["ACCRUALS"]　→　配列内のidx番目の条件の「見越額関連条件 (運賃など)」
[idx]["CONINVOLST"]　→　配列内のidx番目の条件の「請求書一覧条件」
[idx]["CONDORIGIN"]　→　配列内のidx番目の条件の「条件生成区分」
[idx]["GROUPCOND"]　→　配列内のidx番目の条件の「グループ条件区分」
[idx]["COND_UPDAT"]　→　配列内のidx番目の条件の「条件更新」
[idx]["ACCESS_SEQ"]　→　配列内のidx番目の条件の「検索順序 - 検索番号」
[idx]["CONDCOUNT"]　→　配列内のidx番目の条件の「条件連続番号」
[idx]["ROUNDOFFDI"]　→　配列内のidx番目の条件の「BAPI の通貨額 (小数点以下９桁)」
[idx]["CONDVALUE"]　→　配列内のidx番目の条件の「条件金額」
[idx]["CURRENCY_2"]　→　配列内のidx番目の条件の「販売伝票通貨」
[idx]["CURR_ISO_2"]　→　配列内のidx番目の条件の「ISO コード通貨」
[idx]["CONDCNTRL"]　→　配列内のidx番目の条件の「条件管理」
[idx]["CONDISACTI"]　→　配列内のidx番目の条件の「無効条件」
[idx]["CONDCLASS"]　→　配列内のidx番目の条件の「条件クラス」
[idx]["FACTBASVAL"]　→　配列内のidx番目の条件の「条件基礎値に対する要因」
[idx]["SCALEBASIN"]　→　配列内のidx番目の条件の「スケール基準区分」
[idx]["SCALBASVAL"]　→　配列内のidx番目の条件の「条件のスケール基準値」
[idx]["UNITMEASUR"]　→　配列内のidx番目の条件の「条件スケール単位」
[idx]["ISO_UNIT"]　→　配列内のidx番目の条件の「単位の ISO コード」
[idx]["CURRENCKEY"]　→　配列内のidx番目の条件の「スケール通貨」
[idx]["CURRENISO"]　→　配列内のidx番目の条件の「ISO コード通貨」
[idx]["CONDINCOMP"]　→　配列内のidx番目の条件の「会社間請求の条件」
[idx]["CONDCONFIG"]　→　配列内のidx番目の条件の「システム設定の条件」
[idx]["CONDCHAMAN"]　→　配列内のidx番目の条件の「条件 (マニュアル変更済)」
[idx]["COND_NO"]　→　配列内のidx番目の条件の「条件レコード番号」
[idx]["TAX_CODE"]　→　配列内のidx番目の条件の「消費税コード」
[idx]["VARCOND"]　→　配列内のidx番目の条件の「バリアント条件」
[idx]["ACCOUNTKEY"]　→　配列内のidx番目の条件の「勘定キー」
[idx]["ACCOUNT_KE"]　→　配列内のidx番目の条件の「勘定キー 見越/引当」
[idx]["WT_WITHCD"]　→　配列内のidx番目の条件の「源泉徴収税コード」
[idx]["STRUCTCOND"]　→　配列内のidx番目の条件の「構造条件」
[idx]["FACTCONBAS"]　→　配列内のidx番目の条件の「条件基準の係数 (期間)」
[idx]["CONDCOINHD"]　→　配列内のidx番目の条件の「条件カウンタ (ヘッダ条件)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationConditionsInXList

Array getQuotationConditionsInXList ()

受注における条件更新の通信項目を取得します。
返却値
Array 受注における条件更新の通信項目

受注における条件更新の通信項目オブジェクトの構成は以下のとおりです。
受注における条件更新の通信項目
オブジェクト
(Object)
ITM_NUMBER 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件連続番号 (String)
COND_TYPE 条件タイプ (String)
UPDATEFLAG 更新区分 (String)
COND_VALUE 関連ユーザデータ項目の更新情報 (String)
CURRENCY 関連ユーザデータ項目の更新情報 (String)
COND_UNIT 関連ユーザデータ項目の更新情報 (String)
COND_P_UNT 関連ユーザデータ項目の更新情報 (String)
VARCOND バリアント条件 (String)

受注における条件更新の通信項目オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の受注における条件更新の通信項目の「条件明細番号」
[idx]["COND_ST_NO"]　→　配列内のidx番目の受注における条件更新の通信項目の「ステップ番号」
[idx]["COND_COUNT"]　→　配列内のidx番目の受注における条件更新の通信項目の「条件連続番号」
[idx]["COND_TYPE"]　→　配列内のidx番目の受注における条件更新の通信項目の「条件タイプ」
[idx]["UPDATEFLAG"]　→　配列内のidx番目の受注における条件更新の通信項目の「更新区分」
[idx]["COND_VALUE"]　→　配列内のidx番目の受注における条件更新の通信項目の 「関連ユーザデータ項目の更新情報」
[idx]["CURRENCY"]　→　配列内のidx番目の受注における条件更新の通信項目の 「関連ユーザデータ項目の更新情報」
[idx]["COND_UNIT"]　→　配列内のidx番目の受注における条件更新の通信項目の 「関連ユーザデータ項目の更新情報」
[idx]["COND_P_UNT"]　→　配列内のidx番目の受注における条件更新の通信項目の 「関連ユーザデータ項目の更新情報」
[idx]["VARCOND"]　→　配列内のidx番目の受注における条件更新の通信項目の「バリアント条件」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationHeaderIn

Object getQuotationHeaderIn ()

見積伝票ヘッダデータを取得します。
返却値
Object 見積伝票ヘッダデータ

見積伝票ヘッダデータオブジェクトの構成は以下のとおりです。
見積伝票ヘッダデータ
オブジェクト
(Object)
REFOBJTYPE オブジェクトタイプ(String)
REFOBJKEY オブジェクトキー(String)
REFDOCTYPE 参照オブジェクトの伝票タイプ(String)
DOC_TYPE 販売伝票タイプ(String)
COLLECT_NO 一括番号(String)
SALES_ORG 販売組織(String)
DISTR_CHAN 流通チャネル(String)
DIVISION 製品部門(String)
SALES_GRP 営業グループ(String)
SALES_OFF 営業所(String)
REQ_DATE_H 指定納入期日(String)
DATE_TYPE 提案日付タイプ(String)
PURCH_DATE 得意先発注日付(String)
PO_METHOD 得意先発注タイプ(String)
PO_SUPPLEM 得意先発注番号補足(String)
REF_1 得意先/仕入先の内部参照コード(String)
NAME 発注者名称(String)
TELEPHONE 電話番号(String)
PRICE_GRP 価格グループ (得意先)(String)
CUST_GROUP 得意先グループ(String)
SALES_DIST 販売地域(String)
PRICE_LIST 価格表タイプ(String)
INCOTERMS1 インコタームズ (1)(String)
INCOTERMS2 インコタームズ 2(String)
PMNTTRMS 支払条件キー(String)
DLV_BLOCK 出荷ブロック (伝票ヘッダ)(String)
BILL_BLOCK 販売管理伝票の請求ブロック(String)
ORD_REASON 受注理由 (取引理由)(String)
COMPL_DLV 一括納入区分(String)
PRICE_DATE 価格設定/外貨換算の実行日付(String)
QT_VALID_F 見積/引合有効開始日(String)
QT_VALID_T 見積の有効終了日(String)
CT_VALID_F 有効開始日付 (販売契約/品目提案)(String)
CT_VALID_T 有効終了日付 (販売契約/品目提案)(String)
CUST_GRP1 得意先グループ 1(String)
CUST_GRP2 得意先グループ 2(String)
CUST_GRP3 得意先グループ 3(String)
CUST_GRP4 得意先グループ 4(String)
CUST_GRP5 得意先グループ 5(String)
PURCH_NO_C 出荷先発注番号(String)
PURCH_NO_S 出荷先の得意先発注番号(String)
PO_DAT_S 出荷先の出荷先発注日付(String)
PO_METH_S 出荷先の出荷先発注タイプ(String)
REF_1_S 出荷先文字(String)
SD_DOC_CAT 販売管理伝票カテゴリ(String)
DOC_DATE 伝票日付 (受信日/送信日)(String)
WAR_DATE 保証期間の開始日付(String)
SHIP_COND 出荷条件(String)
PP_SEARCH 品目提案検索条件(String)
DUN_COUNT 得意先商談回数(String)
DUN_DATE 得意先との前回の商談日(String)
DLVSCHDUSE 用途区分(String)
PLDLVSTYP MRP: 出荷計画タイプ(String)
REF_DOC 参照伝票番号(String)
COMP_CDE_B 請求対象会社コード(String)
ALTTAX_CLS 代替税分類(String)
TAX_CLASS2 得意先税分類 2(String)
TAX_CLASS3 得意先税分類 3(String)
TAX_CLASS4 得意先に対する税クラス 4(String)
TAX_CLASS5 得意先に対する税クラス 5(String)
TAX_CLASS6 得意先に対する税クラス 6(String)
TAX_CLASS7 得意先に対する税クラス 7(String)
TAX_CLASS8 得意先に対する税クラス 8(String)
TAX_CLASS9 得意先に対する税クラス 9(String)
REF_DOC_L 参照伝票番号(String)
ASS_NUMBER 割当番号(String)
REFDOC_CAT 先行販売管理伝票の伝票カテゴリ(String)
ORDCOMB_IN 受注結合出荷区分(String)
BILL_SCHED 請求日程 (稼働日カレンダ指定)(String)
INVO_SCHED 請求書一覧日程 (稼働日カレンダ指定)(String)
MN_INVOICE マニュアル請求書更新(String)
EXRATE_FI FI 転記の換算レート (直接相場)(String)
ADD_VAL_DY 有効日からの日数(String)
FIX_VAL_DY 有効日日付(String)
PYMT_METH 支払方法(String)
ACCNT_ASGN 得意先の勘定設定グループ(String)
EXCHG_RATE 価格設定/統計の換算レート (直接引用)(String)
BILL_DATE 請求索引および印刷に対する請求日(String)
SERV_DATE サービス提供日(String)
DUNN_KEY 督促処理キー(String)
DUNN_BLOCK 督促処理保留(String)
PMTGAR_PRO 支払保証決定表(String)
DEPARTM_NO 部門コード(String)
REC_POINT 入荷ポイント(String)
DOC_NUM_FI ドキュメンタリクレジット処理: 内部番号(String)
CSTCNDGRP1 得意先条件グループ１(String)
CSTCNDGRP2 得意先条件グループ２(String)
CSTCNDGRP3 得意先条件グループ３(String)
CSTCNDGRP4 得意先条件グループ４(String)
CSTCNDGRP5 得意先条件グループ５(String)
DLV_TIME 契約出荷期間(String)
CURRENCY 販売伝票通貨(String)
CURR_ISO ISO コード通貨(String)
CREATED_BY オブジェクト登録者名(String)
TAXDEP_CTY 税出荷国(String)
TAXDST_CTY 税仕向国(String)
EUTRI_DEAL フラグ: EC 内三角取引(String)
MAST_CONTR グループマスタ契約番号(String)
REF_PROC 参照限定条件: 決定区分(String)
CHKPRTAUTH 取引先権限チェック(String)
CMLQTY_DAT 累積出荷数量日付(String)
VERSION 販売伝票バージョン番号(String)
NOTIF_NO 通知番号(String)
WBS_ELEM WBS 要素(String)
EXCH_RATE_FI_V FI 転記の換算レート (間接相場)(String)
EXCHG_RATE_V 価格設定/統計の換算レート (間接引用)(String)
FKK_CONACCT 長さ 12 の文字項目(String)
CAMPAIGN 総括プロジェクト計画: 外部 SAP システムの GUID(String)
DOC_CLASS リリースおよびトランザクション管理 を備えた元システム(String)
H_CURR 通貨コード(String)
H_CURR_ISO ISO 通貨コード(String)
SHIP_TYPE 出荷タイプ(String)
S_PROC_IND 特別処理区分(String)
REF_DOC_L_LONG 参照伝票番号 (依存関係についてはテキスト (長) を参照)(String)
LINE_TIME 納入日程の提案時刻 (現地時間: 販売組織参照)(String)
CALC_MOTIVE 計算区分(String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationHeaderInX

Object getQuotationHeaderInX ()

ヘッダデータチェックボックスを取得します。
返却値
Object ヘッダデータチェックボックス

ヘッダデータチェックボックスオブジェクトの構成は以下のとおりです。
ヘッダデータチェックボックス
オブジェクト
(Object)
UPDATEFLAG 更新区分 (String)
DOC_TYPE 関連ユーザデータ項目の更新情報 (String)
COLLECT_NO 関連ユーザデータ項目の更新情報 (String)
SALES_ORG 関連ユーザデータ項目の更新情報 (String)
DISTR_CHAN 関連ユーザデータ項目の更新情報 (String)
DIVISION 関連ユーザデータ項目の更新情報 (String)
SALES_GRP 関連ユーザデータ項目の更新情報 (String)
SALES_OFF 関連ユーザデータ項目の更新情報 (String)
REQ_DATE_H 関連ユーザデータ項目の更新情報 (String)
DATE_TYPE 関連ユーザデータ項目の更新情報 (String)
PURCH_DATE 関連ユーザデータ項目の更新情報 (String)
PO_METHOD 関連ユーザデータ項目の更新情報 (String)
PO_SUPPLEM 関連ユーザデータ項目の更新情報 (String)
REF_1 関連ユーザデータ項目の更新情報 (String)
NAME 関連ユーザデータ項目の更新情報 (String)
TELEPHONE 関連ユーザデータ項目の更新情報 (String)
PRICE_GRP 関連ユーザデータ項目の更新情報 (String)
CUST_GROUP 関連ユーザデータ項目の更新情報 (String)
SALES_DIST 関連ユーザデータ項目の更新情報 (String)
PRICE_LIST 関連ユーザデータ項目の更新情報 (String)
INCOTERMS1 関連ユーザデータ項目の更新情報 (String)
INCOTERMS2 関連ユーザデータ項目の更新情報 (String)
PMNTTRMS 関連ユーザデータ項目の更新情報 (String)
DLV_BLOCK 関連ユーザデータ項目の更新情報 (String)
BILL_BLOCK 関連ユーザデータ項目の更新情報 (String)
ORD_REASON 関連ユーザデータ項目の更新情報 (String)
COMPL_DLV 関連ユーザデータ項目の更新情報 (String)
PRICE_DATE 関連ユーザデータ項目の更新情報 (String)
QT_VALID_F 関連ユーザデータ項目の更新情報 (String)
QT_VALID_T 関連ユーザデータ項目の更新情報 (String)
CT_VALID_F 関連ユーザデータ項目の更新情報 (String)
CT_VALID_T 関連ユーザデータ項目の更新情報 (String)
CUST_GRP1 関連ユーザデータ項目の更新情報 (String)
CUST_GRP2 関連ユーザデータ項目の更新情報 (String)
CUST_GRP3 関連ユーザデータ項目の更新情報 (String)
CUST_GRP4 関連ユーザデータ項目の更新情報 (String)
CUST_GRP5 関連ユーザデータ項目の更新情報 (String)
PURCH_NO_C 関連ユーザデータ項目の更新情報 (String)
PURCH_NO_S 関連ユーザデータ項目の更新情報 (String)
PO_DAT_S 関連ユーザデータ項目の更新情報 (String)
PO_METH_S 関連ユーザデータ項目の更新情報 (String)
REF_1_S 関連ユーザデータ項目の更新情報 (String)
SD_DOC_CAT 関連ユーザデータ項目の更新情報 (String)
DOC_DATE 関連ユーザデータ項目の更新情報 (String)
WAR_DATE 関連ユーザデータ項目の更新情報 (String)
SHIP_COND 関連ユーザデータ項目の更新情報 (String)
PP_SEARCH 関連ユーザデータ項目の更新情報 (String)
DUN_COUNT 関連ユーザデータ項目の更新情報 (String)
DUN_DATE 関連ユーザデータ項目の更新情報 (String)
DLVSCHDUSE 関連ユーザデータ項目の更新情報 (String)
PLDLVSTYP 関連ユーザデータ項目の更新情報 (String)
REF_DOC 関連ユーザデータ項目の更新情報 (String)
COMP_CDE_B 関連ユーザデータ項目の更新情報 (String)
ALTTAX_CLS 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS2 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS3 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS4 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS5 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS6 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS7 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS8 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS9 関連ユーザデータ項目の更新情報 (String)
REF_DOC_L 関連ユーザデータ項目の更新情報 (String)
ASS_NUMBER 関連ユーザデータ項目の更新情報 (String)
REFDOC_CAT 関連ユーザデータ項目の更新情報 (String)
ORDCOMB_IN 関連ユーザデータ項目の更新情報 (String)
BILL_SCHED 関連ユーザデータ項目の更新情報 (String)
INVO_SCHED 関連ユーザデータ項目の更新情報 (String)
MN_INVOICE 関連ユーザデータ項目の更新情報 (String)
EXRATE_FI 関連ユーザデータ項目の更新情報 (String)
ADD_VAL_DY 関連ユーザデータ項目の更新情報 (String)
FIX_VAL_DY 関連ユーザデータ項目の更新情報 (String)
PYMT_METH 関連ユーザデータ項目の更新情報 (String)
ACCNT_ASGN 関連ユーザデータ項目の更新情報 (String)
EXCHG_RATE 関連ユーザデータ項目の更新情報 (String)
BILL_DATE 関連ユーザデータ項目の更新情報 (String)
SERV_DATE 関連ユーザデータ項目の更新情報 (String)
DUNN_KEY 関連ユーザデータ項目の更新情報 (String)
DUNN_BLOCK 関連ユーザデータ項目の更新情報 (String)
PROMOTION 関連ユーザデータ項目の更新情報 (String)
PMTGAR_PRO 関連ユーザデータ項目の更新情報 (String)
DEPARTM_NO 関連ユーザデータ項目の更新情報 (String)
REC_POINT 関連ユーザデータ項目の更新情報 (String)
POITM_NO_S 関連ユーザデータ項目の更新情報 (String)
DOC_NUM_FI 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP1 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP2 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP3 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP4 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP5 関連ユーザデータ項目の更新情報 (String)
DLV_TIME 関連ユーザデータ項目の更新情報 (String)
CURRENCY 関連ユーザデータ項目の更新情報 (String)
TAXDEP_CTY 関連ユーザデータ項目の更新情報 (String)
TAXDST_CTY 関連ユーザデータ項目の更新情報 (String)
EUTRI_DEAL 関連ユーザデータ項目の更新情報 (String)
MAST_CONTR 関連ユーザデータ項目の更新情報 (String)
REF_PROC 関連ユーザデータ項目の更新情報 (String)
CHKPRTAUTH 関連ユーザデータ項目の更新情報 (String)
CMLQTY_DAT 関連ユーザデータ項目の更新情報 (String)
VERSION 関連ユーザデータ項目の更新情報 (String)
NOTIF_NO 関連ユーザデータ項目の更新情報 (String)
WBS_ELEM 関連ユーザデータ項目の更新情報 (String)
EXCH_RATE_FI_V 関連ユーザデータ項目の更新情報 (String)
EXCHG_RATE_V 関連ユーザデータ項目の更新情報 (String)
FKK_CONACCT 関連ユーザデータ項目の更新情報 (String)
CAMPAIGN 関連ユーザデータ項目の更新情報 (String)
DOC_CLASS 関連ユーザデータ項目の更新情報 (String)
H_CURR 関連ユーザデータ項目の更新情報 (String)
SHIP_TYPE 関連ユーザデータ項目の更新情報 (String)
S_PROC_IND 関連ユーザデータ項目の更新情報 (String)
LINE_TIME 関連ユーザデータ項目の更新情報 (String)
CALC_MOTIVE 関連ユーザデータ項目の更新情報 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationItemsInList

Array getQuotationItemsInList ()

明細データを取得します。
返却値
Array 明細データ

明細データオブジェクトの構成は以下のとおりです。
引合伝票明細データ
オブジェクト
(Object)
ITM_NUMBER 販売伝票明細 (String)
HG_LV_ITEM 上位レベル明細 (String)
PO_ITM_NO 元となる購買発注の明細番号 (String)
MATERIAL 品目コード (String)
ALT_TO_ITM 代替明細 (String)
CUST_MAT22 得意先品目コード (無効) (String)
BATCH ロット番号 (String)
DLV_GROUP 出荷グループ (明細一括出荷) (String)
PART_DLV 明細レベルの分納納入 (String)
REASON_REJ 見積および受注の拒否理由 (String)
BILL_BLOCK ブロック (String)
BILL_DATE 請求索引および印刷に対する請求日 (String)
PLANT プラント (String)
STORE_LOC 保管場所 (String)
TARGET_QTY 目標数量（販売単位） (String)
TARGET_QU 目標数量 (数量単位) (String)
T_UNIT_ISO 目標数量単位 (ISO コード) (String)
ITEM_CATEG 明細カテゴリ (販売伝票) (String)
SHORT_TEXT テキスト (短): 受注明細 (String)
PRC_GROUP1 品目グループ 1 (String)
PRC_GROUP2 品目グループ 2 (String)
PRC_GROUP3 品目グループ 3 (String)
PRC_GROUP4 品目グループ 4 (String)
PRC_GROUP5 品目グループ 5 (String)
PROD_HIERA 品目階層 (String)
MATL_GROUP 品目グループ (String)
PURCH_NO_C 出荷先発注番号 (String)
PURCH_DATE 得意先発注日付 (String)
PO_METHOD 得意先発注タイプ (String)
REF_1 得意先/仕入先の内部参照コード (String)
PURCH_NO_S 出荷先の得意先発注番号 (String)
PO_DAT_S 出荷先の出荷先発注日付 (String)
PO_METH_S 出荷先の出荷先発注タイプ (String)
REF_1_S 出荷先文字 (String)
POITM_NO_S 元となる購買発注の明細番号 (String)
PRICE_GRP 価格グループ (得意先) (String)
CUST_GROUP 得意先グループ (String)
SALES_DIST 販売地域 (String)
PRICE_LIST 価格表タイプ (String)
INCOTERMS1 インコタームズ (1) (String)
INCOTERMS2 インコタームズ 2 (String)
ORDCOMP_IN 受注結合出荷区分 (String)
BILL_SCHED 請求日程 (稼働日カレンダ指定) (String)
INVO_SCHED 請求書一覧日程 (稼働日カレンダ指定) (String)
MN_INVOICE マニュアル請求書更新 (String)
EX_RATE_FI FI 転記の換算レート (直接相場) (String)
ADD_VAL_DY 有効日からの日数 (String)
FIX_VAL_DY 有効日日付 (String)
PMNTTRMS 支払条件キー (String)
PYMT_METH 支払方法 (String)
ACCNT_ASGN 得意先の勘定設定グループ (String)
EXCHG_RATE 価格設定/統計の換算レート (直接引用) (String)
PRICE_DATE 価格設定/外貨換算の実行日付 (String)
SERV_DATE サービス提供日 (String)
DUNN_KEY 督促処理キー (String)
DUNN_BLOCK 督促処理保留 (String)
PROMOTION プロモーション (String)
PMTGAR_PRO 支払保証決定表 (String)
DOC_NUM_FI ドキュメンタリクレジット処理: 内部番号 (String)
DEPARTM_NO 部門コード (String)
REC_POINT 入荷ポイント (String)
CSTCNDGRP1 得意先条件グループ１ (String)
CSTCNDGRP2 得意先条件グループ２ (String)
CSTCNDGRP3 得意先条件グループ３ (String)
CSTCNDGRP4 得意先条件グループ４ (String)
CSTCNDGRP5 得意先条件グループ５ (String)
DLV_TIME 契約出荷期間 (String)
SALES_UNIT 販売単位 (String)
S_UNIT_ISO 単位の ISO コード (String)
TRG_QTY_NO 販売単位から基本単位への換算係数 (String)
TRGQTY_DEN 販売単位から基本単位への換算係数 (String)
RNDDLV_QTY 丸め数量: 出荷 (String)
MAXDEVAMNT 数量に関する許容偏差 (絶対値) (String)
MAXDEVPER 数量に関する許容偏差 (%) (String)
MAXDEV_DAY シフト所要日数 (String)
USAGE_IND 未使用 - 予約長 3 (String)
FIXED_QUAN 数量固定区分 (String)
UNLMT_DLV 区分: 無制限過剰納入可能 (String)
OVERDLVTOL 過剰納入許容範囲 (String)
UNDDLV_TOL 不足納入許容範囲リミット (String)
DIVISION 製品部門 (String)
SALQTYNUM 販売数量単位から基本数量単位への変換係数の分子 (String)
SALQTYDEN 販売数量単位を SKU に換算するための分母 (除数) (String)
GROSS_WGHT 明細の総重量 (String)
NET_WEIGHT 明細の正味重量 (String)
UNTOF_WGHT 重量単位 (String)
UNOF_WTISO ISO コードでの重量単位 (String)
VOLUME 明細の総数量 (String)
VOLUNIT 容積単位 (String)
VOLUNITISO ISO コードでの容積単位 (String)
DLV_PRIO 出荷優先順位 (String)
SHIP_POINT 出荷ポイント/入荷ポイント (String)
ROUTE 輸送経路 (String)
CREATED_BY オブジェクト登録者名 (String)
TAX_CLASS1 品目の税分類 (String)
TAX_CLASS2 品目の税分類 (String)
TAX_CLASS3 品目の税分類 (String)
TAX_CLASS4 品目の税分類 (String)
TAX_CLASS5 品目の税分類 (String)
TAX_CLASS6 品目の税分類 (String)
TAX_CLASS7 品目の税分類 (String)
TAX_CLASS8 品目の税分類 (String)
TAX_CLASS9 品目の税分類 (String)
MAT_PR_GRP 品目価格設定グループ (String)
VAL_TYPE 評価タイプ (String)
FIXDAT_QTY 納期と出荷数量の固定 (String)
BOMEXPL_NO BOM 展開番号 (String)
RESANALKEY 結果分析キー (String)
REQMTS_TYP 所要量タイプ (String)
NO_GR_POST 得意先が入庫を転記していません (String)
BUS_TRANST 貿易管理の取引タイプ (String)
OVERHD_KEY 間接費キー (String)
CSTG_SHEET 原価計算表 (String)
MATFRGTGRP 品目運賃グループ (String)
PLDLVSHDIN 出荷計画に関する指示 (String)
SEQ_NO KANBAN/連続番号 (String)
BIL_FORM 請求書式 (String)
DLI_PROFIL 動的明細プロセッサプロファイル (String)
REV_TYPE 収益承認カテゴリ (String)
BEGDEM_PER 見越期間の提案開始日付 (String)
PR_REF_MAT 価格設定参照品目 (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)
ORDER_PROB 明細の受注可能性 (String)
MAX_PL_DLV 明細ごとの分割納入可能な最大回数 (String)
CFOP_CODE CFOP code and extension (old 5 char version) (String)
TAXLAWICMS 税法: ICMS (String)
TAXLAWIPI 税法: IPI (String)
SD_TAXCODE 0 (String)
ASSORT_MOD 品揃モジュール (String)
COMP_QUANT 構成品目数量 (String)
TARGET_VAL BAPI の通貨額 (小数点以下９桁) (String)
CURRENCY 販売伝票通貨 (String)
CURR_ISO ISO コード通貨 (String)
PROFIT_CTR 利益センタ (String)
ORDERID 指図番号 (String)
WBS_ELEM WBS 要素 (String)
DEPREC_PER ドキュメンタリクレジット処理 に関する償却率 (%) (String)
REF_DOC 参照伝票番号 (String)
REF_DOC_IT 参照明細番号 (String)
REF_DOC_CA 先行販売管理伝票の伝票カテゴリ (String)
CUST_MAT35 得意先品目 (String)
EXCH_RATE_FI_V FI 転記の換算レート (間接相場) (String)
EXCHG_RATE_V 価格設定/統計の換算レート (間接引用) (String)
ITEMGUID_ATP ATP: 暗号 - DELNR および DELPS (String)
VAL_CONTR 金額契約番号 (String)
VAL_CON_I 金額契約明細 (String)
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)
MAT_EXT 項目 MATERIAL の品目コード (長) (今後のリリースで開発) (String)
MAT_GUID 項目 MATERIAL の外部 GUID (今後のリリースで開発) (String)
MAT_VERS 項目 MATERIAL のバージョン番号 (今後のリリースで開発) (String)
P_MAT_EXT 項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発) (String)
P_MAT_GUID 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発) (String)
P_MAT_VERS 項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発) (String)
FUNC_AREA 機能領域 (String)
ALTERN_BOM 代替 BOM (String)
FKK_CONACCT 長さ 12 の文字項目 (String)
EAN_UPC 国際商品コード (EAN/UPC) (String)
PRODCAT 製品カタログ番号 (String)
SHIP_TYPE 出荷タイプ (String)
S_PROC_IND 特別処理区分 (String)
FUNC_AREA_LONG 機能領域 (String)
BILL_REL 請求関連 (CRM) (String)
VW_UEPOS 上位レベル明細用途 ID (String)
CAMPAIGN 総括プロジェクト計画: 外部 SAP システムの GUID (String)
DLVSCHDUSE 用途区分 (String)
CFOP_LONG CFOP code and extension (String)
SELECTION 選択 ID (永続) (String)
MAT_ENTRD 入力品目 (String)
LOG_SYSTEM_OWN 論理システム (String)
ITM_TYPE_USAGE 明細用途 (String)
TAXLAWISS ISS Tax Law (String)
MAT_ENTRD_EXTERNAL 項目 MAT_ENTRD の品目コード (長) (String)
MAT_ENTRD_GUID 項目 MAT_ENTRD の外部 GUID (String)
MAT_ENTRD_VERSION 項目 MAT_ENTRD のバージョン番号 (String)
LOC_TAXCAT 税タイプ (String)
LOC_ZEROVAT LOC_ZEROVAT (String)
LOC_ACTCODE 総所得税の活動コード (String)
LOC_DISTTYPE 所得税の配賦タイプ (String)
LOC_TXRELCLAS 税関連分類 (String)
CALC_MOTIVE 計算区分 (String)

明細データオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の明細データの「販売伝票明細」
[idx]["HG_LV_ITEM"]　→　配列内のidx番目の明細データの「上位レベル明細」
[idx]["PO_ITM_NO"]　→　配列内のidx番目の明細データの「元となる購買発注の明細番号」
[idx]["MATERIAL"]　→　配列内のidx番目の明細データの「品目コード」
[idx]["ALT_TO_ITM"]　→　配列内のidx番目の明細データの「代替明細」
[idx]["CUST_MAT22"]　→　配列内のidx番目の明細データの「得意先品目コード (無効)」
[idx]["BATCH"]　→　配列内のidx番目の明細データの「ロット番号」
[idx]["DLV_GROUP"]　→　配列内のidx番目の明細データの「出荷グループ (明細一括出荷)」
[idx]["PART_DLV"]　→　配列内のidx番目の明細データの「明細レベルの分納納入」
[idx]["REASON_REJ"]　→　配列内のidx番目の明細データの「見積および受注の拒否理由」
[idx]["BILL_BLOCK"]　→　配列内のidx番目の明細データの「ブロック」
[idx]["BILL_DATE"]　→　配列内のidx番目の明細データの「請求索引および印刷に対する請求日」
[idx]["PLANT"]　→　配列内のidx番目の明細データの「プラント」
[idx]["STORE_LOC"]　→　配列内のidx番目の明細データの「保管場所」
[idx]["TARGET_QTY"]　→　配列内のidx番目の明細データの「目標数量（販売単位）」
[idx]["TARGET_QU"]　→　配列内のidx番目の明細データの「目標数量 (数量単位)」
[idx]["T_UNIT_ISO"]　→　配列内のidx番目の明細データの「目標数量単位 (ISO コード)」
[idx]["ITEM_CATEG"]　→　配列内のidx番目の明細データの「明細カテゴリ (販売伝票)」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の明細データの「テキスト (短): 受注明細」
[idx]["PRC_GROUP1"]　→　配列内のidx番目の明細データの「品目グループ 1」
[idx]["PRC_GROUP2"]　→　配列内のidx番目の明細データの「品目グループ 2」
[idx]["PRC_GROUP3"]　→　配列内のidx番目の明細データの「品目グループ 3」
[idx]["PRC_GROUP4"]　→　配列内のidx番目の明細データの「品目グループ 4」
[idx]["PRC_GROUP5"]　→　配列内のidx番目の明細データの「品目グループ 5」
[idx]["PROD_HIERA"]　→　配列内のidx番目の明細データの「品目階層」
[idx]["MATL_GROUP"]　→　配列内のidx番目の明細データの「品目グループ」
[idx]["PURCH_NO_C"]　→　配列内のidx番目の明細データの「出荷先発注番号」
[idx]["PURCH_DATE"]　→　配列内のidx番目の明細データの「得意先発注日付」
[idx]["PO_METHOD"]　→　配列内のidx番目の明細データの「得意先発注タイプ」
[idx]["REF_1"]　→　配列内のidx番目の明細データの「得意先/仕入先の内部参照コード」
[idx]["PURCH_NO_S"]　→　配列内のidx番目の明細データの「出荷先の得意先発注番号」
[idx]["PO_DAT_S"]　→　配列内のidx番目の明細データの「出荷先の出荷先発注日付」
[idx]["PO_METH_S"]　→　配列内のidx番目の明細データの「出荷先の出荷先発注タイプ」
[idx]["REF_1_S"]　→　配列内のidx番目の明細データの「出荷先文字」
[idx]["POITM_NO_S"]　→　配列内のidx番目の明細データの「元となる購買発注の明細番号」
[idx]["PRICE_GRP"]　→　配列内のidx番目の明細データの「価格グループ (得意先)」
[idx]["CUST_GROUP"]　→　配列内のidx番目の明細データの「得意先グループ」
[idx]["SALES_DIST"]　→　配列内のidx番目の明細データの「販売地域」
[idx]["PRICE_LIST"]　→　配列内のidx番目の明細データの「価格表タイプ」
[idx]["INCOTERMS1"]　→　配列内のidx番目の明細データの「インコタームズ (1)」
[idx]["INCOTERMS2"]　→　配列内のidx番目の明細データの「インコタームズ 2」
[idx]["ORDCOMP_IN"]　→　配列内のidx番目の明細データの「受注結合出荷区分」
[idx]["BILL_SCHED"]　→　配列内のidx番目の明細データの「請求日程 (稼働日カレンダ指定)」
[idx]["INVO_SCHED"]　→　配列内のidx番目の明細データの「請求書一覧日程 (稼働日カレンダ指定)」
[idx]["MN_INVOICE"]　→　配列内のidx番目の明細データの「マニュアル請求書更新」
[idx]["EX_RATE_FI"]　→　配列内のidx番目の明細データの「FI 転記の換算レート (直接相場)」
[idx]["ADD_VAL_DY"]　→　配列内のidx番目の明細データの「有効日からの日数」
[idx]["FIX_VAL_DY"]　→　配列内のidx番目の明細データの「有効日日付」
[idx]["PMNTTRMS"]　→　配列内のidx番目の明細データの「支払条件キー」
[idx]["PYMT_METH"]　→　配列内のidx番目の明細データの「支払方法」
[idx]["ACCNT_ASGN"]　→　配列内のidx番目の明細データの「得意先の勘定設定グループ」
[idx]["EXCHG_RATE"]　→　配列内のidx番目の明細データの 「価格設定/統計の換算レート (直接引用)」
[idx]["PRICE_DATE"]　→　配列内のidx番目の明細データの「価格設定/外貨換算の実行日付」
[idx]["SERV_DATE"]　→　配列内のidx番目の明細データの「サービス提供日」
[idx]["DUNN_KEY"]　→　配列内のidx番目の明細データの「督促処理キー」
[idx]["DUNN_BLOCK"]　→　配列内のidx番目の明細データの「督促処理保留」
[idx]["PROMOTION"]　→　配列内のidx番目の明細データの「プロモーション」
[idx]["PMTGAR_PRO"]　→　配列内のidx番目の明細データの「支払保証決定表」
[idx]["DOC_NUM_FI"]　→　配列内のidx番目の明細データの 「ドキュメンタリクレジット処理: 内部番号」
[idx]["DEPARTM_NO"]　→　配列内のidx番目の明細データの「部門コード」
[idx]["REC_POINT"]　→　配列内のidx番目の明細データの「入荷ポイント」
[idx]["CSTCNDGRP1"]　→　配列内のidx番目の明細データの「得意先条件グループ１」
[idx]["CSTCNDGRP2"]　→　配列内のidx番目の明細データの「得意先条件グループ２」
[idx]["CSTCNDGRP3"]　→　配列内のidx番目の明細データの「得意先条件グループ３」
[idx]["CSTCNDGRP4"]　→　配列内のidx番目の明細データの「得意先条件グループ４」
[idx]["CSTCNDGRP5"]　→　配列内のidx番目の明細データの「得意先条件グループ５」
[idx]["DLV_TIME"]　→　配列内のidx番目の明細データの「契約出荷期間」
[idx]["SALES_UNIT"]　→　配列内のidx番目の明細データの「販売単位」
[idx]["S_UNIT_ISO"]　→　配列内のidx番目の明細データの「単位の ISO コード」
[idx]["TRG_QTY_NO"]　→　配列内のidx番目の明細データの「販売単位から基本単位への換算係数」
[idx]["TRGQTY_DEN"]　→　配列内のidx番目の明細データの「販売単位から基本単位への換算係数」
[idx]["RNDDLV_QTY"]　→　配列内のidx番目の明細データの「丸め数量: 出荷」
[idx]["MAXDEVAMNT"]　→　配列内のidx番目の明細データの「数量に関する許容偏差 (絶対値)」
[idx]["MAXDEVPER"]　→　配列内のidx番目の明細データの「数量に関する許容偏差 (%)」
[idx]["MAXDEV_DAY"]　→　配列内のidx番目の明細データの「シフト所要日数」
[idx]["USAGE_IND"]　→　配列内のidx番目の明細データの「未使用 - 予約長 3」
[idx]["FIXED_QUAN"]　→　配列内のidx番目の明細データの「数量固定区分」
[idx]["UNLMT_DLV"]　→　配列内のidx番目の明細データの「区分: 無制限過剰納入可能」
[idx]["OVERDLVTOL"]　→　配列内のidx番目の明細データの「過剰納入許容範囲」
[idx]["UNDDLV_TOL"]　→　配列内のidx番目の明細データの「不足納入許容範囲リミット」
[idx]["DIVISION"]　→　配列内のidx番目の明細データの「製品部門」
[idx]["SALQTYNUM"]　→　配列内のidx番目の明細データの 「販売数量単位から基本数量単位への変換係数の分子」
[idx]["SALQTYDEN"]　→　配列内のidx番目の明細データの 「販売数量単位を SKU に換算するための分母 (除数)」
[idx]["GROSS_WGHT"]　→　配列内のidx番目の明細データの「明細の総重量」
[idx]["NET_WEIGHT"]　→　配列内のidx番目の明細データの「明細の正味重量」
[idx]["UNTOF_WGHT"]　→　配列内のidx番目の明細データの「重量単位」
[idx]["UNOF_WTISO"]　→　配列内のidx番目の明細データの「ISO コードでの重量単位」
[idx]["VOLUME"]　→　配列内のidx番目の明細データの「明細の総数量」
[idx]["VOLUNIT"]　→　配列内のidx番目の明細データの「容積単位」
[idx]["VOLUNITISO"]　→　配列内のidx番目の明細データの「ISO コードでの容積単位」
[idx]["DLV_PRIO"]　→　配列内のidx番目の明細データの「出荷優先順位」
[idx]["SHIP_POINT"]　→　配列内のidx番目の明細データの「出荷ポイント/入荷ポイント」
[idx]["ROUTE"]　→　配列内のidx番目の明細データの「輸送経路」
[idx]["CREATED_BY"]　→　配列内のidx番目の明細データの「オブジェクト登録者名」
[idx]["TAX_CLASS1"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS2"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS3"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS4"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS5"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS6"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS7"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS8"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS9"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["MAT_PR_GRP"]　→　配列内のidx番目の明細データの「品目価格設定グループ」
[idx]["VAL_TYPE"]　→　配列内のidx番目の明細データの「評価タイプ」
[idx]["FIXDAT_QTY"]　→　配列内のidx番目の明細データの「納期と出荷数量の固定」
[idx]["BOMEXPL_NO"]　→　配列内のidx番目の明細データの「BOM 展開番号」
[idx]["RESANALKEY"]　→　配列内のidx番目の明細データの「結果分析キー」
[idx]["REQMTS_TYP"]　→　配列内のidx番目の明細データの「所要量タイプ」
[idx]["NO_GR_POST"]　→　配列内のidx番目の明細データの「得意先が入庫を転記していません」
[idx]["BUS_TRANST"]　→　配列内のidx番目の明細データの「貿易管理の取引タイプ」
[idx]["OVERHD_KEY"]　→　配列内のidx番目の明細データの「間接費キー」
[idx]["CSTG_SHEET"]　→　配列内のidx番目の明細データの「原価計算表」
[idx]["MATFRGTGRP"]　→　配列内のidx番目の明細データの「品目運賃グループ」
[idx]["PLDLVSHDIN"]　→　配列内のidx番目の明細データの「出荷計画に関する指示」
[idx]["SEQ_NO"]　→　配列内のidx番目の明細データの「KANBAN/連続番号」
[idx]["BIL_FORM"]　→　配列内のidx番目の明細データの「請求書式」
[idx]["DLI_PROFIL"]　→　配列内のidx番目の明細データの「動的明細プロセッサプロファイル」
[idx]["REV_TYPE"]　→　配列内のidx番目の明細データの「収益承認カテゴリ」
[idx]["BEGDEM_PER"]　→　配列内のidx番目の明細データの「見越期間の提案開始日付」
[idx]["PR_REF_MAT"]　→　配列内のidx番目の明細データの「価格設定参照品目」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の明細データの「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の明細データの「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の明細データの「論理システム」
[idx]["ORDER_PROB"]　→　配列内のidx番目の明細データの「明細の受注可能性」
[idx]["MAX_PL_DLV"]　→　配列内のidx番目の明細データの「明細ごとの分割納入可能な最大回数」
[idx]["CFOP_CODE"]　→　配列内のidx番目の明細データの 「CFOP code and extension (old 5 char version)」
[idx]["TAXLAWICMS"]　→　配列内のidx番目の明細データの「税法: ICMS」
[idx]["TAXLAWIPI"]　→　配列内のidx番目の明細データの「税法: IPI」
[idx]["SD_TAXCODE"]　→　配列内のidx番目の明細データの「0」
[idx]["ASSORT_MOD"]　→　配列内のidx番目の明細データの「品揃モジュール」
[idx]["COMP_QUANT"]　→　配列内のidx番目の明細データの「構成品目数量」
[idx]["TARGET_VAL"]　→　配列内のidx番目の明細データの「BAPI の通貨額 (小数点以下９桁)」
[idx]["CURRENCY"]　→　配列内のidx番目の明細データの「販売伝票通貨」
[idx]["CURR_ISO"]　→　配列内のidx番目の明細データの「ISO コード通貨」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の明細データの「利益センタ」
[idx]["ORDERID"]　→　配列内のidx番目の明細データの「指図番号」
[idx]["WBS_ELEM"]　→　配列内のidx番目の明細データの「WBS 要素」
[idx]["DEPREC_PER"]　→　配列内のidx番目の明細データの 「ドキュメンタリクレジット処理に関する償却率 (%)」
[idx]["REF_DOC"]　→　配列内のidx番目の明細データの「参照伝票番号」
[idx]["REF_DOC_IT"]　→　配列内のidx番目の明細データの「参照明細番号」
[idx]["REF_DOC_CA"]　→　配列内のidx番目の明細データの「先行販売管理伝票の伝票カテゴリ」
[idx]["CUST_MAT35"]　→　配列内のidx番目の明細データの「得意先品目」
[idx]["EXCH_RATE_FI_V"]　→　配列内のidx番目の明細データの 「FI 転記の換算レート (間接相場)」
[idx]["EXCHG_RATE_V"]　→　配列内のidx番目の明細データの 「価格設定/統計の換算レート (間接引用)」
[idx]["ITEMGUID_ATP"]　→　配列内のidx番目の明細データの 「ATP: 暗号 - DELNR および DELPS」
[idx]["VAL_CONTR"]　→　配列内のidx番目の明細データの「金額契約番号」
[idx]["VAL_CON_I"]　→　配列内のidx番目の明細データの「金額契約明細」
[idx]["CONFIG_ID"]　→　配列内のidx番目の明細データの「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の明細データの「選定におけるインスタンス番号」
[idx]["MAT_EXT"]　→　配列内のidx番目の明細データの 「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["MAT_GUID"]　→　配列内のidx番目の明細データの 「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["MAT_VERS"]　→　配列内のidx番目の明細データの 「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」
[idx]["P_MAT_EXT"]　→　配列内のidx番目の明細データの 「項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)」
[idx]["P_MAT_GUID"]　→　配列内のidx番目の明細データの 「項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)」
[idx]["P_MAT_VERS"]　→　配列内のidx番目の明細データの 「項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)」
[idx]["FUNC_AREA"]　→　配列内のidx番目の明細データの「機能領域」
[idx]["ALTERN_BOM"]　→　配列内のidx番目の明細データの「代替 BOM」
[idx]["FKK_CONACCT"]　→　配列内のidx番目の明細データの「長さ 12 の文字項目」
[idx]["EAN_UPC"]　→　配列内のidx番目の明細データの「国際商品コード (EAN/UPC)」
[idx]["PRODCAT"]　→　配列内のidx番目の明細データの「製品カタログ番号」
[idx]["SHIP_TYPE"]　→　配列内のidx番目の明細データの「出荷タイプ」
[idx]["S_PROC_IND"]　→　配列内のidx番目の明細データの「特別処理区分」
[idx]["FUNC_AREA_LONG"]　→　配列内のidx番目の明細データの「機能領域」
[idx]["BILL_REL"]　→　配列内のidx番目の明細データの「請求関連 (CRM)」
[idx]["VW_UEPOS"]　→　配列内のidx番目の明細データの「上位レベル明細用途 ID」
[idx]["CAMPAIGN"]　→　配列内のidx番目の明細データの 「総括プロジェクト計画: 外部 SAP システムの GUID」
[idx]["DLVSCHDUSE"]　→　配列内のidx番目の明細データの「用途区分」
[idx]["CFOP_LONG"]　→　配列内のidx番目の明細データの 「CFOP code and extension」
[idx]["SELECTION"]　→　配列内のidx番目の明細データの「選択 ID (永続)」
[idx]["MAT_ENTRD"]　→　配列内のidx番目の明細データの「入力品目」
[idx]["LOG_SYSTEM_OWN"]　→　配列内のidx番目の明細データの「論理システム」
[idx]["ITM_TYPE_USAGE"]　→　配列内のidx番目の明細データの「明細用途」
[idx]["TAXLAWISS"]　→　配列内のidx番目の明細データの「ISS Tax Law」
[idx]["MAT_ENTRD_EXTERNAL"]　→　配列内のidx番目の明細データの 「項目 MAT_ENTRD の品目コード (長)」
[idx]["MAT_ENTRD_GUID"]　→　配列内のidx番目の明細データの 「項目 MAT_ENTRD の外部 GUID」
[idx]["MAT_ENTRD_VERSION"]　→　配列内のidx番目の明細データの 「項目 MAT_ENTRD のバージョン番号」
[idx]["LOC_TAXCAT"]　→　配列内のidx番目の明細データの「税タイプ」
[idx]["LOC_ZEROVAT"]　→　配列内のidx番目の明細データの「LOC_ZEROVAT」
[idx]["LOC_ACTCODE"]　→　配列内のidx番目の明細データの「総所得税の活動コード」
[idx]["LOC_DISTTYPE"]　→　配列内のidx番目の明細データの「所得税の配賦タイプ」
[idx]["LOC_TXRELCLAS"]　→　配列内のidx番目の明細データの「税関連分類」
[idx]["CALC_MOTIVE"]　→　配列内のidx番目の明細データの「計算区分」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationItemsInXList

Array getQuotationItemsInXList ()

明細データチェックボックスを取得します。
返却値
Array 明細データチェックボックス

明細データチェックボックスオブジェクトの構成は以下のとおりです。
明細データチェックボックス
オブジェクト
(Object)
ITM_NUMBER 販売伝票明細 (String)
UPDATEFLAG 更新区分 (String)
HG_LV_ITEM 関連ユーザデータ項目の更新情報 (String)
PO_ITM_NO 関連ユーザデータ項目の更新情報 (String)
MATERIAL 関連ユーザデータ項目の更新情報 (String)
ALT_TO_ITM 関連ユーザデータ項目の更新情報 (String)
CUST_MAT22 関連ユーザデータ項目の更新情報 (String)
BATCH 関連ユーザデータ項目の更新情報 (String)
DLV_GROUP 関連ユーザデータ項目の更新情報 (String)
PART_DLV 関連ユーザデータ項目の更新情報 (String)
REASON_REJ 関連ユーザデータ項目の更新情報 (String)
BILL_BLOCK 関連ユーザデータ項目の更新情報 (String)
BILL_DATE 関連ユーザデータ項目の更新情報 (String)
PLANT 関連ユーザデータ項目の更新情報 (String)
STORE_LOC 関連ユーザデータ項目の更新情報 (String)
TARGET_QTY 関連ユーザデータ項目の更新情報 (String)
TARGET_QU 関連ユーザデータ項目の更新情報 (String)
T_UNIT_ISO 関連ユーザデータ項目の更新情報 (String)
ITEM_CATEG 関連ユーザデータ項目の更新情報 (String)
SHORT_TEXT 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP1 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP2 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP3 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP4 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP5 関連ユーザデータ項目の更新情報 (String)
PROD_HIERA 関連ユーザデータ項目の更新情報 (String)
MATL_GROUP 関連ユーザデータ項目の更新情報 (String)
PURCH_NO_C 関連ユーザデータ項目の更新情報 (String)
PURCH_DATE 関連ユーザデータ項目の更新情報 (String)
PO_METHOD 関連ユーザデータ項目の更新情報 (String)
REF_1 関連ユーザデータ項目の更新情報 (String)
PURCH_NO_S 関連ユーザデータ項目の更新情報 (String)
PO_DAT_S 関連ユーザデータ項目の更新情報 (String)
PO_METH_S 関連ユーザデータ項目の更新情報 (String)
REF_1_S 関連ユーザデータ項目の更新情報 (String)
POITM_NO_S 関連ユーザデータ項目の更新情報 (String)
PRICE_GRP 関連ユーザデータ項目の更新情報 (String)
CUST_GROUP 関連ユーザデータ項目の更新情報 (String)
SALES_DIST 関連ユーザデータ項目の更新情報 (String)
PRICE_LIST 関連ユーザデータ項目の更新情報 (String)
INCOTERMS1 関連ユーザデータ項目の更新情報 (String)
INCOTERMS2 関連ユーザデータ項目の更新情報 (String)
ORDCOMP_IN 関連ユーザデータ項目の更新情報 (String)
BILL_SCHED 関連ユーザデータ項目の更新情報 (String)
INVO_SCHED 関連ユーザデータ項目の更新情報 (String)
MN_INVOICE 関連ユーザデータ項目の更新情報 (String)
EX_RATE_FI 関連ユーザデータ項目の更新情報 (String)
ADD_VAL_DY 関連ユーザデータ項目の更新情報 (String)
FIX_VAL_DY 関連ユーザデータ項目の更新情報 (String)
PMNTTRMS 関連ユーザデータ項目の更新情報 (String)
PYMT_METH 関連ユーザデータ項目の更新情報 (String)
ACCNT_ASGN 関連ユーザデータ項目の更新情報 (String)
EXCHG_RATE 関連ユーザデータ項目の更新情報 (String)
PRICE_DATE 関連ユーザデータ項目の更新情報 (String)
SERV_DATE 関連ユーザデータ項目の更新情報 (String)
DUNN_KEY 関連ユーザデータ項目の更新情報 (String)
DUNN_BLOCK 関連ユーザデータ項目の更新情報 (String)
PROMOTION 関連ユーザデータ項目の更新情報 (String)
PMTGAR_PRO 関連ユーザデータ項目の更新情報 (String)
DOC_NUM_FI 関連ユーザデータ項目の更新情報 (String)
DEPARTM_NO 関連ユーザデータ項目の更新情報 (String)
REC_POINT 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP1 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP2 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP3 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP4 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP5 関連ユーザデータ項目の更新情報 (String)
DLV_TIME 関連ユーザデータ項目の更新情報 (String)
SALES_UNIT 関連ユーザデータ項目の更新情報 (String)
TRG_QTY_NO 関連ユーザデータ項目の更新情報 (String)
TRGQTY_DEN 関連ユーザデータ項目の更新情報 (String)
RNDDLV_QTY 関連ユーザデータ項目の更新情報 (String)
MAXDEVAMNT 関連ユーザデータ項目の更新情報 (String)
MAXDEVPER 関連ユーザデータ項目の更新情報 (String)
MAXDEV_DAY 関連ユーザデータ項目の更新情報 (String)
USAGE_IND 関連ユーザデータ項目の更新情報 (String)
FIXED_QUAN 関連ユーザデータ項目の更新情報 (String)
UNLMT_DLV 関連ユーザデータ項目の更新情報 (String)
OVERDLVTOL 関連ユーザデータ項目の更新情報 (String)
UNDDLV_TOL 関連ユーザデータ項目の更新情報 (String)
DIVISION 関連ユーザデータ項目の更新情報 (String)
SALQTYNUM 関連ユーザデータ項目の更新情報 (String)
SALQTYDEN 関連ユーザデータ項目の更新情報 (String)
GROSS_WGHT 関連ユーザデータ項目の更新情報 (String)
NET_WEIGHT 関連ユーザデータ項目の更新情報 (String)
UNTOF_WGHT 関連ユーザデータ項目の更新情報 (String)
VOLUME 関連ユーザデータ項目の更新情報 (String)
VOLUNIT 関連ユーザデータ項目の更新情報 (String)
DLV_PRIO 関連ユーザデータ項目の更新情報 (String)
SHIP_POINT 関連ユーザデータ項目の更新情報 (String)
ROUTE 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS1 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS2 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS3 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS4 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS5 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS6 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS7 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS8 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS9 関連ユーザデータ項目の更新情報 (String)
MAT_PR_GRP 関連ユーザデータ項目の更新情報 (String)
VAL_TYPE 関連ユーザデータ項目の更新情報 (String)
FIXDAT_QTY 関連ユーザデータ項目の更新情報 (String)
BOMEXPL_NO 関連ユーザデータ項目の更新情報 (String)
RESANALKEY 関連ユーザデータ項目の更新情報 (String)
REQMTS_TYP 関連ユーザデータ項目の更新情報 (String)
NO_GR_POST 関連ユーザデータ項目の更新情報 (String)
BUS_TRANST 関連ユーザデータ項目の更新情報 (String)
OVERHD_KEY 関連ユーザデータ項目の更新情報 (String)
CSTG_SHEET 関連ユーザデータ項目の更新情報 (String)
MATFRGTGRP 関連ユーザデータ項目の更新情報 (String)
PLDLVSHDIN 関連ユーザデータ項目の更新情報 (String)
SEQ_NO 関連ユーザデータ項目の更新情報 (String)
BIL_FORM 関連ユーザデータ項目の更新情報 (String)
DLI_PROFIL 関連ユーザデータ項目の更新情報 (String)
REV_TYPE 関連ユーザデータ項目の更新情報 (String)
BEGDEM_PER 関連ユーザデータ項目の更新情報 (String)
PR_REF_MAT 関連ユーザデータ項目の更新情報 (String)
REFOBJTYPE 関連ユーザデータ項目の更新情報 (String)
REFOBJKEY 関連ユーザデータ項目の更新情報 (String)
REFLOGSYS 関連ユーザデータ項目の更新情報 (String)
ORDER_PROB 関連ユーザデータ項目の更新情報 (String)
MAX_PL_DLV 関連ユーザデータ項目の更新情報 (String)
CFOP_CODE 関連ユーザデータ項目の更新情報 (String)
TAXLAWICMS 関連ユーザデータ項目の更新情報 (String)
TAXLAWIPI 関連ユーザデータ項目の更新情報 (String)
SD_TAXCODE 関連ユーザデータ項目の更新情報 (String)
ASSORT_MOD 関連ユーザデータ項目の更新情報 (String)
COMP_QUANT 関連ユーザデータ項目の更新情報 (String)
TARGET_VAL 関連ユーザデータ項目の更新情報 (String)
PROFIT_CTR 関連ユーザデータ項目の更新情報 (String)
ORDERID 関連ユーザデータ項目の更新情報 (String)
WBS_ELEM 関連ユーザデータ項目の更新情報 (String)
DEPREC_PER 関連ユーザデータ項目の更新情報 (String)
REF_DOC 関連ユーザデータ項目の更新情報 (String)
REF_DOC_IT 関連ユーザデータ項目の更新情報 (String)
REF_DOC_CA 関連ユーザデータ項目の更新情報 (String)
CUST_MAT35 関連ユーザデータ項目の更新情報 (String)
EXCH_RATE_FI_V 関連ユーザデータ項目の更新情報 (String)
EXCHG_RATE_V 関連ユーザデータ項目の更新情報 (String)
ITEMGUID_ATP 関連ユーザデータ項目の更新情報 (String)
VAL_CONTR 関連ユーザデータ項目の更新情報 (String)
VAL_CON_I 関連ユーザデータ項目の更新情報 (String)
CONFIG_ID 関連ユーザデータ項目の更新情報 (String)
INST_ID 関連ユーザデータ項目の更新情報 (String)
MAT_EXT 関連ユーザデータ項目の更新情報 (String)
MAT_GUID 関連ユーザデータ項目の更新情報 (String)
MAT_VERS 関連ユーザデータ項目の更新情報 (String)
P_MAT_EXT 関連ユーザデータ項目の更新情報 (String)
P_MAT_GUID 関連ユーザデータ項目の更新情報 (String)
P_MAT_VERS 関連ユーザデータ項目の更新情報 (String)
FUNC_AREA 関連ユーザデータ項目の更新情報 (String)
ALTERN_BOM 関連ユーザデータ項目の更新情報 (String)
FKK_CONACCT 関連ユーザデータ項目の更新情報 (String)
EAN_UPC 関連ユーザデータ項目の更新情報 (String)
PRODCAT 関連ユーザデータ項目の更新情報 (String)
SHIP_TYPE 関連ユーザデータ項目の更新情報 (String)
S_PROC_IND 関連ユーザデータ項目の更新情報 (String)
BILL_REL 関連ユーザデータ項目の更新情報 (String)
VW_UEPOS 関連ユーザデータ項目の更新情報 (String)
CAMPAIGN 関連ユーザデータ項目の更新情報 (String)
DLVSCHDUSE 関連ユーザデータ項目の更新情報 (String)
SELECTION 関連ユーザデータ項目の更新情報 (String)
MAT_ENTRD 関連ユーザデータ項目の更新情報 (String)
LOG_SYSTEM_OWN 関連ユーザデータ項目の更新情報 (String)
ITM_TYPE_USAGE 関連ユーザデータ項目の更新情報 (String)
MAT_ENTRD_EXTERNAL 関連ユーザデータ項目の更新情報 (String)
MAT_ENTRD_GUID 関連ユーザデータ項目の更新情報 (String)
MAT_ENTRD_VERSION 関連ユーザデータ項目の更新情報 (String)
LOC_TAXCAT 関連ユーザデータ項目の更新情報 (String)
LOC_ZEROVAT 関連ユーザデータ項目の更新情報 (String)
LOC_ACTCODE 関連ユーザデータ項目の更新情報 (String)
LOC_DISTTYPE 関連ユーザデータ項目の更新情報 (String)
LOC_TXRELCLAS 関連ユーザデータ項目の更新情報 (String)
CALC_MOTIVE 関連ユーザデータ項目の更新情報 (String)

明細データチェックボックスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の明細データチェックボックスの「販売伝票明細」
[idx]["UPDATEFLAG"]　→　配列内のidx番目の明細データチェックボックスの「更新区分
[idx]["HG_LV_ITEM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_ITM_NO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["MATERIAL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["ALT_TO_ITM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["CUST_MAT22"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["BATCH"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報
[idx]["DLV_GROUP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["PART_DLV"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["REASON_REJ"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_BLOCK"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_DATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PLANT"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["STORE_LOC"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TARGET_QTY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["TARGET_QU"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["T_UNIT_ISO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ITEM_CATEG"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP1"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP2"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP3"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP4"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP5"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PROD_HIERA"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["MATL_GROUP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PURCH_NO_C"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PURCH_DATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_METHOD"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_1"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["PURCH_NO_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_DAT_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_METH_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_1_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["POITM_NO_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_GRP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["CUST_GROUP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SALES_DIST"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_LIST"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INCOTERMS1"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INCOTERMS2"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ORDCOMP_IN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_SCHED"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INVO_SCHED"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MN_INVOICE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EX_RATE_FI"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ADD_VAL_DY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FIX_VAL_DY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["PMNTTRMS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["PYMT_METH"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ACCNT_ASGN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCHG_RATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_DATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SERV_DATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DUNN_KEY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DUNN_BLOCK"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PROMOTION"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PMTGAR_PRO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DOC_NUM_FI"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DEPARTM_NO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REC_POINT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP1"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP2"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["CSTCNDGRP3"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["CSTCNDGRP4"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP5"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLV_TIME"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SALES_UNIT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TRG_QTY_NO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TRGQTY_DEN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["RNDDLV_QTY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAXDEVAMNT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAXDEVPER"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAXDEV_DAY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["USAGE_IND"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FIXED_QUAN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["UNLMT_DLV"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["OVERDLVTOL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["UNDDLV_TOL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DIVISION"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["SALQTYNUM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["SALQTYDEN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["GROSS_WGHT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["NET_WEIGHT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["UNTOF_WGHT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["VOLUME"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["VOLUNIT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLV_PRIO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SHIP_POINT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ROUTE"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS1"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS2"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS3"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS4"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS5"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS6"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS7"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS8"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS9"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["MAT_PR_GRP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["VAL_TYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FIXDAT_QTY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BOMEXPL_NO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["RESANALKEY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REQMTS_TYP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["NO_GR_POST"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BUS_TRANST"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["OVERHD_KEY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTG_SHEET"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MATFRGTGRP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PLDLVSHDIN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SEQ_NO"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["BIL_FORM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLI_PROFIL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REV_TYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BEGDEM_PER"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PR_REF_MAT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REFOBJKEY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REFLOGSYS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["ORDER_PROB"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAX_PL_DLV"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CFOP_CODE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAXLAWICMS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAXLAWIPI"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SD_TAXCODE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ASSORT_MOD"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["COMP_QUANT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TARGET_VAL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ORDERID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["WBS_ELEM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DEPREC_PER"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_DOC"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_DOC_IT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_DOC_CA"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CUST_MAT35"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCH_RATE_FI_V"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCHG_RATE_V"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ITEMGUID_ATP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["VAL_CONTR"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["VAL_CON_I"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CONFIG_ID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INST_ID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_EXT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_GUID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_VERS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["P_MAT_EXT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["P_MAT_GUID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["P_MAT_VERS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FUNC_AREA"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ALTERN_BOM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FKK_CONACCT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EAN_UPC"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRODCAT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SHIP_TYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["S_PROC_IND"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_REL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["VW_UEPOS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CAMPAIGN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLVSCHDUSE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SELECTION"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_ENTRD"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["LOG_SYSTEM_OWN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ITM_TYPE_USAGE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_ENTRD_EXTERNAL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_ENTRD_GUID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_ENTRD_VERSION"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["LOC_TAXCAT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["LOC_ZEROVAT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["LOC_ACTCODE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["LOC_DISTTYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["LOC_TXRELCLAS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CALC_MOTIVE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationKeysList

Array getQuotationKeysList ()

参照キーの出力を取得します。
返却値
Array 参照キーの出力

参照キーの出力オブジェクトの構成は以下のとおりです。
参照キーの出力
オブジェクト
(Object)
REFOBJTYP オブジェクトタイプ (String)
REFOBJECT オブジェクト名 (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)
DOC_NUMBER 販売管理伝票番号 (String)
ITM_NUMBER 販売伝票明細 (String)
SCHED_LIN 納入日程行 (String)
COND_NO 伝票条件番号 (String)
CONDITEMNO 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件カウンタ (String)
COND_TYPE 条件タイプ (String)
STATUS 単一文字フラグ (String)
TINDEX 数値項目: 長さ 6 (String)
ADDRESS 住所 (String)
ABRLI 内部納入日程番号 (String)
ABART 承認タイプ (String)

参照キーの出力オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["REFOBJTYP"]　→　配列内のidx番目の参照キーの出力の「オブジェクトタイプ」
[idx]["REFOBJECT"]　→　配列内のidx番目の参照キーの出力の「オブジェクト名
[idx]["REFOBJKEY"]　→　配列内のidx番目の参照キーの出力の「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の参照キーの出力の「論理システム
[idx]["DOC_NUMBER"]　→　配列内のidx番目の参照キーの出力の「販売管理伝票番号
[idx]["ITM_NUMBER"]　→　配列内のidx番目の参照キーの出力の「販売伝票明細
[idx]["SCHED_LIN"]　→　配列内のidx番目の参照キーの出力の「納入日程行
[idx]["COND_NO"]　→　配列内のidx番目の参照キーの出力の「伝票条件番号
[idx]["CONDITEMNO"]　→　配列内のidx番目の参照キーの出力の「条件明細番号
[idx]["COND_ST_NO"]　→　配列内のidx番目の参照キーの出力の「ステップ番号
[idx]["COND_COUNT"]　→　配列内のidx番目の参照キーの出力の「条件カウンタ」
[idx]["COND_TYPE"]　→　配列内のidx番目の参照キーの出力の「条件タイプ」
[idx]["STATUS"]　→　配列内のidx番目の参照キーの出力の「単一文字フラグ」
[idx]["TINDEX"]　→　配列内のidx番目の参照キーの出力の「数値項目: 長さ 6」
[idx]["ADDRESS"]　→　配列内のidx番目の参照キーの出力の「住所」
[idx]["ABRLI"]　→　配列内のidx番目の参照キーの出力の「内部納入日程番号
[idx]["ABART"]　→　配列内のidx番目の参照キーの出力の「承認タイプ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationPartnersList

Array getQuotationPartnersList ()

伝票取引先を取得します。
返却値
Array 伝票取引先

伝票取引先オブジェクトの構成は以下のとおりです。
伝票取引先
オブジェクト
(Object)
PARTN_ROLE 取引先機能 (String)
PARTN_NUMB 得意先コード 1 (String)
ITM_NUMBER 明細番号 (販売管理伝票) (String)
TITLE 敬称 (String)
NAME 名称 1 (String)
NAME_2 名称 2 (String)
NAME_3 名称 3 (String)
NAME_4 名称 4 (String)
STREET 地名/番地-号 (String)
COUNTRY 国コード (String)
COUNTR_ISO 国キー (ISO コード) (String)
POSTL_CODE 郵便番号 (String)
POBX_PCD 私書箱番号 (String)
POBX_CTY 私書箱住所 (String)
CITY 市区町村 (String)
DISTRICT 所在地 (String)
REGION 地域 (都道府県) (String)
PO_BOX 私書箱 (String)
TELEPHONE 電話番号 1 (String)
TELEPHONE2 電話番号 2 (String)
TELEBOX テレボックス番号 (String)
FAX_NUMBER FAX 番号 (String)
TELETEX_NO テレテクス番号 (String)
TELEX_NO テレックス番号 (String)
LANGU 言語キー (String)
LANGU_ISO ISO 639 準拠の言語 (String)
UNLOAD_PT 荷渡ポイント (String)
TRANSPZONE 商品の納入区域 (String)
TAXJURCODE 税計算管轄コード - 税管轄コード (String)
ADDRESS 住所 (String)
PRIV_ADDR 自宅住所 (String)
ADDR_TYPE アドレスタイプ (1=組織、2=個人、3=取引先担当者) (String)
ADDR_ORIG コピー元住所 (String)
ADDR_LINK 住所コードへのリンク (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)

伝票取引先オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PARTN_ROLE"]　→　配列内のidx番目の伝票取引先の「取引先機能」
[idx]["PARTN_NUMB"]　→　配列内のidx番目の伝票取引先の「得意先コード 1
[idx]["ITM_NUMBER"]　→　配列内のidx番目の伝票取引先の「明細番号 (販売管理伝票)」
[idx]["TITLE"]　→　配列内のidx番目の伝票取引先の「敬称
[idx]["NAME"]　→　配列内のidx番目の伝票取引先の「名称 1
[idx]["NAME_2"]　→　配列内のidx番目の伝票取引先の「名称 2
[idx]["NAME_3"]　→　配列内のidx番目の伝票取引先の「名称 3
[idx]["NAME_4"]　→　配列内のidx番目の伝票取引先の「名称 4
[idx]["STREET"]　→　配列内のidx番目の伝票取引先の「地名/番地-号
[idx]["COUNTRY"]　→　配列内のidx番目の伝票取引先の「国コード
[idx]["COUNTR_ISO"]　→　配列内のidx番目の伝票取引先の「国キー (ISO コード)」
[idx]["POSTL_CODE"]　→　配列内のidx番目の伝票取引先の「郵便番号」
[idx]["POBX_PCD"]　→　配列内のidx番目の伝票取引先の「私書箱番号」
[idx]["POBX_CTY"]　→　配列内のidx番目の伝票取引先の「私書箱住所」
[idx]["CITY"]　→　配列内のidx番目の伝票取引先の「市区町村」
[idx]["DISTRICT"]　→　配列内のidx番目の伝票取引先の「所在地
[idx]["REGION"]　→　配列内のidx番目の伝票取引先の「地域 (都道府県)」
[idx]["PO_BOX"]　→　配列内のidx番目の伝票取引先の「私書箱」
[idx]["TELEPHONE"]　→　配列内のidx番目の伝票取引先の「電話番号 1」
[idx]["TELEPHONE2"]　→　配列内のidx番目の伝票取引先の「電話番号 2」
[idx]["TELEBOX"]　→　配列内のidx番目の伝票取引先の「テレボックス番号」
[idx]["FAX_NUMBER"]　→　配列内のidx番目の伝票取引先の「FAX 番号」
[idx]["TELETEX_NO"]　→　配列内のidx番目の伝票取引先の「テレテクス番号」
[idx]["TELEX_NO"]　→　配列内のidx番目の伝票取引先の「テレックス番号」
[idx]["LANGU"]　→　配列内のidx番目の伝票取引先の「言語キー」
[idx]["LANGU_ISO"]　→　配列内のidx番目の伝票取引先の「ISO 639 準拠の言語
[idx]["UNLOAD_PT"]　→　配列内のidx番目の伝票取引先の「荷渡ポイント」
[idx]["TRANSPZONE"]　→　配列内のidx番目の伝票取引先の「商品の納入区域」
[idx]["TAXJURCODE"]　→　配列内のidx番目の伝票取引先の「税計算管轄コード - 税管轄コード」
[idx]["ADDRESS"]　→　配列内のidx番目の伝票取引先の「住所」
[idx]["PRIV_ADDR"]　→　配列内のidx番目の伝票取引先の「自宅住所」
[idx]["ADDR_TYPE"]　→　配列内のidx番目の伝票取引先の 「アドレスタイプ (1=組織、2=個人、3=取引先担当者)」
[idx]["ADDR_ORIG"]　→　配列内のidx番目の伝票取引先の「コピー元住所」
[idx]["ADDR_LINK"]　→　配列内のidx番目の伝票取引先の「住所コードへのリンク」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の伝票取引先の「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の伝票取引先の「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の伝票取引先の「論理システム

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationSchedulesInList

Array getQuotationSchedulesInList ()

納入日程行を取得します。
返却値
Array 納入日程行

納入日程行オブジェクトの構成は以下のとおりです。
納入日程行
オブジェクト
(Object)
ITM_NUMBER 販売伝票明細 (String)
SCHED_LINE 納入日程行 (String)
REQ_DATE 納入日程日付 (String)
DATE_TYPE 日付タイプ (日、週、月、期間) (String)
REQ_TIME 納入時間 (String)
REQ_QTY 販売単位による受注数量 (String)
REQ_DLV_BL 出荷ブロック中の納入日程行 (String)
SCHED_TYPE 納入日程カテゴリ (String)
TP_DATE 輸送計画日付 (String)
MS_DATE 品目利用可能日 (String)
LOAD_DATE 積載日付 (String)
GI_DATE 出庫日付 (String)
TP_TIME 輸送計画 - 時間 (現地時間/出荷ポイント参照) (String)
MS_TIME 品目供給ステージ (現地時刻: プラント参照) (String)
LOAD_TIME 積載時刻 (現地時間: 出荷ポイント) (String)
GI_TIME 出庫時刻 (現地時間 - プラント参照) (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)
DLV_DATE 納入日程日付 (String)
DLV_TIME 納入時間 (String)
REL_TYPE 承認タイプ (String)
PLAN_SCHED_TYPE 納入日程行タイプ EDI (String)

納入日程行オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の納入日程行の「販売伝票明細」
[idx]["SCHED_LINE"]　→　配列内のidx番目の納入日程行の「納入日程行」
[idx]["REQ_DATE"]　→　配列内のidx番目の納入日程行の「納入日程日付」
[idx]["DATE_TYPE"]　→　配列内のidx番目の納入日程行の「日付タイプ (日、週、月、期間)」
[idx]["REQ_TIME"]　→　配列内のidx番目の納入日程行の「納入時間」
[idx]["REQ_QTY"]　→　配列内のidx番目の納入日程行の「販売単位による受注数量」
[idx]["REQ_DLV_BL"]　→　配列内のidx番目の納入日程行の「出荷ブロック中の納入日程行」
[idx]["SCHED_TYPE"]　→　配列内のidx番目の納入日程行の「納入日程カテゴリ」
[idx]["TP_DATE"]　→　配列内のidx番目の納入日程行の「輸送計画日付」
[idx]["MS_DATE"]　→　配列内のidx番目の納入日程行の「品目利用可能日」
[idx]["LOAD_DATE"]　→　配列内のidx番目の納入日程行の「積載日付」
[idx]["GI_DATE"]　→　配列内のidx番目の納入日程行の「出庫日付」
[idx]["TP_TIME"]　→　配列内のidx番目の納入日程行の 「輸送計画 - 時間 (現地時間/出荷ポイント参照)」
[idx]["MS_TIME"]　→　配列内のidx番目の納入日程行の 「品目供給ステージ (現地時刻: プラント参照)」
[idx]["LOAD_TIME"]　→　配列内のidx番目の納入日程行の「積載時刻 (現地時間: 出荷ポイント)」
[idx]["GI_TIME"]　→　配列内のidx番目の納入日程行の「出庫時刻 (現地時間 - プラント参照)」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の納入日程行の「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の納入日程行の「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の納入日程行の「論理システム」
[idx]["DLV_DATE"]　→　配列内のidx番目の納入日程行の「納入日程日付」
[idx]["DLV_TIME"]　→　配列内のidx番目の納入日程行の「納入時間」
[idx]["REL_TYPE"]　→　配列内のidx番目の納入日程行の「承認タイプ」
[idx]["PLAN_SCHED_TYPE"]　→　配列内のidx番目の納入日程行の「納入日程行タイプ EDI」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationSchedulesInXList

Array getQuotationSchedulesInXList ()

納入日程行チェックボックスを取得します。
返却値
Array 納入日程行チェックボックス

納入日程行チェックボックスオブジェクトの構成は以下のとおりです。
納入日程行チェックボックス
オブジェクト
(Object)
ITM_NUMBER 販売伝票明細 (String)
SCHED_LINE 納入日程行 (String)
UPDATEFLAG 更新区分 (String)
REQ_DATE 関連ユーザデータ項目の更新情報 (String)
DATE_TYPE 関連ユーザデータ項目の更新情報 (String)
REQ_TIME 関連ユーザデータ項目の更新情報 (String)
REQ_QTY 関連ユーザデータ項目の更新情報 (String)
REQ_DLV_BL 関連ユーザデータ項目の更新情報 (String)
SCHED_TYPE 関連ユーザデータ項目の更新情報 (String)
TP_DATE 関連ユーザデータ項目の更新情報 (String)
MS_DATE 関連ユーザデータ項目の更新情報 (String)
LOAD_DATE 関連ユーザデータ項目の更新情報 (String)
GI_DATE 関連ユーザデータ項目の更新情報 (String)
TP_TIME 関連ユーザデータ項目の更新情報 (String)
MS_TIME 関連ユーザデータ項目の更新情報 (String)
LOAD_TIME 関連ユーザデータ項目の更新情報 (String)
GI_TIME 関連ユーザデータ項目の更新情報 (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
DLV_DATE 関連ユーザデータ項目の更新情報 (String)
DLV_TIME 関連ユーザデータ項目の更新情報 (String)
REL_TYPE 関連ユーザデータ項目の更新情報 (String)
PLAN_SCHED_TYPE 関連ユーザデータ項目の更新情報 (String)

納入日程行チェックボックスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の納入日程行チェックボックスの「販売伝票明細」
[idx]["SCHED_LINE"]　→　配列内のidx番目の納入日程行チェックボックスの「納入日程行」
[idx]["UPDATEFLAG"]　→　配列内のidx番目の納入日程行チェックボックスの「更新区分」
[idx]["REQ_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["DATE_TYPE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REQ_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REQ_QTY 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REQ_DLV_BL 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["SCHED_TYPE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["TP_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["MS_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["LOAD_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["GI_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["TP_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["MS_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["LOAD_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["GI_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の納入日程行チェックボックスの「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の納入日程行チェックボックスの「オブジェクトキー」
[idx]["DLV_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["DLV_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REL_TYPE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["PLAN_SCHED_TYPE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationTextList

Array getQuotationTextList ()

テキストを取得します。
返却値
Array テキスト

テキストオブジェクトの構成は以下のとおりです。
テキスト
オブジェクト
(Object)
DOC_NUMBE 販売伝票 (String)
ITM_NUMBE 販売伝票明細 (String)
TEXT_ID テキスト ID (String)
LANGU 言語キー (String)
LANGU_ISO ISO 639 準拠の言語 (String)
FORMAT_COL タグ列 (String)
TEXT_LINE テキスト行 (String)
FUNCTION 機能 (String)

テキストオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["DOC_NUMBE"]　→　配列内のidx番目のテキストの「販売伝票」
[idx]["ITM_NUMBE"]　→　配列内のidx番目のテキストの「販売伝票明細」
[idx]["TEXT_ID"]　→　配列内のidx番目のテキストの「テキスト ID」
[idx]["LANGU"]　→　配列内のidx番目のテキストの「言語キー」
[idx]["LANGU_ISO"]　→　配列内のidx番目のテキストの「ISO 639 準拠の言語」
[idx]["FORMAT_COL"]　→　配列内のidx番目のテキストの「タグ列」
[idx]["TEXT_LINE"]　→　配列内のidx番目のテキストの「テキスト行」
[idx]["FUNCTION"]　→　配列内のidx番目のテキストの「機能」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getSalesdocument

Object getSalesdocument ()

販売管理伝票番号を取得します。

返却値
Object 販売管理伝票番号
getSalesdocumentin

Object getSalesdocumentin ()

販売管理伝票番号を取得します。

返却値
Object 販売管理伝票番号
getSender

Object getSender ()

論理システム - 送信者を取得します。
返却値
Object 論理システム - 送信者

論理システム - 送信者オブジェクトの構成は以下のとおりです。
論理システム - 送信者
オブジェクト
(Object)
LOG_SYSTEM 論理システム (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getTestrun

Object getTestrun ()

テスト実行を取得します。
返却値
Object テスト実行
setBehaveWhenError

void setBehaveWhenError (Object value)

エラー処理を設定します｡
パラメータ
value Object エラー処理
返却値
void
setBinaryRelationshiptype

void setBinaryRelationshiptype (Object value)

バイナリ関連タイプ (専用)を設定します｡
パラメータ
value Object バイナリ関連タイプ (専用)
返却値
void
setConvert

void setConvert (Object value)

取引先機能/受注伝票タイプの変換を設定します｡
パラメータ
value Object 取引先機能/受注伝票タイプの変換
返却値
void
setIntNumberAssignment

void setIntNumberAssignment (Object value)

明細番号内部採番を設定します｡
パラメータ
value Object 明細番号内部採番
返却値
void
setSalesdocumentin

void setSalesdocumentin (Object value)

見積伝票番号を設定します｡
パラメータ
value Object 見積伝票番号
返却値
void
setStrParam

void setStrParam (String paramStr ,String paramName ,Object value)

構造型の項目に値をセットします。
パラメータ
paramStr | String | 構造名
paramName | String | 項目名
value | Object | セットする値
返却値
void
setTblParam

void setTblParam (String paramTable ,String paramName ,Object value ,int index)

テーブル型の項目に値をセットします。
パラメータ
paramTable | String | テーブル名
paramName | String | 項目名
value | Object | セットする値
index | int | レコード番号
返却値
void
setTestrun

void setTestrun (Object value)

テスト実行を設定します｡
パラメータ
value Object テスト実行
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 SalesOrderCreateFromDat2Controller オブジェクト

受注伝票登録コントローラクラス。

機能は以下の通り
  • 受注伝票を登録します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
SalesOrderCreateFromDat2Controller ()
コンストラクタ｡
SalesOrderCreateFromDat2Controller (ConnectionManager connectionManager)
コンストラクタ。
SalesOrderCreateFromDat2Controller (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより販売伝票を登録します。
String | getBapiReturnErrMessage () ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage () プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。
Object | getBinaryRelationshiptype () バイナリ関連タイプ (専用)を取得します。
Object | getConvert () 変換: 取引先機能 + 受注伝票タイプを取得します。
Array | getExtensionInList () VBAK、VBAP、VBEP のカスタマ拡張を取得します。
Object | getIntNumberAssignment () 明細番号内部採番を取得します。
Object | getLogicSwitch () 内部制御パラメータを取得します。
Array | getOrderCcardList () クレジットカードデータを取得します。
Array | getOrderCfgsBlobList () 選定: BLOB 内部データ (SCE)を取得します。
Array | getOrderCfgsInstList () 選定: インスタンスを取得します。
Array | getOrderCfgsPartOfList () 選定: 部分設定を取得します。
Array | getOrderCfgsRefInstList () 選定: 参照明細/インスタンスを取得します。
Array | getOrderCfgsRefList () 選定: 参照データを取得します。
Array | getOrderCfgsValueList () 選定: 特性値を取得します。
Array | getOrderCfgsVkList () 選定: バリアント条件キーを取得します。
Array | getOrderConditionsInList () 条件を取得します。
Array | getOrderConditionsInXList () 受注における条件更新の通信項目を取得します。
Object | getOrderHeaderIn () 受注伝票ヘッダデータを取得します。
Object | getOrderHeaderInX () ヘッダデータチェックボックスを取得します。
Array | getOrderItemsInList () 明細データを取得します。
Array | getOrderItemsInXList () 明細データチェックボックスを取得します。
Array | getOrderKeysList () 参照キーの出力を取得します。
Array | getOrderPartnersList () 伝票取引先を取得します。
Array | getOrderSchedulesInList () 納入日程行を取得します。
Array | getOrderSchedulesInXList () 納入日程行チェックボックスを取得します。
Array | getOrderTextList () テキストを取得します。
Array | getPartnerAddressesList () アドレス (組織/会社) 用 BAPI 参照構造を取得します。
Object | getSalesdocument () 生成された伝票の番号を取得します。
Object | getSalesdocumentin () 販売管理伝票番号を取得します。
Object | getSender () 論理システム - 送信者を取得します。
Object | getTestrun () テスト実行を取得します。
void | setBehaveWhenError (Object value) エラー処理を設定します｡
void | setBinaryRelationshiptype (Object value) バイナリ関連タイプ (専用)を設定します｡
void | setConvert (Object value) 変換: 取引先機能 + 受注伝票タイプを設定します｡
void | setIntNumberAssignment (Object value) 明細番号内部採番を設定します｡
void | setSalesdocumentin (Object value) 販売管理伝票番号を設定します｡
void | setStrParam (String paramStr ,String paramName ,Object value) 構造型の項目に値をセットします。
void | setTblParam (String paramTable ,String paramName ,Object value ,int index) テーブル型の項目に値をセットします。
void | setTestrun (Object value) テスト実行を設定します｡
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
SalesOrderCreateFromDat2Controller

SalesOrderCreateFromDat2Controller ()
コンストラクタ｡
SalesOrderCreateFromDat2Controller

SalesOrderCreateFromDat2Controller (ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、SalesOrderCreateFromDat2Controller#executeBapi()実行後に必ず ConnectionManager#commit()またはConnectionManager#rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。
パラメータ
connectionManager ConnectionManager コネクションマネージャー
SalesOrderCreateFromDat2Controller

SalesOrderCreateFromDat2Controller (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより販売伝票を登録します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getBapiReturnErrMessage

String getBapiReturnErrMessage ()

ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡
返却値
String BAPI実行結果エラーとなった全てのメッセージ情報
getBapiReturnMessage

String getBapiReturnMessage ()

プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡
返却値
String プロパティファイルでオートコミット条件に一致したType情報のメッセージ情報
getBinaryRelationshiptype

Object getBinaryRelationshiptype ()

バイナリ関連タイプ (専用)を取得します。
返却値
Object バイナリ関連タイプ（専用）
getConvert

Object getConvert ()

変換: 取引先機能 + 受注伝票タイプを取得します。
返却値
Object 変換: 取引先機能 + 受注伝票タイプ
getExtensionInList

Array getExtensionInList ()

VBAK、VBAP、VBEP のカスタマ拡張を取得します。
返却値
Array VBAK、VBAP、VBEP のカスタマ拡張

VBAK、VBAP、VBEP のカスタマ拡張の構成は以下のとおりです。
VBAK、VBAP、VBEP のカスタマ拡張
オブジェクト
(Object)
STRUCTURE BAPI テーブル拡張の構造名 (String)
VALUEPART1 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART2 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART3 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART4 BAPI 拡張パラメータのデータ部分 (String)

VBAK、VBAP、VBEP のカスタマ拡張オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["STRUCTURE"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI テーブル拡張の構造名」
[idx]["VALUEPART1"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART2"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART3"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART4"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI 拡張パラメータのデータ部分」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getIntNumberAssignment

Object getIntNumberAssignment ()

明細番号内部採番を取得します。
返却値
Object 明細番号内部採番
getLogicSwitch

Object getLogicSwitch ()

内部制御パラメータを取得します。
返却値
Object 内部制御パラメータ

内部制御パラメータオブジェクトの構成は以下のとおりです。
内部制御パラメータ
オブジェクト
(Object)
PRICING 価格設定タイプ (String)
ATP_WRKMOD ATP セッション: 結果取得/新規決定 APO-ATP (String)
SCHEDULING 単一文字フラグ (String)
NOSTRUCTURE チェックボックス (String)
COND_HANDL 選択: 条件行処理 (SD 伝票変更) (String)

内部制御パラメータオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PRICING"]　→　配列内のidx番目の内部制御パラメータの「価格設定タイプ」
[idx]["ATP_WRKMOD"]　→　配列内のidx番目の内部制御パラメータの 「ATP セッション: 結果取得/新規決定 APO-ATP」
[idx]["SCHEDULING"]　→　配列内のidx番目の内部制御パラメータの「単一文字フラグ」
[idx]["NOSTRUCTURE"]　→　配列内のidx番目の内部制御パラメータの「チェックボックス」
[idx]["COND_HANDL"]　→　配列内のidx番目の内部制御パラメータの 「選択: 条件行処理 (SD 伝票変更)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderCcardList

Array getOrderCcardList ()

クレジットカードデータを取得します。
返却値
Array クレジットカードデータ

クレジットカードデータオブジェクトの構成は以下のとおりです。
引合伝票ヘッダデータ
オブジェクト
(Object)
CC_TYPE 支払カードタイプ: カードタイプ (String)
CC_NUMBER 支払カード: カード番号 (String)
CC_VALID_T 支払カード: 有効終了日 (String)
CC_NAME 支払カード: カード所有者の氏名 (String)
BILLAMOUNT 請求金額: 請求計画に請求日付が指定されている場合 (String)
AUTH_FLAG 支払カード: 振替権限 (String)
AUTHAMOUNT 支払カード: 承認額 (String)
CURRENCY 通貨コード (String)
CURR_ISO ISO コード通貨 (String)
AUTH_DATE 支払カード: 承認日 (String)
AUTH_TIME 支払カード: 承認時刻 (String)
AUTH_CC_NO 支払カード: 承認番号 (String)
AUTH_REFNO 支払カード: 決済代行会社の権限参照コード (String)
CC_REACT 支払カード: 権限確認に対する応答 (String)
CC_RE_AMOUNT BAPI インタフェースの通貨金額 (String)
GL_ACCOUNT G/L 勘定コード (String)
CC_STAT_EX 支払カード: 外部システム呼出時のステータス (String)
CC_REACT_T 支払カード: 結果テキスト (String)
VIRT_CARD チェックボックス (String)
MERCHIDCL 支払カード: 決済代行会社のマーチャント ID (String)
PRE_AUTH 支払カード: 事前承認 (String)
CC_SEQ_NO 支払カード: 支払カード - 接尾辞 (String)
AMOUNTCHAN 支払カード: 金額変更 (String)
AUTHORTYPE 支払カード: 承認タイプ (String)
DATAORIGIN 支払カード: 入力モード (String)
RADRCHECK1 支払カード: 住所チェックの結果 (住所結果) (String)
RADRCHECK2 支払カード: 住所チェックの結果 (住所承認) (String)
RADRCHECK3 支払カード: 住所チェックの結果 (郵便番号結果) (String)
RCARDCHECK 支払カード: カードチェックの結果 (返信コード) (String)
CC_LIMITED 支払カード: 限度額 (String)
CC_VERIF_VALUE カード照合額 (String)
CC_CTRL_FIELD カード照合額の制御項目 (String)
CC_IN_USE_ST カード照合額の使用ステータス (String)

クレジットカードデータオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CC_TYPE"]　→　配列内のidx番目のクレジットカードデータの「支払カードタイプ: カードタイプ」
[idx]["CC_NUMBER"]　→　配列内のidx番目のクレジットカードデータの「支払カード: カード番号」
[idx]["CC_VALID_T"]　→　配列内のidx番目のクレジットカードデータの「支払カード: 有効終了日」
[idx]["CC_NAME"]　→　配列内のidx番目のクレジットカードデータの「支払カード: カード所有者の氏名」
[idx]["BILLAMOUNT"]　→　配列内のidx番目のクレジットカードデータの 「請求金額: 請求計画に請求日付が指定されている場合」
[idx]["AUTH_FLAG"]　→　配列内のidx番目のクレジットカードデータの「支払カード: 振替権限」
[idx]["AUTHAMOUNT"]　→　配列内のidx番目のクレジットカードデータの「支払カード: 承認額」
[idx]["CURRENCY"]　→　配列内のidx番目のクレジットカードデータの「通貨コード」
[idx]["CURR_ISO"]　→　配列内のidx番目のクレジットカードデータの「ISO コード通貨」
[idx]["AUTH_DATE"]　→　配列内のidx番目のクレジットカードデータの「支払カード: 承認日」
[idx]["AUTH_TIME"]　→　配列内のidx番目のクレジットカードデータの「支払カード: 承認時刻」
[idx]["AUTH_CC_NO"]　→　配列内のidx番目のクレジットカードデータの「支払カード: 承認番号」
[idx]["AUTH_REFNO"]　→　配列内のidx番目のクレジットカードデータの 「支払カード: 決済代行会社の権限参照コード」
[idx]["CC_REACT"]　→　配列内のidx番目のクレジットカードデータの 「支払カード: 権限確認に対する応答」
[idx]["CC_RE_AMOUNT"]　→　配列内のidx番目のクレジットカードデータの 「BAPI インタフェースの通貨金額」
[idx]["GL_ACCOUNT"]　→　配列内のidx番目のクレジットカードデータの「G/L 勘定コード」
[idx]["CC_STAT_EX"]　→　配列内のidx番目のクレジットカードデータの 「支払カード: 外部システム呼出時のステータス」
[idx]["CC_REACT_T"]　→　配列内のidx番目のクレジットカードデータの「支払カード: 結果テキスト」
[idx]["VIRT_CARD"]　→　配列内のidx番目のクレジットカードデータの「チェックボックス」
[idx]["MERCHIDCL"]　→　配列内のidx番目のクレジットカードデータの 「支払カード: 決済代行会社のマーチャント ID」
[idx]["PRE_AUTH"]　→　配列内のidx番目のクレジットカードデータの「支払カード: 事前承認」
[idx]["CC_SEQ_NO"]　→　配列内のidx番目のクレジットカードデータの「支払カード: 支払カード - 接尾辞」
[idx]["AMOUNTCHAN"]　→　配列内のidx番目のクレジットカードデータの「支払カード:金額変更」
[idx]["AUTHORTYPE"]　→　配列内のidx番目のクレジットカードデータの「支払カード:承認タイプ」
[idx]["DATAORIGIN"]　→　配列内のidx番目のクレジットカードデータの「支払カード: 入力モード」
[idx]["RADRCHECK1"]　→　配列内のidx番目のクレジットカードデータの 「支払カード: 住所チェックの結果 (住所結果)」
[idx]["RADRCHECK2"]　→　配列内のidx番目のクレジットカードデータの 「支払カード: 住所チェックの結果 (住所承認)」
[idx]["RADRCHECK3"]　→　配列内のidx番目のクレジットカードデータの 「支払カード: 住所チェックの結果 (郵便番号結果)」
[idx]["RCARDCHECK"]　→　配列内のidx番目のクレジットカードデータの 「支払カード: カードチェックの結果 (返信コード)」
[idx]["CC_LIMITED"]　→　配列内のidx番目のクレジットカードデータの「支払カード: 限度額」
[idx]["CC_VERIF_VALUE"]　→　配列内のidx番目のクレジットカードデータの「カード照合額」
[idx]["CC_CTRL_FIELD"]　→　配列内のidx番目のクレジットカードデータの「カード照合額の制御項目」
[idx]["CC_IN_USE_ST"]　→　配列内のidx番目のクレジットカードデータの 「カード照合額の使用ステータス」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderCfgsBlobList

Array getOrderCfgsBlobList ()

選定: BLOB 内部データ (SCE)を取得します。
返却値
Array 選定: BLOB 内部データ (SCE)

選定: BLOB 内部データ (SCE)オブジェクトの構成は以下のとおりです。
CONFIG_ID 外部選定 ID (仮) (String)
CONTEXT CU: 選定の BLOB. (SCE) (String)

選定: BLOB 内部データ (SCE)オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: BLOB 内部データ (SCE)の 「外部選定 ID (仮)」
[idx]["CONTEXT"]　→　配列内のidx番目の選定: BLOB 内部データ (SCE)の 「CU: 選定の BLOB. (SCE)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderCfgsInstList

Array getOrderCfgsInstList ()

選定: インスタンスを取得します。
返却値
Array 選定: インスタンス

選定: インスタンスオブジェクトの構成は以下のとおりです。
選定: インスタンス
オブジェクト
(Object)
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)
OBJ_TYPE 対象タイプ (String)
CLASS_TYPE クラスタイプ (String)
OBJ_KEY 対象キー (String)
OBJ_TXT 言語依存対象テキスト (String)
QUANTITY インスタンス数量 (String)
AUTHOR 報告書提案済 (String)
QUANTITY_UNIT 数量単位 (String)
COMPLETE 一般区分 (String)
CONSISTENT 一般区分 (String)
OBJECT_GUID インスタンス用 TYPE_OF ステートメントの GUID (String)
PERSIST_ID インスタンス番号 (固定) (String)
PERSIST_ID_TYPE インスタンス番号タイプ (固定) (String)

選定: インスタンスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: インスタンスの「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の選定: インスタンスの「選定におけるインスタンス番号」
[idx]["OBJ_TYPE"]　→　配列内のidx番目の選定: インスタンスの「対象タイプ」
[idx]["CLASS_TYPE"]　→　配列内のidx番目の選定: インスタンスの「クラスタイプ」
[idx]["OBJ_KEY"]　→　配列内のidx番目の選定: インスタンスの「対象キー」
[idx]["OBJ_TXT"]　→　配列内のidx番目の選定: インスタンスの「言語依存対象テキスト」
[idx]["QUANTITY"]　→　配列内のidx番目の選定: インスタンスの「インスタンス数量」
[idx]["AUTHOR"]　→　配列内のidx番目の選定: インスタンスの「報告書提案済」
[idx]["QUANTITY_UNIT"]　→　配列内のidx番目の選定: インスタンスの「数量単位」
[idx]["COMPLETE"]　→　配列内のidx番目の選定: インスタンスの「一般区分」
[idx]["CONSISTENT"]　→　配列内のidx番目の選定: インスタンスの「一般区分」
[idx]["OBJECT_GUID"]　→　配列内のidx番目の選定: インスタンスの 「インスタンス用 TYPE_OF ステートメントの GUID」
[idx]["PERSIST_ID"]　→　配列内のidx番目の選定: インスタンスの「インスタンス番号 (固定)」
[idx]["PERSIST_ID_TYPE"]　→　配列内のidx番目の選定: インスタンスの 「インスタンス番号タイプ (固定)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderCfgsPartOfList

Array getOrderCfgsPartOfList ()

選定: 部分設定を取得します。
返却値
Array 選定: 部分設定

選定: 部分設定オブジェクトの構成は以下のとおりです。
選定: 部分設定
オブジェクト
(Object)
CONFIG_ID 外部選定 ID (仮) (String)
PARENT_ID 選定におけるインスタンス番号 (String)
INST_ID 選定におけるインスタンス番号 (String)
PART_OF_NO Part_of 明細番号 (String)
OBJ_TYPE 対象タイプ (String)
CLASS_TYPE クラスタイプ (String)
OBJ_KEY 対象キー (String)
AUTHOR 報告書提案済 (String)
SALES_RELEVANT この部品は販売に関連しています (String)
PART_OF_GUID インスタンス用 PART_OF ステートメントの GUID (String)

選定: 部分設定オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: 部分設定の「外部選定 ID (仮)」
[idx]["PARENT_ID"]　→　配列内のidx番目の選定: 部分設定の「選定におけるインスタンス番号」
[idx]["INST_ID"]　→　配列内のidx番目の選定: 部分設定の「選定におけるインスタンス番号」
[idx]["PART_OF_NO"]　→　配列内のidx番目の選定: 部分設定の「Part_of 明細番号」
[idx]["OBJ_TYPE"]　→　配列内のidx番目の選定: 部分設定の「対象タイプ」
[idx]["CLASS_TYPE"]　→　配列内のidx番目の選定: 部分設定の「クラスタイプ」
[idx]["OBJ_KEY"]　→　配列内のidx番目の選定: 部分設定の「対象キー」
[idx]["AUTHOR"]　→　配列内のidx番目の選定: 部分設定の「報告書提案済」
[idx]["SALES_RELEVANT"]　→　配列内のidx番目の選定: 部分設定の 「この部品は販売に関連しています」
[idx]["PART_OF_GUID"]　→　配列内のidx番目の選定: 部分設定の 「インスタンス用 PART_OF ステートメントの GUID」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderCfgsRefInstList

Array getOrderCfgsRefInstList ()

選定: 参照明細/インスタンスを取得します。
返却値
Array 選定: 参照明細/インスタンス

選定: 参照明細/インスタンスオブジェクトの構成は以下のとおりです。
POSEX 外部明細番号 (String)
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)

選定: 参照明細/インスタンスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["POSEX"]　→　配列内のidx番目の選定: 参照明細/インスタンスの「外部明細番号」
[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: 参照明細/インスタンスの 「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の選定: 参照明細/インスタンスの 「選定におけるインスタンス番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderCfgsRefList

Array getOrderCfgsRefList ()

選定: 参照データを取得します。
返却値
Array 選定: 参照データ

選定: 参照データオブジェクトの構成は以下のとおりです。
選定: 参照データ
オブジェクト
(Object)
POSEX 外部明細番号 (String)
CONFIGconfig_id 外部選定 ID (仮) (String)
ROOT_Iroot_id 選定におけるインスタンス番号 (String)
SCE scCUX: 選定タイプ (String)
KBNAMEkbname ナレッジベースオブジェクト (String)
KBVERSkbversion SCE ナレッジベースの実行時バージョン (String)
COMPLEcomplete 一般区分 (String)
CONSISconsistent 一般区分 (String)
CFGINFcfginfo CU: 選定の BLOB (SCE) (String)
KBPROFkbprofile ナレッジベースプロファイル (String)
KBLANGkblanguage システム設定の言語 (String)
CBASE_cbase_id インスタンス番号 (固定) (String)
CBASE_cbase_id_type インスタンス番号タイプ (固定) (String)

選定: 参照データオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["POSEX"]　→　配列内のidx番目の選定: 参照データの「外部明細番号」
[idx]["CONFIGconfig_id"]　→　配列内のidx番目の選定: 参照データの 「外部選定 ID (仮)」
[idx]["ROOT_Iroot_id"]　→　配列内のidx番目の選定: 参照データの 「選定におけるインスタンス番号」
[idx]["SCE"]　→　配列内のidx番目の選定: 参照データの「scCUX: 選定タイプ」
[idx]["KBNAMEkbname"]　→　配列内のidx番目の選定: 参照データの「ナレッジベースオブジェクト」
[idx]["KBVERSkbversion"]　→　配列内のidx番目の選定: 参照データの 「SCE ナレッジベースの実行時バージョン」
[idx]["COMPLEcomplete"]　→　配列内のidx番目の選定: 参照データの「一般区分」
[idx]["CONSISconsistent"]　→　配列内のidx番目の選定: 参照データの「一般区分」
[idx]["CFGINFcfginfo"]　→　配列内のidx番目の選定: 参照データの 「CU: 選定の BLOB (SCE)」
[idx]["KBPROFkbprofile"]　→　配列内のidx番目の選定: 参照データの 「ナレッジベースプロファイル」
[idx]["KBLANGkblanguage"]　→　配列内のidx番目の選定: 参照データの「システム設定の言語」
[idx]["CBASE_cbase_id"]　→　配列内のidx番目の選定: 参照データの 「インスタンス番号 (固定)」
[idx]["CBASE_cbase_id_type"]　→　配列内のidx番目の選定: 参照データの 「インスタンス番号タイプ (固定)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderCfgsValueList

Array getOrderCfgsValueList ()

選定: 特性値を取得します。
返却値
Array 選定: 特性値

選定: 特性値オブジェクトの構成は以下のとおりです。
選定: 特性値
オブジェクト
(Object)
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)
CHARC 特性名 (String)
CHARC_TXT 言語依存特性テキスト (String)
VALUE 特性値 (String)
VALUE_TXT 特性値の言語依存テキスト (String)
AUTHOR 報告書提案済 (String)
VALUE_TO 特性値 (String)
VALCODE 値タイプ: 範囲制限 - 単一値 (String)

選定: 特性値オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: 特性値の「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の選定: 特性値の「選定におけるインスタンス番号」
[idx]["CHARC"]　→　配列内のidx番目の選定: 特性値の「特性名」
[idx]["CHARC_TXT"]　→　配列内のidx番目の選定: 特性値の「言語依存特性テキスト」
[idx]["VALUE"]　→　配列内のidx番目の選定: 特性値の「特性値」
[idx]["VALUE_TXT"]　→　配列内のidx番目の選定: 特性値の「特性値の言語依存テキスト」
[idx]["AUTHOR"]　→　配列内のidx番目の選定: 特性値の「報告書提案済」
[idx]["VALUE_TO"]　→　配列内のidx番目の選定: 特性値の「特性値」
[idx]["VALCODE"]　→　配列内のidx番目の選定: 特性値の「値タイプ: 範囲制限 - 単一値」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderCfgsVkList

Array getOrderCfgsVkList ()

選定: バリアント条件キーを取得します。
返却値
Array 選定: バリアント条件キー

選定: バリアント条件キーオブジェクトの構成は以下のとおりです。
選定: バリアント条件キー
オブジェクト
(Object)
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)
VKEY バリアント条件名 (String)
FACTOR バリアント条件の加重係数 (String)

選定: バリアント条件キーオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: バリアント条件キーの「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の選定: バリアント条件キーの「選定におけるインスタンス番号」
[idx]["VKEY"]　→　配列内のidx番目の選定: バリアント条件キーの「バリアント条件名」
[idx]["FACTOR"]　→　配列内のidx番目の選定: バリアント条件キーの「バリアント条件の加重係数」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderConditionsInList

Array getOrderConditionsInList ()

条件を取得します。
返却値
Array 条件

条件オブジェクトの構成は以下のとおりです。
条件
オブジェクト
(Object)
ITM_NUMBER 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件カウンタ (String)
COND_TYPE 条件タイプ (String)
COND_VALUE 条件レート (String)
CURRENCY 通貨コード (String)
COND_UNIT 条件単位 (String)
COND_P_UNT 価格条件単位 (String)
CURR_ISO ISO コード通貨 (String)
CD_UNT_ISO 条件数量単位 (ISO コード) (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)
APPLICATIO アプリケーション (String)
CONPRICDAT 条件価格設定日付 (String)
CALCTYPCON 条件計算タイプ (String)
CONBASEVAL 条件基礎値 (String)
CONEXCHRAT 現地通貨への換算レートに対する条件 (String)
NUMCONVERT 条件単位を基本単位へ変換する分子 (String)
DENOMINATO 条件単位を基本単位へ変換する分母 (String)
CONDTYPE 条件カテゴリ (例: 税、運賃、価格、原価) (String)
STAT_CON 統計に適用する条件 (String)
SCALETYPE スケールタイプ (String)
ACCRUALS 見越額関連条件 (運賃など) (String)
CONINVOLST 請求書一覧条件 (String)
CONDORIGIN 条件生成区分 (String)
GROUPCOND グループ条件区分 (String)
COND_UPDAT 条件更新 (String)
ACCESS_SEQ 検索順序 - 検索番号 (String)
CONDCOUNT 条件連続番号 (String)
ROUNDOFFDI BAPI の通貨額 (小数点以下９桁) (String)
CONDVALUE 条件金額 (String)
CURRENCY_2 販売伝票通貨 (String)
CURR_ISO_2 ISO コード通貨 (String)
CONDCNTRL 条件管理 (String)
CONDISACTI 無効条件 (String)
CONDCLASS 条件クラス (String)
FACTBASVAL 条件基礎値に対する要因 (String)
SCALEBASIN スケール基準区分 (String)
SCALBASVAL 条件のスケール基準値 (String)
UNITMEASUR 条件スケール単位 (String)
ISO_UNIT 単位の ISO コード (String)
CURRENCKEY スケール通貨 (String)
CURRENISO ISO コード通貨 (String)
CONDINCOMP 会社間請求の条件 (String)
CONDCONFIG システム設定の条件 (String)
CONDCHAMAN 条件 (マニュアル変更済) (String)
COND_NO 条件レコード番号 (String)
TAX_CODE 消費税コード (String)
VARCOND バリアント条件 (String)
ACCOUNTKEY 勘定キー (String)
ACCOUNT_KE 勘定キー 見越/引当 (String)
WT_WITHCD 源泉徴収税コード (String)
STRUCTCOND 構造条件 (String)
FACTCONBAS 条件基準の係数 (期間) (String)
CONDCOINHD 条件カウンタ (ヘッダ条件) (String)

条件オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の条件の「条件明細番号」
[idx]["COND_ST_NO"]　→　配列内のidx番目の条件の「ステップ番号」
[idx]["COND_COUNT"]　→　配列内のidx番目の条件の「条件カウンタ」
[idx]["COND_TYPE"]　→　配列内のidx番目の条件の「条件タイプ」
[idx]["COND_VALUE"]　→　配列内のidx番目の条件の「条件レート」
[idx]["CURRENCY"]　→　配列内のidx番目の条件の「通貨コード」
[idx]["COND_UNIT"]　→　配列内のidx番目の条件の「条件単位」
[idx]["COND_P_UNT"]　→　配列内のidx番目の条件の「価格条件単位」
[idx]["CURR_ISO"]　→　配列内のidx番目の条件の「ISO コード通貨」
[idx]["CD_UNT_ISO"]　→　配列内のidx番目の条件の「条件数量単位 (ISO コード)」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の条件の「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の条件の「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の条件の「論理システム」
[idx]["APPLICATIO"]　→　配列内のidx番目の条件の「アプリケーション」
[idx]["CONPRICDAT"]　→　配列内のidx番目の条件の「条件価格設定日付」
[idx]["CALCTYPCON"]　→　配列内のidx番目の条件の「条件計算タイプ」
[idx]["CONBASEVAL"]　→　配列内のidx番目の条件の「条件基礎値」
[idx]["CONEXCHRAT"]　→　配列内のidx番目の条件の「現地通貨への換算レートに対する条件」
[idx]["NUMCONVERT"]　→　配列内のidx番目の条件の「条件単位を基本単位へ変換する分子」
[idx]["DENOMINATO"]　→　配列内のidx番目の条件の「条件単位を基本単位へ変換する分母」
[idx]["CONDTYPE"]　→　配列内のidx番目の条件の「条件カテゴリ (例: 税、運賃、価格、原価)」
[idx]["STAT_CON"]　→　配列内のidx番目の条件の「統計に適用する条件」
[idx]["SCALETYPE"]　→　配列内のidx番目の条件の「スケールタイプ」
[idx]["ACCRUALS"]　→　配列内のidx番目の条件の「見越額関連条件 (運賃など)」
[idx]["CONINVOLST"]　→　配列内のidx番目の条件の「請求書一覧条件」
[idx]["CONDORIGIN"]　→　配列内のidx番目の条件の「条件生成区分」
[idx]["GROUPCOND"]　→　配列内のidx番目の条件の「グループ条件区分」
[idx]["COND_UPDAT"]　→　配列内のidx番目の条件の「条件更新」
[idx]["ACCESS_SEQ"]　→　配列内のidx番目の条件の「検索順序 - 検索番号」
[idx]["CONDCOUNT"]　→　配列内のidx番目の条件の「条件連続番号」
[idx]["ROUNDOFFDI"]　→　配列内のidx番目の条件の「BAPI の通貨額 (小数点以下９桁)」
[idx]["CONDVALUE"]　→　配列内のidx番目の条件の「条件金額」
[idx]["CURRENCY_2"]　→　配列内のidx番目の条件の「販売伝票通貨」
[idx]["CURR_ISO_2"]　→　配列内のidx番目の条件の「ISO コード通貨」
[idx]["CONDCNTRL"]　→　配列内のidx番目の条件の「条件管理」
[idx]["CONDISACTI"]　→　配列内のidx番目の条件の「無効条件」
[idx]["CONDCLASS"]　→　配列内のidx番目の条件の「条件クラス」
[idx]["FACTBASVAL"]　→　配列内のidx番目の条件の「条件基礎値に対する要因」
[idx]["SCALEBASIN"]　→　配列内のidx番目の条件の「スケール基準区分」
[idx]["SCALBASVAL"]　→　配列内のidx番目の条件の「条件のスケール基準値」
[idx]["UNITMEASUR"]　→　配列内のidx番目の条件の「条件スケール単位」
[idx]["ISO_UNIT"]　→　配列内のidx番目の条件の「単位の ISO コード」
[idx]["CURRENCKEY"]　→　配列内のidx番目の条件の「スケール通貨」
[idx]["CURRENISO"]　→　配列内のidx番目の条件の「ISO コード通貨」
[idx]["CONDINCOMP"]　→　配列内のidx番目の条件の「会社間請求の条件」
[idx]["CONDCONFIG"]　→　配列内のidx番目の条件の「システム設定の条件」
[idx]["CONDCHAMAN"]　→　配列内のidx番目の条件の「条件 (マニュアル変更済)」
[idx]["COND_NO"]　→　配列内のidx番目の条件の「条件レコード番号」
[idx]["TAX_CODE"]　→　配列内のidx番目の条件の「消費税コード」
[idx]["VARCOND"]　→　配列内のidx番目の条件の「バリアント条件」
[idx]["ACCOUNTKEY"]　→　配列内のidx番目の条件の「勘定キー」
[idx]["ACCOUNT_KE"]　→　配列内のidx番目の条件の「勘定キー 見越/引当」
[idx]["WT_WITHCD"]　→　配列内のidx番目の条件の「源泉徴収税コード」
[idx]["STRUCTCOND"]　→　配列内のidx番目の条件の「構造条件」
[idx]["FACTCONBAS"]　→　配列内のidx番目の条件の「条件基準の係数 (期間)」
[idx]["CONDCOINHD"]　→　配列内のidx番目の条件の「条件カウンタ (ヘッダ条件)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderConditionsInXList

Array getOrderConditionsInXList ()

受注における条件更新の通信項目を取得します。
返却値
Array 受注における条件更新の通信項目

受注における条件更新の通信項目オブジェクトの構成は以下のとおりです。
受注における条件更新の通信項目
オブジェクト
(Object)
ITM_NUMBER 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件連続番号 (String)
COND_TYPE 条件タイプ (String)
UPDATEFLAG 更新区分 (String)
COND_VALUE 関連ユーザデータ項目の更新情報 (String)
CURRENCY 関連ユーザデータ項目の更新情報 (String)
COND_UNIT 関連ユーザデータ項目の更新情報 (String)
COND_P_UNT 関連ユーザデータ項目の更新情報 (String)
VARCOND バリアント条件 (String)

受注における条件更新の通信項目オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の受注における条件更新の通信項目の「条件明細番号」
[idx]["COND_ST_NO"]　→　配列内のidx番目の受注における条件更新の通信項目の「ステップ番号」
[idx]["COND_COUNT"]　→　配列内のidx番目の受注における条件更新の通信項目の「条件連続番号」
[idx]["COND_TYPE"]　→　配列内のidx番目の受注における条件更新の通信項目の「条件タイプ」
[idx]["UPDATEFLAG"]　→　配列内のidx番目の受注における条件更新の通信項目の「更新区分」
[idx]["COND_VALUE"]　→　配列内のidx番目の受注における条件更新の通信項目の 「関連ユーザデータ項目の更新情報」
[idx]["CURRENCY"]　→　配列内のidx番目の受注における条件更新の通信項目の 「関連ユーザデータ項目の更新情報」
[idx]["COND_UNIT"]　→　配列内のidx番目の受注における条件更新の通信項目の 「関連ユーザデータ項目の更新情報」
[idx]["COND_P_UNT"]　→　配列内のidx番目の受注における条件更新の通信項目の 「関連ユーザデータ項目の更新情報」
[idx]["VARCOND"]　→　配列内のidx番目の受注における条件更新の通信項目の「バリアント条件」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderHeaderIn

Object getOrderHeaderIn ()

受注伝票ヘッダデータを取得します。
返却値
Object 受注伝票ヘッダデータ

受注伝票ヘッダデータオブジェクトの構成は以下のとおりです。
受注伝票ヘッダデータ
オブジェクト
(Object)
REFOBJTYPE オブジェクトタイプ(String)
REFOBJKEY オブジェクトキー(String)
REFDOCTYPE 参照オブジェクトの伝票タイプ(String)
DOC_TYPE 販売伝票タイプ(String)
COLLECT_NO 一括番号(String)
SALES_ORG 販売組織(String)
DISTR_CHAN 流通チャネル(String)
DIVISION 製品部門(String)
SALES_GRP 営業グループ(String)
SALES_OFF 営業所(String)
REQ_DATE_H 指定納入期日(String)
DATE_TYPE 提案日付タイプ(String)
PURCH_DATE 得意先発注日付(String)
PO_METHOD 得意先発注タイプ(String)
PO_SUPPLEM 得意先発注番号補足(String)
REF_1 得意先/仕入先の内部参照コード(String)
NAME 発注者名称(String)
TELEPHONE 電話番号(String)
PRICE_GRP 価格グループ (得意先)(String)
CUST_GROUP 得意先グループ(String)
SALES_DIST 販売地域(String)
PRICE_LIST 価格表タイプ(String)
INCOTERMS1 インコタームズ (1)(String)
INCOTERMS2 インコタームズ 2(String)
PMNTTRMS 支払条件キー(String)
DLV_BLOCK 出荷ブロック (伝票ヘッダ)(String)
BILL_BLOCK 販売管理伝票の請求ブロック(String)
ORD_REASON 受注理由 (取引理由)(String)
COMPL_DLV 一括納入区分(String)
PRICE_DATE 価格設定/外貨換算の実行日付(String)
QT_VALID_F 見積/引合有効開始日(String)
QT_VALID_T 見積の有効終了日(String)
CT_VALID_F 有効開始日付 (販売契約/品目提案)(String)
CT_VALID_T 有効終了日付 (販売契約/品目提案)(String)
CUST_GRP1 得意先グループ 1(String)
CUST_GRP2 得意先グループ 2(String)
CUST_GRP3 得意先グループ 3(String)
CUST_GRP4 得意先グループ 4(String)
CUST_GRP5 得意先グループ 5(String)
PURCH_NO_C 出荷先発注番号(String)
PURCH_NO_S 出荷先の得意先発注番号(String)
PO_DAT_S 出荷先の出荷先発注日付(String)
PO_METH_S 出荷先の出荷先発注タイプ(String)
REF_1_S 出荷先文字(String)
SD_DOC_CAT 販売管理伝票カテゴリ(String)
DOC_DATE 伝票日付 (受信日/送信日)(String)
WAR_DATE 保証期間の開始日付(String)
SHIP_COND 出荷条件(String)
PP_SEARCH 品目提案検索条件(String)
DUN_COUNT 得意先商談回数(String)
DUN_DATE 得意先との前回の商談日(String)
DLVSCHDUSE 用途区分(String)
PLDLVSTYP MRP: 出荷計画タイプ(String)
REF_DOC 参照伝票番号(String)
COMP_CDE_B 請求対象会社コード(String)
ALTTAX_CLS 代替税分類(String)
TAX_CLASS2 得意先税分類 2(String)
TAX_CLASS3 得意先税分類 3(String)
TAX_CLASS4 得意先に対する税クラス 4(String)
TAX_CLASS5 得意先に対する税クラス 5(String)
TAX_CLASS6 得意先に対する税クラス 6(String)
TAX_CLASS7 得意先に対する税クラス 7(String)
TAX_CLASS8 得意先に対する税クラス 8(String)
TAX_CLASS9 得意先に対する税クラス 9(String)
REF_DOC_L 参照伝票番号(String)
ASS_NUMBER 割当番号(String)
REFDOC_CAT 先行販売管理伝票の伝票カテゴリ(String)
ORDCOMB_IN 受注結合出荷区分(String)
BILL_SCHED 請求日程 (稼働日カレンダ指定)(String)
INVO_SCHED 請求書一覧日程 (稼働日カレンダ指定)(String)
MN_INVOICE マニュアル請求書更新(String)
EXRATE_FI FI 転記の換算レート (直接相場)(String)
ADD_VAL_DY 有効日からの日数(String)
FIX_VAL_DY 有効日日付(String)
PYMT_METH 支払方法(String)
ACCNT_ASGN 得意先の勘定設定グループ(String)
EXCHG_RATE 価格設定/統計の換算レート (直接引用)(String)
BILL_DATE 請求索引および印刷に対する請求日(String)
SERV_DATE サービス提供日(String)
DUNN_KEY 督促処理キー(String)
DUNN_BLOCK 督促処理保留(String)
PMTGAR_PRO 支払保証決定表(String)
DEPARTM_NO 部門コード(String)
REC_POINT 入荷ポイント(String)
DOC_NUM_FI ドキュメンタリクレジット処理: 内部番号(String)
CSTCNDGRP1 得意先条件グループ１(String)
CSTCNDGRP2 得意先条件グループ２(String)
CSTCNDGRP3 得意先条件グループ３(String)
CSTCNDGRP4 得意先条件グループ４(String)
CSTCNDGRP5 得意先条件グループ５(String)
DLV_TIME 契約出荷期間(String)
CURRENCY 販売伝票通貨(String)
CURR_ISO ISO コード通貨(String)
CREATED_BY オブジェクト登録者名(String)
TAXDEP_CTY 税出荷国(String)
TAXDST_CTY 税仕向国(String)
EUTRI_DEAL フラグ: EC 内三角取引(String)
MAST_CONTR グループマスタ契約番号(String)
REF_PROC 参照限定条件: 決定区分(String)
CHKPRTAUTH 取引先権限チェック(String)
CMLQTY_DAT 累積出荷数量日付(String)
VERSION 販売伝票バージョン番号(String)
NOTIF_NO 通知番号(String)
WBS_ELEM WBS 要素(String)
EXCH_RATE_FI_V FI 転記の換算レート (間接相場)(String)
EXCHG_RATE_V 価格設定/統計の換算レート (間接引用)(String)
FKK_CONACCT 長さ 12 の文字項目(String)
CAMPAIGN 総括プロジェクト計画: 外部 SAP システムの GUID(String)
DOC_CLASS リリースおよびトランザクション管理 を備えた元システム(String)
H_CURR 通貨コード(String)
H_CURR_ISO ISO 通貨コード(String)
SHIP_TYPE 出荷タイプ(String)
S_PROC_IND 特別処理区分(String)
REF_DOC_L_LONG 参照伝票番号 (依存関係についてはテキスト (長) を参照)(String)
LINE_TIME 納入日程の提案時刻 （現地時間:販売組織参照）(String)
CALC_MOTIVE 計算区分(String)

内部制御パラメータオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["REFOBJTYPE"]　→　配列内のidx番目の受注伝票ヘッダデータの「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の受注伝票ヘッダデータの「オブジェクトキー」
[idx]["REFDOCTYPE"]　→　配列内のidx番目の受注伝票ヘッダデータの「参照オブジェクトの伝票タイプ」
[idx]["DOC_TYPE"]　→　配列内のidx番目の受注伝票ヘッダデータの「販売伝票タイプ」
[idx]["COLLECT_NO"]　→　配列内のidx番目の受注伝票ヘッダデータの「一括番号」
[idx]["SALES_ORG"]　→　配列内のidx番目の受注伝票ヘッダデータの「販売組織」
[idx]["DISTR_CHAN"]　→　配列内のidx番目の受注伝票ヘッダデータの「流通チャネル」
[idx]["DIVISION"]　→　配列内のidx番目の受注伝票ヘッダデータの「製品部門」
[idx]["SALES_GRP"]　→　配列内のidx番目の受注伝票ヘッダデータの「営業グループ」
[idx]["SALES_OFF"]　→　配列内のidx番目の受注伝票ヘッダデータの「営業所」
[idx]["REQ_DATE_H"]　→　配列内のidx番目の受注伝票ヘッダデータの「指定納入期日」
[idx]["DATE_TYPE"]　→　配列内のidx番目の受注伝票ヘッダデータの「提案日付タイプ」
[idx]["PURCH_DATE"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先発注日付」
[idx]["PO_METHOD"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先発注タイプ」
[idx]["PO_SUPPLEM"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先発注番号補足」
[idx]["REF_1"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先/仕入先の内部参照コード」
[idx]["NAME"]　→　配列内のidx番目の受注伝票ヘッダデータの「発注者名称」
[idx]["TELEPHONE"]　→　配列内のidx番目の受注伝票ヘッダデータの「電話番号」
[idx]["PRICE_GRP"]　→　配列内のidx番目の受注伝票ヘッダデータの「価格グループ (得意先)」
[idx]["CUST_GROUP"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先グループ」
[idx]["SALES_DIST"]　→　配列内のidx番目の受注伝票ヘッダデータの「販売地域」
[idx]["PRICE_LIST"]　→　配列内のidx番目の受注伝票ヘッダデータの「価格表タイプ」
[idx]["INCOTERMS1"]　→　配列内のidx番目の受注伝票ヘッダデータの「インコタームズ (1)」
[idx]["INCOTERMS2"]　→　配列内のidx番目の受注伝票ヘッダデータの「インコタームズ 2」
[idx]["PMNTTRMS"]　→　配列内のidx番目の受注伝票ヘッダデータの「支払条件キー」
[idx]["DLV_BLOCK"]　→　配列内のidx番目の受注伝票ヘッダデータの「出荷ブロック (伝票ヘッダ)」
[idx]["BILL_BLOCK"]　→　配列内のidx番目の受注伝票ヘッダデータの「販売管理伝票の請求ブロック」
[idx]["ORD_REASON"]　→　配列内のidx番目の受注伝票ヘッダデータの「受注理由 (取引理由)」
[idx]["COMPL_DLV"]　→　配列内のidx番目の受注伝票ヘッダデータの「一括納入区分」
[idx]["PRICE_DATE"]　→　配列内のidx番目の受注伝票ヘッダデータの「価格設定/外貨換算の実行日付」
[idx]["QT_VALID_F"]　→　配列内のidx番目の受注伝票ヘッダデータの「見積/引合有効開始日」
[idx]["QT_VALID_T"]　→　配列内のidx番目の受注伝票ヘッダデータの「見積の有効終了日」
[idx]["CT_VALID_F"]　→　配列内のidx番目の受注伝票ヘッダデータの 「有効開始日付 (販売契約/品目提案)」
[idx]["CT_VALID_T"]　→　配列内のidx番目の受注伝票ヘッダデータの 「有効終了日付 (販売契約/品目提案)」
[idx]["CUST_GRP1"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先グループ 1」
[idx]["CUST_GRP2"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先グループ 2」
[idx]["CUST_GRP3"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先グループ 3」
[idx]["CUST_GRP4"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先グループ 4」
[idx]["CUST_GRP5"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先グループ 5」
[idx]["PURCH_NO_C"]　→　配列内のidx番目の受注伝票ヘッダデータの「出荷先発注番号」
[idx]["PURCH_NO_S"]　→　配列内のidx番目の受注伝票ヘッダデータの「出荷先の得意先発注番号」
[idx]["PO_DAT_S"]　→　配列内のidx番目の受注伝票ヘッダデータの「出荷先の出荷先発注日付」
[idx]["PO_METH_S"]　→　配列内のidx番目の受注伝票ヘッダデータの「出荷先の出荷先発注タイプ」
[idx]["REF_1_S"]　→　配列内のidx番目の受注伝票ヘッダデータの「出荷先文字」
[idx]["SD_DOC_CAT"]　→　配列内のidx番目の受注伝票ヘッダデータの「販売管理伝票カテゴリ」
[idx]["DOC_DATE"]　→　配列内のidx番目の受注伝票ヘッダデータの「伝票日付 (受信日/送信日)」
[idx]["WAR_DATE"]　→　配列内のidx番目の受注伝票ヘッダデータの「保証期間の開始日付」
[idx]["SHIP_COND"]　→　配列内のidx番目の受注伝票ヘッダデータの「出荷条件」
[idx]["PP_SEARCH"]　→　配列内のidx番目の受注伝票ヘッダデータの「品目提案検索条件」
[idx]["DUN_COUNT"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先商談回数」
[idx]["DUN_DATE"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先との前回の商談日」
[idx]["DLVSCHDUSE"]　→　配列内のidx番目の受注伝票ヘッダデータの「用途区分」
[idx]["PLDLVSTYP"]　→　配列内のidx番目の受注伝票ヘッダデータの「MRP: 出荷計画タイプ」
[idx]["REF_DOC"]　→　配列内のidx番目の受注伝票ヘッダデータの「参照伝票番号」
[idx]["COMP_CDE_B"]　→　配列内のidx番目の受注伝票ヘッダデータの「請求対象会社コード」
[idx]["ALTTAX_CLS"]　→　配列内のidx番目の受注伝票ヘッダデータの「代替税分類」
[idx]["TAX_CLASS2"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先税分類 2」
[idx]["TAX_CLASS3"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先税分類 3」
[idx]["TAX_CLASS4"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先に対する税クラス 4」
[idx]["TAX_CLASS5"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先に対する税クラス 5」
[idx]["TAX_CLASS6"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先に対する税クラス 6」
[idx]["TAX_CLASS7"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先に対する税クラス 7」
[idx]["TAX_CLASS8"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先に対する税クラス 8」
[idx]["TAX_CLASS9"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先に対する税クラス 9」
[idx]["REF_DOC_L"]　→　配列内のidx番目の受注伝票ヘッダデータの「参照伝票番号」
[idx]["ASS_NUMBER"]　→　配列内のidx番目の受注伝票ヘッダデータの「割当番号」
[idx]["REFDOC_CAT"]　→　配列内のidx番目の受注伝票ヘッダデータの 「先行販売管理伝票の伝票カテゴリ」
[idx]["ORDCOMB_IN"]　→　配列内のidx番目の受注伝票ヘッダデータの「受注結合出荷区分」
[idx]["BILL_SCHED"]　→　配列内のidx番目の受注伝票ヘッダデータの 「請求日程 (稼働日カレンダ指定)」
[idx]["INVO_SCHED"]　→　配列内のidx番目の受注伝票ヘッダデータの 「請求書一覧日程 (稼働日カレンダ指定)」
[idx]["MN_INVOICE"]　→　配列内のidx番目の受注伝票ヘッダデータの「マニュアル請求書更新」
[idx]["EXRATE_FI"]　→　配列内のidx番目の受注伝票ヘッダデータの 「FI 転記の換算レート (直接相場)」
[idx]["ADD_VAL_DY"]　→　配列内のidx番目の受注伝票ヘッダデータの「有効日からの日数」
[idx]["FIX_VAL_DY"]　→　配列内のidx番目の受注伝票ヘッダデータの「有効日日付」
[idx]["PYMT_METH"]　→　配列内のidx番目の受注伝票ヘッダデータの「支払方法」
[idx]["ACCNT_ASGN"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先の勘定設定グループ」
[idx]["EXCHG_RATE"]　→　配列内のidx番目の受注伝票ヘッダデータの 「価格設定/統計の換算レート (直接引用)」
[idx]["BILL_DATE"]　→　配列内のidx番目の受注伝票ヘッダデータの 「請求索引および印刷に対する請求日」
[idx]["SERV_DATE"]　→　配列内のidx番目の受注伝票ヘッダデータの「サービス提供日」
[idx]["DUNN_KEY"]　→　配列内のidx番目の受注伝票ヘッダデータの「督促処理キー」
[idx]["DUNN_BLOCK"]　→　配列内のidx番目の受注伝票ヘッダデータの「督促処理保留」
[idx]["PMTGAR_PRO"]　→　配列内のidx番目の受注伝票ヘッダデータの「支払保証決定表」
[idx]["DEPARTM_NO"]　→　配列内のidx番目の受注伝票ヘッダデータの「部門コード」
[idx]["REC_POINT"]　→　配列内のidx番目の受注伝票ヘッダデータの「入荷ポイント」
[idx]["DOC_NUM_FI"]　→　配列内のidx番目の受注伝票ヘッダデータの 「ドキュメンタリクレジット処理: 内部番号」
[idx]["CSTCNDGRP1"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先条件グループ１」
[idx]["CSTCNDGRP2"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先条件グループ２」
[idx]["CSTCNDGRP3"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先条件グループ３」
[idx]["CSTCNDGRP4"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先条件グループ４」
[idx]["CSTCNDGRP5"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先条件グループ５」
[idx]["DLV_TIME"]　→　配列内のidx番目の受注伝票ヘッダデータの「契約出荷期間」
[idx]["CURRENCY"]　→　配列内のidx番目の受注伝票ヘッダデータの「販売伝票通貨」
[idx]["CURR_ISO"]　→　配列内のidx番目の受注伝票ヘッダデータの「ISO コード通貨」
[idx]["CREATED_BY"]　→　配列内のidx番目の受注伝票ヘッダデータの「オブジェクト登録者名」
[idx]["TAXDEP_CTY"]　→　配列内のidx番目の受注伝票ヘッダデータの「税出荷国」
[idx]["TAXDST_CTY"]　→　配列内のidx番目の受注伝票ヘッダデータの「税仕向国」
[idx]["EUTRI_DEAL"]　→　配列内のidx番目の受注伝票ヘッダデータの「フラグ: EC 内三角取引」
[idx]["MAST_CONTR"]　→　配列内のidx番目の受注伝票ヘッダデータの「グループマスタ契約番号」
[idx]["REF_PROC"]　→　配列内のidx番目の受注伝票ヘッダデータの「参照限定条件: 決定区分」
[idx]["CHKPRTAUTH"]　→　配列内のidx番目の受注伝票ヘッダデータの「取引先権限チェック」
[idx]["CMLQTY_DAT"]　→　配列内のidx番目の受注伝票ヘッダデータの「累積出荷数量日付」
[idx]["VERSION"]　→　配列内のidx番目の受注伝票ヘッダデータの「販売伝票バージョン番号」
[idx]["NOTIF_NO"]　→　配列内のidx番目の受注伝票ヘッダデータの「通知番号」
[idx]["WBS_ELEM"]　→　配列内のidx番目の受注伝票ヘッダデータの「WBS 要素」
[idx]["EXCH_RATE_FI_V"]　→　配列内のidx番目の受注伝票ヘッダデータの 「FI 転記の換算レート (間接相場)」
[idx]["EXCHG_RATE_V"]　→　配列内のidx番目の受注伝票ヘッダデータの 「価格設定/統計の換算レート (間接引用)」
[idx]["FKK_CONACCT"]　→　配列内のidx番目の受注伝票ヘッダデータの「長さ 12 の文字項目」
[idx]["CAMPAIGN"]　→　配列内のidx番目の受注伝票ヘッダデータの 「総括プロジェクト計画: 外部 SAP システムの GUID」
[idx]["DOC_CLASS"]　→　配列内のidx番目の受注伝票ヘッダデータの 「リリースおよびトランザクション管理を備えた元システム」
[idx]["H_CURR"]　→　配列内のidx番目の受注伝票ヘッダデータの「通貨コード」
[idx]["H_CURR_ISO"]　→　配列内のidx番目の受注伝票ヘッダデータの「ISO 通貨コード」
[idx]["SHIP_TYPE"]　→　配列内のidx番目の受注伝票ヘッダデータの「出荷タイプ」
[idx]["S_PROC_IND"]　→　配列内のidx番目の受注伝票ヘッダデータの「特別処理区分」
[idx]["REF_DOC_L_LONG"]　→　配列内のidx番目の受注伝票ヘッダデータの 「参照伝票番号 (依存関係についてはテキスト (長) を参照)」

[idx]["LINE_TIME"]　→　配列内のidx番目の受注伝票ヘッダデータの 「納入日程の提案時刻（現地時間:販売組織参照）」
[idx]["CALC_MOTIVE"]　→　配列内のidx番目の受注伝票ヘッダデータの「計算区分」
※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderHeaderInX

Object getOrderHeaderInX ()

ヘッダデータチェックボックスを取得します。
返却値
Object ヘッダデータチェックボックス

ヘッダデータチェックボックスオブジェクトの構成は以下のとおりです。
ヘッダデータチェックボックス
オブジェクト
(Object)
UPDATEFLAG 更新区分 (String)
DOC_TYPE 関連ユーザデータ項目の更新情報 (String)
COLLECT_NO 関連ユーザデータ項目の更新情報 (String)
SALES_ORG 関連ユーザデータ項目の更新情報 (String)
DISTR_CHAN 関連ユーザデータ項目の更新情報 (String)
DIVISION 関連ユーザデータ項目の更新情報 (String)
SALES_GRP 関連ユーザデータ項目の更新情報 (String)
SALES_OFF 関連ユーザデータ項目の更新情報 (String)
REQ_DATE_H 関連ユーザデータ項目の更新情報 (String)
DATE_TYPE 関連ユーザデータ項目の更新情報 (String)
PURCH_DATE 関連ユーザデータ項目の更新情報 (String)
PO_METHOD 関連ユーザデータ項目の更新情報 (String)
PO_SUPPLEM 関連ユーザデータ項目の更新情報 (String)
REF_1 関連ユーザデータ項目の更新情報 (String)
NAME 関連ユーザデータ項目の更新情報 (String)
TELEPHONE 関連ユーザデータ項目の更新情報 (String)
PRICE_GRP 関連ユーザデータ項目の更新情報 (String)
CUST_GROUP 関連ユーザデータ項目の更新情報 (String)
SALES_DIST 関連ユーザデータ項目の更新情報 (String)
PRICE_LIST 関連ユーザデータ項目の更新情報 (String)
INCOTERMS1 関連ユーザデータ項目の更新情報 (String)
INCOTERMS2 関連ユーザデータ項目の更新情報 (String)
PMNTTRMS 関連ユーザデータ項目の更新情報 (String)
DLV_BLOCK 関連ユーザデータ項目の更新情報 (String)
BILL_BLOCK 関連ユーザデータ項目の更新情報 (String)
ORD_REASON 関連ユーザデータ項目の更新情報 (String)
COMPL_DLV 関連ユーザデータ項目の更新情報 (String)
PRICE_DATE 関連ユーザデータ項目の更新情報 (String)
QT_VALID_F 関連ユーザデータ項目の更新情報 (String)
QT_VALID_T 関連ユーザデータ項目の更新情報 (String)
CT_VALID_F 関連ユーザデータ項目の更新情報 (String)
CT_VALID_T 関連ユーザデータ項目の更新情報 (String)
CUST_GRP1 関連ユーザデータ項目の更新情報 (String)
CUST_GRP2 関連ユーザデータ項目の更新情報 (String)
CUST_GRP3 関連ユーザデータ項目の更新情報 (String)
CUST_GRP4 関連ユーザデータ項目の更新情報 (String)
CUST_GRP5 関連ユーザデータ項目の更新情報 (String)
PURCH_NO_C 関連ユーザデータ項目の更新情報 (String)
PURCH_NO_S 関連ユーザデータ項目の更新情報 (String)
PO_DAT_S 関連ユーザデータ項目の更新情報 (String)
PO_METH_S 関連ユーザデータ項目の更新情報 (String)
REF_1_S 関連ユーザデータ項目の更新情報 (String)
SD_DOC_CAT 関連ユーザデータ項目の更新情報 (String)
DOC_DATE 関連ユーザデータ項目の更新情報 (String)
WAR_DATE 関連ユーザデータ項目の更新情報 (String)
SHIP_COND 関連ユーザデータ項目の更新情報 (String)
PP_SEARCH 関連ユーザデータ項目の更新情報 (String)
DUN_COUNT 関連ユーザデータ項目の更新情報 (String)
DUN_DATE 関連ユーザデータ項目の更新情報 (String)
DLVSCHDUSE 関連ユーザデータ項目の更新情報 (String)
PLDLVSTYP 関連ユーザデータ項目の更新情報 (String)
REF_DOC 関連ユーザデータ項目の更新情報 (String)
COMP_CDE_B 関連ユーザデータ項目の更新情報 (String)
ALTTAX_CLS 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS2 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS3 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS4 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS5 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS6 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS7 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS8 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS9 関連ユーザデータ項目の更新情報 (String)
REF_DOC_L 関連ユーザデータ項目の更新情報 (String)
ASS_NUMBER 関連ユーザデータ項目の更新情報 (String)
REFDOC_CAT 関連ユーザデータ項目の更新情報 (String)
ORDCOMB_IN 関連ユーザデータ項目の更新情報 (String)
BILL_SCHED 関連ユーザデータ項目の更新情報 (String)
INVO_SCHED 関連ユーザデータ項目の更新情報 (String)
MN_INVOICE 関連ユーザデータ項目の更新情報 (String)
EXRATE_FI 関連ユーザデータ項目の更新情報 (String)
ADD_VAL_DY 関連ユーザデータ項目の更新情報 (String)
FIX_VAL_DY 関連ユーザデータ項目の更新情報 (String)
PYMT_METH 関連ユーザデータ項目の更新情報 (String)
ACCNT_ASGN 関連ユーザデータ項目の更新情報 (String)
EXCHG_RATE 関連ユーザデータ項目の更新情報 (String)
BILL_DATE 関連ユーザデータ項目の更新情報 (String)
SERV_DATE 関連ユーザデータ項目の更新情報 (String)
DUNN_KEY 関連ユーザデータ項目の更新情報 (String)
DUNN_BLOCK 関連ユーザデータ項目の更新情報 (String)
PROMOTION 関連ユーザデータ項目の更新情報 (String)
PMTGAR_PRO 関連ユーザデータ項目の更新情報 (String)
DEPARTM_NO 関連ユーザデータ項目の更新情報 (String)
REC_POINT 関連ユーザデータ項目の更新情報 (String)
POITM_NO_S 関連ユーザデータ項目の更新情報 (String)
DOC_NUM_FI 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP1 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP2 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP3 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP4 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP5 関連ユーザデータ項目の更新情報 (String)
DLV_TIME 関連ユーザデータ項目の更新情報 (String)
CURRENCY 関連ユーザデータ項目の更新情報 (String)
TAXDEP_CTY 関連ユーザデータ項目の更新情報 (String)
TAXDST_CTY 関連ユーザデータ項目の更新情報 (String)
EUTRI_DEAL 関連ユーザデータ項目の更新情報 (String)
MAST_CONTR 関連ユーザデータ項目の更新情報 (String)
REF_PROC 関連ユーザデータ項目の更新情報 (String)
CHKPRTAUTH 関連ユーザデータ項目の更新情報 (String)
CMLQTY_DAT 関連ユーザデータ項目の更新情報 (String)
VERSION 関連ユーザデータ項目の更新情報 (String)
NOTIF_NO 関連ユーザデータ項目の更新情報 (String)
WBS_ELEM 関連ユーザデータ項目の更新情報 (String)
EXCH_RATE_FI_V 関連ユーザデータ項目の更新情報 (String)
EXCHG_RATE_V 関連ユーザデータ項目の更新情報 (String)
FKK_CONACCT 関連ユーザデータ項目の更新情報 (String)
CAMPAIGN 関連ユーザデータ項目の更新情報 (String)
DOC_CLASS 関連ユーザデータ項目の更新情報 (String)
H_CURR 関連ユーザデータ項目の更新情報 (String)
SHIP_TYPE 関連ユーザデータ項目の更新情報 (String)
S_PROC_IND 関連ユーザデータ項目の更新情報 (String)
LINE_TIME 関連ユーザデータ項目の更新情報 (String)
CALC_MOTIVE 関連ユーザデータ項目の更新情報 (String)

ヘッダデータチェックボックスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["LOG_SYSTEM"]　→　配列内のidx番目のヘッダデータチェックボックスの「論理システム」
[idx]["UPDATEFLAG"]　→　配列内のidx番目のヘッダデータチェックボックスの「更新区分」
[idx]["DOC_TYPE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["COLLECT_NO"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SALES_ORG"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DISTR_CHAN"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DIVISION"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SALES_GRP"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SALES_OFF"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REQ_DATE_H"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DATE_TYPE"]　→idx　配列内の番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PURCH_DATE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_METHOD"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_SUPPLEM"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_1"]　→　配列内のidx番目のヘッダデータチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["NAME"]　→　配列内のidx番目のヘッダデータチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["TELEPHONE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_GRP"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CUST_GROUP"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SALES_DIST"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_LIST"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INCOTERMS1"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INCOTERMS2"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PMNTTRMS"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLV_BLOCK"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_BLOCK"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ORD_REASON"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["COMPL_DLV"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_DATE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["QT_VALID_F"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["QT_VALID_T"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CT_VALID_F"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CT_VALID_T"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CUST_GRP1"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CUST_GRP2"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CUST_GRP3"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CUST_GRP4"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CUST_GRP5"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PURCH_NO_C"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PURCH_NO_S"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_DAT_S"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_METH_S"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_1_S"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SD_DOC_CAT"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DOC_DATE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["WAR_DATE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SHIP_COND"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PP_SEARCH"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DUN_COUNT"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DUN_DATE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLVSCHDUSE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PLDLVSTYP"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_DOC"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["COMP_CDE_B"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ALTTAX_CLS"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS2"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS3"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS4"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS5"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS6"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS7"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS8"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS9"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_DOC_L"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ASS_NUMBER"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REFDOC_CAT"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ORDCOMB_IN"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_SCHED"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INVO_SCHED"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MN_INVOICE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXRATE_FI"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ADD_VAL_DY"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FIX_VAL_DY"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PYMT_METH"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ACCNT_ASGN"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCHG_RATE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_DATE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SERV_DATE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DUNN_KEY"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DUNN_BLOCK"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PROMOTION"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PMTGAR_PRO"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DEPARTM_NO"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REC_POINT"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["POITM_NO_S"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DOC_NUM_FI"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP1"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP2"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP3"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP4"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP5"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLV_TIME"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CURRENCY"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAXDEP_CTY"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAXDST_CTY"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EUTRI_DEAL"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAST_CONTR"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_PROC"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CHKPRTAUTH"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CMLQTY_DAT"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["VERSION"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["NOTIF_NO"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["WBS_ELEM"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCH_RATE_FI_V"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCHG_RATE_V"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FKK_CONACCT"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CAMPAIGN"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DOC_CLASS"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["H_CURR"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SHIP_TYPE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["S_PROC_IND"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["LINE_TIME"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CALC_MOTIVE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderItemsInList

Array getOrderItemsInList ()

明細データを取得します。
返却値
Array 明細データ

明細データオブジェクトの構成は以下のとおりです。
明細データ
オブジェクト
(Object)
ITM_NUMBER 販売伝票明細 (String)
HG_LV_ITEM 上位レベル明細 (String)
PO_ITM_NO 元となる購買発注の明細番号 (String)
MATERIAL 品目コード (String)
ALT_TO_ITM 代替明細 (String)
CUST_MAT22 得意先品目コード (無効) (String)
BATCH ロット番号 (String)
DLV_GROUP 出荷グループ (明細一括出荷) (String)
PART_DLV 明細レベルの分納納入 (String)
REASON_REJ 見積および受注の拒否理由 (String)
BILL_BLOCK ブロック (String)
BILL_DATE 請求索引および印刷に対する請求日 (String)
PLANT プラント (String)
STORE_LOC 保管場所 (String)
TARGET_QTY 目標数量（販売単位） (String)
TARGET_QU 目標数量 (数量単位) (String)
T_UNIT_ISO 目標数量単位 (ISO コード) (String)
ITEM_CATEG 明細カテゴリ (販売伝票) (String)
SHORT_TEXT テキスト (短): 受注明細 (String)
PRC_GROUP1 品目グループ 1 (String)
PRC_GROUP2 品目グループ 2 (String)
PRC_GROUP3 品目グループ 3 (String)
PRC_GROUP4 品目グループ 4 (String)
PRC_GROUP5 品目グループ 5 (String)
PROD_HIERA 品目階層 (String)
MATL_GROUP 品目グループ (String)
PURCH_NO_C 出荷先発注番号 (String)
PURCH_DATE 得意先発注日付 (String)
PO_METHOD 得意先発注タイプ (String)
REF_1 得意先/仕入先の内部参照コード (String)
PURCH_NO_S 出荷先の得意先発注番号 (String)
PO_DAT_S 出荷先の出荷先発注日付 (String)
PO_METH_S 出荷先の出荷先発注タイプ (String)
REF_1_S 出荷先文字 (String)
POITM_NO_S 元となる購買発注の明細番号 (String)
PRICE_GRP 価格グループ (得意先) (String)
CUST_GROUP 得意先グループ (String)
SALES_DIST 販売地域 (String)
PRICE_LIST 価格表タイプ (String)
INCOTERMS1 インコタームズ (1) (String)
INCOTERMS2 インコタームズ 2 (String)
ORDCOMP_IN 受注結合出荷区分 (String)
BILL_SCHED 請求日程 (稼働日カレンダ指定) (String)
INVO_SCHED 請求書一覧日程 (稼働日カレンダ指定) (String)
MN_INVOICE マニュアル請求書更新 (String)
EX_RATE_FI FI 転記の換算レート (直接相場) (String)
ADD_VAL_DY 有効日からの日数 (String)
FIX_VAL_DY 有効日日付 (String)
PMNTTRMS 支払条件キー (String)
PYMT_METH 支払方法 (String)
ACCNT_ASGN 得意先の勘定設定グループ (String)
EXCHG_RATE 価格設定/統計の換算レート (直接引用) (String)
PRICE_DATE 価格設定/外貨換算の実行日付 (String)
SERV_DATE サービス提供日 (String)
DUNN_KEY 督促処理キー (String)
DUNN_BLOCK 督促処理保留 (String)
PROMOTION プロモーション (String)
PMTGAR_PRO 支払保証決定表 (String)
DOC_NUM_FI ドキュメンタリクレジット処理: 内部番号 (String)
DEPARTM_NO 部門コード (String)
REC_POINT 入荷ポイント (String)
CSTCNDGRP1 得意先条件グループ１ (String)
CSTCNDGRP2 得意先条件グループ２ (String)
CSTCNDGRP3 得意先条件グループ３ (String)
CSTCNDGRP4 得意先条件グループ４ (String)
CSTCNDGRP5 得意先条件グループ５ (String)
DLV_TIME 契約出荷期間 (String)
SALES_UNIT 販売単位 (String)
S_UNIT_ISO 単位の ISO コード (String)
TRG_QTY_NO 販売単位から基本単位への換算係数 (String)
TRGQTY_DEN 販売単位から基本単位への換算係数 (String)
RNDDLV_QTY 丸め数量: 出荷 (String)
MAXDEVAMNT 数量に関する許容偏差 (絶対値) (String)
MAXDEVPER 数量に関する許容偏差 (%) (String)
MAXDEV_DAY シフト所要日数 (String)
USAGE_IND 未使用 - 予約長 3 (String)
FIXED_QUAN 数量固定区分 (String)
UNLMT_DLV 区分: 無制限過剰納入可能 (String)
OVERDLVTOL 過剰納入許容範囲 (String)
UNDDLV_TOL 不足納入許容範囲リミット (String)
DIVISION 製品部門 (String)
SALQTYNUM 販売数量単位から基本数量単位への変換係数の分子 (String)
SALQTYDEN 販売数量単位を SKU に換算するための分母 (除数) (String)
GROSS_WGHT 明細の総重量 (String)
NET_WEIGHT 明細の正味重量 (String)
UNTOF_WGHT 重量単位 (String)
UNOF_WTISO ISO コードでの重量単位 (String)
VOLUME 明細の総数量 (String)
VOLUNIT 容積単位 (String)
VOLUNITISO ISO コードでの容積単位 (String)
DLV_PRIO 出荷優先順位 (String)
SHIP_POINT 出荷ポイント/入荷ポイント (String)
ROUTE 輸送経路 (String)
CREATED_BY オブジェクト登録者名 (String)
TAX_CLASS1 品目の税分類 (String)
TAX_CLASS2 品目の税分類 (String)
TAX_CLASS3 品目の税分類 (String)
TAX_CLASS4 品目の税分類 (String)
TAX_CLASS5 品目の税分類 (String)
TAX_CLASS6 品目の税分類 (String)
TAX_CLASS7 品目の税分類 (String)
TAX_CLASS8 品目の税分類 (String)
TAX_CLASS9 品目の税分類 (String)
MAT_PR_GRP 品目価格設定グループ (String)
VAL_TYPE 評価タイプ (String)
FIXDAT_QTY 納期と出荷数量の固定 (String)
BOMEXPL_NO BOM 展開番号 (String)
RESANALKEY 結果分析キー (String)
REQMTS_TYP 所要量タイプ (String)
NO_GR_POST 得意先が入庫を転記していません (String)
BUS_TRANST 貿易管理の取引タイプ (String)
OVERHD_KEY 間接費キー (String)
CSTG_SHEET 原価計算表 (String)
MATFRGTGRP 品目運賃グループ (String)
PLDLVSHDIN 出荷計画に関する指示 (String)
SEQ_NO KANBAN/連続番号 (String)
BIL_FORM 請求書式 (String)
DLI_PROFIL 動的明細プロセッサプロファイル (String)
REV_TYPE 収益承認カテゴリ (String)
BEGDEM_PER 見越期間の提案開始日付 (String)
PR_REF_MAT 価格設定参照品目 (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)
ORDER_PROB 明細の受注可能性 (String)
MAX_PL_DLV 明細ごとの分割納入可能な最大回数 (String)
CFOP_CODE CFOP code and extension (old 5 char version) (String)
TAXLAWICMS 税法: ICMS (String)
TAXLAWIPI 税法: IPI (String)
SD_TAXCODE 0 (String)
ASSORT_MOD 品揃モジュール (String)
COMP_QUANT 構成品目数量 (String)
TARGET_VAL BAPI の通貨額 (小数点以下９桁) (String)
CURRENCY 販売伝票通貨 (String)
CURR_ISO ISO コード通貨 (String)
PROFIT_CTR 利益センタ (String)
ORDERID 指図番号 (String)
WBS_ELEM WBS 要素 (String)
DEPREC_PER ドキュメンタリクレジット処理に関する償却率 (%) (String)
REF_DOC 参照伝票番号 (String)
REF_DOC_IT 参照明細番号 (String)
REF_DOC_CA 先行販売管理伝票の伝票カテゴリ (String)
CUST_MAT35 得意先品目 (String)
EXCH_RATE_FI_V FI 転記の換算レート (間接相場) (String)
EXCHG_RATE_V 価格設定/統計の換算レート (間接引用) (String)
ITEMGUID_ATP ATP: 暗号 - DELNR および DELPS (String)
VAL_CONTR 金額契約番号 (String)
VAL_CON_I 金額契約明細 (String)
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)
MAT_EXT 項目 MATERIAL の品目コード (長) (今後のリリースで開発) (String)
MAT_GUID 項目 MATERIAL の外部 GUID (今後のリリースで開発) (String)
MAT_VERS 項目 MATERIAL のバージョン番号 (今後のリリースで開発) (String)
P_MAT_EXT 項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発) (String)
P_MAT_GUID 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発) (String)
P_MAT_VERS 項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発) (String)
FUNC_AREA 機能領域 (String)
ALTERN_BOM 代替 BOM (String)
FKK_CONACCT 長さ 12 の文字項目 (String)
EAN_UPC 国際商品コード (EAN/UPC) (String)
PRODCAT 製品カタログ番号 (String)
SHIP_TYPE 出荷タイプ (String)
S_PROC_IND 特別処理区分 (String)
FUNC_AREA_LONG 機能領域 (String)
BILL_REL 請求関連 (CRM) (String)
VW_UEPOS 上位レベル明細用途 ID (String)
CAMPAIGN 総括プロジェクト計画: 外部 SAP システムの GUID (String)
DLVSCHDUSE 用途区分 (String)
CFOP_LONG CFOP code and extension (String)
SELECTION 選択 ID (永続) (String)
MAT_ENTRD 入力品目 (String)
LOG_SYSTEM_OWN 論理システム (String)
ITM_TYPE_USAGE 明細用途 (String)
TAXLAWISS ISS Tax Law (String)
MAT_ENTRD_EXTERNAL 項目 MAT_ENTRD の品目コード (長) (String)
MAT_ENTRD_GUID 項目 MAT_ENTRD の外部 GUID (String)
MAT_ENTRD_VERSION 項目 MAT_ENTRD のバージョン番号 (String)
LOC_TAXCAT 税タイプ (String)
LOC_ZEROVAT LOC_ZEROVAT(String)
LOC_ACTCODE 総所得税の活動コード (String)
LOC_DISTTYPE 所得税の配賦タイプ (String)
LOC_TXRELCLAS 税関連分類 (String)
CALC_MOTIVE 計算区分 (String)

明細データオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の明細データの「販売伝票明細」
[idx]["HG_LV_ITEM"]　→　配列内のidx番目の明細データの「上位レベル明細」
[idx]["PO_ITM_NO"]　→　配列内のidx番目の明細データの「元となる購買発注の明細番号」
[idx]["MATERIAL"]　→　配列内のidx番目の明細データの「品目コード」
[idx]["ALT_TO_ITM"]　→　配列内のidx番目の明細データの「代替明細」
[idx]["CUST_MAT22"]　→　配列内のidx番目の明細データの「得意先品目コード (無効)」
[idx]["BATCH"]　→　配列内のidx番目の明細データの「ロット番号」
[idx]["DLV_GROUP"]　→　配列内のidx番目の明細データの「出荷グループ (明細一括出荷)」
[idx]["PART_DLV"]　→　配列内のidx番目の明細データの「明細レベルの分納納入」
[idx]["REASON_REJ"]　→　配列内のidx番目の明細データの「見積および受注の拒否理由」
[idx]["BILL_BLOCK"]　→　配列内のidx番目の明細データの「ブロック」
[idx]["BILL_DATE"]　→　配列内のidx番目の明細データの「請求索引および印刷に対する請求日」
[idx]["PLANT"]　→　配列内のidx番目の明細データの「プラント」
[idx]["STORE_LOC"]　→　配列内のidx番目の明細データの「保管場所」
[idx]["TARGET_QTY"]　→　配列内のidx番目の明細データの「目標数量（販売単位）」
[idx]["TARGET_QU"]　→　配列内のidx番目の明細データの「目標数量 (数量単位)」
[idx]["T_UNIT_ISO"]　→　配列内のidx番目の明細データの「目標数量単位 (ISO コード)」
[idx]["ITEM_CATEG"]　→　配列内のidx番目の明細データの「明細カテゴリ (販売伝票)」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の明細データの「テキスト (短): 受注明細」
[idx]["PRC_GROUP1"]　→　配列内のidx番目の明細データの「品目グループ 1」
[idx]["PRC_GROUP2"]　→　配列内のidx番目の明細データの「品目グループ 2」
[idx]["PRC_GROUP3"]　→　配列内のidx番目の明細データの「品目グループ 3」
[idx]["PRC_GROUP4"]　→　配列内のidx番目の明細データの「品目グループ 4」
[idx]["PRC_GROUP5"]　→　配列内のidx番目の明細データの「品目グループ 5」
[idx]["PROD_HIERA"]　→　配列内のidx番目の明細データの「品目階層」
[idx]["MATL_GROUP"]　→　配列内のidx番目の明細データの「品目グループ」
[idx]["PURCH_NO_C"]　→　配列内のidx番目の明細データの「出荷先発注番号」
[idx]["PURCH_DATE"]　→　配列内のidx番目の明細データの「得意先発注日付」
[idx]["PO_METHOD"]　→　配列内のidx番目の明細データの「得意先発注タイプ」
[idx]["REF_1"]　→　配列内のidx番目の明細データの「得意先/仕入先の内部参照コード」
[idx]["PURCH_NO_S"]　→　配列内のidx番目の明細データの「出荷先の得意先発注番号」
[idx]["PO_DAT_S"]　→　配列内のidx番目の明細データの「出荷先の出荷先発注日付」
[idx]["PO_METH_S"]　→　配列内のidx番目の明細データの「出荷先の出荷先発注タイプ」
[idx]["REF_1_S"]　→　配列内のidx番目の明細データの「出荷先文字」
[idx]["POITM_NO_S"]　→　配列内のidx番目の明細データの「元となる購買発注の明細番号」
[idx]["PRICE_GRP"]　→　配列内のidx番目の明細データの「価格グループ (得意先)」
[idx]["CUST_GROUP"]　→　配列内のidx番目の明細データの「得意先グループ」
[idx]["SALES_DIST"]　→　配列内のidx番目の明細データの「販売地域」
[idx]["PRICE_LIST"]　→　配列内のidx番目の明細データの「価格表タイプ」
[idx]["INCOTERMS1"]　→　配列内のidx番目の明細データの「インコタームズ (1)」
[idx]["INCOTERMS2"]　→　配列内のidx番目の明細データの「インコタームズ 2」
[idx]["ORDCOMP_IN"]　→　配列内のidx番目の明細データの「受注結合出荷区分」
[idx]["BILL_SCHED"]　→　配列内のidx番目の明細データの「請求日程 (稼働日カレンダ指定)」
[idx]["INVO_SCHED"]　→　配列内のidx番目の明細データの「請求書一覧日程 (稼働日カレンダ指定)」
[idx]["MN_INVOICE"]　→　配列内のidx番目の明細データの「マニュアル請求書更新」
[idx]["EX_RATE_FI"]　→　配列内のidx番目の明細データの「FI 転記の換算レート (直接相場)」
[idx]["ADD_VAL_DY"]　→　配列内のidx番目の明細データの「有効日からの日数」
[idx]["FIX_VAL_DY"]　→　配列内のidx番目の明細データの「有効日日付」
[idx]["PMNTTRMS"]　→　配列内のidx番目の明細データの「支払条件キー」
[idx]["PYMT_METH"]　→　配列内のidx番目の明細データの「支払方法」
[idx]["ACCNT_ASGN"]　→　配列内のidx番目の明細データの「得意先の勘定設定グループ」
[idx]["EXCHG_RATE"]　→　配列内のidx番目の明細データの 「価格設定/統計の換算レート (直接引用)」
[idx]["PRICE_DATE"]　→　配列内のidx番目の明細データの「価格設定/外貨換算の実行日付」
[idx]["SERV_DATE"]　→　配列内のidx番目の明細データの「サービス提供日」
[idx]["DUNN_KEY"]　→　配列内のidx番目の明細データの「督促処理キー」
[idx]["DUNN_BLOCK"]　→　配列内のidx番目の明細データの「督促処理保留」
[idx]["PROMOTION"]　→　配列内のidx番目の明細データの「プロモーション」
[idx]["PMTGAR_PRO"]　→　配列内のidx番目の明細データの「支払保証決定表」
[idx]["DOC_NUM_FI"]　→　配列内のidx番目の明細データの 「ドキュメンタリクレジット処理: 内部番号」
[idx]["DEPARTM_NO"]　→　配列内のidx番目の明細データの「部門コード」
[idx]["REC_POINT"]　→　配列内のidx番目の明細データの「入荷ポイント」
[idx]["CSTCNDGRP1"]　→　配列内のidx番目の明細データの「得意先条件グループ１」
[idx]["CSTCNDGRP2"]　→　配列内のidx番目の明細データの「得意先条件グループ２」
[idx]["CSTCNDGRP3"]　→　配列内のidx番目の明細データの「得意先条件グループ３」
[idx]["CSTCNDGRP4"]　→　配列内のidx番目の明細データの「得意先条件グループ４」
[idx]["CSTCNDGRP5"]　→　配列内のidx番目の明細データの「得意先条件グループ５」
[idx]["DLV_TIME"]　→　配列内のidx番目の明細データの「契約出荷期間」
[idx]["SALES_UNIT"]　→　配列内のidx番目の明細データの「販売単位」
[idx]["S_UNIT_ISO"]　→　配列内のidx番目の明細データの「単位の ISO コード」
[idx]["TRG_QTY_NO"]　→　配列内のidx番目の明細データの「販売単位から基本単位への換算係数」
[idx]["TRGQTY_DEN"]　→　配列内のidx番目の明細データの「販売単位から基本単位への換算係数」
[idx]["RNDDLV_QTY"]　→　配列内のidx番目の明細データの「丸め数量: 出荷」
[idx]["MAXDEVAMNT"]　→　配列内のidx番目の明細データの「数量に関する許容偏差 (絶対値)」
[idx]["MAXDEVPER"]　→　配列内のidx番目の明細データの「数量に関する許容偏差 (%)」
[idx]["MAXDEV_DAY"]　→　配列内のidx番目の明細データの「シフト所要日数」
[idx]["USAGE_IND"]　→　配列内のidx番目の明細データの「未使用 - 予約長 3」
[idx]["FIXED_QUAN"]　→　配列内のidx番目の明細データの「数量固定区分」
[idx]["UNLMT_DLV"]　→　配列内のidx番目の明細データの「区分: 無制限過剰納入可能」
[idx]["OVERDLVTOL"]　→　配列内のidx番目の明細データの「過剰納入許容範囲」
[idx]["UNDDLV_TOL"]　→　配列内のidx番目の明細データの「不足納入許容範囲リミット」
[idx]["DIVISION"]　→　配列内のidx番目の明細データの「製品部門」
[idx]["SALQTYNUM"]　→　配列内のidx番目の明細データの 「販売数量単位から基本数量単位への変換係数の分子」
[idx]["SALQTYDEN"]　→　配列内のidx番目の明細データの 「販売数量単位を SKU に換算するための分母 (除数)」
[idx]["GROSS_WGHT"]　→　配列内のidx番目の明細データの「明細の総重量」
[idx]["NET_WEIGHT"]　→　配列内のidx番目の明細データの「明細の正味重量」
[idx]["UNTOF_WGHT"]　→　配列内のidx番目の明細データの「重量単位」
[idx]["UNOF_WTISO"]　→　配列内のidx番目の明細データの「ISO コードでの重量単位」
[idx]["VOLUME"]　→　配列内のidx番目の明細データの「明細の総数量」
[idx]["VOLUNIT"]　→　配列内のidx番目の明細データの「容積単位」
[idx]["VOLUNITISO"]　→　配列内のidx番目の明細データの「ISO コードでの容積単位」
[idx]["DLV_PRIO"]　→　配列内のidx番目の明細データの「出荷優先順位」
[idx]["SHIP_POINT"]　→　配列内のidx番目の明細データの「出荷ポイント/入荷ポイント」
[idx]["ROUTE"]　→　配列内のidx番目の明細データの「輸送経路」
[idx]["CREATED_BY"]　→　配列内のidx番目の明細データの「オブジェクト登録者名」
[idx]["TAX_CLASS1"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS2"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS3"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS4"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS5"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS6"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS7"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS8"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS9"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["MAT_PR_GRP"]　→　配列内のidx番目の明細データの「品目価格設定グループ」
[idx]["VAL_TYPE"]　→　配列内のidx番目の明細データの「評価タイプ」
[idx]["FIXDAT_QTY"]　→　配列内のidx番目の明細データの「納期と出荷数量の固定」
[idx]["BOMEXPL_NO"]　→　配列内のidx番目の明細データの「BOM 展開番号」
[idx]["RESANALKEY"]　→　配列内のidx番目の明細データの「結果分析キー」
[idx]["REQMTS_TYP"]　→　配列内のidx番目の明細データの「所要量タイプ」
[idx]["NO_GR_POST"]　→　配列内のidx番目の明細データの「得意先が入庫を転記していません」
[idx]["BUS_TRANST"]　→　配列内のidx番目の明細データの「貿易管理の取引タイプ」
[idx]["OVERHD_KEY"]　→　配列内のidx番目の明細データの「間接費キー」
[idx]["CSTG_SHEET"]　→　配列内のidx番目の明細データの「原価計算表」
[idx]["MATFRGTGRP"]　→　配列内のidx番目の明細データの「品目運賃グループ」
[idx]["PLDLVSHDIN"]　→　配列内のidx番目の明細データの「出荷計画に関する指示」
[idx]["SEQ_NO"]　→　配列内のidx番目の明細データの「KANBAN/連続番号」
[idx]["BIL_FORM"]　→　配列内のidx番目の明細データの「請求書式」
[idx]["DLI_PROFIL"]　→　配列内のidx番目の明細データの「動的明細プロセッサプロファイル」
[idx]["REV_TYPE"]　→　配列内のidx番目の明細データの「収益承認カテゴリ」
[idx]["BEGDEM_PER"]　→　配列内のidx番目の明細データの「見越期間の提案開始日付」
[idx]["PR_REF_MAT"]　→　配列内のidx番目の明細データの「価格設定参照品目」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の明細データの「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の明細データの「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の明細データの「論理システム」
[idx]["ORDER_PROB"]　→　配列内のidx番目の明細データの「明細の受注可能性」
[idx]["MAX_PL_DLV"]　→　配列内のidx番目の明細データの「明細ごとの分割納入可能な最大回数」
[idx]["CFOP_CODE"]　→　配列内のidx番目の明細データの 「CFOP code and extension (old 5 char version)」
[idx]["TAXLAWICMS"]　→　配列内のidx番目の明細データの「税法: ICMS」
[idx]["TAXLAWIPI"]　→　配列内のidx番目の明細データの「税法: IPI」
[idx]["SD_TAXCODE"]　→　配列内のidx番目の明細データの「0」
[idx]["ASSORT_MOD"]　→　配列内のidx番目の明細データの「品揃モジュール」
[idx]["COMP_QUANT"]　→　配列内のidx番目の明細データの「構成品目数量」
[idx]["TARGET_VAL"]　→　配列内のidx番目の明細データの「BAPI の通貨額 (小数点以下９桁)」
[idx]["CURRENCY"]　→　配列内のidx番目の明細データの「販売伝票通貨」
[idx]["CURR_ISO"]　→　配列内のidx番目の明細データの「ISO コード通貨」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の明細データの「利益センタ」
[idx]["ORDERID"]　→　配列内のidx番目の明細データの「指図番号」
[idx]["WBS_ELEM"]　→　配列内のidx番目の明細データの「WBS 要素」
[idx]["DEPREC_PER"]　→　配列内のidx番目の明細データの 「ドキュメンタリクレジット処理に関する償却率 (%)」
[idx]["REF_DOC"]　→　配列内のidx番目の明細データの「参照伝票番号」
[idx]["REF_DOC_IT"]　→　配列内のidx番目の明細データの「参照明細番号」
[idx]["REF_DOC_CA"]　→　配列内のidx番目の明細データの「先行販売管理伝票の伝票カテゴリ」
[idx]["CUST_MAT35"]　→　配列内のidx番目の明細データの「得意先品目」
[idx]["EXCH_RATE_FI_V"]　→　配列内のidx番目の明細データの 「FI 転記の換算レート (間接相場)」
[idx]["EXCHG_RATE_V"]　→　配列内のidx番目の明細データの 「価格設定/統計の換算レート (間接引用)」
[idx]["ITEMGUID_ATP"]　→　配列内のidx番目の明細データの 「ATP: 暗号 - DELNR および DELPS」
[idx]["VAL_CONTR"]　→　配列内のidx番目の明細データの「金額契約番号」
[idx]["VAL_CON_I"]　→　配列内のidx番目の明細データの「金額契約明細」
[idx]["CONFIG_ID"]　→　配列内のidx番目の明細データの「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の明細データの「選定におけるインスタンス番号」
[idx]["MAT_EXT"]　→　配列内のidx番目の明細データの 「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["MAT_GUID"]　→　配列内のidx番目の明細データの 「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["MAT_VERS"]　→　配列内のidx番目の明細データの 「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」
[idx]["P_MAT_EXT"]　→　配列内のidx番目の明細データの 「項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)」
[idx]["P_MAT_GUID"]　→　配列内のidx番目の明細データの 「項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)」
[idx]["P_MAT_VERS"]　→　配列内のidx番目の明細データの 「項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)」
[idx]["FUNC_AREA"]　→　配列内のidx番目の明細データの「機能領域」
[idx]["ALTERN_BOM"]　→　配列内のidx番目の明細データの「代替 BOM」
[idx]["FKK_CONACCT"]　→　配列内のidx番目の明細データの「長さ 12 の文字項目」
[idx]["EAN_UPC"]　→　配列内のidx番目の明細データの「国際商品コード (EAN/UPC)」
[idx]["PRODCAT"]　→　配列内のidx番目の明細データの「製品カタログ番号」
[idx]["SHIP_TYPE"]　→　配列内のidx番目の明細データの「出荷タイプ」
[idx]["S_PROC_IND"]　→　配列内のidx番目の明細データの「特別処理区分」
[idx]["FUNC_AREA_LONG"]　→　配列内のidx番目の明細データの「機能領域」
[idx]["BILL_REL"]　→　配列内のidx番目の明細データの「請求関連 (CRM)」
[idx]["VW_UEPOS"]　→　配列内のidx番目の明細データの「上位レベル明細用途 ID」
[idx]["CAMPAIGN"]　→　配列内のidx番目の明細データの 「総括プロジェクト計画: 外部 SAP システムの GUID」
[idx]["DLVSCHDUSE"]　→　配列内のidx番目の明細データの「用途区分」
[idx]["CFOP_LONG"]　→　配列内のidx番目の明細データの 「CFOP code and extension」
[idx]["SELECTION"]　→　配列内のidx番目の明細データの「選択 ID (永続)」
[idx]["MAT_ENTRD"]　→　配列内のidx番目の明細データの「入力品目」
[idx]["LOG_SYSTEM_OWN"]　→　配列内のidx番目の明細データの「論理システム」
[idx]["ITM_TYPE_USAGE"]　→　配列内のidx番目の明細データの「明細用途」
[idx]["TAXLAWISS"]　→　配列内のidx番目の明細データの「ISS Tax Law」
[idx]["MAT_ENTRD_EXTERNAL"]　→　配列内のidx番目の明細データの「項目 MAT_ENTRD の品目コード (長)」
[idx]["MAT_ENTRD_GUID"]　→　配列内のidx番目の明細データの「項目 MAT_ENTRD の外部 GUID」
[idx]["MAT_ENTRD_VERSION"]　→　配列内のidx番目の明細データの「項目 MAT_ENTRD のバージョン番号」
[idx]["LOC_TAXCAT"]　→　配列内のidx番目の明細データの「税タイプ」
[idx]["LOC_ZEROVAT"]　→　配列内のidx番目の明細データの「LOC_ZEROVAT」
[idx]["LOC_ACTCODE"]　→　配列内のidx番目の明細データの「総所得税の活動コード」
[idx]["LOC_DISTTYPE"]　→　配列内のidx番目の明細データの「所得税の配賦タイプ」
[idx]["LOC_TXRELCLAS"]　→　配列内のidx番目の明細データの「税関連分類」
[idx]["CALC_MOTIVE"]　→　配列内のidx番目の明細データの「計算区分」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderItemsInXList

Array getOrderItemsInXList ()

明細データチェックボックスを取得します。
返却値
Array 明細データチェックボックス

明細データチェックボックスオブジェクトの構成は以下のとおりです。
明細データチェックボックス
オブジェクト
(Object)
ITM_NUMBER 販売伝票明細 (String)
UPDATEFLAG 更新区分 (String)
HG_LV_ITEM 関連ユーザデータ項目の更新情報 (String)
PO_ITM_NO 関連ユーザデータ項目の更新情報 (String)
MATERIAL 関連ユーザデータ項目の更新情報 (String)
ALT_TO_ITM 関連ユーザデータ項目の更新情報 (String)
CUST_MAT22 関連ユーザデータ項目の更新情報 (String)
BATCH 関連ユーザデータ項目の更新情報 (String)
DLV_GROUP 関連ユーザデータ項目の更新情報 (String)
PART_DLV 関連ユーザデータ項目の更新情報 (String)
REASON_REJ 関連ユーザデータ項目の更新情報 (String)
BILL_BLOCK 関連ユーザデータ項目の更新情報 (String)
BILL_DATE 関連ユーザデータ項目の更新情報 (String)
PLANT 関連ユーザデータ項目の更新情報 (String)
STORE_LOC 関連ユーザデータ項目の更新情報 (String)
TARGET_QTY 関連ユーザデータ項目の更新情報 (String)
TARGET_QU 関連ユーザデータ項目の更新情報 (String)
T_UNIT_ISO 関連ユーザデータ項目の更新情報 (String)
ITEM_CATEG 関連ユーザデータ項目の更新情報 (String)
SHORT_TEXT 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP1 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP2 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP3 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP4 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP5 関連ユーザデータ項目の更新情報 (String)
PROD_HIERA 関連ユーザデータ項目の更新情報 (String)
MATL_GROUP 関連ユーザデータ項目の更新情報 (String)
PURCH_NO_C 関連ユーザデータ項目の更新情報 (String)
PURCH_DATE 関連ユーザデータ項目の更新情報 (String)
PO_METHOD 関連ユーザデータ項目の更新情報 (String)
REF_1 関連ユーザデータ項目の更新情報 (String)
PURCH_NO_S 関連ユーザデータ項目の更新情報 (String)
PO_DAT_S 関連ユーザデータ項目の更新情報 (String)
PO_METH_S 関連ユーザデータ項目の更新情報 (String)
REF_1_S 関連ユーザデータ項目の更新情報 (String)
POITM_NO_S 関連ユーザデータ項目の更新情報 (String)
PRICE_GRP 関連ユーザデータ項目の更新情報 (String)
CUST_GROUP 関連ユーザデータ項目の更新情報 (String)
SALES_DIST 関連ユーザデータ項目の更新情報 (String)
PRICE_LIST 関連ユーザデータ項目の更新情報 (String)
INCOTERMS1 関連ユーザデータ項目の更新情報 (String)
INCOTERMS2 関連ユーザデータ項目の更新情報 (String)
ORDCOMP_IN 関連ユーザデータ項目の更新情報 (String)
BILL_SCHED 関連ユーザデータ項目の更新情報 (String)
INVO_SCHED 関連ユーザデータ項目の更新情報 (String)
MN_INVOICE 関連ユーザデータ項目の更新情報 (String)
EX_RATE_FI 関連ユーザデータ項目の更新情報 (String)
ADD_VAL_DY 関連ユーザデータ項目の更新情報 (String)
FIX_VAL_DY 関連ユーザデータ項目の更新情報 (String)
PMNTTRMS 関連ユーザデータ項目の更新情報 (String)
PYMT_METH 関連ユーザデータ項目の更新情報 (String)
ACCNT_ASGN 関連ユーザデータ項目の更新情報 (String)
EXCHG_RATE 関連ユーザデータ項目の更新情報 (String)
PRICE_DATE 関連ユーザデータ項目の更新情報 (String)
SERV_DATE 関連ユーザデータ項目の更新情報 (String)
DUNN_KEY 関連ユーザデータ項目の更新情報 (String)
DUNN_BLOCK 関連ユーザデータ項目の更新情報 (String)
PROMOTION 関連ユーザデータ項目の更新情報 (String)
PMTGAR_PRO 関連ユーザデータ項目の更新情報 (String)
DOC_NUM_FI 関連ユーザデータ項目の更新情報 (String)
DEPARTM_NO 関連ユーザデータ項目の更新情報 (String)
REC_POINT 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP1 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP2 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP3 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP4 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP5 関連ユーザデータ項目の更新情報 (String)
DLV_TIME 関連ユーザデータ項目の更新情報 (String)
SALES_UNIT 関連ユーザデータ項目の更新情報 (String)
TRG_QTY_NO 関連ユーザデータ項目の更新情報 (String)
TRGQTY_DEN 関連ユーザデータ項目の更新情報 (String)
RNDDLV_QTY 関連ユーザデータ項目の更新情報 (String)
MAXDEVAMNT 関連ユーザデータ項目の更新情報 (String)
MAXDEVPER 関連ユーザデータ項目の更新情報 (String)
MAXDEV_DAY 関連ユーザデータ項目の更新情報 (String)
USAGE_IND 関連ユーザデータ項目の更新情報 (String)
FIXED_QUAN 関連ユーザデータ項目の更新情報 (String)
UNLMT_DLV 関連ユーザデータ項目の更新情報 (String)
OVERDLVTOL 関連ユーザデータ項目の更新情報 (String)
UNDDLV_TOL 関連ユーザデータ項目の更新情報 (String)
DIVISION 関連ユーザデータ項目の更新情報 (String)
SALQTYNUM 関連ユーザデータ項目の更新情報 (String)
SALQTYDEN 関連ユーザデータ項目の更新情報 (String)
GROSS_WGHT 関連ユーザデータ項目の更新情報 (String)
NET_WEIGHT 関連ユーザデータ項目の更新情報 (String)
UNTOF_WGHT 関連ユーザデータ項目の更新情報 (String)
VOLUME 関連ユーザデータ項目の更新情報 (String)
VOLUNIT 関連ユーザデータ項目の更新情報 (String)
DLV_PRIO 関連ユーザデータ項目の更新情報 (String)
SHIP_POINT 関連ユーザデータ項目の更新情報 (String)
ROUTE 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS1 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS2 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS3 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS4 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS5 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS6 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS7 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS8 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS9 関連ユーザデータ項目の更新情報 (String)
MAT_PR_GRP 関連ユーザデータ項目の更新情報 (String)
VAL_TYPE 関連ユーザデータ項目の更新情報 (String)
FIXDAT_QTY 関連ユーザデータ項目の更新情報 (String)
BOMEXPL_NO 関連ユーザデータ項目の更新情報 (String)
RESANALKEY 関連ユーザデータ項目の更新情報 (String)
REQMTS_TYP 関連ユーザデータ項目の更新情報 (String)
NO_GR_POST 関連ユーザデータ項目の更新情報 (String)
BUS_TRANST 関連ユーザデータ項目の更新情報 (String)
OVERHD_KEY 関連ユーザデータ項目の更新情報 (String)
CSTG_SHEET 関連ユーザデータ項目の更新情報 (String)
MATFRGTGRP 関連ユーザデータ項目の更新情報 (String)
PLDLVSHDIN 関連ユーザデータ項目の更新情報 (String)
SEQ_NO 関連ユーザデータ項目の更新情報 (String)
BIL_FORM 関連ユーザデータ項目の更新情報 (String)
DLI_PROFIL 関連ユーザデータ項目の更新情報 (String)
REV_TYPE 関連ユーザデータ項目の更新情報 (String)
BEGDEM_PER 関連ユーザデータ項目の更新情報 (String)
PR_REF_MAT 関連ユーザデータ項目の更新情報 (String)
REFOBJTYPE 関連ユーザデータ項目の更新情報 (String)
REFOBJKEY 関連ユーザデータ項目の更新情報 (String)
REFLOGSYS 関連ユーザデータ項目の更新情報 (String)
ORDER_PROB 関連ユーザデータ項目の更新情報 (String)
MAX_PL_DLV 関連ユーザデータ項目の更新情報 (String)
CFOP_CODE 関連ユーザデータ項目の更新情報 (String)
TAXLAWICMS 関連ユーザデータ項目の更新情報 (String)
TAXLAWIPI 関連ユーザデータ項目の更新情報 (String)
SD_TAXCODE 関連ユーザデータ項目の更新情報 (String)
ASSORT_MOD 関連ユーザデータ項目の更新情報 (String)
COMP_QUANT 関連ユーザデータ項目の更新情報 (String)
TARGET_VAL 関連ユーザデータ項目の更新情報 (String)
PROFIT_CTR 関連ユーザデータ項目の更新情報 (String)
ORDERID 関連ユーザデータ項目の更新情報 (String)
WBS_ELEM 関連ユーザデータ項目の更新情報 (String)
DEPREC_PER 関連ユーザデータ項目の更新情報 (String)
REF_DOC 関連ユーザデータ項目の更新情報 (String)
REF_DOC_IT 関連ユーザデータ項目の更新情報 (String)
REF_DOC_CA 関連ユーザデータ項目の更新情報 (String)
CUST_MAT35 関連ユーザデータ項目の更新情報 (String)
EXCH_RATE_FI_V 関連ユーザデータ項目の更新情報 (String)
EXCHG_RATE_V 関連ユーザデータ項目の更新情報 (String)
ITEMGUID_ATP 関連ユーザデータ項目の更新情報 (String)
VAL_CONTR 関連ユーザデータ項目の更新情報 (String)
VAL_CON_I 関連ユーザデータ項目の更新情報 (String)
CONFIG_ID 関連ユーザデータ項目の更新情報 (String)
INST_ID 関連ユーザデータ項目の更新情報 (String)
MAT_EXT 関連ユーザデータ項目の更新情報 (String)
MAT_GUID 関連ユーザデータ項目の更新情報 (String)
MAT_VERS 関連ユーザデータ項目の更新情報 (String)
P_MAT_EXT 関連ユーザデータ項目の更新情報 (String)
P_MAT_GUID 関連ユーザデータ項目の更新情報 (String)
P_MAT_VERS 関連ユーザデータ項目の更新情報 (String)
FUNC_AREA 関連ユーザデータ項目の更新情報 (String)
ALTERN_BOM 関連ユーザデータ項目の更新情報 (String)
FKK_CONACCT 関連ユーザデータ項目の更新情報 (String)
EAN_UPC 関連ユーザデータ項目の更新情報 (String)
PRODCAT 関連ユーザデータ項目の更新情報 (String)
SHIP_TYPE 関連ユーザデータ項目の更新情報 (String)
S_PROC_IND 関連ユーザデータ項目の更新情報 (String)
BILL_REL 関連ユーザデータ項目の更新情報 (String)
VW_UEPOS 関連ユーザデータ項目の更新情報 (String)
CAMPAIGN 関連ユーザデータ項目の更新情報 (String)
DLVSCHDUSE 関連ユーザデータ項目の更新情報 (String)
SELECTION 関連ユーザデータ項目の更新情報 (String)
MAT_ENTRD 関連ユーザデータ項目の更新情報 (String)
LOG_SYSTEM_OWN 関連ユーザデータ項目の更新情報 (String)
ITM_TYPE_USAGE 関連ユーザデータ項目の更新情報 (String)
TAXLAWISS 関連ユーザデータ項目の更新情報 (String)
MAT_ENTRD_EXTERNAL 関連ユーザデータ項目の更新情報 (String)
MAT_ENTRD_GUID 関連ユーザデータ項目の更新情報 (String)
MAT_ENTRD_VERSION 関連ユーザデータ項目の更新情報 (String)
LOC_TAXCAT 関連ユーザデータ項目の更新情報 (String)
LOC_ZEROVAT 関連ユーザデータ項目の更新情報 (String)
LOC_ACTCODE 関連ユーザデータ項目の更新情報 (String)
LOC_DISTTYPE 関連ユーザデータ項目の更新情報 (String)
LOC_TXRELCLAS 関連ユーザデータ項目の更新情報 (String)
CALC_MOTIVE 関連ユーザデータ項目の更新情報 (String)

明細データチェックボックスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の明細データチェックボックスの「販売伝票明細」
[idx]["UPDATEFLAG"]　→　配列内のidx番目の明細データチェックボックスの「更新区分
[idx]["HG_LV_ITEM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_ITM_NO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["MATERIAL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["ALT_TO_ITM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["CUST_MAT22"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["BATCH"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報
[idx]["DLV_GROUP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["PART_DLV"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["REASON_REJ"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_BLOCK"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_DATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PLANT"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["STORE_LOC"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TARGET_QTY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["TARGET_QU"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["T_UNIT_ISO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ITEM_CATEG"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP1"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP2"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP3"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP4"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP5"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PROD_HIERA"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["MATL_GROUP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PURCH_NO_C"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PURCH_DATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_METHOD"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_1"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["PURCH_NO_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_DAT_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_METH_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_1_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["POITM_NO_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_GRP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["CUST_GROUP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SALES_DIST"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_LIST"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INCOTERMS1"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INCOTERMS2"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ORDCOMP_IN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_SCHED"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INVO_SCHED"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MN_INVOICE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EX_RATE_FI"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ADD_VAL_DY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FIX_VAL_DY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["PMNTTRMS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["PYMT_METH"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ACCNT_ASGN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCHG_RATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_DATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SERV_DATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DUNN_KEY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DUNN_BLOCK"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PROMOTION"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PMTGAR_PRO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DOC_NUM_FI"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DEPARTM_NO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REC_POINT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP1"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP2"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["CSTCNDGRP3"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["CSTCNDGRP4"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP5"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLV_TIME"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SALES_UNIT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TRG_QTY_NO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TRGQTY_DEN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["RNDDLV_QTY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAXDEVAMNT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAXDEVPER"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAXDEV_DAY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["USAGE_IND"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FIXED_QUAN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["UNLMT_DLV"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["OVERDLVTOL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["UNDDLV_TOL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DIVISION"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["SALQTYNUM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["SALQTYDEN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["GROSS_WGHT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["NET_WEIGHT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["UNTOF_WGHT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["VOLUME"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["VOLUNIT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLV_PRIO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SHIP_POINT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ROUTE"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS1"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS2"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS3"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS4"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS5"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS6"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS7"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS8"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS9"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["MAT_PR_GRP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["VAL_TYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FIXDAT_QTY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BOMEXPL_NO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["RESANALKEY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REQMTS_TYP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["NO_GR_POST"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BUS_TRANST"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["OVERHD_KEY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTG_SHEET"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MATFRGTGRP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PLDLVSHDIN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SEQ_NO"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["BIL_FORM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLI_PROFIL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REV_TYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BEGDEM_PER"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PR_REF_MAT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REFOBJKEY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REFLOGSYS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["ORDER_PROB"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAX_PL_DLV"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CFOP_CODE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAXLAWICMS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAXLAWIPI"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SD_TAXCODE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ASSORT_MOD"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["COMP_QUANT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TARGET_VAL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ORDERID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["WBS_ELEM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DEPREC_PER"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_DOC"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_DOC_IT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_DOC_CA"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CUST_MAT35"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCH_RATE_FI_V"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCHG_RATE_V"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ITEMGUID_ATP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["VAL_CONTR"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["VAL_CON_I"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CONFIG_ID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INST_ID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_EXT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_GUID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_VERS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["P_MAT_EXT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["P_MAT_GUID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["P_MAT_VERS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FUNC_AREA"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ALTERN_BOM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FKK_CONACCT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EAN_UPC"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRODCAT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SHIP_TYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["S_PROC_IND"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_REL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["VW_UEPOS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CAMPAIGN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLVSCHDUSE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SELECTION"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_ENTRD"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["LOG_SYSTEM_OWN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ITM_TYPE_USAGE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAXLAWISS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_ENTRD_EXTERNAL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_ENTRD_GUID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_ENTRD_VERSION"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["LOC_TAXCAT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["LOC_ZEROVAT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["LOC_ACTCODE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["LOC_DISTTYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["LOC_TXRELCLAS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CALC_MOTIVE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderKeysList

Array getOrderKeysList ()

参照キーの出力を取得します。
返却値
Array 参照キーの出力

参照キーの出力オブジェクトの構成は以下のとおりです。
参照キーの出力
オブジェクト
(Object)
REFOBJTYP オブジェクトタイプ (String)
REFOBJECT オブジェクト名 (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)
DOC_NUMBER 販売管理伝票番号 (String)
ITM_NUMBER 販売伝票明細 (String)
SCHED_LIN 納入日程行 (String)
COND_NO 伝票条件番号 (String)
CONDITEMNO 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件カウンタ (String)
COND_TYPE 条件タイプ (String)
STATUS 単一文字フラグ (String)
TINDEX 数値項目: 長さ 6 (String)
ADDRESS 住所 (String)
ABRLI 内部納入日程番号 (String)
ABART 承認タイプ (String)

参照キーの出力オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["REFOBJTYP"]　→　配列内のidx番目の参照キーの出力の「オブジェクトタイプ」
[idx]["REFOBJECT"]　→　配列内のidx番目の参照キーの出力の「オブジェクト名
[idx]["REFOBJKEY"]　→　配列内のidx番目の参照キーの出力の「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の参照キーの出力の「論理システム
[idx]["DOC_NUMBER"]　→　配列内のidx番目の参照キーの出力の「販売管理伝票番号
[idx]["ITM_NUMBER"]　→　配列内のidx番目の参照キーの出力の「販売伝票明細
[idx]["SCHED_LIN"]　→　配列内のidx番目の参照キーの出力の「納入日程行
[idx]["COND_NO"]　→　配列内のidx番目の参照キーの出力の「伝票条件番号
[idx]["CONDITEMNO"]　→　配列内のidx番目の参照キーの出力の「条件明細番号
[idx]["COND_ST_NO"]　→　配列内のidx番目の参照キーの出力の「ステップ番号
[idx]["COND_COUNT"]　→　配列内のidx番目の参照キーの出力の「条件カウンタ」
[idx]["COND_TYPE"]　→　配列内のidx番目の参照キーの出力の「条件タイプ」
[idx]["STATUS"]　→　配列内のidx番目の参照キーの出力の「単一文字フラグ」
[idx]["TINDEX"]　→　配列内のidx番目の参照キーの出力の「数値項目: 長さ 6」
[idx]["ADDRESS"]　→　配列内のidx番目の参照キーの出力の「住所」
[idx]["ABRLI"]　→　配列内のidx番目の参照キーの出力の「内部納入日程番号
[idx]["ABART"]　→　配列内のidx番目の参照キーの出力の「承認タイプ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderPartnersList

Array getOrderPartnersList ()

伝票取引先を取得します。
返却値
Array 伝票取引先

伝票取引先オブジェクトの構成は以下のとおりです。
伝票取引先
オブジェクト
(Object)
PARTN_ROLE 取引先機能 (String)
PARTN_NUMB 得意先コード 1 (String)
ITM_NUMBER 明細番号 (販売管理伝票) (String)
TITLE 敬称 (String)
NAME 名称 1 (String)
NAME_2 名称 2 (String)
NAME_3 名称 3 (String)
NAME_4 名称 4 (String)
STREET 地名/番地-号 (String)
COUNTRY 国コード (String)
COUNTR_ISO 国キー (ISO コード) (String)
POSTL_CODE 郵便番号 (String)
POBX_PCD 私書箱番号 (String)
POBX_CTY 私書箱住所 (String)
CITY 市区町村 (String)
DISTRICT 所在地 (String)
REGION 地域 (都道府県) (String)
PO_BOX 私書箱 (String)
TELEPHONE 電話番号 1 (String)
TELEPHONE2 電話番号 2 (String)
TELEBOX テレボックス番号 (String)
FAX_NUMBER FAX 番号 (String)
TELETEX_NO テレテクス番号 (String)
TELEX_NO テレックス番号 (String)
LANGU 言語キー (String)
LANGU_ISO ISO 639 準拠の言語 (String)
UNLOAD_PT 荷渡ポイント (String)
TRANSPZONE 商品の納入区域 (String)
TAXJURCODE 税計算管轄コード - 税管轄コード (String)
ADDRESS 住所 (String)
PRIV_ADDR 自宅住所 (String)
ADDR_TYPE アドレスタイプ (1=組織、2=個人、3=取引先担当者) (String)
ADDR_ORIG コピー元住所 (String)
ADDR_LINK 住所コードへのリンク (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)

伝票取引先オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PARTN_ROLE"]　→　配列内のidx番目の伝票取引先の「取引先機能」
[idx]["PARTN_NUMB"]　→　配列内のidx番目の伝票取引先の「得意先コード 1
[idx]["ITM_NUMBER"]　→　配列内のidx番目の伝票取引先の「明細番号 (販売管理伝票)」
[idx]["TITLE"]　→　配列内のidx番目の伝票取引先の「敬称
[idx]["NAME"]　→　配列内のidx番目の伝票取引先の「名称 1
[idx]["NAME_2"]　→　配列内のidx番目の伝票取引先の「名称 2
[idx]["NAME_3"]　→　配列内のidx番目の伝票取引先の「名称 3
[idx]["NAME_4"]　→　配列内のidx番目の伝票取引先の「名称 4
[idx]["STREET"]　→　配列内のidx番目の伝票取引先の「地名/番地-号
[idx]["COUNTRY"]　→　配列内のidx番目の伝票取引先の「国コード
[idx]["COUNTR_ISO"]　→　配列内のidx番目の伝票取引先の「国キー (ISO コード)」
[idx]["POSTL_CODE"]　→　配列内のidx番目の伝票取引先の「郵便番号」
[idx]["POBX_PCD"]　→　配列内のidx番目の伝票取引先の「私書箱番号」
[idx]["POBX_CTY"]　→　配列内のidx番目の伝票取引先の「私書箱住所」
[idx]["CITY"]　→　配列内のidx番目の伝票取引先の「市区町村」
[idx]["DISTRICT"]　→　配列内のidx番目の伝票取引先の「所在地
[idx]["REGION"]　→　配列内のidx番目の伝票取引先の「地域 (都道府県)」
[idx]["PO_BOX"]　→　配列内のidx番目の伝票取引先の「私書箱」
[idx]["TELEPHONE"]　→　配列内のidx番目の伝票取引先の「電話番号 1」
[idx]["TELEPHONE2"]　→　配列内のidx番目の伝票取引先の「電話番号 2」
[idx]["TELEBOX"]　→　配列内のidx番目の伝票取引先の「テレボックス番号」
[idx]["FAX_NUMBER"]　→　配列内のidx番目の伝票取引先の「FAX 番号」
[idx]["TELETEX_NO"]　→　配列内のidx番目の伝票取引先の「テレテクス番号」
[idx]["TELEX_NO"]　→　配列内のidx番目の伝票取引先の「テレックス番号」
[idx]["LANGU"]　→　配列内のidx番目の伝票取引先の「言語キー」
[idx]["LANGU_ISO"]　→　配列内のidx番目の伝票取引先の「ISO 639 準拠の言語
[idx]["UNLOAD_PT"]　→　配列内のidx番目の伝票取引先の「荷渡ポイント」
[idx]["TRANSPZONE"]　→　配列内のidx番目の伝票取引先の「商品の納入区域」
[idx]["TAXJURCODE"]　→　配列内のidx番目の伝票取引先の「税計算管轄コード - 税管轄コード」
[idx]["ADDRESS"]　→　配列内のidx番目の伝票取引先の「住所」
[idx]["PRIV_ADDR"]　→　配列内のidx番目の伝票取引先の「自宅住所」
[idx]["ADDR_TYPE"]　→　配列内のidx番目の伝票取引先の 「アドレスタイプ (1=組織、2=個人、3=取引先担当者)」
[idx]["ADDR_ORIG"]　→　配列内のidx番目の伝票取引先の「コピー元住所」
[idx]["ADDR_LINK"]　→　配列内のidx番目の伝票取引先の「住所コードへのリンク」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の伝票取引先の「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の伝票取引先の「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の伝票取引先の「論理システム

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderSchedulesInList

Array getOrderSchedulesInList ()

納入日程行を取得します。
返却値
Array 納入日程行

納入日程行オブジェクトの構成は以下のとおりです。
納入日程行
オブジェクト
(Object)
ITM_NUMBER 販売伝票明細 (String)
SCHED_LINE 納入日程行 (String)
REQ_DATE 納入日程日付 (String)
DATE_TYPE 日付タイプ (日、週、月、期間) (String)
REQ_TIME 納入時間 (String)
REQ_QTY 販売単位による受注数量 (String)
REQ_DLV_BL 出荷ブロック中の納入日程行 (String)
SCHED_TYPE 納入日程カテゴリ (String)
TP_DATE 輸送計画日付 (String)
MS_DATE 品目利用可能日 (String)
LOAD_DATE 積載日付 (String)
GI_DATE 出庫日付 (String)
TP_TIME 輸送計画 - 時間 (現地時間/出荷ポイント参照) (String)
MS_TIME 品目供給ステージ (現地時刻: プラント参照) (String)
LOAD_TIME 積載時刻 (現地時間: 出荷ポイント) (String)
GI_TIME 出庫時刻 (現地時間 - プラント参照) (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)
DLV_DATE 納入日程日付 (String)
DLV_TIME 納入時間 (String)
REL_TYPE 承認タイプ (String)
PLAN_SCHED_TYPE 納入日程行タイプ EDI (String)

納入日程行オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の納入日程行の「販売伝票明細」
[idx]["SCHED_LINE"]　→　配列内のidx番目の納入日程行の「納入日程行」
[idx]["REQ_DATE"]　→　配列内のidx番目の納入日程行の「納入日程日付」
[idx]["DATE_TYPE"]　→　配列内のidx番目の納入日程行の「日付タイプ (日、週、月、期間)」
[idx]["REQ_TIME"]　→　配列内のidx番目の納入日程行の「納入時間」
[idx]["REQ_QTY"]　→　配列内のidx番目の納入日程行の「販売単位による受注数量」
[idx]["REQ_DLV_BL"]　→　配列内のidx番目の納入日程行の「出荷ブロック中の納入日程行」
[idx]["SCHED_TYPE"]　→　配列内のidx番目の納入日程行の「納入日程カテゴリ」
[idx]["TP_DATE"]　→　配列内のidx番目の納入日程行の「輸送計画日付」
[idx]["MS_DATE"]　→　配列内のidx番目の納入日程行の「品目利用可能日」
[idx]["LOAD_DATE"]　→　配列内のidx番目の納入日程行の「積載日付」
[idx]["GI_DATE"]　→　配列内のidx番目の納入日程行の「出庫日付」
[idx]["TP_TIME"]　→　配列内のidx番目の納入日程行の 「輸送計画 - 時間 (現地時間/出荷ポイント参照)」
[idx]["MS_TIME"]　→　配列内のidx番目の納入日程行の 「品目供給ステージ (現地時刻: プラント参照)」
[idx]["LOAD_TIME"]　→　配列内のidx番目の納入日程行の「積載時刻 (現地時間: 出荷ポイント)」
[idx]["GI_TIME"]　→　配列内のidx番目の納入日程行の「出庫時刻 (現地時間 - プラント参照)」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の納入日程行の「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の納入日程行の「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の納入日程行の「論理システム」
[idx]["DLV_DATE"]　→　配列内のidx番目の納入日程行の「納入日程日付」
[idx]["DLV_TIME"]　→　配列内のidx番目の納入日程行の「納入時間」
[idx]["REL_TYPE"]　→　配列内のidx番目の納入日程行の「承認タイプ」
[idx]["PLAN_SCHED_TYPE"]　→　配列内のidx番目の納入日程行の「納入日程行タイプ EDI」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderSchedulesInXList

Array getOrderSchedulesInXList ()

納入日程行チェックボックスを取得します。
返却値
Array 納入日程行チェックボックス

納入日程行チェックボックスオブジェクトの構成は以下のとおりです。
納入日程行チェックボックス
オブジェクト
(Object)
ITM_NUMBER 販売伝票明細 (String)
SCHED_LINE 納入日程行 (String)
UPDATEFLAG 更新区分 (String)
REQ_DATE 関連ユーザデータ項目の更新情報 (String)
DATE_TYPE 関連ユーザデータ項目の更新情報 (String)
REQ_TIME 関連ユーザデータ項目の更新情報 (String)
REQ_QTY 関連ユーザデータ項目の更新情報 (String)
REQ_DLV_BL 関連ユーザデータ項目の更新情報 (String)
SCHED_TYPE 関連ユーザデータ項目の更新情報 (String)
TP_DATE 関連ユーザデータ項目の更新情報 (String)
MS_DATE 関連ユーザデータ項目の更新情報 (String)
LOAD_DATE 関連ユーザデータ項目の更新情報 (String)
GI_DATE 関連ユーザデータ項目の更新情報 (String)
TP_TIME 関連ユーザデータ項目の更新情報 (String)
MS_TIME 関連ユーザデータ項目の更新情報 (String)
LOAD_TIME 関連ユーザデータ項目の更新情報 (String)
GI_TIME 関連ユーザデータ項目の更新情報 (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
DLV_DATE 関連ユーザデータ項目の更新情報 (String)
DLV_TIME 関連ユーザデータ項目の更新情報 (String)
REL_TYPE 関連ユーザデータ項目の更新情報 (String)
PLAN_SCHED_TYPE 関連ユーザデータ項目の更新情報 (String)

納入日程行チェックボックスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の納入日程行チェックボックスの「販売伝票明細」
[idx]["SCHED_LINE"]　→　配列内のidx番目の納入日程行チェックボックスの「納入日程行」
[idx]["UPDATEFLAG"]　→　配列内のidx番目の納入日程行チェックボックスの「更新区分」
[idx]["REQ_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["DATE_TYPE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REQ_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REQ_QTY 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REQ_DLV_BL 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["SCHED_TYPE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["TP_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["MS_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["LOAD_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["GI_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["TP_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["MS_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["LOAD_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["GI_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の納入日程行チェックボックスの「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の納入日程行チェックボックスの「オブジェクトキー」
[idx]["DLV_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["DLV_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REL_TYPE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["PLAN_SCHED_TYPE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderTextList

Array getOrderTextList ()

テキストを取得します。
返却値
Array テキスト

テキストオブジェクトの構成は以下のとおりです。
テキスト
オブジェクト
(Object)
DOC_NUMBE 販売伝票 (String)
ITM_NUMBE 販売伝票明細 (String)
TEXT_ID テキスト ID (String)
LANGU 言語キー (String)
LANGU_ISO ISO 639 準拠の言語 (String)
FORMAT_COL タグ列 (String)
TEXT_LINE テキスト行 (String)
FUNCTION 機能 (String)

テキストオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["DOC_NUMBE"]　→　配列内のidx番目のテキストの「販売伝票」
[idx]["ITM_NUMBE"]　→　配列内のidx番目のテキストの「販売伝票明細」
[idx]["TEXT_ID"]　→　配列内のidx番目のテキストの「テキスト ID」
[idx]["LANGU"]　→　配列内のidx番目のテキストの「言語キー」
[idx]["LANGU_ISO"]　→　配列内のidx番目のテキストの「ISO 639 準拠の言語」
[idx]["FORMAT_COL"]　→　配列内のidx番目のテキストの「タグ列」
[idx]["TEXT_LINE"]　→　配列内のidx番目のテキストの「テキスト行」
[idx]["FUNCTION"]　→　配列内のidx番目のテキストの「機能」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPartnerAddressesList

Array getPartnerAddressesList ()

アドレス (組織/会社) 用 BAPI 参照構造を取得します。
返却値
Array アドレス (組織/会社) 用 BAPI 参照構造

アドレス (組織/会社) 用 BAPI 参照構造オブジェクトの構成は以下のとおりです。
アドレス (組織/会社) 用 BAPI 参照構造
オブジェクト
(Object)
ADDR_NO アドレス番号 (String)
FORMOFADDR 敬称テキスト (String)
NAME 名称 1 (String)
NAME_2 名称 2 (String)
NAME_3 名称 3 (String)
NAME_4 名称 4 (String)
C_O_NAME 気付 (String)
CITY 市区町村 (String)
DISTRICT 所在地 (String)
CITY_NO 市区町村/地名ファイルの市区町村コード (String)
POSTL_COD1 市区町村の郵便番号 (String)
POSTL_COD2 私書箱郵便番号 (String)
POSTL_COD3 会社郵便番号 (大規模なユーザ用) (String)
PO_BOX 私書箱 (String)
PO_BOX_CIT 私書箱住所 (String)
DELIV_DIS 郵便配達地域 (String)
STREET 地名 (String)
STREET_NO 市区町村/地名ファイルの地名コード (String)
STR_ABBR 地名の略称 (例: スペイン) (String)
HOUSE_NO 番地-号 (String)
STR_SUPPL1 地名 2 (String)
STR_SUPPL2 地名 3 (String)
LOCATION 地名 5 (String)
BUILDING 旧: 建物 (番号または略称) (String)
FLOOR 建物の階 (String)
ROOM_NO 部屋/アパート番号 (String)
COUNTRY 国コード (String)
LANGU 言語キー (String)
REGION 地域 (都道府県) (String)
SORT1 検索条件 1 (String)
SORT2 検索条件 2 (String)
TIME_ZONE アドレスタイムゾーン (String)
TAXJURCODE 税管轄コード (String)
ADR_NOTES 住所注記 (String)
COMM_TYPE 通信方法 (キー) (アドレス管理) (String)
TEL1_NUMBR 第一電話番号: ダイヤルコード + 番号 (String)
TEL1_EXT 第 1 電話番号: 内線 (String)
FAX_NUMBER 第一 FAX 番号: ダイヤルコード + 番号 (String)
FAX_EXTENS 第一 FAX 番号: 内線 (String)
STREET_LNG 地名 (String)
DISTRCT_NO 市区町村/地名ファイルの所在地コード (String)
CHCKSTATUS 市区町村ファイルテストステータス (String)
PBOXCIT_NO 市区町村私書箱コード (市ファイル) (String)
TRANSPZONE 商品の納入区域 (String)
HOUSE_NO2 番地補足 (String)
E_MAIL 電子メールアドレス (String)
STR_SUPPL3 地名 4 (String)
TITLE タイトル (敬称) (String)
COUNTRYISO ISO 国コード (String)
LANGU_ISO ISO 639 準拠の言語 (String)
BUILD_LONG 建物 (番号またはコード) (String)
REGIOGROUP 地域構造グループ化 (String)
HOME_CITY 市区町村 (郵便用市区町村と異なる場合) (String)
HOMECITYNO 別の市区町村 (市区町村/地名ファイル) (String)
PCODE1_EXT 市区町村郵便番号の拡張子 例: 郵便番号 +4+2 (String)
PCODE2_EXT 私書箱郵便番号拡張子 例: 郵便番号 +4+2 (String)
PCODE3_EXT 主要得意先郵便番号拡張子 例: 郵便番号 +4+2 (String)
PO_W_O_NO フラグ: 郵便私書箱 (番号なし) (String)
PO_BOX_REG 私書箱の地域 (国、都道府県、地域、...) (String)
POBOX_CTRY 私書箱の国指定 (String)
PO_CTRYISO ISO 国コード (String)
HOMEPAGE URI 例: ホームページ、FTP アドレス (String)
DONT_USE_S 地名住所配達不可フラグ (String)
DONT_USE_P 私書箱住所配達不可フラグ (String)
HOUSE_NO3 番地範囲 (String)
LANGU_CR アドレスレコード登録オリジナル言語 (String)
LANGUCRISO ISO 639 準拠の言語 (String)

アドレス (組織/会社) 用 BAPI 参照構造オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ADDR_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「アドレス番号」
[idx]["FORMOFADDR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「敬称テキスト」
[idx]["NAME"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「名称 1」
[idx]["NAME_2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「名称 2」
[idx]["NAME_3"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「名称 3」
[idx]["NAME_4"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「名称 4」
[idx]["C_O_NAME"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「気付」
[idx]["CITY"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「市区町村」
[idx]["DISTRICT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「所在地」
[idx]["CITY_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村/地名ファイルの市区町村コード」
[idx]["POSTL_COD1"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村の郵便番号」
[idx]["POSTL_COD2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱郵便番号」
[idx]["POSTL_COD3"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「会社郵便番号 (大規模なユーザ用)」
[idx]["PO_BOX"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「私書箱」
[idx]["PO_BOX_CIT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱住所」
[idx]["DELIV_DIS"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「郵便配達地域」
[idx]["STREET"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「地名」
[idx]["STREET_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村/地名ファイルの地名コード」
[idx]["STR_ABBR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名の略称 (例: スペイン)」
[idx]["HOUSE_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「番地-号」
[idx]["STR_SUPPL1"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名 2」
[idx]["STR_SUPPL2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名 3」
[idx]["LOCATION"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「地名 5」
[idx]["BUILDING"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「旧: 建物 (番号または略称)」
[idx]["FLOOR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「建物の階」
[idx]["ROOM_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「部屋/アパート番号」
[idx]["COUNTRY"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「国コード」
[idx]["LANGU"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「言語キー」
[idx]["REGION"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地域 (都道府県)」
[idx]["SORT1"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「検索条件 1」
[idx]["SORT2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「検索条件 2」
[idx]["TIME_ZONE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「アドレスタイムゾーン」
[idx]["TAXJURCODE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「税管轄コード」
[idx]["ADR_NOTES"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「住所注記」
[idx]["COMM_TYPE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「通信方法 (キー) (アドレス管理)」
[idx]["TEL1_NUMBR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「第一電話番号: ダイヤルコード + 番号」
[idx]["TEL1_EXT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「第 1 電話番号: 内線」
[idx]["FAX_NUMBER"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「第一 FAX 番号: ダイヤルコード + 番号」
[idx]["FAX_EXTENS"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「第一 FAX 番号: 内線」
[idx]["STREET_LNG"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「地名」
[idx]["DISTRCT_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村/地名ファイルの所在地コード」
[idx]["CHCKSTATUS"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村ファイルテストステータス」
[idx]["PBOXCIT_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村私書箱コード (市ファイル)」
[idx]["TRANSPZONE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「商品の納入区域」
[idx]["HOUSE_NO2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「番地補足」
[idx]["E_MAIL"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「電子メールアドレス」
[idx]["STR_SUPPL3"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名 4」
[idx]["TITLE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「タイトル (敬称)」
[idx]["COUNTRYISO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「ISO 国コード」
[idx]["LANGU_ISO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「ISO 639 準拠の言語」
[idx]["BUILD_LONG"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「建物 (番号またはコード)」
[idx]["REGIOGROUP"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地域構造グループ化」
[idx]["HOME_CITY"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村 (郵便用市区町村と異なる場合)」
[idx]["HOMECITYNO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「別の市区町村 (市区町村/地名ファイル)」
[idx]["PCODE1_EXT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村郵便番号の拡張子 例: 郵便番号 +4+2」
[idx]["PCODE2_EXT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱郵便番号拡張子 例: 郵便番号 +4+2」
[idx]["PCODE3_EXT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「主要得意先郵便番号拡張子 例: 郵便番号 +4+2」
[idx]["PO_W_O_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「フラグ: 郵便私書箱 (番号なし)」
[idx]["PO_BOX_REG"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱の地域 (国、都道府県、地域、...)」
[idx]["POBOX_CTRY"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱の国指定」
[idx]["PO_CTRYISO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「ISO 国コード」
[idx]["HOMEPAGE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「URI 例: ホームページ、FTP アドレス」
[idx]["DONT_USE_S"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名住所配達不可フラグ」
[idx]["DONT_USE_P"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱住所配達不可フラグ」
[idx]["HOUSE_NO3"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「番地範囲」
[idx]["LANGU_CR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「アドレスレコード登録オリジナル言語」
[idx]["LANGUCRISO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「ISO 639 準拠の言語」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getSalesdocument

Object getSalesdocument ()

生成された伝票の番号を取得します。

返却値
Object 生成された伝票の番号
getSalesdocumentin

Object getSalesdocumentin ()

販売管理伝票番号を取得します。

返却値
Object 販売管理伝票番号
getSender

Object getSender ()

論理システム - 送信者を取得します。
返却値
Object 論理システム - 送信者

論理システム - 送信者オブジェクトの構成は以下のとおりです。
LOG_SYSTEM 論理システム (String)

論理システム - 送信者オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["LOG_SYSTEM"]　→　配列内のidx番目の論理システム - 送信者の「論理システム」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getTestrun

Object getTestrun ()

テスト実行を取得します。
返却値
Object テスト実行
setBehaveWhenError

void setBehaveWhenError (Object value)

エラー処理を設定します｡
パラメータ
value Object エラー処理
返却値
void
setBinaryRelationshiptype

void setBinaryRelationshiptype (Object value)

バイナリ関連タイプ (専用)を設定します｡
パラメータ
value Object バイナリ関連タイプ (専用)
返却値
void
setConvert

void setConvert (Object value)

変換: 取引先機能 + 受注伝票タイプを設定します｡
パラメータ
value Object 変換: 取引先機能 + 受注伝票タイプ
返却値
void
setIntNumberAssignment

void setIntNumberAssignment (Object value)

明細番号内部採番を設定します｡
パラメータ
value Object 明細番号内部採番
返却値
void
setSalesdocumentin

void setSalesdocumentin (Object value)

販売管理伝票番号を設定します｡
パラメータ
value Object 販売管理伝票番号
返却値
void
setStrParam

void setStrParam (String paramStr ,String paramName ,Object value)

構造型の項目に値をセットします。
パラメータ
paramStr | String | 構造名
paramName | String | 項目名
value | Object | セットする値
返却値
void
setTblParam

void setTblParam (String paramTable ,String paramName ,Object value ,int index)

テーブル型の項目に値をセットします。
パラメータ
paramTable | String | テーブル名
paramName | String | 項目名
value | Object | セットする値
index | int | レコード番号
返却値
void
setTestrun

void setTestrun (Object value)

テスト実行を設定します｡
パラメータ
value Object テスト実行
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 SalesOrderGetListController オブジェクト

販売伝票一覧照会コントローラクラス。

機能は以下の通り
  • 販売伝票一覧を取得します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
SalesOrderGetListController ()
コンストラクタ。
SalesOrderGetListController (SapClient sapClient)
コンストラクタ。
SalesOrderGetListController (String customerNumber ,String salesOrganisation ,String material ,String purchaseOrder ,String transactionGroup ,SAPクライアント sapClient)
コンストラクタ。
SalesOrderGetListController (String customerNumber ,String salesOrganisation ,String material ,String purchaseOrder ,String transactionGroup)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより販売伝票を取得します。
value | getCustomerNumber () 得意先コードを取得します。
Object | getDocumentDate () 登録日付を取得します。
Object | getDocumentDateTo () 入力日付 (以前/以降)を取得します。
Object | getMaterial () 品目コードを取得します。
Object | getMaterialEvg () 品目コード(長)を取得します｡
Object | getPurchaseOrder () 得意先発注番号を取得します。
Object | getPurchaseOrderNumber () 得意先発注番号1を取得します。
Object | getSalesOrdersList () 販売伝票一覧を取得します。
Object | getSalesOrganization () 販売組織を取得します。
Object | getTransactionGroup () 一文字フラグを取得します。
void | setStrParam (String paramStr ,String paramName ,Object value) 構造型の項目に値をセットします。
void | setTblParam (String paramTable ,String paramName ,Object value ,int index) テーブル型の項目に値をセットします。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
SalesOrderGetListController

SalesOrderGetListController ()
コンストラクタ。
SalesOrderGetListController

SalesOrderGetListController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
SalesOrderGetListController

SalesOrderGetListController (String customerNumber ,String salesOrganisation ,String material ,String purchaseOrder ,String transactionGroup ,SAPクライアント sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
customerNumber | String | 得意先コード
salesOrganisation | String | 販売組織
material | String | 品目コード
purchaseOrder | String | 得意先発注番号
transactionGroup | String | 一文字フラグ
sapClient | SAPクライアント
SalesOrderGetListController

SalesOrderGetListController (String customerNumber ,String salesOrganisation ,String material ,String purchaseOrder ,String transactionGroup)
コンストラクタ。

パラメータ
customerNumber | String | 得意先コード
salesOrganisation | String | 販売組織
material | String | 品目コード
purchaseOrder | String | 得意先発注番号
transactionGroup | String | 一文字フラグ
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより販売伝票を取得します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getCustomerNumber

value getCustomerNumber ()

得意先コードを取得します。
返却値
value Object 得意先コード
getDocumentDate

Object getDocumentDate ()

登録日付を取得します。
返却値
Object 登録日付
getDocumentDateTo

Object getDocumentDateTo ()

入力日付 (以前/以降)を取得します。
返却値
Object 入力日付 (以前/以降)
getMaterial

Object getMaterial ()

品目コードを取得します。
返却値
Object 品目コード
getMaterialEvg

Object getMaterialEvg ()

品目コード(長)を取得します｡
返却値
Object 品目コード(長)

品目コード(長)情報オブジェクトの構成は以下のとおりです。
品目コード(長)
オブジェクト
(Object)
MATERIAL_EXT外部品目コード(長)(String)
MATERIAL_VERS品目バージョン番号(String)
MATERIAL_GUID品目コード(外部GUID)(String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPurchaseOrder

Object getPurchaseOrder ()

得意先発注番号を取得します。
返却値
Object 得意先発注番号
getPurchaseOrderNumber

Object getPurchaseOrderNumber ()

得意先発注番号1を取得します。
返却値
Object 得意先発注番号1
getSalesOrdersList

Object getSalesOrdersList ()

販売伝票一覧を取得します。
返却値
Object 販売伝票一覧

販売伝票一覧情報オブジェクトの構成は以下のとおりです。
販売伝票一覧情報
オブジェクト
(Object)
SD_DOC 販売管理伝票番号 (String)
ITM_NUMBER 明細番号 (販売管理伝票) (String)
MATERIAL 品目コード (String)
SHORT_TEXT テキスト (短): 受注明細 (String)
DOC_TYPE 販売伝票タイプ (String)
DOC_DATE 伝票日付 (受信日/送信日) (String)
REQ_QTY 累積受注数量 (販売単位) (String)
REQ_DATE 指定納期 (String)
PURCH_NO 得意先発注番号 (String)
BATCH ロット番号 (String)
VALID_FROM 見積または基本契約の有効開始日 (String)
VALID_TO 見積または基本契約有効終了日 (String)
BILL_BLOCK 販売管理伝票の請求ブロック (String)
DLV_BLOCK 出荷ブロック (伝票ヘッダ) (String)
SOLD_TO 受注先 (String)
NAME 名称 1 (String)
EXCHG_RATE 価格設定/統計の換算レート (直接引用) (String)
DLV_QTY 出荷数量実績 (販売単位) (String)
BASE_UOM 基本数量単位 (String)
NET_PRICE 正味価格 (String)
COND_P_UNT 価格条件単位 (String)
COND_UNIT 条件単位 (String)
NET_VAL_HD 受注正味額 (伝票通貨) (String)
NET_VALUE 伝票通貨による正味額 (String)
DIVISION 製品部門 (String)
DOC_STATUS 伝票ステータス (String)
SALES_GRP 営業グループ (String)
SALES_OFF 営業所 (String)
SALES_ORG 販売組織 (String)
SALES_UNIT 販売単位 (String)
SHIP_POINT 出荷ポイント/入荷ポイント (String)
DISTR_CHAN 流通チャネル (String)
GI_DATE 出庫日付 (String)
CURRENCY 販売伝票通貨 (String)
PLANT プラント (String)
STORE_LOC 保管場所 (String)
ORD_REASON 受注理由 (取引理由) (String)
REASON_REJ 見積および受注の拒否理由 (String)
B_UOM_ISO ISO コードでの基本数量単位 (String)
CD_UNT_ISO 条件数量単位 (ISO コード) (String)
S_UNIT_ISO ISO コードによる販売単位 (String)
CURR_ISO ISO コード通貨 (String)
PURCH_NO_C 出荷先発注番号 (String)
EXCHG_RATE_V 価格設定/統計の換算レート (間接引用) (String)
MAT_EXT 項目 MATERIAL の品目コード (長) (String)
MAT_GUID 項目 MATERIAL の外部 GUID (String)
MAT_VERS 項目 MATERIAL のバージョン番号 (String)
CREATION_DATE レコード登録日 (String)
CREATION_TIME 登録時刻 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11: 販売発注システムエラー
12: 販売発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getSalesOrganization

Object getSalesOrganization ()

販売組織を取得します。
返却値
Object 販売組織
getTransactionGroup

Object getTransactionGroup ()

一文字フラグを取得します。
返却値
Object 一文字フラグ
setStrParam

void setStrParam (String paramStr ,String paramName ,Object value)

構造型の項目に値をセットします。
パラメータ
paramStr | String | 構造名
paramName | String | 項目名
value | Object | セットする値
返却値
void
setTblParam

void setTblParam (String paramTable ,String paramName ,Object value ,int index)

テーブル型の項目に値をセットします。
パラメータ
paramTable | String | テーブル名
paramName | String | 項目名
value | Object | セットする値
index | int | レコード番号
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 SalesOrderGetStatusController オブジェクト

販売伝票ステータス一覧照会コントローラクラス。

機能は以下の通り
  • 販売伝票ステータス一覧を照会します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
SalesOrderGetStatusController ()
コンストラクタ
SalesOrderGetStatusController (SapClient sapClient)
コンストラクタ。
SalesOrderGetStatusController (String salesdocument)
コンストラクタ。
SalesOrderGetStatusController (String salesdocument ,SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより販売伝票ステータスを取得します。
value | getSalesdocument () 販売管理伝票番号を取得します。
Object | getStatusInfoList () 販売伝票ステータス一覧を取得します。
void | setTblParam (String paramTable ,String paramName ,Object value ,int index) テーブル型の項目に値をセットします。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
SalesOrderGetStatusController

SalesOrderGetStatusController ()
コンストラクタ
SalesOrderGetStatusController

SalesOrderGetStatusController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
SalesOrderGetStatusController

SalesOrderGetStatusController (String salesdocument)
コンストラクタ。

パラメータ
salesdocument String 販売管理伝票番号
SalesOrderGetStatusController

SalesOrderGetStatusController (String salesdocument ,SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
salesdocument | String | 販売管理伝票番号
sapClient | SapClient | Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより販売伝票ステータスを取得します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getSalesdocument

value getSalesdocument ()

販売管理伝票番号を取得します。
返却値
value String 販売管理伝票番号
getStatusInfoList

Object getStatusInfoList ()

販売伝票ステータス一覧を取得します。
返却値
Object 販売伝票ステータス一覧

販売伝票ステータス一覧情報オブジェクトの構成は以下のとおりです。
販売伝票ステータス一覧情報
オブジェクト
(Object)
DOC_NUMBER 販売伝票 (String)
DOC_DATE 伝票日付 (受信日/送信日) (String)
PURCH_NO 得意先発注番号 (String)
PRC_STAT_H 伝票の全処理ステータス (String)
DLV_STAT_H 全明細の出荷ステータス (String)
REQ_DATE_H 指定納入期日 (String)
DLV_BLOCK 出荷ブロック (伝票ヘッダ) (String)
ITM_NUMBER 販売伝票明細 (String)
MATERIAL 品目コード (String)
SHORT_TEXT テキスト (短): 受注明細 (String)
REQ_DATE 納入日程日付 (String)
REQ_QTY 累積受注数量 (販売単位) (String)
CUM_CF_QTY 累積確認数量 (販売数量単位) (String)
SALES_UNIT 販売単位 (String)
NET_VALUE 伝票通貨での受注明細正味額 (String)
CURRENCY 販売伝票通貨 (String)
NET_PRICE 正味価格 (String)
COND_P_UNT 価格条件単位 (String)
COND_UNIT 条件単位 (String)
DLV_STAT_I 明細の全体出荷ステータス (String)
DELIV_NUMB 出荷伝票 (String)
DELIV_ITEM 出荷明細 (String)
DELIV_DATE 納入期日 (String)
DLV_QTY 出荷数量実績 (販売単位) (String)
REF_QTY 基本数量単位による参照数量 (String)
S_UNIT_ISO ISO コードによる販売単位 (String)
CD_UNT_ISO 条件数量単位 (ISO コード) (String)
CURR_ISO ISO コード通貨 (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード (長) (String)
MATERIAL_GUID 項目 MATERIAL の外部 GUID (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (String)
PO_ITM_NO 元となる購買発注の明細番号 (String)
CREATION_DATE レコード登録日 (String)
CREATION_TIME 登録時刻 (String)
S_UNIT_DLV 出荷単位 (String)
DLV_UNIT_ISO ISO コードでの出荷単位の数量単位 (String)
REA_FOR_RE 見積および受注の拒否理由 (String)
PURCH_NO_C 得意先発注番号 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11: 販売管理システムエラー
12: 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

setTblParam

void setTblParam (String paramTable ,String paramName ,Object value ,int index)

テーブル型の項目に値をセットします。
パラメータ
paramTable | String | テーブル名
paramName | String | 項目名
value | Object | セットする値
index | int | レコード番号
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 StdMaterialGetIntNumberController オブジェクト

品目コード割当済照会コントローラクラス。

機能は以下の通り
  • 品目コード割当済情報を取得します。
バージョン：1.0
導入されたバージョン：6.1
コンストラクタの概要
StdMaterialGetIntNumberController (materialType String ,industrySector String ,requiredNumbers String)
コンストラクタ。
StdMaterialGetIntNumberController (materialType String ,industrySector String ,requiredNumbers String ,SapClient sapClient)
コンストラクタ。
メソッドの概要
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
Array | getStdMaterialGetIntNumberList () 品目コード割当済一覧(結果)を取得します。
コンストラクタの詳細
StdMaterialGetIntNumberController

StdMaterialGetIntNumberController (materialType String ,industrySector String ,requiredNumbers String)
コンストラクタ。

品目コード割当済一覧を作成します。
パラメータ
String | materialType | 品目タイプ
String | industrySector | 産業コード
String | requiredNumbers | 必須品目コードの設定 ※割当数
StdMaterialGetIntNumberController

StdMaterialGetIntNumberController (materialType String ,industrySector String ,requiredNumbers String ,SapClient sapClient)
コンストラクタ。

品目コード割当済一覧を作成します。
SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
String | materialType | 品目タイプ
String | industrySector | 産業コード
String | requiredNumbers | 必須品目コードの設定
sapClient | SapClient | Sapクライアント
メソッドの詳細
getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getStdMaterialGetIntNumberList

Array getStdMaterialGetIntNumberList ()

品目コード割当済一覧(結果)を取得します。

返却値
Array 品目コード割当済一覧(結果)

品目コード割当済情報オブジェクトの構成は以下のとおりです。
品目コード割当済情報
オブジェクト
(Object)
MATERIAL 品目コード (String)
MATERIAL_EXTERNAL MATERIAL の品目コード (長) (String)
MATERIAL_GUID MATERIAL の外部 GUID (String)
MATERIAL_VERSION MATERIAL のバージョン番号 (String)

取得した品目コード割当済情報の配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["MATERIAL"]　→　配列内のidx番目の会社の「品目コード」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の会社の「MATERIAL の品目コード (長)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の会社の「MATERIAL の外部 GUID (String)」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の会社の「MATERIAL のバージョン番号」

※ idxは0〜n （配列サイズ-1）
※ 配列サイズは、コンストラクタ 第3引数 requiredNumbers で指定した数となります。


 SupplierExistenceCheckController オブジェクト

仕入先コード存在チェックコントローラクラス。

機能は以下の通り
  • 仕入先コード存在チェック情報を取得します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
SupplierExistenceCheckController (String vendor ,String compCode)
コンストラクタ｡
SupplierExistenceCheckController (String vendor ,String compCode ,SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | getCheckReturn () 結果情報を取得します｡
Object | getCompCode () 会社コードを取得します。
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
Object | getSupplierExistenceCheck () 仕入先コード存在チェック情報を取得します｡
Object | getVendor () 仕入先コードを取得します｡
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
SupplierExistenceCheckController

SupplierExistenceCheckController (String vendor ,String compCode)
コンストラクタ｡
パラメータ
vendor | String | 仕入先コード
compCode | String | 会社コード
SupplierExistenceCheckController

SupplierExistenceCheckController (String vendor ,String compCode ,SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
vendor | String | 仕入先コード
compCode | String | 会社コード
sapClient | SapClient | Sapクライアント
メソッドの詳細
getCheckReturn

Object getCheckReturn ()

結果情報を取得します｡

返却値
Object 結果情報
getCompCode

Object getCompCode ()

会社コードを取得します。

返却値
Object 会社コード
getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getSupplierExistenceCheck

Object getSupplierExistenceCheck ()

仕入先コード存在チェック情報を取得します｡

返却値
Object 仕入先コード存在チェック情報
getVendor

Object getVendor ()

仕入先コードを取得します｡

返却値
Object 仕入先コード
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 SupplierGetDetailController オブジェクト

仕入先マスタの詳細照会コントローラクラス。

機能は以下の通り
  • 仕入先マスタの詳細照会情報を取得します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
SupplierGetDetailController (String vendor ,String compCode)
コンストラクタ｡
SupplierGetDetailController (String vendor ,String compCode ,SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | getBankDataList () 銀行データ情報を取得します。
Object | getCompanyDataInfo () 会社コード依存データ情報を取得します｡
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
Object | getGeneralDataInfo () 一般データ情報を取得します｡
Object | getSupplierDetail () 仕入先マスタ詳細情報を取得します｡
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
SupplierGetDetailController

SupplierGetDetailController (String vendor ,String compCode)
コンストラクタ｡
パラメータ
vendor | String | 仕入先コード
compCode | String | 会社コード
SupplierGetDetailController

SupplierGetDetailController (String vendor ,String compCode ,SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
vendor | String | 仕入先コード
compCode | String | 会社コード
sapClient | SapClient | Sapクライアント
メソッドの詳細
getBankDataList

Object getBankDataList ()

銀行データ情報を取得します。
返却値
Object 銀行国コード(銀行データ情報)

銀行データ情報オブジェクトの構成は以下のとおりです。
銀行データ情報
オブジェクト
(Object)
VENDOR 仕入先または債権者の勘定コード (String)
BANK_CTRY 銀行国コード (String)
BANK_KEY 銀行コード (String)
BANK_ACCT 口座番号 (String)
CTRL_KEY 預金種別 (String)
PARTNER_BK 取引先銀行タイプ (String)
COLL_AUTH フラグ: 回収権限 (String)
BANK_REF 銀行詳細の参照詳細 (String)

取得した銀行データ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["VENDOR"]　→　配列内のidx番目の銀行データの「仕入先または債権者の勘定コード」
[idx]["BANK_CTRY"]　→　配列内のidx番目の銀行データの「銀行国コード」
[idx]["BANK_KEY"]　→　配列内のidx番目の銀行データの「銀行コード」
[idx]["BANK_ACCT"]　→　配列内のidx番目の銀行データの「口座番号」
[idx]["CTRL_KEY"]　→　配列内のidx番目の銀行データの「預金種別」
[idx]["PARTNER_BK"]　→　配列内のidx番目の銀行データの「取引先銀行タイプ」
[idx]["COLL_AUTH"]　→　配列内のidx番目の銀行データの「フラグ: 回収権限」
[idx]["BANK_REF"]　→　配列内のidx番目の銀行データの「銀行詳細の参照詳細」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getCompanyDataInfo

Object getCompanyDataInfo ()

会社コード依存データ情報を取得します｡
返却値
Object 会社コード依存データ

会社コード依存データ情報オブジェクトの構成は以下のとおりです。
会社コード依存データ情報
オブジェクト
(Object)
VEODOR 仕入先または債権者の勘定コード (String)
COMP_CODE 会社コード (String)
CLERK 記帳担当者 (String)
HD_OFFICE 本店勘定コード (String)
ALT_PAYEE 代理受取人勘定コード (String)
CUVD_CLEAR フラグ: 得意先と仕入先間の相殺決済 (String)
PMNTTRMS 支払条件キー (String)
ACT_AT_VEN 仕入先での自社勘定コード (String)
VEND_USER 仕入先担当者 (String)
INTERNET 関係会社担当者のインターネットアドレス (String)
FAX 得意先/仕入先の経理担当者のファックス No. (String)
PAYMENT_METHODS 考慮される支払方法一覧 (String)
TEL 取引先での記帳担当者電話番号 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getGeneralDataInfo

Object getGeneralDataInfo ()

一般データ情報を取得します｡
返却値
Object 一般データ

一般データ情報オブジェクトの構成は以下のとおりです。
一般データ情報
オブジェクト
(Object)
VENDOR 仕入先または債権者の勘定コード (String)
NAME 名称 1 (String)
NAME_2 名称 2 (String)
NAME_3 名称 3 (String)
NAME_4 名称 4 (String)
CITY 市区町村 (String)
DISTRICT 所在地 (String)
PO_BOX 私書箱 (String)
POBX_PCD 私書箱番号 (String)
POSTL_CODE 郵便番号 (String)
REGION 地域 (都道府県) (String)
STREET 地名/番地-号 (String)
COUNTRY 国コード (String)
COUNTRYISO ISO 国コード (String)
POBX_CTY 私書箱住所 (String)
LANGU ISO 639 準拠の言語 (String)
LANGU_ISO ISO 639 準拠の言語 (String)
TELEPHONE 電話番号 1 (String)
FORMOFADDR 敬称 (String)
TELEPHONE2 電話番号 2 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getSupplierDetail

Object getSupplierDetail ()

仕入先マスタ詳細情報を取得します｡
返却値
Object 仕入先マスタ
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 AccEmployeePayPostController オブジェクト

伝票登録コントローラクラス。

会計伝票を登録します。
バージョン：1.1
導入されたバージョン：5.0
コンストラクタの概要
AccEmployeePayPostController ()
コンストラクタ。
AccEmployeePayPostController (ConnectionManager connectionManager)
コンストラクタ。
AccEmployeePayPostController (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより会計伝票を登録します。
String | getBapiReturnErrMessage () ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage () プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。
void | setCuAmtBase (String value ,Number recNo) 明細通貨項目の課税基準額に値を設定します。
void | setCuAmtDoccur (String value ,Number recNo) 明細通貨項目の伝票通貨額に値を設定します。
void | setCuCurrency (String value ,Number recNo) 明細通貨項目の通貨コードに値を設定します。
void | setCuItemnoAcc (String value ,Number recNo) 明細通貨項目の会計伝票明細番号に値を設定します。
void | setDocAcDocNo (String value) 伝票ヘッダの会計伝票番号に値を設定します。
void | setDocCompCode (String value) 伝票ヘッダの会社コードに値を設定します。
void | setDocDocDate (String value) 伝票ヘッダの伝票の伝票日付に値を設定します。
void | setDocDocType (String value) 伝票ヘッダの伝票タイプに値を設定します。
void | setDocFisPeriod (String value) 伝票ヘッダの会計期間に値を設定します。
void | setDocFiscYear (String value) 伝票ヘッダの会計年度に値を設定します。
void | setDocHeaderTxt (String value) 伝票ヘッダの伝票ヘッダテキストに値を設定します。
void | setDocObjKey (String value) 伝票ヘッダのオブジェクトキーに値を設定します。
void | setDocObjType (String value) 伝票ヘッダの参照処理に値を設定します。
void | setDocPstngDate (String value) 伝票ヘッダの伝票の転記日付に値を設定します。
void | setDocRefDocNo (String value) 伝票ヘッダの参照伝票番号に値を設定します。
void | setDocUsername (String value) 伝票ヘッダのユーザ名に値を設定します。
void | setGlAllocNmbr (String value ,Number recNo) G/L 勘定明細のソートキーに値を設定します。
void | setGlBusArea (String value ,Number recNo) G/L 勘定明細の事業領域に値を設定します。
void | setGlCompCode (String value ,Number recNo) G/L 勘定明細の会社コードに値を設定します。
void | setGlCostcenter (String value ,Number recNo) G/L 勘定明細の原価センタに値を設定します。
void | setGlDocType (String value ,Number recNo) G/L 勘定明細の伝票タイプに値を設定します。
void | setGlFiscYear (String value ,Number recNo) G/L 勘定明細の会計年度に値を設定します。
void | setGlGlAccount (String value ,Number recNo) G/L 勘定明細の総勘定元帳勘定に値を設定します。
void | setGlItemText (String value ,Number recNo) G/L 勘定明細の明細テキストに値を設定します。
void | setGlItemnoAcc (String value ,Number recNo) G/L 勘定明細の会計伝票明細番号に値を設定します。
void | setGlOrderid (String value ,Number recNo) G/L 勘定明細の指図番号に値を設定します。
void | setGlPstngDate (String value ,Number recNo) G/L 勘定明細の伝票の転記日付に値を設定します。
void | setGlRefKey1 (String value ,Number recNo) G/L 勘定明細の取引先参照キーに値を設定します。
void | setGlTaxCode (String value ,Number recNo) G/L 勘定明細の消費税コードに値を設定します。
void | setGlWbsElement (String value ,Number recNo) G/L 勘定明細のWBS 要素に値を設定します。
void | setPaAllocNmbr (String value ,Number recNo) 仕入先明細のソートキーに値を設定します。
void | setPaBlineDate (String value ,Number recNo) 仕入先明細の期日計算の支払基準日に値を設定します。
void | setPaGlAccount (String value ,Number recNo) 仕入先明細の総勘定元帳勘定に値を設定します。
void | setPaItemText (String value ,Number recNo) 仕入先明細の明細テキストに値を設定します。
void | setPaItemnoAcc (String value ,Number recNo) 仕入先明細の会計伝票明細番号に値を設定します。
void | setPaPymtMeth (String value ,Number recNo) 仕入先明細の支払方法に値を設定します。
void | setPaVendorNo (String value ,Number recNo) 仕入先明細の仕入先または債権者の勘定コードに値を設定します。
void | setTaGlAccount (String value ,Number recNo) 税明細の総勘定元帳勘定に値を設定します。
void | setTaItemnoAcc (String value ,Number recNo) 税明細の会計伝票明細番号に値を設定します。
void | setTaTaxCode (String value ,Number recNo) 税明細の消費税コードに値を設定します。
コンストラクタの詳細
AccEmployeePayPostController

AccEmployeePayPostController ()
コンストラクタ。

AccEmployeePayPostController

AccEmployeePayPostController (ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、AccEmployeePayPostController#executeBapi()実行後に 必ずConnectionManager#commit()またはConnectionManager#rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。
パラメータ
connectionManager ConnectionManager コネクションマネージャー
AccEmployeePayPostController

AccEmployeePayPostController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより会計伝票を登録します。

返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getBapiReturnErrMessage

String getBapiReturnErrMessage ()

ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡
返却値
String BAPI実行結果エラーとなった全てのメッセージ情報
getBapiReturnMessage

String getBapiReturnMessage ()

プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡
返却値
String プロパティファイルでオートコミット条件に一致したType情報のメッセージ情報
setCuAmtBase

void setCuAmtBase (String value ,Number recNo)

明細通貨項目の課税基準額に値を設定します。

パラメータ
value | String | 課税基準額
recNo | Number | レコード番号
返却値
void
setCuAmtDoccur

void setCuAmtDoccur (String value ,Number recNo)

明細通貨項目の伝票通貨額に値を設定します。

パラメータ
value | String | 伝票通貨額
recNo | Number | レコード番号
返却値
void
setCuCurrency

void setCuCurrency (String value ,Number recNo)

明細通貨項目の通貨コードに値を設定します。

パラメータ
value | String | 通貨コード
recNo | Number | レコード番号
返却値
void
setCuItemnoAcc

void setCuItemnoAcc (String value ,Number recNo)

明細通貨項目の会計伝票明細番号に値を設定します。

パラメータ
value | String | 会計伝票明細番号
recNo | Number | レコード番号
返却値
void
setDocAcDocNo

void setDocAcDocNo (String value)

伝票ヘッダの会計伝票番号に値を設定します。

パラメータ
value String 会計伝票番号
返却値
void
setDocCompCode

void setDocCompCode (String value)

伝票ヘッダの会社コードに値を設定します。

パラメータ
value String 会社コード
返却値
void
setDocDocDate

void setDocDocDate (String value)

伝票ヘッダの伝票の伝票日付に値を設定します。

パラメータ
value String 伝票の伝票日付
返却値
void
setDocDocType

void setDocDocType (String value)

伝票ヘッダの伝票タイプに値を設定します。

パラメータ
value String 伝票タイプ
返却値
void
setDocFisPeriod

void setDocFisPeriod (String value)

伝票ヘッダの会計期間に値を設定します。

パラメータ
value String 会計期間
返却値
void
setDocFiscYear

void setDocFiscYear (String value)

伝票ヘッダの会計年度に値を設定します。

パラメータ
value String 会計年度
返却値
void
setDocHeaderTxt

void setDocHeaderTxt (String value)

伝票ヘッダの伝票ヘッダテキストに値を設定します。

パラメータ
value String 伝票ヘッダテキスト
返却値
void
setDocObjKey

void setDocObjKey (String value)

伝票ヘッダのオブジェクトキーに値を設定します。

パラメータ
value String オブジェクトキー
返却値
void
setDocObjType

void setDocObjType (String value)

伝票ヘッダの参照処理に値を設定します。

パラメータ
value String 参照処理
返却値
void
setDocPstngDate

void setDocPstngDate (String value)

伝票ヘッダの伝票の転記日付に値を設定します。

パラメータ
value String 伝票の転記日付
返却値
void
setDocRefDocNo

void setDocRefDocNo (String value)

伝票ヘッダの参照伝票番号に値を設定します。

パラメータ
value String 参照伝票番号
返却値
void
setDocUsername

void setDocUsername (String value)

伝票ヘッダのユーザ名に値を設定します。

パラメータ
value String ユーザ名
返却値
void
setGlAllocNmbr

void setGlAllocNmbr (String value ,Number recNo)

G/L 勘定明細のソートキーに値を設定します。

パラメータ
value | String | ソートキー
recNo | Number | レコード番号
返却値
void
setGlBusArea

void setGlBusArea (String value ,Number recNo)

G/L 勘定明細の事業領域に値を設定します。

パラメータ
value | String | 事業領域
recNo | Number | レコード番号
返却値
void
setGlCompCode

void setGlCompCode (String value ,Number recNo)

G/L 勘定明細の会社コードに値を設定します。

パラメータ
value | String | 会社コード
recNo | Number | レコード番号
返却値
void
setGlCostcenter

void setGlCostcenter (String value ,Number recNo)

G/L 勘定明細の原価センタに値を設定します。

パラメータ
value | String | 原価センタ
recNo | Number | レコード番号
返却値
void
setGlDocType

void setGlDocType (String value ,Number recNo)

G/L 勘定明細の伝票タイプに値を設定します。

パラメータ
value | String | 伝票タイプ
recNo | Number | レコード番号
返却値
void
setGlFiscYear

void setGlFiscYear (String value ,Number recNo)

G/L 勘定明細の会計年度に値を設定します。

パラメータ
value | String | 会計年度
recNo | Number | レコード番号
返却値
void
setGlGlAccount

void setGlGlAccount (String value ,Number recNo)

G/L 勘定明細の総勘定元帳勘定に値を設定します。

パラメータ
value | String | 総勘定元帳勘定
recNo | Number | レコード番号
返却値
void
setGlItemText

void setGlItemText (String value ,Number recNo)

G/L 勘定明細の明細テキストに値を設定します。

パラメータ
value | String | 明細テキスト
recNo | Number | レコード番号
返却値
void
setGlItemnoAcc

void setGlItemnoAcc (String value ,Number recNo)

G/L 勘定明細の会計伝票明細番号に値を設定します。

パラメータ
value | String | 会計伝票明細番号
recNo | Number | レコード番号
返却値
void
setGlOrderid

void setGlOrderid (String value ,Number recNo)

G/L 勘定明細の指図番号に値を設定します。

パラメータ
value | String | 指図番号
recNo | Number | レコード番号
返却値
void
setGlPstngDate

void setGlPstngDate (String value ,Number recNo)

G/L 勘定明細の伝票の転記日付に値を設定します。

パラメータ
value | String | 伝票の転記日付
recNo | Number | レコード番号
返却値
void
setGlRefKey1

void setGlRefKey1 (String value ,Number recNo)

G/L 勘定明細の取引先参照キーに値を設定します。

パラメータ
value | String | 取引先参照キー
recNo | Number | レコード番号
返却値
void
setGlTaxCode

void setGlTaxCode (String value ,Number recNo)

G/L 勘定明細の消費税コードに値を設定します。

パラメータ
value | String | 消費税コード
recNo | Number | レコード番号
返却値
void
setGlWbsElement

void setGlWbsElement (String value ,Number recNo)

G/L 勘定明細のWBS 要素に値を設定します。

パラメータ
value | String | WBS要素
recNo | Number | レコード番号
返却値
void
setPaAllocNmbr

void setPaAllocNmbr (String value ,Number recNo)

仕入先明細のソートキーに値を設定します。

パラメータ
value | String | ソートキー
recNo | Number | レコード番号
返却値
void
setPaBlineDate

void setPaBlineDate (String value ,Number recNo)

仕入先明細の期日計算の支払基準日に値を設定します。

パラメータ
value | String | 期日計算の支払基準日
recNo | Number | レコード番号
返却値
void
setPaGlAccount

void setPaGlAccount (String value ,Number recNo)

仕入先明細の総勘定元帳勘定に値を設定します。

パラメータ
value | String | 総勘定元帳勘定
recNo | Number | レコード番号
返却値
void
setPaItemText

void setPaItemText (String value ,Number recNo)

仕入先明細の明細テキストに値を設定します。

パラメータ
value | String | 明細テキスト
recNo | Number | レコード番号
返却値
void
setPaItemnoAcc

void setPaItemnoAcc (String value ,Number recNo)

仕入先明細の会計伝票明細番号に値を設定します。

パラメータ
value | String | 会計伝票明細番号
recNo | Number | レコード番号
返却値
void
setPaPymtMeth

void setPaPymtMeth (String value ,Number recNo)

仕入先明細の支払方法に値を設定します。

パラメータ
value | String | 支払方法
recNo | Number | レコード番号
返却値
void
setPaVendorNo

void setPaVendorNo (String value ,Number recNo)

仕入先明細の仕入先または債権者の勘定コードに値を設定します。

パラメータ
value | String | 仕入先または債権者の勘定コード
recNo | Number | レコード番号
返却値
void
setTaGlAccount

void setTaGlAccount (String value ,Number recNo)

税明細の総勘定元帳勘定に値を設定します。

パラメータ
value | String | 総勘定元帳勘定
recNo | Number | レコード番号
返却値
void
setTaItemnoAcc

void setTaItemnoAcc (String value ,Number recNo)

税明細の会計伝票明細番号に値を設定します。

パラメータ
value | String | 会計伝票明細番号
recNo | Number | レコード番号
返却値
void
setTaTaxCode

void setTaTaxCode (String value ,Number recNo)

税明細の消費税コードに値を設定します。

パラメータ
value | String | 消費税コード
recNo | Number | レコード番号
返却値
void


 BankController オブジェクト

銀行コントローラクラス。

銀行の情報を取得します。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
BankController ()
コンストラクタ。
BankController (SapClient sapClient)
コンストラクタ。
メソッドの概要
Array | getBankList () 銀行一覧を取得します。
Object | getBankName (String bankKey) 銀行コードを指定して銀行名を取得します。
Object | getCity (String bankKey) 銀行コードを指定して市区町村名を取得します。
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
コンストラクタの詳細
BankController

BankController ()
コンストラクタ。

BankController

BankController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
getBankList

Array getBankList ()

銀行一覧を取得します。
返却値
Array 銀行情報が格納された配列

銀行情報オブジェクトの構成は以下のとおりです。
銀行情報
オブジェクト
(Object)
BANK_KEY 銀行コード (String)
BANK_NAME 銀行名 (String)
CITY 市区町村名 (String)

取得した銀行情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["BANK_KEY"]　→　配列内のidx番目の銀行の「銀行コード」
[idx]["BANK_NAME"]　→　配列内のidx番目の銀行の「銀行名」
[idx]["CITY"]　→　配列内のidx番目の銀行の「市区町村名」

※ idxは0〜n （配列サイズ-1）

getBankName

Object getBankName (String bankKey)

銀行コードを指定して銀行名を取得します。

パラメータ
bankKey String SAP R/3上に存在する銀行コード
返却値
Object 指定した銀行コードに対応する銀行名
（成功時の返却値は String になります。）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getCity

Object getCity (String bankKey)

銀行コードを指定して市区町村名を取得します。

パラメータ
bankKey String SAP R/3上に存在する銀行コード
返却値
Object 指定した銀行コードに対応する市区町村名
（成功時の返却値は String になります。）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ


 BillingDocCreateMultipleController オブジェクト

請求伝票登録コントローラクラス。

機能は以下の通り
  • 請求伝票を登録します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
BillingDocCreateMultipleController ()
コンストラクタ｡
BillingDocCreateMultipleController (ConnectionManager connectionManager)
コンストラクタ。
BillingDocCreateMultipleController (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより請求伝票を登録します。
String | getBapiReturnErrMessage () ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage () プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。
Array | getBillingDataInList () 処理予定明細データのテーブルを取得します。
Array | getCCardDataInList () 処理予定支払方法のテーブルを取得します。
Array | getConditionDataInList () 処理予定条件のテーブルを取得します。
Object | getCreatorDataIn () 取り込まれる日付の順序を取得します｡
Array | getErrorsList () 前明細の不正処理に関する情報を取得します。
Array | getSuccessList () 正常に処理された明細のテーブルを取得します。
Object | getTestrun () シミュレーション実行 ('X')、更新実行 (' ')を取得します。
Array | getTextDataInList () 処理予定明細データのテーブルを取得します。
void | setStrParam (String paramStr ,String paramName ,Object value) 構造型の項目に値をセットします。
void | setTblParam (String paramTable ,String paramName ,Object value ,int index) テーブル型の項目に値をセットします。
void | setTestrun (Object value) シミュレーション実行 ('X')、更新実行 (' ')を設定します｡
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
BillingDocCreateMultipleController

BillingDocCreateMultipleController ()
コンストラクタ｡
BillingDocCreateMultipleController

BillingDocCreateMultipleController (ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、BillingDocCreateMultipleController#executeBapi()実行後に必ず ConnectionManager#commit()またはConnectionManager#rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。
パラメータ
connectionManager ConnectionManager コネクションマネージャー
BillingDocCreateMultipleController

BillingDocCreateMultipleController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより請求伝票を登録します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getBapiReturnErrMessage

String getBapiReturnErrMessage ()

ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡
返却値
String BAPI実行結果エラーとなった全てのメッセージ情報
getBapiReturnMessage

String getBapiReturnMessage ()

プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡
返却値
String プロパティファイルでオートコミット条件に一致したType情報のメッセージ情報
getBillingDataInList

Array getBillingDataInList ()

処理予定明細データのテーブルを取得します。
返却値
Array 処理予定明細データのテーブル

処理予定明細データのテーブル情報オブジェクトの構成は以下のとおりです。
処理予定明細データのテーブル情報
オブジェクト
(Object)
SALESORG販売組織(String)
DISTR_CHAN流通チャネル(String)
DIVISION製品部門(String)
DOC_TYPE販売伝票タイプ(String)
ORDBILLTYP受注関連請求伝票に対する提案請求伝票タイプ(String)
BILL_DATE請求索引および印刷に対する請求日(String)
SOLD_TO受注先(String)
ITEM_CATEG明細カテゴリ (販売伝票)(String)
ACCTASGNMT品目の勘定設定グループ(String)
PRICE_DATE価格設定/外貨換算の実行日付(String)
COUNTRY出荷国 (商品発送国)(String)
PLANTプラント(String)
BILL_TO請求先(String)
PAYER支払人(String)
SHIP_TO出荷先(String)
REF_DOC参照伝票番号(String)
MATERIAL品目コード(String)
REQ_QTY累積受注数量 (販売単位)(String)
CURRENCY販売伝票通貨(String)
SHORT_TEXTテキスト (短): 受注明細(String)
TAXCL_1MAT品目の税分類(String)
REF_ITEM参照明細番号(String)
STAT_GROUP統計グループ(String)
NO_MATMAST品目マスタ確認禁止(String)
ADDR_NOアドレス: アドレス番号(String)
TITLE敬称(String)
NAME名称 1(String)
NAME_2名称 2(String)
POSTL_CODE郵便番号(String)
CONSUMCTRY消費者の国キー(String)
CITY市区町村(String)
DISTRICT所在地(String)
STREET地名/番地-号(String)
REGION地域 (都道府県)(String)
PROD_HIER品目階層(String)
SALES_UNIT販売単位(String)
PROFIT_CTR利益センタ(String)
TAXJURCODE税計算管轄コード - 税管轄コード(String)
PURCH_ORD出荷先発注番号(String)
DOC_NUMBER販売伝票(String)
ITM_NUMBER販売伝票明細(String)
ORIGINDOC開始伝票(String)
ITEM開始明細(String)
CREATED_BYオブジェクト登録者名(String)
MATERIAL_EXTERNAL項目 MATERIAL の品目コード (長) (今後のリリースで開発)(String)
MATERIAL_GUID項目 MATERIAL の外部 GUID (今後のリリースで開発)(String)
MATERIAL_VERSION項目 MATERIAL のバージョン番号 (今後のリリースで開発)(String)
INCOTERMS1インコタームズ (1)(String)
INCOTERMS2インコタームズ (2)(String)
EXCHANGE_RATE価格設定/統計用換算レート(String)
PAYMENT_TERMS支払条件キー(String)
HG_LV_ITEMBOM 構成の上位レベル明細(String)
REF_DOC_CA先行販売管理伝票の伝票カテゴリ(String)
ORDERID指図番号(String)
PROFIT_SEGM_NO収益性セグメント番号 (CO-PA) (String)
COSTCENTER原価センタ(String)
WBS_ELEMWBS 要素(String)
TAX_DEPART_CTY税出荷国(String)
TAX_DEST_CTY税仕向国(String)

取得した管理情報設定ヘッダセグメント情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["SALESORG"]　→　配列内のidx番目の処理予定明細データのテーブルの「販売組織」
[idx]["DISTR_CHAN"]　→　配列内のidx番目の処理予定明細データのテーブルの「流通チャネル」
[idx]["DIVISION"]　→　配列内のidx番目の処理予定明細データのテーブルの「製品部門」
[idx]["DOC_TYPE"]　→　配列内のidx番目の処理予定明細データのテーブルの「販売伝票タイプ」
[idx]["ORDBILLTYP"]　→　配列内のidx番目の処理予定明細データのテーブルの 「受注関連請求伝票に対する提案請求伝票タイプ」
[idx]["BILL_DATE"]　→　配列内のidx番目の処理予定明細データのテーブルの 「請求索引および印刷に対する請求日」
[idx]["SOLD_TO"]　→　配列内のidx番目の処理予定明細データのテーブルの「受注先」
[idx]["ITEM_CATEG"]　→　配列内のidx番目の処理予定明細データのテーブルの 「明細カテゴリ (販売伝票)」
[idx]["ACCTASGNMT"]　→　配列内のidx番目の処理予定明細データのテーブルの 「品目の勘定設定グループ」
[idx]["PRICE_DATE"]　→　配列内のidx番目の処理予定明細データのテーブルの 「価格設定/外貨換算の実行日付」
[idx]["COUNTRY"]　→　配列内のidx番目の処理予定明細データのテーブルの「出荷国 (商品発送国)」
[idx]["PLANT"]　→　配列内のidx番目の処理予定明細データのテーブルの「プラント」
[idx]["BILL_TO"]　→　配列内のidx番目の処理予定明細データのテーブルの「請求先」
[idx]["PAYER"]　→　配列内のidx番目の処理予定明細データのテーブルの「支払人」
[idx]["SHIP_TO"]　→　配列内のidx番目の処理予定明細データのテーブルの「出荷先」
[idx]["REF_DOC"]　→　配列内のidx番目の処理予定明細データのテーブルの「参照伝票番号」
[idx]["MATERIAL"]　→　配列内のidx番目の処理予定明細データのテーブルの「品目コード」
[idx]["REQ_QTY"]　→　配列内のidx番目の処理予定明細データのテーブルの「累積受注数量 (販売単位)」
[idx]["CURRENCY"]　→　配列内のidx番目の処理予定明細データのテーブルの「販売伝票通貨」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の処理予定明細データのテーブルの 「テキスト (短): 受注明細」
[idx]["TAXCL_1MAT"]　→　配列内のidx番目の処理予定明細データのテーブルの「品目の税分類」
[idx]["REF_ITEM"]　→　配列内のidx番目の処理予定明細データのテーブルの「参照明細番号」
[idx]["STAT_GROUP"]　→　配列内のidx番目の処理予定明細データのテーブルの「統計グループ」
[idx]["NO_MATMAST"]　→　配列内のidx番目の処理予定明細データのテーブルの「品目マスタ確認禁止」
[idx]["ADDR_NO"]　→　配列内のidx番目の処理予定明細データのテーブルの「アドレス: アドレス番号」
[idx]["TITLE"]　→　配列内のidx番目の処理予定明細データのテーブルの「敬称」
[idx]["NAME"]　→　配列内のidx番目の処理予定明細データのテーブルの「名称 1」
[idx]["NAME_2"]　→　配列内のidx番目の処理予定明細データのテーブルの「名称 2」
[idx]["POSTL_CODE"]　→　配列内のidx番目の処理予定明細データのテーブルの「郵便番号」
[idx]["CONSUMCTRY"]　→　配列内のidx番目の処理予定明細データのテーブルの「消費者の国キー」
[idx]["CITY"]　→　配列内のidx番目の処理予定明細データのテーブルの「市区町村」
[idx]["DISTRICT"]　→　配列内のidx番目の処理予定明細データのテーブルの「所在地」
[idx]["STREET"]　→　配列内のidx番目の処理予定明細データのテーブルの「地名/番地-号」
[idx]["REGION"]　→　配列内のidx番目の処理予定明細データのテーブルの「地域 (都道府県)」
[idx]["PROD_HIER"]　→　配列内のidx番目の処理予定明細データのテーブルの「品目階層」
[idx]["SALES_UNIT"]　→　配列内のidx番目の処理予定明細データのテーブルの「販売単位」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の処理予定明細データのテーブルの「利益センタ」
[idx]["TAXJURCODE"]　→　配列内のidx番目の処理予定明細データのテーブルの 「税計算管轄コード - 税管轄コード」
[idx]["PURCH_ORD"]　→　配列内のidx番目の処理予定明細データのテーブルの「出荷先発注番号」
[idx]["DOC_NUMBER"]　→　配列内のidx番目の処理予定明細データのテーブルの「販売伝票」
[idx]["ITM_NUMBER"]　→　配列内のidx番目の処理予定明細データのテーブルの「販売伝票明細」
[idx]["ORIGINDOC"]　→　配列内のidx番目の処理予定明細データのテーブルの「開始伝票」
[idx]["ITEM"]　→　配列内のidx番目の処理予定明細データのテーブルの「開始明細」
[idx]["CREATED_BY"]　→　配列内のidx番目の処理予定明細データのテーブルの「オブジェクト登録者名」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の処理予定明細データのテーブルの 「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の処理予定明細データのテーブルの 「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の処理予定明細データのテーブルの 「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」
[idx]["INCOTERMS1"]　→　配列内のidx番目の処理予定明細データのテーブルの 「インコタームズ (1)」
[idx]["INCOTERMS2"]　→　配列内のidx番目の処理予定明細データのテーブルの 「インコタームズ (2)」
[idx]["EXCHANGE_RATE"]　→　配列内のidx番目の処理予定明細データのテーブルの 「価格設定/統計用換算レート」
[idx]["PAYMENT_TERMS"]　→　配列内のidx番目の処理予定明細データのテーブルの「支払条件キー」
[idx]["HG_LV_ITEM"]　→　配列内のidx番目の処理予定明細データのテーブルの 「BOM 構成の上位レベル明細」
[idx]["REF_DOC_CA"]　→　配列内のidx番目の処理予定明細データのテーブルの 「先行販売管理伝票の伝票カテゴリ」
[idx]["ORDERID"]　→　配列内のidx番目の処理予定明細データのテーブルの「指図番号」
[idx]["PROFIT_SEGM_NO"]　→　配列内のidx番目の処理予定明細データのテーブルの 「収益性セグメント番号 (CO-PA)」
[idx]["COSTCENTER"]　→　配列内のidx番目の処理予定明細データのテーブルの「原価センタ」
[idx]["WBS_ELEM"]　→　配列内のidx番目の処理予定明細データのテーブルの「WBS 要素」
[idx]["TAX_DEPART_CTY"]　→　配列内のidx番目の処理予定明細データのテーブルの「税出荷国」
[idx]["TAX_DEST_CTY"]　→　配列内のidx番目の処理予定明細データのテーブルの「税仕向国」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11: 販売管理システムエラー
12: 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getCCardDataInList

Array getCCardDataInList ()

処理予定支払方法のテーブルを取得します。
返却値
Array 処理予定支払方法のテーブル

処理予定支払方法のテーブル情報オブジェクトの構成は以下のとおりです。
処理予定支払方法のテーブル情報
オブジェクト
(Object)
PAYTYPE支払手段: 支払カード計画の明細分類(String)
CC_TYPE支払カードタイプ: カードタイプ(String)
CC_NUMBER支払カード: カード番号(String)
CC_SEQ_NO支払カード: 支払カード - 接尾辞(String)
CC_VALID_F支払カード: 使用有効開始日付(String)
CC_VALID_T支払カード: 有効終了日(String)
CC_NAME支払カード: カード所有者の氏名(String)
AUTHAMOUNT支払カード: 承認額(String)
CURRENCY通貨コード(String)
CURRENCY_ISOISO コード通貨(String)
AUTH_FLAG支払カード: 振替権限(String)
AUTH_DATE支払カード: 承認日(String)
AUTH_TIME支払カード: 承認時刻(String)
CC_AUTH_NO支払カード: 承認番号(String)
AUTH_REFNO支払カード: 決済代行会社の権限参照コード(String)
MERCHIDCL支払カード: 決済代行会社のマーチャント ID (String)
TERMINAL支払カード: 端末(String)
DATAORIGIN支払カード: 入力モード(String)
CC_SETTLED支払カード: 決済終了(String)
CC_LOC_ID支払カード: トランザクション (入庫時点)(String)
BILL_PLAN請求計画番号(String)
BILL_PLANI明細: 請求計画/支払計画/支払カード(String)
BILL_VALUE請求金額: 請求計画に請求日付が指定されている場合 (String)

取得した管理情報設定ヘッダセグメント情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PAYTYPE"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「支払手段: 支払カード計画の明細分類」
[idx]["CC_TYPE"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「支払カードタイプ: カードタイプ」
[idx]["CC_NUMBER"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「支払カード: カード番号」
[idx]["CC_SEQ_NO"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「支払カード: 支払カード - 接尾辞」
[idx]["CC_VALID_F"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「支払カード: 使用有効開始日付」
[idx]["CC_VALID_T"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「支払カード: 有効終了日」
[idx]["CC_NAME"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「支払カード: カード所有者の氏名」
[idx]["AUTHAMOUNT"]　→　配列内のidx番目の処理予定支払方法のテーブルの「支払カード: 承認額」
[idx]["CURRENCY"]　→　配列内のidx番目の処理予定支払方法のテーブルの「通貨コード」
[idx]["CURRENCY_ISO"]　→　配列内のidx番目の処理予定支払方法のテーブルの「ISO コード通貨」
[idx]["AUTH_FLAG"]　→　配列内のidx番目の処理予定支払方法のテーブルの「支払カード: 振替権限」
[idx]["AUTH_DATE"]　→　配列内のidx番目の処理予定支払方法のテーブルの「支払カード: 承認日」
[idx]["AUTH_TIME"]　→　配列内のidx番目の処理予定支払方法のテーブルの「支払カード: 承認時刻」
[idx]["CC_AUTH_NO"]　→　配列内のidx番目の処理予定支払方法のテーブルの「支払カード: 承認番号」
[idx]["AUTH_REFNO"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「支払カード: 決済代行会社の権限参照コード」
[idx]["MERCHIDCL"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「支払カード: 決済代行会社のマーチャント ID」
[idx]["TERMINAL"]　→　配列内のidx番目の処理予定支払方法のテーブルの「支払カード: 端末」
[idx]["DATAORIGIN"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「支払カード: 入力モード」
[idx]["CC_SETTLED"]　→　配列内のidx番目の処理予定支払方法のテーブルの「支払カード: 決済終了」
[idx]["CC_LOC_ID"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「支払カード: トランザクション (入庫時点)」
[idx]["BILL_PLAN"]　→　配列内のidx番目の処理予定支払方法のテーブルの「請求計画番号」
[idx]["BILL_PLANI"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「明細: 請求計画/支払計画/支払カード」
[idx]["BILL_VALUE"]　→　配列内のidx番目の処理予定支払方法のテーブルの 「請求金額: 請求計画に請求日付が指定されている場合」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11: 販売管理システムエラー
12: 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getConditionDataInList

Array getConditionDataInList ()

処理予定条件のテーブルを取得します。
返却値
Array 処理予定条件のテーブル

処理予定条件のテーブル情報オブジェクトの構成は以下のとおりです。
処理予定条件のテーブル情報
オブジェクト
(Object)
DATA_INDEX別の構成のテーブル入力へのポインタ(String)
COND_TYPE条件タイプ(String)
COND_VALUE条件金額/率(String)
COND_CURR条件通貨 (累積項目用)(String)
COND_P_UNT価格条件単位(String)
COND_D_UNT伝票の条件単位(String)

取得した管理情報設定ヘッダセグメント情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["DATA_INDEX"]　→　配列内のidx番目の処理予定条件のテーブルの 「別の構成のテーブル入力へのポインタ」
[idx]["COND_TYPE"]　→　配列内のidx番目の処理予定条件のテーブルの「条件タイプ」
[idx]["COND_VALUE"]　→　配列内のidx番目の処理予定条件のテーブルの「条件金額/率」
[idx]["COND_CURR"]　→　配列内のidx番目の処理予定条件のテーブルの「条件通貨 (累積項目用)」
[idx]["COND_P_UNT"]　→　配列内のidx番目の処理予定条件のテーブルの「価格条件単位」
[idx]["COND_D_UNT"]　→　配列内のidx番目の処理予定条件のテーブルの「伝票の条件単位」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11: 販売管理システムエラー
12: 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getCreatorDataIn

Object getCreatorDataIn ()

取り込まれる日付の順序を取得します｡
返却値
Object 取り込まれる日付の順序

取り込まれる日付の順序情報オブジェクトの構成は以下のとおりです。
取り込まれる日付の順序情報
オブジェクト
(Object)
CREATED_BYオブジェクト登録者名(String)
CREATED_ONレコード登録日(String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getErrorsList

Array getErrorsList ()

前明細の不正処理に関する情報を取得します。
返却値
Array 前明細の不正処理に関する情報

前明細の不正処理に関する情報オブジェクトの構成は以下のとおりです。
前明細の不正処理に関する情報
オブジェクト
(Object)
REF_DOC参照伝票番号(String)
REF_DOC_ITEM参照明細番号(String)
TYPEメッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了 (String)
IDメッセージ、メッセージクラス(String)
NUMBERメッセージ、メッセージ番号(String)
MESSAGEメッセージテキスト(String)
LOG_NOアプリケーションログ: ログ番号(String)
LOG_MSG_NOアプリケーションログ: メッセージシリアル番号 (String)
MESSAGE_V1メッセージ、メッセージ変数(String)
MESSAGE_V2メッセージ、メッセージ変数(String)
MESSAGE_V3メッセージ、メッセージ変数(String)
MESSAGE_V4メッセージ、メッセージ変数(String)

取得した管理情報設定ヘッダセグメント情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["REF_DOC"]　→　配列内のidx番目の前明細の不正処理に関する情報の「参照伝票番号」
[idx]["REF_DOC_ITEM"]　→　配列内のidx番目の前明細の不正処理に関する情報の「参照明細番号」
[idx]["TYPE"]　→　配列内のidx番目の前明細の不正処理に関する情報の 「メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了」
[idx]["ID"]　→　配列内のidx番目の前明細の不正処理に関する情報の「メッセージ、メッセージクラス」
[idx]["NUMBER"]　→　配列内のidx番目の前明細の不正処理に関する情報の「メッセージ、メッセージ番号」
[idx]["MESSAGE"]　→　配列内のidx番目の前明細の不正処理に関する情報の「メッセージテキスト」
[idx]["LOG_NO"]　→　配列内のidx番目の前明細の不正処理に関する情報の 「アプリケーションログ: ログ番号」
[idx]["LOG_MSG_NO"]　→　配列内のidx番目の前明細の不正処理に関する情報の 「アプリケーションログ: メッセージシリアル番号」
[idx]["MESSAGE_V1"]　→　配列内のidx番目の前明細の不正処理に関する情報の 「メッセージ、メッセージ変数」
[idx]["MESSAGE_V2"]　→　配列内のidx番目の前明細の不正処理に関する情報の 「メッセージ、メッセージ変数」
[idx]["MESSAGE_V3"]　→　配列内のidx番目の前明細の不正処理に関する情報の 「メッセージ、メッセージ変数」
[idx]["MESSAGE_V4"]　→　配列内のidx番目の前明細の不正処理に関する情報の 「メッセージ、メッセージ変数」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11: 販売管理システムエラー
12: 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getSuccessList

Array getSuccessList ()

正常に処理された明細のテーブルを取得します。
返却値
Array 正常に処理された明細のテーブル

正常に処理された明細のテーブル情報オブジェクトの構成は以下のとおりです。
正常に処理された明細のテーブル情報
オブジェクト
(Object)
REF_DOC参照伝票番号(String)
REF_DOC_ITEM参照明細番号(String)
BILL_DOC請求伝票(String)
BILL_DOC_ITEM請求伝票明細(String)
NET_VALUE正味金額(String)
TAX_VALUE税額(String)
CURRENCY通貨コード(String)
CURRENCY_ISOISO コード通貨(String)
NET_VALUE_ITEM正味金額(String)
TAX_VALUE_ITEM税額(String)
GRO_VALUE_ITEM総額(String)

取得した管理情報設定ヘッダセグメント情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["REF_DOC"]　→　配列内のidx番目の正常に処理された明細のテーブルの「参照伝票番号」
[idx]["REF_DOC_ITEM"]　→　配列内のidx番目の正常に処理された明細のテーブルの「参照明細番号」
[idx]["BILL_DOC"]　→　配列内のidx番目の正常に処理された明細のテーブルの「請求伝票」
[idx]["BILL_DOC_ITEM"]　→　配列内のidx番目の正常に処理された明細のテーブルの「請求伝票明細」
[idx]["NET_VALUE"]　→　配列内のidx番目の正常に処理された明細のテーブルの「正味金額」
[idx]["TAX_VALUE"]　→　配列内のidx番目の正常に処理された明細のテーブルの「税額」
[idx]["CURRENCY"]　→　配列内のidx番目の正常に処理された明細のテーブルの「通貨コード」
[idx]["CURRENCY_ISO"]　→　配列内のidx番目の正常に処理された明細のテーブルの 「ISO コード通貨」
[idx]["NET_VALUE_ITEM"]　→　配列内のidx番目の正常に処理された明細のテーブルの「正味金額」
[idx]["TAX_VALUE_ITEM"]　→　配列内のidx番目の正常に処理された明細のテーブルの「税額」
[idx]["GRO_VALUE_ITEM"]　→　配列内のidx番目の正常に処理された明細のテーブルの「総額」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11: 販売管理システムエラー
12: 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getTestrun

Object getTestrun ()

シミュレーション実行 ('X')、更新実行 (' ')を取得します。

返却値
Object シミュレーション実行 ('X')、更新実行 (' ')
getTextDataInList

Array getTextDataInList ()

処理予定明細データのテーブルを取得します。
返却値
Array 処理予定明細データのテーブル

処理予定明細データのテーブル情報オブジェクトの構成は以下のとおりです。
処理予定明細データのテーブル情報
オブジェクト
(Object)
REF_DOC参照伝票番号(String)
REF_ITEM参照明細番号(String)
APPLOBJECTテキスト: アプリケーションオブジェクト(String)
TEXT_IDテキスト ID(String)
LANGU言語キー(String)
FORMAT_COLタグ列(String)
TEXT_LINEテキスト行(String)

取得した管理情報設定ヘッダセグメント情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["REF_DOC"]　→　配列内のidx番目の請求インタフェースの通信構造テキストの「参照伝票番号」
[idx]["REF_ITEM"]　→　配列内のidx番目の請求インタフェースの通信構造テキストの「参照明細番号」
[idx]["APPLOBJECT"]　→　配列内のidx番目の請求インタフェースの通信構造テキストの 「テキスト: アプリケーションオブジェクト」
[idx]["TEXT_ID"]　→　配列内のidx番目の請求インタフェースの通信構造テキストの「テキスト ID」
[idx]["LANGU"]　→　配列内のidx番目の請求インタフェースの通信構造テキストの「言語キー」
[idx]["FORMAT_COL"]　→　配列内のidx番目の請求インタフェースの通信構造テキストの「タグ列」
[idx]["TEXT_LINE"]　→　配列内のidx番目の請求インタフェースの通信構造テキストの「テキスト行」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11: 販売管理システムエラー
12: 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

setStrParam

void setStrParam (String paramStr ,String paramName ,Object value)

構造型の項目に値をセットします。
パラメータ
paramStr | String | 構造名
paramName | String | 項目名
value | Object | セットする値
返却値
void
setTblParam

void setTblParam (String paramTable ,String paramName ,Object value ,int index)

テーブル型の項目に値をセットします。
パラメータ
paramTable | String | テーブル名
paramName | String | 項目名
value | Object | セットする値
index | int | レコード番号
返却値
void
setTestrun

void setTestrun (Object value)

シミュレーション実行 ('X')、更新実行 (' ')を設定します｡
パラメータ
value Object シミュレーション実行 ('X')、更新実行 (' ')
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 BusinessAreaController オブジェクト

事業領域コントローラクラス。

事業領域の情報を取得します。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
BusinessAreaController ()
コンストラクタ。
BusinessAreaController (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | getBusArDes (String busArea) 事業領域を指定して事業領域名を取得します。
Array | getBusinessAreaList () 事業領域一覧を取得します。
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
コンストラクタの詳細
BusinessAreaController

BusinessAreaController ()
コンストラクタ。

BusinessAreaController

BusinessAreaController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
getBusArDes

Object getBusArDes (String busArea)

事業領域を指定して事業領域名を取得します。

パラメータ
busArea String SAP R/3上に存在する事業領域コード
返却値
Object 指定した事業領域コードに対応する事業領域名
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getBusinessAreaList

Array getBusinessAreaList ()

事業領域一覧を取得します。

返却値
Array 事業領域情報が格納された配列

事業領域情報オブジェクトの構成は以下のとおりです。
事業領域情報
オブジェクト
(Object)
BUS_AREA 事業領域コード (String)
BUS_AREA_DES 事業領域名 (String)

取得した事業領域情報の配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["BUS_AREA"]　→　配列内のidx番目の事業領域の「事業領域コード」
[idx]["BUS_AREA_DES"]　→　配列内のidx番目の事業領域の「事業領域名」

※ idxは0〜n （配列サイズ-1）

getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ


 CompanyController オブジェクト

会社コントローラクラス。

会社の情報を取得します｡
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
CompanyController ()
コンストラクタ。
CompanyController (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | getCompName (String compCode) 会社コードを指定して会社名を取得します。
Array | getCompanyList () 会社一覧を取得します。
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
コンストラクタの詳細
CompanyController

CompanyController ()
コンストラクタ。

CompanyController

CompanyController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
getCompName

Object getCompName (String compCode)

会社コードを指定して会社名を取得します。

パラメータ
compCode String SAP R/3上に存在する会社コード
返却値
Object 指定した会社コードに対応する会社名
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getCompanyList

Array getCompanyList ()

会社一覧を取得します。

返却値
Array 会社情報が格納された配列

会社情報オブジェクトの構成は以下のとおりです。
会社情報
オブジェクト
(Object)
COMP_CODE 会社コード (String)
COMP_NAME 会社名 (String)

取得した会社情報の配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["COMP_CODE"]　→　配列内のidx番目の会社の「会社コード」
[idx]["COMP_NAME"]　→　配列内のidx番目の会社の「会社名」

※ idxは0〜n （配列サイズ-1）

getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ


 ControllingAreaController オブジェクト

管理領域コントローラクラス。

管理領域の情報を取得します。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
ControllingAreaController ()
コンストラクタ。
ControllingAreaController (SapClient sapClient)
コンストラクタ。
メソッドの概要
Array | getControllingAreaList () 管理領域一覧を取得します。
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
Object | getName (String coArea) 管理領域を指定して管理領域名を取得します。
コンストラクタの詳細
ControllingAreaController

ControllingAreaController ()
コンストラクタ。

ControllingAreaController

ControllingAreaController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
getControllingAreaList

Array getControllingAreaList ()

管理領域一覧を取得します。

返却値
Array 管理領域情報が格納された配列

管理領域情報オブジェクトの構成は以下のとおりです。
管理領域情報
オブジェクト
(Object)
CO_AREA 管理領域コード (String)
NAME 管理領域名 (String)

取得した管理領域情報の配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CO_AREA"]　→　配列内のidx番目の管理領域の「管理領域コード」
[idx]["NAME"]　→　配列内のidx番目の管理領域の「管理領域名」

※ idxは0〜n （配列サイズ-1）

getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getName

Object getName (String coArea)

管理領域を指定して管理領域名を取得します。

パラメータ
coArea String SAP R/3上に存在する管理領域コード
返却値
Object 指定した管理領域コードに対応する管理領域名
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)


 CostCenterController オブジェクト

原価センタコントローラクラス。

原価センタの情報を取得します。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
CostCenterController (String controllingArea)
コンストラクタ。
CostCenterController (String controllingArea ,String date)
コンストラクタ。
CostCenterController (String controllingArea ,SapClient sapClient)
コンストラクタ。
CostCenterController (String controllingArea ,String date ,SapClient sapClient)
コンストラクタ。
メソッドの概要
Array | getCostCenterList () 原価センタ一覧を取得します。
Object | getDescript (SAP costCenter) 原価センタを指定してテキストを取得します。
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
Object | getName (String costCenter) 原価センタを指定して一般名称を取得します。
コンストラクタの詳細
CostCenterController

CostCenterController (String controllingArea)
コンストラクタ。

引数１つのコンストラクタです。
システム日付で有効な原価センタ情報が抽出対象となります。
パラメータ
controllingArea String SAP R/3上に存在する管理領域コード
CostCenterController

CostCenterController (String controllingArea ,String date)
コンストラクタ。

引数２つのコンストラクタです。
指定したYYYYMMDDの日付で有効な原価センタ情報が抽出対象となります。
パラメータ
controllingArea | String | 管理領域
date | String | 有効期間: 開始
CostCenterController

CostCenterController (String controllingArea ,SapClient sapClient)
コンストラクタ。

引数２つのコンストラクタです。
SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
controllingArea | String | 管理領域
sapClient | SapClient | Sapクライアント
CostCenterController

CostCenterController (String controllingArea ,String date ,SapClient sapClient)
コンストラクタ。

引数３つのコンストラクタです。
指定したYYYYMMDDの日付で有効な原価センタ情報が抽出対象となります。
SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
controllingArea | String | 管理領域
date | String | 有効期間: 開始
sapClient | SapClient | Sapクライアント
メソッドの詳細
getCostCenterList

Array getCostCenterList ()

原価センタ一覧を取得します。

返却値
Array 原価センタ情報が格納された配列

原価センタ情報オブジェクトの構成は以下のとおりです。
原価センタ情報
オブジェクト
(Object)
CONTROLLING_AREA 管理領域コード (String)
COST_CENTER 原価センタコード (String)
DESCRIPT 一般名称 (String)
NAME テキスト (String)

取得した原価センタ情報の配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONTROLLING_AREA"]　→　配列内のidx番目の原価センタの「管理領域コード」
[idx]["COST_CENTER"]　→　配列内のidx番目の原価センタの「原価センタコード」
[idx]["DESCRIPT"]　→　配列内のidx番目の原価センタの「一般名称」
[idx]["NAME"]　→　配列内のidx番目の原価センタの「テキスト」

※ idxは0〜n （配列サイズ-1）

getDescript

Object getDescript (SAP costCenter)

原価センタを指定してテキストを取得します。

パラメータ
costCenter SAP R/3上に存在する原価センタコード
返却値
Object 指定した原価センタコードに対応するテキスト
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getName

Object getName (String costCenter)

原価センタを指定して一般名称を取得します。

パラメータ
costCenter String SAP R/3上に存在する原価センタコード
返却値
Object 指定した原価センタコードに対応する一般名称
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)


 CostCenterGroupGetDetailController オブジェクト

原価センタグループ情報取得コントローラクラス。

機能は以下の通り
  • 原価センタグループ情報を取得します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
CostCenterGroupGetDetailController (String controllingarea ,String groupname)
コンストラクタ｡
CostCenterGroupGetDetailController (String controllingarea ,String groupname ,SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | getControllingarea () 原価センタグループの管理領域から値を取得します。
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
Object | getGroupname () 原価センタグループのグループ名から値を取得します。
Array | getHierarchyNodesList () 階層ノード一覧を取得します。
Array | getHierarchyValuesList () 階層値一覧を取得します。
void | setControllingarea (String value) 原価センタグループの管理領域に値を設定します。
void | setGroupname (String value) 原価センタグループのグループ名に値を設定します。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
CostCenterGroupGetDetailController

CostCenterGroupGetDetailController (String controllingarea ,String groupname)
コンストラクタ｡
パラメータ
controllingarea | String | 管理領域
groupname | String | グループ名
CostCenterGroupGetDetailController

CostCenterGroupGetDetailController (String controllingarea ,String groupname ,SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
controllingarea | String | 管理領域
groupname | String | グループ名
sapClient | SapClient | Sapクライアント
メソッドの詳細
getControllingarea

Object getControllingarea ()

原価センタグループの管理領域から値を取得します。

返却値
Object 管理領域
getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getGroupname

Object getGroupname ()

原価センタグループのグループ名から値を取得します。

返却値
Object グループ名
getHierarchyNodesList

Array getHierarchyNodesList ()

階層ノード一覧を取得します。
返却値
Array 階層ノード情報が格納された配列

階層ノード情報オブジェクトの構成は以下のとおりです。
階層ノード情報
オブジェクト
(Object)
GROUPNAME グループ名 (String)
HIERLEVEL 階層のエントリレベル (String)
VALCOUNT 階層ノード内の値の値数 (String)
DESCRIPT グループテキスト (短) (String)

取得した階層ノード情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["GROUPNAME"]　→　配列内のidx番目の階層ノードの「グループ名」
[idx]["HIERLEVEL"]　→　配列内のidx番目の階層ノードの「階層のエントリレベル」
[idx]["VALCOUNT"]　→　配列内のidx番目の階層ノードの「階層ノード内の値の値数」
[idx]["DESCRIPT"]　→　配列内のidx番目の階層ノードの「グループテキスト (短)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getHierarchyValuesList

Array getHierarchyValuesList ()

階層値一覧を取得します。
返却値
Array 階層値情報が格納された配列

階層値情報オブジェクトの構成は以下のとおりです。
階層値情報
オブジェクト
(Object)
VALFROM 原価センタ (String)
VALTO 原価センタ (String)

取得した階層値情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["VALFROM"]　→　配列内のidx番目の階層値の「利益センタ」
[idx]["VALTO"]　→　配列内のidx番目の階層値の「利益センタ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

setControllingarea

void setControllingarea (String value)

原価センタグループの管理領域に値を設定します。
パラメータ
value String 管理領域
返却値
void
setGroupname

void setGroupname (String value)

原価センタグループのグループ名に値を設定します。
パラメータ
value String グループ名
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 GlAccController オブジェクト

勘定科目コントローラクラス。

勘定科目の情報を取得します。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
GlAccController (String companyCode)
コンストラクタ。
GlAccController (String companyCode ,SapClient sapClient)
コンストラクタ。
メソッドの概要
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
Array | getGlAccList () 勘定科目一覧を取得します。
Object | getLongText (String glAccount) 総勘定元帳勘定テキスト(長)を取得します。
Object | getShortText (String glAccount) G/L勘定コードテキスト(短)を取得します。
コンストラクタの詳細
GlAccController

GlAccController (String companyCode)
コンストラクタ。

パラメータ
companyCode String 会社コード String SAP R/3上に存在する会社コード
GlAccController

GlAccController (String companyCode ,SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
companyCode | String | 会社コード
sapClient | SapClient | Sapクライアント
メソッドの詳細
getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getGlAccList

Array getGlAccList ()

勘定科目一覧を取得します。

返却値
Array 勘定科目情報が格納された配列

勘定科目情報オブジェクトの構成は以下のとおりです。
勘定科目情報
オブジェクト
(Object)
COMPANY_CODE 会社コード (String)
GL_ACCOUNT G/L勘定コード (String)
SHORT_TEXT G/L勘定コードテキスト(短) (String)
LONG_TEXT 総勘定元帳勘定テキスト(長) (String)

取得した勘定科目情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["COMPANY_CODE"]　→　配列内のidx番目の勘定科目の「会社コード」
[idx]["GL_ACCOUNT"]　→　配列内のidx番目の勘定科目の「G/L勘定コード」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の勘定科目の「G/L勘定コードテキスト(短)」
[idx]["LONG_TEXT"]　→　配列内のidx番目の勘定科目の「総勘定元帳勘定テキスト(長)」

※ idxは0〜n （配列サイズ-1）

getLongText

Object getLongText (String glAccount)

総勘定元帳勘定テキスト(長)を取得します。

G/L勘定コードを指定して総勘定元帳勘定テキスト(長)を取得します。
パラメータ
glAccount String SAP R/3上に存在するG/L勘定コード
返却値
Object 指定したG/L勘定コードに対応する総勘定元帳勘定テキスト(長)
（成功時の返却値は String になります。）
（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getShortText

Object getShortText (String glAccount)

G/L勘定コードテキスト(短)を取得します。

G/L勘定コードを指定してG/L勘定コードテキスト(短)を取得します。
パラメータ
glAccount String SAP R/3上に存在するG/L勘定コード
返却値
Object 指定したG/L勘定コードに対応するG/L勘定コードテキスト(短)
（成功時の返却値は String になります。）
（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)


 GoodsMvtCreateController オブジェクト

入出庫伝票登録コントローラクラス。

機能は以下の通り
  • 入出庫伝票を登録します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
GoodsMvtCreateController ()
コンストラクタ｡
GoodsMvtCreateController (ConnectionManager connectionManager)
コンストラクタ。
GoodsMvtCreateController (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより入出庫伝票を登録します。
String | getBapiReturnErrMessage () ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage () プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。
Object | getGoodsMvtCode () 在庫移動に対するコードのトランザクションへの割当を取得します。
Object | getGoodsMvtHeader () 入出庫伝票ヘッダデータを取得します｡
Object | getGoodsMvtHeadret () 入出庫伝票番号/入出庫伝票会計年度を取得します。
Object | getGoodsMvtItemList () 入出庫伝票一覧を取得します。
Object | getGoodsMvtSerialNumberList () シリアル番号を取得します。
String | getMatdocumentyear () 入出庫伝票会計年度を取得します。
value | getTestrun () 在庫移動シミュレーションを取得します｡
void | setStrParam (String paramStr ,String paramName ,Object value) 構造型の項目に値をセットします。
void | setTblParam (String paramTable ,String paramName ,Object value ,int index) テーブル型の項目に値をセットします。
void | setTestrun (Object value) 在庫移動シミュレーションを設定します｡
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
GoodsMvtCreateController

GoodsMvtCreateController ()
コンストラクタ｡
GoodsMvtCreateController

GoodsMvtCreateController (ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、GoodsMvtCreateController#executeBapi()実行後に必ず ConnectionManager#commit()またはConnectionManager#rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。
パラメータ
connectionManager ConnectionManager コネクションマネージャー
GoodsMvtCreateController

GoodsMvtCreateController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより入出庫伝票を登録します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getBapiReturnErrMessage

String getBapiReturnErrMessage ()

ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡
返却値
String BAPI実行結果エラーとなった全てのメッセージ情報
getBapiReturnMessage

String getBapiReturnMessage ()

プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡
返却値
String プロパティファイルでオートコミット条件に一致したType情報のメッセージ情報
getGoodsMvtCode

Object getGoodsMvtCode ()

在庫移動に対するコードのトランザクションへの割当を取得します。
返却値
Object 在庫移動に対するコードのトランザクションへの割当

在庫移動に対するコードのトランザクションへの割当の順序情報オブジェクトの構成は以下のとおりです。
在庫移動に対するコードのトランザクションへの割当の順序情報
オブジェクト
(Object)
GM_CODEBAPI 在庫移動トランザクションのコード割当(String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getGoodsMvtHeader

Object getGoodsMvtHeader ()

入出庫伝票ヘッダデータを取得します｡
返却値
Object 入出庫伝票ヘッダデータ

入出庫伝票ヘッダデータの順序情報オブジェクトの構成は以下のとおりです。
入出庫伝票ヘッダデータの順序情報
オブジェクト
(Object)
PSTNG_DATE伝票の転記日付(String)
DOC_DATE伝票の伝票日付(String)
REF_DOC_NO参照伝票番号(String)
BILL_OF_LADING入庫時に登録した B/L 番号(String)
GR_GI_SLIP_NO入出庫票番号(String)
PR_UNAMEユーザ名(String)
HEADER_TXT伝票ヘッダテキスト(String)
VER_GR_GI_SLIP入出庫票の印刷バ−ジョン(String)
VER_GR_GI_SLIPX関連ユーザデータ項目の更新情報(String)
EXT_WMS外部倉庫管理の転記の制御(String)
REF_DOC_NO_LONG参照伝票番号 (依存性についてはテキスト長参照)(String)
BILL_OF_LADING_LONG入庫の船荷証券番号 (依存: テキスト (長) 参照)(String)
BAR_CODEバーコードエントリ(String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getGoodsMvtHeadret

Object getGoodsMvtHeadret ()

入出庫伝票番号/入出庫伝票会計年度を取得します。
返却値
Object 入出庫伝票番号/入出庫伝票会計年度

XXXオブジェクトの構成は以下のとおりです。
入出庫伝票番号/入出庫伝票会計年度
オブジェクト
(Object)
MAT_DOC 入出庫伝票番号 (String)
DOC_YEAR 入出庫伝票年度 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getGoodsMvtItemList

Object getGoodsMvtItemList ()

入出庫伝票一覧を取得します。
返却値
Object 入出庫伝票一覧

入出庫伝票一覧情報オブジェクトの構成は以下のとおりです。
入出庫伝票一覧
オブジェクト
(Object)
MATERIAL 品目コード (String)
PLANT プラント (String)
STGE_LOC 保管場所 (String)
BATCH ロット番号 (String)
MOVE_TYPE 移動タイプ (在庫管理) (String)
STCK_TYPE 在庫タイプ (String)
SPEC_STOCK 特殊在庫区分 (String)
VENDOR 仕入先勘定コード (String)
CUSTOMER 得意先コード (String)
SALES_ORD 受注伝票番号 (String)
S_ORD_ITEM 受注明細番号 (String)
SCHED_LINE 受注納入日程 (String)
VAL_TYPE 評価タイプ (String)
ENTRY_QNT 入力単位での数量 (String)
ENTRY_UOM 入力単位 (String)
ENTRY_UOM_ISO 単位の ISO コード (String)
PO_PR_QNT 数量 (購買発注価格単位) (String)
ORDERPR_UN 購買発注価格単位 (購買管理) (String)
ORDERPR_UN_ISO 単位の ISO コード (String)
PO_NUMBER 購買発注番号 (String)
PO_ITEM 購買伝票の明細番号 (String)
SHIPPING 出荷指示 (String)
COMP_SHIP 出荷指示順守 (String)
NO_MORE_GR 納入完了 区分 (String)
ITEM_TEXT 明細テキスト (String)
GR_RCPT 受領者 (String)
UNLOAD_PT 荷渡ポイント (String)
COSTCENTER 原価センタ (String)
ORDERID 指図番号 (String)
ORDER_ITNO 指図明細番号 (String)
CALC_MOTIVE 計算区分 (String)
ASSET_NO 資産番号 (String)
SUB_NUMBER 資産補助番号 (String)
RESERV_NO 入出庫予定/従属所要量の番号 (String)
RES_ITEM 入出庫予定/従属所要量の明細番号 (String)
RES_TYPE レコードタイプ (String)
WITHDRAWN 入出庫予定に対する出庫完了 (String)
MOVE_MAT 入庫/出庫品目 (String)
MOVE_PLANT 入庫/出庫プラント (String)
MOVE_STLOC 入庫/出庫保管場所 (String)
MOVE_BATCH 入庫/出庫ロット (String)
MOVE_VAL_TYPE 転送ロットの評価タイプ (String)
MVT_IND 移動区分 (String)
MOVE_REAS 移動理由 (String)
RL_EST_KEY 不動産管理対象の内部キー (String)
REF_DATE 決済の参照日付 (String)
COST_OBJ 原価対象 (String)
PROFIT_SEGM_NO 収益性セグメント番号 (CO-PA) (String)
PROFIT_CTR 利益センタ (String)
WBS_ELEM WBS 要素 (String)
NETWORK 勘定割当のネットワーク番号 (String)
ACTIVITY 作業番号 (String)
PART_ACCT 取引先勘定コード (String)
AMOUNT_LC マニュアル入力による転記金額 (国内通貨) (String)
AMOUNT_SV 外部入力による販売金額 (国内通貨) (String)
REF_DOC_YR 参照伝票の会計年度 (String)
REF_DOC 参照伝票の伝票番号 (String)
REF_DOC_IT 参照伝票の明細番号 (String)
EXPIRYDATE 有効期間期限日 (String)
PROD_DATE ロット製造日付 (String)
FUND 会計区分 (String)
FUNDS_CTR 予算センタ (String)
CMMT_ITEM 資金予算コード (String)
VAL_SALES_ORD 評価受注在庫の受注番号 (String)
VAL_S_ORD_ITEM 評価受注在庫の受注明細 (String)
VAL_WBS_ELEM WBS 要素 (String)
GL_ACCOUNT G/L 勘定コード (String)
IND_PROPOSE_QUANX 提案数量 (初期数量) (String)
XSTOB 取消移動タイプ区分の使用 (String)
EAN_UPC 国際商品コード (EAN/UPC) (String)
DELIV_NUMB_TO_SEARCH 出荷伝票 (String)
DELIV_ITEM_TO_SEARCH 出荷明細 (String)
SERIALNO_AUTO_NUMBERASSIGNMENT シリアル番号の自動登録 (String)
VENDRBATCH 仕入先ロット番号 (String)
STGE_TYPE 保管域タイプ (String)
STGE_BIN 棚番 (String)
SU_PL_STCK_1 在庫受入予定の保管単位数 (String)
ST_UN_QTYY_1 代替数量単位での在庫受入予定保管単位別数量 (String)
ST_UN_QTYY_1_ISO 単位の ISO コード (String)
UNITTYPE_1 保管単位タイプ (String)
SU_PL_STCK_2 在庫受入予定の保管単位数 (String)
ST_UN_QTYY_2 代替数量単位での在庫受入予定保管単位別数量 (String)
ST_UN_QTYY_2_ISO 単位の ISO コード (String)
UNITTYPE_2 保管単位タイプ (String)
STGE_TYPE_PC 在庫転送の保管域タイプ (String)
STGE_BIN_PC 在庫転送棚番 (String)
NO_PST_CHGNT 区分: 振替要求通知登録禁止 (String)
GR_NUMBER 入庫番号 (String)
STGE_TYPE_ST 在庫転送の保管域タイプ (String)
STGE_BIN_ST 在庫転送棚番 (String)
MATDOC_TR_CANCEL 取消予定の転送要求の入出庫伝票番号 (String)
MATITEM_TR_CANCEL 取消予定の転送数量入出庫伝票明細 (String)
MATYEAR_TR_CANCEL 取消予定の転送要求入出庫伝票年度 (String)
NO_TRANSFER_REQ 区分: 転送要求未登録 (String)
CO_BUSPROC 業務プロセス (String)
ACTTYPE 活動タイプ (String)
SUPPL_VEND 供給仕入先 (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード (長) (今後のリリースで開発) (String)
MATERIAL_GUID 項目 MATERIAL の外部 GUID (今後のリリースで開発) (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (今後のリリースで開発) (String)
MOVE_MAT_EXTERNAL 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発) (String)
MOVE_MAT_GUID 項目 MOVE_MAT の外部 GUID (今後のリリースで開発) (String)
MOVE_MAT_VERSION 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発) (String)
FUNC_AREA 機能領域 (String)
TR_PART_BA 取引会社事業領域 (String)
PAR_COMPCO 決済会社コード (String)
DELIV_NUMB 出荷伝票 (String)
DELIV_ITEM 出荷明細 (String)
NB_SLIPS 入庫/出庫票の印刷部数 (String)
NB_SLIPSX 関連ユーザデータ項目の更新情報 (String)
GR_RCPTX 関連ユーザデータ項目の更新情報 (String)
UNLOAD_PTX 関連ユーザデータ項目の更新情報 (String)
SPEC_MVMT 倉庫管理の特殊移動区分 (String)
GRANT_NBR 補助金 (String)
CMMT_ITEM_LONG 資金予算コード (String)
FUNC_AREA_LONG 機能領域 (String)
LINE_ID 伝票明細行の一意 ID (String)
PARENT_ID 1 レベル上位の行 ID (String)
LINE_DEPTH 伝票での明細行階層レベル (String)
QUANTITY 数量 (String)
BASE_UOM 基本数量単位 (String)

取得した入出庫伝票情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["MATERIAL"]　→　配列内のidx番目の入出庫伝票の「品目コード」
[idx]["PLANT"]　→　配列内のidx番目の入出庫伝票の「プラント」
[idx]["STGE_LOC"]　→　配列内のidx番目の入出庫伝票の「保管場所」
[idx]["BATCH"]　→　配列内のidx番目の入出庫伝票の「ロット番号」
[idx]["MOVE_TYPE"]　→　配列内のidx番目の入出庫伝票の「移動タイプ (在庫管理)」
[idx]["STCK_TYPE"]　→　配列内のidx番目の入出庫伝票の「在庫タイプ」
[idx]["SPEC_STOCK"]　→　配列内のidx番目の入出庫伝票の「特殊在庫区分」
[idx]["VENDOR"]　→　配列内のidx番目の入出庫伝票の「仕入先勘定コード」
[idx]["CUSTOMER"]　→　配列内のidx番目の入出庫伝票の「得意先コード」
[idx]["SALES_ORD"]　→　配列内のidx番目の入出庫伝票の「受注伝票番号」
[idx]["S_ORD_ITEM"]　→　配列内のidx番目の入出庫伝票の「受注明細番号」
[idx]["SCHED_LINE"]　→　配列内のidx番目の入出庫伝票の「受注納入日程」
[idx]["VAL_TYPE"]　→　配列内のidx番目の入出庫伝票の「評価タイプ」
[idx]["ENTRY_QNT"]　→　配列内のidx番目の入出庫伝票の「入力単位での数量」
[idx]["ENTRY_UOM"]　→　配列内のidx番目の入出庫伝票の「入力単位」
[idx]["ENTRY_UOM_ISO"]　→　配列内のidx番目の入出庫伝票の「単位の ISO コード」
[idx]["PO_PR_QNT"]　→　配列内のidx番目の入出庫伝票の「数量 (購買発注価格単位)」
[idx]["ORDERPR_UN"]　→　配列内のidx番目の入出庫伝票の「購買発注価格単位 (購買管理)」
[idx]["ORDERPR_UN_ISO"]　→　配列内のidx番目の入出庫伝票の「単位の ISO コード」
[idx]["PO_NUMBER"]　→　配列内のidx番目の入出庫伝票の「購買発注番号」
[idx]["PO_ITEM"]　→　配列内のidx番目の入出庫伝票の「購買伝票の明細番号」
[idx]["SHIPPING"]　→　配列内のidx番目の入出庫伝票の「出荷指示」
[idx]["COMP_SHIP"]　→　配列内のidx番目の入出庫伝票の「出荷指示順守」
[idx]["NO_MORE_GR"]　→　配列内のidx番目の入出庫伝票の「納入完了 区分」
[idx]["ITEM_TEXT"]　→　配列内のidx番目の入出庫伝票の「明細テキスト」
[idx]["GR_RCPT"]　→　配列内のidx番目の入出庫伝票の「受領者」
[idx]["UNLOAD_PT"]　→　配列内のidx番目の入出庫伝票の「荷渡ポイント」
[idx]["COSTCENTER"]　→　配列内のidx番目の入出庫伝票の「原価センタ」
[idx]["ORDERID"]　→　配列内のidx番目の入出庫伝票の「指図番号」
[idx]["ORDER_ITNO"]　→　配列内のidx番目の入出庫伝票の「指図明細番号」
[idx]["CALC_MOTIVE"]　→　配列内のidx番目の入出庫伝票の「計算区分」
[idx]["ASSET_NO"]　→　配列内のidx番目の入出庫伝票の「資産番号」
[idx]["SUB_NUMBER"]　→　配列内のidx番目の入出庫伝票の「資産補助番号」
[idx]["RESERV_NO"]　→　配列内のidx番目の入出庫伝票の「入出庫予定/従属所要量の番号」
[idx]["RES_ITEM"]　→　配列内のidx番目の入出庫伝票の「入出庫予定/従属所要量の明細番号」
[idx]["RES_TYPE"]　→　配列内のidx番目の入出庫伝票の「レコードタイプ」
[idx]["WITHDRAWN"]　→　配列内のidx番目の入出庫伝票の「入出庫予定に対する出庫完了」
[idx]["MOVE_MAT"]　→　配列内のidx番目の入出庫伝票の「入庫/出庫品目」
[idx]["MOVE_PLANT"]　→　配列内のidx番目の入出庫伝票の「入庫/出庫プラント」
[idx]["MOVE_STLOC"]　→　配列内のidx番目の入出庫伝票の「入庫/出庫保管場所」
[idx]["MOVE_BATCH"]　→　配列内のidx番目の入出庫伝票の「入庫/出庫ロット」
[idx]["MOVE_VAL_TYPE"]　→　配列内のidx番目の入出庫伝票の「転送ロットの評価タイプ」
[idx]["MVT_IND"]　→　配列内のidx番目の入出庫伝票の「移動区分」
[idx]["MOVE_REAS"]　→　配列内のidx番目の入出庫伝票の「移動理由」
[idx]["RL_EST_KEY"]　→　配列内のidx番目の入出庫伝票の「不動産管理対象の内部キー」
[idx]["REF_DATE"]　→　配列内のidx番目の入出庫伝票の「決済の参照日付」
[idx]["COST_OBJ"]　→　配列内のidx番目の入出庫伝票の「原価対象」
[idx]["PROFIT_SEGM_NO"]　→ 　配列内のidx番目の入出庫伝票の「収益性セグメント番号 (CO-PA)」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の入出庫伝票の「利益センタ」
[idx]["WBS_ELEM"]　→　配列内のidx番目の入出庫伝票の「WBS 要素」
[idx]["NETWORK"]　→　配列内のidx番目の入出庫伝票の「勘定割当のネットワーク番号」
[idx]["ACTIVITY"]　→　配列内のidx番目の入出庫伝票の「作業番号」
[idx]["PART_ACCT"]　→　配列内のidx番目の入出庫伝票の「取引先勘定コード」
[idx]["AMOUNT_LC"]　→ 　配列内のidx番目の入出庫伝票の「マニュアル入力による転記金額 (国内通貨)」
[idx]["AMOUNT_SV"]　→ 　配列内のidx番目の入出庫伝票の「外部入力による販売金額 (国内通貨)」
[idx]["REF_DOC_YR"]　→　配列内のidx番目の入出庫伝票の「参照伝票の会計年度」
[idx]["REF_DOC"]　→　配列内のidx番目の入出庫伝票の「参照伝票の伝票番号」
[idx]["REF_DOC_IT"]　→　配列内のidx番目の入出庫伝票の「参照伝票の明細番号」
[idx]["EXPIRYDATE"]　→　配列内のidx番目の入出庫伝票の「有効期間期限日」
[idx]["PROD_DATE"]　→　配列内のidx番目の入出庫伝票の「ロット製造日付」
[idx]["FUND"]　→　配列内のidx番目の入出庫伝票の「会計区分」
[idx]["FUNDS_CTR"]　→　配列内のidx番目の入出庫伝票の「予算センタ」
[idx]["CMMT_ITEM"]　→　配列内のidx番目の入出庫伝票の「資金予算コード」
[idx]["VAL_SALES_ORD"]　→　配列内のidx番目の入出庫伝票の「評価受注在庫の受注番号」
[idx]["VAL_S_ORD_ITEM"]　→　配列内のidx番目の入出庫伝票の「評価受注在庫の受注明細」
[idx]["VAL_WBS_ELEM"]　→　配列内のidx番目の入出庫伝票の「WBS 要素」
[idx]["GL_ACCOUNT"]　→　配列内のidx番目の入出庫伝票の「G/L 勘定コード」
[idx]["IND_PROPOSE_QUANX"]　→ 　配列内のidx番目の入出庫伝票の「提案数量 (初期数量)」
[idx]["XSTOB"]　→　配列内のidx番目の入出庫伝票の「取消移動タイプ区分の使用」
[idx]["EAN_UPC"]　→　配列内のidx番目の入出庫伝票の「国際商品コード (EAN/UPC)」
[idx]["DELIV_NUMB_TO_SEARCH"]　→　配列内のidx番目の入出庫伝票の「出荷伝票」
[idx]["DELIV_ITEM_TO_SEARCH"]　→　配列内のidx番目の入出庫伝票の「出荷明細」
[idx]["SERIALNO_AUTO_NUMBERASSIGNMENT"]　→ 　配列内のidx番目の入出庫伝票の「シリアル番号の自動登録」
[idx]["VENDRBATCH"]　→　配列内のidx番目の入出庫伝票の「仕入先ロット番号」
[idx]["STGE_TYPE"]　→　配列内のidx番目の入出庫伝票の「保管域タイプ」
[idx]["STGE_BIN"]　→　配列内のidx番目の入出庫伝票の「棚番」
[idx]["SU_PL_STCK_1"]　→　配列内のidx番目の入出庫伝票の「在庫受入予定の保管単位数」
[idx]["ST_UN_QTYY_1"]　→ 　配列内のidx番目の入出庫伝票の「代替数量単位での在庫受入予定保管単位別数量」
[idx]["ST_UN_QTYY_1_ISO"]　→ 　配列内のidx番目の入出庫伝票の「単位の ISO コード」
[idx]["UNITTYPE_1"]　→　配列内のidx番目の入出庫伝票の「保管単位タイプ」
[idx]["SU_PL_STCK_2"]　→　配列内のidx番目の入出庫伝票の「在庫受入予定の保管単位数」
[idx]["ST_UN_QTYY_2"]　→ 　配列内のidx番目の入出庫伝票の「代替数量単位での在庫受入予定保管単位別数量」
[idx]["ST_UN_QTYY_2_ISO"]　→ 　配列内のidx番目の入出庫伝票の「単位の ISO コード」
[idx]["UNITTYPE_2"]　→　配列内のidx番目の入出庫伝票の「保管単位タイプ」
[idx]["STGE_TYPE_PC"]　→　配列内のidx番目の入出庫伝票の「在庫転送の保管域タイプ」
[idx]["STGE_BIN_PC"]　→　配列内のidx番目の入出庫伝票の「在庫転送棚番」
[idx]["NO_PST_CHGNT"]　→　配列内のidx番目の入出庫伝票の「区分: 振替要求通知登録禁止」
[idx]["GR_NUMBER"]　→　配列内のidx番目の入出庫伝票の「入庫番号」
[idx]["STGE_TYPE_ST"]　→　配列内のidx番目の入出庫伝票の「在庫転送の保管域タイプ」
[idx]["STGE_BIN_ST"]　→　配列内のidx番目の入出庫伝票の「在庫転送棚番」
[idx]["MATDOC_TR_CANCEL"]　→ 　配列内のidx番目の入出庫伝票の「取消予定の転送要求の入出庫伝票番号」
[idx]["MATITEM_TR_CANCEL"]　→ 　配列内のidx番目の入出庫伝票の「取消予定の転送数量入出庫伝票明細」
[idx]["MATYEAR_TR_CANCEL"]　→ 　配列内のidx番目の入出庫伝票の「取消予定の転送要求入出庫伝票年度」
[idx]["NO_TRANSFER_REQ"]　→　配列内のidx番目の入出庫伝票の「区分: 転送要求未登録」
[idx]["CO_BUSPROC"]　→　配列内のidx番目の入出庫伝票の「業務プロセス」
[idx]["ACTTYPE"]　→　配列内のidx番目の入出庫伝票の「活動タイプ」
[idx]["SUPPL_VEND"]　→　配列内のidx番目の入出庫伝票の「供給仕入先」
[idx]["MATERIAL_EXTERNAL"]　→ 　配列内のidx番目の入出庫伝票の「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["MATERIAL_GUID"]　→ 　配列内のidx番目の入出庫伝票の「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["MATERIAL_VERSION"]　→ 　配列内のidx番目の入出庫伝票の「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」
[idx]["MOVE_MAT_EXTERNAL"]　→ 　配列内のidx番目の入出庫伝票の「項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)」
[idx]["MOVE_MAT_GUID"]　→ 　配列内のidx番目の入出庫伝票の「項目 MOVE_MAT の外部 GUID (今後のリリースで開発)」
[idx]["MOVE_MAT_VERSION"]　→ 　配列内のidx番目の入出庫伝票の「項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)」
[idx]["FUNC_AREA"]　→　配列内のidx番目の入出庫伝票の「機能領域」
[idx]["TR_PART_BA"]　→　配列内のidx番目の入出庫伝票の「取引会社事業領域」
[idx]["PAR_COMPCO"]　→　配列内のidx番目の入出庫伝票の「決済会社コード」
[idx]["DELIV_NUMB"]　→　配列内のidx番目の入出庫伝票の「出荷伝票」
[idx]["DELIV_ITEM"]　→　配列内のidx番目の入出庫伝票の「出荷明細」
[idx]["NB_SLIPS"]　→　配列内のidx番目の入出庫伝票の「入庫/出庫票の印刷部数」
[idx]["NB_SLIPSX"]　→　配列内のidx番目の入出庫伝票の「関連ユーザデータ項目の更新情報」
[idx]["GR_RCPTX"]　→　配列内のidx番目の入出庫伝票の「関連ユーザデータ項目の更新情報」
[idx]["UNLOAD_PTX"]　→　配列内のidx番目の入出庫伝票の「関連ユーザデータ項目の更新情報」
[idx]["SPEC_MVMT"]　→　配列内のidx番目の入出庫伝票の「倉庫管理の特殊移動区分」
[idx]["GRANT_NBR"]　→　配列内のidx番目の入出庫伝票の「補助金」
[idx]["CMMT_ITEM_LONG"]　→　配列内のidx番目の入出庫伝票の「資金予算コード」
[idx]["FUNC_AREA_LONG"]　→　配列内のidx番目の入出庫伝票の「機能領域」
[idx]["LINE_ID"]　→　配列内のidx番目の入出庫伝票の「伝票明細行の一意 ID」
[idx]["PARENT_ID"]　→　配列内のidx番目の入出庫伝票の「1 レベル上位の行 ID」
[idx]["LINE_DEPTH"]　→　配列内のidx番目の入出庫伝票の「伝票での明細行階層レベル」
[idx]["QUANTITY"]　→　配列内のidx番目の入出庫伝票の「数量」
[idx]["BASE_UOM"]　→　配列内のidx番目の入出庫伝票の「基本数量単位」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getGoodsMvtSerialNumberList

Object getGoodsMvtSerialNumberList ()

シリアル番号を取得します。
返却値
Object シリアル番号

シリアル番号情報オブジェクトの構成は以下のとおりです。
シリアル番号
オブジェクト
(Object)
MATDOC_ITM 入出庫伝票の明細 (String)
SERIALNO シリアル番号 (String)

取得した需要予測パラメータ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["MATDOC_ITM"]　→　配列内のidx番目のシリアル番号の「入出庫伝票の明細」
[idx]["SERIALNO"]　→　配列内のidx番目のシリアル番号の「シリアル番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getMatdocumentyear

String getMatdocumentyear ()

入出庫伝票会計年度を取得します。
返却値
String 入出庫伝票会計年度
getTestrun

value getTestrun ()

在庫移動シミュレーションを取得します｡
返却値
value Object 在庫移動シミュレーション
setStrParam

void setStrParam (String paramStr ,String paramName ,Object value)

構造型の項目に値をセットします。
パラメータ
paramStr | String | 構造名
paramName | String | 項目名
value | Object | セットする値
返却値
void
setTblParam

void setTblParam (String paramTable ,String paramName ,Object value ,int index)

テーブル型の項目に値をセットします。
パラメータ
paramTable | String | テーブル名
paramName | String | 項目名
value | Object | セットする値
index | int | レコード番号
返却値
void
setTestrun

void setTestrun (Object value)

在庫移動シミュレーションを設定します｡
パラメータ
value Object 在庫移動シミュレーション
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 InquiryCreateFromData2Controller オブジェクト

引合伝票登録コントローラクラス。

機能は以下の通り
  • 引合伝票を登録します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
InquiryCreateFromData2Controller ()
コンストラクタ｡
InquiryCreateFromData2Controller (ConnectionManager connectionManager)
コンストラクタ。
InquiryCreateFromData2Controller (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより引合伝票を登録します。
String | getBapiReturnErrMessage () ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage () プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。
Object | getBinaryRelationshiptype () バイナリ関連タイプ (専用)を取得します。
Object | getConvert () 変換: 取引先機能 + 受注伝票タイプを取得します。
Array | getExtensionInList () VBAK、VBAP、VBEP のカスタマ拡張を取得します。
Array | getInquiryCfgsBlobList () 選定: BLOB 内部データ (SCE)を取得します。
Array | getInquiryCfgsInstList () 選定: インスタンスを取得します。
Array | getInquiryCfgsPartOfList () 選定: 部分設定を取得します。
Array | getInquiryCfgsRefInstList () 選定: 参照明細/インスタンスを取得します。
Array | getInquiryCfgsRefList () 選定: 参照データを取得します。
Array | getInquiryCfgsValueList () 選定: 特性値を取得します。
Array | getInquiryCfgsVkList () 選定: バリアント条件キーを取得します。
Array | getInquiryConditionsInList () 条件を取得します。
Array | getInquiryConditionsInXList () 受注における条件更新の通信項目を取得します。
Object | getInquiryHeaderIn () 引合伝票ヘッダデータを取得します。
Object | getInquiryHeaderInX () ヘッダデータチェックボックスを取得します。
Array | getInquiryItemsInList () 明細データを取得します。
Array | getInquiryItemsInXList () 明細データチェックボックスを取得します。
Array | getInquiryKeysList () 参照キーの出力を取得します。
Array | getInquiryPartnersList () 伝票取引先を取得します。
Array | getInquirySchedulesInList () 納入日程行を取得します。
Array | getInquirySchedulesInXList () 納入日程行チェックボックスを取得します。
Array | getInquiryTextList () テキストを取得します。
Object | getIntNumberAssignment () 明細番号内部採番を取得します。
Object | getLogicSwitch () 内部制御パラメータを取得します。
Array | getPartnerAddressesList () アドレス (組織/会社) 用 BAPI 参照構造を取得します。
Object | getSalesdocument () 販売伝票番号を取得します。
Object | getSalesdocumentin () 販売管理伝票番号を取得します。
Object | getSender () 論理システム - 送信者を取得します。
Object | getTestrun () テスト実行を取得します。
void | setBehaveWhenError (Object value) エラー処理を設定します｡
void | setBinaryRelationshiptype (Object value) バイナリ関連タイプ (専用)を設定します｡
void | setConvert (Object value) 変換: 取引先機能 + 受注伝票タイプを設定します｡
void | setIntNumberAssignment (Object value) 明細番号内部採番を設定します｡
void | setSalesdocumentin (Object value) 販売管理伝票番号を設定します｡
void | setStrParam (String paramStr ,String paramName ,Object value) 構造型の項目に値をセットします。
void | setTblParam (String paramTable ,String paramName ,Object value ,int index) テーブル型の項目に値をセットします。
void | setTestrun (Object value) テスト実行を設定します｡
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
InquiryCreateFromData2Controller

InquiryCreateFromData2Controller ()
コンストラクタ｡
InquiryCreateFromData2Controller

InquiryCreateFromData2Controller (ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、InquiryCreateFromData2Controller#executeBapi()実行後に必ず ConnectionManager#commit()またはConnectionManager#rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。
パラメータ
connectionManager ConnectionManager コネクションマネージャー
InquiryCreateFromData2Controller

InquiryCreateFromData2Controller (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより引合伝票を登録します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getBapiReturnErrMessage

String getBapiReturnErrMessage ()

ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡
返却値
String BAPI実行結果エラーとなった全てのメッセージ情報
getBapiReturnMessage

String getBapiReturnMessage ()

プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡
返却値
String プロパティファイルでオートコミット条件に一致したType情報のメッセージ情報
getBinaryRelationshiptype

Object getBinaryRelationshiptype ()

バイナリ関連タイプ (専用)を取得します。
返却値
Object バイナリ関連タイプ（専用）
getConvert

Object getConvert ()

変換: 取引先機能 + 受注伝票タイプを取得します。
返却値
Object 変換: 取引先機能 + 受注伝票タイプ
getExtensionInList

Array getExtensionInList ()

VBAK、VBAP、VBEP のカスタマ拡張を取得します。
返却値
Array VBAK、VBAP、VBEP のカスタマ拡張

VBAK、VBAP、VBEP のカスタマ拡張の構成は以下のとおりです。
VBAK、VBAP、VBEP のカスタマ拡張
オブジェクト
(Object)
STRUCTURE BAPI テーブル拡張の構造名 (String)
VALUEPART1 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART2 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART3 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART4 BAPI 拡張パラメータのデータ部分 (String)

VBAK、VBAP、VBEP のカスタマ拡張オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["STRUCTURE"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI テーブル拡張の構造名」
[idx]["VALUEPART1"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART2"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART3"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART4"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI 拡張パラメータのデータ部分」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryCfgsBlobList

Array getInquiryCfgsBlobList ()

選定: BLOB 内部データ (SCE)を取得します。
返却値
Array 選定: BLOB 内部データ (SCE)

選定: BLOB 内部データ (SCE)オブジェクトの構成は以下のとおりです。
選定: BLOB 内部データ (SCE)
オブジェクト
(Object)
CONFIG_ID 外部選定 ID (仮) (String)
CONTEXT CU: 選定の BLOB. (SCE) (String)

選定: BLOB 内部データ (SCE)オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: BLOB 内部データ (SCE)の 「外部選定 ID (仮)」
[idx]["CONTEXT"]　→　配列内のidx番目の選定: BLOB 内部データ (SCE)の 「CU: 選定の BLOB. (SCE)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryCfgsInstList

Array getInquiryCfgsInstList ()

選定: インスタンスを取得します。
返却値
Array 選定: インスタンス

選定: インスタンスオブジェクトの構成は以下のとおりです。
選定: インスタンス
オブジェクト
(Object)
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)
OBJ_TYPE 対象タイプ (String)
CLASS_TYPE クラスタイプ (String)
OBJ_KEY 対象キー (String)
OBJ_TXT 言語依存対象テキスト (String)
QUANTITY インスタンス数量 (String)
AUTHOR 報告書提案済 (String)
QUANTITY_UNIT 数量単位 (String)
COMPLETE 一般区分 (String)
CONSISTENT 一般区分 (String)
OBJECT_GUID インスタンス用 TYPE_OF ステートメントの GUID (String)
PERSIST_ID インスタンス番号 (固定) (String)
PERSIST_ID_TYPE インスタンス番号タイプ (固定) (String)

選定: インスタンスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: インスタンスの「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の選定: インスタンスの「選定におけるインスタンス番号」
[idx]["OBJ_TYPE"]　→　配列内のidx番目の選定: インスタンスの「対象タイプ」
[idx]["CLASS_TYPE"]　→　配列内のidx番目の選定: インスタンスの「クラスタイプ」
[idx]["OBJ_KEY"]　→　配列内のidx番目の選定: インスタンスの「対象キー」
[idx]["OBJ_TXT"]　→　配列内のidx番目の選定: インスタンスの「言語依存対象テキスト」
[idx]["QUANTITY"]　→　配列内のidx番目の選定: インスタンスの「インスタンス数量」
[idx]["AUTHOR"]　→　配列内のidx番目の選定: インスタンスの「報告書提案済」
[idx]["QUANTITY_UNIT"]　→　配列内のidx番目の選定: インスタンスの「数量単位」
[idx]["COMPLETE"]　→　配列内のidx番目の選定: インスタンスの「一般区分」
[idx]["CONSISTENT"]　→　配列内のidx番目の選定: インスタンスの「一般区分」
[idx]["OBJECT_GUID"]　→　配列内のidx番目の選定: インスタンスの 「インスタンス用 TYPE_OF ステートメントの GUID」
[idx]["PERSIST_ID"]　→　配列内のidx番目の選定: インスタンスの「インスタンス番号 (固定)」
[idx]["PERSIST_ID_TYPE"]　→　配列内のidx番目の選定: インスタンスの 「インスタンス番号タイプ (固定)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryCfgsPartOfList

Array getInquiryCfgsPartOfList ()

選定: 部分設定を取得します。
返却値
Array 選定: 部分設定

選定: 部分設定オブジェクトの構成は以下のとおりです。
選定: 部分設定
オブジェクト
(Object)
CONFIG_ID 外部選定 ID (仮) (String)
PARENT_ID 選定におけるインスタンス番号 (String)
INST_ID 選定におけるインスタンス番号 (String)
PART_OF_NO Part_of 明細番号 (String)
OBJ_TYPE 対象タイプ (String)
CLASS_TYPE クラスタイプ (String)
OBJ_KEY 対象キー (String)
AUTHOR 報告書提案済 (String)
SALES_RELEVANT この部品は販売に関連しています (String)
PART_OF_GUID インスタンス用 PART_OF ステートメントの GUID (String)

選定: 部分設定オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: 部分設定の「外部選定 ID (仮)」
[idx]["PARENT_ID"]　→　配列内のidx番目の選定: 部分設定の「選定におけるインスタンス番号」
[idx]["INST_ID"]　→　配列内のidx番目の選定: 部分設定の「選定におけるインスタンス番号」
[idx]["PART_OF_NO"]　→　配列内のidx番目の選定: 部分設定の「Part_of 明細番号」
[idx]["OBJ_TYPE"]　→　配列内のidx番目の選定: 部分設定の「対象タイプ」
[idx]["CLASS_TYPE"]　→　配列内のidx番目の選定: 部分設定の「クラスタイプ」
[idx]["OBJ_KEY"]　→　配列内のidx番目の選定: 部分設定の「対象キー」
[idx]["AUTHOR"]　→　配列内のidx番目の選定: 部分設定の「報告書提案済」
[idx]["SALES_RELEVANT"]　→　配列内のidx番目の選定: 部分設定の 「この部品は販売に関連しています」
[idx]["PART_OF_GUID"]　→　配列内のidx番目の選定: 部分設定の 「インスタンス用 PART_OF ステートメントの GUID」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryCfgsRefInstList

Array getInquiryCfgsRefInstList ()

選定: 参照明細/インスタンスを取得します。
返却値
Array 選定: 参照明細/インスタンス

選定: 参照明細/インスタンスオブジェクトの構成は以下のとおりです。
選定: 参照明細/インスタンス
オブジェクト
(Object)
POSEX 外部明細番号 (String)
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)

選定: 参照明細/インスタンスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["POSEX"]　→　配列内のidx番目の選定: 参照明細/インスタンスの「外部明細番号」
[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: 参照明細/インスタンスの 「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の選定: 参照明細/インスタンスの 「選定におけるインスタンス番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryCfgsRefList

Array getInquiryCfgsRefList ()

選定: 参照データを取得します。
返却値
Array 選定: 参照データ

選定: 参照データオブジェクトの構成は以下のとおりです。
選定: 参照データ
オブジェクト
(Object)
POSEX 外部明細番号 (String)
CONFIGconfig_id 外部選定 ID (仮) (String)
ROOT_Iroot_id 選定におけるインスタンス番号 (String)
SCE scCUX: 選定タイプ (String)
KBNAMEkbname ナレッジベースオブジェクト (String)
KBVERSkbversion SCE ナレッジベースの実行時バージョン (String)
COMPLEcomplete 一般区分 (String)
CONSISconsistent 一般区分 (String)
CFGINFcfginfo CU: 選定の BLOB (SCE) (String)
KBPROFkbprofile ナレッジベースプロファイル (String)
KBLANGkblanguage システム設定の言語 (String)
CBASE_cbase_id インスタンス番号 (固定) (String)
CBASE_cbase_id_type インスタンス番号タイプ (固定) (String)

選定: 参照データオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["POSEX"]　→　配列内のidx番目の選定: 参照データの「外部明細番号」
[idx]["CONFIGconfig_id"]　→　配列内のidx番目の選定: 参照データの 「外部選定 ID (仮)」
[idx]["ROOT_Iroot_id"]　→　配列内のidx番目の選定: 参照データの 「選定におけるインスタンス番号」
[idx]["SCE"]　→　配列内のidx番目の選定: 参照データの「scCUX: 選定タイプ」
[idx]["KBNAMEkbname"]　→　配列内のidx番目の選定: 参照データの「ナレッジベースオブジェクト」
[idx]["KBVERSkbversion"]　→　配列内のidx番目の選定: 参照データの 「SCE ナレッジベースの実行時バージョン」
[idx]["COMPLEcomplete"]　→　配列内のidx番目の選定: 参照データの「一般区分」
[idx]["CONSISconsistent"]　→　配列内のidx番目の選定: 参照データの「一般区分」
[idx]["CFGINFcfginfo"]　→　配列内のidx番目の選定: 参照データの 「CU: 選定の BLOB (SCE)」
[idx]["KBPROFkbprofile"]　→　配列内のidx番目の選定: 参照データの 「ナレッジベースプロファイル」
[idx]["KBLANGkblanguage"]　→　配列内のidx番目の選定: 参照データの「システム設定の言語」
[idx]["CBASE_cbase_id"]　→　配列内のidx番目の選定: 参照データの 「インスタンス番号 (固定)」
[idx]["CBASE_cbase_id_type"]　→　配列内のidx番目の選定: 参照データの 「インスタンス番号タイプ (固定)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryCfgsValueList

Array getInquiryCfgsValueList ()

選定: 特性値を取得します。
返却値
Array 選定: 特性値

選定: 特性値オブジェクトの構成は以下のとおりです。
選定: 特性値
オブジェクト
(Object)
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)
CHARC 特性名 (String)
CHARC_TXT 言語依存特性テキスト (String)
VALUE 特性値 (String)
VALUE_TXT 特性値の言語依存テキスト (String)
AUTHOR 報告書提案済 (String)
VALUE_TO 特性値 (String)
VALCODE 値タイプ: 範囲制限 - 単一値 (String)

選定: 特性値オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: 特性値の「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の選定: 特性値の「選定におけるインスタンス番号」
[idx]["CHARC"]　→　配列内のidx番目の選定: 特性値の「特性名」
[idx]["CHARC_TXT"]　→　配列内のidx番目の選定: 特性値の「言語依存特性テキスト」
[idx]["VALUE"]　→　配列内のidx番目の選定: 特性値の「特性値」
[idx]["VALUE_TXT"]　→　配列内のidx番目の選定: 特性値の「特性値の言語依存テキスト」
[idx]["AUTHOR"]　→　配列内のidx番目の選定: 特性値の「報告書提案済」
[idx]["VALUE_TO"]　→　配列内のidx番目の選定: 特性値の「特性値」
[idx]["VALCODE"]　→　配列内のidx番目の選定: 特性値の「値タイプ: 範囲制限 - 単一値」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryCfgsVkList

Array getInquiryCfgsVkList ()

選定: バリアント条件キーを取得します。
返却値
Array 選定: バリアント条件キー

選定: バリアント条件キーオブジェクトの構成は以下のとおりです。
選定: バリアント条件キー
オブジェクト
(Object)
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)
VKEY バリアント条件名 (String)
FACTOR バリアント条件の加重係数 (String)

選定: バリアント条件キーオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: バリアント条件キーの「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の選定: バリアント条件キーの「選定におけるインスタンス番号」
[idx]["VKEY"]　→　配列内のidx番目の選定: バリアント条件キーの「バリアント条件名」
[idx]["FACTOR"]　→　配列内のidx番目の選定: バリアント条件キーの「バリアント条件の加重係数」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryConditionsInList

Array getInquiryConditionsInList ()

条件を取得します。
返却値
Array 条件

条件オブジェクトの構成は以下のとおりです。
条件
オブジェクト
(Object)
ITM_NUMBER 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件カウンタ (String)
COND_TYPE 条件タイプ (String)
COND_VALUE 条件レート (String)
CURRENCY 通貨コード (String)
COND_UNIT 条件単位 (String)
COND_P_UNT 価格条件単位 (String)
CURR_ISO ISO コード通貨 (String)
CD_UNT_ISO 条件数量単位 (ISO コード) (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)
APPLICATIO アプリケーション (String)
CONPRICDAT 条件価格設定日付 (String)
CALCTYPCON 条件計算タイプ (String)
CONBASEVAL 条件基礎値 (String)
CONEXCHRAT 現地通貨への換算レートに対する条件 (String)
NUMCONVERT 条件単位を基本単位へ変換する分子 (String)
DENOMINATO 条件単位を基本単位へ変換する分母 (String)
CONDTYPE 条件カテゴリ (例: 税、運賃、価格、原価) (String)
STAT_CON 統計に適用する条件 (String)
SCALETYPE スケールタイプ (String)
ACCRUALS 見越額関連条件 (運賃など) (String)
CONINVOLST 請求書一覧条件 (String)
CONDORIGIN 条件生成区分 (String)
GROUPCOND グループ条件区分 (String)
COND_UPDAT 条件更新 (String)
ACCESS_SEQ 検索順序 - 検索番号 (String)
CONDCOUNT 条件連続番号 (String)
ROUNDOFFDI BAPI の通貨額 (小数点以下９桁) (String)
CONDVALUE 条件金額 (String)
CURRENCY_2 販売伝票通貨 (String)
CURR_ISO_2 ISO コード通貨 (String)
CONDCNTRL 条件管理 (String)
CONDISACTI 無効条件 (String)
CONDCLASS 条件クラス (String)
FACTBASVAL 条件基礎値に対する要因 (String)
SCALEBASIN スケール基準区分 (String)
SCALBASVAL 条件のスケール基準値 (String)
UNITMEASUR 条件スケール単位 (String)
ISO_UNIT 単位の ISO コード (String)
CURRENCKEY スケール通貨 (String)
CURRENISO ISO コード通貨 (String)
CONDINCOMP 会社間請求の条件 (String)
CONDCONFIG システム設定の条件 (String)
CONDCHAMAN 条件 (マニュアル変更済) (String)
COND_NO 条件レコード番号 (String)
TAX_CODE 消費税コード (String)
VARCOND バリアント条件 (String)
ACCOUNTKEY 勘定キー (String)
ACCOUNT_KE 勘定キー 見越/引当 (String)
WT_WITHCD 源泉徴収税コード (String)
STRUCTCOND 構造条件 (String)
FACTCONBAS 条件基準の係数 (期間) (String)
CONDCOINHD 条件カウンタ (ヘッダ条件) (String)

条件オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の条件の「条件明細番号」
[idx]["COND_ST_NO"]　→　配列内のidx番目の条件の「ステップ番号」
[idx]["COND_COUNT"]　→　配列内のidx番目の条件の「条件カウンタ」
[idx]["COND_TYPE"]　→　配列内のidx番目の条件の「条件タイプ」
[idx]["COND_VALUE"]　→　配列内のidx番目の条件の「条件レート」
[idx]["CURRENCY"]　→　配列内のidx番目の条件の「通貨コード」
[idx]["COND_UNIT"]　→　配列内のidx番目の条件の「条件単位」
[idx]["COND_P_UNT"]　→　配列内のidx番目の条件の「価格条件単位」
[idx]["CURR_ISO"]　→　配列内のidx番目の条件の「ISO コード通貨」
[idx]["CD_UNT_ISO"]　→　配列内のidx番目の条件の「条件数量単位 (ISO コード)」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の条件の「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の条件の「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の条件の「論理システム」
[idx]["APPLICATIO"]　→　配列内のidx番目の条件の「アプリケーション」
[idx]["CONPRICDAT"]　→　配列内のidx番目の条件の「条件価格設定日付」
[idx]["CALCTYPCON"]　→　配列内のidx番目の条件の「条件計算タイプ」
[idx]["CONBASEVAL"]　→　配列内のidx番目の条件の「条件基礎値」
[idx]["CONEXCHRAT"]　→　配列内のidx番目の条件の「現地通貨への換算レートに対する条件」
[idx]["NUMCONVERT"]　→　配列内のidx番目の条件の「条件単位を基本単位へ変換する分子」
[idx]["DENOMINATO"]　→　配列内のidx番目の条件の「条件単位を基本単位へ変換する分母」
[idx]["CONDTYPE"]　→　配列内のidx番目の条件の「条件カテゴリ (例: 税、運賃、価格、原価)」
[idx]["STAT_CON"]　→　配列内のidx番目の条件の「統計に適用する条件」
[idx]["SCALETYPE"]　→　配列内のidx番目の条件の「スケールタイプ」
[idx]["ACCRUALS"]　→　配列内のidx番目の条件の「見越額関連条件 (運賃など)」
[idx]["CONINVOLST"]　→　配列内のidx番目の条件の「請求書一覧条件」
[idx]["CONDORIGIN"]　→　配列内のidx番目の条件の「条件生成区分」
[idx]["GROUPCOND"]　→　配列内のidx番目の条件の「グループ条件区分」
[idx]["COND_UPDAT"]　→　配列内のidx番目の条件の「条件更新」
[idx]["ACCESS_SEQ"]　→　配列内のidx番目の条件の「検索順序 - 検索番号」
[idx]["CONDCOUNT"]　→　配列内のidx番目の条件の「条件連続番号」
[idx]["ROUNDOFFDI"]　→　配列内のidx番目の条件の「BAPI の通貨額 (小数点以下９桁)」
[idx]["CONDVALUE"]　→　配列内のidx番目の条件の「条件金額」
[idx]["CURRENCY_2"]　→　配列内のidx番目の条件の「販売伝票通貨」
[idx]["CURR_ISO_2"]　→　配列内のidx番目の条件の「ISO コード通貨」
[idx]["CONDCNTRL"]　→　配列内のidx番目の条件の「条件管理」
[idx]["CONDISACTI"]　→　配列内のidx番目の条件の「無効条件」
[idx]["CONDCLASS"]　→　配列内のidx番目の条件の「条件クラス」
[idx]["FACTBASVAL"]　→　配列内のidx番目の条件の「条件基礎値に対する要因」
[idx]["SCALEBASIN"]　→　配列内のidx番目の条件の「スケール基準区分」
[idx]["SCALBASVAL"]　→　配列内のidx番目の条件の「条件のスケール基準値」
[idx]["UNITMEASUR"]　→　配列内のidx番目の条件の「条件スケール単位」
[idx]["ISO_UNIT"]　→　配列内のidx番目の条件の「単位の ISO コード」
[idx]["CURRENCKEY"]　→　配列内のidx番目の条件の「スケール通貨」
[idx]["CURRENISO"]　→　配列内のidx番目の条件の「ISO コード通貨」
[idx]["CONDINCOMP"]　→　配列内のidx番目の条件の「会社間請求の条件」
[idx]["CONDCONFIG"]　→　配列内のidx番目の条件の「システム設定の条件」
[idx]["CONDCHAMAN"]　→　配列内のidx番目の条件の「条件 (マニュアル変更済)」
[idx]["COND_NO"]　→　配列内のidx番目の条件の「条件レコード番号」
[idx]["TAX_CODE"]　→　配列内のidx番目の条件の「消費税コード」
[idx]["VARCOND"]　→　配列内のidx番目の条件の「バリアント条件」
[idx]["ACCOUNTKEY"]　→　配列内のidx番目の条件の「勘定キー」
[idx]["ACCOUNT_KE"]　→　配列内のidx番目の条件の「勘定キー 見越/引当」
[idx]["WT_WITHCD"]　→　配列内のidx番目の条件の「源泉徴収税コード」
[idx]["STRUCTCOND"]　→　配列内のidx番目の条件の「構造条件」
[idx]["FACTCONBAS"]　→　配列内のidx番目の条件の「条件基準の係数 (期間)」
[idx]["CONDCOINHD"]　→　配列内のidx番目の条件の「条件カウンタ (ヘッダ条件)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryConditionsInXList

Array getInquiryConditionsInXList ()

受注における条件更新の通信項目を取得します。
返却値
Array 受注における条件更新の通信項目

受注における条件更新の通信項目オブジェクトの構成は以下のとおりです。
受注における条件更新の通信項目
オブジェクト
(Object)
ITM_NUMBER 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件連続番号 (String)
COND_TYPE 条件タイプ (String)
UPDATEFLAG 更新区分 (String)
COND_VALUE 関連ユーザデータ項目の更新情報 (String)
CURRENCY 関連ユーザデータ項目の更新情報 (String)
COND_UNIT 関連ユーザデータ項目の更新情報 (String)
COND_P_UNT 関連ユーザデータ項目の更新情報 (String)
VARCOND バリアント条件 (String)

受注における条件更新の通信項目オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の受注における条件更新の通信項目の「条件明細番号」
[idx]["COND_ST_NO"]　→　配列内のidx番目の受注における条件更新の通信項目の「ステップ番号」
[idx]["COND_COUNT"]　→　配列内のidx番目の受注における条件更新の通信項目の「条件連続番号」
[idx]["COND_TYPE"]　→　配列内のidx番目の受注における条件更新の通信項目の「条件タイプ」
[idx]["UPDATEFLAG"]　→　配列内のidx番目の受注における条件更新の通信項目の「更新区分」
[idx]["COND_VALUE"]　→　配列内のidx番目の受注における条件更新の通信項目の 「関連ユーザデータ項目の更新情報」
[idx]["CURRENCY"]　→　配列内のidx番目の受注における条件更新の通信項目の 「関連ユーザデータ項目の更新情報」
[idx]["COND_UNIT"]　→　配列内のidx番目の受注における条件更新の通信項目の 「関連ユーザデータ項目の更新情報」
[idx]["COND_P_UNT"]　→　配列内のidx番目の受注における条件更新の通信項目の 「関連ユーザデータ項目の更新情報」
[idx]["VARCOND"]　→　配列内のidx番目の受注における条件更新の通信項目の「バリアント条件」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryHeaderIn

Object getInquiryHeaderIn ()

引合伝票ヘッダデータを取得します。
返却値
Object 引合伝票ヘッダデータ

引合伝票ヘッダデータオブジェクトの構成は以下のとおりです。
引合伝票ヘッダデータ
オブジェクト
(Object)
REFOBJTYPE オブジェクトタイプ(String)
REFOBJKEY オブジェクトキー(String)
REFDOCTYPE 参照オブジェクトの伝票タイプ(String)
DOC_TYPE 販売伝票タイプ(String)
COLLECT_NO 一括番号(String)
SALES_ORG 販売組織(String)
DISTR_CHAN 流通チャネル(String)
DIVISION 製品部門(String)
SALES_GRP 営業グループ(String)
SALES_OFF 営業所(String)
REQ_DATE_H 指定納入期日(String)
DATE_TYPE 提案日付タイプ(String)
PURCH_DATE 得意先発注日付(String)
PO_METHOD 得意先発注タイプ(String)
PO_SUPPLEM 得意先発注番号補足(String)
REF_1 得意先/仕入先の内部参照コード(String)
NAME 発注者名称(String)
TELEPHONE 電話番号(String)
PRICE_GRP 価格グループ (得意先)(String)
CUST_GROUP 得意先グループ(String)
SALES_DIST 販売地域(String)
PRICE_LIST 価格表タイプ(String)
INCOTERMS1 インコタームズ (1)(String)
INCOTERMS2 インコタームズ 2(String)
PMNTTRMS 支払条件キー(String)
DLV_BLOCK 出荷ブロック (伝票ヘッダ)(String)
BILL_BLOCK 販売管理伝票の請求ブロック(String)
ORD_REASON 受注理由 (取引理由)(String)
COMPL_DLV 一括納入区分(String)
PRICE_DATE 価格設定/外貨換算の実行日付(String)
QT_VALID_F 見積/引合有効開始日(String)
QT_VALID_T 見積の有効終了日(String)
CT_VALID_F 有効開始日付 (販売契約/品目提案)(String)
CT_VALID_T 有効終了日付 (販売契約/品目提案)(String)
CUST_GRP1 得意先グループ 1(String)
CUST_GRP2 得意先グループ 2(String)
CUST_GRP3 得意先グループ 3(String)
CUST_GRP4 得意先グループ 4(String)
CUST_GRP5 得意先グループ 5(String)
PURCH_NO_C 出荷先発注番号(String)
PURCH_NO_S 出荷先の得意先発注番号(String)
PO_DAT_S 出荷先の出荷先発注日付(String)
PO_METH_S 出荷先の出荷先発注タイプ(String)
REF_1_S 出荷先文字(String)
SD_DOC_CAT 販売管理伝票カテゴリ(String)
DOC_DATE 伝票日付 (受信日/送信日)(String)
WAR_DATE 保証期間の開始日付(String)
SHIP_COND 出荷条件(String)
PP_SEARCH 品目提案検索条件(String)
DUN_COUNT 得意先商談回数(String)
DUN_DATE 得意先との前回の商談日(String)
DLVSCHDUSE 用途区分(String)
PLDLVSTYP MRP: 出荷計画タイプ(String)
REF_DOC 参照伝票番号(String)
COMP_CDE_B 請求対象会社コード(String)
ALTTAX_CLS 代替税分類(String)
TAX_CLASS2 得意先税分類 2(String)
TAX_CLASS3 得意先税分類 3(String)
TAX_CLASS4 得意先に対する税クラス 4(String)
TAX_CLASS5 得意先に対する税クラス 5(String)
TAX_CLASS6 得意先に対する税クラス 6(String)
TAX_CLASS7 得意先に対する税クラス 7(String)
TAX_CLASS8 得意先に対する税クラス 8(String)
TAX_CLASS9 得意先に対する税クラス 9(String)
REF_DOC_L 参照伝票番号(String)
ASS_NUMBER 割当番号(String)
REFDOC_CAT 先行販売管理伝票の伝票カテゴリ(String)
ORDCOMB_IN 受注結合出荷区分(String)
BILL_SCHED 請求日程 (稼働日カレンダ指定)(String)
INVO_SCHED 請求書一覧日程 (稼働日カレンダ指定)(String)
MN_INVOICE マニュアル請求書更新(String)
EXRATE_FI FI 転記の換算レート (直接相場)(String)
ADD_VAL_DY 有効日からの日数(String)
FIX_VAL_DY 有効日日付(String)
PYMT_METH 支払方法(String)
ACCNT_ASGN 得意先の勘定設定グループ(String)
EXCHG_RATE 価格設定/統計の換算レート (直接引用)(String)
BILL_DATE 請求索引および印刷に対する請求日(String)
SERV_DATE サービス提供日(String)
DUNN_KEY 督促処理キー(String)
DUNN_BLOCK 督促処理保留(String)
PMTGAR_PRO 支払保証決定表(String)
DEPARTM_NO 部門コード(String)
REC_POINT 入荷ポイント(String)
DOC_NUM_FI ドキュメンタリクレジット処理: 内部番号(String)
CSTCNDGRP1 得意先条件グループ１(String)
CSTCNDGRP2 得意先条件グループ２(String)
CSTCNDGRP3 得意先条件グループ３(String)
CSTCNDGRP4 得意先条件グループ４(String)
CSTCNDGRP5 得意先条件グループ５(String)
DLV_TIME 契約出荷期間(String)
CURRENCY 販売伝票通貨(String)
CURR_ISO ISO コード通貨(String)
CREATED_BY オブジェクト登録者名(String)
TAXDEP_CTY 税出荷国(String)
TAXDST_CTY 税仕向国(String)
EUTRI_DEAL フラグ: EC 内三角取引(String)
MAST_CONTR グループマスタ契約番号(String)
REF_PROC 参照限定条件: 決定区分(String)
CHKPRTAUTH 取引先権限チェック(String)
CMLQTY_DAT 累積出荷数量日付(String)
VERSION 販売伝票バージョン番号(String)
NOTIF_NO 通知番号(String)
WBS_ELEM WBS 要素(String)
EXCH_RATE_FI_V FI 転記の換算レート (間接相場)(String)
EXCHG_RATE_V 価格設定/統計の換算レート (間接引用)(String)
FKK_CONACCT 長さ 12 の文字項目(String)
CAMPAIGN 総括プロジェクト計画: 外部 R/3 システムの GUID(String)
DOC_CLASS リリースおよびトランザクション管理 を備えた元システム(String)
H_CURR 通貨コード(String)
H_CURR_ISO ISO 通貨コード(String)
SHIP_TYPE 出荷タイプ(String)
S_PROC_IND 特別処理区分(String)
REF_DOC_L_LONG 参照伝票番号 (依存関係についてはテキスト (長) を参照)(String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryHeaderInX

Object getInquiryHeaderInX ()

ヘッダデータチェックボックスを取得します。
返却値
Object ヘッダデータチェックボックス

ヘッダデータチェックボックスオブジェクトの構成は以下のとおりです。
ヘッダデータチェックボックス
オブジェクト
(Object)
UPDATEFLAG 更新区分 (String)
DOC_TYPE 関連ユーザデータ項目の更新情報 (String)
COLLECT_NO 関連ユーザデータ項目の更新情報 (String)
SALES_ORG 関連ユーザデータ項目の更新情報 (String)
DISTR_CHAN 関連ユーザデータ項目の更新情報 (String)
DIVISION 関連ユーザデータ項目の更新情報 (String)
SALES_GRP 関連ユーザデータ項目の更新情報 (String)
SALES_OFF 関連ユーザデータ項目の更新情報 (String)
REQ_DATE_H 関連ユーザデータ項目の更新情報 (String)
DATE_TYPE 関連ユーザデータ項目の更新情報 (String)
PURCH_DATE 関連ユーザデータ項目の更新情報 (String)
PO_METHOD 関連ユーザデータ項目の更新情報 (String)
PO_SUPPLEM 関連ユーザデータ項目の更新情報 (String)
REF_1 関連ユーザデータ項目の更新情報 (String)
NAME 関連ユーザデータ項目の更新情報 (String)
TELEPHONE 関連ユーザデータ項目の更新情報 (String)
PRICE_GRP 関連ユーザデータ項目の更新情報 (String)
CUST_GROUP 関連ユーザデータ項目の更新情報 (String)
SALES_DIST 関連ユーザデータ項目の更新情報 (String)
PRICE_LIST 関連ユーザデータ項目の更新情報 (String)
INCOTERMS1 関連ユーザデータ項目の更新情報 (String)
INCOTERMS2 関連ユーザデータ項目の更新情報 (String)
PMNTTRMS 関連ユーザデータ項目の更新情報 (String)
DLV_BLOCK 関連ユーザデータ項目の更新情報 (String)
BILL_BLOCK 関連ユーザデータ項目の更新情報 (String)
ORD_REASON 関連ユーザデータ項目の更新情報 (String)
COMPL_DLV 関連ユーザデータ項目の更新情報 (String)
PRICE_DATE 関連ユーザデータ項目の更新情報 (String)
QT_VALID_F 関連ユーザデータ項目の更新情報 (String)
QT_VALID_T 関連ユーザデータ項目の更新情報 (String)
CT_VALID_F 関連ユーザデータ項目の更新情報 (String)
CT_VALID_T 関連ユーザデータ項目の更新情報 (String)
CUST_GRP1 関連ユーザデータ項目の更新情報 (String)
CUST_GRP2 関連ユーザデータ項目の更新情報 (String)
CUST_GRP3 関連ユーザデータ項目の更新情報 (String)
CUST_GRP4 関連ユーザデータ項目の更新情報 (String)
CUST_GRP5 関連ユーザデータ項目の更新情報 (String)
PURCH_NO_C 関連ユーザデータ項目の更新情報 (String)
PURCH_NO_S 関連ユーザデータ項目の更新情報 (String)
PO_DAT_S 関連ユーザデータ項目の更新情報 (String)
PO_METH_S 関連ユーザデータ項目の更新情報 (String)
REF_1_S 関連ユーザデータ項目の更新情報 (String)
SD_DOC_CAT 関連ユーザデータ項目の更新情報 (String)
DOC_DATE 関連ユーザデータ項目の更新情報 (String)
WAR_DATE 関連ユーザデータ項目の更新情報 (String)
SHIP_COND 関連ユーザデータ項目の更新情報 (String)
PP_SEARCH 関連ユーザデータ項目の更新情報 (String)
DUN_COUNT 関連ユーザデータ項目の更新情報 (String)
DUN_DATE 関連ユーザデータ項目の更新情報 (String)
DLVSCHDUSE 関連ユーザデータ項目の更新情報 (String)
PLDLVSTYP 関連ユーザデータ項目の更新情報 (String)
REF_DOC 関連ユーザデータ項目の更新情報 (String)
COMP_CDE_B 関連ユーザデータ項目の更新情報 (String)
ALTTAX_CLS 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS2 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS3 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS4 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS5 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS6 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS7 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS8 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS9 関連ユーザデータ項目の更新情報 (String)
REF_DOC_L 関連ユーザデータ項目の更新情報 (String)
ASS_NUMBER 関連ユーザデータ項目の更新情報 (String)
REFDOC_CAT 関連ユーザデータ項目の更新情報 (String)
ORDCOMB_IN 関連ユーザデータ項目の更新情報 (String)
BILL_SCHED 関連ユーザデータ項目の更新情報 (String)
INVO_SCHED 関連ユーザデータ項目の更新情報 (String)
MN_INVOICE 関連ユーザデータ項目の更新情報 (String)
EXRATE_FI 関連ユーザデータ項目の更新情報 (String)
ADD_VAL_DY 関連ユーザデータ項目の更新情報 (String)
FIX_VAL_DY 関連ユーザデータ項目の更新情報 (String)
PYMT_METH 関連ユーザデータ項目の更新情報 (String)
ACCNT_ASGN 関連ユーザデータ項目の更新情報 (String)
EXCHG_RATE 関連ユーザデータ項目の更新情報 (String)
BILL_DATE 関連ユーザデータ項目の更新情報 (String)
SERV_DATE 関連ユーザデータ項目の更新情報 (String)
DUNN_KEY 関連ユーザデータ項目の更新情報 (String)
DUNN_BLOCK 関連ユーザデータ項目の更新情報 (String)
PROMOTION 関連ユーザデータ項目の更新情報 (String)
PMTGAR_PRO 関連ユーザデータ項目の更新情報 (String)
DEPARTM_NO 関連ユーザデータ項目の更新情報 (String)
REC_POINT 関連ユーザデータ項目の更新情報 (String)
POITM_NO_S 関連ユーザデータ項目の更新情報 (String)
DOC_NUM_FI 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP1 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP2 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP3 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP4 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP5 関連ユーザデータ項目の更新情報 (String)
DLV_TIME 関連ユーザデータ項目の更新情報 (String)
CURRENCY 関連ユーザデータ項目の更新情報 (String)
TAXDEP_CTY 関連ユーザデータ項目の更新情報 (String)
TAXDST_CTY 関連ユーザデータ項目の更新情報 (String)
EUTRI_DEAL 関連ユーザデータ項目の更新情報 (String)
MAST_CONTR 関連ユーザデータ項目の更新情報 (String)
REF_PROC 関連ユーザデータ項目の更新情報 (String)
CHKPRTAUTH 関連ユーザデータ項目の更新情報 (String)
CMLQTY_DAT 関連ユーザデータ項目の更新情報 (String)
VERSION 関連ユーザデータ項目の更新情報 (String)
NOTIF_NO 関連ユーザデータ項目の更新情報 (String)
WBS_ELEM 関連ユーザデータ項目の更新情報 (String)
EXCH_RATE_FI_V 関連ユーザデータ項目の更新情報 (String)
EXCHG_RATE_V 関連ユーザデータ項目の更新情報 (String)
FKK_CONACCT 関連ユーザデータ項目の更新情報 (String)
CAMPAIGN 関連ユーザデータ項目の更新情報 (String)
DOC_CLASS 関連ユーザデータ項目の更新情報 (String)
H_CURR 関連ユーザデータ項目の更新情報 (String)
SHIP_TYPE 関連ユーザデータ項目の更新情報 (String)
S_PROC_IND 関連ユーザデータ項目の更新情報 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryItemsInList

Array getInquiryItemsInList ()

明細データを取得します。
返却値
Array 明細データ

明細データオブジェクトの構成は以下のとおりです。
明細データ
オブジェクト
(Object)
ITM_NUMBER 販売伝票明細 (String)
HG_LV_ITEM 上位レベル明細 (String)
PO_ITM_NO 元となる購買発注の明細番号 (String)
MATERIAL 品目コード (String)
ALT_TO_ITM 代替明細 (String)
CUST_MAT22 得意先品目コード (無効) (String)
BATCH ロット番号 (String)
DLV_GROUP 出荷グループ (明細一括出荷) (String)
PART_DLV 明細レベルの分納納入 (String)
REASON_REJ 見積および受注の拒否理由 (String)
BILL_BLOCK ブロック (String)
BILL_DATE 請求索引および印刷に対する請求日 (String)
PLANT プラント (String)
STORE_LOC 保管場所 (String)
TARGET_QTY 目標数量（販売単位） (String)
TARGET_QU 目標数量 (数量単位) (String)
T_UNIT_ISO 目標数量単位 (ISO コード) (String)
ITEM_CATEG 明細カテゴリ (販売伝票) (String)
SHORT_TEXT テキスト (短): 受注明細 (String)
PRC_GROUP1 品目グループ 1 (String)
PRC_GROUP2 品目グループ 2 (String)
PRC_GROUP3 品目グループ 3 (String)
PRC_GROUP4 品目グループ 4 (String)
PRC_GROUP5 品目グループ 5 (String)
PROD_HIERA 品目階層 (String)
MATL_GROUP 品目グループ (String)
PURCH_NO_C 出荷先発注番号 (String)
PURCH_DATE 得意先発注日付 (String)
PO_METHOD 得意先発注タイプ (String)
REF_1 得意先/仕入先の内部参照コード (String)
PURCH_NO_S 出荷先の得意先発注番号 (String)
PO_DAT_S 出荷先の出荷先発注日付 (String)
PO_METH_S 出荷先の出荷先発注タイプ (String)
REF_1_S 出荷先文字 (String)
POITM_NO_S 元となる購買発注の明細番号 (String)
PRICE_GRP 価格グループ (得意先) (String)
CUST_GROUP 得意先グループ (String)
SALES_DIST 販売地域 (String)
PRICE_LIST 価格表タイプ (String)
INCOTERMS1 インコタームズ (1) (String)
INCOTERMS2 インコタームズ 2 (String)
ORDCOMP_IN 受注結合出荷区分 (String)
BILL_SCHED 請求日程 (稼働日カレンダ指定) (String)
INVO_SCHED 請求書一覧日程 (稼働日カレンダ指定) (String)
MN_INVOICE マニュアル請求書更新 (String)
EX_RATE_FI FI 転記の換算レート (直接相場) (String)
ADD_VAL_DY 有効日からの日数 (String)
FIX_VAL_DY 有効日日付 (String)
PMNTTRMS 支払条件キー (String)
PYMT_METH 支払方法 (String)
ACCNT_ASGN 得意先の勘定設定グループ (String)
EXCHG_RATE 価格設定/統計の換算レート (直接引用) (String)
PRICE_DATE 価格設定/外貨換算の実行日付 (String)
SERV_DATE サービス提供日 (String)
DUNN_KEY 督促処理キー (String)
DUNN_BLOCK 督促処理保留 (String)
PROMOTION プロモーション (String)
PMTGAR_PRO 支払保証決定表 (String)
DOC_NUM_FI ドキュメンタリクレジット処理: 内部番号 (String)
DEPARTM_NO 部門コード (String)
REC_POINT 入荷ポイント (String)
CSTCNDGRP1 得意先条件グループ１ (String)
CSTCNDGRP2 得意先条件グループ２ (String)
CSTCNDGRP3 得意先条件グループ３ (String)
CSTCNDGRP4 得意先条件グループ４ (String)
CSTCNDGRP5 得意先条件グループ５ (String)
DLV_TIME 契約出荷期間 (String)
SALES_UNIT 販売単位 (String)
S_UNIT_ISO 単位の ISO コード (String)
TRG_QTY_NO 販売単位から基本単位への換算係数 (String)
TRGQTY_DEN 販売単位から基本単位への換算係数 (String)
RNDDLV_QTY 丸め数量: 出荷 (String)
MAXDEVAMNT 数量に関する許容偏差 (絶対値) (String)
MAXDEVPER 数量に関する許容偏差 (%) (String)
MAXDEV_DAY シフト所要日数 (String)
USAGE_IND 未使用 - 予約長 3 (String)
FIXED_QUAN 数量固定区分 (String)
UNLMT_DLV 区分: 無制限過剰納入可能 (String)
OVERDLVTOL 過剰納入許容範囲 (String)
UNDDLV_TOL 不足納入許容範囲リミット (String)
DIVISION 製品部門 (String)
SALQTYNUM 販売数量単位から基本数量単位への変換係数の分子 (String)
SALQTYDEN 販売数量単位を SKU に換算するための分母 (除数) (String)
GROSS_WGHT 明細の総重量 (String)
NET_WEIGHT 明細の正味重量 (String)
UNTOF_WGHT 重量単位 (String)
UNOF_WTISO ISO コードでの重量単位 (String)
VOLUME 明細の総数量 (String)
VOLUNIT 容積単位 (String)
VOLUNITISO ISO コードでの容積単位 (String)
DLV_PRIO 出荷優先順位 (String)
SHIP_POINT 出荷ポイント/入荷ポイント (String)
ROUTE 輸送経路 (String)
CREATED_BY オブジェクト登録者名 (String)
TAX_CLASS1 品目の税分類 (String)
TAX_CLASS2 品目の税分類 (String)
TAX_CLASS3 品目の税分類 (String)
TAX_CLASS4 品目の税分類 (String)
TAX_CLASS5 品目の税分類 (String)
TAX_CLASS6 品目の税分類 (String)
TAX_CLASS7 品目の税分類 (String)
TAX_CLASS8 品目の税分類 (String)
TAX_CLASS9 品目の税分類 (String)
MAT_PR_GRP 品目価格設定グループ (String)
VAL_TYPE 評価タイプ (String)
FIXDAT_QTY 納期と出荷数量の固定 (String)
BOMEXPL_NO BOM 展開番号 (String)
RESANALKEY 結果分析キー (String)
REQMTS_TYP 所要量タイプ (String)
NO_GR_POST 得意先が入庫を転記していません (String)
BUS_TRANST 貿易管理の取引タイプ (String)
OVERHD_KEY 間接費キー (String)
CSTG_SHEET 原価計算表 (String)
MATFRGTGRP 品目運賃グループ (String)
PLDLVSHDIN 出荷計画に関する指示 (String)
SEQ_NO KANBAN/連続番号 (String)
BIL_FORM 請求書式 (String)
DLI_PROFIL 動的明細プロセッサプロファイル (String)
REV_TYPE 収益承認カテゴリ (String)
BEGDEM_PER 見越期間の提案開始日付 (String)
PR_REF_MAT 価格設定参照品目 (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)
ORDER_PROB 明細の受注可能性 (String)
MAX_PL_DLV 明細ごとの分割納入可能な最大回数 (String)
CFOP_CODE CFOP code and extension (old 5 char version) (String)
TAXLAWICMS 税法: ICMS (String)
TAXLAWIPI 税法: IPI (String)
SD_TAXCODE 0 (String)
ASSORT_MOD 品揃モジュール (String)
COMP_QUANT 構成品目数量 (String)
TARGET_VAL BAPI の通貨額 (小数点以下９桁) (String)
CURRENCY 販売伝票通貨 (String)
CURR_ISO ISO コード通貨 (String)
PROFIT_CTR 利益センタ (String)
ORDERID 指図番号 (String)
WBS_ELEM WBS 要素 (String)
DEPREC_PER ドキュメンタリクレジット処理に関する償却率 (%) (String)
REF_DOC 参照伝票番号 (String)
REF_DOC_IT 参照明細番号 (String)
REF_DOC_CA 先行販売管理伝票の伝票カテゴリ (String)
CUST_MAT35 得意先品目 (String)
EXCH_RATE_FI_V FI 転記の換算レート (間接相場) (String)
EXCHG_RATE_V 価格設定/統計の換算レート (間接引用) (String)
ITEMGUID_ATP ATP: 暗号 - DELNR および DELPS (String)
VAL_CONTR 金額契約番号 (String)
VAL_CON_I 金額契約明細 (String)
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)
MAT_EXT 項目 MATERIAL の品目コード (長) (今後のリリースで開発) (String)
MAT_GUID 項目 MATERIAL の外部 GUID (今後のリリースで開発) (String)
MAT_VERS 項目 MATERIAL のバージョン番号 (今後のリリースで開発) (String)
P_MAT_EXT 項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発) (String)
P_MAT_GUID 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発) (String)
P_MAT_VERS 項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発) (String)
FUNC_AREA 機能領域 (String)
ALTERN_BOM 代替 BOM (String)
FKK_CONACCT 長さ 12 の文字項目 (String)
EAN_UPC 国際商品コード (EAN/UPC) (String)
PRODCAT 製品カタログ番号 (String)
SHIP_TYPE 出荷タイプ (String)
S_PROC_IND 特別処理区分 (String)
FUNC_AREA_LONG 機能領域 (String)
BILL_REL 請求関連 (CRM) (String)
VW_UEPOS 上位レベル明細用途 ID (String)
CAMPAIGN 総括プロジェクト計画: 外部 R/3 システムの GUID (String)
DLVSCHDUSE 用途区分 (String)
CFOP_LONG CFOP code and extension (String)
SELECTION 選択 ID (永続) (String)
MAT_ENTRD 入力品目 (String)
LOG_SYSTEM_OWN 論理システム (String)
ITM_TYPE_USAGE 明細用途 (String)

明細データオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の明細データの「販売伝票明細」
[idx]["HG_LV_ITEM"]　→　配列内のidx番目の明細データの「上位レベル明細」
[idx]["PO_ITM_NO"]　→　配列内のidx番目の明細データの「元となる購買発注の明細番号」
[idx]["MATERIAL"]　→　配列内のidx番目の明細データの「品目コード」
[idx]["ALT_TO_ITM"]　→　配列内のidx番目の明細データの「代替明細」
[idx]["CUST_MAT22"]　→　配列内のidx番目の明細データの「得意先品目コード (無効)」
[idx]["BATCH"]　→　配列内のidx番目の明細データの「ロット番号」
[idx]["DLV_GROUP"]　→　配列内のidx番目の明細データの「出荷グループ (明細一括出荷)」
[idx]["PART_DLV"]　→　配列内のidx番目の明細データの「明細レベルの分納納入」
[idx]["REASON_REJ"]　→　配列内のidx番目の明細データの「見積および受注の拒否理由」
[idx]["BILL_BLOCK"]　→　配列内のidx番目の明細データの「ブロック」
[idx]["BILL_DATE"]　→　配列内のidx番目の明細データの「請求索引および印刷に対する請求日」
[idx]["PLANT"]　→　配列内のidx番目の明細データの「プラント」
[idx]["STORE_LOC"]　→　配列内のidx番目の明細データの「保管場所」
[idx]["TARGET_QTY"]　→　配列内のidx番目の明細データの「目標数量（販売単位）」
[idx]["TARGET_QU"]　→　配列内のidx番目の明細データの「目標数量 (数量単位)」
[idx]["T_UNIT_ISO"]　→　配列内のidx番目の明細データの「目標数量単位 (ISO コード)」
[idx]["ITEM_CATEG"]　→　配列内のidx番目の明細データの「明細カテゴリ (販売伝票)」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の明細データの「テキスト (短): 受注明細」
[idx]["PRC_GROUP1"]　→　配列内のidx番目の明細データの「品目グループ 1」
[idx]["PRC_GROUP2"]　→　配列内のidx番目の明細データの「品目グループ 2」
[idx]["PRC_GROUP3"]　→　配列内のidx番目の明細データの「品目グループ 3」
[idx]["PRC_GROUP4"]　→　配列内のidx番目の明細データの「品目グループ 4」
[idx]["PRC_GROUP5"]　→　配列内のidx番目の明細データの「品目グループ 5」
[idx]["PROD_HIERA"]　→　配列内のidx番目の明細データの「品目階層」
[idx]["MATL_GROUP"]　→　配列内のidx番目の明細データの「品目グループ」
[idx]["PURCH_NO_C"]　→　配列内のidx番目の明細データの「出荷先発注番号」
[idx]["PURCH_DATE"]　→　配列内のidx番目の明細データの「得意先発注日付」
[idx]["PO_METHOD"]　→　配列内のidx番目の明細データの「得意先発注タイプ」
[idx]["REF_1"]　→　配列内のidx番目の明細データの「得意先/仕入先の内部参照コード」
[idx]["PURCH_NO_S"]　→　配列内のidx番目の明細データの「出荷先の得意先発注番号」
[idx]["PO_DAT_S"]　→　配列内のidx番目の明細データの「出荷先の出荷先発注日付」
[idx]["PO_METH_S"]　→　配列内のidx番目の明細データの「出荷先の出荷先発注タイプ」
[idx]["REF_1_S"]　→　配列内のidx番目の明細データの「出荷先文字」
[idx]["POITM_NO_S"]　→　配列内のidx番目の明細データの「元となる購買発注の明細番号」
[idx]["PRICE_GRP"]　→　配列内のidx番目の明細データの「価格グループ (得意先)」
[idx]["CUST_GROUP"]　→　配列内のidx番目の明細データの「得意先グループ」
[idx]["SALES_DIST"]　→　配列内のidx番目の明細データの「販売地域」
[idx]["PRICE_LIST"]　→　配列内のidx番目の明細データの「価格表タイプ」
[idx]["INCOTERMS1"]　→　配列内のidx番目の明細データの「インコタームズ (1)」
[idx]["INCOTERMS2"]　→　配列内のidx番目の明細データの「インコタームズ 2」
[idx]["ORDCOMP_IN"]　→　配列内のidx番目の明細データの「受注結合出荷区分」
[idx]["BILL_SCHED"]　→　配列内のidx番目の明細データの「請求日程 (稼働日カレンダ指定)」
[idx]["INVO_SCHED"]　→　配列内のidx番目の明細データの「請求書一覧日程 (稼働日カレンダ指定)」
[idx]["MN_INVOICE"]　→　配列内のidx番目の明細データの「マニュアル請求書更新」
[idx]["EX_RATE_FI"]　→　配列内のidx番目の明細データの「FI 転記の換算レート (直接相場)」
[idx]["ADD_VAL_DY"]　→　配列内のidx番目の明細データの「有効日からの日数」
[idx]["FIX_VAL_DY"]　→　配列内のidx番目の明細データの「有効日日付」
[idx]["PMNTTRMS"]　→　配列内のidx番目の明細データの「支払条件キー」
[idx]["PYMT_METH"]　→　配列内のidx番目の明細データの「支払方法」
[idx]["ACCNT_ASGN"]　→　配列内のidx番目の明細データの「得意先の勘定設定グループ」
[idx]["EXCHG_RATE"]　→　配列内のidx番目の明細データの 「価格設定/統計の換算レート (直接引用)」
[idx]["PRICE_DATE"]　→　配列内のidx番目の明細データの「価格設定/外貨換算の実行日付」
[idx]["SERV_DATE"]　→　配列内のidx番目の明細データの「サービス提供日」
[idx]["DUNN_KEY"]　→　配列内のidx番目の明細データの「督促処理キー」
[idx]["DUNN_BLOCK"]　→　配列内のidx番目の明細データの「督促処理保留」
[idx]["PROMOTION"]　→　配列内のidx番目の明細データの「プロモーション」
[idx]["PMTGAR_PRO"]　→　配列内のidx番目の明細データの「支払保証決定表」
[idx]["DOC_NUM_FI"]　→　配列内のidx番目の明細データの 「ドキュメンタリクレジット処理: 内部番号」
[idx]["DEPARTM_NO"]　→　配列内のidx番目の明細データの「部門コード」
[idx]["REC_POINT"]　→　配列内のidx番目の明細データの「入荷ポイント」
[idx]["CSTCNDGRP1"]　→　配列内のidx番目の明細データの「得意先条件グループ１」
[idx]["CSTCNDGRP2"]　→　配列内のidx番目の明細データの「得意先条件グループ２」
[idx]["CSTCNDGRP3"]　→　配列内のidx番目の明細データの「得意先条件グループ３」
[idx]["CSTCNDGRP4"]　→　配列内のidx番目の明細データの「得意先条件グループ４」
[idx]["CSTCNDGRP5"]　→　配列内のidx番目の明細データの「得意先条件グループ５」
[idx]["DLV_TIME"]　→　配列内のidx番目の明細データの「契約出荷期間」
[idx]["SALES_UNIT"]　→　配列内のidx番目の明細データの「販売単位」
[idx]["S_UNIT_ISO"]　→　配列内のidx番目の明細データの「単位の ISO コード」
[idx]["TRG_QTY_NO"]　→　配列内のidx番目の明細データの「販売単位から基本単位への換算係数」
[idx]["TRGQTY_DEN"]　→　配列内のidx番目の明細データの「販売単位から基本単位への換算係数」
[idx]["RNDDLV_QTY"]　→　配列内のidx番目の明細データの「丸め数量: 出荷」
[idx]["MAXDEVAMNT"]　→　配列内のidx番目の明細データの「数量に関する許容偏差 (絶対値)」
[idx]["MAXDEVPER"]　→　配列内のidx番目の明細データの「数量に関する許容偏差 (%)」
[idx]["MAXDEV_DAY"]　→　配列内のidx番目の明細データの「シフト所要日数」
[idx]["USAGE_IND"]　→　配列内のidx番目の明細データの「未使用 - 予約長 3」
[idx]["FIXED_QUAN"]　→　配列内のidx番目の明細データの「数量固定区分」
[idx]["UNLMT_DLV"]　→　配列内のidx番目の明細データの「区分: 無制限過剰納入可能」
[idx]["OVERDLVTOL"]　→　配列内のidx番目の明細データの「過剰納入許容範囲」
[idx]["UNDDLV_TOL"]　→　配列内のidx番目の明細データの「不足納入許容範囲リミット」
[idx]["DIVISION"]　→　配列内のidx番目の明細データの「製品部門」
[idx]["SALQTYNUM"]　→　配列内のidx番目の明細データの 「販売数量単位から基本数量単位への変換係数の分子」
[idx]["SALQTYDEN"]　→　配列内のidx番目の明細データの 「販売数量単位を SKU に換算するための分母 (除数)」
[idx]["GROSS_WGHT"]　→　配列内のidx番目の明細データの「明細の総重量」
[idx]["NET_WEIGHT"]　→　配列内のidx番目の明細データの「明細の正味重量」
[idx]["UNTOF_WGHT"]　→　配列内のidx番目の明細データの「重量単位」
[idx]["UNOF_WTISO"]　→　配列内のidx番目の明細データの「ISO コードでの重量単位」
[idx]["VOLUME"]　→　配列内のidx番目の明細データの「明細の総数量」
[idx]["VOLUNIT"]　→　配列内のidx番目の明細データの「容積単位」
[idx]["VOLUNITISO"]　→　配列内のidx番目の明細データの「ISO コードでの容積単位」
[idx]["DLV_PRIO"]　→　配列内のidx番目の明細データの「出荷優先順位」
[idx]["SHIP_POINT"]　→　配列内のidx番目の明細データの「出荷ポイント/入荷ポイント」
[idx]["ROUTE"]　→　配列内のidx番目の明細データの「輸送経路」
[idx]["CREATED_BY"]　→　配列内のidx番目の明細データの「オブジェクト登録者名」
[idx]["TAX_CLASS1"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS2"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS3"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS4"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS5"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS6"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS7"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS8"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS9"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["MAT_PR_GRP"]　→　配列内のidx番目の明細データの「品目価格設定グループ」
[idx]["VAL_TYPE"]　→　配列内のidx番目の明細データの「評価タイプ」
[idx]["FIXDAT_QTY"]　→　配列内のidx番目の明細データの「納期と出荷数量の固定」
[idx]["BOMEXPL_NO"]　→　配列内のidx番目の明細データの「BOM 展開番号」
[idx]["RESANALKEY"]　→　配列内のidx番目の明細データの「結果分析キー」
[idx]["REQMTS_TYP"]　→　配列内のidx番目の明細データの「所要量タイプ」
[idx]["NO_GR_POST"]　→　配列内のidx番目の明細データの「得意先が入庫を転記していません」
[idx]["BUS_TRANST"]　→　配列内のidx番目の明細データの「貿易管理の取引タイプ」
[idx]["OVERHD_KEY"]　→　配列内のidx番目の明細データの「間接費キー」
[idx]["CSTG_SHEET"]　→　配列内のidx番目の明細データの「原価計算表」
[idx]["MATFRGTGRP"]　→　配列内のidx番目の明細データの「品目運賃グループ」
[idx]["PLDLVSHDIN"]　→　配列内のidx番目の明細データの「出荷計画に関する指示」
[idx]["SEQ_NO"]　→　配列内のidx番目の明細データの「KANBAN/連続番号」
[idx]["BIL_FORM"]　→　配列内のidx番目の明細データの「請求書式」
[idx]["DLI_PROFIL"]　→　配列内のidx番目の明細データの「動的明細プロセッサプロファイル」
[idx]["REV_TYPE"]　→　配列内のidx番目の明細データの「収益承認カテゴリ」
[idx]["BEGDEM_PER"]　→　配列内のidx番目の明細データの「見越期間の提案開始日付」
[idx]["PR_REF_MAT"]　→　配列内のidx番目の明細データの「価格設定参照品目」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の明細データの「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の明細データの「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の明細データの「論理システム」
[idx]["ORDER_PROB"]　→　配列内のidx番目の明細データの「明細の受注可能性」
[idx]["MAX_PL_DLV"]　→　配列内のidx番目の明細データの「明細ごとの分割納入可能な最大回数」
[idx]["CFOP_CODE"]　→　配列内のidx番目の明細データの 「CFOP code and extension (old 5 char version)」
[idx]["TAXLAWICMS"]　→　配列内のidx番目の明細データの「税法: ICMS」
[idx]["TAXLAWIPI"]　→　配列内のidx番目の明細データの「税法: IPI」
[idx]["SD_TAXCODE"]　→　配列内のidx番目の明細データの「0」
[idx]["ASSORT_MOD"]　→　配列内のidx番目の明細データの「品揃モジュール」
[idx]["COMP_QUANT"]　→　配列内のidx番目の明細データの「構成品目数量」
[idx]["TARGET_VAL"]　→　配列内のidx番目の明細データの「BAPI の通貨額 (小数点以下９桁)」
[idx]["CURRENCY"]　→　配列内のidx番目の明細データの「販売伝票通貨」
[idx]["CURR_ISO"]　→　配列内のidx番目の明細データの「ISO コード通貨」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の明細データの「利益センタ」
[idx]["ORDERID"]　→　配列内のidx番目の明細データの「指図番号」
[idx]["WBS_ELEM"]　→　配列内のidx番目の明細データの「WBS 要素」
[idx]["DEPREC_PER"]　→　配列内のidx番目の明細データの 「ドキュメンタリクレジット処理に関する償却率 (%)」
[idx]["REF_DOC"]　→　配列内のidx番目の明細データの「参照伝票番号」
[idx]["REF_DOC_IT"]　→　配列内のidx番目の明細データの「参照明細番号」
[idx]["REF_DOC_CA"]　→　配列内のidx番目の明細データの「先行販売管理伝票の伝票カテゴリ」
[idx]["CUST_MAT35"]　→　配列内のidx番目の明細データの「得意先品目」
[idx]["EXCH_RATE_FI_V"]　→　配列内のidx番目の明細データの 「FI 転記の換算レート (間接相場)」
[idx]["EXCHG_RATE_V"]　→　配列内のidx番目の明細データの 「価格設定/統計の換算レート (間接引用)」
[idx]["ITEMGUID_ATP"]　→　配列内のidx番目の明細データの 「ATP: 暗号 - DELNR および DELPS」
[idx]["VAL_CONTR"]　→　配列内のidx番目の明細データの「金額契約番号」
[idx]["VAL_CON_I"]　→　配列内のidx番目の明細データの「金額契約明細」
[idx]["CONFIG_ID"]　→　配列内のidx番目の明細データの「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の明細データの「選定におけるインスタンス番号」
[idx]["MAT_EXT"]　→　配列内のidx番目の明細データの 「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["MAT_GUID"]　→　配列内のidx番目の明細データの 「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["MAT_VERS"]　→　配列内のidx番目の明細データの 「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」
[idx]["P_MAT_EXT"]　→　配列内のidx番目の明細データの 「項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)」
[idx]["P_MAT_GUID"]　→　配列内のidx番目の明細データの 「項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)」
[idx]["P_MAT_VERS"]　→　配列内のidx番目の明細データの 「項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)」
[idx]["FUNC_AREA"]　→　配列内のidx番目の明細データの「機能領域」
[idx]["ALTERN_BOM"]　→　配列内のidx番目の明細データの「代替 BOM」
[idx]["FKK_CONACCT"]　→　配列内のidx番目の明細データの「長さ 12 の文字項目」
[idx]["EAN_UPC"]　→　配列内のidx番目の明細データの「国際商品コード (EAN/UPC)」
[idx]["PRODCAT"]　→　配列内のidx番目の明細データの「製品カタログ番号」
[idx]["SHIP_TYPE"]　→　配列内のidx番目の明細データの「出荷タイプ」
[idx]["S_PROC_IND"]　→　配列内のidx番目の明細データの「特別処理区分」
[idx]["FUNC_AREA_LONG"]　→　配列内のidx番目の明細データの「機能領域」
[idx]["BILL_REL"]　→　配列内のidx番目の明細データの「請求関連 (CRM)」
[idx]["VW_UEPOS"]　→　配列内のidx番目の明細データの「上位レベル明細用途 ID」
[idx]["CAMPAIGN"]　→　配列内のidx番目の明細データの 「総括プロジェクト計画: 外部 R/3 システムの GUID」
[idx]["DLVSCHDUSE"]　→　配列内のidx番目の明細データの「用途区分」
[idx]["CFOP_LONG"]　→　配列内のidx番目の明細データの 「CFOP code and extension」
[idx]["SELECTION"]　→　配列内のidx番目の明細データの「選択 ID (永続)」
[idx]["MAT_ENTRD"]　→　配列内のidx番目の明細データの「入力品目」
[idx]["LOG_SYSTEM_OWN"]　→　配列内のidx番目の明細データの「論理システム」
[idx]["ITM_TYPE_USAGE"]　→　配列内のidx番目の明細データの「明細用途」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryItemsInXList

Array getInquiryItemsInXList ()

明細データチェックボックスを取得します。
返却値
Array 明細データチェックボックス

明細データチェックボックスオブジェクトの構成は以下のとおりです。
明細データチェックボックス
オブジェクト
(Object)
ITM_NUMBER 販売伝票明細 (String)
UPDATEFLAG 更新区分 (String)
HG_LV_ITEM 関連ユーザデータ項目の更新情報 (String)
PO_ITM_NO 関連ユーザデータ項目の更新情報 (String)
MATERIAL 関連ユーザデータ項目の更新情報 (String)
ALT_TO_ITM 関連ユーザデータ項目の更新情報 (String)
CUST_MAT22 関連ユーザデータ項目の更新情報 (String)
BATCH 関連ユーザデータ項目の更新情報 (String)
DLV_GROUP 関連ユーザデータ項目の更新情報 (String)
PART_DLV 関連ユーザデータ項目の更新情報 (String)
REASON_REJ 関連ユーザデータ項目の更新情報 (String)
BILL_BLOCK 関連ユーザデータ項目の更新情報 (String)
BILL_DATE 関連ユーザデータ項目の更新情報 (String)
PLANT 関連ユーザデータ項目の更新情報 (String)
STORE_LOC 関連ユーザデータ項目の更新情報 (String)
TARGET_QTY 関連ユーザデータ項目の更新情報 (String)
TARGET_QU 関連ユーザデータ項目の更新情報 (String)
T_UNIT_ISO 関連ユーザデータ項目の更新情報 (String)
ITEM_CATEG 関連ユーザデータ項目の更新情報 (String)
SHORT_TEXT 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP1 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP2 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP3 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP4 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP5 関連ユーザデータ項目の更新情報 (String)
PROD_HIERA 関連ユーザデータ項目の更新情報 (String)
MATL_GROUP 関連ユーザデータ項目の更新情報 (String)
PURCH_NO_C 関連ユーザデータ項目の更新情報 (String)
PURCH_DATE 関連ユーザデータ項目の更新情報 (String)
PO_METHOD 関連ユーザデータ項目の更新情報 (String)
REF_1 関連ユーザデータ項目の更新情報 (String)
PURCH_NO_S 関連ユーザデータ項目の更新情報 (String)
PO_DAT_S 関連ユーザデータ項目の更新情報 (String)
PO_METH_S 関連ユーザデータ項目の更新情報 (String)
REF_1_S 関連ユーザデータ項目の更新情報 (String)
POITM_NO_S 関連ユーザデータ項目の更新情報 (String)
PRICE_GRP 関連ユーザデータ項目の更新情報 (String)
CUST_GROUP 関連ユーザデータ項目の更新情報 (String)
SALES_DIST 関連ユーザデータ項目の更新情報 (String)
PRICE_LIST 関連ユーザデータ項目の更新情報 (String)
INCOTERMS1 関連ユーザデータ項目の更新情報 (String)
INCOTERMS2 関連ユーザデータ項目の更新情報 (String)
ORDCOMP_IN 関連ユーザデータ項目の更新情報 (String)
BILL_SCHED 関連ユーザデータ項目の更新情報 (String)
INVO_SCHED 関連ユーザデータ項目の更新情報 (String)
MN_INVOICE 関連ユーザデータ項目の更新情報 (String)
EX_RATE_FI 関連ユーザデータ項目の更新情報 (String)
ADD_VAL_DY 関連ユーザデータ項目の更新情報 (String)
FIX_VAL_DY 関連ユーザデータ項目の更新情報 (String)
PMNTTRMS 関連ユーザデータ項目の更新情報 (String)
PYMT_METH 関連ユーザデータ項目の更新情報 (String)
ACCNT_ASGN 関連ユーザデータ項目の更新情報 (String)
EXCHG_RATE 関連ユーザデータ項目の更新情報 (String)
PRICE_DATE 関連ユーザデータ項目の更新情報 (String)
SERV_DATE 関連ユーザデータ項目の更新情報 (String)
DUNN_KEY 関連ユーザデータ項目の更新情報 (String)
DUNN_BLOCK 関連ユーザデータ項目の更新情報 (String)
PROMOTION 関連ユーザデータ項目の更新情報 (String)
PMTGAR_PRO 関連ユーザデータ項目の更新情報 (String)
DOC_NUM_FI 関連ユーザデータ項目の更新情報 (String)
DEPARTM_NO 関連ユーザデータ項目の更新情報 (String)
REC_POINT 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP1 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP2 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP3 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP4 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP5 関連ユーザデータ項目の更新情報 (String)
DLV_TIME 関連ユーザデータ項目の更新情報 (String)
SALES_UNIT 関連ユーザデータ項目の更新情報 (String)
TRG_QTY_NO 関連ユーザデータ項目の更新情報 (String)
TRGQTY_DEN 関連ユーザデータ項目の更新情報 (String)
RNDDLV_QTY 関連ユーザデータ項目の更新情報 (String)
MAXDEVAMNT 関連ユーザデータ項目の更新情報 (String)
MAXDEVPER 関連ユーザデータ項目の更新情報 (String)
MAXDEV_DAY 関連ユーザデータ項目の更新情報 (String)
USAGE_IND 関連ユーザデータ項目の更新情報 (String)
FIXED_QUAN 関連ユーザデータ項目の更新情報 (String)
UNLMT_DLV 関連ユーザデータ項目の更新情報 (String)
OVERDLVTOL 関連ユーザデータ項目の更新情報 (String)
UNDDLV_TOL 関連ユーザデータ項目の更新情報 (String)
DIVISION 関連ユーザデータ項目の更新情報 (String)
SALQTYNUM 関連ユーザデータ項目の更新情報 (String)
SALQTYDEN 関連ユーザデータ項目の更新情報 (String)
GROSS_WGHT 関連ユーザデータ項目の更新情報 (String)
NET_WEIGHT 関連ユーザデータ項目の更新情報 (String)
UNTOF_WGHT 関連ユーザデータ項目の更新情報 (String)
VOLUME 関連ユーザデータ項目の更新情報 (String)
VOLUNIT 関連ユーザデータ項目の更新情報 (String)
DLV_PRIO 関連ユーザデータ項目の更新情報 (String)
SHIP_POINT 関連ユーザデータ項目の更新情報 (String)
ROUTE 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS1 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS2 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS3 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS4 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS5 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS6 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS7 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS8 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS9 関連ユーザデータ項目の更新情報 (String)
MAT_PR_GRP 関連ユーザデータ項目の更新情報 (String)
VAL_TYPE 関連ユーザデータ項目の更新情報 (String)
FIXDAT_QTY 関連ユーザデータ項目の更新情報 (String)
BOMEXPL_NO 関連ユーザデータ項目の更新情報 (String)
RESANALKEY 関連ユーザデータ項目の更新情報 (String)
REQMTS_TYP 関連ユーザデータ項目の更新情報 (String)
NO_GR_POST 関連ユーザデータ項目の更新情報 (String)
BUS_TRANST 関連ユーザデータ項目の更新情報 (String)
OVERHD_KEY 関連ユーザデータ項目の更新情報 (String)
CSTG_SHEET 関連ユーザデータ項目の更新情報 (String)
MATFRGTGRP 関連ユーザデータ項目の更新情報 (String)
PLDLVSHDIN 関連ユーザデータ項目の更新情報 (String)
SEQ_NO 関連ユーザデータ項目の更新情報 (String)
BIL_FORM 関連ユーザデータ項目の更新情報 (String)
DLI_PROFIL 関連ユーザデータ項目の更新情報 (String)
REV_TYPE 関連ユーザデータ項目の更新情報 (String)
BEGDEM_PER 関連ユーザデータ項目の更新情報 (String)
PR_REF_MAT 関連ユーザデータ項目の更新情報 (String)
REFOBJTYPE 関連ユーザデータ項目の更新情報 (String)
REFOBJKEY 関連ユーザデータ項目の更新情報 (String)
REFLOGSYS 関連ユーザデータ項目の更新情報 (String)
ORDER_PROB 関連ユーザデータ項目の更新情報 (String)
MAX_PL_DLV 関連ユーザデータ項目の更新情報 (String)
CFOP_CODE 関連ユーザデータ項目の更新情報 (String)
TAXLAWICMS 関連ユーザデータ項目の更新情報 (String)
TAXLAWIPI 関連ユーザデータ項目の更新情報 (String)
SD_TAXCODE 関連ユーザデータ項目の更新情報 (String)
ASSORT_MOD 関連ユーザデータ項目の更新情報 (String)
COMP_QUANT 関連ユーザデータ項目の更新情報 (String)
TARGET_VAL 関連ユーザデータ項目の更新情報 (String)
PROFIT_CTR 関連ユーザデータ項目の更新情報 (String)
ORDERID 関連ユーザデータ項目の更新情報 (String)
WBS_ELEM 関連ユーザデータ項目の更新情報 (String)
DEPREC_PER 関連ユーザデータ項目の更新情報 (String)
REF_DOC 関連ユーザデータ項目の更新情報 (String)
REF_DOC_IT 関連ユーザデータ項目の更新情報 (String)
REF_DOC_CA 関連ユーザデータ項目の更新情報 (String)
CUST_MAT35 関連ユーザデータ項目の更新情報 (String)
EXCH_RATE_FI_V 関連ユーザデータ項目の更新情報 (String)
EXCHG_RATE_V 関連ユーザデータ項目の更新情報 (String)
ITEMGUID_ATP 関連ユーザデータ項目の更新情報 (String)
VAL_CONTR 関連ユーザデータ項目の更新情報 (String)
VAL_CON_I 関連ユーザデータ項目の更新情報 (String)
CONFIG_ID 関連ユーザデータ項目の更新情報 (String)
INST_ID 関連ユーザデータ項目の更新情報 (String)
MAT_EXT 関連ユーザデータ項目の更新情報 (String)
MAT_GUID 関連ユーザデータ項目の更新情報 (String)
MAT_VERS 関連ユーザデータ項目の更新情報 (String)
P_MAT_EXT 関連ユーザデータ項目の更新情報 (String)
P_MAT_GUID 関連ユーザデータ項目の更新情報 (String)
P_MAT_VERS 関連ユーザデータ項目の更新情報 (String)
FUNC_AREA 関連ユーザデータ項目の更新情報 (String)
ALTERN_BOM 関連ユーザデータ項目の更新情報 (String)
FKK_CONACCT 関連ユーザデータ項目の更新情報 (String)
EAN_UPC 関連ユーザデータ項目の更新情報 (String)
PRODCAT 関連ユーザデータ項目の更新情報 (String)
SHIP_TYPE 関連ユーザデータ項目の更新情報 (String)
S_PROC_IND 関連ユーザデータ項目の更新情報 (String)
BILL_REL 関連ユーザデータ項目の更新情報 (String)
VW_UEPOS 関連ユーザデータ項目の更新情報 (String)
CAMPAIGN 関連ユーザデータ項目の更新情報 (String)
DLVSCHDUSE 関連ユーザデータ項目の更新情報 (String)
SELECTION 関連ユーザデータ項目の更新情報 (String)
MAT_ENTRD 関連ユーザデータ項目の更新情報 (String)
LOG_SYSTEM_OWN 関連ユーザデータ項目の更新情報 (String)
ITM_TYPE_USAGE 関連ユーザデータ項目の更新情報 (String)

明細データチェックボックスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の明細データチェックボックスの「販売伝票明細」
[idx]["UPDATEFLAG"]　→　配列内のidx番目の明細データチェックボックスの「更新区分
[idx]["HG_LV_ITEM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_ITM_NO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["MATERIAL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["ALT_TO_ITM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["CUST_MAT22"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["BATCH"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報
[idx]["DLV_GROUP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["PART_DLV"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["REASON_REJ"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_BLOCK"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_DATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PLANT"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["STORE_LOC"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TARGET_QTY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["TARGET_QU"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["T_UNIT_ISO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ITEM_CATEG"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP1"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP2"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP3"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP4"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP5"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PROD_HIERA"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["MATL_GROUP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PURCH_NO_C"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PURCH_DATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_METHOD"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_1"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["PURCH_NO_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_DAT_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_METH_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_1_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["POITM_NO_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_GRP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["CUST_GROUP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SALES_DIST"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_LIST"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INCOTERMS1"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INCOTERMS2"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ORDCOMP_IN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_SCHED"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INVO_SCHED"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MN_INVOICE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EX_RATE_FI"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ADD_VAL_DY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FIX_VAL_DY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["PMNTTRMS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["PYMT_METH"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ACCNT_ASGN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCHG_RATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_DATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SERV_DATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DUNN_KEY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DUNN_BLOCK"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PROMOTION"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PMTGAR_PRO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DOC_NUM_FI"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DEPARTM_NO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REC_POINT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP1"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP2"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["CSTCNDGRP3"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["CSTCNDGRP4"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP5"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLV_TIME"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SALES_UNIT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TRG_QTY_NO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TRGQTY_DEN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["RNDDLV_QTY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAXDEVAMNT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAXDEVPER"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAXDEV_DAY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["USAGE_IND"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FIXED_QUAN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["UNLMT_DLV"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["OVERDLVTOL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["UNDDLV_TOL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DIVISION"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["SALQTYNUM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["SALQTYDEN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["GROSS_WGHT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["NET_WEIGHT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["UNTOF_WGHT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["VOLUME"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["VOLUNIT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLV_PRIO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SHIP_POINT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ROUTE"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS1"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS2"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS3"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS4"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS5"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS6"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS7"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS8"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS9"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["MAT_PR_GRP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["VAL_TYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FIXDAT_QTY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BOMEXPL_NO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["RESANALKEY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REQMTS_TYP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["NO_GR_POST"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BUS_TRANST"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["OVERHD_KEY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTG_SHEET"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MATFRGTGRP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PLDLVSHDIN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SEQ_NO"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["BIL_FORM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLI_PROFIL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REV_TYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BEGDEM_PER"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PR_REF_MAT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REFOBJKEY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REFLOGSYS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["ORDER_PROB"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAX_PL_DLV"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CFOP_CODE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAXLAWICMS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAXLAWIPI"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SD_TAXCODE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ASSORT_MOD"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["COMP_QUANT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TARGET_VAL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ORDERID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["WBS_ELEM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DEPREC_PER"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_DOC"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_DOC_IT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_DOC_CA"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CUST_MAT35"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCH_RATE_FI_V"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCHG_RATE_V"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ITEMGUID_ATP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["VAL_CONTR"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["VAL_CON_I"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CONFIG_ID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INST_ID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_EXT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_GUID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_VERS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["P_MAT_EXT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["P_MAT_GUID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["P_MAT_VERS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FUNC_AREA"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ALTERN_BOM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FKK_CONACCT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EAN_UPC"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRODCAT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SHIP_TYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["S_PROC_IND"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_REL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["VW_UEPOS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CAMPAIGN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLVSCHDUSE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SELECTION"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_ENTRD"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["LOG_SYSTEM_OWN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ITM_TYPE_USAGE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryKeysList

Array getInquiryKeysList ()

参照キーの出力を取得します。
返却値
Array 参照キーの出力

参照キーの出力オブジェクトの構成は以下のとおりです。
伝票取引先
オブジェクト
(Object)
REFOBJTYP オブジェクトタイプ (String)
REFOBJECT オブジェクト名 (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)
DOC_NUMBER 販売管理伝票番号 (String)
ITM_NUMBER 販売伝票明細 (String)
SCHED_LIN 納入日程行 (String)
COND_NO 伝票条件番号 (String)
CONDITEMNO 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件カウンタ (String)
COND_TYPE 条件タイプ (String)
STATUS 単一文字フラグ (String)
TINDEX 数値項目: 長さ 6 (String)
ADDRESS 住所 (String)
ABRLI 内部納入日程番号 (String)
ABART 承認タイプ (String)

参照キーの出力オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["REFOBJTYP"]　→　配列内のidx番目の参照キーの出力の「オブジェクトタイプ」
[idx]["REFOBJECT"]　→　配列内のidx番目の参照キーの出力の「オブジェクト名
[idx]["REFOBJKEY"]　→　配列内のidx番目の参照キーの出力の「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の参照キーの出力の「論理システム
[idx]["DOC_NUMBER"]　→　配列内のidx番目の参照キーの出力の「販売管理伝票番号
[idx]["ITM_NUMBER"]　→　配列内のidx番目の参照キーの出力の「販売伝票明細
[idx]["SCHED_LIN"]　→　配列内のidx番目の参照キーの出力の「納入日程行
[idx]["COND_NO"]　→　配列内のidx番目の参照キーの出力の「伝票条件番号
[idx]["CONDITEMNO"]　→　配列内のidx番目の参照キーの出力の「条件明細番号
[idx]["COND_ST_NO"]　→　配列内のidx番目の参照キーの出力の「ステップ番号
[idx]["COND_COUNT"]　→　配列内のidx番目の参照キーの出力の「条件カウンタ」
[idx]["COND_TYPE"]　→　配列内のidx番目の参照キーの出力の「条件タイプ」
[idx]["STATUS"]　→　配列内のidx番目の参照キーの出力の「単一文字フラグ」
[idx]["TINDEX"]　→　配列内のidx番目の参照キーの出力の「数値項目: 長さ 6」
[idx]["ADDRESS"]　→　配列内のidx番目の参照キーの出力の「住所」
[idx]["ABRLI"]　→　配列内のidx番目の参照キーの出力の「内部納入日程番号
[idx]["ABART"]　→　配列内のidx番目の参照キーの出力の「承認タイプ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryPartnersList

Array getInquiryPartnersList ()

伝票取引先を取得します。
返却値
Array 伝票取引先

伝票取引先オブジェクトの構成は以下のとおりです。
伝票取引先
オブジェクト
(Object)
PARTN_ROLE 取引先機能 (String)
PARTN_NUMB 得意先コード 1 (String)
ITM_NUMBER 明細番号 (販売管理伝票) (String)
TITLE 敬称 (String)
NAME 名称 1 (String)
NAME_2 名称 2 (String)
NAME_3 名称 3 (String)
NAME_4 名称 4 (String)
STREET 地名/番地-号 (String)
COUNTRY 国コード (String)
COUNTR_ISO 国キー (ISO コード) (String)
POSTL_CODE 郵便番号 (String)
POBX_PCD 私書箱番号 (String)
POBX_CTY 私書箱住所 (String)
CITY 市区町村 (String)
DISTRICT 所在地 (String)
REGION 地域 (都道府県) (String)
PO_BOX 私書箱 (String)
TELEPHONE 電話番号 1 (String)
TELEPHONE2 電話番号 2 (String)
TELEBOX テレボックス番号 (String)
FAX_NUMBER FAX 番号 (String)
TELETEX_NO テレテクス番号 (String)
TELEX_NO テレックス番号 (String)
LANGU 言語キー (String)
LANGU_ISO ISO 639 準拠の言語 (String)
UNLOAD_PT 荷渡ポイント (String)
TRANSPZONE 商品の納入区域 (String)
TAXJURCODE 税計算管轄コード - 税管轄コード (String)
ADDRESS 住所 (String)
PRIV_ADDR 自宅住所 (String)
ADDR_TYPE アドレスタイプ (1=組織、2=個人、3=取引先担当者) (String)
ADDR_ORIG コピー元住所 (String)
ADDR_LINK 住所コードへのリンク (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)

伝票取引先オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PARTN_ROLE"]　→　配列内のidx番目の伝票取引先の「取引先機能」
[idx]["PARTN_NUMB"]　→　配列内のidx番目の伝票取引先の「得意先コード 1
[idx]["ITM_NUMBER"]　→　配列内のidx番目の伝票取引先の「明細番号 (販売管理伝票)」
[idx]["TITLE"]　→　配列内のidx番目の伝票取引先の「敬称
[idx]["NAME"]　→　配列内のidx番目の伝票取引先の「名称 1
[idx]["NAME_2"]　→　配列内のidx番目の伝票取引先の「名称 2
[idx]["NAME_3"]　→　配列内のidx番目の伝票取引先の「名称 3
[idx]["NAME_4"]　→　配列内のidx番目の伝票取引先の「名称 4
[idx]["STREET"]　→　配列内のidx番目の伝票取引先の「地名/番地-号
[idx]["COUNTRY"]　→　配列内のidx番目の伝票取引先の「国コード
[idx]["COUNTR_ISO"]　→　配列内のidx番目の伝票取引先の「国キー (ISO コード)」
[idx]["POSTL_CODE"]　→　配列内のidx番目の伝票取引先の「郵便番号」
[idx]["POBX_PCD"]　→　配列内のidx番目の伝票取引先の「私書箱番号」
[idx]["POBX_CTY"]　→　配列内のidx番目の伝票取引先の「私書箱住所」
[idx]["CITY"]　→　配列内のidx番目の伝票取引先の「市区町村」
[idx]["DISTRICT"]　→　配列内のidx番目の伝票取引先の「所在地
[idx]["REGION"]　→　配列内のidx番目の伝票取引先の「地域 (都道府県)」
[idx]["PO_BOX"]　→　配列内のidx番目の伝票取引先の「私書箱」
[idx]["TELEPHONE"]　→　配列内のidx番目の伝票取引先の「電話番号 1」
[idx]["TELEPHONE2"]　→　配列内のidx番目の伝票取引先の「電話番号 2」
[idx]["TELEBOX"]　→　配列内のidx番目の伝票取引先の「テレボックス番号」
[idx]["FAX_NUMBER"]　→　配列内のidx番目の伝票取引先の「FAX 番号」
[idx]["TELETEX_NO"]　→　配列内のidx番目の伝票取引先の「テレテクス番号」
[idx]["TELEX_NO"]　→　配列内のidx番目の伝票取引先の「テレックス番号」
[idx]["LANGU"]　→　配列内のidx番目の伝票取引先の「言語キー」
[idx]["LANGU_ISO"]　→　配列内のidx番目の伝票取引先の「ISO 639 準拠の言語
[idx]["UNLOAD_PT"]　→　配列内のidx番目の伝票取引先の「荷渡ポイント」
[idx]["TRANSPZONE"]　→　配列内のidx番目の伝票取引先の「商品の納入区域」
[idx]["TAXJURCODE"]　→　配列内のidx番目の伝票取引先の「税計算管轄コード - 税管轄コード」
[idx]["ADDRESS"]　→　配列内のidx番目の伝票取引先の「住所」
[idx]["PRIV_ADDR"]　→　配列内のidx番目の伝票取引先の「自宅住所」
[idx]["ADDR_TYPE"]　→　配列内のidx番目の伝票取引先の 「アドレスタイプ (1=組織、2=個人、3=取引先担当者)」
[idx]["ADDR_ORIG"]　→　配列内のidx番目の伝票取引先の「コピー元住所」
[idx]["ADDR_LINK"]　→　配列内のidx番目の伝票取引先の「住所コードへのリンク」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の伝票取引先の「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の伝票取引先の「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の伝票取引先の「論理システム

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquirySchedulesInList

Array getInquirySchedulesInList ()

納入日程行を取得します。
返却値
Array 納入日程行

納入日程行オブジェクトの構成は以下のとおりです。
納入日程行
オブジェクト
(Object)
ITM_NUMBER 販売伝票明細 (String)
SCHED_LINE 納入日程行 (String)
REQ_DATE 納入日程日付 (String)
DATE_TYPE 日付タイプ (日、週、月、期間) (String)
REQ_TIME 納入時間 (String)
REQ_QTY 販売単位による受注数量 (String)
REQ_DLV_BL 出荷ブロック中の納入日程行 (String)
SCHED_TYPE 納入日程カテゴリ (String)
TP_DATE 輸送計画日付 (String)
MS_DATE 品目利用可能日 (String)
LOAD_DATE 積載日付 (String)
GI_DATE 出庫日付 (String)
TP_TIME 輸送計画 - 時間 (現地時間/出荷ポイント参照) (String)
MS_TIME 品目供給ステージ (現地時刻: プラント参照) (String)
LOAD_TIME 積載時刻 (現地時間: 出荷ポイント) (String)
GI_TIME 出庫時刻 (現地時間 - プラント参照) (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)
DLV_DATE 納入日程日付 (String)
DLV_TIME 納入時間 (String)
REL_TYPE 承認タイプ (String)
PLAN_SCHED_TYPE 納入日程行タイプ EDI (String)

納入日程行オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の納入日程行の「販売伝票明細」
[idx]["SCHED_LINE"]　→　配列内のidx番目の納入日程行の「納入日程行」
[idx]["REQ_DATE"]　→　配列内のidx番目の納入日程行の「納入日程日付」
[idx]["DATE_TYPE"]　→　配列内のidx番目の納入日程行の「日付タイプ (日、週、月、期間)」
[idx]["REQ_TIME"]　→　配列内のidx番目の納入日程行の「納入時間」
[idx]["REQ_QTY"]　→　配列内のidx番目の納入日程行の「販売単位による受注数量」
[idx]["REQ_DLV_BL"]　→　配列内のidx番目の納入日程行の「出荷ブロック中の納入日程行」
[idx]["SCHED_TYPE"]　→　配列内のidx番目の納入日程行の「納入日程カテゴリ」
[idx]["TP_DATE"]　→　配列内のidx番目の納入日程行の「輸送計画日付」
[idx]["MS_DATE"]　→　配列内のidx番目の納入日程行の「品目利用可能日」
[idx]["LOAD_DATE"]　→　配列内のidx番目の納入日程行の「積載日付」
[idx]["GI_DATE"]　→　配列内のidx番目の納入日程行の「出庫日付」
[idx]["TP_TIME"]　→　配列内のidx番目の納入日程行の 「輸送計画 - 時間 (現地時間/出荷ポイント参照)」
[idx]["MS_TIME"]　→　配列内のidx番目の納入日程行の 「品目供給ステージ (現地時刻: プラント参照)」
[idx]["LOAD_TIME"]　→　配列内のidx番目の納入日程行の「積載時刻 (現地時間: 出荷ポイント)」
[idx]["GI_TIME"]　→　配列内のidx番目の納入日程行の「出庫時刻 (現地時間 - プラント参照)」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の納入日程行の「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の納入日程行の「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の納入日程行の「論理システム」
[idx]["DLV_DATE"]　→　配列内のidx番目の納入日程行の「納入日程日付」
[idx]["DLV_TIME"]　→　配列内のidx番目の納入日程行の「納入時間」
[idx]["REL_TYPE"]　→　配列内のidx番目の納入日程行の「承認タイプ」
[idx]["PLAN_SCHED_TYPE"]　→　配列内のidx番目の納入日程行の「納入日程行タイプ EDI」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquirySchedulesInXList

Array getInquirySchedulesInXList ()

納入日程行チェックボックスを取得します。
返却値
Array 納入日程行チェックボックス

納入日程行チェックボックスオブジェクトの構成は以下のとおりです。
納入日程行チェックボックス
オブジェクト
(Object)
ITM_NUMBER 販売伝票明細 (String)
SCHED_LINE 納入日程行 (String)
UPDATEFLAG 更新区分 (String)
REQ_DATE 関連ユーザデータ項目の更新情報 (String)
DATE_TYPE 関連ユーザデータ項目の更新情報 (String)
REQ_TIME 関連ユーザデータ項目の更新情報 (String)
REQ_QTY 関連ユーザデータ項目の更新情報 (String)
REQ_DLV_BL 関連ユーザデータ項目の更新情報 (String)
SCHED_TYPE 関連ユーザデータ項目の更新情報 (String)
TP_DATE 関連ユーザデータ項目の更新情報 (String)
MS_DATE 関連ユーザデータ項目の更新情報 (String)
LOAD_DATE 関連ユーザデータ項目の更新情報 (String)
GI_DATE 関連ユーザデータ項目の更新情報 (String)
TP_TIME 関連ユーザデータ項目の更新情報 (String)
MS_TIME 関連ユーザデータ項目の更新情報 (String)
LOAD_TIME 関連ユーザデータ項目の更新情報 (String)
GI_TIME 関連ユーザデータ項目の更新情報 (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
DLV_DATE 関連ユーザデータ項目の更新情報 (String)
DLV_TIME 関連ユーザデータ項目の更新情報 (String)
REL_TYPE 関連ユーザデータ項目の更新情報 (String)
PLAN_SCHED_TYPE 関連ユーザデータ項目の更新情報 (String)

納入日程行チェックボックスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の納入日程行チェックボックスの「販売伝票明細」
[idx]["SCHED_LINE"]　→　配列内のidx番目の納入日程行チェックボックスの「納入日程行」
[idx]["UPDATEFLAG"]　→　配列内のidx番目の納入日程行チェックボックスの「更新区分」
[idx]["REQ_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["DATE_TYPE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REQ_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REQ_QTY 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REQ_DLV_BL 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["SCHED_TYPE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["TP_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["MS_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["LOAD_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["GI_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["TP_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["MS_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["LOAD_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["GI_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の納入日程行チェックボックスの「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の納入日程行チェックボックスの「オブジェクトキー」
[idx]["DLV_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["DLV_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REL_TYPE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["PLAN_SCHED_TYPE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInquiryTextList

Array getInquiryTextList ()

テキストを取得します。
返却値
Array テキスト

テキストオブジェクトの構成は以下のとおりです。
テキスト
オブジェクト
(Object)
DOC_NUMBE 販売伝票 (String)
ITM_NUMBE 販売伝票明細 (String)
TEXT_ID テキスト ID (String)
LANGU 言語キー (String)
LANGU_ISO ISO 639 準拠の言語 (String)
FORMAT_COL タグ列 (String)
TEXT_LINE テキスト行 (String)
FUNCTION 機能 (String)

テキストオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["DOC_NUMBE"]　→　配列内のidx番目のテキストの「販売伝票」
[idx]["ITM_NUMBE"]　→　配列内のidx番目のテキストの「販売伝票明細」
[idx]["TEXT_ID"]　→　配列内のidx番目のテキストの「テキスト ID」
[idx]["LANGU"]　→　配列内のidx番目のテキストの「言語キー」
[idx]["LANGU_ISO"]　→　配列内のidx番目のテキストの「ISO 639 準拠の言語」
[idx]["FORMAT_COL"]　→　配列内のidx番目のテキストの「タグ列」
[idx]["TEXT_LINE"]　→　配列内のidx番目のテキストの「テキスト行」
[idx]["FUNCTION"]　→　配列内のidx番目のテキストの「機能」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getIntNumberAssignment

Object getIntNumberAssignment ()

明細番号内部採番を取得します。
返却値
Object 明細番号内部採番
getLogicSwitch

Object getLogicSwitch ()

内部制御パラメータを取得します。
返却値
Object 内部制御パラメータ

内部制御パラメータオブジェクトの構成は以下のとおりです。
内部制御パラメータ
オブジェクト
(Object)
PRICING 価格設定タイプ (String)
ATP_WRKMOD ATP セッション: 結果取得/新規決定 APO-ATP (String)
SCHEDULING 単一文字フラグ (String)
NOSTRUCTURE チェックボックス (String)
COND_HANDL 選択: 条件行処理 (SD 伝票変更) (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPartnerAddressesList

Array getPartnerAddressesList ()

アドレス (組織/会社) 用 BAPI 参照構造を取得します。
返却値
Array アドレス (組織/会社) 用 BAPI 参照構造

アドレス (組織/会社) 用 BAPI 参照構造オブジェクトの構成は以下のとおりです。
アドレス (組織/会社) 用 BAPI 参照構造
オブジェクト
(Object)
ADDR_NO アドレス番号 (String)
FORMOFADDR 敬称テキスト (String)
NAME 名称 1 (String)
NAME_2 名称 2 (String)
NAME_3 名称 3 (String)
NAME_4 名称 4 (String)
C_O_NAME 気付 (String)
CITY 市区町村 (String)
DISTRICT 所在地 (String)
CITY_NO 市区町村/地名ファイルの市区町村コード (String)
POSTL_COD1 市区町村の郵便番号 (String)
POSTL_COD2 私書箱郵便番号 (String)
POSTL_COD3 会社郵便番号 (大規模なユーザ用) (String)
PO_BOX 私書箱 (String)
PO_BOX_CIT 私書箱住所 (String)
DELIV_DIS 郵便配達地域 (String)
STREET 地名 (String)
STREET_NO 市区町村/地名ファイルの地名コード (String)
STR_ABBR 地名の略称 (例: スペイン) (String)
HOUSE_NO 番地-号 (String)
STR_SUPPL1 地名 2 (String)
STR_SUPPL2 地名 3 (String)
LOCATION 地名 5 (String)
BUILDING 旧: 建物 (番号または略称) (String)
FLOOR 建物の階 (String)
ROOM_NO 部屋/アパート番号 (String)
COUNTRY 国コード (String)
LANGU 言語キー (String)
REGION 地域 (都道府県) (String)
SORT1 検索条件 1 (String)
SORT2 検索条件 2 (String)
TIME_ZONE アドレスタイムゾーン (String)
TAXJURCODE 税管轄コード (String)
ADR_NOTES 住所注記 (String)
COMM_TYPE 通信方法 (キー) (アドレス管理) (String)
TEL1_NUMBR 第一電話番号: ダイヤルコード + 番号 (String)
TEL1_EXT 第 1 電話番号: 内線 (String)
FAX_NUMBER 第一 FAX 番号: ダイヤルコード + 番号 (String)
FAX_EXTENS 第一 FAX 番号: 内線 (String)
STREET_LNG 地名 (String)
DISTRCT_NO 市区町村/地名ファイルの所在地コード (String)
CHCKSTATUS 市区町村ファイルテストステータス (String)
PBOXCIT_NO 市区町村私書箱コード (市ファイル) (String)
TRANSPZONE 商品の納入区域 (String)
HOUSE_NO2 番地補足 (String)
E_MAIL 電子メールアドレス (String)
STR_SUPPL3 地名 4 (String)
TITLE タイトル (敬称) (String)
COUNTRYISO ISO 国コード (String)
LANGU_ISO ISO 639 準拠の言語 (String)
BUILD_LONG 建物 (番号またはコード) (String)
REGIOGROUP 地域構造グループ化 (String)
HOME_CITY 市区町村 (郵便用市区町村と異なる場合) (String)
HOMECITYNO 別の市区町村 (市区町村/地名ファイル) (String)
PCODE1_EXT 市区町村郵便番号の拡張子 例: 郵便番号 +4+2 (String)
PCODE2_EXT 私書箱郵便番号拡張子 例: 郵便番号 +4+2 (String)
PCODE3_EXT 主要得意先郵便番号拡張子 例: 郵便番号 +4+2 (String)
PO_W_O_NO フラグ: 郵便私書箱 (番号なし) (String)
PO_BOX_REG 私書箱の地域 (国、都道府県、地域、...) (String)
POBOX_CTRY 私書箱の国指定 (String)
PO_CTRYISO ISO 国コード (String)
HOMEPAGE URI 例: ホームページ、FTP アドレス (String)
DONT_USE_S 地名住所配達不可フラグ (String)
DONT_USE_P 私書箱住所配達不可フラグ (String)
HOUSE_NO3 番地範囲 (String)
LANGU_CR アドレスレコード登録オリジナル言語 (String)
LANGUCRISO ISO 639 準拠の言語 (String)

アドレス (組織/会社) 用 BAPI 参照構造オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ADDR_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「アドレス番号」
[idx]["FORMOFADDR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「敬称テキスト」
[idx]["NAME"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「名称 1」
[idx]["NAME_2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「名称 2」
[idx]["NAME_3"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「名称 3」
[idx]["NAME_4"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「名称 4」
[idx]["C_O_NAME"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「気付」
[idx]["CITY"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「市区町村」
[idx]["DISTRICT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「所在地」
[idx]["CITY_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村/地名ファイルの市区町村コード」
[idx]["POSTL_COD1"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村の郵便番号」
[idx]["POSTL_COD2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱郵便番号」
[idx]["POSTL_COD3"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「会社郵便番号 (大規模なユーザ用)」
[idx]["PO_BOX"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「私書箱」
[idx]["PO_BOX_CIT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱住所」
[idx]["DELIV_DIS"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「郵便配達地域」
[idx]["STREET"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「地名」
[idx]["STREET_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村/地名ファイルの地名コード」
[idx]["STR_ABBR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名の略称 (例: スペイン)」
[idx]["HOUSE_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「番地-号」
[idx]["STR_SUPPL1"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名 2」
[idx]["STR_SUPPL2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名 3」
[idx]["LOCATION"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「地名 5」
[idx]["BUILDING"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「旧: 建物 (番号または略称)」
[idx]["FLOOR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「建物の階」
[idx]["ROOM_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「部屋/アパート番号」
[idx]["COUNTRY"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「国コード」
[idx]["LANGU"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「言語キー」
[idx]["REGION"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地域 (都道府県)」
[idx]["SORT1"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「検索条件 1」
[idx]["SORT2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「検索条件 2」
[idx]["TIME_ZONE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「アドレスタイムゾーン」
[idx]["TAXJURCODE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「税管轄コード」
[idx]["ADR_NOTES"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「住所注記」
[idx]["COMM_TYPE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「通信方法 (キー) (アドレス管理)」
[idx]["TEL1_NUMBR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「第一電話番号: ダイヤルコード + 番号」
[idx]["TEL1_EXT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「第 1 電話番号: 内線」
[idx]["FAX_NUMBER"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「第一 FAX 番号: ダイヤルコード + 番号」
[idx]["FAX_EXTENS"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「第一 FAX 番号: 内線」
[idx]["STREET_LNG"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「地名」
[idx]["DISTRCT_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村/地名ファイルの所在地コード」
[idx]["CHCKSTATUS"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村ファイルテストステータス」
[idx]["PBOXCIT_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村私書箱コード (市ファイル)」
[idx]["TRANSPZONE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「商品の納入区域」
[idx]["HOUSE_NO2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「番地補足」
[idx]["E_MAIL"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「電子メールアドレス」
[idx]["STR_SUPPL3"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名 4」
[idx]["TITLE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「タイトル (敬称)」
[idx]["COUNTRYISO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「ISO 国コード」
[idx]["LANGU_ISO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「ISO 639 準拠の言語」
[idx]["BUILD_LONG"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「建物 (番号またはコード)」
[idx]["REGIOGROUP"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地域構造グループ化」
[idx]["HOME_CITY"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村 (郵便用市区町村と異なる場合)」
[idx]["HOMECITYNO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「別の市区町村 (市区町村/地名ファイル)」
[idx]["PCODE1_EXT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村郵便番号の拡張子 例: 郵便番号 +4+2」
[idx]["PCODE2_EXT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱郵便番号拡張子 例: 郵便番号 +4+2」
[idx]["PCODE3_EXT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「主要得意先郵便番号拡張子 例: 郵便番号 +4+2」
[idx]["PO_W_O_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「フラグ: 郵便私書箱 (番号なし)」
[idx]["PO_BOX_REG"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱の地域 (国、都道府県、地域、...)」
[idx]["POBOX_CTRY"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱の国指定」
[idx]["PO_CTRYISO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「ISO 国コード」
[idx]["HOMEPAGE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「URI 例: ホームページ、FTP アドレス」
[idx]["DONT_USE_S"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名住所配達不可フラグ」
[idx]["DONT_USE_P"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱住所配達不可フラグ」
[idx]["HOUSE_NO3"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「番地範囲」
[idx]["LANGU_CR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「アドレスレコード登録オリジナル言語」
[idx]["LANGUCRISO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「ISO 639 準拠の言語」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getSalesdocument

Object getSalesdocument ()

販売伝票番号を取得します。

返却値
Object 販売伝票番号
getSalesdocumentin

Object getSalesdocumentin ()

販売管理伝票番号を取得します。

返却値
Object 販売管理伝票番号
getSender

Object getSender ()

論理システム - 送信者を取得します。
返却値
Object 論理システム - 送信者

論理システム - 送信者オブジェクトの構成は以下のとおりです。
論理システム - 送信者
オブジェクト
(Object)
LOG_SYSTEM 論理システム (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getTestrun

Object getTestrun ()

テスト実行を取得します。
返却値
Object テスト実行
setBehaveWhenError

void setBehaveWhenError (Object value)

エラー処理を設定します｡
パラメータ
value Object エラー処理
返却値
void
setBinaryRelationshiptype

void setBinaryRelationshiptype (Object value)

バイナリ関連タイプ (専用)を設定します｡
パラメータ
value Object バイナリ関連タイプ (専用)
返却値
void
setConvert

void setConvert (Object value)

変換: 取引先機能 + 受注伝票タイプを設定します｡
パラメータ
value Object 変換: 取引先機能 + 受注伝票タイプ
返却値
void
setIntNumberAssignment

void setIntNumberAssignment (Object value)

明細番号内部採番を設定します｡
パラメータ
value Object 明細番号内部採番
返却値
void
setSalesdocumentin

void setSalesdocumentin (Object value)

販売管理伝票番号を設定します｡
パラメータ
value Object 販売管理伝票番号
返却値
void
setStrParam

void setStrParam (String paramStr ,String paramName ,Object value)

構造型の項目に値をセットします。
パラメータ
paramStr | String | 構造名
paramName | String | 項目名
value | Object | セットする値
返却値
void
setTblParam

void setTblParam (String paramTable ,String paramName ,Object value ,int index)

テーブル型の項目に値をセットします。
パラメータ
paramTable | String | テーブル名
paramName | String | 項目名
value | Object | セットする値
index | int | レコード番号
返却値
void
setTestrun

void setTestrun (Object value)

テスト実行を設定します｡
パラメータ
value Object テスト実行
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 InternalOrderGetDetailController オブジェクト

内部指図書詳細コントローラクラス。

機能は以下の通り
  • 内部指図書詳細情報を取得します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
InternalOrderGetDetailController (String orderid ,String language)
コンストラクタ｡
InternalOrderGetDetailController (String orderid ,String language ,SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | getAllowedBusTractList () 内部指図書詳細の使用可能業務トランザクションのテーブルから値を取得します。
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
Object | getLanguage () 内部指図書詳細のステータスおよび業務トランザクションテキストの言語から値を取得します。
Object | getMasterData () 内部指図書詳細の指図のマスタデータ構造から値を取得します。
Object | getOrderid () 内部指図書詳細の指図番号から値を取得します。
Object | getSystemStatusList () 内部指図書詳細のシステムステータステーブルから値を取得します。
Object | getUserStatusList () 内部指図書詳細のユーザステータス/指図ステータステーブルから値を取得します。
void | setLanguage (String value) 内部指図書詳細のステータスおよび業務トランザクションテキストの言語に値を設定します。
void | setOrderid (String value) 内部指図書詳細の指図番号に値を設定します。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
InternalOrderGetDetailController

InternalOrderGetDetailController (String orderid ,String language)
コンストラクタ｡
パラメータ
orderid | String | 指図番号
language | String | ステータスおよび業務トランザクションテキストの言語
InternalOrderGetDetailController

InternalOrderGetDetailController (String orderid ,String language ,SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
orderid | String | 指図番号
language | String | ステータスおよび業務トランザクションテキストの言語
sapClient | SapClient | Sapクライアント
メソッドの詳細
getAllowedBusTractList

Object getAllowedBusTractList ()

内部指図書詳細の使用可能業務トランザクションのテーブルから値を取得します。
返却値
Object 使用可能業務トランザクションのテーブル

内部指図書詳細の使用可能業務トランザクション情報オブジェクトの構成は以下のとおりです。
内部指図書詳細の使用可能業務トランザクション情報
オブジェクト
(Object)
TRANS 取引 (String)
DESCRIPT テキスト (30 文字) (String)

取得した内部指図書詳細の使用可能業務トランザクション情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["TRANS"]　→　配列内のidx番目の内部指図書詳細の使用可能業務トランザクションの「取引」
[idx]["DESCRIPT"]　→　配列内のidx番目の内部指図書詳細の使用可能業務トランザクションの 「テキスト (30 文字)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getLanguage

Object getLanguage ()

内部指図書詳細のステータスおよび業務トランザクションテキストの言語から値を取得します。

返却値
Object ステータスおよび業務トランザクションテキストの言語
getMasterData

Object getMasterData ()

内部指図書詳細の指図のマスタデータ構造から値を取得します。
返却値
Object 指図のマスタデータ構造

内部指図書詳細の指図のマスタデータ構造情報オブジェクトの構成は以下のとおりです。
内部指図書詳細の指図のマスタデータ構造情報
オブジェクト
(Object)
ORDER 指図番号 (String)
ORDER_TYPE 販売伝票タイプ (String)
ORDER_NAME テキスト (String)
EXT_ORD_NO 外部指図番号 (String)
OBJECT_NO 対象番号 (String)
CO_AREA 管理領域 (String)
COMP_CODE 会社コード (String)
BUS_AREA 事業領域 (String)
PLANT プラント (String)
PROFIT_CTR 利益センタ (String)
RESPCCTR 責任原価センタ (String)
WBS_ELEM 作業詳細項目要素 (WBS 要素) (String)
WBS_ELEMENT_EXT WBS 要素 (String)
REQUEST_CCTR 申請原価センタ (String)
REQU_COMP_CODE 会社コード要求 (String)
SALES_ORD 受注伝票番号 (String)
S_ORD_ITEM 受注明細番号 (String)
TAXJURCODE 税計算管轄コード - 税管轄コード (String)
CCTR_POSTED 原価が実際に転記された原価センタ (String)
CURRENCY 購買発注通貨 (String)
CSTG_SHEET 原価計算表 (String)
OVERHEAD_KEY 間接費キー (String)
RES_ANAL_KEY 結果分析キー (String)
INTEREST_PROF プロジェクト/指図金利計算の金利プロファイル (String)
APPLICANT 申請者 (String)
APPLICANT_PHONE 申請者の電話番号 (String)
PERSON_RESP 責任者 (String)
PERSON_RESP_PHONE 責任者の電話番号 (String)
ESTIMATED_COSTS 指図の見積原価合計 (String)
APPLICATION_DATE 申請日 (String)
DEPARTMENT 部署 (String)
DATE_WORK_BEGINS 作業開始 (String)
DATE_WORK_ENDS 作業終了 (String)
WORK_PERMIT 仕事許可済フラグ (String)
PROCESSING_GROUP 処理グループ (String)
PLN_RELEASE 計画リリース日付 (String)
PLN_COMPLETION 計画完了日 (String)
PLN_CLOSE 計画終了日付 (String)
REQUEST_ORDER 申請指図 (String)
FUNC_AREA 機能領域 (String)
FUNC_AREA_LONG 機能領域 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderid

Object getOrderid ()

内部指図書詳細の指図番号から値を取得します。

返却値
Object 指図番号
getSystemStatusList

Object getSystemStatusList ()

内部指図書詳細のシステムステータステーブルから値を取得します。
返却値
Object システムステータステーブル

内部指図書詳細のシステムステータス情報オブジェクトの構成は以下のとおりです。
内部指図書詳細のシステムステータス情報
オブジェクト
(Object)
SYS_STATUS システムステータス (String)
SY_ST_TEXT オブジェクトの個別ステータス (簡略形式) (String)
SY_ST_DSCR オブジェクトステータス (String)

取得した内部指図書詳細のシステムステータス情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["SYS_STATUS"] 　→　配列内のidx番目の内部指図書詳細のシステムステータスの「システムステータス」
[idx]["SY_ST_TEXT"] 　→　配列内のidx番目の内部指図書詳細のシステムステータスの「オブジェクトの個別ステータス (簡略形式)」
[idx]["SY_ST_DSCR"] 　→　配列内のidx番目の内部指図書詳細のシステムステータスの「オブジェクトステータス」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getUserStatusList

Object getUserStatusList ()

内部指図書詳細のユーザステータス/指図ステータステーブルから値を取得します。
返却値
Object ユーザステータス/指図ステータステーブル

内部指図書詳細のユーザステータス/指図ステータス情報オブジェクトの構成は以下のとおりです。
内部指図書詳細のユーザステータス/指図ステータス情報
オブジェクト
(Object)
STAT_PROF ステータスプロファイル (String)
USR_STATUS ユーザステータス (String)
US_ST_NUMB ステータス番号 (String)
US_ST_TEXT オブジェクトの個別ステータス (簡略形式) (String)
US_ST_DSCR オブジェクトステータス (String)

取得した内部指図書詳細のユーザステータス/指図ステータス情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["STAT_PROF"] 　→　配列内のidx番目の内部指図書詳細のユーザステータス/指図ステータスの「ステータスプロファイル」
[idx]["USR_STATUS"] 　→　配列内のidx番目の内部指図書詳細のユーザステータス/指図ステータスの「ユーザステータス」
[idx]["US_ST_NUMB"] 　→　配列内のidx番目の内部指図書詳細のユーザステータス/指図ステータスの「ステータス番号」
[idx]["US_ST_TEXT"] 　→　配列内のidx番目の内部指図書詳細のユーザステータス/指図ステータスの 「オブジェクトの個別ステータス (簡略形式)」
[idx]["US_ST_DSCR"] 　→　配列内のidx番目の内部指図書詳細のユーザステータス/指図ステータスの「オブジェクトステータス」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
9： 管理会計業務系システムエラー
10： 管理会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

setLanguage

void setLanguage (String value)

内部指図書詳細のステータスおよび業務トランザクションテキストの言語に値を設定します。
パラメータ
value String ステータスおよび業務トランザクションテキストの言語
返却値
void
setOrderid

void setOrderid (String value)

内部指図書詳細の指図番号に値を設定します。
パラメータ
value String 指図番号
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 MaterialAvailabilityController オブジェクト

品目在庫確認クラス。

機能は以下の通り
  • 品目在庫を照会します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
MaterialAvailabilityController ()
コンストラクタ｡
MaterialAvailabilityController (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより品目在庫を検索します。
Object | getAvQtyPlt () プラントレベル利用可能数量を取得します。
Object | getBatch () ロットを取得します。
Object | getCheckRule () 確認規則を取得します。
Object | getCustomer () 得意先コードを取得します。
Object | getDecForRounding () 小数点位置 (その位置まで丸める)を取得します。
Object | getDecForRoundingX () 関連ユーザデータ項目の更新情報を取得します。
Object | getDialogflag () 区分 (X = 利用不可 /N = 確認なし)を取得します。
Object | getDocNumber () 伝票番号を取得します。
Object | getEndleadtme () 補充リードタイムの終了日付を取得します。
Object | getItmNumber () 明細番号を取得します。
Object | getMaterial () 品目コードを取得します。
Object | getPlant () プラントを取得します。
Object | getStgeLoc () 保管場所を取得します。
Object | getUnit () 表示数量単位を取得します。
Object | getWbsElem () WBS 要素を取得します。
Object | getWmdvexList () 出力テーブル (日付および ATP 数量)を取得します。
Object | getWmdvsxList () 入力テーブル (日付/数量)を取得します。
void | setAvQtyPlt (Object value) プラントレベル利用可能数量を設定します。
void | setBatch (Object value) ロットを設定します。
void | setCheckRule (Object value) 確認規則を設定します。
void | setCustomer (Object value) 得意先コードを設定します。
void | setDecForRounding (Object value) 小数点位置 (その位置まで丸める)を設定します。
void | setDecForRoundingX (Object value) 関連ユーザデータ項目の更新情報を設定します。
void | setDialogflag (Object value) 区分 (X = 利用不可 /N = 確認なし)を設定します。
void | setDocNumber (Object value) 伝票番号を設定します。
void | setEndleadtme (Object value) 補充リードタイムの終了日付を設定します。
void | setItmNumber (Object value) 明細番号を設定します。
void | setMaterial (Object value) 品目コードを設定します。
void | setPlant (Object value) プラントを設定します。
void | setStgeLoc (Object value) 保管場所を設定します。
void | setStockInd (Object value) 特殊在庫区分を設定します。
void | setTblParam (String paramTable ,String paramName ,Object value ,int index) テーブル型の項目に値をセットします。
void | setUnit (Object value) 表示数量単位を設定します。
void | setWbsElem (Object value) WBS 要素を設定します。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
MaterialAvailabilityController

MaterialAvailabilityController ()
コンストラクタ｡
MaterialAvailabilityController

MaterialAvailabilityController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより品目在庫を検索します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getAvQtyPlt

Object getAvQtyPlt ()

プラントレベル利用可能数量を取得します。
返却値
Object プラントレベル利用可能数量
getBatch

Object getBatch ()

ロットを取得します。
返却値
Object ロット
getCheckRule

Object getCheckRule ()

確認規則を取得します。
返却値
Object 確認規則
getCustomer

Object getCustomer ()

得意先コードを取得します。
返却値
Object 得意先コード
getDecForRounding

Object getDecForRounding ()

小数点位置 (その位置まで丸める)を取得します。
返却値
Object 小数点位置 (その位置まで丸める)
getDecForRoundingX

Object getDecForRoundingX ()

関連ユーザデータ項目の更新情報を取得します。
返却値
Object 関連ユーザデータ項目の更新情報
getDialogflag

Object getDialogflag ()

区分 (X = 利用不可 /N = 確認なし)を取得します。
返却値
Object 区分 (X = 利用不可 /N = 確認なし)
getDocNumber

Object getDocNumber ()

伝票番号を取得します。
返却値
Object 伝票番号
getEndleadtme

Object getEndleadtme ()

補充リードタイムの終了日付を取得します。
返却値
Object 補充リードタイムの終了日付
getItmNumber

Object getItmNumber ()

明細番号を取得します。
返却値
Object 明細番号
getMaterial

Object getMaterial ()

品目コードを取得します。
返却値
Object 品目コード
getPlant

Object getPlant ()

プラントを取得します。
返却値
Object プラント
getStgeLoc

Object getStgeLoc ()

保管場所を取得します。
返却値
Object 保管場所
getUnit

Object getUnit ()

表示数量単位を取得します。
返却値
Object 表示数量単位
getWbsElem

Object getWbsElem ()

WBS 要素を取得します。
返却値
Object WBS 要素
getWmdvexList

Object getWmdvexList ()

出力テーブル (日付および ATP 数量)を取得します。
返却値
Object 出力テーブル (日付および ATP 数量)

出力テーブル (日付および ATP 数量)情報オブジェクトの構成は以下のとおりです。
出力テーブル (日付および ATP 数量)情報
オブジェクト
(Object)
BDCNT 5 文字数値 NUMC (String)
REQ_DATE 所要日付 (String)
REQ_QTY 利用可能在庫確認の所要量 (String)
COM_DATE 確認日 (String)
COM_QTY 確認数量 (String)

取得した出力テーブル情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["BDCNT"]　→　配列内のidx番目の出力テーブルの「5 文字数値 NUMC」
[idx]["REQ_DATE"]　→　配列内のidx番目の出力テーブルの「所要日付」
[idx]["REQ_QTY"]　→　配列内のidx番目の出力テーブルの「利用可能在庫確認の所要量」
[idx]["COM_DATE"]　→　配列内のidx番目の出力テーブルの「確認日」
[idx]["COM_QTY"]　→　配列内のidx番目の出力テーブルの「確認数量」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getWmdvsxList

Object getWmdvsxList ()

入力テーブル (日付/数量)を取得します。
返却値
Object 入力テーブル (日付/数量)

入力テーブル (日付/数量)情報オブジェクトの構成は以下のとおりです。
入力テーブル (日付/数量)情報
オブジェクト
(Object)
REQ_DATE 所要日付 (String)
REQ_QTY 所要量 (String)
DELKZ MRP 要素区分 (String)
YLINE 内部テ−ブル処理の行索引 (String)

取得した入力テーブル情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["REQ_DATE"]　→　配列内のidx番目の出力テーブルの「所要日付」
[idx]["REQ_QTY"]　→　配列内のidx番目の出力テーブルの「所要量」
[idx]["DELKZ"]　→　配列内のidx番目の出力テーブルの「MRP 要素区分」
[idx]["YLINE"]　→　配列内のidx番目の出力テーブルの「内部テ−ブル処理の行索引」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

setAvQtyPlt

void setAvQtyPlt (Object value)

プラントレベル利用可能数量を設定します。
パラメータ
value Object プラントレベル利用可能数量
返却値
void
setBatch

void setBatch (Object value)

ロットを設定します。
パラメータ
value Object ロット
返却値
void
setCheckRule

void setCheckRule (Object value)

確認規則を設定します。
パラメータ
value Object 確認規則
返却値
void
setCustomer

void setCustomer (Object value)

得意先コードを設定します。
パラメータ
value Object 得意先コード
返却値
void
setDecForRounding

void setDecForRounding (Object value)

小数点位置 (その位置まで丸める)を設定します。
パラメータ
value Object 小数点位置 (その位置まで丸める)
返却値
void
setDecForRoundingX

void setDecForRoundingX (Object value)

関連ユーザデータ項目の更新情報を設定します。
パラメータ
value Object 関連ユーザデータ項目の更新情報
返却値
void
setDialogflag

void setDialogflag (Object value)

区分 (X = 利用不可 /N = 確認なし)を設定します。
パラメータ
value Object 区分 (X = 利用不可 /N = 確認なし)
返却値
void
setDocNumber

void setDocNumber (Object value)

伝票番号を設定します。
パラメータ
value Object 伝票番号
返却値
void
setEndleadtme

void setEndleadtme (Object value)

補充リードタイムの終了日付を設定します。
パラメータ
value Object 補充リードタイムの終了日付
返却値
void
setItmNumber

void setItmNumber (Object value)

明細番号を設定します。
パラメータ
value Object 明細番号
返却値
void
setMaterial

void setMaterial (Object value)

品目コードを設定します。
パラメータ
value Object 品目コード
返却値
void
setPlant

void setPlant (Object value)

プラントを設定します。
パラメータ
value Object プラント
返却値
void
setStgeLoc

void setStgeLoc (Object value)

保管場所を設定します。
パラメータ
value Object 保管場所
返却値
void
setStockInd

void setStockInd (Object value)

特殊在庫区分を設定します。
パラメータ
value Object 特殊在庫区分
返却値
void
setTblParam

void setTblParam (String paramTable ,String paramName ,Object value ,int index)

テーブル型の項目に値をセットします。
パラメータ
paramTable | String | テーブル名
paramName | String | 項目名
value | Object | セットする値
index | int | レコード番号
返却値
void
setUnit

void setUnit (Object value)

表示数量単位を設定します。
パラメータ
value Object 表示数量単位
返却値
void
setWbsElem

void setWbsElem (Object value)

WBS 要素を設定します。
パラメータ
value Object WBS 要素
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 MaterialGetAllController オブジェクト

品目マスタ照会クラス。

機能は以下の通り
  • 品目マスタを照会します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
MaterialGetAllController ()
コンストラクタ
メソッドの概要
Object | executeBapi () BapiControllerにより品目コードを検索します。
Object | getClientData () 品目データ (クライアントレベル)を取得します。
Object | getCompanycode () 会社コードを取得します。
Object | getDistributionchannel () 流通チャネルを取得します。
Object | getExtensionOutList () BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。
Object | getForecastParameters () 予測パラメータを取得します。
Array | getInternationArticleNumbersList () EANを取得します。
Object | getLifoValuationData () LIFO 関連品目データを取得します。
Object | getLifovaluationlevel () LIFO 評価レベルを取得します。
Object | getMaterial () 品目コードを取得します。
Array | getMaterialDescriptionList () 品目テキストを取得します。
Array | getMaterialTextList () テキスト (長)を取得します。
Object | getPlanningData () 品目マスタ/製品グループの変更伝票構造を取得します。
Object | getPlant () プラントを取得します。
Object | getPlantData () 品目データ (プラントレベル)を取得します。
Object | getProductionResourceToolData () 品目マスタの生産資源/治工具 (PRT) 項目を取得します。
Object | getSalesData () 販売データを取得します。
Object | getSalesorganisation () 販売組織を取得します。
Object | getStorageLocationData () 品目データ (保管場所レベル)を取得します。
Object | getStorageTypeData () 保管域タイプデータを取得します。
Object | getStoragelocation () 保管場所を取得します。
Object | getStoragetype () 保管域タイプを取得します。
Array | getTaxClassificationsList () 制御デ−タを取得します。
Array | getUnitSofmeasureList () 数量単位を取得します。
Object | getValuationData () 評価データを取得します。
Object | getValuationarea () 評価レベルを取得します。
Object | getValuationtype () 評価タイプを取得します。
Object | getWarehouseNumberData () 倉庫番号データを取得します。
Object | getWarehousenumber () 倉庫番号/複合倉庫を取得します。
void | setCompanycode (Object value) 会社コードを設定します。
void | setDistributionchannel (Object value) 流通チャネルを設定します。
void | setLifovaluationlevel (Object value) LIFO 評価レベルを設定します。
void | setMaterial (Object value) 品目コードを設定します。
void | setPlant (Object value) プラントを設定します。
void | setSalesorganisation (Object value) 販売組織を設定します。
void | setStoragelocation (Object value) 保管場所を設定します。
void | setStoragetype (Object value) 保管域タイプを設定します。
void | setTblParam (String tableName ,String paramName ,Object value ,int index) テーブル型の項目に値をセットします。
void | setValuationarea (Object value) 評価レベルを設定します。
void | setValuationtype (Object value) 評価タイプを設定します。
void | setWarehousenumber (Object value) 倉庫番号/複合倉庫を設定します。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
MaterialGetAllController

MaterialGetAllController ()
コンストラクタ
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより品目コードを検索します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getClientData

Object getClientData ()

品目データ (クライアントレベル)を取得します。
返却値
Object 品目データ (クライアントレベル)

品目データ (クライアントレベル)情報オブジェクトの構成は以下のとおりです。
品目データ (クライアントレベル)
オブジェクト
(Object)
MATERIAL 品目コード (String)
IND_SECTOR 産業コード (String)
MATL_TYPE 品目タイプ (String)
CREATED_ON 登録日付 (String)
CREATED_BY オブジェクト登録者名 (String)
LAST_CHNGE 最終変更日付 (String)
CHANGED_BY オブジェクトの変更者名 (String)
MAT_STATUS 品目更新完了ステータス (String)
MAINT_STAT 更新ステータス (String)
DEL_FLAG クライアントレベルでの品目削除フラグ (String)
MATL_GROUP 品目グループ (String)
OLD_MAT_NO 旧品目コード (String)
BASE_UOM 基本数量単位 (String)
BASE_UOM_ISO ISO コードでの基本数量単位 (String)
PO_UNIT 発注単位 (String)
PO_UNIT_ISO ISO コードによる発注単位 (String)
DOCUMENT 文書番号 (文書管理システムによらない) (String)
DOC_TYPE 文書タイプ (文書管理システムによらない) (String)
DOC_VERS 文書バージョン (文書管理システムによらない) (String)
DOC_FORMAT 文書のページ書式 (文書管理システムによらない) (String)
DOC_CHG_NO 文書変更番号 (文書管理システム外) (String)
PAGE_NO 文書ページ番号 (文書管理システムによらない) (String)
NO_SHEETS 文書枚数 (文書管理システムによらない) (String)
PROD_MEMO 製造/検査メモ (String)
PAGEFORMAT 製造メモのページ書式 (String)
SIZE_DIM サイズ/寸法 (String)
BASIC_MATL 主構成物質 (String)
STD_DESCR 標準テキスト (ANSI、ISO など) (String)
DSN_OFFICE 研究室/設計室 (String)
PUR_VALKEY 購買許容値キー (String)
NET_WEIGHT 正味重量 (String)
UNIT_OF_WT 重量単位 (String)
UNIT_OF_WT_ISO ISO コードでの重量単位 (String)
CONTAINER 容器条件 (String)
STOR_CONDS 保管条件 (String)
TEMP_CONDS 温度条件区分 (String)
TRANS_GRP 輸送グループ (String)
HAZ_MAT_NO 危険物コード (String)
DIVISION 製品部門 (String)
COMPETITOR 競合会社 (String)
QTY_GR_GI 数量: 印刷予定入出庫票数 (String)
PROC_RULE 調達規則 (String)
SUP_SOURCE 供給元 (String)
SEASON 季節カテゴリ (String)
LABEL_TYPE ラベルタイプ (String)
LABEL_FORM ラベル書式 (String)
PROD_HIER 品目階層 (String)
CAD_ID CAD 区分 (String)
ALLOWED_WT 許容梱包重量 (String)
PACK_WT_UN 重量単位 (許容梱包重量) (String)
PACK_WT_UN_ISO ISO コードでの重量単位 (許容梱包重量) (String)
ALLWD_VOL 許容梱包容積 (String)
PACK_VO_UN 容積単位 (許容梱包容積) (String)
PACK_VO_UN_ISO ISO コードでの容積単位 (許容梱包容積) (String)
WT_TOL_LT 荷役単位の重量超過許容量 (String)
VOL_TOL_LT 荷役単位の容積超過許容量 (String)
VAR_ORD_UN 可変購買発注単位有効 (String)
CONFIGURED 選定可能品目 (String)
BATCH_MGMT ロット管理所要量区分 (String)
SH_MAT_TYP 梱包材タイプ (String)
FILL_LEVEL 最大レベル (容積別) (String)
STACK_FACT 山積係数 (String)
MAT_GRP_SM 品目グループ: 梱包材 (String)
AUTHORITYGROUP 権限グループ (String)
QM_PROCMNT 調達における品質管理有効 (String)
CATPROFILE カタログプロファイル (String)
MINREMLIFE 最低有効期間残 (String)
SHELF_LIFE 総有効期間 (String)
STOR_PCT 残存有効期間割合 % (String)
CONF_MATL プラント共通選定可能品目 (String)
CO_PRODUCT 区分: 連産品としても使用可能な品目 (String)
PR_REF_MAT 価格設定参照品目 (String)
PUR_STATUS プラント共通品目ステータス (String)
SAL_STATUS 流通チェーン間品目ステータス (String)
PVALIDFROM プラント共通品目のステータス有効開始日付 (String)
SVALIDFROM 流通チェーン間品目ステータスの有効開始日付 (String)
ENVT_RLVT 区分: 環境関連 (String)
PROD_ALLOC 製品割当決定手順 (String)
QUAL_DIK 無償納入による割引対象品目 (String)
MANU_MAT 製造者製品コード (String)
MFR_NO 製造者番号 (String)
INV_MAT_NO 会社固有 (内部) 在庫管理品目コード (String)
MANUF_PROF 製造者製品プロファイル (String)
HAZMATPROF 危険物インジケータプロファイル (String)
HIGH_VISC 区分: 高粘性 (String)
LOOSEORLIQ 区分: バルク/液体 (String)
CLOSED_BOX 完了した梱包材 (String)
APPD_B_REC 区分: バッチ製造記録の承認必須 (String)
MATCMPLLVL 品目完了レベル (String)
PAR_EFF 有効性パラメータへの値割当/変更番号よりも優先 (String)
ROUND_UP_RULE_EXPIRATION_DATE 有効期間期限日 計算の丸め規則 (String)
PERIOD_IND_EXPIRATION_DATE 有効期間期限日 の期間区分 (String)
PROD_COMPOSITION_ON_PACKAGING 区分: 梱包材にプリントされた生産構造 (String)
ITEM_CAT 一般明細カテゴリグループ (String)
HAZ_MAT_NO_EXTERNAL 項目 HAZ_MAT_NO の 品目コード (長) (今後のリリースで開発) (String)
HAZ_MAT_NO_GUID 項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発) (String)
HAZ_MAT_NO_VERSION 項目 HAZ_MAT_NO の バージョン番号 (今後のリリースで開発) (String)
INV_MAT_NO_EXTERNAL 項目 INV_MAT_NO の 品目コード (長) (今後のリリースで開発) (String)
INV_MAT_NO_GUID 項目 INV_MAT_NO の外部 GUID (今後のリリースで開発) (String)
INV_MAT_NO_VERSION 項目 INV_MAT_NO の バージョン番号 (今後のリリースで開発) (String)
MATERIAL_FIXED ロックされている品目 (String)
CM_RELEVANCE_FLAG 構成管理関連 (String)
SLED_BBD 有効期限 (String)
GTIN_VARIANT グローバルトレード明細番号バリアント (String)
SERIALIZATION_LEVEL シリアル番号の指定レベル (String)
PL_REF_MAT 梱包方法が同じ品目の参照品目 (String)
EXTMATLGRP 外部品目グループ (String)
UOMUSAGE 使用数量単位 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getCompanycode

Object getCompanycode ()

会社コードを取得します。
返却値
Object 会社コード
getDistributionchannel

Object getDistributionchannel ()

流通チャネルを取得します。
返却値
Object 流通チャネル
getExtensionOutList

Object getExtensionOutList ()

BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。
返却値
Object BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造

BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報オブジェクト の構成は以下のとおりです。
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報
オブジェクト
(Object)
STRUCTURE BAPI テーブル拡張の構造名 (String)
VALUEPART1 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART2 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART3 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART4 BAPI 拡張パラメータのデータ部分 (String)

取得したBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報 オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["STRUCTURE"]　→　配列内のidx番目のBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の「BAPI テーブル拡張の構造名」
[idx]["VALUEPART1"]　→　配列内のidx番目のBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART2"]　→　配列内のidx番目のBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART3"]　→　配列内のidx番目のBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART4"]　→　配列内のidx番目のBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の「BAPI 拡張パラメータのデータ部分」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getForecastParameters

Object getForecastParameters ()

予測パラメータを取得します。
返却値
Object 予測パラメータ

予測パラメータ情報オブジェクトの構成は以下のとおりです。
予測パラメータ
オブジェクト
(Object)
PLANT プラント (String)
FORE_PROF 需要予測プロファイル (String)
MODEL_SI モデル選択区分 (String)
MODEL_SP モデル選択方式 (String)
PARAM_OPT パラメータ最適化用の区分 (String)
OPTIM_LEV 最適化レベル (String)
INITIALIZE 初期化区分 (String)
FORE_MODEL 予測モデル (String)
ALPHA_FACT アルファ係数使用による基本値の平滑化 (String)
BETA_FACT ベータ係数による傾向値平準化 (String)
GAMMA_FACT ガンマ係数使用の平滑化のための 季節指数 (String)
DELTA_FACT デルタ係数使用による MAD (絶対平均偏差) 平準化 (String)
TRACKLIMIT 警告限界 (String)
FORE_DATE 最終需要予測日 (String)
HIST_VALS 履歴値の数 (String)
INIT_PDS 初期化で使用する履歴値の数 (String)
SEASON_PDS 季節周期ごとの期間数 (String)
EXPOST_PDS 事後的需要予測に含む履歴値の数 (String)
FORE_PDS 需要予測期間 (String)
FIXED_PDS 固定期間 (String)
BASIC_VALUE 基準値 (String)
BASIC_VALUE1 第二指図の基準値 (String)
BASIC_VALUE2 第二指図の基準値 (String)
BASIC_VALUE_PP 前期間の基準値 (String)
BASIC_VALUE_PP1 前期間における第二指図の基準値 (String)
BASIC_VALUE_PP2 前期間における第二指図の基準値 (String)
TREND_VALUE 傾向値 (String)
TREND_VALUE_PP 前期間の傾向値 (String)
MEAN_ABSOL_DEV 絶対平均偏差 (MAD) (String)
MEAN_ABSOL_DEV_PP 前期間の平均絶対偏差 (String)
ERROR_TOTAL エラー合計 (String)
ERROR_TOTAL_PP 前期間のエラー合計 (String)
WTG_GROUP 加重グループ (String)
COEFF_THEIL タイル係数 (String)
EXCEPT_LIST 例外メッセージバー (String)
FOREC_FLOW_CONT 予測フロー管理 (String)
PERIOD_IND 期間区分 (String)
FY_VARIANT 会計年度バリアント (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInternationArticleNumbersList

Array getInternationArticleNumbersList ()

EANを取得します。
返却値
Array EAN

EAN情報オブジェクトの構成は以下のとおりです。
EAN情報
オブジェクト
(Object)
UNIT 表示数量単位 (String)
UNIT_ISO ISO コードでの表示数量単位 (String)
EAN_UPC 国際商品コード (EAN/UPC) (String)
EAN_CAT 国際商品コード (EAN) のカテゴリ (String)
MAIN_EAN 区分: 主要 EAN (String)

取得したEAN情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["UNIT"]　→　配列内のidx番目のEANの「表示数量単位」
[idx]["UNIT_ISO"]　→　配列内のidx番目のEANの「ISO コードでの表示数量単位」
[idx]["EAN_UPC"]　→　配列内のidx番目のEANの「国際商品コード (EAN/UPC)」
[idx]["EAN_CAT"]　→　配列内のidx番目のEANの「国際商品コード (EAN) のカテゴリ」
[idx]["MAIN_EAN"]　→　配列内のidx番目のEANの「区分: 主要 EAN」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getLifoValuationData

Object getLifoValuationData ()

LIFO 関連品目データを取得します。
返却値
Object LIFO 関連品目データ

LIFO 関連品目データ情報オブジェクトの構成は以下のとおりです。
LIFO 関連品目データ
オブジェクト
(Object)
LIFO_VALUATION_LEVEL LIFO 評価レベル (String)
POOLNUMBER LIFO 評価でのプール番号 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getLifovaluationlevel

Object getLifovaluationlevel ()

LIFO 評価レベルを取得します。
返却値
Object LIFO 評価レベル
getMaterial

Object getMaterial ()

品目コードを取得します。
返却値
Object 品目コード
getMaterialDescriptionList

Array getMaterialDescriptionList ()

品目テキストを取得します。
返却値
Array 品目テキスト

品目テキスト情報オブジェクトの構成は以下のとおりです。
品目テキスト情報
オブジェクト
(Object)
LANGU 言語キー (String)
LANGU_ISO ISO 639 準拠の言語 (String)
MATL_DESC 品目テキスト (String)

取得した品目テキスト情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["LANGU"]　→　配列内のidx番目の品目テキストの「言語キー」
[idx]["LANGU_ISO"]　→　配列内のidx番目の品目テキストの「ISO 639 準拠の言語」
[idx]["MATL_DESC"]　→　配列内のidx番目の品目テキストの「品目テキスト」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getMaterialTextList

Array getMaterialTextList ()

テキスト (長)を取得します。
返却値
Array テキスト (長)

テキスト (長)情報オブジェクトの構成は以下のとおりです。
テキスト (長)情報
オブジェクト
(Object)
APPLOBJECT テキスト : アプリケーションオブジェクト (String)
TEXT_NAME 名称 (String)
TEXT_ID テキスト ID (String)
LANGU 言語キー (String)
LANGU_ISO ISO 639 準拠の言語 (String)
FORMAT_COL タグ列 (String)
TEXT_LINE テキスト行 (String)

取得したテキスト (長)情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["APPLOBJECT"]　→　配列内のidx番目のテキスト (長)の 「テキスト: アプリケーションオブジェクト」
[idx]["TEXT_NAME"]　→　配列内のidx番目のテキスト (長)の「名称」
[idx]["TEXT_ID"]　→　配列内のidx番目のテキスト (長)の「テキスト ID」
[idx]["LANGU"]　→　配列内のidx番目のテキスト (長)の「言語キー」
[idx]["LANGU_ISO"]　→　配列内のidx番目のテキスト (長)の「ISO 639 準拠の言語」
[idx]["FORMAT_COL"]　→　配列内のidx番目のテキスト (長)の「タグ列」
[idx]["TEXT_LINE"]　→　配列内のidx番目のテキスト (長)の「テキスト行」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPlanningData

Object getPlanningData ()

品目マスタ/製品グループの変更伝票構造を取得します。
返却値
Object 品目マスタ/製品グループの変更伝票構造

品目マスタ/製品グループの変更伝票構造情報オブジェクトの構成は以下のとおりです。
品目マスタ/製品グループの変更伝票構造
オブジェクト
(Object)
PLANT プラント (String)
PLNG_MATL 計画品目 (String)
PLNG_PLANT 計画プラント (String)
CONVFACTOR 計画品目用変換係数 (String)
PLNG_MATL_EXTERNAL 項目 PLNG_MATL の品目コード (長) (今後のリリースで開発) (String)
PLNG_MATL_GUID 項目 PLNG_MATL の外部 GUID (今後のリリースで開発) (String)
PLNG_MATL_VERSION 項目 PLNG_MATL の バージョン番号 (今後のリリースで開発) (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPlant

Object getPlant ()

プラントを取得します。
返却値
Object プラント
getPlantData

Object getPlantData ()

品目データ (プラントレベル)を取得します。
返却値
Object 品目データ (プラントレベル)

品目データ (プラントレベル)情報オブジェクトの構成は以下のとおりです。
品目データ (プラントレベル)
オブジェクト
(Object)
PLANT プラント (String)
MAINT_STAT 更新ステータス (String)
DEL_FLAG プラントレベルでの品目削除フラグ (String)
ABC_ID ABC 区分 (String)
CRIT_PART 区分: 重要品目 (String)
PUR_GROUP 購買グループ (String)
ISSUE_UNIT 出庫単位 (String)
ISSUE_UNIT_ISO ISO コードでの出庫単位 (String)
MRPPROFILE 品目: MRP プロファイル (String)
MRP_TYPE MRP タイプ (String)
MRP_CTRLER MRP 管理者 (String)
PLND_DELRY 予定納入時間 (単位: 日) (String)
GR_PR_TIME 入庫処理日数 (String)
PERIOD_IND 期間区分 (String)
ASSY_SCRAP 組立不良率 (String)
LOTSIZEKEY ロットサイズ (品目計画) (String)
PROC_TYPE 調達タイプ (String)
SPPROCTYPE 特殊調達タイプ (String)
REORDER_PT 発注点 (String)
SAFETY_STK 安全在庫 (String)
MINLOTSIZE 最小ロットサイズ (String)
MAXLOTSIZE 最大ロットサイズ (String)
FIXED_LOT 固定ロットサイズ (String)
ROUND_VAL 購買発注数量の丸め数量 (String)
MAX_STOCK 最大在庫レベル (String)
ORD_COSTS 発注原価 (BAPI インタフェース) (String)
DEP_REQ_ID 個別所要量と包括所要量に対する従属所要量区分 (String)
STOR_COSTS 保管経費区分 (String)
ALT_BOM_ID 代替 BOM 選択の方法 (String)
DISCONTINU 打切区分 (String)
EFF_O_DAY 有効終了日 (String)
FOLLOW_UP フォローアップ品目 (String)
GRP_REQMTS 区分: 所要量グループ化 (String)
MIXED_MRP 二重 MRP 区分 (String)
SM_KEY 日程計画余裕キー (String)
BACKFLUSH 区分: バックフラッシュ (String)
PRODUCTION_SCHEDULER 製造計画担当 (String)
PROC_TIME 処理時間 (String)
SETUPTIME 段取時間と片付け時間 (String)
INTEROP 移動時間 (String)
BASE_QTY 基本数量 (String)
INHSEPRODT 内製日数 (String)
STGEPERIOD 最長保管期間 (String)
STGE_PD_UN 最長保管期間の単位 (String)
STGE_PD_UN_ISO ISO コードでの最長保管期間単位 (String)
OVER_TOL 過剰納入許容範囲リミット (String)
UNLIMITED 区分: 無制限過剰納入可能 (String)
UNDER_TOL 不足納入許容範囲リミット (String)
REPLENTIME 補充リードタイム合計 (稼動日数) (String)
REPLACE_PT 取替部品 (String)
IND_POST_TO_INSP_STOCK 品質検査中在庫への転記 (String)
CTRL_KEY 調達における品質管理の管理キー (String)
DOC_REQD 文書必須フラグ (String)
LOADINGGRP 積載グループ (String)
BATCH_MGMT ロット管理所要量区分 (String)
QUOTAUSAGE 供給量割当の使用 (String)
SERV_LEVEL サービスレベル (String)
SPLIT_IND 分割区分 (String)
AVAILCHECK 利用可能在庫確認の確認グループ (String)
FY_VARIANT 会計年度バリアント (String)
CORR_FACT 区分: 修正係数を需要予測値計算に使用 (String)
SETUP_TIME 出荷準備時間 (String)
BASE_QTY_PLAN 出荷の能力計画のための基本数量 (String)
SHIP_PROC_TIME 出荷処理時間 (String)
SUP_SOURCE 供給元 (String)
AUTO_P_ORD 区分: 購買発注自動生成 (String)
SOURCELIST 区分: 供給元一覧必須 (String)
COMM_CODE 貿易: 統計品目コード/輸入コード番号 (String)
COUNTRYORI 品目の原産国 (String)
COUNTRYORI_ISO ISO コードでの品目原産国 (String)
REGIONORIG 品目の原産地 (非特恵対象地区の原産) (String)
COMM_CO_UN 物品コード (貿易) の数量単位 (String)
COMM_CO_UN_ISO ISO コードによる物品コード (貿易管理) の数量単位 (String)
EXPIMPGRP 輸出/輸入品目グループ (String)
PROFIT_CTR 利益センタ (String)
PPC_PL_CAL PPC 計画カレンダ (String)
REP_MANUF 区分: 繰返生産許可 (String)
PL_TI_FNCE 計画タイムフェンス (String)
CONSUMMODE 消費モード (String)
BWD_CONS 消費期間: 後方 (String)
FWD_CONS 消費期間: 前方 (String)
VERSION_FLAG バージョン区分 (String)
ALTERNATIVE_BOM 代替 BOM (String)
BOM_USAGE BOM 用途 (String)
PLANLISTGRP タスクリストグループのキー (String)
PLANLISTCNT グループカウンタ (String)
LOT_SIZE 原価計算ロットサイズ (String)
SPECPROCTY 原価計算の特殊調達タイプ (String)
PROD_UNIT 製造単位 (String)
PROD_UNIT_ISO 製造単位 (ISO コード) (String)
ISS_ST_LOC 出庫保管場所 (String)
MRP_GROUP MRP グループ (String)
COMP_SCRAP 構成品目不良率 (String)
CERT_TYPE 証明書タイプ (String)
CYCLE_TIME タクトタイム (String)
INSP_SETUP_FLAG 品目/プラントに QM 検査データ設定 (String)
COVPROFILE 在庫日数プロファイル (String)
CC_PH_INV 循環棚卸の実地棚卸区分 (String)
VARIANCE_KEY 差異キー (String)
SERNO_PROF シリアル番号プロファイル (String)
PS_CONF_MAT 選定可能品目 (String)
REPMANPROF 繰返生産プロファイル (String)
NEG_STOCKS プラントにおけるマイナス在庫許可 (String)
QM_RGMTS 仕入先の必須 QM システム (String)
PLNG_CYCLE 計画サイクル (String)
ROUND_PROF 丸めプロファイル (String)
REFMATCONS 消費参照品目 (String)
REFPLTCONS 消費参照プラント (String)
D_TO_REF_M 消費データ参照の有効終了日 (String)
MULT_REF_M 消費データ参照品目の乗数 (String)
AUTO_RESET 予測モデル自動リセット (String)
PREF_STAT_FLAG 区分: 特恵関税 - 輸出/輸入 (String)
EX_CERT_ID 法令管理: 認定書区分 (String)
EX_CERT_NO_NEW 非該当証明書番号 - 法令管理 (String)
EX_CERT_DT 非該当証明書発行日 (String)
DECL_STAT_FLAG 区分: 仕入先申告あり (String)
MILIT_ID ID: 武器 (String)
INSP_INT 次回再検査までの間隔 (String)
CO_PRODUCT 区分: 連産品としても使用可能な品目 (String)
PLAN_STRGP 計画方針グループ (String)
SLOC_EXPRC 外部調達の初期保管場所 (String)
BULK_MAT 区分: バルク品目 (String)
CC_FIXED 循環棚卸区分固定 (String)
DETERM_GRP 在庫決定グループ (String)
QM_AUTHGRP QM における活動の品目権限グループ (String)
TASK_LIST_TYPE タスクリストタイプ (String)
PUR_STATUS プラント特有品目ステータス (String)
PRODPROF 製造計画プロファイル (String)
SAFTY_T_ID 安全時間区分（安全リードタイムあり/なし) (String)
SAFETYTIME 安全時間 (稼動日数) (String)
PLORD_CTRL アクション管理: 計画手配処理 (String)
BATCHENTRY 製造/プロセス指図でのロット入力設定 (String)
PVALIDFROM プラント品目ステータス有効期間開始日 (String)
MATFRGTGRP 品目運賃グループ (String)
PRODVERSCS 原価計算を行う製造バージョン (String)
MAT_CFOP 品目 CFOP カテゴリ (String)
EU_LIST_NO CAP: CAP 製品一覧番号 (String)
EU_MAT_GRP EEC 農産物政策: CAP 生産品グループ - 貿易 (String)
CAS_NO CAS 番号： 薬事品目 - 貿易 (String)
PRODCOM_NO 生産統計: 貿易における PRODCOM コード (String)
CTRL_CODE 貿易: 消費税の管理コード (String)
JIT_RELVT 区分: JIT 納入日程の関連明細 (String)
MAT_GRP_TRANS 段取替えマトリクスに対する品目のグループ (String)
HANDLG_GRP ワークロード計算のロジスティクス処理グループ (String)
SUPPLY_AREA 品目マスタレコードで提案される供給場所 (String)
FAIR_SHARE_RULE 均等配賦ルール (String)
PUSH_DISTRIB 区分: プッシュ配賦 (String)
DEPLOY_HORIZ 供給分配期間の日数 (String)
MIN_LOT_SIZE 需要と供給を一致させるための最小ロットサイズ (String)
MAX_LOT_SIZE 需要と供給を一致させるための最大ロットサイズ (String)
FIX_LOT_SIZE 需要供給の一致に対する固定ロットサイズ (String)
LOT_INCREMENT 需要と供給を一致させるためのロットサイズ増分 (String)
PROD_CONV_TYPE 生産値の変換タイプ (String)
DISTR_PROF サイトの商品の物流プロファイル (String)
PERIOD_PROFILE_SAFETY_TIME 安全時間の期間プロファイル (String)
FXD_PRICE 固定価格連産品 (String)
AVAIL_CHECK_ALL_PROJ_SEGMENTS プロジェクト間品目区分 (String)
OVERALLPRF 指図変更管理の全体プロファイル (String)
MRP_RELEVANCY_DEP_REQUIREMENTS 従属所要量と MRP の関連性 (String)
MRP_AREA_EXISTS 区分: MRP エリア登録済 (String)
MIN_SAFETY_STK 最小安全在庫 (String)
NO_COSTING 原価計算なし (String)
UNIT_GROUP 数量単位グループ (String)
FOLLOW_UP_EXTERNAL 項目 FOLLOW_UP の 品目コード (長) (今後のリリースで開発) (String)
FOLLOW_UP_GUID 項目 FOLLOW_UP の外部 GUID (今後のリリースで開発) (String)
FOLLOW_UP_VERSION 項目 FOLLOW_UP の バージョン番号 (今後のリリースで開発) (String)
REFMATCONS_EXTERNAL 項目 REFMATCONS の 品目コード (長) (今後のリリースで開発) (String)
REFMATCONS_GUID 項目 REFMATCONS の外部 GUID (今後のリリースで開発) (String)
REFMATCONS_VERSION 項目 REFMATCONS の バージョン番号 (今後のリリースで開発) (String)
ROTATION_DATE 項目 REFMATCONS の バージョン番号 (今後のリリースで開発) (String)
ORIGINAL_BATCH_FLAG 元ロット管理区分 (String)
ORIGINAL_BATCH_REF_MATERIAL 元ロットの参照品目 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getProductionResourceToolData

Object getProductionResourceToolData ()

品目マスタの生産資源/治工具 (PRT) 項目を取得します。
返却値
Object 品目マスタの生産資源/治工具 (PRT) 項目

品目マスタの生産資源/治工具 (PRT) 項目情報オブジェクトの構成は以下のとおりです。
品目データ (クライアントレベル)
オブジェクト
(Object)
PLANT プラント (String)
CREATE_LOAD_RECS 区分: 生産資源/治工具の負荷レコード登録 (String)
CTRL_KEY 生産資源/治工具管理の管理キー (String)
CTRL_KEY_NO_CHG 管理キーは変更できません (String)
GRP_KEY_1 生産資源/治工具のグループキー 1 (String)
GRP_KEY_2 生産資源/治工具のグループキー 2 (String)
PRT_USAGE 生産資源/治工具用途 (String)
STD_TEXT_KEY 生産資源/治工具の標準テキストキー (String)
REF_KEY_NO_CHG 参照キーは変更できません (String)
START_REF_DATE 生産資源/治工具使用開始の参照日付 (String)
ST_REF_DATE_NO_CHG 開始参照日付は変更できません (String)
START_OFFSET 生産資源/治工具使用の開始オフセット (String)
START_OFFSET_UNIT 生産資源/治工具使用開始の オフセット単位 (String)
START_OFFSET_UNIT_ISO PRT 用途開始決定の 間隔時間単位 (ISO) (String)
START_OFFSET_NO_CHG 開始オフセットは変更できません (String)
END_REF_DATE 生産資源/治工具使用終了日の参照日付 (String)
END_REF_DATE_NO_CHG 終了参照日付は変更できません (String)
END_OFFSET 生産資源/治工具用途の終了オフセット (String)
END_OFFSET_UNIT 生産資源/治工具使用終了 オフセット単位 (String)
END_OFFSET_UNIT_ISO PRT 用途終了決定の 間隔時間単位 (ISO) (String)
END_OFFSET_NO_CHG 終了オフセットは変更できません (String)
FORMULA_TOT_QTY 生産資源/治工具の合計数量 の計算式 (String)
FORMULA_TOT_QTY_NO_CHG 合計数量の計算式は 変更できません (String)
FORMULA_TOT_USAGE 生産資源/治工具の総用途値 の計算式 (String)
FORMULA_TOT_USAGE_NO_CHG すべての用途値を 計算する計算式は変更できません (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getSalesData

Object getSalesData ()

販売データを取得します。
返却値
Object 販売データ

販売データ情報オブジェクトの構成は以下のとおりです。
販売データ
オブジェクト
(Object)
SALES_ORG 販売組織 (String)
DISTR_CHAN 流通チャネル (String)
DEL_FLAG 区分: 流通チャネルレベルでの 品目削除フラグ (String)
MATL_STATS 品目統計グループ (String)
REBATE_GRP 取引量リベートグループ (String)
COMM_GROUP 手数料グループ (String)
CASH_DISC 現金値引区分 (String)
SAL_STATUS 販売ビューからの品目ステータス (String)
VALID_FROM 流通チェーン別品目ステータスの 有効期間開始日 (String)
MIN_ORDER 基本数量単位での最小受注数量 (String)
MIN_DELY 納品書処理時の最小納入数量 (String)
MIN_MTO 受注製造品最少受注数量 (String)
DELY_UNIT 出荷単位 (String)
DELY_UOM 出荷数量単位 (String)
DELY_UOM_ISO ISO コードでの出荷単位の 数量単位 (String)
SALES_UNIT 販売単位 (String)
SALES_UNIT_ISO ISO コードによる販売単位 (String)
ITEM_CAT 品目マスタの明細カテゴリグループ (String)
DELYG_PLNT 出荷プラント (String)
PROD_HIER 品目階層 (String)
PR_REF_MAT 価格設定参照品目 (String)
MAT_PR_GRP 品目価格設定グループ (String)
ACCT_ASSGT 品目の勘定設定グループ (String)
MATL_GRP_1 品目グループ 1 (String)
MATL_GRP_2 品目グループ 2 (String)
MATL_GRP_3 品目グループ 3 (String)
MATL_GRP_4 品目グループ 4 (String)
MATL_GRP_5 品目グループ 5 (String)
PROD_ATT_1 ID: 製品属性 1 (String)
PROD_ATT_2 品目属性 2 用 ID (String)
PROD_ATT_3 品目属性 3 用 ID (String)
PROD_ATT_4 品目属性 4 用 ID (String)
PROD_ATT_5 品目属性 5 用 ID (String)
PROD_ATT_6 品目属性 6 の ID (String)
PROD_ATT_7 品目属性 7 用 ID (String)
PROD_ATT_8 品目属性 8 用 ID (String)
PROD_ATT_9 品目属性 9 (String)
PROD_ATT10 品目属性 10 用 ID (String)
ROUND_PROF 丸めプロファイル (String)
VAR_SALES_UN 可変販売単位の使用不可 (String)
UNIT_GROUP 数量単位グループ (String)
PR_REF_MAT_EXTERNAL 項目 PR_REF_MAT の 品目コード (長) (今後のリリースで開発) (String)
PR_REF_MAT_GUID 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発) (String)
PR_REF_MAT_VERSION 項目 PR_REF_MAT の バージョン番号 (今後のリリースで開発) (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getSalesorganisation

Object getSalesorganisation ()

販売組織を取得します。
返却値
Object 販売組織
getStorageLocationData

Object getStorageLocationData ()

品目データ (保管場所レベル)を取得します。
返却値
Object 品目データ (保管場所レベル)

品目データ (保管場所レベル)情報オブジェクトの構成は以下のとおりです。
品目データ (保管場所レベル)
オブジェクト
(Object)
PLANT プラント (String)
STGE_LOC 保管場所 (String)
MAINT_STAT 更新ステータス (String)
DEL_FLAG 保管場所レベルでの品目削除フラグ (String)
FISC_YEAR 当会計年度 (String)
CURR_PERIOD 当期 (転記期間) (String)
MRP_IND 保管場所 MRP 区分 (String)
SPEC_PROC 保管場所レベルでの特殊調達タイプ (String)
REORDER_PT 保管場所 MRP に対する発注点 (String)
REPL_QTY 保管場所 MRP に対する補充数量 (String)
STGE_BIN 棚番 (String)
PICKG_AREA 簡易倉庫管理のピッキングエリア (String)
INV_CORR_FAC 在庫修正係数 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getStorageTypeData

Object getStorageTypeData ()

保管域タイプデータを取得します。
返却値
Object 保管域タイプデータ

保管域タイプデータ情報オブジェクトの構成は以下のとおりです。
保管域タイプデータ
オブジェクト
(Object)
WHSE_NO 倉庫番号/複合倉庫 (String)
STGE_TYPE 保管域タイプ (String)
DEL_FLAG 保管タイプに該当する 全品目データ削除フラグ (String)
STGE_BIN 棚番 (String)
MAX_SB_QTY 最大棚番在庫数量 (String)
MIN_SB_QTY 最小棚番在庫数量 (String)
CTRL_QTY 管理数量 (String)
REPLEN_QTY 補充数量 (String)
PICK_AREA ピッキングエリア (String)
ROUND_QTY 丸め数量 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getStoragelocation

Object getStoragelocation ()

保管場所を取得します。
返却値
Object 保管場所
getStoragetype

Object getStoragetype ()

保管域タイプを取得します。
返却値
Object 保管域タイプ
getTaxClassificationsList

Array getTaxClassificationsList ()

制御デ−タを取得します。
返却値
Array 制御デ−タ

制御デ−タ情報オブジェクトの構成は以下のとおりです。
制御デ−タ情報
オブジェクト
(Object)
DEPCOUNTRY 出荷国 (商品発送国) (String)
DEPCOUNTRY_ISO 出荷国の ISO コード (String)
TAX_TYPE_1 税カテゴリ (消費税等) (String)
TAXCLASS_1 品目の税分類 (String)

取得した制御デ−タ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["DEPCOUNTRY"]　→　配列内のidx番目の制御デ−タの「出荷国 (商品発送国)」
[idx]["DEPCOUNTRY_ISO"]　→　配列内のidx番目の制御デ−タの「出荷国の ISO コード」
[idx]["TAX_TYPE_1"]　→　配列内のidx番目の制御デ−タの「税カテゴリ (消費税等)」
[idx]["TAXCLASS_1"]　→　配列内のidx番目の制御デ−タの「品目の税分類」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getUnitSofmeasureList

Array getUnitSofmeasureList ()

数量単位を取得します。
返却値
Array 数量単位

数量単位情報オブジェクトの構成は以下のとおりです。
数量単位情報
オブジェクト
(Object)
ALT_UNIT 在庫保管単位の代替数量単位 (String)
ALT_UNIT_ISO ISO コードによる 在庫単位の代替数量単位 (String)
NUMERATOR 基本数量単位への換算分子 (String)
DENOMINATR 分母: 基本数量単位へ変換する場合 (String)
EAN_UPC 国際商品コード (EAN/UPC) (String)
EAN_CAT 国際商品コード (EAN) のカテゴリ (String)
LENGTH 長さ (String)
WIDTH 幅 (String)
HEIGHT 高さ (String)
UNIT_DIM 寸法単位 (長さ/幅/高さ) (String)
UNIT_DIM_ISO ISO コードでの 長さ、幅、高さの単位 (String)
VOLUME 容積 (String)
VOLUMEUNIT 容積単位 (String)
VOLUMEUNIT_ISO ISO コードでの容積単位 (String)
GROSS_WT 総重量 (String)
UNIT_OF_WT 重量単位 (String)
UNIT_OF_WT_ISO ISO コードでの重量単位 (String)
SUB_UOM 梱包階層の下位レベル数量単位 (String)
SUB_UOM_ISO 下位レベル数量単位 (ISO コード) (String)
INTERNAL_CHAR 内部特性 (String)
UOMSORTNUMBER 数量単位ソート番号 (String)
LEADINGUOM 主要ロット特定数量単位 (String)
VALUEDUOM ロット特定数量単位での評価 (String)
CHAR_UNIT 特性の数量単位 (String)
CHAR_UNIT_ISO 下位レベル数量単位 (ISO コード) (String)
GTIN_VARIANT グローバルトレード明細番号 バリアント (String)
NET_WEIGHT 正味重量 (String)
ME_ANZ_SUB 下位レベル数量単位数 (String)

取得した数量単位情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ALT_UNIT"]　→　配列内のidx番目の数量単位の「在庫保管単位の代替数量単位」
[idx]["ALT_UNIT_ISO"]　→　配列内のidx番目の数量単位の 「ISO コードによる在庫単位の代替数量単位」
[idx]["NUMERATOR"]　→　配列内のidx番目の数量単位の「基本数量単位への換算分子」
[idx]["DENOMINATR"]　→　配列内のidx番目の数量単位の「分母: 基本数量単位へ変換する場合」
[idx]["EAN_UPC"]　→　配列内のidx番目の数量単位の「国際商品コード (EAN/UPC)」
[idx]["EAN_CAT"]　→　配列内のidx番目の数量単位の「国際商品コード (EAN) のカテゴリ」
[idx]["LENGTH"]　→　配列内のidx番目の数量単位の「長さ」
[idx]["WIDTH"]　→　配列内のidx番目の数量単位の「幅」
[idx]["HEIGHT"]　→　配列内のidx番目の数量単位の「高さ」
[idx]["UNIT_DIM"]　→　配列内のidx番目の数量単位の「寸法単位 (長さ/幅/高さ)」
[idx]["UNIT_DIM_ISO"]　→　配列内のidx番目の数量単位の 「ISO コードでの長さ、幅、高さの単位」
[idx]["VOLUME"]　→　配列内のidx番目の数量単位の「容積」
[idx]["VOLUMEUNIT"]　→　配列内のidx番目の数量単位の「容積単位」
[idx]["VOLUMEUNIT_ISO"]　→　配列内のidx番目の数量単位の「ISO コードでの容積単位」
[idx]["GROSS_WT"]　→　配列内のidx番目の数量単位の「総重量」
[idx]["UNIT_OF_WT"]　→　配列内のidx番目の数量単位の「重量単位」
[idx]["UNIT_OF_WT_ISO"]　→　配列内のidx番目の数量単位の「ISO コードでの重量単位」
[idx]["SUB_UOM"]　→　配列内のidx番目の数量単位の「梱包階層の下位レベル数量単位」
[idx]["SUB_UOM_ISO"]　→　配列内のidx番目の数量単位の「下位レベル数量単位 (ISO コード)」
[idx]["INTERNAL_CHAR"]　→　配列内のidx番目の数量単位の「内部特性」
[idx]["UOMSORTNUMBER"]　→　配列内のidx番目の数量単位の「数量単位ソート番号」
[idx]["LEADINGUOM"]　→　配列内のidx番目の数量単位の「主要ロット特定数量単位」
[idx]["VALUEDUOM"]　→　配列内のidx番目の数量単位の「ロット特定数量単位での評価」
[idx]["CHAR_UNIT"]　→　配列内のidx番目の数量単位の「特性の数量単位」
[idx]["CHAR_UNIT_ISO"]　→　配列内のidx番目の数量単位の 「下位レベル数量単位 (ISO コード)」
[idx]["GTIN_VARIANT"]　→　配列内のidx番目の数量単位の「グローバルトレード明細番号バリアント」
[idx]["NET_WEIGHT"]　→　配列内のidx番目の数量単位の「正味重量」
[idx]["ME_ANZ_SUB"]　→　配列内のidx番目の数量単位の「下位レベル数量単位数」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getValuationData

Object getValuationData ()

評価データを取得します。
返却値
Object 評価データ

評価データ情報オブジェクトの構成は以下のとおりです。
評価データ
オブジェクト
(Object)
VAL_AREA 評価レベル (String)
VAL_TYPE 評価タイプ (String)
MAINT_STAT 更新ステータス (String)
DEL_FLAG 評価タイプに該当する 全品目データ削除フラグ (String)
PRICE_CTRL 原価管理区分 (String)
MOVING_PR 移動平均原価/期間単位価格 (String)
STD_PRICE 標準原価 (String)
PRICE_UNIT 価格単位 (String)
VAL_CLASS 評価クラス (String)
PR_CTRL_PP 前期間の原価管理区分 (String)
MOV_PR_PP 前期移動平均原価/期間平均原価 (String)
STD_PR_PP 前期標準標準原価 (String)
PR_UNIT_PP 前期価格単位 (String)
VCLASS_PP 前期評価クラス (String)
PR_CTRL_PY 前年度の原価管理区分 (String)
MOV_PR_PY 前年度の移動平均原価/期間単価 (String)
STD_PR_PY 前年度標準原価 (String)
VCLASS_PY 前年度の評価クラス (String)
PR_UNIT_PY 前年度価格単位 (String)
FISC_YEAR 当会計年度 (String)
CURR_PERIOD 当期 (転記期間) (String)
VAL_CAT 評価カテゴリ (String)
FUTURE_PR 次期標準原価 (String)
VALID_FROM 原価有効開始日 (String)
TAXPRICE_1 税法による評価額: レベル 1 (String)
COMMPRICE1 商法による評価額: レベル 1 (String)
TAXPRICE_3 税法基準評価額: レベル 3 (String)
COMMPRICE3 商法基準評価額: レベル 3 (String)
PLND_PRICE 予定計画原価 (String)
PLNDPRICE1 予定計画原価 1 (String)
PLNDPRICE2 予定計画原価 2 (String)
PLNDPRICE3 予定計画原価 3 (String)
PLNDPRDATE1 予定原価 1 の有効開始日 (String)
PLNDPRDATE2 予定原価 2 の有効開始日 (String)
PLNDPRDATE3 予定原価 3 の有効開始日 (String)
LIFO_FIFO LIFO/FIFO 関連 (String)
POOLNUMBER LIFO 評価でのプール番号 (String)
TAXPRICE_2 税法による評価額: レベル 2 (String)
COMMPRICE2 商法による評価額: レベル 2 (String)
DEVAL_IND 低価法: 評価減区分 (String)
ORIG_GROUP 発生源グループ (原価要素の下位区分) (String)
OVERHEAD_GRP 原価計算間接費グループ (String)
PER_FUT_COST_EST 将来標準原価見積期間 (String)
PER_CUR_COST_EST 現行標準原価見積期間 (String)
PER_PRE_COST_EST 前標準原価見積期間 (String)
FIJ_FUT_COST_EST 将来標準原価見積の 会計年度 (String)
FIJ_CUR_COST_EST 当期標準原価見積の 会計年度 (String)
FIJ_PRE_COST_EST 前期標準原価見積の 会計年度 (String)
QTY_STRUCT 数量構成により原価計算を行う品目 (String)
PREV_PLAN_PRICE 税法基準評価額: レベル 2 (String)
ML_ACTIVE 品目レベルで有効な品目元帳 (String)
ML_SETTLE 品目元帳決済: 管理 (String)
CURR_PLAN_PRICE 税法基準評価額: レベル 2 (String)
ORIG_MAT 品目発生源 (String)
VM_SO_STK 受注在庫の評価クラス (String)
VM_P_STOCK プロジェクト在庫の評価クラス (String)
MATL_USAGE 品目の用途 (String)
MAT_ORIGIN 品目の原産地 (String)
IN_HOUSE 内部生産 (String)
TAX_CML_UN 税法/商法にもとづく評価額価格単位 (String)
CURRENCY 通貨コード (String)
CURRENCY_ISO ISO コード通貨 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getValuationarea

Object getValuationarea ()

評価レベルを取得します。
返却値
Object 評価レベル
getValuationtype

Object getValuationtype ()

評価タイプを取得します。
返却値
Object 評価タイプ
getWarehouseNumberData

Object getWarehouseNumberData ()

倉庫番号データを取得します。
返却値
Object 倉庫番号データ

倉庫番号データ情報オブジェクトの構成は以下のとおりです。
倉庫番号データ
オブジェクト
(Object)
WHSE_NO 倉庫番号/複合倉庫 (String)
DEL_FLAG WM 倉庫内の全品目データ削除フラグ (String)
STGESECTOR 保管区画区分 (String)
PLACEMENT 在庫受入に対する保管域タイプ検索区分 (String)
WITHDRAWAL 在庫払出に対する保管域タイプ区分 (String)
L_EQUIP_1 積載装置数量 1 (String)
L_EQUIP_2 積載装置数量 2 (String)
L_EQUIP_3 積載装置数量 3 (String)
LEQ_UNIT_1 積載装置数量 1 の数量単位 (String)
LEQ_UNIT_1_ISO ISO コードによる 積載装置数量 1 の数量単位 (String)
LEQ_UNIT_2 積載装置数量 2 の数量単位 (String)
LEQ_UNIT_2_ISO ISO コードによる 積載装置数量 2 の数量単位 (String)
LEQ_UNIT_3 積載装置数量 3 の数量単位 (String)
LEQ_UNIT_3_ISO ISO コードによる 積載装置数量 3 の数量単位 (String)
UNITTYPE_1 第１保管単位タイプ (String)
UNITTYPE_2 第２保管単位タイプ (String)
UNITTYPE_3 第３保管単位タイプ (String)
WM_UNIT 倉庫管理の数量単位 (String)
WM_UNIT_ISO ISO コードでの倉庫管理単位 (String)
ADD_TO_STK 既存在庫への追加許可 (String)
BLOCK_STGE 平置保管域区分 (String)
MSG_TO_IM 区分: 在庫管理への出力 (String)
SPEC_MVMT 倉庫管理の特殊移動区分 (String)
CAPY_USAGE 保管容量使用 (String)
PROCURE_UN 保管容量消費の数量単位 (String)
PROCURE_UN_ISO ISO コードでの 保管容量消費の数量単位 (String)
STGE_TYPE 概略計画および詳細計画の ピッキング保管域タイプ (String)
REF_UNIT 品目マスタレコードの数量単位初期値 (String)
2STEP_PICK ツーステップピッキング適用品目 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getWarehousenumber

Object getWarehousenumber ()

倉庫番号/複合倉庫を取得します。
返却値
Object 倉庫番号/複合倉庫
setCompanycode

void setCompanycode (Object value)

会社コードを設定します。
パラメータ
value Object 会社コード
返却値
void
setDistributionchannel

void setDistributionchannel (Object value)

流通チャネルを設定します。
パラメータ
value Object 流通チャネル
返却値
void
setLifovaluationlevel

void setLifovaluationlevel (Object value)

LIFO 評価レベルを設定します。
パラメータ
value Object LIFO 評価レベル
返却値
void
setMaterial

void setMaterial (Object value)

品目コードを設定します。
パラメータ
value Object 品目コード
返却値
void
setPlant

void setPlant (Object value)

プラントを設定します。
パラメータ
value Object プラント
返却値
void
setSalesorganisation

void setSalesorganisation (Object value)

販売組織を設定します。
パラメータ
value Object 販売組織
返却値
void
setStoragelocation

void setStoragelocation (Object value)

保管場所を設定します。
パラメータ
value Object 保管場所
返却値
void
setStoragetype

void setStoragetype (Object value)

保管域タイプを設定します。
パラメータ
value Object 保管域タイプ
返却値
void
setTblParam

void setTblParam (String tableName ,String paramName ,Object value ,int index)

テーブル型の項目に値をセットします。
パラメータ
tableName | String | テーブル名
paramName | String | 項目名
value | Object | セットする値
index | int | レコード番号
返却値
void
setValuationarea

void setValuationarea (Object value)

評価レベルを設定します。
パラメータ
value Object 評価レベル
返却値
void
setValuationtype

void setValuationtype (Object value)

評価タイプを設定します。
パラメータ
value Object 評価タイプ
返却値
void
setWarehousenumber

void setWarehousenumber (Object value)

倉庫番号/複合倉庫を設定します。
パラメータ
value Object 倉庫番号/複合倉庫
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 MaterialSaveReplicaController オブジェクト

品目マスタ更新クラス。

機能は以下の通り
  • 品目マスタを更新します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
MaterialSaveReplicaController ()
コンストラクタ。
MaterialSaveReplicaController (ConnectionManager connectionManager)
コンストラクタ。
MaterialSaveReplicaController (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより品目マスタを更新します。
Array | getClientDataList () 品目データ (クライアントレベル)を取得します。
Array | getExtensionInList () BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。
Array | getExtensionInXList () 拡張イン/拡張アウトのチェックボックス構造を取得します。
Object | getFlagCadCall () CAD システムからコールを取得します。
Array | getForecastParametersList () 需要予測パラメータを取得します。
Object | getForecastValuesList () 需要予測値のデータ転送を取得します。
Array | getHeadDataList () 管理情報設定ヘッダセグメントを取得します。
Object | getInpfldcheck () 項目無効時の応答を取得します。
Array | getInternationalArtnosList () 国際商品コード (EAN)を取得します。
Object | getMaterialDescriptionList () 品目テキストを取得します。
Array | getMaterialLongTextList () テキスト (長)を取得します。
Object | getNoappllog () アプリケーションログ書込なしを取得します。
Object | getNochangedoc () 変更伝票書込なしを取得します。
Array | getPlanningDataList () 品目マスタ/製品グループの変更伝票構造を取得します。
Array | getPlantDataList () 品目データ (プラントレベル)を取得します。
Array | getPrtDataList () 品目マスタの生産資源/治工具 (PRT) 項目を取得します。
Array | getReturnMessagesList () リターンパラメータ BAPIRET2 の代替構造のデータ転送を取得します。
Array | getSalesDataList () 販売データを取得します。
Array | getStorageLocationDataList () 品目データ (保管場所レベル)を取得します。
Array | getStorageTypeDataList () 保管域タイプデータを取得します。
Array | getTaxClassificationsList () 制御デ−タを取得します。
Object | getTestrun () 書込 BAPI のシミュレーションセッションへの切替を取得します。
Array | getTotalConsumptionList () 品目総消費量のデータ転送を取得します。
Array | getUnitSofmeasureList () 数量単位を取得します。
Array | getUnplndConsumptionList () 計画外消費のデータ転送を取得します。
Array | getValuationDataList () 評価データを取得します。
Array | getWarehouseNumberDataList () 倉庫番号データを取得します。
void | setFlagCadCall (Object value) CAD システムからコールを設定します。
void | setInpfldcheck (Object value) 項目無効時の応答を設定します。
void | setNoappllog (Object value) アプリケーションログ書込なしを設定します。
void | setNochangedoc (Object value) 変更伝票書込なしを設定します。
void | setTblParam (String tableName ,String paramName ,Object value ,int index) テーブル型の項目に値をセットします。
void | setTestrun (Object value) 書込 BAPI のシミュレーションセッションへの切替を設定します。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
MaterialSaveReplicaController

MaterialSaveReplicaController ()
コンストラクタ。
MaterialSaveReplicaController

MaterialSaveReplicaController (ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、MaterialSaveReplicaController#executeBapi()実行後に必ず ConnectionManager#commit()またはConnectionManager#rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。
パラメータ
connectionManager ConnectionManager コネクションマネージャー
MaterialSaveReplicaController

MaterialSaveReplicaController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより品目マスタを更新します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getClientDataList

Array getClientDataList ()

品目データ (クライアントレベル)を取得します。
返却値
Array 品目データ (クライアントレベル)

品目データ (クライアントレベル)情報オブジェクトの構成は以下のとおりです。
品目データ (クライアントレベル)情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
DEL_FLAG クライアントレベルでの品目削除フラグ (String)
MATL_GROUP 品目グループ (String)
OLD_MAT_NO 旧品目コード (String)
BASE_UOM 基本数量単位 (String)
BASE_UOM_ISO ISO コードでの基本数量単位 (String)
PO_UNIT 発注単位 (String)
PO_UNIT_ISO ISO コードによる発注単位 (String)
DOCUMENT 文書番号 (文書管理システムによらない) (String)
DOC_TYPE 文書タイプ (文書管理システムによらない) (String)
DOC_VERS 文書バージョン (文書管理システムによらない) (String)
DOC_FORMAT 文書のページ書式 (文書管理システムによらない) (String)
DOC_CHG_NO 文書変更番号 (文書管理システム外) (String)
PAGE_NO 文書ページ番号 (文書管理システムによらない) (String)
NO_SHEETS 文書枚数 (文書管理システムによらない) (String)
PROD_MEMO 製造/検査メモ (String)
PAGEFORMAT 製造メモのページ書式 (String)
SIZE_DIM サイズ/寸法 (String)
BASIC_MATL 主構成物質 (String)
STD_DESCR 標準テキスト (ANSI、ISO など) (String)
DSN_OFFICE 研究室/設計室 (String)
PUR_VALKEY 購買許容値キー (String)
NET_WEIGHT 正味重量 (String)
UNIT_OF_WT 重量単位 (String)
UNIT_OF_WT_ISO ISO コードでの重量単位 (String)
CONTAINER 容器条件 (String)
STOR_CONDS 保管条件 (String)
TEMP_CONDS 温度条件区分 (String)
TRANS_GRP 輸送グループ (String)
HAZ_MAT_NO 危険物コード (String)
DIVISION 製品部門 (String)
COMPETITOR 競合会社 (String)
QTY_GR_GI 数量: 印刷予定入出庫票数 (String)
PROC_RULE 調達規則 (String)
SUP_SOURCE 供給元 (String)
SEASON 季節カテゴリ (String)
LABEL_TYPE ラベルタイプ (String)
LABEL_FORM ラベル書式 (String)
PROD_HIER 品目階層 (String)
CAD_ID CAD 区分 (String)
ALLOWED_WT 許容梱包重量 (String)
PACK_WT_UN 重量単位 (許容梱包重量) (String)
PACK_WT_UN_ISO ISO コードでの重量単位 (許容梱包重量) (String)
ALLWD_VOL 許容梱包容積 (String)
PACK_VO_UN 容積単位 (許容梱包容積) (String)
PACK_VO_UN_ISO ISO コードでの容積単位 (許容梱包容積) (String)
WT_TOL_LT 荷役単位の重量超過許容量 (String)
VOL_TOL_LT 荷役単位の容積超過許容量 (String)
VAR_ORD_UN 可変購買発注単位有効 (String)
BATCH_MGMT ロット管理所要量区分 (String)
SH_MAT_TYP 梱包材タイプ (String)
FILL_LEVEL 最大レベル (容積別) (String)
STACK_FACT 山積係数 (String)
MAT_GRP_SM 品目グループ: 梱包材 (String)
AUTHORITYGROUP 権限グループ (String)
QM_PROCMNT 調達における品質管理有効 (String)
CATPROFILE カタログプロファイル (String)
MINREMLIFE 最低有効期間残 (String)
SHELF_LIFE 総有効期間 (String)
STOR_PCT 残存有効期間割合 % (String)
PUR_STATUS プラント共通品目ステータス (String)
SAL_STATUS 流通チェーン間品目ステータス (String)
PVALIDFROM プラント共通品目のステータス有効開始日付 (String)
SVALIDFROM 流通チェーン間品目ステータスの有効開始日付 (String)
ENVT_RLVT 区分: 環境関連 (String)
PROD_ALLOC 製品割当決定手順 (String)
QUAL_DIK 無償納入による割引対象品目 (String)
MANU_MAT 製造者製品コード (String)
MFR_NO 製造者番号 (String)
INV_MAT_NO 会社固有 (内部) 在庫管理品目コード (String)
MANUF_PROF 製造者製品プロファイル (String)
HAZMATPROF 危険物インジケータプロファイル (String)
HIGH_VISC 区分: 高粘性 (String)
LOOSEORLIQ 区分: バルク/液体 (String)
CLOSED_BOX 完了した梱包材 (String)
APPD_B_REC 区分: バッチ製造記録の承認必須 (String)
MATCMPLLVL 品目完了レベル (String)
PAR_EFF 有効性パラメータへの値割当/変更番号よりも優先 (String)
ROUND_UP_RULE_EXPIRATION_DATE 有効期間期限日 計算の丸め規則 (String)
PERIOD_IND_EXPIRATION_DATE 有効期間期限日の期間区分 (String)
PROD_COMPOSITION_ON_PACKAGING 区分: 梱包材にプリントされた生産構造 (String)
ITEM_CAT 一般明細カテゴリグループ (String)
HAZ_MAT_NO_EXTERNAL 項目 HAZ_MAT_NO の 品目コード (長) (今後のリリースで開発) (String)
HAZ_MAT_NO_GUID 項目 HAZ_MAT_NO の 外部 GUID (今後のリリースで開発) (String)
HAZ_MAT_NO_VERSION 項目 HAZ_MAT_NO の バージョン番号 (今後のリリースで開発) (String)
INV_MAT_NO_EXTERNAL 項目 INV_MAT_NO の 品目コード (長) (今後のリリースで開発) (String)
INV_MAT_NO_GUID 項目 INV_MAT_NO の 外部 GUID (今後のリリースで開発) (String)
INV_MAT_NO_VERSION 項目 INV_MAT_NO の バージョン番号 (今後のリリースで開発) (String)
MATERIAL_FIXED ロックされている品目 (String)
CM_RELEVANCE_FLAG 構成管理関連 (String)
SLED_BBD 有効期限 (String)
GTIN_VARIANT グローバルトレード明細番号 バリアント (String)
SERIALIZATION_LEVEL シリアル番号の指定レベル (String)
PL_REF_MAT 梱包方法が同じ品目の参照品目 (String)
EXTMATLGRP 外部品目グループ (String)
UOMUSAGE 使用数量単位 (String)

取得した品目データ (クライアントレベル)情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「品目コード」
[idx]["DEL_FLAG"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「クライアントレベルでの品目削除フラグ」
[idx]["MATL_GROUP"]　→　配列内のidx番目の品目データ (クライアントレベル)の「品目グループ」
[idx]["OLD_MAT_NO"]　→　配列内のidx番目の品目データ (クライアントレベル)の「旧品目コード」
[idx]["BASE_UOM"]　→　配列内のidx番目の品目データ (クライアントレベル)の「基本数量単位」
[idx]["BASE_UOM_ISO"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「ISO コードでの基本数量単位」
[idx]["PO_UNIT"]　→　配列内のidx番目の品目データ (クライアントレベル)の「発注単位」
[idx]["PO_UNIT_ISO"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「ISO コードによる発注単位」
[idx]["DOCUMENT"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「文書番号 (文書管理システムによらない)」
[idx]["DOC_TYPE"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「文書タイプ (文書管理システムによらない)」
[idx]["DOC_VERS"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「文書バージョン (文書管理システムによらない)」
[idx]["DOC_FORMAT"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「文書のページ書式 (文書管理システムによらない)」
[idx]["DOC_CHG_NO"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「文書変更番号 (文書管理システム外)」
[idx]["PAGE_NO"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「文書ページ番号 (文書管理システムによらない)」
[idx]["NO_SHEETS"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「文書枚数 (文書管理システムによらない)」
[idx]["PROD_MEMO"]　→　配列内のidx番目の品目データ (クライアントレベル)の「製造/検査メモ」
[idx]["PAGEFORMAT"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「製造メモのページ書式」
[idx]["SIZE_DIM"]　→　配列内のidx番目の品目データ (クライアントレベル)の「サイズ/寸法」
[idx]["BASIC_MATL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「主構成物質」
[idx]["STD_DESCR"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「標準テキスト (ANSI、ISO など)」
[idx]["DSN_OFFICE"]　→　配列内のidx番目の品目データ (クライアントレベル)の「研究室/設計室」
[idx]["PUR_VALKEY"]　→　配列内のidx番目の品目データ (クライアントレベル)の「購買許容値キー」
[idx]["NET_WEIGHT"]　→　配列内のidx番目の品目データ (クライアントレベル)の「正味重量」
[idx]["UNIT_OF_WT"]　→　配列内のidx番目の品目データ (クライアントレベル)の「重量単位」
[idx]["UNIT_OF_WT_ISO"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「ISO コードでの重量単位」
[idx]["CONTAINER"]　→　配列内のidx番目の品目データ (クライアントレベル)の「容器条件」
[idx]["STOR_CONDS"]　→　配列内のidx番目の品目データ (クライアントレベル)の「保管条件」
[idx]["TEMP_CONDS"]　→　配列内のidx番目の品目データ (クライアントレベル)の「温度条件区分」
[idx]["TRANS_GRP"]　→　配列内のidx番目の品目データ (クライアントレベル)の「輸送グループ」
[idx]["HAZ_MAT_NO"]　→　配列内のidx番目の品目データ (クライアントレベル)の「危険物コード」
[idx]["DIVISION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「製品部門」
[idx]["COMPETITOR"]　→　配列内のidx番目の品目データ (クライアントレベル)の「競合会社」
[idx]["QTY_GR_GI"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「数量: 印刷予定入出庫票数」
[idx]["PROC_RULE"]　→　配列内のidx番目の品目データ (クライアントレベル)の「調達規則」
[idx]["SUP_SOURCE"]　→　配列内のidx番目の品目データ (クライアントレベル)の「供給元」
[idx]["SEASON"]　→　配列内のidx番目の品目データ (クライアントレベル)の「季節カテゴリ」
[idx]["LABEL_TYPE"]　→　配列内のidx番目の品目データ (クライアントレベル)の「ラベルタイプ」
[idx]["LABEL_FORM"]　→　配列内のidx番目の品目データ (クライアントレベル)の「ラベル書式」
[idx]["PROD_HIER"]　→　配列内のidx番目の品目データ (クライアントレベル)の「品目階層」
[idx]["CAD_ID"]　→　配列内のidx番目の品目データ (クライアントレベル)の「CAD 区分」
[idx]["ALLOWED_WT"]　→　配列内のidx番目の品目データ (クライアントレベル)の「許容梱包重量」
[idx]["PACK_WT_UN"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「重量単位 (許容梱包重量)」
[idx]["PACK_WT_UN_ISO"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「ISO コードでの重量単位 (許容梱包重量)」
[idx]["ALLWD_VOL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「許容梱包容積」
[idx]["PACK_VO_UN"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「容積単位 (許容梱包容積)」
[idx]["PACK_VO_UN_ISO"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「ISO コードでの容積単位 (許容梱包容積)」
[idx]["WT_TOL_LT"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「荷役単位の重量超過許容量」
[idx]["VOL_TOL_LT"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「荷役単位の容積超過許容量」
[idx]["VAR_ORD_UN"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「可変購買発注単位有効」
[idx]["BATCH_MGMT"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「ロット管理所要量区分」
[idx]["SH_MAT_TYP"]　→　配列内のidx番目の品目データ (クライアントレベル)の「梱包材タイプ」
[idx]["FILL_LEVEL"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「最大レベル (容積別)」
[idx]["STACK_FACT"]　→　配列内のidx番目の品目データ (クライアントレベル)の「山積係数」
[idx]["MAT_GRP_SM"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「品目グループ: 梱包材」
[idx]["AUTHORITYGROUP"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「権限グループ」
[idx]["QM_PROCMNT"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「調達における品質管理有効」
[idx]["CATPROFILE"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「カタログプロファイル」
[idx]["MINREMLIFE"]　→　配列内のidx番目の品目データ (クライアントレベル)の「最低有効期間残」
[idx]["SHELF_LIFE"]　→　配列内のidx番目の品目データ (クライアントレベル)の「総有効期間」
[idx]["STOR_PCT"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「残存有効期間割合 %」
[idx]["PUR_STATUS"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「プラント共通品目ステータス」
[idx]["SAL_STATUS"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「流通チェーン間品目ステータス」
[idx]["PVALIDFROM"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「プラント共通品目のステータス有効開始日付」
[idx]["SVALIDFROM"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「流通チェーン間品目ステータスの有効開始日付」
[idx]["ENVT_RLVT"]　→　配列内のidx番目の品目データ (クライアントレベル)の「区分: 環境関連」
[idx]["PROD_ALLOC"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「製品割当決定手順」
[idx]["QUAL_DIK"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「無償納入による割引対象品目」
[idx]["MANU_MAT"]　→　配列内のidx番目の品目データ (クライアントレベル)の「製造者製品コード」
[idx]["MFR_NO"]　→　配列内のidx番目の品目データ (クライアントレベル)の「製造者番号」
[idx]["INV_MAT_NO"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「会社固有 (内部) 在庫管理品目コード」
[idx]["MANUF_PROF"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「製造者製品プロファイル」
[idx]["HAZMATPROF"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「危険物インジケータプロファイル」
[idx]["HIGH_VISC"]　→　配列内のidx番目の品目データ (クライアントレベル)の「区分: 高粘性」
[idx]["LOOSEORLIQ"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「区分: バルク/液体」
[idx]["CLOSED_BOX"]　→　配列内のidx番目の品目データ (クライアントレベル)の「完了した梱包材」
[idx]["APPD_B_REC"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「区分: バッチ製造記録の承認必須」
[idx]["MATCMPLLVL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「品目完了レベル」
[idx]["PAR_EFF"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「有効性パラメータへの値割当/変更番号よりも優先」
[idx]["ROUND_UP_RULE_EXPIRATION_DATE"]　→　配列内のidx番目の品目データ (クライアントレベル)の「有効期間期限日計算の丸め規則」
[idx]["PERIOD_IND_EXPIRATION_DATE"]　→　配列内のidx番目の品目データ (クライアントレベル)の「有効期間期限日の期間区分」
[idx]["PROD_COMPOSITION_ON_PACKAGING"]　→　配列内のidx番目の品目データ (クライアントレベル)の「区分: 梱包材にプリントされた生産構造」
[idx]["ITEM_CAT"]　→　配列内のidx番目の品目データ (クライアントレベル)の 「一般明細カテゴリグループ」
[idx]["HAZ_MAT_NO_EXTERNAL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 HAZ_MAT_NO の品目コード (長) (今後のリリースで開発)」
[idx]["HAZ_MAT_NO_GUID"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)」
[idx]["HAZ_MAT_NO_VERSION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 HAZ_MAT_NO のバージョン番号 (今後のリリースで開発)」
[idx]["INV_MAT_NO_EXTERNAL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 INV_MAT_NO の品目コード (長) (今後のリリースで開発)」
[idx]["INV_MAT_NO_GUID"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)」
[idx]["INV_MAT_NO_VERSION"]　→　配列内のidx番目の品目データ (クライアントレベル)の「項目 INV_MAT_NO のバージョン番号 (今後のリリースで開発)」
[idx]["MATERIAL_FIXED"]　→　配列内のidx番目の品目データ (クライアントレベル)の「ロックされている品目」
[idx]["CM_RELEVANCE_FLAG"]　→　配列内のidx番目の品目データ (クライアントレベル)の「構成管理関連」
[idx]["SLED_BBD"]　→　配列内のidx番目の品目データ (クライアントレベル)の「有効期限」
[idx]["GTIN_VARIANT"]　→　配列内のidx番目の品目データ (クライアントレベル)の「グローバルトレード明細番号バリアント」
[idx]["SERIALIZATION_LEVEL"]　→　配列内のidx番目の品目データ (クライアントレベル)の「シリアル番号の指定レベル」
[idx]["PL_REF_MAT"]　→　配列内のidx番目の品目データ (クライアントレベル)の「梱包方法が同じ品目の参照品目」
[idx]["EXTMATLGRP"]　→　配列内のidx番目の品目データ (クライアントレベル)の「外部品目グループ」
[idx]["UOMUSAGE"]　→　配列内のidx番目の品目データ (クライアントレベル)の「使用数量単位」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getExtensionInList

Array getExtensionInList ()

BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。
返却値
Array BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造

BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報オブジェクト の構成は以下のとおりです。
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
STRUCTURE BAPI テーブル拡張の構造名 (String)
VALUEPART1 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART2 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART3 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART4 長さ 229 の文字データのコンテナ (String)

取得したBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の 参照構造情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目のBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目のBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の「品目コード」
[idx]["STRUCTURE"]　→　配列内のidx番目のBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の「BAPI テーブル拡張の構造名」
[idx]["VALUEPART1"]　→　配列内のidx番目のBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART2"]　→　配列内のidx番目のBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART3"]　→　配列内のidx番目のBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART4"]　→　配列内のidx番目のBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の「長さ 229 の文字データのコンテナ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getExtensionInXList

Array getExtensionInXList ()

拡張イン/拡張アウトのチェックボックス構造を取得します。
返却値
Array 拡張イン/拡張アウトのチェックボックス構造

拡張イン/拡張アウトのチェックボックス構造情報オブジェクトの構成は以下のとおりです。
拡張イン/拡張アウトの チェックボックス構造情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
STRUCTURE BAPI テーブル拡張の構造名 (String)
VALUEPART1 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART2 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART3 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART4 長さ 229 の文字データのコンテナ (String)

取得した拡張イン/拡張アウトのチェックボックス構造情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の拡張イン/拡張アウトの チェックボックス構造の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の拡張イン/拡張アウトのチェックボックス構造の「品目コード」
[idx]["STRUCTURE"]　→　配列内のidx番目の拡張イン/拡張アウトの チェックボックス構造の「BAPI テーブル拡張の構造名」
[idx]["VALUEPART1"]　→　配列内のidx番目の拡張イン/拡張アウトの チェックボックス構造の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART2"]　→　配列内のidx番目の拡張イン/拡張アウトの チェックボックス構造の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART3"]　→　配列内のidx番目の拡張イン/拡張アウトの チェックボックス構造の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART4"]　→　配列内のidx番目の拡張イン/拡張アウトの チェックボックス構造の「長さ 229 の文字データのコンテナ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getFlagCadCall

Object getFlagCadCall ()

CAD システムからコールを取得します。
返却値
Object CAD システムからコール
getForecastParametersList

Array getForecastParametersList ()

需要予測パラメータを取得します。
返却値
Array 需要予測パラメータ

需要予測パラメータ情報オブジェクトの構成は以下のとおりです。
需要予測パラメータ情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
PLANT プラント (String)
FORE_PROF 需要予測プロファイル (String)
MODEL_SI モデル選択区分 (String)
MODEL_SP モデル選択方式 (String)
PARAM_OPT パラメータ最適化用の区分 (String)
OPTIM_LEV 最適化レベル (String)
INITIALIZE 初期化区分 (String)
FORE_MODEL 予測モデル (String)
ALPHA_FACT アルファ係数使用による基本値の平滑化 (String)
BETA_FACT ベータ係数による傾向値平準化 (String)
GAMMA_FACT ガンマ係数使用の平滑化の ための季節指数 (String)
DELTA_FACT デルタ係数使用による MAD (絶対平均偏差) 平準化 (String)
TRACKLIMIT 警告限界 (String)
FORE_DATE 最終需要予測日 (String)
HIST_VALS 履歴値の数 (String)
INIT_PDS 初期化で使用する履歴値の数 (String)
SEASON_PDS 季節周期ごとの期間数 (String)
EXPOST_PDS 事後的需要予測に含む履歴値の数 (String)
FORE_PDS 需要予測期間 (String)
FIXED_PDS 固定期間 (String)
WTG_GROUP 加重グループ (String)

取得した需要予測パラメータ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の需要予測パラメータの「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の需要予測パラメータの「品目コード」
[idx]["PLANT"]　→　配列内のidx番目の需要予測パラメータの「プラント」
[idx]["FORE_PROF"]　→　配列内のidx番目の需要予測パラメータの「需要予測プロファイル」
[idx]["MODEL_SI"]　→　配列内のidx番目の需要予測パラメータの「モデル選択区分」
[idx]["MODEL_SP"]　→　配列内のidx番目の需要予測パラメータの「モデル選択方式」
[idx]["PARAM_OPT"]　→　配列内のidx番目の需要予測パラメータの「パラメータ最適化用の区分」
[idx]["OPTIM_LEV"]　→　配列内のidx番目の需要予測パラメータの「最適化レベル」
[idx]["INITIALIZE"]　→　配列内のidx番目の需要予測パラメータの「初期化区分」
[idx]["FORE_MODEL"]　→　配列内のidx番目の需要予測パラメータの「予測モデル」
[idx]["ALPHA_FACT"]　→　配列内のidx番目の需要予測パラメータの 「アルファ係数使用による基本値の平滑化」
[idx]["BETA_FACT"]　→　配列内のidx番目の需要予測パラメータの「ベータ係数による傾向値平準化」
[idx]["GAMMA_FACT"]　→　配列内のidx番目の需要予測パラメータの 「ガンマ係数使用の平滑化のための季節指数」
[idx]["DELTA_FACT"]　→　配列内のidx番目の需要予測パラメータの 「デルタ係数使用による MAD (絶対平均偏差) 平準化」
[idx]["TRACKLIMIT"]　→　配列内のidx番目の需要予測パラメータの「警告限界」
[idx]["FORE_DATE"]　→　配列内のidx番目の需要予測パラメータの「最終需要予測日」
[idx]["HIST_VALS"]　→　配列内のidx番目の需要予測パラメータの「履歴値の数」
[idx]["INIT_PDS"]　→　配列内のidx番目の需要予測パラメータの「初期化で使用する履歴値の数」
[idx]["SEASON_PDS"]　→　配列内のidx番目の需要予測パラメータの「季節周期ごとの期間数」
[idx]["EXPOST_PDS"]　→　配列内のidx番目の需要予測パラメータの「事後的需要予測に含む履歴値の数」
[idx]["FORE_PDS"]　→　配列内のidx番目の需要予測パラメータの「需要予測期間」
[idx]["FIXED_PDS"]　→　配列内のidx番目の需要予測パラメータの「固定期間」
[idx]["WTG_GROUP"]　→　配列内のidx番目の需要予測パラメータの「加重グループ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getForecastValuesList

Object getForecastValuesList ()

需要予測値のデータ転送を取得します。
返却値
Object 需要予測値のデータ転送

需要予測値のデータ転送情報オブジェクトの構成は以下のとおりです。
需要予測値のデータ転送
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
PLANT プラント (String)
FIRST_DAY 値参照期間の第一日目 (String)
FORE_VALUE 予測値 (String)
CORR_VALUE 需要予測に対する修正値 (String)
SEAS_INDEX 季節指数 (String)
CVALUE_FXD 区分: 消費金額の確定 (String)
EXPOST_VAL 事後的需要予測値 (String)
VAL_RATIO 元値に対する修正値の比率 (修正値: 元値) (String)
MATERIAL_EXTERNAL 項目 MATERIAL の 品目コード (長) (今後のリリースで開発) (String)
MATERIAL_GUID 項目 MATERIAL の外部 GUID (今後のリリースで開発) (String)
MATERIAL_VERSION 項目 MATERIAL の バージョン番号 (今後のリリースで開発) (String)

取得した需要予測値のデータ転送情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の需要予測値のデータ転送の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の需要予測値のデータ転送の「品目コード」
[idx]["PLANT"]　→　配列内のidx番目の需要予測値のデータ転送の「プラント」
[idx]["FIRST_DAY"]　→　配列内のidx番目の需要予測値のデータ転送の「値参照期間の第一日目」
[idx]["FORE_VALUE"]　→　配列内のidx番目の需要予測値のデータ転送の「予測値」
[idx]["CORR_VALUE"]　→　配列内のidx番目の需要予測値のデータ転送の「需要予測に対する修正値」
[idx]["SEAS_INDEX"]　→　配列内のidx番目の需要予測値のデータ転送の「季節指数」
[idx]["CVALUE_FXD"]　→　配列内のidx番目の需要予測値のデータ転送の「区分: 消費金額の確定」
[idx]["EXPOST_VAL"]　→　配列内のidx番目の需要予測値のデータ転送の「事後的需要予測値」
[idx]["VAL_RATIO"]　→　配列内のidx番目の需要予測値のデータ転送の 「元値に対する修正値の比率 (修正値: 元値)」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の需要予測値のデータ転送の 「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の需要予測値のデータ転送の 「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の需要予測値のデータ転送の 「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getHeadDataList

Array getHeadDataList ()

管理情報設定ヘッダセグメントを取得します。
返却値
Array 管理情報設定ヘッダセグメント

管理情報設定ヘッダセグメント情報オブジェクトの構成は以下のとおりです。
管理情報設定ヘッダセグメント情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
IND_SECTOR 産業コード (String)
MATL_TYPE 品目タイプ (String)
BASIC_VIEW 基本データビュー (String)
SALES_VIEW 販売ビュー (String)
PURCHASE_VIEW 購買管理ビュー (String)
MRP_VIEW 資材所要量計画 (MRP) ビュー (String)
FORECAST_VIEW 需要予測ビュー (String)
WORK_SCHED_VIEW 作業計画ビュー (String)
PRT_VIEW 生産資源/治工具 (PRT) ビュー (String)
STORAGE_VIEW 保管ビュー (String)
WAREHOUSE_VIEW 倉庫管理ビュー (String)
QUALITY_VIEW 品質管理ビュー (String)
ACCOUNT_VIEW 会計ビュー (String)
COST_VIEW 原価計算ビュー (String)
MATERIAL_EXTERNAL 項目 MATERIAL の 品目コード (長) (今後のリリースで開発) (String)
MATERIAL_GUID 項目 MATERIAL の 外部 GUID (今後のリリースで開発) (String)
MATERIAL_VERSION 項目 MATERIAL の バージョン番号 (今後のリリースで開発) (String)

取得した管理情報設定ヘッダセグメント情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの「品目コード」
[idx]["IND_SECTOR"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの「産業コード」
[idx]["MATL_TYPE"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの「品目タイプ」
[idx]["BASIC_VIEW"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの「基本データビュー」
[idx]["SALES_VIEW"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの「販売ビュー」
[idx]["PURCHASE_VIEW"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの「購買管理ビュー」
[idx]["MRP_VIEW"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの 「資材所要量計画 (MRP) ビュー」
[idx]["FORECAST_VIEW"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの「需要予測ビュー」
[idx]["WORK_SCHED_VIEW"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの 「作業計画ビュー」
[idx]["PRT_VIEW"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの 「生産資源/治工具 (PRT) ビュー」
[idx]["STORAGE_VIEW"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの「保管ビュー」
[idx]["WAREHOUSE_VIEW"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの 「倉庫管理ビュー」
[idx]["QUALITY_VIEW"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの「品質管理ビュー」
[idx]["ACCOUNT_VIEW"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの「会計ビュー」
[idx]["COST_VIEW"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの「原価計算ビュー」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの 「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの 「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の管理情報設定ヘッダセグメントの 「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getInpfldcheck

Object getInpfldcheck ()

項目無効時の応答を取得します。
返却値
Object 項目無効時の応答
getInternationalArtnosList

Array getInternationalArtnosList ()

国際商品コード (EAN)を取得します。
返却値
Array 国際商品コード (EAN)

国際商品コード (EAN)情報オブジェクトの構成は以下のとおりです。
国際商品コード (EAN)情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
UNIT 表示数量単位 (String)
UNIT_ISO ISO コードでの表示数量単位 (String)
EAN_UPC 国際商品コード (EAN/UPC) (String)
EAN_CAT 国際商品コード (EAN) のカテゴリ (String)
DEL_FLAG データレコード削除 (テーブル繰返し) (String)

取得した国際商品コード (EAN)情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の国際商品コード (EAN)の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の国際商品コード (EAN)の「品目コード」
[idx]["UNIT"]　→　配列内のidx番目の国際商品コード (EAN)の「表示数量単位」
[idx]["UNIT_ISO"]　→　配列内のidx番目の国際商品コード (EAN)の 「ISO コードでの表示数量単位」
[idx]["EAN_UPC"]　→　配列内のidx番目の国際商品コード (EAN)の 「国際商品コード (EAN/UPC)」
[idx]["EAN_CAT"]　→　配列内のidx番目の国際商品コード (EAN)の 「国際商品コード (EAN) のカテゴリ」
[idx]["DEL_FLAG"]　→　配列内のidx番目の国際商品コード (EAN)の 「データレコード削除 (テーブル繰返し)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getMaterialDescriptionList

Object getMaterialDescriptionList ()

品目テキストを取得します。
返却値
Object 品目テキスト

品目テキスト情報オブジェクトの構成は以下のとおりです。
品目テキスト
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
LANGU 言語キー (String)
LANGU_ISO ISO 639 準拠の言語 (String)
MATL_DESC 品目テキスト (String)
DEL_FLAG データレコード削除 (テーブル繰返し) (String)

取得した品目テキスト情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の品目テキストの「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の品目テキストの「品目コード」
[idx]["LANGU"]　→　配列内のidx番目の品目テキストの「言語キー」
[idx]["LANGU_ISO"]　→　配列内のidx番目の品目テキストの「ISO 639 準拠の言語」
[idx]["MATL_DESC"]　→　配列内のidx番目の品目テキストの「品目テキスト」
[idx]["DEL_FLAG"]　→　配列内のidx番目の品目テキストの「データレコード削除 (テーブル繰返し)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getMaterialLongTextList

Array getMaterialLongTextList ()

テキスト (長)を取得します。
返却値
Array テキスト (長)

テキスト (長)情報オブジェクトの構成は以下のとおりです。
テキスト (長)情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
APPLOBJECT テキスト: アプリケーションオブジェクト (String)
TEXT_NAME 名称 (String)
TEXT_ID テキスト ID (String)
LANGU 言語キー (String)
LANGU_ISO ISO 639 準拠の言語 (String)
FORMAT_COL タグ列 (String)
TEXT_LINE テキスト行 (String)
DEL_FLAG データレコード削除 (テーブル繰返し) (String)

取得したテキスト (長)情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目のテキスト (長)の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目のテキスト (長)の「品目コード」
[idx]["APPLOBJECT"]　→　配列内のidx番目のテキスト (長)の 「テキスト: アプリケーションオブジェクト」
[idx]["TEXT_NAME"]　→　配列内のidx番目のテキスト (長)の「名称」
[idx]["TEXT_ID"]　→　配列内のidx番目のテキスト (長)の「テキスト ID」
[idx]["LANGU"]　→　配列内のidx番目のテキスト (長)の「言語キー」
[idx]["LANGU_ISO"]　→　配列内のidx番目のテキスト (長)の「ISO 639 準拠の言語」
[idx]["FORMAT_COL"]　→　配列内のidx番目のテキスト (長)の「タグ列」
[idx]["TEXT_LINE"]　→　配列内のidx番目のテキスト (長)の「テキスト行」
[idx]["DEL_FLAG"]　→　配列内のidx番目のテキスト (長)の 「データレコード削除 (テーブル繰返し)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getNoappllog

Object getNoappllog ()

アプリケーションログ書込なしを取得します。
返却値
Object アプリケーションログ書込なし
getNochangedoc

Object getNochangedoc ()

変更伝票書込なしを取得します。
返却値
Object 変更伝票書込なし
getPlanningDataList

Array getPlanningDataList ()

品目マスタ/製品グループの変更伝票構造を取得します。
返却値
Array 品目マスタ/製品グループの変更伝票構造

品目マスタ/製品グループの変更伝票構造情報オブジェクトの構成は以下のとおりです。
品目マスタ/製品グループの変更伝票構造情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
PLANT プラント (String)
PLNG_MATL 計画品目 (String)
PLNG_PLANT 計画プラント (String)
CONVFACTOR 計画品目用変換係数 (String)
PLNG_MATL_EXTERNAL 項目 PLNG_MATL の 品目コード (長) (今後のリリースで開発) (String)
PLNG_MATL_GUID 項目 PLNG_MATL の外部 GUID (今後のリリースで開発) (String)
PLNG_MATL_VERSION 項目 PLNG_MATL の バージョン番号 (今後のリリースで開発) (String)

取得した品目マスタ/製品グループの変更伝票構造情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の品目マスタ/製品グループの変更伝票構造の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の品目マスタ/製品グループの変更伝票構造の「品目コード」
[idx]["PLANT"]　→　配列内のidx番目の品目マスタ/製品グループの変更伝票構造の「プラント」
[idx]["PLNG_MATL"]　→　配列内のidx番目の品目マスタ/製品グループの変更伝票構造の「計画品目」
[idx]["PLNG_PLANT"]　→　配列内のidx番目の品目マスタ/製品グループ の変更伝票構造の「計画プラント」
[idx]["CONVFACTOR"]　→　配列内のidx番目の品目マスタ/製品グループ の変更伝票構造の「計画品目用変換係数」
[idx]["PLNG_MATL_EXTERNAL"]　→　配列内のidx番目の品目マスタ/製品グループ の変更伝票構造の「項目 PLNG_MATL の品目コード (長) (今後のリリースで開発)」
[idx]["PLNG_MATL_GUID"]　→　配列内のidx番目の品目マスタ/製品グループ の変更伝票構造の「項目 PLNG_MATL の外部 GUID (今後のリリースで開発)」
[idx]["PLNG_MATL_VERSION"]　→　配列内のidx番目の品目マスタ/製品グループ の変更伝票構造の「項目 PLNG_MATL のバージョン番号 (今後のリリースで開発)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPlantDataList

Array getPlantDataList ()

品目データ (プラントレベル)を取得します。
返却値
Array 品目データ (プラントレベル)

品目データ (プラントレベル)情報オブジェクトの構成は以下のとおりです。
品目データ (プラントレベル)情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
PLANT プラント (String)
DEL_FLAG プラントレベルでの品目削除フラグ (String)
ABC_ID ABC 区分 (String)
CRIT_PART 区分: 重要品目 (String)
PUR_GROUP 購買グループ (String)
ISSUE_UNIT 出庫単位 (String)
ISSUE_UNIT_ISO ISO コードでの出庫単位 (String)
MRPPROFILE 品目: MRP プロファイル (String)
MRP_TYPE MRP タイプ (String)
MRP_CTRLER MRP 管理者 (String)
PLND_DELRY 予定納入時間 (単位: 日) (String)
GR_PR_TIME 入庫処理日数 (String)
PERIOD_IND 期間区分 (String)
ASSY_SCRAP 組立不良率 (String)
LOTSIZEKEY ロットサイズ (品目計画) (String)
PROC_TYPE 調達タイプ (String)
SPPROCTYPE 特殊調達タイプ (String)
REORDER_PT 発注点 (String)
SAFETY_STK 安全在庫 (String)
MINLOTSIZE 最小ロットサイズ (String)
MAXLOTSIZE 最大ロットサイズ (String)
FIXED_LOT 固定ロットサイズ (String)
ROUND_VAL 購買発注数量の丸め数量 (String)
MAX_STOCK 最大在庫レベル (String)
ORD_COSTS 発注原価 (BAPI インタフェース) (String)
DEP_REQ_ID 個別所要量と包括所要量に 対する従属所要量区分 (String)
STOR_COSTS 保管経費区分 (String)
ALT_BOM_ID 代替 BOM 選択の方法 (String)
DISCONTINU 打切区分 (String)
EFF_O_DAY 有効終了日 (String)
FOLLOW_UP フォローアップ品目 (String)
GRP_REQMTS 区分: 所要量グループ化 (String)
MIXED_MRP 二重 MRP 区分 (String)
SM_KEY 日程計画余裕キー (String)
BACKFLUSH 区分: バックフラッシュ (String)
PRODUCTION_SCHEDULER 製造計画担当 (String)
PROC_TIME 処理時間 (String)
SETUPTIME 段取時間と片付け時間 (String)
INTEROP 移動時間 (String)
BASE_QTY 基本数量 (String)
INHSEPRODT 内製日数 (String)
STGEPERIOD 最長保管期間 (String)
STGE_PD_UN 最長保管期間の単位 (String)
STGE_PD_UN_ISO ISO コードでの 最長保管期間単位 (String)
OVER_TOL 過剰納入許容範囲リミット (String)
UNLIMITED 区分: 無制限過剰納入可能 (String)
UNDER_TOL 不足納入許容範囲リミット (String)
REPLENTIME 補充リードタイム合計 (稼動日数) (String)
REPLACE_PT 取替部品 (String)
IND_POST_TO_INSP_STOCK 品質検査中在庫への転記 (String)
CTRL_KEY 調達における品質管理の管理キー (String)
DOC_REQD 文書必須フラグ (String)
LOADINGGRP 積載グループ (String)
BATCH_MGMT ロット管理所要量区分 (String)
QUOTAUSAGE 供給量割当の使用 (String)
SERV_LEVEL サービスレベル (String)
SPLIT_IND 分割区分 (String)
AVAILCHECK 利用可能在庫確認の確認グループ (String)
FY_VARIANT 会計年度バリアント (String)
CORR_FACT 区分: 修正係数を需要予測値計算に使用 (String)
SETUP_TIME 出荷準備時間 (String)
BASE_QTY_PLAN 出荷の能力計画のための基本数量 (String)
SHIP_PROC_TIME 出荷処理時間 (String)
SUP_SOURCE 供給元 (String)
AUTO_P_ORD 区分: 購買発注自動生成 (String)
SOURCELIST 区分: 供給元一覧必須 (String)
COMM_CODE 貿易: 統計品目コード/輸入コード番号 (String)
COUNTRYORI 品目の原産国 (String)
COUNTRYORI_ISO ISO コードでの品目原産国 (String)
REGIONORIG 品目の原産地 (非特恵対象地区の原産) (String)
COMM_CO_UN 物品コード (貿易) の数量単位 (String)
COMM_CO_UN_ISO ISO コードによる物品コード (貿易管理) の数量単位 (String)
EXPIMPGRP 輸出/輸入品目グループ (String)
PROFIT_CTR 利益センタ (String)
PPC_PL_CAL PPC 計画カレンダ (String)
REP_MANUF 区分: 繰返生産許可 (String)
PL_TI_FNCE 計画タイムフェンス (String)
CONSUMMODE 消費モード (String)
BWD_CONS 消費期間: 後方 (String)
FWD_CONS 消費期間: 前方 (String)
ALTERNATIVE_BOM 代替 BOM (String)
BOM_USAGE BOM 用途 (String)
PLANLISTGRP タスクリストグループのキー (String)
PLANLISTCNT グループカウンタ (String)
LOT_SIZE 原価計算ロットサイズ (String)
SPECPROCTY 原価計算の特殊調達タイプ (String)
PROD_UNIT 製造単位 (String)
PROD_UNIT_ISO 製造単位 (ISO コード) (String)
ISS_ST_LOC 出庫保管場所 (String)
MRP_GROUP MRP グループ (String)
COMP_SCRAP 構成品目不良率 (String)
CERT_TYPE 証明書タイプ (String)
CYCLE_TIME タクトタイム (String)
COVPROFILE 在庫日数プロファイル (String)
CC_PH_INV 循環棚卸の実地棚卸区分 (String)
VARIANCE_KEY 差異キー (String)
SERNO_PROF シリアル番号プロファイル (String)
REPMANPROF 繰返生産プロファイル (String)
NEG_STOCKS プラントにおけるマイナス在庫許可 (String)
QM_RGMTS 仕入先の必須 QM システム (String)
PLNG_CYCLE 計画サイクル (String)
ROUND_PROF 丸めプロファイル (String)
REFMATCONS 消費参照品目 (String)
D_TO_REF_M 消費データ参照の有効終了日 (String)
MULT_REF_M 消費データ参照品目の乗数 (String)
AUTO_RESET 予測モデル自動リセット (String)
EX_CERT_ID 法令管理: 認定書区分 (String)
EX_CERT_NO_NEW 非該当証明書番号 - 法令管理 (String)
EX_CERT_DT 非該当証明書発行日 (String)
MILIT_ID ID: 武器 (String)
INSP_INT 次回再検査までの間隔 (String)
CO_PRODUCT 区分: 連産品としても使用可能な品目 (String)
PLAN_STRGP 計画方針グループ (String)
SLOC_EXPRC 外部調達の初期保管場所 (String)
BULK_MAT 区分: バルク品目 (String)
CC_FIXED 循環棚卸区分固定 (String)
DETERM_GRP 在庫決定グループ (String)
QM_AUTHGRP QM における活動の品目権限グループ (String)
TASK_LIST_TYPE タスクリストタイプ (String)
PUR_STATUS プラント特有品目ステータス (String)
PRODPROF 製造計画プロファイル (String)
SAFTY_T_ID 安全時間区分 （安全リードタイムあり/なし) (String)
SAFETYTIME 安全時間 (稼動日数) (String)
PLORD_CTRL アクション管理: 計画手配処理 (String)
BATCHENTRY 製造/プロセス指図でのロット入力設定 (String)
PVALIDFROM プラント品目ステータス有効期間開始日 (String)
MATFRGTGRP 品目運賃グループ (String)
PRODVERSCS 原価計算を行う製造バージョン (String)
MAT_CFOP 品目 CFOP カテゴリ (String)
EU_LIST_NO CAP: CAP 製品一覧番号 (String)
EU_MAT_GRP EEC 農産物政策: CAP 生産品グループ - 貿易 (String)
CAS_NO CAS 番号： 薬事品目 - 貿易 (String)
PRODCOM_NO 生産統計: 貿易における PRODCOM コード (String)
CTRL_CODE 貿易: 消費税の管理コード (String)
JIT_RELVT 区分: JIT 納入日程の関連明細 (String)
MAT_GRP_TRANS 段取替えマトリクスに対する 品目のグループ (String)
HANDLG_GRP ワークロード計算の ロジスティクス処理グループ (String)
SUPPLY_AREA 品目マスタレコードで 提案される供給場所 (String)
FAIR_SHARE_RULE 均等配賦ルール (String)
PUSH_DISTRIB 区分: プッシュ配賦 (String)
DEPLOY_HORIZ 供給分配期間の日数 (String)
MIN_LOT_SIZE 需要と供給を一致させるための 最小ロットサイズ (String)
MAX_LOT_SIZE 需要と供給を一致させるための 最大ロットサイズ (String)
FIX_LOT_SIZE 需要供給の一致に対する 固定ロットサイズ (String)
LOT_INCREMENT 需要と供給を一致させるための ロットサイズ増分 (String)
PROD_CONV_TYPE 生産値の変換タイプ (String)
DISTR_PROF サイトの商品の物流プロファイル (String)
PERIOD_PROFILE_SAFETY_TIME 安全時間の 期間プロファイル (String)
FXD_PRICE 固定価格連産品 (String)
AVAIL_CHECK_ALL_PROJ_SEGMENTS プロジェクト間品目区分 (String)
OVERALLPRF 指図変更管理の全体プロファイル (String)
MRP_RELEVANCY_DEP_REQUIREMENTS 従属所要量と MRP の関連性 (String)
MIN_SAFETY_STK 最小安全在庫 (String)
NO_COSTING 原価計算なし (String)
UNIT_GROUP 数量単位グループ (String)
FOLLOW_UP_EXTERNAL 項目 FOLLOW_UP の 品目コード (長) (今後のリリースで開発) (String)
FOLLOW_UP_GUID 項目 FOLLOW_UP の 外部 GUID (今後のリリースで開発) (String)
FOLLOW_UP_VERSION 項目 FOLLOW_UP の バージョン番号 (今後のリリースで開発) (String)
REFMATCONS_EXTERNAL 項目 REFMATCONS の 品目コード (長) (今後のリリースで開発) (String)
REFMATCONS_GUID 項目 REFMATCONS の 外部 GUID (今後のリリースで開発) (String)
REFMATCONS_VERSION 項目 REFMATCONS の バージョン番号 (今後のリリースで開発) (String)
SALES_VIEW 販売ビュー (String)
PURCH_VIEW 購買管理ビュー (String)
MRP_VIEW 資材所要量計画 (MRP) ビュー (String)
FORECAST_VIEW 需要予測ビュー (String)
WORK_SCHED_VIEW 作業計画ビュー (String)
PRT_VIEW 生産資源/治工具 (PRT) ビュー (String)
STORAGE_VIEW 保管ビュー (String)
WAREHOUSE_VIEW 倉庫管理ビュー (String)
QUALITY_VIEW 品質管理ビュー (String)
ACCOUNT_VIEW 会計ビュー (String)
COST_VIEW 原価計算ビュー (String)
ROTATION_DATE 原価計算ビュー (String)
ORIGINAL_BATCH_FLAG 元ロット管理区分 (String)
ORIGINAL_BATCH_REF_MATERIAL 元ロットの 参照品目 (String)

取得した品目データ (プラントレベル)情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の品目データ (プラントレベル)の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の品目データ (プラントレベル)の「品目コード」
[idx]["PLANT"]　→　配列内のidx番目の品目データ (プラントレベル)の「プラント」
[idx]["DEL_FLAG"]　→　配列内のidx番目の品目データ (プラントレベル)の「プラントレベルでの品目削除フラグ」
[idx]["ABC_ID"]　→　配列内のidx番目の品目データ (プラントレベル)の「ABC 区分」
[idx]["CRIT_PART"]　→　配列内のidx番目の品目データ (プラントレベル)の「区分: 重要品目」
[idx]["PUR_GROUP"]　→　配列内のidx番目の品目データ (プラントレベル)の「購買グループ」
[idx]["ISSUE_UNIT"]　→　配列内のidx番目の品目データ (プラントレベル)の「出庫単位」
[idx]["ISSUE_UNIT_ISO"]　→　配列内のidx番目の品目データ (プラントレベル)の「ISO コードでの出庫単位」
[idx]["MRPPROFILE"]　→　配列内のidx番目の品目データ (プラントレベル)の「品目: MRP プロファイル」
[idx]["MRP_TYPE"]　→　配列内のidx番目の品目データ (プラントレベル)の「MRP タイプ」
[idx]["MRP_CTRLER"]　→　配列内のidx番目の品目データ (プラントレベル)の「MRP 管理者」
[idx]["PLND_DELRY"]　→　配列内のidx番目の品目データ (プラントレベル)の「予定納入時間 (単位: 日)」
[idx]["GR_PR_TIME"]　→　配列内のidx番目の品目データ (プラントレベル)の「入庫処理日数」
[idx]["PERIOD_IND"]　→　配列内のidx番目の品目データ (プラントレベル)の「期間区分」
[idx]["ASSY_SCRAP"]　→　配列内のidx番目の品目データ (プラントレベル)の「組立不良率」
[idx]["LOTSIZEKEY"]　→　配列内のidx番目の品目データ (プラントレベル)の「ロットサイズ (品目計画)」
[idx]["PROC_TYPE"]　→　配列内のidx番目の品目データ (プラントレベル)の「調達タイプ」
[idx]["SPPROCTYPE"]　→　配列内のidx番目の品目データ (プラントレベル)の「特殊調達タイプ」
[idx]["REORDER_PT"]　→　配列内のidx番目の品目データ (プラントレベル)の「発注点」
[idx]["SAFETY_STK"]　→　配列内のidx番目の品目データ (プラントレベル)の「安全在庫」
[idx]["MINLOTSIZE"]　→　配列内のidx番目の品目データ (プラントレベル)の「最小ロットサイズ」
[idx]["MAXLOTSIZE"]　→　配列内のidx番目の品目データ (プラントレベル)の「最大ロットサイズ」
[idx]["FIXED_LOT"]　→　配列内のidx番目の品目データ (プラントレベル)の「固定ロットサイズ」
[idx]["ROUND_VAL"]　→　配列内のidx番目の品目データ (プラントレベル)の「購買発注数量の丸め数量」
[idx]["MAX_STOCK"]　→　配列内のidx番目の品目データ (プラントレベル)の「最大在庫レベル」
[idx]["ORD_COSTS"]　→　配列内のidx番目の品目データ (プラントレベル)の「発注原価 (BAPI インタフェース)」
[idx]["DEP_REQ_ID"]　→　配列内のidx番目の品目データ (プラントレベル)の「個別所要量と包括所要量に対する従属所要量区分」
[idx]["STOR_COSTS"]　→　配列内のidx番目の品目データ (プラントレベル)の「保管経費区分」
[idx]["ALT_BOM_ID"]　→　配列内のidx番目の品目データ (プラントレベル)の「代替 BOM 選択の方法」
[idx]["DISCONTINU"]　→　配列内のidx番目の品目データ (プラントレベル)の「打切区分」
[idx]["EFF_O_DAY"]　→　配列内のidx番目の品目データ (プラントレベル)の「有効終了日」
[idx]["FOLLOW_UP"]　→　配列内のidx番目の品目データ (プラントレベル)の「フォローアップ品目」
[idx]["GRP_REQMTS"]　→　配列内のidx番目の品目データ (プラントレベル)の「区分: 所要量グループ化」
[idx]["MIXED_MRP"]　→　配列内のidx番目の品目データ (プラントレベル)の「二重 MRP 区分」
[idx]["SM_KEY"]　→　配列内のidx番目の品目データ (プラントレベル)の「日程計画余裕キー」
[idx]["BACKFLUSH"]　→　配列内のidx番目の品目データ (プラントレベル)の「区分: バックフラッシュ」
[idx]["PRODUCTION_SCHEDULER"]　→　配列内のidx番目の品目データ (プラントレベル)の「製造計画担当」
[idx]["PROC_TIME"]　→　配列内のidx番目の品目データ (プラントレベル)の「処理時間」
[idx]["SETUPTIME"]　→　配列内のidx番目の品目データ (プラントレベル)の「段取時間と片付け時間」
[idx]["INTEROP"]　→　配列内のidx番目の品目データ (プラントレベル)の「移動時間」
[idx]["BASE_QTY"]　→　配列内のidx番目の品目データ (プラントレベル)の「基本数量」
[idx]["INHSEPRODT"]　→　配列内のidx番目の品目データ (プラントレベル)の「内製日数」
[idx]["STGEPERIOD"]　→　配列内のidx番目の品目データ (プラントレベル)の「最長保管期間」
[idx]["STGE_PD_UN"]　→　配列内のidx番目の品目データ (プラントレベル)の「最長保管期間の単位」
[idx]["STGE_PD_UN_ISO"]　→　配列内のidx番目の品目データ (プラントレベル)の「ISO コードでの最長保管期間単位」
[idx]["OVER_TOL"]　→　配列内のidx番目の品目データ (プラントレベル)の「過剰納入許容範囲リミット」
[idx]["UNLIMITED"]　→　配列内のidx番目の品目データ (プラントレベル)の「区分: 無制限過剰納入可能」
[idx]["UNDER_TOL"]　→　配列内のidx番目の品目データ (プラントレベル)の「不足納入許容範囲リミット」
[idx]["REPLENTIME"]　→　配列内のidx番目の品目データ (プラントレベル)の「補充リードタイム合計 (稼動日数)」
[idx]["REPLACE_PT"]　→　配列内のidx番目の品目データ (プラントレベル)の「取替部品」
[idx]["IND_POST_TO_INSP_STOCK"]　→　配列内のidx番目の品目データ (プラントレベル)の「品質検査中在庫への転記」
[idx]["CTRL_KEY"]　→　配列内のidx番目の品目データ (プラントレベル)の「調達における品質管理の管理キー」
[idx]["DOC_REQD"]　→　配列内のidx番目の品目データ (プラントレベル)の「文書必須フラグ」
[idx]["LOADINGGRP"]　→　配列内のidx番目の品目データ (プラントレベル)の「積載グループ」
[idx]["BATCH_MGMT"]　→　配列内のidx番目の品目データ (プラントレベル)の「ロット管理所要量区分」
[idx]["QUOTAUSAGE"]　→　配列内のidx番目の品目データ (プラントレベル)の「供給量割当の使用」
[idx]["SERV_LEVEL"]　→　配列内のidx番目の品目データ (プラントレベル)の「サービスレベル」
[idx]["SPLIT_IND"]　→　配列内のidx番目の品目データ (プラントレベル)の「分割区分」
[idx]["AVAILCHECK"]　→　配列内のidx番目の品目データ (プラントレベル)の「利用可能在庫確認の確認グループ」
[idx]["FY_VARIANT"]　→　配列内のidx番目の品目データ (プラントレベル)の「会計年度バリアント」
[idx]["CORR_FACT"]　→　配列内のidx番目の品目データ (プラントレベル)の「区分: 修正係数を需要予測値計算に使用」
[idx]["SETUP_TIME"]　→　配列内のidx番目の品目データ (プラントレベル)の「出荷準備時間」
[idx]["BASE_QTY_PLAN"]　→　配列内のidx番目の品目データ (プラントレベル)の「出荷の能力計画のための基本数量」
[idx]["SHIP_PROC_TIME"]　→　配列内のidx番目の品目データ (プラントレベル)の「出荷処理時間」
[idx]["SUP_SOURCE"]　→　配列内のidx番目の品目データ (プラントレベル)の「供給元」
[idx]["AUTO_P_ORD"]　→　配列内のidx番目の品目データ (プラントレベル)の「区分: "購買発注自動生成"」
[idx]["SOURCELIST"]　→　配列内のidx番目の品目データ (プラントレベル)の「区分: 供給元一覧必須」
[idx]["COMM_CODE"]　→　配列内のidx番目の品目データ (プラントレベル)の「貿易: 統計品目コード/輸入コード番号」
[idx]["COUNTRYORI"]　→　配列内のidx番目の品目データ (プラントレベル)の「品目の原産国」
[idx]["COUNTRYORI_ISO"]　→　配列内のidx番目の品目データ (プラントレベル)の「ISO コードでの品目原産国」
[idx]["REGIONORIG"]　→　配列内のidx番目の品目データ (プラントレベル)の「品目の原産地 (非特恵対象地区の原産)」
[idx]["COMM_CO_UN"]　→　配列内のidx番目の品目データ (プラントレベル)の「物品コード (貿易) の数量単位」
[idx]["COMM_CO_UN_ISO"]　→　配列内のidx番目の品目データ (プラントレベル)の「ISO コードによる物品コード (貿易管理) の数量単位」
[idx]["EXPIMPGRP"]　→　配列内のidx番目の品目データ (プラントレベル)の「輸出/輸入品目グループ」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の品目データ (プラントレベル)の「利益センタ」
[idx]["PPC_PL_CAL"]　→　配列内のidx番目の品目データ (プラントレベル)の「PPC 計画カレンダ」
[idx]["REP_MANUF"]　→　配列内のidx番目の品目データ (プラントレベル)の「区分: 繰返生産許可」
[idx]["PL_TI_FNCE"]　→　配列内のidx番目の品目データ (プラントレベル)の「計画タイムフェンス」
[idx]["CONSUMMODE"]　→　配列内のidx番目の品目データ (プラントレベル)の「消費モード」
[idx]["BWD_CONS"]　→　配列内のidx番目の品目データ (プラントレベル)の「消費期間: 後方」
[idx]["FWD_CONS"]　→　配列内のidx番目の品目データ (プラントレベル)の「消費期間: 前方」
[idx]["ALTERNATIVE_BOM"]　→　配列内のidx番目の品目データ (プラントレベル)の「代替 BOM」
[idx]["BOM_USAGE"]　→　配列内のidx番目の品目データ (プラントレベル)の「BOM 用途」
[idx]["PLANLISTGRP"]　→　配列内のidx番目の品目データ (プラントレベル)の「タスクリストグループのキー」
[idx]["PLANLISTCNT"]　→　配列内のidx番目の品目データ (プラントレベル)の「グループカウンタ」
[idx]["LOT_SIZE"]　→　配列内のidx番目の品目データ (プラントレベル)の「原価計算ロットサイズ」
[idx]["SPECPROCTY"]　→　配列内のidx番目の品目データ (プラントレベル)の「原価計算の特殊調達タイプ」
[idx]["PROD_UNIT"]　→　配列内のidx番目の品目データ (プラントレベル)の「製造単位」
[idx]["PROD_UNIT_ISO"]　→　配列内のidx番目の品目データ (プラントレベル)の「製造単位 (ISO コード)」
[idx]["ISS_ST_LOC"]　→　配列内のidx番目の品目データ (プラントレベル)の「出庫保管場所」
[idx]["MRP_GROUP"]　→　配列内のidx番目の品目データ (プラントレベル)の「MRP グループ」
[idx]["COMP_SCRAP"]　→　配列内のidx番目の品目データ (プラントレベル)の「構成品目不良率」
[idx]["CERT_TYPE"]　→　配列内のidx番目の品目データ (プラントレベル)の「証明書タイプ」
[idx]["CYCLE_TIME"]　→　配列内のidx番目の品目データ (プラントレベル)の「タクトタイム」
[idx]["COVPROFILE"]　→　配列内のidx番目の品目データ (プラントレベル)の「在庫日数プロファイル」
[idx]["CC_PH_INV"]　→　配列内のidx番目の品目データ (プラントレベル)の「循環棚卸の実地棚卸区分」
[idx]["VARIANCE_KEY"]　→　配列内のidx番目の品目データ (プラントレベル)の「差異キー」
[idx]["SERNO_PROF"]　→　配列内のidx番目の品目データ (プラントレベル)の「シリアル番号プロファイル」
[idx]["REPMANPROF"]　→　配列内のidx番目の品目データ (プラントレベル)の「繰返生産プロファイル」
[idx]["NEG_STOCKS"]　→　配列内のidx番目の品目データ (プラントレベル)の「プラントにおけるマイナス在庫許可」
[idx]["QM_RGMTS"]　→　配列内のidx番目の品目データ (プラントレベル)の「仕入先の必須 QM システム」
[idx]["PLNG_CYCLE"]　→　配列内のidx番目の品目データ (プラントレベル)の「計画サイクル」
[idx]["ROUND_PROF"]　→　配列内のidx番目の品目データ (プラントレベル)の「丸めプロファイル」
[idx]["REFMATCONS"]　→　配列内のidx番目の品目データ (プラントレベル)の「消費参照品目」
[idx]["D_TO_REF_M"]　→　配列内のidx番目の品目データ (プラントレベル)の「消費データ参照の有効終了日」
[idx]["MULT_REF_M"]　→　配列内のidx番目の品目データ (プラントレベル)の「消費データ参照品目の乗数」
[idx]["AUTO_RESET"]　→　配列内のidx番目の品目データ (プラントレベル)の「予測モデル自動リセット」
[idx]["EX_CERT_ID"]　→　配列内のidx番目の品目データ (プラントレベル)の「法令管理: 認定書区分」
[idx]["EX_CERT_NO_NEW"]　→　配列内のidx番目の品目データ (プラントレベル)の「非該当証明書番号 - 法令管理」
[idx]["EX_CERT_DT"]　→　配列内のidx番目の品目データ (プラントレベル)の「非該当証明書発行日」
[idx]["MILIT_ID"]　→　配列内のidx番目の品目データ (プラントレベル)の「ID: 武器」
[idx]["INSP_INT"]　→　配列内のidx番目の品目データ (プラントレベル)の「次回再検査までの間隔」
[idx]["CO_PRODUCT"]　→　配列内のidx番目の品目データ (プラントレベル)の「区分: 連産品としても使用可能な品目」
[idx]["PLAN_STRGP"]　→　配列内のidx番目の品目データ (プラントレベル)の「計画方針グループ」
[idx]["SLOC_EXPRC"]　→　配列内のidx番目の品目データ (プラントレベル)の「外部調達の初期保管場所」
[idx]["BULK_MAT"]　→　配列内のidx番目の品目データ (プラントレベル)の「区分: バルク品目」
[idx]["CC_FIXED"]　→　配列内のidx番目の品目データ (プラントレベル)の「循環棚卸区分固定」
[idx]["DETERM_GRP"]　→　配列内のidx番目の品目データ (プラントレベル)の「在庫決定グループ」
[idx]["QM_AUTHGRP"]　→　配列内のidx番目の品目データ (プラントレベル)の「QM における活動の品目権限グループ」
[idx]["TASK_LIST_TYPE"]　→　配列内のidx番目の品目データ (プラントレベル)の「タスクリストタイプ」
[idx]["PUR_STATUS"]　→　配列内のidx番目の品目データ (プラントレベル)の「プラント特有品目ステータス」
[idx]["PRODPROF"]　→　配列内のidx番目の品目データ (プラントレベル)の「製造計画プロファイル」
[idx]["SAFTY_T_ID"]　→　配列内のidx番目の品目データ (プラントレベル)の「安全時間区分（安全リードタイムあり/なし)」
[idx]["SAFETYTIME"]　→　配列内のidx番目の品目データ (プラントレベル)の「安全時間 (稼動日数)」
[idx]["PLORD_CTRL"]　→　配列内のidx番目の品目データ (プラントレベル)の「アクション管理: 計画手配処理」
[idx]["BATCHENTRY"]　→　配列内のidx番目の品目データ (プラントレベル)の「製造/プロセス指図でのロット入力設定」
[idx]["PVALIDFROM"]　→　配列内のidx番目の品目データ (プラントレベル)の「プラント品目ステータス有効期間開始日」
[idx]["MATFRGTGRP"]　→　配列内のidx番目の品目データ (プラントレベル)の「品目運賃グループ」
[idx]["PRODVERSCS"]　→　配列内のidx番目の品目データ (プラントレベル)の「原価計算を行う製造バージョン」
[idx]["MAT_CFOP"]　→　配列内のidx番目の品目データ (プラントレベル)の「品目 CFOP カテゴリ」
[idx]["EU_LIST_NO"]　→　配列内のidx番目の品目データ (プラントレベル)の「CAP: CAP 製品一覧番号」
[idx]["EU_MAT_GRP"]　→　配列内のidx番目の品目データ (プラントレベル)の「EEC 農産物政策: CAP 生産品グループ - 貿易」
[idx]["CAS_NO"]　→　配列内のidx番目の品目データ (プラントレベル)の「CAS 番号： 薬事品目 - 貿易」
[idx]["PRODCOM_NO"]　→　配列内のidx番目の品目データ (プラントレベル)の「生産統計: 貿易における PRODCOM コード」
[idx]["CTRL_CODE"]　→　配列内のidx番目の品目データ (プラントレベル)の「貿易: 消費税の管理コード」
[idx]["JIT_RELVT"]　→　配列内のidx番目の品目データ (プラントレベル)の「区分: JIT 納入日程の関連明細」
[idx]["MAT_GRP_TRANS"]　→　配列内のidx番目の品目データ (プラントレベル)の「段取替えマトリクスに対する品目のグループ」
[idx]["HANDLG_GRP"]　→　配列内のidx番目の品目データ (プラントレベル)の「ワークロード計算のロジスティクス処理グループ」
[idx]["SUPPLY_AREA"]　→　配列内のidx番目の品目データ (プラントレベル)の「品目マスタレコードで提案される供給場所」
[idx]["FAIR_SHARE_RULE"]　→　配列内のidx番目の品目データ (プラントレベル)の「均等配賦ルール」
[idx]["PUSH_DISTRIB"]　→　配列内のidx番目の品目データ (プラントレベル)の「区分: プッシュ配賦」
[idx]["DEPLOY_HORIZ"]　→　配列内のidx番目の品目データ (プラントレベル)の「供給分配期間の日数」
[idx]["MIN_LOT_SIZE"]　→　配列内のidx番目の品目データ (プラントレベル)の「需要と供給を一致させるための最小ロットサイズ」
[idx]["MAX_LOT_SIZE"]　→　配列内のidx番目の品目データ (プラントレベル)の「需要と供給を一致させるための最大ロットサイズ」
[idx]["FIX_LOT_SIZE"]　→　配列内のidx番目の品目データ (プラントレベル)の「需要供給の一致に対する固定ロットサイズ」
[idx]["LOT_INCREMENT"]　→　配列内のidx番目の品目データ (プラントレベル)の「需要と供給を一致させるためのロットサイズ増分」
[idx]["PROD_CONV_TYPE"]　→　配列内のidx番目の品目データ (プラントレベル)の「生産値の変換タイプ」
[idx]["DISTR_PROF"]　→　配列内のidx番目の品目データ (プラントレベル)の「サイトの商品の物流プロファイル」
[idx]["PERIOD_PROFILE_SAFETY_TIME"]　→　配列内のidx番目の品目データ (プラントレベル)の「安全時間の期間プロファイル」
[idx]["FXD_PRICE"]　→　配列内のidx番目の品目データ (プラントレベル)の「固定価格連産品」
[idx]["AVAIL_CHECK_ALL_PROJ_SEGMENTS"]　→　配列内のidx番目の品目データ (プラントレベル)の「プロジェクト間品目区分」
[idx]["OVERALLPRF"]　→　配列内のidx番目の品目データ (プラントレベル)の「指図変更管理の全体プロファイル」
[idx]["MRP_RELEVANCY_DEP_REQUIREMENTS"]　→　配列内のidx番目の品目データ (プラントレベル)の「従属所要量と MRP の関連性」
[idx]["MIN_SAFETY_STK"]　→　配列内のidx番目の品目データ (プラントレベル)の「最小安全在庫」
[idx]["NO_COSTING"]　→　配列内のidx番目の品目データ (プラントレベル)の「原価計算なし」
[idx]["UNIT_GROUP"]　→　配列内のidx番目の品目データ (プラントレベル)の「数量単位グループ」
[idx]["FOLLOW_UP_EXTERNAL"]　→　配列内のidx番目の品目データ (プラントレベル)の「項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)」
[idx]["FOLLOW_UP_GUID"]　→　配列内のidx番目の品目データ (プラントレベル)の「項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)」
[idx]["FOLLOW_UP_VERSION"]　→　配列内のidx番目の品目データ (プラントレベル)の「項目 FOLLOW_UP のバージョン番号 (今後のリリースで開発)」
[idx]["REFMATCONS_EXTERNAL"]　→　配列内のidx番目の品目データ (プラントレベル)の「項目 REFMATCONS の品目コード (長) (今後のリリースで開発)」
[idx]["REFMATCONS_GUID"]　→　配列内のidx番目の品目データ (プラントレベル)の「項目 REFMATCONS の外部 GUID (今後のリリースで開発)」
[idx]["REFMATCONS_VERSION"]　→　配列内のidx番目の品目データ (プラントレベル)の「項目 REFMATCONS のバージョン番号 (今後のリリースで開発)」
[idx]["SALES_VIEW"]　→　配列内のidx番目の品目データ (プラントレベル)の「販売ビュー」
[idx]["PURCH_VIEW"]　→　配列内のidx番目の品目データ (プラントレベル)の「購買管理ビュー」
[idx]["MRP_VIEW"]　→　配列内のidx番目の品目データ (プラントレベル)の「資材所要量計画 (MRP) ビュー」
[idx]["FORECAST_VIEW"]　→　配列内のidx番目の品目データ (プラントレベル)の「需要予測ビュー」
[idx]["WORK_SCHED_VIEW"]　→　配列内のidx番目の品目データ (プラントレベル)の「作業計画ビュー」
[idx]["PRT_VIEW"]　→　配列内のidx番目の品目データ (プラントレベル)の「生産資源/治工具 (PRT) ビュー」
[idx]["STORAGE_VIEW"]　→　配列内のidx番目の品目データ (プラントレベル)の「保管ビュー」
[idx]["WAREHOUSE_VIEW"]　→　配列内のidx番目の品目データ (プラントレベル)の「倉庫管理ビュー」
[idx]["QUALITY_VIEW"]　→　配列内のidx番目の品目データ (プラントレベル)の「品質管理ビュー」
[idx]["ACCOUNT_VIEW"]　→　配列内のidx番目の品目データ (プラントレベル)の「会計ビュー」
[idx]["COST_VIEW"]　→　配列内のidx番目の品目データ (プラントレベル)の「原価計算ビュー」
[idx]["ROTATION_DATE"]　→　配列内のidx番目の品目データ (プラントレベル)の「原価計算ビュー」
[idx]["ORIGINAL_BATCH_FLAG"]　→　配列内のidx番目の品目データ (プラントレベル)の「元ロット管理区分」
[idx]["ORIGINAL_BATCH_REF_MATERIAL"]　→　配列内のidx番目の品目データ (プラントレベル)の「元ロットの参照品目」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPrtDataList

Array getPrtDataList ()

品目マスタの生産資源/治工具 (PRT) 項目を取得します。
返却値
Array 品目マスタの生産資源/治工具 (PRT) 項目

品目マスタの生産資源/治工具 (PRT) 項目情報オブジェクトの構成は以下のとおりです。
品目マスタの生産資源/治工具 (PRT) 項目
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
PLANT プラント (String)
CREATE_LOAD_RECS 区分: 生産資源/治工具の 負荷レコード登録 (String)
CTRL_KEY 生産資源/治工具管理の管理キー (String)
CTRL_KEY_NO_CHG 管理キーは変更できません (String)
GRP_KEY_1 生産資源/治工具のグループキー 1 (String)
GRP_KEY_2 生産資源/治工具のグループキー 2 (String)
PRT_USAGE 生産資源/治工具用途 (String)
STD_TEXT_KEY 生産資源/治工具の 標準テキストキー (String)
REF_KEY_NO_CHG 参照キーは変更できません (String)
START_REF_DATE 生産資源/治工具使用開始の 参照日付 (String)
ST_REF_DATE_NO_CHG 開始参照日付は 変更できません (String)
START_OFFSET 生産資源/治工具使用の 開始オフセット (String)
START_OFFSET_UNIT 生産資源/治工具使用開始の オフセット単位 (String)
START_OFFSET_UNIT_ISO PRT 用途開始決定の 間隔時間単位 (ISO) (String)
START_OFFSET_NO_CHG 開始オフセットは 変更できません (String)
END_REF_DATE 生産資源/治工具使用終了日の 参照日付 (String)
END_REF_DATE_NO_CHG 終了参照日付は 変更できません (String)
END_OFFSET 生産資源/治工具用途の終了オフセット (String)
END_OFFSET_UNIT 生産資源/治工具使用終了 オフセット単位 (String)
END_OFFSET_UNIT_ISO PRT 用途終了決定の 間隔時間単位 (ISO) (String)
END_OFFSET_NO_CHG 終了オフセットは 変更できません (String)
FORMULA_TOT_QTY 生産資源/治工具の合計数量の 計算式 (String)
FORMULA_TOT_QTY_NO_CHG 合計数量の計算式は 変更できません (String)
FORMULA_TOT_USAGE 生産資源/治工具の総用途値 の計算式 (String)
FORMULA_TOT_USAGE_NO_CHG すべての用途値を 計算する計算式は変更できません (String)

取得した品目マスタの生産資源/治工具 (PRT) 項目情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「品目コード」
[idx]["PLANT"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「プラント」
[idx]["CREATE_LOAD_RECS"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「区分: 生産資源/治工具の負荷レコード登録」
[idx]["CTRL_KEY"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具管理の管理キー」
[idx]["CTRL_KEY_NO_CHG"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「管理キーは変更できません」
[idx]["GRP_KEY_1"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具のグループキー 1」
[idx]["GRP_KEY_2"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具のグループキー 2」
[idx]["PRT_USAGE"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具用途」
[idx]["STD_TEXT_KEY"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具の標準テキストキー」
[idx]["REF_KEY_NO_CHG"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「参照キーは変更できません」
[idx]["START_REF_DATE"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具使用開始の参照日付」
[idx]["ST_REF_DATE_NO_CHG"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「開始参照日付は変更できません」
[idx]["START_OFFSET"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具使用の開始オフセット」
[idx]["START_OFFSET_UNIT"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具使用開始のオフセット単位」
[idx]["START_OFFSET_UNIT_ISO"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「PRT 用途開始決定の間隔時間単位 (ISO)」
[idx]["START_OFFSET_NO_CHG"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「開始オフセットは変更できません」
[idx]["END_REF_DATE"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具使用終了日の参照日付」
[idx]["END_REF_DATE_NO_CHG"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「終了参照日付は変更できません」
[idx]["END_OFFSET"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具用途の終了オフセット」
[idx]["END_OFFSET_UNIT"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具使用終了オフセット単位」
[idx]["END_OFFSET_UNIT_ISO"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「PRT 用途終了決定の間隔時間単位 (ISO)」
[idx]["END_OFFSET_NO_CHG"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「終了オフセットは変更できません」
[idx]["FORMULA_TOT_QTY"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具の合計数量の計算式」
[idx]["FORMULA_TOT_QTY_NO_CHG"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「合計数量の計算式は変更できません」
[idx]["FORMULA_TOT_USAGE"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「生産資源/治工具の総用途値の計算式」
[idx]["FORMULA_TOT_USAGE_NO_CHG"]　→　配列内のidx番目の品目マスタの生産資源/治工具 (PRT) 項目の「すべての用途値を計算する計算式は変更できません」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getReturnMessagesList

Array getReturnMessagesList ()

リターンパラメータ BAPIRET2 の代替構造のデータ転送を取得します。
返却値
Array リターンパラメータ BAPIRET2 の代替構造

リターンパラメータ BAPIRET2 の代替構造情報オブジェクトの構成は以下のとおりです。
リターンパラメータ BAPIRET2 の代替構造情報
オブジェクト
(Object)
TYPE メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了 (String)
ID メッセージ、メッセージクラス (String)
NUMBER メッセージ、メッセージ番号 (String)
MESSAGE メッセージテキスト (String)
LOG_NO アプリケーションログ: ログ番号 (String)
LOG_MSG_NO アプリケーションログ: メッセージシリアル番号 (String)
MESSAGE_V1 メッセージ、メッセージ変数 (String)
MESSAGE_V2 メッセージ、メッセージ変数 (String)
MESSAGE_V3 メッセージ、メッセージ変数 (String)
MESSAGE_V4 メッセージ、メッセージ変数 (String)
PARAMETER パラメータ名 (String)
ROW パラメータの行 (String)
FIELD パラメータの項目 (String)
SYSTEM メッセージが発行された論理システム (String)

取得したリターンパラメータ BAPIRET2 の代替構造情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["TYPE"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了」
[idx]["ID"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「メッセージ、メッセージクラス」
[idx]["NUMBER"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「メッセージ、メッセージ番号」
[idx]["MESSAGE"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「メッセージテキスト」
[idx]["LOG_NO"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「アプリケーションログ: ログ番号」
[idx]["LOG_MSG_NO"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「アプリケーションログ: メッセージシリアル番号」
[idx]["MESSAGE_V1"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「メッセージ、メッセージ変数」
[idx]["MESSAGE_V2"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「メッセージ、メッセージ変数」
[idx]["MESSAGE_V3"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「メッセージ、メッセージ変数」
[idx]["MESSAGE_V4"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「メッセージ、メッセージ変数」
[idx]["PARAMETER"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「パラメータ名」
[idx]["ROW"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「パラメータの行」
[idx]["FIELD"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「パラメータの項目」
[idx]["SYSTEM"]　→　配列内のidx番目のリターンパラメータ BAPIRET2 の代替構造の「メッセージが発行された論理システム」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getSalesDataList

Array getSalesDataList ()

販売データを取得します。
返却値
Array 販売データ

販売データ情報オブジェクトの構成は以下のとおりです。
販売データ情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
SALES_ORG 販売組織 (String)
DISTR_CHAN 流通チャネル (String)
DEL_FLAG 区分: 流通チャネルレベルでの 品目削除フラグ (String)
MATL_STATS 品目統計グループ (String)
REBATE_GRP 取引量リベートグループ (String)
COMM_GROUP 手数料グループ (String)
CASH_DISC 現金値引区分 (String)
SAL_STATUS 販売ビューからの品目ステータス (String)
VALID_FROM 流通チェーン別品目ステータスの 有効期間開始日 (String)
MIN_ORDER 基本数量単位での最小受注数量 (String)
MIN_DELY 納品書処理時の最小納入数量 (String)
MIN_MTO 受注製造品最少受注数量 (String)
DELY_UNIT 出荷単位 (String)
DELY_UOM 出荷数量単位 (String)
DELY_UOM_ISO ISO コードでの出荷単位の 数量単位 (String)
SALES_UNIT 販売単位 (String)
SALES_UNIT_ISO ISO コードによる販売単位 (String)
ITEM_CAT 品目マスタの明細カテゴリグループ (String)
DELYG_PLNT 出荷プラント (String)
PROD_HIER 品目階層 (String)
PR_REF_MAT 価格設定参照品目 (String)
MAT_PR_GRP 品目価格設定グループ (String)
ACCT_ASSGT 品目の勘定設定グループ (String)
MATL_GRP_1 品目グループ 1 (String)
MATL_GRP_2 品目グループ 2 (String)
MATL_GRP_3 品目グループ 3 (String)
MATL_GRP_4 品目グループ 4 (String)
MATL_GRP_5 品目グループ 5 (String)
PROD_ATT_1 ID: 製品属性 1 (String)
PROD_ATT_2 品目属性 2 用 ID (String)
PROD_ATT_3 品目属性 3 用 ID (String)
PROD_ATT_4 品目属性 4 用 ID (String)
PROD_ATT_5 品目属性 5 用 ID (String)
PROD_ATT_6 品目属性 6 の ID (String)
PROD_ATT_7 品目属性 7 用 ID (String)
PROD_ATT_8 品目属性 8 用 ID (String)
PROD_ATT_9 品目属性 9 (String)
PROD_ATT10 品目属性 10 用 ID (String)
ROUND_PROF 丸めプロファイル (String)
VAR_SALES_UN 可変販売単位の使用不可 (String)
UNIT_GROUP 数量単位グループ (String)
PR_REF_MAT_EXTERNAL 項目 PR_REF_MAT の 品目コード (長) (今後のリリースで開発) (String)
PR_REF_MAT_GUID 項目 PR_REF_MAT の 外部 GUID (今後のリリースで開発) (String)
PR_REF_MAT_VERSION 項目 PR_REF_MAT の バージョン番号 (今後のリリースで開発) (String)

取得した販売データ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の販売データの「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の販売データの「品目コード」
[idx]["SALES_ORG"]　→　配列内のidx番目の販売データの「販売組織」
[idx]["DISTR_CHAN"]　→　配列内のidx番目の販売データの「流通チャネル」
[idx]["DEL_FLAG"]　→　配列内のidx番目の販売データの 「区分: 流通チャネルレベルでの品目削除フラグ」
[idx]["MATL_STATS"]　→　配列内のidx番目の販売データの「品目統計グループ」
[idx]["REBATE_GRP"]　→　配列内のidx番目の販売データの「取引量リベートグループ」
[idx]["COMM_GROUP"]　→　配列内のidx番目の販売データの「手数料グループ」
[idx]["CASH_DISC"]　→　配列内のidx番目の販売データの「現金値引区分」
[idx]["SAL_STATUS"]　→　配列内のidx番目の販売データの「販売ビューからの品目ステータス」
[idx]["VALID_FROM"]　→　配列内のidx番目の販売データの 「流通チェーン別品目ステータスの有効期間開始日」
[idx]["MIN_ORDER"]　→　配列内のidx番目の販売データの「基本数量単位での最小受注数量」
[idx]["MIN_DELY"]　→　配列内のidx番目の販売データの「納品書処理時の最小納入数量」
[idx]["MIN_MTO"]　→　配列内のidx番目の販売データの「受注製造品最少受注数量」
[idx]["DELY_UNIT"]　→　配列内のidx番目の販売データの「出荷単位」
[idx]["DELY_UOM"]　→　配列内のidx番目の販売データの「出荷数量単位」
[idx]["DELY_UOM_ISO"]　→　配列内のidx番目の販売データの 「ISO コードでの出荷単位の数量単位」
[idx]["SALES_UNIT"]　→　配列内のidx番目の販売データの「販売単位」
[idx]["SALES_UNIT_ISO"]　→　配列内のidx番目の販売データの「ISO コードによる販売単位」
[idx]["ITEM_CAT"]　→　配列内のidx番目の販売データの「品目マスタの明細カテゴリグループ」
[idx]["DELYG_PLNT"]　→　配列内のidx番目の販売データの「出荷プラント」
[idx]["PROD_HIER"]　→　配列内のidx番目の販売データの「品目階層」
[idx]["PR_REF_MAT"]　→　配列内のidx番目の販売データの「価格設定参照品目」
[idx]["MAT_PR_GRP"]　→　配列内のidx番目の販売データの「品目価格設定グループ」
[idx]["ACCT_ASSGT"]　→　配列内のidx番目の販売データの「品目の勘定設定グループ」
[idx]["MATL_GRP_1"]　→　配列内のidx番目の販売データの「品目グループ 1」
[idx]["MATL_GRP_2"]　→　配列内のidx番目の販売データの「品目グループ 2」
[idx]["MATL_GRP_3"]　→　配列内のidx番目の販売データの「品目グループ 3」
[idx]["MATL_GRP_4"]　→　配列内のidx番目の販売データの「品目グループ 4」
[idx]["MATL_GRP_5"]　→　配列内のidx番目の販売データの「品目グループ 5」
[idx]["PROD_ATT_1"]　→　配列内のidx番目の販売データの「ID: 製品属性 1」
[idx]["PROD_ATT_2"]　→　配列内のidx番目の販売データの「品目属性 2 用 ID」
[idx]["PROD_ATT_3"]　→　配列内のidx番目の販売データの「品目属性 3 用 ID」
[idx]["PROD_ATT_4"]　→　配列内のidx番目の販売データの「品目属性 4 用 ID」
[idx]["PROD_ATT_5"]　→　配列内のidx番目の販売データの「品目属性 5 用 ID」
[idx]["PROD_ATT_6"]　→　配列内のidx番目の販売データの「品目属性 6 の ID」
[idx]["PROD_ATT_7"]　→　配列内のidx番目の販売データの「品目属性 7 用 ID」
[idx]["PROD_ATT_8"]　→　配列内のidx番目の販売データの「品目属性 8 用 ID」
[idx]["PROD_ATT_9"]　→　配列内のidx番目の販売データの「品目属性 9」
[idx]["PROD_ATT10"]　→　配列内のidx番目の販売データの「品目属性 10 用 ID」
[idx]["ROUND_PROF"]　→　配列内のidx番目の販売データの「丸めプロファイル」
[idx]["VAR_SALES_UN"]　→　配列内のidx番目の販売データの「可変販売単位の使用不可」
[idx]["UNIT_GROUP"]　→　配列内のidx番目の販売データの「数量単位グループ」
[idx]["PR_REF_MAT_EXTERNAL"]　→　配列内のidx番目の販売データの 「項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)」
[idx]["PR_REF_MAT_GUID"]　→　配列内のidx番目の販売データの 「項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)」
[idx]["PR_REF_MAT_VERSION"]　→　配列内のidx番目の販売データの 「項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getStorageLocationDataList

Array getStorageLocationDataList ()

品目データ (保管場所レベル)を取得します。
返却値
Array 品目データ (保管場所レベル)

品目データ (保管場所レベル)情報オブジェクトの構成は以下のとおりです。
品目データ (保管場所レベル)
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
PLANT プラント (String)
STGE_LOC 保管場所 (String)
DEL_FLAG 保管場所レベルでの品目削除フラグ (String)
MRP_IND 保管場所 MRP 区分 (String)
SPEC_PROC 保管場所レベルでの特殊調達タイプ (String)
REORDER_PT 保管場所 MRP に対する発注点 (String)
REPL_QTY 保管場所 MRP に対する補充数量 (String)
STGE_BIN 棚番 (String)
PICKG_AREA 簡易倉庫管理のピッキングエリア (String)
INV_CORR_FAC 在庫修正係数 (String)
MRP_VIEW 資材所要量計画 (MRP) ビュー (String)
STORAGE_VIEW 保管ビュー (String)

取得した品目データ (保管場所レベル)情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の品目データ (保管場所レベル)の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の品目データ (保管場所レベル)の「品目コード」
[idx]["PLANT"]　→　配列内のidx番目の品目データ (保管場所レベル)の「プラント」
[idx]["STGE_LOC"]　→　配列内のidx番目の品目データ (保管場所レベル)の「保管場所」
[idx]["DEL_FLAG"]　→　配列内のidx番目の品目データ (保管場所レベル)の「保管場所レベルでの品目削除フラグ」
[idx]["MRP_IND"]　→　配列内のidx番目の品目データ (保管場所レベル)の「保管場所 MRP 区分」
[idx]["SPEC_PROC"]　→　配列内のidx番目の品目データ (保管場所レベル)の「保管場所レベルでの特殊調達タイプ」
[idx]["REORDER_PT"]　→　配列内のidx番目の品目データ (保管場所レベル)の「保管場所 MRP に対する発注点」
[idx]["REPL_QTY"]　→　配列内のidx番目の品目データ (保管場所レベル)の「保管場所 MRP に対する補充数量」
[idx]["STGE_BIN"]　→　配列内のidx番目の品目データ (保管場所レベル)の「棚番」
[idx]["PICKG_AREA"]　→　配列内のidx番目の品目データ (保管場所レベル)の「簡易倉庫管理のピッキングエリア」
[idx]["INV_CORR_FAC"]　→　配列内のidx番目の品目データ (保管場所レベル)の「在庫修正係数」
[idx]["MRP_VIEW"]　→　配列内のidx番目の品目データ (保管場所レベル)の「資材所要量計画 (MRP) ビュー」
[idx]["STORAGE_VIEW"]　→　配列内のidx番目の品目データ (保管場所レベル)の「保管ビュー」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getStorageTypeDataList

Array getStorageTypeDataList ()

保管域タイプデータを取得します。
返却値
Array 保管域タイプデータ

保管域タイプデータ情報オブジェクトの構成は以下のとおりです。
保管域タイプデータ情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
WHSE_NO 倉庫番号/複合倉庫 (String)
STGE_TYPE 保管域タイプ (String)
DEL_FLAG 保管タイプに該当する全品目データ 削除フラグ (String)
STGE_BIN 棚番 (String)
MAX_SB_QTY 最大棚番在庫数量 (String)
MIN_SB_QTY 最小棚番在庫数量 (String)
CTRL_QTY 管理数量 (String)
REPLEN_QTY 補充数量 (String)
PICK_AREA ピッキングエリア (String)
ROUND_QTY 丸め数量 (String)

取得した保管域タイプデータ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の保管域タイプデータの「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の保管域タイプデータの「品目コード」
[idx]["WHSE_NO"]　→　配列内のidx番目の保管域タイプデータの「倉庫番号/複合倉庫」
[idx]["STGE_TYPE"]　→　配列内のidx番目の保管域タイプデータの「保管域タイプ」
[idx]["DEL_FLAG"]　→　配列内のidx番目の保管域タイプデータの 「保管タイプに該当する全品目データ削除フラグ」
[idx]["STGE_BIN"]　→　配列内のidx番目の保管域タイプデータの「棚番」
[idx]["MAX_SB_QTY"]　→　配列内のidx番目の保管域タイプデータの「最大棚番在庫数量」
[idx]["MIN_SB_QTY"]　→　配列内のidx番目の保管域タイプデータの「最小棚番在庫数量」
[idx]["CTRL_QTY"]　→　配列内のidx番目の保管域タイプデータの「管理数量」
[idx]["REPLEN_QTY"]　→　配列内のidx番目の保管域タイプデータの「補充数量」
[idx]["PICK_AREA"]　→　配列内のidx番目の保管域タイプデータの「ピッキングエリア」
[idx]["ROUND_QTY"]　→　配列内のidx番目の保管域タイプデータの「丸め数量」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getTaxClassificationsList

Array getTaxClassificationsList ()

制御デ−タを取得します。
返却値
Array 制御デ−タ

制御デ−タ情報オブジェクトの構成は以下のとおりです。
制御デ−タ
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
DEPCOUNTRY 出荷国 (商品発送国) (String)
DEPCOUNTRY_ISO 出荷国の ISO コード (String)
TAX_TYPE_1 税カテゴリ (消費税等) (String)
TAXCLASS_1 品目の税分類 (String)
TAX_TYPE_2 税カテゴリ (消費税等) (String)
TAXCLASS_2 品目の税分類 (String)
TAX_TYPE_3 税カテゴリ (消費税等) (String)
TAXCLASS_3 品目の税分類 (String)
TAX_TYPE_4 税カテゴリ (消費税等) (String)
TAXCLASS_4 品目の税分類 (String)
TAX_TYPE_5 税カテゴリ (消費税等) (String)
TAXCLASS_5 品目の税分類 (String)
TAX_TYPE_6 税カテゴリ (消費税等) (String)
TAXCLASS_6 品目の税分類 (String)
TAX_TYPE_7 税カテゴリ (消費税等) (String)
TAXCLASS_7 品目の税分類 (String)
TAX_TYPE_8 税カテゴリ (消費税等) (String)
TAXCLASS_8 品目の税分類 (String)
TAX_TYPE_9 税カテゴリ (消費税等) (String)
TAXCLASS_9 品目の税分類 (String)
TAX_IND 税区分: 品目 (購買管理) (String)

取得した制御デ−タ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の制御デ−タの「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の制御デ−タの「品目コード」
[idx]["DEPCOUNTRY"]　→　配列内のidx番目の制御デ−タの「出荷国 (商品発送国)」
[idx]["DEPCOUNTRY_ISO"]　→　配列内のidx番目の制御デ−タの「出荷国の ISO コード」
[idx]["TAX_TYPE_1"]　→　配列内のidx番目の制御デ−タの「税カテゴリ (消費税等)」
[idx]["TAXCLASS_1"]　→　配列内のidx番目の制御デ−タの「品目の税分類」
[idx]["TAX_TYPE_2"]　→　配列内のidx番目の制御デ−タの「税カテゴリ (消費税等)」
[idx]["TAXCLASS_2"]　→　配列内のidx番目の制御デ−タの「品目の税分類」
[idx]["TAX_TYPE_3"]　→　配列内のidx番目の制御デ−タの「税カテゴリ (消費税等)」
[idx]["TAXCLASS_3"]　→　配列内のidx番目の制御デ−タの「品目の税分類」
[idx]["TAX_TYPE_4"]　→　配列内のidx番目の制御デ−タの「税カテゴリ (消費税等)」
[idx]["TAXCLASS_4"]　→　配列内のidx番目の制御デ−タの「品目の税分類」
[idx]["TAX_TYPE_5"]　→　配列内のidx番目の制御デ−タの「税カテゴリ (消費税等)」
[idx]["TAXCLASS_5"]　→　配列内のidx番目の制御デ−タの「品目の税分類」
[idx]["TAX_TYPE_6"]　→　配列内のidx番目の制御デ−タの「税カテゴリ (消費税等)」
[idx]["TAXCLASS_6"]　→　配列内のidx番目の制御デ−タの「品目の税分類」
[idx]["TAX_TYPE_7"]　→　配列内のidx番目の制御デ−タの「税カテゴリ (消費税等)」
[idx]["TAXCLASS_7"]　→　配列内のidx番目の制御デ−タの「品目の税分類」
[idx]["TAX_TYPE_8"]　→　配列内のidx番目の制御デ−タの「税カテゴリ (消費税等)」
[idx]["TAXCLASS_8"]　→　配列内のidx番目の制御デ−タの「品目の税分類」
[idx]["TAX_TYPE_9"]　→　配列内のidx番目の制御デ−タの「税カテゴリ (消費税等)」
[idx]["TAXCLASS_9"]　→　配列内のidx番目の制御デ−タの「品目の税分類」
[idx]["TAX_IND"]　→　配列内のidx番目の制御デ−タの「税区分: 品目 (購買管理)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getTestrun

Object getTestrun ()

書込 BAPI のシミュレーションセッションへの切替を取得します。
返却値
Object 書込 BAPI のシミュレーションセッションへの切替
getTotalConsumptionList

Array getTotalConsumptionList ()

品目総消費量のデータ転送を取得します。
返却値
Array 品目総消費量のデータ転送

品目総消費量のデータ転送情報オブジェクトの構成は以下のとおりです。
品目総消費量のデータ転送情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
PLANT プラント (String)
FIRST_DAY 値参照期間の第一日目 (String)
CONS_VALUE 消費量 (String)
CORR_VALUE 修正消費量 (String)
VAL_RATIO 元値に対する修正値の比率 (修正値: 元値) (String)
MATERIAL_EXTERNAL 項目 MATERIAL の 品目コード (長) (今後のリリースで開発) (String)
MATERIAL_GUID 項目 MATERIAL の外部 GUID (今後のリリースで開発) (String)
MATERIAL_VERSION 項目 MATERIAL の バージョン番号 (今後のリリースで開発) (String)

取得した品目総消費量のデータ転送情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の品目総消費量のデータ転送の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の品目総消費量のデータ転送の「品目コード」
[idx]["PLANT"]　→　配列内のidx番目の品目総消費量のデータ転送の「プラント」
[idx]["FIRST_DAY"]　→　配列内のidx番目の品目総消費量のデータ転送の「値参照期間の第一日目」
[idx]["CONS_VALUE"]　→　配列内のidx番目の品目総消費量のデータ転送の「消費量」
[idx]["CORR_VALUE"]　→　配列内のidx番目の品目総消費量のデータ転送の「修正消費量」
[idx]["VAL_RATIO"]　→　配列内のidx番目の品目総消費量の データ転送の「元値に対する修正値の比率 (修正値: 元値)」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の品目総消費量の データ転送の「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の品目総消費量の データ転送の「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の品目総消費量の データ転送の「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getUnitSofmeasureList

Array getUnitSofmeasureList ()

数量単位を取得します。
返却値
Array 数量単位

数量単位オブジェクトの構成は以下のとおりです。
数量単位
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
ALT_UNIT 在庫保管単位の代替数量単位 (String)
ALT_UNIT_ISO ISO コードによる在庫単位の 代替数量単位 (String)
NUMERATOR 基本数量単位への換算分子 (String)
DENOMINATR 分母: 基本数量単位へ変換する場合 (String)
EAN_UPC 国際商品コード (EAN/UPC) (String)
EAN_CAT 国際商品コード (EAN) のカテゴリ (String)
LENGTH 長さ (String)
WIDTH 幅 (String)
HEIGHT 高さ (String)
UNIT_DIM 寸法単位 (長さ/幅/高さ) (String)
UNIT_DIM_ISO ISO コードでの 長さ、幅、高さの単位 (String)
VOLUME 容積 (String)
VOLUMEUNIT 容積単位 (String)
VOLUMEUNIT_ISO ISO コードでの容積単位 (String)
GROSS_WT 総重量 (String)
UNIT_OF_WT 重量単位 (String)
UNIT_OF_WT_ISO ISO コードでの重量単位 (String)
DEL_FLAG データレコード削除 (テーブル繰返し) (String)
SUB_UOM 梱包階層の下位レベル数量単位 (String)
SUB_UOM_ISO 下位レベル数量単位 (ISO コード) (String)
GTIN_VARIANT グローバルトレード明細番号 バリアント (String)

取得した数量単位情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の数量単位の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の数量単位の「品目コード」
[idx]["ALT_UNIT"]　→　配列内のidx番目の数量単位の「在庫保管単位の代替数量単位」
[idx]["ALT_UNIT_ISO"]　→　配列内のidx番目の数量単位の 「ISO コードによる在庫単位の代替数量単位」
[idx]["NUMERATOR"]　→　配列内のidx番目の数量単位の「基本数量単位への換算分子」
[idx]["DENOMINATR"]　→　配列内のidx番目の数量単位の「分母: 基本数量単位へ変換する場合」
[idx]["EAN_UPC"]　→　配列内のidx番目の数量単位の「国際商品コード (EAN/UPC)」
[idx]["EAN_CAT"]　→　配列内のidx番目の数量単位の「国際商品コード (EAN) のカテゴリ」
[idx]["LENGTH"]　→　配列内のidx番目の数量単位の「長さ」
[idx]["WIDTH"]　→　配列内のidx番目の数量単位の「幅」
[idx]["HEIGHT"]　→　配列内のidx番目の数量単位の「高さ」
[idx]["UNIT_DIM"]　→　配列内のidx番目の数量単位の「寸法単位 (長さ/幅/高さ)」
[idx]["UNIT_DIM_ISO"]　→　配列内のidx番目の数量単位の 「ISO コードでの長さ、幅、高さの単位」
[idx]["VOLUME"]　→　配列内のidx番目の数量単位の「容積」
[idx]["VOLUMEUNIT"]　→　配列内のidx番目の数量単位の「容積単位」
[idx]["VOLUMEUNIT_ISO"]　→　配列内のidx番目の数量単位の「ISO コードでの容積単位」
[idx]["GROSS_WT"]　→　配列内のidx番目の数量単位の「総重量」
[idx]["UNIT_OF_WT"]　→　配列内のidx番目の数量単位の「重量単位」
[idx]["UNIT_OF_WT_ISO"]　→　配列内のidx番目の数量単位の「ISO コードでの重量単位」
[idx]["DEL_FLAG"]　→　配列内のidx番目の数量単位の「データレコード削除 (テーブル繰返し)」
[idx]["SUB_UOM"]　→　配列内のidx番目の数量単位の「梱包階層の下位レベル数量単位」
[idx]["SUB_UOM_ISO"]　→　配列内のidx番目の数量単位の「下位レベル数量単位 (ISO コード)」
[idx]["GTIN_VARIANT"]　→　配列内のidx番目の数量単位の「グローバルトレード明細番号バリアント」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getUnplndConsumptionList

Array getUnplndConsumptionList ()

計画外消費のデータ転送を取得します。
返却値
Array 計画外消費のデータ転送

計画外消費のデータ転送情報オブジェクトの構成は以下のとおりです。
計画外消費のデータ転送情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
PLANT プラント (String)
FIRST_DAY 値参照期間の第一日目 (String)
CONS_VALUE 消費量 (String)
CORR_VALUE 修正消費量 (String)
VAL_RATIO 元値に対する修正値の比率 (修正値: 元値) (String)
MATERIAL_EXTERNAL 項目 MATERIAL の 品目コード (長) (今後のリリースで開発) (String)
MATERIAL_GUID 項目 MATERIAL の外部 GUID (今後のリリースで開発) (String)
MATERIAL_VERSION 項目 MATERIAL の バージョン番号 (今後のリリースで開発) (String)

取得した計画外消費のデータ転送情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の計画外消費のデータ転送の「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の計画外消費のデータ転送の「品目コード」
[idx]["PLANT"]　→　配列内のidx番目の計画外消費のデータ転送の「プラント」
[idx]["FIRST_DAY"]　→　配列内のidx番目の計画外消費のデータ転送の「値参照期間の第一日目」
[idx]["CONS_VALUE"]　→　配列内のidx番目の計画外消費のデータ転送の「消費量」
[idx]["CORR_VALUE"]　→　配列内のidx番目の計画外消費のデータ転送の「修正消費量」
[idx]["VAL_RATIO"]　→　配列内のidx番目の計画外消費のデータ転送の 「元値に対する修正値の比率 (修正値: 元値)」
[idx]["MATERIAL_EXTERNAL"]　→　配列内のidx番目の計画外消費のデータ転送の 「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["MATERIAL_GUID"]　→　配列内のidx番目の計画外消費のデータ転送の 「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["MATERIAL_VERSION"]　→　配列内のidx番目の計画外消費のデータ転送の 「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getValuationDataList

Array getValuationDataList ()

評価データを取得します。
返却値
Array 評価データ

評価データ情報オブジェクトの構成は以下のとおりです。
評価データ
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
VAL_AREA 評価レベル (String)
VAL_TYPE 評価タイプ (String)
DEL_FLAG 評価タイプに該当する 全品目データ削除フラグ (String)
PRICE_CTRL 原価管理区分 (String)
MOVING_PR 移動平均原価/期間単位価格 (String)
STD_PRICE 標準原価 (String)
PRICE_UNIT 価格単位 (String)
VAL_CLASS 評価クラス (String)
PR_CTRL_PP 前期間の原価管理区分 (String)
MOV_PR_PP 前期移動平均原価/期間平均原価 (String)
STD_PR_PP 前期標準標準原価 (String)
PR_UNIT_PP 前期価格単位 (String)
VCLASS_PP 前期評価クラス (String)
PR_CTRL_PY 前年度の原価管理区分 (String)
MOV_PR_PY 前年度の移動平均原価/期間単価 (String)
STD_PR_PY 前年度標準原価 (String)
VCLASS_PY 前年度の評価クラス (String)
PR_UNIT_PY 前年度価格単位 (String)
VAL_CAT 評価カテゴリ (String)
FUTURE_PR 次期標準原価 (String)
VALID_FROM 原価有効開始日 (String)
TAXPRICE_1 税法による評価額: レベル 1 (String)
COMMPRICE1 商法による評価額: レベル 1 (String)
TAXPRICE_3 税法基準評価額: レベル 3 (String)
COMMPRICE3 商法基準評価額: レベル 3 (String)
PLND_PRICE 予定計画原価 (String)
PLNDPRICE1 予定計画原価 1 (String)
PLNDPRICE2 予定計画原価 2 (String)
PLNDPRICE3 予定計画原価 3 (String)
PLNDPRDATE1 予定原価 1 の有効開始日 (String)
PLNDPRDATE2 予定原価 2 の有効開始日 (String)
PLNDPRDATE3 予定原価 3 の有効開始日 (String)
LIFO_FIFO LIFO/FIFO 関連 (String)
POOLNUMBER LIFO 評価でのプール番号 (String)
TAXPRICE_2 税法による評価額: レベル 2 (String)
COMMPRICE2 商法による評価額: レベル 2 (String)
DEVAL_IND 低価法: 評価減区分 (String)
ORIG_GROUP 発生源グループ (原価要素の下位区分) (String)
OVERHEAD_GRP 原価計算間接費グループ (String)
QTY_STRUCT 数量構成により原価計算を行う品目 (String)
ML_ACTIVE 品目レベルで有効な品目元帳 (String)
ML_SETTLE 品目元帳決済: 管理 (String)
ORIG_MAT 品目発生源 (String)
VM_SO_STK 受注在庫の評価クラス (String)
VM_P_STOCK プロジェクト在庫の評価クラス (String)
MATL_USAGE 品目の用途 (String)
MAT_ORIGIN 品目の原産地 (String)
IN_HOUSE 内部生産 (String)
TAX_CML_UN 税法/商法にもとづく評価額価格単位 (String)
ACCOUNT_VIEW 会計ビュー (String)
COST_VIEW 原価計算ビュー (String)

取得した評価データ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の評価データの「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の評価データの「品目コード」
[idx]["VAL_AREA"]　→　配列内のidx番目の評価データの「評価レベル」
[idx]["VAL_TYPE"]　→　配列内のidx番目の評価データの「評価タイプ」
[idx]["DEL_FLAG"]　→　配列内のidx番目の評価データの「評価タイプに該当する全品目データ削除フラグ」
[idx]["PRICE_CTRL"]　→　配列内のidx番目の評価データの「原価管理区分」
[idx]["MOVING_PR"]　→　配列内のidx番目の評価データの「移動平均原価/期間単位価格」
[idx]["STD_PRICE"]　→　配列内のidx番目の評価データの「標準原価」
[idx]["PRICE_UNIT"]　→　配列内のidx番目の評価データの「価格単位」
[idx]["VAL_CLASS"]　→　配列内のidx番目の評価データの「評価クラス」
[idx]["PR_CTRL_PP"]　→　配列内のidx番目の評価データの「前期間の原価管理区分」
[idx]["MOV_PR_PP"]　→　配列内のidx番目の評価データの「前期移動平均原価/期間平均原価」
[idx]["STD_PR_PP"]　→　配列内のidx番目の評価データの「前期標準標準原価」
[idx]["PR_UNIT_PP"]　→　配列内のidx番目の評価データの「前期価格単位」
[idx]["VCLASS_PP"]　→　配列内のidx番目の評価データの「前期評価クラス」
[idx]["PR_CTRL_PY"]　→　配列内のidx番目の評価データの「前年度の原価管理区分」
[idx]["MOV_PR_PY"]　→　配列内のidx番目の評価データの「前年度の移動平均原価/期間単価」
[idx]["STD_PR_PY"]　→　配列内のidx番目の評価データの「前年度標準原価」
[idx]["VCLASS_PY"]　→　配列内のidx番目の評価データの「前年度の評価クラス」
[idx]["PR_UNIT_PY"]　→　配列内のidx番目の評価データの「前年度価格単位」
[idx]["VAL_CAT"]　→　配列内のidx番目の評価データの「評価カテゴリ」
[idx]["FUTURE_PR"]　→　配列内のidx番目の評価データの「次期標準原価」
[idx]["VALID_FROM"]　→　配列内のidx番目の評価データの「原価有効開始日」
[idx]["TAXPRICE_1"]　→　配列内のidx番目の評価データの「税法による評価額: レベル 1」
[idx]["COMMPRICE1"]　→　配列内のidx番目の評価データの「商法による評価額: レベル 1」
[idx]["TAXPRICE_3"]　→　配列内のidx番目の評価データの「税法基準評価額: レベル 3」
[idx]["COMMPRICE3"]　→　配列内のidx番目の評価データの「商法基準評価額: レベル 3」
[idx]["PLND_PRICE"]　→　配列内のidx番目の評価データの「予定計画原価」
[idx]["PLNDPRICE1"]　→　配列内のidx番目の評価データの「予定計画原価 1」
[idx]["PLNDPRICE2"]　→　配列内のidx番目の評価データの「予定計画原価 2」
[idx]["PLNDPRICE3"]　→　配列内のidx番目の評価データの「予定計画原価 3」
[idx]["PLNDPRDATE1"]　→　配列内のidx番目の評価データの「予定原価 1 の有効開始日」
[idx]["PLNDPRDATE2"]　→　配列内のidx番目の評価データの「予定原価 2 の有効開始日」
[idx]["PLNDPRDATE3"]　→　配列内のidx番目の評価データの「予定原価 3 の有効開始日」
[idx]["LIFO_FIFO"]　→　配列内のidx番目の評価データの「LIFO/FIFO 関連」
[idx]["POOLNUMBER"]　→　配列内のidx番目の評価データの「LIFO 評価でのプール番号」
[idx]["TAXPRICE_2"]　→　配列内のidx番目の評価データの「税法による評価額: レベル 2」
[idx]["COMMPRICE2"]　→　配列内のidx番目の評価データの「商法による評価額: レベル 2」
[idx]["DEVAL_IND"]　→　配列内のidx番目の評価データの「低価法: 評価減区分」
[idx]["ORIG_GROUP"]　→　配列内のidx番目の評価データの「発生源グループ (原価要素の下位区分)」
[idx]["OVERHEAD_GRP"]　→　配列内のidx番目の評価データの「原価計算間接費グループ」
[idx]["QTY_STRUCT"]　→　配列内のidx番目の評価データの「数量構成により原価計算を行う品目」
[idx]["ML_ACTIVE"]　→　配列内のidx番目の評価データの「品目レベルで有効な品目元帳」
[idx]["ML_SETTLE"]　→　配列内のidx番目の評価データの「品目元帳決済: 管理」
[idx]["ORIG_MAT"]　→　配列内のidx番目の評価データの「品目発生源」
[idx]["VM_SO_STK"]　→　配列内のidx番目の評価データの「受注在庫の評価クラス」
[idx]["VM_P_STOCK"]　→　配列内のidx番目の評価データの「プロジェクト在庫の評価クラス」
[idx]["MATL_USAGE"]　→　配列内のidx番目の評価データの「品目の用途」
[idx]["MAT_ORIGIN"]　→　配列内のidx番目の評価データの「品目の原産地」
[idx]["IN_HOUSE"]　→　配列内のidx番目の評価データの「内部生産」
[idx]["TAX_CML_UN"]　→　配列内のidx番目の評価データの「税法/商法にもとづく評価額価格単位」
[idx]["ACCOUNT_VIEW"]　→　配列内のidx番目の評価データの「会計ビュー」
[idx]["COST_VIEW"]　→　配列内のidx番目の評価データの「原価計算ビュー」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getWarehouseNumberDataList

Array getWarehouseNumberDataList ()

倉庫番号データを取得します。
返却値
Array 倉庫番号データ

倉庫番号データ情報オブジェクトの構成は以下のとおりです。
倉庫番号データ情報
オブジェクト
(Object)
FUNCTION BAPI 機能 (String)
MATERIAL 品目コード (String)
WHSE_NO 倉庫番号/複合倉庫 (String)
DEL_FLAG WM 倉庫内の全品目データ削除フラグ (String)
STGESECTOR 保管区画区分 (String)
PLACEMENT 在庫受入に対する保管域タイプ検索区分 (String)
WITHDRAWAL 在庫払出に対する保管域タイプ区分 (String)
L_EQUIP_1 積載装置数量 1 (String)
L_EQUIP_2 積載装置数量 2 (String)
L_EQUIP_3 積載装置数量 3 (String)
LEQ_UNIT_1 積載装置数量 1 の数量単位 (String)
LEQ_UNIT_1_ISO ISO コードによる 積載装置数量 1 の数量単位 (String)
LEQ_UNIT_2 積載装置数量 2 の数量単位 (String)
LEQ_UNIT_2_ISO ISO コードによる 積載装置数量 2 の数量単位 (String)
LEQ_UNIT_3 積載装置数量 3 の数量単位 (String)
LEQ_UNIT_3_ISO ISO コードによる 積載装置数量 3 の数量単位 (String)
UNITTYPE_1 第１保管単位タイプ (String)
UNITTYPE_2 第２保管単位タイプ (String)
UNITTYPE_3 第３保管単位タイプ (String)
WM_UNIT 倉庫管理の数量単位 (String)
WM_UNIT_ISO ISO コードでの倉庫管理単位 (String)
ADD_TO_STK 既存在庫への追加許可 (String)
BLOCK_STGE 平置保管域区分 (String)
MSG_TO_IM 区分: 在庫管理への出力 (String)
SPEC_MVMT 倉庫管理の特殊移動区分 (String)
CAPY_USAGE 保管容量使用 (String)
PROCURE_UN 保管容量消費の数量単位 (String)
PROCURE_UN_ISO ISO コードでの 保管容量消費の数量単位 (String)
STGE_TYPE 概略計画および詳細計画の ピッキング保管域タイプ (String)
REF_UNIT 品目マスタレコードの数量単位初期値 (String)
2STEP_PICK ツーステップピッキング適用品目 (String)

取得した倉庫番号データ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["FUNCTION"]　→　配列内のidx番目の倉庫番号データの「BAPI 機能」
[idx]["MATERIAL"]　→　配列内のidx番目の倉庫番号データの「品目コード」
[idx]["WHSE_NO"]　→　配列内のidx番目の倉庫番号データの「倉庫番号/複合倉庫」
[idx]["DEL_FLAG"]　→　配列内のidx番目の倉庫番号データの「WM 倉庫内の全品目データ削除フラグ」
[idx]["STGESECTOR"]　→　配列内のidx番目の倉庫番号データの「保管区画区分」
[idx]["PLACEMENT"]　→　配列内のidx番目の倉庫番号データの「在庫受入に対する保管域タイプ検索区分」
[idx]["WITHDRAWAL"]　→　配列内のidx番目の倉庫番号データの「在庫払出に対する保管域タイプ区分」
[idx]["L_EQUIP_1"]　→　配列内のidx番目の倉庫番号データの「積載装置数量 1」
[idx]["L_EQUIP_2"]　→　配列内のidx番目の倉庫番号データの「積載装置数量 2」
[idx]["L_EQUIP_3"]　→　配列内のidx番目の倉庫番号データの「積載装置数量 3」
[idx]["LEQ_UNIT_1"]　→　配列内のidx番目の倉庫番号データの「積載装置数量 1 の数量単位」
[idx]["LEQ_UNIT_1_ISO"]　→　配列内のidx番目の倉庫番号データの 「ISO コードによる積載装置数量 1 の数量単位」
[idx]["LEQ_UNIT_2"]　→　配列内のidx番目の倉庫番号データの「積載装置数量 2 の数量単位」
[idx]["LEQ_UNIT_2_ISO"]　→　配列内のidx番目の倉庫番号データの 「ISO コードによる積載装置数量 2 の数量単位」
[idx]["LEQ_UNIT_3"]　→　配列内のidx番目の倉庫番号データの「積載装置数量 3 の数量単位」
[idx]["LEQ_UNIT_3_ISO"]　→　配列内のidx番目の倉庫番号データの 「ISO コードによる積載装置数量 3 の数量単位」
[idx]["UNITTYPE_1"]　→　配列内のidx番目の倉庫番号データの「第１保管単位タイプ」
[idx]["UNITTYPE_2"]　→　配列内のidx番目の倉庫番号データの「第２保管単位タイプ」
[idx]["UNITTYPE_3"]　→　配列内のidx番目の倉庫番号データの「第３保管単位タイプ」
[idx]["WM_UNIT"]　→　配列内のidx番目の倉庫番号データの「倉庫管理の数量単位」
[idx]["WM_UNIT_ISO"]　→　配列内のidx番目の倉庫番号データの「ISO コードでの倉庫管理単位」
[idx]["ADD_TO_STK"]　→　配列内のidx番目の倉庫番号データの「既存在庫への追加許可」
[idx]["BLOCK_STGE"]　→　配列内のidx番目の倉庫番号データの「平置保管域区分」
[idx]["MSG_TO_IM"]　→　配列内のidx番目の倉庫番号データの「区分: 在庫管理への出力」
[idx]["SPEC_MVMT"]　→　配列内のidx番目の倉庫番号データの「倉庫管理の特殊移動区分」
[idx]["CAPY_USAGE"]　→　配列内のidx番目の倉庫番号データの「保管容量使用」
[idx]["PROCURE_UN"]　→　配列内のidx番目の倉庫番号データの「保管容量消費の数量単位」
[idx]["PROCURE_UN_ISO"]　→　配列内のidx番目の倉庫番号データの 「ISO コードでの保管容量消費の数量単位」
[idx]["STGE_TYPE"]　→　配列内のidx番目の倉庫番号データの 「概略計画および詳細計画のピッキング保管域タイプ」
[idx]["REF_UNIT"]　→　配列内のidx番目の倉庫番号データの「品目マスタレコードの数量単位初期値」
[idx]["2STEP_PICK"]　→　配列内のidx番目の倉庫番号データの「ツーステップピッキング適用品目」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7: 購買発注システムエラー
8: 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

setFlagCadCall

void setFlagCadCall (Object value)

CAD システムからコールを設定します。
パラメータ
value Object CAD システムからコール
返却値
void
setInpfldcheck

void setInpfldcheck (Object value)

項目無効時の応答を設定します。
パラメータ
value Object 項目無効時の応答
返却値
void
setNoappllog

void setNoappllog (Object value)

アプリケーションログ書込なしを設定します。
パラメータ
value Object アプリケーションログ書込なし
返却値
void
setNochangedoc

void setNochangedoc (Object value)

変更伝票書込なしを設定します。
パラメータ
value Object 変更伝票書込なし
返却値
void
setTblParam

void setTblParam (String tableName ,String paramName ,Object value ,int index)

テーブル型の項目に値をセットします。
パラメータ
tableName | String | テーブル名
paramName | String | 項目名
value | Object | セットする値
index | int | レコード番号
返却値
void
setTestrun

void setTestrun (Object value)

書込 BAPI のシミュレーションセッションへの切替を設定します。
パラメータ
value Object 書込 BAPI のシミュレーションセッションへの切替
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 ProfitCenterController オブジェクト

利益センタコントローラクラス。

利益センタの情報を取得します。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
ProfitCenterController (String controllingArea)
コンストラクタ。
ProfitCenterController (String controllingArea ,String date)
コンストラクタ。
ProfitCenterController (String controllingArea ,String date ,SapClient sapClient)
コンストラクタ。
メソッドの概要
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
Object | getInCharge (String profitCtr) 利益センタ責任者を取得します。
Object | getPctrName (String profitCtr) 一般名称を取得します。
Array | getProfitCenterList () 利益センタ情報一覧を取得します。
Object | getValidTo (String profitCtr) 有効終了日を取得します。
コンストラクタの詳細
ProfitCenterController

ProfitCenterController (String controllingArea)
コンストラクタ。

引数１つのコンストラクタです。
システム日付で有効な利益センタ情報が抽出対象となります。
パラメータ
controllingArea String SAP R/3上に存在する管理領域コード
ProfitCenterController

ProfitCenterController (String controllingArea ,String date)
コンストラクタ。

引数２つコンストラクタです。
指定したYYYYMMDDの日付で有効な利益センタ情報が抽出対象となります。
パラメータ
controllingArea String SAP R/3上に存在する管理領域コード
date String 日付 ※日付書式「YYYYMMDD」
ProfitCenterController

ProfitCenterController (String controllingArea ,String date ,SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
controllingArea | String | SAP R/3上に存在する管理領域コード
date | String | 日付
sapClient | SapClient | Sapクライアント
メソッドの詳細
getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getInCharge

Object getInCharge (String profitCtr)

利益センタ責任者を取得します。

利益センタコードを指定して利益センタ責任者を取得します。
パラメータ
profitCtr String SAP R/3上に存在する利益センタコード
返却値
Object 指定した利益センタコードに対応する利益センタ責任者
（成功時の返却値は String になります。）
（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPctrName

Object getPctrName (String profitCtr)

一般名称を取得します。

利益センタコードを指定して一般名称を取得します。
パラメータ
profitCtr String SAP R/3上に存在する利益センタコード
返却値
Object 指定した利益センタコードに対応する一般名称
（成功時の返却値は String になります。）
（失敗時）Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getProfitCenterList

Array getProfitCenterList ()

利益センタ情報一覧を取得します。

返却値
Array 利益センタ情報が格納された配列

利益センタ情報オブジェクトの構成は以下のとおりです。
利益センタ情報
オブジェクト
(Object)
CONTROLLING_AREA 管理領域コードコード (String)
PROFIT_CTR 利益センタコード (String)
VALID_TO 有効終了日 (String)
IN_CHARGE 利益センタ責任者 (String)
PCTR_NAME 一般名称 (String)

取得した利益センタ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONTROLLING_AREA"]　→　配列内のidx番目の利益センタの「管理領域コード」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の利益センタの「利益センタコード」
[idx]["VALID_TO"]　→　配列内のidx番目の利益センタの「有効終了日」
[idx]["IN_CHARGE"]　→　配列内のidx番目の利益センタの「利益センタ責任者」
[idx]["PCTR_NAME"]　→　配列内のidx番目の利益センタの「一般名称」

※ idxは0〜n （配列サイズ-1）

getValidTo

Object getValidTo (String profitCtr)

有効終了日を取得します。

利益センタコードを指定して有効終了日を取得します。
パラメータ
profitCtr String SAP R/3上に存在する利益センタコード
返却値
Object 指定した利益センタコードに対応する有効終了日
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 財務会計業務系システムエラー
6： 財務会計業務系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)


 PurchaseGetItemSrelController オブジェクト

伝票承認対象一覧取得コントローラクラス。

機能は以下の通り
  • 伝票承認対象一覧を取得します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
PurchaseGetItemSrelController (String relGroup ,String relCode ,String itemForRelease)
コンストラクタ｡
PurchaseGetItemSrelController (String relGroup ,String relCode ,String itemForRelease ,SapClient sapClient)
コンストラクタ。
メソッドの概要
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
Object | getItemsForRelease () 区分：承認待ち購買発注のみ照会を取得します。
Object | getPurchaseGetItemSrel () 承認対象一覧情報を取得します｡
Object | getPurchaseHeadersList () ヘッダ一覧を取得します｡
Object | getPurchaseItemsList () 明細一覧を取得します｡
Object | getRelCode () 承認コードを取得します。
Object | getRelGroup () 承認グループを取得します。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
PurchaseGetItemSrelController

PurchaseGetItemSrelController (String relGroup ,String relCode ,String itemForRelease)
コンストラクタ｡
パラメータ
relGroup | String | 承認グループ
relCode | String | 承認コード
itemForRelease | String | 照会区分
PurchaseGetItemSrelController

PurchaseGetItemSrelController (String relGroup ,String relCode ,String itemForRelease ,SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
relGroup | String | 承認グループ
relCode | String | 承認コード
itemForRelease | String | 照会区分
sapClient | SapClient | Sapクライアント
メソッドの詳細
getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getItemsForRelease

Object getItemsForRelease ()

区分：承認待ち購買発注のみ照会を取得します。

返却値
Object 区分：承認待ち購買発注のみ照会
getPurchaseGetItemSrel

Object getPurchaseGetItemSrel ()

承認対象一覧情報を取得します｡

返却値
Object 承認対象一覧
getPurchaseHeadersList

Object getPurchaseHeadersList ()

ヘッダ一覧を取得します｡
返却値
Object ヘッダ一覧

ヘッダ情報オブジェクトの構成は以下のとおりです。
ヘッダ情報
オブジェクト
(Object)
PO_NUMBER 購買伝票番号 (String)
CO_CODE 会社コード (String)
DOC_CAT 購買伝票カテゴリ (String)
DOC_TYPE 購買伝票タイプ (String)
CNTRL_IND 購買伝票タイプに対する管理区分 (String)
DELETE_IND 購買伝票の削除フラグ (String)
STATUS 購買伝票のステータス (String)
CREATED_ON レコード登録日 (String)
CREATED_BY オブジェクト登録者名 (String)
ITEM_INTVL 明細番号間隔 (String)
LAST_ITEM 最終明細番号 (String)
VENDOR 仕入先勘定コード (String)
LANGUAGE 言語キー (String)
PMNTTRMS 支払条件キー (String)
DSCNT1_TO 現金割引日数 1 (String)
DSCNT2_TO 現金割引期間 2 (日数) (String)
DSCNT3_TO 現金値引期間 3 (String)
CASH_DISC1 割引率 1 (String)
CASH_DISC2 割引率 2 (String)
PURCH_ORG 購買組織 (String)
PUR_GROUP 購買グループ (String)
CURRENCY 通貨コード (String)
EXCH_RATE 直接呼び値換算レート (String)
EX_RATE_FX 区分：換算レート固定 (String)
DOC_DATE 購買伝票日付 (String)
VPER_START 有効期間開始日 (String)
VPER_END 有効期間の終了日 (String)
APPLIC_BY 見積提出期限 (String)
QUOT_DEAD 見積提出期限 (String)
BINDG_PER 見積有効期間 (String)
WARRANTY 保証日 (String)
BIDINV_NO 見積管理番号 (String)
QUOTATION 見積番号 (String)
QUOT_DATE 見積提出日 (String)
REF_1 得意先/仕入先の内部参照コード (String)
SALES_PERS 仕入先営業担当者 (String)
TELEPHONE 仕入先電話番号 (String)
SUPPL_VEND 供給仕入先 (String)
CUSTOMER 得意先コード 1 (String)
AGREEMENT 購買契約番号 (String)
REJ_REASON 見積および受注の拒否理由 (String)
COMPL_DLV 全購買発注に対する一括納入指定 (String)
GR_MESSAGE 区分：入庫メッセージ (String)
SUPPL_PLNT 在庫転送オーダーにおける供給 (出庫) プラント (String)
RCVG_VEND 未使用項目 (String)
INCOTERMS1 インコタームズ (1) (String)
INCOTERMS2 インコタームズ 2 (String)
TARGET_VAL 累積計画金額 (String)
COLL_NO 一括番号 (String)
DOC_COND 伝票条件番号 (String)
PROCEDURE 決定表 (価格設定/出力管理/勘定設定/原価計算など) (String)
UPDATE_GRP 統計更新の更新グループ (String)
DIFF_INV 仕入先と請求元が異なる場合の請求元のコード (String)
EXPORT_NO 貿易データ番号：MM/SD 伝票 (String)
OUR_REF 社内参照番号 (String)
LOGSYSTEM 論理システム (String)
SUBITEMINT 副明細の明細間隔 (String)
MAST_COND 期間依存条件伝票 (String)
REL_GROUP 承認グループ (String)
REL_STRAT 承認方針 (String)
REL_IND 承認区分：購買伝票 (String)
REL_STATUS 承認状況 (String)
SUBJ_TO_R 承認未完了 (String)
TAXR_CNTRY 納税申告書の国 (String)
SCHED_IND 分納契約のリリース伝票区分 (String)
VEND_NAME 名称 1 (String)
CURRENCY_ISO ISO 通貨コード (String)
EXCH_RATE_CM 間接呼び値換算レート (String)
HOLD 購買発注の不完全 (String)

取得したヘッダ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_NUMBER"]　→　配列内のidx番目のヘッダの「購買伝票番号」
[idx]["CO_CODE"]　→　配列内のidx番目のヘッダの「会社コード」
[idx]["DOC_CAT"]　→　配列内のidx番目のヘッダの「購買伝票カテゴリ」
[idx]["DOC_TYPE"]　→　配列内のidx番目のヘッダの「購買伝票タイプ」
[idx]["CNTRL_IND"]　→　配列内のidx番目のヘッダの「購買伝票タイプに対する管理区分」
[idx]["DELETE_IND"]　→　配列内のidx番目のヘッダの「購買伝票の削除フラグ」
[idx]["STATUS"]　→　配列内のidx番目のヘッダの「購買伝票のステータス」
[idx]["CREATED_ON"]　→　配列内のidx番目のヘッダの「レコード登録日」
[idx]["CREATED_BY"]　→　配列内のidx番目のヘッダの「オブジェクト登録者名」
[idx]["ITEM_INTVL"]　→　配列内のidx番目のヘッダの「明細番号間隔」
[idx]["LAST_ITEM"]　→　配列内のidx番目のヘッダの「最終明細番号」
[idx]["VENDOR"]　→　配列内のidx番目のヘッダの「仕入先勘定コード」
[idx]["LANGUAGE"]　→　配列内のidx番目のヘッダの「言語キー」
[idx]["PMNTTRMS"]　→　配列内のidx番目のヘッダの「支払条件キー」
[idx]["DSCNT1_TO"]　→　配列内のidx番目のヘッダの「現金割引日数 1」
[idx]["DSCNT2_TO"]　→　配列内のidx番目のヘッダの「現金割引期間 2 (日数)」
[idx]["DSCNT3_TO"]　→　配列内のidx番目のヘッダの「現金値引期間 3」
[idx]["CASH_DISC1"]　→　配列内のidx番目のヘッダの「割引率 1」
[idx]["CASH_DISC2"]　→　配列内のidx番目のヘッダの「割引率 2」
[idx]["PURCH_ORG"]　→　配列内のidx番目のヘッダの「購買組織」
[idx]["PUR_GROUP"]　→　配列内のidx番目のヘッダの「購買グループ」
[idx]["CURRENCY"]　→　配列内のidx番目のヘッダの「通貨コード」
[idx]["EXCH_RATE"]　→　配列内のidx番目のヘッダの「直接呼び値換算レート」
[idx]["EX_RATE_FX"]　→　配列内のidx番目のヘッダの「区分：換算レート固定」
[idx]["DOC_DATE"]　→　配列内のidx番目のヘッダの「購買伝票日付」
[idx]["VPER_START"]　→　配列内のidx番目のヘッダの「有効期間開始日」
[idx]["VPER_END"]　→　配列内のidx番目のヘッダの「有効期間の終了日」
[idx]["APPLIC_BY"]　→　配列内のidx番目のヘッダの「見積提出期限」
[idx]["QUOT_DEAD"]　→　配列内のidx番目のヘッダの「見積提出期限」
[idx]["BINDG_PER"]　→　配列内のidx番目のヘッダの「見積有効期間」
[idx]["WARRANTY"]　→　配列内のidx番目のヘッダの「保証日」
[idx]["BIDINV_NO"]　→　配列内のidx番目のヘッダの「見積管理番号」
[idx]["QUOTATION"]　→　配列内のidx番目のヘッダの「見積番号」
[idx]["QUOT_DATE"]　→　配列内のidx番目のヘッダの「見積提出日」
[idx]["REF_1"]　→　配列内のidx番目のヘッダの「得意先/仕入先の内部参照コード」
[idx]["SALES_PERS"]　→　配列内のidx番目のヘッダの「仕入先営業担当者」
[idx]["TELEPHONE"]　→　配列内のidx番目のヘッダの「仕入先電話番号」
[idx]["SUPPL_VEND"]　→　配列内のidx番目のヘッダの「供給仕入先」
[idx]["CUSTOMER"]　→　配列内のidx番目のヘッダの「得意先コード 1」
[idx]["AGREEMENT"]　→　配列内のidx番目のヘッダの「購買契約番号」
[idx]["REJ_REASON"]　→　配列内のidx番目のヘッダの「見積および受注の拒否理由」
[idx]["COMPL_DLV"]　→　配列内のidx番目のヘッダの「全購買発注に対する一括納入指定」
[idx]["GR_MESSAGE"]　→　配列内のidx番目のヘッダの「区分：入庫メッセージ」
[idx]["SUPPL_PLNT"]　→ 　配列内のidx番目のヘッダの「在庫転送オーダーにおける供給 (出庫) プラント」
[idx]["RCVG_VEND"]　→　配列内のidx番目のヘッダの「未使用項目」
[idx]["INCOTERMS1"]　→　配列内のidx番目のヘッダの「インコタームズ (1)」
[idx]["INCOTERMS2"]　→　配列内のidx番目のヘッダの「インコタームズ 2」
[idx]["TARGET_VAL"]　→　配列内のidx番目のヘッダの「累積計画金額」
[idx]["COLL_NO"]　→　配列内のidx番目のヘッダの「一括番号」
[idx]["DOC_COND"]　→　配列内のidx番目のヘッダの「伝票条件番号」
[idx]["PROCEDURE"]　→ 　配列内のidx番目のヘッダの「決定表 (価格設定/出力管理/勘定設定/原価計算など)」
[idx]["UPDATE_GRP"]　→　配列内のidx番目のヘッダの「統計更新の更新グループ」
[idx]["DIFF_INV"]　→　配列内のidx番目のヘッダの「仕入先と請求元が異なる場合の請求元のコード」
[idx]["EXPORT_NO"]　→　配列内のidx番目のヘッダの「貿易データ番号：MM/SD 伝票」
[idx]["OUR_REF"]　→　配列内のidx番目のヘッダの「社内参照番号」
[idx]["LOGSYSTEM"]　→　配列内のidx番目のヘッダの「論理システム」
[idx]["SUBITEMINT"]　→　配列内のidx番目のヘッダの「副明細の明細間隔」
[idx]["MAST_COND"]　→　配列内のidx番目のヘッダの「期間依存条件伝票」
[idx]["REL_GROUP"]　→　配列内のidx番目のヘッダの「承認グループ」
[idx]["REL_STRAT"]　→　配列内のidx番目のヘッダの「承認方針」
[idx]["REL_IND"]　→　配列内のidx番目のヘッダの「承認区分：購買伝票」
[idx]["REL_STATUS"]　→　配列内のidx番目のヘッダの「承認状況」
[idx]["SUBJ_TO_R"]　→　配列内のidx番目のヘッダの「承認未完了」
[idx]["TAXR_CNTRY"]　→　配列内のidx番目のヘッダの「納税申告書の国」
[idx]["SCHED_IND"]　→　配列内のidx番目のヘッダの「分納契約のリリース伝票区分」
[idx]["VEND_NAME"]　→　配列内のidx番目のヘッダの「名称 1」
[idx]["CURRENCY_ISO"]　→　配列内のidx番目のヘッダの「ISO 通貨コード」
[idx]["EXCH_RATE_CM"]　→　配列内のidx番目のヘッダの「間接呼び値換算レート」
[idx]["HOLD"]　→　配列内のidx番目のヘッダの「購買発注の不完全」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPurchaseItemsList

Object getPurchaseItemsList ()

明細一覧を取得します｡
返却値
Object 明細一覧

明細情報オブジェクトの構成は以下のとおりです。
明細情報
オブジェクト
(Object)
PO_NUMBER 購買伝票番号 (String)
PO_ITEM 購買伝票の明細番号 (String)
ADDRESS 住所 (String)
MATERIAL 品目コード (String)
PUR_MAT 品目コード (String)
INFO_REC 購買情報番号 (String)
ITEM_CAT 購買伝票の明細カテゴリ (String)
ACCTASSCAT 勘定設定カテゴリ (String)
AGREEMENT 購買契約番号 (String)
AGMT_ITEM 購買契約の明細番号 (String)
STORE_LOC 保管場所 (String)
MAT_GRP 品目グループ (String)
SHORT_TEXT テキスト (短) (String)
DISTRIB 複数勘定設定の配賦区分 (String)
PART_INV 一部請求区分 (String)
KANBAN_IND かんばん区分 (String)
PLANT プラント (String)
ALLOC_TBL 商品配分表番号 (String)
AT_ITEM 割当テーブルの明細番号 (String)
UNIT 発注単位 (String)
NET_PRICE 購買伝票における正味価格 (伝票通貨) (String)
PRICE_UNIT 価格単位 (String)
CONV_NUM1 購買価格単位から購買発注単位への変換分子 (String)
CONV_DEN1 購買価格単位から購買発注単位への変換分母 (String)
ORDERPR_UN 購買発注価格単位 (購買管理) (String)
PCKG_NO パッケージ番号 (String)
PROMOTION プロモーション (String)
ACKN_REQD 購買発注請書依頼 (String)
TRACKINGNO 購買依頼追跡番号 (String)
PLAN_DEL 予定納入日数 (String)
RET_ITEM 返品明細 (String)
AT_RELEV 割当テーブル関連 (String)
VEND_MAT 仕入先の品目コード (String)
MANUF_PROF 製造者製品プロファイル (String)
MANU_MAT 製造者製品コード (String)
MFR_NO 製造者番号 (String)
MFR_NO_EXT 外部製造者コード名または番号 (String)
PO_PRICE 区分：価格採用 - 購買情報不使用 (String)
SHIPPING 出荷指示 (String)
ITEM_CAT_EXT 購買伝票の明細カテゴリ (String)
PO_UNIT_ISO ISO コードによる発注単位 (String)
ORDERPR_UN_ISO 購買発注価格単位の ISO コード (String)
PREQ_NAME 購買依頼者名/要求者名 (String)
DISP_QUAN 購買発注数量：表示目的全納入日程合計 (String)
QUAL_INSP 在庫タイプ (String)
NO_MORE_GR 納入完了 区分 (String)
DELETE_IND 購買伝票の削除フラグ (String)
NO_ROUNDING 区分：購買発注明細での非表示丸め (String)
TAX_CODE 消費税コード (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード (長) (今後のリリースで開発) (String)
MATERIAL_GUID 項目 MATERIAL の外部 GUID (今後のリリースで開発) (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (今後のリリースで開発) (String)
PUR_MAT_EXTERNAL 項目 PUR_MAT の品目コード (長) (今後のリリースで開発) (String)
PUR_MAT_GUID 項目 PUR_MAT の外部 GUID (今後のリリースで開発) (String)
PUR_MAT_VERSION 項目 PUR_MAT のバージョン番号 (今後のリリースで開発) (String)
VAL_TYPE 評価タイプ (String)
PR_CLOSED 購買依頼処理済 (String)

取得した明細情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_NUMBER"]　→　配列内のidx番目の明細の「購買伝票番号」
[idx]["PO_ITEM"]　→　配列内のidx番目の明細の「購買伝票の明細番号」
[idx]["ADDRESS"]　→　配列内のidx番目の明細の「住所」
[idx]["MATERIAL"]　→　配列内のidx番目の明細の「品目コード」
[idx]["PUR_MAT"]　→　配列内のidx番目の明細の「品目コード」
[idx]["INFO_REC"]　→　配列内のidx番目の明細の「購買情報番号」
[idx]["ITEM_CAT"]　→　配列内のidx番目の明細の「購買伝票の明細カテゴリ」
[idx]["ACCTASSCAT"]　→　配列内のidx番目の明細の「勘定設定カテゴリ」
[idx]["AGREEMENT"]　→　配列内のidx番目の明細の「購買契約番号」
[idx]["AGMT_ITEM"]　→　配列内のidx番目の明細の「購買契約の明細番号」
[idx]["STORE_LOC"]　→　配列内のidx番目の明細の「保管場所」
[idx]["MAT_GRP"]　→　配列内のidx番目の明細の「品目グループ」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の明細の「テキスト (短)」
[idx]["DISTRIB"]　→　配列内のidx番目の明細の「複数勘定設定の配賦区分」
[idx]["PART_INV"]　→　配列内のidx番目の明細の「一部請求区分」
[idx]["KANBAN_IND"]　→　配列内のidx番目の明細の「かんばん区分」
[idx]["PLANT"]　→　配列内のidx番目の明細の「プラント」
[idx]["ALLOC_TBL"]　→　配列内のidx番目の明細の「商品配分表番号」
[idx]["AT_ITEM"]　→　配列内のidx番目の明細の「割当テーブルの明細番号」
[idx]["UNIT"]　→　配列内のidx番目の明細の「発注単位」
[idx]["NET_PRICE"]　→　配列内のidx番目の明細の「購買伝票における正味価格 (伝票通貨)」
[idx]["PRICE_UNIT"]　→　配列内のidx番目の明細の「価格単位」
[idx]["CONV_NUM1"]　→　配列内のidx番目の明細の「購買価格単位から購買発注単位への変換分子」
[idx]["CONV_DEN1"]　→　配列内のidx番目の明細の「購買価格単位から購買発注単位への変換分母」
[idx]["ORDERPR_UN"]　→　配列内のidx番目の明細の「購買発注価格単位 (購買管理)」
[idx]["PCKG_NO"]　→　配列内のidx番目の明細の「パッケージ番号」
[idx]["PROMOTION"]　→　配列内のidx番目の明細の「プロモーション」
[idx]["ACKN_REQD"]　→　配列内のidx番目の明細の「購買発注請書依頼」
[idx]["TRACKINGNO"]　→　配列内のidx番目の明細の「購買依頼追跡番号」
[idx]["PLAN_DEL"]　→　配列内のidx番目の明細の「予定納入日数」
[idx]["RET_ITEM"]　→　配列内のidx番目の明細の「返品明細」
[idx]["AT_RELEV"]　→　配列内のidx番目の明細の「割当テーブル関連」
[idx]["VEND_MAT"]　→　配列内のidx番目の明細の「仕入先の品目コード」
[idx]["MANUF_PROF"]　→　配列内のidx番目の明細の「製造者製品プロファイル」
[idx]["MANU_MAT"]　→　配列内のidx番目の明細の「製造者製品コード」
[idx]["MFR_NO"]　→　配列内のidx番目の明細の「製造者番号」
[idx]["MFR_NO_EXT"]　→　配列内のidx番目の明細の「外部製造者コード名または番号」
[idx]["PO_PRICE"]　→　配列内のidx番目の明細の「区分：価格採用 - 購買情報不使用」
[idx]["SHIPPING"]　→　配列内のidx番目の明細の「出荷指示」
[idx]["ITEM_CAT_EXT"]　→　配列内のidx番目の明細の「購買伝票の明細カテゴリ」
[idx]["PO_UNIT_ISO"]　→　配列内のidx番目の明細の「ISO コードによる発注単位」
[idx]["ORDERPR_UN_ISO"]　→　配列内のidx番目の明細の「購買発注価格単位の ISO コード」
[idx]["PREQ_NAME"]　→　配列内のidx番目の明細の「購買依頼者名/要求者名」
[idx]["DISP_QUAN"]　→　配列内のidx番目の明細の「購買発注数量：表示目的全納入日程合計」
[idx]["QUAL_INSP"]　→　配列内のidx番目の明細の「在庫タイプ」
[idx]["NO_MORE_GR"]　→　配列内のidx番目の明細の「納入完了 区分」
[idx]["DELETE_IND"]　→　配列内のidx番目の明細の「購買伝票の削除フラグ」
[idx]["NO_ROUNDING"]　→　配列内のidx番目の明細の「区分：購買発注明細での非表示丸め」
[idx]["TAX_CODE"]　→　配列内のidx番目の明細の「消費税コード」
[idx]["MATERIAL_EXTERNAL"]　→ 　配列内のidx番目の明細の「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["MATERIAL_GUID"]　→ 　配列内のidx番目の明細の「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["MATERIAL_VERSION"]　→ 　配列内のidx番目の明細の「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」
[idx]["PUR_MAT_EXTERNAL"]　→ 　配列内のidx番目の明細の「項目 PUR_MAT の品目コード (長) (今後のリリースで開発)」
[idx]["PUR_MAT_GUID"]　→ 　配列内のidx番目の明細の「項目 PUR_MAT の外部 GUID (今後のリリースで開発)」
[idx]["PUR_MAT_VERSION"]　→ 　配列内のidx番目の明細の「項目 PUR_MAT のバージョン番号 (今後のリリースで開発)」
[idx]["VAL_TYPE"]　→　配列内のidx番目の明細の「評価タイプ」
[idx]["PR_CLOSED"]　→　配列内のidx番目の明細の「購買依頼処理済」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getRelCode

Object getRelCode ()

承認コードを取得します。

返却値
Object 承認コード
getRelGroup

Object getRelGroup ()

承認グループを取得します。

返却値
Object 承認グループ
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 PurchaseOrderPayPostController オブジェクト

伝票登録コントローラクラス。

機能は以下の通り
  • 伝票を登録します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
PurchaseOrderPayPostController ()
コンストラクタ｡
PurchaseOrderPayPostController (ConnectionManager connectionManager)
コンストラクタ。
PurchaseOrderPayPostController (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより購買伝票を登録します。
Object | getAllVersionsList () 全バージョン一覧を取得します｡
String | getBapiReturnErrMessage () ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage () プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。
Object | getCondHeaderList () 条件ヘッダ一覧を取得します｡
Object | getCondItemList () 条件明細一覧を取得します｡
Object | getContractLimitsList () 外注基本契約制限一覧を取得します｡
Object | getContractServiceAccountList () 外注サービス勘定設定一覧を取得します｡
Object | getContractServiceList () 外注サービス一覧を取得します｡
Object | getContractServiceTextList () 外注サービステキスト一覧を取得します｡
Object | getDeliverryAddressList () 出荷伝票アドレス一覧を取得します｡
Object | getDocumentHeader () 伝票ヘッダを取得します。
Object | getExportHeader () 貿易管理ヘッダを取得します｡
Object | getExportItemList () 貿易管理明細一覧を取得します｡
Object | getExtensionList () 拡張得意先項目一覧を取得します｡
Object | getHeaderTextList () ヘッダテキスト一覧を取得します｡
Object | getItemTextList () 明細テキスト一覧を取得します｡
Object | getLimitsList () 外注制限一覧を取得します｡
Object | getMemoryComplete () エラーがない場合に購買発注を保留にする区分を取得します｡
Object | getMemoryUnComplete () エラーがある場合に購買発注を保留にする区分を取得します｡
Object | getNoAuthority () 権限チェックなし区分を取得します｡
Object | getNoMessageReq () メッセージ不要区分を取得します｡
Object | getNoMessaging () 出力決定なし区分を取得します。
Object | getNoPriceFromPo () 最終伝票からの価格転送なし区分を取得します｡
Object | getPartnerList () 得意先一覧を取得します｡
Object | getPoNumber () 購買伝票番号を取得します｡
Object | getProfitSegmentList () 入出庫予定一覧を取得します｡
Object | getPurchaseAccountList () 勘定設定一覧を取得します｡
Object | getPurchaseItemPostList () 明細一覧を取得します｡
Object | getPurchaseScheduleList () 納入日程一覧を取得します｡
Object | getSupplierInfo () 仕入先住所を取得します｡
Object | getTestRun () テスト区分を取得します。
Object | getVersions () バージョン管理を取得します｡
void | setMemoryComplete (String value) エラーがない場合に購買発注を保留する区分を設定します｡
void | setMemoryUnComplete (String value) エラーがある場合に購買発注を保留する区分を設定します｡
void | setNoAuthority (String value) 権限チェックなし区分を設定します｡
void | setNoMessage (String value) 出力決定なし区分に購買発注を保留する区分を設定します｡
void | setNoMessageReq (String value) メッセージ不要区分を設定します｡
void | setNoPriceFromPo (String value) 最終伝票からの価格転送なし区分を設定します｡
void | setStrParam (String paramStr ,String paramName ,String value) 構造型の項目に値をセットします。
void | setTblParam (String paramTable ,String paramName ,String value ,int index) テーブル型の項目に値をセットします。
void | setTestRun (String value) テスト区分を設定します｡
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
PurchaseOrderPayPostController

PurchaseOrderPayPostController ()
コンストラクタ｡
PurchaseOrderPayPostController

PurchaseOrderPayPostController (ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、PurchaseOrderPayPostController#executeBapi()実行後に必ず ConnectionManager#commit()またはConnectionManager#rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。
パラメータ
connectionManager ConnectionManager コネクションマネージャー
PurchaseOrderPayPostController

PurchaseOrderPayPostController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより購買伝票を登録します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getAllVersionsList

Object getAllVersionsList ()

全バージョン一覧を取得します｡
返却値
Object 全バージョン一覧

全バージョン情報オブジェクトの構成は以下のとおりです。
全バージョン情報
オブジェクト
(Object)
DOC_TYPE 購買伝票カテゴリ (String)
DOC_NUMBER 購買管理におけるオブジェクト番号 (String)
ITEM_NUMBER 購買管理オブジェクト：明細 (String)
VERSION 購買管理におけるバージョン番号 (String)
CREATED_BY オブジェクト登録者名 (String)
CR_ON レコード登録日 (String)
REC_TIME 登録時刻 (String)
RELEASED_BY 承認者名 (String)
RELEASE_DATE 承認日 (String)
RELEASE_TIME 承認時刻 (String)
RELEASEBY_PUR 承認購買担当者名 (String)
RELEASEDATE_PUR 購買担当者承認日付 (String)
RELEASETIME_PUR 購買担当者承認時刻 (String)
REASON 変更理由 (String)
DESCRIPTION バージョンテキスト（長） (String)
REQ_BY_EXT バージョンの外部変更番号 (String)
REQ_BY 変更を依頼した従業員 (String)
NET_VALUE 購買発注通貨による正味発注額 (String)
VALUE_CHANGED バージョンによる金額変更 (String)
CURRENCY 通貨コード (String)
CURRENCY_ISO ISO コード通貨 (String)
POST_DATE バージョンの転記日付 (String)
COMPLETED ステータス ""バージョン完了済"" (String)
STATUS バージョンステータス (String)
DELETE_IND 購買伝票の削除フラグ (String)
STATUS_DOC_OLD このバージョンの前の旧処理状況 (購買伝票内) (String)

取得した全バージョン情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["DOC_TYPE"]　→　配列内のidx番目の全バージョンの「購買伝票カテゴリ」
[idx]["DOC_NUMBER"]　→　配列内のidx番目の全バージョンの「購買管理におけるオブジェクト番号」
[idx]["ITEM_NUMBER"]　→　配列内のidx番目の全バージョンの「購買管理オブジェクト：明細」
[idx]["VERSION"]　→　配列内のidx番目の全バージョンの「購買管理におけるバージョン番号」
[idx]["CREATED_BY"]　→　配列内のidx番目の全バージョンの「オブジェクト登録者名」
[idx]["CR_ON"]　→　配列内のidx番目の全バージョンの「レコード登録日」
[idx]["REC_TIME"]　→　配列内のidx番目の全バージョンの「登録時刻」
[idx]["RELEASED_BY"]　→　配列内のidx番目の全バージョンの「承認者名」
[idx]["RELEASE_DATE"]　→　配列内のidx番目の全バージョンの「承認日」
[idx]["RELEASE_TIME"]　→　配列内のidx番目の全バージョンの「承認時刻」
[idx]["RELEASEBY_PUR"]　→　配列内のidx番目の全バージョンの「承認購買担当者名」
[idx]["RELEASEDATE_PUR"]　→　配列内のidx番目の全バージョンの「購買担当者承認日付」
[idx]["RELEASETIME_PUR"]　→　配列内のidx番目の全バージョンの「購買担当者承認時刻」
[idx]["REASON"]　→　配列内のidx番目の全バージョンの「変更理由」
[idx]["DESCRIPTION"]　→　配列内のidx番目の全バージョンの「バージョンテキスト（長）」
[idx]["REQ_BY_EXT"]　→　配列内のidx番目の全バージョンの「バージョンの外部変更番号」
[idx]["REQ_BY"]　→　配列内のidx番目の全バージョンの「変更を依頼した従業員」
[idx]["NET_VALUE"]　→　配列内のidx番目の全バージョンの「購買発注通貨による正味発注額」
[idx]["VALUE_CHANGED"]　→　配列内のidx番目の全バージョンの「バージョンによる金額変更」
[idx]["CURRENCY"]　→　配列内のidx番目の全バージョンの「通貨コード」
[idx]["CURRENCY_ISO"]　→　配列内のidx番目の全バージョンの「ISO コード通貨」
[idx]["POST_DATE"]　→　配列内のidx番目の全バージョンの「バージョンの転記日付」
[idx]["COMPLETED"]　→　配列内のidx番目の全バージョンの「ステータス "バージョン完了済"」
[idx]["STATUS"]　→　配列内のidx番目の全バージョンの「バージョンステータス」
[idx]["DELETE_IND"]　→　配列内のidx番目の全バージョンの「購買伝票の削除フラグ」
[idx]["STATUS_DOC_OLD"] 　→　配列内のidx番目の全バージョンの「このバージョンの前の旧処理状況 (購買伝票内)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getBapiReturnErrMessage

String getBapiReturnErrMessage ()

ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡
返却値
String BAPI実行結果エラーとなった全てのメッセージ情報
getBapiReturnMessage

String getBapiReturnMessage ()

プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡
返却値
String プロパティファイルでオートコミット条件に一致したType情報のメッセージ情報
getCondHeaderList

Object getCondHeaderList ()

条件ヘッダ一覧を取得します｡
返却値
Object 条件ヘッダ一覧

条件ヘッダ情報オブジェクトの構成は以下のとおりです。
条件ヘッダ情報
オブジェクト
(Object)
CONDITION_NO 伝票条件番号 (String)
ITM_NUMBER 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件カウンタ (String)
COND_TYPE 条件タイプ (String)
COND_VALUE 条件レート (String)
CURRENCY 通貨コード (String)
CURRENCY_ISO ISO コード通貨 (String)
COND_UNIT 条件単位 (String)
COND_UNIT_ISO 条件数量単位 (ISO コード) (String)
COND_P_UNT 価格条件単位 (String)
APPLICATIO アプリケーション (String)
CONPRICDAT 条件価格設定日付 (String)
CALCTYPCON 条件計算タイプ (String)
CONBASEVAL 条件基礎値 (String)
CONEXCHRAT 現地通貨への換算レートに対する条件 (String)
NUMCONVERT 条件単位を基本単位へ変換する分子 (String)
DENOMINATO 条件単位を基本単位へ変換する分母 (String)
CONDTYPE 条件カテゴリ (例：税、運賃、価格、原価) (String)
STAT_CON 統計に適用する条件 (String)
SCALETYPE スケールタイプ (String)
ACCRUALS 見越額関連条件 (運賃など) (String)
CONINVOLST 請求書一覧条件 (String)
CONDORIGIN 条件生成区分 (String)
GROUPCOND グループ条件区分 (String)
COND_UPDAT 条件更新 (String)
ACCESS_SEQ 検索順序 - 検索番号 (String)
CONDCOUNT 条件連続番号 (String)
CONDCNTRL 条件管理 (String)
CONDISACTI 無効条件 (String)
CONDCLASS 条件クラス (String)
FACTBASVAL 条件基礎値に対する要因 (String)
SCALEBASIN スケール基準区分 (String)
SCALBASVAL 条件のスケール基準値 (String)
UNITMEASUR 条件スケール単位 (String)
UNITMEASUR_ISO 単位の ISO コード (String)
CURRENCKEY スケール通貨 (String)
CURRENCKEY_ISO ISO コード通貨 (String)
CONDINCOMP 会社間請求の条件 (String)
CONDCONFIG システム設定の条件 (String)
CONDCHAMAN 条件 (マニュアル変更済) (String)
COND_NO 条件レコード番号 (String)
CHANGE_ID 変更タイプ(U、I、E、D) (String)

取得した条件ヘッダ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONDITION_NO"]　→　配列内のidx番目の条件ヘッダの「伝票条件番号」
[idx]["ITM_NUMBER"]　→　配列内のidx番目の条件ヘッダの「条件明細番号」
[idx]["COND_ST_NO"]　→　配列内のidx番目の条件ヘッダの「ステップ番号」
[idx]["COND_COUNT"]　→　配列内のidx番目の条件ヘッダの「条件カウンタ」
[idx]["COND_TYPE"]　→　配列内のidx番目の条件ヘッダの「条件タイプ」
[idx]["COND_VALUE"]　→　配列内のidx番目の条件ヘッダの「条件レート」
[idx]["CURRENCY"]　→　配列内のidx番目の条件ヘッダの「通貨コード」
[idx]["CURRENCY_ISO"]　→　配列内のidx番目の条件ヘッダの「ISO コード通貨」
[idx]["COND_UNIT"]　→　配列内のidx番目の条件ヘッダの「条件単位」
[idx]["COND_UNIT_ISO"]　→　配列内のidx番目の条件ヘッダの「条件数量単位 (ISO コード)」
[idx]["COND_P_UNT"]　→　配列内のidx番目の条件ヘッダの「価格条件単位」
[idx]["APPLICATIO"]　→　配列内のidx番目の条件ヘッダの「アプリケーション」
[idx]["CONPRICDAT"]　→　配列内のidx番目の条件ヘッダの「条件価格設定日付」
[idx]["CALCTYPCON"]　→　配列内のidx番目の条件ヘッダの「条件計算タイプ」
[idx]["CONBASEVAL"]　→　配列内のidx番目の条件ヘッダの「条件基礎値」
[idx]["CONEXCHRAT"]　→　配列内のidx番目の条件ヘッダの「現地通貨への換算レートに対する条件」
[idx]["NUMCONVERT"]　→　配列内のidx番目の条件ヘッダの「条件単位を基本単位へ変換する分子」
[idx]["DENOMINATO"]　→　配列内のidx番目の条件ヘッダの「条件単位を基本単位へ変換する分母」
[idx]["CONDTYPE"]　→　配列内のidx番目の条件ヘッダの「条件カテゴリ (例：税、運賃、価格、原価)」
[idx]["STAT_CON"]　→　配列内のidx番目の条件ヘッダの「統計に適用する条件」
[idx]["SCALETYPE"]　→　配列内のidx番目の条件ヘッダの「スケールタイプ」
[idx]["ACCRUALS"]　→　配列内のidx番目の条件ヘッダの「見越額関連条件 (運賃など)」
[idx]["CONINVOLST"]　→　配列内のidx番目の条件ヘッダの「請求書一覧条件」
[idx]["CONDORIGIN"]　→　配列内のidx番目の条件ヘッダの「条件生成区分」
[idx]["GROUPCOND"]　→　配列内のidx番目の条件ヘッダの「グループ条件区分」
[idx]["COND_UPDAT"]　→　配列内のidx番目の条件ヘッダの「条件更新」
[idx]["ACCESS_SEQ"]　→　配列内のidx番目の条件ヘッダの「検索順序 - 検索番号」
[idx]["CONDCOUNT"]　→　配列内のidx番目の条件ヘッダの「条件連続番号」
[idx]["CONDCNTRL"]　→　配列内のidx番目の条件ヘッダの「条件管理」
[idx]["CONDISACTI"]　→　配列内のidx番目の条件ヘッダの「無効条件」
[idx]["CONDCLASS"]　→　配列内のidx番目の条件ヘッダの「条件クラス」
[idx]["FACTBASVAL"]　→　配列内のidx番目の条件ヘッダの「条件基礎値に対する要因」
[idx]["SCALEBASIN"]　→　配列内のidx番目の条件ヘッダの「スケール基準区分」
[idx]["SCALBASVAL"]　→　配列内のidx番目の条件ヘッダの「条件のスケール基準値」
[idx]["UNITMEASUR"]　→　配列内のidx番目の条件ヘッダの「条件スケール単位」
[idx]["UNITMEASUR_ISO"]　→　配列内のidx番目の条件ヘッダの「単位の ISO コード」
[idx]["CURRENCKEY"]　→　配列内のidx番目の条件ヘッダの「スケール通貨」
[idx]["CURRENCKEY_ISO"]　→　配列内のidx番目の条件ヘッダの「ISO コード通貨」
[idx]["CONDINCOMP"]　→　配列内のidx番目の条件ヘッダの「会社間請求の条件」
[idx]["CONDCONFIG"]　→　配列内のidx番目の条件ヘッダの「システム設定の条件」
[idx]["CONDCHAMAN"]　→　配列内のidx番目の条件ヘッダの「条件 (マニュアル変更済)」
[idx]["COND_NO"]　→　配列内のidx番目の条件ヘッダの「条件レコード番号」
[idx]["CHANGE_ID"]　→　配列内のidx番目の条件ヘッダの「変更タイプ(U、I、E、D)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getCondItemList

Object getCondItemList ()

条件明細一覧を取得します｡
返却値
Object 条件明細一覧

条件明細情報オブジェクトの構成は以下のとおりです。
条件明細情報
オブジェクト
(Object)
CONDITION_NO 伝票条件番号 (String)
ITM_NUMBER 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件カウンタ (String)
COND_TYPE 条件タイプ (String)
COND_VALUE 条件レート (String)
CURRENCY 通貨コード (String)
CURRENCY_ISO ISO コード通貨 (String)
COND_UNIT 条件単位 (String)
COND_UNIT_ISO 条件数量単位 (ISO コード) (String)
COND_P_UNT 価格条件単位 (String)
APPLICATIO アプリケーション (String)
CONPRICDAT 条件価格設定日付 (String)
CALCTYPCON 条件計算タイプ (String)
CONBASEVAL 条件基礎値 (String)
CONEXCHRAT 現地通貨への換算レートに対する条件 (String)
NUMCONVERT 条件単位を基本単位へ変換する分子 (String)
DENOMINATO 条件単位を基本単位へ変換する分母 (String)
CONDTYPE 条件カテゴリ (例：税、運賃、価格、原価) (String)
STAT_CON 統計に適用する条件 (String)
SCALETYPE スケールタイプ (String)
ACCRUALS 見越額関連条件 (運賃など) (String)
CONINVOLST 請求書一覧条件 (String)
CONDORIGIN 条件生成区分 (String)
GROUPCOND グループ条件区分 (String)
COND_UPDAT 条件更新 (String)
ACCESS_SEQ 検索順序 - 検索番号 (String)
CONDCOUNT 条件連続番号 (String)
CONDCNTRL 条件管理 (String)
CONDISACTI 無効条件 (String)
CONDCLASS 条件クラス (String)
FACTBASVAL 条件基礎値に対する要因 (String)
SCALEBASIN スケール基準区分 (String)
SCALBASVAL 条件のスケール基準値 (String)
UNITMEASUR 条件スケール単位 (String)
UNITMEASUR_ISO 単位の ISO コード (String)
CURRENCKEY スケール通貨 (String)
CURRENCKEY_ISO ISO コード通貨 (String)
CONDINCOMP 会社間請求の条件 (String)
CONDCONFIG システム設定の条件 (String)
CONDCHAMAN 条件 (マニュアル変更済) (String)
COND_NO 条件レコード番号 (String)
CHANGE_ID 変更タイプ(U、I、E、D) (String)

取得した条件明細情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONDITION_NO"]　→　配列内のidx番目の条件明細の「伝票条件番号」
[idx]["ITM_NUMBER"]　→　配列内のidx番目の条件明細の「条件明細番号」
[idx]["COND_ST_NO"]　→　配列内のidx番目の条件明細の「ステップ番号」
[idx]["COND_COUNT"]　→　配列内のidx番目の条件明細の「条件カウンタ」
[idx]["COND_TYPE"]　→　配列内のidx番目の条件明細の「条件タイプ」
[idx]["COND_VALUE"]　→　配列内のidx番目の条件明細の「条件レート」
[idx]["CURRENCY"]　→　配列内のidx番目の条件明細の「通貨コード」
[idx]["CURRENCY_ISO"]　→　配列内のidx番目の条件明細の「ISO コード通貨」
[idx]["COND_UNIT"]　→　配列内のidx番目の条件明細の「条件単位」
[idx]["COND_UNIT_ISO"]　→　配列内のidx番目の条件明細の「条件数量単位 (ISO コード)」
[idx]["COND_P_UNT"]　→　配列内のidx番目の条件明細の「価格条件単位」
[idx]["APPLICATIO"]　→　配列内のidx番目の条件明細の「アプリケーション」
[idx]["CONPRICDAT"]　→　配列内のidx番目の条件明細の「条件価格設定日付」
[idx]["CALCTYPCON"]　→　配列内のidx番目の条件明細の「条件計算タイプ」
[idx]["CONBASEVAL"]　→　配列内のidx番目の条件明細の「条件基礎値」
[idx]["CONEXCHRAT"]　→　配列内のidx番目の条件明細の「現地通貨への換算レートに対する条件」
[idx]["NUMCONVERT"]　→　配列内のidx番目の条件明細の「条件単位を基本単位へ変換する分子」
[idx]["DENOMINATO"]　→　配列内のidx番目の条件明細の「条件単位を基本単位へ変換する分母」
[idx]["CONDTYPE"]　→　配列内のidx番目の条件明細の「条件カテゴリ (例：税、運賃、価格、原価)」
[idx]["STAT_CON"]　→　配列内のidx番目の条件明細の「統計に適用する条件」
[idx]["SCALETYPE"]　→　配列内のidx番目の条件明細の「スケールタイプ」
[idx]["ACCRUALS"]　→　配列内のidx番目の条件明細の「見越額関連条件 (運賃など)」
[idx]["CONINVOLST"]　→　配列内のidx番目の条件明細の「請求書一覧条件」
[idx]["CONDORIGIN"]　→　配列内のidx番目の条件明細の「条件生成区分」
[idx]["GROUPCOND"]　→　配列内のidx番目の条件明細の「グループ条件区分」
[idx]["COND_UPDAT"]　→　配列内のidx番目の条件明細の「条件更新」
[idx]["ACCESS_SEQ"]　→　配列内のidx番目の条件明細の「検索順序 - 検索番号」
[idx]["CONDCOUNT"]　→　配列内のidx番目の条件明細の「条件連続番号」
[idx]["CONDCNTRL"]　→　配列内のidx番目の条件明細の「条件管理」
[idx]["CONDISACTI"]　→　配列内のidx番目の条件明細の「無効条件」
[idx]["CONDCLASS"]　→　配列内のidx番目の条件明細の「条件クラス」
[idx]["FACTBASVAL"]　→　配列内のidx番目の条件明細の「条件基礎値に対する要因」
[idx]["SCALEBASIN"]　→　配列内のidx番目の条件明細の「スケール基準区分」
[idx]["SCALBASVAL"]　→　配列内のidx番目の条件明細の「条件のスケール基準値」
[idx]["UNITMEASUR"]　→　配列内のidx番目の条件明細の「条件スケール単位」
[idx]["UNITMEASUR_ISO"]　→　配列内のidx番目の条件明細の「単位の ISO コード」
[idx]["CURRENCKEY"]　→　配列内のidx番目の条件明細の「スケール通貨」
[idx]["CURRENCKEY_ISO"]　→　配列内のidx番目の条件明細の「ISO コード通貨」
[idx]["CONDINCOMP"]　→　配列内のidx番目の条件明細の「会社間請求の条件」
[idx]["CONDCONFIG"]　→　配列内のidx番目の条件明細の「システム設定の条件」
[idx]["CONDCHAMAN"]　→　配列内のidx番目の条件明細の「条件 (マニュアル変更済)」
[idx]["COND_NO"]　→　配列内のidx番目の条件明細の「条件レコード番号」
[idx]["CHANGE_ID"]　→　配列内のidx番目の条件明細の「変更タイプ(U、I、E、D)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getContractLimitsList

Object getContractLimitsList ()

外注基本契約制限一覧を取得します｡
返却値
Object 外注基本契約制限一覧

外注基本契約制限情報オブジェクトの構成は以下のとおりです。
外注基本契約制限情報
オブジェクト
(Object)
PCKG_NO パッケージ番号 (String)
LINE_NO 制限の内部明細番号 (String)
CON_NUMBER 基本契約番号 (String)
CON_ITEM 明細番号、契約 (String)
LIMIT 全体制限 (String)
NO_LIMIT 制限なし (String)
PRICE_CHG 入力シートの価格変更 (String)
SHORT_TEXT テキスト 1 (短) (String)
DELETE_IND 削除フラグ (String)

取得した外注基本契約制限情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PCKG_NO"]　→　配列内のidx番目の外注基本契約制限の「パッケージ番号」
[idx]["LINE_NO"]　→　配列内のidx番目の外注基本契約制限の「制限の内部明細番号」
[idx]["CON_NUMBER"]　→　配列内のidx番目の外注基本契約制限の「基本契約番号」
[idx]["CON_ITEM"]　→　配列内のidx番目の外注基本契約制限の「明細番号、契約」
[idx]["LIMIT"]　→　配列内のidx番目の外注基本契約制限の「全体制限」
[idx]["NO_LIMIT"]　→　配列内のidx番目の外注基本契約制限の「制限なし」
[idx]["PRICE_CHG"]　→　配列内のidx番目の外注基本契約制限の「入力シートの価格変更」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の外注基本契約制限の「テキスト 1 (短)」
[idx]["DELETE_IND"]　→　配列内のidx番目の外注基本契約制限の「削除フラグ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getContractServiceAccountList

Object getContractServiceAccountList ()

外注サービス勘定設定一覧を取得します｡
返却値
Object 外注サービス勘定設定一覧

外注サービス勘定設定情報オブジェクトの構成は以下のとおりです。
外注サービス勘定設定情報
オブジェクト
(Object)
PCKG_NO パッケージ番号 (String)
LINE_NO 明細行番号 (String)
SERNO_LINE 勘定コード設定のシリアル番号、サービス明細 (String)
PERCENTAGE 勘定設定金額配賦のパーセント (String)
SERIAL_NO 勘定設定の連続番号 (String)
QUANTITY +/- 記号あり/なし数量 (String)
NET_VALUE 明細の正味額 (String)

取得した外注サービス勘定設定情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PCKG_NO"]　→　配列内のidx番目の外注サービス勘定設定の「パッケージ番号」
[idx]["LINE_NO"]　→　配列内のidx番目の外注サービス勘定設定の「明細行番号」
[idx]["SERNO_LINE"] 　→　配列内のidx番目の外注サービス勘定設定の「勘定コード設定のシリアル番号、サービス明細」
[idx]["PERCENTAGE"]　→　配列内のidx番目の外注サービス勘定設定の「勘定設定金額配賦のパーセント」
[idx]["SERIAL_NO"]　→　配列内のidx番目の外注サービス勘定設定の「勘定設定の連続番号」
[idx]["QUANTITY"]　→　配列内のidx番目の外注サービス勘定設定の「+/- 記号あり/なし数量」
[idx]["NET_VALUE"]　→　配列内のidx番目の外注サービス勘定設定の「明細の正味額」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getContractServiceList

Object getContractServiceList ()

外注サービス一覧を取得します｡
返却値
Object 外注サービス一覧

外注サービス情報オブジェクトの構成は以下のとおりです。
外注サービス情報
オブジェクト
(Object)
PCKG_NO パッケージ番号 (String)
LINE_NO 内部明細番号 (String)
EXT_LINE 明細番号 (String)
OUTL_LEVEL グループの階層レベル (String)
OUTL_NO アウトラインレベル (String)
OUTL_IND 区分：出力行 (String)
SUBPCKG_NO サブパッケージ番号 (String)
SERVICE 活動番号 (String)
SERV_TYPE サービスタイプのテキスト (短) (String)
EDITION サービスタイプのバージョン (String)
SSC_ITEM 標準サービスカタログ：明細 (String)
EXT_SERV 仕入先のサービス番号 (String)
QUANTITY +/- 記号あり/なし数量 (String)
BASE_UOM 基本数量単位 (String)
UOM_ISO 単位の ISO コード (String)
OVF_TOL 超過許容値 (String)
OVF_UNLIM 契約外サービス制限なし (String)
PRICE_UNIT 価格単位 (String)
GR_PRICE 基準額 (String)
FROM_LINE 下限 (String)
TO_LINE 上限 (String)
SHORT_TEXT テキスト(短) (String)
DISTRIB 複数勘定設定の配賦区分 (String)
PERS_NO 従業員番号 (String)
WAGETYPE ウェイジタイプ (String)
PLN_PCKG パッケージ番号供給元一覧 (String)
PLN_LINE 入力：計画梱包明細行 (String)
CON_PCKG 入力：基本契約の計画外 (String)
CON_LINE 入力：基本契約の計画外 (String)
TMP_PCKG 入力：モデル仕様からの計画外サービス (String)
TMP_LINE 入力：モデル仕様からの計画外サービス (String)
SSC_LIM 標準サービスカタログ制限参照のサービス行 (String)
LIMIT_LINE 入力：計画外、明細制限 (String)
TARGET_VAL 目標値 (String)
BASLINE_NO 代替：基本明細参照 (String)
BASIC_LINE 基本明細 (String)
ALTERNAT 代替明細 (String)
BIDDER 入札者の明細 (String)
SUPP_LINE 補足明細 (String)
OPEN_QTY 未処理数量のある明細 (String)
INFORM 情報行 (String)
BLANKET 包括明細 (String)
EVENTUAL 偶発的明細 (String)
TAX_CODE 消費税コード (String)
TAXJURCODE 税計算管轄コード - 税管轄コード (String)
PRICE_CHG 入力シートの価格変更 (String)
MATL_GROUP 品目グループ (String)
DATE 日付 (String)
BEGINTIME 開始時刻 (String)
ENDTIME 終了時刻 (String)
EXTPERS_NO 外部従業員番号 (String)
FORMULA 計算式番号 (String)
FORM_VAL1 計算式値 (String)
FORM_VAL2 計算式値 (String)
FORM_VAL3 計算式値 (String)
FORM_VAL4 計算式値 (String)
FORM_VAL5 計算式値 (String)
USERF1_NUM ユーザ定義項目 (String)
USERF2_NUM ユーザ定義項目 (String)
USERF1_TXT ユーザ定義項目 (String)
USERF2_TXT ユーザ定義項目 (String)
HI_LINE_NO 上位階層明細番号 (String)
EXTREFKEY サービスの外部参照キー (String)
DELETE_IND 削除フラグ (String)

取得した外注サービス情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PCKG_NO"]　→　配列内のidx番目の外注サービスの「パッケージ番号」
[idx]["LINE_NO"]　→　配列内のidx番目の外注サービスの「内部明細番号」
[idx]["EXT_LINE"]　→　配列内のidx番目の外注サービスの「明細番号」
[idx]["OUTL_LEVEL"]　→　配列内のidx番目の外注サービスの「グループの階層レベル」
[idx]["OUTL_NO"]　→　配列内のidx番目の外注サービスの「アウトラインレベル」
[idx]["OUTL_IND"]　→　配列内のidx番目の外注サービスの「区分：出力行」
[idx]["SUBPCKG_NO"]　→　配列内のidx番目の外注サービスの「サブパッケージ番号」
[idx]["SERVICE"]　→　配列内のidx番目の外注サービスの「活動番号」
[idx]["SERV_TYPE"]　→　配列内のidx番目の外注サービスの「サービスタイプのテキスト (短)」
[idx]["EDITION"]　→　配列内のidx番目の外注サービスの「サービスタイプのバージョン」
[idx]["SSC_ITEM"]　→　配列内のidx番目の外注サービスの「標準サービスカタログ：明細」
[idx]["EXT_SERV"]　→　配列内のidx番目の外注サービスの「仕入先のサービス番号」
[idx]["QUANTITY"]　→　配列内のidx番目の外注サービスの「+/- 記号あり/なし数量」
[idx]["BASE_UOM"]　→　配列内のidx番目の外注サービスの「基本数量単位」
[idx]["UOM_ISO"]　→　配列内のidx番目の外注サービスの「単位の ISO コード」
[idx]["OVF_TOL"]　→　配列内のidx番目の外注サービスの「超過許容値」
[idx]["OVF_UNLIM"]　→　配列内のidx番目の外注サービスの「契約外サービス制限なし」
[idx]["PRICE_UNIT"]　→　配列内のidx番目の外注サービスの「価格単位」
[idx]["GR_PRICE"]　→　配列内のidx番目の外注サービスの「基準額」
[idx]["FROM_LINE"]　→　配列内のidx番目の外注サービスの「下限」
[idx]["TO_LINE"]　→　配列内のidx番目の外注サービスの「上限」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の外注サービスの「テキスト(短)」
[idx]["DISTRIB"]　→　配列内のidx番目の外注サービスの「複数勘定設定の配賦区分」
[idx]["PERS_NO"]　→　配列内のidx番目の外注サービスの「従業員番号」
[idx]["WAGETYPE"]　→　配列内のidx番目の外注サービスの「ウェイジタイプ」
[idx]["PLN_PCKG"]　→　配列内のidx番目の外注サービスの「パッケージ番号供給元一覧」
[idx]["PLN_LINE"]　→　配列内のidx番目の外注サービスの「入力：計画梱包明細行」
[idx]["CON_PCKG"]　→　配列内のidx番目の外注サービスの「入力：基本契約の計画外」
[idx]["CON_LINE"]　→　配列内のidx番目の外注サービスの「入力：基本契約の計画外」
[idx]["TMP_PCKG"]　→　配列内のidx番目の外注サービスの「入力：モデル仕様からの計画外サービス」
[idx]["TMP_LINE"]　→　配列内のidx番目の外注サービスの「入力：モデル仕様からの計画外サービス」
[idx]["SSC_LIM"]　→　配列内のidx番目の外注サービスの「標準サービスカタログ制限参照のサービス行」
[idx]["LIMIT_LINE"]　→　配列内のidx番目の外注サービスの「入力：計画外、明細制限」
[idx]["TARGET_VAL"]　→　配列内のidx番目の外注サービスの「目標値」
[idx]["BASLINE_NO"]　→　配列内のidx番目の外注サービスの「代替：基本明細参照」
[idx]["BASIC_LINE"]　→　配列内のidx番目の外注サービスの「基本明細」
[idx]["ALTERNAT"]　→　配列内のidx番目の外注サービスの「代替明細」
[idx]["BIDDER"]　→　配列内のidx番目の外注サービスの「入札者の明細」
[idx]["SUPP_LINE"]　→　配列内のidx番目の外注サービスの「補足明細」
[idx]["OPEN_QTY"]　→　配列内のidx番目の外注サービスの「未処理数量のある明細」
[idx]["INFORM"]　→　配列内のidx番目の外注サービスの「情報行」
[idx]["BLANKET"]　→　配列内のidx番目の外注サービスの「包括明細」
[idx]["EVENTUAL"]　→　配列内のidx番目の外注サービスの「偶発的明細」
[idx]["TAX_CODE"]　→　配列内のidx番目の外注サービスの「消費税コード」
[idx]["TAXJURCODE"]　→　配列内のidx番目の外注サービスの「税計算管轄コード - 税管轄コード」
[idx]["PRICE_CHG"]　→　配列内のidx番目の外注サービスの「入力シートの価格変更」
[idx]["MATL_GROUP"]　→　配列内のidx番目の外注サービスの「品目グループ」
[idx]["DATE"]　→　配列内のidx番目の外注サービスの「日付」
[idx]["BEGINTIME"]　→　配列内のidx番目の外注サービスの「開始時刻」
[idx]["ENDTIME"]　→　配列内のidx番目の外注サービスの「終了時刻」
[idx]["EXTPERS_NO"]　→　配列内のidx番目の外注サービスの「外部従業員番号」
[idx]["FORMULA"]　→　配列内のidx番目の外注サービスの「計算式番号」
[idx]["FORM_VAL1"]　→　配列内のidx番目の外注サービスの「計算式値」
[idx]["FORM_VAL2"]　→　配列内のidx番目の外注サービスの「計算式値」
[idx]["FORM_VAL3"]　→　配列内のidx番目の外注サービスの「計算式値」
[idx]["FORM_VAL4"]　→　配列内のidx番目の外注サービスの「計算式値」
[idx]["FORM_VAL5"]　→　配列内のidx番目の外注サービスの「計算式値」
[idx]["USERF1_NUM"]　→　配列内のidx番目の外注サービスの「ユーザ定義項目」
[idx]["USERF2_NUM"]　→　配列内のidx番目の外注サービスの「ユーザ定義項目」
[idx]["USERF1_TXT"]　→　配列内のidx番目の外注サービスの「ユーザ定義項目」
[idx]["USERF2_TXT"]　→　配列内のidx番目の外注サービスの「ユーザ定義項目」
[idx]["HI_LINE_NO"]　→　配列内のidx番目の外注サービスの「上位階層明細番号」
[idx]["EXTREFKEY"]　→　配列内のidx番目の外注サービスの「サービスの外部参照キー」
[idx]["DELETE_IND"]　→　配列内のidx番目の外注サービスの「削除フラグ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getContractServiceTextList

Object getContractServiceTextList ()

外注サービステキスト一覧を取得します｡
返却値
Object 外注サービステキスト一覧

外注サービステキスト情報オブジェクトの構成は以下のとおりです。
外注サービステキスト情報
オブジェクト
(Object)
PCKG_NO パッケージ番号 (String)
LINE_NO 内部明細番号 (String)
TEXT_ID テキスト ID (String)
FORMAT_COL タグ列 (String)
TEXT_LINE テキスト行 (String)

取得した外注サービステキスト情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PCKG_NO"]　→　配列内のidx番目の外注サービステキストの「パッケージ番号」
[idx]["LINE_NO"]　→　配列内のidx番目の外注サービステキストの「内部明細番号」
[idx]["TEXT_ID"]　→　配列内のidx番目の外注サービステキストの「テキスト ID」
[idx]["FORMAT_COL"]　→　配列内のidx番目の外注サービステキストの「タグ列」
[idx]["TEXT_LINE"]　→　配列内のidx番目の外注サービステキストの「テキスト行」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getDeliverryAddressList

Object getDeliverryAddressList ()

出荷伝票アドレス一覧を取得します｡
返却値
Object 出荷伝票アドレス一覧

出荷伝票アドレス情報オブジェクトの構成は以下のとおりです。
出荷伝票アドレス情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号 (String)
ADDR_NO アドレス番号 (String)
FORMOFADDR 敬称テキスト (String)
NAME 名称 1 (String)
NAME_2 名称 2 (String)
NAME_3 名称 3 (String)
NAME_4 名称 4 (String)
C_O_NAME 気付 (String)
CITY 市区町村 (String)
DISTRICT 所在地 (String)
CITY_NO 市区町村/地名ファイルの市区町村コード (String)
POSTL_COD1 市区町村の郵便番号 (String)
POSTL_COD2 私書箱郵便番号 (String)
POSTL_COD3 会社郵便番号 (大規模なユーザ用) (String)
PO_BOX 私書箱 (String)
PO_BOX_CIT 私書箱住所 (String)
DELIV_DIS 郵便配達地域 (String)
STREET 地名 (String)
STREET_NO 市区町村/地名ファイルの地名コード (String)
STR_ABBR 地名の略称 (例：スペイン) (String)
HOUSE_NO 番地-号 (String)
STR_SUPPL1 地名 2 (String)
STR_SUPPL2 地名 3 (String)
LOCATION 地名 5 (String)
BUILDING 旧：建物 (番号または略称) (String)
FLOOR 建物の階 (String)
ROOM_NO 部屋/アパート番号 (String)
COUNTRY 国コード (String)
LANGU 言語キー (String)
REGION 地域 (都道府県) (String)
SORT1 検索条件 1 (String)
SORT2 検索条件 2 (String)
TIME_ZONE アドレスタイムゾーン (String)
TAXJURCODE 税管轄コード (String)
ADR_NOTES 住所注記 (String)
COMM_TYPE 通信方法 (キー) (アドレス管理) (String)
TEL1_NUMBR 第一電話番号：ダイヤルコード + 番号 (String)
TEL1_EXT 第 1 電話番号：内線 (String)
FAX_NUMBER 第一 FAX 番号：ダイヤルコード + 番号 (String)
FAX_EXTENS 第一 FAX 番号：内線 (String)
STREET_LNG 地名 (String)
DISTRCT_NO 市区町村/地名ファイルの所在地コード (String)
CHCKSTATUS 市区町村ファイルテストステータス (String)
PBOXCIT_NO 市区町村私書箱コード (市ファイル) (String)
TRANSPZONE 商品の納入区域 (String)
HOUSE_NO2 番地補足 (String)
E_MAIL 電子メールアドレス (String)
STR_SUPPL3 地名 4 (String)
TITLE タイトル (敬称) (String)
COUNTRYISO ISO 国コード (String)
LANGU_ISO ISO 639 準拠の言語 (String)
BUILD_LONG 建物 (番号またはコード) (String)
REGIOGROUP 地域構造グループ化 (String)

取得した出荷伝票アドレス情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の出荷伝票アドレスの「購買伝票の明細番号」
[idx]["ADDR_NO"]　→　配列内のidx番目の出荷伝票アドレスの「アドレス番号」
[idx]["FORMOFADDR"]　→　配列内のidx番目の出荷伝票アドレスの「敬称テキスト」
[idx]["NAME"]　→　配列内のidx番目の出荷伝票アドレスの「名称 1」
[idx]["NAME_2"]　→　配列内のidx番目の出荷伝票アドレスの「名称 2」
[idx]["NAME_3"]　→　配列内のidx番目の出荷伝票アドレスの「名称 3」
[idx]["NAME_4"]　→　配列内のidx番目の出荷伝票アドレスの「名称 4」
[idx]["C_O_NAME"]　→　配列内のidx番目の出荷伝票アドレスの「気付」
[idx]["CITY"]　→　配列内のidx番目の出荷伝票アドレスの「市区町村」
[idx]["DISTRICT"]　→　配列内のidx番目の出荷伝票アドレスの「所在地」
[idx]["CITY_NO"]　→　配列内のidx番目の出荷伝票アドレスの「市区町村/地名ファイルの市区町村コード」
[idx]["POSTL_COD1"]　→　配列内のidx番目の出荷伝票アドレスの「市区町村の郵便番号」
[idx]["POSTL_COD2"]　→　配列内のidx番目の出荷伝票アドレスの「私書箱郵便番号」
[idx]["POSTL_COD3"] 　→　配列内のidx番目の出荷伝票アドレスの「会社郵便番号 (大規模なユーザ用)」
[idx]["PO_BOX"]　→　配列内のidx番目の出荷伝票アドレスの「私書箱」
[idx]["PO_BOX_CIT"]　→　配列内のidx番目の出荷伝票アドレスの「私書箱住所」
[idx]["DELIV_DIS"]　→　配列内のidx番目の出荷伝票アドレスの「郵便配達地域」
[idx]["STREET"]　→　配列内のidx番目の出荷伝票アドレスの「地名」
[idx]["STREET_NO"]　→　配列内のidx番目の出荷伝票アドレスの「市区町村/地名ファイルの地名コード」
[idx]["STR_ABBR"]　→　配列内のidx番目の出荷伝票アドレスの「地名の略称 (例：スペイン)」
[idx]["HOUSE_NO"]　→　配列内のidx番目の出荷伝票アドレスの「番地-号」
[idx]["STR_SUPPL1"]　→　配列内のidx番目の出荷伝票アドレスの「地名 2」
[idx]["STR_SUPPL2"]　→　配列内のidx番目の出荷伝票アドレスの「地名 3」
[idx]["LOCATION"]　→　配列内のidx番目の出荷伝票アドレスの「地名 5」
[idx]["BUILDING"]　→　配列内のidx番目の出荷伝票アドレスの「旧：建物 (番号または略称)」
[idx]["FLOOR"]　→　配列内のidx番目の出荷伝票アドレスの「建物の階」
[idx]["ROOM_NO"]　→　配列内のidx番目の出荷伝票アドレスの「部屋/アパート番号」
[idx]["COUNTRY"]　→　配列内のidx番目の出荷伝票アドレスの「国コード」
[idx]["LANGU"]　→　配列内のidx番目の出荷伝票アドレスの「言語キー」
[idx]["REGION"]　→　配列内のidx番目の出荷伝票アドレスの「地域 (都道府県)」
[idx]["SORT1"]　→　配列内のidx番目の出荷伝票アドレスの「検索条件 1」
[idx]["SORT2"]　→　配列内のidx番目の出荷伝票アドレスの「検索条件 2」
[idx]["TIME_ZONE"]　→　配列内のidx番目の出荷伝票アドレスの「アドレスタイムゾーン」
[idx]["TAXJURCODE"]　→　配列内のidx番目の出荷伝票アドレスの「税管轄コード」
[idx]["ADR_NOTES"]　→　配列内のidx番目の出荷伝票アドレスの「住所注記」
[idx]["COMM_TYPE"] 　→　配列内のidx番目の出荷伝票アドレスの「通信方法 (キー) (アドレス管理)」
[idx]["TEL1_NUMBR"] 　→　配列内のidx番目の出荷伝票アドレスの「第一電話番号：ダイヤルコード + 番号」
[idx]["TEL1_EXT"]　→　配列内のidx番目の出荷伝票アドレスの「第 1 電話番号：内線」
[idx]["FAX_NUMBER"] 　→　配列内のidx番目の出荷伝票アドレスの「第一 FAX 番号：ダイヤルコード + 番号」
[idx]["FAX_EXTENS"]　→　配列内のidx番目の出荷伝票アドレスの「第一 FAX 番号：内線」
[idx]["STREET_LNG"]　→　配列内のidx番目の出荷伝票アドレスの「地名」
[idx]["DISTRCT_NO"] 　→　配列内のidx番目の出荷伝票アドレスの「市区町村/地名ファイルの所在地コード」
[idx]["CHCKSTATUS"]　→　配列内のidx番目の出荷伝票アドレスの「市区町村ファイルテストステータス」
[idx]["PBOXCIT_NO"] 　→　配列内のidx番目の出荷伝票アドレスの「市区町村私書箱コード (市ファイル)」
[idx]["TRANSPZONE"]　→　配列内のidx番目の出荷伝票アドレスの「商品の納入区域」
[idx]["HOUSE_NO2"]　→　配列内のidx番目の出荷伝票アドレスの「番地補足」
[idx]["E_MAIL"]　→　配列内のidx番目の出荷伝票アドレスの「電子メールアドレス」
[idx]["STR_SUPPL3"]　→　配列内のidx番目の出荷伝票アドレスの「地名 4」
[idx]["TITLE"]　→　配列内のidx番目の出荷伝票アドレスの「タイトル (敬称)」
[idx]["COUNTRYISO"]　→　配列内のidx番目の出荷伝票アドレスの「ISO 国コード」
[idx]["LANGU_ISO"]　→　配列内のidx番目の出荷伝票アドレスの「ISO 639 準拠の言語」
[idx]["BUILD_LONG"]　→　配列内のidx番目の出荷伝票アドレスの「建物 (番号またはコード)」
[idx]["REGIOGROUP"]　→　配列内のidx番目の出荷伝票アドレスの「地域構造グループ化」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getDocumentHeader

Object getDocumentHeader ()

伝票ヘッダを取得します。
返却値
Object 伝票ヘッダオブジェクト

伝票ヘッダオブジェクトの構成は以下のとおりです。
伝票ヘッダ情報
オブジェクト
(Object)
PO_NUMBER 購買伝票番号 (String)
COMP_CODE 会社コード (String)
DOC_TYPE 購買伝票タイプ (String)
DELETE_IND 購買伝票の削除フラグ (String)
STATUS 購買伝票のステータス (String)
CREAT_DATE レコード登録日 (String)
CREATED_BY オブジェクト登録者名 (String)
ITEM_INTVL 明細番号間隔 (String)
VENDOR 仕入先勘定コード (String)
LANGU 言語キー (String)
LANGU_ISO 言語キーの ISO コード (String)
PMNTTRMS 支払条件キー (String)
DSCNT1_TO 現金割引日数 (早期支払) (String)
DSCNT2_TO 現金割引日数 (早期支払) (String)
DSCNT3_TO 現金割引日数 (早期支払) (String)
DSCT_PCT1 割引率 1 (String)
DSCT_PCT2 割引率 2 (String)
PURCH_ORG 購買組織 (String)
PUR_GROUP 購買グループ (String)
CURRENCY 通貨コード (String)
CURRENCY_ISO ISO コード通貨 (String)
EXCH_RATE 換算レート (String)
EX_RATE_FX 区分：換算レート固定 (String)
DOC_DATE 購買伝票日付 (String)
VPER_START 有効期間開始日 (String)
VPER_END 有効期間の終了日 (String)
WARRANTY 保証日 (String)
QUOTATION 見積番号 (String)
QUOT_DATE 見積提出日 (String)
REF_1 得意先/仕入先の内部参照コード (String)
SALES_PERS 仕入先営業担当者 (String)
TELEPHONE 仕入先電話番号 (String)
SUPPL_VEND 供給仕入先 (String)
CUSTOMER 得意先コード 1 (String)
AGREEMENT 購買契約番号 (String)
GR_MESSAGE 区分：入庫メッセージ (String)
SUPPL_PLNT 在庫転送オーダーにおける供給 (出庫) プラント (String)
INCOTERMS1 インコタームズ (1) (String)
INCOTERMS2 インコタームズ 2 (String)
COLLECT_NO 一括番号 (String)
DIFF_INV 仕入先と請求元が異なる場合の請求元のコード (String)
OUR_REF 社内参照番号 (String)
LOGSYSTEM 論理システム (String)
SUBITEMINT 副明細の明細間隔 (String)
PO_REL_IND 承認区分：購買伝票 (String)
REL_STATUS 承認状況 (String)
VAT_CNTRY 売上税 ID 番号国 (String)
VAT_CNTRY_ISO 消費税登録番号の ISO 国コード (String)
REASON_CANCEL 取消理由 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getExportHeader

Object getExportHeader ()

貿易管理ヘッダを取得します｡
返却値
Object 貿易管理ヘッダ

貿易管理ヘッダ情報オブジェクトの構成は以下のとおりです。
貿易管理ヘッダ情報
オブジェクト
(Object)
TRANSPORT_MODE 貿易管理の輸送モード (String)
CUSTOMS 税関：税関 (出国時) (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getExportItemList

Object getExportItemList ()

貿易管理明細一覧を取得します｡
返却値
Object 貿易管理明細一覧

貿易管理明細情報オブジェクトの構成は以下のとおりです。
貿易管理明細情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号 (String)
BUSINESS_TRANSACTION_TYPE 貿易管理の取引タイプ (String)
EXPORT_IMPORT_PROCEDURE 貿易の輸出入手続 (String)
COUNTRYORI 品目の原産国 (String)
COUNTRYORI_ISO ISO 国コード (String)
REGIONORIG 品目の原産地 (非特恵対象地区の原産) (String)
COMM_CODE 貿易：統計品目コード/輸入コード番号 (String)
SHIPPING_COUNTRY 貿易：出荷国 (String)
SHIPPING_COUNTRY_ISO ISO 国コード (String)

取得した貿易管理明細情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の貿易管理明細の「購買伝票の明細番号」
[idx]["BUSINESS_TRANSACTION_TYPE"] →　配列内のidx番目の貿易管理明細の「貿易管理の取引タイプ」
[idx]["EXPORT_IMPORT_PROCEDURE"] 　→　配列内のidx番目の貿易管理明細の「貿易の輸出入手続」
[idx]["COUNTRYORI"]　→　配列内のidx番目の貿易管理明細の「品目の原産国」
[idx]["COUNTRYORI_ISO"]　→　配列内のidx番目の貿易管理明細の「ISO 国コード」
[idx]["REGIONORIG"] 　→　配列内のidx番目の貿易管理明細の「品目の原産地 (非特恵対象地区の原産)」
[idx]["COMM_CODE"]　→　配列内のidx番目の貿易管理明細の「貿易：統計品目コード/輸入コード番号」
[idx]["SHIPPING_COUNTRY"]　→　配列内のidx番目の貿易管理明細の「貿易：出荷国」
[idx]["SHIPPING_COUNTRY_ISO"]　→　配列内のidx番目の貿易管理明細の「ISO 国コード」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getExtensionList

Object getExtensionList ()

拡張得意先項目一覧を取得します｡
返却値
Object 拡張得意先項目一覧

拡張得意先項目情報オブジェクトの構成は以下のとおりです。
拡張得意先項目情報
オブジェクト
(Object)
STRUCTURE BAPI テーブル拡張の構造名 (String)
VALUEPART1 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART2 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART3 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART4 BAPI 拡張パラメータのデータ部分 (String)

取得した拡張得意先項目情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["STRUCTURE"]　→　配列内のidx番目の拡張得意先項目の「BAPI テーブル拡張の構造名」
[idx]["VALUEPART1"] 　→　配列内のidx番目の拡張得意先項目の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART2"] 　→　配列内のidx番目の拡張得意先項目の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART3"] 　→　配列内のidx番目の拡張得意先項目の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART4"] 　→　配列内のidx番目の拡張得意先項目の「BAPI 拡張パラメータのデータ部分」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getHeaderTextList

Object getHeaderTextList ()

ヘッダテキスト一覧を取得します｡
返却値
Object ヘッダテキスト一覧

ヘッダテキスト情報オブジェクトの構成は以下のとおりです。
ヘッダテキスト情報
オブジェクト
(Object)
PO_NUMBER 購買伝票番号 (String)
PO_ITEM 購買伝票の明細番号 (String)
TEXT_ID テキスト ID (String)
TEXT_FORM タグ列 (String)
TEXT_LINE テキスト行 (String)

取得したヘッダテキスト情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_NUMBER"]　→　配列内のidx番目のヘッダテキストの「購買伝票番号」
[idx]["PO_ITEM"]　→　配列内のidx番目のヘッダテキストの「購買伝票の明細番号」
[idx]["TEXT_ID"]　→　配列内のidx番目のヘッダテキストの「テキスト ID」
[idx]["TEXT_FORM"]　→　配列内のidx番目のヘッダテキストの「タグ列」
[idx]["TEXT_LINE"]　→　配列内のidx番目のヘッダテキストの「テキスト行」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getItemTextList

Object getItemTextList ()

明細テキスト一覧を取得します｡
返却値
Object 明細テキスト

明細テキスト情報オブジェクトの構成は以下のとおりです。
明細テキスト情報
オブジェクト
(Object)
PO_NUMBER 購買伝票番号 (String)
PO_ITEM 購買伝票の明細番号 (String)
TEXT_ID テキスト ID (String)
TEXT_FORM タグ列 (String)
TEXT_LINE テキスト行 (String)

取得した明細テキスト情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_NUMBER"]　→　配列内のidx番目の明細テキストの「購買伝票番号」
[idx]["PO_ITEM"]　→　配列内のidx番目の明細テキストの「購買伝票の明細番号」
[idx]["TEXT_ID"]　→　配列内のidx番目の明細テキストの「テキスト ID」
[idx]["TEXT_FORM"]　→　配列内のidx番目の明細テキストの「タグ列」
[idx]["TEXT_LINE"]　→　配列内のidx番目の明細テキストの「テキスト行」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getLimitsList

Object getLimitsList ()

外注制限一覧を取得します｡
返却値
Object 外注制限一覧

外注制限情報オブジェクトの構成は以下のとおりです。
外注制限情報
オブジェクト
(Object)
PCKG_NO パッケージ番号 (String)
LIMIT 全体制限 (String)
NO_LIMIT 制限なし (String)
EXP_VALUE 見込金額 (String)
SSC_EXIST サービスタイプの制限 (String)
CON_EXIST 基本契約明細の制限 (String)
TMP_EXIST サービスパッケージの制限 (String)
PRICE_CHG 入力シートの価格変更 (String)
FREE_LIMIT 自由制限 (String)
NO_FRLIMIT 制限なし (String)
SERV_TYPE サービスタイプのテキスト (短) (String)
EDITION サービスタイプのバージョン (String)
SSC_LIMIT サービスタイプの金額制限 (String)
SSC_NOLIM 標準サービスタイプの制限なし (String)
SSC_PRSCHG 入力シートの価格変更 (String)
SSC_PERC 価格決定率 (String)
TMP_NUMBER モデルサービス明細セット番号 (String)
TMP_LIMIT モデルサービス明細制限 (String)
TMP_NOLIM モデル仕様の制限なし (String)
TMP_PRSCHG 入力シートの価格変更 (String)
TMP_PERC 価格決定率 (String)
CONT_PERC 価格決定率 (String)

取得した外注制限情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PCKG_NO"]　→　配列内のidx番目の外注制限の「パッケージ番号」
[idx]["LIMIT"]　→　配列内のidx番目の外注制限の「全体制限」
[idx]["NO_LIMIT"]　→　配列内のidx番目の外注制限の「制限なし」
[idx]["EXP_VALUE"]　→　配列内のidx番目の外注制限の「見込金額」
[idx]["SSC_EXIST"]　→　配列内のidx番目の外注制限の「サービスタイプの制限」
[idx]["CON_EXIST"]　→　配列内のidx番目の外注制限の「基本契約明細の制限」
[idx]["TMP_EXIST"]　→　配列内のidx番目の外注制限の「サービスパッケージの制限」
[idx]["PRICE_CHG"]　→　配列内のidx番目の外注制限の「入力シートの価格変更」
[idx]["FREE_LIMIT"]　→　配列内のidx番目の外注制限の「自由制限」
[idx]["NO_FRLIMIT"]　→　配列内のidx番目の外注制限の「制限なし」
[idx]["SERV_TYPE"]　→　配列内のidx番目の外注制限の「サービスタイプのテキスト (短)」
[idx]["EDITION"]　→　配列内のidx番目の外注制限の「サービスタイプのバージョン」
[idx]["SSC_LIMIT"]　→　配列内のidx番目の外注制限の「サービスタイプの金額制限」
[idx]["SSC_NOLIM"]　→　配列内のidx番目の外注制限の「標準サービスタイプの制限なし」
[idx]["SSC_PRSCHG"]　→　配列内のidx番目の外注制限の「入力シートの価格変更」
[idx]["SSC_PERC"]　→　配列内のidx番目の外注制限の「価格決定率」
[idx]["TMP_NUMBER"]　→　配列内のidx番目の外注制限の「モデルサービス明細セット番号」
[idx]["TMP_LIMIT"]　→　配列内のidx番目の外注制限の「モデルサービス明細制限」
[idx]["TMP_NOLIM"]　→　配列内のidx番目の外注制限の「モデル仕様の制限なし」
[idx]["TMP_PRSCHG"]　→　配列内のidx番目の外注制限の「入力シートの価格変更」
[idx]["TMP_PERC"]　→　配列内のidx番目の外注制限の「価格決定率」
[idx]["CONT_PERC"]　→　配列内のidx番目の外注制限の「価格決定率」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getMemoryComplete

Object getMemoryComplete ()

エラーがない場合に購買発注を保留にする区分を取得します｡

返却値
Object エラーがない場合に購買発注を保留にする区分
getMemoryUnComplete

Object getMemoryUnComplete ()

エラーがある場合に購買発注を保留にする区分を取得します｡

返却値
Object エラーがある場合に購買発注を保留にする区分
getNoAuthority

Object getNoAuthority ()

権限チェックなし区分を取得します｡

返却値
Object 権限チェックなし区分
getNoMessageReq

Object getNoMessageReq ()

メッセージ不要区分を取得します｡

返却値
Object メッセージ不要区分
getNoMessaging

Object getNoMessaging ()

出力決定なし区分を取得します。

返却値
Object 出力決定なし区分
getNoPriceFromPo

Object getNoPriceFromPo ()

最終伝票からの価格転送なし区分を取得します｡

返却値
Object 最終伝票からの価格転送なし区分
getPartnerList

Object getPartnerList ()

得意先一覧を取得します｡
返却値
Object 得意先一覧

得意先情報オブジェクトの構成は以下のとおりです。
得意先情報
オブジェクト
(Object)
PARTNERDESC 言語別取引先機能テキスト (String)
LANGU 言語キー (String)
BUSPARTNO 取引先の仕入先マスタコード (String)

取得した得意先情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PARTNERDESC"]　→　配列内のidx番目の得意先の「言語別取引先機能テキスト」
[idx]["LANGU"]　→　配列内のidx番目の得意先の「言語キー」
[idx]["BUSPARTNO"]　→　配列内のidx番目の得意先の「取引先の仕入先マスタコード」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPoNumber

Object getPoNumber ()

購買伝票番号を取得します｡

返却値
Object 購買伝票番号
getProfitSegmentList

Object getProfitSegmentList ()

入出庫予定一覧を取得します｡
返却値
Object 入出庫予定一覧

入出庫予定情報オブジェクトの構成は以下のとおりです。
入出庫予定情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号 (String)
SERIAL_NO 勘定設定の連続番号 (String)
FIELDNAME 項目名 (String)
VALUE CO-PA 特性値 (String)

取得した入出庫予定情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の入出庫予定の「購買伝票の明細番号」
[idx]["SERIAL_NO"]　→　配列内のidx番目の入出庫予定の「勘定設定の連続番号」
[idx]["FIELDNAME"]　→　配列内のidx番目の入出庫予定の「項目名」
[idx]["VALUE"]　→　配列内のidx番目の入出庫予定の「CO-PA 特性値」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPurchaseAccountList

Object getPurchaseAccountList ()

勘定設定一覧を取得します｡
返却値
Object 勘定設定一覧

勘定設定情報オブジェクトの構成は以下のとおりです。
勘定設定情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号 (String)
SERIAL_NO 勘定設定の連続番号 (String)
DELETE_IND 削除フラグ：購買伝票勘定設定 (String)
CREAT_DATE レコード登録日 (String)
QUANTITY 数量 (String)
DISTR_PERC 配賦率 % (複数勘定設定) (String)
NET_VALUE BAPI の通貨額 (小数点以下９桁) (String)
GL_ACCOUNT G/L 勘定コード (String)
BUS_AREA 事業領域 (String)
COSTCENTER 原価センタ (String)
SD_DOC 販売管理伝票番号 (String)
ITM_NUMBER 販売伝票明細 (String)
SCHED_LINE 納入日程行 (String)
ASSET_NO 資産番号 (String)
SUB_NUMBER 資産補助番号 (String)
ORDERID 指図番号 (String)
GR_RCPT 受領者 (String)
UNLOAD_PT 荷渡ポイント (String)
CO_AREA 管理領域 (String)
COSTOBJECT 原価対象 (String)
PROFIT_CTR 利益センタ (String)
WBS_ELEMENT WBS 要素 (String)
NETWORK 勘定割当のネットワーク番号 (String)
RL_EST_KEY 不動産管理対象の内部キー (String)
PART_ACCT 取引先勘定コード (String)
CMMT_ITEM 資金予算コード (String)
REC_IND リカバリフラグ (String)
FUNDS_CTR 予算センタ (String)
FUND 会計区分 (String)
FUNC_AREA 機能領域 (String)
REF_DATE 決済の参照日付 (String)
TAX_CODE 消費税コード (String)
TAXJURCODE 税計算管轄コード - 税管轄コード (String)
NOND_ITAX BAPI の通貨額 (小数点以下９桁) (String)
ACTTYPE 活動タイプ (String)
CO_BUSPROC 業務プロセス (String)
RES_DOC 用途指定予算の伝票番号 (String)
RES_ITEM 用途指定予算：伝票明細 (String)
ACTIVITY 作業番号 (String)
GRANT_NBR 補助金 (String)
CMMT_ITEM_LONG 資金予算コード (String)
FUNC_AREA_LONG 機能領域 (String)

取得した勘定設定情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の勘定設定の「購買伝票の明細番号」
[idx]["SERIAL_NO"]　→　配列内のidx番目の勘定設定の「勘定設定の連続番号」
[idx]["DELETE_IND"]　→　配列内のidx番目の勘定設定の「削除フラグ：購買伝票勘定設定」
[idx]["CREAT_DATE"]　→　配列内のidx番目の勘定設定の「レコード登録日」
[idx]["QUANTITY"]　→　配列内のidx番目の勘定設定の「数量」
[idx]["DISTR_PERC"]　→　配列内のidx番目の勘定設定の「配賦率 % (複数勘定設定)」
[idx]["NET_VALUE"]　→　配列内のidx番目の勘定設定の「BAPI の通貨額 (小数点以下９桁)」
[idx]["GL_ACCOUNT"]　→　配列内のidx番目の勘定設定の「G/L 勘定コード」
[idx]["BUS_AREA"]　→　配列内のidx番目の勘定設定の「事業領域」
[idx]["COSTCENTER"]　→　配列内のidx番目の勘定設定の「原価センタ」
[idx]["SD_DOC"]　→　配列内のidx番目の勘定設定の「販売管理伝票番号」
[idx]["ITM_NUMBER"]　→　配列内のidx番目の勘定設定の「販売伝票明細」
[idx]["SCHED_LINE"]　→　配列内のidx番目の勘定設定の「納入日程行」
[idx]["ASSET_NO"]　→　配列内のidx番目の勘定設定の「資産番号」
[idx]["SUB_NUMBER"]　→　配列内のidx番目の勘定設定の「資産補助番号」
[idx]["ORDERID"]　→　配列内のidx番目の勘定設定の「指図番号」
[idx]["GR_RCPT"]　→　配列内のidx番目の勘定設定の「受領者」
[idx]["UNLOAD_PT"]　→　配列内のidx番目の勘定設定の「荷渡ポイント」
[idx]["CO_AREA"]　→　配列内のidx番目の勘定設定の「管理領域」
[idx]["COSTOBJECT"]　→　配列内のidx番目の勘定設定の「原価対象」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の勘定設定の「利益センタ」
[idx]["WBS_ELEMENT"]　→　配列内のidx番目の勘定設定の「WBS 要素」
[idx]["NETWORK"]　→　配列内のidx番目の勘定設定の「勘定割当のネットワーク番号」
[idx]["RL_EST_KEY"]　→　配列内のidx番目の勘定設定の「不動産管理対象の内部キー」
[idx]["PART_ACCT"]　→　配列内のidx番目の勘定設定の「取引先勘定コード」
[idx]["CMMT_ITEM"]　→　配列内のidx番目の勘定設定の「資金予算コード」
[idx]["REC_IND"]　→　配列内のidx番目の勘定設定の「リカバリフラグ」
[idx]["FUNDS_CTR"]　→　配列内のidx番目の勘定設定の「予算センタ」
[idx]["FUND"]　→　配列内のidx番目の勘定設定の「会計区分」
[idx]["FUNC_AREA"]　→　配列内のidx番目の勘定設定の「機能領域」
[idx]["REF_DATE"]　→　配列内のidx番目の勘定設定の「決済の参照日付」
[idx]["TAX_CODE"]　→　配列内のidx番目の勘定設定の「消費税コード」
[idx]["TAXJURCODE"]　→　配列内のidx番目の勘定設定の「税計算管轄コード - 税管轄コード」
[idx]["NOND_ITAX"]　→　配列内のidx番目の勘定設定の「BAPI の通貨額 (小数点以下９桁)」
[idx]["ACTTYPE"]　→　配列内のidx番目の勘定設定の「活動タイプ」
[idx]["CO_BUSPROC"]　→　配列内のidx番目の勘定設定の「業務プロセス」
[idx]["RES_DOC"]　→　配列内のidx番目の勘定設定の「用途指定予算の伝票番号」
[idx]["RES_ITEM"]　→　配列内のidx番目の勘定設定の「用途指定予算：伝票明細」
[idx]["ACTIVITY"]　→　配列内のidx番目の勘定設定の「作業番号」
[idx]["GRANT_NBR"]　→　配列内のidx番目の勘定設定の「補助金」
[idx]["CMMT_ITEM_LONG"]　→　配列内のidx番目の勘定設定の「資金予算コード」
[idx]["FUNC_AREA_LONG"]　→　配列内のidx番目の勘定設定の「機能領域」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPurchaseItemPostList

Object getPurchaseItemPostList ()

明細一覧を取得します｡
返却値
Object 明細一覧

明細情報オブジェクトの構成は以下のとおりです。
明細情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号 (String)
DELETE_IND 購買伝票の削除フラグ (String)
SHORT_TEXT テキスト (短) (String)
MATERIAL 品目コード (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード (長) (今後のリリースで開発) (String)
MATERIAL_GUID 項目 MATERIAL の外部 GUID (今後のリリースで開発) (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (今後のリリースで開発) (String)
EMATERIAL 品目コード (String)
EMATERIAL_EXTERNAL 項目 MATERIAL の品目コード (長) (今後のリリースで開発) (String)
EMATERIAL_GUID 項目 MATERIAL の外部 GUID (今後のリリースで開発) (String)
EMATERIAL_VERSION 項目 MATERIAL のバージョン番号 (今後のリリースで開発) (String)
PLANT プラント (String)
STGE_LOC 保管場所 (String)
TRACKINGNO 購買依頼追跡番号 (String)
MATL_GROUP 品目グループ (String)
INFO_REC 購買情報番号 (String)
VEND_MAT 仕入先が使用している品目コード (String)
QUANTITY 購買発注数量 (String)
PO_UNIT 発注単位 (String)
PO_UNIT_ISO ISO コードによる発注単位 (String)
ORDERPR_UN 購買発注価格単位 (購買管理) (String)
ORDERPR_UN_ISO 購買発注価格単位の ISO コード (String)
CONV_NUM1 購買価格単位から購買発注単位への変換分子 (String)
CONV_DEN1 購買価格単位から購買発注単位への変換分母 (String)
NET_PRICE BAPI の通貨額 (小数点以下９桁) (String)
PRICE_UNIT 価格単位 (String)
GR_PR_TIME 入庫処理日数 (String)
TAX_CODE 消費税コード (String)
BON_GRP1 決済グループ 1（購買） (String)
QUAL_INSP 在庫タイプ (String)
INFO_UPD 区分：購買情報更新 (String)
PRNT_PRICE 価格印刷 (String)
EST_PRICE 区分：概算価格 (String)
REMINDER1 第一回催促状/督促状の日数 (String)
REMINDER2 第二回催促状/督促状の日数 (String)
REMINDER3 第三回催促状/督促状の日数 (String)
OVER_DLV_TOL 過剰納入許容範囲 (String)
UNLIMITED_DLV 区分：無制限過剰納入可能 (String)
UNDER_DLV_TOL 不足納入許容範囲リミット (String)
VAL_TYPE 評価タイプ (String)
NO_MORE_GR 納入完了 区分 (String)
FINAL_INV 請求書処理完了区分 (String)
ITEM_CAT 購買伝票の明細カテゴリ (String)
ACCTASSCAT 勘定設定カテゴリ (String)
DISTRIB 複数勘定設定の配賦区分 (String)
PART_INV 一部請求区分 (String)
GR_IND 入庫区分 (String)
GR_NON_VAL 非評価入庫 (String)
IR_IND 請求書受領区分 (String)
FREE_ITEM 無償明細 (String)
GR_BASEDIV 区分：入庫基準の請求書照合 (String)
ACKN_REQD 購買発注請書依頼 (String)
ACKNOWL_NO 購買発注請書番号 (String)
AGREEMENT 購買契約番号 (String)
AGMT_ITEM 購買契約の明細番号 (String)
SHIPPING 出荷指示 (String)
CUSTOMER 得意先 (String)
COND_GROUP 仕入先条件グループ (String)
NO_DISCT 現金値引対象外明細 (String)
PLAN_DEL 予定納入日数 (String)
NET_WEIGHT 正味重量 (String)
WEIGHTUNIT 重量単位 (String)
WEIGHTUNIT_ISO 重量単位の ISO コード (String)
TAXJURCODE 税計算管轄コード - 税管轄コード (String)
CTRL_KEY 調達における品質管理の管理キー (String)
CONF_CTRL 確認管理キー (String)
REV_LEV 改訂レベル (String)
FUND 会計区分 (String)
FUNDS_CTR 予算センタ (String)
CMMT_ITEM 資金予算コード (String)
PRICEDATE 価格設定日カテゴリ (価格設定日管理) (String)
PRICE_DATE 価格設定日 (String)
GROSS_WT 総重量 (String)
VOLUME 容積 (String)
VOLUMEUNIT 容積単位 (String)
VOLUMEUNIT_ISO ISO コードでの容積単位 (String)
INCOTERMS1 インコタームズ (1) (String)
INCOTERMS2 インコタームズ 2 (String)
PRE_VENDOR 製造元/販売元 (String)
VEND_PART 仕入先部門 (String)
HL_ITEM 購買伝票中の上位明細 (String)
GR_TO_DATE 納入最終期限 (String)
SUPP_VENDOR 供給仕入先/仕入入庫 (String)
SC_VENDOR 外注仕入先 (String)
KANBAN_IND かんばん区分 (String)
ERS ERS（入庫/請求自動決済） (String)
R_PROMO プロモーション (String)
POINTS リベートポイント数 (String)
POINT_UNIT ポイント単位 (String)
POINT_UNIT_ISO ポイント単位の ISO コード (String)
SEASON 季節カテゴリ (String)
SEASON_YR シーズン年度 (String)
BON_GRP2 決済グループ 2 (リベート決済、購買) (String)
BON_GRP3 決済グループ 3 (リベート決済、購買) (String)
SETT_ITEM リベート (期末) 決済対象の明細 (String)
MINREMLIFE 最低有効期間残 (String)
RFQ_NO 見積依頼番号 (String)
RFQ_ITEM 見積依頼明細番号 (String)
PREQ_NO 購買依頼番号 (String)
PREQ_ITEM 購買依頼の明細番号 (String)
REF_DOC 参照伝票番号 (String)
REF_ITEM 参照伝票の明細 (String)
SI_CAT 補助明細カテゴリ、購買伝票 (String)
RET_ITEM 返品明細 (String)
AT_RELEV 割当テーブル関連 (String)
ORDER_REASON 発注理由 (String)
BRAS_NBM Brazilian NCM Code (String)
MATL_USAGE 品目の用途 (String)
MAT_ORIGIN 品目の原産地 (String)
IN_HOUSE 内部生産 (String)
INDUS3 品目 CFOP カテゴリ (String)
INF_INDEX インフレーション指数 (String)
UNTIL_DATE インフレーション指数日付 (String)
DELIV_COMPL 出荷完了 区分 (String)
PART_DELIV 明細レベルでの分割納入 (在庫転送) (String)
SHIP_BLOCKED SD 出荷伝票の明細ブロック (String)
PREQ_NAME 購買依頼者名/要求者名 (String)
PERIOD_IND_EXPIRATION_DATE 有効期間期限日の期間区分 (String)
INT_OBJ_NO 選定 (内部オブジェクト番号) (String)
PCKG_NO パッケージ番号 (String)
BATCH ロット番号 (String)
VENDRBATCH 仕入先ロット番号 (String)
CALCTYPE 価格設定タイプ (String)
GRANT_NBR 補助金 (String)
CMMT_ITEM_LONG 資金予算コード (String)
FUNC_AREA_LONG 機能領域 (String)
NO_ROUNDING 区分：購買発注明細での非表示丸め (String)
PO_PRICE 区分：価格採用：1 = 総額、2 = 正味額 (String)
SUPPL_STLOC 出庫保管場所：在庫転送オーダー (String)

取得した明細情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の明細の「購買伝票の明細番号」
[idx]["DELETE_IND"]　→　配列内のidx番目の明細の「購買伝票の削除フラグ」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の明細の「テキスト (短)」
[idx]["MATERIAL"] 　→　配列内のidx番目の明細の「品目コード」
[idx]["MATERIAL_EXTERNAL"] 　→　配列内のidx番目の明細の「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["MATERIAL_GUID"] 　→　配列内のidx番目の明細の「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["MATERIAL_VERSION"] 　→　配列内のidx番目の明細の「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」
[idx]["EMATERIAL"]　→　配列内のidx番目の明細の「品目コード」
[idx]["EMATERIAL_EXTERNAL"] 　→　配列内のidx番目の明細の「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["EMATERIAL_GUID"] 　→　配列内のidx番目の明細の「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["EMATERIAL_VERSION"] 　→　配列内のidx番目の明細の「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」
[idx]["PLANT"]　→　配列内のidx番目の明細の「プラント」
[idx]["STGE_LOC"]　→　配列内のidx番目の明細の「保管場所」
[idx]["TRACKINGNO"]　→　配列内のidx番目の明細の「購買依頼追跡番号」
[idx]["MATL_GROUP"]　→　配列内のidx番目の明細の「品目グループ」
[idx]["INFO_REC"]　→　配列内のidx番目の明細の「購買情報番号」
[idx]["VEND_MAT"]　→　配列内のidx番目の明細の「仕入先が使用している品目コード」
[idx]["QUANTITY"]　→　配列内のidx番目の明細の「購買発注数量」
[idx]["PO_UNIT"]　→　配列内のidx番目の明細の「発注単位」
[idx]["PO_UNIT_ISO"]　→　配列内のidx番目の明細の「ISO コードによる発注単位」
[idx]["ORDERPR_UN"]　→　配列内のidx番目の明細の「購買発注価格単位 (購買管理)」
[idx]["ORDERPR_UN_ISO"]　→　配列内のidx番目の明細の「購買発注価格単位の ISO コード」
[idx]["CONV_NUM1"]　→　配列内のidx番目の明細の「購買価格単位から購買発注単位への変換分子」
[idx]["CONV_DEN1"]　→　配列内のidx番目の明細の「購買価格単位から購買発注単位への変換分母」
[idx]["NET_PRICE"]　→　配列内のidx番目の明細の「BAPI の通貨額 (小数点以下９桁)」
[idx]["PRICE_UNIT"]　→　配列内のidx番目の明細の「価格単位」
[idx]["GR_PR_TIME"]　→　配列内のidx番目の明細の「入庫処理日数」
[idx]["TAX_CODE"]　→　配列内のidx番目の明細の「消費税コード」
[idx]["BON_GRP1"]　→　配列内のidx番目の明細の「決済グループ 1（購買）」
[idx]["QUAL_INSP"]　→　配列内のidx番目の明細の「在庫タイプ」
[idx]["INFO_UPD"]　→　配列内のidx番目の明細の「区分：購買情報更新」
[idx]["PRNT_PRICE"]　→　配列内のidx番目の明細の「価格印刷」
[idx]["EST_PRICE"]　→　配列内のidx番目の明細の「区分：概算価格」
[idx]["REMINDER1"]　→　配列内のidx番目の明細の「第一回催促状/督促状の日数」
[idx]["REMINDER2"]　→　配列内のidx番目の明細の「第二回催促状/督促状の日数」
[idx]["REMINDER3"]　→　配列内のidx番目の明細の「第三回催促状/督促状の日数」
[idx]["OVER_DLV_TOL"]　→　配列内のidx番目の明細の「過剰納入許容範囲」
[idx]["UNLIMITED_DLV"]　→　配列内のidx番目の明細の「区分：無制限過剰納入可能」
[idx]["UNDER_DLV_TOL"]　→　配列内のidx番目の明細の「不足納入許容範囲リミット」
[idx]["VAL_TYPE"]　→　配列内のidx番目の明細の「評価タイプ」
[idx]["NO_MORE_GR"]　→　配列内のidx番目の明細の「納入完了 区分」
[idx]["FINAL_INV"]　→　配列内のidx番目の明細の「請求書処理完了区分」
[idx]["ITEM_CAT"]　→　配列内のidx番目の明細の「購買伝票の明細カテゴリ」
[idx]["ACCTASSCAT"]　→　配列内のidx番目の明細の「勘定設定カテゴリ」
[idx]["DISTRIB"]　→　配列内のidx番目の明細の「複数勘定設定の配賦区分」
[idx]["PART_INV"]　→　配列内のidx番目の明細の「一部請求区分」
[idx]["GR_IND"]　→　配列内のidx番目の明細の「入庫区分」
[idx]["GR_NON_VAL"]　→　配列内のidx番目の明細の「非評価入庫」
[idx]["IR_IND"]　→　配列内のidx番目の明細の「請求書受領区分」
[idx]["FREE_ITEM"]　→　配列内のidx番目の明細の「無償明細」
[idx]["GR_BASEDIV"]　→　配列内のidx番目の明細の「区分：入庫基準の請求書照合」
[idx]["ACKN_REQD"]　→　配列内のidx番目の明細の「購買発注請書依頼」
[idx]["ACKNOWL_NO"]　→　配列内のidx番目の明細の「購買発注請書番号」
[idx]["AGREEMENT"]　→　配列内のidx番目の明細の「購買契約番号」
[idx]["AGMT_ITEM"]　→　配列内のidx番目の明細の「購買契約の明細番号」
[idx]["SHIPPING"]　→　配列内のidx番目の明細の「出荷指示」
[idx]["CUSTOMER"]　→　配列内のidx番目の明細の「得意先」
[idx]["COND_GROUP"]　→　配列内のidx番目の明細の「仕入先条件グループ」
[idx]["NO_DISCT"]　→　配列内のidx番目の明細の「現金値引対象外明細」
[idx]["PLAN_DEL"]　→　配列内のidx番目の明細の「予定納入日数」
[idx]["NET_WEIGHT"]　→　配列内のidx番目の明細の「正味重量」
[idx]["WEIGHTUNIT"]　→　配列内のidx番目の明細の「重量単位」
[idx]["WEIGHTUNIT_ISO"]　→　配列内のidx番目の明細の「重量単位の ISO コード」
[idx]["TAXJURCODE"]　→　配列内のidx番目の明細の「税計算管轄コード - 税管轄コード」
[idx]["CTRL_KEY"]　→　配列内のidx番目の明細の「調達における品質管理の管理キー」
[idx]["CONF_CTRL"]　→　配列内のidx番目の明細の「確認管理キー」
[idx]["REV_LEV"]　→　配列内のidx番目の明細の「改訂レベル」
[idx]["FUND"]　→　配列内のidx番目の明細の「会計区分」
[idx]["FUNDS_CTR"]　→　配列内のidx番目の明細の「予算センタ」
[idx]["CMMT_ITEM"]　→　配列内のidx番目の明細の「資金予算コード」
[idx]["PRICEDATE"]　→　配列内のidx番目の明細の「価格設定日カテゴリ (価格設定日管理)」
[idx]["PRICE_DATE"]　→　配列内のidx番目の明細の「価格設定日」
[idx]["GROSS_WT"]　→　配列内のidx番目の明細の「総重量」
[idx]["VOLUME"]　→　配列内のidx番目の明細の「容積」
[idx]["VOLUMEUNIT"]　→　配列内のidx番目の明細の「容積単位」
[idx]["VOLUMEUNIT_ISO"]　→　配列内のidx番目の明細の「ISO コードでの容積単位」
[idx]["INCOTERMS1"]　→　配列内のidx番目の明細の「インコタームズ (1)」
[idx]["INCOTERMS2"]　→　配列内のidx番目の明細の「インコタームズ 2」
[idx]["PRE_VENDOR"]　→　配列内のidx番目の明細の「製造元/販売元」
[idx]["VEND_PART"]　→　配列内のidx番目の明細の「仕入先部門」
[idx]["HL_ITEM"]　→　配列内のidx番目の明細の「購買伝票中の上位明細」
[idx]["GR_TO_DATE"]　→　配列内のidx番目の明細の「納入最終期限」
[idx]["SUPP_VENDOR"]　→　配列内のidx番目の明細の「供給仕入先/仕入入庫」
[idx]["SC_VENDOR"]　→　配列内のidx番目の明細の「外注仕入先」
[idx]["KANBAN_IND"]　→　配列内のidx番目の明細の「かんばん区分」
[idx]["ERS"]　→　配列内のidx番目の明細の「ERS（入庫/請求自動決済）」
[idx]["R_PROMO"]　→　配列内のidx番目の明細の「プロモーション」
[idx]["POINTS"]　→　配列内のidx番目の明細の「リベートポイント数」
[idx]["POINT_UNIT"]　→　配列内のidx番目の明細の「ポイント単位」
[idx]["POINT_UNIT_ISO"]　→　配列内のidx番目の明細の「ポイント単位の ISO コード」
[idx]["SEASON"]　→　配列内のidx番目の明細の「季節カテゴリ」
[idx]["SEASON_YR"]　→　配列内のidx番目の明細の「シーズン年度」
[idx]["BON_GRP2"]　→　配列内のidx番目の明細の「決済グループ 2 (リベート決済、購買)」
[idx]["BON_GRP3"]　→　配列内のidx番目の明細の「決済グループ 3 (リベート決済、購買)」
[idx]["SETT_ITEM"]　→　配列内のidx番目の明細の「リベート (期末) 決済対象の明細」
[idx]["MINREMLIFE"]　→　配列内のidx番目の明細の「最低有効期間残」
[idx]["RFQ_NO"]　→　配列内のidx番目の明細の「見積依頼番号」
[idx]["RFQ_ITEM"]　→　配列内のidx番目の明細の「見積依頼明細番号」
[idx]["PREQ_NO"]　→　配列内のidx番目の明細の「購買依頼番号」
[idx]["PREQ_ITEM"]　→　配列内のidx番目の明細の「購買依頼の明細番号」
[idx]["REF_DOC"]　→　配列内のidx番目の明細の「参照伝票番号」
[idx]["REF_ITEM"]　→　配列内のidx番目の明細の「参照伝票の明細」
[idx]["SI_CAT"]　→　配列内のidx番目の明細の「補助明細カテゴリ、購買伝票」
[idx]["RET_ITEM"]　→　配列内のidx番目の明細の「返品明細」
[idx]["AT_RELEV"]　→　配列内のidx番目の明細の「割当テーブル関連」
[idx]["ORDER_REASON"]　→　配列内のidx番目の明細の「発注理由」
[idx]["BRAS_NBM"]　→　配列内のidx番目の明細の「Brazilian NCM Code」
[idx]["MATL_USAGE"]　→　配列内のidx番目の明細の「品目の用途」
[idx]["MAT_ORIGIN"]　→　配列内のidx番目の明細の「品目の原産地」
[idx]["IN_HOUSE"]　→　配列内のidx番目の明細の「内部生産」
[idx]["INDUS3"]　→　配列内のidx番目の明細の「品目 CFOP カテゴリ」
[idx]["INF_INDEX"]　→　配列内のidx番目の明細の「インフレーション指数」
[idx]["UNTIL_DATE"]　→　配列内のidx番目の明細の「インフレーション指数日付」
[idx]["DELIV_COMPL"]　→　配列内のidx番目の明細の「出荷完了 区分」
[idx]["PART_DELIV"]　→　配列内のidx番目の明細の「明細レベルでの分割納入 (在庫転送)」
[idx]["SHIP_BLOCKED"]　→　配列内のidx番目の明細の「SD 出荷伝票の明細ブロック」
[idx]["PREQ_NAME"]　→　配列内のidx番目の明細の「購買依頼者名/要求者名」
[idx]["PERIOD_IND_EXPIRATION_DATE"] 　→　配列内のidx番目の明細の「有効期間期限日の期間区分」
[idx]["INT_OBJ_NO"]　→　配列内のidx番目の明細の「選定 (内部オブジェクト番号)」
[idx]["PCKG_NO"]　→　配列内のidx番目の明細の「パッケージ番号」
[idx]["BATCH"]　→　配列内のidx番目の明細の「ロット番号」
[idx]["VENDRBATCH"]　→　配列内のidx番目の明細の「仕入先ロット番号」
[idx]["CALCTYPE"]　→　配列内のidx番目の明細の「価格設定タイプ」
[idx]["GRANT_NBR"]　→　配列内のidx番目の明細の「補助金」
[idx]["CMMT_ITEM_LONG"]　→　配列内のidx番目の明細の「資金予算コード」
[idx]["FUNC_AREA_LONG"]　→　配列内のidx番目の明細の「機能領域」
[idx]["NO_ROUNDING"]　→　配列内のidx番目の明細の「区分：購買発注明細での非表示丸め」
[idx]["PO_PRICE"]　→　配列内のidx番目の明細の「区分：価格採用：1 = 総額、2 = 正味額」
[idx]["SUPPL_STLOC"]　→　配列内のidx番目の明細の「出庫保管場所：在庫転送オーダー」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPurchaseScheduleList

Object getPurchaseScheduleList ()

納入日程一覧を取得します｡
返却値
Object 納入日程一覧

納入日程情報オブジェクトの構成は以下のとおりです。
納入日程情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号 (String)
SCHED_LINE 納入日程行 (String)
DEL_DATCAT_EXT 納入期日カテゴリ (String)
DELIVERY_DATE 納入期日 (String)
QUANTITY 計画数量 (String)
DELIV_TIME 納入期日における指定時間 (String)
STAT_DATE 統計的納入期日 (String)
PREQ_NO 購買依頼番号 (String)
PREQ_ITEM 購買依頼の明細番号 (String)
PO_DATE 納入日程の購買発注日付 (String)
ROUTESCHED 輸送経路計画 (String)
MS_DATE 品目利用可能日 (String)
MS_TIME 品目供給ステージ (現地時刻：プラント参照) (String)
LOAD_DATE 積載日付 (String)
LOAD_TIME 積載時刻 (現地時間：出荷ポイント) (String)
TP_DATE 輸送計画日付 (String)
TP_TIME 輸送計画 - 時間 (現地時間/出荷ポイント参照) (String)
GI_DATE 出庫日付 (String)
GI_TIME 出庫時刻 (現地時間 - プラント参照) (String)
DELETE_IND 購買伝票の削除フラグ (String)

取得した納入日程情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の納入日程の「購買伝票の明細番号」
[idx]["SCHED_LINE"]　→　配列内のidx番目の納入日程の「納入日程行」
[idx]["DEL_DATCAT_EXT"]　→　配列内のidx番目の納入日程の「納入期日カテゴリ」
[idx]["DELIVERY_DATE"]　→　配列内のidx番目の納入日程の「納入期日」
[idx]["QUANTITY"]　→　配列内のidx番目の納入日程の「計画数量」
[idx]["DELIV_TIME"]　→　配列内のidx番目の納入日程の「納入期日における指定時間」
[idx]["STAT_DATE"]　→　配列内のidx番目の納入日程の「統計的納入期日」
[idx]["PREQ_NO"]　→　配列内のidx番目の納入日程の「購買依頼番号」
[idx]["PREQ_ITEM"]　→　配列内のidx番目の納入日程の「購買依頼の明細番号」
[idx]["PO_DATE"]　→　配列内のidx番目の納入日程の「納入日程の購買発注日付」
[idx]["ROUTESCHED"]　→　配列内のidx番目の納入日程の「輸送経路計画」
[idx]["MS_DATE"]　→　配列内のidx番目の納入日程の「品目利用可能日」
[idx]["MS_TIME"]　→　配列内のidx番目の納入日程の「品目供給ステージ (現地時刻：プラント参照)」
[idx]["LOAD_DATE"]　→　配列内のidx番目の納入日程の「積載日付」
[idx]["LOAD_TIME"]　→　配列内のidx番目の納入日程の「積載時刻 (現地時間：出荷ポイント)」
[idx]["TP_DATE"]　→　配列内のidx番目の納入日程の「輸送計画日付」
[idx]["TP_TIME"] 　→　配列内のidx番目の納入日程の「輸送計画 - 時間 (現地時間/出荷ポイント参照)」
[idx]["GI_DATE"]　→　配列内のidx番目の納入日程の「出庫日付」
[idx]["GI_TIME"]　→　配列内のidx番目の納入日程の「出庫時刻 (現地時間 - プラント参照)」
[idx]["DELETE_IND"]　→　配列内のidx番目の納入日程の「購買伝票の削除フラグ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getSupplierInfo

Object getSupplierInfo ()

仕入先住所を取得します｡
返却値
Object 仕入先住所

仕入先住所情報オブジェクトの構成は以下のとおりです。
仕入先住所情報
オブジェクト
(Object)
PO_NUMBER 購買伝票番号 (String)
ADDR_NO アドレス番号 (String)
FORMOFADDR 敬称テキスト (String)
NAME 名称 1 (String)
NAME_2 名称 2 (String)
NAME_3 名称 3 (String)
NAME_4 名称 4 (String)
C_O_NAME 気付 (String)
CITY 市区町村 (String)
DISTRICT 所在地 (String)
CITY_NO 市区町村/地名ファイルの市区町村コード (String)
POSTL_COD1 市区町村の郵便番号 (String)
POSTL_COD2 私書箱郵便番号 (String)
POSTL_COD3 会社郵便番号 (大規模なユーザ用) (String)
PO_BOX 私書箱 (String)
PO_BOX_CIT 私書箱住所 (String)
DELIV_DIS 郵便配達地域 (String)
STREET 地名 (String)
STREET_NO 市区町村/地名ファイルの地名コード (String)
STR_ABBR 地名の略称 (例：スペイン) (String)
HOUSE_NO 番地-号 (String)
STR_SUPPL1 地名 2 (String)
STR_SUPPL2 地名 3 (String)
LOCATION 地名 5 (String)
BUILDING 旧：建物 (番号または略称) (String)
FLOOR 建物の階 (String)
ROOM_NO 部屋/アパート番号 (String)
COUNTRY 国コード (String)
LANGU 言語キー (String)
REGION 地域 (都道府県) (String)
SORT1 検索条件 1 (String)
SORT2 検索条件 2 (String)
TIME_ZONE アドレスタイムゾーン (String)
TAXJURCODE 税管轄コード (String)
ADR_NOTES 住所注記 (String)
COMM_TYPE 通信方法 (キー) (アドレス管理) (String)
TEL1_NUMBR 第一電話番号：ダイヤルコード + 番号 (String)
TEL1_EXT 第 1 電話番号：内線 (String)
FAX_NUMBER 第一 FAX 番号：ダイヤルコード + 番号 (String)
FAX_EXTENS 第一 FAX 番号：内線 (String)
STREET_LNG 地名 (String)
DISTRCT_NO 市区町村/地名ファイルの所在地コード (String)
CHCKSTATUS 市区町村ファイルテストステータス (String)
PBOXCIT_NO 市区町村私書箱コード (市ファイル) (String)
TRANSPZONE 商品の納入区域 (String)
HOUSE_NO2 番地補足 (String)
E_MAIL 電子メールアドレス (String)
STR_SUPPL3 地名 4 (String)
TITLE タイトル (敬称) (String)
COUNTRYISO ISO 国コード (String)
LANGU_ISO ISO 639 準拠の言語 (String)
BUILD_LONG 建物 (番号またはコード) (String)
REGIOGROUP 地域構造グループ化 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getTestRun

Object getTestRun ()

テスト区分を取得します。

返却値
Object テスト区分
getVersions

Object getVersions ()

バージョン管理を取得します｡
返却値
Object バージョン管理

バージョン管理情報オブジェクトの構成は以下のとおりです。
バージョン管理情報
オブジェクト
(Object)
POST_DATE バージョンの転記日付 (String)
COMPLETED ステータス ""バージョン完了済"" (String)
REASON 変更理由 (String)
DESCRIPTION バージョンテキスト（長） (String)
REQ_BY 変更を依頼した従業員 (String)
REQ_BY_EXT バージョンの外部変更番号 (String)
ACTIVITY 処理タイプ - R/3 Enterprise で使用不可能 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

setMemoryComplete

void setMemoryComplete (String value)

エラーがない場合に購買発注を保留する区分を設定します｡
パラメータ
value String エラーがない場合に購買発注を保留する区分
返却値
void
setMemoryUnComplete

void setMemoryUnComplete (String value)

エラーがある場合に購買発注を保留する区分を設定します｡
パラメータ
value String エラーがある場合に購買発注を保留する区分
返却値
void
setNoAuthority

void setNoAuthority (String value)

権限チェックなし区分を設定します｡
パラメータ
value String 権限チェックなし区分
返却値
void
setNoMessage

void setNoMessage (String value)

出力決定なし区分に購買発注を保留する区分を設定します｡
パラメータ
value String 出力決定なし区分に購買発注を保留する区分
返却値
void
setNoMessageReq

void setNoMessageReq (String value)

メッセージ不要区分を設定します｡
パラメータ
value String メッセージ不要区分
返却値
void
setNoPriceFromPo

void setNoPriceFromPo (String value)

最終伝票からの価格転送なし区分を設定します｡
パラメータ
value String 最終伝票からの価格転送なし区分
返却値
void
setStrParam

void setStrParam (String paramStr ,String paramName ,String value)

構造型の項目に値をセットします。
パラメータ
paramStr | String | 構造名
paramName | String | 項目名
value | String | セットする値
返却値
void
setTblParam

void setTblParam (String paramTable ,String paramName ,String value ,int index)

テーブル型の項目に値をセットします。
パラメータ
paramTable | String | テーブル名
paramName | String | 項目名
value | String | セットする値
index | int | レコード番号
返却値
void
setTestRun

void setTestRun (String value)

テスト区分を設定します｡
パラメータ
value String テスト区分
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 PurchaseOrderPostChangeController オブジェクト

伝票登録変更コントローラクラス。

機能は以下の通り
  • 伝票を更新します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
AccEmployeePayPostController (ConnectionManager connectionManager)
コンストラクタ。
AccEmployeePayPostController (SapClient sapClient)
コンストラクタ。
PurchaseOrderPostChangeController ()
コンストラクタ｡
メソッドの概要
Object | executeBapi () BapiControllerにより購買伝票を登録します。
Object | getAllVersionsList () 全バージョン一覧を取得します｡
String | getBapiReturnErrMessage () ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage () プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。
Object | getCondHeaderList () 条件ヘッダ一覧を取得します｡
Object | getCondItemList () 条件明細一覧を取得します｡
Object | getContractLimitsList () 外注基本契約制限一覧を取得します｡
Object | getContractServiceAccountList () 外注サービス勘定設定一覧を取得します｡
Object | getContractServiceList () 外注サービス一覧を取得します｡
Object | getContractServiceTextList () 外注サービステキスト一覧を取得します｡
Object | getDeliverryAddressList () 出荷伝票アドレス一覧を取得します｡
Object | getDocumentHeader () 伝票ヘッダを取得します。
Object | getExportHeader () 貿易管理ヘッダを取得します｡
Object | getExportItemList () 貿易管理明細一覧を取得します｡
Object | getExtensionList () 拡張得意先項目一覧を取得します｡
Object | getHeaderTextList () ヘッダテキスト一覧を取得します｡
Object | getItemTextList () 明細テキスト一覧を取得します｡
Object | getLimitsList () 外注制限一覧を取得します｡
Object | getMemoryComplete () エラーがない場合に購買発注を保留にする区分を取得します｡
Object | getMemoryUnComplete () エラーがある場合に購買発注を保留にする区分を取得します｡
Object | getNoAuthority () 権限チェックなし区分を取得します｡
Object | getNoMessageReq () メッセージ不要区分を取得します｡
Object | getNoMessaging () 出力決定なし区分を取得します。
Object | getNoPriceFromPo () 最終伝票からの価格転送なし区分を取得します｡。
Object | getPartnerList () 得意先一覧を取得します｡
Object | getPoNumber () 購買伝票番号を取得します｡
Object | getProfitSegmentList () 入出庫予定一覧を取得します｡
Object | getPurchaseAccountList () 勘定設定一覧を取得します｡
Object | getPurchaseItemPostList () 明細一覧を取得します｡
Object | getPurchaseScheduleList () 納入日程一覧を取得します｡
Object | getSupplierInfo () 仕入先住所を取得します｡
Object | getTestRun () テスト区分を取得します。
Object | getVersions () バージョン管理を取得します｡
void | setMemoryComplete (String value) エラーがない場合に購買発注を保留する区分を設定します｡を設定します｡
void | setMemoryUnComplete (String value) エラーがある場合に購買発注を保留する区分を設定します｡を設定します｡
void | setNoAuthority (String value) 権限チェックなし区分を設定します｡を設定します｡
void | setNoMessage (String value) 出力決定なし区分に購買発注を保留する区分を設定します｡を設定します｡
void | setNoMessageReq (String value) メッセージ不要区分を設定します｡を設定します｡
void | setNoPriceFromPo (String value) 最終伝票からの価格転送なし区分を設定します｡を設定します｡
void | setPoNumber (String value) 購買伝票番号を設定します｡
void | setStrParam (String paramStr ,String paramName ,String value) 構造型の項目に値をセットします。
void | setTblParam (String paramTable ,String paramName ,String value ,int index) テーブル型の項目に値をセットします。
void | setTestRun (String value) テスト区分を設定します｡
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
AccEmployeePayPostController

AccEmployeePayPostController (ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の更新処理を実行することができます。
なお、PurchaseOrderPostChangeController#executeBapi()実行後に 必ずConnectionManager#commit()またはConnectionManager#rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。
パラメータ
connectionManager ConnectionManager コネクションマネージャー
AccEmployeePayPostController

AccEmployeePayPostController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
PurchaseOrderPostChangeController

PurchaseOrderPostChangeController ()
コンストラクタ｡
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより購買伝票を登録します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getAllVersionsList

Object getAllVersionsList ()

全バージョン一覧を取得します｡
返却値
Object 全バージョン一覧

全バージョン情報オブジェクトの構成は以下のとおりです。
全バージョン情報
オブジェクト
(Object)
DOC_TYPE 購買伝票カテゴリ (String)
DOC_NUMBER 購買管理におけるオブジェクト番号 (String)
ITEM_NUMBER 購買管理オブジェクト：明細 (String)
VERSION 購買管理におけるバージョン番号 (String)
CREATED_BY オブジェクト登録者名 (String)
CR_ON レコード登録日 (String)
REC_TIME 登録時刻 (String)
RELEASED_BY 承認者名 (String)
RELEASE_DATE 承認日 (String)
RELEASE_TIME 承認時刻 (String)
RELEASEBY_PUR 承認購買担当者名 (String)
RELEASEDATE_PUR 購買担当者承認日付 (String)
RELEASETIME_PUR 購買担当者承認時刻 (String)
REASON 変更理由 (String)
DESCRIPTION バージョンテキスト（長） (String)
REQ_BY_EXT バージョンの外部変更番号 (String)
REQ_BY 変更を依頼した従業員 (String)
NET_VALUE 購買発注通貨による正味発注額 (String)
VALUE_CHANGED バージョンによる金額変更 (String)
CURRENCY 通貨コード (String)
CURRENCY_ISO ISO コード通貨 (String)
POST_DATE バージョンの転記日付 (String)
COMPLETED ステータス ""バージョン完了済"" (String)
STATUS バージョンステータス (String)
DELETE_IND 購買伝票の削除フラグ (String)
STATUS_DOC_OLD このバージョンの前の旧処理状況 (購買伝票内) (String)

取得した全バージョン情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["DOC_TYPE"]　→　配列内のidx番目の全バージョンの「購買伝票カテゴリ」
[idx]["DOC_NUMBER"]　→　配列内のidx番目の全バージョンの「購買管理におけるオブジェクト番号」
[idx]["ITEM_NUMBER"]　→　配列内のidx番目の全バージョンの「購買管理オブジェクト：明細」
[idx]["VERSION"]　→　配列内のidx番目の全バージョンの「購買管理におけるバージョン番号」
[idx]["CREATED_BY"]　→　配列内のidx番目の全バージョンの「オブジェクト登録者名」
[idx]["CR_ON"]　→　配列内のidx番目の全バージョンの「レコード登録日」
[idx]["REC_TIME"]　→　配列内のidx番目の全バージョンの「登録時刻」
[idx]["RELEASED_BY"]　→　配列内のidx番目の全バージョンの「承認者名」
[idx]["RELEASE_DATE"]　→　配列内のidx番目の全バージョンの「承認日」
[idx]["RELEASE_TIME"]　→　配列内のidx番目の全バージョンの「承認時刻」
[idx]["RELEASEBY_PUR"]　→　配列内のidx番目の全バージョンの「承認購買担当者名」
[idx]["RELEASEDATE_PUR"]　→　配列内のidx番目の全バージョンの「購買担当者承認日付」
[idx]["RELEASETIME_PUR"]　→　配列内のidx番目の全バージョンの「購買担当者承認時刻」
[idx]["REASON"]　→　配列内のidx番目の全バージョンの「変更理由」
[idx]["DESCRIPTION"]　→　配列内のidx番目の全バージョンの「バージョンテキスト（長）」
[idx]["REQ_BY_EXT"]　→　配列内のidx番目の全バージョンの「バージョンの外部変更番号」
[idx]["REQ_BY"]　→　配列内のidx番目の全バージョンの「変更を依頼した従業員」
[idx]["NET_VALUE"]　→　配列内のidx番目の全バージョンの「購買発注通貨による正味発注額」
[idx]["VALUE_CHANGED"]　→　配列内のidx番目の全バージョンの「バージョンによる金額変更」
[idx]["CURRENCY"]　→　配列内のidx番目の全バージョンの「通貨コード」
[idx]["CURRENCY_ISO"]　→　配列内のidx番目の全バージョンの「ISO コード通貨」
[idx]["POST_DATE"]　→　配列内のidx番目の全バージョンの「バージョンの転記日付」
[idx]["COMPLETED"]　→　配列内のidx番目の全バージョンの「ステータス "バージョン完了済"」
[idx]["STATUS"]　→　配列内のidx番目の全バージョンの「バージョンステータス」
[idx]["DELETE_IND"]　→　配列内のidx番目の全バージョンの「購買伝票の削除フラグ」
[idx]["STATUS_DOC_OLD"] 　→　配列内のidx番目の全バージョンの「このバージョンの前の旧処理状況 (購買伝票内)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getBapiReturnErrMessage

String getBapiReturnErrMessage ()

ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡
返却値
String BAPI実行結果エラーとなった全てのメッセージ情報
getBapiReturnMessage

String getBapiReturnMessage ()

プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡
返却値
String プロパティファイルでオートコミット条件に一致したType情報のメッセージ情報
getCondHeaderList

Object getCondHeaderList ()

条件ヘッダ一覧を取得します｡
返却値
Object 条件ヘッダ一覧

条件ヘッダ情報オブジェクトの構成は以下のとおりです。
条件ヘッダ情報
オブジェクト
(Object)
CONDITION_NO 伝票条件番号 (String)
ITM_NUMBER 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件カウンタ (String)
COND_TYPE 条件タイプ (String)
COND_VALUE 条件レート (String)
CURRENCY 通貨コード (String)
CURRENCY_ISO ISO コード通貨 (String)
COND_UNIT 条件単位 (String)
COND_UNIT_ISO 条件数量単位 (ISO コード) (String)
COND_P_UNT 価格条件単位 (String)
APPLICATIO アプリケーション (String)
CONPRICDAT 条件価格設定日付 (String)
CALCTYPCON 条件計算タイプ (String)
CONBASEVAL 条件基礎値 (String)
CONEXCHRAT 現地通貨への換算レートに対する条件 (String)
NUMCONVERT 条件単位を基本単位へ変換する分子 (String)
DENOMINATO 条件単位を基本単位へ変換する分母 (String)
CONDTYPE 条件カテゴリ (例：税、運賃、価格、原価) (String)
STAT_CON 統計に適用する条件 (String)
SCALETYPE スケールタイプ (String)
ACCRUALS 見越額関連条件 (運賃など) (String)
CONINVOLST 請求書一覧条件 (String)
CONDORIGIN 条件生成区分 (String)
GROUPCOND グループ条件区分 (String)
COND_UPDAT 条件更新 (String)
ACCESS_SEQ 検索順序 - 検索番号 (String)
CONDCOUNT 条件連続番号 (String)
CONDCNTRL 条件管理 (String)
CONDISACTI 無効条件 (String)
CONDCLASS 条件クラス (String)
FACTBASVAL 条件基礎値に対する要因 (String)
SCALEBASIN スケール基準区分 (String)
SCALBASVAL 条件のスケール基準値 (String)
UNITMEASUR 条件スケール単位 (String)
UNITMEASUR_ISO 単位の ISO コード (String)
CURRENCKEY スケール通貨 (String)
CURRENCKEY_ISO ISO コード通貨 (String)
CONDINCOMP 会社間請求の条件 (String)
CONDCONFIG システム設定の条件 (String)
CONDCHAMAN 条件 (マニュアル変更済) (String)
COND_NO 条件レコード番号 (String)
CHANGE_ID 変更タイプ(U、I、E、D) (String)

取得した条件ヘッダ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONDITION_NO"]　→　配列内のidx番目の条件ヘッダの「伝票条件番号」
[idx]["ITM_NUMBER"]　→　配列内のidx番目の条件ヘッダの「条件明細番号」
[idx]["COND_ST_NO"]　→　配列内のidx番目の条件ヘッダの「ステップ番号」
[idx]["COND_COUNT"]　→　配列内のidx番目の条件ヘッダの「条件カウンタ」
[idx]["COND_TYPE"]　→　配列内のidx番目の条件ヘッダの「条件タイプ」
[idx]["COND_VALUE"]　→　配列内のidx番目の条件ヘッダの「条件レート」
[idx]["CURRENCY"]　→　配列内のidx番目の条件ヘッダの「通貨コード」
[idx]["CURRENCY_ISO"]　→　配列内のidx番目の条件ヘッダの「ISO コード通貨」
[idx]["COND_UNIT"]　→　配列内のidx番目の条件ヘッダの「条件単位」
[idx]["COND_UNIT_ISO"] 　→　配列内のidx番目の条件ヘッダの「条件数量単位 (ISO コード)」
[idx]["COND_P_UNT"]　→　配列内のidx番目の条件ヘッダの「価格条件単位」
[idx]["APPLICATIO"]　→　配列内のidx番目の条件ヘッダの「アプリケーション」
[idx]["CONPRICDAT"]　→　配列内のidx番目の条件ヘッダの「条件価格設定日付」
[idx]["CALCTYPCON"]　→　配列内のidx番目の条件ヘッダの「条件計算タイプ」
[idx]["CONBASEVAL"]　→　配列内のidx番目の条件ヘッダの「条件基礎値」
[idx]["CONEXCHRAT"]　→　配列内のidx番目の条件ヘッダの「現地通貨への換算レートに対する条件」
[idx]["NUMCONVERT"]　→　配列内のidx番目の条件ヘッダの「条件単位を基本単位へ変換する分子」
[idx]["DENOMINATO"]　→　配列内のidx番目の条件ヘッダの「条件単位を基本単位へ変換する分母」
[idx]["CONDTYPE"] 　→　配列内のidx番目の条件ヘッダの「条件カテゴリ (例：税、運賃、価格、原価)」
[idx]["STAT_CON"]　→　配列内のidx番目の条件ヘッダの「統計に適用する条件」
[idx]["SCALETYPE"]　→　配列内のidx番目の条件ヘッダの「スケールタイプ」
[idx]["ACCRUALS"]　→　配列内のidx番目の条件ヘッダの「見越額関連条件 (運賃など)」
[idx]["CONINVOLST"]　→　配列内のidx番目の条件ヘッダの「請求書一覧条件」
[idx]["CONDORIGIN"]　→　配列内のidx番目の条件ヘッダの「条件生成区分」
[idx]["GROUPCOND"]　→　配列内のidx番目の条件ヘッダの「グループ条件区分」
[idx]["COND_UPDAT"]　→　配列内のidx番目の条件ヘッダの「条件更新」
[idx]["ACCESS_SEQ"]　→　配列内のidx番目の条件ヘッダの「検索順序 - 検索番号」
[idx]["CONDCOUNT"]　→　配列内のidx番目の条件ヘッダの「条件連続番号」
[idx]["CONDCNTRL"]　→　配列内のidx番目の条件ヘッダの「条件管理」
[idx]["CONDISACTI"]　→　配列内のidx番目の条件ヘッダの「無効条件」
[idx]["CONDCLASS"]　→　配列内のidx番目の条件ヘッダの「条件クラス」
[idx]["FACTBASVAL"]　→　配列内のidx番目の条件ヘッダの「条件基礎値に対する要因」
[idx]["SCALEBASIN"]　→　配列内のidx番目の条件ヘッダの「スケール基準区分」
[idx]["SCALBASVAL"]　→　配列内のidx番目の条件ヘッダの「条件のスケール基準値」
[idx]["UNITMEASUR"]　→　配列内のidx番目の条件ヘッダの「条件スケール単位」
[idx]["UNITMEASUR_ISO"]　→　配列内のidx番目の条件ヘッダの「単位の ISO コード」
[idx]["CURRENCKEY"]　→　配列内のidx番目の条件ヘッダの「スケール通貨」
[idx]["CURRENCKEY_ISO"]　→　配列内のidx番目の条件ヘッダの「ISO コード通貨」
[idx]["CONDINCOMP"]　→　配列内のidx番目の条件ヘッダの「会社間請求の条件」
[idx]["CONDCONFIG"]　→　配列内のidx番目の条件ヘッダの「システム設定の条件」
[idx]["CONDCHAMAN"]　→　配列内のidx番目の条件ヘッダの「条件 (マニュアル変更済)」
[idx]["COND_NO"]　→　配列内のidx番目の条件ヘッダの「条件レコード番号」
[idx]["CHANGE_ID"]　→　配列内のidx番目の条件ヘッダの「変更タイプ(U、I、E、D)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getCondItemList

Object getCondItemList ()

条件明細一覧を取得します｡
返却値
Object 条件明細一覧

条件明細情報オブジェクトの構成は以下のとおりです。
条件明細情報
オブジェクト
(Object)
CONDITION_NO 伝票条件番号 (String)
ITM_NUMBER 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件カウンタ (String)
COND_TYPE 条件タイプ (String)
COND_VALUE 条件レート (String)
CURRENCY 通貨コード (String)
CURRENCY_ISO ISO コード通貨 (String)
COND_UNIT 条件単位 (String)
COND_UNIT_ISO 条件数量単位 (ISO コード) (String)
COND_P_UNT 価格条件単位 (String)
APPLICATIO アプリケーション (String)
CONPRICDAT 条件価格設定日付 (String)
CALCTYPCON 条件計算タイプ (String)
CONBASEVAL 条件基礎値 (String)
CONEXCHRAT 現地通貨への換算レートに対する条件 (String)
NUMCONVERT 条件単位を基本単位へ変換する分子 (String)
DENOMINATO 条件単位を基本単位へ変換する分母 (String)
CONDTYPE 条件カテゴリ (例：税、運賃、価格、原価) (String)
STAT_CON 統計に適用する条件 (String)
SCALETYPE スケールタイプ (String)
ACCRUALS 見越額関連条件 (運賃など) (String)
CONINVOLST 請求書一覧条件 (String)
CONDORIGIN 条件生成区分 (String)
GROUPCOND グループ条件区分 (String)
COND_UPDAT 条件更新 (String)
ACCESS_SEQ 検索順序 - 検索番号 (String)
CONDCOUNT 条件連続番号 (String)
CONDCNTRL 条件管理 (String)
CONDISACTI 無効条件 (String)
CONDCLASS 条件クラス (String)
FACTBASVAL 条件基礎値に対する要因 (String)
SCALEBASIN スケール基準区分 (String)
SCALBASVAL 条件のスケール基準値 (String)
UNITMEASUR 条件スケール単位 (String)
UNITMEASUR_ISO 単位の ISO コード (String)
CURRENCKEY スケール通貨 (String)
CURRENCKEY_ISO ISO コード通貨 (String)
CONDINCOMP 会社間請求の条件 (String)
CONDCONFIG システム設定の条件 (String)
CONDCHAMAN 条件 (マニュアル変更済) (String)
COND_NO 条件レコード番号 (String)
CHANGE_ID 変更タイプ(U、I、E、D) (String)

取得した条件明細情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONDITION_NO"]　→　配列内のidx番目の条件明細の「伝票条件番号」
[idx]["ITM_NUMBER"]　→　配列内のidx番目の条件明細の「条件明細番号」
[idx]["COND_ST_NO"]　→　配列内のidx番目の条件明細の「ステップ番号」
[idx]["COND_COUNT"]　→　配列内のidx番目の条件明細の「条件カウンタ」
[idx]["COND_TYPE"]　→　配列内のidx番目の条件明細の「条件タイプ」
[idx]["COND_VALUE"]　→　配列内のidx番目の条件明細の「条件レート」
[idx]["CURRENCY"]　→　配列内のidx番目の条件明細の「通貨コード」
[idx]["CURRENCY_ISO"]　→　配列内のidx番目の条件明細の「ISO コード通貨」
[idx]["COND_UNIT"]　→　配列内のidx番目の条件明細の「条件単位」
[idx]["COND_UNIT_ISO"]　→　配列内のidx番目の条件明細の「条件数量単位 (ISO コード)」
[idx]["COND_P_UNT"]　→　配列内のidx番目の条件明細の「価格条件単位」
[idx]["APPLICATIO"]　→　配列内のidx番目の条件明細の「アプリケーション」
[idx]["CONPRICDAT"]　→　配列内のidx番目の条件明細の「条件価格設定日付」
[idx]["CALCTYPCON"]　→　配列内のidx番目の条件明細の「条件計算タイプ」
[idx]["CONBASEVAL"]　→　配列内のidx番目の条件明細の「条件基礎値」
[idx]["CONEXCHRAT"]　→　配列内のidx番目の条件明細の「現地通貨への換算レートに対する条件」
[idx]["NUMCONVERT"]　→　配列内のidx番目の条件明細の「条件単位を基本単位へ変換する分子」
[idx]["DENOMINATO"]　→　配列内のidx番目の条件明細の「条件単位を基本単位へ変換する分母」
[idx]["CONDTYPE"]　→　配列内のidx番目の条件明細の「条件カテゴリ (例：税、運賃、価格、原価)」
[idx]["STAT_CON"]　→　配列内のidx番目の条件明細の「統計に適用する条件」
[idx]["SCALETYPE"]　→　配列内のidx番目の条件明細の「スケールタイプ」
[idx]["ACCRUALS"]　→　配列内のidx番目の条件明細の「見越額関連条件 (運賃など)」
[idx]["CONINVOLST"]　→　配列内のidx番目の条件明細の「請求書一覧条件」
[idx]["CONDORIGIN"]　→　配列内のidx番目の条件明細の「条件生成区分」
[idx]["GROUPCOND"]　→　配列内のidx番目の条件明細の「グループ条件区分」
[idx]["COND_UPDAT"]　→　配列内のidx番目の条件明細の「条件更新」
[idx]["ACCESS_SEQ"]　→　配列内のidx番目の条件明細の「検索順序 - 検索番号」
[idx]["CONDCOUNT"]　→　配列内のidx番目の条件明細の「条件連続番号」
[idx]["CONDCNTRL"]　→　配列内のidx番目の条件明細の「条件管理」
[idx]["CONDISACTI"]　→　配列内のidx番目の条件明細の「無効条件」
[idx]["CONDCLASS"]　→　配列内のidx番目の条件明細の「条件クラス」
[idx]["FACTBASVAL"]　→　配列内のidx番目の条件明細の「条件基礎値に対する要因」
[idx]["SCALEBASIN"]　→　配列内のidx番目の条件明細の「スケール基準区分」
[idx]["SCALBASVAL"]　→　配列内のidx番目の条件明細の「条件のスケール基準値」
[idx]["UNITMEASUR"]　→　配列内のidx番目の条件明細の「条件スケール単位」
[idx]["UNITMEASUR_ISO"]　→　配列内のidx番目の条件明細の「単位の ISO コード」
[idx]["CURRENCKEY"]　→　配列内のidx番目の条件明細の「スケール通貨」
[idx]["CURRENCKEY_ISO"]　→　配列内のidx番目の条件明細の「ISO コード通貨」
[idx]["CONDINCOMP"]　→　配列内のidx番目の条件明細の「会社間請求の条件」
[idx]["CONDCONFIG"]　→　配列内のidx番目の条件明細の「システム設定の条件」
[idx]["CONDCHAMAN"]　→　配列内のidx番目の条件明細の「条件 (マニュアル変更済)」
[idx]["COND_NO"]　→　配列内のidx番目の条件明細の「条件レコード番号」
[idx]["CHANGE_ID"]　→　配列内のidx番目の条件明細の「変更タイプ(U、I、E、D)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getContractLimitsList

Object getContractLimitsList ()

外注基本契約制限一覧を取得します｡
返却値
Object 外注基本契約制限一覧

外注基本契約制限情報オブジェクトの構成は以下のとおりです。
外注基本契約制限情報
オブジェクト
(Object)
PCKG_NO パッケージ番号 (String)
LINE_NO 制限の内部明細番号 (String)
CON_NUMBER 基本契約番号 (String)
CON_ITEM 明細番号、契約 (String)
LIMIT 全体制限 (String)
NO_LIMIT 制限なし (String)
PRICE_CHG 入力シートの価格変更 (String)
SHORT_TEXT テキスト 1 (短) (String)
DELETE_IND 削除フラグ (String)

取得した外注基本契約制限情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PCKG_NO"]　→　配列内のidx番目の外注基本契約制限の「パッケージ番号」
[idx]["LINE_NO"]　→　配列内のidx番目の外注基本契約制限の「制限の内部明細番号」
[idx]["CON_NUMBER"]　→　配列内のidx番目の外注基本契約制限の「基本契約番号」
[idx]["CON_ITEM"]　→　配列内のidx番目の外注基本契約制限の「明細番号、契約」
[idx]["LIMIT"]　→　配列内のidx番目の外注基本契約制限の「全体制限」
[idx]["NO_LIMIT"]　→　配列内のidx番目の外注基本契約制限の「制限なし」
[idx]["PRICE_CHG"]　→　配列内のidx番目の外注基本契約制限の「入力シートの価格変更」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の外注基本契約制限の「テキスト 1 (短)」
[idx]["DELETE_IND"]　→　配列内のidx番目の外注基本契約制限の「削除フラグ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getContractServiceAccountList

Object getContractServiceAccountList ()

外注サービス勘定設定一覧を取得します｡
返却値
Object 外注サービス勘定設定一覧

外注サービス勘定設定情報オブジェクトの構成は以下のとおりです。
外注サービス勘定設定情報
オブジェクト
(Object)
PCKG_NO パッケージ番号 (String)
LINE_NO 明細行番号 (String)
SERNO_LINE 勘定コード設定のシリアル番号、サービス明細 (String)
PERCENTAGE 勘定設定金額配賦のパーセント (String)
SERIAL_NO 勘定設定の連続番号 (String)
QUANTITY +/- 記号あり/なし数量 (String)
NET_VALUE 明細の正味額 (String)

取得した外注サービス勘定設定情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PCKG_NO"]　→　配列内のidx番目の外注サービス勘定設定の「パッケージ番号」
[idx]["LINE_NO"]　→　配列内のidx番目の外注サービス勘定設定の「明細行番号」
[idx]["SERNO_LINE"] 　→　配列内のidx番目の外注サービス勘定設定の「勘定コード設定のシリアル番号、サービス明細」
[idx]["PERCENTAGE"] 　→　配列内のidx番目の外注サービス勘定設定の「勘定設定金額配賦のパーセント」
[idx]["SERIAL_NO"]　→　配列内のidx番目の外注サービス勘定設定の「勘定設定の連続番号」
[idx]["QUANTITY"]　→　配列内のidx番目の外注サービス勘定設定の「+/- 記号あり/なし数量」
[idx]["NET_VALUE"]　→　配列内のidx番目の外注サービス勘定設定の「明細の正味額」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getContractServiceList

Object getContractServiceList ()

外注サービス一覧を取得します｡
返却値
Object 外注サービス一覧

外注サービス情報オブジェクトの構成は以下のとおりです。
外注サービス情報
オブジェクト
(Object)
PCKG_NO パッケージ番号 (String)
LINE_NO 内部明細番号 (String)
EXT_LINE 明細番号 (String)
OUTL_LEVEL グループの階層レベル (String)
OUTL_NO アウトラインレベル (String)
OUTL_IND 区分：出力行 (String)
SUBPCKG_NO サブパッケージ番号 (String)
SERVICE 活動番号 (String)
SERV_TYPE サービスタイプのテキスト (短) (String)
EDITION サービスタイプのバージョン (String)
SSC_ITEM 標準サービスカタログ：明細 (String)
EXT_SERV 仕入先のサービス番号 (String)
QUANTITY +/- 記号あり/なし数量 (String)
BASE_UOM 基本数量単位 (String)
UOM_ISO 単位の ISO コード (String)
OVF_TOL 超過許容値 (String)
OVF_UNLIM 契約外サービス制限なし (String)
PRICE_UNIT 価格単位 (String)
GR_PRICE 基準額 (String)
FROM_LINE 下限 (String)
TO_LINE 上限 (String)
SHORT_TEXT テキスト(短) (String)
DISTRIB 複数勘定設定の配賦区分 (String)
PERS_NO 従業員番号 (String)
WAGETYPE ウェイジタイプ (String)
PLN_PCKG パッケージ番号供給元一覧 (String)
PLN_LINE 入力：計画梱包明細行 (String)
CON_PCKG 入力：基本契約の計画外 (String)
CON_LINE 入力：基本契約の計画外 (String)
TMP_PCKG 入力：モデル仕様からの計画外サービス (String)
TMP_LINE 入力：モデル仕様からの計画外サービス (String)
SSC_LIM 標準サービスカタログ制限参照のサービス行 (String)
LIMIT_LINE 入力：計画外、明細制限 (String)
TARGET_VAL 目標値 (String)
BASLINE_NO 代替：基本明細参照 (String)
BASIC_LINE 基本明細 (String)
ALTERNAT 代替明細 (String)
BIDDER 入札者の明細 (String)
SUPP_LINE 補足明細 (String)
OPEN_QTY 未処理数量のある明細 (String)
INFORM 情報行 (String)
BLANKET 包括明細 (String)
EVENTUAL 偶発的明細 (String)
TAX_CODE 消費税コード (String)
TAXJURCODE 税計算管轄コード - 税管轄コード (String)
PRICE_CHG 入力シートの価格変更 (String)
MATL_GROUP 品目グループ (String)
DATE 日付 (String)
BEGINTIME 開始時刻 (String)
ENDTIME 終了時刻 (String)
EXTPERS_NO 外部従業員番号 (String)
FORMULA 計算式番号 (String)
FORM_VAL1 計算式値 (String)
FORM_VAL2 計算式値 (String)
FORM_VAL3 計算式値 (String)
FORM_VAL4 計算式値 (String)
FORM_VAL5 計算式値 (String)
USERF1_NUM ユーザ定義項目 (String)
USERF2_NUM ユーザ定義項目 (String)
USERF1_TXT ユーザ定義項目 (String)
USERF2_TXT ユーザ定義項目 (String)
HI_LINE_NO 上位階層明細番号 (String)
EXTREFKEY サービスの外部参照キー (String)
DELETE_IND 削除フラグ (String)

取得した外注サービス情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PCKG_NO"]　→　配列内のidx番目の外注サービスの「パッケージ番号」
[idx]["LINE_NO"]　→　配列内のidx番目の外注サービスの「内部明細番号」
[idx]["EXT_LINE"]　→　配列内のidx番目の外注サービスの「明細番号」
[idx]["OUTL_LEVEL"]　→　配列内のidx番目の外注サービスの「グループの階層レベル」
[idx]["OUTL_NO"]　→　配列内のidx番目の外注サービスの「アウトラインレベル」
[idx]["OUTL_IND"]　→　配列内のidx番目の外注サービスの「区分：出力行」
[idx]["SUBPCKG_NO"]　→　配列内のidx番目の外注サービスの「サブパッケージ番号」
[idx]["SERVICE"]　→　配列内のidx番目の外注サービスの「活動番号」
[idx]["SERV_TYPE"]　→　配列内のidx番目の外注サービスの「サービスタイプのテキスト (短)」
[idx]["EDITION"]　→　配列内のidx番目の外注サービスの「サービスタイプのバージョン」
[idx]["SSC_ITEM"]　→　配列内のidx番目の外注サービスの「標準サービスカタログ：明細」
[idx]["EXT_SERV"]　→　配列内のidx番目の外注サービスの「仕入先のサービス番号」
[idx]["QUANTITY"]　→　配列内のidx番目の外注サービスの「+/- 記号あり/なし数量」
[idx]["BASE_UOM"]　→　配列内のidx番目の外注サービスの「基本数量単位」
[idx]["UOM_ISO"]　→　配列内のidx番目の外注サービスの「単位の ISO コード」
[idx]["OVF_TOL"]　→　配列内のidx番目の外注サービスの「超過許容値」
[idx]["OVF_UNLIM"]　→　配列内のidx番目の外注サービスの「契約外サービス制限なし」
[idx]["PRICE_UNIT"]　→　配列内のidx番目の外注サービスの「価格単位」
[idx]["GR_PRICE"]　→　配列内のidx番目の外注サービスの「基準額」
[idx]["FROM_LINE"]　→　配列内のidx番目の外注サービスの「下限」
[idx]["TO_LINE"]　→　配列内のidx番目の外注サービスの「上限」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の外注サービスの「テキスト(短)」
[idx]["DISTRIB"]　→　配列内のidx番目の外注サービスの「複数勘定設定の配賦区分」
[idx]["PERS_NO"]　→　配列内のidx番目の外注サービスの「従業員番号」
[idx]["WAGETYPE"]　→　配列内のidx番目の外注サービスの「ウェイジタイプ」
[idx]["PLN_PCKG"]　→　配列内のidx番目の外注サービスの「パッケージ番号供給元一覧」
[idx]["PLN_LINE"]　→　配列内のidx番目の外注サービスの「入力：計画梱包明細行」
[idx]["CON_PCKG"]　→　配列内のidx番目の外注サービスの「入力：基本契約の計画外」
[idx]["CON_LINE"]　→　配列内のidx番目の外注サービスの「入力：基本契約の計画外」
[idx]["TMP_PCKG"]　→　配列内のidx番目の外注サービスの「入力：モデル仕様からの計画外サービス」
[idx]["TMP_LINE"]　→　配列内のidx番目の外注サービスの「入力：モデル仕様からの計画外サービス」
[idx]["SSC_LIM"]　→　配列内のidx番目の外注サービスの「標準サービスカタログ制限参照のサービス行」
[idx]["LIMIT_LINE"]　→　配列内のidx番目の外注サービスの「入力：計画外、明細制限」
[idx]["TARGET_VAL"]　→　配列内のidx番目の外注サービスの「目標値」
[idx]["BASLINE_NO"]　→　配列内のidx番目の外注サービスの「代替：基本明細参照」
[idx]["BASIC_LINE"]　→　配列内のidx番目の外注サービスの「基本明細」
[idx]["ALTERNAT"]　→　配列内のidx番目の外注サービスの「代替明細」
[idx]["BIDDER"]　→　配列内のidx番目の外注サービスの「入札者の明細」
[idx]["SUPP_LINE"]　→　配列内のidx番目の外注サービスの「補足明細」
[idx]["OPEN_QTY"]　→　配列内のidx番目の外注サービスの「未処理数量のある明細」
[idx]["INFORM"]　→　配列内のidx番目の外注サービスの「情報行」
[idx]["BLANKET"]　→　配列内のidx番目の外注サービスの「包括明細」
[idx]["EVENTUAL"]　→　配列内のidx番目の外注サービスの「偶発的明細」
[idx]["TAX_CODE"]　→　配列内のidx番目の外注サービスの「消費税コード」
[idx]["TAXJURCODE"]　→　配列内のidx番目の外注サービスの「税計算管轄コード - 税管轄コード」
[idx]["PRICE_CHG"]　→　配列内のidx番目の外注サービスの「入力シートの価格変更」
[idx]["MATL_GROUP"]　→　配列内のidx番目の外注サービスの「品目グループ」
[idx]["DATE"]　→　配列内のidx番目の外注サービスの「日付」
[idx]["BEGINTIME"]　→　配列内のidx番目の外注サービスの「開始時刻」
[idx]["ENDTIME"]　→　配列内のidx番目の外注サービスの「終了時刻」
[idx]["EXTPERS_NO"]　→　配列内のidx番目の外注サービスの「外部従業員番号」
[idx]["FORMULA"]　→　配列内のidx番目の外注サービスの「計算式番号」
[idx]["FORM_VAL1"]　→　配列内のidx番目の外注サービスの「計算式値」
[idx]["FORM_VAL2"]　→　配列内のidx番目の外注サービスの「計算式値」
[idx]["FORM_VAL3"]　→　配列内のidx番目の外注サービスの「計算式値」
[idx]["FORM_VAL4"]　→　配列内のidx番目の外注サービスの「計算式値」
[idx]["FORM_VAL5"]　→　配列内のidx番目の外注サービスの「計算式値」
[idx]["USERF1_NUM"]　→　配列内のidx番目の外注サービスの「ユーザ定義項目」
[idx]["USERF2_NUM"]　→　配列内のidx番目の外注サービスの「ユーザ定義項目」
[idx]["USERF1_TXT"]　→　配列内のidx番目の外注サービスの「ユーザ定義項目」
[idx]["USERF2_TXT"]　→　配列内のidx番目の外注サービスの「ユーザ定義項目」
[idx]["HI_LINE_NO"]　→　配列内のidx番目の外注サービスの「上位階層明細番号」
[idx]["EXTREFKEY"]　→　配列内のidx番目の外注サービスの「サービスの外部参照キー」
[idx]["DELETE_IND"]　→　配列内のidx番目の外注サービスの「削除フラグ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getContractServiceTextList

Object getContractServiceTextList ()

外注サービステキスト一覧を取得します｡
返却値
Object 外注サービステキスト一覧

外注サービステキスト情報オブジェクトの構成は以下のとおりです。
外注サービステキスト情報
オブジェクト
(Object)
PCKG_NO パッケージ番号 (String)
LINE_NO 内部明細番号 (String)
TEXT_ID テキスト ID (String)
FORMAT_COL タグ列 (String)
TEXT_LINE テキスト行 (String)

取得した外注サービステキスト情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PCKG_NO"]　→　配列内のidx番目の外注サービステキストの「パッケージ番号」
[idx]["LINE_NO"]　→　配列内のidx番目の外注サービステキストの「内部明細番号」
[idx]["TEXT_ID"]　→　配列内のidx番目の外注サービステキストの「テキスト ID」
[idx]["FORMAT_COL"]　→　配列内のidx番目の外注サービステキストの「タグ列」
[idx]["TEXT_LINE"]　→　配列内のidx番目の外注サービステキストの「テキスト行」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getDeliverryAddressList

Object getDeliverryAddressList ()

出荷伝票アドレス一覧を取得します｡
返却値
Object 出荷伝票アドレス一覧

出荷伝票アドレス情報オブジェクトの構成は以下のとおりです。
出荷伝票アドレス情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号 (String)
ADDR_NO アドレス番号 (String)
FORMOFADDR 敬称テキスト (String)
NAME 名称 1 (String)
NAME_2 名称 2 (String)
NAME_3 名称 3 (String)
NAME_4 名称 4 (String)
C_O_NAME 気付 (String)
CITY 市区町村 (String)
DISTRICT 所在地 (String)
CITY_NO 市区町村/地名ファイルの市区町村コード (String)
POSTL_COD1 市区町村の郵便番号 (String)
POSTL_COD2 私書箱郵便番号 (String)
POSTL_COD3 会社郵便番号 (大規模なユーザ用) (String)
PO_BOX 私書箱 (String)
PO_BOX_CIT 私書箱住所 (String)
DELIV_DIS 郵便配達地域 (String)
STREET 地名 (String)
STREET_NO 市区町村/地名ファイルの地名コード (String)
STR_ABBR 地名の略称 (例：スペイン) (String)
HOUSE_NO 番地-号 (String)
STR_SUPPL1 地名 2 (String)
STR_SUPPL2 地名 3 (String)
LOCATION 地名 5 (String)
BUILDING 旧：建物 (番号または略称) (String)
FLOOR 建物の階 (String)
ROOM_NO 部屋/アパート番号 (String)
COUNTRY 国コード (String)
LANGU 言語キー (String)
REGION 地域 (都道府県) (String)
SORT1 検索条件 1 (String)
SORT2 検索条件 2 (String)
TIME_ZONE アドレスタイムゾーン (String)
TAXJURCODE 税管轄コード (String)
ADR_NOTES 住所注記 (String)
COMM_TYPE 通信方法 (キー) (アドレス管理) (String)
TEL1_NUMBR 第一電話番号：ダイヤルコード + 番号 (String)
TEL1_EXT 第 1 電話番号：内線 (String)
FAX_NUMBER 第一 FAX 番号：ダイヤルコード + 番号 (String)
FAX_EXTENS 第一 FAX 番号：内線 (String)
STREET_LNG 地名 (String)
DISTRCT_NO 市区町村/地名ファイルの所在地コード (String)
CHCKSTATUS 市区町村ファイルテストステータス (String)
PBOXCIT_NO 市区町村私書箱コード (市ファイル) (String)
TRANSPZONE 商品の納入区域 (String)
HOUSE_NO2 番地補足 (String)
E_MAIL 電子メールアドレス (String)
STR_SUPPL3 地名 4 (String)
TITLE タイトル (敬称) (String)
COUNTRYISO ISO 国コード (String)
LANGU_ISO ISO 639 準拠の言語 (String)
BUILD_LONG 建物 (番号またはコード) (String)
REGIOGROUP 地域構造グループ化 (String)

取得した出荷伝票アドレス情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の出荷伝票アドレスの「購買伝票の明細番号」
[idx]["ADDR_NO"]　→　配列内のidx番目の出荷伝票アドレスの「アドレス番号」
[idx]["FORMOFADDR"]　→　配列内のidx番目の出荷伝票アドレスの「敬称テキスト」
[idx]["NAME"]　→　配列内のidx番目の出荷伝票アドレスの「名称 1」
[idx]["NAME_2"]　→　配列内のidx番目の出荷伝票アドレスの「名称 2」
[idx]["NAME_3"]　→　配列内のidx番目の出荷伝票アドレスの「名称 3」
[idx]["NAME_4"]　→　配列内のidx番目の出荷伝票アドレスの「名称 4」
[idx]["C_O_NAME"]　→　配列内のidx番目の出荷伝票アドレスの「気付」
[idx]["CITY"]　→　配列内のidx番目の出荷伝票アドレスの「市区町村」
[idx]["DISTRICT"]　→　配列内のidx番目の出荷伝票アドレスの「所在地」
[idx]["CITY_NO"] 　→　配列内のidx番目の出荷伝票アドレスの「市区町村/地名ファイルの市区町村コード」
[idx]["POSTL_COD1"]　→　配列内のidx番目の出荷伝票アドレスの「市区町村の郵便番号」
[idx]["POSTL_COD2"]　→　配列内のidx番目の出荷伝票アドレスの「私書箱郵便番号」
[idx]["POSTL_COD3"] 　→　配列内のidx番目の出荷伝票アドレスの「会社郵便番号 (大規模なユーザ用)」
[idx]["PO_BOX"]　→　配列内のidx番目の出荷伝票アドレスの「私書箱」
[idx]["PO_BOX_CIT"]　→　配列内のidx番目の出荷伝票アドレスの「私書箱住所」
[idx]["DELIV_DIS"]　→　配列内のidx番目の出荷伝票アドレスの「郵便配達地域」
[idx]["STREET"]　→　配列内のidx番目の出荷伝票アドレスの「地名」
[idx]["STREET_NO"] 　→　配列内のidx番目の出荷伝票アドレスの「市区町村/地名ファイルの地名コード」
[idx]["STR_ABBR"]　→　配列内のidx番目の出荷伝票アドレスの「地名の略称 (例：スペイン)」
[idx]["HOUSE_NO"]　→　配列内のidx番目の出荷伝票アドレスの「番地-号」
[idx]["STR_SUPPL1"]　→　配列内のidx番目の出荷伝票アドレスの「地名 2」
[idx]["STR_SUPPL2"]　→　配列内のidx番目の出荷伝票アドレスの「地名 3」
[idx]["LOCATION"]　→　配列内のidx番目の出荷伝票アドレスの「地名 5」
[idx]["BUILDING"]　→　配列内のidx番目の出荷伝票アドレスの「旧：建物 (番号または略称)」
[idx]["FLOOR"]　→　配列内のidx番目の出荷伝票アドレスの「建物の階」
[idx]["ROOM_NO"]　→　配列内のidx番目の出荷伝票アドレスの「部屋/アパート番号」
[idx]["COUNTRY"]　→　配列内のidx番目の出荷伝票アドレスの「国コード」
[idx]["LANGU"]　→　配列内のidx番目の出荷伝票アドレスの「言語キー」
[idx]["REGION"]　→　配列内のidx番目の出荷伝票アドレスの「地域 (都道府県)」
[idx]["SORT1"]　→　配列内のidx番目の出荷伝票アドレスの「検索条件 1」
[idx]["SORT2"]　→　配列内のidx番目の出荷伝票アドレスの「検索条件 2」
[idx]["TIME_ZONE"]　→　配列内のidx番目の出荷伝票アドレスの「アドレスタイムゾーン」
[idx]["TAXJURCODE"]　→　配列内のidx番目の出荷伝票アドレスの「税管轄コード」
[idx]["ADR_NOTES"]　→　配列内のidx番目の出荷伝票アドレスの「住所注記」
[idx]["COMM_TYPE"] 　→　配列内のidx番目の出荷伝票アドレスの「通信方法 (キー) (アドレス管理)」
[idx]["TEL1_NUMBR"] 　→　配列内のidx番目の出荷伝票アドレスの「第一電話番号：ダイヤルコード + 番号」
[idx]["TEL1_EXT"]　→　配列内のidx番目の出荷伝票アドレスの「第 1 電話番号：内線」
[idx]["FAX_NUMBER"] 　→　配列内のidx番目の出荷伝票アドレスの「第一 FAX 番号：ダイヤルコード + 番号」
[idx]["FAX_EXTENS"]　→　配列内のidx番目の出荷伝票アドレスの「第一 FAX 番号：内線」
[idx]["STREET_LNG"]　→　配列内のidx番目の出荷伝票アドレスの「地名」
[idx]["DISTRCT_NO"] 　→　配列内のidx番目の出荷伝票アドレスの「市区町村/地名ファイルの所在地コード」
[idx]["CHCKSTATUS"] 　→　配列内のidx番目の出荷伝票アドレスの「市区町村ファイルテストステータス」
[idx]["PBOXCIT_NO"] 　→　配列内のidx番目の出荷伝票アドレスの「市区町村私書箱コード (市ファイル)」
[idx]["TRANSPZONE"]　→　配列内のidx番目の出荷伝票アドレスの「商品の納入区域」
[idx]["HOUSE_NO2"]　→　配列内のidx番目の出荷伝票アドレスの「番地補足」
[idx]["E_MAIL"]　→　配列内のidx番目の出荷伝票アドレスの「電子メールアドレス」
[idx]["STR_SUPPL3"]　→　配列内のidx番目の出荷伝票アドレスの「地名 4」
[idx]["TITLE"]　→　配列内のidx番目の出荷伝票アドレスの「タイトル (敬称)」
[idx]["COUNTRYISO"]　→　配列内のidx番目の出荷伝票アドレスの「ISO 国コード」
[idx]["LANGU_ISO"]　→　配列内のidx番目の出荷伝票アドレスの「ISO 639 準拠の言語」
[idx]["BUILD_LONG"]　→　配列内のidx番目の出荷伝票アドレスの「建物 (番号またはコード)」
[idx]["REGIOGROUP"]　→　配列内のidx番目の出荷伝票アドレスの「地域構造グループ化」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getDocumentHeader

Object getDocumentHeader ()

伝票ヘッダを取得します。
返却値
Object 伝票ヘッダオブジェクト

伝票ヘッダオブジェクトの構成は以下のとおりです。
伝票ヘッダ情報
オブジェクト
(Object)
PO_NUMBER 購買伝票番号 (String)
COMP_CODE 会社コード (String)
DOC_TYPE 購買伝票タイプ (String)
DELETE_IND 購買伝票の削除フラグ (String)
STATUS 購買伝票のステータス (String)
CREAT_DATE レコード登録日 (String)
CREATED_BY オブジェクト登録者名 (String)
ITEM_INTVL 明細番号間隔 (String)
VENDOR 仕入先勘定コード (String)
LANGU 言語キー (String)
LANGU_ISO 言語キーの ISO コード (String)
PMNTTRMS 支払条件キー (String)
DSCNT1_TO 現金割引日数 (早期支払) (String)
DSCNT2_TO 現金割引日数 (早期支払) (String)
DSCNT3_TO 現金割引日数 (早期支払) (String)
DSCT_PCT1 割引率 1 (String)
DSCT_PCT2 割引率 2 (String)
PURCH_ORG 購買組織 (String)
PUR_GROUP 購買グループ (String)
CURRENCY 通貨コード (String)
CURRENCY_ISO ISO コード通貨 (String)
EXCH_RATE 換算レート (String)
EX_RATE_FX 区分：換算レート固定 (String)
DOC_DATE 購買伝票日付 (String)
VPER_START 有効期間開始日 (String)
VPER_END 有効期間の終了日 (String)
WARRANTY 保証日 (String)
QUOTATION 見積番号 (String)
QUOT_DATE 見積提出日 (String)
REF_1 得意先/仕入先の内部参照コード (String)
SALES_PERS 仕入先営業担当者 (String)
TELEPHONE 仕入先電話番号 (String)
SUPPL_VEND 供給仕入先 (String)
CUSTOMER 得意先コード 1 (String)
AGREEMENT 購買契約番号 (String)
GR_MESSAGE 区分：入庫メッセージ (String)
SUPPL_PLNT 在庫転送オーダーにおける供給 (出庫) プラント (String)
INCOTERMS1 インコタームズ (1) (String)
INCOTERMS2 インコタームズ 2 (String)
COLLECT_NO 一括番号 (String)
DIFF_INV 仕入先と請求元が異なる場合の請求元のコード (String)
OUR_REF 社内参照番号 (String)
LOGSYSTEM 論理システム (String)
SUBITEMINT 副明細の明細間隔 (String)
PO_REL_IND 承認区分：購買伝票 (String)
REL_STATUS 承認状況 (String)
VAT_CNTRY 売上税 ID 番号国 (String)
VAT_CNTRY_ISO 消費税登録番号の ISO 国コード (String)
REASON_CANCEL 取消理由 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getExportHeader

Object getExportHeader ()

貿易管理ヘッダを取得します｡
返却値
Object 貿易管理ヘッダ

貿易管理ヘッダ情報オブジェクトの構成は以下のとおりです。
貿易管理ヘッダ情報
オブジェクト
(Object)
TRANSPORT_MODE 貿易管理の輸送モード (String)
CUSTOMS 税関：税関 (出国時) (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getExportItemList

Object getExportItemList ()

貿易管理明細一覧を取得します｡
返却値
Object 貿易管理明細一覧

貿易管理明細情報オブジェクトの構成は以下のとおりです。
貿易管理明細情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号 (String)
BUSINESS_TRANSACTION_TYPE 貿易管理の取引タイプ (String)
EXPORT_IMPORT_PROCEDURE 貿易の輸出入手続 (String)
COUNTRYORI 品目の原産国 (String)
COUNTRYORI_ISO ISO 国コード (String)
REGIONORIG 品目の原産地 (非特恵対象地区の原産) (String)
COMM_CODE 貿易：統計品目コード/輸入コード番号 (String)
SHIPPING_COUNTRY 貿易：出荷国 (String)
SHIPPING_COUNTRY_ISO ISO 国コード (String)

取得した貿易管理明細情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の貿易管理明細の「購買伝票の明細番号」
[idx]["BUSINESS_TRANSACTION_TYPE"] 　→　配列内のidx番目の貿易管理明細の「貿易管理の取引タイプ」
[idx]["EXPORT_IMPORT_PROCEDURE"] 　→　配列内のidx番目の貿易管理明細の「貿易の輸出入手続」
[idx]["COUNTRYORI"]　→　配列内のidx番目の貿易管理明細の「品目の原産国」
[idx]["COUNTRYORI_ISO"]　→　配列内のidx番目の貿易管理明細の「ISO 国コード」
[idx]["REGIONORIG"] 　→　配列内のidx番目の貿易管理明細の「品目の原産地 (非特恵対象地区の原産)」
[idx]["COMM_CODE"]　→　配列内のidx番目の貿易管理明細の「貿易：統計品目コード/輸入コード番号」
[idx]["SHIPPING_COUNTRY"]　→　配列内のidx番目の貿易管理明細の「貿易：出荷国」
[idx]["SHIPPING_COUNTRY_ISO"] 　→　配列内のidx番目の貿易管理明細の「ISO 国コード」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getExtensionList

Object getExtensionList ()

拡張得意先項目一覧を取得します｡
返却値
Object 拡張得意先項目一覧

拡張得意先項目情報オブジェクトの構成は以下のとおりです。
拡張得意先項目情報
オブジェクト
(Object)
STRUCTURE BAPI テーブル拡張の構造名 (String)
VALUEPART1 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART2 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART3 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART4 BAPI 拡張パラメータのデータ部分 (String)

取得した拡張得意先項目情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["STRUCTURE"]　→　配列内のidx番目の拡張得意先項目の「BAPI テーブル拡張の構造名」
[idx]["VALUEPART1"] 　→　配列内のidx番目の拡張得意先項目の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART2"] 　→　配列内のidx番目の拡張得意先項目の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART3"] 　→　配列内のidx番目の拡張得意先項目の「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART4"] 　→　配列内のidx番目の拡張得意先項目の「BAPI 拡張パラメータのデータ部分」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getHeaderTextList

Object getHeaderTextList ()

ヘッダテキスト一覧を取得します｡
返却値
Object ヘッダテキスト一覧

ヘッダテキスト情報オブジェクトの構成は以下のとおりです。
ヘッダテキスト情報
オブジェクト
(Object)
PO_NUMBER 購買伝票番号 (String)
PO_ITEM 購買伝票の明細番号 (String)
TEXT_ID テキスト ID (String)
TEXT_FORM タグ列 (String)
TEXT_LINE テキスト行 (String)

取得したヘッダテキスト情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_NUMBER"]　→　配列内のidx番目のヘッダテキストの「購買伝票番号」
[idx]["PO_ITEM"]　→　配列内のidx番目のヘッダテキストの「購買伝票の明細番号」
[idx]["TEXT_ID"]　→　配列内のidx番目のヘッダテキストの「テキスト ID」
[idx]["TEXT_FORM"]　→　配列内のidx番目のヘッダテキストの「タグ列」
[idx]["TEXT_LINE"]　→　配列内のidx番目のヘッダテキストの「テキスト行」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getItemTextList

Object getItemTextList ()

明細テキスト一覧を取得します｡
返却値
Object 明細テキスト

明細テキスト情報オブジェクトの構成は以下のとおりです。
明細テキスト情報
オブジェクト
(Object)
PO_NUMBER 購買伝票番号 (String)
PO_ITEM 購買伝票の明細番号 (String)
TEXT_ID テキスト ID (String)
TEXT_FORM タグ列 (String)
TEXT_LINE テキスト行 (String)

取得した明細テキスト情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_NUMBER"]　→　配列内のidx番目の明細テキストの「購買伝票番号」
[idx]["PO_ITEM"]　→　配列内のidx番目の明細テキストの「購買伝票の明細番号」
[idx]["TEXT_ID"]　→　配列内のidx番目の明細テキストの「テキスト ID」
[idx]["TEXT_FORM"]　→　配列内のidx番目の明細テキストの「タグ列」
[idx]["TEXT_LINE"]　→　配列内のidx番目の明細テキストの「テキスト行」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getLimitsList

Object getLimitsList ()

外注制限一覧を取得します｡
返却値
Object 外注制限一覧

外注制限情報オブジェクトの構成は以下のとおりです。
外注制限情報
オブジェクト
(Object)
PCKG_NO パッケージ番号 (String)
LIMIT 全体制限 (String)
NO_LIMIT 制限なし (String)
EXP_VALUE 見込金額 (String)
SSC_EXIST サービスタイプの制限 (String)
CON_EXIST 基本契約明細の制限 (String)
TMP_EXIST サービスパッケージの制限 (String)
PRICE_CHG 入力シートの価格変更 (String)
FREE_LIMIT 自由制限 (String)
NO_FRLIMIT 制限なし (String)
SERV_TYPE サービスタイプのテキスト (短) (String)
EDITION サービスタイプのバージョン (String)
SSC_LIMIT サービスタイプの金額制限 (String)
SSC_NOLIM 標準サービスタイプの制限なし (String)
SSC_PRSCHG 入力シートの価格変更 (String)
SSC_PERC 価格決定率 (String)
TMP_NUMBER モデルサービス明細セット番号 (String)
TMP_LIMIT モデルサービス明細制限 (String)
TMP_NOLIM モデル仕様の制限なし (String)
TMP_PRSCHG 入力シートの価格変更 (String)
TMP_PERC 価格決定率 (String)
CONT_PERC 価格決定率 (String)

取得した外注制限情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PCKG_NO"]　→　配列内のidx番目の外注制限の「パッケージ番号」
[idx]["LIMIT"]　→　配列内のidx番目の外注制限の「全体制限」
[idx]["NO_LIMIT"]　→　配列内のidx番目の外注制限の「制限なし」
[idx]["EXP_VALUE"]　→　配列内のidx番目の外注制限の「見込金額」
[idx]["SSC_EXIST"]　→　配列内のidx番目の外注制限の「サービスタイプの制限」
[idx]["CON_EXIST"]　→　配列内のidx番目の外注制限の「基本契約明細の制限」
[idx]["TMP_EXIST"]　→　配列内のidx番目の外注制限の「サービスパッケージの制限」
[idx]["PRICE_CHG"]　→　配列内のidx番目の外注制限の「入力シートの価格変更」
[idx]["FREE_LIMIT"]　→　配列内のidx番目の外注制限の「自由制限」
[idx]["NO_FRLIMIT"]　→　配列内のidx番目の外注制限の「制限なし」
[idx]["SERV_TYPE"]　→　配列内のidx番目の外注制限の「サービスタイプのテキスト (短)」
[idx]["EDITION"]　→　配列内のidx番目の外注制限の「サービスタイプのバージョン」
[idx]["SSC_LIMIT"]　→　配列内のidx番目の外注制限の「サービスタイプの金額制限」
[idx]["SSC_NOLIM"]　→　配列内のidx番目の外注制限の「標準サービスタイプの制限なし」
[idx]["SSC_PRSCHG"]　→　配列内のidx番目の外注制限の「入力シートの価格変更」
[idx]["SSC_PERC"]　→　配列内のidx番目の外注制限の「価格決定率」
[idx]["TMP_NUMBER"]　→　配列内のidx番目の外注制限の「モデルサービス明細セット番号」
[idx]["TMP_LIMIT"]　→　配列内のidx番目の外注制限の「モデルサービス明細制限」
[idx]["TMP_NOLIM"]　→　配列内のidx番目の外注制限の「モデル仕様の制限なし」
[idx]["TMP_PRSCHG"]　→　配列内のidx番目の外注制限の「入力シートの価格変更」
[idx]["TMP_PERC"]　→　配列内のidx番目の外注制限の「価格決定率」
[idx]["CONT_PERC"]　→　配列内のidx番目の外注制限の「価格決定率」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getMemoryComplete

Object getMemoryComplete ()

エラーがない場合に購買発注を保留にする区分を取得します｡

返却値
Object エラーがない場合に購買発注を保留にする区分
getMemoryUnComplete

Object getMemoryUnComplete ()

エラーがある場合に購買発注を保留にする区分を取得します｡

返却値
Object エラーがある場合に購買発注を保留にする区分
getNoAuthority

Object getNoAuthority ()

権限チェックなし区分を取得します｡

返却値
Object 権限チェックなし区分
getNoMessageReq

Object getNoMessageReq ()

メッセージ不要区分を取得します｡

返却値
Object メッセージ不要区分
getNoMessaging

Object getNoMessaging ()

出力決定なし区分を取得します。

返却値
Object 出力決定なし区分
getNoPriceFromPo

Object getNoPriceFromPo ()

最終伝票からの価格転送なし区分を取得します｡。

返却値
Object 最終伝票からの価格転送なし区分
getPartnerList

Object getPartnerList ()

得意先一覧を取得します｡
返却値
Object 得意先一覧

得意先情報オブジェクトの構成は以下のとおりです。
得意先情報
オブジェクト
(Object)
PARTNERDESC 言語別取引先機能テキスト (String)
LANGU 言語キー (String)
BUSPARTNO 取引先の仕入先マスタコード (String)

取得した得意先情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PARTNERDESC"]　→　配列内のidx番目の得意先の「言語別取引先機能テキスト」
[idx]["LANGU"]　→　配列内のidx番目の得意先の「言語キー」
[idx]["BUSPARTNO"]　→　配列内のidx番目の得意先の「取引先の仕入先マスタコード」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPoNumber

Object getPoNumber ()

購買伝票番号を取得します｡

返却値
Object 購買伝票番号
getProfitSegmentList

Object getProfitSegmentList ()

入出庫予定一覧を取得します｡
返却値
Object 入出庫予定一覧

入出庫予定情報オブジェクトの構成は以下のとおりです。
入出庫予定情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号 (String)
SERIAL_NO 勘定設定の連続番号 (String)
FIELDNAME 項目名 (String)
VALUE CO-PA 特性値 (String)

取得した入出庫予定情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の入出庫予定の「購買伝票の明細番号」
[idx]["SERIAL_NO"]　→　配列内のidx番目の入出庫予定の「勘定設定の連続番号」
[idx]["FIELDNAME"]　→　配列内のidx番目の入出庫予定の「項目名」
[idx]["VALUE"]　→　配列内のidx番目の入出庫予定の「CO-PA 特性値」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPurchaseAccountList

Object getPurchaseAccountList ()

勘定設定一覧を取得します｡
返却値
Object 勘定設定一覧

勘定設定情報オブジェクトの構成は以下のとおりです。
勘定設定情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号 (String)
SERIAL_NO 勘定設定の連続番号 (String)
DELETE_IND 削除フラグ：購買伝票勘定設定 (String)
CREAT_DATE レコード登録日 (String)
QUANTITY 数量 (String)
DISTR_PERC 配賦率 % (複数勘定設定) (String)
NET_VALUE BAPI の通貨額 (小数点以下９桁) (String)
GL_ACCOUNT G/L 勘定コード (String)
BUS_AREA 事業領域 (String)
COSTCENTER 原価センタ (String)
SD_DOC 販売管理伝票番号 (String)
ITM_NUMBER 販売伝票明細 (String)
SCHED_LINE 納入日程行 (String)
ASSET_NO 資産番号 (String)
SUB_NUMBER 資産補助番号 (String)
ORDERID 指図番号 (String)
GR_RCPT 受領者 (String)
UNLOAD_PT 荷渡ポイント (String)
CO_AREA 管理領域 (String)
COSTOBJECT 原価対象 (String)
PROFIT_CTR 利益センタ (String)
WBS_ELEMENT WBS 要素 (String)
NETWORK 勘定割当のネットワーク番号 (String)
RL_EST_KEY 不動産管理対象の内部キー (String)
PART_ACCT 取引先勘定コード (String)
CMMT_ITEM 資金予算コード (String)
REC_IND リカバリフラグ (String)
FUNDS_CTR 予算センタ (String)
FUND 会計区分 (String)
FUNC_AREA 機能領域 (String)
REF_DATE 決済の参照日付 (String)
TAX_CODE 消費税コード (String)
TAXJURCODE 税計算管轄コード - 税管轄コード (String)
NOND_ITAX BAPI の通貨額 (小数点以下９桁) (String)
ACTTYPE 活動タイプ (String)
CO_BUSPROC 業務プロセス (String)
RES_DOC 用途指定予算の伝票番号 (String)
RES_ITEM 用途指定予算：伝票明細 (String)
ACTIVITY 作業番号 (String)
GRANT_NBR 補助金 (String)
CMMT_ITEM_LONG 資金予算コード (String)
FUNC_AREA_LONG 機能領域 (String)

取得した勘定設定情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の勘定設定の「購買伝票の明細番号」
[idx]["SERIAL_NO"]　→　配列内のidx番目の勘定設定の「勘定設定の連続番号」
[idx]["DELETE_IND"]　→　配列内のidx番目の勘定設定の「削除フラグ：購買伝票勘定設定」
[idx]["CREAT_DATE"]　→　配列内のidx番目の勘定設定の「レコード登録日」
[idx]["QUANTITY"]　→　配列内のidx番目の勘定設定の「数量」
[idx]["DISTR_PERC"]　→　配列内のidx番目の勘定設定の「配賦率 % (複数勘定設定)」
[idx]["NET_VALUE"]　→　配列内のidx番目の勘定設定の「BAPI の通貨額 (小数点以下９桁)」
[idx]["GL_ACCOUNT"]　→　配列内のidx番目の勘定設定の「G/L 勘定コード」
[idx]["BUS_AREA"]　→　配列内のidx番目の勘定設定の「事業領域」
[idx]["COSTCENTER"]　→　配列内のidx番目の勘定設定の「原価センタ」
[idx]["SD_DOC"]　→　配列内のidx番目の勘定設定の「販売管理伝票番号」
[idx]["ITM_NUMBER"]　→　配列内のidx番目の勘定設定の「販売伝票明細」
[idx]["SCHED_LINE"]　→　配列内のidx番目の勘定設定の「納入日程行」
[idx]["ASSET_NO"]　→　配列内のidx番目の勘定設定の「資産番号」
[idx]["SUB_NUMBER"]　→　配列内のidx番目の勘定設定の「資産補助番号」
[idx]["ORDERID"]　→　配列内のidx番目の勘定設定の「指図番号」
[idx]["GR_RCPT"]　→　配列内のidx番目の勘定設定の「受領者」
[idx]["UNLOAD_PT"]　→　配列内のidx番目の勘定設定の「荷渡ポイント」
[idx]["CO_AREA"]　→　配列内のidx番目の勘定設定の「管理領域」
[idx]["COSTOBJECT"]　→　配列内のidx番目の勘定設定の「原価対象」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の勘定設定の「利益センタ」
[idx]["WBS_ELEMENT"]　→　配列内のidx番目の勘定設定の「WBS 要素」
[idx]["NETWORK"]　→　配列内のidx番目の勘定設定の「勘定割当のネットワーク番号」
[idx]["RL_EST_KEY"]　→　配列内のidx番目の勘定設定の「不動産管理対象の内部キー」
[idx]["PART_ACCT"]　→　配列内のidx番目の勘定設定の「取引先勘定コード」
[idx]["CMMT_ITEM"]　→　配列内のidx番目の勘定設定の「資金予算コード」
[idx]["REC_IND"]　→　配列内のidx番目の勘定設定の「リカバリフラグ」
[idx]["FUNDS_CTR"]　→　配列内のidx番目の勘定設定の「予算センタ」
[idx]["FUND"]　→　配列内のidx番目の勘定設定の「会計区分」
[idx]["FUNC_AREA"]　→　配列内のidx番目の勘定設定の「機能領域」
[idx]["REF_DATE"]　→　配列内のidx番目の勘定設定の「決済の参照日付」
[idx]["TAX_CODE"]　→　配列内のidx番目の勘定設定の「消費税コード」
[idx]["TAXJURCODE"]　→　配列内のidx番目の勘定設定の「税計算管轄コード - 税管轄コード」
[idx]["NOND_ITAX"]　→　配列内のidx番目の勘定設定の「BAPI の通貨額 (小数点以下９桁)」
[idx]["ACTTYPE"]　→　配列内のidx番目の勘定設定の「活動タイプ」
[idx]["CO_BUSPROC"]　→　配列内のidx番目の勘定設定の「業務プロセス」
[idx]["RES_DOC"]　→　配列内のidx番目の勘定設定の「用途指定予算の伝票番号」
[idx]["RES_ITEM"]　→　配列内のidx番目の勘定設定の「用途指定予算：伝票明細」
[idx]["ACTIVITY"]　→　配列内のidx番目の勘定設定の「作業番号」
[idx]["GRANT_NBR"]　→　配列内のidx番目の勘定設定の「補助金」
[idx]["CMMT_ITEM_LONG"]　→　配列内のidx番目の勘定設定の「資金予算コード」
[idx]["FUNC_AREA_LONG"]　→　配列内のidx番目の勘定設定の「機能領域」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPurchaseItemPostList

Object getPurchaseItemPostList ()

明細一覧を取得します｡
返却値
Object 明細一覧

明細情報オブジェクトの構成は以下のとおりです。
明細情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号 (String)
DELETE_IND 購買伝票の削除フラグ (String)
SHORT_TEXT テキスト (短) (String)
MATERIAL 品目コード (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード (長) (今後のリリースで開発) (String)
MATERIAL_GUID 項目 MATERIAL の外部 GUID (今後のリリースで開発) (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (今後のリリースで開発) (String)
EMATERIAL 品目コード (String)
EMATERIAL_EXTERNAL 項目 MATERIAL の品目コード (長) (今後のリリースで開発) (String)
EMATERIAL_GUID 項目 MATERIAL の外部 GUID (今後のリリースで開発) (String)
EMATERIAL_VERSION 項目 MATERIAL のバージョン番号 (今後のリリースで開発) (String)
PLANT プラント (String)
STGE_LOC 保管場所 (String)
TRACKINGNO 購買依頼追跡番号 (String)
MATL_GROUP 品目グループ (String)
INFO_REC 購買情報番号 (String)
VEND_MAT 仕入先が使用している品目コード (String)
QUANTITY 購買発注数量 (String)
PO_UNIT 発注単位 (String)
PO_UNIT_ISO ISO コードによる発注単位 (String)
ORDERPR_UN 購買発注価格単位 (購買管理) (String)
ORDERPR_UN_ISO 購買発注価格単位の ISO コード (String)
CONV_NUM1 購買価格単位から購買発注単位への変換分子 (String)
CONV_DEN1 購買価格単位から購買発注単位への変換分母 (String)
NET_PRICE BAPI の通貨額 (小数点以下９桁) (String)
PRICE_UNIT 価格単位 (String)
GR_PR_TIME 入庫処理日数 (String)
TAX_CODE 消費税コード (String)
BON_GRP1 決済グループ 1（購買） (String)
QUAL_INSP 在庫タイプ (String)
INFO_UPD 区分：購買情報更新 (String)
PRNT_PRICE 価格印刷 (String)
EST_PRICE 区分：概算価格 (String)
REMINDER1 第一回催促状/督促状の日数 (String)
REMINDER2 第二回催促状/督促状の日数 (String)
REMINDER3 第三回催促状/督促状の日数 (String)
OVER_DLV_TOL 過剰納入許容範囲 (String)
UNLIMITED_DLV 区分：無制限過剰納入可能 (String)
UNDER_DLV_TOL 不足納入許容範囲リミット (String)
VAL_TYPE 評価タイプ (String)
NO_MORE_GR 納入完了 区分 (String)
FINAL_INV 請求書処理完了区分 (String)
ITEM_CAT 購買伝票の明細カテゴリ (String)
ACCTASSCAT 勘定設定カテゴリ (String)
DISTRIB 複数勘定設定の配賦区分 (String)
PART_INV 一部請求区分 (String)
GR_IND 入庫区分 (String)
GR_NON_VAL 非評価入庫 (String)
IR_IND 請求書受領区分 (String)
FREE_ITEM 無償明細 (String)
GR_BASEDIV 区分：入庫基準の請求書照合 (String)
ACKN_REQD 購買発注請書依頼 (String)
ACKNOWL_NO 購買発注請書番号 (String)
AGREEMENT 購買契約番号 (String)
AGMT_ITEM 購買契約の明細番号 (String)
SHIPPING 出荷指示 (String)
CUSTOMER 得意先 (String)
COND_GROUP 仕入先条件グループ (String)
NO_DISCT 現金値引対象外明細 (String)
PLAN_DEL 予定納入日数 (String)
NET_WEIGHT 正味重量 (String)
WEIGHTUNIT 重量単位 (String)
WEIGHTUNIT_ISO 重量単位の ISO コード (String)
TAXJURCODE 税計算管轄コード - 税管轄コード (String)
CTRL_KEY 調達における品質管理の管理キー (String)
CONF_CTRL 確認管理キー (String)
REV_LEV 改訂レベル (String)
FUND 会計区分 (String)
FUNDS_CTR 予算センタ (String)
CMMT_ITEM 資金予算コード (String)
PRICEDATE 価格設定日カテゴリ (価格設定日管理) (String)
PRICE_DATE 価格設定日 (String)
GROSS_WT 総重量 (String)
VOLUME 容積 (String)
VOLUMEUNIT 容積単位 (String)
VOLUMEUNIT_ISO ISO コードでの容積単位 (String)
INCOTERMS1 インコタームズ (1) (String)
INCOTERMS2 インコタームズ 2 (String)
PRE_VENDOR 製造元/販売元 (String)
VEND_PART 仕入先部門 (String)
HL_ITEM 購買伝票中の上位明細 (String)
GR_TO_DATE 納入最終期限 (String)
SUPP_VENDOR 供給仕入先/仕入入庫 (String)
SC_VENDOR 外注仕入先 (String)
KANBAN_IND かんばん区分 (String)
ERS ERS（入庫/請求自動決済） (String)
R_PROMO プロモーション (String)
POINTS リベートポイント数 (String)
POINT_UNIT ポイント単位 (String)
POINT_UNIT_ISO ポイント単位の ISO コード (String)
SEASON 季節カテゴリ (String)
SEASON_YR シーズン年度 (String)
BON_GRP2 決済グループ 2 (リベート決済、購買) (String)
BON_GRP3 決済グループ 3 (リベート決済、購買) (String)
SETT_ITEM リベート (期末) 決済対象の明細 (String)
MINREMLIFE 最低有効期間残 (String)
RFQ_NO 見積依頼番号 (String)
RFQ_ITEM 見積依頼明細番号 (String)
PREQ_NO 購買依頼番号 (String)
PREQ_ITEM 購買依頼の明細番号 (String)
REF_DOC 参照伝票番号 (String)
REF_ITEM 参照伝票の明細 (String)
SI_CAT 補助明細カテゴリ、購買伝票 (String)
RET_ITEM 返品明細 (String)
AT_RELEV 割当テーブル関連 (String)
ORDER_REASON 発注理由 (String)
BRAS_NBM Brazilian NCM Code (String)
MATL_USAGE 品目の用途 (String)
MAT_ORIGIN 品目の原産地 (String)
IN_HOUSE 内部生産 (String)
INDUS3 品目 CFOP カテゴリ (String)
INF_INDEX インフレーション指数 (String)
UNTIL_DATE インフレーション指数日付 (String)
DELIV_COMPL 出荷完了 区分 (String)
PART_DELIV 明細レベルでの分割納入 (在庫転送) (String)
SHIP_BLOCKED SD 出荷伝票の明細ブロック (String)
PREQ_NAME 購買依頼者名/要求者名 (String)
PERIOD_IND_EXPIRATION_DATE 有効期間期限日の期間区分 (String)
INT_OBJ_NO 選定 (内部オブジェクト番号) (String)
PCKG_NO パッケージ番号 (String)
BATCH ロット番号 (String)
VENDRBATCH 仕入先ロット番号 (String)
CALCTYPE 価格設定タイプ (String)
GRANT_NBR 補助金 (String)
CMMT_ITEM_LONG 資金予算コード (String)
FUNC_AREA_LONG 機能領域 (String)
NO_ROUNDING 区分：購買発注明細での非表示丸め (String)
PO_PRICE 区分：価格採用：1 = 総額、2 = 正味額 (String)
SUPPL_STLOC 出庫保管場所：在庫転送オーダー (String)

取得した明細情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の明細の「購買伝票の明細番号」
[idx]["DELETE_IND"]　→　配列内のidx番目の明細の「購買伝票の削除フラグ」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の明細の「テキスト (短)」
[idx]["MATERIAL"]　→　配列内のidx番目の明細の「品目コード」
[idx]["MATERIAL_EXTERNAL"] 　→　配列内のidx番目の明細の「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["MATERIAL_GUID"] 　→　配列内のidx番目の明細の「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["MATERIAL_VERSION"] 　→　配列内のidx番目の明細の「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」
[idx]["EMATERIAL"]　→　配列内のidx番目の明細の「品目コード」
[idx]["EMATERIAL_EXTERNAL"] 　→　配列内のidx番目の明細の「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["EMATERIAL_GUID"] 　→　配列内のidx番目の明細の「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["EMATERIAL_VERSION"] 　→　配列内のidx番目の明細の「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」
[idx]["PLANT"]　→　配列内のidx番目の明細の「プラント」
[idx]["STGE_LOC"]　→　配列内のidx番目の明細の「保管場所」
[idx]["TRACKINGNO"]　→　配列内のidx番目の明細の「購買依頼追跡番号」
[idx]["MATL_GROUP"]　→　配列内のidx番目の明細の「品目グループ」
[idx]["INFO_REC"]　→　配列内のidx番目の明細の「購買情報番号」
[idx]["VEND_MAT"]　→　配列内のidx番目の明細の「仕入先が使用している品目コード」
[idx]["QUANTITY"]　→　配列内のidx番目の明細の「購買発注数量」
[idx]["PO_UNIT"]　→　配列内のidx番目の明細の「発注単位」
[idx]["PO_UNIT_ISO"]　→　配列内のidx番目の明細の「ISO コードによる発注単位」
[idx]["ORDERPR_UN"]　→　配列内のidx番目の明細の「購買発注価格単位 (購買管理)」
[idx]["ORDERPR_UN_ISO"]　→　配列内のidx番目の明細の「購買発注価格単位の ISO コード」
[idx]["CONV_NUM1"]　→　配列内のidx番目の明細の「購買価格単位から購買発注単位への変換分子」
[idx]["CONV_DEN1"]　→　配列内のidx番目の明細の「購買価格単位から購買発注単位への変換分母」
[idx]["NET_PRICE"]　→　配列内のidx番目の明細の「BAPI の通貨額 (小数点以下９桁)」
[idx]["PRICE_UNIT"]　→　配列内のidx番目の明細の「価格単位」
[idx]["GR_PR_TIME"]　→　配列内のidx番目の明細の「入庫処理日数」
[idx]["TAX_CODE"]　→　配列内のidx番目の明細の「消費税コード」
[idx]["BON_GRP1"]　→　配列内のidx番目の明細の「決済グループ 1（購買）」
[idx]["QUAL_INSP"]　→　配列内のidx番目の明細の「在庫タイプ」
[idx]["INFO_UPD"]　→　配列内のidx番目の明細の「区分：購買情報更新」
[idx]["PRNT_PRICE"]　→　配列内のidx番目の明細の「価格印刷」
[idx]["EST_PRICE"]　→　配列内のidx番目の明細の「区分：概算価格」
[idx]["REMINDER1"]　→　配列内のidx番目の明細の「第一回催促状/督促状の日数」
[idx]["REMINDER2"]　→　配列内のidx番目の明細の「第二回催促状/督促状の日数」
[idx]["REMINDER3"]　→　配列内のidx番目の明細の「第三回催促状/督促状の日数」
[idx]["OVER_DLV_TOL"]　→　配列内のidx番目の明細の「過剰納入許容範囲」
[idx]["UNLIMITED_DLV"]　→　配列内のidx番目の明細の「区分：無制限過剰納入可能」
[idx]["UNDER_DLV_TOL"]　→　配列内のidx番目の明細の「不足納入許容範囲リミット」
[idx]["VAL_TYPE"]　→　配列内のidx番目の明細の「評価タイプ」
[idx]["NO_MORE_GR"]　→　配列内のidx番目の明細の「納入完了 区分」
[idx]["FINAL_INV"]　→　配列内のidx番目の明細の「請求書処理完了区分」
[idx]["ITEM_CAT"]　→　配列内のidx番目の明細の「購買伝票の明細カテゴリ」
[idx]["ACCTASSCAT"]　→　配列内のidx番目の明細の「勘定設定カテゴリ」
[idx]["DISTRIB"]　→　配列内のidx番目の明細の「複数勘定設定の配賦区分」
[idx]["PART_INV"]　→　配列内のidx番目の明細の「一部請求区分」
[idx]["GR_IND"]　→　配列内のidx番目の明細の「入庫区分」
[idx]["GR_NON_VAL"]　→　配列内のidx番目の明細の「非評価入庫」
[idx]["IR_IND"]　→　配列内のidx番目の明細の「請求書受領区分」
[idx]["FREE_ITEM"]　→　配列内のidx番目の明細の「無償明細」
[idx]["GR_BASEDIV"]　→　配列内のidx番目の明細の「区分：入庫基準の請求書照合」
[idx]["ACKN_REQD"]　→　配列内のidx番目の明細の「購買発注請書依頼」
[idx]["ACKNOWL_NO"]　→　配列内のidx番目の明細の「購買発注請書番号」
[idx]["AGREEMENT"]　→　配列内のidx番目の明細の「購買契約番号」
[idx]["AGMT_ITEM"]　→　配列内のidx番目の明細の「購買契約の明細番号」
[idx]["SHIPPING"]　→　配列内のidx番目の明細の「出荷指示」
[idx]["CUSTOMER"]　→　配列内のidx番目の明細の「得意先」
[idx]["COND_GROUP"]　→　配列内のidx番目の明細の「仕入先条件グループ」
[idx]["NO_DISCT"]　→　配列内のidx番目の明細の「現金値引対象外明細」
[idx]["PLAN_DEL"]　→　配列内のidx番目の明細の「予定納入日数」
[idx]["NET_WEIGHT"]　→　配列内のidx番目の明細の「正味重量」
[idx]["WEIGHTUNIT"]　→　配列内のidx番目の明細の「重量単位」
[idx]["WEIGHTUNIT_ISO"]　→　配列内のidx番目の明細の「重量単位の ISO コード」
[idx]["TAXJURCODE"]　→　配列内のidx番目の明細の「税計算管轄コード - 税管轄コード」
[idx]["CTRL_KEY"]　→　配列内のidx番目の明細の「調達における品質管理の管理キー」
[idx]["CONF_CTRL"]　→　配列内のidx番目の明細の「確認管理キー」
[idx]["REV_LEV"]　→　配列内のidx番目の明細の「改訂レベル」
[idx]["FUND"]　→　配列内のidx番目の明細の「会計区分」
[idx]["FUNDS_CTR"]　→　配列内のidx番目の明細の「予算センタ」
[idx]["CMMT_ITEM"]　→　配列内のidx番目の明細の「資金予算コード」
[idx]["PRICEDATE"]　→　配列内のidx番目の明細の「価格設定日カテゴリ (価格設定日管理)」
[idx]["PRICE_DATE"]　→　配列内のidx番目の明細の「価格設定日」
[idx]["GROSS_WT"]　→　配列内のidx番目の明細の「総重量」
[idx]["VOLUME"]　→　配列内のidx番目の明細の「容積」
[idx]["VOLUMEUNIT"]　→　配列内のidx番目の明細の「容積単位」
[idx]["VOLUMEUNIT_ISO"]　→　配列内のidx番目の明細の「ISO コードでの容積単位」
[idx]["INCOTERMS1"]　→　配列内のidx番目の明細の「インコタームズ (1)」
[idx]["INCOTERMS2"]　→　配列内のidx番目の明細の「インコタームズ 2」
[idx]["PRE_VENDOR"]　→　配列内のidx番目の明細の「製造元/販売元」
[idx]["VEND_PART"]　→　配列内のidx番目の明細の「仕入先部門」
[idx]["HL_ITEM"]　→　配列内のidx番目の明細の「購買伝票中の上位明細」
[idx]["GR_TO_DATE"]　→　配列内のidx番目の明細の「納入最終期限」
[idx]["SUPP_VENDOR"]　→　配列内のidx番目の明細の「供給仕入先/仕入入庫」
[idx]["SC_VENDOR"]　→　配列内のidx番目の明細の「外注仕入先」
[idx]["KANBAN_IND"]　→　配列内のidx番目の明細の「かんばん区分」
[idx]["ERS"]　→　配列内のidx番目の明細の「ERS（入庫/請求自動決済）」
[idx]["R_PROMO"]　→　配列内のidx番目の明細の「プロモーション」
[idx]["POINTS"]　→　配列内のidx番目の明細の「リベートポイント数」
[idx]["POINT_UNIT"]　→　配列内のidx番目の明細の「ポイント単位」
[idx]["POINT_UNIT_ISO"]　→　配列内のidx番目の明細の「ポイント単位の ISO コード」
[idx]["SEASON"]　→　配列内のidx番目の明細の「季節カテゴリ」
[idx]["SEASON_YR"]　→　配列内のidx番目の明細の「シーズン年度」
[idx]["BON_GRP2"]　→　配列内のidx番目の明細の「決済グループ 2 (リベート決済、購買)」
[idx]["BON_GRP3"]　→　配列内のidx番目の明細の「決済グループ 3 (リベート決済、購買)」
[idx]["SETT_ITEM"]　→　配列内のidx番目の明細の「リベート (期末) 決済対象の明細」
[idx]["MINREMLIFE"]　→　配列内のidx番目の明細の「最低有効期間残」
[idx]["RFQ_NO"]　→　配列内のidx番目の明細の「見積依頼番号」
[idx]["RFQ_ITEM"]　→　配列内のidx番目の明細の「見積依頼明細番号」
[idx]["PREQ_NO"]　→　配列内のidx番目の明細の「購買依頼番号」
[idx]["PREQ_ITEM"]　→　配列内のidx番目の明細の「購買依頼の明細番号」
[idx]["REF_DOC"]　→　配列内のidx番目の明細の「参照伝票番号」
[idx]["REF_ITEM"]　→　配列内のidx番目の明細の「参照伝票の明細」
[idx]["SI_CAT"]　→　配列内のidx番目の明細の「補助明細カテゴリ、購買伝票」
[idx]["RET_ITEM"]　→　配列内のidx番目の明細の「返品明細」
[idx]["AT_RELEV"]　→　配列内のidx番目の明細の「割当テーブル関連」
[idx]["ORDER_REASON"]　→　配列内のidx番目の明細の「発注理由」
[idx]["BRAS_NBM"]　→　配列内のidx番目の明細の「Brazilian NCM Code」
[idx]["MATL_USAGE"]　→　配列内のidx番目の明細の「品目の用途」
[idx]["MAT_ORIGIN"]　→　配列内のidx番目の明細の「品目の原産地」
[idx]["IN_HOUSE"]　→　配列内のidx番目の明細の「内部生産」
[idx]["INDUS3"]　→　配列内のidx番目の明細の「品目 CFOP カテゴリ」
[idx]["INF_INDEX"]　→　配列内のidx番目の明細の「インフレーション指数」
[idx]["UNTIL_DATE"]　→　配列内のidx番目の明細の「インフレーション指数日付」
[idx]["DELIV_COMPL"]　→　配列内のidx番目の明細の「出荷完了 区分」
[idx]["PART_DELIV"]　→　配列内のidx番目の明細の「明細レベルでの分割納入 (在庫転送)」
[idx]["SHIP_BLOCKED"]　→　配列内のidx番目の明細の「SD 出荷伝票の明細ブロック」
[idx]["PREQ_NAME"]　→　配列内のidx番目の明細の「購買依頼者名/要求者名」
[idx]["PERIOD_IND_EXPIRATION_DATE"] 　→　配列内のidx番目の明細の「有効期間期限日の期間区分」
[idx]["INT_OBJ_NO"]　→　配列内のidx番目の明細の「選定 (内部オブジェクト番号)」
[idx]["PCKG_NO"]　→　配列内のidx番目の明細の「パッケージ番号」
[idx]["BATCH"]　→　配列内のidx番目の明細の「ロット番号」
[idx]["VENDRBATCH"]　→　配列内のidx番目の明細の「仕入先ロット番号」
[idx]["CALCTYPE"]　→　配列内のidx番目の明細の「価格設定タイプ」
[idx]["GRANT_NBR"]　→　配列内のidx番目の明細の「補助金」
[idx]["CMMT_ITEM_LONG"]　→　配列内のidx番目の明細の「資金予算コード」
[idx]["FUNC_AREA_LONG"]　→　配列内のidx番目の明細の「機能領域」
[idx]["NO_ROUNDING"]　→　配列内のidx番目の明細の「区分：購買発注明細での非表示丸め」
[idx]["PO_PRICE"]　→　配列内のidx番目の明細の「区分：価格採用：1 = 総額、2 = 正味額」
[idx]["SUPPL_STLOC"]　→　配列内のidx番目の明細の「出庫保管場所：在庫転送オーダー」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPurchaseScheduleList

Object getPurchaseScheduleList ()

納入日程一覧を取得します｡
返却値
Object 納入日程一覧

納入日程情報オブジェクトの構成は以下のとおりです。
納入日程情報
オブジェクト
(Object)
PO_ITEM 購買伝票の明細番号 (String)
SCHED_LINE 納入日程行 (String)
DEL_DATCAT_EXT 納入期日カテゴリ (String)
DELIVERY_DATE 納入期日 (String)
QUANTITY 計画数量 (String)
DELIV_TIME 納入期日における指定時間 (String)
STAT_DATE 統計的納入期日 (String)
PREQ_NO 購買依頼番号 (String)
PREQ_ITEM 購買依頼の明細番号 (String)
PO_DATE 納入日程の購買発注日付 (String)
ROUTESCHED 輸送経路計画 (String)
MS_DATE 品目利用可能日 (String)
MS_TIME 品目供給ステージ (現地時刻：プラント参照) (String)
LOAD_DATE 積載日付 (String)
LOAD_TIME 積載時刻 (現地時間：出荷ポイント) (String)
TP_DATE 輸送計画日付 (String)
TP_TIME 輸送計画 - 時間 (現地時間/出荷ポイント参照) (String)
GI_DATE 出庫日付 (String)
GI_TIME 出庫時刻 (現地時間 - プラント参照) (String)
DELETE_IND 購買伝票の削除フラグ (String)

取得した納入日程情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PO_ITEM"]　→　配列内のidx番目の納入日程の「購買伝票の明細番号」
[idx]["SCHED_LINE"]　→　配列内のidx番目の納入日程の「納入日程行」
[idx]["DEL_DATCAT_EXT"]　→　配列内のidx番目の納入日程の「納入期日カテゴリ」
[idx]["DELIVERY_DATE"]　→　配列内のidx番目の納入日程の「納入期日」
[idx]["QUANTITY"]　→　配列内のidx番目の納入日程の「計画数量」
[idx]["DELIV_TIME"]　→　配列内のidx番目の納入日程の「納入期日における指定時間」
[idx]["STAT_DATE"]　→　配列内のidx番目の納入日程の「統計的納入期日」
[idx]["PREQ_NO"]　→　配列内のidx番目の納入日程の「購買依頼番号」
[idx]["PREQ_ITEM"]　→　配列内のidx番目の納入日程の「購買依頼の明細番号」
[idx]["PO_DATE"]　→　配列内のidx番目の納入日程の「納入日程の購買発注日付」
[idx]["ROUTESCHED"]　→　配列内のidx番目の納入日程の「輸送経路計画」
[idx]["MS_DATE"]　→　配列内のidx番目の納入日程の「品目利用可能日」
[idx]["MS_TIME"]　→　配列内のidx番目の納入日程の「品目供給ステージ (現地時刻：プラント参照)」
[idx]["LOAD_DATE"]　→　配列内のidx番目の納入日程の「積載日付」
[idx]["LOAD_TIME"]　→　配列内のidx番目の納入日程の「積載時刻 (現地時間：出荷ポイント)」
[idx]["TP_DATE"]　→　配列内のidx番目の納入日程の「輸送計画日付」
[idx]["TP_TIME"] 　→　配列内のidx番目の納入日程の「輸送計画 - 時間 (現地時間/出荷ポイント参照)」
[idx]["GI_DATE"]　→　配列内のidx番目の納入日程の「出庫日付」
[idx]["GI_TIME"]　→　配列内のidx番目の納入日程の「出庫時刻 (現地時間 - プラント参照)」
[idx]["DELETE_IND"]　→　配列内のidx番目の納入日程の「購買伝票の削除フラグ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getSupplierInfo

Object getSupplierInfo ()

仕入先住所を取得します｡
返却値
Object 仕入先住所

仕入先住所情報オブジェクトの構成は以下のとおりです。
仕入先住所情報
オブジェクト
(Object)
PO_NUMBER 購買伝票番号 (String)
ADDR_NO アドレス番号 (String)
FORMOFADDR 敬称テキスト (String)
NAME 名称 1 (String)
NAME_2 名称 2 (String)
NAME_3 名称 3 (String)
NAME_4 名称 4 (String)
C_O_NAME 気付 (String)
CITY 市区町村 (String)
DISTRICT 所在地 (String)
CITY_NO 市区町村/地名ファイルの市区町村コード (String)
POSTL_COD1 市区町村の郵便番号 (String)
POSTL_COD2 私書箱郵便番号 (String)
POSTL_COD3 会社郵便番号 (大規模なユーザ用) (String)
PO_BOX 私書箱 (String)
PO_BOX_CIT 私書箱住所 (String)
DELIV_DIS 郵便配達地域 (String)
STREET 地名 (String)
STREET_NO 市区町村/地名ファイルの地名コード (String)
STR_ABBR 地名の略称 (例：スペイン) (String)
HOUSE_NO 番地-号 (String)
STR_SUPPL1 地名 2 (String)
STR_SUPPL2 地名 3 (String)
LOCATION 地名 5 (String)
BUILDING 旧：建物 (番号または略称) (String)
FLOOR 建物の階 (String)
ROOM_NO 部屋/アパート番号 (String)
COUNTRY 国コード (String)
LANGU 言語キー (String)
REGION 地域 (都道府県) (String)
SORT1 検索条件 1 (String)
SORT2 検索条件 2 (String)
TIME_ZONE アドレスタイムゾーン (String)
TAXJURCODE 税管轄コード (String)
ADR_NOTES 住所注記 (String)
COMM_TYPE 通信方法 (キー) (アドレス管理) (String)
TEL1_NUMBR 第一電話番号：ダイヤルコード + 番号 (String)
TEL1_EXT 第 1 電話番号：内線 (String)
FAX_NUMBER 第一 FAX 番号：ダイヤルコード + 番号 (String)
FAX_EXTENS 第一 FAX 番号：内線 (String)
STREET_LNG 地名 (String)
DISTRCT_NO 市区町村/地名ファイルの所在地コード (String)
CHCKSTATUS 市区町村ファイルテストステータス (String)
PBOXCIT_NO 市区町村私書箱コード (市ファイル) (String)
TRANSPZONE 商品の納入区域 (String)
HOUSE_NO2 番地補足 (String)
E_MAIL 電子メールアドレス (String)
STR_SUPPL3 地名 4 (String)
TITLE タイトル (敬称) (String)
COUNTRYISO ISO 国コード (String)
LANGU_ISO ISO 639 準拠の言語 (String)
BUILD_LONG 建物 (番号またはコード) (String)
REGIOGROUP 地域構造グループ化 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getTestRun

Object getTestRun ()

テスト区分を取得します。

返却値
Object テスト区分
getVersions

Object getVersions ()

バージョン管理を取得します｡
返却値
Object バージョン管理

バージョン管理情報オブジェクトの構成は以下のとおりです。
バージョン管理情報
オブジェクト
(Object)
POST_DATE バージョンの転記日付 (String)
COMPLETED ステータス ""バージョン完了済"" (String)
REASON 変更理由 (String)
DESCRIPTION バージョンテキスト（長） (String)
REQ_BY 変更を依頼した従業員 (String)
REQ_BY_EXT バージョンの外部変更番号 (String)
ACTIVITY 処理タイプ - R/3 Enterprise で使用不可能 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

setMemoryComplete

void setMemoryComplete (String value)

エラーがない場合に購買発注を保留する区分を設定します｡を設定します｡
パラメータ
value String エラーがない場合に購買発注を保留する区分を設定します｡
返却値
void
setMemoryUnComplete

void setMemoryUnComplete (String value)

エラーがある場合に購買発注を保留する区分を設定します｡を設定します｡
パラメータ
value String エラーがある場合に購買発注を保留する区分を設定します｡
返却値
void
setNoAuthority

void setNoAuthority (String value)

権限チェックなし区分を設定します｡を設定します｡
パラメータ
value String 権限チェックなし区分を設定します｡
返却値
void
setNoMessage

void setNoMessage (String value)

出力決定なし区分に購買発注を保留する区分を設定します｡を設定します｡
パラメータ
value String 出力決定なし区分に購買発注を保留する区分を設定します｡
返却値
void
setNoMessageReq

void setNoMessageReq (String value)

メッセージ不要区分を設定します｡を設定します｡
パラメータ
value String メッセージ不要区分を設定します｡
返却値
void
setNoPriceFromPo

void setNoPriceFromPo (String value)

最終伝票からの価格転送なし区分を設定します｡を設定します｡
パラメータ
value String 最終伝票からの価格転送なし区分を設定します｡
返却値
void
setPoNumber

void setPoNumber (String value)

購買伝票番号を設定します｡
パラメータ
value String 購買伝票番号
返却値
void
setStrParam

void setStrParam (String paramStr ,String paramName ,String value)

構造型の項目に値をセットします。
パラメータ
paramStr | String | 構造名
paramName | String | 項目名
value | String | セットする値
返却値
void
setTblParam

void setTblParam (String paramTable ,String paramName ,String value ,int index)

テーブル型の項目に値をセットします。
パラメータ
paramTable | String | テーブル名
paramName | String | 項目名
value | String | セットする値
index | int | レコード番号
返却値
void
setTestRun

void setTestRun (String value)

テスト区分を設定します｡
パラメータ
value String テスト区分
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 PurchaseReleaseController オブジェクト

伝票承認コントローラクラス。

機能は以下の通り
  • 伝票を承認します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
PurchaseReleaseController (String purchaseorder ,String poRelCode ,String useExceptions)
コンストラクタ｡
PurchaseReleaseController (String purchaseorder ,String poRelCode ,String useExceptions)
コンストラクタ。
PurchaseReleaseController (String purchaseorder ,String poRelCode ,String useExceptions ,ConnectionManager connectionManager)
コンストラクタ。
PurchaseReleaseController (String purchaseorder ,String poRelCode ,String useExceptions ,SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより伝票の承認処理を実行します。
String | getBapiReturnErrMessage () ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage () プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。
Object | getRelIndicatorNew () 伝票承認の新規承認区分を取得します。
Object | getRelStatusNew () 伝票承認の新承認状況を取得します。
Object | getRetCode () リターン値、ABAP 命令後のリターン値を取得します。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
PurchaseReleaseController

PurchaseReleaseController (String purchaseorder ,String poRelCode ,String useExceptions)
コンストラクタ｡
パラメータ
purchaseorder | String | 購買発注番号
poRelCode | String | 承認コード
useExceptions | String | 例外メッセージ設定とエラーメッセージ出力
PurchaseReleaseController

PurchaseReleaseController (String purchaseorder ,String poRelCode ,String useExceptions)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
purchaseorder | String | 購買発注番号
poRelCode | String | 承認コード
useExceptions | String | 例外メッセージ設定とエラーメッセージ出力
PurchaseReleaseController

PurchaseReleaseController (String purchaseorder ,String poRelCode ,String useExceptions ,ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の更新処理を実行することができます。
なお、PurchaseReleaseController#executeBapi()実行後に 必ずConnectionManager#commit()またはConnectionManager#rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

【注意】このAPIが使用する標準のBAPI(BAPI_PO_RELEASE)では、BAPI実行時にコミット処理が実行されます。 つまり、PurchaseReleaseController#executeBapi()実行後に ここまでのコネクションマネージャーで実行したすべての処理がコミットされます。
※ただし、コネクションはリリースされませんので、リリースされるようにConnectionManager#commit()または ConnectionManager#rollback()を実行してください。
この振る舞いを変更するには、BAPI自体をカスタマイズする必要があります。
パラメータ
purchaseorder | String | 購買発注番号
poRelCode | String | 承認コード
useExceptions | String | 例外メッセージ設定とエラーメッセージ出力
connectionManager | ConnectionManager | コネクションマネージャー
PurchaseReleaseController

PurchaseReleaseController (String purchaseorder ,String poRelCode ,String useExceptions ,SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
purchaseorder | String | 購買発注番号
poRelCode | String | 承認コード
useExceptions | String | 例外メッセージ設定とエラーメッセージ出力
sapClient | SapClient | Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより伝票の承認処理を実行します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getBapiReturnErrMessage

String getBapiReturnErrMessage ()

ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡
返却値
String BAPI実行結果エラーとなった全てのメッセージ情報
getBapiReturnMessage

String getBapiReturnMessage ()

プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡
返却値
String プロパティファイルでオートコミット条件に一致したType情報のメッセージ情報
getRelIndicatorNew

Object getRelIndicatorNew ()

伝票承認の新規承認区分を取得します。

返却値
Object 新規承認区分
getRelStatusNew

Object getRelStatusNew ()

伝票承認の新承認状況を取得します。

返却値
Object 新承認状況
getRetCode

Object getRetCode ()

リターン値、ABAP 命令後のリターン値を取得します。

返却値
Object リターン値、ABAP 命令後のリターン値
(成功時の返却値は String になります。)

(失敗時)　エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1:　認証系システムエラー
2:　認証系アプリケーションエラー
3:　汎用系システムエラー
4:　汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 PurchaseResetReleaseController オブジェクト

伝票承認取消コントローラクラス。

機能は以下の通り
  • 伝票承認取消をします。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
PurchaseResetReleaseController (String purchaseorder ,String poRelCode ,String useExceptions)
コンストラクタ｡
PurchaseResetReleaseController (String purchaseorder ,String poRelCode ,String useExceptions)
コンストラクタ。
PurchaseResetReleaseController (String purchaseorder ,String poRelCode ,String useExceptions ,ConnectionManager connectionManager)
コンストラクタ。
PurchaseResetReleaseController (String purchaseorder ,String poRelCode ,String useExceptions ,SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより伝票の承認取消処理を実行します。
String | getBapiReturnErrMessage () ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage () プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。
Object | getRelIndicatorNew () 伝票承認取消の前回承認区分に値を取得します。
Object | getRelStatusNew () 伝票承認取消の前回承認状況に値を取得します。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
PurchaseResetReleaseController

PurchaseResetReleaseController (String purchaseorder ,String poRelCode ,String useExceptions)
コンストラクタ｡
パラメータ
purchaseorder | String | 購買発注番号
poRelCode | String | 承認コード
useExceptions | String | 例外メッセージ設定とエラーメッセージ出力
PurchaseResetReleaseController

PurchaseResetReleaseController (String purchaseorder ,String poRelCode ,String useExceptions)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
purchaseorder | String | 購買発注番号
poRelCode | String | 承認コード
useExceptions | String | 例外メッセージ設定とエラーメッセージ出力
PurchaseResetReleaseController

PurchaseResetReleaseController (String purchaseorder ,String poRelCode ,String useExceptions ,ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の更新処理を実行することができます。
なお、PurchaseReleaseController#executeBapi()実行後に 必ずConnectionManager#commit()またはConnectionManager#rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

【注意】このAPIが使用する標準のBAPI(BAPI_PO_RELEASE)では、BAPI実行時にコミット処理が実行されます。 つまり、PurchaseReleaseController#executeBapi()実行後に ここまでのコネクションマネージャーで実行したすべての処理がコミットされます。
※ただし、コネクションはリリースされませんので、リリースされるようにConnectionManager#commit()または ConnectionManager#rollback()を実行してください。
この振る舞いを変更するには、BAPI自体をカスタマイズする必要があります。
パラメータ
purchaseorder | String | 購買発注番号
poRelCode | String | 承認コード
useExceptions | String | 例外メッセージ設定とエラーメッセージ出力
connectionManager | ConnectionManager | コネクションマネージャー
PurchaseResetReleaseController

PurchaseResetReleaseController (String purchaseorder ,String poRelCode ,String useExceptions ,SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
purchaseorder | String | 購買発注番号
poRelCode | String | 承認コード
useExceptions | String | 例外メッセージ設定とエラーメッセージ出力
sapClient | SapClient | Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより伝票の承認取消処理を実行します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
7： 購買発注システムエラー
8： 購買発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getBapiReturnErrMessage

String getBapiReturnErrMessage ()

ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡
返却値
String BAPI実行結果エラーとなった全てのメッセージ情報
getBapiReturnMessage

String getBapiReturnMessage ()

プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡
返却値
String プロパティファイルでオートコミット条件に一致したType情報のメッセージ情報
getRelIndicatorNew

Object getRelIndicatorNew ()

伝票承認取消の前回承認区分に値を取得します。

返却値
Object 前回承認区分
getRelStatusNew

Object getRelStatusNew ()

伝票承認取消の前回承認状況に値を取得します。

返却値
Object 前回承認状況
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 QuotationCreateFromData2Controller オブジェクト

見積伝票登録コントローラクラス。

機能は以下の通り
  • 見積伝票を登録します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
QuotationCreateFromData2Controller ()
コンストラクタ｡
QuotationCreateFromData2Controller (ConnectionManager connectionManager)
コンストラクタ。
QuotationCreateFromData2Controller (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより見積伝票を登録します。
String | getBapiReturnErrMessage () ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage () プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。
Object | getBinaryRelationshiptype () バイナリ関連タイプ (専用)を取得します。
Object | getConvert () 変換: 取引先機能 + 受注伝票タイプを取得します。
Array | getExtensionInList () VBAK、VBAP、VBEP のカスタマ拡張を取得します。
Object | getIntNumberAssignment () 明細番号内部採番を取得します。
Object | getLogicSwitch () 内部制御パラメータを取得します。
Array | getPartnerAddressesList () アドレス (組織/会社) 用 BAPI 参照構造を取得します。
Array | getQuotationCfgsBlobList () 選定: BLOB 内部データ (SCE)を取得します。
Array | getQuotationCfgsInstList () 選定: インスタンスを取得します。
Array | getQuotationCfgsPartOfList () 選定: 部分設定を取得します。
Array | getQuotationCfgsRefInstList () 選定: 参照明細/インスタンスを取得します。
Array | getQuotationCfgsRefList () 選定: 参照データを取得します。
Array | getQuotationCfgsValueList () 選定: 特性値を取得します。
Array | getQuotationCfgsVkList () 選定: バリアント条件キーを取得します。
Array | getQuotationConditionsInList () 条件を取得します。
Array | getQuotationConditionsInXList () 受注における条件更新の通信項目を取得します。
Object | getQuotationHeaderIn () 見積伝票ヘッダデータを取得します。
Object | getQuotationHeaderInX () ヘッダデータチェックボックスを取得します。
Array | getQuotationItemsInList () 明細データを取得します。
Array | getQuotationItemsInXList () 明細データチェックボックスを取得します。
Array | getQuotationKeysList () 参照キーの出力を取得します。
Array | getQuotationPartnersList () 伝票取引先を取得します。
Array | getQuotationSchedulesInList () 納入日程行を取得します。
Array | getQuotationSchedulesInXList () 納入日程行チェックボックスを取得します。
Array | getQuotationTextList () テキストを取得します。
Object | getSalesdocument () 販売管理伝票番号を取得します。
Object | getSalesdocumentin () 販売管理伝票番号を取得します。
Object | getSender () 論理システム - 送信者を取得します。
Object | getTestrun () テスト実行を取得します。
void | setBehaveWhenError (Object value) エラー処理を設定します｡
void | setBinaryRelationshiptype (Object value) バイナリ関連タイプ (専用)を設定します｡
void | setConvert (Object value) 取引先機能/受注伝票タイプの変換を設定します｡
void | setIntNumberAssignment (Object value) 明細番号内部採番を設定します｡
void | setSalesdocumentin (Object value) 見積伝票番号を設定します｡
void | setStrParam (String paramStr ,String paramName ,Object value) 構造型の項目に値をセットします。
void | setTblParam (String paramTable ,String paramName ,Object value ,int index) テーブル型の項目に値をセットします。
void | setTestrun (Object value) テスト実行を設定します｡
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
QuotationCreateFromData2Controller

QuotationCreateFromData2Controller ()
コンストラクタ｡
QuotationCreateFromData2Controller

QuotationCreateFromData2Controller (ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、QuotationCreateFromData2Controller#executeBapi()実行後に必ず ConnectionManager#commit()またはConnectionManager#rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。
パラメータ
connectionManager ConnectionManager コネクションマネージャー
QuotationCreateFromData2Controller

QuotationCreateFromData2Controller (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより見積伝票を登録します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getBapiReturnErrMessage

String getBapiReturnErrMessage ()

ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡
返却値
String BAPI実行結果エラーとなった全てのメッセージ情報
getBapiReturnMessage

String getBapiReturnMessage ()

プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡
返却値
String プロパティファイルでオートコミット条件に一致したType情報のメッセージ情報
getBinaryRelationshiptype

Object getBinaryRelationshiptype ()

バイナリ関連タイプ (専用)を取得します。
返却値
Object バイナリ関連タイプ（専用）
getConvert

Object getConvert ()

変換: 取引先機能 + 受注伝票タイプを取得します。
返却値
Object 変換: 取引先機能 + 受注伝票タイプ
getExtensionInList

Array getExtensionInList ()

VBAK、VBAP、VBEP のカスタマ拡張を取得します。
返却値
Array VBAK、VBAP、VBEP のカスタマ拡張

VBAK、VBAP、VBEP のカスタマ拡張の構成は以下のとおりです。
STRUCTURE BAPI テーブル拡張の構造名 (String)
VALUEPART1 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART2 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART3 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART4 BAPI 拡張パラメータのデータ部分 (String)

VBAK、VBAP、VBEP のカスタマ拡張オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["STRUCTURE"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI テーブル拡張の構造名」
[idx]["VALUEPART1"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART2"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART3"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART4"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI 拡張パラメータのデータ部分」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getIntNumberAssignment

Object getIntNumberAssignment ()

明細番号内部採番を取得します。
返却値
Object 明細番号内部採番
getLogicSwitch

Object getLogicSwitch ()

内部制御パラメータを取得します。
返却値
Object 内部制御パラメータ

内部制御パラメータオブジェクトの構成は以下のとおりです。
内部制御パラメータ
オブジェクト
(Object)
PRICING 価格設定タイプ (String)
ATP_WRKMOD ATP セッション: 結果取得/新規決定 APO-ATP (String)
SCHEDULING 単一文字フラグ (String)
NOSTRUCTURE チェックボックス (String)
COND_HANDL 選択: 条件行処理 (SD 伝票変更) (String)

内部制御パラメータオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PRICING"]　→　配列内のidx番目の内部制御パラメータの「価格設定タイプ」
[idx]["ATP_WRKMOD"]　→　配列内のidx番目の内部制御パラメータの 「ATP セッション: 結果取得/新規決定 APO-ATP」
[idx]["SCHEDULING"]　→　配列内のidx番目の内部制御パラメータの「単一文字フラグ」
[idx]["NOSTRUCTURE"]　→　配列内のidx番目の内部制御パラメータの「チェックボックス」
[idx]["COND_HANDL"]　→　配列内のidx番目の内部制御パラメータの 「選択: 条件行処理 (SD 伝票変更)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPartnerAddressesList

Array getPartnerAddressesList ()

アドレス (組織/会社) 用 BAPI 参照構造を取得します。
返却値
Array アドレス (組織/会社) 用 BAPI 参照構造

アドレス (組織/会社) 用 BAPI 参照構造オブジェクトの構成は以下のとおりです。
ADDR_NO アドレス番号 (String)
FORMOFADDR 敬称テキスト (String)
NAME 名称 1 (String)
NAME_2 名称 2 (String)
NAME_3 名称 3 (String)
NAME_4 名称 4 (String)
C_O_NAME 気付 (String)
CITY 市区町村 (String)
DISTRICT 所在地 (String)
CITY_NO 市区町村/地名ファイルの市区町村コード (String)
POSTL_COD1 市区町村の郵便番号 (String)
POSTL_COD2 私書箱郵便番号 (String)
POSTL_COD3 会社郵便番号 (大規模なユーザ用) (String)
PO_BOX 私書箱 (String)
PO_BOX_CIT 私書箱住所 (String)
DELIV_DIS 郵便配達地域 (String)
STREET 地名 (String)
STREET_NO 市区町村/地名ファイルの地名コード (String)
STR_ABBR 地名の略称 (例: スペイン) (String)
HOUSE_NO 番地-号 (String)
STR_SUPPL1 地名 2 (String)
STR_SUPPL2 地名 3 (String)
LOCATION 地名 5 (String)
BUILDING 旧: 建物 (番号または略称) (String)
FLOOR 建物の階 (String)
ROOM_NO 部屋/アパート番号 (String)
COUNTRY 国コード (String)
LANGU 言語キー (String)
REGION 地域 (都道府県) (String)
SORT1 検索条件 1 (String)
SORT2 検索条件 2 (String)
TIME_ZONE アドレスタイムゾーン (String)
TAXJURCODE 税管轄コード (String)
ADR_NOTES 住所注記 (String)
COMM_TYPE 通信方法 (キー) (アドレス管理) (String)
TEL1_NUMBR 第一電話番号: ダイヤルコード + 番号 (String)
TEL1_EXT 第 1 電話番号: 内線 (String)
FAX_NUMBER 第一 FAX 番号: ダイヤルコード + 番号 (String)
FAX_EXTENS 第一 FAX 番号: 内線 (String)
STREET_LNG 地名 (String)
DISTRCT_NO 市区町村/地名ファイルの所在地コード (String)
CHCKSTATUS 市区町村ファイルテストステータス (String)
PBOXCIT_NO 市区町村私書箱コード (市ファイル) (String)
TRANSPZONE 商品の納入区域 (String)
HOUSE_NO2 番地補足 (String)
E_MAIL 電子メールアドレス (String)
STR_SUPPL3 地名 4 (String)
TITLE タイトル (敬称) (String)
COUNTRYISO ISO 国コード (String)
LANGU_ISO ISO 639 準拠の言語 (String)
BUILD_LONG 建物 (番号またはコード) (String)
REGIOGROUP 地域構造グループ化 (String)
HOME_CITY 市区町村 (郵便用市区町村と異なる場合) (String)
HOMECITYNO 別の市区町村 (市区町村/地名ファイル) (String)
PCODE1_EXT 市区町村郵便番号の拡張子 例: 郵便番号 +4+2 (String)
PCODE2_EXT 私書箱郵便番号拡張子 例: 郵便番号 +4+2 (String)
PCODE3_EXT 主要得意先郵便番号拡張子 例: 郵便番号 +4+2 (String)
PO_W_O_NO フラグ: 郵便私書箱 (番号なし) (String)
PO_BOX_REG 私書箱の地域 (国、都道府県、地域、...) (String)
POBOX_CTRY 私書箱の国指定 (String)
PO_CTRYISO ISO 国コード (String)
HOMEPAGE URI 例: ホームページ、FTP アドレス (String)
DONT_USE_S 地名住所配達不可フラグ (String)
DONT_USE_P 私書箱住所配達不可フラグ (String)
HOUSE_NO3 番地範囲 (String)
LANGU_CR アドレスレコード登録オリジナル言語 (String)
LANGUCRISO ISO 639 準拠の言語 (String)

アドレス (組織/会社) 用 BAPI 参照構造オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ADDR_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「アドレス番号」
[idx]["FORMOFADDR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「敬称テキスト」
[idx]["NAME"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「名称 1」
[idx]["NAME_2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「名称 2」
[idx]["NAME_3"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「名称 3」
[idx]["NAME_4"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「名称 4」
[idx]["C_O_NAME"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「気付」
[idx]["CITY"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「市区町村」
[idx]["DISTRICT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「所在地」
[idx]["CITY_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村/地名ファイルの市区町村コード」
[idx]["POSTL_COD1"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村の郵便番号」
[idx]["POSTL_COD2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱郵便番号」
[idx]["POSTL_COD3"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「会社郵便番号 (大規模なユーザ用)」
[idx]["PO_BOX"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「私書箱」
[idx]["PO_BOX_CIT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱住所」
[idx]["DELIV_DIS"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「郵便配達地域」
[idx]["STREET"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「地名」
[idx]["STREET_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村/地名ファイルの地名コード」
[idx]["STR_ABBR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名の略称 (例: スペイン)」
[idx]["HOUSE_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「番地-号」
[idx]["STR_SUPPL1"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名 2」
[idx]["STR_SUPPL2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名 3」
[idx]["LOCATION"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「地名 5」
[idx]["BUILDING"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「旧: 建物 (番号または略称)」
[idx]["FLOOR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「建物の階」
[idx]["ROOM_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「部屋/アパート番号」
[idx]["COUNTRY"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「国コード」
[idx]["LANGU"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「言語キー」
[idx]["REGION"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地域 (都道府県)」
[idx]["SORT1"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「検索条件 1」
[idx]["SORT2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「検索条件 2」
[idx]["TIME_ZONE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「アドレスタイムゾーン」
[idx]["TAXJURCODE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「税管轄コード」
[idx]["ADR_NOTES"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「住所注記」
[idx]["COMM_TYPE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「通信方法 (キー) (アドレス管理)」
[idx]["TEL1_NUMBR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「第一電話番号: ダイヤルコード + 番号」
[idx]["TEL1_EXT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「第 1 電話番号: 内線」
[idx]["FAX_NUMBER"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「第一 FAX 番号: ダイヤルコード + 番号」
[idx]["FAX_EXTENS"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「第一 FAX 番号: 内線」
[idx]["STREET_LNG"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「地名」
[idx]["DISTRCT_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村/地名ファイルの所在地コード」
[idx]["CHCKSTATUS"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村ファイルテストステータス」
[idx]["PBOXCIT_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村私書箱コード (市ファイル)」
[idx]["TRANSPZONE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「商品の納入区域」
[idx]["HOUSE_NO2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「番地補足」
[idx]["E_MAIL"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「電子メールアドレス」
[idx]["STR_SUPPL3"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名 4」
[idx]["TITLE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「タイトル (敬称)」
[idx]["COUNTRYISO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「ISO 国コード」
[idx]["LANGU_ISO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「ISO 639 準拠の言語」
[idx]["BUILD_LONG"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「建物 (番号またはコード)」
[idx]["REGIOGROUP"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地域構造グループ化」
[idx]["HOME_CITY"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村 (郵便用市区町村と異なる場合)」
[idx]["HOMECITYNO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「別の市区町村 (市区町村/地名ファイル)」
[idx]["PCODE1_EXT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村郵便番号の拡張子 例: 郵便番号 +4+2」
[idx]["PCODE2_EXT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱郵便番号拡張子 例: 郵便番号 +4+2」
[idx]["PCODE3_EXT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「主要得意先郵便番号拡張子 例: 郵便番号 +4+2」
[idx]["PO_W_O_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「フラグ: 郵便私書箱 (番号なし)」
[idx]["PO_BOX_REG"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱の地域 (国、都道府県、地域、...)」
[idx]["POBOX_CTRY"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱の国指定」
[idx]["PO_CTRYISO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「ISO 国コード」
[idx]["HOMEPAGE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「URI 例: ホームページ、FTP アドレス」
[idx]["DONT_USE_S"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名住所配達不可フラグ」
[idx]["DONT_USE_P"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱住所配達不可フラグ」
[idx]["HOUSE_NO3"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「番地範囲」
[idx]["LANGU_CR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「アドレスレコード登録オリジナル言語」
[idx]["LANGUCRISO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「ISO 639 準拠の言語」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationCfgsBlobList

Array getQuotationCfgsBlobList ()

選定: BLOB 内部データ (SCE)を取得します。
返却値
Array 選定: BLOB 内部データ (SCE)

選定: BLOB 内部データ (SCE)オブジェクトの構成は以下のとおりです。
CONFIG_ID 外部選定 ID (仮) (String)
CONTEXT CU: 選定の BLOB. (SCE) (String)

選定: BLOB 内部データ (SCE)オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: BLOB 内部データ (SCE)の 「外部選定 ID (仮)」
[idx]["CONTEXT"]　→　配列内のidx番目の選定: BLOB 内部データ (SCE)の 「CU: 選定の BLOB. (SCE)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationCfgsInstList

Array getQuotationCfgsInstList ()

選定: インスタンスを取得します。
返却値
Array 選定: インスタンス

選定: インスタンスオブジェクトの構成は以下のとおりです。
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)
OBJ_TYPE 対象タイプ (String)
CLASS_TYPE クラスタイプ (String)
OBJ_KEY 対象キー (String)
OBJ_TXT 言語依存対象テキスト (String)
QUANTITY インスタンス数量 (String)
AUTHOR 報告書提案済 (String)
QUANTITY_UNIT 数量単位 (String)
COMPLETE 一般区分 (String)
CONSISTENT 一般区分 (String)
OBJECT_GUID インスタンス用 TYPE_OF ステートメントの GUID (String)
PERSIST_ID インスタンス番号 (固定) (String)
PERSIST_ID_TYPE インスタンス番号タイプ (固定) (String)

選定: インスタンスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: インスタンスの「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の選定: インスタンスの「選定におけるインスタンス番号」
[idx]["OBJ_TYPE"]　→　配列内のidx番目の選定: インスタンスの「対象タイプ」
[idx]["CLASS_TYPE"]　→　配列内のidx番目の選定: インスタンスの「クラスタイプ」
[idx]["OBJ_KEY"]　→　配列内のidx番目の選定: インスタンスの「対象キー」
[idx]["OBJ_TXT"]　→　配列内のidx番目の選定: インスタンスの「言語依存対象テキスト」
[idx]["QUANTITY"]　→　配列内のidx番目の選定: インスタンスの「インスタンス数量」
[idx]["AUTHOR"]　→　配列内のidx番目の選定: インスタンスの「報告書提案済」
[idx]["QUANTITY_UNIT"]　→　配列内のidx番目の選定: インスタンスの「数量単位」
[idx]["COMPLETE"]　→　配列内のidx番目の選定: インスタンスの「一般区分」
[idx]["CONSISTENT"]　→　配列内のidx番目の選定: インスタンスの「一般区分」
[idx]["OBJECT_GUID"]　→　配列内のidx番目の選定: インスタンスの 「インスタンス用 TYPE_OF ステートメントの GUID」
[idx]["PERSIST_ID"]　→　配列内のidx番目の選定: インスタンスの「インスタンス番号 (固定)」
[idx]["PERSIST_ID_TYPE"]　→　配列内のidx番目の選定: インスタンスの 「インスタンス番号タイプ (固定)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationCfgsPartOfList

Array getQuotationCfgsPartOfList ()

選定: 部分設定を取得します。
返却値
Array 選定: 部分設定

選定: 部分設定オブジェクトの構成は以下のとおりです。
CONFIG_ID 外部選定 ID (仮) (String)
PARENT_ID 選定におけるインスタンス番号 (String)
INST_ID 選定におけるインスタンス番号 (String)
PART_OF_NO Part_of 明細番号 (String)
OBJ_TYPE 対象タイプ (String)
CLASS_TYPE クラスタイプ (String)
OBJ_KEY 対象キー (String)
AUTHOR 報告書提案済 (String)
SALES_RELEVANT この部品は販売に関連しています (String)
PART_OF_GUID インスタンス用 PART_OF ステートメントの GUID (String)

選定: 部分設定オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: 部分設定の「外部選定 ID (仮)」
[idx]["PARENT_ID"]　→　配列内のidx番目の選定: 部分設定の「選定におけるインスタンス番号」
[idx]["INST_ID"]　→　配列内のidx番目の選定: 部分設定の「選定におけるインスタンス番号」
[idx]["PART_OF_NO"]　→　配列内のidx番目の選定: 部分設定の「Part_of 明細番号」
[idx]["OBJ_TYPE"]　→　配列内のidx番目の選定: 部分設定の「対象タイプ」
[idx]["CLASS_TYPE"]　→　配列内のidx番目の選定: 部分設定の「クラスタイプ」
[idx]["OBJ_KEY"]　→　配列内のidx番目の選定: 部分設定の「対象キー」
[idx]["AUTHOR"]　→　配列内のidx番目の選定: 部分設定の「報告書提案済」
[idx]["SALES_RELEVANT"]　→　配列内のidx番目の選定: 部分設定の 「この部品は販売に関連しています」
[idx]["PART_OF_GUID"]　→　配列内のidx番目の選定: 部分設定の 「インスタンス用 PART_OF ステートメントの GUID」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationCfgsRefInstList

Array getQuotationCfgsRefInstList ()

選定: 参照明細/インスタンスを取得します。
返却値
Array 選定: 参照明細/インスタンス

選定: 参照明細/インスタンスオブジェクトの構成は以下のとおりです。
POSEX 外部明細番号 (String)
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)

選定: 参照明細/インスタンスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["POSEX"]　→　配列内のidx番目の選定: 参照明細/インスタンスの「外部明細番号」
[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: 参照明細/インスタンスの 「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の選定: 参照明細/インスタンスの 「選定におけるインスタンス番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationCfgsRefList

Array getQuotationCfgsRefList ()

選定: 参照データを取得します。
返却値
Array 選定: 参照データ

選定: 参照データオブジェクトの構成は以下のとおりです。
POSEX 外部明細番号 (String)
CONFIGconfig_id 外部選定 ID (仮) (String)
ROOT_Iroot_id 選定におけるインスタンス番号 (String)
SCE scCUX: 選定タイプ (String)
KBNAMEkbname ナレッジベースオブジェクト (String)
KBVERSkbversion SCE ナレッジベースの実行時バージョン (String)
COMPLEcomplete 一般区分 (String)
CONSISconsistent 一般区分 (String)
CFGINFcfginfo CU: 選定の BLOB (SCE) (String)
KBPROFkbprofile ナレッジベースプロファイル (String)
KBLANGkblanguage システム設定の言語 (String)
CBASE_cbase_id インスタンス番号 (固定) (String)
CBASE_cbase_id_type インスタンス番号タイプ (固定) (String)

選定: 参照データオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["POSEX"]　→　配列内のidx番目の選定: 参照データの「外部明細番号」
[idx]["CONFIGconfig_id"]　→　配列内のidx番目の選定: 参照データの 「外部選定 ID (仮)」
[idx]["ROOT_Iroot_id"]　→　配列内のidx番目の選定: 参照データの 「選定におけるインスタンス番号」
[idx]["SCE"]　→　配列内のidx番目の選定: 参照データの「scCUX: 選定タイプ」
[idx]["KBNAMEkbname"]　→　配列内のidx番目の選定: 参照データの「ナレッジベースオブジェクト」
[idx]["KBVERSkbversion"]　→　配列内のidx番目の選定: 参照データの 「SCE ナレッジベースの実行時バージョン」
[idx]["COMPLEcomplete"]　→　配列内のidx番目の選定: 参照データの「一般区分」
[idx]["CONSISconsistent"]　→　配列内のidx番目の選定: 参照データの「一般区分」
[idx]["CFGINFcfginfo"]　→　配列内のidx番目の選定: 参照データの 「CU: 選定の BLOB (SCE)」
[idx]["KBPROFkbprofile"]　→　配列内のidx番目の選定: 参照データの 「ナレッジベースプロファイル」
[idx]["KBLANGkblanguage"]　→　配列内のidx番目の選定: 参照データの「システム設定の言語」
[idx]["CBASE_cbase_id"]　→　配列内のidx番目の選定: 参照データの 「インスタンス番号 (固定)」
[idx]["CBASE_cbase_id_type"]　→　配列内のidx番目の選定: 参照データの 「インスタンス番号タイプ (固定)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationCfgsValueList

Array getQuotationCfgsValueList ()

選定: 特性値を取得します。
返却値
Array 選定: 特性値

選定: 特性値オブジェクトの構成は以下のとおりです。
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)
CHARC 特性名 (String)
CHARC_TXT 言語依存特性テキスト (String)
VALUE 特性値 (String)
VALUE_TXT 特性値の言語依存テキスト (String)
AUTHOR 報告書提案済 (String)
VALUE_TO 特性値 (String)
VALCODE 値タイプ: 範囲制限 - 単一値 (String)

選定: 特性値オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: 特性値の「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の選定: 特性値の「選定におけるインスタンス番号」
[idx]["CHARC"]　→　配列内のidx番目の選定: 特性値の「特性名」
[idx]["CHARC_TXT"]　→　配列内のidx番目の選定: 特性値の「言語依存特性テキスト」
[idx]["VALUE"]　→　配列内のidx番目の選定: 特性値の「特性値」
[idx]["VALUE_TXT"]　→　配列内のidx番目の選定: 特性値の「特性値の言語依存テキスト」
[idx]["AUTHOR"]　→　配列内のidx番目の選定: 特性値の「報告書提案済」
[idx]["VALUE_TO"]　→　配列内のidx番目の選定: 特性値の「特性値」
[idx]["VALCODE"]　→　配列内のidx番目の選定: 特性値の「値タイプ: 範囲制限 - 単一値」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationCfgsVkList

Array getQuotationCfgsVkList ()

選定: バリアント条件キーを取得します。
返却値
Array 選定: バリアント条件キー

選定: バリアント条件キーオブジェクトの構成は以下のとおりです。
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)
VKEY バリアント条件名 (String)
FACTOR バリアント条件の加重係数 (String)

選定: バリアント条件キーオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: バリアント条件キーの「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の選定: バリアント条件キーの「選定におけるインスタンス番号」
[idx]["VKEY"]　→　配列内のidx番目の選定: バリアント条件キーの「バリアント条件名」
[idx]["FACTOR"]　→　配列内のidx番目の選定: バリアント条件キーの「バリアント条件の加重係数」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationConditionsInList

Array getQuotationConditionsInList ()

条件を取得します。
返却値
Array 条件

条件オブジェクトの構成は以下のとおりです。
ITM_NUMBER 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件カウンタ (String)
COND_TYPE 条件タイプ (String)
COND_VALUE 条件レート (String)
CURRENCY 通貨コード (String)
COND_UNIT 条件単位 (String)
COND_P_UNT 価格条件単位 (String)
CURR_ISO ISO コード通貨 (String)
CD_UNT_ISO 条件数量単位 (ISO コード) (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)
APPLICATIO アプリケーション (String)
CONPRICDAT 条件価格設定日付 (String)
CALCTYPCON 条件計算タイプ (String)
CONBASEVAL 条件基礎値 (String)
CONEXCHRAT 現地通貨への換算レートに対する条件 (String)
NUMCONVERT 条件単位を基本単位へ変換する分子 (String)
DENOMINATO 条件単位を基本単位へ変換する分母 (String)
CONDTYPE 条件カテゴリ (例: 税、運賃、価格、原価) (String)
STAT_CON 統計に適用する条件 (String)
SCALETYPE スケールタイプ (String)
ACCRUALS 見越額関連条件 (運賃など) (String)
CONINVOLST 請求書一覧条件 (String)
CONDORIGIN 条件生成区分 (String)
GROUPCOND グループ条件区分 (String)
COND_UPDAT 条件更新 (String)
ACCESS_SEQ 検索順序 - 検索番号 (String)
CONDCOUNT 条件連続番号 (String)
ROUNDOFFDI BAPI の通貨額 (小数点以下９桁) (String)
CONDVALUE 条件金額 (String)
CURRENCY_2 販売伝票通貨 (String)
CURR_ISO_2 ISO コード通貨 (String)
CONDCNTRL 条件管理 (String)
CONDISACTI 無効条件 (String)
CONDCLASS 条件クラス (String)
FACTBASVAL 条件基礎値に対する要因 (String)
SCALEBASIN スケール基準区分 (String)
SCALBASVAL 条件のスケール基準値 (String)
UNITMEASUR 条件スケール単位 (String)
ISO_UNIT 単位の ISO コード (String)
CURRENCKEY スケール通貨 (String)
CURRENISO ISO コード通貨 (String)
CONDINCOMP 会社間請求の条件 (String)
CONDCONFIG システム設定の条件 (String)
CONDCHAMAN 条件 (マニュアル変更済) (String)
COND_NO 条件レコード番号 (String)
TAX_CODE 消費税コード (String)
VARCOND バリアント条件 (String)
ACCOUNTKEY 勘定キー (String)
ACCOUNT_KE 勘定キー 見越/引当 (String)
WT_WITHCD 源泉徴収税コード (String)
STRUCTCOND 構造条件 (String)
FACTCONBAS 条件基準の係数 (期間) (String)
CONDCOINHD 条件カウンタ (ヘッダ条件) (String)

条件オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の条件の「条件明細番号」
[idx]["COND_ST_NO"]　→　配列内のidx番目の条件の「ステップ番号」
[idx]["COND_COUNT"]　→　配列内のidx番目の条件の「条件カウンタ」
[idx]["COND_TYPE"]　→　配列内のidx番目の条件の「条件タイプ」
[idx]["COND_VALUE"]　→　配列内のidx番目の条件の「条件レート」
[idx]["CURRENCY"]　→　配列内のidx番目の条件の「通貨コード」
[idx]["COND_UNIT"]　→　配列内のidx番目の条件の「条件単位」
[idx]["COND_P_UNT"]　→　配列内のidx番目の条件の「価格条件単位」
[idx]["CURR_ISO"]　→　配列内のidx番目の条件の「ISO コード通貨」
[idx]["CD_UNT_ISO"]　→　配列内のidx番目の条件の「条件数量単位 (ISO コード)」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の条件の「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の条件の「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の条件の「論理システム」
[idx]["APPLICATIO"]　→　配列内のidx番目の条件の「アプリケーション」
[idx]["CONPRICDAT"]　→　配列内のidx番目の条件の「条件価格設定日付」
[idx]["CALCTYPCON"]　→　配列内のidx番目の条件の「条件計算タイプ」
[idx]["CONBASEVAL"]　→　配列内のidx番目の条件の「条件基礎値」
[idx]["CONEXCHRAT"]　→　配列内のidx番目の条件の「現地通貨への換算レートに対する条件」
[idx]["NUMCONVERT"]　→　配列内のidx番目の条件の「条件単位を基本単位へ変換する分子」
[idx]["DENOMINATO"]　→　配列内のidx番目の条件の「条件単位を基本単位へ変換する分母」
[idx]["CONDTYPE"]　→　配列内のidx番目の条件の「条件カテゴリ (例: 税、運賃、価格、原価)」
[idx]["STAT_CON"]　→　配列内のidx番目の条件の「統計に適用する条件」
[idx]["SCALETYPE"]　→　配列内のidx番目の条件の「スケールタイプ」
[idx]["ACCRUALS"]　→　配列内のidx番目の条件の「見越額関連条件 (運賃など)」
[idx]["CONINVOLST"]　→　配列内のidx番目の条件の「請求書一覧条件」
[idx]["CONDORIGIN"]　→　配列内のidx番目の条件の「条件生成区分」
[idx]["GROUPCOND"]　→　配列内のidx番目の条件の「グループ条件区分」
[idx]["COND_UPDAT"]　→　配列内のidx番目の条件の「条件更新」
[idx]["ACCESS_SEQ"]　→　配列内のidx番目の条件の「検索順序 - 検索番号」
[idx]["CONDCOUNT"]　→　配列内のidx番目の条件の「条件連続番号」
[idx]["ROUNDOFFDI"]　→　配列内のidx番目の条件の「BAPI の通貨額 (小数点以下９桁)」
[idx]["CONDVALUE"]　→　配列内のidx番目の条件の「条件金額」
[idx]["CURRENCY_2"]　→　配列内のidx番目の条件の「販売伝票通貨」
[idx]["CURR_ISO_2"]　→　配列内のidx番目の条件の「ISO コード通貨」
[idx]["CONDCNTRL"]　→　配列内のidx番目の条件の「条件管理」
[idx]["CONDISACTI"]　→　配列内のidx番目の条件の「無効条件」
[idx]["CONDCLASS"]　→　配列内のidx番目の条件の「条件クラス」
[idx]["FACTBASVAL"]　→　配列内のidx番目の条件の「条件基礎値に対する要因」
[idx]["SCALEBASIN"]　→　配列内のidx番目の条件の「スケール基準区分」
[idx]["SCALBASVAL"]　→　配列内のidx番目の条件の「条件のスケール基準値」
[idx]["UNITMEASUR"]　→　配列内のidx番目の条件の「条件スケール単位」
[idx]["ISO_UNIT"]　→　配列内のidx番目の条件の「単位の ISO コード」
[idx]["CURRENCKEY"]　→　配列内のidx番目の条件の「スケール通貨」
[idx]["CURRENISO"]　→　配列内のidx番目の条件の「ISO コード通貨」
[idx]["CONDINCOMP"]　→　配列内のidx番目の条件の「会社間請求の条件」
[idx]["CONDCONFIG"]　→　配列内のidx番目の条件の「システム設定の条件」
[idx]["CONDCHAMAN"]　→　配列内のidx番目の条件の「条件 (マニュアル変更済)」
[idx]["COND_NO"]　→　配列内のidx番目の条件の「条件レコード番号」
[idx]["TAX_CODE"]　→　配列内のidx番目の条件の「消費税コード」
[idx]["VARCOND"]　→　配列内のidx番目の条件の「バリアント条件」
[idx]["ACCOUNTKEY"]　→　配列内のidx番目の条件の「勘定キー」
[idx]["ACCOUNT_KE"]　→　配列内のidx番目の条件の「勘定キー 見越/引当」
[idx]["WT_WITHCD"]　→　配列内のidx番目の条件の「源泉徴収税コード」
[idx]["STRUCTCOND"]　→　配列内のidx番目の条件の「構造条件」
[idx]["FACTCONBAS"]　→　配列内のidx番目の条件の「条件基準の係数 (期間)」
[idx]["CONDCOINHD"]　→　配列内のidx番目の条件の「条件カウンタ (ヘッダ条件)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationConditionsInXList

Array getQuotationConditionsInXList ()

受注における条件更新の通信項目を取得します。
返却値
Array 受注における条件更新の通信項目

受注における条件更新の通信項目オブジェクトの構成は以下のとおりです。
ITM_NUMBER 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件連続番号 (String)
COND_TYPE 条件タイプ (String)
UPDATEFLAG 更新区分 (String)
COND_VALUE 関連ユーザデータ項目の更新情報 (String)
CURRENCY 関連ユーザデータ項目の更新情報 (String)
COND_UNIT 関連ユーザデータ項目の更新情報 (String)
COND_P_UNT 関連ユーザデータ項目の更新情報 (String)
VARCOND バリアント条件 (String)

受注における条件更新の通信項目オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の受注における条件更新の通信項目の「条件明細番号」
[idx]["COND_ST_NO"]　→　配列内のidx番目の受注における条件更新の通信項目の「ステップ番号」
[idx]["COND_COUNT"]　→　配列内のidx番目の受注における条件更新の通信項目の「条件連続番号」
[idx]["COND_TYPE"]　→　配列内のidx番目の受注における条件更新の通信項目の「条件タイプ」
[idx]["UPDATEFLAG"]　→　配列内のidx番目の受注における条件更新の通信項目の「更新区分」
[idx]["COND_VALUE"]　→　配列内のidx番目の受注における条件更新の通信項目の 「関連ユーザデータ項目の更新情報」
[idx]["CURRENCY"]　→　配列内のidx番目の受注における条件更新の通信項目の 「関連ユーザデータ項目の更新情報」
[idx]["COND_UNIT"]　→　配列内のidx番目の受注における条件更新の通信項目の 「関連ユーザデータ項目の更新情報」
[idx]["COND_P_UNT"]　→　配列内のidx番目の受注における条件更新の通信項目の 「関連ユーザデータ項目の更新情報」
[idx]["VARCOND"]　→　配列内のidx番目の受注における条件更新の通信項目の「バリアント条件」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationHeaderIn

Object getQuotationHeaderIn ()

見積伝票ヘッダデータを取得します。
返却値
Object 見積伝票ヘッダデータ

見積伝票ヘッダデータオブジェクトの構成は以下のとおりです。
REFOBJTYPE オブジェクトタイプ(String)
REFOBJKEY オブジェクトキー(String)
REFDOCTYPE 参照オブジェクトの伝票タイプ(String)
DOC_TYPE 販売伝票タイプ(String)
COLLECT_NO 一括番号(String)
SALES_ORG 販売組織(String)
DISTR_CHAN 流通チャネル(String)
DIVISION 製品部門(String)
SALES_GRP 営業グループ(String)
SALES_OFF 営業所(String)
REQ_DATE_H 指定納入期日(String)
DATE_TYPE 提案日付タイプ(String)
PURCH_DATE 得意先発注日付(String)
PO_METHOD 得意先発注タイプ(String)
PO_SUPPLEM 得意先発注番号補足(String)
REF_1 得意先/仕入先の内部参照コード(String)
NAME 発注者名称(String)
TELEPHONE 電話番号(String)
PRICE_GRP 価格グループ (得意先)(String)
CUST_GROUP 得意先グループ(String)
SALES_DIST 販売地域(String)
PRICE_LIST 価格表タイプ(String)
INCOTERMS1 インコタームズ (1)(String)
INCOTERMS2 インコタームズ 2(String)
PMNTTRMS 支払条件キー(String)
DLV_BLOCK 出荷ブロック (伝票ヘッダ)(String)
BILL_BLOCK 販売管理伝票の請求ブロック(String)
ORD_REASON 受注理由 (取引理由)(String)
COMPL_DLV 一括納入区分(String)
PRICE_DATE 価格設定/外貨換算の実行日付(String)
QT_VALID_F 見積/引合有効開始日(String)
QT_VALID_T 見積の有効終了日(String)
CT_VALID_F 有効開始日付 (販売契約/品目提案)(String)
CT_VALID_T 有効終了日付 (販売契約/品目提案)(String)
CUST_GRP1 得意先グループ 1(String)
CUST_GRP2 得意先グループ 2(String)
CUST_GRP3 得意先グループ 3(String)
CUST_GRP4 得意先グループ 4(String)
CUST_GRP5 得意先グループ 5(String)
PURCH_NO_C 出荷先発注番号(String)
PURCH_NO_S 出荷先の得意先発注番号(String)
PO_DAT_S 出荷先の出荷先発注日付(String)
PO_METH_S 出荷先の出荷先発注タイプ(String)
REF_1_S 出荷先文字(String)
SD_DOC_CAT 販売管理伝票カテゴリ(String)
DOC_DATE 伝票日付 (受信日/送信日)(String)
WAR_DATE 保証期間の開始日付(String)
SHIP_COND 出荷条件(String)
PP_SEARCH 品目提案検索条件(String)
DUN_COUNT 得意先商談回数(String)
DUN_DATE 得意先との前回の商談日(String)
DLVSCHDUSE 用途区分(String)
PLDLVSTYP MRP: 出荷計画タイプ(String)
REF_DOC 参照伝票番号(String)
COMP_CDE_B 請求対象会社コード(String)
ALTTAX_CLS 代替税分類(String)
TAX_CLASS2 得意先税分類 2(String)
TAX_CLASS3 得意先税分類 3(String)
TAX_CLASS4 得意先に対する税クラス 4(String)
TAX_CLASS5 得意先に対する税クラス 5(String)
TAX_CLASS6 得意先に対する税クラス 6(String)
TAX_CLASS7 得意先に対する税クラス 7(String)
TAX_CLASS8 得意先に対する税クラス 8(String)
TAX_CLASS9 得意先に対する税クラス 9(String)
REF_DOC_L 参照伝票番号(String)
ASS_NUMBER 割当番号(String)
REFDOC_CAT 先行販売管理伝票の伝票カテゴリ(String)
ORDCOMB_IN 受注結合出荷区分(String)
BILL_SCHED 請求日程 (稼働日カレンダ指定)(String)
INVO_SCHED 請求書一覧日程 (稼働日カレンダ指定)(String)
MN_INVOICE マニュアル請求書更新(String)
EXRATE_FI FI 転記の換算レート (直接相場)(String)
ADD_VAL_DY 有効日からの日数(String)
FIX_VAL_DY 有効日日付(String)
PYMT_METH 支払方法(String)
ACCNT_ASGN 得意先の勘定設定グループ(String)
EXCHG_RATE 価格設定/統計の換算レート (直接引用)(String)
BILL_DATE 請求索引および印刷に対する請求日(String)
SERV_DATE サービス提供日(String)
DUNN_KEY 督促処理キー(String)
DUNN_BLOCK 督促処理保留(String)
PMTGAR_PRO 支払保証決定表(String)
DEPARTM_NO 部門コード(String)
REC_POINT 入荷ポイント(String)
DOC_NUM_FI ドキュメンタリクレジット処理: 内部番号(String)
CSTCNDGRP1 得意先条件グループ１(String)
CSTCNDGRP2 得意先条件グループ２(String)
CSTCNDGRP3 得意先条件グループ３(String)
CSTCNDGRP4 得意先条件グループ４(String)
CSTCNDGRP5 得意先条件グループ５(String)
DLV_TIME 契約出荷期間(String)
CURRENCY 販売伝票通貨(String)
CURR_ISO ISO コード通貨(String)
CREATED_BY オブジェクト登録者名(String)
TAXDEP_CTY 税出荷国(String)
TAXDST_CTY 税仕向国(String)
EUTRI_DEAL フラグ: EC 内三角取引(String)
MAST_CONTR グループマスタ契約番号(String)
REF_PROC 参照限定条件: 決定区分(String)
CHKPRTAUTH 取引先権限チェック(String)
CMLQTY_DAT 累積出荷数量日付(String)
VERSION 販売伝票バージョン番号(String)
NOTIF_NO 通知番号(String)
WBS_ELEM WBS 要素(String)
EXCH_RATE_FI_V FI 転記の換算レート (間接相場)(String)
EXCHG_RATE_V 価格設定/統計の換算レート (間接引用)(String)
FKK_CONACCT 長さ 12 の文字項目(String)
CAMPAIGN 総括プロジェクト計画: 外部 R/3 システムの GUID(String)
DOC_CLASS リリースおよびトランザクション管理 を備えた元システム(String)
H_CURR 通貨コード(String)
H_CURR_ISO ISO 通貨コード(String)
SHIP_TYPE 出荷タイプ(String)
S_PROC_IND 特別処理区分(String)
REF_DOC_L_LONG 参照伝票番号 (依存関係についてはテキスト (長) を参照)(String)

内部制御パラメータオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["REFOBJTYPE"]　→　配列内のidx番目の見積伝票ヘッダデータの「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の見積伝票ヘッダデータの「オブジェクトキー」
[idx]["REFDOCTYPE"]　→　配列内のidx番目の見積伝票ヘッダデータの「参照オブジェクトの伝票タイプ」
[idx]["DOC_TYPE"]　→　配列内のidx番目の見積伝票ヘッダデータの「販売伝票タイプ」
[idx]["COLLECT_NO"]　→　配列内のidx番目の見積伝票ヘッダデータの「一括番号」
[idx]["SALES_ORG"]　→　配列内のidx番目の見積伝票ヘッダデータの「販売組織」
[idx]["DISTR_CHAN"]　→　配列内のidx番目の見積伝票ヘッダデータの「流通チャネル」
[idx]["DIVISION"]　→　配列内のidx番目の見積伝票ヘッダデータの「製品部門」
[idx]["SALES_GRP"]　→　配列内のidx番目の見積伝票ヘッダデータの「営業グループ」
[idx]["SALES_OFF"]　→　配列内のidx番目の見積伝票ヘッダデータの「営業所」
[idx]["REQ_DATE_H"]　→　配列内のidx番目の見積伝票ヘッダデータの「指定納入期日」
[idx]["DATE_TYPE"]　→　配列内のidx番目の見積伝票ヘッダデータの「提案日付タイプ」
[idx]["PURCH_DATE"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先発注日付」
[idx]["PO_METHOD"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先発注タイプ」
[idx]["PO_SUPPLEM"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先発注番号補足」
[idx]["REF_1"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先/仕入先の内部参照コード」
[idx]["NAME"]　→　配列内のidx番目の見積伝票ヘッダデータの「発注者名称」
[idx]["TELEPHONE"]　→　配列内のidx番目の見積伝票ヘッダデータの「電話番号」
[idx]["PRICE_GRP"]　→　配列内のidx番目の見積伝票ヘッダデータの「価格グループ (得意先)」
[idx]["CUST_GROUP"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先グループ」
[idx]["SALES_DIST"]　→　配列内のidx番目の見積伝票ヘッダデータの「販売地域」
[idx]["PRICE_LIST"]　→　配列内のidx番目の見積伝票ヘッダデータの「価格表タイプ」
[idx]["INCOTERMS1"]　→　配列内のidx番目の見積伝票ヘッダデータの「インコタームズ (1)」
[idx]["INCOTERMS2"]　→　配列内のidx番目の見積伝票ヘッダデータの「インコタームズ 2」
[idx]["PMNTTRMS"]　→　配列内のidx番目の見積伝票ヘッダデータの「支払条件キー」
[idx]["DLV_BLOCK"]　→　配列内のidx番目の見積伝票ヘッダデータの「出荷ブロック (伝票ヘッダ)」
[idx]["BILL_BLOCK"]　→　配列内のidx番目の見積伝票ヘッダデータの「販売管理伝票の請求ブロック」
[idx]["ORD_REASON"]　→　配列内のidx番目の見積伝票ヘッダデータの「受注理由 (取引理由)」
[idx]["COMPL_DLV"]　→　配列内のidx番目の見積伝票ヘッダデータの「一括納入区分」
[idx]["PRICE_DATE"]　→　配列内のidx番目の見積伝票ヘッダデータの「価格設定/外貨換算の実行日付」
[idx]["QT_VALID_F"]　→　配列内のidx番目の見積伝票ヘッダデータの「見積/引合有効開始日」
[idx]["QT_VALID_T"]　→　配列内のidx番目の見積伝票ヘッダデータの「見積の有効終了日」
[idx]["CT_VALID_F"]　→　配列内のidx番目の見積伝票ヘッダデータの 「有効開始日付 (販売契約/品目提案)」
[idx]["CT_VALID_T"]　→　配列内のidx番目の見積伝票ヘッダデータの 「有効終了日付 (販売契約/品目提案)」
[idx]["CUST_GRP1"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先グループ 1」
[idx]["CUST_GRP2"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先グループ 2」
[idx]["CUST_GRP3"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先グループ 3」
[idx]["CUST_GRP4"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先グループ 4」
[idx]["CUST_GRP5"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先グループ 5」
[idx]["PURCH_NO_C"]　→　配列内のidx番目の見積伝票ヘッダデータの「出荷先発注番号」
[idx]["PURCH_NO_S"]　→　配列内のidx番目の見積伝票ヘッダデータの「出荷先の得意先発注番号」
[idx]["PO_DAT_S"]　→　配列内のidx番目の見積伝票ヘッダデータの「出荷先の出荷先発注日付」
[idx]["PO_METH_S"]　→　配列内のidx番目の見積伝票ヘッダデータの「出荷先の出荷先発注タイプ」
[idx]["REF_1_S"]　→　配列内のidx番目の見積伝票ヘッダデータの「出荷先文字」
[idx]["SD_DOC_CAT"]　→　配列内のidx番目の見積伝票ヘッダデータの「販売管理伝票カテゴリ」
[idx]["DOC_DATE"]　→　配列内のidx番目の見積伝票ヘッダデータの「伝票日付 (受信日/送信日)」
[idx]["WAR_DATE"]　→　配列内のidx番目の見積伝票ヘッダデータの「保証期間の開始日付」
[idx]["SHIP_COND"]　→　配列内のidx番目の見積伝票ヘッダデータの「出荷条件」
[idx]["PP_SEARCH"]　→　配列内のidx番目の見積伝票ヘッダデータの「品目提案検索条件」
[idx]["DUN_COUNT"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先商談回数」
[idx]["DUN_DATE"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先との前回の商談日」
[idx]["DLVSCHDUSE"]　→　配列内のidx番目の見積伝票ヘッダデータの「用途区分」
[idx]["PLDLVSTYP"]　→　配列内のidx番目の見積伝票ヘッダデータの「MRP: 出荷計画タイプ」
[idx]["REF_DOC"]　→　配列内のidx番目の見積伝票ヘッダデータの「参照伝票番号」
[idx]["COMP_CDE_B"]　→　配列内のidx番目の見積伝票ヘッダデータの「請求対象会社コード」
[idx]["ALTTAX_CLS"]　→　配列内のidx番目の見積伝票ヘッダデータの「代替税分類」
[idx]["TAX_CLASS2"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先税分類 2」
[idx]["TAX_CLASS3"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先税分類 3」
[idx]["TAX_CLASS4"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先に対する税クラス 4」
[idx]["TAX_CLASS5"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先に対する税クラス 5」
[idx]["TAX_CLASS6"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先に対する税クラス 6」
[idx]["TAX_CLASS7"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先に対する税クラス 7」
[idx]["TAX_CLASS8"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先に対する税クラス 8」
[idx]["TAX_CLASS9"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先に対する税クラス 9」
[idx]["REF_DOC_L"]　→　配列内のidx番目の見積伝票ヘッダデータの「参照伝票番号」
[idx]["ASS_NUMBER"]　→　配列内のidx番目の見積伝票ヘッダデータの「割当番号」
[idx]["REFDOC_CAT"]　→　配列内のidx番目の見積伝票ヘッダデータの 「先行販売管理伝票の伝票カテゴリ」
[idx]["ORDCOMB_IN"]　→　配列内のidx番目の見積伝票ヘッダデータの「受注結合出荷区分」
[idx]["BILL_SCHED"]　→　配列内のidx番目の見積伝票ヘッダデータの 「請求日程 (稼働日カレンダ指定)」
[idx]["INVO_SCHED"]　→　配列内のidx番目の見積伝票ヘッダデータの 「請求書一覧日程 (稼働日カレンダ指定)」
[idx]["MN_INVOICE"]　→　配列内のidx番目の見積伝票ヘッダデータの「マニュアル請求書更新」
[idx]["EXRATE_FI"]　→　配列内のidx番目の見積伝票ヘッダデータの 「FI 転記の換算レート (直接相場)」
[idx]["ADD_VAL_DY"]　→　配列内のidx番目の見積伝票ヘッダデータの「有効日からの日数」
[idx]["FIX_VAL_DY"]　→　配列内のidx番目の見積伝票ヘッダデータの「有効日日付」
[idx]["PYMT_METH"]　→　配列内のidx番目の見積伝票ヘッダデータの「支払方法」
[idx]["ACCNT_ASGN"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先の勘定設定グループ」
[idx]["EXCHG_RATE"]　→　配列内のidx番目の見積伝票ヘッダデータの 「価格設定/統計の換算レート (直接引用)」
[idx]["BILL_DATE"]　→　配列内のidx番目の見積伝票ヘッダデータの 「請求索引および印刷に対する請求日」
[idx]["SERV_DATE"]　→　配列内のidx番目の見積伝票ヘッダデータの「サービス提供日」
[idx]["DUNN_KEY"]　→　配列内のidx番目の見積伝票ヘッダデータの「督促処理キー」
[idx]["DUNN_BLOCK"]　→　配列内のidx番目の見積伝票ヘッダデータの「督促処理保留」
[idx]["PMTGAR_PRO"]　→　配列内のidx番目の見積伝票ヘッダデータの「支払保証決定表」
[idx]["DEPARTM_NO"]　→　配列内のidx番目の見積伝票ヘッダデータの「部門コード」
[idx]["REC_POINT"]　→　配列内のidx番目の見積伝票ヘッダデータの「入荷ポイント」
[idx]["DOC_NUM_FI"]　→　配列内のidx番目の見積伝票ヘッダデータの 「ドキュメンタリクレジット処理: 内部番号」
[idx]["CSTCNDGRP1"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先条件グループ１」
[idx]["CSTCNDGRP2"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先条件グループ２」
[idx]["CSTCNDGRP3"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先条件グループ３」
[idx]["CSTCNDGRP4"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先条件グループ４」
[idx]["CSTCNDGRP5"]　→　配列内のidx番目の見積伝票ヘッダデータの「得意先条件グループ５」
[idx]["DLV_TIME"]　→　配列内のidx番目の見積伝票ヘッダデータの「契約出荷期間」
[idx]["CURRENCY"]　→　配列内のidx番目の見積伝票ヘッダデータの「販売伝票通貨」
[idx]["CURR_ISO"]　→　配列内のidx番目の見積伝票ヘッダデータの「ISO コード通貨」
[idx]["CREATED_BY"]　→　配列内のidx番目の見積伝票ヘッダデータの「オブジェクト登録者名」
[idx]["TAXDEP_CTY"]　→　配列内のidx番目の見積伝票ヘッダデータの「税出荷国」
[idx]["TAXDST_CTY"]　→　配列内のidx番目の見積伝票ヘッダデータの「税仕向国」
[idx]["EUTRI_DEAL"]　→　配列内のidx番目の見積伝票ヘッダデータの「フラグ: EC 内三角取引」
[idx]["MAST_CONTR"]　→　配列内のidx番目の見積伝票ヘッダデータの「グループマスタ契約番号」
[idx]["REF_PROC"]　→　配列内のidx番目の見積伝票ヘッダデータの「参照限定条件: 決定区分」
[idx]["CHKPRTAUTH"]　→　配列内のidx番目の見積伝票ヘッダデータの「取引先権限チェック」
[idx]["CMLQTY_DAT"]　→　配列内のidx番目の見積伝票ヘッダデータの「累積出荷数量日付」
[idx]["VERSION"]　→　配列内のidx番目の見積伝票ヘッダデータの「販売伝票バージョン番号」
[idx]["NOTIF_NO"]　→　配列内のidx番目の見積伝票ヘッダデータの「通知番号」
[idx]["WBS_ELEM"]　→　配列内のidx番目の見積伝票ヘッダデータの「WBS 要素」
[idx]["EXCH_RATE_FI_V"]　→　配列内のidx番目の見積伝票ヘッダデータの 「FI 転記の換算レート (間接相場)」
[idx]["EXCHG_RATE_V"]　→　配列内のidx番目の見積伝票ヘッダデータの 「価格設定/統計の換算レート (間接引用)」
[idx]["FKK_CONACCT"]　→　配列内のidx番目の見積伝票ヘッダデータの「長さ 12 の文字項目」
[idx]["CAMPAIGN"]　→　配列内のidx番目の見積伝票ヘッダデータの 「総括プロジェクト計画: 外部 R/3 システムの GUID」
[idx]["DOC_CLASS"]　→　配列内のidx番目の見積伝票ヘッダデータの 「リリースおよびトランザクション管理を備えた元システム」
[idx]["H_CURR"]　→　配列内のidx番目の見積伝票ヘッダデータの「通貨コード」
[idx]["H_CURR_ISO"]　→　配列内のidx番目の見積伝票ヘッダデータの「ISO 通貨コード」
[idx]["SHIP_TYPE"]　→　配列内のidx番目の見積伝票ヘッダデータの「出荷タイプ」
[idx]["S_PROC_IND"]　→　配列内のidx番目の見積伝票ヘッダデータの「特別処理区分」
[idx]["REF_DOC_L_LONG"]　→　配列内のidx番目の見積伝票ヘッダデータの 「参照伝票番号 (依存関係についてはテキスト (長) を参照)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationHeaderInX

Object getQuotationHeaderInX ()

ヘッダデータチェックボックスを取得します。
返却値
Object ヘッダデータチェックボックス

ヘッダデータチェックボックスオブジェクトの構成は以下のとおりです。
UPDATEFLAG 更新区分 (String)
DOC_TYPE 関連ユーザデータ項目の更新情報 (String)
COLLECT_NO 関連ユーザデータ項目の更新情報 (String)
SALES_ORG 関連ユーザデータ項目の更新情報 (String)
DISTR_CHAN 関連ユーザデータ項目の更新情報 (String)
DIVISION 関連ユーザデータ項目の更新情報 (String)
SALES_GRP 関連ユーザデータ項目の更新情報 (String)
SALES_OFF 関連ユーザデータ項目の更新情報 (String)
REQ_DATE_H 関連ユーザデータ項目の更新情報 (String)
DATE_TYPE 関連ユーザデータ項目の更新情報 (String)
PURCH_DATE 関連ユーザデータ項目の更新情報 (String)
PO_METHOD 関連ユーザデータ項目の更新情報 (String)
PO_SUPPLEM 関連ユーザデータ項目の更新情報 (String)
REF_1 関連ユーザデータ項目の更新情報 (String)
NAME 関連ユーザデータ項目の更新情報 (String)
TELEPHONE 関連ユーザデータ項目の更新情報 (String)
PRICE_GRP 関連ユーザデータ項目の更新情報 (String)
CUST_GROUP 関連ユーザデータ項目の更新情報 (String)
SALES_DIST 関連ユーザデータ項目の更新情報 (String)
PRICE_LIST 関連ユーザデータ項目の更新情報 (String)
INCOTERMS1 関連ユーザデータ項目の更新情報 (String)
INCOTERMS2 関連ユーザデータ項目の更新情報 (String)
PMNTTRMS 関連ユーザデータ項目の更新情報 (String)
DLV_BLOCK 関連ユーザデータ項目の更新情報 (String)
BILL_BLOCK 関連ユーザデータ項目の更新情報 (String)
ORD_REASON 関連ユーザデータ項目の更新情報 (String)
COMPL_DLV 関連ユーザデータ項目の更新情報 (String)
PRICE_DATE 関連ユーザデータ項目の更新情報 (String)
QT_VALID_F 関連ユーザデータ項目の更新情報 (String)
QT_VALID_T 関連ユーザデータ項目の更新情報 (String)
CT_VALID_F 関連ユーザデータ項目の更新情報 (String)
CT_VALID_T 関連ユーザデータ項目の更新情報 (String)
CUST_GRP1 関連ユーザデータ項目の更新情報 (String)
CUST_GRP2 関連ユーザデータ項目の更新情報 (String)
CUST_GRP3 関連ユーザデータ項目の更新情報 (String)
CUST_GRP4 関連ユーザデータ項目の更新情報 (String)
CUST_GRP5 関連ユーザデータ項目の更新情報 (String)
PURCH_NO_C 関連ユーザデータ項目の更新情報 (String)
PURCH_NO_S 関連ユーザデータ項目の更新情報 (String)
PO_DAT_S 関連ユーザデータ項目の更新情報 (String)
PO_METH_S 関連ユーザデータ項目の更新情報 (String)
REF_1_S 関連ユーザデータ項目の更新情報 (String)
SD_DOC_CAT 関連ユーザデータ項目の更新情報 (String)
DOC_DATE 関連ユーザデータ項目の更新情報 (String)
WAR_DATE 関連ユーザデータ項目の更新情報 (String)
SHIP_COND 関連ユーザデータ項目の更新情報 (String)
PP_SEARCH 関連ユーザデータ項目の更新情報 (String)
DUN_COUNT 関連ユーザデータ項目の更新情報 (String)
DUN_DATE 関連ユーザデータ項目の更新情報 (String)
DLVSCHDUSE 関連ユーザデータ項目の更新情報 (String)
PLDLVSTYP 関連ユーザデータ項目の更新情報 (String)
REF_DOC 関連ユーザデータ項目の更新情報 (String)
COMP_CDE_B 関連ユーザデータ項目の更新情報 (String)
ALTTAX_CLS 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS2 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS3 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS4 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS5 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS6 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS7 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS8 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS9 関連ユーザデータ項目の更新情報 (String)
REF_DOC_L 関連ユーザデータ項目の更新情報 (String)
ASS_NUMBER 関連ユーザデータ項目の更新情報 (String)
REFDOC_CAT 関連ユーザデータ項目の更新情報 (String)
ORDCOMB_IN 関連ユーザデータ項目の更新情報 (String)
BILL_SCHED 関連ユーザデータ項目の更新情報 (String)
INVO_SCHED 関連ユーザデータ項目の更新情報 (String)
MN_INVOICE 関連ユーザデータ項目の更新情報 (String)
EXRATE_FI 関連ユーザデータ項目の更新情報 (String)
ADD_VAL_DY 関連ユーザデータ項目の更新情報 (String)
FIX_VAL_DY 関連ユーザデータ項目の更新情報 (String)
PYMT_METH 関連ユーザデータ項目の更新情報 (String)
ACCNT_ASGN 関連ユーザデータ項目の更新情報 (String)
EXCHG_RATE 関連ユーザデータ項目の更新情報 (String)
BILL_DATE 関連ユーザデータ項目の更新情報 (String)
SERV_DATE 関連ユーザデータ項目の更新情報 (String)
DUNN_KEY 関連ユーザデータ項目の更新情報 (String)
DUNN_BLOCK 関連ユーザデータ項目の更新情報 (String)
PROMOTION 関連ユーザデータ項目の更新情報 (String)
PMTGAR_PRO 関連ユーザデータ項目の更新情報 (String)
DEPARTM_NO 関連ユーザデータ項目の更新情報 (String)
REC_POINT 関連ユーザデータ項目の更新情報 (String)
POITM_NO_S 関連ユーザデータ項目の更新情報 (String)
DOC_NUM_FI 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP1 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP2 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP3 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP4 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP5 関連ユーザデータ項目の更新情報 (String)
DLV_TIME 関連ユーザデータ項目の更新情報 (String)
CURRENCY 関連ユーザデータ項目の更新情報 (String)
TAXDEP_CTY 関連ユーザデータ項目の更新情報 (String)
TAXDST_CTY 関連ユーザデータ項目の更新情報 (String)
EUTRI_DEAL 関連ユーザデータ項目の更新情報 (String)
MAST_CONTR 関連ユーザデータ項目の更新情報 (String)
REF_PROC 関連ユーザデータ項目の更新情報 (String)
CHKPRTAUTH 関連ユーザデータ項目の更新情報 (String)
CMLQTY_DAT 関連ユーザデータ項目の更新情報 (String)
VERSION 関連ユーザデータ項目の更新情報 (String)
NOTIF_NO 関連ユーザデータ項目の更新情報 (String)
WBS_ELEM 関連ユーザデータ項目の更新情報 (String)
EXCH_RATE_FI_V 関連ユーザデータ項目の更新情報 (String)
EXCHG_RATE_V 関連ユーザデータ項目の更新情報 (String)
FKK_CONACCT 関連ユーザデータ項目の更新情報 (String)
CAMPAIGN 関連ユーザデータ項目の更新情報 (String)
DOC_CLASS 関連ユーザデータ項目の更新情報 (String)
H_CURR 関連ユーザデータ項目の更新情報 (String)
SHIP_TYPE 関連ユーザデータ項目の更新情報 (String)
S_PROC_IND 関連ユーザデータ項目の更新情報 (String)

ヘッダデータチェックボックスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["LOG_SYSTEM"]　→　配列内のidx番目のヘッダデータチェックボックスの「論理システム」
[idx]["UPDATEFLAG"]　→　配列内のidx番目のヘッダデータチェックボックスの「更新区分」
[idx]["DOC_TYPE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["COLLECT_NO"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SALES_ORG"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DISTR_CHAN"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DIVISION"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SALES_GRP"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SALES_OFF"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REQ_DATE_H"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DATE_TYPE"]　→idx　配列内の番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PURCH_DATE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_METHOD"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_SUPPLEM"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_1"]　→　配列内のidx番目のヘッダデータチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["NAME"]　→　配列内のidx番目のヘッダデータチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["TELEPHONE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_GRP"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CUST_GROUP"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SALES_DIST"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_LIST"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INCOTERMS1"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INCOTERMS2"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PMNTTRMS"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLV_BLOCK"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_BLOCK"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ORD_REASON"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["COMPL_DLV"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_DATE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["QT_VALID_F"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["QT_VALID_T"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CT_VALID_F"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CT_VALID_T"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CUST_GRP1"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CUST_GRP2"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CUST_GRP3"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CUST_GRP4"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CUST_GRP5"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PURCH_NO_C"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PURCH_NO_S"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_DAT_S"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_METH_S"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_1_S"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SD_DOC_CAT"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DOC_DATE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["WAR_DATE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SHIP_COND"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PP_SEARCH"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DUN_COUNT"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DUN_DATE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLVSCHDUSE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PLDLVSTYP"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_DOC"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["COMP_CDE_B"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ALTTAX_CLS"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS2"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS3"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS4"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS5"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS6"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS7"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS8"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS9"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_DOC_L"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ASS_NUMBER"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REFDOC_CAT"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ORDCOMB_IN"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_SCHED"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INVO_SCHED"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MN_INVOICE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXRATE_FI"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ADD_VAL_DY"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FIX_VAL_DY"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PYMT_METH"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ACCNT_ASGN"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCHG_RATE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_DATE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SERV_DATE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DUNN_KEY"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DUNN_BLOCK"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PROMOTION"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PMTGAR_PRO"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DEPARTM_NO"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REC_POINT"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["POITM_NO_S"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DOC_NUM_FI"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP1"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP2"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP3"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP4"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP5"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLV_TIME"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CURRENCY"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAXDEP_CTY"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAXDST_CTY"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EUTRI_DEAL"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAST_CONTR"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_PROC"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CHKPRTAUTH"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CMLQTY_DAT"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["VERSION"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["NOTIF_NO"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["WBS_ELEM"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCH_RATE_FI_V"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCHG_RATE_V"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FKK_CONACCT"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CAMPAIGN"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DOC_CLASS"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["H_CURR"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SHIP_TYPE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["S_PROC_IND"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationItemsInList

Array getQuotationItemsInList ()

明細データを取得します。
返却値
Array 明細データ

明細データオブジェクトの構成は以下のとおりです。
ITM_NUMBER 販売伝票明細 (String)
HG_LV_ITEM 上位レベル明細 (String)
PO_ITM_NO 元となる購買発注の明細番号 (String)
MATERIAL 品目コード (String)
ALT_TO_ITM 代替明細 (String)
CUST_MAT22 得意先品目コード (無効) (String)
BATCH ロット番号 (String)
DLV_GROUP 出荷グループ (明細一括出荷) (String)
PART_DLV 明細レベルの分納納入 (String)
REASON_REJ 見積および受注の拒否理由 (String)
BILL_BLOCK ブロック (String)
BILL_DATE 請求索引および印刷に対する請求日 (String)
PLANT プラント (String)
STORE_LOC 保管場所 (String)
TARGET_QTY 目標数量（販売単位） (String)
TARGET_QU 目標数量 (数量単位) (String)
T_UNIT_ISO 目標数量単位 (ISO コード) (String)
ITEM_CATEG 明細カテゴリ (販売伝票) (String)
SHORT_TEXT テキスト (短): 受注明細 (String)
PRC_GROUP1 品目グループ 1 (String)
PRC_GROUP2 品目グループ 2 (String)
PRC_GROUP3 品目グループ 3 (String)
PRC_GROUP4 品目グループ 4 (String)
PRC_GROUP5 品目グループ 5 (String)
PROD_HIERA 品目階層 (String)
MATL_GROUP 品目グループ (String)
PURCH_NO_C 出荷先発注番号 (String)
PURCH_DATE 得意先発注日付 (String)
PO_METHOD 得意先発注タイプ (String)
REF_1 得意先/仕入先の内部参照コード (String)
PURCH_NO_S 出荷先の得意先発注番号 (String)
PO_DAT_S 出荷先の出荷先発注日付 (String)
PO_METH_S 出荷先の出荷先発注タイプ (String)
REF_1_S 出荷先文字 (String)
POITM_NO_S 元となる購買発注の明細番号 (String)
PRICE_GRP 価格グループ (得意先) (String)
CUST_GROUP 得意先グループ (String)
SALES_DIST 販売地域 (String)
PRICE_LIST 価格表タイプ (String)
INCOTERMS1 インコタームズ (1) (String)
INCOTERMS2 インコタームズ 2 (String)
ORDCOMP_IN 受注結合出荷区分 (String)
BILL_SCHED 請求日程 (稼働日カレンダ指定) (String)
INVO_SCHED 請求書一覧日程 (稼働日カレンダ指定) (String)
MN_INVOICE マニュアル請求書更新 (String)
EX_RATE_FI FI 転記の換算レート (直接相場) (String)
ADD_VAL_DY 有効日からの日数 (String)
FIX_VAL_DY 有効日日付 (String)
PMNTTRMS 支払条件キー (String)
PYMT_METH 支払方法 (String)
ACCNT_ASGN 得意先の勘定設定グループ (String)
EXCHG_RATE 価格設定/統計の換算レート (直接引用) (String)
PRICE_DATE 価格設定/外貨換算の実行日付 (String)
SERV_DATE サービス提供日 (String)
DUNN_KEY 督促処理キー (String)
DUNN_BLOCK 督促処理保留 (String)
PROMOTION プロモーション (String)
PMTGAR_PRO 支払保証決定表 (String)
DOC_NUM_FI ドキュメンタリクレジット処理: 内部番号 (String)
DEPARTM_NO 部門コード (String)
REC_POINT 入荷ポイント (String)
CSTCNDGRP1 得意先条件グループ１ (String)
CSTCNDGRP2 得意先条件グループ２ (String)
CSTCNDGRP3 得意先条件グループ３ (String)
CSTCNDGRP4 得意先条件グループ４ (String)
CSTCNDGRP5 得意先条件グループ５ (String)
DLV_TIME 契約出荷期間 (String)
SALES_UNIT 販売単位 (String)
S_UNIT_ISO 単位の ISO コード (String)
TRG_QTY_NO 販売単位から基本単位への換算係数 (String)
TRGQTY_DEN 販売単位から基本単位への換算係数 (String)
RNDDLV_QTY 丸め数量: 出荷 (String)
MAXDEVAMNT 数量に関する許容偏差 (絶対値) (String)
MAXDEVPER 数量に関する許容偏差 (%) (String)
MAXDEV_DAY シフト所要日数 (String)
USAGE_IND 未使用 - 予約長 3 (String)
FIXED_QUAN 数量固定区分 (String)
UNLMT_DLV 区分: 無制限過剰納入可能 (String)
OVERDLVTOL 過剰納入許容範囲 (String)
UNDDLV_TOL 不足納入許容範囲リミット (String)
DIVISION 製品部門 (String)
SALQTYNUM 販売数量単位から基本数量単位への変換係数の分子 (String)
SALQTYDEN 販売数量単位を SKU に換算するための分母 (除数) (String)
GROSS_WGHT 明細の総重量 (String)
NET_WEIGHT 明細の正味重量 (String)
UNTOF_WGHT 重量単位 (String)
UNOF_WTISO ISO コードでの重量単位 (String)
VOLUME 明細の総数量 (String)
VOLUNIT 容積単位 (String)
VOLUNITISO ISO コードでの容積単位 (String)
DLV_PRIO 出荷優先順位 (String)
SHIP_POINT 出荷ポイント/入荷ポイント (String)
ROUTE 輸送経路 (String)
CREATED_BY オブジェクト登録者名 (String)
TAX_CLASS1 品目の税分類 (String)
TAX_CLASS2 品目の税分類 (String)
TAX_CLASS3 品目の税分類 (String)
TAX_CLASS4 品目の税分類 (String)
TAX_CLASS5 品目の税分類 (String)
TAX_CLASS6 品目の税分類 (String)
TAX_CLASS7 品目の税分類 (String)
TAX_CLASS8 品目の税分類 (String)
TAX_CLASS9 品目の税分類 (String)
MAT_PR_GRP 品目価格設定グループ (String)
VAL_TYPE 評価タイプ (String)
FIXDAT_QTY 納期と出荷数量の固定 (String)
BOMEXPL_NO BOM 展開番号 (String)
RESANALKEY 結果分析キー (String)
REQMTS_TYP 所要量タイプ (String)
NO_GR_POST 得意先が入庫を転記していません (String)
BUS_TRANST 貿易管理の取引タイプ (String)
OVERHD_KEY 間接費キー (String)
CSTG_SHEET 原価計算表 (String)
MATFRGTGRP 品目運賃グループ (String)
PLDLVSHDIN 出荷計画に関する指示 (String)
SEQ_NO KANBAN/連続番号 (String)
BIL_FORM 請求書式 (String)
DLI_PROFIL 動的明細プロセッサプロファイル (String)
REV_TYPE 収益承認カテゴリ (String)
BEGDEM_PER 見越期間の提案開始日付 (String)
PR_REF_MAT 価格設定参照品目 (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)
ORDER_PROB 明細の受注可能性 (String)
MAX_PL_DLV 明細ごとの分割納入可能な最大回数 (String)
CFOP_CODE CFOP code and extension (old 5 char version) (String)
TAXLAWICMS 税法: ICMS (String)
TAXLAWIPI 税法: IPI (String)
SD_TAXCODE 0 (String)
ASSORT_MOD 品揃モジュール (String)
COMP_QUANT 構成品目数量 (String)
TARGET_VAL BAPI の通貨額 (小数点以下９桁) (String)
CURRENCY 販売伝票通貨 (String)
CURR_ISO ISO コード通貨 (String)
PROFIT_CTR 利益センタ (String)
ORDERID 指図番号 (String)
WBS_ELEM WBS 要素 (String)
DEPREC_PER ドキュメンタリクレジット処理 に関する償却率 (%) (String)
REF_DOC 参照伝票番号 (String)
REF_DOC_IT 参照明細番号 (String)
REF_DOC_CA 先行販売管理伝票の伝票カテゴリ (String)
CUST_MAT35 得意先品目 (String)
EXCH_RATE_FI_V FI 転記の換算レート (間接相場) (String)
EXCHG_RATE_V 価格設定/統計の換算レート (間接引用) (String)
ITEMGUID_ATP ATP: 暗号 - DELNR および DELPS (String)
VAL_CONTR 金額契約番号 (String)
VAL_CON_I 金額契約明細 (String)
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)
MAT_EXT 項目 MATERIAL の品目コード (長) (今後のリリースで開発) (String)
MAT_GUID 項目 MATERIAL の外部 GUID (今後のリリースで開発) (String)
MAT_VERS 項目 MATERIAL のバージョン番号 (今後のリリースで開発) (String)
P_MAT_EXT 項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発) (String)
P_MAT_GUID 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発) (String)
P_MAT_VERS 項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発) (String)
FUNC_AREA 機能領域 (String)
ALTERN_BOM 代替 BOM (String)
FKK_CONACCT 長さ 12 の文字項目 (String)
EAN_UPC 国際商品コード (EAN/UPC) (String)
PRODCAT 製品カタログ番号 (String)
SHIP_TYPE 出荷タイプ (String)
S_PROC_IND 特別処理区分 (String)
FUNC_AREA_LONG 機能領域 (String)
BILL_REL 請求関連 (CRM) (String)
VW_UEPOS 上位レベル明細用途 ID (String)
CAMPAIGN 総括プロジェクト計画: 外部 R/3 システムの GUID (String)
DLVSCHDUSE 用途区分 (String)
CFOP_LONG CFOP code and extension (String)
SELECTION 選択 ID (永続) (String)
MAT_ENTRD 入力品目 (String)
LOG_SYSTEM_OWN 論理システム (String)
ITM_TYPE_USAGE 明細用途 (String)

明細データオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の明細データの「販売伝票明細」
[idx]["HG_LV_ITEM"]　→　配列内のidx番目の明細データの「上位レベル明細」
[idx]["PO_ITM_NO"]　→　配列内のidx番目の明細データの「元となる購買発注の明細番号」
[idx]["MATERIAL"]　→　配列内のidx番目の明細データの「品目コード」
[idx]["ALT_TO_ITM"]　→　配列内のidx番目の明細データの「代替明細」
[idx]["CUST_MAT22"]　→　配列内のidx番目の明細データの「得意先品目コード (無効)」
[idx]["BATCH"]　→　配列内のidx番目の明細データの「ロット番号」
[idx]["DLV_GROUP"]　→　配列内のidx番目の明細データの「出荷グループ (明細一括出荷)」
[idx]["PART_DLV"]　→　配列内のidx番目の明細データの「明細レベルの分納納入」
[idx]["REASON_REJ"]　→　配列内のidx番目の明細データの「見積および受注の拒否理由」
[idx]["BILL_BLOCK"]　→　配列内のidx番目の明細データの「ブロック」
[idx]["BILL_DATE"]　→　配列内のidx番目の明細データの「請求索引および印刷に対する請求日」
[idx]["PLANT"]　→　配列内のidx番目の明細データの「プラント」
[idx]["STORE_LOC"]　→　配列内のidx番目の明細データの「保管場所」
[idx]["TARGET_QTY"]　→　配列内のidx番目の明細データの「目標数量（販売単位）」
[idx]["TARGET_QU"]　→　配列内のidx番目の明細データの「目標数量 (数量単位)」
[idx]["T_UNIT_ISO"]　→　配列内のidx番目の明細データの「目標数量単位 (ISO コード)」
[idx]["ITEM_CATEG"]　→　配列内のidx番目の明細データの「明細カテゴリ (販売伝票)」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の明細データの「テキスト (短): 受注明細」
[idx]["PRC_GROUP1"]　→　配列内のidx番目の明細データの「品目グループ 1」
[idx]["PRC_GROUP2"]　→　配列内のidx番目の明細データの「品目グループ 2」
[idx]["PRC_GROUP3"]　→　配列内のidx番目の明細データの「品目グループ 3」
[idx]["PRC_GROUP4"]　→　配列内のidx番目の明細データの「品目グループ 4」
[idx]["PRC_GROUP5"]　→　配列内のidx番目の明細データの「品目グループ 5」
[idx]["PROD_HIERA"]　→　配列内のidx番目の明細データの「品目階層」
[idx]["MATL_GROUP"]　→　配列内のidx番目の明細データの「品目グループ」
[idx]["PURCH_NO_C"]　→　配列内のidx番目の明細データの「出荷先発注番号」
[idx]["PURCH_DATE"]　→　配列内のidx番目の明細データの「得意先発注日付」
[idx]["PO_METHOD"]　→　配列内のidx番目の明細データの「得意先発注タイプ」
[idx]["REF_1"]　→　配列内のidx番目の明細データの「得意先/仕入先の内部参照コード」
[idx]["PURCH_NO_S"]　→　配列内のidx番目の明細データの「出荷先の得意先発注番号」
[idx]["PO_DAT_S"]　→　配列内のidx番目の明細データの「出荷先の出荷先発注日付」
[idx]["PO_METH_S"]　→　配列内のidx番目の明細データの「出荷先の出荷先発注タイプ」
[idx]["REF_1_S"]　→　配列内のidx番目の明細データの「出荷先文字」
[idx]["POITM_NO_S"]　→　配列内のidx番目の明細データの「元となる購買発注の明細番号」
[idx]["PRICE_GRP"]　→　配列内のidx番目の明細データの「価格グループ (得意先)」
[idx]["CUST_GROUP"]　→　配列内のidx番目の明細データの「得意先グループ」
[idx]["SALES_DIST"]　→　配列内のidx番目の明細データの「販売地域」
[idx]["PRICE_LIST"]　→　配列内のidx番目の明細データの「価格表タイプ」
[idx]["INCOTERMS1"]　→　配列内のidx番目の明細データの「インコタームズ (1)」
[idx]["INCOTERMS2"]　→　配列内のidx番目の明細データの「インコタームズ 2」
[idx]["ORDCOMP_IN"]　→　配列内のidx番目の明細データの「受注結合出荷区分」
[idx]["BILL_SCHED"]　→　配列内のidx番目の明細データの「請求日程 (稼働日カレンダ指定)」
[idx]["INVO_SCHED"]　→　配列内のidx番目の明細データの「請求書一覧日程 (稼働日カレンダ指定)」
[idx]["MN_INVOICE"]　→　配列内のidx番目の明細データの「マニュアル請求書更新」
[idx]["EX_RATE_FI"]　→　配列内のidx番目の明細データの「FI 転記の換算レート (直接相場)」
[idx]["ADD_VAL_DY"]　→　配列内のidx番目の明細データの「有効日からの日数」
[idx]["FIX_VAL_DY"]　→　配列内のidx番目の明細データの「有効日日付」
[idx]["PMNTTRMS"]　→　配列内のidx番目の明細データの「支払条件キー」
[idx]["PYMT_METH"]　→　配列内のidx番目の明細データの「支払方法」
[idx]["ACCNT_ASGN"]　→　配列内のidx番目の明細データの「得意先の勘定設定グループ」
[idx]["EXCHG_RATE"]　→　配列内のidx番目の明細データの 「価格設定/統計の換算レート (直接引用)」
[idx]["PRICE_DATE"]　→　配列内のidx番目の明細データの「価格設定/外貨換算の実行日付」
[idx]["SERV_DATE"]　→　配列内のidx番目の明細データの「サービス提供日」
[idx]["DUNN_KEY"]　→　配列内のidx番目の明細データの「督促処理キー」
[idx]["DUNN_BLOCK"]　→　配列内のidx番目の明細データの「督促処理保留」
[idx]["PROMOTION"]　→　配列内のidx番目の明細データの「プロモーション」
[idx]["PMTGAR_PRO"]　→　配列内のidx番目の明細データの「支払保証決定表」
[idx]["DOC_NUM_FI"]　→　配列内のidx番目の明細データの 「ドキュメンタリクレジット処理: 内部番号」
[idx]["DEPARTM_NO"]　→　配列内のidx番目の明細データの「部門コード」
[idx]["REC_POINT"]　→　配列内のidx番目の明細データの「入荷ポイント」
[idx]["CSTCNDGRP1"]　→　配列内のidx番目の明細データの「得意先条件グループ１」
[idx]["CSTCNDGRP2"]　→　配列内のidx番目の明細データの「得意先条件グループ２」
[idx]["CSTCNDGRP3"]　→　配列内のidx番目の明細データの「得意先条件グループ３」
[idx]["CSTCNDGRP4"]　→　配列内のidx番目の明細データの「得意先条件グループ４」
[idx]["CSTCNDGRP5"]　→　配列内のidx番目の明細データの「得意先条件グループ５」
[idx]["DLV_TIME"]　→　配列内のidx番目の明細データの「契約出荷期間」
[idx]["SALES_UNIT"]　→　配列内のidx番目の明細データの「販売単位」
[idx]["S_UNIT_ISO"]　→　配列内のidx番目の明細データの「単位の ISO コード」
[idx]["TRG_QTY_NO"]　→　配列内のidx番目の明細データの「販売単位から基本単位への換算係数」
[idx]["TRGQTY_DEN"]　→　配列内のidx番目の明細データの「販売単位から基本単位への換算係数」
[idx]["RNDDLV_QTY"]　→　配列内のidx番目の明細データの「丸め数量: 出荷」
[idx]["MAXDEVAMNT"]　→　配列内のidx番目の明細データの「数量に関する許容偏差 (絶対値)」
[idx]["MAXDEVPER"]　→　配列内のidx番目の明細データの「数量に関する許容偏差 (%)」
[idx]["MAXDEV_DAY"]　→　配列内のidx番目の明細データの「シフト所要日数」
[idx]["USAGE_IND"]　→　配列内のidx番目の明細データの「未使用 - 予約長 3」
[idx]["FIXED_QUAN"]　→　配列内のidx番目の明細データの「数量固定区分」
[idx]["UNLMT_DLV"]　→　配列内のidx番目の明細データの「区分: 無制限過剰納入可能」
[idx]["OVERDLVTOL"]　→　配列内のidx番目の明細データの「過剰納入許容範囲」
[idx]["UNDDLV_TOL"]　→　配列内のidx番目の明細データの「不足納入許容範囲リミット」
[idx]["DIVISION"]　→　配列内のidx番目の明細データの「製品部門」
[idx]["SALQTYNUM"]　→　配列内のidx番目の明細データの 「販売数量単位から基本数量単位への変換係数の分子」
[idx]["SALQTYDEN"]　→　配列内のidx番目の明細データの 「販売数量単位を SKU に換算するための分母 (除数)」
[idx]["GROSS_WGHT"]　→　配列内のidx番目の明細データの「明細の総重量」
[idx]["NET_WEIGHT"]　→　配列内のidx番目の明細データの「明細の正味重量」
[idx]["UNTOF_WGHT"]　→　配列内のidx番目の明細データの「重量単位」
[idx]["UNOF_WTISO"]　→　配列内のidx番目の明細データの「ISO コードでの重量単位」
[idx]["VOLUME"]　→　配列内のidx番目の明細データの「明細の総数量」
[idx]["VOLUNIT"]　→　配列内のidx番目の明細データの「容積単位」
[idx]["VOLUNITISO"]　→　配列内のidx番目の明細データの「ISO コードでの容積単位」
[idx]["DLV_PRIO"]　→　配列内のidx番目の明細データの「出荷優先順位」
[idx]["SHIP_POINT"]　→　配列内のidx番目の明細データの「出荷ポイント/入荷ポイント」
[idx]["ROUTE"]　→　配列内のidx番目の明細データの「輸送経路」
[idx]["CREATED_BY"]　→　配列内のidx番目の明細データの「オブジェクト登録者名」
[idx]["TAX_CLASS1"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS2"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS3"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS4"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS5"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS6"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS7"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS8"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS9"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["MAT_PR_GRP"]　→　配列内のidx番目の明細データの「品目価格設定グループ」
[idx]["VAL_TYPE"]　→　配列内のidx番目の明細データの「評価タイプ」
[idx]["FIXDAT_QTY"]　→　配列内のidx番目の明細データの「納期と出荷数量の固定」
[idx]["BOMEXPL_NO"]　→　配列内のidx番目の明細データの「BOM 展開番号」
[idx]["RESANALKEY"]　→　配列内のidx番目の明細データの「結果分析キー」
[idx]["REQMTS_TYP"]　→　配列内のidx番目の明細データの「所要量タイプ」
[idx]["NO_GR_POST"]　→　配列内のidx番目の明細データの「得意先が入庫を転記していません」
[idx]["BUS_TRANST"]　→　配列内のidx番目の明細データの「貿易管理の取引タイプ」
[idx]["OVERHD_KEY"]　→　配列内のidx番目の明細データの「間接費キー」
[idx]["CSTG_SHEET"]　→　配列内のidx番目の明細データの「原価計算表」
[idx]["MATFRGTGRP"]　→　配列内のidx番目の明細データの「品目運賃グループ」
[idx]["PLDLVSHDIN"]　→　配列内のidx番目の明細データの「出荷計画に関する指示」
[idx]["SEQ_NO"]　→　配列内のidx番目の明細データの「KANBAN/連続番号」
[idx]["BIL_FORM"]　→　配列内のidx番目の明細データの「請求書式」
[idx]["DLI_PROFIL"]　→　配列内のidx番目の明細データの「動的明細プロセッサプロファイル」
[idx]["REV_TYPE"]　→　配列内のidx番目の明細データの「収益承認カテゴリ」
[idx]["BEGDEM_PER"]　→　配列内のidx番目の明細データの「見越期間の提案開始日付」
[idx]["PR_REF_MAT"]　→　配列内のidx番目の明細データの「価格設定参照品目」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の明細データの「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の明細データの「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の明細データの「論理システム」
[idx]["ORDER_PROB"]　→　配列内のidx番目の明細データの「明細の受注可能性」
[idx]["MAX_PL_DLV"]　→　配列内のidx番目の明細データの「明細ごとの分割納入可能な最大回数」
[idx]["CFOP_CODE"]　→　配列内のidx番目の明細データの 「CFOP code and extension (old 5 char version)」
[idx]["TAXLAWICMS"]　→　配列内のidx番目の明細データの「税法: ICMS」
[idx]["TAXLAWIPI"]　→　配列内のidx番目の明細データの「税法: IPI」
[idx]["SD_TAXCODE"]　→　配列内のidx番目の明細データの「0」
[idx]["ASSORT_MOD"]　→　配列内のidx番目の明細データの「品揃モジュール」
[idx]["COMP_QUANT"]　→　配列内のidx番目の明細データの「構成品目数量」
[idx]["TARGET_VAL"]　→　配列内のidx番目の明細データの「BAPI の通貨額 (小数点以下９桁)」
[idx]["CURRENCY"]　→　配列内のidx番目の明細データの「販売伝票通貨」
[idx]["CURR_ISO"]　→　配列内のidx番目の明細データの「ISO コード通貨」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の明細データの「利益センタ」
[idx]["ORDERID"]　→　配列内のidx番目の明細データの「指図番号」
[idx]["WBS_ELEM"]　→　配列内のidx番目の明細データの「WBS 要素」
[idx]["DEPREC_PER"]　→　配列内のidx番目の明細データの 「ドキュメンタリクレジット処理に関する償却率 (%)」
[idx]["REF_DOC"]　→　配列内のidx番目の明細データの「参照伝票番号」
[idx]["REF_DOC_IT"]　→　配列内のidx番目の明細データの「参照明細番号」
[idx]["REF_DOC_CA"]　→　配列内のidx番目の明細データの「先行販売管理伝票の伝票カテゴリ」
[idx]["CUST_MAT35"]　→　配列内のidx番目の明細データの「得意先品目」
[idx]["EXCH_RATE_FI_V"]　→　配列内のidx番目の明細データの 「FI 転記の換算レート (間接相場)」
[idx]["EXCHG_RATE_V"]　→　配列内のidx番目の明細データの 「価格設定/統計の換算レート (間接引用)」
[idx]["ITEMGUID_ATP"]　→　配列内のidx番目の明細データの 「ATP: 暗号 - DELNR および DELPS」
[idx]["VAL_CONTR"]　→　配列内のidx番目の明細データの「金額契約番号」
[idx]["VAL_CON_I"]　→　配列内のidx番目の明細データの「金額契約明細」
[idx]["CONFIG_ID"]　→　配列内のidx番目の明細データの「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の明細データの「選定におけるインスタンス番号」
[idx]["MAT_EXT"]　→　配列内のidx番目の明細データの 「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["MAT_GUID"]　→　配列内のidx番目の明細データの 「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["MAT_VERS"]　→　配列内のidx番目の明細データの 「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」
[idx]["P_MAT_EXT"]　→　配列内のidx番目の明細データの 「項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)」
[idx]["P_MAT_GUID"]　→　配列内のidx番目の明細データの 「項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)」
[idx]["P_MAT_VERS"]　→　配列内のidx番目の明細データの 「項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)」
[idx]["FUNC_AREA"]　→　配列内のidx番目の明細データの「機能領域」
[idx]["ALTERN_BOM"]　→　配列内のidx番目の明細データの「代替 BOM」
[idx]["FKK_CONACCT"]　→　配列内のidx番目の明細データの「長さ 12 の文字項目」
[idx]["EAN_UPC"]　→　配列内のidx番目の明細データの「国際商品コード (EAN/UPC)」
[idx]["PRODCAT"]　→　配列内のidx番目の明細データの「製品カタログ番号」
[idx]["SHIP_TYPE"]　→　配列内のidx番目の明細データの「出荷タイプ」
[idx]["S_PROC_IND"]　→　配列内のidx番目の明細データの「特別処理区分」
[idx]["FUNC_AREA_LONG"]　→　配列内のidx番目の明細データの「機能領域」
[idx]["BILL_REL"]　→　配列内のidx番目の明細データの「請求関連 (CRM)」
[idx]["VW_UEPOS"]　→　配列内のidx番目の明細データの「上位レベル明細用途 ID」
[idx]["CAMPAIGN"]　→　配列内のidx番目の明細データの 「総括プロジェクト計画: 外部 R/3 システムの GUID」
[idx]["DLVSCHDUSE"]　→　配列内のidx番目の明細データの「用途区分」
[idx]["CFOP_LONG"]　→　配列内のidx番目の明細データの 「CFOP code and extension」
[idx]["SELECTION"]　→　配列内のidx番目の明細データの「選択 ID (永続)」
[idx]["MAT_ENTRD"]　→　配列内のidx番目の明細データの「入力品目」
[idx]["LOG_SYSTEM_OWN"]　→　配列内のidx番目の明細データの「論理システム」
[idx]["ITM_TYPE_USAGE"]　→　配列内のidx番目の明細データの「明細用途」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationItemsInXList

Array getQuotationItemsInXList ()

明細データチェックボックスを取得します。
返却値
Array 明細データチェックボックス

明細データチェックボックスオブジェクトの構成は以下のとおりです。
ITM_NUMBER 販売伝票明細 (String)
UPDATEFLAG 更新区分 (String)
HG_LV_ITEM 関連ユーザデータ項目の更新情報 (String)
PO_ITM_NO 関連ユーザデータ項目の更新情報 (String)
MATERIAL 関連ユーザデータ項目の更新情報 (String)
ALT_TO_ITM 関連ユーザデータ項目の更新情報 (String)
CUST_MAT22 関連ユーザデータ項目の更新情報 (String)
BATCH 関連ユーザデータ項目の更新情報 (String)
DLV_GROUP 関連ユーザデータ項目の更新情報 (String)
PART_DLV 関連ユーザデータ項目の更新情報 (String)
REASON_REJ 関連ユーザデータ項目の更新情報 (String)
BILL_BLOCK 関連ユーザデータ項目の更新情報 (String)
BILL_DATE 関連ユーザデータ項目の更新情報 (String)
PLANT 関連ユーザデータ項目の更新情報 (String)
STORE_LOC 関連ユーザデータ項目の更新情報 (String)
TARGET_QTY 関連ユーザデータ項目の更新情報 (String)
TARGET_QU 関連ユーザデータ項目の更新情報 (String)
T_UNIT_ISO 関連ユーザデータ項目の更新情報 (String)
ITEM_CATEG 関連ユーザデータ項目の更新情報 (String)
SHORT_TEXT 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP1 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP2 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP3 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP4 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP5 関連ユーザデータ項目の更新情報 (String)
PROD_HIERA 関連ユーザデータ項目の更新情報 (String)
MATL_GROUP 関連ユーザデータ項目の更新情報 (String)
PURCH_NO_C 関連ユーザデータ項目の更新情報 (String)
PURCH_DATE 関連ユーザデータ項目の更新情報 (String)
PO_METHOD 関連ユーザデータ項目の更新情報 (String)
REF_1 関連ユーザデータ項目の更新情報 (String)
PURCH_NO_S 関連ユーザデータ項目の更新情報 (String)
PO_DAT_S 関連ユーザデータ項目の更新情報 (String)
PO_METH_S 関連ユーザデータ項目の更新情報 (String)
REF_1_S 関連ユーザデータ項目の更新情報 (String)
POITM_NO_S 関連ユーザデータ項目の更新情報 (String)
PRICE_GRP 関連ユーザデータ項目の更新情報 (String)
CUST_GROUP 関連ユーザデータ項目の更新情報 (String)
SALES_DIST 関連ユーザデータ項目の更新情報 (String)
PRICE_LIST 関連ユーザデータ項目の更新情報 (String)
INCOTERMS1 関連ユーザデータ項目の更新情報 (String)
INCOTERMS2 関連ユーザデータ項目の更新情報 (String)
ORDCOMP_IN 関連ユーザデータ項目の更新情報 (String)
BILL_SCHED 関連ユーザデータ項目の更新情報 (String)
INVO_SCHED 関連ユーザデータ項目の更新情報 (String)
MN_INVOICE 関連ユーザデータ項目の更新情報 (String)
EX_RATE_FI 関連ユーザデータ項目の更新情報 (String)
ADD_VAL_DY 関連ユーザデータ項目の更新情報 (String)
FIX_VAL_DY 関連ユーザデータ項目の更新情報 (String)
PMNTTRMS 関連ユーザデータ項目の更新情報 (String)
PYMT_METH 関連ユーザデータ項目の更新情報 (String)
ACCNT_ASGN 関連ユーザデータ項目の更新情報 (String)
EXCHG_RATE 関連ユーザデータ項目の更新情報 (String)
PRICE_DATE 関連ユーザデータ項目の更新情報 (String)
SERV_DATE 関連ユーザデータ項目の更新情報 (String)
DUNN_KEY 関連ユーザデータ項目の更新情報 (String)
DUNN_BLOCK 関連ユーザデータ項目の更新情報 (String)
PROMOTION 関連ユーザデータ項目の更新情報 (String)
PMTGAR_PRO 関連ユーザデータ項目の更新情報 (String)
DOC_NUM_FI 関連ユーザデータ項目の更新情報 (String)
DEPARTM_NO 関連ユーザデータ項目の更新情報 (String)
REC_POINT 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP1 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP2 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP3 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP4 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP5 関連ユーザデータ項目の更新情報 (String)
DLV_TIME 関連ユーザデータ項目の更新情報 (String)
SALES_UNIT 関連ユーザデータ項目の更新情報 (String)
TRG_QTY_NO 関連ユーザデータ項目の更新情報 (String)
TRGQTY_DEN 関連ユーザデータ項目の更新情報 (String)
RNDDLV_QTY 関連ユーザデータ項目の更新情報 (String)
MAXDEVAMNT 関連ユーザデータ項目の更新情報 (String)
MAXDEVPER 関連ユーザデータ項目の更新情報 (String)
MAXDEV_DAY 関連ユーザデータ項目の更新情報 (String)
USAGE_IND 関連ユーザデータ項目の更新情報 (String)
FIXED_QUAN 関連ユーザデータ項目の更新情報 (String)
UNLMT_DLV 関連ユーザデータ項目の更新情報 (String)
OVERDLVTOL 関連ユーザデータ項目の更新情報 (String)
UNDDLV_TOL 関連ユーザデータ項目の更新情報 (String)
DIVISION 関連ユーザデータ項目の更新情報 (String)
SALQTYNUM 関連ユーザデータ項目の更新情報 (String)
SALQTYDEN 関連ユーザデータ項目の更新情報 (String)
GROSS_WGHT 関連ユーザデータ項目の更新情報 (String)
NET_WEIGHT 関連ユーザデータ項目の更新情報 (String)
UNTOF_WGHT 関連ユーザデータ項目の更新情報 (String)
VOLUME 関連ユーザデータ項目の更新情報 (String)
VOLUNIT 関連ユーザデータ項目の更新情報 (String)
DLV_PRIO 関連ユーザデータ項目の更新情報 (String)
SHIP_POINT 関連ユーザデータ項目の更新情報 (String)
ROUTE 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS1 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS2 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS3 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS4 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS5 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS6 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS7 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS8 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS9 関連ユーザデータ項目の更新情報 (String)
MAT_PR_GRP 関連ユーザデータ項目の更新情報 (String)
VAL_TYPE 関連ユーザデータ項目の更新情報 (String)
FIXDAT_QTY 関連ユーザデータ項目の更新情報 (String)
BOMEXPL_NO 関連ユーザデータ項目の更新情報 (String)
RESANALKEY 関連ユーザデータ項目の更新情報 (String)
REQMTS_TYP 関連ユーザデータ項目の更新情報 (String)
NO_GR_POST 関連ユーザデータ項目の更新情報 (String)
BUS_TRANST 関連ユーザデータ項目の更新情報 (String)
OVERHD_KEY 関連ユーザデータ項目の更新情報 (String)
CSTG_SHEET 関連ユーザデータ項目の更新情報 (String)
MATFRGTGRP 関連ユーザデータ項目の更新情報 (String)
PLDLVSHDIN 関連ユーザデータ項目の更新情報 (String)
SEQ_NO 関連ユーザデータ項目の更新情報 (String)
BIL_FORM 関連ユーザデータ項目の更新情報 (String)
DLI_PROFIL 関連ユーザデータ項目の更新情報 (String)
REV_TYPE 関連ユーザデータ項目の更新情報 (String)
BEGDEM_PER 関連ユーザデータ項目の更新情報 (String)
PR_REF_MAT 関連ユーザデータ項目の更新情報 (String)
REFOBJTYPE 関連ユーザデータ項目の更新情報 (String)
REFOBJKEY 関連ユーザデータ項目の更新情報 (String)
REFLOGSYS 関連ユーザデータ項目の更新情報 (String)
ORDER_PROB 関連ユーザデータ項目の更新情報 (String)
MAX_PL_DLV 関連ユーザデータ項目の更新情報 (String)
CFOP_CODE 関連ユーザデータ項目の更新情報 (String)
TAXLAWICMS 関連ユーザデータ項目の更新情報 (String)
TAXLAWIPI 関連ユーザデータ項目の更新情報 (String)
SD_TAXCODE 関連ユーザデータ項目の更新情報 (String)
ASSORT_MOD 関連ユーザデータ項目の更新情報 (String)
COMP_QUANT 関連ユーザデータ項目の更新情報 (String)
TARGET_VAL 関連ユーザデータ項目の更新情報 (String)
PROFIT_CTR 関連ユーザデータ項目の更新情報 (String)
ORDERID 関連ユーザデータ項目の更新情報 (String)
WBS_ELEM 関連ユーザデータ項目の更新情報 (String)
DEPREC_PER 関連ユーザデータ項目の更新情報 (String)
REF_DOC 関連ユーザデータ項目の更新情報 (String)
REF_DOC_IT 関連ユーザデータ項目の更新情報 (String)
REF_DOC_CA 関連ユーザデータ項目の更新情報 (String)
CUST_MAT35 関連ユーザデータ項目の更新情報 (String)
EXCH_RATE_FI_V 関連ユーザデータ項目の更新情報 (String)
EXCHG_RATE_V 関連ユーザデータ項目の更新情報 (String)
ITEMGUID_ATP 関連ユーザデータ項目の更新情報 (String)
VAL_CONTR 関連ユーザデータ項目の更新情報 (String)
VAL_CON_I 関連ユーザデータ項目の更新情報 (String)
CONFIG_ID 関連ユーザデータ項目の更新情報 (String)
INST_ID 関連ユーザデータ項目の更新情報 (String)
MAT_EXT 関連ユーザデータ項目の更新情報 (String)
MAT_GUID 関連ユーザデータ項目の更新情報 (String)
MAT_VERS 関連ユーザデータ項目の更新情報 (String)
P_MAT_EXT 関連ユーザデータ項目の更新情報 (String)
P_MAT_GUID 関連ユーザデータ項目の更新情報 (String)
P_MAT_VERS 関連ユーザデータ項目の更新情報 (String)
FUNC_AREA 関連ユーザデータ項目の更新情報 (String)
ALTERN_BOM 関連ユーザデータ項目の更新情報 (String)
FKK_CONACCT 関連ユーザデータ項目の更新情報 (String)
EAN_UPC 関連ユーザデータ項目の更新情報 (String)
PRODCAT 関連ユーザデータ項目の更新情報 (String)
SHIP_TYPE 関連ユーザデータ項目の更新情報 (String)
S_PROC_IND 関連ユーザデータ項目の更新情報 (String)
BILL_REL 関連ユーザデータ項目の更新情報 (String)
VW_UEPOS 関連ユーザデータ項目の更新情報 (String)
CAMPAIGN 関連ユーザデータ項目の更新情報 (String)
DLVSCHDUSE 関連ユーザデータ項目の更新情報 (String)
SELECTION 関連ユーザデータ項目の更新情報 (String)
MAT_ENTRD 関連ユーザデータ項目の更新情報 (String)
LOG_SYSTEM_OWN 関連ユーザデータ項目の更新情報 (String)
ITM_TYPE_USAGE 関連ユーザデータ項目の更新情報 (String)

明細データチェックボックスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の明細データチェックボックスの「販売伝票明細」
[idx]["UPDATEFLAG"]　→　配列内のidx番目の明細データチェックボックスの「更新区分
[idx]["HG_LV_ITEM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_ITM_NO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["MATERIAL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["ALT_TO_ITM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["CUST_MAT22"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["BATCH"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報
[idx]["DLV_GROUP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["PART_DLV"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["REASON_REJ"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_BLOCK"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_DATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PLANT"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["STORE_LOC"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TARGET_QTY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["TARGET_QU"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["T_UNIT_ISO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ITEM_CATEG"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP1"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP2"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP3"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP4"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP5"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PROD_HIERA"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["MATL_GROUP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PURCH_NO_C"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PURCH_DATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_METHOD"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_1"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["PURCH_NO_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_DAT_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_METH_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_1_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["POITM_NO_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_GRP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["CUST_GROUP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SALES_DIST"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_LIST"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INCOTERMS1"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INCOTERMS2"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ORDCOMP_IN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_SCHED"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INVO_SCHED"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MN_INVOICE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EX_RATE_FI"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ADD_VAL_DY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FIX_VAL_DY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["PMNTTRMS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["PYMT_METH"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ACCNT_ASGN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCHG_RATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_DATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SERV_DATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DUNN_KEY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DUNN_BLOCK"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PROMOTION"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PMTGAR_PRO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DOC_NUM_FI"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DEPARTM_NO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REC_POINT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP1"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP2"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["CSTCNDGRP3"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["CSTCNDGRP4"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP5"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLV_TIME"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SALES_UNIT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TRG_QTY_NO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TRGQTY_DEN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["RNDDLV_QTY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAXDEVAMNT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAXDEVPER"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAXDEV_DAY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["USAGE_IND"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FIXED_QUAN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["UNLMT_DLV"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["OVERDLVTOL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["UNDDLV_TOL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DIVISION"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["SALQTYNUM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["SALQTYDEN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["GROSS_WGHT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["NET_WEIGHT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["UNTOF_WGHT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["VOLUME"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["VOLUNIT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLV_PRIO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SHIP_POINT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ROUTE"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS1"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS2"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS3"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS4"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS5"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS6"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS7"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS8"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS9"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["MAT_PR_GRP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["VAL_TYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FIXDAT_QTY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BOMEXPL_NO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["RESANALKEY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REQMTS_TYP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["NO_GR_POST"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BUS_TRANST"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["OVERHD_KEY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTG_SHEET"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MATFRGTGRP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PLDLVSHDIN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SEQ_NO"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["BIL_FORM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLI_PROFIL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REV_TYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BEGDEM_PER"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PR_REF_MAT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REFOBJKEY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REFLOGSYS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["ORDER_PROB"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAX_PL_DLV"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CFOP_CODE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAXLAWICMS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAXLAWIPI"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SD_TAXCODE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ASSORT_MOD"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["COMP_QUANT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TARGET_VAL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ORDERID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["WBS_ELEM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DEPREC_PER"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_DOC"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_DOC_IT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_DOC_CA"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CUST_MAT35"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCH_RATE_FI_V"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCHG_RATE_V"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ITEMGUID_ATP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["VAL_CONTR"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["VAL_CON_I"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CONFIG_ID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INST_ID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_EXT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_GUID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_VERS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["P_MAT_EXT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["P_MAT_GUID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["P_MAT_VERS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FUNC_AREA"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ALTERN_BOM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FKK_CONACCT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EAN_UPC"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRODCAT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SHIP_TYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["S_PROC_IND"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_REL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["VW_UEPOS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CAMPAIGN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLVSCHDUSE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SELECTION"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_ENTRD"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["LOG_SYSTEM_OWN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ITM_TYPE_USAGE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationKeysList

Array getQuotationKeysList ()

参照キーの出力を取得します。
返却値
Array 参照キーの出力

参照キーの出力オブジェクトの構成は以下のとおりです。
REFOBJTYP オブジェクトタイプ (String)
REFOBJECT オブジェクト名 (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)
DOC_NUMBER 販売管理伝票番号 (String)
ITM_NUMBER 販売伝票明細 (String)
SCHED_LIN 納入日程行 (String)
COND_NO 伝票条件番号 (String)
CONDITEMNO 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件カウンタ (String)
COND_TYPE 条件タイプ (String)
STATUS 単一文字フラグ (String)
TINDEX 数値項目: 長さ 6 (String)
ADDRESS 住所 (String)
ABRLI 内部納入日程番号 (String)
ABART 承認タイプ (String)

参照キーの出力オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["REFOBJTYP"]　→　配列内のidx番目の参照キーの出力の「オブジェクトタイプ」
[idx]["REFOBJECT"]　→　配列内のidx番目の参照キーの出力の「オブジェクト名
[idx]["REFOBJKEY"]　→　配列内のidx番目の参照キーの出力の「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の参照キーの出力の「論理システム
[idx]["DOC_NUMBER"]　→　配列内のidx番目の参照キーの出力の「販売管理伝票番号
[idx]["ITM_NUMBER"]　→　配列内のidx番目の参照キーの出力の「販売伝票明細
[idx]["SCHED_LIN"]　→　配列内のidx番目の参照キーの出力の「納入日程行
[idx]["COND_NO"]　→　配列内のidx番目の参照キーの出力の「伝票条件番号
[idx]["CONDITEMNO"]　→　配列内のidx番目の参照キーの出力の「条件明細番号
[idx]["COND_ST_NO"]　→　配列内のidx番目の参照キーの出力の「ステップ番号
[idx]["COND_COUNT"]　→　配列内のidx番目の参照キーの出力の「条件カウンタ」
[idx]["COND_TYPE"]　→　配列内のidx番目の参照キーの出力の「条件タイプ」
[idx]["STATUS"]　→　配列内のidx番目の参照キーの出力の「単一文字フラグ」
[idx]["TINDEX"]　→　配列内のidx番目の参照キーの出力の「数値項目: 長さ 6」
[idx]["ADDRESS"]　→　配列内のidx番目の参照キーの出力の「住所」
[idx]["ABRLI"]　→　配列内のidx番目の参照キーの出力の「内部納入日程番号
[idx]["ABART"]　→　配列内のidx番目の参照キーの出力の「承認タイプ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationPartnersList

Array getQuotationPartnersList ()

伝票取引先を取得します。
返却値
Array 伝票取引先

伝票取引先オブジェクトの構成は以下のとおりです。
PARTN_ROLE 取引先機能 (String)
PARTN_NUMB 得意先コード 1 (String)
ITM_NUMBER 明細番号 (販売管理伝票) (String)
TITLE 敬称 (String)
NAME 名称 1 (String)
NAME_2 名称 2 (String)
NAME_3 名称 3 (String)
NAME_4 名称 4 (String)
STREET 地名/番地-号 (String)
COUNTRY 国コード (String)
COUNTR_ISO 国キー (ISO コード) (String)
POSTL_CODE 郵便番号 (String)
POBX_PCD 私書箱番号 (String)
POBX_CTY 私書箱住所 (String)
CITY 市区町村 (String)
DISTRICT 所在地 (String)
REGION 地域 (都道府県) (String)
PO_BOX 私書箱 (String)
TELEPHONE 電話番号 1 (String)
TELEPHONE2 電話番号 2 (String)
TELEBOX テレボックス番号 (String)
FAX_NUMBER FAX 番号 (String)
TELETEX_NO テレテクス番号 (String)
TELEX_NO テレックス番号 (String)
LANGU 言語キー (String)
LANGU_ISO ISO 639 準拠の言語 (String)
UNLOAD_PT 荷渡ポイント (String)
TRANSPZONE 商品の納入区域 (String)
TAXJURCODE 税計算管轄コード - 税管轄コード (String)
ADDRESS 住所 (String)
PRIV_ADDR 自宅住所 (String)
ADDR_TYPE アドレスタイプ (1=組織、2=個人、3=取引先担当者) (String)
ADDR_ORIG コピー元住所 (String)
ADDR_LINK 住所コードへのリンク (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)

伝票取引先オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PARTN_ROLE"]　→　配列内のidx番目の伝票取引先の「取引先機能」
[idx]["PARTN_NUMB"]　→　配列内のidx番目の伝票取引先の「得意先コード 1
[idx]["ITM_NUMBER"]　→　配列内のidx番目の伝票取引先の「明細番号 (販売管理伝票)」
[idx]["TITLE"]　→　配列内のidx番目の伝票取引先の「敬称
[idx]["NAME"]　→　配列内のidx番目の伝票取引先の「名称 1
[idx]["NAME_2"]　→　配列内のidx番目の伝票取引先の「名称 2
[idx]["NAME_3"]　→　配列内のidx番目の伝票取引先の「名称 3
[idx]["NAME_4"]　→　配列内のidx番目の伝票取引先の「名称 4
[idx]["STREET"]　→　配列内のidx番目の伝票取引先の「地名/番地-号
[idx]["COUNTRY"]　→　配列内のidx番目の伝票取引先の「国コード
[idx]["COUNTR_ISO"]　→　配列内のidx番目の伝票取引先の「国キー (ISO コード)」
[idx]["POSTL_CODE"]　→　配列内のidx番目の伝票取引先の「郵便番号」
[idx]["POBX_PCD"]　→　配列内のidx番目の伝票取引先の「私書箱番号」
[idx]["POBX_CTY"]　→　配列内のidx番目の伝票取引先の「私書箱住所」
[idx]["CITY"]　→　配列内のidx番目の伝票取引先の「市区町村」
[idx]["DISTRICT"]　→　配列内のidx番目の伝票取引先の「所在地
[idx]["REGION"]　→　配列内のidx番目の伝票取引先の「地域 (都道府県)」
[idx]["PO_BOX"]　→　配列内のidx番目の伝票取引先の「私書箱」
[idx]["TELEPHONE"]　→　配列内のidx番目の伝票取引先の「電話番号 1」
[idx]["TELEPHONE2"]　→　配列内のidx番目の伝票取引先の「電話番号 2」
[idx]["TELEBOX"]　→　配列内のidx番目の伝票取引先の「テレボックス番号」
[idx]["FAX_NUMBER"]　→　配列内のidx番目の伝票取引先の「FAX 番号」
[idx]["TELETEX_NO"]　→　配列内のidx番目の伝票取引先の「テレテクス番号」
[idx]["TELEX_NO"]　→　配列内のidx番目の伝票取引先の「テレックス番号」
[idx]["LANGU"]　→　配列内のidx番目の伝票取引先の「言語キー」
[idx]["LANGU_ISO"]　→　配列内のidx番目の伝票取引先の「ISO 639 準拠の言語
[idx]["UNLOAD_PT"]　→　配列内のidx番目の伝票取引先の「荷渡ポイント」
[idx]["TRANSPZONE"]　→　配列内のidx番目の伝票取引先の「商品の納入区域」
[idx]["TAXJURCODE"]　→　配列内のidx番目の伝票取引先の「税計算管轄コード - 税管轄コード」
[idx]["ADDRESS"]　→　配列内のidx番目の伝票取引先の「住所」
[idx]["PRIV_ADDR"]　→　配列内のidx番目の伝票取引先の「自宅住所」
[idx]["ADDR_TYPE"]　→　配列内のidx番目の伝票取引先の 「アドレスタイプ (1=組織、2=個人、3=取引先担当者)」
[idx]["ADDR_ORIG"]　→　配列内のidx番目の伝票取引先の「コピー元住所」
[idx]["ADDR_LINK"]　→　配列内のidx番目の伝票取引先の「住所コードへのリンク」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の伝票取引先の「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の伝票取引先の「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の伝票取引先の「論理システム

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationSchedulesInList

Array getQuotationSchedulesInList ()

納入日程行を取得します。
返却値
Array 納入日程行

納入日程行オブジェクトの構成は以下のとおりです。
ITM_NUMBER 販売伝票明細 (String)
SCHED_LINE 納入日程行 (String)
REQ_DATE 納入日程日付 (String)
DATE_TYPE 日付タイプ (日、週、月、期間) (String)
REQ_TIME 納入時間 (String)
REQ_QTY 販売単位による受注数量 (String)
REQ_DLV_BL 出荷ブロック中の納入日程行 (String)
SCHED_TYPE 納入日程カテゴリ (String)
TP_DATE 輸送計画日付 (String)
MS_DATE 品目利用可能日 (String)
LOAD_DATE 積載日付 (String)
GI_DATE 出庫日付 (String)
TP_TIME 輸送計画 - 時間 (現地時間/出荷ポイント参照) (String)
MS_TIME 品目供給ステージ (現地時刻: プラント参照) (String)
LOAD_TIME 積載時刻 (現地時間: 出荷ポイント) (String)
GI_TIME 出庫時刻 (現地時間 - プラント参照) (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)
DLV_DATE 納入日程日付 (String)
DLV_TIME 納入時間 (String)
REL_TYPE 承認タイプ (String)
PLAN_SCHED_TYPE 納入日程行タイプ EDI (String)

納入日程行オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の納入日程行の「販売伝票明細」
[idx]["SCHED_LINE"]　→　配列内のidx番目の納入日程行の「納入日程行」
[idx]["REQ_DATE"]　→　配列内のidx番目の納入日程行の「納入日程日付」
[idx]["DATE_TYPE"]　→　配列内のidx番目の納入日程行の「日付タイプ (日、週、月、期間)」
[idx]["REQ_TIME"]　→　配列内のidx番目の納入日程行の「納入時間」
[idx]["REQ_QTY"]　→　配列内のidx番目の納入日程行の「販売単位による受注数量」
[idx]["REQ_DLV_BL"]　→　配列内のidx番目の納入日程行の「出荷ブロック中の納入日程行」
[idx]["SCHED_TYPE"]　→　配列内のidx番目の納入日程行の「納入日程カテゴリ」
[idx]["TP_DATE"]　→　配列内のidx番目の納入日程行の「輸送計画日付」
[idx]["MS_DATE"]　→　配列内のidx番目の納入日程行の「品目利用可能日」
[idx]["LOAD_DATE"]　→　配列内のidx番目の納入日程行の「積載日付」
[idx]["GI_DATE"]　→　配列内のidx番目の納入日程行の「出庫日付」
[idx]["TP_TIME"]　→　配列内のidx番目の納入日程行の 「輸送計画 - 時間 (現地時間/出荷ポイント参照)」
[idx]["MS_TIME"]　→　配列内のidx番目の納入日程行の 「品目供給ステージ (現地時刻: プラント参照)」
[idx]["LOAD_TIME"]　→　配列内のidx番目の納入日程行の「積載時刻 (現地時間: 出荷ポイント)」
[idx]["GI_TIME"]　→　配列内のidx番目の納入日程行の「出庫時刻 (現地時間 - プラント参照)」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の納入日程行の「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の納入日程行の「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の納入日程行の「論理システム」
[idx]["DLV_DATE"]　→　配列内のidx番目の納入日程行の「納入日程日付」
[idx]["DLV_TIME"]　→　配列内のidx番目の納入日程行の「納入時間」
[idx]["REL_TYPE"]　→　配列内のidx番目の納入日程行の「承認タイプ」
[idx]["PLAN_SCHED_TYPE"]　→　配列内のidx番目の納入日程行の「納入日程行タイプ EDI」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationSchedulesInXList

Array getQuotationSchedulesInXList ()

納入日程行チェックボックスを取得します。
返却値
Array 納入日程行チェックボックス

納入日程行チェックボックスオブジェクトの構成は以下のとおりです。
ITM_NUMBER 販売伝票明細 (String)
SCHED_LINE 納入日程行 (String)
UPDATEFLAG 更新区分 (String)
REQ_DATE 関連ユーザデータ項目の更新情報 (String)
DATE_TYPE 関連ユーザデータ項目の更新情報 (String)
REQ_TIME 関連ユーザデータ項目の更新情報 (String)
REQ_QTY 関連ユーザデータ項目の更新情報 (String)
REQ_DLV_BL 関連ユーザデータ項目の更新情報 (String)
SCHED_TYPE 関連ユーザデータ項目の更新情報 (String)
TP_DATE 関連ユーザデータ項目の更新情報 (String)
MS_DATE 関連ユーザデータ項目の更新情報 (String)
LOAD_DATE 関連ユーザデータ項目の更新情報 (String)
GI_DATE 関連ユーザデータ項目の更新情報 (String)
TP_TIME 関連ユーザデータ項目の更新情報 (String)
MS_TIME 関連ユーザデータ項目の更新情報 (String)
LOAD_TIME 関連ユーザデータ項目の更新情報 (String)
GI_TIME 関連ユーザデータ項目の更新情報 (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
DLV_DATE 関連ユーザデータ項目の更新情報 (String)
DLV_TIME 関連ユーザデータ項目の更新情報 (String)
REL_TYPE 関連ユーザデータ項目の更新情報 (String)
PLAN_SCHED_TYPE 関連ユーザデータ項目の更新情報 (String)

納入日程行チェックボックスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の納入日程行チェックボックスの「販売伝票明細」
[idx]["SCHED_LINE"]　→　配列内のidx番目の納入日程行チェックボックスの「納入日程行」
[idx]["UPDATEFLAG"]　→　配列内のidx番目の納入日程行チェックボックスの「更新区分」
[idx]["REQ_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["DATE_TYPE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REQ_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REQ_QTY 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REQ_DLV_BL 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["SCHED_TYPE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["TP_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["MS_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["LOAD_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["GI_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["TP_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["MS_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["LOAD_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["GI_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の納入日程行チェックボックスの「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の納入日程行チェックボックスの「オブジェクトキー」
[idx]["DLV_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["DLV_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REL_TYPE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["PLAN_SCHED_TYPE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getQuotationTextList

Array getQuotationTextList ()

テキストを取得します。
返却値
Array テキスト

テキストオブジェクトの構成は以下のとおりです。
DOC_NUMBE 販売伝票 (String)
ITM_NUMBE 販売伝票明細 (String)
TEXT_ID テキスト ID (String)
LANGU 言語キー (String)
LANGU_ISO ISO 639 準拠の言語 (String)
FORMAT_COL タグ列 (String)
TEXT_LINE テキスト行 (String)
FUNCTION 機能 (String)

テキストオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["DOC_NUMBE"]　→　配列内のidx番目のテキストの「販売伝票」
[idx]["ITM_NUMBE"]　→　配列内のidx番目のテキストの「販売伝票明細」
[idx]["TEXT_ID"]　→　配列内のidx番目のテキストの「テキスト ID」
[idx]["LANGU"]　→　配列内のidx番目のテキストの「言語キー」
[idx]["LANGU_ISO"]　→　配列内のidx番目のテキストの「ISO 639 準拠の言語」
[idx]["FORMAT_COL"]　→　配列内のidx番目のテキストの「タグ列」
[idx]["TEXT_LINE"]　→　配列内のidx番目のテキストの「テキスト行」
[idx]["FUNCTION"]　→　配列内のidx番目のテキストの「機能」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getSalesdocument

Object getSalesdocument ()

販売管理伝票番号を取得します。

返却値
Object 販売管理伝票番号
getSalesdocumentin

Object getSalesdocumentin ()

販売管理伝票番号を取得します。

返却値
Object 販売管理伝票番号
getSender

Object getSender ()

論理システム - 送信者を取得します。
返却値
Object 論理システム - 送信者

論理システム - 送信者オブジェクトの構成は以下のとおりです。
論理システム - 送信者
オブジェクト
(Object)
LOG_SYSTEM 論理システム (String)

論理システム - 送信者オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["LOG_SYSTEM"]　→　配列内のidx番目の論理システム - 送信者の「論理システム」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getTestrun

Object getTestrun ()

テスト実行を取得します。
返却値
Object テスト実行
setBehaveWhenError

void setBehaveWhenError (Object value)

エラー処理を設定します｡
パラメータ
value Object エラー処理
返却値
void
setBinaryRelationshiptype

void setBinaryRelationshiptype (Object value)

バイナリ関連タイプ (専用)を設定します｡
パラメータ
value Object バイナリ関連タイプ (専用)
返却値
void
setConvert

void setConvert (Object value)

取引先機能/受注伝票タイプの変換を設定します｡
パラメータ
value Object 取引先機能/受注伝票タイプの変換
返却値
void
setIntNumberAssignment

void setIntNumberAssignment (Object value)

明細番号内部採番を設定します｡
パラメータ
value Object 明細番号内部採番
返却値
void
setSalesdocumentin

void setSalesdocumentin (Object value)

見積伝票番号を設定します｡
パラメータ
value Object 見積伝票番号
返却値
void
setStrParam

void setStrParam (String paramStr ,String paramName ,Object value)

構造型の項目に値をセットします。
パラメータ
paramStr | String | 構造名
paramName | String | 項目名
value | Object | セットする値
返却値
void
setTblParam

void setTblParam (String paramTable ,String paramName ,Object value ,int index)

テーブル型の項目に値をセットします。
パラメータ
paramTable | String | テーブル名
paramName | String | 項目名
value | Object | セットする値
index | int | レコード番号
返却値
void
setTestrun

void setTestrun (Object value)

テスト実行を設定します｡
パラメータ
value Object テスト実行
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 SalesOrderCreateFromDat2Controller オブジェクト

受注伝票登録コントローラクラス。

機能は以下の通り
  • 受注伝票を登録します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
SalesOrderCreateFromDat2Controller ()
コンストラクタ｡
SalesOrderCreateFromDat2Controller (ConnectionManager connectionManager)
コンストラクタ。
SalesOrderCreateFromDat2Controller (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより販売伝票を登録します。
String | getBapiReturnErrMessage () ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage () プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。
Object | getBinaryRelationshiptype () バイナリ関連タイプ (専用)を取得します。
Object | getConvert () 変換: 取引先機能 + 受注伝票タイプを取得します。
Array | getExtensionInList () VBAK、VBAP、VBEP のカスタマ拡張を取得します。
Object | getIntNumberAssignment () 明細番号内部採番を取得します。
Object | getLogicSwitch () 内部制御パラメータを取得します。
Array | getOrderCcardList () クレジットカードデータを取得します。
Array | getOrderCfgsBlobList () 選定: BLOB 内部データ (SCE)を取得します。
Array | getOrderCfgsInstList () 選定: インスタンスを取得します。
Array | getOrderCfgsPartOfList () 選定: 部分設定を取得します。
Array | getOrderCfgsRefInstList () 選定: 参照明細/インスタンスを取得します。
Array | getOrderCfgsRefList () 選定: 参照データを取得します。
Array | getOrderCfgsValueList () 選定: 特性値を取得します。
Array | getOrderCfgsVkList () 選定: バリアント条件キーを取得します。
Array | getOrderConditionsInList () 条件を取得します。
Array | getOrderConditionsInXList () 受注における条件更新の通信項目を取得します。
Object | getOrderHeaderIn () 受注伝票ヘッダデータを取得します。
Object | getOrderHeaderInX () ヘッダデータチェックボックスを取得します。
Array | getOrderItemsInList () 明細データを取得します。
Array | getOrderItemsInXList () 明細データチェックボックスを取得します。
Array | getOrderKeysList () 参照キーの出力を取得します。
Array | getOrderPartnersList () 伝票取引先を取得します。
Array | getOrderSchedulesInList () 納入日程行を取得します。
Array | getOrderSchedulesInXList () 納入日程行チェックボックスを取得します。
Array | getOrderTextList () テキストを取得します。
Array | getPartnerAddressesList () アドレス (組織/会社) 用 BAPI 参照構造を取得します。
Object | getSalesdocument () 生成された伝票の番号を取得します。
Object | getSalesdocumentin () 販売管理伝票番号を取得します。
Object | getSender () 論理システム - 送信者を取得します。
Object | getTestrun () テスト実行を取得します。
void | setBehaveWhenError (Object value) エラー処理を設定します｡
void | setBinaryRelationshiptype (Object value) バイナリ関連タイプ (専用)を設定します｡
void | setConvert (Object value) 変換: 取引先機能 + 受注伝票タイプを設定します｡
void | setIntNumberAssignment (Object value) 明細番号内部採番を設定します｡
void | setSalesdocumentin (Object value) 販売管理伝票番号を設定します｡
void | setStrParam (String paramStr ,String paramName ,Object value) 構造型の項目に値をセットします。
void | setTblParam (String paramTable ,String paramName ,Object value ,int index) テーブル型の項目に値をセットします。
void | setTestrun (Object value) テスト実行を設定します｡
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
SalesOrderCreateFromDat2Controller

SalesOrderCreateFromDat2Controller ()
コンストラクタ｡
SalesOrderCreateFromDat2Controller

SalesOrderCreateFromDat2Controller (ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、SalesOrderCreateFromDat2Controller#executeBapi()実行後に必ず ConnectionManager#commit()またはConnectionManager#rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。
パラメータ
connectionManager ConnectionManager コネクションマネージャー
SalesOrderCreateFromDat2Controller

SalesOrderCreateFromDat2Controller (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより販売伝票を登録します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getBapiReturnErrMessage

String getBapiReturnErrMessage ()

ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡
返却値
String BAPI実行結果エラーとなった全てのメッセージ情報
getBapiReturnMessage

String getBapiReturnMessage ()

プロパティファイルでオートコミット条件に設定されたType情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡
返却値
String プロパティファイルでオートコミット条件に一致したType情報のメッセージ情報
getBinaryRelationshiptype

Object getBinaryRelationshiptype ()

バイナリ関連タイプ (専用)を取得します。
返却値
Object バイナリ関連タイプ（専用）
getConvert

Object getConvert ()

変換: 取引先機能 + 受注伝票タイプを取得します。
返却値
Object 変換: 取引先機能 + 受注伝票タイプ
getExtensionInList

Array getExtensionInList ()

VBAK、VBAP、VBEP のカスタマ拡張を取得します。
返却値
Array VBAK、VBAP、VBEP のカスタマ拡張

VBAK、VBAP、VBEP のカスタマ拡張の構成は以下のとおりです。
STRUCTURE BAPI テーブル拡張の構造名 (String)
VALUEPART1 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART2 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART3 BAPI 拡張パラメータのデータ部分 (String)
VALUEPART4 BAPI 拡張パラメータのデータ部分 (String)

VBAK、VBAP、VBEP のカスタマ拡張オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["STRUCTURE"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI テーブル拡張の構造名」
[idx]["VALUEPART1"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART2"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART3"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI 拡張パラメータのデータ部分」
[idx]["VALUEPART4"]　→　配列内のidx番目のVBAK、VBAP、VBEP のカスタマ拡張の 「BAPI 拡張パラメータのデータ部分」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getIntNumberAssignment

Object getIntNumberAssignment ()

明細番号内部採番を取得します。
返却値
Object 明細番号内部採番
getLogicSwitch

Object getLogicSwitch ()

内部制御パラメータを取得します。
返却値
Object 内部制御パラメータ

内部制御パラメータオブジェクトの構成は以下のとおりです。
PRICING 価格設定タイプ (String)
ATP_WRKMOD ATP セッション: 結果取得/新規決定 APO-ATP (String)
SCHEDULING 単一文字フラグ (String)
NOSTRUCTURE チェックボックス (String)
COND_HANDL 選択: 条件行処理 (SD 伝票変更) (String)

内部制御パラメータオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PRICING"]　→　配列内のidx番目の内部制御パラメータの「価格設定タイプ」
[idx]["ATP_WRKMOD"]　→　配列内のidx番目の内部制御パラメータの 「ATP セッション: 結果取得/新規決定 APO-ATP」
[idx]["SCHEDULING"]　→　配列内のidx番目の内部制御パラメータの「単一文字フラグ」
[idx]["NOSTRUCTURE"]　→　配列内のidx番目の内部制御パラメータの「チェックボックス」
[idx]["COND_HANDL"]　→　配列内のidx番目の内部制御パラメータの 「選択: 条件行処理 (SD 伝票変更)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderCcardList

Array getOrderCcardList ()

クレジットカードデータを取得します。
返却値
Array クレジットカードデータ

クレジットカードデータオブジェクトの構成は以下のとおりです。
CC_TYPE 支払カードタイプ: カードタイプ (String)
CC_NUMBER 支払カード: カード番号 (String)
CC_VALID_T 支払カード: 有効終了日 (String)
CC_NAME 支払カード: カード所有者の氏名 (String)
BILLAMOUNT 請求金額: 請求計画に請求日付が指定されている場合 (String)
AUTH_FLAG 支払カード: 振替権限 (String)
AUTHAMOUNT 支払カード: 承認額 (String)
CURRENCY 通貨コード (String)
CURR_ISO ISO コード通貨 (String)
AUTH_DATE 支払カード: 承認日 (String)
AUTH_TIME 支払カード: 承認時刻 (String)
AUTH_CC_NO 支払カード: 承認番号 (String)
AUTH_REFNO 支払カード: 決済代行会社の権限参照コード (String)
CC_REACT 支払カード: 権限確認に対する応答 (String)
CC_RE_AMOUNT BAPI インタフェースの通貨金額 (String)
GL_ACCOUNT G/L 勘定コード (String)
CC_STAT_EX 支払カード: 外部システム呼出時のステータス (String)
CC_REACT_T 支払カード: 結果テキスト (String)
VIRT_CARD チェックボックス (String)
MERCHIDCL 支払カード: 決済代行会社のマーチャント ID (String)

クレジットカードデータオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CC_TYPE"]　→　配列内のidx番目のクレジットカードデータの「支払カードタイプ: カードタイプ」
[idx]["CC_NUMBER"]　→　配列内のidx番目のクレジットカードデータの「支払カード: カード番号」
[idx]["CC_VALID_T"]　→　配列内のidx番目のクレジットカードデータの「支払カード: 有効終了日」
[idx]["CC_NAME"]　→　配列内のidx番目のクレジットカードデータの「支払カード: カード所有者の氏名」
[idx]["BILLAMOUNT"]　→　配列内のidx番目のクレジットカードデータの 「請求金額: 請求計画に請求日付が指定されている場合」
[idx]["AUTH_FLAG"]　→　配列内のidx番目のクレジットカードデータの「支払カード: 振替権限」
[idx]["AUTHAMOUNT"]　→　配列内のidx番目のクレジットカードデータの「支払カード: 承認額」
[idx]["CURRENCY"]　→　配列内のidx番目のクレジットカードデータの「通貨コード」
[idx]["CURR_ISO"]　→　配列内のidx番目のクレジットカードデータの「ISO コード通貨」
[idx]["AUTH_DATE"]　→　配列内のidx番目のクレジットカードデータの「支払カード: 承認日」
[idx]["AUTH_TIME"]　→　配列内のidx番目のクレジットカードデータの「支払カード: 承認時刻」
[idx]["AUTH_CC_NO"]　→　配列内のidx番目のクレジットカードデータの「支払カード: 承認番号」
[idx]["AUTH_REFNO"]　→　配列内のidx番目のクレジットカードデータの 「支払カード: 決済代行会社の権限参照コード」
[idx]["CC_REACT"]　→　配列内のidx番目のクレジットカードデータの 「支払カード: 権限確認に対する応答」
[idx]["CC_RE_AMOUNT"]　→　配列内のidx番目のクレジットカードデータの 「BAPI インタフェースの通貨金額」
[idx]["GL_ACCOUNT"]　→　配列内のidx番目のクレジットカードデータの「G/L 勘定コード」
[idx]["CC_STAT_EX"]　→　配列内のidx番目のクレジットカードデータの 「支払カード: 外部システム呼出時のステータス」
[idx]["CC_REACT_T"]　→　配列内のidx番目のクレジットカードデータの「支払カード: 結果テキスト」
[idx]["VIRT_CARD"]　→　配列内のidx番目のクレジットカードデータの「チェックボックス」
[idx]["MERCHIDCL"]　→　配列内のidx番目のクレジットカードデータの 「支払カード: 決済代行会社のマーチャント ID」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderCfgsBlobList

Array getOrderCfgsBlobList ()

選定: BLOB 内部データ (SCE)を取得します。
返却値
Array 選定: BLOB 内部データ (SCE)

選定: BLOB 内部データ (SCE)オブジェクトの構成は以下のとおりです。
CONFIG_ID 外部選定 ID (仮) (String)
CONTEXT CU: 選定の BLOB. (SCE) (String)

選定: BLOB 内部データ (SCE)オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: BLOB 内部データ (SCE)の 「外部選定 ID (仮)」
[idx]["CONTEXT"]　→　配列内のidx番目の選定: BLOB 内部データ (SCE)の 「CU: 選定の BLOB. (SCE)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderCfgsInstList

Array getOrderCfgsInstList ()

選定: インスタンスを取得します。
返却値
Array 選定: インスタンス

選定: インスタンスオブジェクトの構成は以下のとおりです。
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)
OBJ_TYPE 対象タイプ (String)
CLASS_TYPE クラスタイプ (String)
OBJ_KEY 対象キー (String)
OBJ_TXT 言語依存対象テキスト (String)
QUANTITY インスタンス数量 (String)
AUTHOR 報告書提案済 (String)
QUANTITY_UNIT 数量単位 (String)
COMPLETE 一般区分 (String)
CONSISTENT 一般区分 (String)
OBJECT_GUID インスタンス用 TYPE_OF ステートメントの GUID (String)
PERSIST_ID インスタンス番号 (固定) (String)
PERSIST_ID_TYPE インスタンス番号タイプ (固定) (String)

選定: インスタンスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: インスタンスの「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の選定: インスタンスの「選定におけるインスタンス番号」
[idx]["OBJ_TYPE"]　→　配列内のidx番目の選定: インスタンスの「対象タイプ」
[idx]["CLASS_TYPE"]　→　配列内のidx番目の選定: インスタンスの「クラスタイプ」
[idx]["OBJ_KEY"]　→　配列内のidx番目の選定: インスタンスの「対象キー」
[idx]["OBJ_TXT"]　→　配列内のidx番目の選定: インスタンスの「言語依存対象テキスト」
[idx]["QUANTITY"]　→　配列内のidx番目の選定: インスタンスの「インスタンス数量」
[idx]["AUTHOR"]　→　配列内のidx番目の選定: インスタンスの「報告書提案済」
[idx]["QUANTITY_UNIT"]　→　配列内のidx番目の選定: インスタンスの「数量単位」
[idx]["COMPLETE"]　→　配列内のidx番目の選定: インスタンスの「一般区分」
[idx]["CONSISTENT"]　→　配列内のidx番目の選定: インスタンスの「一般区分」
[idx]["OBJECT_GUID"]　→　配列内のidx番目の選定: インスタンスの 「インスタンス用 TYPE_OF ステートメントの GUID」
[idx]["PERSIST_ID"]　→　配列内のidx番目の選定: インスタンスの「インスタンス番号 (固定)」
[idx]["PERSIST_ID_TYPE"]　→　配列内のidx番目の選定: インスタンスの 「インスタンス番号タイプ (固定)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderCfgsPartOfList

Array getOrderCfgsPartOfList ()

選定: 部分設定を取得します。
返却値
Array 選定: 部分設定

選定: 部分設定オブジェクトの構成は以下のとおりです。
CONFIG_ID 外部選定 ID (仮) (String)
PARENT_ID 選定におけるインスタンス番号 (String)
INST_ID 選定におけるインスタンス番号 (String)
PART_OF_NO Part_of 明細番号 (String)
OBJ_TYPE 対象タイプ (String)
CLASS_TYPE クラスタイプ (String)
OBJ_KEY 対象キー (String)
AUTHOR 報告書提案済 (String)
SALES_RELEVANT この部品は販売に関連しています (String)
PART_OF_GUID インスタンス用 PART_OF ステートメントの GUID (String)

選定: 部分設定オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: 部分設定の「外部選定 ID (仮)」
[idx]["PARENT_ID"]　→　配列内のidx番目の選定: 部分設定の「選定におけるインスタンス番号」
[idx]["INST_ID"]　→　配列内のidx番目の選定: 部分設定の「選定におけるインスタンス番号」
[idx]["PART_OF_NO"]　→　配列内のidx番目の選定: 部分設定の「Part_of 明細番号」
[idx]["OBJ_TYPE"]　→　配列内のidx番目の選定: 部分設定の「対象タイプ」
[idx]["CLASS_TYPE"]　→　配列内のidx番目の選定: 部分設定の「クラスタイプ」
[idx]["OBJ_KEY"]　→　配列内のidx番目の選定: 部分設定の「対象キー」
[idx]["AUTHOR"]　→　配列内のidx番目の選定: 部分設定の「報告書提案済」
[idx]["SALES_RELEVANT"]　→　配列内のidx番目の選定: 部分設定の 「この部品は販売に関連しています」
[idx]["PART_OF_GUID"]　→　配列内のidx番目の選定: 部分設定の 「インスタンス用 PART_OF ステートメントの GUID」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderCfgsRefInstList

Array getOrderCfgsRefInstList ()

選定: 参照明細/インスタンスを取得します。
返却値
Array 選定: 参照明細/インスタンス

選定: 参照明細/インスタンスオブジェクトの構成は以下のとおりです。
POSEX 外部明細番号 (String)
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)

選定: 参照明細/インスタンスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["POSEX"]　→　配列内のidx番目の選定: 参照明細/インスタンスの「外部明細番号」
[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: 参照明細/インスタンスの 「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の選定: 参照明細/インスタンスの 「選定におけるインスタンス番号」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderCfgsRefList

Array getOrderCfgsRefList ()

選定: 参照データを取得します。
返却値
Array 選定: 参照データ

選定: 参照データオブジェクトの構成は以下のとおりです。
POSEX 外部明細番号 (String)
CONFIGconfig_id 外部選定 ID (仮) (String)
ROOT_Iroot_id 選定におけるインスタンス番号 (String)
SCE scCUX: 選定タイプ (String)
KBNAMEkbname ナレッジベースオブジェクト (String)
KBVERSkbversion SCE ナレッジベースの実行時バージョン (String)
COMPLEcomplete 一般区分 (String)
CONSISconsistent 一般区分 (String)
CFGINFcfginfo CU: 選定の BLOB (SCE) (String)
KBPROFkbprofile ナレッジベースプロファイル (String)
KBLANGkblanguage システム設定の言語 (String)
CBASE_cbase_id インスタンス番号 (固定) (String)
CBASE_cbase_id_type インスタンス番号タイプ (固定) (String)

選定: 参照データオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["POSEX"]　→　配列内のidx番目の選定: 参照データの「外部明細番号」
[idx]["CONFIGconfig_id"]　→　配列内のidx番目の選定: 参照データの 「外部選定 ID (仮)」
[idx]["ROOT_Iroot_id"]　→　配列内のidx番目の選定: 参照データの 「選定におけるインスタンス番号」
[idx]["SCE"]　→　配列内のidx番目の選定: 参照データの「scCUX: 選定タイプ」
[idx]["KBNAMEkbname"]　→　配列内のidx番目の選定: 参照データの「ナレッジベースオブジェクト」
[idx]["KBVERSkbversion"]　→　配列内のidx番目の選定: 参照データの 「SCE ナレッジベースの実行時バージョン」
[idx]["COMPLEcomplete"]　→　配列内のidx番目の選定: 参照データの「一般区分」
[idx]["CONSISconsistent"]　→　配列内のidx番目の選定: 参照データの「一般区分」
[idx]["CFGINFcfginfo"]　→　配列内のidx番目の選定: 参照データの 「CU: 選定の BLOB (SCE)」
[idx]["KBPROFkbprofile"]　→　配列内のidx番目の選定: 参照データの 「ナレッジベースプロファイル」
[idx]["KBLANGkblanguage"]　→　配列内のidx番目の選定: 参照データの「システム設定の言語」
[idx]["CBASE_cbase_id"]　→　配列内のidx番目の選定: 参照データの 「インスタンス番号 (固定)」
[idx]["CBASE_cbase_id_type"]　→　配列内のidx番目の選定: 参照データの 「インスタンス番号タイプ (固定)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderCfgsValueList

Array getOrderCfgsValueList ()

選定: 特性値を取得します。
返却値
Array 選定: 特性値

選定: 特性値オブジェクトの構成は以下のとおりです。
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)
CHARC 特性名 (String)
CHARC_TXT 言語依存特性テキスト (String)
VALUE 特性値 (String)
VALUE_TXT 特性値の言語依存テキスト (String)
AUTHOR 報告書提案済 (String)
VALUE_TO 特性値 (String)
VALCODE 値タイプ: 範囲制限 - 単一値 (String)

選定: 特性値オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: 特性値の「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の選定: 特性値の「選定におけるインスタンス番号」
[idx]["CHARC"]　→　配列内のidx番目の選定: 特性値の「特性名」
[idx]["CHARC_TXT"]　→　配列内のidx番目の選定: 特性値の「言語依存特性テキスト」
[idx]["VALUE"]　→　配列内のidx番目の選定: 特性値の「特性値」
[idx]["VALUE_TXT"]　→　配列内のidx番目の選定: 特性値の「特性値の言語依存テキスト」
[idx]["AUTHOR"]　→　配列内のidx番目の選定: 特性値の「報告書提案済」
[idx]["VALUE_TO"]　→　配列内のidx番目の選定: 特性値の「特性値」
[idx]["VALCODE"]　→　配列内のidx番目の選定: 特性値の「値タイプ: 範囲制限 - 単一値」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderCfgsVkList

Array getOrderCfgsVkList ()

選定: バリアント条件キーを取得します。
返却値
Array 選定: バリアント条件キー

選定: バリアント条件キーオブジェクトの構成は以下のとおりです。
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)
VKEY バリアント条件名 (String)
FACTOR バリアント条件の加重係数 (String)

選定: バリアント条件キーオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONFIG_ID"]　→　配列内のidx番目の選定: バリアント条件キーの「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の選定: バリアント条件キーの「選定におけるインスタンス番号」
[idx]["VKEY"]　→　配列内のidx番目の選定: バリアント条件キーの「バリアント条件名」
[idx]["FACTOR"]　→　配列内のidx番目の選定: バリアント条件キーの「バリアント条件の加重係数」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderConditionsInList

Array getOrderConditionsInList ()

条件を取得します。
返却値
Array 条件

条件オブジェクトの構成は以下のとおりです。
ITM_NUMBER 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件カウンタ (String)
COND_TYPE 条件タイプ (String)
COND_VALUE 条件レート (String)
CURRENCY 通貨コード (String)
COND_UNIT 条件単位 (String)
COND_P_UNT 価格条件単位 (String)
CURR_ISO ISO コード通貨 (String)
CD_UNT_ISO 条件数量単位 (ISO コード) (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)
APPLICATIO アプリケーション (String)
CONPRICDAT 条件価格設定日付 (String)
CALCTYPCON 条件計算タイプ (String)
CONBASEVAL 条件基礎値 (String)
CONEXCHRAT 現地通貨への換算レートに対する条件 (String)
NUMCONVERT 条件単位を基本単位へ変換する分子 (String)
DENOMINATO 条件単位を基本単位へ変換する分母 (String)
CONDTYPE 条件カテゴリ (例: 税、運賃、価格、原価) (String)
STAT_CON 統計に適用する条件 (String)
SCALETYPE スケールタイプ (String)
ACCRUALS 見越額関連条件 (運賃など) (String)
CONINVOLST 請求書一覧条件 (String)
CONDORIGIN 条件生成区分 (String)
GROUPCOND グループ条件区分 (String)
COND_UPDAT 条件更新 (String)
ACCESS_SEQ 検索順序 - 検索番号 (String)
CONDCOUNT 条件連続番号 (String)
ROUNDOFFDI BAPI の通貨額 (小数点以下９桁) (String)
CONDVALUE 条件金額 (String)
CURRENCY_2 販売伝票通貨 (String)
CURR_ISO_2 ISO コード通貨 (String)
CONDCNTRL 条件管理 (String)
CONDISACTI 無効条件 (String)
CONDCLASS 条件クラス (String)
FACTBASVAL 条件基礎値に対する要因 (String)
SCALEBASIN スケール基準区分 (String)
SCALBASVAL 条件のスケール基準値 (String)
UNITMEASUR 条件スケール単位 (String)
ISO_UNIT 単位の ISO コード (String)
CURRENCKEY スケール通貨 (String)
CURRENISO ISO コード通貨 (String)
CONDINCOMP 会社間請求の条件 (String)
CONDCONFIG システム設定の条件 (String)
CONDCHAMAN 条件 (マニュアル変更済) (String)
COND_NO 条件レコード番号 (String)
TAX_CODE 消費税コード (String)
VARCOND バリアント条件 (String)
ACCOUNTKEY 勘定キー (String)
ACCOUNT_KE 勘定キー 見越/引当 (String)
WT_WITHCD 源泉徴収税コード (String)
STRUCTCOND 構造条件 (String)
FACTCONBAS 条件基準の係数 (期間) (String)
CONDCOINHD 条件カウンタ (ヘッダ条件) (String)

条件オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の条件の「条件明細番号」
[idx]["COND_ST_NO"]　→　配列内のidx番目の条件の「ステップ番号」
[idx]["COND_COUNT"]　→　配列内のidx番目の条件の「条件カウンタ」
[idx]["COND_TYPE"]　→　配列内のidx番目の条件の「条件タイプ」
[idx]["COND_VALUE"]　→　配列内のidx番目の条件の「条件レート」
[idx]["CURRENCY"]　→　配列内のidx番目の条件の「通貨コード」
[idx]["COND_UNIT"]　→　配列内のidx番目の条件の「条件単位」
[idx]["COND_P_UNT"]　→　配列内のidx番目の条件の「価格条件単位」
[idx]["CURR_ISO"]　→　配列内のidx番目の条件の「ISO コード通貨」
[idx]["CD_UNT_ISO"]　→　配列内のidx番目の条件の「条件数量単位 (ISO コード)」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の条件の「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の条件の「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の条件の「論理システム」
[idx]["APPLICATIO"]　→　配列内のidx番目の条件の「アプリケーション」
[idx]["CONPRICDAT"]　→　配列内のidx番目の条件の「条件価格設定日付」
[idx]["CALCTYPCON"]　→　配列内のidx番目の条件の「条件計算タイプ」
[idx]["CONBASEVAL"]　→　配列内のidx番目の条件の「条件基礎値」
[idx]["CONEXCHRAT"]　→　配列内のidx番目の条件の「現地通貨への換算レートに対する条件」
[idx]["NUMCONVERT"]　→　配列内のidx番目の条件の「条件単位を基本単位へ変換する分子」
[idx]["DENOMINATO"]　→　配列内のidx番目の条件の「条件単位を基本単位へ変換する分母」
[idx]["CONDTYPE"]　→　配列内のidx番目の条件の「条件カテゴリ (例: 税、運賃、価格、原価)」
[idx]["STAT_CON"]　→　配列内のidx番目の条件の「統計に適用する条件」
[idx]["SCALETYPE"]　→　配列内のidx番目の条件の「スケールタイプ」
[idx]["ACCRUALS"]　→　配列内のidx番目の条件の「見越額関連条件 (運賃など)」
[idx]["CONINVOLST"]　→　配列内のidx番目の条件の「請求書一覧条件」
[idx]["CONDORIGIN"]　→　配列内のidx番目の条件の「条件生成区分」
[idx]["GROUPCOND"]　→　配列内のidx番目の条件の「グループ条件区分」
[idx]["COND_UPDAT"]　→　配列内のidx番目の条件の「条件更新」
[idx]["ACCESS_SEQ"]　→　配列内のidx番目の条件の「検索順序 - 検索番号」
[idx]["CONDCOUNT"]　→　配列内のidx番目の条件の「条件連続番号」
[idx]["ROUNDOFFDI"]　→　配列内のidx番目の条件の「BAPI の通貨額 (小数点以下９桁)」
[idx]["CONDVALUE"]　→　配列内のidx番目の条件の「条件金額」
[idx]["CURRENCY_2"]　→　配列内のidx番目の条件の「販売伝票通貨」
[idx]["CURR_ISO_2"]　→　配列内のidx番目の条件の「ISO コード通貨」
[idx]["CONDCNTRL"]　→　配列内のidx番目の条件の「条件管理」
[idx]["CONDISACTI"]　→　配列内のidx番目の条件の「無効条件」
[idx]["CONDCLASS"]　→　配列内のidx番目の条件の「条件クラス」
[idx]["FACTBASVAL"]　→　配列内のidx番目の条件の「条件基礎値に対する要因」
[idx]["SCALEBASIN"]　→　配列内のidx番目の条件の「スケール基準区分」
[idx]["SCALBASVAL"]　→　配列内のidx番目の条件の「条件のスケール基準値」
[idx]["UNITMEASUR"]　→　配列内のidx番目の条件の「条件スケール単位」
[idx]["ISO_UNIT"]　→　配列内のidx番目の条件の「単位の ISO コード」
[idx]["CURRENCKEY"]　→　配列内のidx番目の条件の「スケール通貨」
[idx]["CURRENISO"]　→　配列内のidx番目の条件の「ISO コード通貨」
[idx]["CONDINCOMP"]　→　配列内のidx番目の条件の「会社間請求の条件」
[idx]["CONDCONFIG"]　→　配列内のidx番目の条件の「システム設定の条件」
[idx]["CONDCHAMAN"]　→　配列内のidx番目の条件の「条件 (マニュアル変更済)」
[idx]["COND_NO"]　→　配列内のidx番目の条件の「条件レコード番号」
[idx]["TAX_CODE"]　→　配列内のidx番目の条件の「消費税コード」
[idx]["VARCOND"]　→　配列内のidx番目の条件の「バリアント条件」
[idx]["ACCOUNTKEY"]　→　配列内のidx番目の条件の「勘定キー」
[idx]["ACCOUNT_KE"]　→　配列内のidx番目の条件の「勘定キー 見越/引当」
[idx]["WT_WITHCD"]　→　配列内のidx番目の条件の「源泉徴収税コード」
[idx]["STRUCTCOND"]　→　配列内のidx番目の条件の「構造条件」
[idx]["FACTCONBAS"]　→　配列内のidx番目の条件の「条件基準の係数 (期間)」
[idx]["CONDCOINHD"]　→　配列内のidx番目の条件の「条件カウンタ (ヘッダ条件)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderConditionsInXList

Array getOrderConditionsInXList ()

受注における条件更新の通信項目を取得します。
返却値
Array 受注における条件更新の通信項目

受注における条件更新の通信項目オブジェクトの構成は以下のとおりです。
ITM_NUMBER 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件連続番号 (String)
COND_TYPE 条件タイプ (String)
UPDATEFLAG 更新区分 (String)
COND_VALUE 関連ユーザデータ項目の更新情報 (String)
CURRENCY 関連ユーザデータ項目の更新情報 (String)
COND_UNIT 関連ユーザデータ項目の更新情報 (String)
COND_P_UNT 関連ユーザデータ項目の更新情報 (String)
VARCOND バリアント条件 (String)

受注における条件更新の通信項目オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の受注における条件更新の通信項目の「条件明細番号」
[idx]["COND_ST_NO"]　→　配列内のidx番目の受注における条件更新の通信項目の「ステップ番号」
[idx]["COND_COUNT"]　→　配列内のidx番目の受注における条件更新の通信項目の「条件連続番号」
[idx]["COND_TYPE"]　→　配列内のidx番目の受注における条件更新の通信項目の「条件タイプ」
[idx]["UPDATEFLAG"]　→　配列内のidx番目の受注における条件更新の通信項目の「更新区分」
[idx]["COND_VALUE"]　→　配列内のidx番目の受注における条件更新の通信項目の 「関連ユーザデータ項目の更新情報」
[idx]["CURRENCY"]　→　配列内のidx番目の受注における条件更新の通信項目の 「関連ユーザデータ項目の更新情報」
[idx]["COND_UNIT"]　→　配列内のidx番目の受注における条件更新の通信項目の 「関連ユーザデータ項目の更新情報」
[idx]["COND_P_UNT"]　→　配列内のidx番目の受注における条件更新の通信項目の 「関連ユーザデータ項目の更新情報」
[idx]["VARCOND"]　→　配列内のidx番目の受注における条件更新の通信項目の「バリアント条件」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderHeaderIn

Object getOrderHeaderIn ()

受注伝票ヘッダデータを取得します。
返却値
Object 受注伝票ヘッダデータ

受注伝票ヘッダデータオブジェクトの構成は以下のとおりです。
REFOBJTYPE オブジェクトタイプ(String)
REFOBJKEY オブジェクトキー(String)
REFDOCTYPE 参照オブジェクトの伝票タイプ(String)
DOC_TYPE 販売伝票タイプ(String)
COLLECT_NO 一括番号(String)
SALES_ORG 販売組織(String)
DISTR_CHAN 流通チャネル(String)
DIVISION 製品部門(String)
SALES_GRP 営業グループ(String)
SALES_OFF 営業所(String)
REQ_DATE_H 指定納入期日(String)
DATE_TYPE 提案日付タイプ(String)
PURCH_DATE 得意先発注日付(String)
PO_METHOD 得意先発注タイプ(String)
PO_SUPPLEM 得意先発注番号補足(String)
REF_1 得意先/仕入先の内部参照コード(String)
NAME 発注者名称(String)
TELEPHONE 電話番号(String)
PRICE_GRP 価格グループ (得意先)(String)
CUST_GROUP 得意先グループ(String)
SALES_DIST 販売地域(String)
PRICE_LIST 価格表タイプ(String)
INCOTERMS1 インコタームズ (1)(String)
INCOTERMS2 インコタームズ 2(String)
PMNTTRMS 支払条件キー(String)
DLV_BLOCK 出荷ブロック (伝票ヘッダ)(String)
BILL_BLOCK 販売管理伝票の請求ブロック(String)
ORD_REASON 受注理由 (取引理由)(String)
COMPL_DLV 一括納入区分(String)
PRICE_DATE 価格設定/外貨換算の実行日付(String)
QT_VALID_F 見積/引合有効開始日(String)
QT_VALID_T 見積の有効終了日(String)
CT_VALID_F 有効開始日付 (販売契約/品目提案)(String)
CT_VALID_T 有効終了日付 (販売契約/品目提案)(String)
CUST_GRP1 得意先グループ 1(String)
CUST_GRP2 得意先グループ 2(String)
CUST_GRP3 得意先グループ 3(String)
CUST_GRP4 得意先グループ 4(String)
CUST_GRP5 得意先グループ 5(String)
PURCH_NO_C 出荷先発注番号(String)
PURCH_NO_S 出荷先の得意先発注番号(String)
PO_DAT_S 出荷先の出荷先発注日付(String)
PO_METH_S 出荷先の出荷先発注タイプ(String)
REF_1_S 出荷先文字(String)
SD_DOC_CAT 販売管理伝票カテゴリ(String)
DOC_DATE 伝票日付 (受信日/送信日)(String)
WAR_DATE 保証期間の開始日付(String)
SHIP_COND 出荷条件(String)
PP_SEARCH 品目提案検索条件(String)
DUN_COUNT 得意先商談回数(String)
DUN_DATE 得意先との前回の商談日(String)
DLVSCHDUSE 用途区分(String)
PLDLVSTYP MRP: 出荷計画タイプ(String)
REF_DOC 参照伝票番号(String)
COMP_CDE_B 請求対象会社コード(String)
ALTTAX_CLS 代替税分類(String)
TAX_CLASS2 得意先税分類 2(String)
TAX_CLASS3 得意先税分類 3(String)
TAX_CLASS4 得意先に対する税クラス 4(String)
TAX_CLASS5 得意先に対する税クラス 5(String)
TAX_CLASS6 得意先に対する税クラス 6(String)
TAX_CLASS7 得意先に対する税クラス 7(String)
TAX_CLASS8 得意先に対する税クラス 8(String)
TAX_CLASS9 得意先に対する税クラス 9(String)
REF_DOC_L 参照伝票番号(String)
ASS_NUMBER 割当番号(String)
REFDOC_CAT 先行販売管理伝票の伝票カテゴリ(String)
ORDCOMB_IN 受注結合出荷区分(String)
BILL_SCHED 請求日程 (稼働日カレンダ指定)(String)
INVO_SCHED 請求書一覧日程 (稼働日カレンダ指定)(String)
MN_INVOICE マニュアル請求書更新(String)
EXRATE_FI FI 転記の換算レート (直接相場)(String)
ADD_VAL_DY 有効日からの日数(String)
FIX_VAL_DY 有効日日付(String)
PYMT_METH 支払方法(String)
ACCNT_ASGN 得意先の勘定設定グループ(String)
EXCHG_RATE 価格設定/統計の換算レート (直接引用)(String)
BILL_DATE 請求索引および印刷に対する請求日(String)
SERV_DATE サービス提供日(String)
DUNN_KEY 督促処理キー(String)
DUNN_BLOCK 督促処理保留(String)
PMTGAR_PRO 支払保証決定表(String)
DEPARTM_NO 部門コード(String)
REC_POINT 入荷ポイント(String)
DOC_NUM_FI ドキュメンタリクレジット処理: 内部番号(String)
CSTCNDGRP1 得意先条件グループ１(String)
CSTCNDGRP2 得意先条件グループ２(String)
CSTCNDGRP3 得意先条件グループ３(String)
CSTCNDGRP4 得意先条件グループ４(String)
CSTCNDGRP5 得意先条件グループ５(String)
DLV_TIME 契約出荷期間(String)
CURRENCY 販売伝票通貨(String)
CURR_ISO ISO コード通貨(String)
CREATED_BY オブジェクト登録者名(String)
TAXDEP_CTY 税出荷国(String)
TAXDST_CTY 税仕向国(String)
EUTRI_DEAL フラグ: EC 内三角取引(String)
MAST_CONTR グループマスタ契約番号(String)
REF_PROC 参照限定条件: 決定区分(String)
CHKPRTAUTH 取引先権限チェック(String)
CMLQTY_DAT 累積出荷数量日付(String)
VERSION 販売伝票バージョン番号(String)
NOTIF_NO 通知番号(String)
WBS_ELEM WBS 要素(String)
EXCH_RATE_FI_V FI 転記の換算レート (間接相場)(String)
EXCHG_RATE_V 価格設定/統計の換算レート (間接引用)(String)
FKK_CONACCT 長さ 12 の文字項目(String)
CAMPAIGN 総括プロジェクト計画: 外部 R/3 システムの GUID(String)
DOC_CLASS リリースおよびトランザクション管理 を備えた元システム(String)
H_CURR 通貨コード(String)
H_CURR_ISO ISO 通貨コード(String)
SHIP_TYPE 出荷タイプ(String)
S_PROC_IND 特別処理区分(String)
REF_DOC_L_LONG 参照伝票番号 (依存関係についてはテキスト (長) を参照)(String)

内部制御パラメータオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["REFOBJTYPE"]　→　配列内のidx番目の受注伝票ヘッダデータの「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の受注伝票ヘッダデータの「オブジェクトキー」
[idx]["REFDOCTYPE"]　→　配列内のidx番目の受注伝票ヘッダデータの「参照オブジェクトの伝票タイプ」
[idx]["DOC_TYPE"]　→　配列内のidx番目の受注伝票ヘッダデータの「販売伝票タイプ」
[idx]["COLLECT_NO"]　→　配列内のidx番目の受注伝票ヘッダデータの「一括番号」
[idx]["SALES_ORG"]　→　配列内のidx番目の受注伝票ヘッダデータの「販売組織」
[idx]["DISTR_CHAN"]　→　配列内のidx番目の受注伝票ヘッダデータの「流通チャネル」
[idx]["DIVISION"]　→　配列内のidx番目の受注伝票ヘッダデータの「製品部門」
[idx]["SALES_GRP"]　→　配列内のidx番目の受注伝票ヘッダデータの「営業グループ」
[idx]["SALES_OFF"]　→　配列内のidx番目の受注伝票ヘッダデータの「営業所」
[idx]["REQ_DATE_H"]　→　配列内のidx番目の受注伝票ヘッダデータの「指定納入期日」
[idx]["DATE_TYPE"]　→　配列内のidx番目の受注伝票ヘッダデータの「提案日付タイプ」
[idx]["PURCH_DATE"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先発注日付」
[idx]["PO_METHOD"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先発注タイプ」
[idx]["PO_SUPPLEM"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先発注番号補足」
[idx]["REF_1"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先/仕入先の内部参照コード」
[idx]["NAME"]　→　配列内のidx番目の受注伝票ヘッダデータの「発注者名称」
[idx]["TELEPHONE"]　→　配列内のidx番目の受注伝票ヘッダデータの「電話番号」
[idx]["PRICE_GRP"]　→　配列内のidx番目の受注伝票ヘッダデータの「価格グループ (得意先)」
[idx]["CUST_GROUP"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先グループ」
[idx]["SALES_DIST"]　→　配列内のidx番目の受注伝票ヘッダデータの「販売地域」
[idx]["PRICE_LIST"]　→　配列内のidx番目の受注伝票ヘッダデータの「価格表タイプ」
[idx]["INCOTERMS1"]　→　配列内のidx番目の受注伝票ヘッダデータの「インコタームズ (1)」
[idx]["INCOTERMS2"]　→　配列内のidx番目の受注伝票ヘッダデータの「インコタームズ 2」
[idx]["PMNTTRMS"]　→　配列内のidx番目の受注伝票ヘッダデータの「支払条件キー」
[idx]["DLV_BLOCK"]　→　配列内のidx番目の受注伝票ヘッダデータの「出荷ブロック (伝票ヘッダ)」
[idx]["BILL_BLOCK"]　→　配列内のidx番目の受注伝票ヘッダデータの「販売管理伝票の請求ブロック」
[idx]["ORD_REASON"]　→　配列内のidx番目の受注伝票ヘッダデータの「受注理由 (取引理由)」
[idx]["COMPL_DLV"]　→　配列内のidx番目の受注伝票ヘッダデータの「一括納入区分」
[idx]["PRICE_DATE"]　→　配列内のidx番目の受注伝票ヘッダデータの「価格設定/外貨換算の実行日付」
[idx]["QT_VALID_F"]　→　配列内のidx番目の受注伝票ヘッダデータの「見積/引合有効開始日」
[idx]["QT_VALID_T"]　→　配列内のidx番目の受注伝票ヘッダデータの「見積の有効終了日」
[idx]["CT_VALID_F"]　→　配列内のidx番目の受注伝票ヘッダデータの 「有効開始日付 (販売契約/品目提案)」
[idx]["CT_VALID_T"]　→　配列内のidx番目の受注伝票ヘッダデータの 「有効終了日付 (販売契約/品目提案)」
[idx]["CUST_GRP1"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先グループ 1」
[idx]["CUST_GRP2"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先グループ 2」
[idx]["CUST_GRP3"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先グループ 3」
[idx]["CUST_GRP4"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先グループ 4」
[idx]["CUST_GRP5"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先グループ 5」
[idx]["PURCH_NO_C"]　→　配列内のidx番目の受注伝票ヘッダデータの「出荷先発注番号」
[idx]["PURCH_NO_S"]　→　配列内のidx番目の受注伝票ヘッダデータの「出荷先の得意先発注番号」
[idx]["PO_DAT_S"]　→　配列内のidx番目の受注伝票ヘッダデータの「出荷先の出荷先発注日付」
[idx]["PO_METH_S"]　→　配列内のidx番目の受注伝票ヘッダデータの「出荷先の出荷先発注タイプ」
[idx]["REF_1_S"]　→　配列内のidx番目の受注伝票ヘッダデータの「出荷先文字」
[idx]["SD_DOC_CAT"]　→　配列内のidx番目の受注伝票ヘッダデータの「販売管理伝票カテゴリ」
[idx]["DOC_DATE"]　→　配列内のidx番目の受注伝票ヘッダデータの「伝票日付 (受信日/送信日)」
[idx]["WAR_DATE"]　→　配列内のidx番目の受注伝票ヘッダデータの「保証期間の開始日付」
[idx]["SHIP_COND"]　→　配列内のidx番目の受注伝票ヘッダデータの「出荷条件」
[idx]["PP_SEARCH"]　→　配列内のidx番目の受注伝票ヘッダデータの「品目提案検索条件」
[idx]["DUN_COUNT"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先商談回数」
[idx]["DUN_DATE"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先との前回の商談日」
[idx]["DLVSCHDUSE"]　→　配列内のidx番目の受注伝票ヘッダデータの「用途区分」
[idx]["PLDLVSTYP"]　→　配列内のidx番目の受注伝票ヘッダデータの「MRP: 出荷計画タイプ」
[idx]["REF_DOC"]　→　配列内のidx番目の受注伝票ヘッダデータの「参照伝票番号」
[idx]["COMP_CDE_B"]　→　配列内のidx番目の受注伝票ヘッダデータの「請求対象会社コード」
[idx]["ALTTAX_CLS"]　→　配列内のidx番目の受注伝票ヘッダデータの「代替税分類」
[idx]["TAX_CLASS2"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先税分類 2」
[idx]["TAX_CLASS3"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先税分類 3」
[idx]["TAX_CLASS4"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先に対する税クラス 4」
[idx]["TAX_CLASS5"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先に対する税クラス 5」
[idx]["TAX_CLASS6"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先に対する税クラス 6」
[idx]["TAX_CLASS7"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先に対する税クラス 7」
[idx]["TAX_CLASS8"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先に対する税クラス 8」
[idx]["TAX_CLASS9"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先に対する税クラス 9」
[idx]["REF_DOC_L"]　→　配列内のidx番目の受注伝票ヘッダデータの「参照伝票番号」
[idx]["ASS_NUMBER"]　→　配列内のidx番目の受注伝票ヘッダデータの「割当番号」
[idx]["REFDOC_CAT"]　→　配列内のidx番目の受注伝票ヘッダデータの 「先行販売管理伝票の伝票カテゴリ」
[idx]["ORDCOMB_IN"]　→　配列内のidx番目の受注伝票ヘッダデータの「受注結合出荷区分」
[idx]["BILL_SCHED"]　→　配列内のidx番目の受注伝票ヘッダデータの 「請求日程 (稼働日カレンダ指定)」
[idx]["INVO_SCHED"]　→　配列内のidx番目の受注伝票ヘッダデータの 「請求書一覧日程 (稼働日カレンダ指定)」
[idx]["MN_INVOICE"]　→　配列内のidx番目の受注伝票ヘッダデータの「マニュアル請求書更新」
[idx]["EXRATE_FI"]　→　配列内のidx番目の受注伝票ヘッダデータの 「FI 転記の換算レート (直接相場)」
[idx]["ADD_VAL_DY"]　→　配列内のidx番目の受注伝票ヘッダデータの「有効日からの日数」
[idx]["FIX_VAL_DY"]　→　配列内のidx番目の受注伝票ヘッダデータの「有効日日付」
[idx]["PYMT_METH"]　→　配列内のidx番目の受注伝票ヘッダデータの「支払方法」
[idx]["ACCNT_ASGN"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先の勘定設定グループ」
[idx]["EXCHG_RATE"]　→　配列内のidx番目の受注伝票ヘッダデータの 「価格設定/統計の換算レート (直接引用)」
[idx]["BILL_DATE"]　→　配列内のidx番目の受注伝票ヘッダデータの 「請求索引および印刷に対する請求日」
[idx]["SERV_DATE"]　→　配列内のidx番目の受注伝票ヘッダデータの「サービス提供日」
[idx]["DUNN_KEY"]　→　配列内のidx番目の受注伝票ヘッダデータの「督促処理キー」
[idx]["DUNN_BLOCK"]　→　配列内のidx番目の受注伝票ヘッダデータの「督促処理保留」
[idx]["PMTGAR_PRO"]　→　配列内のidx番目の受注伝票ヘッダデータの「支払保証決定表」
[idx]["DEPARTM_NO"]　→　配列内のidx番目の受注伝票ヘッダデータの「部門コード」
[idx]["REC_POINT"]　→　配列内のidx番目の受注伝票ヘッダデータの「入荷ポイント」
[idx]["DOC_NUM_FI"]　→　配列内のidx番目の受注伝票ヘッダデータの 「ドキュメンタリクレジット処理: 内部番号」
[idx]["CSTCNDGRP1"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先条件グループ１」
[idx]["CSTCNDGRP2"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先条件グループ２」
[idx]["CSTCNDGRP3"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先条件グループ３」
[idx]["CSTCNDGRP4"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先条件グループ４」
[idx]["CSTCNDGRP5"]　→　配列内のidx番目の受注伝票ヘッダデータの「得意先条件グループ５」
[idx]["DLV_TIME"]　→　配列内のidx番目の受注伝票ヘッダデータの「契約出荷期間」
[idx]["CURRENCY"]　→　配列内のidx番目の受注伝票ヘッダデータの「販売伝票通貨」
[idx]["CURR_ISO"]　→　配列内のidx番目の受注伝票ヘッダデータの「ISO コード通貨」
[idx]["CREATED_BY"]　→　配列内のidx番目の受注伝票ヘッダデータの「オブジェクト登録者名」
[idx]["TAXDEP_CTY"]　→　配列内のidx番目の受注伝票ヘッダデータの「税出荷国」
[idx]["TAXDST_CTY"]　→　配列内のidx番目の受注伝票ヘッダデータの「税仕向国」
[idx]["EUTRI_DEAL"]　→　配列内のidx番目の受注伝票ヘッダデータの「フラグ: EC 内三角取引」
[idx]["MAST_CONTR"]　→　配列内のidx番目の受注伝票ヘッダデータの「グループマスタ契約番号」
[idx]["REF_PROC"]　→　配列内のidx番目の受注伝票ヘッダデータの「参照限定条件: 決定区分」
[idx]["CHKPRTAUTH"]　→　配列内のidx番目の受注伝票ヘッダデータの「取引先権限チェック」
[idx]["CMLQTY_DAT"]　→　配列内のidx番目の受注伝票ヘッダデータの「累積出荷数量日付」
[idx]["VERSION"]　→　配列内のidx番目の受注伝票ヘッダデータの「販売伝票バージョン番号」
[idx]["NOTIF_NO"]　→　配列内のidx番目の受注伝票ヘッダデータの「通知番号」
[idx]["WBS_ELEM"]　→　配列内のidx番目の受注伝票ヘッダデータの「WBS 要素」
[idx]["EXCH_RATE_FI_V"]　→　配列内のidx番目の受注伝票ヘッダデータの 「FI 転記の換算レート (間接相場)」
[idx]["EXCHG_RATE_V"]　→　配列内のidx番目の受注伝票ヘッダデータの 「価格設定/統計の換算レート (間接引用)」
[idx]["FKK_CONACCT"]　→　配列内のidx番目の受注伝票ヘッダデータの「長さ 12 の文字項目」
[idx]["CAMPAIGN"]　→　配列内のidx番目の受注伝票ヘッダデータの 「総括プロジェクト計画: 外部 R/3 システムの GUID」
[idx]["DOC_CLASS"]　→　配列内のidx番目の受注伝票ヘッダデータの 「リリースおよびトランザクション管理を備えた元システム」
[idx]["H_CURR"]　→　配列内のidx番目の受注伝票ヘッダデータの「通貨コード」
[idx]["H_CURR_ISO"]　→　配列内のidx番目の受注伝票ヘッダデータの「ISO 通貨コード」
[idx]["SHIP_TYPE"]　→　配列内のidx番目の受注伝票ヘッダデータの「出荷タイプ」
[idx]["S_PROC_IND"]　→　配列内のidx番目の受注伝票ヘッダデータの「特別処理区分」
[idx]["REF_DOC_L_LONG"]　→　配列内のidx番目の受注伝票ヘッダデータの 「参照伝票番号 (依存関係についてはテキスト (長) を参照)」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderHeaderInX

Object getOrderHeaderInX ()

ヘッダデータチェックボックスを取得します。
返却値
Object ヘッダデータチェックボックス

ヘッダデータチェックボックスオブジェクトの構成は以下のとおりです。
UPDATEFLAG 更新区分 (String)
DOC_TYPE 関連ユーザデータ項目の更新情報 (String)
COLLECT_NO 関連ユーザデータ項目の更新情報 (String)
SALES_ORG 関連ユーザデータ項目の更新情報 (String)
DISTR_CHAN 関連ユーザデータ項目の更新情報 (String)
DIVISION 関連ユーザデータ項目の更新情報 (String)
SALES_GRP 関連ユーザデータ項目の更新情報 (String)
SALES_OFF 関連ユーザデータ項目の更新情報 (String)
REQ_DATE_H 関連ユーザデータ項目の更新情報 (String)
DATE_TYPE 関連ユーザデータ項目の更新情報 (String)
PURCH_DATE 関連ユーザデータ項目の更新情報 (String)
PO_METHOD 関連ユーザデータ項目の更新情報 (String)
PO_SUPPLEM 関連ユーザデータ項目の更新情報 (String)
REF_1 関連ユーザデータ項目の更新情報 (String)
NAME 関連ユーザデータ項目の更新情報 (String)
TELEPHONE 関連ユーザデータ項目の更新情報 (String)
PRICE_GRP 関連ユーザデータ項目の更新情報 (String)
CUST_GROUP 関連ユーザデータ項目の更新情報 (String)
SALES_DIST 関連ユーザデータ項目の更新情報 (String)
PRICE_LIST 関連ユーザデータ項目の更新情報 (String)
INCOTERMS1 関連ユーザデータ項目の更新情報 (String)
INCOTERMS2 関連ユーザデータ項目の更新情報 (String)
PMNTTRMS 関連ユーザデータ項目の更新情報 (String)
DLV_BLOCK 関連ユーザデータ項目の更新情報 (String)
BILL_BLOCK 関連ユーザデータ項目の更新情報 (String)
ORD_REASON 関連ユーザデータ項目の更新情報 (String)
COMPL_DLV 関連ユーザデータ項目の更新情報 (String)
PRICE_DATE 関連ユーザデータ項目の更新情報 (String)
QT_VALID_F 関連ユーザデータ項目の更新情報 (String)
QT_VALID_T 関連ユーザデータ項目の更新情報 (String)
CT_VALID_F 関連ユーザデータ項目の更新情報 (String)
CT_VALID_T 関連ユーザデータ項目の更新情報 (String)
CUST_GRP1 関連ユーザデータ項目の更新情報 (String)
CUST_GRP2 関連ユーザデータ項目の更新情報 (String)
CUST_GRP3 関連ユーザデータ項目の更新情報 (String)
CUST_GRP4 関連ユーザデータ項目の更新情報 (String)
CUST_GRP5 関連ユーザデータ項目の更新情報 (String)
PURCH_NO_C 関連ユーザデータ項目の更新情報 (String)
PURCH_NO_S 関連ユーザデータ項目の更新情報 (String)
PO_DAT_S 関連ユーザデータ項目の更新情報 (String)
PO_METH_S 関連ユーザデータ項目の更新情報 (String)
REF_1_S 関連ユーザデータ項目の更新情報 (String)
SD_DOC_CAT 関連ユーザデータ項目の更新情報 (String)
DOC_DATE 関連ユーザデータ項目の更新情報 (String)
WAR_DATE 関連ユーザデータ項目の更新情報 (String)
SHIP_COND 関連ユーザデータ項目の更新情報 (String)
PP_SEARCH 関連ユーザデータ項目の更新情報 (String)
DUN_COUNT 関連ユーザデータ項目の更新情報 (String)
DUN_DATE 関連ユーザデータ項目の更新情報 (String)
DLVSCHDUSE 関連ユーザデータ項目の更新情報 (String)
PLDLVSTYP 関連ユーザデータ項目の更新情報 (String)
REF_DOC 関連ユーザデータ項目の更新情報 (String)
COMP_CDE_B 関連ユーザデータ項目の更新情報 (String)
ALTTAX_CLS 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS2 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS3 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS4 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS5 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS6 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS7 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS8 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS9 関連ユーザデータ項目の更新情報 (String)
REF_DOC_L 関連ユーザデータ項目の更新情報 (String)
ASS_NUMBER 関連ユーザデータ項目の更新情報 (String)
REFDOC_CAT 関連ユーザデータ項目の更新情報 (String)
ORDCOMB_IN 関連ユーザデータ項目の更新情報 (String)
BILL_SCHED 関連ユーザデータ項目の更新情報 (String)
INVO_SCHED 関連ユーザデータ項目の更新情報 (String)
MN_INVOICE 関連ユーザデータ項目の更新情報 (String)
EXRATE_FI 関連ユーザデータ項目の更新情報 (String)
ADD_VAL_DY 関連ユーザデータ項目の更新情報 (String)
FIX_VAL_DY 関連ユーザデータ項目の更新情報 (String)
PYMT_METH 関連ユーザデータ項目の更新情報 (String)
ACCNT_ASGN 関連ユーザデータ項目の更新情報 (String)
EXCHG_RATE 関連ユーザデータ項目の更新情報 (String)
BILL_DATE 関連ユーザデータ項目の更新情報 (String)
SERV_DATE 関連ユーザデータ項目の更新情報 (String)
DUNN_KEY 関連ユーザデータ項目の更新情報 (String)
DUNN_BLOCK 関連ユーザデータ項目の更新情報 (String)
PROMOTION 関連ユーザデータ項目の更新情報 (String)
PMTGAR_PRO 関連ユーザデータ項目の更新情報 (String)
DEPARTM_NO 関連ユーザデータ項目の更新情報 (String)
REC_POINT 関連ユーザデータ項目の更新情報 (String)
POITM_NO_S 関連ユーザデータ項目の更新情報 (String)
DOC_NUM_FI 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP1 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP2 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP3 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP4 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP5 関連ユーザデータ項目の更新情報 (String)
DLV_TIME 関連ユーザデータ項目の更新情報 (String)
CURRENCY 関連ユーザデータ項目の更新情報 (String)
TAXDEP_CTY 関連ユーザデータ項目の更新情報 (String)
TAXDST_CTY 関連ユーザデータ項目の更新情報 (String)
EUTRI_DEAL 関連ユーザデータ項目の更新情報 (String)
MAST_CONTR 関連ユーザデータ項目の更新情報 (String)
REF_PROC 関連ユーザデータ項目の更新情報 (String)
CHKPRTAUTH 関連ユーザデータ項目の更新情報 (String)
CMLQTY_DAT 関連ユーザデータ項目の更新情報 (String)
VERSION 関連ユーザデータ項目の更新情報 (String)
NOTIF_NO 関連ユーザデータ項目の更新情報 (String)
WBS_ELEM 関連ユーザデータ項目の更新情報 (String)
EXCH_RATE_FI_V 関連ユーザデータ項目の更新情報 (String)
EXCHG_RATE_V 関連ユーザデータ項目の更新情報 (String)
FKK_CONACCT 関連ユーザデータ項目の更新情報 (String)
CAMPAIGN 関連ユーザデータ項目の更新情報 (String)
DOC_CLASS 関連ユーザデータ項目の更新情報 (String)
H_CURR 関連ユーザデータ項目の更新情報 (String)
SHIP_TYPE 関連ユーザデータ項目の更新情報 (String)
S_PROC_IND 関連ユーザデータ項目の更新情報 (String)

ヘッダデータチェックボックスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["LOG_SYSTEM"]　→　配列内のidx番目のヘッダデータチェックボックスの「論理システム」
[idx]["UPDATEFLAG"]　→　配列内のidx番目のヘッダデータチェックボックスの「更新区分」
[idx]["DOC_TYPE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["COLLECT_NO"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SALES_ORG"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DISTR_CHAN"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DIVISION"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SALES_GRP"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SALES_OFF"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REQ_DATE_H"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DATE_TYPE"]　→idx　配列内の番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PURCH_DATE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_METHOD"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_SUPPLEM"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_1"]　→　配列内のidx番目のヘッダデータチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["NAME"]　→　配列内のidx番目のヘッダデータチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["TELEPHONE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_GRP"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CUST_GROUP"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SALES_DIST"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_LIST"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INCOTERMS1"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INCOTERMS2"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PMNTTRMS"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLV_BLOCK"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_BLOCK"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ORD_REASON"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["COMPL_DLV"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_DATE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["QT_VALID_F"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["QT_VALID_T"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CT_VALID_F"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CT_VALID_T"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CUST_GRP1"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CUST_GRP2"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CUST_GRP3"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CUST_GRP4"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CUST_GRP5"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PURCH_NO_C"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PURCH_NO_S"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_DAT_S"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_METH_S"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_1_S"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SD_DOC_CAT"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DOC_DATE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["WAR_DATE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SHIP_COND"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PP_SEARCH"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DUN_COUNT"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DUN_DATE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLVSCHDUSE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PLDLVSTYP"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_DOC"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["COMP_CDE_B"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ALTTAX_CLS"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS2"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS3"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS4"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS5"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS6"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS7"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS8"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS9"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_DOC_L"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ASS_NUMBER"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REFDOC_CAT"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ORDCOMB_IN"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_SCHED"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INVO_SCHED"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MN_INVOICE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXRATE_FI"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ADD_VAL_DY"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FIX_VAL_DY"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PYMT_METH"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ACCNT_ASGN"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCHG_RATE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_DATE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SERV_DATE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DUNN_KEY"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DUNN_BLOCK"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PROMOTION"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PMTGAR_PRO"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DEPARTM_NO"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REC_POINT"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["POITM_NO_S"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DOC_NUM_FI"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP1"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP2"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP3"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP4"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP5"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLV_TIME"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CURRENCY"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAXDEP_CTY"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAXDST_CTY"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EUTRI_DEAL"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAST_CONTR"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_PROC"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CHKPRTAUTH"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CMLQTY_DAT"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["VERSION"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["NOTIF_NO"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["WBS_ELEM"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCH_RATE_FI_V"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCHG_RATE_V"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FKK_CONACCT"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CAMPAIGN"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DOC_CLASS"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["H_CURR"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SHIP_TYPE"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["S_PROC_IND"]　→　配列内のidx番目のヘッダデータチェックボックスの 「関連ユーザデータ項目の更新情報」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderItemsInList

Array getOrderItemsInList ()

明細データを取得します。
返却値
Array 明細データ

明細データオブジェクトの構成は以下のとおりです。
ITM_NUMBER 販売伝票明細 (String)
HG_LV_ITEM 上位レベル明細 (String)
PO_ITM_NO 元となる購買発注の明細番号 (String)
MATERIAL 品目コード (String)
ALT_TO_ITM 代替明細 (String)
CUST_MAT22 得意先品目コード (無効) (String)
BATCH ロット番号 (String)
DLV_GROUP 出荷グループ (明細一括出荷) (String)
PART_DLV 明細レベルの分納納入 (String)
REASON_REJ 見積および受注の拒否理由 (String)
BILL_BLOCK ブロック (String)
BILL_DATE 請求索引および印刷に対する請求日 (String)
PLANT プラント (String)
STORE_LOC 保管場所 (String)
TARGET_QTY 目標数量（販売単位） (String)
TARGET_QU 目標数量 (数量単位) (String)
T_UNIT_ISO 目標数量単位 (ISO コード) (String)
ITEM_CATEG 明細カテゴリ (販売伝票) (String)
SHORT_TEXT テキスト (短): 受注明細 (String)
PRC_GROUP1 品目グループ 1 (String)
PRC_GROUP2 品目グループ 2 (String)
PRC_GROUP3 品目グループ 3 (String)
PRC_GROUP4 品目グループ 4 (String)
PRC_GROUP5 品目グループ 5 (String)
PROD_HIERA 品目階層 (String)
MATL_GROUP 品目グループ (String)
PURCH_NO_C 出荷先発注番号 (String)
PURCH_DATE 得意先発注日付 (String)
PO_METHOD 得意先発注タイプ (String)
REF_1 得意先/仕入先の内部参照コード (String)
PURCH_NO_S 出荷先の得意先発注番号 (String)
PO_DAT_S 出荷先の出荷先発注日付 (String)
PO_METH_S 出荷先の出荷先発注タイプ (String)
REF_1_S 出荷先文字 (String)
POITM_NO_S 元となる購買発注の明細番号 (String)
PRICE_GRP 価格グループ (得意先) (String)
CUST_GROUP 得意先グループ (String)
SALES_DIST 販売地域 (String)
PRICE_LIST 価格表タイプ (String)
INCOTERMS1 インコタームズ (1) (String)
INCOTERMS2 インコタームズ 2 (String)
ORDCOMP_IN 受注結合出荷区分 (String)
BILL_SCHED 請求日程 (稼働日カレンダ指定) (String)
INVO_SCHED 請求書一覧日程 (稼働日カレンダ指定) (String)
MN_INVOICE マニュアル請求書更新 (String)
EX_RATE_FI FI 転記の換算レート (直接相場) (String)
ADD_VAL_DY 有効日からの日数 (String)
FIX_VAL_DY 有効日日付 (String)
PMNTTRMS 支払条件キー (String)
PYMT_METH 支払方法 (String)
ACCNT_ASGN 得意先の勘定設定グループ (String)
EXCHG_RATE 価格設定/統計の換算レート (直接引用) (String)
PRICE_DATE 価格設定/外貨換算の実行日付 (String)
SERV_DATE サービス提供日 (String)
DUNN_KEY 督促処理キー (String)
DUNN_BLOCK 督促処理保留 (String)
PROMOTION プロモーション (String)
PMTGAR_PRO 支払保証決定表 (String)
DOC_NUM_FI ドキュメンタリクレジット処理: 内部番号 (String)
DEPARTM_NO 部門コード (String)
REC_POINT 入荷ポイント (String)
CSTCNDGRP1 得意先条件グループ１ (String)
CSTCNDGRP2 得意先条件グループ２ (String)
CSTCNDGRP3 得意先条件グループ３ (String)
CSTCNDGRP4 得意先条件グループ４ (String)
CSTCNDGRP5 得意先条件グループ５ (String)
DLV_TIME 契約出荷期間 (String)
SALES_UNIT 販売単位 (String)
S_UNIT_ISO 単位の ISO コード (String)
TRG_QTY_NO 販売単位から基本単位への換算係数 (String)
TRGQTY_DEN 販売単位から基本単位への換算係数 (String)
RNDDLV_QTY 丸め数量: 出荷 (String)
MAXDEVAMNT 数量に関する許容偏差 (絶対値) (String)
MAXDEVPER 数量に関する許容偏差 (%) (String)
MAXDEV_DAY シフト所要日数 (String)
USAGE_IND 未使用 - 予約長 3 (String)
FIXED_QUAN 数量固定区分 (String)
UNLMT_DLV 区分: 無制限過剰納入可能 (String)
OVERDLVTOL 過剰納入許容範囲 (String)
UNDDLV_TOL 不足納入許容範囲リミット (String)
DIVISION 製品部門 (String)
SALQTYNUM 販売数量単位から基本数量単位への変換係数の分子 (String)
SALQTYDEN 販売数量単位を SKU に換算するための分母 (除数) (String)
GROSS_WGHT 明細の総重量 (String)
NET_WEIGHT 明細の正味重量 (String)
UNTOF_WGHT 重量単位 (String)
UNOF_WTISO ISO コードでの重量単位 (String)
VOLUME 明細の総数量 (String)
VOLUNIT 容積単位 (String)
VOLUNITISO ISO コードでの容積単位 (String)
DLV_PRIO 出荷優先順位 (String)
SHIP_POINT 出荷ポイント/入荷ポイント (String)
ROUTE 輸送経路 (String)
CREATED_BY オブジェクト登録者名 (String)
TAX_CLASS1 品目の税分類 (String)
TAX_CLASS2 品目の税分類 (String)
TAX_CLASS3 品目の税分類 (String)
TAX_CLASS4 品目の税分類 (String)
TAX_CLASS5 品目の税分類 (String)
TAX_CLASS6 品目の税分類 (String)
TAX_CLASS7 品目の税分類 (String)
TAX_CLASS8 品目の税分類 (String)
TAX_CLASS9 品目の税分類 (String)
MAT_PR_GRP 品目価格設定グループ (String)
VAL_TYPE 評価タイプ (String)
FIXDAT_QTY 納期と出荷数量の固定 (String)
BOMEXPL_NO BOM 展開番号 (String)
RESANALKEY 結果分析キー (String)
REQMTS_TYP 所要量タイプ (String)
NO_GR_POST 得意先が入庫を転記していません (String)
BUS_TRANST 貿易管理の取引タイプ (String)
OVERHD_KEY 間接費キー (String)
CSTG_SHEET 原価計算表 (String)
MATFRGTGRP 品目運賃グループ (String)
PLDLVSHDIN 出荷計画に関する指示 (String)
SEQ_NO KANBAN/連続番号 (String)
BIL_FORM 請求書式 (String)
DLI_PROFIL 動的明細プロセッサプロファイル (String)
REV_TYPE 収益承認カテゴリ (String)
BEGDEM_PER 見越期間の提案開始日付 (String)
PR_REF_MAT 価格設定参照品目 (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)
ORDER_PROB 明細の受注可能性 (String)
MAX_PL_DLV 明細ごとの分割納入可能な最大回数 (String)
CFOP_CODE CFOP code and extension (old 5 char version) (String)
TAXLAWICMS 税法: ICMS (String)
TAXLAWIPI 税法: IPI (String)
SD_TAXCODE 0 (String)
ASSORT_MOD 品揃モジュール (String)
COMP_QUANT 構成品目数量 (String)
TARGET_VAL BAPI の通貨額 (小数点以下９桁) (String)
CURRENCY 販売伝票通貨 (String)
CURR_ISO ISO コード通貨 (String)
PROFIT_CTR 利益センタ (String)
ORDERID 指図番号 (String)
WBS_ELEM WBS 要素 (String)
DEPREC_PER ドキュメンタリクレジット処理に関する償却率 (%) (String)
REF_DOC 参照伝票番号 (String)
REF_DOC_IT 参照明細番号 (String)
REF_DOC_CA 先行販売管理伝票の伝票カテゴリ (String)
CUST_MAT35 得意先品目 (String)
EXCH_RATE_FI_V FI 転記の換算レート (間接相場) (String)
EXCHG_RATE_V 価格設定/統計の換算レート (間接引用) (String)
ITEMGUID_ATP ATP: 暗号 - DELNR および DELPS (String)
VAL_CONTR 金額契約番号 (String)
VAL_CON_I 金額契約明細 (String)
CONFIG_ID 外部選定 ID (仮) (String)
INST_ID 選定におけるインスタンス番号 (String)
MAT_EXT 項目 MATERIAL の品目コード (長) (今後のリリースで開発) (String)
MAT_GUID 項目 MATERIAL の外部 GUID (今後のリリースで開発) (String)
MAT_VERS 項目 MATERIAL のバージョン番号 (今後のリリースで開発) (String)
P_MAT_EXT 項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発) (String)
P_MAT_GUID 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発) (String)
P_MAT_VERS 項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発) (String)
FUNC_AREA 機能領域 (String)
ALTERN_BOM 代替 BOM (String)
FKK_CONACCT 長さ 12 の文字項目 (String)
EAN_UPC 国際商品コード (EAN/UPC) (String)
PRODCAT 製品カタログ番号 (String)
SHIP_TYPE 出荷タイプ (String)
S_PROC_IND 特別処理区分 (String)
FUNC_AREA_LONG 機能領域 (String)
BILL_REL 請求関連 (CRM) (String)
VW_UEPOS 上位レベル明細用途 ID (String)
CAMPAIGN 総括プロジェクト計画: 外部 R/3 システムの GUID (String)
DLVSCHDUSE 用途区分 (String)
CFOP_LONG CFOP code and extension (String)
SELECTION 選択 ID (永続) (String)
MAT_ENTRD 入力品目 (String)
LOG_SYSTEM_OWN 論理システム (String)
ITM_TYPE_USAGE 明細用途 (String)

明細データオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の明細データの「販売伝票明細」
[idx]["HG_LV_ITEM"]　→　配列内のidx番目の明細データの「上位レベル明細」
[idx]["PO_ITM_NO"]　→　配列内のidx番目の明細データの「元となる購買発注の明細番号」
[idx]["MATERIAL"]　→　配列内のidx番目の明細データの「品目コード」
[idx]["ALT_TO_ITM"]　→　配列内のidx番目の明細データの「代替明細」
[idx]["CUST_MAT22"]　→　配列内のidx番目の明細データの「得意先品目コード (無効)」
[idx]["BATCH"]　→　配列内のidx番目の明細データの「ロット番号」
[idx]["DLV_GROUP"]　→　配列内のidx番目の明細データの「出荷グループ (明細一括出荷)」
[idx]["PART_DLV"]　→　配列内のidx番目の明細データの「明細レベルの分納納入」
[idx]["REASON_REJ"]　→　配列内のidx番目の明細データの「見積および受注の拒否理由」
[idx]["BILL_BLOCK"]　→　配列内のidx番目の明細データの「ブロック」
[idx]["BILL_DATE"]　→　配列内のidx番目の明細データの「請求索引および印刷に対する請求日」
[idx]["PLANT"]　→　配列内のidx番目の明細データの「プラント」
[idx]["STORE_LOC"]　→　配列内のidx番目の明細データの「保管場所」
[idx]["TARGET_QTY"]　→　配列内のidx番目の明細データの「目標数量（販売単位）」
[idx]["TARGET_QU"]　→　配列内のidx番目の明細データの「目標数量 (数量単位)」
[idx]["T_UNIT_ISO"]　→　配列内のidx番目の明細データの「目標数量単位 (ISO コード)」
[idx]["ITEM_CATEG"]　→　配列内のidx番目の明細データの「明細カテゴリ (販売伝票)」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の明細データの「テキスト (短): 受注明細」
[idx]["PRC_GROUP1"]　→　配列内のidx番目の明細データの「品目グループ 1」
[idx]["PRC_GROUP2"]　→　配列内のidx番目の明細データの「品目グループ 2」
[idx]["PRC_GROUP3"]　→　配列内のidx番目の明細データの「品目グループ 3」
[idx]["PRC_GROUP4"]　→　配列内のidx番目の明細データの「品目グループ 4」
[idx]["PRC_GROUP5"]　→　配列内のidx番目の明細データの「品目グループ 5」
[idx]["PROD_HIERA"]　→　配列内のidx番目の明細データの「品目階層」
[idx]["MATL_GROUP"]　→　配列内のidx番目の明細データの「品目グループ」
[idx]["PURCH_NO_C"]　→　配列内のidx番目の明細データの「出荷先発注番号」
[idx]["PURCH_DATE"]　→　配列内のidx番目の明細データの「得意先発注日付」
[idx]["PO_METHOD"]　→　配列内のidx番目の明細データの「得意先発注タイプ」
[idx]["REF_1"]　→　配列内のidx番目の明細データの「得意先/仕入先の内部参照コード」
[idx]["PURCH_NO_S"]　→　配列内のidx番目の明細データの「出荷先の得意先発注番号」
[idx]["PO_DAT_S"]　→　配列内のidx番目の明細データの「出荷先の出荷先発注日付」
[idx]["PO_METH_S"]　→　配列内のidx番目の明細データの「出荷先の出荷先発注タイプ」
[idx]["REF_1_S"]　→　配列内のidx番目の明細データの「出荷先文字」
[idx]["POITM_NO_S"]　→　配列内のidx番目の明細データの「元となる購買発注の明細番号」
[idx]["PRICE_GRP"]　→　配列内のidx番目の明細データの「価格グループ (得意先)」
[idx]["CUST_GROUP"]　→　配列内のidx番目の明細データの「得意先グループ」
[idx]["SALES_DIST"]　→　配列内のidx番目の明細データの「販売地域」
[idx]["PRICE_LIST"]　→　配列内のidx番目の明細データの「価格表タイプ」
[idx]["INCOTERMS1"]　→　配列内のidx番目の明細データの「インコタームズ (1)」
[idx]["INCOTERMS2"]　→　配列内のidx番目の明細データの「インコタームズ 2」
[idx]["ORDCOMP_IN"]　→　配列内のidx番目の明細データの「受注結合出荷区分」
[idx]["BILL_SCHED"]　→　配列内のidx番目の明細データの「請求日程 (稼働日カレンダ指定)」
[idx]["INVO_SCHED"]　→　配列内のidx番目の明細データの「請求書一覧日程 (稼働日カレンダ指定)」
[idx]["MN_INVOICE"]　→　配列内のidx番目の明細データの「マニュアル請求書更新」
[idx]["EX_RATE_FI"]　→　配列内のidx番目の明細データの「FI 転記の換算レート (直接相場)」
[idx]["ADD_VAL_DY"]　→　配列内のidx番目の明細データの「有効日からの日数」
[idx]["FIX_VAL_DY"]　→　配列内のidx番目の明細データの「有効日日付」
[idx]["PMNTTRMS"]　→　配列内のidx番目の明細データの「支払条件キー」
[idx]["PYMT_METH"]　→　配列内のidx番目の明細データの「支払方法」
[idx]["ACCNT_ASGN"]　→　配列内のidx番目の明細データの「得意先の勘定設定グループ」
[idx]["EXCHG_RATE"]　→　配列内のidx番目の明細データの 「価格設定/統計の換算レート (直接引用)」
[idx]["PRICE_DATE"]　→　配列内のidx番目の明細データの「価格設定/外貨換算の実行日付」
[idx]["SERV_DATE"]　→　配列内のidx番目の明細データの「サービス提供日」
[idx]["DUNN_KEY"]　→　配列内のidx番目の明細データの「督促処理キー」
[idx]["DUNN_BLOCK"]　→　配列内のidx番目の明細データの「督促処理保留」
[idx]["PROMOTION"]　→　配列内のidx番目の明細データの「プロモーション」
[idx]["PMTGAR_PRO"]　→　配列内のidx番目の明細データの「支払保証決定表」
[idx]["DOC_NUM_FI"]　→　配列内のidx番目の明細データの 「ドキュメンタリクレジット処理: 内部番号」
[idx]["DEPARTM_NO"]　→　配列内のidx番目の明細データの「部門コード」
[idx]["REC_POINT"]　→　配列内のidx番目の明細データの「入荷ポイント」
[idx]["CSTCNDGRP1"]　→　配列内のidx番目の明細データの「得意先条件グループ１」
[idx]["CSTCNDGRP2"]　→　配列内のidx番目の明細データの「得意先条件グループ２」
[idx]["CSTCNDGRP3"]　→　配列内のidx番目の明細データの「得意先条件グループ３」
[idx]["CSTCNDGRP4"]　→　配列内のidx番目の明細データの「得意先条件グループ４」
[idx]["CSTCNDGRP5"]　→　配列内のidx番目の明細データの「得意先条件グループ５」
[idx]["DLV_TIME"]　→　配列内のidx番目の明細データの「契約出荷期間」
[idx]["SALES_UNIT"]　→　配列内のidx番目の明細データの「販売単位」
[idx]["S_UNIT_ISO"]　→　配列内のidx番目の明細データの「単位の ISO コード」
[idx]["TRG_QTY_NO"]　→　配列内のidx番目の明細データの「販売単位から基本単位への換算係数」
[idx]["TRGQTY_DEN"]　→　配列内のidx番目の明細データの「販売単位から基本単位への換算係数」
[idx]["RNDDLV_QTY"]　→　配列内のidx番目の明細データの「丸め数量: 出荷」
[idx]["MAXDEVAMNT"]　→　配列内のidx番目の明細データの「数量に関する許容偏差 (絶対値)」
[idx]["MAXDEVPER"]　→　配列内のidx番目の明細データの「数量に関する許容偏差 (%)」
[idx]["MAXDEV_DAY"]　→　配列内のidx番目の明細データの「シフト所要日数」
[idx]["USAGE_IND"]　→　配列内のidx番目の明細データの「未使用 - 予約長 3」
[idx]["FIXED_QUAN"]　→　配列内のidx番目の明細データの「数量固定区分」
[idx]["UNLMT_DLV"]　→　配列内のidx番目の明細データの「区分: 無制限過剰納入可能」
[idx]["OVERDLVTOL"]　→　配列内のidx番目の明細データの「過剰納入許容範囲」
[idx]["UNDDLV_TOL"]　→　配列内のidx番目の明細データの「不足納入許容範囲リミット」
[idx]["DIVISION"]　→　配列内のidx番目の明細データの「製品部門」
[idx]["SALQTYNUM"]　→　配列内のidx番目の明細データの 「販売数量単位から基本数量単位への変換係数の分子」
[idx]["SALQTYDEN"]　→　配列内のidx番目の明細データの 「販売数量単位を SKU に換算するための分母 (除数)」
[idx]["GROSS_WGHT"]　→　配列内のidx番目の明細データの「明細の総重量」
[idx]["NET_WEIGHT"]　→　配列内のidx番目の明細データの「明細の正味重量」
[idx]["UNTOF_WGHT"]　→　配列内のidx番目の明細データの「重量単位」
[idx]["UNOF_WTISO"]　→　配列内のidx番目の明細データの「ISO コードでの重量単位」
[idx]["VOLUME"]　→　配列内のidx番目の明細データの「明細の総数量」
[idx]["VOLUNIT"]　→　配列内のidx番目の明細データの「容積単位」
[idx]["VOLUNITISO"]　→　配列内のidx番目の明細データの「ISO コードでの容積単位」
[idx]["DLV_PRIO"]　→　配列内のidx番目の明細データの「出荷優先順位」
[idx]["SHIP_POINT"]　→　配列内のidx番目の明細データの「出荷ポイント/入荷ポイント」
[idx]["ROUTE"]　→　配列内のidx番目の明細データの「輸送経路」
[idx]["CREATED_BY"]　→　配列内のidx番目の明細データの「オブジェクト登録者名」
[idx]["TAX_CLASS1"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS2"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS3"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS4"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS5"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS6"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS7"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS8"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["TAX_CLASS9"]　→　配列内のidx番目の明細データの「品目の税分類」
[idx]["MAT_PR_GRP"]　→　配列内のidx番目の明細データの「品目価格設定グループ」
[idx]["VAL_TYPE"]　→　配列内のidx番目の明細データの「評価タイプ」
[idx]["FIXDAT_QTY"]　→　配列内のidx番目の明細データの「納期と出荷数量の固定」
[idx]["BOMEXPL_NO"]　→　配列内のidx番目の明細データの「BOM 展開番号」
[idx]["RESANALKEY"]　→　配列内のidx番目の明細データの「結果分析キー」
[idx]["REQMTS_TYP"]　→　配列内のidx番目の明細データの「所要量タイプ」
[idx]["NO_GR_POST"]　→　配列内のidx番目の明細データの「得意先が入庫を転記していません」
[idx]["BUS_TRANST"]　→　配列内のidx番目の明細データの「貿易管理の取引タイプ」
[idx]["OVERHD_KEY"]　→　配列内のidx番目の明細データの「間接費キー」
[idx]["CSTG_SHEET"]　→　配列内のidx番目の明細データの「原価計算表」
[idx]["MATFRGTGRP"]　→　配列内のidx番目の明細データの「品目運賃グループ」
[idx]["PLDLVSHDIN"]　→　配列内のidx番目の明細データの「出荷計画に関する指示」
[idx]["SEQ_NO"]　→　配列内のidx番目の明細データの「KANBAN/連続番号」
[idx]["BIL_FORM"]　→　配列内のidx番目の明細データの「請求書式」
[idx]["DLI_PROFIL"]　→　配列内のidx番目の明細データの「動的明細プロセッサプロファイル」
[idx]["REV_TYPE"]　→　配列内のidx番目の明細データの「収益承認カテゴリ」
[idx]["BEGDEM_PER"]　→　配列内のidx番目の明細データの「見越期間の提案開始日付」
[idx]["PR_REF_MAT"]　→　配列内のidx番目の明細データの「価格設定参照品目」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の明細データの「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の明細データの「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の明細データの「論理システム」
[idx]["ORDER_PROB"]　→　配列内のidx番目の明細データの「明細の受注可能性」
[idx]["MAX_PL_DLV"]　→　配列内のidx番目の明細データの「明細ごとの分割納入可能な最大回数」
[idx]["CFOP_CODE"]　→　配列内のidx番目の明細データの 「CFOP code and extension (old 5 char version)」
[idx]["TAXLAWICMS"]　→　配列内のidx番目の明細データの「税法: ICMS」
[idx]["TAXLAWIPI"]　→　配列内のidx番目の明細データの「税法: IPI」
[idx]["SD_TAXCODE"]　→　配列内のidx番目の明細データの「0」
[idx]["ASSORT_MOD"]　→　配列内のidx番目の明細データの「品揃モジュール」
[idx]["COMP_QUANT"]　→　配列内のidx番目の明細データの「構成品目数量」
[idx]["TARGET_VAL"]　→　配列内のidx番目の明細データの「BAPI の通貨額 (小数点以下９桁)」
[idx]["CURRENCY"]　→　配列内のidx番目の明細データの「販売伝票通貨」
[idx]["CURR_ISO"]　→　配列内のidx番目の明細データの「ISO コード通貨」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の明細データの「利益センタ」
[idx]["ORDERID"]　→　配列内のidx番目の明細データの「指図番号」
[idx]["WBS_ELEM"]　→　配列内のidx番目の明細データの「WBS 要素」
[idx]["DEPREC_PER"]　→　配列内のidx番目の明細データの 「ドキュメンタリクレジット処理に関する償却率 (%)」
[idx]["REF_DOC"]　→　配列内のidx番目の明細データの「参照伝票番号」
[idx]["REF_DOC_IT"]　→　配列内のidx番目の明細データの「参照明細番号」
[idx]["REF_DOC_CA"]　→　配列内のidx番目の明細データの「先行販売管理伝票の伝票カテゴリ」
[idx]["CUST_MAT35"]　→　配列内のidx番目の明細データの「得意先品目」
[idx]["EXCH_RATE_FI_V"]　→　配列内のidx番目の明細データの 「FI 転記の換算レート (間接相場)」
[idx]["EXCHG_RATE_V"]　→　配列内のidx番目の明細データの 「価格設定/統計の換算レート (間接引用)」
[idx]["ITEMGUID_ATP"]　→　配列内のidx番目の明細データの 「ATP: 暗号 - DELNR および DELPS」
[idx]["VAL_CONTR"]　→　配列内のidx番目の明細データの「金額契約番号」
[idx]["VAL_CON_I"]　→　配列内のidx番目の明細データの「金額契約明細」
[idx]["CONFIG_ID"]　→　配列内のidx番目の明細データの「外部選定 ID (仮)」
[idx]["INST_ID"]　→　配列内のidx番目の明細データの「選定におけるインスタンス番号」
[idx]["MAT_EXT"]　→　配列内のidx番目の明細データの 「項目 MATERIAL の品目コード (長) (今後のリリースで開発)」
[idx]["MAT_GUID"]　→　配列内のidx番目の明細データの 「項目 MATERIAL の外部 GUID (今後のリリースで開発)」
[idx]["MAT_VERS"]　→　配列内のidx番目の明細データの 「項目 MATERIAL のバージョン番号 (今後のリリースで開発)」
[idx]["P_MAT_EXT"]　→　配列内のidx番目の明細データの 「項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)」
[idx]["P_MAT_GUID"]　→　配列内のidx番目の明細データの 「項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)」
[idx]["P_MAT_VERS"]　→　配列内のidx番目の明細データの 「項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)」
[idx]["FUNC_AREA"]　→　配列内のidx番目の明細データの「機能領域」
[idx]["ALTERN_BOM"]　→　配列内のidx番目の明細データの「代替 BOM」
[idx]["FKK_CONACCT"]　→　配列内のidx番目の明細データの「長さ 12 の文字項目」
[idx]["EAN_UPC"]　→　配列内のidx番目の明細データの「国際商品コード (EAN/UPC)」
[idx]["PRODCAT"]　→　配列内のidx番目の明細データの「製品カタログ番号」
[idx]["SHIP_TYPE"]　→　配列内のidx番目の明細データの「出荷タイプ」
[idx]["S_PROC_IND"]　→　配列内のidx番目の明細データの「特別処理区分」
[idx]["FUNC_AREA_LONG"]　→　配列内のidx番目の明細データの「機能領域」
[idx]["BILL_REL"]　→　配列内のidx番目の明細データの「請求関連 (CRM)」
[idx]["VW_UEPOS"]　→　配列内のidx番目の明細データの「上位レベル明細用途 ID」
[idx]["CAMPAIGN"]　→　配列内のidx番目の明細データの 「総括プロジェクト計画: 外部 R/3 システムの GUID」
[idx]["DLVSCHDUSE"]　→　配列内のidx番目の明細データの「用途区分」
[idx]["CFOP_LONG"]　→　配列内のidx番目の明細データの 「CFOP code and extension」
[idx]["SELECTION"]　→　配列内のidx番目の明細データの「選択 ID (永続)」
[idx]["MAT_ENTRD"]　→　配列内のidx番目の明細データの「入力品目」
[idx]["LOG_SYSTEM_OWN"]　→　配列内のidx番目の明細データの「論理システム」
[idx]["ITM_TYPE_USAGE"]　→　配列内のidx番目の明細データの「明細用途」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderItemsInXList

Array getOrderItemsInXList ()

明細データチェックボックスを取得します。
返却値
Array 明細データチェックボックス

明細データチェックボックスオブジェクトの構成は以下のとおりです。
ITM_NUMBER 販売伝票明細 (String)
UPDATEFLAG 更新区分 (String)
HG_LV_ITEM 関連ユーザデータ項目の更新情報 (String)
PO_ITM_NO 関連ユーザデータ項目の更新情報 (String)
MATERIAL 関連ユーザデータ項目の更新情報 (String)
ALT_TO_ITM 関連ユーザデータ項目の更新情報 (String)
CUST_MAT22 関連ユーザデータ項目の更新情報 (String)
BATCH 関連ユーザデータ項目の更新情報 (String)
DLV_GROUP 関連ユーザデータ項目の更新情報 (String)
PART_DLV 関連ユーザデータ項目の更新情報 (String)
REASON_REJ 関連ユーザデータ項目の更新情報 (String)
BILL_BLOCK 関連ユーザデータ項目の更新情報 (String)
BILL_DATE 関連ユーザデータ項目の更新情報 (String)
PLANT 関連ユーザデータ項目の更新情報 (String)
STORE_LOC 関連ユーザデータ項目の更新情報 (String)
TARGET_QTY 関連ユーザデータ項目の更新情報 (String)
TARGET_QU 関連ユーザデータ項目の更新情報 (String)
T_UNIT_ISO 関連ユーザデータ項目の更新情報 (String)
ITEM_CATEG 関連ユーザデータ項目の更新情報 (String)
SHORT_TEXT 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP1 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP2 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP3 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP4 関連ユーザデータ項目の更新情報 (String)
PRC_GROUP5 関連ユーザデータ項目の更新情報 (String)
PROD_HIERA 関連ユーザデータ項目の更新情報 (String)
MATL_GROUP 関連ユーザデータ項目の更新情報 (String)
PURCH_NO_C 関連ユーザデータ項目の更新情報 (String)
PURCH_DATE 関連ユーザデータ項目の更新情報 (String)
PO_METHOD 関連ユーザデータ項目の更新情報 (String)
REF_1 関連ユーザデータ項目の更新情報 (String)
PURCH_NO_S 関連ユーザデータ項目の更新情報 (String)
PO_DAT_S 関連ユーザデータ項目の更新情報 (String)
PO_METH_S 関連ユーザデータ項目の更新情報 (String)
REF_1_S 関連ユーザデータ項目の更新情報 (String)
POITM_NO_S 関連ユーザデータ項目の更新情報 (String)
PRICE_GRP 関連ユーザデータ項目の更新情報 (String)
CUST_GROUP 関連ユーザデータ項目の更新情報 (String)
SALES_DIST 関連ユーザデータ項目の更新情報 (String)
PRICE_LIST 関連ユーザデータ項目の更新情報 (String)
INCOTERMS1 関連ユーザデータ項目の更新情報 (String)
INCOTERMS2 関連ユーザデータ項目の更新情報 (String)
ORDCOMP_IN 関連ユーザデータ項目の更新情報 (String)
BILL_SCHED 関連ユーザデータ項目の更新情報 (String)
INVO_SCHED 関連ユーザデータ項目の更新情報 (String)
MN_INVOICE 関連ユーザデータ項目の更新情報 (String)
EX_RATE_FI 関連ユーザデータ項目の更新情報 (String)
ADD_VAL_DY 関連ユーザデータ項目の更新情報 (String)
FIX_VAL_DY 関連ユーザデータ項目の更新情報 (String)
PMNTTRMS 関連ユーザデータ項目の更新情報 (String)
PYMT_METH 関連ユーザデータ項目の更新情報 (String)
ACCNT_ASGN 関連ユーザデータ項目の更新情報 (String)
EXCHG_RATE 関連ユーザデータ項目の更新情報 (String)
PRICE_DATE 関連ユーザデータ項目の更新情報 (String)
SERV_DATE 関連ユーザデータ項目の更新情報 (String)
DUNN_KEY 関連ユーザデータ項目の更新情報 (String)
DUNN_BLOCK 関連ユーザデータ項目の更新情報 (String)
PROMOTION 関連ユーザデータ項目の更新情報 (String)
PMTGAR_PRO 関連ユーザデータ項目の更新情報 (String)
DOC_NUM_FI 関連ユーザデータ項目の更新情報 (String)
DEPARTM_NO 関連ユーザデータ項目の更新情報 (String)
REC_POINT 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP1 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP2 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP3 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP4 関連ユーザデータ項目の更新情報 (String)
CSTCNDGRP5 関連ユーザデータ項目の更新情報 (String)
DLV_TIME 関連ユーザデータ項目の更新情報 (String)
SALES_UNIT 関連ユーザデータ項目の更新情報 (String)
TRG_QTY_NO 関連ユーザデータ項目の更新情報 (String)
TRGQTY_DEN 関連ユーザデータ項目の更新情報 (String)
RNDDLV_QTY 関連ユーザデータ項目の更新情報 (String)
MAXDEVAMNT 関連ユーザデータ項目の更新情報 (String)
MAXDEVPER 関連ユーザデータ項目の更新情報 (String)
MAXDEV_DAY 関連ユーザデータ項目の更新情報 (String)
USAGE_IND 関連ユーザデータ項目の更新情報 (String)
FIXED_QUAN 関連ユーザデータ項目の更新情報 (String)
UNLMT_DLV 関連ユーザデータ項目の更新情報 (String)
OVERDLVTOL 関連ユーザデータ項目の更新情報 (String)
UNDDLV_TOL 関連ユーザデータ項目の更新情報 (String)
DIVISION 関連ユーザデータ項目の更新情報 (String)
SALQTYNUM 関連ユーザデータ項目の更新情報 (String)
SALQTYDEN 関連ユーザデータ項目の更新情報 (String)
GROSS_WGHT 関連ユーザデータ項目の更新情報 (String)
NET_WEIGHT 関連ユーザデータ項目の更新情報 (String)
UNTOF_WGHT 関連ユーザデータ項目の更新情報 (String)
VOLUME 関連ユーザデータ項目の更新情報 (String)
VOLUNIT 関連ユーザデータ項目の更新情報 (String)
DLV_PRIO 関連ユーザデータ項目の更新情報 (String)
SHIP_POINT 関連ユーザデータ項目の更新情報 (String)
ROUTE 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS1 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS2 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS3 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS4 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS5 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS6 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS7 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS8 関連ユーザデータ項目の更新情報 (String)
TAX_CLASS9 関連ユーザデータ項目の更新情報 (String)
MAT_PR_GRP 関連ユーザデータ項目の更新情報 (String)
VAL_TYPE 関連ユーザデータ項目の更新情報 (String)
FIXDAT_QTY 関連ユーザデータ項目の更新情報 (String)
BOMEXPL_NO 関連ユーザデータ項目の更新情報 (String)
RESANALKEY 関連ユーザデータ項目の更新情報 (String)
REQMTS_TYP 関連ユーザデータ項目の更新情報 (String)
NO_GR_POST 関連ユーザデータ項目の更新情報 (String)
BUS_TRANST 関連ユーザデータ項目の更新情報 (String)
OVERHD_KEY 関連ユーザデータ項目の更新情報 (String)
CSTG_SHEET 関連ユーザデータ項目の更新情報 (String)
MATFRGTGRP 関連ユーザデータ項目の更新情報 (String)
PLDLVSHDIN 関連ユーザデータ項目の更新情報 (String)
SEQ_NO 関連ユーザデータ項目の更新情報 (String)
BIL_FORM 関連ユーザデータ項目の更新情報 (String)
DLI_PROFIL 関連ユーザデータ項目の更新情報 (String)
REV_TYPE 関連ユーザデータ項目の更新情報 (String)
BEGDEM_PER 関連ユーザデータ項目の更新情報 (String)
PR_REF_MAT 関連ユーザデータ項目の更新情報 (String)
REFOBJTYPE 関連ユーザデータ項目の更新情報 (String)
REFOBJKEY 関連ユーザデータ項目の更新情報 (String)
REFLOGSYS 関連ユーザデータ項目の更新情報 (String)
ORDER_PROB 関連ユーザデータ項目の更新情報 (String)
MAX_PL_DLV 関連ユーザデータ項目の更新情報 (String)
CFOP_CODE 関連ユーザデータ項目の更新情報 (String)
TAXLAWICMS 関連ユーザデータ項目の更新情報 (String)
TAXLAWIPI 関連ユーザデータ項目の更新情報 (String)
SD_TAXCODE 関連ユーザデータ項目の更新情報 (String)
ASSORT_MOD 関連ユーザデータ項目の更新情報 (String)
COMP_QUANT 関連ユーザデータ項目の更新情報 (String)
TARGET_VAL 関連ユーザデータ項目の更新情報 (String)
PROFIT_CTR 関連ユーザデータ項目の更新情報 (String)
ORDERID 関連ユーザデータ項目の更新情報 (String)
WBS_ELEM 関連ユーザデータ項目の更新情報 (String)
DEPREC_PER 関連ユーザデータ項目の更新情報 (String)
REF_DOC 関連ユーザデータ項目の更新情報 (String)
REF_DOC_IT 関連ユーザデータ項目の更新情報 (String)
REF_DOC_CA 関連ユーザデータ項目の更新情報 (String)
CUST_MAT35 関連ユーザデータ項目の更新情報 (String)
EXCH_RATE_FI_V 関連ユーザデータ項目の更新情報 (String)
EXCHG_RATE_V 関連ユーザデータ項目の更新情報 (String)
ITEMGUID_ATP 関連ユーザデータ項目の更新情報 (String)
VAL_CONTR 関連ユーザデータ項目の更新情報 (String)
VAL_CON_I 関連ユーザデータ項目の更新情報 (String)
CONFIG_ID 関連ユーザデータ項目の更新情報 (String)
INST_ID 関連ユーザデータ項目の更新情報 (String)
MAT_EXT 関連ユーザデータ項目の更新情報 (String)
MAT_GUID 関連ユーザデータ項目の更新情報 (String)
MAT_VERS 関連ユーザデータ項目の更新情報 (String)
P_MAT_EXT 関連ユーザデータ項目の更新情報 (String)
P_MAT_GUID 関連ユーザデータ項目の更新情報 (String)
P_MAT_VERS 関連ユーザデータ項目の更新情報 (String)
FUNC_AREA 関連ユーザデータ項目の更新情報 (String)
ALTERN_BOM 関連ユーザデータ項目の更新情報 (String)
FKK_CONACCT 関連ユーザデータ項目の更新情報 (String)
EAN_UPC 関連ユーザデータ項目の更新情報 (String)
PRODCAT 関連ユーザデータ項目の更新情報 (String)
SHIP_TYPE 関連ユーザデータ項目の更新情報 (String)
S_PROC_IND 関連ユーザデータ項目の更新情報 (String)
BILL_REL 関連ユーザデータ項目の更新情報 (String)
VW_UEPOS 関連ユーザデータ項目の更新情報 (String)
CAMPAIGN 関連ユーザデータ項目の更新情報 (String)
DLVSCHDUSE 関連ユーザデータ項目の更新情報 (String)
SELECTION 関連ユーザデータ項目の更新情報 (String)
MAT_ENTRD 関連ユーザデータ項目の更新情報 (String)
LOG_SYSTEM_OWN 関連ユーザデータ項目の更新情報 (String)
ITM_TYPE_USAGE 関連ユーザデータ項目の更新情報 (String)

明細データチェックボックスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の明細データチェックボックスの「販売伝票明細」
[idx]["UPDATEFLAG"]　→　配列内のidx番目の明細データチェックボックスの「更新区分
[idx]["HG_LV_ITEM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_ITM_NO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["MATERIAL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["ALT_TO_ITM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["CUST_MAT22"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["BATCH"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報
[idx]["DLV_GROUP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["PART_DLV"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["REASON_REJ"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_BLOCK"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_DATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PLANT"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["STORE_LOC"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TARGET_QTY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["TARGET_QU"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["T_UNIT_ISO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ITEM_CATEG"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP1"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP2"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP3"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP4"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRC_GROUP5"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PROD_HIERA"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["MATL_GROUP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PURCH_NO_C"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PURCH_DATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_METHOD"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_1"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["PURCH_NO_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_DAT_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PO_METH_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_1_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["POITM_NO_S"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_GRP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["CUST_GROUP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SALES_DIST"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_LIST"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INCOTERMS1"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INCOTERMS2"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ORDCOMP_IN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_SCHED"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INVO_SCHED"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MN_INVOICE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EX_RATE_FI"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ADD_VAL_DY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FIX_VAL_DY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["PMNTTRMS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["PYMT_METH"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ACCNT_ASGN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCHG_RATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRICE_DATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SERV_DATE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DUNN_KEY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DUNN_BLOCK"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PROMOTION"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PMTGAR_PRO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DOC_NUM_FI"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DEPARTM_NO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REC_POINT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP1"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP2"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["CSTCNDGRP3"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["CSTCNDGRP4"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTCNDGRP5"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLV_TIME"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SALES_UNIT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TRG_QTY_NO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TRGQTY_DEN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["RNDDLV_QTY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAXDEVAMNT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAXDEVPER"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAXDEV_DAY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["USAGE_IND"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FIXED_QUAN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["UNLMT_DLV"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["OVERDLVTOL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["UNDDLV_TOL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DIVISION"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["SALQTYNUM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["SALQTYDEN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["GROSS_WGHT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["NET_WEIGHT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["UNTOF_WGHT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["VOLUME"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["VOLUNIT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLV_PRIO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SHIP_POINT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ROUTE"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS1"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS2"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS3"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS4"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS5"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS6"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS7"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS8"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAX_CLASS9"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["MAT_PR_GRP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["VAL_TYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FIXDAT_QTY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BOMEXPL_NO"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["RESANALKEY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REQMTS_TYP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["NO_GR_POST"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BUS_TRANST"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["OVERHD_KEY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CSTG_SHEET"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MATFRGTGRP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PLDLVSHDIN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SEQ_NO"]　→　配列内のidx番目の明細データチェックボックスの「関連ユーザデータ項目の更新情報」
[idx]["BIL_FORM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLI_PROFIL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REV_TYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BEGDEM_PER"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PR_REF_MAT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REFOBJKEY"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REFLOGSYS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["ORDER_PROB"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAX_PL_DLV"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CFOP_CODE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAXLAWICMS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TAXLAWIPI"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SD_TAXCODE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ASSORT_MOD"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["COMP_QUANT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["TARGET_VAL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ORDERID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["WBS_ELEM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DEPREC_PER"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_DOC"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_DOC_IT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["REF_DOC_CA"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CUST_MAT35"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCH_RATE_FI_V"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EXCHG_RATE_V"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ITEMGUID_ATP"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["VAL_CONTR"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["VAL_CON_I"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CONFIG_ID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["INST_ID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_EXT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_GUID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_VERS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["P_MAT_EXT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["P_MAT_GUID"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["P_MAT_VERS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FUNC_AREA"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ALTERN_BOM"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["FKK_CONACCT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["EAN_UPC"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["PRODCAT"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SHIP_TYPE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["S_PROC_IND"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["BILL_REL"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["VW_UEPOS"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["CAMPAIGN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["DLVSCHDUSE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["SELECTION"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["MAT_ENTRD"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報
[idx]["LOG_SYSTEM_OWN"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」
[idx]["ITM_TYPE_USAGE"]　→　配列内のidx番目の明細データチェックボックスの 「関連ユーザデータ項目の更新情報」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderKeysList

Array getOrderKeysList ()

参照キーの出力を取得します。
返却値
Array 参照キーの出力

参照キーの出力オブジェクトの構成は以下のとおりです。
REFOBJTYP オブジェクトタイプ (String)
REFOBJECT オブジェクト名 (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)
DOC_NUMBER 販売管理伝票番号 (String)
ITM_NUMBER 販売伝票明細 (String)
SCHED_LIN 納入日程行 (String)
COND_NO 伝票条件番号 (String)
CONDITEMNO 条件明細番号 (String)
COND_ST_NO ステップ番号 (String)
COND_COUNT 条件カウンタ (String)
COND_TYPE 条件タイプ (String)
STATUS 単一文字フラグ (String)
TINDEX 数値項目: 長さ 6 (String)
ADDRESS 住所 (String)
ABRLI 内部納入日程番号 (String)
ABART 承認タイプ (String)

参照キーの出力オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["REFOBJTYP"]　→　配列内のidx番目の参照キーの出力の「オブジェクトタイプ」
[idx]["REFOBJECT"]　→　配列内のidx番目の参照キーの出力の「オブジェクト名
[idx]["REFOBJKEY"]　→　配列内のidx番目の参照キーの出力の「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の参照キーの出力の「論理システム
[idx]["DOC_NUMBER"]　→　配列内のidx番目の参照キーの出力の「販売管理伝票番号
[idx]["ITM_NUMBER"]　→　配列内のidx番目の参照キーの出力の「販売伝票明細
[idx]["SCHED_LIN"]　→　配列内のidx番目の参照キーの出力の「納入日程行
[idx]["COND_NO"]　→　配列内のidx番目の参照キーの出力の「伝票条件番号
[idx]["CONDITEMNO"]　→　配列内のidx番目の参照キーの出力の「条件明細番号
[idx]["COND_ST_NO"]　→　配列内のidx番目の参照キーの出力の「ステップ番号
[idx]["COND_COUNT"]　→　配列内のidx番目の参照キーの出力の「条件カウンタ」
[idx]["COND_TYPE"]　→　配列内のidx番目の参照キーの出力の「条件タイプ」
[idx]["STATUS"]　→　配列内のidx番目の参照キーの出力の「単一文字フラグ」
[idx]["TINDEX"]　→　配列内のidx番目の参照キーの出力の「数値項目: 長さ 6」
[idx]["ADDRESS"]　→　配列内のidx番目の参照キーの出力の「住所」
[idx]["ABRLI"]　→　配列内のidx番目の参照キーの出力の「内部納入日程番号
[idx]["ABART"]　→　配列内のidx番目の参照キーの出力の「承認タイプ」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderPartnersList

Array getOrderPartnersList ()

伝票取引先を取得します。
返却値
Array 伝票取引先

伝票取引先オブジェクトの構成は以下のとおりです。
PARTN_ROLE 取引先機能 (String)
PARTN_NUMB 得意先コード 1 (String)
ITM_NUMBER 明細番号 (販売管理伝票) (String)
TITLE 敬称 (String)
NAME 名称 1 (String)
NAME_2 名称 2 (String)
NAME_3 名称 3 (String)
NAME_4 名称 4 (String)
STREET 地名/番地-号 (String)
COUNTRY 国コード (String)
COUNTR_ISO 国キー (ISO コード) (String)
POSTL_CODE 郵便番号 (String)
POBX_PCD 私書箱番号 (String)
POBX_CTY 私書箱住所 (String)
CITY 市区町村 (String)
DISTRICT 所在地 (String)
REGION 地域 (都道府県) (String)
PO_BOX 私書箱 (String)
TELEPHONE 電話番号 1 (String)
TELEPHONE2 電話番号 2 (String)
TELEBOX テレボックス番号 (String)
FAX_NUMBER FAX 番号 (String)
TELETEX_NO テレテクス番号 (String)
TELEX_NO テレックス番号 (String)
LANGU 言語キー (String)
LANGU_ISO ISO 639 準拠の言語 (String)
UNLOAD_PT 荷渡ポイント (String)
TRANSPZONE 商品の納入区域 (String)
TAXJURCODE 税計算管轄コード - 税管轄コード (String)
ADDRESS 住所 (String)
PRIV_ADDR 自宅住所 (String)
ADDR_TYPE アドレスタイプ (1=組織、2=個人、3=取引先担当者) (String)
ADDR_ORIG コピー元住所 (String)
ADDR_LINK 住所コードへのリンク (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)

伝票取引先オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["PARTN_ROLE"]　→　配列内のidx番目の伝票取引先の「取引先機能」
[idx]["PARTN_NUMB"]　→　配列内のidx番目の伝票取引先の「得意先コード 1
[idx]["ITM_NUMBER"]　→　配列内のidx番目の伝票取引先の「明細番号 (販売管理伝票)」
[idx]["TITLE"]　→　配列内のidx番目の伝票取引先の「敬称
[idx]["NAME"]　→　配列内のidx番目の伝票取引先の「名称 1
[idx]["NAME_2"]　→　配列内のidx番目の伝票取引先の「名称 2
[idx]["NAME_3"]　→　配列内のidx番目の伝票取引先の「名称 3
[idx]["NAME_4"]　→　配列内のidx番目の伝票取引先の「名称 4
[idx]["STREET"]　→　配列内のidx番目の伝票取引先の「地名/番地-号
[idx]["COUNTRY"]　→　配列内のidx番目の伝票取引先の「国コード
[idx]["COUNTR_ISO"]　→　配列内のidx番目の伝票取引先の「国キー (ISO コード)」
[idx]["POSTL_CODE"]　→　配列内のidx番目の伝票取引先の「郵便番号」
[idx]["POBX_PCD"]　→　配列内のidx番目の伝票取引先の「私書箱番号」
[idx]["POBX_CTY"]　→　配列内のidx番目の伝票取引先の「私書箱住所」
[idx]["CITY"]　→　配列内のidx番目の伝票取引先の「市区町村」
[idx]["DISTRICT"]　→　配列内のidx番目の伝票取引先の「所在地
[idx]["REGION"]　→　配列内のidx番目の伝票取引先の「地域 (都道府県)」
[idx]["PO_BOX"]　→　配列内のidx番目の伝票取引先の「私書箱」
[idx]["TELEPHONE"]　→　配列内のidx番目の伝票取引先の「電話番号 1」
[idx]["TELEPHONE2"]　→　配列内のidx番目の伝票取引先の「電話番号 2」
[idx]["TELEBOX"]　→　配列内のidx番目の伝票取引先の「テレボックス番号」
[idx]["FAX_NUMBER"]　→　配列内のidx番目の伝票取引先の「FAX 番号」
[idx]["TELETEX_NO"]　→　配列内のidx番目の伝票取引先の「テレテクス番号」
[idx]["TELEX_NO"]　→　配列内のidx番目の伝票取引先の「テレックス番号」
[idx]["LANGU"]　→　配列内のidx番目の伝票取引先の「言語キー」
[idx]["LANGU_ISO"]　→　配列内のidx番目の伝票取引先の「ISO 639 準拠の言語
[idx]["UNLOAD_PT"]　→　配列内のidx番目の伝票取引先の「荷渡ポイント」
[idx]["TRANSPZONE"]　→　配列内のidx番目の伝票取引先の「商品の納入区域」
[idx]["TAXJURCODE"]　→　配列内のidx番目の伝票取引先の「税計算管轄コード - 税管轄コード」
[idx]["ADDRESS"]　→　配列内のidx番目の伝票取引先の「住所」
[idx]["PRIV_ADDR"]　→　配列内のidx番目の伝票取引先の「自宅住所」
[idx]["ADDR_TYPE"]　→　配列内のidx番目の伝票取引先の 「アドレスタイプ (1=組織、2=個人、3=取引先担当者)」
[idx]["ADDR_ORIG"]　→　配列内のidx番目の伝票取引先の「コピー元住所」
[idx]["ADDR_LINK"]　→　配列内のidx番目の伝票取引先の「住所コードへのリンク」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の伝票取引先の「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の伝票取引先の「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の伝票取引先の「論理システム

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderSchedulesInList

Array getOrderSchedulesInList ()

納入日程行を取得します。
返却値
Array 納入日程行

納入日程行オブジェクトの構成は以下のとおりです。
ITM_NUMBER 販売伝票明細 (String)
SCHED_LINE 納入日程行 (String)
REQ_DATE 納入日程日付 (String)
DATE_TYPE 日付タイプ (日、週、月、期間) (String)
REQ_TIME 納入時間 (String)
REQ_QTY 販売単位による受注数量 (String)
REQ_DLV_BL 出荷ブロック中の納入日程行 (String)
SCHED_TYPE 納入日程カテゴリ (String)
TP_DATE 輸送計画日付 (String)
MS_DATE 品目利用可能日 (String)
LOAD_DATE 積載日付 (String)
GI_DATE 出庫日付 (String)
TP_TIME 輸送計画 - 時間 (現地時間/出荷ポイント参照) (String)
MS_TIME 品目供給ステージ (現地時刻: プラント参照) (String)
LOAD_TIME 積載時刻 (現地時間: 出荷ポイント) (String)
GI_TIME 出庫時刻 (現地時間 - プラント参照) (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
REFLOGSYS 論理システム (String)
DLV_DATE 納入日程日付 (String)
DLV_TIME 納入時間 (String)
REL_TYPE 承認タイプ (String)
PLAN_SCHED_TYPE 納入日程行タイプ EDI (String)

納入日程行オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の納入日程行の「販売伝票明細」
[idx]["SCHED_LINE"]　→　配列内のidx番目の納入日程行の「納入日程行」
[idx]["REQ_DATE"]　→　配列内のidx番目の納入日程行の「納入日程日付」
[idx]["DATE_TYPE"]　→　配列内のidx番目の納入日程行の「日付タイプ (日、週、月、期間)」
[idx]["REQ_TIME"]　→　配列内のidx番目の納入日程行の「納入時間」
[idx]["REQ_QTY"]　→　配列内のidx番目の納入日程行の「販売単位による受注数量」
[idx]["REQ_DLV_BL"]　→　配列内のidx番目の納入日程行の「出荷ブロック中の納入日程行」
[idx]["SCHED_TYPE"]　→　配列内のidx番目の納入日程行の「納入日程カテゴリ」
[idx]["TP_DATE"]　→　配列内のidx番目の納入日程行の「輸送計画日付」
[idx]["MS_DATE"]　→　配列内のidx番目の納入日程行の「品目利用可能日」
[idx]["LOAD_DATE"]　→　配列内のidx番目の納入日程行の「積載日付」
[idx]["GI_DATE"]　→　配列内のidx番目の納入日程行の「出庫日付」
[idx]["TP_TIME"]　→　配列内のidx番目の納入日程行の 「輸送計画 - 時間 (現地時間/出荷ポイント参照)」
[idx]["MS_TIME"]　→　配列内のidx番目の納入日程行の 「品目供給ステージ (現地時刻: プラント参照)」
[idx]["LOAD_TIME"]　→　配列内のidx番目の納入日程行の「積載時刻 (現地時間: 出荷ポイント)」
[idx]["GI_TIME"]　→　配列内のidx番目の納入日程行の「出庫時刻 (現地時間 - プラント参照)」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の納入日程行の「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の納入日程行の「オブジェクトキー」
[idx]["REFLOGSYS"]　→　配列内のidx番目の納入日程行の「論理システム」
[idx]["DLV_DATE"]　→　配列内のidx番目の納入日程行の「納入日程日付」
[idx]["DLV_TIME"]　→　配列内のidx番目の納入日程行の「納入時間」
[idx]["REL_TYPE"]　→　配列内のidx番目の納入日程行の「承認タイプ」
[idx]["PLAN_SCHED_TYPE"]　→　配列内のidx番目の納入日程行の「納入日程行タイプ EDI」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderSchedulesInXList

Array getOrderSchedulesInXList ()

納入日程行チェックボックスを取得します。
返却値
Array 納入日程行チェックボックス

納入日程行チェックボックスオブジェクトの構成は以下のとおりです。
ITM_NUMBER 販売伝票明細 (String)
SCHED_LINE 納入日程行 (String)
UPDATEFLAG 更新区分 (String)
REQ_DATE 関連ユーザデータ項目の更新情報 (String)
DATE_TYPE 関連ユーザデータ項目の更新情報 (String)
REQ_TIME 関連ユーザデータ項目の更新情報 (String)
REQ_QTY 関連ユーザデータ項目の更新情報 (String)
REQ_DLV_BL 関連ユーザデータ項目の更新情報 (String)
SCHED_TYPE 関連ユーザデータ項目の更新情報 (String)
TP_DATE 関連ユーザデータ項目の更新情報 (String)
MS_DATE 関連ユーザデータ項目の更新情報 (String)
LOAD_DATE 関連ユーザデータ項目の更新情報 (String)
GI_DATE 関連ユーザデータ項目の更新情報 (String)
TP_TIME 関連ユーザデータ項目の更新情報 (String)
MS_TIME 関連ユーザデータ項目の更新情報 (String)
LOAD_TIME 関連ユーザデータ項目の更新情報 (String)
GI_TIME 関連ユーザデータ項目の更新情報 (String)
REFOBJTYPE オブジェクトタイプ (String)
REFOBJKEY オブジェクトキー (String)
DLV_DATE 関連ユーザデータ項目の更新情報 (String)
DLV_TIME 関連ユーザデータ項目の更新情報 (String)
REL_TYPE 関連ユーザデータ項目の更新情報 (String)
PLAN_SCHED_TYPE 関連ユーザデータ項目の更新情報 (String)

納入日程行チェックボックスオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ITM_NUMBER"]　→　配列内のidx番目の納入日程行チェックボックスの「販売伝票明細」
[idx]["SCHED_LINE"]　→　配列内のidx番目の納入日程行チェックボックスの「納入日程行」
[idx]["UPDATEFLAG"]　→　配列内のidx番目の納入日程行チェックボックスの「更新区分」
[idx]["REQ_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["DATE_TYPE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REQ_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REQ_QTY 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REQ_DLV_BL 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["SCHED_TYPE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["TP_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["MS_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["LOAD_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["GI_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["TP_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["MS_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["LOAD_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["GI_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REFOBJTYPE"]　→　配列内のidx番目の納入日程行チェックボックスの「オブジェクトタイプ」
[idx]["REFOBJKEY"]　→　配列内のidx番目の納入日程行チェックボックスの「オブジェクトキー」
[idx]["DLV_DATE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["DLV_TIME 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["REL_TYPE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」
[idx]["PLAN_SCHED_TYPE 関連ユーザデータ項目"]　→ 　配列内のidx番目の納入日程行チェックボックスの「更新情報」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getOrderTextList

Array getOrderTextList ()

テキストを取得します。
返却値
Array テキスト

テキストオブジェクトの構成は以下のとおりです。
DOC_NUMBE 販売伝票 (String)
ITM_NUMBE 販売伝票明細 (String)
TEXT_ID テキスト ID (String)
LANGU 言語キー (String)
LANGU_ISO ISO 639 準拠の言語 (String)
FORMAT_COL タグ列 (String)
TEXT_LINE テキスト行 (String)
FUNCTION 機能 (String)

テキストオブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["DOC_NUMBE"]　→　配列内のidx番目のテキストの「販売伝票」
[idx]["ITM_NUMBE"]　→　配列内のidx番目のテキストの「販売伝票明細」
[idx]["TEXT_ID"]　→　配列内のidx番目のテキストの「テキスト ID」
[idx]["LANGU"]　→　配列内のidx番目のテキストの「言語キー」
[idx]["LANGU_ISO"]　→　配列内のidx番目のテキストの「ISO 639 準拠の言語」
[idx]["FORMAT_COL"]　→　配列内のidx番目のテキストの「タグ列」
[idx]["TEXT_LINE"]　→　配列内のidx番目のテキストの「テキスト行」
[idx]["FUNCTION"]　→　配列内のidx番目のテキストの「機能」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPartnerAddressesList

Array getPartnerAddressesList ()

アドレス (組織/会社) 用 BAPI 参照構造を取得します。
返却値
Array アドレス (組織/会社) 用 BAPI 参照構造

アドレス (組織/会社) 用 BAPI 参照構造オブジェクトの構成は以下のとおりです。
ADDR_NO アドレス番号 (String)
FORMOFADDR 敬称テキスト (String)
NAME 名称 1 (String)
NAME_2 名称 2 (String)
NAME_3 名称 3 (String)
NAME_4 名称 4 (String)
C_O_NAME 気付 (String)
CITY 市区町村 (String)
DISTRICT 所在地 (String)
CITY_NO 市区町村/地名ファイルの市区町村コード (String)
POSTL_COD1 市区町村の郵便番号 (String)
POSTL_COD2 私書箱郵便番号 (String)
POSTL_COD3 会社郵便番号 (大規模なユーザ用) (String)
PO_BOX 私書箱 (String)
PO_BOX_CIT 私書箱住所 (String)
DELIV_DIS 郵便配達地域 (String)
STREET 地名 (String)
STREET_NO 市区町村/地名ファイルの地名コード (String)
STR_ABBR 地名の略称 (例: スペイン) (String)
HOUSE_NO 番地-号 (String)
STR_SUPPL1 地名 2 (String)
STR_SUPPL2 地名 3 (String)
LOCATION 地名 5 (String)
BUILDING 旧: 建物 (番号または略称) (String)
FLOOR 建物の階 (String)
ROOM_NO 部屋/アパート番号 (String)
COUNTRY 国コード (String)
LANGU 言語キー (String)
REGION 地域 (都道府県) (String)
SORT1 検索条件 1 (String)
SORT2 検索条件 2 (String)
TIME_ZONE アドレスタイムゾーン (String)
TAXJURCODE 税管轄コード (String)
ADR_NOTES 住所注記 (String)
COMM_TYPE 通信方法 (キー) (アドレス管理) (String)
TEL1_NUMBR 第一電話番号: ダイヤルコード + 番号 (String)
TEL1_EXT 第 1 電話番号: 内線 (String)
FAX_NUMBER 第一 FAX 番号: ダイヤルコード + 番号 (String)
FAX_EXTENS 第一 FAX 番号: 内線 (String)
STREET_LNG 地名 (String)
DISTRCT_NO 市区町村/地名ファイルの所在地コード (String)
CHCKSTATUS 市区町村ファイルテストステータス (String)
PBOXCIT_NO 市区町村私書箱コード (市ファイル) (String)
TRANSPZONE 商品の納入区域 (String)
HOUSE_NO2 番地補足 (String)
E_MAIL 電子メールアドレス (String)
STR_SUPPL3 地名 4 (String)
TITLE タイトル (敬称) (String)
COUNTRYISO ISO 国コード (String)
LANGU_ISO ISO 639 準拠の言語 (String)
BUILD_LONG 建物 (番号またはコード) (String)
REGIOGROUP 地域構造グループ化 (String)
HOME_CITY 市区町村 (郵便用市区町村と異なる場合) (String)
HOMECITYNO 別の市区町村 (市区町村/地名ファイル) (String)
PCODE1_EXT 市区町村郵便番号の拡張子 例: 郵便番号 +4+2 (String)
PCODE2_EXT 私書箱郵便番号拡張子 例: 郵便番号 +4+2 (String)
PCODE3_EXT 主要得意先郵便番号拡張子 例: 郵便番号 +4+2 (String)
PO_W_O_NO フラグ: 郵便私書箱 (番号なし) (String)
PO_BOX_REG 私書箱の地域 (国、都道府県、地域、...) (String)
POBOX_CTRY 私書箱の国指定 (String)
PO_CTRYISO ISO 国コード (String)
HOMEPAGE URI 例: ホームページ、FTP アドレス (String)
DONT_USE_S 地名住所配達不可フラグ (String)
DONT_USE_P 私書箱住所配達不可フラグ (String)
HOUSE_NO3 番地範囲 (String)
LANGU_CR アドレスレコード登録オリジナル言語 (String)
LANGUCRISO ISO 639 準拠の言語 (String)

アドレス (組織/会社) 用 BAPI 参照構造オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["ADDR_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「アドレス番号」
[idx]["FORMOFADDR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「敬称テキスト」
[idx]["NAME"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「名称 1」
[idx]["NAME_2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「名称 2」
[idx]["NAME_3"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「名称 3」
[idx]["NAME_4"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「名称 4」
[idx]["C_O_NAME"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「気付」
[idx]["CITY"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「市区町村」
[idx]["DISTRICT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「所在地」
[idx]["CITY_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村/地名ファイルの市区町村コード」
[idx]["POSTL_COD1"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村の郵便番号」
[idx]["POSTL_COD2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱郵便番号」
[idx]["POSTL_COD3"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「会社郵便番号 (大規模なユーザ用)」
[idx]["PO_BOX"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「私書箱」
[idx]["PO_BOX_CIT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱住所」
[idx]["DELIV_DIS"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「郵便配達地域」
[idx]["STREET"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「地名」
[idx]["STREET_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村/地名ファイルの地名コード」
[idx]["STR_ABBR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名の略称 (例: スペイン)」
[idx]["HOUSE_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「番地-号」
[idx]["STR_SUPPL1"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名 2」
[idx]["STR_SUPPL2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名 3」
[idx]["LOCATION"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「地名 5」
[idx]["BUILDING"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「旧: 建物 (番号または略称)」
[idx]["FLOOR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「建物の階」
[idx]["ROOM_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「部屋/アパート番号」
[idx]["COUNTRY"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「国コード」
[idx]["LANGU"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「言語キー」
[idx]["REGION"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地域 (都道府県)」
[idx]["SORT1"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「検索条件 1」
[idx]["SORT2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「検索条件 2」
[idx]["TIME_ZONE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「アドレスタイムゾーン」
[idx]["TAXJURCODE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「税管轄コード」
[idx]["ADR_NOTES"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「住所注記」
[idx]["COMM_TYPE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「通信方法 (キー) (アドレス管理)」
[idx]["TEL1_NUMBR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「第一電話番号: ダイヤルコード + 番号」
[idx]["TEL1_EXT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「第 1 電話番号: 内線」
[idx]["FAX_NUMBER"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「第一 FAX 番号: ダイヤルコード + 番号」
[idx]["FAX_EXTENS"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「第一 FAX 番号: 内線」
[idx]["STREET_LNG"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の「地名」
[idx]["DISTRCT_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村/地名ファイルの所在地コード」
[idx]["CHCKSTATUS"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村ファイルテストステータス」
[idx]["PBOXCIT_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村私書箱コード (市ファイル)」
[idx]["TRANSPZONE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「商品の納入区域」
[idx]["HOUSE_NO2"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「番地補足」
[idx]["E_MAIL"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「電子メールアドレス」
[idx]["STR_SUPPL3"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名 4」
[idx]["TITLE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「タイトル (敬称)」
[idx]["COUNTRYISO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「ISO 国コード」
[idx]["LANGU_ISO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「ISO 639 準拠の言語」
[idx]["BUILD_LONG"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「建物 (番号またはコード)」
[idx]["REGIOGROUP"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地域構造グループ化」
[idx]["HOME_CITY"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村 (郵便用市区町村と異なる場合)」
[idx]["HOMECITYNO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「別の市区町村 (市区町村/地名ファイル)」
[idx]["PCODE1_EXT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「市区町村郵便番号の拡張子 例: 郵便番号 +4+2」
[idx]["PCODE2_EXT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱郵便番号拡張子 例: 郵便番号 +4+2」
[idx]["PCODE3_EXT"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「主要得意先郵便番号拡張子 例: 郵便番号 +4+2」
[idx]["PO_W_O_NO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「フラグ: 郵便私書箱 (番号なし)」
[idx]["PO_BOX_REG"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱の地域 (国、都道府県、地域、...)」
[idx]["POBOX_CTRY"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱の国指定」
[idx]["PO_CTRYISO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「ISO 国コード」
[idx]["HOMEPAGE"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「URI 例: ホームページ、FTP アドレス」
[idx]["DONT_USE_S"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「地名住所配達不可フラグ」
[idx]["DONT_USE_P"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「私書箱住所配達不可フラグ」
[idx]["HOUSE_NO3"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「番地範囲」
[idx]["LANGU_CR"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「アドレスレコード登録オリジナル言語」
[idx]["LANGUCRISO"]　→　配列内のidx番号のアドレス（組織/会社）用 BAPI 参照構造の 「ISO 639 準拠の言語」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getSalesdocument

Object getSalesdocument ()

生成された伝票の番号を取得します。

返却値
Object 生成された伝票の番号
getSalesdocumentin

Object getSalesdocumentin ()

販売管理伝票番号を取得します。

返却値
Object 販売管理伝票番号
getSender

Object getSender ()

論理システム - 送信者を取得します。
返却値
Object 論理システム - 送信者

論理システム - 送信者オブジェクトの構成は以下のとおりです。
LOG_SYSTEM 論理システム (String)

論理システム - 送信者オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["LOG_SYSTEM"]　→　配列内のidx番目の論理システム - 送信者の「論理システム」

※ idxは0〜n （配列サイズ-1）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getTestrun

Object getTestrun ()

テスト実行を取得します。
返却値
Object テスト実行
setBehaveWhenError

void setBehaveWhenError (Object value)

エラー処理を設定します｡
パラメータ
value Object エラー処理
返却値
void
setBinaryRelationshiptype

void setBinaryRelationshiptype (Object value)

バイナリ関連タイプ (専用)を設定します｡
パラメータ
value Object バイナリ関連タイプ (専用)
返却値
void
setConvert

void setConvert (Object value)

変換: 取引先機能 + 受注伝票タイプを設定します｡
パラメータ
value Object 変換: 取引先機能 + 受注伝票タイプ
返却値
void
setIntNumberAssignment

void setIntNumberAssignment (Object value)

明細番号内部採番を設定します｡
パラメータ
value Object 明細番号内部採番
返却値
void
setSalesdocumentin

void setSalesdocumentin (Object value)

販売管理伝票番号を設定します｡
パラメータ
value Object 販売管理伝票番号
返却値
void
setStrParam

void setStrParam (String paramStr ,String paramName ,Object value)

構造型の項目に値をセットします。
パラメータ
paramStr | String | 構造名
paramName | String | 項目名
value | Object | セットする値
返却値
void
setTblParam

void setTblParam (String paramTable ,String paramName ,Object value ,int index)

テーブル型の項目に値をセットします。
パラメータ
paramTable | String | テーブル名
paramName | String | 項目名
value | Object | セットする値
index | int | レコード番号
返却値
void
setTestrun

void setTestrun (Object value)

テスト実行を設定します｡
パラメータ
value Object テスト実行
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 SalesOrderGetListController オブジェクト

販売伝票一覧照会コントローラクラス。

機能は以下の通り
  • 販売伝票一覧を取得します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
SalesOrderGetListController ()
コンストラクタ。
SalesOrderGetListController (SapClient sapClient)
コンストラクタ。
SalesOrderGetListController (String customerNumber ,String salesOrganisation ,String material ,String purchaseOrder ,String transactionGroup ,SAPクライアント sapClient)
コンストラクタ。
SalesOrderGetListController (String customerNumber ,String salesOrganisation ,String material ,String purchaseOrder ,String transactionGroup)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより販売伝票を取得します。
value | getCustomerNumber () 得意先コードを取得します。
Object | getDocumentDate () 登録日付を取得します。
Object | getDocumentDateTo () 入力日付 (以前/以降)を取得します。
Object | getMaterial () 品目コードを取得します。
Object | getPurchaseOrder () 得意先発注番号を取得します。
Object | getPurchaseOrderNumber () 得意先発注番号1を取得します。
Object | getSalesOrdersList () 販売伝票一覧を取得します。
Object | getSalesOrganization () 販売組織を取得します。
Object | getTransactionGroup () 一文字フラグを取得します。
void | setTblParam (String paramTable ,String paramName ,Object value ,int index) テーブル型の項目に値をセットします。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
SalesOrderGetListController

SalesOrderGetListController ()
コンストラクタ。
SalesOrderGetListController

SalesOrderGetListController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
SalesOrderGetListController

SalesOrderGetListController (String customerNumber ,String salesOrganisation ,String material ,String purchaseOrder ,String transactionGroup ,SAPクライアント sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
customerNumber | String | 得意先コード
salesOrganisation | String | 販売組織
material | String | 品目コード
purchaseOrder | String | 得意先発注番号
transactionGroup | String | 一文字フラグ
sapClient | SAPクライアント
SalesOrderGetListController

SalesOrderGetListController (String customerNumber ,String salesOrganisation ,String material ,String purchaseOrder ,String transactionGroup)
コンストラクタ。

パラメータ
customerNumber | String | 得意先コード
salesOrganisation | String | 販売組織
material | String | 品目コード
purchaseOrder | String | 得意先発注番号
transactionGroup | String | 一文字フラグ
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより販売伝票を取得します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getCustomerNumber

value getCustomerNumber ()

得意先コードを取得します。
返却値
value Object 得意先コード
getDocumentDate

Object getDocumentDate ()

登録日付を取得します。
返却値
Object 登録日付
getDocumentDateTo

Object getDocumentDateTo ()

入力日付 (以前/以降)を取得します。
返却値
Object 入力日付 (以前/以降)
getMaterial

Object getMaterial ()

品目コードを取得します。
返却値
Object 品目コード
getPurchaseOrder

Object getPurchaseOrder ()

得意先発注番号を取得します。
返却値
Object 得意先発注番号
getPurchaseOrderNumber

Object getPurchaseOrderNumber ()

得意先発注番号1を取得します。
返却値
Object 得意先発注番号1
getSalesOrdersList

Object getSalesOrdersList ()

販売伝票一覧を取得します。
返却値
Object 販売伝票一覧

販売伝票一覧情報オブジェクトの構成は以下のとおりです。
販売伝票一覧情報
オブジェクト
(Object)
SD_DOC 販売管理伝票番号 (String)
ITM_NUMBER 明細番号 (販売管理伝票) (String)
MATERIAL 品目コード (String)
SHORT_TEXT テキスト (短): 受注明細 (String)
DOC_TYPE 販売伝票タイプ (String)
DOC_DATE 伝票日付 (受信日/送信日) (String)
REQ_QTY 累積受注数量 (販売単位) (String)
REQ_DATE 指定納期 (String)
PURCH_NO 得意先発注番号 (String)
BATCH ロット番号 (String)
VALID_FROM 見積または基本契約の有効開始日 (String)
VALID_TO 見積または基本契約有効終了日 (String)
BILL_BLOCK 販売管理伝票の請求ブロック (String)
DLV_BLOCK 出荷ブロック (伝票ヘッダ) (String)
SOLD_TO 受注先 (String)
NAME 名称 1 (String)
EXCHG_RATE 価格設定/統計の換算レート (直接引用) (String)
DLV_QTY 出荷数量実績 (販売単位) (String)
BASE_UOM 基本数量単位 (String)
NET_PRICE 正味価格 (String)
COND_P_UNT 価格条件単位 (String)
COND_UNIT 条件単位 (String)
NET_VAL_HD 受注正味額 (伝票通貨) (String)
NET_VALUE 伝票通貨による正味額 (String)
DIVISION 製品部門 (String)
DOC_STATUS 伝票ステータス (String)
SALES_GRP 営業グループ (String)
SALES_OFF 営業所 (String)
SALES_ORG 販売組織 (String)
SALES_UNIT 販売単位 (String)
SHIP_POINT 出荷ポイント/入荷ポイント (String)
DISTR_CHAN 流通チャネル (String)
GI_DATE 出庫日付 (String)
CURRENCY 販売伝票通貨 (String)
PLANT プラント (String)
STORE_LOC 保管場所 (String)
ORD_REASON 受注理由 (取引理由) (String)
REASON_REJ 見積および受注の拒否理由 (String)
B_UOM_ISO ISO コードでの基本数量単位 (String)
CD_UNT_ISO 条件数量単位 (ISO コード) (String)
S_UNIT_ISO ISO コードによる販売単位 (String)
CURR_ISO ISO コード通貨 (String)
PURCH_NO_C 出荷先発注番号 (String)
EXCHG_RATE_V 価格設定/統計の換算レート (間接引用) (String)
MAT_EXT 項目 MATERIAL の品目コード (長) (String)
MAT_GUID 項目 MATERIAL の外部 GUID (String)
MAT_VERS 項目 MATERIAL のバージョン番号 (String)
CREATION_DATE レコード登録日 (String)
CREATION_TIME 登録時刻 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11: 販売発注システムエラー
12: 販売発注アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getSalesOrganization

Object getSalesOrganization ()

販売組織を取得します。
返却値
Object 販売組織
getTransactionGroup

Object getTransactionGroup ()

一文字フラグを取得します。
返却値
Object 一文字フラグ
setTblParam

void setTblParam (String paramTable ,String paramName ,Object value ,int index)

テーブル型の項目に値をセットします。
パラメータ
paramTable | String | テーブル名
paramName | String | 項目名
value | Object | セットする値
index | int | レコード番号
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 SalesOrderGetStatusController オブジェクト

販売伝票ステータス一覧照会コントローラクラス。

機能は以下の通り
  • 販売伝票ステータス一覧を照会します。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
SalesOrderGetStatusController ()
コンストラクタ
SalesOrderGetStatusController (SapClient sapClient)
コンストラクタ。
SalesOrderGetStatusController (String salesdocument)
コンストラクタ。
SalesOrderGetStatusController (String salesdocument ,SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | executeBapi () BapiControllerにより販売伝票ステータスを取得します。
value | getSalesdocument () 販売管理伝票番号を取得します。
Object | getStatusInfoList () 販売伝票ステータス一覧を取得します。
void | setTblParam (String paramTable ,String paramName ,Object value ,int index) テーブル型の項目に値をセットします。
String | toString () デバッグ用のメソッドです。
コンストラクタの詳細
SalesOrderGetStatusController

SalesOrderGetStatusController ()
コンストラクタ
SalesOrderGetStatusController

SalesOrderGetStatusController (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
sapClient SapClient Sapクライアント
SalesOrderGetStatusController

SalesOrderGetStatusController (String salesdocument)
コンストラクタ。

パラメータ
salesdocument String 販売管理伝票番号
SalesOrderGetStatusController

SalesOrderGetStatusController (String salesdocument ,SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
パラメータ
salesdocument | String | 販売管理伝票番号
sapClient | SapClient | Sapクライアント
メソッドの詳細
executeBapi

Object executeBapi ()

BapiControllerにより販売伝票ステータスを取得します。
返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11： 販売管理システムエラー
12： 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
getSalesdocument

value getSalesdocument ()

販売管理伝票番号を取得します。
返却値
value String 販売管理伝票番号
getStatusInfoList

Object getStatusInfoList ()

販売伝票ステータス一覧を取得します。
返却値
Object 販売伝票ステータス一覧

販売伝票ステータス一覧情報オブジェクトの構成は以下のとおりです。
販売伝票ステータス一覧情報
オブジェクト
(Object)
DOC_NUMBER 販売伝票 (String)
DOC_DATE 伝票日付 (受信日/送信日) (String)
PURCH_NO 得意先発注番号 (String)
PRC_STAT_H 伝票の全処理ステータス (String)
DLV_STAT_H 全明細の出荷ステータス (String)
REQ_DATE_H 指定納入期日 (String)
DLV_BLOCK 出荷ブロック (伝票ヘッダ) (String)
ITM_NUMBER 販売伝票明細 (String)
MATERIAL 品目コード (String)
SHORT_TEXT テキスト (短): 受注明細 (String)
REQ_DATE 納入日程日付 (String)
REQ_QTY 累積受注数量 (販売単位) (String)
CUM_CF_QTY 累積確認数量 (販売数量単位) (String)
SALES_UNIT 販売単位 (String)
NET_VALUE 伝票通貨での受注明細正味額 (String)
CURRENCY 販売伝票通貨 (String)
NET_PRICE 正味価格 (String)
COND_P_UNT 価格条件単位 (String)
COND_UNIT 条件単位 (String)
DLV_STAT_I 明細の全体出荷ステータス (String)
DELIV_NUMB 出荷伝票 (String)
DELIV_ITEM 出荷明細 (String)
DELIV_DATE 納入期日 (String)
DLV_QTY 出荷数量実績 (販売単位) (String)
REF_QTY 基本数量単位による参照数量 (String)
S_UNIT_ISO ISO コードによる販売単位 (String)
CD_UNT_ISO 条件数量単位 (ISO コード) (String)
CURR_ISO ISO コード通貨 (String)
MATERIAL_EXTERNAL 項目 MATERIAL の品目コード (長) (String)
MATERIAL_GUID 項目 MATERIAL の外部 GUID (String)
MATERIAL_VERSION 項目 MATERIAL のバージョン番号 (String)
PO_ITM_NO 元となる購買発注の明細番号 (String)
CREATION_DATE レコード登録日 (String)
CREATION_TIME 登録時刻 (String)
S_UNIT_DLV 出荷単位 (String)
DLV_UNIT_ISO ISO コードでの出荷単位の数量単位 (String)

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
11: 販売管理システムエラー
12: 販売管理アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

setTblParam

void setTblParam (String paramTable ,String paramName ,Object value ,int index)

テーブル型の項目に値をセットします。
パラメータ
paramTable | String | テーブル名
paramName | String | 項目名
value | Object | セットする値
index | int | レコード番号
返却値
void
toString

String toString ()

デバッグ用のメソッドです。
返却値
String すべての属性の値


 BapiController オブジェクト

BAPIコントローラクラス。

ソリューション特化型APIにて設定されたBAPI処理実行パラメータを保持し、
BAPI実行時はプロパティファイル設定の内容に従ってJCOパラメータに展開します｡
展開後、BAPI処理を実行し、実行結果を保持します｡
ソリューション特化型APIは、実行結果を当クラスの公開アクセサメソッドを
使用して取得します｡
バージョン：1.2
導入されたバージョン：5.0
コンストラクタの概要
BapiController (String propertyName)
コンストラクタ。
BapiController (String propertyName ,ConnectionManager connectionManager)
コンストラクタ。
BapiController (String propertyName ,SapClient sapClient)
コンストラクタ。
メソッドの概要
void | addAutoCommitCondition (String autoCommitConditon) 推奨されていません。addIgnoreErrMsgReturnType()に置き換えられました。
void | addIgnoreErrMsgReturnType (String ignoreErrMsgReturnType) エラーメッセージを無視するRETURN-TYPEを追加します。
void | clear () セットしたパラメータ、ストラクチャ、テーブル、 BAPIの実行結果をクリアします。
Object | executeBapi () BAPI処理を実行します。
Array | getAutoCommitConditions () 推奨されていません。getIgnoreErrMsgReturnTypes()に置き換えられました。
String | getErrCode () コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc () コンストラクタでエラー時の実行時エラー内容を取得します。
Object | getErrMessage () ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getErrMsg () コンストラクタでエラー時のエラーメッセージを取得します。
Object | getExportParam (String key) export(Export)情報を返します。
Array | getIgnoreErrMsgReturnTypes () エラーメッセージを無視するRETURN-TYPEを取得します。
Object | getMessage () 設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。
Object | getMessage (String type) 引数に一致したType情報のメッセージ情報全て取得します。
Object | getReturn () ＢＡＰＩ実行結果を取得します。
Array | getReturnCodeTypes () BapiReturn のType情報を取得します。
Object | getReturnList () ＢＡＰＩ実行結果の一覧を取得します。
Object | getStructureParam (String paramName) structure(Export)情報を返します。
Object | getTableParam (String paramName) table(Export)情報を返します。
Object | isSuccess () ＢＡＰＩ実行が正常に行われたか判定します。
Object | putImportParam (String key ,String val) BAPI処理実行パラメータを格納します。
Object | putStructParam (String key ,String val ,String structName) BAPI処理実行パラメータを格納します。
Object | putTableParam (String key ,String val ,String tableName ,Number recordNo) BAPI処理実行パラメータを格納します。
void | setAutoCommitConditions (Array autoCommitConditions) 推奨されていません。setIgnoreErrMsgReturnTypes()に置き換えられました。
void | setIgnoreErrMsgReturnTypes (Array ignoreErrMsgReturnTypes) エラーメッセージを無視するRETURN-TYPEを設定します。
コンストラクタの詳細
BapiController

BapiController (String propertyName)
コンストラクタ。

パラメータ
propertyName String BAPIコントローラが使用するプロパティファイル名
BapiController

BapiController (String propertyName ,ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerから トランザクションを制御でき、たとえば同一トランザクション内で 複数の登録・更新処理を実行することができます。
なお、BapiController#executeBapi()実行後に必ずConnectionManager#commit() またはConnectionManager#rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

【注意】トランザクション制御が記述されているBAPIもあります。 その場合、BapiController#executeBapi()実行後に ここまでのコネクションマネージャーで実行したすべての処理が commitまたはrollbackされます。
※ただし、コネクションはリリースされませんので、 リリースされるようにConnectionManager#commit()または ConnectionManager#rollback()を実行してください。
この振る舞いを変更するには、BAPI自体をカスタマイズする必要があります。
パラメータ
propertyName | String | BAPIコントローラが使用するプロパティファイル名
connectionManager | ConnectionManager | コネクションマネージャー
BapiController

BapiController (String propertyName ,SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先へ登録・更新処理を実行することが できます。
なお、任意の接続先へ１トランザクション内の複数APIを処理したい場合は、 ConnectionManagerを参照して下さい。

【注意】トランザクション制御が記述されているBAPIもあります。 その場合、BapiController#executeBapi()実行後に ここまでのコネクションマネージャーで実行したすべての処理が commitまたはrollbackされます。
この振る舞いを変更するには、BAPI自体をカスタマイズする必要があります。
パラメータ
propertyName | String | BAPIコントローラが使用するプロパティファイル名
sapClient | SapClient | Sapクライアント
メソッドの詳細
addAutoCommitCondition

void addAutoCommitCondition (String autoCommitConditon)

推奨されていません。addIgnoreErrMsgReturnType()に置き換えられました。
オートコミットさせる条件を指定します。

BapiReturn のType情報に対して、オートコミットさせる文字列の条件を 設定します。
パラメータ
autoCommitConditon String オートコミットさせる条件
返却値
void
addIgnoreErrMsgReturnType

void addIgnoreErrMsgReturnType (String ignoreErrMsgReturnType)

エラーメッセージを無視するRETURN-TYPEを追加します。

BapiReturn のType情報に対して、エラーメッセージを無視するRETURN-TYPEを 設定します。
パラメータ
ignoreErrMsgReturnType String エラーメッセージを無視するRETURN-TYPE値
返却値
void
導入されたバージョン：6.0
clear

void clear ()

セットしたパラメータ、ストラクチャ、テーブル、 BAPIの実行結果をクリアします。

返却値
void
executeBapi

Object executeBapi ()

BAPI処理を実行します。

JCO.Connectionを生成し､JCO.Functionの生成、
BAPI引渡しパラメータの生成を行いBAPI処理を実行します｡
またBAPI実行結果から、BapiHashオブジェクトの生成とBapiHashListへの追加、
BapiReturnオブジェクトの生成とBapiReturnListへの追加を行います｡

なお、このクラスのコンストラクタ呼び出し時にConnectionManagerを指定した場合、 トランザクション処理は自動的に実行されません。呼び出し側で明示的にConnectionManager#commit() またはConnectionManager#rollbackを実行する必要があります。また、SAPとのコネクションも 上記2メソッド内で行われますので、確実に呼び出すように実装しなくてはなりません。

【注意】ConnectionManagerを指定した場合の注意点

トランザクション制御が記述されているBAPIもあります。 その場合、本メソッド実行後にここまでのコネクションマネージャーで実行したすべての処理がcommitまたはrollbackされます。
※ただし、コネクションはリリースされませんので、リリースされるようにConnectionManager#commit()または ConnectionManager#rollback()を実行してください。
この振る舞いを変更するには、BAPI自体をカスタマイズする必要があります。
返却値
Object 空文字列 ""
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getAutoCommitConditions

Array getAutoCommitConditions ()

推奨されていません。getIgnoreErrMsgReturnTypes()に置き換えられました。
オートコミットさせる条件を取得します。

BapiReturn のType情報に対して、オートコミットさせる文字列からなる条件を 取得します。
返却値
Array オートコミットさせる条件 (文字列の要素からなるArrayオブジェクト)
getErrCode

String getErrCode ()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc ()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMessage

Object getErrMessage ()

ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外の BapiReturnオブジェクトのメッセージ情報を全て返します。
全て正常の場合はnullが返却されます｡ 正常と判断させる条件はプロパティファイル、 またはsetIgnoreErrMsgReturnTypes(Array), addIgnoreErrMsgReturnType(String)でカスタマイズできます。
返却値
Object SAPのエラーメッセージ
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
3： 汎用系システムエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getErrMsg

String getErrMsg ()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getExportParam

Object getExportParam (String key)

export(Export)情報を返します。

入力／出力区分、パラメータ属性、パラメータ名、 プロパティファイルのキー情報で
一覧から該当するBapiHashオブジェクトを検索して、値を返します｡
パラメータ
key String 検索条件となるPropertyKey
返却値
Object 引数のキーに対応する値
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
3： 汎用系システムエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getIgnoreErrMsgReturnTypes

Array getIgnoreErrMsgReturnTypes ()

エラーメッセージを無視するRETURN-TYPEを取得します。

BapiReturn のType情報に対して、エラーメッセージを無視するRETURN-TYPEを 取得します。
返却値
Array エラーメッセージを無視するRETURN-TYPE値のリスト
導入されたバージョン：6.0
getMessage

Object getMessage ()

設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。

メッセージは、以下のように、オートコミット条件に設定されたType情報に 一致した各メッセージが MESSAGE1, MESSAGE2と改行文字で区切られた形式になります。

MESSAGE1 : メッセージ1
MESSAGE2 : メッセージ2
:
メッセージがない場合、nullが返却されます｡
返却値
Object オートコミット条件に一致したType情報のメッセージ情報
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
3： 汎用系システムエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getMessage

Object getMessage (String type)

引数に一致したType情報のメッセージ情報全て取得します。

ＢＡＰＩの実行結果において、引数に一致するType情報のメッセージ情報を全て返します。 メッセージは、以下のように、一致したType情報の各メッセージが MESSAGE1, MESSAGE2と改行文字で区切られた形式になります。

MESSAGE1 : メッセージ1
MESSAGE2 : メッセージ2
:
メッセージがない場合、nullが返却されます｡

引数に指定するType情報は、一般に以下のようになります。
  • S：正常終了
  • W：警告
  • I：情報
  • E：エラー
※上記のType情報は、BAPIに依存します。
パラメータ
type String エラーコードタイプ
返却値
Object 引数で指定したタイプ情報のBAPI実行時のメッセージ情報
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
3： 汎用系システムエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getReturn

Object getReturn ()

ＢＡＰＩ実行結果を取得します。(Structure用)

structure型のBAPI実行結果（RETURNパラメータ）を取得します。

返却値
Object BAPI実行結果（RETURNパラメータ）が格納された配列
（成功時の返却値は Array になります。）

BAPI実行結果情報オブジェクトの構成は以下のとおりです。
BAPI実行結果情報
オブジェクト
(Object)
TYPE メッセージタイプ (String)
ID メッセージクラス (String)
CODE メッセージコード (String)
NUMBER メッセージ番号 (String)
MESSAGE メッセージテキスト (String)
LOG_NO ログ番号 (String)
LOG_MSG_NO メッセージシリアル番号 (String)
MESSAGE_V1 メッセージ変数 (String)
MESSAGE_V2 メッセージ変数 (String)
MESSAGE_V3 メッセージ変数 (String)
MESSAGE_V4 メッセージ変数 (String)
PARAMETER パラメータ名 (String)
ROW パラメータの行 (String)
FIELD パラメータの項目 (String)
SYSTEM メッセージが発行された論理システム (String)
getReturnCodeTypes

Array getReturnCodeTypes ()

BapiReturn のType情報を取得します。

BapiReturn のType情報を文字列の要素からなるArrayオブジェクトを取得します。
BapiReturn のType情報は、一般的に以下となります。
  • S：正常終了
  • W：警告
  • I：情報
  • E：エラー
※上記のBapiReturn のType情報は、BAPIに依存します。
返却値
Array のType情報
getReturnList

Object getReturnList ()

ＢＡＰＩ実行結果の一覧を取得します。(Table用)

table型のBAPI実行結果（RETURNパラメータ）の一覧を取得します。

返却値
Object BAPI実行結果（RETURNパラメータ）が格納された配列
（成功時の返却値は Array になります。）

BAPI実行結果情報オブジェクトの構成は以下のとおりです。
BAPI実行結果情報
オブジェクト
(Object)
TYPE メッセージタイプ (String)
ID メッセージクラス (String)
CODE メッセージコード (String)
NUMBER メッセージ番号 (String)
MESSAGE メッセージテキスト (String)
LOG_NO ログ番号 (String)
LOG_MSG_NO メッセージシリアル番号 (String)
MESSAGE_V1 メッセージ変数 (String)
MESSAGE_V2 メッセージ変数 (String)
MESSAGE_V3 メッセージ変数 (String)
MESSAGE_V4 メッセージ変数 (String)
PARAMETER パラメータ名 (String)
ROW パラメータの行 (String)
FIELD パラメータの項目 (String)
SYSTEM メッセージが発行された論理システム (String)

取得した銀行情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["TYPE"]　→　配列内のidx番目のBAPI実行結果の「メッセージType」
[idx]["ID"]　→　配列内のidx番目のBAPI実行結果の「メッセージクラス」
[idx]["CODE"]　→　配列内のidx番目のBAPI実行結果の「メッセージコード」
[idx]["NUMBER"]　→　配列内のidx番目のBAPI実行結果の「メッセージ番号」
[idx]["MESSAGE"]　→　配列内のidx番目のBAPI実行結果の「メッセージテキスト」
[idx]["LOG_NO"]　→　配列内のidx番目のBAPI実行結果の「ログ番号」
[idx]["LOG_MSG_NO"]　→　配列内のidx番目のBAPI実行結果の「メッセージシリアル番号」
[idx]["MESSAGE_V1"]　→　配列内のidx番目のBAPI実行結果の「メッセージ変数」
[idx]["MESSAGE_V2"]　→　配列内のidx番目のBAPI実行結果の「メッセージ変数」
[idx]["MESSAGE_V3"]　→　配列内のidx番目のBAPI実行結果の「メッセージ変数」
[idx]["MESSAGE_V4"]　→　配列内のidx番目のBAPI実行結果の「メッセージ変数」
[idx]["PARAMETER"]　→　配列内のidx番目のBAPI実行結果の「パラメータ名」
[idx]["ROW"]　→　配列内のidx番目のBAPI実行結果の「パラメータの行」
[idx]["FIELD"]　→　配列内のidx番目のBAPI実行結果の「パラメータの項目」
[idx]["SYSTEM"]　→　配列内のidx番目のBAPI実行結果の 「メッセージが発行された論理システム」

※ idxは0〜n （配列サイズ-1）
getStructureParam

Object getStructureParam (String paramName)

structure(Export)情報を返します。

入力／出力区分、パラメータ属性、パラメータ名で、
一覧から該当するBapiHashオブジェクトを検索して返します｡
パラメータ
paramName String 検索条件となるParamName
返却値
Object 検索結果となるBapiHash

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
3： 汎用系システムエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getTableParam

Object getTableParam (String paramName)

table(Export)情報を返します。

入力／出力区分、パラメータ属性、パラメータ名で、
一覧から該当するBapiHashオブジェクトを検索し、一覧に格納して返します｡
パラメータ
paramName String 検索条件となるParamName
返却値
Object 検索結果となるBapiHash

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
3： 汎用系システムエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

isSuccess

Object isSuccess ()

ＢＡＰＩ実行が正常に行われたか判定します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(S)であった場合"true"を、
それ以外は"false"を返します｡
返却値
Object 処理結果判定
（成功時の返却値は Boolean になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
3： 汎用系システムエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

putImportParam

Object putImportParam (String key ,String val)

BAPI処理実行パラメータを格納します。

引数に指定された条件でBapiHashオブジェクト
(入力／出力区分="import", パラメータ属性="import") を生成し､
一覧に格納します｡
パラメータ
key | String | BapiHashに設定するHashMapのキー
val | String | BapiHashに設定するHashMapの値
返却値
Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

putStructParam

Object putStructParam (String key ,String val ,String structName)

BAPI処理実行パラメータを格納します。

引数に指定された条件でBapiHashオブジェクト
(入力／出力区分="import", パラメータ属性="structure",パラメータ名=第３引数)を生成し､
一覧に格納します｡
パラメータ
key | String | BapiHashに設定するHashMapのキー
val | String | BapiHashに設定するHashMapの値
structName | String | BapiHashに設定するparamTypeの値
返却値
Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

putTableParam

Object putTableParam (String key ,String val ,String tableName ,Number recordNo)

BAPI処理実行パラメータを格納します。

引数に指定された条件でBapiHashオブジェクト
(入力／出力区分="import", パラメータ属性="table",パラメータ名=第３引数,レコード番号=第４引数)を生成し､
一覧に格納します｡
パラメータ
key | String | BapiHashに設定するHashMapのキー
val | String | BapiHashに設定するHashMapの値
tableName | String | BapiHashに設定するparamTypeの値
recordNo | Number | BapiHashに設定するrecordNoの値
返却値
Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

setAutoCommitConditions

void setAutoCommitConditions (Array autoCommitConditions)

推奨されていません。setIgnoreErrMsgReturnTypes()に置き換えられました。
オートコミットさせる条件を指定します。

BapiReturn のType情報に対して、オートコミットさせる文字列条件を設定します。 autoCommitConditionsのArrayオブジェクトの各要素はString型です。
パラメータ
autoCommitConditions Array オートコミットさせる条件リスト (文字列の要素からなるArrayオブジェクト)
返却値
void
setIgnoreErrMsgReturnTypes

void setIgnoreErrMsgReturnTypes (Array ignoreErrMsgReturnTypes)

エラーメッセージを無視するRETURN-TYPEを設定します。

BapiReturn のType情報に対して、 エラーメッセージを無視するRETURN-TYPEを設定します。 この設定を変更することで、たとえば警告時にもコミットさせることができます。 ignoreErrMsgReturnTypesのArrayオブジェクトの各要素の型は 文字列(String)です。
パラメータ
ignoreErrMsgReturnTypes Array エラーメッセージを無視するRETURN-TYPE値のリスト (文字列の要素からなるArrayオブジェクト)
返却値
void


 ConnectionManager オブジェクト

ConnectionManagerクラス。

SAPへのコネクション(トランザクション)を管理するクラスです。
commitとrollbackの2つのパブリックメソッドを持ち、 業務ロジックの最後に実行することで SAPへの変更を確定/取り消しすることができます。
なお、SAPへのコネクションの開放も上記2メソッド内で実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
ConnectionManager ()
コンストラクタ。
ConnectionManager (SapClient sapClient)
コンストラクタ。
メソッドの概要
Object | commit () ＢＡＰＩ実行結果のCOMMIT処理を行います｡
Object | rollback () ＢＡＰＩ実行結果のROLLBACK処理を行います｡
コンストラクタの詳細
ConnectionManager

ConnectionManager ()
コンストラクタ。
ConnectionManager

ConnectionManager (SapClient sapClient)
コンストラクタ。

SapClientを使用することで、任意の接続先のコネクションを取得します。
なお、複数の登録・更新処理を実行する場合、渡した時点のSapClient内にて 設定した接続先に処理を行います。

【注意】トランザクション制御が記述されているBAPIもあります。 その場合、BapiController#executeBapi()実行後に ここまでのコネクションマネージャーで実行したすべての処理が commitまたはrollbackされます。
※ただし、コネクションはリリースされませんので、 リリースされるようにConnectionManager#commit()または ConnectionManager#rollback()を実行してください。
この振る舞いを変更するには、BAPI自体をカスタマイズする必要があります。
パラメータ
sapClient SapClient Sapクライアント
メソッドの詳細
commit

Object commit ()

ＢＡＰＩ実行結果のCOMMIT処理を行います｡
返却値
Object 空文字列 ""
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
3： 汎用系システムエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

rollback

Object rollback ()

ＢＡＰＩ実行結果のROLLBACK処理を行います｡
返却値
Object 空文字列 ""
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
3： 汎用系システムエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)


 ErrorJSHandler オブジェクト

ＪＳエラーハンドラークラス。

機能は以下の通り
  • ＪＳエラー情報を生成します。
バージョン：1.1
導入されたバージョン：5.0
定数の概要
static String | ERR_CODE_AC_APP_EXCEPTION 財務会計業務系アプリケーションエラー
static String | ERR_CODE_AC_SYSTEM_EXCEPTION 財務会計業務系システムエラー
static String | ERR_CODE_AUTH_APP_EXCEPTION 認証系アプリケーションエラー
static String | ERR_CODE_AUTH_SYSTEM_EXCEPTION 認証系システムエラー
static String | ERR_CODE_FI_APP_EXCEPTION 管理会計業務系アプリケーションエラー
static String | ERR_CODE_FI_SYSTEM_EXCEPTION 管理会計業務系システムエラー
static String | ERR_CODE_GENE_APP_EXCEPTION 汎用系アプリケーションエラー
static String | ERR_CODE_GENE_SYSTEM_EXCEPTION 汎用系システムエラー
static String | ERR_CODE_PU_APP_EXCEPTION 経費購買業務系アプリケーションエラー
static String | ERR_CODE_PU_SYSTEM_EXCEPTION 経費購買業務系システムエラー
static String | ERR_CODE_SD_APP_EXCEPTION 販売管理業務系アプリケーションエラー
static String | ERR_CODE_SD_SYSTEM_EXCEPTION 販売管理業務系ステムエラー
定数の詳細
ERR_CODE_AC_APP_EXCEPTION

static String ERR_CODE_AC_APP_EXCEPTION

財務会計業務系アプリケーションエラー
定数値 ： "6"
ERR_CODE_AC_SYSTEM_EXCEPTION

static String ERR_CODE_AC_SYSTEM_EXCEPTION

財務会計業務系システムエラー
定数値 ： "5"
ERR_CODE_AUTH_APP_EXCEPTION

static String ERR_CODE_AUTH_APP_EXCEPTION

認証系アプリケーションエラー
定数値 ： "2"
ERR_CODE_AUTH_SYSTEM_EXCEPTION

static String ERR_CODE_AUTH_SYSTEM_EXCEPTION

認証系システムエラー
定数値 ： "1"
ERR_CODE_FI_APP_EXCEPTION

static String ERR_CODE_FI_APP_EXCEPTION

管理会計業務系アプリケーションエラー
定数値 ： "10"
ERR_CODE_FI_SYSTEM_EXCEPTION

static String ERR_CODE_FI_SYSTEM_EXCEPTION

管理会計業務系システムエラー
定数値 ： "9"
ERR_CODE_GENE_APP_EXCEPTION

static String ERR_CODE_GENE_APP_EXCEPTION

汎用系アプリケーションエラー
定数値 ： "4"
ERR_CODE_GENE_SYSTEM_EXCEPTION

static String ERR_CODE_GENE_SYSTEM_EXCEPTION

汎用系システムエラー
定数値 ： "3"
ERR_CODE_PU_APP_EXCEPTION

static String ERR_CODE_PU_APP_EXCEPTION

経費購買業務系アプリケーションエラー
定数値 ： "8"
ERR_CODE_PU_SYSTEM_EXCEPTION

static String ERR_CODE_PU_SYSTEM_EXCEPTION

経費購買業務系システムエラー
定数値 ： "7"
ERR_CODE_SD_APP_EXCEPTION

static String ERR_CODE_SD_APP_EXCEPTION

販売管理業務系アプリケーションエラー
定数値 ： "12"
ERR_CODE_SD_SYSTEM_EXCEPTION

static String ERR_CODE_SD_SYSTEM_EXCEPTION

販売管理業務系ステムエラー
定数値 ： "11"


JavaScript API リスト概要

 JavaScript API リスト 概要

スクリプト開発モデルで利用可能なJavaScript API の概要です。

オブジェクトの概要
BapiController | BAPIコントローラクラス。
ConnectionManager | ConnectionManagerクラス。
ErrorJSHandler | ＪＳエラーハンドラークラス。
SapClient | SapClientクラス。
SapClientManager | SAPクライアントマネージャークラス。
SapClientNoLoadBalancing | SapClientNoLoadBalancingクラス。
SapClientPoolNoLoadBalancing | SapClientPoolNoLoadBalancingクラス。
SapClientPoolWithLoadBalancing | SapClientPoolWithLoadBalancingクラス。
SapClientWithLoadBalancing | SapClientWithLoadBalancingクラス。


JavaScript API リスト

 オブジェクト
BapiController
ConnectionManager
ErrorJSHandler
SapClient
SapClientManager
SapClientNoLoadBalancing
SapClientPoolNoLoadBalancing
SapClientPoolWithLoadBalancing
SapClientWithLoadBalancing


 SapClient オブジェクト

SapClientクラス。

  • SAP APサーバーへの接続情報を保持する為の抽象クラス。
    • メソッドの概要
String | getClient () クライアントを取得します。
String | getHost () 接続先IPアドレスを取得します。
String | getIdentifier () コネクションの識別子を取得します。
String | getLang () 言語を取得します。
String | getPasswd () パスワードを取得します。
serverType | getServerType () 設定されているサーバータイプを取得します。
String | getUser () ユーザーを取得します。
void | setClient (String client) クライアントを設定します。
void | setLang (String lang) 言語を設定します。
void | setPasswd (String passwd) パスワードを設定します。
void | setUser (String user) ユーザーを設定します。
    メソッドの詳細
    getClient

    String getClient ()

    クライアントを取得します。
    返却値
    String client 設定したクライアント
    getHost

    String getHost ()

    接続先IPアドレスを取得します。
    返却値
    String host 接続先IPアドレス
    getIdentifier

    String getIdentifier ()

    コネクションの識別子を取得します。

    返却値
    String コネクションの識別子
    getLang

    String getLang ()

    言語を取得します。
    返却値
    String lang 設定した言語
    getPasswd

    String getPasswd ()

    パスワードを取得します。
    返却値
    String passwd 設定したパスワード
    getServerType

    serverType getServerType ()

    設定されているサーバータイプを取得します。
    返却値
    serverType String サーバータイプ
    getUser

    String getUser ()

    ユーザーを取得します。
    返却値
    String user 設定したユーザー
    setClient

    void setClient (String client)

    クライアントを設定します。

    なお、ConnectionPool方式による接続を行う際にクライアントを任意の値に設定した場合、 SapRepositoryManagerによるJCO.Repository管理対象外となります。

    パラメータ
    client String 設定するクライアント
    返却値
    void
    setLang

    void setLang (String lang)

    言語を設定します。
    パラメータ
    lang String 設定する言語
    返却値
    void
    setPasswd

    void setPasswd (String passwd)

    パスワードを設定します。
    パラメータ
    passwd String 設定するパスワード
    返却値
    void
    setUser

    void setUser (String user)

    ユーザーを設定します。
    パラメータ
    user String 設定するユーザー
    返却値
    void


 SapClientManager オブジェクト

SAPクライアントマネージャークラス。

機能は以下の通り。
  • 接続情報初期値を保持したSAPクライアントオブジェクトを取得します。
接続情報設定ファイル sap_auth_info.properties で定義した サーバタイプ をキーに SAPクライアントオブジェクトSapClient を取得します。
以下、接続情報設定ファイル sap_auth_info.properties での定義方法を示します。

現在、以下の２つのコネクションに対応しています。
  • プールコネクション(Pool Connection)
  • ダイレクトコネクション(Direct Connection)
それぞれのコネクションにおいて、非負荷分散環境(No Load Balancing)と負荷分散環境(Load Balancing)への接続設定を行うプロパティは異なります。
以下その４パターンについて設定するプロパティを示します。

[備考]
※接続先が１接続の場合、.サーバタイプ を省略することができます。
※接続先が複数存在する場合は、.サーバタイプ を利用して、複数の接続先を定義することができます。
Pool Connection (No Load Balancing)
パラメータ名 | 説明
jco.client.client.サーバタイプ | SAPにログインする際に使用するクライアント
jco.client.user.サーバタイプ | SAPにログインする際に使用するユーザ
jco.client.passwd.サーバタイプ | SAPにログインする際に使用するパスワード
jco.client.lang.サーバタイプ | SAPにログインする際に使用する言語
jco.client.ashost.サーバタイプ | SAPにログインする際に使用する接続先サーバのIPアドレス（ホスト名）
jco.client.sysnr.サーバタイプ | SAPにログインする際に使用するシステム番号
jco.client.poolsize.サーバタイプ | SAPにログインする際に使用できる、指定したプール内のコネクション数
jco.client.poolname.サーバタイプ | SAPにログインする際に使用する任意のプール名称
jco.client.waittime.サーバタイプ | プール内のコネクションが全て使用中の際に、リリースされたコネクションを取得するために待機する時間(単位:ミリ秒)
jco.client.connectiontimeout.サーバタイプ | プール内で一定時間使用されていないコネクションを自動的にクローズする際の未使用時間(単位:ミリ秒)
jco.client.timeoutcheckperiod.サーバタイプ | プール内で一定時間使用されていないコネクションを自動的にクローズする際に、未使用時間をチェックする間隔(単位:ミリ秒)

Direct Connection (No Load Balancing)
パラメータ名 | 説明
jco.client.client.サーバタイプ | SAPにログインする際に使用するクライアント
jco.client.user.サーバタイプ | SAPにログインする際に使用するユーザ
jco.client.passwd.サーバタイプ | SAPにログインする際に使用するパスワード
jco.client.lang.サーバタイプ | SAPにログインする際に使用する言語
jco.client.ashost.サーバタイプ | SAPにログインする際に使用する接続先サーバのIPアドレス（ホスト名）
jco.client.sysnr.サーバタイプ | SAPにログインする際に使用するシステム番号

Pool Connection (Load Balancing)
パラメータ名 | 説明
jco.client.client.サーバタイプ | SAPにログインする際に使用するクライアント
jco.client.user.サーバタイプ | SAPにログインする際に使用するユーザ
jco.client.passwd.サーバタイプ | SAPにログインする際に使用するパスワード
jco.client.lang.サーバタイプ | SAPにログインする際に使用する言語
jco.client.mshost.サーバタイプ | SAPにログインする際に使用する接続先メッセージサーバIPアドレス（ホスト名）
jco.client.r3name.サーバタイプ | SAPにログインする際に使用するSAP名称
jco.client.group.サーバタイプ | SAPにログインする際に使用するグループID
jco.client.poolsize.サーバタイプ | SAPにログインする際に使用できる、指定したプール内のコネクション数
jco.client.poolname.サーバタイプ | SAPにログインする際に使用する任意のプール名称
jco.client.waittime.サーバタイプ | プール内のコネクションが全て使用中の際に、リリースされたコネクションを取得するために待機する時間(単位:ミリ秒)
jco.client.connectiontimeout.サーバタイプ | プール内で一定時間使用されていないコネクションを自動的にクローズする際の未使用時間(単位:ミリ秒)
jco.client.timeoutcheckperiod.サーバタイプ | プール内で一定時間使用されていないコネクションを自動的にクローズする際に、未使用時間をチェックする間隔(単位:ミリ秒)

Direct Connection (Load Balancing)
パラメータ名 | 説明
jco.client.client.サーバタイプ | SAPにログインする際に使用するクライアント
jco.client.user.サーバタイプ | SAPにログインする際に使用するユーザ
jco.client.passwd.サーバタイプ | SAPにログインする際に使用するパスワード
jco.client.lang.サーバタイプ | SAPにログインする際に使用する言語
jco.client.mshost.サーバタイプ | SAPにログインする際に使用する接続先メッセージサーバIPアドレス（ホスト名）
jco.client.r3name.サーバタイプ | SAPにログインする際に使用するSAP名称
jco.client.group.サーバタイプ | SAPにログインする際に使用するグループID
メソッドの概要
static Object | getSapClient () SapClientオブジェクトの取得を行います。
static Object | getSapClient (String serverType) SapClientオブジェクトの取得を行います。
メソッドの詳細
getSapClient

static Object getSapClient ()

SapClientオブジェクトの取得を行います。
返却値
Object SapClientオブジェクト

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
2： 認証系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getSapClient

static Object getSapClient (String serverType)

SapClientオブジェクトの取得を行います。
また引数にnull値をセットした場合、serverTypeの指定がないSapClientオブジェクト を呼出し元に返却します。
但し、sap_auth_info.propertiesに接続情報が記述されている場合の振る舞いであり、 接続情報が記述されていない場合は、nullのオブジェクトを返却します。

パラメータ
serverType String サーバータイプ
返却値
Object SapClientオブジェクト

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
2： 認証系アプリケーションエラー
詳細はErrorJSHandlerをご覧ください。
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)


 SapClientNoLoadBalancing オブジェクト

SapClientNoLoadBalancingクラス。

非負荷分散環境にて構築されたSAP APサーバーと、 DirectConnection方式を用いた接続を行う為の情報を保持するクラス。
その他設定・取得可能なメソッドは親クラスSapClientを参照してください。
メソッドの概要
String | getAshost () 接続先アプリケーションサーバIPアドレスを取得します。
String | getSysnr () システム番号を取得します。
void | setAshost (String ashost) 接続先アプリケーションサーバIPアドレスを設定します。
void | setSysnr (String sysnr) システム番号を設定します。
メソッドの詳細
getAshost

String getAshost ()

接続先アプリケーションサーバIPアドレスを取得します。
返却値
String ashost 設定した接続先アプリケーションサーバIPアドレス
getSysnr

String getSysnr ()

システム番号を取得します。
返却値
String sysnr 設定したシステム番号
setAshost

void setAshost (String ashost)

接続先アプリケーションサーバIPアドレスを設定します。
パラメータ
ashost String 設定する任意の接続先アプリケーションサーバIPアドレス
返却値
void
setSysnr

void setSysnr (String sysnr)

システム番号を設定します。
パラメータ
sysnr String 設定するシステム番号
返却値
void


 SapClientPoolNoLoadBalancing オブジェクト

SapClientPoolNoLoadBalancingクラス。

非負荷分散環境にて構築されたSAP APサーバーと、 ConnectionPool方式を用いた接続を行う為の情報を保持するクラス。
その他設定・取得可能なメソッドは親クラスSapClientを参照してください。
メソッドの概要
String | getAshost () 接続先アプリケーションサーバIPアドレスを取得します。
Number | getConnectionTimeout () コネクションのタイムアウトを取得します。
String | getPoolName () プール名称を取得します。
Number | getPoolSize () プール内のコネクション数を取得します。
String | getSysnr () システム番号を取得します。
Number | getTimeoutCheckPeriod () コネクションのタイムアウトのチェック間隔を取得します。
Number | getWaitTime () コネクション取得の待機時間を取得します。
メソッドの詳細
getAshost

String getAshost ()

接続先アプリケーションサーバIPアドレスを取得します。
返却値
String ashost 設定した接続先アプリケーションサーバIPアドレス
getConnectionTimeout

Number getConnectionTimeout ()

コネクションのタイムアウトを取得します。
返却値
Number connectionTimeout 設定したコネクションのタイムアウト
getPoolName

String getPoolName ()

プール名称を取得します。
返却値
String poolName 設定したプール名称
getPoolSize

Number getPoolSize ()

プール内のコネクション数を取得します。
返却値
Number poolSize 設定したプール内のコネクション数
getSysnr

String getSysnr ()

システム番号を取得します。
返却値
String sysnr 設定したシステム番号
getTimeoutCheckPeriod

Number getTimeoutCheckPeriod ()

コネクションのタイムアウトのチェック間隔を取得します。
返却値
Number timeoutCheckPeriod 設定したコネクションのタイムアウトのチェック間隔
getWaitTime

Number getWaitTime ()

コネクション取得の待機時間を取得します。
返却値
Number waitTime 設定したコネクション取得の待機時間


 SapClientPoolWithLoadBalancing オブジェクト

SapClientPoolWithLoadBalancingクラス。

  • 負荷分散環境にて構築されたSAP APサーバーへ ConnectionPool方式を用いた接続を行う為の情報を保持するクラス。
    • その他設定・取得可能なメソッドは親クラスSapClientを参照してください。
    メソッドの概要
Number | getConnectionTimeout () コネクションのタイムアウトを取得します。
String | getGroup () グループIDを取得します。
String | getMshost () 接続先メッセージサーバIPアドレスを取得します。
String | getPoolName () プール名称を取得します。
Number | getPoolSize () プール内のコネクション数を取得します。
String | getR3name () SAPシステム名称を取得します。
Number | getTimeoutCheckPeriod () コネクションのタイムアウトのチェック間隔を取得します。
Number | getWaitTime () コネクション取得の待機時間を取得します。
    メソッドの詳細
    getConnectionTimeout

    Number getConnectionTimeout ()

    コネクションのタイムアウトを取得します。
    返却値
    Number connectionTimeout 設定したコネクションのタイムアウト
    getGroup

    String getGroup ()

    グループIDを取得します。
    返却値
    String group 設定したグループID
    getMshost

    String getMshost ()

    接続先メッセージサーバIPアドレスを取得します。
    返却値
    String mshost 設定した接続先メッセージサーバIPアドレス
    getPoolName

    String getPoolName ()

    プール名称を取得します。
    返却値
    String poolName 設定したプール名称
    getPoolSize

    Number getPoolSize ()

    プール内のコネクション数を取得します。
    返却値
    Number poolSize 設定したプール内のコネクション数
    getR3name

    String getR3name ()

    SAPシステム名称を取得します。
    返却値
    String r3name 設定したSAPシステム名称
    getTimeoutCheckPeriod

    Number getTimeoutCheckPeriod ()

    コネクションのタイムアウトのチェック間隔を取得します。
    返却値
    Number timeoutCheckPeriod 設定したコネクションのタイムアウトのチェック間隔
    getWaitTime

    Number getWaitTime ()

    コネクション取得の待機時間を取得します。
    返却値
    Number waitTime 設定したコネクション取得の待機時間


 SapClientWithLoadBalancing オブジェクト

SapClientWithLoadBalancingクラス。

負荷分散環境にて構築されたSAP APサーバーへ ConnectionPool方式を用いた接続を行う為の情報を保持するクラス。
その他設定・取得可能なメソッドは親クラスSapClientを参照してください。
メソッドの概要
String | getGroup () グループIDを取得します。
String | getMshost () 接続先メッセージサーバIPアドレスを取得します。
String | getR3name () SAPシステム名称を取得します。
void | setGroup (String group) グループIDを設定します。
void | setMshost (String mshost) 接続先メッセージサーバIPアドレスを設定します。
void | setR3name (String r3name) SAPシステム名称を設定します。
メソッドの詳細
getGroup

String getGroup ()

グループIDを取得します。
返却値
String group 設定したグループID
getMshost

String getMshost ()

接続先メッセージサーバIPアドレスを取得します。
返却値
String mshost 設定した接続先メッセージサーバIPアドレス
getR3name

String getR3name ()

SAPシステム名称を取得します。
返却値
String r3name 設定したSAPシステム名称
setGroup

void setGroup (String group)

グループIDを設定します。
パラメータ
group String 設定するグループID
返却値
void
setMshost

void setMshost (String mshost)

接続先メッセージサーバIPアドレスを設定します。
パラメータ
mshost String 設定する接続先メッセージサーバIPアドレス
返却値
void
setR3name

void setR3name (String r3name)

SAPシステム名称を設定します。
パラメータ
r3name String 設定するSAPシステム名称
返却値
void


 AccessControllerInfo オブジェクト

アクセスコントローラ情報オブジェクト。

アクセスコントローラ情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

オブジェクト作成方法
 var obj = new Object();
 obj.controllerId = "";
 obj.displayName = "";
 obj.description = "";
オブジェクト作成方法(JSON方式)
    {
      "controllerId" : "",
      "displayName"  : "",
      "description"  : ""
    }

プロパティの概要
String | controllerId [必須] アクセスコントローラID 。 | 通常
String | description 説明 。 | 通常
String | displayName [必須] 表示名 。 | 通常
プロパティの詳細
controllerId

String controllerId

[必須] アクセスコントローラID 。
description

String description

説明 。
displayName

String displayName

[必須] 表示名 。


 AccessControllerManager オブジェクト

アクセスコントローラマネージャオブジェクト。

アクセスコントローラ・モデルの参照、更新を行うマネージャオブジェクトです。

バージョン：1.0
導入されたバージョン：6.1
コンストラクタの概要
AccessControllerManager (String groupId)
JSコンストラクタ。
メソッドの概要
Boolean | addController (AccessControllerInfo controller) アクセスコントローラを新規追加します。
Boolean | addControllerDepartment (String controllerId ,DepartmentInfo department) 組織情報を新規追加します。
Boolean | addControllerPost (String controllerId ,PostInfo post) 役職情報を新規追加します。
Boolean | addControllerPublicGroup (String controllerId ,PublicGroupInfo publicGroup) アクセスコントローラパブリックグループを新規追加します。
Boolean | addControllerRole (String controllerId ,String roleId) アクセスコントローラロールを新規追加します。
Boolean | deleteController (String controllerId) 指定したアクセスコントローラを削除します。
Boolean | deleteControllerDepartment (String controllerId ,DepartmentInfo department) 指定した組織情報を削除します。
Boolean | deleteControllerDepartments (String controllerId) 組織情報を削除します。
Boolean | deleteControllerPost (String controllerId ,PostInfo post) 役職情報を削除します。
Boolean | deleteControllerPosts (String controllerId) 役職情報をすべて削除します。
Boolean | deleteControllerPublicGroup (String controllerId ,PublicGroupInfo publicGroup) 指定したアクセスコントローラパブリックグループを削除します。
Boolean | deleteControllerPublicGroups (String controllerId) アクセスコントローラパブリックグループを削除します。
Boolean | deleteControllerRole (String controllerId ,String roleId) 指定したアクセスコントローラロールを削除します。
Boolean | deleteControllerRoles (String controllerId) アクセスコントローラロールを削除します。
Boolean | deleteControllers () すべてのアクセスコントローラを削除します。
String | exportData (String category) アクセスコントローラのエクスポートを行います。
AccessControllerInfo | getController (String controllerId) 指定されたアクセスコントローラIDに対応するアクセスコントローラを取得します。
Array | getControllerDepartments (String controllerId) 組織情報をすべて取得します。
Array | getControllerIds () すべてのアクセスコントローラIDを取得します。
Array | getControllerIdsByDepartment (Array departments) 指定された組織を持つアクセスコントローラIDをすべて取得します。
Array | getControllerIdsByPost (Array posts) 指定された役職を持つアクセスコントローラIDをすべて取得します。
Array | getControllerIdsByPublicGroup (publicGroups Array) 指定されたパブリックグループを持つアクセスコントローラIDをすべて取得します。
Array | getControllerIdsByRole (Array roleIds) 指定されたロールIDを持つアクセスコントローラIDをすべて取得します。
Array | getControllerIdsByUser (String userId [,Date date]) 指定されたユーザおよび日付で有効なアクセスコントローラIDをすべて取得します。
Array | getControllerPosts (String controllerId) 役職情報を取得します。
Array | getControllerPublicGroups (String controllerId) パブリックグループ情報を取得します。
Array | getControllerRoles (String controllerId) アクセスコントローラロールを取得します。
Array | getControllers () すべてのアクセスコントローラを取得します。
Array | getExportCategories () アクセスコントローラエクスポート用のカテゴリの一覧を取得します。
Array | getImportCategories () アクセスコントローラインポート用のカテゴリの一覧を取得します。
String | getLoginGroupId () ログイングループIDを取得します。
Boolean | importData (String category ,String inputString) アクセスコントローラのインポートを行います。
boolean | isUpdate (Date date) アクセスコントローラ情報が指定された日付よりも後に更新されたかチェックします。
Boolean | updateController (AccessControllerInfo controller) アクセスコントローラを更新します。
コンストラクタの詳細
AccessControllerManager

AccessControllerManager (String groupId)
JSコンストラクタ。
パラメータ
groupId String ログイングループID
メソッドの詳細
addController

Boolean addController (AccessControllerInfo controller)

アクセスコントローラを新規追加します。
パラメータ
controller AccessControllerInfo アクセスコントローラ情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
addControllerDepartment

Boolean addControllerDepartment (String controllerId ,DepartmentInfo department)

組織情報を新規追加します。
パラメータ
controllerId | String | アクセスコントローラID
department | DepartmentInfo | 組織情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
addControllerPost

Boolean addControllerPost (String controllerId ,PostInfo post)

役職情報を新規追加します。
パラメータ
controllerId | String | アクセスコントローラID
post | PostInfo | 役職情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
addControllerPublicGroup

Boolean addControllerPublicGroup (String controllerId ,PublicGroupInfo publicGroup)

アクセスコントローラパブリックグループを新規追加します。
パラメータ
controllerId | String | アクセスコントローラID
publicGroup | PublicGroupInfo | パブリックグループ情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
addControllerRole

Boolean addControllerRole (String controllerId ,String roleId)

アクセスコントローラロールを新規追加します。
パラメータ
controllerId | String | アクセスコントローラID
roleId | String | ロールID
返却値
Boolean true : 成功 / false : 失敗
deleteController

Boolean deleteController (String controllerId)

指定したアクセスコントローラを削除します。
パラメータ
controllerId String アクセスコントローラID
返却値
Boolean true : 成功 / false : 失敗
deleteControllerDepartment

Boolean deleteControllerDepartment (String controllerId ,DepartmentInfo department)

指定した組織情報を削除します。
パラメータ
controllerId | String | アクセスコントローラID
department | DepartmentInfo | 組織情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
deleteControllerDepartments

Boolean deleteControllerDepartments (String controllerId)

組織情報を削除します。
パラメータ
controllerId String アクセスコントローラID
返却値
Boolean true : 成功 / false : 失敗
deleteControllerPost

Boolean deleteControllerPost (String controllerId ,PostInfo post)

役職情報を削除します。
パラメータ
controllerId | String | アクセスコントローラID
post | PostInfo | 役職情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
deleteControllerPosts

Boolean deleteControllerPosts (String controllerId)

役職情報をすべて削除します。
パラメータ
controllerId String アクセスコントローラID
返却値
Boolean true : 成功 / false : 失敗
deleteControllerPublicGroup

Boolean deleteControllerPublicGroup (String controllerId ,PublicGroupInfo publicGroup)

指定したアクセスコントローラパブリックグループを削除します。
パラメータ
controllerId | String | アクセスコントローラID
publicGroup | PublicGroupInfo | パブリックグループ情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
deleteControllerPublicGroups

Boolean deleteControllerPublicGroups (String controllerId)

アクセスコントローラパブリックグループを削除します。
パラメータ
controllerId String アクセスコントローラID
返却値
Boolean true : 成功 / false : 失敗
deleteControllerRole

Boolean deleteControllerRole (String controllerId ,String roleId)

指定したアクセスコントローラロールを削除します。
パラメータ
controllerId | String | アクセスコントローラID
roleId | String | ロールID
返却値
Boolean true : 成功 / false : 失敗
deleteControllerRoles

Boolean deleteControllerRoles (String controllerId)

アクセスコントローラロールを削除します。
パラメータ
controllerId String アクセスコントローラID
返却値
Boolean true : 成功 / false : 失敗
deleteControllers

Boolean deleteControllers ()

すべてのアクセスコントローラを削除します。
返却値
Boolean true : 成功 / false : 失敗
exportData

String exportData (String category)

アクセスコントローラのエクスポートを行います。

パラメータ
category String カテゴリ名
返却値
String String 出力情報
エクスポートに失敗した場合は、nullを返却します。
getController

AccessControllerInfo getController (String controllerId)

指定されたアクセスコントローラIDに対応するアクセスコントローラを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
controllerId String アクセスコントローラID
返却値
AccessControllerInfo アクセスコントローラ情報オブジェクト
getControllerDepartments

Array getControllerDepartments (String controllerId)

組織情報をすべて取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
controllerId String アクセスコントローラID
返却値
Array 組織情報オブジェクトの配列
getControllerIds

Array getControllerIds ()

すべてのアクセスコントローラIDを取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array アクセスコントローラIDの配列
getControllerIdsByDepartment

Array getControllerIdsByDepartment (Array departments)

指定された組織を持つアクセスコントローラIDをすべて取得します。
パラメータ
departments Array 組織情報の配列
返却値
Array アクセスコントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
getControllerIdsByPost

Array getControllerIdsByPost (Array posts)

指定された役職を持つアクセスコントローラIDをすべて取得します。
パラメータ
posts Array 役職情報の配列
返却値
Array アクセスコントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
getControllerIdsByPublicGroup

Array getControllerIdsByPublicGroup (publicGroups Array)

指定されたパブリックグループを持つアクセスコントローラIDをすべて取得します。
パラメータ
Array publicGroups パブリックグループの配列
返却値
Array アクセスコントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
getControllerIdsByRole

Array getControllerIdsByRole (Array roleIds)

指定されたロールIDを持つアクセスコントローラIDをすべて取得します。
パラメータ
roleIds Array ロールIDの配列
返却値
Array アクセスコントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
getControllerIdsByUser

Array getControllerIdsByUser (String userId [,Date date])

指定されたユーザおよび日付で有効なアクセスコントローラIDをすべて取得します。
パラメータ
userId String ユーザID
date Date 日付
指定しない場合は、現在の日付を使用します。
返却値
Array アクセスコントローラIDの配列
すべて存在しない場合は、空文字列を返却します。
getControllerPosts

Array getControllerPosts (String controllerId)

役職情報を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
controllerId String アクセスコントローラID
返却値
Array 役職情報オブジェクトの配列
getControllerPublicGroups

Array getControllerPublicGroups (String controllerId)

パブリックグループ情報を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
controllerId String アクセスコントローラID
返却値
Array {PublicGroupInfo パブリックグループ情報オブジェクト}の配列
getControllerRoles

Array getControllerRoles (String controllerId)

アクセスコントローラロールを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
controllerId String アクセスコントローラID
返却値
Array ロールIDの配列
getControllers

Array getControllers ()

すべてのアクセスコントローラを取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array アクセスコントローラ情報オブジェクトの配列
getExportCategories

Array getExportCategories ()

アクセスコントローラエクスポート用のカテゴリの一覧を取得します。

返却値
Array アクセスコントローラエクスポート用カテゴリの一覧
アクセスコントローラエクスポート用のカテゴリの取得に失敗した場合は、空文字列を返却します。
getImportCategories

Array getImportCategories ()

アクセスコントローラインポート用のカテゴリの一覧を取得します。

返却値
Array アクセスコントローラインポート用カテゴリの一覧
アクセスコントローラインポート用のカテゴリの取得に失敗した場合は、空文字列を返却します。
getLoginGroupId

String getLoginGroupId ()

ログイングループIDを取得します。

取得に失敗した場合は、nullを返却します。
返却値
String ログイングループID
importData

Boolean importData (String category ,String inputString)

アクセスコントローラのインポートを行います。

パラメータ
category | String | カテゴリ名
inputString | String | 入力情報
返却値
Boolean true : 成功 / false : 失敗
isUpdate

boolean isUpdate (Date date)

アクセスコントローラ情報が指定された日付よりも後に更新されたかチェックします。
パラメータ
date Date チェック日付
返却値
boolean 判定結果　更新された : true / 更新されていない ： false
updateController

Boolean updateController (AccessControllerInfo controller)

アクセスコントローラを更新します。
パラメータ
controller AccessControllerInfo アクセスコントローラ情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗


 AccessSecurityManager オブジェクト

セキュリティマネージャオブジェクト。

セキュリティ情報の参照を行うマネージャオブジェクトです。

バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
static String | createUrlSignature (String url ,String groupId ,String userId) ダイレクトＵＲＬ署名を作成します。
static String | decrypt ([String category] ,String secret) 指定された暗号化アルゴリズムカテゴリを利用して暗号化された文字列を復号します。
static String | encrypt ([String category] ,String plane) 指定された暗号化アルゴリズムカテゴリを利用して文字列を暗号化します。
static void | forward (String url) 指定のＵＲＬにフォワードします。
static SessionInfo | getCookieSessionInfo () カレントスレッド情報のクッキーからintra-martセッション情報を取得します。
static String | getErrorPage (int errorCode) カレントスレッド情報からエラーページＵＲＬを取得します。
static String | getInitialPage (Object sessionInfo) カレントスレッド情報から初期アクセスページURLを取得します。
static int | getLoginCertification () カレントスレッド情報からログイン処理を行います。
static String | getMainPage () カレントスレッド情報からメインページURLを取得します。
static String | getMobileUserAgent () モバイル端末の固体識別番号を取得します。
static SessionConfigInfo | getSessionConfig () セッション情報保管パラメータを取得します。
static SessionInfo | getSessionInfo () カレントスレッド情報からintra-martセッション情報を取得します。
static int | getSessionMode () intra-martセッションの状態を取得します。
static void | logout () ログアウト処理を行います。
メソッドの詳細
createUrlSignature

static String createUrlSignature (String url ,String groupId ,String userId)

ダイレクトＵＲＬ署名を作成します。

パラメータ
url | String | ダイレクトＵＲＬ
groupId | String | ログイングループＩＤ
userId | String | ユーザＩＤ
返却値
String ダイレクトURL署名
decrypt

static String decrypt ([String category] ,String secret)

指定された暗号化アルゴリズムカテゴリを利用して暗号化された文字列を復号します。

暗号化アルゴリズムカテゴリは,サーバマネージャ/conf/cryption-config.xmlの
cryptionタグのcategory属性に指定した名称を指定します。

暗号化アルゴリズムカテゴリが存在しない場合は、
暗号化アルゴリズムカテゴリに「default」を指定して再度試みます。

cryption-config.xmlに「default」カテゴリの設定が存在しない場合は、
「default」カテゴリを自動的に作成します。
自動的に作成される「default」カテゴリの暗号化アルゴリズムは jp.co.intra_mart.foundation.security.cryption.StandardCryptionが設定されます。
パラメータ
category | String | 暗号化アルゴリズムカテゴリ
secret | String | 暗号化された文字列
返却値
String 復号化された文字列
encrypt

static String encrypt ([String category] ,String plane)

指定された暗号化アルゴリズムカテゴリを利用して文字列を暗号化します。

暗号化アルゴリズムカテゴリは,サーバマネージャ/conf/cryption-config.xmlの
cryptionタグのcategory属性に指定した名称を指定します。

暗号化アルゴリズムカテゴリが存在しない場合は、
暗号化アルゴリズムカテゴリに「default」を指定して再度試みます。

cryption-config.xmlに「default」カテゴリの設定が存在しない場合は、
「default」カテゴリを自動的に作成します。
自動的に作成される「default」カテゴリの暗号化アルゴリズムは jp.co.intra_mart.foundation.security.cryption.StandardCryption が設定されます。
パラメータ
category | String | 暗号化アルゴリズムカテゴリ
plane | String | 暗号化する文字列
返却値
String 暗号化された文字列
forward

static void forward (String url)

指定のＵＲＬにフォワードします。

urlにはコンテキストパス（'/'）から始まるURLを指定してください。
パラメータ
url String ＵＲＬ
返却値
void
getCookieSessionInfo

static SessionInfo getCookieSessionInfo ()

カレントスレッド情報のクッキーからintra-martセッション情報を取得します。

このメソッドを利用するためには、jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestManagementFilterを
web.xmlにフィルタとして設定する必要があります。
返却値
SessionInfo クッキーに保管されているintra-martセッション情報
セッション情報保管用のクッキーが存在しない場合はnull
getErrorPage

static String getErrorPage (int errorCode)

カレントスレッド情報からエラーページＵＲＬを取得します。

引数で指定したエラーページＵＲＬを返却します。
パラメータ
errorCode int ログインエラーコード
返却値
String エラーページのＵＲＬ
ページが存在しなかった場合は、null
getInitialPage

static String getInitialPage (Object sessionInfo)

カレントスレッド情報から初期アクセスページURLを取得します。

パラメータ
sessionInfo Object intra-martセッションオブジェクト
返却値
String 初期アクセスページURL
getLoginCertification

static int getLoginCertification ()

カレントスレッド情報からログイン処理を行います。

ログイン処理後のページを取得します。

返却値
int ログインエラーコード
getMainPage

static String getMainPage ()

カレントスレッド情報からメインページURLを取得します。

ログイン後のメインページを取得します。

返却値
String メインページURL
ページが存在しなかった場合は、nullを返却します。
getMobileUserAgent

static String getMobileUserAgent ()

モバイル端末の固体識別番号を取得します。

モバイル端末の固体識別番号が取得できなかった場合はnullを返却します。
返却値
String モバイル端末固体識別番号
getSessionConfig

static SessionConfigInfo getSessionConfig ()

セッション情報保管パラメータを取得します。

返却値
SessionConfigInfo セッション情報保管パラメータ情報
getSessionInfo

static SessionInfo getSessionInfo ()

カレントスレッド情報からintra-martセッション情報を取得します。

返却値
SessionInfo intra-martセッション情報
セッションが存在しない場合はnull
getSessionMode

static int getSessionMode ()

intra-martセッションの状態を取得します。

返却値
int セッション状態
初期状態 | SecurityConst.CR_SESSION_INITIAL
ログオン状態 | SecurityConst.CR_SESSION_LOGON
セッション不整合状態 | SecurityConst.CR_SESSION_UNMATCH
セッションタイムアウト状態 | SecurityConst.CR_SESSION_TIMEOUT
logout

static void logout ()

ログアウト処理を行います。

返却値
void


 AccountInfo オブジェクト

アカウント情報オブジェクト。

アカウント情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

オブジェクト作成方法
 var obj = new Object();
 obj.encoding = "";
 obj.goOut = "";
 obj.locale = "";
 obj.lockDate = null;
 obj.loginFailureCount = 0;
 obj.mainPagePatternId = null;
 obj.mobilePassword = "***";
 obj.note = "";
 obj.colorPatternId = null;
 obj.password = "***";
 obj.userId = "user1";
 obj.validEndDate = new Date();
 obj.validStartDate = new Date();
オブジェクト作成方法(JSON方式)
    {
      "encoding" : "",
      "goOut"  : "",
      "locale"  : "",
      "lockDate"  : null,
      "loginFailureCount"  : 0,
      "mainPagePatternId"  : null,
      "mobilePassword"  : "***",
      "note"  : "",
      "colorPatternId"  : null,
      "password"  : "***",
      "userId"  : "user1",
      "validEndDate"  : new Date(),
      "validStartDate"  : new Date()
    }

プロパティの概要
String | colorPatternId カラーパターンID。 | 通常
String | encoding エンコーディング。 | 通常
Boolean | goOut 外出フラグ。 | 通常
String | locale ロケール。 | 通常
Date | lockDate アカウントロック日付。 | 通常
Number | loginFailureCount ログイン失敗回数。 | 通常
String | mainPagePatternId メインページパターンID。 | 通常
String | mobilePassword モバイル用パスワード。 | 通常
String | note 説明。 | 通常
String | password パスワード。 | 通常
String | userId ユーザID。 | 通常
Date | validEndDate 有効終了日。 | 通常
Date | validStartDate 有効開始日。 | 通常
プロパティの詳細
colorPatternId

String colorPatternId

カラーパターンID。
encoding

String encoding

エンコーディング。
goOut

Boolean goOut

外出フラグ。
locale

String locale

ロケール。
lockDate

Date lockDate

アカウントロック日付。
loginFailureCount

Number loginFailureCount

ログイン失敗回数。
mainPagePatternId

String mainPagePatternId

メインページパターンID。
mobilePassword

String mobilePassword

モバイル用パスワード。
note

String note

説明。
password

String password

パスワード。
userId

String userId

ユーザID。
validEndDate

Date validEndDate

有効終了日。
validStartDate

Date validStartDate

有効開始日。


 AccountManager オブジェクト

アカウントマネージャオブジェクト
アカウント情報の参照、更新を行うマネージャオブジェクトです。

バージョン：2.0
導入されたバージョン：2.0
定数の概要
static String | ATTR_MENU_DISPLAY ユーザ属性名: ログイン時のメニュー表示・非表示用。
static String | ATTR_MENU_FOLDER_DISPLAY_METHOD ユーザ属性名: メニューフォルダの表示方法。
static String | ATTR_MOBILE_EASY_LOGIN ユーザ属性名: かんたんログイン用。
static String | ATTR_MOBILE_EASY_LOGIN_NONCE ユーザ属性名: かんたんログインのアクセスキー生成時に必要なNonce用。
static String | ATTR_MY_MENU_POSITION ユーザ属性名: マイメニュー表示位置用。
static String | ATTR_REPORT_LIMIT_DAYS ユーザ属性名: パスワード期限切れ通知用。
static String | CRYPTION_CATEGORY_MOBILE_USER_AGENT 暗号化アルゴリズムカテゴリ: モバイル端末個体識別番号用。
コンストラクタの概要
AccountManager (String groupId)
コンストラクタ。
メソッドの概要
Boolean | addAccount (AccountInfo object) アカウントを新規に登録します。
Boolean | addAccountRole (String userId ,AccountRoleInfo object) アカウントロールを新規追加します。
Boolean | addFavoriteMenu (String userId ,FavoriteMenuInfo object) マイメニューを新規追加します。
Boolean | contains (String userId) アカウントの存在チェックを行います。
Number | count () アカウントの登録数を取得します。
Object | del (String uid [,Array funcs] [,Boolean isTransaction]) 推奨されていません。AccountManager.deleteAccount(String userId) に置き換えられました。
Boolean | deleteAccount (String userId) アカウントを削除します。
Boolean | deleteAccountRole (String userId ,String roleId) アカウントロールを削除します。
Boolean | deleteAccountRoles (String userId) 全てのアカウントロールを削除します。
Boolean | deleteAccounts () すべてのアカウントを削除します。
Boolean | deleteAttribute (String userId ,String name) アカウント属性情報を削除します。
String | exportData (String category) アカウントのエクスポートを行います。
DataForAccount | get (String userId) 推奨されていません。AccountManager.getAccount(String userId) に置き換えられました。
AccountInfo | getAccount (String userId) ユーザIDにマッチしたアカウントを取得します。
Array | getAccountRoleIds (String userId) アカウントロールIDを全て取得します。
Array | getAccountRoles (String userId [,Date date]) アカウントロールを全て取得します。
Array | getAccounts () すべてのアカウントを取得します。
Array | getAccountsByUserIds (Array userIds) 引数のユーザIDのアカウントをすべて取得します。
String | getAttribute (String userId ,String name [,String def]) アカウント属性情報を取得します。
Array | getAttributeNames (String userId) アカウント属性名の一覧を取得します。
Array | getExportCategories () アカウントアカウント用のカテゴリの一覧を取得します。
Array | getFavoriteMenuIds (String userId) マイメニューIDを全て取得します。
Array | getFavoriteMenus (String userId) マイメニューを全て取得します。
Array | getImportCategories () アカウントインポート用のカテゴリの一覧を取得します。
Array | getKeys () 推奨されていません。AccountManager.getUserIds() に置き換えられました。
String | getLoginGroupId () ログイングループIDを取得します。
Array | getRoleIds (String userId ,Date date) アカウントが持つ有効なロールIDを全て取得する。
Array | getUserIds () すべてのアカウントのユーザIDを取得します。
Array | getUserIdsByAccountRole (String roleId) 引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
Array | getUserIdsByAttribute (key String ,value String) アカウント属性情報の値と一致するユーザIDを取得します。
Array | getUserIdsByRole (String roleId ,Date date) 引数で指定したロールを持つすべてのアカウントのユーザIDを取得する。
Boolean | importData (String category ,String str) アカウントのインポートを行います。
boolean | isUpdate (Date date) アカウント情報が指定された日付よりも後に更新されたかチェックします。
Array | searchAccounts (String userId) アカウントのユーザIDを検索してマッチしたアカウント取得します。
Object | set (Object request [,Array funcs] [,Boolean isTransaction]) 推奨されていません。AccountManager.addAccount(Object account) および AccountManager.updateAccount(Object account)に置き換えられました。
Boolean | setAttribute (String userId ,String name ,String value) アカウント属性情報を設定します。
Boolean | updateAccount (AccountInfo account) アカウントを更新します。
Boolean | updateAccountRole (String userId ,AccountRoleInfo accountRole) アカウントロールを更新します。
Boolean | updateFavoriteMenu (String userId ,FavoriteMenuInfo favoriteMenu) マイメニューを更新します。
定数の詳細
ATTR_MENU_DISPLAY

static String ATTR_MENU_DISPLAY

ユーザ属性名: ログイン時のメニュー表示・非表示用。
定数値 ： "im_menu_display"
ATTR_MENU_FOLDER_DISPLAY_METHOD

static String ATTR_MENU_FOLDER_DISPLAY_METHOD

ユーザ属性名: メニューフォルダの表示方法。
定数値 ： "im_menu_folder_display_method"
ATTR_MOBILE_EASY_LOGIN

static String ATTR_MOBILE_EASY_LOGIN

ユーザ属性名: かんたんログイン用。
定数値 ： "im_mobile_easy_login"
ATTR_MOBILE_EASY_LOGIN_NONCE

static String ATTR_MOBILE_EASY_LOGIN_NONCE

ユーザ属性名: かんたんログインのアクセスキー生成時に必要なNonce用。
定数値 ： "im_mobile_easy_login_nonce"
導入されたバージョン：6.1.11
ATTR_MY_MENU_POSITION

static String ATTR_MY_MENU_POSITION

ユーザ属性名: マイメニュー表示位置用。
定数値 ： "im_my_menu_position"
ATTR_REPORT_LIMIT_DAYS

static String ATTR_REPORT_LIMIT_DAYS

ユーザ属性名: パスワード期限切れ通知用。
定数値 ： "im_report_limit_days"
CRYPTION_CATEGORY_MOBILE_USER_AGENT

static String CRYPTION_CATEGORY_MOBILE_USER_AGENT

暗号化アルゴリズムカテゴリ: モバイル端末個体識別番号用。
定数値 ： "mobile-user-agent"
導入されたバージョン：6.1.11
コンストラクタの詳細
AccountManager

AccountManager (String groupId)
コンストラクタ。

指定したログイングループのアカウントマネージャオブジェクトを生成します。
パラメータ
groupId String ログイングループID
導入されたバージョン：2.0
メソッドの詳細
addAccount

Boolean addAccount (AccountInfo object)

アカウントを新規に登録します。

パラメータ
object AccountInfo アカウント情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：5.0
addAccountRole

Boolean addAccountRole (String userId ,AccountRoleInfo object)

アカウントロールを新規追加します。

パラメータ
userId | String | ユーザID
object | AccountRoleInfo | アカウントロール情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：5.0
addFavoriteMenu

Boolean addFavoriteMenu (String userId ,FavoriteMenuInfo object)

マイメニューを新規追加します。

パラメータ
userId | String | ユーザID
object | FavoriteMenuInfo | マイメニュー情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：5.0
contains

Boolean contains (String userId)

アカウントの存在チェックを行います。

パラメータ
userId String ユーザID
返却値
Boolean true : 存在する / false : 存在しない、または情報取得に失敗した場合 * @since 2.0
count

Number count ()

アカウントの登録数を取得します。

返却値
Number アカウント登録数（エラーの場合は-1を返します）
導入されたバージョン：2.0
del

Object del (String uid [,Array funcs] [,Boolean isTransaction])

推奨されていません。AccountManager.deleteAccount(String userId) に置き換えられました。
アカウントを削除します。

パラメータ
uid | String | ユーザID
funcs | Array | 動かしたい関数があれば、パスを配列にいれて渡します。(任意)
isTransaction Boolean DBトランザクションフラグ(任意)
trueの場合 このメソッドの中でDBトランザクションを張る。
falseの場合 このメソッドの中でDBトランザクションを張らない。デフォルトはtrue。
返却値
Object 結果オブジェクトまたは、引数が不正の場合、falseを返却します。
結果オブジェクト getCode() エラーコード
-1 実行エラー
0 成功
その他 各アプリに依存
getMessage() エラーメッセージ
導入されたバージョン：2.0
deleteAccount

Boolean deleteAccount (String userId)

アカウントを削除します。

パラメータ
userId String 削除対象アカウントのユーザID
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：5.0
deleteAccountRole

Boolean deleteAccountRole (String userId ,String roleId)

アカウントロールを削除します。

パラメータ
userId | String | 削除ユーザID
roleId | String | ロールID
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：5.0
deleteAccountRoles

Boolean deleteAccountRoles (String userId)

全てのアカウントロールを削除します。

パラメータ
userId String 削除ユーザID
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：5.0
deleteAccounts

Boolean deleteAccounts ()

すべてのアカウントを削除します。

返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：5.0
deleteAttribute

Boolean deleteAttribute (String userId ,String name)

アカウント属性情報を削除します。
指定された属性名に対する属性情報が存在しない場合は、falseを返却します。

パラメータ
userId | String | ユーザID
name | String | 属性名
返却値
Boolean true : 成功 / false : 失敗
exportData

String exportData (String category)

アカウントのエクスポートを行います。

パラメータ
category String カテゴリ
返却値
String String 出力情報
エクスポートに失敗した場合は、nullを返却します。
導入されたバージョン：5.0
get

DataForAccount get (String userId)

推奨されていません。AccountManager.getAccount(String userId) に置き換えられました。
アカウントを取得します。

パラメータ
userId String ユーザID
返却値
DataForAccount DataForAccountオブジェクト
存在しない場合はnullを返却します。
導入されたバージョン：2.0
getAccount

AccountInfo getAccount (String userId)

ユーザIDにマッチしたアカウントを取得します。

存在しなかった場合および取得に失敗した場合は、nullを返却します。
パラメータ
userId String ユーザID
返却値
AccountInfo アカウント情報オブジェクト
getAccountRoleIds

Array getAccountRoleIds (String userId)

アカウントロールIDを全て取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
userId String ユーザID
返却値
Array アカウントロールIDの配列
導入されたバージョン：5.0
getAccountRoles

Array getAccountRoles (String userId [,Date date])

アカウントロールを全て取得します。

引数dateで有効範囲にあるアカウントロールの一覧を取得します。
引数dateを省略した場合は、すべてのアカウントロールの一覧が返却されます。

取得に失敗した場合は、nullを返却します。
パラメータ
userId | String | ユーザID
date | Date | 対象日付
返却値
Array アカウントロール情報オブジェクトの配列
導入されたバージョン：5.0
getAccounts

Array getAccounts ()

すべてのアカウントを取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array アカウント情報オブジェクトの配列
（データがない場合は空の配列を返します）
導入されたバージョン：5.0
getAccountsByUserIds

Array getAccountsByUserIds (Array userIds)

引数のユーザIDのアカウントをすべて取得します。

引数のユーザIDの一覧の中で存在するアカウントのみを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
userIds Array ユーザIDの配列
返却値
Array アカウント情報オブジェクトの配列
（データがない場合は空の配列を返します）
導入されたバージョン：5.0
getAttribute

String getAttribute (String userId ,String name [,String def])

アカウント属性情報を取得します。
指定された属性が設定されていない場合、デフォルト値が設定されている時はデフォルト値を返却します。
デフォルト値が設定されていない時は、nullを返却します。
また、属性情報の取得に失敗した場合は、nullを返却します。

パラメータ
userId | String | ユーザID
name | String | 属性名
def | String | デフォルト値
返却値
String 属性値
getAttributeNames

Array getAttributeNames (String userId)

アカウント属性名の一覧を取得します。
存在しなかった場合は空の配列、取得に失敗した場合は、nullを返却します。

パラメータ
userId String ユーザID
返却値
Array 属性名の配列
getExportCategories

Array getExportCategories ()

アカウントアカウント用のカテゴリの一覧を取得します。

返却値
Array アカウントアカウント用カテゴリの一覧
アカウントエクスポート用のカテゴリの取得に失敗した場合は、空文字列を返却します。
導入されたバージョン：5.0
getFavoriteMenuIds

Array getFavoriteMenuIds (String userId)

マイメニューIDを全て取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
userId String ユーザID
返却値
Array マイメニューIDの配列
導入されたバージョン：5.0
getFavoriteMenus

Array getFavoriteMenus (String userId)

マイメニューを全て取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
userId String ユーザID
返却値
Array マイメニュー情報オブジェクトの配列
導入されたバージョン：5.0
getImportCategories

Array getImportCategories ()

アカウントインポート用のカテゴリの一覧を取得します。

返却値
Array アカウントインポート用カテゴリの一覧
アカウントインポート用のカテゴリの取得に失敗した場合は、空文字列を返却します。
導入されたバージョン：5.0
getKeys

Array getKeys ()

推奨されていません。AccountManager.getUserIds() に置き換えられました。
ユーザIDをすべて取得します。

返却値
Array ユーザIDの配列。
存在しない場合は空の配列を返却します。
導入されたバージョン：2.0
getLoginGroupId

String getLoginGroupId ()

ログイングループIDを取得します。

返却値
String ログイングループID
導入されたバージョン：5.0
getRoleIds

Array getRoleIds (String userId ,Date date)

アカウントが持つ有効なロールIDを全て取得する。
指定日付でアカウントに紐付く有効なアカウントロールをすべて取得し、
有効なアカウントロールが持つすべてのサブロールを取得して、ロールIDの一覧を返却します。
存在しなかった場合および取得に失敗した場合は、空の配列を返却します。
パラメータ
userId | String | ユーザID
date | Date | 日付
返却値
Array ロールIDの配列
導入されたバージョン：5.0
getUserIds

Array getUserIds ()

すべてのアカウントのユーザIDを取得します。

存在しなかった場合および取得に失敗した場合は、空の配列を返却します。
返却値
Array ユーザIDの配列
導入されたバージョン：5.0
getUserIdsByAccountRole

Array getUserIdsByAccountRole (String roleId)

引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。

引数で指定したアカウントロールを持つアカウントのユーザIDの一覧を返却します。
指定したアカウントロールの階層のチェックはお行いません。
存在しなかった場合および取得に失敗した場合は、空の配列を返却します。
パラメータ
roleId String ロールID
返却値
Array ユーザIDの配列
導入されたバージョン：5.0
getUserIdsByAttribute

Array getUserIdsByAttribute (key String ,value String)

アカウント属性情報の値と一致するユーザIDを取得します。

検索対象の属性キーの値が検索値と等しいユーザIDの一覧を取得します。
存在しなかった場合は空の配列、取得に失敗した場合は、nullを返却します。
パラメータ
String | key | 検索対象の属性キー名
String | value | 検索値
返却値
Array ユーザIDの一覧
getUserIdsByRole

Array getUserIdsByRole (String roleId ,Date date)

引数で指定したロールを持つすべてのアカウントのユーザIDを取得する。 指定したロールIDからすべての親ロールを取得し、
指定日付で有効なアカウントロールを持つアカウントのユーザIDの一覧を返却します。
存在しなかった場合および取得に失敗した場合は、空の配列を返却します。
パラメータ
roleId | String | ロールID
date | Date | 日付
返却値
Array ユーザIDの配列
導入されたバージョン：5.0
importData

Boolean importData (String category ,String str)

アカウントのインポートを行います。

パラメータ
category | String | カテゴリ
str | String | ストリーム
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：5.0
isUpdate

boolean isUpdate (Date date)

アカウント情報が指定された日付よりも後に更新されたかチェックします。
パラメータ
date Date チェック日付
返却値
boolean 判定結果　更新された : true / 更新されていない ： false
searchAccounts

Array searchAccounts (String userId)

アカウントのユーザIDを検索してマッチしたアカウント取得します。
ユーザIDまたはユーザIDの一部をキーとして検索し、マッチしたアカウントを返します。
ただし、以下の文字列を特殊文字列として扱う。
* 0以上の長さの文字列とマッチ
? 1文字の文字列とマッチ

取得に失敗した場合は、nullを返却します。
パラメータ
userId String 検索キー
返却値
Array アカウント情報オブジェクトの配列
（データがない場合は空の配列を返します）
導入されたバージョン：5.0
set

Object set (Object request [,Array funcs] [,Boolean isTransaction])

推奨されていません。AccountManager.addAccount(Object account) および AccountManager.updateAccount(Object account)に置き換えられました。
アカウントを登録します。

引数に指定したユーザIDが既に存在していた場合、上書きします。
request
リクエストオブジェクト 		id ユーザID(String)[必須]
pwd パスワード(String)
mpwd モバイル用パスワード(String)
name ユーザ名(String)[必須]
madrs メールアドレス(String)
mbladrs モバイル用メールアドレス(String)
explan 説明(String)
vldDate 有効期限(Number(ミリ秒))
roles ロールIDの配列(Array)
license ライセンス(あり true/なし false)
apps アプリケーションロール（Array）
favorite マイメニュー（Object） メニューID (プロパティ) sort_no ソート番号 （Number）
alias 表示名（String）
kana ユーザ名カナ(String)
eng ユーザ名英字(String)
tel 電話番号(String)
hndy 携帯電話番号(String)
fax FAX番号(String)
extens 内線電話番号(String)
exFax 内線FAX(String)
cntry_cd 国コード(String)
zip 郵便番号(String)
adrs 住所(String)
madrs2 メールアドレス２(String)
url URL(String)
note 備考(String)
sort_key ソート番号(Number)
mainGp 主所属グループCD(String)
groups 所属グループCDの配列(主所属グループは含めない)(Array)
その他 各アプリに依存
パラメータ
request | Object | 登録画面からのリクエストオブジェクト
funcs | Array | 動かしたい関数があれば、パスを配列にいれて渡す（任意）
isTransaction Boolean DBトランザクションフラグ(任意)
trueの場合 このメソッドの中でDBトランザクションを張る。
falseの場合 このメソッドの中でDBトランザクションを張らない。デフォルトはtrue。
返却値
Object 結果オブジェクトまたは、引数が不正の場合、falseを返却します。
結果オブジェクト
(Object) 		getCode() エラーコード
-1 実行エラー
0 成功
その他 各アプリに依存
getMessage() エラーメッセージ
導入されたバージョン：2.0
setAttribute

Boolean setAttribute (String userId ,String name ,String value)

アカウント属性情報を設定します。
引数で指定した属性名に一致する属性情報が存在しない場合は、新規に登録します。
引数で指定した属性名に一致する属性情報がすでに存在する場合は、指定された属性値で更新します。

パラメータ
userId | String | ユーザID
name | String | 属性名
value | String | 属性値
返却値
Boolean true : 成功 / false : 失敗
updateAccount

Boolean updateAccount (AccountInfo account)

アカウントを更新します。

パラメータ
account AccountInfo アカウント情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：5.0
updateAccountRole

Boolean updateAccountRole (String userId ,AccountRoleInfo accountRole)

アカウントロールを更新します。

パラメータ
userId | String | ユーザID
accountRole | AccountRoleInfo | アカウントロール情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：5.0
updateFavoriteMenu

Boolean updateFavoriteMenu (String userId ,FavoriteMenuInfo favoriteMenu)

マイメニューを更新します。

パラメータ
userId | String | ユーザID
favoriteMenu | FavoriteMenuInfo | マイメニュー情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：5.0


 AccountRoleInfo オブジェクト

アカウントロール情報オブジェクト。

アカウントロール情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

オブジェクト作成方法
 var obj = new Object();
 obj.roleId = "";
 obj.validEndDate = new Date();
 obj.validStartDate = new Date();
オブジェクト作成方法(JSON方式)
    {
      "userId"  : "user1",
      "validEndDate"  : new Date(),
      "validStartDate"  : new Date()
    }

プロパティの概要
String | roleId ロールID。 | 通常
Date | validEndDate 有効終了日。 | 通常
Date | validStartDate 有効開始日。 | 通常
プロパティの詳細
roleId

String roleId

ロールID。
validEndDate

Date validEndDate

有効終了日。

アカウントに付与するロールの有効期間終了日
validStartDate

Date validStartDate

有効開始日。

アカウントに付与するロールの有効期間開始日


 ActiveSessionInfo オブジェクト

アクティブセッション情報オブジェクト。

アクティブセッション情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

バージョン：1.0
導入されたバージョン：6.1
プロパティの概要
Number | expireInterval セッションを保ち続ける最大の時間間隔[秒数] 。 | 通常
String | invalidateLoginType 無効化したユーザのログインタイプ 。 | 通常
Number | invalidateTime 無効化した時刻[GMT1970年1月1日0時からのミリ秒数] 。 | 通常
String | invalidateUserId 無効化したユーザのユーザID 。 | 通常
Number | lastResponseTime 最終応答時刻[GMT1970年1月1日0時からのミリ秒数] 。 | 通常
String | loginGroup ログイングループID 。 | 通常
Number | loginTime ログイン時刻[GMT1970年1月1日0時からのミリ秒数] 。 | 通常
String | loginType ログインタイプ 。 | 通常
Boolean | processing 処理中フラグ 。 | 通常
String | remoteAddr クライアントの IP アドレス 。 | 通常
String | sessionId セッションID 。 | 通常
String | userAgent ブラウザ情報 。 | 通常
String | userId ユーザID 。 | 通常
Boolean | valid セッションの有効性フラグ 。 | 通常
プロパティの詳細
expireInterval

Number expireInterval

セッションを保ち続ける最大の時間間隔[秒数] 。
invalidateLoginType

String invalidateLoginType

無効化したユーザのログインタイプ 。
invalidateTime

Number invalidateTime

無効化した時刻[GMT1970年1月1日0時からのミリ秒数] 。
invalidateUserId

String invalidateUserId

無効化したユーザのユーザID 。
lastResponseTime

Number lastResponseTime

最終応答時刻[GMT1970年1月1日0時からのミリ秒数] 。
loginGroup

String loginGroup

ログイングループID 。
loginTime

Number loginTime

ログイン時刻[GMT1970年1月1日0時からのミリ秒数] 。
loginType

String loginType

ログインタイプ 。
processing

Boolean processing

処理中フラグ 。
remoteAddr

String remoteAddr

クライアントの IP アドレス 。
sessionId

String sessionId

セッションID 。
userAgent

String userAgent

ブラウザ情報 。
userId

String userId

ユーザID 。
valid

Boolean valid

セッションの有効性フラグ 。


 ActiveSessionManager オブジェクト

アクティブセッション管理マネージャクラス。

アクティブなセッション情報を管理するためのクラス。

バージョン：1.0
導入されたバージョン：6.1
コンストラクタの概要
ActiveSessionManager ()
コンストラクタ。
メソッドの概要
Boolean | addActiveSessionInfo (ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報を登録します。
int | count (String groupId) アクティブなすべてのセッション数を取得します。
int | count (String groupId ,String loginType) 引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。
Number | count (String groupId ,String loginType ,String userId) 引数で指定されたユーザのアクティブなすべてのセッション数を取得します。
Boolean | destory (String groupId) アクティブなセッション情報をすべて破棄します。
Object | distinctNavigator (String userAgent) 引数で指定されたユーザエージェント情報から判別してナビゲータ情報を取得します。
String | getActiveSessionBindingListenerSessionName () アクティブなセッション情報を登録・削除するために使用するセッション名を取得します。
ActiveSessionInfo | getActiveSessionInfo (String groupId ,String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を取得します。
Array | getActiveSessionInfos (String groupId) アクティブなすべてのセッション情報を取得します。
Array | getActiveSessionInfos (String groupId ,String loginType) 引数で指定されたログインタイプのアクティブなセッション情報を取得します。
Array | getActiveSessionInfos (String groupId ,String loginType ,String userId) 引数で指定されたユーザのアクティブなセッション情報を取得します。
ActiveSessionInfo | getInvalidatedActiveSessionInfo (String groupId ,String sessionId) 無効化されたアクティブなセッション情報を取得します。
Boolean | hasActiveSessionInfo (String groupId ,String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が存在するかチェックします。
Boolean | invalidate (String groupId ,String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
Boolean | isLogined (String groupId ,String loginType ,String userId) 引数で指定されたユーザがログインしているかどうか判別します。
Boolean | isObservable (String groupId) アクティブセッションの監視を行うかどうか取得します。
Boolean | isValid (String groupId ,String loginType ,String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
Boolean | removeActiveSessionInfo (String groupId ,String sessionId) 引数で指定されたセッションIDのアクティブなセッション情報を削除します。
Array | searchActiveSessionInfosByUserId (String groupId ,String loginType) 引数で指定されたユーザ条件からアクティブなセッション情報を検索します。
Boolean | updateLastResponseTime (ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。
Boolean | updateToProcessing (ActiveSessionInfo activeSessionInfo) 引数で指定されたアクティブなセッション情報の処理が開始したことを記録します。
コンストラクタの詳細
ActiveSessionManager

ActiveSessionManager ()
コンストラクタ。

アクティブセッション管理マネージャオブジェクトを生成します。
導入されたバージョン：6.1
メソッドの詳細
addActiveSessionInfo

Boolean addActiveSessionInfo (ActiveSessionInfo activeSessionInfo)

引数で指定されたアクティブなセッション情報を登録します。
パラメータ
activeSessionInfo ActiveSessionInfo アクティブなセッション情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：6.1
count

int count (String groupId)

アクティブなすべてのセッション数を取得します。
パラメータ
groupId String ログイングループID
返却値
int アクティブなすべてのセッション数(0以上)、情報取得に失敗した場合 -1
導入されたバージョン：6.1
count

int count (String groupId ,String loginType)

引数で指定されたログインタイプのアクティブなすべてのセッション数を取得します。
パラメータ
groupId | String | ログイングループID
loginType | String | ログインタイプ
返却値
int アクティブなすべてのセッション数(0以上)、情報取得に失敗した場合 -1
導入されたバージョン：6.1
count

Number count (String groupId ,String loginType ,String userId)

引数で指定されたユーザのアクティブなすべてのセッション数を取得します。
パラメータ
groupId | String | ログイングループID
loginType | String | ログインタイプ
userId | String | ユーザID
返却値
Number アクティブなすべてのセッション数(0以上)、情報取得に失敗した場合 -1
導入されたバージョン：6.1
destory

Boolean destory (String groupId)

アクティブなセッション情報をすべて破棄します。
パラメータ
groupId String ログイングループID
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：6.1
distinctNavigator

Object distinctNavigator (String userAgent)

引数で指定されたユーザエージェント情報から判別してナビゲータ情報を取得します。
パラメータ
userAgent String ユーザエージェント情報オブジェクト

ユーザエージェント情報オブジェクト
ユーザエージェント
情報オブジェクト
(Object)
 appName ブラウザ名 (String)
返却値
Object ナビゲータ情報
導入されたバージョン：6.1
getActiveSessionBindingListenerSessionName

String getActiveSessionBindingListenerSessionName ()

アクティブなセッション情報を登録・削除するために使用するセッション名を取得します。
返却値
String アクティブなセッション情報を登録・削除するために使用するセッション名
導入されたバージョン：6.1
getActiveSessionInfo

ActiveSessionInfo getActiveSessionInfo (String groupId ,String sessionId)

引数で指定されたセッションIDのアクティブなセッション情報を取得します。

存在しない場合、または取得に失敗した場合は、nullを返却します。
パラメータ
groupId | String | ログイングループID
sessionId | String | セッションID
返却値
ActiveSessionInfo アクティブなセッション情報オブジェクト
存在しない場合、取得に失敗した場合 null
導入されたバージョン：6.1
getActiveSessionInfos

Array getActiveSessionInfos (String groupId)

アクティブなすべてのセッション情報を取得します。

1件も存在しない場合、戻り値は空の配列となります。
配列の並び順はログイン時刻の昇順となります。
取得に失敗した場合は、nullを返却します。
パラメータ
groupId String ログイングループID
返却値
Array アクティブなセッション情報オブジェクトの配列
取得に失敗した場合 null
導入されたバージョン：6.1
getActiveSessionInfos

Array getActiveSessionInfos (String groupId ,String loginType)

引数で指定されたログインタイプのアクティブなセッション情報を取得します。

1件も存在しない場合、戻り値は空の配列となります。
配列の並び順はログイン時刻の昇順となります。
取得に失敗した場合は、nullを返却します。
パラメータ
groupId | String | ログイングループID
loginType | String | ログインタイプ
返却値
Array アクティブなセッション情報オブジェクトの配列
取得に失敗した場合 null
導入されたバージョン：6.1
getActiveSessionInfos

Array getActiveSessionInfos (String groupId ,String loginType ,String userId)

引数で指定されたユーザのアクティブなセッション情報を取得します。

1件も存在しない場合、戻り値は空の配列となります。
配列の並び順はログイン時刻の昇順となります。
取得に失敗した場合は、nullを返却します。
パラメータ
groupId | String | ログイングループID
loginType | String | ログインタイプ
userId | String | ユーザID
返却値
Array アクティブなセッション情報オブジェクトの配列
取得に失敗した場合 null
導入されたバージョン：6.1
getInvalidatedActiveSessionInfo

ActiveSessionInfo getInvalidatedActiveSessionInfo (String groupId ,String sessionId)

無効化されたアクティブなセッション情報を取得します。

存在しない場合、または取得に失敗した場合は、nullを返却します。
パラメータ
groupId | String | ログイングループID
sessionId | String | セッションID
返却値
ActiveSessionInfo アクティブなセッション情報オブジェクト
存在しない場合、取得に失敗した場合 null
導入されたバージョン：6.1
hasActiveSessionInfo

Boolean hasActiveSessionInfo (String groupId ,String sessionId)

引数で指定されたセッションIDのアクティブなセッション情報が存在するかチェックします。
パラメータ
groupId | String | ログイングループID
sessionId | String | セッションID
返却値
Boolean アクティブなセッション情報が存在する場合 true、存在しない場合または処理に失敗した場合 false
導入されたバージョン：6.1
invalidate

Boolean invalidate (String groupId ,String sessionId)

引数で指定されたセッションIDのアクティブなセッション情報を無効化します。
パラメータ
groupId | String | ログイングループID
sessionId | String | セッションID
返却値
Boolean 無効化に成功した場合 true、無効化に失敗した場合 false
導入されたバージョン：6.1
isLogined

Boolean isLogined (String groupId ,String loginType ,String userId)

引数で指定されたユーザがログインしているかどうか判別します。
パラメータ
groupId | String | ログイングループID
loginType | String | ログインタイプ
userId | String | ユーザID
返却値
Boolean true : ログインしている / false : していない、または情報取得に失敗した場合
導入されたバージョン：6.1
isObservable

Boolean isObservable (String groupId)

アクティブセッションの監視を行うかどうか取得します。
パラメータ
groupId String ログイングループID
返却値
Boolean アクティブセッションの監視を行う場合 true
導入されたバージョン：6.1.6
isValid

Boolean isValid (String groupId ,String loginType ,String sessionId)

引数で指定されたセッションIDのアクティブなセッション情報が有効かどうか取得します。
パラメータ
groupId | String | ログイングループID
loginType | String | ログインタイプ
sessionId | String | セッションID
返却値
Boolean true : 有効 / false : 無効、または情報取得に失敗した場合
導入されたバージョン：6.1
removeActiveSessionInfo

Boolean removeActiveSessionInfo (String groupId ,String sessionId)

引数で指定されたセッションIDのアクティブなセッション情報を削除します。
パラメータ
groupId | String | ログイングループID
sessionId | String | セッションID
返却値
Boolean 削除に成功した場合または既に削除されている場合 true、削除に失敗した場合 false
導入されたバージョン：6.1
searchActiveSessionInfosByUserId

Array searchActiveSessionInfosByUserId (String groupId ,String loginType)

引数で指定されたユーザ条件からアクティブなセッション情報を検索します。

ユーザIDに検索条件を指定します。
1件も存在しない場合、戻り値は空の配列となります。
配列の並び順はログイン時刻の昇順となります。
パラメータ
groupId | String | ログイングループID
loginType | String | ログインタイプ
返却値
Array アクティブなセッション情報オブジェクトの配列
取得に失敗した場合 null
導入されたバージョン：6.1
updateLastResponseTime

Boolean updateLastResponseTime (ActiveSessionInfo activeSessionInfo)

引数で指定されたアクティブなセッション情報の最終応答時刻を現在の時刻で更新します。
パラメータ
activeSessionInfo ActiveSessionInfo アクティブなセッション情報オブジェクト
返却値
Boolean 処理に成功した場合 true、存在しない場合または処理に失敗した場合 false
導入されたバージョン：6.1
updateToProcessing

Boolean updateToProcessing (ActiveSessionInfo activeSessionInfo)

引数で指定されたアクティブなセッション情報の処理が開始したことを記録します。
パラメータ
activeSessionInfo ActiveSessionInfo アクティブなセッション情報オブジェクト
返却値
Boolean 処理に成功した場合 true、存在しない場合または処理に失敗した場合 false
導入されたバージョン：6.1


 AdminMenuManager オブジェクト

管理メニューマネージャクラス。

グループ管理者が利用する管理メニュー情報の操作を行います。

バージョン：1.0
導入されたバージョン：5.0
定数の概要
static String | CONTENT_TYPE_IN メニューコンテンツの種類（内部URL）。
static String | CONTENT_TYPE_OUT メニューコンテンツの種類（外部URL）。
static String | MENU_TYPE_FOLDER メニュータイプ（フォルダ）。
static String | MENU_TYPE_ITEM メニュータイプ（アイテム）。
メソッドの概要
static Boolean | addMenuItem (String parentMenuId ,MenuInfo object) メニューを新規追加します。
static Boolean | addMenuLoginGroup (String menuId ,String groupId) 指定したログイングループのアクセス権をメニューに設定します。
static Boolean | deleteMenuItem (String menuId) 指定したメニューを削除します。
static Boolean | deleteMenuItems () メニューを削除します。
static Boolean | deleteMenuLoginGroup (String menuId ,String groupId) 指定したログイングループのアクセス権をメニューから削除します。
static String | exportData (String category) 管理メニューのエクスポートを行います。
static Array | getChildMenuIds (String menuId) 子メニューIDを取得します。
static Array | getExportCategories () 管理メニューエクスポート用のカテゴリの一覧を取得します。
static Array | getFirstMenuIds () メニューのルート（第一階層）に設定されてるメニューIDをすべて取得します。
static Array | getImportCategories () 管理メニューインポート用のカテゴリの一覧を取得します。
static Array | getLoginGroupMenuTree (String groupId) 引数に指定したログイングループのメニュー構成を取得します。
static Array | getMenuIds () すべてのメニューIDを取得します。
static Array | getMenuIdsByLoginGroup (String groupId) 引き数に指定したログイングループが参照可能なメニューIDの一覧を取得します。
static MenuInfo | getMenuItem (String menuId) 指定されたメニューIDに対応するメニューを取得します。
static Array | getMenuItems () すべてのメニューを取得します。
static Array | getMenuItemsByIds (Array menuIds) 引き数に指定したメニューIDに一致するメニューアイテムの一覧を取得します。
static Array | getMenuLoginGroups (String menuId) 引数に指定したメニューを参照可能なログイングループIDの一覧を取得します。
static Array | getMenuTree () メニュー構成を取得します。
static String | getParentMenuId (String menuId) 指定されたメニューの親メニューを取得します。
static Boolean | importData (String category ,String inputString) 管理メニューのインポートを行います。
static Boolean | isAccessControlEnabled (String menuId) メニューアイテムのアクセス権の有無を取得します。
static Boolean | moveMenuItem (MenuInclusionInfo object) メニューを移動します。
static Boolean | setAccessControlEnabled (String menuId ,true accessControl) メニューアイテムに対するアクセス権を設定します。
static Boolean | updateMenuItem (MenuInfo object) メニューを更新します。
定数の詳細
CONTENT_TYPE_IN

static String CONTENT_TYPE_IN

メニューコンテンツの種類（内部URL）。
定数値 ： "in"
CONTENT_TYPE_OUT

static String CONTENT_TYPE_OUT

メニューコンテンツの種類（外部URL）。
定数値 ： "out"
MENU_TYPE_FOLDER

static String MENU_TYPE_FOLDER

メニュータイプ（フォルダ）。
定数値 ： "folder"
MENU_TYPE_ITEM

static String MENU_TYPE_ITEM

メニュータイプ（アイテム）。
定数値 ： "item"
メソッドの詳細
addMenuItem

static Boolean addMenuItem (String parentMenuId ,MenuInfo object)

メニューを新規追加します。
パラメータ
parentMenuId | String | 親メニューID
object | MenuInfo | メニュー情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
addMenuLoginGroup

static Boolean addMenuLoginGroup (String menuId ,String groupId)

指定したログイングループのアクセス権をメニューに設定します。
パラメータ
menuId | String | メニューID
groupId | String | ログイングループID
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：5.1
deleteMenuItem

static Boolean deleteMenuItem (String menuId)

指定したメニューを削除します。
パラメータ
menuId String メニューID
返却値
Boolean true : 成功 / false : 失敗
deleteMenuItems

static Boolean deleteMenuItems ()

メニューを削除します。
返却値
Boolean true : 成功 / false : 失敗
deleteMenuLoginGroup

static Boolean deleteMenuLoginGroup (String menuId ,String groupId)

指定したログイングループのアクセス権をメニューから削除します。
パラメータ
menuId | String | メニューID
groupId | String | ログイングループID
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：5.1
exportData

static String exportData (String category)

管理メニューのエクスポートを行います。

パラメータ
category String カテゴリ名
返却値
String String 出力情報
エクスポートに失敗した場合は、nullを返却します。
getChildMenuIds

static Array getChildMenuIds (String menuId)

子メニューIDを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
menuId String メニューID
返却値
Array 子メニューIDの配列
getExportCategories

static Array getExportCategories ()

管理メニューエクスポート用のカテゴリの一覧を取得します。

返却値
Array 管理メニューエクスポート用のカテゴリの一覧
getFirstMenuIds

static Array getFirstMenuIds ()

メニューのルート（第一階層）に設定されてるメニューIDをすべて取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array メニューIDの配列
getImportCategories

static Array getImportCategories ()

管理メニューインポート用のカテゴリの一覧を取得します。

返却値
Array 管理メニューインポート用カテゴリの一覧
getLoginGroupMenuTree

static Array getLoginGroupMenuTree (String groupId)

引数に指定したログイングループのメニュー構成を取得します。

引数に指定したログイングループで表示権限のあるメニュー構成を返却します。
取得に失敗した場合は、nullを返却します。
パラメータ
groupId String ログイングループID
返却値
Array メニューツリー情報オブジェクトの配列
導入されたバージョン：5.1
getMenuIds

static Array getMenuIds ()

すべてのメニューIDを取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array メニューIDの配列
getMenuIdsByLoginGroup

static Array getMenuIdsByLoginGroup (String groupId)

引き数に指定したログイングループが参照可能なメニューIDの一覧を取得します。
パラメータ
groupId String ログイングループID
返却値
Array メニューIDの一覧
導入されたバージョン：5.1
getMenuItem

static MenuInfo getMenuItem (String menuId)

指定されたメニューIDに対応するメニューを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
menuId String メニューID
返却値
MenuInfo メニュー情報オブジェクト
getMenuItems

static Array getMenuItems ()

すべてのメニューを取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array メニュー情報オブジェクトの配列
getMenuItemsByIds

static Array getMenuItemsByIds (Array menuIds)

引き数に指定したメニューIDに一致するメニューアイテムの一覧を取得します。
パラメータ
menuIds Array メニューIDの配列
返却値
Array メニュー情報オブジェクトの配列
導入されたバージョン：5.1
getMenuLoginGroups

static Array getMenuLoginGroups (String menuId)

引数に指定したメニューを参照可能なログイングループIDの一覧を取得します。
パラメータ
menuId String メニューID
返却値
Array ログイングループIDの一覧
導入されたバージョン：5.1
getMenuTree

static Array getMenuTree ()

メニュー構成を取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array メニューツリー情報オブジェクトの配列
getParentMenuId

static String getParentMenuId (String menuId)

指定されたメニューの親メニューを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
menuId String メニューID
返却値
String 親メニュー
importData

static Boolean importData (String category ,String inputString)

管理メニューのインポートを行います。

パラメータ
category | String | カテゴリ名
inputString | String | 入力情報
返却値
Boolean true : 成功 / false : 失敗
isAccessControlEnabled

static Boolean isAccessControlEnabled (String menuId)

メニューアイテムのアクセス権の有無を取得します。
パラメータ
menuId String メニューID
返却値
Boolean true : アクセス権有効 / false : アクセス権無効
導入されたバージョン：5.1
moveMenuItem

static Boolean moveMenuItem (MenuInclusionInfo object)

メニューを移動します。

パラメータ
object MenuInclusionInfo メニュー内包情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
setAccessControlEnabled

static Boolean setAccessControlEnabled (String menuId ,true accessControl)

メニューアイテムに対するアクセス権を設定します。 アクセス権を有効にすると、ログイングループ毎にアクセス制限を設定可能です。 未設定の場合はアクセス制限を行いません。
パラメータ
menuId | String | メニューID
accessControl | true | : アクセス権有効 / false : アクセス権無効
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：5.1
updateMenuItem

static Boolean updateMenuItem (MenuInfo object)

メニューを更新します。
パラメータ
object MenuInfo メニュー情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗


 ApplicationInfo オブジェクト

アプリケーション情報オブジェクト。

インストールされているアプリケーション情報を参照するためのオブジェクトです。
アプリケーション情報オブジェクトは値を参照することのみ許可されています

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
Boolean | expired 試用期限がきているかどうか 。 | 読込み専用
Number | expiredDate アプリケーションの試用期限の日付 [ms] 。 | 読込み専用
Boolean | free フリーライセンスかどうか 。 | 読込み専用
Number | installDate アプリケーションがインストールされた日付 [ms] 。 | 読込み専用
Array | licenseKeys ライセンスキー。 | 読込み専用
Boolean | limited 使用期限付きライセンスかどうか 。 | 読込み専用
Number | limitedDate 期限付きライセンスの使用期限の日付[ms] 。 | 読込み専用
Number | maxAccount 最大ユーザ数 。 | 読込み専用
Number | maxProcess 最大サーバー数 。 | 読込み専用
String | name アプリケーション名 。 | 読込み専用
String | packageVersion パッケージバーション。 | 読込み専用
Array | serialNumbers シリアル番号 。 | 読込み専用
Array | targetLocales 対象ロケール 。 | 読込み専用
Boolean | trial 試用版かどうか 。 | 読込み専用
String | type アプリケーションタイプ 。 | 読込み専用
String | version バージョン 。 | 読込み専用
メソッドの概要
Array | getProperties (String key) インストール情報を取得します。
String | getProperty (String key) インストール情報を取得します。
プロパティの詳細
expired

Boolean expired (読込み専用プロパティ)

試用期限がきているかどうか 。
expiredDate

Number expiredDate (読込み専用プロパティ)

アプリケーションの試用期限の日付 [ms] 。
free

Boolean free (読込み専用プロパティ)

フリーライセンスかどうか 。
installDate

Number installDate (読込み専用プロパティ)

アプリケーションがインストールされた日付 [ms] 。
licenseKeys

Array licenseKeys (読込み専用プロパティ)

ライセンスキー。
limited

Boolean limited (読込み専用プロパティ)

使用期限付きライセンスかどうか 。
limitedDate

Number limitedDate (読込み専用プロパティ)

期限付きライセンスの使用期限の日付[ms] 。
maxAccount

Number maxAccount (読込み専用プロパティ)

最大ユーザ数 。
maxProcess

Number maxProcess (読込み専用プロパティ)

最大サーバー数 。
name

String name (読込み専用プロパティ)

アプリケーション名 。
packageVersion

String packageVersion (読込み専用プロパティ)

パッケージバーション。
serialNumbers

Array serialNumbers (読込み専用プロパティ)

シリアル番号 。
targetLocales

Array targetLocales (読込み専用プロパティ)

対象ロケール 。
trial

Boolean trial (読込み専用プロパティ)

試用版かどうか 。
type

String type (読込み専用プロパティ)

アプリケーションタイプ 。
version

String version (読込み専用プロパティ)

バージョン 。
メソッドの詳細
getProperties

Array getProperties (String key)

インストール情報を取得します。
キーが存在しない場合はnullを返します。
パラメータ
key String 取得情報のキー
返却値
Array 文字列の配列(String)
getProperty

String getProperty (String key)

インストール情報を取得します。
キーが存在しない場合はnullを返します。
パラメータ
key String 取得情報のキー
返却値
String 文字列


 Batch オブジェクト

推奨されていません。BatchManagerに置き替えられました。
バッチオブジェクト。

バッチ情報の参照および更新を行うオブジェクトです。

バッチ情報オブジェクト
バッチ情報の参照、更新を行う場合に使用するオブジェクトです。
バッチ情報
オブジェクト
(Object)
group 設定グループコード(String)
key バッチＩＤ(String)
name バッチ名称（画面への表示名称）(String)
establish 起動スケジュールデータ(String)
year 年(毎設定の場合には非数を指定) (double)
month 月(毎設定の場合には非数を指定) (double)
date 日(毎設定の場合には非数を指定) (double)
day 曜日(毎設定の場合には非数を指定) (double)
hour 時間(毎設定の場合には非数を指定) (double)
minute 分(毎設定の場合には非数を指定) (double)
second 秒(毎設定の場合には非数を指定) (double)
program 起動プログラム・パス名 (path) (String)
validity 有効無効フラグ (boolean)
language バッチプログラムの記述言語 (String)

バージョン：1.0
導入されたバージョン：2.0
コンストラクタの概要
Batch (String groupId)
推奨されていません。BatchManagerに置き換えられました。
メソッドの概要
Object | elements () 推奨されていません。BatchManager.getBatches() に置き換えられました。
static Array | entries () 推奨されていません。LoginGroupManager.getLoginGroupIds()に置き換えられました。
Array | extinction () 推奨されていません。BatchManager.deleteBatches()に置き換えられました。
Object | get (String key) 推奨されていません。BatchManager.getBatch(String id)に置き換えられました。
Array | keys () 推奨されていません。BatchManager.getBatchIds()に置き換えられました。
Object | remove (String name) 推奨されていません。BatchManager.deleteBatch(String batchId)に置き換えられました。
Object | set (String key ,String name ,Number year ,Number month ,Number date ,Number day ,Number hour ,Number minute ,Number second ,String program ,Boolean validity ,String language) 推奨されていません。BatchManager.addBatch(Object batch)および BatchManager.updateBatch(Object batch)に置き換えられました。 に置き換えられました。
コンストラクタの詳細
Batch

Batch (String groupId)
推奨されていません。BatchManagerに置き換えられました。
コンストラクタ。

パラメータ
groupId String ログイングループID
メソッドの詳細
elements

Object elements ()

推奨されていません。BatchManager.getBatches() に置き換えられました。
バッチ情報の一覧を取得します。

返却値
Object 「バッチID」をキー、「バッチ情報オブジェクト」を値にもつオブジェクト
entries

static Array entries ()

推奨されていません。LoginGroupManager.getLoginGroupIds()に置き換えられました。
ログイングループの一覧を取得します。

取得に失敗した場合は、空の配列を返却します。
返却値
Array ログイングループIDの配列
extinction

Array extinction ()

推奨されていません。BatchManager.deleteBatches()に置き換えられました。
すべてのバッチ情報を削除します。
返却値
Array 削除したバッチ情報オブジェクトの配列
get

Object get (String key)

推奨されていません。BatchManager.getBatch(String id)に置き換えられました。
バッチ設定データを取得します。

バッチIDに該当するバッチ設定データを検索し、返却します。
バッチIDに該当するデータが存在しない場合には nullを返却します。
パラメータ
key String バッチID
返却値
Object バッチ情報オブジェクト
keys

Array keys ()

推奨されていません。BatchManager.getBatchIds()に置き換えられました。
バッチIDの一覧を取得します。

取得に失敗した場合は、空の配列を返却します。
返却値
Array バッチIDの配列
remove

Object remove (String name)

推奨されていません。BatchManager.deleteBatch(String batchId)に置き換えられました。
バッチ情報を削除します。

削除に失敗した場合は、nullを返却します。
パラメータ
name String バッチID
返却値
Object 削除したバッチ情報オブジェクト
set

Object set (String key ,String name ,Number year ,Number month ,Number date ,Number day ,Number hour ,Number minute ,Number second ,String program ,Boolean validity ,String language)

推奨されていません。BatchManager.addBatch(Object batch)および BatchManager.updateBatch(Object batch)に置き換えられました。 に置き換えられました。
バッチ設定データを保存します。

指定のバッチ設定データを指定のキーで保存します。
指定キーが既に存在している場合には、過去データを破棄し 指定データで置き換えます。
時間設定が不要な項目に対しては、非数を指定。
日設定および曜日設定は、同時には指定できません。
引数 lang には以下のどちらかのキーワードを指定。
JavaScript: バッチプログラムがファンクションコンテナ
JAVA : バッチプログラムがクラス
パラメータ
key | String | バッチＩＤ
name | String | バッチ名称（画面への表示名称）
year | Number | 年(毎設定の場合には非数を指定)
month | Number | 月(毎設定の場合には非数を指定)
date | Number | 日(毎設定の場合には非数を指定)
day | Number | 曜日(毎設定の場合には非数を指定)
hour | Number | 時間(毎設定の場合には非数を指定)
minute | Number | 分(毎設定の場合には非数を指定)
second | Number | 秒(毎設定の場合には非数を指定)
program | String | 起動プログラム・パス名 (path)
validity | Boolean | 有効無効フラグ
language | String | バッチプログラムの記述言語
返却値
Object 保存したバッチ情報オブジェクト


 BatchInfo オブジェクト

バッチ情報オブジェクト。

バッチ情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

オブジェクト作成方法
   var obj = new Object();
   obj.id = "";
   obj.name = "";
   obj.description = "";
   obj.programLanguage = BatchManager.LANG_JAVA_SCRIPT ;
   obj.runYear = 0;
   obj.runMonth =-1;
   obj.runDay = -1;
   obj.runDayWeek = -1;
   obj.runHour = -1;
   obj.runMinute = -1;
   obj.runSecond = -1;
   obj.validate = true;
オブジェクト作成方法(JSON方式)
   {
     "id"  : "",
     "name"  : "",
     "description"  : "",
     "programLanguage"  : BatchManager.LANG_JAVA_SCRIPT ,
     "runYear"  : 0,
     "runMonth"  : -1,
     "runDay"  : -1,
     "runDayWeek"  : -1,
     "runHour"  : -1,
     "runMinute"  : -1,
     "runSecond"  : -1,
     "validate"  : true
   }

プロパティの概要
String | description 説明。 | 通常
String | id [必須] バッチID。 | 通常
String | name [必須] バッチ名。 | 通常
String | programLanguage [必須] 実行プログラム言語。 | 通常
String | programPath [必須] 実行プログラムパス。 | 通常
Number | runDay 実行日。 | 通常
Number | runDayWeek 実行曜日。 | 通常
Number | runHour 実行時。 | 通常
Number | runMinute 実行分。 | 通常
Number | runMonth 実行月。 | 通常
Number | runSecond 実行秒。 | 通常
Number | runYear 実行年。 | 通常
Boolean | validate バッチの有効・無効。 | 通常
プロパティの詳細
description

String description

説明。
id

String id

[必須] バッチID。
name

String name

[必須] バッチ名。
programLanguage

String programLanguage

[必須] 実行プログラム言語。

BatchManager.LANG_JAVA_SCRIPT ： JavaScript
BatchManager.LANG_JAVA ： Java
のいずれかです。
programPath

String programPath

[必須] 実行プログラムパス。

実行プログラム言語がJavaScriptである場合は、pages以下のパスです。
実行プログラム言語がjavaである場合は、クラスのフルパッケージ名です。
runDay

Number runDay

実行日。
設定できる値は、-1,１から３１です。
-1を設定した場合は、毎日実行されます。
runDayWeek

Number runDayWeek

実行曜日。

設定できる値は、0(日曜日)から6(土曜日)までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。
実行日(runDay)が設定されいる場合は、この設定は無視されます。
runHour

Number runHour

実行時。

設定できる値は、-1,０から２３です。
-1を設定した場合は、毎時実行されます。
runMinute

Number runMinute

実行分。

設定できる値は、-1,０から５９です。
-1を設定した場合は、毎分実行されます。
runMonth

Number runMonth

実行月。

設定できる値は、-1,１から１２です。
-1を設定した場合は、毎月実行されます。
runSecond

Number runSecond

実行秒。

設定できる値は、-1,０から５９です。
-1を設定した場合は、毎秒実行されます。
runYear

Number runYear

実行年。

設定できる値は、-1,０以上です。
-1を設定した場合は、毎年実行されます。
validate

Boolean validate

バッチの有効・無効。

バッチの有効・無効です。無効の場合は、実行されません。


 BatchManager オブジェクト

バッチマネージャオブジェクト。

バッチ情報を参照、更新することができます。
バージョン：1.0
導入されたバージョン：5.0
定数の概要
static String | LANG_JAVA プログラム言語(JAVA)。
static String | LANG_JAVA_SCRIPT プログラム言語(JavaScript)。
コンストラクタの概要
BatchManager (String groupId)
コンストラクタ。
メソッドの概要
Boolean | addBatch (BatchInfo batch) バッチ情報を新規に追加します。
Boolean | deleteBatch (String batchId) バッチ情報を削除します。
Boolean | deleteBatches () すべてのバッチ情報を削除します。
String | exportData (String category) バッチのエクスポートを行います。
BatchInfo | getBatch (String batchId) バッチ情報を取得します。
Array | getBatchIds () バッチIDの一覧を取得します。
Array | getBatches () すべてのバッチ情報を取得します。
Array | getBatchesByIds (Array batchIds) 引数のバッチIDのバッチ情報をすべて取得します。
Array | getExportCategories () バッチエクスポート用のカテゴリの一覧を取得します。
Array | getImportCategories () バッチインポート用のカテゴリの一覧を取得します。
Boolean | importData (String category ,String inputString) バッチのインポートを行います。
boolean | isUpdate (Date date) バッチ情報が指定された日付よりも後に更新されたかチェックします。
Boolean | updateBatch (BatchInfo batch) バッチ情報を更新します。
定数の詳細
LANG_JAVA

static String LANG_JAVA

プログラム言語(JAVA)。
バッチを実行するプログラム言語の種類。
定数値 ： "JAVA"
LANG_JAVA_SCRIPT

static String LANG_JAVA_SCRIPT

プログラム言語(JavaScript)。
バッチを実行するプログラム言語の種類。
定数値 ： "JavaScript"
コンストラクタの詳細
BatchManager

BatchManager (String groupId)
コンストラクタ。

パラメータ
groupId String ログイングループID
メソッドの詳細
addBatch

Boolean addBatch (BatchInfo batch)

バッチ情報を新規に追加します。

パラメータ
batch BatchInfo バッチ情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
deleteBatch

Boolean deleteBatch (String batchId)

バッチ情報を削除します。

パラメータ
batchId String バッチID
返却値
Boolean true : 成功 / false : 失敗
deleteBatches

Boolean deleteBatches ()

すべてのバッチ情報を削除します。

返却値
Boolean true : 成功 / false : 失敗
exportData

String exportData (String category)

バッチのエクスポートを行います。

パラメータ
category String カテゴリ名
返却値
String 出力情報
エクスポートに失敗した場合は、nullを返却します。
getBatch

BatchInfo getBatch (String batchId)

バッチ情報を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
batchId String バッチID
返却値
BatchInfo バッチ情報オブジェクト
getBatchIds

Array getBatchIds ()

バッチIDの一覧を取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array バッチIDの配列
getBatches

Array getBatches ()

すべてのバッチ情報を取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array バッチ情報オブジェクトの配列
getBatchesByIds

Array getBatchesByIds (Array batchIds)

引数のバッチIDのバッチ情報をすべて取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
batchIds Array バッチIDの配列
返却値
Array バッチ情報オブジェクトの配列

データがない場合は空の配列を返します。
getExportCategories

Array getExportCategories ()

バッチエクスポート用のカテゴリの一覧を取得します。

返却値
Array バッチエクスポート用カテゴリの一覧
バッチエクスポート用のカテゴリの取得に失敗した場合は、空文字列を返却します。
getImportCategories

Array getImportCategories ()

バッチインポート用のカテゴリの一覧を取得します。

返却値
Array バッチインポート用カテゴリの一覧
バッチインポート用のカテゴリの取得に失敗した場合は、空文字列を返却します。
importData

Boolean importData (String category ,String inputString)

バッチのインポートを行います。

パラメータ
category | String | カテゴリ名
inputString | String | 入力情報
返却値
Boolean true : 成功 / false : 失敗
isUpdate

boolean isUpdate (Date date)

バッチ情報が指定された日付よりも後に更新されたかチェックします。
パラメータ
date Date チェック日付
返却値
boolean 判定結果　更新された : true / 更新されていない ： false
updateBatch

Boolean updateBatch (BatchInfo batch)

バッチ情報を更新します。

パラメータ
batch BatchInfo バッチ情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗


 BatchServer オブジェクト

バッチサーバーオブジェクト。
バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
String | getRefresh () Batch Server 現在の設定初期化時間取得メソッド。
Boolean | isConnected () Batch Server 動作チェックメソッド。
Boolean | isRun () Batch Server 動作状態取得メソッド。
Boolean | restart () Batch Server 再起動メソッド。
Boolean | setRefresh (int hour ,int minute ,int second) Batch Server 初期化時間設定メソッド。
Boolean | start () Batch Server 起動メソッド。
Boolean | stop () Batch Server 停止メソッド。
メソッドの詳細
getRefresh

String getRefresh ()

Batch Server 現在の設定初期化時間取得メソッド。

Batch Server の初期化時間を返却します。
Batch Server との通信に失敗した場合は、null を返却。
返却値
String 設定データ
isConnected

Boolean isConnected ()

Batch Server 動作チェックメソッド。
Batch Server への接続状況を確認します。
真値の場合、Batch Server を利用可能。偽値の場合、Batch Server を利用不可能。
返却値
Boolean 真値：サーバー動作中/偽値：サーバーアクセスエラー
isRun

Boolean isRun ()

Batch Server 動作状態取得メソッド。
返却値
Boolean 真値：サーバー動作中/偽値：サーバー休眠中またはサーバーが動作していない
restart

Boolean restart ()

Batch Server 再起動メソッド。
Batch Server に対して再起動要求します。
返却値
Boolean 真値：サーバー再起動/偽値：サーバー再起動失敗
setRefresh

Boolean setRefresh (int hour ,int minute ,int second)

Batch Server 初期化時間設定メソッド。

Batch Server に対して初期化時間の設定をします。
パラメータ
hour | int | 時間
minute | int | 分
second | int | 秒
返却値
Boolean 真値：設定成功/偽値：設定失敗
start

Boolean start ()

Batch Server 起動メソッド。
Batch Server に対して起動要求します。
返却値
Boolean 真値：サーバー起動/偽値：サーバー起動失敗
stop

Boolean stop ()

Batch Server 停止メソッド。
Batch Server に対して停止要求します。
返却値
Boolean 真値：サーバー停止/偽値：サーバー停止失敗


 CalendarDayInfo オブジェクト

カレンダ日付情報オブジェクト。
一日単位のカレンダ情報を表すオブジェクトです。

カレンダ日付情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

カレンダ日付設定情報オブジェクトは値を参照することのみ許可されています

プロパティの概要
String | color 背景色 | 読込み専用
Array | data カレンダー情報オブジェクトの配列。 | 読込み専用
Date | date 対象の日付。 | 読込み専用
Boolean | holiday 休日判定。 | 読込み専用
Number | matchcount 名称設定以外でマッチしたカレンダ情報の数。 | 読込み専用
Boolean | nationalholiday 祝日判定。 | 読込み専用
Boolean | weekday 平日判定。 | 読込み専用
プロパティの詳細
color

String color (読込み専用プロパティ)

背景色
data

Array data (読込み専用プロパティ)

カレンダー情報オブジェクトの配列。
date

Date date (読込み専用プロパティ)

対象の日付。
holiday

Boolean holiday (読込み専用プロパティ)

休日判定。
休日（非稼働日）かどうか判定します。
matchcount

Number matchcount (読込み専用プロパティ)

名称設定以外でマッチしたカレンダ情報の数。
nationalholiday

Boolean nationalholiday (読込み専用プロパティ)

祝日判定。
祝日かどうか判定します。
weekday

Boolean weekday (読込み専用プロパティ)

平日判定。
平日（稼働日）かどうか判定します。


 CalendarInfo オブジェクト

カレンダデータオブジェクト。

カレンダデータオブジェクトは下記のプロパティを持つObject型のオブジェクトです。

オブジェクト作成方法
   var obj = new Object();
   obj.id = "";
   obj.type = CalendarManager.TYPE_CONFIG;
   obj.name = "";
   obj.displayName = new Object();
   obj.displayName["ja"] = "";
   obj.displayName["en"] = "";
   obj.description = "";
   obj.year = 2005;
   obj.month = 1;
   obj.day = 1;
   obj.dayWeek = -1;
   obj.times = -1;
   obj.week = -1;
   obj.color = "#00ffff";
   obj.plugin = "";
   obj.validStartYear = 2000;
   obj.validEndYear = 9999;
オブジェクト作成方法(JSON方式)
    {
      "id"  : "",
      "type"  : CalendarManager.TYPE_CONFIG ,
      "name"  : "",
      "displayName"  : {
        "ja"  : "",
        "en"  : ""
        },
      "description"  : "",
      "year"  : 2005,
      "month"  : 1,
      "day"  : 1,
      "dayWeek"  : -1,
      "times"  : -1,
      "week"  : -1,
      "color"  : "#00ffff",
      "plugin"  : "",
      "validStartYear"  : 2000,
      "validEndYear"  : 9999
    }

プロパティの概要
String | color 背景色。 | 通常
Number | day 日。 | 通常
Number | dayWeek 曜日。 | 通常
String | description 説明。 | 通常
String | displayName データ表示名。 | 通常
String | id [必須] データID。 | 通常
Number | month 月。 | 通常
String | name [必須] データ名。 | 通常
String | plugin プラグインID。 | 通常
Number | times 第ｎ？曜日。 | 通常
String | type [必須] データタイプ。 | 通常
Number | validEndYear 有効終了年。 | 通常
Number | validStartYear 有効開始年。 | 通常
Number | week 第ｎ週。 | 通常
Number | year 年。 | 通常
プロパティの詳細
color

String color

背景色。
day

Number day

日。

設定できる値は、1から31までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。
dayWeek

Number dayWeek

曜日。

設定できる値は、0(日曜日)から6(土曜日)までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。

設定した曜日(日)を特定したい場合は、第ｎ？曜日の設定(times)
または第ｎ週の設定(week)と共に設定してください。
第ｎ？曜日の設定、第ｎ週の設定、共に設定を行わなかった場合は、すべての指定曜日の設定となります。
description

String description

説明。
displayName

String displayName

データ表示名。

displayName[ロケール]で指定したロケールの表示名が取得できます。
id

String id

[必須] データID。

カレンダーデータを一意に識別するIDです。
month

Number month

月。

設定できる値は、1から12までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。
name

String name

[必須] データ名。
plugin

String plugin

プラグインID。

この設定を無効にするにはnullまたは空文字列を設定します。
times

Number times

第ｎ？曜日。

設定できる値は、1から5までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。

曜日の設定(dayWeek) と共に設定すると、日を特定できます。
type

String type

[必須] データタイプ。

設定できる値は、
CalendarManager.TYPE_CONFIG ：名称
CalendarManager.TYPE_HOLIDAY ：休日
CalendarManager.TYPE_NATIONAL_HOLDAY： 祝祭日
CalendarManager.TYPE_WEEKDAY ：非休日
のいずれかです。
上記以外の値が設定された場合は、 CalendarManager.TYPE_CONFIG(名称) に設定されます。
validEndYear

Number validEndYear

有効終了年。

この設定を無効にするには-1を設定します。
validStartYear

Number validStartYear

有効開始年。

この設定を無効にするには-1を設定します。
week

Number week

第ｎ週。

設定できる値は、1から6までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。

曜日の設定(dayWeek) と共に設定すると、日が特定できます。
year

Number year

年。

この設定を無効にするには-1を設定します。


 CalendarManager オブジェクト

カレンダーマネージャオブジェクト。

カレンダーの参照、更新を行うマネージャオブジェクトです。
バージョン：1.0
導入されたバージョン：5.0
定数の概要
static String | TYPE_CONFIG 名称（データタイプの定数）。
static String | TYPE_HOLIDAY 休日（データタイプの定数）。
static String | TYPE_NATIONAL_HOLDAY 祝祭日（データタイプの定数）。
static String | TYPE_WEEKDAY 非休日（データタイプの定数）。
コンストラクタの概要
CalendarManager (String groupId)
コンストラクタ。
メソッドの概要
Boolean | addCalendarInfo (String calendarId ,CalendarInfo object) カレンダーデータを新規に追加します。
Boolean | deleteCalendar (String calendarId) カレンダーを削除します。
Boolean | deleteCalendarInfo (String calendarId ,String dataId) カレンダーデータを削除します。
Boolean | deleteCalendarInfos (String calendarId) すべてのカレンダーデータを削除します。
Boolean | deleteCalendars () すべてのカレンダーを削除します。
String | exportData (String category) カレンダーのエクスポートを行います。
Array | getCalendarIds () すべてのカレンダーIDを取得します。
CalendarInfo | getCalendarInfo (String calendarId ,String dataId) カレンダーデータを取得します。
Array | getCalendarInfoIds (String calendarId) すべてのカレンダーデータIDを取得します。
Array | getCalendarInfos (String calendarId) すべてのカレンダーデータを取得します。
Array | getCalendarInfosByIds (String calendarId ,Object calendarInfoIds) 指定されたカレンダーデータIDに一致するカレンダーデータを取得します。
CalendarDayInfo | getDayInfo (String calendarId ,Date date) 日付に対するカレンダーデータ情報を取得します。
String | getDefaultCalendarId () デフォルトカレンダーIDを取得します。
Array | getExportCategories () カレンダーエクスポート用のカテゴリの一覧を取得します。
Array | getImportCategories () カレンダーインポート用のカテゴリの一覧を取得します。
String | getLoginGroupId () ログイングループIDを取得します。
Array | getMonthInfos (String calendarId ,int year ,int month) 月情報を取得します。
Array | getPluginIds () カレンダーデータプラグインIDの一覧を取得します。
Boolean | importData (String category ,String inputString) カレンダーのインポートを行います。
Boolean | isHoliday (String calendarId ,Date date) 休日かどうか判定します。
Boolean | isNationalHoliday (String calendarId ,Date date) 祝日かどうか判定します。
boolean | isUpdate (String calendarId ,Date date) カレンダーデータが指定された日付よりも後に更新されたかチェックします。
Boolean | isWeekday (String calendarId ,Date date) 平日かどうか判定します。
Boolean | updateCalendarInfo (String calendarId ,CalendarInfo object) カレンダーデータを更新します。
Boolean | validatePlugin (String calendarId ,CalendarInfo calendarInfo ,Date date) カレンダーデータをプラグインで検証します。
定数の詳細
TYPE_CONFIG

static String TYPE_CONFIG

名称（データタイプの定数）。
定数値 ： "config"
TYPE_HOLIDAY

static String TYPE_HOLIDAY

休日（データタイプの定数）。
定数値 ： "holiday"
TYPE_NATIONAL_HOLDAY

static String TYPE_NATIONAL_HOLDAY

祝祭日（データタイプの定数）。
定数値 ： "nationalHoliday"
TYPE_WEEKDAY

static String TYPE_WEEKDAY

非休日（データタイプの定数）。
定数値 ： "weekday"
コンストラクタの詳細
CalendarManager

CalendarManager (String groupId)
コンストラクタ。
パラメータ
groupId String ログイングループID
メソッドの詳細
addCalendarInfo

Boolean addCalendarInfo (String calendarId ,CalendarInfo object)

カレンダーデータを新規に追加します。
パラメータ
calendarId | String | カレンダーID
object | CalendarInfo | カレンダデータオブジェクト
返却値
Boolean true : 成功 / false : 失敗
deleteCalendar

Boolean deleteCalendar (String calendarId)

カレンダーを削除します。
パラメータ
calendarId String カレンダーID
返却値
Boolean true : 成功 / false : 失敗
deleteCalendarInfo

Boolean deleteCalendarInfo (String calendarId ,String dataId)

カレンダーデータを削除します。
パラメータ
calendarId | String | カレンダーID
dataId | String | カレンダーデータID
返却値
Boolean true : 成功 / false : 失敗
deleteCalendarInfos

Boolean deleteCalendarInfos (String calendarId)

すべてのカレンダーデータを削除します。
パラメータ
calendarId String カレンダーID
返却値
Boolean true : 成功 / false : 失敗
deleteCalendars

Boolean deleteCalendars ()

すべてのカレンダーを削除します。
返却値
Boolean true : 成功 / false : 失敗
exportData

String exportData (String category)

カレンダーのエクスポートを行います。

パラメータ
category String カテゴリ名
返却値
String String 出力情報
エクスポートに失敗した場合は、nullを返却します。
getCalendarIds

Array getCalendarIds ()

すべてのカレンダーIDを取得します。
取得に失敗した場合は、nullを返却します。
返却値
Array カレンダーIDの配列
getCalendarInfo

CalendarInfo getCalendarInfo (String calendarId ,String dataId)

カレンダーデータを取得します。
取得に失敗した場合は、nullを返却します。
パラメータ
calendarId | String | カレンダーID
dataId | String | カレンダーデータID
返却値
CalendarInfo カレンダデータオブジェクト
getCalendarInfoIds

Array getCalendarInfoIds (String calendarId)

すべてのカレンダーデータIDを取得します。
取得に失敗した場合は、nullを返却します。
パラメータ
calendarId String カレンダーID
返却値
Array カレンダーデータIDの配列
getCalendarInfos

Array getCalendarInfos (String calendarId)

すべてのカレンダーデータを取得します。
取得に失敗した場合は、nullを返却します。
パラメータ
calendarId String カレンダーID
返却値
Array カレンダデータオブジェクトの配列
getCalendarInfosByIds

Array getCalendarInfosByIds (String calendarId ,Object calendarInfoIds)

指定されたカレンダーデータIDに一致するカレンダーデータを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
calendarId | String | カレンダーID
calendarInfoIds | Object | カレンダーデータIDの配列
返却値
Array カレンダデータオブジェクトの配列
getDayInfo

CalendarDayInfo getDayInfo (String calendarId ,Date date)

日付に対するカレンダーデータ情報を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
calendarId | String | カレンダーID
date | Date | 日付
返却値
CalendarDayInfo カレンダ日付情報オブジェクト
getDefaultCalendarId

String getDefaultCalendarId ()

デフォルトカレンダーIDを取得します。

取得に失敗した場合は、nullを返却します。
返却値
String デフォルトカレンダーID
getExportCategories

Array getExportCategories ()

カレンダーエクスポート用のカテゴリの一覧を取得します。

返却値
Array カレンダーエクスポート用カテゴリの一覧
カレンダーエクスポート用のカテゴリの取得に失敗した場合は、空文字列を返却します。
getImportCategories

Array getImportCategories ()

カレンダーインポート用のカテゴリの一覧を取得します。
返却値
Array カレンダーインポート用カテゴリの一覧
カレンダーインポート用のカテゴリの取得に失敗した場合は、空の配列を返却します。
getLoginGroupId

String getLoginGroupId ()

ログイングループIDを取得します。
返却値
String ログイングループID
getMonthInfos

Array getMonthInfos (String calendarId ,int year ,int month)

月情報を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
calendarId | String | カレンダーId
year | int | year 年
month | int | month 月
返却値
Array カレンダー日付情報オブジェクトの配列
配列の添え字が日に対応します。
添え字[20]は20日の情報になります。
getPluginIds

Array getPluginIds ()

カレンダーデータプラグインIDの一覧を取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array カレンダーデータプラグインIDの配列
importData

Boolean importData (String category ,String inputString)

カレンダーのインポートを行います。

パラメータ
category | String | カテゴリ名
inputString | String | 入力情報
返却値
Boolean true : 成功 / false : 失敗
isHoliday

Boolean isHoliday (String calendarId ,Date date)

休日かどうか判定します。

パラメータ
calendarId | String | カレンダーID
date | Date | 日付
返却値
Boolean 判定結果　true : 休日 / false : 平日
isNationalHoliday

Boolean isNationalHoliday (String calendarId ,Date date)

祝日かどうか判定します。

パラメータ
calendarId | String | カレンダーID
date | Date | 日付
返却値
Boolean 判定結果　true : 祝日 / false : 祝日以外の日
isUpdate

boolean isUpdate (String calendarId ,Date date)

カレンダーデータが指定された日付よりも後に更新されたかチェックします。
パラメータ
calendarId | String | カレンダーID
date | Date | チェック日付
返却値
boolean 判定結果　更新された : true / 更新されていない ： false
isWeekday

Boolean isWeekday (String calendarId ,Date date)

平日かどうか判定します。

パラメータ
calendarId | String | カレンダーID
date | Date | 日付
返却値
Boolean 判定結果 true:平日 / false:休日
updateCalendarInfo

Boolean updateCalendarInfo (String calendarId ,CalendarInfo object)

カレンダーデータを更新します。
パラメータ
calendarId | String | カレンダーID
object | CalendarInfo | カレンダーデータオブジェクト
返却値
Boolean true : 成功 / false : 失敗
validatePlugin

Boolean validatePlugin (String calendarId ,CalendarInfo calendarInfo ,Date date)

カレンダーデータをプラグインで検証します。

カレンダーデータにプラグインの設定がない場合、検証結果は true となります。
パラメータ
calendarId | String | カレンダーID
calendarInfo | CalendarInfo | カレンダーデータオブジェクト
date | Date | 検証する日付
返却値
Boolean カレンダーデータのプラグインでの検証結果


 CategoryInfo オブジェクト

カテゴリ詳細情報オブジェクト。
カテゴリ詳細情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

カテゴリ詳細情報オブジェクトの構成は以下の通りです。
カテゴリ詳細情報オブジェクト
カテゴリ詳細情報
オブジェクト
(Object)
categoryClassCode 分類区分コード (String)
categoryCode 分類コード (String)
notes 備考 (String)
locales 国際化情報 (Object) Locale ID
(ja, en等のロケールID)
(Object) 		name 分類名 (String)

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | categoryClassCode 分類区分コード。 | 通常
String | categoryCode 分類コード。 | 通常
Object | locales 国際化情報。 | 通常
String | locales[ロケール].name ロケール別分類名。 | 通常
String | notes 備考。 | 通常
プロパティの詳細
categoryClassCode

String categoryClassCode

分類区分コード。
categoryCode

String categoryCode

分類コード。
locales

Object locales

国際化情報。
locales[ロケール].name

String locales[ロケール].name

ロケール別分類名。
notes

String notes

備考。


 CategoryManager オブジェクト

CategoryManagerオブジェクト。
カテゴリに関連する情報の更新を行うマネージャオブジェクトです。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
CategoryManager (String user ,String group)
コンストラクタ

メソッドの概要
ResultInfo | addCategoryDetail (CategoryInfo categoryDetail) カテゴリ詳細を登録します。
ResultInfo | deleteCategoryDetail (CategoryInfo categoryDetail) 登録済のカテゴリ詳細を削除します。
ResultInfo | getCategoryDetail (String categoryClassCode ,String categoryCode) 登録済みのカテゴリ詳細情報を取得します。
ResultInfo | getCategoryDetails ([String categoryClassCode]) 登録済みのカテゴリ詳細情報の一覧を取得します。
ResultInfo | updateCategoryDetail (CategoryInfo categoryDetail) 登録済のカテゴリ詳細を更新します。
コンストラクタの詳細
CategoryManager

CategoryManager (String user ,String group)
コンストラクタ

パラメータ
user | String | ログインユーザ
group | String | ログイングループ
メソッドの詳細
addCategoryDetail

ResultInfo addCategoryDetail (CategoryInfo categoryDetail)

カテゴリ詳細を登録します。
パラメータ
categoryDetail CategoryInfo カテゴリ詳細情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
deleteCategoryDetail

ResultInfo deleteCategoryDetail (CategoryInfo categoryDetail)

登録済のカテゴリ詳細を削除します。

指定された分類区分詳細の情報が存在しない場合は処理失敗となります。
パラメータ
categoryDetail CategoryInfo カテゴリ詳細情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
getCategoryDetail

ResultInfo getCategoryDetail (String categoryClassCode ,String categoryCode)

登録済みのカテゴリ詳細情報を取得します。
検索結果は、処理結果オブジェクトの data属性にカテゴリ詳細情報オブジェクト として設定されます。
検索条件に一致するデータが存在しない場合は、data属性に null が設定されます。
パラメータ
categoryClassCode | String | 分類区分コード
categoryCode | String | 分類コード
返却値
ResultInfo 処理結果オブジェクト
導入されたバージョン：6.1
getCategoryDetails

ResultInfo getCategoryDetails ([String categoryClassCode])

登録済みのカテゴリ詳細情報の一覧を取得します。
分類区分コードが省略された場合は、すべての詳細情報を取得します。
検索結果は、処理結果オブジェクトの data属性にカテゴリ詳細情報オブジェクトの配列として設定されます。
検索条件に一致するデータが存在しない場合は、data属性に要素数が 0 の配列 (Array) が設定されます。

取得される詳細情報の国際化情報には、ログインユーザのデフォルト言語の情報のみが設定されます。
パラメータ
categoryClassCode String 分類区分コード
返却値
ResultInfo 処理結果オブジェクト
導入されたバージョン：6.1
updateCategoryDetail

ResultInfo updateCategoryDetail (CategoryInfo categoryDetail)

登録済のカテゴリ詳細を更新します。
パラメータ
categoryDetail CategoryInfo カテゴリ詳細情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト


 Client オブジェクト

セッション情報を取得するオブジェクト。

注意事項

画面A
var obj = new Object();
obj.prop1 = "value1111";
Client.set("key1", obj);

画面B
var obj = Client.get("key1");
obj.prop1 = "value2222"

画面C
var obj = Client.get("key1");
Debug.print(obj.prop1); // 【※１】

上記のように画面A→B→Cと遷移した際に、 【※１】での値に関して、intra-martの製品バージョン により、返却される値が異なります。
  • Ver4.0以降のバージョン：「value2222」
  • Ver3.2以前のバージョン：「value1111」
JumpUPモジュール等でVer3.2以前のプログラムを移行する際はご注意ください。
バージョン：1.0
導入されたバージョン：2.0
メソッドの概要
static Object | get (String key) クライアント固有保存情報を取得します。
static String | identifier () セッションＩＤを取得します。
static Array | keys () 保存キー一覧を取得します。
static void | remove (String key) クライアント固有情報を削除します。
static void | set (String key ,Object value) クライアント固有情報を保存します。
static void | sleep (Number millis) 推奨されていません。このメソッドは推奨されません。代替えメソッドも存在しません。
メソッドの詳細
get

static Object get (String key)

クライアント固有保存情報を取得します。

パラメータ
key String 保存時の保存キーコード
返却値
Object 保存データ
identifier

static String identifier ()

セッションＩＤを取得します。

返却値
String セッションＩＤ
keys

static Array keys ()

保存キー一覧を取得します。

返却値
Array 保存キー一覧
remove

static void remove (String key)

クライアント固有情報を削除します。

パラメータ
key String 保存キーコード
返却値
void
set

static void set (String key ,Object value)

クライアント固有情報を保存します。

セッションにクライアント固有情報を保存します。
保存可能なデータは、プログラム中で自作したオブジェクト（Object,String,Arrayなどのインスタンス）です。

なお、Requestオブジェクト や Module.XXXXオブジェクト 等の、 intra-mart標準の組み込みオブジェクトは保存できません。
パラメータ
key | String | 保存キーコード
value | Object | 保存するデータ
返却値
void
sleep

static void sleep (Number millis)

推奨されていません。このメソッドは推奨されません。代替えメソッドも存在しません。
実行処理を中断します。

指定時間だけ、プログラムの実行を中断します。
時間指定の単位はミリ秒
引数には自然数を指定します。
仕様外の引数指定時の動作は保証外です。
パラメータ
millis Number 中断する時間（ミリ秒）
返却値
void


 ClientTypeInfo オブジェクト

クライアントタイプ情報オブジェクト。

クライアントタイプ情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

プロパティの概要
String | clientType クライアントタイプ。 | 読込み専用
String | displayName クライアントタイプ表示名。 | 読込み専用
プロパティの詳細
clientType

String clientType (読込み専用プロパティ)

クライアントタイプ。
displayName

String displayName (読込み専用プロパティ)

クライアントタイプ表示名。


 ColorPatternInfo オブジェクト

カラーパターン情報オブジェクト。

カラーパターン情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。
プロパティの概要
String | code カラーコード。 | 読込み専用
String | cssFile CSSファイルのパス。 | 読込み専用
String | displayName カラーパターン表示名。 | 読込み専用
String | id カラーパターンID。 | 読込み専用
String | imageFolder イメージフォルダのパス。 | 読込み専用
String | property[キー名] プロパティ値。 | 読込み専用
プロパティの詳細
code

String code (読込み専用プロパティ)

カラーコード。
このカラーパターンをイメージするカラーコードです。
cssFile

String cssFile (読込み専用プロパティ)

CSSファイルのパス。
このカラーパターン用のCSSファイルが格納されているファイルのパスです。
設定中の先頭のCSSファイルのパスを返却します。
コンテキストパスからの相対パスです。
displayName

String displayName (読込み専用プロパティ)

カラーパターン表示名。
このカラーパターンの表示名です。
id

String id (読込み専用プロパティ)

カラーパターンID。
imageFolder

String imageFolder (読込み専用プロパティ)

イメージフォルダのパス。
このカラーパターン用のイメージファイルが格納されているフォルダのパスです。
コンテキストパスからの相対パスです。
property[キー名]

String property[キー名] (読込み専用プロパティ)

プロパティ値。
このカラーパターンのキーに対する属性情報です。


 CompanyCategoryInfo オブジェクト

会社組織分類区分情報オブジェクト。
会社組織分類区分情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

会社組織分類区分情報オブジェクトの構成は以下の通りです。
（なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、 「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。）
会社組織分類区分情報オブジェクト
会社組織分類区分情報
オブジェクト
(Object)
companyCode 会社コード (String)
departmentCode 組織コード (String)
categoryClassCode 分類区分コード (String)
categoryCode 分類コード (String)
terms[0..*] 期間化情報の配列 (Array) startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | categoryClassCode 分類区分コード。 | 通常
String | categoryCode 分類コード。 | 通常
String | companyCode 会社コード。 | 通常
String | departmentCode 組織コード。 | 通常
Array | terms 期間化情報の配列。 | 通常
Date | terms[0..*].endDate 有効期間終了日時。 | 通常
Date | terms[0..*].startDate 有効期間開始日時。 | 通常
プロパティの詳細
categoryClassCode

String categoryClassCode

分類区分コード。
categoryCode

String categoryCode

分類コード。
companyCode

String companyCode

会社コード。
departmentCode

String departmentCode

組織コード。
terms

Array terms

期間化情報の配列。
terms[0..*].endDate

Date terms[0..*].endDate

有効期間終了日時。
terms[0..*].startDate

Date terms[0..*].startDate

有効期間開始日時。


 CompanyDetailInfo オブジェクト

会社詳細情報オブジェクト。
会社詳細情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

会社詳細情報オブジェクトの構成は以下の通りです。
（なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、 「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。）
会社詳細情報オブジェクト
会社情報
オブジェクト
(Object)
companyCode 会社コード (String)
notes 備考 (String)
sortKey ソートキー (Number)
terms[0..*] 期間化情報の配列 (Array) startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)
telephoneNumber 電話番号 (String)
faxNumber FAX番号 (String)
extensionNumber 内線番号 (String)
extensionFaxNumber 内線FAX番号 (String)
countryCode 国コード (String)
zipCode 郵便番号 (String)
emailAddress1 メールアドレス１ (String)
emailAddress2 メールアドレス２ (String)
url URL (String)
locales 期間国際化情報 (Object) Locale ID
(ja, en等のロケールID)
(Object) 		name 会社名 (String)
nameSyllabary 会社名カナ (String)
nameEnglish 会社名英字 (String)
address1 住所１ (String)
address2 住所２ (String)

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | companyCode 会社コード。 | 通常
String | notes 備考。 | 通常
Number | sortKey ソートキー。 | 通常
Array | terms 期間化情報の配列。 | 通常
String | terms[0..*].countryCode 国コード。 | 通常
String | terms[0..*].emailAddress1 メールアドレス１。 | 通常
String | terms[0..*].emailAddress2 メールアドレス２。 | 通常
Date | terms[0..*].endDate 有効期間終了日時。 | 通常
String | terms[0..*].extensionFaxNumber 内線FAX番号。 | 通常
String | terms[0..*].extensionNumber 内線番号。 | 通常
String | terms[0..*].faxNumber FAX番号。 | 通常
Object | terms[0..*].locales 期間国際化情報。 | 通常
String | terms[0..*].locales[ロケール].address1 住所１。 | 通常
String | terms[0..*].locales[ロケール].address2 住所２。 | 通常
String | terms[0..*].locales[ロケール].name 会社名。 | 通常
String | terms[0..*].locales[ロケール].nameEnglish 会社名英字。 | 通常
String | terms[0..*].locales[ロケール].nameSyllabary 会社名カナ。 | 通常
Date | terms[0..*].startDate 有効期間開始日時。 | 通常
String | terms[0..*].telephoneNumber 電話番号。 | 通常
String | terms[0..*].url URL。 | 通常
String | terms[0..*].zipCode 郵便番号。 | 通常
プロパティの詳細
companyCode

String companyCode

会社コード。
notes

String notes

備考。
sortKey

Number sortKey

ソートキー。
terms

Array terms

期間化情報の配列。
terms[0..*].countryCode

String terms[0..*].countryCode

国コード。
terms[0..*].emailAddress1

String terms[0..*].emailAddress1

メールアドレス１。
terms[0..*].emailAddress2

String terms[0..*].emailAddress2

メールアドレス２。
terms[0..*].endDate

Date terms[0..*].endDate

有効期間終了日時。
terms[0..*].extensionFaxNumber

String terms[0..*].extensionFaxNumber

内線FAX番号。
terms[0..*].extensionNumber

String terms[0..*].extensionNumber

内線番号。
terms[0..*].faxNumber

String terms[0..*].faxNumber

FAX番号。
terms[0..*].locales

Object terms[0..*].locales

期間国際化情報。
terms[0..*].locales[ロケール].address1

String terms[0..*].locales[ロケール].address1

住所１。
terms[0..*].locales[ロケール].address2

String terms[0..*].locales[ロケール].address2

住所２。
terms[0..*].locales[ロケール].name

String terms[0..*].locales[ロケール].name

会社名。
terms[0..*].locales[ロケール].nameEnglish

String terms[0..*].locales[ロケール].nameEnglish

会社名英字。
terms[0..*].locales[ロケール].nameSyllabary

String terms[0..*].locales[ロケール].nameSyllabary

会社名カナ。
terms[0..*].startDate

Date terms[0..*].startDate

有効期間開始日時。
terms[0..*].telephoneNumber

String terms[0..*].telephoneNumber

電話番号。
terms[0..*].url

String terms[0..*].url

URL。
terms[0..*].zipCode

String terms[0..*].zipCode

郵便番号。